DedNet Namespace
Spazio dei nomi globali nel quale si trova la definizione della classe DedNetApplication oggetto principale della gerarchia degli oggetti.
Classi
 | Classe | Descrizione
Classe pubblica | AddDataDocEventArgs | Argomento utilizzato nell'evento di post linkaggio del documento all'angrafica.
Classe pubblica | AddExtensionsRecognizerEventArgs | Argomento usato aggiungere delle estensioni al riconoscitore di documenti.
Classe pubblica | AfterSaveEventArgs | Argomento contenente le informazioni relative al post salvataggio.
Classe pubblica | AnagrSelectionDeletedEventArgs | Racchiude le informazioni che riguardano le anagrafiche in eliminazione.
Classe pubblica | BomExplorerAddReplaceDataEventArgs | Argomento utilizzato prima dell'elaborazione di un nuovo valore del lookup edit del bom explorer.
Classe pubblica | BomExplorerButtonClickEventArgs | Argomento utilizzato durante il click su un pulsante personalizzato tramite l'editor delle distinte.
Classe pubblica | BomExplorerContextMenuOpeningEventArgs | Argomento utilizzato prima dell'elaborazione di un nuovo valore del lookup edit del bom explorer.
Classe pubblica | BomExplorerLoadDistEventArgs | Argomento utilizzato prima dell'elaborazione di un nuovo valore del lookup edit del bom explorer.
Classe pubblica | BomManualSettings | Classe contenente tutte le configurazioni per la visualizzazione delle colonne nei form relativi alle distinte
Classe pubblica | CadPriorityExtListEventArgs | Contiene le informazioni per la gestione delle estensioni prioritarie dei vari CAD.
Classe pubblica | ChangingDependencyDocumentEventArgs | Argomento contenente le informazioni per attuare una singola sostituzione.
Classe pubblica | CheckProgrReservedEventArgs | Argomento per l'evento di controllo progressivi riservati.
Classe pubblica | CheckRevAlphabetEventArgs | Argomento per l'evento di gestione del controllo dei caratteri nell'alfabeto.
Classe pubblica | ClassListItemClickEventArgs | Contiene le informazioni necessarie sul click di un elemento del class list.
Classe pubblica | CommAnagEventArgs | Argomento utilizzato per lo scambio di informazioni durante la modifica dei legami tra commessa ed anagrafica.
Classe pubblica | CommDescrOverrideEventArgs | Argomento per gli eventi di validazione della commessa.
Classe pubblica | CommElementCreateDataEventArgs | Argomento utilizzato per lo scambio di informazioni durante il salvataggio della distinta e quindi la creazione di una nuova anagrafica partendo da un elemento di distinta non codificato.
Classe pubblica | CommFileExplorerUpdateEventArgs | Classe usata per calcolare il percorso da visualizzare nell'Esplora Risorse delle commesse.
Classe pubblica | CopyDocumentEventArgs | Racchiude le informazioni che riguardano lo spostamento/rinomina di un documento.
Classe pubblica | CreateMultiLevelBomEventArgs | Contiene la distinta ricambio multilivello
Classe pubblica | CreatingSparePartDrawingEventArgs | Argomento usato per le operazioni di aggiunta/modifica/eliminaizone in DEDDATA.
Classe pubblica | DedBeforeOrAfterEventArgs | Contiene l'indicazione di momento esecuzione comando.
Classe pubblica | DedBomEditCustomControlEventArgs | Argomento utilizzato durante il click su un pulsante personalizzato tramite l'editor delle distinte.
Classe pubblica | DedCommandEventArgs | Argomento contenente le informazioni relative al comando in esecuzione.
Classe pubblica | DedCommCancelEventArgs | Argomento per l'evento di conferma creazione/modifica commessa.
Classe pubblica | DedCommCommandEventArgs | Informazioni per gli eventi dei comdandi di creazione/modifica commessa.
Classe pubblica | DedDataChangedEventArgs | Argomento usato per le operazioni di aggiunta/modifica/eliminaizone in DEDDATA.
Classe pubblica | DedDataMoveEventArgs | Argomento usato per le operazioni di spostamento DEDDATA.
Classe pubblica | DedDistEditSaveEventArgs | Evento chiamato prima e dopo il comando di salvataggio dall'editor delle distinte.
Classe pubblica | DedDistSaveEventArgs | Evento chiamato prima e dopo il comando di salvataggio della distinta.
Classe pubblica | DedECOChangeStateCommandEventArgs | Informazioni per gli eventi dei comdandi di cambio stato ECO.
Classe pubblica | DedECOCommandEventArgs | Informazioni per gli eventi dei comdandi di creazione/modifica ECO.
Classe pubblica | DedEventArgs | Argomento contenente le informazioni relative al comando in esecuzione.
Classe pubblica | DedNetApplication | Classe principale che espone alle altre applicazioni tutte le funzionalità ed i comandi e soprattutto le finestre di dialogo.
Classe pubblica | DedNotifyEventArgs | Argomento per l'evento di gestione delle notifiche.
Classe pubblica | DedOpenCommandEventArgs | Argomento per informazioni relative al comando di apertura.
Classe pubblica | DedOpenDocumentEventArgs | Argomento contenente le informazioni relative all'apertura del documento e la relativa anagrafica.
Classe pubblica | DedTranslationChangedEventArgs | Argomento usato per le operazioni di aggiunta/modifica/eliminaizone in DEDDATA.
Classe pubblica | DedTreeViewEventArgs | Argomento utilizzato per comunicare la lista delle famiglie selezionate nei vari eventi.
Classe pubblica | DependencyFileInfoEventArgs | Racchiude le informazioni che riguardano le dipendenze di un file. Viene utilizzato per determinare le dipendenze di un file quando questo non è ancora stato inserito del Database.
Classe pubblica | DisableAutoUpdateAnagrCommEventArgs | Classe usata per gestire la disabilitazione dell'aggiornamento automatico delle revisioni delle anagrafiche di commessa
Classe pubblica | DistAddNodeEventArgs | Argomento utilizzato quando viene aggiunto un nodo alla distinta tramite l'editor delle distinte.
Classe pubblica | DistChangeFieldValueEventArgs | Argomento utilizzato durante l'uscita da una cella di distinta tramite l'editor delle distinte.
Classe pubblica | DistCloneDataEventArgs | Argomento utilizzato durante la clonazione della distinta da DEDAPI.DuplicaDistinta.
Classe pubblica | DistCopyDataEventArgs | Argomento utilizzato durente la copia di un anagrafica dal pannello di dx a quello di sx tramite l'editor delle distinte.
Classe pubblica | DistDragElementEventArgs | Argomento utilizzato durente l'inserimento di un elemento dall'inizia parte veloce in distinta tramite l'editor delle distinte.
Classe pubblica | DistElementCreateDataEventArgs | Argomento utilizzato per lo scambio di informazioni durante il salvataggio della distinta e quindi la creazione di una nuova anagrafica partendo da un elemento di distinta non codificato.
Classe pubblica | DistItemCreateDataEventArgs | Argomento utilizzato per lo scambio di informazioni durante il salvataggio della distinta e quindi la creazione di una nuova anagrafica partendo da un elemento di distinta non codificato.
Classe pubblica | DocOperationEventArgs | Argomento utilizzato per le operazioni sui documenti.
Classe pubblica | DocRegognizerClientsEventArgs | Argomento per l'evento di specializzazione lista file nel form di riconoscimento dei file
Classe pubblica | DocStructInfoEventArgs | Argomento utilizzato per determinare la versione del documento sulla sua creazione o aggiornamento.
Classe pubblica | DocumentCheckLockedEventArgs | Evento chiamato nell'esure local quando controlla se il file è locked
Classe pubblica | DocumentDisableEventArgs | Argomento utilizzato per determinare la visulizzazione del documento nel controllo documentale.
Classe pubblica | DocumentDisconnectingEventArgs | Racchiude le informazioni che riguardano il comando di Disconnessione documento dall'anagrafica.
Classe pubblica | DocumentDragDropEventArgs |
Classe pubblica | DocumentEventArgs | Argomento utilizzato per determinare la versione del documento sulla sua creazione o aggiornamento.
Classe pubblica | DocumentImportingEventArgs | Racchiude le informazioni che riguardano l'importazione di un file come documento da associare ad una anagrafica.
Classe pubblica | DocumentLinkingEventArgs | Racchiude le informazioni che riguardano il comando di Link documento all'anagrafica.
Classe pubblica | DocumentMovingEventArgs | Racchiude le informazioni che riguardano l'operazione di moving su elemento
Classe pubblica | DocumentRecognizingEventArgs | Racchiude le informazioni che riguardano il riconoscimento di un file come documento da associare ad una anagrafica.
Classe pubblica | DocumentsEventArgs | Argomento di elaborazione lista dei documenti
Classe pubblica | DragDropEventArgs |
Classe pubblica | DrawIconEventArgs | Classe usata per impostare l'icona da visualizzare nell'albero.
Classe pubblica | EditAttrEventArgs | Argomento contenente le informazioni relative all'editazione dell'anagrafica.
Classe pubblica | EditAttrValidatingEventArgs | Argomento per validare l'anagrafica in editazione.
Classe pubblica | ElaborateDedListEventArgs | Racchiude le informazioni che riguardano l'elaborazione delle liste personalizzate
Classe pubblica | EvaluateNewValueEventArgs | Contiene le informazioni necessarie alla correzione di un codice digitato dall'utente nella finestra di ricerca veloce, che non è presente nel Database. Il chiamato può impostare il valore sostitutivo da mettere nel controllo per agevolare l'utente.
Classe pubblica | ExportDataEventArg | Contiene le informazioni per la gestione dell'esportazione.
Classe pubblica | ExportResultBomCompareEventArgs | Classe usata per gestire il risultato del confronto tra distinte. Usato nell'evento del tasto 'Esporta'
Classe pubblica | FamDescrOverrideEventArgs | Argomento per gli eventi di validazione della famiglia.
Classe pubblica | FillAttributeListFilterEventArgs | Argomento per evento filtraggio attributi con criteri utente
Classe pubblica | FindCodeMultipleResultsEventArgs | Argomento contenente le informazioni relative alle anagrafiche multiple in fas di apri veloce con ricerca su Invio.
Classe pubblica | FindCodeStateFilterEventArgs | Argomento per evento filtraggio stati anagrafica lista findcode form
Classe pubblica | FolderDisableEventArgs | Argomento utilizzato per determinare la visulizzazione della cartella nel controllo documentale.
Classe pubblica | FtpClientConnectionEventArgs |
Classe pubblica | GetDocPropertiesEventArgs | Classe usata per ricavare le proprietà di una lista di file.
Classe pubblica | GetRepresentationSuffixListEventArgs | Classe usata per gestire l'importazione della lista di suffissi tra cui scegliere in creazione di una Rappresentazione.
Classe pubblica | ImportAttListEventArgs | Classe usata per gestire l'importazione delle liste att da fonti dati esterne.
Classe pubblica | ImportAttrValueEventArgs | Classe usata per gestire l'importazione del valore attributo da fonti dati esterne.
Classe pubblica | ImportDataCanUpdateEventArgs | Classe usate per gestire l'anagrafica da aggiornare nel comando Importa Dati
Classe pubblica | ImportedDocStructInfoEventArgs | Argomento utilizzato nell'evento di post importazione elemento sull'angrafica.
Classe pubblica | ImportOnSaveEventArgs | Argomento utilizzato per l'evento di salvataggio in caso di documenti appartenenti a root presenti nella variabile ROOTS_RECOGNIZED_ON_DBSAVE.
Classe pubblica | ListImportDataEventArgs | Classe usata per gestire la validazione di un codice durante l'importazione in una lista
Classe pubblica | LoadFormCommEditEventArgs | Argomento per l'evento di visualizzazione del form di editazione delle commesse.
Classe pubblica | ManagePlaceHolderEventArgs | Informazioni per l'override della logica dei placeholder.
Classe pubblica | ManageSelectionDocsEventArgs | Racchiude le informazioni che riguardano la selezione dei documenti
Classe pubblica | MoveDocumentEventArgs | Racchiude le informazioni che riguardano lo spostamento/rinomina di un documento.
Classe pubblica | MoveDocumentInfo | Oggetto contenente le informazioni dell'oggetto su cui fare il moved
Classe pubblica | MoveDocumentInfoForcedMoveInfo | Eventuali dati forzati
Classe pubblica | MoveDocumentResult | Oggetto che rappresenta il risultato del move
Classe pubblica | MultipleStateChangeExecuteEventArgs | Raccoglie le informazioni per interrompere le operazioni di Rilascio/Lavorazione multiplo
Classe pubblica | MyDragDropEventArgs | Classe usata per gestire gli eventi del drag drop.
Classe pubblica | MyDragDropNodeEventArgs | Classe usata per gestire gli eventi del drag drop.
Classe pubblica | NewAnagrCancelEventArgs | Argomento per gli eventi di conferma creazione nuova anagrafica.
Classe pubblica | NewAnagrEventArgs | Argomento per gli eventi di creazione nuova anagrafica, contenente le diverse informazioni sul tipo di comando ed il suo stato.
Classe pubblica | NoteTransferPackEventArgs | Evento che permette di inserire una Nota nel trasfer pack con gestione della visualizzazione della finestra di inserimento Note
Classe pubblica | OverrideAttListEventArgs | Argomento contenente le informazioni relative alla lista valori associata ad uno specifico attributo.
Classe pubblica | OverrideAttrEventArgs | Argomento contenente le informazioni relative agli attributi dell'anagrafica.
Classe pubblica | OverrideCommandEnablingEventArgs | Argomento usato dagli add-in per effettuare l'override dell'abilitazione dei comandi del Core.
Classe pubblica | OverwriteImportPlaceHolderEventArgs | Informazioni per l'override della logica dei placeholder.
Classe pubblica | PackAndGoZipFolderEventArgs |
Classe pubblica | ProgrCollisionEventArgs | Argomento per l'evento di gestione del controllo dei conflitti tra progressivi.
Classe pubblica | QsManagerEventArgs | Argomento usato per le operazioni sulle famiglie nel QsManager.
Classe pubblica | QsResources | Classe usata per effettuare l'override della property 'GetString' in modo tale che il testo venga mandato a capo quando è presente il '\n'
Classe pubblica | QSTopDwgViewerProfile | Argomento per evento definizione profilo QsTopDwgViewer.
Classe pubblica | RedrawAnagrEventArgs | Contiene l'indicazione per la colorazione delle anagrafiche della ricerca.
Classe pubblica | RedrawAttrEventArgs | Contiene l'indicazione per la colorazione della commessa.
Classe pubblica | RedrawCommEventArgs | Contiene l'indicazione per la colorazione della commessa.
Classe pubblica | RedrawDedTypeEventArgs | Contiene l'indicazione per la colorazione della commessa.
Classe pubblica | RedrawDepEventArgs | Contiene l'indicazione per la colorazione dell'albero delle dipendenze.
Classe pubblica | RedrawDistEventArgs | Contiene l'indicazione per la colorazione della distinta.
Classe pubblica | ReferenceUpdateOperationEventArgs | Classe usata per permettere ai CAD e ai plugin di registrarsi ai delegate del comando UpdateDocumentReference.
Classe pubblica | RemoveAnagrEventArgs | Racchiude le informazioni che riguardano l'anagrafica in eliminazione. Viene utilizzato per notificare il pre e post del comando di eliminazione anagrarfica.
Classe pubblica | ResolveDedFileDescriptorEventArgs | Argomenti specifici degli eventi sul FileDescriptor del DocStructInfo
Classe pubblica | ResolveDocStructInfoEventArgs | Racchiude il DocStructInfo in fase di risoluzione
Classe pubblica | SaveDistOnApprovedEventArgs | Contiene l'indicazione di momento esecuzione comando.
Classe pubblica | SetDefaultFindCodeFilterEventArgs | Argomento utilizzato per impostare l'attributo di ricerca da utilizzare nel DedFindCodeControl.
Classe pubblica | ShowPreviewEventArgs | Racchiude le informazioni che riguardano la visualizzazione del preview di un file.
Classe pubblica | ShowZoomPreviewEventArgs | Racchiude le informazioni che riguardano la visualizzazione del preview di un file.
Classe pubblica | SkipDocumentStatusOnSaveDistEventArgs | Argomento utilizzato per determinare se il controllo sullo stato del documento durante il salva distinta debba essere skippato
Classe pubblica | SkipEsclAttribEventArgs | Contiene l'indicazione di momento esecuzione comando.
Classe pubblica | SparePartsManualManager | Classe contenente tutte i settaggi di stile che deve avere il manuale ricambi.
Classe pubblica | StateChangedEventArgs | Contiene le informazioni necessarie sul cambio di stato di un'anagrafica.
Classe pubblica | StateCommandEventArgs | Argomento di elaborazione documento durante il comando di modifica stato anagrafica.
Classe pubblica | UnRilErasePublishEventArgs | Argomento utilizzato per l'evento di elimininazione dei formati quando viene tolto il rilascio
Classe pubblica | UpgradeAnagrCommEventArgs | Argomento utilizzato in esecuzione dell'evento di aggiornamento anagrafiche nel gestore commesse.
Classe pubblica | ValidateCheckFunctionEventArgs | Argomento per gli eventi di validazione della funzione di controllo degli attributi.
Classe pubblica | ValidateFamPropertyEventArgs | Argomento per gli eventi di validazione della famiglia.
Interfacce
 | Interfaccia | Descrizione
Interfaccia pubblica | IDedNetApplication | Interfaccia per la visibilità COM della classe principale.
Delegate
 | Delegate | Descrizione
Delegate pubblico | ExportDataDelegate |
Enumerazioni
 | Enumerazione | Descrizione
Enumerazione pubblica | ClientApplicationEnum | Applicazione client collegata.
Enumerazione pubblica | DedChooseElement | Enumerazione delle tipologie di elementi selezionabili attraverso la finestra della ricerca in modalità Modale.
Enumerazione pubblica | DedChooseElementComm | Enumerazione delle tipologie di elementi selezionabili attraverso la finestra della scelta commesse.
Enumerazione pubblica | DedCommandRunningContextEnum |
Enumerazione pubblica | DedDataOperationEnum | Enumerazione sul tipo di operazione effettuata in DEDDATA.
Enumerazione pubblica | DedEventHandlerEnum | Enumerazione che specifica la gestione dell'evento.
Enumerazione pubblica | DedEventTimeEnum | Enumerazione sul momento nel quale l'evento è lanciato.
Enumerazione pubblica | DedEventTimeFileResolutionEnum | Enumerazione sul momento nel quale l'evento è lanciato.
Enumerazione pubblica | DedFindCodeContextEnum | Contesto di esecuzione nel quale è utilizzato il controllo "DedFindCodeControl".
Enumerazione pubblica | DedTranslationOperationEnum | Enumerazione sul tipo di operazione effettuata in DEDDATA.
Enumerazione pubblica | DocumentOperationEnum |

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Classe AddDataDocEventArgs
Argomento utilizzato nell'evento di post linkaggio del documento all'angrafica.
Gerarchia di ereditarietà
SystemObject
DedNetAddDataDocEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class AddDataDocEventArgs
Public Class AddDataDocEventArgs
public ref class AddDataDocEventArgs
type AddDataDocEventArgs = class end

Il tipo AddDataDocEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CfgDescr |
Proprietà pubblica | Context |
Proprietà pubblica | Data |
Proprietà pubblica | Doc |
Proprietà pubblica | LinkingData |
Torna su
Vedi anche

Documentazione

Namespace DedNet


Proprietà di AddDataDocEventArgs

Il tipo AddDataDocEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CfgDescr |
Proprietà pubblica | Context |
Proprietà pubblica | Data |
Proprietà pubblica | Doc |
Proprietà pubblica | LinkingData |
Torna su
Vedi anche

Documentazione

Classe AddDataDocEventArgs
Namespace DedNet


Proprietà AddDataDocEventArgs.CfgDescr

Libreria DedNet

Proprietà AddDataDocEventArgsCfgDescr

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ConfigDescriptor CfgDescr { get; set; }
Public Property CfgDescr As ConfigDescriptor
    Get
    Set
public:
property ConfigDescriptor^ CfgDescr {
    ConfigDescriptor^ get ();
    void set (ConfigDescriptor^ value);
}
member CfgDescr : ConfigDescriptor with get, set

Valore della proprietà

ConfigDescriptor
Vedi anche

Documentazione

Classe AddDataDocEventArgs
Namespace DedNet


Proprietà AddDataDocEventArgs.Context

Proprietà AddDataDocEventArgsContext

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocContextEnum Context { get; set; }
Public Property Context As DedDocContextEnum
    Get
    Set
public:
property DedDocContextEnum Context {
    DedDocContextEnum get ();
    void set (DedDocContextEnum value);
}
member Context : DedDocContextEnum with get, set

Valore della proprietà

DedDocContextEnum
Vedi anche

Documentazione

Classe AddDataDocEventArgs
Namespace DedNet


Proprietà AddDataDocEventArgs.Data

Proprietà AddDataDocEventArgsData

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; set; }
Public Property Data As DedData
    Get
    Set
public:
property DedData^ Data {
    DedData^ get ();
    void set (DedData^ value);
}
member Data : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe AddDataDocEventArgs
Namespace DedNet


Proprietà AddDataDocEventArgs.Doc

Proprietà AddDataDocEventArgsDoc

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDoc Doc { get; set; }
Public Property Doc As DedDoc
    Get
    Set
public:
property DedDoc^ Doc {
    DedDoc^ get ();
    void set (DedDoc^ value);
}
member Doc : DedDoc with get, set

Valore della proprietà

DedDoc
Vedi anche

Documentazione

Classe AddDataDocEventArgs
Namespace DedNet


Proprietà AddDataDocEventArgs.LinkingData

Proprietà AddDataDocEventArgsLinkingData

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData LinkingData { get; set; }
Public Property LinkingData As DedData
    Get
    Set
public:
property DedData^ LinkingData {
    DedData^ get ();
    void set (DedData^ value);
}
member LinkingData : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe AddDataDocEventArgs
Namespace DedNet


Classe AddExtensionsRecognizerEventArgs
Argomento usato aggiungere delle estensioni al riconoscitore di documenti.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetAddExtensionsRecognizerEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class AddExtensionsRecognizerEventArgs : EventArgs
Public Class AddExtensionsRecognizerEventArgs
    Inherits EventArgs
public ref class AddExtensionsRecognizerEventArgs : public EventArgs
type AddExtensionsRecognizerEventArgs =
    class
        inherit EventArgs
    end

Il tipo AddExtensionsRecognizerEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | AddExtensionsRecognizerEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Extensions |
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore AddExtensionsRecognizerEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public AddExtensionsRecognizerEventArgs()
Public Sub New
public:
AddExtensionsRecognizerEventArgs()
new : unit -> AddExtensionsRecognizerEventArgs
Vedi anche

Documentazione

Classe AddExtensionsRecognizerEventArgs
Namespace DedNet


Proprietà di AddExtensionsRecognizerEventArgs

Il tipo AddExtensionsRecognizerEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Extensions |
Torna su
Vedi anche

Documentazione

Classe AddExtensionsRecognizerEventArgs
Namespace DedNet


Proprietà AddExtensionsRecognizerEventArgs.Extensions

Proprietà AddExtensionsRecognizerEventArgsExtensions

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> Extensions { get; set; }
Public Property Extensions As List(Of String)
    Get
    Set
public:
property List<String^>^ Extensions {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
member Extensions : List<string> with get, set

Valore della proprietà

List String
Vedi anche

Documentazione

Classe AddExtensionsRecognizerEventArgs
Namespace DedNet


Classe AfterSaveEventArgs
Argomento contenente le informazioni relative al post salvataggio.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetAfterSaveEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class AfterSaveEventArgs : EventArgs
Public Class AfterSaveEventArgs
    Inherits EventArgs
public ref class AfterSaveEventArgs : public EventArgs
type AfterSaveEventArgs =
    class
        inherit EventArgs
    end

Il tipo AfterSaveEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | AfterSaveEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Aggiunti |
Proprietà pubblica | Collection |
Proprietà pubblica | Eliminati |
Proprietà pubblica | Modificati |
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore AfterSaveEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public AfterSaveEventArgs()
Public Sub New
public:
AfterSaveEventArgs()
new : unit -> AfterSaveEventArgs
Vedi anche

Documentazione

Classe AfterSaveEventArgs
Namespace DedNet


Proprietà di AfterSaveEventArgs

Il tipo AfterSaveEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Aggiunti |
Proprietà pubblica | Collection |
Proprietà pubblica | Eliminati |
Proprietà pubblica | Modificati |
Torna su
Vedi anche

Documentazione

Classe AfterSaveEventArgs
Namespace DedNet


Proprietà AfterSaveEventArgs.Aggiunti

Proprietà AfterSaveEventArgsAggiunti

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<Object> Aggiunti { get; set; }
Public Property Aggiunti As List(Of Object)
    Get
    Set
public:
property List<Object^>^ Aggiunti {
    List<Object^>^ get ();
    void set (List<Object^>^ value);
}
member Aggiunti : List<Object> with get, set

Valore della proprietà

List Object
Vedi anche

Documentazione

Classe AfterSaveEventArgs
Namespace DedNet


Proprietà AfterSaveEventArgs.Collection

Proprietà AfterSaveEventArgsCollection

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object Collection { get; set; }
Public Property Collection As Object
    Get
    Set
public:
property Object^ Collection {
    Object^ get ();
    void set (Object^ value);
}
member Collection : Object with get, set

Valore della proprietà

Object
Vedi anche

Documentazione

Classe AfterSaveEventArgs
Namespace DedNet


Proprietà AfterSaveEventArgs.Eliminati

Proprietà AfterSaveEventArgsEliminati

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<Object> Eliminati { get; set; }
Public Property Eliminati As List(Of Object)
    Get
    Set
public:
property List<Object^>^ Eliminati {
    List<Object^>^ get ();
    void set (List<Object^>^ value);
}
member Eliminati : List<Object> with get, set

Valore della proprietà

List Object
Vedi anche

Documentazione

Classe AfterSaveEventArgs
Namespace DedNet


Proprietà AfterSaveEventArgs.Modificati

Proprietà AfterSaveEventArgsModificati

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<Object> Modificati { get; set; }
Public Property Modificati As List(Of Object)
    Get
    Set
public:
property List<Object^>^ Modificati {
    List<Object^>^ get ();
    void set (List<Object^>^ value);
}
member Modificati : List<Object> with get, set

Valore della proprietà

List Object
Vedi anche

Documentazione

Classe AfterSaveEventArgs
Namespace DedNet


Classe AnagrSelectionDeletedEventArgs
Racchiude le informazioni che riguardano le anagrafiche in eliminazione.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetAnagrSelectionDeletedEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class AnagrSelectionDeletedEventArgs : EventArgs
Public Class AnagrSelectionDeletedEventArgs
    Inherits EventArgs
public ref class AnagrSelectionDeletedEventArgs : public EventArgs
type AnagrSelectionDeletedEventArgs =
    class
        inherit EventArgs
    end

Il tipo AnagrSelectionDeletedEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo protetto | AnagrSelectionDeletedEventArgs | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione.
Proprietà pubblica | Datas | Restituisce l'anagrafica da eliminare.
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento.
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore AnagrSelectionDeletedEventArgs
Costruttore unico.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal AnagrSelectionDeletedEventArgs(
    DedDataList datas
)
Protected Friend Sub New (
    datas As DedDataList
)
protected public:
AnagrSelectionDeletedEventArgs(
    DedDataList^ datas
)
new :
        datas : DedDataList -> AnagrSelectionDeletedEventArgs

Parametri

datas DedDataList
Vedi anche

Documentazione

Classe AnagrSelectionDeletedEventArgs
Namespace DedNet


Proprietà di AnagrSelectionDeletedEventArgs

Il tipo AnagrSelectionDeletedEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione.
Proprietà pubblica | Datas | Restituisce l'anagrafica da eliminare.
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento.
Torna su
Vedi anche

Documentazione

Classe AnagrSelectionDeletedEventArgs
Namespace DedNet


Proprietà AnagrSelectionDeletedEventArgs.BeforeOrAfter

Proprietà AnagrSelectionDeletedEventArgsBeforeOrAfter
Restituisce il momento dell'evento rispetto l'azione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEventTimeEnum BeforeOrAfter { get; }
Public ReadOnly Property BeforeOrAfter As DedEventTimeEnum
    Get
public:
property DedEventTimeEnum BeforeOrAfter {
    DedEventTimeEnum get ();
}
member BeforeOrAfter : DedEventTimeEnum with get

Valore della proprietà

DedEventTimeEnum
Vedi anche

Documentazione

Classe AnagrSelectionDeletedEventArgs
Namespace DedNet


Proprietà AnagrSelectionDeletedEventArgs.Datas

Proprietà AnagrSelectionDeletedEventArgsDatas
Restituisce l'anagrafica da eliminare.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataList Datas { get; }
Public ReadOnly Property Datas As DedDataList
    Get
public:
property DedDataList^ Datas {
    DedDataList^ get ();
}
member Datas : DedDataList with get

Valore della proprietà

DedDataList
Vedi anche

Documentazione

Classe AnagrSelectionDeletedEventArgs
Namespace DedNet


Proprietà AnagrSelectionDeletedEventArgs.HandlingCode

Proprietà AnagrSelectionDeletedEventArgsHandlingCode
Restituisce o imposta la gestione dell'evento.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEventHandlerEnum HandlingCode { get; set; }
Public Property HandlingCode As DedEventHandlerEnum
    Get
    Set
public:
property DedEventHandlerEnum HandlingCode {
    DedEventHandlerEnum get ();
    void set (DedEventHandlerEnum value);
}
member HandlingCode : DedEventHandlerEnum with get, set

Valore della proprietà

DedEventHandlerEnum
Vedi anche

Documentazione

Classe AnagrSelectionDeletedEventArgs
Namespace DedNet


Classe BomExplorerAddReplaceDataEventArgs
Argomento utilizzato prima dell'elaborazione di un nuovo valore del lookup edit del bom explorer.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetDedBeforeOrAfterEventArgs
DedNetDedEventArgs
DedNetBomExplorerAddReplaceDataEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class BomExplorerAddReplaceDataEventArgs : DedEventArgs
Public Class BomExplorerAddReplaceDataEventArgs
    Inherits DedEventArgs
public ref class BomExplorerAddReplaceDataEventArgs : public DedEventArgs
type BomExplorerAddReplaceDataEventArgs =
    class
        inherit DedEventArgs
    end

Il tipo BomExplorerAddReplaceDataEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | BomExplorerAddReplaceDataEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | Control | Restituisce il controllo lookUpEdit
Proprietà pubblica | Data | Legge il valore corrente digitato e permette
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore BomExplorerAddReplaceDataEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomExplorerAddReplaceDataEventArgs()
Public Sub New
public:
BomExplorerAddReplaceDataEventArgs()
new : unit -> BomExplorerAddReplaceDataEventArgs
Vedi anche

Documentazione

Classe BomExplorerAddReplaceDataEventArgs
Namespace DedNet


Proprietà di BomExplorerAddReplaceDataEventArgs

Il tipo BomExplorerAddReplaceDataEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | Control | Restituisce il controllo lookUpEdit
Proprietà pubblica | Data | Legge il valore corrente digitato e permette
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Torna su
Vedi anche

Documentazione

Classe BomExplorerAddReplaceDataEventArgs
Namespace DedNet


Proprietà BomExplorerAddReplaceDataEventArgs.Control

Proprietà BomExplorerAddReplaceDataEventArgsControl
Restituisce il controllo lookUpEdit

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Control Control { get; set; }
Public Property Control As Control
    Get
    Set
public:
property Control^ Control {
    Control^ get ();
    void set (Control^ value);
}
member Control : Control with get, set

Valore della proprietà

Control
Vedi anche

Documentazione

Classe BomExplorerAddReplaceDataEventArgs
Namespace DedNet


Proprietà BomExplorerAddReplaceDataEventArgs.Data

Proprietà BomExplorerAddReplaceDataEventArgsData
Legge il valore corrente digitato e permette

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; set; }
Public Property Data As DedData
    Get
    Set
public:
property DedData^ Data {
    DedData^ get ();
    void set (DedData^ value);
}
member Data : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe BomExplorerAddReplaceDataEventArgs
Namespace DedNet


Classe BomExplorerButtonClickEventArgs
Argomento utilizzato durante il click su un pulsante personalizzato tramite l'editor delle distinte.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetBomExplorerButtonClickEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class BomExplorerButtonClickEventArgs : EventArgs
Public Class BomExplorerButtonClickEventArgs
    Inherits EventArgs
public ref class BomExplorerButtonClickEventArgs : public EventArgs
type BomExplorerButtonClickEventArgs =
    class
        inherit EventArgs
    end

Il tipo BomExplorerButtonClickEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | BomExplorerButtonClickEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | CtrlBomExplorer |
Proprietà pubblica | CtrlDist | Restituisce il controllo delle distinte (DedDistContorl).
Proprietà pubblica | ItemClicked | Restuisce l'elemento cliccato.
Proprietà pubblica | NeedRefresh | Indica se è necessario un refresh dopo il comando.
Proprietà pubblica | SelectedBomItems | Restituisce i bomItems selezionati.
Proprietà pubblica | SelectedDatas | Restituisce le anagrafiche selezionate.
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore BomExplorerButtonClickEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomExplorerButtonClickEventArgs()
Public Sub New
public:
BomExplorerButtonClickEventArgs()
new : unit -> BomExplorerButtonClickEventArgs
Vedi anche

Documentazione

Classe BomExplorerButtonClickEventArgs
Namespace DedNet


Proprietà di BomExplorerButtonClickEventArgs

Il tipo BomExplorerButtonClickEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CtrlBomExplorer |
Proprietà pubblica | CtrlDist | Restituisce il controllo delle distinte (DedDistContorl).
Proprietà pubblica | ItemClicked | Restuisce l'elemento cliccato.
Proprietà pubblica | NeedRefresh | Indica se è necessario un refresh dopo il comando.
Proprietà pubblica | SelectedBomItems | Restituisce i bomItems selezionati.
Proprietà pubblica | SelectedDatas | Restituisce le anagrafiche selezionate.
Torna su
Vedi anche

Documentazione

Classe BomExplorerButtonClickEventArgs
Namespace DedNet


Proprietà BomExplorerButtonClickEventArgs.CtrlBomExplorer

Proprietà BomExplorerButtonClickEventArgsCtrlBomExplorer

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedBomExplorerControl CtrlBomExplorer { get; }
Public ReadOnly Property CtrlBomExplorer As DedBomExplorerControl
    Get
public:
property DedBomExplorerControl^ CtrlBomExplorer {
    DedBomExplorerControl^ get ();
}
member CtrlBomExplorer : DedBomExplorerControl with get

Valore della proprietà

DedBomExplorerControl
Vedi anche

Documentazione

Classe BomExplorerButtonClickEventArgs
Namespace DedNet


Proprietà BomExplorerButtonClickEventArgs.CtrlDist

Proprietà BomExplorerButtonClickEventArgsCtrlDist
Restituisce il controllo delle distinte (DedDistContorl).

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDistControl CtrlDist { get; }
Public ReadOnly Property CtrlDist As DedDistControl
    Get
public:
property DedDistControl^ CtrlDist {
    DedDistControl^ get ();
}
member CtrlDist : DedDistControl with get

Valore della proprietà

DedDistControl
Vedi anche

Documentazione

Classe BomExplorerButtonClickEventArgs
Namespace DedNet


Proprietà BomExplorerButtonClickEventArgs.ItemClicked

Proprietà BomExplorerButtonClickEventArgsItemClicked
Restuisce l'elemento cliccato.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BarButtonItem ItemClicked { get; }
Public ReadOnly Property ItemClicked As BarButtonItem
    Get
public:
property BarButtonItem^ ItemClicked {
    BarButtonItem^ get ();
}
member ItemClicked : BarButtonItem with get

Valore della proprietà

BarButtonItem
Vedi anche

Documentazione

Classe BomExplorerButtonClickEventArgs
Namespace DedNet


Proprietà BomExplorerButtonClickEventArgs.NeedRefresh

Proprietà BomExplorerButtonClickEventArgsNeedRefresh
Indica se è necessario un refresh dopo il comando.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool NeedRefresh { get; set; }
Public Property NeedRefresh As Boolean
    Get
    Set
public:
property bool NeedRefresh {
    bool get ();
    void set (bool value);
}
member NeedRefresh : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe BomExplorerButtonClickEventArgs
Namespace DedNet


Proprietà BomExplorerButtonClickEventArgs.SelectedBomItems

Proprietà BomExplorerButtonClickEventArgsSelectedBomItems
Restituisce i bomItems selezionati.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<BomItem> SelectedBomItems { get; }
Public ReadOnly Property SelectedBomItems As List(Of BomItem)
    Get
public:
property List<BomItem^>^ SelectedBomItems {
    List<BomItem^>^ get ();
}
member SelectedBomItems : List<BomItem> with get

Valore della proprietà

List BomItem
Vedi anche

Documentazione

Classe BomExplorerButtonClickEventArgs
Namespace DedNet


Proprietà BomExplorerButtonClickEventArgs.SelectedDatas

Proprietà BomExplorerButtonClickEventArgsSelectedDatas
Restituisce le anagrafiche selezionate.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataList SelectedDatas { get; }
Public ReadOnly Property SelectedDatas As DedDataList
    Get
public:
property DedDataList^ SelectedDatas {
    DedDataList^ get ();
}
member SelectedDatas : DedDataList with get

Valore della proprietà

DedDataList
Vedi anche

Documentazione

Classe BomExplorerButtonClickEventArgs
Namespace DedNet


Classe BomExplorerContextMenuOpeningEventArgs
Argomento utilizzato prima dell'elaborazione di un nuovo valore del lookup edit del bom explorer.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetDedBeforeOrAfterEventArgs
DedNetDedEventArgs
DedNetBomExplorerContextMenuOpeningEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class BomExplorerContextMenuOpeningEventArgs : DedEventArgs
Public Class BomExplorerContextMenuOpeningEventArgs
    Inherits DedEventArgs
public ref class BomExplorerContextMenuOpeningEventArgs : public DedEventArgs
type BomExplorerContextMenuOpeningEventArgs =
    class
        inherit DedEventArgs
    end

Il tipo BomExplorerContextMenuOpeningEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | BomExplorerContextMenuOpeningEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | ContextMenu | ContextMenu già compilato dall'applicazione
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore BomExplorerContextMenuOpeningEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomExplorerContextMenuOpeningEventArgs()
Public Sub New
public:
BomExplorerContextMenuOpeningEventArgs()
new : unit -> BomExplorerContextMenuOpeningEventArgs
Vedi anche

Documentazione

Classe BomExplorerContextMenuOpeningEventArgs
Namespace DedNet


Proprietà di BomExplorerContextMenuOpeningEventArgs

Il tipo BomExplorerContextMenuOpeningEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | ContextMenu | ContextMenu già compilato dall'applicazione
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Torna su
Vedi anche

Documentazione

Classe BomExplorerContextMenuOpeningEventArgs
Namespace DedNet


Proprietà BomExplorerContextMenuOpeningEventArgs.ContextMenu

Proprietà BomExplorerContextMenuOpeningEventArgsContextMenu
ContextMenu già compilato dall'applicazione

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public PopupMenu ContextMenu { get; set; }
Public Property ContextMenu As PopupMenu
    Get
    Set
public:
property PopupMenu^ ContextMenu {
    PopupMenu^ get ();
    void set (PopupMenu^ value);
}
member ContextMenu : PopupMenu with get, set

Valore della proprietà

PopupMenu
Vedi anche

Documentazione

Classe BomExplorerContextMenuOpeningEventArgs
Namespace DedNet


Classe BomExplorerLoadDistEventArgs
Argomento utilizzato prima dell'elaborazione di un nuovo valore del lookup edit del bom explorer.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetDedBeforeOrAfterEventArgs
DedNetDedEventArgs
DedNetBomExplorerLoadDistEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class BomExplorerLoadDistEventArgs : DedEventArgs
Public Class BomExplorerLoadDistEventArgs
    Inherits DedEventArgs
public ref class BomExplorerLoadDistEventArgs : public DedEventArgs
type BomExplorerLoadDistEventArgs =
    class
        inherit DedEventArgs
    end

Il tipo BomExplorerLoadDistEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | BomExplorerLoadDistEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | Control | Restituisce il controllo lookUpEdit
Proprietà pubblica | Data | Legge il valore corrente digitato e permette
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore BomExplorerLoadDistEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomExplorerLoadDistEventArgs()
Public Sub New
public:
BomExplorerLoadDistEventArgs()
new : unit -> BomExplorerLoadDistEventArgs
Vedi anche

Documentazione

Classe BomExplorerLoadDistEventArgs
Namespace DedNet


Proprietà di BomExplorerLoadDistEventArgs

Il tipo BomExplorerLoadDistEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | Control | Restituisce il controllo lookUpEdit
Proprietà pubblica | Data | Legge il valore corrente digitato e permette
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Torna su
Vedi anche

Documentazione

Classe BomExplorerLoadDistEventArgs
Namespace DedNet


Proprietà BomExplorerLoadDistEventArgs.Control

Proprietà BomExplorerLoadDistEventArgsControl
Restituisce il controllo lookUpEdit

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Control Control { get; set; }
Public Property Control As Control
    Get
    Set
public:
property Control^ Control {
    Control^ get ();
    void set (Control^ value);
}
member Control : Control with get, set

Valore della proprietà

Control
Vedi anche

Documentazione

Classe BomExplorerLoadDistEventArgs
Namespace DedNet


Proprietà BomExplorerLoadDistEventArgs.Data

Proprietà BomExplorerLoadDistEventArgsData
Legge il valore corrente digitato e permette

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; set; }
Public Property Data As DedData
    Get
    Set
public:
property DedData^ Data {
    DedData^ get ();
    void set (DedData^ value);
}
member Data : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe BomExplorerLoadDistEventArgs
Namespace DedNet


Classe BomManualSettings
Classe contenente tutte le configurazioni per la visualizzazione delle colonne nei form relativi alle distinte
Gerarchia di ereditarietà
SystemObject
DedNetBomManualSettings

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class BomManualSettings
Public Class BomManualSettings
public ref class BomManualSettings
type BomManualSettings = class end

Il tipo BomManualSettings espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | BomManualSettings | Crea una nuova istanza della classe 'BomManualSetting'
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | ConfigFile | Percorso del file di configurazione contenente i vari settaggi.
Proprietà pubblica | LoadConfigBomEdit | Indica se caricare o meno la configurazione del form Edita pannello di sinistra
Proprietà pubblica | LoadConfigBomEspl | Indica se caricare o meno la configurazione del form Esplosa
Proprietà pubblica | LoadConfigBomImpl | Indica se caricare o meno la configurazione del form Implosa
Proprietà pubblica | LoadConfigBomView | Indica se caricare o meno la configurazione del form Edita pannello di destra
Proprietà pubblica | LoadConfigCmdEsporta | Indica se caricare o meno la configurazione per il comando Esporta
Proprietà pubblica | PathBomEdit | Percorso dove si trova il file di configurazione per il form Edita pannello di sinistra
Proprietà pubblica | PathBomEspl | Percorso dove si trova il file di configurazione per il form Esplosa
Proprietà pubblica | PathBomImpl | Percorso dove si trova il file di configurazione per il form Implosa
Proprietà pubblica | PathBomView | Percorso dove si trova il file di configurazione per il form Edita pannello di destra
Proprietà pubblica | PathCmdEsporta | Percorso dove si trova il file di configurazione per il comando Esporta
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | GetFiles | Ritorna una lista con l'elenco dei possibili file di configurazione da utilizzare per la visualizzazione delle colonne nei form delle distinte
Metodo pubblico | LoadSettings | Carica le informazioni di layout.
Metodo pubblico | SaveSettings | Carica le informazioni di layout.
Torna su
Campi
Nome | Descrizione
TEMPLATE_BOM_MANUAL_SETTINGS | Nome del file di configurazione.
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore BomManualSettings
Crea una nuova istanza della classe 'BomManualSetting'

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomManualSettings(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
BomManualSettings(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> BomManualSettings

Parametri

app DedNetApplication
Applicazione DedNet.
Vedi anche

Documentazione

Classe BomManualSettings
Namespace DedNet


Proprietà di BomManualSettings

Il tipo BomManualSettings espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | ConfigFile | Percorso del file di configurazione contenente i vari settaggi.
Proprietà pubblica | LoadConfigBomEdit | Indica se caricare o meno la configurazione del form Edita pannello di sinistra
Proprietà pubblica | LoadConfigBomEspl | Indica se caricare o meno la configurazione del form Esplosa
Proprietà pubblica | LoadConfigBomImpl | Indica se caricare o meno la configurazione del form Implosa
Proprietà pubblica | LoadConfigBomView | Indica se caricare o meno la configurazione del form Edita pannello di destra
Proprietà pubblica | LoadConfigCmdEsporta | Indica se caricare o meno la configurazione per il comando Esporta
Proprietà pubblica | PathBomEdit | Percorso dove si trova il file di configurazione per il form Edita pannello di sinistra
Proprietà pubblica | PathBomEspl | Percorso dove si trova il file di configurazione per il form Esplosa
Proprietà pubblica | PathBomImpl | Percorso dove si trova il file di configurazione per il form Implosa
Proprietà pubblica | PathBomView | Percorso dove si trova il file di configurazione per il form Edita pannello di destra
Proprietà pubblica | PathCmdEsporta | Percorso dove si trova il file di configurazione per il comando Esporta
Torna su
Vedi anche

Documentazione

Classe BomManualSettings
Namespace DedNet


Proprietà BomManualSettings.ConfigFile

Proprietà BomManualSettingsConfigFile
Percorso del file di configurazione contenente i vari settaggi.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string ConfigFile { get; }
Public ReadOnly Property ConfigFile As String
    Get
public:
property String^ ConfigFile {
    String^ get ();
}
member ConfigFile : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe BomManualSettings
Namespace DedNet


Proprietà BomManualSettings.LoadConfigBomEdit

Proprietà BomManualSettingsLoadConfigBomEdit
Indica se caricare o meno la configurazione del form Edita pannello di sinistra

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool LoadConfigBomEdit { get; set; }
Public Property LoadConfigBomEdit As Boolean
    Get
    Set
public:
property bool LoadConfigBomEdit {
    bool get ();
    void set (bool value);
}
member LoadConfigBomEdit : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe BomManualSettings
Namespace DedNet


Proprietà BomManualSettings.LoadConfigBomEspl

Proprietà BomManualSettingsLoadConfigBomEspl
Indica se caricare o meno la configurazione del form Esplosa

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool LoadConfigBomEspl { get; set; }
Public Property LoadConfigBomEspl As Boolean
    Get
    Set
public:
property bool LoadConfigBomEspl {
    bool get ();
    void set (bool value);
}
member LoadConfigBomEspl : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe BomManualSettings
Namespace DedNet


Proprietà BomManualSettings.LoadConfigBomImpl

Proprietà BomManualSettingsLoadConfigBomImpl
Indica se caricare o meno la configurazione del form Implosa

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool LoadConfigBomImpl { get; set; }
Public Property LoadConfigBomImpl As Boolean
    Get
    Set
public:
property bool LoadConfigBomImpl {
    bool get ();
    void set (bool value);
}
member LoadConfigBomImpl : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe BomManualSettings
Namespace DedNet


Proprietà BomManualSettings.LoadConfigBomView

Proprietà BomManualSettingsLoadConfigBomView
Indica se caricare o meno la configurazione del form Edita pannello di destra

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool LoadConfigBomView { get; set; }
Public Property LoadConfigBomView As Boolean
    Get
    Set
public:
property bool LoadConfigBomView {
    bool get ();
    void set (bool value);
}
member LoadConfigBomView : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe BomManualSettings
Namespace DedNet


Proprietà BomManualSettings.LoadConfigCmdEsporta

Proprietà BomManualSettingsLoadConfigCmdEsporta
Indica se caricare o meno la configurazione per il comando Esporta

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool LoadConfigCmdEsporta { get; set; }
Public Property LoadConfigCmdEsporta As Boolean
    Get
    Set
public:
property bool LoadConfigCmdEsporta {
    bool get ();
    void set (bool value);
}
member LoadConfigCmdEsporta : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe BomManualSettings
Namespace DedNet


Proprietà BomManualSettings.PathBomEdit

Proprietà BomManualSettingsPathBomEdit
Percorso dove si trova il file di configurazione per il form Edita pannello di sinistra

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string PathBomEdit { get; set; }
Public Property PathBomEdit As String
    Get
    Set
public:
property String^ PathBomEdit {
    String^ get ();
    void set (String^ value);
}
member PathBomEdit : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe BomManualSettings
Namespace DedNet


Proprietà BomManualSettings.PathBomEspl

Proprietà BomManualSettingsPathBomEspl
Percorso dove si trova il file di configurazione per il form Esplosa

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string PathBomEspl { get; set; }
Public Property PathBomEspl As String
    Get
    Set
public:
property String^ PathBomEspl {
    String^ get ();
    void set (String^ value);
}
member PathBomEspl : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe BomManualSettings
Namespace DedNet


Proprietà BomManualSettings.PathBomImpl

Proprietà BomManualSettingsPathBomImpl
Percorso dove si trova il file di configurazione per il form Implosa

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string PathBomImpl { get; set; }
Public Property PathBomImpl As String
    Get
    Set
public:
property String^ PathBomImpl {
    String^ get ();
    void set (String^ value);
}
member PathBomImpl : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe BomManualSettings
Namespace DedNet


Proprietà BomManualSettings.PathBomView

Proprietà BomManualSettingsPathBomView
Percorso dove si trova il file di configurazione per il form Edita pannello di destra

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string PathBomView { get; set; }
Public Property PathBomView As String
    Get
    Set
public:
property String^ PathBomView {
    String^ get ();
    void set (String^ value);
}
member PathBomView : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe BomManualSettings
Namespace DedNet


Proprietà BomManualSettings.PathCmdEsporta

Proprietà BomManualSettingsPathCmdEsporta
Percorso dove si trova il file di configurazione per il comando Esporta

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string PathCmdEsporta { get; set; }
Public Property PathCmdEsporta As String
    Get
    Set
public:
property String^ PathCmdEsporta {
    String^ get ();
    void set (String^ value);
}
member PathCmdEsporta : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe BomManualSettings
Namespace DedNet


Metodi di BomManualSettings

Il tipo BomManualSettings espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | GetFiles | Ritorna una lista con l'elenco dei possibili file di configurazione da utilizzare per la visualizzazione delle colonne nei form delle distinte
Metodo pubblico | LoadSettings | Carica le informazioni di layout.
Metodo pubblico | SaveSettings | Carica le informazioni di layout.
Torna su
Vedi anche

Documentazione

Classe BomManualSettings
Namespace DedNet


Metodo BomManualSettings.GetFiles

Metodo BomManualSettingsGetFiles
Ritorna una lista con l'elenco dei possibili file di configurazione da utilizzare per la visualizzazione delle colonne nei form delle distinte

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> GetFiles()
Public Function GetFiles As List(Of String)
public:
List<String^>^ GetFiles()
member GetFiles : unit -> List<string>

Valore di ritorno

List String
Vedi anche

Documentazione

Classe BomManualSettings
Namespace DedNet


Metodo BomManualSettings.LoadSettings

Metodo BomManualSettingsLoadSettings
Carica le informazioni di layout.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void LoadSettings()
Public Sub LoadSettings
public:
void LoadSettings()
member LoadSettings : unit -> unit
Vedi anche

Documentazione

Classe BomManualSettings
Namespace DedNet


Metodo BomManualSettings.SaveSettings

Metodo BomManualSettingsSaveSettings
Carica le informazioni di layout.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SaveSettings()
Public Sub SaveSettings
public:
void SaveSettings()
member SaveSettings : unit -> unit
Vedi anche

Documentazione

Classe BomManualSettings
Namespace DedNet


Campi di BomManualSettings

Il tipo BomManualSettings espone i seguenti membri.

Campi
Nome | Descrizione
TEMPLATE_BOM_MANUAL_SETTINGS | Nome del file di configurazione.
Torna su
Vedi anche

Documentazione

Classe BomManualSettings
Namespace DedNet


Campo BomManualSettings.TEMPLATE_BOM_MANUAL_SETTINGS

Campo BomManualSettingsTEMPLATE_BOM_MANUAL_SETTINGS
Nome del file di configurazione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string TEMPLATE_BOM_MANUAL_SETTINGS = "QsInformatica_BomManualSettings"
Public Const TEMPLATE_BOM_MANUAL_SETTINGS As String = "QsInformatica_BomManualSettings"
public:
literal String^ TEMPLATE_BOM_MANUAL_SETTINGS = "QsInformatica_BomManualSettings"
static val mutable TEMPLATE_BOM_MANUAL_SETTINGS: string

Valore del campo

String
Vedi anche

Documentazione

Classe BomManualSettings
Namespace DedNet


Classe CadPriorityExtListEventArgs
Contiene le informazioni per la gestione delle estensioni prioritarie dei vari CAD.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetCadPriorityExtListEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class CadPriorityExtListEventArgs : EventArgs
Public Class CadPriorityExtListEventArgs
    Inherits EventArgs
public ref class CadPriorityExtListEventArgs : public EventArgs
type CadPriorityExtListEventArgs =
    class
        inherit EventArgs
    end

Il tipo CadPriorityExtListEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | CadPriorityExtListEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | PriorityList | Lista delle estensioni prioritarie
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore CadPriorityExtListEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public CadPriorityExtListEventArgs()
Public Sub New
public:
CadPriorityExtListEventArgs()
new : unit -> CadPriorityExtListEventArgs
Vedi anche

Documentazione

Classe CadPriorityExtListEventArgs
Namespace DedNet


Proprietà di CadPriorityExtListEventArgs

Il tipo CadPriorityExtListEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | PriorityList | Lista delle estensioni prioritarie
Torna su
Vedi anche

Documentazione

Classe CadPriorityExtListEventArgs
Namespace DedNet


Proprietà CadPriorityExtListEventArgs.PriorityList

Proprietà CadPriorityExtListEventArgsPriorityList
Lista delle estensioni prioritarie

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> PriorityList { get; set; }
Public Property PriorityList As List(Of String)
    Get
    Set
public:
property List<String^>^ PriorityList {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
member PriorityList : List<string> with get, set

Valore della proprietà

List String
Vedi anche

Documentazione

Classe CadPriorityExtListEventArgs
Namespace DedNet


Classe ChangingDependencyDocumentEventArgs
Argomento contenente le informazioni per attuare una singola sostituzione.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetDedBeforeOrAfterEventArgs
DedNetDedEventArgs
DedNetChangingDependencyDocumentEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ChangingDependencyDocumentEventArgs : DedEventArgs
Public Class ChangingDependencyDocumentEventArgs
    Inherits DedEventArgs
public ref class ChangingDependencyDocumentEventArgs : public DedEventArgs
type ChangingDependencyDocumentEventArgs =
    class
        inherit DedEventArgs
    end

Il tipo ChangingDependencyDocumentEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Proprietà pubblica | NewFile | Restituisce il nome completo del file che si deve sostituire.
Proprietà pubblica | OldFile | Restituisce il nome completo del riferimento da sostituire.
Proprietà pubblica | ParentDoc | Restituisce il documento padre nel quale si deve attuare la sostituzione.
Torna su
Vedi anche

Documentazione

Namespace DedNet


Proprietà di ChangingDependencyDocumentEventArgs

Il tipo ChangingDependencyDocumentEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Proprietà pubblica | NewFile | Restituisce il nome completo del file che si deve sostituire.
Proprietà pubblica | OldFile | Restituisce il nome completo del riferimento da sostituire.
Proprietà pubblica | ParentDoc | Restituisce il documento padre nel quale si deve attuare la sostituzione.
Torna su
Vedi anche

Documentazione

Classe ChangingDependencyDocumentEventArgs
Namespace DedNet


Proprietà ChangingDependencyDocumentEventArgs.NewFile

Proprietà ChangingDependencyDocumentEventArgsNewFile
Restituisce il nome completo del file che si deve sostituire.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string NewFile { get; }
Public ReadOnly Property NewFile As String
    Get
public:
property String^ NewFile {
    String^ get ();
}
member NewFile : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe ChangingDependencyDocumentEventArgs
Namespace DedNet


Proprietà ChangingDependencyDocumentEventArgs.OldFile

Proprietà ChangingDependencyDocumentEventArgsOldFile
Restituisce il nome completo del riferimento da sostituire.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string OldFile { get; }
Public ReadOnly Property OldFile As String
    Get
public:
property String^ OldFile {
    String^ get ();
}
member OldFile : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe ChangingDependencyDocumentEventArgs
Namespace DedNet


Proprietà ChangingDependencyDocumentEventArgs.ParentDoc

Proprietà ChangingDependencyDocumentEventArgsParentDoc
Restituisce il documento padre nel quale si deve attuare la sostituzione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDoc ParentDoc { get; }
Public ReadOnly Property ParentDoc As DedDoc
    Get
public:
property DedDoc^ ParentDoc {
    DedDoc^ get ();
}
member ParentDoc : DedDoc with get

Valore della proprietà

DedDoc
Vedi anche

Documentazione

Classe ChangingDependencyDocumentEventArgs
Namespace DedNet


Classe CheckProgrReservedEventArgs
Argomento per l'evento di controllo progressivi riservati.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetCheckProgrReservedEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class CheckProgrReservedEventArgs : EventArgs
Public Class CheckProgrReservedEventArgs
    Inherits EventArgs
public ref class CheckProgrReservedEventArgs : public EventArgs
type CheckProgrReservedEventArgs =
    class
        inherit EventArgs
    end

Il tipo CheckProgrReservedEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | CheckProgrReservedEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | CheckReservedProgr | Restituisce/Imposta se controllare o meno la riservatezza del progressivo.
Proprietà pubblica | Info | Restituisce/imposta le informazioni in salvataggio.
Proprietà pubblica | SaveMode | Imposta o restituisce il comando in esecuzione.
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore CheckProgrReservedEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public CheckProgrReservedEventArgs(
    DedEncodeInfo info,
    bool checkReservedProgr,
    DedFormSaveModeEnum saveMode
)
Public Sub New (
    info As DedEncodeInfo,
    checkReservedProgr As Boolean,
    saveMode As DedFormSaveModeEnum
)
public:
CheckProgrReservedEventArgs(
    DedEncodeInfo^ info,
    bool checkReservedProgr,
    DedFormSaveModeEnum saveMode
)
new :
        info : DedEncodeInfo *
        checkReservedProgr : bool *
        saveMode : DedFormSaveModeEnum -> CheckProgrReservedEventArgs

Parametri

info DedEncodeInfo
checkReservedProgr Boolean
saveMode DedFormSaveModeEnum
Vedi anche

Documentazione

Classe CheckProgrReservedEventArgs
Namespace DedNet


Proprietà di CheckProgrReservedEventArgs

Il tipo CheckProgrReservedEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CheckReservedProgr | Restituisce/Imposta se controllare o meno la riservatezza del progressivo.
Proprietà pubblica | Info | Restituisce/imposta le informazioni in salvataggio.
Proprietà pubblica | SaveMode | Imposta o restituisce il comando in esecuzione.
Torna su
Vedi anche

Documentazione

Classe CheckProgrReservedEventArgs
Namespace DedNet


Proprietà CheckProgrReservedEventArgs.CheckReservedProgr

Proprietà CheckProgrReservedEventArgsCheckReservedProgr
Restituisce/Imposta se controllare o meno la riservatezza del progressivo.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CheckReservedProgr { get; set; }
Public Property CheckReservedProgr As Boolean
    Get
    Set
public:
property bool CheckReservedProgr {
    bool get ();
    void set (bool value);
}
member CheckReservedProgr : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CheckProgrReservedEventArgs
Namespace DedNet


Proprietà CheckProgrReservedEventArgs.Info

Proprietà CheckProgrReservedEventArgsInfo
Restituisce/imposta le informazioni in salvataggio.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEncodeInfo Info { get; }
Public ReadOnly Property Info As DedEncodeInfo
    Get
public:
property DedEncodeInfo^ Info {
    DedEncodeInfo^ get ();
}
member Info : DedEncodeInfo with get

Valore della proprietà

DedEncodeInfo
Vedi anche

Documentazione

Classe CheckProgrReservedEventArgs
Namespace DedNet


Proprietà CheckProgrReservedEventArgs.SaveMode

Proprietà CheckProgrReservedEventArgsSaveMode
Imposta o restituisce il comando in esecuzione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormSaveModeEnum SaveMode { get; set; }
Public Property SaveMode As DedFormSaveModeEnum
    Get
    Set
public:
property DedFormSaveModeEnum SaveMode {
    DedFormSaveModeEnum get ();
    void set (DedFormSaveModeEnum value);
}
member SaveMode : DedFormSaveModeEnum with get, set

Valore della proprietà

DedFormSaveModeEnum
Vedi anche

Documentazione

Classe CheckProgrReservedEventArgs
Namespace DedNet


Classe CheckRevAlphabetEventArgs
Argomento per l'evento di gestione del controllo dei caratteri nell'alfabeto.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetCheckRevAlphabetEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class CheckRevAlphabetEventArgs : EventArgs
Public Class CheckRevAlphabetEventArgs
    Inherits EventArgs
public ref class CheckRevAlphabetEventArgs : public EventArgs
type CheckRevAlphabetEventArgs =
    class
        inherit EventArgs
    end

Il tipo CheckRevAlphabetEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | CheckRevAlphabetEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | IgnoreCheckRevAlphabet | Restituisce/Imposta se ignorare o meno la collisione.
Proprietà pubblica | Info | Restituisce/imposta le informazioni in salvataggio.
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore CheckRevAlphabetEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public CheckRevAlphabetEventArgs(
    DedEncodeInfo info,
    bool ignoreCheckRevAlphabet
)
Public Sub New (
    info As DedEncodeInfo,
    ignoreCheckRevAlphabet As Boolean
)
public:
CheckRevAlphabetEventArgs(
    DedEncodeInfo^ info,
    bool ignoreCheckRevAlphabet
)
new :
        info : DedEncodeInfo *
        ignoreCheckRevAlphabet : bool -> CheckRevAlphabetEventArgs

Parametri

info DedEncodeInfo
ignoreCheckRevAlphabet Boolean
Vedi anche

Documentazione

Classe CheckRevAlphabetEventArgs
Namespace DedNet


Proprietà di CheckRevAlphabetEventArgs

Il tipo CheckRevAlphabetEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | IgnoreCheckRevAlphabet | Restituisce/Imposta se ignorare o meno la collisione.
Proprietà pubblica | Info | Restituisce/imposta le informazioni in salvataggio.
Torna su
Vedi anche

Documentazione

Classe CheckRevAlphabetEventArgs
Namespace DedNet


Proprietà CheckRevAlphabetEventArgs.IgnoreCheckRevAlphabet

Proprietà CheckRevAlphabetEventArgsIgnoreCheckRevAlphabet
Restituisce/Imposta se ignorare o meno la collisione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IgnoreCheckRevAlphabet { get; set; }
Public Property IgnoreCheckRevAlphabet As Boolean
    Get
    Set
public:
property bool IgnoreCheckRevAlphabet {
    bool get ();
    void set (bool value);
}
member IgnoreCheckRevAlphabet : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CheckRevAlphabetEventArgs
Namespace DedNet


Proprietà CheckRevAlphabetEventArgs.Info

Proprietà CheckRevAlphabetEventArgsInfo
Restituisce/imposta le informazioni in salvataggio.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEncodeInfo Info { get; }
Public ReadOnly Property Info As DedEncodeInfo
    Get
public:
property DedEncodeInfo^ Info {
    DedEncodeInfo^ get ();
}
member Info : DedEncodeInfo with get

Valore della proprietà

DedEncodeInfo
Vedi anche

Documentazione

Classe CheckRevAlphabetEventArgs
Namespace DedNet


Classe ClassListItemClickEventArgs
Contiene le informazioni necessarie sul click di un elemento del class list.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetClassListItemClickEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ClassListItemClickEventArgs : EventArgs
Public Class ClassListItemClickEventArgs
    Inherits EventArgs
public ref class ClassListItemClickEventArgs : public EventArgs
type ClassListItemClickEventArgs =
    class
        inherit EventArgs
    end

Il tipo ClassListItemClickEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ClassListItemClickEventArgs | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Attr | Restituisce l'attributo corrispondente al classList selezionato.
Proprietà pubblica | Data | Anagrafica in editazione.
Proprietà pubblica | ItemClicked | Restituisce il nome del class list cliccato dall'utente
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore ClassListItemClickEventArgs
Costruttore

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ClassListItemClickEventArgs(
    IDedEditable data,
    DedAttr attr,
    string item
)
Public Sub New (
    data As IDedEditable,
    attr As DedAttr,
    item As String
)
public:
ClassListItemClickEventArgs(
    IDedEditable^ data,
    DedAttr^ attr,
    String^ item
)
new :
        data : IDedEditable *
        attr : DedAttr *
        item : string -> ClassListItemClickEventArgs

Parametri

data IDedEditable
attr DedAttr
item String
Elemento selezionato nel class list.
Vedi anche

Documentazione

Classe ClassListItemClickEventArgs
Namespace DedNet


Proprietà di ClassListItemClickEventArgs

Il tipo ClassListItemClickEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Attr | Restituisce l'attributo corrispondente al classList selezionato.
Proprietà pubblica | Data | Anagrafica in editazione.
Proprietà pubblica | ItemClicked | Restituisce il nome del class list cliccato dall'utente
Torna su
Vedi anche

Documentazione

Classe ClassListItemClickEventArgs
Namespace DedNet


Proprietà ClassListItemClickEventArgs.Attr

Proprietà ClassListItemClickEventArgsAttr
Restituisce l'attributo corrispondente al classList selezionato.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttr Attr { get; }
Public ReadOnly Property Attr As DedAttr
    Get
public:
property DedAttr^ Attr {
    DedAttr^ get ();
}
member Attr : DedAttr with get

Valore della proprietà

DedAttr
Vedi anche

Documentazione

Classe ClassListItemClickEventArgs
Namespace DedNet


Proprietà ClassListItemClickEventArgs.Data

Proprietà ClassListItemClickEventArgsData
Anagrafica in editazione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public IDedEditable Data { get; set; }
Public Property Data As IDedEditable
    Get
    Set
public:
property IDedEditable^ Data {
    IDedEditable^ get ();
    void set (IDedEditable^ value);
}
member Data : IDedEditable with get, set

Valore della proprietà

IDedEditable
Vedi anche

Documentazione

Classe ClassListItemClickEventArgs
Namespace DedNet


Proprietà ClassListItemClickEventArgs.ItemClicked

Proprietà ClassListItemClickEventArgsItemClicked
Restituisce il nome del class list cliccato dall'utente

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string ItemClicked { get; }
Public ReadOnly Property ItemClicked As String
    Get
public:
property String^ ItemClicked {
    String^ get ();
}
member ItemClicked : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe ClassListItemClickEventArgs
Namespace DedNet


Enumerazione ClientApplicationEnum
Applicazione client collegata.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum ClientApplicationEnum
Public Enumeration ClientApplicationEnum
public enum class ClientApplicationEnum
type ClientApplicationEnum
Membri
Nome | Valore | Descrizione
None | 0 | Enumerazione non inizializzata.
View | 1 | DedView.
Win | 2 | DedWin.
Office | 4 | DedOffice.
Acad | 8 | Ded x Top.
Inv | 16 | DedInv.
Manager | 32 | Manager del database.
Bricscad | 64 | Bricscad.
SolidWorks | 128 | SolidWorks.
Web | 256 | DedNetWeb
HandShake | 512 | HandShake
SolidEdge | 1,024 | SolidEdge.
AllCad | 1,240 | Tutti gli applicativi Cad.
Configuratore | 2,048 | Configuratore.
AllWritableApps | 3,806 | Tutti gli applicativi tranne il Manager ed il View.
AllButManager | 4,063 | Tutti gli applicativi tranne il Manager.
All | 4,095 | Tutti gli applicativi compreso il Manager.
Vedi anche

Documentazione

Namespace DedNet


Classe CommAnagEventArgs
Argomento utilizzato per lo scambio di informazioni durante la modifica dei legami tra commessa ed anagrafica.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetDedBeforeOrAfterEventArgs
DedNetCommAnagEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class CommAnagEventArgs : DedBeforeOrAfterEventArgs
Public Class CommAnagEventArgs
    Inherits DedBeforeOrAfterEventArgs
public ref class CommAnagEventArgs : public DedBeforeOrAfterEventArgs
type CommAnagEventArgs =
    class
        inherit DedBeforeOrAfterEventArgs
    end

Il tipo CommAnagEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | CommAnagEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AnagrComm | Restituisce l'oggetto anagrafica di commessa
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Comm | Restituisce l'elemento di commessa
Proprietà pubblica | Data | Restituisce l'oggetto anagrafica
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore CommAnagEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public CommAnagEventArgs()
Public Sub New
public:
CommAnagEventArgs()
new : unit -> CommAnagEventArgs
Vedi anche

Documentazione

Classe CommAnagEventArgs
Namespace DedNet


Proprietà di CommAnagEventArgs

Il tipo CommAnagEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AnagrComm | Restituisce l'oggetto anagrafica di commessa
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Comm | Restituisce l'elemento di commessa
Proprietà pubblica | Data | Restituisce l'oggetto anagrafica
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Torna su
Vedi anche

Documentazione

Classe CommAnagEventArgs
Namespace DedNet


Proprietà CommAnagEventArgs.AnagrComm

Proprietà CommAnagEventArgsAnagrComm
Restituisce l'oggetto anagrafica di commessa

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommAnagrItem AnagrComm { get; }
Public ReadOnly Property AnagrComm As DedCommAnagrItem
    Get
public:
property DedCommAnagrItem^ AnagrComm {
    DedCommAnagrItem^ get ();
}
member AnagrComm : DedCommAnagrItem with get

Valore della proprietà

DedCommAnagrItem
Vedi anche

Documentazione

Classe CommAnagEventArgs
Namespace DedNet


Proprietà CommAnagEventArgs.Comm

Proprietà CommAnagEventArgsComm
Restituisce l'elemento di commessa

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedComm Comm { get; }
Public ReadOnly Property Comm As DedComm
    Get
public:
property DedComm^ Comm {
    DedComm^ get ();
}
member Comm : DedComm with get

Valore della proprietà

DedComm
Vedi anche

Documentazione

Classe CommAnagEventArgs
Namespace DedNet


Proprietà CommAnagEventArgs.Data

Proprietà CommAnagEventArgsData
Restituisce l'oggetto anagrafica

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; }
Public ReadOnly Property Data As DedData
    Get
public:
property DedData^ Data {
    DedData^ get ();
}
member Data : DedData with get

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe CommAnagEventArgs
Namespace DedNet


Classe CommDescrOverrideEventArgs
Argomento per gli eventi di validazione della commessa.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetCommDescrOverrideEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class CommDescrOverrideEventArgs : EventArgs
Public Class CommDescrOverrideEventArgs
    Inherits EventArgs
public ref class CommDescrOverrideEventArgs : public EventArgs
type CommDescrOverrideEventArgs =
    class
        inherit EventArgs
    end

Il tipo CommDescrOverrideEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo protetto | CommDescrOverrideEventArgs | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Comm | Restituisce la famiglia selezionata.
Proprietà pubblica | Editable | Imposta/restituisce se la lista è editabile o fissa.
Proprietà pubblica | Form | Restituisce il form del QsManager.
Proprietà pubblica | HandlingCode |
Proprietà pubblica | Items | Imposta/restituisce gli elementi della lista a tendina.
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore CommDescrOverrideEventArgs
Costruttore unico.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal CommDescrOverrideEventArgs(
    DedFormQsManager form,
    DedCommType comm
)
Protected Friend Sub New (
    form As DedFormQsManager,
    comm As DedCommType
)
protected public:
CommDescrOverrideEventArgs(
    DedFormQsManager^ form,
    DedCommType^ comm
)
new :
        form : DedFormQsManager *
        comm : DedCommType -> CommDescrOverrideEventArgs

Parametri

form DedFormQsManager
comm DedCommType
Vedi anche

Documentazione

Classe CommDescrOverrideEventArgs
Namespace DedNet


Proprietà di CommDescrOverrideEventArgs

Il tipo CommDescrOverrideEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Comm | Restituisce la famiglia selezionata.
Proprietà pubblica | Editable | Imposta/restituisce se la lista è editabile o fissa.
Proprietà pubblica | Form | Restituisce il form del QsManager.
Proprietà pubblica | HandlingCode |
Proprietà pubblica | Items | Imposta/restituisce gli elementi della lista a tendina.
Torna su
Vedi anche

Documentazione

Classe CommDescrOverrideEventArgs
Namespace DedNet


Proprietà CommDescrOverrideEventArgs.Comm

Proprietà CommDescrOverrideEventArgsComm
Restituisce la famiglia selezionata.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommType Comm { get; }
Public ReadOnly Property Comm As DedCommType
    Get
public:
property DedCommType^ Comm {
    DedCommType^ get ();
}
member Comm : DedCommType with get

Valore della proprietà

DedCommType
Vedi anche

Documentazione

Classe CommDescrOverrideEventArgs
Namespace DedNet


Proprietà CommDescrOverrideEventArgs.Editable

Proprietà CommDescrOverrideEventArgsEditable
Imposta/restituisce se la lista è editabile o fissa.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Editable { get; set; }
Public Property Editable As Boolean
    Get
    Set
public:
property bool Editable {
    bool get ();
    void set (bool value);
}
member Editable : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CommDescrOverrideEventArgs
Namespace DedNet


Proprietà CommDescrOverrideEventArgs.Form

Proprietà CommDescrOverrideEventArgsForm
Restituisce il form del QsManager.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormQsManager Form { get; }
Public ReadOnly Property Form As DedFormQsManager
    Get
public:
property DedFormQsManager^ Form {
    DedFormQsManager^ get ();
}
member Form : DedFormQsManager with get

Valore della proprietà

DedFormQsManager
Vedi anche

Documentazione

Classe CommDescrOverrideEventArgs
Namespace DedNet


Proprietà CommDescrOverrideEventArgs.HandlingCode

Proprietà CommDescrOverrideEventArgsHandlingCode

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEventHandlerEnum HandlingCode { get; set; }
Public Property HandlingCode As DedEventHandlerEnum
    Get
    Set
public:
property DedEventHandlerEnum HandlingCode {
    DedEventHandlerEnum get ();
    void set (DedEventHandlerEnum value);
}
member HandlingCode : DedEventHandlerEnum with get, set

Valore della proprietà

DedEventHandlerEnum
Vedi anche

Documentazione

Classe CommDescrOverrideEventArgs
Namespace DedNet


Proprietà CommDescrOverrideEventArgs.Items

Proprietà CommDescrOverrideEventArgsItems
Imposta/restituisce gli elementi della lista a tendina.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> Items { get; set; }
Public Property Items As List(Of String)
    Get
    Set
public:
property List<String^>^ Items {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
member Items : List<string> with get, set

Valore della proprietà

List String
Vedi anche

Documentazione

Classe CommDescrOverrideEventArgs
Namespace DedNet


Classe CommElementCreateDataEventArgs
Argomento utilizzato per lo scambio di informazioni durante il salvataggio della distinta e quindi la creazione di una nuova anagrafica partendo da un elemento di distinta non codificato.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetCommElementCreateDataEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class CommElementCreateDataEventArgs : CancelEventArgs
Public Class CommElementCreateDataEventArgs
    Inherits CancelEventArgs
public ref class CommElementCreateDataEventArgs : public CancelEventArgs
type CommElementCreateDataEventArgs =
    class
        inherit CancelEventArgs
    end

Il tipo CommElementCreateDataEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | CommElementCreateDataEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione.
Proprietà pubblica | Comm | Restituisce l'elemento del quale si debba creare l'anagrafica.
Proprietà pubblica | Data | Restituisce l'oggetto nel quale impostare le informazioni di anagrafica da utilizzare nel salvataggio. In questo oggetto è necessario impostare il DED_DIS dell'elemento.
Proprietà pubblica | Fam | Restituisce o imposta la famiglia nella quale archiviare l'elemento.
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento.
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore CommElementCreateDataEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public CommElementCreateDataEventArgs()
Public Sub New
public:
CommElementCreateDataEventArgs()
new : unit -> CommElementCreateDataEventArgs
Vedi anche

Documentazione

Classe CommElementCreateDataEventArgs
Namespace DedNet


Proprietà di CommElementCreateDataEventArgs

Il tipo CommElementCreateDataEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione.
Proprietà pubblica | Comm | Restituisce l'elemento del quale si debba creare l'anagrafica.
Proprietà pubblica | Data | Restituisce l'oggetto nel quale impostare le informazioni di anagrafica da utilizzare nel salvataggio. In questo oggetto è necessario impostare il DED_DIS dell'elemento.
Proprietà pubblica | Fam | Restituisce o imposta la famiglia nella quale archiviare l'elemento.
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento.
Torna su
Vedi anche

Documentazione

Classe CommElementCreateDataEventArgs
Namespace DedNet


Proprietà CommElementCreateDataEventArgs.BeforeOrAfter

Proprietà CommElementCreateDataEventArgsBeforeOrAfter
Restituisce il momento dell'evento rispetto l'azione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEventTimeEnum BeforeOrAfter { get; }
Public ReadOnly Property BeforeOrAfter As DedEventTimeEnum
    Get
public:
property DedEventTimeEnum BeforeOrAfter {
    DedEventTimeEnum get ();
}
member BeforeOrAfter : DedEventTimeEnum with get

Valore della proprietà

DedEventTimeEnum
Vedi anche

Documentazione

Classe CommElementCreateDataEventArgs
Namespace DedNet


Proprietà CommElementCreateDataEventArgs.Comm

Proprietà CommElementCreateDataEventArgsComm
Restituisce l'elemento del quale si debba creare l'anagrafica.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedComm Comm { get; }
Public ReadOnly Property Comm As DedComm
    Get
public:
property DedComm^ Comm {
    DedComm^ get ();
}
member Comm : DedComm with get

Valore della proprietà

DedComm
Vedi anche

Documentazione

Classe CommElementCreateDataEventArgs
Namespace DedNet


Proprietà CommElementCreateDataEventArgs.Data

Proprietà CommElementCreateDataEventArgsData
Restituisce l'oggetto nel quale impostare le informazioni di anagrafica da utilizzare nel salvataggio. In questo oggetto è necessario impostare il DED_DIS dell'elemento.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public IDedData Data { get; }
Public ReadOnly Property Data As IDedData
    Get
public:
property IDedData^ Data {
    IDedData^ get ();
}
member Data : IDedData with get

Valore della proprietà

IDedData
Vedi anche

Documentazione

Classe CommElementCreateDataEventArgs
Namespace DedNet


Proprietà CommElementCreateDataEventArgs.Fam

Proprietà CommElementCreateDataEventArgsFam
Restituisce o imposta la famiglia nella quale archiviare l'elemento.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedType Fam { get; set; }
Public Property Fam As DedType
    Get
    Set
public:
property DedType^ Fam {
    DedType^ get ();
    void set (DedType^ value);
}
member Fam : DedType with get, set

Valore della proprietà

DedType
Vedi anche

Documentazione

Classe CommElementCreateDataEventArgs
Namespace DedNet


Proprietà CommElementCreateDataEventArgs.HandlingCode

Proprietà CommElementCreateDataEventArgsHandlingCode
Restituisce o imposta la gestione dell'evento.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEventHandlerEnum HandlingCode { get; set; }
Public Property HandlingCode As DedEventHandlerEnum
    Get
    Set
public:
property DedEventHandlerEnum HandlingCode {
    DedEventHandlerEnum get ();
    void set (DedEventHandlerEnum value);
}
member HandlingCode : DedEventHandlerEnum with get, set

Valore della proprietà

DedEventHandlerEnum
Vedi anche

Documentazione

Classe CommElementCreateDataEventArgs
Namespace DedNet


Classe CommFileExplorerUpdateEventArgs
Classe usata per calcolare il percorso da visualizzare nell'Esplora Risorse delle commesse.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetDedBeforeOrAfterEventArgs
DedNetDedEventArgs
DedNetCommFileExplorerUpdateEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class CommFileExplorerUpdateEventArgs : DedEventArgs
Public Class CommFileExplorerUpdateEventArgs
    Inherits DedEventArgs
public ref class CommFileExplorerUpdateEventArgs : public DedEventArgs
type CommFileExplorerUpdateEventArgs =
    class
        inherit DedEventArgs
    end

Il tipo CommFileExplorerUpdateEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | CommFileExplorerUpdateEventArgs | Costruttore unico.
Metodo pubblico | CommFileExplorerUpdateEventArgs(DedComm, DedCommType) | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Comm | Commessa selezionata.
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Proprietà pubblica | RootPathList | Lista dei percorsi radice da visualizzare.
Proprietà pubblica | Type | Famiglia di appartenenza della commessa.
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore CommFileExplorerUpdateEventArgs
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | CommFileExplorerUpdateEventArgs | Costruttore unico.
Metodo pubblico | CommFileExplorerUpdateEventArgs(DedComm, DedCommType) | Costruttore unico.
Torna su
Vedi anche

Documentazione

Classe CommFileExplorerUpdateEventArgs
Namespace DedNet


Costruttore CommFileExplorerUpdateEventArgs
Costruttore unico.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public CommFileExplorerUpdateEventArgs()
Public Sub New
public:
CommFileExplorerUpdateEventArgs()
new : unit -> CommFileExplorerUpdateEventArgs
Vedi anche

Documentazione

Classe CommFileExplorerUpdateEventArgs
Overload di CommFileExplorerUpdateEventArgs
Namespace DedNet


Costruttore CommFileExplorerUpdateEventArgs(DedComm, DedCommType)
Costruttore unico.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public CommFileExplorerUpdateEventArgs(
    DedComm comm,
    DedCommType type
)
Public Sub New (
    comm As DedComm,
    type As DedCommType
)
public:
CommFileExplorerUpdateEventArgs(
    DedComm^ comm,
    DedCommType^ type
)
new :
        comm : DedComm *
        type : DedCommType -> CommFileExplorerUpdateEventArgs

Parametri

comm DedComm
Commessa selezionata.
type DedCommType
Famiglia di appartenenza della commessa.
Vedi anche

Documentazione

Classe CommFileExplorerUpdateEventArgs
Overload di CommFileExplorerUpdateEventArgs
Namespace DedNet


Proprietà di CommFileExplorerUpdateEventArgs

Il tipo CommFileExplorerUpdateEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Comm | Commessa selezionata.
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Proprietà pubblica | RootPathList | Lista dei percorsi radice da visualizzare.
Proprietà pubblica | Type | Famiglia di appartenenza della commessa.
Torna su
Vedi anche

Documentazione

Classe CommFileExplorerUpdateEventArgs
Namespace DedNet


Proprietà CommFileExplorerUpdateEventArgs.Comm

Proprietà CommFileExplorerUpdateEventArgsComm
Commessa selezionata.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedComm Comm { get; set; }
Public Property Comm As DedComm
    Get
    Set
public:
property DedComm^ Comm {
    DedComm^ get ();
    void set (DedComm^ value);
}
member Comm : DedComm with get, set

Valore della proprietà

DedComm
Vedi anche

Documentazione

Classe CommFileExplorerUpdateEventArgs
Namespace DedNet


Proprietà CommFileExplorerUpdateEventArgs.RootPathList

Proprietà CommFileExplorerUpdateEventArgsRootPathList
Lista dei percorsi radice da visualizzare.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> RootPathList { get; set; }
Public Property RootPathList As List(Of String)
    Get
    Set
public:
property List<String^>^ RootPathList {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
member RootPathList : List<string> with get, set

Valore della proprietà

List String
Vedi anche

Documentazione

Classe CommFileExplorerUpdateEventArgs
Namespace DedNet


Proprietà CommFileExplorerUpdateEventArgs.Type

Proprietà CommFileExplorerUpdateEventArgsType
Famiglia di appartenenza della commessa.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommType Type { get; set; }
Public Property Type As DedCommType
    Get
    Set
public:
property DedCommType^ Type {
    DedCommType^ get ();
    void set (DedCommType^ value);
}
member Type : DedCommType with get, set

Valore della proprietà

DedCommType
Vedi anche

Documentazione

Classe CommFileExplorerUpdateEventArgs
Namespace DedNet


Classe CopyDocumentEventArgs
Racchiude le informazioni che riguardano lo spostamento/rinomina di un documento.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetDedBeforeOrAfterEventArgs
DedNetDedEventArgs
DedNetCopyDocumentEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class CopyDocumentEventArgs : DedEventArgs
Public Class CopyDocumentEventArgs
    Inherits DedEventArgs
public ref class CopyDocumentEventArgs : public DedEventArgs
type CopyDocumentEventArgs =
    class
        inherit DedEventArgs
    end

Il tipo CopyDocumentEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | CopyDocumentEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | Document | Restituisce il nuovo documento già aggiornato sulla nuova destinazione.
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | FromFileName | Restituisce il nome completo del file di partenza, riferito al vault.
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Proprietà pubblica | ToFileName | Restituisce il nome completo della destinazione, riferito al vault.
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore CopyDocumentEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public CopyDocumentEventArgs()
Public Sub New
public:
CopyDocumentEventArgs()
new : unit -> CopyDocumentEventArgs
Vedi anche

Documentazione

Classe CopyDocumentEventArgs
Namespace DedNet


Proprietà di CopyDocumentEventArgs

Il tipo CopyDocumentEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | Document | Restituisce il nuovo documento già aggiornato sulla nuova destinazione.
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | FromFileName | Restituisce il nome completo del file di partenza, riferito al vault.
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Proprietà pubblica | ToFileName | Restituisce il nome completo della destinazione, riferito al vault.
Torna su
Vedi anche

Documentazione

Classe CopyDocumentEventArgs
Namespace DedNet


Proprietà CopyDocumentEventArgs.Document

Proprietà CopyDocumentEventArgsDocument
Restituisce il nuovo documento già aggiornato sulla nuova destinazione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDoc Document { get; }
Public ReadOnly Property Document As DedDoc
    Get
public:
property DedDoc^ Document {
    DedDoc^ get ();
}
member Document : DedDoc with get

Valore della proprietà

DedDoc
Vedi anche

Documentazione

Classe CopyDocumentEventArgs
Namespace DedNet


Proprietà CopyDocumentEventArgs.FromFileName

Proprietà CopyDocumentEventArgsFromFileName
Restituisce il nome completo del file di partenza, riferito al vault.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string FromFileName { get; }
Public ReadOnly Property FromFileName As String
    Get
public:
property String^ FromFileName {
    String^ get ();
}
member FromFileName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe CopyDocumentEventArgs
Namespace DedNet


Proprietà CopyDocumentEventArgs.ToFileName

Proprietà CopyDocumentEventArgsToFileName
Restituisce il nome completo della destinazione, riferito al vault.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string ToFileName { get; }
Public ReadOnly Property ToFileName As String
    Get
public:
property String^ ToFileName {
    String^ get ();
}
member ToFileName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe CopyDocumentEventArgs
Namespace DedNet


Classe CreateMultiLevelBomEventArgs
Contiene la distinta ricambio multilivello
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetDedBeforeOrAfterEventArgs
DedNetCreateMultiLevelBomEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class CreateMultiLevelBomEventArgs : DedBeforeOrAfterEventArgs
Public Class CreateMultiLevelBomEventArgs
    Inherits DedBeforeOrAfterEventArgs
public ref class CreateMultiLevelBomEventArgs : public DedBeforeOrAfterEventArgs
type CreateMultiLevelBomEventArgs =
    class
        inherit DedBeforeOrAfterEventArgs
    end

Il tipo CreateMultiLevelBomEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | CreateMultiLevelBomEventArgs | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Bic | Distinta ricambio
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore CreateMultiLevelBomEventArgs
Costruttore

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public CreateMultiLevelBomEventArgs(
    BomItemCollection bic
)
Public Sub New (
    bic As BomItemCollection
)
public:
CreateMultiLevelBomEventArgs(
    BomItemCollection^ bic
)
new :
        bic : BomItemCollection -> CreateMultiLevelBomEventArgs

Parametri

bic BomItemCollection
Distinta
Vedi anche

Documentazione

Classe CreateMultiLevelBomEventArgs
Namespace DedNet


Proprietà di CreateMultiLevelBomEventArgs

Il tipo CreateMultiLevelBomEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Bic | Distinta ricambio
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Torna su
Vedi anche

Documentazione

Classe CreateMultiLevelBomEventArgs
Namespace DedNet


Proprietà CreateMultiLevelBomEventArgs.Bic

Proprietà CreateMultiLevelBomEventArgsBic
Distinta ricambio

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItemCollection Bic { get; }
Public ReadOnly Property Bic As BomItemCollection
    Get
public:
property BomItemCollection^ Bic {
    BomItemCollection^ get ();
}
member Bic : BomItemCollection with get

Valore della proprietà

BomItemCollection
Vedi anche

Documentazione

Classe CreateMultiLevelBomEventArgs
Namespace DedNet


Classe CreatingSparePartDrawingEventArgs
Argomento usato per le operazioni di aggiunta/modifica/eliminaizone in DEDDATA.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetCreatingSparePartDrawingEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class CreatingSparePartDrawingEventArgs : EventArgs
Public Class CreatingSparePartDrawingEventArgs
    Inherits EventArgs
public ref class CreatingSparePartDrawingEventArgs : public EventArgs
type CreatingSparePartDrawingEventArgs =
    class
        inherit EventArgs
    end

Il tipo CreatingSparePartDrawingEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | CreatingSparePartDrawingEventArgs | Crea una nuova instanza della classe 'CreatingSparePartDrawingEventArgs'.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Data | Anagrafica in cui si vuole associare il nuovo documento tecnico della tavola ricambi.
Proprietà pubblica | DelegateFileCopy | Delegate che viene richiamato se il comando è gestito da un add-in.
Proprietà pubblica | Document | Percorso del file di partenza da cui si vuole generare il documento tecnico della tavola ricambi.
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore CreatingSparePartDrawingEventArgs
Crea una nuova instanza della classe 'CreatingSparePartDrawingEventArgs'.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public CreatingSparePartDrawingEventArgs(
    DedDoc doc,
    DedData data
)
Public Sub New (
    doc As DedDoc,
    data As DedData
)
public:
CreatingSparePartDrawingEventArgs(
    DedDoc^ doc,
    DedData^ data
)
new :
        doc : DedDoc *
        data : DedData -> CreatingSparePartDrawingEventArgs

Parametri

doc DedDoc
data DedData
Anagrafica in cui si vuole associare il nuovo documento tecnico della tavola ricambi.
Vedi anche

Documentazione

Classe CreatingSparePartDrawingEventArgs
Namespace DedNet


Proprietà di CreatingSparePartDrawingEventArgs

Il tipo CreatingSparePartDrawingEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Data | Anagrafica in cui si vuole associare il nuovo documento tecnico della tavola ricambi.
Proprietà pubblica | DelegateFileCopy | Delegate che viene richiamato se il comando è gestito da un add-in.
Proprietà pubblica | Document | Percorso del file di partenza da cui si vuole generare il documento tecnico della tavola ricambi.
Torna su
Vedi anche

Documentazione

Classe CreatingSparePartDrawingEventArgs
Namespace DedNet


Proprietà CreatingSparePartDrawingEventArgs.Data

Proprietà CreatingSparePartDrawingEventArgsData
Anagrafica in cui si vuole associare il nuovo documento tecnico della tavola ricambi.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; set; }
Public Property Data As DedData
    Get
    Set
public:
property DedData^ Data {
    DedData^ get ();
    void set (DedData^ value);
}
member Data : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe CreatingSparePartDrawingEventArgs
Namespace DedNet


Proprietà CreatingSparePartDrawingEventArgs.DelegateFileCopy

Proprietà CreatingSparePartDrawingEventArgsDelegateFileCopy
Delegate che viene richiamato se il comando è gestito da un add-in.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public FileOperationDelegate<DocStructInfoList> DelegateFileCopy { get; set; }
Public Property DelegateFileCopy As FileOperationDelegate(Of DocStructInfoList)
    Get
    Set
public:
property FileOperationDelegate<DocStructInfoList^>^ DelegateFileCopy {
    FileOperationDelegate<DocStructInfoList^>^ get ();
    void set (FileOperationDelegate<DocStructInfoList^>^ value);
}
member DelegateFileCopy : FileOperationDelegate<DocStructInfoList> with get, set

Valore della proprietà

FileOperationDelegate DocStructInfoList
Vedi anche

Documentazione

Classe CreatingSparePartDrawingEventArgs
Namespace DedNet


Proprietà CreatingSparePartDrawingEventArgs.Document

Proprietà CreatingSparePartDrawingEventArgsDocument
Percorso del file di partenza da cui si vuole generare il documento tecnico della tavola ricambi.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDoc Document { get; set; }
Public Property Document As DedDoc
    Get
    Set
public:
property DedDoc^ Document {
    DedDoc^ get ();
    void set (DedDoc^ value);
}
member Document : DedDoc with get, set

Valore della proprietà

DedDoc
Vedi anche

Documentazione

Classe CreatingSparePartDrawingEventArgs
Namespace DedNet


Classe DedBeforeOrAfterEventArgs
Contiene l'indicazione di momento esecuzione comando.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetDedBeforeOrAfterEventArgs
Altro

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedBeforeOrAfterEventArgs : CancelEventArgs
Public Class DedBeforeOrAfterEventArgs
    Inherits CancelEventArgs
public ref class DedBeforeOrAfterEventArgs : public CancelEventArgs
type DedBeforeOrAfterEventArgs =
    class
        inherit CancelEventArgs
    end

Il tipo DedBeforeOrAfterEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedBeforeOrAfterEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione.
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script....
Torna su
Vedi anche

Documentazione

Namespace DedNet
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetDedBeforeOrAfterEventArgs
DedNetCommAnagEventArgs
DedNetCreateMultiLevelBomEventArgs
DedNetDedDataMoveEventArgs
DedNetDedDistEditSaveEventArgs
DedNetDedDistSaveEventArgs
DedNetDedEventArgs
DedNetDedOpenDocumentEventArgs
DedNetDocOperationEventArgs
DedNetDocStructInfoEventArgs
DedNetDocumentCheckLockedEventArgs
DedNetDocumentDisconnectingEventArgs
DedNetDocumentEventArgs
DedNetDocumentImportingEventArgs
DedNetDocumentLinkingEventArgs
DedNetDocumentMovingEventArgs
DedNetDocumentRecognizingEventArgs
DedNetDocumentsEventArgs
DedNetDragDropEventArgs
DedNetEditAttrEventArgs
DedNetManageSelectionDocsEventArgs
DedNetUnRilErasePublishEventArgs


Costruttore DedBeforeOrAfterEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedBeforeOrAfterEventArgs()
Public Sub New
public:
DedBeforeOrAfterEventArgs()
new : unit -> DedBeforeOrAfterEventArgs
Vedi anche

Documentazione

Classe DedBeforeOrAfterEventArgs
Namespace DedNet


Proprietà di DedBeforeOrAfterEventArgs

Il tipo DedBeforeOrAfterEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione.
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script....
Torna su
Vedi anche

Documentazione

Classe DedBeforeOrAfterEventArgs
Namespace DedNet


Proprietà DedBeforeOrAfterEventArgs.BeforeOrAfter

Proprietà DedBeforeOrAfterEventArgsBeforeOrAfter
Restituisce il momento dell'evento rispetto l'azione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEventTimeEnum BeforeOrAfter { get; set; }
Public Property BeforeOrAfter As DedEventTimeEnum
    Get
    Set
public:
property DedEventTimeEnum BeforeOrAfter {
    DedEventTimeEnum get ();
    void set (DedEventTimeEnum value);
}
member BeforeOrAfter : DedEventTimeEnum with get, set

Valore della proprietà

DedEventTimeEnum
Vedi anche

Documentazione

Classe DedBeforeOrAfterEventArgs
Namespace DedNet


Proprietà DedBeforeOrAfterEventArgs.Exception

Proprietà DedBeforeOrAfterEventArgsException
Eccezione per eventuale annullamento dell'evento. Utilizzabile da script....

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Exception Exception { get; set; }
Public Property Exception As Exception
    Get
    Set
public:
property Exception^ Exception {
    Exception^ get ();
    void set (Exception^ value);
}
member Exception : Exception with get, set

Valore della proprietà

Exception
Vedi anche

Documentazione

Classe DedBeforeOrAfterEventArgs
Namespace DedNet


Classe DedBomEditCustomControlEventArgs
Argomento utilizzato durante il click su un pulsante personalizzato tramite l'editor delle distinte.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetDedBomEditCustomControlEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedBomEditCustomControlEventArgs : EventArgs
Public Class DedBomEditCustomControlEventArgs
    Inherits EventArgs
public ref class DedBomEditCustomControlEventArgs : public EventArgs
type DedBomEditCustomControlEventArgs =
    class
        inherit EventArgs
    end

Il tipo DedBomEditCustomControlEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedBomEditCustomControlEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | ItemClicked | Restuisce l'elemento cliccato.
Proprietà pubblica | ItemToggleSwitched | Restuisce l'elemento di cui è cambiato lo stato.
Proprietà pubblica | NeedRefresh | Indica se è necessario un refresh dopo il comando.
Proprietà pubblica | ParentForm | Form di riferimento del controllo
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore DedBomEditCustomControlEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedBomEditCustomControlEventArgs()
Public Sub New
public:
DedBomEditCustomControlEventArgs()
new : unit -> DedBomEditCustomControlEventArgs
Vedi anche

Documentazione

Classe DedBomEditCustomControlEventArgs
Namespace DedNet


Proprietà di DedBomEditCustomControlEventArgs

Il tipo DedBomEditCustomControlEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | ItemClicked | Restuisce l'elemento cliccato.
Proprietà pubblica | ItemToggleSwitched | Restuisce l'elemento di cui è cambiato lo stato.
Proprietà pubblica | NeedRefresh | Indica se è necessario un refresh dopo il comando.
Proprietà pubblica | ParentForm | Form di riferimento del controllo
Torna su
Vedi anche

Documentazione

Classe DedBomEditCustomControlEventArgs
Namespace DedNet


Proprietà DedBomEditCustomControlEventArgs.ItemClicked

Proprietà DedBomEditCustomControlEventArgsItemClicked
Restuisce l'elemento cliccato.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BarButtonItem ItemClicked { get; }
Public ReadOnly Property ItemClicked As BarButtonItem
    Get
public:
property BarButtonItem^ ItemClicked {
    BarButtonItem^ get ();
}
member ItemClicked : BarButtonItem with get

Valore della proprietà

BarButtonItem
Vedi anche

Documentazione

Classe DedBomEditCustomControlEventArgs
Namespace DedNet


Proprietà DedBomEditCustomControlEventArgs.ItemToggleSwitched

Proprietà DedBomEditCustomControlEventArgsItemToggleSwitched
Restuisce l'elemento di cui è cambiato lo stato.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BarToggleSwitchItem ItemToggleSwitched { get; }
Public ReadOnly Property ItemToggleSwitched As BarToggleSwitchItem
    Get
public:
property BarToggleSwitchItem^ ItemToggleSwitched {
    BarToggleSwitchItem^ get ();
}
member ItemToggleSwitched : BarToggleSwitchItem with get

Valore della proprietà

BarToggleSwitchItem
Vedi anche

Documentazione

Classe DedBomEditCustomControlEventArgs
Namespace DedNet


Proprietà DedBomEditCustomControlEventArgs.NeedRefresh

Proprietà DedBomEditCustomControlEventArgsNeedRefresh
Indica se è necessario un refresh dopo il comando.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool NeedRefresh { get; set; }
Public Property NeedRefresh As Boolean
    Get
    Set
public:
property bool NeedRefresh {
    bool get ();
    void set (bool value);
}
member NeedRefresh : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedBomEditCustomControlEventArgs
Namespace DedNet


Proprietà DedBomEditCustomControlEventArgs.ParentForm

Proprietà DedBomEditCustomControlEventArgsParentForm
Form di riferimento del controllo

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormBomEdit ParentForm { get; set; }
Public Property ParentForm As DedFormBomEdit
    Get
    Set
public:
property DedFormBomEdit^ ParentForm {
    DedFormBomEdit^ get ();
    void set (DedFormBomEdit^ value);
}
member ParentForm : DedFormBomEdit with get, set

Valore della proprietà

DedFormBomEdit
Vedi anche

Documentazione

Classe DedBomEditCustomControlEventArgs
Namespace DedNet


Enumerazione DedChooseElement
Enumerazione delle tipologie di elementi selezionabili attraverso la finestra della ricerca in modalità Modale.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum DedChooseElement
Public Enumeration DedChooseElement
public enum class DedChooseElement
type DedChooseElement
Membri
Nome | Valore | Descrizione
Anagrafica | 0 |
Documento | 1 |
Famiglia | 2 |
DocumentoPrimario | 3 |
DocumentoAllegato | 4 |
Vedi anche

Documentazione

Namespace DedNet


Enumerazione DedChooseElementComm
Enumerazione delle tipologie di elementi selezionabili attraverso la finestra della scelta commesse.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum DedChooseElementComm
Public Enumeration DedChooseElementComm
public enum class DedChooseElementComm
type DedChooseElementComm
Membri
Nome | Valore | Descrizione
Comm | 0 |
Path | 1 |
Docs | 2 |
Vedi anche

Documentazione

Namespace DedNet


Classe DedCommandEventArgs
Argomento contenente le informazioni relative al comando in esecuzione.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetDedBeforeOrAfterEventArgs
DedNetDedEventArgs
DedNetDedCommandEventArgs
Altro

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedCommandEventArgs : DedEventArgs
Public Class DedCommandEventArgs
    Inherits DedEventArgs
public ref class DedCommandEventArgs : public DedEventArgs
type DedCommandEventArgs =
    class
        inherit DedEventArgs
    end

Il tipo DedCommandEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedCommandEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Command | Restituisce il comando in esecuzione.
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Proprietà pubblica | RunningContext | Contesto di lancio del comando
Torna su
Vedi anche

Documentazione

Namespace DedNet
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetDedBeforeOrAfterEventArgs
DedNetDedEventArgs
DedNetDedCommandEventArgs
DedNetDedCommCommandEventArgs
DedNetDedECOChangeStateCommandEventArgs
DedNetDedECOCommandEventArgs
DedNetDedOpenCommandEventArgs
DedNetStateCommandEventArgs


Costruttore DedCommandEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommandEventArgs()
Public Sub New
public:
DedCommandEventArgs()
new : unit -> DedCommandEventArgs
Vedi anche

Documentazione

Classe DedCommandEventArgs
Namespace DedNet


Proprietà di DedCommandEventArgs

Il tipo DedCommandEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Command | Restituisce il comando in esecuzione.
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Proprietà pubblica | RunningContext | Contesto di lancio del comando
Torna su
Vedi anche

Documentazione

Classe DedCommandEventArgs
Namespace DedNet


Proprietà DedCommandEventArgs.Command

Proprietà DedCommandEventArgsCommand
Restituisce il comando in esecuzione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommand Command { get; }
Public ReadOnly Property Command As DedCommand
    Get
public:
property DedCommand^ Command {
    DedCommand^ get ();
}
member Command : DedCommand with get

Valore della proprietà

DedCommand
Vedi anche

Documentazione

Classe DedCommandEventArgs
Namespace DedNet


Proprietà DedCommandEventArgs.RunningContext

Proprietà DedCommandEventArgsRunningContext
Contesto di lancio del comando

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommandRunningContextEnum RunningContext { get; }
Public ReadOnly Property RunningContext As DedCommandRunningContextEnum
    Get
public:
property DedCommandRunningContextEnum RunningContext {
    DedCommandRunningContextEnum get ();
}
member RunningContext : DedCommandRunningContextEnum with get

Valore della proprietà

DedCommandRunningContextEnum
Vedi anche

Documentazione

Classe DedCommandEventArgs
Namespace DedNet


Enumerazione DedCommandRunningContextEnum

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum DedCommandRunningContextEnum
Public Enumeration DedCommandRunningContextEnum
public enum class DedCommandRunningContextEnum
type DedCommandRunningContextEnum
Membri
Nome | Valore | Descrizione
MainCommand | 0 | Indica che il comando è in esecuzione come comando principale
SubCommand | 1 | Indica che il comando è stato lanciato come subcommand
Vedi anche

Documentazione

Namespace DedNet


Classe DedCommCancelEventArgs
Argomento per l'evento di conferma creazione/modifica commessa.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetDedCommCancelEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedCommCancelEventArgs : CancelEventArgs
Public Class DedCommCancelEventArgs
    Inherits CancelEventArgs
public ref class DedCommCancelEventArgs : public CancelEventArgs
type DedCommCancelEventArgs =
    class
        inherit CancelEventArgs
    end

Il tipo DedCommCancelEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedCommCancelEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Comm | Restituisce la commessa in modifica.
Proprietà pubblica | Command | Restituisce il comando in esecuzione.
Proprietà pubblica | CommData | Restituisce i dati della commessa in creazione.
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore DedCommCancelEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommCancelEventArgs()
Public Sub New
public:
DedCommCancelEventArgs()
new : unit -> DedCommCancelEventArgs
Vedi anche

Documentazione

Classe DedCommCancelEventArgs
Namespace DedNet


Proprietà di DedCommCancelEventArgs

Il tipo DedCommCancelEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Comm | Restituisce la commessa in modifica.
Proprietà pubblica | Command | Restituisce il comando in esecuzione.
Proprietà pubblica | CommData | Restituisce i dati della commessa in creazione.
Torna su
Vedi anche

Documentazione

Classe DedCommCancelEventArgs
Namespace DedNet


Proprietà DedCommCancelEventArgs.Comm

Proprietà DedCommCancelEventArgsComm
Restituisce la commessa in modifica.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedComm Comm { get; }
Public ReadOnly Property Comm As DedComm
    Get
public:
property DedComm^ Comm {
    DedComm^ get ();
}
member Comm : DedComm with get

Valore della proprietà

DedComm
Vedi anche

Documentazione

Classe DedCommCancelEventArgs
Namespace DedNet


Proprietà DedCommCancelEventArgs.Command

Proprietà DedCommCancelEventArgsCommand
Restituisce il comando in esecuzione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommand Command { get; }
Public ReadOnly Property Command As DedCommand
    Get
public:
property DedCommand^ Command {
    DedCommand^ get ();
}
member Command : DedCommand with get

Valore della proprietà

DedCommand
Vedi anche

Documentazione

Classe DedCommCancelEventArgs
Namespace DedNet


Proprietà DedCommCancelEventArgs.CommData

Proprietà DedCommCancelEventArgsCommData
Restituisce i dati della commessa in creazione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDictionary CommData { get; }
Public ReadOnly Property CommData As DedDictionary
    Get
public:
property DedDictionary^ CommData {
    DedDictionary^ get ();
}
member CommData : DedDictionary with get

Valore della proprietà

DedDictionary
Vedi anche

Documentazione

Classe DedCommCancelEventArgs
Namespace DedNet


Classe DedCommCommandEventArgs
Informazioni per gli eventi dei comdandi di creazione/modifica commessa.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetDedBeforeOrAfterEventArgs
DedNetDedEventArgs
DedNetDedCommandEventArgs
DedNetDedCommCommandEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedCommCommandEventArgs : DedCommandEventArgs
Public Class DedCommCommandEventArgs
    Inherits DedCommandEventArgs
public ref class DedCommCommandEventArgs : public DedCommandEventArgs
type DedCommCommandEventArgs =
    class
        inherit DedCommandEventArgs
    end

Il tipo DedCommCommandEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedCommCommandEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Comm | Restituisce la commessa in modifica.
Proprietà pubblica | Command | Restituisce il comando in esecuzione. (Ereditato da DedCommandEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | CommData | Restituisce i dati della commessa in creazione. Lasciato per retrocompatibilità con passato. Usare proprietà Info
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Proprietà pubblica | Info | Informazioni circa la codifica della commessa
Proprietà pubblica | RunningContext | Contesto di lancio del comando (Ereditato da DedCommandEventArgs)
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore DedCommCommandEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommCommandEventArgs()
Public Sub New
public:
DedCommCommandEventArgs()
new : unit -> DedCommCommandEventArgs
Vedi anche

Documentazione

Classe DedCommCommandEventArgs
Namespace DedNet


Proprietà di DedCommCommandEventArgs

Il tipo DedCommCommandEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Comm | Restituisce la commessa in modifica.
Proprietà pubblica | Command | Restituisce il comando in esecuzione. (Ereditato da DedCommandEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | CommData | Restituisce i dati della commessa in creazione. Lasciato per retrocompatibilità con passato. Usare proprietà Info
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Proprietà pubblica | Info | Informazioni circa la codifica della commessa
Proprietà pubblica | RunningContext | Contesto di lancio del comando (Ereditato da DedCommandEventArgs)
Torna su
Vedi anche

Documentazione

Classe DedCommCommandEventArgs
Namespace DedNet


Proprietà DedCommCommandEventArgs.Comm

Proprietà DedCommCommandEventArgsComm
Restituisce la commessa in modifica.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedComm Comm { get; }
Public ReadOnly Property Comm As DedComm
    Get
public:
property DedComm^ Comm {
    DedComm^ get ();
}
member Comm : DedComm with get

Valore della proprietà

DedComm
Vedi anche

Documentazione

Classe DedCommCommandEventArgs
Namespace DedNet


Proprietà DedCommCommandEventArgs.CommData

Proprietà DedCommCommandEventArgsCommData
Restituisce i dati della commessa in creazione. Lasciato per retrocompatibilità con passato. Usare proprietà Info

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDictionary CommData { get; }
Public ReadOnly Property CommData As DedDictionary
    Get
public:
property DedDictionary^ CommData {
    DedDictionary^ get ();
}
member CommData : DedDictionary with get

Valore della proprietà

DedDictionary
Vedi anche

Documentazione

Classe DedCommCommandEventArgs
Namespace DedNet


Proprietà DedCommCommandEventArgs.Info

Proprietà DedCommCommandEventArgsInfo
Informazioni circa la codifica della commessa

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEncodeInfo Info { get; set; }
Public Property Info As DedEncodeInfo
    Get
    Set
public:
property DedEncodeInfo^ Info {
    DedEncodeInfo^ get ();
    void set (DedEncodeInfo^ value);
}
member Info : DedEncodeInfo with get, set

Valore della proprietà

DedEncodeInfo
Vedi anche

Documentazione

Classe DedCommCommandEventArgs
Namespace DedNet


Classe DedDataChangedEventArgs
Argomento usato per le operazioni di aggiunta/modifica/eliminaizone in DEDDATA.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetDedDataChangedEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedDataChangedEventArgs : EventArgs
Public Class DedDataChangedEventArgs
    Inherits EventArgs
public ref class DedDataChangedEventArgs : public EventArgs
type DedDataChangedEventArgs =
    class
        inherit EventArgs
    end

Il tipo DedDataChangedEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedDataChangedEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Data |
Proprietà pubblica | Operation |
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore DedDataChangedEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataChangedEventArgs()
Public Sub New
public:
DedDataChangedEventArgs()
new : unit -> DedDataChangedEventArgs
Vedi anche

Documentazione

Classe DedDataChangedEventArgs
Namespace DedNet


Proprietà di DedDataChangedEventArgs

Il tipo DedDataChangedEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Data |
Proprietà pubblica | Operation |
Torna su
Vedi anche

Documentazione

Classe DedDataChangedEventArgs
Namespace DedNet


Proprietà DedDataChangedEventArgs.Data

Proprietà DedDataChangedEventArgsData

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; }
Public ReadOnly Property Data As DedData
    Get
public:
property DedData^ Data {
    DedData^ get ();
}
member Data : DedData with get

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe DedDataChangedEventArgs
Namespace DedNet


Proprietà DedDataChangedEventArgs.Operation

Proprietà DedDataChangedEventArgsOperation

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataOperationEnum Operation { get; }
Public ReadOnly Property Operation As DedDataOperationEnum
    Get
public:
property DedDataOperationEnum Operation {
    DedDataOperationEnum get ();
}
member Operation : DedDataOperationEnum with get

Valore della proprietà

DedDataOperationEnum
Vedi anche

Documentazione

Classe DedDataChangedEventArgs
Namespace DedNet


Classe DedDataMoveEventArgs
Argomento usato per le operazioni di spostamento DEDDATA.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetDedBeforeOrAfterEventArgs
DedNetDedDataMoveEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedDataMoveEventArgs : DedBeforeOrAfterEventArgs
Public Class DedDataMoveEventArgs
    Inherits DedBeforeOrAfterEventArgs
public ref class DedDataMoveEventArgs : public DedBeforeOrAfterEventArgs
type DedDataMoveEventArgs =
    class
        inherit DedBeforeOrAfterEventArgs
    end

Il tipo DedDataMoveEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedDataMoveEventArgs | Nell'evento di After è altamente sconsigliato effettuare dei "SetValue()" sull'anagrafica. Eventuali modifiche sull'anagrafica vanno effettuate necessariamente nell'evento di Before.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Data |
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | FromType |
Proprietà pubblica | IgnoreFiles |
Proprietà pubblica | SkipCheckAttr |
Proprietà pubblica | ToType |
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore DedDataMoveEventArgs
Nell'evento di After è altamente sconsigliato effettuare dei "SetValue()" sull'anagrafica. Eventuali modifiche sull'anagrafica vanno effettuate necessariamente nell'evento di Before.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataMoveEventArgs(
    DedData data,
    DedType fromType,
    DedType toType
)
Public Sub New (
    data As DedData,
    fromType As DedType,
    toType As DedType
)
public:
DedDataMoveEventArgs(
    DedData^ data,
    DedType^ fromType,
    DedType^ toType
)
new :
        data : DedData *
        fromType : DedType *
        toType : DedType -> DedDataMoveEventArgs

Parametri

data DedData
Anagraficha sulla quale viene eseguito il comando.
fromType DedType
Famiglia di partenza.
toType DedType
Famiglia di destinazione.
Vedi anche

Documentazione

Classe DedDataMoveEventArgs
Namespace DedNet


Proprietà di DedDataMoveEventArgs

Il tipo DedDataMoveEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Data |
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | FromType |
Proprietà pubblica | IgnoreFiles |
Proprietà pubblica | SkipCheckAttr |
Proprietà pubblica | ToType |
Torna su
Vedi anche

Documentazione

Classe DedDataMoveEventArgs
Namespace DedNet


Proprietà DedDataMoveEventArgs.Data

Proprietà DedDataMoveEventArgsData

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; }
Public ReadOnly Property Data As DedData
    Get
public:
property DedData^ Data {
    DedData^ get ();
}
member Data : DedData with get

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe DedDataMoveEventArgs
Namespace DedNet


Proprietà DedDataMoveEventArgs.FromType

Proprietà DedDataMoveEventArgsFromType

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedType FromType { get; }
Public ReadOnly Property FromType As DedType
    Get
public:
property DedType^ FromType {
    DedType^ get ();
}
member FromType : DedType with get

Valore della proprietà

DedType
Vedi anche

Documentazione

Classe DedDataMoveEventArgs
Namespace DedNet


Proprietà DedDataMoveEventArgs.IgnoreFiles

Proprietà DedDataMoveEventArgsIgnoreFiles

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IgnoreFiles { get; set; }
Public Property IgnoreFiles As Boolean
    Get
    Set
public:
property bool IgnoreFiles {
    bool get ();
    void set (bool value);
}
member IgnoreFiles : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDataMoveEventArgs
Namespace DedNet


Proprietà DedDataMoveEventArgs.SkipCheckAttr

Proprietà DedDataMoveEventArgsSkipCheckAttr

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool SkipCheckAttr { get; set; }
Public Property SkipCheckAttr As Boolean
    Get
    Set
public:
property bool SkipCheckAttr {
    bool get ();
    void set (bool value);
}
member SkipCheckAttr : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDataMoveEventArgs
Namespace DedNet


Proprietà DedDataMoveEventArgs.ToType

Proprietà DedDataMoveEventArgsToType

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedType ToType { get; }
Public ReadOnly Property ToType As DedType
    Get
public:
property DedType^ ToType {
    DedType^ get ();
}
member ToType : DedType with get

Valore della proprietà

DedType
Vedi anche

Documentazione

Classe DedDataMoveEventArgs
Namespace DedNet


Enumerazione DedDataOperationEnum
Enumerazione sul tipo di operazione effettuata in DEDDATA.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum DedDataOperationEnum
Public Enumeration DedDataOperationEnum
public enum class DedDataOperationEnum
type DedDataOperationEnum
Membri
Nome | Valore | Descrizione
Added | 0 | Aggiunta record.
Modified | 1 | Modifica record.
Deleted | 2 | Eliminazione record.
Vedi anche

Documentazione

Namespace DedNet


Classe DedDistEditSaveEventArgs
Evento chiamato prima e dopo il comando di salvataggio dall'editor delle distinte.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetDedBeforeOrAfterEventArgs
DedNetDedDistEditSaveEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedDistEditSaveEventArgs : DedBeforeOrAfterEventArgs
Public Class DedDistEditSaveEventArgs
    Inherits DedBeforeOrAfterEventArgs
public ref class DedDistEditSaveEventArgs : public DedBeforeOrAfterEventArgs
type DedDistEditSaveEventArgs =
    class
        inherit DedBeforeOrAfterEventArgs
    end

Il tipo DedDistEditSaveEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedDistEditSaveEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Item |
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore DedDistEditSaveEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDistEditSaveEventArgs()
Public Sub New
public:
DedDistEditSaveEventArgs()
new : unit -> DedDistEditSaveEventArgs
Vedi anche

Documentazione

Classe DedDistEditSaveEventArgs
Namespace DedNet


Proprietà di DedDistEditSaveEventArgs

Il tipo DedDistEditSaveEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Item |
Torna su
Vedi anche

Documentazione

Classe DedDistEditSaveEventArgs
Namespace DedNet


Proprietà DedDistEditSaveEventArgs.Item

Proprietà DedDistEditSaveEventArgsItem

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItemCollection Item { get; set; }
Public Property Item As BomItemCollection
    Get
    Set
public:
property BomItemCollection^ Item {
    BomItemCollection^ get ();
    void set (BomItemCollection^ value);
}
member Item : BomItemCollection with get, set

Valore della proprietà

BomItemCollection
Vedi anche

Documentazione

Classe DedDistEditSaveEventArgs
Namespace DedNet


Classe DedDistSaveEventArgs
Evento chiamato prima e dopo il comando di salvataggio della distinta.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetDedBeforeOrAfterEventArgs
DedNetDedDistSaveEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedDistSaveEventArgs : DedBeforeOrAfterEventArgs
Public Class DedDistSaveEventArgs
    Inherits DedBeforeOrAfterEventArgs
public ref class DedDistSaveEventArgs : public DedBeforeOrAfterEventArgs
type DedDistSaveEventArgs =
    class
        inherit DedBeforeOrAfterEventArgs
    end

Il tipo DedDistSaveEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedDistSaveEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Error | Specifica se sono avvenuti errori o se l'operazione è andata a buon fine. false => operazione eseguita correttamente (default); true => sono avvenuti errori.
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | SavingDistElement |
Proprietà pubblica | SkipSave | Specifica se saltare il salvataggio della distinta dell'elemento passato. La procedura però prosegue per i suoi figli.
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore DedDistSaveEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDistSaveEventArgs()
Public Sub New
public:
DedDistSaveEventArgs()
new : unit -> DedDistSaveEventArgs
Vedi anche

Documentazione

Classe DedDistSaveEventArgs
Namespace DedNet


Proprietà di DedDistSaveEventArgs

Il tipo DedDistSaveEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Error | Specifica se sono avvenuti errori o se l'operazione è andata a buon fine. false => operazione eseguita correttamente (default); true => sono avvenuti errori.
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | SavingDistElement |
Proprietà pubblica | SkipSave | Specifica se saltare il salvataggio della distinta dell'elemento passato. La procedura però prosegue per i suoi figli.
Torna su
Vedi anche

Documentazione

Classe DedDistSaveEventArgs
Namespace DedNet


Proprietà DedDistSaveEventArgs.Error

Proprietà DedDistSaveEventArgsError
Specifica se sono avvenuti errori o se l'operazione è andata a buon fine. false => operazione eseguita correttamente (default); true => sono avvenuti errori.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Error { get; set; }
Public Property Error As Boolean
    Get
    Set
public:
property bool Error {
    bool get ();
    void set (bool value);
}
member Error : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDistSaveEventArgs
Namespace DedNet


Proprietà DedDistSaveEventArgs.SavingDistElement

Proprietà DedDistSaveEventArgsSavingDistElement

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public SaveDistCommandSavingDistElement SavingDistElement { get; set; }
Public Property SavingDistElement As SaveDistCommandSavingDistElement
    Get
    Set
public:
property SaveDistCommandSavingDistElement^ SavingDistElement {
    SaveDistCommandSavingDistElement^ get ();
    void set (SaveDistCommandSavingDistElement^ value);
}
member SavingDistElement : SaveDistCommandSavingDistElement with get, set

Valore della proprietà

SaveDistCommandSavingDistElement
Vedi anche

Documentazione

Classe DedDistSaveEventArgs
Namespace DedNet


Proprietà DedDistSaveEventArgs.SkipSave

Proprietà DedDistSaveEventArgsSkipSave
Specifica se saltare il salvataggio della distinta dell'elemento passato. La procedura però prosegue per i suoi figli.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool SkipSave { get; set; }
Public Property SkipSave As Boolean
    Get
    Set
public:
property bool SkipSave {
    bool get ();
    void set (bool value);
}
member SkipSave : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDistSaveEventArgs
Namespace DedNet


Classe DedECOChangeStateCommandEventArgs
Informazioni per gli eventi dei comdandi di cambio stato ECO.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetDedBeforeOrAfterEventArgs
DedNetDedEventArgs
DedNetDedCommandEventArgs
DedNetDedECOChangeStateCommandEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedECOChangeStateCommandEventArgs : DedCommandEventArgs
Public Class DedECOChangeStateCommandEventArgs
    Inherits DedCommandEventArgs
public ref class DedECOChangeStateCommandEventArgs : public DedCommandEventArgs
type DedECOChangeStateCommandEventArgs =
    class
        inherit DedCommandEventArgs
    end

Il tipo DedECOChangeStateCommandEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedECOChangeStateCommandEventArgs | Crea una nuova istanza della classe 'DedECOChangeStateCommandEventArgs'.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AssignedUser | Stato in cui deve essere impostato l'ECO.
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Command | Restituisce il comando in esecuzione. (Ereditato da DedCommandEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | ECO | Imposta/Restituisce l'ECO di riferimento.
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Proprietà pubblica | RunningContext | Contesto di lancio del comando (Ereditato da DedCommandEventArgs)
Proprietà pubblica | State | Stato in cui deve essere impostato l'ECO.
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore DedECOChangeStateCommandEventArgs
Crea una nuova istanza della classe 'DedECOChangeStateCommandEventArgs'.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedECOChangeStateCommandEventArgs(
    DedEco eco,
    DedEcoEcoStateEnum state,
    DedUser assignedUser
)
Public Sub New (
    eco As DedEco,
    state As DedEcoEcoStateEnum,
    assignedUser As DedUser
)
public:
DedECOChangeStateCommandEventArgs(
    DedEco^ eco,
    DedEcoEcoStateEnum state,
    DedUser^ assignedUser
)
new :
        eco : DedEco *
        state : DedEcoEcoStateEnum *
        assignedUser : DedUser -> DedECOChangeStateCommandEventArgs

Parametri

eco DedEco
ECO di cui si vuole cambiare lo stato.
state DedEcoEcoStateEnum
Stato di destinazione dell'ECO.
assignedUser DedUser
Utente a cui deve essere assegnato l'ECO.
Vedi anche

Documentazione

Classe DedECOChangeStateCommandEventArgs
Namespace DedNet


Proprietà di DedECOChangeStateCommandEventArgs

Il tipo DedECOChangeStateCommandEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AssignedUser | Stato in cui deve essere impostato l'ECO.
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Command | Restituisce il comando in esecuzione. (Ereditato da DedCommandEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | ECO | Imposta/Restituisce l'ECO di riferimento.
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Proprietà pubblica | RunningContext | Contesto di lancio del comando (Ereditato da DedCommandEventArgs)
Proprietà pubblica | State | Stato in cui deve essere impostato l'ECO.
Torna su
Vedi anche

Documentazione

Classe DedECOChangeStateCommandEventArgs
Namespace DedNet


Proprietà DedECOChangeStateCommandEventArgs.AssignedUser

Proprietà DedECOChangeStateCommandEventArgsAssignedUser
Stato in cui deve essere impostato l'ECO.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedUser AssignedUser { get; }
Public ReadOnly Property AssignedUser As DedUser
    Get
public:
property DedUser^ AssignedUser {
    DedUser^ get ();
}
member AssignedUser : DedUser with get

Valore della proprietà

DedUser
Vedi anche

Documentazione

Classe DedECOChangeStateCommandEventArgs
Namespace DedNet


Proprietà DedECOChangeStateCommandEventArgs.ECO

Proprietà DedECOChangeStateCommandEventArgsECO
Imposta/Restituisce l'ECO di riferimento.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEco ECO { get; }
Public ReadOnly Property ECO As DedEco
    Get
public:
property DedEco^ ECO {
    DedEco^ get ();
}
member ECO : DedEco with get

Valore della proprietà

DedEco
Vedi anche

Documentazione

Classe DedECOChangeStateCommandEventArgs
Namespace DedNet


Proprietà DedECOChangeStateCommandEventArgs.State

Proprietà DedECOChangeStateCommandEventArgsState
Stato in cui deve essere impostato l'ECO.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEcoEcoStateEnum State { get; }
Public ReadOnly Property State As DedEcoEcoStateEnum
    Get
public:
property DedEcoEcoStateEnum State {
    DedEcoEcoStateEnum get ();
}
member State : DedEcoEcoStateEnum with get

Valore della proprietà

DedEcoEcoStateEnum
Vedi anche

Documentazione

Classe DedECOChangeStateCommandEventArgs
Namespace DedNet


Classe DedECOCommandEventArgs
Informazioni per gli eventi dei comdandi di creazione/modifica ECO.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetDedBeforeOrAfterEventArgs
DedNetDedEventArgs
DedNetDedCommandEventArgs
DedNetDedECOCommandEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedECOCommandEventArgs : DedCommandEventArgs
Public Class DedECOCommandEventArgs
    Inherits DedCommandEventArgs
public ref class DedECOCommandEventArgs : public DedCommandEventArgs
type DedECOCommandEventArgs =
    class
        inherit DedCommandEventArgs
    end

Il tipo DedECOCommandEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedECOCommandEventArgs | Crea una nuova istanza della classe 'DedECOCommandEventArgs'.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Anagr | Anagrafica associata all'ECO.
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Comm | Commessa associata all'ECO.
Proprietà pubblica | Command | Restituisce il comando in esecuzione. (Ereditato da DedCommandEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | ECO | Imposta/Restituisce l'ECO di riferimento.
Proprietà pubblica | ECOData | Restituisce i dati dell'ECO in creazione.
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Proprietà pubblica | RunningContext | Contesto di lancio del comando (Ereditato da DedCommandEventArgs)
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore DedECOCommandEventArgs
Crea una nuova istanza della classe 'DedECOCommandEventArgs'.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedECOCommandEventArgs(
    DedEco eco,
    DedData data,
    DedComm comm,
    DedDictionary ecoData
)
Public Sub New (
    eco As DedEco,
    data As DedData,
    comm As DedComm,
    ecoData As DedDictionary
)
public:
DedECOCommandEventArgs(
    DedEco^ eco,
    DedData^ data,
    DedComm^ comm,
    DedDictionary^ ecoData
)
new :
        eco : DedEco *
        data : DedData *
        comm : DedComm *
        ecoData : DedDictionary -> DedECOCommandEventArgs

Parametri

eco DedEco
ECO in creazione.
data DedData
Anagrafica associata all'ECO.
comm DedComm
Commessa associata all'ECO.
ecoData DedDictionary
Parametri dell'ECO.
Vedi anche

Documentazione

Classe DedECOCommandEventArgs
Namespace DedNet


Proprietà di DedECOCommandEventArgs

Il tipo DedECOCommandEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Anagr | Anagrafica associata all'ECO.
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Comm | Commessa associata all'ECO.
Proprietà pubblica | Command | Restituisce il comando in esecuzione. (Ereditato da DedCommandEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | ECO | Imposta/Restituisce l'ECO di riferimento.
Proprietà pubblica | ECOData | Restituisce i dati dell'ECO in creazione.
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Proprietà pubblica | RunningContext | Contesto di lancio del comando (Ereditato da DedCommandEventArgs)
Torna su
Vedi anche

Documentazione

Classe DedECOCommandEventArgs
Namespace DedNet


Proprietà DedECOCommandEventArgs.Anagr

Proprietà DedECOCommandEventArgsAnagr
Anagrafica associata all'ECO.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Anagr { get; }
Public ReadOnly Property Anagr As DedData
    Get
public:
property DedData^ Anagr {
    DedData^ get ();
}
member Anagr : DedData with get

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe DedECOCommandEventArgs
Namespace DedNet


Proprietà DedECOCommandEventArgs.Comm

Proprietà DedECOCommandEventArgsComm
Commessa associata all'ECO.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedComm Comm { get; }
Public ReadOnly Property Comm As DedComm
    Get
public:
property DedComm^ Comm {
    DedComm^ get ();
}
member Comm : DedComm with get

Valore della proprietà

DedComm
Vedi anche

Documentazione

Classe DedECOCommandEventArgs
Namespace DedNet


Proprietà DedECOCommandEventArgs.ECO

Proprietà DedECOCommandEventArgsECO
Imposta/Restituisce l'ECO di riferimento.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEco ECO { get; }
Public ReadOnly Property ECO As DedEco
    Get
public:
property DedEco^ ECO {
    DedEco^ get ();
}
member ECO : DedEco with get

Valore della proprietà

DedEco
Vedi anche

Documentazione

Classe DedECOCommandEventArgs
Namespace DedNet


Proprietà DedECOCommandEventArgs.ECOData

Proprietà DedECOCommandEventArgsECOData
Restituisce i dati dell'ECO in creazione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDictionary ECOData { get; }
Public ReadOnly Property ECOData As DedDictionary
    Get
public:
property DedDictionary^ ECOData {
    DedDictionary^ get ();
}
member ECOData : DedDictionary with get

Valore della proprietà

DedDictionary
Vedi anche

Documentazione

Classe DedECOCommandEventArgs
Namespace DedNet


Classe DedEventArgs
Argomento contenente le informazioni relative al comando in esecuzione.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetDedBeforeOrAfterEventArgs
DedNetDedEventArgs
Altro

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedEventArgs : DedBeforeOrAfterEventArgs
Public Class DedEventArgs
    Inherits DedBeforeOrAfterEventArgs
public ref class DedEventArgs : public DedBeforeOrAfterEventArgs
type DedEventArgs =
    class
        inherit DedBeforeOrAfterEventArgs
    end

Il tipo DedEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled.
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento.
Torna su
Vedi anche

Documentazione

Namespace DedNet
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetDedBeforeOrAfterEventArgs
DedNetDedEventArgs
DedNetBomExplorerAddReplaceDataEventArgs
DedNetBomExplorerContextMenuOpeningEventArgs
DedNetBomExplorerLoadDistEventArgs
DedNetChangingDependencyDocumentEventArgs
DedNetCommFileExplorerUpdateEventArgs
DedNetCopyDocumentEventArgs
DedNetDedCommandEventArgs
DedNetDependencyFileInfoEventArgs
DedNetDisableAutoUpdateAnagrCommEventArgs
DedNetDistAddNodeEventArgs
DedNetDocRegognizerClientsEventArgs
DedNetDocumentDragDropEventArgs
DedNetFindCodeStateFilterEventArgs
DedNetGetRepresentationSuffixListEventArgs
DedNetImportOnSaveEventArgs
DedNetListImportDataEventArgs
DedNetManagePlaceHolderEventArgs
DedNetMoveDocumentEventArgs
DedNetMultipleStateChangeExecuteEventArgs
DedNetNoteTransferPackEventArgs
DedNetOverwriteImportPlaceHolderEventArgs
DedNetResolveDedFileDescriptorEventArgs
DedNetResolveDocStructInfoEventArgs


Costruttore DedEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEventArgs()
Public Sub New
public:
DedEventArgs()
new : unit -> DedEventArgs
Vedi anche

Documentazione

Classe DedEventArgs
Namespace DedNet


Proprietà di DedEventArgs

Il tipo DedEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled.
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento.
Torna su
Vedi anche

Documentazione

Classe DedEventArgs
Namespace DedNet


Proprietà DedEventArgs.CommandResult

Proprietà DedEventArgsCommandResult
Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCmdResult CommandResult { get; set; }
Public Property CommandResult As DedCmdResult
    Get
    Set
public:
property DedCmdResult CommandResult {
    DedCmdResult get ();
    void set (DedCmdResult value);
}
member CommandResult : DedCmdResult with get, set

Valore della proprietà

DedCmdResult
Vedi anche

Documentazione

Classe DedEventArgs
Namespace DedNet


Proprietà DedEventArgs.HandlingCode

Proprietà DedEventArgsHandlingCode
Restituisce o imposta la gestione dell'evento.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEventHandlerEnum HandlingCode { get; set; }
Public Property HandlingCode As DedEventHandlerEnum
    Get
    Set
public:
property DedEventHandlerEnum HandlingCode {
    DedEventHandlerEnum get ();
    void set (DedEventHandlerEnum value);
}
member HandlingCode : DedEventHandlerEnum with get, set

Valore della proprietà

DedEventHandlerEnum
Vedi anche

Documentazione

Classe DedEventArgs
Namespace DedNet


Enumerazione DedEventHandlerEnum
Enumerazione che specifica la gestione dell'evento.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum DedEventHandlerEnum
Public Enumeration DedEventHandlerEnum
public enum class DedEventHandlerEnum
type DedEventHandlerEnum
Membri
Nome | Valore | Descrizione
NotHandled | 0 | Non gestito da chi ha ricevuto la notifica dell'evento. Il comando prosegue normalmente ignorando la proprietà CommandResult.
Handled | 1 | Gestito da chi ha ricevuto la notifica dell'evento. Il comando viene interrotto restituendo il valore impostato in CommandResult.
Cancelled | 2 | Annullata l'operazione. Il comando viene interrotto restituendo il valore impostato in CommandResult.
Vedi anche

Documentazione

Namespace DedNet


Enumerazione DedEventTimeEnum
Enumerazione sul momento nel quale l'evento è lanciato.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum DedEventTimeEnum
Public Enumeration DedEventTimeEnum
public enum class DedEventTimeEnum
type DedEventTimeEnum
Membri
Nome | Valore | Descrizione
Before | 0 | Prima dell'azione.
After | 1 | Dopo l'azione.
Vedi anche

Documentazione

Namespace DedNet


Enumerazione DedEventTimeFileResolutionEnum
Enumerazione sul momento nel quale l'evento è lanciato.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum DedEventTimeFileResolutionEnum
Public Enumeration DedEventTimeFileResolutionEnum
public enum class DedEventTimeFileResolutionEnum
type DedEventTimeFileResolutionEnum
Membri
Nome | Valore | Descrizione
BeforeDedResolution | 0 | Prima della risoluzione del Ded.
AfterDedResolution | 1 | Dopo la risoluzione del Ded.
Vedi anche

Documentazione

Namespace DedNet


Enumerazione DedFindCodeContextEnum
Contesto di esecuzione nel quale è utilizzato il controllo "DedFindCodeControl".

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum DedFindCodeContextEnum
Public Enumeration DedFindCodeContextEnum
public enum class DedFindCodeContextEnum
type DedFindCodeContextEnum
Membri
Nome | Valore | Descrizione
Default | 0 | Contesto di default.
Bom | 1 | Contesto di esecuzione: Editor delle distinte.
FormFindCode | 2 | Contesto di esecuzione: DedFormFindCode.
Order | 3 | Contesto di esecuzione: Gestore commesse.
BomVariantSave | 4 | Contesto di esecuzione: Salva variante di distinta.
BomAddCode | 5 | Contesto di aggiunta elementi nel form della distinta.
DataAlternative | 6 | Contesto di aggiunta elementi nel form della distinta.
Vedi anche

Documentazione

Namespace DedNet


Classe DedNetApplication
Classe principale che espone alle altre applicazioni tutte le funzionalità ed i comandi e soprattutto le finestre di dialogo.
Gerarchia di ereditarietà
SystemObject
DedNetDedNetApplication

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
[ProgIdAttribute("DedNet.Application")]
public class DedNetApplication : IDedNetApplication,
    IDisposable
<ProgIdAttribute("DedNet.Application")>
Public Class DedNetApplication
    Implements IDedNetApplication, IDisposable
[ProgIdAttribute(L"DedNet.Application")]
public ref class DedNetApplication : IDedNetApplication,
    IDisposable
[<ProgIdAttribute("DedNet.Application")>]
type DedNetApplication =
    class
        interface IDedNetApplication
        interface IDisposable
    end

Il tipo DedNetApplication espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetApplication | Costruttore unico senza argomenti per la compatibilità COM.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllCommands | Restituisce la lista di tutti i comandi dell'applicazione.
Proprietà pubblica | ApplicationCommands | Restituisce la lista dei comandi Applicazione.
Proprietà pubblica | AttManager | Restituisce il gestore delle liste collegate agli attributi.
Proprietà pubblica | AttributesEco | Restituisce la lista degli attributi ECO.
Proprietà pubblica | AttributesOcc | Restituisce la lista degli attributi di occorrenza.
Proprietà pubblica | AutocadExtension | Estensioni di Autocad.
Proprietà pubblica | AutoCompleteOnTyping | Indica se deve essere abilitato l'autocompletamento, mentre sto digitando, nel controllo custom DedFindCodeControl.
Proprietà pubblica | BomEditFormCommandList | Lista dei comandi del form dell'editor delle distinte ( bars ).
Proprietà pubblica | BomExplorerCtrlCommandList | Lista dei comandi dei controlli explorer dell'editor delle distinte ( toolbars ).
Proprietà pubblica | BomManualSettings | Ritorna le configurazioni per la visualizzazione delle colonne nei form relativi alle distinte
Proprietà pubblica | CascadeAutocomplete | Indica se autocompilare la tendina di un attributo associato a una cascata nel caso in cui la tendina contenga un solo valore.
Proprietà pubblica | CascadeManager | Restituisce il gestore delle cascate.
Proprietà pubblica | CategManager | Restituisce il gestore delle categorie.
Proprietà pubblica | CheckFunctions | Restituisce la lista delle funzioni di controllo usate negli attributi.
Proprietà pubblica | ClassList | Restituisce la lista di classList usate negli attributi.
Proprietà pubblica | ClientCommands | Restituisce la lista dei comandi Client.
Proprietà pubblica | ClientConnected | Restituisce o imposta la tipologia di client connesso.
Proprietà pubblica | ClientConnectedIgnoreTemporary | Client connesso reale e non forzato
Proprietà pubblica | CloseWindowOnLoad | Indica se chiudere la finestra dopo i comndi di caricamento componenti.
Proprietà pubblica | CloseWindowOnOpening | Indica se chiudere la finestra dopo che il documento è stato aperto.
Proprietà pubblica | Connection | Restituisce l'oggetto QSConnection correntemente utilizzato dall'applicazione.
Proprietà pubblica | ConnectionString | Imposta o restituisce la stringa di connesione al Database.
Proprietà pubblica | ContextManager | Restituisce il Manager di Contesto Documento.
Proprietà pubblica | Corporates | Restitusice la lista delle corporate disponibili
Proprietà pubblica | CurrentComm | Legge o imposta la commessa corrente
Proprietà pubblica | CustomCommands | Restituisce la lista dei comandi personalizzati.
Proprietà pubblica | CustomTranslations | Restituisce la lista delle traduzioni custom aziendali.
Proprietà pubblica | DataManager | Restituisce il Manager delle Anagrafiche.
Proprietà pubblica | DedManagerConnectionString | Imposta o restituisce la stringa di connesione del QsManager al Database.
Proprietà pubblica | DedManagerProviderName | Imposta o restituisce il nome completo della classe del provider di collegamento del QsManager al Database.
Proprietà pubblica | DefaultAnagrCommand | Comando di default da lanciare sul doppio click nelle anagrafiche.
Proprietà pubblica | DefaultDocumentCommand | Comando di default da lanciare sul doppio click neli documenti.
Proprietà pubblica | DocManager | Restituisce il Manager dei Documenti.
Proprietà pubblica | DocumentsWithInternalAttributes | Restituisce la lista delle estensioni dei file che se sono in checkout impediscono l'editazione degli attributi a livello di form ricerca e di comando.
Proprietà pubblica | DpiX | Ritorna la risoluzione orizontale attualmente impostata.
Proprietà pubblica | DpiY | Ritorna la risoluzione verticale attualmente impostata.
Proprietà pubblica | EcoManager | Restituisce l' EcoManager degli Eco.
Proprietà pubblica | ExecuteQueryOnEnter | Indica se il controllo custom DedFindCodeControl deve essere visualizzato con la combobox (True) o con il LookUpEdit (False).
Proprietà pubblica | Extensions | Ritorna la collection di addin caricati
Proprietà pubblica | FileServerManager | Restituisce l'oggetto che gestisce le informazioni sul client/server per la gestione dei file.
Proprietà pubblica | FormFindCodeQueryFields | Restituisce la lista dei campi nel combo di selezione campo query del form DedFormFindCode.
Proprietà pubblica | FormFindCodeResFields | Restituisce la lista dei campi da visualizzare nel combo di risultato ricerca del form DedFormFindCode.
Proprietà pubblica | GerenicDepExtension | Estensioni delle dipendenze di tipo Generic.
Proprietà pubblica | HideAttributeTranslations | Indica se nascondere le traduzioni degli attributi (di default è False).
Proprietà pubblica | IgnoreExtension | Estensioni da ignorare.
Proprietà pubblica | Initialized | Restituisce se l'inizializzazione dell'oggetto è già avvenuta correttamente attraverso la chiamata al metodo Init() con esito positivo.
Proprietà pubblica | InstallPath | Restituisce il path di installazione del DedNet (della root senza la cartella bin).
Proprietà pubblica | InventorExtension | Estensioni di Inventor.
Proprietà pubblica | IsDisposed | Restituisce true se è stato già fatto il Dispose dell'oggetto.
Proprietà pubblica | IsExportingCommand | Indica se il comando di esportazione è in esecuzione
Proprietà pubblica | IsImporterRunning | Indica se l'importartatore è stato avviato ed è in corso l'operazione di importazione dati.
Proprietà pubblica | IsLightInit | Restituisce se è stata fatta un'inizializzazione light.
Proprietà pubblica | Language | Imposta o restituisce la lingua dell'applicazione.
Proprietà pubblica | LastError | Restituisce l'ultimo errore che si è verificato utilizzando i metodi e le proprietà di questa interfaccia.
Proprietà pubblica | ListManager | Restituisce l'oggetto dedicato alla gestione delle liste.
Proprietà pubblica | LoadCurrentCode | Indica se, all'apertura dell'Apri Veloce, deve essere caricata l'anagrafica corrente (se presente).
Proprietà pubblica | LogManager | Restituisce il log manager per la gestione del log nel DB
Proprietà pubblica | LogVerbose | Indica se è attiva la modalità di debug che consente al logger di scrivere maggiori informazioni.
Proprietà pubblica | MainWindow | Restituisce o imposta la finestra principale dell'applicazione client da usare di default come parent di tutte le finestre mostrate (modali e non).
Proprietà pubblica | Notifier | Restituisce l'oggetto che gestisce le notifiche.
Proprietà pubblica | NumCharMemo | Indica il numero dei caratteri oltre il quale usare memoEdit
Proprietà pubblica | PathBomSetting | Imposta o restituisce il percorso in cui cercare la configurazione da usare per la visualizzazione delle colonne nei form relativi alle distinte
Proprietà pubblica | PathLoghi | Imposta o restituisce il percorso in cui cercare i loghi da usare per l'esportazione/stampa dei risultati.
Proprietà pubblica | PathRoots | Restituisce l'oggetto che gestisce la lista delle radici di archiviazione.
Proprietà pubblica | PathTemplate | Imposta o restituisce il percorso in cui cercare i template da usare per l'esportazione/stampa dei risultati.
Proprietà pubblica | PriorityExtList | Restituisce la lista delle estensioni alla quale dare la priorità nella selezione dei documenti. Aggiungere a questa collezione le estensioni (senza punto) sulle quali si desidera dare la precedenza.
Proprietà pubblica | PriorityExtListOriginal | Lista di appoggio contenente le estensioni originali
Proprietà pubblica | ProviderName | Imposta o restituisce il nome completo della classe del provider di collegamento al Database.
Proprietà pubblica | PubExtList | Restituisce la lista delle estensioni per le quali associare i documenti come pubblicazione. Aggiungere a questa collezione le estensioni (senza punto) per le quali usare questo tipo di associazione nel caso di associazione file primario. Di default viene inizializzata con dwf, pdf e tif.
Proprietà pubblica | RapExtList | Restituisce la lista delle estensioni per le quali è consentito creare una nuova rappresentazione. Aggiungere a questa collezione le estensioni (senza punto) per le quali si desidera dare questa possibilità. Di default viene inizializzata con dwg, iam ed ipt.
Proprietà pubblica | RegistryBaseDir | Restituisce la radice delle impostazioni di registro del Ded omettendo il nome della chiave principale che è da considerarsi di default HKEY_CURRENT_USER.
Proprietà pubblica | RegistryDocAssocOnOpen | Restituisce la chiave di registro contenente i dati dei documenti in apertura. Omette il nome della chiave principale che è da considerarsi di default HKEY_CURRENT_USER.
Proprietà pubblica | RegistryRootDir | Restituisce la radice delle impostazioni di registro omettendo il nome della chiave principale che è da considerarsi di default HKEY_CURRENT_USER.
Proprietà pubblica | Root | Restituisce l'oggetto DedType radice dell'albero delle famiglie di archiviazione.
Proprietà pubblica | RootComm | Restituisce l'oggetto DedCommType radice dell'albero delle commesse di archiviazione.
Proprietà pubblica | SearchFilter | Dizionario contenente i vari filtri applicabili sul risultato ricerca.
Proprietà pubblica | SessionID | Identifica in modo univoco la sessione corrente.
Proprietà pubblica | ShowAttributeLabelsInUI | Indica se nascondere le traduzioni degli attributi (di default è False).
Proprietà pubblica | ShowListOnTyping | Indica se deve essere visualizzata la tendina con tutti i codici, mentre sto digitando, nel controllo custom DedFindCodeControl.
Proprietà pubblica | SkipCheckDbVersion | Indica se controllare o meno la versione del Database in avvio
Proprietà pubblica | SkipExtensionsLoading | Controlla se caricare o meno le estensioni dell'applicazione
Proprietà pubblica | SolidworksExtension | Estensioni di SolidWorks.
Proprietà pubblica | SparePartManualForm | Restituisce il diaogo utilizzato per la generazione del manuale ricambi.
Proprietà pubblica | SparePartsManualManager | Ritorna tutti i settaggi di stile che deve avere il manuale ricambi.
Proprietà pubblica | StateManager | Restituisce il Manager degli stati.
Proprietà pubblica | StrHiddenValue | Costante che identifica il valore da usare quando l'utente non ha i pemessi
Proprietà pubblica | TablesAttrAnagr | Restituisce le tabelle interessate agli attributi di Anagrafica
Proprietà pubblica | TablesAttrAnagrComm | Restituisce le tabelle interessate agli attributi di AnagraficaDiCommessa
Proprietà pubblica | TablesAttrComm | Restituisce le tabelle interessate agli attributi di Commessa
Proprietà pubblica | TablesAttrDist | Restituisce le tabelle interessate agli attributi di Distinta
Proprietà pubblica | TablesAttrDoc | Restituisce le tabelle interessate agli attributi di Documento
Proprietà pubblica | TablesAttrEco | Restituisce le tabelle interessate agli attributi di Eco
Proprietà pubblica | TimeManager | Restituisce l'oggetto dedicato alla gestione dei tempi.
Proprietà pubblica | TransferManager | Restituisce il TransferManager per la gestione delle richieste.
Proprietà pubblica | TranslationManager | Restituisce il TranslationManager per la gestione delle traduzioni in lingua.
Proprietà pubblica | TypeManager | Restituisce il Manager delle Famiglie.
Proprietà pubblica | UseModalDialog | Indica se visualizzqare i dialoghi in modalità (Modal) usato in Bricscad.
Proprietà pubblica | User | Restituisce l'oggetto DedUser descrivente l'utente attualmente collegato al Database con i suoi permessi.
Proprietà pubblica | UseRevAsDiscrimInDist | Indica se considerare la revisione come discriminante nelle distinte.
Proprietà pubblica | UserPermManager | Restituisce il gestore dei permessi e degli utenti (per la modifica).
Proprietà pubblica | Util | Restituisce l'oggetto Assert.
Proprietà pubblica | Vars | Restituisce l'oggetto per la lettura delle variabili.
Proprietà pubblica | Versione | Restituisce la versione.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AskByFindComm | Richiede la selezione di una commessa tramite interfaccia di selezione
Metodo pubblico | AskByFindCommDoc | Richiede la selezione di una commessa tramite interfaccia di selezione
Metodo pubblico | AskByFindCommPath | Richiede la selezione di un percorso tramite interfaccia di selezione commesse
Metodo pubblico | AskByFindDocs(String, Boolean, DedDocList) | Visualizza la finestra di ricerca documentale in modalità Modale per chiedere all'utente la selezione di uno o più documenti. Se restituisce Abort l'errore avvenuto è reperibile attraverso la proprietà LastError.
Metodo pubblico | AskByFindDocs(String, Boolean, DedDocList, DedDocList) | Visualizza la finestra di ricerca documentale in modalità Modale per chiedere all'utente la selezione di uno o più documenti. Se restituisce Abort l'errore avvenuto è reperibile attraverso la proprietà LastError.
Metodo pubblico | AskByFindDocs(String, Boolean, ListString, DedDocList) | Visualizza la finestra di ricerca documentale in modalità Modale per chiedere all'utente la selezione di uno o più documenti. Se restituisce Abort l'errore avvenuto è reperibile attraverso la proprietà LastError.
Metodo pubblico | AskByFindDocs(String, Boolean, DedDocList, DedDocList, ListString) | Visualizza la finestra di ricerca documentale in modalità Modale per chiedere all'utente la selezione di uno o più documenti. Se restituisce Abort l'errore avvenuto è reperibile attraverso la proprietà LastError.
Metodo pubblico | AskByFindRoot | Visualizza la finestra di ricerca documentale in modalità Modale per chiedere all'utente la selezione di una root. Se restituisce Abort l'errore avvenuto è reperibile attraverso la proprietà LastError.
Metodo pubblico | AskByMainForm(String, DedChooseElement, Boolean, DedFormMainSelectInfo) | Visualizza la finestra principale in modalità Modale per chiedere all'utente la selezione di una o più anagrafiche. Se restituisce Abort l'errore avvenuto è reperibile attraverso la proprietà LastError.
Metodo pubblico | AskByMainForm(String, DedChooseElement, Boolean, Boolean, DedFormMainSelectInfo) | Visualizza la finestra principale in modalità Modale per chiedere all'utente la selezione di una o più anagrafiche. Se restituisce Abort l'errore avvenuto è reperibile attraverso la proprietà LastError.
Metodo pubblico | AskByMainForm(String, DedChooseElement, Boolean, Boolean, Boolean, DedFormMainSelectInfo) | Visualizza la finestra principale in modalità Modale per chiedere all'utente la selezione di una o più anagrafiche. Se restituisce Abort l'errore avvenuto è reperibile attraverso la proprietà LastError.
Metodo pubblico | AskByMainForm(String, DedChooseElement, Boolean, Boolean, Boolean, DedType, DedFormMainSelectInfo) | Visualizza la finestra principale in modalità Modale per chiedere all'utente la selezione di una o più anagrafiche. Se restituisce Abort l'errore avvenuto è reperibile attraverso la proprietà LastError.
Metodo pubblico | AskByMainForm(String, DedDataList, DedChooseElement, Boolean, Boolean, Boolean, DedType, DedFormMainSelectInfo) | Visualizza la finestra principale in modalità Modale per chiedere all'utente la selezione di una o più anagrafiche. Se restituisce Abort l'errore avvenuto è reperibile attraverso la proprietà LastError.
Metodo pubblico | AskByMainForm(String, DedDataList, DedChooseElement, Boolean, Boolean, Boolean, DedType, ListString, DedFormMainSelectInfo) | Visualizza la finestra principale in modalità Modale, con la visualizzazione di una lista di anagrafiche definite, per chiedere all'utente la selezione di uno o più documenti. Se restituisce Abort l'errore avvenuto è reperibile attraverso la proprietà LastError.
Metodo pubblico | AskDedTypeByMainForm | Visualizza la finestra principale in modalità Modale per chiedere all'utente la selezione di una famiglia. Se restituisce Abort l'errore avvenuto è reperibile attraverso la proprietà LastError.
Metodo pubblico | BeginFileTransaction | Restituisce la transazione di file in atto oppure ne crea una nuova e la restituisce. QUESTO METODO È SEMPRE DA UTILIZZARE INSIEME A EndFileTransaction().
Metodo pubblico | ChangeContext | Cambia il contesto di associazione tra anagrafica e documento. Permette solo il cambio da Modello a Pubblicazione o viceversa.
Metodo pubblico | ChangeDependencyDocument | Aggiorna la dipendenza fisica di uno specifico documento padre aggiornandola al nuovo documento. Se attiva l'area locale, l'aggiornamento deve avvenire sia nel file presente nel vault che nella pws.
Metodo pubblico | CheckPwsLastCleaning | Controlla l'ultima pulizia dell'area locale e nel caso mostra un avvertimento
Metodo pubblico | ClearForcedAuthentication | Cancella le credenziali per l'accesso automatico senza autenticazione.
Metodo pubblico | Close | Chiude l'oggetto liberando le risorse.
Metodo pubblico | CommMatchFilter | Restituisce true se la commessa soddisfa i criteri di ricerca impostati
Metodo pubblico | CompileProgDedDataEncode | Compila il campo prog dentro DedDataEncode
Metodo pubblico | CreateAddCommCommand | Crea un nuovo comando per la creazione di una commessa.
Metodo pubblico | CreateAddEcoCommand | Crea un nuovo comando per la creazione di un ECO.
Metodo pubblico | CreateAddRecurrentTimingCommand | Crea un nuovo comando AddRecurrentTimingCommand.
Metodo pubblico | CreateAddSubCommCommand | Crea un nuovo comando per la creazione di una sotto commessa.
Metodo pubblico | CreateAnagrAssocCommCommand | Crea un nuovo comando AnagrAssocComm che permette di associare delle anagrafiche ad una commessa.
Metodo pubblico | CreateAnagrForm | Crea e restituisce la finestra di visualizzazione/editazione degli attributi di un'anagrafica.
Metodo pubblico | CreateAnagrHistoryCommand | Crea un nuovo comando AnagrHistory che mostra all'utente la storia dell'anagrafica.
Metodo pubblico | CreateAnnullaCheckOutCommand | Crea un nuovo comando Annulla CheckOut. Ripristina il documento al momento in cui è stato scaricato dal vault.
Metodo pubblico | CreateAssignEcoToSpecificUserCommand | Crea un nuovo comando di assegna ECO.
Metodo pubblico | CreateAssociateAlternativeCodeCommand | Crea un nuovo comando che chiede all'utente di associare all'anagrafice dei codici alternativi.
Metodo pubblico | CreateAssociateDocForm | Crea e restituisce la finestra di scelta delle opzioni di associazione documento.
Metodo pubblico | CreateAssociateDocumentCommand | Crea un nuovo comando AssociateDocument che permette di associare/importare un documento/file ad un'anagrafica.
Metodo pubblico | CreateBomEditCommand | Crea un nuovo comando DedBomEdit che mostra all'utente il form di editazione delle distinte.
Metodo pubblico | CreateBomEditOpenReadCommand | Crea un nuovo comando DedBomEdit che mostra all'utente il form di editazione delle distinte. Viene inizializzato il pannello di consultazione con l'anagrafica selezionata
Metodo pubblico | CreateBomHistoryCommand | Crea un nuovo comando DedBomHistory che mostra all'utente il form dello storico delle distinte.
Metodo pubblico | CreateBomHistoryForm | Crea e restituisce la finestra di visualizzazione storico distinta.
Metodo pubblico | CreateBomWhereUsedCommand | Crea un nuovo comando BomWhereUsedCommand.
Metodo pubblico | CreateChangeEcoStateToAssignedCommand | Crea un nuovo comando di cambia stato ECO. Imposta lo stato come 'Assegnato'.
Metodo pubblico | CreateChangeEcoStateToClosedCommand | Crea un nuovo comando di cambia stato ECO. Imposta lo stato come 'Chiuso'.
Metodo pubblico | CreateChangeEcoStateToOpenCommand | Crea un nuovo comando di cambia stato ECO. Imposta lo stato come 'Aperto'.
Metodo pubblico | CreateChangePwdCommand | Crea un nuovo comando Cambio Password.
Metodo pubblico | CreateChangeRepresentationSuffixCommand | Crea un nuovo comando ChangeRepresentationSuffixCommand. E' disponibile solo su documenti in contesto rappresentazione.
Metodo pubblico | CreateChangeStateForm | Crea e restituisce la finestra di cambio stato.
Metodo pubblico | CreateChargeCommCommand | Crea un nuovo comando per la presa in carico di una commessa.
Metodo pubblico | CreateCheckInDocumentCommand | Crea un nuovo comando di Check-In. Effettua la pubblicazione del documento e poi lo mette in Check-In.
Metodo pubblico | CreateCheckInStrutturaDocumentCommand | Crea un nuovo comando di Check-In. Effettua la pubblicazione del documento e poi lo mette in Check-In.
Metodo pubblico | CreateCheckOutCommand | Crea un nuovo comando CheckOut. Scarica dal vault il documento, lo copia in locale e lo imposta in CheckOut.
Metodo pubblico | CreateCheckOutStrutturaCommand | Crea un nuovo comando CheckOut. Scarica dal vault il documento, lo copia in locale e lo imposta in CheckOut.
Metodo pubblico | CreateChmHelpCommand | Crea un nuovo comando Help.
Metodo pubblico | CreateChoseFileForm | Crea e restituisce la finestra di selezione del tipo di file.
Metodo pubblico | CreateCloseCommCommand | Crea un nuovo comando per l'eliminazione di una commessa.
Metodo pubblico | CreateComm | Crea e restituisce un nuova commessa avente il nome specificato. Imposta già la data attuale e l'utente di creazione.
Metodo pubblico | CreateCommAnagrViewCommand | Crea un nuovo comando DedCommEdit che mostra all'utente il form di editazione delle commesse.
Metodo pubblico | CreateCommEditCommand | Crea un nuovo comando DedCommEdit che mostra all'utente il form di editazione delle commesse.
Metodo pubblico | CreateCommEsplCommand | Crea un nuovo comando per la visualizzazione della distinta esplosa di una commessa.
Metodo pubblico | CreateCommViewCommand | Crea un nuovo comando DedCommEdit che mostra all'utente il form di editazione delle commesse.
Metodo pubblico | CreateCopyDocumentCommand | Crea un nuovo comando MoveDocument per rinominare/spostare i documenti. E' disponibile solo negli allegati.
Metodo pubblico | CreateCreateEditSparePartsAttributesCommand | Crea un nuovo comando CreateSparePartsDrawingCommand.
Metodo pubblico | CreateCreateEditSparePartsAttributesCommand(CommandContextEnum) | Crea un nuovo comando CreateSparePartsDrawingCommand.
Metodo pubblico | CreateCreateFolderCommand | Crea un nuovo comando Crea cartella. Crea una cartella.
Metodo pubblico | CreateCreateManualCommand | Crea un nuovo comando 'CreateSparePartsManualCommand'.
Metodo pubblico | CreateCreateSparePartsDrawingCommand | Crea un nuovo comando CreateSparePartsDrawingCommand.
Metodo pubblico | CreateDataStatisticsAnalyzer | Crea un nuovo comando FindInRicercaCommand che permette di aprire la ricerca con selezionata l'anagrafica associata all'anagrafica o al documento selezionato.
Metodo pubblico | CreateDbDocCompareCommand | Crea un nuovo comando DbDocCompareCommand che mostra le differenze tra due anagrafiche.
Metodo pubblico | CreateDbDocCompareForm | Creazione del form di comparazione anagrafiche.
Metodo pubblico | CreateDbVersionCommand | Crea un nuovo comando DbVersionCommand. Permesso minimo di READ in modo che venga visualizzato anche se l'utente non lo può eseguire, utile nel caso in cui venga usato il comando login con un altro utente.
Metodo pubblico | CreateDedAboutCommand | Crea un nuovo comando Help.
Metodo pubblico | CreateDedListEditCommand | Crea un nuovo comando di InsertDocumentToPrint
Metodo pubblico | CreateDedListManagerCommand | Crea un nuovo comando GEstore Liste.
Metodo pubblico | CreateDedRuleApplier | Crea e restituisce un oggetto che si occupa di applicare le regole di auto-composizione su di una parte cioè un oggetto che implementa IDedData.
Metodo pubblico | CreateDefFileNameForm | Creazione del form definizione dei nomi file.
Metodo pubblico | CreateDeleteAnagrCommCommand | Crea un nuovo comando per l'eliminazione di anagrafiche di commessa.
Metodo pubblico | CreateDeleteCommCommand | Crea un nuovo comando per l'eliminazione di una commessa.
Metodo pubblico | CreateDeleteDataCommand | Crea un nuovo comando che chiede all'utente se vuole eliminare l'anagrafica.
Metodo pubblico | CreateDeleteEcoCommand | Crea un nuovo comando di eliminazione Eco dal database.
Metodo pubblico | CreateDeleteFolderCommand | Crea un nuovo comando Elimina cartella. Elimina una cartella e tutti i suoi documenti.
Metodo pubblico | CreateDisconnectCommDocumentCommand | Crea un nuovo comando DisconnectCommDocument. E' disponibile ovunque ci siano le anagrafiche ed anche siano visualizzati i documenti relativi.
Metodo pubblico | CreateDisconnectDocumentCommand | Crea un nuovo comando DisconnectDocument. E' disponibile ovunque ci siano le anagrafiche ed anche siano visualizzati i documenti relativi.
Metodo pubblico | CreateDistEsplCommand | Crea un nuovo comando DistEspl.
Metodo pubblico | CreateDistForm | Crea e restituisce la finestra di visualizzazione distinta esplosa ed implosa.
Metodo pubblico | CreateDistImplCommand | Crea un nuovo comando DistImpl.
Metodo pubblico | CreateDistManager | Crea e restituisce un nuovo oggetto DistManager che si occupa della gestione della distinta.
Metodo pubblico | CreateDistViewCommand | Crea un nuovo comando BomEditCommand che mostra all'utente il form di editazione delle distente in modalità visualizzazione.
Metodo pubblico | CreateDocAssocCommand | Crea un nuovo comando DocAssocCommand.
Metodo pubblico | CreateDocHistoryCommand | Crea un nuovo comando AnagrHistory che mostra all'utente la storia dell'anagrafica.
Metodo pubblico | CreateDocRecognizerCommand | Crea nuovo comando DocRecognizerCommand
Metodo pubblico | CreateDocSearchForm | Crea e restituisce la finestra di ricerca documentale.
Metodo pubblico | CreateDocTransferHistoryCommand | Crea un nuovo comando DocTransferHistoryCommand che mostra all'utente la storia dei trasferimenti del documento.
Metodo pubblico | CreateDocumentCommand | Crea e restituisce il comando che permette di creare un documento dato il nome completo di un file. Aggiunge nel Database anche tutti i documenti da esso dipendenti.
Metodo pubblico | CreateDuplicaRecordCommand | Crea un nuovo comando SaveCommand dedicato alla duplicazione dell'anagrafica.
Metodo pubblico | CreateDuplicateCommCommand | Crea un nuovo comando per la duplicazione di una commessa.
Metodo pubblico | CreateEcoEditCommand | Crea un nuovo comando per la visualizzazione degli Eco.
Metodo pubblico | CreateEcoHistoryCommand | Crea un nuovo comando EcoHistory che mostra all'utente la storia dell'eco.
Metodo pubblico | CreateEditAnagrCommand | Crea un nuovo comando EditAnagr.
Metodo pubblico | CreateEditCommCommand | Crea un nuovo comando per l'eliminazione di una commessa.
Metodo pubblico | CreateEditCommForm | Crea e restituisce la finestra per creare o modificare una commessa.
Metodo pubblico | CreateEditEcoCommand | Crea un nuovo comando per la creazione di un ECO.
Metodo pubblico | CreateEditOnlyDbAttributesCommand | Crea un nuovo comando di editazione attributi solo db con context none
Metodo pubblico | CreateEditOnlyDbAttributesCommand(CommandContextEnum) | Crea un nuovo comando CreateSparePartsDrawingCommand.
Metodo pubblico | CreateEndAllActiveTimingsCommand | Crea un nuovo comando EndAllTimingsCommand.
Metodo pubblico | CreateEndTimingCommand | Crea un nuovo comando EndTimingCommand.
Metodo pubblico | CreateEnsureLocalDocumentCommand | Crea e restituisce il sotto-comando che si occupa della copia in locale del documento e delle sue dipendenze.
Metodo pubblico | CreateEnsureLocalFolderCommand | Crea un nuovo comando di EnsureLocalFolder.
Metodo pubblico | CreateEnsureLocalFolderStructureCommand | Crea un nuovo comando di EnsureLocalFolder.
Metodo pubblico | CreateExportCommand | Crea un nuovo comando ExportCommand.
Metodo pubblico | CreateExportDocumentCommand | Crea un nuovo comando di Esportazione documento. Effettua la copia del documento in una destinazione libera e se necessario lo pone in checkout.
Metodo pubblico | CreateFileZipCommand | Crea un nuovo comando FileZip che chiede all'utente dove vuole archiviare i documenti selezionati.
Metodo pubblico | CreateFileZipStructCommand | Crea un nuovo comando FileZipStruct che chiede all'utente dove vuole archiviare i documenti selezionati.
Metodo pubblico | CreateFillDedDataEncodeTableCommand | Crea un nuovo comando per ricercare i documenti.
Metodo pubblico | CreateFindCodeCommand | Crea un nuovo comando FindCode che visualizza la finestra di dialogo di ricerca codice con preselezionato un comando.
Metodo pubblico | CreateFindCodeForm | Crea e restituisce la finestra di ricerca veloce codice.
Metodo pubblico | CreateFindCommand | Crea un nuovo comando Ricerca.
Metodo pubblico | CreateFindDataDocCommand | Crea un nuovo comando per ricercare i documenti.
Metodo pubblico | CreateFindDocCommand | Crea un nuovo comando per ricercare i documenti.
Metodo pubblico | CreateFindInRicercaCommand | Crea un nuovo comando FindInRicercaCommand che permette di aprire la ricerca con selezionata l'anagrafica associata all'anagrafica o al documento selezionato.
Metodo pubblico | CreateForceMarkerAlingmentCommand | Crea un nuovo comando ForceMarkerAlingment.
Metodo pubblico | CreateFormDocHistory | Crea e restituisce la finestra di dialogo utilizzata per il comando Storia documento.
Metodo pubblico | CreateFormDocTransferHistory(Boolean) | Crea e restituisce la finestra di dialogo utilizzata per il comando Storia di tutti i trasferimenti
Metodo pubblico | CreateFormDocTransferHistory(DedDoc) | Crea e restituisce la finestra di dialogo utilizzata per il comando Storia trasferimenti documento.
Metodo pubblico | CreateFormFindDoc | Crea e restituisce la finestra di dialogo utilizzata per ricercare i documeneti.
Metodo pubblico | CreateFormWhereUsed(DedDoc) | Crea e restituisce la finestra di dialogo utilizzata per il comando Where Used.
Metodo pubblico | CreateFormWhereUsed(DedDoc, Boolean) | Crea e restituisce la finestra di dialogo utilizzata per il comando Where Used.
Metodo pubblico | CreateFormWhereUsed(DedDocList, Boolean) | Crea e restituisce la finestra di dialogo utilizzata per il comando Apri File Associati.
Metodo pubblico | CreateFormWhereUsed(DedDoc, String, Boolean) | Crea e restituisce la finestra di dialogo utilizzata per il comando Where Used.
Metodo pubblico | CreateForzaCheckInDocumentCommand | Crea un nuovo comando di Forza Check-In. Mette in Check-In il documento senza copiarlo nel server.
Metodo pubblico | CreateImportCommDocumentCommand | Crea un nuovo comando ImportCommDocument. E' disponibile nel controllo dei documenti associati alle commesse.
Metodo pubblico | CreateImportCommFilesCommand | Crea un nuovo comando ImportCommDocument. E' disponibile nel controllo dei documenti associati alle commesse.
Metodo pubblico | CreateImportDocsCommand | Crea un nuovo comando ImportDocument. E' disponibile ovunque ci siano le anagrafiche ed anche siano visualizzati i documenti relativi (anche il FindCodeForm).
Metodo pubblico | CreateImportEcoFilesCommand | Crea un nuovo comando ImportEcoFiles. E' disponibile nel dialogo degli Eco.
Metodo pubblico | CreateImporterCommand | Crea un nuovo comando MarkerInfo.
Metodo pubblico | CreateImportFilesCommand | Crea un nuovo comando ImportDocument. E' disponibile ovunque ci siano le anagrafiche ed anche siano visualizzati i documenti relativi (anche il FindCodeForm).
Metodo pubblico | CreateImportSparePartDrawingCommand | Crea un nuovo comando ImportDocument per importare documenti e impostarli con contesto 'PubblicazioneRicambio'.
Metodo pubblico | CreateImportTransferPacketCommand | Crea un nuovo comando di ImportTransferPacket
Metodo pubblico | CreateLiberateCommCommand | Crea un nuovo comando per la presa in carico di una commessa.
Metodo pubblico | CreateLinkCommDocumentCommand | Crea un nuovo comando LinkCommDocument. E' disponibile nel controllo dei documenti associati alle commesse.
Metodo pubblico | CreateLinkDocumentCommand | Crea un nuovo comando LinkDocument. E' disponibile ovunque ci siano le anagrafiche ed anche siano visualizzati i documenti relativi (anche il FindCodeForm).
Metodo pubblico | CreateLogInCommand | Crea un nuovo comando LogIn.
Metodo pubblico | CreateLogViewCommand | Crea un nuovo comando LogViewCommand.
Metodo pubblico | CreateMainForm | Crea e restituisce il dialogo della ricerca.
Metodo pubblico | CreateManageOperationsCommand | Crea un nuovo comando DbVersionCommand. Permesso minimo di READ in modo che venga visualizzato anche se l'utente non lo può eseguire, utile nel caso in cui venga usato il comando login con un altro utente.
Metodo pubblico | CreateManageRootForm | Crea e restituisce la finestra per editare le Root.
Metodo pubblico | CreateMarkerInfoCommand | Crea un nuovo comando MarkerInfo.
Metodo pubblico | CreateMoveAnagrCommand | Crea un nuovo comando MoveAnagrCommand che permette di spostare le anagrafiche in un'altra famiglia.
Metodo pubblico | CreateMovedEditorCommand | Crea un nuovo comando di MovedEditorCommand.
Metodo pubblico | CreateMoveDocumentCommand | Crea un nuovo comando MoveDocument per rinominare/spostare i documenti. E' disponibile solo negli allegati.
Metodo pubblico | CreateNotifyCommand | Crea un nuovo comando per ricercare i documenti.
Metodo pubblico | CreateOpenAssocFilesCommand | Crea un nuovo comando OpenAssocFilesCommand (Apri file associati).
Metodo pubblico | CreateOpenAttachFilesCommand | Crea un nuovo comando OpenAssocFilesCommand (Apri file allegati).
Metodo pubblico | CreateOpenCommCommand | Crea un nuovo comando per l'eliminazione di una commessa.
Metodo pubblico | CreateOpenFilePathCommand | Crea un nuovo comando OpenFilePathCommand che apre la cartella contenente il file selezionato.
Metodo pubblico | CreateOpenReadDocumentCommand | Crea un nuovo comando OpenReadDocument.
Metodo pubblico | CreateOpenWriteDocumentCommand | Crea un nuovo comando OpenWriteDocument.
Metodo pubblico | CreatePrintDocumentCommand | Crea un nuovo comando di PrintDocumentCommand.
Metodo pubblico | CreatePropertiesManagerCommand | Crea un nuovo comando PropertiesManagerCommand.
Metodo pubblico | CreatePubblicaCommand | Crea un nuovo comando Pubblica. Effettua la copia del documento dall'area locale al vault e lo mantiene in CheckOut.
Metodo pubblico | CreatePubblicaStrutturaCommand | Crea un nuovo comando Pubblica. Effettua la copia del documento dall'area locale al vault e lo mantiene in CheckOut.
Metodo pubblico | CreatePublicationFilesMangerCommand | Crea un nuovo comando PublicationFilesCommand. Permesso minimo di READ in modo che venga visualizzato anche se l'utente non lo può eseguire, utile nel caso in cui venga usato il comando login con un altro utente.
Metodo pubblico | CreatePwsBackupCommand | Crea un nuovo comando PwsBackup.
Metodo pubblico | CreatePwsCacheCommand | Crea un nuovo comando PwsCache.
Metodo pubblico | CreateQsManagerCommand | Crea un nuovo comando QsManagerCommand. Permesso minimo di READ in modo che venga visualizzato anche se l'utente non lo può eseguire, utile nel caso in cui venga usato il comando login con un altro utente.
Metodo pubblico | CreateQsManagerCommCommand | Crea un nuovo comando QsManagerCommand. Permesso minimo di READ in modo che venga visualizzato anche se l'utente non lo può eseguire, utile nel caso in cui venga usato il comando login con un altro utente.
Metodo pubblico | CreateRecognaiseCommDocumentCommand | Crea un nuovo comando RecognaiseCommDocument. E' disponibile nel controllo dei documenti associati alle commesse.
Metodo pubblico | CreateRecognaiseCommFilesCommand | Crea un nuovo comando RecognaiseCommDocument. E' disponibile nel controllo dei documenti associati alle commesse.
Metodo pubblico | CreateRecognaiseDocsCommand | Crea un nuovo comando RecognaiseDocument. E' disponibile ovunque ci siano le anagrafiche ed anche siano visualizzati i documenti relativi.
Metodo pubblico | CreateRecognaiseFilesCommand | Crea un nuovo comando RecognaiseDocument. E' disponibile ovunque ci siano le anagrafiche ed anche siano visualizzati i documenti relativi.
Metodo pubblico | CreateRemoveDocumentCommand | Crea un nuovo comando RemoveDocument che permette di eliminare una lista di documenti.
Metodo pubblico | CreateRemoveEcoDocumentCommand |
Metodo pubblico | CreateRemoveRecurrentTimingCommand | Crea un nuovo comando RemoveRecurrentTimingCommand.
Metodo pubblico | CreateRenameDocumentCommand | Crea un nuovo comando RenameDoc per rinominare i documenti. E' disponibile solo negli allegati.
Metodo pubblico | CreateRenameFolderCommand | Crea un nuovo comando Elimina cartella. Eliomina una cartella e tutti i suoi documenti.
Metodo pubblico | CreateReplaceAnagrBomCommand | Crea un nuovo comando ReplaceAnagrBom che permette di sostituire un'anagrafica con un'altra all'interno di più distinte.
Metodo pubblico | CreateReplaceDocumentCommand | Crea un nuovo comando ReplaceDocument. E' disponibile ovunque ci siano le anagrafiche ed anche siano visualizzati i documenti relativi.
Metodo pubblico | CreateReplaceDocumentReferenceCommand | Crea un nuovo comando ReplaceDocumentReference.
Metodo pubblico | CreateReserveProgCommand | Crea un nuovo comando QsReserveProgCommand. Permesso minimo di READ in modo che venga visualizzato anche se l'utente non lo può eseguire, utile nel caso in cui venga usato il comando login con un altro utente.
Metodo pubblico | CreateRevCommand | Crea un nuovo comando RevCommand.
Metodo pubblico | CreateRootManagerCommand | Crea un nuovo comando Gestione root. Permesso minimo di READ in modo che venga visualizzato anche se l'utente non lo può eseguire, utile nel caso in cui venga usato il comando login con un altro utente.
Metodo pubblico | CreateSaveCommand | Crea un nuovo comando SaveCommand.
Metodo pubblico | CreateSaveDistCommand | Crea un nuovo comando SaveDistCommand.
Metodo pubblico | CreateSaveDistVariantCommand | Crea un nuovo comando SaveDistCommand.
Metodo pubblico | CreateSaveForm | Crea e restituisce la finestra di salvataggio nel Database.
Metodo pubblico | CreateSaveSparePartsDistVariantCommand | Crea un nuovo comando SaveSparePartsDistVariantCommand.
Metodo pubblico | CreateSaveVariantCommand | Crea un nuovo comando SaveCommand impostato in modo che sia utilizzato per la creazione della variante.
Metodo pubblico | CreateSbloccaDocumentCommand | Crea un nuovo comando Sblocca documento. Mette il documento in CheckIn senza effettuarne la pubblicazione. Opzionalmente lo cancella dall'area locale.
Metodo pubblico | CreateSendTransferPacketCommand | Crea un nuovo comando di SendTransferPacket.
Metodo pubblico | CreateSendZipCommand | Crea un nuovo comando SendZipViaEmail che zippa i file selezionati in una cartella e apre un messaggio di posta con allegato lo zip. Una volta inviato il messaggio viene rimossa la cartella.
Metodo pubblico | CreateShowAllActiveTimingsCommand | Crea un nuovo comando EndAllTimingsCommand.
Metodo pubblico | CreateShowAnagrCommand | Crea un nuovo comando ShowAnagr.
Metodo pubblico | CreateShowRecurrentTimingCommand | Crea un nuovo comando ShowFavTiming.
Metodo pubblico | CreateShowSparePartsDistVariantCommand | Crea un nuovo comando ShowSparePartsDistVariantCommand.
Metodo pubblico | CreateShowTimingCommand | Crea un nuovo comando ShowTimingCommand.
Metodo pubblico | CreateStartTimingCommand | Crea un nuovo comando StartTimingCommand.
Metodo pubblico | CreateStateCommand | Crea un nuovo comando di impostazione stato documento.
Metodo pubblico | CreateStateManagerCommand | Crea un nuovo comando StateManagerCommand. Permesso minimo di READ in modo che venga visualizzato anche se l'utente non lo può eseguire, utile nel caso in cui venga usato il comando login con un altro utente.
Metodo pubblico | CreateTranslationsMangerCommand | Crea e restituisce il sotto-comando che permette di aggiornare un documento e tutte le sue dipendenze. Riconosce tutti file dipendenti nel Database.
Metodo pubblico | CreateTranslationsMangerCommand(CommandContextEnum) | Crea e restituisce il sotto-comando che permette di aggiornare un documento e tutte le sue dipendenze. Riconosce tutti file dipendenti nel Database.
Metodo pubblico | CreateUpdateDocumentCommand | Crea e restituisce il sotto-comando che permette di aggiornare un documento e tutte le sue dipendenze. Riconosce tutti file dipendenti nel Database.
Metodo pubblico | CreateUpdateDocumentReferenceCommand | Crea un nuovo comando UpdateDocumentReference.
Metodo pubblico | CreateUpdateOldRevCommand | Crea un nuovo comando UpdateOldRev.
Metodo pubblico | CreateUpdateOldRevForm | Creazione del form di aggiornamento delle revisioni superate.
Metodo pubblico | CreateUpdateSparePartsBoms | Crea un nuovo comando UpdateSparePartsBoms.
Metodo pubblico | CreateUsersCommand | Crea un nuovo comando UsersCommand. Permesso minimo di READ in modo che venga visualizzato anche se l'utente non lo può eseguire, utile nel caso in cui venga usato il comando login con un altro utente.
Metodo pubblico | CreateVarsCommand | Crea un nuovo comando VarsCommand. Permesso minimo di READ in modo che venga visualizzato anche se l'utente non lo può eseguire, utile nel caso in cui venga usato il comando login con un altro utente.
Metodo pubblico | CreateViewCommCommand | Crea un nuovo comando per la visualizzazione di una commessa.
Metodo pubblico | CreateVisualDepCommand | Crea un nuovo comando VisualDep che mostra all'utente l'albero delle dipendenze.
Metodo pubblico | CreateWhereUsedCommand | Crea un nuovo comando WhereUsed.
Metodo pubblico | DataToAnagrAttrList | Data un'anagrafica, che può anche essere null, restituisce la lista degli attributi abbinati. Se l'anagrafica è null restituisce la lista degli attributi di anagrafica standard. Restituisce sempre una lista inizializzata.
Metodo pubblico | DataToAnagrDistAttrList | Data un'anagrafica, che può anche essere null, restituisce la lista degli attributi abbinati insieme a quelli di distinta. Se l'anagrafica è null restituisce la lista degli attributi di anagrafica standard e distinta. Restituisce sempre una lista inizializzata.
Metodo pubblico | DataToAnagrDistOccAttrList | Data un'anagrafica, che può anche essere null, restituisce la lista degli attributi abbinati insieme a quelli di distinta e occorrenza. Se l'anagrafica è null restituisce la lista degli attributi di anagrafica standard, distinta e occorrenza. Restituisce sempre una lista inizializzata.
Metodo pubblico | DataToAnagrDocAttrList | Data un'anagrafica, che può anche essere null, restituisce la lista degli attributi abbinati insieme a quelli di documento. Se l'anagrafica è null restituisce la lista degli attributi di anagrafica standard e documento. Restituisce sempre una lista inizializzata.
Metodo pubblico | DataToAnagrDocOccAttrList | Data un'anagrafica, che può anche essere null, restituisce la lista degli attributi abbinati insieme a quelli di documento e occorrenza. Se l'anagrafica è null restituisce la lista degli attributi di anagrafica standard, documento e occorrenza. Restituisce sempre una lista inizializzata.
Metodo pubblico | DataToAnagrOccAttrList | Data un'anagrafica, che può anche essere null, restituisce la lista degli attributi di anagrafica e occorrenza. Se l'anagrafica è null restituisce la lista degli attributi di anagrafica standard e occorrenza. Restituisce sempre una lista inizializzata.
Metodo pubblico | DataToDistAttrList | Data un'anagrafica, che può anche essere null, restituisce la lista degli attributi di distinta. Se l'anagrafica è null restituisce la lista degli attributi di distinta standard. Restituisce sempre una lista inizializzata.
Metodo pubblico | DataToDistOccAttrList | Data un'anagrafica, che può anche essere null, restituisce la lista degli attributi di distinta e occorrenza. Se l'anagrafica è null restituisce la lista degli attributi di distinta standard e occorrenza. Restituisce sempre una lista inizializzata.
Metodo pubblico | DataToDocAttrList | Data un'anagrafica, che può anche essere null, restituisce la lista degli attributi di documento. Se l'anagrafica è null restituisce la lista degli attributi di documento standard. Restituisce sempre una lista inizializzata.
Metodo pubblico | DataToDocOccAttrList | Data un'anagrafica, che può anche essere null, restituisce la lista degli attributi di documento e occorrenza. Se l'anagrafica è null restituisce la lista degli attributi di documento standard e occorrenza. Restituisce sempre una lista inizializzata.
Metodo pubblico | DataToOccAttrList | Data un'anagrafica, che può anche essere null, restituisce la lista degli attributi di occorrenza. Se l'anagrafica è null restituisce la lista degli attributi di distinta standard. Restituisce sempre una lista inizializzata.
Metodo pubblico | DbLog(Exception, LogMessageTypeEnum) | Registra l'eccezione e la gravità nella tabella dedicata al log
Metodo pubblico | DbLog(String, LogMessageTypeEnum) | Registra il messaggio e la gravità nella tabella dedicata al log
Metodo pubblico | DbLog(Exception, String, LogMessageTypeEnum) | Registra l'eccezione e la gravità nella tabella dedicata al log
Metodo pubblico | DbLog(String, String, LogMessageTypeEnum) | Registra il messaggio e la gravità nella tabella dedicata al log
Metodo pubblico | DecodeString(DedTypeBase, String, String) | Utilizzata per decodificare una stringa codificata. Data una stringa contenente i tasselli di codifica ed un'altra contenente il valore corrispondente, viene ricostruito e restituito un oggetto DedEncodeInfo contenente le informazioni presenti. Nella stringa di codifica devono essere presenti tasselli (o anche detti token) che abbiano la parte che specifica la lunghezza (in pratica deve esserci il carattere separatore ':' seguito da un qualsiasi criterio di lunghezza). Restituisce sempre una lista inizializzata ma vuota nel caso non ci fossere corrispondenze.
Metodo pubblico | DecodeString(DedTypeBase, String, String, String) | Utilizzata per decodificare una stringa codificata. Data una stringa contenente i tasselli di codifica ed un'altra contenente il valore corrispondente, viene ricostruito e restituito un oggetto DedEncodeInfo contenente le informazioni presenti. Nella stringa di codifica devono essere presenti tasselli (o anche detti token) che abbiano la parte che specifica la lunghezza (in pratica deve esserci il carattere separatore ':' seguito da un qualsiasi criterio di lunghezza). Restituisce sempre una lista inizializzata ma vuota nel caso non ci fossere corrispondenze.
Metodo pubblico | Dispose | Dispose.
Metodo protetto | Dispose(Boolean) | Effettua il Dispose in base al contesto.
Metodo pubblico | DocNameIsUsed(String) | Controlla se il nome passato senza estensione è già presente tra i documenti registrati o spostati.
Metodo pubblico | DocNameIsUsed(String, Boolean) | Controlla se il nome passato senza estensione è già presente tra i documenti registrati o spostati.
Metodo pubblico | DocNameIsUsed(String, String) | Controlla se il nome passato senza estensione è già presente tra i documenti registrati o spostati.
Metodo pubblico | DocNameIsUsed(String, String, Boolean) | Controlla se il nome passato senza estensione è già presente tra i documenti registrati o spostati.
Metodo pubblico | DocumentMatchData | Verifica che un dato documento sia presente come primario di una particolare anagrafica.
Metodo pubblico | EncodeString(String, DedEncodeInfo) | Utilizzata per calcolare una stringa di codifica. Data una stringa di codifica, per esempio "{F1:3}{P:4}-{R:2}", e le informazioni racchiuse nell'oggetto DedEncodeInfo restituisce una stringa codificata.
Metodo pubblico | EncodeString(String, DedEncodeInfo, String) | Utilizzata per calcolare una stringa di codifica. Data una stringa di codifica, per esempio "{F1:3}{P:4}-{R:2}", e le informazioni racchiuse nell'oggetto DedEncodeInfo restituisce una stringa codificata.
Metodo pubblico | EndFileTransaction | Chiude la transazione in atto effettuando il commit oppure il rollback. QUESTO METODO È SEMPRE DA UTILIZZARE INSIEME A BeginFileTransaction().
Metodo pubblico | EnsureEncodeHasLength(DedTypeBase, String) | Si assicura che il tassello in encode abbia i ":" per definire la sua lunghezza lo fa solo sui campi della famiglia ( poiche nel DEDID gli altri devono avere lunghezza definita)
Metodo pubblico | EnsureEncodeHasLength(IDedTypeEditable, String) | Si assicura che il tassello in encode abbia i ":" per definire la sua lunghezza
Metodo protetto | Finalize | Distruttore. (Sovrascrive ObjectFinalize)
Metodo pubblico | FindAllComm | Restituisce tutte le anagrafiche presenti nel DB.
Metodo pubblico | FindAllContextPrimaryDocuments | Restituisce la lista dei contesti nei quali un documento è collegato come file primario. Restituisce sempre una lista inizializzata.
Metodo pubblico | FindAllData | Restituisce tutte le anagrafiche presenti nel DB.
Metodo pubblico | FindAllDoc | Restituisce tutti i documenti registrati nel database.
Metodo pubblico | FindComm(Guid) | Restituisce una commessa cercata attraverso l'id. Restituisce null se non la trova.
Metodo pubblico | FindComm(String) | Restituisce una commessa cercata attraverso il nome. Restituisce null se non la trova.
Metodo pubblico | FindData(String) | Restituisce la lista delle anagrafiche che hanno il DEDID richiesto. Le restituisce ordinate per revisione in modo ascendente. Restituisce null se non trova alcun record nel Database.
Metodo pubblico | FindData(String, Boolean) | Restituisce l'ultima revisione (con valore più alto) che ha il DEDID specificato. Se si imposta il parametro rilPriority = true viene cercata la prima revisione rilasciata, se presente, altrimenti viene comunque restituita la revisione più alta non superata. Restituisce null se non trova il record nel Database.
Metodo pubblico | FindData(String, String) | Restituisce l'anagrafica che ha il DEDID ed il DEDREV specificati. Restituisce null se non trova il record nel Database.
Metodo pubblico | FindDataByDbPath | Restituisce la lista delle anagrafiche contenute nel dbpath indicato. Vengono considerate anche le anagrafiche che presentano dei dbpath figli di quello indicato
Metodo pubblico | FindDataByField(DedDataStandardDataFields, Object) | Restituisce la lista delle anagrafiche che hanno il campo compilato come richiesto. Le restituisce ordinate per DEDID e DEDREV in modo ascendente. Restituisce null se non trova alcun record nel Database.
Metodo pubblico | FindDataByField(String, Object) | Restituisce la lista delle anagrafiche che hanno il campo compilato come richiesto. Le restituisce ordinate per DEDID e DEDREV in modo ascendente. Restituisce null se non trova alcun record nel Database.
Metodo pubblico | FindDataByFileName | Restituisce la lista delle anagrafiche primarie del documento sotteso al file passato. Restituisce null se non trova alcun documento corrispondente al nome file passato, altrimenti restituisce una lista sempre inizializzata ma vuota se non trova anagrafiche collegate come primarie.
Metodo pubblico | FindDataLast | Restituisce la lista delle revisioni non superate appartenenti al codice richiesto. Restituisce null se non trova alcun record nel Database.
Metodo pubblico | FindDataLike(String) | Effettua una query sul campo DEDID delle anagrafiche utilizzando l'operatore like. Restituisce null se non trova alcun record nel Database, altrimenti restitusice la lista delle anagrafiche individuate. Le restituisce ordinate per DEDID e DEDREV in modo ascendente.
Metodo pubblico | FindDataLike(String, String) | Effettua una query sul campo specificato delle anagrafiche utilizzando l'operatore like. Restituisce null se non trova alcun record nel Database, altrimenti restitusice la lista delle anagrafiche individuate. Le restituisce ordinate per DEDID e DEDREV in modo ascendente.
Metodo pubblico | FindDoc(Guid) | Restituisce il documento presente nel DB, se esiste, altimenti restituisce null.
Metodo pubblico | FindDoc(String) | Restituisce il documento presente nel DB, se esiste, altimenti restituisce null. Se è attiva l'area locale cerca anche nei percorsi di checkout.
Metodo pubblico | FindDocContext(Guid) | Restituisce la lista dei Contesti di legame di un documento. Se non trova record corrispondenti, restituisce una lista inizializzata ma vuota.
Metodo pubblico | FindDocContext(Guid, DedDocContextEnum) | Restituisce la lista dei Contesti di legame di un documento. Se non trova record corrispondenti, restituisce una lista inizializzata ma vuota.
Metodo pubblico | FindDocContext(String, String) | Restituisce la lista dei Contesti di legame di una anagrafica. Se non trova record corrispondenti, restituisce una lista inizializzata ma vuota.
Metodo pubblico | FindDocContext(String, String, DedDocContextEnum) | Restituisce la lista dei Contesti di legame di una anagrafica aventi un particolare contesto. Se non trova record corrispondenti, restituisce una lista inizializzata ma vuota.
Metodo pubblico | FindDocContext(String, String, Guid) | Restituisce il Contesto di legame tra anagrafica e documento, date le sue caratteristiche univoche. Se lo trova lo restituisce altrimenti restituisce null.
Metodo pubblico | FindDocErased(Guid) | Restituisce il documento presente nel DB, se esiste, altimenti restituisce null.
Metodo pubblico | FindDocErased(String) | Restituisce il documento eliminato se presente nel DB, altrimenti restituisce null
Metodo pubblico | FindDocs(String) | Restituisce una lista di documenti filtrati in base ai criteri passati
Metodo pubblico | FindDocs(String, ListString) | Restituisce una lista di documenti filtrati in base ai criteri passati
Metodo pubblico | FindDocs(String, String) | Restituisce una lista di documenti filtrati in base ai criteri passati
Metodo pubblico | FindDocs(String, String, ListString) | Restituisce una lista di documenti filtrati in base ai criteri passati
Metodo pubblico | FindDocsByNameLike | Restituisce una lista di documenti presenti in un path
Metodo pubblico | FindDocsByPath | Restituisce una lista di documenti presenti in un path
Metodo pubblico | FindDocsByPathAndNameLike | Restituisce una lista di documenti presenti in un path
Metodo pubblico | FindDocsByPathLike | Restituisce una lista di documenti presenti in un path
Metodo pubblico | FindDocsCheckOutByMe | Restituisce una lista di documenti in checkOut dall'utente connesso.
Metodo pubblico | FindDocsEquals | Restituisce una lista di documenti filtrati in base ai criteri esatti, senza l'utilizzo del like
Metodo pubblico | FindDocsToMigrate | Restituisce una lista di documenti da migrare in base all'estensione e alla versione dell'addin
Metodo pubblico | FindMainWindow | Se impostato, restituisce il valore della proprietà MainWindow, altrimenti restituisce la IWin32Window della MainWindow del processo corrente.
Metodo pubblico | FireEditAttrValidatingEvent | Esegue evento per validare gli attributi.
Metodo pubblico | FixCodIdNull | Corregge le eventuali anagrafiche che hanno COD_ID in DED_DATA_ENCODE vuoto. Può verificarsi per via di un hotfix con un bug in corso di 23.0.0
Metodo pubblico | GetAllAttrInDb | Restituisce tutti gli attributi con ambiene anagrafica (Anagrafica, AnagraficaEDistinta, ecc..) presenti nel Db. Gli attributi di solo distinta sono esclusi.
Metodo pubblico | GetAllAttrInDb(Boolean) | Restituisce tutti gli attributi con ambiene anagrafica (Anagrafica, AnagraficaEDistinta, ecc..) presenti nel Db.
Metodo pubblico | GetAllAttrInDb(Boolean, Boolean) | Restituisce tutti gli attributi con ambiene anagrafica (Anagrafica, AnagraficaEDistinta, ecc..) presenti nel Db.
Metodo pubblico | GetAllComm | Restituisce la lista completa di tutte le commesse di primo livello. Restituisce una lista sempre inizializzata.
Metodo pubblico | GetAllDocumentPaths | Restituisce tutti i path univoci dai documenti registrati nel database
Metodo pubblico | GetAttrPrompt(DedDataStandardDataFields) | Restituisce il prompt di un attributo standard.
Metodo pubblico | GetAttrPrompt(String) | Restituisce il prompt di un attributo standard.
Metodo pubblico | GetEveryAttrInDb | Restituisce tutti gli attributi di famiglia e ricambio presenti nel Db.
Metodo pubblico | GetEveryCalculatedAttr | Ritorna tutti gli attributi importati presenti nel db.
Metodo pubblico | GetEveryCommAttrInDb | Restituisce tutti gli attributi con ambiente anagrafica (Anagrafica, AnagraficaEDistinta, ecc..) presenti nel Db.
Metodo pubblico | GetFileDependency | Restituisce la lista delle dipendenze di un documento partendo dal suo nome file completo. Viene utilizzata per avere le dipendenze di un documento che non è ancora stato archiviato. Chiama l'evento DefineFileDependency per permettere al client di intervenire.
Metodo pubblico | GetFindCommand | Restituisce il comando "ricerca" memorizzato nella cache (evita di crearne un altro velocizzando il tutto). Proprietà utilizzata principalmente nei vari add-in. ATTENZIONE! Dato che il riferimento in memoria è sempre lo stesso, se si effettuano delle modifiche alle proprietà del comando, queste verranno riportate anche negli utilizzi successivi!
Metodo pubblico | GetFindDocsCommand | Restituisce il comando "ricerca documentale" memorizzato nella cache (evita di crearne un altro velocizzando il tutto). Proprietà utilizzata principalmente nei vari add-in. ATTENZIONE! Dato che il riferimento in memoria è sempre lo stesso, se si effettuano delle modifiche alle proprietà del comando, queste verranno riportate anche negli utilizzi successivi!
Metodo pubblico | GetMessageFromEx | Crea uno StringBuilder con il messaggio completo dell'errore partendo dall'eccezione ricevuta.
Metodo pubblico | GetMovedDoc | Dato un file name ritorna il documento sostituto corrispondente.
Metodo pubblico | GetRegistryDedBaseDir | Metodo per impostare la chiave di registro del Ded con la versione attuale
Metodo pubblico | HasAtLeastOneLinkingContext | Retituisce true se il documento ha almeno un contesto di linking nei confronti di una anagrafica
Metodo pubblico | HasMovedDoc | Ritorna vero se esiste un documento "moved" corrispondente
Metodo pubblico | Init | Inizializza le strutture dati e le variabili leggendole dal Database. Se restituisce false l'errore avvenuto è reperibile attraverso la proprietà LastError.
Metodo pubblico | Init(String, String) | Inizializza le strutture dati e le variabili leggendole dal Database utilizzando una specifica stringa di connessione. Se restituisce false l'errore avvenuto è reperibile attraverso la proprietà LastError.
Metodo pubblico | InitWithConnStringOnly | Inizializza il ded utilizzando unicamente i parametri di connessione forniti senza utilizzare il file ini
Metodo pubblico | InitWithUserAlreadyLoaded | Inizializzazione completa ma specifica per utente Non richiede l'autenticazione dell'utente perchè l'informazione dell'utente è già caricata. Se restituisce false l'errore avvenuto è reperibile attraverso la proprietà LastError.
Metodo pubblico | IsDocErased | Ritorna vero se il documento figura tra gli eliminati
Metodo pubblico | IsMultipleStateChangeExecuteRegister | Restituisce se è stato o meno inizializzato l'evento lua
Metodo pubblico | LightInitWithoutAuthentication | Esegue l'inizializzazione minima per poter almeno accedere alle variabili. Non richiede l'autenticazione dell'utente. Se restituisce false l'errore avvenuto è reperibile attraverso la proprietà LastError.
Metodo pubblico | Log(Exception) | Registra il messaggio nel file di Log dell'applicazione.
Metodo pubblico | Log(String) | Registra il messaggio nei file di Log.
Metodo pubblico | Log(Exception, LogMessageTypeEnum) | Registra il messaggio nel file di Log dell'applicazione.
Metodo pubblico | Log(String, LogMessageTypeEnum) | Registra il messaggio nel file di Log dell'applicazione.
Metodo pubblico | Log(String, String) | Registra il messaggio nei file di Log.
Metodo pubblico | Login | Chiede il login all'utente ed inizializza tutti i permessi, se è attiva la gestione degli utenti, altrimenti inizializza il nome utente di default, prendendolo da Windows. Chiede nome utente e password anche se il login è già stato effettuato. Indica di chiedere obbligatoriamente il login (anche nel caso di autenticazione di windows).
Metodo pubblico | LogInfo | Registra il messaggio nei file di Log.
Metodo pubblico | LogTest | Registra il messaggio nei file di Log.
Metodo protetto | OnAddDataDocEvent | Lancia l'evento LinkingDataDocEvent.
Metodo pubblico | OnAddExtensionsRecognizerForm | Lancia l'evento per aggiungere delle estensioni al form di riconoscimento file/cartelle
Metodo protetto | OnAfterEraseEmptyPwsFolder | Chiama l'evento AfterEraseEmptyPwsFolderEvent.
Metodo protetto | OnAfterSaveDedCommTypeEvent | Chiama l'evento AfterSaveEvent.
Metodo protetto | OnAfterSaveDedTypeEvent | Chiama l'evento AfterSaveEvent.
Metodo protetto | OnAnagrSelectionDeleted | Lancia l'evento che viene scatenato al termine dell'eliminazione di tutta la selezione di anagrafiche
Metodo pubblico | OnAttributeChanged | Lancia l'evento AttributeChanged.
Metodo pubblico | OnAttributeInit | Lancia l'evento AttributeInit.
Metodo pubblico | OnBeforeShowZoomPreviewEvent | Lancia l'evento BeforeShowZoomPreview.
Metodo protetto | OnBomEditFormButtonClick | Lancia l'evento BomEditFormButtonClickEvent.
Metodo protetto | OnBomEditFormToggleSwitch | Lancia l'evento BomEditFormButtonClickEvent.
Metodo protetto | OnBomExplorerAddReplaceData | Lancia l'evento BomExplorerAddReplaceDataEvent.
Metodo protetto | OnBomExplorerButtonClick | Lancia l'evento BomExplorerButtonClickEvent.
Metodo protetto | OnBomExplorerContextMenuOpening | Lancia l'evento BomExplorerContextMenuOpening.
Metodo protetto | OnBomExplorerLoadDist | Lancia l'evento BomExplorerButtonClickEvent.
Metodo protetto | OnChangeStateECO | Chiama l'evento ChangeStateECOEvent.
Metodo protetto | OnChangingDependencyDocument | Chiama l'evento ChangingDependencyDocument.
Metodo protetto | OnCheckProgrReservedEvent | Lancia l'evento CheckProgrReservedEvent
Metodo protetto | OnCheckRevAlphabetEvent | Lancia l'evento CheckAlphabetEvent
Metodo protetto | OnClassListItemClick | Chiama l'evento ClassListItemClick.
Metodo protetto | OnCommAddAnagItem | Lancia l'evento CommAddAnagItemEvent.
Metodo protetto | OnCommandExecuting | Lancia l'evento di esecuzione comando.
Metodo protetto | OnCommCancel | Lancia l'evento CommCancelEvent.
Metodo protetto | OnCommDescrOverrideEvent | Lancia l'evento ValidateCommPropertyEvent.
Metodo protetto | OnCommElementCreateData | Lancia l'evento CommElementCreateData.
Metodo protetto | OnCommFileExplorerUpdate | Lancia l'evento CommFileExplorerUpdate.
Metodo protetto | OnCommTypeAdded | Chiama l'evento TypeAdded.
Metodo protetto | OnCopyDocument | Lancia l'evento CopyDocument.
Metodo protetto | OnCreateComm | Chiama l'evento ExportData.
Metodo protetto | OnCreateECO | Chiama l'evento CreateECOEvent.
Metodo protetto | OnCreateMultiLevelBom | Chiama l'evento EditSparePartMultiLevelBomEvent
Metodo protetto | OnCreatingSparePartDrawing | Chiama l'evento CreatingSparePartDrawing.
Metodo protetto | OnDedBomEditLoaded | Lancia l'evento DedBomEditLoaded.
Metodo protetto | OnDedDataChangedEvent | Chiama l'evento DedDataChangedEvent.
Metodo protetto | OnDedDataMoveEvent | Lancia l'evento DedDataMoveEvent.
Metodo protetto | OnDedOpenDocumentEvent | Lancia l'evento DedOpenDocumentEvent.
Metodo protetto | OnDedRuleLua | Chiama l'evento DedRuleLua.
Metodo protetto | OnDedRuleRowSetAttrPost | Chiama l'evento DedRuleRowSetAttrPost.
Metodo protetto | OnDedRuleSetAttrPost | Chiama l'evento DedRuleSetAttrPost.
Metodo protetto | OnDedRuleSetAttrPre | Chiama l'evento DedRuleSetAttrPre.
Metodo protetto | OnDedRuleSingleSetAttrPre | Chiama l'evento DedRuleSingleSetAttrPre.
Metodo protetto | OnDedTranslationChangedEvent | Chiama l'evento DedTranslationChangedEvent.
Metodo protetto | OnDefineFileDependency | Lancia l'evento DefineFileDependency.
Metodo protetto | OnDisableAutoUpdateAnagrComm | Lancia l'evento DisableAutoUpdateAnagrComm.
Metodo protetto | OnDistAddNode | Lancia l'evento DistAddNodeEvent.
Metodo protetto | OnDistChangeFieldValueEvent | Lancia l'evento DistChangeFieldValueEvent.
Metodo pubblico | OnDistCloneData | Lancia l'evento DistCloneDataEvent.
Metodo protetto | OnDistCopyData | Lancia l'evento DistCopyDataEvent.
Metodo protetto | OnDistDragElement | Lancia l'evento DistAddElementEvent.
Metodo protetto | OnDistEditSaveEvent | Lancia l'evento DistEditSaveEvent.
Metodo protetto | OnDistElementCreateData | Lancia l'evento DistElementCreateData.
Metodo protetto | OnDistItemCreateData | Lancia l'evento DistItemCreateData.
Metodo protetto | OnDistLevelSaveEvent | Lancia l'evento DistLevelSaveEvent.
Metodo protetto | OnDistReplaceSaveEvent | Lancia l'evento DistReplaceSaveEvent.
Metodo protetto | OnDistSaveEvent | Lancia l'evento DistSaveEvent.
Metodo pubblico | OnDocStructInfoCreated | Lancia l'evento alla creazione di un nuovo DocStructInfo
Metodo protetto | OnDocumentAnnullaCheckedOutEvent | Lancia l'evento DocumentAnnullaCheckedOutEvent.
Metodo protetto | OnDocumentCheckedInEvent | Lancia l'evento DocumentCheckedIn.
Metodo protetto | OnDocumentCheckedOutEvent | Lancia l'evento DocumentCheckedOut.
Metodo protetto | OnDocumentCheckLocked | Lancia l'evento DocumentCheckLockedEvent.
Metodo protetto | OnDocumentCreating | Chiama l'evento DocumentCreating.
Metodo pubblico | OnDocumentDisableEvent | Lancia l'evento per non visualizzare i documenti nel controllo documentale
Metodo protetto | OnDocumentDisconnectingEvent | Lancia l'evento DocumentDisconnectingEvent.
Metodo protetto | OnDocumentDownloadedEvent | Lancia l'evento DocumentDownloaded
Metodo pubblico | OnDocumentDragDropEvent |
Metodo protetto | OnDocumentEnsureLocalOperationEvent | Lancia l'evento DocumentEnsureLocalOperationEvent.
Metodo protetto | OnDocumentImportedEvent | Lancia l'evento DocumentImport.
Metodo protetto | OnDocumentImporting | Lancia l'evento DocumentImporting.
Metodo protetto | OnDocumentLinking | Lancia l'evento DocumentLinkingEvent.
Metodo protetto | OnDocumentMoving | Lancia l'evento DocumentImporting.
Metodo protetto | OnDocumentPublishEvent | Lancia l'evento DocumentPublishOut.
Metodo protetto | OnDocumentRecognizing | Lancia l'evento DocumentImporting.
Metodo protetto | OnDocumentSbloccaEvent | Lancia l'evento DocumentSbloccaEvent.
Metodo protetto | OnDocumentUpdating | Chiama l'evento DocumentUpdating.
Metodo pubblico | OnDragDropEvent | Lancia l'evento di DragDrop
Metodo pubblico | OnEditAttr | Lancia l'evento EditAttr.
Metodo pubblico | OnEditAttrValidating | Lancia l'evento ValidatingEditAttrEvent.
Metodo protetto | OnEditComm | Chiama l'evento ExportData.
Metodo protetto | OnEditCommChanged | Lancia l'evento NewAnagrChanged.
Metodo protetto | OnElaborateDedListEvent | Lancia l'evento per gestire le liste.
Metodo pubblico | OnEsclAttrUpdFromDBTabEvent | Lancia l'evento EsclAttrUpdFromDBTabEvent.
Metodo protetto | OnEvaluateNewValue | Chiama l'evento ProcessNewValue.
Metodo protetto | OnExportData | Chiama l'evento ExportData.
Metodo pubblico | OnExportPackAndGoConfirmEvent | Lancia l'evento ExportPackAndGoConfirmEvent.
Metodo pubblico | OnExportResultBomCompare | Lancia l'evento ExportResultBomCompareEventArgs.
Metodo protetto | OnFamDescrOverrideEvent | Lancia l'evento ValidateFamPropertyEvent.
Metodo pubblico | OnFillAttributeListFilter | Lancia l'evento che permette il filtraggio degli attributi in fase di inserimento delle liste utilizzate nell'applicazione
Metodo protetto | OnFilterSearchResult | Chiama l'evento ClassListItemClick.
Metodo pubblico | OnFindCodeMultipleAnagrEvent | Lancia l'evento FindCodeMultipleAnagrEvent.
Metodo protetto | OnFindCodeStateFilter | Lancia l'evento che permette di filtrare la lista del form find code in base allo stato dell'anagrafica
Metodo pubblico | OnFolderDisableEvent | Lancia l'evento per non visualizzare la cartella nel controllo documentale.
Metodo protetto | OnFtpClientConnectionEvent | Lancia l'evento per visualizzare una lista di suffissi in creazione di una Rappresentazione.
Metodo pubblico | OnGetDocPropertiesEvent | Lancia l'evento di GetDocPropertiesEvent.
Metodo protetto | OnGetRepresentationSuffixListEvent | Lancia l'evento per visualizzare una lista di suffissi in creazione di una Rappresentazione.
Metodo protetto | OnImportAttListEvent | Lancia l'evento ImportAttListEvent
Metodo protetto | OnImportAttrValueEvent | Lancia l'evento ImportAttrValueEvent
Metodo pubblico | OnImportDataCanUpdate | Lancia l'evento per la gestione dell'anagrafica da aggiornare nel comando Importa Dati.
Metodo pubblico | OnImportOnSaveEvent | Lancia l'evento di ImportOnSaveEvent sui documenti che sono all'interno delle root definite in ROOTS_RECOGNIZED_ON_DBSAVE
Metodo pubblico | OnImportPackAndGoSelectEvent | Lancia l'evento ImportPackAndGoSelectEvent.
Metodo protetto | OnListImportDataEvent | Lancia l'evento di validazione di un codice durante l'importazione in una lista.
Metodo protetto | OnLoadFormCommEditEvent | Lancia l'evento LoadFormCommEditEvent
Metodo protetto | OnManagePlaceHolderLogicComputed | Lancia l'evento per l'override della logica di gestione dei placeholder.
Metodo pubblico | OnManageSelectionDocsEvent | Metodo che esegue l'evento di 'ManageRevDocsEvent'.
Metodo protetto | OnModifyDocumentBeforeCheckedInEvent | Lancia l'evento DocumentCheckedIn.
Metodo protetto | OnMoveDocument | Lancia l'evento MoveDocument.
Metodo protetto | OnMsgDistReplaceSaveEvent | Lancia l'evento MsgDistReplaceSaveEvent.
Metodo pubblico | OnMultipleStateChangeExecute | Lancia l'evento che permette di verificare la lista delle anagrafiche selezionate durante le operazioni di Rilascio/Lavorazione multiplo
Metodo protetto | OnNewAnagrChanged | Lancia l'evento NewAnagrChanged.
Metodo protetto | OnNewAnagrCreated | Lancia l'evento NewAnagrCreated.
Metodo protetto | OnNewAnagrInit | Lancia l'evento NewAnagrInit.
Metodo protetto | OnNewAnagrValidating | Lancia l'evento NewAnagrValidating.
Metodo protetto | OnNewCommChanged | Lancia l'evento NewAnagrChanged.
Metodo protetto | OnNoteTransferPackEvent | Lancia l'evento NoteTransferPackEventArgs.
Metodo protetto | OnNotifyEvent | Lancia l'evento NotifyEvent
Metodo pubblico | OnOpenCommandDisableDocumentEvent | Lancia l'evento per non aprire alcuni file
Metodo protetto | OnOpenDocument | Lancia l'evento di apertura documento.
Metodo protetto | OnOrderPiorityList | Chiama l'evento OrderPriorityListEvent.
Metodo pubblico | OnOverrideAttListEvent | Lancia l'evento OverrideAttListEvent.
Metodo pubblico | OnOverrideAttrEvent | Lancia l'evento OverrideAttrEvent.
Metodo pubblico | OnOverrideCommandEnablingEvent | Lancia l'evento per non ridefinire l'abilitazione dei comandi.
Metodo pubblico | OnOverrideEnableSaveCommControl | Chiama l'evento OverrideEnableSaveControl.
Metodo pubblico | OnOverrideEnableSaveControl | Chiama l'evento OverrideEnableSaveControl.
Metodo protetto | OnOverwriteImportPlaceHolder | Lancia l'evento per l'override della logica di gestione dei placeholder.
Metodo protetto | OnPostInit | Chiama l'evento PostInit.
Metodo protetto | OnProgrCollisionEvent | Lancia l'evento ProgrCollisionEvent
Metodo pubblico | OnRecognizerPathDefined | Lancia l'evento per la specializzazione della filelist dal path definito nel form di registrazione dei documenti
Metodo pubblico | OnRedrawAnagr | Lancia l'evento RedrawAnagr.
Metodo pubblico | OnRedrawAttr | Lancia l'evento RedrawAttr.
Metodo pubblico | OnRedrawComm | Lancia l'evento RedrawComm.
Metodo pubblico | OnRedrawDedType | Lancia l'evento RedrawDedType.
Metodo pubblico | OnRedrawDep | Lancia l'evento RedrawDep.
Metodo pubblico | OnRedrawDist | Lancia l'evento RedrawDist.
Metodo protetto | OnReferenceUpdateOperationEvent | Lancia l'evento per registrarsi ai delegate del comando UpdateDocumentReference.
Metodo protetto | OnRemoveAnagr | Lancia l'evento RemoveAnagr.
Metodo protetto | OnRemoveDocument | Lancia l'evento di cancellazione documento.
Metodo protetto | OnResetSearchCriteria | Chiama l'evento ResetSearchCriteria
Metodo protetto | OnSaveCustomButtonClickEvent | Chiama l'evento SaveCustomButtonClickEvent.
Metodo pubblico | OnSaveDistOnApprovedEventEvent | Metodo che esegue l'evento di 'SaveDistOnApprovedEvent'.
Metodo pubblico | OnSendToCommandDisableDocumentEvent | Lancia l'evento per non inviare alcuni file
Metodo pubblico | OnSetDefaultFindCodeFilterEvent | Metodo che esegue l'evento di 'SetDefaultFindCodeFilter'.
Metodo pubblico | OnShowPreview | Lancia l'evento ShowPreview.
Metodo protetto | OnShowReplaceAnagrDistForm | Chiama l'evento ShowReplaceAnagrDistForm.
Metodo protetto | OnShowSaveForm | Chiama l'evento ShowSaveForm.
Metodo protetto | OnShowZoomPreview |
Metodo protetto | OnSkipDocumentStatusOnSaveDist | Lancia l'evento SkipDocumentStatusOnSaveDistEvent
Metodo pubblico | OnSkipUpdateAttribListEvent | Lancia l'evento SkipUpdateAttribListEvent.
Metodo protetto | OnStateChanged | Lancia l'evento StateChanged.
Metodo protetto | OnStateCommandDocClose | Lancia l'evento StateCommandDocClose.
Metodo protetto | OnStateCommandDocOpen | Lancia l'evento StateCommandDocOpen.
Metodo protetto | OnStateCommandDocPublish | Lancia l'evento StateCommandDocPublish.
Metodo protetto | OnStateCommandDocPublishErase | Lancia l'evento StateCommandDocPublishEraseEvent.
Metodo protetto | OnStateCommandDocsPublished | Lancia l'evento di termine pubblicazione dei documenti dell'anagrafica rilasciata
Metodo protetto | OnStateCommandEvent | Lancia l'evento StateCommandEvent.
Metodo protetto | OnStateCommmandDocWrite | Lancia l'evento StateCommmandDocWrite
Metodo protetto | OnStateElaboratingDocuments | Lancia l'evento OnStateElaboratingDocuments
Metodo protetto | OnTypeAdded | Chiama l'evento TypeAdded.
Metodo protetto | OnTypesReloaded | Lancia l'evento TypesReloaded.
Metodo pubblico | OnUnRilErasePublishEvent | Metodo che esegue l'evento di UnRilErasePublishEvent
Metodo protetto | OnUpgradeAnagrComm | Lancia l'evento UpgradeAnagrCommEvent.
Metodo protetto | OnValidateCheckFunction | Lancia l'evento ValidateCheckFunction.
Metodo protetto | OnValidateCommPropertyEvent | Lancia l'evento ValidateCommPropertyEvent.
Metodo protetto | OnValidateFamPropertyEvent | Lancia l'evento ValidateFamPropertyEvent.
Metodo pubblico | RegisterUser | Crea l'utente con l'impostazione dei relativi permessi
Metodo pubblico | Reload | Ricarica tutta la struttura degli oggetti e lancia l'evento TypesReloaded.
Metodo pubblico | ReloadAttLists | Rilegge dal database le liste att, scartando eventuali modifiche non salvate.
Metodo pubblico | SelectData(IEnumerableDedData) | Chiede all'utente di selezionare una sola anagrafica tra quelle che ha specificato in ingresso.
Metodo pubblico | SelectData(DedNetApplication, String) | Chiede all'utente di selezionare una sola anagrafica. Restituisce null se l'utente annulla.
Metodo pubblico | SelectData(DedNetApplication, String, Boolean) | Chiede all'utente di selezionare una sola anagrafica. Restituisce null se l'utente annulla.
Metodo pubblico | SelectDataMulti | Chiede all'utente di selezionare un elenco di anagrafiche. Restituisce null se l'utente annulla.
Metodo pubblico | SelectDedType | Chiede all'utente di selezionare una sola famiglia. Restituisce null se l'utente annulla.
Metodo pubblico | SelectDocument | Chiede all'utente di selezionare un solo documento. Restituisce null se l'utente annulla.
Metodo pubblico | SetUserListExt | Metodo che imposta la nuova lista di estensioni
Metodo pubblico | ShowDedDataList | Metodo che riporta, nel dialogo della ricerca, l'elenco di anagrafiche specificate in ingresso.
Metodo pubblico | ShowDedFormAbout | Mostra il dialogo FormAbout del QsUI inizializzato con le informazioni del DED.
Metodo pubblico | ShowDocsSelectionForm | Mostra la finestra di selezione dei documenti nel caso venga passato useUI a true in tutti i casi esegue anche l'evento di post selezione.
Metodo pubblico | StatoAnagr | Metodo che restituisce una stringa con lo stato attuale dell'anagrafica.
Metodo pubblico | StatoAnagrMinimal | Metodo che restituisce una stringa con lo stato attuale dell'anagrafica.
Metodo pubblico | StatoDoc | Metodo che restituisce una stringa con lo stato attuale del doccumento.
Metodo pubblico | StoreForcedAuthentication | Memorizza le credenziali per l'accesso automatico senza autenticazione.
Metodo pubblico | UpdateAttrOrder | Aggiorna tutti gli indici degali attributi.
Metodo pubblico | UserLastModified | Indica l'ultimo utente che ha effettuato un pubblica. Usato nel caso di PSW con DFS mode.
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | AddDataDocEvent | Evento chiamato dopo l'associazione del documento all'anagrafica (linking)
Evento pubblico | AddExtensionsRecognizerFormEvent | Evento per poter modificare la lista delle estensioni aggiuntivi nel form di riconoscimento dei file (DedFormFileRecognizer)
Evento pubblico | AfterEraseEmptyPwsFolderEvent | Evento chiamato alla fine della cancellazione delle cartelle vuote della pws.
Evento pubblico | AfterSaveDedCommTypeEvent | Evento chiamato nel post salvataggio.
Evento pubblico | AfterSaveDedTypeEvent | Evento chiamato nel post salvataggio.
Evento pubblico | AnagrSelectionDeletedEvent | Evento chiamato al termine dell'eliminazione della selezione di anagrafiche
Evento pubblico | AttributeChanged | Evento chiamato alla modifica di un attributo nell'edita attributi.
Evento pubblico | AttributeInit | Evento chiamato all'inizializzazionr del controllo degli attributi.
Evento pubblico | BeforeShowZoomPreviewEvent | Evento che scatta prima che venga caricato il QsTopDwgViewer. Permette di definire con che profilo eseguire il QsTopDwgViewer (di default viene eseguito il profilo 'Simple').
Evento pubblico | BomEditFormButtonClickEvent | Evento chiamato alla pressione dei pulsanti personalizzati delle barre del form editor delle distinte
Evento pubblico | BomEditFormToggleSwitchEvent | Evento chiamato al cambio stato dei toggle personalizzati delle barre del form editor delle distinte
Evento pubblico | BomExplorerAddReplaceDataEvent | Evento chiamato in fase di aggiunta o sostituzione codice dal controllo dedicato nel panello interno all'explorer control.
Evento pubblico | BomExplorerButtonClickEvent | Evento chiamato alla pressione dei pulsanti personalizzati della finestra dell'editor delle distinte.
Evento pubblico | BomExplorerContextMenuOpeningEvent | Evento chiamato in fase di apertura del context menu sul controllo distinta interno al bom explorer. Permette di aggiungere comandi.
Evento pubblico | BomExplorerLoadDistEvent | Evento chiamato al caricamento di una distinta nel controllo explorer dell'editor delle distinte.
Evento pubblico | ChangeStateECOEvent | Evento lanciato prima e dopo il cambio di stato di un ECO.
Evento pubblico | ChangingDependencyDocumentEvent | Evento chiamato quando si debba effettuare la sostituzione fisica di un riferimento in un file. Se attiva l'area locale, l'aggiornamento deve avvenire sia nel file presente nel vault che nella pws.
Evento pubblico | CheckProgrReservedEvent | Evento lanciato quando si verifica una collisione di progressivi al salvataggio nel DB su una famiglia con infouser.
Evento pubblico | CheckRevAlphabetEvent | Evento lanciato quando si verifica una i caratteri dell'alfabeto.
Evento pubblico | ClassListItemClickEvent | Evento chiamato quando l'utente clicca su un elemento del class list.
Evento pubblico | CommAddAnagItemEvent | Evento sull'aggiunta di un elemento di anagrafica sulla commessa
Evento pubblico | CommandExecutingEvent | Evento di esecuzione comando. Questo evento viene chiamato all'inizio ed alla fine dell'esecuzione del comando.
Evento pubblico | CommCancelEvent | Evento di cancellazione creazione/modifica commessa.
Evento pubblico | CommDescrOverrideEvent | Evento chiamato per poter ridefinire la descrizione della commessa ( inserire una lista a tendina ).
Evento pubblico | CommElementCreateDataEvent | Evento sulla creazione dell'anagrafica chiamato sia prima che dopo la creazione di una anagrafica a partire da un nuovo elemento di distinta da aggiungere. Questo è l'evento ad alto livello che agisce a livello di comando, vedere anche l'evento DistItemCreateData..
Evento pubblico | CommFileExplorerUpdateEvent | Evento per calcolare il percorso da visualizzare nell'Esplora Risorse delle commesse.
Evento pubblico | CopyDocumentEvent | Evento chiamato per effettuare la copia di un file. Chi gestisce questo evento si deve preoccupare di copiare sia la versione in locale che quella del server, nel caso di area locale attiva.
Evento pubblico | CreateCommEvent | Evento lanciato prima e dopo la creazione di una commessa.
Evento pubblico | CreateECOEvent | Evento lanciato prima e dopo la creazione di un ECO.
Evento pubblico | CreateMultiLevelBomEvent | Evento che permette di editare la distinta ricambi multilivello
Evento pubblico | CreatingSparePartDrawing | Evento chiamato quando viene eseguito il comando 'Crea tavola ricambi'.
Evento pubblico | DedBomEditLoaded | Evento chiamato durante il load del form DedBomEdit.
Evento pubblico | DedDataChangedEvent | Evento chiamato quando viene aggiunto un record in DedData.
Evento pubblico | DedDataMoveEvent | Evento chiamato sullo spostamento di un'anagrafica.
Evento pubblico | DedOpenDocumentEvent | Evento chiamato in fase di apertura di un documento dal DED.
Evento pubblico | DedRuleLuaEvent | Evento chiamato per la gestione delle regole di autocomposizione in Lua.
Evento pubblico | DedRuleRowSetAttrPostEvent | Evento chiamato subito dopo la sostituzione di tutta la stringa di una regola.
Evento pubblico | DedRuleSetAttrPostEvent | Evento chiamato subito dopo l'impostazione degli attributi di una regola.
Evento pubblico | DedRuleSetAttrPreEvent | Evento chiamato subito prima dell'impostazione degli attributi di una regola.
Evento pubblico | DedRuleSingleSetAttrPreEvent | Evento chiamato prima della sostituzione di un singolo token di una singola regola.
Evento pubblico | DedTranslationChangedEvent | Evento chiamato quando viene aggiunto un record in DedData.
Evento pubblico | DefineFileDependencyEvent | Evento chiamato per definire la dipendenza di un file che non è presente nel Database. Viene chiamato con il Before e l'After ad indicare il momento e se si imposta come Handled lascia la lista delle dipendenze così come l'ha modificata il client.
Evento pubblico | DisableAutoUpdateAnagrCommEvent | Evento per disabilitare l'aggiornamento automatico delle revisioni delle anagrafiche di commessa La disabilitazione avviene tramite un valore di un determinato attributo di commessa
Evento pubblico | DistAddNodeEvent | Evento chiamata quando viene iserito un nuovo nodo in distinta.
Evento pubblico | DistChangeFieldValueEvent | Evento chiamato alla modifica di un attributo di distinta nella finestra dell'editor delle distinte.
Evento pubblico | DistCloneDataEvent | Evento chiamato alla copia di ogni elemento nel clona distinta chiamato da DEDAPI.DuplicaDistinta()
Evento pubblico | DistCopyDataEvent | Evento chiamata quando viene copiato un codice dal pannello di dx a quell di dx tramite editor distinte. Possibilità di annuallare l'inserimento e cambiare i dati inseriti.
Evento pubblico | DistDragElementEvent | Evento chiamata quando viene aggiunto un elemento alla distinta tramite l'inizia parte veloce. Possibilità di annullare l'inserimento e cambiare i dati inseriti.
Evento pubblico | DistEditSaveEvent | Evento di salvataggio all'interno dell'editor delle distinte.
Evento pubblico | DistElementCreateDataEvent | Evento sulla creazione dell'anagrafica chiamato sia prima che dopo la creazione di una anagrafica a partire da un nuovo elemento di distinta da aggiungere. Questo è l'evento ad alto livello che agisce a livello di comando, vedere anche l'evento DistItemCreateData..
Evento pubblico | DistItemCreateDataEvent | Evento sulla creazione dell'anagrafica chiamato sia prima che dopo la creazione di una anagrafica a partire da un nuovo elemento di distinta da aggiungere. Questo è l'evento a basso livello, per agire a livello di comando vedere l'evento DistElementCreateData.
Evento pubblico | DistLevelSaveEvent | Evento di salvataggio della distinta. A differenza dell'evento "DistSaveEvent", questo scatta per ogni item della distinta.
Evento pubblico | DistReplaceSaveEvent | Evento di salvataggio durante la sostituzione massiva.
Evento pubblico | DistSaveEvent | Evento di salvataggio della distinta.
Evento pubblico | DocStructInfoCreatedEvent | Evento creazione nuovo DocStructInfo
Evento pubblico | DocumentAnnullaCheckedOutEvent | Evento chiamato dopo il checkout su di un documento
Evento pubblico | DocumentCheckedInEvent | Evento chiamato prima del checkin di un elemento
Evento pubblico | DocumentCheckedOutEvent | Evento chiamato dopo il checkout su di un documento
Evento pubblico | DocumentCheckLockedEvent | Evento chiamato in fase di scaricamento in locale del documento per controllare se è locked.
Evento pubblico | DocumentCreatingEvent | Evento lanciato in fase di creazione documento, che permette di personalizzare il guid di versione documento da scrivere nel record ed anche i dati del documento.
Evento pubblico | DocumentDisableEvent | Evento lanciato in fase visualizzazione del documento nel controllo documentale.
Evento pubblico | DocumentDisconnectingEvent | Evento chiamato in fase di disconnesione documento dall'anagrafica. Permette ai client di impostare i dati del comando.
Evento pubblico | DocumentDownloadedEvent | Evento chiamato dopo che un documento è stato scaricato in locale da una operazione di ensurelocal
Evento pubblico | DocumentDragDropEvent | Evento lanciato prima della partenza del drag da controllo documentale. Permette di impedirne la continuazione.
Evento pubblico | DocumentEnsureLocalOperationEvent | Evento chiamato durante l'operation dell'esurelocal su di un documento
Evento pubblico | DocumentImportedEvent | Evento chiamato dopo l'importazione di un documento sull'anagrafica
Evento pubblico | DocumentImportingEvent | Evento chiamato in fase di importazione documento che permette di modificare la struttura sottostante al documento prima dell'esecuzione vera e propria dell'operazione. Viene chiamato anche immediatamente dopo l'esecuzione.
Evento pubblico | DocumentLinkingEvent | Evento chiamato in fase di collegamento documento all'anagrafica. Permette ai client di impostare i dati del comando.
Evento pubblico | DocumentMovingEvent | Evento chiamato in fase di move command sui documenti principali. Permette ai client di impostare i dati di clonazione nella sotto struttura.
Evento pubblico | DocumentPublishEvent | Evento chiamato prima della pubblicazione di un elemento
Evento pubblico | DocumentRecognizingEvent | Evento chiamato in fase di riconoscimento documento che permette di modificare la struttura sottostante al documento prima dell'esecuzione vera e propria dell'operazione. Viene chiamato anche immediatamente dopo l'esecuzione.
Evento pubblico | DocumentSbloccaEvent | Evento chiamato dopo lo sblocca su di un documento
Evento pubblico | DocumentUpdatingEvent | Evento lanciato in fase di aggiornamento documento, che permette di personalizzare il guid di versione documento da scrivere nel record.
Evento pubblico | DragDropEvent |
Evento pubblico | EditAttrEvent | Evento chiamato prima di entrare in editazione dell'anagrafica e dopo aver confermato l'editazione.
Evento pubblico | EditAttrValidatingEvent | Evento chiamato prima di entrare in editazione dell'anagrafica e dopo aver confermato l'editazione.
Evento pubblico | EditCommChangedEvent | Evento su modifica della commessa o di uno dei valori durante la procedura di modifica commessa.
Evento pubblico | EditCommEvent | Evento lanciato prima e domo la modifica di una commessa.
Evento pubblico | ElaborateDedListEvent | Evento che permette di gestire gli elementi in lista
Evento pubblico | EsclAttrUpdFromDBTabEvent | Evento lanciato quando viene usata la lista SkipAttribListEvent.
Evento pubblico | EvaluateNewValueEvent | Evento chiamato quando l'utente digita un codice non presente nel Database nella finestra di ricerca veloce, e che quindi può essere corretto da chi gestisce l'evento.
Evento pubblico | ExportDataEvent | Evento chiamato per la gestione dell'esportazione.
Evento pubblico | ExportPackAndGoConfirmEvent |
Evento pubblico | ExportResultBomCompareEvent | Evento che permette di bloccare l'esportazione su excel del risultato del confronto tra distinte e di gestirlo
Evento pubblico | FamDescrOverrideEvent | Evento chiamato per poter ridefinire la descrizione della famiglia ( inserire una lista a tendina ).
Evento pubblico | FillAttributeListFilterEvent | Evento che permette il filtraggio degli attributi in fase di inserimento delle liste utilizzate nell'applicazione
Evento pubblico | FilterSearchResultEvent | Evento chiamato quando l'utente seleziona un filtro sul risultato ricerca.
Evento pubblico | FindCodeMultipleAnagrEvent | Evento chiamato nell'apri veloce nel caso di ricerca su invio con risultato mulitplo.
Evento pubblico | FindCodeStateFilterEvent | Evento che permette di filtrare la lista del form find code in base allo stato dell'anagrafica
Evento pubblico | FolderDisableEvent | Evento lanciato in fase di visualizzazione della cartella nel controllo documentale.
Evento pubblico | FtpClientConnectionEvent | Evento che permette modificare i dati del client FTP.
Evento pubblico | GetDocPropertiesEvent | Evento che permette di ricavare la lista di proprietà di una serie di file.
Evento pubblico | GetRepresentationSuffixListEvent | Evento che permette di visualizzare una lista di suffissi in creazione di una Rappresentazione.
Evento pubblico | ImportAttListEvent | Evento che permette di importare la lista att di un attributo da una fonte dati esterna.
Evento pubblico | ImportAttrValueEvent | Evento che permette di importare il valore di un attributo da una fonte dati esterna.
Evento pubblico | ImportDataCanUpdateEvent | Evento che permette di gestire l'anagrafica da aggiornare nel comando Importa Dati.
Evento pubblico | ImportOnSaveEvent | Evento per gestire l'azione da attuare in fase di salvataggio dei documenti che sono all'interno delle root definite in ROOTS_RECOGNIZED_ON_DBSAVE.
Evento pubblico | ImportPackAndGoSelectEvent |
Evento pubblico | ListImportDataEvent | Evento di validazione di un codice durante l'importazione in una lista
Evento pubblico | LoadFormCommEditEvent | Evento lanciato al caricamento del form delle commesse.
Evento pubblico | ManagePlaceHolderLogicComputedEvent | Evento chiamato per permettere l'override della logica di gestione dei placeholder in base a criteri utente
Evento pubblico | ManageSelectionDocsEvent | Evento che permette di gestire la selezione dei documenti.
Evento pubblico | ModifyDocumentBeforeCheckedInEvent | Evento chiamato per i tecnici in modo che possano modificare il documento prima che il ded faccia tutto nel DocumentCheckedInEvent
Evento pubblico | MoveDocumentEvent | Evento chiamato per effettuare lo spostamento/rinomina di un file. Chi gestisce questo evento si deve preoccupare di spostare sia la copia in locale che quella del server, nel caso di area locale attiva.
Evento pubblico | MsgDistReplaceSaveEvent | Evento che permette di visualizzare un messaggio prima e/o dopo la sostituzione massiva.
Evento pubblico | MultipleStateChangeExecute | Evento che permette di verificare la lista delle anagrafiche selezionate durante le operazioni di Rilascio/Lavorazione multiplo
Evento pubblico | NewAnagrChangedEvent | Evento su modifica dell'anagrafica o di uno dei valori che influenzano la codifica durante la procedura di creazione nuova anagrafica.
Evento pubblico | NewAnagrCreatedEvent | Evento chiamato subito dopo aver creato l'anagrafica nel comando di creazione nuovo record.
Evento pubblico | NewAnagrInitEvent | Evento di inizializzazione dei comandi di creazione nuovo record. Questo evento viene chiamato all'inizio del comando per impostarne le proprietà secondo l'esigenza di personalizzazione.
Evento pubblico | NewAnagrValidatingEvent | Evento di validazione chiamato subito prima la creazione di una nuova anagrafica.
Evento pubblico | NewCommChangedEvent | Evento su modifica della commessa o di uno dei valori durante la procedura di creazione nuova commessa.
Evento pubblico | NoteTransferPackEvent | Evento che permette di inserire una Nota nel trasfer pack con gestione della visualizzazione della finestra di inserimento Note
Evento pubblico | NotifyEvent | Evento lanciato per poter modificare le informazioni della notifica e eventualmente cancellarla.
Evento pubblico | OpenCommandDisableDocumentEvent | Evento lanciato in fase di apertura dei documenti.
Evento pubblico | OpenDocumentEvent | Evento di apertura documento. Viene chiamato per intercettare l'apertura di un documento per consentire di sostituirsi all'apertura.
Evento pubblico | OrderPriorityListEvent | Evento per ordinare la lista delle estensioni prioritarie dai vari CAD.
Evento pubblico | OverrideAttListEvent | Evento chiamato per la personalizzazione dell'elenco valori associata ad un determinato attributo.
Evento pubblico | OverrideAttrEvent | Evento chiamato prima di visualizzare il controllo degli aattributi.
Evento pubblico | OverrideCommandEnablingEvent | Evento usato dagli add-in per effettuare l'override dell'abilitazione dei comandi del Core.
Evento pubblico | OverrideEnableSaveCommControlEvent | Evento da utilizzare per ridefinire l'abilitazione dei controlli nel form di salvataggio commessa
Evento pubblico | OverrideEnableSaveControlEvent | Evento da utilizzare per ridefinire l'abilitazione dei controlli nel form di salvataggio
Evento pubblico | OverwriteImportPlaceHolderEvent | Evento chiamato per permettere l'ultima ridefinizione del placehodre (parte su tutti i file)
Evento pubblico | PostInitEvent | Evento chiamato alla fine dell'inizializzazione dell'applicazione.
Evento pubblico | ProgrCollisionEvent | Evento lanciato quando si verifica una collisione di progressivi al salvataggio nel DB su una famiglia con infouser.
Evento pubblico | RecognizerPathDefinedEvent | Evento per la specializzazione della filelist dal path definito nel form di registrazione dei documenti
Evento pubblico | RedrawAnagrEvent | Evento chiamato prima di disegnare le varie celle della ricerca.
Evento pubblico | RedrawAttrEvent | Evento chiamato prima di disegnare le varie celle degli attributi.
Evento pubblico | RedrawCommEvent | Evento chiamato prima di disegnare le varie celle delle commesse.
Evento pubblico | RedrawDedTypeEvent | Evento chiamato prima di disegnare le varie celle delle famiglie.
Evento pubblico | RedrawDepEvent | Evento chiamato prima di disegnare le varie celle nell'albero delle dipendeze.
Evento pubblico | RedrawDistEvent | Evento chiamato prima di disegnare le varie celle delle distinte.
Evento pubblico | ReferenceUpdateOperationEvent | Evento che permette ai CAD e ai plugin di registrarsi ai delegate del comando UpdateDocumentReference.
Evento pubblico | RemoveAnagrEvent | Evento chiamato nell'eliminazione di un'anagrafica.
Evento pubblico | RemoveDocumentEvent | Evento chiamato quando l'utente elimina un documento.
Evento pubblico | ResetSearchCriteriaEvent | Evento chiamato quanto l'utente preme il tasto di reset dei criteri della ricerca
Evento pubblico | SaveCustomButtonClickEvent | Evento chiamato alla pressione dei pulsanti personalizzati della finestra di salva.
Evento pubblico | SaveDistOnApprovedEvent | Evento che permette di decidere il comportamento sul salvataggio distinta al rilascio
Evento pubblico | SendToCommandDisableDocumentEvent | Evento lanciato in fase di invio dei documenti.
Evento pubblico | SetDefaultFindCodeFilterEvent | Evento che permette di definire l'attributo di ricerca utilizzato nel DedFindCodeControl.
Evento pubblico | ShowPreviewEvent | Evento chiamato per la visualizzazione del preview.
Evento pubblico | ShowReplaceAnagrDistFormEvent | Evento chiamato al caricamento della finestra di sostituzione anagrafica in distinte.
Evento pubblico | ShowSaveFormEvent | Evento chiamato al caricamento della finestra di salva.
Evento pubblico | ShowZoomPreviewEvent | Evento chiamato per la visualizzazione del preview ( zoom ).
Evento pubblico | SkipDocumentStatusOnSaveDistEvent | Evento lanciato per fare determinare dai client se un documento debba essere skippato in fase di controllo dello stato nel salva distinta
Evento pubblico | SkipUpdateAttribListEvent |
Evento pubblico | StateChangedEvent | Evento chiamato al cambio di stato di un'anagrafica.
Evento pubblico | StateCommandDocCloseEvent | Evento di chiusura dopo elaborazione documento.
Evento pubblico | StateCommandDocOpenEvent | Evento di apertura per elaborazione documento.
Evento pubblico | StateCommandDocPublishEraseEvent | Evento di cancellazione documenti pubblicazione.
Evento pubblico | StateCommandDocPublishEvent | Evento di pubblicazione documento.
Evento pubblico | StateCommandDocsPublishedEvent | Evento di post pubblicazione di tutti i documenti dell'anagrafica rilasciata
Evento pubblico | StateCommandEventEvent | Evento generato dal comando di modifica stato anagrafica.
Evento pubblico | StateCommmandDocWriteEvent | Evento di scrittura documento prima della pubblicazione
Evento pubblico | StateElaboratingDocumentsEvent | Evento generato prima della elaborazione dei documenti in modifica stato anagrafica
Evento pubblico | TypeAddedEvent | Evento chiamato quando viene aggiunta una famiglia tramite il QsManager ( crea/incolla )
Evento pubblico | TypesReloadedEvent | Evento chiamato quando vengono ricaricate le famiglie dei tipi e tutta la struttura degli oggetti.
Evento pubblico | UnRilErasePublishEvent | Evento che permette la personalizzazione e l'override delle opzioni di eliminazione dei documenti di pubblicazione in cambio stato
Evento pubblico | UpgradeAnagrCommEvent | Evento sull'aggiornamento delle anagrafiche in commessa
Evento pubblico | ValidateCheckFunctionEvent | Evento chiamato quando vengono validati gli attributi che hanno una funzione di controllo.
Evento pubblico | ValidateCommPropertyEvent | Evento chiamato quando vengono validati gli attributi della commessa.
Evento pubblico | ValidateFamPropertyEvent | Evento chiamato quando vengono validati gli attributi della famiglia.
Torna su
Campi
 | Nome | Descrizione
 | DefaultConfig |
Campo pubblico | ExecutingDbFix |
 | NeutralLanguage | Lingua neutrale utilizzata come default. Attenzione! Se si vuole cambiare questo valore si dovrà poi cambiare anche il valore "Neutral Language" specificato nelle informazioni di ogni assembly (per fare ciò basta cercare la stringa "NeutralResourcesLanguage"). Il valore di questo campo segue quello specificato nel "NeutralResourcesLanguage", di conseguenza se i valori sono diversi, questo valore dovrà essere aggiornato con quello specificato nel "NeutralResourcesLanguage".
 | RecurrentTiming | Nome della chiave di registro in cui sono salvate le temporizzazioni ricorrenti.
 | UnkwownConfig |
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore DedNetApplication
Costruttore unico senza argomenti per la compatibilità COM.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedNetApplication()
Public Sub New
public:
DedNetApplication()
new : unit -> DedNetApplication
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà di DedNetApplication

Il tipo DedNetApplication espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllCommands | Restituisce la lista di tutti i comandi dell'applicazione.
Proprietà pubblica | ApplicationCommands | Restituisce la lista dei comandi Applicazione.
Proprietà pubblica | AttManager | Restituisce il gestore delle liste collegate agli attributi.
Proprietà pubblica | AttributesEco | Restituisce la lista degli attributi ECO.
Proprietà pubblica | AttributesOcc | Restituisce la lista degli attributi di occorrenza.
Proprietà pubblica | AutocadExtension | Estensioni di Autocad.
Proprietà pubblica | AutoCompleteOnTyping | Indica se deve essere abilitato l'autocompletamento, mentre sto digitando, nel controllo custom DedFindCodeControl.
Proprietà pubblica | BomEditFormCommandList | Lista dei comandi del form dell'editor delle distinte ( bars ).
Proprietà pubblica | BomExplorerCtrlCommandList | Lista dei comandi dei controlli explorer dell'editor delle distinte ( toolbars ).
Proprietà pubblica | BomManualSettings | Ritorna le configurazioni per la visualizzazione delle colonne nei form relativi alle distinte
Proprietà pubblica | CascadeAutocomplete | Indica se autocompilare la tendina di un attributo associato a una cascata nel caso in cui la tendina contenga un solo valore.
Proprietà pubblica | CascadeManager | Restituisce il gestore delle cascate.
Proprietà pubblica | CategManager | Restituisce il gestore delle categorie.
Proprietà pubblica | CheckFunctions | Restituisce la lista delle funzioni di controllo usate negli attributi.
Proprietà pubblica | ClassList | Restituisce la lista di classList usate negli attributi.
Proprietà pubblica | ClientCommands | Restituisce la lista dei comandi Client.
Proprietà pubblica | ClientConnected | Restituisce o imposta la tipologia di client connesso.
Proprietà pubblica | ClientConnectedIgnoreTemporary | Client connesso reale e non forzato
Proprietà pubblica | CloseWindowOnLoad | Indica se chiudere la finestra dopo i comndi di caricamento componenti.
Proprietà pubblica | CloseWindowOnOpening | Indica se chiudere la finestra dopo che il documento è stato aperto.
Proprietà pubblica | Connection | Restituisce l'oggetto QSConnection correntemente utilizzato dall'applicazione.
Proprietà pubblica | ConnectionString | Imposta o restituisce la stringa di connesione al Database.
Proprietà pubblica | ContextManager | Restituisce il Manager di Contesto Documento.
Proprietà pubblica | Corporates | Restitusice la lista delle corporate disponibili
Proprietà pubblica | CurrentComm | Legge o imposta la commessa corrente
Proprietà pubblica | CustomCommands | Restituisce la lista dei comandi personalizzati.
Proprietà pubblica | CustomTranslations | Restituisce la lista delle traduzioni custom aziendali.
Proprietà pubblica | DataManager | Restituisce il Manager delle Anagrafiche.
Proprietà pubblica | DedManagerConnectionString | Imposta o restituisce la stringa di connesione del QsManager al Database.
Proprietà pubblica | DedManagerProviderName | Imposta o restituisce il nome completo della classe del provider di collegamento del QsManager al Database.
Proprietà pubblica | DefaultAnagrCommand | Comando di default da lanciare sul doppio click nelle anagrafiche.
Proprietà pubblica | DefaultDocumentCommand | Comando di default da lanciare sul doppio click neli documenti.
Proprietà pubblica | DocManager | Restituisce il Manager dei Documenti.
Proprietà pubblica | DocumentsWithInternalAttributes | Restituisce la lista delle estensioni dei file che se sono in checkout impediscono l'editazione degli attributi a livello di form ricerca e di comando.
Proprietà pubblica | DpiX | Ritorna la risoluzione orizontale attualmente impostata.
Proprietà pubblica | DpiY | Ritorna la risoluzione verticale attualmente impostata.
Proprietà pubblica | EcoManager | Restituisce l' EcoManager degli Eco.
Proprietà pubblica | ExecuteQueryOnEnter | Indica se il controllo custom DedFindCodeControl deve essere visualizzato con la combobox (True) o con il LookUpEdit (False).
Proprietà pubblica | Extensions | Ritorna la collection di addin caricati
Proprietà pubblica | FileServerManager | Restituisce l'oggetto che gestisce le informazioni sul client/server per la gestione dei file.
Proprietà pubblica | FormFindCodeQueryFields | Restituisce la lista dei campi nel combo di selezione campo query del form DedFormFindCode.
Proprietà pubblica | FormFindCodeResFields | Restituisce la lista dei campi da visualizzare nel combo di risultato ricerca del form DedFormFindCode.
Proprietà pubblica | GerenicDepExtension | Estensioni delle dipendenze di tipo Generic.
Proprietà pubblica | HideAttributeTranslations | Indica se nascondere le traduzioni degli attributi (di default è False).
Proprietà pubblica | IgnoreExtension | Estensioni da ignorare.
Proprietà pubblica | Initialized | Restituisce se l'inizializzazione dell'oggetto è già avvenuta correttamente attraverso la chiamata al metodo Init() con esito positivo.
Proprietà pubblica | InstallPath | Restituisce il path di installazione del DedNet (della root senza la cartella bin).
Proprietà pubblica | InventorExtension | Estensioni di Inventor.
Proprietà pubblica | IsDisposed | Restituisce true se è stato già fatto il Dispose dell'oggetto.
Proprietà pubblica | IsExportingCommand | Indica se il comando di esportazione è in esecuzione
Proprietà pubblica | IsImporterRunning | Indica se l'importartatore è stato avviato ed è in corso l'operazione di importazione dati.
Proprietà pubblica | IsLightInit | Restituisce se è stata fatta un'inizializzazione light.
Proprietà pubblica | Language | Imposta o restituisce la lingua dell'applicazione.
Proprietà pubblica | LastError | Restituisce l'ultimo errore che si è verificato utilizzando i metodi e le proprietà di questa interfaccia.
Proprietà pubblica | ListManager | Restituisce l'oggetto dedicato alla gestione delle liste.
Proprietà pubblica | LoadCurrentCode | Indica se, all'apertura dell'Apri Veloce, deve essere caricata l'anagrafica corrente (se presente).
Proprietà pubblica | LogManager | Restituisce il log manager per la gestione del log nel DB
Proprietà pubblica | LogVerbose | Indica se è attiva la modalità di debug che consente al logger di scrivere maggiori informazioni.
Proprietà pubblica | MainWindow | Restituisce o imposta la finestra principale dell'applicazione client da usare di default come parent di tutte le finestre mostrate (modali e non).
Proprietà pubblica | Notifier | Restituisce l'oggetto che gestisce le notifiche.
Proprietà pubblica | NumCharMemo | Indica il numero dei caratteri oltre il quale usare memoEdit
Proprietà pubblica | PathBomSetting | Imposta o restituisce il percorso in cui cercare la configurazione da usare per la visualizzazione delle colonne nei form relativi alle distinte
Proprietà pubblica | PathLoghi | Imposta o restituisce il percorso in cui cercare i loghi da usare per l'esportazione/stampa dei risultati.
Proprietà pubblica | PathRoots | Restituisce l'oggetto che gestisce la lista delle radici di archiviazione.
Proprietà pubblica | PathTemplate | Imposta o restituisce il percorso in cui cercare i template da usare per l'esportazione/stampa dei risultati.
Proprietà pubblica | PriorityExtList | Restituisce la lista delle estensioni alla quale dare la priorità nella selezione dei documenti. Aggiungere a questa collezione le estensioni (senza punto) sulle quali si desidera dare la precedenza.
Proprietà pubblica | PriorityExtListOriginal | Lista di appoggio contenente le estensioni originali
Proprietà pubblica | ProviderName | Imposta o restituisce il nome completo della classe del provider di collegamento al Database.
Proprietà pubblica | PubExtList | Restituisce la lista delle estensioni per le quali associare i documenti come pubblicazione. Aggiungere a questa collezione le estensioni (senza punto) per le quali usare questo tipo di associazione nel caso di associazione file primario. Di default viene inizializzata con dwf, pdf e tif.
Proprietà pubblica | RapExtList | Restituisce la lista delle estensioni per le quali è consentito creare una nuova rappresentazione. Aggiungere a questa collezione le estensioni (senza punto) per le quali si desidera dare questa possibilità. Di default viene inizializzata con dwg, iam ed ipt.
Proprietà pubblica | RegistryBaseDir | Restituisce la radice delle impostazioni di registro del Ded omettendo il nome della chiave principale che è da considerarsi di default HKEY_CURRENT_USER.
Proprietà pubblica | RegistryDocAssocOnOpen | Restituisce la chiave di registro contenente i dati dei documenti in apertura. Omette il nome della chiave principale che è da considerarsi di default HKEY_CURRENT_USER.
Proprietà pubblica | RegistryRootDir | Restituisce la radice delle impostazioni di registro omettendo il nome della chiave principale che è da considerarsi di default HKEY_CURRENT_USER.
Proprietà pubblica | Root | Restituisce l'oggetto DedType radice dell'albero delle famiglie di archiviazione.
Proprietà pubblica | RootComm | Restituisce l'oggetto DedCommType radice dell'albero delle commesse di archiviazione.
Proprietà pubblica | SearchFilter | Dizionario contenente i vari filtri applicabili sul risultato ricerca.
Proprietà pubblica | SessionID | Identifica in modo univoco la sessione corrente.
Proprietà pubblica | ShowAttributeLabelsInUI | Indica se nascondere le traduzioni degli attributi (di default è False).
Proprietà pubblica | ShowListOnTyping | Indica se deve essere visualizzata la tendina con tutti i codici, mentre sto digitando, nel controllo custom DedFindCodeControl.
Proprietà pubblica | SkipCheckDbVersion | Indica se controllare o meno la versione del Database in avvio
Proprietà pubblica | SkipExtensionsLoading | Controlla se caricare o meno le estensioni dell'applicazione
Proprietà pubblica | SolidworksExtension | Estensioni di SolidWorks.
Proprietà pubblica | SparePartManualForm | Restituisce il diaogo utilizzato per la generazione del manuale ricambi.
Proprietà pubblica | SparePartsManualManager | Ritorna tutti i settaggi di stile che deve avere il manuale ricambi.
Proprietà pubblica | StateManager | Restituisce il Manager degli stati.
Proprietà pubblica | StrHiddenValue | Costante che identifica il valore da usare quando l'utente non ha i pemessi
Proprietà pubblica | TablesAttrAnagr | Restituisce le tabelle interessate agli attributi di Anagrafica
Proprietà pubblica | TablesAttrAnagrComm | Restituisce le tabelle interessate agli attributi di AnagraficaDiCommessa
Proprietà pubblica | TablesAttrComm | Restituisce le tabelle interessate agli attributi di Commessa
Proprietà pubblica | TablesAttrDist | Restituisce le tabelle interessate agli attributi di Distinta
Proprietà pubblica | TablesAttrDoc | Restituisce le tabelle interessate agli attributi di Documento
Proprietà pubblica | TablesAttrEco | Restituisce le tabelle interessate agli attributi di Eco
Proprietà pubblica | TimeManager | Restituisce l'oggetto dedicato alla gestione dei tempi.
Proprietà pubblica | TransferManager | Restituisce il TransferManager per la gestione delle richieste.
Proprietà pubblica | TranslationManager | Restituisce il TranslationManager per la gestione delle traduzioni in lingua.
Proprietà pubblica | TypeManager | Restituisce il Manager delle Famiglie.
Proprietà pubblica | UseModalDialog | Indica se visualizzqare i dialoghi in modalità (Modal) usato in Bricscad.
Proprietà pubblica | User | Restituisce l'oggetto DedUser descrivente l'utente attualmente collegato al Database con i suoi permessi.
Proprietà pubblica | UseRevAsDiscrimInDist | Indica se considerare la revisione come discriminante nelle distinte.
Proprietà pubblica | UserPermManager | Restituisce il gestore dei permessi e degli utenti (per la modifica).
Proprietà pubblica | Util | Restituisce l'oggetto Assert.
Proprietà pubblica | Vars | Restituisce l'oggetto per la lettura delle variabili.
Proprietà pubblica | Versione | Restituisce la versione.
Torna su
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.AllCommands

Proprietà DedNetApplicationAllCommands
Restituisce la lista di tutti i comandi dell'applicazione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommandList AllCommands { get; }
Public ReadOnly Property AllCommands As DedCommandList
    Get
public:
property DedCommandList^ AllCommands {
    DedCommandList^ get ();
}
member AllCommands : DedCommandList with get

Valore della proprietà

DedCommandList
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.ApplicationCommands

Proprietà DedNetApplicationApplicationCommands
Restituisce la lista dei comandi Applicazione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommandList ApplicationCommands { get; }
Public ReadOnly Property ApplicationCommands As DedCommandList
    Get
public:
property DedCommandList^ ApplicationCommands {
    DedCommandList^ get ();
}
member ApplicationCommands : DedCommandList with get

Valore della proprietà

DedCommandList
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.AttManager

Proprietà DedNetApplicationAttManager
Restituisce il gestore delle liste collegate agli attributi.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttManager AttManager { get; }
Public ReadOnly Property AttManager As DedAttManager
    Get
public:
property DedAttManager^ AttManager {
    DedAttManager^ get ();
}
member AttManager : DedAttManager with get

Valore della proprietà

DedAttManager
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.AttributesEco

Proprietà DedNetApplicationAttributesEco
Restituisce la lista degli attributi ECO.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrCollection AttributesEco { get; }
Public ReadOnly Property AttributesEco As DedAttrCollection
    Get
public:
property DedAttrCollection^ AttributesEco {
    DedAttrCollection^ get ();
}
member AttributesEco : DedAttrCollection with get

Valore della proprietà

DedAttrCollection
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.AttributesOcc

Proprietà DedNetApplicationAttributesOcc
Restituisce la lista degli attributi di occorrenza.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrCollection AttributesOcc { get; }
Public ReadOnly Property AttributesOcc As DedAttrCollection
    Get
public:
property DedAttrCollection^ AttributesOcc {
    DedAttrCollection^ get ();
}
member AttributesOcc : DedAttrCollection with get

Valore della proprietà

DedAttrCollection
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.AutocadExtension

Proprietà DedNetApplicationAutocadExtension
Estensioni di Autocad.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> AutocadExtension { get; }
Public ReadOnly Property AutocadExtension As List(Of String)
    Get
public:
property List<String^>^ AutocadExtension {
    List<String^>^ get ();
}
member AutocadExtension : List<string> with get

Valore della proprietà

List String
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.AutoCompleteOnTyping

Proprietà DedNetApplicationAutoCompleteOnTyping
Indica se deve essere abilitato l'autocompletamento, mentre sto digitando, nel controllo custom DedFindCodeControl.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AutoCompleteOnTyping { get; set; }
Public Property AutoCompleteOnTyping As Boolean
    Get
    Set
public:
property bool AutoCompleteOnTyping {
    bool get ();
    void set (bool value);
}
member AutoCompleteOnTyping : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.BomEditFormCommandList

Proprietà DedNetApplicationBomEditFormCommandList
Lista dei comandi del form dell'editor delle distinte ( bars ).

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedBomEditFormCommandList BomEditFormCommandList { get; }
Public ReadOnly Property BomEditFormCommandList As DedBomEditFormCommandList
    Get
public:
property DedBomEditFormCommandList^ BomEditFormCommandList {
    DedBomEditFormCommandList^ get ();
}
member BomEditFormCommandList : DedBomEditFormCommandList with get

Valore della proprietà

DedBomEditFormCommandList
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.BomExplorerCtrlCommandList

Proprietà DedNetApplicationBomExplorerCtrlCommandList
Lista dei comandi dei controlli explorer dell'editor delle distinte ( toolbars ).

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedBomExplorerCtrlCommandList BomExplorerCtrlCommandList { get; }
Public ReadOnly Property BomExplorerCtrlCommandList As DedBomExplorerCtrlCommandList
    Get
public:
property DedBomExplorerCtrlCommandList^ BomExplorerCtrlCommandList {
    DedBomExplorerCtrlCommandList^ get ();
}
member BomExplorerCtrlCommandList : DedBomExplorerCtrlCommandList with get

Valore della proprietà

DedBomExplorerCtrlCommandList
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.BomManualSettings

Proprietà DedNetApplicationBomManualSettings
Ritorna le configurazioni per la visualizzazione delle colonne nei form relativi alle distinte

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomManualSettings BomManualSettings { get; }
Public ReadOnly Property BomManualSettings As BomManualSettings
    Get
public:
property BomManualSettings^ BomManualSettings {
    BomManualSettings^ get ();
}
member BomManualSettings : BomManualSettings with get

Valore della proprietà

BomManualSettings
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.CascadeAutocomplete

Proprietà DedNetApplicationCascadeAutocomplete
Indica se autocompilare la tendina di un attributo associato a una cascata nel caso in cui la tendina contenga un solo valore.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CascadeAutocomplete { get; set; }
Public Property CascadeAutocomplete As Boolean
    Get
    Set
public:
property bool CascadeAutocomplete {
    bool get ();
    void set (bool value);
}
member CascadeAutocomplete : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.CascadeManager

Proprietà DedNetApplicationCascadeManager
Restituisce il gestore delle cascate.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCascadeManager CascadeManager { get; }
Public ReadOnly Property CascadeManager As DedCascadeManager
    Get
public:
property DedCascadeManager^ CascadeManager {
    DedCascadeManager^ get ();
}
member CascadeManager : DedCascadeManager with get

Valore della proprietà

DedCascadeManager
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.CategManager

Proprietà DedNetApplicationCategManager
Restituisce il gestore delle categorie.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCategManager CategManager { get; }
Public ReadOnly Property CategManager As DedCategManager
    Get
public:
property DedCategManager^ CategManager {
    DedCategManager^ get ();
}
member CategManager : DedCategManager with get

Valore della proprietà

DedCategManager
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.CheckFunctions

Proprietà DedNetApplicationCheckFunctions
Restituisce la lista delle funzioni di controllo usate negli attributi.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> CheckFunctions { get; }
Public ReadOnly Property CheckFunctions As List(Of String)
    Get
public:
property List<String^>^ CheckFunctions {
    List<String^>^ get ();
}
member CheckFunctions : List<string> with get

Valore della proprietà

List String
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.ClassList

Proprietà DedNetApplicationClassList
Restituisce la lista di classList usate negli attributi.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> ClassList { get; }
Public ReadOnly Property ClassList As List(Of String)
    Get
public:
property List<String^>^ ClassList {
    List<String^>^ get ();
}
member ClassList : List<string> with get

Valore della proprietà

List String
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.ClientCommands

Proprietà DedNetApplicationClientCommands
Restituisce la lista dei comandi Client.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommandList ClientCommands { get; }
Public ReadOnly Property ClientCommands As DedCommandList
    Get
public:
property DedCommandList^ ClientCommands {
    DedCommandList^ get ();
}
member ClientCommands : DedCommandList with get

Valore della proprietà

DedCommandList
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.ClientConnected

Proprietà DedNetApplicationClientConnected
Restituisce o imposta la tipologia di client connesso.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ClientApplicationEnum ClientConnected { get; set; }
Public Property ClientConnected As ClientApplicationEnum
    Get
    Set
public:
property ClientApplicationEnum ClientConnected {
    ClientApplicationEnum get ();
    void set (ClientApplicationEnum value);
}
member ClientConnected : ClientApplicationEnum with get, set

Valore della proprietà

ClientApplicationEnum
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.ClientConnectedIgnoreTemporary

Proprietà DedNetApplicationClientConnectedIgnoreTemporary
Client connesso reale e non forzato

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ClientApplicationEnum ClientConnectedIgnoreTemporary { get; }
Public ReadOnly Property ClientConnectedIgnoreTemporary As ClientApplicationEnum
    Get
public:
property ClientApplicationEnum ClientConnectedIgnoreTemporary {
    ClientApplicationEnum get ();
}
member ClientConnectedIgnoreTemporary : ClientApplicationEnum with get

Valore della proprietà

ClientApplicationEnum
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.CloseWindowOnLoad

Proprietà DedNetApplicationCloseWindowOnLoad
Indica se chiudere la finestra dopo i comndi di caricamento componenti.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CloseWindowOnLoad { get; set; }
Public Property CloseWindowOnLoad As Boolean
    Get
    Set
public:
property bool CloseWindowOnLoad {
    bool get ();
    void set (bool value);
}
member CloseWindowOnLoad : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.CloseWindowOnOpening

Proprietà DedNetApplicationCloseWindowOnOpening
Indica se chiudere la finestra dopo che il documento è stato aperto.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CloseWindowOnOpening { get; set; }
Public Property CloseWindowOnOpening As Boolean
    Get
    Set
public:
property bool CloseWindowOnOpening {
    bool get ();
    void set (bool value);
}
member CloseWindowOnOpening : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.Connection

Proprietà DedNetApplicationConnection
Restituisce l'oggetto QSConnection correntemente utilizzato dall'applicazione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QSConnection Connection { get; }
Public ReadOnly Property Connection As QSConnection
    Get
public:
virtual property QSConnection^ Connection {
    QSConnection^ get () sealed;
}
abstract Connection : QSConnection with get
override Connection : QSConnection with get

Valore della proprietà

QSConnection

Implementa

IDedNetApplicationConnection
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.ConnectionString

Proprietà DedNetApplicationConnectionString
Imposta o restituisce la stringa di connesione al Database.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string ConnectionString { get; set; }
Public Property ConnectionString As String
    Get
    Set
public:
virtual property String^ ConnectionString {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract ConnectionString : string with get, set
override ConnectionString : string with get, set

Valore della proprietà

String

Implementa

IDedNetApplicationConnectionString
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.ContextManager

Proprietà DedNetApplicationContextManager
Restituisce il Manager di Contesto Documento.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocContextManager ContextManager { get; }
Public ReadOnly Property ContextManager As DedDocContextManager
    Get
public:
property DedDocContextManager^ ContextManager {
    DedDocContextManager^ get ();
}
member ContextManager : DedDocContextManager with get

Valore della proprietà

DedDocContextManager
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.Corporates

Proprietà DedNetApplicationCorporates
Restitusice la lista delle corporate disponibili

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCorporates Corporates { get; }
Public ReadOnly Property Corporates As DedCorporates
    Get
public:
property DedCorporates^ Corporates {
    DedCorporates^ get ();
}
member Corporates : DedCorporates with get

Valore della proprietà

DedCorporates
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.CurrentComm

Proprietà DedNetApplicationCurrentComm
Legge o imposta la commessa corrente

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedComm CurrentComm { get; set; }
Public Property CurrentComm As DedComm
    Get
    Set
public:
property DedComm^ CurrentComm {
    DedComm^ get ();
    void set (DedComm^ value);
}
member CurrentComm : DedComm with get, set

Valore della proprietà

DedComm
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.CustomCommands

Proprietà DedNetApplicationCustomCommands
Restituisce la lista dei comandi personalizzati.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommandList CustomCommands { get; }
Public ReadOnly Property CustomCommands As DedCommandList
    Get
public:
property DedCommandList^ CustomCommands {
    DedCommandList^ get ();
}
member CustomCommands : DedCommandList with get

Valore della proprietà

DedCommandList
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.CustomTranslations

Proprietà DedNetApplicationCustomTranslations
Restituisce la lista delle traduzioni custom aziendali.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTranslationCollection CustomTranslations { get; }
Public ReadOnly Property CustomTranslations As DedTranslationCollection
    Get
public:
property DedTranslationCollection^ CustomTranslations {
    DedTranslationCollection^ get ();
}
member CustomTranslations : DedTranslationCollection with get

Valore della proprietà

DedTranslationCollection
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.DataManager

Proprietà DedNetApplicationDataManager
Restituisce il Manager delle Anagrafiche.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataManager DataManager { get; }
Public ReadOnly Property DataManager As DedDataManager
    Get
public:
property DedDataManager^ DataManager {
    DedDataManager^ get ();
}
member DataManager : DedDataManager with get

Valore della proprietà

DedDataManager
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.DedManagerConnectionString

Proprietà DedNetApplicationDedManagerConnectionString
Imposta o restituisce la stringa di connesione del QsManager al Database.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string DedManagerConnectionString { get; set; }
Public Property DedManagerConnectionString As String
    Get
    Set
public:
property String^ DedManagerConnectionString {
    String^ get ();
    void set (String^ value);
}
member DedManagerConnectionString : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.DedManagerProviderName

Proprietà DedNetApplicationDedManagerProviderName
Imposta o restituisce il nome completo della classe del provider di collegamento del QsManager al Database.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string DedManagerProviderName { get; set; }
Public Property DedManagerProviderName As String
    Get
    Set
public:
property String^ DedManagerProviderName {
    String^ get ();
    void set (String^ value);
}
member DedManagerProviderName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.DefaultAnagrCommand

Proprietà DedNetApplicationDefaultAnagrCommand
Comando di default da lanciare sul doppio click nelle anagrafiche.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommand DefaultAnagrCommand { get; set; }
Public Property DefaultAnagrCommand As DedCommand
    Get
    Set
public:
property DedCommand^ DefaultAnagrCommand {
    DedCommand^ get ();
    void set (DedCommand^ value);
}
member DefaultAnagrCommand : DedCommand with get, set

Valore della proprietà

DedCommand
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.DefaultDocumentCommand

Proprietà DedNetApplicationDefaultDocumentCommand
Comando di default da lanciare sul doppio click neli documenti.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommand DefaultDocumentCommand { get; set; }
Public Property DefaultDocumentCommand As DedCommand
    Get
    Set
public:
property DedCommand^ DefaultDocumentCommand {
    DedCommand^ get ();
    void set (DedCommand^ value);
}
member DefaultDocumentCommand : DedCommand with get, set

Valore della proprietà

DedCommand
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.DocManager

Proprietà DedNetApplicationDocManager
Restituisce il Manager dei Documenti.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocManager DocManager { get; }
Public ReadOnly Property DocManager As DedDocManager
    Get
public:
property DedDocManager^ DocManager {
    DedDocManager^ get ();
}
member DocManager : DedDocManager with get

Valore della proprietà

DedDocManager
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.DocumentsWithInternalAttributes

Proprietà DedNetApplicationDocumentsWithInternalAttributes
Restituisce la lista delle estensioni dei file che se sono in checkout impediscono l'editazione degli attributi a livello di form ricerca e di comando.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> DocumentsWithInternalAttributes { get; }
Public ReadOnly Property DocumentsWithInternalAttributes As List(Of String)
    Get
public:
property List<String^>^ DocumentsWithInternalAttributes {
    List<String^>^ get ();
}
member DocumentsWithInternalAttributes : List<string> with get

Valore della proprietà

List String
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.DpiX

Proprietà DedNetApplicationDpiX
Ritorna la risoluzione orizontale attualmente impostata.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int DpiX { get; }
Public ReadOnly Property DpiX As Integer
    Get
public:
property int DpiX {
    int get ();
}
member DpiX : int with get

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.DpiY

Proprietà DedNetApplicationDpiY
Ritorna la risoluzione verticale attualmente impostata.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int DpiY { get; }
Public ReadOnly Property DpiY As Integer
    Get
public:
property int DpiY {
    int get ();
}
member DpiY : int with get

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.EcoManager

Proprietà DedNetApplicationEcoManager
Restituisce l' EcoManager degli Eco.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEcoManager EcoManager { get; }
Public ReadOnly Property EcoManager As DedEcoManager
    Get
public:
property DedEcoManager^ EcoManager {
    DedEcoManager^ get ();
}
member EcoManager : DedEcoManager with get

Valore della proprietà

DedEcoManager
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.ExecuteQueryOnEnter

Proprietà DedNetApplicationExecuteQueryOnEnter
Indica se il controllo custom DedFindCodeControl deve essere visualizzato con la combobox (True) o con il LookUpEdit (False).

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ExecuteQueryOnEnter { get; set; }
Public Property ExecuteQueryOnEnter As Boolean
    Get
    Set
public:
property bool ExecuteQueryOnEnter {
    bool get ();
    void set (bool value);
}
member ExecuteQueryOnEnter : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.Extensions

Proprietà DedNetApplicationExtensions
Ritorna la collection di addin caricati

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ReadOnlyCollection<IDedExtensions> Extensions { get; }
Public ReadOnly Property Extensions As ReadOnlyCollection(Of IDedExtensions)
    Get
public:
property ReadOnlyCollection<IDedExtensions^>^ Extensions {
    ReadOnlyCollection<IDedExtensions^>^ get ();
}
member Extensions : ReadOnlyCollection<IDedExtensions> with get

Valore della proprietà

ReadOnlyCollection IDedExtensions
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.FileServerManager

Proprietà DedNetApplicationFileServerManager
Restituisce l'oggetto che gestisce le informazioni sul client/server per la gestione dei file.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public FileServerManager FileServerManager { get; }
Public ReadOnly Property FileServerManager As FileServerManager
    Get
public:
property FileServerManager^ FileServerManager {
    FileServerManager^ get ();
}
member FileServerManager : FileServerManager with get

Valore della proprietà

FileServerManager
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.FormFindCodeQueryFields

Proprietà DedNetApplicationFormFindCodeQueryFields
Restituisce la lista dei campi nel combo di selezione campo query del form DedFormFindCode.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> FormFindCodeQueryFields { get; }
Public ReadOnly Property FormFindCodeQueryFields As List(Of String)
    Get
public:
property List<String^>^ FormFindCodeQueryFields {
    List<String^>^ get ();
}
member FormFindCodeQueryFields : List<string> with get

Valore della proprietà

List String
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.FormFindCodeResFields

Proprietà DedNetApplicationFormFindCodeResFields
Restituisce la lista dei campi da visualizzare nel combo di risultato ricerca del form DedFormFindCode.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> FormFindCodeResFields { get; }
Public ReadOnly Property FormFindCodeResFields As List(Of String)
    Get
public:
property List<String^>^ FormFindCodeResFields {
    List<String^>^ get ();
}
member FormFindCodeResFields : List<string> with get

Valore della proprietà

List String
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.GerenicDepExtension

Proprietà DedNetApplicationGerenicDepExtension
Estensioni delle dipendenze di tipo Generic.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> GerenicDepExtension { get; }
Public ReadOnly Property GerenicDepExtension As List(Of String)
    Get
public:
property List<String^>^ GerenicDepExtension {
    List<String^>^ get ();
}
member GerenicDepExtension : List<string> with get

Valore della proprietà

List String
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.HideAttributeTranslations

Proprietà DedNetApplicationHideAttributeTranslations
Indica se nascondere le traduzioni degli attributi (di default è False).

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HideAttributeTranslations { get; set; }
Public Property HideAttributeTranslations As Boolean
    Get
    Set
public:
property bool HideAttributeTranslations {
    bool get ();
    void set (bool value);
}
member HideAttributeTranslations : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.IgnoreExtension

Proprietà DedNetApplicationIgnoreExtension
Estensioni da ignorare.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> IgnoreExtension { get; }
Public ReadOnly Property IgnoreExtension As List(Of String)
    Get
public:
property List<String^>^ IgnoreExtension {
    List<String^>^ get ();
}
member IgnoreExtension : List<string> with get

Valore della proprietà

List String
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.Initialized

Proprietà DedNetApplicationInitialized
Restituisce se l'inizializzazione dell'oggetto è già avvenuta correttamente attraverso la chiamata al metodo Init() con esito positivo.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Initialized { get; }
Public ReadOnly Property Initialized As Boolean
    Get
public:
virtual property bool Initialized {
    bool get () sealed;
}
abstract Initialized : bool with get
override Initialized : bool with get

Valore della proprietà

Boolean

Implementa

IDedNetApplicationInitialized
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.InstallPath

Proprietà DedNetApplicationInstallPath
Restituisce il path di installazione del DedNet (della root senza la cartella bin).

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string InstallPath { get; }
Public ReadOnly Property InstallPath As String
    Get
public:
property String^ InstallPath {
    String^ get ();
}
member InstallPath : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.InventorExtension

Proprietà DedNetApplicationInventorExtension
Estensioni di Inventor.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> InventorExtension { get; }
Public ReadOnly Property InventorExtension As List(Of String)
    Get
public:
property List<String^>^ InventorExtension {
    List<String^>^ get ();
}
member InventorExtension : List<string> with get

Valore della proprietà

List String
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.IsDisposed

Proprietà DedNetApplicationIsDisposed
Restituisce true se è stato già fatto il Dispose dell'oggetto.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsDisposed { get; }
Public ReadOnly Property IsDisposed As Boolean
    Get
public:
virtual property bool IsDisposed {
    bool get () sealed;
}
abstract IsDisposed : bool with get
override IsDisposed : bool with get

Valore della proprietà

Boolean

Implementa

IDedNetApplicationIsDisposed
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.IsExportingCommand

Proprietà DedNetApplicationIsExportingCommand
Indica se il comando di esportazione è in esecuzione

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsExportingCommand { get; set; }
Public Property IsExportingCommand As Boolean
    Get
    Set
public:
property bool IsExportingCommand {
    bool get ();
    void set (bool value);
}
member IsExportingCommand : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.IsImporterRunning

Proprietà DedNetApplicationIsImporterRunning
Indica se l'importartatore è stato avviato ed è in corso l'operazione di importazione dati.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsImporterRunning { get; }
Public ReadOnly Property IsImporterRunning As Boolean
    Get
public:
property bool IsImporterRunning {
    bool get ();
}
member IsImporterRunning : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.IsLightInit

Proprietà DedNetApplicationIsLightInit
Restituisce se è stata fatta un'inizializzazione light.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsLightInit { get; }
Public ReadOnly Property IsLightInit As Boolean
    Get
public:
property bool IsLightInit {
    bool get ();
}
member IsLightInit : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.Language

Proprietà DedNetApplicationLanguage
Imposta o restituisce la lingua dell'applicazione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Language { get; set; }
Public Property Language As String
    Get
    Set
public:
property String^ Language {
    String^ get ();
    void set (String^ value);
}
member Language : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.LastError

Proprietà DedNetApplicationLastError
Restituisce l'ultimo errore che si è verificato utilizzando i metodi e le proprietà di questa interfaccia.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string LastError { get; }
Public ReadOnly Property LastError As String
    Get
public:
virtual property String^ LastError {
    String^ get () sealed;
}
abstract LastError : string with get
override LastError : string with get

Valore di ritorno

String
Restituisce la stringa di errore oppure "" se non ne sono avvenuti.

Implementa

IDedNetApplicationLastError
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.ListManager

Proprietà DedNetApplicationListManager
Restituisce l'oggetto dedicato alla gestione delle liste.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedListManager ListManager { get; }
Public ReadOnly Property ListManager As DedListManager
    Get
public:
property DedListManager^ ListManager {
    DedListManager^ get ();
}
member ListManager : DedListManager with get

Valore della proprietà

DedListManager
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.LoadCurrentCode

Proprietà DedNetApplicationLoadCurrentCode
Indica se, all'apertura dell'Apri Veloce, deve essere caricata l'anagrafica corrente (se presente).

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool LoadCurrentCode { get; set; }
Public Property LoadCurrentCode As Boolean
    Get
    Set
public:
property bool LoadCurrentCode {
    bool get ();
    void set (bool value);
}
member LoadCurrentCode : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.LogManager

Proprietà DedNetApplicationLogManager
Restituisce il log manager per la gestione del log nel DB

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedLogManager LogManager { get; }
Public ReadOnly Property LogManager As DedLogManager
    Get
public:
property DedLogManager^ LogManager {
    DedLogManager^ get ();
}
member LogManager : DedLogManager with get

Valore della proprietà

DedLogManager
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.LogVerbose

Proprietà DedNetApplicationLogVerbose
Indica se è attiva la modalità di debug che consente al logger di scrivere maggiori informazioni.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool LogVerbose { get; }
Public ReadOnly Property LogVerbose As Boolean
    Get
public:
property bool LogVerbose {
    bool get ();
}
member LogVerbose : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.MainWindow

Proprietà DedNetApplicationMainWindow
Restituisce o imposta la finestra principale dell'applicazione client da usare di default come parent di tutte le finestre mostrate (modali e non).

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public IWin32Window MainWindow { get; set; }
Public Property MainWindow As IWin32Window
    Get
    Set
public:
property IWin32Window^ MainWindow {
    IWin32Window^ get ();
    void set (IWin32Window^ value);
}
member MainWindow : IWin32Window with get, set

Valore della proprietà

IWin32Window
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.Notifier

Proprietà DedNetApplicationNotifier
Restituisce l'oggetto che gestisce le notifiche.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedNotifies Notifier { get; }
Public ReadOnly Property Notifier As DedNotifies
    Get
public:
property DedNotifies^ Notifier {
    DedNotifies^ get ();
}
member Notifier : DedNotifies with get

Valore della proprietà

DedNotifies
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.NumCharMemo

Proprietà DedNetApplicationNumCharMemo
Indica il numero dei caratteri oltre il quale usare memoEdit

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int NumCharMemo { get; set; }
Public Property NumCharMemo As Integer
    Get
    Set
public:
property int NumCharMemo {
    int get ();
    void set (int value);
}
member NumCharMemo : int with get, set

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.PathBomSetting

Proprietà DedNetApplicationPathBomSetting
Imposta o restituisce il percorso in cui cercare la configurazione da usare per la visualizzazione delle colonne nei form relativi alle distinte

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string PathBomSetting { get; set; }
Public Property PathBomSetting As String
    Get
    Set
public:
property String^ PathBomSetting {
    String^ get ();
    void set (String^ value);
}
member PathBomSetting : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.PathLoghi

Proprietà DedNetApplicationPathLoghi
Imposta o restituisce il percorso in cui cercare i loghi da usare per l'esportazione/stampa dei risultati.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string PathLoghi { get; set; }
Public Property PathLoghi As String
    Get
    Set
public:
property String^ PathLoghi {
    String^ get ();
    void set (String^ value);
}
member PathLoghi : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.PathRoots

Proprietà DedNetApplicationPathRoots
Restituisce l'oggetto che gestisce la lista delle radici di archiviazione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedRoots PathRoots { get; }
Public ReadOnly Property PathRoots As DedRoots
    Get
public:
property DedRoots^ PathRoots {
    DedRoots^ get ();
}
member PathRoots : DedRoots with get

Valore della proprietà

DedRoots
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.PathTemplate

Proprietà DedNetApplicationPathTemplate
Imposta o restituisce il percorso in cui cercare i template da usare per l'esportazione/stampa dei risultati.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string PathTemplate { get; set; }
Public Property PathTemplate As String
    Get
    Set
public:
property String^ PathTemplate {
    String^ get ();
    void set (String^ value);
}
member PathTemplate : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.PriorityExtList

Proprietà DedNetApplicationPriorityExtList
Restituisce la lista delle estensioni alla quale dare la priorità nella selezione dei documenti. Aggiungere a questa collezione le estensioni (senza punto) sulle quali si desidera dare la precedenza.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> PriorityExtList { get; }
Public ReadOnly Property PriorityExtList As List(Of String)
    Get
public:
property List<String^>^ PriorityExtList {
    List<String^>^ get ();
}
member PriorityExtList : List<string> with get

Valore della proprietà

List String
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.PriorityExtListOriginal

Proprietà DedNetApplicationPriorityExtListOriginal
Lista di appoggio contenente le estensioni originali

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> PriorityExtListOriginal { get; }
Public ReadOnly Property PriorityExtListOriginal As List(Of String)
    Get
public:
property List<String^>^ PriorityExtListOriginal {
    List<String^>^ get ();
}
member PriorityExtListOriginal : List<string> with get

Valore della proprietà

List String
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.ProviderName

Proprietà DedNetApplicationProviderName
Imposta o restituisce il nome completo della classe del provider di collegamento al Database.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string ProviderName { get; set; }
Public Property ProviderName As String
    Get
    Set
public:
virtual property String^ ProviderName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract ProviderName : string with get, set
override ProviderName : string with get, set

Valore della proprietà

String

Implementa

IDedNetApplicationProviderName
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.PubExtList

Proprietà DedNetApplicationPubExtList
Restituisce la lista delle estensioni per le quali associare i documenti come pubblicazione. Aggiungere a questa collezione le estensioni (senza punto) per le quali usare questo tipo di associazione nel caso di associazione file primario. Di default viene inizializzata con dwf, pdf e tif.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> PubExtList { get; }
Public ReadOnly Property PubExtList As List(Of String)
    Get
public:
property List<String^>^ PubExtList {
    List<String^>^ get ();
}
member PubExtList : List<string> with get

Valore della proprietà

List String
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.RapExtList

Proprietà DedNetApplicationRapExtList
Restituisce la lista delle estensioni per le quali è consentito creare una nuova rappresentazione. Aggiungere a questa collezione le estensioni (senza punto) per le quali si desidera dare questa possibilità. Di default viene inizializzata con dwg, iam ed ipt.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> RapExtList { get; }
Public ReadOnly Property RapExtList As List(Of String)
    Get
public:
property List<String^>^ RapExtList {
    List<String^>^ get ();
}
member RapExtList : List<string> with get

Valore della proprietà

List String
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.RegistryBaseDir

Proprietà DedNetApplicationRegistryBaseDir
Restituisce la radice delle impostazioni di registro del Ded omettendo il nome della chiave principale che è da considerarsi di default HKEY_CURRENT_USER.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string RegistryBaseDir { get; }
Public ReadOnly Property RegistryBaseDir As String
    Get
public:
property String^ RegistryBaseDir {
    String^ get ();
}
member RegistryBaseDir : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.RegistryDocAssocOnOpen

Proprietà DedNetApplicationRegistryDocAssocOnOpen
Restituisce la chiave di registro contenente i dati dei documenti in apertura. Omette il nome della chiave principale che è da considerarsi di default HKEY_CURRENT_USER.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string RegistryDocAssocOnOpen { get; }
Public ReadOnly Property RegistryDocAssocOnOpen As String
    Get
public:
property String^ RegistryDocAssocOnOpen {
    String^ get ();
}
member RegistryDocAssocOnOpen : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.RegistryRootDir

Proprietà DedNetApplicationRegistryRootDir
Restituisce la radice delle impostazioni di registro omettendo il nome della chiave principale che è da considerarsi di default HKEY_CURRENT_USER.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string RegistryRootDir { get; }
Public ReadOnly Property RegistryRootDir As String
    Get
public:
property String^ RegistryRootDir {
    String^ get ();
}
member RegistryRootDir : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.Root

Proprietà DedNetApplicationRoot
Restituisce l'oggetto DedType radice dell'albero delle famiglie di archiviazione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedType Root { get; }
Public ReadOnly Property Root As DedType
    Get
public:
property DedType^ Root {
    DedType^ get ();
}
member Root : DedType with get

Valore della proprietà

DedType
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.RootComm

Proprietà DedNetApplicationRootComm
Restituisce l'oggetto DedCommType radice dell'albero delle commesse di archiviazione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommType RootComm { get; }
Public ReadOnly Property RootComm As DedCommType
    Get
public:
property DedCommType^ RootComm {
    DedCommType^ get ();
}
member RootComm : DedCommType with get

Valore della proprietà

DedCommType
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.SearchFilter

Proprietà DedNetApplicationSearchFilter
Dizionario contenente i vari filtri applicabili sul risultato ricerca.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<string, string> SearchFilter { get; set; }
Public Property SearchFilter As Dictionary(Of String, String)
    Get
    Set
public:
property Dictionary<String^, String^>^ SearchFilter {
    Dictionary<String^, String^>^ get ();
    void set (Dictionary<String^, String^>^ value);
}
member SearchFilter : Dictionary<string, string> with get, set

Valore della proprietà

Dictionary String, String
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.SessionID

Proprietà DedNetApplicationSessionID
Identifica in modo univoco la sessione corrente.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Guid SessionID { get; }
Public ReadOnly Property SessionID As Guid
    Get
public:
property Guid SessionID {
    Guid get ();
}
member SessionID : Guid with get

Valore della proprietà

Guid
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.ShowAttributeLabelsInUI

Proprietà DedNetApplicationShowAttributeLabelsInUI
Indica se nascondere le traduzioni degli attributi (di default è False).

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ShowAttributeLabelsInUI { get; set; }
Public Property ShowAttributeLabelsInUI As Boolean
    Get
    Set
public:
property bool ShowAttributeLabelsInUI {
    bool get ();
    void set (bool value);
}
member ShowAttributeLabelsInUI : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.ShowListOnTyping

Proprietà DedNetApplicationShowListOnTyping
Indica se deve essere visualizzata la tendina con tutti i codici, mentre sto digitando, nel controllo custom DedFindCodeControl.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ShowListOnTyping { get; set; }
Public Property ShowListOnTyping As Boolean
    Get
    Set
public:
property bool ShowListOnTyping {
    bool get ();
    void set (bool value);
}
member ShowListOnTyping : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.SkipCheckDbVersion

Proprietà DedNetApplicationSkipCheckDbVersion
Indica se controllare o meno la versione del Database in avvio

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool SkipCheckDbVersion { get; set; }
Public Property SkipCheckDbVersion As Boolean
    Get
    Set
public:
property bool SkipCheckDbVersion {
    bool get ();
    void set (bool value);
}
member SkipCheckDbVersion : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.SkipExtensionsLoading

Proprietà DedNetApplicationSkipExtensionsLoading
Controlla se caricare o meno le estensioni dell'applicazione

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool SkipExtensionsLoading { get; set; }
Public Property SkipExtensionsLoading As Boolean
    Get
    Set
public:
property bool SkipExtensionsLoading {
    bool get ();
    void set (bool value);
}
member SkipExtensionsLoading : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.SolidworksExtension

Proprietà DedNetApplicationSolidworksExtension
Estensioni di SolidWorks.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> SolidworksExtension { get; }
Public ReadOnly Property SolidworksExtension As List(Of String)
    Get
public:
property List<String^>^ SolidworksExtension {
    List<String^>^ get ();
}
member SolidworksExtension : List<string> with get

Valore della proprietà

List String
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.SparePartManualForm

Proprietà DedNetApplicationSparePartManualForm
Restituisce il diaogo utilizzato per la generazione del manuale ricambi.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public SparePartsManualForm SparePartManualForm { get; }
Public ReadOnly Property SparePartManualForm As SparePartsManualForm
    Get
public:
property SparePartsManualForm^ SparePartManualForm {
    SparePartsManualForm^ get ();
}
member SparePartManualForm : SparePartsManualForm with get

Valore della proprietà

SparePartsManualForm
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.SparePartsManualManager

Proprietà DedNetApplicationSparePartsManualManager
Ritorna tutti i settaggi di stile che deve avere il manuale ricambi.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public SparePartsManualManager SparePartsManualManager { get; }
Public ReadOnly Property SparePartsManualManager As SparePartsManualManager
    Get
public:
property SparePartsManualManager^ SparePartsManualManager {
    SparePartsManualManager^ get ();
}
member SparePartsManualManager : SparePartsManualManager with get

Valore della proprietà

SparePartsManualManager
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.StateManager

Proprietà DedNetApplicationStateManager
Restituisce il Manager degli stati.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedStateManager StateManager { get; }
Public ReadOnly Property StateManager As DedStateManager
    Get
public:
property DedStateManager^ StateManager {
    DedStateManager^ get ();
}
member StateManager : DedStateManager with get

Valore della proprietà

DedStateManager
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.StrHiddenValue

Proprietà DedNetApplicationStrHiddenValue
Costante che identifica il valore da usare quando l'utente non ha i pemessi

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string StrHiddenValue { get; }
Public ReadOnly Property StrHiddenValue As String
    Get
public:
property String^ StrHiddenValue {
    String^ get ();
}
member StrHiddenValue : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.TablesAttrAnagr

Proprietà DedNetApplicationTablesAttrAnagr
Restituisce le tabelle interessate agli attributi di Anagrafica

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string TablesAttrAnagr { get; }
Public ReadOnly Property TablesAttrAnagr As String
    Get
public:
property String^ TablesAttrAnagr {
    String^ get ();
}
member TablesAttrAnagr : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.TablesAttrAnagrComm

Proprietà DedNetApplicationTablesAttrAnagrComm
Restituisce le tabelle interessate agli attributi di AnagraficaDiCommessa

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string TablesAttrAnagrComm { get; }
Public ReadOnly Property TablesAttrAnagrComm As String
    Get
public:
property String^ TablesAttrAnagrComm {
    String^ get ();
}
member TablesAttrAnagrComm : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.TablesAttrComm

Proprietà DedNetApplicationTablesAttrComm
Restituisce le tabelle interessate agli attributi di Commessa

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string TablesAttrComm { get; }
Public ReadOnly Property TablesAttrComm As String
    Get
public:
property String^ TablesAttrComm {
    String^ get ();
}
member TablesAttrComm : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.TablesAttrDist

Proprietà DedNetApplicationTablesAttrDist
Restituisce le tabelle interessate agli attributi di Distinta

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string TablesAttrDist { get; }
Public ReadOnly Property TablesAttrDist As String
    Get
public:
property String^ TablesAttrDist {
    String^ get ();
}
member TablesAttrDist : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.TablesAttrDoc

Proprietà DedNetApplicationTablesAttrDoc
Restituisce le tabelle interessate agli attributi di Documento

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string TablesAttrDoc { get; }
Public ReadOnly Property TablesAttrDoc As String
    Get
public:
property String^ TablesAttrDoc {
    String^ get ();
}
member TablesAttrDoc : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.TablesAttrEco

Proprietà DedNetApplicationTablesAttrEco
Restituisce le tabelle interessate agli attributi di Eco

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string TablesAttrEco { get; }
Public ReadOnly Property TablesAttrEco As String
    Get
public:
property String^ TablesAttrEco {
    String^ get ();
}
member TablesAttrEco : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.TimeManager

Proprietà DedNetApplicationTimeManager
Restituisce l'oggetto dedicato alla gestione dei tempi.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTimeManager TimeManager { get; }
Public ReadOnly Property TimeManager As DedTimeManager
    Get
public:
property DedTimeManager^ TimeManager {
    DedTimeManager^ get ();
}
member TimeManager : DedTimeManager with get

Valore della proprietà

DedTimeManager
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.TransferManager

Proprietà DedNetApplicationTransferManager
Restituisce il TransferManager per la gestione delle richieste.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTransferManager TransferManager { get; }
Public ReadOnly Property TransferManager As DedTransferManager
    Get
public:
property DedTransferManager^ TransferManager {
    DedTransferManager^ get ();
}
member TransferManager : DedTransferManager with get

Valore della proprietà

DedTransferManager
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.TranslationManager

Proprietà DedNetApplicationTranslationManager
Restituisce il TranslationManager per la gestione delle traduzioni in lingua.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTranslationManager TranslationManager { get; }
Public ReadOnly Property TranslationManager As DedTranslationManager
    Get
public:
property DedTranslationManager^ TranslationManager {
    DedTranslationManager^ get ();
}
member TranslationManager : DedTranslationManager with get

Valore della proprietà

DedTranslationManager
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.TypeManager

Proprietà DedNetApplicationTypeManager
Restituisce il Manager delle Famiglie.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeManager TypeManager { get; }
Public ReadOnly Property TypeManager As DedTypeManager
    Get
public:
property DedTypeManager^ TypeManager {
    DedTypeManager^ get ();
}
member TypeManager : DedTypeManager with get

Valore della proprietà

DedTypeManager
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.UseModalDialog

Proprietà DedNetApplicationUseModalDialog
Indica se visualizzqare i dialoghi in modalità (Modal) usato in Bricscad.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool UseModalDialog { get; set; }
Public Property UseModalDialog As Boolean
    Get
    Set
public:
property bool UseModalDialog {
    bool get ();
    void set (bool value);
}
member UseModalDialog : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.User

Proprietà DedNetApplicationUser
Restituisce l'oggetto DedUser descrivente l'utente attualmente collegato al Database con i suoi permessi.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public UsrUser User { get; set; }
Public Property User As UsrUser
    Get
    Set
public:
property UsrUser^ User {
    UsrUser^ get ();
    void set (UsrUser^ value);
}
member User : UsrUser with get, set

Valore della proprietà

UsrUser
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.UseRevAsDiscrimInDist

Proprietà DedNetApplicationUseRevAsDiscrimInDist
Indica se considerare la revisione come discriminante nelle distinte.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool UseRevAsDiscrimInDist { get; set; }
Public Property UseRevAsDiscrimInDist As Boolean
    Get
    Set
public:
property bool UseRevAsDiscrimInDist {
    bool get ();
    void set (bool value);
}
member UseRevAsDiscrimInDist : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.UserPermManager

Proprietà DedNetApplicationUserPermManager
Restituisce il gestore dei permessi e degli utenti (per la modifica).

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public UserPermManager UserPermManager { get; }
Public ReadOnly Property UserPermManager As UserPermManager
    Get
public:
property UserPermManager^ UserPermManager {
    UserPermManager^ get ();
}
member UserPermManager : UserPermManager with get

Valore della proprietà

UserPermManager
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.Util

Proprietà DedNetApplicationUtil
Restituisce l'oggetto Assert.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Assert Util { get; }
Public ReadOnly Property Util As Assert
    Get
public:
property Assert^ Util {
    Assert^ get ();
}
member Util : Assert with get

Valore della proprietà

Assert
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.Vars

Proprietà DedNetApplicationVars
Restituisce l'oggetto per la lettura delle variabili.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedVars Vars { get; }
Public ReadOnly Property Vars As DedVars
    Get
public:
property DedVars^ Vars {
    DedVars^ get ();
}
member Vars : DedVars with get

Valore della proprietà

DedVars
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Proprietà DedNetApplication.Versione

Proprietà DedNetApplicationVersione
Restituisce la versione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Versione { get; }
Public ReadOnly Property Versione As String
    Get
public:
property String^ Versione {
    String^ get ();
}
member Versione : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodi di DedNetApplication

Il tipo DedNetApplication espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AskByFindComm | Richiede la selezione di una commessa tramite interfaccia di selezione
Metodo pubblico | AskByFindCommDoc | Richiede la selezione di una commessa tramite interfaccia di selezione
Metodo pubblico | AskByFindCommPath | Richiede la selezione di un percorso tramite interfaccia di selezione commesse
Metodo pubblico | AskByFindDocs(String, Boolean, DedDocList) | Visualizza la finestra di ricerca documentale in modalità Modale per chiedere all'utente la selezione di uno o più documenti. Se restituisce Abort l'errore avvenuto è reperibile attraverso la proprietà LastError.
Metodo pubblico | AskByFindDocs(String, Boolean, DedDocList, DedDocList) | Visualizza la finestra di ricerca documentale in modalità Modale per chiedere all'utente la selezione di uno o più documenti. Se restituisce Abort l'errore avvenuto è reperibile attraverso la proprietà LastError.
Metodo pubblico | AskByFindDocs(String, Boolean, ListString, DedDocList) | Visualizza la finestra di ricerca documentale in modalità Modale per chiedere all'utente la selezione di uno o più documenti. Se restituisce Abort l'errore avvenuto è reperibile attraverso la proprietà LastError.
Metodo pubblico | AskByFindDocs(String, Boolean, DedDocList, DedDocList, ListString) | Visualizza la finestra di ricerca documentale in modalità Modale per chiedere all'utente la selezione di uno o più documenti. Se restituisce Abort l'errore avvenuto è reperibile attraverso la proprietà LastError.
Metodo pubblico | AskByFindRoot | Visualizza la finestra di ricerca documentale in modalità Modale per chiedere all'utente la selezione di una root. Se restituisce Abort l'errore avvenuto è reperibile attraverso la proprietà LastError.
Metodo pubblico | AskByMainForm(String, DedChooseElement, Boolean, DedFormMainSelectInfo) | Visualizza la finestra principale in modalità Modale per chiedere all'utente la selezione di una o più anagrafiche. Se restituisce Abort l'errore avvenuto è reperibile attraverso la proprietà LastError.
Metodo pubblico | AskByMainForm(String, DedChooseElement, Boolean, Boolean, DedFormMainSelectInfo) | Visualizza la finestra principale in modalità Modale per chiedere all'utente la selezione di una o più anagrafiche. Se restituisce Abort l'errore avvenuto è reperibile attraverso la proprietà LastError.
Metodo pubblico | AskByMainForm(String, DedChooseElement, Boolean, Boolean, Boolean, DedFormMainSelectInfo) | Visualizza la finestra principale in modalità Modale per chiedere all'utente la selezione di una o più anagrafiche. Se restituisce Abort l'errore avvenuto è reperibile attraverso la proprietà LastError.
Metodo pubblico | AskByMainForm(String, DedChooseElement, Boolean, Boolean, Boolean, DedType, DedFormMainSelectInfo) | Visualizza la finestra principale in modalità Modale per chiedere all'utente la selezione di una o più anagrafiche. Se restituisce Abort l'errore avvenuto è reperibile attraverso la proprietà LastError.
Metodo pubblico | AskByMainForm(String, DedDataList, DedChooseElement, Boolean, Boolean, Boolean, DedType, DedFormMainSelectInfo) | Visualizza la finestra principale in modalità Modale per chiedere all'utente la selezione di una o più anagrafiche. Se restituisce Abort l'errore avvenuto è reperibile attraverso la proprietà LastError.
Metodo pubblico | AskByMainForm(String, DedDataList, DedChooseElement, Boolean, Boolean, Boolean, DedType, ListString, DedFormMainSelectInfo) | Visualizza la finestra principale in modalità Modale, con la visualizzazione di una lista di anagrafiche definite, per chiedere all'utente la selezione di uno o più documenti. Se restituisce Abort l'errore avvenuto è reperibile attraverso la proprietà LastError.
Metodo pubblico | AskDedTypeByMainForm | Visualizza la finestra principale in modalità Modale per chiedere all'utente la selezione di una famiglia. Se restituisce Abort l'errore avvenuto è reperibile attraverso la proprietà LastError.
Metodo pubblico | BeginFileTransaction | Restituisce la transazione di file in atto oppure ne crea una nuova e la restituisce. QUESTO METODO È SEMPRE DA UTILIZZARE INSIEME A EndFileTransaction().
Metodo pubblico | ChangeContext | Cambia il contesto di associazione tra anagrafica e documento. Permette solo il cambio da Modello a Pubblicazione o viceversa.
Metodo pubblico | ChangeDependencyDocument | Aggiorna la dipendenza fisica di uno specifico documento padre aggiornandola al nuovo documento. Se attiva l'area locale, l'aggiornamento deve avvenire sia nel file presente nel vault che nella pws.
Metodo pubblico | CheckPwsLastCleaning | Controlla l'ultima pulizia dell'area locale e nel caso mostra un avvertimento
Metodo pubblico | ClearForcedAuthentication | Cancella le credenziali per l'accesso automatico senza autenticazione.
Metodo pubblico | Close | Chiude l'oggetto liberando le risorse.
Metodo pubblico | CommMatchFilter | Restituisce true se la commessa soddisfa i criteri di ricerca impostati
Metodo pubblico | CompileProgDedDataEncode | Compila il campo prog dentro DedDataEncode
Metodo pubblico | CreateAddCommCommand | Crea un nuovo comando per la creazione di una commessa.
Metodo pubblico | CreateAddEcoCommand | Crea un nuovo comando per la creazione di un ECO.
Metodo pubblico | CreateAddRecurrentTimingCommand | Crea un nuovo comando AddRecurrentTimingCommand.
Metodo pubblico | CreateAddSubCommCommand | Crea un nuovo comando per la creazione di una sotto commessa.
Metodo pubblico | CreateAnagrAssocCommCommand | Crea un nuovo comando AnagrAssocComm che permette di associare delle anagrafiche ad una commessa.
Metodo pubblico | CreateAnagrForm | Crea e restituisce la finestra di visualizzazione/editazione degli attributi di un'anagrafica.
Metodo pubblico | CreateAnagrHistoryCommand | Crea un nuovo comando AnagrHistory che mostra all'utente la storia dell'anagrafica.
Metodo pubblico | CreateAnnullaCheckOutCommand | Crea un nuovo comando Annulla CheckOut. Ripristina il documento al momento in cui è stato scaricato dal vault.
Metodo pubblico | CreateAssignEcoToSpecificUserCommand | Crea un nuovo comando di assegna ECO.
Metodo pubblico | CreateAssociateAlternativeCodeCommand | Crea un nuovo comando che chiede all'utente di associare all'anagrafice dei codici alternativi.
Metodo pubblico | CreateAssociateDocForm | Crea e restituisce la finestra di scelta delle opzioni di associazione documento.
Metodo pubblico | CreateAssociateDocumentCommand | Crea un nuovo comando AssociateDocument che permette di associare/importare un documento/file ad un'anagrafica.
Metodo pubblico | CreateBomEditCommand | Crea un nuovo comando DedBomEdit che mostra all'utente il form di editazione delle distinte.
Metodo pubblico | CreateBomEditOpenReadCommand | Crea un nuovo comando DedBomEdit che mostra all'utente il form di editazione delle distinte. Viene inizializzato il pannello di consultazione con l'anagrafica selezionata
Metodo pubblico | CreateBomHistoryCommand | Crea un nuovo comando DedBomHistory che mostra all'utente il form dello storico delle distinte.
Metodo pubblico | CreateBomHistoryForm | Crea e restituisce la finestra di visualizzazione storico distinta.
Metodo pubblico | CreateBomWhereUsedCommand | Crea un nuovo comando BomWhereUsedCommand.
Metodo pubblico | CreateChangeEcoStateToAssignedCommand | Crea un nuovo comando di cambia stato ECO. Imposta lo stato come 'Assegnato'.
Metodo pubblico | CreateChangeEcoStateToClosedCommand | Crea un nuovo comando di cambia stato ECO. Imposta lo stato come 'Chiuso'.
Metodo pubblico | CreateChangeEcoStateToOpenCommand | Crea un nuovo comando di cambia stato ECO. Imposta lo stato come 'Aperto'.
Metodo pubblico | CreateChangePwdCommand | Crea un nuovo comando Cambio Password.
Metodo pubblico | CreateChangeRepresentationSuffixCommand | Crea un nuovo comando ChangeRepresentationSuffixCommand. E' disponibile solo su documenti in contesto rappresentazione.
Metodo pubblico | CreateChangeStateForm | Crea e restituisce la finestra di cambio stato.
Metodo pubblico | CreateChargeCommCommand | Crea un nuovo comando per la presa in carico di una commessa.
Metodo pubblico | CreateCheckInDocumentCommand | Crea un nuovo comando di Check-In. Effettua la pubblicazione del documento e poi lo mette in Check-In.
Metodo pubblico | CreateCheckInStrutturaDocumentCommand | Crea un nuovo comando di Check-In. Effettua la pubblicazione del documento e poi lo mette in Check-In.
Metodo pubblico | CreateCheckOutCommand | Crea un nuovo comando CheckOut. Scarica dal vault il documento, lo copia in locale e lo imposta in CheckOut.
Metodo pubblico | CreateCheckOutStrutturaCommand | Crea un nuovo comando CheckOut. Scarica dal vault il documento, lo copia in locale e lo imposta in CheckOut.
Metodo pubblico | CreateChmHelpCommand | Crea un nuovo comando Help.
Metodo pubblico | CreateChoseFileForm | Crea e restituisce la finestra di selezione del tipo di file.
Metodo pubblico | CreateCloseCommCommand | Crea un nuovo comando per l'eliminazione di una commessa.
Metodo pubblico | CreateComm | Crea e restituisce un nuova commessa avente il nome specificato. Imposta già la data attuale e l'utente di creazione.
Metodo pubblico | CreateCommAnagrViewCommand | Crea un nuovo comando DedCommEdit che mostra all'utente il form di editazione delle commesse.
Metodo pubblico | CreateCommEditCommand | Crea un nuovo comando DedCommEdit che mostra all'utente il form di editazione delle commesse.
Metodo pubblico | CreateCommEsplCommand | Crea un nuovo comando per la visualizzazione della distinta esplosa di una commessa.
Metodo pubblico | CreateCommViewCommand | Crea un nuovo comando DedCommEdit che mostra all'utente il form di editazione delle commesse.
Metodo pubblico | CreateCopyDocumentCommand | Crea un nuovo comando MoveDocument per rinominare/spostare i documenti. E' disponibile solo negli allegati.
Metodo pubblico | CreateCreateEditSparePartsAttributesCommand | Crea un nuovo comando CreateSparePartsDrawingCommand.
Metodo pubblico | CreateCreateEditSparePartsAttributesCommand(CommandContextEnum) | Crea un nuovo comando CreateSparePartsDrawingCommand.
Metodo pubblico | CreateCreateFolderCommand | Crea un nuovo comando Crea cartella. Crea una cartella.
Metodo pubblico | CreateCreateManualCommand | Crea un nuovo comando 'CreateSparePartsManualCommand'.
Metodo pubblico | CreateCreateSparePartsDrawingCommand | Crea un nuovo comando CreateSparePartsDrawingCommand.
Metodo pubblico | CreateDataStatisticsAnalyzer | Crea un nuovo comando FindInRicercaCommand che permette di aprire la ricerca con selezionata l'anagrafica associata all'anagrafica o al documento selezionato.
Metodo pubblico | CreateDbDocCompareCommand | Crea un nuovo comando DbDocCompareCommand che mostra le differenze tra due anagrafiche.
Metodo pubblico | CreateDbDocCompareForm | Creazione del form di comparazione anagrafiche.
Metodo pubblico | CreateDbVersionCommand | Crea un nuovo comando DbVersionCommand. Permesso minimo di READ in modo che venga visualizzato anche se l'utente non lo può eseguire, utile nel caso in cui venga usato il comando login con un altro utente.
Metodo pubblico | CreateDedAboutCommand | Crea un nuovo comando Help.
Metodo pubblico | CreateDedListEditCommand | Crea un nuovo comando di InsertDocumentToPrint
Metodo pubblico | CreateDedListManagerCommand | Crea un nuovo comando GEstore Liste.
Metodo pubblico | CreateDedRuleApplier | Crea e restituisce un oggetto che si occupa di applicare le regole di auto-composizione su di una parte cioè un oggetto che implementa IDedData.
Metodo pubblico | CreateDefFileNameForm | Creazione del form definizione dei nomi file.
Metodo pubblico | CreateDeleteAnagrCommCommand | Crea un nuovo comando per l'eliminazione di anagrafiche di commessa.
Metodo pubblico | CreateDeleteCommCommand | Crea un nuovo comando per l'eliminazione di una commessa.
Metodo pubblico | CreateDeleteDataCommand | Crea un nuovo comando che chiede all'utente se vuole eliminare l'anagrafica.
Metodo pubblico | CreateDeleteEcoCommand | Crea un nuovo comando di eliminazione Eco dal database.
Metodo pubblico | CreateDeleteFolderCommand | Crea un nuovo comando Elimina cartella. Elimina una cartella e tutti i suoi documenti.
Metodo pubblico | CreateDisconnectCommDocumentCommand | Crea un nuovo comando DisconnectCommDocument. E' disponibile ovunque ci siano le anagrafiche ed anche siano visualizzati i documenti relativi.
Metodo pubblico | CreateDisconnectDocumentCommand | Crea un nuovo comando DisconnectDocument. E' disponibile ovunque ci siano le anagrafiche ed anche siano visualizzati i documenti relativi.
Metodo pubblico | CreateDistEsplCommand | Crea un nuovo comando DistEspl.
Metodo pubblico | CreateDistForm | Crea e restituisce la finestra di visualizzazione distinta esplosa ed implosa.
Metodo pubblico | CreateDistImplCommand | Crea un nuovo comando DistImpl.
Metodo pubblico | CreateDistManager | Crea e restituisce un nuovo oggetto DistManager che si occupa della gestione della distinta.
Metodo pubblico | CreateDistViewCommand | Crea un nuovo comando BomEditCommand che mostra all'utente il form di editazione delle distente in modalità visualizzazione.
Metodo pubblico | CreateDocAssocCommand | Crea un nuovo comando DocAssocCommand.
Metodo pubblico | CreateDocHistoryCommand | Crea un nuovo comando AnagrHistory che mostra all'utente la storia dell'anagrafica.
Metodo pubblico | CreateDocRecognizerCommand | Crea nuovo comando DocRecognizerCommand
Metodo pubblico | CreateDocSearchForm | Crea e restituisce la finestra di ricerca documentale.
Metodo pubblico | CreateDocTransferHistoryCommand | Crea un nuovo comando DocTransferHistoryCommand che mostra all'utente la storia dei trasferimenti del documento.
Metodo pubblico | CreateDocumentCommand | Crea e restituisce il comando che permette di creare un documento dato il nome completo di un file. Aggiunge nel Database anche tutti i documenti da esso dipendenti.
Metodo pubblico | CreateDuplicaRecordCommand | Crea un nuovo comando SaveCommand dedicato alla duplicazione dell'anagrafica.
Metodo pubblico | CreateDuplicateCommCommand | Crea un nuovo comando per la duplicazione di una commessa.
Metodo pubblico | CreateEcoEditCommand | Crea un nuovo comando per la visualizzazione degli Eco.
Metodo pubblico | CreateEcoHistoryCommand | Crea un nuovo comando EcoHistory che mostra all'utente la storia dell'eco.
Metodo pubblico | CreateEditAnagrCommand | Crea un nuovo comando EditAnagr.
Metodo pubblico | CreateEditCommCommand | Crea un nuovo comando per l'eliminazione di una commessa.
Metodo pubblico | CreateEditCommForm | Crea e restituisce la finestra per creare o modificare una commessa.
Metodo pubblico | CreateEditEcoCommand | Crea un nuovo comando per la creazione di un ECO.
Metodo pubblico | CreateEditOnlyDbAttributesCommand | Crea un nuovo comando di editazione attributi solo db con context none
Metodo pubblico | CreateEditOnlyDbAttributesCommand(CommandContextEnum) | Crea un nuovo comando CreateSparePartsDrawingCommand.
Metodo pubblico | CreateEndAllActiveTimingsCommand | Crea un nuovo comando EndAllTimingsCommand.
Metodo pubblico | CreateEndTimingCommand | Crea un nuovo comando EndTimingCommand.
Metodo pubblico | CreateEnsureLocalDocumentCommand | Crea e restituisce il sotto-comando che si occupa della copia in locale del documento e delle sue dipendenze.
Metodo pubblico | CreateEnsureLocalFolderCommand | Crea un nuovo comando di EnsureLocalFolder.
Metodo pubblico | CreateEnsureLocalFolderStructureCommand | Crea un nuovo comando di EnsureLocalFolder.
Metodo pubblico | CreateExportCommand | Crea un nuovo comando ExportCommand.
Metodo pubblico | CreateExportDocumentCommand | Crea un nuovo comando di Esportazione documento. Effettua la copia del documento in una destinazione libera e se necessario lo pone in checkout.
Metodo pubblico | CreateFileZipCommand | Crea un nuovo comando FileZip che chiede all'utente dove vuole archiviare i documenti selezionati.
Metodo pubblico | CreateFileZipStructCommand | Crea un nuovo comando FileZipStruct che chiede all'utente dove vuole archiviare i documenti selezionati.
Metodo pubblico | CreateFillDedDataEncodeTableCommand | Crea un nuovo comando per ricercare i documenti.
Metodo pubblico | CreateFindCodeCommand | Crea un nuovo comando FindCode che visualizza la finestra di dialogo di ricerca codice con preselezionato un comando.
Metodo pubblico | CreateFindCodeForm | Crea e restituisce la finestra di ricerca veloce codice.
Metodo pubblico | CreateFindCommand | Crea un nuovo comando Ricerca.
Metodo pubblico | CreateFindDataDocCommand | Crea un nuovo comando per ricercare i documenti.
Metodo pubblico | CreateFindDocCommand | Crea un nuovo comando per ricercare i documenti.
Metodo pubblico | CreateFindInRicercaCommand | Crea un nuovo comando FindInRicercaCommand che permette di aprire la ricerca con selezionata l'anagrafica associata all'anagrafica o al documento selezionato.
Metodo pubblico | CreateForceMarkerAlingmentCommand | Crea un nuovo comando ForceMarkerAlingment.
Metodo pubblico | CreateFormDocHistory | Crea e restituisce la finestra di dialogo utilizzata per il comando Storia documento.
Metodo pubblico | CreateFormDocTransferHistory(Boolean) | Crea e restituisce la finestra di dialogo utilizzata per il comando Storia di tutti i trasferimenti
Metodo pubblico | CreateFormDocTransferHistory(DedDoc) | Crea e restituisce la finestra di dialogo utilizzata per il comando Storia trasferimenti documento.
Metodo pubblico | CreateFormFindDoc | Crea e restituisce la finestra di dialogo utilizzata per ricercare i documeneti.
Metodo pubblico | CreateFormWhereUsed(DedDoc) | Crea e restituisce la finestra di dialogo utilizzata per il comando Where Used.
Metodo pubblico | CreateFormWhereUsed(DedDoc, Boolean) | Crea e restituisce la finestra di dialogo utilizzata per il comando Where Used.
Metodo pubblico | CreateFormWhereUsed(DedDocList, Boolean) | Crea e restituisce la finestra di dialogo utilizzata per il comando Apri File Associati.
Metodo pubblico | CreateFormWhereUsed(DedDoc, String, Boolean) | Crea e restituisce la finestra di dialogo utilizzata per il comando Where Used.
Metodo pubblico | CreateForzaCheckInDocumentCommand | Crea un nuovo comando di Forza Check-In. Mette in Check-In il documento senza copiarlo nel server.
Metodo pubblico | CreateImportCommDocumentCommand | Crea un nuovo comando ImportCommDocument. E' disponibile nel controllo dei documenti associati alle commesse.
Metodo pubblico | CreateImportCommFilesCommand | Crea un nuovo comando ImportCommDocument. E' disponibile nel controllo dei documenti associati alle commesse.
Metodo pubblico | CreateImportDocsCommand | Crea un nuovo comando ImportDocument. E' disponibile ovunque ci siano le anagrafiche ed anche siano visualizzati i documenti relativi (anche il FindCodeForm).
Metodo pubblico | CreateImportEcoFilesCommand | Crea un nuovo comando ImportEcoFiles. E' disponibile nel dialogo degli Eco.
Metodo pubblico | CreateImporterCommand | Crea un nuovo comando MarkerInfo.
Metodo pubblico | CreateImportFilesCommand | Crea un nuovo comando ImportDocument. E' disponibile ovunque ci siano le anagrafiche ed anche siano visualizzati i documenti relativi (anche il FindCodeForm).
Metodo pubblico | CreateImportSparePartDrawingCommand | Crea un nuovo comando ImportDocument per importare documenti e impostarli con contesto 'PubblicazioneRicambio'.
Metodo pubblico | CreateImportTransferPacketCommand | Crea un nuovo comando di ImportTransferPacket
Metodo pubblico | CreateLiberateCommCommand | Crea un nuovo comando per la presa in carico di una commessa.
Metodo pubblico | CreateLinkCommDocumentCommand | Crea un nuovo comando LinkCommDocument. E' disponibile nel controllo dei documenti associati alle commesse.
Metodo pubblico | CreateLinkDocumentCommand | Crea un nuovo comando LinkDocument. E' disponibile ovunque ci siano le anagrafiche ed anche siano visualizzati i documenti relativi (anche il FindCodeForm).
Metodo pubblico | CreateLogInCommand | Crea un nuovo comando LogIn.
Metodo pubblico | CreateLogViewCommand | Crea un nuovo comando LogViewCommand.
Metodo pubblico | CreateMainForm | Crea e restituisce il dialogo della ricerca.
Metodo pubblico | CreateManageOperationsCommand | Crea un nuovo comando DbVersionCommand. Permesso minimo di READ in modo che venga visualizzato anche se l'utente non lo può eseguire, utile nel caso in cui venga usato il comando login con un altro utente.
Metodo pubblico | CreateManageRootForm | Crea e restituisce la finestra per editare le Root.
Metodo pubblico | CreateMarkerInfoCommand | Crea un nuovo comando MarkerInfo.
Metodo pubblico | CreateMoveAnagrCommand | Crea un nuovo comando MoveAnagrCommand che permette di spostare le anagrafiche in un'altra famiglia.
Metodo pubblico | CreateMovedEditorCommand | Crea un nuovo comando di MovedEditorCommand.
Metodo pubblico | CreateMoveDocumentCommand | Crea un nuovo comando MoveDocument per rinominare/spostare i documenti. E' disponibile solo negli allegati.
Metodo pubblico | CreateNotifyCommand | Crea un nuovo comando per ricercare i documenti.
Metodo pubblico | CreateOpenAssocFilesCommand | Crea un nuovo comando OpenAssocFilesCommand (Apri file associati).
Metodo pubblico | CreateOpenAttachFilesCommand | Crea un nuovo comando OpenAssocFilesCommand (Apri file allegati).
Metodo pubblico | CreateOpenCommCommand | Crea un nuovo comando per l'eliminazione di una commessa.
Metodo pubblico | CreateOpenFilePathCommand | Crea un nuovo comando OpenFilePathCommand che apre la cartella contenente il file selezionato.
Metodo pubblico | CreateOpenReadDocumentCommand | Crea un nuovo comando OpenReadDocument.
Metodo pubblico | CreateOpenWriteDocumentCommand | Crea un nuovo comando OpenWriteDocument.
Metodo pubblico | CreatePrintDocumentCommand | Crea un nuovo comando di PrintDocumentCommand.
Metodo pubblico | CreatePropertiesManagerCommand | Crea un nuovo comando PropertiesManagerCommand.
Metodo pubblico | CreatePubblicaCommand | Crea un nuovo comando Pubblica. Effettua la copia del documento dall'area locale al vault e lo mantiene in CheckOut.
Metodo pubblico | CreatePubblicaStrutturaCommand | Crea un nuovo comando Pubblica. Effettua la copia del documento dall'area locale al vault e lo mantiene in CheckOut.
Metodo pubblico | CreatePublicationFilesMangerCommand | Crea un nuovo comando PublicationFilesCommand. Permesso minimo di READ in modo che venga visualizzato anche se l'utente non lo può eseguire, utile nel caso in cui venga usato il comando login con un altro utente.
Metodo pubblico | CreatePwsBackupCommand | Crea un nuovo comando PwsBackup.
Metodo pubblico | CreatePwsCacheCommand | Crea un nuovo comando PwsCache.
Metodo pubblico | CreateQsManagerCommand | Crea un nuovo comando QsManagerCommand. Permesso minimo di READ in modo che venga visualizzato anche se l'utente non lo può eseguire, utile nel caso in cui venga usato il comando login con un altro utente.
Metodo pubblico | CreateQsManagerCommCommand | Crea un nuovo comando QsManagerCommand. Permesso minimo di READ in modo che venga visualizzato anche se l'utente non lo può eseguire, utile nel caso in cui venga usato il comando login con un altro utente.
Metodo pubblico | CreateRecognaiseCommDocumentCommand | Crea un nuovo comando RecognaiseCommDocument. E' disponibile nel controllo dei documenti associati alle commesse.
Metodo pubblico | CreateRecognaiseCommFilesCommand | Crea un nuovo comando RecognaiseCommDocument. E' disponibile nel controllo dei documenti associati alle commesse.
Metodo pubblico | CreateRecognaiseDocsCommand | Crea un nuovo comando RecognaiseDocument. E' disponibile ovunque ci siano le anagrafiche ed anche siano visualizzati i documenti relativi.
Metodo pubblico | CreateRecognaiseFilesCommand | Crea un nuovo comando RecognaiseDocument. E' disponibile ovunque ci siano le anagrafiche ed anche siano visualizzati i documenti relativi.
Metodo pubblico | CreateRemoveDocumentCommand | Crea un nuovo comando RemoveDocument che permette di eliminare una lista di documenti.
Metodo pubblico | CreateRemoveEcoDocumentCommand |
Metodo pubblico | CreateRemoveRecurrentTimingCommand | Crea un nuovo comando RemoveRecurrentTimingCommand.
Metodo pubblico | CreateRenameDocumentCommand | Crea un nuovo comando RenameDoc per rinominare i documenti. E' disponibile solo negli allegati.
Metodo pubblico | CreateRenameFolderCommand | Crea un nuovo comando Elimina cartella. Eliomina una cartella e tutti i suoi documenti.
Metodo pubblico | CreateReplaceAnagrBomCommand | Crea un nuovo comando ReplaceAnagrBom che permette di sostituire un'anagrafica con un'altra all'interno di più distinte.
Metodo pubblico | CreateReplaceDocumentCommand | Crea un nuovo comando ReplaceDocument. E' disponibile ovunque ci siano le anagrafiche ed anche siano visualizzati i documenti relativi.
Metodo pubblico | CreateReplaceDocumentReferenceCommand | Crea un nuovo comando ReplaceDocumentReference.
Metodo pubblico | CreateReserveProgCommand | Crea un nuovo comando QsReserveProgCommand. Permesso minimo di READ in modo che venga visualizzato anche se l'utente non lo può eseguire, utile nel caso in cui venga usato il comando login con un altro utente.
Metodo pubblico | CreateRevCommand | Crea un nuovo comando RevCommand.
Metodo pubblico | CreateRootManagerCommand | Crea un nuovo comando Gestione root. Permesso minimo di READ in modo che venga visualizzato anche se l'utente non lo può eseguire, utile nel caso in cui venga usato il comando login con un altro utente.
Metodo pubblico | CreateSaveCommand | Crea un nuovo comando SaveCommand.
Metodo pubblico | CreateSaveDistCommand | Crea un nuovo comando SaveDistCommand.
Metodo pubblico | CreateSaveDistVariantCommand | Crea un nuovo comando SaveDistCommand.
Metodo pubblico | CreateSaveForm | Crea e restituisce la finestra di salvataggio nel Database.
Metodo pubblico | CreateSaveSparePartsDistVariantCommand | Crea un nuovo comando SaveSparePartsDistVariantCommand.
Metodo pubblico | CreateSaveVariantCommand | Crea un nuovo comando SaveCommand impostato in modo che sia utilizzato per la creazione della variante.
Metodo pubblico | CreateSbloccaDocumentCommand | Crea un nuovo comando Sblocca documento. Mette il documento in CheckIn senza effettuarne la pubblicazione. Opzionalmente lo cancella dall'area locale.
Metodo pubblico | CreateSendTransferPacketCommand | Crea un nuovo comando di SendTransferPacket.
Metodo pubblico | CreateSendZipCommand | Crea un nuovo comando SendZipViaEmail che zippa i file selezionati in una cartella e apre un messaggio di posta con allegato lo zip. Una volta inviato il messaggio viene rimossa la cartella.
Metodo pubblico | CreateShowAllActiveTimingsCommand | Crea un nuovo comando EndAllTimingsCommand.
Metodo pubblico | CreateShowAnagrCommand | Crea un nuovo comando ShowAnagr.
Metodo pubblico | CreateShowRecurrentTimingCommand | Crea un nuovo comando ShowFavTiming.
Metodo pubblico | CreateShowSparePartsDistVariantCommand | Crea un nuovo comando ShowSparePartsDistVariantCommand.
Metodo pubblico | CreateShowTimingCommand | Crea un nuovo comando ShowTimingCommand.
Metodo pubblico | CreateStartTimingCommand | Crea un nuovo comando StartTimingCommand.
Metodo pubblico | CreateStateCommand | Crea un nuovo comando di impostazione stato documento.
Metodo pubblico | CreateStateManagerCommand | Crea un nuovo comando StateManagerCommand. Permesso minimo di READ in modo che venga visualizzato anche se l'utente non lo può eseguire, utile nel caso in cui venga usato il comando login con un altro utente.
Metodo pubblico | CreateTranslationsMangerCommand | Crea e restituisce il sotto-comando che permette di aggiornare un documento e tutte le sue dipendenze. Riconosce tutti file dipendenti nel Database.
Metodo pubblico | CreateTranslationsMangerCommand(CommandContextEnum) | Crea e restituisce il sotto-comando che permette di aggiornare un documento e tutte le sue dipendenze. Riconosce tutti file dipendenti nel Database.
Metodo pubblico | CreateUpdateDocumentCommand | Crea e restituisce il sotto-comando che permette di aggiornare un documento e tutte le sue dipendenze. Riconosce tutti file dipendenti nel Database.
Metodo pubblico | CreateUpdateDocumentReferenceCommand | Crea un nuovo comando UpdateDocumentReference.
Metodo pubblico | CreateUpdateOldRevCommand | Crea un nuovo comando UpdateOldRev.
Metodo pubblico | CreateUpdateOldRevForm | Creazione del form di aggiornamento delle revisioni superate.
Metodo pubblico | CreateUpdateSparePartsBoms | Crea un nuovo comando UpdateSparePartsBoms.
Metodo pubblico | CreateUsersCommand | Crea un nuovo comando UsersCommand. Permesso minimo di READ in modo che venga visualizzato anche se l'utente non lo può eseguire, utile nel caso in cui venga usato il comando login con un altro utente.
Metodo pubblico | CreateVarsCommand | Crea un nuovo comando VarsCommand. Permesso minimo di READ in modo che venga visualizzato anche se l'utente non lo può eseguire, utile nel caso in cui venga usato il comando login con un altro utente.
Metodo pubblico | CreateViewCommCommand | Crea un nuovo comando per la visualizzazione di una commessa.
Metodo pubblico | CreateVisualDepCommand | Crea un nuovo comando VisualDep che mostra all'utente l'albero delle dipendenze.
Metodo pubblico | CreateWhereUsedCommand | Crea un nuovo comando WhereUsed.
Metodo pubblico | DataToAnagrAttrList | Data un'anagrafica, che può anche essere null, restituisce la lista degli attributi abbinati. Se l'anagrafica è null restituisce la lista degli attributi di anagrafica standard. Restituisce sempre una lista inizializzata.
Metodo pubblico | DataToAnagrDistAttrList | Data un'anagrafica, che può anche essere null, restituisce la lista degli attributi abbinati insieme a quelli di distinta. Se l'anagrafica è null restituisce la lista degli attributi di anagrafica standard e distinta. Restituisce sempre una lista inizializzata.
Metodo pubblico | DataToAnagrDistOccAttrList | Data un'anagrafica, che può anche essere null, restituisce la lista degli attributi abbinati insieme a quelli di distinta e occorrenza. Se l'anagrafica è null restituisce la lista degli attributi di anagrafica standard, distinta e occorrenza. Restituisce sempre una lista inizializzata.
Metodo pubblico | DataToAnagrDocAttrList | Data un'anagrafica, che può anche essere null, restituisce la lista degli attributi abbinati insieme a quelli di documento. Se l'anagrafica è null restituisce la lista degli attributi di anagrafica standard e documento. Restituisce sempre una lista inizializzata.
Metodo pubblico | DataToAnagrDocOccAttrList | Data un'anagrafica, che può anche essere null, restituisce la lista degli attributi abbinati insieme a quelli di documento e occorrenza. Se l'anagrafica è null restituisce la lista degli attributi di anagrafica standard, documento e occorrenza. Restituisce sempre una lista inizializzata.
Metodo pubblico | DataToAnagrOccAttrList | Data un'anagrafica, che può anche essere null, restituisce la lista degli attributi di anagrafica e occorrenza. Se l'anagrafica è null restituisce la lista degli attributi di anagrafica standard e occorrenza. Restituisce sempre una lista inizializzata.
Metodo pubblico | DataToDistAttrList | Data un'anagrafica, che può anche essere null, restituisce la lista degli attributi di distinta. Se l'anagrafica è null restituisce la lista degli attributi di distinta standard. Restituisce sempre una lista inizializzata.
Metodo pubblico | DataToDistOccAttrList | Data un'anagrafica, che può anche essere null, restituisce la lista degli attributi di distinta e occorrenza. Se l'anagrafica è null restituisce la lista degli attributi di distinta standard e occorrenza. Restituisce sempre una lista inizializzata.
Metodo pubblico | DataToDocAttrList | Data un'anagrafica, che può anche essere null, restituisce la lista degli attributi di documento. Se l'anagrafica è null restituisce la lista degli attributi di documento standard. Restituisce sempre una lista inizializzata.
Metodo pubblico | DataToDocOccAttrList | Data un'anagrafica, che può anche essere null, restituisce la lista degli attributi di documento e occorrenza. Se l'anagrafica è null restituisce la lista degli attributi di documento standard e occorrenza. Restituisce sempre una lista inizializzata.
Metodo pubblico | DataToOccAttrList | Data un'anagrafica, che può anche essere null, restituisce la lista degli attributi di occorrenza. Se l'anagrafica è null restituisce la lista degli attributi di distinta standard. Restituisce sempre una lista inizializzata.
Metodo pubblico | DbLog(Exception, LogMessageTypeEnum) | Registra l'eccezione e la gravità nella tabella dedicata al log
Metodo pubblico | DbLog(String, LogMessageTypeEnum) | Registra il messaggio e la gravità nella tabella dedicata al log
Metodo pubblico | DbLog(Exception, String, LogMessageTypeEnum) | Registra l'eccezione e la gravità nella tabella dedicata al log
Metodo pubblico | DbLog(String, String, LogMessageTypeEnum) | Registra il messaggio e la gravità nella tabella dedicata al log
Metodo pubblico | DecodeString(DedTypeBase, String, String) | Utilizzata per decodificare una stringa codificata. Data una stringa contenente i tasselli di codifica ed un'altra contenente il valore corrispondente, viene ricostruito e restituito un oggetto DedEncodeInfo contenente le informazioni presenti. Nella stringa di codifica devono essere presenti tasselli (o anche detti token) che abbiano la parte che specifica la lunghezza (in pratica deve esserci il carattere separatore ':' seguito da un qualsiasi criterio di lunghezza). Restituisce sempre una lista inizializzata ma vuota nel caso non ci fossere corrispondenze.
Metodo pubblico | DecodeString(DedTypeBase, String, String, String) | Utilizzata per decodificare una stringa codificata. Data una stringa contenente i tasselli di codifica ed un'altra contenente il valore corrispondente, viene ricostruito e restituito un oggetto DedEncodeInfo contenente le informazioni presenti. Nella stringa di codifica devono essere presenti tasselli (o anche detti token) che abbiano la parte che specifica la lunghezza (in pratica deve esserci il carattere separatore ':' seguito da un qualsiasi criterio di lunghezza). Restituisce sempre una lista inizializzata ma vuota nel caso non ci fossere corrispondenze.
Metodo pubblico | Dispose | Dispose.
Metodo protetto | Dispose(Boolean) | Effettua il Dispose in base al contesto.
Metodo pubblico | DocNameIsUsed(String) | Controlla se il nome passato senza estensione è già presente tra i documenti registrati o spostati.
Metodo pubblico | DocNameIsUsed(String, Boolean) | Controlla se il nome passato senza estensione è già presente tra i documenti registrati o spostati.
Metodo pubblico | DocNameIsUsed(String, String) | Controlla se il nome passato senza estensione è già presente tra i documenti registrati o spostati.
Metodo pubblico | DocNameIsUsed(String, String, Boolean) | Controlla se il nome passato senza estensione è già presente tra i documenti registrati o spostati.
Metodo pubblico | DocumentMatchData | Verifica che un dato documento sia presente come primario di una particolare anagrafica.
Metodo pubblico | EncodeString(String, DedEncodeInfo) | Utilizzata per calcolare una stringa di codifica. Data una stringa di codifica, per esempio "{F1:3}{P:4}-{R:2}", e le informazioni racchiuse nell'oggetto DedEncodeInfo restituisce una stringa codificata.
Metodo pubblico | EncodeString(String, DedEncodeInfo, String) | Utilizzata per calcolare una stringa di codifica. Data una stringa di codifica, per esempio "{F1:3}{P:4}-{R:2}", e le informazioni racchiuse nell'oggetto DedEncodeInfo restituisce una stringa codificata.
Metodo pubblico | EndFileTransaction | Chiude la transazione in atto effettuando il commit oppure il rollback. QUESTO METODO È SEMPRE DA UTILIZZARE INSIEME A BeginFileTransaction().
Metodo pubblico | EnsureEncodeHasLength(DedTypeBase, String) | Si assicura che il tassello in encode abbia i ":" per definire la sua lunghezza lo fa solo sui campi della famiglia ( poiche nel DEDID gli altri devono avere lunghezza definita)
Metodo pubblico | EnsureEncodeHasLength(IDedTypeEditable, String) | Si assicura che il tassello in encode abbia i ":" per definire la sua lunghezza
Metodo protetto | Finalize | Distruttore. (Sovrascrive ObjectFinalize)
Metodo pubblico | FindAllComm | Restituisce tutte le anagrafiche presenti nel DB.
Metodo pubblico | FindAllContextPrimaryDocuments | Restituisce la lista dei contesti nei quali un documento è collegato come file primario. Restituisce sempre una lista inizializzata.
Metodo pubblico | FindAllData | Restituisce tutte le anagrafiche presenti nel DB.
Metodo pubblico | FindAllDoc | Restituisce tutti i documenti registrati nel database.
Metodo pubblico | FindComm(Guid) | Restituisce una commessa cercata attraverso l'id. Restituisce null se non la trova.
Metodo pubblico | FindComm(String) | Restituisce una commessa cercata attraverso il nome. Restituisce null se non la trova.
Metodo pubblico | FindData(String) | Restituisce la lista delle anagrafiche che hanno il DEDID richiesto. Le restituisce ordinate per revisione in modo ascendente. Restituisce null se non trova alcun record nel Database.
Metodo pubblico | FindData(String, Boolean) | Restituisce l'ultima revisione (con valore più alto) che ha il DEDID specificato. Se si imposta il parametro rilPriority = true viene cercata la prima revisione rilasciata, se presente, altrimenti viene comunque restituita la revisione più alta non superata. Restituisce null se non trova il record nel Database.
Metodo pubblico | FindData(String, String) | Restituisce l'anagrafica che ha il DEDID ed il DEDREV specificati. Restituisce null se non trova il record nel Database.
Metodo pubblico | FindDataByDbPath | Restituisce la lista delle anagrafiche contenute nel dbpath indicato. Vengono considerate anche le anagrafiche che presentano dei dbpath figli di quello indicato
Metodo pubblico | FindDataByField(DedDataStandardDataFields, Object) | Restituisce la lista delle anagrafiche che hanno il campo compilato come richiesto. Le restituisce ordinate per DEDID e DEDREV in modo ascendente. Restituisce null se non trova alcun record nel Database.
Metodo pubblico | FindDataByField(String, Object) | Restituisce la lista delle anagrafiche che hanno il campo compilato come richiesto. Le restituisce ordinate per DEDID e DEDREV in modo ascendente. Restituisce null se non trova alcun record nel Database.
Metodo pubblico | FindDataByFileName | Restituisce la lista delle anagrafiche primarie del documento sotteso al file passato. Restituisce null se non trova alcun documento corrispondente al nome file passato, altrimenti restituisce una lista sempre inizializzata ma vuota se non trova anagrafiche collegate come primarie.
Metodo pubblico | FindDataLast | Restituisce la lista delle revisioni non superate appartenenti al codice richiesto. Restituisce null se non trova alcun record nel Database.
Metodo pubblico | FindDataLike(String) | Effettua una query sul campo DEDID delle anagrafiche utilizzando l'operatore like. Restituisce null se non trova alcun record nel Database, altrimenti restitusice la lista delle anagrafiche individuate. Le restituisce ordinate per DEDID e DEDREV in modo ascendente.
Metodo pubblico | FindDataLike(String, String) | Effettua una query sul campo specificato delle anagrafiche utilizzando l'operatore like. Restituisce null se non trova alcun record nel Database, altrimenti restitusice la lista delle anagrafiche individuate. Le restituisce ordinate per DEDID e DEDREV in modo ascendente.
Metodo pubblico | FindDoc(Guid) | Restituisce il documento presente nel DB, se esiste, altimenti restituisce null.
Metodo pubblico | FindDoc(String) | Restituisce il documento presente nel DB, se esiste, altimenti restituisce null. Se è attiva l'area locale cerca anche nei percorsi di checkout.
Metodo pubblico | FindDocContext(Guid) | Restituisce la lista dei Contesti di legame di un documento. Se non trova record corrispondenti, restituisce una lista inizializzata ma vuota.
Metodo pubblico | FindDocContext(Guid, DedDocContextEnum) | Restituisce la lista dei Contesti di legame di un documento. Se non trova record corrispondenti, restituisce una lista inizializzata ma vuota.
Metodo pubblico | FindDocContext(String, String) | Restituisce la lista dei Contesti di legame di una anagrafica. Se non trova record corrispondenti, restituisce una lista inizializzata ma vuota.
Metodo pubblico | FindDocContext(String, String, DedDocContextEnum) | Restituisce la lista dei Contesti di legame di una anagrafica aventi un particolare contesto. Se non trova record corrispondenti, restituisce una lista inizializzata ma vuota.
Metodo pubblico | FindDocContext(String, String, Guid) | Restituisce il Contesto di legame tra anagrafica e documento, date le sue caratteristiche univoche. Se lo trova lo restituisce altrimenti restituisce null.
Metodo pubblico | FindDocErased(Guid) | Restituisce il documento presente nel DB, se esiste, altimenti restituisce null.
Metodo pubblico | FindDocErased(String) | Restituisce il documento eliminato se presente nel DB, altrimenti restituisce null
Metodo pubblico | FindDocs(String) | Restituisce una lista di documenti filtrati in base ai criteri passati
Metodo pubblico | FindDocs(String, ListString) | Restituisce una lista di documenti filtrati in base ai criteri passati
Metodo pubblico | FindDocs(String, String) | Restituisce una lista di documenti filtrati in base ai criteri passati
Metodo pubblico | FindDocs(String, String, ListString) | Restituisce una lista di documenti filtrati in base ai criteri passati
Metodo pubblico | FindDocsByNameLike | Restituisce una lista di documenti presenti in un path
Metodo pubblico | FindDocsByPath | Restituisce una lista di documenti presenti in un path
Metodo pubblico | FindDocsByPathAndNameLike | Restituisce una lista di documenti presenti in un path
Metodo pubblico | FindDocsByPathLike | Restituisce una lista di documenti presenti in un path
Metodo pubblico | FindDocsCheckOutByMe | Restituisce una lista di documenti in checkOut dall'utente connesso.
Metodo pubblico | FindDocsEquals | Restituisce una lista di documenti filtrati in base ai criteri esatti, senza l'utilizzo del like
Metodo pubblico | FindDocsToMigrate | Restituisce una lista di documenti da migrare in base all'estensione e alla versione dell'addin
Metodo pubblico | FindMainWindow | Se impostato, restituisce il valore della proprietà MainWindow, altrimenti restituisce la IWin32Window della MainWindow del processo corrente.
Metodo pubblico | FireEditAttrValidatingEvent | Esegue evento per validare gli attributi.
Metodo pubblico | FixCodIdNull | Corregge le eventuali anagrafiche che hanno COD_ID in DED_DATA_ENCODE vuoto. Può verificarsi per via di un hotfix con un bug in corso di 23.0.0
Metodo pubblico | GetAllAttrInDb | Restituisce tutti gli attributi con ambiene anagrafica (Anagrafica, AnagraficaEDistinta, ecc..) presenti nel Db. Gli attributi di solo distinta sono esclusi.
Metodo pubblico | GetAllAttrInDb(Boolean) | Restituisce tutti gli attributi con ambiene anagrafica (Anagrafica, AnagraficaEDistinta, ecc..) presenti nel Db.
Metodo pubblico | GetAllAttrInDb(Boolean, Boolean) | Restituisce tutti gli attributi con ambiene anagrafica (Anagrafica, AnagraficaEDistinta, ecc..) presenti nel Db.
Metodo pubblico | GetAllComm | Restituisce la lista completa di tutte le commesse di primo livello. Restituisce una lista sempre inizializzata.
Metodo pubblico | GetAllDocumentPaths | Restituisce tutti i path univoci dai documenti registrati nel database
Metodo pubblico | GetAttrPrompt(DedDataStandardDataFields) | Restituisce il prompt di un attributo standard.
Metodo pubblico | GetAttrPrompt(String) | Restituisce il prompt di un attributo standard.
Metodo pubblico | GetEveryAttrInDb | Restituisce tutti gli attributi di famiglia e ricambio presenti nel Db.
Metodo pubblico | GetEveryCalculatedAttr | Ritorna tutti gli attributi importati presenti nel db.
Metodo pubblico | GetEveryCommAttrInDb | Restituisce tutti gli attributi con ambiente anagrafica (Anagrafica, AnagraficaEDistinta, ecc..) presenti nel Db.
Metodo pubblico | GetFileDependency | Restituisce la lista delle dipendenze di un documento partendo dal suo nome file completo. Viene utilizzata per avere le dipendenze di un documento che non è ancora stato archiviato. Chiama l'evento DefineFileDependency per permettere al client di intervenire.
Metodo pubblico | GetFindCommand | Restituisce il comando "ricerca" memorizzato nella cache (evita di crearne un altro velocizzando il tutto). Proprietà utilizzata principalmente nei vari add-in. ATTENZIONE! Dato che il riferimento in memoria è sempre lo stesso, se si effettuano delle modifiche alle proprietà del comando, queste verranno riportate anche negli utilizzi successivi!
Metodo pubblico | GetFindDocsCommand | Restituisce il comando "ricerca documentale" memorizzato nella cache (evita di crearne un altro velocizzando il tutto). Proprietà utilizzata principalmente nei vari add-in. ATTENZIONE! Dato che il riferimento in memoria è sempre lo stesso, se si effettuano delle modifiche alle proprietà del comando, queste verranno riportate anche negli utilizzi successivi!
Metodo pubblico | GetMessageFromEx | Crea uno StringBuilder con il messaggio completo dell'errore partendo dall'eccezione ricevuta.
Metodo pubblico | GetMovedDoc | Dato un file name ritorna il documento sostituto corrispondente.
Metodo pubblico | GetRegistryDedBaseDir | Metodo per impostare la chiave di registro del Ded con la versione attuale
Metodo pubblico | HasAtLeastOneLinkingContext | Retituisce true se il documento ha almeno un contesto di linking nei confronti di una anagrafica
Metodo pubblico | HasMovedDoc | Ritorna vero se esiste un documento "moved" corrispondente
Metodo pubblico | Init | Inizializza le strutture dati e le variabili leggendole dal Database. Se restituisce false l'errore avvenuto è reperibile attraverso la proprietà LastError.
Metodo pubblico | Init(String, String) | Inizializza le strutture dati e le variabili leggendole dal Database utilizzando una specifica stringa di connessione. Se restituisce false l'errore avvenuto è reperibile attraverso la proprietà LastError.
Metodo pubblico | InitWithConnStringOnly | Inizializza il ded utilizzando unicamente i parametri di connessione forniti senza utilizzare il file ini
Metodo pubblico | InitWithUserAlreadyLoaded | Inizializzazione completa ma specifica per utente Non richiede l'autenticazione dell'utente perchè l'informazione dell'utente è già caricata. Se restituisce false l'errore avvenuto è reperibile attraverso la proprietà LastError.
Metodo pubblico | IsDocErased | Ritorna vero se il documento figura tra gli eliminati
Metodo pubblico | IsMultipleStateChangeExecuteRegister | Restituisce se è stato o meno inizializzato l'evento lua
Metodo pubblico | LightInitWithoutAuthentication | Esegue l'inizializzazione minima per poter almeno accedere alle variabili. Non richiede l'autenticazione dell'utente. Se restituisce false l'errore avvenuto è reperibile attraverso la proprietà LastError.
Metodo pubblico | Log(Exception) | Registra il messaggio nel file di Log dell'applicazione.
Metodo pubblico | Log(String) | Registra il messaggio nei file di Log.
Metodo pubblico | Log(Exception, LogMessageTypeEnum) | Registra il messaggio nel file di Log dell'applicazione.
Metodo pubblico | Log(String, LogMessageTypeEnum) | Registra il messaggio nel file di Log dell'applicazione.
Metodo pubblico | Log(String, String) | Registra il messaggio nei file di Log.
Metodo pubblico | Login | Chiede il login all'utente ed inizializza tutti i permessi, se è attiva la gestione degli utenti, altrimenti inizializza il nome utente di default, prendendolo da Windows. Chiede nome utente e password anche se il login è già stato effettuato. Indica di chiedere obbligatoriamente il login (anche nel caso di autenticazione di windows).
Metodo pubblico | LogInfo | Registra il messaggio nei file di Log.
Metodo pubblico | LogTest | Registra il messaggio nei file di Log.
Metodo protetto | OnAddDataDocEvent | Lancia l'evento LinkingDataDocEvent.
Metodo pubblico | OnAddExtensionsRecognizerForm | Lancia l'evento per aggiungere delle estensioni al form di riconoscimento file/cartelle
Metodo protetto | OnAfterEraseEmptyPwsFolder | Chiama l'evento AfterEraseEmptyPwsFolderEvent.
Metodo protetto | OnAfterSaveDedCommTypeEvent | Chiama l'evento AfterSaveEvent.
Metodo protetto | OnAfterSaveDedTypeEvent | Chiama l'evento AfterSaveEvent.
Metodo protetto | OnAnagrSelectionDeleted | Lancia l'evento che viene scatenato al termine dell'eliminazione di tutta la selezione di anagrafiche
Metodo pubblico | OnAttributeChanged | Lancia l'evento AttributeChanged.
Metodo pubblico | OnAttributeInit | Lancia l'evento AttributeInit.
Metodo pubblico | OnBeforeShowZoomPreviewEvent | Lancia l'evento BeforeShowZoomPreview.
Metodo protetto | OnBomEditFormButtonClick | Lancia l'evento BomEditFormButtonClickEvent.
Metodo protetto | OnBomEditFormToggleSwitch | Lancia l'evento BomEditFormButtonClickEvent.
Metodo protetto | OnBomExplorerAddReplaceData | Lancia l'evento BomExplorerAddReplaceDataEvent.
Metodo protetto | OnBomExplorerButtonClick | Lancia l'evento BomExplorerButtonClickEvent.
Metodo protetto | OnBomExplorerContextMenuOpening | Lancia l'evento BomExplorerContextMenuOpening.
Metodo protetto | OnBomExplorerLoadDist | Lancia l'evento BomExplorerButtonClickEvent.
Metodo protetto | OnChangeStateECO | Chiama l'evento ChangeStateECOEvent.
Metodo protetto | OnChangingDependencyDocument | Chiama l'evento ChangingDependencyDocument.
Metodo protetto | OnCheckProgrReservedEvent | Lancia l'evento CheckProgrReservedEvent
Metodo protetto | OnCheckRevAlphabetEvent | Lancia l'evento CheckAlphabetEvent
Metodo protetto | OnClassListItemClick | Chiama l'evento ClassListItemClick.
Metodo protetto | OnCommAddAnagItem | Lancia l'evento CommAddAnagItemEvent.
Metodo protetto | OnCommandExecuting | Lancia l'evento di esecuzione comando.
Metodo protetto | OnCommCancel | Lancia l'evento CommCancelEvent.
Metodo protetto | OnCommDescrOverrideEvent | Lancia l'evento ValidateCommPropertyEvent.
Metodo protetto | OnCommElementCreateData | Lancia l'evento CommElementCreateData.
Metodo protetto | OnCommFileExplorerUpdate | Lancia l'evento CommFileExplorerUpdate.
Metodo protetto | OnCommTypeAdded | Chiama l'evento TypeAdded.
Metodo protetto | OnCopyDocument | Lancia l'evento CopyDocument.
Metodo protetto | OnCreateComm | Chiama l'evento ExportData.
Metodo protetto | OnCreateECO | Chiama l'evento CreateECOEvent.
Metodo protetto | OnCreateMultiLevelBom | Chiama l'evento EditSparePartMultiLevelBomEvent
Metodo protetto | OnCreatingSparePartDrawing | Chiama l'evento CreatingSparePartDrawing.
Metodo protetto | OnDedBomEditLoaded | Lancia l'evento DedBomEditLoaded.
Metodo protetto | OnDedDataChangedEvent | Chiama l'evento DedDataChangedEvent.
Metodo protetto | OnDedDataMoveEvent | Lancia l'evento DedDataMoveEvent.
Metodo protetto | OnDedOpenDocumentEvent | Lancia l'evento DedOpenDocumentEvent.
Metodo protetto | OnDedRuleLua | Chiama l'evento DedRuleLua.
Metodo protetto | OnDedRuleRowSetAttrPost | Chiama l'evento DedRuleRowSetAttrPost.
Metodo protetto | OnDedRuleSetAttrPost | Chiama l'evento DedRuleSetAttrPost.
Metodo protetto | OnDedRuleSetAttrPre | Chiama l'evento DedRuleSetAttrPre.
Metodo protetto | OnDedRuleSingleSetAttrPre | Chiama l'evento DedRuleSingleSetAttrPre.
Metodo protetto | OnDedTranslationChangedEvent | Chiama l'evento DedTranslationChangedEvent.
Metodo protetto | OnDefineFileDependency | Lancia l'evento DefineFileDependency.
Metodo protetto | OnDisableAutoUpdateAnagrComm | Lancia l'evento DisableAutoUpdateAnagrComm.
Metodo protetto | OnDistAddNode | Lancia l'evento DistAddNodeEvent.
Metodo protetto | OnDistChangeFieldValueEvent | Lancia l'evento DistChangeFieldValueEvent.
Metodo pubblico | OnDistCloneData | Lancia l'evento DistCloneDataEvent.
Metodo protetto | OnDistCopyData | Lancia l'evento DistCopyDataEvent.
Metodo protetto | OnDistDragElement | Lancia l'evento DistAddElementEvent.
Metodo protetto | OnDistEditSaveEvent | Lancia l'evento DistEditSaveEvent.
Metodo protetto | OnDistElementCreateData | Lancia l'evento DistElementCreateData.
Metodo protetto | OnDistItemCreateData | Lancia l'evento DistItemCreateData.
Metodo protetto | OnDistLevelSaveEvent | Lancia l'evento DistLevelSaveEvent.
Metodo protetto | OnDistReplaceSaveEvent | Lancia l'evento DistReplaceSaveEvent.
Metodo protetto | OnDistSaveEvent | Lancia l'evento DistSaveEvent.
Metodo pubblico | OnDocStructInfoCreated | Lancia l'evento alla creazione di un nuovo DocStructInfo
Metodo protetto | OnDocumentAnnullaCheckedOutEvent | Lancia l'evento DocumentAnnullaCheckedOutEvent.
Metodo protetto | OnDocumentCheckedInEvent | Lancia l'evento DocumentCheckedIn.
Metodo protetto | OnDocumentCheckedOutEvent | Lancia l'evento DocumentCheckedOut.
Metodo protetto | OnDocumentCheckLocked | Lancia l'evento DocumentCheckLockedEvent.
Metodo protetto | OnDocumentCreating | Chiama l'evento DocumentCreating.
Metodo pubblico | OnDocumentDisableEvent | Lancia l'evento per non visualizzare i documenti nel controllo documentale
Metodo protetto | OnDocumentDisconnectingEvent | Lancia l'evento DocumentDisconnectingEvent.
Metodo protetto | OnDocumentDownloadedEvent | Lancia l'evento DocumentDownloaded
Metodo pubblico | OnDocumentDragDropEvent |
Metodo protetto | OnDocumentEnsureLocalOperationEvent | Lancia l'evento DocumentEnsureLocalOperationEvent.
Metodo protetto | OnDocumentImportedEvent | Lancia l'evento DocumentImport.
Metodo protetto | OnDocumentImporting | Lancia l'evento DocumentImporting.
Metodo protetto | OnDocumentLinking | Lancia l'evento DocumentLinkingEvent.
Metodo protetto | OnDocumentMoving | Lancia l'evento DocumentImporting.
Metodo protetto | OnDocumentPublishEvent | Lancia l'evento DocumentPublishOut.
Metodo protetto | OnDocumentRecognizing | Lancia l'evento DocumentImporting.
Metodo protetto | OnDocumentSbloccaEvent | Lancia l'evento DocumentSbloccaEvent.
Metodo protetto | OnDocumentUpdating | Chiama l'evento DocumentUpdating.
Metodo pubblico | OnDragDropEvent | Lancia l'evento di DragDrop
Metodo pubblico | OnEditAttr | Lancia l'evento EditAttr.
Metodo pubblico | OnEditAttrValidating | Lancia l'evento ValidatingEditAttrEvent.
Metodo protetto | OnEditComm | Chiama l'evento ExportData.
Metodo protetto | OnEditCommChanged | Lancia l'evento NewAnagrChanged.
Metodo protetto | OnElaborateDedListEvent | Lancia l'evento per gestire le liste.
Metodo pubblico | OnEsclAttrUpdFromDBTabEvent | Lancia l'evento EsclAttrUpdFromDBTabEvent.
Metodo protetto | OnEvaluateNewValue | Chiama l'evento ProcessNewValue.
Metodo protetto | OnExportData | Chiama l'evento ExportData.
Metodo pubblico | OnExportPackAndGoConfirmEvent | Lancia l'evento ExportPackAndGoConfirmEvent.
Metodo pubblico | OnExportResultBomCompare | Lancia l'evento ExportResultBomCompareEventArgs.
Metodo protetto | OnFamDescrOverrideEvent | Lancia l'evento ValidateFamPropertyEvent.
Metodo pubblico | OnFillAttributeListFilter | Lancia l'evento che permette il filtraggio degli attributi in fase di inserimento delle liste utilizzate nell'applicazione
Metodo protetto | OnFilterSearchResult | Chiama l'evento ClassListItemClick.
Metodo pubblico | OnFindCodeMultipleAnagrEvent | Lancia l'evento FindCodeMultipleAnagrEvent.
Metodo protetto | OnFindCodeStateFilter | Lancia l'evento che permette di filtrare la lista del form find code in base allo stato dell'anagrafica
Metodo pubblico | OnFolderDisableEvent | Lancia l'evento per non visualizzare la cartella nel controllo documentale.
Metodo protetto | OnFtpClientConnectionEvent | Lancia l'evento per visualizzare una lista di suffissi in creazione di una Rappresentazione.
Metodo pubblico | OnGetDocPropertiesEvent | Lancia l'evento di GetDocPropertiesEvent.
Metodo protetto | OnGetRepresentationSuffixListEvent | Lancia l'evento per visualizzare una lista di suffissi in creazione di una Rappresentazione.
Metodo protetto | OnImportAttListEvent | Lancia l'evento ImportAttListEvent
Metodo protetto | OnImportAttrValueEvent | Lancia l'evento ImportAttrValueEvent
Metodo pubblico | OnImportDataCanUpdate | Lancia l'evento per la gestione dell'anagrafica da aggiornare nel comando Importa Dati.
Metodo pubblico | OnImportOnSaveEvent | Lancia l'evento di ImportOnSaveEvent sui documenti che sono all'interno delle root definite in ROOTS_RECOGNIZED_ON_DBSAVE
Metodo pubblico | OnImportPackAndGoSelectEvent | Lancia l'evento ImportPackAndGoSelectEvent.
Metodo protetto | OnListImportDataEvent | Lancia l'evento di validazione di un codice durante l'importazione in una lista.
Metodo protetto | OnLoadFormCommEditEvent | Lancia l'evento LoadFormCommEditEvent
Metodo protetto | OnManagePlaceHolderLogicComputed | Lancia l'evento per l'override della logica di gestione dei placeholder.
Metodo pubblico | OnManageSelectionDocsEvent | Metodo che esegue l'evento di 'ManageRevDocsEvent'.
Metodo protetto | OnModifyDocumentBeforeCheckedInEvent | Lancia l'evento DocumentCheckedIn.
Metodo protetto | OnMoveDocument | Lancia l'evento MoveDocument.
Metodo protetto | OnMsgDistReplaceSaveEvent | Lancia l'evento MsgDistReplaceSaveEvent.
Metodo pubblico | OnMultipleStateChangeExecute | Lancia l'evento che permette di verificare la lista delle anagrafiche selezionate durante le operazioni di Rilascio/Lavorazione multiplo
Metodo protetto | OnNewAnagrChanged | Lancia l'evento NewAnagrChanged.
Metodo protetto | OnNewAnagrCreated | Lancia l'evento NewAnagrCreated.
Metodo protetto | OnNewAnagrInit | Lancia l'evento NewAnagrInit.
Metodo protetto | OnNewAnagrValidating | Lancia l'evento NewAnagrValidating.
Metodo protetto | OnNewCommChanged | Lancia l'evento NewAnagrChanged.
Metodo protetto | OnNoteTransferPackEvent | Lancia l'evento NoteTransferPackEventArgs.
Metodo protetto | OnNotifyEvent | Lancia l'evento NotifyEvent
Metodo pubblico | OnOpenCommandDisableDocumentEvent | Lancia l'evento per non aprire alcuni file
Metodo protetto | OnOpenDocument | Lancia l'evento di apertura documento.
Metodo protetto | OnOrderPiorityList | Chiama l'evento OrderPriorityListEvent.
Metodo pubblico | OnOverrideAttListEvent | Lancia l'evento OverrideAttListEvent.
Metodo pubblico | OnOverrideAttrEvent | Lancia l'evento OverrideAttrEvent.
Metodo pubblico | OnOverrideCommandEnablingEvent | Lancia l'evento per non ridefinire l'abilitazione dei comandi.
Metodo pubblico | OnOverrideEnableSaveCommControl | Chiama l'evento OverrideEnableSaveControl.
Metodo pubblico | OnOverrideEnableSaveControl | Chiama l'evento OverrideEnableSaveControl.
Metodo protetto | OnOverwriteImportPlaceHolder | Lancia l'evento per l'override della logica di gestione dei placeholder.
Metodo protetto | OnPostInit | Chiama l'evento PostInit.
Metodo protetto | OnProgrCollisionEvent | Lancia l'evento ProgrCollisionEvent
Metodo pubblico | OnRecognizerPathDefined | Lancia l'evento per la specializzazione della filelist dal path definito nel form di registrazione dei documenti
Metodo pubblico | OnRedrawAnagr | Lancia l'evento RedrawAnagr.
Metodo pubblico | OnRedrawAttr | Lancia l'evento RedrawAttr.
Metodo pubblico | OnRedrawComm | Lancia l'evento RedrawComm.
Metodo pubblico | OnRedrawDedType | Lancia l'evento RedrawDedType.
Metodo pubblico | OnRedrawDep | Lancia l'evento RedrawDep.
Metodo pubblico | OnRedrawDist | Lancia l'evento RedrawDist.
Metodo protetto | OnReferenceUpdateOperationEvent | Lancia l'evento per registrarsi ai delegate del comando UpdateDocumentReference.
Metodo protetto | OnRemoveAnagr | Lancia l'evento RemoveAnagr.
Metodo protetto | OnRemoveDocument | Lancia l'evento di cancellazione documento.
Metodo protetto | OnResetSearchCriteria | Chiama l'evento ResetSearchCriteria
Metodo protetto | OnSaveCustomButtonClickEvent | Chiama l'evento SaveCustomButtonClickEvent.
Metodo pubblico | OnSaveDistOnApprovedEventEvent | Metodo che esegue l'evento di 'SaveDistOnApprovedEvent'.
Metodo pubblico | OnSendToCommandDisableDocumentEvent | Lancia l'evento per non inviare alcuni file
Metodo pubblico | OnSetDefaultFindCodeFilterEvent | Metodo che esegue l'evento di 'SetDefaultFindCodeFilter'.
Metodo pubblico | OnShowPreview | Lancia l'evento ShowPreview.
Metodo protetto | OnShowReplaceAnagrDistForm | Chiama l'evento ShowReplaceAnagrDistForm.
Metodo protetto | OnShowSaveForm | Chiama l'evento ShowSaveForm.
Metodo protetto | OnShowZoomPreview |
Metodo protetto | OnSkipDocumentStatusOnSaveDist | Lancia l'evento SkipDocumentStatusOnSaveDistEvent
Metodo pubblico | OnSkipUpdateAttribListEvent | Lancia l'evento SkipUpdateAttribListEvent.
Metodo protetto | OnStateChanged | Lancia l'evento StateChanged.
Metodo protetto | OnStateCommandDocClose | Lancia l'evento StateCommandDocClose.
Metodo protetto | OnStateCommandDocOpen | Lancia l'evento StateCommandDocOpen.
Metodo protetto | OnStateCommandDocPublish | Lancia l'evento StateCommandDocPublish.
Metodo protetto | OnStateCommandDocPublishErase | Lancia l'evento StateCommandDocPublishEraseEvent.
Metodo protetto | OnStateCommandDocsPublished | Lancia l'evento di termine pubblicazione dei documenti dell'anagrafica rilasciata
Metodo protetto | OnStateCommandEvent | Lancia l'evento StateCommandEvent.
Metodo protetto | OnStateCommmandDocWrite | Lancia l'evento StateCommmandDocWrite
Metodo protetto | OnStateElaboratingDocuments | Lancia l'evento OnStateElaboratingDocuments
Metodo protetto | OnTypeAdded | Chiama l'evento TypeAdded.
Metodo protetto | OnTypesReloaded | Lancia l'evento TypesReloaded.
Metodo pubblico | OnUnRilErasePublishEvent | Metodo che esegue l'evento di UnRilErasePublishEvent
Metodo protetto | OnUpgradeAnagrComm | Lancia l'evento UpgradeAnagrCommEvent.
Metodo protetto | OnValidateCheckFunction | Lancia l'evento ValidateCheckFunction.
Metodo protetto | OnValidateCommPropertyEvent | Lancia l'evento ValidateCommPropertyEvent.
Metodo protetto | OnValidateFamPropertyEvent | Lancia l'evento ValidateFamPropertyEvent.
Metodo pubblico | RegisterUser | Crea l'utente con l'impostazione dei relativi permessi
Metodo pubblico | Reload | Ricarica tutta la struttura degli oggetti e lancia l'evento TypesReloaded.
Metodo pubblico | ReloadAttLists | Rilegge dal database le liste att, scartando eventuali modifiche non salvate.
Metodo pubblico | SelectData(IEnumerableDedData) | Chiede all'utente di selezionare una sola anagrafica tra quelle che ha specificato in ingresso.
Metodo pubblico | SelectData(DedNetApplication, String) | Chiede all'utente di selezionare una sola anagrafica. Restituisce null se l'utente annulla.
Metodo pubblico | SelectData(DedNetApplication, String, Boolean) | Chiede all'utente di selezionare una sola anagrafica. Restituisce null se l'utente annulla.
Metodo pubblico | SelectDataMulti | Chiede all'utente di selezionare un elenco di anagrafiche. Restituisce null se l'utente annulla.
Metodo pubblico | SelectDedType | Chiede all'utente di selezionare una sola famiglia. Restituisce null se l'utente annulla.
Metodo pubblico | SelectDocument | Chiede all'utente di selezionare un solo documento. Restituisce null se l'utente annulla.
Metodo pubblico | SetUserListExt | Metodo che imposta la nuova lista di estensioni
Metodo pubblico | ShowDedDataList | Metodo che riporta, nel dialogo della ricerca, l'elenco di anagrafiche specificate in ingresso.
Metodo pubblico | ShowDedFormAbout | Mostra il dialogo FormAbout del QsUI inizializzato con le informazioni del DED.
Metodo pubblico | ShowDocsSelectionForm | Mostra la finestra di selezione dei documenti nel caso venga passato useUI a true in tutti i casi esegue anche l'evento di post selezione.
Metodo pubblico | StatoAnagr | Metodo che restituisce una stringa con lo stato attuale dell'anagrafica.
Metodo pubblico | StatoAnagrMinimal | Metodo che restituisce una stringa con lo stato attuale dell'anagrafica.
Metodo pubblico | StatoDoc | Metodo che restituisce una stringa con lo stato attuale del doccumento.
Metodo pubblico | StoreForcedAuthentication | Memorizza le credenziali per l'accesso automatico senza autenticazione.
Metodo pubblico | UpdateAttrOrder | Aggiorna tutti gli indici degali attributi.
Metodo pubblico | UserLastModified | Indica l'ultimo utente che ha effettuato un pubblica. Usato nel caso di PSW con DFS mode.
Torna su
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.AskByFindComm

Metodo DedNetApplicationAskByFindComm
Richiede la selezione di una commessa tramite interfaccia di selezione

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DialogResult AskByFindComm(
    IWin32Window owner,
    out DedComm comm
)
Public Function AskByFindComm (
    owner As IWin32Window,
    <OutAttribute> ByRef comm As DedComm
) As DialogResult
public:
DialogResult AskByFindComm(
    IWin32Window^ owner,
    [OutAttribute] DedComm^% comm
)
member AskByFindComm :
        owner : IWin32Window *
        comm : DedComm byref -> DialogResult

Parametri

owner IWin32Window
Form parent
comm DedComm
Commessa selezionata oppure null

Valore di ritorno

DialogResult
Restituisce il risultato del form
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.AskByFindCommDoc

Metodo DedNetApplicationAskByFindCommDoc
Richiede la selezione di una commessa tramite interfaccia di selezione

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DialogResult AskByFindCommDoc(
    IWin32Window owner,
    out DedDocList doc,
    out DedComm comm
)
Public Function AskByFindCommDoc (
    owner As IWin32Window,
    <OutAttribute> ByRef doc As DedDocList,
    <OutAttribute> ByRef comm As DedComm
) As DialogResult
public:
DialogResult AskByFindCommDoc(
    IWin32Window^ owner,
    [OutAttribute] DedDocList^% doc,
    [OutAttribute] DedComm^% comm
)
member AskByFindCommDoc :
        owner : IWin32Window *
        doc : DedDocList byref *
        comm : DedComm byref -> DialogResult

Parametri

owner IWin32Window
Form parent
doc DedDocList
Docuento di commessa selezionato
comm DedComm
Commessa selezionata

Valore di ritorno

DialogResult
Restituisce il risultato del form
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.AskByFindCommPath

Metodo DedNetApplicationAskByFindCommPath
Richiede la selezione di un percorso tramite interfaccia di selezione commesse

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DialogResult AskByFindCommPath(
    IWin32Window owner,
    out string path,
    out DedComm comm
)
Public Function AskByFindCommPath (
    owner As IWin32Window,
    <OutAttribute> ByRef path As String,
    <OutAttribute> ByRef comm As DedComm
) As DialogResult
public:
DialogResult AskByFindCommPath(
    IWin32Window^ owner,
    [OutAttribute] String^% path,
    [OutAttribute] DedComm^% comm
)
member AskByFindCommPath :
        owner : IWin32Window *
        path : string byref *
        comm : DedComm byref -> DialogResult

Parametri

owner IWin32Window
Form parent
path String
Percorso di commessa selezionato
comm DedComm
Commessa selezionata

Valore di ritorno

DialogResult
Restituisce il risultato del form
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.AskByFindDocs

Metodo DedNetApplicationAskByFindDocs
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AskByFindDocs(String, Boolean, DedDocList) | Visualizza la finestra di ricerca documentale in modalità Modale per chiedere all'utente la selezione di uno o più documenti. Se restituisce Abort l'errore avvenuto è reperibile attraverso la proprietà LastError.
Metodo pubblico | AskByFindDocs(String, Boolean, DedDocList, DedDocList) | Visualizza la finestra di ricerca documentale in modalità Modale per chiedere all'utente la selezione di uno o più documenti. Se restituisce Abort l'errore avvenuto è reperibile attraverso la proprietà LastError.
Metodo pubblico | AskByFindDocs(String, Boolean, ListString, DedDocList) | Visualizza la finestra di ricerca documentale in modalità Modale per chiedere all'utente la selezione di uno o più documenti. Se restituisce Abort l'errore avvenuto è reperibile attraverso la proprietà LastError.
Metodo pubblico | AskByFindDocs(String, Boolean, DedDocList, DedDocList, ListString) | Visualizza la finestra di ricerca documentale in modalità Modale per chiedere all'utente la selezione di uno o più documenti. Se restituisce Abort l'errore avvenuto è reperibile attraverso la proprietà LastError.
Torna su
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.AskByFindDocs(String, Boolean, DedDocList)

Metodo DedNetApplicationAskByFindDocs(String, Boolean, DedDocList)
Visualizza la finestra di ricerca documentale in modalità Modale per chiedere all'utente la selezione di uno o più documenti. Se restituisce Abort l'errore avvenuto è reperibile attraverso la proprietà LastError.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DialogResult AskByFindDocs(
    string userMessage,
    bool moreThanOne,
    out DedDocList restDocs
)
Public Function AskByFindDocs (
    userMessage As String,
    moreThanOne As Boolean,
    <OutAttribute> ByRef restDocs As DedDocList
) As DialogResult
public:
DialogResult AskByFindDocs(
    String^ userMessage,
    bool moreThanOne,
    [OutAttribute] DedDocList^% restDocs
)
member AskByFindDocs :
        userMessage : string *
        moreThanOne : bool *
        restDocs : DedDocList byref -> DialogResult

Parametri

userMessage String
Messaggio da mostrare all'utente.
moreThanOne Boolean
Indica se è una selezione multipla
restDocs DedDocList
Restituisce gli oggetti selezionati DocList oppure null se l'utente ha annullato o è avvenuto un errore.

Valore di ritorno

DialogResult
Restituisce il risultato della scelta dell'utente oppure Abort nel caso di errore.
Vedi anche

Documentazione

Classe DedNetApplication
Overload di AskByFindDocs
Namespace DedNet


Metodo DedNetApplication.AskByFindDocs(String, Boolean, DedDocList, DedDocList)

Metodo DedNetApplicationAskByFindDocs(String, Boolean, DedDocList, DedDocList)
Visualizza la finestra di ricerca documentale in modalità Modale per chiedere all'utente la selezione di uno o più documenti. Se restituisce Abort l'errore avvenuto è reperibile attraverso la proprietà LastError.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DialogResult AskByFindDocs(
    string userMessage,
    bool moreThanOne,
    out DedDocList restDocs,
    DedDocList _docsList
)
Public Function AskByFindDocs (
    userMessage As String,
    moreThanOne As Boolean,
    <OutAttribute> ByRef restDocs As DedDocList,
    _docsList As DedDocList
) As DialogResult
public:
DialogResult AskByFindDocs(
    String^ userMessage,
    bool moreThanOne,
    [OutAttribute] DedDocList^% restDocs,
    DedDocList^ _docsList
)
member AskByFindDocs :
        userMessage : string *
        moreThanOne : bool *
        restDocs : DedDocList byref *
        _docsList : DedDocList -> DialogResult

Parametri

userMessage String
Messaggio da mostrare all'utente.
moreThanOne Boolean
Indica se è una selezione multipla
restDocs DedDocList
Restituisce gli oggetti selezionati DocList oppure null se l'utente ha annullato o è avvenuto un errore.
_docsList DedDocList
Lista dei documenti da visualizzare.

Valore di ritorno

DialogResult
Restituisce il risultato della scelta dell'utente oppure Abort nel caso di errore.
Vedi anche

Documentazione

Classe DedNetApplication
Overload di AskByFindDocs
Namespace DedNet


Metodo DedNetApplication.AskByFindDocs(String, Boolean, List<String>, DedDocList)

Metodo DedNetApplicationAskByFindDocs(String, Boolean, ListString, DedDocList)
Visualizza la finestra di ricerca documentale in modalità Modale per chiedere all'utente la selezione di uno o più documenti. Se restituisce Abort l'errore avvenuto è reperibile attraverso la proprietà LastError.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DialogResult AskByFindDocs(
    string userMessage,
    bool moreThanOne,
    List<string> filterOnLoad,
    out DedDocList restDocs
)
Public Function AskByFindDocs (
    userMessage As String,
    moreThanOne As Boolean,
    filterOnLoad As List(Of String),
    <OutAttribute> ByRef restDocs As DedDocList
) As DialogResult
public:
DialogResult AskByFindDocs(
    String^ userMessage,
    bool moreThanOne,
    List<String^>^ filterOnLoad,
    [OutAttribute] DedDocList^% restDocs
)
member AskByFindDocs :
        userMessage : string *
        moreThanOne : bool *
        filterOnLoad : List<string> *
        restDocs : DedDocList byref -> DialogResult

Parametri

userMessage String
Messaggio da mostrare all'utente.
moreThanOne Boolean
Indica se è una selezione multipla
filterOnLoad List String
Lista delle estensioni su cui filtrare all'apertura.
restDocs DedDocList
Restituisce gli oggetti selezionati DocList oppure null se l'utente ha annullato o è avvenuto un errore.

Valore di ritorno

DialogResult
Restituisce il risultato della scelta dell'utente oppure Abort nel caso di errore.
Vedi anche

Documentazione

Classe DedNetApplication
Overload di AskByFindDocs
Namespace DedNet


Metodo DedNetApplication.AskByFindDocs(String, Boolean, DedDocList, DedDocList, List<String>)

Metodo DedNetApplicationAskByFindDocs(String, Boolean, DedDocList, DedDocList, ListString)
Visualizza la finestra di ricerca documentale in modalità Modale per chiedere all'utente la selezione di uno o più documenti. Se restituisce Abort l'errore avvenuto è reperibile attraverso la proprietà LastError.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DialogResult AskByFindDocs(
    string userMessage,
    bool moreThanOne,
    out DedDocList restDocs,
    DedDocList _docsList,
    List<string> filterOnLoad
)
Public Function AskByFindDocs (
    userMessage As String,
    moreThanOne As Boolean,
    <OutAttribute> ByRef restDocs As DedDocList,
    _docsList As DedDocList,
    filterOnLoad As List(Of String)
) As DialogResult
public:
DialogResult AskByFindDocs(
    String^ userMessage,
    bool moreThanOne,
    [OutAttribute] DedDocList^% restDocs,
    DedDocList^ _docsList,
    List<String^>^ filterOnLoad
)
member AskByFindDocs :
        userMessage : string *
        moreThanOne : bool *
        restDocs : DedDocList byref *
        _docsList : DedDocList *
        filterOnLoad : List<string> -> DialogResult

Parametri

userMessage String
Messaggio da mostrare all'utente.
moreThanOne Boolean
Indica se è una selezione multipla
restDocs DedDocList
Restituisce gli oggetti selezionati DocList oppure null se l'utente ha annullato o è avvenuto un errore.
_docsList DedDocList
Lista dei documenti da visualizzare.
filterOnLoad List String
Lista delle estensioni su cui filtrare all'apertura.

Valore di ritorno

DialogResult
Restituisce il risultato della scelta dell'utente oppure Abort nel caso di errore.
Vedi anche

Documentazione

Classe DedNetApplication
Overload di AskByFindDocs
Namespace DedNet


Metodo DedNetApplication.AskByFindRoot

Metodo DedNetApplicationAskByFindRoot
Visualizza la finestra di ricerca documentale in modalità Modale per chiedere all'utente la selezione di una root. Se restituisce Abort l'errore avvenuto è reperibile attraverso la proprietà LastError.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DialogResult AskByFindRoot(
    string userMessage,
    out string restPath
)
Public Function AskByFindRoot (
    userMessage As String,
    <OutAttribute> ByRef restPath As String
) As DialogResult
public:
DialogResult AskByFindRoot(
    String^ userMessage,
    [OutAttribute] String^% restPath
)
member AskByFindRoot :
        userMessage : string *
        restPath : string byref -> DialogResult

Parametri

userMessage String
Messaggio da mostrare all'utente.
restPath String
Restituisce il percorso selezionato oppure null se l'utente ha annullato o è avvenuto un errore.

Valore di ritorno

DialogResult
Restituisce il risultato della scelta dell'utente oppure Abort nel caso di errore.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.AskByMainForm

Metodo DedNetApplicationAskByMainForm
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AskByMainForm(String, DedChooseElement, Boolean, DedFormMainSelectInfo) | Visualizza la finestra principale in modalità Modale per chiedere all'utente la selezione di una o più anagrafiche. Se restituisce Abort l'errore avvenuto è reperibile attraverso la proprietà LastError.
Metodo pubblico | AskByMainForm(String, DedChooseElement, Boolean, Boolean, DedFormMainSelectInfo) | Visualizza la finestra principale in modalità Modale per chiedere all'utente la selezione di una o più anagrafiche. Se restituisce Abort l'errore avvenuto è reperibile attraverso la proprietà LastError.
Metodo pubblico | AskByMainForm(String, DedChooseElement, Boolean, Boolean, Boolean, DedFormMainSelectInfo) | Visualizza la finestra principale in modalità Modale per chiedere all'utente la selezione di una o più anagrafiche. Se restituisce Abort l'errore avvenuto è reperibile attraverso la proprietà LastError.
Metodo pubblico | AskByMainForm(String, DedChooseElement, Boolean, Boolean, Boolean, DedType, DedFormMainSelectInfo) | Visualizza la finestra principale in modalità Modale per chiedere all'utente la selezione di una o più anagrafiche. Se restituisce Abort l'errore avvenuto è reperibile attraverso la proprietà LastError.
Metodo pubblico | AskByMainForm(String, DedDataList, DedChooseElement, Boolean, Boolean, Boolean, DedType, DedFormMainSelectInfo) | Visualizza la finestra principale in modalità Modale per chiedere all'utente la selezione di una o più anagrafiche. Se restituisce Abort l'errore avvenuto è reperibile attraverso la proprietà LastError.
Metodo pubblico | AskByMainForm(String, DedDataList, DedChooseElement, Boolean, Boolean, Boolean, DedType, ListString, DedFormMainSelectInfo) | Visualizza la finestra principale in modalità Modale, con la visualizzazione di una lista di anagrafiche definite, per chiedere all'utente la selezione di uno o più documenti. Se restituisce Abort l'errore avvenuto è reperibile attraverso la proprietà LastError.
Torna su
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.AskByMainForm(String, DedChooseElement, Boolean, DedFormMain.SelectInfo)

Metodo DedNetApplicationAskByMainForm(String, DedChooseElement, Boolean, DedFormMainSelectInfo)
Visualizza la finestra principale in modalità Modale per chiedere all'utente la selezione di una o più anagrafiche. Se restituisce Abort l'errore avvenuto è reperibile attraverso la proprietà LastError.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DialogResult AskByMainForm(
    string userMessage,
    DedChooseElement elementToSelect,
    bool moreThanOne,
    out DedFormMainSelectInfo restData
)
Public Function AskByMainForm (
    userMessage As String,
    elementToSelect As DedChooseElement,
    moreThanOne As Boolean,
    <OutAttribute> ByRef restData As DedFormMainSelectInfo
) As DialogResult
public:
DialogResult AskByMainForm(
    String^ userMessage,
    DedChooseElement elementToSelect,
    bool moreThanOne,
    [OutAttribute] DedFormMainSelectInfo% restData
)
member AskByMainForm :
        userMessage : string *
        elementToSelect : DedChooseElement *
        moreThanOne : bool *
        restData : DedFormMainSelectInfo byref -> DialogResult

Parametri

userMessage String
Messaggio da mostrare all'utente.
elementToSelect DedChooseElement
Tipo di elementi da selezionare
moreThanOne Boolean
Indica se gli elementi da selezionare devono essere più di uno.
restData DedFormMainSelectInfo
Restituisce gli oggetti selezionati DedDocList oppure null se l'utente ha annullato o è avvenuto un errore.

Valore di ritorno

DialogResult
Restituisce il risultato della scelta dell'utente oppure Abort nel caso di errore.
Vedi anche

Documentazione

Classe DedNetApplication
Overload di AskByMainForm
Namespace DedNet


Metodo DedNetApplication.AskByMainForm(String, DedChooseElement, Boolean, Boolean, DedFormMain.SelectInfo)

Metodo DedNetApplicationAskByMainForm(String, DedChooseElement, Boolean, Boolean, DedFormMainSelectInfo)
Visualizza la finestra principale in modalità Modale per chiedere all'utente la selezione di una o più anagrafiche. Se restituisce Abort l'errore avvenuto è reperibile attraverso la proprietà LastError.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DialogResult AskByMainForm(
    string userMessage,
    DedChooseElement elementToSelect,
    bool moreThanOne,
    bool onlyLavAnagr,
    out DedFormMainSelectInfo restData
)
Public Function AskByMainForm (
    userMessage As String,
    elementToSelect As DedChooseElement,
    moreThanOne As Boolean,
    onlyLavAnagr As Boolean,
    <OutAttribute> ByRef restData As DedFormMainSelectInfo
) As DialogResult
public:
DialogResult AskByMainForm(
    String^ userMessage,
    DedChooseElement elementToSelect,
    bool moreThanOne,
    bool onlyLavAnagr,
    [OutAttribute] DedFormMainSelectInfo% restData
)
member AskByMainForm :
        userMessage : string *
        elementToSelect : DedChooseElement *
        moreThanOne : bool *
        onlyLavAnagr : bool *
        restData : DedFormMainSelectInfo byref -> DialogResult

Parametri

userMessage String
Messaggio da mostrare all'utente.
elementToSelect DedChooseElement
Tipo di elementi da selezionare
moreThanOne Boolean
Indica se gli elementi da selezionare devono essere più di uno.
onlyLavAnagr Boolean
Indica se si possono selezionare solo anagrafiche in Lavorazione.
restData DedFormMainSelectInfo
Restituisce gli oggetti selezionati DedDocList oppure null se l'utente ha annullato o è avvenuto un errore.

Valore di ritorno

DialogResult
Restituisce il risultato della scelta dell'utente oppure Abort nel caso di errore.
Vedi anche

Documentazione

Classe DedNetApplication
Overload di AskByMainForm
Namespace DedNet


Metodo DedNetApplication.AskByMainForm(String, DedChooseElement, Boolean, Boolean, Boolean, DedFormMain.SelectInfo)

Metodo DedNetApplicationAskByMainForm(String, DedChooseElement, Boolean, Boolean, Boolean, DedFormMainSelectInfo)
Visualizza la finestra principale in modalità Modale per chiedere all'utente la selezione di una o più anagrafiche. Se restituisce Abort l'errore avvenuto è reperibile attraverso la proprietà LastError.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DialogResult AskByMainForm(
    string userMessage,
    DedChooseElement elementToSelect,
    bool moreThanOne,
    bool onlyLavAnagr,
    bool onlySubTypes,
    out DedFormMainSelectInfo restData
)
Public Function AskByMainForm (
    userMessage As String,
    elementToSelect As DedChooseElement,
    moreThanOne As Boolean,
    onlyLavAnagr As Boolean,
    onlySubTypes As Boolean,
    <OutAttribute> ByRef restData As DedFormMainSelectInfo
) As DialogResult
public:
DialogResult AskByMainForm(
    String^ userMessage,
    DedChooseElement elementToSelect,
    bool moreThanOne,
    bool onlyLavAnagr,
    bool onlySubTypes,
    [OutAttribute] DedFormMainSelectInfo% restData
)
member AskByMainForm :
        userMessage : string *
        elementToSelect : DedChooseElement *
        moreThanOne : bool *
        onlyLavAnagr : bool *
        onlySubTypes : bool *
        restData : DedFormMainSelectInfo byref -> DialogResult

Parametri

userMessage String
Messaggio da mostrare all'utente.
elementToSelect DedChooseElement
Tipo di elementi da selezionare
moreThanOne Boolean
Indica se gli elementi da selezionare devono essere più di uno.
onlyLavAnagr Boolean
Indica se si possono selezionare solo anagrafiche in Lavorazione.
onlySubTypes Boolean
Indica se devono essere selezionate solo famiglie foglie
restData DedFormMainSelectInfo
Restituisce gli oggetti selezionati DedDocList oppure null se l'utente ha annullato o è avvenuto un errore.

Valore di ritorno

DialogResult
Restituisce il risultato della scelta dell'utente oppure Abort nel caso di errore.
Vedi anche

Documentazione

Classe DedNetApplication
Overload di AskByMainForm
Namespace DedNet


Metodo DedNetApplication.AskByMainForm(String, DedChooseElement, Boolean, Boolean, Boolean, DedType, DedFormMain.SelectInfo)

Metodo DedNetApplicationAskByMainForm(String, DedChooseElement, Boolean, Boolean, Boolean, DedType, DedFormMainSelectInfo)
Visualizza la finestra principale in modalità Modale per chiedere all'utente la selezione di una o più anagrafiche. Se restituisce Abort l'errore avvenuto è reperibile attraverso la proprietà LastError.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DialogResult AskByMainForm(
    string userMessage,
    DedChooseElement elementToSelect,
    bool moreThanOne,
    bool onlyLavAnagr,
    bool onlySubTypes,
    DedType selDedType,
    out DedFormMainSelectInfo restData
)
Public Function AskByMainForm (
    userMessage As String,
    elementToSelect As DedChooseElement,
    moreThanOne As Boolean,
    onlyLavAnagr As Boolean,
    onlySubTypes As Boolean,
    selDedType As DedType,
    <OutAttribute> ByRef restData As DedFormMainSelectInfo
) As DialogResult
public:
DialogResult AskByMainForm(
    String^ userMessage,
    DedChooseElement elementToSelect,
    bool moreThanOne,
    bool onlyLavAnagr,
    bool onlySubTypes,
    DedType^ selDedType,
    [OutAttribute] DedFormMainSelectInfo% restData
)
member AskByMainForm :
        userMessage : string *
        elementToSelect : DedChooseElement *
        moreThanOne : bool *
        onlyLavAnagr : bool *
        onlySubTypes : bool *
        selDedType : DedType *
        restData : DedFormMainSelectInfo byref -> DialogResult

Parametri

userMessage String
Messaggio da mostrare all'utente.
elementToSelect DedChooseElement
Tipo di elementi da selezionare
moreThanOne Boolean
Indica se gli elementi da selezionare devono essere più di uno.
onlyLavAnagr Boolean
Indica se si possono selezionare solo anagrafiche in Lavorazione.
onlySubTypes Boolean
Indica se devono essere selezionate solo famiglie foglie
selDedType DedType
Indica la famiglia da selezionare
restData DedFormMainSelectInfo
Restituisce gli oggetti selezionati DedDocList oppure null se l'utente ha annullato o è avvenuto un errore.

Valore di ritorno

DialogResult
Restituisce il risultato della scelta dell'utente oppure Abort nel caso di errore.
Vedi anche

Documentazione

Classe DedNetApplication
Overload di AskByMainForm
Namespace DedNet


Metodo DedNetApplication.AskByMainForm(String, DedDataList, DedChooseElement, Boolean, Boolean, Boolean, DedType, DedFormMain.SelectInfo)

Metodo DedNetApplicationAskByMainForm(String, DedDataList, DedChooseElement, Boolean, Boolean, Boolean, DedType, DedFormMainSelectInfo)
Visualizza la finestra principale in modalità Modale per chiedere all'utente la selezione di una o più anagrafiche. Se restituisce Abort l'errore avvenuto è reperibile attraverso la proprietà LastError.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DialogResult AskByMainForm(
    string userMessage,
    DedDataList dataList,
    DedChooseElement elementToSelect,
    bool moreThanOne,
    bool onlyLavAnagr,
    bool onlySubTypes,
    DedType selDedType,
    out DedFormMainSelectInfo restData
)
Public Function AskByMainForm (
    userMessage As String,
    dataList As DedDataList,
    elementToSelect As DedChooseElement,
    moreThanOne As Boolean,
    onlyLavAnagr As Boolean,
    onlySubTypes As Boolean,
    selDedType As DedType,
    <OutAttribute> ByRef restData As DedFormMainSelectInfo
) As DialogResult
public:
DialogResult AskByMainForm(
    String^ userMessage,
    DedDataList^ dataList,
    DedChooseElement elementToSelect,
    bool moreThanOne,
    bool onlyLavAnagr,
    bool onlySubTypes,
    DedType^ selDedType,
    [OutAttribute] DedFormMainSelectInfo% restData
)
member AskByMainForm :
        userMessage : string *
        dataList : DedDataList *
        elementToSelect : DedChooseElement *
        moreThanOne : bool *
        onlyLavAnagr : bool *
        onlySubTypes : bool *
        selDedType : DedType *
        restData : DedFormMainSelectInfo byref -> DialogResult

Parametri

userMessage String
Messaggio da mostrare all'utente.
dataList DedDataList
Lista di anagrafiche da visualizzare
elementToSelect DedChooseElement
Tipo di elementi da selezionare
moreThanOne Boolean
Indica se gli elementi da selezionare devono essere più di uno.
onlyLavAnagr Boolean
Indica se si possono selezionare solo anagrafiche in Lavorazione.
onlySubTypes Boolean
Indica se devono essere selezionate solo famiglie foglie
selDedType DedType
Indica la famiglia da selezionare
restData DedFormMainSelectInfo
Restituisce gli oggetti selezionati DedDocList oppure null se l'utente ha annullato o è avvenuto un errore.

Valore di ritorno

DialogResult
Restituisce il risultato della scelta dell'utente oppure Abort nel caso di errore.
Vedi anche

Documentazione

Classe DedNetApplication
Overload di AskByMainForm
Namespace DedNet


Metodo DedNetApplication.AskByMainForm(String, DedDataList, DedChooseElement, Boolean, Boolean, Boolean, DedType, List<String>, DedFormMain.SelectInfo)

Metodo DedNetApplicationAskByMainForm(String, DedDataList, DedChooseElement, Boolean, Boolean, Boolean, DedType, ListString, DedFormMainSelectInfo)
Visualizza la finestra principale in modalità Modale, con la visualizzazione di una lista di anagrafiche definite, per chiedere all'utente la selezione di uno o più documenti. Se restituisce Abort l'errore avvenuto è reperibile attraverso la proprietà LastError.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DialogResult AskByMainForm(
    string userMessage,
    DedDataList dataList,
    DedChooseElement elementToSelect,
    bool moreThanOne,
    bool onlyLavAnagr,
    bool onlySubTypes,
    DedType selDedType,
    List<string> filterOnLoad,
    out DedFormMainSelectInfo restData
)
Public Function AskByMainForm (
    userMessage As String,
    dataList As DedDataList,
    elementToSelect As DedChooseElement,
    moreThanOne As Boolean,
    onlyLavAnagr As Boolean,
    onlySubTypes As Boolean,
    selDedType As DedType,
    filterOnLoad As List(Of String),
    <OutAttribute> ByRef restData As DedFormMainSelectInfo
) As DialogResult
public:
DialogResult AskByMainForm(
    String^ userMessage,
    DedDataList^ dataList,
    DedChooseElement elementToSelect,
    bool moreThanOne,
    bool onlyLavAnagr,
    bool onlySubTypes,
    DedType^ selDedType,
    List<String^>^ filterOnLoad,
    [OutAttribute] DedFormMainSelectInfo% restData
)
member AskByMainForm :
        userMessage : string *
        dataList : DedDataList *
        elementToSelect : DedChooseElement *
        moreThanOne : bool *
        onlyLavAnagr : bool *
        onlySubTypes : bool *
        selDedType : DedType *
        filterOnLoad : List<string> *
        restData : DedFormMainSelectInfo byref -> DialogResult

Parametri

userMessage String
Messaggio da mostrare all'utente.
dataList DedDataList
Lista di anagrafiche da visualizzare
elementToSelect DedChooseElement
Tipo di elementi da selezionare
moreThanOne Boolean
Indica se gli elementi da selezionare devono essere più di uno.
onlyLavAnagr Boolean
Indica se si possono selezionare solo anagrafiche in Lavorazione.
onlySubTypes Boolean
Indica se devono essere selezionate solo famiglie foglie
selDedType DedType
Indica la famiglia da selezionare
filterOnLoad List String
Lista contenente le estensioni su cui effettuare il filtraggio sui documenti in apertura.
restData DedFormMainSelectInfo
Restituisce gli oggetti selezionati DedDocList oppure null se l'utente ha annullato o è avvenuto un errore.

Valore di ritorno

DialogResult
Restituisce il risultato della scelta dell'utente oppure Abort nel caso di errore.
Vedi anche

Documentazione

Classe DedNetApplication
Overload di AskByMainForm
Namespace DedNet


Metodo DedNetApplication.AskDedTypeByMainForm

Metodo DedNetApplicationAskDedTypeByMainForm
Visualizza la finestra principale in modalità Modale per chiedere all'utente la selezione di una famiglia. Se restituisce Abort l'errore avvenuto è reperibile attraverso la proprietà LastError.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DialogResult AskDedTypeByMainForm(
    string userMessage,
    bool onlySubTypes,
    DedType selDedType,
    out DedFormMainSelectInfo restData
)
Public Function AskDedTypeByMainForm (
    userMessage As String,
    onlySubTypes As Boolean,
    selDedType As DedType,
    <OutAttribute> ByRef restData As DedFormMainSelectInfo
) As DialogResult
public:
DialogResult AskDedTypeByMainForm(
    String^ userMessage,
    bool onlySubTypes,
    DedType^ selDedType,
    [OutAttribute] DedFormMainSelectInfo% restData
)
member AskDedTypeByMainForm :
        userMessage : string *
        onlySubTypes : bool *
        selDedType : DedType *
        restData : DedFormMainSelectInfo byref -> DialogResult

Parametri

userMessage String
Messaggio da mostrare all'utente.
onlySubTypes Boolean
Indica se permettere di selezionare solo famiglie foglia
selDedType DedType
Famiglia selezionata di default
restData DedFormMainSelectInfo
Risultato della selezione

Valore di ritorno

DialogResult
Restituisce il risultato della scelta dell'utente oppure Abort nel caso di errore.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.BeginFileTransaction

Metodo DedNetApplicationBeginFileTransaction
Restituisce la transazione di file in atto oppure ne crea una nuova e la restituisce. QUESTO METODO È SEMPRE DA UTILIZZARE INSIEME A EndFileTransaction().

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public FileTransaction BeginFileTransaction()
Public Function BeginFileTransaction As FileTransaction
public:
FileTransaction^ BeginFileTransaction()
member BeginFileTransaction : unit -> FileTransaction

Valore di ritorno

FileTransaction
Restituisce l'oggetto di transazione file corrente.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.ChangeContext

Metodo DedNetApplicationChangeContext
Cambia il contesto di associazione tra anagrafica e documento. Permette solo il cambio da Modello a Pubblicazione o viceversa.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ChangeContext(
    string dedid,
    string dedrev,
    Guid docid,
    DedDocContextEnum newcontext
)
Public Function ChangeContext (
    dedid As String,
    dedrev As String,
    docid As Guid,
    newcontext As DedDocContextEnum
) As Boolean
public:
bool ChangeContext(
    String^ dedid,
    String^ dedrev,
    Guid docid,
    DedDocContextEnum newcontext
)
member ChangeContext :
        dedid : string *
        dedrev : string *
        docid : Guid *
        newcontext : DedDocContextEnum -> bool

Parametri

dedid String
DEDID per il quale reperire l'anagrafica.
dedrev String
DEDREV per il quale reperire l'anagrafica.
docid Guid
DocId del documento
newcontext DedDocContextEnum
Nuovo contesto di associazione.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.ChangeDependencyDocument

Metodo DedNetApplicationChangeDependencyDocument
Aggiorna la dipendenza fisica di uno specifico documento padre aggiornandola al nuovo documento. Se attiva l'area locale, l'aggiornamento deve avvenire sia nel file presente nel vault che nella pws.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ChangeDependencyDocument(
    DedDoc parentDoc,
    string oldDep,
    string newDep
)
Public Sub ChangeDependencyDocument (
    parentDoc As DedDoc,
    oldDep As String,
    newDep As String
)
public:
void ChangeDependencyDocument(
    DedDoc^ parentDoc,
    String^ oldDep,
    String^ newDep
)
member ChangeDependencyDocument :
        parentDoc : DedDoc *
        oldDep : string *
        newDep : string -> unit

Parametri

parentDoc DedDoc
Documento al quale aggiornare la dipendenza.
oldDep String
Nome completo del file di dipendenza che è da modificare.
newDep String
Nome completo del file che deve essere impostato come dipendenza.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CheckPwsLastCleaning

Metodo DedNetApplicationCheckPwsLastCleaning
Controlla l'ultima pulizia dell'area locale e nel caso mostra un avvertimento

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void CheckPwsLastCleaning()
Public Sub CheckPwsLastCleaning
public:
void CheckPwsLastCleaning()
member CheckPwsLastCleaning : unit -> unit
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.ClearForcedAuthentication

Metodo DedNetApplicationClearForcedAuthentication
Cancella le credenziali per l'accesso automatico senza autenticazione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ClearForcedAuthentication()
Public Sub ClearForcedAuthentication
public:
void ClearForcedAuthentication()
member ClearForcedAuthentication : unit -> unit
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.Close

Metodo DedNetApplicationClose
Chiude l'oggetto liberando le risorse.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Close()
Public Sub Close
public:
void Close()
member Close : unit -> unit
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CommMatchFilter

Metodo DedNetApplicationCommMatchFilter
Restituisce true se la commessa soddisfa i criteri di ricerca impostati

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CommMatchFilter(
    DedComm refComm,
    DedDataList filterAnagr,
    string freeTextSearch
)
Public Function CommMatchFilter (
    refComm As DedComm,
    filterAnagr As DedDataList,
    freeTextSearch As String
) As Boolean
public:
bool CommMatchFilter(
    DedComm^ refComm,
    DedDataList^ filterAnagr,
    String^ freeTextSearch
)
member CommMatchFilter :
        refComm : DedComm *
        filterAnagr : DedDataList *
        freeTextSearch : string -> bool

Parametri

refComm DedComm
Commessa di riferimento
filterAnagr DedDataList
Anagrafica da ricerca nelle collegate
freeTextSearch String
Testo libero da ricercare nei campi della commessa

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CompileProgDedDataEncode

Metodo DedNetApplicationCompileProgDedDataEncode
Compila il campo prog dentro DedDataEncode

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void CompileProgDedDataEncode()
Public Sub CompileProgDedDataEncode
public:
void CompileProgDedDataEncode()
member CompileProgDedDataEncode : unit -> unit
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateAddCommCommand

Metodo DedNetApplicationCreateAddCommCommand
Crea un nuovo comando per la creazione di una commessa.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public AddCommCommand CreateAddCommCommand()
Public Function CreateAddCommCommand As AddCommCommand
public:
AddCommCommand^ CreateAddCommCommand()
member CreateAddCommCommand : unit -> AddCommCommand

Valore di ritorno

AddCommCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateAddEcoCommand

Metodo DedNetApplicationCreateAddEcoCommand
Crea un nuovo comando per la creazione di un ECO.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public AddEcoCommand CreateAddEcoCommand()
Public Function CreateAddEcoCommand As AddEcoCommand
public:
AddEcoCommand^ CreateAddEcoCommand()
member CreateAddEcoCommand : unit -> AddEcoCommand

Valore di ritorno

AddEcoCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateAddRecurrentTimingCommand

Metodo DedNetApplicationCreateAddRecurrentTimingCommand
Crea un nuovo comando AddRecurrentTimingCommand.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public AddRecurrentTimingCommand CreateAddRecurrentTimingCommand()
Public Function CreateAddRecurrentTimingCommand As AddRecurrentTimingCommand
public:
AddRecurrentTimingCommand^ CreateAddRecurrentTimingCommand()
member CreateAddRecurrentTimingCommand : unit -> AddRecurrentTimingCommand

Valore di ritorno

AddRecurrentTimingCommand
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateAddSubCommCommand

Metodo DedNetApplicationCreateAddSubCommCommand
Crea un nuovo comando per la creazione di una sotto commessa.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public AddCommCommand CreateAddSubCommCommand()
Public Function CreateAddSubCommCommand As AddCommCommand
public:
AddCommCommand^ CreateAddSubCommCommand()
member CreateAddSubCommCommand : unit -> AddCommCommand

Valore di ritorno

AddCommCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateAnagrAssocCommCommand

Metodo DedNetApplicationCreateAnagrAssocCommCommand
Crea un nuovo comando AnagrAssocComm che permette di associare delle anagrafiche ad una commessa.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public AnagrAssocComm CreateAnagrAssocCommCommand()
Public Function CreateAnagrAssocCommCommand As AnagrAssocComm
public:
AnagrAssocComm^ CreateAnagrAssocCommCommand()
member CreateAnagrAssocCommCommand : unit -> AnagrAssocComm

Valore di ritorno

AnagrAssocComm
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateAnagrForm

Metodo DedNetApplicationCreateAnagrForm
Crea e restituisce la finestra di visualizzazione/editazione degli attributi di un'anagrafica.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormAnagrafica CreateAnagrForm()
Public Function CreateAnagrForm As DedFormAnagrafica
public:
DedFormAnagrafica^ CreateAnagrForm()
member CreateAnagrForm : unit -> DedFormAnagrafica

Valore di ritorno

DedFormAnagrafica
Restituisce il form.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateAnagrHistoryCommand

Metodo DedNetApplicationCreateAnagrHistoryCommand
Crea un nuovo comando AnagrHistory che mostra all'utente la storia dell'anagrafica.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public AnagrHistoryCommand CreateAnagrHistoryCommand()
Public Function CreateAnagrHistoryCommand As AnagrHistoryCommand
public:
AnagrHistoryCommand^ CreateAnagrHistoryCommand()
member CreateAnagrHistoryCommand : unit -> AnagrHistoryCommand

Valore di ritorno

AnagrHistoryCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateAnnullaCheckOutCommand

Metodo DedNetApplicationCreateAnnullaCheckOutCommand
Crea un nuovo comando Annulla CheckOut. Ripristina il documento al momento in cui è stato scaricato dal vault.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public AnnullaCheckOutDocument CreateAnnullaCheckOutCommand()
Public Function CreateAnnullaCheckOutCommand As AnnullaCheckOutDocument
public:
AnnullaCheckOutDocument^ CreateAnnullaCheckOutCommand()
member CreateAnnullaCheckOutCommand : unit -> AnnullaCheckOutDocument

Valore di ritorno

AnnullaCheckOutDocument
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateAssignEcoToSpecificUserCommand

Metodo DedNetApplicationCreateAssignEcoToSpecificUserCommand
Crea un nuovo comando di assegna ECO.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public AssignEcoToSpecificUserCommand CreateAssignEcoToSpecificUserCommand()
Public Function CreateAssignEcoToSpecificUserCommand As AssignEcoToSpecificUserCommand
public:
AssignEcoToSpecificUserCommand^ CreateAssignEcoToSpecificUserCommand()
member CreateAssignEcoToSpecificUserCommand : unit -> AssignEcoToSpecificUserCommand

Valore di ritorno

AssignEcoToSpecificUserCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateAssociateAlternativeCodeCommand

Metodo DedNetApplicationCreateAssociateAlternativeCodeCommand
Crea un nuovo comando che chiede all'utente di associare all'anagrafice dei codici alternativi.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public AssociateAlternativeDataCommand CreateAssociateAlternativeCodeCommand()
Public Function CreateAssociateAlternativeCodeCommand As AssociateAlternativeDataCommand
public:
AssociateAlternativeDataCommand^ CreateAssociateAlternativeCodeCommand()
member CreateAssociateAlternativeCodeCommand : unit -> AssociateAlternativeDataCommand

Valore di ritorno

AssociateAlternativeDataCommand
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateAssociateDocForm

Metodo DedNetApplicationCreateAssociateDocForm
Crea e restituisce la finestra di scelta delle opzioni di associazione documento.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormAssociateDoc CreateAssociateDocForm()
Public Function CreateAssociateDocForm As DedFormAssociateDoc
public:
DedFormAssociateDoc^ CreateAssociateDocForm()
member CreateAssociateDocForm : unit -> DedFormAssociateDoc

Valore di ritorno

DedFormAssociateDoc
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateAssociateDocumentCommand

Metodo DedNetApplicationCreateAssociateDocumentCommand
Crea un nuovo comando AssociateDocument che permette di associare/importare un documento/file ad un'anagrafica.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public AssociateDocument CreateAssociateDocumentCommand()
Public Function CreateAssociateDocumentCommand As AssociateDocument
public:
AssociateDocument^ CreateAssociateDocumentCommand()
member CreateAssociateDocumentCommand : unit -> AssociateDocument

Valore di ritorno

AssociateDocument
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateBomEditCommand

Metodo DedNetApplicationCreateBomEditCommand
Crea un nuovo comando DedBomEdit che mostra all'utente il form di editazione delle distinte.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomEditCommand CreateBomEditCommand()
Public Function CreateBomEditCommand As BomEditCommand
public:
BomEditCommand^ CreateBomEditCommand()
member CreateBomEditCommand : unit -> BomEditCommand

Valore di ritorno

BomEditCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateBomEditOpenReadCommand

Metodo DedNetApplicationCreateBomEditOpenReadCommand
Crea un nuovo comando DedBomEdit che mostra all'utente il form di editazione delle distinte. Viene inizializzato il pannello di consultazione con l'anagrafica selezionata

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommand CreateBomEditOpenReadCommand()
Public Function CreateBomEditOpenReadCommand As DedCommand
public:
DedCommand^ CreateBomEditOpenReadCommand()
member CreateBomEditOpenReadCommand : unit -> DedCommand

Valore di ritorno

DedCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateBomHistoryCommand

Metodo DedNetApplicationCreateBomHistoryCommand
Crea un nuovo comando DedBomHistory che mostra all'utente il form dello storico delle distinte.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomHistoryCommand CreateBomHistoryCommand()
Public Function CreateBomHistoryCommand As BomHistoryCommand
public:
BomHistoryCommand^ CreateBomHistoryCommand()
member CreateBomHistoryCommand : unit -> BomHistoryCommand

Valore di ritorno

BomHistoryCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateBomHistoryForm

Metodo DedNetApplicationCreateBomHistoryForm
Crea e restituisce la finestra di visualizzazione storico distinta.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormBomHistory CreateBomHistoryForm(
    DedData data,
    string discr
)
Public Function CreateBomHistoryForm (
    data As DedData,
    discr As String
) As DedFormBomHistory
public:
DedFormBomHistory^ CreateBomHistoryForm(
    DedData^ data,
    String^ discr
)
member CreateBomHistoryForm :
        data : DedData *
        discr : string -> DedFormBomHistory

Parametri

data DedData
discr String

Valore di ritorno

DedFormBomHistory
Restituisce il form.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateBomWhereUsedCommand

Metodo DedNetApplicationCreateBomWhereUsedCommand
Crea un nuovo comando BomWhereUsedCommand.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomWhereUsedCommand CreateBomWhereUsedCommand()
Public Function CreateBomWhereUsedCommand As BomWhereUsedCommand
public:
BomWhereUsedCommand^ CreateBomWhereUsedCommand()
member CreateBomWhereUsedCommand : unit -> BomWhereUsedCommand

Valore di ritorno

BomWhereUsedCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateChangeEcoStateToAssignedCommand

Metodo DedNetApplicationCreateChangeEcoStateToAssignedCommand
Crea un nuovo comando di cambia stato ECO. Imposta lo stato come 'Assegnato'.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ChangeEcoStateCommand CreateChangeEcoStateToAssignedCommand()
Public Function CreateChangeEcoStateToAssignedCommand As ChangeEcoStateCommand
public:
ChangeEcoStateCommand^ CreateChangeEcoStateToAssignedCommand()
member CreateChangeEcoStateToAssignedCommand : unit -> ChangeEcoStateCommand

Valore di ritorno

ChangeEcoStateCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateChangeEcoStateToClosedCommand

Metodo DedNetApplicationCreateChangeEcoStateToClosedCommand
Crea un nuovo comando di cambia stato ECO. Imposta lo stato come 'Chiuso'.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ChangeEcoStateCommand CreateChangeEcoStateToClosedCommand()
Public Function CreateChangeEcoStateToClosedCommand As ChangeEcoStateCommand
public:
ChangeEcoStateCommand^ CreateChangeEcoStateToClosedCommand()
member CreateChangeEcoStateToClosedCommand : unit -> ChangeEcoStateCommand

Valore di ritorno

ChangeEcoStateCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateChangeEcoStateToOpenCommand

Metodo DedNetApplicationCreateChangeEcoStateToOpenCommand
Crea un nuovo comando di cambia stato ECO. Imposta lo stato come 'Aperto'.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ChangeEcoStateCommand CreateChangeEcoStateToOpenCommand()
Public Function CreateChangeEcoStateToOpenCommand As ChangeEcoStateCommand
public:
ChangeEcoStateCommand^ CreateChangeEcoStateToOpenCommand()
member CreateChangeEcoStateToOpenCommand : unit -> ChangeEcoStateCommand

Valore di ritorno

ChangeEcoStateCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateChangePwdCommand

Metodo DedNetApplicationCreateChangePwdCommand
Crea un nuovo comando Cambio Password.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ChangePasswordCommand CreateChangePwdCommand()
Public Function CreateChangePwdCommand As ChangePasswordCommand
public:
ChangePasswordCommand^ CreateChangePwdCommand()
member CreateChangePwdCommand : unit -> ChangePasswordCommand

Valore di ritorno

ChangePasswordCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateChangeRepresentationSuffixCommand

Metodo DedNetApplicationCreateChangeRepresentationSuffixCommand
Crea un nuovo comando ChangeRepresentationSuffixCommand. E' disponibile solo su documenti in contesto rappresentazione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ChangeRepresentationSuffixCommand CreateChangeRepresentationSuffixCommand()
Public Function CreateChangeRepresentationSuffixCommand As ChangeRepresentationSuffixCommand
public:
ChangeRepresentationSuffixCommand^ CreateChangeRepresentationSuffixCommand()
member CreateChangeRepresentationSuffixCommand : unit -> ChangeRepresentationSuffixCommand

Valore di ritorno

ChangeRepresentationSuffixCommand
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateChangeStateForm

Metodo DedNetApplicationCreateChangeStateForm
Crea e restituisce la finestra di cambio stato.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormChangeState CreateChangeStateForm(
    DedState currentState,
    bool includeCurrentState
)
Public Function CreateChangeStateForm (
    currentState As DedState,
    includeCurrentState As Boolean
) As DedFormChangeState
public:
DedFormChangeState^ CreateChangeStateForm(
    DedState^ currentState,
    bool includeCurrentState
)
member CreateChangeStateForm :
        currentState : DedState *
        includeCurrentState : bool -> DedFormChangeState

Parametri

currentState DedState
includeCurrentState Boolean

Valore di ritorno

DedFormChangeState
Restituisce il form.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateChargeCommCommand

Metodo DedNetApplicationCreateChargeCommCommand
Crea un nuovo comando per la presa in carico di una commessa.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommand CreateChargeCommCommand()
Public Function CreateChargeCommCommand As DedCommand
public:
DedCommand^ CreateChargeCommCommand()
member CreateChargeCommCommand : unit -> DedCommand

Valore di ritorno

DedCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateCheckInDocumentCommand

Metodo DedNetApplicationCreateCheckInDocumentCommand
Crea un nuovo comando di Check-In. Effettua la pubblicazione del documento e poi lo mette in Check-In.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public CheckInDocument CreateCheckInDocumentCommand()
Public Function CreateCheckInDocumentCommand As CheckInDocument
public:
CheckInDocument^ CreateCheckInDocumentCommand()
member CreateCheckInDocumentCommand : unit -> CheckInDocument

Valore di ritorno

CheckInDocument
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateCheckInStrutturaDocumentCommand

Metodo DedNetApplicationCreateCheckInStrutturaDocumentCommand
Crea un nuovo comando di Check-In. Effettua la pubblicazione del documento e poi lo mette in Check-In.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public CheckInDocument CreateCheckInStrutturaDocumentCommand()
Public Function CreateCheckInStrutturaDocumentCommand As CheckInDocument
public:
CheckInDocument^ CreateCheckInStrutturaDocumentCommand()
member CreateCheckInStrutturaDocumentCommand : unit -> CheckInDocument

Valore di ritorno

CheckInDocument
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateCheckOutCommand

Metodo DedNetApplicationCreateCheckOutCommand
Crea un nuovo comando CheckOut. Scarica dal vault il documento, lo copia in locale e lo imposta in CheckOut.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public CheckOutDocument CreateCheckOutCommand()
Public Function CreateCheckOutCommand As CheckOutDocument
public:
CheckOutDocument^ CreateCheckOutCommand()
member CreateCheckOutCommand : unit -> CheckOutDocument

Valore di ritorno

CheckOutDocument
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateCheckOutStrutturaCommand

Metodo DedNetApplicationCreateCheckOutStrutturaCommand
Crea un nuovo comando CheckOut. Scarica dal vault il documento, lo copia in locale e lo imposta in CheckOut.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public CheckOutDocument CreateCheckOutStrutturaCommand()
Public Function CreateCheckOutStrutturaCommand As CheckOutDocument
public:
CheckOutDocument^ CreateCheckOutStrutturaCommand()
member CreateCheckOutStrutturaCommand : unit -> CheckOutDocument

Valore di ritorno

CheckOutDocument
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateChmHelpCommand

Metodo DedNetApplicationCreateChmHelpCommand
Crea un nuovo comando Help.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ChmHelpCommand CreateChmHelpCommand()
Public Function CreateChmHelpCommand As ChmHelpCommand
public:
ChmHelpCommand^ CreateChmHelpCommand()
member CreateChmHelpCommand : unit -> ChmHelpCommand

Valore di ritorno

ChmHelpCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateChoseFileForm

Metodo DedNetApplicationCreateChoseFileForm
Crea e restituisce la finestra di selezione del tipo di file.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormChoseFile CreateChoseFileForm(
    bool comm = false
)
Public Function CreateChoseFileForm (
    Optional comm As Boolean = false
) As DedFormChoseFile
public:
DedFormChoseFile^ CreateChoseFileForm(
    bool comm = false
)
member CreateChoseFileForm :
        ?comm : bool
(* Defaults:
        let _comm = defaultArg comm false
*)
-> DedFormChoseFile

Parametri

comm Boolean (Optional)

Valore di ritorno

DedFormChoseFile
Restituisce il form.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateCloseCommCommand

Metodo DedNetApplicationCreateCloseCommCommand
Crea un nuovo comando per l'eliminazione di una commessa.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommand CreateCloseCommCommand()
Public Function CreateCloseCommCommand As DedCommand
public:
DedCommand^ CreateCloseCommCommand()
member CreateCloseCommCommand : unit -> DedCommand

Valore di ritorno

DedCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateComm

Metodo DedNetApplicationCreateComm
Crea e restituisce un nuova commessa avente il nome specificato. Imposta già la data attuale e l'utente di creazione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedComm CreateComm(
    string name,
    string dbpath = "!DEFAULT",
    DedCommCommKindEnum commKind = DedCommCommKindEnum.Normal
)
Public Function CreateComm (
    name As String,
    Optional dbpath As String = "!DEFAULT",
    Optional commKind As DedCommCommKindEnum = DedCommCommKindEnum.Normal
) As DedComm
public:
DedComm^ CreateComm(
    String^ name,
    String^ dbpath = L"!DEFAULT",
    DedCommCommKindEnum commKind = DedCommCommKindEnum::Normal
)
member CreateComm :
        name : string *
        ?dbpath : string *
        ?commKind : DedCommCommKindEnum
(* Defaults:
        let _dbpath = defaultArg dbpath "!DEFAULT"
        let _commKind = defaultArg commKind DedCommCommKindEnum.Normal
*)
-> DedComm

Parametri

name String
Nome univoco da utilizzare per la commessa.
dbpath String (Optional)
commKind DedCommCommKindEnum (Optional)

Valore di ritorno

DedComm
Eccezioni
Eccezione | Condizione
ArgumentNullException | Parametro mancante.
QsException | Errore avvenuto durante l'istruzione d'inserimento.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateCommAnagrViewCommand

Metodo DedNetApplicationCreateCommAnagrViewCommand
Crea un nuovo comando DedCommEdit che mostra all'utente il form di editazione delle commesse.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public CommEditCommand CreateCommAnagrViewCommand()
Public Function CreateCommAnagrViewCommand As CommEditCommand
public:
CommEditCommand^ CreateCommAnagrViewCommand()
member CreateCommAnagrViewCommand : unit -> CommEditCommand

Valore di ritorno

CommEditCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateCommEditCommand

Metodo DedNetApplicationCreateCommEditCommand
Crea un nuovo comando DedCommEdit che mostra all'utente il form di editazione delle commesse.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public CommEditCommand CreateCommEditCommand()
Public Function CreateCommEditCommand As CommEditCommand
public:
CommEditCommand^ CreateCommEditCommand()
member CreateCommEditCommand : unit -> CommEditCommand

Valore di ritorno

CommEditCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateCommEsplCommand

Metodo DedNetApplicationCreateCommEsplCommand
Crea un nuovo comando per la visualizzazione della distinta esplosa di una commessa.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public CommEsplCommand CreateCommEsplCommand()
Public Function CreateCommEsplCommand As CommEsplCommand
public:
CommEsplCommand^ CreateCommEsplCommand()
member CreateCommEsplCommand : unit -> CommEsplCommand

Valore di ritorno

CommEsplCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateCommViewCommand

Metodo DedNetApplicationCreateCommViewCommand
Crea un nuovo comando DedCommEdit che mostra all'utente il form di editazione delle commesse.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public CommEditCommand CreateCommViewCommand()
Public Function CreateCommViewCommand As CommEditCommand
public:
CommEditCommand^ CreateCommViewCommand()
member CreateCommViewCommand : unit -> CommEditCommand

Valore di ritorno

CommEditCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateCopyDocumentCommand

Metodo DedNetApplicationCreateCopyDocumentCommand
Crea un nuovo comando MoveDocument per rinominare/spostare i documenti. E' disponibile solo negli allegati.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public CopyDocument CreateCopyDocumentCommand()
Public Function CreateCopyDocumentCommand As CopyDocument
public:
CopyDocument^ CreateCopyDocumentCommand()
member CreateCopyDocumentCommand : unit -> CopyDocument

Valore di ritorno

CopyDocument
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateCreateEditSparePartsAttributesCommand

Metodo DedNetApplicationCreateCreateEditSparePartsAttributesCommand
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | CreateCreateEditSparePartsAttributesCommand | Crea un nuovo comando CreateSparePartsDrawingCommand.
Metodo pubblico | CreateCreateEditSparePartsAttributesCommand(CommandContextEnum) | Crea un nuovo comando CreateSparePartsDrawingCommand.
Torna su
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateCreateEditSparePartsAttributesCommand

Metodo DedNetApplicationCreateCreateEditSparePartsAttributesCommand
Crea un nuovo comando CreateSparePartsDrawingCommand.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public CreateEditSparePartsAttributesCommand CreateCreateEditSparePartsAttributesCommand()
Public Function CreateCreateEditSparePartsAttributesCommand As CreateEditSparePartsAttributesCommand
public:
CreateEditSparePartsAttributesCommand^ CreateCreateEditSparePartsAttributesCommand()
member CreateCreateEditSparePartsAttributesCommand : unit -> CreateEditSparePartsAttributesCommand

Valore di ritorno

CreateEditSparePartsAttributesCommand
Vedi anche

Documentazione

Classe DedNetApplication
Overload di CreateCreateEditSparePartsAttributesCommand
Namespace DedNet


Metodo DedNetApplication.CreateCreateEditSparePartsAttributesCommand(CommandContextEnum)

Metodo DedNetApplicationCreateCreateEditSparePartsAttributesCommand(CommandContextEnum)
Crea un nuovo comando CreateSparePartsDrawingCommand.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public CreateEditSparePartsAttributesCommand CreateCreateEditSparePartsAttributesCommand(
    CommandContextEnum cntx
)
Public Function CreateCreateEditSparePartsAttributesCommand (
    cntx As CommandContextEnum
) As CreateEditSparePartsAttributesCommand
public:
CreateEditSparePartsAttributesCommand^ CreateCreateEditSparePartsAttributesCommand(
    CommandContextEnum cntx
)
member CreateCreateEditSparePartsAttributesCommand :
        cntx : CommandContextEnum -> CreateEditSparePartsAttributesCommand

Parametri

cntx CommandContextEnum

Valore di ritorno

CreateEditSparePartsAttributesCommand
Vedi anche

Documentazione

Classe DedNetApplication
Overload di CreateCreateEditSparePartsAttributesCommand
Namespace DedNet


Metodo DedNetApplication.CreateCreateFolderCommand

Metodo DedNetApplicationCreateCreateFolderCommand
Crea un nuovo comando Crea cartella. Crea una cartella.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public CreateFolder CreateCreateFolderCommand()
Public Function CreateCreateFolderCommand As CreateFolder
public:
CreateFolder^ CreateCreateFolderCommand()
member CreateCreateFolderCommand : unit -> CreateFolder

Valore di ritorno

CreateFolder
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateCreateManualCommand

Metodo DedNetApplicationCreateCreateManualCommand
Crea un nuovo comando 'CreateSparePartsManualCommand'.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public CreateManualCommand CreateCreateManualCommand()
Public Function CreateCreateManualCommand As CreateManualCommand
public:
CreateManualCommand^ CreateCreateManualCommand()
member CreateCreateManualCommand : unit -> CreateManualCommand

Valore di ritorno

CreateManualCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateCreateSparePartsDrawingCommand

Metodo DedNetApplicationCreateCreateSparePartsDrawingCommand
Crea un nuovo comando CreateSparePartsDrawingCommand.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public CreateSparePartsDrawingCommand CreateCreateSparePartsDrawingCommand()
Public Function CreateCreateSparePartsDrawingCommand As CreateSparePartsDrawingCommand
public:
CreateSparePartsDrawingCommand^ CreateCreateSparePartsDrawingCommand()
member CreateCreateSparePartsDrawingCommand : unit -> CreateSparePartsDrawingCommand

Valore di ritorno

CreateSparePartsDrawingCommand
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateDataStatisticsAnalyzer

Metodo DedNetApplicationCreateDataStatisticsAnalyzer
Crea un nuovo comando FindInRicercaCommand che permette di aprire la ricerca con selezionata l'anagrafica associata all'anagrafica o al documento selezionato.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DataStatisticsAnalyzer CreateDataStatisticsAnalyzer()
Public Function CreateDataStatisticsAnalyzer As DataStatisticsAnalyzer
public:
DataStatisticsAnalyzer^ CreateDataStatisticsAnalyzer()
member CreateDataStatisticsAnalyzer : unit -> DataStatisticsAnalyzer

Valore di ritorno

DataStatisticsAnalyzer
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateDbDocCompareCommand

Metodo DedNetApplicationCreateDbDocCompareCommand
Crea un nuovo comando DbDocCompareCommand che mostra le differenze tra due anagrafiche.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DbDocCompareCommand CreateDbDocCompareCommand()
Public Function CreateDbDocCompareCommand As DbDocCompareCommand
public:
DbDocCompareCommand^ CreateDbDocCompareCommand()
member CreateDbDocCompareCommand : unit -> DbDocCompareCommand

Valore di ritorno

DbDocCompareCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateDbDocCompareForm

Metodo DedNetApplicationCreateDbDocCompareForm
Creazione del form di comparazione anagrafiche.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormDbDocCompare CreateDbDocCompareForm(
    DedFormDbDocCompareListRowObjetc diffList,
    IDedData dataResult,
    List<string> requiredAttr
)
Public Function CreateDbDocCompareForm (
    diffList As DedFormDbDocCompareListRowObjetc,
    dataResult As IDedData,
    requiredAttr As List(Of String)
) As DedFormDbDocCompare
public:
DedFormDbDocCompare^ CreateDbDocCompareForm(
    DedFormDbDocCompareListRowObjetc^ diffList,
    IDedData^ dataResult,
    List<String^>^ requiredAttr
)
member CreateDbDocCompareForm :
        diffList : DedFormDbDocCompareListRowObjetc *
        dataResult : IDedData *
        requiredAttr : List<string> -> DedFormDbDocCompare

Parametri

diffList DedFormDbDocCompareListRowObjetc
Lista delle differenze.
dataResult IDedData
Lista dei risultati di default.
requiredAttr List String

Valore di ritorno

DedFormDbDocCompare
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateDbVersionCommand

Metodo DedNetApplicationCreateDbVersionCommand
Crea un nuovo comando DbVersionCommand. Permesso minimo di READ in modo che venga visualizzato anche se l'utente non lo può eseguire, utile nel caso in cui venga usato il comando login con un altro utente.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DbVersionCommand CreateDbVersionCommand()
Public Function CreateDbVersionCommand As DbVersionCommand
public:
DbVersionCommand^ CreateDbVersionCommand()
member CreateDbVersionCommand : unit -> DbVersionCommand

Valore di ritorno

DbVersionCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateDedAboutCommand

Metodo DedNetApplicationCreateDedAboutCommand
Crea un nuovo comando Help.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAboutCommand CreateDedAboutCommand()
Public Function CreateDedAboutCommand As DedAboutCommand
public:
DedAboutCommand^ CreateDedAboutCommand()
member CreateDedAboutCommand : unit -> DedAboutCommand

Valore di ritorno

DedAboutCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateDedListEditCommand

Metodo DedNetApplicationCreateDedListEditCommand
Crea un nuovo comando di InsertDocumentToPrint

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedListEditCommand CreateDedListEditCommand()
Public Function CreateDedListEditCommand As DedListEditCommand
public:
DedListEditCommand^ CreateDedListEditCommand()
member CreateDedListEditCommand : unit -> DedListEditCommand

Valore di ritorno

DedListEditCommand
Restituisce il comando
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateDedListManagerCommand

Metodo DedNetApplicationCreateDedListManagerCommand
Crea un nuovo comando GEstore Liste.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedListManagerCommand CreateDedListManagerCommand()
Public Function CreateDedListManagerCommand As DedListManagerCommand
public:
DedListManagerCommand^ CreateDedListManagerCommand()
member CreateDedListManagerCommand : unit -> DedListManagerCommand

Valore di ritorno

DedListManagerCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateDedRuleApplier

Metodo DedNetApplicationCreateDedRuleApplier
Crea e restituisce un oggetto che si occupa di applicare le regole di auto-composizione su di una parte cioè un oggetto che implementa IDedData.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedRuleApplier CreateDedRuleApplier(
    DedTypeBase fam,
    bool alsoIfEmpty,
    bool asInDb
)
Public Function CreateDedRuleApplier (
    fam As DedTypeBase,
    alsoIfEmpty As Boolean,
    asInDb As Boolean
) As DedRuleApplier
public:
DedRuleApplier^ CreateDedRuleApplier(
    DedTypeBase^ fam,
    bool alsoIfEmpty,
    bool asInDb
)
member CreateDedRuleApplier :
        fam : DedTypeBase *
        alsoIfEmpty : bool *
        asInDb : bool -> DedRuleApplier

Parametri

fam DedTypeBase
Famiglia dalla quale prendere le regole di autocomposizione.
alsoIfEmpty Boolean
Applica la regola anche se il risultato è stringa vuota.
asInDb Boolean
Considera l'anagrafica presente nel Database anche se non la è.

Valore di ritorno

DedRuleApplier
Restituisce un nuovo oggetto creato.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateDefFileNameForm

Metodo DedNetApplicationCreateDefFileNameForm
Creazione del form definizione dei nomi file.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormDefFileName CreateDefFileNameForm(
    Dictionary<DocStructInfo, string> dizInfo
)
Public Function CreateDefFileNameForm (
    dizInfo As Dictionary(Of DocStructInfo, String)
) As DedFormDefFileName
public:
DedFormDefFileName^ CreateDefFileNameForm(
    Dictionary<DocStructInfo^, String^>^ dizInfo
)
member CreateDefFileNameForm :
        dizInfo : Dictionary<DocStructInfo, string> -> DedFormDefFileName

Parametri

dizInfo Dictionary DocStructInfo, String
Dizionario contenente gli abbinamenti tra informazioni documento e nome file da utilizzare nell'importazione. Il nome file deve essere senza percorso ma compreso di estensione.

Valore di ritorno

DedFormDefFileName
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateDeleteAnagrCommCommand

Metodo DedNetApplicationCreateDeleteAnagrCommCommand
Crea un nuovo comando per l'eliminazione di anagrafiche di commessa.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommand CreateDeleteAnagrCommCommand()
Public Function CreateDeleteAnagrCommCommand As DedCommand
public:
DedCommand^ CreateDeleteAnagrCommCommand()
member CreateDeleteAnagrCommCommand : unit -> DedCommand

Valore di ritorno

DedCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateDeleteCommCommand

Metodo DedNetApplicationCreateDeleteCommCommand
Crea un nuovo comando per l'eliminazione di una commessa.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DeleteCommCommand CreateDeleteCommCommand()
Public Function CreateDeleteCommCommand As DeleteCommCommand
public:
DeleteCommCommand^ CreateDeleteCommCommand()
member CreateDeleteCommCommand : unit -> DeleteCommCommand

Valore di ritorno

DeleteCommCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateDeleteDataCommand

Metodo DedNetApplicationCreateDeleteDataCommand
Crea un nuovo comando che chiede all'utente se vuole eliminare l'anagrafica.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DeleteDataCommand CreateDeleteDataCommand()
Public Function CreateDeleteDataCommand As DeleteDataCommand
public:
DeleteDataCommand^ CreateDeleteDataCommand()
member CreateDeleteDataCommand : unit -> DeleteDataCommand

Valore di ritorno

DeleteDataCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateDeleteEcoCommand

Metodo DedNetApplicationCreateDeleteEcoCommand
Crea un nuovo comando di eliminazione Eco dal database.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DeleteEcoCommand CreateDeleteEcoCommand()
Public Function CreateDeleteEcoCommand As DeleteEcoCommand
public:
DeleteEcoCommand^ CreateDeleteEcoCommand()
member CreateDeleteEcoCommand : unit -> DeleteEcoCommand

Valore di ritorno

DeleteEcoCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateDeleteFolderCommand

Metodo DedNetApplicationCreateDeleteFolderCommand
Crea un nuovo comando Elimina cartella. Elimina una cartella e tutti i suoi documenti.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DeleteFolder CreateDeleteFolderCommand()
Public Function CreateDeleteFolderCommand As DeleteFolder
public:
DeleteFolder^ CreateDeleteFolderCommand()
member CreateDeleteFolderCommand : unit -> DeleteFolder

Valore di ritorno

DeleteFolder
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateDisconnectCommDocumentCommand

Metodo DedNetApplicationCreateDisconnectCommDocumentCommand
Crea un nuovo comando DisconnectCommDocument. E' disponibile ovunque ci siano le anagrafiche ed anche siano visualizzati i documenti relativi.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DisconnectCommDocument CreateDisconnectCommDocumentCommand()
Public Function CreateDisconnectCommDocumentCommand As DisconnectCommDocument
public:
DisconnectCommDocument^ CreateDisconnectCommDocumentCommand()
member CreateDisconnectCommDocumentCommand : unit -> DisconnectCommDocument

Valore di ritorno

DisconnectCommDocument
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateDisconnectDocumentCommand

Metodo DedNetApplicationCreateDisconnectDocumentCommand
Crea un nuovo comando DisconnectDocument. E' disponibile ovunque ci siano le anagrafiche ed anche siano visualizzati i documenti relativi.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DisconnectDocument CreateDisconnectDocumentCommand()
Public Function CreateDisconnectDocumentCommand As DisconnectDocument
public:
DisconnectDocument^ CreateDisconnectDocumentCommand()
member CreateDisconnectDocumentCommand : unit -> DisconnectDocument

Valore di ritorno

DisconnectDocument
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateDistEsplCommand

Metodo DedNetApplicationCreateDistEsplCommand
Crea un nuovo comando DistEspl.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DistEsplCommand CreateDistEsplCommand()
Public Function CreateDistEsplCommand As DistEsplCommand
public:
DistEsplCommand^ CreateDistEsplCommand()
member CreateDistEsplCommand : unit -> DistEsplCommand

Valore di ritorno

DistEsplCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateDistForm

Metodo DedNetApplicationCreateDistForm
Crea e restituisce la finestra di visualizzazione distinta esplosa ed implosa.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormDist CreateDistForm()
Public Function CreateDistForm As DedFormDist
public:
DedFormDist^ CreateDistForm()
member CreateDistForm : unit -> DedFormDist

Valore di ritorno

DedFormDist
Restituisce il form.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateDistImplCommand

Metodo DedNetApplicationCreateDistImplCommand
Crea un nuovo comando DistImpl.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DistImplCommand CreateDistImplCommand()
Public Function CreateDistImplCommand As DistImplCommand
public:
DistImplCommand^ CreateDistImplCommand()
member CreateDistImplCommand : unit -> DistImplCommand

Valore di ritorno

DistImplCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateDistManager

Metodo DedNetApplicationCreateDistManager
Crea e restituisce un nuovo oggetto DistManager che si occupa della gestione della distinta.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DistManager CreateDistManager()
Public Function CreateDistManager As DistManager
public:
DistManager^ CreateDistManager()
member CreateDistManager : unit -> DistManager

Valore di ritorno

DistManager
Restituisce un nuovo oggetto DistManager.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateDistViewCommand

Metodo DedNetApplicationCreateDistViewCommand
Crea un nuovo comando BomEditCommand che mostra all'utente il form di editazione delle distente in modalità visualizzazione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomEditCommand CreateDistViewCommand()
Public Function CreateDistViewCommand As BomEditCommand
public:
BomEditCommand^ CreateDistViewCommand()
member CreateDistViewCommand : unit -> BomEditCommand

Valore di ritorno

BomEditCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateDocAssocCommand

Metodo DedNetApplicationCreateDocAssocCommand
Crea un nuovo comando DocAssocCommand.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocAssocCommand CreateDocAssocCommand()
Public Function CreateDocAssocCommand As DocAssocCommand
public:
DocAssocCommand^ CreateDocAssocCommand()
member CreateDocAssocCommand : unit -> DocAssocCommand

Valore di ritorno

DocAssocCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateDocHistoryCommand

Metodo DedNetApplicationCreateDocHistoryCommand
Crea un nuovo comando AnagrHistory che mostra all'utente la storia dell'anagrafica.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocHistoryCommand CreateDocHistoryCommand()
Public Function CreateDocHistoryCommand As DocHistoryCommand
public:
DocHistoryCommand^ CreateDocHistoryCommand()
member CreateDocHistoryCommand : unit -> DocHistoryCommand

Valore di ritorno

DocHistoryCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateDocRecognizerCommand

Metodo DedNetApplicationCreateDocRecognizerCommand
Crea nuovo comando DocRecognizerCommand

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocRecognizerCommand CreateDocRecognizerCommand()
Public Function CreateDocRecognizerCommand As DocRecognizerCommand
public:
DocRecognizerCommand^ CreateDocRecognizerCommand()
member CreateDocRecognizerCommand : unit -> DocRecognizerCommand

Valore di ritorno

DocRecognizerCommand
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateDocSearchForm

Metodo DedNetApplicationCreateDocSearchForm
Crea e restituisce la finestra di ricerca documentale.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormDocSearch CreateDocSearchForm()
Public Function CreateDocSearchForm As DedFormDocSearch
public:
DedFormDocSearch^ CreateDocSearchForm()
member CreateDocSearchForm : unit -> DedFormDocSearch

Valore di ritorno

DedFormDocSearch
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateDocTransferHistoryCommand

Metodo DedNetApplicationCreateDocTransferHistoryCommand
Crea un nuovo comando DocTransferHistoryCommand che mostra all'utente la storia dei trasferimenti del documento.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocTransferHistoryCommand CreateDocTransferHistoryCommand()
Public Function CreateDocTransferHistoryCommand As DocTransferHistoryCommand
public:
DocTransferHistoryCommand^ CreateDocTransferHistoryCommand()
member CreateDocTransferHistoryCommand : unit -> DocTransferHistoryCommand

Valore di ritorno

DocTransferHistoryCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateDocumentCommand

Metodo DedNetApplicationCreateDocumentCommand
Crea e restituisce il comando che permette di creare un documento dato il nome completo di un file. Aggiunge nel Database anche tutti i documenti da esso dipendenti.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public CreateDocument CreateDocumentCommand()
Public Function CreateDocumentCommand As CreateDocument
public:
CreateDocument^ CreateDocumentCommand()
member CreateDocumentCommand : unit -> CreateDocument

Valore di ritorno

CreateDocument
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateDuplicaRecordCommand

Metodo DedNetApplicationCreateDuplicaRecordCommand
Crea un nuovo comando SaveCommand dedicato alla duplicazione dell'anagrafica.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public SaveCommand CreateDuplicaRecordCommand()
Public Function CreateDuplicaRecordCommand As SaveCommand
public:
SaveCommand^ CreateDuplicaRecordCommand()
member CreateDuplicaRecordCommand : unit -> SaveCommand

Valore di ritorno

SaveCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateDuplicateCommCommand

Metodo DedNetApplicationCreateDuplicateCommCommand
Crea un nuovo comando per la duplicazione di una commessa.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommand CreateDuplicateCommCommand()
Public Function CreateDuplicateCommCommand As DedCommand
public:
DedCommand^ CreateDuplicateCommCommand()
member CreateDuplicateCommCommand : unit -> DedCommand

Valore di ritorno

DedCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateEcoEditCommand

Metodo DedNetApplicationCreateEcoEditCommand
Crea un nuovo comando per la visualizzazione degli Eco.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public EcoEditCommand CreateEcoEditCommand()
Public Function CreateEcoEditCommand As EcoEditCommand
public:
EcoEditCommand^ CreateEcoEditCommand()
member CreateEcoEditCommand : unit -> EcoEditCommand

Valore di ritorno

EcoEditCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateEcoHistoryCommand

Metodo DedNetApplicationCreateEcoHistoryCommand
Crea un nuovo comando EcoHistory che mostra all'utente la storia dell'eco.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public EcoHistoryCommand CreateEcoHistoryCommand()
Public Function CreateEcoHistoryCommand As EcoHistoryCommand
public:
EcoHistoryCommand^ CreateEcoHistoryCommand()
member CreateEcoHistoryCommand : unit -> EcoHistoryCommand

Valore di ritorno

EcoHistoryCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateEditAnagrCommand

Metodo DedNetApplicationCreateEditAnagrCommand
Crea un nuovo comando EditAnagr.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public EditAnagrCommand CreateEditAnagrCommand()
Public Function CreateEditAnagrCommand As EditAnagrCommand
public:
EditAnagrCommand^ CreateEditAnagrCommand()
member CreateEditAnagrCommand : unit -> EditAnagrCommand

Valore di ritorno

EditAnagrCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateEditCommCommand

Metodo DedNetApplicationCreateEditCommCommand
Crea un nuovo comando per l'eliminazione di una commessa.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public EditCommCommand CreateEditCommCommand()
Public Function CreateEditCommCommand As EditCommCommand
public:
EditCommCommand^ CreateEditCommCommand()
member CreateEditCommCommand : unit -> EditCommCommand

Valore di ritorno

EditCommCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateEditCommForm

Metodo DedNetApplicationCreateEditCommForm
Crea e restituisce la finestra per creare o modificare una commessa.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormEditComm CreateEditCommForm(
    DedEncodeInfo info,
    DedFormEditCommDedFormEditMode frmMode
)
Public Function CreateEditCommForm (
    info As DedEncodeInfo,
    frmMode As DedFormEditCommDedFormEditMode
) As DedFormEditComm
public:
DedFormEditComm^ CreateEditCommForm(
    DedEncodeInfo^ info,
    DedFormEditCommDedFormEditMode frmMode
)
member CreateEditCommForm :
        info : DedEncodeInfo *
        frmMode : DedFormEditCommDedFormEditMode -> DedFormEditComm

Parametri

info DedEncodeInfo
frmMode DedFormEditCommDedFormEditMode
Modalità di creazione, modifica, visualizzazione.

Valore di ritorno

DedFormEditComm
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateEditEcoCommand

Metodo DedNetApplicationCreateEditEcoCommand
Crea un nuovo comando per la creazione di un ECO.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public EditEcoCommand CreateEditEcoCommand()
Public Function CreateEditEcoCommand As EditEcoCommand
public:
EditEcoCommand^ CreateEditEcoCommand()
member CreateEditEcoCommand : unit -> EditEcoCommand

Valore di ritorno

EditEcoCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateEditOnlyDbAttributesCommand

Metodo DedNetApplicationCreateEditOnlyDbAttributesCommand
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | CreateEditOnlyDbAttributesCommand | Crea un nuovo comando di editazione attributi solo db con context none
Metodo pubblico | CreateEditOnlyDbAttributesCommand(CommandContextEnum) | Crea un nuovo comando CreateSparePartsDrawingCommand.
Torna su
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateEditOnlyDbAttributesCommand

Metodo DedNetApplicationCreateEditOnlyDbAttributesCommand
Crea un nuovo comando di editazione attributi solo db con context none

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public EditOnlyDbAttributesCommand CreateEditOnlyDbAttributesCommand()
Public Function CreateEditOnlyDbAttributesCommand As EditOnlyDbAttributesCommand
public:
EditOnlyDbAttributesCommand^ CreateEditOnlyDbAttributesCommand()
member CreateEditOnlyDbAttributesCommand : unit -> EditOnlyDbAttributesCommand

Valore di ritorno

EditOnlyDbAttributesCommand
Vedi anche

Documentazione

Classe DedNetApplication
Overload di CreateEditOnlyDbAttributesCommand
Namespace DedNet


Metodo DedNetApplication.CreateEditOnlyDbAttributesCommand(CommandContextEnum)

Metodo DedNetApplicationCreateEditOnlyDbAttributesCommand(CommandContextEnum)
Crea un nuovo comando CreateSparePartsDrawingCommand.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public EditOnlyDbAttributesCommand CreateEditOnlyDbAttributesCommand(
    CommandContextEnum cntx
)
Public Function CreateEditOnlyDbAttributesCommand (
    cntx As CommandContextEnum
) As EditOnlyDbAttributesCommand
public:
EditOnlyDbAttributesCommand^ CreateEditOnlyDbAttributesCommand(
    CommandContextEnum cntx
)
member CreateEditOnlyDbAttributesCommand :
        cntx : CommandContextEnum -> EditOnlyDbAttributesCommand

Parametri

cntx CommandContextEnum

Valore di ritorno

EditOnlyDbAttributesCommand
Vedi anche

Documentazione

Classe DedNetApplication
Overload di CreateEditOnlyDbAttributesCommand
Namespace DedNet


Metodo DedNetApplication.CreateEndAllActiveTimingsCommand

Metodo DedNetApplicationCreateEndAllActiveTimingsCommand
Crea un nuovo comando EndAllTimingsCommand.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public EndAllActiveTimingsCommand CreateEndAllActiveTimingsCommand()
Public Function CreateEndAllActiveTimingsCommand As EndAllActiveTimingsCommand
public:
EndAllActiveTimingsCommand^ CreateEndAllActiveTimingsCommand()
member CreateEndAllActiveTimingsCommand : unit -> EndAllActiveTimingsCommand

Valore di ritorno

EndAllActiveTimingsCommand
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateEndTimingCommand

Metodo DedNetApplicationCreateEndTimingCommand
Crea un nuovo comando EndTimingCommand.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public EndTimingCommand CreateEndTimingCommand()
Public Function CreateEndTimingCommand As EndTimingCommand
public:
EndTimingCommand^ CreateEndTimingCommand()
member CreateEndTimingCommand : unit -> EndTimingCommand

Valore di ritorno

EndTimingCommand
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateEnsureLocalDocumentCommand

Metodo DedNetApplicationCreateEnsureLocalDocumentCommand
Crea e restituisce il sotto-comando che si occupa della copia in locale del documento e delle sue dipendenze.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public EnsureLocalDocument CreateEnsureLocalDocumentCommand()
Public Function CreateEnsureLocalDocumentCommand As EnsureLocalDocument
public:
EnsureLocalDocument^ CreateEnsureLocalDocumentCommand()
member CreateEnsureLocalDocumentCommand : unit -> EnsureLocalDocument

Valore di ritorno

EnsureLocalDocument
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateEnsureLocalFolderCommand

Metodo DedNetApplicationCreateEnsureLocalFolderCommand
Crea un nuovo comando di EnsureLocalFolder.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public EnsureLocalFolder CreateEnsureLocalFolderCommand()
Public Function CreateEnsureLocalFolderCommand As EnsureLocalFolder
public:
EnsureLocalFolder^ CreateEnsureLocalFolderCommand()
member CreateEnsureLocalFolderCommand : unit -> EnsureLocalFolder

Valore di ritorno

EnsureLocalFolder
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateEnsureLocalFolderStructureCommand

Metodo DedNetApplicationCreateEnsureLocalFolderStructureCommand
Crea un nuovo comando di EnsureLocalFolder.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public EnsureLocalFolder CreateEnsureLocalFolderStructureCommand()
Public Function CreateEnsureLocalFolderStructureCommand As EnsureLocalFolder
public:
EnsureLocalFolder^ CreateEnsureLocalFolderStructureCommand()
member CreateEnsureLocalFolderStructureCommand : unit -> EnsureLocalFolder

Valore di ritorno

EnsureLocalFolder
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateExportCommand

Metodo DedNetApplicationCreateExportCommand
Crea un nuovo comando ExportCommand.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ExportCommand CreateExportCommand()
Public Function CreateExportCommand As ExportCommand
public:
ExportCommand^ CreateExportCommand()
member CreateExportCommand : unit -> ExportCommand

Valore di ritorno

ExportCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateExportDocumentCommand

Metodo DedNetApplicationCreateExportDocumentCommand
Crea un nuovo comando di Esportazione documento. Effettua la copia del documento in una destinazione libera e se necessario lo pone in checkout.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ExportDocument CreateExportDocumentCommand()
Public Function CreateExportDocumentCommand As ExportDocument
public:
ExportDocument^ CreateExportDocumentCommand()
member CreateExportDocumentCommand : unit -> ExportDocument

Valore di ritorno

ExportDocument
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateFileZipCommand

Metodo DedNetApplicationCreateFileZipCommand
Crea un nuovo comando FileZip che chiede all'utente dove vuole archiviare i documenti selezionati.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public FileZip CreateFileZipCommand()
Public Function CreateFileZipCommand As FileZip
public:
FileZip^ CreateFileZipCommand()
member CreateFileZipCommand : unit -> FileZip

Valore di ritorno

FileZip
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateFileZipStructCommand

Metodo DedNetApplicationCreateFileZipStructCommand
Crea un nuovo comando FileZipStruct che chiede all'utente dove vuole archiviare i documenti selezionati.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public FileZipStruct CreateFileZipStructCommand()
Public Function CreateFileZipStructCommand As FileZipStruct
public:
FileZipStruct^ CreateFileZipStructCommand()
member CreateFileZipStructCommand : unit -> FileZipStruct

Valore di ritorno

FileZipStruct
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateFillDedDataEncodeTableCommand

Metodo DedNetApplicationCreateFillDedDataEncodeTableCommand
Crea un nuovo comando per ricercare i documenti.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public FillDedDataEncodeTableCommand CreateFillDedDataEncodeTableCommand()
Public Function CreateFillDedDataEncodeTableCommand As FillDedDataEncodeTableCommand
public:
FillDedDataEncodeTableCommand^ CreateFillDedDataEncodeTableCommand()
member CreateFillDedDataEncodeTableCommand : unit -> FillDedDataEncodeTableCommand

Valore di ritorno

FillDedDataEncodeTableCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateFindCodeCommand

Metodo DedNetApplicationCreateFindCodeCommand
Crea un nuovo comando FindCode che visualizza la finestra di dialogo di ricerca codice con preselezionato un comando.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public FindCodeCommand CreateFindCodeCommand(
    DedCommand defaultCommand
)
Public Function CreateFindCodeCommand (
    defaultCommand As DedCommand
) As FindCodeCommand
public:
FindCodeCommand^ CreateFindCodeCommand(
    DedCommand^ defaultCommand
)
member CreateFindCodeCommand :
        defaultCommand : DedCommand -> FindCodeCommand

Parametri

defaultCommand DedCommand
Oggetto command di default sul pulsante principale.

Valore di ritorno

FindCodeCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateFindCodeForm

Metodo DedNetApplicationCreateFindCodeForm
Crea e restituisce la finestra di ricerca veloce codice.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormFindCode CreateFindCodeForm()
Public Function CreateFindCodeForm As DedFormFindCode
public:
DedFormFindCode^ CreateFindCodeForm()
member CreateFindCodeForm : unit -> DedFormFindCode

Valore di ritorno

DedFormFindCode
Restituisce il form.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateFindCommand

Metodo DedNetApplicationCreateFindCommand
Crea un nuovo comando Ricerca.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public FindCommand CreateFindCommand()
Public Function CreateFindCommand As FindCommand
public:
FindCommand^ CreateFindCommand()
member CreateFindCommand : unit -> FindCommand

Valore di ritorno

FindCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateFindDataDocCommand

Metodo DedNetApplicationCreateFindDataDocCommand
Crea un nuovo comando per ricercare i documenti.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public FindDataDocCommand CreateFindDataDocCommand()
Public Function CreateFindDataDocCommand As FindDataDocCommand
public:
FindDataDocCommand^ CreateFindDataDocCommand()
member CreateFindDataDocCommand : unit -> FindDataDocCommand

Valore di ritorno

FindDataDocCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateFindDocCommand

Metodo DedNetApplicationCreateFindDocCommand
Crea un nuovo comando per ricercare i documenti.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public FindDocCommand CreateFindDocCommand()
Public Function CreateFindDocCommand As FindDocCommand
public:
FindDocCommand^ CreateFindDocCommand()
member CreateFindDocCommand : unit -> FindDocCommand

Valore di ritorno

FindDocCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateFindInRicercaCommand

Metodo DedNetApplicationCreateFindInRicercaCommand
Crea un nuovo comando FindInRicercaCommand che permette di aprire la ricerca con selezionata l'anagrafica associata all'anagrafica o al documento selezionato.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public FindInRicercaCommand CreateFindInRicercaCommand()
Public Function CreateFindInRicercaCommand As FindInRicercaCommand
public:
FindInRicercaCommand^ CreateFindInRicercaCommand()
member CreateFindInRicercaCommand : unit -> FindInRicercaCommand

Valore di ritorno

FindInRicercaCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateForceMarkerAlingmentCommand

Metodo DedNetApplicationCreateForceMarkerAlingmentCommand
Crea un nuovo comando ForceMarkerAlingment.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ForceMarkerAlingmentCommand CreateForceMarkerAlingmentCommand()
Public Function CreateForceMarkerAlingmentCommand As ForceMarkerAlingmentCommand
public:
ForceMarkerAlingmentCommand^ CreateForceMarkerAlingmentCommand()
member CreateForceMarkerAlingmentCommand : unit -> ForceMarkerAlingmentCommand

Valore di ritorno

ForceMarkerAlingmentCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateFormDocHistory

Metodo DedNetApplicationCreateFormDocHistory
Crea e restituisce la finestra di dialogo utilizzata per il comando Storia documento.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormDocHistory CreateFormDocHistory(
    DedDoc doc
)
Public Function CreateFormDocHistory (
    doc As DedDoc
) As DedFormDocHistory
public:
DedFormDocHistory^ CreateFormDocHistory(
    DedDoc^ doc
)
member CreateFormDocHistory :
        doc : DedDoc -> DedFormDocHistory

Parametri

doc DedDoc
Documento del quale si vuole ottenenre dove è usato.

Valore di ritorno

DedFormDocHistory
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateFormDocTransferHistory

Metodo DedNetApplicationCreateFormDocTransferHistory
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | CreateFormDocTransferHistory(Boolean) | Crea e restituisce la finestra di dialogo utilizzata per il comando Storia di tutti i trasferimenti
Metodo pubblico | CreateFormDocTransferHistory(DedDoc) | Crea e restituisce la finestra di dialogo utilizzata per il comando Storia trasferimenti documento.
Torna su
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateFormDocTransferHistory(Boolean)

Metodo DedNetApplicationCreateFormDocTransferHistory(Boolean)
Crea e restituisce la finestra di dialogo utilizzata per il comando Storia di tutti i trasferimenti

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormDocTransferHistory CreateFormDocTransferHistory(
    bool allTransfer
)
Public Function CreateFormDocTransferHistory (
    allTransfer As Boolean
) As DedFormDocTransferHistory
public:
DedFormDocTransferHistory^ CreateFormDocTransferHistory(
    bool allTransfer
)
member CreateFormDocTransferHistory :
        allTransfer : bool -> DedFormDocTransferHistory

Parametri

allTransfer Boolean
Indica se visualizzare la storia di tutti i transfer packet

Valore di ritorno

DedFormDocTransferHistory
Vedi anche

Documentazione

Classe DedNetApplication
Overload di CreateFormDocTransferHistory
Namespace DedNet


Metodo DedNetApplication.CreateFormDocTransferHistory(DedDoc)

Metodo DedNetApplicationCreateFormDocTransferHistory(DedDoc)
Crea e restituisce la finestra di dialogo utilizzata per il comando Storia trasferimenti documento.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormDocTransferHistory CreateFormDocTransferHistory(
    DedDoc doc
)
Public Function CreateFormDocTransferHistory (
    doc As DedDoc
) As DedFormDocTransferHistory
public:
DedFormDocTransferHistory^ CreateFormDocTransferHistory(
    DedDoc^ doc
)
member CreateFormDocTransferHistory :
        doc : DedDoc -> DedFormDocTransferHistory

Parametri

doc DedDoc
Documento del quale si vuole ottenenre dove è usato.

Valore di ritorno

DedFormDocTransferHistory
Vedi anche

Documentazione

Classe DedNetApplication
Overload di CreateFormDocTransferHistory
Namespace DedNet


Metodo DedNetApplication.CreateFormFindDoc

Metodo DedNetApplicationCreateFormFindDoc
Crea e restituisce la finestra di dialogo utilizzata per ricercare i documeneti.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormDocSearch CreateFormFindDoc()
Public Function CreateFormFindDoc As DedFormDocSearch
public:
DedFormDocSearch^ CreateFormFindDoc()
member CreateFormFindDoc : unit -> DedFormDocSearch

Valore di ritorno

DedFormDocSearch
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateFormWhereUsed

Metodo DedNetApplicationCreateFormWhereUsed
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | CreateFormWhereUsed(DedDoc) | Crea e restituisce la finestra di dialogo utilizzata per il comando Where Used.
Metodo pubblico | CreateFormWhereUsed(DedDoc, Boolean) | Crea e restituisce la finestra di dialogo utilizzata per il comando Where Used.
Metodo pubblico | CreateFormWhereUsed(DedDocList, Boolean) | Crea e restituisce la finestra di dialogo utilizzata per il comando Apri File Associati.
Metodo pubblico | CreateFormWhereUsed(DedDoc, String, Boolean) | Crea e restituisce la finestra di dialogo utilizzata per il comando Where Used.
Torna su
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateFormWhereUsed(DedDoc)

Metodo DedNetApplicationCreateFormWhereUsed(DedDoc)
Crea e restituisce la finestra di dialogo utilizzata per il comando Where Used.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormWhereUsed CreateFormWhereUsed(
    DedDoc doc
)
Public Function CreateFormWhereUsed (
    doc As DedDoc
) As DedFormWhereUsed
public:
DedFormWhereUsed^ CreateFormWhereUsed(
    DedDoc^ doc
)
member CreateFormWhereUsed :
        doc : DedDoc -> DedFormWhereUsed

Parametri

doc DedDoc
Documento del quale si vuole ottenenre dove è usato.

Valore di ritorno

DedFormWhereUsed
Vedi anche

Documentazione

Classe DedNetApplication
Overload di CreateFormWhereUsed
Namespace DedNet


Metodo DedNetApplication.CreateFormWhereUsed(DedDoc, Boolean)

Metodo DedNetApplicationCreateFormWhereUsed(DedDoc, Boolean)
Crea e restituisce la finestra di dialogo utilizzata per il comando Where Used.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormWhereUsed CreateFormWhereUsed(
    DedDoc doc,
    bool showExtraData
)
Public Function CreateFormWhereUsed (
    doc As DedDoc,
    showExtraData As Boolean
) As DedFormWhereUsed
public:
DedFormWhereUsed^ CreateFormWhereUsed(
    DedDoc^ doc,
    bool showExtraData
)
member CreateFormWhereUsed :
        doc : DedDoc *
        showExtraData : bool -> DedFormWhereUsed

Parametri

doc DedDoc
Documento del quale si vuole ottenenre dove è usato.
showExtraData Boolean
Indica se visualizzare o meno i dati delle anagrafiche associate ai documenti.

Valore di ritorno

DedFormWhereUsed
Vedi anche

Documentazione

Classe DedNetApplication
Overload di CreateFormWhereUsed
Namespace DedNet


Metodo DedNetApplication.CreateFormWhereUsed(DedDocList, Boolean)

Metodo DedNetApplicationCreateFormWhereUsed(DedDocList, Boolean)
Crea e restituisce la finestra di dialogo utilizzata per il comando Apri File Associati.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormWhereUsed CreateFormWhereUsed(
    DedDocList docs,
    bool attach = false
)
Public Function CreateFormWhereUsed (
    docs As DedDocList,
    Optional attach As Boolean = false
) As DedFormWhereUsed
public:
DedFormWhereUsed^ CreateFormWhereUsed(
    DedDocList^ docs,
    bool attach = false
)
member CreateFormWhereUsed :
        docs : DedDocList *
        ?attach : bool
(* Defaults:
        let _attach = defaultArg attach false
*)
-> DedFormWhereUsed

Parametri

docs DedDocList
Lista dei documenti del quale chiedere la selezione dei file associati.
attach Boolean (Optional)

Valore di ritorno

DedFormWhereUsed
Vedi anche

Documentazione

Classe DedNetApplication
Overload di CreateFormWhereUsed
Namespace DedNet


Metodo DedNetApplication.CreateFormWhereUsed(DedDoc, String, Boolean)

Metodo DedNetApplicationCreateFormWhereUsed(DedDoc, String, Boolean)
Crea e restituisce la finestra di dialogo utilizzata per il comando Where Used.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormWhereUsed CreateFormWhereUsed(
    DedDoc doc,
    string config,
    bool showExtraData
)
Public Function CreateFormWhereUsed (
    doc As DedDoc,
    config As String,
    showExtraData As Boolean
) As DedFormWhereUsed
public:
DedFormWhereUsed^ CreateFormWhereUsed(
    DedDoc^ doc,
    String^ config,
    bool showExtraData
)
member CreateFormWhereUsed :
        doc : DedDoc *
        config : string *
        showExtraData : bool -> DedFormWhereUsed

Parametri

doc DedDoc
Documento del quale si vuole ottenenre dove è usato.
config String
Nome del model state attivo
showExtraData Boolean
Indica se visualizzare o meno i dati delle anagrafiche associate ai documenti.

Valore di ritorno

DedFormWhereUsed
Vedi anche

Documentazione

Classe DedNetApplication
Overload di CreateFormWhereUsed
Namespace DedNet


Metodo DedNetApplication.CreateForzaCheckInDocumentCommand

Metodo DedNetApplicationCreateForzaCheckInDocumentCommand
Crea un nuovo comando di Forza Check-In. Mette in Check-In il documento senza copiarlo nel server.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ForzaCheckInDocument CreateForzaCheckInDocumentCommand()
Public Function CreateForzaCheckInDocumentCommand As ForzaCheckInDocument
public:
ForzaCheckInDocument^ CreateForzaCheckInDocumentCommand()
member CreateForzaCheckInDocumentCommand : unit -> ForzaCheckInDocument

Valore di ritorno

ForzaCheckInDocument
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateImportCommDocumentCommand

Metodo DedNetApplicationCreateImportCommDocumentCommand
Crea un nuovo comando ImportCommDocument. E' disponibile nel controllo dei documenti associati alle commesse.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ImportCommDocument CreateImportCommDocumentCommand()
Public Function CreateImportCommDocumentCommand As ImportCommDocument
public:
ImportCommDocument^ CreateImportCommDocumentCommand()
member CreateImportCommDocumentCommand : unit -> ImportCommDocument

Valore di ritorno

ImportCommDocument
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateImportCommFilesCommand

Metodo DedNetApplicationCreateImportCommFilesCommand
Crea un nuovo comando ImportCommDocument. E' disponibile nel controllo dei documenti associati alle commesse.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ImportCommDocument CreateImportCommFilesCommand()
Public Function CreateImportCommFilesCommand As ImportCommDocument
public:
ImportCommDocument^ CreateImportCommFilesCommand()
member CreateImportCommFilesCommand : unit -> ImportCommDocument

Valore di ritorno

ImportCommDocument
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateImportDocsCommand

Metodo DedNetApplicationCreateImportDocsCommand
Crea un nuovo comando ImportDocument. E' disponibile ovunque ci siano le anagrafiche ed anche siano visualizzati i documenti relativi (anche il FindCodeForm).

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ImportDocument CreateImportDocsCommand()
Public Function CreateImportDocsCommand As ImportDocument
public:
ImportDocument^ CreateImportDocsCommand()
member CreateImportDocsCommand : unit -> ImportDocument

Valore di ritorno

ImportDocument
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateImportEcoFilesCommand

Metodo DedNetApplicationCreateImportEcoFilesCommand
Crea un nuovo comando ImportEcoFiles. E' disponibile nel dialogo degli Eco.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ImportEcoFiles CreateImportEcoFilesCommand()
Public Function CreateImportEcoFilesCommand As ImportEcoFiles
public:
ImportEcoFiles^ CreateImportEcoFilesCommand()
member CreateImportEcoFilesCommand : unit -> ImportEcoFiles

Valore di ritorno

ImportEcoFiles
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateImporterCommand

Metodo DedNetApplicationCreateImporterCommand
Crea un nuovo comando MarkerInfo.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ImporterCommand CreateImporterCommand()
Public Function CreateImporterCommand As ImporterCommand
public:
ImporterCommand^ CreateImporterCommand()
member CreateImporterCommand : unit -> ImporterCommand

Valore di ritorno

ImporterCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateImportFilesCommand

Metodo DedNetApplicationCreateImportFilesCommand
Crea un nuovo comando ImportDocument. E' disponibile ovunque ci siano le anagrafiche ed anche siano visualizzati i documenti relativi (anche il FindCodeForm).

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ImportDocument CreateImportFilesCommand()
Public Function CreateImportFilesCommand As ImportDocument
public:
ImportDocument^ CreateImportFilesCommand()
member CreateImportFilesCommand : unit -> ImportDocument

Valore di ritorno

ImportDocument
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateImportSparePartDrawingCommand

Metodo DedNetApplicationCreateImportSparePartDrawingCommand
Crea un nuovo comando ImportDocument per importare documenti e impostarli con contesto 'PubblicazioneRicambio'.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ImportDocument CreateImportSparePartDrawingCommand()
Public Function CreateImportSparePartDrawingCommand As ImportDocument
public:
ImportDocument^ CreateImportSparePartDrawingCommand()
member CreateImportSparePartDrawingCommand : unit -> ImportDocument

Valore di ritorno

ImportDocument
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateImportTransferPacketCommand

Metodo DedNetApplicationCreateImportTransferPacketCommand
Crea un nuovo comando di ImportTransferPacket

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ImportTransferPacket CreateImportTransferPacketCommand()
Public Function CreateImportTransferPacketCommand As ImportTransferPacket
public:
ImportTransferPacket^ CreateImportTransferPacketCommand()
member CreateImportTransferPacketCommand : unit -> ImportTransferPacket

Valore di ritorno

ImportTransferPacket
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateLiberateCommCommand

Metodo DedNetApplicationCreateLiberateCommCommand
Crea un nuovo comando per la presa in carico di una commessa.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommand CreateLiberateCommCommand()
Public Function CreateLiberateCommCommand As DedCommand
public:
DedCommand^ CreateLiberateCommCommand()
member CreateLiberateCommCommand : unit -> DedCommand

Valore di ritorno

DedCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateLinkCommDocumentCommand

Metodo DedNetApplicationCreateLinkCommDocumentCommand
Crea un nuovo comando LinkCommDocument. E' disponibile nel controllo dei documenti associati alle commesse.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public LinkCommDocument CreateLinkCommDocumentCommand()
Public Function CreateLinkCommDocumentCommand As LinkCommDocument
public:
LinkCommDocument^ CreateLinkCommDocumentCommand()
member CreateLinkCommDocumentCommand : unit -> LinkCommDocument

Valore di ritorno

LinkCommDocument
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateLinkDocumentCommand

Metodo DedNetApplicationCreateLinkDocumentCommand
Crea un nuovo comando LinkDocument. E' disponibile ovunque ci siano le anagrafiche ed anche siano visualizzati i documenti relativi (anche il FindCodeForm).

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public LinkDocument CreateLinkDocumentCommand()
Public Function CreateLinkDocumentCommand As LinkDocument
public:
LinkDocument^ CreateLinkDocumentCommand()
member CreateLinkDocumentCommand : unit -> LinkDocument

Valore di ritorno

LinkDocument
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateLogInCommand

Metodo DedNetApplicationCreateLogInCommand
Crea un nuovo comando LogIn.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public LoginCommand CreateLogInCommand()
Public Function CreateLogInCommand As LoginCommand
public:
LoginCommand^ CreateLogInCommand()
member CreateLogInCommand : unit -> LoginCommand

Valore di ritorno

LoginCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateLogViewCommand

Metodo DedNetApplicationCreateLogViewCommand
Crea un nuovo comando LogViewCommand.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public LogViewCommand CreateLogViewCommand()
Public Function CreateLogViewCommand As LogViewCommand
public:
LogViewCommand^ CreateLogViewCommand()
member CreateLogViewCommand : unit -> LogViewCommand

Valore di ritorno

LogViewCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateMainForm

Metodo DedNetApplicationCreateMainForm
Crea e restituisce il dialogo della ricerca.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormMain CreateMainForm()
Public Function CreateMainForm As DedFormMain
public:
DedFormMain^ CreateMainForm()
member CreateMainForm : unit -> DedFormMain

Valore di ritorno

DedFormMain
Dialogo della ricerca.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateManageOperationsCommand

Metodo DedNetApplicationCreateManageOperationsCommand
Crea un nuovo comando DbVersionCommand. Permesso minimo di READ in modo che venga visualizzato anche se l'utente non lo può eseguire, utile nel caso in cui venga usato il comando login con un altro utente.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ManageOperationsCommand CreateManageOperationsCommand()
Public Function CreateManageOperationsCommand As ManageOperationsCommand
public:
ManageOperationsCommand^ CreateManageOperationsCommand()
member CreateManageOperationsCommand : unit -> ManageOperationsCommand

Valore di ritorno

ManageOperationsCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateManageRootForm

Metodo DedNetApplicationCreateManageRootForm
Crea e restituisce la finestra per editare le Root.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormManageRoot CreateManageRootForm()
Public Function CreateManageRootForm As DedFormManageRoot
public:
DedFormManageRoot^ CreateManageRootForm()
member CreateManageRootForm : unit -> DedFormManageRoot

Valore di ritorno

DedFormManageRoot
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateMarkerInfoCommand

Metodo DedNetApplicationCreateMarkerInfoCommand
Crea un nuovo comando MarkerInfo.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public MarkerInfoCommand CreateMarkerInfoCommand()
Public Function CreateMarkerInfoCommand As MarkerInfoCommand
public:
MarkerInfoCommand^ CreateMarkerInfoCommand()
member CreateMarkerInfoCommand : unit -> MarkerInfoCommand

Valore di ritorno

MarkerInfoCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateMoveAnagrCommand

Metodo DedNetApplicationCreateMoveAnagrCommand
Crea un nuovo comando MoveAnagrCommand che permette di spostare le anagrafiche in un'altra famiglia.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public MoveAnagrCommand CreateMoveAnagrCommand()
Public Function CreateMoveAnagrCommand As MoveAnagrCommand
public:
MoveAnagrCommand^ CreateMoveAnagrCommand()
member CreateMoveAnagrCommand : unit -> MoveAnagrCommand

Valore di ritorno

MoveAnagrCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateMovedEditorCommand

Metodo DedNetApplicationCreateMovedEditorCommand
Crea un nuovo comando di MovedEditorCommand.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public MovedEditorCommand CreateMovedEditorCommand()
Public Function CreateMovedEditorCommand As MovedEditorCommand
public:
MovedEditorCommand^ CreateMovedEditorCommand()
member CreateMovedEditorCommand : unit -> MovedEditorCommand

Valore di ritorno

MovedEditorCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateMoveDocumentCommand

Metodo DedNetApplicationCreateMoveDocumentCommand
Crea un nuovo comando MoveDocument per rinominare/spostare i documenti. E' disponibile solo negli allegati.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public MoveDocument CreateMoveDocumentCommand()
Public Function CreateMoveDocumentCommand As MoveDocument
public:
MoveDocument^ CreateMoveDocumentCommand()
member CreateMoveDocumentCommand : unit -> MoveDocument

Valore di ritorno

MoveDocument
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateNotifyCommand

Metodo DedNetApplicationCreateNotifyCommand
Crea un nuovo comando per ricercare i documenti.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public NotifyCommand CreateNotifyCommand()
Public Function CreateNotifyCommand As NotifyCommand
public:
NotifyCommand^ CreateNotifyCommand()
member CreateNotifyCommand : unit -> NotifyCommand

Valore di ritorno

NotifyCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateOpenAssocFilesCommand

Metodo DedNetApplicationCreateOpenAssocFilesCommand
Crea un nuovo comando OpenAssocFilesCommand (Apri file associati).

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public OpenAssocFilesCommand CreateOpenAssocFilesCommand()
Public Function CreateOpenAssocFilesCommand As OpenAssocFilesCommand
public:
OpenAssocFilesCommand^ CreateOpenAssocFilesCommand()
member CreateOpenAssocFilesCommand : unit -> OpenAssocFilesCommand

Valore di ritorno

OpenAssocFilesCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateOpenAttachFilesCommand

Metodo DedNetApplicationCreateOpenAttachFilesCommand
Crea un nuovo comando OpenAssocFilesCommand (Apri file allegati).

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public OpenAssocFilesCommand CreateOpenAttachFilesCommand()
Public Function CreateOpenAttachFilesCommand As OpenAssocFilesCommand
public:
OpenAssocFilesCommand^ CreateOpenAttachFilesCommand()
member CreateOpenAttachFilesCommand : unit -> OpenAssocFilesCommand

Valore di ritorno

OpenAssocFilesCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateOpenCommCommand

Metodo DedNetApplicationCreateOpenCommCommand
Crea un nuovo comando per l'eliminazione di una commessa.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommand CreateOpenCommCommand()
Public Function CreateOpenCommCommand As DedCommand
public:
DedCommand^ CreateOpenCommCommand()
member CreateOpenCommCommand : unit -> DedCommand

Valore di ritorno

DedCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateOpenFilePathCommand

Metodo DedNetApplicationCreateOpenFilePathCommand
Crea un nuovo comando OpenFilePathCommand che apre la cartella contenente il file selezionato.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public OpenFilePathCommand CreateOpenFilePathCommand()
Public Function CreateOpenFilePathCommand As OpenFilePathCommand
public:
OpenFilePathCommand^ CreateOpenFilePathCommand()
member CreateOpenFilePathCommand : unit -> OpenFilePathCommand

Valore di ritorno

OpenFilePathCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateOpenReadDocumentCommand

Metodo DedNetApplicationCreateOpenReadDocumentCommand
Crea un nuovo comando OpenReadDocument.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public OpenReadDocument CreateOpenReadDocumentCommand()
Public Function CreateOpenReadDocumentCommand As OpenReadDocument
public:
OpenReadDocument^ CreateOpenReadDocumentCommand()
member CreateOpenReadDocumentCommand : unit -> OpenReadDocument

Valore di ritorno

OpenReadDocument
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateOpenWriteDocumentCommand

Metodo DedNetApplicationCreateOpenWriteDocumentCommand
Crea un nuovo comando OpenWriteDocument.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public OpenWriteDocument CreateOpenWriteDocumentCommand()
Public Function CreateOpenWriteDocumentCommand As OpenWriteDocument
public:
OpenWriteDocument^ CreateOpenWriteDocumentCommand()
member CreateOpenWriteDocumentCommand : unit -> OpenWriteDocument

Valore di ritorno

OpenWriteDocument
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreatePrintDocumentCommand

Metodo DedNetApplicationCreatePrintDocumentCommand
Crea un nuovo comando di PrintDocumentCommand.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public PrintDocumentCommand CreatePrintDocumentCommand()
Public Function CreatePrintDocumentCommand As PrintDocumentCommand
public:
PrintDocumentCommand^ CreatePrintDocumentCommand()
member CreatePrintDocumentCommand : unit -> PrintDocumentCommand

Valore di ritorno

PrintDocumentCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreatePropertiesManagerCommand

Metodo DedNetApplicationCreatePropertiesManagerCommand
Crea un nuovo comando PropertiesManagerCommand.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public PropertiesManagerCommand CreatePropertiesManagerCommand()
Public Function CreatePropertiesManagerCommand As PropertiesManagerCommand
public:
PropertiesManagerCommand^ CreatePropertiesManagerCommand()
member CreatePropertiesManagerCommand : unit -> PropertiesManagerCommand

Valore di ritorno

PropertiesManagerCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreatePubblicaCommand

Metodo DedNetApplicationCreatePubblicaCommand
Crea un nuovo comando Pubblica. Effettua la copia del documento dall'area locale al vault e lo mantiene in CheckOut.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public PublishDocument CreatePubblicaCommand()
Public Function CreatePubblicaCommand As PublishDocument
public:
PublishDocument^ CreatePubblicaCommand()
member CreatePubblicaCommand : unit -> PublishDocument

Valore di ritorno

PublishDocument
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreatePubblicaStrutturaCommand

Metodo DedNetApplicationCreatePubblicaStrutturaCommand
Crea un nuovo comando Pubblica. Effettua la copia del documento dall'area locale al vault e lo mantiene in CheckOut.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public PublishDocument CreatePubblicaStrutturaCommand()
Public Function CreatePubblicaStrutturaCommand As PublishDocument
public:
PublishDocument^ CreatePubblicaStrutturaCommand()
member CreatePubblicaStrutturaCommand : unit -> PublishDocument

Valore di ritorno

PublishDocument
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreatePublicationFilesMangerCommand

Metodo DedNetApplicationCreatePublicationFilesMangerCommand
Crea un nuovo comando PublicationFilesCommand. Permesso minimo di READ in modo che venga visualizzato anche se l'utente non lo può eseguire, utile nel caso in cui venga usato il comando login con un altro utente.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public PublicationFilesMangerCommand CreatePublicationFilesMangerCommand()
Public Function CreatePublicationFilesMangerCommand As PublicationFilesMangerCommand
public:
PublicationFilesMangerCommand^ CreatePublicationFilesMangerCommand()
member CreatePublicationFilesMangerCommand : unit -> PublicationFilesMangerCommand

Valore di ritorno

PublicationFilesMangerCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreatePwsBackupCommand

Metodo DedNetApplicationCreatePwsBackupCommand
Crea un nuovo comando PwsBackup.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public PwsBackupCommand CreatePwsBackupCommand()
Public Function CreatePwsBackupCommand As PwsBackupCommand
public:
PwsBackupCommand^ CreatePwsBackupCommand()
member CreatePwsBackupCommand : unit -> PwsBackupCommand

Valore di ritorno

PwsBackupCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreatePwsCacheCommand

Metodo DedNetApplicationCreatePwsCacheCommand
Crea un nuovo comando PwsCache.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public PwsCacheCommand CreatePwsCacheCommand()
Public Function CreatePwsCacheCommand As PwsCacheCommand
public:
PwsCacheCommand^ CreatePwsCacheCommand()
member CreatePwsCacheCommand : unit -> PwsCacheCommand

Valore di ritorno

PwsCacheCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateQsManagerCommand

Metodo DedNetApplicationCreateQsManagerCommand
Crea un nuovo comando QsManagerCommand. Permesso minimo di READ in modo che venga visualizzato anche se l'utente non lo può eseguire, utile nel caso in cui venga usato il comando login con un altro utente.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QsManagerCommand CreateQsManagerCommand()
Public Function CreateQsManagerCommand As QsManagerCommand
public:
QsManagerCommand^ CreateQsManagerCommand()
member CreateQsManagerCommand : unit -> QsManagerCommand

Valore di ritorno

QsManagerCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateQsManagerCommCommand

Metodo DedNetApplicationCreateQsManagerCommCommand
Crea un nuovo comando QsManagerCommand. Permesso minimo di READ in modo che venga visualizzato anche se l'utente non lo può eseguire, utile nel caso in cui venga usato il comando login con un altro utente.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QsManagerCommCommand CreateQsManagerCommCommand()
Public Function CreateQsManagerCommCommand As QsManagerCommCommand
public:
QsManagerCommCommand^ CreateQsManagerCommCommand()
member CreateQsManagerCommCommand : unit -> QsManagerCommCommand

Valore di ritorno

QsManagerCommCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateRecognaiseCommDocumentCommand

Metodo DedNetApplicationCreateRecognaiseCommDocumentCommand
Crea un nuovo comando RecognaiseCommDocument. E' disponibile nel controllo dei documenti associati alle commesse.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public RecognaiseCommDocument CreateRecognaiseCommDocumentCommand()
Public Function CreateRecognaiseCommDocumentCommand As RecognaiseCommDocument
public:
RecognaiseCommDocument^ CreateRecognaiseCommDocumentCommand()
member CreateRecognaiseCommDocumentCommand : unit -> RecognaiseCommDocument

Valore di ritorno

RecognaiseCommDocument
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateRecognaiseCommFilesCommand

Metodo DedNetApplicationCreateRecognaiseCommFilesCommand
Crea un nuovo comando RecognaiseCommDocument. E' disponibile nel controllo dei documenti associati alle commesse.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public RecognaiseCommDocument CreateRecognaiseCommFilesCommand()
Public Function CreateRecognaiseCommFilesCommand As RecognaiseCommDocument
public:
RecognaiseCommDocument^ CreateRecognaiseCommFilesCommand()
member CreateRecognaiseCommFilesCommand : unit -> RecognaiseCommDocument

Valore di ritorno

RecognaiseCommDocument
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateRecognaiseDocsCommand

Metodo DedNetApplicationCreateRecognaiseDocsCommand
Crea un nuovo comando RecognaiseDocument. E' disponibile ovunque ci siano le anagrafiche ed anche siano visualizzati i documenti relativi.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public RecognaiseDocument CreateRecognaiseDocsCommand()
Public Function CreateRecognaiseDocsCommand As RecognaiseDocument
public:
RecognaiseDocument^ CreateRecognaiseDocsCommand()
member CreateRecognaiseDocsCommand : unit -> RecognaiseDocument

Valore di ritorno

RecognaiseDocument
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateRecognaiseFilesCommand

Metodo DedNetApplicationCreateRecognaiseFilesCommand
Crea un nuovo comando RecognaiseDocument. E' disponibile ovunque ci siano le anagrafiche ed anche siano visualizzati i documenti relativi.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public RecognaiseDocument CreateRecognaiseFilesCommand()
Public Function CreateRecognaiseFilesCommand As RecognaiseDocument
public:
RecognaiseDocument^ CreateRecognaiseFilesCommand()
member CreateRecognaiseFilesCommand : unit -> RecognaiseDocument

Valore di ritorno

RecognaiseDocument
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateRemoveDocumentCommand

Metodo DedNetApplicationCreateRemoveDocumentCommand
Crea un nuovo comando RemoveDocument che permette di eliminare una lista di documenti.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public RemoveDocument CreateRemoveDocumentCommand()
Public Function CreateRemoveDocumentCommand As RemoveDocument
public:
RemoveDocument^ CreateRemoveDocumentCommand()
member CreateRemoveDocumentCommand : unit -> RemoveDocument

Valore di ritorno

RemoveDocument
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateRemoveEcoDocumentCommand

Metodo DedNetApplicationCreateRemoveEcoDocumentCommand

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public RemoveEcoDocument CreateRemoveEcoDocumentCommand()
Public Function CreateRemoveEcoDocumentCommand As RemoveEcoDocument
public:
RemoveEcoDocument^ CreateRemoveEcoDocumentCommand()
member CreateRemoveEcoDocumentCommand : unit -> RemoveEcoDocument

Valore di ritorno

RemoveEcoDocument
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateRemoveRecurrentTimingCommand

Metodo DedNetApplicationCreateRemoveRecurrentTimingCommand
Crea un nuovo comando RemoveRecurrentTimingCommand.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public RemoveRecurrentTimingCommand CreateRemoveRecurrentTimingCommand()
Public Function CreateRemoveRecurrentTimingCommand As RemoveRecurrentTimingCommand
public:
RemoveRecurrentTimingCommand^ CreateRemoveRecurrentTimingCommand()
member CreateRemoveRecurrentTimingCommand : unit -> RemoveRecurrentTimingCommand

Valore di ritorno

RemoveRecurrentTimingCommand
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateRenameDocumentCommand

Metodo DedNetApplicationCreateRenameDocumentCommand
Crea un nuovo comando RenameDoc per rinominare i documenti. E' disponibile solo negli allegati.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public RenameDocument CreateRenameDocumentCommand()
Public Function CreateRenameDocumentCommand As RenameDocument
public:
RenameDocument^ CreateRenameDocumentCommand()
member CreateRenameDocumentCommand : unit -> RenameDocument

Valore di ritorno

RenameDocument
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateRenameFolderCommand

Metodo DedNetApplicationCreateRenameFolderCommand
Crea un nuovo comando Elimina cartella. Eliomina una cartella e tutti i suoi documenti.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public RenameFolder CreateRenameFolderCommand()
Public Function CreateRenameFolderCommand As RenameFolder
public:
RenameFolder^ CreateRenameFolderCommand()
member CreateRenameFolderCommand : unit -> RenameFolder

Valore di ritorno

RenameFolder
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateReplaceAnagrBomCommand

Metodo DedNetApplicationCreateReplaceAnagrBomCommand
Crea un nuovo comando ReplaceAnagrBom che permette di sostituire un'anagrafica con un'altra all'interno di più distinte.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ReplaceAnagrBom CreateReplaceAnagrBomCommand()
Public Function CreateReplaceAnagrBomCommand As ReplaceAnagrBom
public:
ReplaceAnagrBom^ CreateReplaceAnagrBomCommand()
member CreateReplaceAnagrBomCommand : unit -> ReplaceAnagrBom

Valore di ritorno

ReplaceAnagrBom
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateReplaceDocumentCommand

Metodo DedNetApplicationCreateReplaceDocumentCommand
Crea un nuovo comando ReplaceDocument. E' disponibile ovunque ci siano le anagrafiche ed anche siano visualizzati i documenti relativi.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ReplaceDocument CreateReplaceDocumentCommand(
    bool isDocSelection
)
Public Function CreateReplaceDocumentCommand (
    isDocSelection As Boolean
) As ReplaceDocument
public:
ReplaceDocument^ CreateReplaceDocumentCommand(
    bool isDocSelection
)
member CreateReplaceDocumentCommand :
        isDocSelection : bool -> ReplaceDocument

Parametri

isDocSelection Boolean

Valore di ritorno

ReplaceDocument
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateReplaceDocumentReferenceCommand

Metodo DedNetApplicationCreateReplaceDocumentReferenceCommand
Crea un nuovo comando ReplaceDocumentReference.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ReplaceDocumentReference CreateReplaceDocumentReferenceCommand()
Public Function CreateReplaceDocumentReferenceCommand As ReplaceDocumentReference
public:
ReplaceDocumentReference^ CreateReplaceDocumentReferenceCommand()
member CreateReplaceDocumentReferenceCommand : unit -> ReplaceDocumentReference

Valore di ritorno

ReplaceDocumentReference
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateReserveProgCommand

Metodo DedNetApplicationCreateReserveProgCommand
Crea un nuovo comando QsReserveProgCommand. Permesso minimo di READ in modo che venga visualizzato anche se l'utente non lo può eseguire, utile nel caso in cui venga usato il comando login con un altro utente.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QsReserveProgCommand CreateReserveProgCommand()
Public Function CreateReserveProgCommand As QsReserveProgCommand
public:
QsReserveProgCommand^ CreateReserveProgCommand()
member CreateReserveProgCommand : unit -> QsReserveProgCommand

Valore di ritorno

QsReserveProgCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateRevCommand

Metodo DedNetApplicationCreateRevCommand
Crea un nuovo comando RevCommand.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public RevCommand CreateRevCommand()
Public Function CreateRevCommand As RevCommand
public:
RevCommand^ CreateRevCommand()
member CreateRevCommand : unit -> RevCommand

Valore di ritorno

RevCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateRootManagerCommand

Metodo DedNetApplicationCreateRootManagerCommand
Crea un nuovo comando Gestione root. Permesso minimo di READ in modo che venga visualizzato anche se l'utente non lo può eseguire, utile nel caso in cui venga usato il comando login con un altro utente.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public RootManagerCommand CreateRootManagerCommand()
Public Function CreateRootManagerCommand As RootManagerCommand
public:
RootManagerCommand^ CreateRootManagerCommand()
member CreateRootManagerCommand : unit -> RootManagerCommand

Valore di ritorno

RootManagerCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateSaveCommand

Metodo DedNetApplicationCreateSaveCommand
Crea un nuovo comando SaveCommand.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public SaveCommand CreateSaveCommand()
Public Function CreateSaveCommand As SaveCommand
public:
SaveCommand^ CreateSaveCommand()
member CreateSaveCommand : unit -> SaveCommand

Valore di ritorno

SaveCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateSaveDistCommand

Metodo DedNetApplicationCreateSaveDistCommand
Crea un nuovo comando SaveDistCommand.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public SaveDistCommand CreateSaveDistCommand()
Public Function CreateSaveDistCommand As SaveDistCommand
public:
SaveDistCommand^ CreateSaveDistCommand()
member CreateSaveDistCommand : unit -> SaveDistCommand

Valore di ritorno

SaveDistCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateSaveDistVariantCommand

Metodo DedNetApplicationCreateSaveDistVariantCommand
Crea un nuovo comando SaveDistCommand.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public SaveDistVariantCommand CreateSaveDistVariantCommand()
Public Function CreateSaveDistVariantCommand As SaveDistVariantCommand
public:
SaveDistVariantCommand^ CreateSaveDistVariantCommand()
member CreateSaveDistVariantCommand : unit -> SaveDistVariantCommand

Valore di ritorno

SaveDistVariantCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateSaveForm

Metodo DedNetApplicationCreateSaveForm
Crea e restituisce la finestra di salvataggio nel Database.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormSave CreateSaveForm()
Public Function CreateSaveForm As DedFormSave
public:
DedFormSave^ CreateSaveForm()
member CreateSaveForm : unit -> DedFormSave

Valore di ritorno

DedFormSave
Restituisce il form.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateSaveSparePartsDistVariantCommand

Metodo DedNetApplicationCreateSaveSparePartsDistVariantCommand
Crea un nuovo comando SaveSparePartsDistVariantCommand.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public SaveSparePartsDistVariantCommand CreateSaveSparePartsDistVariantCommand()
Public Function CreateSaveSparePartsDistVariantCommand As SaveSparePartsDistVariantCommand
public:
SaveSparePartsDistVariantCommand^ CreateSaveSparePartsDistVariantCommand()
member CreateSaveSparePartsDistVariantCommand : unit -> SaveSparePartsDistVariantCommand

Valore di ritorno

SaveSparePartsDistVariantCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateSaveVariantCommand

Metodo DedNetApplicationCreateSaveVariantCommand
Crea un nuovo comando SaveCommand impostato in modo che sia utilizzato per la creazione della variante.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public SaveCommand CreateSaveVariantCommand()
Public Function CreateSaveVariantCommand As SaveCommand
public:
SaveCommand^ CreateSaveVariantCommand()
member CreateSaveVariantCommand : unit -> SaveCommand

Valore di ritorno

SaveCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateSbloccaDocumentCommand

Metodo DedNetApplicationCreateSbloccaDocumentCommand
Crea un nuovo comando Sblocca documento. Mette il documento in CheckIn senza effettuarne la pubblicazione. Opzionalmente lo cancella dall'area locale.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public SbloccaDocument CreateSbloccaDocumentCommand()
Public Function CreateSbloccaDocumentCommand As SbloccaDocument
public:
SbloccaDocument^ CreateSbloccaDocumentCommand()
member CreateSbloccaDocumentCommand : unit -> SbloccaDocument

Valore di ritorno

SbloccaDocument
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateSendTransferPacketCommand

Metodo DedNetApplicationCreateSendTransferPacketCommand
Crea un nuovo comando di SendTransferPacket.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public SendTransferPacket CreateSendTransferPacketCommand()
Public Function CreateSendTransferPacketCommand As SendTransferPacket
public:
SendTransferPacket^ CreateSendTransferPacketCommand()
member CreateSendTransferPacketCommand : unit -> SendTransferPacket

Valore di ritorno

SendTransferPacket
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateSendZipCommand

Metodo DedNetApplicationCreateSendZipCommand
Crea un nuovo comando SendZipViaEmail che zippa i file selezionati in una cartella e apre un messaggio di posta con allegato lo zip. Una volta inviato il messaggio viene rimossa la cartella.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public SendZipViaEmail CreateSendZipCommand()
Public Function CreateSendZipCommand As SendZipViaEmail
public:
SendZipViaEmail^ CreateSendZipCommand()
member CreateSendZipCommand : unit -> SendZipViaEmail

Valore di ritorno

SendZipViaEmail
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateShowAllActiveTimingsCommand

Metodo DedNetApplicationCreateShowAllActiveTimingsCommand
Crea un nuovo comando EndAllTimingsCommand.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ShowAllActiveTimingsCommand CreateShowAllActiveTimingsCommand()
Public Function CreateShowAllActiveTimingsCommand As ShowAllActiveTimingsCommand
public:
ShowAllActiveTimingsCommand^ CreateShowAllActiveTimingsCommand()
member CreateShowAllActiveTimingsCommand : unit -> ShowAllActiveTimingsCommand

Valore di ritorno

ShowAllActiveTimingsCommand
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateShowAnagrCommand

Metodo DedNetApplicationCreateShowAnagrCommand
Crea un nuovo comando ShowAnagr.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ShowAnagrCommand CreateShowAnagrCommand()
Public Function CreateShowAnagrCommand As ShowAnagrCommand
public:
ShowAnagrCommand^ CreateShowAnagrCommand()
member CreateShowAnagrCommand : unit -> ShowAnagrCommand

Valore di ritorno

ShowAnagrCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateShowRecurrentTimingCommand

Metodo DedNetApplicationCreateShowRecurrentTimingCommand
Crea un nuovo comando ShowFavTiming.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ShowRecurrentTimingCommand CreateShowRecurrentTimingCommand()
Public Function CreateShowRecurrentTimingCommand As ShowRecurrentTimingCommand
public:
ShowRecurrentTimingCommand^ CreateShowRecurrentTimingCommand()
member CreateShowRecurrentTimingCommand : unit -> ShowRecurrentTimingCommand

Valore di ritorno

ShowRecurrentTimingCommand
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateShowSparePartsDistVariantCommand

Metodo DedNetApplicationCreateShowSparePartsDistVariantCommand
Crea un nuovo comando ShowSparePartsDistVariantCommand.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ShowSparePartsDistVariantCommand CreateShowSparePartsDistVariantCommand()
Public Function CreateShowSparePartsDistVariantCommand As ShowSparePartsDistVariantCommand
public:
ShowSparePartsDistVariantCommand^ CreateShowSparePartsDistVariantCommand()
member CreateShowSparePartsDistVariantCommand : unit -> ShowSparePartsDistVariantCommand

Valore di ritorno

ShowSparePartsDistVariantCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateShowTimingCommand

Metodo DedNetApplicationCreateShowTimingCommand
Crea un nuovo comando ShowTimingCommand.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ShowTimingCommand CreateShowTimingCommand()
Public Function CreateShowTimingCommand As ShowTimingCommand
public:
ShowTimingCommand^ CreateShowTimingCommand()
member CreateShowTimingCommand : unit -> ShowTimingCommand

Valore di ritorno

ShowTimingCommand
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateStartTimingCommand

Metodo DedNetApplicationCreateStartTimingCommand
Crea un nuovo comando StartTimingCommand.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public StartTimingCommand CreateStartTimingCommand()
Public Function CreateStartTimingCommand As StartTimingCommand
public:
StartTimingCommand^ CreateStartTimingCommand()
member CreateStartTimingCommand : unit -> StartTimingCommand

Valore di ritorno

StartTimingCommand
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateStateCommand

Metodo DedNetApplicationCreateStateCommand
Crea un nuovo comando di impostazione stato documento.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedStateCommand CreateStateCommand(
    DedState targetState
)
Public Function CreateStateCommand (
    targetState As DedState
) As DedStateCommand
public:
DedStateCommand^ CreateStateCommand(
    DedState^ targetState
)
member CreateStateCommand :
        targetState : DedState -> DedStateCommand

Parametri

targetState DedState
Stato di destinazione.

Valore di ritorno

DedStateCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateStateManagerCommand

Metodo DedNetApplicationCreateStateManagerCommand
Crea un nuovo comando StateManagerCommand. Permesso minimo di READ in modo che venga visualizzato anche se l'utente non lo può eseguire, utile nel caso in cui venga usato il comando login con un altro utente.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public StateManagerCommand CreateStateManagerCommand()
Public Function CreateStateManagerCommand As StateManagerCommand
public:
StateManagerCommand^ CreateStateManagerCommand()
member CreateStateManagerCommand : unit -> StateManagerCommand

Valore di ritorno

StateManagerCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateTranslationsMangerCommand

Metodo DedNetApplicationCreateTranslationsMangerCommand
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | CreateTranslationsMangerCommand | Crea e restituisce il sotto-comando che permette di aggiornare un documento e tutte le sue dipendenze. Riconosce tutti file dipendenti nel Database.
Metodo pubblico | CreateTranslationsMangerCommand(CommandContextEnum) | Crea e restituisce il sotto-comando che permette di aggiornare un documento e tutte le sue dipendenze. Riconosce tutti file dipendenti nel Database.
Torna su
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateTranslationsMangerCommand

Metodo DedNetApplicationCreateTranslationsMangerCommand
Crea e restituisce il sotto-comando che permette di aggiornare un documento e tutte le sue dipendenze. Riconosce tutti file dipendenti nel Database.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public TranslationsMangerCommand CreateTranslationsMangerCommand()
Public Function CreateTranslationsMangerCommand As TranslationsMangerCommand
public:
TranslationsMangerCommand^ CreateTranslationsMangerCommand()
member CreateTranslationsMangerCommand : unit -> TranslationsMangerCommand

Valore di ritorno

TranslationsMangerCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Overload di CreateTranslationsMangerCommand
Namespace DedNet


Metodo DedNetApplication.CreateTranslationsMangerCommand(CommandContextEnum)

Metodo DedNetApplicationCreateTranslationsMangerCommand(CommandContextEnum)
Crea e restituisce il sotto-comando che permette di aggiornare un documento e tutte le sue dipendenze. Riconosce tutti file dipendenti nel Database.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public TranslationsMangerCommand CreateTranslationsMangerCommand(
    CommandContextEnum cntx
)
Public Function CreateTranslationsMangerCommand (
    cntx As CommandContextEnum
) As TranslationsMangerCommand
public:
TranslationsMangerCommand^ CreateTranslationsMangerCommand(
    CommandContextEnum cntx
)
member CreateTranslationsMangerCommand :
        cntx : CommandContextEnum -> TranslationsMangerCommand

Parametri

cntx CommandContextEnum

Valore di ritorno

TranslationsMangerCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Overload di CreateTranslationsMangerCommand
Namespace DedNet


Metodo DedNetApplication.CreateUpdateDocumentCommand

Metodo DedNetApplicationCreateUpdateDocumentCommand
Crea e restituisce il sotto-comando che permette di aggiornare un documento e tutte le sue dipendenze. Riconosce tutti file dipendenti nel Database.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public UpdateDocument CreateUpdateDocumentCommand()
Public Function CreateUpdateDocumentCommand As UpdateDocument
public:
UpdateDocument^ CreateUpdateDocumentCommand()
member CreateUpdateDocumentCommand : unit -> UpdateDocument

Valore di ritorno

UpdateDocument
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateUpdateDocumentReferenceCommand

Metodo DedNetApplicationCreateUpdateDocumentReferenceCommand
Crea un nuovo comando UpdateDocumentReference.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public UpdateDocumentReference CreateUpdateDocumentReferenceCommand()
Public Function CreateUpdateDocumentReferenceCommand As UpdateDocumentReference
public:
UpdateDocumentReference^ CreateUpdateDocumentReferenceCommand()
member CreateUpdateDocumentReferenceCommand : unit -> UpdateDocumentReference

Valore di ritorno

UpdateDocumentReference
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateUpdateOldRevCommand

Metodo DedNetApplicationCreateUpdateOldRevCommand
Crea un nuovo comando UpdateOldRev.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public UpdateOldRevCommand CreateUpdateOldRevCommand()
Public Function CreateUpdateOldRevCommand As UpdateOldRevCommand
public:
UpdateOldRevCommand^ CreateUpdateOldRevCommand()
member CreateUpdateOldRevCommand : unit -> UpdateOldRevCommand

Valore di ritorno

UpdateOldRevCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateUpdateOldRevForm

Metodo DedNetApplicationCreateUpdateOldRevForm
Creazione del form di aggiornamento delle revisioni superate.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormUpdateOldRev CreateUpdateOldRevForm()
Public Function CreateUpdateOldRevForm As DedFormUpdateOldRev
public:
DedFormUpdateOldRev^ CreateUpdateOldRevForm()
member CreateUpdateOldRevForm : unit -> DedFormUpdateOldRev

Valore di ritorno

DedFormUpdateOldRev
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateUpdateSparePartsBoms

Metodo DedNetApplicationCreateUpdateSparePartsBoms
Crea un nuovo comando UpdateSparePartsBoms.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public UpdateSparePartsBoms CreateUpdateSparePartsBoms()
Public Function CreateUpdateSparePartsBoms As UpdateSparePartsBoms
public:
UpdateSparePartsBoms^ CreateUpdateSparePartsBoms()
member CreateUpdateSparePartsBoms : unit -> UpdateSparePartsBoms

Valore di ritorno

UpdateSparePartsBoms
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateUsersCommand

Metodo DedNetApplicationCreateUsersCommand
Crea un nuovo comando UsersCommand. Permesso minimo di READ in modo che venga visualizzato anche se l'utente non lo può eseguire, utile nel caso in cui venga usato il comando login con un altro utente.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public UsersCommand CreateUsersCommand()
Public Function CreateUsersCommand As UsersCommand
public:
UsersCommand^ CreateUsersCommand()
member CreateUsersCommand : unit -> UsersCommand

Valore di ritorno

UsersCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateVarsCommand

Metodo DedNetApplicationCreateVarsCommand
Crea un nuovo comando VarsCommand. Permesso minimo di READ in modo che venga visualizzato anche se l'utente non lo può eseguire, utile nel caso in cui venga usato il comando login con un altro utente.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public VarsCommand CreateVarsCommand()
Public Function CreateVarsCommand As VarsCommand
public:
VarsCommand^ CreateVarsCommand()
member CreateVarsCommand : unit -> VarsCommand

Valore di ritorno

VarsCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateViewCommCommand

Metodo DedNetApplicationCreateViewCommCommand
Crea un nuovo comando per la visualizzazione di una commessa.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ViewCommCommand CreateViewCommCommand()
Public Function CreateViewCommCommand As ViewCommCommand
public:
ViewCommCommand^ CreateViewCommCommand()
member CreateViewCommCommand : unit -> ViewCommCommand

Valore di ritorno

ViewCommCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateVisualDepCommand

Metodo DedNetApplicationCreateVisualDepCommand
Crea un nuovo comando VisualDep che mostra all'utente l'albero delle dipendenze.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public VisualDepCommand CreateVisualDepCommand()
Public Function CreateVisualDepCommand As VisualDepCommand
public:
VisualDepCommand^ CreateVisualDepCommand()
member CreateVisualDepCommand : unit -> VisualDepCommand

Valore di ritorno

VisualDepCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.CreateWhereUsedCommand

Metodo DedNetApplicationCreateWhereUsedCommand
Crea un nuovo comando WhereUsed.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public WhereUsedCommand CreateWhereUsedCommand()
Public Function CreateWhereUsedCommand As WhereUsedCommand
public:
WhereUsedCommand^ CreateWhereUsedCommand()
member CreateWhereUsedCommand : unit -> WhereUsedCommand

Valore di ritorno

WhereUsedCommand
Restituisce il comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.DataToAnagrAttrList

Metodo DedNetApplicationDataToAnagrAttrList
Data un'anagrafica, che può anche essere null, restituisce la lista degli attributi abbinati. Se l'anagrafica è null restituisce la lista degli attributi di anagrafica standard. Restituisce sempre una lista inizializzata.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList DataToAnagrAttrList(
    IDedData data
)
Public Function DataToAnagrAttrList (
    data As IDedData
) As DedAttrList
public:
DedAttrList^ DataToAnagrAttrList(
    IDedData^ data
)
member DataToAnagrAttrList :
        data : IDedData -> DedAttrList

Parametri

data IDedData
Anagrafica da analizzare.

Valore di ritorno

DedAttrList
Resituisce la lista degli attribuiti abbinati all'anagrafica.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.DataToAnagrDistAttrList

Metodo DedNetApplicationDataToAnagrDistAttrList
Data un'anagrafica, che può anche essere null, restituisce la lista degli attributi abbinati insieme a quelli di distinta. Se l'anagrafica è null restituisce la lista degli attributi di anagrafica standard e distinta. Restituisce sempre una lista inizializzata.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList DataToAnagrDistAttrList(
    IDedData data
)
Public Function DataToAnagrDistAttrList (
    data As IDedData
) As DedAttrList
public:
DedAttrList^ DataToAnagrDistAttrList(
    IDedData^ data
)
member DataToAnagrDistAttrList :
        data : IDedData -> DedAttrList

Parametri

data IDedData
Anagrafica da analizzare.

Valore di ritorno

DedAttrList
Resituisce la lista degli attribuiti abbinati all'anagrafica.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.DataToAnagrDistOccAttrList

Metodo DedNetApplicationDataToAnagrDistOccAttrList
Data un'anagrafica, che può anche essere null, restituisce la lista degli attributi abbinati insieme a quelli di distinta e occorrenza. Se l'anagrafica è null restituisce la lista degli attributi di anagrafica standard, distinta e occorrenza. Restituisce sempre una lista inizializzata.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList DataToAnagrDistOccAttrList(
    IDedData data
)
Public Function DataToAnagrDistOccAttrList (
    data As IDedData
) As DedAttrList
public:
DedAttrList^ DataToAnagrDistOccAttrList(
    IDedData^ data
)
member DataToAnagrDistOccAttrList :
        data : IDedData -> DedAttrList

Parametri

data IDedData
Anagrafica da analizzare.

Valore di ritorno

DedAttrList
Resituisce la lista degli attribuiti abbinati all'anagrafica.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.DataToAnagrDocAttrList

Metodo DedNetApplicationDataToAnagrDocAttrList
Data un'anagrafica, che può anche essere null, restituisce la lista degli attributi abbinati insieme a quelli di documento. Se l'anagrafica è null restituisce la lista degli attributi di anagrafica standard e documento. Restituisce sempre una lista inizializzata.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList DataToAnagrDocAttrList(
    IDedData data
)
Public Function DataToAnagrDocAttrList (
    data As IDedData
) As DedAttrList
public:
DedAttrList^ DataToAnagrDocAttrList(
    IDedData^ data
)
member DataToAnagrDocAttrList :
        data : IDedData -> DedAttrList

Parametri

data IDedData
Anagrafica da analizzare.

Valore di ritorno

DedAttrList
Resituisce la lista degli attribuiti abbinati all'anagrafica.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.DataToAnagrDocOccAttrList

Metodo DedNetApplicationDataToAnagrDocOccAttrList
Data un'anagrafica, che può anche essere null, restituisce la lista degli attributi abbinati insieme a quelli di documento e occorrenza. Se l'anagrafica è null restituisce la lista degli attributi di anagrafica standard, documento e occorrenza. Restituisce sempre una lista inizializzata.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList DataToAnagrDocOccAttrList(
    IDedData data
)
Public Function DataToAnagrDocOccAttrList (
    data As IDedData
) As DedAttrList
public:
DedAttrList^ DataToAnagrDocOccAttrList(
    IDedData^ data
)
member DataToAnagrDocOccAttrList :
        data : IDedData -> DedAttrList

Parametri

data IDedData
Anagrafica da analizzare.

Valore di ritorno

DedAttrList
Resituisce la lista degli attribuiti abbinati all'anagrafica.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.DataToAnagrOccAttrList

Metodo DedNetApplicationDataToAnagrOccAttrList
Data un'anagrafica, che può anche essere null, restituisce la lista degli attributi di anagrafica e occorrenza. Se l'anagrafica è null restituisce la lista degli attributi di anagrafica standard e occorrenza. Restituisce sempre una lista inizializzata.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList DataToAnagrOccAttrList(
    IDedData data
)
Public Function DataToAnagrOccAttrList (
    data As IDedData
) As DedAttrList
public:
DedAttrList^ DataToAnagrOccAttrList(
    IDedData^ data
)
member DataToAnagrOccAttrList :
        data : IDedData -> DedAttrList

Parametri

data IDedData
Anagrafica da analizzare.

Valore di ritorno

DedAttrList
Resituisce la lista degli attribuiti abbinati all'anagrafica.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.DataToDistAttrList

Metodo DedNetApplicationDataToDistAttrList
Data un'anagrafica, che può anche essere null, restituisce la lista degli attributi di distinta. Se l'anagrafica è null restituisce la lista degli attributi di distinta standard. Restituisce sempre una lista inizializzata.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList DataToDistAttrList(
    IDedData data
)
Public Function DataToDistAttrList (
    data As IDedData
) As DedAttrList
public:
DedAttrList^ DataToDistAttrList(
    IDedData^ data
)
member DataToDistAttrList :
        data : IDedData -> DedAttrList

Parametri

data IDedData
Anagrafica da analizzare.

Valore di ritorno

DedAttrList
Resituisce la lista degli attribuiti di distinta
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.DataToDistOccAttrList

Metodo DedNetApplicationDataToDistOccAttrList
Data un'anagrafica, che può anche essere null, restituisce la lista degli attributi di distinta e occorrenza. Se l'anagrafica è null restituisce la lista degli attributi di distinta standard e occorrenza. Restituisce sempre una lista inizializzata.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList DataToDistOccAttrList(
    IDedData data
)
Public Function DataToDistOccAttrList (
    data As IDedData
) As DedAttrList
public:
DedAttrList^ DataToDistOccAttrList(
    IDedData^ data
)
member DataToDistOccAttrList :
        data : IDedData -> DedAttrList

Parametri

data IDedData
Anagrafica da analizzare.

Valore di ritorno

DedAttrList
Resituisce la lista degli attribuiti di distinta
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.DataToDocAttrList

Metodo DedNetApplicationDataToDocAttrList
Data un'anagrafica, che può anche essere null, restituisce la lista degli attributi di documento. Se l'anagrafica è null restituisce la lista degli attributi di documento standard. Restituisce sempre una lista inizializzata.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList DataToDocAttrList(
    IDedData data
)
Public Function DataToDocAttrList (
    data As IDedData
) As DedAttrList
public:
DedAttrList^ DataToDocAttrList(
    IDedData^ data
)
member DataToDocAttrList :
        data : IDedData -> DedAttrList

Parametri

data IDedData
Anagrafica da analizzare.

Valore di ritorno

DedAttrList
Resituisce la lista degli attribuiti di documento
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.DataToDocOccAttrList

Metodo DedNetApplicationDataToDocOccAttrList
Data un'anagrafica, che può anche essere null, restituisce la lista degli attributi di documento e occorrenza. Se l'anagrafica è null restituisce la lista degli attributi di documento standard e occorrenza. Restituisce sempre una lista inizializzata.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList DataToDocOccAttrList(
    IDedData data
)
Public Function DataToDocOccAttrList (
    data As IDedData
) As DedAttrList
public:
DedAttrList^ DataToDocOccAttrList(
    IDedData^ data
)
member DataToDocOccAttrList :
        data : IDedData -> DedAttrList

Parametri

data IDedData
Anagrafica da analizzare.

Valore di ritorno

DedAttrList
Resituisce la lista degli attribuiti di documento
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.DataToOccAttrList

Metodo DedNetApplicationDataToOccAttrList
Data un'anagrafica, che può anche essere null, restituisce la lista degli attributi di occorrenza. Se l'anagrafica è null restituisce la lista degli attributi di distinta standard. Restituisce sempre una lista inizializzata.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList DataToOccAttrList(
    IDedData data
)
Public Function DataToOccAttrList (
    data As IDedData
) As DedAttrList
public:
DedAttrList^ DataToOccAttrList(
    IDedData^ data
)
member DataToOccAttrList :
        data : IDedData -> DedAttrList

Parametri

data IDedData
Anagrafica da analizzare.

Valore di ritorno

DedAttrList
Resituisce la lista degli attribuiti di distinta
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.DbLog

Metodo DedNetApplicationDbLog
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | DbLog(Exception, LogMessageTypeEnum) | Registra l'eccezione e la gravità nella tabella dedicata al log
Metodo pubblico | DbLog(String, LogMessageTypeEnum) | Registra il messaggio e la gravità nella tabella dedicata al log
Metodo pubblico | DbLog(Exception, String, LogMessageTypeEnum) | Registra l'eccezione e la gravità nella tabella dedicata al log
Metodo pubblico | DbLog(String, String, LogMessageTypeEnum) | Registra il messaggio e la gravità nella tabella dedicata al log
Torna su
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.DbLog(Exception, LogMessageTypeEnum)

Metodo DedNetApplicationDbLog(Exception, LogMessageTypeEnum)
Registra l'eccezione e la gravità nella tabella dedicata al log

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void DbLog(
    Exception ex,
    LogMessageTypeEnum severity
)
Public Sub DbLog (
    ex As Exception,
    severity As LogMessageTypeEnum
)
public:
void DbLog(
    Exception^ ex,
    LogMessageTypeEnum severity
)
member DbLog :
        ex : Exception *
        severity : LogMessageTypeEnum -> unit

Parametri

ex Exception
severity LogMessageTypeEnum
Vedi anche

Documentazione

Classe DedNetApplication
Overload di DbLog
Namespace DedNet


Metodo DedNetApplication.DbLog(String, LogMessageTypeEnum)

Metodo DedNetApplicationDbLog(String, LogMessageTypeEnum)
Registra il messaggio e la gravità nella tabella dedicata al log

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void DbLog(
    string msg,
    LogMessageTypeEnum severity
)
Public Sub DbLog (
    msg As String,
    severity As LogMessageTypeEnum
)
public:
void DbLog(
    String^ msg,
    LogMessageTypeEnum severity
)
member DbLog :
        msg : string *
        severity : LogMessageTypeEnum -> unit

Parametri

msg String
severity LogMessageTypeEnum
Vedi anche

Documentazione

Classe DedNetApplication
Overload di DbLog
Namespace DedNet


Metodo DedNetApplication.DbLog(Exception, String, LogMessageTypeEnum)

Metodo DedNetApplicationDbLog(Exception, String, LogMessageTypeEnum)
Registra l'eccezione e la gravità nella tabella dedicata al log

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void DbLog(
    Exception ex,
    string module,
    LogMessageTypeEnum severity
)
Public Sub DbLog (
    ex As Exception,
    module As String,
    severity As LogMessageTypeEnum
)
public:
void DbLog(
    Exception^ ex,
    String^ module,
    LogMessageTypeEnum severity
)
member DbLog :
        ex : Exception *
        module : string *
        severity : LogMessageTypeEnum -> unit

Parametri

ex Exception
module String
severity LogMessageTypeEnum
Vedi anche

Documentazione

Classe DedNetApplication
Overload di DbLog
Namespace DedNet


Metodo DedNetApplication.DbLog(String, String, LogMessageTypeEnum)

Metodo DedNetApplicationDbLog(String, String, LogMessageTypeEnum)
Registra il messaggio e la gravità nella tabella dedicata al log

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void DbLog(
    string msg,
    string module,
    LogMessageTypeEnum severity
)
Public Sub DbLog (
    msg As String,
    module As String,
    severity As LogMessageTypeEnum
)
public:
void DbLog(
    String^ msg,
    String^ module,
    LogMessageTypeEnum severity
)
member DbLog :
        msg : string *
        module : string *
        severity : LogMessageTypeEnum -> unit

Parametri

msg String
module String
severity LogMessageTypeEnum
Vedi anche

Documentazione

Classe DedNetApplication
Overload di DbLog
Namespace DedNet


Metodo DedNetApplication.DecodeString

Metodo DedNetApplicationDecodeString
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | DecodeString(DedTypeBase, String, String) | Utilizzata per decodificare una stringa codificata. Data una stringa contenente i tasselli di codifica ed un'altra contenente il valore corrispondente, viene ricostruito e restituito un oggetto DedEncodeInfo contenente le informazioni presenti. Nella stringa di codifica devono essere presenti tasselli (o anche detti token) che abbiano la parte che specifica la lunghezza (in pratica deve esserci il carattere separatore ':' seguito da un qualsiasi criterio di lunghezza). Restituisce sempre una lista inizializzata ma vuota nel caso non ci fossere corrispondenze.
Metodo pubblico | DecodeString(DedTypeBase, String, String, String) | Utilizzata per decodificare una stringa codificata. Data una stringa contenente i tasselli di codifica ed un'altra contenente il valore corrispondente, viene ricostruito e restituito un oggetto DedEncodeInfo contenente le informazioni presenti. Nella stringa di codifica devono essere presenti tasselli (o anche detti token) che abbiano la parte che specifica la lunghezza (in pratica deve esserci il carattere separatore ':' seguito da un qualsiasi criterio di lunghezza). Restituisce sempre una lista inizializzata ma vuota nel caso non ci fossere corrispondenze.
Torna su
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.DecodeString(DedTypeBase, String, String)

Metodo DedNetApplicationDecodeString(DedTypeBase, String, String)
Utilizzata per decodificare una stringa codificata. Data una stringa contenente i tasselli di codifica ed un'altra contenente il valore corrispondente, viene ricostruito e restituito un oggetto DedEncodeInfo contenente le informazioni presenti. Nella stringa di codifica devono essere presenti tasselli (o anche detti token) che abbiano la parte che specifica la lunghezza (in pratica deve esserci il carattere separatore ':' seguito da un qualsiasi criterio di lunghezza). Restituisce sempre una lista inizializzata ma vuota nel caso non ci fossere corrispondenze.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEncodeInfo DecodeString(
    DedTypeBase fam,
    string codeString,
    string valueString
)
Public Function DecodeString (
    fam As DedTypeBase,
    codeString As String,
    valueString As String
) As DedEncodeInfo
public:
DedEncodeInfo^ DecodeString(
    DedTypeBase^ fam,
    String^ codeString,
    String^ valueString
)
member DecodeString :
        fam : DedTypeBase *
        codeString : string *
        valueString : string -> DedEncodeInfo

Parametri

fam DedTypeBase
Famiglia di appartenenza della codifica
codeString String
Stringa di codifica da utilizzare per decodificare. Es: '{F1:1}{F2:3}{P:6}-{R:2}'.
valueString String
Stringa da decodificare leggendone le varie parti. Es: 'P500123456-00'.

Valore di ritorno

DedEncodeInfo
Restituisce un DedEncodeInfo contenente tutte le informazioni trovate.
Vedi anche

Documentazione

Classe DedNetApplication
Overload di DecodeString
Namespace DedNet


Metodo DedNetApplication.DecodeString(DedTypeBase, String, String, String)

Metodo DedNetApplicationDecodeString(DedTypeBase, String, String, String)
Utilizzata per decodificare una stringa codificata. Data una stringa contenente i tasselli di codifica ed un'altra contenente il valore corrispondente, viene ricostruito e restituito un oggetto DedEncodeInfo contenente le informazioni presenti. Nella stringa di codifica devono essere presenti tasselli (o anche detti token) che abbiano la parte che specifica la lunghezza (in pratica deve esserci il carattere separatore ':' seguito da un qualsiasi criterio di lunghezza). Restituisce sempre una lista inizializzata ma vuota nel caso non ci fossere corrispondenze.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEncodeInfo DecodeString(
    DedTypeBase fam,
    string codeString,
    string valueString,
    string attrName
)
Public Function DecodeString (
    fam As DedTypeBase,
    codeString As String,
    valueString As String,
    attrName As String
) As DedEncodeInfo
public:
DedEncodeInfo^ DecodeString(
    DedTypeBase^ fam,
    String^ codeString,
    String^ valueString,
    String^ attrName
)
member DecodeString :
        fam : DedTypeBase *
        codeString : string *
        valueString : string *
        attrName : string -> DedEncodeInfo

Parametri

fam DedTypeBase
Famiglia di appartenenza della codifica
codeString String
Stringa di codifica da utilizzare per decodificare. Es: '{F1:1}{F2:3}{P:6}-{R:2}'.
valueString String
Stringa da decodificare leggendone le varie parti. Es: 'P500123456-00'.
attrName String
Nome dell'attributo che si sta decodificando (non necessario ma utile per le personalizzazioni)

Valore di ritorno

DedEncodeInfo
Restituisce un DedEncodeInfo contenente tutte le informazioni trovate.
Vedi anche

Documentazione

Classe DedNetApplication
Overload di DecodeString
Namespace DedNet


Metodo DedNetApplication.Dispose

Metodo DedNetApplicationDispose
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Dispose | Dispose.
Metodo protetto | Dispose(Boolean) | Effettua il Dispose in base al contesto.
Torna su
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.Dispose

Metodo DedNetApplicationDispose
Dispose.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implementa

IDisposableDispose
Vedi anche

Documentazione

Classe DedNetApplication
Overload di Dispose
Namespace DedNet


Metodo DedNetApplication.Dispose(Boolean)

Metodo DedNetApplicationDispose(Boolean)
Effettua il Dispose in base al contesto.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
Indica se è stato chiamato dal metodo Dispose().
Vedi anche

Documentazione

Classe DedNetApplication
Overload di Dispose
Namespace DedNet


Metodo DedNetApplication.DocNameIsUsed

Metodo DedNetApplicationDocNameIsUsed
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | DocNameIsUsed(String) | Controlla se il nome passato senza estensione è già presente tra i documenti registrati o spostati.
Metodo pubblico | DocNameIsUsed(String, Boolean) | Controlla se il nome passato senza estensione è già presente tra i documenti registrati o spostati.
Metodo pubblico | DocNameIsUsed(String, String) | Controlla se il nome passato senza estensione è già presente tra i documenti registrati o spostati.
Metodo pubblico | DocNameIsUsed(String, String, Boolean) | Controlla se il nome passato senza estensione è già presente tra i documenti registrati o spostati.
Torna su
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.DocNameIsUsed(String)

Metodo DedNetApplicationDocNameIsUsed(String)
Controlla se il nome passato senza estensione è già presente tra i documenti registrati o spostati.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool DocNameIsUsed(
    string fileNameNoExt
)
Public Function DocNameIsUsed (
    fileNameNoExt As String
) As Boolean
public:
bool DocNameIsUsed(
    String^ fileNameNoExt
)
member DocNameIsUsed :
        fileNameNoExt : string -> bool

Parametri

fileNameNoExt String
Nome del file senza estensione da controllare

Valore di ritorno

Boolean
Booleano che indica l'esitenza del nome tra i doc registrati
Vedi anche

Documentazione

Classe DedNetApplication
Overload di DocNameIsUsed
Namespace DedNet


Metodo DedNetApplication.DocNameIsUsed(String, Boolean)

Metodo DedNetApplicationDocNameIsUsed(String, Boolean)
Controlla se il nome passato senza estensione è già presente tra i documenti registrati o spostati.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool DocNameIsUsed(
    string fileNameNoExt,
    bool includeMoved
)
Public Function DocNameIsUsed (
    fileNameNoExt As String,
    includeMoved As Boolean
) As Boolean
public:
bool DocNameIsUsed(
    String^ fileNameNoExt,
    bool includeMoved
)
member DocNameIsUsed :
        fileNameNoExt : string *
        includeMoved : bool -> bool

Parametri

fileNameNoExt String
Nome del file senza estensione da controllare
includeMoved Boolean
Indica se cercare anche nei moved

Valore di ritorno

Boolean
Booleano che indica l'esitenza del nome tra i doc registrati
Vedi anche

Documentazione

Classe DedNetApplication
Overload di DocNameIsUsed
Namespace DedNet


Metodo DedNetApplication.DocNameIsUsed(String, String)

Metodo DedNetApplicationDocNameIsUsed(String, String)
Controlla se il nome passato senza estensione è già presente tra i documenti registrati o spostati.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool DocNameIsUsed(
    string fileNameNoExt,
    string ext
)
Public Function DocNameIsUsed (
    fileNameNoExt As String,
    ext As String
) As Boolean
public:
bool DocNameIsUsed(
    String^ fileNameNoExt,
    String^ ext
)
member DocNameIsUsed :
        fileNameNoExt : string *
        ext : string -> bool

Parametri

fileNameNoExt String
Nome del file senza estensione da controllare
ext String
Estensione del file da controllare

Valore di ritorno

Boolean
Booleano che indica l'esitenza del nome tra i doc registrati
Vedi anche

Documentazione

Classe DedNetApplication
Overload di DocNameIsUsed
Namespace DedNet


Metodo DedNetApplication.DocNameIsUsed(String, String, Boolean)

Metodo DedNetApplicationDocNameIsUsed(String, String, Boolean)
Controlla se il nome passato senza estensione è già presente tra i documenti registrati o spostati.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool DocNameIsUsed(
    string fileNameNoExt,
    string ext,
    bool includeMoved
)
Public Function DocNameIsUsed (
    fileNameNoExt As String,
    ext As String,
    includeMoved As Boolean
) As Boolean
public:
bool DocNameIsUsed(
    String^ fileNameNoExt,
    String^ ext,
    bool includeMoved
)
member DocNameIsUsed :
        fileNameNoExt : string *
        ext : string *
        includeMoved : bool -> bool

Parametri

fileNameNoExt String
Nome del file senza estensione da controllare
ext String
Estensione del file da controllare
includeMoved Boolean
Indica se cercare anche nei moved

Valore di ritorno

Boolean
Booleano che indica l'esitenza del nome tra i doc registrati
Vedi anche

Documentazione

Classe DedNetApplication
Overload di DocNameIsUsed
Namespace DedNet


Metodo DedNetApplication.DocumentMatchData

Metodo DedNetApplicationDocumentMatchData
Verifica che un dato documento sia presente come primario di una particolare anagrafica.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool DocumentMatchData(
    Guid docid,
    string dedid,
    string dedrev,
    string config
)
Public Function DocumentMatchData (
    docid As Guid,
    dedid As String,
    dedrev As String,
    config As String
) As Boolean
public:
bool DocumentMatchData(
    Guid docid,
    String^ dedid,
    String^ dedrev,
    String^ config
)
member DocumentMatchData :
        docid : Guid *
        dedid : string *
        dedrev : string *
        config : string -> bool

Parametri

docid Guid
Id del documento.
dedid String
Id dell'anagrafica.
dedrev String
Revisione dell'anagrafica.
config String
Configurazione nel caso venga passato null non considera la configurazione

Valore di ritorno

Boolean
Restituisce true se, trovato il documento e l'anagrafica, riscotra che il documento è file primario dell'anagrafica, altrimenti restituisce false.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.EncodeString

Metodo DedNetApplicationEncodeString
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | EncodeString(String, DedEncodeInfo) | Utilizzata per calcolare una stringa di codifica. Data una stringa di codifica, per esempio "{F1:3}{P:4}-{R:2}", e le informazioni racchiuse nell'oggetto DedEncodeInfo restituisce una stringa codificata.
Metodo pubblico | EncodeString(String, DedEncodeInfo, String) | Utilizzata per calcolare una stringa di codifica. Data una stringa di codifica, per esempio "{F1:3}{P:4}-{R:2}", e le informazioni racchiuse nell'oggetto DedEncodeInfo restituisce una stringa codificata.
Torna su
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.EncodeString(String, DedEncodeInfo)

Metodo DedNetApplicationEncodeString(String, DedEncodeInfo)
Utilizzata per calcolare una stringa di codifica. Data una stringa di codifica, per esempio "{F1:3}{P:4}-{R:2}", e le informazioni racchiuse nell'oggetto DedEncodeInfo restituisce una stringa codificata.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string EncodeString(
    string codeString,
    DedEncodeInfo info
)
Public Function EncodeString (
    codeString As String,
    info As DedEncodeInfo
) As String
public:
String^ EncodeString(
    String^ codeString,
    DedEncodeInfo^ info
)
member EncodeString :
        codeString : string *
        info : DedEncodeInfo -> string

Parametri

codeString String
Stringa di codifica contenente i tasselli di sostituzione.
info DedEncodeInfo
Oggetto contenente le informazioni per la codifica.

Valore di ritorno

String
Restituisce la stringa codificata oppure stringa vuota.
Vedi anche

Documentazione

Classe DedNetApplication
Overload di EncodeString
Namespace DedNet


Metodo DedNetApplication.EncodeString(String, DedEncodeInfo, String)

Metodo DedNetApplicationEncodeString(String, DedEncodeInfo, String)
Utilizzata per calcolare una stringa di codifica. Data una stringa di codifica, per esempio "{F1:3}{P:4}-{R:2}", e le informazioni racchiuse nell'oggetto DedEncodeInfo restituisce una stringa codificata.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string EncodeString(
    string codeString,
    DedEncodeInfo info,
    string attrName
)
Public Function EncodeString (
    codeString As String,
    info As DedEncodeInfo,
    attrName As String
) As String
public:
String^ EncodeString(
    String^ codeString,
    DedEncodeInfo^ info,
    String^ attrName
)
member EncodeString :
        codeString : string *
        info : DedEncodeInfo *
        attrName : string -> string

Parametri

codeString String
Stringa di codifica contenente i tasselli di sostituzione.
info DedEncodeInfo
Oggetto contenente le informazioni per la codifica.
attrName String

Valore di ritorno

String
Restituisce la stringa codificata oppure stringa vuota.
Vedi anche

Documentazione

Classe DedNetApplication
Overload di EncodeString
Namespace DedNet


Metodo DedNetApplication.EndFileTransaction

Metodo DedNetApplicationEndFileTransaction
Chiude la transazione in atto effettuando il commit oppure il rollback. QUESTO METODO È SEMPRE DA UTILIZZARE INSIEME A BeginFileTransaction().

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void EndFileTransaction(
    bool rollback
)
Public Sub EndFileTransaction (
    rollback As Boolean
)
public:
void EndFileTransaction(
    bool rollback
)
member EndFileTransaction :
        rollback : bool -> unit

Parametri

rollback Boolean
Se effettuare il rollback dell'operazione.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.EnsureEncodeHasLength

Metodo DedNetApplicationEnsureEncodeHasLength
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | EnsureEncodeHasLength(DedTypeBase, String) | Si assicura che il tassello in encode abbia i ":" per definire la sua lunghezza lo fa solo sui campi della famiglia ( poiche nel DEDID gli altri devono avere lunghezza definita)
Metodo pubblico | EnsureEncodeHasLength(IDedTypeEditable, String) | Si assicura che il tassello in encode abbia i ":" per definire la sua lunghezza
Torna su
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.EnsureEncodeHasLength(DedTypeBase, String)

Metodo DedNetApplicationEnsureEncodeHasLength(DedTypeBase, String)
Si assicura che il tassello in encode abbia i ":" per definire la sua lunghezza lo fa solo sui campi della famiglia ( poiche nel DEDID gli altri devono avere lunghezza definita)

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string EnsureEncodeHasLength(
    DedTypeBase type,
    string encode
)
Public Function EnsureEncodeHasLength (
    type As DedTypeBase,
    encode As String
) As String
public:
String^ EnsureEncodeHasLength(
    DedTypeBase^ type,
    String^ encode
)
member EnsureEncodeHasLength :
        type : DedTypeBase *
        encode : string -> string

Parametri

type DedTypeBase
encode String

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedNetApplication
Overload di EnsureEncodeHasLength
Namespace DedNet


Metodo DedNetApplication.EnsureEncodeHasLength(IDedTypeEditable, String)

Metodo DedNetApplicationEnsureEncodeHasLength(IDedTypeEditable, String)
Si assicura che il tassello in encode abbia i ":" per definire la sua lunghezza

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string EnsureEncodeHasLength(
    IDedTypeEditable data,
    string encode
)
Public Function EnsureEncodeHasLength (
    data As IDedTypeEditable,
    encode As String
) As String
public:
String^ EnsureEncodeHasLength(
    IDedTypeEditable^ data,
    String^ encode
)
member EnsureEncodeHasLength :
        data : IDedTypeEditable *
        encode : string -> string

Parametri

data IDedTypeEditable
encode String

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedNetApplication
Overload di EnsureEncodeHasLength
Namespace DedNet


Metodo DedNetApplication.Finalize

Metodo DedNetApplicationFinalize
Distruttore.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
~Finalize()
Protected Overrides Sub Finalize
!Finalize()
abstract Finalize : unit -> unit
override Finalize : unit -> unit
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.FindAllComm

Metodo DedNetApplicationFindAllComm
Restituisce tutte le anagrafiche presenti nel DB.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommList FindAllComm()
Public Function FindAllComm As DedCommList
public:
DedCommList^ FindAllComm()
member FindAllComm : unit -> DedCommList

Valore di ritorno

DedCommList
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.FindAllContextPrimaryDocuments

Metodo DedNetApplicationFindAllContextPrimaryDocuments
Restituisce la lista dei contesti nei quali un documento è collegato come file primario. Restituisce sempre una lista inizializzata.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocContextList FindAllContextPrimaryDocuments(
    Guid docid
)
Public Function FindAllContextPrimaryDocuments (
    docid As Guid
) As DedDocContextList
public:
DedDocContextList^ FindAllContextPrimaryDocuments(
    Guid docid
)
member FindAllContextPrimaryDocuments :
        docid : Guid -> DedDocContextList

Parametri

docid Guid
DocID del documento da cercare.

Valore di ritorno

DedDocContextList
Eccezioni
Eccezione | Condizione
QsException | Errore nella lettura del Database.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.FindAllData

Metodo DedNetApplicationFindAllData
Restituisce tutte le anagrafiche presenti nel DB.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataList FindAllData()
Public Function FindAllData As DedDataList
public:
DedDataList^ FindAllData()
member FindAllData : unit -> DedDataList

Valore di ritorno

DedDataList
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.FindAllDoc

Metodo DedNetApplicationFindAllDoc
Restituisce tutti i documenti registrati nel database.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocList FindAllDoc(
    List<string> ext,
    bool esclude = true
)
Public Function FindAllDoc (
    ext As List(Of String),
    Optional esclude As Boolean = true
) As DedDocList
public:
DedDocList^ FindAllDoc(
    List<String^>^ ext,
    bool esclude = true
)
member FindAllDoc :
        ext : List<string> *
        ?esclude : bool
(* Defaults:
        let _esclude = defaultArg esclude true
*)
-> DedDocList

Parametri

ext List String
Effettua una ricerca per estensioni in base a quelle specificate.
esclude Boolean (Optional)
Indica se la ricerca per estensioni deve essere eseguita per uguaglianza (False) o per diversità (True).

Valore di ritorno

DedDocList
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.FindComm

Metodo DedNetApplicationFindComm
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | FindComm(Guid) | Restituisce una commessa cercata attraverso l'id. Restituisce null se non la trova.
Metodo pubblico | FindComm(String) | Restituisce una commessa cercata attraverso il nome. Restituisce null se non la trova.
Torna su
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.FindComm(Guid)

Metodo DedNetApplicationFindComm(Guid)
Restituisce una commessa cercata attraverso l'id. Restituisce null se non la trova.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedComm FindComm(
    Guid commId
)
Public Function FindComm (
    commId As Guid
) As DedComm
public:
DedComm^ FindComm(
    Guid commId
)
member FindComm :
        commId : Guid -> DedComm

Parametri

commId Guid
Id della commessa da cercare.

Valore di ritorno

DedComm
Eccezioni
Eccezione | Condizione
ArgumentNullException | Parametro mancante.
QsException | Errore avvenuto durante l'istruzione di select.
Vedi anche

Documentazione

Classe DedNetApplication
Overload di FindComm
Namespace DedNet


Metodo DedNetApplication.FindComm(String)

Metodo DedNetApplicationFindComm(String)
Restituisce una commessa cercata attraverso il nome. Restituisce null se non la trova.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedComm FindComm(
    string name
)
Public Function FindComm (
    name As String
) As DedComm
public:
DedComm^ FindComm(
    String^ name
)
member FindComm :
        name : string -> DedComm

Parametri

name String
Nome della commessa da cercare.

Valore di ritorno

DedComm
Eccezioni
Eccezione | Condizione
ArgumentNullException | Parametro mancante.
QsException | Errore avvenuto durante l'istruzione di select.
Vedi anche

Documentazione

Classe DedNetApplication
Overload di FindComm
Namespace DedNet


Metodo DedNetApplication.FindData

Metodo DedNetApplicationFindData
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | FindData(String) | Restituisce la lista delle anagrafiche che hanno il DEDID richiesto. Le restituisce ordinate per revisione in modo ascendente. Restituisce null se non trova alcun record nel Database.
Metodo pubblico | FindData(String, Boolean) | Restituisce l'ultima revisione (con valore più alto) che ha il DEDID specificato. Se si imposta il parametro rilPriority = true viene cercata la prima revisione rilasciata, se presente, altrimenti viene comunque restituita la revisione più alta non superata. Restituisce null se non trova il record nel Database.
Metodo pubblico | FindData(String, String) | Restituisce l'anagrafica che ha il DEDID ed il DEDREV specificati. Restituisce null se non trova il record nel Database.
Torna su
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.FindData(String)

Metodo DedNetApplicationFindData(String)
Restituisce la lista delle anagrafiche che hanno il DEDID richiesto. Le restituisce ordinate per revisione in modo ascendente. Restituisce null se non trova alcun record nel Database.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataList FindData(
    string dedid
)
Public Function FindData (
    dedid As String
) As DedDataList
public:
DedDataList^ FindData(
    String^ dedid
)
member FindData :
        dedid : string -> DedDataList

Parametri

dedid String
DEDID per il quale reperire le anagrafiche.

Valore di ritorno

DedDataList
Eccezioni
Eccezione | Condizione
QsException | Errore verificatosi durante la lettura del record.
ArgumentNullException | Parametro mancante.
Vedi anche

Documentazione

Classe DedNetApplication
Overload di FindData
Namespace DedNet


Metodo DedNetApplication.FindData(String, Boolean)

Metodo DedNetApplicationFindData(String, Boolean)
Restituisce l'ultima revisione (con valore più alto) che ha il DEDID specificato. Se si imposta il parametro rilPriority = true viene cercata la prima revisione rilasciata, se presente, altrimenti viene comunque restituita la revisione più alta non superata. Restituisce null se non trova il record nel Database.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData FindData(
    string dedid,
    bool rilPriority
)
Public Function FindData (
    dedid As String,
    rilPriority As Boolean
) As DedData
public:
DedData^ FindData(
    String^ dedid,
    bool rilPriority
)
member FindData :
        dedid : string *
        rilPriority : bool -> DedData

Parametri

dedid String
rilPriority Boolean
Se impostato a true indica che si desidera dare la precedenza ad una eventuale revisione rilasciata altrimenti, se a false, si desidera avere la prima revisione non superata con valore più alto.

Valore di ritorno

DedData
Eccezioni
Eccezione | Condizione
QsException | Errore verificatosi durante la lettura del record.
ArgumentNullException | Parametro mancante.
Vedi anche

Documentazione

Classe DedNetApplication
Overload di FindData
Namespace DedNet


Metodo DedNetApplication.FindData(String, String)

Metodo DedNetApplicationFindData(String, String)
Restituisce l'anagrafica che ha il DEDID ed il DEDREV specificati. Restituisce null se non trova il record nel Database.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData FindData(
    string dedid,
    string dedrev
)
Public Function FindData (
    dedid As String,
    dedrev As String
) As DedData
public:
DedData^ FindData(
    String^ dedid,
    String^ dedrev
)
member FindData :
        dedid : string *
        dedrev : string -> DedData

Parametri

dedid String
DEDID per il quale reperire l'anagrafica.
dedrev String
DEDREV per il quale reperire l'anagrafica.

Valore di ritorno

DedData
Eccezioni
Eccezione | Condizione
QsException | Errore verificatosi durante la lettura del record.
ArgumentNullException | Parametro mancante.
Vedi anche

Documentazione

Classe DedNetApplication
Overload di FindData
Namespace DedNet


Metodo DedNetApplication.FindDataByDbPath

Metodo DedNetApplicationFindDataByDbPath
Restituisce la lista delle anagrafiche contenute nel dbpath indicato. Vengono considerate anche le anagrafiche che presentano dei dbpath figli di quello indicato

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataList FindDataByDbPath(
    string dbpath
)
Public Function FindDataByDbPath (
    dbpath As String
) As DedDataList
public:
DedDataList^ FindDataByDbPath(
    String^ dbpath
)
member FindDataByDbPath :
        dbpath : string -> DedDataList

Parametri

dbpath String
Dbpath per il quale effettuare la ricerca delle anagrafiche

Valore di ritorno

DedDataList
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.FindDataByField

Metodo DedNetApplicationFindDataByField
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | FindDataByField(DedDataStandardDataFields, Object) | Restituisce la lista delle anagrafiche che hanno il campo compilato come richiesto. Le restituisce ordinate per DEDID e DEDREV in modo ascendente. Restituisce null se non trova alcun record nel Database.
Metodo pubblico | FindDataByField(String, Object) | Restituisce la lista delle anagrafiche che hanno il campo compilato come richiesto. Le restituisce ordinate per DEDID e DEDREV in modo ascendente. Restituisce null se non trova alcun record nel Database.
Torna su
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.FindDataByField(DedData.StandardDataFields, Object)

Metodo DedNetApplicationFindDataByField(DedDataStandardDataFields, Object)
Restituisce la lista delle anagrafiche che hanno il campo compilato come richiesto. Le restituisce ordinate per DEDID e DEDREV in modo ascendente. Restituisce null se non trova alcun record nel Database.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataList FindDataByField(
    DedDataStandardDataFields field,
    Object fieldValue
)
Public Function FindDataByField (
    field As DedDataStandardDataFields,
    fieldValue As Object
) As DedDataList
public:
DedDataList^ FindDataByField(
    DedDataStandardDataFields field,
    Object^ fieldValue
)
member FindDataByField :
        field : DedDataStandardDataFields *
        fieldValue : Object -> DedDataList

Parametri

field DedDataStandardDataFields
Campo standard sul quale effettuare la query.
fieldValue Object
Valore da usare per la query.

Valore di ritorno

DedDataList
Eccezioni
Eccezione | Condizione
QsException | Errore verificatosi durante la lettura del record.
Vedi anche

Documentazione

Classe DedNetApplication
Overload di FindDataByField
Namespace DedNet


Metodo DedNetApplication.FindDataByField(String, Object)

Metodo DedNetApplicationFindDataByField(String, Object)
Restituisce la lista delle anagrafiche che hanno il campo compilato come richiesto. Le restituisce ordinate per DEDID e DEDREV in modo ascendente. Restituisce null se non trova alcun record nel Database.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataList FindDataByField(
    string field,
    Object fieldValue
)
Public Function FindDataByField (
    field As String,
    fieldValue As Object
) As DedDataList
public:
DedDataList^ FindDataByField(
    String^ field,
    Object^ fieldValue
)
member FindDataByField :
        field : string *
        fieldValue : Object -> DedDataList

Parametri

field String
Campo sul quale effettuare la query.
fieldValue Object
Valore da usare per la query.

Valore di ritorno

DedDataList
Eccezioni
Eccezione | Condizione
QsException | Errore verificatosi durante la lettura del record.
Vedi anche

Documentazione

Classe DedNetApplication
Overload di FindDataByField
Namespace DedNet


Metodo DedNetApplication.FindDataByFileName

Metodo DedNetApplicationFindDataByFileName
Restituisce la lista delle anagrafiche primarie del documento sotteso al file passato. Restituisce null se non trova alcun documento corrispondente al nome file passato, altrimenti restituisce una lista sempre inizializzata ma vuota se non trova anagrafiche collegate come primarie.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataList FindDataByFileName(
    string fileName
)
Public Function FindDataByFileName (
    fileName As String
) As DedDataList
public:
DedDataList^ FindDataByFileName(
    String^ fileName
)
member FindDataByFileName :
        fileName : string -> DedDataList

Parametri

fileName String
Nome del file da utilizzare nella ricerca.

Valore di ritorno

DedDataList
Eccezioni
Eccezione | Condizione
QsException | Errore verificatosi durante la lettura del record.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.FindDataLast

Metodo DedNetApplicationFindDataLast
Restituisce la lista delle revisioni non superate appartenenti al codice richiesto. Restituisce null se non trova alcun record nel Database.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataList FindDataLast(
    string dedid
)
Public Function FindDataLast (
    dedid As String
) As DedDataList
public:
DedDataList^ FindDataLast(
    String^ dedid
)
member FindDataLast :
        dedid : string -> DedDataList

Parametri

dedid String
DEDID per il quale reperire l'anagrafica.

Valore di ritorno

DedDataList
Eccezioni
Eccezione | Condizione
QsException | Errore verificatosi durante la lettura del record.
ArgumentNullException | Parametro mancante.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.FindDataLike

Metodo DedNetApplicationFindDataLike
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | FindDataLike(String) | Effettua una query sul campo DEDID delle anagrafiche utilizzando l'operatore like. Restituisce null se non trova alcun record nel Database, altrimenti restitusice la lista delle anagrafiche individuate. Le restituisce ordinate per DEDID e DEDREV in modo ascendente.
Metodo pubblico | FindDataLike(String, String) | Effettua una query sul campo specificato delle anagrafiche utilizzando l'operatore like. Restituisce null se non trova alcun record nel Database, altrimenti restitusice la lista delle anagrafiche individuate. Le restituisce ordinate per DEDID e DEDREV in modo ascendente.
Torna su
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.FindDataLike(String)

Metodo DedNetApplicationFindDataLike(String)
Effettua una query sul campo DEDID delle anagrafiche utilizzando l'operatore like. Restituisce null se non trova alcun record nel Database, altrimenti restitusice la lista delle anagrafiche individuate. Le restituisce ordinate per DEDID e DEDREV in modo ascendente.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataList FindDataLike(
    string dedidValueLike
)
Public Function FindDataLike (
    dedidValueLike As String
) As DedDataList
public:
DedDataList^ FindDataLike(
    String^ dedidValueLike
)
member FindDataLike :
        dedidValueLike : string -> DedDataList

Parametri

dedidValueLike String
Valore col quale effettuare la query, es.: "%PA%, "P03465__-__".

Valore di ritorno

DedDataList
Eccezioni
Eccezione | Condizione
QsException | Errore verificatosi durante la lettura del record.
Vedi anche

Documentazione

Classe DedNetApplication
Overload di FindDataLike
Namespace DedNet


Metodo DedNetApplication.FindDataLike(String, String)

Metodo DedNetApplicationFindDataLike(String, String)
Effettua una query sul campo specificato delle anagrafiche utilizzando l'operatore like. Restituisce null se non trova alcun record nel Database, altrimenti restitusice la lista delle anagrafiche individuate. Le restituisce ordinate per DEDID e DEDREV in modo ascendente.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataList FindDataLike(
    string fieldName,
    string fieldValueLike
)
Public Function FindDataLike (
    fieldName As String,
    fieldValueLike As String
) As DedDataList
public:
DedDataList^ FindDataLike(
    String^ fieldName,
    String^ fieldValueLike
)
member FindDataLike :
        fieldName : string *
        fieldValueLike : string -> DedDataList

Parametri

fieldName String
Nome del campo sul quale effettuare la query.
fieldValueLike String
Valore col quale effettuare la query, es.: "%PA%, "P03465__-__".

Valore di ritorno

DedDataList
Eccezioni
Eccezione | Condizione
QsException | Errore verificatosi durante la lettura del record.
Vedi anche

Documentazione

Classe DedNetApplication
Overload di FindDataLike
Namespace DedNet


Metodo DedNetApplication.FindDoc

Metodo DedNetApplicationFindDoc
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | FindDoc(Guid) | Restituisce il documento presente nel DB, se esiste, altimenti restituisce null.
Metodo pubblico | FindDoc(String) | Restituisce il documento presente nel DB, se esiste, altimenti restituisce null. Se è attiva l'area locale cerca anche nei percorsi di checkout.
Torna su
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.FindDoc(Guid)

Metodo DedNetApplicationFindDoc(Guid)
Restituisce il documento presente nel DB, se esiste, altimenti restituisce null.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDoc FindDoc(
    Guid docId
)
Public Function FindDoc (
    docId As Guid
) As DedDoc
public:
DedDoc^ FindDoc(
    Guid docId
)
member FindDoc :
        docId : Guid -> DedDoc

Parametri

docId Guid
DocID del documento da reperire.

Valore di ritorno

DedDoc
Eccezioni
Eccezione | Condizione
QsException | Errore verificatosi durante la lettura del record.
Vedi anche

Documentazione

Classe DedNetApplication
Overload di FindDoc
Namespace DedNet


Metodo DedNetApplication.FindDoc(String)

Metodo DedNetApplicationFindDoc(String)
Restituisce il documento presente nel DB, se esiste, altimenti restituisce null. Se è attiva l'area locale cerca anche nei percorsi di checkout.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDoc FindDoc(
    string fileName
)
Public Function FindDoc (
    fileName As String
) As DedDoc
public:
DedDoc^ FindDoc(
    String^ fileName
)
member FindDoc :
        fileName : string -> DedDoc

Parametri

fileName String
Nome completo del documento da cercare.

Valore di ritorno

DedDoc
Eccezioni
Eccezione | Condizione
QsException | Errore verificatosi durante la lettura del record.
ArgumentNullException | Parametro mancante.
Vedi anche

Documentazione

Classe DedNetApplication
Overload di FindDoc
Namespace DedNet


Metodo DedNetApplication.FindDocContext

Metodo DedNetApplicationFindDocContext
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | FindDocContext(Guid) | Restituisce la lista dei Contesti di legame di un documento. Se non trova record corrispondenti, restituisce una lista inizializzata ma vuota.
Metodo pubblico | FindDocContext(Guid, DedDocContextEnum) | Restituisce la lista dei Contesti di legame di un documento. Se non trova record corrispondenti, restituisce una lista inizializzata ma vuota.
Metodo pubblico | FindDocContext(String, String) | Restituisce la lista dei Contesti di legame di una anagrafica. Se non trova record corrispondenti, restituisce una lista inizializzata ma vuota.
Metodo pubblico | FindDocContext(String, String, DedDocContextEnum) | Restituisce la lista dei Contesti di legame di una anagrafica aventi un particolare contesto. Se non trova record corrispondenti, restituisce una lista inizializzata ma vuota.
Metodo pubblico | FindDocContext(String, String, Guid) | Restituisce il Contesto di legame tra anagrafica e documento, date le sue caratteristiche univoche. Se lo trova lo restituisce altrimenti restituisce null.
Torna su
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.FindDocContext(Guid)

Metodo DedNetApplicationFindDocContext(Guid)
Restituisce la lista dei Contesti di legame di un documento. Se non trova record corrispondenti, restituisce una lista inizializzata ma vuota.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocContextList FindDocContext(
    Guid docid
)
Public Function FindDocContext (
    docid As Guid
) As DedDocContextList
public:
DedDocContextList^ FindDocContext(
    Guid docid
)
member FindDocContext :
        docid : Guid -> DedDocContextList

Parametri

docid Guid
DocID del documento.

Valore di ritorno

DedDocContextList
Eccezioni
Eccezione | Condizione
QsException | Errore nella lettura del Database.
Vedi anche

Documentazione

Classe DedNetApplication
Overload di FindDocContext
Namespace DedNet


Metodo DedNetApplication.FindDocContext(Guid, DedDocContextEnum)

Metodo DedNetApplicationFindDocContext(Guid, DedDocContextEnum)
Restituisce la lista dei Contesti di legame di un documento. Se non trova record corrispondenti, restituisce una lista inizializzata ma vuota.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocContextList FindDocContext(
    Guid docid,
    DedDocContextEnum context
)
Public Function FindDocContext (
    docid As Guid,
    context As DedDocContextEnum
) As DedDocContextList
public:
DedDocContextList^ FindDocContext(
    Guid docid,
    DedDocContextEnum context
)
member FindDocContext :
        docid : Guid *
        context : DedDocContextEnum -> DedDocContextList

Parametri

docid Guid
DocID del documento.
context DedDocContextEnum
Contesto particolare per il quale si desidera avere i contesti di documento.

Valore di ritorno

DedDocContextList
Eccezioni
Eccezione | Condizione
QsException | Errore nella lettura del Database.
Vedi anche

Documentazione

Classe DedNetApplication
Overload di FindDocContext
Namespace DedNet


Metodo DedNetApplication.FindDocContext(String, String)

Metodo DedNetApplicationFindDocContext(String, String)
Restituisce la lista dei Contesti di legame di una anagrafica. Se non trova record corrispondenti, restituisce una lista inizializzata ma vuota.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocContextList FindDocContext(
    string dedid,
    string dedrev
)
Public Function FindDocContext (
    dedid As String,
    dedrev As String
) As DedDocContextList
public:
DedDocContextList^ FindDocContext(
    String^ dedid,
    String^ dedrev
)
member FindDocContext :
        dedid : string *
        dedrev : string -> DedDocContextList

Parametri

dedid String
DEDID dell'anagrafica.
dedrev String
DEDREV dell'anagrafica.

Valore di ritorno

DedDocContextList
Eccezioni
Eccezione | Condizione
QsException | Errore nella lettura del Database.
ArgumentNullException | Parametro mancante.
Vedi anche

Documentazione

Classe DedNetApplication
Overload di FindDocContext
Namespace DedNet


Metodo DedNetApplication.FindDocContext(String, String, DedDocContextEnum)

Metodo DedNetApplicationFindDocContext(String, String, DedDocContextEnum)
Restituisce la lista dei Contesti di legame di una anagrafica aventi un particolare contesto. Se non trova record corrispondenti, restituisce una lista inizializzata ma vuota.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocContextList FindDocContext(
    string dedid,
    string dedrev,
    DedDocContextEnum context
)
Public Function FindDocContext (
    dedid As String,
    dedrev As String,
    context As DedDocContextEnum
) As DedDocContextList
public:
DedDocContextList^ FindDocContext(
    String^ dedid,
    String^ dedrev,
    DedDocContextEnum context
)
member FindDocContext :
        dedid : string *
        dedrev : string *
        context : DedDocContextEnum -> DedDocContextList

Parametri

dedid String
DEDID dell'anagrafica.
dedrev String
DEDREV dell'anagrafica.
context DedDocContextEnum
Contesto particolare per il quale si desidera avere i contesti di documento.

Valore di ritorno

DedDocContextList
Eccezioni
Eccezione | Condizione
QsException | Errore nella lettura del Database.
ArgumentNullException | Parametro mancante.
Vedi anche

Documentazione

Classe DedNetApplication
Overload di FindDocContext
Namespace DedNet


Metodo DedNetApplication.FindDocContext(String, String, Guid)

Metodo DedNetApplicationFindDocContext(String, String, Guid)
Restituisce il Contesto di legame tra anagrafica e documento, date le sue caratteristiche univoche. Se lo trova lo restituisce altrimenti restituisce null.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocContext FindDocContext(
    string dedid,
    string dedrev,
    Guid docid
)
Public Function FindDocContext (
    dedid As String,
    dedrev As String,
    docid As Guid
) As DedDocContext
public:
DedDocContext^ FindDocContext(
    String^ dedid,
    String^ dedrev,
    Guid docid
)
member FindDocContext :
        dedid : string *
        dedrev : string *
        docid : Guid -> DedDocContext

Parametri

dedid String
DEDID dell'anagrafica.
dedrev String
DEDREV dell'anagrafica.
docid Guid
DocID del documento.

Valore di ritorno

DedDocContext
Eccezioni
Eccezione | Condizione
QsException | Errore nella lettura del Database.
ArgumentNullException | Parametro mancante.
Vedi anche

Documentazione

Classe DedNetApplication
Overload di FindDocContext
Namespace DedNet


Metodo DedNetApplication.FindDocErased

Metodo DedNetApplicationFindDocErased
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | FindDocErased(Guid) | Restituisce il documento presente nel DB, se esiste, altimenti restituisce null.
Metodo pubblico | FindDocErased(String) | Restituisce il documento eliminato se presente nel DB, altrimenti restituisce null
Torna su
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.FindDocErased(Guid)

Metodo DedNetApplicationFindDocErased(Guid)
Restituisce il documento presente nel DB, se esiste, altimenti restituisce null.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDoc FindDocErased(
    Guid docId
)
Public Function FindDocErased (
    docId As Guid
) As DedDoc
public:
DedDoc^ FindDocErased(
    Guid docId
)
member FindDocErased :
        docId : Guid -> DedDoc

Parametri

docId Guid
DocID del documento da reperire.

Valore di ritorno

DedDoc
Eccezioni
Eccezione | Condizione
QsException | Errore verificatosi durante la lettura del record.
Vedi anche

Documentazione

Classe DedNetApplication
Overload di FindDocErased
Namespace DedNet


Metodo DedNetApplication.FindDocErased(String)

Metodo DedNetApplicationFindDocErased(String)
Restituisce il documento eliminato se presente nel DB, altrimenti restituisce null

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDoc FindDocErased(
    string fileName
)
Public Function FindDocErased (
    fileName As String
) As DedDoc
public:
DedDoc^ FindDocErased(
    String^ fileName
)
member FindDocErased :
        fileName : string -> DedDoc

Parametri

fileName String

Valore di ritorno

DedDoc
Vedi anche

Documentazione

Classe DedNetApplication
Overload di FindDocErased
Namespace DedNet


Metodo DedNetApplication.FindDocs

Metodo DedNetApplicationFindDocs
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | FindDocs(String) | Restituisce una lista di documenti filtrati in base ai criteri passati
Metodo pubblico | FindDocs(String, ListString) | Restituisce una lista di documenti filtrati in base ai criteri passati
Metodo pubblico | FindDocs(String, String) | Restituisce una lista di documenti filtrati in base ai criteri passati
Metodo pubblico | FindDocs(String, String, ListString) | Restituisce una lista di documenti filtrati in base ai criteri passati
Torna su
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.FindDocs(String)

Metodo DedNetApplicationFindDocs(String)
Restituisce una lista di documenti filtrati in base ai criteri passati

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocList FindDocs(
    string nameNoExt
)
Public Function FindDocs (
    nameNoExt As String
) As DedDocList
public:
DedDocList^ FindDocs(
    String^ nameNoExt
)
member FindDocs :
        nameNoExt : string -> DedDocList

Parametri

nameNoExt String

Valore di ritorno

DedDocList
Vedi anche

Documentazione

Classe DedNetApplication
Overload di FindDocs
Namespace DedNet


Metodo DedNetApplication.FindDocs(String, List<String>)

Metodo DedNetApplicationFindDocs(String, ListString)
Restituisce una lista di documenti filtrati in base ai criteri passati

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocList FindDocs(
    string nameNoExt,
    List<string> extList
)
Public Function FindDocs (
    nameNoExt As String,
    extList As List(Of String)
) As DedDocList
public:
DedDocList^ FindDocs(
    String^ nameNoExt,
    List<String^>^ extList
)
member FindDocs :
        nameNoExt : string *
        extList : List<string> -> DedDocList

Parametri

nameNoExt String
extList List String

Valore di ritorno

DedDocList
Vedi anche

Documentazione

Classe DedNetApplication
Overload di FindDocs
Namespace DedNet


Metodo DedNetApplication.FindDocs(String, String)

Metodo DedNetApplicationFindDocs(String, String)
Restituisce una lista di documenti filtrati in base ai criteri passati

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocList FindDocs(
    string nameNoExt,
    string path
)
Public Function FindDocs (
    nameNoExt As String,
    path As String
) As DedDocList
public:
DedDocList^ FindDocs(
    String^ nameNoExt,
    String^ path
)
member FindDocs :
        nameNoExt : string *
        path : string -> DedDocList

Parametri

nameNoExt String
path String

Valore di ritorno

DedDocList
Vedi anche

Documentazione

Classe DedNetApplication
Overload di FindDocs
Namespace DedNet


Metodo DedNetApplication.FindDocs(String, String, List<String>)

Metodo DedNetApplicationFindDocs(String, String, ListString)
Restituisce una lista di documenti filtrati in base ai criteri passati

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocList FindDocs(
    string nameNoExt,
    string path,
    List<string> extList
)
Public Function FindDocs (
    nameNoExt As String,
    path As String,
    extList As List(Of String)
) As DedDocList
public:
DedDocList^ FindDocs(
    String^ nameNoExt,
    String^ path,
    List<String^>^ extList
)
member FindDocs :
        nameNoExt : string *
        path : string *
        extList : List<string> -> DedDocList

Parametri

nameNoExt String
path String
extList List String

Valore di ritorno

DedDocList
Vedi anche

Documentazione

Classe DedNetApplication
Overload di FindDocs
Namespace DedNet


Metodo DedNetApplication.FindDocsByNameLike

Metodo DedNetApplicationFindDocsByNameLike
Restituisce una lista di documenti presenti in un path

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocList FindDocsByNameLike(
    string nameNoExt,
    List<string> extList,
    SqlLikeOperatorEnum likeEnum
)
Public Function FindDocsByNameLike (
    nameNoExt As String,
    extList As List(Of String),
    likeEnum As SqlLikeOperatorEnum
) As DedDocList
public:
DedDocList^ FindDocsByNameLike(
    String^ nameNoExt,
    List<String^>^ extList,
    SqlLikeOperatorEnum likeEnum
)
member FindDocsByNameLike :
        nameNoExt : string *
        extList : List<string> *
        likeEnum : SqlLikeOperatorEnum -> DedDocList

Parametri

nameNoExt String
extList List String
likeEnum SqlLikeOperatorEnum

Valore di ritorno

DedDocList
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.FindDocsByPath

Metodo DedNetApplicationFindDocsByPath
Restituisce una lista di documenti presenti in un path

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocList FindDocsByPath(
    string path,
    List<string> extList,
    bool includeSubDirsDocs = false
)
Public Function FindDocsByPath (
    path As String,
    extList As List(Of String),
    Optional includeSubDirsDocs As Boolean = false
) As DedDocList
public:
DedDocList^ FindDocsByPath(
    String^ path,
    List<String^>^ extList,
    bool includeSubDirsDocs = false
)
member FindDocsByPath :
        path : string *
        extList : List<string> *
        ?includeSubDirsDocs : bool
(* Defaults:
        let _includeSubDirsDocs = defaultArg includeSubDirsDocs false
*)
-> DedDocList

Parametri

path String
extList List String
includeSubDirsDocs Boolean (Optional)

Valore di ritorno

DedDocList
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.FindDocsByPathAndNameLike

Metodo DedNetApplicationFindDocsByPathAndNameLike
Restituisce una lista di documenti presenti in un path

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocList FindDocsByPathAndNameLike(
    string path,
    string nameNoExt,
    List<string> extList,
    SqlLikeOperatorEnum pathLikeEnum,
    SqlLikeOperatorEnum nameLikeEnum
)
Public Function FindDocsByPathAndNameLike (
    path As String,
    nameNoExt As String,
    extList As List(Of String),
    pathLikeEnum As SqlLikeOperatorEnum,
    nameLikeEnum As SqlLikeOperatorEnum
) As DedDocList
public:
DedDocList^ FindDocsByPathAndNameLike(
    String^ path,
    String^ nameNoExt,
    List<String^>^ extList,
    SqlLikeOperatorEnum pathLikeEnum,
    SqlLikeOperatorEnum nameLikeEnum
)
member FindDocsByPathAndNameLike :
        path : string *
        nameNoExt : string *
        extList : List<string> *
        pathLikeEnum : SqlLikeOperatorEnum *
        nameLikeEnum : SqlLikeOperatorEnum -> DedDocList

Parametri

path String
nameNoExt String
extList List String
pathLikeEnum SqlLikeOperatorEnum
nameLikeEnum SqlLikeOperatorEnum

Valore di ritorno

DedDocList
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.FindDocsByPathLike

Metodo DedNetApplicationFindDocsByPathLike
Restituisce una lista di documenti presenti in un path

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocList FindDocsByPathLike(
    string path,
    List<string> extList,
    SqlLikeOperatorEnum likeEnum
)
Public Function FindDocsByPathLike (
    path As String,
    extList As List(Of String),
    likeEnum As SqlLikeOperatorEnum
) As DedDocList
public:
DedDocList^ FindDocsByPathLike(
    String^ path,
    List<String^>^ extList,
    SqlLikeOperatorEnum likeEnum
)
member FindDocsByPathLike :
        path : string *
        extList : List<string> *
        likeEnum : SqlLikeOperatorEnum -> DedDocList

Parametri

path String
extList List String
likeEnum SqlLikeOperatorEnum

Valore di ritorno

DedDocList
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.FindDocsCheckOutByMe

Metodo DedNetApplicationFindDocsCheckOutByMe
Restituisce una lista di documenti in checkOut dall'utente connesso.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocList FindDocsCheckOutByMe(
    List<string> extList,
    bool esclude
)
Public Function FindDocsCheckOutByMe (
    extList As List(Of String),
    esclude As Boolean
) As DedDocList
public:
DedDocList^ FindDocsCheckOutByMe(
    List<String^>^ extList,
    bool esclude
)
member FindDocsCheckOutByMe :
        extList : List<string> *
        esclude : bool -> DedDocList

Parametri

extList List String
esclude Boolean

Valore di ritorno

DedDocList
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.FindDocsEquals

Metodo DedNetApplicationFindDocsEquals
Restituisce una lista di documenti filtrati in base ai criteri esatti, senza l'utilizzo del like

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocList FindDocsEquals(
    string nameNoExt,
    string path
)
Public Function FindDocsEquals (
    nameNoExt As String,
    path As String
) As DedDocList
public:
DedDocList^ FindDocsEquals(
    String^ nameNoExt,
    String^ path
)
member FindDocsEquals :
        nameNoExt : string *
        path : string -> DedDocList

Parametri

nameNoExt String
path String

Valore di ritorno

DedDocList
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.FindDocsToMigrate

Metodo DedNetApplicationFindDocsToMigrate
Restituisce una lista di documenti da migrare in base all'estensione e alla versione dell'addin

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocList FindDocsToMigrate(
    long addinver,
    List<string> extList
)
Public Function FindDocsToMigrate (
    addinver As Long,
    extList As List(Of String)
) As DedDocList
public:
DedDocList^ FindDocsToMigrate(
    long long addinver,
    List<String^>^ extList
)
member FindDocsToMigrate :
        addinver : int64 *
        extList : List<string> -> DedDocList

Parametri

addinver Int64
extList List String

Valore di ritorno

DedDocList
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.FindMainWindow

Metodo DedNetApplicationFindMainWindow
Se impostato, restituisce il valore della proprietà MainWindow, altrimenti restituisce la IWin32Window della MainWindow del processo corrente.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public IWin32Window FindMainWindow()
Public Function FindMainWindow As IWin32Window
public:
IWin32Window^ FindMainWindow()
member FindMainWindow : unit -> IWin32Window

Valore di ritorno

IWin32Window
Restituisce l'oggetto oppure null se non è presente.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.FireEditAttrValidatingEvent

Metodo DedNetApplicationFireEditAttrValidatingEvent
Esegue evento per validare gli attributi.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool FireEditAttrValidatingEvent(
    IDedEditable _dedData,
    bool silent
)
Public Function FireEditAttrValidatingEvent (
    _dedData As IDedEditable,
    silent As Boolean
) As Boolean
public:
bool FireEditAttrValidatingEvent(
    IDedEditable^ _dedData,
    bool silent
)
member FireEditAttrValidatingEvent :
        _dedData : IDedEditable *
        silent : bool -> bool

Parametri

_dedData IDedEditable
anagrafica in editazione
silent Boolean
Indica se mostrare i messaggi a video o no.

Valore di ritorno

Boolean
Restituisce true se gli attributi vanno bene altrimenti false.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.FixCodIdNull

Metodo DedNetApplicationFixCodIdNull
Corregge le eventuali anagrafiche che hanno COD_ID in DED_DATA_ENCODE vuoto. Può verificarsi per via di un hotfix con un bug in corso di 23.0.0

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void FixCodIdNull()
Public Sub FixCodIdNull
public:
void FixCodIdNull()
member FixCodIdNull : unit -> unit
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.GetAllAttrInDb

Metodo DedNetApplicationGetAllAttrInDb
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | GetAllAttrInDb | Restituisce tutti gli attributi con ambiene anagrafica (Anagrafica, AnagraficaEDistinta, ecc..) presenti nel Db. Gli attributi di solo distinta sono esclusi.
Metodo pubblico | GetAllAttrInDb(Boolean) | Restituisce tutti gli attributi con ambiene anagrafica (Anagrafica, AnagraficaEDistinta, ecc..) presenti nel Db.
Metodo pubblico | GetAllAttrInDb(Boolean, Boolean) | Restituisce tutti gli attributi con ambiene anagrafica (Anagrafica, AnagraficaEDistinta, ecc..) presenti nel Db.
Torna su
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.GetAllAttrInDb

Metodo DedNetApplicationGetAllAttrInDb
Restituisce tutti gli attributi con ambiene anagrafica (Anagrafica, AnagraficaEDistinta, ecc..) presenti nel Db. Gli attributi di solo distinta sono esclusi.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<DedAttr> GetAllAttrInDb()
Public Function GetAllAttrInDb As List(Of DedAttr)
public:
List<DedAttr^>^ GetAllAttrInDb()
member GetAllAttrInDb : unit -> List<DedAttr>

Valore di ritorno

List DedAttr
Vedi anche

Documentazione

Classe DedNetApplication
Overload di GetAllAttrInDb
Namespace DedNet


Metodo DedNetApplication.GetAllAttrInDb(Boolean)

Metodo DedNetApplicationGetAllAttrInDb(Boolean)
Restituisce tutti gli attributi con ambiene anagrafica (Anagrafica, AnagraficaEDistinta, ecc..) presenti nel Db.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<DedAttr> GetAllAttrInDb(
    bool includeBomAttrs
)
Public Function GetAllAttrInDb (
    includeBomAttrs As Boolean
) As List(Of DedAttr)
public:
List<DedAttr^>^ GetAllAttrInDb(
    bool includeBomAttrs
)
member GetAllAttrInDb :
        includeBomAttrs : bool -> List<DedAttr>

Parametri

includeBomAttrs Boolean
Indica se includere anche gli attributi di distinta.

Valore di ritorno

List DedAttr
Vedi anche

Documentazione

Classe DedNetApplication
Overload di GetAllAttrInDb
Namespace DedNet


Metodo DedNetApplication.GetAllAttrInDb(Boolean, Boolean)

Metodo DedNetApplicationGetAllAttrInDb(Boolean, Boolean)
Restituisce tutti gli attributi con ambiene anagrafica (Anagrafica, AnagraficaEDistinta, ecc..) presenti nel Db.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<DedAttr> GetAllAttrInDb(
    bool includeBomAttrs,
    bool allowRedefined
)
Public Function GetAllAttrInDb (
    includeBomAttrs As Boolean,
    allowRedefined As Boolean
) As List(Of DedAttr)
public:
List<DedAttr^>^ GetAllAttrInDb(
    bool includeBomAttrs,
    bool allowRedefined
)
member GetAllAttrInDb :
        includeBomAttrs : bool *
        allowRedefined : bool -> List<DedAttr>

Parametri

includeBomAttrs Boolean
Indica se includere anche gli attributi di distinta.
allowRedefined Boolean
Indica se includere nella lista anche eventuali attributi ridefiniti.

Valore di ritorno

List DedAttr
Vedi anche

Documentazione

Classe DedNetApplication
Overload di GetAllAttrInDb
Namespace DedNet


Metodo DedNetApplication.GetAllComm

Metodo DedNetApplicationGetAllComm
Restituisce la lista completa di tutte le commesse di primo livello. Restituisce una lista sempre inizializzata.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommList GetAllComm(
    DedDataList anagrList = null,
    string freeTextSearch = null,
    DedCommTypeList dedTypeList = null
)
Public Function GetAllComm (
    Optional anagrList As DedDataList = Nothing,
    Optional freeTextSearch As String = Nothing,
    Optional dedTypeList As DedCommTypeList = Nothing
) As DedCommList
public:
DedCommList^ GetAllComm(
    DedDataList^ anagrList = nullptr,
    String^ freeTextSearch = nullptr,
    DedCommTypeList^ dedTypeList = nullptr
)
member GetAllComm :
        ?anagrList : DedDataList *
        ?freeTextSearch : string *
        ?dedTypeList : DedCommTypeList
(* Defaults:
        let _anagrList = defaultArg anagrList null
        let _freeTextSearch = defaultArg freeTextSearch null
        let _dedTypeList = defaultArg dedTypeList null
*)
-> DedCommList

Parametri

anagrList DedDataList (Optional)
freeTextSearch String (Optional)
dedTypeList DedCommTypeList (Optional)

Valore di ritorno

DedCommList
Eccezioni
Eccezione | Condizione
ArgumentNullException | Parametro mancante.
QsException | Errore avvenuto durante l'istruzione di select.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.GetAllDocumentPaths

Metodo DedNetApplicationGetAllDocumentPaths
Restituisce tutti i path univoci dai documenti registrati nel database

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<string, List<string>> GetAllDocumentPaths(
    List<string> pathToHide = null,
    List<string> additionalPaths = null
)
Public Function GetAllDocumentPaths (
    Optional pathToHide As List(Of String) = Nothing,
    Optional additionalPaths As List(Of String) = Nothing
) As Dictionary(Of String, List(Of String))
public:
Dictionary<String^, List<String^>^>^ GetAllDocumentPaths(
    List<String^>^ pathToHide = nullptr,
    List<String^>^ additionalPaths = nullptr
)
member GetAllDocumentPaths :
        ?pathToHide : List<string> *
        ?additionalPaths : List<string>
(* Defaults:
        let _pathToHide = defaultArg pathToHide null
        let _additionalPaths = defaultArg additionalPaths null
*)
-> Dictionary<string, List<string>>

Parametri

pathToHide List String (Optional)
Path da escludere
additionalPaths List String (Optional)
Percorsi addizionali

Valore di ritorno

Dictionary String, List String
Creo un dizionario con i percorsi strutturati Es. key = %ROOT%\PATH -> value = %ROOT%\PATH\SUBPATH
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.GetAttrPrompt

Metodo DedNetApplicationGetAttrPrompt
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | GetAttrPrompt(DedDataStandardDataFields) | Restituisce il prompt di un attributo standard.
Metodo pubblico | GetAttrPrompt(String) | Restituisce il prompt di un attributo standard.
Torna su
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.GetAttrPrompt(DedData.StandardDataFields)

Metodo DedNetApplicationGetAttrPrompt(DedDataStandardDataFields)
Restituisce il prompt di un attributo standard.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string GetAttrPrompt(
    DedDataStandardDataFields field
)
Public Function GetAttrPrompt (
    field As DedDataStandardDataFields
) As String
public:
String^ GetAttrPrompt(
    DedDataStandardDataFields field
)
member GetAttrPrompt :
        field : DedDataStandardDataFields -> string

Parametri

field DedDataStandardDataFields
Campo standard del quale restituire il prompt.

Valore di ritorno

String
Restituisce il prompt trovato oppure stringa vuota.
Vedi anche

Documentazione

Classe DedNetApplication
Overload di GetAttrPrompt
Namespace DedNet


Metodo DedNetApplication.GetAttrPrompt(String)

Metodo DedNetApplicationGetAttrPrompt(String)
Restituisce il prompt di un attributo standard.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string GetAttrPrompt(
    string field
)
Public Function GetAttrPrompt (
    field As String
) As String
public:
String^ GetAttrPrompt(
    String^ field
)
member GetAttrPrompt :
        field : string -> string

Parametri

field String
Nome del campo del quale restituire il prompt.

Valore di ritorno

String
Restituisce il prompt trovato oppure stringa vuota.
Vedi anche

Documentazione

Classe DedNetApplication
Overload di GetAttrPrompt
Namespace DedNet


Metodo DedNetApplication.GetEveryAttrInDb

Metodo DedNetApplicationGetEveryAttrInDb
Restituisce tutti gli attributi di famiglia e ricambio presenti nel Db.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<DedAttr> GetEveryAttrInDb()
Public Function GetEveryAttrInDb As List(Of DedAttr)
public:
List<DedAttr^>^ GetEveryAttrInDb()
member GetEveryAttrInDb : unit -> List<DedAttr>

Valore di ritorno

List DedAttr
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.GetEveryCalculatedAttr

Metodo DedNetApplicationGetEveryCalculatedAttr
Ritorna tutti gli attributi importati presenti nel db.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList GetEveryCalculatedAttr()
Public Function GetEveryCalculatedAttr As DedAttrList
public:
DedAttrList^ GetEveryCalculatedAttr()
member GetEveryCalculatedAttr : unit -> DedAttrList

Valore di ritorno

DedAttrList
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.GetEveryCommAttrInDb

Metodo DedNetApplicationGetEveryCommAttrInDb
Restituisce tutti gli attributi con ambiente anagrafica (Anagrafica, AnagraficaEDistinta, ecc..) presenti nel Db.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<DedAttr> GetEveryCommAttrInDb()
Public Function GetEveryCommAttrInDb As List(Of DedAttr)
public:
List<DedAttr^>^ GetEveryCommAttrInDb()
member GetEveryCommAttrInDb : unit -> List<DedAttr>

Valore di ritorno

List DedAttr
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.GetFileDependency

Metodo DedNetApplicationGetFileDependency
Restituisce la lista delle dipendenze di un documento partendo dal suo nome file completo. Viene utilizzata per avere le dipendenze di un documento che non è ancora stato archiviato. Chiama l'evento DefineFileDependency per permettere al client di intervenire.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocDepFileList GetFileDependency(
    string fileName
)
Public Function GetFileDependency (
    fileName As String
) As DocDepFileList
public:
DocDepFileList^ GetFileDependency(
    String^ fileName
)
member GetFileDependency :
        fileName : string -> DocDepFileList

Parametri

fileName String
Nome completo del file del quale avere le dipendenze.

Valore di ritorno

DocDepFileList
Restituisce una lista di dipendenze sempre inizializzata ma vuota nel caso in cui non ce ne siano.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.GetFindCommand

Metodo DedNetApplicationGetFindCommand
Restituisce il comando "ricerca" memorizzato nella cache (evita di crearne un altro velocizzando il tutto). Proprietà utilizzata principalmente nei vari add-in. ATTENZIONE! Dato che il riferimento in memoria è sempre lo stesso, se si effettuano delle modifiche alle proprietà del comando, queste verranno riportate anche negli utilizzi successivi!

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public FindCommand GetFindCommand()
Public Function GetFindCommand As FindCommand
public:
FindCommand^ GetFindCommand()
member GetFindCommand : unit -> FindCommand

Valore di ritorno

FindCommand
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.GetFindDocsCommand

Metodo DedNetApplicationGetFindDocsCommand
Restituisce il comando "ricerca documentale" memorizzato nella cache (evita di crearne un altro velocizzando il tutto). Proprietà utilizzata principalmente nei vari add-in. ATTENZIONE! Dato che il riferimento in memoria è sempre lo stesso, se si effettuano delle modifiche alle proprietà del comando, queste verranno riportate anche negli utilizzi successivi!

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public FindDocCommand GetFindDocsCommand()
Public Function GetFindDocsCommand As FindDocCommand
public:
FindDocCommand^ GetFindDocsCommand()
member GetFindDocsCommand : unit -> FindDocCommand

Valore di ritorno

FindDocCommand
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.GetMessageFromEx

Metodo DedNetApplicationGetMessageFromEx
Crea uno StringBuilder con il messaggio completo dell'errore partendo dall'eccezione ricevuta.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void GetMessageFromEx(
    Exception ex,
    ref StringBuilder rest
)
Public Sub GetMessageFromEx (
    ex As Exception,
    ByRef rest As StringBuilder
)
public:
void GetMessageFromEx(
    Exception^ ex,
    StringBuilder^% rest
)
member GetMessageFromEx :
        ex : Exception *
        rest : StringBuilder byref -> unit

Parametri

ex Exception
Eccezione da analizzare
rest StringBuilder
Messaggio restituito
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.GetMovedDoc

Metodo DedNetApplicationGetMovedDoc
Dato un file name ritorna il documento sostituto corrispondente.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDoc GetMovedDoc(
    string fullFileName
)
Public Function GetMovedDoc (
    fullFileName As String
) As DedDoc
public:
DedDoc^ GetMovedDoc(
    String^ fullFileName
)
member GetMovedDoc :
        fullFileName : string -> DedDoc

Parametri

fullFileName String
Path assoluto del file originale

Valore di ritorno

DedDoc
Documento corrispondente al documento "moved" codificato.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.GetRegistryDedBaseDir

Metodo DedNetApplicationGetRegistryDedBaseDir
Metodo per impostare la chiave di registro del Ded con la versione attuale

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string GetRegistryDedBaseDir()
Public Function GetRegistryDedBaseDir As String
public:
String^ GetRegistryDedBaseDir()
member GetRegistryDedBaseDir : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.HasAtLeastOneLinkingContext

Metodo DedNetApplicationHasAtLeastOneLinkingContext
Retituisce true se il documento ha almeno un contesto di linking nei confronti di una anagrafica

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasAtLeastOneLinkingContext(
    Guid docid
)
Public Function HasAtLeastOneLinkingContext (
    docid As Guid
) As Boolean
public:
bool HasAtLeastOneLinkingContext(
    Guid docid
)
member HasAtLeastOneLinkingContext :
        docid : Guid -> bool

Parametri

docid Guid
DocID del documento da cercare.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.HasMovedDoc

Metodo DedNetApplicationHasMovedDoc
Ritorna vero se esiste un documento "moved" corrispondente

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasMovedDoc(
    string fullFileName
)
Public Function HasMovedDoc (
    fullFileName As String
) As Boolean
public:
bool HasMovedDoc(
    String^ fullFileName
)
member HasMovedDoc :
        fullFileName : string -> bool

Parametri

fullFileName String
Path assoluto del file da esaminare

Valore di ritorno

Boolean
Booleano di riscontro
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.Init

Metodo DedNetApplicationInit
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Init | Inizializza le strutture dati e le variabili leggendole dal Database. Se restituisce false l'errore avvenuto è reperibile attraverso la proprietà LastError.
Metodo pubblico | Init(String, String) | Inizializza le strutture dati e le variabili leggendole dal Database utilizzando una specifica stringa di connessione. Se restituisce false l'errore avvenuto è reperibile attraverso la proprietà LastError.
Torna su
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.Init

Metodo DedNetApplicationInit
Inizializza le strutture dati e le variabili leggendole dal Database. Se restituisce false l'errore avvenuto è reperibile attraverso la proprietà LastError.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Init()
Public Function Init As Boolean
public:
virtual bool Init() sealed
abstract Init : unit -> bool
override Init : unit -> bool

Valore di ritorno

Boolean
Restituisce true se riesce altrimenti false.

Implementa

IDedNetApplicationInit
Vedi anche

Documentazione

Classe DedNetApplication
Overload di Init
Namespace DedNet


Metodo DedNetApplication.Init(String, String)

Metodo DedNetApplicationInit(String, String)
Inizializza le strutture dati e le variabili leggendole dal Database utilizzando una specifica stringa di connessione. Se restituisce false l'errore avvenuto è reperibile attraverso la proprietà LastError.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Init(
    string providerName,
    string connectionString
)
Public Function Init (
    providerName As String,
    connectionString As String
) As Boolean
public:
virtual bool Init(
    String^ providerName,
    String^ connectionString
) sealed
abstract Init :
        providerName : string *
        connectionString : string -> bool
override Init :
        providerName : string *
        connectionString : string -> bool

Parametri

providerName String
Nome del provider per la connessione al Database.
connectionString String
Stringa di connessione per connettersi al Database.

Valore di ritorno

Boolean
Restituisce true se riesce altrimenti false.

Implementa

IDedNetApplicationInit(String, String)
Vedi anche

Documentazione

Classe DedNetApplication
Overload di Init
Namespace DedNet


Metodo DedNetApplication.InitWithConnStringOnly

Metodo DedNetApplicationInitWithConnStringOnly
Inizializza il ded utilizzando unicamente i parametri di connessione forniti senza utilizzare il file ini

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool InitWithConnStringOnly(
    string providerName,
    string connectionString
)
Public Function InitWithConnStringOnly (
    providerName As String,
    connectionString As String
) As Boolean
public:
bool InitWithConnStringOnly(
    String^ providerName,
    String^ connectionString
)
member InitWithConnStringOnly :
        providerName : string *
        connectionString : string -> bool

Parametri

providerName String
connectionString String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.InitWithUserAlreadyLoaded

Metodo DedNetApplicationInitWithUserAlreadyLoaded
Inizializzazione completa ma specifica per utente Non richiede l'autenticazione dell'utente perchè l'informazione dell'utente è già caricata. Se restituisce false l'errore avvenuto è reperibile attraverso la proprietà LastError.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool InitWithUserAlreadyLoaded()
Public Function InitWithUserAlreadyLoaded As Boolean
public:
bool InitWithUserAlreadyLoaded()
member InitWithUserAlreadyLoaded : unit -> bool

Valore di ritorno

Boolean
Restituisce true se riesce altrimenti false.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.IsDocErased

Metodo DedNetApplicationIsDocErased
Ritorna vero se il documento figura tra gli eliminati

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsDocErased(
    string fullFileName
)
Public Function IsDocErased (
    fullFileName As String
) As Boolean
public:
bool IsDocErased(
    String^ fullFileName
)
member IsDocErased :
        fullFileName : string -> bool

Parametri

fullFileName String
Path assoluto del file da esaminare

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.IsMultipleStateChangeExecuteRegister

Metodo DedNetApplicationIsMultipleStateChangeExecuteRegister
Restituisce se è stato o meno inizializzato l'evento lua

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsMultipleStateChangeExecuteRegister()
Public Function IsMultipleStateChangeExecuteRegister As Boolean
public:
bool IsMultipleStateChangeExecuteRegister()
member IsMultipleStateChangeExecuteRegister : unit -> bool

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.LightInitWithoutAuthentication

Metodo DedNetApplicationLightInitWithoutAuthentication
Esegue l'inizializzazione minima per poter almeno accedere alle variabili. Non richiede l'autenticazione dell'utente. Se restituisce false l'errore avvenuto è reperibile attraverso la proprietà LastError.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool LightInitWithoutAuthentication()
Public Function LightInitWithoutAuthentication As Boolean
public:
bool LightInitWithoutAuthentication()
member LightInitWithoutAuthentication : unit -> bool

Valore di ritorno

Boolean
Restituisce true se riesce altrimenti false.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.Log

Metodo DedNetApplicationLog
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Log(Exception) | Registra il messaggio nel file di Log dell'applicazione.
Metodo pubblico | Log(String) | Registra il messaggio nei file di Log.
Metodo pubblico | Log(Exception, LogMessageTypeEnum) | Registra il messaggio nel file di Log dell'applicazione.
Metodo pubblico | Log(String, LogMessageTypeEnum) | Registra il messaggio nel file di Log dell'applicazione.
Metodo pubblico | Log(String, String) | Registra il messaggio nei file di Log.
Torna su
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.Log(Exception)

Metodo DedNetApplicationLog(Exception)
Registra il messaggio nel file di Log dell'applicazione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Log(
    Exception ex
)
Public Sub Log (
    ex As Exception
)
public:
void Log(
    Exception^ ex
)
member Log :
        ex : Exception -> unit

Parametri

ex Exception
Eccezione da registrare nel file di Log.
Vedi anche

Documentazione

Classe DedNetApplication
Overload di Log
Namespace DedNet


Metodo DedNetApplication.Log(String)

Metodo DedNetApplicationLog(String)
Registra il messaggio nei file di Log.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Log(
    string message
)
Public Sub Log (
    message As String
)
public:
void Log(
    String^ message
)
member Log :
        message : string -> unit

Parametri

message String
Messaggio da registrare nel file di Log.
Vedi anche

Documentazione

Classe DedNetApplication
Overload di Log
Namespace DedNet


Metodo DedNetApplication.Log(Exception, LogMessageTypeEnum)

Metodo DedNetApplicationLog(Exception, LogMessageTypeEnum)
Registra il messaggio nel file di Log dell'applicazione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Log(
    Exception ex,
    LogMessageTypeEnum exType
)
Public Sub Log (
    ex As Exception,
    exType As LogMessageTypeEnum
)
public:
void Log(
    Exception^ ex,
    LogMessageTypeEnum exType
)
member Log :
        ex : Exception *
        exType : LogMessageTypeEnum -> unit

Parametri

ex Exception
Eccezione da registrare nel file di Log.
exType LogMessageTypeEnum
Gravità dell'eccezione.
Vedi anche

Documentazione

Classe DedNetApplication
Overload di Log
Namespace DedNet


Metodo DedNetApplication.Log(String, LogMessageTypeEnum)

Metodo DedNetApplicationLog(String, LogMessageTypeEnum)
Registra il messaggio nel file di Log dell'applicazione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Log(
    string msg,
    LogMessageTypeEnum exType
)
Public Sub Log (
    msg As String,
    exType As LogMessageTypeEnum
)
public:
void Log(
    String^ msg,
    LogMessageTypeEnum exType
)
member Log :
        msg : string *
        exType : LogMessageTypeEnum -> unit

Parametri

msg String
Messaggio da registrare nel file di Log.
exType LogMessageTypeEnum
Gravità dell'eccezione.
Vedi anche

Documentazione

Classe DedNetApplication
Overload di Log
Namespace DedNet


Metodo DedNetApplication.Log(String, String)

Metodo DedNetApplicationLog(String, String)
Registra il messaggio nei file di Log.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Log(
    string modulename,
    string message
)
Public Sub Log (
    modulename As String,
    message As String
)
public:
void Log(
    String^ modulename,
    String^ message
)
member Log :
        modulename : string *
        message : string -> unit

Parametri

modulename String
Nome del modulo dal quale proviene la registrazione.
message String
Messaggio da registrare nel file di Log.
Vedi anche

Documentazione

Classe DedNetApplication
Overload di Log
Namespace DedNet


Metodo DedNetApplication.Login

Metodo DedNetApplicationLogin
Chiede il login all'utente ed inizializza tutti i permessi, se è attiva la gestione degli utenti, altrimenti inizializza il nome utente di default, prendendolo da Windows. Chiede nome utente e password anche se il login è già stato effettuato. Indica di chiedere obbligatoriamente il login (anche nel caso di autenticazione di windows).

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Login(
    bool askLogIn
)
Public Sub Login (
    askLogIn As Boolean
)
public:
void Login(
    bool askLogIn
)
member Login :
        askLogIn : bool -> unit

Parametri

askLogIn Boolean
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.LogInfo

Metodo DedNetApplicationLogInfo
Registra il messaggio nei file di Log.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void LogInfo(
    string message
)
Public Sub LogInfo (
    message As String
)
public:
void LogInfo(
    String^ message
)
member LogInfo :
        message : string -> unit

Parametri

message String
Messaggio da registrare nel file di Log.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.LogTest

Metodo DedNetApplicationLogTest
Registra il messaggio nei file di Log.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void LogTest(
    string message
)
Public Sub LogTest (
    message As String
)
public:
void LogTest(
    String^ message
)
member LogTest :
        message : string -> unit

Parametri

message String
Messaggio da registrare nel file di Log.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnAddDataDocEvent

Metodo DedNetApplicationOnAddDataDocEvent
Lancia l'evento LinkingDataDocEvent.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnAddDataDocEvent(
    AddDataDocEventArgs e
)
Protected Friend Sub OnAddDataDocEvent (
    e As AddDataDocEventArgs
)
protected public:
void OnAddDataDocEvent(
    AddDataDocEventArgs^ e
)
member OnAddDataDocEvent :
        e : AddDataDocEventArgs -> unit

Parametri

e AddDataDocEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnAddExtensionsRecognizerForm

Metodo DedNetApplicationOnAddExtensionsRecognizerForm
Lancia l'evento per aggiungere delle estensioni al form di riconoscimento file/cartelle

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void OnAddExtensionsRecognizerForm(
    AddExtensionsRecognizerEventArgs e
)
Public Sub OnAddExtensionsRecognizerForm (
    e As AddExtensionsRecognizerEventArgs
)
public:
void OnAddExtensionsRecognizerForm(
    AddExtensionsRecognizerEventArgs^ e
)
member OnAddExtensionsRecognizerForm :
        e : AddExtensionsRecognizerEventArgs -> unit

Parametri

e AddExtensionsRecognizerEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnAfterEraseEmptyPwsFolder

Metodo DedNetApplicationOnAfterEraseEmptyPwsFolder
Chiama l'evento AfterEraseEmptyPwsFolderEvent.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnAfterEraseEmptyPwsFolder()
Protected Friend Sub OnAfterEraseEmptyPwsFolder
protected public:
void OnAfterEraseEmptyPwsFolder()
member OnAfterEraseEmptyPwsFolder : unit -> unit
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnAfterSaveDedCommTypeEvent

Metodo DedNetApplicationOnAfterSaveDedCommTypeEvent
Chiama l'evento AfterSaveEvent.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnAfterSaveDedCommTypeEvent(
    AfterSaveEventArgs e
)
Protected Friend Sub OnAfterSaveDedCommTypeEvent (
    e As AfterSaveEventArgs
)
protected public:
void OnAfterSaveDedCommTypeEvent(
    AfterSaveEventArgs^ e
)
member OnAfterSaveDedCommTypeEvent :
        e : AfterSaveEventArgs -> unit

Parametri

e AfterSaveEventArgs
Oggetto DedRuleParserEventArg.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnAfterSaveDedTypeEvent

Metodo DedNetApplicationOnAfterSaveDedTypeEvent
Chiama l'evento AfterSaveEvent.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnAfterSaveDedTypeEvent(
    AfterSaveEventArgs e
)
Protected Friend Sub OnAfterSaveDedTypeEvent (
    e As AfterSaveEventArgs
)
protected public:
void OnAfterSaveDedTypeEvent(
    AfterSaveEventArgs^ e
)
member OnAfterSaveDedTypeEvent :
        e : AfterSaveEventArgs -> unit

Parametri

e AfterSaveEventArgs
Oggetto DedRuleParserEventArg.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnAnagrSelectionDeleted

Metodo DedNetApplicationOnAnagrSelectionDeleted
Lancia l'evento che viene scatenato al termine dell'eliminazione di tutta la selezione di anagrafiche

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnAnagrSelectionDeleted(
    AnagrSelectionDeletedEventArgs e
)
Protected Friend Sub OnAnagrSelectionDeleted (
    e As AnagrSelectionDeletedEventArgs
)
protected public:
void OnAnagrSelectionDeleted(
    AnagrSelectionDeletedEventArgs^ e
)
member OnAnagrSelectionDeleted :
        e : AnagrSelectionDeletedEventArgs -> unit

Parametri

e AnagrSelectionDeletedEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnAttributeChanged

Metodo DedNetApplicationOnAttributeChanged
Lancia l'evento AttributeChanged.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void OnAttributeChanged(
    Object sender,
    EventArgs e
)
Public Sub OnAttributeChanged (
    sender As Object,
    e As EventArgs
)
public:
void OnAttributeChanged(
    Object^ sender,
    EventArgs^ e
)
member OnAttributeChanged :
        sender : Object *
        e : EventArgs -> unit

Parametri

sender Object
e EventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnAttributeInit

Metodo DedNetApplicationOnAttributeInit
Lancia l'evento AttributeInit.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void OnAttributeInit(
    Object sender,
    EventArgs e
)
Public Sub OnAttributeInit (
    sender As Object,
    e As EventArgs
)
public:
void OnAttributeInit(
    Object^ sender,
    EventArgs^ e
)
member OnAttributeInit :
        sender : Object *
        e : EventArgs -> unit

Parametri

sender Object
e EventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnBeforeShowZoomPreviewEvent

Metodo DedNetApplicationOnBeforeShowZoomPreviewEvent
Lancia l'evento BeforeShowZoomPreview.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void OnBeforeShowZoomPreviewEvent(
    QSTopDwgViewerProfile e
)
Public Sub OnBeforeShowZoomPreviewEvent (
    e As QSTopDwgViewerProfile
)
public:
void OnBeforeShowZoomPreviewEvent(
    QSTopDwgViewerProfile^ e
)
member OnBeforeShowZoomPreviewEvent :
        e : QSTopDwgViewerProfile -> unit

Parametri

e QSTopDwgViewerProfile
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnBomEditFormButtonClick

Metodo DedNetApplicationOnBomEditFormButtonClick
Lancia l'evento BomEditFormButtonClickEvent.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnBomEditFormButtonClick(
    Object sender,
    DedBomEditCustomControlEventArgs e
)
Protected Friend Sub OnBomEditFormButtonClick (
    sender As Object,
    e As DedBomEditCustomControlEventArgs
)
protected public:
void OnBomEditFormButtonClick(
    Object^ sender,
    DedBomEditCustomControlEventArgs^ e
)
member OnBomEditFormButtonClick :
        sender : Object *
        e : DedBomEditCustomControlEventArgs -> unit

Parametri

sender Object
e DedBomEditCustomControlEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnBomEditFormToggleSwitch

Metodo DedNetApplicationOnBomEditFormToggleSwitch
Lancia l'evento BomEditFormButtonClickEvent.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnBomEditFormToggleSwitch(
    Object sender,
    DedBomEditCustomControlEventArgs e
)
Protected Friend Sub OnBomEditFormToggleSwitch (
    sender As Object,
    e As DedBomEditCustomControlEventArgs
)
protected public:
void OnBomEditFormToggleSwitch(
    Object^ sender,
    DedBomEditCustomControlEventArgs^ e
)
member OnBomEditFormToggleSwitch :
        sender : Object *
        e : DedBomEditCustomControlEventArgs -> unit

Parametri

sender Object
e DedBomEditCustomControlEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnBomExplorerAddReplaceData

Metodo DedNetApplicationOnBomExplorerAddReplaceData
Lancia l'evento BomExplorerAddReplaceDataEvent.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnBomExplorerAddReplaceData(
    Object sender,
    BomExplorerAddReplaceDataEventArgs e
)
Protected Friend Sub OnBomExplorerAddReplaceData (
    sender As Object,
    e As BomExplorerAddReplaceDataEventArgs
)
protected public:
void OnBomExplorerAddReplaceData(
    Object^ sender,
    BomExplorerAddReplaceDataEventArgs^ e
)
member OnBomExplorerAddReplaceData :
        sender : Object *
        e : BomExplorerAddReplaceDataEventArgs -> unit

Parametri

sender Object
e BomExplorerAddReplaceDataEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnBomExplorerButtonClick

Metodo DedNetApplicationOnBomExplorerButtonClick
Lancia l'evento BomExplorerButtonClickEvent.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnBomExplorerButtonClick(
    Object sender,
    BomExplorerButtonClickEventArgs e
)
Protected Friend Sub OnBomExplorerButtonClick (
    sender As Object,
    e As BomExplorerButtonClickEventArgs
)
protected public:
void OnBomExplorerButtonClick(
    Object^ sender,
    BomExplorerButtonClickEventArgs^ e
)
member OnBomExplorerButtonClick :
        sender : Object *
        e : BomExplorerButtonClickEventArgs -> unit

Parametri

sender Object
e BomExplorerButtonClickEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnBomExplorerContextMenuOpening

Metodo DedNetApplicationOnBomExplorerContextMenuOpening
Lancia l'evento BomExplorerContextMenuOpening.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnBomExplorerContextMenuOpening(
    Object sender,
    BomExplorerContextMenuOpeningEventArgs e
)
Protected Friend Sub OnBomExplorerContextMenuOpening (
    sender As Object,
    e As BomExplorerContextMenuOpeningEventArgs
)
protected public:
void OnBomExplorerContextMenuOpening(
    Object^ sender,
    BomExplorerContextMenuOpeningEventArgs^ e
)
member OnBomExplorerContextMenuOpening :
        sender : Object *
        e : BomExplorerContextMenuOpeningEventArgs -> unit

Parametri

sender Object
e BomExplorerContextMenuOpeningEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnBomExplorerLoadDist

Metodo DedNetApplicationOnBomExplorerLoadDist
Lancia l'evento BomExplorerButtonClickEvent.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnBomExplorerLoadDist(
    Object sender,
    BomExplorerLoadDistEventArgs e
)
Protected Friend Sub OnBomExplorerLoadDist (
    sender As Object,
    e As BomExplorerLoadDistEventArgs
)
protected public:
void OnBomExplorerLoadDist(
    Object^ sender,
    BomExplorerLoadDistEventArgs^ e
)
member OnBomExplorerLoadDist :
        sender : Object *
        e : BomExplorerLoadDistEventArgs -> unit

Parametri

sender Object
e BomExplorerLoadDistEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnChangeStateECO

Metodo DedNetApplicationOnChangeStateECO
Chiama l'evento ChangeStateECOEvent.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnChangeStateECO(
    DedECOChangeStateCommandEventArgs e
)
Protected Friend Sub OnChangeStateECO (
    e As DedECOChangeStateCommandEventArgs
)
protected public:
void OnChangeStateECO(
    DedECOChangeStateCommandEventArgs^ e
)
member OnChangeStateECO :
        e : DedECOChangeStateCommandEventArgs -> unit

Parametri

e DedECOChangeStateCommandEventArgs
Informazioni per l'evento.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnChangingDependencyDocument

Metodo DedNetApplicationOnChangingDependencyDocument
Chiama l'evento ChangingDependencyDocument.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnChangingDependencyDocument(
    Object sender,
    ChangingDependencyDocumentEventArgs e
)
Protected Friend Sub OnChangingDependencyDocument (
    sender As Object,
    e As ChangingDependencyDocumentEventArgs
)
protected public:
void OnChangingDependencyDocument(
    Object^ sender,
    ChangingDependencyDocumentEventArgs^ e
)
member OnChangingDependencyDocument :
        sender : Object *
        e : ChangingDependencyDocumentEventArgs -> unit

Parametri

sender Object
e ChangingDependencyDocumentEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnCheckProgrReservedEvent

Metodo DedNetApplicationOnCheckProgrReservedEvent
Lancia l'evento CheckProgrReservedEvent

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnCheckProgrReservedEvent(
    CheckProgrReservedEventArgs e
)
Protected Friend Sub OnCheckProgrReservedEvent (
    e As CheckProgrReservedEventArgs
)
protected public:
void OnCheckProgrReservedEvent(
    CheckProgrReservedEventArgs^ e
)
member OnCheckProgrReservedEvent :
        e : CheckProgrReservedEventArgs -> unit

Parametri

e CheckProgrReservedEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnCheckRevAlphabetEvent

Metodo DedNetApplicationOnCheckRevAlphabetEvent
Lancia l'evento CheckAlphabetEvent

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnCheckRevAlphabetEvent(
    CheckRevAlphabetEventArgs e
)
Protected Friend Sub OnCheckRevAlphabetEvent (
    e As CheckRevAlphabetEventArgs
)
protected public:
void OnCheckRevAlphabetEvent(
    CheckRevAlphabetEventArgs^ e
)
member OnCheckRevAlphabetEvent :
        e : CheckRevAlphabetEventArgs -> unit

Parametri

e CheckRevAlphabetEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnClassListItemClick

Metodo DedNetApplicationOnClassListItemClick
Chiama l'evento ClassListItemClick.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnClassListItemClick(
    DedEditAnagrControl _ctr,
    ClassListItemClickEventArgs ev
)
Protected Friend Sub OnClassListItemClick (
    _ctr As DedEditAnagrControl,
    ev As ClassListItemClickEventArgs
)
protected public:
void OnClassListItemClick(
    DedEditAnagrControl^ _ctr,
    ClassListItemClickEventArgs^ ev
)
member OnClassListItemClick :
        _ctr : DedEditAnagrControl *
        ev : ClassListItemClickEventArgs -> unit

Parametri

_ctr DedEditAnagrControl
Form chiamante.
ev ClassListItemClickEventArgs
Oggetto ProcessNewValueEventArgs inizializzato da passare all'evento.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnCommAddAnagItem

Metodo DedNetApplicationOnCommAddAnagItem
Lancia l'evento CommAddAnagItemEvent.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnCommAddAnagItem(
    Object sender,
    CommAnagEventArgs e
)
Protected Friend Sub OnCommAddAnagItem (
    sender As Object,
    e As CommAnagEventArgs
)
protected public:
void OnCommAddAnagItem(
    Object^ sender,
    CommAnagEventArgs^ e
)
member OnCommAddAnagItem :
        sender : Object *
        e : CommAnagEventArgs -> unit

Parametri

sender Object
e CommAnagEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnCommandExecuting

Metodo DedNetApplicationOnCommandExecuting
Lancia l'evento di esecuzione comando.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnCommandExecuting(
    DedCommand command,
    DedEventTimeEnum BeforeOrAfter,
    DedCommandRunningContextEnum runningCtx,
    ref DedEventHandlerEnum HandlingCode,
    ref DedCmdResult CommandResult
)
Protected Friend Sub OnCommandExecuting (
    command As DedCommand,
    BeforeOrAfter As DedEventTimeEnum,
    runningCtx As DedCommandRunningContextEnum,
    ByRef HandlingCode As DedEventHandlerEnum,
    ByRef CommandResult As DedCmdResult
)
protected public:
void OnCommandExecuting(
    DedCommand^ command,
    DedEventTimeEnum BeforeOrAfter,
    DedCommandRunningContextEnum runningCtx,
    DedEventHandlerEnum% HandlingCode,
    DedCmdResult% CommandResult
)
member OnCommandExecuting :
        command : DedCommand *
        BeforeOrAfter : DedEventTimeEnum *
        runningCtx : DedCommandRunningContextEnum *
        HandlingCode : DedEventHandlerEnum byref *
        CommandResult : DedCmdResult byref -> unit

Parametri

command DedCommand
Comando in esecuzione.
BeforeOrAfter DedEventTimeEnum
Momento di esecuzione evento.
runningCtx DedCommandRunningContextEnum
HandlingCode DedEventHandlerEnum
Codice restituito dall'evento.
CommandResult DedCmdResult
Codice da restituire nel comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnCommCancel

Metodo DedNetApplicationOnCommCancel
Lancia l'evento CommCancelEvent.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnCommCancel(
    DedCommCancelEventArgs e
)
Protected Friend Sub OnCommCancel (
    e As DedCommCancelEventArgs
)
protected public:
void OnCommCancel(
    DedCommCancelEventArgs^ e
)
member OnCommCancel :
        e : DedCommCancelEventArgs -> unit

Parametri

e DedCommCancelEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnCommDescrOverrideEvent

Metodo DedNetApplicationOnCommDescrOverrideEvent
Lancia l'evento ValidateCommPropertyEvent.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnCommDescrOverrideEvent(
    CommDescrOverrideEventArgs e
)
Protected Friend Sub OnCommDescrOverrideEvent (
    e As CommDescrOverrideEventArgs
)
protected public:
void OnCommDescrOverrideEvent(
    CommDescrOverrideEventArgs^ e
)
member OnCommDescrOverrideEvent :
        e : CommDescrOverrideEventArgs -> unit

Parametri

e CommDescrOverrideEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnCommElementCreateData

Metodo DedNetApplicationOnCommElementCreateData
Lancia l'evento CommElementCreateData.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnCommElementCreateData(
    Object sender,
    CommElementCreateDataEventArgs e
)
Protected Friend Sub OnCommElementCreateData (
    sender As Object,
    e As CommElementCreateDataEventArgs
)
protected public:
void OnCommElementCreateData(
    Object^ sender,
    CommElementCreateDataEventArgs^ e
)
member OnCommElementCreateData :
        sender : Object *
        e : CommElementCreateDataEventArgs -> unit

Parametri

sender Object
e CommElementCreateDataEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnCommFileExplorerUpdate

Metodo DedNetApplicationOnCommFileExplorerUpdate
Lancia l'evento CommFileExplorerUpdate.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnCommFileExplorerUpdate(
    CommFileExplorerUpdateEventArgs ev
)
Protected Friend Sub OnCommFileExplorerUpdate (
    ev As CommFileExplorerUpdateEventArgs
)
protected public:
void OnCommFileExplorerUpdate(
    CommFileExplorerUpdateEventArgs^ ev
)
member OnCommFileExplorerUpdate :
        ev : CommFileExplorerUpdateEventArgs -> unit

Parametri

ev CommFileExplorerUpdateEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnCommTypeAdded

Metodo DedNetApplicationOnCommTypeAdded
Chiama l'evento TypeAdded.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnCommTypeAdded(
    QsManagerEventArgs e
)
Protected Friend Sub OnCommTypeAdded (
    e As QsManagerEventArgs
)
protected public:
void OnCommTypeAdded(
    QsManagerEventArgs^ e
)
member OnCommTypeAdded :
        e : QsManagerEventArgs -> unit

Parametri

e QsManagerEventArgs
Oggetto QsManagerEventArgs.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnCopyDocument

Metodo DedNetApplicationOnCopyDocument
Lancia l'evento CopyDocument.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnCopyDocument(
    CopyDocumentEventArgs e
)
Protected Friend Sub OnCopyDocument (
    e As CopyDocumentEventArgs
)
protected public:
void OnCopyDocument(
    CopyDocumentEventArgs^ e
)
member OnCopyDocument :
        e : CopyDocumentEventArgs -> unit

Parametri

e CopyDocumentEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnCreateComm

Metodo DedNetApplicationOnCreateComm
Chiama l'evento ExportData.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnCreateComm(
    DedCommCommandEventArgs e
)
Protected Friend Sub OnCreateComm (
    e As DedCommCommandEventArgs
)
protected public:
void OnCreateComm(
    DedCommCommandEventArgs^ e
)
member OnCreateComm :
        e : DedCommCommandEventArgs -> unit

Parametri

e DedCommCommandEventArgs
Informazioni per l'evento.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnCreateECO

Metodo DedNetApplicationOnCreateECO
Chiama l'evento CreateECOEvent.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnCreateECO(
    DedECOCommandEventArgs e
)
Protected Friend Sub OnCreateECO (
    e As DedECOCommandEventArgs
)
protected public:
void OnCreateECO(
    DedECOCommandEventArgs^ e
)
member OnCreateECO :
        e : DedECOCommandEventArgs -> unit

Parametri

e DedECOCommandEventArgs
Informazioni per l'evento.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnCreateMultiLevelBom

Metodo DedNetApplicationOnCreateMultiLevelBom
Chiama l'evento EditSparePartMultiLevelBomEvent

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnCreateMultiLevelBom(
    CreateMultiLevelBomEventArgs e
)
Protected Friend Sub OnCreateMultiLevelBom (
    e As CreateMultiLevelBomEventArgs
)
protected public:
void OnCreateMultiLevelBom(
    CreateMultiLevelBomEventArgs^ e
)
member OnCreateMultiLevelBom :
        e : CreateMultiLevelBomEventArgs -> unit

Parametri

e CreateMultiLevelBomEventArgs
Oggetto EditSparePartMultiLevelBomEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnCreatingSparePartDrawing

Metodo DedNetApplicationOnCreatingSparePartDrawing
Chiama l'evento CreatingSparePartDrawing.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnCreatingSparePartDrawing(
    CreatingSparePartDrawingEventArgs e
)
Protected Friend Sub OnCreatingSparePartDrawing (
    e As CreatingSparePartDrawingEventArgs
)
protected public:
void OnCreatingSparePartDrawing(
    CreatingSparePartDrawingEventArgs^ e
)
member OnCreatingSparePartDrawing :
        e : CreatingSparePartDrawingEventArgs -> unit

Parametri

e CreatingSparePartDrawingEventArgs
Oggetto CreatingSparePartDrawingEventArgs.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnDedBomEditLoaded

Metodo DedNetApplicationOnDedBomEditLoaded
Lancia l'evento DedBomEditLoaded.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnDedBomEditLoaded(
    Object sender,
    EventArgs e
)
Protected Friend Sub OnDedBomEditLoaded (
    sender As Object,
    e As EventArgs
)
protected public:
void OnDedBomEditLoaded(
    Object^ sender,
    EventArgs^ e
)
member OnDedBomEditLoaded :
        sender : Object *
        e : EventArgs -> unit

Parametri

sender Object
e EventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnDedDataChangedEvent

Metodo DedNetApplicationOnDedDataChangedEvent
Chiama l'evento DedDataChangedEvent.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnDedDataChangedEvent(
    DedDataChangedEventArgs e
)
Protected Friend Sub OnDedDataChangedEvent (
    e As DedDataChangedEventArgs
)
protected public:
void OnDedDataChangedEvent(
    DedDataChangedEventArgs^ e
)
member OnDedDataChangedEvent :
        e : DedDataChangedEventArgs -> unit

Parametri

e DedDataChangedEventArgs
Oggetto DedDataChangedEventArgs.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnDedDataMoveEvent

Metodo DedNetApplicationOnDedDataMoveEvent
Lancia l'evento DedDataMoveEvent.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnDedDataMoveEvent(
    DedDataMoveEventArgs e
)
Protected Friend Sub OnDedDataMoveEvent (
    e As DedDataMoveEventArgs
)
protected public:
void OnDedDataMoveEvent(
    DedDataMoveEventArgs^ e
)
member OnDedDataMoveEvent :
        e : DedDataMoveEventArgs -> unit

Parametri

e DedDataMoveEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnDedOpenDocumentEvent

Metodo DedNetApplicationOnDedOpenDocumentEvent
Lancia l'evento DedOpenDocumentEvent.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnDedOpenDocumentEvent(
    DedOpenDocumentEventArgs e
)
Protected Friend Sub OnDedOpenDocumentEvent (
    e As DedOpenDocumentEventArgs
)
protected public:
void OnDedOpenDocumentEvent(
    DedOpenDocumentEventArgs^ e
)
member OnDedOpenDocumentEvent :
        e : DedOpenDocumentEventArgs -> unit

Parametri

e DedOpenDocumentEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnDedRuleLua

Metodo DedNetApplicationOnDedRuleLua
Chiama l'evento DedRuleLua.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnDedRuleLua(
    DedRuleLuaEventArg e
)
Protected Friend Sub OnDedRuleLua (
    e As DedRuleLuaEventArg
)
protected public:
void OnDedRuleLua(
    DedRuleLuaEventArg^ e
)
member OnDedRuleLua :
        e : DedRuleLuaEventArg -> unit

Parametri

e DedRuleLuaEventArg
Oggetto DedRuleParserEventArg.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnDedRuleRowSetAttrPost

Metodo DedNetApplicationOnDedRuleRowSetAttrPost
Chiama l'evento DedRuleRowSetAttrPost.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnDedRuleRowSetAttrPost(
    DedRuleParserEventArg e
)
Protected Friend Sub OnDedRuleRowSetAttrPost (
    e As DedRuleParserEventArg
)
protected public:
void OnDedRuleRowSetAttrPost(
    DedRuleParserEventArg^ e
)
member OnDedRuleRowSetAttrPost :
        e : DedRuleParserEventArg -> unit

Parametri

e DedRuleParserEventArg
Oggetto DedRuleParserEventArg.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnDedRuleSetAttrPost

Metodo DedNetApplicationOnDedRuleSetAttrPost
Chiama l'evento DedRuleSetAttrPost.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnDedRuleSetAttrPost(
    DedRuleApplierItem obj
)
Protected Friend Sub OnDedRuleSetAttrPost (
    obj As DedRuleApplierItem
)
protected public:
void OnDedRuleSetAttrPost(
    DedRuleApplierItem^ obj
)
member OnDedRuleSetAttrPost :
        obj : DedRuleApplierItem -> unit

Parametri

obj DedRuleApplierItem
Oggetto DedAttrRuleObj.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnDedRuleSetAttrPre

Metodo DedNetApplicationOnDedRuleSetAttrPre
Chiama l'evento DedRuleSetAttrPre.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnDedRuleSetAttrPre(
    DedRuleApplierItem obj
)
Protected Friend Sub OnDedRuleSetAttrPre (
    obj As DedRuleApplierItem
)
protected public:
void OnDedRuleSetAttrPre(
    DedRuleApplierItem^ obj
)
member OnDedRuleSetAttrPre :
        obj : DedRuleApplierItem -> unit

Parametri

obj DedRuleApplierItem
Oggetto DedAttrRuleObj.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnDedRuleSingleSetAttrPre

Metodo DedNetApplicationOnDedRuleSingleSetAttrPre
Chiama l'evento DedRuleSingleSetAttrPre.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnDedRuleSingleSetAttrPre(
    DedRuleParserEventArg e
)
Protected Friend Sub OnDedRuleSingleSetAttrPre (
    e As DedRuleParserEventArg
)
protected public:
void OnDedRuleSingleSetAttrPre(
    DedRuleParserEventArg^ e
)
member OnDedRuleSingleSetAttrPre :
        e : DedRuleParserEventArg -> unit

Parametri

e DedRuleParserEventArg
Oggetto DedRuleParserEventArg.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnDedTranslationChangedEvent

Metodo DedNetApplicationOnDedTranslationChangedEvent
Chiama l'evento DedTranslationChangedEvent.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnDedTranslationChangedEvent(
    DedTranslationChangedEventArgs e
)
Protected Friend Sub OnDedTranslationChangedEvent (
    e As DedTranslationChangedEventArgs
)
protected public:
void OnDedTranslationChangedEvent(
    DedTranslationChangedEventArgs^ e
)
member OnDedTranslationChangedEvent :
        e : DedTranslationChangedEventArgs -> unit

Parametri

e DedTranslationChangedEventArgs
Oggetto DedTranslationChangedEventArgs.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnDefineFileDependency

Metodo DedNetApplicationOnDefineFileDependency
Lancia l'evento DefineFileDependency.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnDefineFileDependency(
    string fileName,
    DedEventTimeEnum BeforeOrAfter,
    ref DedEventHandlerEnum HandlingCode,
    ref DedCmdResult CommandResult,
    ref DocDepFileList dep
)
Protected Friend Sub OnDefineFileDependency (
    fileName As String,
    BeforeOrAfter As DedEventTimeEnum,
    ByRef HandlingCode As DedEventHandlerEnum,
    ByRef CommandResult As DedCmdResult,
    ByRef dep As DocDepFileList
)
protected public:
void OnDefineFileDependency(
    String^ fileName,
    DedEventTimeEnum BeforeOrAfter,
    DedEventHandlerEnum% HandlingCode,
    DedCmdResult% CommandResult,
    DocDepFileList^% dep
)
member OnDefineFileDependency :
        fileName : string *
        BeforeOrAfter : DedEventTimeEnum *
        HandlingCode : DedEventHandlerEnum byref *
        CommandResult : DedCmdResult byref *
        dep : DocDepFileList byref -> unit

Parametri

fileName String
File del quale reperire le dipendenze.
BeforeOrAfter DedEventTimeEnum
Momento di esecuzione evento.
HandlingCode DedEventHandlerEnum
Codice restituito dall'evento.
CommandResult DedCmdResult
Codice da restituire nel comando.
dep DocDepFileList
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnDisableAutoUpdateAnagrComm

Metodo DedNetApplicationOnDisableAutoUpdateAnagrComm
Lancia l'evento DisableAutoUpdateAnagrComm.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnDisableAutoUpdateAnagrComm(
    DisableAutoUpdateAnagrCommEventArgs ev
)
Protected Friend Sub OnDisableAutoUpdateAnagrComm (
    ev As DisableAutoUpdateAnagrCommEventArgs
)
protected public:
void OnDisableAutoUpdateAnagrComm(
    DisableAutoUpdateAnagrCommEventArgs^ ev
)
member OnDisableAutoUpdateAnagrComm :
        ev : DisableAutoUpdateAnagrCommEventArgs -> unit

Parametri

ev DisableAutoUpdateAnagrCommEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnDistAddNode

Metodo DedNetApplicationOnDistAddNode
Lancia l'evento DistAddNodeEvent.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnDistAddNode(
    Object sender,
    DistAddNodeEventArgs e
)
Protected Friend Sub OnDistAddNode (
    sender As Object,
    e As DistAddNodeEventArgs
)
protected public:
void OnDistAddNode(
    Object^ sender,
    DistAddNodeEventArgs^ e
)
member OnDistAddNode :
        sender : Object *
        e : DistAddNodeEventArgs -> unit

Parametri

sender Object
e DistAddNodeEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnDistChangeFieldValueEvent

Metodo DedNetApplicationOnDistChangeFieldValueEvent
Lancia l'evento DistChangeFieldValueEvent.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnDistChangeFieldValueEvent(
    Object sender,
    DistChangeFieldValueEventArgs e
)
Protected Friend Sub OnDistChangeFieldValueEvent (
    sender As Object,
    e As DistChangeFieldValueEventArgs
)
protected public:
void OnDistChangeFieldValueEvent(
    Object^ sender,
    DistChangeFieldValueEventArgs^ e
)
member OnDistChangeFieldValueEvent :
        sender : Object *
        e : DistChangeFieldValueEventArgs -> unit

Parametri

sender Object
e DistChangeFieldValueEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnDistCloneData

Metodo DedNetApplicationOnDistCloneData
Lancia l'evento DistCloneDataEvent.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void OnDistCloneData(
    Object sender,
    DistCloneDataEventArgs e
)
Public Sub OnDistCloneData (
    sender As Object,
    e As DistCloneDataEventArgs
)
public:
void OnDistCloneData(
    Object^ sender,
    DistCloneDataEventArgs^ e
)
member OnDistCloneData :
        sender : Object *
        e : DistCloneDataEventArgs -> unit

Parametri

sender Object
e DistCloneDataEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnDistCopyData

Metodo DedNetApplicationOnDistCopyData
Lancia l'evento DistCopyDataEvent.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnDistCopyData(
    Object sender,
    DistCopyDataEventArgs e
)
Protected Friend Sub OnDistCopyData (
    sender As Object,
    e As DistCopyDataEventArgs
)
protected public:
void OnDistCopyData(
    Object^ sender,
    DistCopyDataEventArgs^ e
)
member OnDistCopyData :
        sender : Object *
        e : DistCopyDataEventArgs -> unit

Parametri

sender Object
e DistCopyDataEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnDistDragElement

Metodo DedNetApplicationOnDistDragElement
Lancia l'evento DistAddElementEvent.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnDistDragElement(
    Object sender,
    DistDragElementEventArgs e
)
Protected Friend Sub OnDistDragElement (
    sender As Object,
    e As DistDragElementEventArgs
)
protected public:
void OnDistDragElement(
    Object^ sender,
    DistDragElementEventArgs^ e
)
member OnDistDragElement :
        sender : Object *
        e : DistDragElementEventArgs -> unit

Parametri

sender Object
e DistDragElementEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnDistEditSaveEvent

Metodo DedNetApplicationOnDistEditSaveEvent
Lancia l'evento DistEditSaveEvent.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnDistEditSaveEvent(
    DedDistEditSaveEventArgs e
)
Protected Friend Sub OnDistEditSaveEvent (
    e As DedDistEditSaveEventArgs
)
protected public:
void OnDistEditSaveEvent(
    DedDistEditSaveEventArgs^ e
)
member OnDistEditSaveEvent :
        e : DedDistEditSaveEventArgs -> unit

Parametri

e DedDistEditSaveEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnDistElementCreateData

Metodo DedNetApplicationOnDistElementCreateData
Lancia l'evento DistElementCreateData.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnDistElementCreateData(
    Object sender,
    DistElementCreateDataEventArgs e
)
Protected Friend Sub OnDistElementCreateData (
    sender As Object,
    e As DistElementCreateDataEventArgs
)
protected public:
void OnDistElementCreateData(
    Object^ sender,
    DistElementCreateDataEventArgs^ e
)
member OnDistElementCreateData :
        sender : Object *
        e : DistElementCreateDataEventArgs -> unit

Parametri

sender Object
e DistElementCreateDataEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnDistItemCreateData

Metodo DedNetApplicationOnDistItemCreateData
Lancia l'evento DistItemCreateData.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnDistItemCreateData(
    Object sender,
    DistItemCreateDataEventArgs e
)
Protected Friend Sub OnDistItemCreateData (
    sender As Object,
    e As DistItemCreateDataEventArgs
)
protected public:
void OnDistItemCreateData(
    Object^ sender,
    DistItemCreateDataEventArgs^ e
)
member OnDistItemCreateData :
        sender : Object *
        e : DistItemCreateDataEventArgs -> unit

Parametri

sender Object
e DistItemCreateDataEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnDistLevelSaveEvent

Metodo DedNetApplicationOnDistLevelSaveEvent
Lancia l'evento DistLevelSaveEvent.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnDistLevelSaveEvent(
    DedDistSaveEventArgs e
)
Protected Friend Sub OnDistLevelSaveEvent (
    e As DedDistSaveEventArgs
)
protected public:
void OnDistLevelSaveEvent(
    DedDistSaveEventArgs^ e
)
member OnDistLevelSaveEvent :
        e : DedDistSaveEventArgs -> unit

Parametri

e DedDistSaveEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnDistReplaceSaveEvent

Metodo DedNetApplicationOnDistReplaceSaveEvent
Lancia l'evento DistReplaceSaveEvent.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnDistReplaceSaveEvent(
    DedDistEditSaveEventArgs e
)
Protected Friend Sub OnDistReplaceSaveEvent (
    e As DedDistEditSaveEventArgs
)
protected public:
void OnDistReplaceSaveEvent(
    DedDistEditSaveEventArgs^ e
)
member OnDistReplaceSaveEvent :
        e : DedDistEditSaveEventArgs -> unit

Parametri

e DedDistEditSaveEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnDistSaveEvent

Metodo DedNetApplicationOnDistSaveEvent
Lancia l'evento DistSaveEvent.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnDistSaveEvent(
    DedDistSaveEventArgs e
)
Protected Friend Sub OnDistSaveEvent (
    e As DedDistSaveEventArgs
)
protected public:
void OnDistSaveEvent(
    DedDistSaveEventArgs^ e
)
member OnDistSaveEvent :
        e : DedDistSaveEventArgs -> unit

Parametri

e DedDistSaveEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnDocStructInfoCreated

Metodo DedNetApplicationOnDocStructInfoCreated
Lancia l'evento alla creazione di un nuovo DocStructInfo

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void OnDocStructInfoCreated(
    ResolveDocStructInfoEventArgs e
)
Public Sub OnDocStructInfoCreated (
    e As ResolveDocStructInfoEventArgs
)
public:
void OnDocStructInfoCreated(
    ResolveDocStructInfoEventArgs^ e
)
member OnDocStructInfoCreated :
        e : ResolveDocStructInfoEventArgs -> unit

Parametri

e ResolveDocStructInfoEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnDocumentAnnullaCheckedOutEvent

Metodo DedNetApplicationOnDocumentAnnullaCheckedOutEvent
Lancia l'evento DocumentAnnullaCheckedOutEvent.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnDocumentAnnullaCheckedOutEvent(
    DocStructInfoEventArgs e
)
Protected Friend Sub OnDocumentAnnullaCheckedOutEvent (
    e As DocStructInfoEventArgs
)
protected public:
void OnDocumentAnnullaCheckedOutEvent(
    DocStructInfoEventArgs^ e
)
member OnDocumentAnnullaCheckedOutEvent :
        e : DocStructInfoEventArgs -> unit

Parametri

e DocStructInfoEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnDocumentCheckedInEvent

Metodo DedNetApplicationOnDocumentCheckedInEvent
Lancia l'evento DocumentCheckedIn.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnDocumentCheckedInEvent(
    DocStructInfoEventArgs e
)
Protected Friend Sub OnDocumentCheckedInEvent (
    e As DocStructInfoEventArgs
)
protected public:
void OnDocumentCheckedInEvent(
    DocStructInfoEventArgs^ e
)
member OnDocumentCheckedInEvent :
        e : DocStructInfoEventArgs -> unit

Parametri

e DocStructInfoEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnDocumentCheckedOutEvent

Metodo DedNetApplicationOnDocumentCheckedOutEvent
Lancia l'evento DocumentCheckedOut.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnDocumentCheckedOutEvent(
    DocStructInfoEventArgs e
)
Protected Friend Sub OnDocumentCheckedOutEvent (
    e As DocStructInfoEventArgs
)
protected public:
void OnDocumentCheckedOutEvent(
    DocStructInfoEventArgs^ e
)
member OnDocumentCheckedOutEvent :
        e : DocStructInfoEventArgs -> unit

Parametri

e DocStructInfoEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnDocumentCheckLocked

Metodo DedNetApplicationOnDocumentCheckLocked
Lancia l'evento DocumentCheckLockedEvent.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnDocumentCheckLocked(
    DocumentCheckLockedEventArgs e
)
Protected Friend Sub OnDocumentCheckLocked (
    e As DocumentCheckLockedEventArgs
)
protected public:
void OnDocumentCheckLocked(
    DocumentCheckLockedEventArgs^ e
)
member OnDocumentCheckLocked :
        e : DocumentCheckLockedEventArgs -> unit

Parametri

e DocumentCheckLockedEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnDocumentCreating

Metodo DedNetApplicationOnDocumentCreating
Chiama l'evento DocumentCreating.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnDocumentCreating(
    Object sender,
    DocumentEventArgs e
)
Protected Friend Sub OnDocumentCreating (
    sender As Object,
    e As DocumentEventArgs
)
protected public:
void OnDocumentCreating(
    Object^ sender,
    DocumentEventArgs^ e
)
member OnDocumentCreating :
        sender : Object *
        e : DocumentEventArgs -> unit

Parametri

sender Object
e DocumentEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnDocumentDisableEvent

Metodo DedNetApplicationOnDocumentDisableEvent
Lancia l'evento per non visualizzare i documenti nel controllo documentale

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void OnDocumentDisableEvent(
    DocumentDisableEventArgs e
)
Public Sub OnDocumentDisableEvent (
    e As DocumentDisableEventArgs
)
public:
void OnDocumentDisableEvent(
    DocumentDisableEventArgs^ e
)
member OnDocumentDisableEvent :
        e : DocumentDisableEventArgs -> unit

Parametri

e DocumentDisableEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnDocumentDisconnectingEvent

Metodo DedNetApplicationOnDocumentDisconnectingEvent
Lancia l'evento DocumentDisconnectingEvent.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnDocumentDisconnectingEvent(
    DocumentDisconnectingEventArgs e
)
Protected Friend Sub OnDocumentDisconnectingEvent (
    e As DocumentDisconnectingEventArgs
)
protected public:
void OnDocumentDisconnectingEvent(
    DocumentDisconnectingEventArgs^ e
)
member OnDocumentDisconnectingEvent :
        e : DocumentDisconnectingEventArgs -> unit

Parametri

e DocumentDisconnectingEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnDocumentDownloadedEvent

Metodo DedNetApplicationOnDocumentDownloadedEvent
Lancia l'evento DocumentDownloaded

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnDocumentDownloadedEvent(
    DedCommandEventArgs e
)
Protected Friend Sub OnDocumentDownloadedEvent (
    e As DedCommandEventArgs
)
protected public:
void OnDocumentDownloadedEvent(
    DedCommandEventArgs^ e
)
member OnDocumentDownloadedEvent :
        e : DedCommandEventArgs -> unit

Parametri

e DedCommandEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnDocumentDragDropEvent

Metodo DedNetApplicationOnDocumentDragDropEvent

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void OnDocumentDragDropEvent(
    DocumentDragDropEventArgs e
)
Public Sub OnDocumentDragDropEvent (
    e As DocumentDragDropEventArgs
)
public:
void OnDocumentDragDropEvent(
    DocumentDragDropEventArgs^ e
)
member OnDocumentDragDropEvent :
        e : DocumentDragDropEventArgs -> unit

Parametri

e DocumentDragDropEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnDocumentEnsureLocalOperationEvent

Metodo DedNetApplicationOnDocumentEnsureLocalOperationEvent
Lancia l'evento DocumentEnsureLocalOperationEvent.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnDocumentEnsureLocalOperationEvent(
    DocOperationEventArgs e
)
Protected Friend Sub OnDocumentEnsureLocalOperationEvent (
    e As DocOperationEventArgs
)
protected public:
void OnDocumentEnsureLocalOperationEvent(
    DocOperationEventArgs^ e
)
member OnDocumentEnsureLocalOperationEvent :
        e : DocOperationEventArgs -> unit

Parametri

e DocOperationEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnDocumentImportedEvent

Metodo DedNetApplicationOnDocumentImportedEvent
Lancia l'evento DocumentImport.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnDocumentImportedEvent(
    ImportedDocStructInfoEventArgs e
)
Protected Friend Sub OnDocumentImportedEvent (
    e As ImportedDocStructInfoEventArgs
)
protected public:
void OnDocumentImportedEvent(
    ImportedDocStructInfoEventArgs^ e
)
member OnDocumentImportedEvent :
        e : ImportedDocStructInfoEventArgs -> unit

Parametri

e ImportedDocStructInfoEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnDocumentImporting

Metodo DedNetApplicationOnDocumentImporting
Lancia l'evento DocumentImporting.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnDocumentImporting(
    DocumentImportingEventArgs e
)
Protected Friend Sub OnDocumentImporting (
    e As DocumentImportingEventArgs
)
protected public:
void OnDocumentImporting(
    DocumentImportingEventArgs^ e
)
member OnDocumentImporting :
        e : DocumentImportingEventArgs -> unit

Parametri

e DocumentImportingEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnDocumentLinking

Metodo DedNetApplicationOnDocumentLinking
Lancia l'evento DocumentLinkingEvent.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnDocumentLinking(
    DocumentLinkingEventArgs e
)
Protected Friend Sub OnDocumentLinking (
    e As DocumentLinkingEventArgs
)
protected public:
void OnDocumentLinking(
    DocumentLinkingEventArgs^ e
)
member OnDocumentLinking :
        e : DocumentLinkingEventArgs -> unit

Parametri

e DocumentLinkingEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnDocumentMoving

Metodo DedNetApplicationOnDocumentMoving
Lancia l'evento DocumentImporting.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnDocumentMoving(
    DocumentMovingEventArgs e
)
Protected Friend Sub OnDocumentMoving (
    e As DocumentMovingEventArgs
)
protected public:
void OnDocumentMoving(
    DocumentMovingEventArgs^ e
)
member OnDocumentMoving :
        e : DocumentMovingEventArgs -> unit

Parametri

e DocumentMovingEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnDocumentPublishEvent

Metodo DedNetApplicationOnDocumentPublishEvent
Lancia l'evento DocumentPublishOut.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnDocumentPublishEvent(
    DocStructInfoEventArgs e
)
Protected Friend Sub OnDocumentPublishEvent (
    e As DocStructInfoEventArgs
)
protected public:
void OnDocumentPublishEvent(
    DocStructInfoEventArgs^ e
)
member OnDocumentPublishEvent :
        e : DocStructInfoEventArgs -> unit

Parametri

e DocStructInfoEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnDocumentRecognizing

Metodo DedNetApplicationOnDocumentRecognizing
Lancia l'evento DocumentImporting.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnDocumentRecognizing(
    DocumentRecognizingEventArgs e
)
Protected Friend Sub OnDocumentRecognizing (
    e As DocumentRecognizingEventArgs
)
protected public:
void OnDocumentRecognizing(
    DocumentRecognizingEventArgs^ e
)
member OnDocumentRecognizing :
        e : DocumentRecognizingEventArgs -> unit

Parametri

e DocumentRecognizingEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnDocumentSbloccaEvent

Metodo DedNetApplicationOnDocumentSbloccaEvent
Lancia l'evento DocumentSbloccaEvent.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnDocumentSbloccaEvent(
    DocStructInfoEventArgs e
)
Protected Friend Sub OnDocumentSbloccaEvent (
    e As DocStructInfoEventArgs
)
protected public:
void OnDocumentSbloccaEvent(
    DocStructInfoEventArgs^ e
)
member OnDocumentSbloccaEvent :
        e : DocStructInfoEventArgs -> unit

Parametri

e DocStructInfoEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnDocumentUpdating

Metodo DedNetApplicationOnDocumentUpdating
Chiama l'evento DocumentUpdating.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnDocumentUpdating(
    Object sender,
    DocumentEventArgs e
)
Protected Friend Sub OnDocumentUpdating (
    sender As Object,
    e As DocumentEventArgs
)
protected public:
void OnDocumentUpdating(
    Object^ sender,
    DocumentEventArgs^ e
)
member OnDocumentUpdating :
        sender : Object *
        e : DocumentEventArgs -> unit

Parametri

sender Object
e DocumentEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnDragDropEvent

Metodo DedNetApplicationOnDragDropEvent
Lancia l'evento di DragDrop

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void OnDragDropEvent(
    DragDropEventArgs e
)
Public Sub OnDragDropEvent (
    e As DragDropEventArgs
)
public:
void OnDragDropEvent(
    DragDropEventArgs^ e
)
member OnDragDropEvent :
        e : DragDropEventArgs -> unit

Parametri

e DragDropEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnEditAttr

Metodo DedNetApplicationOnEditAttr
Lancia l'evento EditAttr.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void OnEditAttr(
    EditAttrEventArgs e
)
Public Sub OnEditAttr (
    e As EditAttrEventArgs
)
public:
void OnEditAttr(
    EditAttrEventArgs^ e
)
member OnEditAttr :
        e : EditAttrEventArgs -> unit

Parametri

e EditAttrEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnEditAttrValidating

Metodo DedNetApplicationOnEditAttrValidating
Lancia l'evento ValidatingEditAttrEvent.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void OnEditAttrValidating(
    EditAttrValidatingEventArgs e
)
Public Sub OnEditAttrValidating (
    e As EditAttrValidatingEventArgs
)
public:
void OnEditAttrValidating(
    EditAttrValidatingEventArgs^ e
)
member OnEditAttrValidating :
        e : EditAttrValidatingEventArgs -> unit

Parametri

e EditAttrValidatingEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnEditComm

Metodo DedNetApplicationOnEditComm
Chiama l'evento ExportData.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnEditComm(
    DedCommCommandEventArgs e
)
Protected Friend Sub OnEditComm (
    e As DedCommCommandEventArgs
)
protected public:
void OnEditComm(
    DedCommCommandEventArgs^ e
)
member OnEditComm :
        e : DedCommCommandEventArgs -> unit

Parametri

e DedCommCommandEventArgs
Informazioni per l'evento.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnEditCommChanged

Metodo DedNetApplicationOnEditCommChanged
Lancia l'evento NewAnagrChanged.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnEditCommChanged(
    DedCommand cmd
)
Protected Friend Sub OnEditCommChanged (
    cmd As DedCommand
)
protected public:
void OnEditCommChanged(
    DedCommand^ cmd
)
member OnEditCommChanged :
        cmd : DedCommand -> unit

Parametri

cmd DedCommand
Comando che lancia l'evento.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnElaborateDedListEvent

Metodo DedNetApplicationOnElaborateDedListEvent
Lancia l'evento per gestire le liste.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnElaborateDedListEvent(
    ElaborateDedListEventArgs e
)
Protected Friend Sub OnElaborateDedListEvent (
    e As ElaborateDedListEventArgs
)
protected public:
void OnElaborateDedListEvent(
    ElaborateDedListEventArgs^ e
)
member OnElaborateDedListEvent :
        e : ElaborateDedListEventArgs -> unit

Parametri

e ElaborateDedListEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnEsclAttrUpdFromDBTabEvent

Metodo DedNetApplicationOnEsclAttrUpdFromDBTabEvent
Lancia l'evento EsclAttrUpdFromDBTabEvent.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void OnEsclAttrUpdFromDBTabEvent(
    SkipEsclAttribEventArgs e
)
Public Sub OnEsclAttrUpdFromDBTabEvent (
    e As SkipEsclAttribEventArgs
)
public:
void OnEsclAttrUpdFromDBTabEvent(
    SkipEsclAttribEventArgs^ e
)
member OnEsclAttrUpdFromDBTabEvent :
        e : SkipEsclAttribEventArgs -> unit

Parametri

e SkipEsclAttribEventArgs
Argomento SkipEsclAttribEventArgs.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnEvaluateNewValue

Metodo DedNetApplicationOnEvaluateNewValue
Chiama l'evento ProcessNewValue.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnEvaluateNewValue(
    DedFormFindCode frm,
    EvaluateNewValueEventArgs ev
)
Protected Friend Sub OnEvaluateNewValue (
    frm As DedFormFindCode,
    ev As EvaluateNewValueEventArgs
)
protected public:
void OnEvaluateNewValue(
    DedFormFindCode^ frm,
    EvaluateNewValueEventArgs^ ev
)
member OnEvaluateNewValue :
        frm : DedFormFindCode *
        ev : EvaluateNewValueEventArgs -> unit

Parametri

frm DedFormFindCode
Form chiamante.
ev EvaluateNewValueEventArgs
Oggetto ProcessNewValueEventArgs inizializzato da passare all'evento.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnExportData

Metodo DedNetApplicationOnExportData
Chiama l'evento ExportData.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnExportData(
    ExportDataEventArg e
)
Protected Friend Sub OnExportData (
    e As ExportDataEventArg
)
protected public:
void OnExportData(
    ExportDataEventArg^ e
)
member OnExportData :
        e : ExportDataEventArg -> unit

Parametri

e ExportDataEventArg
Oggetto DedRuleParserEventArg.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnExportPackAndGoConfirmEvent

Metodo DedNetApplicationOnExportPackAndGoConfirmEvent
Lancia l'evento ExportPackAndGoConfirmEvent.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void OnExportPackAndGoConfirmEvent(
    PackAndGoZipFolderEventArgs e
)
Public Sub OnExportPackAndGoConfirmEvent (
    e As PackAndGoZipFolderEventArgs
)
public:
void OnExportPackAndGoConfirmEvent(
    PackAndGoZipFolderEventArgs^ e
)
member OnExportPackAndGoConfirmEvent :
        e : PackAndGoZipFolderEventArgs -> unit

Parametri

e PackAndGoZipFolderEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnExportResultBomCompare

Metodo DedNetApplicationOnExportResultBomCompare
Lancia l'evento ExportResultBomCompareEventArgs.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void OnExportResultBomCompare(
    Object sender,
    ExportResultBomCompareEventArgs ev
)
Public Sub OnExportResultBomCompare (
    sender As Object,
    ev As ExportResultBomCompareEventArgs
)
public:
void OnExportResultBomCompare(
    Object^ sender,
    ExportResultBomCompareEventArgs^ ev
)
member OnExportResultBomCompare :
        sender : Object *
        ev : ExportResultBomCompareEventArgs -> unit

Parametri

sender Object
ev ExportResultBomCompareEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnFamDescrOverrideEvent

Metodo DedNetApplicationOnFamDescrOverrideEvent
Lancia l'evento ValidateFamPropertyEvent.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnFamDescrOverrideEvent(
    FamDescrOverrideEventArgs e
)
Protected Friend Sub OnFamDescrOverrideEvent (
    e As FamDescrOverrideEventArgs
)
protected public:
void OnFamDescrOverrideEvent(
    FamDescrOverrideEventArgs^ e
)
member OnFamDescrOverrideEvent :
        e : FamDescrOverrideEventArgs -> unit

Parametri

e FamDescrOverrideEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnFillAttributeListFilter

Metodo DedNetApplicationOnFillAttributeListFilter
Lancia l'evento che permette il filtraggio degli attributi in fase di inserimento delle liste utilizzate nell'applicazione

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void OnFillAttributeListFilter(
    FillAttributeListFilterEventArgs e
)
Public Sub OnFillAttributeListFilter (
    e As FillAttributeListFilterEventArgs
)
public:
void OnFillAttributeListFilter(
    FillAttributeListFilterEventArgs^ e
)
member OnFillAttributeListFilter :
        e : FillAttributeListFilterEventArgs -> unit

Parametri

e FillAttributeListFilterEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnFilterSearchResult

Metodo DedNetApplicationOnFilterSearchResult
Chiama l'evento ClassListItemClick.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnFilterSearchResult(
    Object sender,
    DedAnagrViewControlFilterEventArgs ev
)
Protected Friend Sub OnFilterSearchResult (
    sender As Object,
    ev As DedAnagrViewControlFilterEventArgs
)
protected public:
void OnFilterSearchResult(
    Object^ sender,
    DedAnagrViewControlFilterEventArgs^ ev
)
member OnFilterSearchResult :
        sender : Object *
        ev : DedAnagrViewControlFilterEventArgs -> unit

Parametri

sender Object
ev DedAnagrViewControlFilterEventArgs
Oggetto ProcessNewValueEventArgs inizializzato da passare all'evento.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnFindCodeMultipleAnagrEvent

Metodo DedNetApplicationOnFindCodeMultipleAnagrEvent
Lancia l'evento FindCodeMultipleAnagrEvent.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void OnFindCodeMultipleAnagrEvent(
    FindCodeMultipleResultsEventArgs e
)
Public Sub OnFindCodeMultipleAnagrEvent (
    e As FindCodeMultipleResultsEventArgs
)
public:
void OnFindCodeMultipleAnagrEvent(
    FindCodeMultipleResultsEventArgs^ e
)
member OnFindCodeMultipleAnagrEvent :
        e : FindCodeMultipleResultsEventArgs -> unit

Parametri

e FindCodeMultipleResultsEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnFindCodeStateFilter

Metodo DedNetApplicationOnFindCodeStateFilter
Lancia l'evento che permette di filtrare la lista del form find code in base allo stato dell'anagrafica

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnFindCodeStateFilter(
    FindCodeStateFilterEventArgs e
)
Protected Friend Sub OnFindCodeStateFilter (
    e As FindCodeStateFilterEventArgs
)
protected public:
void OnFindCodeStateFilter(
    FindCodeStateFilterEventArgs^ e
)
member OnFindCodeStateFilter :
        e : FindCodeStateFilterEventArgs -> unit

Parametri

e FindCodeStateFilterEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnFolderDisableEvent

Metodo DedNetApplicationOnFolderDisableEvent
Lancia l'evento per non visualizzare la cartella nel controllo documentale.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void OnFolderDisableEvent(
    FolderDisableEventArgs e
)
Public Sub OnFolderDisableEvent (
    e As FolderDisableEventArgs
)
public:
void OnFolderDisableEvent(
    FolderDisableEventArgs^ e
)
member OnFolderDisableEvent :
        e : FolderDisableEventArgs -> unit

Parametri

e FolderDisableEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnFtpClientConnectionEvent

Metodo DedNetApplicationOnFtpClientConnectionEvent
Lancia l'evento per visualizzare una lista di suffissi in creazione di una Rappresentazione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnFtpClientConnectionEvent(
    FtpClientConnectionEventArgs e
)
Protected Friend Sub OnFtpClientConnectionEvent (
    e As FtpClientConnectionEventArgs
)
protected public:
void OnFtpClientConnectionEvent(
    FtpClientConnectionEventArgs^ e
)
member OnFtpClientConnectionEvent :
        e : FtpClientConnectionEventArgs -> unit

Parametri

e FtpClientConnectionEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnGetDocPropertiesEvent

Metodo DedNetApplicationOnGetDocPropertiesEvent
Lancia l'evento di GetDocPropertiesEvent.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void OnGetDocPropertiesEvent(
    GetDocPropertiesEventArgs e
)
Public Sub OnGetDocPropertiesEvent (
    e As GetDocPropertiesEventArgs
)
public:
void OnGetDocPropertiesEvent(
    GetDocPropertiesEventArgs^ e
)
member OnGetDocPropertiesEvent :
        e : GetDocPropertiesEventArgs -> unit

Parametri

e GetDocPropertiesEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnGetRepresentationSuffixListEvent

Metodo DedNetApplicationOnGetRepresentationSuffixListEvent
Lancia l'evento per visualizzare una lista di suffissi in creazione di una Rappresentazione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnGetRepresentationSuffixListEvent(
    GetRepresentationSuffixListEventArgs e
)
Protected Friend Sub OnGetRepresentationSuffixListEvent (
    e As GetRepresentationSuffixListEventArgs
)
protected public:
void OnGetRepresentationSuffixListEvent(
    GetRepresentationSuffixListEventArgs^ e
)
member OnGetRepresentationSuffixListEvent :
        e : GetRepresentationSuffixListEventArgs -> unit

Parametri

e GetRepresentationSuffixListEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnImportAttListEvent

Metodo DedNetApplicationOnImportAttListEvent
Lancia l'evento ImportAttListEvent

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnImportAttListEvent(
    ImportAttListEventArgs e
)
Protected Friend Sub OnImportAttListEvent (
    e As ImportAttListEventArgs
)
protected public:
void OnImportAttListEvent(
    ImportAttListEventArgs^ e
)
member OnImportAttListEvent :
        e : ImportAttListEventArgs -> unit

Parametri

e ImportAttListEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnImportAttrValueEvent

Metodo DedNetApplicationOnImportAttrValueEvent
Lancia l'evento ImportAttrValueEvent

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnImportAttrValueEvent(
    ImportAttrValueEventArgs e
)
Protected Friend Sub OnImportAttrValueEvent (
    e As ImportAttrValueEventArgs
)
protected public:
void OnImportAttrValueEvent(
    ImportAttrValueEventArgs^ e
)
member OnImportAttrValueEvent :
        e : ImportAttrValueEventArgs -> unit

Parametri

e ImportAttrValueEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnImportDataCanUpdate

Metodo DedNetApplicationOnImportDataCanUpdate
Lancia l'evento per la gestione dell'anagrafica da aggiornare nel comando Importa Dati.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void OnImportDataCanUpdate(
    ImportDataCanUpdateEventArgs e
)
Public Sub OnImportDataCanUpdate (
    e As ImportDataCanUpdateEventArgs
)
public:
void OnImportDataCanUpdate(
    ImportDataCanUpdateEventArgs^ e
)
member OnImportDataCanUpdate :
        e : ImportDataCanUpdateEventArgs -> unit

Parametri

e ImportDataCanUpdateEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnImportOnSaveEvent

Metodo DedNetApplicationOnImportOnSaveEvent
Lancia l'evento di ImportOnSaveEvent sui documenti che sono all'interno delle root definite in ROOTS_RECOGNIZED_ON_DBSAVE

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void OnImportOnSaveEvent(
    Object sender,
    ImportOnSaveEventArgs e
)
Public Sub OnImportOnSaveEvent (
    sender As Object,
    e As ImportOnSaveEventArgs
)
public:
void OnImportOnSaveEvent(
    Object^ sender,
    ImportOnSaveEventArgs^ e
)
member OnImportOnSaveEvent :
        sender : Object *
        e : ImportOnSaveEventArgs -> unit

Parametri

sender Object
e ImportOnSaveEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnImportPackAndGoSelectEvent

Metodo DedNetApplicationOnImportPackAndGoSelectEvent
Lancia l'evento ImportPackAndGoSelectEvent.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void OnImportPackAndGoSelectEvent(
    PackAndGoZipFolderEventArgs e
)
Public Sub OnImportPackAndGoSelectEvent (
    e As PackAndGoZipFolderEventArgs
)
public:
void OnImportPackAndGoSelectEvent(
    PackAndGoZipFolderEventArgs^ e
)
member OnImportPackAndGoSelectEvent :
        e : PackAndGoZipFolderEventArgs -> unit

Parametri

e PackAndGoZipFolderEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnListImportDataEvent

Metodo DedNetApplicationOnListImportDataEvent
Lancia l'evento di validazione di un codice durante l'importazione in una lista.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnListImportDataEvent(
    ListImportDataEventArgs e
)
Protected Friend Sub OnListImportDataEvent (
    e As ListImportDataEventArgs
)
protected public:
void OnListImportDataEvent(
    ListImportDataEventArgs^ e
)
member OnListImportDataEvent :
        e : ListImportDataEventArgs -> unit

Parametri

e ListImportDataEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnLoadFormCommEditEvent

Metodo DedNetApplicationOnLoadFormCommEditEvent
Lancia l'evento LoadFormCommEditEvent

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnLoadFormCommEditEvent(
    LoadFormCommEditEventArgs e
)
Protected Friend Sub OnLoadFormCommEditEvent (
    e As LoadFormCommEditEventArgs
)
protected public:
void OnLoadFormCommEditEvent(
    LoadFormCommEditEventArgs^ e
)
member OnLoadFormCommEditEvent :
        e : LoadFormCommEditEventArgs -> unit

Parametri

e LoadFormCommEditEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnManagePlaceHolderLogicComputed

Metodo DedNetApplicationOnManagePlaceHolderLogicComputed
Lancia l'evento per l'override della logica di gestione dei placeholder.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnManagePlaceHolderLogicComputed(
    ManagePlaceHolderEventArgs e
)
Protected Friend Sub OnManagePlaceHolderLogicComputed (
    e As ManagePlaceHolderEventArgs
)
protected public:
void OnManagePlaceHolderLogicComputed(
    ManagePlaceHolderEventArgs^ e
)
member OnManagePlaceHolderLogicComputed :
        e : ManagePlaceHolderEventArgs -> unit

Parametri

e ManagePlaceHolderEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnManageSelectionDocsEvent

Metodo DedNetApplicationOnManageSelectionDocsEvent
Metodo che esegue l'evento di 'ManageRevDocsEvent'.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void OnManageSelectionDocsEvent(
    ManageSelectionDocsEventArgs ev
)
Public Sub OnManageSelectionDocsEvent (
    ev As ManageSelectionDocsEventArgs
)
public:
void OnManageSelectionDocsEvent(
    ManageSelectionDocsEventArgs^ ev
)
member OnManageSelectionDocsEvent :
        ev : ManageSelectionDocsEventArgs -> unit

Parametri

ev ManageSelectionDocsEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnModifyDocumentBeforeCheckedInEvent

Metodo DedNetApplicationOnModifyDocumentBeforeCheckedInEvent
Lancia l'evento DocumentCheckedIn.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnModifyDocumentBeforeCheckedInEvent(
    DocStructInfoEventArgs e
)
Protected Friend Sub OnModifyDocumentBeforeCheckedInEvent (
    e As DocStructInfoEventArgs
)
protected public:
void OnModifyDocumentBeforeCheckedInEvent(
    DocStructInfoEventArgs^ e
)
member OnModifyDocumentBeforeCheckedInEvent :
        e : DocStructInfoEventArgs -> unit

Parametri

e DocStructInfoEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnMoveDocument

Metodo DedNetApplicationOnMoveDocument
Lancia l'evento MoveDocument.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnMoveDocument(
    MoveDocumentEventArgs e
)
Protected Friend Sub OnMoveDocument (
    e As MoveDocumentEventArgs
)
protected public:
void OnMoveDocument(
    MoveDocumentEventArgs^ e
)
member OnMoveDocument :
        e : MoveDocumentEventArgs -> unit

Parametri

e MoveDocumentEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnMsgDistReplaceSaveEvent

Metodo DedNetApplicationOnMsgDistReplaceSaveEvent
Lancia l'evento MsgDistReplaceSaveEvent.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnMsgDistReplaceSaveEvent(
    DedBeforeOrAfterEventArgs e
)
Protected Friend Sub OnMsgDistReplaceSaveEvent (
    e As DedBeforeOrAfterEventArgs
)
protected public:
void OnMsgDistReplaceSaveEvent(
    DedBeforeOrAfterEventArgs^ e
)
member OnMsgDistReplaceSaveEvent :
        e : DedBeforeOrAfterEventArgs -> unit

Parametri

e DedBeforeOrAfterEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnMultipleStateChangeExecute

Metodo DedNetApplicationOnMultipleStateChangeExecute
Lancia l'evento che permette di verificare la lista delle anagrafiche selezionate durante le operazioni di Rilascio/Lavorazione multiplo

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void OnMultipleStateChangeExecute(
    MultipleStateChangeExecuteEventArgs e
)
Public Sub OnMultipleStateChangeExecute (
    e As MultipleStateChangeExecuteEventArgs
)
public:
void OnMultipleStateChangeExecute(
    MultipleStateChangeExecuteEventArgs^ e
)
member OnMultipleStateChangeExecute :
        e : MultipleStateChangeExecuteEventArgs -> unit

Parametri

e MultipleStateChangeExecuteEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnNewAnagrChanged

Metodo DedNetApplicationOnNewAnagrChanged
Lancia l'evento NewAnagrChanged.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnNewAnagrChanged(
    DedCommand cmd,
    DedFormSaveModeEnum mode
)
Protected Friend Sub OnNewAnagrChanged (
    cmd As DedCommand,
    mode As DedFormSaveModeEnum
)
protected public:
void OnNewAnagrChanged(
    DedCommand^ cmd,
    DedFormSaveModeEnum mode
)
member OnNewAnagrChanged :
        cmd : DedCommand *
        mode : DedFormSaveModeEnum -> unit

Parametri

cmd DedCommand
Comando che lancia l'evento.
mode DedFormSaveModeEnum
Modalità del comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnNewAnagrCreated

Metodo DedNetApplicationOnNewAnagrCreated
Lancia l'evento NewAnagrCreated.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnNewAnagrCreated(
    DedCommand cmd,
    DedFormSaveModeEnum mode
)
Protected Friend Sub OnNewAnagrCreated (
    cmd As DedCommand,
    mode As DedFormSaveModeEnum
)
protected public:
void OnNewAnagrCreated(
    DedCommand^ cmd,
    DedFormSaveModeEnum mode
)
member OnNewAnagrCreated :
        cmd : DedCommand *
        mode : DedFormSaveModeEnum -> unit

Parametri

cmd DedCommand
Comando che lancia l'evento.
mode DedFormSaveModeEnum
Modalità del comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnNewAnagrInit

Metodo DedNetApplicationOnNewAnagrInit
Lancia l'evento NewAnagrInit.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnNewAnagrInit(
    DedCommand cmd,
    DedFormSaveModeEnum mode
)
Protected Friend Sub OnNewAnagrInit (
    cmd As DedCommand,
    mode As DedFormSaveModeEnum
)
protected public:
void OnNewAnagrInit(
    DedCommand^ cmd,
    DedFormSaveModeEnum mode
)
member OnNewAnagrInit :
        cmd : DedCommand *
        mode : DedFormSaveModeEnum -> unit

Parametri

cmd DedCommand
Comando che lancia l'evento.
mode DedFormSaveModeEnum
Modalità del comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnNewAnagrValidating

Metodo DedNetApplicationOnNewAnagrValidating
Lancia l'evento NewAnagrValidating.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnNewAnagrValidating(
    DedCommand cmd,
    DedFormSaveModeEnum mode,
    out bool cancel
)
Protected Friend Sub OnNewAnagrValidating (
    cmd As DedCommand,
    mode As DedFormSaveModeEnum,
    <OutAttribute> ByRef cancel As Boolean
)
protected public:
void OnNewAnagrValidating(
    DedCommand^ cmd,
    DedFormSaveModeEnum mode,
    [OutAttribute] bool% cancel
)
member OnNewAnagrValidating :
        cmd : DedCommand *
        mode : DedFormSaveModeEnum *
        cancel : bool byref -> unit

Parametri

cmd DedCommand
Comando che lancia l'evento.
mode DedFormSaveModeEnum
Modalità del comando.
cancel Boolean
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnNewCommChanged

Metodo DedNetApplicationOnNewCommChanged
Lancia l'evento NewAnagrChanged.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnNewCommChanged(
    DedCommand cmd
)
Protected Friend Sub OnNewCommChanged (
    cmd As DedCommand
)
protected public:
void OnNewCommChanged(
    DedCommand^ cmd
)
member OnNewCommChanged :
        cmd : DedCommand -> unit

Parametri

cmd DedCommand
Comando che lancia l'evento.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnNoteTransferPackEvent

Metodo DedNetApplicationOnNoteTransferPackEvent
Lancia l'evento NoteTransferPackEventArgs.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnNoteTransferPackEvent(
    NoteTransferPackEventArgs e
)
Protected Friend Sub OnNoteTransferPackEvent (
    e As NoteTransferPackEventArgs
)
protected public:
void OnNoteTransferPackEvent(
    NoteTransferPackEventArgs^ e
)
member OnNoteTransferPackEvent :
        e : NoteTransferPackEventArgs -> unit

Parametri

e NoteTransferPackEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnNotifyEvent

Metodo DedNetApplicationOnNotifyEvent
Lancia l'evento NotifyEvent

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnNotifyEvent(
    DedNotifyEventArgs e
)
Protected Friend Sub OnNotifyEvent (
    e As DedNotifyEventArgs
)
protected public:
void OnNotifyEvent(
    DedNotifyEventArgs^ e
)
member OnNotifyEvent :
        e : DedNotifyEventArgs -> unit

Parametri

e DedNotifyEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnOpenCommandDisableDocumentEvent

Metodo DedNetApplicationOnOpenCommandDisableDocumentEvent
Lancia l'evento per non aprire alcuni file

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void OnOpenCommandDisableDocumentEvent(
    DocumentDisableEventArgs e
)
Public Sub OnOpenCommandDisableDocumentEvent (
    e As DocumentDisableEventArgs
)
public:
void OnOpenCommandDisableDocumentEvent(
    DocumentDisableEventArgs^ e
)
member OnOpenCommandDisableDocumentEvent :
        e : DocumentDisableEventArgs -> unit

Parametri

e DocumentDisableEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnOpenDocument

Metodo DedNetApplicationOnOpenDocument
Lancia l'evento di apertura documento.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnOpenDocument(
    DedCommand command,
    string fullFileName,
    bool readOnly,
    DedCommandDocAnagrInfo info,
    DedEventTimeEnum BeforeOrAfter,
    ref DedEventHandlerEnum HandlingCode,
    ref DedCmdResult CommandResult
)
Protected Friend Sub OnOpenDocument (
    command As DedCommand,
    fullFileName As String,
    readOnly As Boolean,
    info As DedCommandDocAnagrInfo,
    BeforeOrAfter As DedEventTimeEnum,
    ByRef HandlingCode As DedEventHandlerEnum,
    ByRef CommandResult As DedCmdResult
)
protected public:
void OnOpenDocument(
    DedCommand^ command,
    String^ fullFileName,
    bool readOnly,
    DedCommandDocAnagrInfo^ info,
    DedEventTimeEnum BeforeOrAfter,
    DedEventHandlerEnum% HandlingCode,
    DedCmdResult% CommandResult
)
member OnOpenDocument :
        command : DedCommand *
        fullFileName : string *
        readOnly : bool *
        info : DedCommandDocAnagrInfo *
        BeforeOrAfter : DedEventTimeEnum *
        HandlingCode : DedEventHandlerEnum byref *
        CommandResult : DedCmdResult byref -> unit

Parametri

command DedCommand
Comando DedDocumentCommand.
fullFileName String
Nome completo del file in apertura.
readOnly Boolean
Se l'apertura sia in sola lettura.
info DedCommandDocAnagrInfo
Informazioni sul documento in apertura.
BeforeOrAfter DedEventTimeEnum
Momento di esecuzione evento.
HandlingCode DedEventHandlerEnum
Codice restituito dall'evento.
CommandResult DedCmdResult
Restituzione del comando.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnOrderPiorityList

Metodo DedNetApplicationOnOrderPiorityList
Chiama l'evento OrderPriorityListEvent.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnOrderPiorityList(
    CadPriorityExtListEventArgs ev
)
Protected Friend Sub OnOrderPiorityList (
    ev As CadPriorityExtListEventArgs
)
protected public:
void OnOrderPiorityList(
    CadPriorityExtListEventArgs^ ev
)
member OnOrderPiorityList :
        ev : CadPriorityExtListEventArgs -> unit

Parametri

ev CadPriorityExtListEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnOverrideAttListEvent

Metodo DedNetApplicationOnOverrideAttListEvent
Lancia l'evento OverrideAttListEvent.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void OnOverrideAttListEvent(
    OverrideAttListEventArgs e
)
Public Sub OnOverrideAttListEvent (
    e As OverrideAttListEventArgs
)
public:
void OnOverrideAttListEvent(
    OverrideAttListEventArgs^ e
)
member OnOverrideAttListEvent :
        e : OverrideAttListEventArgs -> unit

Parametri

e OverrideAttListEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnOverrideAttrEvent

Metodo DedNetApplicationOnOverrideAttrEvent
Lancia l'evento OverrideAttrEvent.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void OnOverrideAttrEvent(
    Object sender,
    OverrideAttrEventArgs e
)
Public Sub OnOverrideAttrEvent (
    sender As Object,
    e As OverrideAttrEventArgs
)
public:
void OnOverrideAttrEvent(
    Object^ sender,
    OverrideAttrEventArgs^ e
)
member OnOverrideAttrEvent :
        sender : Object *
        e : OverrideAttrEventArgs -> unit

Parametri

sender Object
e OverrideAttrEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnOverrideCommandEnablingEvent

Metodo DedNetApplicationOnOverrideCommandEnablingEvent
Lancia l'evento per non ridefinire l'abilitazione dei comandi.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void OnOverrideCommandEnablingEvent(
    OverrideCommandEnablingEventArgs e
)
Public Sub OnOverrideCommandEnablingEvent (
    e As OverrideCommandEnablingEventArgs
)
public:
void OnOverrideCommandEnablingEvent(
    OverrideCommandEnablingEventArgs^ e
)
member OnOverrideCommandEnablingEvent :
        e : OverrideCommandEnablingEventArgs -> unit

Parametri

e OverrideCommandEnablingEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnOverrideEnableSaveCommControl

Metodo DedNetApplicationOnOverrideEnableSaveCommControl
Chiama l'evento OverrideEnableSaveControl.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void OnOverrideEnableSaveCommControl(
    Object sender
)
Public Sub OnOverrideEnableSaveCommControl (
    sender As Object
)
public:
void OnOverrideEnableSaveCommControl(
    Object^ sender
)
member OnOverrideEnableSaveCommControl :
        sender : Object -> unit

Parametri

sender Object
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnOverrideEnableSaveControl

Metodo DedNetApplicationOnOverrideEnableSaveControl
Chiama l'evento OverrideEnableSaveControl.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void OnOverrideEnableSaveControl(
    Object sender
)
Public Sub OnOverrideEnableSaveControl (
    sender As Object
)
public:
void OnOverrideEnableSaveControl(
    Object^ sender
)
member OnOverrideEnableSaveControl :
        sender : Object -> unit

Parametri

sender Object
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnOverwriteImportPlaceHolder

Metodo DedNetApplicationOnOverwriteImportPlaceHolder
Lancia l'evento per l'override della logica di gestione dei placeholder.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnOverwriteImportPlaceHolder(
    OverwriteImportPlaceHolderEventArgs e
)
Protected Friend Sub OnOverwriteImportPlaceHolder (
    e As OverwriteImportPlaceHolderEventArgs
)
protected public:
void OnOverwriteImportPlaceHolder(
    OverwriteImportPlaceHolderEventArgs^ e
)
member OnOverwriteImportPlaceHolder :
        e : OverwriteImportPlaceHolderEventArgs -> unit

Parametri

e OverwriteImportPlaceHolderEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnPostInit

Metodo DedNetApplicationOnPostInit
Chiama l'evento PostInit.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnPostInit()
Protected Friend Sub OnPostInit
protected public:
void OnPostInit()
member OnPostInit : unit -> unit
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnProgrCollisionEvent

Metodo DedNetApplicationOnProgrCollisionEvent
Lancia l'evento ProgrCollisionEvent

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnProgrCollisionEvent(
    ProgrCollisionEventArgs e
)
Protected Friend Sub OnProgrCollisionEvent (
    e As ProgrCollisionEventArgs
)
protected public:
void OnProgrCollisionEvent(
    ProgrCollisionEventArgs^ e
)
member OnProgrCollisionEvent :
        e : ProgrCollisionEventArgs -> unit

Parametri

e ProgrCollisionEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnRecognizerPathDefined

Metodo DedNetApplicationOnRecognizerPathDefined
Lancia l'evento per la specializzazione della filelist dal path definito nel form di registrazione dei documenti

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void OnRecognizerPathDefined(
    DocRegognizerClientsEventArgs e
)
Public Sub OnRecognizerPathDefined (
    e As DocRegognizerClientsEventArgs
)
public:
void OnRecognizerPathDefined(
    DocRegognizerClientsEventArgs^ e
)
member OnRecognizerPathDefined :
        e : DocRegognizerClientsEventArgs -> unit

Parametri

e DocRegognizerClientsEventArgs
Elementi per la specializzazione della file list da parte del client in ascolto
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnRedrawAnagr

Metodo DedNetApplicationOnRedrawAnagr
Lancia l'evento RedrawAnagr.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void OnRedrawAnagr(
    RedrawAnagrEventArgs e
)
Public Sub OnRedrawAnagr (
    e As RedrawAnagrEventArgs
)
public:
void OnRedrawAnagr(
    RedrawAnagrEventArgs^ e
)
member OnRedrawAnagr :
        e : RedrawAnagrEventArgs -> unit

Parametri

e RedrawAnagrEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnRedrawAttr

Metodo DedNetApplicationOnRedrawAttr
Lancia l'evento RedrawAttr.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void OnRedrawAttr(
    RedrawAttrEventArgs e
)
Public Sub OnRedrawAttr (
    e As RedrawAttrEventArgs
)
public:
void OnRedrawAttr(
    RedrawAttrEventArgs^ e
)
member OnRedrawAttr :
        e : RedrawAttrEventArgs -> unit

Parametri

e RedrawAttrEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnRedrawComm

Metodo DedNetApplicationOnRedrawComm
Lancia l'evento RedrawComm.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void OnRedrawComm(
    RedrawCommEventArgs e
)
Public Sub OnRedrawComm (
    e As RedrawCommEventArgs
)
public:
void OnRedrawComm(
    RedrawCommEventArgs^ e
)
member OnRedrawComm :
        e : RedrawCommEventArgs -> unit

Parametri

e RedrawCommEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnRedrawDedType

Metodo DedNetApplicationOnRedrawDedType
Lancia l'evento RedrawDedType.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void OnRedrawDedType(
    RedrawDedTypeEventArgs e
)
Public Sub OnRedrawDedType (
    e As RedrawDedTypeEventArgs
)
public:
void OnRedrawDedType(
    RedrawDedTypeEventArgs^ e
)
member OnRedrawDedType :
        e : RedrawDedTypeEventArgs -> unit

Parametri

e RedrawDedTypeEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnRedrawDep

Metodo DedNetApplicationOnRedrawDep
Lancia l'evento RedrawDep.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void OnRedrawDep(
    RedrawDepEventArgs e
)
Public Sub OnRedrawDep (
    e As RedrawDepEventArgs
)
public:
void OnRedrawDep(
    RedrawDepEventArgs^ e
)
member OnRedrawDep :
        e : RedrawDepEventArgs -> unit

Parametri

e RedrawDepEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnRedrawDist

Metodo DedNetApplicationOnRedrawDist
Lancia l'evento RedrawDist.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void OnRedrawDist(
    RedrawDistEventArgs e
)
Public Sub OnRedrawDist (
    e As RedrawDistEventArgs
)
public:
void OnRedrawDist(
    RedrawDistEventArgs^ e
)
member OnRedrawDist :
        e : RedrawDistEventArgs -> unit

Parametri

e RedrawDistEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnReferenceUpdateOperationEvent

Metodo DedNetApplicationOnReferenceUpdateOperationEvent
Lancia l'evento per registrarsi ai delegate del comando UpdateDocumentReference.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnReferenceUpdateOperationEvent(
    ReferenceUpdateOperationEventArgs e
)
Protected Friend Sub OnReferenceUpdateOperationEvent (
    e As ReferenceUpdateOperationEventArgs
)
protected public:
void OnReferenceUpdateOperationEvent(
    ReferenceUpdateOperationEventArgs^ e
)
member OnReferenceUpdateOperationEvent :
        e : ReferenceUpdateOperationEventArgs -> unit

Parametri

e ReferenceUpdateOperationEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnRemoveAnagr

Metodo DedNetApplicationOnRemoveAnagr
Lancia l'evento RemoveAnagr.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnRemoveAnagr(
    RemoveAnagrEventArgs e
)
Protected Friend Sub OnRemoveAnagr (
    e As RemoveAnagrEventArgs
)
protected public:
void OnRemoveAnagr(
    RemoveAnagrEventArgs^ e
)
member OnRemoveAnagr :
        e : RemoveAnagrEventArgs -> unit

Parametri

e RemoveAnagrEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnRemoveDocument

Metodo DedNetApplicationOnRemoveDocument
Lancia l'evento di cancellazione documento.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnRemoveDocument(
    Object sender,
    DedEventArgs e
)
Protected Friend Sub OnRemoveDocument (
    sender As Object,
    e As DedEventArgs
)
protected public:
void OnRemoveDocument(
    Object^ sender,
    DedEventArgs^ e
)
member OnRemoveDocument :
        sender : Object *
        e : DedEventArgs -> unit

Parametri

sender Object
Oggetto DocStructInfo sul quale è stata lanciata l'operazione.
e DedEventArgs
Argomenti dell'evento.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnResetSearchCriteria

Metodo DedNetApplicationOnResetSearchCriteria
Chiama l'evento ResetSearchCriteria

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnResetSearchCriteria(
    Object sender,
    DedBeforeOrAfterEventArgs ev
)
Protected Friend Sub OnResetSearchCriteria (
    sender As Object,
    ev As DedBeforeOrAfterEventArgs
)
protected public:
void OnResetSearchCriteria(
    Object^ sender,
    DedBeforeOrAfterEventArgs^ ev
)
member OnResetSearchCriteria :
        sender : Object *
        ev : DedBeforeOrAfterEventArgs -> unit

Parametri

sender Object
Controllo che ha effettuata la chiamata
ev DedBeforeOrAfterEventArgs
Oggetto DedBeforeOrAfterEventArgs inizializzato da passare all'evento.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnSaveCustomButtonClickEvent

Metodo DedNetApplicationOnSaveCustomButtonClickEvent
Chiama l'evento SaveCustomButtonClickEvent.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnSaveCustomButtonClickEvent(
    DedFormSave frm
)
Protected Friend Sub OnSaveCustomButtonClickEvent (
    frm As DedFormSave
)
protected public:
void OnSaveCustomButtonClickEvent(
    DedFormSave^ frm
)
member OnSaveCustomButtonClickEvent :
        frm : DedFormSave -> unit

Parametri

frm DedFormSave
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnSaveDistOnApprovedEventEvent

Metodo DedNetApplicationOnSaveDistOnApprovedEventEvent
Metodo che esegue l'evento di 'SaveDistOnApprovedEvent'.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void OnSaveDistOnApprovedEventEvent(
    SaveDistOnApprovedEventArgs ev
)
Public Sub OnSaveDistOnApprovedEventEvent (
    ev As SaveDistOnApprovedEventArgs
)
public:
void OnSaveDistOnApprovedEventEvent(
    SaveDistOnApprovedEventArgs^ ev
)
member OnSaveDistOnApprovedEventEvent :
        ev : SaveDistOnApprovedEventArgs -> unit

Parametri

ev SaveDistOnApprovedEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnSendToCommandDisableDocumentEvent

Metodo DedNetApplicationOnSendToCommandDisableDocumentEvent
Lancia l'evento per non inviare alcuni file

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void OnSendToCommandDisableDocumentEvent(
    DocumentDisableEventArgs e
)
Public Sub OnSendToCommandDisableDocumentEvent (
    e As DocumentDisableEventArgs
)
public:
void OnSendToCommandDisableDocumentEvent(
    DocumentDisableEventArgs^ e
)
member OnSendToCommandDisableDocumentEvent :
        e : DocumentDisableEventArgs -> unit

Parametri

e DocumentDisableEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnSetDefaultFindCodeFilterEvent

Metodo DedNetApplicationOnSetDefaultFindCodeFilterEvent
Metodo che esegue l'evento di 'SetDefaultFindCodeFilter'.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void OnSetDefaultFindCodeFilterEvent(
    SetDefaultFindCodeFilterEventArgs ev
)
Public Sub OnSetDefaultFindCodeFilterEvent (
    ev As SetDefaultFindCodeFilterEventArgs
)
public:
void OnSetDefaultFindCodeFilterEvent(
    SetDefaultFindCodeFilterEventArgs^ ev
)
member OnSetDefaultFindCodeFilterEvent :
        ev : SetDefaultFindCodeFilterEventArgs -> unit

Parametri

ev SetDefaultFindCodeFilterEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnShowPreview

Metodo DedNetApplicationOnShowPreview
Lancia l'evento ShowPreview.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void OnShowPreview(
    ShowPreviewEventArgs e
)
Public Sub OnShowPreview (
    e As ShowPreviewEventArgs
)
public:
void OnShowPreview(
    ShowPreviewEventArgs^ e
)
member OnShowPreview :
        e : ShowPreviewEventArgs -> unit

Parametri

e ShowPreviewEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnShowReplaceAnagrDistForm

Metodo DedNetApplicationOnShowReplaceAnagrDistForm
Chiama l'evento ShowReplaceAnagrDistForm.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnShowReplaceAnagrDistForm(
    DedFormReplaceAnagrDist frm
)
Protected Friend Sub OnShowReplaceAnagrDistForm (
    frm As DedFormReplaceAnagrDist
)
protected public:
void OnShowReplaceAnagrDistForm(
    DedFormReplaceAnagrDist^ frm
)
member OnShowReplaceAnagrDistForm :
        frm : DedFormReplaceAnagrDist -> unit

Parametri

frm DedFormReplaceAnagrDist
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnShowSaveForm

Metodo DedNetApplicationOnShowSaveForm
Chiama l'evento ShowSaveForm.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnShowSaveForm(
    DedFormSave frm
)
Protected Friend Sub OnShowSaveForm (
    frm As DedFormSave
)
protected public:
void OnShowSaveForm(
    DedFormSave^ frm
)
member OnShowSaveForm :
        frm : DedFormSave -> unit

Parametri

frm DedFormSave
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnShowZoomPreview

Metodo DedNetApplicationOnShowZoomPreview

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnShowZoomPreview(
    ShowZoomPreviewEventArgs e
)
Protected Friend Sub OnShowZoomPreview (
    e As ShowZoomPreviewEventArgs
)
protected public:
void OnShowZoomPreview(
    ShowZoomPreviewEventArgs^ e
)
member OnShowZoomPreview :
        e : ShowZoomPreviewEventArgs -> unit

Parametri

e ShowZoomPreviewEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnSkipDocumentStatusOnSaveDist

Metodo DedNetApplicationOnSkipDocumentStatusOnSaveDist
Lancia l'evento SkipDocumentStatusOnSaveDistEvent

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnSkipDocumentStatusOnSaveDist(
    SkipDocumentStatusOnSaveDistEventArgs e
)
Protected Friend Sub OnSkipDocumentStatusOnSaveDist (
    e As SkipDocumentStatusOnSaveDistEventArgs
)
protected public:
void OnSkipDocumentStatusOnSaveDist(
    SkipDocumentStatusOnSaveDistEventArgs^ e
)
member OnSkipDocumentStatusOnSaveDist :
        e : SkipDocumentStatusOnSaveDistEventArgs -> unit

Parametri

e SkipDocumentStatusOnSaveDistEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnSkipUpdateAttribListEvent

Metodo DedNetApplicationOnSkipUpdateAttribListEvent
Lancia l'evento SkipUpdateAttribListEvent.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void OnSkipUpdateAttribListEvent(
    SkipEsclAttribEventArgs e
)
Public Sub OnSkipUpdateAttribListEvent (
    e As SkipEsclAttribEventArgs
)
public:
void OnSkipUpdateAttribListEvent(
    SkipEsclAttribEventArgs^ e
)
member OnSkipUpdateAttribListEvent :
        e : SkipEsclAttribEventArgs -> unit

Parametri

e SkipEsclAttribEventArgs
Argomento SkipEsclAttribEventArgs.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnStateChanged

Metodo DedNetApplicationOnStateChanged
Lancia l'evento StateChanged.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnStateChanged(
    StateChangedEventArgs e
)
Protected Friend Sub OnStateChanged (
    e As StateChangedEventArgs
)
protected public:
void OnStateChanged(
    StateChangedEventArgs^ e
)
member OnStateChanged :
        e : StateChangedEventArgs -> unit

Parametri

e StateChangedEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnStateCommandDocClose

Metodo DedNetApplicationOnStateCommandDocClose
Lancia l'evento StateCommandDocClose.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnStateCommandDocClose(
    StateCommandEventArgs e
)
Protected Friend Sub OnStateCommandDocClose (
    e As StateCommandEventArgs
)
protected public:
void OnStateCommandDocClose(
    StateCommandEventArgs^ e
)
member OnStateCommandDocClose :
        e : StateCommandEventArgs -> unit

Parametri

e StateCommandEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnStateCommandDocOpen

Metodo DedNetApplicationOnStateCommandDocOpen
Lancia l'evento StateCommandDocOpen.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnStateCommandDocOpen(
    StateCommandEventArgs e
)
Protected Friend Sub OnStateCommandDocOpen (
    e As StateCommandEventArgs
)
protected public:
void OnStateCommandDocOpen(
    StateCommandEventArgs^ e
)
member OnStateCommandDocOpen :
        e : StateCommandEventArgs -> unit

Parametri

e StateCommandEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnStateCommandDocPublish

Metodo DedNetApplicationOnStateCommandDocPublish
Lancia l'evento StateCommandDocPublish.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnStateCommandDocPublish(
    StateCommandEventArgs e
)
Protected Friend Sub OnStateCommandDocPublish (
    e As StateCommandEventArgs
)
protected public:
void OnStateCommandDocPublish(
    StateCommandEventArgs^ e
)
member OnStateCommandDocPublish :
        e : StateCommandEventArgs -> unit

Parametri

e StateCommandEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnStateCommandDocPublishErase

Metodo DedNetApplicationOnStateCommandDocPublishErase
Lancia l'evento StateCommandDocPublishEraseEvent.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnStateCommandDocPublishErase(
    StateCommandEventArgs e
)
Protected Friend Sub OnStateCommandDocPublishErase (
    e As StateCommandEventArgs
)
protected public:
void OnStateCommandDocPublishErase(
    StateCommandEventArgs^ e
)
member OnStateCommandDocPublishErase :
        e : StateCommandEventArgs -> unit

Parametri

e StateCommandEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnStateCommandDocsPublished

Metodo DedNetApplicationOnStateCommandDocsPublished
Lancia l'evento di termine pubblicazione dei documenti dell'anagrafica rilasciata

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnStateCommandDocsPublished(
    DedCommandEventArgs e
)
Protected Friend Sub OnStateCommandDocsPublished (
    e As DedCommandEventArgs
)
protected public:
void OnStateCommandDocsPublished(
    DedCommandEventArgs^ e
)
member OnStateCommandDocsPublished :
        e : DedCommandEventArgs -> unit

Parametri

e DedCommandEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnStateCommandEvent

Metodo DedNetApplicationOnStateCommandEvent
Lancia l'evento StateCommandEvent.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnStateCommandEvent(
    DedCommandEventArgs e
)
Protected Friend Sub OnStateCommandEvent (
    e As DedCommandEventArgs
)
protected public:
void OnStateCommandEvent(
    DedCommandEventArgs^ e
)
member OnStateCommandEvent :
        e : DedCommandEventArgs -> unit

Parametri

e DedCommandEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnStateCommmandDocWrite

Metodo DedNetApplicationOnStateCommmandDocWrite
Lancia l'evento StateCommmandDocWrite

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnStateCommmandDocWrite(
    StateCommandEventArgs e
)
Protected Friend Sub OnStateCommmandDocWrite (
    e As StateCommandEventArgs
)
protected public:
void OnStateCommmandDocWrite(
    StateCommandEventArgs^ e
)
member OnStateCommmandDocWrite :
        e : StateCommandEventArgs -> unit

Parametri

e StateCommandEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnStateElaboratingDocuments

Metodo DedNetApplicationOnStateElaboratingDocuments
Lancia l'evento OnStateElaboratingDocuments

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnStateElaboratingDocuments(
    DocumentsEventArgs e
)
Protected Friend Sub OnStateElaboratingDocuments (
    e As DocumentsEventArgs
)
protected public:
void OnStateElaboratingDocuments(
    DocumentsEventArgs^ e
)
member OnStateElaboratingDocuments :
        e : DocumentsEventArgs -> unit

Parametri

e DocumentsEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnTypeAdded

Metodo DedNetApplicationOnTypeAdded
Chiama l'evento TypeAdded.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnTypeAdded(
    QsManagerEventArgs e
)
Protected Friend Sub OnTypeAdded (
    e As QsManagerEventArgs
)
protected public:
void OnTypeAdded(
    QsManagerEventArgs^ e
)
member OnTypeAdded :
        e : QsManagerEventArgs -> unit

Parametri

e QsManagerEventArgs
Oggetto QsManagerEventArgs.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnTypesReloaded

Metodo DedNetApplicationOnTypesReloaded
Lancia l'evento TypesReloaded.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnTypesReloaded(
    Object sender,
    EventArgs e
)
Protected Friend Sub OnTypesReloaded (
    sender As Object,
    e As EventArgs
)
protected public:
void OnTypesReloaded(
    Object^ sender,
    EventArgs^ e
)
member OnTypesReloaded :
        sender : Object *
        e : EventArgs -> unit

Parametri

sender Object
e EventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnUnRilErasePublishEvent

Metodo DedNetApplicationOnUnRilErasePublishEvent
Metodo che esegue l'evento di UnRilErasePublishEvent

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void OnUnRilErasePublishEvent(
    Object sender,
    UnRilErasePublishEventArgs ev
)
Public Sub OnUnRilErasePublishEvent (
    sender As Object,
    ev As UnRilErasePublishEventArgs
)
public:
void OnUnRilErasePublishEvent(
    Object^ sender,
    UnRilErasePublishEventArgs^ ev
)
member OnUnRilErasePublishEvent :
        sender : Object *
        ev : UnRilErasePublishEventArgs -> unit

Parametri

sender Object
ev UnRilErasePublishEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnUpgradeAnagrComm

Metodo DedNetApplicationOnUpgradeAnagrComm
Lancia l'evento UpgradeAnagrCommEvent.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnUpgradeAnagrComm(
    Object sender,
    UpgradeAnagrCommEventArgs e
)
Protected Friend Sub OnUpgradeAnagrComm (
    sender As Object,
    e As UpgradeAnagrCommEventArgs
)
protected public:
void OnUpgradeAnagrComm(
    Object^ sender,
    UpgradeAnagrCommEventArgs^ e
)
member OnUpgradeAnagrComm :
        sender : Object *
        e : UpgradeAnagrCommEventArgs -> unit

Parametri

sender Object
e UpgradeAnagrCommEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnValidateCheckFunction

Metodo DedNetApplicationOnValidateCheckFunction
Lancia l'evento ValidateCheckFunction.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnValidateCheckFunction(
    ValidateCheckFunctionEventArgs e
)
Protected Friend Sub OnValidateCheckFunction (
    e As ValidateCheckFunctionEventArgs
)
protected public:
void OnValidateCheckFunction(
    ValidateCheckFunctionEventArgs^ e
)
member OnValidateCheckFunction :
        e : ValidateCheckFunctionEventArgs -> unit

Parametri

e ValidateCheckFunctionEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnValidateCommPropertyEvent

Metodo DedNetApplicationOnValidateCommPropertyEvent
Lancia l'evento ValidateCommPropertyEvent.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnValidateCommPropertyEvent(
    ValidateFamPropertyEventArgs e
)
Protected Friend Sub OnValidateCommPropertyEvent (
    e As ValidateFamPropertyEventArgs
)
protected public:
void OnValidateCommPropertyEvent(
    ValidateFamPropertyEventArgs^ e
)
member OnValidateCommPropertyEvent :
        e : ValidateFamPropertyEventArgs -> unit

Parametri

e ValidateFamPropertyEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.OnValidateFamPropertyEvent

Metodo DedNetApplicationOnValidateFamPropertyEvent
Lancia l'evento ValidateFamPropertyEvent.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnValidateFamPropertyEvent(
    ValidateFamPropertyEventArgs e
)
Protected Friend Sub OnValidateFamPropertyEvent (
    e As ValidateFamPropertyEventArgs
)
protected public:
void OnValidateFamPropertyEvent(
    ValidateFamPropertyEventArgs^ e
)
member OnValidateFamPropertyEvent :
        e : ValidateFamPropertyEventArgs -> unit

Parametri

e ValidateFamPropertyEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.RegisterUser

Metodo DedNetApplicationRegisterUser
Crea l'utente con l'impostazione dei relativi permessi

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public UsrUser RegisterUser(
    string username
)
Public Function RegisterUser (
    username As String
) As UsrUser
public:
UsrUser^ RegisterUser(
    String^ username
)
member RegisterUser :
        username : string -> UsrUser

Parametri

username String
Nome dell'utente da registrare

Valore di ritorno

UsrUser
Oggetto UsrUser
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.Reload

Metodo DedNetApplicationReload
Ricarica tutta la struttura degli oggetti e lancia l'evento TypesReloaded.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Reload()
Public Sub Reload
public:
void Reload()
member Reload : unit -> unit
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.ReloadAttLists

Metodo DedNetApplicationReloadAttLists
Rilegge dal database le liste att, scartando eventuali modifiche non salvate.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ReloadAttLists()
Public Sub ReloadAttLists
public:
void ReloadAttLists()
member ReloadAttLists : unit -> unit
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.SelectData

Metodo DedNetApplicationSelectData
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | SelectData(IEnumerableDedData) | Chiede all'utente di selezionare una sola anagrafica tra quelle che ha specificato in ingresso.
Metodo pubblico | SelectData(DedNetApplication, String) | Chiede all'utente di selezionare una sola anagrafica. Restituisce null se l'utente annulla.
Metodo pubblico | SelectData(DedNetApplication, String, Boolean) | Chiede all'utente di selezionare una sola anagrafica. Restituisce null se l'utente annulla.
Torna su
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.SelectData(IEnumerable<DedData>)

Metodo DedNetApplicationSelectData(IEnumerableDedData)
Chiede all'utente di selezionare una sola anagrafica tra quelle che ha specificato in ingresso.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData SelectData(
    IEnumerable<DedData> dataList
)
Public Function SelectData (
    dataList As IEnumerable(Of DedData)
) As DedData
public:
DedData^ SelectData(
    IEnumerable<DedData^>^ dataList
)
member SelectData :
        dataList : IEnumerable<DedData> -> DedData

Parametri

dataList IEnumerable DedData
Elenco di anagrafiche da riportare nel dialogo.

Valore di ritorno

DedData
Vedi anche

Documentazione

Classe DedNetApplication
Overload di SelectData
Namespace DedNet


Metodo DedNetApplication.SelectData(DedNetApplication, String)

Metodo DedNetApplicationSelectData(DedNetApplication, String)
Chiede all'utente di selezionare una sola anagrafica. Restituisce null se l'utente annulla.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData SelectData(
    DedNetApplication app,
    string textMsg
)
Public Function SelectData (
    app As DedNetApplication,
    textMsg As String
) As DedData
public:
DedData^ SelectData(
    DedNetApplication^ app,
    String^ textMsg
)
member SelectData :
        app : DedNetApplication *
        textMsg : string -> DedData

Parametri

app DedNetApplication
Oggetto applicazione.
textMsg String
Messaggio da visualizzare all'utente.

Valore di ritorno

DedData
Restituisce l'anagrafica selezionata oppure null se l'utente annulla.
Vedi anche

Documentazione

Classe DedNetApplication
Overload di SelectData
Namespace DedNet


Metodo DedNetApplication.SelectData(DedNetApplication, String, Boolean)

Metodo DedNetApplicationSelectData(DedNetApplication, String, Boolean)
Chiede all'utente di selezionare una sola anagrafica. Restituisce null se l'utente annulla.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData SelectData(
    DedNetApplication app,
    string textMsg,
    bool onlyLav
)
Public Function SelectData (
    app As DedNetApplication,
    textMsg As String,
    onlyLav As Boolean
) As DedData
public:
DedData^ SelectData(
    DedNetApplication^ app,
    String^ textMsg,
    bool onlyLav
)
member SelectData :
        app : DedNetApplication *
        textMsg : string *
        onlyLav : bool -> DedData

Parametri

app DedNetApplication
Oggetto applicazione.
textMsg String
Messaggio da visualizzare all'utente.
onlyLav Boolean
Se impostata a True, potranno essere selezionate anagrafiche in Lavorazione.

Valore di ritorno

DedData
Restituisce l'anagrafica selezionata oppure null se l'utente annulla.
Vedi anche

Documentazione

Classe DedNetApplication
Overload di SelectData
Namespace DedNet


Metodo DedNetApplication.SelectDataMulti

Metodo DedNetApplicationSelectDataMulti
Chiede all'utente di selezionare un elenco di anagrafiche. Restituisce null se l'utente annulla.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataList SelectDataMulti(
    DedNetApplication app,
    string textMsg,
    bool onlyLav
)
Public Function SelectDataMulti (
    app As DedNetApplication,
    textMsg As String,
    onlyLav As Boolean
) As DedDataList
public:
DedDataList^ SelectDataMulti(
    DedNetApplication^ app,
    String^ textMsg,
    bool onlyLav
)
member SelectDataMulti :
        app : DedNetApplication *
        textMsg : string *
        onlyLav : bool -> DedDataList

Parametri

app DedNetApplication
Oggetto applicazione.
textMsg String
Messaggio da visualizzare all'utente.
onlyLav Boolean
Se impostata a True, potranno essere selezionate anagrafiche in Lavorazione.

Valore di ritorno

DedDataList
Restituisce l'anagrafica selezionata oppure null se l'utente annulla.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.SelectDedType

Metodo DedNetApplicationSelectDedType
Chiede all'utente di selezionare una sola famiglia. Restituisce null se l'utente annulla.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedType SelectDedType(
    DedNetApplication app,
    string textMsg
)
Public Function SelectDedType (
    app As DedNetApplication,
    textMsg As String
) As DedType
public:
DedType^ SelectDedType(
    DedNetApplication^ app,
    String^ textMsg
)
member SelectDedType :
        app : DedNetApplication *
        textMsg : string -> DedType

Parametri

app DedNetApplication
Oggetto applicazione.
textMsg String
Messaggio da visualizzare all'utente.

Valore di ritorno

DedType
Restituisce la famiglia selezionata oppure null se l'utente annulla.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.SelectDocument

Metodo DedNetApplicationSelectDocument
Chiede all'utente di selezionare un solo documento. Restituisce null se l'utente annulla.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDoc SelectDocument(
    DedNetApplication app,
    string textMsg
)
Public Function SelectDocument (
    app As DedNetApplication,
    textMsg As String
) As DedDoc
public:
DedDoc^ SelectDocument(
    DedNetApplication^ app,
    String^ textMsg
)
member SelectDocument :
        app : DedNetApplication *
        textMsg : string -> DedDoc

Parametri

app DedNetApplication
Oggetto applicazione.
textMsg String
Messaggio da visualizzare all'utente.

Valore di ritorno

DedDoc
Restituisce il documento selezionata oppure null se l'utente annulla.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.SetUserListExt

Metodo DedNetApplicationSetUserListExt
Metodo che imposta la nuova lista di estensioni

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetUserListExt(
    string[] arrayExt
)
Public Sub SetUserListExt (
    arrayExt As String()
)
public:
void SetUserListExt(
    array<String^>^ arrayExt
)
member SetUserListExt :
        arrayExt : string[] -> unit

Parametri

arrayExt String
Array delle estensioni
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.ShowDedDataList

Metodo DedNetApplicationShowDedDataList
Metodo che riporta, nel dialogo della ricerca, l'elenco di anagrafiche specificate in ingresso.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ShowDedDataList(
    DedDataList dataList
)
Public Sub ShowDedDataList (
    dataList As DedDataList
)
public:
void ShowDedDataList(
    DedDataList^ dataList
)
member ShowDedDataList :
        dataList : DedDataList -> unit

Parametri

dataList DedDataList
Elenco di anagrafiche da visualizzare a schermo.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.ShowDedFormAbout

Metodo DedNetApplicationShowDedFormAbout
Mostra il dialogo FormAbout del QsUI inizializzato con le informazioni del DED.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ShowDedFormAbout()
Public Sub ShowDedFormAbout
public:
void ShowDedFormAbout()
member ShowDedFormAbout : unit -> unit
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.ShowDocsSelectionForm

Metodo DedNetApplicationShowDocsSelectionForm
Mostra la finestra di selezione dei documenti nel caso venga passato useUI a true in tutti i casi esegue anche l'evento di post selezione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DialogResult ShowDocsSelectionForm(
    GridInfoDataList list,
    bool useUI,
    IWin32Window owner = null
)
Public Function ShowDocsSelectionForm (
    list As GridInfoDataList,
    useUI As Boolean,
    Optional owner As IWin32Window = Nothing
) As DialogResult
public:
DialogResult ShowDocsSelectionForm(
    GridInfoDataList^ list,
    bool useUI,
    IWin32Window^ owner = nullptr
)
member ShowDocsSelectionForm :
        list : GridInfoDataList *
        useUI : bool *
        ?owner : IWin32Window
(* Defaults:
        let _owner = defaultArg owner null
*)
-> DialogResult

Parametri

list GridInfoDataList
Oggetto contenente le informazioni dei documenti.
useUI Boolean
owner IWin32Window (Optional)

Valore di ritorno

DialogResult
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.StatoAnagr

Metodo DedNetApplicationStatoAnagr
Metodo che restituisce una stringa con lo stato attuale dell'anagrafica.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string StatoAnagr(
    DedData data
)
Public Function StatoAnagr (
    data As DedData
) As String
public:
String^ StatoAnagr(
    DedData^ data
)
member StatoAnagr :
        data : DedData -> string

Parametri

data DedData
Anagrafica della quale analizzare lo stato.

Valore di ritorno

String
Stringa con lo stato attuale dell'anagrafica
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.StatoAnagrMinimal

Metodo DedNetApplicationStatoAnagrMinimal
Metodo che restituisce una stringa con lo stato attuale dell'anagrafica.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string StatoAnagrMinimal(
    DedData data
)
Public Function StatoAnagrMinimal (
    data As DedData
) As String
public:
String^ StatoAnagrMinimal(
    DedData^ data
)
member StatoAnagrMinimal :
        data : DedData -> string

Parametri

data DedData
Anagrafica della quale analizzare lo stato.

Valore di ritorno

String
Stringa con lo stato attuale dell'anagrafica
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.StatoDoc

Metodo DedNetApplicationStatoDoc
Metodo che restituisce una stringa con lo stato attuale del doccumento.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string StatoDoc(
    string fullFileName
)
Public Function StatoDoc (
    fullFileName As String
) As String
public:
String^ StatoDoc(
    String^ fullFileName
)
member StatoDoc :
        fullFileName : string -> string

Parametri

fullFileName String
Percorso completo del documento.

Valore di ritorno

String
Stringa con lo stato attuale del documento.
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.StoreForcedAuthentication

Metodo DedNetApplicationStoreForcedAuthentication
Memorizza le credenziali per l'accesso automatico senza autenticazione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void StoreForcedAuthentication(
    string username
)
Public Sub StoreForcedAuthentication (
    username As String
)
public:
void StoreForcedAuthentication(
    String^ username
)
member StoreForcedAuthentication :
        username : string -> unit

Parametri

username String
Nome dell'utente da registrare
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.UpdateAttrOrder

Metodo DedNetApplicationUpdateAttrOrder
Aggiorna tutti gli indici degali attributi.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void UpdateAttrOrder()
Public Sub UpdateAttrOrder
public:
void UpdateAttrOrder()
member UpdateAttrOrder : unit -> unit
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Metodo DedNetApplication.UserLastModified

Metodo DedNetApplicationUserLastModified
Indica l'ultimo utente che ha effettuato un pubblica. Usato nel caso di PSW con DFS mode.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string UserLastModified(
    DedDoc doc
)
Public Function UserLastModified (
    doc As DedDoc
) As String
public:
String^ UserLastModified(
    DedDoc^ doc
)
member UserLastModified :
        doc : DedDoc -> string

Parametri

doc DedDoc
Documento da analizzare.

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Eventi di DedNetApplication

Il tipo DedNetApplication espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | AddDataDocEvent | Evento chiamato dopo l'associazione del documento all'anagrafica (linking)
Evento pubblico | AddExtensionsRecognizerFormEvent | Evento per poter modificare la lista delle estensioni aggiuntivi nel form di riconoscimento dei file (DedFormFileRecognizer)
Evento pubblico | AfterEraseEmptyPwsFolderEvent | Evento chiamato alla fine della cancellazione delle cartelle vuote della pws.
Evento pubblico | AfterSaveDedCommTypeEvent | Evento chiamato nel post salvataggio.
Evento pubblico | AfterSaveDedTypeEvent | Evento chiamato nel post salvataggio.
Evento pubblico | AnagrSelectionDeletedEvent | Evento chiamato al termine dell'eliminazione della selezione di anagrafiche
Evento pubblico | AttributeChanged | Evento chiamato alla modifica di un attributo nell'edita attributi.
Evento pubblico | AttributeInit | Evento chiamato all'inizializzazionr del controllo degli attributi.
Evento pubblico | BeforeShowZoomPreviewEvent | Evento che scatta prima che venga caricato il QsTopDwgViewer. Permette di definire con che profilo eseguire il QsTopDwgViewer (di default viene eseguito il profilo 'Simple').
Evento pubblico | BomEditFormButtonClickEvent | Evento chiamato alla pressione dei pulsanti personalizzati delle barre del form editor delle distinte
Evento pubblico | BomEditFormToggleSwitchEvent | Evento chiamato al cambio stato dei toggle personalizzati delle barre del form editor delle distinte
Evento pubblico | BomExplorerAddReplaceDataEvent | Evento chiamato in fase di aggiunta o sostituzione codice dal controllo dedicato nel panello interno all'explorer control.
Evento pubblico | BomExplorerButtonClickEvent | Evento chiamato alla pressione dei pulsanti personalizzati della finestra dell'editor delle distinte.
Evento pubblico | BomExplorerContextMenuOpeningEvent | Evento chiamato in fase di apertura del context menu sul controllo distinta interno al bom explorer. Permette di aggiungere comandi.
Evento pubblico | BomExplorerLoadDistEvent | Evento chiamato al caricamento di una distinta nel controllo explorer dell'editor delle distinte.
Evento pubblico | ChangeStateECOEvent | Evento lanciato prima e dopo il cambio di stato di un ECO.
Evento pubblico | ChangingDependencyDocumentEvent | Evento chiamato quando si debba effettuare la sostituzione fisica di un riferimento in un file. Se attiva l'area locale, l'aggiornamento deve avvenire sia nel file presente nel vault che nella pws.
Evento pubblico | CheckProgrReservedEvent | Evento lanciato quando si verifica una collisione di progressivi al salvataggio nel DB su una famiglia con infouser.
Evento pubblico | CheckRevAlphabetEvent | Evento lanciato quando si verifica una i caratteri dell'alfabeto.
Evento pubblico | ClassListItemClickEvent | Evento chiamato quando l'utente clicca su un elemento del class list.
Evento pubblico | CommAddAnagItemEvent | Evento sull'aggiunta di un elemento di anagrafica sulla commessa
Evento pubblico | CommandExecutingEvent | Evento di esecuzione comando. Questo evento viene chiamato all'inizio ed alla fine dell'esecuzione del comando.
Evento pubblico | CommCancelEvent | Evento di cancellazione creazione/modifica commessa.
Evento pubblico | CommDescrOverrideEvent | Evento chiamato per poter ridefinire la descrizione della commessa ( inserire una lista a tendina ).
Evento pubblico | CommElementCreateDataEvent | Evento sulla creazione dell'anagrafica chiamato sia prima che dopo la creazione di una anagrafica a partire da un nuovo elemento di distinta da aggiungere. Questo è l'evento ad alto livello che agisce a livello di comando, vedere anche l'evento DistItemCreateData..
Evento pubblico | CommFileExplorerUpdateEvent | Evento per calcolare il percorso da visualizzare nell'Esplora Risorse delle commesse.
Evento pubblico | CopyDocumentEvent | Evento chiamato per effettuare la copia di un file. Chi gestisce questo evento si deve preoccupare di copiare sia la versione in locale che quella del server, nel caso di area locale attiva.
Evento pubblico | CreateCommEvent | Evento lanciato prima e dopo la creazione di una commessa.
Evento pubblico | CreateECOEvent | Evento lanciato prima e dopo la creazione di un ECO.
Evento pubblico | CreateMultiLevelBomEvent | Evento che permette di editare la distinta ricambi multilivello
Evento pubblico | CreatingSparePartDrawing | Evento chiamato quando viene eseguito il comando 'Crea tavola ricambi'.
Evento pubblico | DedBomEditLoaded | Evento chiamato durante il load del form DedBomEdit.
Evento pubblico | DedDataChangedEvent | Evento chiamato quando viene aggiunto un record in DedData.
Evento pubblico | DedDataMoveEvent | Evento chiamato sullo spostamento di un'anagrafica.
Evento pubblico | DedOpenDocumentEvent | Evento chiamato in fase di apertura di un documento dal DED.
Evento pubblico | DedRuleLuaEvent | Evento chiamato per la gestione delle regole di autocomposizione in Lua.
Evento pubblico | DedRuleRowSetAttrPostEvent | Evento chiamato subito dopo la sostituzione di tutta la stringa di una regola.
Evento pubblico | DedRuleSetAttrPostEvent | Evento chiamato subito dopo l'impostazione degli attributi di una regola.
Evento pubblico | DedRuleSetAttrPreEvent | Evento chiamato subito prima dell'impostazione degli attributi di una regola.
Evento pubblico | DedRuleSingleSetAttrPreEvent | Evento chiamato prima della sostituzione di un singolo token di una singola regola.
Evento pubblico | DedTranslationChangedEvent | Evento chiamato quando viene aggiunto un record in DedData.
Evento pubblico | DefineFileDependencyEvent | Evento chiamato per definire la dipendenza di un file che non è presente nel Database. Viene chiamato con il Before e l'After ad indicare il momento e se si imposta come Handled lascia la lista delle dipendenze così come l'ha modificata il client.
Evento pubblico | DisableAutoUpdateAnagrCommEvent | Evento per disabilitare l'aggiornamento automatico delle revisioni delle anagrafiche di commessa La disabilitazione avviene tramite un valore di un determinato attributo di commessa
Evento pubblico | DistAddNodeEvent | Evento chiamata quando viene iserito un nuovo nodo in distinta.
Evento pubblico | DistChangeFieldValueEvent | Evento chiamato alla modifica di un attributo di distinta nella finestra dell'editor delle distinte.
Evento pubblico | DistCloneDataEvent | Evento chiamato alla copia di ogni elemento nel clona distinta chiamato da DEDAPI.DuplicaDistinta()
Evento pubblico | DistCopyDataEvent | Evento chiamata quando viene copiato un codice dal pannello di dx a quell di dx tramite editor distinte. Possibilità di annuallare l'inserimento e cambiare i dati inseriti.
Evento pubblico | DistDragElementEvent | Evento chiamata quando viene aggiunto un elemento alla distinta tramite l'inizia parte veloce. Possibilità di annullare l'inserimento e cambiare i dati inseriti.
Evento pubblico | DistEditSaveEvent | Evento di salvataggio all'interno dell'editor delle distinte.
Evento pubblico | DistElementCreateDataEvent | Evento sulla creazione dell'anagrafica chiamato sia prima che dopo la creazione di una anagrafica a partire da un nuovo elemento di distinta da aggiungere. Questo è l'evento ad alto livello che agisce a livello di comando, vedere anche l'evento DistItemCreateData..
Evento pubblico | DistItemCreateDataEvent | Evento sulla creazione dell'anagrafica chiamato sia prima che dopo la creazione di una anagrafica a partire da un nuovo elemento di distinta da aggiungere. Questo è l'evento a basso livello, per agire a livello di comando vedere l'evento DistElementCreateData.
Evento pubblico | DistLevelSaveEvent | Evento di salvataggio della distinta. A differenza dell'evento "DistSaveEvent", questo scatta per ogni item della distinta.
Evento pubblico | DistReplaceSaveEvent | Evento di salvataggio durante la sostituzione massiva.
Evento pubblico | DistSaveEvent | Evento di salvataggio della distinta.
Evento pubblico | DocStructInfoCreatedEvent | Evento creazione nuovo DocStructInfo
Evento pubblico | DocumentAnnullaCheckedOutEvent | Evento chiamato dopo il checkout su di un documento
Evento pubblico | DocumentCheckedInEvent | Evento chiamato prima del checkin di un elemento
Evento pubblico | DocumentCheckedOutEvent | Evento chiamato dopo il checkout su di un documento
Evento pubblico | DocumentCheckLockedEvent | Evento chiamato in fase di scaricamento in locale del documento per controllare se è locked.
Evento pubblico | DocumentCreatingEvent | Evento lanciato in fase di creazione documento, che permette di personalizzare il guid di versione documento da scrivere nel record ed anche i dati del documento.
Evento pubblico | DocumentDisableEvent | Evento lanciato in fase visualizzazione del documento nel controllo documentale.
Evento pubblico | DocumentDisconnectingEvent | Evento chiamato in fase di disconnesione documento dall'anagrafica. Permette ai client di impostare i dati del comando.
Evento pubblico | DocumentDownloadedEvent | Evento chiamato dopo che un documento è stato scaricato in locale da una operazione di ensurelocal
Evento pubblico | DocumentDragDropEvent | Evento lanciato prima della partenza del drag da controllo documentale. Permette di impedirne la continuazione.
Evento pubblico | DocumentEnsureLocalOperationEvent | Evento chiamato durante l'operation dell'esurelocal su di un documento
Evento pubblico | DocumentImportedEvent | Evento chiamato dopo l'importazione di un documento sull'anagrafica
Evento pubblico | DocumentImportingEvent | Evento chiamato in fase di importazione documento che permette di modificare la struttura sottostante al documento prima dell'esecuzione vera e propria dell'operazione. Viene chiamato anche immediatamente dopo l'esecuzione.
Evento pubblico | DocumentLinkingEvent | Evento chiamato in fase di collegamento documento all'anagrafica. Permette ai client di impostare i dati del comando.
Evento pubblico | DocumentMovingEvent | Evento chiamato in fase di move command sui documenti principali. Permette ai client di impostare i dati di clonazione nella sotto struttura.
Evento pubblico | DocumentPublishEvent | Evento chiamato prima della pubblicazione di un elemento
Evento pubblico | DocumentRecognizingEvent | Evento chiamato in fase di riconoscimento documento che permette di modificare la struttura sottostante al documento prima dell'esecuzione vera e propria dell'operazione. Viene chiamato anche immediatamente dopo l'esecuzione.
Evento pubblico | DocumentSbloccaEvent | Evento chiamato dopo lo sblocca su di un documento
Evento pubblico | DocumentUpdatingEvent | Evento lanciato in fase di aggiornamento documento, che permette di personalizzare il guid di versione documento da scrivere nel record.
Evento pubblico | DragDropEvent |
Evento pubblico | EditAttrEvent | Evento chiamato prima di entrare in editazione dell'anagrafica e dopo aver confermato l'editazione.
Evento pubblico | EditAttrValidatingEvent | Evento chiamato prima di entrare in editazione dell'anagrafica e dopo aver confermato l'editazione.
Evento pubblico | EditCommChangedEvent | Evento su modifica della commessa o di uno dei valori durante la procedura di modifica commessa.
Evento pubblico | EditCommEvent | Evento lanciato prima e domo la modifica di una commessa.
Evento pubblico | ElaborateDedListEvent | Evento che permette di gestire gli elementi in lista
Evento pubblico | EsclAttrUpdFromDBTabEvent | Evento lanciato quando viene usata la lista SkipAttribListEvent.
Evento pubblico | EvaluateNewValueEvent | Evento chiamato quando l'utente digita un codice non presente nel Database nella finestra di ricerca veloce, e che quindi può essere corretto da chi gestisce l'evento.
Evento pubblico | ExportDataEvent | Evento chiamato per la gestione dell'esportazione.
Evento pubblico | ExportPackAndGoConfirmEvent |
Evento pubblico | ExportResultBomCompareEvent | Evento che permette di bloccare l'esportazione su excel del risultato del confronto tra distinte e di gestirlo
Evento pubblico | FamDescrOverrideEvent | Evento chiamato per poter ridefinire la descrizione della famiglia ( inserire una lista a tendina ).
Evento pubblico | FillAttributeListFilterEvent | Evento che permette il filtraggio degli attributi in fase di inserimento delle liste utilizzate nell'applicazione
Evento pubblico | FilterSearchResultEvent | Evento chiamato quando l'utente seleziona un filtro sul risultato ricerca.
Evento pubblico | FindCodeMultipleAnagrEvent | Evento chiamato nell'apri veloce nel caso di ricerca su invio con risultato mulitplo.
Evento pubblico | FindCodeStateFilterEvent | Evento che permette di filtrare la lista del form find code in base allo stato dell'anagrafica
Evento pubblico | FolderDisableEvent | Evento lanciato in fase di visualizzazione della cartella nel controllo documentale.
Evento pubblico | FtpClientConnectionEvent | Evento che permette modificare i dati del client FTP.
Evento pubblico | GetDocPropertiesEvent | Evento che permette di ricavare la lista di proprietà di una serie di file.
Evento pubblico | GetRepresentationSuffixListEvent | Evento che permette di visualizzare una lista di suffissi in creazione di una Rappresentazione.
Evento pubblico | ImportAttListEvent | Evento che permette di importare la lista att di un attributo da una fonte dati esterna.
Evento pubblico | ImportAttrValueEvent | Evento che permette di importare il valore di un attributo da una fonte dati esterna.
Evento pubblico | ImportDataCanUpdateEvent | Evento che permette di gestire l'anagrafica da aggiornare nel comando Importa Dati.
Evento pubblico | ImportOnSaveEvent | Evento per gestire l'azione da attuare in fase di salvataggio dei documenti che sono all'interno delle root definite in ROOTS_RECOGNIZED_ON_DBSAVE.
Evento pubblico | ImportPackAndGoSelectEvent |
Evento pubblico | ListImportDataEvent | Evento di validazione di un codice durante l'importazione in una lista
Evento pubblico | LoadFormCommEditEvent | Evento lanciato al caricamento del form delle commesse.
Evento pubblico | ManagePlaceHolderLogicComputedEvent | Evento chiamato per permettere l'override della logica di gestione dei placeholder in base a criteri utente
Evento pubblico | ManageSelectionDocsEvent | Evento che permette di gestire la selezione dei documenti.
Evento pubblico | ModifyDocumentBeforeCheckedInEvent | Evento chiamato per i tecnici in modo che possano modificare il documento prima che il ded faccia tutto nel DocumentCheckedInEvent
Evento pubblico | MoveDocumentEvent | Evento chiamato per effettuare lo spostamento/rinomina di un file. Chi gestisce questo evento si deve preoccupare di spostare sia la copia in locale che quella del server, nel caso di area locale attiva.
Evento pubblico | MsgDistReplaceSaveEvent | Evento che permette di visualizzare un messaggio prima e/o dopo la sostituzione massiva.
Evento pubblico | MultipleStateChangeExecute | Evento che permette di verificare la lista delle anagrafiche selezionate durante le operazioni di Rilascio/Lavorazione multiplo
Evento pubblico | NewAnagrChangedEvent | Evento su modifica dell'anagrafica o di uno dei valori che influenzano la codifica durante la procedura di creazione nuova anagrafica.
Evento pubblico | NewAnagrCreatedEvent | Evento chiamato subito dopo aver creato l'anagrafica nel comando di creazione nuovo record.
Evento pubblico | NewAnagrInitEvent | Evento di inizializzazione dei comandi di creazione nuovo record. Questo evento viene chiamato all'inizio del comando per impostarne le proprietà secondo l'esigenza di personalizzazione.
Evento pubblico | NewAnagrValidatingEvent | Evento di validazione chiamato subito prima la creazione di una nuova anagrafica.
Evento pubblico | NewCommChangedEvent | Evento su modifica della commessa o di uno dei valori durante la procedura di creazione nuova commessa.
Evento pubblico | NoteTransferPackEvent | Evento che permette di inserire una Nota nel trasfer pack con gestione della visualizzazione della finestra di inserimento Note
Evento pubblico | NotifyEvent | Evento lanciato per poter modificare le informazioni della notifica e eventualmente cancellarla.
Evento pubblico | OpenCommandDisableDocumentEvent | Evento lanciato in fase di apertura dei documenti.
Evento pubblico | OpenDocumentEvent | Evento di apertura documento. Viene chiamato per intercettare l'apertura di un documento per consentire di sostituirsi all'apertura.
Evento pubblico | OrderPriorityListEvent | Evento per ordinare la lista delle estensioni prioritarie dai vari CAD.
Evento pubblico | OverrideAttListEvent | Evento chiamato per la personalizzazione dell'elenco valori associata ad un determinato attributo.
Evento pubblico | OverrideAttrEvent | Evento chiamato prima di visualizzare il controllo degli aattributi.
Evento pubblico | OverrideCommandEnablingEvent | Evento usato dagli add-in per effettuare l'override dell'abilitazione dei comandi del Core.
Evento pubblico | OverrideEnableSaveCommControlEvent | Evento da utilizzare per ridefinire l'abilitazione dei controlli nel form di salvataggio commessa
Evento pubblico | OverrideEnableSaveControlEvent | Evento da utilizzare per ridefinire l'abilitazione dei controlli nel form di salvataggio
Evento pubblico | OverwriteImportPlaceHolderEvent | Evento chiamato per permettere l'ultima ridefinizione del placehodre (parte su tutti i file)
Evento pubblico | PostInitEvent | Evento chiamato alla fine dell'inizializzazione dell'applicazione.
Evento pubblico | ProgrCollisionEvent | Evento lanciato quando si verifica una collisione di progressivi al salvataggio nel DB su una famiglia con infouser.
Evento pubblico | RecognizerPathDefinedEvent | Evento per la specializzazione della filelist dal path definito nel form di registrazione dei documenti
Evento pubblico | RedrawAnagrEvent | Evento chiamato prima di disegnare le varie celle della ricerca.
Evento pubblico | RedrawAttrEvent | Evento chiamato prima di disegnare le varie celle degli attributi.
Evento pubblico | RedrawCommEvent | Evento chiamato prima di disegnare le varie celle delle commesse.
Evento pubblico | RedrawDedTypeEvent | Evento chiamato prima di disegnare le varie celle delle famiglie.
Evento pubblico | RedrawDepEvent | Evento chiamato prima di disegnare le varie celle nell'albero delle dipendeze.
Evento pubblico | RedrawDistEvent | Evento chiamato prima di disegnare le varie celle delle distinte.
Evento pubblico | ReferenceUpdateOperationEvent | Evento che permette ai CAD e ai plugin di registrarsi ai delegate del comando UpdateDocumentReference.
Evento pubblico | RemoveAnagrEvent | Evento chiamato nell'eliminazione di un'anagrafica.
Evento pubblico | RemoveDocumentEvent | Evento chiamato quando l'utente elimina un documento.
Evento pubblico | ResetSearchCriteriaEvent | Evento chiamato quanto l'utente preme il tasto di reset dei criteri della ricerca
Evento pubblico | SaveCustomButtonClickEvent | Evento chiamato alla pressione dei pulsanti personalizzati della finestra di salva.
Evento pubblico | SaveDistOnApprovedEvent | Evento che permette di decidere il comportamento sul salvataggio distinta al rilascio
Evento pubblico | SendToCommandDisableDocumentEvent | Evento lanciato in fase di invio dei documenti.
Evento pubblico | SetDefaultFindCodeFilterEvent | Evento che permette di definire l'attributo di ricerca utilizzato nel DedFindCodeControl.
Evento pubblico | ShowPreviewEvent | Evento chiamato per la visualizzazione del preview.
Evento pubblico | ShowReplaceAnagrDistFormEvent | Evento chiamato al caricamento della finestra di sostituzione anagrafica in distinte.
Evento pubblico | ShowSaveFormEvent | Evento chiamato al caricamento della finestra di salva.
Evento pubblico | ShowZoomPreviewEvent | Evento chiamato per la visualizzazione del preview ( zoom ).
Evento pubblico | SkipDocumentStatusOnSaveDistEvent | Evento lanciato per fare determinare dai client se un documento debba essere skippato in fase di controllo dello stato nel salva distinta
Evento pubblico | SkipUpdateAttribListEvent |
Evento pubblico | StateChangedEvent | Evento chiamato al cambio di stato di un'anagrafica.
Evento pubblico | StateCommandDocCloseEvent | Evento di chiusura dopo elaborazione documento.
Evento pubblico | StateCommandDocOpenEvent | Evento di apertura per elaborazione documento.
Evento pubblico | StateCommandDocPublishEraseEvent | Evento di cancellazione documenti pubblicazione.
Evento pubblico | StateCommandDocPublishEvent | Evento di pubblicazione documento.
Evento pubblico | StateCommandDocsPublishedEvent | Evento di post pubblicazione di tutti i documenti dell'anagrafica rilasciata
Evento pubblico | StateCommandEventEvent | Evento generato dal comando di modifica stato anagrafica.
Evento pubblico | StateCommmandDocWriteEvent | Evento di scrittura documento prima della pubblicazione
Evento pubblico | StateElaboratingDocumentsEvent | Evento generato prima della elaborazione dei documenti in modifica stato anagrafica
Evento pubblico | TypeAddedEvent | Evento chiamato quando viene aggiunta una famiglia tramite il QsManager ( crea/incolla )
Evento pubblico | TypesReloadedEvent | Evento chiamato quando vengono ricaricate le famiglie dei tipi e tutta la struttura degli oggetti.
Evento pubblico | UnRilErasePublishEvent | Evento che permette la personalizzazione e l'override delle opzioni di eliminazione dei documenti di pubblicazione in cambio stato
Evento pubblico | UpgradeAnagrCommEvent | Evento sull'aggiornamento delle anagrafiche in commessa
Evento pubblico | ValidateCheckFunctionEvent | Evento chiamato quando vengono validati gli attributi che hanno una funzione di controllo.
Evento pubblico | ValidateCommPropertyEvent | Evento chiamato quando vengono validati gli attributi della commessa.
Evento pubblico | ValidateFamPropertyEvent | Evento chiamato quando vengono validati gli attributi della famiglia.
Torna su
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.AddDataDocEvent

Evento DedNetApplicationAddDataDocEvent
Evento chiamato dopo l'associazione del documento all'anagrafica (linking)

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<AddDataDocEventArgs> AddDataDocEvent
Public Event AddDataDocEvent As EventHandler(Of AddDataDocEventArgs)
public:
 event EventHandler<AddDataDocEventArgs^>^ AddDataDocEvent {
    void add (EventHandler<AddDataDocEventArgs^>^ value);
    void remove (EventHandler<AddDataDocEventArgs^>^ value);
}
member AddDataDocEvent : IEvent<EventHandler<AddDataDocEventArgs>,
    AddDataDocEventArgs>

Valore

EventHandler AddDataDocEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.AddExtensionsRecognizerFormEvent

Evento DedNetApplicationAddExtensionsRecognizerFormEvent
Evento per poter modificare la lista delle estensioni aggiuntivi nel form di riconoscimento dei file (DedFormFileRecognizer)

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<AddExtensionsRecognizerEventArgs> AddExtensionsRecognizerFormEvent
Public Event AddExtensionsRecognizerFormEvent As EventHandler(Of AddExtensionsRecognizerEventArgs)
public:
 event EventHandler<AddExtensionsRecognizerEventArgs^>^ AddExtensionsRecognizerFormEvent {
    void add (EventHandler<AddExtensionsRecognizerEventArgs^>^ value);
    void remove (EventHandler<AddExtensionsRecognizerEventArgs^>^ value);
}
member AddExtensionsRecognizerFormEvent : IEvent<EventHandler<AddExtensionsRecognizerEventArgs>,
    AddExtensionsRecognizerEventArgs>

Valore

EventHandler AddExtensionsRecognizerEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.AfterEraseEmptyPwsFolderEvent

Evento DedNetApplicationAfterEraseEmptyPwsFolderEvent
Evento chiamato alla fine della cancellazione delle cartelle vuote della pws.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler AfterEraseEmptyPwsFolderEvent
Public Event AfterEraseEmptyPwsFolderEvent As EventHandler
public:
 event EventHandler^ AfterEraseEmptyPwsFolderEvent {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member AfterEraseEmptyPwsFolderEvent : IEvent<EventHandler,
    EventArgs>

Valore

EventHandler
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.AfterSaveDedCommTypeEvent

Evento DedNetApplicationAfterSaveDedCommTypeEvent
Evento chiamato nel post salvataggio.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<AfterSaveEventArgs> AfterSaveDedCommTypeEvent
Public Event AfterSaveDedCommTypeEvent As EventHandler(Of AfterSaveEventArgs)
public:
 event EventHandler<AfterSaveEventArgs^>^ AfterSaveDedCommTypeEvent {
    void add (EventHandler<AfterSaveEventArgs^>^ value);
    void remove (EventHandler<AfterSaveEventArgs^>^ value);
}
member AfterSaveDedCommTypeEvent : IEvent<EventHandler<AfterSaveEventArgs>,
    AfterSaveEventArgs>

Valore

EventHandler AfterSaveEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.AfterSaveDedTypeEvent

Evento DedNetApplicationAfterSaveDedTypeEvent
Evento chiamato nel post salvataggio.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<AfterSaveEventArgs> AfterSaveDedTypeEvent
Public Event AfterSaveDedTypeEvent As EventHandler(Of AfterSaveEventArgs)
public:
 event EventHandler<AfterSaveEventArgs^>^ AfterSaveDedTypeEvent {
    void add (EventHandler<AfterSaveEventArgs^>^ value);
    void remove (EventHandler<AfterSaveEventArgs^>^ value);
}
member AfterSaveDedTypeEvent : IEvent<EventHandler<AfterSaveEventArgs>,
    AfterSaveEventArgs>

Valore

EventHandler AfterSaveEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.AnagrSelectionDeletedEvent

Evento DedNetApplicationAnagrSelectionDeletedEvent
Evento chiamato al termine dell'eliminazione della selezione di anagrafiche

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<AnagrSelectionDeletedEventArgs> AnagrSelectionDeletedEvent
Public Event AnagrSelectionDeletedEvent As EventHandler(Of AnagrSelectionDeletedEventArgs)
public:
 event EventHandler<AnagrSelectionDeletedEventArgs^>^ AnagrSelectionDeletedEvent {
    void add (EventHandler<AnagrSelectionDeletedEventArgs^>^ value);
    void remove (EventHandler<AnagrSelectionDeletedEventArgs^>^ value);
}
member AnagrSelectionDeletedEvent : IEvent<EventHandler<AnagrSelectionDeletedEventArgs>,
    AnagrSelectionDeletedEventArgs>

Valore

EventHandler AnagrSelectionDeletedEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.AttributeChanged

Evento DedNetApplicationAttributeChanged
Evento chiamato alla modifica di un attributo nell'edita attributi.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<EventArgs> AttributeChanged
Public Event AttributeChanged As EventHandler(Of EventArgs)
public:
 event EventHandler<EventArgs^>^ AttributeChanged {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}
member AttributeChanged : IEvent<EventHandler<EventArgs>,
    EventArgs>

Valore

EventHandler EventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.AttributeInit

Evento DedNetApplicationAttributeInit
Evento chiamato all'inizializzazionr del controllo degli attributi.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<EventArgs> AttributeInit
Public Event AttributeInit As EventHandler(Of EventArgs)
public:
 event EventHandler<EventArgs^>^ AttributeInit {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}
member AttributeInit : IEvent<EventHandler<EventArgs>,
    EventArgs>

Valore

EventHandler EventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.BeforeShowZoomPreviewEvent

Evento DedNetApplicationBeforeShowZoomPreviewEvent
Evento che scatta prima che venga caricato il QsTopDwgViewer. Permette di definire con che profilo eseguire il QsTopDwgViewer (di default viene eseguito il profilo 'Simple').

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<QSTopDwgViewerProfile> BeforeShowZoomPreviewEvent
Public Event BeforeShowZoomPreviewEvent As EventHandler(Of QSTopDwgViewerProfile)
public:
 event EventHandler<QSTopDwgViewerProfile^>^ BeforeShowZoomPreviewEvent {
    void add (EventHandler<QSTopDwgViewerProfile^>^ value);
    void remove (EventHandler<QSTopDwgViewerProfile^>^ value);
}
member BeforeShowZoomPreviewEvent : IEvent<EventHandler<QSTopDwgViewerProfile>,
    QSTopDwgViewerProfile>

Valore

EventHandler QSTopDwgViewerProfile
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.BomEditFormButtonClickEvent

Evento DedNetApplicationBomEditFormButtonClickEvent
Evento chiamato alla pressione dei pulsanti personalizzati delle barre del form editor delle distinte

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DedBomEditCustomControlEventArgs> BomEditFormButtonClickEvent
Public Event BomEditFormButtonClickEvent As EventHandler(Of DedBomEditCustomControlEventArgs)
public:
 event EventHandler<DedBomEditCustomControlEventArgs^>^ BomEditFormButtonClickEvent {
    void add (EventHandler<DedBomEditCustomControlEventArgs^>^ value);
    void remove (EventHandler<DedBomEditCustomControlEventArgs^>^ value);
}
member BomEditFormButtonClickEvent : IEvent<EventHandler<DedBomEditCustomControlEventArgs>,
    DedBomEditCustomControlEventArgs>

Valore

EventHandler DedBomEditCustomControlEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.BomEditFormToggleSwitchEvent

Evento DedNetApplicationBomEditFormToggleSwitchEvent
Evento chiamato al cambio stato dei toggle personalizzati delle barre del form editor delle distinte

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DedBomEditCustomControlEventArgs> BomEditFormToggleSwitchEvent
Public Event BomEditFormToggleSwitchEvent As EventHandler(Of DedBomEditCustomControlEventArgs)
public:
 event EventHandler<DedBomEditCustomControlEventArgs^>^ BomEditFormToggleSwitchEvent {
    void add (EventHandler<DedBomEditCustomControlEventArgs^>^ value);
    void remove (EventHandler<DedBomEditCustomControlEventArgs^>^ value);
}
member BomEditFormToggleSwitchEvent : IEvent<EventHandler<DedBomEditCustomControlEventArgs>,
    DedBomEditCustomControlEventArgs>

Valore

EventHandler DedBomEditCustomControlEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.BomExplorerAddReplaceDataEvent

Evento DedNetApplicationBomExplorerAddReplaceDataEvent
Evento chiamato in fase di aggiunta o sostituzione codice dal controllo dedicato nel panello interno all'explorer control.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<BomExplorerAddReplaceDataEventArgs> BomExplorerAddReplaceDataEvent
Public Event BomExplorerAddReplaceDataEvent As EventHandler(Of BomExplorerAddReplaceDataEventArgs)
public:
 event EventHandler<BomExplorerAddReplaceDataEventArgs^>^ BomExplorerAddReplaceDataEvent {
    void add (EventHandler<BomExplorerAddReplaceDataEventArgs^>^ value);
    void remove (EventHandler<BomExplorerAddReplaceDataEventArgs^>^ value);
}
member BomExplorerAddReplaceDataEvent : IEvent<EventHandler<BomExplorerAddReplaceDataEventArgs>,
    BomExplorerAddReplaceDataEventArgs>

Valore

EventHandler BomExplorerAddReplaceDataEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.BomExplorerButtonClickEvent

Evento DedNetApplicationBomExplorerButtonClickEvent
Evento chiamato alla pressione dei pulsanti personalizzati della finestra dell'editor delle distinte.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<BomExplorerButtonClickEventArgs> BomExplorerButtonClickEvent
Public Event BomExplorerButtonClickEvent As EventHandler(Of BomExplorerButtonClickEventArgs)
public:
 event EventHandler<BomExplorerButtonClickEventArgs^>^ BomExplorerButtonClickEvent {
    void add (EventHandler<BomExplorerButtonClickEventArgs^>^ value);
    void remove (EventHandler<BomExplorerButtonClickEventArgs^>^ value);
}
member BomExplorerButtonClickEvent : IEvent<EventHandler<BomExplorerButtonClickEventArgs>,
    BomExplorerButtonClickEventArgs>

Valore

EventHandler BomExplorerButtonClickEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.BomExplorerContextMenuOpeningEvent

Evento DedNetApplicationBomExplorerContextMenuOpeningEvent
Evento chiamato in fase di apertura del context menu sul controllo distinta interno al bom explorer. Permette di aggiungere comandi.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<BomExplorerContextMenuOpeningEventArgs> BomExplorerContextMenuOpeningEvent
Public Event BomExplorerContextMenuOpeningEvent As EventHandler(Of BomExplorerContextMenuOpeningEventArgs)
public:
 event EventHandler<BomExplorerContextMenuOpeningEventArgs^>^ BomExplorerContextMenuOpeningEvent {
    void add (EventHandler<BomExplorerContextMenuOpeningEventArgs^>^ value);
    void remove (EventHandler<BomExplorerContextMenuOpeningEventArgs^>^ value);
}
member BomExplorerContextMenuOpeningEvent : IEvent<EventHandler<BomExplorerContextMenuOpeningEventArgs>,
    BomExplorerContextMenuOpeningEventArgs>

Valore

EventHandler BomExplorerContextMenuOpeningEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.BomExplorerLoadDistEvent

Evento DedNetApplicationBomExplorerLoadDistEvent
Evento chiamato al caricamento di una distinta nel controllo explorer dell'editor delle distinte.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<BomExplorerLoadDistEventArgs> BomExplorerLoadDistEvent
Public Event BomExplorerLoadDistEvent As EventHandler(Of BomExplorerLoadDistEventArgs)
public:
 event EventHandler<BomExplorerLoadDistEventArgs^>^ BomExplorerLoadDistEvent {
    void add (EventHandler<BomExplorerLoadDistEventArgs^>^ value);
    void remove (EventHandler<BomExplorerLoadDistEventArgs^>^ value);
}
member BomExplorerLoadDistEvent : IEvent<EventHandler<BomExplorerLoadDistEventArgs>,
    BomExplorerLoadDistEventArgs>

Valore

EventHandler BomExplorerLoadDistEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.ChangeStateECOEvent

Evento DedNetApplicationChangeStateECOEvent
Evento lanciato prima e dopo il cambio di stato di un ECO.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DedECOChangeStateCommandEventArgs> ChangeStateECOEvent
Public Event ChangeStateECOEvent As EventHandler(Of DedECOChangeStateCommandEventArgs)
public:
 event EventHandler<DedECOChangeStateCommandEventArgs^>^ ChangeStateECOEvent {
    void add (EventHandler<DedECOChangeStateCommandEventArgs^>^ value);
    void remove (EventHandler<DedECOChangeStateCommandEventArgs^>^ value);
}
member ChangeStateECOEvent : IEvent<EventHandler<DedECOChangeStateCommandEventArgs>,
    DedECOChangeStateCommandEventArgs>

Valore

EventHandler DedECOChangeStateCommandEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.ChangingDependencyDocumentEvent

Evento DedNetApplicationChangingDependencyDocumentEvent
Evento chiamato quando si debba effettuare la sostituzione fisica di un riferimento in un file. Se attiva l'area locale, l'aggiornamento deve avvenire sia nel file presente nel vault che nella pws.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<ChangingDependencyDocumentEventArgs> ChangingDependencyDocumentEvent
Public Event ChangingDependencyDocumentEvent As EventHandler(Of ChangingDependencyDocumentEventArgs)
public:
 event EventHandler<ChangingDependencyDocumentEventArgs^>^ ChangingDependencyDocumentEvent {
    void add (EventHandler<ChangingDependencyDocumentEventArgs^>^ value);
    void remove (EventHandler<ChangingDependencyDocumentEventArgs^>^ value);
}
member ChangingDependencyDocumentEvent : IEvent<EventHandler<ChangingDependencyDocumentEventArgs>,
    ChangingDependencyDocumentEventArgs>

Valore

EventHandler ChangingDependencyDocumentEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.CheckProgrReservedEvent

Evento DedNetApplicationCheckProgrReservedEvent
Evento lanciato quando si verifica una collisione di progressivi al salvataggio nel DB su una famiglia con infouser.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<CheckProgrReservedEventArgs> CheckProgrReservedEvent
Public Event CheckProgrReservedEvent As EventHandler(Of CheckProgrReservedEventArgs)
public:
 event EventHandler<CheckProgrReservedEventArgs^>^ CheckProgrReservedEvent {
    void add (EventHandler<CheckProgrReservedEventArgs^>^ value);
    void remove (EventHandler<CheckProgrReservedEventArgs^>^ value);
}
member CheckProgrReservedEvent : IEvent<EventHandler<CheckProgrReservedEventArgs>,
    CheckProgrReservedEventArgs>

Valore

EventHandler CheckProgrReservedEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.CheckRevAlphabetEvent

Evento DedNetApplicationCheckRevAlphabetEvent
Evento lanciato quando si verifica una i caratteri dell'alfabeto.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<CheckRevAlphabetEventArgs> CheckRevAlphabetEvent
Public Event CheckRevAlphabetEvent As EventHandler(Of CheckRevAlphabetEventArgs)
public:
 event EventHandler<CheckRevAlphabetEventArgs^>^ CheckRevAlphabetEvent {
    void add (EventHandler<CheckRevAlphabetEventArgs^>^ value);
    void remove (EventHandler<CheckRevAlphabetEventArgs^>^ value);
}
member CheckRevAlphabetEvent : IEvent<EventHandler<CheckRevAlphabetEventArgs>,
    CheckRevAlphabetEventArgs>

Valore

EventHandler CheckRevAlphabetEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.ClassListItemClickEvent

Evento DedNetApplicationClassListItemClickEvent
Evento chiamato quando l'utente clicca su un elemento del class list.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<ClassListItemClickEventArgs> ClassListItemClickEvent
Public Event ClassListItemClickEvent As EventHandler(Of ClassListItemClickEventArgs)
public:
 event EventHandler<ClassListItemClickEventArgs^>^ ClassListItemClickEvent {
    void add (EventHandler<ClassListItemClickEventArgs^>^ value);
    void remove (EventHandler<ClassListItemClickEventArgs^>^ value);
}
member ClassListItemClickEvent : IEvent<EventHandler<ClassListItemClickEventArgs>,
    ClassListItemClickEventArgs>

Valore

EventHandler ClassListItemClickEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.CommAddAnagItemEvent

Evento DedNetApplicationCommAddAnagItemEvent
Evento sull'aggiunta di un elemento di anagrafica sulla commessa

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<CommAnagEventArgs> CommAddAnagItemEvent
Public Event CommAddAnagItemEvent As EventHandler(Of CommAnagEventArgs)
public:
 event EventHandler<CommAnagEventArgs^>^ CommAddAnagItemEvent {
    void add (EventHandler<CommAnagEventArgs^>^ value);
    void remove (EventHandler<CommAnagEventArgs^>^ value);
}
member CommAddAnagItemEvent : IEvent<EventHandler<CommAnagEventArgs>,
    CommAnagEventArgs>

Valore

EventHandler CommAnagEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.CommandExecutingEvent

Evento DedNetApplicationCommandExecutingEvent
Evento di esecuzione comando. Questo evento viene chiamato all'inizio ed alla fine dell'esecuzione del comando.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DedCommandEventArgs> CommandExecutingEvent
Public Event CommandExecutingEvent As EventHandler(Of DedCommandEventArgs)
public:
 event EventHandler<DedCommandEventArgs^>^ CommandExecutingEvent {
    void add (EventHandler<DedCommandEventArgs^>^ value);
    void remove (EventHandler<DedCommandEventArgs^>^ value);
}
member CommandExecutingEvent : IEvent<EventHandler<DedCommandEventArgs>,
    DedCommandEventArgs>

Valore

EventHandler DedCommandEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.CommCancelEvent

Evento DedNetApplicationCommCancelEvent
Evento di cancellazione creazione/modifica commessa.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DedCommCancelEventArgs> CommCancelEvent
Public Event CommCancelEvent As EventHandler(Of DedCommCancelEventArgs)
public:
 event EventHandler<DedCommCancelEventArgs^>^ CommCancelEvent {
    void add (EventHandler<DedCommCancelEventArgs^>^ value);
    void remove (EventHandler<DedCommCancelEventArgs^>^ value);
}
member CommCancelEvent : IEvent<EventHandler<DedCommCancelEventArgs>,
    DedCommCancelEventArgs>

Valore

EventHandler DedCommCancelEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.CommDescrOverrideEvent

Evento DedNetApplicationCommDescrOverrideEvent
Evento chiamato per poter ridefinire la descrizione della commessa ( inserire una lista a tendina ).

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<CommDescrOverrideEventArgs> CommDescrOverrideEvent
Public Event CommDescrOverrideEvent As EventHandler(Of CommDescrOverrideEventArgs)
public:
 event EventHandler<CommDescrOverrideEventArgs^>^ CommDescrOverrideEvent {
    void add (EventHandler<CommDescrOverrideEventArgs^>^ value);
    void remove (EventHandler<CommDescrOverrideEventArgs^>^ value);
}
member CommDescrOverrideEvent : IEvent<EventHandler<CommDescrOverrideEventArgs>,
    CommDescrOverrideEventArgs>

Valore

EventHandler CommDescrOverrideEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.CommElementCreateDataEvent

Evento DedNetApplicationCommElementCreateDataEvent
Evento sulla creazione dell'anagrafica chiamato sia prima che dopo la creazione di una anagrafica a partire da un nuovo elemento di distinta da aggiungere. Questo è l'evento ad alto livello che agisce a livello di comando, vedere anche l'evento DistItemCreateData..

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<CommElementCreateDataEventArgs> CommElementCreateDataEvent
Public Event CommElementCreateDataEvent As EventHandler(Of CommElementCreateDataEventArgs)
public:
 event EventHandler<CommElementCreateDataEventArgs^>^ CommElementCreateDataEvent {
    void add (EventHandler<CommElementCreateDataEventArgs^>^ value);
    void remove (EventHandler<CommElementCreateDataEventArgs^>^ value);
}
member CommElementCreateDataEvent : IEvent<EventHandler<CommElementCreateDataEventArgs>,
    CommElementCreateDataEventArgs>

Valore

EventHandler CommElementCreateDataEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.CommFileExplorerUpdateEvent

Evento DedNetApplicationCommFileExplorerUpdateEvent
Evento per calcolare il percorso da visualizzare nell'Esplora Risorse delle commesse.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<CommFileExplorerUpdateEventArgs> CommFileExplorerUpdateEvent
Public Event CommFileExplorerUpdateEvent As EventHandler(Of CommFileExplorerUpdateEventArgs)
public:
 event EventHandler<CommFileExplorerUpdateEventArgs^>^ CommFileExplorerUpdateEvent {
    void add (EventHandler<CommFileExplorerUpdateEventArgs^>^ value);
    void remove (EventHandler<CommFileExplorerUpdateEventArgs^>^ value);
}
member CommFileExplorerUpdateEvent : IEvent<EventHandler<CommFileExplorerUpdateEventArgs>,
    CommFileExplorerUpdateEventArgs>

Valore

EventHandler CommFileExplorerUpdateEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.CopyDocumentEvent

Evento DedNetApplicationCopyDocumentEvent
Evento chiamato per effettuare la copia di un file. Chi gestisce questo evento si deve preoccupare di copiare sia la versione in locale che quella del server, nel caso di area locale attiva.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<CopyDocumentEventArgs> CopyDocumentEvent
Public Event CopyDocumentEvent As EventHandler(Of CopyDocumentEventArgs)
public:
 event EventHandler<CopyDocumentEventArgs^>^ CopyDocumentEvent {
    void add (EventHandler<CopyDocumentEventArgs^>^ value);
    void remove (EventHandler<CopyDocumentEventArgs^>^ value);
}
member CopyDocumentEvent : IEvent<EventHandler<CopyDocumentEventArgs>,
    CopyDocumentEventArgs>

Valore

EventHandler CopyDocumentEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.CreateCommEvent

Evento DedNetApplicationCreateCommEvent
Evento lanciato prima e dopo la creazione di una commessa.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DedCommCommandEventArgs> CreateCommEvent
Public Event CreateCommEvent As EventHandler(Of DedCommCommandEventArgs)
public:
 event EventHandler<DedCommCommandEventArgs^>^ CreateCommEvent {
    void add (EventHandler<DedCommCommandEventArgs^>^ value);
    void remove (EventHandler<DedCommCommandEventArgs^>^ value);
}
member CreateCommEvent : IEvent<EventHandler<DedCommCommandEventArgs>,
    DedCommCommandEventArgs>

Valore

EventHandler DedCommCommandEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.CreateECOEvent

Evento DedNetApplicationCreateECOEvent
Evento lanciato prima e dopo la creazione di un ECO.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DedECOCommandEventArgs> CreateECOEvent
Public Event CreateECOEvent As EventHandler(Of DedECOCommandEventArgs)
public:
 event EventHandler<DedECOCommandEventArgs^>^ CreateECOEvent {
    void add (EventHandler<DedECOCommandEventArgs^>^ value);
    void remove (EventHandler<DedECOCommandEventArgs^>^ value);
}
member CreateECOEvent : IEvent<EventHandler<DedECOCommandEventArgs>,
    DedECOCommandEventArgs>

Valore

EventHandler DedECOCommandEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.CreateMultiLevelBomEvent

Evento DedNetApplicationCreateMultiLevelBomEvent
Evento che permette di editare la distinta ricambi multilivello

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<CreateMultiLevelBomEventArgs> CreateMultiLevelBomEvent
Public Event CreateMultiLevelBomEvent As EventHandler(Of CreateMultiLevelBomEventArgs)
public:
 event EventHandler<CreateMultiLevelBomEventArgs^>^ CreateMultiLevelBomEvent {
    void add (EventHandler<CreateMultiLevelBomEventArgs^>^ value);
    void remove (EventHandler<CreateMultiLevelBomEventArgs^>^ value);
}
member CreateMultiLevelBomEvent : IEvent<EventHandler<CreateMultiLevelBomEventArgs>,
    CreateMultiLevelBomEventArgs>

Valore

EventHandler CreateMultiLevelBomEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.CreatingSparePartDrawing

Evento DedNetApplicationCreatingSparePartDrawing
Evento chiamato quando viene eseguito il comando 'Crea tavola ricambi'.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<CreatingSparePartDrawingEventArgs> CreatingSparePartDrawing
Public Event CreatingSparePartDrawing As EventHandler(Of CreatingSparePartDrawingEventArgs)
public:
 event EventHandler<CreatingSparePartDrawingEventArgs^>^ CreatingSparePartDrawing {
    void add (EventHandler<CreatingSparePartDrawingEventArgs^>^ value);
    void remove (EventHandler<CreatingSparePartDrawingEventArgs^>^ value);
}
member CreatingSparePartDrawing : IEvent<EventHandler<CreatingSparePartDrawingEventArgs>,
    CreatingSparePartDrawingEventArgs>

Valore

EventHandler CreatingSparePartDrawingEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.DedBomEditLoaded

Evento DedNetApplicationDedBomEditLoaded
Evento chiamato durante il load del form DedBomEdit.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<EventArgs> DedBomEditLoaded
Public Event DedBomEditLoaded As EventHandler(Of EventArgs)
public:
 event EventHandler<EventArgs^>^ DedBomEditLoaded {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}
member DedBomEditLoaded : IEvent<EventHandler<EventArgs>,
    EventArgs>

Valore

EventHandler EventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.DedDataChangedEvent

Evento DedNetApplicationDedDataChangedEvent
Evento chiamato quando viene aggiunto un record in DedData.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DedDataChangedEventArgs> DedDataChangedEvent
Public Event DedDataChangedEvent As EventHandler(Of DedDataChangedEventArgs)
public:
 event EventHandler<DedDataChangedEventArgs^>^ DedDataChangedEvent {
    void add (EventHandler<DedDataChangedEventArgs^>^ value);
    void remove (EventHandler<DedDataChangedEventArgs^>^ value);
}
member DedDataChangedEvent : IEvent<EventHandler<DedDataChangedEventArgs>,
    DedDataChangedEventArgs>

Valore

EventHandler DedDataChangedEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.DedDataMoveEvent

Evento DedNetApplicationDedDataMoveEvent
Evento chiamato sullo spostamento di un'anagrafica.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DedDataMoveEventArgs> DedDataMoveEvent
Public Event DedDataMoveEvent As EventHandler(Of DedDataMoveEventArgs)
public:
 event EventHandler<DedDataMoveEventArgs^>^ DedDataMoveEvent {
    void add (EventHandler<DedDataMoveEventArgs^>^ value);
    void remove (EventHandler<DedDataMoveEventArgs^>^ value);
}
member DedDataMoveEvent : IEvent<EventHandler<DedDataMoveEventArgs>,
    DedDataMoveEventArgs>

Valore

EventHandler DedDataMoveEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.DedOpenDocumentEvent

Evento DedNetApplicationDedOpenDocumentEvent
Evento chiamato in fase di apertura di un documento dal DED.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DedOpenDocumentEventArgs> DedOpenDocumentEvent
Public Event DedOpenDocumentEvent As EventHandler(Of DedOpenDocumentEventArgs)
public:
 event EventHandler<DedOpenDocumentEventArgs^>^ DedOpenDocumentEvent {
    void add (EventHandler<DedOpenDocumentEventArgs^>^ value);
    void remove (EventHandler<DedOpenDocumentEventArgs^>^ value);
}
member DedOpenDocumentEvent : IEvent<EventHandler<DedOpenDocumentEventArgs>,
    DedOpenDocumentEventArgs>

Valore

EventHandler DedOpenDocumentEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.DedRuleLuaEvent

Evento DedNetApplicationDedRuleLuaEvent
Evento chiamato per la gestione delle regole di autocomposizione in Lua.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DedRuleLuaEventArg> DedRuleLuaEvent
Public Event DedRuleLuaEvent As EventHandler(Of DedRuleLuaEventArg)
public:
 event EventHandler<DedRuleLuaEventArg^>^ DedRuleLuaEvent {
    void add (EventHandler<DedRuleLuaEventArg^>^ value);
    void remove (EventHandler<DedRuleLuaEventArg^>^ value);
}
member DedRuleLuaEvent : IEvent<EventHandler<DedRuleLuaEventArg>,
    DedRuleLuaEventArg>

Valore

EventHandler DedRuleLuaEventArg
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.DedRuleRowSetAttrPostEvent

Evento DedNetApplicationDedRuleRowSetAttrPostEvent
Evento chiamato subito dopo la sostituzione di tutta la stringa di una regola.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DedRuleParserEventArg> DedRuleRowSetAttrPostEvent
Public Event DedRuleRowSetAttrPostEvent As EventHandler(Of DedRuleParserEventArg)
public:
 event EventHandler<DedRuleParserEventArg^>^ DedRuleRowSetAttrPostEvent {
    void add (EventHandler<DedRuleParserEventArg^>^ value);
    void remove (EventHandler<DedRuleParserEventArg^>^ value);
}
member DedRuleRowSetAttrPostEvent : IEvent<EventHandler<DedRuleParserEventArg>,
    DedRuleParserEventArg>

Valore

EventHandler DedRuleParserEventArg
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.DedRuleSetAttrPostEvent

Evento DedNetApplicationDedRuleSetAttrPostEvent
Evento chiamato subito dopo l'impostazione degli attributi di una regola.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler DedRuleSetAttrPostEvent
Public Event DedRuleSetAttrPostEvent As EventHandler
public:
 event EventHandler^ DedRuleSetAttrPostEvent {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member DedRuleSetAttrPostEvent : IEvent<EventHandler,
    EventArgs>

Valore

EventHandler
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.DedRuleSetAttrPreEvent

Evento DedNetApplicationDedRuleSetAttrPreEvent
Evento chiamato subito prima dell'impostazione degli attributi di una regola.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler DedRuleSetAttrPreEvent
Public Event DedRuleSetAttrPreEvent As EventHandler
public:
 event EventHandler^ DedRuleSetAttrPreEvent {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member DedRuleSetAttrPreEvent : IEvent<EventHandler,
    EventArgs>

Valore

EventHandler
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.DedRuleSingleSetAttrPreEvent

Evento DedNetApplicationDedRuleSingleSetAttrPreEvent
Evento chiamato prima della sostituzione di un singolo token di una singola regola.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DedRuleParserEventArg> DedRuleSingleSetAttrPreEvent
Public Event DedRuleSingleSetAttrPreEvent As EventHandler(Of DedRuleParserEventArg)
public:
 event EventHandler<DedRuleParserEventArg^>^ DedRuleSingleSetAttrPreEvent {
    void add (EventHandler<DedRuleParserEventArg^>^ value);
    void remove (EventHandler<DedRuleParserEventArg^>^ value);
}
member DedRuleSingleSetAttrPreEvent : IEvent<EventHandler<DedRuleParserEventArg>,
    DedRuleParserEventArg>

Valore

EventHandler DedRuleParserEventArg
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.DedTranslationChangedEvent

Evento DedNetApplicationDedTranslationChangedEvent
Evento chiamato quando viene aggiunto un record in DedData.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DedTranslationChangedEventArgs> DedTranslationChangedEvent
Public Event DedTranslationChangedEvent As EventHandler(Of DedTranslationChangedEventArgs)
public:
 event EventHandler<DedTranslationChangedEventArgs^>^ DedTranslationChangedEvent {
    void add (EventHandler<DedTranslationChangedEventArgs^>^ value);
    void remove (EventHandler<DedTranslationChangedEventArgs^>^ value);
}
member DedTranslationChangedEvent : IEvent<EventHandler<DedTranslationChangedEventArgs>,
    DedTranslationChangedEventArgs>

Valore

EventHandler DedTranslationChangedEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.DefineFileDependencyEvent

Evento DedNetApplicationDefineFileDependencyEvent
Evento chiamato per definire la dipendenza di un file che non è presente nel Database. Viene chiamato con il Before e l'After ad indicare il momento e se si imposta come Handled lascia la lista delle dipendenze così come l'ha modificata il client.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DependencyFileInfoEventArgs> DefineFileDependencyEvent
Public Event DefineFileDependencyEvent As EventHandler(Of DependencyFileInfoEventArgs)
public:
 event EventHandler<DependencyFileInfoEventArgs^>^ DefineFileDependencyEvent {
    void add (EventHandler<DependencyFileInfoEventArgs^>^ value);
    void remove (EventHandler<DependencyFileInfoEventArgs^>^ value);
}
member DefineFileDependencyEvent : IEvent<EventHandler<DependencyFileInfoEventArgs>,
    DependencyFileInfoEventArgs>

Valore

EventHandler DependencyFileInfoEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.DisableAutoUpdateAnagrCommEvent

Evento DedNetApplicationDisableAutoUpdateAnagrCommEvent
Evento per disabilitare l'aggiornamento automatico delle revisioni delle anagrafiche di commessa La disabilitazione avviene tramite un valore di un determinato attributo di commessa

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DisableAutoUpdateAnagrCommEventArgs> DisableAutoUpdateAnagrCommEvent
Public Event DisableAutoUpdateAnagrCommEvent As EventHandler(Of DisableAutoUpdateAnagrCommEventArgs)
public:
 event EventHandler<DisableAutoUpdateAnagrCommEventArgs^>^ DisableAutoUpdateAnagrCommEvent {
    void add (EventHandler<DisableAutoUpdateAnagrCommEventArgs^>^ value);
    void remove (EventHandler<DisableAutoUpdateAnagrCommEventArgs^>^ value);
}
member DisableAutoUpdateAnagrCommEvent : IEvent<EventHandler<DisableAutoUpdateAnagrCommEventArgs>,
    DisableAutoUpdateAnagrCommEventArgs>

Valore

EventHandler DisableAutoUpdateAnagrCommEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.DistAddNodeEvent

Evento DedNetApplicationDistAddNodeEvent
Evento chiamata quando viene iserito un nuovo nodo in distinta.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DistAddNodeEventArgs> DistAddNodeEvent
Public Event DistAddNodeEvent As EventHandler(Of DistAddNodeEventArgs)
public:
 event EventHandler<DistAddNodeEventArgs^>^ DistAddNodeEvent {
    void add (EventHandler<DistAddNodeEventArgs^>^ value);
    void remove (EventHandler<DistAddNodeEventArgs^>^ value);
}
member DistAddNodeEvent : IEvent<EventHandler<DistAddNodeEventArgs>,
    DistAddNodeEventArgs>

Valore

EventHandler DistAddNodeEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.DistChangeFieldValueEvent

Evento DedNetApplicationDistChangeFieldValueEvent
Evento chiamato alla modifica di un attributo di distinta nella finestra dell'editor delle distinte.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DistChangeFieldValueEventArgs> DistChangeFieldValueEvent
Public Event DistChangeFieldValueEvent As EventHandler(Of DistChangeFieldValueEventArgs)
public:
 event EventHandler<DistChangeFieldValueEventArgs^>^ DistChangeFieldValueEvent {
    void add (EventHandler<DistChangeFieldValueEventArgs^>^ value);
    void remove (EventHandler<DistChangeFieldValueEventArgs^>^ value);
}
member DistChangeFieldValueEvent : IEvent<EventHandler<DistChangeFieldValueEventArgs>,
    DistChangeFieldValueEventArgs>

Valore

EventHandler DistChangeFieldValueEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.DistCloneDataEvent

Evento DedNetApplicationDistCloneDataEvent
Evento chiamato alla copia di ogni elemento nel clona distinta chiamato da DEDAPI.DuplicaDistinta()

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DistCloneDataEventArgs> DistCloneDataEvent
Public Event DistCloneDataEvent As EventHandler(Of DistCloneDataEventArgs)
public:
 event EventHandler<DistCloneDataEventArgs^>^ DistCloneDataEvent {
    void add (EventHandler<DistCloneDataEventArgs^>^ value);
    void remove (EventHandler<DistCloneDataEventArgs^>^ value);
}
member DistCloneDataEvent : IEvent<EventHandler<DistCloneDataEventArgs>,
    DistCloneDataEventArgs>

Valore

EventHandler DistCloneDataEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.DistCopyDataEvent

Evento DedNetApplicationDistCopyDataEvent
Evento chiamata quando viene copiato un codice dal pannello di dx a quell di dx tramite editor distinte. Possibilità di annuallare l'inserimento e cambiare i dati inseriti.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DistCopyDataEventArgs> DistCopyDataEvent
Public Event DistCopyDataEvent As EventHandler(Of DistCopyDataEventArgs)
public:
 event EventHandler<DistCopyDataEventArgs^>^ DistCopyDataEvent {
    void add (EventHandler<DistCopyDataEventArgs^>^ value);
    void remove (EventHandler<DistCopyDataEventArgs^>^ value);
}
member DistCopyDataEvent : IEvent<EventHandler<DistCopyDataEventArgs>,
    DistCopyDataEventArgs>

Valore

EventHandler DistCopyDataEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.DistDragElementEvent

Evento DedNetApplicationDistDragElementEvent
Evento chiamata quando viene aggiunto un elemento alla distinta tramite l'inizia parte veloce. Possibilità di annullare l'inserimento e cambiare i dati inseriti.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DistDragElementEventArgs> DistDragElementEvent
Public Event DistDragElementEvent As EventHandler(Of DistDragElementEventArgs)
public:
 event EventHandler<DistDragElementEventArgs^>^ DistDragElementEvent {
    void add (EventHandler<DistDragElementEventArgs^>^ value);
    void remove (EventHandler<DistDragElementEventArgs^>^ value);
}
member DistDragElementEvent : IEvent<EventHandler<DistDragElementEventArgs>,
    DistDragElementEventArgs>

Valore

EventHandler DistDragElementEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.DistEditSaveEvent

Evento DedNetApplicationDistEditSaveEvent
Evento di salvataggio all'interno dell'editor delle distinte.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DedDistEditSaveEventArgs> DistEditSaveEvent
Public Event DistEditSaveEvent As EventHandler(Of DedDistEditSaveEventArgs)
public:
 event EventHandler<DedDistEditSaveEventArgs^>^ DistEditSaveEvent {
    void add (EventHandler<DedDistEditSaveEventArgs^>^ value);
    void remove (EventHandler<DedDistEditSaveEventArgs^>^ value);
}
member DistEditSaveEvent : IEvent<EventHandler<DedDistEditSaveEventArgs>,
    DedDistEditSaveEventArgs>

Valore

EventHandler DedDistEditSaveEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.DistElementCreateDataEvent

Evento DedNetApplicationDistElementCreateDataEvent
Evento sulla creazione dell'anagrafica chiamato sia prima che dopo la creazione di una anagrafica a partire da un nuovo elemento di distinta da aggiungere. Questo è l'evento ad alto livello che agisce a livello di comando, vedere anche l'evento DistItemCreateData..

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DistElementCreateDataEventArgs> DistElementCreateDataEvent
Public Event DistElementCreateDataEvent As EventHandler(Of DistElementCreateDataEventArgs)
public:
 event EventHandler<DistElementCreateDataEventArgs^>^ DistElementCreateDataEvent {
    void add (EventHandler<DistElementCreateDataEventArgs^>^ value);
    void remove (EventHandler<DistElementCreateDataEventArgs^>^ value);
}
member DistElementCreateDataEvent : IEvent<EventHandler<DistElementCreateDataEventArgs>,
    DistElementCreateDataEventArgs>

Valore

EventHandler DistElementCreateDataEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.DistItemCreateDataEvent

Evento DedNetApplicationDistItemCreateDataEvent
Evento sulla creazione dell'anagrafica chiamato sia prima che dopo la creazione di una anagrafica a partire da un nuovo elemento di distinta da aggiungere. Questo è l'evento a basso livello, per agire a livello di comando vedere l'evento DistElementCreateData.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DistItemCreateDataEventArgs> DistItemCreateDataEvent
Public Event DistItemCreateDataEvent As EventHandler(Of DistItemCreateDataEventArgs)
public:
 event EventHandler<DistItemCreateDataEventArgs^>^ DistItemCreateDataEvent {
    void add (EventHandler<DistItemCreateDataEventArgs^>^ value);
    void remove (EventHandler<DistItemCreateDataEventArgs^>^ value);
}
member DistItemCreateDataEvent : IEvent<EventHandler<DistItemCreateDataEventArgs>,
    DistItemCreateDataEventArgs>

Valore

EventHandler DistItemCreateDataEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.DistLevelSaveEvent

Evento DedNetApplicationDistLevelSaveEvent
Evento di salvataggio della distinta. A differenza dell'evento "DistSaveEvent", questo scatta per ogni item della distinta.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DedDistSaveEventArgs> DistLevelSaveEvent
Public Event DistLevelSaveEvent As EventHandler(Of DedDistSaveEventArgs)
public:
 event EventHandler<DedDistSaveEventArgs^>^ DistLevelSaveEvent {
    void add (EventHandler<DedDistSaveEventArgs^>^ value);
    void remove (EventHandler<DedDistSaveEventArgs^>^ value);
}
member DistLevelSaveEvent : IEvent<EventHandler<DedDistSaveEventArgs>,
    DedDistSaveEventArgs>

Valore

EventHandler DedDistSaveEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.DistReplaceSaveEvent

Evento DedNetApplicationDistReplaceSaveEvent
Evento di salvataggio durante la sostituzione massiva.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DedDistEditSaveEventArgs> DistReplaceSaveEvent
Public Event DistReplaceSaveEvent As EventHandler(Of DedDistEditSaveEventArgs)
public:
 event EventHandler<DedDistEditSaveEventArgs^>^ DistReplaceSaveEvent {
    void add (EventHandler<DedDistEditSaveEventArgs^>^ value);
    void remove (EventHandler<DedDistEditSaveEventArgs^>^ value);
}
member DistReplaceSaveEvent : IEvent<EventHandler<DedDistEditSaveEventArgs>,
    DedDistEditSaveEventArgs>

Valore

EventHandler DedDistEditSaveEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.DistSaveEvent

Evento DedNetApplicationDistSaveEvent
Evento di salvataggio della distinta.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DedDistSaveEventArgs> DistSaveEvent
Public Event DistSaveEvent As EventHandler(Of DedDistSaveEventArgs)
public:
 event EventHandler<DedDistSaveEventArgs^>^ DistSaveEvent {
    void add (EventHandler<DedDistSaveEventArgs^>^ value);
    void remove (EventHandler<DedDistSaveEventArgs^>^ value);
}
member DistSaveEvent : IEvent<EventHandler<DedDistSaveEventArgs>,
    DedDistSaveEventArgs>

Valore

EventHandler DedDistSaveEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.DocStructInfoCreatedEvent

Evento DedNetApplicationDocStructInfoCreatedEvent
Evento creazione nuovo DocStructInfo

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<ResolveDocStructInfoEventArgs> DocStructInfoCreatedEvent
Public Event DocStructInfoCreatedEvent As EventHandler(Of ResolveDocStructInfoEventArgs)
public:
 event EventHandler<ResolveDocStructInfoEventArgs^>^ DocStructInfoCreatedEvent {
    void add (EventHandler<ResolveDocStructInfoEventArgs^>^ value);
    void remove (EventHandler<ResolveDocStructInfoEventArgs^>^ value);
}
member DocStructInfoCreatedEvent : IEvent<EventHandler<ResolveDocStructInfoEventArgs>,
    ResolveDocStructInfoEventArgs>

Valore

EventHandler ResolveDocStructInfoEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.DocumentAnnullaCheckedOutEvent

Evento DedNetApplicationDocumentAnnullaCheckedOutEvent
Evento chiamato dopo il checkout su di un documento

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DocStructInfoEventArgs> DocumentAnnullaCheckedOutEvent
Public Event DocumentAnnullaCheckedOutEvent As EventHandler(Of DocStructInfoEventArgs)
public:
 event EventHandler<DocStructInfoEventArgs^>^ DocumentAnnullaCheckedOutEvent {
    void add (EventHandler<DocStructInfoEventArgs^>^ value);
    void remove (EventHandler<DocStructInfoEventArgs^>^ value);
}
member DocumentAnnullaCheckedOutEvent : IEvent<EventHandler<DocStructInfoEventArgs>,
    DocStructInfoEventArgs>

Valore

EventHandler DocStructInfoEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.DocumentCheckedInEvent

Evento DedNetApplicationDocumentCheckedInEvent
Evento chiamato prima del checkin di un elemento

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DocStructInfoEventArgs> DocumentCheckedInEvent
Public Event DocumentCheckedInEvent As EventHandler(Of DocStructInfoEventArgs)
public:
 event EventHandler<DocStructInfoEventArgs^>^ DocumentCheckedInEvent {
    void add (EventHandler<DocStructInfoEventArgs^>^ value);
    void remove (EventHandler<DocStructInfoEventArgs^>^ value);
}
member DocumentCheckedInEvent : IEvent<EventHandler<DocStructInfoEventArgs>,
    DocStructInfoEventArgs>

Valore

EventHandler DocStructInfoEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.DocumentCheckedOutEvent

Evento DedNetApplicationDocumentCheckedOutEvent
Evento chiamato dopo il checkout su di un documento

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DocStructInfoEventArgs> DocumentCheckedOutEvent
Public Event DocumentCheckedOutEvent As EventHandler(Of DocStructInfoEventArgs)
public:
 event EventHandler<DocStructInfoEventArgs^>^ DocumentCheckedOutEvent {
    void add (EventHandler<DocStructInfoEventArgs^>^ value);
    void remove (EventHandler<DocStructInfoEventArgs^>^ value);
}
member DocumentCheckedOutEvent : IEvent<EventHandler<DocStructInfoEventArgs>,
    DocStructInfoEventArgs>

Valore

EventHandler DocStructInfoEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.DocumentCheckLockedEvent

Evento DedNetApplicationDocumentCheckLockedEvent
Evento chiamato in fase di scaricamento in locale del documento per controllare se è locked.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DocumentCheckLockedEventArgs> DocumentCheckLockedEvent
Public Event DocumentCheckLockedEvent As EventHandler(Of DocumentCheckLockedEventArgs)
public:
 event EventHandler<DocumentCheckLockedEventArgs^>^ DocumentCheckLockedEvent {
    void add (EventHandler<DocumentCheckLockedEventArgs^>^ value);
    void remove (EventHandler<DocumentCheckLockedEventArgs^>^ value);
}
member DocumentCheckLockedEvent : IEvent<EventHandler<DocumentCheckLockedEventArgs>,
    DocumentCheckLockedEventArgs>

Valore

EventHandler DocumentCheckLockedEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.DocumentCreatingEvent

Evento DedNetApplicationDocumentCreatingEvent
Evento lanciato in fase di creazione documento, che permette di personalizzare il guid di versione documento da scrivere nel record ed anche i dati del documento.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DocumentEventArgs> DocumentCreatingEvent
Public Event DocumentCreatingEvent As EventHandler(Of DocumentEventArgs)
public:
 event EventHandler<DocumentEventArgs^>^ DocumentCreatingEvent {
    void add (EventHandler<DocumentEventArgs^>^ value);
    void remove (EventHandler<DocumentEventArgs^>^ value);
}
member DocumentCreatingEvent : IEvent<EventHandler<DocumentEventArgs>,
    DocumentEventArgs>

Valore

EventHandler DocumentEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.DocumentDisableEvent

Evento DedNetApplicationDocumentDisableEvent
Evento lanciato in fase visualizzazione del documento nel controllo documentale.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DocumentDisableEventArgs> DocumentDisableEvent
Public Event DocumentDisableEvent As EventHandler(Of DocumentDisableEventArgs)
public:
 event EventHandler<DocumentDisableEventArgs^>^ DocumentDisableEvent {
    void add (EventHandler<DocumentDisableEventArgs^>^ value);
    void remove (EventHandler<DocumentDisableEventArgs^>^ value);
}
member DocumentDisableEvent : IEvent<EventHandler<DocumentDisableEventArgs>,
    DocumentDisableEventArgs>

Valore

EventHandler DocumentDisableEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.DocumentDisconnectingEvent

Evento DedNetApplicationDocumentDisconnectingEvent
Evento chiamato in fase di disconnesione documento dall'anagrafica. Permette ai client di impostare i dati del comando.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DocumentDisconnectingEventArgs> DocumentDisconnectingEvent
Public Event DocumentDisconnectingEvent As EventHandler(Of DocumentDisconnectingEventArgs)
public:
 event EventHandler<DocumentDisconnectingEventArgs^>^ DocumentDisconnectingEvent {
    void add (EventHandler<DocumentDisconnectingEventArgs^>^ value);
    void remove (EventHandler<DocumentDisconnectingEventArgs^>^ value);
}
member DocumentDisconnectingEvent : IEvent<EventHandler<DocumentDisconnectingEventArgs>,
    DocumentDisconnectingEventArgs>

Valore

EventHandler DocumentDisconnectingEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.DocumentDownloadedEvent

Evento DedNetApplicationDocumentDownloadedEvent
Evento chiamato dopo che un documento è stato scaricato in locale da una operazione di ensurelocal

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DedCommandEventArgs> DocumentDownloadedEvent
Public Event DocumentDownloadedEvent As EventHandler(Of DedCommandEventArgs)
public:
 event EventHandler<DedCommandEventArgs^>^ DocumentDownloadedEvent {
    void add (EventHandler<DedCommandEventArgs^>^ value);
    void remove (EventHandler<DedCommandEventArgs^>^ value);
}
member DocumentDownloadedEvent : IEvent<EventHandler<DedCommandEventArgs>,
    DedCommandEventArgs>

Valore

EventHandler DedCommandEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.DocumentDragDropEvent

Evento DedNetApplicationDocumentDragDropEvent
Evento lanciato prima della partenza del drag da controllo documentale. Permette di impedirne la continuazione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DocumentDragDropEventArgs> DocumentDragDropEvent
Public Event DocumentDragDropEvent As EventHandler(Of DocumentDragDropEventArgs)
public:
 event EventHandler<DocumentDragDropEventArgs^>^ DocumentDragDropEvent {
    void add (EventHandler<DocumentDragDropEventArgs^>^ value);
    void remove (EventHandler<DocumentDragDropEventArgs^>^ value);
}
member DocumentDragDropEvent : IEvent<EventHandler<DocumentDragDropEventArgs>,
    DocumentDragDropEventArgs>

Valore

EventHandler DocumentDragDropEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.DocumentEnsureLocalOperationEvent

Evento DedNetApplicationDocumentEnsureLocalOperationEvent
Evento chiamato durante l'operation dell'esurelocal su di un documento

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DocOperationEventArgs> DocumentEnsureLocalOperationEvent
Public Event DocumentEnsureLocalOperationEvent As EventHandler(Of DocOperationEventArgs)
public:
 event EventHandler<DocOperationEventArgs^>^ DocumentEnsureLocalOperationEvent {
    void add (EventHandler<DocOperationEventArgs^>^ value);
    void remove (EventHandler<DocOperationEventArgs^>^ value);
}
member DocumentEnsureLocalOperationEvent : IEvent<EventHandler<DocOperationEventArgs>,
    DocOperationEventArgs>

Valore

EventHandler DocOperationEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.DocumentImportedEvent

Evento DedNetApplicationDocumentImportedEvent
Evento chiamato dopo l'importazione di un documento sull'anagrafica

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<ImportedDocStructInfoEventArgs> DocumentImportedEvent
Public Event DocumentImportedEvent As EventHandler(Of ImportedDocStructInfoEventArgs)
public:
 event EventHandler<ImportedDocStructInfoEventArgs^>^ DocumentImportedEvent {
    void add (EventHandler<ImportedDocStructInfoEventArgs^>^ value);
    void remove (EventHandler<ImportedDocStructInfoEventArgs^>^ value);
}
member DocumentImportedEvent : IEvent<EventHandler<ImportedDocStructInfoEventArgs>,
    ImportedDocStructInfoEventArgs>

Valore

EventHandler ImportedDocStructInfoEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.DocumentImportingEvent

Evento DedNetApplicationDocumentImportingEvent
Evento chiamato in fase di importazione documento che permette di modificare la struttura sottostante al documento prima dell'esecuzione vera e propria dell'operazione. Viene chiamato anche immediatamente dopo l'esecuzione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DocumentImportingEventArgs> DocumentImportingEvent
Public Event DocumentImportingEvent As EventHandler(Of DocumentImportingEventArgs)
public:
 event EventHandler<DocumentImportingEventArgs^>^ DocumentImportingEvent {
    void add (EventHandler<DocumentImportingEventArgs^>^ value);
    void remove (EventHandler<DocumentImportingEventArgs^>^ value);
}
member DocumentImportingEvent : IEvent<EventHandler<DocumentImportingEventArgs>,
    DocumentImportingEventArgs>

Valore

EventHandler DocumentImportingEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.DocumentLinkingEvent

Evento DedNetApplicationDocumentLinkingEvent
Evento chiamato in fase di collegamento documento all'anagrafica. Permette ai client di impostare i dati del comando.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DocumentLinkingEventArgs> DocumentLinkingEvent
Public Event DocumentLinkingEvent As EventHandler(Of DocumentLinkingEventArgs)
public:
 event EventHandler<DocumentLinkingEventArgs^>^ DocumentLinkingEvent {
    void add (EventHandler<DocumentLinkingEventArgs^>^ value);
    void remove (EventHandler<DocumentLinkingEventArgs^>^ value);
}
member DocumentLinkingEvent : IEvent<EventHandler<DocumentLinkingEventArgs>,
    DocumentLinkingEventArgs>

Valore

EventHandler DocumentLinkingEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.DocumentMovingEvent

Evento DedNetApplicationDocumentMovingEvent
Evento chiamato in fase di move command sui documenti principali. Permette ai client di impostare i dati di clonazione nella sotto struttura.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DocumentMovingEventArgs> DocumentMovingEvent
Public Event DocumentMovingEvent As EventHandler(Of DocumentMovingEventArgs)
public:
 event EventHandler<DocumentMovingEventArgs^>^ DocumentMovingEvent {
    void add (EventHandler<DocumentMovingEventArgs^>^ value);
    void remove (EventHandler<DocumentMovingEventArgs^>^ value);
}
member DocumentMovingEvent : IEvent<EventHandler<DocumentMovingEventArgs>,
    DocumentMovingEventArgs>

Valore

EventHandler DocumentMovingEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.DocumentPublishEvent

Evento DedNetApplicationDocumentPublishEvent
Evento chiamato prima della pubblicazione di un elemento

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DocStructInfoEventArgs> DocumentPublishEvent
Public Event DocumentPublishEvent As EventHandler(Of DocStructInfoEventArgs)
public:
 event EventHandler<DocStructInfoEventArgs^>^ DocumentPublishEvent {
    void add (EventHandler<DocStructInfoEventArgs^>^ value);
    void remove (EventHandler<DocStructInfoEventArgs^>^ value);
}
member DocumentPublishEvent : IEvent<EventHandler<DocStructInfoEventArgs>,
    DocStructInfoEventArgs>

Valore

EventHandler DocStructInfoEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.DocumentRecognizingEvent

Evento DedNetApplicationDocumentRecognizingEvent
Evento chiamato in fase di riconoscimento documento che permette di modificare la struttura sottostante al documento prima dell'esecuzione vera e propria dell'operazione. Viene chiamato anche immediatamente dopo l'esecuzione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DocumentRecognizingEventArgs> DocumentRecognizingEvent
Public Event DocumentRecognizingEvent As EventHandler(Of DocumentRecognizingEventArgs)
public:
 event EventHandler<DocumentRecognizingEventArgs^>^ DocumentRecognizingEvent {
    void add (EventHandler<DocumentRecognizingEventArgs^>^ value);
    void remove (EventHandler<DocumentRecognizingEventArgs^>^ value);
}
member DocumentRecognizingEvent : IEvent<EventHandler<DocumentRecognizingEventArgs>,
    DocumentRecognizingEventArgs>

Valore

EventHandler DocumentRecognizingEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.DocumentSbloccaEvent

Evento DedNetApplicationDocumentSbloccaEvent
Evento chiamato dopo lo sblocca su di un documento

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DocStructInfoEventArgs> DocumentSbloccaEvent
Public Event DocumentSbloccaEvent As EventHandler(Of DocStructInfoEventArgs)
public:
 event EventHandler<DocStructInfoEventArgs^>^ DocumentSbloccaEvent {
    void add (EventHandler<DocStructInfoEventArgs^>^ value);
    void remove (EventHandler<DocStructInfoEventArgs^>^ value);
}
member DocumentSbloccaEvent : IEvent<EventHandler<DocStructInfoEventArgs>,
    DocStructInfoEventArgs>

Valore

EventHandler DocStructInfoEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.DocumentUpdatingEvent

Evento DedNetApplicationDocumentUpdatingEvent
Evento lanciato in fase di aggiornamento documento, che permette di personalizzare il guid di versione documento da scrivere nel record.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DocumentEventArgs> DocumentUpdatingEvent
Public Event DocumentUpdatingEvent As EventHandler(Of DocumentEventArgs)
public:
 event EventHandler<DocumentEventArgs^>^ DocumentUpdatingEvent {
    void add (EventHandler<DocumentEventArgs^>^ value);
    void remove (EventHandler<DocumentEventArgs^>^ value);
}
member DocumentUpdatingEvent : IEvent<EventHandler<DocumentEventArgs>,
    DocumentEventArgs>

Valore

EventHandler DocumentEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.DragDropEvent

Evento DedNetApplicationDragDropEvent

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DragDropEventArgs> DragDropEvent
Public Event DragDropEvent As EventHandler(Of DragDropEventArgs)
public:
 event EventHandler<DragDropEventArgs^>^ DragDropEvent {
    void add (EventHandler<DragDropEventArgs^>^ value);
    void remove (EventHandler<DragDropEventArgs^>^ value);
}
member DragDropEvent : IEvent<EventHandler<DragDropEventArgs>,
    DragDropEventArgs>

Valore

EventHandler DragDropEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.EditAttrEvent

Evento DedNetApplicationEditAttrEvent
Evento chiamato prima di entrare in editazione dell'anagrafica e dopo aver confermato l'editazione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<EditAttrEventArgs> EditAttrEvent
Public Event EditAttrEvent As EventHandler(Of EditAttrEventArgs)
public:
 event EventHandler<EditAttrEventArgs^>^ EditAttrEvent {
    void add (EventHandler<EditAttrEventArgs^>^ value);
    void remove (EventHandler<EditAttrEventArgs^>^ value);
}
member EditAttrEvent : IEvent<EventHandler<EditAttrEventArgs>,
    EditAttrEventArgs>

Valore

EventHandler EditAttrEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.EditAttrValidatingEvent

Evento DedNetApplicationEditAttrValidatingEvent
Evento chiamato prima di entrare in editazione dell'anagrafica e dopo aver confermato l'editazione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<EditAttrValidatingEventArgs> EditAttrValidatingEvent
Public Event EditAttrValidatingEvent As EventHandler(Of EditAttrValidatingEventArgs)
public:
 event EventHandler<EditAttrValidatingEventArgs^>^ EditAttrValidatingEvent {
    void add (EventHandler<EditAttrValidatingEventArgs^>^ value);
    void remove (EventHandler<EditAttrValidatingEventArgs^>^ value);
}
member EditAttrValidatingEvent : IEvent<EventHandler<EditAttrValidatingEventArgs>,
    EditAttrValidatingEventArgs>

Valore

EventHandler EditAttrValidatingEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.EditCommChangedEvent

Evento DedNetApplicationEditCommChangedEvent
Evento su modifica della commessa o di uno dei valori durante la procedura di modifica commessa.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<EventArgs> EditCommChangedEvent
Public Event EditCommChangedEvent As EventHandler(Of EventArgs)
public:
 event EventHandler<EventArgs^>^ EditCommChangedEvent {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}
member EditCommChangedEvent : IEvent<EventHandler<EventArgs>,
    EventArgs>

Valore

EventHandler EventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.EditCommEvent

Evento DedNetApplicationEditCommEvent
Evento lanciato prima e domo la modifica di una commessa.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DedCommCommandEventArgs> EditCommEvent
Public Event EditCommEvent As EventHandler(Of DedCommCommandEventArgs)
public:
 event EventHandler<DedCommCommandEventArgs^>^ EditCommEvent {
    void add (EventHandler<DedCommCommandEventArgs^>^ value);
    void remove (EventHandler<DedCommCommandEventArgs^>^ value);
}
member EditCommEvent : IEvent<EventHandler<DedCommCommandEventArgs>,
    DedCommCommandEventArgs>

Valore

EventHandler DedCommCommandEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.ElaborateDedListEvent

Evento DedNetApplicationElaborateDedListEvent
Evento che permette di gestire gli elementi in lista

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<ElaborateDedListEventArgs> ElaborateDedListEvent
Public Event ElaborateDedListEvent As EventHandler(Of ElaborateDedListEventArgs)
public:
 event EventHandler<ElaborateDedListEventArgs^>^ ElaborateDedListEvent {
    void add (EventHandler<ElaborateDedListEventArgs^>^ value);
    void remove (EventHandler<ElaborateDedListEventArgs^>^ value);
}
member ElaborateDedListEvent : IEvent<EventHandler<ElaborateDedListEventArgs>,
    ElaborateDedListEventArgs>

Valore

EventHandler ElaborateDedListEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.EsclAttrUpdFromDBTabEvent

Evento DedNetApplicationEsclAttrUpdFromDBTabEvent
Evento lanciato quando viene usata la lista SkipAttribListEvent.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<SkipEsclAttribEventArgs> EsclAttrUpdFromDBTabEvent
Public Event EsclAttrUpdFromDBTabEvent As EventHandler(Of SkipEsclAttribEventArgs)
public:
 event EventHandler<SkipEsclAttribEventArgs^>^ EsclAttrUpdFromDBTabEvent {
    void add (EventHandler<SkipEsclAttribEventArgs^>^ value);
    void remove (EventHandler<SkipEsclAttribEventArgs^>^ value);
}
member EsclAttrUpdFromDBTabEvent : IEvent<EventHandler<SkipEsclAttribEventArgs>,
    SkipEsclAttribEventArgs>

Valore

EventHandler SkipEsclAttribEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.EvaluateNewValueEvent

Evento DedNetApplicationEvaluateNewValueEvent
Evento chiamato quando l'utente digita un codice non presente nel Database nella finestra di ricerca veloce, e che quindi può essere corretto da chi gestisce l'evento.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<EvaluateNewValueEventArgs> EvaluateNewValueEvent
Public Event EvaluateNewValueEvent As EventHandler(Of EvaluateNewValueEventArgs)
public:
 event EventHandler<EvaluateNewValueEventArgs^>^ EvaluateNewValueEvent {
    void add (EventHandler<EvaluateNewValueEventArgs^>^ value);
    void remove (EventHandler<EvaluateNewValueEventArgs^>^ value);
}
member EvaluateNewValueEvent : IEvent<EventHandler<EvaluateNewValueEventArgs>,
    EvaluateNewValueEventArgs>

Valore

EventHandler EvaluateNewValueEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.ExportDataEvent

Evento DedNetApplicationExportDataEvent
Evento chiamato per la gestione dell'esportazione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<ExportDataEventArg> ExportDataEvent
Public Event ExportDataEvent As EventHandler(Of ExportDataEventArg)
public:
 event EventHandler<ExportDataEventArg^>^ ExportDataEvent {
    void add (EventHandler<ExportDataEventArg^>^ value);
    void remove (EventHandler<ExportDataEventArg^>^ value);
}
member ExportDataEvent : IEvent<EventHandler<ExportDataEventArg>,
    ExportDataEventArg>

Valore

EventHandler ExportDataEventArg
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.ExportPackAndGoConfirmEvent

Evento DedNetApplicationExportPackAndGoConfirmEvent

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<PackAndGoZipFolderEventArgs> ExportPackAndGoConfirmEvent
Public Event ExportPackAndGoConfirmEvent As EventHandler(Of PackAndGoZipFolderEventArgs)
public:
 event EventHandler<PackAndGoZipFolderEventArgs^>^ ExportPackAndGoConfirmEvent {
    void add (EventHandler<PackAndGoZipFolderEventArgs^>^ value);
    void remove (EventHandler<PackAndGoZipFolderEventArgs^>^ value);
}
member ExportPackAndGoConfirmEvent : IEvent<EventHandler<PackAndGoZipFolderEventArgs>,
    PackAndGoZipFolderEventArgs>

Valore

EventHandler PackAndGoZipFolderEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.ExportResultBomCompareEvent

Evento DedNetApplicationExportResultBomCompareEvent
Evento che permette di bloccare l'esportazione su excel del risultato del confronto tra distinte e di gestirlo

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<ExportResultBomCompareEventArgs> ExportResultBomCompareEvent
Public Event ExportResultBomCompareEvent As EventHandler(Of ExportResultBomCompareEventArgs)
public:
 event EventHandler<ExportResultBomCompareEventArgs^>^ ExportResultBomCompareEvent {
    void add (EventHandler<ExportResultBomCompareEventArgs^>^ value);
    void remove (EventHandler<ExportResultBomCompareEventArgs^>^ value);
}
member ExportResultBomCompareEvent : IEvent<EventHandler<ExportResultBomCompareEventArgs>,
    ExportResultBomCompareEventArgs>

Valore

EventHandler ExportResultBomCompareEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.FamDescrOverrideEvent

Evento DedNetApplicationFamDescrOverrideEvent
Evento chiamato per poter ridefinire la descrizione della famiglia ( inserire una lista a tendina ).

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<FamDescrOverrideEventArgs> FamDescrOverrideEvent
Public Event FamDescrOverrideEvent As EventHandler(Of FamDescrOverrideEventArgs)
public:
 event EventHandler<FamDescrOverrideEventArgs^>^ FamDescrOverrideEvent {
    void add (EventHandler<FamDescrOverrideEventArgs^>^ value);
    void remove (EventHandler<FamDescrOverrideEventArgs^>^ value);
}
member FamDescrOverrideEvent : IEvent<EventHandler<FamDescrOverrideEventArgs>,
    FamDescrOverrideEventArgs>

Valore

EventHandler FamDescrOverrideEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.FillAttributeListFilterEvent

Evento DedNetApplicationFillAttributeListFilterEvent
Evento che permette il filtraggio degli attributi in fase di inserimento delle liste utilizzate nell'applicazione

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<FillAttributeListFilterEventArgs> FillAttributeListFilterEvent
Public Event FillAttributeListFilterEvent As EventHandler(Of FillAttributeListFilterEventArgs)
public:
 event EventHandler<FillAttributeListFilterEventArgs^>^ FillAttributeListFilterEvent {
    void add (EventHandler<FillAttributeListFilterEventArgs^>^ value);
    void remove (EventHandler<FillAttributeListFilterEventArgs^>^ value);
}
member FillAttributeListFilterEvent : IEvent<EventHandler<FillAttributeListFilterEventArgs>,
    FillAttributeListFilterEventArgs>

Valore

EventHandler FillAttributeListFilterEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.FilterSearchResultEvent

Evento DedNetApplicationFilterSearchResultEvent
Evento chiamato quando l'utente seleziona un filtro sul risultato ricerca.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DedAnagrViewControlFilterEventArgs> FilterSearchResultEvent
Public Event FilterSearchResultEvent As EventHandler(Of DedAnagrViewControlFilterEventArgs)
public:
 event EventHandler<DedAnagrViewControlFilterEventArgs^>^ FilterSearchResultEvent {
    void add (EventHandler<DedAnagrViewControlFilterEventArgs^>^ value);
    void remove (EventHandler<DedAnagrViewControlFilterEventArgs^>^ value);
}
member FilterSearchResultEvent : IEvent<EventHandler<DedAnagrViewControlFilterEventArgs>,
    DedAnagrViewControlFilterEventArgs>

Valore

EventHandler DedAnagrViewControlFilterEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.FindCodeMultipleAnagrEvent

Evento DedNetApplicationFindCodeMultipleAnagrEvent
Evento chiamato nell'apri veloce nel caso di ricerca su invio con risultato mulitplo.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<FindCodeMultipleResultsEventArgs> FindCodeMultipleAnagrEvent
Public Event FindCodeMultipleAnagrEvent As EventHandler(Of FindCodeMultipleResultsEventArgs)
public:
 event EventHandler<FindCodeMultipleResultsEventArgs^>^ FindCodeMultipleAnagrEvent {
    void add (EventHandler<FindCodeMultipleResultsEventArgs^>^ value);
    void remove (EventHandler<FindCodeMultipleResultsEventArgs^>^ value);
}
member FindCodeMultipleAnagrEvent : IEvent<EventHandler<FindCodeMultipleResultsEventArgs>,
    FindCodeMultipleResultsEventArgs>

Valore

EventHandler FindCodeMultipleResultsEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.FindCodeStateFilterEvent

Evento DedNetApplicationFindCodeStateFilterEvent
Evento che permette di filtrare la lista del form find code in base allo stato dell'anagrafica

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<FindCodeStateFilterEventArgs> FindCodeStateFilterEvent
Public Event FindCodeStateFilterEvent As EventHandler(Of FindCodeStateFilterEventArgs)
public:
 event EventHandler<FindCodeStateFilterEventArgs^>^ FindCodeStateFilterEvent {
    void add (EventHandler<FindCodeStateFilterEventArgs^>^ value);
    void remove (EventHandler<FindCodeStateFilterEventArgs^>^ value);
}
member FindCodeStateFilterEvent : IEvent<EventHandler<FindCodeStateFilterEventArgs>,
    FindCodeStateFilterEventArgs>

Valore

EventHandler FindCodeStateFilterEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.FolderDisableEvent

Evento DedNetApplicationFolderDisableEvent
Evento lanciato in fase di visualizzazione della cartella nel controllo documentale.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<FolderDisableEventArgs> FolderDisableEvent
Public Event FolderDisableEvent As EventHandler(Of FolderDisableEventArgs)
public:
 event EventHandler<FolderDisableEventArgs^>^ FolderDisableEvent {
    void add (EventHandler<FolderDisableEventArgs^>^ value);
    void remove (EventHandler<FolderDisableEventArgs^>^ value);
}
member FolderDisableEvent : IEvent<EventHandler<FolderDisableEventArgs>,
    FolderDisableEventArgs>

Valore

EventHandler FolderDisableEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.FtpClientConnectionEvent

Evento DedNetApplicationFtpClientConnectionEvent
Evento che permette modificare i dati del client FTP.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<FtpClientConnectionEventArgs> FtpClientConnectionEvent
Public Event FtpClientConnectionEvent As EventHandler(Of FtpClientConnectionEventArgs)
public:
 event EventHandler<FtpClientConnectionEventArgs^>^ FtpClientConnectionEvent {
    void add (EventHandler<FtpClientConnectionEventArgs^>^ value);
    void remove (EventHandler<FtpClientConnectionEventArgs^>^ value);
}
member FtpClientConnectionEvent : IEvent<EventHandler<FtpClientConnectionEventArgs>,
    FtpClientConnectionEventArgs>

Valore

EventHandler FtpClientConnectionEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.GetDocPropertiesEvent

Evento DedNetApplicationGetDocPropertiesEvent
Evento che permette di ricavare la lista di proprietà di una serie di file.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<GetDocPropertiesEventArgs> GetDocPropertiesEvent
Public Event GetDocPropertiesEvent As EventHandler(Of GetDocPropertiesEventArgs)
public:
 event EventHandler<GetDocPropertiesEventArgs^>^ GetDocPropertiesEvent {
    void add (EventHandler<GetDocPropertiesEventArgs^>^ value);
    void remove (EventHandler<GetDocPropertiesEventArgs^>^ value);
}
member GetDocPropertiesEvent : IEvent<EventHandler<GetDocPropertiesEventArgs>,
    GetDocPropertiesEventArgs>

Valore

EventHandler GetDocPropertiesEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.GetRepresentationSuffixListEvent

Evento DedNetApplicationGetRepresentationSuffixListEvent
Evento che permette di visualizzare una lista di suffissi in creazione di una Rappresentazione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<GetRepresentationSuffixListEventArgs> GetRepresentationSuffixListEvent
Public Event GetRepresentationSuffixListEvent As EventHandler(Of GetRepresentationSuffixListEventArgs)
public:
 event EventHandler<GetRepresentationSuffixListEventArgs^>^ GetRepresentationSuffixListEvent {
    void add (EventHandler<GetRepresentationSuffixListEventArgs^>^ value);
    void remove (EventHandler<GetRepresentationSuffixListEventArgs^>^ value);
}
member GetRepresentationSuffixListEvent : IEvent<EventHandler<GetRepresentationSuffixListEventArgs>,
    GetRepresentationSuffixListEventArgs>

Valore

EventHandler GetRepresentationSuffixListEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.ImportAttListEvent

Evento DedNetApplicationImportAttListEvent
Evento che permette di importare la lista att di un attributo da una fonte dati esterna.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<ImportAttListEventArgs> ImportAttListEvent
Public Event ImportAttListEvent As EventHandler(Of ImportAttListEventArgs)
public:
 event EventHandler<ImportAttListEventArgs^>^ ImportAttListEvent {
    void add (EventHandler<ImportAttListEventArgs^>^ value);
    void remove (EventHandler<ImportAttListEventArgs^>^ value);
}
member ImportAttListEvent : IEvent<EventHandler<ImportAttListEventArgs>,
    ImportAttListEventArgs>

Valore

EventHandler ImportAttListEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.ImportAttrValueEvent

Evento DedNetApplicationImportAttrValueEvent
Evento che permette di importare il valore di un attributo da una fonte dati esterna.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<ImportAttrValueEventArgs> ImportAttrValueEvent
Public Event ImportAttrValueEvent As EventHandler(Of ImportAttrValueEventArgs)
public:
 event EventHandler<ImportAttrValueEventArgs^>^ ImportAttrValueEvent {
    void add (EventHandler<ImportAttrValueEventArgs^>^ value);
    void remove (EventHandler<ImportAttrValueEventArgs^>^ value);
}
member ImportAttrValueEvent : IEvent<EventHandler<ImportAttrValueEventArgs>,
    ImportAttrValueEventArgs>

Valore

EventHandler ImportAttrValueEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.ImportDataCanUpdateEvent

Evento DedNetApplicationImportDataCanUpdateEvent
Evento che permette di gestire l'anagrafica da aggiornare nel comando Importa Dati.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<ImportDataCanUpdateEventArgs> ImportDataCanUpdateEvent
Public Event ImportDataCanUpdateEvent As EventHandler(Of ImportDataCanUpdateEventArgs)
public:
 event EventHandler<ImportDataCanUpdateEventArgs^>^ ImportDataCanUpdateEvent {
    void add (EventHandler<ImportDataCanUpdateEventArgs^>^ value);
    void remove (EventHandler<ImportDataCanUpdateEventArgs^>^ value);
}
member ImportDataCanUpdateEvent : IEvent<EventHandler<ImportDataCanUpdateEventArgs>,
    ImportDataCanUpdateEventArgs>

Valore

EventHandler ImportDataCanUpdateEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.ImportOnSaveEvent

Evento DedNetApplicationImportOnSaveEvent
Evento per gestire l'azione da attuare in fase di salvataggio dei documenti che sono all'interno delle root definite in ROOTS_RECOGNIZED_ON_DBSAVE.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<ImportOnSaveEventArgs> ImportOnSaveEvent
Public Event ImportOnSaveEvent As EventHandler(Of ImportOnSaveEventArgs)
public:
 event EventHandler<ImportOnSaveEventArgs^>^ ImportOnSaveEvent {
    void add (EventHandler<ImportOnSaveEventArgs^>^ value);
    void remove (EventHandler<ImportOnSaveEventArgs^>^ value);
}
member ImportOnSaveEvent : IEvent<EventHandler<ImportOnSaveEventArgs>,
    ImportOnSaveEventArgs>

Valore

EventHandler ImportOnSaveEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.ImportPackAndGoSelectEvent

Evento DedNetApplicationImportPackAndGoSelectEvent

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<PackAndGoZipFolderEventArgs> ImportPackAndGoSelectEvent
Public Event ImportPackAndGoSelectEvent As EventHandler(Of PackAndGoZipFolderEventArgs)
public:
 event EventHandler<PackAndGoZipFolderEventArgs^>^ ImportPackAndGoSelectEvent {
    void add (EventHandler<PackAndGoZipFolderEventArgs^>^ value);
    void remove (EventHandler<PackAndGoZipFolderEventArgs^>^ value);
}
member ImportPackAndGoSelectEvent : IEvent<EventHandler<PackAndGoZipFolderEventArgs>,
    PackAndGoZipFolderEventArgs>

Valore

EventHandler PackAndGoZipFolderEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.ListImportDataEvent

Evento DedNetApplicationListImportDataEvent
Evento di validazione di un codice durante l'importazione in una lista

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<ListImportDataEventArgs> ListImportDataEvent
Public Event ListImportDataEvent As EventHandler(Of ListImportDataEventArgs)
public:
 event EventHandler<ListImportDataEventArgs^>^ ListImportDataEvent {
    void add (EventHandler<ListImportDataEventArgs^>^ value);
    void remove (EventHandler<ListImportDataEventArgs^>^ value);
}
member ListImportDataEvent : IEvent<EventHandler<ListImportDataEventArgs>,
    ListImportDataEventArgs>

Valore

EventHandler ListImportDataEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.LoadFormCommEditEvent

Evento DedNetApplicationLoadFormCommEditEvent
Evento lanciato al caricamento del form delle commesse.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<LoadFormCommEditEventArgs> LoadFormCommEditEvent
Public Event LoadFormCommEditEvent As EventHandler(Of LoadFormCommEditEventArgs)
public:
 event EventHandler<LoadFormCommEditEventArgs^>^ LoadFormCommEditEvent {
    void add (EventHandler<LoadFormCommEditEventArgs^>^ value);
    void remove (EventHandler<LoadFormCommEditEventArgs^>^ value);
}
member LoadFormCommEditEvent : IEvent<EventHandler<LoadFormCommEditEventArgs>,
    LoadFormCommEditEventArgs>

Valore

EventHandler LoadFormCommEditEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.ManagePlaceHolderLogicComputedEvent

Evento DedNetApplicationManagePlaceHolderLogicComputedEvent
Evento chiamato per permettere l'override della logica di gestione dei placeholder in base a criteri utente

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<ManagePlaceHolderEventArgs> ManagePlaceHolderLogicComputedEvent
Public Event ManagePlaceHolderLogicComputedEvent As EventHandler(Of ManagePlaceHolderEventArgs)
public:
 event EventHandler<ManagePlaceHolderEventArgs^>^ ManagePlaceHolderLogicComputedEvent {
    void add (EventHandler<ManagePlaceHolderEventArgs^>^ value);
    void remove (EventHandler<ManagePlaceHolderEventArgs^>^ value);
}
member ManagePlaceHolderLogicComputedEvent : IEvent<EventHandler<ManagePlaceHolderEventArgs>,
    ManagePlaceHolderEventArgs>

Valore

EventHandler ManagePlaceHolderEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.ManageSelectionDocsEvent

Evento DedNetApplicationManageSelectionDocsEvent
Evento che permette di gestire la selezione dei documenti.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<ManageSelectionDocsEventArgs> ManageSelectionDocsEvent
Public Event ManageSelectionDocsEvent As EventHandler(Of ManageSelectionDocsEventArgs)
public:
 event EventHandler<ManageSelectionDocsEventArgs^>^ ManageSelectionDocsEvent {
    void add (EventHandler<ManageSelectionDocsEventArgs^>^ value);
    void remove (EventHandler<ManageSelectionDocsEventArgs^>^ value);
}
member ManageSelectionDocsEvent : IEvent<EventHandler<ManageSelectionDocsEventArgs>,
    ManageSelectionDocsEventArgs>

Valore

EventHandler ManageSelectionDocsEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.ModifyDocumentBeforeCheckedInEvent

Evento DedNetApplicationModifyDocumentBeforeCheckedInEvent
Evento chiamato per i tecnici in modo che possano modificare il documento prima che il ded faccia tutto nel DocumentCheckedInEvent

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DocStructInfoEventArgs> ModifyDocumentBeforeCheckedInEvent
Public Event ModifyDocumentBeforeCheckedInEvent As EventHandler(Of DocStructInfoEventArgs)
public:
 event EventHandler<DocStructInfoEventArgs^>^ ModifyDocumentBeforeCheckedInEvent {
    void add (EventHandler<DocStructInfoEventArgs^>^ value);
    void remove (EventHandler<DocStructInfoEventArgs^>^ value);
}
member ModifyDocumentBeforeCheckedInEvent : IEvent<EventHandler<DocStructInfoEventArgs>,
    DocStructInfoEventArgs>

Valore

EventHandler DocStructInfoEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.MoveDocumentEvent

Evento DedNetApplicationMoveDocumentEvent
Evento chiamato per effettuare lo spostamento/rinomina di un file. Chi gestisce questo evento si deve preoccupare di spostare sia la copia in locale che quella del server, nel caso di area locale attiva.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<MoveDocumentEventArgs> MoveDocumentEvent
Public Event MoveDocumentEvent As EventHandler(Of MoveDocumentEventArgs)
public:
 event EventHandler<MoveDocumentEventArgs^>^ MoveDocumentEvent {
    void add (EventHandler<MoveDocumentEventArgs^>^ value);
    void remove (EventHandler<MoveDocumentEventArgs^>^ value);
}
member MoveDocumentEvent : IEvent<EventHandler<MoveDocumentEventArgs>,
    MoveDocumentEventArgs>

Valore

EventHandler MoveDocumentEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.MsgDistReplaceSaveEvent

Evento DedNetApplicationMsgDistReplaceSaveEvent
Evento che permette di visualizzare un messaggio prima e/o dopo la sostituzione massiva.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DedBeforeOrAfterEventArgs> MsgDistReplaceSaveEvent
Public Event MsgDistReplaceSaveEvent As EventHandler(Of DedBeforeOrAfterEventArgs)
public:
 event EventHandler<DedBeforeOrAfterEventArgs^>^ MsgDistReplaceSaveEvent {
    void add (EventHandler<DedBeforeOrAfterEventArgs^>^ value);
    void remove (EventHandler<DedBeforeOrAfterEventArgs^>^ value);
}
member MsgDistReplaceSaveEvent : IEvent<EventHandler<DedBeforeOrAfterEventArgs>,
    DedBeforeOrAfterEventArgs>

Valore

EventHandler DedBeforeOrAfterEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.MultipleStateChangeExecute

Evento DedNetApplicationMultipleStateChangeExecute
Evento che permette di verificare la lista delle anagrafiche selezionate durante le operazioni di Rilascio/Lavorazione multiplo

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<MultipleStateChangeExecuteEventArgs> MultipleStateChangeExecute
Public Event MultipleStateChangeExecute As EventHandler(Of MultipleStateChangeExecuteEventArgs)
public:
 event EventHandler<MultipleStateChangeExecuteEventArgs^>^ MultipleStateChangeExecute {
    void add (EventHandler<MultipleStateChangeExecuteEventArgs^>^ value);
    void remove (EventHandler<MultipleStateChangeExecuteEventArgs^>^ value);
}
member MultipleStateChangeExecute : IEvent<EventHandler<MultipleStateChangeExecuteEventArgs>,
    MultipleStateChangeExecuteEventArgs>

Valore

EventHandler MultipleStateChangeExecuteEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.NewAnagrChangedEvent

Evento DedNetApplicationNewAnagrChangedEvent
Evento su modifica dell'anagrafica o di uno dei valori che influenzano la codifica durante la procedura di creazione nuova anagrafica.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<NewAnagrEventArgs> NewAnagrChangedEvent
Public Event NewAnagrChangedEvent As EventHandler(Of NewAnagrEventArgs)
public:
 event EventHandler<NewAnagrEventArgs^>^ NewAnagrChangedEvent {
    void add (EventHandler<NewAnagrEventArgs^>^ value);
    void remove (EventHandler<NewAnagrEventArgs^>^ value);
}
member NewAnagrChangedEvent : IEvent<EventHandler<NewAnagrEventArgs>,
    NewAnagrEventArgs>

Valore

EventHandler NewAnagrEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.NewAnagrCreatedEvent

Evento DedNetApplicationNewAnagrCreatedEvent
Evento chiamato subito dopo aver creato l'anagrafica nel comando di creazione nuovo record.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<NewAnagrEventArgs> NewAnagrCreatedEvent
Public Event NewAnagrCreatedEvent As EventHandler(Of NewAnagrEventArgs)
public:
 event EventHandler<NewAnagrEventArgs^>^ NewAnagrCreatedEvent {
    void add (EventHandler<NewAnagrEventArgs^>^ value);
    void remove (EventHandler<NewAnagrEventArgs^>^ value);
}
member NewAnagrCreatedEvent : IEvent<EventHandler<NewAnagrEventArgs>,
    NewAnagrEventArgs>

Valore

EventHandler NewAnagrEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.NewAnagrInitEvent

Evento DedNetApplicationNewAnagrInitEvent
Evento di inizializzazione dei comandi di creazione nuovo record. Questo evento viene chiamato all'inizio del comando per impostarne le proprietà secondo l'esigenza di personalizzazione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<NewAnagrEventArgs> NewAnagrInitEvent
Public Event NewAnagrInitEvent As EventHandler(Of NewAnagrEventArgs)
public:
 event EventHandler<NewAnagrEventArgs^>^ NewAnagrInitEvent {
    void add (EventHandler<NewAnagrEventArgs^>^ value);
    void remove (EventHandler<NewAnagrEventArgs^>^ value);
}
member NewAnagrInitEvent : IEvent<EventHandler<NewAnagrEventArgs>,
    NewAnagrEventArgs>

Valore

EventHandler NewAnagrEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.NewAnagrValidatingEvent

Evento DedNetApplicationNewAnagrValidatingEvent
Evento di validazione chiamato subito prima la creazione di una nuova anagrafica.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<NewAnagrCancelEventArgs> NewAnagrValidatingEvent
Public Event NewAnagrValidatingEvent As EventHandler(Of NewAnagrCancelEventArgs)
public:
 event EventHandler<NewAnagrCancelEventArgs^>^ NewAnagrValidatingEvent {
    void add (EventHandler<NewAnagrCancelEventArgs^>^ value);
    void remove (EventHandler<NewAnagrCancelEventArgs^>^ value);
}
member NewAnagrValidatingEvent : IEvent<EventHandler<NewAnagrCancelEventArgs>,
    NewAnagrCancelEventArgs>

Valore

EventHandler NewAnagrCancelEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.NewCommChangedEvent

Evento DedNetApplicationNewCommChangedEvent
Evento su modifica della commessa o di uno dei valori durante la procedura di creazione nuova commessa.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<EventArgs> NewCommChangedEvent
Public Event NewCommChangedEvent As EventHandler(Of EventArgs)
public:
 event EventHandler<EventArgs^>^ NewCommChangedEvent {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}
member NewCommChangedEvent : IEvent<EventHandler<EventArgs>,
    EventArgs>

Valore

EventHandler EventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.NoteTransferPackEvent

Evento DedNetApplicationNoteTransferPackEvent
Evento che permette di inserire una Nota nel trasfer pack con gestione della visualizzazione della finestra di inserimento Note

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<NoteTransferPackEventArgs> NoteTransferPackEvent
Public Event NoteTransferPackEvent As EventHandler(Of NoteTransferPackEventArgs)
public:
 event EventHandler<NoteTransferPackEventArgs^>^ NoteTransferPackEvent {
    void add (EventHandler<NoteTransferPackEventArgs^>^ value);
    void remove (EventHandler<NoteTransferPackEventArgs^>^ value);
}
member NoteTransferPackEvent : IEvent<EventHandler<NoteTransferPackEventArgs>,
    NoteTransferPackEventArgs>

Valore

EventHandler NoteTransferPackEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.NotifyEvent

Evento DedNetApplicationNotifyEvent
Evento lanciato per poter modificare le informazioni della notifica e eventualmente cancellarla.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DedNotifyEventArgs> NotifyEvent
Public Event NotifyEvent As EventHandler(Of DedNotifyEventArgs)
public:
 event EventHandler<DedNotifyEventArgs^>^ NotifyEvent {
    void add (EventHandler<DedNotifyEventArgs^>^ value);
    void remove (EventHandler<DedNotifyEventArgs^>^ value);
}
member NotifyEvent : IEvent<EventHandler<DedNotifyEventArgs>,
    DedNotifyEventArgs>

Valore

EventHandler DedNotifyEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.OpenCommandDisableDocumentEvent

Evento DedNetApplicationOpenCommandDisableDocumentEvent
Evento lanciato in fase di apertura dei documenti.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DocumentDisableEventArgs> OpenCommandDisableDocumentEvent
Public Event OpenCommandDisableDocumentEvent As EventHandler(Of DocumentDisableEventArgs)
public:
 event EventHandler<DocumentDisableEventArgs^>^ OpenCommandDisableDocumentEvent {
    void add (EventHandler<DocumentDisableEventArgs^>^ value);
    void remove (EventHandler<DocumentDisableEventArgs^>^ value);
}
member OpenCommandDisableDocumentEvent : IEvent<EventHandler<DocumentDisableEventArgs>,
    DocumentDisableEventArgs>

Valore

EventHandler DocumentDisableEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.OpenDocumentEvent

Evento DedNetApplicationOpenDocumentEvent
Evento di apertura documento. Viene chiamato per intercettare l'apertura di un documento per consentire di sostituirsi all'apertura.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DedOpenCommandEventArgs> OpenDocumentEvent
Public Event OpenDocumentEvent As EventHandler(Of DedOpenCommandEventArgs)
public:
 event EventHandler<DedOpenCommandEventArgs^>^ OpenDocumentEvent {
    void add (EventHandler<DedOpenCommandEventArgs^>^ value);
    void remove (EventHandler<DedOpenCommandEventArgs^>^ value);
}
member OpenDocumentEvent : IEvent<EventHandler<DedOpenCommandEventArgs>,
    DedOpenCommandEventArgs>

Valore

EventHandler DedOpenCommandEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.OrderPriorityListEvent

Evento DedNetApplicationOrderPriorityListEvent
Evento per ordinare la lista delle estensioni prioritarie dai vari CAD.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<CadPriorityExtListEventArgs> OrderPriorityListEvent
Public Event OrderPriorityListEvent As EventHandler(Of CadPriorityExtListEventArgs)
public:
 event EventHandler<CadPriorityExtListEventArgs^>^ OrderPriorityListEvent {
    void add (EventHandler<CadPriorityExtListEventArgs^>^ value);
    void remove (EventHandler<CadPriorityExtListEventArgs^>^ value);
}
member OrderPriorityListEvent : IEvent<EventHandler<CadPriorityExtListEventArgs>,
    CadPriorityExtListEventArgs>

Valore

EventHandler CadPriorityExtListEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.OverrideAttListEvent

Evento DedNetApplicationOverrideAttListEvent
Evento chiamato per la personalizzazione dell'elenco valori associata ad un determinato attributo.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<OverrideAttListEventArgs> OverrideAttListEvent
Public Event OverrideAttListEvent As EventHandler(Of OverrideAttListEventArgs)
public:
 event EventHandler<OverrideAttListEventArgs^>^ OverrideAttListEvent {
    void add (EventHandler<OverrideAttListEventArgs^>^ value);
    void remove (EventHandler<OverrideAttListEventArgs^>^ value);
}
member OverrideAttListEvent : IEvent<EventHandler<OverrideAttListEventArgs>,
    OverrideAttListEventArgs>

Valore

EventHandler OverrideAttListEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.OverrideAttrEvent

Evento DedNetApplicationOverrideAttrEvent
Evento chiamato prima di visualizzare il controllo degli aattributi.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<OverrideAttrEventArgs> OverrideAttrEvent
Public Event OverrideAttrEvent As EventHandler(Of OverrideAttrEventArgs)
public:
 event EventHandler<OverrideAttrEventArgs^>^ OverrideAttrEvent {
    void add (EventHandler<OverrideAttrEventArgs^>^ value);
    void remove (EventHandler<OverrideAttrEventArgs^>^ value);
}
member OverrideAttrEvent : IEvent<EventHandler<OverrideAttrEventArgs>,
    OverrideAttrEventArgs>

Valore

EventHandler OverrideAttrEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.OverrideCommandEnablingEvent

Evento DedNetApplicationOverrideCommandEnablingEvent
Evento usato dagli add-in per effettuare l'override dell'abilitazione dei comandi del Core.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<OverrideCommandEnablingEventArgs> OverrideCommandEnablingEvent
Public Event OverrideCommandEnablingEvent As EventHandler(Of OverrideCommandEnablingEventArgs)
public:
 event EventHandler<OverrideCommandEnablingEventArgs^>^ OverrideCommandEnablingEvent {
    void add (EventHandler<OverrideCommandEnablingEventArgs^>^ value);
    void remove (EventHandler<OverrideCommandEnablingEventArgs^>^ value);
}
member OverrideCommandEnablingEvent : IEvent<EventHandler<OverrideCommandEnablingEventArgs>,
    OverrideCommandEnablingEventArgs>

Valore

EventHandler OverrideCommandEnablingEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.OverrideEnableSaveCommControlEvent

Evento DedNetApplicationOverrideEnableSaveCommControlEvent
Evento da utilizzare per ridefinire l'abilitazione dei controlli nel form di salvataggio commessa

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler OverrideEnableSaveCommControlEvent
Public Event OverrideEnableSaveCommControlEvent As EventHandler
public:
 event EventHandler^ OverrideEnableSaveCommControlEvent {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member OverrideEnableSaveCommControlEvent : IEvent<EventHandler,
    EventArgs>

Valore

EventHandler
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.OverrideEnableSaveControlEvent

Evento DedNetApplicationOverrideEnableSaveControlEvent
Evento da utilizzare per ridefinire l'abilitazione dei controlli nel form di salvataggio

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler OverrideEnableSaveControlEvent
Public Event OverrideEnableSaveControlEvent As EventHandler
public:
 event EventHandler^ OverrideEnableSaveControlEvent {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member OverrideEnableSaveControlEvent : IEvent<EventHandler,
    EventArgs>

Valore

EventHandler
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.OverwriteImportPlaceHolderEvent

Evento DedNetApplicationOverwriteImportPlaceHolderEvent
Evento chiamato per permettere l'ultima ridefinizione del placehodre (parte su tutti i file)

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<OverwriteImportPlaceHolderEventArgs> OverwriteImportPlaceHolderEvent
Public Event OverwriteImportPlaceHolderEvent As EventHandler(Of OverwriteImportPlaceHolderEventArgs)
public:
 event EventHandler<OverwriteImportPlaceHolderEventArgs^>^ OverwriteImportPlaceHolderEvent {
    void add (EventHandler<OverwriteImportPlaceHolderEventArgs^>^ value);
    void remove (EventHandler<OverwriteImportPlaceHolderEventArgs^>^ value);
}
member OverwriteImportPlaceHolderEvent : IEvent<EventHandler<OverwriteImportPlaceHolderEventArgs>,
    OverwriteImportPlaceHolderEventArgs>

Valore

EventHandler OverwriteImportPlaceHolderEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.PostInitEvent

Evento DedNetApplicationPostInitEvent
Evento chiamato alla fine dell'inizializzazione dell'applicazione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler PostInitEvent
Public Event PostInitEvent As EventHandler
public:
 event EventHandler^ PostInitEvent {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member PostInitEvent : IEvent<EventHandler,
    EventArgs>

Valore

EventHandler
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.ProgrCollisionEvent

Evento DedNetApplicationProgrCollisionEvent
Evento lanciato quando si verifica una collisione di progressivi al salvataggio nel DB su una famiglia con infouser.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<ProgrCollisionEventArgs> ProgrCollisionEvent
Public Event ProgrCollisionEvent As EventHandler(Of ProgrCollisionEventArgs)
public:
 event EventHandler<ProgrCollisionEventArgs^>^ ProgrCollisionEvent {
    void add (EventHandler<ProgrCollisionEventArgs^>^ value);
    void remove (EventHandler<ProgrCollisionEventArgs^>^ value);
}
member ProgrCollisionEvent : IEvent<EventHandler<ProgrCollisionEventArgs>,
    ProgrCollisionEventArgs>

Valore

EventHandler ProgrCollisionEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.RecognizerPathDefinedEvent

Evento DedNetApplicationRecognizerPathDefinedEvent
Evento per la specializzazione della filelist dal path definito nel form di registrazione dei documenti

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DocRegognizerClientsEventArgs> RecognizerPathDefinedEvent
Public Event RecognizerPathDefinedEvent As EventHandler(Of DocRegognizerClientsEventArgs)
public:
 event EventHandler<DocRegognizerClientsEventArgs^>^ RecognizerPathDefinedEvent {
    void add (EventHandler<DocRegognizerClientsEventArgs^>^ value);
    void remove (EventHandler<DocRegognizerClientsEventArgs^>^ value);
}
member RecognizerPathDefinedEvent : IEvent<EventHandler<DocRegognizerClientsEventArgs>,
    DocRegognizerClientsEventArgs>

Valore

EventHandler DocRegognizerClientsEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.RedrawAnagrEvent

Evento DedNetApplicationRedrawAnagrEvent
Evento chiamato prima di disegnare le varie celle della ricerca.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<RedrawAnagrEventArgs> RedrawAnagrEvent
Public Event RedrawAnagrEvent As EventHandler(Of RedrawAnagrEventArgs)
public:
 event EventHandler<RedrawAnagrEventArgs^>^ RedrawAnagrEvent {
    void add (EventHandler<RedrawAnagrEventArgs^>^ value);
    void remove (EventHandler<RedrawAnagrEventArgs^>^ value);
}
member RedrawAnagrEvent : IEvent<EventHandler<RedrawAnagrEventArgs>,
    RedrawAnagrEventArgs>

Valore

EventHandler RedrawAnagrEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.RedrawAttrEvent

Evento DedNetApplicationRedrawAttrEvent
Evento chiamato prima di disegnare le varie celle degli attributi.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<RedrawAttrEventArgs> RedrawAttrEvent
Public Event RedrawAttrEvent As EventHandler(Of RedrawAttrEventArgs)
public:
 event EventHandler<RedrawAttrEventArgs^>^ RedrawAttrEvent {
    void add (EventHandler<RedrawAttrEventArgs^>^ value);
    void remove (EventHandler<RedrawAttrEventArgs^>^ value);
}
member RedrawAttrEvent : IEvent<EventHandler<RedrawAttrEventArgs>,
    RedrawAttrEventArgs>

Valore

EventHandler RedrawAttrEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.RedrawCommEvent

Evento DedNetApplicationRedrawCommEvent
Evento chiamato prima di disegnare le varie celle delle commesse.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<RedrawCommEventArgs> RedrawCommEvent
Public Event RedrawCommEvent As EventHandler(Of RedrawCommEventArgs)
public:
 event EventHandler<RedrawCommEventArgs^>^ RedrawCommEvent {
    void add (EventHandler<RedrawCommEventArgs^>^ value);
    void remove (EventHandler<RedrawCommEventArgs^>^ value);
}
member RedrawCommEvent : IEvent<EventHandler<RedrawCommEventArgs>,
    RedrawCommEventArgs>

Valore

EventHandler RedrawCommEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.RedrawDedTypeEvent

Evento DedNetApplicationRedrawDedTypeEvent
Evento chiamato prima di disegnare le varie celle delle famiglie.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<RedrawDedTypeEventArgs> RedrawDedTypeEvent
Public Event RedrawDedTypeEvent As EventHandler(Of RedrawDedTypeEventArgs)
public:
 event EventHandler<RedrawDedTypeEventArgs^>^ RedrawDedTypeEvent {
    void add (EventHandler<RedrawDedTypeEventArgs^>^ value);
    void remove (EventHandler<RedrawDedTypeEventArgs^>^ value);
}
member RedrawDedTypeEvent : IEvent<EventHandler<RedrawDedTypeEventArgs>,
    RedrawDedTypeEventArgs>

Valore

EventHandler RedrawDedTypeEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.RedrawDepEvent

Evento DedNetApplicationRedrawDepEvent
Evento chiamato prima di disegnare le varie celle nell'albero delle dipendeze.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<RedrawDepEventArgs> RedrawDepEvent
Public Event RedrawDepEvent As EventHandler(Of RedrawDepEventArgs)
public:
 event EventHandler<RedrawDepEventArgs^>^ RedrawDepEvent {
    void add (EventHandler<RedrawDepEventArgs^>^ value);
    void remove (EventHandler<RedrawDepEventArgs^>^ value);
}
member RedrawDepEvent : IEvent<EventHandler<RedrawDepEventArgs>,
    RedrawDepEventArgs>

Valore

EventHandler RedrawDepEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.RedrawDistEvent

Evento DedNetApplicationRedrawDistEvent
Evento chiamato prima di disegnare le varie celle delle distinte.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<RedrawDistEventArgs> RedrawDistEvent
Public Event RedrawDistEvent As EventHandler(Of RedrawDistEventArgs)
public:
 event EventHandler<RedrawDistEventArgs^>^ RedrawDistEvent {
    void add (EventHandler<RedrawDistEventArgs^>^ value);
    void remove (EventHandler<RedrawDistEventArgs^>^ value);
}
member RedrawDistEvent : IEvent<EventHandler<RedrawDistEventArgs>,
    RedrawDistEventArgs>

Valore

EventHandler RedrawDistEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.ReferenceUpdateOperationEvent

Evento DedNetApplicationReferenceUpdateOperationEvent
Evento che permette ai CAD e ai plugin di registrarsi ai delegate del comando UpdateDocumentReference.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<ReferenceUpdateOperationEventArgs> ReferenceUpdateOperationEvent
Public Event ReferenceUpdateOperationEvent As EventHandler(Of ReferenceUpdateOperationEventArgs)
public:
 event EventHandler<ReferenceUpdateOperationEventArgs^>^ ReferenceUpdateOperationEvent {
    void add (EventHandler<ReferenceUpdateOperationEventArgs^>^ value);
    void remove (EventHandler<ReferenceUpdateOperationEventArgs^>^ value);
}
member ReferenceUpdateOperationEvent : IEvent<EventHandler<ReferenceUpdateOperationEventArgs>,
    ReferenceUpdateOperationEventArgs>

Valore

EventHandler ReferenceUpdateOperationEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.RemoveAnagrEvent

Evento DedNetApplicationRemoveAnagrEvent
Evento chiamato nell'eliminazione di un'anagrafica.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<RemoveAnagrEventArgs> RemoveAnagrEvent
Public Event RemoveAnagrEvent As EventHandler(Of RemoveAnagrEventArgs)
public:
 event EventHandler<RemoveAnagrEventArgs^>^ RemoveAnagrEvent {
    void add (EventHandler<RemoveAnagrEventArgs^>^ value);
    void remove (EventHandler<RemoveAnagrEventArgs^>^ value);
}
member RemoveAnagrEvent : IEvent<EventHandler<RemoveAnagrEventArgs>,
    RemoveAnagrEventArgs>

Valore

EventHandler RemoveAnagrEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.RemoveDocumentEvent

Evento DedNetApplicationRemoveDocumentEvent
Evento chiamato quando l'utente elimina un documento.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DedEventArgs> RemoveDocumentEvent
Public Event RemoveDocumentEvent As EventHandler(Of DedEventArgs)
public:
 event EventHandler<DedEventArgs^>^ RemoveDocumentEvent {
    void add (EventHandler<DedEventArgs^>^ value);
    void remove (EventHandler<DedEventArgs^>^ value);
}
member RemoveDocumentEvent : IEvent<EventHandler<DedEventArgs>,
    DedEventArgs>

Valore

EventHandler DedEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.ResetSearchCriteriaEvent

Evento DedNetApplicationResetSearchCriteriaEvent
Evento chiamato quanto l'utente preme il tasto di reset dei criteri della ricerca

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DedBeforeOrAfterEventArgs> ResetSearchCriteriaEvent
Public Event ResetSearchCriteriaEvent As EventHandler(Of DedBeforeOrAfterEventArgs)
public:
 event EventHandler<DedBeforeOrAfterEventArgs^>^ ResetSearchCriteriaEvent {
    void add (EventHandler<DedBeforeOrAfterEventArgs^>^ value);
    void remove (EventHandler<DedBeforeOrAfterEventArgs^>^ value);
}
member ResetSearchCriteriaEvent : IEvent<EventHandler<DedBeforeOrAfterEventArgs>,
    DedBeforeOrAfterEventArgs>

Valore

EventHandler DedBeforeOrAfterEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.SaveCustomButtonClickEvent

Evento DedNetApplicationSaveCustomButtonClickEvent
Evento chiamato alla pressione dei pulsanti personalizzati della finestra di salva.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler SaveCustomButtonClickEvent
Public Event SaveCustomButtonClickEvent As EventHandler
public:
 event EventHandler^ SaveCustomButtonClickEvent {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member SaveCustomButtonClickEvent : IEvent<EventHandler,
    EventArgs>

Valore

EventHandler
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.SaveDistOnApprovedEvent

Evento DedNetApplicationSaveDistOnApprovedEvent
Evento che permette di decidere il comportamento sul salvataggio distinta al rilascio

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<SaveDistOnApprovedEventArgs> SaveDistOnApprovedEvent
Public Event SaveDistOnApprovedEvent As EventHandler(Of SaveDistOnApprovedEventArgs)
public:
 event EventHandler<SaveDistOnApprovedEventArgs^>^ SaveDistOnApprovedEvent {
    void add (EventHandler<SaveDistOnApprovedEventArgs^>^ value);
    void remove (EventHandler<SaveDistOnApprovedEventArgs^>^ value);
}
member SaveDistOnApprovedEvent : IEvent<EventHandler<SaveDistOnApprovedEventArgs>,
    SaveDistOnApprovedEventArgs>

Valore

EventHandler SaveDistOnApprovedEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.SendToCommandDisableDocumentEvent

Evento DedNetApplicationSendToCommandDisableDocumentEvent
Evento lanciato in fase di invio dei documenti.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DocumentDisableEventArgs> SendToCommandDisableDocumentEvent
Public Event SendToCommandDisableDocumentEvent As EventHandler(Of DocumentDisableEventArgs)
public:
 event EventHandler<DocumentDisableEventArgs^>^ SendToCommandDisableDocumentEvent {
    void add (EventHandler<DocumentDisableEventArgs^>^ value);
    void remove (EventHandler<DocumentDisableEventArgs^>^ value);
}
member SendToCommandDisableDocumentEvent : IEvent<EventHandler<DocumentDisableEventArgs>,
    DocumentDisableEventArgs>

Valore

EventHandler DocumentDisableEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.SetDefaultFindCodeFilterEvent

Evento DedNetApplicationSetDefaultFindCodeFilterEvent
Evento che permette di definire l'attributo di ricerca utilizzato nel DedFindCodeControl.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<SetDefaultFindCodeFilterEventArgs> SetDefaultFindCodeFilterEvent
Public Event SetDefaultFindCodeFilterEvent As EventHandler(Of SetDefaultFindCodeFilterEventArgs)
public:
 event EventHandler<SetDefaultFindCodeFilterEventArgs^>^ SetDefaultFindCodeFilterEvent {
    void add (EventHandler<SetDefaultFindCodeFilterEventArgs^>^ value);
    void remove (EventHandler<SetDefaultFindCodeFilterEventArgs^>^ value);
}
member SetDefaultFindCodeFilterEvent : IEvent<EventHandler<SetDefaultFindCodeFilterEventArgs>,
    SetDefaultFindCodeFilterEventArgs>

Valore

EventHandler SetDefaultFindCodeFilterEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.ShowPreviewEvent

Evento DedNetApplicationShowPreviewEvent
Evento chiamato per la visualizzazione del preview.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<ShowPreviewEventArgs> ShowPreviewEvent
Public Event ShowPreviewEvent As EventHandler(Of ShowPreviewEventArgs)
public:
 event EventHandler<ShowPreviewEventArgs^>^ ShowPreviewEvent {
    void add (EventHandler<ShowPreviewEventArgs^>^ value);
    void remove (EventHandler<ShowPreviewEventArgs^>^ value);
}
member ShowPreviewEvent : IEvent<EventHandler<ShowPreviewEventArgs>,
    ShowPreviewEventArgs>

Valore

EventHandler ShowPreviewEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.ShowReplaceAnagrDistFormEvent

Evento DedNetApplicationShowReplaceAnagrDistFormEvent
Evento chiamato al caricamento della finestra di sostituzione anagrafica in distinte.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler ShowReplaceAnagrDistFormEvent
Public Event ShowReplaceAnagrDistFormEvent As EventHandler
public:
 event EventHandler^ ShowReplaceAnagrDistFormEvent {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member ShowReplaceAnagrDistFormEvent : IEvent<EventHandler,
    EventArgs>

Valore

EventHandler
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.ShowSaveFormEvent

Evento DedNetApplicationShowSaveFormEvent
Evento chiamato al caricamento della finestra di salva.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler ShowSaveFormEvent
Public Event ShowSaveFormEvent As EventHandler
public:
 event EventHandler^ ShowSaveFormEvent {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member ShowSaveFormEvent : IEvent<EventHandler,
    EventArgs>

Valore

EventHandler
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.ShowZoomPreviewEvent

Evento DedNetApplicationShowZoomPreviewEvent
Evento chiamato per la visualizzazione del preview ( zoom ).

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<ShowZoomPreviewEventArgs> ShowZoomPreviewEvent
Public Event ShowZoomPreviewEvent As EventHandler(Of ShowZoomPreviewEventArgs)
public:
 event EventHandler<ShowZoomPreviewEventArgs^>^ ShowZoomPreviewEvent {
    void add (EventHandler<ShowZoomPreviewEventArgs^>^ value);
    void remove (EventHandler<ShowZoomPreviewEventArgs^>^ value);
}
member ShowZoomPreviewEvent : IEvent<EventHandler<ShowZoomPreviewEventArgs>,
    ShowZoomPreviewEventArgs>

Valore

EventHandler ShowZoomPreviewEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.SkipDocumentStatusOnSaveDistEvent

Evento DedNetApplicationSkipDocumentStatusOnSaveDistEvent
Evento lanciato per fare determinare dai client se un documento debba essere skippato in fase di controllo dello stato nel salva distinta

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<SkipDocumentStatusOnSaveDistEventArgs> SkipDocumentStatusOnSaveDistEvent
Public Event SkipDocumentStatusOnSaveDistEvent As EventHandler(Of SkipDocumentStatusOnSaveDistEventArgs)
public:
 event EventHandler<SkipDocumentStatusOnSaveDistEventArgs^>^ SkipDocumentStatusOnSaveDistEvent {
    void add (EventHandler<SkipDocumentStatusOnSaveDistEventArgs^>^ value);
    void remove (EventHandler<SkipDocumentStatusOnSaveDistEventArgs^>^ value);
}
member SkipDocumentStatusOnSaveDistEvent : IEvent<EventHandler<SkipDocumentStatusOnSaveDistEventArgs>,
    SkipDocumentStatusOnSaveDistEventArgs>

Valore

EventHandler SkipDocumentStatusOnSaveDistEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.SkipUpdateAttribListEvent

Evento DedNetApplicationSkipUpdateAttribListEvent

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<SkipEsclAttribEventArgs> SkipUpdateAttribListEvent
Public Event SkipUpdateAttribListEvent As EventHandler(Of SkipEsclAttribEventArgs)
public:
 event EventHandler<SkipEsclAttribEventArgs^>^ SkipUpdateAttribListEvent {
    void add (EventHandler<SkipEsclAttribEventArgs^>^ value);
    void remove (EventHandler<SkipEsclAttribEventArgs^>^ value);
}
member SkipUpdateAttribListEvent : IEvent<EventHandler<SkipEsclAttribEventArgs>,
    SkipEsclAttribEventArgs>

Valore

EventHandler SkipEsclAttribEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.StateChangedEvent

Evento DedNetApplicationStateChangedEvent
Evento chiamato al cambio di stato di un'anagrafica.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<StateChangedEventArgs> StateChangedEvent
Public Event StateChangedEvent As EventHandler(Of StateChangedEventArgs)
public:
 event EventHandler<StateChangedEventArgs^>^ StateChangedEvent {
    void add (EventHandler<StateChangedEventArgs^>^ value);
    void remove (EventHandler<StateChangedEventArgs^>^ value);
}
member StateChangedEvent : IEvent<EventHandler<StateChangedEventArgs>,
    StateChangedEventArgs>

Valore

EventHandler StateChangedEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.StateCommandDocCloseEvent

Evento DedNetApplicationStateCommandDocCloseEvent
Evento di chiusura dopo elaborazione documento.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<StateCommandEventArgs> StateCommandDocCloseEvent
Public Event StateCommandDocCloseEvent As EventHandler(Of StateCommandEventArgs)
public:
 event EventHandler<StateCommandEventArgs^>^ StateCommandDocCloseEvent {
    void add (EventHandler<StateCommandEventArgs^>^ value);
    void remove (EventHandler<StateCommandEventArgs^>^ value);
}
member StateCommandDocCloseEvent : IEvent<EventHandler<StateCommandEventArgs>,
    StateCommandEventArgs>

Valore

EventHandler StateCommandEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.StateCommandDocOpenEvent

Evento DedNetApplicationStateCommandDocOpenEvent
Evento di apertura per elaborazione documento.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<StateCommandEventArgs> StateCommandDocOpenEvent
Public Event StateCommandDocOpenEvent As EventHandler(Of StateCommandEventArgs)
public:
 event EventHandler<StateCommandEventArgs^>^ StateCommandDocOpenEvent {
    void add (EventHandler<StateCommandEventArgs^>^ value);
    void remove (EventHandler<StateCommandEventArgs^>^ value);
}
member StateCommandDocOpenEvent : IEvent<EventHandler<StateCommandEventArgs>,
    StateCommandEventArgs>

Valore

EventHandler StateCommandEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.StateCommandDocPublishEraseEvent

Evento DedNetApplicationStateCommandDocPublishEraseEvent
Evento di cancellazione documenti pubblicazione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<StateCommandEventArgs> StateCommandDocPublishEraseEvent
Public Event StateCommandDocPublishEraseEvent As EventHandler(Of StateCommandEventArgs)
public:
 event EventHandler<StateCommandEventArgs^>^ StateCommandDocPublishEraseEvent {
    void add (EventHandler<StateCommandEventArgs^>^ value);
    void remove (EventHandler<StateCommandEventArgs^>^ value);
}
member StateCommandDocPublishEraseEvent : IEvent<EventHandler<StateCommandEventArgs>,
    StateCommandEventArgs>

Valore

EventHandler StateCommandEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.StateCommandDocPublishEvent

Evento DedNetApplicationStateCommandDocPublishEvent
Evento di pubblicazione documento.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<StateCommandEventArgs> StateCommandDocPublishEvent
Public Event StateCommandDocPublishEvent As EventHandler(Of StateCommandEventArgs)
public:
 event EventHandler<StateCommandEventArgs^>^ StateCommandDocPublishEvent {
    void add (EventHandler<StateCommandEventArgs^>^ value);
    void remove (EventHandler<StateCommandEventArgs^>^ value);
}
member StateCommandDocPublishEvent : IEvent<EventHandler<StateCommandEventArgs>,
    StateCommandEventArgs>

Valore

EventHandler StateCommandEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.StateCommandDocsPublishedEvent

Evento DedNetApplicationStateCommandDocsPublishedEvent
Evento di post pubblicazione di tutti i documenti dell'anagrafica rilasciata

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DedCommandEventArgs> StateCommandDocsPublishedEvent
Public Event StateCommandDocsPublishedEvent As EventHandler(Of DedCommandEventArgs)
public:
 event EventHandler<DedCommandEventArgs^>^ StateCommandDocsPublishedEvent {
    void add (EventHandler<DedCommandEventArgs^>^ value);
    void remove (EventHandler<DedCommandEventArgs^>^ value);
}
member StateCommandDocsPublishedEvent : IEvent<EventHandler<DedCommandEventArgs>,
    DedCommandEventArgs>

Valore

EventHandler DedCommandEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.StateCommandEventEvent

Evento DedNetApplicationStateCommandEventEvent
Evento generato dal comando di modifica stato anagrafica.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DedCommandEventArgs> StateCommandEventEvent
Public Event StateCommandEventEvent As EventHandler(Of DedCommandEventArgs)
public:
 event EventHandler<DedCommandEventArgs^>^ StateCommandEventEvent {
    void add (EventHandler<DedCommandEventArgs^>^ value);
    void remove (EventHandler<DedCommandEventArgs^>^ value);
}
member StateCommandEventEvent : IEvent<EventHandler<DedCommandEventArgs>,
    DedCommandEventArgs>

Valore

EventHandler DedCommandEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.StateCommmandDocWriteEvent

Evento DedNetApplicationStateCommmandDocWriteEvent
Evento di scrittura documento prima della pubblicazione

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<StateCommandEventArgs> StateCommmandDocWriteEvent
Public Event StateCommmandDocWriteEvent As EventHandler(Of StateCommandEventArgs)
public:
 event EventHandler<StateCommandEventArgs^>^ StateCommmandDocWriteEvent {
    void add (EventHandler<StateCommandEventArgs^>^ value);
    void remove (EventHandler<StateCommandEventArgs^>^ value);
}
member StateCommmandDocWriteEvent : IEvent<EventHandler<StateCommandEventArgs>,
    StateCommandEventArgs>

Valore

EventHandler StateCommandEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.StateElaboratingDocumentsEvent

Evento DedNetApplicationStateElaboratingDocumentsEvent
Evento generato prima della elaborazione dei documenti in modifica stato anagrafica

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DocumentsEventArgs> StateElaboratingDocumentsEvent
Public Event StateElaboratingDocumentsEvent As EventHandler(Of DocumentsEventArgs)
public:
 event EventHandler<DocumentsEventArgs^>^ StateElaboratingDocumentsEvent {
    void add (EventHandler<DocumentsEventArgs^>^ value);
    void remove (EventHandler<DocumentsEventArgs^>^ value);
}
member StateElaboratingDocumentsEvent : IEvent<EventHandler<DocumentsEventArgs>,
    DocumentsEventArgs>

Valore

EventHandler DocumentsEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.TypeAddedEvent

Evento DedNetApplicationTypeAddedEvent
Evento chiamato quando viene aggiunta una famiglia tramite il QsManager ( crea/incolla )

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<QsManagerEventArgs> TypeAddedEvent
Public Event TypeAddedEvent As EventHandler(Of QsManagerEventArgs)
public:
 event EventHandler<QsManagerEventArgs^>^ TypeAddedEvent {
    void add (EventHandler<QsManagerEventArgs^>^ value);
    void remove (EventHandler<QsManagerEventArgs^>^ value);
}
member TypeAddedEvent : IEvent<EventHandler<QsManagerEventArgs>,
    QsManagerEventArgs>

Valore

EventHandler QsManagerEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.TypesReloadedEvent

Evento DedNetApplicationTypesReloadedEvent
Evento chiamato quando vengono ricaricate le famiglie dei tipi e tutta la struttura degli oggetti.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<EventArgs> TypesReloadedEvent
Public Event TypesReloadedEvent As EventHandler(Of EventArgs)
public:
 event EventHandler<EventArgs^>^ TypesReloadedEvent {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}
member TypesReloadedEvent : IEvent<EventHandler<EventArgs>,
    EventArgs>

Valore

EventHandler EventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.UnRilErasePublishEvent

Evento DedNetApplicationUnRilErasePublishEvent
Evento che permette la personalizzazione e l'override delle opzioni di eliminazione dei documenti di pubblicazione in cambio stato

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<UnRilErasePublishEventArgs> UnRilErasePublishEvent
Public Event UnRilErasePublishEvent As EventHandler(Of UnRilErasePublishEventArgs)
public:
 event EventHandler<UnRilErasePublishEventArgs^>^ UnRilErasePublishEvent {
    void add (EventHandler<UnRilErasePublishEventArgs^>^ value);
    void remove (EventHandler<UnRilErasePublishEventArgs^>^ value);
}
member UnRilErasePublishEvent : IEvent<EventHandler<UnRilErasePublishEventArgs>,
    UnRilErasePublishEventArgs>

Valore

EventHandler UnRilErasePublishEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.UpgradeAnagrCommEvent

Evento DedNetApplicationUpgradeAnagrCommEvent
Evento sull'aggiornamento delle anagrafiche in commessa

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<UpgradeAnagrCommEventArgs> UpgradeAnagrCommEvent
Public Event UpgradeAnagrCommEvent As EventHandler(Of UpgradeAnagrCommEventArgs)
public:
 event EventHandler<UpgradeAnagrCommEventArgs^>^ UpgradeAnagrCommEvent {
    void add (EventHandler<UpgradeAnagrCommEventArgs^>^ value);
    void remove (EventHandler<UpgradeAnagrCommEventArgs^>^ value);
}
member UpgradeAnagrCommEvent : IEvent<EventHandler<UpgradeAnagrCommEventArgs>,
    UpgradeAnagrCommEventArgs>

Valore

EventHandler UpgradeAnagrCommEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.ValidateCheckFunctionEvent

Evento DedNetApplicationValidateCheckFunctionEvent
Evento chiamato quando vengono validati gli attributi che hanno una funzione di controllo.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<ValidateCheckFunctionEventArgs> ValidateCheckFunctionEvent
Public Event ValidateCheckFunctionEvent As EventHandler(Of ValidateCheckFunctionEventArgs)
public:
 event EventHandler<ValidateCheckFunctionEventArgs^>^ ValidateCheckFunctionEvent {
    void add (EventHandler<ValidateCheckFunctionEventArgs^>^ value);
    void remove (EventHandler<ValidateCheckFunctionEventArgs^>^ value);
}
member ValidateCheckFunctionEvent : IEvent<EventHandler<ValidateCheckFunctionEventArgs>,
    ValidateCheckFunctionEventArgs>

Valore

EventHandler ValidateCheckFunctionEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.ValidateCommPropertyEvent

Evento DedNetApplicationValidateCommPropertyEvent
Evento chiamato quando vengono validati gli attributi della commessa.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<ValidateFamPropertyEventArgs> ValidateCommPropertyEvent
Public Event ValidateCommPropertyEvent As EventHandler(Of ValidateFamPropertyEventArgs)
public:
 event EventHandler<ValidateFamPropertyEventArgs^>^ ValidateCommPropertyEvent {
    void add (EventHandler<ValidateFamPropertyEventArgs^>^ value);
    void remove (EventHandler<ValidateFamPropertyEventArgs^>^ value);
}
member ValidateCommPropertyEvent : IEvent<EventHandler<ValidateFamPropertyEventArgs>,
    ValidateFamPropertyEventArgs>

Valore

EventHandler ValidateFamPropertyEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Evento DedNetApplication.ValidateFamPropertyEvent

Evento DedNetApplicationValidateFamPropertyEvent
Evento chiamato quando vengono validati gli attributi della famiglia.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<ValidateFamPropertyEventArgs> ValidateFamPropertyEvent
Public Event ValidateFamPropertyEvent As EventHandler(Of ValidateFamPropertyEventArgs)
public:
 event EventHandler<ValidateFamPropertyEventArgs^>^ ValidateFamPropertyEvent {
    void add (EventHandler<ValidateFamPropertyEventArgs^>^ value);
    void remove (EventHandler<ValidateFamPropertyEventArgs^>^ value);
}
member ValidateFamPropertyEvent : IEvent<EventHandler<ValidateFamPropertyEventArgs>,
    ValidateFamPropertyEventArgs>

Valore

EventHandler ValidateFamPropertyEventArgs
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Campi di DedNetApplication

Il tipo DedNetApplication espone i seguenti membri.

Campi
 | Nome | Descrizione
 | DefaultConfig |
Campo pubblico | ExecutingDbFix |
 | NeutralLanguage | Lingua neutrale utilizzata come default. Attenzione! Se si vuole cambiare questo valore si dovrà poi cambiare anche il valore "Neutral Language" specificato nelle informazioni di ogni assembly (per fare ciò basta cercare la stringa "NeutralResourcesLanguage"). Il valore di questo campo segue quello specificato nel "NeutralResourcesLanguage", di conseguenza se i valori sono diversi, questo valore dovrà essere aggiornato con quello specificato nel "NeutralResourcesLanguage".
 | RecurrentTiming | Nome della chiave di registro in cui sono salvate le temporizzazioni ricorrenti.
 | UnkwownConfig |
Torna su
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Campo DedNetApplication.DefaultConfig

Campo DedNetApplicationDefaultConfig

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string DefaultConfig = "*"
Public Const DefaultConfig As String = "*"
public:
literal String^ DefaultConfig = "*"
static val mutable DefaultConfig: string

Valore del campo

String
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Campo DedNetApplication.ExecutingDbFix

Campo DedNetApplicationExecutingDbFix

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ExecutingDbFix
Public ExecutingDbFix As Boolean
public:
bool ExecutingDbFix
val mutable ExecutingDbFix: bool

Valore del campo

Boolean
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Campo DedNetApplication.NeutralLanguage

Campo DedNetApplicationNeutralLanguage
Lingua neutrale utilizzata come default. Attenzione! Se si vuole cambiare questo valore si dovrà poi cambiare anche il valore "Neutral Language" specificato nelle informazioni di ogni assembly (per fare ciò basta cercare la stringa "NeutralResourcesLanguage"). Il valore di questo campo segue quello specificato nel "NeutralResourcesLanguage", di conseguenza se i valori sono diversi, questo valore dovrà essere aggiornato con quello specificato nel "NeutralResourcesLanguage".

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string NeutralLanguage = "it-IT"
Public Const NeutralLanguage As String = "it-IT"
public:
literal String^ NeutralLanguage = "it-IT"
static val mutable NeutralLanguage: string

Valore del campo

String
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Campo DedNetApplication.RecurrentTiming

Campo DedNetApplicationRecurrentTiming
Nome della chiave di registro in cui sono salvate le temporizzazioni ricorrenti.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string RecurrentTiming = "RecurrentTiming"
Public Const RecurrentTiming As String = "RecurrentTiming"
public:
literal String^ RecurrentTiming = "RecurrentTiming"
static val mutable RecurrentTiming: string

Valore del campo

String
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Campo DedNetApplication.UnkwownConfig

Campo DedNetApplicationUnkwownConfig

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string UnkwownConfig = "?"
Public Const UnkwownConfig As String = "?"
public:
literal String^ UnkwownConfig = "?"
static val mutable UnkwownConfig: string

Valore del campo

String
Vedi anche

Documentazione

Classe DedNetApplication
Namespace DedNet


Classe DedNotifyEventArgs
Argomento per l'evento di gestione delle notifiche.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetDedNotifyEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedNotifyEventArgs : CancelEventArgs
Public Class DedNotifyEventArgs
    Inherits CancelEventArgs
public ref class DedNotifyEventArgs : public CancelEventArgs
type DedNotifyEventArgs =
    class
        inherit CancelEventArgs
    end

Il tipo DedNotifyEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNotifyEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Attachments | Allegati della mail
Proprietà pubblica | Body | Corpo della notifica.
Proprietà pubblica | Cc | Destinatari in copia conoscenza.
Proprietà pubblica | Ccn | Destinatari in copia conoscenza nascosta.
Proprietà pubblica | Comms | Restituisce le commessa interessate.
Proprietà pubblica | Datas | Restituisce le anagrafiche interessate.
Proprietà pubblica | Eco | Restituisce le commessa interessate.
Proprietà pubblica | Notify | Restituisce la notifica.
Proprietà pubblica | Obj | Oggetto della notifica.
Proprietà pubblica | To | Destrinatari della notifica.
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore DedNotifyEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedNotifyEventArgs()
Public Sub New
public:
DedNotifyEventArgs()
new : unit -> DedNotifyEventArgs
Vedi anche

Documentazione

Classe DedNotifyEventArgs
Namespace DedNet


Proprietà di DedNotifyEventArgs

Il tipo DedNotifyEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Attachments | Allegati della mail
Proprietà pubblica | Body | Corpo della notifica.
Proprietà pubblica | Cc | Destinatari in copia conoscenza.
Proprietà pubblica | Ccn | Destinatari in copia conoscenza nascosta.
Proprietà pubblica | Comms | Restituisce le commessa interessate.
Proprietà pubblica | Datas | Restituisce le anagrafiche interessate.
Proprietà pubblica | Eco | Restituisce le commessa interessate.
Proprietà pubblica | Notify | Restituisce la notifica.
Proprietà pubblica | Obj | Oggetto della notifica.
Proprietà pubblica | To | Destrinatari della notifica.
Torna su
Vedi anche

Documentazione

Classe DedNotifyEventArgs
Namespace DedNet


Proprietà DedNotifyEventArgs.Attachments

Proprietà DedNotifyEventArgsAttachments
Allegati della mail

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> Attachments { get; set; }
Public Property Attachments As List(Of String)
    Get
    Set
public:
property List<String^>^ Attachments {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
member Attachments : List<string> with get, set

Valore della proprietà

List String
Vedi anche

Documentazione

Classe DedNotifyEventArgs
Namespace DedNet


Proprietà DedNotifyEventArgs.Body

Proprietà DedNotifyEventArgsBody
Corpo della notifica.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Body { get; set; }
Public Property Body As String
    Get
    Set
public:
property String^ Body {
    String^ get ();
    void set (String^ value);
}
member Body : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNotifyEventArgs
Namespace DedNet


Proprietà DedNotifyEventArgs.Cc

Proprietà DedNotifyEventArgsCc
Destinatari in copia conoscenza.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Cc { get; set; }
Public Property Cc As String
    Get
    Set
public:
property String^ Cc {
    String^ get ();
    void set (String^ value);
}
member Cc : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNotifyEventArgs
Namespace DedNet


Proprietà DedNotifyEventArgs.Ccn

Proprietà DedNotifyEventArgsCcn
Destinatari in copia conoscenza nascosta.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Ccn { get; set; }
Public Property Ccn As String
    Get
    Set
public:
property String^ Ccn {
    String^ get ();
    void set (String^ value);
}
member Ccn : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNotifyEventArgs
Namespace DedNet


Proprietà DedNotifyEventArgs.Comms

Proprietà DedNotifyEventArgsComms
Restituisce le commessa interessate.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommList Comms { get; }
Public ReadOnly Property Comms As DedCommList
    Get
public:
property DedCommList^ Comms {
    DedCommList^ get ();
}
member Comms : DedCommList with get

Valore della proprietà

DedCommList
Vedi anche

Documentazione

Classe DedNotifyEventArgs
Namespace DedNet


Proprietà DedNotifyEventArgs.Datas

Proprietà DedNotifyEventArgsDatas
Restituisce le anagrafiche interessate.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataList Datas { get; }
Public ReadOnly Property Datas As DedDataList
    Get
public:
property DedDataList^ Datas {
    DedDataList^ get ();
}
member Datas : DedDataList with get

Valore della proprietà

DedDataList
Vedi anche

Documentazione

Classe DedNotifyEventArgs
Namespace DedNet


Proprietà DedNotifyEventArgs.Eco

Proprietà DedNotifyEventArgsEco
Restituisce le commessa interessate.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEco Eco { get; }
Public ReadOnly Property Eco As DedEco
    Get
public:
property DedEco^ Eco {
    DedEco^ get ();
}
member Eco : DedEco with get

Valore della proprietà

DedEco
Vedi anche

Documentazione

Classe DedNotifyEventArgs
Namespace DedNet


Proprietà DedNotifyEventArgs.Notify

Proprietà DedNotifyEventArgsNotify
Restituisce la notifica.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedNotify Notify { get; }
Public ReadOnly Property Notify As DedNotify
    Get
public:
property DedNotify^ Notify {
    DedNotify^ get ();
}
member Notify : DedNotify with get

Valore della proprietà

DedNotify
Vedi anche

Documentazione

Classe DedNotifyEventArgs
Namespace DedNet


Proprietà DedNotifyEventArgs.Obj

Proprietà DedNotifyEventArgsObj
Oggetto della notifica.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Obj { get; set; }
Public Property Obj As String
    Get
    Set
public:
property String^ Obj {
    String^ get ();
    void set (String^ value);
}
member Obj : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNotifyEventArgs
Namespace DedNet


Proprietà DedNotifyEventArgs.To

Proprietà DedNotifyEventArgsTo
Destrinatari della notifica.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string To { get; set; }
Public Property To As String
    Get
    Set
public:
property String^ To {
    String^ get ();
    void set (String^ value);
}
member To : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNotifyEventArgs
Namespace DedNet


Classe DedOpenCommandEventArgs
Argomento per informazioni relative al comando di apertura.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetDedBeforeOrAfterEventArgs
DedNetDedEventArgs
DedNetDedCommandEventArgs
DedNetDedOpenCommandEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedOpenCommandEventArgs : DedCommandEventArgs
Public Class DedOpenCommandEventArgs
    Inherits DedCommandEventArgs
public ref class DedOpenCommandEventArgs : public DedCommandEventArgs
type DedOpenCommandEventArgs =
    class
        inherit DedCommandEventArgs
    end

Il tipo DedOpenCommandEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedOpenCommandEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Command | Restituisce il comando in esecuzione. (Ereditato da DedCommandEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | DocAnagrInfo | Restituisce le informazioni di associazione anagrafica relative al documento in apertura.
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | FullFileName | Restituisce il nome completo del file da aprire.
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Proprietà pubblica | ReadOnly | Restituisce se si tratti di una apertura in sola lettura.
Proprietà pubblica | RunningContext | Contesto di lancio del comando (Ereditato da DedCommandEventArgs)
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore DedOpenCommandEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedOpenCommandEventArgs()
Public Sub New
public:
DedOpenCommandEventArgs()
new : unit -> DedOpenCommandEventArgs
Vedi anche

Documentazione

Classe DedOpenCommandEventArgs
Namespace DedNet


Proprietà di DedOpenCommandEventArgs

Il tipo DedOpenCommandEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Command | Restituisce il comando in esecuzione. (Ereditato da DedCommandEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | DocAnagrInfo | Restituisce le informazioni di associazione anagrafica relative al documento in apertura.
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | FullFileName | Restituisce il nome completo del file da aprire.
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Proprietà pubblica | ReadOnly | Restituisce se si tratti di una apertura in sola lettura.
Proprietà pubblica | RunningContext | Contesto di lancio del comando (Ereditato da DedCommandEventArgs)
Torna su
Vedi anche

Documentazione

Classe DedOpenCommandEventArgs
Namespace DedNet


Proprietà DedOpenCommandEventArgs.DocAnagrInfo

Proprietà DedOpenCommandEventArgsDocAnagrInfo
Restituisce le informazioni di associazione anagrafica relative al documento in apertura.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommandDocAnagrInfo DocAnagrInfo { get; }
Public ReadOnly Property DocAnagrInfo As DedCommandDocAnagrInfo
    Get
public:
property DedCommandDocAnagrInfo^ DocAnagrInfo {
    DedCommandDocAnagrInfo^ get ();
}
member DocAnagrInfo : DedCommandDocAnagrInfo with get

Valore della proprietà

DedCommandDocAnagrInfo
Vedi anche

Documentazione

Classe DedOpenCommandEventArgs
Namespace DedNet


Proprietà DedOpenCommandEventArgs.FullFileName

Proprietà DedOpenCommandEventArgsFullFileName
Restituisce il nome completo del file da aprire.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string FullFileName { get; }
Public ReadOnly Property FullFileName As String
    Get
public:
property String^ FullFileName {
    String^ get ();
}
member FullFileName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedOpenCommandEventArgs
Namespace DedNet


Proprietà DedOpenCommandEventArgs.ReadOnly

Proprietà DedOpenCommandEventArgsReadOnly
Restituisce se si tratti di una apertura in sola lettura.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ReadOnly { get; }
Public ReadOnly Property ReadOnly As Boolean
    Get
public:
property bool ReadOnly {
    bool get ();
}
member ReadOnly : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedOpenCommandEventArgs
Namespace DedNet


Classe DedOpenDocumentEventArgs
Argomento contenente le informazioni relative all'apertura del documento e la relativa anagrafica.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetDedBeforeOrAfterEventArgs
DedNetDedOpenDocumentEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedOpenDocumentEventArgs : DedBeforeOrAfterEventArgs
Public Class DedOpenDocumentEventArgs
    Inherits DedBeforeOrAfterEventArgs
public ref class DedOpenDocumentEventArgs : public DedBeforeOrAfterEventArgs
type DedOpenDocumentEventArgs =
    class
        inherit DedBeforeOrAfterEventArgs
    end

Il tipo DedOpenDocumentEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedOpenDocumentEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | DocAnagrInfo | Anagrafica o lista di anagrafiche in editazione.
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore DedOpenDocumentEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedOpenDocumentEventArgs()
Public Sub New
public:
DedOpenDocumentEventArgs()
new : unit -> DedOpenDocumentEventArgs
Vedi anche

Documentazione

Classe DedOpenDocumentEventArgs
Namespace DedNet


Proprietà di DedOpenDocumentEventArgs

Il tipo DedOpenDocumentEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | DocAnagrInfo | Anagrafica o lista di anagrafiche in editazione.
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Torna su
Vedi anche

Documentazione

Classe DedOpenDocumentEventArgs
Namespace DedNet


Proprietà DedOpenDocumentEventArgs.DocAnagrInfo

Proprietà DedOpenDocumentEventArgsDocAnagrInfo
Anagrafica o lista di anagrafiche in editazione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommandDocAnagrInfo DocAnagrInfo { get; set; }
Public Property DocAnagrInfo As DedCommandDocAnagrInfo
    Get
    Set
public:
property DedCommandDocAnagrInfo^ DocAnagrInfo {
    DedCommandDocAnagrInfo^ get ();
    void set (DedCommandDocAnagrInfo^ value);
}
member DocAnagrInfo : DedCommandDocAnagrInfo with get, set

Valore della proprietà

DedCommandDocAnagrInfo
Vedi anche

Documentazione

Classe DedOpenDocumentEventArgs
Namespace DedNet


Classe DedTranslationChangedEventArgs
Argomento usato per le operazioni di aggiunta/modifica/eliminaizone in DEDDATA.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetDedTranslationChangedEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedTranslationChangedEventArgs : EventArgs
Public Class DedTranslationChangedEventArgs
    Inherits EventArgs
public ref class DedTranslationChangedEventArgs : public EventArgs
type DedTranslationChangedEventArgs =
    class
        inherit EventArgs
    end

Il tipo DedTranslationChangedEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedTranslationChangedEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Operation |
Proprietà pubblica | Translation |
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore DedTranslationChangedEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTranslationChangedEventArgs()
Public Sub New
public:
DedTranslationChangedEventArgs()
new : unit -> DedTranslationChangedEventArgs
Vedi anche

Documentazione

Classe DedTranslationChangedEventArgs
Namespace DedNet


Proprietà di DedTranslationChangedEventArgs

Il tipo DedTranslationChangedEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Operation |
Proprietà pubblica | Translation |
Torna su
Vedi anche

Documentazione

Classe DedTranslationChangedEventArgs
Namespace DedNet


Proprietà DedTranslationChangedEventArgs.Operation

Proprietà DedTranslationChangedEventArgsOperation

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTranslationOperationEnum Operation { get; }
Public ReadOnly Property Operation As DedTranslationOperationEnum
    Get
public:
property DedTranslationOperationEnum Operation {
    DedTranslationOperationEnum get ();
}
member Operation : DedTranslationOperationEnum with get

Valore della proprietà

DedTranslationOperationEnum
Vedi anche

Documentazione

Classe DedTranslationChangedEventArgs
Namespace DedNet


Proprietà DedTranslationChangedEventArgs.Translation

Proprietà DedTranslationChangedEventArgsTranslation

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTranslation Translation { get; }
Public ReadOnly Property Translation As DedTranslation
    Get
public:
property DedTranslation^ Translation {
    DedTranslation^ get ();
}
member Translation : DedTranslation with get

Valore della proprietà

DedTranslation
Vedi anche

Documentazione

Classe DedTranslationChangedEventArgs
Namespace DedNet


Enumerazione DedTranslationOperationEnum
Enumerazione sul tipo di operazione effettuata in DEDDATA.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum DedTranslationOperationEnum
Public Enumeration DedTranslationOperationEnum
public enum class DedTranslationOperationEnum
type DedTranslationOperationEnum
Membri
Nome | Valore | Descrizione
Added | 0 | Aggiunta record.
Modified | 1 | Modifica record.
Deleted | 2 | Eliminazione record.
Vedi anche

Documentazione

Namespace DedNet


Classe DedTreeViewEventArgs
Argomento utilizzato per comunicare la lista delle famiglie selezionate nei vari eventi.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetDedTreeViewEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedTreeViewEventArgs : EventArgs
Public Class DedTreeViewEventArgs
    Inherits EventArgs
public ref class DedTreeViewEventArgs : public EventArgs
type DedTreeViewEventArgs =
    class
        inherit EventArgs
    end

Il tipo DedTreeViewEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Types | Restituisce la lista delle famiglie selezionate.
Torna su
Vedi anche

Documentazione

Namespace DedNet


Proprietà di DedTreeViewEventArgs

Il tipo DedTreeViewEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Types | Restituisce la lista delle famiglie selezionate.
Torna su
Vedi anche

Documentazione

Classe DedTreeViewEventArgs
Namespace DedNet


Proprietà DedTreeViewEventArgs.Types

Proprietà DedTreeViewEventArgsTypes
Restituisce la lista delle famiglie selezionate.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeBaseList Types { get; }
Public ReadOnly Property Types As DedTypeBaseList
    Get
public:
property DedTypeBaseList^ Types {
    DedTypeBaseList^ get ();
}
member Types : DedTypeBaseList with get

Valore della proprietà

DedTypeBaseList
Vedi anche

Documentazione

Classe DedTreeViewEventArgs
Namespace DedNet


Classe DependencyFileInfoEventArgs
Racchiude le informazioni che riguardano le dipendenze di un file. Viene utilizzato per determinare le dipendenze di un file quando questo non è ancora stato inserito del Database.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetDedBeforeOrAfterEventArgs
DedNetDedEventArgs
DedNetDependencyFileInfoEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DependencyFileInfoEventArgs : DedEventArgs
Public Class DependencyFileInfoEventArgs
    Inherits DedEventArgs
public ref class DependencyFileInfoEventArgs : public DedEventArgs
type DependencyFileInfoEventArgs =
    class
        inherit DedEventArgs
    end

Il tipo DependencyFileInfoEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo protetto | DependencyFileInfoEventArgs | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | DepList | Restituisce la lista delle dipendenze da associare al file in fase di archiviazione.
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | FileName | Restituisce il file che si sta elaborando e del quale si desidera conoscere le dipendenze.
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore DependencyFileInfoEventArgs
Costruttore unico.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal DependencyFileInfoEventArgs()
Protected Friend Sub New
protected public:
DependencyFileInfoEventArgs()
new : unit -> DependencyFileInfoEventArgs
Vedi anche

Documentazione

Classe DependencyFileInfoEventArgs
Namespace DedNet


Proprietà di DependencyFileInfoEventArgs

Il tipo DependencyFileInfoEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | DepList | Restituisce la lista delle dipendenze da associare al file in fase di archiviazione.
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | FileName | Restituisce il file che si sta elaborando e del quale si desidera conoscere le dipendenze.
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Torna su
Vedi anche

Documentazione

Classe DependencyFileInfoEventArgs
Namespace DedNet


Proprietà DependencyFileInfoEventArgs.DepList

Proprietà DependencyFileInfoEventArgsDepList
Restituisce la lista delle dipendenze da associare al file in fase di archiviazione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocDepFileList DepList { get; }
Public ReadOnly Property DepList As DocDepFileList
    Get
public:
property DocDepFileList^ DepList {
    DocDepFileList^ get ();
}
member DepList : DocDepFileList with get

Valore della proprietà

DocDepFileList
Vedi anche

Documentazione

Classe DependencyFileInfoEventArgs
Namespace DedNet


Proprietà DependencyFileInfoEventArgs.FileName

Proprietà DependencyFileInfoEventArgsFileName
Restituisce il file che si sta elaborando e del quale si desidera conoscere le dipendenze.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string FileName { get; }
Public ReadOnly Property FileName As String
    Get
public:
property String^ FileName {
    String^ get ();
}
member FileName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DependencyFileInfoEventArgs
Namespace DedNet


Classe DisableAutoUpdateAnagrCommEventArgs
Classe usata per gestire la disabilitazione dell'aggiornamento automatico delle revisioni delle anagrafiche di commessa
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetDedBeforeOrAfterEventArgs
DedNetDedEventArgs
DedNetDisableAutoUpdateAnagrCommEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DisableAutoUpdateAnagrCommEventArgs : DedEventArgs
Public Class DisableAutoUpdateAnagrCommEventArgs
    Inherits DedEventArgs
public ref class DisableAutoUpdateAnagrCommEventArgs : public DedEventArgs
type DisableAutoUpdateAnagrCommEventArgs =
    class
        inherit DedEventArgs
    end

Il tipo DisableAutoUpdateAnagrCommEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DisableAutoUpdateAnagrCommEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Comm | Restituisce la commessa.
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | DisableAutoUpdate | Indica se l'aggiornamento automatico è da disabilitare
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore DisableAutoUpdateAnagrCommEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DisableAutoUpdateAnagrCommEventArgs()
Public Sub New
public:
DisableAutoUpdateAnagrCommEventArgs()
new : unit -> DisableAutoUpdateAnagrCommEventArgs
Vedi anche

Documentazione

Classe DisableAutoUpdateAnagrCommEventArgs
Namespace DedNet


Proprietà di DisableAutoUpdateAnagrCommEventArgs

Il tipo DisableAutoUpdateAnagrCommEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Comm | Restituisce la commessa.
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | DisableAutoUpdate | Indica se l'aggiornamento automatico è da disabilitare
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Torna su
Vedi anche

Documentazione

Classe DisableAutoUpdateAnagrCommEventArgs
Namespace DedNet


Proprietà DisableAutoUpdateAnagrCommEventArgs.Comm

Proprietà DisableAutoUpdateAnagrCommEventArgsComm
Restituisce la commessa.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedComm Comm { get; set; }
Public Property Comm As DedComm
    Get
    Set
public:
property DedComm^ Comm {
    DedComm^ get ();
    void set (DedComm^ value);
}
member Comm : DedComm with get, set

Valore della proprietà

DedComm
Vedi anche

Documentazione

Classe DisableAutoUpdateAnagrCommEventArgs
Namespace DedNet


Proprietà DisableAutoUpdateAnagrCommEventArgs.DisableAutoUpdate

Proprietà DisableAutoUpdateAnagrCommEventArgsDisableAutoUpdate
Indica se l'aggiornamento automatico è da disabilitare

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool DisableAutoUpdate { get; set; }
Public Property DisableAutoUpdate As Boolean
    Get
    Set
public:
property bool DisableAutoUpdate {
    bool get ();
    void set (bool value);
}
member DisableAutoUpdate : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DisableAutoUpdateAnagrCommEventArgs
Namespace DedNet


Classe DistAddNodeEventArgs
Argomento utilizzato quando viene aggiunto un nodo alla distinta tramite l'editor delle distinte.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetDedBeforeOrAfterEventArgs
DedNetDedEventArgs
DedNetDistAddNodeEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DistAddNodeEventArgs : DedEventArgs
Public Class DistAddNodeEventArgs
    Inherits DedEventArgs
public ref class DistAddNodeEventArgs : public DedEventArgs
type DistAddNodeEventArgs =
    class
        inherit DedEventArgs
    end

Il tipo DistAddNodeEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DistAddNodeEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | BomItem | Restituisce l'elemento di distinta aggiunto.
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | DistValues | Espone gli attributi di distinta
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Proprietà pubblica | ObjData | Oggetto che espone l'interfaccia dell'anagrafica
Proprietà pubblica | Qta | Quantità
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore DistAddNodeEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DistAddNodeEventArgs()
Public Sub New
public:
DistAddNodeEventArgs()
new : unit -> DistAddNodeEventArgs
Vedi anche

Documentazione

Classe DistAddNodeEventArgs
Namespace DedNet


Proprietà di DistAddNodeEventArgs

Il tipo DistAddNodeEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | BomItem | Restituisce l'elemento di distinta aggiunto.
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | DistValues | Espone gli attributi di distinta
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Proprietà pubblica | ObjData | Oggetto che espone l'interfaccia dell'anagrafica
Proprietà pubblica | Qta | Quantità
Torna su
Vedi anche

Documentazione

Classe DistAddNodeEventArgs
Namespace DedNet


Proprietà DistAddNodeEventArgs.BomItem

Proprietà DistAddNodeEventArgsBomItem
Restituisce l'elemento di distinta aggiunto.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItem BomItem { get; set; }
Public Property BomItem As BomItem
    Get
    Set
public:
property BomItem^ BomItem {
    BomItem^ get ();
    void set (BomItem^ value);
}
member BomItem : BomItem with get, set

Valore della proprietà

BomItem
Vedi anche

Documentazione

Classe DistAddNodeEventArgs
Namespace DedNet


Proprietà DistAddNodeEventArgs.DistValues

Proprietà DistAddNodeEventArgsDistValues
Espone gli attributi di distinta

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object[] DistValues { get; set; }
Public Property DistValues As Object()
    Get
    Set
public:
property array<Object^>^ DistValues {
    array<Object^>^ get ();
    void set (array<Object^>^ value);
}
member DistValues : Object[] with get, set

Valore della proprietà

Object
Vedi anche

Documentazione

Classe DistAddNodeEventArgs
Namespace DedNet


Proprietà DistAddNodeEventArgs.ObjData

Proprietà DistAddNodeEventArgsObjData
Oggetto che espone l'interfaccia dell'anagrafica

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public IDedData ObjData { get; set; }
Public Property ObjData As IDedData
    Get
    Set
public:
property IDedData^ ObjData {
    IDedData^ get ();
    void set (IDedData^ value);
}
member ObjData : IDedData with get, set

Valore della proprietà

IDedData
Vedi anche

Documentazione

Classe DistAddNodeEventArgs
Namespace DedNet


Proprietà DistAddNodeEventArgs.Qta

Proprietà DistAddNodeEventArgsQta
Quantità

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public double Qta { get; set; }
Public Property Qta As Double
    Get
    Set
public:
property double Qta {
    double get ();
    void set (double value);
}
member Qta : float with get, set

Valore della proprietà

Double
Vedi anche

Documentazione

Classe DistAddNodeEventArgs
Namespace DedNet


Classe DistChangeFieldValueEventArgs
Argomento utilizzato durante l'uscita da una cella di distinta tramite l'editor delle distinte.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetDistChangeFieldValueEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DistChangeFieldValueEventArgs : CancelEventArgs
Public Class DistChangeFieldValueEventArgs
    Inherits CancelEventArgs
public ref class DistChangeFieldValueEventArgs : public CancelEventArgs
type DistChangeFieldValueEventArgs =
    class
        inherit CancelEventArgs
    end

Il tipo DistChangeFieldValueEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DistChangeFieldValueEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BomItem | Elemento di distinta
Proprietà pubblica | ColumnName | Restituisce il nome della colonna selezionata.
Proprietà pubblica | CtrlDist | Restituisce il controllo delle distinte (DedDistContorl).
Proprietà pubblica | ErrorText | Restituisce/Imposta l'eventuale errore da visualizzare.
Proprietà pubblica | Value | Restuisce il valore della cella selezionata.
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore DistChangeFieldValueEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DistChangeFieldValueEventArgs()
Public Sub New
public:
DistChangeFieldValueEventArgs()
new : unit -> DistChangeFieldValueEventArgs
Vedi anche

Documentazione

Classe DistChangeFieldValueEventArgs
Namespace DedNet


Proprietà di DistChangeFieldValueEventArgs

Il tipo DistChangeFieldValueEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BomItem | Elemento di distinta
Proprietà pubblica | ColumnName | Restituisce il nome della colonna selezionata.
Proprietà pubblica | CtrlDist | Restituisce il controllo delle distinte (DedDistContorl).
Proprietà pubblica | ErrorText | Restituisce/Imposta l'eventuale errore da visualizzare.
Proprietà pubblica | Value | Restuisce il valore della cella selezionata.
Torna su
Vedi anche

Documentazione

Classe DistChangeFieldValueEventArgs
Namespace DedNet


Proprietà DistChangeFieldValueEventArgs.BomItem

Proprietà DistChangeFieldValueEventArgsBomItem
Elemento di distinta

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItem BomItem { get; }
Public ReadOnly Property BomItem As BomItem
    Get
public:
property BomItem^ BomItem {
    BomItem^ get ();
}
member BomItem : BomItem with get

Valore della proprietà

BomItem
Vedi anche

Documentazione

Classe DistChangeFieldValueEventArgs
Namespace DedNet


Proprietà DistChangeFieldValueEventArgs.ColumnName

Proprietà DistChangeFieldValueEventArgsColumnName
Restituisce il nome della colonna selezionata.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string ColumnName { get; }
Public ReadOnly Property ColumnName As String
    Get
public:
property String^ ColumnName {
    String^ get ();
}
member ColumnName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DistChangeFieldValueEventArgs
Namespace DedNet


Proprietà DistChangeFieldValueEventArgs.CtrlDist

Proprietà DistChangeFieldValueEventArgsCtrlDist
Restituisce il controllo delle distinte (DedDistContorl).

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDistControl CtrlDist { get; }
Public ReadOnly Property CtrlDist As DedDistControl
    Get
public:
property DedDistControl^ CtrlDist {
    DedDistControl^ get ();
}
member CtrlDist : DedDistControl with get

Valore della proprietà

DedDistControl
Vedi anche

Documentazione

Classe DistChangeFieldValueEventArgs
Namespace DedNet


Proprietà DistChangeFieldValueEventArgs.ErrorText

Proprietà DistChangeFieldValueEventArgsErrorText
Restituisce/Imposta l'eventuale errore da visualizzare.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string ErrorText { get; set; }
Public Property ErrorText As String
    Get
    Set
public:
property String^ ErrorText {
    String^ get ();
    void set (String^ value);
}
member ErrorText : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DistChangeFieldValueEventArgs
Namespace DedNet


Proprietà DistChangeFieldValueEventArgs.Value

Proprietà DistChangeFieldValueEventArgsValue
Restuisce il valore della cella selezionata.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object Value { get; set; }
Public Property Value As Object
    Get
    Set
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}
member Value : Object with get, set

Valore della proprietà

Object
Vedi anche

Documentazione

Classe DistChangeFieldValueEventArgs
Namespace DedNet


Classe DistCloneDataEventArgs
Argomento utilizzato durante la clonazione della distinta da DEDAPI.DuplicaDistinta.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetDistCloneDataEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DistCloneDataEventArgs : CancelEventArgs
Public Class DistCloneDataEventArgs
    Inherits CancelEventArgs
public ref class DistCloneDataEventArgs : public CancelEventArgs
type DistCloneDataEventArgs =
    class
        inherit CancelEventArgs
    end

Il tipo DistCloneDataEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DistCloneDataEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | ItemFrom | Restituisce l'elemento di distinta dal quale viene copiato.
Proprietà pubblica | ItemTo | Restituisce l'elemento di distinta da aggiungere.
Proprietà pubblica | NewData | Restituisce l'eventuale nuova anagrafica da associare all'elemento in creazione.
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore DistCloneDataEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DistCloneDataEventArgs()
Public Sub New
public:
DistCloneDataEventArgs()
new : unit -> DistCloneDataEventArgs
Vedi anche

Documentazione

Classe DistCloneDataEventArgs
Namespace DedNet


Proprietà di DistCloneDataEventArgs

Il tipo DistCloneDataEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | ItemFrom | Restituisce l'elemento di distinta dal quale viene copiato.
Proprietà pubblica | ItemTo | Restituisce l'elemento di distinta da aggiungere.
Proprietà pubblica | NewData | Restituisce l'eventuale nuova anagrafica da associare all'elemento in creazione.
Torna su
Vedi anche

Documentazione

Classe DistCloneDataEventArgs
Namespace DedNet


Proprietà DistCloneDataEventArgs.ItemFrom

Proprietà DistCloneDataEventArgsItemFrom
Restituisce l'elemento di distinta dal quale viene copiato.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItem ItemFrom { get; set; }
Public Property ItemFrom As BomItem
    Get
    Set
public:
property BomItem^ ItemFrom {
    BomItem^ get ();
    void set (BomItem^ value);
}
member ItemFrom : BomItem with get, set

Valore della proprietà

BomItem
Vedi anche

Documentazione

Classe DistCloneDataEventArgs
Namespace DedNet


Proprietà DistCloneDataEventArgs.ItemTo

Proprietà DistCloneDataEventArgsItemTo
Restituisce l'elemento di distinta da aggiungere.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItem ItemTo { get; set; }
Public Property ItemTo As BomItem
    Get
    Set
public:
property BomItem^ ItemTo {
    BomItem^ get ();
    void set (BomItem^ value);
}
member ItemTo : BomItem with get, set

Valore della proprietà

BomItem
Vedi anche

Documentazione

Classe DistCloneDataEventArgs
Namespace DedNet


Proprietà DistCloneDataEventArgs.NewData

Proprietà DistCloneDataEventArgsNewData
Restituisce l'eventuale nuova anagrafica da associare all'elemento in creazione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData NewData { get; set; }
Public Property NewData As DedData
    Get
    Set
public:
property DedData^ NewData {
    DedData^ get ();
    void set (DedData^ value);
}
member NewData : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe DistCloneDataEventArgs
Namespace DedNet


Classe DistCopyDataEventArgs
Argomento utilizzato durente la copia di un anagrafica dal pannello di dx a quello di sx tramite l'editor delle distinte.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetDistCopyDataEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DistCopyDataEventArgs : CancelEventArgs
Public Class DistCopyDataEventArgs
    Inherits CancelEventArgs
public ref class DistCopyDataEventArgs : public CancelEventArgs
type DistCopyDataEventArgs =
    class
        inherit CancelEventArgs
    end

Il tipo DistCopyDataEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DistCopyDataEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AnagrDist | Restuisce l'anagrafica della distinta in editazione.
Proprietà pubblica | CtrlDist | Restituisce il controllo delle distinte (DedDistContorl).
Proprietà pubblica | DistValues | Valori degli attributi di distinta.
Proprietà pubblica | InsertAnagr | Restituisce l'elemento del quale si debba creare l'anagrafica.
Proprietà pubblica | Qta | Quantità
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore DistCopyDataEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DistCopyDataEventArgs()
Public Sub New
public:
DistCopyDataEventArgs()
new : unit -> DistCopyDataEventArgs
Vedi anche

Documentazione

Classe DistCopyDataEventArgs
Namespace DedNet


Proprietà di DistCopyDataEventArgs

Il tipo DistCopyDataEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AnagrDist | Restuisce l'anagrafica della distinta in editazione.
Proprietà pubblica | CtrlDist | Restituisce il controllo delle distinte (DedDistContorl).
Proprietà pubblica | DistValues | Valori degli attributi di distinta.
Proprietà pubblica | InsertAnagr | Restituisce l'elemento del quale si debba creare l'anagrafica.
Proprietà pubblica | Qta | Quantità
Torna su
Vedi anche

Documentazione

Classe DistCopyDataEventArgs
Namespace DedNet


Proprietà DistCopyDataEventArgs.AnagrDist

Proprietà DistCopyDataEventArgsAnagrDist
Restuisce l'anagrafica della distinta in editazione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData AnagrDist { get; }
Public ReadOnly Property AnagrDist As DedData
    Get
public:
property DedData^ AnagrDist {
    DedData^ get ();
}
member AnagrDist : DedData with get

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe DistCopyDataEventArgs
Namespace DedNet


Proprietà DistCopyDataEventArgs.CtrlDist

Proprietà DistCopyDataEventArgsCtrlDist
Restituisce il controllo delle distinte (DedDistContorl).

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDistControl CtrlDist { get; }
Public ReadOnly Property CtrlDist As DedDistControl
    Get
public:
property DedDistControl^ CtrlDist {
    DedDistControl^ get ();
}
member CtrlDist : DedDistControl with get

Valore della proprietà

DedDistControl
Vedi anche

Documentazione

Classe DistCopyDataEventArgs
Namespace DedNet


Proprietà DistCopyDataEventArgs.DistValues

Proprietà DistCopyDataEventArgsDistValues
Valori degli attributi di distinta.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object[] DistValues { get; set; }
Public Property DistValues As Object()
    Get
    Set
public:
property array<Object^>^ DistValues {
    array<Object^>^ get ();
    void set (array<Object^>^ value);
}
member DistValues : Object[] with get, set

Valore della proprietà

Object
Vedi anche

Documentazione

Classe DistCopyDataEventArgs
Namespace DedNet


Proprietà DistCopyDataEventArgs.InsertAnagr

Proprietà DistCopyDataEventArgsInsertAnagr
Restituisce l'elemento del quale si debba creare l'anagrafica.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData InsertAnagr { get; set; }
Public Property InsertAnagr As DedData
    Get
    Set
public:
property DedData^ InsertAnagr {
    DedData^ get ();
    void set (DedData^ value);
}
member InsertAnagr : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe DistCopyDataEventArgs
Namespace DedNet


Proprietà DistCopyDataEventArgs.Qta

Proprietà DistCopyDataEventArgsQta
Quantità

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public double Qta { get; set; }
Public Property Qta As Double
    Get
    Set
public:
property double Qta {
    double get ();
    void set (double value);
}
member Qta : float with get, set

Valore della proprietà

Double
Vedi anche

Documentazione

Classe DistCopyDataEventArgs
Namespace DedNet


Classe DistDragElementEventArgs
Argomento utilizzato durente l'inserimento di un elemento dall'inizia parte veloce in distinta tramite l'editor delle distinte.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetDistDragElementEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DistDragElementEventArgs : CancelEventArgs
Public Class DistDragElementEventArgs
    Inherits CancelEventArgs
public ref class DistDragElementEventArgs : public CancelEventArgs
type DistDragElementEventArgs =
    class
        inherit CancelEventArgs
    end

Il tipo DistDragElementEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DistDragElementEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AnagrDist | Restuisce l'anagrafica della distinta in editazione.
Proprietà pubblica | CtrlDist | Restituisce il controllo delle distinte (DedDistContorl).
Proprietà pubblica | DistValues | Valori degli attributi di distinta.
Proprietà pubblica | Element | Restituisce l'elemento del quale si debba creare l'anagrafica.
Proprietà pubblica | ElementDdp | Restituisce l'elemento del quale si debba creare l'anagrafica.
Proprietà pubblica | Qta | Quantità
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore DistDragElementEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DistDragElementEventArgs()
Public Sub New
public:
DistDragElementEventArgs()
new : unit -> DistDragElementEventArgs
Vedi anche

Documentazione

Classe DistDragElementEventArgs
Namespace DedNet


Proprietà di DistDragElementEventArgs

Il tipo DistDragElementEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AnagrDist | Restuisce l'anagrafica della distinta in editazione.
Proprietà pubblica | CtrlDist | Restituisce il controllo delle distinte (DedDistContorl).
Proprietà pubblica | DistValues | Valori degli attributi di distinta.
Proprietà pubblica | Element | Restituisce l'elemento del quale si debba creare l'anagrafica.
Proprietà pubblica | ElementDdp | Restituisce l'elemento del quale si debba creare l'anagrafica.
Proprietà pubblica | Qta | Quantità
Torna su
Vedi anche

Documentazione

Classe DistDragElementEventArgs
Namespace DedNet


Proprietà DistDragElementEventArgs.AnagrDist

Proprietà DistDragElementEventArgsAnagrDist
Restuisce l'anagrafica della distinta in editazione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData AnagrDist { get; }
Public ReadOnly Property AnagrDist As DedData
    Get
public:
property DedData^ AnagrDist {
    DedData^ get ();
}
member AnagrDist : DedData with get

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe DistDragElementEventArgs
Namespace DedNet


Proprietà DistDragElementEventArgs.CtrlDist

Proprietà DistDragElementEventArgsCtrlDist
Restituisce il controllo delle distinte (DedDistContorl).

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDistControl CtrlDist { get; }
Public ReadOnly Property CtrlDist As DedDistControl
    Get
public:
property DedDistControl^ CtrlDist {
    DedDistControl^ get ();
}
member CtrlDist : DedDistControl with get

Valore della proprietà

DedDistControl
Vedi anche

Documentazione

Classe DistDragElementEventArgs
Namespace DedNet


Proprietà DistDragElementEventArgs.DistValues

Proprietà DistDragElementEventArgsDistValues
Valori degli attributi di distinta.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object[] DistValues { get; set; }
Public Property DistValues As Object()
    Get
    Set
public:
property array<Object^>^ DistValues {
    array<Object^>^ get ();
    void set (array<Object^>^ value);
}
member DistValues : Object[] with get, set

Valore della proprietà

Object
Vedi anche

Documentazione

Classe DistDragElementEventArgs
Namespace DedNet


Proprietà DistDragElementEventArgs.Element

Proprietà DistDragElementEventArgsElement
Restituisce l'elemento del quale si debba creare l'anagrafica.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Row Element { get; }
Public ReadOnly Property Element As Row
    Get
public:
property Row^ Element {
    Row^ get ();
}
member Element : Row with get

Valore della proprietà

Row
Vedi anche

Documentazione

Classe DistDragElementEventArgs
Namespace DedNet


Proprietà DistDragElementEventArgs.ElementDdp

Proprietà DistDragElementEventArgsElementDdp
Restituisce l'elemento del quale si debba creare l'anagrafica.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public IDedData ElementDdp { get; }
Public ReadOnly Property ElementDdp As IDedData
    Get
public:
property IDedData^ ElementDdp {
    IDedData^ get ();
}
member ElementDdp : IDedData with get

Valore della proprietà

IDedData
Vedi anche

Documentazione

Classe DistDragElementEventArgs
Namespace DedNet


Proprietà DistDragElementEventArgs.Qta

Proprietà DistDragElementEventArgsQta
Quantità

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public double Qta { get; set; }
Public Property Qta As Double
    Get
    Set
public:
property double Qta {
    double get ();
    void set (double value);
}
member Qta : float with get, set

Valore della proprietà

Double
Vedi anche

Documentazione

Classe DistDragElementEventArgs
Namespace DedNet


Classe DistElementCreateDataEventArgs
Argomento utilizzato per lo scambio di informazioni durante il salvataggio della distinta e quindi la creazione di una nuova anagrafica partendo da un elemento di distinta non codificato.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetDistElementCreateDataEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DistElementCreateDataEventArgs : CancelEventArgs
Public Class DistElementCreateDataEventArgs
    Inherits CancelEventArgs
public ref class DistElementCreateDataEventArgs : public CancelEventArgs
type DistElementCreateDataEventArgs =
    class
        inherit CancelEventArgs
    end

Il tipo DistElementCreateDataEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DistElementCreateDataEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione.
Proprietà pubblica | Data | Restituisce l'oggetto nel quale impostare le informazioni di anagrafica da utilizzare nel salvataggio. In questo oggetto è necessario impostare il DED_DIS dell'elemento.
Proprietà pubblica | Fam | Restituisce o imposta la famiglia nella quale archiviare l'elemento.
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento.
Proprietà pubblica | Item | Restituisce l'elemento del quale si debba creare l'anagrafica.
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore DistElementCreateDataEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DistElementCreateDataEventArgs()
Public Sub New
public:
DistElementCreateDataEventArgs()
new : unit -> DistElementCreateDataEventArgs
Vedi anche

Documentazione

Classe DistElementCreateDataEventArgs
Namespace DedNet


Proprietà di DistElementCreateDataEventArgs

Il tipo DistElementCreateDataEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione.
Proprietà pubblica | Data | Restituisce l'oggetto nel quale impostare le informazioni di anagrafica da utilizzare nel salvataggio. In questo oggetto è necessario impostare il DED_DIS dell'elemento.
Proprietà pubblica | Fam | Restituisce o imposta la famiglia nella quale archiviare l'elemento.
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento.
Proprietà pubblica | Item | Restituisce l'elemento del quale si debba creare l'anagrafica.
Torna su
Vedi anche

Documentazione

Classe DistElementCreateDataEventArgs
Namespace DedNet


Proprietà DistElementCreateDataEventArgs.BeforeOrAfter

Proprietà DistElementCreateDataEventArgsBeforeOrAfter
Restituisce il momento dell'evento rispetto l'azione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEventTimeEnum BeforeOrAfter { get; }
Public ReadOnly Property BeforeOrAfter As DedEventTimeEnum
    Get
public:
property DedEventTimeEnum BeforeOrAfter {
    DedEventTimeEnum get ();
}
member BeforeOrAfter : DedEventTimeEnum with get

Valore della proprietà

DedEventTimeEnum
Vedi anche

Documentazione

Classe DistElementCreateDataEventArgs
Namespace DedNet


Proprietà DistElementCreateDataEventArgs.Data

Proprietà DistElementCreateDataEventArgsData
Restituisce l'oggetto nel quale impostare le informazioni di anagrafica da utilizzare nel salvataggio. In questo oggetto è necessario impostare il DED_DIS dell'elemento.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public IDedData Data { get; }
Public ReadOnly Property Data As IDedData
    Get
public:
property IDedData^ Data {
    IDedData^ get ();
}
member Data : IDedData with get

Valore della proprietà

IDedData
Vedi anche

Documentazione

Classe DistElementCreateDataEventArgs
Namespace DedNet


Proprietà DistElementCreateDataEventArgs.Fam

Proprietà DistElementCreateDataEventArgsFam
Restituisce o imposta la famiglia nella quale archiviare l'elemento.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedType Fam { get; set; }
Public Property Fam As DedType
    Get
    Set
public:
property DedType^ Fam {
    DedType^ get ();
    void set (DedType^ value);
}
member Fam : DedType with get, set

Valore della proprietà

DedType
Vedi anche

Documentazione

Classe DistElementCreateDataEventArgs
Namespace DedNet


Proprietà DistElementCreateDataEventArgs.HandlingCode

Proprietà DistElementCreateDataEventArgsHandlingCode
Restituisce o imposta la gestione dell'evento.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEventHandlerEnum HandlingCode { get; set; }
Public Property HandlingCode As DedEventHandlerEnum
    Get
    Set
public:
property DedEventHandlerEnum HandlingCode {
    DedEventHandlerEnum get ();
    void set (DedEventHandlerEnum value);
}
member HandlingCode : DedEventHandlerEnum with get, set

Valore della proprietà

DedEventHandlerEnum
Vedi anche

Documentazione

Classe DistElementCreateDataEventArgs
Namespace DedNet


Proprietà DistElementCreateDataEventArgs.Item

Proprietà DistElementCreateDataEventArgsItem
Restituisce l'elemento del quale si debba creare l'anagrafica.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public SaveDistCommandSavingDistElement Item { get; }
Public ReadOnly Property Item As SaveDistCommandSavingDistElement
    Get
public:
property SaveDistCommandSavingDistElement^ Item {
    SaveDistCommandSavingDistElement^ get ();
}
member Item : SaveDistCommandSavingDistElement with get

Valore della proprietà

SaveDistCommandSavingDistElement
Vedi anche

Documentazione

Classe DistElementCreateDataEventArgs
Namespace DedNet


Classe DistItemCreateDataEventArgs
Argomento utilizzato per lo scambio di informazioni durante il salvataggio della distinta e quindi la creazione di una nuova anagrafica partendo da un elemento di distinta non codificato.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetDistItemCreateDataEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DistItemCreateDataEventArgs : CancelEventArgs
Public Class DistItemCreateDataEventArgs
    Inherits CancelEventArgs
public ref class DistItemCreateDataEventArgs : public CancelEventArgs
type DistItemCreateDataEventArgs =
    class
        inherit CancelEventArgs
    end

Il tipo DistItemCreateDataEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DistItemCreateDataEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione.
Proprietà pubblica | Data | Restituisce l'oggetto nel quale impostare le informazioni di anagrafica da utilizzare nel salvataggio. In questo oggetto è necessario impostare il DED_DIS dell'elemento.
Proprietà pubblica | Fam | Restituisce o imposta la famiglia nella quale archiviare l'elemento.
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento.
Proprietà pubblica | Item | Restituisce l'elemento del quale si debba creare l'anagrafica.
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore DistItemCreateDataEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DistItemCreateDataEventArgs()
Public Sub New
public:
DistItemCreateDataEventArgs()
new : unit -> DistItemCreateDataEventArgs
Vedi anche

Documentazione

Classe DistItemCreateDataEventArgs
Namespace DedNet


Proprietà di DistItemCreateDataEventArgs

Il tipo DistItemCreateDataEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione.
Proprietà pubblica | Data | Restituisce l'oggetto nel quale impostare le informazioni di anagrafica da utilizzare nel salvataggio. In questo oggetto è necessario impostare il DED_DIS dell'elemento.
Proprietà pubblica | Fam | Restituisce o imposta la famiglia nella quale archiviare l'elemento.
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento.
Proprietà pubblica | Item | Restituisce l'elemento del quale si debba creare l'anagrafica.
Torna su
Vedi anche

Documentazione

Classe DistItemCreateDataEventArgs
Namespace DedNet


Proprietà DistItemCreateDataEventArgs.BeforeOrAfter

Proprietà DistItemCreateDataEventArgsBeforeOrAfter
Restituisce il momento dell'evento rispetto l'azione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEventTimeEnum BeforeOrAfter { get; }
Public ReadOnly Property BeforeOrAfter As DedEventTimeEnum
    Get
public:
property DedEventTimeEnum BeforeOrAfter {
    DedEventTimeEnum get ();
}
member BeforeOrAfter : DedEventTimeEnum with get

Valore della proprietà

DedEventTimeEnum
Vedi anche

Documentazione

Classe DistItemCreateDataEventArgs
Namespace DedNet


Proprietà DistItemCreateDataEventArgs.Data

Proprietà DistItemCreateDataEventArgsData
Restituisce l'oggetto nel quale impostare le informazioni di anagrafica da utilizzare nel salvataggio. In questo oggetto è necessario impostare il DED_DIS dell'elemento.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public IDedData Data { get; }
Public ReadOnly Property Data As IDedData
    Get
public:
property IDedData^ Data {
    IDedData^ get ();
}
member Data : IDedData with get

Valore della proprietà

IDedData
Vedi anche

Documentazione

Classe DistItemCreateDataEventArgs
Namespace DedNet


Proprietà DistItemCreateDataEventArgs.Fam

Proprietà DistItemCreateDataEventArgsFam
Restituisce o imposta la famiglia nella quale archiviare l'elemento.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedType Fam { get; set; }
Public Property Fam As DedType
    Get
    Set
public:
property DedType^ Fam {
    DedType^ get ();
    void set (DedType^ value);
}
member Fam : DedType with get, set

Valore della proprietà

DedType
Vedi anche

Documentazione

Classe DistItemCreateDataEventArgs
Namespace DedNet


Proprietà DistItemCreateDataEventArgs.HandlingCode

Proprietà DistItemCreateDataEventArgsHandlingCode
Restituisce o imposta la gestione dell'evento.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEventHandlerEnum HandlingCode { get; set; }
Public Property HandlingCode As DedEventHandlerEnum
    Get
    Set
public:
property DedEventHandlerEnum HandlingCode {
    DedEventHandlerEnum get ();
    void set (DedEventHandlerEnum value);
}
member HandlingCode : DedEventHandlerEnum with get, set

Valore della proprietà

DedEventHandlerEnum
Vedi anche

Documentazione

Classe DistItemCreateDataEventArgs
Namespace DedNet


Proprietà DistItemCreateDataEventArgs.Item

Proprietà DistItemCreateDataEventArgsItem
Restituisce l'elemento del quale si debba creare l'anagrafica.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItem Item { get; }
Public ReadOnly Property Item As BomItem
    Get
public:
property BomItem^ Item {
    BomItem^ get ();
}
member Item : BomItem with get

Valore della proprietà

BomItem
Vedi anche

Documentazione

Classe DistItemCreateDataEventArgs
Namespace DedNet


Classe DocOperationEventArgs
Argomento utilizzato per le operazioni sui documenti.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetDedBeforeOrAfterEventArgs
DedNetDocOperationEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DocOperationEventArgs : DedBeforeOrAfterEventArgs
Public Class DocOperationEventArgs
    Inherits DedBeforeOrAfterEventArgs
public ref class DocOperationEventArgs : public DedBeforeOrAfterEventArgs
type DocOperationEventArgs =
    class
        inherit DedBeforeOrAfterEventArgs
    end

Il tipo DocOperationEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Document | Restituisce Documento in esame.
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Torna su
Vedi anche

Documentazione

Namespace DedNet


Proprietà di DocOperationEventArgs

Il tipo DocOperationEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Document | Restituisce Documento in esame.
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Torna su
Vedi anche

Documentazione

Classe DocOperationEventArgs
Namespace DedNet


Proprietà DocOperationEventArgs.Document

Proprietà DocOperationEventArgsDocument
Restituisce Documento in esame.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDoc Document { get; }
Public ReadOnly Property Document As DedDoc
    Get
public:
property DedDoc^ Document {
    DedDoc^ get ();
}
member Document : DedDoc with get

Valore della proprietà

DedDoc
Vedi anche

Documentazione

Classe DocOperationEventArgs
Namespace DedNet


Classe DocRegognizerClientsEventArgs
Argomento per l'evento di specializzazione lista file nel form di riconoscimento dei file
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetDedBeforeOrAfterEventArgs
DedNetDedEventArgs
DedNetDocRegognizerClientsEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DocRegognizerClientsEventArgs : DedEventArgs
Public Class DocRegognizerClientsEventArgs
    Inherits DedEventArgs
public ref class DocRegognizerClientsEventArgs : public DedEventArgs
type DocRegognizerClientsEventArgs =
    class
        inherit DedEventArgs
    end

Il tipo DocRegognizerClientsEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo protetto | DocRegognizerClientsEventArgs | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | FileList | Restituisce la lista dei file associata al path di riferimento associata in base alle regole del client
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Proprietà pubblica | RefPath | Restituisce il DocStructInfo che si sta elaborando.
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore DocRegognizerClientsEventArgs
Costruttore unico.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal DocRegognizerClientsEventArgs(
    string refPath
)
Protected Friend Sub New (
    refPath As String
)
protected public:
DocRegognizerClientsEventArgs(
    String^ refPath
)
new :
        refPath : string -> DocRegognizerClientsEventArgs

Parametri

refPath String
Vedi anche

Documentazione

Classe DocRegognizerClientsEventArgs
Namespace DedNet


Proprietà di DocRegognizerClientsEventArgs

Il tipo DocRegognizerClientsEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | FileList | Restituisce la lista dei file associata al path di riferimento associata in base alle regole del client
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Proprietà pubblica | RefPath | Restituisce il DocStructInfo che si sta elaborando.
Torna su
Vedi anche

Documentazione

Classe DocRegognizerClientsEventArgs
Namespace DedNet


Proprietà DocRegognizerClientsEventArgs.FileList

Proprietà DocRegognizerClientsEventArgsFileList
Restituisce la lista dei file associata al path di riferimento associata in base alle regole del client

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> FileList { get; set; }
Public Property FileList As List(Of String)
    Get
    Set
public:
property List<String^>^ FileList {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
member FileList : List<string> with get, set

Valore della proprietà

List String
Vedi anche

Documentazione

Classe DocRegognizerClientsEventArgs
Namespace DedNet


Proprietà DocRegognizerClientsEventArgs.RefPath

Proprietà DocRegognizerClientsEventArgsRefPath
Restituisce il DocStructInfo che si sta elaborando.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string RefPath { get; set; }
Public Property RefPath As String
    Get
    Set
public:
property String^ RefPath {
    String^ get ();
    void set (String^ value);
}
member RefPath : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DocRegognizerClientsEventArgs
Namespace DedNet


Classe DocStructInfoEventArgs
Argomento utilizzato per determinare la versione del documento sulla sua creazione o aggiornamento.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetDedBeforeOrAfterEventArgs
DedNetDocStructInfoEventArgs
DedNetImportedDocStructInfoEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DocStructInfoEventArgs : DedBeforeOrAfterEventArgs
Public Class DocStructInfoEventArgs
    Inherits DedBeforeOrAfterEventArgs
public ref class DocStructInfoEventArgs : public DedBeforeOrAfterEventArgs
type DocStructInfoEventArgs =
    class
        inherit DedBeforeOrAfterEventArgs
    end

Il tipo DocStructInfoEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | DocStructInfo | Restituisce il DocStructInfo di riferimento.
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | UseUI | Specifica se utilizzare o meno l'interfaccia utente all'interno del delegate dell'evento
Torna su
Vedi anche

Documentazione

Namespace DedNet


Proprietà di DocStructInfoEventArgs

Il tipo DocStructInfoEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | DocStructInfo | Restituisce il DocStructInfo di riferimento.
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | UseUI | Specifica se utilizzare o meno l'interfaccia utente all'interno del delegate dell'evento
Torna su
Vedi anche

Documentazione

Classe DocStructInfoEventArgs
Namespace DedNet


Proprietà DocStructInfoEventArgs.DocStructInfo

Proprietà DocStructInfoEventArgsDocStructInfo
Restituisce il DocStructInfo di riferimento.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfo DocStructInfo { get; }
Public ReadOnly Property DocStructInfo As DocStructInfo
    Get
public:
property DocStructInfo^ DocStructInfo {
    DocStructInfo^ get ();
}
member DocStructInfo : DocStructInfo with get

Valore della proprietà

DocStructInfo
Vedi anche

Documentazione

Classe DocStructInfoEventArgs
Namespace DedNet


Proprietà DocStructInfoEventArgs.UseUI

Proprietà DocStructInfoEventArgsUseUI
Specifica se utilizzare o meno l'interfaccia utente all'interno del delegate dell'evento

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool UseUI { get; set; }
Public Property UseUI As Boolean
    Get
    Set
public:
property bool UseUI {
    bool get ();
    void set (bool value);
}
member UseUI : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructInfoEventArgs
Namespace DedNet


Classe DocumentCheckLockedEventArgs
Evento chiamato nell'esure local quando controlla se il file è locked
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetDedBeforeOrAfterEventArgs
DedNetDocumentCheckLockedEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DocumentCheckLockedEventArgs : DedBeforeOrAfterEventArgs
Public Class DocumentCheckLockedEventArgs
    Inherits DedBeforeOrAfterEventArgs
public ref class DocumentCheckLockedEventArgs : public DedBeforeOrAfterEventArgs
type DocumentCheckLockedEventArgs =
    class
        inherit DedBeforeOrAfterEventArgs
    end

Il tipo DocumentCheckLockedEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DocumentCheckLockedEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Document | Restituisce il documento in esame.
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore DocumentCheckLockedEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocumentCheckLockedEventArgs()
Public Sub New
public:
DocumentCheckLockedEventArgs()
new : unit -> DocumentCheckLockedEventArgs
Vedi anche

Documentazione

Classe DocumentCheckLockedEventArgs
Namespace DedNet


Proprietà di DocumentCheckLockedEventArgs

Il tipo DocumentCheckLockedEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Document | Restituisce il documento in esame.
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Torna su
Vedi anche

Documentazione

Classe DocumentCheckLockedEventArgs
Namespace DedNet


Proprietà DocumentCheckLockedEventArgs.Document

Proprietà DocumentCheckLockedEventArgsDocument
Restituisce il documento in esame.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDoc Document { get; }
Public ReadOnly Property Document As DedDoc
    Get
public:
property DedDoc^ Document {
    DedDoc^ get ();
}
member Document : DedDoc with get

Valore della proprietà

DedDoc
Vedi anche

Documentazione

Classe DocumentCheckLockedEventArgs
Namespace DedNet


Classe DocumentDisableEventArgs
Argomento utilizzato per determinare la visulizzazione del documento nel controllo documentale.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetDocumentDisableEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DocumentDisableEventArgs : EventArgs
Public Class DocumentDisableEventArgs
    Inherits EventArgs
public ref class DocumentDisableEventArgs : public EventArgs
type DocumentDisableEventArgs =
    class
        inherit EventArgs
    end

Il tipo DocumentDisableEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DocumentDisableEventArgs | Costruttore che inizializza i parametri dell'oggetto.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Attributes | Dizionario con accoppiata nome attributo-valore.
Proprietà pubblica | Datas | Eventuali anagrafiche in gioco.
Proprietà pubblica | Document | Restituisce il documento in aggiornamento. Questa proprietà è null nell'evento Before della creazione documento.
Proprietà pubblica | Estensione | Estensione del documento.
Proprietà pubblica | Nome | Nome del documento.
Proprietà pubblica | Percorso | Percorso del documento.
Proprietà pubblica | Visible | Indica se di default il file è visibile o meno all'utente. Impostandolo a False il file non verrà visualizzato.
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore DocumentDisableEventArgs
Costruttore che inizializza i parametri dell'oggetto.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocumentDisableEventArgs(
    DedDoc doc,
    DedDataList datas,
    string nome,
    string percorso,
    string ext,
    Dictionary<string, Object> attributes,
    bool visible
)
Public Sub New (
    doc As DedDoc,
    datas As DedDataList,
    nome As String,
    percorso As String,
    ext As String,
    attributes As Dictionary(Of String, Object),
    visible As Boolean
)
public:
DocumentDisableEventArgs(
    DedDoc^ doc,
    DedDataList^ datas,
    String^ nome,
    String^ percorso,
    String^ ext,
    Dictionary<String^, Object^>^ attributes,
    bool visible
)
new :
        doc : DedDoc *
        datas : DedDataList *
        nome : string *
        percorso : string *
        ext : string *
        attributes : Dictionary<string, Object> *
        visible : bool -> DocumentDisableEventArgs

Parametri

doc DedDoc
Documento in aggiornamento.
datas DedDataList
Lista delle anagrafiche
nome String
Nome del documento
percorso String
Percorso del documento
ext String
Estensione del documento
attributes Dictionary String, Object
Attributi documentali
visible Boolean
Indica se di default il file è visibile o meno all'utente.
Vedi anche

Documentazione

Classe DocumentDisableEventArgs
Namespace DedNet


Proprietà di DocumentDisableEventArgs

Il tipo DocumentDisableEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Attributes | Dizionario con accoppiata nome attributo-valore.
Proprietà pubblica | Datas | Eventuali anagrafiche in gioco.
Proprietà pubblica | Document | Restituisce il documento in aggiornamento. Questa proprietà è null nell'evento Before della creazione documento.
Proprietà pubblica | Estensione | Estensione del documento.
Proprietà pubblica | Nome | Nome del documento.
Proprietà pubblica | Percorso | Percorso del documento.
Proprietà pubblica | Visible | Indica se di default il file è visibile o meno all'utente. Impostandolo a False il file non verrà visualizzato.
Torna su
Vedi anche

Documentazione

Classe DocumentDisableEventArgs
Namespace DedNet


Proprietà DocumentDisableEventArgs.Attributes

Proprietà DocumentDisableEventArgsAttributes
Dizionario con accoppiata nome attributo-valore.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<string, Object> Attributes { get; set; }
Public Property Attributes As Dictionary(Of String, Object)
    Get
    Set
public:
property Dictionary<String^, Object^>^ Attributes {
    Dictionary<String^, Object^>^ get ();
    void set (Dictionary<String^, Object^>^ value);
}
member Attributes : Dictionary<string, Object> with get, set

Valore della proprietà

Dictionary String, Object
Vedi anche

Documentazione

Classe DocumentDisableEventArgs
Namespace DedNet


Proprietà DocumentDisableEventArgs.Datas

Proprietà DocumentDisableEventArgsDatas
Eventuali anagrafiche in gioco.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataList Datas { get; set; }
Public Property Datas As DedDataList
    Get
    Set
public:
property DedDataList^ Datas {
    DedDataList^ get ();
    void set (DedDataList^ value);
}
member Datas : DedDataList with get, set

Valore della proprietà

DedDataList
Vedi anche

Documentazione

Classe DocumentDisableEventArgs
Namespace DedNet


Proprietà DocumentDisableEventArgs.Document

Proprietà DocumentDisableEventArgsDocument
Restituisce il documento in aggiornamento. Questa proprietà è null nell'evento Before della creazione documento.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDoc Document { get; }
Public ReadOnly Property Document As DedDoc
    Get
public:
property DedDoc^ Document {
    DedDoc^ get ();
}
member Document : DedDoc with get

Valore della proprietà

DedDoc
Vedi anche

Documentazione

Classe DocumentDisableEventArgs
Namespace DedNet


Proprietà DocumentDisableEventArgs.Estensione

Proprietà DocumentDisableEventArgsEstensione
Estensione del documento.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Estensione { get; }
Public ReadOnly Property Estensione As String
    Get
public:
property String^ Estensione {
    String^ get ();
}
member Estensione : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DocumentDisableEventArgs
Namespace DedNet


Proprietà DocumentDisableEventArgs.Nome

Proprietà DocumentDisableEventArgsNome
Nome del documento.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Nome { get; }
Public ReadOnly Property Nome As String
    Get
public:
property String^ Nome {
    String^ get ();
}
member Nome : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DocumentDisableEventArgs
Namespace DedNet


Proprietà DocumentDisableEventArgs.Percorso

Proprietà DocumentDisableEventArgsPercorso
Percorso del documento.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Percorso { get; }
Public ReadOnly Property Percorso As String
    Get
public:
property String^ Percorso {
    String^ get ();
}
member Percorso : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DocumentDisableEventArgs
Namespace DedNet


Proprietà DocumentDisableEventArgs.Visible

Proprietà DocumentDisableEventArgsVisible
Indica se di default il file è visibile o meno all'utente. Impostandolo a False il file non verrà visualizzato.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Visible { get; set; }
Public Property Visible As Boolean
    Get
    Set
public:
property bool Visible {
    bool get ();
    void set (bool value);
}
member Visible : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocumentDisableEventArgs
Namespace DedNet


Classe DocumentDisconnectingEventArgs
Racchiude le informazioni che riguardano il comando di Disconnessione documento dall'anagrafica.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetDedBeforeOrAfterEventArgs
DedNetDocumentDisconnectingEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DocumentDisconnectingEventArgs : DedBeforeOrAfterEventArgs
Public Class DocumentDisconnectingEventArgs
    Inherits DedBeforeOrAfterEventArgs
public ref class DocumentDisconnectingEventArgs : public DedBeforeOrAfterEventArgs
type DocumentDisconnectingEventArgs =
    class
        inherit DedBeforeOrAfterEventArgs
    end

Il tipo DocumentDisconnectingEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DocumentDisconnectingEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Data | Restituisce l'anagrafica alla quale si sta disconnettendo il documento.
Proprietà pubblica | DocumentsToBeDelete | Restituisce l'elenco dei documenti che verranno eliminati. Sono quelli che non sono più associati ad alcuna anagrafica.
Proprietà pubblica | DocumentsToBeDisconnect | Restituisce l'elenco dei documenti che si vogliono disconnettere dall'anagrafica.
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore DocumentDisconnectingEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocumentDisconnectingEventArgs()
Public Sub New
public:
DocumentDisconnectingEventArgs()
new : unit -> DocumentDisconnectingEventArgs
Vedi anche

Documentazione

Classe DocumentDisconnectingEventArgs
Namespace DedNet


Proprietà di DocumentDisconnectingEventArgs

Il tipo DocumentDisconnectingEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Data | Restituisce l'anagrafica alla quale si sta disconnettendo il documento.
Proprietà pubblica | DocumentsToBeDelete | Restituisce l'elenco dei documenti che verranno eliminati. Sono quelli che non sono più associati ad alcuna anagrafica.
Proprietà pubblica | DocumentsToBeDisconnect | Restituisce l'elenco dei documenti che si vogliono disconnettere dall'anagrafica.
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Torna su
Vedi anche

Documentazione

Classe DocumentDisconnectingEventArgs
Namespace DedNet


Proprietà DocumentDisconnectingEventArgs.Data

Proprietà DocumentDisconnectingEventArgsData
Restituisce l'anagrafica alla quale si sta disconnettendo il documento.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; set; }
Public Property Data As DedData
    Get
    Set
public:
property DedData^ Data {
    DedData^ get ();
    void set (DedData^ value);
}
member Data : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe DocumentDisconnectingEventArgs
Namespace DedNet


Proprietà DocumentDisconnectingEventArgs.DocumentsToBeDelete

Proprietà DocumentDisconnectingEventArgsDocumentsToBeDelete
Restituisce l'elenco dei documenti che verranno eliminati. Sono quelli che non sono più associati ad alcuna anagrafica.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocList DocumentsToBeDelete { get; set; }
Public Property DocumentsToBeDelete As DedDocList
    Get
    Set
public:
property DedDocList^ DocumentsToBeDelete {
    DedDocList^ get ();
    void set (DedDocList^ value);
}
member DocumentsToBeDelete : DedDocList with get, set

Valore della proprietà

DedDocList
Vedi anche

Documentazione

Classe DocumentDisconnectingEventArgs
Namespace DedNet


Proprietà DocumentDisconnectingEventArgs.DocumentsToBeDisconnect

Proprietà DocumentDisconnectingEventArgsDocumentsToBeDisconnect
Restituisce l'elenco dei documenti che si vogliono disconnettere dall'anagrafica.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfoList DocumentsToBeDisconnect { get; set; }
Public Property DocumentsToBeDisconnect As DocStructInfoList
    Get
    Set
public:
property DocStructInfoList^ DocumentsToBeDisconnect {
    DocStructInfoList^ get ();
    void set (DocStructInfoList^ value);
}
member DocumentsToBeDisconnect : DocStructInfoList with get, set

Valore della proprietà

DocStructInfoList
Vedi anche

Documentazione

Classe DocumentDisconnectingEventArgs
Namespace DedNet


Classe DocumentDragDropEventArgs
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetDedBeforeOrAfterEventArgs
DedNetDedEventArgs
DedNetDocumentDragDropEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DocumentDragDropEventArgs : DedEventArgs
Public Class DocumentDragDropEventArgs
    Inherits DedEventArgs
public ref class DocumentDragDropEventArgs : public DedEventArgs
type DocumentDragDropEventArgs =
    class
        inherit DedEventArgs
    end

Il tipo DocumentDragDropEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DocumentDragDropEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Proprietà pubblica | Paths |
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore DocumentDragDropEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocumentDragDropEventArgs(
    StringCollection paths
)
Public Sub New (
    paths As StringCollection
)
public:
DocumentDragDropEventArgs(
    StringCollection^ paths
)
new :
        paths : StringCollection -> DocumentDragDropEventArgs

Parametri

paths StringCollection
Vedi anche

Documentazione

Classe DocumentDragDropEventArgs
Namespace DedNet


Proprietà di DocumentDragDropEventArgs

Il tipo DocumentDragDropEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Proprietà pubblica | Paths |
Torna su
Vedi anche

Documentazione

Classe DocumentDragDropEventArgs
Namespace DedNet


Proprietà DocumentDragDropEventArgs.Paths

Proprietà DocumentDragDropEventArgsPaths

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public StringCollection Paths { get; set; }
Public Property Paths As StringCollection
    Get
    Set
public:
property StringCollection^ Paths {
    StringCollection^ get ();
    void set (StringCollection^ value);
}
member Paths : StringCollection with get, set

Valore della proprietà

StringCollection
Vedi anche

Documentazione

Classe DocumentDragDropEventArgs
Namespace DedNet


Classe DocumentEventArgs
Argomento utilizzato per determinare la versione del documento sulla sua creazione o aggiornamento.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetDedBeforeOrAfterEventArgs
DedNetDocumentEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DocumentEventArgs : DedBeforeOrAfterEventArgs
Public Class DocumentEventArgs
    Inherits DedBeforeOrAfterEventArgs
public ref class DocumentEventArgs : public DedBeforeOrAfterEventArgs
type DocumentEventArgs =
    class
        inherit DedBeforeOrAfterEventArgs
    end

Il tipo DocumentEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Document | Restituisce il documento in aggiornamento. Questa proprietà è null nell'evento Before della creazione documento.
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso documento.
Proprietà pubblica | RowVer | Restituisce o imposta la versione che dovrà essere assegnata al record del documento.
Torna su
Vedi anche

Documentazione

Namespace DedNet


Proprietà di DocumentEventArgs

Il tipo DocumentEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Document | Restituisce il documento in aggiornamento. Questa proprietà è null nell'evento Before della creazione documento.
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso documento.
Proprietà pubblica | RowVer | Restituisce o imposta la versione che dovrà essere assegnata al record del documento.
Torna su
Vedi anche

Documentazione

Classe DocumentEventArgs
Namespace DedNet


Proprietà DocumentEventArgs.Document

Proprietà DocumentEventArgsDocument
Restituisce il documento in aggiornamento. Questa proprietà è null nell'evento Before della creazione documento.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDoc Document { get; }
Public ReadOnly Property Document As DedDoc
    Get
public:
property DedDoc^ Document {
    DedDoc^ get ();
}
member Document : DedDoc with get

Valore della proprietà

DedDoc
Vedi anche

Documentazione

Classe DocumentEventArgs
Namespace DedNet


Proprietà DocumentEventArgs.RootInfo

Proprietà DocumentEventArgsRootInfo
Restituisce le informazioni sul percorso documento.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedRootInfo RootInfo { get; }
Public ReadOnly Property RootInfo As DedRootInfo
    Get
public:
property DedRootInfo^ RootInfo {
    DedRootInfo^ get ();
}
member RootInfo : DedRootInfo with get

Valore della proprietà

DedRootInfo
Vedi anche

Documentazione

Classe DocumentEventArgs
Namespace DedNet


Proprietà DocumentEventArgs.RowVer

Proprietà DocumentEventArgsRowVer
Restituisce o imposta la versione che dovrà essere assegnata al record del documento.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Guid RowVer { get; set; }
Public Property RowVer As Guid
    Get
    Set
public:
property Guid RowVer {
    Guid get ();
    void set (Guid value);
}
member RowVer : Guid with get, set

Valore della proprietà

Guid
Vedi anche

Documentazione

Classe DocumentEventArgs
Namespace DedNet


Classe DocumentImportingEventArgs
Racchiude le informazioni che riguardano l'importazione di un file come documento da associare ad una anagrafica.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetDedBeforeOrAfterEventArgs
DedNetDocumentImportingEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DocumentImportingEventArgs : DedBeforeOrAfterEventArgs
Public Class DocumentImportingEventArgs
    Inherits DedBeforeOrAfterEventArgs
public ref class DocumentImportingEventArgs : public DedBeforeOrAfterEventArgs
type DocumentImportingEventArgs =
    class
        inherit DedBeforeOrAfterEventArgs
    end

Il tipo DocumentImportingEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DocumentImportingEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Operation | Restituisce il documento creato ma ancora senza il file.
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore DocumentImportingEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocumentImportingEventArgs()
Public Sub New
public:
DocumentImportingEventArgs()
new : unit -> DocumentImportingEventArgs
Vedi anche

Documentazione

Classe DocumentImportingEventArgs
Namespace DedNet


Proprietà di DocumentImportingEventArgs

Il tipo DocumentImportingEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Operation | Restituisce il documento creato ma ancora senza il file.
Torna su
Vedi anche

Documentazione

Classe DocumentImportingEventArgs
Namespace DedNet


Proprietà DocumentImportingEventArgs.Operation

Proprietà DocumentImportingEventArgsOperation
Restituisce il documento creato ma ancora senza il file.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructImportingOperation Operation { get; }
Public ReadOnly Property Operation As DocStructImportingOperation
    Get
public:
property DocStructImportingOperation^ Operation {
    DocStructImportingOperation^ get ();
}
member Operation : DocStructImportingOperation with get

Valore della proprietà

DocStructImportingOperation
Vedi anche

Documentazione

Classe DocumentImportingEventArgs
Namespace DedNet


Classe DocumentLinkingEventArgs
Racchiude le informazioni che riguardano il comando di Link documento all'anagrafica.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetDedBeforeOrAfterEventArgs
DedNetDocumentLinkingEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DocumentLinkingEventArgs : DedBeforeOrAfterEventArgs
Public Class DocumentLinkingEventArgs
    Inherits DedBeforeOrAfterEventArgs
public ref class DocumentLinkingEventArgs : public DedBeforeOrAfterEventArgs
type DocumentLinkingEventArgs =
    class
        inherit DedBeforeOrAfterEventArgs
    end

Il tipo DocumentLinkingEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DocumentLinkingEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Data | Restituisce l'anagrafica alla quale si sta linkando il documento.
Proprietà pubblica | Documents | Restituisce l'elenco dei documenti che si vogliono linkare all'anagrafica.
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore DocumentLinkingEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocumentLinkingEventArgs()
Public Sub New
public:
DocumentLinkingEventArgs()
new : unit -> DocumentLinkingEventArgs
Vedi anche

Documentazione

Classe DocumentLinkingEventArgs
Namespace DedNet


Proprietà di DocumentLinkingEventArgs

Il tipo DocumentLinkingEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Data | Restituisce l'anagrafica alla quale si sta linkando il documento.
Proprietà pubblica | Documents | Restituisce l'elenco dei documenti che si vogliono linkare all'anagrafica.
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Torna su
Vedi anche

Documentazione

Classe DocumentLinkingEventArgs
Namespace DedNet


Proprietà DocumentLinkingEventArgs.Data

Proprietà DocumentLinkingEventArgsData
Restituisce l'anagrafica alla quale si sta linkando il documento.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; set; }
Public Property Data As DedData
    Get
    Set
public:
property DedData^ Data {
    DedData^ get ();
    void set (DedData^ value);
}
member Data : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe DocumentLinkingEventArgs
Namespace DedNet


Proprietà DocumentLinkingEventArgs.Documents

Proprietà DocumentLinkingEventArgsDocuments
Restituisce l'elenco dei documenti che si vogliono linkare all'anagrafica.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfoList Documents { get; set; }
Public Property Documents As DocStructInfoList
    Get
    Set
public:
property DocStructInfoList^ Documents {
    DocStructInfoList^ get ();
    void set (DocStructInfoList^ value);
}
member Documents : DocStructInfoList with get, set

Valore della proprietà

DocStructInfoList
Vedi anche

Documentazione

Classe DocumentLinkingEventArgs
Namespace DedNet


Classe DocumentMovingEventArgs
Racchiude le informazioni che riguardano l'operazione di moving su elemento
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetDedBeforeOrAfterEventArgs
DedNetDocumentMovingEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DocumentMovingEventArgs : DedBeforeOrAfterEventArgs
Public Class DocumentMovingEventArgs
    Inherits DedBeforeOrAfterEventArgs
public ref class DocumentMovingEventArgs : public DedBeforeOrAfterEventArgs
type DocumentMovingEventArgs =
    class
        inherit DedBeforeOrAfterEventArgs
    end

Il tipo DocumentMovingEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DocumentMovingEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Command | Comando corrente
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Item | Restituisce l'elemento che sta per essere oggetto dell'operazione
Proprietà pubblica | NewPath | Destinazione dello spostamento
Proprietà pubblica | Reason | Ragione dello spostamento
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore DocumentMovingEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocumentMovingEventArgs()
Public Sub New
public:
DocumentMovingEventArgs()
new : unit -> DocumentMovingEventArgs
Vedi anche

Documentazione

Classe DocumentMovingEventArgs
Namespace DedNet


Proprietà di DocumentMovingEventArgs

Il tipo DocumentMovingEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Command | Comando corrente
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Item | Restituisce l'elemento che sta per essere oggetto dell'operazione
Proprietà pubblica | NewPath | Destinazione dello spostamento
Proprietà pubblica | Reason | Ragione dello spostamento
Torna su
Vedi anche

Documentazione

Classe DocumentMovingEventArgs
Namespace DedNet


Proprietà DocumentMovingEventArgs.Command

Proprietà DocumentMovingEventArgsCommand
Comando corrente

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public MoveDocument Command { get; }
Public ReadOnly Property Command As MoveDocument
    Get
public:
property MoveDocument^ Command {
    MoveDocument^ get ();
}
member Command : MoveDocument with get

Valore della proprietà

MoveDocument
Vedi anche

Documentazione

Classe DocumentMovingEventArgs
Namespace DedNet


Proprietà DocumentMovingEventArgs.Item

Proprietà DocumentMovingEventArgsItem
Restituisce l'elemento che sta per essere oggetto dell'operazione

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfo Item { get; }
Public ReadOnly Property Item As DocStructInfo
    Get
public:
property DocStructInfo^ Item {
    DocStructInfo^ get ();
}
member Item : DocStructInfo with get

Valore della proprietà

DocStructInfo
Vedi anche

Documentazione

Classe DocumentMovingEventArgs
Namespace DedNet


Proprietà DocumentMovingEventArgs.NewPath

Proprietà DocumentMovingEventArgsNewPath
Destinazione dello spostamento

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string NewPath { get; }
Public ReadOnly Property NewPath As String
    Get
public:
property String^ NewPath {
    String^ get ();
}
member NewPath : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DocumentMovingEventArgs
Namespace DedNet


Proprietà DocumentMovingEventArgs.Reason

Proprietà DocumentMovingEventArgsReason
Ragione dello spostamento

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocMovReasonEnum Reason { get; }
Public ReadOnly Property Reason As DedDocMovReasonEnum
    Get
public:
property DedDocMovReasonEnum Reason {
    DedDocMovReasonEnum get ();
}
member Reason : DedDocMovReasonEnum with get

Valore della proprietà

DedDocMovReasonEnum
Vedi anche

Documentazione

Classe DocumentMovingEventArgs
Namespace DedNet


Enumerazione DocumentOperationEnum

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum DocumentOperationEnum
Public Enumeration DocumentOperationEnum
public enum class DocumentOperationEnum
type DocumentOperationEnum
Membri
Nome | Valore | Descrizione
Default | 0 |
Copy | 1 |
Move | 2 |
Vedi anche

Documentazione

Namespace DedNet


Classe DocumentRecognizingEventArgs
Racchiude le informazioni che riguardano il riconoscimento di un file come documento da associare ad una anagrafica.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetDedBeforeOrAfterEventArgs
DedNetDocumentRecognizingEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DocumentRecognizingEventArgs : DedBeforeOrAfterEventArgs
Public Class DocumentRecognizingEventArgs
    Inherits DedBeforeOrAfterEventArgs
public ref class DocumentRecognizingEventArgs : public DedBeforeOrAfterEventArgs
type DocumentRecognizingEventArgs =
    class
        inherit DedBeforeOrAfterEventArgs
    end

Il tipo DocumentRecognizingEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DocumentRecognizingEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Operation | Restituisce il documento creato ma ancora senza il file.
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore DocumentRecognizingEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocumentRecognizingEventArgs()
Public Sub New
public:
DocumentRecognizingEventArgs()
new : unit -> DocumentRecognizingEventArgs
Vedi anche

Documentazione

Classe DocumentRecognizingEventArgs
Namespace DedNet


Proprietà di DocumentRecognizingEventArgs

Il tipo DocumentRecognizingEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Operation | Restituisce il documento creato ma ancora senza il file.
Torna su
Vedi anche

Documentazione

Classe DocumentRecognizingEventArgs
Namespace DedNet


Proprietà DocumentRecognizingEventArgs.Operation

Proprietà DocumentRecognizingEventArgsOperation
Restituisce il documento creato ma ancora senza il file.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructRecogniseOperation Operation { get; }
Public ReadOnly Property Operation As DocStructRecogniseOperation
    Get
public:
property DocStructRecogniseOperation^ Operation {
    DocStructRecogniseOperation^ get ();
}
member Operation : DocStructRecogniseOperation with get

Valore della proprietà

DocStructRecogniseOperation
Vedi anche

Documentazione

Classe DocumentRecognizingEventArgs
Namespace DedNet


Classe DocumentsEventArgs
Argomento di elaborazione lista dei documenti
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetDedBeforeOrAfterEventArgs
DedNetDocumentsEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DocumentsEventArgs : DedBeforeOrAfterEventArgs
Public Class DocumentsEventArgs
    Inherits DedBeforeOrAfterEventArgs
public ref class DocumentsEventArgs : public DedBeforeOrAfterEventArgs
type DocumentsEventArgs =
    class
        inherit DedBeforeOrAfterEventArgs
    end

Il tipo DocumentsEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Data | Restituisce la lista dei documenti in argomento.
Proprietà pubblica | Documents | Restituisce la lista dei documenti in argomento.
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Torna su
Vedi anche

Documentazione

Namespace DedNet


Proprietà di DocumentsEventArgs

Il tipo DocumentsEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Data | Restituisce la lista dei documenti in argomento.
Proprietà pubblica | Documents | Restituisce la lista dei documenti in argomento.
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Torna su
Vedi anche

Documentazione

Classe DocumentsEventArgs
Namespace DedNet


Proprietà DocumentsEventArgs.Data

Proprietà DocumentsEventArgsData
Restituisce la lista dei documenti in argomento.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; set; }
Public Property Data As DedData
    Get
    Set
public:
property DedData^ Data {
    DedData^ get ();
    void set (DedData^ value);
}
member Data : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe DocumentsEventArgs
Namespace DedNet


Proprietà DocumentsEventArgs.Documents

Proprietà DocumentsEventArgsDocuments
Restituisce la lista dei documenti in argomento.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocList Documents { get; }
Public ReadOnly Property Documents As DedDocList
    Get
public:
property DedDocList^ Documents {
    DedDocList^ get ();
}
member Documents : DedDocList with get

Valore della proprietà

DedDocList
Vedi anche

Documentazione

Classe DocumentsEventArgs
Namespace DedNet


Classe DragDropEventArgs
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetDedBeforeOrAfterEventArgs
DedNetDragDropEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DragDropEventArgs : DedBeforeOrAfterEventArgs
Public Class DragDropEventArgs
    Inherits DedBeforeOrAfterEventArgs
public ref class DragDropEventArgs : public DedBeforeOrAfterEventArgs
type DragDropEventArgs =
    class
        inherit DedBeforeOrAfterEventArgs
    end

Il tipo DragDropEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo protetto | DragDropEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | InfoList | Imposta/Restituisce la struttura di documenti da importare
Proprietà pubblica | PrimaryContext | Restituisce se si tratta di un contesto di associazione primario.
Proprietà pubblica | Result | Indica se l'eventuale operazione avvenuta tra il before e l'after ha avuto successo.
Proprietà pubblica | TargetComm | Imposta/Restituisce la struttura di documenti da importare
Proprietà pubblica | TargetData | Imposta/Restituisce la struttura di documenti da importare
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore DragDropEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal DragDropEventArgs(
    DocStructInfoList infoList,
    bool primaryContext
)
Protected Friend Sub New (
    infoList As DocStructInfoList,
    primaryContext As Boolean
)
protected public:
DragDropEventArgs(
    DocStructInfoList^ infoList,
    bool primaryContext
)
new :
        infoList : DocStructInfoList *
        primaryContext : bool -> DragDropEventArgs

Parametri

infoList DocStructInfoList
primaryContext Boolean
Vedi anche

Documentazione

Classe DragDropEventArgs
Namespace DedNet


Proprietà di DragDropEventArgs

Il tipo DragDropEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | InfoList | Imposta/Restituisce la struttura di documenti da importare
Proprietà pubblica | PrimaryContext | Restituisce se si tratta di un contesto di associazione primario.
Proprietà pubblica | Result | Indica se l'eventuale operazione avvenuta tra il before e l'after ha avuto successo.
Proprietà pubblica | TargetComm | Imposta/Restituisce la struttura di documenti da importare
Proprietà pubblica | TargetData | Imposta/Restituisce la struttura di documenti da importare
Torna su
Vedi anche

Documentazione

Classe DragDropEventArgs
Namespace DedNet


Proprietà DragDropEventArgs.InfoList

Proprietà DragDropEventArgsInfoList
Imposta/Restituisce la struttura di documenti da importare

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfoList InfoList { get; set; }
Public Property InfoList As DocStructInfoList
    Get
    Set
public:
property DocStructInfoList^ InfoList {
    DocStructInfoList^ get ();
    void set (DocStructInfoList^ value);
}
member InfoList : DocStructInfoList with get, set

Valore della proprietà

DocStructInfoList
Vedi anche

Documentazione

Classe DragDropEventArgs
Namespace DedNet


Proprietà DragDropEventArgs.PrimaryContext

Proprietà DragDropEventArgsPrimaryContext
Restituisce se si tratta di un contesto di associazione primario.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool PrimaryContext { get; }
Public ReadOnly Property PrimaryContext As Boolean
    Get
public:
property bool PrimaryContext {
    bool get ();
}
member PrimaryContext : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DragDropEventArgs
Namespace DedNet


Proprietà DragDropEventArgs.Result

Proprietà DragDropEventArgsResult
Indica se l'eventuale operazione avvenuta tra il before e l'after ha avuto successo.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCmdResult Result { get; }
Public ReadOnly Property Result As DedCmdResult
    Get
public:
property DedCmdResult Result {
    DedCmdResult get ();
}
member Result : DedCmdResult with get

Valore della proprietà

DedCmdResult
Vedi anche

Documentazione

Classe DragDropEventArgs
Namespace DedNet


Proprietà DragDropEventArgs.TargetComm

Proprietà DragDropEventArgsTargetComm
Imposta/Restituisce la struttura di documenti da importare

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedComm TargetComm { get; set; }
Public Property TargetComm As DedComm
    Get
    Set
public:
property DedComm^ TargetComm {
    DedComm^ get ();
    void set (DedComm^ value);
}
member TargetComm : DedComm with get, set

Valore della proprietà

DedComm
Vedi anche

Documentazione

Classe DragDropEventArgs
Namespace DedNet


Proprietà DragDropEventArgs.TargetData

Proprietà DragDropEventArgsTargetData
Imposta/Restituisce la struttura di documenti da importare

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData TargetData { get; set; }
Public Property TargetData As DedData
    Get
    Set
public:
property DedData^ TargetData {
    DedData^ get ();
    void set (DedData^ value);
}
member TargetData : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe DragDropEventArgs
Namespace DedNet


Classe DrawIconEventArgs
Classe usata per impostare l'icona da visualizzare nell'albero.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetDrawIconEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DrawIconEventArgs : EventArgs
Public Class DrawIconEventArgs
    Inherits EventArgs
public ref class DrawIconEventArgs : public EventArgs
type DrawIconEventArgs =
    class
        inherit EventArgs
    end

Il tipo DrawIconEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Handled |
Proprietà pubblica | Idx |
Proprietà pubblica | Node |
Torna su
Vedi anche

Documentazione

Namespace DedNet


Proprietà di DrawIconEventArgs

Il tipo DrawIconEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Handled |
Proprietà pubblica | Idx |
Proprietà pubblica | Node |
Torna su
Vedi anche

Documentazione

Classe DrawIconEventArgs
Namespace DedNet


Proprietà DrawIconEventArgs.Handled

Proprietà DrawIconEventArgsHandled

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Handled { get; set; }
Public Property Handled As Boolean
    Get
    Set
public:
property bool Handled {
    bool get ();
    void set (bool value);
}
member Handled : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DrawIconEventArgs
Namespace DedNet


Proprietà DrawIconEventArgs.Idx

Proprietà DrawIconEventArgsIdx

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int Idx { get; set; }
Public Property Idx As Integer
    Get
    Set
public:
property int Idx {
    int get ();
    void set (int value);
}
member Idx : int with get, set

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe DrawIconEventArgs
Namespace DedNet


Proprietà DrawIconEventArgs.Node

Proprietà DrawIconEventArgsNode

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public TreeListNode Node { get; }
Public ReadOnly Property Node As TreeListNode
    Get
public:
property TreeListNode^ Node {
    TreeListNode^ get ();
}
member Node : TreeListNode with get

Valore della proprietà

TreeListNode
Vedi anche

Documentazione

Classe DrawIconEventArgs
Namespace DedNet


Classe EditAttrEventArgs
Argomento contenente le informazioni relative all'editazione dell'anagrafica.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetDedBeforeOrAfterEventArgs
DedNetEditAttrEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class EditAttrEventArgs : DedBeforeOrAfterEventArgs
Public Class EditAttrEventArgs
    Inherits DedBeforeOrAfterEventArgs
public ref class EditAttrEventArgs : public DedBeforeOrAfterEventArgs
type EditAttrEventArgs =
    class
        inherit DedBeforeOrAfterEventArgs
    end

Il tipo EditAttrEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | EditAttrEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Anagr | Anagrafica o lista di anagrafiche in editazione.
Proprietà pubblica | Attr | Lista di attributi in editazione.
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore EditAttrEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public EditAttrEventArgs()
Public Sub New
public:
EditAttrEventArgs()
new : unit -> EditAttrEventArgs
Vedi anche

Documentazione

Classe EditAttrEventArgs
Namespace DedNet


Proprietà di EditAttrEventArgs

Il tipo EditAttrEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Anagr | Anagrafica o lista di anagrafiche in editazione.
Proprietà pubblica | Attr | Lista di attributi in editazione.
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Torna su
Vedi anche

Documentazione

Classe EditAttrEventArgs
Namespace DedNet


Proprietà EditAttrEventArgs.Anagr

Proprietà EditAttrEventArgsAnagr
Anagrafica o lista di anagrafiche in editazione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public IDedData Anagr { get; set; }
Public Property Anagr As IDedData
    Get
    Set
public:
property IDedData^ Anagr {
    IDedData^ get ();
    void set (IDedData^ value);
}
member Anagr : IDedData with get, set

Valore della proprietà

IDedData
Vedi anche

Documentazione

Classe EditAttrEventArgs
Namespace DedNet


Proprietà EditAttrEventArgs.Attr

Proprietà EditAttrEventArgsAttr
Lista di attributi in editazione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList Attr { get; set; }
Public Property Attr As DedAttrList
    Get
    Set
public:
property DedAttrList^ Attr {
    DedAttrList^ get ();
    void set (DedAttrList^ value);
}
member Attr : DedAttrList with get, set

Valore della proprietà

DedAttrList
Vedi anche

Documentazione

Classe EditAttrEventArgs
Namespace DedNet


Classe EditAttrValidatingEventArgs
Argomento per validare l'anagrafica in editazione.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetEditAttrValidatingEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class EditAttrValidatingEventArgs : CancelEventArgs
Public Class EditAttrValidatingEventArgs
    Inherits CancelEventArgs
public ref class EditAttrValidatingEventArgs : public CancelEventArgs
type EditAttrValidatingEventArgs =
    class
        inherit CancelEventArgs
    end

Il tipo EditAttrValidatingEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | EditAttrValidatingEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Data | Anagrafica o lista di anagrafiche in editazione.
Proprietà pubblica | ErrorMessage | Messaggio di errore da mostrare in caso di Cancel = true;
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore EditAttrValidatingEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public EditAttrValidatingEventArgs()
Public Sub New
public:
EditAttrValidatingEventArgs()
new : unit -> EditAttrValidatingEventArgs
Vedi anche

Documentazione

Classe EditAttrValidatingEventArgs
Namespace DedNet


Proprietà di EditAttrValidatingEventArgs

Il tipo EditAttrValidatingEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Data | Anagrafica o lista di anagrafiche in editazione.
Proprietà pubblica | ErrorMessage | Messaggio di errore da mostrare in caso di Cancel = true;
Torna su
Vedi anche

Documentazione

Classe EditAttrValidatingEventArgs
Namespace DedNet


Proprietà EditAttrValidatingEventArgs.Data

Proprietà EditAttrValidatingEventArgsData
Anagrafica o lista di anagrafiche in editazione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public IDedEditable Data { get; set; }
Public Property Data As IDedEditable
    Get
    Set
public:
property IDedEditable^ Data {
    IDedEditable^ get ();
    void set (IDedEditable^ value);
}
member Data : IDedEditable with get, set

Valore della proprietà

IDedEditable
Vedi anche

Documentazione

Classe EditAttrValidatingEventArgs
Namespace DedNet


Proprietà EditAttrValidatingEventArgs.ErrorMessage

Proprietà EditAttrValidatingEventArgsErrorMessage
Messaggio di errore da mostrare in caso di Cancel = true;

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string ErrorMessage { get; set; }
Public Property ErrorMessage As String
    Get
    Set
public:
property String^ ErrorMessage {
    String^ get ();
    void set (String^ value);
}
member ErrorMessage : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe EditAttrValidatingEventArgs
Namespace DedNet


Classe ElaborateDedListEventArgs
Racchiude le informazioni che riguardano l'elaborazione delle liste personalizzate
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetElaborateDedListEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ElaborateDedListEventArgs : EventArgs
Public Class ElaborateDedListEventArgs
    Inherits EventArgs
public ref class ElaborateDedListEventArgs : public EventArgs
type ElaborateDedListEventArgs =
    class
        inherit EventArgs
    end

Il tipo ElaborateDedListEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ElaborateDedListEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | ObjList |
Proprietà pubblica | UserList |
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore ElaborateDedListEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ElaborateDedListEventArgs(
    DedUserList userList
)
Public Sub New (
    userList As DedUserList
)
public:
ElaborateDedListEventArgs(
    DedUserList^ userList
)
new :
        userList : DedUserList -> ElaborateDedListEventArgs

Parametri

userList DedUserList
Vedi anche

Documentazione

Classe ElaborateDedListEventArgs
Namespace DedNet


Proprietà di ElaborateDedListEventArgs

Il tipo ElaborateDedListEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | ObjList |
Proprietà pubblica | UserList |
Torna su
Vedi anche

Documentazione

Classe ElaborateDedListEventArgs
Namespace DedNet


Proprietà ElaborateDedListEventArgs.ObjList

Proprietà ElaborateDedListEventArgsObjList

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<Object> ObjList { get; set; }
Public Property ObjList As List(Of Object)
    Get
    Set
public:
property List<Object^>^ ObjList {
    List<Object^>^ get ();
    void set (List<Object^>^ value);
}
member ObjList : List<Object> with get, set

Valore della proprietà

List Object
Vedi anche

Documentazione

Classe ElaborateDedListEventArgs
Namespace DedNet


Proprietà ElaborateDedListEventArgs.UserList

Proprietà ElaborateDedListEventArgsUserList

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedUserList UserList { get; }
Public ReadOnly Property UserList As DedUserList
    Get
public:
property DedUserList^ UserList {
    DedUserList^ get ();
}
member UserList : DedUserList with get

Valore della proprietà

DedUserList
Vedi anche

Documentazione

Classe ElaborateDedListEventArgs
Namespace DedNet


Classe EvaluateNewValueEventArgs
Contiene le informazioni necessarie alla correzione di un codice digitato dall'utente nella finestra di ricerca veloce, che non è presente nel Database. Il chiamato può impostare il valore sostitutivo da mettere nel controllo per agevolare l'utente.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetEvaluateNewValueEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class EvaluateNewValueEventArgs : EventArgs
Public Class EvaluateNewValueEventArgs
    Inherits EventArgs
public ref class EvaluateNewValueEventArgs : public EventArgs
type EvaluateNewValueEventArgs =
    class
        inherit EventArgs
    end

Il tipo EvaluateNewValueEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | EvaluateNewValueEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | CurrentText | Restituisce il testo digitato dall'utente che non è presente nel Database.
Proprietà pubblica | NewText | Nuovo testo da mostrare come sostituzione del testo digitato.
Proprietà pubblica | SelectedAttr | Restituisce il nome della colonna dell'attributo correntemente selezionato dall'utente.
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore EvaluateNewValueEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public EvaluateNewValueEventArgs()
Public Sub New
public:
EvaluateNewValueEventArgs()
new : unit -> EvaluateNewValueEventArgs
Vedi anche

Documentazione

Classe EvaluateNewValueEventArgs
Namespace DedNet


Proprietà di EvaluateNewValueEventArgs

Il tipo EvaluateNewValueEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CurrentText | Restituisce il testo digitato dall'utente che non è presente nel Database.
Proprietà pubblica | NewText | Nuovo testo da mostrare come sostituzione del testo digitato.
Proprietà pubblica | SelectedAttr | Restituisce il nome della colonna dell'attributo correntemente selezionato dall'utente.
Torna su
Vedi anche

Documentazione

Classe EvaluateNewValueEventArgs
Namespace DedNet


Proprietà EvaluateNewValueEventArgs.CurrentText

Proprietà EvaluateNewValueEventArgsCurrentText
Restituisce il testo digitato dall'utente che non è presente nel Database.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string CurrentText { get; }
Public ReadOnly Property CurrentText As String
    Get
public:
property String^ CurrentText {
    String^ get ();
}
member CurrentText : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe EvaluateNewValueEventArgs
Namespace DedNet


Proprietà EvaluateNewValueEventArgs.NewText

Proprietà EvaluateNewValueEventArgsNewText
Nuovo testo da mostrare come sostituzione del testo digitato.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string NewText { get; set; }
Public Property NewText As String
    Get
    Set
public:
property String^ NewText {
    String^ get ();
    void set (String^ value);
}
member NewText : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe EvaluateNewValueEventArgs
Namespace DedNet


Proprietà EvaluateNewValueEventArgs.SelectedAttr

Proprietà EvaluateNewValueEventArgsSelectedAttr
Restituisce il nome della colonna dell'attributo correntemente selezionato dall'utente.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string SelectedAttr { get; set; }
Public Property SelectedAttr As String
    Get
    Set
public:
property String^ SelectedAttr {
    String^ get ();
    void set (String^ value);
}
member SelectedAttr : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe EvaluateNewValueEventArgs
Namespace DedNet


Delegate ExportDataDelegate

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public delegate void ExportDataDelegate(
    string[] a,
    List<Object[]> b
)
Public Delegate Sub ExportDataDelegate (
    a As String(),
    b As List(Of Object())
)
public delegate void ExportDataDelegate(
    array<String^>^ a,
    List<array<Object^>^>^ b
)
type ExportDataDelegate =
    delegate of
        a : string[] *
        b : List<Object[]> -> unit

Parametri

a String
b List Object
Vedi anche

Documentazione

Namespace DedNet


Classe ExportDataEventArg
Contiene le informazioni per la gestione dell'esportazione.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetExportDataEventArg

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ExportDataEventArg : EventArgs
Public Class ExportDataEventArg
    Inherits EventArgs
public ref class ExportDataEventArg : public EventArgs
type ExportDataEventArg =
    class
        inherit EventArgs
    end

Il tipo ExportDataEventArg espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Context | Contesto dal quale è stato chiamato il comando di esportazione.
Proprietà pubblica | Diz | Dizionario contenente le coppie (nome funzione, delegate da chiamare).
Proprietà pubblica | Tag | Tag generico per informazioni aggiuntive.
Torna su
Vedi anche

Documentazione

Namespace DedNet


Proprietà di ExportDataEventArg

Il tipo ExportDataEventArg espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Context | Contesto dal quale è stato chiamato il comando di esportazione.
Proprietà pubblica | Diz | Dizionario contenente le coppie (nome funzione, delegate da chiamare).
Proprietà pubblica | Tag | Tag generico per informazioni aggiuntive.
Torna su
Vedi anche

Documentazione

Classe ExportDataEventArg
Namespace DedNet


Proprietà ExportDataEventArg.Context

Proprietà ExportDataEventArgContext
Contesto dal quale è stato chiamato il comando di esportazione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public CommandContextEnum Context { get; }
Public ReadOnly Property Context As CommandContextEnum
    Get
public:
property CommandContextEnum Context {
    CommandContextEnum get ();
}
member Context : CommandContextEnum with get

Valore della proprietà

CommandContextEnum
Vedi anche

Documentazione

Classe ExportDataEventArg
Namespace DedNet


Proprietà ExportDataEventArg.Diz

Proprietà ExportDataEventArgDiz
Dizionario contenente le coppie (nome funzione, delegate da chiamare).

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<string, ExportDataDelegate> Diz { get; }
Public ReadOnly Property Diz As Dictionary(Of String, ExportDataDelegate)
    Get
public:
property Dictionary<String^, ExportDataDelegate^>^ Diz {
    Dictionary<String^, ExportDataDelegate^>^ get ();
}
member Diz : Dictionary<string, ExportDataDelegate> with get

Valore della proprietà

Dictionary String, ExportDataDelegate
Vedi anche

Documentazione

Classe ExportDataEventArg
Namespace DedNet


Proprietà ExportDataEventArg.Tag

Proprietà ExportDataEventArgTag
Tag generico per informazioni aggiuntive.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object Tag { get; }
Public ReadOnly Property Tag As Object
    Get
public:
property Object^ Tag {
    Object^ get ();
}
member Tag : Object with get

Valore della proprietà

Object
Vedi anche

Documentazione

Classe ExportDataEventArg
Namespace DedNet


Classe ExportResultBomCompareEventArgs
Classe usata per gestire il risultato del confronto tra distinte. Usato nell'evento del tasto 'Esporta'
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetExportResultBomCompareEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ExportResultBomCompareEventArgs : EventArgs
Public Class ExportResultBomCompareEventArgs
    Inherits EventArgs
public ref class ExportResultBomCompareEventArgs : public EventArgs
type ExportResultBomCompareEventArgs =
    class
        inherit EventArgs
    end

Il tipo ExportResultBomCompareEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ExportResultBomCompareEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Form | Form DedFormBomCompareExp, da questo form si può ricavare il risultato dell'esporta dal metodo ResultBomCompareExp
Proprietà pubblica | Handled | Indica se l'evento è stato gestito via lua
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore ExportResultBomCompareEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ExportResultBomCompareEventArgs()
Public Sub New
public:
ExportResultBomCompareEventArgs()
new : unit -> ExportResultBomCompareEventArgs
Vedi anche

Documentazione

Classe ExportResultBomCompareEventArgs
Namespace DedNet


Proprietà di ExportResultBomCompareEventArgs

Il tipo ExportResultBomCompareEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Form | Form DedFormBomCompareExp, da questo form si può ricavare il risultato dell'esporta dal metodo ResultBomCompareExp
Proprietà pubblica | Handled | Indica se l'evento è stato gestito via lua
Torna su
Vedi anche

Documentazione

Classe ExportResultBomCompareEventArgs
Namespace DedNet


Proprietà ExportResultBomCompareEventArgs.Form

Proprietà ExportResultBomCompareEventArgsForm
Form DedFormBomCompareExp, da questo form si può ricavare il risultato dell'esporta dal metodo ResultBomCompareExp

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormBomCompareExp Form { get; set; }
Public Property Form As DedFormBomCompareExp
    Get
    Set
public:
property DedFormBomCompareExp^ Form {
    DedFormBomCompareExp^ get ();
    void set (DedFormBomCompareExp^ value);
}
member Form : DedFormBomCompareExp with get, set

Valore della proprietà

DedFormBomCompareExp
Vedi anche

Documentazione

Classe ExportResultBomCompareEventArgs
Namespace DedNet


Proprietà ExportResultBomCompareEventArgs.Handled

Proprietà ExportResultBomCompareEventArgsHandled
Indica se l'evento è stato gestito via lua

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Handled { get; set; }
Public Property Handled As Boolean
    Get
    Set
public:
property bool Handled {
    bool get ();
    void set (bool value);
}
member Handled : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ExportResultBomCompareEventArgs
Namespace DedNet


Classe FamDescrOverrideEventArgs
Argomento per gli eventi di validazione della famiglia.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetFamDescrOverrideEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class FamDescrOverrideEventArgs : EventArgs
Public Class FamDescrOverrideEventArgs
    Inherits EventArgs
public ref class FamDescrOverrideEventArgs : public EventArgs
type FamDescrOverrideEventArgs =
    class
        inherit EventArgs
    end

Il tipo FamDescrOverrideEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo protetto | FamDescrOverrideEventArgs | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Editable | Imposta/restituisce se la lista è editabile o fissa.
Proprietà pubblica | Fam | Restituisce la famiglia selezionata.
Proprietà pubblica | Form | Restituisce il form del QsManager.
Proprietà pubblica | HandlingCode |
Proprietà pubblica | Items | Imposta/restituisce gli elementi della lista a tendina.
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore FamDescrOverrideEventArgs
Costruttore unico.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal FamDescrOverrideEventArgs(
    DedFormQsManager form,
    DedType fam
)
Protected Friend Sub New (
    form As DedFormQsManager,
    fam As DedType
)
protected public:
FamDescrOverrideEventArgs(
    DedFormQsManager^ form,
    DedType^ fam
)
new :
        form : DedFormQsManager *
        fam : DedType -> FamDescrOverrideEventArgs

Parametri

form DedFormQsManager
fam DedType
Vedi anche

Documentazione

Classe FamDescrOverrideEventArgs
Namespace DedNet


Proprietà di FamDescrOverrideEventArgs

Il tipo FamDescrOverrideEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Editable | Imposta/restituisce se la lista è editabile o fissa.
Proprietà pubblica | Fam | Restituisce la famiglia selezionata.
Proprietà pubblica | Form | Restituisce il form del QsManager.
Proprietà pubblica | HandlingCode |
Proprietà pubblica | Items | Imposta/restituisce gli elementi della lista a tendina.
Torna su
Vedi anche

Documentazione

Classe FamDescrOverrideEventArgs
Namespace DedNet


Proprietà FamDescrOverrideEventArgs.Editable

Proprietà FamDescrOverrideEventArgsEditable
Imposta/restituisce se la lista è editabile o fissa.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Editable { get; set; }
Public Property Editable As Boolean
    Get
    Set
public:
property bool Editable {
    bool get ();
    void set (bool value);
}
member Editable : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe FamDescrOverrideEventArgs
Namespace DedNet


Proprietà FamDescrOverrideEventArgs.Fam

Proprietà FamDescrOverrideEventArgsFam
Restituisce la famiglia selezionata.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedType Fam { get; }
Public ReadOnly Property Fam As DedType
    Get
public:
property DedType^ Fam {
    DedType^ get ();
}
member Fam : DedType with get

Valore della proprietà

DedType
Vedi anche

Documentazione

Classe FamDescrOverrideEventArgs
Namespace DedNet


Proprietà FamDescrOverrideEventArgs.Form

Proprietà FamDescrOverrideEventArgsForm
Restituisce il form del QsManager.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormQsManager Form { get; }
Public ReadOnly Property Form As DedFormQsManager
    Get
public:
property DedFormQsManager^ Form {
    DedFormQsManager^ get ();
}
member Form : DedFormQsManager with get

Valore della proprietà

DedFormQsManager
Vedi anche

Documentazione

Classe FamDescrOverrideEventArgs
Namespace DedNet


Proprietà FamDescrOverrideEventArgs.HandlingCode

Proprietà FamDescrOverrideEventArgsHandlingCode

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEventHandlerEnum HandlingCode { get; set; }
Public Property HandlingCode As DedEventHandlerEnum
    Get
    Set
public:
property DedEventHandlerEnum HandlingCode {
    DedEventHandlerEnum get ();
    void set (DedEventHandlerEnum value);
}
member HandlingCode : DedEventHandlerEnum with get, set

Valore della proprietà

DedEventHandlerEnum
Vedi anche

Documentazione

Classe FamDescrOverrideEventArgs
Namespace DedNet


Proprietà FamDescrOverrideEventArgs.Items

Proprietà FamDescrOverrideEventArgsItems
Imposta/restituisce gli elementi della lista a tendina.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> Items { get; set; }
Public Property Items As List(Of String)
    Get
    Set
public:
property List<String^>^ Items {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
member Items : List<string> with get, set

Valore della proprietà

List String
Vedi anche

Documentazione

Classe FamDescrOverrideEventArgs
Namespace DedNet


Classe FillAttributeListFilterEventArgs
Argomento per evento filtraggio attributi con criteri utente
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetFillAttributeListFilterEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class FillAttributeListFilterEventArgs : EventArgs
Public Class FillAttributeListFilterEventArgs
    Inherits EventArgs
public ref class FillAttributeListFilterEventArgs : public EventArgs
type FillAttributeListFilterEventArgs =
    class
        inherit EventArgs
    end

Il tipo FillAttributeListFilterEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | FillAttributeListFilterEventArgs | Costruttore unico
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Attr | Attributo di riferimento
Proprietà pubblica | Enabled | Abilitazione
Proprietà pubblica | Fam | Famiglia di riferimento
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore FillAttributeListFilterEventArgs
Costruttore unico

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public FillAttributeListFilterEventArgs(
    DedTypeBase fam,
    DedAttr attr
)
Public Sub New (
    fam As DedTypeBase,
    attr As DedAttr
)
public:
FillAttributeListFilterEventArgs(
    DedTypeBase^ fam,
    DedAttr^ attr
)
new :
        fam : DedTypeBase *
        attr : DedAttr -> FillAttributeListFilterEventArgs

Parametri

fam DedTypeBase
attr DedAttr
Vedi anche

Documentazione

Classe FillAttributeListFilterEventArgs
Namespace DedNet


Proprietà di FillAttributeListFilterEventArgs

Il tipo FillAttributeListFilterEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Attr | Attributo di riferimento
Proprietà pubblica | Enabled | Abilitazione
Proprietà pubblica | Fam | Famiglia di riferimento
Torna su
Vedi anche

Documentazione

Classe FillAttributeListFilterEventArgs
Namespace DedNet


Proprietà FillAttributeListFilterEventArgs.Attr

Proprietà FillAttributeListFilterEventArgsAttr
Attributo di riferimento

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttr Attr { get; }
Public ReadOnly Property Attr As DedAttr
    Get
public:
property DedAttr^ Attr {
    DedAttr^ get ();
}
member Attr : DedAttr with get

Valore della proprietà

DedAttr
Vedi anche

Documentazione

Classe FillAttributeListFilterEventArgs
Namespace DedNet


Proprietà FillAttributeListFilterEventArgs.Enabled

Proprietà FillAttributeListFilterEventArgsEnabled
Abilitazione

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
member Enabled : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe FillAttributeListFilterEventArgs
Namespace DedNet


Proprietà FillAttributeListFilterEventArgs.Fam

Proprietà FillAttributeListFilterEventArgsFam
Famiglia di riferimento

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeBase Fam { get; set; }
Public Property Fam As DedTypeBase
    Get
    Set
public:
property DedTypeBase^ Fam {
    DedTypeBase^ get ();
    void set (DedTypeBase^ value);
}
member Fam : DedTypeBase with get, set

Valore della proprietà

DedTypeBase
Vedi anche

Documentazione

Classe FillAttributeListFilterEventArgs
Namespace DedNet


Classe FindCodeMultipleResultsEventArgs
Argomento contenente le informazioni relative alle anagrafiche multiple in fas di apri veloce con ricerca su Invio.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelHandledEventArgs
DedNetFindCodeMultipleResultsEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class FindCodeMultipleResultsEventArgs : HandledEventArgs
Public Class FindCodeMultipleResultsEventArgs
    Inherits HandledEventArgs
public ref class FindCodeMultipleResultsEventArgs : public HandledEventArgs
type FindCodeMultipleResultsEventArgs =
    class
        inherit HandledEventArgs
    end

Il tipo FindCodeMultipleResultsEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Code | Codice inserito
Proprietà pubblica | Context | Contesto di utilizzo del controllo
Proprietà pubblica | DataList | Lista di anagrafiche presenti.
Proprietà pubblica | FilterBy | Campo di filtro
Proprietà pubblica | SelectedData | Anagrafica corretta da aprire.
Torna su
Vedi anche

Documentazione

Namespace DedNet


Proprietà di FindCodeMultipleResultsEventArgs

Il tipo FindCodeMultipleResultsEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Code | Codice inserito
Proprietà pubblica | Context | Contesto di utilizzo del controllo
Proprietà pubblica | DataList | Lista di anagrafiche presenti.
Proprietà pubblica | FilterBy | Campo di filtro
Proprietà pubblica | SelectedData | Anagrafica corretta da aprire.
Torna su
Vedi anche

Documentazione

Classe FindCodeMultipleResultsEventArgs
Namespace DedNet


Proprietà FindCodeMultipleResultsEventArgs.Code

Proprietà FindCodeMultipleResultsEventArgsCode
Codice inserito

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Code { get; }
Public ReadOnly Property Code As String
    Get
public:
property String^ Code {
    String^ get ();
}
member Code : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe FindCodeMultipleResultsEventArgs
Namespace DedNet


Proprietà FindCodeMultipleResultsEventArgs.Context

Proprietà FindCodeMultipleResultsEventArgsContext
Contesto di utilizzo del controllo

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFindCodeContextEnum Context { get; set; }
Public Property Context As DedFindCodeContextEnum
    Get
    Set
public:
property DedFindCodeContextEnum Context {
    DedFindCodeContextEnum get ();
    void set (DedFindCodeContextEnum value);
}
member Context : DedFindCodeContextEnum with get, set

Valore della proprietà

DedFindCodeContextEnum
Vedi anche

Documentazione

Classe FindCodeMultipleResultsEventArgs
Namespace DedNet


Proprietà FindCodeMultipleResultsEventArgs.DataList

Proprietà FindCodeMultipleResultsEventArgsDataList
Lista di anagrafiche presenti.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataList DataList { get; }
Public ReadOnly Property DataList As DedDataList
    Get
public:
property DedDataList^ DataList {
    DedDataList^ get ();
}
member DataList : DedDataList with get

Valore della proprietà

DedDataList
Vedi anche

Documentazione

Classe FindCodeMultipleResultsEventArgs
Namespace DedNet


Proprietà FindCodeMultipleResultsEventArgs.FilterBy

Proprietà FindCodeMultipleResultsEventArgsFilterBy
Campo di filtro

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string FilterBy { get; }
Public ReadOnly Property FilterBy As String
    Get
public:
property String^ FilterBy {
    String^ get ();
}
member FilterBy : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe FindCodeMultipleResultsEventArgs
Namespace DedNet


Proprietà FindCodeMultipleResultsEventArgs.SelectedData

Proprietà FindCodeMultipleResultsEventArgsSelectedData
Anagrafica corretta da aprire.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData SelectedData { get; set; }
Public Property SelectedData As DedData
    Get
    Set
public:
property DedData^ SelectedData {
    DedData^ get ();
    void set (DedData^ value);
}
member SelectedData : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe FindCodeMultipleResultsEventArgs
Namespace DedNet


Classe FindCodeStateFilterEventArgs
Argomento per evento filtraggio stati anagrafica lista findcode form
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetDedBeforeOrAfterEventArgs
DedNetDedEventArgs
DedNetFindCodeStateFilterEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class FindCodeStateFilterEventArgs : DedEventArgs
Public Class FindCodeStateFilterEventArgs
    Inherits DedEventArgs
public ref class FindCodeStateFilterEventArgs : public DedEventArgs
type FindCodeStateFilterEventArgs =
    class
        inherit DedEventArgs
    end

Il tipo FindCodeStateFilterEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo protetto | FindCodeStateFilterEventArgs | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | Context | Contesto di utilizzo del controllo
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Proprietà pubblica | StateList | Restituisce la lista delle dipendenze da associare al file in fase di archiviazione.
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore FindCodeStateFilterEventArgs
Costruttore unico.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal FindCodeStateFilterEventArgs()
Protected Friend Sub New
protected public:
FindCodeStateFilterEventArgs()
new : unit -> FindCodeStateFilterEventArgs
Vedi anche

Documentazione

Classe FindCodeStateFilterEventArgs
Namespace DedNet


Proprietà di FindCodeStateFilterEventArgs

Il tipo FindCodeStateFilterEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | Context | Contesto di utilizzo del controllo
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Proprietà pubblica | StateList | Restituisce la lista delle dipendenze da associare al file in fase di archiviazione.
Torna su
Vedi anche

Documentazione

Classe FindCodeStateFilterEventArgs
Namespace DedNet


Proprietà FindCodeStateFilterEventArgs.Context

Proprietà FindCodeStateFilterEventArgsContext
Contesto di utilizzo del controllo

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFindCodeContextEnum Context { get; set; }
Public Property Context As DedFindCodeContextEnum
    Get
    Set
public:
property DedFindCodeContextEnum Context {
    DedFindCodeContextEnum get ();
    void set (DedFindCodeContextEnum value);
}
member Context : DedFindCodeContextEnum with get, set

Valore della proprietà

DedFindCodeContextEnum
Vedi anche

Documentazione

Classe FindCodeStateFilterEventArgs
Namespace DedNet


Proprietà FindCodeStateFilterEventArgs.StateList

Proprietà FindCodeStateFilterEventArgsStateList
Restituisce la lista delle dipendenze da associare al file in fase di archiviazione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedStateList StateList { get; }
Public ReadOnly Property StateList As DedStateList
    Get
public:
property DedStateList^ StateList {
    DedStateList^ get ();
}
member StateList : DedStateList with get

Valore della proprietà

DedStateList
Vedi anche

Documentazione

Classe FindCodeStateFilterEventArgs
Namespace DedNet


Classe FolderDisableEventArgs
Argomento utilizzato per determinare la visulizzazione della cartella nel controllo documentale.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetFolderDisableEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class FolderDisableEventArgs : EventArgs
Public Class FolderDisableEventArgs
    Inherits EventArgs
public ref class FolderDisableEventArgs : public EventArgs
type FolderDisableEventArgs =
    class
        inherit EventArgs
    end

Il tipo FolderDisableEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | FolderDisableEventArgs | Costruttore.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Datas | Lista di anagrafiche.
Proprietà pubblica | DocList | Lista di documenti all'interno della cartella.
Proprietà pubblica | Nome | Nome della cartella.
Proprietà pubblica | Percorso | Percorso della cartella.
Proprietà pubblica | Visible | Indica se di default la cartella è visibile o meno all'utente. Impostandolo a False la cartella non verrà visualizzata.
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore FolderDisableEventArgs
Costruttore.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public FolderDisableEventArgs(
    string percorso,
    string nome,
    DedDocList docList,
    DedDataList datas,
    bool visible
)
Public Sub New (
    percorso As String,
    nome As String,
    docList As DedDocList,
    datas As DedDataList,
    visible As Boolean
)
public:
FolderDisableEventArgs(
    String^ percorso,
    String^ nome,
    DedDocList^ docList,
    DedDataList^ datas,
    bool visible
)
new :
        percorso : string *
        nome : string *
        docList : DedDocList *
        datas : DedDataList *
        visible : bool -> FolderDisableEventArgs

Parametri

percorso String
Percorso della cartella.
nome String
Nome della cartella.
docList DedDocList
Lista di documenti all'interno della cartella.
datas DedDataList
Lista di anagrafiche.
visible Boolean
Indica se di default la cartella è visibile o meno all'utente.
Vedi anche

Documentazione

Classe FolderDisableEventArgs
Namespace DedNet


Proprietà di FolderDisableEventArgs

Il tipo FolderDisableEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Datas | Lista di anagrafiche.
Proprietà pubblica | DocList | Lista di documenti all'interno della cartella.
Proprietà pubblica | Nome | Nome della cartella.
Proprietà pubblica | Percorso | Percorso della cartella.
Proprietà pubblica | Visible | Indica se di default la cartella è visibile o meno all'utente. Impostandolo a False la cartella non verrà visualizzata.
Torna su
Vedi anche

Documentazione

Classe FolderDisableEventArgs
Namespace DedNet


Proprietà FolderDisableEventArgs.Datas

Proprietà FolderDisableEventArgsDatas
Lista di anagrafiche.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataList Datas { get; }
Public ReadOnly Property Datas As DedDataList
    Get
public:
property DedDataList^ Datas {
    DedDataList^ get ();
}
member Datas : DedDataList with get

Valore della proprietà

DedDataList
Vedi anche

Documentazione

Classe FolderDisableEventArgs
Namespace DedNet


Proprietà FolderDisableEventArgs.DocList

Proprietà FolderDisableEventArgsDocList
Lista di documenti all'interno della cartella.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocList DocList { get; }
Public ReadOnly Property DocList As DedDocList
    Get
public:
property DedDocList^ DocList {
    DedDocList^ get ();
}
member DocList : DedDocList with get

Valore della proprietà

DedDocList
Vedi anche

Documentazione

Classe FolderDisableEventArgs
Namespace DedNet


Proprietà FolderDisableEventArgs.Nome

Proprietà FolderDisableEventArgsNome
Nome della cartella.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Nome { get; }
Public ReadOnly Property Nome As String
    Get
public:
property String^ Nome {
    String^ get ();
}
member Nome : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe FolderDisableEventArgs
Namespace DedNet


Proprietà FolderDisableEventArgs.Percorso

Proprietà FolderDisableEventArgsPercorso
Percorso della cartella.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Percorso { get; }
Public ReadOnly Property Percorso As String
    Get
public:
property String^ Percorso {
    String^ get ();
}
member Percorso : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe FolderDisableEventArgs
Namespace DedNet


Proprietà FolderDisableEventArgs.Visible

Proprietà FolderDisableEventArgsVisible
Indica se di default la cartella è visibile o meno all'utente. Impostandolo a False la cartella non verrà visualizzata.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Visible { get; set; }
Public Property Visible As Boolean
    Get
    Set
public:
property bool Visible {
    bool get ();
    void set (bool value);
}
member Visible : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe FolderDisableEventArgs
Namespace DedNet


Classe FtpClientConnectionEventArgs
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetFtpClientConnectionEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class FtpClientConnectionEventArgs : EventArgs
Public Class FtpClientConnectionEventArgs
    Inherits EventArgs
public ref class FtpClientConnectionEventArgs : public EventArgs
type FtpClientConnectionEventArgs =
    class
        inherit EventArgs
    end

Il tipo FtpClientConnectionEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | FtpClientConnectionEventArgs | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | ClientFtp | Restituisce la commessa.
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore FtpClientConnectionEventArgs
Costruttore unico.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public FtpClientConnectionEventArgs(
    FtpClient clientFtp
)
Public Sub New (
    clientFtp As FtpClient
)
public:
FtpClientConnectionEventArgs(
    FtpClient^ clientFtp
)
new :
        clientFtp : FtpClient -> FtpClientConnectionEventArgs

Parametri

clientFtp FtpClient
Client FTP.
Vedi anche

Documentazione

Classe FtpClientConnectionEventArgs
Namespace DedNet


Proprietà di FtpClientConnectionEventArgs

Il tipo FtpClientConnectionEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | ClientFtp | Restituisce la commessa.
Torna su
Vedi anche

Documentazione

Classe FtpClientConnectionEventArgs
Namespace DedNet


Proprietà FtpClientConnectionEventArgs.ClientFtp

Proprietà FtpClientConnectionEventArgsClientFtp
Restituisce la commessa.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public FtpClient ClientFtp { get; set; }
Public Property ClientFtp As FtpClient
    Get
    Set
public:
property FtpClient^ ClientFtp {
    FtpClient^ get ();
    void set (FtpClient^ value);
}
member ClientFtp : FtpClient with get, set

Valore della proprietà

FtpClient
Vedi anche

Documentazione

Classe FtpClientConnectionEventArgs
Namespace DedNet


Classe GetDocPropertiesEventArgs
Classe usata per ricavare le proprietà di una lista di file.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetGetDocPropertiesEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class GetDocPropertiesEventArgs : EventArgs
Public Class GetDocPropertiesEventArgs
    Inherits EventArgs
public ref class GetDocPropertiesEventArgs : public EventArgs
type GetDocPropertiesEventArgs =
    class
        inherit EventArgs
    end

Il tipo GetDocPropertiesEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | GetDocPropertiesEventArgs | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | FileNames | Lista di file da analizzare.
Proprietà pubblica | Properties | Dizionario contenente proprietà e relativa lista di estensioni che la contengono.
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore GetDocPropertiesEventArgs
Costruttore unico.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public GetDocPropertiesEventArgs(
    string[] filenames
)
Public Sub New (
    filenames As String()
)
public:
GetDocPropertiesEventArgs(
    array<String^>^ filenames
)
new :
        filenames : string[] -> GetDocPropertiesEventArgs

Parametri

filenames String
Nomi file.
Vedi anche

Documentazione

Classe GetDocPropertiesEventArgs
Namespace DedNet


Proprietà di GetDocPropertiesEventArgs

Il tipo GetDocPropertiesEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | FileNames | Lista di file da analizzare.
Proprietà pubblica | Properties | Dizionario contenente proprietà e relativa lista di estensioni che la contengono.
Torna su
Vedi anche

Documentazione

Classe GetDocPropertiesEventArgs
Namespace DedNet


Proprietà GetDocPropertiesEventArgs.FileNames

Proprietà GetDocPropertiesEventArgsFileNames
Lista di file da analizzare.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string[] FileNames { get; }
Public ReadOnly Property FileNames As String()
    Get
public:
property array<String^>^ FileNames {
    array<String^>^ get ();
}
member FileNames : string[] with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe GetDocPropertiesEventArgs
Namespace DedNet


Proprietà GetDocPropertiesEventArgs.Properties

Proprietà GetDocPropertiesEventArgsProperties
Dizionario contenente proprietà e relativa lista di estensioni che la contengono.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<string, List<string>> Properties { get; set; }
Public Property Properties As Dictionary(Of String, List(Of String))
    Get
    Set
public:
property Dictionary<String^, List<String^>^>^ Properties {
    Dictionary<String^, List<String^>^>^ get ();
    void set (Dictionary<String^, List<String^>^>^ value);
}
member Properties : Dictionary<string, List<string>> with get, set

Valore della proprietà

Dictionary String, List String
Vedi anche

Documentazione

Classe GetDocPropertiesEventArgs
Namespace DedNet


Classe GetRepresentationSuffixListEventArgs
Classe usata per gestire l'importazione della lista di suffissi tra cui scegliere in creazione di una Rappresentazione.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetDedBeforeOrAfterEventArgs
DedNetDedEventArgs
DedNetGetRepresentationSuffixListEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class GetRepresentationSuffixListEventArgs : DedEventArgs
Public Class GetRepresentationSuffixListEventArgs
    Inherits DedEventArgs
public ref class GetRepresentationSuffixListEventArgs : public DedEventArgs
type GetRepresentationSuffixListEventArgs =
    class
        inherit DedEventArgs
    end

Il tipo GetRepresentationSuffixListEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | GetRepresentationSuffixListEventArgs | Costruttore unico.
Metodo pubblico | GetRepresentationSuffixListEventArgs(String) | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | CurrentVal | Valore corrente generato automaticamente dal DED.
Proprietà pubblica | DefaultVal | Valore di default preselezionato nella tendina.
Proprietà pubblica | DisableEdit | Flag che indica se disabilitare l'editazione per l'utente.
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Proprietà pubblica | Values | Lista di valori da visualizzare.
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore GetRepresentationSuffixListEventArgs
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | GetRepresentationSuffixListEventArgs | Costruttore unico.
Metodo pubblico | GetRepresentationSuffixListEventArgs(String) | Costruttore unico.
Torna su
Vedi anche

Documentazione

Classe GetRepresentationSuffixListEventArgs
Namespace DedNet


Costruttore GetRepresentationSuffixListEventArgs
Costruttore unico.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public GetRepresentationSuffixListEventArgs()
Public Sub New
public:
GetRepresentationSuffixListEventArgs()
new : unit -> GetRepresentationSuffixListEventArgs
Vedi anche

Documentazione

Classe GetRepresentationSuffixListEventArgs
Overload di GetRepresentationSuffixListEventArgs
Namespace DedNet


Costruttore GetRepresentationSuffixListEventArgs(String)
Costruttore unico.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public GetRepresentationSuffixListEventArgs(
    string currentVal
)
Public Sub New (
    currentVal As String
)
public:
GetRepresentationSuffixListEventArgs(
    String^ currentVal
)
new :
        currentVal : string -> GetRepresentationSuffixListEventArgs

Parametri

currentVal String
Valore corrente generato dal DED.
Vedi anche

Documentazione

Classe GetRepresentationSuffixListEventArgs
Overload di GetRepresentationSuffixListEventArgs
Namespace DedNet


Proprietà di GetRepresentationSuffixListEventArgs

Il tipo GetRepresentationSuffixListEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | CurrentVal | Valore corrente generato automaticamente dal DED.
Proprietà pubblica | DefaultVal | Valore di default preselezionato nella tendina.
Proprietà pubblica | DisableEdit | Flag che indica se disabilitare l'editazione per l'utente.
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Proprietà pubblica | Values | Lista di valori da visualizzare.
Torna su
Vedi anche

Documentazione

Classe GetRepresentationSuffixListEventArgs
Namespace DedNet


Proprietà GetRepresentationSuffixListEventArgs.CurrentVal

Proprietà GetRepresentationSuffixListEventArgsCurrentVal
Valore corrente generato automaticamente dal DED.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string CurrentVal { get; }
Public ReadOnly Property CurrentVal As String
    Get
public:
property String^ CurrentVal {
    String^ get ();
}
member CurrentVal : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe GetRepresentationSuffixListEventArgs
Namespace DedNet


Proprietà GetRepresentationSuffixListEventArgs.DefaultVal

Proprietà GetRepresentationSuffixListEventArgsDefaultVal
Valore di default preselezionato nella tendina.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string DefaultVal { get; set; }
Public Property DefaultVal As String
    Get
    Set
public:
property String^ DefaultVal {
    String^ get ();
    void set (String^ value);
}
member DefaultVal : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe GetRepresentationSuffixListEventArgs
Namespace DedNet


Proprietà GetRepresentationSuffixListEventArgs.DisableEdit

Proprietà GetRepresentationSuffixListEventArgsDisableEdit
Flag che indica se disabilitare l'editazione per l'utente.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool DisableEdit { get; set; }
Public Property DisableEdit As Boolean
    Get
    Set
public:
property bool DisableEdit {
    bool get ();
    void set (bool value);
}
member DisableEdit : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe GetRepresentationSuffixListEventArgs
Namespace DedNet


Proprietà GetRepresentationSuffixListEventArgs.Values

Proprietà GetRepresentationSuffixListEventArgsValues
Lista di valori da visualizzare.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> Values { get; set; }
Public Property Values As List(Of String)
    Get
    Set
public:
property List<String^>^ Values {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
member Values : List<string> with get, set

Valore della proprietà

List String
Vedi anche

Documentazione

Classe GetRepresentationSuffixListEventArgs
Namespace DedNet


Interfaccia IDedNetApplication
Interfaccia per la visibilità COM della classe principale.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public interface IDedNetApplication
Public Interface IDedNetApplication
public interface class IDedNetApplication
type IDedNetApplication = interface end

Il tipo IDedNetApplication espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Connection | Restituisce l'oggetto QSConnection correntemente utilizzato dall'applicazione.
Proprietà pubblica | ConnectionString | Imposta o restituisce la stringa di connesione al Database.
Proprietà pubblica | Initialized | Restituisce se l'inizializzazione dell'oggetto è già avvenuta correttamente attraverso la chiamata al metodo Init() con esito positivo.
Proprietà pubblica | IsDisposed | Restituisce true se è stato già fatto il Dispose dell'oggetto.
Proprietà pubblica | LastError | Restituisce l'ultimo errore che si è verificato utilizzando i metodi e le proprietà di questa interfaccia.
Proprietà pubblica | ProviderName | Imposta o restituisce il nome completo della classe del provider di collegamento al Database.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Init | Inizializza le strutture dati e le variabili leggendole dal Database. Se restituisce false l'errore avvenuto è reperibile attraverso la proprietà LastError.
Metodo pubblico | Init(String, String) | Inizializza le strutture dati e le variabili leggendole dal Database utilizzando una specifica stringa di connessione. Se restituisce false l'errore avvenuto è reperibile attraverso la proprietà LastError.
Torna su
Vedi anche

Documentazione

Namespace DedNet


Proprietà di IDedNetApplication

Il tipo IDedNetApplication espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Connection | Restituisce l'oggetto QSConnection correntemente utilizzato dall'applicazione.
Proprietà pubblica | ConnectionString | Imposta o restituisce la stringa di connesione al Database.
Proprietà pubblica | Initialized | Restituisce se l'inizializzazione dell'oggetto è già avvenuta correttamente attraverso la chiamata al metodo Init() con esito positivo.
Proprietà pubblica | IsDisposed | Restituisce true se è stato già fatto il Dispose dell'oggetto.
Proprietà pubblica | LastError | Restituisce l'ultimo errore che si è verificato utilizzando i metodi e le proprietà di questa interfaccia.
Proprietà pubblica | ProviderName | Imposta o restituisce il nome completo della classe del provider di collegamento al Database.
Torna su
Vedi anche

Documentazione

Interfaccia IDedNetApplication
Namespace DedNet


Proprietà IDedNetApplication.Connection

Proprietà IDedNetApplicationConnection
Restituisce l'oggetto QSConnection correntemente utilizzato dall'applicazione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
QSConnection Connection { get; }
ReadOnly Property Connection As QSConnection
    Get
property QSConnection^ Connection {
    QSConnection^ get ();
}
abstract Connection : QSConnection with get

Valore della proprietà

QSConnection
Vedi anche

Documentazione

Interfaccia IDedNetApplication
Namespace DedNet


Proprietà IDedNetApplication.ConnectionString

Proprietà IDedNetApplicationConnectionString
Imposta o restituisce la stringa di connesione al Database.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
string ConnectionString { get; set; }
Property ConnectionString As String
    Get
    Set
property String^ ConnectionString {
    String^ get ();
    void set (String^ value);
}
abstract ConnectionString : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Interfaccia IDedNetApplication
Namespace DedNet


Proprietà IDedNetApplication.Initialized

Proprietà IDedNetApplicationInitialized
Restituisce se l'inizializzazione dell'oggetto è già avvenuta correttamente attraverso la chiamata al metodo Init() con esito positivo.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
bool Initialized { get; }
ReadOnly Property Initialized As Boolean
    Get
property bool Initialized {
    bool get ();
}
abstract Initialized : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Interfaccia IDedNetApplication
Namespace DedNet


Proprietà IDedNetApplication.IsDisposed

Proprietà IDedNetApplicationIsDisposed
Restituisce true se è stato già fatto il Dispose dell'oggetto.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
bool IsDisposed { get; }
ReadOnly Property IsDisposed As Boolean
    Get
property bool IsDisposed {
    bool get ();
}
abstract IsDisposed : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Interfaccia IDedNetApplication
Namespace DedNet


Proprietà IDedNetApplication.LastError

Proprietà IDedNetApplicationLastError
Restituisce l'ultimo errore che si è verificato utilizzando i metodi e le proprietà di questa interfaccia.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
string LastError { get; }
ReadOnly Property LastError As String
    Get
property String^ LastError {
    String^ get ();
}
abstract LastError : string with get

Valore di ritorno

String
Restituisce la stringa di errore oppure "" se non ne sono avvenuti.
Vedi anche

Documentazione

Interfaccia IDedNetApplication
Namespace DedNet


Proprietà IDedNetApplication.ProviderName

Proprietà IDedNetApplicationProviderName
Imposta o restituisce il nome completo della classe del provider di collegamento al Database.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
string ProviderName { get; set; }
Property ProviderName As String
    Get
    Set
property String^ ProviderName {
    String^ get ();
    void set (String^ value);
}
abstract ProviderName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Interfaccia IDedNetApplication
Namespace DedNet


Metodi di IDedNetApplication

Il tipo IDedNetApplication espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Init | Inizializza le strutture dati e le variabili leggendole dal Database. Se restituisce false l'errore avvenuto è reperibile attraverso la proprietà LastError.
Metodo pubblico | Init(String, String) | Inizializza le strutture dati e le variabili leggendole dal Database utilizzando una specifica stringa di connessione. Se restituisce false l'errore avvenuto è reperibile attraverso la proprietà LastError.
Torna su
Vedi anche

Documentazione

Interfaccia IDedNetApplication
Namespace DedNet


Metodo IDedNetApplication.Init

Metodo IDedNetApplicationInit
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Init | Inizializza le strutture dati e le variabili leggendole dal Database. Se restituisce false l'errore avvenuto è reperibile attraverso la proprietà LastError.
Metodo pubblico | Init(String, String) | Inizializza le strutture dati e le variabili leggendole dal Database utilizzando una specifica stringa di connessione. Se restituisce false l'errore avvenuto è reperibile attraverso la proprietà LastError.
Torna su
Vedi anche

Documentazione

Interfaccia IDedNetApplication
Namespace DedNet


Metodo IDedNetApplication.Init

Metodo IDedNetApplicationInit
Inizializza le strutture dati e le variabili leggendole dal Database. Se restituisce false l'errore avvenuto è reperibile attraverso la proprietà LastError.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
bool Init()
Function Init As Boolean
bool Init()
abstract Init : unit -> bool

Valore di ritorno

Boolean
Restituisce true se riesce altrimenti false.
Vedi anche

Documentazione

Interfaccia IDedNetApplication
Overload di Init
Namespace DedNet


Metodo IDedNetApplication.Init(String, String)

Metodo IDedNetApplicationInit(String, String)
Inizializza le strutture dati e le variabili leggendole dal Database utilizzando una specifica stringa di connessione. Se restituisce false l'errore avvenuto è reperibile attraverso la proprietà LastError.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
bool Init(
    string prividerName,
    string connectionString
)
Function Init (
    prividerName As String,
    connectionString As String
) As Boolean
bool Init(
    String^ prividerName,
    String^ connectionString
)
abstract Init :
        prividerName : string *
        connectionString : string -> bool

Parametri

prividerName String
Nome del provider per la connessione al Database.
connectionString String
Stringa di connessione per connettersi al Database.

Valore di ritorno

Boolean
Restituisce true se riesce altrimenti false.
Vedi anche

Documentazione

Interfaccia IDedNetApplication
Overload di Init
Namespace DedNet


Classe ImportAttListEventArgs
Classe usata per gestire l'importazione delle liste att da fonti dati esterne.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetImportAttListEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ImportAttListEventArgs : EventArgs
Public Class ImportAttListEventArgs
    Inherits EventArgs
public ref class ImportAttListEventArgs : public EventArgs
type ImportAttListEventArgs =
    class
        inherit EventArgs
    end

Il tipo ImportAttListEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ImportAttListEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Attr | Attributo a cui è bindata la lista.
Proprietà pubblica | List | Lista calcolata esternamente.
Proprietà pubblica | Type | Famiglia a cui appartiene l'attributo.
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore ImportAttListEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ImportAttListEventArgs()
Public Sub New
public:
ImportAttListEventArgs()
new : unit -> ImportAttListEventArgs
Vedi anche

Documentazione

Classe ImportAttListEventArgs
Namespace DedNet


Proprietà di ImportAttListEventArgs

Il tipo ImportAttListEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Attr | Attributo a cui è bindata la lista.
Proprietà pubblica | List | Lista calcolata esternamente.
Proprietà pubblica | Type | Famiglia a cui appartiene l'attributo.
Torna su
Vedi anche

Documentazione

Classe ImportAttListEventArgs
Namespace DedNet


Proprietà ImportAttListEventArgs.Attr

Proprietà ImportAttListEventArgsAttr
Attributo a cui è bindata la lista.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttr Attr { get; set; }
Public Property Attr As DedAttr
    Get
    Set
public:
property DedAttr^ Attr {
    DedAttr^ get ();
    void set (DedAttr^ value);
}
member Attr : DedAttr with get, set

Valore della proprietà

DedAttr
Vedi anche

Documentazione

Classe ImportAttListEventArgs
Namespace DedNet


Proprietà ImportAttListEventArgs.List

Proprietà ImportAttListEventArgsList
Lista calcolata esternamente.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAtt List { get; set; }
Public Property List As DedAtt
    Get
    Set
public:
property DedAtt^ List {
    DedAtt^ get ();
    void set (DedAtt^ value);
}
member List : DedAtt with get, set

Valore della proprietà

DedAtt
Vedi anche

Documentazione

Classe ImportAttListEventArgs
Namespace DedNet


Proprietà ImportAttListEventArgs.Type

Proprietà ImportAttListEventArgsType
Famiglia a cui appartiene l'attributo.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeBase Type { get; set; }
Public Property Type As DedTypeBase
    Get
    Set
public:
property DedTypeBase^ Type {
    DedTypeBase^ get ();
    void set (DedTypeBase^ value);
}
member Type : DedTypeBase with get, set

Valore della proprietà

DedTypeBase
Vedi anche

Documentazione

Classe ImportAttListEventArgs
Namespace DedNet


Classe ImportAttrValueEventArgs
Classe usata per gestire l'importazione del valore attributo da fonti dati esterne.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetImportAttrValueEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ImportAttrValueEventArgs : EventArgs
Public Class ImportAttrValueEventArgs
    Inherits EventArgs
public ref class ImportAttrValueEventArgs : public EventArgs
type ImportAttrValueEventArgs =
    class
        inherit EventArgs
    end

Il tipo ImportAttrValueEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ImportAttrValueEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Attr | Nome dell'attributo.
Proprietà pubblica | BomItem | Distinta.
Proprietà pubblica | Comm | Commessa.
Proprietà pubblica | Data | Anagrafica.
Proprietà pubblica | Type | Famiglia dell'attributo.
Proprietà pubblica | Value | Valore calcolato esternamente.
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore ImportAttrValueEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ImportAttrValueEventArgs()
Public Sub New
public:
ImportAttrValueEventArgs()
new : unit -> ImportAttrValueEventArgs
Vedi anche

Documentazione

Classe ImportAttrValueEventArgs
Namespace DedNet


Proprietà di ImportAttrValueEventArgs

Il tipo ImportAttrValueEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Attr | Nome dell'attributo.
Proprietà pubblica | BomItem | Distinta.
Proprietà pubblica | Comm | Commessa.
Proprietà pubblica | Data | Anagrafica.
Proprietà pubblica | Type | Famiglia dell'attributo.
Proprietà pubblica | Value | Valore calcolato esternamente.
Torna su
Vedi anche

Documentazione

Classe ImportAttrValueEventArgs
Namespace DedNet


Proprietà ImportAttrValueEventArgs.Attr

Proprietà ImportAttrValueEventArgsAttr
Nome dell'attributo.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttr Attr { get; set; }
Public Property Attr As DedAttr
    Get
    Set
public:
property DedAttr^ Attr {
    DedAttr^ get ();
    void set (DedAttr^ value);
}
member Attr : DedAttr with get, set

Valore della proprietà

DedAttr
Vedi anche

Documentazione

Classe ImportAttrValueEventArgs
Namespace DedNet


Proprietà ImportAttrValueEventArgs.BomItem

Proprietà ImportAttrValueEventArgsBomItem
Distinta.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItem BomItem { get; set; }
Public Property BomItem As BomItem
    Get
    Set
public:
property BomItem^ BomItem {
    BomItem^ get ();
    void set (BomItem^ value);
}
member BomItem : BomItem with get, set

Valore della proprietà

BomItem
Vedi anche

Documentazione

Classe ImportAttrValueEventArgs
Namespace DedNet


Proprietà ImportAttrValueEventArgs.Comm

Proprietà ImportAttrValueEventArgsComm
Commessa.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedComm Comm { get; set; }
Public Property Comm As DedComm
    Get
    Set
public:
property DedComm^ Comm {
    DedComm^ get ();
    void set (DedComm^ value);
}
member Comm : DedComm with get, set

Valore della proprietà

DedComm
Vedi anche

Documentazione

Classe ImportAttrValueEventArgs
Namespace DedNet


Proprietà ImportAttrValueEventArgs.Data

Proprietà ImportAttrValueEventArgsData
Anagrafica.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public IDedData Data { get; set; }
Public Property Data As IDedData
    Get
    Set
public:
property IDedData^ Data {
    IDedData^ get ();
    void set (IDedData^ value);
}
member Data : IDedData with get, set

Valore della proprietà

IDedData
Vedi anche

Documentazione

Classe ImportAttrValueEventArgs
Namespace DedNet


Proprietà ImportAttrValueEventArgs.Type

Proprietà ImportAttrValueEventArgsType
Famiglia dell'attributo.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeBase Type { get; set; }
Public Property Type As DedTypeBase
    Get
    Set
public:
property DedTypeBase^ Type {
    DedTypeBase^ get ();
    void set (DedTypeBase^ value);
}
member Type : DedTypeBase with get, set

Valore della proprietà

DedTypeBase
Vedi anche

Documentazione

Classe ImportAttrValueEventArgs
Namespace DedNet


Proprietà ImportAttrValueEventArgs.Value

Proprietà ImportAttrValueEventArgsValue
Valore calcolato esternamente.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object Value { get; set; }
Public Property Value As Object
    Get
    Set
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}
member Value : Object with get, set

Valore della proprietà

Object
Vedi anche

Documentazione

Classe ImportAttrValueEventArgs
Namespace DedNet


Classe ImportDataCanUpdateEventArgs
Classe usate per gestire l'anagrafica da aggiornare nel comando Importa Dati
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetImportDataCanUpdateEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ImportDataCanUpdateEventArgs : EventArgs
Public Class ImportDataCanUpdateEventArgs
    Inherits EventArgs
public ref class ImportDataCanUpdateEventArgs : public EventArgs
type ImportDataCanUpdateEventArgs =
    class
        inherit EventArgs
    end

Il tipo ImportDataCanUpdateEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ImportDataCanUpdateEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Data | Anagrafica che sta per essere aggiornata
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore ImportDataCanUpdateEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ImportDataCanUpdateEventArgs()
Public Sub New
public:
ImportDataCanUpdateEventArgs()
new : unit -> ImportDataCanUpdateEventArgs
Vedi anche

Documentazione

Classe ImportDataCanUpdateEventArgs
Namespace DedNet


Proprietà di ImportDataCanUpdateEventArgs

Il tipo ImportDataCanUpdateEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Data | Anagrafica che sta per essere aggiornata
Torna su
Vedi anche

Documentazione

Classe ImportDataCanUpdateEventArgs
Namespace DedNet


Proprietà ImportDataCanUpdateEventArgs.Data

Proprietà ImportDataCanUpdateEventArgsData
Anagrafica che sta per essere aggiornata

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; set; }
Public Property Data As DedData
    Get
    Set
public:
property DedData^ Data {
    DedData^ get ();
    void set (DedData^ value);
}
member Data : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe ImportDataCanUpdateEventArgs
Namespace DedNet


Classe ImportedDocStructInfoEventArgs
Argomento utilizzato nell'evento di post importazione elemento sull'angrafica.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetDedBeforeOrAfterEventArgs
DedNetDocStructInfoEventArgs
DedNetImportedDocStructInfoEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ImportedDocStructInfoEventArgs : DocStructInfoEventArgs
Public Class ImportedDocStructInfoEventArgs
    Inherits DocStructInfoEventArgs
public ref class ImportedDocStructInfoEventArgs : public DocStructInfoEventArgs
type ImportedDocStructInfoEventArgs =
    class
        inherit DocStructInfoEventArgs
    end

Il tipo ImportedDocStructInfoEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Data | Specifica l'anagrafica di riferimento per l'operazione di importazione
Proprietà pubblica | DocStructInfo | Restituisce il DocStructInfo di riferimento. (Ereditato da DocStructInfoEventArgs)
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | UseUI | Specifica se utilizzare o meno l'interfaccia utente all'interno del delegate dell'evento (Ereditato da DocStructInfoEventArgs)
Torna su
Vedi anche

Documentazione

Namespace DedNet


Proprietà di ImportedDocStructInfoEventArgs

Il tipo ImportedDocStructInfoEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Data | Specifica l'anagrafica di riferimento per l'operazione di importazione
Proprietà pubblica | DocStructInfo | Restituisce il DocStructInfo di riferimento. (Ereditato da DocStructInfoEventArgs)
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | UseUI | Specifica se utilizzare o meno l'interfaccia utente all'interno del delegate dell'evento (Ereditato da DocStructInfoEventArgs)
Torna su
Vedi anche

Documentazione

Classe ImportedDocStructInfoEventArgs
Namespace DedNet


Proprietà ImportedDocStructInfoEventArgs.Data

Proprietà ImportedDocStructInfoEventArgsData
Specifica l'anagrafica di riferimento per l'operazione di importazione

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; set; }
Public Property Data As DedData
    Get
    Set
public:
property DedData^ Data {
    DedData^ get ();
    void set (DedData^ value);
}
member Data : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe ImportedDocStructInfoEventArgs
Namespace DedNet


Classe ImportOnSaveEventArgs
Argomento utilizzato per l'evento di salvataggio in caso di documenti appartenenti a root presenti nella variabile ROOTS_RECOGNIZED_ON_DBSAVE.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetDedBeforeOrAfterEventArgs
DedNetDedEventArgs
DedNetImportOnSaveEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ImportOnSaveEventArgs : DedEventArgs
Public Class ImportOnSaveEventArgs
    Inherits DedEventArgs
public ref class ImportOnSaveEventArgs : public DedEventArgs
type ImportOnSaveEventArgs =
    class
        inherit DedEventArgs
    end

Il tipo ImportOnSaveEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ImportOnSaveEventArgs | Costruttore. Salva gli argomenti nei campi
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | DsInfo | Restituisce il docstructinfo in elaborazione.
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Proprietà pubblica | ImportFileInNewData | Restituisce il docstructinfo in elaborazione.
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore ImportOnSaveEventArgs
Costruttore. Salva gli argomenti nei campi

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ImportOnSaveEventArgs(
    DocStructInfo dsInfo,
    bool importFileInNewData
)
Public Sub New (
    dsInfo As DocStructInfo,
    importFileInNewData As Boolean
)
public:
ImportOnSaveEventArgs(
    DocStructInfo^ dsInfo,
    bool importFileInNewData
)
new :
        dsInfo : DocStructInfo *
        importFileInNewData : bool -> ImportOnSaveEventArgs

Parametri

dsInfo DocStructInfo
importFileInNewData Boolean
Vedi anche

Documentazione

Classe ImportOnSaveEventArgs
Namespace DedNet


Proprietà di ImportOnSaveEventArgs

Il tipo ImportOnSaveEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | DsInfo | Restituisce il docstructinfo in elaborazione.
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Proprietà pubblica | ImportFileInNewData | Restituisce il docstructinfo in elaborazione.
Torna su
Vedi anche

Documentazione

Classe ImportOnSaveEventArgs
Namespace DedNet


Proprietà ImportOnSaveEventArgs.DsInfo

Proprietà ImportOnSaveEventArgsDsInfo
Restituisce il docstructinfo in elaborazione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfo DsInfo { get; }
Public ReadOnly Property DsInfo As DocStructInfo
    Get
public:
property DocStructInfo^ DsInfo {
    DocStructInfo^ get ();
}
member DsInfo : DocStructInfo with get

Valore della proprietà

DocStructInfo
Vedi anche

Documentazione

Classe ImportOnSaveEventArgs
Namespace DedNet


Proprietà ImportOnSaveEventArgs.ImportFileInNewData

Proprietà ImportOnSaveEventArgsImportFileInNewData
Restituisce il docstructinfo in elaborazione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ImportFileInNewData { get; set; }
Public Property ImportFileInNewData As Boolean
    Get
    Set
public:
property bool ImportFileInNewData {
    bool get ();
    void set (bool value);
}
member ImportFileInNewData : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ImportOnSaveEventArgs
Namespace DedNet


Classe ListImportDataEventArgs
Classe usata per gestire la validazione di un codice durante l'importazione in una lista
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetDedBeforeOrAfterEventArgs
DedNetDedEventArgs
DedNetListImportDataEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ListImportDataEventArgs : DedEventArgs
Public Class ListImportDataEventArgs
    Inherits DedEventArgs
public ref class ListImportDataEventArgs : public DedEventArgs
type ListImportDataEventArgs =
    class
        inherit DedEventArgs
    end

Il tipo ListImportDataEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ListImportDataEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | Data | Anagrafica importata.
Proprietà pubblica | ElaborationType | Tipo di elaborazione.
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Proprietà pubblica | Qta | Quantità di importazione.
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore ListImportDataEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ListImportDataEventArgs()
Public Sub New
public:
ListImportDataEventArgs()
new : unit -> ListImportDataEventArgs
Vedi anche

Documentazione

Classe ListImportDataEventArgs
Namespace DedNet


Proprietà di ListImportDataEventArgs

Il tipo ListImportDataEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | Data | Anagrafica importata.
Proprietà pubblica | ElaborationType | Tipo di elaborazione.
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Proprietà pubblica | Qta | Quantità di importazione.
Torna su
Vedi anche

Documentazione

Classe ListImportDataEventArgs
Namespace DedNet


Proprietà ListImportDataEventArgs.Data

Proprietà ListImportDataEventArgsData
Anagrafica importata.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; set; }
Public Property Data As DedData
    Get
    Set
public:
property DedData^ Data {
    DedData^ get ();
    void set (DedData^ value);
}
member Data : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe ListImportDataEventArgs
Namespace DedNet


Proprietà ListImportDataEventArgs.ElaborationType

Proprietà ListImportDataEventArgsElaborationType
Tipo di elaborazione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ListElaborationTypeEnum ElaborationType { get; set; }
Public Property ElaborationType As ListElaborationTypeEnum
    Get
    Set
public:
property ListElaborationTypeEnum ElaborationType {
    ListElaborationTypeEnum get ();
    void set (ListElaborationTypeEnum value);
}
member ElaborationType : ListElaborationTypeEnum with get, set

Valore della proprietà

ListElaborationTypeEnum
Vedi anche

Documentazione

Classe ListImportDataEventArgs
Namespace DedNet


Proprietà ListImportDataEventArgs.Qta

Proprietà ListImportDataEventArgsQta
Quantità di importazione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public double Qta { get; set; }
Public Property Qta As Double
    Get
    Set
public:
property double Qta {
    double get ();
    void set (double value);
}
member Qta : float with get, set

Valore della proprietà

Double
Vedi anche

Documentazione

Classe ListImportDataEventArgs
Namespace DedNet


Classe LoadFormCommEditEventArgs
Argomento per l'evento di visualizzazione del form di editazione delle commesse.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetLoadFormCommEditEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class LoadFormCommEditEventArgs : EventArgs
Public Class LoadFormCommEditEventArgs
    Inherits EventArgs
public ref class LoadFormCommEditEventArgs : public EventArgs
type LoadFormCommEditEventArgs =
    class
        inherit EventArgs
    end

Il tipo LoadFormCommEditEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | LoadFormCommEditEventArgs | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Form |
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore LoadFormCommEditEventArgs
Costruttore

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public LoadFormCommEditEventArgs(
    DedFormEditComm form
)
Public Sub New (
    form As DedFormEditComm
)
public:
LoadFormCommEditEventArgs(
    DedFormEditComm^ form
)
new :
        form : DedFormEditComm -> LoadFormCommEditEventArgs

Parametri

form DedFormEditComm
Vedi anche

Documentazione

Classe LoadFormCommEditEventArgs
Namespace DedNet


Proprietà di LoadFormCommEditEventArgs

Il tipo LoadFormCommEditEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Form |
Torna su
Vedi anche

Documentazione

Classe LoadFormCommEditEventArgs
Namespace DedNet


Proprietà LoadFormCommEditEventArgs.Form

Proprietà LoadFormCommEditEventArgsForm

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormEditComm Form { get; }
Public ReadOnly Property Form As DedFormEditComm
    Get
public:
property DedFormEditComm^ Form {
    DedFormEditComm^ get ();
}
member Form : DedFormEditComm with get

Valore della proprietà

DedFormEditComm
Vedi anche

Documentazione

Classe LoadFormCommEditEventArgs
Namespace DedNet


Classe ManagePlaceHolderEventArgs
Informazioni per l'override della logica dei placeholder.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetDedBeforeOrAfterEventArgs
DedNetDedEventArgs
DedNetManagePlaceHolderEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ManagePlaceHolderEventArgs : DedEventArgs
Public Class ManagePlaceHolderEventArgs
    Inherits DedEventArgs
public ref class ManagePlaceHolderEventArgs : public DedEventArgs
type ManagePlaceHolderEventArgs =
    class
        inherit DedEventArgs
    end

Il tipo ManagePlaceHolderEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ManagePlaceHolderEventArgs | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | DelToMake | Restituisce se sull'elemento è impostato di fare il .del
Proprietà pubblica | DestPath | Percorso di destinazione in cui verrà messo il documento
Proprietà pubblica | DestType | Eventuale famiglia in cui verrà impostato il documento
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | ForcedInfo | Eventuali dati forzati da fuori
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Proprietà pubblica | Item | DocStrucInfo dell'elemento in elborazione
Proprietà pubblica | MoveInsteadOfCopy | Restituisce se sull'elemento è impostato di fare il .moved
Proprietà pubblica | MoveInsteadOfCopyPlaceHolderEnforced | Restituisce se l'elemento fa parte delle famiglie con moved forzato e anagrafica da impostare obsoleta
Proprietà pubblica | Msg | Eventuale messaggio da mostrare all'utente nel caso non abbia possibilità di scelta per spiegarne il motivo
Proprietà pubblica | StartingData | Eventuale anagrafica di partenza
Proprietà pubblica | UserCanChoice | Imposta o restituisce se l'utente ha facoltà di scegliere se fare uno sposata o un copia
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | SetMoveOrDel | Permette di settare se fare il moved/del NOTE : Da chiamare una volta sola
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore ManagePlaceHolderEventArgs
Costruttore

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ManagePlaceHolderEventArgs(
    MoveDocumentResult mdRes
)
Public Sub New (
    mdRes As MoveDocumentResult
)
public:
ManagePlaceHolderEventArgs(
    MoveDocumentResult^ mdRes
)
new :
        mdRes : MoveDocumentResult -> ManagePlaceHolderEventArgs

Parametri

mdRes MoveDocumentResult
Vedi anche

Documentazione

Classe ManagePlaceHolderEventArgs
Namespace DedNet


Proprietà di ManagePlaceHolderEventArgs

Il tipo ManagePlaceHolderEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | DelToMake | Restituisce se sull'elemento è impostato di fare il .del
Proprietà pubblica | DestPath | Percorso di destinazione in cui verrà messo il documento
Proprietà pubblica | DestType | Eventuale famiglia in cui verrà impostato il documento
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | ForcedInfo | Eventuali dati forzati da fuori
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Proprietà pubblica | Item | DocStrucInfo dell'elemento in elborazione
Proprietà pubblica | MoveInsteadOfCopy | Restituisce se sull'elemento è impostato di fare il .moved
Proprietà pubblica | MoveInsteadOfCopyPlaceHolderEnforced | Restituisce se l'elemento fa parte delle famiglie con moved forzato e anagrafica da impostare obsoleta
Proprietà pubblica | Msg | Eventuale messaggio da mostrare all'utente nel caso non abbia possibilità di scelta per spiegarne il motivo
Proprietà pubblica | StartingData | Eventuale anagrafica di partenza
Proprietà pubblica | UserCanChoice | Imposta o restituisce se l'utente ha facoltà di scegliere se fare uno sposata o un copia
Torna su
Vedi anche

Documentazione

Classe ManagePlaceHolderEventArgs
Namespace DedNet


Proprietà ManagePlaceHolderEventArgs.DelToMake

Proprietà ManagePlaceHolderEventArgsDelToMake
Restituisce se sull'elemento è impostato di fare il .del

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool DelToMake { get; }
Public ReadOnly Property DelToMake As Boolean
    Get
public:
property bool DelToMake {
    bool get ();
}
member DelToMake : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ManagePlaceHolderEventArgs
Namespace DedNet


Proprietà ManagePlaceHolderEventArgs.DestPath

Proprietà ManagePlaceHolderEventArgsDestPath
Percorso di destinazione in cui verrà messo il documento

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string DestPath { get; }
Public ReadOnly Property DestPath As String
    Get
public:
property String^ DestPath {
    String^ get ();
}
member DestPath : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe ManagePlaceHolderEventArgs
Namespace DedNet


Proprietà ManagePlaceHolderEventArgs.DestType

Proprietà ManagePlaceHolderEventArgsDestType
Eventuale famiglia in cui verrà impostato il documento

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeBase DestType { get; }
Public ReadOnly Property DestType As DedTypeBase
    Get
public:
property DedTypeBase^ DestType {
    DedTypeBase^ get ();
}
member DestType : DedTypeBase with get

Valore della proprietà

DedTypeBase
Vedi anche

Documentazione

Classe ManagePlaceHolderEventArgs
Namespace DedNet


Proprietà ManagePlaceHolderEventArgs.ForcedInfo

Proprietà ManagePlaceHolderEventArgsForcedInfo
Eventuali dati forzati da fuori

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public MoveDocumentInfoForcedMoveInfo ForcedInfo { get; }
Public ReadOnly Property ForcedInfo As MoveDocumentInfoForcedMoveInfo
    Get
public:
property MoveDocumentInfoForcedMoveInfo^ ForcedInfo {
    MoveDocumentInfoForcedMoveInfo^ get ();
}
member ForcedInfo : MoveDocumentInfoForcedMoveInfo with get

Valore della proprietà

MoveDocumentInfoForcedMoveInfo
Vedi anche

Documentazione

Classe ManagePlaceHolderEventArgs
Namespace DedNet


Proprietà ManagePlaceHolderEventArgs.Item

Proprietà ManagePlaceHolderEventArgsItem
DocStrucInfo dell'elemento in elborazione

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfo Item { get; }
Public ReadOnly Property Item As DocStructInfo
    Get
public:
property DocStructInfo^ Item {
    DocStructInfo^ get ();
}
member Item : DocStructInfo with get

Valore della proprietà

DocStructInfo
Vedi anche

Documentazione

Classe ManagePlaceHolderEventArgs
Namespace DedNet


Proprietà ManagePlaceHolderEventArgs.MoveInsteadOfCopy

Proprietà ManagePlaceHolderEventArgsMoveInsteadOfCopy
Restituisce se sull'elemento è impostato di fare il .moved

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool MoveInsteadOfCopy { get; }
Public ReadOnly Property MoveInsteadOfCopy As Boolean
    Get
public:
property bool MoveInsteadOfCopy {
    bool get ();
}
member MoveInsteadOfCopy : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ManagePlaceHolderEventArgs
Namespace DedNet


Proprietà ManagePlaceHolderEventArgs.MoveInsteadOfCopyPlaceHolderEnforced

Proprietà ManagePlaceHolderEventArgsMoveInsteadOfCopyPlaceHolderEnforced
Restituisce se l'elemento fa parte delle famiglie con moved forzato e anagrafica da impostare obsoleta

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool MoveInsteadOfCopyPlaceHolderEnforced { get; set; }
Public Property MoveInsteadOfCopyPlaceHolderEnforced As Boolean
    Get
    Set
public:
property bool MoveInsteadOfCopyPlaceHolderEnforced {
    bool get ();
    void set (bool value);
}
member MoveInsteadOfCopyPlaceHolderEnforced : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ManagePlaceHolderEventArgs
Namespace DedNet


Proprietà ManagePlaceHolderEventArgs.Msg

Proprietà ManagePlaceHolderEventArgsMsg
Eventuale messaggio da mostrare all'utente nel caso non abbia possibilità di scelta per spiegarne il motivo

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Msg { get; set; }
Public Property Msg As String
    Get
    Set
public:
property String^ Msg {
    String^ get ();
    void set (String^ value);
}
member Msg : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe ManagePlaceHolderEventArgs
Namespace DedNet


Proprietà ManagePlaceHolderEventArgs.StartingData

Proprietà ManagePlaceHolderEventArgsStartingData
Eventuale anagrafica di partenza

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData StartingData { get; }
Public ReadOnly Property StartingData As DedData
    Get
public:
property DedData^ StartingData {
    DedData^ get ();
}
member StartingData : DedData with get

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe ManagePlaceHolderEventArgs
Namespace DedNet


Proprietà ManagePlaceHolderEventArgs.UserCanChoice

Proprietà ManagePlaceHolderEventArgsUserCanChoice
Imposta o restituisce se l'utente ha facoltà di scegliere se fare uno sposata o un copia

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool UserCanChoice { get; set; }
Public Property UserCanChoice As Boolean
    Get
    Set
public:
property bool UserCanChoice {
    bool get ();
    void set (bool value);
}
member UserCanChoice : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ManagePlaceHolderEventArgs
Namespace DedNet


Metodi di ManagePlaceHolderEventArgs

Il tipo ManagePlaceHolderEventArgs espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | SetMoveOrDel | Permette di settare se fare il moved/del NOTE : Da chiamare una volta sola
Torna su
Vedi anche

Documentazione

Classe ManagePlaceHolderEventArgs
Namespace DedNet


Metodo ManagePlaceHolderEventArgs.SetMoveOrDel

Metodo ManagePlaceHolderEventArgsSetMoveOrDel
Permette di settare se fare il moved/del NOTE : Da chiamare una volta sola

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetMoveOrDel(
    bool val
)
Public Sub SetMoveOrDel (
    val As Boolean
)
public:
void SetMoveOrDel(
    bool val
)
member SetMoveOrDel :
        val : bool -> unit

Parametri

val Boolean
Se true imposta di fare del/moved altrimenti no
Vedi anche

Documentazione

Classe ManagePlaceHolderEventArgs
Namespace DedNet


Classe ManageSelectionDocsEventArgs
Racchiude le informazioni che riguardano la selezione dei documenti
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetDedBeforeOrAfterEventArgs
DedNetManageSelectionDocsEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ManageSelectionDocsEventArgs : DedBeforeOrAfterEventArgs
Public Class ManageSelectionDocsEventArgs
    Inherits DedBeforeOrAfterEventArgs
public ref class ManageSelectionDocsEventArgs : public DedBeforeOrAfterEventArgs
type ManageSelectionDocsEventArgs =
    class
        inherit DedBeforeOrAfterEventArgs
    end

Il tipo ManageSelectionDocsEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ManageSelectionDocsEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | InfoFile |
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore ManageSelectionDocsEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ManageSelectionDocsEventArgs(
    GridInfoDataList infoFile
)
Public Sub New (
    infoFile As GridInfoDataList
)
public:
ManageSelectionDocsEventArgs(
    GridInfoDataList^ infoFile
)
new :
        infoFile : GridInfoDataList -> ManageSelectionDocsEventArgs

Parametri

infoFile GridInfoDataList
Vedi anche

Documentazione

Classe ManageSelectionDocsEventArgs
Namespace DedNet


Proprietà di ManageSelectionDocsEventArgs

Il tipo ManageSelectionDocsEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | InfoFile |
Torna su
Vedi anche

Documentazione

Classe ManageSelectionDocsEventArgs
Namespace DedNet


Proprietà ManageSelectionDocsEventArgs.InfoFile

Proprietà ManageSelectionDocsEventArgsInfoFile

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public GridInfoDataList InfoFile { get; }
Public ReadOnly Property InfoFile As GridInfoDataList
    Get
public:
property GridInfoDataList^ InfoFile {
    GridInfoDataList^ get ();
}
member InfoFile : GridInfoDataList with get

Valore della proprietà

GridInfoDataList
Vedi anche

Documentazione

Classe ManageSelectionDocsEventArgs
Namespace DedNet


Classe MoveDocumentEventArgs
Racchiude le informazioni che riguardano lo spostamento/rinomina di un documento.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetDedBeforeOrAfterEventArgs
DedNetDedEventArgs
DedNetMoveDocumentEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class MoveDocumentEventArgs : DedEventArgs
Public Class MoveDocumentEventArgs
    Inherits DedEventArgs
public ref class MoveDocumentEventArgs : public DedEventArgs
type MoveDocumentEventArgs =
    class
        inherit DedEventArgs
    end

Il tipo MoveDocumentEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | MoveDocumentEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | Document | Restituisce il documento da spostare già aggiornato sulla nuova destinazione.
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | FromFileName | Restituisce il nome completo del file da spostare, riferito al vault.
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Proprietà pubblica | NotEraseFromFile | Restituisce o imposta se non eliminare il file di partenza.
Proprietà pubblica | ToFileName | Restituisce il nome completo della destinazione del file da spostare, riferito al vault.
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore MoveDocumentEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public MoveDocumentEventArgs()
Public Sub New
public:
MoveDocumentEventArgs()
new : unit -> MoveDocumentEventArgs
Vedi anche

Documentazione

Classe MoveDocumentEventArgs
Namespace DedNet


Proprietà di MoveDocumentEventArgs

Il tipo MoveDocumentEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | Document | Restituisce il documento da spostare già aggiornato sulla nuova destinazione.
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | FromFileName | Restituisce il nome completo del file da spostare, riferito al vault.
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Proprietà pubblica | NotEraseFromFile | Restituisce o imposta se non eliminare il file di partenza.
Proprietà pubblica | ToFileName | Restituisce il nome completo della destinazione del file da spostare, riferito al vault.
Torna su
Vedi anche

Documentazione

Classe MoveDocumentEventArgs
Namespace DedNet


Proprietà MoveDocumentEventArgs.Document

Proprietà MoveDocumentEventArgsDocument
Restituisce il documento da spostare già aggiornato sulla nuova destinazione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDoc Document { get; }
Public ReadOnly Property Document As DedDoc
    Get
public:
property DedDoc^ Document {
    DedDoc^ get ();
}
member Document : DedDoc with get

Valore della proprietà

DedDoc
Vedi anche

Documentazione

Classe MoveDocumentEventArgs
Namespace DedNet


Proprietà MoveDocumentEventArgs.FromFileName

Proprietà MoveDocumentEventArgsFromFileName
Restituisce il nome completo del file da spostare, riferito al vault.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string FromFileName { get; }
Public ReadOnly Property FromFileName As String
    Get
public:
property String^ FromFileName {
    String^ get ();
}
member FromFileName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe MoveDocumentEventArgs
Namespace DedNet


Proprietà MoveDocumentEventArgs.NotEraseFromFile

Proprietà MoveDocumentEventArgsNotEraseFromFile
Restituisce o imposta se non eliminare il file di partenza.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool NotEraseFromFile { get; set; }
Public Property NotEraseFromFile As Boolean
    Get
    Set
public:
property bool NotEraseFromFile {
    bool get ();
    void set (bool value);
}
member NotEraseFromFile : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe MoveDocumentEventArgs
Namespace DedNet


Proprietà MoveDocumentEventArgs.ToFileName

Proprietà MoveDocumentEventArgsToFileName
Restituisce il nome completo della destinazione del file da spostare, riferito al vault.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string ToFileName { get; }
Public ReadOnly Property ToFileName As String
    Get
public:
property String^ ToFileName {
    String^ get ();
}
member ToFileName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe MoveDocumentEventArgs
Namespace DedNet


Classe MoveDocumentInfo
Oggetto contenente le informazioni dell'oggetto su cui fare il moved
Gerarchia di ereditarietà
SystemObject
DedNetMoveDocumentInfo

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class MoveDocumentInfo
Public Class MoveDocumentInfo
public ref class MoveDocumentInfo
type MoveDocumentInfo = class end

Il tipo MoveDocumentInfo espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | MoveDocumentInfo | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | DestPath | Percorso di destinazione
Proprietà pubblica | DestType | Famiglia di destinazione
Proprietà pubblica | DsInfo | DocstrutInfo oggetto in esame
Proprietà pubblica | ForcedInfo | Eventuali dati forzati
Proprietà pubblica | StartingData | Anagrafica di partenza
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore MoveDocumentInfo
Costruttore

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public MoveDocumentInfo(
    DocStructInfo dsInfo,
    DedData startingData,
    DedTypeBase destType,
    string destPath,
    MoveDocumentInfoForcedMoveInfo forcedMoveOrDelInfo
)
Public Sub New (
    dsInfo As DocStructInfo,
    startingData As DedData,
    destType As DedTypeBase,
    destPath As String,
    forcedMoveOrDelInfo As MoveDocumentInfoForcedMoveInfo
)
public:
MoveDocumentInfo(
    DocStructInfo^ dsInfo,
    DedData^ startingData,
    DedTypeBase^ destType,
    String^ destPath,
    MoveDocumentInfoForcedMoveInfo^ forcedMoveOrDelInfo
)
new :
        dsInfo : DocStructInfo *
        startingData : DedData *
        destType : DedTypeBase *
        destPath : string *
        forcedMoveOrDelInfo : MoveDocumentInfoForcedMoveInfo -> MoveDocumentInfo

Parametri

dsInfo DocStructInfo
DocStructInfo in esame
startingData DedData
Anagrafica di partenza
destType DedTypeBase
Famiglia di destinazione
destPath String
Percorso di destinazione
forcedMoveOrDelInfo MoveDocumentInfoForcedMoveInfo
Dati forzati
Vedi anche

Documentazione

Classe MoveDocumentInfo
Namespace DedNet


Proprietà di MoveDocumentInfo

Il tipo MoveDocumentInfo espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | DestPath | Percorso di destinazione
Proprietà pubblica | DestType | Famiglia di destinazione
Proprietà pubblica | DsInfo | DocstrutInfo oggetto in esame
Proprietà pubblica | ForcedInfo | Eventuali dati forzati
Proprietà pubblica | StartingData | Anagrafica di partenza
Torna su
Vedi anche

Documentazione

Classe MoveDocumentInfo
Namespace DedNet


Proprietà MoveDocumentInfo.DestPath

Proprietà MoveDocumentInfoDestPath
Percorso di destinazione

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string DestPath { get; set; }
Public Property DestPath As String
    Get
    Set
public:
property String^ DestPath {
    String^ get ();
    void set (String^ value);
}
member DestPath : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe MoveDocumentInfo
Namespace DedNet


Proprietà MoveDocumentInfo.DestType

Proprietà MoveDocumentInfoDestType
Famiglia di destinazione

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeBase DestType { get; set; }
Public Property DestType As DedTypeBase
    Get
    Set
public:
property DedTypeBase^ DestType {
    DedTypeBase^ get ();
    void set (DedTypeBase^ value);
}
member DestType : DedTypeBase with get, set

Valore della proprietà

DedTypeBase
Vedi anche

Documentazione

Classe MoveDocumentInfo
Namespace DedNet


Proprietà MoveDocumentInfo.DsInfo

Proprietà MoveDocumentInfoDsInfo
DocstrutInfo oggetto in esame

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfo DsInfo { get; set; }
Public Property DsInfo As DocStructInfo
    Get
    Set
public:
property DocStructInfo^ DsInfo {
    DocStructInfo^ get ();
    void set (DocStructInfo^ value);
}
member DsInfo : DocStructInfo with get, set

Valore della proprietà

DocStructInfo
Vedi anche

Documentazione

Classe MoveDocumentInfo
Namespace DedNet


Proprietà MoveDocumentInfo.ForcedInfo

Proprietà MoveDocumentInfoForcedInfo
Eventuali dati forzati

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public MoveDocumentInfoForcedMoveInfo ForcedInfo { get; set; }
Public Property ForcedInfo As MoveDocumentInfoForcedMoveInfo
    Get
    Set
public:
property MoveDocumentInfoForcedMoveInfo^ ForcedInfo {
    MoveDocumentInfoForcedMoveInfo^ get ();
    void set (MoveDocumentInfoForcedMoveInfo^ value);
}
member ForcedInfo : MoveDocumentInfoForcedMoveInfo with get, set

Valore della proprietà

MoveDocumentInfoForcedMoveInfo
Vedi anche

Documentazione

Classe MoveDocumentInfo
Namespace DedNet


Proprietà MoveDocumentInfo.StartingData

Proprietà MoveDocumentInfoStartingData
Anagrafica di partenza

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData StartingData { get; set; }
Public Property StartingData As DedData
    Get
    Set
public:
property DedData^ StartingData {
    DedData^ get ();
    void set (DedData^ value);
}
member StartingData : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe MoveDocumentInfo
Namespace DedNet


Classe MoveDocumentInfo.ForcedMoveInfo

Classe MoveDocumentInfoForcedMoveInfo
Eventuali dati forzati
Gerarchia di ereditarietà
SystemObject
DedNetMoveDocumentInfoForcedMoveInfo

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ForcedMoveInfo
Public Class ForcedMoveInfo
public ref class ForcedMoveInfo
type ForcedMoveInfo = class end

Il tipo MoveDocumentInfoForcedMoveInfo espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | MoveDocumentInfoForcedMoveInfo | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | ForceDoNotMoveOrDel | Indica di forzare la copia
Proprietà pubblica | ForceMoveOrDel | Indica di forzare lo sposta
Proprietà pubblica | Msg | Messaggio da mostrare all'utente
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore MoveDocumentInfo.ForcedMoveInfo

Costruttore MoveDocumentInfoForcedMoveInfo
Costruttore

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ForcedMoveInfo()
Public Sub New
public:
ForcedMoveInfo()
new : unit -> ForcedMoveInfo
Vedi anche

Documentazione

Classe MoveDocumentInfoForcedMoveInfo
Namespace DedNet


Proprietà di ForcedMoveInfo

Il tipo MoveDocumentInfoForcedMoveInfo espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | ForceDoNotMoveOrDel | Indica di forzare la copia
Proprietà pubblica | ForceMoveOrDel | Indica di forzare lo sposta
Proprietà pubblica | Msg | Messaggio da mostrare all'utente
Torna su
Vedi anche

Documentazione

Classe MoveDocumentInfoForcedMoveInfo
Namespace DedNet


Proprietà MoveDocumentInfo.ForcedMoveInfo.ForceDoNotMoveOrDel

Proprietà MoveDocumentInfoForcedMoveInfoForceDoNotMoveOrDel
Indica di forzare la copia

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ForceDoNotMoveOrDel { get; set; }
Public Property ForceDoNotMoveOrDel As Boolean
    Get
    Set
public:
property bool ForceDoNotMoveOrDel {
    bool get ();
    void set (bool value);
}
member ForceDoNotMoveOrDel : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe MoveDocumentInfoForcedMoveInfo
Namespace DedNet


Proprietà MoveDocumentInfo.ForcedMoveInfo.ForceMoveOrDel

Proprietà MoveDocumentInfoForcedMoveInfoForceMoveOrDel
Indica di forzare lo sposta

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ForceMoveOrDel { get; set; }
Public Property ForceMoveOrDel As Boolean
    Get
    Set
public:
property bool ForceMoveOrDel {
    bool get ();
    void set (bool value);
}
member ForceMoveOrDel : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe MoveDocumentInfoForcedMoveInfo
Namespace DedNet


Proprietà MoveDocumentInfo.ForcedMoveInfo.Msg

Proprietà MoveDocumentInfoForcedMoveInfoMsg
Messaggio da mostrare all'utente

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Msg { get; set; }
Public Property Msg As String
    Get
    Set
public:
property String^ Msg {
    String^ get ();
    void set (String^ value);
}
member Msg : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe MoveDocumentInfoForcedMoveInfo
Namespace DedNet


Classe MoveDocumentResult
Oggetto che rappresenta il risultato del move
Gerarchia di ereditarietà
SystemObject
DedNetMoveDocumentResult

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class MoveDocumentResult
Public Class MoveDocumentResult
public ref class MoveDocumentResult
type MoveDocumentResult = class end

Il tipo MoveDocumentResult espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | MoveDocumentResult | Costruttore unico
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | DelToMake | Indica se per l'elemento in questione sia necessario creare il segnaposto .del Questo argomento viene preso in considerazione solo se HandlingCode = Handled.
Proprietà pubblica | MdInfo | Informazioni sull'oggetto del move
Proprietà pubblica | MoveInsteadOfCopy | Indica se per l'elemento in questione sia necessario creare il segnaposto .moved Questo argomento viene preso in considerazione solo se HandlingCode = Handled.
Proprietà pubblica | MoveInsteadOfCopyPlaceHolderEnforced | Indica se per l'elemento in questione rientra nella famiglie con moved forzato e relativa impostazione anagrafica obsoleta
Proprietà pubblica | Msg | Eventuale messaggio da mostrare all’utente in caso non possa scegliere
Proprietà pubblica | UserCanChoice | Indica se l'utente può modificare le opzioni impostate (mai impostarlo a true tramite personalizzazioni).
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ResetMoveOrDel | Reimposta i flag a false
Metodo pubblico | SetMoveOrDel | Permette di modificare se fare il move/del o meno
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore MoveDocumentResult
Costruttore unico

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public MoveDocumentResult(
    MoveDocumentInfo mdInfo
)
Public Sub New (
    mdInfo As MoveDocumentInfo
)
public:
MoveDocumentResult(
    MoveDocumentInfo^ mdInfo
)
new :
        mdInfo : MoveDocumentInfo -> MoveDocumentResult

Parametri

mdInfo MoveDocumentInfo
Vedi anche

Documentazione

Classe MoveDocumentResult
Namespace DedNet


Proprietà di MoveDocumentResult

Il tipo MoveDocumentResult espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | DelToMake | Indica se per l'elemento in questione sia necessario creare il segnaposto .del Questo argomento viene preso in considerazione solo se HandlingCode = Handled.
Proprietà pubblica | MdInfo | Informazioni sull'oggetto del move
Proprietà pubblica | MoveInsteadOfCopy | Indica se per l'elemento in questione sia necessario creare il segnaposto .moved Questo argomento viene preso in considerazione solo se HandlingCode = Handled.
Proprietà pubblica | MoveInsteadOfCopyPlaceHolderEnforced | Indica se per l'elemento in questione rientra nella famiglie con moved forzato e relativa impostazione anagrafica obsoleta
Proprietà pubblica | Msg | Eventuale messaggio da mostrare all’utente in caso non possa scegliere
Proprietà pubblica | UserCanChoice | Indica se l'utente può modificare le opzioni impostate (mai impostarlo a true tramite personalizzazioni).
Torna su
Vedi anche

Documentazione

Classe MoveDocumentResult
Namespace DedNet


Proprietà MoveDocumentResult.DelToMake

Proprietà MoveDocumentResultDelToMake
Indica se per l'elemento in questione sia necessario creare il segnaposto .del Questo argomento viene preso in considerazione solo se HandlingCode = Handled.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool DelToMake { get; }
Public ReadOnly Property DelToMake As Boolean
    Get
public:
property bool DelToMake {
    bool get ();
}
member DelToMake : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe MoveDocumentResult
Namespace DedNet


Proprietà MoveDocumentResult.MdInfo

Proprietà MoveDocumentResultMdInfo
Informazioni sull'oggetto del move

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public MoveDocumentInfo MdInfo { get; set; }
Public Property MdInfo As MoveDocumentInfo
    Get
    Set
public:
property MoveDocumentInfo^ MdInfo {
    MoveDocumentInfo^ get ();
    void set (MoveDocumentInfo^ value);
}
member MdInfo : MoveDocumentInfo with get, set

Valore della proprietà

MoveDocumentInfo
Vedi anche

Documentazione

Classe MoveDocumentResult
Namespace DedNet


Proprietà MoveDocumentResult.MoveInsteadOfCopy

Proprietà MoveDocumentResultMoveInsteadOfCopy
Indica se per l'elemento in questione sia necessario creare il segnaposto .moved Questo argomento viene preso in considerazione solo se HandlingCode = Handled.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool MoveInsteadOfCopy { get; }
Public ReadOnly Property MoveInsteadOfCopy As Boolean
    Get
public:
property bool MoveInsteadOfCopy {
    bool get ();
}
member MoveInsteadOfCopy : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe MoveDocumentResult
Namespace DedNet


Proprietà MoveDocumentResult.MoveInsteadOfCopyPlaceHolderEnforced

Proprietà MoveDocumentResultMoveInsteadOfCopyPlaceHolderEnforced
Indica se per l'elemento in questione rientra nella famiglie con moved forzato e relativa impostazione anagrafica obsoleta

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool MoveInsteadOfCopyPlaceHolderEnforced { get; set; }
Public Property MoveInsteadOfCopyPlaceHolderEnforced As Boolean
    Get
    Set
public:
property bool MoveInsteadOfCopyPlaceHolderEnforced {
    bool get ();
    void set (bool value);
}
member MoveInsteadOfCopyPlaceHolderEnforced : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe MoveDocumentResult
Namespace DedNet


Proprietà MoveDocumentResult.Msg

Proprietà MoveDocumentResultMsg
Eventuale messaggio da mostrare all’utente in caso non possa scegliere

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Msg { get; set; }
Public Property Msg As String
    Get
    Set
public:
property String^ Msg {
    String^ get ();
    void set (String^ value);
}
member Msg : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe MoveDocumentResult
Namespace DedNet


Proprietà MoveDocumentResult.UserCanChoice

Proprietà MoveDocumentResultUserCanChoice
Indica se l'utente può modificare le opzioni impostate (mai impostarlo a true tramite personalizzazioni).

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool UserCanChoice { get; set; }
Public Property UserCanChoice As Boolean
    Get
    Set
public:
property bool UserCanChoice {
    bool get ();
    void set (bool value);
}
member UserCanChoice : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe MoveDocumentResult
Namespace DedNet


Metodi di MoveDocumentResult

Il tipo MoveDocumentResult espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ResetMoveOrDel | Reimposta i flag a false
Metodo pubblico | SetMoveOrDel | Permette di modificare se fare il move/del o meno
Torna su
Vedi anche

Documentazione

Classe MoveDocumentResult
Namespace DedNet


Metodo MoveDocumentResult.ResetMoveOrDel

Metodo MoveDocumentResultResetMoveOrDel
Reimposta i flag a false

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ResetMoveOrDel()
Public Sub ResetMoveOrDel
public:
void ResetMoveOrDel()
member ResetMoveOrDel : unit -> unit
Vedi anche

Documentazione

Classe MoveDocumentResult
Namespace DedNet


Metodo MoveDocumentResult.SetMoveOrDel

Metodo MoveDocumentResultSetMoveOrDel
Permette di modificare se fare il move/del o meno

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetMoveOrDel(
    bool val
)
Public Sub SetMoveOrDel (
    val As Boolean
)
public:
void SetMoveOrDel(
    bool val
)
member SetMoveOrDel :
        val : bool -> unit

Parametri

val Boolean
Vedi anche

Documentazione

Classe MoveDocumentResult
Namespace DedNet


Classe MultipleStateChangeExecuteEventArgs
Raccoglie le informazioni per interrompere le operazioni di Rilascio/Lavorazione multiplo
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetDedBeforeOrAfterEventArgs
DedNetDedEventArgs
DedNetMultipleStateChangeExecuteEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class MultipleStateChangeExecuteEventArgs : DedEventArgs
Public Class MultipleStateChangeExecuteEventArgs
    Inherits DedEventArgs
public ref class MultipleStateChangeExecuteEventArgs : public DedEventArgs
type MultipleStateChangeExecuteEventArgs =
    class
        inherit DedEventArgs
    end

Il tipo MultipleStateChangeExecuteEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | MultipleStateChangeExecuteEventArgs | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | DsInfoList | Restituisce la lista dei docstructinfo relativi alle anagrafiche selezionate nel Rilascio/Lavorazione multiplo
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Proprietà pubblica | NodeList | Restituisce la lista delle anagrafiche selezionate nel Rilascio/Lavorazione multiplo
Proprietà pubblica | TargetState | Restituisce lo stato dell'operazione
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore MultipleStateChangeExecuteEventArgs
Costruttore

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public MultipleStateChangeExecuteEventArgs(
    List<Object> dsInfolist,
    List<Object> nodeList,
    DedState targetState
)
Public Sub New (
    dsInfolist As List(Of Object),
    nodeList As List(Of Object),
    targetState As DedState
)
public:
MultipleStateChangeExecuteEventArgs(
    List<Object^>^ dsInfolist,
    List<Object^>^ nodeList,
    DedState^ targetState
)
new :
        dsInfolist : List<Object> *
        nodeList : List<Object> *
        targetState : DedState -> MultipleStateChangeExecuteEventArgs

Parametri

dsInfolist List Object
nodeList List Object
targetState DedState
Vedi anche

Documentazione

Classe MultipleStateChangeExecuteEventArgs
Namespace DedNet


Proprietà di MultipleStateChangeExecuteEventArgs

Il tipo MultipleStateChangeExecuteEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | DsInfoList | Restituisce la lista dei docstructinfo relativi alle anagrafiche selezionate nel Rilascio/Lavorazione multiplo
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Proprietà pubblica | NodeList | Restituisce la lista delle anagrafiche selezionate nel Rilascio/Lavorazione multiplo
Proprietà pubblica | TargetState | Restituisce lo stato dell'operazione
Torna su
Vedi anche

Documentazione

Classe MultipleStateChangeExecuteEventArgs
Namespace DedNet


Proprietà MultipleStateChangeExecuteEventArgs.DsInfoList

Proprietà MultipleStateChangeExecuteEventArgsDsInfoList
Restituisce la lista dei docstructinfo relativi alle anagrafiche selezionate nel Rilascio/Lavorazione multiplo

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<Object> DsInfoList { get; }
Public ReadOnly Property DsInfoList As List(Of Object)
    Get
public:
property List<Object^>^ DsInfoList {
    List<Object^>^ get ();
}
member DsInfoList : List<Object> with get

Valore della proprietà

List Object
Vedi anche

Documentazione

Classe MultipleStateChangeExecuteEventArgs
Namespace DedNet


Proprietà MultipleStateChangeExecuteEventArgs.NodeList

Proprietà MultipleStateChangeExecuteEventArgsNodeList
Restituisce la lista delle anagrafiche selezionate nel Rilascio/Lavorazione multiplo

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<Object> NodeList { get; }
Public ReadOnly Property NodeList As List(Of Object)
    Get
public:
property List<Object^>^ NodeList {
    List<Object^>^ get ();
}
member NodeList : List<Object> with get

Valore della proprietà

List Object
Vedi anche

Documentazione

Classe MultipleStateChangeExecuteEventArgs
Namespace DedNet


Proprietà MultipleStateChangeExecuteEventArgs.TargetState

Proprietà MultipleStateChangeExecuteEventArgsTargetState
Restituisce lo stato dell'operazione

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedState TargetState { get; }
Public ReadOnly Property TargetState As DedState
    Get
public:
property DedState^ TargetState {
    DedState^ get ();
}
member TargetState : DedState with get

Valore della proprietà

DedState
Vedi anche

Documentazione

Classe MultipleStateChangeExecuteEventArgs
Namespace DedNet


Classe MyDragDropEventArgs
Classe usata per gestire gli eventi del drag drop.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetMyDragDropEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class MyDragDropEventArgs : EventArgs
Public Class MyDragDropEventArgs
    Inherits EventArgs
public ref class MyDragDropEventArgs : public EventArgs
type MyDragDropEventArgs =
    class
        inherit EventArgs
    end

Il tipo MyDragDropEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllowedEffect |
Proprietà pubblica | Data |
Proprietà pubblica | Effect |
Proprietà pubblica | KeyState |
Proprietà pubblica | Type |
Torna su
Vedi anche

Documentazione

Namespace DedNet


Proprietà di MyDragDropEventArgs

Il tipo MyDragDropEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllowedEffect |
Proprietà pubblica | Data |
Proprietà pubblica | Effect |
Proprietà pubblica | KeyState |
Proprietà pubblica | Type |
Torna su
Vedi anche

Documentazione

Classe MyDragDropEventArgs
Namespace DedNet


Proprietà MyDragDropEventArgs.AllowedEffect

Proprietà MyDragDropEventArgsAllowedEffect

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DragDropEffects AllowedEffect { get; set; }
Public Property AllowedEffect As DragDropEffects
    Get
    Set
public:
property DragDropEffects AllowedEffect {
    DragDropEffects get ();
    void set (DragDropEffects value);
}
member AllowedEffect : DragDropEffects with get, set

Valore della proprietà

DragDropEffects
Vedi anche

Documentazione

Classe MyDragDropEventArgs
Namespace DedNet


Proprietà MyDragDropEventArgs.Data

Proprietà MyDragDropEventArgsData

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public IDataObject Data { get; set; }
Public Property Data As IDataObject
    Get
    Set
public:
property IDataObject^ Data {
    IDataObject^ get ();
    void set (IDataObject^ value);
}
member Data : IDataObject with get, set

Valore della proprietà

IDataObject
Vedi anche

Documentazione

Classe MyDragDropEventArgs
Namespace DedNet


Proprietà MyDragDropEventArgs.Effect

Proprietà MyDragDropEventArgsEffect

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DragDropEffects Effect { get; set; }
Public Property Effect As DragDropEffects
    Get
    Set
public:
property DragDropEffects Effect {
    DragDropEffects get ();
    void set (DragDropEffects value);
}
member Effect : DragDropEffects with get, set

Valore della proprietà

DragDropEffects
Vedi anche

Documentazione

Classe MyDragDropEventArgs
Namespace DedNet


Proprietà MyDragDropEventArgs.KeyState

Proprietà MyDragDropEventArgsKeyState

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int KeyState { get; set; }
Public Property KeyState As Integer
    Get
    Set
public:
property int KeyState {
    int get ();
    void set (int value);
}
member KeyState : int with get, set

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe MyDragDropEventArgs
Namespace DedNet


Proprietà MyDragDropEventArgs.Type

Proprietà MyDragDropEventArgsType

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedType Type { get; set; }
Public Property Type As DedType
    Get
    Set
public:
property DedType^ Type {
    DedType^ get ();
    void set (DedType^ value);
}
member Type : DedType with get, set

Valore della proprietà

DedType
Vedi anche

Documentazione

Classe MyDragDropEventArgs
Namespace DedNet


Classe MyDragDropNodeEventArgs
Classe usata per gestire gli eventi del drag drop.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetMyDragDropNodeEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class MyDragDropNodeEventArgs : EventArgs
Public Class MyDragDropNodeEventArgs
    Inherits EventArgs
public ref class MyDragDropNodeEventArgs : public EventArgs
type MyDragDropNodeEventArgs =
    class
        inherit EventArgs
    end

Il tipo MyDragDropNodeEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllowedEffect |
Proprietà pubblica | Data |
Proprietà pubblica | Effect |
Proprietà pubblica | KeyState |
Proprietà pubblica | Node |
Torna su
Vedi anche

Documentazione

Namespace DedNet


Proprietà di MyDragDropNodeEventArgs

Il tipo MyDragDropNodeEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllowedEffect |
Proprietà pubblica | Data |
Proprietà pubblica | Effect |
Proprietà pubblica | KeyState |
Proprietà pubblica | Node |
Torna su
Vedi anche

Documentazione

Classe MyDragDropNodeEventArgs
Namespace DedNet


Proprietà MyDragDropNodeEventArgs.AllowedEffect

Proprietà MyDragDropNodeEventArgsAllowedEffect

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DragDropEffects AllowedEffect { get; set; }
Public Property AllowedEffect As DragDropEffects
    Get
    Set
public:
property DragDropEffects AllowedEffect {
    DragDropEffects get ();
    void set (DragDropEffects value);
}
member AllowedEffect : DragDropEffects with get, set

Valore della proprietà

DragDropEffects
Vedi anche

Documentazione

Classe MyDragDropNodeEventArgs
Namespace DedNet


Proprietà MyDragDropNodeEventArgs.Data

Proprietà MyDragDropNodeEventArgsData

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public IDataObject Data { get; set; }
Public Property Data As IDataObject
    Get
    Set
public:
property IDataObject^ Data {
    IDataObject^ get ();
    void set (IDataObject^ value);
}
member Data : IDataObject with get, set

Valore della proprietà

IDataObject
Vedi anche

Documentazione

Classe MyDragDropNodeEventArgs
Namespace DedNet


Proprietà MyDragDropNodeEventArgs.Effect

Proprietà MyDragDropNodeEventArgsEffect

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DragDropEffects Effect { get; set; }
Public Property Effect As DragDropEffects
    Get
    Set
public:
property DragDropEffects Effect {
    DragDropEffects get ();
    void set (DragDropEffects value);
}
member Effect : DragDropEffects with get, set

Valore della proprietà

DragDropEffects
Vedi anche

Documentazione

Classe MyDragDropNodeEventArgs
Namespace DedNet


Proprietà MyDragDropNodeEventArgs.KeyState

Proprietà MyDragDropNodeEventArgsKeyState

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int KeyState { get; set; }
Public Property KeyState As Integer
    Get
    Set
public:
property int KeyState {
    int get ();
    void set (int value);
}
member KeyState : int with get, set

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe MyDragDropNodeEventArgs
Namespace DedNet


Proprietà MyDragDropNodeEventArgs.Node

Proprietà MyDragDropNodeEventArgsNode

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public TreeListNode Node { get; set; }
Public Property Node As TreeListNode
    Get
    Set
public:
property TreeListNode^ Node {
    TreeListNode^ get ();
    void set (TreeListNode^ value);
}
member Node : TreeListNode with get, set

Valore della proprietà

TreeListNode
Vedi anche

Documentazione

Classe MyDragDropNodeEventArgs
Namespace DedNet


Classe NewAnagrCancelEventArgs
Argomento per gli eventi di conferma creazione nuova anagrafica.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetNewAnagrCancelEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class NewAnagrCancelEventArgs : CancelEventArgs
Public Class NewAnagrCancelEventArgs
    Inherits CancelEventArgs
public ref class NewAnagrCancelEventArgs : public CancelEventArgs
type NewAnagrCancelEventArgs =
    class
        inherit CancelEventArgs
    end

Il tipo NewAnagrCancelEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo protetto | NewAnagrCancelEventArgs | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Mode | Restituisce la modalità di salvataggio dell'anagrafica.
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore NewAnagrCancelEventArgs
Costruttore unico.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal NewAnagrCancelEventArgs(
    DedFormSaveModeEnum mode
)
Protected Friend Sub New (
    mode As DedFormSaveModeEnum
)
protected public:
NewAnagrCancelEventArgs(
    DedFormSaveModeEnum mode
)
new :
        mode : DedFormSaveModeEnum -> NewAnagrCancelEventArgs

Parametri

mode DedFormSaveModeEnum
Modalità di salvataggio.
Vedi anche

Documentazione

Classe NewAnagrCancelEventArgs
Namespace DedNet


Proprietà di NewAnagrCancelEventArgs

Il tipo NewAnagrCancelEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Mode | Restituisce la modalità di salvataggio dell'anagrafica.
Torna su
Vedi anche

Documentazione

Classe NewAnagrCancelEventArgs
Namespace DedNet


Proprietà NewAnagrCancelEventArgs.Mode

Proprietà NewAnagrCancelEventArgsMode
Restituisce la modalità di salvataggio dell'anagrafica.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormSaveModeEnum Mode { get; }
Public ReadOnly Property Mode As DedFormSaveModeEnum
    Get
public:
property DedFormSaveModeEnum Mode {
    DedFormSaveModeEnum get ();
}
member Mode : DedFormSaveModeEnum with get

Valore della proprietà

DedFormSaveModeEnum
Vedi anche

Documentazione

Classe NewAnagrCancelEventArgs
Namespace DedNet


Classe NewAnagrEventArgs
Argomento per gli eventi di creazione nuova anagrafica, contenente le diverse informazioni sul tipo di comando ed il suo stato.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetNewAnagrEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class NewAnagrEventArgs : EventArgs
Public Class NewAnagrEventArgs
    Inherits EventArgs
public ref class NewAnagrEventArgs : public EventArgs
type NewAnagrEventArgs =
    class
        inherit EventArgs
    end

Il tipo NewAnagrEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo protetto | NewAnagrEventArgs | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Mode | Restituisce la modalità di salvataggio dell'anagrafica.
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore NewAnagrEventArgs
Costruttore unico.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal NewAnagrEventArgs(
    DedFormSaveModeEnum mode
)
Protected Friend Sub New (
    mode As DedFormSaveModeEnum
)
protected public:
NewAnagrEventArgs(
    DedFormSaveModeEnum mode
)
new :
        mode : DedFormSaveModeEnum -> NewAnagrEventArgs

Parametri

mode DedFormSaveModeEnum
Modalità di salvataggio.
Vedi anche

Documentazione

Classe NewAnagrEventArgs
Namespace DedNet


Proprietà di NewAnagrEventArgs

Il tipo NewAnagrEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Mode | Restituisce la modalità di salvataggio dell'anagrafica.
Torna su
Vedi anche

Documentazione

Classe NewAnagrEventArgs
Namespace DedNet


Proprietà NewAnagrEventArgs.Mode

Proprietà NewAnagrEventArgsMode
Restituisce la modalità di salvataggio dell'anagrafica.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormSaveModeEnum Mode { get; }
Public ReadOnly Property Mode As DedFormSaveModeEnum
    Get
public:
property DedFormSaveModeEnum Mode {
    DedFormSaveModeEnum get ();
}
member Mode : DedFormSaveModeEnum with get

Valore della proprietà

DedFormSaveModeEnum
Vedi anche

Documentazione

Classe NewAnagrEventArgs
Namespace DedNet


Classe NoteTransferPackEventArgs
Evento che permette di inserire una Nota nel trasfer pack con gestione della visualizzazione della finestra di inserimento Note
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetDedBeforeOrAfterEventArgs
DedNetDedEventArgs
DedNetNoteTransferPackEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class NoteTransferPackEventArgs : DedEventArgs
Public Class NoteTransferPackEventArgs
    Inherits DedEventArgs
public ref class NoteTransferPackEventArgs : public DedEventArgs
type NoteTransferPackEventArgs =
    class
        inherit DedEventArgs
    end

Il tipo NoteTransferPackEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | NoteTransferPackEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Proprietà pubblica | Note | Nota da aggiungere al trasfer pack
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore NoteTransferPackEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public NoteTransferPackEventArgs()
Public Sub New
public:
NoteTransferPackEventArgs()
new : unit -> NoteTransferPackEventArgs
Vedi anche

Documentazione

Classe NoteTransferPackEventArgs
Namespace DedNet


Proprietà di NoteTransferPackEventArgs

Il tipo NoteTransferPackEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Proprietà pubblica | Note | Nota da aggiungere al trasfer pack
Torna su
Vedi anche

Documentazione

Classe NoteTransferPackEventArgs
Namespace DedNet


Proprietà NoteTransferPackEventArgs.Note

Proprietà NoteTransferPackEventArgsNote
Nota da aggiungere al trasfer pack

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Note { get; set; }
Public Property Note As String
    Get
    Set
public:
property String^ Note {
    String^ get ();
    void set (String^ value);
}
member Note : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe NoteTransferPackEventArgs
Namespace DedNet


Classe OverrideAttListEventArgs
Argomento contenente le informazioni relative alla lista valori associata ad uno specifico attributo.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetOverrideAttListEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class OverrideAttListEventArgs : EventArgs
Public Class OverrideAttListEventArgs
    Inherits EventArgs
public ref class OverrideAttListEventArgs : public EventArgs
type OverrideAttListEventArgs =
    class
        inherit EventArgs
    end

Il tipo OverrideAttListEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | OverrideAttListEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AttList | Lista di valori associata all'attributo.
Proprietà pubblica | Attr | Attributo di riferimento.
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore OverrideAttListEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public OverrideAttListEventArgs()
Public Sub New
public:
OverrideAttListEventArgs()
new : unit -> OverrideAttListEventArgs
Vedi anche

Documentazione

Classe OverrideAttListEventArgs
Namespace DedNet


Proprietà di OverrideAttListEventArgs

Il tipo OverrideAttListEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AttList | Lista di valori associata all'attributo.
Proprietà pubblica | Attr | Attributo di riferimento.
Torna su
Vedi anche

Documentazione

Classe OverrideAttListEventArgs
Namespace DedNet


Proprietà OverrideAttListEventArgs.AttList

Proprietà OverrideAttListEventArgsAttList
Lista di valori associata all'attributo.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAtt AttList { get; set; }
Public Property AttList As DedAtt
    Get
    Set
public:
property DedAtt^ AttList {
    DedAtt^ get ();
    void set (DedAtt^ value);
}
member AttList : DedAtt with get, set

Valore della proprietà

DedAtt
Vedi anche

Documentazione

Classe OverrideAttListEventArgs
Namespace DedNet


Proprietà OverrideAttListEventArgs.Attr

Proprietà OverrideAttListEventArgsAttr
Attributo di riferimento.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttr Attr { get; set; }
Public Property Attr As DedAttr
    Get
    Set
public:
property DedAttr^ Attr {
    DedAttr^ get ();
    void set (DedAttr^ value);
}
member Attr : DedAttr with get, set

Valore della proprietà

DedAttr
Vedi anche

Documentazione

Classe OverrideAttListEventArgs
Namespace DedNet


Classe OverrideAttrEventArgs
Argomento contenente le informazioni relative agli attributi dell'anagrafica.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetOverrideAttrEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class OverrideAttrEventArgs : EventArgs
Public Class OverrideAttrEventArgs
    Inherits EventArgs
public ref class OverrideAttrEventArgs : public EventArgs
type OverrideAttrEventArgs =
    class
        inherit EventArgs
    end

Il tipo OverrideAttrEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | OverrideAttrEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Anagr | Anagrafica o lista di anagrafiche in editazione.
Proprietà pubblica | Attr | Lista di attributi in visualizzazione.
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore OverrideAttrEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public OverrideAttrEventArgs()
Public Sub New
public:
OverrideAttrEventArgs()
new : unit -> OverrideAttrEventArgs
Vedi anche

Documentazione

Classe OverrideAttrEventArgs
Namespace DedNet


Proprietà di OverrideAttrEventArgs

Il tipo OverrideAttrEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Anagr | Anagrafica o lista di anagrafiche in editazione.
Proprietà pubblica | Attr | Lista di attributi in visualizzazione.
Torna su
Vedi anche

Documentazione

Classe OverrideAttrEventArgs
Namespace DedNet


Proprietà OverrideAttrEventArgs.Anagr

Proprietà OverrideAttrEventArgsAnagr
Anagrafica o lista di anagrafiche in editazione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public IDedEditable Anagr { get; set; }
Public Property Anagr As IDedEditable
    Get
    Set
public:
property IDedEditable^ Anagr {
    IDedEditable^ get ();
    void set (IDedEditable^ value);
}
member Anagr : IDedEditable with get, set

Valore della proprietà

IDedEditable
Vedi anche

Documentazione

Classe OverrideAttrEventArgs
Namespace DedNet


Proprietà OverrideAttrEventArgs.Attr

Proprietà OverrideAttrEventArgsAttr
Lista di attributi in visualizzazione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList Attr { get; set; }
Public Property Attr As DedAttrList
    Get
    Set
public:
property DedAttrList^ Attr {
    DedAttrList^ get ();
    void set (DedAttrList^ value);
}
member Attr : DedAttrList with get, set

Valore della proprietà

DedAttrList
Vedi anche

Documentazione

Classe OverrideAttrEventArgs
Namespace DedNet


Classe OverrideCommandEnablingEventArgs
Argomento usato dagli add-in per effettuare l'override dell'abilitazione dei comandi del Core.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetOverrideCommandEnablingEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class OverrideCommandEnablingEventArgs : EventArgs
Public Class OverrideCommandEnablingEventArgs
    Inherits EventArgs
public ref class OverrideCommandEnablingEventArgs : public EventArgs
type OverrideCommandEnablingEventArgs =
    class
        inherit EventArgs
    end

Il tipo OverrideCommandEnablingEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | OverrideCommandEnablingEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Cmd |
Proprietà pubblica | Ctx |
Proprietà pubblica | Enabled |
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore OverrideCommandEnablingEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public OverrideCommandEnablingEventArgs(
    DedCommand cmd,
    DedCommandContext ctx,
    bool enable
)
Public Sub New (
    cmd As DedCommand,
    ctx As DedCommandContext,
    enable As Boolean
)
public:
OverrideCommandEnablingEventArgs(
    DedCommand^ cmd,
    DedCommandContext^ ctx,
    bool enable
)
new :
        cmd : DedCommand *
        ctx : DedCommandContext *
        enable : bool -> OverrideCommandEnablingEventArgs

Parametri

cmd DedCommand
ctx DedCommandContext
enable Boolean
Vedi anche

Documentazione

Classe OverrideCommandEnablingEventArgs
Namespace DedNet


Proprietà di OverrideCommandEnablingEventArgs

Il tipo OverrideCommandEnablingEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Cmd |
Proprietà pubblica | Ctx |
Proprietà pubblica | Enabled |
Torna su
Vedi anche

Documentazione

Classe OverrideCommandEnablingEventArgs
Namespace DedNet


Proprietà OverrideCommandEnablingEventArgs.Cmd

Proprietà OverrideCommandEnablingEventArgsCmd

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommand Cmd { get; }
Public ReadOnly Property Cmd As DedCommand
    Get
public:
property DedCommand^ Cmd {
    DedCommand^ get ();
}
member Cmd : DedCommand with get

Valore della proprietà

DedCommand
Vedi anche

Documentazione

Classe OverrideCommandEnablingEventArgs
Namespace DedNet


Proprietà OverrideCommandEnablingEventArgs.Ctx

Proprietà OverrideCommandEnablingEventArgsCtx

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommandContext Ctx { get; }
Public ReadOnly Property Ctx As DedCommandContext
    Get
public:
property DedCommandContext^ Ctx {
    DedCommandContext^ get ();
}
member Ctx : DedCommandContext with get

Valore della proprietà

DedCommandContext
Vedi anche

Documentazione

Classe OverrideCommandEnablingEventArgs
Namespace DedNet


Proprietà OverrideCommandEnablingEventArgs.Enabled

Proprietà OverrideCommandEnablingEventArgsEnabled

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
member Enabled : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe OverrideCommandEnablingEventArgs
Namespace DedNet


Classe OverwriteImportPlaceHolderEventArgs
Informazioni per l'override della logica dei placeholder.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetDedBeforeOrAfterEventArgs
DedNetDedEventArgs
DedNetOverwriteImportPlaceHolderEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class OverwriteImportPlaceHolderEventArgs : DedEventArgs
Public Class OverwriteImportPlaceHolderEventArgs
    Inherits DedEventArgs
public ref class OverwriteImportPlaceHolderEventArgs : public DedEventArgs
type OverwriteImportPlaceHolderEventArgs =
    class
        inherit DedEventArgs
    end

Il tipo OverwriteImportPlaceHolderEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | OverwriteImportPlaceHolderEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Cmd | Restituisce il comando di import
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | Data | Restituisce l'anagrafica sulla quale viene eseguito l'import
Proprietà pubblica | DelToMake | Indica se per l'elemento in questione sia necessario creare il segnaposto .del Questo argomento viene preso in considerazione solo se HandlingCode = Handled.
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Proprietà pubblica | Item | Elemento corrente da importare.
Proprietà pubblica | MdRes | Contiene le informazioni calcolate
Proprietà pubblica | MoveInsteadOfCopy | Indica se per l'elemento in questione sia necessario creare il segnaposto .moved Questo argomento viene preso in considerazione solo se HandlingCode = Handled.
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore OverwriteImportPlaceHolderEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public OverwriteImportPlaceHolderEventArgs()
Public Sub New
public:
OverwriteImportPlaceHolderEventArgs()
new : unit -> OverwriteImportPlaceHolderEventArgs
Vedi anche

Documentazione

Classe OverwriteImportPlaceHolderEventArgs
Namespace DedNet


Proprietà di OverwriteImportPlaceHolderEventArgs

Il tipo OverwriteImportPlaceHolderEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Cmd | Restituisce il comando di import
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | Data | Restituisce l'anagrafica sulla quale viene eseguito l'import
Proprietà pubblica | DelToMake | Indica se per l'elemento in questione sia necessario creare il segnaposto .del Questo argomento viene preso in considerazione solo se HandlingCode = Handled.
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Proprietà pubblica | Item | Elemento corrente da importare.
Proprietà pubblica | MdRes | Contiene le informazioni calcolate
Proprietà pubblica | MoveInsteadOfCopy | Indica se per l'elemento in questione sia necessario creare il segnaposto .moved Questo argomento viene preso in considerazione solo se HandlingCode = Handled.
Torna su
Vedi anche

Documentazione

Classe OverwriteImportPlaceHolderEventArgs
Namespace DedNet


Proprietà OverwriteImportPlaceHolderEventArgs.Cmd

Proprietà OverwriteImportPlaceHolderEventArgsCmd
Restituisce il comando di import

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommand Cmd { get; }
Public ReadOnly Property Cmd As DedCommand
    Get
public:
property DedCommand^ Cmd {
    DedCommand^ get ();
}
member Cmd : DedCommand with get

Valore della proprietà

DedCommand
Vedi anche

Documentazione

Classe OverwriteImportPlaceHolderEventArgs
Namespace DedNet


Proprietà OverwriteImportPlaceHolderEventArgs.Data

Proprietà OverwriteImportPlaceHolderEventArgsData
Restituisce l'anagrafica sulla quale viene eseguito l'import

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; }
Public ReadOnly Property Data As DedData
    Get
public:
property DedData^ Data {
    DedData^ get ();
}
member Data : DedData with get

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe OverwriteImportPlaceHolderEventArgs
Namespace DedNet


Proprietà OverwriteImportPlaceHolderEventArgs.DelToMake

Proprietà OverwriteImportPlaceHolderEventArgsDelToMake
Indica se per l'elemento in questione sia necessario creare il segnaposto .del Questo argomento viene preso in considerazione solo se HandlingCode = Handled.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool DelToMake { get; set; }
Public Property DelToMake As Boolean
    Get
    Set
public:
property bool DelToMake {
    bool get ();
    void set (bool value);
}
member DelToMake : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe OverwriteImportPlaceHolderEventArgs
Namespace DedNet


Proprietà OverwriteImportPlaceHolderEventArgs.Item

Proprietà OverwriteImportPlaceHolderEventArgsItem
Elemento corrente da importare.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfo Item { get; }
Public ReadOnly Property Item As DocStructInfo
    Get
public:
property DocStructInfo^ Item {
    DocStructInfo^ get ();
}
member Item : DocStructInfo with get

Valore della proprietà

DocStructInfo
Vedi anche

Documentazione

Classe OverwriteImportPlaceHolderEventArgs
Namespace DedNet


Proprietà OverwriteImportPlaceHolderEventArgs.MdRes

Proprietà OverwriteImportPlaceHolderEventArgsMdRes
Contiene le informazioni calcolate

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public MoveDocumentResult MdRes { get; }
Public ReadOnly Property MdRes As MoveDocumentResult
    Get
public:
property MoveDocumentResult^ MdRes {
    MoveDocumentResult^ get ();
}
member MdRes : MoveDocumentResult with get

Valore della proprietà

MoveDocumentResult
Vedi anche

Documentazione

Classe OverwriteImportPlaceHolderEventArgs
Namespace DedNet


Proprietà OverwriteImportPlaceHolderEventArgs.MoveInsteadOfCopy

Proprietà OverwriteImportPlaceHolderEventArgsMoveInsteadOfCopy
Indica se per l'elemento in questione sia necessario creare il segnaposto .moved Questo argomento viene preso in considerazione solo se HandlingCode = Handled.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool MoveInsteadOfCopy { get; set; }
Public Property MoveInsteadOfCopy As Boolean
    Get
    Set
public:
property bool MoveInsteadOfCopy {
    bool get ();
    void set (bool value);
}
member MoveInsteadOfCopy : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe OverwriteImportPlaceHolderEventArgs
Namespace DedNet


Classe PackAndGoZipFolderEventArgs
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelHandledEventArgs
DedNetPackAndGoZipFolderEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class PackAndGoZipFolderEventArgs : HandledEventArgs
Public Class PackAndGoZipFolderEventArgs
    Inherits HandledEventArgs
public ref class PackAndGoZipFolderEventArgs : public HandledEventArgs
type PackAndGoZipFolderEventArgs =
    class
        inherit HandledEventArgs
    end

Il tipo PackAndGoZipFolderEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | PackAndGoZipFolderEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Folder |
Proprietà pubblica | ZipFile |
Proprietà pubblica | ZipMode |
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore PackAndGoZipFolderEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoZipFolderEventArgs()
Public Sub New
public:
PackAndGoZipFolderEventArgs()
new : unit -> PackAndGoZipFolderEventArgs
Vedi anche

Documentazione

Classe PackAndGoZipFolderEventArgs
Namespace DedNet


Proprietà di PackAndGoZipFolderEventArgs

Il tipo PackAndGoZipFolderEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Folder |
Proprietà pubblica | ZipFile |
Proprietà pubblica | ZipMode |
Torna su
Vedi anche

Documentazione

Classe PackAndGoZipFolderEventArgs
Namespace DedNet


Proprietà PackAndGoZipFolderEventArgs.Folder

Proprietà PackAndGoZipFolderEventArgsFolder

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Folder { get; set; }
Public Property Folder As String
    Get
    Set
public:
property String^ Folder {
    String^ get ();
    void set (String^ value);
}
member Folder : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe PackAndGoZipFolderEventArgs
Namespace DedNet


Proprietà PackAndGoZipFolderEventArgs.ZipFile

Proprietà PackAndGoZipFolderEventArgsZipFile

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string ZipFile { get; set; }
Public Property ZipFile As String
    Get
    Set
public:
property String^ ZipFile {
    String^ get ();
    void set (String^ value);
}
member ZipFile : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe PackAndGoZipFolderEventArgs
Namespace DedNet


Proprietà PackAndGoZipFolderEventArgs.ZipMode

Proprietà PackAndGoZipFolderEventArgsZipMode

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ZipMode { get; set; }
Public Property ZipMode As Boolean
    Get
    Set
public:
property bool ZipMode {
    bool get ();
    void set (bool value);
}
member ZipMode : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe PackAndGoZipFolderEventArgs
Namespace DedNet


Classe ProgrCollisionEventArgs
Argomento per l'evento di gestione del controllo dei conflitti tra progressivi.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetProgrCollisionEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ProgrCollisionEventArgs : EventArgs
Public Class ProgrCollisionEventArgs
    Inherits EventArgs
public ref class ProgrCollisionEventArgs : public EventArgs
type ProgrCollisionEventArgs =
    class
        inherit EventArgs
    end

Il tipo ProgrCollisionEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ProgrCollisionEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | IgnoreCollision | Restituisce/Imposta se ignorare o meno la collisione.
Proprietà pubblica | Info | Restituisce/imposta le informazioni in salvataggio.
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore ProgrCollisionEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ProgrCollisionEventArgs(
    DedEncodeInfo info,
    bool ignoreCollision
)
Public Sub New (
    info As DedEncodeInfo,
    ignoreCollision As Boolean
)
public:
ProgrCollisionEventArgs(
    DedEncodeInfo^ info,
    bool ignoreCollision
)
new :
        info : DedEncodeInfo *
        ignoreCollision : bool -> ProgrCollisionEventArgs

Parametri

info DedEncodeInfo
ignoreCollision Boolean
Vedi anche

Documentazione

Classe ProgrCollisionEventArgs
Namespace DedNet


Proprietà di ProgrCollisionEventArgs

Il tipo ProgrCollisionEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | IgnoreCollision | Restituisce/Imposta se ignorare o meno la collisione.
Proprietà pubblica | Info | Restituisce/imposta le informazioni in salvataggio.
Torna su
Vedi anche

Documentazione

Classe ProgrCollisionEventArgs
Namespace DedNet


Proprietà ProgrCollisionEventArgs.IgnoreCollision

Proprietà ProgrCollisionEventArgsIgnoreCollision
Restituisce/Imposta se ignorare o meno la collisione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IgnoreCollision { get; set; }
Public Property IgnoreCollision As Boolean
    Get
    Set
public:
property bool IgnoreCollision {
    bool get ();
    void set (bool value);
}
member IgnoreCollision : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ProgrCollisionEventArgs
Namespace DedNet


Proprietà ProgrCollisionEventArgs.Info

Proprietà ProgrCollisionEventArgsInfo
Restituisce/imposta le informazioni in salvataggio.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEncodeInfo Info { get; }
Public ReadOnly Property Info As DedEncodeInfo
    Get
public:
property DedEncodeInfo^ Info {
    DedEncodeInfo^ get ();
}
member Info : DedEncodeInfo with get

Valore della proprietà

DedEncodeInfo
Vedi anche

Documentazione

Classe ProgrCollisionEventArgs
Namespace DedNet


Classe QsManagerEventArgs
Argomento usato per le operazioni sulle famiglie nel QsManager.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetQsManagerEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class QsManagerEventArgs : EventArgs
Public Class QsManagerEventArgs
    Inherits EventArgs
public ref class QsManagerEventArgs : public EventArgs
type QsManagerEventArgs =
    class
        inherit EventArgs
    end

Il tipo QsManagerEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | QsManagerEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Type |
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore QsManagerEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QsManagerEventArgs()
Public Sub New
public:
QsManagerEventArgs()
new : unit -> QsManagerEventArgs
Vedi anche

Documentazione

Classe QsManagerEventArgs
Namespace DedNet


Proprietà di QsManagerEventArgs

Il tipo QsManagerEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Type |
Torna su
Vedi anche

Documentazione

Classe QsManagerEventArgs
Namespace DedNet


Proprietà QsManagerEventArgs.Type

Proprietà QsManagerEventArgsType

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeBase Type { get; }
Public ReadOnly Property Type As DedTypeBase
    Get
public:
property DedTypeBase^ Type {
    DedTypeBase^ get ();
}
member Type : DedTypeBase with get

Valore della proprietà

DedTypeBase
Vedi anche

Documentazione

Classe QsManagerEventArgs
Namespace DedNet


Classe QsResources
Classe usata per effettuare l'override della property 'GetString' in modo tale che il testo venga mandato a capo quando è presente il '\n'
Gerarchia di ereditarietà
SystemObject
System.ResourcesResourceManager
DedNetQsResources

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class QsResources : ResourceManager
Public Class QsResources
    Inherits ResourceManager
public ref class QsResources : public ResourceManager
type QsResources =
    class
        inherit ResourceManager
    end

Il tipo QsResources espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | QsResources |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | GetString(String) | Override che dimezza le barre ('\') per mandare a capo il testo (Sovrascrive ResourceManagerGetString(String))
Metodo pubblico | GetString(String, CultureInfo) | Override che dimezza le barre ('\') per mandare a capo il testo (Sovrascrive ResourceManagerGetString(String, CultureInfo))
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore QsResources

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QsResources(
    string s,
    Assembly a
)
Public Sub New (
    s As String,
    a As Assembly
)
public:
QsResources(
    String^ s,
    Assembly^ a
)
new :
        s : string *
        a : Assembly -> QsResources

Parametri

s String
a Assembly
Vedi anche

Documentazione

Classe QsResources
Namespace DedNet


Metodi di QsResources

Il tipo QsResources espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | GetString(String) | Override che dimezza le barre ('\') per mandare a capo il testo (Sovrascrive ResourceManagerGetString(String))
Metodo pubblico | GetString(String, CultureInfo) | Override che dimezza le barre ('\') per mandare a capo il testo (Sovrascrive ResourceManagerGetString(String, CultureInfo))
Torna su
Vedi anche

Documentazione

Classe QsResources
Namespace DedNet


Metodo QsResources.GetString

Metodo QsResourcesGetString
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | GetString(String) | Override che dimezza le barre ('\') per mandare a capo il testo
Metodo pubblico | GetString(String, CultureInfo) | Override che dimezza le barre ('\') per mandare a capo il testo
Torna su
Vedi anche

Documentazione

Classe QsResources
Namespace DedNet


Metodo QsResources.GetString(String)

Metodo QsResourcesGetString(String)
Override che dimezza le barre ('\') per mandare a capo il testo

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string GetString(
    string name
)
Public Overrides Function GetString (
    name As String
) As String
public:
virtual String^ GetString(
    String^ name
) override
abstract GetString :
        name : string -> string
override GetString :
        name : string -> string

Parametri

name String

Valore di ritorno

String
Vedi anche

Documentazione

Classe QsResources
Overload di GetString
Namespace DedNet


Metodo QsResources.GetString(String, CultureInfo)

Metodo QsResourcesGetString(String, CultureInfo)
Override che dimezza le barre ('\') per mandare a capo il testo

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string GetString(
    string name,
    CultureInfo culture
)
Public Overrides Function GetString (
    name As String,
    culture As CultureInfo
) As String
public:
virtual String^ GetString(
    String^ name,
    CultureInfo^ culture
) override
abstract GetString :
        name : string *
        culture : CultureInfo -> string
override GetString :
        name : string *
        culture : CultureInfo -> string

Parametri

name String
culture CultureInfo

Valore di ritorno

String
Vedi anche

Documentazione

Classe QsResources
Overload di GetString
Namespace DedNet


Classe QSTopDwgViewerProfile
Argomento per evento definizione profilo QsTopDwgViewer.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetQSTopDwgViewerProfile

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class QSTopDwgViewerProfile : EventArgs
Public Class QSTopDwgViewerProfile
    Inherits EventArgs
public ref class QSTopDwgViewerProfile : public EventArgs
type QSTopDwgViewerProfile =
    class
        inherit EventArgs
    end

Il tipo QSTopDwgViewerProfile espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | QSTopDwgViewerProfile | Costruttore unico
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Profile | Profilo con cui eseguire il QsTopDwgViewer.
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore QSTopDwgViewerProfile
Costruttore unico

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QSTopDwgViewerProfile(
    string profile
)
Public Sub New (
    profile As String
)
public:
QSTopDwgViewerProfile(
    String^ profile
)
new :
        profile : string -> QSTopDwgViewerProfile

Parametri

profile String
Vedi anche

Documentazione

Classe QSTopDwgViewerProfile
Namespace DedNet


Proprietà di QSTopDwgViewerProfile

Il tipo QSTopDwgViewerProfile espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Profile | Profilo con cui eseguire il QsTopDwgViewer.
Torna su
Vedi anche

Documentazione

Classe QSTopDwgViewerProfile
Namespace DedNet


Proprietà QSTopDwgViewerProfile.Profile

Proprietà QSTopDwgViewerProfileProfile
Profilo con cui eseguire il QsTopDwgViewer.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Profile { get; set; }
Public Property Profile As String
    Get
    Set
public:
property String^ Profile {
    String^ get ();
    void set (String^ value);
}
member Profile : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe QSTopDwgViewerProfile
Namespace DedNet


Classe RedrawAnagrEventArgs
Contiene l'indicazione per la colorazione delle anagrafiche della ricerca.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelHandledEventArgs
DedNetRedrawAnagrEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class RedrawAnagrEventArgs : HandledEventArgs
Public Class RedrawAnagrEventArgs
    Inherits HandledEventArgs
public ref class RedrawAnagrEventArgs : public HandledEventArgs
type RedrawAnagrEventArgs =
    class
        inherit HandledEventArgs
    end

Il tipo RedrawAnagrEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | RedrawAnagrEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BackColor |
Proprietà pubblica | ColName |
Proprietà pubblica | DbPath |
Proprietà pubblica | ForeColor |
Proprietà pubblica | Row |
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore RedrawAnagrEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public RedrawAnagrEventArgs()
Public Sub New
public:
RedrawAnagrEventArgs()
new : unit -> RedrawAnagrEventArgs
Vedi anche

Documentazione

Classe RedrawAnagrEventArgs
Namespace DedNet


Proprietà di RedrawAnagrEventArgs

Il tipo RedrawAnagrEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BackColor |
Proprietà pubblica | ColName |
Proprietà pubblica | DbPath |
Proprietà pubblica | ForeColor |
Proprietà pubblica | Row |
Torna su
Vedi anche

Documentazione

Classe RedrawAnagrEventArgs
Namespace DedNet


Proprietà RedrawAnagrEventArgs.BackColor

Proprietà RedrawAnagrEventArgsBackColor

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Color BackColor { get; set; }
Public Property BackColor As Color
    Get
    Set
public:
property Color BackColor {
    Color get ();
    void set (Color value);
}
member BackColor : Color with get, set

Valore della proprietà

Color
Vedi anche

Documentazione

Classe RedrawAnagrEventArgs
Namespace DedNet


Proprietà RedrawAnagrEventArgs.ColName

Proprietà RedrawAnagrEventArgsColName

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string ColName { get; set; }
Public Property ColName As String
    Get
    Set
public:
property String^ ColName {
    String^ get ();
    void set (String^ value);
}
member ColName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe RedrawAnagrEventArgs
Namespace DedNet


Proprietà RedrawAnagrEventArgs.DbPath

Proprietà RedrawAnagrEventArgsDbPath

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string DbPath { get; set; }
Public Property DbPath As String
    Get
    Set
public:
property String^ DbPath {
    String^ get ();
    void set (String^ value);
}
member DbPath : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe RedrawAnagrEventArgs
Namespace DedNet


Proprietà RedrawAnagrEventArgs.ForeColor

Proprietà RedrawAnagrEventArgsForeColor

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Color ForeColor { get; set; }
Public Property ForeColor As Color
    Get
    Set
public:
property Color ForeColor {
    Color get ();
    void set (Color value);
}
member ForeColor : Color with get, set

Valore della proprietà

Color
Vedi anche

Documentazione

Classe RedrawAnagrEventArgs
Namespace DedNet


Proprietà RedrawAnagrEventArgs.Row

Proprietà RedrawAnagrEventArgsRow

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<string, string> Row { get; set; }
Public Property Row As Dictionary(Of String, String)
    Get
    Set
public:
property Dictionary<String^, String^>^ Row {
    Dictionary<String^, String^>^ get ();
    void set (Dictionary<String^, String^>^ value);
}
member Row : Dictionary<string, string> with get, set

Valore della proprietà

Dictionary String, String
Vedi anche

Documentazione

Classe RedrawAnagrEventArgs
Namespace DedNet


Classe RedrawAttrEventArgs
Contiene l'indicazione per la colorazione della commessa.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelHandledEventArgs
DedNetRedrawAttrEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class RedrawAttrEventArgs : HandledEventArgs
Public Class RedrawAttrEventArgs
    Inherits HandledEventArgs
public ref class RedrawAttrEventArgs : public HandledEventArgs
type RedrawAttrEventArgs =
    class
        inherit HandledEventArgs
    end

Il tipo RedrawAttrEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | RedrawAttrEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Attr |
Proprietà pubblica | BackColor |
Proprietà pubblica | ColName |
Proprietà pubblica | Deddata |
Proprietà pubblica | ForeColor |
Proprietà pubblica | Value |
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore RedrawAttrEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public RedrawAttrEventArgs()
Public Sub New
public:
RedrawAttrEventArgs()
new : unit -> RedrawAttrEventArgs
Vedi anche

Documentazione

Classe RedrawAttrEventArgs
Namespace DedNet


Proprietà di RedrawAttrEventArgs

Il tipo RedrawAttrEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Attr |
Proprietà pubblica | BackColor |
Proprietà pubblica | ColName |
Proprietà pubblica | Deddata |
Proprietà pubblica | ForeColor |
Proprietà pubblica | Value |
Torna su
Vedi anche

Documentazione

Classe RedrawAttrEventArgs
Namespace DedNet


Proprietà RedrawAttrEventArgs.Attr

Proprietà RedrawAttrEventArgsAttr

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttr Attr { get; set; }
Public Property Attr As DedAttr
    Get
    Set
public:
property DedAttr^ Attr {
    DedAttr^ get ();
    void set (DedAttr^ value);
}
member Attr : DedAttr with get, set

Valore della proprietà

DedAttr
Vedi anche

Documentazione

Classe RedrawAttrEventArgs
Namespace DedNet


Proprietà RedrawAttrEventArgs.BackColor

Proprietà RedrawAttrEventArgsBackColor

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Color BackColor { get; set; }
Public Property BackColor As Color
    Get
    Set
public:
property Color BackColor {
    Color get ();
    void set (Color value);
}
member BackColor : Color with get, set

Valore della proprietà

Color
Vedi anche

Documentazione

Classe RedrawAttrEventArgs
Namespace DedNet


Proprietà RedrawAttrEventArgs.ColName

Proprietà RedrawAttrEventArgsColName

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string ColName { get; set; }
Public Property ColName As String
    Get
    Set
public:
property String^ ColName {
    String^ get ();
    void set (String^ value);
}
member ColName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe RedrawAttrEventArgs
Namespace DedNet


Proprietà RedrawAttrEventArgs.Deddata

Proprietà RedrawAttrEventArgsDeddata

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public IDedEditable Deddata { get; set; }
Public Property Deddata As IDedEditable
    Get
    Set
public:
property IDedEditable^ Deddata {
    IDedEditable^ get ();
    void set (IDedEditable^ value);
}
member Deddata : IDedEditable with get, set

Valore della proprietà

IDedEditable
Vedi anche

Documentazione

Classe RedrawAttrEventArgs
Namespace DedNet


Proprietà RedrawAttrEventArgs.ForeColor

Proprietà RedrawAttrEventArgsForeColor

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Color ForeColor { get; set; }
Public Property ForeColor As Color
    Get
    Set
public:
property Color ForeColor {
    Color get ();
    void set (Color value);
}
member ForeColor : Color with get, set

Valore della proprietà

Color
Vedi anche

Documentazione

Classe RedrawAttrEventArgs
Namespace DedNet


Proprietà RedrawAttrEventArgs.Value

Proprietà RedrawAttrEventArgsValue

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object Value { get; set; }
Public Property Value As Object
    Get
    Set
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}
member Value : Object with get, set

Valore della proprietà

Object
Vedi anche

Documentazione

Classe RedrawAttrEventArgs
Namespace DedNet


Classe RedrawCommEventArgs
Contiene l'indicazione per la colorazione della commessa.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelHandledEventArgs
DedNetRedrawCommEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class RedrawCommEventArgs : HandledEventArgs
Public Class RedrawCommEventArgs
    Inherits HandledEventArgs
public ref class RedrawCommEventArgs : public HandledEventArgs
type RedrawCommEventArgs =
    class
        inherit HandledEventArgs
    end

Il tipo RedrawCommEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | RedrawCommEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BackColor |
Proprietà pubblica | ColName |
Proprietà pubblica | Comm |
Proprietà pubblica | ForeColor |
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore RedrawCommEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public RedrawCommEventArgs()
Public Sub New
public:
RedrawCommEventArgs()
new : unit -> RedrawCommEventArgs
Vedi anche

Documentazione

Classe RedrawCommEventArgs
Namespace DedNet


Proprietà di RedrawCommEventArgs

Il tipo RedrawCommEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BackColor |
Proprietà pubblica | ColName |
Proprietà pubblica | Comm |
Proprietà pubblica | ForeColor |
Torna su
Vedi anche

Documentazione

Classe RedrawCommEventArgs
Namespace DedNet


Proprietà RedrawCommEventArgs.BackColor

Proprietà RedrawCommEventArgsBackColor

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Color BackColor { get; set; }
Public Property BackColor As Color
    Get
    Set
public:
property Color BackColor {
    Color get ();
    void set (Color value);
}
member BackColor : Color with get, set

Valore della proprietà

Color
Vedi anche

Documentazione

Classe RedrawCommEventArgs
Namespace DedNet


Proprietà RedrawCommEventArgs.ColName

Proprietà RedrawCommEventArgsColName

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string ColName { get; set; }
Public Property ColName As String
    Get
    Set
public:
property String^ ColName {
    String^ get ();
    void set (String^ value);
}
member ColName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe RedrawCommEventArgs
Namespace DedNet


Proprietà RedrawCommEventArgs.Comm

Proprietà RedrawCommEventArgsComm

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedComm Comm { get; set; }
Public Property Comm As DedComm
    Get
    Set
public:
property DedComm^ Comm {
    DedComm^ get ();
    void set (DedComm^ value);
}
member Comm : DedComm with get, set

Valore della proprietà

DedComm
Vedi anche

Documentazione

Classe RedrawCommEventArgs
Namespace DedNet


Proprietà RedrawCommEventArgs.ForeColor

Proprietà RedrawCommEventArgsForeColor

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Color ForeColor { get; set; }
Public Property ForeColor As Color
    Get
    Set
public:
property Color ForeColor {
    Color get ();
    void set (Color value);
}
member ForeColor : Color with get, set

Valore della proprietà

Color
Vedi anche

Documentazione

Classe RedrawCommEventArgs
Namespace DedNet


Classe RedrawDedTypeEventArgs
Contiene l'indicazione per la colorazione della commessa.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelHandledEventArgs
DedNetRedrawDedTypeEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class RedrawDedTypeEventArgs : HandledEventArgs
Public Class RedrawDedTypeEventArgs
    Inherits HandledEventArgs
public ref class RedrawDedTypeEventArgs : public HandledEventArgs
type RedrawDedTypeEventArgs =
    class
        inherit HandledEventArgs
    end

Il tipo RedrawDedTypeEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | RedrawDedTypeEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BackColor |
Proprietà pubblica | ColName |
Proprietà pubblica | DedType |
Proprietà pubblica | ForeColor |
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore RedrawDedTypeEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public RedrawDedTypeEventArgs()
Public Sub New
public:
RedrawDedTypeEventArgs()
new : unit -> RedrawDedTypeEventArgs
Vedi anche

Documentazione

Classe RedrawDedTypeEventArgs
Namespace DedNet


Proprietà di RedrawDedTypeEventArgs

Il tipo RedrawDedTypeEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BackColor |
Proprietà pubblica | ColName |
Proprietà pubblica | DedType |
Proprietà pubblica | ForeColor |
Torna su
Vedi anche

Documentazione

Classe RedrawDedTypeEventArgs
Namespace DedNet


Proprietà RedrawDedTypeEventArgs.BackColor

Proprietà RedrawDedTypeEventArgsBackColor

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Color BackColor { get; set; }
Public Property BackColor As Color
    Get
    Set
public:
property Color BackColor {
    Color get ();
    void set (Color value);
}
member BackColor : Color with get, set

Valore della proprietà

Color
Vedi anche

Documentazione

Classe RedrawDedTypeEventArgs
Namespace DedNet


Proprietà RedrawDedTypeEventArgs.ColName

Proprietà RedrawDedTypeEventArgsColName

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string ColName { get; set; }
Public Property ColName As String
    Get
    Set
public:
property String^ ColName {
    String^ get ();
    void set (String^ value);
}
member ColName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe RedrawDedTypeEventArgs
Namespace DedNet


Proprietà RedrawDedTypeEventArgs.DedType

Proprietà RedrawDedTypeEventArgsDedType

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeBase DedType { get; set; }
Public Property DedType As DedTypeBase
    Get
    Set
public:
property DedTypeBase^ DedType {
    DedTypeBase^ get ();
    void set (DedTypeBase^ value);
}
member DedType : DedTypeBase with get, set

Valore della proprietà

DedTypeBase
Vedi anche

Documentazione

Classe RedrawDedTypeEventArgs
Namespace DedNet


Proprietà RedrawDedTypeEventArgs.ForeColor

Proprietà RedrawDedTypeEventArgsForeColor

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Color ForeColor { get; set; }
Public Property ForeColor As Color
    Get
    Set
public:
property Color ForeColor {
    Color get ();
    void set (Color value);
}
member ForeColor : Color with get, set

Valore della proprietà

Color
Vedi anche

Documentazione

Classe RedrawDedTypeEventArgs
Namespace DedNet


Classe RedrawDepEventArgs
Contiene l'indicazione per la colorazione dell'albero delle dipendenze.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelHandledEventArgs
DedNetRedrawDepEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class RedrawDepEventArgs : HandledEventArgs
Public Class RedrawDepEventArgs
    Inherits HandledEventArgs
public ref class RedrawDepEventArgs : public HandledEventArgs
type RedrawDepEventArgs =
    class
        inherit HandledEventArgs
    end

Il tipo RedrawDepEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | RedrawDepEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BackColor |
Proprietà pubblica | ColName |
Proprietà pubblica | Data |
Proprietà pubblica | Doc |
Proprietà pubblica | ForeColor |
Proprietà pubblica | IsDirty |
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore RedrawDepEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public RedrawDepEventArgs()
Public Sub New
public:
RedrawDepEventArgs()
new : unit -> RedrawDepEventArgs
Vedi anche

Documentazione

Classe RedrawDepEventArgs
Namespace DedNet


Proprietà di RedrawDepEventArgs

Il tipo RedrawDepEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BackColor |
Proprietà pubblica | ColName |
Proprietà pubblica | Data |
Proprietà pubblica | Doc |
Proprietà pubblica | ForeColor |
Proprietà pubblica | IsDirty |
Torna su
Vedi anche

Documentazione

Classe RedrawDepEventArgs
Namespace DedNet


Proprietà RedrawDepEventArgs.BackColor

Proprietà RedrawDepEventArgsBackColor

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Color BackColor { get; set; }
Public Property BackColor As Color
    Get
    Set
public:
property Color BackColor {
    Color get ();
    void set (Color value);
}
member BackColor : Color with get, set

Valore della proprietà

Color
Vedi anche

Documentazione

Classe RedrawDepEventArgs
Namespace DedNet


Proprietà RedrawDepEventArgs.ColName

Proprietà RedrawDepEventArgsColName

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string ColName { get; set; }
Public Property ColName As String
    Get
    Set
public:
property String^ ColName {
    String^ get ();
    void set (String^ value);
}
member ColName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe RedrawDepEventArgs
Namespace DedNet


Proprietà RedrawDepEventArgs.Data

Proprietà RedrawDepEventArgsData

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; set; }
Public Property Data As DedData
    Get
    Set
public:
property DedData^ Data {
    DedData^ get ();
    void set (DedData^ value);
}
member Data : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe RedrawDepEventArgs
Namespace DedNet


Proprietà RedrawDepEventArgs.Doc

Proprietà RedrawDepEventArgsDoc

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDoc Doc { get; set; }
Public Property Doc As DedDoc
    Get
    Set
public:
property DedDoc^ Doc {
    DedDoc^ get ();
    void set (DedDoc^ value);
}
member Doc : DedDoc with get, set

Valore della proprietà

DedDoc
Vedi anche

Documentazione

Classe RedrawDepEventArgs
Namespace DedNet


Proprietà RedrawDepEventArgs.ForeColor

Proprietà RedrawDepEventArgsForeColor

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Color ForeColor { get; set; }
Public Property ForeColor As Color
    Get
    Set
public:
property Color ForeColor {
    Color get ();
    void set (Color value);
}
member ForeColor : Color with get, set

Valore della proprietà

Color
Vedi anche

Documentazione

Classe RedrawDepEventArgs
Namespace DedNet


Proprietà RedrawDepEventArgs.IsDirty

Proprietà RedrawDepEventArgsIsDirty

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsDirty { get; set; }
Public Property IsDirty As Boolean
    Get
    Set
public:
property bool IsDirty {
    bool get ();
    void set (bool value);
}
member IsDirty : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe RedrawDepEventArgs
Namespace DedNet


Classe RedrawDistEventArgs
Contiene l'indicazione per la colorazione della distinta.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelHandledEventArgs
DedNetRedrawDistEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class RedrawDistEventArgs : HandledEventArgs
Public Class RedrawDistEventArgs
    Inherits HandledEventArgs
public ref class RedrawDistEventArgs : public HandledEventArgs
type RedrawDistEventArgs =
    class
        inherit HandledEventArgs
    end

Il tipo RedrawDistEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | RedrawDistEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BackColor |
Proprietà pubblica | BomItem |
Proprietà pubblica | ColName |
Proprietà pubblica | Ctrl |
Proprietà pubblica | ForeColor |
Proprietà pubblica | Node |
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore RedrawDistEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public RedrawDistEventArgs()
Public Sub New
public:
RedrawDistEventArgs()
new : unit -> RedrawDistEventArgs
Vedi anche

Documentazione

Classe RedrawDistEventArgs
Namespace DedNet


Proprietà di RedrawDistEventArgs

Il tipo RedrawDistEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BackColor |
Proprietà pubblica | BomItem |
Proprietà pubblica | ColName |
Proprietà pubblica | Ctrl |
Proprietà pubblica | ForeColor |
Proprietà pubblica | Node |
Torna su
Vedi anche

Documentazione

Classe RedrawDistEventArgs
Namespace DedNet


Proprietà RedrawDistEventArgs.BackColor

Proprietà RedrawDistEventArgsBackColor

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Color BackColor { get; set; }
Public Property BackColor As Color
    Get
    Set
public:
property Color BackColor {
    Color get ();
    void set (Color value);
}
member BackColor : Color with get, set

Valore della proprietà

Color
Vedi anche

Documentazione

Classe RedrawDistEventArgs
Namespace DedNet


Proprietà RedrawDistEventArgs.BomItem

Proprietà RedrawDistEventArgsBomItem

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItem BomItem { get; set; }
Public Property BomItem As BomItem
    Get
    Set
public:
property BomItem^ BomItem {
    BomItem^ get ();
    void set (BomItem^ value);
}
member BomItem : BomItem with get, set

Valore della proprietà

BomItem
Vedi anche

Documentazione

Classe RedrawDistEventArgs
Namespace DedNet


Proprietà RedrawDistEventArgs.ColName

Proprietà RedrawDistEventArgsColName

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string ColName { get; set; }
Public Property ColName As String
    Get
    Set
public:
property String^ ColName {
    String^ get ();
    void set (String^ value);
}
member ColName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe RedrawDistEventArgs
Namespace DedNet


Proprietà RedrawDistEventArgs.Ctrl

Proprietà RedrawDistEventArgsCtrl

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDistControl Ctrl { get; set; }
Public Property Ctrl As DedDistControl
    Get
    Set
public:
property DedDistControl^ Ctrl {
    DedDistControl^ get ();
    void set (DedDistControl^ value);
}
member Ctrl : DedDistControl with get, set

Valore della proprietà

DedDistControl
Vedi anche

Documentazione

Classe RedrawDistEventArgs
Namespace DedNet


Proprietà RedrawDistEventArgs.ForeColor

Proprietà RedrawDistEventArgsForeColor

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Color ForeColor { get; set; }
Public Property ForeColor As Color
    Get
    Set
public:
property Color ForeColor {
    Color get ();
    void set (Color value);
}
member ForeColor : Color with get, set

Valore della proprietà

Color
Vedi anche

Documentazione

Classe RedrawDistEventArgs
Namespace DedNet


Proprietà RedrawDistEventArgs.Node

Proprietà RedrawDistEventArgsNode

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public TreeListNode Node { get; set; }
Public Property Node As TreeListNode
    Get
    Set
public:
property TreeListNode^ Node {
    TreeListNode^ get ();
    void set (TreeListNode^ value);
}
member Node : TreeListNode with get, set

Valore della proprietà

TreeListNode
Vedi anche

Documentazione

Classe RedrawDistEventArgs
Namespace DedNet


Classe ReferenceUpdateOperationEventArgs
Classe usata per permettere ai CAD e ai plugin di registrarsi ai delegate del comando UpdateDocumentReference.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetReferenceUpdateOperationEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ReferenceUpdateOperationEventArgs : EventArgs
Public Class ReferenceUpdateOperationEventArgs
    Inherits EventArgs
public ref class ReferenceUpdateOperationEventArgs : public EventArgs
type ReferenceUpdateOperationEventArgs =
    class
        inherit EventArgs
    end

Il tipo ReferenceUpdateOperationEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ReferenceUpdateOperationEventArgs | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | UpdateReferenceCommand | Comando UpdateDocumentReference.
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore ReferenceUpdateOperationEventArgs
Costruttore unico.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ReferenceUpdateOperationEventArgs(
    UpdateDocumentReference cmd
)
Public Sub New (
    cmd As UpdateDocumentReference
)
public:
ReferenceUpdateOperationEventArgs(
    UpdateDocumentReference^ cmd
)
new :
        cmd : UpdateDocumentReference -> ReferenceUpdateOperationEventArgs

Parametri

cmd UpdateDocumentReference
Vedi anche

Documentazione

Classe ReferenceUpdateOperationEventArgs
Namespace DedNet


Proprietà di ReferenceUpdateOperationEventArgs

Il tipo ReferenceUpdateOperationEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | UpdateReferenceCommand | Comando UpdateDocumentReference.
Torna su
Vedi anche

Documentazione

Classe ReferenceUpdateOperationEventArgs
Namespace DedNet


Proprietà ReferenceUpdateOperationEventArgs.UpdateReferenceCommand

Proprietà ReferenceUpdateOperationEventArgsUpdateReferenceCommand
Comando UpdateDocumentReference.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public UpdateDocumentReference UpdateReferenceCommand { get; set; }
Public Property UpdateReferenceCommand As UpdateDocumentReference
    Get
    Set
public:
property UpdateDocumentReference^ UpdateReferenceCommand {
    UpdateDocumentReference^ get ();
    void set (UpdateDocumentReference^ value);
}
member UpdateReferenceCommand : UpdateDocumentReference with get, set

Valore della proprietà

UpdateDocumentReference
Vedi anche

Documentazione

Classe ReferenceUpdateOperationEventArgs
Namespace DedNet


Classe RemoveAnagrEventArgs
Racchiude le informazioni che riguardano l'anagrafica in eliminazione. Viene utilizzato per notificare il pre e post del comando di eliminazione anagrarfica.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetRemoveAnagrEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class RemoveAnagrEventArgs : EventArgs
Public Class RemoveAnagrEventArgs
    Inherits EventArgs
public ref class RemoveAnagrEventArgs : public EventArgs
type RemoveAnagrEventArgs =
    class
        inherit EventArgs
    end

Il tipo RemoveAnagrEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo protetto | RemoveAnagrEventArgs | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione.
Proprietà pubblica | Data | Restituisce l'anagrafica da eliminare.
Proprietà pubblica | DedId | Restituisce l'id dell'anagrafica da elmininare.
Proprietà pubblica | DedRev | Restituisce la revisione dell'anagrafica da eliminare.
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento.
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore RemoveAnagrEventArgs
Costruttore unico.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal RemoveAnagrEventArgs(
    DedData data,
    string dedId,
    string dedRev
)
Protected Friend Sub New (
    data As DedData,
    dedId As String,
    dedRev As String
)
protected public:
RemoveAnagrEventArgs(
    DedData^ data,
    String^ dedId,
    String^ dedRev
)
new :
        data : DedData *
        dedId : string *
        dedRev : string -> RemoveAnagrEventArgs

Parametri

data DedData
dedId String
dedRev String
Vedi anche

Documentazione

Classe RemoveAnagrEventArgs
Namespace DedNet


Proprietà di RemoveAnagrEventArgs

Il tipo RemoveAnagrEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione.
Proprietà pubblica | Data | Restituisce l'anagrafica da eliminare.
Proprietà pubblica | DedId | Restituisce l'id dell'anagrafica da elmininare.
Proprietà pubblica | DedRev | Restituisce la revisione dell'anagrafica da eliminare.
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento.
Torna su
Vedi anche

Documentazione

Classe RemoveAnagrEventArgs
Namespace DedNet


Proprietà RemoveAnagrEventArgs.BeforeOrAfter

Proprietà RemoveAnagrEventArgsBeforeOrAfter
Restituisce il momento dell'evento rispetto l'azione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEventTimeEnum BeforeOrAfter { get; }
Public ReadOnly Property BeforeOrAfter As DedEventTimeEnum
    Get
public:
property DedEventTimeEnum BeforeOrAfter {
    DedEventTimeEnum get ();
}
member BeforeOrAfter : DedEventTimeEnum with get

Valore della proprietà

DedEventTimeEnum
Vedi anche

Documentazione

Classe RemoveAnagrEventArgs
Namespace DedNet


Proprietà RemoveAnagrEventArgs.Data

Proprietà RemoveAnagrEventArgsData
Restituisce l'anagrafica da eliminare.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; }
Public ReadOnly Property Data As DedData
    Get
public:
property DedData^ Data {
    DedData^ get ();
}
member Data : DedData with get

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe RemoveAnagrEventArgs
Namespace DedNet


Proprietà RemoveAnagrEventArgs.DedId

Proprietà RemoveAnagrEventArgsDedId
Restituisce l'id dell'anagrafica da elmininare.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string DedId { get; }
Public ReadOnly Property DedId As String
    Get
public:
property String^ DedId {
    String^ get ();
}
member DedId : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe RemoveAnagrEventArgs
Namespace DedNet


Proprietà RemoveAnagrEventArgs.DedRev

Proprietà RemoveAnagrEventArgsDedRev
Restituisce la revisione dell'anagrafica da eliminare.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string DedRev { get; }
Public ReadOnly Property DedRev As String
    Get
public:
property String^ DedRev {
    String^ get ();
}
member DedRev : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe RemoveAnagrEventArgs
Namespace DedNet


Proprietà RemoveAnagrEventArgs.HandlingCode

Proprietà RemoveAnagrEventArgsHandlingCode
Restituisce o imposta la gestione dell'evento.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEventHandlerEnum HandlingCode { get; set; }
Public Property HandlingCode As DedEventHandlerEnum
    Get
    Set
public:
property DedEventHandlerEnum HandlingCode {
    DedEventHandlerEnum get ();
    void set (DedEventHandlerEnum value);
}
member HandlingCode : DedEventHandlerEnum with get, set

Valore della proprietà

DedEventHandlerEnum
Vedi anche

Documentazione

Classe RemoveAnagrEventArgs
Namespace DedNet


Classe ResolveDedFileDescriptorEventArgs
Argomenti specifici degli eventi sul FileDescriptor del DocStructInfo
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetDedBeforeOrAfterEventArgs
DedNetDedEventArgs
DedNetResolveDedFileDescriptorEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ResolveDedFileDescriptorEventArgs : DedEventArgs
Public Class ResolveDedFileDescriptorEventArgs
    Inherits DedEventArgs
public ref class ResolveDedFileDescriptorEventArgs : public DedEventArgs
type ResolveDedFileDescriptorEventArgs =
    class
        inherit DedEventArgs
    end

Il tipo ResolveDedFileDescriptorEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo protetto | ResolveDedFileDescriptorEventArgs | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | FileDescriptor | Restituisce il DocStructInfoDescriptor che si sta elaborando.
Proprietà pubblica | FileName | Restituisce il filename in oggetto
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore ResolveDedFileDescriptorEventArgs
Costruttore unico.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal ResolveDedFileDescriptorEventArgs(
    string fileName
)
Protected Friend Sub New (
    fileName As String
)
protected public:
ResolveDedFileDescriptorEventArgs(
    String^ fileName
)
new :
        fileName : string -> ResolveDedFileDescriptorEventArgs

Parametri

fileName String
Vedi anche

Documentazione

Classe ResolveDedFileDescriptorEventArgs
Namespace DedNet


Proprietà di ResolveDedFileDescriptorEventArgs

Il tipo ResolveDedFileDescriptorEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | FileDescriptor | Restituisce il DocStructInfoDescriptor che si sta elaborando.
Proprietà pubblica | FileName | Restituisce il filename in oggetto
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Torna su
Vedi anche

Documentazione

Classe ResolveDedFileDescriptorEventArgs
Namespace DedNet


Proprietà ResolveDedFileDescriptorEventArgs.FileDescriptor

Proprietà ResolveDedFileDescriptorEventArgsFileDescriptor
Restituisce il DocStructInfoDescriptor che si sta elaborando.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfoFileDescriptor FileDescriptor { get; set; }
Public Property FileDescriptor As DocStructInfoFileDescriptor
    Get
    Set
public:
property DocStructInfoFileDescriptor^ FileDescriptor {
    DocStructInfoFileDescriptor^ get ();
    void set (DocStructInfoFileDescriptor^ value);
}
member FileDescriptor : DocStructInfoFileDescriptor with get, set

Valore della proprietà

DocStructInfoFileDescriptor
Vedi anche

Documentazione

Classe ResolveDedFileDescriptorEventArgs
Namespace DedNet


Proprietà ResolveDedFileDescriptorEventArgs.FileName

Proprietà ResolveDedFileDescriptorEventArgsFileName
Restituisce il filename in oggetto

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}
member FileName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe ResolveDedFileDescriptorEventArgs
Namespace DedNet


Classe ResolveDocStructInfoEventArgs
Racchiude il DocStructInfo in fase di risoluzione
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetDedBeforeOrAfterEventArgs
DedNetDedEventArgs
DedNetResolveDocStructInfoEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ResolveDocStructInfoEventArgs : DedEventArgs
Public Class ResolveDocStructInfoEventArgs
    Inherits DedEventArgs
public ref class ResolveDocStructInfoEventArgs : public DedEventArgs
type ResolveDocStructInfoEventArgs =
    class
        inherit DedEventArgs
    end

Il tipo ResolveDocStructInfoEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo protetto | ResolveDocStructInfoEventArgs | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | ClientDocs | Restituisce la lista
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | DocInfo | Restituisce il DocStructInfo che si sta elaborando.
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore ResolveDocStructInfoEventArgs
Costruttore unico.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal ResolveDocStructInfoEventArgs(
    DocStructInfo docInfo,
    DocStructInfoList clientDocs
)
Protected Friend Sub New (
    docInfo As DocStructInfo,
    clientDocs As DocStructInfoList
)
protected public:
ResolveDocStructInfoEventArgs(
    DocStructInfo^ docInfo,
    DocStructInfoList^ clientDocs
)
new :
        docInfo : DocStructInfo *
        clientDocs : DocStructInfoList -> ResolveDocStructInfoEventArgs

Parametri

docInfo DocStructInfo
clientDocs DocStructInfoList
Vedi anche

Documentazione

Classe ResolveDocStructInfoEventArgs
Namespace DedNet


Proprietà di ResolveDocStructInfoEventArgs

Il tipo ResolveDocStructInfoEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | ClientDocs | Restituisce la lista
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | DocInfo | Restituisce il DocStructInfo che si sta elaborando.
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Torna su
Vedi anche

Documentazione

Classe ResolveDocStructInfoEventArgs
Namespace DedNet


Proprietà ResolveDocStructInfoEventArgs.ClientDocs

Proprietà ResolveDocStructInfoEventArgsClientDocs
Restituisce la lista

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfoList ClientDocs { get; }
Public ReadOnly Property ClientDocs As DocStructInfoList
    Get
public:
property DocStructInfoList^ ClientDocs {
    DocStructInfoList^ get ();
}
member ClientDocs : DocStructInfoList with get

Valore della proprietà

DocStructInfoList
Vedi anche

Documentazione

Classe ResolveDocStructInfoEventArgs
Namespace DedNet


Proprietà ResolveDocStructInfoEventArgs.DocInfo

Proprietà ResolveDocStructInfoEventArgsDocInfo
Restituisce il DocStructInfo che si sta elaborando.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfo DocInfo { get; set; }
Public Property DocInfo As DocStructInfo
    Get
    Set
public:
property DocStructInfo^ DocInfo {
    DocStructInfo^ get ();
    void set (DocStructInfo^ value);
}
member DocInfo : DocStructInfo with get, set

Valore della proprietà

DocStructInfo
Vedi anche

Documentazione

Classe ResolveDocStructInfoEventArgs
Namespace DedNet


Classe SaveDistOnApprovedEventArgs
Contiene l'indicazione di momento esecuzione comando.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetSaveDistOnApprovedEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class SaveDistOnApprovedEventArgs : CancelEventArgs
Public Class SaveDistOnApprovedEventArgs
    Inherits CancelEventArgs
public ref class SaveDistOnApprovedEventArgs : public CancelEventArgs
type SaveDistOnApprovedEventArgs =
    class
        inherit CancelEventArgs
    end

Il tipo SaveDistOnApprovedEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | SaveDistOnApprovedEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | ChangeStateInfo | Contiente tutte le informazioni sul comando
Proprietà pubblica | RollBackChangeState | Restituisce se invalidare o meno il rilascio se il salva di distinta fallisze.
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore SaveDistOnApprovedEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public SaveDistOnApprovedEventArgs()
Public Sub New
public:
SaveDistOnApprovedEventArgs()
new : unit -> SaveDistOnApprovedEventArgs
Vedi anche

Documentazione

Classe SaveDistOnApprovedEventArgs
Namespace DedNet


Proprietà di SaveDistOnApprovedEventArgs

Il tipo SaveDistOnApprovedEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | ChangeStateInfo | Contiente tutte le informazioni sul comando
Proprietà pubblica | RollBackChangeState | Restituisce se invalidare o meno il rilascio se il salva di distinta fallisze.
Torna su
Vedi anche

Documentazione

Classe SaveDistOnApprovedEventArgs
Namespace DedNet


Proprietà SaveDistOnApprovedEventArgs.ChangeStateInfo

Proprietà SaveDistOnApprovedEventArgsChangeStateInfo
Contiente tutte le informazioni sul comando

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public StateCommandEventArgs ChangeStateInfo { get; set; }
Public Property ChangeStateInfo As StateCommandEventArgs
    Get
    Set
public:
property StateCommandEventArgs^ ChangeStateInfo {
    StateCommandEventArgs^ get ();
    void set (StateCommandEventArgs^ value);
}
member ChangeStateInfo : StateCommandEventArgs with get, set

Valore della proprietà

StateCommandEventArgs
Vedi anche

Documentazione

Classe SaveDistOnApprovedEventArgs
Namespace DedNet


Proprietà SaveDistOnApprovedEventArgs.RollBackChangeState

Proprietà SaveDistOnApprovedEventArgsRollBackChangeState
Restituisce se invalidare o meno il rilascio se il salva di distinta fallisze.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool RollBackChangeState { get; set; }
Public Property RollBackChangeState As Boolean
    Get
    Set
public:
property bool RollBackChangeState {
    bool get ();
    void set (bool value);
}
member RollBackChangeState : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SaveDistOnApprovedEventArgs
Namespace DedNet


Classe SetDefaultFindCodeFilterEventArgs
Argomento utilizzato per impostare l'attributo di ricerca da utilizzare nel DedFindCodeControl.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetSetDefaultFindCodeFilterEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class SetDefaultFindCodeFilterEventArgs : EventArgs
Public Class SetDefaultFindCodeFilterEventArgs
    Inherits EventArgs
public ref class SetDefaultFindCodeFilterEventArgs : public EventArgs
type SetDefaultFindCodeFilterEventArgs =
    class
        inherit EventArgs
    end

Il tipo SetDefaultFindCodeFilterEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | SetDefaultFindCodeFilterEventArgs | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Context | Rappresenta il contesto nel quale è utilizzato il DedFindCodeControl.
Proprietà pubblica | Control | Oggetto combobox rappresentante il criterio di ricerca.
Proprietà pubblica | SearchBy | Rappresentan il PROMPT dell'attributo da usare come ricerca.
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore SetDefaultFindCodeFilterEventArgs
Costruttore unico.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public SetDefaultFindCodeFilterEventArgs(
    string searchBy,
    DedFindCodeContextEnum context,
    Control ctrl
)
Public Sub New (
    searchBy As String,
    context As DedFindCodeContextEnum,
    ctrl As Control
)
public:
SetDefaultFindCodeFilterEventArgs(
    String^ searchBy,
    DedFindCodeContextEnum context,
    Control^ ctrl
)
new :
        searchBy : string *
        context : DedFindCodeContextEnum *
        ctrl : Control -> SetDefaultFindCodeFilterEventArgs

Parametri

searchBy String
Stringa rappresentante il PROMPT dell'attributo da usare come ricerca.
context DedFindCodeContextEnum
DedFindCodeContextEnum rappresentante il contesto nel quale è utilizzato il DedFindCodeControl.
ctrl Control
Oggetto combobox rappresentante il criterio di ricerca.
Vedi anche

Documentazione

Classe SetDefaultFindCodeFilterEventArgs
Namespace DedNet


Proprietà di SetDefaultFindCodeFilterEventArgs

Il tipo SetDefaultFindCodeFilterEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Context | Rappresenta il contesto nel quale è utilizzato il DedFindCodeControl.
Proprietà pubblica | Control | Oggetto combobox rappresentante il criterio di ricerca.
Proprietà pubblica | SearchBy | Rappresentan il PROMPT dell'attributo da usare come ricerca.
Torna su
Vedi anche

Documentazione

Classe SetDefaultFindCodeFilterEventArgs
Namespace DedNet


Proprietà SetDefaultFindCodeFilterEventArgs.Context

Proprietà SetDefaultFindCodeFilterEventArgsContext
Rappresenta il contesto nel quale è utilizzato il DedFindCodeControl.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFindCodeContextEnum Context { get; }
Public ReadOnly Property Context As DedFindCodeContextEnum
    Get
public:
property DedFindCodeContextEnum Context {
    DedFindCodeContextEnum get ();
}
member Context : DedFindCodeContextEnum with get

Valore della proprietà

DedFindCodeContextEnum
Vedi anche

Documentazione

Classe SetDefaultFindCodeFilterEventArgs
Namespace DedNet


Proprietà SetDefaultFindCodeFilterEventArgs.Control

Proprietà SetDefaultFindCodeFilterEventArgsControl
Oggetto combobox rappresentante il criterio di ricerca.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Control Control { get; set; }
Public Property Control As Control
    Get
    Set
public:
property Control^ Control {
    Control^ get ();
    void set (Control^ value);
}
member Control : Control with get, set

Valore della proprietà

Control
Vedi anche

Documentazione

Classe SetDefaultFindCodeFilterEventArgs
Namespace DedNet


Proprietà SetDefaultFindCodeFilterEventArgs.SearchBy

Proprietà SetDefaultFindCodeFilterEventArgsSearchBy
Rappresentan il PROMPT dell'attributo da usare come ricerca.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string SearchBy { get; set; }
Public Property SearchBy As String
    Get
    Set
public:
property String^ SearchBy {
    String^ get ();
    void set (String^ value);
}
member SearchBy : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe SetDefaultFindCodeFilterEventArgs
Namespace DedNet


Classe ShowPreviewEventArgs
Racchiude le informazioni che riguardano la visualizzazione del preview di un file.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetShowPreviewEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ShowPreviewEventArgs : EventArgs
Public Class ShowPreviewEventArgs
    Inherits EventArgs
public ref class ShowPreviewEventArgs : public EventArgs
type ShowPreviewEventArgs =
    class
        inherit EventArgs
    end

Il tipo ShowPreviewEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ShowPreviewEventArgs | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BackgroundColor | Restituisce o imposta il colore di sfondo.
Proprietà pubblica | EnableZoom | Imposta o restituisce se deve essere abilitato il pulsante di zoom.
Proprietà pubblica | Ext | Restituisce l'estensione del file.
Proprietà pubblica | HandledOnlyZoomEnabling | Indica che è stata gestita solo l'abilitazione dello zoom. Non deve essere gestita l'immagine da visualizzare ( non impostare _handlingCode ).
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento.
Proprietà pubblica | Height | Restituisce l'altezza del controllo di preview.
Proprietà pubblica | Image | Imposta o restituisce l'immagine da visualizzare.
Proprietà pubblica | Path | Restituisce il percorso del file del quale visualizzare l'anteprima.
Proprietà pubblica | Title | Restituisce il titolo dell'anteprima.
Proprietà pubblica | Width | Restituisce la larghezza del controllo di preview.
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore ShowPreviewEventArgs
Costruttore unico.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ShowPreviewEventArgs(
    string path
)
Public Sub New (
    path As String
)
public:
ShowPreviewEventArgs(
    String^ path
)
new :
        path : string -> ShowPreviewEventArgs

Parametri

path String
Vedi anche

Documentazione

Classe ShowPreviewEventArgs
Namespace DedNet


Proprietà di ShowPreviewEventArgs

Il tipo ShowPreviewEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BackgroundColor | Restituisce o imposta il colore di sfondo.
Proprietà pubblica | EnableZoom | Imposta o restituisce se deve essere abilitato il pulsante di zoom.
Proprietà pubblica | Ext | Restituisce l'estensione del file.
Proprietà pubblica | HandledOnlyZoomEnabling | Indica che è stata gestita solo l'abilitazione dello zoom. Non deve essere gestita l'immagine da visualizzare ( non impostare _handlingCode ).
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento.
Proprietà pubblica | Height | Restituisce l'altezza del controllo di preview.
Proprietà pubblica | Image | Imposta o restituisce l'immagine da visualizzare.
Proprietà pubblica | Path | Restituisce il percorso del file del quale visualizzare l'anteprima.
Proprietà pubblica | Title | Restituisce il titolo dell'anteprima.
Proprietà pubblica | Width | Restituisce la larghezza del controllo di preview.
Torna su
Vedi anche

Documentazione

Classe ShowPreviewEventArgs
Namespace DedNet


Proprietà ShowPreviewEventArgs.BackgroundColor

Proprietà ShowPreviewEventArgsBackgroundColor
Restituisce o imposta il colore di sfondo.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Color BackgroundColor { get; set; }
Public Property BackgroundColor As Color
    Get
    Set
public:
property Color BackgroundColor {
    Color get ();
    void set (Color value);
}
member BackgroundColor : Color with get, set

Valore della proprietà

Color
Vedi anche

Documentazione

Classe ShowPreviewEventArgs
Namespace DedNet


Proprietà ShowPreviewEventArgs.EnableZoom

Proprietà ShowPreviewEventArgsEnableZoom
Imposta o restituisce se deve essere abilitato il pulsante di zoom.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool EnableZoom { get; set; }
Public Property EnableZoom As Boolean
    Get
    Set
public:
property bool EnableZoom {
    bool get ();
    void set (bool value);
}
member EnableZoom : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ShowPreviewEventArgs
Namespace DedNet


Proprietà ShowPreviewEventArgs.Ext

Proprietà ShowPreviewEventArgsExt
Restituisce l'estensione del file.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Ext { get; set; }
Public Property Ext As String
    Get
    Set
public:
property String^ Ext {
    String^ get ();
    void set (String^ value);
}
member Ext : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe ShowPreviewEventArgs
Namespace DedNet


Proprietà ShowPreviewEventArgs.HandledOnlyZoomEnabling

Proprietà ShowPreviewEventArgsHandledOnlyZoomEnabling
Indica che è stata gestita solo l'abilitazione dello zoom. Non deve essere gestita l'immagine da visualizzare ( non impostare _handlingCode ).

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HandledOnlyZoomEnabling { get; set; }
Public Property HandledOnlyZoomEnabling As Boolean
    Get
    Set
public:
property bool HandledOnlyZoomEnabling {
    bool get ();
    void set (bool value);
}
member HandledOnlyZoomEnabling : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ShowPreviewEventArgs
Namespace DedNet


Proprietà ShowPreviewEventArgs.HandlingCode

Proprietà ShowPreviewEventArgsHandlingCode
Restituisce o imposta la gestione dell'evento.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEventHandlerEnum HandlingCode { get; set; }
Public Property HandlingCode As DedEventHandlerEnum
    Get
    Set
public:
property DedEventHandlerEnum HandlingCode {
    DedEventHandlerEnum get ();
    void set (DedEventHandlerEnum value);
}
member HandlingCode : DedEventHandlerEnum with get, set

Valore della proprietà

DedEventHandlerEnum
Vedi anche

Documentazione

Classe ShowPreviewEventArgs
Namespace DedNet


Proprietà ShowPreviewEventArgs.Height

Proprietà ShowPreviewEventArgsHeight
Restituisce l'altezza del controllo di preview.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int Height { get; set; }
Public Property Height As Integer
    Get
    Set
public:
property int Height {
    int get ();
    void set (int value);
}
member Height : int with get, set

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe ShowPreviewEventArgs
Namespace DedNet


Proprietà ShowPreviewEventArgs.Image

Proprietà ShowPreviewEventArgsImage
Imposta o restituisce l'immagine da visualizzare.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Image Image { get; set; }
Public Property Image As Image
    Get
    Set
public:
property Image^ Image {
    Image^ get ();
    void set (Image^ value);
}
member Image : Image with get, set

Valore della proprietà

Image
Vedi anche

Documentazione

Classe ShowPreviewEventArgs
Namespace DedNet


Proprietà ShowPreviewEventArgs.Path

Proprietà ShowPreviewEventArgsPath
Restituisce il percorso del file del quale visualizzare l'anteprima.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Path { get; }
Public ReadOnly Property Path As String
    Get
public:
property String^ Path {
    String^ get ();
}
member Path : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe ShowPreviewEventArgs
Namespace DedNet


Proprietà ShowPreviewEventArgs.Title

Proprietà ShowPreviewEventArgsTitle
Restituisce il titolo dell'anteprima.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Title { get; }
Public ReadOnly Property Title As String
    Get
public:
property String^ Title {
    String^ get ();
}
member Title : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe ShowPreviewEventArgs
Namespace DedNet


Proprietà ShowPreviewEventArgs.Width

Proprietà ShowPreviewEventArgsWidth
Restituisce la larghezza del controllo di preview.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int Width { get; set; }
Public Property Width As Integer
    Get
    Set
public:
property int Width {
    int get ();
    void set (int value);
}
member Width : int with get, set

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe ShowPreviewEventArgs
Namespace DedNet


Classe ShowZoomPreviewEventArgs
Racchiude le informazioni che riguardano la visualizzazione del preview di un file.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetShowZoomPreviewEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ShowZoomPreviewEventArgs : EventArgs
Public Class ShowZoomPreviewEventArgs
    Inherits EventArgs
public ref class ShowZoomPreviewEventArgs : public EventArgs
type ShowZoomPreviewEventArgs =
    class
        inherit EventArgs
    end

Il tipo ShowZoomPreviewEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ShowZoomPreviewEventArgs | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Ext | Restituisce l'estensione del file.
Proprietà pubblica | FrmHandle | Restituisce l'handle della finestra principale.
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento.
Proprietà pubblica | ParentForm | Restituisce il form da utilizzare come parent.
Proprietà pubblica | Path | Restituisce il percorso del file del quale visualizzare l'anteprima.
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore ShowZoomPreviewEventArgs
Costruttore unico.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ShowZoomPreviewEventArgs(
    IntPtr frmHandle,
    string path
)
Public Sub New (
    frmHandle As IntPtr,
    path As String
)
public:
ShowZoomPreviewEventArgs(
    IntPtr frmHandle,
    String^ path
)
new :
        frmHandle : IntPtr *
        path : string -> ShowZoomPreviewEventArgs

Parametri

frmHandle IntPtr
path String
Vedi anche

Documentazione

Classe ShowZoomPreviewEventArgs
Namespace DedNet


Proprietà di ShowZoomPreviewEventArgs

Il tipo ShowZoomPreviewEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Ext | Restituisce l'estensione del file.
Proprietà pubblica | FrmHandle | Restituisce l'handle della finestra principale.
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento.
Proprietà pubblica | ParentForm | Restituisce il form da utilizzare come parent.
Proprietà pubblica | Path | Restituisce il percorso del file del quale visualizzare l'anteprima.
Torna su
Vedi anche

Documentazione

Classe ShowZoomPreviewEventArgs
Namespace DedNet


Proprietà ShowZoomPreviewEventArgs.Ext

Proprietà ShowZoomPreviewEventArgsExt
Restituisce l'estensione del file.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Ext { get; }
Public ReadOnly Property Ext As String
    Get
public:
property String^ Ext {
    String^ get ();
}
member Ext : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe ShowZoomPreviewEventArgs
Namespace DedNet


Proprietà ShowZoomPreviewEventArgs.FrmHandle

Proprietà ShowZoomPreviewEventArgsFrmHandle
Restituisce l'handle della finestra principale.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public IntPtr FrmHandle { get; }
Public ReadOnly Property FrmHandle As IntPtr
    Get
public:
property IntPtr FrmHandle {
    IntPtr get ();
}
member FrmHandle : IntPtr with get

Valore della proprietà

IntPtr
Vedi anche

Documentazione

Classe ShowZoomPreviewEventArgs
Namespace DedNet


Proprietà ShowZoomPreviewEventArgs.HandlingCode

Proprietà ShowZoomPreviewEventArgsHandlingCode
Restituisce o imposta la gestione dell'evento.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEventHandlerEnum HandlingCode { get; set; }
Public Property HandlingCode As DedEventHandlerEnum
    Get
    Set
public:
property DedEventHandlerEnum HandlingCode {
    DedEventHandlerEnum get ();
    void set (DedEventHandlerEnum value);
}
member HandlingCode : DedEventHandlerEnum with get, set

Valore della proprietà

DedEventHandlerEnum
Vedi anche

Documentazione

Classe ShowZoomPreviewEventArgs
Namespace DedNet


Proprietà ShowZoomPreviewEventArgs.ParentForm

Proprietà ShowZoomPreviewEventArgsParentForm
Restituisce il form da utilizzare come parent.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public IWin32Window ParentForm { get; }
Public ReadOnly Property ParentForm As IWin32Window
    Get
public:
property IWin32Window^ ParentForm {
    IWin32Window^ get ();
}
member ParentForm : IWin32Window with get

Valore della proprietà

IWin32Window
Vedi anche

Documentazione

Classe ShowZoomPreviewEventArgs
Namespace DedNet


Proprietà ShowZoomPreviewEventArgs.Path

Proprietà ShowZoomPreviewEventArgsPath
Restituisce il percorso del file del quale visualizzare l'anteprima.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Path { get; }
Public ReadOnly Property Path As String
    Get
public:
property String^ Path {
    String^ get ();
}
member Path : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe ShowZoomPreviewEventArgs
Namespace DedNet


Classe SkipDocumentStatusOnSaveDistEventArgs
Argomento utilizzato per determinare se il controllo sullo stato del documento durante il salva distinta debba essere skippato
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetSkipDocumentStatusOnSaveDistEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class SkipDocumentStatusOnSaveDistEventArgs : EventArgs
Public Class SkipDocumentStatusOnSaveDistEventArgs
    Inherits EventArgs
public ref class SkipDocumentStatusOnSaveDistEventArgs : public EventArgs
type SkipDocumentStatusOnSaveDistEventArgs =
    class
        inherit EventArgs
    end

Il tipo SkipDocumentStatusOnSaveDistEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Document | Restituisce il documento analizzato in salvataggio della distinta
Proprietà pubblica | Skip | Restituisce o imposta la versione che dovrà essere assegnata al record del documento.
Torna su
Vedi anche

Documentazione

Namespace DedNet


Proprietà di SkipDocumentStatusOnSaveDistEventArgs

Il tipo SkipDocumentStatusOnSaveDistEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Document | Restituisce il documento analizzato in salvataggio della distinta
Proprietà pubblica | Skip | Restituisce o imposta la versione che dovrà essere assegnata al record del documento.
Torna su
Vedi anche

Documentazione

Classe SkipDocumentStatusOnSaveDistEventArgs
Namespace DedNet


Proprietà SkipDocumentStatusOnSaveDistEventArgs.Document

Proprietà SkipDocumentStatusOnSaveDistEventArgsDocument
Restituisce il documento analizzato in salvataggio della distinta

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDoc Document { get; }
Public ReadOnly Property Document As DedDoc
    Get
public:
property DedDoc^ Document {
    DedDoc^ get ();
}
member Document : DedDoc with get

Valore della proprietà

DedDoc
Vedi anche

Documentazione

Classe SkipDocumentStatusOnSaveDistEventArgs
Namespace DedNet


Proprietà SkipDocumentStatusOnSaveDistEventArgs.Skip

Proprietà SkipDocumentStatusOnSaveDistEventArgsSkip
Restituisce o imposta la versione che dovrà essere assegnata al record del documento.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Skip { get; set; }
Public Property Skip As Boolean
    Get
    Set
public:
property bool Skip {
    bool get ();
    void set (bool value);
}
member Skip : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SkipDocumentStatusOnSaveDistEventArgs
Namespace DedNet


Classe SkipEsclAttribEventArgs
Contiene l'indicazione di momento esecuzione comando.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetSkipEsclAttribEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class SkipEsclAttribEventArgs : EventArgs
Public Class SkipEsclAttribEventArgs
    Inherits EventArgs
public ref class SkipEsclAttribEventArgs : public EventArgs
type SkipEsclAttribEventArgs =
    class
        inherit EventArgs
    end

Il tipo SkipEsclAttribEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | SkipEsclAttribEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AttribList |
Proprietà pubblica | Data |
Proprietà pubblica | DataDoc |
Proprietà pubblica | DedDoc |
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore SkipEsclAttribEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public SkipEsclAttribEventArgs(
    IDedData data,
    IDedData dataDoc,
    List<string> attribList
)
Public Sub New (
    data As IDedData,
    dataDoc As IDedData,
    attribList As List(Of String)
)
public:
SkipEsclAttribEventArgs(
    IDedData^ data,
    IDedData^ dataDoc,
    List<String^>^ attribList
)
new :
        data : IDedData *
        dataDoc : IDedData *
        attribList : List<string> -> SkipEsclAttribEventArgs

Parametri

data IDedData
dataDoc IDedData
attribList List String
Vedi anche

Documentazione

Classe SkipEsclAttribEventArgs
Namespace DedNet


Proprietà di SkipEsclAttribEventArgs

Il tipo SkipEsclAttribEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AttribList |
Proprietà pubblica | Data |
Proprietà pubblica | DataDoc |
Proprietà pubblica | DedDoc |
Torna su
Vedi anche

Documentazione

Classe SkipEsclAttribEventArgs
Namespace DedNet


Proprietà SkipEsclAttribEventArgs.AttribList

Proprietà SkipEsclAttribEventArgsAttribList

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> AttribList { get; set; }
Public Property AttribList As List(Of String)
    Get
    Set
public:
property List<String^>^ AttribList {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
member AttribList : List<string> with get, set

Valore della proprietà

List String
Vedi anche

Documentazione

Classe SkipEsclAttribEventArgs
Namespace DedNet


Proprietà SkipEsclAttribEventArgs.Data

Proprietà SkipEsclAttribEventArgsData

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public IDedData Data { get; }
Public ReadOnly Property Data As IDedData
    Get
public:
property IDedData^ Data {
    IDedData^ get ();
}
member Data : IDedData with get

Valore della proprietà

IDedData
Vedi anche

Documentazione

Classe SkipEsclAttribEventArgs
Namespace DedNet


Proprietà SkipEsclAttribEventArgs.DataDoc

Proprietà SkipEsclAttribEventArgsDataDoc

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public IDedData DataDoc { get; }
Public ReadOnly Property DataDoc As IDedData
    Get
public:
property IDedData^ DataDoc {
    IDedData^ get ();
}
member DataDoc : IDedData with get

Valore della proprietà

IDedData
Vedi anche

Documentazione

Classe SkipEsclAttribEventArgs
Namespace DedNet


Proprietà SkipEsclAttribEventArgs.DedDoc

Proprietà SkipEsclAttribEventArgsDedDoc

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDoc DedDoc { get; set; }
Public Property DedDoc As DedDoc
    Get
    Set
public:
property DedDoc^ DedDoc {
    DedDoc^ get ();
    void set (DedDoc^ value);
}
member DedDoc : DedDoc with get, set

Valore della proprietà

DedDoc
Vedi anche

Documentazione

Classe SkipEsclAttribEventArgs
Namespace DedNet


Classe SparePartsManualManager
Classe contenente tutte i settaggi di stile che deve avere il manuale ricambi.
Gerarchia di ereditarietà
SystemObject
DedNetSparePartsManualManager

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class SparePartsManualManager
Public Class SparePartsManualManager
public ref class SparePartsManualManager
type SparePartsManualManager = class end

Il tipo SparePartsManualManager espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | SparePartsManualManager | Crea una nuova istanza della classe 'SparePartsManualSettings' contenente tutte i settaggi di stile che deve avere il manuale ricambi.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | ConfigFile | Percorso del file di configurazione contenente i vari settaggi.
Proprietà pubblica | HyperLinkColumn | Colonna della tabella dati su cui impostare l'hyperlink.
Proprietà pubblica | Language | Lingua di default con cui creare il manuale.
Proprietà pubblica | MultiSheetTemplate | Template da utilizzare per la generazione del manuale utilizzando la struttura multi-foglio.
Proprietà pubblica | Template | Nome del template da utilizzare per generare il manuale. Corrisponde al nome del file e non all'intero percorso.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | GetLanguages | Ritorna una lista con l'elenco delle possibili lingue in cui il manuale ricambi può essere generato. In prima posizione ci sarà la lingua presente nel file DedNet.ini (in quanto si presume che sarà quella di default). A seguire ci saranno quelle definite nel Gestore Traduzioni.
Metodo pubblico | GetMultiSheetFolder | Ritorna il percorso della cartella contenente i template multifoglio.
Metodo pubblico | GetMultiSheetTemplates | Ritorna una lista con l'elenco dei possibili templates multifoglio da utilizzare per la generazione del manuale ricambi.
Metodo pubblico | GetTemplates | Ritorna una lista con l'elenco dei possibili templates da utilizzare per la generazione del manuale ricambi.
Metodo pubblico | LoadSettings | Carica le informazioni di layout.
Metodo pubblico | SaveSettings | Carica le informazioni di layout.
Torna su
Campi
Nome | Descrizione
TEMPLATE_MANUAL_SETTINGS | Nome del file di configurazione.
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore SparePartsManualManager
Crea una nuova istanza della classe 'SparePartsManualSettings' contenente tutte i settaggi di stile che deve avere il manuale ricambi.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public SparePartsManualManager(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
SparePartsManualManager(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> SparePartsManualManager

Parametri

app DedNetApplication
Applicazione DedNet.
Vedi anche

Documentazione

Classe SparePartsManualManager
Namespace DedNet


Proprietà di SparePartsManualManager

Il tipo SparePartsManualManager espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | ConfigFile | Percorso del file di configurazione contenente i vari settaggi.
Proprietà pubblica | HyperLinkColumn | Colonna della tabella dati su cui impostare l'hyperlink.
Proprietà pubblica | Language | Lingua di default con cui creare il manuale.
Proprietà pubblica | MultiSheetTemplate | Template da utilizzare per la generazione del manuale utilizzando la struttura multi-foglio.
Proprietà pubblica | Template | Nome del template da utilizzare per generare il manuale. Corrisponde al nome del file e non all'intero percorso.
Torna su
Vedi anche

Documentazione

Classe SparePartsManualManager
Namespace DedNet


Proprietà SparePartsManualManager.ConfigFile

Proprietà SparePartsManualManagerConfigFile
Percorso del file di configurazione contenente i vari settaggi.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string ConfigFile { get; }
Public ReadOnly Property ConfigFile As String
    Get
public:
property String^ ConfigFile {
    String^ get ();
}
member ConfigFile : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe SparePartsManualManager
Namespace DedNet


Proprietà SparePartsManualManager.HyperLinkColumn

Proprietà SparePartsManualManagerHyperLinkColumn
Colonna della tabella dati su cui impostare l'hyperlink.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string HyperLinkColumn { get; set; }
Public Property HyperLinkColumn As String
    Get
    Set
public:
property String^ HyperLinkColumn {
    String^ get ();
    void set (String^ value);
}
member HyperLinkColumn : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe SparePartsManualManager
Namespace DedNet


Proprietà SparePartsManualManager.Language

Proprietà SparePartsManualManagerLanguage
Lingua di default con cui creare il manuale.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Language { get; set; }
Public Property Language As String
    Get
    Set
public:
property String^ Language {
    String^ get ();
    void set (String^ value);
}
member Language : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe SparePartsManualManager
Namespace DedNet


Proprietà SparePartsManualManager.MultiSheetTemplate

Proprietà SparePartsManualManagerMultiSheetTemplate
Template da utilizzare per la generazione del manuale utilizzando la struttura multi-foglio.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string MultiSheetTemplate { get; set; }
Public Property MultiSheetTemplate As String
    Get
    Set
public:
property String^ MultiSheetTemplate {
    String^ get ();
    void set (String^ value);
}
member MultiSheetTemplate : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe SparePartsManualManager
Namespace DedNet


Proprietà SparePartsManualManager.Template

Proprietà SparePartsManualManagerTemplate
Nome del template da utilizzare per generare il manuale. Corrisponde al nome del file e non all'intero percorso.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Template { get; set; }
Public Property Template As String
    Get
    Set
public:
property String^ Template {
    String^ get ();
    void set (String^ value);
}
member Template : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe SparePartsManualManager
Namespace DedNet


Metodi di SparePartsManualManager

Il tipo SparePartsManualManager espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | GetLanguages | Ritorna una lista con l'elenco delle possibili lingue in cui il manuale ricambi può essere generato. In prima posizione ci sarà la lingua presente nel file DedNet.ini (in quanto si presume che sarà quella di default). A seguire ci saranno quelle definite nel Gestore Traduzioni.
Metodo pubblico | GetMultiSheetFolder | Ritorna il percorso della cartella contenente i template multifoglio.
Metodo pubblico | GetMultiSheetTemplates | Ritorna una lista con l'elenco dei possibili templates multifoglio da utilizzare per la generazione del manuale ricambi.
Metodo pubblico | GetTemplates | Ritorna una lista con l'elenco dei possibili templates da utilizzare per la generazione del manuale ricambi.
Metodo pubblico | LoadSettings | Carica le informazioni di layout.
Metodo pubblico | SaveSettings | Carica le informazioni di layout.
Torna su
Vedi anche

Documentazione

Classe SparePartsManualManager
Namespace DedNet


Metodo SparePartsManualManager.GetLanguages

Metodo SparePartsManualManagerGetLanguages
Ritorna una lista con l'elenco delle possibili lingue in cui il manuale ricambi può essere generato. In prima posizione ci sarà la lingua presente nel file DedNet.ini (in quanto si presume che sarà quella di default). A seguire ci saranno quelle definite nel Gestore Traduzioni.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> GetLanguages()
Public Function GetLanguages As List(Of String)
public:
List<String^>^ GetLanguages()
member GetLanguages : unit -> List<string>

Valore di ritorno

List String
Vedi anche

Documentazione

Classe SparePartsManualManager
Namespace DedNet


Metodo SparePartsManualManager.GetMultiSheetFolder

Metodo SparePartsManualManagerGetMultiSheetFolder
Ritorna il percorso della cartella contenente i template multifoglio.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string GetMultiSheetFolder()
Public Function GetMultiSheetFolder As String
public:
String^ GetMultiSheetFolder()
member GetMultiSheetFolder : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe SparePartsManualManager
Namespace DedNet


Metodo SparePartsManualManager.GetMultiSheetTemplates

Metodo SparePartsManualManagerGetMultiSheetTemplates
Ritorna una lista con l'elenco dei possibili templates multifoglio da utilizzare per la generazione del manuale ricambi.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> GetMultiSheetTemplates()
Public Function GetMultiSheetTemplates As List(Of String)
public:
List<String^>^ GetMultiSheetTemplates()
member GetMultiSheetTemplates : unit -> List<string>

Valore di ritorno

List String
Vedi anche

Documentazione

Classe SparePartsManualManager
Namespace DedNet


Metodo SparePartsManualManager.GetTemplates

Metodo SparePartsManualManagerGetTemplates
Ritorna una lista con l'elenco dei possibili templates da utilizzare per la generazione del manuale ricambi.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> GetTemplates()
Public Function GetTemplates As List(Of String)
public:
List<String^>^ GetTemplates()
member GetTemplates : unit -> List<string>

Valore di ritorno

List String
Vedi anche

Documentazione

Classe SparePartsManualManager
Namespace DedNet


Metodo SparePartsManualManager.LoadSettings

Metodo SparePartsManualManagerLoadSettings
Carica le informazioni di layout.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void LoadSettings()
Public Sub LoadSettings
public:
void LoadSettings()
member LoadSettings : unit -> unit
Vedi anche

Documentazione

Classe SparePartsManualManager
Namespace DedNet


Metodo SparePartsManualManager.SaveSettings

Metodo SparePartsManualManagerSaveSettings
Carica le informazioni di layout.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SaveSettings()
Public Sub SaveSettings
public:
void SaveSettings()
member SaveSettings : unit -> unit
Vedi anche

Documentazione

Classe SparePartsManualManager
Namespace DedNet


Campi di SparePartsManualManager

Il tipo SparePartsManualManager espone i seguenti membri.

Campi
Nome | Descrizione
TEMPLATE_MANUAL_SETTINGS | Nome del file di configurazione.
Torna su
Vedi anche

Documentazione

Classe SparePartsManualManager
Namespace DedNet


Campo SparePartsManualManager.TEMPLATE_MANUAL_SETTINGS

Campo SparePartsManualManagerTEMPLATE_MANUAL_SETTINGS
Nome del file di configurazione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string TEMPLATE_MANUAL_SETTINGS = "QsInformatica_ManualSettings"
Public Const TEMPLATE_MANUAL_SETTINGS As String = "QsInformatica_ManualSettings"
public:
literal String^ TEMPLATE_MANUAL_SETTINGS = "QsInformatica_ManualSettings"
static val mutable TEMPLATE_MANUAL_SETTINGS: string

Valore del campo

String
Vedi anche

Documentazione

Classe SparePartsManualManager
Namespace DedNet


Classe StateChangedEventArgs
Contiene le informazioni necessarie sul cambio di stato di un'anagrafica.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetStateChangedEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class StateChangedEventArgs : EventArgs
Public Class StateChangedEventArgs
    Inherits EventArgs
public ref class StateChangedEventArgs : public EventArgs
type StateChangedEventArgs =
    class
        inherit EventArgs
    end

Il tipo StateChangedEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | StateChangedEventArgs | Costruttore.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | ActualState | Restituisce lo stato attuale.
Proprietà pubblica | Data | Anagrafica di cui è cambiato lo stato.
Proprietà pubblica | PrecState | Restituisce lo stato precedente.
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore StateChangedEventArgs
Costruttore.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public StateChangedEventArgs(
    DedData data,
    DedState precState,
    DedState actualState
)
Public Sub New (
    data As DedData,
    precState As DedState,
    actualState As DedState
)
public:
StateChangedEventArgs(
    DedData^ data,
    DedState^ precState,
    DedState^ actualState
)
new :
        data : DedData *
        precState : DedState *
        actualState : DedState -> StateChangedEventArgs

Parametri

data DedData
Anagrafica della quale è stato modificato lo stato.
precState DedState
Stato precedente.
actualState DedState
Stato attuale.
Vedi anche

Documentazione

Classe StateChangedEventArgs
Namespace DedNet


Proprietà di StateChangedEventArgs

Il tipo StateChangedEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | ActualState | Restituisce lo stato attuale.
Proprietà pubblica | Data | Anagrafica di cui è cambiato lo stato.
Proprietà pubblica | PrecState | Restituisce lo stato precedente.
Torna su
Vedi anche

Documentazione

Classe StateChangedEventArgs
Namespace DedNet


Proprietà StateChangedEventArgs.ActualState

Proprietà StateChangedEventArgsActualState
Restituisce lo stato attuale.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedState ActualState { get; }
Public ReadOnly Property ActualState As DedState
    Get
public:
property DedState^ ActualState {
    DedState^ get ();
}
member ActualState : DedState with get

Valore della proprietà

DedState
Vedi anche

Documentazione

Classe StateChangedEventArgs
Namespace DedNet


Proprietà StateChangedEventArgs.Data

Proprietà StateChangedEventArgsData
Anagrafica di cui è cambiato lo stato.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; }
Public ReadOnly Property Data As DedData
    Get
public:
property DedData^ Data {
    DedData^ get ();
}
member Data : DedData with get

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe StateChangedEventArgs
Namespace DedNet


Proprietà StateChangedEventArgs.PrecState

Proprietà StateChangedEventArgsPrecState
Restituisce lo stato precedente.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedState PrecState { get; }
Public ReadOnly Property PrecState As DedState
    Get
public:
property DedState^ PrecState {
    DedState^ get ();
}
member PrecState : DedState with get

Valore della proprietà

DedState
Vedi anche

Documentazione

Classe StateChangedEventArgs
Namespace DedNet


Classe StateCommandEventArgs
Argomento di elaborazione documento durante il comando di modifica stato anagrafica.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetDedBeforeOrAfterEventArgs
DedNetDedEventArgs
DedNetDedCommandEventArgs
DedNetStateCommandEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class StateCommandEventArgs : DedCommandEventArgs
Public Class StateCommandEventArgs
    Inherits DedCommandEventArgs
public ref class StateCommandEventArgs : public DedCommandEventArgs
type StateCommandEventArgs =
    class
        inherit DedCommandEventArgs
    end

Il tipo StateCommandEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | StateCommandEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Command | Restituisce il comando in esecuzione. (Ereditato da DedCommandEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | Data | Restituisce l'anagrafica associata al documento in elaborazione.
Proprietà pubblica | Document | Restituisce il documento in elaborazione dal comando.
Proprietà pubblica | DocWasInCheckIn | Restituisce se il documento, in partenza, era in check-in.
Proprietà pubblica | DocWasOpened | Restituisce o imposta se il documento era aperto. Il client imposta questo flag a true per indicare che NON deve essere chiamato l'evento di chiusura documento.
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Proprietà pubblica | PublicationExceptionList | Restituisce la lista delle eventuali eccezioni catturate in fase pubblicazione della documentazione
Proprietà pubblica | RunningContext | Contesto di lancio del comando (Ereditato da DedCommandEventArgs)
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore StateCommandEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public StateCommandEventArgs()
Public Sub New
public:
StateCommandEventArgs()
new : unit -> StateCommandEventArgs
Vedi anche

Documentazione

Classe StateCommandEventArgs
Namespace DedNet


Proprietà di StateCommandEventArgs

Il tipo StateCommandEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Command | Restituisce il comando in esecuzione. (Ereditato da DedCommandEventArgs)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs)
Proprietà pubblica | Data | Restituisce l'anagrafica associata al documento in elaborazione.
Proprietà pubblica | Document | Restituisce il documento in elaborazione dal comando.
Proprietà pubblica | DocWasInCheckIn | Restituisce se il documento, in partenza, era in check-in.
Proprietà pubblica | DocWasOpened | Restituisce o imposta se il documento era aperto. Il client imposta questo flag a true per indicare che NON deve essere chiamato l'evento di chiusura documento.
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs)
Proprietà pubblica | PublicationExceptionList | Restituisce la lista delle eventuali eccezioni catturate in fase pubblicazione della documentazione
Proprietà pubblica | RunningContext | Contesto di lancio del comando (Ereditato da DedCommandEventArgs)
Torna su
Vedi anche

Documentazione

Classe StateCommandEventArgs
Namespace DedNet


Proprietà StateCommandEventArgs.Data

Proprietà StateCommandEventArgsData
Restituisce l'anagrafica associata al documento in elaborazione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; }
Public ReadOnly Property Data As DedData
    Get
public:
property DedData^ Data {
    DedData^ get ();
}
member Data : DedData with get

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe StateCommandEventArgs
Namespace DedNet


Proprietà StateCommandEventArgs.Document

Proprietà StateCommandEventArgsDocument
Restituisce il documento in elaborazione dal comando.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDoc Document { get; }
Public ReadOnly Property Document As DedDoc
    Get
public:
property DedDoc^ Document {
    DedDoc^ get ();
}
member Document : DedDoc with get

Valore della proprietà

DedDoc
Vedi anche

Documentazione

Classe StateCommandEventArgs
Namespace DedNet


Proprietà StateCommandEventArgs.DocWasInCheckIn

Proprietà StateCommandEventArgsDocWasInCheckIn
Restituisce se il documento, in partenza, era in check-in.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool DocWasInCheckIn { get; }
Public ReadOnly Property DocWasInCheckIn As Boolean
    Get
public:
property bool DocWasInCheckIn {
    bool get ();
}
member DocWasInCheckIn : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe StateCommandEventArgs
Namespace DedNet


Proprietà StateCommandEventArgs.DocWasOpened

Proprietà StateCommandEventArgsDocWasOpened
Restituisce o imposta se il documento era aperto. Il client imposta questo flag a true per indicare che NON deve essere chiamato l'evento di chiusura documento.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool DocWasOpened { get; set; }
Public Property DocWasOpened As Boolean
    Get
    Set
public:
property bool DocWasOpened {
    bool get ();
    void set (bool value);
}
member DocWasOpened : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe StateCommandEventArgs
Namespace DedNet


Proprietà StateCommandEventArgs.PublicationExceptionList

Proprietà StateCommandEventArgsPublicationExceptionList
Restituisce la lista delle eventuali eccezioni catturate in fase pubblicazione della documentazione

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<Exception> PublicationExceptionList { get; }
Public ReadOnly Property PublicationExceptionList As List(Of Exception)
    Get
public:
property List<Exception^>^ PublicationExceptionList {
    List<Exception^>^ get ();
}
member PublicationExceptionList : List<Exception> with get

Valore della proprietà

List Exception
Vedi anche

Documentazione

Classe StateCommandEventArgs
Namespace DedNet


Classe UnRilErasePublishEventArgs
Argomento utilizzato per l'evento di elimininazione dei formati quando viene tolto il rilascio
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNetDedBeforeOrAfterEventArgs
DedNetUnRilErasePublishEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class UnRilErasePublishEventArgs : DedBeforeOrAfterEventArgs
Public Class UnRilErasePublishEventArgs
    Inherits DedBeforeOrAfterEventArgs
public ref class UnRilErasePublishEventArgs : public DedBeforeOrAfterEventArgs
type UnRilErasePublishEventArgs =
    class
        inherit DedBeforeOrAfterEventArgs
    end

Il tipo UnRilErasePublishEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | UnRilErasePublishEventArgs | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Data | Restituisce l'anagrafica associata al documento in elaborazione.
Proprietà pubblica | DeletionFormat | Ritorna il formato di riferimento per l'operazione di eliminazione
Proprietà pubblica | DocHasToBeKept | Imposta e Restituisce se il documento di pubblicazione deve essere mantenuto (TRUE significa non cancellare!)
Proprietà pubblica | Document | Restituisce il documento in elaborazione dal comando.
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore UnRilErasePublishEventArgs
Costruttore

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public UnRilErasePublishEventArgs(
    DedData data,
    DedDoc doc,
    DedPublicationFormat fmtDeletion,
    bool docHasToBeKept
)
Public Sub New (
    data As DedData,
    doc As DedDoc,
    fmtDeletion As DedPublicationFormat,
    docHasToBeKept As Boolean
)
public:
UnRilErasePublishEventArgs(
    DedData^ data,
    DedDoc^ doc,
    DedPublicationFormat fmtDeletion,
    bool docHasToBeKept
)
new :
        data : DedData *
        doc : DedDoc *
        fmtDeletion : DedPublicationFormat *
        docHasToBeKept : bool -> UnRilErasePublishEventArgs

Parametri

data DedData
doc DedDoc
fmtDeletion DedPublicationFormat
docHasToBeKept Boolean
Vedi anche

Documentazione

Classe UnRilErasePublishEventArgs
Namespace DedNet


Proprietà di UnRilErasePublishEventArgs

Il tipo UnRilErasePublishEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs)
Proprietà pubblica | Data | Restituisce l'anagrafica associata al documento in elaborazione.
Proprietà pubblica | DeletionFormat | Ritorna il formato di riferimento per l'operazione di eliminazione
Proprietà pubblica | DocHasToBeKept | Imposta e Restituisce se il documento di pubblicazione deve essere mantenuto (TRUE significa non cancellare!)
Proprietà pubblica | Document | Restituisce il documento in elaborazione dal comando.
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs)
Torna su
Vedi anche

Documentazione

Classe UnRilErasePublishEventArgs
Namespace DedNet


Proprietà UnRilErasePublishEventArgs.Data

Proprietà UnRilErasePublishEventArgsData
Restituisce l'anagrafica associata al documento in elaborazione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; }
Public ReadOnly Property Data As DedData
    Get
public:
property DedData^ Data {
    DedData^ get ();
}
member Data : DedData with get

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe UnRilErasePublishEventArgs
Namespace DedNet


Proprietà UnRilErasePublishEventArgs.DeletionFormat

Proprietà UnRilErasePublishEventArgsDeletionFormat
Ritorna il formato di riferimento per l'operazione di eliminazione

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedPublicationFormat DeletionFormat { get; }
Public ReadOnly Property DeletionFormat As DedPublicationFormat
    Get
public:
property DedPublicationFormat DeletionFormat {
    DedPublicationFormat get ();
}
member DeletionFormat : DedPublicationFormat with get

Valore della proprietà

DedPublicationFormat
Vedi anche

Documentazione

Classe UnRilErasePublishEventArgs
Namespace DedNet


Proprietà UnRilErasePublishEventArgs.DocHasToBeKept

Proprietà UnRilErasePublishEventArgsDocHasToBeKept
Imposta e Restituisce se il documento di pubblicazione deve essere mantenuto (TRUE significa non cancellare!)

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool DocHasToBeKept { get; set; }
Public Property DocHasToBeKept As Boolean
    Get
    Set
public:
property bool DocHasToBeKept {
    bool get ();
    void set (bool value);
}
member DocHasToBeKept : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe UnRilErasePublishEventArgs
Namespace DedNet


Proprietà UnRilErasePublishEventArgs.Document

Proprietà UnRilErasePublishEventArgsDocument
Restituisce il documento in elaborazione dal comando.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDoc Document { get; }
Public ReadOnly Property Document As DedDoc
    Get
public:
property DedDoc^ Document {
    DedDoc^ get ();
}
member Document : DedDoc with get

Valore della proprietà

DedDoc
Vedi anche

Documentazione

Classe UnRilErasePublishEventArgs
Namespace DedNet


Classe UpgradeAnagrCommEventArgs
Argomento utilizzato in esecuzione dell'evento di aggiornamento anagrafiche nel gestore commesse.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetUpgradeAnagrCommEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class UpgradeAnagrCommEventArgs : EventArgs
Public Class UpgradeAnagrCommEventArgs
    Inherits EventArgs
public ref class UpgradeAnagrCommEventArgs : public EventArgs
type UpgradeAnagrCommEventArgs =
    class
        inherit EventArgs
    end

Il tipo UpgradeAnagrCommEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | UpgradeAnagrCommEventArgs | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | CommAnagrItem | Anagrafica di commessa
Proprietà pubblica | RefComm | Commessa di riferimento
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore UpgradeAnagrCommEventArgs
Costruttore unico.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public UpgradeAnagrCommEventArgs(
    DedComm refComm,
    DedCommAnagrItem commAnagrItem
)
Public Sub New (
    refComm As DedComm,
    commAnagrItem As DedCommAnagrItem
)
public:
UpgradeAnagrCommEventArgs(
    DedComm^ refComm,
    DedCommAnagrItem^ commAnagrItem
)
new :
        refComm : DedComm *
        commAnagrItem : DedCommAnagrItem -> UpgradeAnagrCommEventArgs

Parametri

refComm DedComm
Commessa di riferimento
commAnagrItem DedCommAnagrItem
Anagrafica di commessa
Vedi anche

Documentazione

Classe UpgradeAnagrCommEventArgs
Namespace DedNet


Proprietà di UpgradeAnagrCommEventArgs

Il tipo UpgradeAnagrCommEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CommAnagrItem | Anagrafica di commessa
Proprietà pubblica | RefComm | Commessa di riferimento
Torna su
Vedi anche

Documentazione

Classe UpgradeAnagrCommEventArgs
Namespace DedNet


Proprietà UpgradeAnagrCommEventArgs.CommAnagrItem

Proprietà UpgradeAnagrCommEventArgsCommAnagrItem
Anagrafica di commessa

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommAnagrItem CommAnagrItem { get; set; }
Public Property CommAnagrItem As DedCommAnagrItem
    Get
    Set
public:
property DedCommAnagrItem^ CommAnagrItem {
    DedCommAnagrItem^ get ();
    void set (DedCommAnagrItem^ value);
}
member CommAnagrItem : DedCommAnagrItem with get, set

Valore della proprietà

DedCommAnagrItem
Vedi anche

Documentazione

Classe UpgradeAnagrCommEventArgs
Namespace DedNet


Proprietà UpgradeAnagrCommEventArgs.RefComm

Proprietà UpgradeAnagrCommEventArgsRefComm
Commessa di riferimento

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedComm RefComm { get; set; }
Public Property RefComm As DedComm
    Get
    Set
public:
property DedComm^ RefComm {
    DedComm^ get ();
    void set (DedComm^ value);
}
member RefComm : DedComm with get, set

Valore della proprietà

DedComm
Vedi anche

Documentazione

Classe UpgradeAnagrCommEventArgs
Namespace DedNet


Classe ValidateCheckFunctionEventArgs
Argomento per gli eventi di validazione della funzione di controllo degli attributi.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetValidateCheckFunctionEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ValidateCheckFunctionEventArgs : EventArgs
Public Class ValidateCheckFunctionEventArgs
    Inherits EventArgs
public ref class ValidateCheckFunctionEventArgs : public EventArgs
type ValidateCheckFunctionEventArgs =
    class
        inherit EventArgs
    end

Il tipo ValidateCheckFunctionEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo protetto | ValidateCheckFunctionEventArgs | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Attr | Restituisce la modalità di salvataggio dell'anagrafica.
Proprietà pubblica | Checkfunction | Funzione di check.
Proprietà pubblica | DedData | Restituisce la modalità di salvataggio dell'anagrafica.
Proprietà pubblica | ErrorText | Imposta/restituisce il testo relativo all'errore di validazione.
Proprietà pubblica | IsValid | Imposta/restituisce se la validazione è ok.
Proprietà pubblica | Valore | Valore dell'attributo.
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore ValidateCheckFunctionEventArgs
Costruttore unico.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal ValidateCheckFunctionEventArgs(
    DedAttr attr,
    string checkFunction,
    Object valore,
    IDedEditable dedData
)
Protected Friend Sub New (
    attr As DedAttr,
    checkFunction As String,
    valore As Object,
    dedData As IDedEditable
)
protected public:
ValidateCheckFunctionEventArgs(
    DedAttr^ attr,
    String^ checkFunction,
    Object^ valore,
    IDedEditable^ dedData
)
new :
        attr : DedAttr *
        checkFunction : string *
        valore : Object *
        dedData : IDedEditable -> ValidateCheckFunctionEventArgs

Parametri

attr DedAttr
checkFunction String
valore Object
dedData IDedEditable
Vedi anche

Documentazione

Classe ValidateCheckFunctionEventArgs
Namespace DedNet


Proprietà di ValidateCheckFunctionEventArgs

Il tipo ValidateCheckFunctionEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Attr | Restituisce la modalità di salvataggio dell'anagrafica.
Proprietà pubblica | Checkfunction | Funzione di check.
Proprietà pubblica | DedData | Restituisce la modalità di salvataggio dell'anagrafica.
Proprietà pubblica | ErrorText | Imposta/restituisce il testo relativo all'errore di validazione.
Proprietà pubblica | IsValid | Imposta/restituisce se la validazione è ok.
Proprietà pubblica | Valore | Valore dell'attributo.
Torna su
Vedi anche

Documentazione

Classe ValidateCheckFunctionEventArgs
Namespace DedNet


Proprietà ValidateCheckFunctionEventArgs.Attr

Proprietà ValidateCheckFunctionEventArgsAttr
Restituisce la modalità di salvataggio dell'anagrafica.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttr Attr { get; }
Public ReadOnly Property Attr As DedAttr
    Get
public:
property DedAttr^ Attr {
    DedAttr^ get ();
}
member Attr : DedAttr with get

Valore della proprietà

DedAttr
Vedi anche

Documentazione

Classe ValidateCheckFunctionEventArgs
Namespace DedNet


Proprietà ValidateCheckFunctionEventArgs.Checkfunction

Proprietà ValidateCheckFunctionEventArgsCheckfunction
Funzione di check.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Checkfunction { get; }
Public ReadOnly Property Checkfunction As String
    Get
public:
property String^ Checkfunction {
    String^ get ();
}
member Checkfunction : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe ValidateCheckFunctionEventArgs
Namespace DedNet


Proprietà ValidateCheckFunctionEventArgs.DedData

Proprietà ValidateCheckFunctionEventArgsDedData
Restituisce la modalità di salvataggio dell'anagrafica.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public IDedEditable DedData { get; }
Public ReadOnly Property DedData As IDedEditable
    Get
public:
property IDedEditable^ DedData {
    IDedEditable^ get ();
}
member DedData : IDedEditable with get

Valore della proprietà

IDedEditable
Vedi anche

Documentazione

Classe ValidateCheckFunctionEventArgs
Namespace DedNet


Proprietà ValidateCheckFunctionEventArgs.ErrorText

Proprietà ValidateCheckFunctionEventArgsErrorText
Imposta/restituisce il testo relativo all'errore di validazione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string ErrorText { get; set; }
Public Property ErrorText As String
    Get
    Set
public:
property String^ ErrorText {
    String^ get ();
    void set (String^ value);
}
member ErrorText : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe ValidateCheckFunctionEventArgs
Namespace DedNet


Proprietà ValidateCheckFunctionEventArgs.IsValid

Proprietà ValidateCheckFunctionEventArgsIsValid
Imposta/restituisce se la validazione è ok.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsValid { get; set; }
Public Property IsValid As Boolean
    Get
    Set
public:
property bool IsValid {
    bool get ();
    void set (bool value);
}
member IsValid : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ValidateCheckFunctionEventArgs
Namespace DedNet


Proprietà ValidateCheckFunctionEventArgs.Valore

Proprietà ValidateCheckFunctionEventArgsValore
Valore dell'attributo.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object Valore { get; }
Public ReadOnly Property Valore As Object
    Get
public:
property Object^ Valore {
    Object^ get ();
}
member Valore : Object with get

Valore della proprietà

Object
Vedi anche

Documentazione

Classe ValidateCheckFunctionEventArgs
Namespace DedNet


Classe ValidateFamPropertyEventArgs
Argomento per gli eventi di validazione della famiglia.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetValidateFamPropertyEventArgs

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ValidateFamPropertyEventArgs : EventArgs
Public Class ValidateFamPropertyEventArgs
    Inherits EventArgs
public ref class ValidateFamPropertyEventArgs : public EventArgs
type ValidateFamPropertyEventArgs =
    class
        inherit EventArgs
    end

Il tipo ValidateFamPropertyEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo protetto | ValidateFamPropertyEventArgs | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Cancel | Imposta/restituisce se è da cancellare o no.
Proprietà pubblica | Control | Controllo da validare.
Proprietà pubblica | ErrorText | Imposta/restituisce il testo relativo all'errore di validazione.
Proprietà pubblica | Fam | Restituisce la famiglia selezionata.
Proprietà pubblica | Form | Restituisce il form del QsManager.
Torna su
Vedi anche

Documentazione

Namespace DedNet


Costruttore ValidateFamPropertyEventArgs
Costruttore unico.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal ValidateFamPropertyEventArgs(
    DedFormQsManager form,
    Control control,
    DedTypeBase fam
)
Protected Friend Sub New (
    form As DedFormQsManager,
    control As Control,
    fam As DedTypeBase
)
protected public:
ValidateFamPropertyEventArgs(
    DedFormQsManager^ form,
    Control^ control,
    DedTypeBase^ fam
)
new :
        form : DedFormQsManager *
        control : Control *
        fam : DedTypeBase -> ValidateFamPropertyEventArgs

Parametri

form DedFormQsManager
control Control
fam DedTypeBase
Vedi anche

Documentazione

Classe ValidateFamPropertyEventArgs
Namespace DedNet


Proprietà di ValidateFamPropertyEventArgs

Il tipo ValidateFamPropertyEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Cancel | Imposta/restituisce se è da cancellare o no.
Proprietà pubblica | Control | Controllo da validare.
Proprietà pubblica | ErrorText | Imposta/restituisce il testo relativo all'errore di validazione.
Proprietà pubblica | Fam | Restituisce la famiglia selezionata.
Proprietà pubblica | Form | Restituisce il form del QsManager.
Torna su
Vedi anche

Documentazione

Classe ValidateFamPropertyEventArgs
Namespace DedNet


Proprietà ValidateFamPropertyEventArgs.Cancel

Proprietà ValidateFamPropertyEventArgsCancel
Imposta/restituisce se è da cancellare o no.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Cancel { get; set; }
Public Property Cancel As Boolean
    Get
    Set
public:
property bool Cancel {
    bool get ();
    void set (bool value);
}
member Cancel : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ValidateFamPropertyEventArgs
Namespace DedNet


Proprietà ValidateFamPropertyEventArgs.Control

Proprietà ValidateFamPropertyEventArgsControl
Controllo da validare.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Control Control { get; }
Public ReadOnly Property Control As Control
    Get
public:
property Control^ Control {
    Control^ get ();
}
member Control : Control with get

Valore della proprietà

Control
Vedi anche

Documentazione

Classe ValidateFamPropertyEventArgs
Namespace DedNet


Proprietà ValidateFamPropertyEventArgs.ErrorText

Proprietà ValidateFamPropertyEventArgsErrorText
Imposta/restituisce il testo relativo all'errore di validazione.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string ErrorText { get; set; }
Public Property ErrorText As String
    Get
    Set
public:
property String^ ErrorText {
    String^ get ();
    void set (String^ value);
}
member ErrorText : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe ValidateFamPropertyEventArgs
Namespace DedNet


Proprietà ValidateFamPropertyEventArgs.Fam

Proprietà ValidateFamPropertyEventArgsFam
Restituisce la famiglia selezionata.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeBase Fam { get; }
Public ReadOnly Property Fam As DedTypeBase
    Get
public:
property DedTypeBase^ Fam {
    DedTypeBase^ get ();
}
member Fam : DedTypeBase with get

Valore della proprietà

DedTypeBase
Vedi anche

Documentazione

Classe ValidateFamPropertyEventArgs
Namespace DedNet


Proprietà ValidateFamPropertyEventArgs.Form

Proprietà ValidateFamPropertyEventArgsForm
Restituisce il form del QsManager.

Namespace: DedNet
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormQsManager Form { get; }
Public ReadOnly Property Form As DedFormQsManager
    Get
public:
property DedFormQsManager^ Form {
    DedFormQsManager^ get ();
}
member Form : DedFormQsManager with get

Valore della proprietà

DedFormQsManager
Vedi anche

Documentazione

Classe ValidateFamPropertyEventArgs
Namespace DedNet


DedNet.Commands Namespace
Spazio dei nomi contenente tutte le classi di definizione dei comandi.
Classi
Classe | Descrizione
Classe pubblica | AddCommCommand | Comando creazione di una commessa.
Classe pubblica | AddEcoCommand | Comando usato per creare/editare gli ECO.
Classe pubblica | AddRecurrentTimingCommand | Comando utilizzato per aggiungere anagrafiche, commesse, ECO all'elenco delle temporizzazioni ricorrenti.
Classe pubblica | AddRemoveRecurrentTiming | Comando utilizzato per aggiungere/rimuovere una temporizzazione dai ricorrenti.
Classe pubblica | AnagrAssocComm | Classe che rappresenta il comando per associare anagrafica a commessa.
Classe pubblica | AnagrHistoryCommand | Classe che rappresenta il comando per visualizzare la storia di un'anagrafica.
Classe pubblica | AnnullaCheckOutDocument | Permette di annullare il check-out di una lista di documenti ripristinando la situazione a prima di aver effettuato il check-out.
Classe pubblica | AssignEcoToSpecificUserCommand | Comando usato per assegnare un ECO ad un utente specifico.
Classe pubblica | AssociateAlternativeDataCommand | Comando utilizzato per associare ad un set di anagrafiche dei codici alternativi.
Classe pubblica | AssociateDocument | Utilizzato per decidere se associare un documento come file primario o come allegato di un'anagrafica ed anche per decidere se importare o collegare il documento all'anagrafica (nel caso in cui il documento risulti già registrato nel Database). Di fatto si tratta di un comando a più alto livello che chiama ImportDocument oppure LinkDocument in base al file in elaborazione ed in base alla scelta dell'utente, se l'uso dell'interfaccia utente risulta abilita. I client possono registrare un delegate per operare la copia del documento nella nuova posizione nel caso risulti necessario. Attraverso le proprietà del comando il client può venire a conoscenza delle scelte dell'utente.
Classe pubblica | BomEditCommand | Classe che rappresenta il comando per editare la distinta.
Classe pubblica | BomHistoryCommand | Classe che rappresenta il comando per visualizzare lo storico revisioni di una distinta.
Classe pubblica | BomWhereUsedCommand | Classe che rappresenta il comando per l'estrazione dei padri di distinta comuni per le anagrafiche selezionate
Classe pubblica | ChangeEcoStateCommand | Comando usato per cambiare lo stato di un ECO.
Classe pubblica | ChangePasswordCommand | Classe che rappresenta il comando per cambiare la password dell'utente.
Classe pubblica | ChangeRepresentationSuffixCommand | Classe che rappresenta il comando per modificare il suffisso di un documento di rappresentazione.
Classe pubblica | ChargeCommCommand | Comando per la presa in carico di una commessa da parte dell'utente corrente.
Classe pubblica | CheckInDocument | Effettua il checkin dei documenti pubblicandoli sul server. Opzionalmente i documenti possono essere rimossi dall'area locale. Se si imposta l'opzione Struttura viene effettuato il checkin dei documenti di testata più tutte le dipendenze che risultano in checkout.
Classe pubblica | CheckOutDocument | Imposta in checkout una lista di documenti. Effettua i controllie si assicura che tutte le dipendenze siano presenti in locale.
Classe pubblica | ChmHelpCommand | Classe che rappresente il comando per visualizzare l'help (.chm). Obbligatorio impostare al comando la proprietà Parent contenente il controllo che lo chiama.
Classe pubblica | CloseCommCommand | Comando chiusura di una commessa.
Classe pubblica | CmdUtil | Classe di utilità comuni a diversi comandi.
Classe pubblica | CommEditCommand | Classe che rappresenta il comando per aprire il gestore commesse.
Classe pubblica | CommEsplCommand | Comando di esplosione di una commessa.
Classe pubblica | CopyDocument | Permette di copiare una lista di documenti in una nuova destinazione con un nuovo nome, e creando quindi nuovi documenti. I file di partenza possono anche non essere presenti nel Database. Se è attiva l'area locale i nuovi documenti vengono creati in checkout dall'utente e non vengono pubblicati sul server. La pubblicazione avverrà su comando esplicito dell'utente. Viene chiamato un evento che permette al client di sostituirsi al comando ed effettuare la copia fisica del file, se questo non viene fatto dal client viene fatto dal comando stesso. Aggiorna poi i riferimenti presenti nei file di Inventor appena copiati, per quanto riguarda i documenti coinvolti nella copia.
Classe pubblica | CopyDocumentCopyDocumentItem | Descrive un singolo documento da copiare.
Classe pubblica | CopyDocumentCopyDocumentList | Lista di oggetti CopyDocumentItem.
Classe pubblica | CreateDocument | Crea l'anagrafica documentale dato un nome completo di file. Se il file risulta essere già registrato nel Database allora non fa niente e ne ricava solo il documento. Diversamente lo aggiunge lasciandolo così com'è e registrando anche tutte le sue sotto-dipendenze a cascata, sempre lasciando i nomi ed i percorsi di file così come sono. Se avviene anche un singolo errore viene annullata tutta l'operazione. Tutti i file devono essere nelle root del Database.
Classe pubblica | CreateEditSparePartsAttributesCommand | Comando utilizzato per editare gli attributi di ricambio di un set di anagrafiche.
Classe pubblica | CreateFolder | Crea una cartella.
Classe pubblica | CreateManualCommand | Comando utilizzato per generare il manuale di una distinta.
Classe pubblica | CreateSparePartsDrawingCommand | Comando utilizzato per creare il documento tecnico da inserire nel manuale ricambi.
Classe pubblica | DataStatisticsAnalyzer | Comando di individuazione elementi albero dall'area grafica / browser.
Classe pubblica | DbDocCompareCommand | Comando per confrontare i dati provenienti da un documento e quelli presenti nell'anagrafica del Database.
Classe pubblica | DbVersionCommand | Classe che rappresenta il comando per editare gli utenti e i permessi.
Classe pubblica | DedAboutCommand | Classe che rappresente il comando per visualizzare l'about del DED.
Classe pubblica | DedBomEditFormButtonCommand | Classe per gestire i button personalizzati nelle tendine del form editor delle distinte
Classe pubblica | DedBomEditFormCommandBase | Classe per gestire i comandi personalizzati nelle tendine del form editor delle distinte
Classe pubblica | DedBomEditFormCommandList | Lista di oggetti DedBomEditFormCommand.
Classe pubblica | DedBomEditFormToggleCommand | Classe per gestire i toggle personalizzati nelle tendine del form editor delle distinte
Classe pubblica | DedBomExplorerCtrlCommand | Classe per gestire i comandi personalizzati dei controlli explorer nell'editor delle distinte
Classe pubblica | DedBomExplorerCtrlCommandList | Lista di oggetti DedBomExplorerCtrlCommand.
Classe pubblica | DedCommand | Classe base dalla quale derivare ogni comando dell'applicazione.
Classe pubblica | DedCommandContext | Classe base per il contesto di esecuzione comando. Contiene le informazioni necessarie per l'esecuzione di un comando.
Classe pubblica | DedCommandDocAnagrInfo | Classe descrivente un singolo documento e l'anagrafica nel quale contesto deve essere elaborato il comando. Utilizzato nei comandi che lavorano sul documento quando le informazioni dell'anagrafica sono già disponibili.
Classe pubblica | DedCommandDocAnagrInfoList | Classe che descrive una lista di DedCommandDocAnagrInfo
Classe pubblica | DedCommandList | Lista di oggetti DedCommand.
Classe pubblica | DedDataCommand | Comando di base per operare sulle anagrafiche.
Classe pubblica | DedDocumentCommand | Comando di base per operare sui documenti.
Classe pubblica | DedListEditCommand | Comando che inserisce l'anagrafica alla lista di stampa
Classe pubblica | DedListManagerCommand | Classe che rappresenta il comando per la gestione delle tipologie di lista.
Classe pubblica | DedStateCommand | Classe che definisce un oggetto per la modifica dello stato di un'anagrafica. Gestisce la modifica di stato contenendo tutte le informazioni sull'anagrafiche in modifica ed i relativi documenti collegati. Lancia i vari eventi di modifica di stato e di attributi ed ogni evento contiene le seguenti informazioni: - L'anagrafica in oggetto; - Lo stato di partenza; - Lo stato di destinazione; - I documenti coinvolti ovvero collegati all'anagrafica. Prima di effettuare i vari controlli sui documenti, il comando lancia un evento di aggiornamento attributi in modo che si possano personalizzare ed aggiornare nel documento eventualmente aperto (nel caso per esempio del rilascio).
Classe pubblica | DeleteCommAnagrCommand | Comando eliminazione di una commessa.
Classe pubblica | DeleteCommCommand | Comando eliminazione di una commessa.
Classe pubblica | DeleteDataCommand | Classe che rappresenta il comando per eliminare un'anagrafica dal database. Il comando controlla subito che l'utente abbia il permesso di eliminare un record, che l'anagrafica non sia rilasciata e non sia presente in nessuna distinta. Se l'anagrafica ha una distinta viene chiesto all'utente se desidera elimanarla ugualmente. Nel caso venga eliminata un'anagrafica vengono eliminati anche i documenti ad essa associati e nel caso abbia una distinta viene eliminata. Nel caso l'anagrafica sia in lavorazione viene co ntrollato se è presente una revisione superata, se c'è viene messa in lavorazione. Infine retrocede il progressivo se è l'ultimo e non sono presenti altre revisioni.
Classe pubblica | DeleteEcoCommand | Comando usato per cancellare un ECO dal database.
Classe pubblica | DeleteFolder | Elimina una cartella.
Classe pubblica | DisconnectCommDocument | Comando che permette di scollegare uno o più documenti da una commedsa. Non chiede alcuna selezione all'utente e devono essere specificati tutti i dati necessari all'esecuzione del comando. Se un documento è collegato ad un solo riferimento commessa/anagrafica e viene scollegato viene chiesto all'utente se lo si desidera eliminare, se UseUI è a true, altrimenti il comando non elimina il documento ma lo scollega soltando dalla commessa.
Classe pubblica | DisconnectDocument | Comando che permette di scollegare uno o più documenti da un'anagrafica. Non chiede alcuna selezione all'utente e devono essere specificati tutti i dati necessari all'esecuzione del comando. Se un documento è collegato ad una sola anagrafica e viene scollegato viene chiesto all'utente se lo si desidera eliminare, se UseUI è a true, altrimenti il comando non elimina il documento ma lo scollega soltando dall'anagrafica.
Classe pubblica | DistEsplCommand | Apre la finestra di Distinta Esplosa per un'anagrafica.
Classe pubblica | DistImplCommand | Apre la finestra di Distinta Implosa di un'anagrafica.
Classe pubblica | DocAssocCommand | Mostra la finestra di ricerca con la lista delle anagrafiche alle quali un documento è associato.
Classe pubblica | DocHistoryCommand | Classe che rappresenta il comando per visualizzare tutti i padri di un determinato documento ( ovvero dove viene usato in altri documenti ).
Classe pubblica | DocRecognizerCommand | Mostra la finestra per la registrazione di documenti che si trovano nelle root ma che non hanno ancora l'oggetto associato
Classe pubblica | DocStructAnnullaCheckOutOperation | Annulla l'operazione di check-out, ripristinando sia il file fisico che il record.
Classe pubblica | DocStructCheckInOperation | Mette in checkin un documento.
Classe pubblica | DocStructCheckInStrutturaOperation | Esegue il check-in sul documento e su tutte le sue dipendenze, se su queste è possibile effettuare l'operazione.
Classe pubblica | DocStructCheckOutOperation | Operazione di check-out del documento.
Classe pubblica | DocStructCheckOutStrutturaOperation | Effettua il check-out sul documento e su tutte le sue dipendenze, se su queste è possibile effettuare l'operazione.
Classe pubblica | DocStructCommDisconnectingOperation | Operazione di scollegamento documento da un'anagrafica.
Classe pubblica | DocStructCommImportingOperation | Operazione di collegamento documento già esistente ad una commessa.
Classe pubblica | DocStructCommLinkingOperation | Operazione di collegamento documento già esistente ad una commessa.
Classe pubblica | DocStructCommRecogniseOperation | Operazione di riconoscimento file con collegamento ad un'anagrafica.
Classe pubblica | DocStructCopyingOperation | Operazione di copia documento.
Classe pubblica | DocStructCreatingOperation | Operazione di creazione documento da file.
Classe pubblica | DocStructDisconnectingOperation | Operazione di scollegamento documento da un'anagrafica.
Classe pubblica | DocStructEcoImportingOperation | Operazione di collegamento documento già esistente ad un'Eco.
Classe pubblica | DocStructEcoLinkingOperation | Operazione di collegamento documento già esistente ad un Eco (l'Eco deve essere già registrato nel database).
Classe pubblica | DocStructEnsureLocalOperation | Operazione di copia in locale di un documento e di tutte le sue dipendenze, dal vault alla pws.
Classe pubblica | DocStructExportingOperation | Esporta un documento in un percorso esterno al database
Classe pubblica | DocStructExportingStrutturaOperation | Esegue l'esporta del documento e su tutte le sue dipendenze, se su queste è possibile effettuare l'operazione.
Classe pubblica | DocStructForzaCheckInOperation | Mette in checkin un documento forzatamente.
Classe pubblica | DocStructForzaCheckInStrutturaOperation | Esegue il forza check-in sul documento e su tutte le sue dipendenze, se su queste è possibile effettuare l'operazione.
Classe pubblica | DocStructImportingOperation | Operazione di collegamento documento già esistente ad un'anagrafica.
Classe pubblica | DocStructLinkingOperation | Operazione di collegamento documento già esistente ad un'anagrafica.
Classe pubblica | DocStructMovingOperation | Operazione di spostamento documento.
Classe pubblica | DocStructOperationBase | Classe base per le operazioni sui documenti. Utilizzata per specificare le informazioni di base su di un file: documento, anagrafica di contesto, versione, ecc. Da questa derivano tutte le operazioni semplici sui file che si occupano sia della modifica/creazione dei record per il documento che delle operazioni fisiche sui file.
Classe pubblica | DocStructOperationBaseList | Lista di oggetti DocStructOperationBase.
Classe pubblica | DocStructPubblicaOperation | Pubblica sul vault un documento che è in checkout nell'area locale.
Classe pubblica | DocStructPubblicaStrutturaOperation | Esegue il check-in sul documento e su tutte le sue dipendenze, se su queste è possibile effettuare l'operazione.
Classe pubblica | DocStructRecogniseOperation | Operazione di riconoscimento file con collegamento ad un'anagrafica.
Classe pubblica | DocStructRelocateOperation | Operazione di rilocazione di un file esterno su un documento interno. Permette di "puntare" semplicemente il documento interno ma anche di eseguire l'overwrite fisico come nel caso del replace.
Classe pubblica | DocStructRemovingOperation | Operazione di eliminazione documento.
Classe pubblica | DocStructReplaceOperation | Operazione di sostituzione documento con un nuovo file.
Classe pubblica | DocStructSbloccaOperation | Sblocca un documento in modo che sia modificabile dagli altri utenti. Non effettua operazioni sui file.
Classe pubblica | DocStructUpdatingOperation | Operazione di aggiornamento documento nel Database.
Classe pubblica | DocTransferHistoryCommand | Classe che rappresenta il comando per visualizzare la storia dei trasferimenti del documento
Classe pubblica | DuplicateCommCommand | Comando di duplicazione di una commessa. In base alla commessa di riferimento impostata, verrà creata una nuova commessa dello stesso livello e con gli stessi dati (fatta ad eccezione del NOME e della DATA).
Classe pubblica | EcoEditCommand | Comando usato per visualizzare gli ECO.
Classe pubblica | EcoHistoryCommand | Comando usato per visualizzare la storia di un ECO
Classe pubblica | EditAnagrCommand | Apre la finestra di Editazione delle anagrafiche.
Classe pubblica | EditAnagrCommandBase | Classe base per i comandi di visualizza/edita attributi.
Classe pubblica | EditCommCommand | Comando editazione di una commessa.
Classe pubblica | EditEcoCommand | Comando usato per creare/editare gli ECO.
Classe pubblica | EditOnlyDbAttributesCommand | Comando utilizzato per editare gli attributi di ricambio di un set di anagrafiche.
Classe pubblica | EndAllActiveTimingsCommand | Comando utilizzato per interrompere tutte le temporizzazioni attive associate all'utente corrente.
Classe pubblica | EndTimingCommand | Comando utilizzato per interrompere una temporizzazione su una anagrafica, commessa, ECO, ecc..
Classe pubblica | EnsureLocalDocument | Permette di assicurarsi che un documento e tutte le sue dipendenze siano disponibili nell'area locale. Quando un documento è già presente nell'area locale confronta la versione scaricata con quella attualmente presente sul server. Se la versione in locale non è da aggiornare non copia il file, altrimenti chiede conferma all'utente e copia sovrascrivendo.
Classe pubblica | EnsureLocalFolder | Permette di assicurarsi che un documento e tutte le sue dipendenze siano disponibili nell'area locale. Quando un documento è già presente nell'area locale confronta la versione scaricata con quella attualmente presente sul server. Se la versione in locale non è da aggiornare non copia il file, altrimenti chiede conferma all'utente e copia sovrascrivendo.
Classe pubblica | ExportCommand | Classe che rappresenta il comando per editare gli utenti e i permessi.
Classe pubblica | ExportDocument | Permette di esportare il documento copiandolo in una destinazione all'esterno dei path del database. Non registra nulla. E' utilizzato per fornire la documentazione a terzi. Fornisce la possibilità di porre in checkout i documenti all'atto dell'esportazione. Necessita di un percorso di destinazione valido.
Classe pubblica | FileZip | Esegue lo zip di un insieme di documenti, chiedendo all'utente vuole archiviarli.
Classe pubblica | FileZipStruct | Esegue lo zip di un insieme di documenti, chiedendo all'utente vuole archiviarli.
Classe pubblica | FillDedDataEncodeTableCommand | Compila la tabella DED_DATA_ENCODE con tutte le anagrafiche presenti nel DB.
Classe pubblica | FindCodeCommand | Comando che permette l'apertura della finestra di ricerca codice con in primo piano un comando specifico.
Classe pubblica | FindCommand | Classe che rappresenta il comando per ricercare dentro al DataBase. Lancia il form della ricerca in modalità non modale.
Classe pubblica | FindDataDocCommand | Classe che rappresenta il comando per ricercare i documenti all'interno del Database.
Classe pubblica | FindDocCommand | Classe che rappresenta il comando per ricercare i documenti all'interno del Database.
Classe pubblica | FindInRicercaCommand | Comando che permette di aprire la ricerca con selezionata l'anagrafica associata al documento selezionato.
Classe pubblica | ForceMarkerAlingmentCommand | Comando per forzare l'allinemento del documento nel caso si DFS attivo.
Classe pubblica | ForzaCheckInDocument | Effettua il checkin forzato dei documenti. I documenti presenti nell'area locale non vengono rimossi (verranno mantenuti quelli presenti sul server). Se si imposta l'opzione Struttura viene effettuato il checkin dei documenti di testata più tutte le dipendenze che risultano in checkout.
Classe pubblica | GridInfoDataList | Lista bindabile alla griglia per la gestione dei documenti primari ed allegati in fase di creazione di una nuova revisione.
Classe pubblica | GridInfoDataRow | Singolo elemento bindabile alla griglia specificante una riga. Attraverso questo elemento si memorizza quale documento si desidera portare nella nuova revisione.
Classe pubblica | ImportCommDocument | Associa uno o più documenti ad una commessa.
Classe pubblica | ImportDocument | Associa uno o più documenti ad un'anagrafica. Se i documenti da associare non sono presenti ne viene chiesta la selezione all'utente. Se l'anagrafica alla quale associare il documento non è presente viene chiesta all'utente attraverso la finestra di dialogo ricerca (modale). Se il contesto specificato è Primario ed il file da riconoscere ha una estensione già presente nei primari allora, se questa estensione rientra nella lista delle estensioni disponibili alle nuove rappresentazioni, diventa una nuova rappresentazione altrimenti viene sollevato un errore. Questo comando copia il documento nella posizione di destinazione calcolata in base all'anagrafica. Se il file non è presente nel Database e viene associato come allegato, cerca di copiarlo mantenendo lo stesso nome. Se viene invece associato come primario o pubblicazione calcola il nome corretto di destinazione in base all'anagrafica ed alla sua famiglia di appartenenza. Se esiste già un documento con stesso nome di destinazione, se si tratta di una estensione per la quale si può creare una nuova rappresentazione allora procedere creando una nuova rappresentazione ed aggiunge ^xxxx al nome file. Diversamente interrompe l'esecuzione. Se è attiva l'area locale il file viene copiato nell'area locale e poi riconosciuto come documento associato all'anagrafica. Non viene contestualmente pubblicato nel vault ma rimane in checkout dall'utente corrente. Per ogni documento vengono chieste le dipendenze e, se presenti, anche queste sono inserite nel Database (a meno ché non vi fossero già) ed impostate in checkout (se pws attiva) ed aggiunte come dipendenze del nuovo documento creato. L'elaborazione è racchiusa in una transazione quindi se non ha successo la creazione del documento o di una sua dipendenza oppure l'associazione all'anagrafica, tutte le operazioni vengono annullate. Questo anche se l'errore è avvenuto su di un solo file tra quelli elaborati.
Classe pubblica | ImportEcoFiles | Associa uno o più documenti ad un ECO.
Classe pubblica | ImporterCommand
Classe pubblica | ImportTransferPacket | Comando ricezione richieste di traferimento
Classe pubblica | LiberateCommCommand | Comando per liberare una commessa dopo che è stata presa in carico
Classe pubblica | LinkCommDocument | Comando che permette di collegare uno o più documenti preesistenti ad una commessa.
Classe pubblica | LinkDocument | Comando che permette di collegare uno o più documenti preesistenti ad un'anagrafica anch'essa preesistente. Se i documenti da associare non sono presenti ne viene chiesta la selezione all'utente attraverso la finestra di dialogo ricerca (modale). Se l'anagrafica alla quale associare il documento non è presente viene chiesta all'utente attraverso la finestra di dialogo ricerca (modale). Se il contesto specificato è Primario ed il file da riconoscere ha una estensione già presente nei primari allora, se questa estensione rientra nella lista delle estensioni disponibili alle nuove rappresentazioni, diventa una nuova rappresentazione altrimenti viene sollevato un errore.
Classe pubblica | LoginCommand | Classe che rappresenta il comando per effettuare il login con un utente specifico.
Classe pubblica | LogViewCommand | Apre il dialogo di visualizzazione dei log presenti nella tabella DED_LOG.
Classe pubblica | ManageOperationsCommand | Classe che rappresenta il comando per eseguire il gestore delle operazioni del DED.
Classe pubblica | MarkerInfoCommand | Comando per visualizzare lo stato di allinemento del documento nel caso si DFS attivo.
Classe pubblica | MessageLocalIsOlderNotifier | Classe di servizio per unificare i messaggi di richiesta sovrascrittura file nel caso in cui sul server ci sia un file più recente rispetto a quello già presente nell'area locale.
Classe pubblica | MoveAnagrCommand | Classe che rappresenta il comando per spostare un'anagrafica in un'altra famiglia.
Classe pubblica | MovedEditorCommand | Comando utilizzato per visualizzare e gestire i .moved dei vari documenti.
Classe pubblica | MoveDocument | Permette di rinominare o spostare una lista di documenti già registrati nel Database. Sposta il file sul server e nell'area locale (se attiva e se il documento è in check-out dall'utente corrente) chiamando un evento che permette al client di sostituirsi allo spostamento del file. Aggiorna poi i riferimenti presenti nei file di Inventor, per quanto riguarda i documenti coinvolti nello spostamento, e, opzionalmente, per tutti i padri che contengono i file che si stanno spostando/rinominando, in modo che rispecchino la situazione reale. In base ad una opzione è anche possibile premettere lo spostamento dei file primari, che di default non è consentita.
Classe pubblica | MoveDocumentMoveDocumentItem | Descrive un singolo documento da spostare.
Classe pubblica | MoveDocumentMoveDocumentList | Lista di oggetti MoveDocumentItem.
Classe pubblica | NotifyCommand | Classe che rappresenta il comando per visualizzare i backup.
Classe pubblica | OpenAssocFilesCommand | Classe che rappresenta il comando per aprire uno o più file associati ad una anagrafica escludo un particolare documento.
Classe pubblica | OpenCommCommand | Comando apertura di una commessa.
Classe pubblica | OpenFilePathCommand | Classe che rappresenta il comando per cambiare la password dell'utente.
Classe pubblica | OpenReadDocument | Apre un documento in lettura.
Classe pubblica | OpenWriteDocument | Apre un documento in scrittura.
Classe pubblica | PrintDocumentCommand
Classe pubblica | PropertiesManagerCommand | Classe che rappresenta il comando per editare le variabili delle DedDocProperties.
Classe pubblica | PublicationFilesMangerCommand | Classe che rappresenta il comando per editare gli stati.
Classe pubblica | PublishDocument | Effettua la pubblicazione di una lista di documenti che precedentemente sono stati messi in checkout.
Classe pubblica | PwsBackupCommand | Classe che rappresenta il comando per visualizzare i backup.
Classe pubblica | PwsCacheCommand | Classe che rappresenta il comando per visualizzare lo stato dell'area locale..
Classe pubblica | QsManagerCommand | Classe che rappresenta il comando per editare le famiglie e gli attributi.
Classe pubblica | QsManagerCommCommand | Classe che rappresenta il comando per editare le famiglie e gli attributi.
Classe pubblica | QsReserveProgCommand | Classe che rappresenta il comando per riservare i progressivi ai vari utenti.
Classe pubblica | RecognaiseCommDocument | Riconosce uno o più documenti da associare ad una commessa. Se i documenti da associare non sono presenti ne viene chiesta la selezione all'utente. Questo comando non copia e non rinomina il documento da associare, verifica i permessi dell'utente e che il percorso sia nelle root di vault o di pws (nel caso sia attiva l'area locale). Se attiva l'area locale il documento riconosciuto non viene contestualmente pubblicato nel vault ma rimane in checkout dall'utente corrente. Per ogni documento vengono registrate le dipendenze, se presenti, ed anche queste sono inserite nel Database (a meno ché non vi fossero già) ed impostate in checkout (se pws attiva) ed aggiunte come dipendenze del nuovo documento creato. L'elaborazione è racchiusa in una transazione quindi se non ha successo la creazione del documento o di una sua dipendenza oppure l'associazione alla commessa, tutte le operazioni vengono annullate. Questo anche se l'errore è avvenuto su di un solo file tra quelli elaborati.
Classe pubblica | RecognaiseDocument | Riconosce uno o più documenti da associare ad un'anagrafica. Il comando lavora sia sui file primari che sugli allegati ma nell'interfaccia utente è disponibile solo negli allegati. Se i documenti da associare non sono presenti ne viene chiesta la selezione all'utente. Se l'anagrafica alla quale associare il documento non è presente viene chiesta all'utente attraverso la finestra di dialogo ricerca (modale). Questo comando non copia e non rinomina il documento da associare, verifica i permessi dell'utente e che il percorso sia nelle root di vault o di pws (nel caso sia attiva l'area locale). Se attiva l'area locale il documento riconosciuto non viene contestualmente pubblicato nel vault ma rimane in checkout dall'utente corrente. Per ogni documento vengono registrate le dipendenze, se presenti, ed anche queste sono inserite nel Database (a meno ché non vi fossero già) ed impostate in checkout (se pws attiva) ed aggiunte come dipendenze del nuovo documento creato. L'elaborazione è racchiusa in una transazione quindi se non ha successo la creazione del documento o di una sua dipendenza oppure l'associazione all'anagrafica, tutte le operazioni vengono annullate. Questo anche se l'errore è avvenuto su di un solo file tra quelli elaborati.
Classe pubblica | RemoveDocument | Elimina una lista di documenti. Se il documento è collegato a qualche anagrafica viene scollegato prima da tutte (dopo richiesta di conferma dell'utente). Se il documento è legato come dipendenza diretta e vitale a qualche altro documento (non in elaborazione dal comando) allora viene richiesta conferma all'utente.
Classe pubblica | RemoveEcoDocument | Rimuove uno o più documenti da un ECO.
Classe pubblica | RemoveRecurrentTimingCommand | Comando utilizzato per rimuovere anagrafiche, commesse, ECO dall'elenco delle temporizzazioni ricorrenti.
Classe pubblica | RenameDocument | Rinomina un documento
Classe pubblica | RenameFolder | Elimina una cartella.
Classe pubblica | ReplaceAnagrBom | Classe che rappresenta il comando per visualizzare la storia di un'anagrafica.
Classe pubblica | ReplaceDocument | Sostituisce il file di un documento già esistente con un nuovo file. Per attuare l'operazione, con attiva l'area locale, si deve avere in check-out il documento. Se il file con il quale sostituire il documento non è presente ne viene chiesta la selezione all'utente. Vengono aggiornate le dipendenze del documento in base alle dipendenze presenti nella struttura documento. L'elaborazione è racchiusa in una transazione quindi se non ha successo un qualsiasi operazione tutto viene annullato.
Classe pubblica | ReplaceDocumentReference | Comando esposto ai CAD che chiama il comando di aggiorna riferimenti. Inzializza il comando e lo lancia senza un documento di sostituzione, in modo che debba essere l'utente a selezionarlo manualmente.
Classe pubblica | RevCommand | Crea una nuova revisione partendo da un'anagrafica già esistente. È possibile partire con la revisione da un'anagrafica che non sia l'ultima. Fa scegliere all'utente come comportarsi con gli allegati: se collegarli o clonarli dalla revisione di partenza o dall'ultima, se diversa da quella di partenza. Impostare la proprietà Info.Data con l'anagrafica di partenza (letta dal Database e clonata tramite il metodo MakeClonePart()) oppure, se si desidera creare la revisione partendo da un'anagrafica già modificata, (come nel caso di un documento CAD) impostare i vari campi della proprietà Info secondo le esigenze. Impostare in Info.Data gli attributi precompilati desiderati. Ogni proprietà impostata dell'oggetto Info, come il progressivo, la revisione o il tassello utente, ha la priorità su quanto presente nell'anagrafica Info.Data. Questo comando non ricalcola il DedId ma lo tiene buono così com'é. Tutto il resto come il nome file, il DED_DIS ecc. sono ricalcolati come nel comando di creazione anagrafica. I file primari sono trattati in modo differente in base al fatto che si tratti o meno di anagrafica con tassello revisione nel nome file. La scelata viene comunque fatta dall'utente, anche se c'é un default: - Se il file ha la revisione, nessun file priamario viene portato dietro, la nuova anagrafica risulta senza documenti primari. - Se il file NON ha la revisione: 1) Caso di file presente nella revisione di partenza ma non nell'ultima revisione: - Il documento viene importato nella nuova revisione. 2) Caso di file presente nell'ultima revisione ma non nella revisione di partenza. - Il documento rimane nell'ultima revisione. 3) Caso di file presente in entrambe: - Di default viene tenuto il documento proveniente dalla revisione di partenza. Utilizzare la proprietà UseUI per visualizzare o meno all'utente la finestra di salvataggio per la convalida dei dati e la finestra di selezione file di revisione. Aggiungere nella lista ClientInterstingDocs i documenti dei quali si vuole occupare il client.
Classe pubblica | RootManagerCommand | Classe che rappresenta il comando per editare le root.
Classe pubblica | SaveCommand | Crea una nuova anagrafica partendo dal nulla o da un'anagrafica già esistente. Non si porta dietro alcun documento dell'anagrafica di partenza. Se si vuole attuare un Duplica anagrafica facendo creare un nuovo progressivo e salvando nella stessa famiglia dell'anagrafica di partenza, impostare la proprietà Info.Data con l'anagrafica di partenza (clonata tramite il metodo MakeClonePart()). Se invece si desidera creare una nuova anagrafica utilizzando dati personalizzati, impostare i vari campi della proprietà Info secondo le esigenze. Impostare in Info.Data gli attributi precompilati desiderati. Ogni proprietà impostata dell'oggetto Info, come il progressivo, la revisione o il tassello utente, ha la priorità su quanto presente nell'anagrafica Info.Data. Utilizzare la proprietà UseUI per visualizzare o meno all'utente la finestra di salvataggio per la convalida dei dati.
Classe pubblica | SaveDistCommand | Comando che implementa il salvataggio della distinta nel Database. Riceve come parametro una struttura di archiviazione. Opzionalmente è possibile visualizzare in anteprima la distinta in salvataggio. TODO : Ancora la finestra di anteprima non è disponibile... Le anagrafiche che non sono nel Database vengono create nella famiglia di default oppure in una particolare famiglia. O il salvataggio funziona completamente altrimenti viene effettuato il rollback di tutto. Se l'elemento di testa in salvataggio è solo e non ha figli la distinta viene svuotata (chiedendo conferma all'utente se UseUI = true), questo però vale solo per l'elemento di testa.
Classe pubblica | SaveDistCommandSavingDistElement | Oggetto descrittivo del singolo elemento in salvataggio. Contiene il riferimento agli oggetti figli. E' del tutto simile all'oggetto BomItem solo lascia più libertà d'azione per elaborare l'albero di distinta. Se l'elemento in salvataggio è solo e non ha figli la distinta viene svuotata (chiedendo conferma all'utente), questo però vale solo per l'elemento di testa.
Classe pubblica | SaveDistCommandSavingDistElementCollection | Collezione elementi di distinta in salvataggio
Classe pubblica | SaveDistVariantCommand | Comando che implementa la creazione della distinta di produzione. La funzionalità è nativamente multilivello. Il nuovo discriminante di distinta viene applicato a tutta la struttura
Classe pubblica | SaveSparePartsDistVariantCommand | Comando che crea la distinta MONOLIVELLO e MULTILIVELLO dei ricambio.
Classe pubblica | SbloccaDocument | Permette di sbloccare una lista di documenti senza effettuarne la pubblicazione sul server. Vengono mantenuti gli effetti delle precedenti eventuali pubblicazioni ma viene eliminato il backup effettuato durante il check-out.
Classe pubblica | SendTransferPacket | Comando aggiunta richieste di traferimento
Classe pubblica | SendZipViaEmail | Esegue lo zip di un insieme do documenti, crea una mail con lo zip come allegato e poi cancella lo zip una volta inviata la mail.
Classe pubblica | ShowAllActiveTimingsCommand | Comando utilizzato per visualizzare tutte le temporizzazioni attive associate all'utente corrente.
Classe pubblica | ShowAnagrCommand | Apre la finestra di Visualizzazione delle anagrafiche.
Classe pubblica | ShowRecurrentTimingCommand | Comando utilizzato per visualizzare le temporizzazioni ricorrenti.
Classe pubblica | ShowSparePartsDistVariantCommand | Comando utilizzato per visualizzare la distinta MULTILIVELLO del codice specificato.
Classe pubblica | ShowTimingCommand | Comando utilizzato per visualizzare tutte le temporizzazioni di una determinata anagrafica, commessa, ECO, ecc..
Classe pubblica | StartTimingCommand | Comando utilizzato per avviare una temporizzazione su una anagrafica, commessa, ECO, ecc..
Classe pubblica | StateManagerCommand | Classe che rappresenta il comando per editare gli stati.
Classe pubblica | TimingCommand | Comando utilizzato per avviare/interrompere una temporizzazione su una anagrafica, commessa, ECO, ecc..
Classe pubblica | TranslationsMangerCommand
Classe pubblica | UpdateDocument | Si occupa di aggiornare i dati di uno o più documenti nel Database e di riconoscere i documenti dipendenti a cascata. Aggiorna la versione del documento nel Database per segnalare che il file fisico è stato modificato. I client, se l'area locale non è attiva, devono chiamare questo comando subito dopo il salvataggio. Con l'area locale attiva invece non devono fare niente perché verrà invocato dal comando di pubblicazione. Anche se non ci sono dati particolari da aggiornare nel Database (come il formato, la scala ed il foglio) visto che il file fisico è stato modificato, è bene aggiornare anche la versione del documento che dovrebbe essere suggerita dal client al comando (a questo comando oppure al comando di pubblicazione) utilizzando il guid presente nella struttura DocStructInfo (es.: Inventor ed Autocad).
Classe pubblica | UpdateDocumentReference | Si occupa di eseguire la sostituzione fisica dei riferimenti di un file all'interno dei suoi padri con un documento di sostituzione. Il comando effettua prima di tutto un'analisi della lista di padri passata e, sulla base del documento di partenza e quello di sostituzione, mostra all'utente su quali padri la sostituzione è possibile e su quali no. L'utente può poi scegliere tramite una spunta su quali padri effettuare la sostituzione effettiva (tra quelli su cui è possibile). In seguito, viene lanciato un Elaboration Report che si occupa di effettuare le sostituzioni effettive. Esse dipendono da un delegate (ExecuteReferenceUpdateDelegate) a cui CAD e Plugin si attachano in modo che ognuno esegua la sostituzione sulla base delle proprie logiche. Per salvare le modifiche, ogni documento padre viene prima posto in check-out e poi, dopo l'avvenuta sostituzione, riposto in check-in, a meno che il file non fosse in check-out già prima che venisse lanciato il comando.
Classe pubblica | UpdateDocumentReferenceOverrideGridInfoArgument | Classe che descrive le informazioni neecssarie per il delegate ElaborationOverrideGridInfo.
Classe pubblica | UpdateDocumentReferenceReferenceAnalysisArgument | Classe che descrive le informazioni per l'analisi di una sostituzione riferimenti.
Classe pubblica | UpdateDocumentReferenceReferenceUpdateDescriptor | Classe usata per descrivere l'operazione di aggiornamento dei riferimenti.
Classe pubblica | UpdateOldRevCommand | Classe che rappresenta il comando per aggiornare le vecchie revisioni.
Classe pubblica | UpdateSparePartsBoms | Comando utilizzato per aggiornare le distinte ricambio con i nuovi valori di anagrafica.
Classe pubblica | UsersCommand | Classe che rappresenta il comando per editare gli utenti e i permessi.
Classe pubblica | VarsCommand | Classe che rappresenta il comando per editare le variabili.
Classe pubblica | ViewCommCommand | Comando visuliazziazione di una commessa.
Classe pubblica | VisualDepCommand | Comando che visualizza in un diagramma le dipendenza tra i documenti
Classe pubblica | WhereUsedCommand | Classe che rappresenta il comando per visualizzare tutti i padri di un determinato documento ( ovvero dove viene usato in altri documenti ).
Strutture
 | Struttura | Descrizione
Struttura pubblica | DedStateCommandCadInfo | Struttura con informazioni aggiunti ve inserite dai CAD.
Interfacce
 | Interfaccia | Descrizione
Interfaccia pubblica | IMoveCopyDocumentItem | Interfaccia comune agli oggetti contenenti informazioni sullo spostamento/copia dei file.
Delegate
 | Delegate | Descrizione
Delegate pubblico | DedCommandContextUpdateDialogAnag | Delegate contenente la funzione di aggiornamento del dialogo delle angrafiche.
Delegate pubblico | DedCommandContextUpdateDialogComm | Delegate contenente la funzione di aggiornamento del dialogo delle commesse.
Delegate pubblico | FileOperationDelegateT | Delegate utilizzato per elaborare i file fisici dal client. Il client dovrà restituire Success se riesce nell'operazione sui file di suo interesse, altrimenti restituirà un altro valore che sarà poi restituito dal comando stesso.
Delegate pubblico | ParamRestT, A | Delegate utilizzato per passare un parametro e averne restituito un altro che può essere differente.
Delegate pubblico | UpdateDocumentReferenceElaborationOverrideGridInfo |
Delegate pubblico | UpdateDocumentReferenceExecuteReferenceUpdateDelegate |
Delegate pubblico | UpdateDocumentReferenceReferenceAnalysisDelegate |
Enumerazioni
 | Enumerazione | Descrizione
Enumerazione pubblica | AddCommCommandDedCreateCommCommandBehaviourEnum | Enumerazioni dei possibili comportamenti del comando
Enumerazione pubblica | AttachBehaviourEnum | Enumerazione dei possibili comportamenti per gli allegati.
Enumerazione pubblica | BomEditCommandDedBomEditCommandBehaviourEnum | Enumerazioni dei possibili comportamenti del controllo
Enumerazione pubblica | CommandContextEnum | Enumerazione delle posizioni dalle quali è stato lanciato o è possibile lanciare un comando.
Enumerazione pubblica | DedCmdResult | Enumerazione dei risultati di un comando.
Enumerazione pubblica | DocStructOperationEnum | Enumerazione delle operazioni riguardanti un file/documento da svolgersi nell'ambito di un comando.
Enumerazione pubblica | OperationKindEnum |
Enumerazione pubblica | SaveDistCommandRestrictSaveDistStates | Possibili stati di restrizione salvataggio in base allo stato anagrafico


Classe AddCommCommand
Comando creazione di una commessa.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsAddCommCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class AddCommCommand : DedCommand
Public Class AddCommCommand
    Inherits DedCommand
public ref class AddCommCommand : public DedCommand
type AddCommCommand =
    class
        inherit DedCommand
    end

Il tipo AddCommCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddedComm | Restituisce la Commessa risultante dall'operazione. Disponibile solo alla fine del comando.
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | ApplyRule | Permette di decidere se applicare o meno le regole di autocomposizione (quando lanciato da script).
Proprietà pubblica | Behaviour | Restituisce o imposta il comportamento del comando nella creazione della commessa.
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommData | Restituisce il dizionario da utilizzare per inizializzare i dati per creare la nuova commessa.
Proprietà pubblica | CommKind | Identifica il tipo specifico collegato alla commessa
Proprietà pubblica | CommName | Restituisce o imposta il nome della commessa nel dizionario interno (quello ottenibile dalla proprietà CommData).
Proprietà pubblica | ForcedData | Indica se i dati sono stati forzati e quindi non vanno ricalcolati ( NOME )
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Info | Restituisce le informazioni di codifica correntemente utilizzate dal comando.
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | Master | Eventuale commessa Master dalla quale copiare la struttura.
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se si vuole creare una sotto commessa ma non si passa il riferimento. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | ReferenceComm | Imposta o restituisce la commessa di riferimento da utilizzare per la creazione della nuova commessa. Viene usata come riferimento per l'identificazione del padre o del livello di creazione della nuova commessa. Deve essere impostata se Behaviour = CreateSubComm.
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Metodo pubblico | UpdateData | Ricalcola i campi presenti nell'anagrafica temporanea in base ai valori presenti nelle info. Chiama l'evento di personalizzazione e poi li ricalcola in modo che se l'evento ha modificato le info si riflettano i valori nell'anagrafica.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di AddCommCommand

Il tipo AddCommCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddedComm | Restituisce la Commessa risultante dall'operazione. Disponibile solo alla fine del comando.
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | ApplyRule | Permette di decidere se applicare o meno le regole di autocomposizione (quando lanciato da script).
Proprietà pubblica | Behaviour | Restituisce o imposta il comportamento del comando nella creazione della commessa.
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommData | Restituisce il dizionario da utilizzare per inizializzare i dati per creare la nuova commessa.
Proprietà pubblica | CommKind | Identifica il tipo specifico collegato alla commessa
Proprietà pubblica | CommName | Restituisce o imposta il nome della commessa nel dizionario interno (quello ottenibile dalla proprietà CommData).
Proprietà pubblica | ForcedData | Indica se i dati sono stati forzati e quindi non vanno ricalcolati ( NOME )
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Info | Restituisce le informazioni di codifica correntemente utilizzate dal comando.
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | Master | Eventuale commessa Master dalla quale copiare la struttura.
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se si vuole creare una sotto commessa ma non si passa il riferimento. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | ReferenceComm | Imposta o restituisce la commessa di riferimento da utilizzare per la creazione della nuova commessa. Viene usata come riferimento per l'identificazione del padre o del livello di creazione della nuova commessa. Deve essere impostata se Behaviour = CreateSubComm.
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe AddCommCommand
Namespace DedNet.Commands


Proprietà AddCommCommand.AddedComm

Proprietà AddCommCommandAddedComm
Restituisce la Commessa risultante dall'operazione. Disponibile solo alla fine del comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedComm AddedComm { get; }
Public ReadOnly Property AddedComm As DedComm
    Get
public:
property DedComm^ AddedComm {
    DedComm^ get ();
}
member AddedComm : DedComm with get

Valore della proprietà

DedComm
Vedi anche

Documentazione

Classe AddCommCommand
Namespace DedNet.Commands


Proprietà AddCommCommand.ApplyRule

Proprietà AddCommCommandApplyRule
Permette di decidere se applicare o meno le regole di autocomposizione (quando lanciato da script).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ApplyRule { set; }
Public WriteOnly Property ApplyRule As Boolean
    Set
public:
property bool ApplyRule {
    void set (bool value);
}
member ApplyRule : bool with set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe AddCommCommand
Namespace DedNet.Commands


Proprietà AddCommCommand.Behaviour

Proprietà AddCommCommandBehaviour
Restituisce o imposta il comportamento del comando nella creazione della commessa.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public AddCommCommandDedCreateCommCommandBehaviourEnum Behaviour { get; set; }
Public Property Behaviour As AddCommCommandDedCreateCommCommandBehaviourEnum
    Get
    Set
public:
property AddCommCommandDedCreateCommCommandBehaviourEnum Behaviour {
    AddCommCommandDedCreateCommCommandBehaviourEnum get ();
    void set (AddCommCommandDedCreateCommCommandBehaviourEnum value);
}
member Behaviour : AddCommCommandDedCreateCommCommandBehaviourEnum with get, set

Valore della proprietà

AddCommCommandDedCreateCommCommandBehaviourEnum
Vedi anche

Documentazione

Classe AddCommCommand
Namespace DedNet.Commands


Proprietà AddCommCommand.CommData

Proprietà AddCommCommandCommData
Restituisce il dizionario da utilizzare per inizializzare i dati per creare la nuova commessa.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDictionary CommData { get; }
Public ReadOnly Property CommData As DedDictionary
    Get
public:
property DedDictionary^ CommData {
    DedDictionary^ get ();
}
member CommData : DedDictionary with get

Valore della proprietà

DedDictionary
Vedi anche

Documentazione

Classe AddCommCommand
Namespace DedNet.Commands


Proprietà AddCommCommand.CommKind

Proprietà AddCommCommandCommKind
Identifica il tipo specifico collegato alla commessa

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommCommKindEnum CommKind { get; set; }
Public Property CommKind As DedCommCommKindEnum
    Get
    Set
public:
property DedCommCommKindEnum CommKind {
    DedCommCommKindEnum get ();
    void set (DedCommCommKindEnum value);
}
member CommKind : DedCommCommKindEnum with get, set

Valore della proprietà

DedCommCommKindEnum
Vedi anche

Documentazione

Classe AddCommCommand
Namespace DedNet.Commands


Proprietà AddCommCommand.CommName

Proprietà AddCommCommandCommName
Restituisce o imposta il nome della commessa nel dizionario interno (quello ottenibile dalla proprietà CommData).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string CommName { get; set; }
Public Property CommName As String
    Get
    Set
public:
property String^ CommName {
    String^ get ();
    void set (String^ value);
}
member CommName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe AddCommCommand
Namespace DedNet.Commands


Proprietà AddCommCommand.ForcedData

Proprietà AddCommCommandForcedData
Indica se i dati sono stati forzati e quindi non vanno ricalcolati ( NOME )

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ForcedData { get; set; }
Public Property ForcedData As Boolean
    Get
    Set
public:
property bool ForcedData {
    bool get ();
    void set (bool value);
}
member ForcedData : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe AddCommCommand
Namespace DedNet.Commands


Proprietà AddCommCommand.Info

Proprietà AddCommCommandInfo
Restituisce le informazioni di codifica correntemente utilizzate dal comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEncodeInfo Info { get; }
Public ReadOnly Property Info As DedEncodeInfo
    Get
public:
property DedEncodeInfo^ Info {
    DedEncodeInfo^ get ();
}
member Info : DedEncodeInfo with get

Valore della proprietà

DedEncodeInfo
Vedi anche

Documentazione

Classe AddCommCommand
Namespace DedNet.Commands


Proprietà AddCommCommand.Master

Proprietà AddCommCommandMaster
Eventuale commessa Master dalla quale copiare la struttura.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedComm Master { get; set; }
Public Property Master As DedComm
    Get
    Set
public:
property DedComm^ Master {
    DedComm^ get ();
    void set (DedComm^ value);
}
member Master : DedComm with get, set

Valore della proprietà

DedComm
Vedi anche

Documentazione

Classe AddCommCommand
Namespace DedNet.Commands


Proprietà AddCommCommand.NeedParameters

Proprietà AddCommCommandNeedParameters
Restituisce true se si vuole creare una sotto commessa ma non si passa il riferimento.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe AddCommCommand
Namespace DedNet.Commands


Proprietà AddCommCommand.ReferenceComm

Proprietà AddCommCommandReferenceComm
Imposta o restituisce la commessa di riferimento da utilizzare per la creazione della nuova commessa. Viene usata come riferimento per l'identificazione del padre o del livello di creazione della nuova commessa. Deve essere impostata se Behaviour = CreateSubComm.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedComm ReferenceComm { get; set; }
Public Property ReferenceComm As DedComm
    Get
    Set
public:
property DedComm^ ReferenceComm {
    DedComm^ get ();
    void set (DedComm^ value);
}
member ReferenceComm : DedComm with get, set

Valore della proprietà

DedComm
Vedi anche

Documentazione

Classe AddCommCommand
Namespace DedNet.Commands


Metodi di AddCommCommand

Il tipo AddCommCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Metodo pubblico | UpdateData | Ricalcola i campi presenti nell'anagrafica temporanea in base ai valori presenti nelle info. Chiama l'evento di personalizzazione e poi li ricalcola in modo che se l'evento ha modificato le info si riflettano i valori nell'anagrafica.
Torna su
Vedi anche

Documentazione

Classe AddCommCommand
Namespace DedNet.Commands


Metodo AddCommCommand.ClearCommand

Metodo AddCommCommandClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe AddCommCommand
Namespace DedNet.Commands


Metodo AddCommCommand.Enabled

Metodo AddCommCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe AddCommCommand
Namespace DedNet.Commands


Metodo AddCommCommand.ExecuteCommand

Metodo AddCommCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe AddCommCommand
Namespace DedNet.Commands


Metodo AddCommCommand.SetContext

Metodo AddCommCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto c'è una sola anagrafica alla quale associare il file.
Vedi anche

Documentazione

Classe AddCommCommand
Namespace DedNet.Commands


Metodo AddCommCommand.UpdateData

Metodo AddCommCommandUpdateData
Ricalcola i campi presenti nell'anagrafica temporanea in base ai valori presenti nelle info. Chiama l'evento di personalizzazione e poi li ricalcola in modo che se l'evento ha modificato le info si riflettano i valori nell'anagrafica.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void UpdateData()
Public Sub UpdateData
public:
void UpdateData()
member UpdateData : unit -> unit
Vedi anche

Documentazione

Classe AddCommCommand
Namespace DedNet.Commands


Enumerazione AddCommCommand.DedCreateCommCommandBehaviourEnum

Enumerazione AddCommCommandDedCreateCommCommandBehaviourEnum
Enumerazioni dei possibili comportamenti del comando

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum DedCreateCommCommandBehaviourEnum
Public Enumeration DedCreateCommCommandBehaviourEnum
public enum class DedCreateCommCommandBehaviourEnum
type DedCreateCommCommandBehaviourEnum
Membri
Nome | Valore | Descrizione
Standard | 0 | Creazione commessa sorella
CreateSubComm | 1 | Creazione commessa figlia
Vedi anche

Documentazione

Namespace DedNet.Commands


Classe AddEcoCommand
Comando usato per creare/editare gli ECO.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsAddEcoCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class AddEcoCommand : DedCommand
Public Class AddEcoCommand
    Inherits DedCommand
public ref class AddEcoCommand : public DedCommand
type AddEcoCommand =
    class
        inherit DedCommand
    end

Il tipo AddEcoCommand espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | AddEcoCommand | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Eco | Restituisce l'ECO appena creato.
Proprietà pubblica | EcoData | Dizionario contentenente i valori da usare come default per gli attributi.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve essere impostata la struttura di salvataggio distinta. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Eseguo il comando. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Imposto il contesto per l'esecuzione del comando (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Costruttore AddEcoCommand
Costruttore unico.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public AddEcoCommand(
    DedNetApplication app,
    string internalName,
    string name
)
Public Sub New (
    app As DedNetApplication,
    internalName As String,
    name As String
)
public:
AddEcoCommand(
    DedNetApplication^ app,
    String^ internalName,
    String^ name
)
new :
        app : DedNetApplication *
        internalName : string *
        name : string -> AddEcoCommand

Parametri

app DedNetApplication
Riferimento all'oggetto DedNetApplication.
internalName String
Nome interno del comando.
name String
Nome visualizzato del comando.
Vedi anche

Documentazione

Classe AddEcoCommand
Namespace DedNet.Commands


Proprietà di AddEcoCommand

Il tipo AddEcoCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Eco | Restituisce l'ECO appena creato.
Proprietà pubblica | EcoData | Dizionario contentenente i valori da usare come default per gli attributi.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve essere impostata la struttura di salvataggio distinta. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe AddEcoCommand
Namespace DedNet.Commands


Proprietà AddEcoCommand.Eco

Proprietà AddEcoCommandEco
Restituisce l'ECO appena creato.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEco Eco { get; }
Public ReadOnly Property Eco As DedEco
    Get
public:
property DedEco^ Eco {
    DedEco^ get ();
}
member Eco : DedEco with get

Valore della proprietà

DedEco
Vedi anche

Documentazione

Classe AddEcoCommand
Namespace DedNet.Commands


Proprietà AddEcoCommand.EcoData

Proprietà AddEcoCommandEcoData
Dizionario contentenente i valori da usare come default per gli attributi.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDictionary EcoData { get; }
Public ReadOnly Property EcoData As DedDictionary
    Get
public:
property DedDictionary^ EcoData {
    DedDictionary^ get ();
}
member EcoData : DedDictionary with get

Valore della proprietà

DedDictionary
Vedi anche

Documentazione

Classe AddEcoCommand
Namespace DedNet.Commands


Proprietà AddEcoCommand.NeedParameters

Proprietà AddEcoCommandNeedParameters
Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve essere impostata la struttura di salvataggio distinta.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe AddEcoCommand
Namespace DedNet.Commands


Metodi di AddEcoCommand

Il tipo AddEcoCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Eseguo il comando. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Imposto il contesto per l'esecuzione del comando (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe AddEcoCommand
Namespace DedNet.Commands


Metodo AddEcoCommand.ClearCommand

Metodo AddEcoCommandClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe AddEcoCommand
Namespace DedNet.Commands


Metodo AddEcoCommand.Enabled

Metodo AddEcoCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe AddEcoCommand
Namespace DedNet.Commands


Metodo AddEcoCommand.ExecuteCommand

Metodo AddEcoCommandExecuteCommand
Eseguo il comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe AddEcoCommand
Namespace DedNet.Commands


Metodo AddEcoCommand.SetContext

Metodo AddEcoCommandSetContext
Imposto il contesto per l'esecuzione del comando

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe AddEcoCommand
Namespace DedNet.Commands


Classe AddRecurrentTimingCommand
Comando utilizzato per aggiungere anagrafiche, commesse, ECO all'elenco delle temporizzazioni ricorrenti.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsAddRemoveRecurrentTiming
DedNet.CommandsAddRecurrentTimingCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class AddRecurrentTimingCommand : AddRemoveRecurrentTiming
Public Class AddRecurrentTimingCommand
    Inherits AddRemoveRecurrentTiming
public ref class AddRecurrentTimingCommand : public AddRemoveRecurrentTiming
type AddRecurrentTimingCommand =
    class
        inherit AddRemoveRecurrentTiming
    end

Il tipo AddRecurrentTimingCommand espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | AddRecurrentTimingCommand | Crea una nuova istanza della classe 'AddRecurrentTimingCommand' utilizzata per aggiungere anagrafiche, commesse, ECO all'elenco delle temporizzazioni ricorrenti.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Inidica se il comando necessita di parametri. (Ereditato da AddRemoveRecurrentTiming)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulizia del comando. (Ereditato da AddRemoveRecurrentTiming)
Metodo pubblico | Enabled | Abilitazione dal contesto. (Ereditato da AddRemoveRecurrentTiming)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esecuzione del comando. (Ereditato da AddRemoveRecurrentTiming)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Settaggio del contesto. (Ereditato da AddRemoveRecurrentTiming)
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Costruttore AddRecurrentTimingCommand
Crea una nuova istanza della classe 'AddRecurrentTimingCommand' utilizzata per aggiungere anagrafiche, commesse, ECO all'elenco delle temporizzazioni ricorrenti.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public AddRecurrentTimingCommand(
    DedNetApplication app,
    string internalName,
    string name
)
Public Sub New (
    app As DedNetApplication,
    internalName As String,
    name As String
)
public:
AddRecurrentTimingCommand(
    DedNetApplication^ app,
    String^ internalName,
    String^ name
)
new :
        app : DedNetApplication *
        internalName : string *
        name : string -> AddRecurrentTimingCommand

Parametri

app DedNetApplication
Applicazione DedNet.
internalName String
Nome interno del comando.
name String
Nome visualizzato del comando.
Vedi anche

Documentazione

Classe AddRecurrentTimingCommand
Namespace DedNet.Commands


Proprietà di AddRecurrentTimingCommand

Il tipo AddRecurrentTimingCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Inidica se il comando necessita di parametri. (Ereditato da AddRemoveRecurrentTiming)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe AddRecurrentTimingCommand
Namespace DedNet.Commands


Metodi di AddRecurrentTimingCommand

Il tipo AddRecurrentTimingCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulizia del comando. (Ereditato da AddRemoveRecurrentTiming)
Metodo pubblico | Enabled | Abilitazione dal contesto. (Ereditato da AddRemoveRecurrentTiming)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esecuzione del comando. (Ereditato da AddRemoveRecurrentTiming)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Settaggio del contesto. (Ereditato da AddRemoveRecurrentTiming)
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe AddRecurrentTimingCommand
Namespace DedNet.Commands


Classe AddRemoveRecurrentTiming
Comando utilizzato per aggiungere/rimuovere una temporizzazione dai ricorrenti.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsAddRemoveRecurrentTiming
DedNet.CommandsAddRecurrentTimingCommand
DedNet.CommandsRemoveRecurrentTimingCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public abstract class AddRemoveRecurrentTiming : DedCommand
Public MustInherit Class AddRemoveRecurrentTiming
    Inherits DedCommand
public ref class AddRemoveRecurrentTiming abstract : public DedCommand
[<AbstractClassAttribute>]
type AddRemoveRecurrentTiming =
    class
        inherit DedCommand
    end

Il tipo AddRemoveRecurrentTiming espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | AddRemoveRecurrentTiming | Classa astratta utilizzata per aggiungere/rimuovere una temporizzazione dai ricorrenti.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Inidica se il comando necessita di parametri. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulizia del comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Abilitazione dal contesto. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esecuzione del comando. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Settaggio del contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Costruttore AddRemoveRecurrentTiming
Classa astratta utilizzata per aggiungere/rimuovere una temporizzazione dai ricorrenti.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public AddRemoveRecurrentTiming(
    DedNetApplication app,
    string internalName,
    string name,
    bool isAddingOperation
)
Public Sub New (
    app As DedNetApplication,
    internalName As String,
    name As String,
    isAddingOperation As Boolean
)
public:
AddRemoveRecurrentTiming(
    DedNetApplication^ app,
    String^ internalName,
    String^ name,
    bool isAddingOperation
)
new :
        app : DedNetApplication *
        internalName : string *
        name : string *
        isAddingOperation : bool -> AddRemoveRecurrentTiming

Parametri

app DedNetApplication
Applicazione DedNet.
internalName String
Nome interno del comando.
name String
Nome visualizzato del comando.
isAddingOperation Boolean
indica se è una operazione di aggiunta o rimozione.
Vedi anche

Documentazione

Classe AddRemoveRecurrentTiming
Namespace DedNet.Commands


Proprietà di AddRemoveRecurrentTiming

Il tipo AddRemoveRecurrentTiming espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Inidica se il comando necessita di parametri. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe AddRemoveRecurrentTiming
Namespace DedNet.Commands


Proprietà AddRemoveRecurrentTiming.NeedParameters

Proprietà AddRemoveRecurrentTimingNeedParameters
Inidica se il comando necessita di parametri.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe AddRemoveRecurrentTiming
Namespace DedNet.Commands


Metodi di AddRemoveRecurrentTiming

Il tipo AddRemoveRecurrentTiming espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulizia del comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Abilitazione dal contesto. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esecuzione del comando. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Settaggio del contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe AddRemoveRecurrentTiming
Namespace DedNet.Commands


Metodo AddRemoveRecurrentTiming.ClearCommand

Metodo AddRemoveRecurrentTimingClearCommand
Pulizia del comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe AddRemoveRecurrentTiming
Namespace DedNet.Commands


Metodo AddRemoveRecurrentTiming.Enabled

Metodo AddRemoveRecurrentTimingEnabled
Abilitazione dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe AddRemoveRecurrentTiming
Namespace DedNet.Commands


Metodo AddRemoveRecurrentTiming.ExecuteCommand

Metodo AddRemoveRecurrentTimingExecuteCommand
Esecuzione del comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe AddRemoveRecurrentTiming
Namespace DedNet.Commands


Metodo AddRemoveRecurrentTiming.SetContext

Metodo AddRemoveRecurrentTimingSetContext
Settaggio del contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe AddRemoveRecurrentTiming
Namespace DedNet.Commands


Classe AnagrAssocComm
Classe che rappresenta il comando per associare anagrafica a commessa.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsDedDataCommand
DedNet.CommandsAnagrAssocComm

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class AnagrAssocComm : DedDataCommand
Public Class AnagrAssocComm
    Inherits DedDataCommand
public ref class AnagrAssocComm : public DedDataCommand
type AnagrAssocComm =
    class
        inherit DedDataCommand
    end

Il tipo AnagrAssocComm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DataInfos | Restituisce la lista delle anagrafiche di elaborazione comando. (Ereditato da DedDataCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedDataCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive DedDataCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedDataCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedDataCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedDataCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Sovrascrive DedDataCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di AnagrAssocComm

Il tipo AnagrAssocComm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DataInfos | Restituisce la lista delle anagrafiche di elaborazione comando. (Ereditato da DedDataCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedDataCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe AnagrAssocComm
Namespace DedNet.Commands


Proprietà AnagrAssocComm.NeedParameters

Proprietà AnagrAssocCommNeedParameters

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe AnagrAssocComm
Namespace DedNet.Commands


Metodi di AnagrAssocComm

Il tipo AnagrAssocComm espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive DedDataCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedDataCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedDataCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedDataCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Sovrascrive DedDataCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe AnagrAssocComm
Namespace DedNet.Commands


Metodo AnagrAssocComm.ClearCommand

Metodo AnagrAssocCommClearCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe AnagrAssocComm
Namespace DedNet.Commands


Metodo AnagrAssocComm.Enabled

Metodo AnagrAssocCommEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe AnagrAssocComm
Namespace DedNet.Commands


Metodo AnagrAssocComm.ExecuteCommand

Metodo AnagrAssocCommExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe AnagrAssocComm
Namespace DedNet.Commands


Metodo AnagrAssocComm.SetContext

Metodo AnagrAssocCommSetContext

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe AnagrAssocComm
Namespace DedNet.Commands


Classe AnagrHistoryCommand
Classe che rappresenta il comando per visualizzare la storia di un'anagrafica.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsDedDataCommand
DedNet.CommandsAnagrHistoryCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class AnagrHistoryCommand : DedDataCommand
Public Class AnagrHistoryCommand
    Inherits DedDataCommand
public ref class AnagrHistoryCommand : public DedDataCommand
type AnagrHistoryCommand =
    class
        inherit DedDataCommand
    end

Il tipo AnagrHistoryCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DataInfos | Restituisce la lista delle anagrafiche di elaborazione comando. (Ereditato da DedDataCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedDataCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Esegue la pulizia del comando. Azzera tutte le variabili. (Ereditato da DedDataCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedDataCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedDataCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedDataCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Sovrascrive DedDataCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di AnagrHistoryCommand

Il tipo AnagrHistoryCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DataInfos | Restituisce la lista delle anagrafiche di elaborazione comando. (Ereditato da DedDataCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedDataCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe AnagrHistoryCommand
Namespace DedNet.Commands


Proprietà AnagrHistoryCommand.NeedParameters

Proprietà AnagrHistoryCommandNeedParameters

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe AnagrHistoryCommand
Namespace DedNet.Commands


Metodi di AnagrHistoryCommand

Il tipo AnagrHistoryCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Esegue la pulizia del comando. Azzera tutte le variabili. (Ereditato da DedDataCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedDataCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedDataCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedDataCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Sovrascrive DedDataCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe AnagrHistoryCommand
Namespace DedNet.Commands


Metodo AnagrHistoryCommand.Enabled

Metodo AnagrHistoryCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe AnagrHistoryCommand
Namespace DedNet.Commands


Metodo AnagrHistoryCommand.ExecuteCommand

Metodo AnagrHistoryCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe AnagrHistoryCommand
Namespace DedNet.Commands


Metodo AnagrHistoryCommand.SetContext

Metodo AnagrHistoryCommandSetContext

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe AnagrHistoryCommand
Namespace DedNet.Commands


Classe AnnullaCheckOutDocument
Permette di annullare il check-out di una lista di documenti ripristinando la situazione a prima di aver effettuato il check-out.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsAnnullaCheckOutDocument

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class AnnullaCheckOutDocument : DedCommand
Public Class AnnullaCheckOutDocument
    Inherits DedCommand
public ref class AnnullaCheckOutDocument : public DedCommand
type AnnullaCheckOutDocument =
    class
        inherit DedCommand
    end

Il tipo AnnullaCheckOutDocument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | AskEraseFromPws | Restituisce o imposta se chiedere all'utente di eliminare o meno il documento dall'area locale una volta terminato il comadno (di default è true).
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | EraseFromPws | Restituisce o imposta se cancellare i documenti dalla pws dopo il comando (di default è false).
Proprietà pubblica | FileList | Restituisce la lista dei documenti da elaborare. Inserire in questa lista solo i file che si desidera elaborare e non le dipendenze.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non sono presenti documenti da elaborare. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di AnnullaCheckOutDocument

Il tipo AnnullaCheckOutDocument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | AskEraseFromPws | Restituisce o imposta se chiedere all'utente di eliminare o meno il documento dall'area locale una volta terminato il comadno (di default è true).
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | EraseFromPws | Restituisce o imposta se cancellare i documenti dalla pws dopo il comando (di default è false).
Proprietà pubblica | FileList | Restituisce la lista dei documenti da elaborare. Inserire in questa lista solo i file che si desidera elaborare e non le dipendenze.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non sono presenti documenti da elaborare. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe AnnullaCheckOutDocument
Namespace DedNet.Commands


Proprietà AnnullaCheckOutDocument.AskEraseFromPws

Proprietà AnnullaCheckOutDocumentAskEraseFromPws
Restituisce o imposta se chiedere all'utente di eliminare o meno il documento dall'area locale una volta terminato il comadno (di default è true).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AskEraseFromPws { get; set; }
Public Property AskEraseFromPws As Boolean
    Get
    Set
public:
property bool AskEraseFromPws {
    bool get ();
    void set (bool value);
}
member AskEraseFromPws : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe AnnullaCheckOutDocument
Namespace DedNet.Commands


Proprietà AnnullaCheckOutDocument.EraseFromPws

Proprietà AnnullaCheckOutDocumentEraseFromPws
Restituisce o imposta se cancellare i documenti dalla pws dopo il comando (di default è false).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool EraseFromPws { get; set; }
Public Property EraseFromPws As Boolean
    Get
    Set
public:
property bool EraseFromPws {
    bool get ();
    void set (bool value);
}
member EraseFromPws : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe AnnullaCheckOutDocument
Namespace DedNet.Commands


Proprietà AnnullaCheckOutDocument.FileList

Proprietà AnnullaCheckOutDocumentFileList
Restituisce la lista dei documenti da elaborare. Inserire in questa lista solo i file che si desidera elaborare e non le dipendenze.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfoList FileList { get; }
Public ReadOnly Property FileList As DocStructInfoList
    Get
public:
property DocStructInfoList^ FileList {
    DocStructInfoList^ get ();
}
member FileList : DocStructInfoList with get

Valore della proprietà

DocStructInfoList
Vedi anche

Documentazione

Classe AnnullaCheckOutDocument
Namespace DedNet.Commands


Proprietà AnnullaCheckOutDocument.NeedParameters

Proprietà AnnullaCheckOutDocumentNeedParameters
Restituisce true se non sono presenti documenti da elaborare.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe AnnullaCheckOutDocument
Namespace DedNet.Commands


Metodi di AnnullaCheckOutDocument

Il tipo AnnullaCheckOutDocument espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe AnnullaCheckOutDocument
Namespace DedNet.Commands


Metodo AnnullaCheckOutDocument.ClearCommand

Metodo AnnullaCheckOutDocumentClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe AnnullaCheckOutDocument
Namespace DedNet.Commands


Metodo AnnullaCheckOutDocument.Enabled

Metodo AnnullaCheckOutDocumentEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe AnnullaCheckOutDocument
Namespace DedNet.Commands


Metodo AnnullaCheckOutDocument.ExecuteCommand

Metodo AnnullaCheckOutDocumentExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe AnnullaCheckOutDocument
Namespace DedNet.Commands


Metodo AnnullaCheckOutDocument.SetContext

Metodo AnnullaCheckOutDocumentSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto c'è una sola anagrafica alla quale associare il file.
Vedi anche

Documentazione

Classe AnnullaCheckOutDocument
Namespace DedNet.Commands


Classe AssignEcoToSpecificUserCommand
Comando usato per assegnare un ECO ad un utente specifico.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsAssignEcoToSpecificUserCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class AssignEcoToSpecificUserCommand : DedCommand
Public Class AssignEcoToSpecificUserCommand
    Inherits DedCommand
public ref class AssignEcoToSpecificUserCommand : public DedCommand
type AssignEcoToSpecificUserCommand =
    class
        inherit DedCommand
    end

Il tipo AssignEcoToSpecificUserCommand espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | AssignEcoToSpecificUserCommand | Costruttore.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Eco | ECO da assegnare ad un utente specifico.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve essere impostata la struttura di salvataggio distinta. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | User | Utente a cui verrà assegnato l'ECO.
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Imposto il contesto per l'esecuzione del comando (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Costruttore AssignEcoToSpecificUserCommand
Costruttore.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public AssignEcoToSpecificUserCommand(
    DedNetApplication app,
    string internalName,
    string name
)
Public Sub New (
    app As DedNetApplication,
    internalName As String,
    name As String
)
public:
AssignEcoToSpecificUserCommand(
    DedNetApplication^ app,
    String^ internalName,
    String^ name
)
new :
        app : DedNetApplication *
        internalName : string *
        name : string -> AssignEcoToSpecificUserCommand

Parametri

app DedNetApplication
Riferimento all'oggetto DedNetApplication.
internalName String
Nome interno del comando.
name String
Nome visualizzato del comando.
Vedi anche

Documentazione

Classe AssignEcoToSpecificUserCommand
Namespace DedNet.Commands


Proprietà di AssignEcoToSpecificUserCommand

Il tipo AssignEcoToSpecificUserCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Eco | ECO da assegnare ad un utente specifico.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve essere impostata la struttura di salvataggio distinta. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | User | Utente a cui verrà assegnato l'ECO.
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe AssignEcoToSpecificUserCommand
Namespace DedNet.Commands


Proprietà AssignEcoToSpecificUserCommand.Eco

Proprietà AssignEcoToSpecificUserCommandEco
ECO da assegnare ad un utente specifico.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEco Eco { get; set; }
Public Property Eco As DedEco
    Get
    Set
public:
property DedEco^ Eco {
    DedEco^ get ();
    void set (DedEco^ value);
}
member Eco : DedEco with get, set

Valore della proprietà

DedEco
Vedi anche

Documentazione

Classe AssignEcoToSpecificUserCommand
Namespace DedNet.Commands


Proprietà AssignEcoToSpecificUserCommand.NeedParameters

Proprietà AssignEcoToSpecificUserCommandNeedParameters
Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve essere impostata la struttura di salvataggio distinta.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe AssignEcoToSpecificUserCommand
Namespace DedNet.Commands


Proprietà AssignEcoToSpecificUserCommand.User

Proprietà AssignEcoToSpecificUserCommandUser
Utente a cui verrà assegnato l'ECO.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedUser User { get; set; }
Public Property User As DedUser
    Get
    Set
public:
property DedUser^ User {
    DedUser^ get ();
    void set (DedUser^ value);
}
member User : DedUser with get, set

Valore della proprietà

DedUser
Vedi anche

Documentazione

Classe AssignEcoToSpecificUserCommand
Namespace DedNet.Commands


Metodi di AssignEcoToSpecificUserCommand

Il tipo AssignEcoToSpecificUserCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Imposto il contesto per l'esecuzione del comando (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe AssignEcoToSpecificUserCommand
Namespace DedNet.Commands


Metodo AssignEcoToSpecificUserCommand.ClearCommand

Metodo AssignEcoToSpecificUserCommandClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe AssignEcoToSpecificUserCommand
Namespace DedNet.Commands


Metodo AssignEcoToSpecificUserCommand.Enabled

Metodo AssignEcoToSpecificUserCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe AssignEcoToSpecificUserCommand
Namespace DedNet.Commands


Metodo AssignEcoToSpecificUserCommand.ExecuteCommand

Metodo AssignEcoToSpecificUserCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe AssignEcoToSpecificUserCommand
Namespace DedNet.Commands


Metodo AssignEcoToSpecificUserCommand.SetContext

Metodo AssignEcoToSpecificUserCommandSetContext
Imposto il contesto per l'esecuzione del comando

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe AssignEcoToSpecificUserCommand
Namespace DedNet.Commands


Classe AssociateAlternativeDataCommand
Comando utilizzato per associare ad un set di anagrafiche dei codici alternativi.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsAssociateAlternativeDataCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class AssociateAlternativeDataCommand : DedCommand
Public Class AssociateAlternativeDataCommand
    Inherits DedCommand
public ref class AssociateAlternativeDataCommand : public DedCommand
type AssociateAlternativeDataCommand =
    class
        inherit DedCommand
    end

Il tipo AssociateAlternativeDataCommand espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | AssociateAlternativeDataCommand | Crea una nuova istanza del comando 'AssociateAlternativeDataCommand' utilizzato per associare ad un set di anagrafiche dei codici alternativi.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Ritorna True se il comando necessita di parametri aggiuntivi per l'esecuzione, False se è configurato correttamente. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Costruttore AssociateAlternativeDataCommand
Crea una nuova istanza del comando 'AssociateAlternativeDataCommand' utilizzato per associare ad un set di anagrafiche dei codici alternativi.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public AssociateAlternativeDataCommand(
    DedNetApplication app,
    string internalName,
    string name
)
Public Sub New (
    app As DedNetApplication,
    internalName As String,
    name As String
)
public:
AssociateAlternativeDataCommand(
    DedNetApplication^ app,
    String^ internalName,
    String^ name
)
new :
        app : DedNetApplication *
        internalName : string *
        name : string -> AssociateAlternativeDataCommand

Parametri

app DedNetApplication
Riferimento all'oggetto DedNetApplication.
internalName String
Nome interno del comando.
name String
Nome visualizzato del comando.
Vedi anche

Documentazione

Classe AssociateAlternativeDataCommand
Namespace DedNet.Commands


Proprietà di AssociateAlternativeDataCommand

Il tipo AssociateAlternativeDataCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Ritorna True se il comando necessita di parametri aggiuntivi per l'esecuzione, False se è configurato correttamente. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe AssociateAlternativeDataCommand
Namespace DedNet.Commands


Proprietà AssociateAlternativeDataCommand.NeedParameters

Proprietà AssociateAlternativeDataCommandNeedParameters
Ritorna True se il comando necessita di parametri aggiuntivi per l'esecuzione, False se è configurato correttamente.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe AssociateAlternativeDataCommand
Namespace DedNet.Commands


Metodi di AssociateAlternativeDataCommand

Il tipo AssociateAlternativeDataCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe AssociateAlternativeDataCommand
Namespace DedNet.Commands


Metodo AssociateAlternativeDataCommand.ClearCommand

Metodo AssociateAlternativeDataCommandClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe AssociateAlternativeDataCommand
Namespace DedNet.Commands


Metodo AssociateAlternativeDataCommand.Enabled

Metodo AssociateAlternativeDataCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe AssociateAlternativeDataCommand
Namespace DedNet.Commands


Metodo AssociateAlternativeDataCommand.ExecuteCommand

Metodo AssociateAlternativeDataCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe AssociateAlternativeDataCommand
Namespace DedNet.Commands


Metodo AssociateAlternativeDataCommand.SetContext

Metodo AssociateAlternativeDataCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe AssociateAlternativeDataCommand
Namespace DedNet.Commands


Classe AssociateDocument
Utilizzato per decidere se associare un documento come file primario o come allegato di un'anagrafica ed anche per decidere se importare o collegare il documento all'anagrafica (nel caso in cui il documento risulti già registrato nel Database). Di fatto si tratta di un comando a più alto livello che chiama ImportDocument oppure LinkDocument in base al file in elaborazione ed in base alla scelta dell'utente, se l'uso dell'interfaccia utente risulta abilita. I client possono registrare un delegate per operare la copia del documento nella nuova posizione nel caso risulti necessario. Attraverso le proprietà del comando il client può venire a conoscenza delle scelte dell'utente.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsAssociateDocument

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class AssociateDocument : DedCommand
Public Class AssociateDocument
    Inherits DedCommand
public ref class AssociateDocument : public DedCommand
type AssociateDocument =
    class
        inherit DedCommand
    end

Il tipo AssociateDocument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Data | Restituisce o imposta l'anagrafica nella quale importare i documenti.
Proprietà pubblica | DelegateFileCopy | Restituisce o imposta il delegate che viene chiamato dal comando per la copia effettiva dei file. Se viene lasciato vuoto la copia viene effettuatata dal comando. Chi implementa il delegate dovrebbe sollevare eccezioni in caso di errore per interrompere ed annullare tutta la procedura di importazione documenti.
Proprietà pubblica | DelegateFileRecognize | Restituisce o imposta il delegate che viene chiamato dal comando di riconoscimento. Chi implementa il delegate dovrebbe sollevare eccezioni in caso di errore per interrompere ed annullare tutta la procedura di importazione documenti.
Proprietà pubblica | DelegateNewAttachFileName | Restitusice o imposta il delegate che viene chiamato per reperire il nome file nel caso di importazione di un nuovo documento come allegato. Il valore restituito deve essere il nome file compreso di estensione ma senza percorso: viene calcolato dal comando. Chi implementa il delegate dovrebbe sollevare eccezioni in caso di errore per interrompere ed annullare tutta la procedura di importazione documenti.
Proprietà pubblica | DocData | Opzionale : Restituisce o imposta i dati presenti nel documento (solo se il comando è lanciato da un client) da comparare eventualmente con l'anagrafica.
Proprietà pubblica | EnforceOverWriteMode | Imposta/Restituisce se è nel caso sovrascrivere o creare una rappresentazione.
Proprietà pubblica | FileList | Restituisce la lista dei file da importare come documenti e da associare all'anagrafica. Inserire in questa lista solo i file che si desidera importare e non le dipendenze, a meno ché non siano a loro volta da importare.
Proprietà pubblica | ForcedMoveInfo |
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InfoFile | Imposta/Restituisce l'oggetto GridInfoDataList relativo alla selezione dei documenti dell'utente.
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | LinkingData | Restituisce o imposta l'anagrafica di partenza (contenete il documento da collegare).
Proprietà pubblica | LinkNotCopy | Restituisce o imposta se il documento debba essere collegato e non importato (false di default).
Proprietà pubblica | Mdres |
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non è impostata l'anagrafica nella quale importare il documento. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | PrimaryContext | Restituisce o imposta il contesto con il quale importare i documenti. Di default è true ed i documenti vengono importati come primari.
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowAssociateModeForm | Indica se è necessario visualizzare il form che richiede la modalità di associazione all'anagrafica
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SparePartsContext | Indica se importare il documento associandolo all'anagrafica con contesto 'PubblicazioneRicambio' o 'TavolaRicambio'.
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | ToBeCheckIn | Indica se impostare il documento in checkin alla fine del comando (default True).
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseDocValues | Imposta/restituisce se utilizzare gli attributi di documento.
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere l'anagrafica alla quale associare i file. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere l'anagrafica alla quale associare il file. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di AssociateDocument

Il tipo AssociateDocument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Data | Restituisce o imposta l'anagrafica nella quale importare i documenti.
Proprietà pubblica | DelegateFileCopy | Restituisce o imposta il delegate che viene chiamato dal comando per la copia effettiva dei file. Se viene lasciato vuoto la copia viene effettuatata dal comando. Chi implementa il delegate dovrebbe sollevare eccezioni in caso di errore per interrompere ed annullare tutta la procedura di importazione documenti.
Proprietà pubblica | DelegateFileRecognize | Restituisce o imposta il delegate che viene chiamato dal comando di riconoscimento. Chi implementa il delegate dovrebbe sollevare eccezioni in caso di errore per interrompere ed annullare tutta la procedura di importazione documenti.
Proprietà pubblica | DelegateNewAttachFileName | Restitusice o imposta il delegate che viene chiamato per reperire il nome file nel caso di importazione di un nuovo documento come allegato. Il valore restituito deve essere il nome file compreso di estensione ma senza percorso: viene calcolato dal comando. Chi implementa il delegate dovrebbe sollevare eccezioni in caso di errore per interrompere ed annullare tutta la procedura di importazione documenti.
Proprietà pubblica | DocData | Opzionale : Restituisce o imposta i dati presenti nel documento (solo se il comando è lanciato da un client) da comparare eventualmente con l'anagrafica.
Proprietà pubblica | EnforceOverWriteMode | Imposta/Restituisce se è nel caso sovrascrivere o creare una rappresentazione.
Proprietà pubblica | FileList | Restituisce la lista dei file da importare come documenti e da associare all'anagrafica. Inserire in questa lista solo i file che si desidera importare e non le dipendenze, a meno ché non siano a loro volta da importare.
Proprietà pubblica | ForcedMoveInfo |
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InfoFile | Imposta/Restituisce l'oggetto GridInfoDataList relativo alla selezione dei documenti dell'utente.
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | LinkingData | Restituisce o imposta l'anagrafica di partenza (contenete il documento da collegare).
Proprietà pubblica | LinkNotCopy | Restituisce o imposta se il documento debba essere collegato e non importato (false di default).
Proprietà pubblica | Mdres |
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non è impostata l'anagrafica nella quale importare il documento. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | PrimaryContext | Restituisce o imposta il contesto con il quale importare i documenti. Di default è true ed i documenti vengono importati come primari.
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowAssociateModeForm | Indica se è necessario visualizzare il form che richiede la modalità di associazione all'anagrafica
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SparePartsContext | Indica se importare il documento associandolo all'anagrafica con contesto 'PubblicazioneRicambio' o 'TavolaRicambio'.
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | ToBeCheckIn | Indica se impostare il documento in checkin alla fine del comando (default True).
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseDocValues | Imposta/restituisce se utilizzare gli attributi di documento.
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe AssociateDocument
Namespace DedNet.Commands


Proprietà AssociateDocument.Data

Proprietà AssociateDocumentData
Restituisce o imposta l'anagrafica nella quale importare i documenti.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; set; }
Public Property Data As DedData
    Get
    Set
public:
property DedData^ Data {
    DedData^ get ();
    void set (DedData^ value);
}
member Data : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe AssociateDocument
Namespace DedNet.Commands


Proprietà AssociateDocument.DelegateFileCopy

Proprietà AssociateDocumentDelegateFileCopy
Restituisce o imposta il delegate che viene chiamato dal comando per la copia effettiva dei file. Se viene lasciato vuoto la copia viene effettuatata dal comando. Chi implementa il delegate dovrebbe sollevare eccezioni in caso di errore per interrompere ed annullare tutta la procedura di importazione documenti.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public FileOperationDelegate<DocStructInfoList> DelegateFileCopy { get; set; }
Public Property DelegateFileCopy As FileOperationDelegate(Of DocStructInfoList)
    Get
    Set
public:
property FileOperationDelegate<DocStructInfoList^>^ DelegateFileCopy {
    FileOperationDelegate<DocStructInfoList^>^ get ();
    void set (FileOperationDelegate<DocStructInfoList^>^ value);
}
member DelegateFileCopy : FileOperationDelegate<DocStructInfoList> with get, set

Valore della proprietà

FileOperationDelegate DocStructInfoList
Vedi anche

Documentazione

Classe AssociateDocument
Namespace DedNet.Commands


Proprietà AssociateDocument.DelegateFileRecognize

Proprietà AssociateDocumentDelegateFileRecognize
Restituisce o imposta il delegate che viene chiamato dal comando di riconoscimento. Chi implementa il delegate dovrebbe sollevare eccezioni in caso di errore per interrompere ed annullare tutta la procedura di importazione documenti.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public FileOperationDelegate<DocStructInfoList> DelegateFileRecognize { get; set; }
Public Property DelegateFileRecognize As FileOperationDelegate(Of DocStructInfoList)
    Get
    Set
public:
property FileOperationDelegate<DocStructInfoList^>^ DelegateFileRecognize {
    FileOperationDelegate<DocStructInfoList^>^ get ();
    void set (FileOperationDelegate<DocStructInfoList^>^ value);
}
member DelegateFileRecognize : FileOperationDelegate<DocStructInfoList> with get, set

Valore della proprietà

FileOperationDelegate DocStructInfoList
Vedi anche

Documentazione

Classe AssociateDocument
Namespace DedNet.Commands


Proprietà AssociateDocument.DelegateNewAttachFileName

Proprietà AssociateDocumentDelegateNewAttachFileName
Restitusice o imposta il delegate che viene chiamato per reperire il nome file nel caso di importazione di un nuovo documento come allegato. Il valore restituito deve essere il nome file compreso di estensione ma senza percorso: viene calcolato dal comando. Chi implementa il delegate dovrebbe sollevare eccezioni in caso di errore per interrompere ed annullare tutta la procedura di importazione documenti.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ParamRest<DocStructInfo, string> DelegateNewAttachFileName { get; set; }
Public Property DelegateNewAttachFileName As ParamRest(Of DocStructInfo, String)
    Get
    Set
public:
property ParamRest<DocStructInfo^, String^>^ DelegateNewAttachFileName {
    ParamRest<DocStructInfo^, String^>^ get ();
    void set (ParamRest<DocStructInfo^, String^>^ value);
}
member DelegateNewAttachFileName : ParamRest<DocStructInfo, string> with get, set

Valore della proprietà

ParamRest DocStructInfo, String
Vedi anche

Documentazione

Classe AssociateDocument
Namespace DedNet.Commands


Proprietà AssociateDocument.DocData

Proprietà AssociateDocumentDocData
Opzionale : Restituisce o imposta i dati presenti nel documento (solo se il comando è lanciato da un client) da comparare eventualmente con l'anagrafica.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public IDedData DocData { get; set; }
Public Property DocData As IDedData
    Get
    Set
public:
property IDedData^ DocData {
    IDedData^ get ();
    void set (IDedData^ value);
}
member DocData : IDedData with get, set

Valore della proprietà

IDedData
Vedi anche

Documentazione

Classe AssociateDocument
Namespace DedNet.Commands


Proprietà AssociateDocument.EnforceOverWriteMode

Proprietà AssociateDocumentEnforceOverWriteMode
Imposta/Restituisce se è nel caso sovrascrivere o creare una rappresentazione.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool EnforceOverWriteMode { get; set; }
Public Property EnforceOverWriteMode As Boolean
    Get
    Set
public:
property bool EnforceOverWriteMode {
    bool get ();
    void set (bool value);
}
member EnforceOverWriteMode : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe AssociateDocument
Namespace DedNet.Commands


Proprietà AssociateDocument.FileList

Proprietà AssociateDocumentFileList
Restituisce la lista dei file da importare come documenti e da associare all'anagrafica. Inserire in questa lista solo i file che si desidera importare e non le dipendenze, a meno ché non siano a loro volta da importare.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfoList FileList { get; }
Public ReadOnly Property FileList As DocStructInfoList
    Get
public:
property DocStructInfoList^ FileList {
    DocStructInfoList^ get ();
}
member FileList : DocStructInfoList with get

Valore della proprietà

DocStructInfoList
Vedi anche

Documentazione

Classe AssociateDocument
Namespace DedNet.Commands


Proprietà AssociateDocument.ForcedMoveInfo

Proprietà AssociateDocumentForcedMoveInfo

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public MoveDocumentInfoForcedMoveInfo ForcedMoveInfo { get; set; }
Public Property ForcedMoveInfo As MoveDocumentInfoForcedMoveInfo
    Get
    Set
public:
property MoveDocumentInfoForcedMoveInfo^ ForcedMoveInfo {
    MoveDocumentInfoForcedMoveInfo^ get ();
    void set (MoveDocumentInfoForcedMoveInfo^ value);
}
member ForcedMoveInfo : MoveDocumentInfoForcedMoveInfo with get, set

Valore della proprietà

MoveDocumentInfoForcedMoveInfo
Vedi anche

Documentazione

Classe AssociateDocument
Namespace DedNet.Commands


Proprietà AssociateDocument.InfoFile

Proprietà AssociateDocumentInfoFile
Imposta/Restituisce l'oggetto GridInfoDataList relativo alla selezione dei documenti dell'utente.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public GridInfoDataList InfoFile { get; set; }
Public Property InfoFile As GridInfoDataList
    Get
    Set
public:
property GridInfoDataList^ InfoFile {
    GridInfoDataList^ get ();
    void set (GridInfoDataList^ value);
}
member InfoFile : GridInfoDataList with get, set

Valore della proprietà

GridInfoDataList
Vedi anche

Documentazione

Classe AssociateDocument
Namespace DedNet.Commands


Proprietà AssociateDocument.LinkingData

Proprietà AssociateDocumentLinkingData
Restituisce o imposta l'anagrafica di partenza (contenete il documento da collegare).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData LinkingData { get; set; }
Public Property LinkingData As DedData
    Get
    Set
public:
property DedData^ LinkingData {
    DedData^ get ();
    void set (DedData^ value);
}
member LinkingData : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe AssociateDocument
Namespace DedNet.Commands


Proprietà AssociateDocument.LinkNotCopy

Proprietà AssociateDocumentLinkNotCopy
Restituisce o imposta se il documento debba essere collegato e non importato (false di default).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool LinkNotCopy { get; set; }
Public Property LinkNotCopy As Boolean
    Get
    Set
public:
property bool LinkNotCopy {
    bool get ();
    void set (bool value);
}
member LinkNotCopy : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe AssociateDocument
Namespace DedNet.Commands


Proprietà AssociateDocument.Mdres

Proprietà AssociateDocumentMdres

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public MoveDocumentResult Mdres { get; set; }
Public Property Mdres As MoveDocumentResult
    Get
    Set
public:
property MoveDocumentResult^ Mdres {
    MoveDocumentResult^ get ();
    void set (MoveDocumentResult^ value);
}
member Mdres : MoveDocumentResult with get, set

Valore della proprietà

MoveDocumentResult
Vedi anche

Documentazione

Classe AssociateDocument
Namespace DedNet.Commands


Proprietà AssociateDocument.NeedParameters

Proprietà AssociateDocumentNeedParameters
Restituisce true se non è impostata l'anagrafica nella quale importare il documento.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe AssociateDocument
Namespace DedNet.Commands


Proprietà AssociateDocument.PrimaryContext

Proprietà AssociateDocumentPrimaryContext
Restituisce o imposta il contesto con il quale importare i documenti. Di default è true ed i documenti vengono importati come primari.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool PrimaryContext { get; set; }
Public Property PrimaryContext As Boolean
    Get
    Set
public:
property bool PrimaryContext {
    bool get ();
    void set (bool value);
}
member PrimaryContext : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe AssociateDocument
Namespace DedNet.Commands


Proprietà AssociateDocument.ShowAssociateModeForm

Proprietà AssociateDocumentShowAssociateModeForm
Indica se è necessario visualizzare il form che richiede la modalità di associazione all'anagrafica

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ShowAssociateModeForm { get; set; }
Public Property ShowAssociateModeForm As Boolean
    Get
    Set
public:
property bool ShowAssociateModeForm {
    bool get ();
    void set (bool value);
}
member ShowAssociateModeForm : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe AssociateDocument
Namespace DedNet.Commands


Proprietà AssociateDocument.SparePartsContext

Proprietà AssociateDocumentSparePartsContext
Indica se importare il documento associandolo all'anagrafica con contesto 'PubblicazioneRicambio' o 'TavolaRicambio'.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocContextEnum SparePartsContext { get; set; }
Public Property SparePartsContext As DedDocContextEnum
    Get
    Set
public:
property DedDocContextEnum SparePartsContext {
    DedDocContextEnum get ();
    void set (DedDocContextEnum value);
}
member SparePartsContext : DedDocContextEnum with get, set

Valore della proprietà

DedDocContextEnum
Vedi anche

Documentazione

Classe AssociateDocument
Namespace DedNet.Commands


Proprietà AssociateDocument.ToBeCheckIn

Proprietà AssociateDocumentToBeCheckIn
Indica se impostare il documento in checkin alla fine del comando (default True).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ToBeCheckIn { get; set; }
Public Property ToBeCheckIn As Boolean
    Get
    Set
public:
property bool ToBeCheckIn {
    bool get ();
    void set (bool value);
}
member ToBeCheckIn : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe AssociateDocument
Namespace DedNet.Commands


Proprietà AssociateDocument.UseDocValues

Proprietà AssociateDocumentUseDocValues
Imposta/restituisce se utilizzare gli attributi di documento.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool UseDocValues { get; set; }
Public Property UseDocValues As Boolean
    Get
    Set
public:
property bool UseDocValues {
    bool get ();
    void set (bool value);
}
member UseDocValues : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe AssociateDocument
Namespace DedNet.Commands


Metodi di AssociateDocument

Il tipo AssociateDocument espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere l'anagrafica alla quale associare i file. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere l'anagrafica alla quale associare il file. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe AssociateDocument
Namespace DedNet.Commands


Metodo AssociateDocument.ClearCommand

Metodo AssociateDocumentClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe AssociateDocument
Namespace DedNet.Commands


Metodo AssociateDocument.Enabled

Metodo AssociateDocumentEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere l'anagrafica alla quale associare i file.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe AssociateDocument
Namespace DedNet.Commands


Metodo AssociateDocument.ExecuteCommand

Metodo AssociateDocumentExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe AssociateDocument
Namespace DedNet.Commands


Metodo AssociateDocument.SetContext

Metodo AssociateDocumentSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere l'anagrafica alla quale associare il file.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto c'è una sola anagrafica alla quale associare il file.
Vedi anche

Documentazione

Classe AssociateDocument
Namespace DedNet.Commands


Enumerazione AttachBehaviourEnum
Enumerazione dei possibili comportamenti per gli allegati.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum AttachBehaviourEnum
Public Enumeration AttachBehaviourEnum
public enum class AttachBehaviourEnum
type AttachBehaviourEnum
Membri
Nome | Valore | Descrizione
Nessuno | 0 | Nessun allegato sarà presente nella nuova revisione.
Collega | 1 | Collegati alla revisione di partenza.
Copia | 2 | Copiati dalla revisione di partenza.
CollegaUltima | 3 | Lascia quelli collegati all'ultima revisione (se la rev. di partenza non coincide con l'ultima).
CopiaUltima | 4 | Copia quelli dell'ultima revisione (se la rev. di partenza non coincide con l'ultima).
Vedi anche

Documentazione

Namespace DedNet.Commands


Classe BomEditCommand
Classe che rappresenta il comando per editare la distinta.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsDedDataCommand
DedNet.CommandsBomEditCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class BomEditCommand : DedDataCommand
Public Class BomEditCommand
    Inherits DedDataCommand
public ref class BomEditCommand : public DedDataCommand
type BomEditCommand =
    class
        inherit DedDataCommand
    end

Il tipo BomEditCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Behaviour | Imposta o ritorna il comportamento del comando.
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DataInfos | Restituisce la lista delle anagrafiche di elaborazione comando. (Ereditato da DedDataCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InitDiscrimDist | Imposta o ritorna il tipo di distinta da caricare all'avvio del form
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedDataCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Esegue la pulizia del comando. Azzera tutte le variabili. (Ereditato da DedDataCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedDataCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedDataCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedDataCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Sovrascrive DedDataCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di BomEditCommand

Il tipo BomEditCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Behaviour | Imposta o ritorna il comportamento del comando.
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DataInfos | Restituisce la lista delle anagrafiche di elaborazione comando. (Ereditato da DedDataCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InitDiscrimDist | Imposta o ritorna il tipo di distinta da caricare all'avvio del form
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedDataCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe BomEditCommand
Namespace DedNet.Commands


Proprietà BomEditCommand.Behaviour

Proprietà BomEditCommandBehaviour
Imposta o ritorna il comportamento del comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomEditCommandDedBomEditCommandBehaviourEnum Behaviour { get; set; }
Public Property Behaviour As BomEditCommandDedBomEditCommandBehaviourEnum
    Get
    Set
public:
property BomEditCommandDedBomEditCommandBehaviourEnum Behaviour {
    BomEditCommandDedBomEditCommandBehaviourEnum get ();
    void set (BomEditCommandDedBomEditCommandBehaviourEnum value);
}
member Behaviour : BomEditCommandDedBomEditCommandBehaviourEnum with get, set

Valore della proprietà

BomEditCommandDedBomEditCommandBehaviourEnum
Vedi anche

Documentazione

Classe BomEditCommand
Namespace DedNet.Commands


Proprietà BomEditCommand.InitDiscrimDist

Proprietà BomEditCommandInitDiscrimDist
Imposta o ritorna il tipo di distinta da caricare all'avvio del form

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string InitDiscrimDist { get; set; }
Public Property InitDiscrimDist As String
    Get
    Set
public:
property String^ InitDiscrimDist {
    String^ get ();
    void set (String^ value);
}
member InitDiscrimDist : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe BomEditCommand
Namespace DedNet.Commands


Proprietà BomEditCommand.NeedParameters

Proprietà BomEditCommandNeedParameters

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe BomEditCommand
Namespace DedNet.Commands


Metodi di BomEditCommand

Il tipo BomEditCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Esegue la pulizia del comando. Azzera tutte le variabili. (Ereditato da DedDataCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedDataCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedDataCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedDataCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Sovrascrive DedDataCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe BomEditCommand
Namespace DedNet.Commands


Metodo BomEditCommand.Enabled

Metodo BomEditCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe BomEditCommand
Namespace DedNet.Commands


Metodo BomEditCommand.ExecuteCommand

Metodo BomEditCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe BomEditCommand
Namespace DedNet.Commands


Metodo BomEditCommand.SetContext

Metodo BomEditCommandSetContext

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe BomEditCommand
Namespace DedNet.Commands


Enumerazione BomEditCommand.DedBomEditCommandBehaviourEnum

Enumerazione BomEditCommandDedBomEditCommandBehaviourEnum
Enumerazioni dei possibili comportamenti del controllo

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum DedBomEditCommandBehaviourEnum
Public Enumeration DedBomEditCommandBehaviourEnum
public enum class DedBomEditCommandBehaviourEnum
type DedBomEditCommandBehaviourEnum
Membri
Nome | Valore | Descrizione
Standard | 0 | Non specificato
OpenRead | 1 | Apertura anagrafica in lettura
Vedi anche

Documentazione

Namespace DedNet.Commands


Classe BomHistoryCommand
Classe che rappresenta il comando per visualizzare lo storico revisioni di una distinta.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsDedDataCommand
DedNet.CommandsBomHistoryCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class BomHistoryCommand : DedDataCommand
Public Class BomHistoryCommand
    Inherits DedDataCommand
public ref class BomHistoryCommand : public DedDataCommand
type BomHistoryCommand =
    class
        inherit DedDataCommand
    end

Il tipo BomHistoryCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DataInfos | Restituisce la lista delle anagrafiche di elaborazione comando. (Ereditato da DedDataCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce false se non esiste nemmeno un documento sul quale eseguire il comando. (Ereditato da DedDataCommand)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Esegue la pulizia del comando. Azzera tutte le variabili. (Ereditato da DedDataCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedDataCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedDataCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedDataCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedDataCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di BomHistoryCommand

Il tipo BomHistoryCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DataInfos | Restituisce la lista delle anagrafiche di elaborazione comando. (Ereditato da DedDataCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce false se non esiste nemmeno un documento sul quale eseguire il comando. (Ereditato da DedDataCommand)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe BomHistoryCommand
Namespace DedNet.Commands


Metodi di BomHistoryCommand

Il tipo BomHistoryCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Esegue la pulizia del comando. Azzera tutte le variabili. (Ereditato da DedDataCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedDataCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedDataCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedDataCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedDataCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe BomHistoryCommand
Namespace DedNet.Commands


Metodo BomHistoryCommand.Enabled

Metodo BomHistoryCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe BomHistoryCommand
Namespace DedNet.Commands


Metodo BomHistoryCommand.ExecuteCommand

Metodo BomHistoryCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe BomHistoryCommand
Namespace DedNet.Commands


Metodo BomHistoryCommand.SetContext

Metodo BomHistoryCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe BomHistoryCommand
Namespace DedNet.Commands


Classe BomWhereUsedCommand
Classe che rappresenta il comando per l'estrazione dei padri di distinta comuni per le anagrafiche selezionate
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsDedDataCommand
DedNet.CommandsBomWhereUsedCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class BomWhereUsedCommand : DedDataCommand
Public Class BomWhereUsedCommand
    Inherits DedDataCommand
public ref class BomWhereUsedCommand : public DedDataCommand
type BomWhereUsedCommand =
    class
        inherit DedDataCommand
    end

Il tipo BomWhereUsedCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DataInfos | Restituisce la lista delle anagrafiche di elaborazione comando. (Ereditato da DedDataCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedDataCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Esegue la pulizia del comando. Azzera tutte le variabili. (Ereditato da DedDataCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedDataCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedDataCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedDataCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Sovrascrive DedDataCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di BomWhereUsedCommand

Il tipo BomWhereUsedCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DataInfos | Restituisce la lista delle anagrafiche di elaborazione comando. (Ereditato da DedDataCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedDataCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe BomWhereUsedCommand
Namespace DedNet.Commands


Proprietà BomWhereUsedCommand.NeedParameters

Proprietà BomWhereUsedCommandNeedParameters

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe BomWhereUsedCommand
Namespace DedNet.Commands


Metodi di BomWhereUsedCommand

Il tipo BomWhereUsedCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Esegue la pulizia del comando. Azzera tutte le variabili. (Ereditato da DedDataCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedDataCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedDataCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedDataCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Sovrascrive DedDataCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe BomWhereUsedCommand
Namespace DedNet.Commands


Metodo BomWhereUsedCommand.Enabled

Metodo BomWhereUsedCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe BomWhereUsedCommand
Namespace DedNet.Commands


Metodo BomWhereUsedCommand.ExecuteCommand

Metodo BomWhereUsedCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe BomWhereUsedCommand
Namespace DedNet.Commands


Metodo BomWhereUsedCommand.SetContext

Metodo BomWhereUsedCommandSetContext

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe BomWhereUsedCommand
Namespace DedNet.Commands


Classe ChangeEcoStateCommand
Comando usato per cambiare lo stato di un ECO.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsChangeEcoStateCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ChangeEcoStateCommand : DedCommand
Public Class ChangeEcoStateCommand
    Inherits DedCommand
public ref class ChangeEcoStateCommand : public DedCommand
type ChangeEcoStateCommand =
    class
        inherit DedCommand
    end

Il tipo ChangeEcoStateCommand espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ChangeEcoStateCommand | Costruttore.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | ClosureNote | Note di chiusura da utilizzare quando l'ECO viene impostato come chiuso.
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DestinationState | Stato di destinazione dell'ECO.
Proprietà pubblica | ECO | ECO a cui cambiare lo stato.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve essere impostata la struttura di salvataggio distinta. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | User | Utente a cui assegnare l'ECO. Vuole l'internalName dell'utente. Viene effettuato un controllo di validità del nome.
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Imposto il contesto per l'esecuzione del comando (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Costruttore ChangeEcoStateCommand
Costruttore.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ChangeEcoStateCommand(
    DedNetApplication app,
    string internalName,
    string name
)
Public Sub New (
    app As DedNetApplication,
    internalName As String,
    name As String
)
public:
ChangeEcoStateCommand(
    DedNetApplication^ app,
    String^ internalName,
    String^ name
)
new :
        app : DedNetApplication *
        internalName : string *
        name : string -> ChangeEcoStateCommand

Parametri

app DedNetApplication
Riferimento all'oggetto DedNetApplication.
internalName String
Nome interno del comando.
name String
Nome visualizzato del comando.
Vedi anche

Documentazione

Classe ChangeEcoStateCommand
Namespace DedNet.Commands


Proprietà di ChangeEcoStateCommand

Il tipo ChangeEcoStateCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | ClosureNote | Note di chiusura da utilizzare quando l'ECO viene impostato come chiuso.
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DestinationState | Stato di destinazione dell'ECO.
Proprietà pubblica | ECO | ECO a cui cambiare lo stato.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve essere impostata la struttura di salvataggio distinta. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | User | Utente a cui assegnare l'ECO. Vuole l'internalName dell'utente. Viene effettuato un controllo di validità del nome.
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ChangeEcoStateCommand
Namespace DedNet.Commands


Proprietà ChangeEcoStateCommand.ClosureNote

Proprietà ChangeEcoStateCommandClosureNote
Note di chiusura da utilizzare quando l'ECO viene impostato come chiuso.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string ClosureNote { get; set; }
Public Property ClosureNote As String
    Get
    Set
public:
property String^ ClosureNote {
    String^ get ();
    void set (String^ value);
}
member ClosureNote : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe ChangeEcoStateCommand
Namespace DedNet.Commands


Proprietà ChangeEcoStateCommand.DestinationState

Proprietà ChangeEcoStateCommandDestinationState
Stato di destinazione dell'ECO.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEcoEcoStateEnum DestinationState { set; }
Public WriteOnly Property DestinationState As DedEcoEcoStateEnum
    Set
public:
property DedEcoEcoStateEnum DestinationState {
    void set (DedEcoEcoStateEnum value);
}
member DestinationState : DedEcoEcoStateEnum with set

Valore della proprietà

DedEcoEcoStateEnum
Vedi anche

Documentazione

Classe ChangeEcoStateCommand
Namespace DedNet.Commands


Proprietà ChangeEcoStateCommand.ECO

Proprietà ChangeEcoStateCommandECO
ECO a cui cambiare lo stato.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEco ECO { get; set; }
Public Property ECO As DedEco
    Get
    Set
public:
property DedEco^ ECO {
    DedEco^ get ();
    void set (DedEco^ value);
}
member ECO : DedEco with get, set

Valore della proprietà

DedEco
Vedi anche

Documentazione

Classe ChangeEcoStateCommand
Namespace DedNet.Commands


Proprietà ChangeEcoStateCommand.NeedParameters

Proprietà ChangeEcoStateCommandNeedParameters
Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve essere impostata la struttura di salvataggio distinta.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ChangeEcoStateCommand
Namespace DedNet.Commands


Proprietà ChangeEcoStateCommand.User

Proprietà ChangeEcoStateCommandUser
Utente a cui assegnare l'ECO. Vuole l'internalName dell'utente. Viene effettuato un controllo di validità del nome.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string User { get; set; }
Public Property User As String
    Get
    Set
public:
property String^ User {
    String^ get ();
    void set (String^ value);
}
member User : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe ChangeEcoStateCommand
Namespace DedNet.Commands


Metodi di ChangeEcoStateCommand

Il tipo ChangeEcoStateCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Imposto il contesto per l'esecuzione del comando (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ChangeEcoStateCommand
Namespace DedNet.Commands


Metodo ChangeEcoStateCommand.ClearCommand

Metodo ChangeEcoStateCommandClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe ChangeEcoStateCommand
Namespace DedNet.Commands


Metodo ChangeEcoStateCommand.Enabled

Metodo ChangeEcoStateCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe ChangeEcoStateCommand
Namespace DedNet.Commands


Metodo ChangeEcoStateCommand.ExecuteCommand

Metodo ChangeEcoStateCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe ChangeEcoStateCommand
Namespace DedNet.Commands


Metodo ChangeEcoStateCommand.SetContext

Metodo ChangeEcoStateCommandSetContext
Imposto il contesto per l'esecuzione del comando

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe ChangeEcoStateCommand
Namespace DedNet.Commands


Classe ChangePasswordCommand
Classe che rappresenta il comando per cambiare la password dell'utente.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsChangePasswordCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ChangePasswordCommand : DedCommand
Public Class ChangePasswordCommand
    Inherits DedCommand
public ref class ChangePasswordCommand : public DedCommand
type ChangePasswordCommand =
    class
        inherit DedCommand
    end

Il tipo ChangePasswordCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce se i parametri siano o meno sufficienti per l'esecuzione del comando. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | User | Restituisce o imposta l'utente del quale cambiare la password.
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di ChangePasswordCommand

Il tipo ChangePasswordCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce se i parametri siano o meno sufficienti per l'esecuzione del comando. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | User | Restituisce o imposta l'utente del quale cambiare la password.
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ChangePasswordCommand
Namespace DedNet.Commands


Proprietà ChangePasswordCommand.NeedParameters

Proprietà ChangePasswordCommandNeedParameters
Restituisce se i parametri siano o meno sufficienti per l'esecuzione del comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ChangePasswordCommand
Namespace DedNet.Commands


Proprietà ChangePasswordCommand.User

Proprietà ChangePasswordCommandUser
Restituisce o imposta l'utente del quale cambiare la password.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string User { get; set; }
Public Property User As String
    Get
    Set
public:
property String^ User {
    String^ get ();
    void set (String^ value);
}
member User : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe ChangePasswordCommand
Namespace DedNet.Commands


Metodi di ChangePasswordCommand

Il tipo ChangePasswordCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ChangePasswordCommand
Namespace DedNet.Commands


Metodo ChangePasswordCommand.ClearCommand

Metodo ChangePasswordCommandClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe ChangePasswordCommand
Namespace DedNet.Commands


Metodo ChangePasswordCommand.Enabled

Metodo ChangePasswordCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe ChangePasswordCommand
Namespace DedNet.Commands


Metodo ChangePasswordCommand.ExecuteCommand

Metodo ChangePasswordCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe ChangePasswordCommand
Namespace DedNet.Commands


Metodo ChangePasswordCommand.SetContext

Metodo ChangePasswordCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe ChangePasswordCommand
Namespace DedNet.Commands


Classe ChangeRepresentationSuffixCommand
Classe che rappresenta il comando per modificare il suffisso di un documento di rappresentazione.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsDedDocumentCommand
DedNet.CommandsChangeRepresentationSuffixCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ChangeRepresentationSuffixCommand : DedDocumentCommand
Public Class ChangeRepresentationSuffixCommand
    Inherits DedDocumentCommand
public ref class ChangeRepresentationSuffixCommand : public DedDocumentCommand
type ChangeRepresentationSuffixCommand =
    class
        inherit DedDocumentCommand
    end

Il tipo ChangeRepresentationSuffixCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DocumentInfos | Restituisce la lista dei documenti con abbinato il contesto di anagrafica di elaborazione comando. (Ereditato da DedDocumentCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedDocumentCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UserNewRapIdx |
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Reinizializza il comando. (Ereditato da DedDocumentCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedDocumentCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedDocumentCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedDocumentCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedDocumentCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di ChangeRepresentationSuffixCommand

Il tipo ChangeRepresentationSuffixCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DocumentInfos | Restituisce la lista dei documenti con abbinato il contesto di anagrafica di elaborazione comando. (Ereditato da DedDocumentCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedDocumentCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UserNewRapIdx |
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ChangeRepresentationSuffixCommand
Namespace DedNet.Commands


Proprietà ChangeRepresentationSuffixCommand.NeedParameters

Proprietà ChangeRepresentationSuffixCommandNeedParameters

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ChangeRepresentationSuffixCommand
Namespace DedNet.Commands


Proprietà ChangeRepresentationSuffixCommand.UserNewRapIdx

Proprietà ChangeRepresentationSuffixCommandUserNewRapIdx

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string UserNewRapIdx { get; set; }
Public Property UserNewRapIdx As String
    Get
    Set
public:
property String^ UserNewRapIdx {
    String^ get ();
    void set (String^ value);
}
member UserNewRapIdx : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe ChangeRepresentationSuffixCommand
Namespace DedNet.Commands


Metodi di ChangeRepresentationSuffixCommand

Il tipo ChangeRepresentationSuffixCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Reinizializza il comando. (Ereditato da DedDocumentCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedDocumentCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedDocumentCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedDocumentCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedDocumentCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ChangeRepresentationSuffixCommand
Namespace DedNet.Commands


Metodo ChangeRepresentationSuffixCommand.Enabled

Metodo ChangeRepresentationSuffixCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe ChangeRepresentationSuffixCommand
Namespace DedNet.Commands


Metodo ChangeRepresentationSuffixCommand.ExecuteCommand

Metodo ChangeRepresentationSuffixCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe ChangeRepresentationSuffixCommand
Namespace DedNet.Commands


Metodo ChangeRepresentationSuffixCommand.SetContext

Metodo ChangeRepresentationSuffixCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe ChangeRepresentationSuffixCommand
Namespace DedNet.Commands


Classe ChargeCommCommand
Comando per la presa in carico di una commessa da parte dell'utente corrente.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsChargeCommCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ChargeCommCommand : DedCommand
Public Class ChargeCommCommand
    Inherits DedCommand
public ref class ChargeCommCommand : public DedCommand
type ChargeCommCommand =
    class
        inherit DedCommand
    end

Il tipo ChargeCommCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se si vuole creare una sotto commessa ma non si passa il riferimento. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | ReferenceComm | Commessa di riferimento
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di ChargeCommCommand

Il tipo ChargeCommCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se si vuole creare una sotto commessa ma non si passa il riferimento. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | ReferenceComm | Commessa di riferimento
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ChargeCommCommand
Namespace DedNet.Commands


Proprietà ChargeCommCommand.NeedParameters

Proprietà ChargeCommCommandNeedParameters
Restituisce true se si vuole creare una sotto commessa ma non si passa il riferimento.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ChargeCommCommand
Namespace DedNet.Commands


Proprietà ChargeCommCommand.ReferenceComm

Proprietà ChargeCommCommandReferenceComm
Commessa di riferimento

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedComm ReferenceComm { get; set; }
Public Property ReferenceComm As DedComm
    Get
    Set
public:
property DedComm^ ReferenceComm {
    DedComm^ get ();
    void set (DedComm^ value);
}
member ReferenceComm : DedComm with get, set

Valore della proprietà

DedComm
Vedi anche

Documentazione

Classe ChargeCommCommand
Namespace DedNet.Commands


Metodi di ChargeCommCommand

Il tipo ChargeCommCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ChargeCommCommand
Namespace DedNet.Commands


Metodo ChargeCommCommand.ClearCommand

Metodo ChargeCommCommandClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe ChargeCommCommand
Namespace DedNet.Commands


Metodo ChargeCommCommand.Enabled

Metodo ChargeCommCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe ChargeCommCommand
Namespace DedNet.Commands


Metodo ChargeCommCommand.ExecuteCommand

Metodo ChargeCommCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe ChargeCommCommand
Namespace DedNet.Commands


Metodo ChargeCommCommand.SetContext

Metodo ChargeCommCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto c'è una sola anagrafica alla quale associare il file.
Vedi anche

Documentazione

Classe ChargeCommCommand
Namespace DedNet.Commands


Classe CheckInDocument
Effettua il checkin dei documenti pubblicandoli sul server. Opzionalmente i documenti possono essere rimossi dall'area locale. Se si imposta l'opzione Struttura viene effettuato il checkin dei documenti di testata più tutte le dipendenze che risultano in checkout.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsCheckInDocument

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class CheckInDocument : DedCommand
Public Class CheckInDocument
    Inherits DedCommand
public ref class CheckInDocument : public DedCommand
type CheckInDocument =
    class
        inherit DedCommand
    end

Il tipo CheckInDocument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | AskEraseFromPws | Restituisce o imposta se chiedere all'utente di eliminare o meno il documento dall'area locale una volta messo in check-in (di default è true).
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | ConsiderMultipleOperationsAsChildrenOperations | Considera le sotto-operazioni come operazioni children anche se non lo sono per permettere una gestione errori più blanda.
Proprietà pubblica | EraseFromPws | Restituisce o imposta se cancellare i documenti dalla pws dopo il comando (di default è false).
Proprietà pubblica | FileList | Restituisce la lista dei documenti da impostare in checkout. Inserire in questa lista solo i file che si desidera elaborare e non le dipendenze.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non sono presenti documenti da elaborare. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | Restitusice o imposta se il check-in debba essere effettuato su tutta la struttura (di default è false).
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Proprietà pubblica | ViewReportStructOperation | Indica se visualizzare l'elenco dei documenti non elaborati. Utilizzato nel comando CheckIn Struttura e CheckIn Struttura con Associati.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di CheckInDocument

Il tipo CheckInDocument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | AskEraseFromPws | Restituisce o imposta se chiedere all'utente di eliminare o meno il documento dall'area locale una volta messo in check-in (di default è true).
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | ConsiderMultipleOperationsAsChildrenOperations | Considera le sotto-operazioni come operazioni children anche se non lo sono per permettere una gestione errori più blanda.
Proprietà pubblica | EraseFromPws | Restituisce o imposta se cancellare i documenti dalla pws dopo il comando (di default è false).
Proprietà pubblica | FileList | Restituisce la lista dei documenti da impostare in checkout. Inserire in questa lista solo i file che si desidera elaborare e non le dipendenze.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non sono presenti documenti da elaborare. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | Restitusice o imposta se il check-in debba essere effettuato su tutta la struttura (di default è false).
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Proprietà pubblica | ViewReportStructOperation | Indica se visualizzare l'elenco dei documenti non elaborati. Utilizzato nel comando CheckIn Struttura e CheckIn Struttura con Associati.
Torna su
Vedi anche

Documentazione

Classe CheckInDocument
Namespace DedNet.Commands


Proprietà CheckInDocument.AskEraseFromPws

Proprietà CheckInDocumentAskEraseFromPws
Restituisce o imposta se chiedere all'utente di eliminare o meno il documento dall'area locale una volta messo in check-in (di default è true).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AskEraseFromPws { get; set; }
Public Property AskEraseFromPws As Boolean
    Get
    Set
public:
property bool AskEraseFromPws {
    bool get ();
    void set (bool value);
}
member AskEraseFromPws : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CheckInDocument
Namespace DedNet.Commands


Proprietà CheckInDocument.ConsiderMultipleOperationsAsChildrenOperations

Proprietà CheckInDocumentConsiderMultipleOperationsAsChildrenOperations
Considera le sotto-operazioni come operazioni children anche se non lo sono per permettere una gestione errori più blanda.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ConsiderMultipleOperationsAsChildrenOperations { get; set; }
Public Property ConsiderMultipleOperationsAsChildrenOperations As Boolean
    Get
    Set
public:
property bool ConsiderMultipleOperationsAsChildrenOperations {
    bool get ();
    void set (bool value);
}
member ConsiderMultipleOperationsAsChildrenOperations : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CheckInDocument
Namespace DedNet.Commands


Proprietà CheckInDocument.EraseFromPws

Proprietà CheckInDocumentEraseFromPws
Restituisce o imposta se cancellare i documenti dalla pws dopo il comando (di default è false).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool EraseFromPws { get; set; }
Public Property EraseFromPws As Boolean
    Get
    Set
public:
property bool EraseFromPws {
    bool get ();
    void set (bool value);
}
member EraseFromPws : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CheckInDocument
Namespace DedNet.Commands


Proprietà CheckInDocument.FileList

Proprietà CheckInDocumentFileList
Restituisce la lista dei documenti da impostare in checkout. Inserire in questa lista solo i file che si desidera elaborare e non le dipendenze.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfoList FileList { get; }
Public ReadOnly Property FileList As DocStructInfoList
    Get
public:
property DocStructInfoList^ FileList {
    DocStructInfoList^ get ();
}
member FileList : DocStructInfoList with get

Valore della proprietà

DocStructInfoList
Vedi anche

Documentazione

Classe CheckInDocument
Namespace DedNet.Commands


Proprietà CheckInDocument.NeedParameters

Proprietà CheckInDocumentNeedParameters
Restituisce true se non sono presenti documenti da elaborare.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CheckInDocument
Namespace DedNet.Commands


Proprietà CheckInDocument.Struttura

Proprietà CheckInDocumentStruttura
Restitusice o imposta se il check-in debba essere effettuato su tutta la struttura (di default è false).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Struttura { get; set; }
Public Property Struttura As Boolean
    Get
    Set
public:
property bool Struttura {
    bool get ();
    void set (bool value);
}
member Struttura : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CheckInDocument
Namespace DedNet.Commands


Proprietà CheckInDocument.ViewReportStructOperation

Proprietà CheckInDocumentViewReportStructOperation
Indica se visualizzare l'elenco dei documenti non elaborati. Utilizzato nel comando CheckIn Struttura e CheckIn Struttura con Associati.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ViewReportStructOperation { get; set; }
Public Property ViewReportStructOperation As Boolean
    Get
    Set
public:
property bool ViewReportStructOperation {
    bool get ();
    void set (bool value);
}
member ViewReportStructOperation : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CheckInDocument
Namespace DedNet.Commands


Metodi di CheckInDocument

Il tipo CheckInDocument espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe CheckInDocument
Namespace DedNet.Commands


Metodo CheckInDocument.ClearCommand

Metodo CheckInDocumentClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe CheckInDocument
Namespace DedNet.Commands


Metodo CheckInDocument.Enabled

Metodo CheckInDocumentEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe CheckInDocument
Namespace DedNet.Commands


Metodo CheckInDocument.ExecuteCommand

Metodo CheckInDocumentExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe CheckInDocument
Namespace DedNet.Commands


Metodo CheckInDocument.SetContext

Metodo CheckInDocumentSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto c'è una sola anagrafica alla quale associare il file.
Vedi anche

Documentazione

Classe CheckInDocument
Namespace DedNet.Commands


Classe CheckOutDocument
Imposta in checkout una lista di documenti. Effettua i controllie si assicura che tutte le dipendenze siano presenti in locale.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsCheckOutDocument

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class CheckOutDocument : DedCommand
Public Class CheckOutDocument
    Inherits DedCommand
public ref class CheckOutDocument : public DedCommand
type CheckOutDocument =
    class
        inherit DedCommand
    end

Il tipo CheckOutDocument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | ConsiderMultipleOperationsAsChildrenOperations | Considera le sotto-operazioni come operazioni children anche se non lo sono per permettere una gestione errori più blanda.
Proprietà pubblica | FileList | Restituisce la lista dei documenti da impostare in checkout. Inserire in questa lista solo i file che si desidera elaborare e non le dipendenze.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreDataLockState | Consente di ignorare il blocco legato allo stato dell'anagrafica
Proprietà pubblica | IgnoreFileExistingEnsureLocal | Indica di ignorare il controllo dell'esistenza del file in fase di EnsureLocal.
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non sono presenti documenti da elaborare. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | Restitusice o imposta se il check-in debba essere effettuato su tutta la struttura (di default è false).
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Proprietà pubblica | ViewReportStructOperation | Indica se visualizzare l'elenco dei documenti non elaborati. Utilizzato nei comandi CheckOut Struttura, CheckOut Struttura Dirty e CheckOut Struttura con Associati.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di CheckOutDocument

Il tipo CheckOutDocument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | ConsiderMultipleOperationsAsChildrenOperations | Considera le sotto-operazioni come operazioni children anche se non lo sono per permettere una gestione errori più blanda.
Proprietà pubblica | FileList | Restituisce la lista dei documenti da impostare in checkout. Inserire in questa lista solo i file che si desidera elaborare e non le dipendenze.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreDataLockState | Consente di ignorare il blocco legato allo stato dell'anagrafica
Proprietà pubblica | IgnoreFileExistingEnsureLocal | Indica di ignorare il controllo dell'esistenza del file in fase di EnsureLocal.
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non sono presenti documenti da elaborare. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | Restitusice o imposta se il check-in debba essere effettuato su tutta la struttura (di default è false).
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Proprietà pubblica | ViewReportStructOperation | Indica se visualizzare l'elenco dei documenti non elaborati. Utilizzato nei comandi CheckOut Struttura, CheckOut Struttura Dirty e CheckOut Struttura con Associati.
Torna su
Vedi anche

Documentazione

Classe CheckOutDocument
Namespace DedNet.Commands


Proprietà CheckOutDocument.ConsiderMultipleOperationsAsChildrenOperations

Proprietà CheckOutDocumentConsiderMultipleOperationsAsChildrenOperations
Considera le sotto-operazioni come operazioni children anche se non lo sono per permettere una gestione errori più blanda.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ConsiderMultipleOperationsAsChildrenOperations { get; set; }
Public Property ConsiderMultipleOperationsAsChildrenOperations As Boolean
    Get
    Set
public:
property bool ConsiderMultipleOperationsAsChildrenOperations {
    bool get ();
    void set (bool value);
}
member ConsiderMultipleOperationsAsChildrenOperations : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CheckOutDocument
Namespace DedNet.Commands


Proprietà CheckOutDocument.FileList

Proprietà CheckOutDocumentFileList
Restituisce la lista dei documenti da impostare in checkout. Inserire in questa lista solo i file che si desidera elaborare e non le dipendenze.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfoList FileList { get; }
Public ReadOnly Property FileList As DocStructInfoList
    Get
public:
property DocStructInfoList^ FileList {
    DocStructInfoList^ get ();
}
member FileList : DocStructInfoList with get

Valore della proprietà

DocStructInfoList
Vedi anche

Documentazione

Classe CheckOutDocument
Namespace DedNet.Commands


Proprietà CheckOutDocument.IgnoreDataLockState

Proprietà CheckOutDocumentIgnoreDataLockState
Consente di ignorare il blocco legato allo stato dell'anagrafica

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IgnoreDataLockState { get; set; }
Public Property IgnoreDataLockState As Boolean
    Get
    Set
public:
property bool IgnoreDataLockState {
    bool get ();
    void set (bool value);
}
member IgnoreDataLockState : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CheckOutDocument
Namespace DedNet.Commands


Proprietà CheckOutDocument.IgnoreFileExistingEnsureLocal

Proprietà CheckOutDocumentIgnoreFileExistingEnsureLocal
Indica di ignorare il controllo dell'esistenza del file in fase di EnsureLocal.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IgnoreFileExistingEnsureLocal { get; set; }
Public Property IgnoreFileExistingEnsureLocal As Boolean
    Get
    Set
public:
property bool IgnoreFileExistingEnsureLocal {
    bool get ();
    void set (bool value);
}
member IgnoreFileExistingEnsureLocal : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CheckOutDocument
Namespace DedNet.Commands


Proprietà CheckOutDocument.NeedParameters

Proprietà CheckOutDocumentNeedParameters
Restituisce true se non sono presenti documenti da elaborare.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CheckOutDocument
Namespace DedNet.Commands


Proprietà CheckOutDocument.Struttura

Proprietà CheckOutDocumentStruttura
Restitusice o imposta se il check-in debba essere effettuato su tutta la struttura (di default è false).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Struttura { get; set; }
Public Property Struttura As Boolean
    Get
    Set
public:
property bool Struttura {
    bool get ();
    void set (bool value);
}
member Struttura : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CheckOutDocument
Namespace DedNet.Commands


Proprietà CheckOutDocument.ViewReportStructOperation

Proprietà CheckOutDocumentViewReportStructOperation
Indica se visualizzare l'elenco dei documenti non elaborati. Utilizzato nei comandi CheckOut Struttura, CheckOut Struttura Dirty e CheckOut Struttura con Associati.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ViewReportStructOperation { get; set; }
Public Property ViewReportStructOperation As Boolean
    Get
    Set
public:
property bool ViewReportStructOperation {
    bool get ();
    void set (bool value);
}
member ViewReportStructOperation : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CheckOutDocument
Namespace DedNet.Commands


Metodi di CheckOutDocument

Il tipo CheckOutDocument espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe CheckOutDocument
Namespace DedNet.Commands


Metodo CheckOutDocument.ClearCommand

Metodo CheckOutDocumentClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe CheckOutDocument
Namespace DedNet.Commands


Metodo CheckOutDocument.Enabled

Metodo CheckOutDocumentEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe CheckOutDocument
Namespace DedNet.Commands


Metodo CheckOutDocument.ExecuteCommand

Metodo CheckOutDocumentExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe CheckOutDocument
Namespace DedNet.Commands


Metodo CheckOutDocument.SetContext

Metodo CheckOutDocumentSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto c'è almeno un documento ed in check-in.
Vedi anche

Documentazione

Classe CheckOutDocument
Namespace DedNet.Commands


Classe ChmHelpCommand
Classe che rappresente il comando per visualizzare l'help (.chm). Obbligatorio impostare al comando la proprietà Parent contenente il controllo che lo chiama.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsChmHelpCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ChmHelpCommand : DedCommand
Public Class ChmHelpCommand
    Inherits DedCommand
public ref class ChmHelpCommand : public DedCommand
type ChmHelpCommand =
    class
        inherit DedCommand
    end

Il tipo ChmHelpCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Indica se il comando ha bisogno di parametri. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Parent | Controllo padre da cui è stato eseguito il comando.
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | Topic | Capitolo del manuale che si vuole ricercare.
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di ChmHelpCommand

Il tipo ChmHelpCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Indica se il comando ha bisogno di parametri. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Parent | Controllo padre da cui è stato eseguito il comando.
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | Topic | Capitolo del manuale che si vuole ricercare.
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ChmHelpCommand
Namespace DedNet.Commands


Proprietà ChmHelpCommand.NeedParameters

Proprietà ChmHelpCommandNeedParameters
Indica se il comando ha bisogno di parametri.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ChmHelpCommand
Namespace DedNet.Commands


Proprietà ChmHelpCommand.Parent

Proprietà ChmHelpCommandParent
Controllo padre da cui è stato eseguito il comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Control Parent { set; }
Public WriteOnly Property Parent As Control
    Set
public:
property Control^ Parent {
    void set (Control^ value);
}
member Parent : Control with set

Valore della proprietà

Control
Vedi anche

Documentazione

Classe ChmHelpCommand
Namespace DedNet.Commands


Proprietà ChmHelpCommand.Topic

Proprietà ChmHelpCommandTopic
Capitolo del manuale che si vuole ricercare.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Topic { set; }
Public WriteOnly Property Topic As String
    Set
public:
property String^ Topic {
    void set (String^ value);
}
member Topic : string with set

Valore della proprietà

String
Vedi anche

Documentazione

Classe ChmHelpCommand
Namespace DedNet.Commands


Metodi di ChmHelpCommand

Il tipo ChmHelpCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ChmHelpCommand
Namespace DedNet.Commands


Metodo ChmHelpCommand.ClearCommand

Metodo ChmHelpCommandClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe ChmHelpCommand
Namespace DedNet.Commands


Metodo ChmHelpCommand.Enabled

Metodo ChmHelpCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe ChmHelpCommand
Namespace DedNet.Commands


Metodo ChmHelpCommand.ExecuteCommand

Metodo ChmHelpCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe ChmHelpCommand
Namespace DedNet.Commands


Metodo ChmHelpCommand.SetContext

Metodo ChmHelpCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe ChmHelpCommand
Namespace DedNet.Commands


Classe CloseCommCommand
Comando chiusura di una commessa.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsCloseCommCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class CloseCommCommand : DedCommand
Public Class CloseCommCommand
    Inherits DedCommand
public ref class CloseCommCommand : public DedCommand
type CloseCommCommand =
    class
        inherit DedCommand
    end

Il tipo CloseCommCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se si vuole creare una sotto commessa ma non si passa il riferimento. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | ReferenceComm | Commessa di riferimento
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di CloseCommCommand

Il tipo CloseCommCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se si vuole creare una sotto commessa ma non si passa il riferimento. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | ReferenceComm | Commessa di riferimento
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe CloseCommCommand
Namespace DedNet.Commands


Proprietà CloseCommCommand.NeedParameters

Proprietà CloseCommCommandNeedParameters
Restituisce true se si vuole creare una sotto commessa ma non si passa il riferimento.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CloseCommCommand
Namespace DedNet.Commands


Proprietà CloseCommCommand.ReferenceComm

Proprietà CloseCommCommandReferenceComm
Commessa di riferimento

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedComm ReferenceComm { get; set; }
Public Property ReferenceComm As DedComm
    Get
    Set
public:
property DedComm^ ReferenceComm {
    DedComm^ get ();
    void set (DedComm^ value);
}
member ReferenceComm : DedComm with get, set

Valore della proprietà

DedComm
Vedi anche

Documentazione

Classe CloseCommCommand
Namespace DedNet.Commands


Metodi di CloseCommCommand

Il tipo CloseCommCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe CloseCommCommand
Namespace DedNet.Commands


Metodo CloseCommCommand.ClearCommand

Metodo CloseCommCommandClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe CloseCommCommand
Namespace DedNet.Commands


Metodo CloseCommCommand.Enabled

Metodo CloseCommCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe CloseCommCommand
Namespace DedNet.Commands


Metodo CloseCommCommand.ExecuteCommand

Metodo CloseCommCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe CloseCommCommand
Namespace DedNet.Commands


Metodo CloseCommCommand.SetContext

Metodo CloseCommCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto c'è una sola anagrafica alla quale associare il file.
Vedi anche

Documentazione

Classe CloseCommCommand
Namespace DedNet.Commands


Classe CmdUtil
Classe di utilità comuni a diversi comandi.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsCmdUtil

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static class CmdUtil
Public NotInheritable Class CmdUtil
public ref class CmdUtil abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type CmdUtil = class end

Il tipo CmdUtil espone i seguenti membri.

Metodi
Nome | Descrizione
CheckAnagrNotLocked | Solleva una eccezione se le anagrafiche alla quali il documento è collegato come primario, non sono lockabili.
CheckLavDocInAnagr | Solleva una eccezione se le anagrafiche alla quali il documento è collegato come primario, non sono tutte in lavorazione.
CheckNeedExecuteCheckoutOperation | Controlla se deve eseguire l'operazione di Checkout sul documento passato. Controlla lo stato del documento e le variabili RootSkippedOnCheckOutStructure, RootTypeSkippedOnCheckOutStructure,DedTypesSkippedOnCheckOutStructure dei comandi di struttura.
CheckPermEraseDocInAnagr | Dato un documento in eliminazione, verifica che l'utente abbia il permesso di eliminazione su tutte le anagrafiche che lo contengono come documento primario ed il permesso di allegare in tutte le anagrafiche che lo contengono come allegato. Solleva una eccezione durante le verifiche in caso di mancato permesso. Verifica la funzione stessa se è attiva la gestione degli utenti prima di effettuare le verifiche.
CheckPermModDocInAnagr | Dato un documento in modifica, verifica che l'utente abbia il permesso di scrittura su tutte le anagrafiche che lo contengono come documento primario ed il permesso di allegare in tutte le anagrafiche che lo contengono come allegato. Solleva una eccezione durante le verifiche in caso di mancato permesso. Verifica la funzione stessa se è attiva la gestione degli utenti prima di effettuare le verifiche.
CheckWritableDocInAnagr | Solleva una eccezione se le anagrafiche alla quali il documento è collegato come primario, non sono tutte in uno stato scrivibile.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Metodi di CmdUtil

Il tipo CmdUtil espone i seguenti membri.

Metodi
Nome | Descrizione
CheckAnagrNotLocked | Solleva una eccezione se le anagrafiche alla quali il documento è collegato come primario, non sono lockabili.
CheckLavDocInAnagr | Solleva una eccezione se le anagrafiche alla quali il documento è collegato come primario, non sono tutte in lavorazione.
CheckNeedExecuteCheckoutOperation | Controlla se deve eseguire l'operazione di Checkout sul documento passato. Controlla lo stato del documento e le variabili RootSkippedOnCheckOutStructure, RootTypeSkippedOnCheckOutStructure,DedTypesSkippedOnCheckOutStructure dei comandi di struttura.
CheckPermEraseDocInAnagr | Dato un documento in eliminazione, verifica che l'utente abbia il permesso di eliminazione su tutte le anagrafiche che lo contengono come documento primario ed il permesso di allegare in tutte le anagrafiche che lo contengono come allegato. Solleva una eccezione durante le verifiche in caso di mancato permesso. Verifica la funzione stessa se è attiva la gestione degli utenti prima di effettuare le verifiche.
CheckPermModDocInAnagr | Dato un documento in modifica, verifica che l'utente abbia il permesso di scrittura su tutte le anagrafiche che lo contengono come documento primario ed il permesso di allegare in tutte le anagrafiche che lo contengono come allegato. Solleva una eccezione durante le verifiche in caso di mancato permesso. Verifica la funzione stessa se è attiva la gestione degli utenti prima di effettuare le verifiche.
CheckWritableDocInAnagr | Solleva una eccezione se le anagrafiche alla quali il documento è collegato come primario, non sono tutte in uno stato scrivibile.
Torna su
Vedi anche

Documentazione

Classe CmdUtil
Namespace DedNet.Commands


Metodo CmdUtil.CheckAnagrNotLocked

Metodo CmdUtilCheckAnagrNotLocked
Solleva una eccezione se le anagrafiche alla quali il documento è collegato come primario, non sono lockabili.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void CheckAnagrNotLocked(
    DedNetApplication app,
    DedDoc doc,
    bool ignoreState
)
Public Shared Sub CheckAnagrNotLocked (
    app As DedNetApplication,
    doc As DedDoc,
    ignoreState As Boolean
)
public:
static void CheckAnagrNotLocked(
    DedNetApplication^ app,
    DedDoc^ doc,
    bool ignoreState
)
static member CheckAnagrNotLocked :
        app : DedNetApplication *
        doc : DedDoc *
        ignoreState : bool -> unit

Parametri

app DedNetApplication
Applicazione.
doc DedDoc
Documento da sottoporre a verifica.
ignoreState Boolean
Vedi anche

Documentazione

Classe CmdUtil
Namespace DedNet.Commands


Metodo CmdUtil.CheckLavDocInAnagr

Metodo CmdUtilCheckLavDocInAnagr
Solleva una eccezione se le anagrafiche alla quali il documento è collegato come primario, non sono tutte in lavorazione.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void CheckLavDocInAnagr(
    DedNetApplication app,
    DedDoc doc
)
Public Shared Sub CheckLavDocInAnagr (
    app As DedNetApplication,
    doc As DedDoc
)
public:
static void CheckLavDocInAnagr(
    DedNetApplication^ app,
    DedDoc^ doc
)
static member CheckLavDocInAnagr :
        app : DedNetApplication *
        doc : DedDoc -> unit

Parametri

app DedNetApplication
Applicazione.
doc DedDoc
Documento da sottoporre a verifica.
Vedi anche

Documentazione

Classe CmdUtil
Namespace DedNet.Commands


Metodo CmdUtil.CheckNeedExecuteCheckoutOperation

Metodo CmdUtilCheckNeedExecuteCheckoutOperation
Controlla se deve eseguire l'operazione di Checkout sul documento passato. Controlla lo stato del documento e le variabili RootSkippedOnCheckOutStructure, RootTypeSkippedOnCheckOutStructure,DedTypesSkippedOnCheckOutStructure dei comandi di struttura.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool CheckNeedExecuteCheckoutOperation(
    DedNetApplication app,
    DedDoc doc,
    out string msg
)
Public Shared Function CheckNeedExecuteCheckoutOperation (
    app As DedNetApplication,
    doc As DedDoc,
    <OutAttribute> ByRef msg As String
) As Boolean
public:
static bool CheckNeedExecuteCheckoutOperation(
    DedNetApplication^ app,
    DedDoc^ doc,
    [OutAttribute] String^% msg
)
static member CheckNeedExecuteCheckoutOperation :
        app : DedNetApplication *
        doc : DedDoc *
        msg : string byref -> bool

Parametri

app DedNetApplication
Oggetto DedNetApplication
doc DedDoc
DedDoc da controllare
msg String
Messaggio che identifica la causa della non esecuzione

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe CmdUtil
Namespace DedNet.Commands


Metodo CmdUtil.CheckPermEraseDocInAnagr

Metodo CmdUtilCheckPermEraseDocInAnagr
Dato un documento in eliminazione, verifica che l'utente abbia il permesso di eliminazione su tutte le anagrafiche che lo contengono come documento primario ed il permesso di allegare in tutte le anagrafiche che lo contengono come allegato. Solleva una eccezione durante le verifiche in caso di mancato permesso. Verifica la funzione stessa se è attiva la gestione degli utenti prima di effettuare le verifiche.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void CheckPermEraseDocInAnagr(
    DedNetApplication app,
    DedDoc doc
)
Public Shared Sub CheckPermEraseDocInAnagr (
    app As DedNetApplication,
    doc As DedDoc
)
public:
static void CheckPermEraseDocInAnagr(
    DedNetApplication^ app,
    DedDoc^ doc
)
static member CheckPermEraseDocInAnagr :
        app : DedNetApplication *
        doc : DedDoc -> unit

Parametri

app DedNetApplication
Applicazione.
doc DedDoc
Documento da sottoporre a verifica.
Vedi anche

Documentazione

Classe CmdUtil
Namespace DedNet.Commands


Metodo CmdUtil.CheckPermModDocInAnagr

Metodo CmdUtilCheckPermModDocInAnagr
Dato un documento in modifica, verifica che l'utente abbia il permesso di scrittura su tutte le anagrafiche che lo contengono come documento primario ed il permesso di allegare in tutte le anagrafiche che lo contengono come allegato. Solleva una eccezione durante le verifiche in caso di mancato permesso. Verifica la funzione stessa se è attiva la gestione degli utenti prima di effettuare le verifiche.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void CheckPermModDocInAnagr(
    DedNetApplication app,
    DedDoc doc
)
Public Shared Sub CheckPermModDocInAnagr (
    app As DedNetApplication,
    doc As DedDoc
)
public:
static void CheckPermModDocInAnagr(
    DedNetApplication^ app,
    DedDoc^ doc
)
static member CheckPermModDocInAnagr :
        app : DedNetApplication *
        doc : DedDoc -> unit

Parametri

app DedNetApplication
Applicazione.
doc DedDoc
Documento da sottoporre a verifica.
Vedi anche

Documentazione

Classe CmdUtil
Namespace DedNet.Commands


Metodo CmdUtil.CheckWritableDocInAnagr

Metodo CmdUtilCheckWritableDocInAnagr
Solleva una eccezione se le anagrafiche alla quali il documento è collegato come primario, non sono tutte in uno stato scrivibile.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void CheckWritableDocInAnagr(
    DedNetApplication app,
    DedDoc doc
)
Public Shared Sub CheckWritableDocInAnagr (
    app As DedNetApplication,
    doc As DedDoc
)
public:
static void CheckWritableDocInAnagr(
    DedNetApplication^ app,
    DedDoc^ doc
)
static member CheckWritableDocInAnagr :
        app : DedNetApplication *
        doc : DedDoc -> unit

Parametri

app DedNetApplication
Applicazione.
doc DedDoc
Documento da sottoporre a verifica.
Vedi anche

Documentazione

Classe CmdUtil
Namespace DedNet.Commands


Enumerazione CommandContextEnum
Enumerazione delle posizioni dalle quali è stato lanciato o è possibile lanciare un comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum CommandContextEnum
Public Enumeration CommandContextEnum
public enum class CommandContextEnum
type CommandContextEnum
Membri
Nome | Valore | Descrizione
None | 0 | Enumerazione non inizializzata.
PrimaryFiles | 1 | Comando lanciato dal menu contestuale dei file primari.
AttachFiles | 2 | Comando lanciato dal menu contestuale dei file allegati.
AllAnagrFiles | 3 | File primari ed allegati.
CommFiles | 4 | Comando lanciato dal menu contestuale dei file di commessa
DocCentral | 8 | Comando lanciato dal menu contestuale della ricerca documentale
AnagrCentral | 16 | Comando lanciato dal menu contestuale delle anagrafiche.
AnagrPref | 32 | Comando lanciato dal menu contestuale delle anagrafiche preferite.
AnagrRec | 64 | Comando lanciato dal menu contestuale delle anagrafiche recenti.
AnagrComm | 128 | Comando lanciato sulle anagrafiche del form delle commesse
AllAnagr | 240 | Tutte le anagrafiche senza distinta.
DistControl | 256 | Comando lanciato dalla distinta Esplosa/Implosa.
AllAnagrWithDist | 496 | Tutte le anagrafiche compresa la distinta.
AllAnagrAndFilesWithDist | 499 | Tutte le anagraifche compresa la distinta e tutti i file.
TypesTree | 512 | Comando lanciato dal menu dell'albero delle famiglie.
FindCodeForm | 1,024 | Comando lanciato dalla finestra Cerca codice.
PwsCache | 2,048 | Comando lanciato dalla PwsCache.
BomExplorerCtrlReadOnly | 4,096 | Comando lanciato dal controllo esplorazione distinta in sola lettura§
BomExplorerCtrlReadWrite | 8,192 | Comando lanciato dal controllo esplorazione distinta in scrittura
AllBomExplorer | 12,288 | Tutti i comandi bomexplorer
CommExplorerCtrl | 16,384 | Comando lanciato dal controllo di esplorazione delle commesse.
EcoFiles | 32,768 | Comando lanciato dal menu contestuale dei file di ECO.
AllFiles | 32,775 | Tutti i file
AllAnagrAndFiles | 33,015 | Tutte le anagraifche (esclusa la distinta) e tutti i file.
Eco | 65,536 | Comando lanciato dal dialogo di visualizzazione degli ECO.
DocTreeFolder | 131,072 | Comando lanciato dalla struttura a cartelle dei documenti.
EditAttrControl | 262,144 | Comando lanciato dal controllo custom dedicato all'editazione degli attributi.
RecurrentTiming | 524,288 | Comando lanciato dalla barra dei menu oppure dal menu a tendina dei comandi generali.
AlternativeDataForm | 1,048,576 | Comando lanciato dal dialogo dei codici alternativi.
Global | 2,097,152 | Comando lanciato dalla barra dei menu oppure dal menu a tendina dei comandi generali.
All | 2,099,059 | Tutti i contesti.
CommTypesTree | 4,194,304 | Comando lanciato dal menu dell'albero delle tipologie di commessa.
Vedi anche

Documentazione

Namespace DedNet.Commands


Classe CommEditCommand
Classe che rappresenta il comando per aprire il gestore commesse.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsDedDataCommand
DedNet.CommandsCommEditCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class CommEditCommand : DedDataCommand
Public Class CommEditCommand
    Inherits DedDataCommand
public ref class CommEditCommand : public DedDataCommand
type CommEditCommand =
    class
        inherit DedDataCommand
    end

Il tipo CommEditCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllLev | Indica se visualizzare anche le commesse collegate tramite la distinta implosa del codice.
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DataInfos | Restituisce la lista delle anagrafiche di elaborazione comando. (Ereditato da DedDataCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce sempre false. (Sovrascrive DedDataCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Esegue la pulizia del comando. Azzera tutte le variabili. (Ereditato da DedDataCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedDataCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedDataCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedDataCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Restituisce sempre true... (Sovrascrive DedDataCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di CommEditCommand

Il tipo CommEditCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllLev | Indica se visualizzare anche le commesse collegate tramite la distinta implosa del codice.
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DataInfos | Restituisce la lista delle anagrafiche di elaborazione comando. (Ereditato da DedDataCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce sempre false. (Sovrascrive DedDataCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe CommEditCommand
Namespace DedNet.Commands


Proprietà CommEditCommand.AllLev

Proprietà CommEditCommandAllLev
Indica se visualizzare anche le commesse collegate tramite la distinta implosa del codice.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AllLev { get; set; }
Public Property AllLev As Boolean
    Get
    Set
public:
property bool AllLev {
    bool get ();
    void set (bool value);
}
member AllLev : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CommEditCommand
Namespace DedNet.Commands


Proprietà CommEditCommand.NeedParameters

Proprietà CommEditCommandNeedParameters
Restituisce sempre false.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CommEditCommand
Namespace DedNet.Commands


Metodi di CommEditCommand

Il tipo CommEditCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Esegue la pulizia del comando. Azzera tutte le variabili. (Ereditato da DedDataCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedDataCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedDataCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedDataCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Restituisce sempre true... (Sovrascrive DedDataCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe CommEditCommand
Namespace DedNet.Commands


Metodo CommEditCommand.Enabled

Metodo CommEditCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe CommEditCommand
Namespace DedNet.Commands


Metodo CommEditCommand.ExecuteCommand

Metodo CommEditCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe CommEditCommand
Namespace DedNet.Commands


Metodo CommEditCommand.SetContext

Metodo CommEditCommandSetContext
Restituisce sempre true...

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe CommEditCommand
Namespace DedNet.Commands


Classe CommEsplCommand
Comando di esplosione di una commessa.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsCommEsplCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class CommEsplCommand : DedCommand
Public Class CommEsplCommand
    Inherits DedCommand
public ref class CommEsplCommand : public DedCommand
type CommEsplCommand =
    class
        inherit DedCommand
    end

Il tipo CommEsplCommand espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | CommEsplCommand | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se si vuole creare una sotto commessa ma non si passa il riferimento. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | ReferenceComm | Commessa di riferimento
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Costruttore CommEsplCommand
Costruttore unico.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public CommEsplCommand(
    DedNetApplication app,
    string internalName,
    string name
)
Public Sub New (
    app As DedNetApplication,
    internalName As String,
    name As String
)
public:
CommEsplCommand(
    DedNetApplication^ app,
    String^ internalName,
    String^ name
)
new :
        app : DedNetApplication *
        internalName : string *
        name : string -> CommEsplCommand

Parametri

app DedNetApplication
Riferimento all'oggetto DedNetApplication.
internalName String
Nome interno del comando.
name String
Nome visualizzato del comando.
Vedi anche

Documentazione

Classe CommEsplCommand
Namespace DedNet.Commands


Proprietà di CommEsplCommand

Il tipo CommEsplCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se si vuole creare una sotto commessa ma non si passa il riferimento. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | ReferenceComm | Commessa di riferimento
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe CommEsplCommand
Namespace DedNet.Commands


Proprietà CommEsplCommand.NeedParameters

Proprietà CommEsplCommandNeedParameters
Restituisce true se si vuole creare una sotto commessa ma non si passa il riferimento.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CommEsplCommand
Namespace DedNet.Commands


Proprietà CommEsplCommand.ReferenceComm

Proprietà CommEsplCommandReferenceComm
Commessa di riferimento

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedComm ReferenceComm { get; set; }
Public Property ReferenceComm As DedComm
    Get
    Set
public:
property DedComm^ ReferenceComm {
    DedComm^ get ();
    void set (DedComm^ value);
}
member ReferenceComm : DedComm with get, set

Valore della proprietà

DedComm
Vedi anche

Documentazione

Classe CommEsplCommand
Namespace DedNet.Commands


Metodi di CommEsplCommand

Il tipo CommEsplCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe CommEsplCommand
Namespace DedNet.Commands


Metodo CommEsplCommand.ClearCommand

Metodo CommEsplCommandClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe CommEsplCommand
Namespace DedNet.Commands


Metodo CommEsplCommand.Enabled

Metodo CommEsplCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe CommEsplCommand
Namespace DedNet.Commands


Metodo CommEsplCommand.ExecuteCommand

Metodo CommEsplCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe CommEsplCommand
Namespace DedNet.Commands


Metodo CommEsplCommand.SetContext

Metodo CommEsplCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto c'è una sola anagrafica alla quale associare il file.
Vedi anche

Documentazione

Classe CommEsplCommand
Namespace DedNet.Commands


Classe CopyDocument
Permette di copiare una lista di documenti in una nuova destinazione con un nuovo nome, e creando quindi nuovi documenti. I file di partenza possono anche non essere presenti nel Database. Se è attiva l'area locale i nuovi documenti vengono creati in checkout dall'utente e non vengono pubblicati sul server. La pubblicazione avverrà su comando esplicito dell'utente. Viene chiamato un evento che permette al client di sostituirsi al comando ed effettuare la copia fisica del file, se questo non viene fatto dal client viene fatto dal comando stesso. Aggiorna poi i riferimenti presenti nei file di Inventor appena copiati, per quanto riguarda i documenti coinvolti nella copia.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsCopyDocument

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class CopyDocument : DedCommand
Public Class CopyDocument
    Inherits DedCommand
public ref class CopyDocument : public DedCommand
type CopyDocument =
    class
        inherit DedCommand
    end

Il tipo CopyDocument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CopyingDocuments | Restituisce la lista dei documenti da copiare. Aggiungere qui le informazioni necessarie al comando.
Proprietà pubblica | DelegateFileCopy | Restituisce o imposta il delegate che, dopo la modifica dei record, viene chiamato dal comando per la copia effettiva dei file. Se viene lasciato vuoto, la copia viene effettuatata dal comando. Chi implementa il delegate dovrebbe sollevare eccezioni in caso di errore per interrompere ed annullare tutta la procedura di copia documenti.
Proprietà pubblica | EnforceFileCopy | Restituisce o imposta il flag di sovrascrittura forzata in fase di copia
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InfoList | Restituisce la lista delle operazioni ricavate dalla lista CopyingDocuments impostata nel comando. Non inserire qui le informazioni ma leggerne solo il risultato dopo l'esecuzione del comando.
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non è impostato almeno un documento da spostare. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato o meno in base alla selezione contestuale. Gli basta che sia selezionato un documento. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Gli basta che sia selezionato un documento. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di CopyDocument

Il tipo CopyDocument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CopyingDocuments | Restituisce la lista dei documenti da copiare. Aggiungere qui le informazioni necessarie al comando.
Proprietà pubblica | DelegateFileCopy | Restituisce o imposta il delegate che, dopo la modifica dei record, viene chiamato dal comando per la copia effettiva dei file. Se viene lasciato vuoto, la copia viene effettuatata dal comando. Chi implementa il delegate dovrebbe sollevare eccezioni in caso di errore per interrompere ed annullare tutta la procedura di copia documenti.
Proprietà pubblica | EnforceFileCopy | Restituisce o imposta il flag di sovrascrittura forzata in fase di copia
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InfoList | Restituisce la lista delle operazioni ricavate dalla lista CopyingDocuments impostata nel comando. Non inserire qui le informazioni ma leggerne solo il risultato dopo l'esecuzione del comando.
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non è impostato almeno un documento da spostare. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe CopyDocument
Namespace DedNet.Commands


Proprietà CopyDocument.CopyingDocuments

Proprietà CopyDocumentCopyingDocuments
Restituisce la lista dei documenti da copiare. Aggiungere qui le informazioni necessarie al comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public CopyDocumentCopyDocumentList CopyingDocuments { get; }
Public ReadOnly Property CopyingDocuments As CopyDocumentCopyDocumentList
    Get
public:
property CopyDocumentCopyDocumentList^ CopyingDocuments {
    CopyDocumentCopyDocumentList^ get ();
}
member CopyingDocuments : CopyDocumentCopyDocumentList with get

Valore della proprietà

CopyDocumentCopyDocumentList
Vedi anche

Documentazione

Classe CopyDocument
Namespace DedNet.Commands


Proprietà CopyDocument.DelegateFileCopy

Proprietà CopyDocumentDelegateFileCopy
Restituisce o imposta il delegate che, dopo la modifica dei record, viene chiamato dal comando per la copia effettiva dei file. Se viene lasciato vuoto, la copia viene effettuatata dal comando. Chi implementa il delegate dovrebbe sollevare eccezioni in caso di errore per interrompere ed annullare tutta la procedura di copia documenti.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public FileOperationDelegate<DocStructInfoList> DelegateFileCopy { get; set; }
Public Property DelegateFileCopy As FileOperationDelegate(Of DocStructInfoList)
    Get
    Set
public:
property FileOperationDelegate<DocStructInfoList^>^ DelegateFileCopy {
    FileOperationDelegate<DocStructInfoList^>^ get ();
    void set (FileOperationDelegate<DocStructInfoList^>^ value);
}
member DelegateFileCopy : FileOperationDelegate<DocStructInfoList> with get, set

Valore della proprietà

FileOperationDelegate DocStructInfoList
Vedi anche

Documentazione

Classe CopyDocument
Namespace DedNet.Commands


Proprietà CopyDocument.EnforceFileCopy

Proprietà CopyDocumentEnforceFileCopy
Restituisce o imposta il flag di sovrascrittura forzata in fase di copia

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool EnforceFileCopy { get; set; }
Public Property EnforceFileCopy As Boolean
    Get
    Set
public:
property bool EnforceFileCopy {
    bool get ();
    void set (bool value);
}
member EnforceFileCopy : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CopyDocument
Namespace DedNet.Commands


Proprietà CopyDocument.InfoList

Proprietà CopyDocumentInfoList
Restituisce la lista delle operazioni ricavate dalla lista CopyingDocuments impostata nel comando. Non inserire qui le informazioni ma leggerne solo il risultato dopo l'esecuzione del comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfoList InfoList { get; }
Public ReadOnly Property InfoList As DocStructInfoList
    Get
public:
property DocStructInfoList^ InfoList {
    DocStructInfoList^ get ();
}
member InfoList : DocStructInfoList with get

Valore della proprietà

DocStructInfoList
Vedi anche

Documentazione

Classe CopyDocument
Namespace DedNet.Commands


Proprietà CopyDocument.NeedParameters

Proprietà CopyDocumentNeedParameters
Restituisce true se non è impostato almeno un documento da spostare.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CopyDocument
Namespace DedNet.Commands


Metodi di CopyDocument

Il tipo CopyDocument espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato o meno in base alla selezione contestuale. Gli basta che sia selezionato un documento. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Gli basta che sia selezionato un documento. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe CopyDocument
Namespace DedNet.Commands


Metodo CopyDocument.ClearCommand

Metodo CopyDocumentClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe CopyDocument
Namespace DedNet.Commands


Metodo CopyDocument.Enabled

Metodo CopyDocumentEnabled
Restituisce se il comando sia abilitato o meno in base alla selezione contestuale. Gli basta che sia selezionato un documento.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe CopyDocument
Namespace DedNet.Commands


Metodo CopyDocument.ExecuteCommand

Metodo CopyDocumentExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe CopyDocument
Namespace DedNet.Commands


Metodo CopyDocument.SetContext

Metodo CopyDocumentSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Gli basta che sia selezionato un documento.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce sempre false.
Vedi anche

Documentazione

Classe CopyDocument
Namespace DedNet.Commands


Classe CopyDocument.CopyDocumentItem

Classe CopyDocumentCopyDocumentItem
Descrive un singolo documento da copiare.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsCopyDocumentCopyDocumentItem

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class CopyDocumentItem : IMoveCopyDocumentItem
Public Class CopyDocumentItem
    Implements IMoveCopyDocumentItem
public ref class CopyDocumentItem : IMoveCopyDocumentItem
type CopyDocumentItem =
    class
        interface IMoveCopyDocumentItem
    end

Il tipo CopyDocumentCopyDocumentItem espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | CopyDocumentCopyDocumentItem | Inizializza l'elemento.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | InfoItem | Restituisce la struttura del documento da copiare.
Proprietà pubblica | NewPath | Restituisce il path di destinazione del documento.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Costruttore CopyDocument.CopyDocumentItem

Costruttore CopyDocumentCopyDocumentItem
Inizializza l'elemento.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public CopyDocumentItem(
    DocStructInfo infoItem,
    string newPath
)
Public Sub New (
    infoItem As DocStructInfo,
    newPath As String
)
public:
CopyDocumentItem(
    DocStructInfo^ infoItem,
    String^ newPath
)
new :
        infoItem : DocStructInfo *
        newPath : string -> CopyDocumentItem

Parametri

infoItem DocStructInfo
newPath String
Vedi anche

Documentazione

Classe CopyDocumentCopyDocumentItem
Namespace DedNet.Commands


Proprietà di CopyDocumentItem

Il tipo CopyDocumentCopyDocumentItem espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | InfoItem | Restituisce la struttura del documento da copiare.
Proprietà pubblica | NewPath | Restituisce il path di destinazione del documento.
Torna su
Vedi anche

Documentazione

Classe CopyDocumentCopyDocumentItem
Namespace DedNet.Commands


Proprietà CopyDocument.CopyDocumentItem.InfoItem

Proprietà CopyDocumentCopyDocumentItemInfoItem
Restituisce la struttura del documento da copiare.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfo InfoItem { get; }
Public ReadOnly Property InfoItem As DocStructInfo
    Get
public:
virtual property DocStructInfo^ InfoItem {
    DocStructInfo^ get () sealed;
}
abstract InfoItem : DocStructInfo with get
override InfoItem : DocStructInfo with get

Valore della proprietà

DocStructInfo

Implementa

IMoveCopyDocumentItemInfoItem
Vedi anche

Documentazione

Classe CopyDocumentCopyDocumentItem
Namespace DedNet.Commands


Proprietà CopyDocument.CopyDocumentItem.NewPath

Proprietà CopyDocumentCopyDocumentItemNewPath
Restituisce il path di destinazione del documento.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string NewPath { get; set; }
Public Property NewPath As String
    Get
    Set
public:
virtual property String^ NewPath {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract NewPath : string with get, set
override NewPath : string with get, set

Valore della proprietà

String

Implementa

IMoveCopyDocumentItemNewPath
Vedi anche

Documentazione

Classe CopyDocumentCopyDocumentItem
Namespace DedNet.Commands


Classe CopyDocument.CopyDocumentList

Classe CopyDocumentCopyDocumentList
Lista di oggetti CopyDocumentItem.
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList IMoveCopyDocumentItem
DedNet.CommandsCopyDocumentCopyDocumentList

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class CopyDocumentList : List<IMoveCopyDocumentItem>
Public Class CopyDocumentList
    Inherits List(Of IMoveCopyDocumentItem)
public ref class CopyDocumentList : public List<IMoveCopyDocumentItem^>
type CopyDocumentList =
    class
        inherit List<IMoveCopyDocumentItem>
    end

Il tipo CopyDocumentCopyDocumentList espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllNewFileSpecified | Restituisce true se sono stati specificati dei percorsi di destinazione per tutti gli elementi della collezione.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Add | Aggiunge un nuovo elemento alla collezione.
Metodo pubblico | FindByDocId | Restituisce l'elemento avente DocId specificato, oppure null se non è presente.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di CopyDocumentList

Il tipo CopyDocumentCopyDocumentList espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllNewFileSpecified | Restituisce true se sono stati specificati dei percorsi di destinazione per tutti gli elementi della collezione.
Torna su
Vedi anche

Documentazione

Classe CopyDocumentCopyDocumentList
Namespace DedNet.Commands


Proprietà CopyDocument.CopyDocumentList.AllNewFileSpecified

Proprietà CopyDocumentCopyDocumentListAllNewFileSpecified
Restituisce true se sono stati specificati dei percorsi di destinazione per tutti gli elementi della collezione.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AllNewFileSpecified { get; }
Public ReadOnly Property AllNewFileSpecified As Boolean
    Get
public:
property bool AllNewFileSpecified {
    bool get ();
}
member AllNewFileSpecified : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CopyDocumentCopyDocumentList
Namespace DedNet.Commands


Metodi di CopyDocumentList

Il tipo CopyDocumentCopyDocumentList espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Add | Aggiunge un nuovo elemento alla collezione.
Metodo pubblico | FindByDocId | Restituisce l'elemento avente DocId specificato, oppure null se non è presente.
Torna su
Vedi anche

Documentazione

Classe CopyDocumentCopyDocumentList
Namespace DedNet.Commands


Metodo CopyDocument.CopyDocumentList.Add

Metodo CopyDocumentCopyDocumentListAdd
Aggiunge un nuovo elemento alla collezione.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public CopyDocumentCopyDocumentItem Add(
    string fileName,
    string newPath
)
Public Function Add (
    fileName As String,
    newPath As String
) As CopyDocumentCopyDocumentItem
public:
CopyDocumentCopyDocumentItem^ Add(
    String^ fileName,
    String^ newPath
)
member Add :
        fileName : string *
        newPath : string -> CopyDocumentCopyDocumentItem

Parametri

fileName String
Elemento da aggiungere.
newPath String
Nome completo che l'elemento dovrà avere.

Valore di ritorno

CopyDocumentCopyDocumentItem
Vedi anche

Documentazione

Classe CopyDocumentCopyDocumentList
Namespace DedNet.Commands


Metodo CopyDocument.CopyDocumentList.FindByDocId

Metodo CopyDocumentCopyDocumentListFindByDocId
Restituisce l'elemento avente DocId specificato, oppure null se non è presente.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public CopyDocumentCopyDocumentItem FindByDocId(
    Guid docid
)
Public Function FindByDocId (
    docid As Guid
) As CopyDocumentCopyDocumentItem
public:
CopyDocumentCopyDocumentItem^ FindByDocId(
    Guid docid
)
member FindByDocId :
        docid : Guid -> CopyDocumentCopyDocumentItem

Parametri

docid Guid
DocId da utilizzare per cercare l'elemento.

Valore di ritorno

CopyDocumentCopyDocumentItem
Restituisce l'elemento trovato oppure null.
Vedi anche

Documentazione

Classe CopyDocumentCopyDocumentList
Namespace DedNet.Commands


Classe CreateDocument
Crea l'anagrafica documentale dato un nome completo di file. Se il file risulta essere già registrato nel Database allora non fa niente e ne ricava solo il documento. Diversamente lo aggiunge lasciandolo così com'è e registrando anche tutte le sue sotto-dipendenze a cascata, sempre lasciando i nomi ed i percorsi di file così come sono. Se avviene anche un singolo errore viene annullata tutta l'operazione. Tutti i file devono essere nelle root del Database.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsCreateDocument

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class CreateDocument : DedCommand
Public Class CreateDocument
    Inherits DedCommand
public ref class CreateDocument : public DedCommand
type CreateDocument =
    class
        inherit DedCommand
    end

Il tipo CreateDocument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | FileList | Restituisce la lista dei file dei quali creare i documenti. Inserire in questa lista solo i file che si desidera importare e non le dipendenze, a meno ché non siano a loro volta da importare.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | LazyMode | Se vero attiva la modalità che non invalida il comando in caso di errori
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non è impostato alcun file dal quale creare il documento. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. Restituisce sempre false perché questo è utilizzato come sotto-comando. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Restituisce sempre false perché questo è utilizzato come sotto-comando. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di CreateDocument

Il tipo CreateDocument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | FileList | Restituisce la lista dei file dei quali creare i documenti. Inserire in questa lista solo i file che si desidera importare e non le dipendenze, a meno ché non siano a loro volta da importare.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | LazyMode | Se vero attiva la modalità che non invalida il comando in caso di errori
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non è impostato alcun file dal quale creare il documento. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe CreateDocument
Namespace DedNet.Commands


Proprietà CreateDocument.FileList

Proprietà CreateDocumentFileList
Restituisce la lista dei file dei quali creare i documenti. Inserire in questa lista solo i file che si desidera importare e non le dipendenze, a meno ché non siano a loro volta da importare.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfoList FileList { get; }
Public ReadOnly Property FileList As DocStructInfoList
    Get
public:
property DocStructInfoList^ FileList {
    DocStructInfoList^ get ();
}
member FileList : DocStructInfoList with get

Valore della proprietà

DocStructInfoList
Vedi anche

Documentazione

Classe CreateDocument
Namespace DedNet.Commands


Proprietà CreateDocument.LazyMode

Proprietà CreateDocumentLazyMode
Se vero attiva la modalità che non invalida il comando in caso di errori

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool LazyMode { get; set; }
Public Property LazyMode As Boolean
    Get
    Set
public:
property bool LazyMode {
    bool get ();
    void set (bool value);
}
member LazyMode : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CreateDocument
Namespace DedNet.Commands


Proprietà CreateDocument.NeedParameters

Proprietà CreateDocumentNeedParameters
Restituisce true se non è impostato alcun file dal quale creare il documento.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CreateDocument
Namespace DedNet.Commands


Metodi di CreateDocument

Il tipo CreateDocument espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. Restituisce sempre false perché questo è utilizzato come sotto-comando. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Restituisce sempre false perché questo è utilizzato come sotto-comando. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe CreateDocument
Namespace DedNet.Commands


Metodo CreateDocument.ClearCommand

Metodo CreateDocumentClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe CreateDocument
Namespace DedNet.Commands


Metodo CreateDocument.Enabled

Metodo CreateDocumentEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale. Restituisce sempre false perché questo è utilizzato come sotto-comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce sempre false.
Vedi anche

Documentazione

Classe CreateDocument
Namespace DedNet.Commands


Metodo CreateDocument.ExecuteCommand

Metodo CreateDocumentExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe CreateDocument
Namespace DedNet.Commands


Metodo CreateDocument.SetContext

Metodo CreateDocumentSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Restituisce sempre false perché questo è utilizzato come sotto-comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce sempre false.
Vedi anche

Documentazione

Classe CreateDocument
Namespace DedNet.Commands


Classe CreateEditSparePartsAttributesCommand
Comando utilizzato per editare gli attributi di ricambio di un set di anagrafiche.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsCreateEditSparePartsAttributesCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class CreateEditSparePartsAttributesCommand : DedCommand
Public Class CreateEditSparePartsAttributesCommand
    Inherits DedCommand
public ref class CreateEditSparePartsAttributesCommand : public DedCommand
type CreateEditSparePartsAttributesCommand =
    class
        inherit DedCommand
    end

Il tipo CreateEditSparePartsAttributesCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Data | Anagrafiche di cui si vuole editare gli attributi di ricambio.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve essere impostata la struttura di salvataggio distinta. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Esegue la pulizia del comando. Azzera tutte le variabili. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). Restituisce sempre false perché non è direttamente chiamato dall'utente. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Restituisce sempre false perché non è direttamente chiamato dall'utente. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di CreateEditSparePartsAttributesCommand

Il tipo CreateEditSparePartsAttributesCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Data | Anagrafiche di cui si vuole editare gli attributi di ricambio.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve essere impostata la struttura di salvataggio distinta. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe CreateEditSparePartsAttributesCommand
Namespace DedNet.Commands


Proprietà CreateEditSparePartsAttributesCommand.Data

Proprietà CreateEditSparePartsAttributesCommandData
Anagrafiche di cui si vuole editare gli attributi di ricambio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataList Data { get; set; }
Public Property Data As DedDataList
    Get
    Set
public:
property DedDataList^ Data {
    DedDataList^ get ();
    void set (DedDataList^ value);
}
member Data : DedDataList with get, set

Valore della proprietà

DedDataList
Vedi anche

Documentazione

Classe CreateEditSparePartsAttributesCommand
Namespace DedNet.Commands


Proprietà CreateEditSparePartsAttributesCommand.NeedParameters

Proprietà CreateEditSparePartsAttributesCommandNeedParameters
Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve essere impostata la struttura di salvataggio distinta.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CreateEditSparePartsAttributesCommand
Namespace DedNet.Commands


Metodi di CreateEditSparePartsAttributesCommand

Il tipo CreateEditSparePartsAttributesCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Esegue la pulizia del comando. Azzera tutte le variabili. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). Restituisce sempre false perché non è direttamente chiamato dall'utente. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Restituisce sempre false perché non è direttamente chiamato dall'utente. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe CreateEditSparePartsAttributesCommand
Namespace DedNet.Commands


Metodo CreateEditSparePartsAttributesCommand.ClearCommand

Metodo CreateEditSparePartsAttributesCommandClearCommand
Esegue la pulizia del comando. Azzera tutte le variabili.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe CreateEditSparePartsAttributesCommand
Namespace DedNet.Commands


Metodo CreateEditSparePartsAttributesCommand.Enabled

Metodo CreateEditSparePartsAttributesCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). Restituisce sempre false perché non è direttamente chiamato dall'utente.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext commandContext
)
Public Overrides Function Enabled (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ commandContext
) override
abstract Enabled :
        commandContext : DedCommandContext -> bool
override Enabled :
        commandContext : DedCommandContext -> bool

Parametri

commandContext DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe CreateEditSparePartsAttributesCommand
Namespace DedNet.Commands


Metodo CreateEditSparePartsAttributesCommand.ExecuteCommand

Metodo CreateEditSparePartsAttributesCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe CreateEditSparePartsAttributesCommand
Namespace DedNet.Commands


Metodo CreateEditSparePartsAttributesCommand.SetContext

Metodo CreateEditSparePartsAttributesCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Restituisce sempre false perché non è direttamente chiamato dall'utente.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext commandContext
)
Public Overrides Function SetContext (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ commandContext
) override
abstract SetContext :
        commandContext : DedCommandContext -> bool
override SetContext :
        commandContext : DedCommandContext -> bool

Parametri

commandContext DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe CreateEditSparePartsAttributesCommand
Namespace DedNet.Commands


Classe CreateFolder
Crea una cartella.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsCreateFolder

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class CreateFolder : DedCommand
Public Class CreateFolder
    Inherits DedCommand
public ref class CreateFolder : public DedCommand
type CreateFolder =
    class
        inherit DedCommand
    end

Il tipo CreateFolder espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non è impostato alcun file dal quale creare il documento. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OutFolderPath |
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Path |
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. Restituisce sempre false perché questo è utilizzato come sotto-comando. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Restituisce sempre false perché questo è utilizzato come sotto-comando. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di CreateFolder

Il tipo CreateFolder espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non è impostato alcun file dal quale creare il documento. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OutFolderPath |
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Path |
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe CreateFolder
Namespace DedNet.Commands


Proprietà CreateFolder.NeedParameters

Proprietà CreateFolderNeedParameters
Restituisce true se non è impostato alcun file dal quale creare il documento.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CreateFolder
Namespace DedNet.Commands


Proprietà CreateFolder.OutFolderPath

Proprietà CreateFolderOutFolderPath

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> OutFolderPath { get; }
Public ReadOnly Property OutFolderPath As List(Of String)
    Get
public:
property List<String^>^ OutFolderPath {
    List<String^>^ get ();
}
member OutFolderPath : List<string> with get

Valore della proprietà

List String
Vedi anche

Documentazione

Classe CreateFolder
Namespace DedNet.Commands


Proprietà CreateFolder.Path

Proprietà CreateFolderPath

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> Path { get; set; }
Public Property Path As List(Of String)
    Get
    Set
public:
property List<String^>^ Path {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
member Path : List<string> with get, set

Valore della proprietà

List String
Vedi anche

Documentazione

Classe CreateFolder
Namespace DedNet.Commands


Metodi di CreateFolder

Il tipo CreateFolder espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. Restituisce sempre false perché questo è utilizzato come sotto-comando. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Restituisce sempre false perché questo è utilizzato come sotto-comando. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe CreateFolder
Namespace DedNet.Commands


Metodo CreateFolder.ClearCommand

Metodo CreateFolderClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe CreateFolder
Namespace DedNet.Commands


Metodo CreateFolder.Enabled

Metodo CreateFolderEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale. Restituisce sempre false perché questo è utilizzato come sotto-comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce sempre false.
Vedi anche

Documentazione

Classe CreateFolder
Namespace DedNet.Commands


Metodo CreateFolder.ExecuteCommand

Metodo CreateFolderExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe CreateFolder
Namespace DedNet.Commands


Metodo CreateFolder.SetContext

Metodo CreateFolderSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Restituisce sempre false perché questo è utilizzato come sotto-comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce sempre false.
Vedi anche

Documentazione

Classe CreateFolder
Namespace DedNet.Commands


Classe CreateManualCommand
Comando utilizzato per generare il manuale di una distinta.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsCreateManualCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class CreateManualCommand : DedCommand
Public Class CreateManualCommand
    Inherits DedCommand
public ref class CreateManualCommand : public DedCommand
type CreateManualCommand =
    class
        inherit DedCommand
    end

Il tipo CreateManualCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Data | Anagrafica da cui prelevare la distinta e generare il manuale.
Proprietà pubblica | DiscrimDist | Discriminante di distinta di cui si vuole creare il manuale ricambi.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | Language | Lingua in cui generare il manuale.
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | MultiSheetTemplate | Template multifoglio che si intende utilizzare per generare il manuale. Vuole solo il nome del file con la relativa estensione.
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve essere impostata la struttura di salvataggio distinta. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RevisionDist | Indica la revisione di distinta da utilizzare. Di default è impostato a -1 che significa 'utilizza ultima revisione'.
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Template | Template che si intende utilizzare per generare il manuale. Vuole solo il nome del file con la relativa estensione.
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Esegue la pulizia del comando. Azzera tutte le variabili. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). Restituisce sempre false perché non è direttamente chiamato dall'utente. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Restituisce sempre false perché non è direttamente chiamato dall'utente. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di CreateManualCommand

Il tipo CreateManualCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Data | Anagrafica da cui prelevare la distinta e generare il manuale.
Proprietà pubblica | DiscrimDist | Discriminante di distinta di cui si vuole creare il manuale ricambi.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | Language | Lingua in cui generare il manuale.
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | MultiSheetTemplate | Template multifoglio che si intende utilizzare per generare il manuale. Vuole solo il nome del file con la relativa estensione.
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve essere impostata la struttura di salvataggio distinta. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RevisionDist | Indica la revisione di distinta da utilizzare. Di default è impostato a -1 che significa 'utilizza ultima revisione'.
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Template | Template che si intende utilizzare per generare il manuale. Vuole solo il nome del file con la relativa estensione.
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe CreateManualCommand
Namespace DedNet.Commands


Proprietà CreateManualCommand.Data

Proprietà CreateManualCommandData
Anagrafica da cui prelevare la distinta e generare il manuale.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; set; }
Public Property Data As DedData
    Get
    Set
public:
property DedData^ Data {
    DedData^ get ();
    void set (DedData^ value);
}
member Data : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe CreateManualCommand
Namespace DedNet.Commands


Proprietà CreateManualCommand.DiscrimDist

Proprietà CreateManualCommandDiscrimDist
Discriminante di distinta di cui si vuole creare il manuale ricambi.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string DiscrimDist { get; set; }
Public Property DiscrimDist As String
    Get
    Set
public:
property String^ DiscrimDist {
    String^ get ();
    void set (String^ value);
}
member DiscrimDist : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe CreateManualCommand
Namespace DedNet.Commands


Proprietà CreateManualCommand.Language

Proprietà CreateManualCommandLanguage
Lingua in cui generare il manuale.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Language { get; set; }
Public Property Language As String
    Get
    Set
public:
property String^ Language {
    String^ get ();
    void set (String^ value);
}
member Language : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe CreateManualCommand
Namespace DedNet.Commands


Proprietà CreateManualCommand.MultiSheetTemplate

Proprietà CreateManualCommandMultiSheetTemplate
Template multifoglio che si intende utilizzare per generare il manuale. Vuole solo il nome del file con la relativa estensione.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string MultiSheetTemplate { get; set; }
Public Property MultiSheetTemplate As String
    Get
    Set
public:
property String^ MultiSheetTemplate {
    String^ get ();
    void set (String^ value);
}
member MultiSheetTemplate : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe CreateManualCommand
Namespace DedNet.Commands


Proprietà CreateManualCommand.NeedParameters

Proprietà CreateManualCommandNeedParameters
Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve essere impostata la struttura di salvataggio distinta.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CreateManualCommand
Namespace DedNet.Commands


Proprietà CreateManualCommand.RevisionDist

Proprietà CreateManualCommandRevisionDist
Indica la revisione di distinta da utilizzare. Di default è impostato a -1 che significa 'utilizza ultima revisione'.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int RevisionDist { get; set; }
Public Property RevisionDist As Integer
    Get
    Set
public:
property int RevisionDist {
    int get ();
    void set (int value);
}
member RevisionDist : int with get, set

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe CreateManualCommand
Namespace DedNet.Commands


Proprietà CreateManualCommand.Template

Proprietà CreateManualCommandTemplate
Template che si intende utilizzare per generare il manuale. Vuole solo il nome del file con la relativa estensione.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Template { get; set; }
Public Property Template As String
    Get
    Set
public:
property String^ Template {
    String^ get ();
    void set (String^ value);
}
member Template : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe CreateManualCommand
Namespace DedNet.Commands


Metodi di CreateManualCommand

Il tipo CreateManualCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Esegue la pulizia del comando. Azzera tutte le variabili. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). Restituisce sempre false perché non è direttamente chiamato dall'utente. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Restituisce sempre false perché non è direttamente chiamato dall'utente. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe CreateManualCommand
Namespace DedNet.Commands


Metodo CreateManualCommand.ClearCommand

Metodo CreateManualCommandClearCommand
Esegue la pulizia del comando. Azzera tutte le variabili.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe CreateManualCommand
Namespace DedNet.Commands


Metodo CreateManualCommand.Enabled

Metodo CreateManualCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). Restituisce sempre false perché non è direttamente chiamato dall'utente.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext commandContext
)
Public Overrides Function Enabled (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ commandContext
) override
abstract Enabled :
        commandContext : DedCommandContext -> bool
override Enabled :
        commandContext : DedCommandContext -> bool

Parametri

commandContext DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe CreateManualCommand
Namespace DedNet.Commands


Metodo CreateManualCommand.ExecuteCommand

Metodo CreateManualCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe CreateManualCommand
Namespace DedNet.Commands


Metodo CreateManualCommand.SetContext

Metodo CreateManualCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Restituisce sempre false perché non è direttamente chiamato dall'utente.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext commandContext
)
Public Overrides Function SetContext (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ commandContext
) override
abstract SetContext :
        commandContext : DedCommandContext -> bool
override SetContext :
        commandContext : DedCommandContext -> bool

Parametri

commandContext DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe CreateManualCommand
Namespace DedNet.Commands


Classe CreateSparePartsDrawingCommand
Comando utilizzato per creare il documento tecnico da inserire nel manuale ricambi.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsCreateSparePartsDrawingCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class CreateSparePartsDrawingCommand : DedCommand
Public Class CreateSparePartsDrawingCommand
    Inherits DedCommand
public ref class CreateSparePartsDrawingCommand : public DedCommand
type CreateSparePartsDrawingCommand =
    class
        inherit DedCommand
    end

Il tipo CreateSparePartsDrawingCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Data | Anagrafica a cui si vuole associare il documento tecnico.
Proprietà pubblica | Document | Percorso del file di cui si vuole creare il documento tecnico.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve essere impostata la struttura di salvataggio distinta. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Esegue la pulizia del comando. Azzera tutte le variabili. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). Restituisce sempre false perché non è direttamente chiamato dall'utente. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Restituisce sempre false perché non è direttamente chiamato dall'utente. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di CreateSparePartsDrawingCommand

Il tipo CreateSparePartsDrawingCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Data | Anagrafica a cui si vuole associare il documento tecnico.
Proprietà pubblica | Document | Percorso del file di cui si vuole creare il documento tecnico.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve essere impostata la struttura di salvataggio distinta. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe CreateSparePartsDrawingCommand
Namespace DedNet.Commands


Proprietà CreateSparePartsDrawingCommand.Data

Proprietà CreateSparePartsDrawingCommandData
Anagrafica a cui si vuole associare il documento tecnico.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; set; }
Public Property Data As DedData
    Get
    Set
public:
property DedData^ Data {
    DedData^ get ();
    void set (DedData^ value);
}
member Data : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe CreateSparePartsDrawingCommand
Namespace DedNet.Commands


Proprietà CreateSparePartsDrawingCommand.Document

Proprietà CreateSparePartsDrawingCommandDocument
Percorso del file di cui si vuole creare il documento tecnico.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDoc Document { get; set; }
Public Property Document As DedDoc
    Get
    Set
public:
property DedDoc^ Document {
    DedDoc^ get ();
    void set (DedDoc^ value);
}
member Document : DedDoc with get, set

Valore della proprietà

DedDoc
Vedi anche

Documentazione

Classe CreateSparePartsDrawingCommand
Namespace DedNet.Commands


Proprietà CreateSparePartsDrawingCommand.NeedParameters

Proprietà CreateSparePartsDrawingCommandNeedParameters
Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve essere impostata la struttura di salvataggio distinta.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CreateSparePartsDrawingCommand
Namespace DedNet.Commands


Metodi di CreateSparePartsDrawingCommand

Il tipo CreateSparePartsDrawingCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Esegue la pulizia del comando. Azzera tutte le variabili. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). Restituisce sempre false perché non è direttamente chiamato dall'utente. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Restituisce sempre false perché non è direttamente chiamato dall'utente. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe CreateSparePartsDrawingCommand
Namespace DedNet.Commands


Metodo CreateSparePartsDrawingCommand.ClearCommand

Metodo CreateSparePartsDrawingCommandClearCommand
Esegue la pulizia del comando. Azzera tutte le variabili.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe CreateSparePartsDrawingCommand
Namespace DedNet.Commands


Metodo CreateSparePartsDrawingCommand.Enabled

Metodo CreateSparePartsDrawingCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). Restituisce sempre false perché non è direttamente chiamato dall'utente.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext commandContext
)
Public Overrides Function Enabled (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ commandContext
) override
abstract Enabled :
        commandContext : DedCommandContext -> bool
override Enabled :
        commandContext : DedCommandContext -> bool

Parametri

commandContext DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe CreateSparePartsDrawingCommand
Namespace DedNet.Commands


Metodo CreateSparePartsDrawingCommand.ExecuteCommand

Metodo CreateSparePartsDrawingCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe CreateSparePartsDrawingCommand
Namespace DedNet.Commands


Metodo CreateSparePartsDrawingCommand.SetContext

Metodo CreateSparePartsDrawingCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Restituisce sempre false perché non è direttamente chiamato dall'utente.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext commandContext
)
Public Overrides Function SetContext (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ commandContext
) override
abstract SetContext :
        commandContext : DedCommandContext -> bool
override SetContext :
        commandContext : DedCommandContext -> bool

Parametri

commandContext DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe CreateSparePartsDrawingCommand
Namespace DedNet.Commands


Classe DataStatisticsAnalyzer
Comando di individuazione elementi albero dall'area grafica / browser.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsDataStatisticsAnalyzer

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DataStatisticsAnalyzer : DedCommand
Public Class DataStatisticsAnalyzer
    Inherits DedCommand
public ref class DataStatisticsAnalyzer : public DedCommand
type DataStatisticsAnalyzer =
    class
        inherit DedCommand
    end

Il tipo DataStatisticsAnalyzer espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Data | Permette di impostare l'anagrafica sul quale calcolare la struttura di distinta
Proprietà pubblica | DsInfo | Permette di impostare il docstructinfo sul quale calcolare la struttura documentale
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Se manca sia la struttura documentale che quella anagrafica... (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Il comando è abilitato se è selezionata almeno una anagrafica con distinta oppure un documento (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Lancia il comando di salva nel db. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Settaggio del contesto. Setta l'anagrafica o il documento a seconda del contesto (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di DataStatisticsAnalyzer

Il tipo DataStatisticsAnalyzer espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Data | Permette di impostare l'anagrafica sul quale calcolare la struttura di distinta
Proprietà pubblica | DsInfo | Permette di impostare il docstructinfo sul quale calcolare la struttura documentale
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Se manca sia la struttura documentale che quella anagrafica... (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DataStatisticsAnalyzer
Namespace DedNet.Commands


Proprietà DataStatisticsAnalyzer.Data

Proprietà DataStatisticsAnalyzerData
Permette di impostare l'anagrafica sul quale calcolare la struttura di distinta

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; set; }
Public Property Data As DedData
    Get
    Set
public:
property DedData^ Data {
    DedData^ get ();
    void set (DedData^ value);
}
member Data : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe DataStatisticsAnalyzer
Namespace DedNet.Commands


Proprietà DataStatisticsAnalyzer.DsInfo

Proprietà DataStatisticsAnalyzerDsInfo
Permette di impostare il docstructinfo sul quale calcolare la struttura documentale

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfo DsInfo { get; set; }
Public Property DsInfo As DocStructInfo
    Get
    Set
public:
property DocStructInfo^ DsInfo {
    DocStructInfo^ get ();
    void set (DocStructInfo^ value);
}
member DsInfo : DocStructInfo with get, set

Valore della proprietà

DocStructInfo
Vedi anche

Documentazione

Classe DataStatisticsAnalyzer
Namespace DedNet.Commands


Proprietà DataStatisticsAnalyzer.NeedParameters

Proprietà DataStatisticsAnalyzerNeedParameters
Se manca sia la struttura documentale che quella anagrafica...

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DataStatisticsAnalyzer
Namespace DedNet.Commands


Metodi di DataStatisticsAnalyzer

Il tipo DataStatisticsAnalyzer espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Il comando è abilitato se è selezionata almeno una anagrafica con distinta oppure un documento (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Lancia il comando di salva nel db. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Settaggio del contesto. Setta l'anagrafica o il documento a seconda del contesto (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DataStatisticsAnalyzer
Namespace DedNet.Commands


Metodo DataStatisticsAnalyzer.ClearCommand

Metodo DataStatisticsAnalyzerClearCommand
Azzera il comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe DataStatisticsAnalyzer
Namespace DedNet.Commands


Metodo DataStatisticsAnalyzer.Enabled

Metodo DataStatisticsAnalyzerEnabled
Il comando è abilitato se è selezionata almeno una anagrafica con distinta oppure un documento

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext commandContext
)
Public Overrides Function Enabled (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ commandContext
) override
abstract Enabled :
        commandContext : DedCommandContext -> bool
override Enabled :
        commandContext : DedCommandContext -> bool

Parametri

commandContext DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DataStatisticsAnalyzer
Namespace DedNet.Commands


Metodo DataStatisticsAnalyzer.ExecuteCommand

Metodo DataStatisticsAnalyzerExecuteCommand
Lancia il comando di salva nel db.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe DataStatisticsAnalyzer
Namespace DedNet.Commands


Metodo DataStatisticsAnalyzer.SetContext

Metodo DataStatisticsAnalyzerSetContext
Settaggio del contesto. Setta l'anagrafica o il documento a seconda del contesto

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext commandContext
)
Public Overrides Function SetContext (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ commandContext
) override
abstract SetContext :
        commandContext : DedCommandContext -> bool
override SetContext :
        commandContext : DedCommandContext -> bool

Parametri

commandContext DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DataStatisticsAnalyzer
Namespace DedNet.Commands


Classe DbDocCompareCommand
Comando per confrontare i dati provenienti da un documento e quelli presenti nell'anagrafica del Database.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsDbDocCompareCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DbDocCompareCommand : DedCommand
Public Class DbDocCompareCommand
    Inherits DedCommand
public ref class DbDocCompareCommand : public DedCommand
type DbDocCompareCommand =
    class
        inherit DedCommand
    end

Il tipo DbDocCompareCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DataDB | Imposta o restituisce l'anagrafica presente nel Database da confrontare.
Proprietà pubblica | DataDoc | Imposta o restituisce l'anagrafica del documento da confrontare.
Proprietà pubblica | DataResult | Restituisce l'anagrafica risultatnte dal confronto.
Proprietà pubblica | Doc | Imposta/Restituisce il documento sul quale sono stati letti i dati documentali
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | ListAttrNameDiff | Restituisce la lista dei nomi degli attributi che hanno delle differenze di valore
Proprietà pubblica | ListRestrictedAttrNameUseDocValues | Permette di impostare una lista ristretta di nomi di attributi dei quali usare il valore del documento nel caso in cui sia a True la proprietà UseDocValues. Se l'attributo non è nella lista viene usato il valore del DB acnhe se UseDocValues è True.
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione (servono le due anagrafiche da confrontare). (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NeedToBeCompared | Viene impostata in base a true se il documento deve essere comparato. Può essere utile per testare la reale esigenza di effettuare la comparazione se il comando è lanciato in modalità test, ovvere UseUI = false
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseDocValues | Restituisce o imposta se vanno usati i valori del documento (di default è false e vengono mantenuti i dati presenti nel database).
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Esegue la pulizia del comando. Azzera tutte le variabili. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di DbDocCompareCommand

Il tipo DbDocCompareCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DataDB | Imposta o restituisce l'anagrafica presente nel Database da confrontare.
Proprietà pubblica | DataDoc | Imposta o restituisce l'anagrafica del documento da confrontare.
Proprietà pubblica | DataResult | Restituisce l'anagrafica risultatnte dal confronto.
Proprietà pubblica | Doc | Imposta/Restituisce il documento sul quale sono stati letti i dati documentali
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | ListAttrNameDiff | Restituisce la lista dei nomi degli attributi che hanno delle differenze di valore
Proprietà pubblica | ListRestrictedAttrNameUseDocValues | Permette di impostare una lista ristretta di nomi di attributi dei quali usare il valore del documento nel caso in cui sia a True la proprietà UseDocValues. Se l'attributo non è nella lista viene usato il valore del DB acnhe se UseDocValues è True.
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione (servono le due anagrafiche da confrontare). (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NeedToBeCompared | Viene impostata in base a true se il documento deve essere comparato. Può essere utile per testare la reale esigenza di effettuare la comparazione se il comando è lanciato in modalità test, ovvere UseUI = false
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseDocValues | Restituisce o imposta se vanno usati i valori del documento (di default è false e vengono mantenuti i dati presenti nel database).
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DbDocCompareCommand
Namespace DedNet.Commands


Proprietà DbDocCompareCommand.DataDB

Proprietà DbDocCompareCommandDataDB
Imposta o restituisce l'anagrafica presente nel Database da confrontare.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData DataDB { set; }
Public WriteOnly Property DataDB As DedData
    Set
public:
property DedData^ DataDB {
    void set (DedData^ value);
}
member DataDB : DedData with set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe DbDocCompareCommand
Namespace DedNet.Commands


Proprietà DbDocCompareCommand.DataDoc

Proprietà DbDocCompareCommandDataDoc
Imposta o restituisce l'anagrafica del documento da confrontare.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public IDedData DataDoc { set; }
Public WriteOnly Property DataDoc As IDedData
    Set
public:
property IDedData^ DataDoc {
    void set (IDedData^ value);
}
member DataDoc : IDedData with set

Valore della proprietà

IDedData
Vedi anche

Documentazione

Classe DbDocCompareCommand
Namespace DedNet.Commands


Proprietà DbDocCompareCommand.DataResult

Proprietà DbDocCompareCommandDataResult
Restituisce l'anagrafica risultatnte dal confronto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public IDedData DataResult { get; }
Public ReadOnly Property DataResult As IDedData
    Get
public:
property IDedData^ DataResult {
    IDedData^ get ();
}
member DataResult : IDedData with get

Valore della proprietà

IDedData
Vedi anche

Documentazione

Classe DbDocCompareCommand
Namespace DedNet.Commands


Proprietà DbDocCompareCommand.Doc

Proprietà DbDocCompareCommandDoc
Imposta/Restituisce il documento sul quale sono stati letti i dati documentali

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDoc Doc { get; set; }
Public Property Doc As DedDoc
    Get
    Set
public:
property DedDoc^ Doc {
    DedDoc^ get ();
    void set (DedDoc^ value);
}
member Doc : DedDoc with get, set

Valore della proprietà

DedDoc
Vedi anche

Documentazione

Classe DbDocCompareCommand
Namespace DedNet.Commands


Proprietà DbDocCompareCommand.ListAttrNameDiff

Proprietà DbDocCompareCommandListAttrNameDiff
Restituisce la lista dei nomi degli attributi che hanno delle differenze di valore

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> ListAttrNameDiff { get; }
Public ReadOnly Property ListAttrNameDiff As List(Of String)
    Get
public:
property List<String^>^ ListAttrNameDiff {
    List<String^>^ get ();
}
member ListAttrNameDiff : List<string> with get

Valore della proprietà

List String
Vedi anche

Documentazione

Classe DbDocCompareCommand
Namespace DedNet.Commands


Proprietà DbDocCompareCommand.ListRestrictedAttrNameUseDocValues

Proprietà DbDocCompareCommandListRestrictedAttrNameUseDocValues
Permette di impostare una lista ristretta di nomi di attributi dei quali usare il valore del documento nel caso in cui sia a True la proprietà UseDocValues. Se l'attributo non è nella lista viene usato il valore del DB acnhe se UseDocValues è True.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> ListRestrictedAttrNameUseDocValues { set; }
Public WriteOnly Property ListRestrictedAttrNameUseDocValues As List(Of String)
    Set
public:
property List<String^>^ ListRestrictedAttrNameUseDocValues {
    void set (List<String^>^ value);
}
member ListRestrictedAttrNameUseDocValues : List<string> with set

Valore della proprietà

List String
Vedi anche

Documentazione

Classe DbDocCompareCommand
Namespace DedNet.Commands


Proprietà DbDocCompareCommand.NeedParameters

Proprietà DbDocCompareCommandNeedParameters
Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione (servono le due anagrafiche da confrontare).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DbDocCompareCommand
Namespace DedNet.Commands


Proprietà DbDocCompareCommand.NeedToBeCompared

Proprietà DbDocCompareCommandNeedToBeCompared
Viene impostata in base a true se il documento deve essere comparato. Può essere utile per testare la reale esigenza di effettuare la comparazione se il comando è lanciato in modalità test, ovvere UseUI = false

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool NeedToBeCompared { get; }
Public ReadOnly Property NeedToBeCompared As Boolean
    Get
public:
property bool NeedToBeCompared {
    bool get ();
}
member NeedToBeCompared : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DbDocCompareCommand
Namespace DedNet.Commands


Proprietà DbDocCompareCommand.UseDocValues

Proprietà DbDocCompareCommandUseDocValues
Restituisce o imposta se vanno usati i valori del documento (di default è false e vengono mantenuti i dati presenti nel database).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool UseDocValues { set; }
Public WriteOnly Property UseDocValues As Boolean
    Set
public:
property bool UseDocValues {
    void set (bool value);
}
member UseDocValues : bool with set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DbDocCompareCommand
Namespace DedNet.Commands


Metodi di DbDocCompareCommand

Il tipo DbDocCompareCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Esegue la pulizia del comando. Azzera tutte le variabili. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DbDocCompareCommand
Namespace DedNet.Commands


Metodo DbDocCompareCommand.ClearCommand

Metodo DbDocCompareCommandClearCommand
Esegue la pulizia del comando. Azzera tutte le variabili.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe DbDocCompareCommand
Namespace DedNet.Commands


Metodo DbDocCompareCommand.Enabled

Metodo DbDocCompareCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe DbDocCompareCommand
Namespace DedNet.Commands


Metodo DbDocCompareCommand.ExecuteCommand

Metodo DbDocCompareCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe DbDocCompareCommand
Namespace DedNet.Commands


Metodo DbDocCompareCommand.SetContext

Metodo DbDocCompareCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe DbDocCompareCommand
Namespace DedNet.Commands


Classe DbVersionCommand
Classe che rappresenta il comando per editare gli utenti e i permessi.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsDbVersionCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DbVersionCommand : DedCommand
Public Class DbVersionCommand
    Inherits DedCommand
public ref class DbVersionCommand : public DedCommand
type DbVersionCommand =
    class
        inherit DedCommand
    end

Il tipo DbVersionCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | ActivateTabUpdate | Indica di attivare la tab di aggiornamento DB.
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowBackupTables |
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di DbVersionCommand

Il tipo DbVersionCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | ActivateTabUpdate | Indica di attivare la tab di aggiornamento DB.
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowBackupTables |
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DbVersionCommand
Namespace DedNet.Commands


Proprietà DbVersionCommand.ActivateTabUpdate

Proprietà DbVersionCommandActivateTabUpdate
Indica di attivare la tab di aggiornamento DB.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ActivateTabUpdate { get; set; }
Public Property ActivateTabUpdate As Boolean
    Get
    Set
public:
property bool ActivateTabUpdate {
    bool get ();
    void set (bool value);
}
member ActivateTabUpdate : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DbVersionCommand
Namespace DedNet.Commands


Proprietà DbVersionCommand.NeedParameters

Proprietà DbVersionCommandNeedParameters

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DbVersionCommand
Namespace DedNet.Commands


Proprietà DbVersionCommand.ShowBackupTables

Proprietà DbVersionCommandShowBackupTables

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ShowBackupTables { get; set; }
Public Property ShowBackupTables As Boolean
    Get
    Set
public:
property bool ShowBackupTables {
    bool get ();
    void set (bool value);
}
member ShowBackupTables : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DbVersionCommand
Namespace DedNet.Commands


Metodi di DbVersionCommand

Il tipo DbVersionCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DbVersionCommand
Namespace DedNet.Commands


Metodo DbVersionCommand.ClearCommand

Metodo DbVersionCommandClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe DbVersionCommand
Namespace DedNet.Commands


Metodo DbVersionCommand.Enabled

Metodo DbVersionCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe DbVersionCommand
Namespace DedNet.Commands


Metodo DbVersionCommand.ExecuteCommand

Metodo DbVersionCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe DbVersionCommand
Namespace DedNet.Commands


Metodo DbVersionCommand.SetContext

Metodo DbVersionCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe DbVersionCommand
Namespace DedNet.Commands


Classe DedAboutCommand
Classe che rappresente il comando per visualizzare l'about del DED.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsDedAboutCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedAboutCommand : DedCommand
Public Class DedAboutCommand
    Inherits DedCommand
public ref class DedAboutCommand : public DedCommand
type DedAboutCommand =
    class
        inherit DedCommand
    end

Il tipo DedAboutCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di DedAboutCommand

Il tipo DedAboutCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DedAboutCommand
Namespace DedNet.Commands


Proprietà DedAboutCommand.NeedParameters

Proprietà DedAboutCommandNeedParameters

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAboutCommand
Namespace DedNet.Commands


Metodi di DedAboutCommand

Il tipo DedAboutCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DedAboutCommand
Namespace DedNet.Commands


Metodo DedAboutCommand.ClearCommand

Metodo DedAboutCommandClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe DedAboutCommand
Namespace DedNet.Commands


Metodo DedAboutCommand.Enabled

Metodo DedAboutCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe DedAboutCommand
Namespace DedNet.Commands


Metodo DedAboutCommand.ExecuteCommand

Metodo DedAboutCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe DedAboutCommand
Namespace DedNet.Commands


Metodo DedAboutCommand.SetContext

Metodo DedAboutCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe DedAboutCommand
Namespace DedNet.Commands


Classe DedBomEditFormButtonCommand
Classe per gestire i button personalizzati nelle tendine del form editor delle distinte
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedBomEditFormCommandBase
DedNet.CommandsDedBomEditFormButtonCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedBomEditFormButtonCommand : DedBomEditFormCommandBase
Public Class DedBomEditFormButtonCommand
    Inherits DedBomEditFormCommandBase
public ref class DedBomEditFormButtonCommand : public DedBomEditFormCommandBase
type DedBomEditFormButtonCommand =
    class
        inherit DedBomEditFormCommandBase
    end

Il tipo DedBomEditFormButtonCommand espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedBomEditFormButtonCommand | Costruttore Button
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | App | (Ereditato da DedBomEditFormCommandBase)
Proprietà pubblica | BeginGroup | (Ereditato da DedBomEditFormCommandBase)
Proprietà pubblica | ImagePath | (Ereditato da DedBomEditFormCommandBase)
Proprietà pubblica | MenuName | (Ereditato da DedBomEditFormCommandBase)
Proprietà pubblica | Name | (Ereditato da DedBomEditFormCommandBase)
Proprietà pubblica | Prompt | (Ereditato da DedBomEditFormCommandBase)
Proprietà pubblica | Tooltip | (Ereditato da DedBomEditFormCommandBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Clone | Returns a new copy of the object. (Sovrascrive DedBomEditFormCommandBaseClone)
Metodo pubblico | CreateMenuItem | Create a new BarItem object to be add to menu. (Sovrascrive DedBomEditFormCommandBaseCreateMenuItem)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Costruttore DedBomEditFormButtonCommand
Costruttore Button

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedBomEditFormButtonCommand(
    DedNetApplication app,
    string name,
    string prompt,
    string tooltip,
    string imagePath
)
Public Sub New (
    app As DedNetApplication,
    name As String,
    prompt As String,
    tooltip As String,
    imagePath As String
)
public:
DedBomEditFormButtonCommand(
    DedNetApplication^ app,
    String^ name,
    String^ prompt,
    String^ tooltip,
    String^ imagePath
)
new :
        app : DedNetApplication *
        name : string *
        prompt : string *
        tooltip : string *
        imagePath : string -> DedBomEditFormButtonCommand

Parametri

app DedNetApplication
name String
prompt String
tooltip String
imagePath String
Vedi anche

Documentazione

Classe DedBomEditFormButtonCommand
Namespace DedNet.Commands


Proprietà di DedBomEditFormButtonCommand

Il tipo DedBomEditFormButtonCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | App | (Ereditato da DedBomEditFormCommandBase)
Proprietà pubblica | BeginGroup | (Ereditato da DedBomEditFormCommandBase)
Proprietà pubblica | ImagePath | (Ereditato da DedBomEditFormCommandBase)
Proprietà pubblica | MenuName | (Ereditato da DedBomEditFormCommandBase)
Proprietà pubblica | Name | (Ereditato da DedBomEditFormCommandBase)
Proprietà pubblica | Prompt | (Ereditato da DedBomEditFormCommandBase)
Proprietà pubblica | Tooltip | (Ereditato da DedBomEditFormCommandBase)
Torna su
Vedi anche

Documentazione

Classe DedBomEditFormButtonCommand
Namespace DedNet.Commands


Metodi di DedBomEditFormButtonCommand

Il tipo DedBomEditFormButtonCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Clone | Returns a new copy of the object. (Sovrascrive DedBomEditFormCommandBaseClone)
Metodo pubblico | CreateMenuItem | Create a new BarItem object to be add to menu. (Sovrascrive DedBomEditFormCommandBaseCreateMenuItem)
Torna su
Vedi anche

Documentazione

Classe DedBomEditFormButtonCommand
Namespace DedNet.Commands


Metodo DedBomEditFormButtonCommand.Clone

Metodo DedBomEditFormButtonCommandClone
Returns a new copy of the object.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override DedBomEditFormCommandBase Clone()
Public Overrides Function Clone As DedBomEditFormCommandBase
public:
virtual DedBomEditFormCommandBase^ Clone() override
abstract Clone : unit -> DedBomEditFormCommandBase
override Clone : unit -> DedBomEditFormCommandBase

Valore di ritorno

DedBomEditFormCommandBase
Vedi anche

Documentazione

Classe DedBomEditFormButtonCommand
Namespace DedNet.Commands


Metodo DedBomEditFormButtonCommand.CreateMenuItem

Metodo DedBomEditFormButtonCommandCreateMenuItem
Create a new BarItem object to be add to menu.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override BarItem CreateMenuItem()
Public Overrides Function CreateMenuItem As BarItem
public:
virtual BarItem^ CreateMenuItem() override
abstract CreateMenuItem : unit -> BarItem
override CreateMenuItem : unit -> BarItem

Valore di ritorno

BarItem
Vedi anche

Documentazione

Classe DedBomEditFormButtonCommand
Namespace DedNet.Commands


Classe DedBomEditFormCommandBase
Classe per gestire i comandi personalizzati nelle tendine del form editor delle distinte
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedBomEditFormCommandBase
DedNet.CommandsDedBomEditFormButtonCommand
DedNet.CommandsDedBomEditFormToggleCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public abstract class DedBomEditFormCommandBase
Public MustInherit Class DedBomEditFormCommandBase
public ref class DedBomEditFormCommandBase abstract
[<AbstractClassAttribute>]
type DedBomEditFormCommandBase = class end

Il tipo DedBomEditFormCommandBase espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo protetto | DedBomEditFormCommandBase | Csotruttore command base
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | App |
Proprietà pubblica | BeginGroup |
Proprietà pubblica | ImagePath |
Proprietà pubblica | MenuName |
Proprietà pubblica | Name |
Proprietà pubblica | Prompt |
Proprietà pubblica | Tooltip |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Clone | Returns a new copy of the object.
Metodo pubblico | CreateMenuItem | Create a new BarItem object to be add to menu.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Costruttore DedBomEditFormCommandBase
Csotruttore command base

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected DedBomEditFormCommandBase(
    DedNetApplication app,
    string name,
    string prompt,
    string tooltip,
    string imagePath
)
Protected Sub New (
    app As DedNetApplication,
    name As String,
    prompt As String,
    tooltip As String,
    imagePath As String
)
protected:
DedBomEditFormCommandBase(
    DedNetApplication^ app,
    String^ name,
    String^ prompt,
    String^ tooltip,
    String^ imagePath
)
new :
        app : DedNetApplication *
        name : string *
        prompt : string *
        tooltip : string *
        imagePath : string -> DedBomEditFormCommandBase

Parametri

app DedNetApplication
name String
prompt String
tooltip String
imagePath String
Vedi anche

Documentazione

Classe DedBomEditFormCommandBase
Namespace DedNet.Commands


Proprietà di DedBomEditFormCommandBase

Il tipo DedBomEditFormCommandBase espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | App |
Proprietà pubblica | BeginGroup |
Proprietà pubblica | ImagePath |
Proprietà pubblica | MenuName |
Proprietà pubblica | Name |
Proprietà pubblica | Prompt |
Proprietà pubblica | Tooltip |
Torna su
Vedi anche

Documentazione

Classe DedBomEditFormCommandBase
Namespace DedNet.Commands


Proprietà DedBomEditFormCommandBase.App

Proprietà DedBomEditFormCommandBaseApp

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedNetApplication App { get; set; }
Public Property App As DedNetApplication
    Get
    Set
public:
property DedNetApplication^ App {
    DedNetApplication^ get ();
    void set (DedNetApplication^ value);
}
member App : DedNetApplication with get, set

Valore della proprietà

DedNetApplication
Vedi anche

Documentazione

Classe DedBomEditFormCommandBase
Namespace DedNet.Commands


Proprietà DedBomEditFormCommandBase.BeginGroup

Proprietà DedBomEditFormCommandBaseBeginGroup

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool BeginGroup { get; set; }
Public Property BeginGroup As Boolean
    Get
    Set
public:
property bool BeginGroup {
    bool get ();
    void set (bool value);
}
member BeginGroup : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedBomEditFormCommandBase
Namespace DedNet.Commands


Proprietà DedBomEditFormCommandBase.ImagePath

Proprietà DedBomEditFormCommandBaseImagePath

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string ImagePath { get; set; }
Public Property ImagePath As String
    Get
    Set
public:
property String^ ImagePath {
    String^ get ();
    void set (String^ value);
}
member ImagePath : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedBomEditFormCommandBase
Namespace DedNet.Commands


Proprietà DedBomEditFormCommandBase.MenuName

Proprietà DedBomEditFormCommandBaseMenuName

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string MenuName { get; set; }
Public Property MenuName As String
    Get
    Set
public:
property String^ MenuName {
    String^ get ();
    void set (String^ value);
}
member MenuName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedBomEditFormCommandBase
Namespace DedNet.Commands


Proprietà DedBomEditFormCommandBase.Name

Proprietà DedBomEditFormCommandBaseName

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedBomEditFormCommandBase
Namespace DedNet.Commands


Proprietà DedBomEditFormCommandBase.Prompt

Proprietà DedBomEditFormCommandBasePrompt

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Prompt { get; set; }
Public Property Prompt As String
    Get
    Set
public:
property String^ Prompt {
    String^ get ();
    void set (String^ value);
}
member Prompt : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedBomEditFormCommandBase
Namespace DedNet.Commands


Proprietà DedBomEditFormCommandBase.Tooltip

Proprietà DedBomEditFormCommandBaseTooltip

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Tooltip { get; set; }
Public Property Tooltip As String
    Get
    Set
public:
property String^ Tooltip {
    String^ get ();
    void set (String^ value);
}
member Tooltip : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedBomEditFormCommandBase
Namespace DedNet.Commands


Metodi di DedBomEditFormCommandBase

Il tipo DedBomEditFormCommandBase espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Clone | Returns a new copy of the object.
Metodo pubblico | CreateMenuItem | Create a new BarItem object to be add to menu.
Torna su
Vedi anche

Documentazione

Classe DedBomEditFormCommandBase
Namespace DedNet.Commands


Metodo DedBomEditFormCommandBase.Clone

Metodo DedBomEditFormCommandBaseClone
Returns a new copy of the object.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public abstract DedBomEditFormCommandBase Clone()
Public MustOverride Function Clone As DedBomEditFormCommandBase
public:
virtual DedBomEditFormCommandBase^ Clone() abstract
abstract Clone : unit -> DedBomEditFormCommandBase

Valore di ritorno

DedBomEditFormCommandBase
Vedi anche

Documentazione

Classe DedBomEditFormCommandBase
Namespace DedNet.Commands


Metodo DedBomEditFormCommandBase.CreateMenuItem

Metodo DedBomEditFormCommandBaseCreateMenuItem
Create a new BarItem object to be add to menu.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public abstract BarItem CreateMenuItem()
Public MustOverride Function CreateMenuItem As BarItem
public:
virtual BarItem^ CreateMenuItem() abstract
abstract CreateMenuItem : unit -> BarItem

Valore di ritorno

BarItem
Vedi anche

Documentazione

Classe DedBomEditFormCommandBase
Namespace DedNet.Commands


Classe DedBomEditFormCommandList
Lista di oggetti DedBomEditFormCommand.
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList DedBomEditFormCommandBase
DedNet.CommandsDedBomEditFormCommandList

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedBomEditFormCommandList : List<DedBomEditFormCommandBase>
Public Class DedBomEditFormCommandList
    Inherits List(Of DedBomEditFormCommandBase)
public ref class DedBomEditFormCommandList : public List<DedBomEditFormCommandBase^>
type DedBomEditFormCommandList =
    class
        inherit List<DedBomEditFormCommandBase>
    end

Il tipo DedBomEditFormCommandList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedBomEditFormCommandList |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Costruttore DedBomEditFormCommandList

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedBomEditFormCommandList()
Public Sub New
public:
DedBomEditFormCommandList()
new : unit -> DedBomEditFormCommandList
Vedi anche

Documentazione

Classe DedBomEditFormCommandList
Namespace DedNet.Commands


Classe DedBomEditFormToggleCommand
Classe per gestire i toggle personalizzati nelle tendine del form editor delle distinte
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedBomEditFormCommandBase
DedNet.CommandsDedBomEditFormToggleCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedBomEditFormToggleCommand : DedBomEditFormCommandBase
Public Class DedBomEditFormToggleCommand
    Inherits DedBomEditFormCommandBase
public ref class DedBomEditFormToggleCommand : public DedBomEditFormCommandBase
type DedBomEditFormToggleCommand =
    class
        inherit DedBomEditFormCommandBase
    end

Il tipo DedBomEditFormToggleCommand espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedBomEditFormToggleCommand | Costruttore Button
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | App | (Ereditato da DedBomEditFormCommandBase)
Proprietà pubblica | BeginGroup | (Ereditato da DedBomEditFormCommandBase)
Proprietà pubblica | ImagePath | (Ereditato da DedBomEditFormCommandBase)
Proprietà pubblica | MenuName | (Ereditato da DedBomEditFormCommandBase)
Proprietà pubblica | Name | (Ereditato da DedBomEditFormCommandBase)
Proprietà pubblica | Prompt | (Ereditato da DedBomEditFormCommandBase)
Proprietà pubblica | Tooltip | (Ereditato da DedBomEditFormCommandBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Clone | Returns a new copy of the object. (Sovrascrive DedBomEditFormCommandBaseClone)
Metodo pubblico | CreateMenuItem | Create a new BarItem object to be add to menu. (Sovrascrive DedBomEditFormCommandBaseCreateMenuItem)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Costruttore DedBomEditFormToggleCommand
Costruttore Button

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedBomEditFormToggleCommand(
    DedNetApplication app,
    string name,
    string prompt,
    string tooltip,
    string imagePath,
    bool ischecked
)
Public Sub New (
    app As DedNetApplication,
    name As String,
    prompt As String,
    tooltip As String,
    imagePath As String,
    ischecked As Boolean
)
public:
DedBomEditFormToggleCommand(
    DedNetApplication^ app,
    String^ name,
    String^ prompt,
    String^ tooltip,
    String^ imagePath,
    bool ischecked
)
new :
        app : DedNetApplication *
        name : string *
        prompt : string *
        tooltip : string *
        imagePath : string *
        ischecked : bool -> DedBomEditFormToggleCommand

Parametri

app DedNetApplication
name String
prompt String
tooltip String
imagePath String
ischecked Boolean
Vedi anche

Documentazione

Classe DedBomEditFormToggleCommand
Namespace DedNet.Commands


Proprietà di DedBomEditFormToggleCommand

Il tipo DedBomEditFormToggleCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | App | (Ereditato da DedBomEditFormCommandBase)
Proprietà pubblica | BeginGroup | (Ereditato da DedBomEditFormCommandBase)
Proprietà pubblica | ImagePath | (Ereditato da DedBomEditFormCommandBase)
Proprietà pubblica | MenuName | (Ereditato da DedBomEditFormCommandBase)
Proprietà pubblica | Name | (Ereditato da DedBomEditFormCommandBase)
Proprietà pubblica | Prompt | (Ereditato da DedBomEditFormCommandBase)
Proprietà pubblica | Tooltip | (Ereditato da DedBomEditFormCommandBase)
Torna su
Vedi anche

Documentazione

Classe DedBomEditFormToggleCommand
Namespace DedNet.Commands


Metodi di DedBomEditFormToggleCommand

Il tipo DedBomEditFormToggleCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Clone | Returns a new copy of the object. (Sovrascrive DedBomEditFormCommandBaseClone)
Metodo pubblico | CreateMenuItem | Create a new BarItem object to be add to menu. (Sovrascrive DedBomEditFormCommandBaseCreateMenuItem)
Torna su
Vedi anche

Documentazione

Classe DedBomEditFormToggleCommand
Namespace DedNet.Commands


Metodo DedBomEditFormToggleCommand.Clone

Metodo DedBomEditFormToggleCommandClone
Returns a new copy of the object.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override DedBomEditFormCommandBase Clone()
Public Overrides Function Clone As DedBomEditFormCommandBase
public:
virtual DedBomEditFormCommandBase^ Clone() override
abstract Clone : unit -> DedBomEditFormCommandBase
override Clone : unit -> DedBomEditFormCommandBase

Valore di ritorno

DedBomEditFormCommandBase
Vedi anche

Documentazione

Classe DedBomEditFormToggleCommand
Namespace DedNet.Commands


Metodo DedBomEditFormToggleCommand.CreateMenuItem

Metodo DedBomEditFormToggleCommandCreateMenuItem
Create a new BarItem object to be add to menu.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override BarItem CreateMenuItem()
Public Overrides Function CreateMenuItem As BarItem
public:
virtual BarItem^ CreateMenuItem() override
abstract CreateMenuItem : unit -> BarItem
override CreateMenuItem : unit -> BarItem

Valore di ritorno

BarItem
Vedi anche

Documentazione

Classe DedBomEditFormToggleCommand
Namespace DedNet.Commands


Classe DedBomExplorerCtrlCommand
Classe per gestire i comandi personalizzati dei controlli explorer nell'editor delle distinte
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedBomExplorerCtrlCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedBomExplorerCtrlCommand
Public Class DedBomExplorerCtrlCommand
public ref class DedBomExplorerCtrlCommand
type DedBomExplorerCtrlCommand = class end

Il tipo DedBomExplorerCtrlCommand espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedBomExplorerCtrlCommand |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Behaviour |
Proprietà pubblica | ImagePath |
Proprietà pubblica | Name |
Proprietà pubblica | Prompt |
Proprietà pubblica | SmallWithoutTextWidth |
Proprietà pubblica | ToolStripItem |
Proprietà pubblica | Tooltip |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Costruttore DedBomExplorerCtrlCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedBomExplorerCtrlCommand(
    DedNetApplication app,
    string name,
    string prompt,
    string tooltip,
    string imagePath,
    DedBomExplorerControlDedBomExplorerBehaviourEnum behaviour
)
Public Sub New (
    app As DedNetApplication,
    name As String,
    prompt As String,
    tooltip As String,
    imagePath As String,
    behaviour As DedBomExplorerControlDedBomExplorerBehaviourEnum
)
public:
DedBomExplorerCtrlCommand(
    DedNetApplication^ app,
    String^ name,
    String^ prompt,
    String^ tooltip,
    String^ imagePath,
    DedBomExplorerControlDedBomExplorerBehaviourEnum behaviour
)
new :
        app : DedNetApplication *
        name : string *
        prompt : string *
        tooltip : string *
        imagePath : string *
        behaviour : DedBomExplorerControlDedBomExplorerBehaviourEnum -> DedBomExplorerCtrlCommand

Parametri

app DedNetApplication
name String
prompt String
tooltip String
imagePath String
behaviour DedBomExplorerControlDedBomExplorerBehaviourEnum
Vedi anche

Documentazione

Classe DedBomExplorerCtrlCommand
Namespace DedNet.Commands


Proprietà di DedBomExplorerCtrlCommand

Il tipo DedBomExplorerCtrlCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Behaviour |
Proprietà pubblica | ImagePath |
Proprietà pubblica | Name |
Proprietà pubblica | Prompt |
Proprietà pubblica | SmallWithoutTextWidth |
Proprietà pubblica | ToolStripItem |
Proprietà pubblica | Tooltip |
Torna su
Vedi anche

Documentazione

Classe DedBomExplorerCtrlCommand
Namespace DedNet.Commands


Proprietà DedBomExplorerCtrlCommand.Behaviour

Proprietà DedBomExplorerCtrlCommandBehaviour

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedBomExplorerControlDedBomExplorerBehaviourEnum Behaviour { get; set; }
Public Property Behaviour As DedBomExplorerControlDedBomExplorerBehaviourEnum
    Get
    Set
public:
property DedBomExplorerControlDedBomExplorerBehaviourEnum Behaviour {
    DedBomExplorerControlDedBomExplorerBehaviourEnum get ();
    void set (DedBomExplorerControlDedBomExplorerBehaviourEnum value);
}
member Behaviour : DedBomExplorerControlDedBomExplorerBehaviourEnum with get, set

Valore della proprietà

DedBomExplorerControlDedBomExplorerBehaviourEnum
Vedi anche

Documentazione

Classe DedBomExplorerCtrlCommand
Namespace DedNet.Commands


Proprietà DedBomExplorerCtrlCommand.ImagePath

Proprietà DedBomExplorerCtrlCommandImagePath

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string ImagePath { get; set; }
Public Property ImagePath As String
    Get
    Set
public:
property String^ ImagePath {
    String^ get ();
    void set (String^ value);
}
member ImagePath : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedBomExplorerCtrlCommand
Namespace DedNet.Commands


Proprietà DedBomExplorerCtrlCommand.Name

Proprietà DedBomExplorerCtrlCommandName

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedBomExplorerCtrlCommand
Namespace DedNet.Commands


Proprietà DedBomExplorerCtrlCommand.Prompt

Proprietà DedBomExplorerCtrlCommandPrompt

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Prompt { get; set; }
Public Property Prompt As String
    Get
    Set
public:
property String^ Prompt {
    String^ get ();
    void set (String^ value);
}
member Prompt : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedBomExplorerCtrlCommand
Namespace DedNet.Commands


Proprietà DedBomExplorerCtrlCommand.SmallWithoutTextWidth

Proprietà DedBomExplorerCtrlCommandSmallWithoutTextWidth

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int SmallWithoutTextWidth { get; set; }
Public Property SmallWithoutTextWidth As Integer
    Get
    Set
public:
property int SmallWithoutTextWidth {
    int get ();
    void set (int value);
}
member SmallWithoutTextWidth : int with get, set

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe DedBomExplorerCtrlCommand
Namespace DedNet.Commands


Proprietà DedBomExplorerCtrlCommand.ToolStripItem

Proprietà DedBomExplorerCtrlCommandToolStripItem

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BarItem ToolStripItem { get; }
Public ReadOnly Property ToolStripItem As BarItem
    Get
public:
property BarItem^ ToolStripItem {
    BarItem^ get ();
}
member ToolStripItem : BarItem with get

Valore della proprietà

BarItem
Vedi anche

Documentazione

Classe DedBomExplorerCtrlCommand
Namespace DedNet.Commands


Proprietà DedBomExplorerCtrlCommand.Tooltip

Proprietà DedBomExplorerCtrlCommandTooltip

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Tooltip { get; set; }
Public Property Tooltip As String
    Get
    Set
public:
property String^ Tooltip {
    String^ get ();
    void set (String^ value);
}
member Tooltip : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedBomExplorerCtrlCommand
Namespace DedNet.Commands


Classe DedBomExplorerCtrlCommandList
Lista di oggetti DedBomExplorerCtrlCommand.
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList DedBomExplorerCtrlCommand
DedNet.CommandsDedBomExplorerCtrlCommandList

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedBomExplorerCtrlCommandList : List<DedBomExplorerCtrlCommand>
Public Class DedBomExplorerCtrlCommandList
    Inherits List(Of DedBomExplorerCtrlCommand)
public ref class DedBomExplorerCtrlCommandList : public List<DedBomExplorerCtrlCommand^>
type DedBomExplorerCtrlCommandList =
    class
        inherit List<DedBomExplorerCtrlCommand>
    end

Il tipo DedBomExplorerCtrlCommandList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedBomExplorerCtrlCommandList |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Costruttore DedBomExplorerCtrlCommandList

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedBomExplorerCtrlCommandList()
Public Sub New
public:
DedBomExplorerCtrlCommandList()
new : unit -> DedBomExplorerCtrlCommandList
Vedi anche

Documentazione

Classe DedBomExplorerCtrlCommandList
Namespace DedNet.Commands


Enumerazione DedCmdResult
Enumerazione dei risultati di un comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum DedCmdResult
Public Enumeration DedCmdResult
public enum class DedCmdResult
type DedCmdResult
Membri
Nome | Valore | Descrizione
None | 0 | Non assegnato.
Success | 1 | Terminato con successo.
UserCancelled | 2 | Cancellato dall'utente.
InputDataMissing | 3 | Dati mancanti in ingresso al comando.
Handled | 4 | Soppiantato da codice (tramite un evento).
Cancelled | 5 | Interrotto da codice (tramite un evento).
Error | 6 | E' avvenuto un errore.
Vedi anche

Documentazione

Namespace DedNet.Commands


Classe DedCommand
Classe base dalla quale derivare ogni comando dell'applicazione.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
Altro

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public abstract class DedCommand
Public MustInherit Class DedCommand
public ref class DedCommand abstract
[<AbstractClassAttribute>]
type DedCommand = class end

Il tipo DedCommand espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedCommand | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene.
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile.
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name.
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000.
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help.
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente.
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando.
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando.
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale.
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto.
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori.
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando.
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando.
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento.
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione.
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh.
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela.
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate.
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione.
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente.
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false.
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando.
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando.
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando.
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help.
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Esegue la pulizia del comando. Azzera tutte le variabili.
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. Da fare l'override nelle classi derivate.
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo.
Metodo pubblico | Run | Esegue il comando.
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. ///
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsAddCommCommand
DedNet.CommandsAddEcoCommand
DedNet.CommandsAddRemoveRecurrentTiming
DedNet.CommandsAnnullaCheckOutDocument
DedNet.CommandsAssignEcoToSpecificUserCommand
DedNet.CommandsAssociateAlternativeDataCommand
DedNet.CommandsAssociateDocument
DedNet.CommandsChangeEcoStateCommand
DedNet.CommandsChangePasswordCommand
DedNet.CommandsChargeCommCommand
DedNet.CommandsCheckInDocument
DedNet.CommandsCheckOutDocument
DedNet.CommandsChmHelpCommand
DedNet.CommandsCloseCommCommand
DedNet.CommandsCommEsplCommand
DedNet.CommandsCopyDocument
DedNet.CommandsCreateDocument
DedNet.CommandsCreateEditSparePartsAttributesCommand
DedNet.CommandsCreateFolder
DedNet.CommandsCreateManualCommand
DedNet.CommandsCreateSparePartsDrawingCommand
DedNet.CommandsDataStatisticsAnalyzer
DedNet.CommandsDbDocCompareCommand
DedNet.CommandsDbVersionCommand
DedNet.CommandsDedAboutCommand
DedNet.CommandsDedDataCommand
DedNet.CommandsDedDocumentCommand
DedNet.CommandsDedListEditCommand
DedNet.CommandsDedListManagerCommand
DedNet.CommandsDedStateCommand
DedNet.CommandsDeleteCommCommand
DedNet.CommandsDeleteEcoCommand
DedNet.CommandsDeleteFolder
DedNet.CommandsDisconnectCommDocument
DedNet.CommandsDisconnectDocument
DedNet.CommandsDocAssocCommand
DedNet.CommandsDocRecognizerCommand
DedNet.CommandsDuplicateCommCommand
DedNet.CommandsEcoEditCommand
DedNet.CommandsEcoHistoryCommand
DedNet.CommandsEditAnagrCommandBase
DedNet.CommandsEditCommCommand
DedNet.CommandsEditEcoCommand
DedNet.CommandsEditOnlyDbAttributesCommand
DedNet.CommandsEndAllActiveTimingsCommand
DedNet.CommandsEnsureLocalDocument
DedNet.CommandsEnsureLocalFolder
DedNet.CommandsExportCommand
DedNet.CommandsExportDocument
DedNet.CommandsFillDedDataEncodeTableCommand
DedNet.CommandsFindCodeCommand
DedNet.CommandsFindCommand
DedNet.CommandsFindDocCommand
DedNet.CommandsForzaCheckInDocument
DedNet.CommandsImportCommDocument
DedNet.CommandsImportDocument
DedNet.CommandsImportEcoFiles
DedNet.CommandsImporterCommand
DedNet.CommandsImportTransferPacket
DedNet.CommandsLiberateCommCommand
DedNet.CommandsLinkCommDocument
DedNet.CommandsLinkDocument
DedNet.CommandsLoginCommand
DedNet.CommandsLogViewCommand
DedNet.CommandsManageOperationsCommand
DedNet.CommandsMovedEditorCommand
DedNet.CommandsMoveDocument
DedNet.CommandsNotifyCommand
DedNet.CommandsOpenAssocFilesCommand
DedNet.CommandsOpenCommCommand
DedNet.CommandsOpenFilePathCommand
DedNet.CommandsPrintDocumentCommand
DedNet.CommandsPropertiesManagerCommand
DedNet.CommandsPublicationFilesMangerCommand
DedNet.CommandsPublishDocument
DedNet.CommandsPwsBackupCommand
DedNet.CommandsPwsCacheCommand
DedNet.CommandsQsManagerCommand
DedNet.CommandsQsManagerCommCommand
DedNet.CommandsQsReserveProgCommand
DedNet.CommandsRecognaiseCommDocument
DedNet.CommandsRecognaiseDocument
DedNet.CommandsRemoveDocument
DedNet.CommandsRemoveEcoDocument
DedNet.CommandsRenameDocument
DedNet.CommandsRenameFolder
DedNet.CommandsReplaceDocument
DedNet.CommandsReplaceDocumentReference
DedNet.CommandsRevCommand
DedNet.CommandsRootManagerCommand
DedNet.CommandsSaveCommand
DedNet.CommandsSaveDistCommand
DedNet.CommandsSaveDistVariantCommand
DedNet.CommandsSaveSparePartsDistVariantCommand
DedNet.CommandsSbloccaDocument
DedNet.CommandsSendTransferPacket
DedNet.CommandsShowAllActiveTimingsCommand
DedNet.CommandsShowRecurrentTimingCommand
DedNet.CommandsShowSparePartsDistVariantCommand
DedNet.CommandsShowTimingCommand
DedNet.CommandsStateManagerCommand
DedNet.CommandsTimingCommand
DedNet.CommandsTranslationsMangerCommand
DedNet.CommandsUpdateDocument
DedNet.CommandsUpdateDocumentReference
DedNet.CommandsUpdateOldRevCommand
DedNet.CommandsUpdateSparePartsBoms
DedNet.CommandsUsersCommand
DedNet.CommandsVarsCommand
DedNet.CommandsViewCommCommand


Costruttore DedCommand
Costruttore unico.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommand(
    DedNetApplication app,
    string internalName,
    string name
)
Public Sub New (
    app As DedNetApplication,
    internalName As String,
    name As String
)
public:
DedCommand(
    DedNetApplication^ app,
    String^ internalName,
    String^ name
)
new :
        app : DedNetApplication *
        internalName : string *
        name : string -> DedCommand

Parametri

app DedNetApplication
Riferimento all'oggetto DedNetApplication.
internalName String
Nome interno del comando.
name String
Nome visualizzato del comando.
Vedi anche

Documentazione

Classe DedCommand
Namespace DedNet.Commands


Proprietà di DedCommand

Il tipo DedCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene.
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile.
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name.
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000.
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help.
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente.
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando.
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando.
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale.
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto.
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori.
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando.
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando.
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento.
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione.
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh.
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela.
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate.
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione.
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente.
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false.
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando.
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando.
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando.
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help.
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true.
Torna su
Vedi anche

Documentazione

Classe DedCommand
Namespace DedNet.Commands


Proprietà DedCommand.Application

Proprietà DedCommandApplication
Restituisce l'applicazione alla quale questo oggetto appartiene.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedNetApplication Application { get; }
Public ReadOnly Property Application As DedNetApplication
    Get
public:
property DedNetApplication^ Application {
    DedNetApplication^ get ();
}
member Application : DedNetApplication with get

Valore della proprietà

DedNetApplication
Vedi anche

Documentazione

Classe DedCommand
Namespace DedNet.Commands


Proprietà DedCommand.Client

Proprietà DedCommandClient
Restituisce o imposta le applicazioni client per le quali questo comando è disponibile.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual ClientApplicationEnum Client { get; set; }
Public Overridable Property Client As ClientApplicationEnum
    Get
    Set
public:
virtual property ClientApplicationEnum Client {
    ClientApplicationEnum get ();
    void set (ClientApplicationEnum value);
}
abstract Client : ClientApplicationEnum with get, set
override Client : ClientApplicationEnum with get, set

Valore della proprietà

ClientApplicationEnum
Vedi anche

Documentazione

Classe DedCommand
Namespace DedNet.Commands


Proprietà DedCommand.CommandContext

Proprietà DedCommandCommandContext
Restituisce o imposta il Contesto nel quale questo comando è disponibile.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual CommandContextEnum CommandContext { get; set; }
Public Overridable Property CommandContext As CommandContextEnum
    Get
    Set
public:
virtual property CommandContextEnum CommandContext {
    CommandContextEnum get ();
    void set (CommandContextEnum value);
}
abstract CommandContext : CommandContextEnum with get, set
override CommandContext : CommandContextEnum with get, set

Valore della proprietà

CommandContextEnum
Vedi anche

Documentazione

Classe DedCommand
Namespace DedNet.Commands


Proprietà DedCommand.GlobalName

Proprietà DedCommandGlobalName
Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string GlobalName { get; set; }
Public Property GlobalName As String
    Get
    Set
public:
property String^ GlobalName {
    String^ get ();
    void set (String^ value);
}
member GlobalName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedCommand
Namespace DedNet.Commands


Proprietà DedCommand.GlobalOrder

Proprietà DedCommandGlobalOrder
Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int GlobalOrder { get; set; }
Public Property GlobalOrder As Integer
    Get
    Set
public:
property int GlobalOrder {
    int get ();
    void set (int value);
}
member GlobalOrder : int with get, set

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe DedCommand
Namespace DedNet.Commands


Proprietà DedCommand.HasTopic

Proprietà DedCommandHasTopic
Restituisce o imposta il Topic per individuare il comando nell'Help.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasTopic { get; }
Public ReadOnly Property HasTopic As Boolean
    Get
public:
property bool HasTopic {
    bool get ();
}
member HasTopic : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedCommand
Namespace DedNet.Commands


Proprietà DedCommand.IgnoreUserPerm

Proprietà DedCommandIgnoreUserPerm
Indica di ignorare i permessi utente.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IgnoreUserPerm { get; set; }
Public Property IgnoreUserPerm As Boolean
    Get
    Set
public:
property bool IgnoreUserPerm {
    bool get ();
    void set (bool value);
}
member IgnoreUserPerm : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedCommand
Namespace DedNet.Commands


Proprietà DedCommand.Img16

Proprietà DedCommandImg16
Restituisce o imposta l'immagine 16x16 abbinata al comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual Image Img16 { get; set; }
Public Overridable Property Img16 As Image
    Get
    Set
public:
virtual property Image^ Img16 {
    Image^ get ();
    void set (Image^ value);
}
abstract Img16 : Image with get, set
override Img16 : Image with get, set

Valore della proprietà

Image
Vedi anche

Documentazione

Classe DedCommand
Namespace DedNet.Commands


Proprietà DedCommand.Img32

Proprietà DedCommandImg32
Restituisce o imposta l'immagine 32x32 abbinata al comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual Image Img32 { get; set; }
Public Overridable Property Img32 As Image
    Get
    Set
public:
virtual property Image^ Img32 {
    Image^ get ();
    void set (Image^ value);
}
abstract Img32 : Image with get, set
override Img32 : Image with get, set

Valore della proprietà

Image
Vedi anche

Documentazione

Classe DedCommand
Namespace DedNet.Commands


Proprietà DedCommand.InternalName

Proprietà DedCommandInternalName
Restituisce il nome interno del comando che non varia in base alla lingua locale.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual string InternalName { get; protected set; }
Public Overridable Property InternalName As String
    Get
    Protected Set
public:
virtual property String^ InternalName {
    String^ get ();
    protected: void set (String^ value);
}
abstract InternalName : string with get, set
override InternalName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedCommand
Namespace DedNet.Commands


Proprietà DedCommand.IsImportingOperation

Proprietà DedCommandIsImportingOperation
Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsImportingOperation { get; set; }
Public Property IsImportingOperation As Boolean
    Get
    Set
public:
property bool IsImportingOperation {
    bool get ();
    void set (bool value);
}
member IsImportingOperation : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedCommand
Namespace DedNet.Commands


Proprietà DedCommand.LastException

Proprietà DedCommandLastException
Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual Exception LastException { get; }
Public Overridable ReadOnly Property LastException As Exception
    Get
public:
virtual property Exception^ LastException {
    Exception^ get ();
}
abstract LastException : Exception with get
override LastException : Exception with get

Valore della proprietà

Exception
Vedi anche

Documentazione

Classe DedCommand
Namespace DedNet.Commands


Proprietà DedCommand.MinimumPerm

Proprietà DedCommandMinimumPerm
Restituisce o imposta il permesso minimo necessario per eseguire il comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual DedStandardPerm MinimumPerm { get; set; }
Public Overridable Property MinimumPerm As DedStandardPerm
    Get
    Set
public:
virtual property DedStandardPerm MinimumPerm {
    DedStandardPerm get ();
    void set (DedStandardPerm value);
}
abstract MinimumPerm : DedStandardPerm with get, set
override MinimumPerm : DedStandardPerm with get, set

Valore della proprietà

DedStandardPerm
Vedi anche

Documentazione

Classe DedCommand
Namespace DedNet.Commands


Proprietà DedCommand.Name

Proprietà DedCommandName
Restituisce il nome visualizzato del comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual string Name { get; protected set; }
Public Overridable Property Name As String
    Get
    Protected Set
public:
virtual property String^ Name {
    String^ get ();
    protected: void set (String^ value);
}
abstract Name : string with get, set
override Name : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedCommand
Namespace DedNet.Commands


Proprietà DedCommand.NeedDocument

Proprietà DedCommandNeedDocument
Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual bool NeedDocument { get; protected set; }
Public Overridable Property NeedDocument As Boolean
    Get
    Protected Set
public:
virtual property bool NeedDocument {
    bool get ();
    protected: void set (bool value);
}
abstract NeedDocument : bool with get, set
override NeedDocument : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedCommand
Namespace DedNet.Commands


Proprietà DedCommand.NeedParameters

Proprietà DedCommandNeedParameters
Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public abstract bool NeedParameters { get; }
Public MustOverride ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () abstract;
}
abstract NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedCommand
Namespace DedNet.Commands


Proprietà DedCommand.NeedRefresh

Proprietà DedCommandNeedRefresh
Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual bool NeedRefresh { get; set; }
Public Overridable Property NeedRefresh As Boolean
    Get
    Set
public:
virtual property bool NeedRefresh {
    bool get ();
    void set (bool value);
}
abstract NeedRefresh : bool with get, set
override NeedRefresh : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedCommand
Namespace DedNet.Commands


Proprietà DedCommand.NoOwnerForm

Proprietà DedCommandNoOwnerForm
Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool NoOwnerForm { get; set; }
Public Property NoOwnerForm As Boolean
    Get
    Set
public:
property bool NoOwnerForm {
    bool get ();
    void set (bool value);
}
member NoOwnerForm : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedCommand
Namespace DedNet.Commands


Proprietà DedCommand.OwnerForm

Proprietà DedCommandOwnerForm
Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public IWin32Window OwnerForm { get; set; }
Public Property OwnerForm As IWin32Window
    Get
    Set
public:
property IWin32Window^ OwnerForm {
    IWin32Window^ get ();
    void set (IWin32Window^ value);
}
member OwnerForm : IWin32Window with get, set

Valore della proprietà

IWin32Window
Vedi anche

Documentazione

Classe DedCommand
Namespace DedNet.Commands


Proprietà DedCommand.Result

Proprietà DedCommandResult
Restituisce il risultato dell'ultima esecuzione.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual DedCmdResult Result { get; protected set; }
Public Overridable Property Result As DedCmdResult
    Get
    Protected Set
public:
virtual property DedCmdResult Result {
    DedCmdResult get ();
    protected: void set (DedCmdResult value);
}
abstract Result : DedCmdResult with get, set
override Result : DedCmdResult with get, set

Valore della proprietà

DedCmdResult
Vedi anche

Documentazione

Classe DedCommand
Namespace DedNet.Commands


Proprietà DedCommand.RunningContext

Proprietà DedCommandRunningContext
Indica di ignorare i permessi utente.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommandRunningContextEnum RunningContext { get; set; }
Public Property RunningContext As DedCommandRunningContextEnum
    Get
    Set
public:
property DedCommandRunningContextEnum RunningContext {
    DedCommandRunningContextEnum get ();
    void set (DedCommandRunningContextEnum value);
}
member RunningContext : DedCommandRunningContextEnum with get, set

Valore della proprietà

DedCommandRunningContextEnum
Vedi anche

Documentazione

Classe DedCommand
Namespace DedNet.Commands


Proprietà DedCommand.Silent

Proprietà DedCommandSilent
Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual bool Silent { get; set; }
Public Overridable Property Silent As Boolean
    Get
    Set
public:
virtual property bool Silent {
    bool get ();
    void set (bool value);
}
abstract Silent : bool with get, set
override Silent : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedCommand
Namespace DedNet.Commands


Proprietà DedCommand.SubMenuName

Proprietà DedCommandSubMenuName
Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual string SubMenuName { get; set; }
Public Overridable Property SubMenuName As String
    Get
    Set
public:
virtual property String^ SubMenuName {
    String^ get ();
    void set (String^ value);
}
abstract SubMenuName : string with get, set
override SubMenuName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedCommand
Namespace DedNet.Commands


Proprietà DedCommand.SubMenuText

Proprietà DedCommandSubMenuText
Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual string SubMenuText { get; set; }
Public Overridable Property SubMenuText As String
    Get
    Set
public:
virtual property String^ SubMenuText {
    String^ get ();
    void set (String^ value);
}
abstract SubMenuText : string with get, set
override SubMenuText : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedCommand
Namespace DedNet.Commands


Proprietà DedCommand.Tooltip

Proprietà DedCommandTooltip
Restituisce o imposta il Tooltip descrittivo del comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual string Tooltip { get; set; }
Public Overridable Property Tooltip As String
    Get
    Set
public:
virtual property String^ Tooltip {
    String^ get ();
    void set (String^ value);
}
abstract Tooltip : string with get, set
override Tooltip : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedCommand
Namespace DedNet.Commands


Proprietà DedCommand.TopicHelp

Proprietà DedCommandTopicHelp
Restituisce o imposta il Topic per individuare il comando nell'Help.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual string TopicHelp { get; set; }
Public Overridable Property TopicHelp As String
    Get
    Set
public:
virtual property String^ TopicHelp {
    String^ get ();
    void set (String^ value);
}
abstract TopicHelp : string with get, set
override TopicHelp : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedCommand
Namespace DedNet.Commands


Proprietà DedCommand.UseUI

Proprietà DedCommandUseUI
Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual bool UseUI { get; set; }
Public Overridable Property UseUI As Boolean
    Get
    Set
public:
virtual property bool UseUI {
    bool get ();
    void set (bool value);
}
abstract UseUI : bool with get, set
override UseUI : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedCommand
Namespace DedNet.Commands


Metodi di DedCommand

Il tipo DedCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Esegue la pulizia del comando. Azzera tutte le variabili.
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. Da fare l'override nelle classi derivate.
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo.
Metodo pubblico | Run | Esegue il comando.
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. ///
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Torna su
Vedi anche

Documentazione

Classe DedCommand
Namespace DedNet.Commands


Metodo DedCommand.ClearCommand

Metodo DedCommandClearCommand
Esegue la pulizia del comando. Azzera tutte le variabili.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public abstract void ClearCommand()
Public MustOverride Sub ClearCommand
public:
virtual void ClearCommand() abstract
abstract ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe DedCommand
Namespace DedNet.Commands


Metodo DedCommand.Enabled

Metodo DedCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public abstract bool Enabled(
    DedCommandContext commandContext
)
Public MustOverride Function Enabled (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ commandContext
) abstract
abstract Enabled :
        commandContext : DedCommandContext -> bool

Parametri

commandContext DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe DedCommand
Namespace DedNet.Commands


Metodo DedCommand.Equals

Metodo DedCommandEquals

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj Object

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedCommand
Namespace DedNet.Commands


Metodo DedCommand.ExecuteCommand

Metodo DedCommandExecuteCommand
Esegue il comando vero e proprio. Da fare l'override nelle classi derivate.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected abstract DedCmdResult ExecuteCommand()
Protected MustOverride Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() abstract
abstract ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe DedCommand
Namespace DedNet.Commands


Metodo DedCommand.GetHashCode

Metodo DedCommandGetHashCode

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedCommand
Namespace DedNet.Commands


Metodo DedCommand.InitSubCommand

Metodo DedCommandInitSubCommand
Inizializza un sotto-comando con le impostazioni generali presenti in questo.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected void InitSubCommand(
    DedCommand subCommand
)
Protected Sub InitSubCommand (
    subCommand As DedCommand
)
protected:
void InitSubCommand(
    DedCommand^ subCommand
)
member InitSubCommand :
        subCommand : DedCommand -> unit

Parametri

subCommand DedCommand
Sotto comando da impostare.
Vedi anche

Documentazione

Classe DedCommand
Namespace DedNet.Commands


Metodo DedCommand.Run

Metodo DedCommandRun
Esegue il comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual DedCmdResult Run()
Public Overridable Function Run As DedCmdResult
public:
virtual DedCmdResult Run()
abstract Run : unit -> DedCmdResult
override Run : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe DedCommand
Namespace DedNet.Commands


Metodo DedCommand.RunSubCommand

Metodo DedCommandRunSubCommand
Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. ///

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual DedCmdResult RunSubCommand()
Public Overridable Function RunSubCommand As DedCmdResult
public:
virtual DedCmdResult RunSubCommand()
abstract RunSubCommand : unit -> DedCmdResult
override RunSubCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe DedCommand
Namespace DedNet.Commands


Metodo DedCommand.SetContext

Metodo DedCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public abstract bool SetContext(
    DedCommandContext commandContext
)
Public MustOverride Function SetContext (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ commandContext
) abstract
abstract SetContext :
        commandContext : DedCommandContext -> bool

Parametri

commandContext DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe DedCommand
Namespace DedNet.Commands


Metodo DedCommand.ToString

Metodo DedCommandToString

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedCommand
Namespace DedNet.Commands


Classe DedCommandContext
Classe base per il contesto di esecuzione comando. Contiene le informazioni necessarie per l'esecuzione di un comando.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommandContext

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedCommandContext
Public Class DedCommandContext
public ref class DedCommandContext
type DedCommandContext = class end

Il tipo DedCommandContext espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedCommandContext | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BicList | Restituisce una lista contenente i BomItemCollection
Proprietà pubblica | Comm | Restituisce l'oggetto commessa sul quale eseguire il comando
Proprietà pubblica | DataList | Restituisce la lista delle anagrafiche sulle quali eseguire il comando.
Proprietà pubblica | DcaList | Restituisce una lista contenente i DedCommAnagrItem
Proprietà pubblica | DelegateOfAnag | Delegate contenente la funzione di aggiornamento del dialogo padre.
Proprietà pubblica | DelegateOfComm | Delegate contenente la funzione di aggiornamento del dialogo padre.
Proprietà pubblica | DiscrimDist | Restituisce o imposta il discriminante di distinta relativo al contesto
Proprietà pubblica | DocList | Restituisce la lista dei documenti sui quali eseguire il comando.
Proprietà pubblica | DocListConfig | Restituisce la lista delle configurazioni dei documenti selezionati.
Proprietà pubblica | Eco | Restituisce l'oggetto Eco sul quale eseguire il comando
Proprietà pubblica | FolderList | Restituisce la lista delle cartelle selezionate sulle quali eseguire il comando.
Proprietà pubblica | ManagerFolder | Restituisce o imposta le cartelle ( usato nel controllo documentale )
Proprietà pubblica | Modale | Restituisce o imposta la modalità di apertura del dialogo (true = modale; false = non modale)
Proprietà pubblica | Tag | Tag generico per aggiungere informazioni specifiche all'oggetto
Proprietà pubblica | Target | Restituisce o imposta il punto dal quale è stato lanciato il comando.
Proprietà pubblica | Toexport | Restituisce l'oggetto Iprintable da esportare.
Proprietà pubblica | TypeList | Restituisce la lista delle famiglie sulle quali eseguire il comando.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Costruttore DedCommandContext
Costruttore unico.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommandContext(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedCommandContext(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedCommandContext

Parametri

app DedNetApplication
Vedi anche

Documentazione

Classe DedCommandContext
Namespace DedNet.Commands


Proprietà di DedCommandContext

Il tipo DedCommandContext espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BicList | Restituisce una lista contenente i BomItemCollection
Proprietà pubblica | Comm | Restituisce l'oggetto commessa sul quale eseguire il comando
Proprietà pubblica | DataList | Restituisce la lista delle anagrafiche sulle quali eseguire il comando.
Proprietà pubblica | DcaList | Restituisce una lista contenente i DedCommAnagrItem
Proprietà pubblica | DelegateOfAnag | Delegate contenente la funzione di aggiornamento del dialogo padre.
Proprietà pubblica | DelegateOfComm | Delegate contenente la funzione di aggiornamento del dialogo padre.
Proprietà pubblica | DiscrimDist | Restituisce o imposta il discriminante di distinta relativo al contesto
Proprietà pubblica | DocList | Restituisce la lista dei documenti sui quali eseguire il comando.
Proprietà pubblica | DocListConfig | Restituisce la lista delle configurazioni dei documenti selezionati.
Proprietà pubblica | Eco | Restituisce l'oggetto Eco sul quale eseguire il comando
Proprietà pubblica | FolderList | Restituisce la lista delle cartelle selezionate sulle quali eseguire il comando.
Proprietà pubblica | ManagerFolder | Restituisce o imposta le cartelle ( usato nel controllo documentale )
Proprietà pubblica | Modale | Restituisce o imposta la modalità di apertura del dialogo (true = modale; false = non modale)
Proprietà pubblica | Tag | Tag generico per aggiungere informazioni specifiche all'oggetto
Proprietà pubblica | Target | Restituisce o imposta il punto dal quale è stato lanciato il comando.
Proprietà pubblica | Toexport | Restituisce l'oggetto Iprintable da esportare.
Proprietà pubblica | TypeList | Restituisce la lista delle famiglie sulle quali eseguire il comando.
Torna su
Vedi anche

Documentazione

Classe DedCommandContext
Namespace DedNet.Commands


Proprietà DedCommandContext.BicList

Proprietà DedCommandContextBicList
Restituisce una lista contenente i BomItemCollection

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<BomItemCollection> BicList { get; set; }
Public Property BicList As List(Of BomItemCollection)
    Get
    Set
public:
property List<BomItemCollection^>^ BicList {
    List<BomItemCollection^>^ get ();
    void set (List<BomItemCollection^>^ value);
}
member BicList : List<BomItemCollection> with get, set

Valore della proprietà

List BomItemCollection
Vedi anche

Documentazione

Classe DedCommandContext
Namespace DedNet.Commands


Proprietà DedCommandContext.Comm

Proprietà DedCommandContextComm
Restituisce l'oggetto commessa sul quale eseguire il comando

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedComm Comm { get; set; }
Public Property Comm As DedComm
    Get
    Set
public:
property DedComm^ Comm {
    DedComm^ get ();
    void set (DedComm^ value);
}
member Comm : DedComm with get, set

Valore della proprietà

DedComm
Vedi anche

Documentazione

Classe DedCommandContext
Namespace DedNet.Commands


Proprietà DedCommandContext.DataList

Proprietà DedCommandContextDataList
Restituisce la lista delle anagrafiche sulle quali eseguire il comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataList DataList { get; }
Public ReadOnly Property DataList As DedDataList
    Get
public:
property DedDataList^ DataList {
    DedDataList^ get ();
}
member DataList : DedDataList with get

Valore della proprietà

DedDataList
Vedi anche

Documentazione

Classe DedCommandContext
Namespace DedNet.Commands


Proprietà DedCommandContext.DcaList

Proprietà DedCommandContextDcaList
Restituisce una lista contenente i DedCommAnagrItem

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<DedCommAnagrItem> DcaList { get; set; }
Public Property DcaList As List(Of DedCommAnagrItem)
    Get
    Set
public:
property List<DedCommAnagrItem^>^ DcaList {
    List<DedCommAnagrItem^>^ get ();
    void set (List<DedCommAnagrItem^>^ value);
}
member DcaList : List<DedCommAnagrItem> with get, set

Valore della proprietà

List DedCommAnagrItem
Vedi anche

Documentazione

Classe DedCommandContext
Namespace DedNet.Commands


Proprietà DedCommandContext.DelegateOfAnag

Proprietà DedCommandContextDelegateOfAnag
Delegate contenente la funzione di aggiornamento del dialogo padre.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommandContextUpdateDialogAnag DelegateOfAnag { get; set; }
Public Property DelegateOfAnag As DedCommandContextUpdateDialogAnag
    Get
    Set
public:
property DedCommandContextUpdateDialogAnag^ DelegateOfAnag {
    DedCommandContextUpdateDialogAnag^ get ();
    void set (DedCommandContextUpdateDialogAnag^ value);
}
member DelegateOfAnag : DedCommandContextUpdateDialogAnag with get, set

Valore della proprietà

DedCommandContextUpdateDialogAnag
Vedi anche

Documentazione

Classe DedCommandContext
Namespace DedNet.Commands


Proprietà DedCommandContext.DelegateOfComm

Proprietà DedCommandContextDelegateOfComm
Delegate contenente la funzione di aggiornamento del dialogo padre.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommandContextUpdateDialogComm DelegateOfComm { get; set; }
Public Property DelegateOfComm As DedCommandContextUpdateDialogComm
    Get
    Set
public:
property DedCommandContextUpdateDialogComm^ DelegateOfComm {
    DedCommandContextUpdateDialogComm^ get ();
    void set (DedCommandContextUpdateDialogComm^ value);
}
member DelegateOfComm : DedCommandContextUpdateDialogComm with get, set

Valore della proprietà

DedCommandContextUpdateDialogComm
Vedi anche

Documentazione

Classe DedCommandContext
Namespace DedNet.Commands


Proprietà DedCommandContext.DiscrimDist

Proprietà DedCommandContextDiscrimDist
Restituisce o imposta il discriminante di distinta relativo al contesto

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string DiscrimDist { get; set; }
Public Property DiscrimDist As String
    Get
    Set
public:
property String^ DiscrimDist {
    String^ get ();
    void set (String^ value);
}
member DiscrimDist : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedCommandContext
Namespace DedNet.Commands


Proprietà DedCommandContext.DocList

Proprietà DedCommandContextDocList
Restituisce la lista dei documenti sui quali eseguire il comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocList DocList { get; }
Public ReadOnly Property DocList As DedDocList
    Get
public:
property DedDocList^ DocList {
    DedDocList^ get ();
}
member DocList : DedDocList with get

Valore della proprietà

DedDocList
Vedi anche

Documentazione

Classe DedCommandContext
Namespace DedNet.Commands


Proprietà DedCommandContext.DocListConfig

Proprietà DedCommandContextDocListConfig
Restituisce la lista delle configurazioni dei documenti selezionati.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<DedDoc, List<string>> DocListConfig { get; set; }
Public Property DocListConfig As Dictionary(Of DedDoc, List(Of String))
    Get
    Set
public:
property Dictionary<DedDoc^, List<String^>^>^ DocListConfig {
    Dictionary<DedDoc^, List<String^>^>^ get ();
    void set (Dictionary<DedDoc^, List<String^>^>^ value);
}
member DocListConfig : Dictionary<DedDoc, List<string>> with get, set

Valore della proprietà

Dictionary DedDoc, List String
Vedi anche

Documentazione

Classe DedCommandContext
Namespace DedNet.Commands


Proprietà DedCommandContext.Eco

Proprietà DedCommandContextEco
Restituisce l'oggetto Eco sul quale eseguire il comando

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEco Eco { get; set; }
Public Property Eco As DedEco
    Get
    Set
public:
property DedEco^ Eco {
    DedEco^ get ();
    void set (DedEco^ value);
}
member Eco : DedEco with get, set

Valore della proprietà

DedEco
Vedi anche

Documentazione

Classe DedCommandContext
Namespace DedNet.Commands


Proprietà DedCommandContext.FolderList

Proprietà DedCommandContextFolderList
Restituisce la lista delle cartelle selezionate sulle quali eseguire il comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> FolderList { get; }
Public ReadOnly Property FolderList As List(Of String)
    Get
public:
property List<String^>^ FolderList {
    List<String^>^ get ();
}
member FolderList : List<string> with get

Valore della proprietà

List String
Vedi anche

Documentazione

Classe DedCommandContext
Namespace DedNet.Commands


Proprietà DedCommandContext.ManagerFolder

Proprietà DedCommandContextManagerFolder
Restituisce o imposta le cartelle ( usato nel controllo documentale )

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> ManagerFolder { get; set; }
Public Property ManagerFolder As List(Of String)
    Get
    Set
public:
property List<String^>^ ManagerFolder {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
member ManagerFolder : List<string> with get, set

Valore della proprietà

List String
Vedi anche

Documentazione

Classe DedCommandContext
Namespace DedNet.Commands


Proprietà DedCommandContext.Modale

Proprietà DedCommandContextModale
Restituisce o imposta la modalità di apertura del dialogo (true = modale; false = non modale)

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Modale { get; set; }
Public Property Modale As Boolean
    Get
    Set
public:
property bool Modale {
    bool get ();
    void set (bool value);
}
member Modale : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedCommandContext
Namespace DedNet.Commands


Proprietà DedCommandContext.Tag

Proprietà DedCommandContextTag
Tag generico per aggiungere informazioni specifiche all'oggetto

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object Tag { get; set; }
Public Property Tag As Object
    Get
    Set
public:
property Object^ Tag {
    Object^ get ();
    void set (Object^ value);
}
member Tag : Object with get, set

Valore della proprietà

Object
Vedi anche

Documentazione

Classe DedCommandContext
Namespace DedNet.Commands


Proprietà DedCommandContext.Target

Proprietà DedCommandContextTarget
Restituisce o imposta il punto dal quale è stato lanciato il comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public CommandContextEnum Target { get; set; }
Public Property Target As CommandContextEnum
    Get
    Set
public:
property CommandContextEnum Target {
    CommandContextEnum get ();
    void set (CommandContextEnum value);
}
member Target : CommandContextEnum with get, set

Valore della proprietà

CommandContextEnum
Vedi anche

Documentazione

Classe DedCommandContext
Namespace DedNet.Commands


Proprietà DedCommandContext.Toexport

Proprietà DedCommandContextToexport
Restituisce l'oggetto Iprintable da esportare.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public IPrintable Toexport { get; set; }
Public Property Toexport As IPrintable
    Get
    Set
public:
property IPrintable^ Toexport {
    IPrintable^ get ();
    void set (IPrintable^ value);
}
member Toexport : IPrintable with get, set

Valore della proprietà

IPrintable
Vedi anche

Documentazione

Classe DedCommandContext
Namespace DedNet.Commands


Proprietà DedCommandContext.TypeList

Proprietà DedCommandContextTypeList
Restituisce la lista delle famiglie sulle quali eseguire il comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeList TypeList { get; }
Public ReadOnly Property TypeList As DedTypeList
    Get
public:
property DedTypeList^ TypeList {
    DedTypeList^ get ();
}
member TypeList : DedTypeList with get

Valore della proprietà

DedTypeList
Vedi anche

Documentazione

Classe DedCommandContext
Namespace DedNet.Commands


Delegate DedCommandContext.UpdateDialogAnag

Delegate DedCommandContextUpdateDialogAnag
Delegate contenente la funzione di aggiornamento del dialogo delle angrafiche.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public delegate void UpdateDialogAnag()
Public Delegate Sub UpdateDialogAnag
public delegate void UpdateDialogAnag()
type UpdateDialogAnag =
    delegate of unit -> unit
Vedi anche

Documentazione

Namespace DedNet.Commands


Delegate DedCommandContext.UpdateDialogComm

Delegate DedCommandContextUpdateDialogComm
Delegate contenente la funzione di aggiornamento del dialogo delle commesse.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public delegate void UpdateDialogComm(
    DedComm comm
)
Public Delegate Sub UpdateDialogComm (
    comm As DedComm
)
public delegate void UpdateDialogComm(
    DedComm^ comm
)
type UpdateDialogComm =
    delegate of
        comm : DedComm -> unit

Parametri

comm DedComm
Vedi anche

Documentazione

Namespace DedNet.Commands


Classe DedCommandDocAnagrInfo
Classe descrivente un singolo documento e l'anagrafica nel quale contesto deve essere elaborato il comando. Utilizzato nei comandi che lavorano sul documento quando le informazioni dell'anagrafica sono già disponibili.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommandDocAnagrInfo

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedCommandDocAnagrInfo
Public Class DedCommandDocAnagrInfo
public ref class DedCommandDocAnagrInfo
type DedCommandDocAnagrInfo = class end

Il tipo DedCommandDocAnagrInfo espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedCommandDocAnagrInfo(DedData, DedDoc) | Costruttore unico che inizializza i campi.
Metodo pubblico | DedCommandDocAnagrInfo(DedData, DedDoc, Boolean) | Costruttore unico che inizializza i campi.
Metodo pubblico | DedCommandDocAnagrInfo(DedData, DedDoc, String) | Costruttore unico che inizializza i campi.
Metodo pubblico | DedCommandDocAnagrInfo(DedData, DedDoc, Boolean, String) | Costruttore unico che inizializza i campi.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AnagOk | Indica se l'anagrafica impostata è quella effettivamente associata al documento.
Proprietà pubblica | Anagr | Restitusce l'anagrafica di contesto del documento: può essere null se il documento non ha un contesto chiaro oppure se non è disponibile.
Proprietà pubblica | Config |
Proprietà pubblica | Document | Restituisce il documento sul quale eseguire il comando.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Costruttore DedCommandDocAnagrInfo
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | DedCommandDocAnagrInfo(DedData, DedDoc) | Costruttore unico che inizializza i campi.
Metodo pubblico | DedCommandDocAnagrInfo(DedData, DedDoc, Boolean) | Costruttore unico che inizializza i campi.
Metodo pubblico | DedCommandDocAnagrInfo(DedData, DedDoc, String) | Costruttore unico che inizializza i campi.
Metodo pubblico | DedCommandDocAnagrInfo(DedData, DedDoc, Boolean, String) | Costruttore unico che inizializza i campi.
Torna su
Vedi anche

Documentazione

Classe DedCommandDocAnagrInfo
Namespace DedNet.Commands


Costruttore DedCommandDocAnagrInfo(DedData, DedDoc)
Costruttore unico che inizializza i campi.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommandDocAnagrInfo(
    DedData anagr,
    DedDoc doc
)
Public Sub New (
    anagr As DedData,
    doc As DedDoc
)
public:
DedCommandDocAnagrInfo(
    DedData^ anagr,
    DedDoc^ doc
)
new :
        anagr : DedData *
        doc : DedDoc -> DedCommandDocAnagrInfo

Parametri

anagr DedData
Anagrafica di contesto al documento.
doc DedDoc
Documento sul quale eseguire il comando.
Vedi anche

Documentazione

Classe DedCommandDocAnagrInfo
Overload di DedCommandDocAnagrInfo
Namespace DedNet.Commands


Costruttore DedCommandDocAnagrInfo(DedData, DedDoc, Boolean)
Costruttore unico che inizializza i campi.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommandDocAnagrInfo(
    DedData anagr,
    DedDoc doc,
    bool anagOk
)
Public Sub New (
    anagr As DedData,
    doc As DedDoc,
    anagOk As Boolean
)
public:
DedCommandDocAnagrInfo(
    DedData^ anagr,
    DedDoc^ doc,
    bool anagOk
)
new :
        anagr : DedData *
        doc : DedDoc *
        anagOk : bool -> DedCommandDocAnagrInfo

Parametri

anagr DedData
Anagrafica di contesto al documento.
doc DedDoc
Documento sul quale eseguire il comando.
anagOk Boolean
Indica se l'anagrafica impostata è quella effettivamente associata al documento..
Vedi anche

Documentazione

Classe DedCommandDocAnagrInfo
Overload di DedCommandDocAnagrInfo
Namespace DedNet.Commands


Costruttore DedCommandDocAnagrInfo(DedData, DedDoc, String)
Costruttore unico che inizializza i campi.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommandDocAnagrInfo(
    DedData anagr,
    DedDoc doc,
    string config
)
Public Sub New (
    anagr As DedData,
    doc As DedDoc,
    config As String
)
public:
DedCommandDocAnagrInfo(
    DedData^ anagr,
    DedDoc^ doc,
    String^ config
)
new :
        anagr : DedData *
        doc : DedDoc *
        config : string -> DedCommandDocAnagrInfo

Parametri

anagr DedData
Anagrafica di contesto al documento.
doc DedDoc
Documento sul quale eseguire il comando.
config String
Configurazione
Vedi anche

Documentazione

Classe DedCommandDocAnagrInfo
Overload di DedCommandDocAnagrInfo
Namespace DedNet.Commands


Costruttore DedCommandDocAnagrInfo(DedData, DedDoc, Boolean, String)
Costruttore unico che inizializza i campi.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommandDocAnagrInfo(
    DedData anagr,
    DedDoc doc,
    bool anagOk,
    string config
)
Public Sub New (
    anagr As DedData,
    doc As DedDoc,
    anagOk As Boolean,
    config As String
)
public:
DedCommandDocAnagrInfo(
    DedData^ anagr,
    DedDoc^ doc,
    bool anagOk,
    String^ config
)
new :
        anagr : DedData *
        doc : DedDoc *
        anagOk : bool *
        config : string -> DedCommandDocAnagrInfo

Parametri

anagr DedData
Anagrafica di contesto al documento.
doc DedDoc
Documento sul quale eseguire il comando.
anagOk Boolean
Indica se l'anagrafica impostata è quella effettivamente associata al documento..
config String
Configurazione
Vedi anche

Documentazione

Classe DedCommandDocAnagrInfo
Overload di DedCommandDocAnagrInfo
Namespace DedNet.Commands


Proprietà di DedCommandDocAnagrInfo

Il tipo DedCommandDocAnagrInfo espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AnagOk | Indica se l'anagrafica impostata è quella effettivamente associata al documento.
Proprietà pubblica | Anagr | Restitusce l'anagrafica di contesto del documento: può essere null se il documento non ha un contesto chiaro oppure se non è disponibile.
Proprietà pubblica | Config |
Proprietà pubblica | Document | Restituisce il documento sul quale eseguire il comando.
Torna su
Vedi anche

Documentazione

Classe DedCommandDocAnagrInfo
Namespace DedNet.Commands


Proprietà DedCommandDocAnagrInfo.AnagOk

Proprietà DedCommandDocAnagrInfoAnagOk
Indica se l'anagrafica impostata è quella effettivamente associata al documento.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AnagOk { get; }
Public ReadOnly Property AnagOk As Boolean
    Get
public:
property bool AnagOk {
    bool get ();
}
member AnagOk : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedCommandDocAnagrInfo
Namespace DedNet.Commands


Proprietà DedCommandDocAnagrInfo.Anagr

Proprietà DedCommandDocAnagrInfoAnagr
Restitusce l'anagrafica di contesto del documento: può essere null se il documento non ha un contesto chiaro oppure se non è disponibile.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Anagr { get; set; }
Public Property Anagr As DedData
    Get
    Set
public:
property DedData^ Anagr {
    DedData^ get ();
    void set (DedData^ value);
}
member Anagr : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe DedCommandDocAnagrInfo
Namespace DedNet.Commands


Proprietà DedCommandDocAnagrInfo.Config

Proprietà DedCommandDocAnagrInfoConfig

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Config { get; }
Public ReadOnly Property Config As String
    Get
public:
property String^ Config {
    String^ get ();
}
member Config : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedCommandDocAnagrInfo
Namespace DedNet.Commands


Proprietà DedCommandDocAnagrInfo.Document

Proprietà DedCommandDocAnagrInfoDocument
Restituisce il documento sul quale eseguire il comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDoc Document { get; set; }
Public Property Document As DedDoc
    Get
    Set
public:
property DedDoc^ Document {
    DedDoc^ get ();
    void set (DedDoc^ value);
}
member Document : DedDoc with get, set

Valore della proprietà

DedDoc
Vedi anche

Documentazione

Classe DedCommandDocAnagrInfo
Namespace DedNet.Commands


Classe DedCommandDocAnagrInfoList
Classe che descrive una lista di DedCommandDocAnagrInfo
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList DedCommandDocAnagrInfo
DedNet.CommandsDedCommandDocAnagrInfoList

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedCommandDocAnagrInfoList : List<DedCommandDocAnagrInfo>
Public Class DedCommandDocAnagrInfoList
    Inherits List(Of DedCommandDocAnagrInfo)
public ref class DedCommandDocAnagrInfoList : public List<DedCommandDocAnagrInfo^>
type DedCommandDocAnagrInfoList =
    class
        inherit List<DedCommandDocAnagrInfo>
    end

Il tipo DedCommandDocAnagrInfoList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedCommandDocAnagrInfoList |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | getFiles | Restituisce un array contenente tutti i file presenti nell'oggetto.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Costruttore DedCommandDocAnagrInfoList

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommandDocAnagrInfoList()
Public Sub New
public:
DedCommandDocAnagrInfoList()
new : unit -> DedCommandDocAnagrInfoList
Vedi anche

Documentazione

Classe DedCommandDocAnagrInfoList
Namespace DedNet.Commands


Metodi di DedCommandDocAnagrInfoList

Il tipo DedCommandDocAnagrInfoList espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | getFiles | Restituisce un array contenente tutti i file presenti nell'oggetto.
Torna su
Vedi anche

Documentazione

Classe DedCommandDocAnagrInfoList
Namespace DedNet.Commands


Metodo DedCommandDocAnagrInfoList.getFiles

Metodo DedCommandDocAnagrInfoListgetFiles
Restituisce un array contenente tutti i file presenti nell'oggetto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string[] getFiles()
Public Function getFiles As String()
public:
array<String^>^ getFiles()
member getFiles : unit -> string[]

Valore di ritorno

String
Restituisce un array contenente tutti i file presenti nell'oggetto.
Vedi anche

Documentazione

Classe DedCommandDocAnagrInfoList
Namespace DedNet.Commands


Classe DedCommandList
Lista di oggetti DedCommand.
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList DedCommand
DedNet.CommandsDedCommandList

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedCommandList : List<DedCommand>
Public Class DedCommandList
    Inherits List(Of DedCommand)
public ref class DedCommandList : public List<DedCommand^>
type DedCommandList =
    class
        inherit List<DedCommand>
    end

Il tipo DedCommandList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedCommandList | Costruttore di default.
Metodo pubblico | DedCommandList(IEnumerableDedCommand) | Costruttore che inizializza la collezione interna con quella passata in ingresso.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | FindIndexByInternalName | Ritorna l'indice del comando dal nome interno
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Costruttore DedCommandList
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | DedCommandList | Costruttore di default.
Metodo pubblico | DedCommandList(IEnumerableDedCommand) | Costruttore che inizializza la collezione interna con quella passata in ingresso.
Torna su
Vedi anche

Documentazione

Classe DedCommandList
Namespace DedNet.Commands


Costruttore DedCommandList
Costruttore di default.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommandList()
Public Sub New
public:
DedCommandList()
new : unit -> DedCommandList
Vedi anche

Documentazione

Classe DedCommandList
Overload di DedCommandList
Namespace DedNet.Commands


Costruttore DedCommandList(IEnumerable<DedCommand>)

Costruttore DedCommandList(IEnumerableDedCommand)
Costruttore che inizializza la collezione interna con quella passata in ingresso.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommandList(
    IEnumerable<DedCommand> collection
)
Public Sub New (
    collection As IEnumerable(Of DedCommand)
)
public:
DedCommandList(
    IEnumerable<DedCommand^>^ collection
)
new :
        collection : IEnumerable<DedCommand> -> DedCommandList

Parametri

collection IEnumerable DedCommand
Collezione di DedCommand da cui partire per inizializzare la lista interna.
Vedi anche

Documentazione

Classe DedCommandList
Overload di DedCommandList
Namespace DedNet.Commands


Metodi di DedCommandList

Il tipo DedCommandList espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | FindIndexByInternalName | Ritorna l'indice del comando dal nome interno
Torna su
Vedi anche

Documentazione

Classe DedCommandList
Namespace DedNet.Commands


Metodo DedCommandList.FindIndexByInternalName

Metodo DedCommandListFindIndexByInternalName
Ritorna l'indice del comando dal nome interno

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int FindIndexByInternalName(
    string internalName
)
Public Function FindIndexByInternalName (
    internalName As String
) As Integer
public:
int FindIndexByInternalName(
    String^ internalName
)
member FindIndexByInternalName :
        internalName : string -> int

Parametri

internalName String
Nome interno del comando da cercare

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedCommandList
Namespace DedNet.Commands


Classe DedDataCommand
Comando di base per operare sulle anagrafiche.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsDedDataCommand
Altro

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public abstract class DedDataCommand : DedCommand
Public MustInherit Class DedDataCommand
    Inherits DedCommand
public ref class DedDataCommand abstract : public DedCommand
[<AbstractClassAttribute>]
type DedDataCommand =
    class
        inherit DedCommand
    end

Il tipo DedDataCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DataInfos | Restituisce la lista delle anagrafiche di elaborazione comando.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce false se non esiste nemmeno un documento sul quale eseguire il comando. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Esegue la pulizia del comando. Azzera tutte le variabili. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. Da fare l'override nelle classi derivate. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Sovrascrive DedCommandRun)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsDedDataCommand
DedNet.CommandsAnagrAssocComm
DedNet.CommandsAnagrHistoryCommand
DedNet.CommandsBomEditCommand
DedNet.CommandsBomHistoryCommand
DedNet.CommandsBomWhereUsedCommand
DedNet.CommandsCommEditCommand
DedNet.CommandsDeleteCommAnagrCommand
DedNet.CommandsDeleteDataCommand
DedNet.CommandsDistEsplCommand
DedNet.CommandsDistImplCommand
DedNet.CommandsFindDataDocCommand
DedNet.CommandsMoveAnagrCommand
DedNet.CommandsReplaceAnagrBom


Proprietà di DedDataCommand

Il tipo DedDataCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DataInfos | Restituisce la lista delle anagrafiche di elaborazione comando.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce false se non esiste nemmeno un documento sul quale eseguire il comando. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DedDataCommand
Namespace DedNet.Commands


Proprietà DedDataCommand.DataInfos

Proprietà DedDataCommandDataInfos
Restituisce la lista delle anagrafiche di elaborazione comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataList DataInfos { get; }
Public ReadOnly Property DataInfos As DedDataList
    Get
public:
property DedDataList^ DataInfos {
    DedDataList^ get ();
}
member DataInfos : DedDataList with get

Valore della proprietà

DedDataList
Vedi anche

Documentazione

Classe DedDataCommand
Namespace DedNet.Commands


Proprietà DedDataCommand.NeedParameters

Proprietà DedDataCommandNeedParameters
Restituisce false se non esiste nemmeno un documento sul quale eseguire il comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDataCommand
Namespace DedNet.Commands


Metodi di DedDataCommand

Il tipo DedDataCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Esegue la pulizia del comando. Azzera tutte le variabili. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. Da fare l'override nelle classi derivate. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Sovrascrive DedCommandRun)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DedDataCommand
Namespace DedNet.Commands


Metodo DedDataCommand.ClearCommand

Metodo DedDataCommandClearCommand
Esegue la pulizia del comando. Azzera tutte le variabili.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe DedDataCommand
Namespace DedNet.Commands


Metodo DedDataCommand.Enabled

Metodo DedDataCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public abstract bool Enabled(
    DedCommandContext commandContext
)
Public MustOverride Function Enabled (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ commandContext
) abstract override
override Enabled :
        commandContext : DedCommandContext -> bool

Parametri

commandContext DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe DedDataCommand
Namespace DedNet.Commands


Metodo DedDataCommand.ExecuteCommand

Metodo DedDataCommandExecuteCommand
Esegue il comando vero e proprio. Da fare l'override nelle classi derivate.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected abstract DedCmdResult ExecuteCommand()
Protected MustOverride Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() abstract override
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe DedDataCommand
Namespace DedNet.Commands


Metodo DedDataCommand.Run

Metodo DedDataCommandRun
Esegue il comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override DedCmdResult Run()
Public Overrides Function Run As DedCmdResult
public:
virtual DedCmdResult Run() override
abstract Run : unit -> DedCmdResult
override Run : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe DedDataCommand
Namespace DedNet.Commands


Metodo DedDataCommand.SetContext

Metodo DedDataCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public abstract bool SetContext(
    DedCommandContext commandContext
)
Public MustOverride Function SetContext (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ commandContext
) abstract override
override SetContext :
        commandContext : DedCommandContext -> bool

Parametri

commandContext DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe DedDataCommand
Namespace DedNet.Commands


Classe DedDocumentCommand
Comando di base per operare sui documenti.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsDedDocumentCommand
Altro

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public abstract class DedDocumentCommand : DedCommand
Public MustInherit Class DedDocumentCommand
    Inherits DedCommand
public ref class DedDocumentCommand abstract : public DedCommand
[<AbstractClassAttribute>]
type DedDocumentCommand =
    class
        inherit DedCommand
    end

Il tipo DedDocumentCommand espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedDocumentCommand | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DocumentInfos | Restituisce la lista dei documenti con abbinato il contesto di anagrafica di elaborazione comando.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce false se non esiste nemmeno un documento sul quale eseguire il comando. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Reinizializza il comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. Da fare l'override nelle classi derivate. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Sovrascrive DedCommandRun)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsDedDocumentCommand
DedNet.CommandsChangeRepresentationSuffixCommand
DedNet.CommandsDocHistoryCommand
DedNet.CommandsDocTransferHistoryCommand
DedNet.CommandsFileZip
DedNet.CommandsFileZipStruct
DedNet.CommandsFindInRicercaCommand
DedNet.CommandsForceMarkerAlingmentCommand
DedNet.CommandsMarkerInfoCommand
DedNet.CommandsOpenReadDocument
DedNet.CommandsOpenWriteDocument
DedNet.CommandsSendZipViaEmail
DedNet.CommandsVisualDepCommand
DedNet.CommandsWhereUsedCommand


Costruttore DedDocumentCommand
Costruttore unico.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocumentCommand(
    DedNetApplication app,
    string internalName,
    string name
)
Public Sub New (
    app As DedNetApplication,
    internalName As String,
    name As String
)
public:
DedDocumentCommand(
    DedNetApplication^ app,
    String^ internalName,
    String^ name
)
new :
        app : DedNetApplication *
        internalName : string *
        name : string -> DedDocumentCommand

Parametri

app DedNetApplication
Riferimento all'oggetto DedNetApplication.
internalName String
Nome interno del comando.
name String
Nome visualizzato del comando.
Vedi anche

Documentazione

Classe DedDocumentCommand
Namespace DedNet.Commands


Proprietà di DedDocumentCommand

Il tipo DedDocumentCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DocumentInfos | Restituisce la lista dei documenti con abbinato il contesto di anagrafica di elaborazione comando.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce false se non esiste nemmeno un documento sul quale eseguire il comando. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DedDocumentCommand
Namespace DedNet.Commands


Proprietà DedDocumentCommand.DocumentInfos

Proprietà DedDocumentCommandDocumentInfos
Restituisce la lista dei documenti con abbinato il contesto di anagrafica di elaborazione comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommandDocAnagrInfoList DocumentInfos { get; }
Public ReadOnly Property DocumentInfos As DedCommandDocAnagrInfoList
    Get
public:
property DedCommandDocAnagrInfoList^ DocumentInfos {
    DedCommandDocAnagrInfoList^ get ();
}
member DocumentInfos : DedCommandDocAnagrInfoList with get

Valore della proprietà

DedCommandDocAnagrInfoList
Vedi anche

Documentazione

Classe DedDocumentCommand
Namespace DedNet.Commands


Proprietà DedDocumentCommand.NeedParameters

Proprietà DedDocumentCommandNeedParameters
Restituisce false se non esiste nemmeno un documento sul quale eseguire il comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDocumentCommand
Namespace DedNet.Commands


Metodi di DedDocumentCommand

Il tipo DedDocumentCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Reinizializza il comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. Da fare l'override nelle classi derivate. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Sovrascrive DedCommandRun)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DedDocumentCommand
Namespace DedNet.Commands


Metodo DedDocumentCommand.ClearCommand

Metodo DedDocumentCommandClearCommand
Reinizializza il comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe DedDocumentCommand
Namespace DedNet.Commands


Metodo DedDocumentCommand.Enabled

Metodo DedDocumentCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public abstract bool Enabled(
    DedCommandContext commandContext
)
Public MustOverride Function Enabled (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ commandContext
) abstract override
override Enabled :
        commandContext : DedCommandContext -> bool

Parametri

commandContext DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe DedDocumentCommand
Namespace DedNet.Commands


Metodo DedDocumentCommand.ExecuteCommand

Metodo DedDocumentCommandExecuteCommand
Esegue il comando vero e proprio. Da fare l'override nelle classi derivate.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected abstract DedCmdResult ExecuteCommand()
Protected MustOverride Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() abstract override
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe DedDocumentCommand
Namespace DedNet.Commands


Metodo DedDocumentCommand.Run

Metodo DedDocumentCommandRun
Esegue il comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override DedCmdResult Run()
Public Overrides Function Run As DedCmdResult
public:
virtual DedCmdResult Run() override
abstract Run : unit -> DedCmdResult
override Run : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe DedDocumentCommand
Namespace DedNet.Commands


Metodo DedDocumentCommand.SetContext

Metodo DedDocumentCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public abstract bool SetContext(
    DedCommandContext commandContext
)
Public MustOverride Function SetContext (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ commandContext
) abstract override
override SetContext :
        commandContext : DedCommandContext -> bool

Parametri

commandContext DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe DedDocumentCommand
Namespace DedNet.Commands


Classe DedListEditCommand
Comando che inserisce l'anagrafica alla lista di stampa
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsDedListEditCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedListEditCommand : DedCommand
Public Class DedListEditCommand
    Inherits DedCommand
public ref class DedListEditCommand : public DedCommand
type DedListEditCommand =
    class
        inherit DedCommand
    end

Il tipo DedListEditCommand espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedListEditCommand | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Eseguo il comando. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Imposto il contesto per l'esecuzione del comando (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Costruttore DedListEditCommand
Costruttore unico.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedListEditCommand(
    DedNetApplication app,
    string internalName,
    string name
)
Public Sub New (
    app As DedNetApplication,
    internalName As String,
    name As String
)
public:
DedListEditCommand(
    DedNetApplication^ app,
    String^ internalName,
    String^ name
)
new :
        app : DedNetApplication *
        internalName : string *
        name : string -> DedListEditCommand

Parametri

app DedNetApplication
Riferimento all'oggetto DedNetApplication.
internalName String
Nome interno del comando.
name String
Nome visualizzato del comando.
Vedi anche

Documentazione

Classe DedListEditCommand
Namespace DedNet.Commands


Proprietà di DedListEditCommand

Il tipo DedListEditCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DedListEditCommand
Namespace DedNet.Commands


Proprietà DedListEditCommand.NeedParameters

Proprietà DedListEditCommandNeedParameters
Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedListEditCommand
Namespace DedNet.Commands


Metodi di DedListEditCommand

Il tipo DedListEditCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Eseguo il comando. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Imposto il contesto per l'esecuzione del comando (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DedListEditCommand
Namespace DedNet.Commands


Metodo DedListEditCommand.ClearCommand

Metodo DedListEditCommandClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe DedListEditCommand
Namespace DedNet.Commands


Metodo DedListEditCommand.Enabled

Metodo DedListEditCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce True se il comando deve risultare abilitato all'utente, False altrimenti.
Vedi anche

Documentazione

Classe DedListEditCommand
Namespace DedNet.Commands


Metodo DedListEditCommand.ExecuteCommand

Metodo DedListEditCommandExecuteCommand
Eseguo il comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe DedListEditCommand
Namespace DedNet.Commands


Metodo DedListEditCommand.SetContext

Metodo DedListEditCommandSetContext
Imposto il contesto per l'esecuzione del comando

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedListEditCommand
Namespace DedNet.Commands


Classe DedListManagerCommand
Classe che rappresenta il comando per la gestione delle tipologie di lista.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsDedListManagerCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedListManagerCommand : DedCommand
Public Class DedListManagerCommand
    Inherits DedCommand
public ref class DedListManagerCommand : public DedCommand
type DedListManagerCommand =
    class
        inherit DedCommand
    end

Il tipo DedListManagerCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce se i parametri siano o meno sufficienti per l'esecuzione del comando. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di DedListManagerCommand

Il tipo DedListManagerCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce se i parametri siano o meno sufficienti per l'esecuzione del comando. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DedListManagerCommand
Namespace DedNet.Commands


Proprietà DedListManagerCommand.NeedParameters

Proprietà DedListManagerCommandNeedParameters
Restituisce se i parametri siano o meno sufficienti per l'esecuzione del comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedListManagerCommand
Namespace DedNet.Commands


Metodi di DedListManagerCommand

Il tipo DedListManagerCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DedListManagerCommand
Namespace DedNet.Commands


Metodo DedListManagerCommand.ClearCommand

Metodo DedListManagerCommandClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe DedListManagerCommand
Namespace DedNet.Commands


Metodo DedListManagerCommand.Enabled

Metodo DedListManagerCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe DedListManagerCommand
Namespace DedNet.Commands


Metodo DedListManagerCommand.ExecuteCommand

Metodo DedListManagerCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe DedListManagerCommand
Namespace DedNet.Commands


Metodo DedListManagerCommand.SetContext

Metodo DedListManagerCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe DedListManagerCommand
Namespace DedNet.Commands


Classe DedStateCommand
Classe che definisce un oggetto per la modifica dello stato di un'anagrafica. Gestisce la modifica di stato contenendo tutte le informazioni sull'anagrafiche in modifica ed i relativi documenti collegati. Lancia i vari eventi di modifica di stato e di attributi ed ogni evento contiene le seguenti informazioni: - L'anagrafica in oggetto; - Lo stato di partenza; - Lo stato di destinazione; - I documenti coinvolti ovvero collegati all'anagrafica. Prima di effettuare i vari controlli sui documenti, il comando lancia un evento di aggiornamento attributi in modo che si possano personalizzare ed aggiornare nel documento eventualmente aperto (nel caso per esempio del rilascio).
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsDedStateCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedStateCommand : DedCommand
Public Class DedStateCommand
    Inherits DedCommand
public ref class DedStateCommand : public DedCommand
type DedStateCommand =
    class
        inherit DedCommand
    end

Il tipo DedStateCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | AttrsToUpdateOnSetState | Dizionario prompt - valore utilizzato eventualmente prima del cambio stato per apportare modifiche all'anagrafica
Proprietà pubblica | CadInformation | Informazioni aggiuntive sulle operazioni eseguite dal CAD.
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Data | Restituisce l'anagrafica della quale si sta modificando lo stato.
Proprietà pubblica | Datas | Restituisce o imposta le anagrafica della quale modificare lo stato.
Proprietà pubblica | DocAttrsToUpdateOnSetState | Dizionario prompt - valore utilizzato eventualmente prima del cambio stato per apportare modifiche ai documenti
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | IsReservedTransaction | Indica se il comando deve pilotare una transazione ammessa ma riservata
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | Message | Restituisce il messaggio informativo in caso di operaizione completata o annullata ma senza eccezioni
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Se cioè l'anagrafica non è impostata. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | PrimaryDocs | Restituisce la lista dei documenti primari dell'anagrafica in elaborazione.
Proprietà pubblica | PublicationExceptionList | Restituisce la lista delle eventuali eccezioni catturate in fase pubblicazione della documentazione
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | Revs | Restituisce la lista di tutte le revisioni presenti, aventi stesso DEDID di quella in modifica di stato. In questa lista è presente anche l'anagrafica in modifica.
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | StartingState | Restituisce lo stato di partenza dell'anagrafica (disponibile solo per gli eventi, durante l'esecuzione del comando).
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | TargetState | Restituisce lo stato di destinazione da impostare all' anagrafica, e che caratterizza il comando stesso.
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | CheckParentApprovedState | Controllo se ci sono dei padri in rilascio o attesa di approvazione e ne visualizza la struttura
Metodo pubblico | ClearCommand | Reinizializza il comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). Verifica che sia presente una sola anagrafica. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Imposta l'anagrafica. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di DedStateCommand

Il tipo DedStateCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | AttrsToUpdateOnSetState | Dizionario prompt - valore utilizzato eventualmente prima del cambio stato per apportare modifiche all'anagrafica
Proprietà pubblica | CadInformation | Informazioni aggiuntive sulle operazioni eseguite dal CAD.
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Data | Restituisce l'anagrafica della quale si sta modificando lo stato.
Proprietà pubblica | Datas | Restituisce o imposta le anagrafica della quale modificare lo stato.
Proprietà pubblica | DocAttrsToUpdateOnSetState | Dizionario prompt - valore utilizzato eventualmente prima del cambio stato per apportare modifiche ai documenti
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | IsReservedTransaction | Indica se il comando deve pilotare una transazione ammessa ma riservata
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | Message | Restituisce il messaggio informativo in caso di operaizione completata o annullata ma senza eccezioni
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Se cioè l'anagrafica non è impostata. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | PrimaryDocs | Restituisce la lista dei documenti primari dell'anagrafica in elaborazione.
Proprietà pubblica | PublicationExceptionList | Restituisce la lista delle eventuali eccezioni catturate in fase pubblicazione della documentazione
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | Revs | Restituisce la lista di tutte le revisioni presenti, aventi stesso DEDID di quella in modifica di stato. In questa lista è presente anche l'anagrafica in modifica.
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | StartingState | Restituisce lo stato di partenza dell'anagrafica (disponibile solo per gli eventi, durante l'esecuzione del comando).
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | TargetState | Restituisce lo stato di destinazione da impostare all' anagrafica, e che caratterizza il comando stesso.
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DedStateCommand
Namespace DedNet.Commands


Proprietà DedStateCommand.AttrsToUpdateOnSetState

Proprietà DedStateCommandAttrsToUpdateOnSetState
Dizionario prompt - valore utilizzato eventualmente prima del cambio stato per apportare modifiche all'anagrafica

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<string, Object> AttrsToUpdateOnSetState { get; set; }
Public Property AttrsToUpdateOnSetState As Dictionary(Of String, Object)
    Get
    Set
public:
property Dictionary<String^, Object^>^ AttrsToUpdateOnSetState {
    Dictionary<String^, Object^>^ get ();
    void set (Dictionary<String^, Object^>^ value);
}
member AttrsToUpdateOnSetState : Dictionary<string, Object> with get, set

Valore della proprietà

Dictionary String, Object
Vedi anche

Documentazione

Classe DedStateCommand
Namespace DedNet.Commands


Proprietà DedStateCommand.CadInformation

Proprietà DedStateCommandCadInformation
Informazioni aggiuntive sulle operazioni eseguite dal CAD.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedStateCommandCadInfo CadInformation { get; set; }
Public Property CadInformation As DedStateCommandCadInfo
    Get
    Set
public:
property DedStateCommandCadInfo CadInformation {
    DedStateCommandCadInfo get ();
    void set (DedStateCommandCadInfo value);
}
member CadInformation : DedStateCommandCadInfo with get, set

Valore della proprietà

DedStateCommandCadInfo
Vedi anche

Documentazione

Classe DedStateCommand
Namespace DedNet.Commands


Proprietà DedStateCommand.Data

Proprietà DedStateCommandData
Restituisce l'anagrafica della quale si sta modificando lo stato.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; }
Public ReadOnly Property Data As DedData
    Get
public:
property DedData^ Data {
    DedData^ get ();
}
member Data : DedData with get

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe DedStateCommand
Namespace DedNet.Commands


Proprietà DedStateCommand.Datas

Proprietà DedStateCommandDatas
Restituisce o imposta le anagrafica della quale modificare lo stato.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataList Datas { get; }
Public ReadOnly Property Datas As DedDataList
    Get
public:
property DedDataList^ Datas {
    DedDataList^ get ();
}
member Datas : DedDataList with get

Valore della proprietà

DedDataList
Vedi anche

Documentazione

Classe DedStateCommand
Namespace DedNet.Commands


Proprietà DedStateCommand.DocAttrsToUpdateOnSetState

Proprietà DedStateCommandDocAttrsToUpdateOnSetState
Dizionario prompt - valore utilizzato eventualmente prima del cambio stato per apportare modifiche ai documenti

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<string, Object> DocAttrsToUpdateOnSetState { get; set; }
Public Property DocAttrsToUpdateOnSetState As Dictionary(Of String, Object)
    Get
    Set
public:
property Dictionary<String^, Object^>^ DocAttrsToUpdateOnSetState {
    Dictionary<String^, Object^>^ get ();
    void set (Dictionary<String^, Object^>^ value);
}
member DocAttrsToUpdateOnSetState : Dictionary<string, Object> with get, set

Valore della proprietà

Dictionary String, Object
Vedi anche

Documentazione

Classe DedStateCommand
Namespace DedNet.Commands


Proprietà DedStateCommand.IsReservedTransaction

Proprietà DedStateCommandIsReservedTransaction
Indica se il comando deve pilotare una transazione ammessa ma riservata

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsReservedTransaction { get; set; }
Public Property IsReservedTransaction As Boolean
    Get
    Set
public:
property bool IsReservedTransaction {
    bool get ();
    void set (bool value);
}
member IsReservedTransaction : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedStateCommand
Namespace DedNet.Commands


Proprietà DedStateCommand.Message

Proprietà DedStateCommandMessage
Restituisce il messaggio informativo in caso di operaizione completata o annullata ma senza eccezioni

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Message { get; set; }
Public Property Message As String
    Get
    Set
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}
member Message : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedStateCommand
Namespace DedNet.Commands


Proprietà DedStateCommand.NeedParameters

Proprietà DedStateCommandNeedParameters
Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Se cioè l'anagrafica non è impostata.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedStateCommand
Namespace DedNet.Commands


Proprietà DedStateCommand.PrimaryDocs

Proprietà DedStateCommandPrimaryDocs
Restituisce la lista dei documenti primari dell'anagrafica in elaborazione.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocList PrimaryDocs { get; }
Public ReadOnly Property PrimaryDocs As DedDocList
    Get
public:
property DedDocList^ PrimaryDocs {
    DedDocList^ get ();
}
member PrimaryDocs : DedDocList with get

Valore della proprietà

DedDocList
Vedi anche

Documentazione

Classe DedStateCommand
Namespace DedNet.Commands


Proprietà DedStateCommand.PublicationExceptionList

Proprietà DedStateCommandPublicationExceptionList
Restituisce la lista delle eventuali eccezioni catturate in fase pubblicazione della documentazione

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<Exception> PublicationExceptionList { get; }
Public ReadOnly Property PublicationExceptionList As List(Of Exception)
    Get
public:
property List<Exception^>^ PublicationExceptionList {
    List<Exception^>^ get ();
}
member PublicationExceptionList : List<Exception> with get

Valore della proprietà

List Exception
Vedi anche

Documentazione

Classe DedStateCommand
Namespace DedNet.Commands


Proprietà DedStateCommand.Revs

Proprietà DedStateCommandRevs
Restituisce la lista di tutte le revisioni presenti, aventi stesso DEDID di quella in modifica di stato. In questa lista è presente anche l'anagrafica in modifica.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataList Revs { get; }
Public ReadOnly Property Revs As DedDataList
    Get
public:
property DedDataList^ Revs {
    DedDataList^ get ();
}
member Revs : DedDataList with get

Valore della proprietà

DedDataList
Vedi anche

Documentazione

Classe DedStateCommand
Namespace DedNet.Commands


Proprietà DedStateCommand.StartingState

Proprietà DedStateCommandStartingState
Restituisce lo stato di partenza dell'anagrafica (disponibile solo per gli eventi, durante l'esecuzione del comando).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedState StartingState { get; }
Public ReadOnly Property StartingState As DedState
    Get
public:
property DedState^ StartingState {
    DedState^ get ();
}
member StartingState : DedState with get

Valore della proprietà

DedState
Vedi anche

Documentazione

Classe DedStateCommand
Namespace DedNet.Commands


Proprietà DedStateCommand.TargetState

Proprietà DedStateCommandTargetState
Restituisce lo stato di destinazione da impostare all' anagrafica, e che caratterizza il comando stesso.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedState TargetState { get; }
Public ReadOnly Property TargetState As DedState
    Get
public:
property DedState^ TargetState {
    DedState^ get ();
}
member TargetState : DedState with get

Valore della proprietà

DedState
Vedi anche

Documentazione

Classe DedStateCommand
Namespace DedNet.Commands


Metodi di DedStateCommand

Il tipo DedStateCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | CheckParentApprovedState | Controllo se ci sono dei padri in rilascio o attesa di approvazione e ne visualizza la struttura
Metodo pubblico | ClearCommand | Reinizializza il comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). Verifica che sia presente una sola anagrafica. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Imposta l'anagrafica. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DedStateCommand
Namespace DedNet.Commands


Metodo DedStateCommand.CheckParentApprovedState

Metodo DedStateCommandCheckParentApprovedState
Controllo se ci sono dei padri in rilascio o attesa di approvazione e ne visualizza la struttura

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void CheckParentApprovedState(
    DedData refData,
    DocStructInfo refDocInfo,
    DocStructInfo multipleMainDocInfo,
    bool isMultiple
)
Public Sub CheckParentApprovedState (
    refData As DedData,
    refDocInfo As DocStructInfo,
    multipleMainDocInfo As DocStructInfo,
    isMultiple As Boolean
)
public:
void CheckParentApprovedState(
    DedData^ refData,
    DocStructInfo^ refDocInfo,
    DocStructInfo^ multipleMainDocInfo,
    bool isMultiple
)
member CheckParentApprovedState :
        refData : DedData *
        refDocInfo : DocStructInfo *
        multipleMainDocInfo : DocStructInfo *
        isMultiple : bool -> unit

Parametri

refData DedData
refDocInfo DocStructInfo
multipleMainDocInfo DocStructInfo
isMultiple Boolean
Vedi anche

Documentazione

Classe DedStateCommand
Namespace DedNet.Commands


Metodo DedStateCommand.ClearCommand

Metodo DedStateCommandClearCommand
Reinizializza il comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe DedStateCommand
Namespace DedNet.Commands


Metodo DedStateCommand.Enabled

Metodo DedStateCommandEnabled
Restituisce se il comando sia abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). Verifica che sia presente una sola anagrafica.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext commandContext
)
Public Overrides Function Enabled (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ commandContext
) override
abstract Enabled :
        commandContext : DedCommandContext -> bool
override Enabled :
        commandContext : DedCommandContext -> bool

Parametri

commandContext DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe DedStateCommand
Namespace DedNet.Commands


Metodo DedStateCommand.ExecuteCommand

Metodo DedStateCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe DedStateCommand
Namespace DedNet.Commands


Metodo DedStateCommand.SetContext

Metodo DedStateCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Imposta l'anagrafica.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext commandContext
)
Public Overrides Function SetContext (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ commandContext
) override
abstract SetContext :
        commandContext : DedCommandContext -> bool
override SetContext :
        commandContext : DedCommandContext -> bool

Parametri

commandContext DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe DedStateCommand
Namespace DedNet.Commands


Struttura DedStateCommand.CadInfo

Struttura DedStateCommandCadInfo
Struttura con informazioni aggiunti ve inserite dai CAD.
Gerarchia di ereditarietà
SystemObject
SystemValueType
DedNet.CommandsDedStateCommandCadInfo

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public struct CadInfo
Public Structure CadInfo
public value class CadInfo
[<SealedAttribute>]
type CadInfo =
    struct
        inherit ValueType
    end

Il tipo DedStateCommandCadInfo espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | SetActiveMs |
Torna su
Campi
 | Nome | Descrizione
Campo pubblico | ActiveMs |
Campo pubblico | ChangeNote |
Campo pubblico | ChangeStateDocumentDescriptors |
Campo pubblico | DocStructInfo |
Campo pubblico | isChildOperation |
Campo pubblico | MultipleMainDocStructInfo |
Campo pubblico | Multiplo |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Metodi di CadInfo

Il tipo DedStateCommandCadInfo espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | SetActiveMs |
Torna su
Vedi anche

Documentazione

Struttura DedStateCommandCadInfo
Namespace DedNet.Commands


Metodo DedStateCommand.CadInfo.SetActiveMs

Metodo DedStateCommandCadInfoSetActiveMs

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetActiveMs(
    string ms
)
Public Sub SetActiveMs (
    ms As String
)
public:
void SetActiveMs(
    String^ ms
)
member SetActiveMs :
        ms : string -> unit

Parametri

ms String
Vedi anche

Documentazione

Struttura DedStateCommandCadInfo
Namespace DedNet.Commands


Campi di CadInfo

Il tipo DedStateCommandCadInfo espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | ActiveMs |
Campo pubblico | ChangeNote |
Campo pubblico | ChangeStateDocumentDescriptors |
Campo pubblico | DocStructInfo |
Campo pubblico | isChildOperation |
Campo pubblico | MultipleMainDocStructInfo |
Campo pubblico | Multiplo |
Torna su
Vedi anche

Documentazione

Struttura DedStateCommandCadInfo
Namespace DedNet.Commands


Campo DedStateCommand.CadInfo.ActiveMs

Campo DedStateCommandCadInfoActiveMs

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string ActiveMs
Public ActiveMs As String
public:
String^ ActiveMs
val mutable ActiveMs: string

Valore del campo

String
Vedi anche

Documentazione

Struttura DedStateCommandCadInfo
Namespace DedNet.Commands


Campo DedStateCommand.CadInfo.ChangeNote

Campo DedStateCommandCadInfoChangeNote

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string ChangeNote
Public ChangeNote As String
public:
String^ ChangeNote
val mutable ChangeNote: string

Valore del campo

String
Vedi anche

Documentazione

Struttura DedStateCommandCadInfo
Namespace DedNet.Commands


Campo DedStateCommand.CadInfo.ChangeStateDocumentDescriptors

Campo DedStateCommandCadInfoChangeStateDocumentDescriptors

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object ChangeStateDocumentDescriptors
Public ChangeStateDocumentDescriptors As Object
public:
Object^ ChangeStateDocumentDescriptors
val mutable ChangeStateDocumentDescriptors: Object

Valore del campo

Object
Vedi anche

Documentazione

Struttura DedStateCommandCadInfo
Namespace DedNet.Commands


Campo DedStateCommand.CadInfo.DocStructInfo

Campo DedStateCommandCadInfoDocStructInfo

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object DocStructInfo
Public DocStructInfo As Object
public:
Object^ DocStructInfo
val mutable DocStructInfo: Object

Valore del campo

Object
Vedi anche

Documentazione

Struttura DedStateCommandCadInfo
Namespace DedNet.Commands


Campo DedStateCommand.CadInfo.isChildOperation

Campo DedStateCommandCadInfoisChildOperation

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool isChildOperation
Public isChildOperation As Boolean
public:
bool isChildOperation
val mutable isChildOperation: bool

Valore del campo

Boolean
Vedi anche

Documentazione

Struttura DedStateCommandCadInfo
Namespace DedNet.Commands


Campo DedStateCommand.CadInfo.MultipleMainDocStructInfo

Campo DedStateCommandCadInfoMultipleMainDocStructInfo

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object MultipleMainDocStructInfo
Public MultipleMainDocStructInfo As Object
public:
Object^ MultipleMainDocStructInfo
val mutable MultipleMainDocStructInfo: Object

Valore del campo

Object
Vedi anche

Documentazione

Struttura DedStateCommandCadInfo
Namespace DedNet.Commands


Campo DedStateCommand.CadInfo.Multiplo

Campo DedStateCommandCadInfoMultiplo

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Multiplo
Public Multiplo As Boolean
public:
bool Multiplo
val mutable Multiplo: bool

Valore del campo

Boolean
Vedi anche

Documentazione

Struttura DedStateCommandCadInfo
Namespace DedNet.Commands


Classe DeleteCommAnagrCommand
Comando eliminazione di una commessa.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsDedDataCommand
DedNet.CommandsDeleteCommAnagrCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DeleteCommAnagrCommand : DedDataCommand
Public Class DeleteCommAnagrCommand
    Inherits DedDataCommand
public ref class DeleteCommAnagrCommand : public DedDataCommand
type DeleteCommAnagrCommand =
    class
        inherit DedDataCommand
    end

Il tipo DeleteCommAnagrCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DataInfos | Restituisce la lista delle anagrafiche di elaborazione comando. (Ereditato da DedDataCommand)
Proprietà pubblica | DcaList | Lista di oggetti DedCommAnagrItem
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se si vuole creare una sotto commessa ma non si passa il riferimento. (Sovrascrive DedDataCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | ReferenceComm | Commessa di riferimento
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedDataCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova. (Sovrascrive DedDataCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedDataCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedDataCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova. (Sovrascrive DedDataCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di DeleteCommAnagrCommand

Il tipo DeleteCommAnagrCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DataInfos | Restituisce la lista delle anagrafiche di elaborazione comando. (Ereditato da DedDataCommand)
Proprietà pubblica | DcaList | Lista di oggetti DedCommAnagrItem
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se si vuole creare una sotto commessa ma non si passa il riferimento. (Sovrascrive DedDataCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | ReferenceComm | Commessa di riferimento
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DeleteCommAnagrCommand
Namespace DedNet.Commands


Proprietà DeleteCommAnagrCommand.DcaList

Proprietà DeleteCommAnagrCommandDcaList
Lista di oggetti DedCommAnagrItem

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<DedCommAnagrItem> DcaList { get; set; }
Public Property DcaList As List(Of DedCommAnagrItem)
    Get
    Set
public:
property List<DedCommAnagrItem^>^ DcaList {
    List<DedCommAnagrItem^>^ get ();
    void set (List<DedCommAnagrItem^>^ value);
}
member DcaList : List<DedCommAnagrItem> with get, set

Valore della proprietà

List DedCommAnagrItem
Vedi anche

Documentazione

Classe DeleteCommAnagrCommand
Namespace DedNet.Commands


Proprietà DeleteCommAnagrCommand.NeedParameters

Proprietà DeleteCommAnagrCommandNeedParameters
Restituisce true se si vuole creare una sotto commessa ma non si passa il riferimento.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DeleteCommAnagrCommand
Namespace DedNet.Commands


Proprietà DeleteCommAnagrCommand.ReferenceComm

Proprietà DeleteCommAnagrCommandReferenceComm
Commessa di riferimento

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedComm ReferenceComm { get; set; }
Public Property ReferenceComm As DedComm
    Get
    Set
public:
property DedComm^ ReferenceComm {
    DedComm^ get ();
    void set (DedComm^ value);
}
member ReferenceComm : DedComm with get, set

Valore della proprietà

DedComm
Vedi anche

Documentazione

Classe DeleteCommAnagrCommand
Namespace DedNet.Commands


Metodi di DeleteCommAnagrCommand

Il tipo DeleteCommAnagrCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedDataCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova. (Sovrascrive DedDataCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedDataCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedDataCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova. (Sovrascrive DedDataCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DeleteCommAnagrCommand
Namespace DedNet.Commands


Metodo DeleteCommAnagrCommand.ClearCommand

Metodo DeleteCommAnagrCommandClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe DeleteCommAnagrCommand
Namespace DedNet.Commands


Metodo DeleteCommAnagrCommand.Enabled

Metodo DeleteCommAnagrCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe DeleteCommAnagrCommand
Namespace DedNet.Commands


Metodo DeleteCommAnagrCommand.ExecuteCommand

Metodo DeleteCommAnagrCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe DeleteCommAnagrCommand
Namespace DedNet.Commands


Metodo DeleteCommAnagrCommand.SetContext

Metodo DeleteCommAnagrCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto c'è una sola anagrafica alla quale associare il file.
Vedi anche

Documentazione

Classe DeleteCommAnagrCommand
Namespace DedNet.Commands


Classe DeleteCommCommand
Comando eliminazione di una commessa.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsDeleteCommCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DeleteCommCommand : DedCommand
Public Class DeleteCommCommand
    Inherits DedCommand
public ref class DeleteCommCommand : public DedCommand
type DeleteCommCommand =
    class
        inherit DedCommand
    end

Il tipo DeleteCommCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se si vuole creare una sotto commessa ma non si passa il riferimento. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | ReferenceComm | Commessa di riferimento
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di DeleteCommCommand

Il tipo DeleteCommCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se si vuole creare una sotto commessa ma non si passa il riferimento. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | ReferenceComm | Commessa di riferimento
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DeleteCommCommand
Namespace DedNet.Commands


Proprietà DeleteCommCommand.NeedParameters

Proprietà DeleteCommCommandNeedParameters
Restituisce true se si vuole creare una sotto commessa ma non si passa il riferimento.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DeleteCommCommand
Namespace DedNet.Commands


Proprietà DeleteCommCommand.ReferenceComm

Proprietà DeleteCommCommandReferenceComm
Commessa di riferimento

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedComm ReferenceComm { get; set; }
Public Property ReferenceComm As DedComm
    Get
    Set
public:
property DedComm^ ReferenceComm {
    DedComm^ get ();
    void set (DedComm^ value);
}
member ReferenceComm : DedComm with get, set

Valore della proprietà

DedComm
Vedi anche

Documentazione

Classe DeleteCommCommand
Namespace DedNet.Commands


Metodi di DeleteCommCommand

Il tipo DeleteCommCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DeleteCommCommand
Namespace DedNet.Commands


Metodo DeleteCommCommand.ClearCommand

Metodo DeleteCommCommandClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe DeleteCommCommand
Namespace DedNet.Commands


Metodo DeleteCommCommand.Enabled

Metodo DeleteCommCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe DeleteCommCommand
Namespace DedNet.Commands


Metodo DeleteCommCommand.ExecuteCommand

Metodo DeleteCommCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe DeleteCommCommand
Namespace DedNet.Commands


Metodo DeleteCommCommand.SetContext

Metodo DeleteCommCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto c'è una sola anagrafica alla quale associare il file.
Vedi anche

Documentazione

Classe DeleteCommCommand
Namespace DedNet.Commands


Classe DeleteDataCommand
Classe che rappresenta il comando per eliminare un'anagrafica dal database. Il comando controlla subito che l'utente abbia il permesso di eliminare un record, che l'anagrafica non sia rilasciata e non sia presente in nessuna distinta. Se l'anagrafica ha una distinta viene chiesto all'utente se desidera elimanarla ugualmente. Nel caso venga eliminata un'anagrafica vengono eliminati anche i documenti ad essa associati e nel caso abbia una distinta viene eliminata. Nel caso l'anagrafica sia in lavorazione viene co ntrollato se è presente una revisione superata, se c'è viene messa in lavorazione. Infine retrocede il progressivo se è l'ultimo e non sono presenti altre revisioni.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsDedDataCommand
DedNet.CommandsDeleteDataCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DeleteDataCommand : DedDataCommand
Public Class DeleteDataCommand
    Inherits DedDataCommand
public ref class DeleteDataCommand : public DedDataCommand
type DeleteDataCommand =
    class
        inherit DedDataCommand
    end

Il tipo DeleteDataCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DataInfos | Restituisce la lista delle anagrafiche di elaborazione comando. (Ereditato da DedDataCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce false se non esiste nemmeno un documento sul quale eseguire il comando. (Ereditato da DedDataCommand)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RetrocediProgr | Restituisce o imposta se retrocedere il progressivo nel caso sia possibile (di default è true).
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Sovrascrive DedDataCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base alla selezione contestuale. (Sovrascrive DedDataCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedDataCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedDataCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedDataCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di DeleteDataCommand

Il tipo DeleteDataCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DataInfos | Restituisce la lista delle anagrafiche di elaborazione comando. (Ereditato da DedDataCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce false se non esiste nemmeno un documento sul quale eseguire il comando. (Ereditato da DedDataCommand)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RetrocediProgr | Restituisce o imposta se retrocedere il progressivo nel caso sia possibile (di default è true).
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DeleteDataCommand
Namespace DedNet.Commands


Proprietà DeleteDataCommand.RetrocediProgr

Proprietà DeleteDataCommandRetrocediProgr
Restituisce o imposta se retrocedere il progressivo nel caso sia possibile (di default è true).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool RetrocediProgr { get; set; }
Public Property RetrocediProgr As Boolean
    Get
    Set
public:
property bool RetrocediProgr {
    bool get ();
    void set (bool value);
}
member RetrocediProgr : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DeleteDataCommand
Namespace DedNet.Commands


Metodi di DeleteDataCommand

Il tipo DeleteDataCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Sovrascrive DedDataCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base alla selezione contestuale. (Sovrascrive DedDataCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedDataCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedDataCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedDataCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DeleteDataCommand
Namespace DedNet.Commands


Metodo DeleteDataCommand.ClearCommand

Metodo DeleteDataCommandClearCommand
Azzera il comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe DeleteDataCommand
Namespace DedNet.Commands


Metodo DeleteDataCommand.Enabled

Metodo DeleteDataCommandEnabled
Restituisce se il comando sia abilitato in base alla selezione contestuale.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe DeleteDataCommand
Namespace DedNet.Commands


Metodo DeleteDataCommand.ExecuteCommand

Metodo DeleteDataCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe DeleteDataCommand
Namespace DedNet.Commands


Metodo DeleteDataCommand.SetContext

Metodo DeleteDataCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe DeleteDataCommand
Namespace DedNet.Commands


Classe DeleteEcoCommand
Comando usato per cancellare un ECO dal database.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsDeleteEcoCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DeleteEcoCommand : DedCommand
Public Class DeleteEcoCommand
    Inherits DedCommand
public ref class DeleteEcoCommand : public DedCommand
type DeleteEcoCommand =
    class
        inherit DedCommand
    end

Il tipo DeleteEcoCommand espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DeleteEcoCommand | Costruttore.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Eco | Oggeto DedEco da eliminare.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve essere impostata la struttura di salvataggio distinta. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Imposta il contesto del comando. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Costruttore DeleteEcoCommand
Costruttore.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DeleteEcoCommand(
    DedNetApplication app,
    string internalName,
    string name
)
Public Sub New (
    app As DedNetApplication,
    internalName As String,
    name As String
)
public:
DeleteEcoCommand(
    DedNetApplication^ app,
    String^ internalName,
    String^ name
)
new :
        app : DedNetApplication *
        internalName : string *
        name : string -> DeleteEcoCommand

Parametri

app DedNetApplication
Riferimento all'oggetto DedNetApplication.
internalName String
Nome interno del comando.
name String
Nome visualizzato del comando.
Vedi anche

Documentazione

Classe DeleteEcoCommand
Namespace DedNet.Commands


Proprietà di DeleteEcoCommand

Il tipo DeleteEcoCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Eco | Oggeto DedEco da eliminare.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve essere impostata la struttura di salvataggio distinta. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DeleteEcoCommand
Namespace DedNet.Commands


Proprietà DeleteEcoCommand.Eco

Proprietà DeleteEcoCommandEco
Oggeto DedEco da eliminare.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEco Eco { get; set; }
Public Property Eco As DedEco
    Get
    Set
public:
property DedEco^ Eco {
    DedEco^ get ();
    void set (DedEco^ value);
}
member Eco : DedEco with get, set

Valore della proprietà

DedEco
Vedi anche

Documentazione

Classe DeleteEcoCommand
Namespace DedNet.Commands


Proprietà DeleteEcoCommand.NeedParameters

Proprietà DeleteEcoCommandNeedParameters
Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve essere impostata la struttura di salvataggio distinta.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DeleteEcoCommand
Namespace DedNet.Commands


Metodi di DeleteEcoCommand

Il tipo DeleteEcoCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Imposta il contesto del comando. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DeleteEcoCommand
Namespace DedNet.Commands


Metodo DeleteEcoCommand.ClearCommand

Metodo DeleteEcoCommandClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe DeleteEcoCommand
Namespace DedNet.Commands


Metodo DeleteEcoCommand.Enabled

Metodo DeleteEcoCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe DeleteEcoCommand
Namespace DedNet.Commands


Metodo DeleteEcoCommand.ExecuteCommand

Metodo DeleteEcoCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe DeleteEcoCommand
Namespace DedNet.Commands


Metodo DeleteEcoCommand.SetContext

Metodo DeleteEcoCommandSetContext
Imposta il contesto del comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DeleteEcoCommand
Namespace DedNet.Commands


Classe DeleteFolder
Elimina una cartella.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsDeleteFolder

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DeleteFolder : DedCommand
Public Class DeleteFolder
    Inherits DedCommand
public ref class DeleteFolder : public DedCommand
type DeleteFolder =
    class
        inherit DedCommand
    end

Il tipo DeleteFolder espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non è impostato alcun file dal quale creare il documento. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Path |
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. Restituisce sempre false perché questo è utilizzato come sotto-comando. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Restituisce sempre false perché questo è utilizzato come sotto-comando. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di DeleteFolder

Il tipo DeleteFolder espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non è impostato alcun file dal quale creare il documento. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Path |
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DeleteFolder
Namespace DedNet.Commands


Proprietà DeleteFolder.NeedParameters

Proprietà DeleteFolderNeedParameters
Restituisce true se non è impostato alcun file dal quale creare il documento.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DeleteFolder
Namespace DedNet.Commands


Proprietà DeleteFolder.Path

Proprietà DeleteFolderPath

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> Path { get; set; }
Public Property Path As List(Of String)
    Get
    Set
public:
property List<String^>^ Path {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
member Path : List<string> with get, set

Valore della proprietà

List String
Vedi anche

Documentazione

Classe DeleteFolder
Namespace DedNet.Commands


Metodi di DeleteFolder

Il tipo DeleteFolder espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. Restituisce sempre false perché questo è utilizzato come sotto-comando. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Restituisce sempre false perché questo è utilizzato come sotto-comando. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DeleteFolder
Namespace DedNet.Commands


Metodo DeleteFolder.ClearCommand

Metodo DeleteFolderClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe DeleteFolder
Namespace DedNet.Commands


Metodo DeleteFolder.Enabled

Metodo DeleteFolderEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale. Restituisce sempre false perché questo è utilizzato come sotto-comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce sempre false.
Vedi anche

Documentazione

Classe DeleteFolder
Namespace DedNet.Commands


Metodo DeleteFolder.ExecuteCommand

Metodo DeleteFolderExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe DeleteFolder
Namespace DedNet.Commands


Metodo DeleteFolder.SetContext

Metodo DeleteFolderSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Restituisce sempre false perché questo è utilizzato come sotto-comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce sempre false.
Vedi anche

Documentazione

Classe DeleteFolder
Namespace DedNet.Commands


Classe DisconnectCommDocument
Comando che permette di scollegare uno o più documenti da una commedsa. Non chiede alcuna selezione all'utente e devono essere specificati tutti i dati necessari all'esecuzione del comando. Se un documento è collegato ad un solo riferimento commessa/anagrafica e viene scollegato viene chiesto all'utente se lo si desidera eliminare, se UseUI è a true, altrimenti il comando non elimina il documento ma lo scollega soltando dalla commessa.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsDisconnectCommDocument

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DisconnectCommDocument : DedCommand
Public Class DisconnectCommDocument
    Inherits DedCommand
public ref class DisconnectCommDocument : public DedCommand
type DisconnectCommDocument =
    class
        inherit DedCommand
    end

Il tipo DisconnectCommDocument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | AskDeleteIfNoMoreRef | Restituisce o imposta se chiedere all'utente di cancellare il documento qualora questo non sia più collegato ad alcun riferimento. Il suo valore di default è true. Se la proprietà UseUI è impostata a false questa opzione viene ignorata e non viene mai cancellato il documento.
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Comm | Restituisce o imposta la commessa dalla quale scollegare tutti i documenti.
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | FileList | Restituisce la lista dei documenti da scollegare dalla commessa.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se è impostata la commessa ed almeno un documento da scollegare. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di DisconnectCommDocument

Il tipo DisconnectCommDocument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | AskDeleteIfNoMoreRef | Restituisce o imposta se chiedere all'utente di cancellare il documento qualora questo non sia più collegato ad alcun riferimento. Il suo valore di default è true. Se la proprietà UseUI è impostata a false questa opzione viene ignorata e non viene mai cancellato il documento.
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Comm | Restituisce o imposta la commessa dalla quale scollegare tutti i documenti.
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | FileList | Restituisce la lista dei documenti da scollegare dalla commessa.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se è impostata la commessa ed almeno un documento da scollegare. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DisconnectCommDocument
Namespace DedNet.Commands


Proprietà DisconnectCommDocument.AskDeleteIfNoMoreRef

Proprietà DisconnectCommDocumentAskDeleteIfNoMoreRef
Restituisce o imposta se chiedere all'utente di cancellare il documento qualora questo non sia più collegato ad alcun riferimento. Il suo valore di default è true. Se la proprietà UseUI è impostata a false questa opzione viene ignorata e non viene mai cancellato il documento.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AskDeleteIfNoMoreRef { get; set; }
Public Property AskDeleteIfNoMoreRef As Boolean
    Get
    Set
public:
property bool AskDeleteIfNoMoreRef {
    bool get ();
    void set (bool value);
}
member AskDeleteIfNoMoreRef : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DisconnectCommDocument
Namespace DedNet.Commands


Proprietà DisconnectCommDocument.Comm

Proprietà DisconnectCommDocumentComm
Restituisce o imposta la commessa dalla quale scollegare tutti i documenti.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedComm Comm { get; set; }
Public Property Comm As DedComm
    Get
    Set
public:
property DedComm^ Comm {
    DedComm^ get ();
    void set (DedComm^ value);
}
member Comm : DedComm with get, set

Valore della proprietà

DedComm
Vedi anche

Documentazione

Classe DisconnectCommDocument
Namespace DedNet.Commands


Proprietà DisconnectCommDocument.FileList

Proprietà DisconnectCommDocumentFileList
Restituisce la lista dei documenti da scollegare dalla commessa.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfoList FileList { get; }
Public ReadOnly Property FileList As DocStructInfoList
    Get
public:
property DocStructInfoList^ FileList {
    DocStructInfoList^ get ();
}
member FileList : DocStructInfoList with get

Valore della proprietà

DocStructInfoList
Vedi anche

Documentazione

Classe DisconnectCommDocument
Namespace DedNet.Commands


Proprietà DisconnectCommDocument.NeedParameters

Proprietà DisconnectCommDocumentNeedParameters
Restituisce true se è impostata la commessa ed almeno un documento da scollegare.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DisconnectCommDocument
Namespace DedNet.Commands


Metodi di DisconnectCommDocument

Il tipo DisconnectCommDocument espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DisconnectCommDocument
Namespace DedNet.Commands


Metodo DisconnectCommDocument.ClearCommand

Metodo DisconnectCommDocumentClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe DisconnectCommDocument
Namespace DedNet.Commands


Metodo DisconnectCommDocument.Enabled

Metodo DisconnectCommDocumentEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe DisconnectCommDocument
Namespace DedNet.Commands


Metodo DisconnectCommDocument.ExecuteCommand

Metodo DisconnectCommDocumentExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe DisconnectCommDocument
Namespace DedNet.Commands


Metodo DisconnectCommDocument.SetContext

Metodo DisconnectCommDocumentSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto c'è una commessa dalla quale scollegare i file.
Vedi anche

Documentazione

Classe DisconnectCommDocument
Namespace DedNet.Commands


Classe DisconnectDocument
Comando che permette di scollegare uno o più documenti da un'anagrafica. Non chiede alcuna selezione all'utente e devono essere specificati tutti i dati necessari all'esecuzione del comando. Se un documento è collegato ad una sola anagrafica e viene scollegato viene chiesto all'utente se lo si desidera eliminare, se UseUI è a true, altrimenti il comando non elimina il documento ma lo scollega soltando dall'anagrafica.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsDisconnectDocument

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DisconnectDocument : DedCommand
Public Class DisconnectDocument
    Inherits DedCommand
public ref class DisconnectDocument : public DedCommand
type DisconnectDocument =
    class
        inherit DedCommand
    end

Il tipo DisconnectDocument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Data | Restituisce o imposta l'anagrafica dalla quale scollegare tutti i documenti.
Proprietà pubblica | DataList | Lista di anagrafiche dalle quali scollegare i documenti.
Proprietà pubblica | DeleteIfNoMoreAnagr | Restituisce o imposta se eliminare il documento nel caso non sia collegato ad altre anagrafiche. Il suo valore di default è true. Questa opzione viene sempre valutata anche se la proprietà UseUI è impostata a false.
Proprietà pubblica | FileList | Restituisce la lista dei documenti da scollegare dall'anagrafica.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se è impostata la lista di anagrafiche ed almeno un documento da scollegare. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di DisconnectDocument

Il tipo DisconnectDocument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Data | Restituisce o imposta l'anagrafica dalla quale scollegare tutti i documenti.
Proprietà pubblica | DataList | Lista di anagrafiche dalle quali scollegare i documenti.
Proprietà pubblica | DeleteIfNoMoreAnagr | Restituisce o imposta se eliminare il documento nel caso non sia collegato ad altre anagrafiche. Il suo valore di default è true. Questa opzione viene sempre valutata anche se la proprietà UseUI è impostata a false.
Proprietà pubblica | FileList | Restituisce la lista dei documenti da scollegare dall'anagrafica.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se è impostata la lista di anagrafiche ed almeno un documento da scollegare. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DisconnectDocument
Namespace DedNet.Commands


Proprietà DisconnectDocument.Data

Proprietà DisconnectDocumentData
Restituisce o imposta l'anagrafica dalla quale scollegare tutti i documenti.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; set; }
Public Property Data As DedData
    Get
    Set
public:
property DedData^ Data {
    DedData^ get ();
    void set (DedData^ value);
}
member Data : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe DisconnectDocument
Namespace DedNet.Commands


Proprietà DisconnectDocument.DataList

Proprietà DisconnectDocumentDataList
Lista di anagrafiche dalle quali scollegare i documenti.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataList DataList { get; set; }
Public Property DataList As DedDataList
    Get
    Set
public:
property DedDataList^ DataList {
    DedDataList^ get ();
    void set (DedDataList^ value);
}
member DataList : DedDataList with get, set

Valore della proprietà

DedDataList
Vedi anche

Documentazione

Classe DisconnectDocument
Namespace DedNet.Commands


Proprietà DisconnectDocument.DeleteIfNoMoreAnagr

Proprietà DisconnectDocumentDeleteIfNoMoreAnagr
Restituisce o imposta se eliminare il documento nel caso non sia collegato ad altre anagrafiche. Il suo valore di default è true. Questa opzione viene sempre valutata anche se la proprietà UseUI è impostata a false.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool DeleteIfNoMoreAnagr { get; set; }
Public Property DeleteIfNoMoreAnagr As Boolean
    Get
    Set
public:
property bool DeleteIfNoMoreAnagr {
    bool get ();
    void set (bool value);
}
member DeleteIfNoMoreAnagr : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DisconnectDocument
Namespace DedNet.Commands


Proprietà DisconnectDocument.FileList

Proprietà DisconnectDocumentFileList
Restituisce la lista dei documenti da scollegare dall'anagrafica.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfoList FileList { get; }
Public ReadOnly Property FileList As DocStructInfoList
    Get
public:
property DocStructInfoList^ FileList {
    DocStructInfoList^ get ();
}
member FileList : DocStructInfoList with get

Valore della proprietà

DocStructInfoList
Vedi anche

Documentazione

Classe DisconnectDocument
Namespace DedNet.Commands


Proprietà DisconnectDocument.NeedParameters

Proprietà DisconnectDocumentNeedParameters
Restituisce true se è impostata la lista di anagrafiche ed almeno un documento da scollegare.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DisconnectDocument
Namespace DedNet.Commands


Metodi di DisconnectDocument

Il tipo DisconnectDocument espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DisconnectDocument
Namespace DedNet.Commands


Metodo DisconnectDocument.ClearCommand

Metodo DisconnectDocumentClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe DisconnectDocument
Namespace DedNet.Commands


Metodo DisconnectDocument.Enabled

Metodo DisconnectDocumentEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe DisconnectDocument
Namespace DedNet.Commands


Metodo DisconnectDocument.ExecuteCommand

Metodo DisconnectDocumentExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe DisconnectDocument
Namespace DedNet.Commands


Metodo DisconnectDocument.SetContext

Metodo DisconnectDocumentSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto c'è una sola anagrafica alla quale associare il file.
Vedi anche

Documentazione

Classe DisconnectDocument
Namespace DedNet.Commands


Classe DistEsplCommand
Apre la finestra di Distinta Esplosa per un'anagrafica.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsDedDataCommand
DedNet.CommandsDistEsplCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DistEsplCommand : DedDataCommand
Public Class DistEsplCommand
    Inherits DedDataCommand
public ref class DistEsplCommand : public DedDataCommand
type DistEsplCommand =
    class
        inherit DedDataCommand
    end

Il tipo DistEsplCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CurDiscrimDist | Discriminante di distinta
Proprietà pubblica | DataInfos | Restituisce la lista delle anagrafiche di elaborazione comando. (Ereditato da DedDataCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce false se non esiste nemmeno un documento sul quale eseguire il comando. (Ereditato da DedDataCommand)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Esegue la pulizia del comando. Azzera tutte le variabili. (Ereditato da DedDataCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedDataCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedDataCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedDataCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedDataCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di DistEsplCommand

Il tipo DistEsplCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CurDiscrimDist | Discriminante di distinta
Proprietà pubblica | DataInfos | Restituisce la lista delle anagrafiche di elaborazione comando. (Ereditato da DedDataCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce false se non esiste nemmeno un documento sul quale eseguire il comando. (Ereditato da DedDataCommand)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DistEsplCommand
Namespace DedNet.Commands


Proprietà DistEsplCommand.CurDiscrimDist

Proprietà DistEsplCommandCurDiscrimDist
Discriminante di distinta

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string CurDiscrimDist { get; set; }
Public Property CurDiscrimDist As String
    Get
    Set
public:
property String^ CurDiscrimDist {
    String^ get ();
    void set (String^ value);
}
member CurDiscrimDist : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DistEsplCommand
Namespace DedNet.Commands


Metodi di DistEsplCommand

Il tipo DistEsplCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Esegue la pulizia del comando. Azzera tutte le variabili. (Ereditato da DedDataCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedDataCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedDataCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedDataCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedDataCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DistEsplCommand
Namespace DedNet.Commands


Metodo DistEsplCommand.Enabled

Metodo DistEsplCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe DistEsplCommand
Namespace DedNet.Commands


Metodo DistEsplCommand.ExecuteCommand

Metodo DistEsplCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe DistEsplCommand
Namespace DedNet.Commands


Metodo DistEsplCommand.SetContext

Metodo DistEsplCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe DistEsplCommand
Namespace DedNet.Commands


Classe DistImplCommand
Apre la finestra di Distinta Implosa di un'anagrafica.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsDedDataCommand
DedNet.CommandsDistImplCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DistImplCommand : DedDataCommand
Public Class DistImplCommand
    Inherits DedDataCommand
public ref class DistImplCommand : public DedDataCommand
type DistImplCommand =
    class
        inherit DedDataCommand
    end

Il tipo DistImplCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CurDiscrimDist | Discriminante di distinta
Proprietà pubblica | DataInfos | Restituisce la lista delle anagrafiche di elaborazione comando. (Ereditato da DedDataCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce false se non esiste nemmeno un documento sul quale eseguire il comando. (Ereditato da DedDataCommand)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Esegue la pulizia del comando. Azzera tutte le variabili. (Ereditato da DedDataCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedDataCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedDataCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedDataCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedDataCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di DistImplCommand

Il tipo DistImplCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CurDiscrimDist | Discriminante di distinta
Proprietà pubblica | DataInfos | Restituisce la lista delle anagrafiche di elaborazione comando. (Ereditato da DedDataCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce false se non esiste nemmeno un documento sul quale eseguire il comando. (Ereditato da DedDataCommand)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DistImplCommand
Namespace DedNet.Commands


Proprietà DistImplCommand.CurDiscrimDist

Proprietà DistImplCommandCurDiscrimDist
Discriminante di distinta

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string CurDiscrimDist { get; set; }
Public Property CurDiscrimDist As String
    Get
    Set
public:
property String^ CurDiscrimDist {
    String^ get ();
    void set (String^ value);
}
member CurDiscrimDist : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DistImplCommand
Namespace DedNet.Commands


Metodi di DistImplCommand

Il tipo DistImplCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Esegue la pulizia del comando. Azzera tutte le variabili. (Ereditato da DedDataCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedDataCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedDataCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedDataCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedDataCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DistImplCommand
Namespace DedNet.Commands


Metodo DistImplCommand.Enabled

Metodo DistImplCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe DistImplCommand
Namespace DedNet.Commands


Metodo DistImplCommand.ExecuteCommand

Metodo DistImplCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe DistImplCommand
Namespace DedNet.Commands


Metodo DistImplCommand.SetContext

Metodo DistImplCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe DistImplCommand
Namespace DedNet.Commands


Classe DocAssocCommand
Mostra la finestra di ricerca con la lista delle anagrafiche alle quali un documento è associato.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsDocAssocCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DocAssocCommand : DedCommand
Public Class DocAssocCommand
    Inherits DedCommand
public ref class DocAssocCommand : public DedCommand
type DocAssocCommand =
    class
        inherit DedCommand
    end

Il tipo DocAssocCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Data | Restituisce l'anagrafica selezionata.
Proprietà pubblica | DocId |
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowOnly |
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di DocAssocCommand

Il tipo DocAssocCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Data | Restituisce l'anagrafica selezionata.
Proprietà pubblica | DocId |
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowOnly |
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DocAssocCommand
Namespace DedNet.Commands


Proprietà DocAssocCommand.Data

Proprietà DocAssocCommandData
Restituisce l'anagrafica selezionata.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; }
Public ReadOnly Property Data As DedData
    Get
public:
property DedData^ Data {
    DedData^ get ();
}
member Data : DedData with get

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe DocAssocCommand
Namespace DedNet.Commands


Proprietà DocAssocCommand.DocId

Proprietà DocAssocCommandDocId

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Guid DocId { set; }
Public WriteOnly Property DocId As Guid
    Set
public:
property Guid DocId {
    void set (Guid value);
}
member DocId : Guid with set

Valore della proprietà

Guid
Vedi anche

Documentazione

Classe DocAssocCommand
Namespace DedNet.Commands


Proprietà DocAssocCommand.NeedParameters

Proprietà DocAssocCommandNeedParameters

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocAssocCommand
Namespace DedNet.Commands


Proprietà DocAssocCommand.ShowOnly

Proprietà DocAssocCommandShowOnly

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ShowOnly { set; }
Public WriteOnly Property ShowOnly As Boolean
    Set
public:
property bool ShowOnly {
    void set (bool value);
}
member ShowOnly : bool with set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocAssocCommand
Namespace DedNet.Commands


Metodi di DocAssocCommand

Il tipo DocAssocCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DocAssocCommand
Namespace DedNet.Commands


Metodo DocAssocCommand.ClearCommand

Metodo DocAssocCommandClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe DocAssocCommand
Namespace DedNet.Commands


Metodo DocAssocCommand.Enabled

Metodo DocAssocCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe DocAssocCommand
Namespace DedNet.Commands


Metodo DocAssocCommand.ExecuteCommand

Metodo DocAssocCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe DocAssocCommand
Namespace DedNet.Commands


Metodo DocAssocCommand.SetContext

Metodo DocAssocCommandSetContext

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DocAssocCommand
Namespace DedNet.Commands


Classe DocHistoryCommand
Classe che rappresenta il comando per visualizzare tutti i padri di un determinato documento ( ovvero dove viene usato in altri documenti ).
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsDedDocumentCommand
DedNet.CommandsDocHistoryCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DocHistoryCommand : DedDocumentCommand
Public Class DocHistoryCommand
    Inherits DedDocumentCommand
public ref class DocHistoryCommand : public DedDocumentCommand
type DocHistoryCommand =
    class
        inherit DedDocumentCommand
    end

Il tipo DocHistoryCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DocumentInfos | Restituisce la lista dei documenti con abbinato il contesto di anagrafica di elaborazione comando. (Ereditato da DedDocumentCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedDocumentCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Reinizializza il comando. (Ereditato da DedDocumentCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedDocumentCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedDocumentCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedDocumentCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedDocumentCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di DocHistoryCommand

Il tipo DocHistoryCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DocumentInfos | Restituisce la lista dei documenti con abbinato il contesto di anagrafica di elaborazione comando. (Ereditato da DedDocumentCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedDocumentCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DocHistoryCommand
Namespace DedNet.Commands


Proprietà DocHistoryCommand.NeedParameters

Proprietà DocHistoryCommandNeedParameters

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocHistoryCommand
Namespace DedNet.Commands


Metodi di DocHistoryCommand

Il tipo DocHistoryCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Reinizializza il comando. (Ereditato da DedDocumentCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedDocumentCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedDocumentCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedDocumentCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedDocumentCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DocHistoryCommand
Namespace DedNet.Commands


Metodo DocHistoryCommand.Enabled

Metodo DocHistoryCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe DocHistoryCommand
Namespace DedNet.Commands


Metodo DocHistoryCommand.ExecuteCommand

Metodo DocHistoryCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe DocHistoryCommand
Namespace DedNet.Commands


Metodo DocHistoryCommand.SetContext

Metodo DocHistoryCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe DocHistoryCommand
Namespace DedNet.Commands


Classe DocRecognizerCommand
Mostra la finestra per la registrazione di documenti che si trovano nelle root ma che non hanno ancora l'oggetto associato
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsDocRecognizerCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DocRecognizerCommand : DedCommand
Public Class DocRecognizerCommand
    Inherits DedCommand
public ref class DocRecognizerCommand : public DedCommand
type DocRecognizerCommand =
    class
        inherit DedCommand
    end

Il tipo DocRecognizerCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Paramerti richiesti (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Il comando sarà sempre abilitato (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. Il form gestisce tutta l'elaborazione. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Il setContext al momento non esegue alcuna operazione (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di DocRecognizerCommand

Il tipo DocRecognizerCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Paramerti richiesti (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DocRecognizerCommand
Namespace DedNet.Commands


Proprietà DocRecognizerCommand.NeedParameters

Proprietà DocRecognizerCommandNeedParameters
Paramerti richiesti

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocRecognizerCommand
Namespace DedNet.Commands


Metodi di DocRecognizerCommand

Il tipo DocRecognizerCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Il comando sarà sempre abilitato (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. Il form gestisce tutta l'elaborazione. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Il setContext al momento non esegue alcuna operazione (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DocRecognizerCommand
Namespace DedNet.Commands


Metodo DocRecognizerCommand.ClearCommand

Metodo DocRecognizerCommandClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe DocRecognizerCommand
Namespace DedNet.Commands


Metodo DocRecognizerCommand.Enabled

Metodo DocRecognizerCommandEnabled
Il comando sarà sempre abilitato

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe DocRecognizerCommand
Namespace DedNet.Commands


Metodo DocRecognizerCommand.ExecuteCommand

Metodo DocRecognizerCommandExecuteCommand
Esegue il comando vero e proprio. Il form gestisce tutta l'elaborazione.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe DocRecognizerCommand
Namespace DedNet.Commands


Metodo DocRecognizerCommand.SetContext

Metodo DocRecognizerCommandSetContext
Il setContext al momento non esegue alcuna operazione

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DocRecognizerCommand
Namespace DedNet.Commands


Classe DocStructAnnullaCheckOutOperation
Annulla l'operazione di check-out, ripristinando sia il file fisico che il record.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDocStructOperationBase
DedNet.CommandsDocStructAnnullaCheckOutOperation

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DocStructAnnullaCheckOutOperation : DocStructOperationBase
Public Class DocStructAnnullaCheckOutOperation
    Inherits DocStructOperationBase
public ref class DocStructAnnullaCheckOutOperation : public DocStructOperationBase
type DocStructAnnullaCheckOutOperation =
    class
        inherit DocStructOperationBase
    end

Il tipo DocStructAnnullaCheckOutOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CurrentWorkingFileName | Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | DeletingPwsFile | Restituisce se il comando eliminerà o meno il documento in locale.
Proprietà pubblica | Document | Restituisce il documento abbinato al file oppure null se non è registrato nel Database. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Exists | Restituisce se il file sia presente nel percorso corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | FileOperationExecuted | Restituisce se le operazioni sui file siano già state effettuate. (Sovrascrive DocStructOperationBaseFileOperationExecuted)
Proprietà pubblica | ForcedDocId | Restituisce oppure imposta la versione del DocId forzata per la creazione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasDocument | Restituisce se il file sia registrato nel Database come documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasForcedDocId | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasRowver | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsElaborated | Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsNew | Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato). (Ereditato da DocStructOperationBase)
Proprietà pubblica | Operation | Restituisce l'operazione che caratterizza questo elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Parent | Restituisce l'oggetto di appartenenza. (Ereditato da DocStructOperationBase)
Proprietà pubblica | PrecOperation | Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso file dell'elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RowVer | Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | SkipReferenceUpdate | Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false. (Ereditato da DocStructOperationBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | CalcolaNomeSostituto | Calcola e restituisce il percorso completo di destinazione del sostituto. (Ereditato da DocStructOperationBase)
Metodo protetto | UpdateDependences | Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di DocStructAnnullaCheckOutOperation

Il tipo DocStructAnnullaCheckOutOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CurrentWorkingFileName | Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | DeletingPwsFile | Restituisce se il comando eliminerà o meno il documento in locale.
Proprietà pubblica | Document | Restituisce il documento abbinato al file oppure null se non è registrato nel Database. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Exists | Restituisce se il file sia presente nel percorso corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | FileOperationExecuted | Restituisce se le operazioni sui file siano già state effettuate. (Sovrascrive DocStructOperationBaseFileOperationExecuted)
Proprietà pubblica | ForcedDocId | Restituisce oppure imposta la versione del DocId forzata per la creazione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasDocument | Restituisce se il file sia registrato nel Database come documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasForcedDocId | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasRowver | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsElaborated | Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsNew | Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato). (Ereditato da DocStructOperationBase)
Proprietà pubblica | Operation | Restituisce l'operazione che caratterizza questo elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Parent | Restituisce l'oggetto di appartenenza. (Ereditato da DocStructOperationBase)
Proprietà pubblica | PrecOperation | Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso file dell'elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RowVer | Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | SkipReferenceUpdate | Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Classe DocStructAnnullaCheckOutOperation
Namespace DedNet.Commands


Proprietà DocStructAnnullaCheckOutOperation.DeletingPwsFile

Proprietà DocStructAnnullaCheckOutOperationDeletingPwsFile
Restituisce se il comando eliminerà o meno il documento in locale.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool DeletingPwsFile { get; }
Public ReadOnly Property DeletingPwsFile As Boolean
    Get
public:
property bool DeletingPwsFile {
    bool get ();
}
member DeletingPwsFile : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructAnnullaCheckOutOperation
Namespace DedNet.Commands


Proprietà DocStructAnnullaCheckOutOperation.FileOperationExecuted

Proprietà DocStructAnnullaCheckOutOperationFileOperationExecuted
Restituisce se le operazioni sui file siano già state effettuate.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool FileOperationExecuted { get; }
Public Overrides ReadOnly Property FileOperationExecuted As Boolean
    Get
public:
virtual property bool FileOperationExecuted {
    bool get () override;
}
abstract FileOperationExecuted : bool with get
override FileOperationExecuted : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructAnnullaCheckOutOperation
Namespace DedNet.Commands


Metodi di DocStructAnnullaCheckOutOperation

Il tipo DocStructAnnullaCheckOutOperation espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | CalcolaNomeSostituto | Calcola e restituisce il percorso completo di destinazione del sostituto. (Ereditato da DocStructOperationBase)
Metodo protetto | UpdateDependences | Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Classe DocStructAnnullaCheckOutOperation
Namespace DedNet.Commands


Classe DocStructCheckInOperation
Mette in checkin un documento.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDocStructOperationBase
DedNet.CommandsDocStructCheckInOperation

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DocStructCheckInOperation : DocStructOperationBase
Public Class DocStructCheckInOperation
    Inherits DocStructOperationBase
public ref class DocStructCheckInOperation : public DocStructOperationBase
type DocStructCheckInOperation =
    class
        inherit DocStructOperationBase
    end

Il tipo DocStructCheckInOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CurrentWorkingFileName | Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | DeletingPwsFile | Restituisce se il comando eliminerà o meno il documento in locale.
Proprietà pubblica | Document | Restituisce il documento abbinato al file oppure null se non è registrato nel Database. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Exists | Restituisce se il file sia presente nel percorso corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | FileOperationExecuted | Restituisce se le operazioni sui file siano già state effettuate. (Sovrascrive DocStructOperationBaseFileOperationExecuted)
Proprietà pubblica | ForcedDocId | Restituisce oppure imposta la versione del DocId forzata per la creazione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasDocument | Restituisce se il file sia registrato nel Database come documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasForcedDocId | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasRowver | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsElaborated | Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsNew | Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato). (Ereditato da DocStructOperationBase)
Proprietà pubblica | Operation | Restituisce l'operazione che caratterizza questo elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Parent | Restituisce l'oggetto di appartenenza. (Ereditato da DocStructOperationBase)
Proprietà pubblica | PrecOperation | Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso file dell'elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RowVer | Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | SkipReferenceUpdate | Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false. (Ereditato da DocStructOperationBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | CalcolaNomeSostituto | Calcola e restituisce il percorso completo di destinazione del sostituto. (Ereditato da DocStructOperationBase)
Metodo protetto | UpdateDependences | Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di DocStructCheckInOperation

Il tipo DocStructCheckInOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CurrentWorkingFileName | Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | DeletingPwsFile | Restituisce se il comando eliminerà o meno il documento in locale.
Proprietà pubblica | Document | Restituisce il documento abbinato al file oppure null se non è registrato nel Database. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Exists | Restituisce se il file sia presente nel percorso corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | FileOperationExecuted | Restituisce se le operazioni sui file siano già state effettuate. (Sovrascrive DocStructOperationBaseFileOperationExecuted)
Proprietà pubblica | ForcedDocId | Restituisce oppure imposta la versione del DocId forzata per la creazione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasDocument | Restituisce se il file sia registrato nel Database come documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasForcedDocId | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasRowver | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsElaborated | Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsNew | Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato). (Ereditato da DocStructOperationBase)
Proprietà pubblica | Operation | Restituisce l'operazione che caratterizza questo elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Parent | Restituisce l'oggetto di appartenenza. (Ereditato da DocStructOperationBase)
Proprietà pubblica | PrecOperation | Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso file dell'elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RowVer | Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | SkipReferenceUpdate | Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Classe DocStructCheckInOperation
Namespace DedNet.Commands


Proprietà DocStructCheckInOperation.DeletingPwsFile

Proprietà DocStructCheckInOperationDeletingPwsFile
Restituisce se il comando eliminerà o meno il documento in locale.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool DeletingPwsFile { get; }
Public ReadOnly Property DeletingPwsFile As Boolean
    Get
public:
property bool DeletingPwsFile {
    bool get ();
}
member DeletingPwsFile : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructCheckInOperation
Namespace DedNet.Commands


Proprietà DocStructCheckInOperation.FileOperationExecuted

Proprietà DocStructCheckInOperationFileOperationExecuted
Restituisce se le operazioni sui file siano già state effettuate.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool FileOperationExecuted { get; }
Public Overrides ReadOnly Property FileOperationExecuted As Boolean
    Get
public:
virtual property bool FileOperationExecuted {
    bool get () override;
}
abstract FileOperationExecuted : bool with get
override FileOperationExecuted : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructCheckInOperation
Namespace DedNet.Commands


Metodi di DocStructCheckInOperation

Il tipo DocStructCheckInOperation espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | CalcolaNomeSostituto | Calcola e restituisce il percorso completo di destinazione del sostituto. (Ereditato da DocStructOperationBase)
Metodo protetto | UpdateDependences | Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Classe DocStructCheckInOperation
Namespace DedNet.Commands


Classe DocStructCheckInStrutturaOperation
Esegue il check-in sul documento e su tutte le sue dipendenze, se su queste è possibile effettuare l'operazione.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDocStructOperationBase
DedNet.CommandsDocStructCheckInStrutturaOperation

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DocStructCheckInStrutturaOperation : DocStructOperationBase
Public Class DocStructCheckInStrutturaOperation
    Inherits DocStructOperationBase
public ref class DocStructCheckInStrutturaOperation : public DocStructOperationBase
type DocStructCheckInStrutturaOperation =
    class
        inherit DocStructOperationBase
    end

Il tipo DocStructCheckInStrutturaOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CurrentWorkingFileName | Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | DeletingPwsFile | Restituisce se il comando eliminerà o meno il documento in locale.
Proprietà pubblica | Document | Restituisce il documento abbinato al file oppure null se non è registrato nel Database. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Exists | Restituisce se il file sia presente nel percorso corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | FileOperationExecuted | Restituisce se le operazioni sui file siano già state effettuate. (Sovrascrive DocStructOperationBaseFileOperationExecuted)
Proprietà pubblica | ForcedDocId | Restituisce oppure imposta la versione del DocId forzata per la creazione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasDocument | Restituisce se il file sia registrato nel Database come documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasForcedDocId | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasRowver | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsChildren | Restitusice se questa operazione di check-in struttura sia una operazione di testa oppure se si tratti di un sotto-documento. Di default é false.
Proprietà pubblica | IsElaborated | Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsNew | Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato). (Ereditato da DocStructOperationBase)
Proprietà pubblica | Operation | Restituisce l'operazione che caratterizza questo elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Parent | Restituisce l'oggetto di appartenenza. (Ereditato da DocStructOperationBase)
Proprietà pubblica | PrecOperation | Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione. (Ereditato da DocStructOperationBase)
Proprietà pubblica | ResultOperation | Dizionario che contiene i risultati del comando sui singoli documenti
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso file dell'elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RowVer | Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | SkipReferenceUpdate | Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false. (Ereditato da DocStructOperationBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | CalcolaNomeSostituto | Calcola e restituisce il percorso completo di destinazione del sostituto. (Ereditato da DocStructOperationBase)
Metodo protetto | UpdateDependences | Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di DocStructCheckInStrutturaOperation

Il tipo DocStructCheckInStrutturaOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CurrentWorkingFileName | Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | DeletingPwsFile | Restituisce se il comando eliminerà o meno il documento in locale.
Proprietà pubblica | Document | Restituisce il documento abbinato al file oppure null se non è registrato nel Database. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Exists | Restituisce se il file sia presente nel percorso corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | FileOperationExecuted | Restituisce se le operazioni sui file siano già state effettuate. (Sovrascrive DocStructOperationBaseFileOperationExecuted)
Proprietà pubblica | ForcedDocId | Restituisce oppure imposta la versione del DocId forzata per la creazione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasDocument | Restituisce se il file sia registrato nel Database come documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasForcedDocId | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasRowver | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsChildren | Restitusice se questa operazione di check-in struttura sia una operazione di testa oppure se si tratti di un sotto-documento. Di default é false.
Proprietà pubblica | IsElaborated | Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsNew | Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato). (Ereditato da DocStructOperationBase)
Proprietà pubblica | Operation | Restituisce l'operazione che caratterizza questo elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Parent | Restituisce l'oggetto di appartenenza. (Ereditato da DocStructOperationBase)
Proprietà pubblica | PrecOperation | Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione. (Ereditato da DocStructOperationBase)
Proprietà pubblica | ResultOperation | Dizionario che contiene i risultati del comando sui singoli documenti
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso file dell'elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RowVer | Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | SkipReferenceUpdate | Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Classe DocStructCheckInStrutturaOperation
Namespace DedNet.Commands


Proprietà DocStructCheckInStrutturaOperation.DeletingPwsFile

Proprietà DocStructCheckInStrutturaOperationDeletingPwsFile
Restituisce se il comando eliminerà o meno il documento in locale.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool DeletingPwsFile { get; }
Public ReadOnly Property DeletingPwsFile As Boolean
    Get
public:
property bool DeletingPwsFile {
    bool get ();
}
member DeletingPwsFile : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructCheckInStrutturaOperation
Namespace DedNet.Commands


Proprietà DocStructCheckInStrutturaOperation.FileOperationExecuted

Proprietà DocStructCheckInStrutturaOperationFileOperationExecuted
Restituisce se le operazioni sui file siano già state effettuate.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool FileOperationExecuted { get; }
Public Overrides ReadOnly Property FileOperationExecuted As Boolean
    Get
public:
virtual property bool FileOperationExecuted {
    bool get () override;
}
abstract FileOperationExecuted : bool with get
override FileOperationExecuted : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructCheckInStrutturaOperation
Namespace DedNet.Commands


Proprietà DocStructCheckInStrutturaOperation.IsChildren

Proprietà DocStructCheckInStrutturaOperationIsChildren
Restitusice se questa operazione di check-in struttura sia una operazione di testa oppure se si tratti di un sotto-documento. Di default é false.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsChildren { get; }
Public ReadOnly Property IsChildren As Boolean
    Get
public:
property bool IsChildren {
    bool get ();
}
member IsChildren : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructCheckInStrutturaOperation
Namespace DedNet.Commands


Proprietà DocStructCheckInStrutturaOperation.ResultOperation

Proprietà DocStructCheckInStrutturaOperationResultOperation
Dizionario che contiene i risultati del comando sui singoli documenti

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<DedDoc, ResultOperationOnStructObject> ResultOperation { get; set; }
Public Property ResultOperation As Dictionary(Of DedDoc, ResultOperationOnStructObject)
    Get
    Set
public:
property Dictionary<DedDoc^, ResultOperationOnStructObject^>^ ResultOperation {
    Dictionary<DedDoc^, ResultOperationOnStructObject^>^ get ();
    void set (Dictionary<DedDoc^, ResultOperationOnStructObject^>^ value);
}
member ResultOperation : Dictionary<DedDoc, ResultOperationOnStructObject> with get, set

Valore della proprietà

Dictionary DedDoc, ResultOperationOnStructObject
Vedi anche

Documentazione

Classe DocStructCheckInStrutturaOperation
Namespace DedNet.Commands


Metodi di DocStructCheckInStrutturaOperation

Il tipo DocStructCheckInStrutturaOperation espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | CalcolaNomeSostituto | Calcola e restituisce il percorso completo di destinazione del sostituto. (Ereditato da DocStructOperationBase)
Metodo protetto | UpdateDependences | Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Classe DocStructCheckInStrutturaOperation
Namespace DedNet.Commands


Classe DocStructCheckOutOperation
Operazione di check-out del documento.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDocStructOperationBase
DedNet.CommandsDocStructCheckOutOperation

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DocStructCheckOutOperation : DocStructOperationBase
Public Class DocStructCheckOutOperation
    Inherits DocStructOperationBase
public ref class DocStructCheckOutOperation : public DocStructOperationBase
type DocStructCheckOutOperation =
    class
        inherit DocStructOperationBase
    end

Il tipo DocStructCheckOutOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CurrentWorkingFileName | Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | DocStateChanged | Notifica se il documento è stato effettivamente modificato
Proprietà pubblica | Document | Restituisce il documento abbinato al file oppure null se non è registrato nel Database. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Exists | Restituisce se il file sia presente nel percorso corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | FileOperationExecuted | Restituisce se le operazioni sui file siano già state effettuate. (Sovrascrive DocStructOperationBaseFileOperationExecuted)
Proprietà pubblica | ForcedDocId | Restituisce oppure imposta la versione del DocId forzata per la creazione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasDocument | Restituisce se il file sia registrato nel Database come documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasForcedDocId | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasRowver | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IgnoreCopyIfFileExistsEnsureLocal | Indica di ignorare la copia in locale se il file è già presente durante l'ensurelocal
Proprietà pubblica | IgnoreDataLockState | Consente di ignorare il blocco legato allo stato dell'anagrafica
Proprietà pubblica | IgnoreFileExistingEnsureLocal | Indica di ignorare il controllo dell'esistenza del file in fase di EnsureLocal.
Proprietà pubblica | IsChildrenOperation | Restituisce se si tratta di un operazione su un figlio.
Proprietà pubblica | IsElaborated | Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsNew | Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato). (Ereditato da DocStructOperationBase)
Proprietà pubblica | Operation | Restituisce l'operazione che caratterizza questo elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Parent | Restituisce l'oggetto di appartenenza. (Ereditato da DocStructOperationBase)
Proprietà pubblica | PrecOperation | Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione. (Ereditato da DocStructOperationBase)
Proprietà pubblica | ResultOperation | Dizionario che contiene i risultati del comando sui singoli documenti
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso file dell'elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RowVer | Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | SkipReferenceUpdate | Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false. (Ereditato da DocStructOperationBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | CalcolaNomeSostituto | Calcola e restituisce il percorso completo di destinazione del sostituto. (Ereditato da DocStructOperationBase)
Metodo protetto | UpdateDependences | Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di DocStructCheckOutOperation

Il tipo DocStructCheckOutOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CurrentWorkingFileName | Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | DocStateChanged | Notifica se il documento è stato effettivamente modificato
Proprietà pubblica | Document | Restituisce il documento abbinato al file oppure null se non è registrato nel Database. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Exists | Restituisce se il file sia presente nel percorso corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | FileOperationExecuted | Restituisce se le operazioni sui file siano già state effettuate. (Sovrascrive DocStructOperationBaseFileOperationExecuted)
Proprietà pubblica | ForcedDocId | Restituisce oppure imposta la versione del DocId forzata per la creazione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasDocument | Restituisce se il file sia registrato nel Database come documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasForcedDocId | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasRowver | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IgnoreCopyIfFileExistsEnsureLocal | Indica di ignorare la copia in locale se il file è già presente durante l'ensurelocal
Proprietà pubblica | IgnoreDataLockState | Consente di ignorare il blocco legato allo stato dell'anagrafica
Proprietà pubblica | IgnoreFileExistingEnsureLocal | Indica di ignorare il controllo dell'esistenza del file in fase di EnsureLocal.
Proprietà pubblica | IsChildrenOperation | Restituisce se si tratta di un operazione su un figlio.
Proprietà pubblica | IsElaborated | Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsNew | Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato). (Ereditato da DocStructOperationBase)
Proprietà pubblica | Operation | Restituisce l'operazione che caratterizza questo elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Parent | Restituisce l'oggetto di appartenenza. (Ereditato da DocStructOperationBase)
Proprietà pubblica | PrecOperation | Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione. (Ereditato da DocStructOperationBase)
Proprietà pubblica | ResultOperation | Dizionario che contiene i risultati del comando sui singoli documenti
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso file dell'elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RowVer | Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | SkipReferenceUpdate | Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Classe DocStructCheckOutOperation
Namespace DedNet.Commands


Proprietà DocStructCheckOutOperation.DocStateChanged

Proprietà DocStructCheckOutOperationDocStateChanged
Notifica se il documento è stato effettivamente modificato

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool DocStateChanged { get; }
Public ReadOnly Property DocStateChanged As Boolean
    Get
public:
property bool DocStateChanged {
    bool get ();
}
member DocStateChanged : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructCheckOutOperation
Namespace DedNet.Commands


Proprietà DocStructCheckOutOperation.FileOperationExecuted

Proprietà DocStructCheckOutOperationFileOperationExecuted
Restituisce se le operazioni sui file siano già state effettuate.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool FileOperationExecuted { get; }
Public Overrides ReadOnly Property FileOperationExecuted As Boolean
    Get
public:
virtual property bool FileOperationExecuted {
    bool get () override;
}
abstract FileOperationExecuted : bool with get
override FileOperationExecuted : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructCheckOutOperation
Namespace DedNet.Commands


Proprietà DocStructCheckOutOperation.IgnoreCopyIfFileExistsEnsureLocal

Proprietà DocStructCheckOutOperationIgnoreCopyIfFileExistsEnsureLocal
Indica di ignorare la copia in locale se il file è già presente durante l'ensurelocal

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IgnoreCopyIfFileExistsEnsureLocal { get; set; }
Public Property IgnoreCopyIfFileExistsEnsureLocal As Boolean
    Get
    Set
public:
property bool IgnoreCopyIfFileExistsEnsureLocal {
    bool get ();
    void set (bool value);
}
member IgnoreCopyIfFileExistsEnsureLocal : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructCheckOutOperation
Namespace DedNet.Commands


Proprietà DocStructCheckOutOperation.IgnoreDataLockState

Proprietà DocStructCheckOutOperationIgnoreDataLockState
Consente di ignorare il blocco legato allo stato dell'anagrafica

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IgnoreDataLockState { get; set; }
Public Property IgnoreDataLockState As Boolean
    Get
    Set
public:
property bool IgnoreDataLockState {
    bool get ();
    void set (bool value);
}
member IgnoreDataLockState : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructCheckOutOperation
Namespace DedNet.Commands


Proprietà DocStructCheckOutOperation.IgnoreFileExistingEnsureLocal

Proprietà DocStructCheckOutOperationIgnoreFileExistingEnsureLocal
Indica di ignorare il controllo dell'esistenza del file in fase di EnsureLocal.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IgnoreFileExistingEnsureLocal { get; set; }
Public Property IgnoreFileExistingEnsureLocal As Boolean
    Get
    Set
public:
property bool IgnoreFileExistingEnsureLocal {
    bool get ();
    void set (bool value);
}
member IgnoreFileExistingEnsureLocal : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructCheckOutOperation
Namespace DedNet.Commands


Proprietà DocStructCheckOutOperation.IsChildrenOperation

Proprietà DocStructCheckOutOperationIsChildrenOperation
Restituisce se si tratta di un operazione su un figlio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsChildrenOperation { get; }
Public ReadOnly Property IsChildrenOperation As Boolean
    Get
public:
property bool IsChildrenOperation {
    bool get ();
}
member IsChildrenOperation : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructCheckOutOperation
Namespace DedNet.Commands


Proprietà DocStructCheckOutOperation.ResultOperation

Proprietà DocStructCheckOutOperationResultOperation
Dizionario che contiene i risultati del comando sui singoli documenti

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<DedDoc, ResultOperationOnStructObject> ResultOperation { get; set; }
Public Property ResultOperation As Dictionary(Of DedDoc, ResultOperationOnStructObject)
    Get
    Set
public:
property Dictionary<DedDoc^, ResultOperationOnStructObject^>^ ResultOperation {
    Dictionary<DedDoc^, ResultOperationOnStructObject^>^ get ();
    void set (Dictionary<DedDoc^, ResultOperationOnStructObject^>^ value);
}
member ResultOperation : Dictionary<DedDoc, ResultOperationOnStructObject> with get, set

Valore della proprietà

Dictionary DedDoc, ResultOperationOnStructObject
Vedi anche

Documentazione

Classe DocStructCheckOutOperation
Namespace DedNet.Commands


Metodi di DocStructCheckOutOperation

Il tipo DocStructCheckOutOperation espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | CalcolaNomeSostituto | Calcola e restituisce il percorso completo di destinazione del sostituto. (Ereditato da DocStructOperationBase)
Metodo protetto | UpdateDependences | Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Classe DocStructCheckOutOperation
Namespace DedNet.Commands


Classe DocStructCheckOutStrutturaOperation
Effettua il check-out sul documento e su tutte le sue dipendenze, se su queste è possibile effettuare l'operazione.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDocStructOperationBase
DedNet.CommandsDocStructCheckOutStrutturaOperation

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DocStructCheckOutStrutturaOperation : DocStructOperationBase
Public Class DocStructCheckOutStrutturaOperation
    Inherits DocStructOperationBase
public ref class DocStructCheckOutStrutturaOperation : public DocStructOperationBase
type DocStructCheckOutStrutturaOperation =
    class
        inherit DocStructOperationBase
    end

Il tipo DocStructCheckOutStrutturaOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CurrentWorkingFileName | Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Document | Restituisce il documento abbinato al file oppure null se non è registrato nel Database. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Exists | Restituisce se il file sia presente nel percorso corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | FileOperationExecuted | Restituisce se le operazioni sui file siano già state effettuate. (Sovrascrive DocStructOperationBaseFileOperationExecuted)
Proprietà pubblica | ForcedDocId | Restituisce oppure imposta la versione del DocId forzata per la creazione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasDocument | Restituisce se il file sia registrato nel Database come documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasForcedDocId | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasRowver | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IgnoreDataLockState | Consente di ignorare il blocco legato allo stato dell'anagrafica
Proprietà pubblica | IgnoreFileExistingEnsureLocal | Indica di ignorare il controllo dell'esistenza del file in fase di EnsureLocal.
Proprietà pubblica | IsChildren | Restitusice se questa operazione di check-out struttura sia una operazione di testa oppure se si tratti di un sotto-documento. Di default é false.
Proprietà pubblica | IsElaborated | Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsNew | Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato). (Ereditato da DocStructOperationBase)
Proprietà pubblica | Operation | Restituisce l'operazione che caratterizza questo elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Parent | Restituisce l'oggetto di appartenenza. (Ereditato da DocStructOperationBase)
Proprietà pubblica | PrecOperation | Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione. (Ereditato da DocStructOperationBase)
Proprietà pubblica | ResultOperation | Dizionario che contiene i risultati del comando sui singoli documenti
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso file dell'elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RowVer | Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | SkipReferenceUpdate | Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false. (Ereditato da DocStructOperationBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | CalcolaNomeSostituto | Calcola e restituisce il percorso completo di destinazione del sostituto. (Ereditato da DocStructOperationBase)
Metodo protetto | UpdateDependences | Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di DocStructCheckOutStrutturaOperation

Il tipo DocStructCheckOutStrutturaOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CurrentWorkingFileName | Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Document | Restituisce il documento abbinato al file oppure null se non è registrato nel Database. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Exists | Restituisce se il file sia presente nel percorso corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | FileOperationExecuted | Restituisce se le operazioni sui file siano già state effettuate. (Sovrascrive DocStructOperationBaseFileOperationExecuted)
Proprietà pubblica | ForcedDocId | Restituisce oppure imposta la versione del DocId forzata per la creazione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasDocument | Restituisce se il file sia registrato nel Database come documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasForcedDocId | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasRowver | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IgnoreDataLockState | Consente di ignorare il blocco legato allo stato dell'anagrafica
Proprietà pubblica | IgnoreFileExistingEnsureLocal | Indica di ignorare il controllo dell'esistenza del file in fase di EnsureLocal.
Proprietà pubblica | IsChildren | Restitusice se questa operazione di check-out struttura sia una operazione di testa oppure se si tratti di un sotto-documento. Di default é false.
Proprietà pubblica | IsElaborated | Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsNew | Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato). (Ereditato da DocStructOperationBase)
Proprietà pubblica | Operation | Restituisce l'operazione che caratterizza questo elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Parent | Restituisce l'oggetto di appartenenza. (Ereditato da DocStructOperationBase)
Proprietà pubblica | PrecOperation | Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione. (Ereditato da DocStructOperationBase)
Proprietà pubblica | ResultOperation | Dizionario che contiene i risultati del comando sui singoli documenti
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso file dell'elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RowVer | Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | SkipReferenceUpdate | Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Classe DocStructCheckOutStrutturaOperation
Namespace DedNet.Commands


Proprietà DocStructCheckOutStrutturaOperation.FileOperationExecuted

Proprietà DocStructCheckOutStrutturaOperationFileOperationExecuted
Restituisce se le operazioni sui file siano già state effettuate.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool FileOperationExecuted { get; }
Public Overrides ReadOnly Property FileOperationExecuted As Boolean
    Get
public:
virtual property bool FileOperationExecuted {
    bool get () override;
}
abstract FileOperationExecuted : bool with get
override FileOperationExecuted : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructCheckOutStrutturaOperation
Namespace DedNet.Commands


Proprietà DocStructCheckOutStrutturaOperation.IgnoreDataLockState

Proprietà DocStructCheckOutStrutturaOperationIgnoreDataLockState
Consente di ignorare il blocco legato allo stato dell'anagrafica

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IgnoreDataLockState { get; set; }
Public Property IgnoreDataLockState As Boolean
    Get
    Set
public:
property bool IgnoreDataLockState {
    bool get ();
    void set (bool value);
}
member IgnoreDataLockState : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructCheckOutStrutturaOperation
Namespace DedNet.Commands


Proprietà DocStructCheckOutStrutturaOperation.IgnoreFileExistingEnsureLocal

Proprietà DocStructCheckOutStrutturaOperationIgnoreFileExistingEnsureLocal
Indica di ignorare il controllo dell'esistenza del file in fase di EnsureLocal.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IgnoreFileExistingEnsureLocal { get; set; }
Public Property IgnoreFileExistingEnsureLocal As Boolean
    Get
    Set
public:
property bool IgnoreFileExistingEnsureLocal {
    bool get ();
    void set (bool value);
}
member IgnoreFileExistingEnsureLocal : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructCheckOutStrutturaOperation
Namespace DedNet.Commands


Proprietà DocStructCheckOutStrutturaOperation.IsChildren

Proprietà DocStructCheckOutStrutturaOperationIsChildren
Restitusice se questa operazione di check-out struttura sia una operazione di testa oppure se si tratti di un sotto-documento. Di default é false.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsChildren { get; }
Public ReadOnly Property IsChildren As Boolean
    Get
public:
property bool IsChildren {
    bool get ();
}
member IsChildren : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructCheckOutStrutturaOperation
Namespace DedNet.Commands


Proprietà DocStructCheckOutStrutturaOperation.ResultOperation

Proprietà DocStructCheckOutStrutturaOperationResultOperation
Dizionario che contiene i risultati del comando sui singoli documenti

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<DedDoc, ResultOperationOnStructObject> ResultOperation { get; set; }
Public Property ResultOperation As Dictionary(Of DedDoc, ResultOperationOnStructObject)
    Get
    Set
public:
property Dictionary<DedDoc^, ResultOperationOnStructObject^>^ ResultOperation {
    Dictionary<DedDoc^, ResultOperationOnStructObject^>^ get ();
    void set (Dictionary<DedDoc^, ResultOperationOnStructObject^>^ value);
}
member ResultOperation : Dictionary<DedDoc, ResultOperationOnStructObject> with get, set

Valore della proprietà

Dictionary DedDoc, ResultOperationOnStructObject
Vedi anche

Documentazione

Classe DocStructCheckOutStrutturaOperation
Namespace DedNet.Commands


Metodi di DocStructCheckOutStrutturaOperation

Il tipo DocStructCheckOutStrutturaOperation espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | CalcolaNomeSostituto | Calcola e restituisce il percorso completo di destinazione del sostituto. (Ereditato da DocStructOperationBase)
Metodo protetto | UpdateDependences | Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Classe DocStructCheckOutStrutturaOperation
Namespace DedNet.Commands


Classe DocStructCommDisconnectingOperation
Operazione di scollegamento documento da un'anagrafica.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDocStructOperationBase
DedNet.CommandsDocStructCommDisconnectingOperation

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DocStructCommDisconnectingOperation : DocStructOperationBase
Public Class DocStructCommDisconnectingOperation
    Inherits DocStructOperationBase
public ref class DocStructCommDisconnectingOperation : public DocStructOperationBase
type DocStructCommDisconnectingOperation =
    class
        inherit DocStructOperationBase
    end

Il tipo DocStructCommDisconnectingOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CurrentWorkingFileName | Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Document | Restituisce il documento abbinato al file oppure null se non è registrato nel Database. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Exists | Restituisce se il file sia presente nel percorso corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | FileOperationExecuted | Restitusice se le operazioni sui file siano o meno state effettuate Valuta l'esistenza nel Vault del file. (Ereditato da DocStructOperationBase)
Proprietà pubblica | ForcedDocId | Restituisce oppure imposta la versione del DocId forzata per la creazione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasDocument | Restituisce se il file sia registrato nel Database come documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasForcedDocId | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasRowver | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsElaborated | Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsNew | Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato). (Ereditato da DocStructOperationBase)
Proprietà pubblica | Operation | Restituisce l'operazione che caratterizza questo elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Parent | Restituisce l'oggetto di appartenenza. (Ereditato da DocStructOperationBase)
Proprietà pubblica | PrecOperation | Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso file dell'elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RowVer | Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | SkipReferenceUpdate | Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false. (Ereditato da DocStructOperationBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | CalcolaNomeSostituto | Calcola e restituisce il percorso completo di destinazione del sostituto. (Ereditato da DocStructOperationBase)
Metodo protetto | UpdateDependences | Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di DocStructCommDisconnectingOperation

Il tipo DocStructCommDisconnectingOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CurrentWorkingFileName | Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Document | Restituisce il documento abbinato al file oppure null se non è registrato nel Database. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Exists | Restituisce se il file sia presente nel percorso corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | FileOperationExecuted | Restitusice se le operazioni sui file siano o meno state effettuate Valuta l'esistenza nel Vault del file. (Ereditato da DocStructOperationBase)
Proprietà pubblica | ForcedDocId | Restituisce oppure imposta la versione del DocId forzata per la creazione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasDocument | Restituisce se il file sia registrato nel Database come documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasForcedDocId | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasRowver | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsElaborated | Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsNew | Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato). (Ereditato da DocStructOperationBase)
Proprietà pubblica | Operation | Restituisce l'operazione che caratterizza questo elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Parent | Restituisce l'oggetto di appartenenza. (Ereditato da DocStructOperationBase)
Proprietà pubblica | PrecOperation | Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso file dell'elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RowVer | Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | SkipReferenceUpdate | Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Classe DocStructCommDisconnectingOperation
Namespace DedNet.Commands


Metodi di DocStructCommDisconnectingOperation

Il tipo DocStructCommDisconnectingOperation espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | CalcolaNomeSostituto | Calcola e restituisce il percorso completo di destinazione del sostituto. (Ereditato da DocStructOperationBase)
Metodo protetto | UpdateDependences | Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Classe DocStructCommDisconnectingOperation
Namespace DedNet.Commands


Classe DocStructCommImportingOperation
Operazione di collegamento documento già esistente ad una commessa.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDocStructOperationBase
DedNet.CommandsDocStructCommImportingOperation

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DocStructCommImportingOperation : DocStructOperationBase
Public Class DocStructCommImportingOperation
    Inherits DocStructOperationBase
public ref class DocStructCommImportingOperation : public DocStructOperationBase
type DocStructCommImportingOperation =
    class
        inherit DocStructOperationBase
    end

Il tipo DocStructCommImportingOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CurrentWorkingFileName | Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Document | Restituisce il documento abbinato al file oppure null se non è registrato nel Database. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Exists | Restituisce se il file sia presente nel percorso corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | FileOperationExecuted | Restitusice se le operazioni sui file siano o meno state effettuate Valuta l'esistenza nel Vault del file. (Ereditato da DocStructOperationBase)
Proprietà pubblica | ForcedDocId | Restituisce oppure imposta la versione del DocId forzata per la creazione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasDocument | Restituisce se il file sia registrato nel Database come documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasForcedDocId | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasRowver | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsElaborated | Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsNew | Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato). (Ereditato da DocStructOperationBase)
Proprietà pubblica | Operation | Restituisce l'operazione che caratterizza questo elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Parent | Restituisce l'oggetto di appartenenza. (Ereditato da DocStructOperationBase)
Proprietà pubblica | PrecOperation | Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso file dell'elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RowVer | Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | SkipReferenceUpdate | Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false. (Ereditato da DocStructOperationBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | CalcolaNomeSostituto | Calcola e restituisce il percorso completo di destinazione del sostituto. (Ereditato da DocStructOperationBase)
Metodo protetto | UpdateDependences | Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di DocStructCommImportingOperation

Il tipo DocStructCommImportingOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CurrentWorkingFileName | Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Document | Restituisce il documento abbinato al file oppure null se non è registrato nel Database. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Exists | Restituisce se il file sia presente nel percorso corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | FileOperationExecuted | Restitusice se le operazioni sui file siano o meno state effettuate Valuta l'esistenza nel Vault del file. (Ereditato da DocStructOperationBase)
Proprietà pubblica | ForcedDocId | Restituisce oppure imposta la versione del DocId forzata per la creazione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasDocument | Restituisce se il file sia registrato nel Database come documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasForcedDocId | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasRowver | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsElaborated | Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsNew | Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato). (Ereditato da DocStructOperationBase)
Proprietà pubblica | Operation | Restituisce l'operazione che caratterizza questo elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Parent | Restituisce l'oggetto di appartenenza. (Ereditato da DocStructOperationBase)
Proprietà pubblica | PrecOperation | Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso file dell'elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RowVer | Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | SkipReferenceUpdate | Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Classe DocStructCommImportingOperation
Namespace DedNet.Commands


Metodi di DocStructCommImportingOperation

Il tipo DocStructCommImportingOperation espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | CalcolaNomeSostituto | Calcola e restituisce il percorso completo di destinazione del sostituto. (Ereditato da DocStructOperationBase)
Metodo protetto | UpdateDependences | Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Classe DocStructCommImportingOperation
Namespace DedNet.Commands


Classe DocStructCommLinkingOperation
Operazione di collegamento documento già esistente ad una commessa.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDocStructOperationBase
DedNet.CommandsDocStructCommLinkingOperation

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DocStructCommLinkingOperation : DocStructOperationBase
Public Class DocStructCommLinkingOperation
    Inherits DocStructOperationBase
public ref class DocStructCommLinkingOperation : public DocStructOperationBase
type DocStructCommLinkingOperation =
    class
        inherit DocStructOperationBase
    end

Il tipo DocStructCommLinkingOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CurrentWorkingFileName | Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Document | Restituisce il documento abbinato al file oppure null se non è registrato nel Database. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Exists | Restituisce se il file sia presente nel percorso corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | FileOperationExecuted | Restitusice se le operazioni sui file siano o meno state effettuate Valuta l'esistenza nel Vault del file. (Ereditato da DocStructOperationBase)
Proprietà pubblica | ForcedDocId | Restituisce oppure imposta la versione del DocId forzata per la creazione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasDocument | Restituisce se il file sia registrato nel Database come documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasForcedDocId | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasRowver | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsElaborated | Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsNew | Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato). (Ereditato da DocStructOperationBase)
Proprietà pubblica | Operation | Restituisce l'operazione che caratterizza questo elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Parent | Restituisce l'oggetto di appartenenza. (Ereditato da DocStructOperationBase)
Proprietà pubblica | PrecOperation | Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso file dell'elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RowVer | Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | SkipReferenceUpdate | Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false. (Ereditato da DocStructOperationBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | CalcolaNomeSostituto | Calcola e restituisce il percorso completo di destinazione del sostituto. (Ereditato da DocStructOperationBase)
Metodo protetto | UpdateDependences | Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di DocStructCommLinkingOperation

Il tipo DocStructCommLinkingOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CurrentWorkingFileName | Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Document | Restituisce il documento abbinato al file oppure null se non è registrato nel Database. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Exists | Restituisce se il file sia presente nel percorso corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | FileOperationExecuted | Restitusice se le operazioni sui file siano o meno state effettuate Valuta l'esistenza nel Vault del file. (Ereditato da DocStructOperationBase)
Proprietà pubblica | ForcedDocId | Restituisce oppure imposta la versione del DocId forzata per la creazione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasDocument | Restituisce se il file sia registrato nel Database come documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasForcedDocId | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasRowver | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsElaborated | Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsNew | Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato). (Ereditato da DocStructOperationBase)
Proprietà pubblica | Operation | Restituisce l'operazione che caratterizza questo elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Parent | Restituisce l'oggetto di appartenenza. (Ereditato da DocStructOperationBase)
Proprietà pubblica | PrecOperation | Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso file dell'elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RowVer | Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | SkipReferenceUpdate | Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Classe DocStructCommLinkingOperation
Namespace DedNet.Commands


Metodi di DocStructCommLinkingOperation

Il tipo DocStructCommLinkingOperation espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | CalcolaNomeSostituto | Calcola e restituisce il percorso completo di destinazione del sostituto. (Ereditato da DocStructOperationBase)
Metodo protetto | UpdateDependences | Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Classe DocStructCommLinkingOperation
Namespace DedNet.Commands


Classe DocStructCommRecogniseOperation
Operazione di riconoscimento file con collegamento ad un'anagrafica.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDocStructOperationBase
DedNet.CommandsDocStructCommRecogniseOperation

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DocStructCommRecogniseOperation : DocStructOperationBase
Public Class DocStructCommRecogniseOperation
    Inherits DocStructOperationBase
public ref class DocStructCommRecogniseOperation : public DocStructOperationBase
type DocStructCommRecogniseOperation =
    class
        inherit DocStructOperationBase
    end

Il tipo DocStructCommRecogniseOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CurrentWorkingFileName | Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Document | Restituisce il documento abbinato al file oppure null se non è registrato nel Database. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Exists | Restituisce se il file sia presente nel percorso corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | FileOperationExecuted | Restitusice se le operazioni sui file siano o meno state effettuate Valuta l'esistenza nel Vault del file. (Ereditato da DocStructOperationBase)
Proprietà pubblica | ForcedDocId | Restituisce oppure imposta la versione del DocId forzata per la creazione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasDocument | Restituisce se il file sia registrato nel Database come documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasForcedDocId | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasRowver | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsElaborated | Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsNew | Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato). (Ereditato da DocStructOperationBase)
Proprietà pubblica | Operation | Restituisce l'operazione che caratterizza questo elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Parent | Restituisce l'oggetto di appartenenza. (Ereditato da DocStructOperationBase)
Proprietà pubblica | PrecOperation | Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso file dell'elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RowVer | Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | SkipReferenceUpdate | Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false. (Ereditato da DocStructOperationBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | CalcolaNomeSostituto | Calcola e restituisce il percorso completo di destinazione del sostituto. (Ereditato da DocStructOperationBase)
Metodo protetto | UpdateDependences | Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di DocStructCommRecogniseOperation

Il tipo DocStructCommRecogniseOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CurrentWorkingFileName | Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Document | Restituisce il documento abbinato al file oppure null se non è registrato nel Database. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Exists | Restituisce se il file sia presente nel percorso corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | FileOperationExecuted | Restitusice se le operazioni sui file siano o meno state effettuate Valuta l'esistenza nel Vault del file. (Ereditato da DocStructOperationBase)
Proprietà pubblica | ForcedDocId | Restituisce oppure imposta la versione del DocId forzata per la creazione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasDocument | Restituisce se il file sia registrato nel Database come documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasForcedDocId | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasRowver | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsElaborated | Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsNew | Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato). (Ereditato da DocStructOperationBase)
Proprietà pubblica | Operation | Restituisce l'operazione che caratterizza questo elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Parent | Restituisce l'oggetto di appartenenza. (Ereditato da DocStructOperationBase)
Proprietà pubblica | PrecOperation | Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso file dell'elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RowVer | Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | SkipReferenceUpdate | Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Classe DocStructCommRecogniseOperation
Namespace DedNet.Commands


Metodi di DocStructCommRecogniseOperation

Il tipo DocStructCommRecogniseOperation espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | CalcolaNomeSostituto | Calcola e restituisce il percorso completo di destinazione del sostituto. (Ereditato da DocStructOperationBase)
Metodo protetto | UpdateDependences | Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Classe DocStructCommRecogniseOperation
Namespace DedNet.Commands


Classe DocStructCopyingOperation
Operazione di copia documento.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDocStructOperationBase
DedNet.CommandsDocStructCopyingOperation

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DocStructCopyingOperation : DocStructOperationBase
Public Class DocStructCopyingOperation
    Inherits DocStructOperationBase
public ref class DocStructCopyingOperation : public DocStructOperationBase
type DocStructCopyingOperation =
    class
        inherit DocStructOperationBase
    end

Il tipo DocStructCopyingOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CurrentWorkingFileName | Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Document | Restituisce il documento abbinato al file oppure null se non è registrato nel Database. (Ereditato da DocStructOperationBase)
Proprietà pubblica | EnforcedFileOperations | Indica se è necessario forzare le operazioni sui file anzichè utilizzare le deduzioni dell'operation base
Proprietà pubblica | Exists | Restituisce se il file sia presente nel percorso corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | FileOperationExecuted | Restituisce se le operazioni sui file siano già state effettuate. (Sovrascrive DocStructOperationBaseFileOperationExecuted)
Proprietà pubblica | ForcedDocId | Restituisce oppure imposta la versione del DocId forzata per la creazione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasDocument | Restituisce se il file sia registrato nel Database come documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasForcedDocId | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasRowver | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsElaborated | Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsNew | Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato). (Ereditato da DocStructOperationBase)
Proprietà pubblica | Operation | Restituisce l'operazione che caratterizza questo elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Parent | Restituisce l'oggetto di appartenenza. (Ereditato da DocStructOperationBase)
Proprietà pubblica | PrecOperation | Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso file dell'elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RowVer | Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | SkipReferenceUpdate | Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false. (Ereditato da DocStructOperationBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | CalcolaNomeSostituto | Calcola e restituisce il percorso completo di destinazione del sostituto. (Ereditato da DocStructOperationBase)
Metodo protetto | UpdateDependences | Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di DocStructCopyingOperation

Il tipo DocStructCopyingOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CurrentWorkingFileName | Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Document | Restituisce il documento abbinato al file oppure null se non è registrato nel Database. (Ereditato da DocStructOperationBase)
Proprietà pubblica | EnforcedFileOperations | Indica se è necessario forzare le operazioni sui file anzichè utilizzare le deduzioni dell'operation base
Proprietà pubblica | Exists | Restituisce se il file sia presente nel percorso corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | FileOperationExecuted | Restituisce se le operazioni sui file siano già state effettuate. (Sovrascrive DocStructOperationBaseFileOperationExecuted)
Proprietà pubblica | ForcedDocId | Restituisce oppure imposta la versione del DocId forzata per la creazione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasDocument | Restituisce se il file sia registrato nel Database come documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasForcedDocId | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasRowver | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsElaborated | Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsNew | Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato). (Ereditato da DocStructOperationBase)
Proprietà pubblica | Operation | Restituisce l'operazione che caratterizza questo elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Parent | Restituisce l'oggetto di appartenenza. (Ereditato da DocStructOperationBase)
Proprietà pubblica | PrecOperation | Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso file dell'elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RowVer | Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | SkipReferenceUpdate | Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Classe DocStructCopyingOperation
Namespace DedNet.Commands


Proprietà DocStructCopyingOperation.EnforcedFileOperations

Proprietà DocStructCopyingOperationEnforcedFileOperations
Indica se è necessario forzare le operazioni sui file anzichè utilizzare le deduzioni dell'operation base

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool EnforcedFileOperations { get; set; }
Public Property EnforcedFileOperations As Boolean
    Get
    Set
public:
property bool EnforcedFileOperations {
    bool get ();
    void set (bool value);
}
member EnforcedFileOperations : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructCopyingOperation
Namespace DedNet.Commands


Proprietà DocStructCopyingOperation.FileOperationExecuted

Proprietà DocStructCopyingOperationFileOperationExecuted
Restituisce se le operazioni sui file siano già state effettuate.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool FileOperationExecuted { get; }
Public Overrides ReadOnly Property FileOperationExecuted As Boolean
    Get
public:
virtual property bool FileOperationExecuted {
    bool get () override;
}
abstract FileOperationExecuted : bool with get
override FileOperationExecuted : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructCopyingOperation
Namespace DedNet.Commands


Metodi di DocStructCopyingOperation

Il tipo DocStructCopyingOperation espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | CalcolaNomeSostituto | Calcola e restituisce il percorso completo di destinazione del sostituto. (Ereditato da DocStructOperationBase)
Metodo protetto | UpdateDependences | Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Classe DocStructCopyingOperation
Namespace DedNet.Commands


Classe DocStructCreatingOperation
Operazione di creazione documento da file.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDocStructOperationBase
DedNet.CommandsDocStructCreatingOperation

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DocStructCreatingOperation : DocStructOperationBase
Public Class DocStructCreatingOperation
    Inherits DocStructOperationBase
public ref class DocStructCreatingOperation : public DocStructOperationBase
type DocStructCreatingOperation =
    class
        inherit DocStructOperationBase
    end

Il tipo DocStructCreatingOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CurrentWorkingFileName | Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Document | Restituisce il documento abbinato al file oppure null se non è registrato nel Database. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Exists | Restituisce se il file sia presente nel percorso corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | FileOperationExecuted | Restitusice se le operazioni sui file siano o meno state effettuate Valuta l'esistenza nel Vault del file. (Ereditato da DocStructOperationBase)
Proprietà pubblica | ForcedDocId | Restituisce oppure imposta la versione del DocId forzata per la creazione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasDocument | Restituisce se il file sia registrato nel Database come documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasForcedDocId | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasRowver | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsElaborated | Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsNew | Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato). (Ereditato da DocStructOperationBase)
Proprietà pubblica | Operation | Restituisce l'operazione che caratterizza questo elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Parent | Restituisce l'oggetto di appartenenza. (Ereditato da DocStructOperationBase)
Proprietà pubblica | PrecOperation | Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso file dell'elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RowVer | Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | SkipReferenceUpdate | Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false. (Ereditato da DocStructOperationBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | CalcolaNomeSostituto | Calcola e restituisce il percorso completo di destinazione del sostituto. (Ereditato da DocStructOperationBase)
Metodo protetto | UpdateDependences | Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di DocStructCreatingOperation

Il tipo DocStructCreatingOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CurrentWorkingFileName | Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Document | Restituisce il documento abbinato al file oppure null se non è registrato nel Database. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Exists | Restituisce se il file sia presente nel percorso corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | FileOperationExecuted | Restitusice se le operazioni sui file siano o meno state effettuate Valuta l'esistenza nel Vault del file. (Ereditato da DocStructOperationBase)
Proprietà pubblica | ForcedDocId | Restituisce oppure imposta la versione del DocId forzata per la creazione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasDocument | Restituisce se il file sia registrato nel Database come documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasForcedDocId | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasRowver | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsElaborated | Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsNew | Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato). (Ereditato da DocStructOperationBase)
Proprietà pubblica | Operation | Restituisce l'operazione che caratterizza questo elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Parent | Restituisce l'oggetto di appartenenza. (Ereditato da DocStructOperationBase)
Proprietà pubblica | PrecOperation | Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso file dell'elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RowVer | Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | SkipReferenceUpdate | Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Classe DocStructCreatingOperation
Namespace DedNet.Commands


Metodi di DocStructCreatingOperation

Il tipo DocStructCreatingOperation espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | CalcolaNomeSostituto | Calcola e restituisce il percorso completo di destinazione del sostituto. (Ereditato da DocStructOperationBase)
Metodo protetto | UpdateDependences | Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Classe DocStructCreatingOperation
Namespace DedNet.Commands


Classe DocStructDisconnectingOperation
Operazione di scollegamento documento da un'anagrafica.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDocStructOperationBase
DedNet.CommandsDocStructDisconnectingOperation

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DocStructDisconnectingOperation : DocStructOperationBase
Public Class DocStructDisconnectingOperation
    Inherits DocStructOperationBase
public ref class DocStructDisconnectingOperation : public DocStructOperationBase
type DocStructDisconnectingOperation =
    class
        inherit DocStructOperationBase
    end

Il tipo DocStructDisconnectingOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CurrentWorkingFileName | Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Document | Restituisce il documento abbinato al file oppure null se non è registrato nel Database. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Exists | Restituisce se il file sia presente nel percorso corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | FileOperationExecuted | Restitusice se le operazioni sui file siano o meno state effettuate Valuta l'esistenza nel Vault del file. (Ereditato da DocStructOperationBase)
Proprietà pubblica | ForcedDocId | Restituisce oppure imposta la versione del DocId forzata per la creazione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasDocument | Restituisce se il file sia registrato nel Database come documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasForcedDocId | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasRowver | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsElaborated | Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsNew | Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato). (Ereditato da DocStructOperationBase)
Proprietà pubblica | Operation | Restituisce l'operazione che caratterizza questo elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Parent | Restituisce l'oggetto di appartenenza. (Ereditato da DocStructOperationBase)
Proprietà pubblica | PrecOperation | Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso file dell'elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RowVer | Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | SkipReferenceUpdate | Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false. (Ereditato da DocStructOperationBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | CalcolaNomeSostituto | Calcola e restituisce il percorso completo di destinazione del sostituto. (Ereditato da DocStructOperationBase)
Metodo protetto | UpdateDependences | Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di DocStructDisconnectingOperation

Il tipo DocStructDisconnectingOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CurrentWorkingFileName | Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Document | Restituisce il documento abbinato al file oppure null se non è registrato nel Database. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Exists | Restituisce se il file sia presente nel percorso corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | FileOperationExecuted | Restitusice se le operazioni sui file siano o meno state effettuate Valuta l'esistenza nel Vault del file. (Ereditato da DocStructOperationBase)
Proprietà pubblica | ForcedDocId | Restituisce oppure imposta la versione del DocId forzata per la creazione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasDocument | Restituisce se il file sia registrato nel Database come documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasForcedDocId | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasRowver | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsElaborated | Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsNew | Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato). (Ereditato da DocStructOperationBase)
Proprietà pubblica | Operation | Restituisce l'operazione che caratterizza questo elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Parent | Restituisce l'oggetto di appartenenza. (Ereditato da DocStructOperationBase)
Proprietà pubblica | PrecOperation | Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso file dell'elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RowVer | Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | SkipReferenceUpdate | Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Classe DocStructDisconnectingOperation
Namespace DedNet.Commands


Metodi di DocStructDisconnectingOperation

Il tipo DocStructDisconnectingOperation espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | CalcolaNomeSostituto | Calcola e restituisce il percorso completo di destinazione del sostituto. (Ereditato da DocStructOperationBase)
Metodo protetto | UpdateDependences | Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Classe DocStructDisconnectingOperation
Namespace DedNet.Commands


Classe DocStructEcoImportingOperation
Operazione di collegamento documento già esistente ad un'Eco.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDocStructOperationBase
DedNet.CommandsDocStructEcoImportingOperation

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DocStructEcoImportingOperation : DocStructOperationBase
Public Class DocStructEcoImportingOperation
    Inherits DocStructOperationBase
public ref class DocStructEcoImportingOperation : public DocStructOperationBase
type DocStructEcoImportingOperation =
    class
        inherit DocStructOperationBase
    end

Il tipo DocStructEcoImportingOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CurrentWorkingFileName | Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Document | Restituisce il documento abbinato al file oppure null se non è registrato nel Database. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Exists | Restituisce se il file sia presente nel percorso corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | FileOperationExecuted | Restitusice se le operazioni sui file siano o meno state effettuate Valuta l'esistenza nel Vault del file. (Ereditato da DocStructOperationBase)
Proprietà pubblica | ForcedDocId | Restituisce oppure imposta la versione del DocId forzata per la creazione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasDocument | Restituisce se il file sia registrato nel Database come documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasForcedDocId | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasRowver | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsElaborated | Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsNew | Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato). (Ereditato da DocStructOperationBase)
Proprietà pubblica | Operation | Restituisce l'operazione che caratterizza questo elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Parent | Restituisce l'oggetto di appartenenza. (Ereditato da DocStructOperationBase)
Proprietà pubblica | PrecOperation | Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso file dell'elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RowVer | Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | SkipReferenceUpdate | Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false. (Ereditato da DocStructOperationBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | CalcolaNomeSostituto | Calcola e restituisce il percorso completo di destinazione del sostituto. (Ereditato da DocStructOperationBase)
Metodo protetto | UpdateDependences | Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di DocStructEcoImportingOperation

Il tipo DocStructEcoImportingOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CurrentWorkingFileName | Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Document | Restituisce il documento abbinato al file oppure null se non è registrato nel Database. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Exists | Restituisce se il file sia presente nel percorso corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | FileOperationExecuted | Restitusice se le operazioni sui file siano o meno state effettuate Valuta l'esistenza nel Vault del file. (Ereditato da DocStructOperationBase)
Proprietà pubblica | ForcedDocId | Restituisce oppure imposta la versione del DocId forzata per la creazione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasDocument | Restituisce se il file sia registrato nel Database come documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasForcedDocId | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasRowver | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsElaborated | Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsNew | Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato). (Ereditato da DocStructOperationBase)
Proprietà pubblica | Operation | Restituisce l'operazione che caratterizza questo elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Parent | Restituisce l'oggetto di appartenenza. (Ereditato da DocStructOperationBase)
Proprietà pubblica | PrecOperation | Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso file dell'elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RowVer | Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | SkipReferenceUpdate | Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Classe DocStructEcoImportingOperation
Namespace DedNet.Commands


Metodi di DocStructEcoImportingOperation

Il tipo DocStructEcoImportingOperation espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | CalcolaNomeSostituto | Calcola e restituisce il percorso completo di destinazione del sostituto. (Ereditato da DocStructOperationBase)
Metodo protetto | UpdateDependences | Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Classe DocStructEcoImportingOperation
Namespace DedNet.Commands


Classe DocStructEcoLinkingOperation
Operazione di collegamento documento già esistente ad un Eco (l'Eco deve essere già registrato nel database).
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDocStructOperationBase
DedNet.CommandsDocStructEcoLinkingOperation

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DocStructEcoLinkingOperation : DocStructOperationBase
Public Class DocStructEcoLinkingOperation
    Inherits DocStructOperationBase
public ref class DocStructEcoLinkingOperation : public DocStructOperationBase
type DocStructEcoLinkingOperation =
    class
        inherit DocStructOperationBase
    end

Il tipo DocStructEcoLinkingOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CurrentWorkingFileName | Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Document | Restituisce il documento abbinato al file oppure null se non è registrato nel Database. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Exists | Restituisce se il file sia presente nel percorso corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | FileOperationExecuted | Restitusice se le operazioni sui file siano o meno state effettuate Valuta l'esistenza nel Vault del file. (Ereditato da DocStructOperationBase)
Proprietà pubblica | ForcedDocId | Restituisce oppure imposta la versione del DocId forzata per la creazione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasDocument | Restituisce se il file sia registrato nel Database come documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasForcedDocId | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasRowver | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsElaborated | Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsNew | Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato). (Ereditato da DocStructOperationBase)
Proprietà pubblica | Operation | Restituisce l'operazione che caratterizza questo elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Parent | Restituisce l'oggetto di appartenenza. (Ereditato da DocStructOperationBase)
Proprietà pubblica | PrecOperation | Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso file dell'elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RowVer | Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | SkipReferenceUpdate | Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false. (Ereditato da DocStructOperationBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | CalcolaNomeSostituto | Calcola e restituisce il percorso completo di destinazione del sostituto. (Ereditato da DocStructOperationBase)
Metodo protetto | UpdateDependences | Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di DocStructEcoLinkingOperation

Il tipo DocStructEcoLinkingOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CurrentWorkingFileName | Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Document | Restituisce il documento abbinato al file oppure null se non è registrato nel Database. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Exists | Restituisce se il file sia presente nel percorso corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | FileOperationExecuted | Restitusice se le operazioni sui file siano o meno state effettuate Valuta l'esistenza nel Vault del file. (Ereditato da DocStructOperationBase)
Proprietà pubblica | ForcedDocId | Restituisce oppure imposta la versione del DocId forzata per la creazione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasDocument | Restituisce se il file sia registrato nel Database come documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasForcedDocId | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasRowver | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsElaborated | Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsNew | Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato). (Ereditato da DocStructOperationBase)
Proprietà pubblica | Operation | Restituisce l'operazione che caratterizza questo elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Parent | Restituisce l'oggetto di appartenenza. (Ereditato da DocStructOperationBase)
Proprietà pubblica | PrecOperation | Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso file dell'elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RowVer | Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | SkipReferenceUpdate | Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Classe DocStructEcoLinkingOperation
Namespace DedNet.Commands


Metodi di DocStructEcoLinkingOperation

Il tipo DocStructEcoLinkingOperation espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | CalcolaNomeSostituto | Calcola e restituisce il percorso completo di destinazione del sostituto. (Ereditato da DocStructOperationBase)
Metodo protetto | UpdateDependences | Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Classe DocStructEcoLinkingOperation
Namespace DedNet.Commands


Classe DocStructEnsureLocalOperation
Operazione di copia in locale di un documento e di tutte le sue dipendenze, dal vault alla pws.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDocStructOperationBase
DedNet.CommandsDocStructEnsureLocalOperation

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DocStructEnsureLocalOperation : DocStructOperationBase
Public Class DocStructEnsureLocalOperation
    Inherits DocStructOperationBase
public ref class DocStructEnsureLocalOperation : public DocStructOperationBase
type DocStructEnsureLocalOperation =
    class
        inherit DocStructOperationBase
    end

Il tipo DocStructEnsureLocalOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CurrentWorkingFileName | Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Document | Restituisce il documento abbinato al file oppure null se non è registrato nel Database. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Exists | Restituisce se il file sia presente nel percorso corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | FileOperationExecuted | Restituisce se la copia del file sia già stata effettuata. (Sovrascrive DocStructOperationBaseFileOperationExecuted)
Proprietà pubblica | ForcedDocId | Restituisce oppure imposta la versione del DocId forzata per la creazione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasDocument | Restituisce se il file sia registrato nel Database come documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasForcedDocId | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasRowver | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IgnoreCopyIfFileExists | Indica di ignorare la copia in locale se il file esiste già
Proprietà pubblica | IgnoreFileExistingEnsureLocal | Indica di ignorare il controllo dell'esistenza del file in fase di EnsureLocal.
Proprietà pubblica | IsElaborated | Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsNew | Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato). (Ereditato da DocStructOperationBase)
Proprietà pubblica | Operation | Restituisce l'operazione che caratterizza questo elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Parent | Restituisce l'oggetto di appartenenza. (Ereditato da DocStructOperationBase)
Proprietà pubblica | PrecOperation | Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso file dell'elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RowVer | Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | SkipReferenceUpdate | Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false. (Ereditato da DocStructOperationBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | CalcolaNomeSostituto | Calcola e restituisce il percorso completo di destinazione del sostituto. (Ereditato da DocStructOperationBase)
Metodo protetto | UpdateDependences | Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di DocStructEnsureLocalOperation

Il tipo DocStructEnsureLocalOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CurrentWorkingFileName | Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Document | Restituisce il documento abbinato al file oppure null se non è registrato nel Database. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Exists | Restituisce se il file sia presente nel percorso corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | FileOperationExecuted | Restituisce se la copia del file sia già stata effettuata. (Sovrascrive DocStructOperationBaseFileOperationExecuted)
Proprietà pubblica | ForcedDocId | Restituisce oppure imposta la versione del DocId forzata per la creazione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasDocument | Restituisce se il file sia registrato nel Database come documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasForcedDocId | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasRowver | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IgnoreCopyIfFileExists | Indica di ignorare la copia in locale se il file esiste già
Proprietà pubblica | IgnoreFileExistingEnsureLocal | Indica di ignorare il controllo dell'esistenza del file in fase di EnsureLocal.
Proprietà pubblica | IsElaborated | Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsNew | Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato). (Ereditato da DocStructOperationBase)
Proprietà pubblica | Operation | Restituisce l'operazione che caratterizza questo elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Parent | Restituisce l'oggetto di appartenenza. (Ereditato da DocStructOperationBase)
Proprietà pubblica | PrecOperation | Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso file dell'elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RowVer | Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | SkipReferenceUpdate | Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Classe DocStructEnsureLocalOperation
Namespace DedNet.Commands


Proprietà DocStructEnsureLocalOperation.FileOperationExecuted

Proprietà DocStructEnsureLocalOperationFileOperationExecuted
Restituisce se la copia del file sia già stata effettuata.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool FileOperationExecuted { get; }
Public Overrides ReadOnly Property FileOperationExecuted As Boolean
    Get
public:
virtual property bool FileOperationExecuted {
    bool get () override;
}
abstract FileOperationExecuted : bool with get
override FileOperationExecuted : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructEnsureLocalOperation
Namespace DedNet.Commands


Proprietà DocStructEnsureLocalOperation.IgnoreCopyIfFileExists

Proprietà DocStructEnsureLocalOperationIgnoreCopyIfFileExists
Indica di ignorare la copia in locale se il file esiste già

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IgnoreCopyIfFileExists { get; set; }
Public Property IgnoreCopyIfFileExists As Boolean
    Get
    Set
public:
property bool IgnoreCopyIfFileExists {
    bool get ();
    void set (bool value);
}
member IgnoreCopyIfFileExists : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructEnsureLocalOperation
Namespace DedNet.Commands


Proprietà DocStructEnsureLocalOperation.IgnoreFileExistingEnsureLocal

Proprietà DocStructEnsureLocalOperationIgnoreFileExistingEnsureLocal
Indica di ignorare il controllo dell'esistenza del file in fase di EnsureLocal.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IgnoreFileExistingEnsureLocal { get; set; }
Public Property IgnoreFileExistingEnsureLocal As Boolean
    Get
    Set
public:
property bool IgnoreFileExistingEnsureLocal {
    bool get ();
    void set (bool value);
}
member IgnoreFileExistingEnsureLocal : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructEnsureLocalOperation
Namespace DedNet.Commands


Metodi di DocStructEnsureLocalOperation

Il tipo DocStructEnsureLocalOperation espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | CalcolaNomeSostituto | Calcola e restituisce il percorso completo di destinazione del sostituto. (Ereditato da DocStructOperationBase)
Metodo protetto | UpdateDependences | Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Classe DocStructEnsureLocalOperation
Namespace DedNet.Commands


Classe DocStructExportingOperation
Esporta un documento in un percorso esterno al database
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDocStructOperationBase
DedNet.CommandsDocStructExportingOperation

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DocStructExportingOperation : DocStructOperationBase
Public Class DocStructExportingOperation
    Inherits DocStructOperationBase
public ref class DocStructExportingOperation : public DocStructOperationBase
type DocStructExportingOperation =
    class
        inherit DocStructOperationBase
    end

Il tipo DocStructExportingOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CheckOutOnExport | Restituisce se il comando porrà il documento in checkOut.
Proprietà pubblica | CreateFolderStructure | Indica se creare la struttura delle cartelle nel pacchetto di esportazione ( in Autocad è false )
Proprietà pubblica | CurrentWorkingFileName | Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Document | Restituisce il documento abbinato al file oppure null se non è registrato nel Database. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Exists | Restituisce se il file sia presente nel percorso corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | FileOperationExecuted | Restituisce se le operazioni sui file siano già state effettuate. (Sovrascrive DocStructOperationBaseFileOperationExecuted)
Proprietà pubblica | ForcedDocId | Restituisce oppure imposta la versione del DocId forzata per la creazione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasDocument | Restituisce se il file sia registrato nel Database come documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasForcedDocId | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasRowver | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsElaborated | Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsNew | Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato). (Ereditato da DocStructOperationBase)
Proprietà pubblica | Operation | Restituisce l'operazione che caratterizza questo elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Parent | Restituisce l'oggetto di appartenenza. (Ereditato da DocStructOperationBase)
Proprietà pubblica | PrecOperation | Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso file dell'elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RowVer | Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | SkipReferenceUpdate | Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false. (Ereditato da DocStructOperationBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | CalcolaNomeSostituto | Calcola e restituisce il percorso completo di destinazione del sostituto. (Ereditato da DocStructOperationBase)
Metodo protetto | UpdateDependences | Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di DocStructExportingOperation

Il tipo DocStructExportingOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CheckOutOnExport | Restituisce se il comando porrà il documento in checkOut.
Proprietà pubblica | CreateFolderStructure | Indica se creare la struttura delle cartelle nel pacchetto di esportazione ( in Autocad è false )
Proprietà pubblica | CurrentWorkingFileName | Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Document | Restituisce il documento abbinato al file oppure null se non è registrato nel Database. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Exists | Restituisce se il file sia presente nel percorso corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | FileOperationExecuted | Restituisce se le operazioni sui file siano già state effettuate. (Sovrascrive DocStructOperationBaseFileOperationExecuted)
Proprietà pubblica | ForcedDocId | Restituisce oppure imposta la versione del DocId forzata per la creazione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasDocument | Restituisce se il file sia registrato nel Database come documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasForcedDocId | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasRowver | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsElaborated | Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsNew | Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato). (Ereditato da DocStructOperationBase)
Proprietà pubblica | Operation | Restituisce l'operazione che caratterizza questo elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Parent | Restituisce l'oggetto di appartenenza. (Ereditato da DocStructOperationBase)
Proprietà pubblica | PrecOperation | Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso file dell'elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RowVer | Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | SkipReferenceUpdate | Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Classe DocStructExportingOperation
Namespace DedNet.Commands


Proprietà DocStructExportingOperation.CheckOutOnExport

Proprietà DocStructExportingOperationCheckOutOnExport
Restituisce se il comando porrà il documento in checkOut.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CheckOutOnExport { get; }
Public ReadOnly Property CheckOutOnExport As Boolean
    Get
public:
property bool CheckOutOnExport {
    bool get ();
}
member CheckOutOnExport : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructExportingOperation
Namespace DedNet.Commands


Proprietà DocStructExportingOperation.CreateFolderStructure

Proprietà DocStructExportingOperationCreateFolderStructure
Indica se creare la struttura delle cartelle nel pacchetto di esportazione ( in Autocad è false )

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CreateFolderStructure { get; set; }
Public Property CreateFolderStructure As Boolean
    Get
    Set
public:
property bool CreateFolderStructure {
    bool get ();
    void set (bool value);
}
member CreateFolderStructure : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructExportingOperation
Namespace DedNet.Commands


Proprietà DocStructExportingOperation.FileOperationExecuted

Proprietà DocStructExportingOperationFileOperationExecuted
Restituisce se le operazioni sui file siano già state effettuate.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool FileOperationExecuted { get; }
Public Overrides ReadOnly Property FileOperationExecuted As Boolean
    Get
public:
virtual property bool FileOperationExecuted {
    bool get () override;
}
abstract FileOperationExecuted : bool with get
override FileOperationExecuted : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructExportingOperation
Namespace DedNet.Commands


Metodi di DocStructExportingOperation

Il tipo DocStructExportingOperation espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | CalcolaNomeSostituto | Calcola e restituisce il percorso completo di destinazione del sostituto. (Ereditato da DocStructOperationBase)
Metodo protetto | UpdateDependences | Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Classe DocStructExportingOperation
Namespace DedNet.Commands


Classe DocStructExportingStrutturaOperation
Esegue l'esporta del documento e su tutte le sue dipendenze, se su queste è possibile effettuare l'operazione.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDocStructOperationBase
DedNet.CommandsDocStructExportingStrutturaOperation

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DocStructExportingStrutturaOperation : DocStructOperationBase
Public Class DocStructExportingStrutturaOperation
    Inherits DocStructOperationBase
public ref class DocStructExportingStrutturaOperation : public DocStructOperationBase
type DocStructExportingStrutturaOperation =
    class
        inherit DocStructOperationBase
    end

Il tipo DocStructExportingStrutturaOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CurrentWorkingFileName | Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Document | Restituisce il documento abbinato al file oppure null se non è registrato nel Database. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Exists | Restituisce se il file sia presente nel percorso corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | FileOperationExecuted | Restitusice se le operazioni sui file siano o meno state effettuate Valuta l'esistenza nel Vault del file. (Ereditato da DocStructOperationBase)
Proprietà pubblica | ForcedDocId | Restituisce oppure imposta la versione del DocId forzata per la creazione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasDocument | Restituisce se il file sia registrato nel Database come documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasForcedDocId | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasRowver | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsElaborated | Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsNew | Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato). (Ereditato da DocStructOperationBase)
Proprietà pubblica | Operation | Restituisce l'operazione che caratterizza questo elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Parent | Restituisce l'oggetto di appartenenza. (Ereditato da DocStructOperationBase)
Proprietà pubblica | PrecOperation | Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso file dell'elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RowVer | Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | SkipReferenceUpdate | Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false. (Ereditato da DocStructOperationBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | CalcolaNomeSostituto | Calcola e restituisce il percorso completo di destinazione del sostituto. (Ereditato da DocStructOperationBase)
Metodo protetto | UpdateDependences | Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di DocStructExportingStrutturaOperation

Il tipo DocStructExportingStrutturaOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CurrentWorkingFileName | Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Document | Restituisce il documento abbinato al file oppure null se non è registrato nel Database. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Exists | Restituisce se il file sia presente nel percorso corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | FileOperationExecuted | Restitusice se le operazioni sui file siano o meno state effettuate Valuta l'esistenza nel Vault del file. (Ereditato da DocStructOperationBase)
Proprietà pubblica | ForcedDocId | Restituisce oppure imposta la versione del DocId forzata per la creazione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasDocument | Restituisce se il file sia registrato nel Database come documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasForcedDocId | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasRowver | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsElaborated | Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsNew | Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato). (Ereditato da DocStructOperationBase)
Proprietà pubblica | Operation | Restituisce l'operazione che caratterizza questo elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Parent | Restituisce l'oggetto di appartenenza. (Ereditato da DocStructOperationBase)
Proprietà pubblica | PrecOperation | Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso file dell'elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RowVer | Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | SkipReferenceUpdate | Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Classe DocStructExportingStrutturaOperation
Namespace DedNet.Commands


Metodi di DocStructExportingStrutturaOperation

Il tipo DocStructExportingStrutturaOperation espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | CalcolaNomeSostituto | Calcola e restituisce il percorso completo di destinazione del sostituto. (Ereditato da DocStructOperationBase)
Metodo protetto | UpdateDependences | Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Classe DocStructExportingStrutturaOperation
Namespace DedNet.Commands


Classe DocStructForzaCheckInOperation
Mette in checkin un documento forzatamente.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDocStructOperationBase
DedNet.CommandsDocStructForzaCheckInOperation

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DocStructForzaCheckInOperation : DocStructOperationBase
Public Class DocStructForzaCheckInOperation
    Inherits DocStructOperationBase
public ref class DocStructForzaCheckInOperation : public DocStructOperationBase
type DocStructForzaCheckInOperation =
    class
        inherit DocStructOperationBase
    end

Il tipo DocStructForzaCheckInOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CurrentWorkingFileName | Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Document | Restituisce il documento abbinato al file oppure null se non è registrato nel Database. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Exists | Restituisce se il file sia presente nel percorso corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | FileOperationExecuted | Restituisce se le operazioni sui file siano già state effettuate. (Sovrascrive DocStructOperationBaseFileOperationExecuted)
Proprietà pubblica | ForcedDocId | Restituisce oppure imposta la versione del DocId forzata per la creazione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasDocument | Restituisce se il file sia registrato nel Database come documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasForcedDocId | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasRowver | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsElaborated | Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsNew | Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato). (Ereditato da DocStructOperationBase)
Proprietà pubblica | Operation | Restituisce l'operazione che caratterizza questo elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Parent | Restituisce l'oggetto di appartenenza. (Ereditato da DocStructOperationBase)
Proprietà pubblica | PrecOperation | Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso file dell'elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RowVer | Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | SkipReferenceUpdate | Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false. (Ereditato da DocStructOperationBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | CalcolaNomeSostituto | Calcola e restituisce il percorso completo di destinazione del sostituto. (Ereditato da DocStructOperationBase)
Metodo protetto | UpdateDependences | Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di DocStructForzaCheckInOperation

Il tipo DocStructForzaCheckInOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CurrentWorkingFileName | Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Document | Restituisce il documento abbinato al file oppure null se non è registrato nel Database. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Exists | Restituisce se il file sia presente nel percorso corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | FileOperationExecuted | Restituisce se le operazioni sui file siano già state effettuate. (Sovrascrive DocStructOperationBaseFileOperationExecuted)
Proprietà pubblica | ForcedDocId | Restituisce oppure imposta la versione del DocId forzata per la creazione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasDocument | Restituisce se il file sia registrato nel Database come documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasForcedDocId | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasRowver | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsElaborated | Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsNew | Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato). (Ereditato da DocStructOperationBase)
Proprietà pubblica | Operation | Restituisce l'operazione che caratterizza questo elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Parent | Restituisce l'oggetto di appartenenza. (Ereditato da DocStructOperationBase)
Proprietà pubblica | PrecOperation | Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso file dell'elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RowVer | Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | SkipReferenceUpdate | Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Classe DocStructForzaCheckInOperation
Namespace DedNet.Commands


Proprietà DocStructForzaCheckInOperation.FileOperationExecuted

Proprietà DocStructForzaCheckInOperationFileOperationExecuted
Restituisce se le operazioni sui file siano già state effettuate.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool FileOperationExecuted { get; }
Public Overrides ReadOnly Property FileOperationExecuted As Boolean
    Get
public:
virtual property bool FileOperationExecuted {
    bool get () override;
}
abstract FileOperationExecuted : bool with get
override FileOperationExecuted : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructForzaCheckInOperation
Namespace DedNet.Commands


Metodi di DocStructForzaCheckInOperation

Il tipo DocStructForzaCheckInOperation espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | CalcolaNomeSostituto | Calcola e restituisce il percorso completo di destinazione del sostituto. (Ereditato da DocStructOperationBase)
Metodo protetto | UpdateDependences | Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Classe DocStructForzaCheckInOperation
Namespace DedNet.Commands


Classe DocStructForzaCheckInStrutturaOperation
Esegue il forza check-in sul documento e su tutte le sue dipendenze, se su queste è possibile effettuare l'operazione.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDocStructOperationBase
DedNet.CommandsDocStructForzaCheckInStrutturaOperation

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DocStructForzaCheckInStrutturaOperation : DocStructOperationBase
Public Class DocStructForzaCheckInStrutturaOperation
    Inherits DocStructOperationBase
public ref class DocStructForzaCheckInStrutturaOperation : public DocStructOperationBase
type DocStructForzaCheckInStrutturaOperation =
    class
        inherit DocStructOperationBase
    end

Il tipo DocStructForzaCheckInStrutturaOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CurrentWorkingFileName | Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Document | Restituisce il documento abbinato al file oppure null se non è registrato nel Database. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Exists | Restituisce se il file sia presente nel percorso corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | FileOperationExecuted | Restitusice se le operazioni sui file siano o meno state effettuate Valuta l'esistenza nel Vault del file. (Ereditato da DocStructOperationBase)
Proprietà pubblica | ForcedDocId | Restituisce oppure imposta la versione del DocId forzata per la creazione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasDocument | Restituisce se il file sia registrato nel Database come documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasForcedDocId | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasRowver | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsChildren | Restitusice se questa operazione di check-in struttura sia una operazione di testa oppure se si tratti di un sotto-documento. Di default é false.
Proprietà pubblica | IsElaborated | Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsNew | Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato). (Ereditato da DocStructOperationBase)
Proprietà pubblica | Operation | Restituisce l'operazione che caratterizza questo elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Parent | Restituisce l'oggetto di appartenenza. (Ereditato da DocStructOperationBase)
Proprietà pubblica | PrecOperation | Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso file dell'elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RowVer | Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | SkipReferenceUpdate | Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false. (Ereditato da DocStructOperationBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | CalcolaNomeSostituto | Calcola e restituisce il percorso completo di destinazione del sostituto. (Ereditato da DocStructOperationBase)
Metodo protetto | UpdateDependences | Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di DocStructForzaCheckInStrutturaOperation

Il tipo DocStructForzaCheckInStrutturaOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CurrentWorkingFileName | Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Document | Restituisce il documento abbinato al file oppure null se non è registrato nel Database. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Exists | Restituisce se il file sia presente nel percorso corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | FileOperationExecuted | Restitusice se le operazioni sui file siano o meno state effettuate Valuta l'esistenza nel Vault del file. (Ereditato da DocStructOperationBase)
Proprietà pubblica | ForcedDocId | Restituisce oppure imposta la versione del DocId forzata per la creazione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasDocument | Restituisce se il file sia registrato nel Database come documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasForcedDocId | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasRowver | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsChildren | Restitusice se questa operazione di check-in struttura sia una operazione di testa oppure se si tratti di un sotto-documento. Di default é false.
Proprietà pubblica | IsElaborated | Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsNew | Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato). (Ereditato da DocStructOperationBase)
Proprietà pubblica | Operation | Restituisce l'operazione che caratterizza questo elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Parent | Restituisce l'oggetto di appartenenza. (Ereditato da DocStructOperationBase)
Proprietà pubblica | PrecOperation | Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso file dell'elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RowVer | Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | SkipReferenceUpdate | Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Classe DocStructForzaCheckInStrutturaOperation
Namespace DedNet.Commands


Proprietà DocStructForzaCheckInStrutturaOperation.IsChildren

Proprietà DocStructForzaCheckInStrutturaOperationIsChildren
Restitusice se questa operazione di check-in struttura sia una operazione di testa oppure se si tratti di un sotto-documento. Di default é false.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsChildren { get; }
Public ReadOnly Property IsChildren As Boolean
    Get
public:
property bool IsChildren {
    bool get ();
}
member IsChildren : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructForzaCheckInStrutturaOperation
Namespace DedNet.Commands


Metodi di DocStructForzaCheckInStrutturaOperation

Il tipo DocStructForzaCheckInStrutturaOperation espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | CalcolaNomeSostituto | Calcola e restituisce il percorso completo di destinazione del sostituto. (Ereditato da DocStructOperationBase)
Metodo protetto | UpdateDependences | Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Classe DocStructForzaCheckInStrutturaOperation
Namespace DedNet.Commands


Classe DocStructImportingOperation
Operazione di collegamento documento già esistente ad un'anagrafica.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDocStructOperationBase
DedNet.CommandsDocStructImportingOperation

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DocStructImportingOperation : DocStructOperationBase
Public Class DocStructImportingOperation
    Inherits DocStructOperationBase
public ref class DocStructImportingOperation : public DocStructOperationBase
type DocStructImportingOperation =
    class
        inherit DocStructOperationBase
    end

Il tipo DocStructImportingOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Context | Restituisce il contesto di importazione calcolato dal comando.
Proprietà pubblica | CurrentWorkingFileName | Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Data | Ritorna l'anagrafica associata all'operazione di import
Proprietà pubblica | DestFileName | Restitusice il percorso completo di importazione del documento calcolato dal comando.
Proprietà pubblica | Document | Restituisce il documento abbinato al file oppure null se non è registrato nel Database. (Ereditato da DocStructOperationBase)
Proprietà pubblica | EnforceRepresentation | Indica di forzare la creazione di una rappresentazione per una situazione in cui, per il calcolo contesti, non sarebbe creata
Proprietà pubblica | Exists | Restituisce se il file sia presente nel percorso corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | FileNameForNewAttach | Restituisce il nome file con estensione, da utilizzare nel caso di importazione di un nuovo documento come allegato.
Proprietà pubblica | FileOperationExecuted | Restituisce se la copia del file sia già stata effettuata. (Sovrascrive DocStructOperationBaseFileOperationExecuted)
Proprietà pubblica | ForcedDocId | Restituisce oppure imposta la versione del DocId forzata per la creazione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasDocument | Restituisce se il file sia registrato nel Database come documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasForcedDocId | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasRowver | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsElaborated | Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsNew | Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato). (Ereditato da DocStructOperationBase)
Proprietà pubblica | MoveInsteadOfCopy | Restituisce se verrà effettuato lo spostamento del documento al posto della copia.
Proprietà pubblica | Operation | Restituisce l'operazione che caratterizza questo elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | OverwriteMode | Indica di non creare un'eventuale rappresentazione o errore ( nel caso l'estenzione non consenta rappresentazioni ) ma di sovrascrivere il file.
Proprietà pubblica | Parent | Restituisce l'oggetto di appartenenza. (Ereditato da DocStructOperationBase)
Proprietà pubblica | PrecOperation | Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione. (Ereditato da DocStructOperationBase)
Proprietà pubblica | PrimaryContext | Restituisce il contesto di importazione dell'elemento.
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso file dell'elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RowVer | Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | SkipReferenceUpdate | Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false. (Ereditato da DocStructOperationBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | CalcolaNomeSostituto | Calcola e restituisce il percorso completo di destinazione del sostituto. (Ereditato da DocStructOperationBase)
Metodo protetto | UpdateDependences | Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di DocStructImportingOperation

Il tipo DocStructImportingOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Context | Restituisce il contesto di importazione calcolato dal comando.
Proprietà pubblica | CurrentWorkingFileName | Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Data | Ritorna l'anagrafica associata all'operazione di import
Proprietà pubblica | DestFileName | Restitusice il percorso completo di importazione del documento calcolato dal comando.
Proprietà pubblica | Document | Restituisce il documento abbinato al file oppure null se non è registrato nel Database. (Ereditato da DocStructOperationBase)
Proprietà pubblica | EnforceRepresentation | Indica di forzare la creazione di una rappresentazione per una situazione in cui, per il calcolo contesti, non sarebbe creata
Proprietà pubblica | Exists | Restituisce se il file sia presente nel percorso corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | FileNameForNewAttach | Restituisce il nome file con estensione, da utilizzare nel caso di importazione di un nuovo documento come allegato.
Proprietà pubblica | FileOperationExecuted | Restituisce se la copia del file sia già stata effettuata. (Sovrascrive DocStructOperationBaseFileOperationExecuted)
Proprietà pubblica | ForcedDocId | Restituisce oppure imposta la versione del DocId forzata per la creazione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasDocument | Restituisce se il file sia registrato nel Database come documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasForcedDocId | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasRowver | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsElaborated | Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsNew | Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato). (Ereditato da DocStructOperationBase)
Proprietà pubblica | MoveInsteadOfCopy | Restituisce se verrà effettuato lo spostamento del documento al posto della copia.
Proprietà pubblica | Operation | Restituisce l'operazione che caratterizza questo elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | OverwriteMode | Indica di non creare un'eventuale rappresentazione o errore ( nel caso l'estenzione non consenta rappresentazioni ) ma di sovrascrivere il file.
Proprietà pubblica | Parent | Restituisce l'oggetto di appartenenza. (Ereditato da DocStructOperationBase)
Proprietà pubblica | PrecOperation | Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione. (Ereditato da DocStructOperationBase)
Proprietà pubblica | PrimaryContext | Restituisce il contesto di importazione dell'elemento.
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso file dell'elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RowVer | Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | SkipReferenceUpdate | Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Classe DocStructImportingOperation
Namespace DedNet.Commands


Proprietà DocStructImportingOperation.Context

Proprietà DocStructImportingOperationContext
Restituisce il contesto di importazione calcolato dal comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocContextEnum Context { get; }
Public ReadOnly Property Context As DedDocContextEnum
    Get
public:
property DedDocContextEnum Context {
    DedDocContextEnum get ();
}
member Context : DedDocContextEnum with get

Valore della proprietà

DedDocContextEnum
Vedi anche

Documentazione

Classe DocStructImportingOperation
Namespace DedNet.Commands


Proprietà DocStructImportingOperation.Data

Proprietà DocStructImportingOperationData
Ritorna l'anagrafica associata all'operazione di import

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; }
Public ReadOnly Property Data As DedData
    Get
public:
property DedData^ Data {
    DedData^ get ();
}
member Data : DedData with get

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe DocStructImportingOperation
Namespace DedNet.Commands


Proprietà DocStructImportingOperation.DestFileName

Proprietà DocStructImportingOperationDestFileName
Restitusice il percorso completo di importazione del documento calcolato dal comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string DestFileName { get; }
Public ReadOnly Property DestFileName As String
    Get
public:
property String^ DestFileName {
    String^ get ();
}
member DestFileName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DocStructImportingOperation
Namespace DedNet.Commands


Proprietà DocStructImportingOperation.EnforceRepresentation

Proprietà DocStructImportingOperationEnforceRepresentation
Indica di forzare la creazione di una rappresentazione per una situazione in cui, per il calcolo contesti, non sarebbe creata

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool EnforceRepresentation { get; set; }
Public Property EnforceRepresentation As Boolean
    Get
    Set
public:
property bool EnforceRepresentation {
    bool get ();
    void set (bool value);
}
member EnforceRepresentation : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructImportingOperation
Namespace DedNet.Commands


Proprietà DocStructImportingOperation.FileNameForNewAttach

Proprietà DocStructImportingOperationFileNameForNewAttach
Restituisce il nome file con estensione, da utilizzare nel caso di importazione di un nuovo documento come allegato.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string FileNameForNewAttach { get; }
Public ReadOnly Property FileNameForNewAttach As String
    Get
public:
property String^ FileNameForNewAttach {
    String^ get ();
}
member FileNameForNewAttach : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DocStructImportingOperation
Namespace DedNet.Commands


Proprietà DocStructImportingOperation.FileOperationExecuted

Proprietà DocStructImportingOperationFileOperationExecuted
Restituisce se la copia del file sia già stata effettuata.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool FileOperationExecuted { get; }
Public Overrides ReadOnly Property FileOperationExecuted As Boolean
    Get
public:
virtual property bool FileOperationExecuted {
    bool get () override;
}
abstract FileOperationExecuted : bool with get
override FileOperationExecuted : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructImportingOperation
Namespace DedNet.Commands


Proprietà DocStructImportingOperation.MoveInsteadOfCopy

Proprietà DocStructImportingOperationMoveInsteadOfCopy
Restituisce se verrà effettuato lo spostamento del documento al posto della copia.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool MoveInsteadOfCopy { get; }
Public ReadOnly Property MoveInsteadOfCopy As Boolean
    Get
public:
property bool MoveInsteadOfCopy {
    bool get ();
}
member MoveInsteadOfCopy : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructImportingOperation
Namespace DedNet.Commands


Proprietà DocStructImportingOperation.OverwriteMode

Proprietà DocStructImportingOperationOverwriteMode
Indica di non creare un'eventuale rappresentazione o errore ( nel caso l'estenzione non consenta rappresentazioni ) ma di sovrascrivere il file.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool OverwriteMode { get; set; }
Public Property OverwriteMode As Boolean
    Get
    Set
public:
property bool OverwriteMode {
    bool get ();
    void set (bool value);
}
member OverwriteMode : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructImportingOperation
Namespace DedNet.Commands


Proprietà DocStructImportingOperation.PrimaryContext

Proprietà DocStructImportingOperationPrimaryContext
Restituisce il contesto di importazione dell'elemento.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool PrimaryContext { get; }
Public ReadOnly Property PrimaryContext As Boolean
    Get
public:
property bool PrimaryContext {
    bool get ();
}
member PrimaryContext : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructImportingOperation
Namespace DedNet.Commands


Metodi di DocStructImportingOperation

Il tipo DocStructImportingOperation espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | CalcolaNomeSostituto | Calcola e restituisce il percorso completo di destinazione del sostituto. (Ereditato da DocStructOperationBase)
Metodo protetto | UpdateDependences | Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Classe DocStructImportingOperation
Namespace DedNet.Commands


Classe DocStructLinkingOperation
Operazione di collegamento documento già esistente ad un'anagrafica.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDocStructOperationBase
DedNet.CommandsDocStructLinkingOperation

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DocStructLinkingOperation : DocStructOperationBase
Public Class DocStructLinkingOperation
    Inherits DocStructOperationBase
public ref class DocStructLinkingOperation : public DocStructOperationBase
type DocStructLinkingOperation =
    class
        inherit DocStructOperationBase
    end

Il tipo DocStructLinkingOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CurrentWorkingFileName | Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Document | Restituisce il documento abbinato al file oppure null se non è registrato nel Database. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Exists | Restituisce se il file sia presente nel percorso corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | FileOperationExecuted | Restitusice se le operazioni sui file siano o meno state effettuate Valuta l'esistenza nel Vault del file. (Ereditato da DocStructOperationBase)
Proprietà pubblica | ForcedDocId | Restituisce oppure imposta la versione del DocId forzata per la creazione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasDocument | Restituisce se il file sia registrato nel Database come documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasForcedDocId | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasRowver | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsElaborated | Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsNew | Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato). (Ereditato da DocStructOperationBase)
Proprietà pubblica | Operation | Restituisce l'operazione che caratterizza questo elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Parent | Restituisce l'oggetto di appartenenza. (Ereditato da DocStructOperationBase)
Proprietà pubblica | PrecOperation | Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso file dell'elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RowVer | Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | SkipReferenceUpdate | Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false. (Ereditato da DocStructOperationBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | CalcolaNomeSostituto | Calcola e restituisce il percorso completo di destinazione del sostituto. (Ereditato da DocStructOperationBase)
Metodo protetto | UpdateDependences | Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di DocStructLinkingOperation

Il tipo DocStructLinkingOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CurrentWorkingFileName | Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Document | Restituisce il documento abbinato al file oppure null se non è registrato nel Database. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Exists | Restituisce se il file sia presente nel percorso corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | FileOperationExecuted | Restitusice se le operazioni sui file siano o meno state effettuate Valuta l'esistenza nel Vault del file. (Ereditato da DocStructOperationBase)
Proprietà pubblica | ForcedDocId | Restituisce oppure imposta la versione del DocId forzata per la creazione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasDocument | Restituisce se il file sia registrato nel Database come documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasForcedDocId | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasRowver | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsElaborated | Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsNew | Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato). (Ereditato da DocStructOperationBase)
Proprietà pubblica | Operation | Restituisce l'operazione che caratterizza questo elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Parent | Restituisce l'oggetto di appartenenza. (Ereditato da DocStructOperationBase)
Proprietà pubblica | PrecOperation | Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso file dell'elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RowVer | Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | SkipReferenceUpdate | Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Classe DocStructLinkingOperation
Namespace DedNet.Commands


Metodi di DocStructLinkingOperation

Il tipo DocStructLinkingOperation espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | CalcolaNomeSostituto | Calcola e restituisce il percorso completo di destinazione del sostituto. (Ereditato da DocStructOperationBase)
Metodo protetto | UpdateDependences | Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Classe DocStructLinkingOperation
Namespace DedNet.Commands


Classe DocStructMovingOperation
Operazione di spostamento documento.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDocStructOperationBase
DedNet.CommandsDocStructMovingOperation

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DocStructMovingOperation : DocStructOperationBase
Public Class DocStructMovingOperation
    Inherits DocStructOperationBase
public ref class DocStructMovingOperation : public DocStructOperationBase
type DocStructMovingOperation =
    class
        inherit DocStructOperationBase
    end

Il tipo DocStructMovingOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CurrentWorkingFileName | Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Document | Restituisce il documento abbinato al file oppure null se non è registrato nel Database. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Exists | Restituisce se il file sia presente nel percorso corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | FileOperationExecuted | Restitusice se le operazioni sui file siano o meno state effettuate Valuta l'esistenza nel Vault del file. (Ereditato da DocStructOperationBase)
Proprietà pubblica | ForcedDocId | Restituisce oppure imposta la versione del DocId forzata per la creazione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasDocument | Restituisce se il file sia registrato nel Database come documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasForcedDocId | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasRowver | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsElaborated | Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsNew | Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato). (Ereditato da DocStructOperationBase)
Proprietà pubblica | Operation | Restituisce l'operazione che caratterizza questo elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Parent | Restituisce l'oggetto di appartenenza. (Ereditato da DocStructOperationBase)
Proprietà pubblica | PrecOperation | Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso file dell'elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RowVer | Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | SkipReferenceUpdate | Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false. (Ereditato da DocStructOperationBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | CalcolaNomeSostituto | Calcola e restituisce il percorso completo di destinazione del sostituto. (Ereditato da DocStructOperationBase)
Metodo protetto | UpdateDependences | Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di DocStructMovingOperation

Il tipo DocStructMovingOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CurrentWorkingFileName | Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Document | Restituisce il documento abbinato al file oppure null se non è registrato nel Database. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Exists | Restituisce se il file sia presente nel percorso corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | FileOperationExecuted | Restitusice se le operazioni sui file siano o meno state effettuate Valuta l'esistenza nel Vault del file. (Ereditato da DocStructOperationBase)
Proprietà pubblica | ForcedDocId | Restituisce oppure imposta la versione del DocId forzata per la creazione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasDocument | Restituisce se il file sia registrato nel Database come documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasForcedDocId | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasRowver | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsElaborated | Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsNew | Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato). (Ereditato da DocStructOperationBase)
Proprietà pubblica | Operation | Restituisce l'operazione che caratterizza questo elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Parent | Restituisce l'oggetto di appartenenza. (Ereditato da DocStructOperationBase)
Proprietà pubblica | PrecOperation | Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso file dell'elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RowVer | Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | SkipReferenceUpdate | Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Classe DocStructMovingOperation
Namespace DedNet.Commands


Metodi di DocStructMovingOperation

Il tipo DocStructMovingOperation espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | CalcolaNomeSostituto | Calcola e restituisce il percorso completo di destinazione del sostituto. (Ereditato da DocStructOperationBase)
Metodo protetto | UpdateDependences | Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Classe DocStructMovingOperation
Namespace DedNet.Commands


Classe DocStructOperationBase
Classe base per le operazioni sui documenti. Utilizzata per specificare le informazioni di base su di un file: documento, anagrafica di contesto, versione, ecc. Da questa derivano tutte le operazioni semplici sui file che si occupano sia della modifica/creazione dei record per il documento che delle operazioni fisiche sui file.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDocStructOperationBase
Altro

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DocStructOperationBase
Public Class DocStructOperationBase
public ref class DocStructOperationBase
type DocStructOperationBase = class end

Il tipo DocStructOperationBase espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CurrentWorkingFileName | Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente.
Proprietà pubblica | Document | Restituisce il documento abbinato al file oppure null se non è registrato nel Database.
Proprietà pubblica | Exists | Restituisce se il file sia presente nel percorso corrente.
Proprietà pubblica | FileOperationExecuted | Restitusice se le operazioni sui file siano o meno state effettuate Valuta l'esistenza nel Vault del file.
Proprietà pubblica | ForcedDocId | Restituisce oppure imposta la versione del DocId forzata per la creazione del documento.
Proprietà pubblica | HasDocument | Restituisce se il file sia registrato nel Database come documento.
Proprietà pubblica | HasForcedDocId | Restituisce se sia stata specificata una particolare versione del documento.
Proprietà pubblica | HasRowver | Restituisce se sia stata specificata una particolare versione del documento.
Proprietà pubblica | IsElaborated | Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted.
Proprietà pubblica | IsNew | Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato).
Proprietà pubblica | Operation | Restituisce l'operazione che caratterizza questo elemento.
Proprietà pubblica | Parent | Restituisce l'oggetto di appartenenza.
Proprietà pubblica | PrecOperation | Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione.
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso file dell'elemento.
Proprietà pubblica | RowVer | Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento.
Proprietà pubblica | SkipReferenceUpdate | Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false.
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | CalcolaNomeSostituto | Calcola e restituisce il percorso completo di destinazione del sostituto.
Metodo protetto | UpdateDependences | Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDocStructOperationBase
DedNet.CommandsDocStructAnnullaCheckOutOperation
DedNet.CommandsDocStructCheckInOperation
DedNet.CommandsDocStructCheckInStrutturaOperation
DedNet.CommandsDocStructCheckOutOperation
DedNet.CommandsDocStructCheckOutStrutturaOperation
DedNet.CommandsDocStructCommDisconnectingOperation
DedNet.CommandsDocStructCommImportingOperation
DedNet.CommandsDocStructCommLinkingOperation
DedNet.CommandsDocStructCommRecogniseOperation
DedNet.CommandsDocStructCopyingOperation
DedNet.CommandsDocStructCreatingOperation
DedNet.CommandsDocStructDisconnectingOperation
DedNet.CommandsDocStructEcoImportingOperation
DedNet.CommandsDocStructEcoLinkingOperation
DedNet.CommandsDocStructEnsureLocalOperation
DedNet.CommandsDocStructExportingOperation
DedNet.CommandsDocStructExportingStrutturaOperation
DedNet.CommandsDocStructForzaCheckInOperation
DedNet.CommandsDocStructForzaCheckInStrutturaOperation
DedNet.CommandsDocStructImportingOperation
DedNet.CommandsDocStructLinkingOperation
DedNet.CommandsDocStructMovingOperation
DedNet.CommandsDocStructPubblicaOperation
DedNet.CommandsDocStructPubblicaStrutturaOperation
DedNet.CommandsDocStructRecogniseOperation
DedNet.CommandsDocStructRelocateOperation
DedNet.CommandsDocStructRemovingOperation
DedNet.CommandsDocStructReplaceOperation
DedNet.CommandsDocStructSbloccaOperation
DedNet.CommandsDocStructUpdatingOperation


Proprietà di DocStructOperationBase

Il tipo DocStructOperationBase espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CurrentWorkingFileName | Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente.
Proprietà pubblica | Document | Restituisce il documento abbinato al file oppure null se non è registrato nel Database.
Proprietà pubblica | Exists | Restituisce se il file sia presente nel percorso corrente.
Proprietà pubblica | FileOperationExecuted | Restitusice se le operazioni sui file siano o meno state effettuate Valuta l'esistenza nel Vault del file.
Proprietà pubblica | ForcedDocId | Restituisce oppure imposta la versione del DocId forzata per la creazione del documento.
Proprietà pubblica | HasDocument | Restituisce se il file sia registrato nel Database come documento.
Proprietà pubblica | HasForcedDocId | Restituisce se sia stata specificata una particolare versione del documento.
Proprietà pubblica | HasRowver | Restituisce se sia stata specificata una particolare versione del documento.
Proprietà pubblica | IsElaborated | Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted.
Proprietà pubblica | IsNew | Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato).
Proprietà pubblica | Operation | Restituisce l'operazione che caratterizza questo elemento.
Proprietà pubblica | Parent | Restituisce l'oggetto di appartenenza.
Proprietà pubblica | PrecOperation | Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione.
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso file dell'elemento.
Proprietà pubblica | RowVer | Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento.
Proprietà pubblica | SkipReferenceUpdate | Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false.
Torna su
Vedi anche

Documentazione

Classe DocStructOperationBase
Namespace DedNet.Commands


Proprietà DocStructOperationBase.CurrentWorkingFileName

Proprietà DocStructOperationBaseCurrentWorkingFileName
Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string CurrentWorkingFileName { get; }
Public ReadOnly Property CurrentWorkingFileName As String
    Get
public:
property String^ CurrentWorkingFileName {
    String^ get ();
}
member CurrentWorkingFileName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DocStructOperationBase
Namespace DedNet.Commands


Proprietà DocStructOperationBase.Document

Proprietà DocStructOperationBaseDocument
Restituisce il documento abbinato al file oppure null se non è registrato nel Database.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDoc Document { get; set; }
Public Property Document As DedDoc
    Get
    Set
public:
property DedDoc^ Document {
    DedDoc^ get ();
    void set (DedDoc^ value);
}
member Document : DedDoc with get, set

Valore della proprietà

DedDoc
Vedi anche

Documentazione

Classe DocStructOperationBase
Namespace DedNet.Commands


Proprietà DocStructOperationBase.Exists

Proprietà DocStructOperationBaseExists
Restituisce se il file sia presente nel percorso corrente.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Exists { get; }
Public ReadOnly Property Exists As Boolean
    Get
public:
property bool Exists {
    bool get ();
}
member Exists : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructOperationBase
Namespace DedNet.Commands


Proprietà DocStructOperationBase.FileOperationExecuted

Proprietà DocStructOperationBaseFileOperationExecuted
Restitusice se le operazioni sui file siano o meno state effettuate Valuta l'esistenza nel Vault del file.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual bool FileOperationExecuted { get; set; }
Public Overridable Property FileOperationExecuted As Boolean
    Get
    Set
public:
virtual property bool FileOperationExecuted {
    bool get ();
    void set (bool value);
}
abstract FileOperationExecuted : bool with get, set
override FileOperationExecuted : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructOperationBase
Namespace DedNet.Commands


Proprietà DocStructOperationBase.ForcedDocId

Proprietà DocStructOperationBaseForcedDocId
Restituisce oppure imposta la versione del DocId forzata per la creazione del documento.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Guid ForcedDocId { get; set; }
Public Property ForcedDocId As Guid
    Get
    Set
public:
property Guid ForcedDocId {
    Guid get ();
    void set (Guid value);
}
member ForcedDocId : Guid with get, set

Valore della proprietà

Guid
Vedi anche

Documentazione

Classe DocStructOperationBase
Namespace DedNet.Commands


Proprietà DocStructOperationBase.HasDocument

Proprietà DocStructOperationBaseHasDocument
Restituisce se il file sia registrato nel Database come documento.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasDocument { get; }
Public ReadOnly Property HasDocument As Boolean
    Get
public:
property bool HasDocument {
    bool get ();
}
member HasDocument : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructOperationBase
Namespace DedNet.Commands


Proprietà DocStructOperationBase.HasForcedDocId

Proprietà DocStructOperationBaseHasForcedDocId
Restituisce se sia stata specificata una particolare versione del documento.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasForcedDocId { get; }
Public ReadOnly Property HasForcedDocId As Boolean
    Get
public:
property bool HasForcedDocId {
    bool get ();
}
member HasForcedDocId : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructOperationBase
Namespace DedNet.Commands


Proprietà DocStructOperationBase.HasRowver

Proprietà DocStructOperationBaseHasRowver
Restituisce se sia stata specificata una particolare versione del documento.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasRowver { get; }
Public ReadOnly Property HasRowver As Boolean
    Get
public:
property bool HasRowver {
    bool get ();
}
member HasRowver : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructOperationBase
Namespace DedNet.Commands


Proprietà DocStructOperationBase.IsElaborated

Proprietà DocStructOperationBaseIsElaborated
Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual bool IsElaborated { get; protected set; }
Public Overridable Property IsElaborated As Boolean
    Get
    Protected Set
public:
virtual property bool IsElaborated {
    bool get ();
    protected: void set (bool value);
}
abstract IsElaborated : bool with get, set
override IsElaborated : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructOperationBase
Namespace DedNet.Commands


Proprietà DocStructOperationBase.IsNew

Proprietà DocStructOperationBaseIsNew
Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsNew { get; set; }
Public Property IsNew As Boolean
    Get
    Set
public:
property bool IsNew {
    bool get ();
    void set (bool value);
}
member IsNew : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructOperationBase
Namespace DedNet.Commands


Proprietà DocStructOperationBase.Operation

Proprietà DocStructOperationBaseOperation
Restituisce l'operazione che caratterizza questo elemento.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructOperationEnum Operation { get; protected set; }
Public Property Operation As DocStructOperationEnum
    Get
    Protected Set
public:
property DocStructOperationEnum Operation {
    DocStructOperationEnum get ();
    protected: void set (DocStructOperationEnum value);
}
member Operation : DocStructOperationEnum with get, set

Valore della proprietà

DocStructOperationEnum
Vedi anche

Documentazione

Classe DocStructOperationBase
Namespace DedNet.Commands


Proprietà DocStructOperationBase.Parent

Proprietà DocStructOperationBaseParent
Restituisce l'oggetto di appartenenza.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfo Parent { get; }
Public ReadOnly Property Parent As DocStructInfo
    Get
public:
property DocStructInfo^ Parent {
    DocStructInfo^ get ();
}
member Parent : DocStructInfo with get

Valore della proprietà

DocStructInfo
Vedi anche

Documentazione

Classe DocStructOperationBase
Namespace DedNet.Commands


Proprietà DocStructOperationBase.PrecOperation

Proprietà DocStructOperationBasePrecOperation
Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructOperationBase PrecOperation { get; }
Public ReadOnly Property PrecOperation As DocStructOperationBase
    Get
public:
property DocStructOperationBase^ PrecOperation {
    DocStructOperationBase^ get ();
}
member PrecOperation : DocStructOperationBase with get

Valore della proprietà

DocStructOperationBase
Vedi anche

Documentazione

Classe DocStructOperationBase
Namespace DedNet.Commands


Proprietà DocStructOperationBase.RootInfo

Proprietà DocStructOperationBaseRootInfo
Restituisce le informazioni sul percorso file dell'elemento.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedRootInfo RootInfo { get; }
Public ReadOnly Property RootInfo As DedRootInfo
    Get
public:
property DedRootInfo^ RootInfo {
    DedRootInfo^ get ();
}
member RootInfo : DedRootInfo with get

Valore della proprietà

DedRootInfo
Vedi anche

Documentazione

Classe DocStructOperationBase
Namespace DedNet.Commands


Proprietà DocStructOperationBase.RowVer

Proprietà DocStructOperationBaseRowVer
Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Guid RowVer { get; set; }
Public Property RowVer As Guid
    Get
    Set
public:
property Guid RowVer {
    Guid get ();
    void set (Guid value);
}
member RowVer : Guid with get, set

Valore della proprietà

Guid
Vedi anche

Documentazione

Classe DocStructOperationBase
Namespace DedNet.Commands


Proprietà DocStructOperationBase.SkipReferenceUpdate

Proprietà DocStructOperationBaseSkipReferenceUpdate
Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual bool SkipReferenceUpdate { get; set; }
Public Overridable Property SkipReferenceUpdate As Boolean
    Get
    Set
public:
virtual property bool SkipReferenceUpdate {
    bool get ();
    void set (bool value);
}
abstract SkipReferenceUpdate : bool with get, set
override SkipReferenceUpdate : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructOperationBase
Namespace DedNet.Commands


Metodi di DocStructOperationBase

Il tipo DocStructOperationBase espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | CalcolaNomeSostituto | Calcola e restituisce il percorso completo di destinazione del sostituto.
Metodo protetto | UpdateDependences | Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento.
Torna su
Vedi anche

Documentazione

Classe DocStructOperationBase
Namespace DedNet.Commands


Metodo DocStructOperationBase.CalcolaNomeSostituto

Metodo DocStructOperationBaseCalcolaNomeSostituto
Calcola e restituisce il percorso completo di destinazione del sostituto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected string CalcolaNomeSostituto(
    List<string> giaCalcolati
)
Protected Function CalcolaNomeSostituto (
    giaCalcolati As List(Of String)
) As String
protected:
String^ CalcolaNomeSostituto(
    List<String^>^ giaCalcolati
)
member CalcolaNomeSostituto :
        giaCalcolati : List<string> -> string

Parametri

giaCalcolati List String
Percorsi già calcolati per evitare duplicati.

Valore di ritorno

String
Vedi anche

Documentazione

Classe DocStructOperationBase
Namespace DedNet.Commands


Metodo DocStructOperationBase.UpdateDependences

Metodo DocStructOperationBaseUpdateDependences
Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected void UpdateDependences(
    DedDoc doc
)
Protected Sub UpdateDependences (
    doc As DedDoc
)
protected:
void UpdateDependences(
    DedDoc^ doc
)
member UpdateDependences :
        doc : DedDoc -> unit

Parametri

doc DedDoc
Documento del quale aggiornare le dipendenze.
Vedi anche

Documentazione

Classe DocStructOperationBase
Namespace DedNet.Commands


Classe DocStructOperationBaseList
Lista di oggetti DocStructOperationBase.
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList DocStructOperationBase
DedNet.CommandsDocStructOperationBaseList

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DocStructOperationBaseList : List<DocStructOperationBase>
Public Class DocStructOperationBaseList
    Inherits List(Of DocStructOperationBase)
public ref class DocStructOperationBaseList : public List<DocStructOperationBase^>
type DocStructOperationBaseList =
    class
        inherit List<DocStructOperationBase>
    end

Il tipo DocStructOperationBaseList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DocStructOperationBaseList |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Costruttore DocStructOperationBaseList

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructOperationBaseList()
Public Sub New
public:
DocStructOperationBaseList()
new : unit -> DocStructOperationBaseList
Vedi anche

Documentazione

Classe DocStructOperationBaseList
Namespace DedNet.Commands


Enumerazione DocStructOperationEnum
Enumerazione delle operazioni riguardanti un file/documento da svolgersi nell'ambito di un comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum DocStructOperationEnum
Public Enumeration DocStructOperationEnum
public enum class DocStructOperationEnum
type DocStructOperationEnum
Membri
Nome | Valore | Descrizione
Base | 0 | Operazione non definita ovvero è la base di partenza delle informazioni sul file/documento. Tutti i primi elementi della struttura hanno questo tipo di operazione preimpostata.
Creating | 1 | Creazione di un nuovo documento lì dov'é.
Updating | 2 | Aggiornamento di un documento nel Database.
Moving | 3 | Spostamento o rinomina di un documento.
Copying | 4 | Copia di un documento o file da una posizione ad un'altra, creandone uno nuovo.
Linking | 5 | Collegamento di un documento ad un'anagrafica.
Disconnecting | 6 | Scollegare un documento da un'anagrafica.
Removing | 7 | Cancellazione di un documento.
Importing | 8 | Importazione di un file ed associazione ad un'anagrafica (Copia + Link).
Recognise | 9 | Registrazione nel Database di un file creando il documento lasciandolo lì dov'è ed associandolo ad un'anagrafica (Crea + Link). Se il documento esiste già effettua il solo Link.
Replacing | 10 | Sostituzione di un documento con un nuovo file.
Relocating | 11 | Puntamento di un file esterno ad un documento registrato con eventuale sostituzione,
EnsureLocal | 12 | Scaricamento del documento nell'area locale.
CheckOut | 13 | Messa in check-out del documento.
CheckOutStruttura | 14 | Messa in check-out del documento e di tutte le sue dipendenze.
Pubblica | 15 | Pubblica sul vault il file che è in checkout nell'area locale.
PubblicaStruttura | 16 | Pubblica sul vault il file che è in checkout nell'area locale comprese le dipendenze.
CheckIn | 17 | Mette in check-in il documento.
CheckInStruttura | 18 | Mette in check-in il documento e tutte le sue dipendenze. Cancella i documenti dall'area locale.
Sblocca | 19 | Sblocca il record del documento senza effettuare il Pubblica.
AnnullaCheckOut | 20 | Riporta il documento alla situazione precedente il check-out.
ForzaCheckIn | 21 | Permette di forzare il check-in di un documento.
ForzaCheckInStruttura | 22 | Forza il check-in del documento e tutte le sue dipendenze.
Export | 23 | Esportazione in percorso fuori dal database
ExportStruttura | 24 | Esportazione in percorso fuori dal database (struttura)
Vedi anche

Documentazione

Namespace DedNet.Commands


Classe DocStructPubblicaOperation
Pubblica sul vault un documento che è in checkout nell'area locale.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDocStructOperationBase
DedNet.CommandsDocStructPubblicaOperation

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DocStructPubblicaOperation : DocStructOperationBase
Public Class DocStructPubblicaOperation
    Inherits DocStructOperationBase
public ref class DocStructPubblicaOperation : public DocStructOperationBase
type DocStructPubblicaOperation =
    class
        inherit DocStructOperationBase
    end

Il tipo DocStructPubblicaOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CurrentWorkingFileName | Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Document | Restituisce il documento abbinato al file oppure null se non è registrato nel Database. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Exists | Restituisce se il file sia presente nel percorso corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | FileOperationExecuted | Restituisce se le operazioni sui file siano già state effettuate. (Sovrascrive DocStructOperationBaseFileOperationExecuted)
Proprietà pubblica | ForcedDocId | Restituisce oppure imposta la versione del DocId forzata per la creazione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasDocument | Restituisce se il file sia registrato nel Database come documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasForcedDocId | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasRowver | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsElaborated | Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsNew | Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato). (Ereditato da DocStructOperationBase)
Proprietà pubblica | Operation | Restituisce l'operazione che caratterizza questo elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Parent | Restituisce l'oggetto di appartenenza. (Ereditato da DocStructOperationBase)
Proprietà pubblica | PrecOperation | Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso file dell'elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RowVer | Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | SkipReferenceUpdate | Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false. (Ereditato da DocStructOperationBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | CalcolaNomeSostituto | Calcola e restituisce il percorso completo di destinazione del sostituto. (Ereditato da DocStructOperationBase)
Metodo protetto | UpdateDependences | Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di DocStructPubblicaOperation

Il tipo DocStructPubblicaOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CurrentWorkingFileName | Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Document | Restituisce il documento abbinato al file oppure null se non è registrato nel Database. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Exists | Restituisce se il file sia presente nel percorso corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | FileOperationExecuted | Restituisce se le operazioni sui file siano già state effettuate. (Sovrascrive DocStructOperationBaseFileOperationExecuted)
Proprietà pubblica | ForcedDocId | Restituisce oppure imposta la versione del DocId forzata per la creazione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasDocument | Restituisce se il file sia registrato nel Database come documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasForcedDocId | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasRowver | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsElaborated | Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsNew | Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato). (Ereditato da DocStructOperationBase)
Proprietà pubblica | Operation | Restituisce l'operazione che caratterizza questo elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Parent | Restituisce l'oggetto di appartenenza. (Ereditato da DocStructOperationBase)
Proprietà pubblica | PrecOperation | Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso file dell'elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RowVer | Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | SkipReferenceUpdate | Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Classe DocStructPubblicaOperation
Namespace DedNet.Commands


Proprietà DocStructPubblicaOperation.FileOperationExecuted

Proprietà DocStructPubblicaOperationFileOperationExecuted
Restituisce se le operazioni sui file siano già state effettuate.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool FileOperationExecuted { get; }
Public Overrides ReadOnly Property FileOperationExecuted As Boolean
    Get
public:
virtual property bool FileOperationExecuted {
    bool get () override;
}
abstract FileOperationExecuted : bool with get
override FileOperationExecuted : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructPubblicaOperation
Namespace DedNet.Commands


Metodi di DocStructPubblicaOperation

Il tipo DocStructPubblicaOperation espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | CalcolaNomeSostituto | Calcola e restituisce il percorso completo di destinazione del sostituto. (Ereditato da DocStructOperationBase)
Metodo protetto | UpdateDependences | Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Classe DocStructPubblicaOperation
Namespace DedNet.Commands


Classe DocStructPubblicaStrutturaOperation
Esegue il check-in sul documento e su tutte le sue dipendenze, se su queste è possibile effettuare l'operazione.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDocStructOperationBase
DedNet.CommandsDocStructPubblicaStrutturaOperation

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DocStructPubblicaStrutturaOperation : DocStructOperationBase
Public Class DocStructPubblicaStrutturaOperation
    Inherits DocStructOperationBase
public ref class DocStructPubblicaStrutturaOperation : public DocStructOperationBase
type DocStructPubblicaStrutturaOperation =
    class
        inherit DocStructOperationBase
    end

Il tipo DocStructPubblicaStrutturaOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CurrentWorkingFileName | Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Document | Restituisce il documento abbinato al file oppure null se non è registrato nel Database. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Exists | Restituisce se il file sia presente nel percorso corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | FileOperationExecuted | Restitusice se le operazioni sui file siano o meno state effettuate Valuta l'esistenza nel Vault del file. (Ereditato da DocStructOperationBase)
Proprietà pubblica | ForcedDocId | Restituisce oppure imposta la versione del DocId forzata per la creazione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasDocument | Restituisce se il file sia registrato nel Database come documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasForcedDocId | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasRowver | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsElaborated | Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsNew | Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato). (Ereditato da DocStructOperationBase)
Proprietà pubblica | Operation | Restituisce l'operazione che caratterizza questo elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Parent | Restituisce l'oggetto di appartenenza. (Ereditato da DocStructOperationBase)
Proprietà pubblica | PrecOperation | Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso file dell'elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RowVer | Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | SkipReferenceUpdate | Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false. (Ereditato da DocStructOperationBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | CalcolaNomeSostituto | Calcola e restituisce il percorso completo di destinazione del sostituto. (Ereditato da DocStructOperationBase)
Metodo protetto | UpdateDependences | Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di DocStructPubblicaStrutturaOperation

Il tipo DocStructPubblicaStrutturaOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CurrentWorkingFileName | Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Document | Restituisce il documento abbinato al file oppure null se non è registrato nel Database. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Exists | Restituisce se il file sia presente nel percorso corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | FileOperationExecuted | Restitusice se le operazioni sui file siano o meno state effettuate Valuta l'esistenza nel Vault del file. (Ereditato da DocStructOperationBase)
Proprietà pubblica | ForcedDocId | Restituisce oppure imposta la versione del DocId forzata per la creazione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasDocument | Restituisce se il file sia registrato nel Database come documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasForcedDocId | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasRowver | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsElaborated | Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsNew | Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato). (Ereditato da DocStructOperationBase)
Proprietà pubblica | Operation | Restituisce l'operazione che caratterizza questo elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Parent | Restituisce l'oggetto di appartenenza. (Ereditato da DocStructOperationBase)
Proprietà pubblica | PrecOperation | Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso file dell'elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RowVer | Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | SkipReferenceUpdate | Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Classe DocStructPubblicaStrutturaOperation
Namespace DedNet.Commands


Metodi di DocStructPubblicaStrutturaOperation

Il tipo DocStructPubblicaStrutturaOperation espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | CalcolaNomeSostituto | Calcola e restituisce il percorso completo di destinazione del sostituto. (Ereditato da DocStructOperationBase)
Metodo protetto | UpdateDependences | Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Classe DocStructPubblicaStrutturaOperation
Namespace DedNet.Commands


Classe DocStructRecogniseOperation
Operazione di riconoscimento file con collegamento ad un'anagrafica.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDocStructOperationBase
DedNet.CommandsDocStructRecogniseOperation

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DocStructRecogniseOperation : DocStructOperationBase
Public Class DocStructRecogniseOperation
    Inherits DocStructOperationBase
public ref class DocStructRecogniseOperation : public DocStructOperationBase
type DocStructRecogniseOperation =
    class
        inherit DocStructOperationBase
    end

Il tipo DocStructRecogniseOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CurrentWorkingFileName | Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Document | Restituisce il documento abbinato al file oppure null se non è registrato nel Database. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Exists | Restituisce se il file sia presente nel percorso corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | FileOperationExecuted | Restitusice se le operazioni sui file siano o meno state effettuate Valuta l'esistenza nel Vault del file. (Ereditato da DocStructOperationBase)
Proprietà pubblica | ForcedDocId | Restituisce oppure imposta la versione del DocId forzata per la creazione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasDocument | Restituisce se il file sia registrato nel Database come documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasForcedDocId | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasRowver | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsElaborated | Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsNew | Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato). (Ereditato da DocStructOperationBase)
Proprietà pubblica | Operation | Restituisce l'operazione che caratterizza questo elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Parent | Restituisce l'oggetto di appartenenza. (Ereditato da DocStructOperationBase)
Proprietà pubblica | PrecOperation | Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso file dell'elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RowVer | Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | SkipReferenceUpdate | Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false. (Ereditato da DocStructOperationBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | CalcolaNomeSostituto | Calcola e restituisce il percorso completo di destinazione del sostituto. (Ereditato da DocStructOperationBase)
Metodo protetto | UpdateDependences | Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di DocStructRecogniseOperation

Il tipo DocStructRecogniseOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CurrentWorkingFileName | Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Document | Restituisce il documento abbinato al file oppure null se non è registrato nel Database. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Exists | Restituisce se il file sia presente nel percorso corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | FileOperationExecuted | Restitusice se le operazioni sui file siano o meno state effettuate Valuta l'esistenza nel Vault del file. (Ereditato da DocStructOperationBase)
Proprietà pubblica | ForcedDocId | Restituisce oppure imposta la versione del DocId forzata per la creazione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasDocument | Restituisce se il file sia registrato nel Database come documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasForcedDocId | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasRowver | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsElaborated | Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsNew | Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato). (Ereditato da DocStructOperationBase)
Proprietà pubblica | Operation | Restituisce l'operazione che caratterizza questo elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Parent | Restituisce l'oggetto di appartenenza. (Ereditato da DocStructOperationBase)
Proprietà pubblica | PrecOperation | Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso file dell'elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RowVer | Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | SkipReferenceUpdate | Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Classe DocStructRecogniseOperation
Namespace DedNet.Commands


Metodi di DocStructRecogniseOperation

Il tipo DocStructRecogniseOperation espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | CalcolaNomeSostituto | Calcola e restituisce il percorso completo di destinazione del sostituto. (Ereditato da DocStructOperationBase)
Metodo protetto | UpdateDependences | Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Classe DocStructRecogniseOperation
Namespace DedNet.Commands


Classe DocStructRelocateOperation
Operazione di rilocazione di un file esterno su un documento interno. Permette di "puntare" semplicemente il documento interno ma anche di eseguire l'overwrite fisico come nel caso del replace.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDocStructOperationBase
DedNet.CommandsDocStructRelocateOperation

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DocStructRelocateOperation : DocStructOperationBase
Public Class DocStructRelocateOperation
    Inherits DocStructOperationBase
public ref class DocStructRelocateOperation : public DocStructOperationBase
type DocStructRelocateOperation =
    class
        inherit DocStructOperationBase
    end

Il tipo DocStructRelocateOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CurrentWorkingFileName | Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Document | Restituisce il documento abbinato al file oppure null se non è registrato nel Database. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Exists | Restituisce se il file sia presente nel percorso corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | FileOperationExecuted | Restituisce se la copia del file sia già stata effettuata. (Sovrascrive DocStructOperationBaseFileOperationExecuted)
Proprietà pubblica | ForcedDocId | Restituisce oppure imposta la versione del DocId forzata per la creazione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasDocument | Restituisce se il file sia registrato nel Database come documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasForcedDocId | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasRowver | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsElaborated | Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsNew | Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato). (Ereditato da DocStructOperationBase)
Proprietà pubblica | LazyMode | Indica se è attiva la modalità a ridotto numero di controlli
Proprietà pubblica | Operation | Restituisce l'operazione che caratterizza questo elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Parent | Restituisce l'oggetto di appartenenza. (Ereditato da DocStructOperationBase)
Proprietà pubblica | PrecOperation | Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso file dell'elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RowVer | Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | SkipReferenceUpdate | Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false. (Ereditato da DocStructOperationBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | CalcolaNomeSostituto | Calcola e restituisce il percorso completo di destinazione del sostituto. (Ereditato da DocStructOperationBase)
Metodo protetto | UpdateDependences | Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di DocStructRelocateOperation

Il tipo DocStructRelocateOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CurrentWorkingFileName | Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Document | Restituisce il documento abbinato al file oppure null se non è registrato nel Database. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Exists | Restituisce se il file sia presente nel percorso corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | FileOperationExecuted | Restituisce se la copia del file sia già stata effettuata. (Sovrascrive DocStructOperationBaseFileOperationExecuted)
Proprietà pubblica | ForcedDocId | Restituisce oppure imposta la versione del DocId forzata per la creazione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasDocument | Restituisce se il file sia registrato nel Database come documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasForcedDocId | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasRowver | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsElaborated | Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsNew | Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato). (Ereditato da DocStructOperationBase)
Proprietà pubblica | LazyMode | Indica se è attiva la modalità a ridotto numero di controlli
Proprietà pubblica | Operation | Restituisce l'operazione che caratterizza questo elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Parent | Restituisce l'oggetto di appartenenza. (Ereditato da DocStructOperationBase)
Proprietà pubblica | PrecOperation | Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso file dell'elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RowVer | Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | SkipReferenceUpdate | Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Classe DocStructRelocateOperation
Namespace DedNet.Commands


Proprietà DocStructRelocateOperation.FileOperationExecuted

Proprietà DocStructRelocateOperationFileOperationExecuted
Restituisce se la copia del file sia già stata effettuata.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool FileOperationExecuted { get; set; }
Public Overrides Property FileOperationExecuted As Boolean
    Get
    Set
public:
virtual property bool FileOperationExecuted {
    bool get () override;
    void set (bool value) override;
}
abstract FileOperationExecuted : bool with get, set
override FileOperationExecuted : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructRelocateOperation
Namespace DedNet.Commands


Proprietà DocStructRelocateOperation.LazyMode

Proprietà DocStructRelocateOperationLazyMode
Indica se è attiva la modalità a ridotto numero di controlli

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool LazyMode { get; set; }
Public Property LazyMode As Boolean
    Get
    Set
public:
property bool LazyMode {
    bool get ();
    void set (bool value);
}
member LazyMode : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructRelocateOperation
Namespace DedNet.Commands


Metodi di DocStructRelocateOperation

Il tipo DocStructRelocateOperation espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | CalcolaNomeSostituto | Calcola e restituisce il percorso completo di destinazione del sostituto. (Ereditato da DocStructOperationBase)
Metodo protetto | UpdateDependences | Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Classe DocStructRelocateOperation
Namespace DedNet.Commands


Classe DocStructRemovingOperation
Operazione di eliminazione documento.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDocStructOperationBase
DedNet.CommandsDocStructRemovingOperation

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DocStructRemovingOperation : DocStructOperationBase
Public Class DocStructRemovingOperation
    Inherits DocStructOperationBase
public ref class DocStructRemovingOperation : public DocStructOperationBase
type DocStructRemovingOperation =
    class
        inherit DocStructOperationBase
    end

Il tipo DocStructRemovingOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CurrentWorkingFileName | Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Document | Restituisce il documento abbinato al file oppure null se non è registrato nel Database. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Exists | Restituisce se il file sia presente nel percorso corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | FileOperationExecuted | Restituisce true se il file non esiste, altrimenti false. (Sovrascrive DocStructOperationBaseFileOperationExecuted)
Proprietà pubblica | ForcedDocId | Restituisce oppure imposta la versione del DocId forzata per la creazione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasDocument | Restituisce se il file sia registrato nel Database come documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasForcedDocId | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasRowver | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsElaborated | Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsNew | Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato). (Ereditato da DocStructOperationBase)
Proprietà pubblica | Operation | Restituisce l'operazione che caratterizza questo elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Parent | Restituisce l'oggetto di appartenenza. (Ereditato da DocStructOperationBase)
Proprietà pubblica | PrecOperation | Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso file dell'elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RowVer | Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | SkipDeletionTracking |
Proprietà pubblica | SkipReferenceUpdate | Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false. (Ereditato da DocStructOperationBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | CalcolaNomeSostituto | Calcola e restituisce il percorso completo di destinazione del sostituto. (Ereditato da DocStructOperationBase)
Metodo protetto | UpdateDependences | Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di DocStructRemovingOperation

Il tipo DocStructRemovingOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CurrentWorkingFileName | Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Document | Restituisce il documento abbinato al file oppure null se non è registrato nel Database. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Exists | Restituisce se il file sia presente nel percorso corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | FileOperationExecuted | Restituisce true se il file non esiste, altrimenti false. (Sovrascrive DocStructOperationBaseFileOperationExecuted)
Proprietà pubblica | ForcedDocId | Restituisce oppure imposta la versione del DocId forzata per la creazione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasDocument | Restituisce se il file sia registrato nel Database come documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasForcedDocId | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasRowver | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsElaborated | Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsNew | Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato). (Ereditato da DocStructOperationBase)
Proprietà pubblica | Operation | Restituisce l'operazione che caratterizza questo elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Parent | Restituisce l'oggetto di appartenenza. (Ereditato da DocStructOperationBase)
Proprietà pubblica | PrecOperation | Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso file dell'elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RowVer | Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | SkipDeletionTracking |
Proprietà pubblica | SkipReferenceUpdate | Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Classe DocStructRemovingOperation
Namespace DedNet.Commands


Proprietà DocStructRemovingOperation.FileOperationExecuted

Proprietà DocStructRemovingOperationFileOperationExecuted
Restituisce true se il file non esiste, altrimenti false.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool FileOperationExecuted { get; }
Public Overrides ReadOnly Property FileOperationExecuted As Boolean
    Get
public:
virtual property bool FileOperationExecuted {
    bool get () override;
}
abstract FileOperationExecuted : bool with get
override FileOperationExecuted : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructRemovingOperation
Namespace DedNet.Commands


Proprietà DocStructRemovingOperation.SkipDeletionTracking

Proprietà DocStructRemovingOperationSkipDeletionTracking

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool SkipDeletionTracking { get; set; }
Public Property SkipDeletionTracking As Boolean
    Get
    Set
public:
property bool SkipDeletionTracking {
    bool get ();
    void set (bool value);
}
member SkipDeletionTracking : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructRemovingOperation
Namespace DedNet.Commands


Metodi di DocStructRemovingOperation

Il tipo DocStructRemovingOperation espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | CalcolaNomeSostituto | Calcola e restituisce il percorso completo di destinazione del sostituto. (Ereditato da DocStructOperationBase)
Metodo protetto | UpdateDependences | Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Classe DocStructRemovingOperation
Namespace DedNet.Commands


Classe DocStructReplaceOperation
Operazione di sostituzione documento con un nuovo file.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDocStructOperationBase
DedNet.CommandsDocStructReplaceOperation

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DocStructReplaceOperation : DocStructOperationBase
Public Class DocStructReplaceOperation
    Inherits DocStructOperationBase
public ref class DocStructReplaceOperation : public DocStructOperationBase
type DocStructReplaceOperation =
    class
        inherit DocStructOperationBase
    end

Il tipo DocStructReplaceOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CurrentWorkingFileName | Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Document | Restituisce il documento abbinato al file oppure null se non è registrato nel Database. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Exists | Restituisce se il file sia presente nel percorso corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | FileOperationExecuted | Restituisce se la copia del file sia già stata effettuata. (Sovrascrive DocStructOperationBaseFileOperationExecuted)
Proprietà pubblica | ForcedDocId | Restituisce oppure imposta la versione del DocId forzata per la creazione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasDocument | Restituisce se il file sia registrato nel Database come documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasForcedDocId | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasRowver | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsElaborated | Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsNew | Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato). (Ereditato da DocStructOperationBase)
Proprietà pubblica | Operation | Restituisce l'operazione che caratterizza questo elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Parent | Restituisce l'oggetto di appartenenza. (Ereditato da DocStructOperationBase)
Proprietà pubblica | PrecOperation | Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso file dell'elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RowVer | Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | SkipReferenceUpdate | Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false. (Ereditato da DocStructOperationBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | CalcolaNomeSostituto | Calcola e restituisce il percorso completo di destinazione del sostituto. (Ereditato da DocStructOperationBase)
Metodo protetto | UpdateDependences | Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di DocStructReplaceOperation

Il tipo DocStructReplaceOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CurrentWorkingFileName | Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Document | Restituisce il documento abbinato al file oppure null se non è registrato nel Database. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Exists | Restituisce se il file sia presente nel percorso corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | FileOperationExecuted | Restituisce se la copia del file sia già stata effettuata. (Sovrascrive DocStructOperationBaseFileOperationExecuted)
Proprietà pubblica | ForcedDocId | Restituisce oppure imposta la versione del DocId forzata per la creazione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasDocument | Restituisce se il file sia registrato nel Database come documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasForcedDocId | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasRowver | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsElaborated | Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsNew | Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato). (Ereditato da DocStructOperationBase)
Proprietà pubblica | Operation | Restituisce l'operazione che caratterizza questo elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Parent | Restituisce l'oggetto di appartenenza. (Ereditato da DocStructOperationBase)
Proprietà pubblica | PrecOperation | Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso file dell'elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RowVer | Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | SkipReferenceUpdate | Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Classe DocStructReplaceOperation
Namespace DedNet.Commands


Proprietà DocStructReplaceOperation.FileOperationExecuted

Proprietà DocStructReplaceOperationFileOperationExecuted
Restituisce se la copia del file sia già stata effettuata.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool FileOperationExecuted { get; }
Public Overrides ReadOnly Property FileOperationExecuted As Boolean
    Get
public:
virtual property bool FileOperationExecuted {
    bool get () override;
}
abstract FileOperationExecuted : bool with get
override FileOperationExecuted : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructReplaceOperation
Namespace DedNet.Commands


Metodi di DocStructReplaceOperation

Il tipo DocStructReplaceOperation espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | CalcolaNomeSostituto | Calcola e restituisce il percorso completo di destinazione del sostituto. (Ereditato da DocStructOperationBase)
Metodo protetto | UpdateDependences | Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Classe DocStructReplaceOperation
Namespace DedNet.Commands


Classe DocStructSbloccaOperation
Sblocca un documento in modo che sia modificabile dagli altri utenti. Non effettua operazioni sui file.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDocStructOperationBase
DedNet.CommandsDocStructSbloccaOperation

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DocStructSbloccaOperation : DocStructOperationBase
Public Class DocStructSbloccaOperation
    Inherits DocStructOperationBase
public ref class DocStructSbloccaOperation : public DocStructOperationBase
type DocStructSbloccaOperation =
    class
        inherit DocStructOperationBase
    end

Il tipo DocStructSbloccaOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CurrentWorkingFileName | Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | DeletingPwsFile | Restituisce se il comando eliminerà o meno il documento in locale.
Proprietà pubblica | Document | Restituisce il documento abbinato al file oppure null se non è registrato nel Database. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Exists | Restituisce se il file sia presente nel percorso corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | FileOperationExecuted | Restituisce se le operazioni sui file siano già state effettuate. (Sovrascrive DocStructOperationBaseFileOperationExecuted)
Proprietà pubblica | ForcedDocId | Restituisce oppure imposta la versione del DocId forzata per la creazione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasDocument | Restituisce se il file sia registrato nel Database come documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasForcedDocId | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasRowver | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsElaborated | Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsNew | Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato). (Ereditato da DocStructOperationBase)
Proprietà pubblica | Operation | Restituisce l'operazione che caratterizza questo elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Parent | Restituisce l'oggetto di appartenenza. (Ereditato da DocStructOperationBase)
Proprietà pubblica | PrecOperation | Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso file dell'elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RowVer | Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | SkipReferenceUpdate | Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false. (Ereditato da DocStructOperationBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | CalcolaNomeSostituto | Calcola e restituisce il percorso completo di destinazione del sostituto. (Ereditato da DocStructOperationBase)
Metodo protetto | UpdateDependences | Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di DocStructSbloccaOperation

Il tipo DocStructSbloccaOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CurrentWorkingFileName | Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | DeletingPwsFile | Restituisce se il comando eliminerà o meno il documento in locale.
Proprietà pubblica | Document | Restituisce il documento abbinato al file oppure null se non è registrato nel Database. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Exists | Restituisce se il file sia presente nel percorso corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | FileOperationExecuted | Restituisce se le operazioni sui file siano già state effettuate. (Sovrascrive DocStructOperationBaseFileOperationExecuted)
Proprietà pubblica | ForcedDocId | Restituisce oppure imposta la versione del DocId forzata per la creazione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasDocument | Restituisce se il file sia registrato nel Database come documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasForcedDocId | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasRowver | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsElaborated | Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsNew | Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato). (Ereditato da DocStructOperationBase)
Proprietà pubblica | Operation | Restituisce l'operazione che caratterizza questo elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Parent | Restituisce l'oggetto di appartenenza. (Ereditato da DocStructOperationBase)
Proprietà pubblica | PrecOperation | Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso file dell'elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RowVer | Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | SkipReferenceUpdate | Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Classe DocStructSbloccaOperation
Namespace DedNet.Commands


Proprietà DocStructSbloccaOperation.DeletingPwsFile

Proprietà DocStructSbloccaOperationDeletingPwsFile
Restituisce se il comando eliminerà o meno il documento in locale.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool DeletingPwsFile { get; }
Public ReadOnly Property DeletingPwsFile As Boolean
    Get
public:
property bool DeletingPwsFile {
    bool get ();
}
member DeletingPwsFile : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructSbloccaOperation
Namespace DedNet.Commands


Proprietà DocStructSbloccaOperation.FileOperationExecuted

Proprietà DocStructSbloccaOperationFileOperationExecuted
Restituisce se le operazioni sui file siano già state effettuate.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool FileOperationExecuted { get; }
Public Overrides ReadOnly Property FileOperationExecuted As Boolean
    Get
public:
virtual property bool FileOperationExecuted {
    bool get () override;
}
abstract FileOperationExecuted : bool with get
override FileOperationExecuted : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructSbloccaOperation
Namespace DedNet.Commands


Metodi di DocStructSbloccaOperation

Il tipo DocStructSbloccaOperation espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | CalcolaNomeSostituto | Calcola e restituisce il percorso completo di destinazione del sostituto. (Ereditato da DocStructOperationBase)
Metodo protetto | UpdateDependences | Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Classe DocStructSbloccaOperation
Namespace DedNet.Commands


Classe DocStructUpdatingOperation
Operazione di aggiornamento documento nel Database.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDocStructOperationBase
DedNet.CommandsDocStructUpdatingOperation

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DocStructUpdatingOperation : DocStructOperationBase
Public Class DocStructUpdatingOperation
    Inherits DocStructOperationBase
public ref class DocStructUpdatingOperation : public DocStructOperationBase
type DocStructUpdatingOperation =
    class
        inherit DocStructOperationBase
    end

Il tipo DocStructUpdatingOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CurrentWorkingFileName | Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Document | Restituisce il documento abbinato al file oppure null se non è registrato nel Database. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Exists | Restituisce se il file sia presente nel percorso corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | FileOperationExecuted | Restitusice se le operazioni sui file siano o meno state effettuate Valuta l'esistenza nel Vault del file. (Ereditato da DocStructOperationBase)
Proprietà pubblica | ForcedDocId | Restituisce oppure imposta la versione del DocId forzata per la creazione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasDocument | Restituisce se il file sia registrato nel Database come documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasForcedDocId | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasRowver | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsElaborated | Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsNew | Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato). (Ereditato da DocStructOperationBase)
Proprietà pubblica | Operation | Restituisce l'operazione che caratterizza questo elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Parent | Restituisce l'oggetto di appartenenza. (Ereditato da DocStructOperationBase)
Proprietà pubblica | PrecOperation | Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso file dell'elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RowVer | Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | SkipReferenceUpdate | Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false. (Ereditato da DocStructOperationBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | CalcolaNomeSostituto | Calcola e restituisce il percorso completo di destinazione del sostituto. (Ereditato da DocStructOperationBase)
Metodo protetto | UpdateDependences | Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di DocStructUpdatingOperation

Il tipo DocStructUpdatingOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CurrentWorkingFileName | Se è presente un DedDoc nella proprità Document lo usa per capire se l'utente sta lavorando in locale o in rete (nel vault). In ogni caso utilizza le informazioni presenti nella proprietà RootInfo in quanto può capitare che RootInfo contenga il percorso file di interesse mentre il Document faccia riferimento alle operazioni precedenti quella corrente e che sia poi da aggiornare con il contenuto del RootInfo. Questo serve per mantenere il più possibile "tramandato" tra le varie operazioni, il percorso originale utilizato per l'inizializzazione del DocStructInfo in modo che operazioni come la creazione del documento possano valutare se dopo aver creato il documento sia da lasciare o meno in check-out dall'utente corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Document | Restituisce il documento abbinato al file oppure null se non è registrato nel Database. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Exists | Restituisce se il file sia presente nel percorso corrente. (Ereditato da DocStructOperationBase)
Proprietà pubblica | FileOperationExecuted | Restitusice se le operazioni sui file siano o meno state effettuate Valuta l'esistenza nel Vault del file. (Ereditato da DocStructOperationBase)
Proprietà pubblica | ForcedDocId | Restituisce oppure imposta la versione del DocId forzata per la creazione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasDocument | Restituisce se il file sia registrato nel Database come documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasForcedDocId | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | HasRowver | Restituisce se sia stata specificata una particolare versione del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsElaborated | Verifica se questo elemento sia o meno elaborato dal punto di vista dell'operazione sui record. Se true vuol dire che sono state effettuate tutte le operazioni sul Database ma non è detto che siano anche state effettuate le perazioni sui file. Le operazioni su file sono segnalate dalla proprietà FileOperationExecuted. (Ereditato da DocStructOperationBase)
Proprietà pubblica | IsNew | Restituisce o imposta se il documento sia nuovo (in memoria e non ancora salvato). (Ereditato da DocStructOperationBase)
Proprietà pubblica | Operation | Restituisce l'operazione che caratterizza questo elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | Parent | Restituisce l'oggetto di appartenenza. (Ereditato da DocStructOperationBase)
Proprietà pubblica | PrecOperation | Restituisce l'ultima operazione presente prima di questa stessa operazione. Viene utilizzata per reperire delle informazioni sullo stato del file prima di questa operazione. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RootInfo | Restituisce le informazioni sul percorso file dell'elemento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | RowVer | Restituisce oppure imposta la versione attuale del documento (in memoria se impostata dal client) e quindi da usare nella creazione o nell'aggiornamento del documento. (Ereditato da DocStructOperationBase)
Proprietà pubblica | SkipReferenceUpdate | Determina se l'aggiornamento dei riferimenti deve essere skippato. Normalmente è false. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Classe DocStructUpdatingOperation
Namespace DedNet.Commands


Metodi di DocStructUpdatingOperation

Il tipo DocStructUpdatingOperation espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | CalcolaNomeSostituto | Calcola e restituisce il percorso completo di destinazione del sostituto. (Ereditato da DocStructOperationBase)
Metodo protetto | UpdateDependences | Aggiorna le dipendenze nel Database in base ai figli presenti in questo elemento. (Ereditato da DocStructOperationBase)
Torna su
Vedi anche

Documentazione

Classe DocStructUpdatingOperation
Namespace DedNet.Commands


Classe DocTransferHistoryCommand
Classe che rappresenta il comando per visualizzare la storia dei trasferimenti del documento
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsDedDocumentCommand
DedNet.CommandsDocTransferHistoryCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DocTransferHistoryCommand : DedDocumentCommand
Public Class DocTransferHistoryCommand
    Inherits DedDocumentCommand
public ref class DocTransferHistoryCommand : public DedDocumentCommand
type DocTransferHistoryCommand =
    class
        inherit DedDocumentCommand
    end

Il tipo DocTransferHistoryCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DocumentInfos | Restituisce la lista dei documenti con abbinato il contesto di anagrafica di elaborazione comando. (Ereditato da DedDocumentCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedDocumentCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Reinizializza il comando. (Ereditato da DedDocumentCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedDocumentCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedDocumentCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedDocumentCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedDocumentCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di DocTransferHistoryCommand

Il tipo DocTransferHistoryCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DocumentInfos | Restituisce la lista dei documenti con abbinato il contesto di anagrafica di elaborazione comando. (Ereditato da DedDocumentCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedDocumentCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DocTransferHistoryCommand
Namespace DedNet.Commands


Proprietà DocTransferHistoryCommand.NeedParameters

Proprietà DocTransferHistoryCommandNeedParameters

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocTransferHistoryCommand
Namespace DedNet.Commands


Metodi di DocTransferHistoryCommand

Il tipo DocTransferHistoryCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Reinizializza il comando. (Ereditato da DedDocumentCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedDocumentCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedDocumentCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedDocumentCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedDocumentCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DocTransferHistoryCommand
Namespace DedNet.Commands


Metodo DocTransferHistoryCommand.Enabled

Metodo DocTransferHistoryCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe DocTransferHistoryCommand
Namespace DedNet.Commands


Metodo DocTransferHistoryCommand.ExecuteCommand

Metodo DocTransferHistoryCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe DocTransferHistoryCommand
Namespace DedNet.Commands


Metodo DocTransferHistoryCommand.SetContext

Metodo DocTransferHistoryCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe DocTransferHistoryCommand
Namespace DedNet.Commands


Classe DuplicateCommCommand
Comando di duplicazione di una commessa. In base alla commessa di riferimento impostata, verrà creata una nuova commessa dello stesso livello e con gli stessi dati (fatta ad eccezione del NOME e della DATA).
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsDuplicateCommCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DuplicateCommCommand : DedCommand
Public Class DuplicateCommCommand
    Inherits DedCommand
public ref class DuplicateCommCommand : public DedCommand
type DuplicateCommCommand =
    class
        inherit DedCommand
    end

Il tipo DuplicateCommCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se si vuole creare una sotto commessa ma non si passa il riferimento. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NewComm | Restituisce la nuova commessa clonata. Questo campo verrà impostato solamente nel caso in cui il comando sia terminato con successo.
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | ReferenceComm | Imposta o restituisce la commessa di riferimento da utilizzare per l'operazione di duplicazione.
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di DuplicateCommCommand

Il tipo DuplicateCommCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se si vuole creare una sotto commessa ma non si passa il riferimento. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NewComm | Restituisce la nuova commessa clonata. Questo campo verrà impostato solamente nel caso in cui il comando sia terminato con successo.
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | ReferenceComm | Imposta o restituisce la commessa di riferimento da utilizzare per l'operazione di duplicazione.
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DuplicateCommCommand
Namespace DedNet.Commands


Proprietà DuplicateCommCommand.NeedParameters

Proprietà DuplicateCommCommandNeedParameters
Restituisce true se si vuole creare una sotto commessa ma non si passa il riferimento.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DuplicateCommCommand
Namespace DedNet.Commands


Proprietà DuplicateCommCommand.NewComm

Proprietà DuplicateCommCommandNewComm
Restituisce la nuova commessa clonata. Questo campo verrà impostato solamente nel caso in cui il comando sia terminato con successo.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedComm NewComm { get; }
Public ReadOnly Property NewComm As DedComm
    Get
public:
property DedComm^ NewComm {
    DedComm^ get ();
}
member NewComm : DedComm with get

Valore della proprietà

DedComm
Vedi anche

Documentazione

Classe DuplicateCommCommand
Namespace DedNet.Commands


Proprietà DuplicateCommCommand.ReferenceComm

Proprietà DuplicateCommCommandReferenceComm
Imposta o restituisce la commessa di riferimento da utilizzare per l'operazione di duplicazione.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedComm ReferenceComm { get; set; }
Public Property ReferenceComm As DedComm
    Get
    Set
public:
property DedComm^ ReferenceComm {
    DedComm^ get ();
    void set (DedComm^ value);
}
member ReferenceComm : DedComm with get, set

Valore della proprietà

DedComm
Vedi anche

Documentazione

Classe DuplicateCommCommand
Namespace DedNet.Commands


Metodi di DuplicateCommCommand

Il tipo DuplicateCommCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe DuplicateCommCommand
Namespace DedNet.Commands


Metodo DuplicateCommCommand.ClearCommand

Metodo DuplicateCommCommandClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe DuplicateCommCommand
Namespace DedNet.Commands


Metodo DuplicateCommCommand.Enabled

Metodo DuplicateCommCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe DuplicateCommCommand
Namespace DedNet.Commands


Metodo DuplicateCommCommand.ExecuteCommand

Metodo DuplicateCommCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe DuplicateCommCommand
Namespace DedNet.Commands


Metodo DuplicateCommCommand.SetContext

Metodo DuplicateCommCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto c'è una sola anagrafica alla quale associare il file.
Vedi anche

Documentazione

Classe DuplicateCommCommand
Namespace DedNet.Commands


Classe EcoEditCommand
Comando usato per visualizzare gli ECO.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsEcoEditCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class EcoEditCommand : DedCommand
Public Class EcoEditCommand
    Inherits DedCommand
public ref class EcoEditCommand : public DedCommand
type EcoEditCommand =
    class
        inherit DedCommand
    end

Il tipo EcoEditCommand espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | EcoEditCommand | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Comm | Commessa della quale associare/visualizzare gli ECO.
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Data | Anagrafica della quale associare/visualizzare gli ECO.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve essere impostata la struttura di salvataggio distinta. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Eseguo il comando. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Imposto il contesto per l'esecuzione del comando (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Costruttore EcoEditCommand
Costruttore unico.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public EcoEditCommand(
    DedNetApplication app,
    string internalName,
    string name
)
Public Sub New (
    app As DedNetApplication,
    internalName As String,
    name As String
)
public:
EcoEditCommand(
    DedNetApplication^ app,
    String^ internalName,
    String^ name
)
new :
        app : DedNetApplication *
        internalName : string *
        name : string -> EcoEditCommand

Parametri

app DedNetApplication
Riferimento all'oggetto DedNetApplication.
internalName String
Nome interno del comando.
name String
Nome visualizzato del comando.
Vedi anche

Documentazione

Classe EcoEditCommand
Namespace DedNet.Commands


Proprietà di EcoEditCommand

Il tipo EcoEditCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Comm | Commessa della quale associare/visualizzare gli ECO.
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Data | Anagrafica della quale associare/visualizzare gli ECO.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve essere impostata la struttura di salvataggio distinta. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe EcoEditCommand
Namespace DedNet.Commands


Proprietà EcoEditCommand.Comm

Proprietà EcoEditCommandComm
Commessa della quale associare/visualizzare gli ECO.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedComm Comm { get; set; }
Public Property Comm As DedComm
    Get
    Set
public:
property DedComm^ Comm {
    DedComm^ get ();
    void set (DedComm^ value);
}
member Comm : DedComm with get, set

Valore della proprietà

DedComm
Vedi anche

Documentazione

Classe EcoEditCommand
Namespace DedNet.Commands


Proprietà EcoEditCommand.Data

Proprietà EcoEditCommandData
Anagrafica della quale associare/visualizzare gli ECO.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; set; }
Public Property Data As DedData
    Get
    Set
public:
property DedData^ Data {
    DedData^ get ();
    void set (DedData^ value);
}
member Data : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe EcoEditCommand
Namespace DedNet.Commands


Proprietà EcoEditCommand.NeedParameters

Proprietà EcoEditCommandNeedParameters
Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve essere impostata la struttura di salvataggio distinta.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe EcoEditCommand
Namespace DedNet.Commands


Metodi di EcoEditCommand

Il tipo EcoEditCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Eseguo il comando. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Imposto il contesto per l'esecuzione del comando (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe EcoEditCommand
Namespace DedNet.Commands


Metodo EcoEditCommand.ClearCommand

Metodo EcoEditCommandClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe EcoEditCommand
Namespace DedNet.Commands


Metodo EcoEditCommand.Enabled

Metodo EcoEditCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce True se il comando deve risultare abilitato all'utente, False altrimenti.
Vedi anche

Documentazione

Classe EcoEditCommand
Namespace DedNet.Commands


Metodo EcoEditCommand.ExecuteCommand

Metodo EcoEditCommandExecuteCommand
Eseguo il comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe EcoEditCommand
Namespace DedNet.Commands


Metodo EcoEditCommand.SetContext

Metodo EcoEditCommandSetContext
Imposto il contesto per l'esecuzione del comando

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe EcoEditCommand
Namespace DedNet.Commands


Classe EcoHistoryCommand
Comando usato per visualizzare la storia di un ECO
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsEcoHistoryCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class EcoHistoryCommand : DedCommand
Public Class EcoHistoryCommand
    Inherits DedCommand
public ref class EcoHistoryCommand : public DedCommand
type EcoHistoryCommand =
    class
        inherit DedCommand
    end

Il tipo EcoHistoryCommand espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | EcoHistoryCommand | Costruttore.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Eco | Oggeto DedEco da eliminare.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve essere impostata la struttura di salvataggio distinta. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Imposta il contesto del comando. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Costruttore EcoHistoryCommand
Costruttore.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public EcoHistoryCommand(
    DedNetApplication app,
    string internalName,
    string name
)
Public Sub New (
    app As DedNetApplication,
    internalName As String,
    name As String
)
public:
EcoHistoryCommand(
    DedNetApplication^ app,
    String^ internalName,
    String^ name
)
new :
        app : DedNetApplication *
        internalName : string *
        name : string -> EcoHistoryCommand

Parametri

app DedNetApplication
Riferimento all'oggetto DedNetApplication.
internalName String
Nome interno del comando.
name String
Nome visualizzato del comando.
Vedi anche

Documentazione

Classe EcoHistoryCommand
Namespace DedNet.Commands


Proprietà di EcoHistoryCommand

Il tipo EcoHistoryCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Eco | Oggeto DedEco da eliminare.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve essere impostata la struttura di salvataggio distinta. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe EcoHistoryCommand
Namespace DedNet.Commands


Proprietà EcoHistoryCommand.Eco

Proprietà EcoHistoryCommandEco
Oggeto DedEco da eliminare.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEco Eco { get; set; }
Public Property Eco As DedEco
    Get
    Set
public:
property DedEco^ Eco {
    DedEco^ get ();
    void set (DedEco^ value);
}
member Eco : DedEco with get, set

Valore della proprietà

DedEco
Vedi anche

Documentazione

Classe EcoHistoryCommand
Namespace DedNet.Commands


Proprietà EcoHistoryCommand.NeedParameters

Proprietà EcoHistoryCommandNeedParameters
Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve essere impostata la struttura di salvataggio distinta.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe EcoHistoryCommand
Namespace DedNet.Commands


Metodi di EcoHistoryCommand

Il tipo EcoHistoryCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Imposta il contesto del comando. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe EcoHistoryCommand
Namespace DedNet.Commands


Metodo EcoHistoryCommand.ClearCommand

Metodo EcoHistoryCommandClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe EcoHistoryCommand
Namespace DedNet.Commands


Metodo EcoHistoryCommand.Enabled

Metodo EcoHistoryCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe EcoHistoryCommand
Namespace DedNet.Commands


Metodo EcoHistoryCommand.ExecuteCommand

Metodo EcoHistoryCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe EcoHistoryCommand
Namespace DedNet.Commands


Metodo EcoHistoryCommand.SetContext

Metodo EcoHistoryCommandSetContext
Imposta il contesto del comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe EcoHistoryCommand
Namespace DedNet.Commands


Classe EditAnagrCommand
Apre la finestra di Editazione delle anagrafiche.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsEditAnagrCommandBase
DedNet.CommandsEditAnagrCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class EditAnagrCommand : EditAnagrCommandBase
Public Class EditAnagrCommand
    Inherits EditAnagrCommandBase
public ref class EditAnagrCommand : public EditAnagrCommandBase
type EditAnagrCommand =
    class
        inherit EditAnagrCommandBase
    end

Il tipo EditAnagrCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | ApplyRule | Imposta / Restiruisce se aplpicare le regole. (Ereditato da EditAnagrCommandBase)
Proprietà pubblica | AttrList | Restituisce la lista che viene utilizzata dal comando. (Ereditato da EditAnagrCommandBase)
Proprietà pubblica | BtnRefreshClick | Imposta/Restituisce l'evento chiamato sul click del puldante di Refresh. (Ereditato da EditAnagrCommandBase)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DataInfos | Restituisce la lista delle anagrafiche di elaborazione comando. (Ereditato da EditAnagrCommandBase)
Proprietà pubblica | DisableEditingForOnlyDbAttrs | Indica se abilitare o meno l'editazione per gli attributi marchiati come "Solo Db". (Ereditato da EditAnagrCommandBase)
Proprietà pubblica | EnableDedContextMenu | Indica se abilitare il menu contestuale con i comandi del DED. (Ereditato da EditAnagrCommandBase)
Proprietà pubblica | ExecuteFromBomControl | Indica se il comando è stato eseguito da un contesto di distinta o meno.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnorePerm | Indica se ignorare il controllo sui permessi. (Ereditato da EditAnagrCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | IsInDb | Restituisce o imposta se le anagrafiche siano o meno da considerarsi nel Database. (Ereditato da EditAnagrCommandBase)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | LockAnagr | Indica se effettuare il lock dell'anagrafica. Di defualt è True. (Ereditato da EditAnagrCommandBase)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Il comando necessita di almeno una IDedData nella lista. (Ereditato da EditAnagrCommandBase)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NewAttrEditingManagement | Indica se il utilizzare la nuova gestione per l'editazione degli attributi.
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OnlyDbAttrManagement | Indica se il dialogo deve gestire gli attributi di ricambio o meno.
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | RefreshButtonEnabled | Imposta/Restituisce se abilitare il tasto di refresh. (Ereditato da EditAnagrCommandBase)
Proprietà pubblica | RefreshButtonTooltip | Imposta/Restituisce il tooltip del tasto di refresh. (Ereditato da EditAnagrCommandBase)
Proprietà pubblica | RefreshButtonVisible | Imposta/Restituisce se visualizzare il tasto di refresh. (Ereditato da EditAnagrCommandBase)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SparePartsManagement | Indica se il dialogo deve gestire gli attributi di ricambio o meno.
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Proprietà pubblica | ValidateAttr | Indica se validare gli attributi. (Ereditato da EditAnagrCommandBase)
Proprietà pubblica | WindowTitle | Restituisce o imposta il titolo della finestra di dialogo. (Ereditato da EditAnagrCommandBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Ereditato da EditAnagrCommandBase)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Ereditato da EditAnagrCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Ereditato da EditAnagrCommandBase)
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di EditAnagrCommand

Il tipo EditAnagrCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | ApplyRule | Imposta / Restiruisce se aplpicare le regole. (Ereditato da EditAnagrCommandBase)
Proprietà pubblica | AttrList | Restituisce la lista che viene utilizzata dal comando. (Ereditato da EditAnagrCommandBase)
Proprietà pubblica | BtnRefreshClick | Imposta/Restituisce l'evento chiamato sul click del puldante di Refresh. (Ereditato da EditAnagrCommandBase)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DataInfos | Restituisce la lista delle anagrafiche di elaborazione comando. (Ereditato da EditAnagrCommandBase)
Proprietà pubblica | DisableEditingForOnlyDbAttrs | Indica se abilitare o meno l'editazione per gli attributi marchiati come "Solo Db". (Ereditato da EditAnagrCommandBase)
Proprietà pubblica | EnableDedContextMenu | Indica se abilitare il menu contestuale con i comandi del DED. (Ereditato da EditAnagrCommandBase)
Proprietà pubblica | ExecuteFromBomControl | Indica se il comando è stato eseguito da un contesto di distinta o meno.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnorePerm | Indica se ignorare il controllo sui permessi. (Ereditato da EditAnagrCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | IsInDb | Restituisce o imposta se le anagrafiche siano o meno da considerarsi nel Database. (Ereditato da EditAnagrCommandBase)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | LockAnagr | Indica se effettuare il lock dell'anagrafica. Di defualt è True. (Ereditato da EditAnagrCommandBase)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Il comando necessita di almeno una IDedData nella lista. (Ereditato da EditAnagrCommandBase)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NewAttrEditingManagement | Indica se il utilizzare la nuova gestione per l'editazione degli attributi.
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OnlyDbAttrManagement | Indica se il dialogo deve gestire gli attributi di ricambio o meno.
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | RefreshButtonEnabled | Imposta/Restituisce se abilitare il tasto di refresh. (Ereditato da EditAnagrCommandBase)
Proprietà pubblica | RefreshButtonTooltip | Imposta/Restituisce il tooltip del tasto di refresh. (Ereditato da EditAnagrCommandBase)
Proprietà pubblica | RefreshButtonVisible | Imposta/Restituisce se visualizzare il tasto di refresh. (Ereditato da EditAnagrCommandBase)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SparePartsManagement | Indica se il dialogo deve gestire gli attributi di ricambio o meno.
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Proprietà pubblica | ValidateAttr | Indica se validare gli attributi. (Ereditato da EditAnagrCommandBase)
Proprietà pubblica | WindowTitle | Restituisce o imposta il titolo della finestra di dialogo. (Ereditato da EditAnagrCommandBase)
Torna su
Vedi anche

Documentazione

Classe EditAnagrCommand
Namespace DedNet.Commands


Proprietà EditAnagrCommand.ExecuteFromBomControl

Proprietà EditAnagrCommandExecuteFromBomControl
Indica se il comando è stato eseguito da un contesto di distinta o meno.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ExecuteFromBomControl { get; set; }
Public Property ExecuteFromBomControl As Boolean
    Get
    Set
public:
property bool ExecuteFromBomControl {
    bool get ();
    void set (bool value);
}
member ExecuteFromBomControl : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe EditAnagrCommand
Namespace DedNet.Commands


Proprietà EditAnagrCommand.NewAttrEditingManagement

Proprietà EditAnagrCommandNewAttrEditingManagement
Indica se il utilizzare la nuova gestione per l'editazione degli attributi.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool NewAttrEditingManagement { get; set; }
Public Property NewAttrEditingManagement As Boolean
    Get
    Set
public:
property bool NewAttrEditingManagement {
    bool get ();
    void set (bool value);
}
member NewAttrEditingManagement : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe EditAnagrCommand
Namespace DedNet.Commands


Proprietà EditAnagrCommand.OnlyDbAttrManagement

Proprietà EditAnagrCommandOnlyDbAttrManagement
Indica se il dialogo deve gestire gli attributi di ricambio o meno.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool OnlyDbAttrManagement { get; set; }
Public Property OnlyDbAttrManagement As Boolean
    Get
    Set
public:
property bool OnlyDbAttrManagement {
    bool get ();
    void set (bool value);
}
member OnlyDbAttrManagement : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe EditAnagrCommand
Namespace DedNet.Commands


Proprietà EditAnagrCommand.SparePartsManagement

Proprietà EditAnagrCommandSparePartsManagement
Indica se il dialogo deve gestire gli attributi di ricambio o meno.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool SparePartsManagement { get; set; }
Public Property SparePartsManagement As Boolean
    Get
    Set
public:
property bool SparePartsManagement {
    bool get ();
    void set (bool value);
}
member SparePartsManagement : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe EditAnagrCommand
Namespace DedNet.Commands


Metodi di EditAnagrCommand

Il tipo EditAnagrCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Ereditato da EditAnagrCommandBase)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Ereditato da EditAnagrCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Ereditato da EditAnagrCommandBase)
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe EditAnagrCommand
Namespace DedNet.Commands


Metodo EditAnagrCommand.ExecuteCommand

Metodo EditAnagrCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe EditAnagrCommand
Namespace DedNet.Commands


Classe EditAnagrCommandBase
Classe base per i comandi di visualizza/edita attributi.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsEditAnagrCommandBase
DedNet.CommandsEditAnagrCommand
DedNet.CommandsShowAnagrCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public abstract class EditAnagrCommandBase : DedCommand
Public MustInherit Class EditAnagrCommandBase
    Inherits DedCommand
public ref class EditAnagrCommandBase abstract : public DedCommand
[<AbstractClassAttribute>]
type EditAnagrCommandBase =
    class
        inherit DedCommand
    end

Il tipo EditAnagrCommandBase espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | ApplyRule | Imposta / Restiruisce se aplpicare le regole.
Proprietà pubblica | AttrList | Restituisce la lista che viene utilizzata dal comando.
Proprietà pubblica | BtnRefreshClick | Imposta/Restituisce l'evento chiamato sul click del puldante di Refresh.
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DataInfos | Restituisce la lista delle anagrafiche di elaborazione comando.
Proprietà pubblica | DisableEditingForOnlyDbAttrs | Indica se abilitare o meno l'editazione per gli attributi marchiati come "Solo Db".
Proprietà pubblica | EnableDedContextMenu | Indica se abilitare il menu contestuale con i comandi del DED.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnorePerm | Indica se ignorare il controllo sui permessi.
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | IsInDb | Restituisce o imposta se le anagrafiche siano o meno da considerarsi nel Database.
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | LockAnagr | Indica se effettuare il lock dell'anagrafica. Di defualt è True.
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Il comando necessita di almeno una IDedData nella lista. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | RefreshButtonEnabled | Imposta/Restituisce se abilitare il tasto di refresh.
Proprietà pubblica | RefreshButtonTooltip | Imposta/Restituisce il tooltip del tasto di refresh.
Proprietà pubblica | RefreshButtonVisible | Imposta/Restituisce se visualizzare il tasto di refresh.
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Proprietà pubblica | ValidateAttr | Indica se validare gli attributi.
Proprietà pubblica | WindowTitle | Restituisce o imposta il titolo della finestra di dialogo.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. Da fare l'override nelle classi derivate. (Ereditato da DedCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di EditAnagrCommandBase

Il tipo EditAnagrCommandBase espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | ApplyRule | Imposta / Restiruisce se aplpicare le regole.
Proprietà pubblica | AttrList | Restituisce la lista che viene utilizzata dal comando.
Proprietà pubblica | BtnRefreshClick | Imposta/Restituisce l'evento chiamato sul click del puldante di Refresh.
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DataInfos | Restituisce la lista delle anagrafiche di elaborazione comando.
Proprietà pubblica | DisableEditingForOnlyDbAttrs | Indica se abilitare o meno l'editazione per gli attributi marchiati come "Solo Db".
Proprietà pubblica | EnableDedContextMenu | Indica se abilitare il menu contestuale con i comandi del DED.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnorePerm | Indica se ignorare il controllo sui permessi.
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | IsInDb | Restituisce o imposta se le anagrafiche siano o meno da considerarsi nel Database.
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | LockAnagr | Indica se effettuare il lock dell'anagrafica. Di defualt è True.
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Il comando necessita di almeno una IDedData nella lista. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | RefreshButtonEnabled | Imposta/Restituisce se abilitare il tasto di refresh.
Proprietà pubblica | RefreshButtonTooltip | Imposta/Restituisce il tooltip del tasto di refresh.
Proprietà pubblica | RefreshButtonVisible | Imposta/Restituisce se visualizzare il tasto di refresh.
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Proprietà pubblica | ValidateAttr | Indica se validare gli attributi.
Proprietà pubblica | WindowTitle | Restituisce o imposta il titolo della finestra di dialogo.
Torna su
Vedi anche

Documentazione

Classe EditAnagrCommandBase
Namespace DedNet.Commands


Proprietà EditAnagrCommandBase.ApplyRule

Proprietà EditAnagrCommandBaseApplyRule
Imposta / Restiruisce se aplpicare le regole.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ApplyRule { get; set; }
Public Property ApplyRule As Boolean
    Get
    Set
public:
property bool ApplyRule {
    bool get ();
    void set (bool value);
}
member ApplyRule : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe EditAnagrCommandBase
Namespace DedNet.Commands


Proprietà EditAnagrCommandBase.AttrList

Proprietà EditAnagrCommandBaseAttrList
Restituisce la lista che viene utilizzata dal comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList AttrList { get; }
Public ReadOnly Property AttrList As DedAttrList
    Get
public:
property DedAttrList^ AttrList {
    DedAttrList^ get ();
}
member AttrList : DedAttrList with get

Valore della proprietà

DedAttrList
Vedi anche

Documentazione

Classe EditAnagrCommandBase
Namespace DedNet.Commands


Proprietà EditAnagrCommandBase.BtnRefreshClick

Proprietà EditAnagrCommandBaseBtnRefreshClick
Imposta/Restituisce l'evento chiamato sul click del puldante di Refresh.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public EventHandler BtnRefreshClick { get; set; }
Public Property BtnRefreshClick As EventHandler
    Get
    Set
public:
property EventHandler^ BtnRefreshClick {
    EventHandler^ get ();
    void set (EventHandler^ value);
}
member BtnRefreshClick : EventHandler with get, set

Valore della proprietà

EventHandler
Vedi anche

Documentazione

Classe EditAnagrCommandBase
Namespace DedNet.Commands


Proprietà EditAnagrCommandBase.DataInfos

Proprietà EditAnagrCommandBaseDataInfos
Restituisce la lista delle anagrafiche di elaborazione comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataPartList DataInfos { get; }
Public ReadOnly Property DataInfos As DedDataPartList
    Get
public:
property DedDataPartList^ DataInfos {
    DedDataPartList^ get ();
}
member DataInfos : DedDataPartList with get

Valore della proprietà

DedDataPartList
Vedi anche

Documentazione

Classe EditAnagrCommandBase
Namespace DedNet.Commands


Proprietà EditAnagrCommandBase.DisableEditingForOnlyDbAttrs

Proprietà EditAnagrCommandBaseDisableEditingForOnlyDbAttrs
Indica se abilitare o meno l'editazione per gli attributi marchiati come "Solo Db".

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool DisableEditingForOnlyDbAttrs { get; set; }
Public Property DisableEditingForOnlyDbAttrs As Boolean
    Get
    Set
public:
property bool DisableEditingForOnlyDbAttrs {
    bool get ();
    void set (bool value);
}
member DisableEditingForOnlyDbAttrs : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe EditAnagrCommandBase
Namespace DedNet.Commands


Proprietà EditAnagrCommandBase.EnableDedContextMenu

Proprietà EditAnagrCommandBaseEnableDedContextMenu
Indica se abilitare il menu contestuale con i comandi del DED.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool EnableDedContextMenu { get; set; }
Public Property EnableDedContextMenu As Boolean
    Get
    Set
public:
property bool EnableDedContextMenu {
    bool get ();
    void set (bool value);
}
member EnableDedContextMenu : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe EditAnagrCommandBase
Namespace DedNet.Commands


Proprietà EditAnagrCommandBase.IgnorePerm

Proprietà EditAnagrCommandBaseIgnorePerm
Indica se ignorare il controllo sui permessi.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IgnorePerm { get; set; }
Public Property IgnorePerm As Boolean
    Get
    Set
public:
property bool IgnorePerm {
    bool get ();
    void set (bool value);
}
member IgnorePerm : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe EditAnagrCommandBase
Namespace DedNet.Commands


Proprietà EditAnagrCommandBase.IsInDb

Proprietà EditAnagrCommandBaseIsInDb
Restituisce o imposta se le anagrafiche siano o meno da considerarsi nel Database.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsInDb { get; set; }
Public Property IsInDb As Boolean
    Get
    Set
public:
property bool IsInDb {
    bool get ();
    void set (bool value);
}
member IsInDb : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe EditAnagrCommandBase
Namespace DedNet.Commands


Proprietà EditAnagrCommandBase.LockAnagr

Proprietà EditAnagrCommandBaseLockAnagr
Indica se effettuare il lock dell'anagrafica. Di defualt è True.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool LockAnagr { get; set; }
Public Property LockAnagr As Boolean
    Get
    Set
public:
property bool LockAnagr {
    bool get ();
    void set (bool value);
}
member LockAnagr : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe EditAnagrCommandBase
Namespace DedNet.Commands


Proprietà EditAnagrCommandBase.NeedParameters

Proprietà EditAnagrCommandBaseNeedParameters
Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Il comando necessita di almeno una IDedData nella lista.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe EditAnagrCommandBase
Namespace DedNet.Commands


Proprietà EditAnagrCommandBase.RefreshButtonEnabled

Proprietà EditAnagrCommandBaseRefreshButtonEnabled
Imposta/Restituisce se abilitare il tasto di refresh.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool RefreshButtonEnabled { get; set; }
Public Property RefreshButtonEnabled As Boolean
    Get
    Set
public:
property bool RefreshButtonEnabled {
    bool get ();
    void set (bool value);
}
member RefreshButtonEnabled : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe EditAnagrCommandBase
Namespace DedNet.Commands


Proprietà EditAnagrCommandBase.RefreshButtonTooltip

Proprietà EditAnagrCommandBaseRefreshButtonTooltip
Imposta/Restituisce il tooltip del tasto di refresh.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string RefreshButtonTooltip { get; set; }
Public Property RefreshButtonTooltip As String
    Get
    Set
public:
property String^ RefreshButtonTooltip {
    String^ get ();
    void set (String^ value);
}
member RefreshButtonTooltip : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe EditAnagrCommandBase
Namespace DedNet.Commands


Proprietà EditAnagrCommandBase.RefreshButtonVisible

Proprietà EditAnagrCommandBaseRefreshButtonVisible
Imposta/Restituisce se visualizzare il tasto di refresh.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool RefreshButtonVisible { get; set; }
Public Property RefreshButtonVisible As Boolean
    Get
    Set
public:
property bool RefreshButtonVisible {
    bool get ();
    void set (bool value);
}
member RefreshButtonVisible : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe EditAnagrCommandBase
Namespace DedNet.Commands


Proprietà EditAnagrCommandBase.ValidateAttr

Proprietà EditAnagrCommandBaseValidateAttr
Indica se validare gli attributi.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ValidateAttr { get; set; }
Public Property ValidateAttr As Boolean
    Get
    Set
public:
property bool ValidateAttr {
    bool get ();
    void set (bool value);
}
member ValidateAttr : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe EditAnagrCommandBase
Namespace DedNet.Commands


Proprietà EditAnagrCommandBase.WindowTitle

Proprietà EditAnagrCommandBaseWindowTitle
Restituisce o imposta il titolo della finestra di dialogo.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string WindowTitle { get; set; }
Public Property WindowTitle As String
    Get
    Set
public:
property String^ WindowTitle {
    String^ get ();
    void set (String^ value);
}
member WindowTitle : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe EditAnagrCommandBase
Namespace DedNet.Commands


Metodi di EditAnagrCommandBase

Il tipo EditAnagrCommandBase espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. Da fare l'override nelle classi derivate. (Ereditato da DedCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe EditAnagrCommandBase
Namespace DedNet.Commands


Metodo EditAnagrCommandBase.ClearCommand

Metodo EditAnagrCommandBaseClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe EditAnagrCommandBase
Namespace DedNet.Commands


Metodo EditAnagrCommandBase.Enabled

Metodo EditAnagrCommandBaseEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe EditAnagrCommandBase
Namespace DedNet.Commands


Metodo EditAnagrCommandBase.SetContext

Metodo EditAnagrCommandBaseSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe EditAnagrCommandBase
Namespace DedNet.Commands


Classe EditCommCommand
Comando editazione di una commessa.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsEditCommCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class EditCommCommand : DedCommand
Public Class EditCommCommand
    Inherits DedCommand
public ref class EditCommCommand : public DedCommand
type EditCommCommand =
    class
        inherit DedCommand
    end

Il tipo EditCommCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | ApplyRule | Permette di decidere se applicare o meno le regole di autocomposizione (quando lanciato da script).
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Comm | Commessa da modificare.
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommData | Restituisce il dizionario utilizzato dal Form per la modifica della commessa. Inizialmente è null, ed è impostato al runtime dal comando durante l'elaborazione, leggendo i dati dalla commessa da modificare.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se la commessa da modificare non è disponibile. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Metodo pubblico | UpdateData | Ricalcola i campi presenti nell'anagrafica temporanea in base ai valori presenti nelle info. Chiama l'evento di personalizzazione e poi li ricalcola in modo che se l'evento ha modificato le info si riflettano i valori nell'anagrafica.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di EditCommCommand

Il tipo EditCommCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | ApplyRule | Permette di decidere se applicare o meno le regole di autocomposizione (quando lanciato da script).
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Comm | Commessa da modificare.
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommData | Restituisce il dizionario utilizzato dal Form per la modifica della commessa. Inizialmente è null, ed è impostato al runtime dal comando durante l'elaborazione, leggendo i dati dalla commessa da modificare.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se la commessa da modificare non è disponibile. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe EditCommCommand
Namespace DedNet.Commands


Proprietà EditCommCommand.ApplyRule

Proprietà EditCommCommandApplyRule
Permette di decidere se applicare o meno le regole di autocomposizione (quando lanciato da script).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ApplyRule { set; }
Public WriteOnly Property ApplyRule As Boolean
    Set
public:
property bool ApplyRule {
    void set (bool value);
}
member ApplyRule : bool with set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe EditCommCommand
Namespace DedNet.Commands


Proprietà EditCommCommand.Comm

Proprietà EditCommCommandComm
Commessa da modificare.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedComm Comm { get; set; }
Public Property Comm As DedComm
    Get
    Set
public:
property DedComm^ Comm {
    DedComm^ get ();
    void set (DedComm^ value);
}
member Comm : DedComm with get, set

Valore della proprietà

DedComm
Vedi anche

Documentazione

Classe EditCommCommand
Namespace DedNet.Commands


Proprietà EditCommCommand.CommData

Proprietà EditCommCommandCommData
Restituisce il dizionario utilizzato dal Form per la modifica della commessa. Inizialmente è null, ed è impostato al runtime dal comando durante l'elaborazione, leggendo i dati dalla commessa da modificare.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDictionary CommData { get; }
Public ReadOnly Property CommData As DedDictionary
    Get
public:
property DedDictionary^ CommData {
    DedDictionary^ get ();
}
member CommData : DedDictionary with get

Valore della proprietà

DedDictionary
Vedi anche

Documentazione

Classe EditCommCommand
Namespace DedNet.Commands


Proprietà EditCommCommand.NeedParameters

Proprietà EditCommCommandNeedParameters
Restituisce true se la commessa da modificare non è disponibile.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe EditCommCommand
Namespace DedNet.Commands


Metodi di EditCommCommand

Il tipo EditCommCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Metodo pubblico | UpdateData | Ricalcola i campi presenti nell'anagrafica temporanea in base ai valori presenti nelle info. Chiama l'evento di personalizzazione e poi li ricalcola in modo che se l'evento ha modificato le info si riflettano i valori nell'anagrafica.
Torna su
Vedi anche

Documentazione

Classe EditCommCommand
Namespace DedNet.Commands


Metodo EditCommCommand.ClearCommand

Metodo EditCommCommandClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe EditCommCommand
Namespace DedNet.Commands


Metodo EditCommCommand.Enabled

Metodo EditCommCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe EditCommCommand
Namespace DedNet.Commands


Metodo EditCommCommand.ExecuteCommand

Metodo EditCommCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe EditCommCommand
Namespace DedNet.Commands


Metodo EditCommCommand.SetContext

Metodo EditCommCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto c'è una sola anagrafica alla quale associare il file.
Vedi anche

Documentazione

Classe EditCommCommand
Namespace DedNet.Commands


Metodo EditCommCommand.UpdateData

Metodo EditCommCommandUpdateData
Ricalcola i campi presenti nell'anagrafica temporanea in base ai valori presenti nelle info. Chiama l'evento di personalizzazione e poi li ricalcola in modo che se l'evento ha modificato le info si riflettano i valori nell'anagrafica.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void UpdateData()
Public Sub UpdateData
public:
void UpdateData()
member UpdateData : unit -> unit
Vedi anche

Documentazione

Classe EditCommCommand
Namespace DedNet.Commands


Classe EditEcoCommand
Comando usato per creare/editare gli ECO.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsEditEcoCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class EditEcoCommand : DedCommand
Public Class EditEcoCommand
    Inherits DedCommand
public ref class EditEcoCommand : public DedCommand
type EditEcoCommand =
    class
        inherit DedCommand
    end

Il tipo EditEcoCommand espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | EditEcoCommand | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve essere impostata la struttura di salvataggio distinta. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Eseguo il comando. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Imposto il contesto per l'esecuzione del comando (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Costruttore EditEcoCommand
Costruttore unico.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public EditEcoCommand(
    DedNetApplication app,
    string internalName,
    string name
)
Public Sub New (
    app As DedNetApplication,
    internalName As String,
    name As String
)
public:
EditEcoCommand(
    DedNetApplication^ app,
    String^ internalName,
    String^ name
)
new :
        app : DedNetApplication *
        internalName : string *
        name : string -> EditEcoCommand

Parametri

app DedNetApplication
Riferimento all'oggetto DedNetApplication.
internalName String
Nome interno del comando.
name String
Nome visualizzato del comando.
Vedi anche

Documentazione

Classe EditEcoCommand
Namespace DedNet.Commands


Proprietà di EditEcoCommand

Il tipo EditEcoCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve essere impostata la struttura di salvataggio distinta. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe EditEcoCommand
Namespace DedNet.Commands


Proprietà EditEcoCommand.NeedParameters

Proprietà EditEcoCommandNeedParameters
Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve essere impostata la struttura di salvataggio distinta.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe EditEcoCommand
Namespace DedNet.Commands


Metodi di EditEcoCommand

Il tipo EditEcoCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Eseguo il comando. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Imposto il contesto per l'esecuzione del comando (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe EditEcoCommand
Namespace DedNet.Commands


Metodo EditEcoCommand.ClearCommand

Metodo EditEcoCommandClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe EditEcoCommand
Namespace DedNet.Commands


Metodo EditEcoCommand.Enabled

Metodo EditEcoCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe EditEcoCommand
Namespace DedNet.Commands


Metodo EditEcoCommand.ExecuteCommand

Metodo EditEcoCommandExecuteCommand
Eseguo il comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe EditEcoCommand
Namespace DedNet.Commands


Metodo EditEcoCommand.SetContext

Metodo EditEcoCommandSetContext
Imposto il contesto per l'esecuzione del comando

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe EditEcoCommand
Namespace DedNet.Commands


Classe EditOnlyDbAttributesCommand
Comando utilizzato per editare gli attributi di ricambio di un set di anagrafiche.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsEditOnlyDbAttributesCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class EditOnlyDbAttributesCommand : DedCommand
Public Class EditOnlyDbAttributesCommand
    Inherits DedCommand
public ref class EditOnlyDbAttributesCommand : public DedCommand
type EditOnlyDbAttributesCommand =
    class
        inherit DedCommand
    end

Il tipo EditOnlyDbAttributesCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Data | Anagrafiche di cui si vuole editare gli attributi di ricambio.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve essere impostata la struttura di salvataggio distinta. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Esegue la pulizia del comando. Azzera tutte le variabili. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). Restituisce sempre false perché non è direttamente chiamato dall'utente. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Restituisce sempre false perché non è direttamente chiamato dall'utente. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di EditOnlyDbAttributesCommand

Il tipo EditOnlyDbAttributesCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Data | Anagrafiche di cui si vuole editare gli attributi di ricambio.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve essere impostata la struttura di salvataggio distinta. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe EditOnlyDbAttributesCommand
Namespace DedNet.Commands


Proprietà EditOnlyDbAttributesCommand.Data

Proprietà EditOnlyDbAttributesCommandData
Anagrafiche di cui si vuole editare gli attributi di ricambio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataList Data { get; set; }
Public Property Data As DedDataList
    Get
    Set
public:
property DedDataList^ Data {
    DedDataList^ get ();
    void set (DedDataList^ value);
}
member Data : DedDataList with get, set

Valore della proprietà

DedDataList
Vedi anche

Documentazione

Classe EditOnlyDbAttributesCommand
Namespace DedNet.Commands


Proprietà EditOnlyDbAttributesCommand.NeedParameters

Proprietà EditOnlyDbAttributesCommandNeedParameters
Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve essere impostata la struttura di salvataggio distinta.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe EditOnlyDbAttributesCommand
Namespace DedNet.Commands


Metodi di EditOnlyDbAttributesCommand

Il tipo EditOnlyDbAttributesCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Esegue la pulizia del comando. Azzera tutte le variabili. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). Restituisce sempre false perché non è direttamente chiamato dall'utente. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Restituisce sempre false perché non è direttamente chiamato dall'utente. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe EditOnlyDbAttributesCommand
Namespace DedNet.Commands


Metodo EditOnlyDbAttributesCommand.ClearCommand

Metodo EditOnlyDbAttributesCommandClearCommand
Esegue la pulizia del comando. Azzera tutte le variabili.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe EditOnlyDbAttributesCommand
Namespace DedNet.Commands


Metodo EditOnlyDbAttributesCommand.Enabled

Metodo EditOnlyDbAttributesCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). Restituisce sempre false perché non è direttamente chiamato dall'utente.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext commandContext
)
Public Overrides Function Enabled (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ commandContext
) override
abstract Enabled :
        commandContext : DedCommandContext -> bool
override Enabled :
        commandContext : DedCommandContext -> bool

Parametri

commandContext DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe EditOnlyDbAttributesCommand
Namespace DedNet.Commands


Metodo EditOnlyDbAttributesCommand.ExecuteCommand

Metodo EditOnlyDbAttributesCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe EditOnlyDbAttributesCommand
Namespace DedNet.Commands


Metodo EditOnlyDbAttributesCommand.SetContext

Metodo EditOnlyDbAttributesCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Restituisce sempre false perché non è direttamente chiamato dall'utente.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext commandContext
)
Public Overrides Function SetContext (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ commandContext
) override
abstract SetContext :
        commandContext : DedCommandContext -> bool
override SetContext :
        commandContext : DedCommandContext -> bool

Parametri

commandContext DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe EditOnlyDbAttributesCommand
Namespace DedNet.Commands


Classe EndAllActiveTimingsCommand
Comando utilizzato per interrompere tutte le temporizzazioni attive associate all'utente corrente.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsEndAllActiveTimingsCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class EndAllActiveTimingsCommand : DedCommand
Public Class EndAllActiveTimingsCommand
    Inherits DedCommand
public ref class EndAllActiveTimingsCommand : public DedCommand
type EndAllActiveTimingsCommand =
    class
        inherit DedCommand
    end

Il tipo EndAllActiveTimingsCommand espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | EndAllActiveTimingsCommand | Crea una nuova istanza della classe 'EndAllTimingsCommand' utilizzata per interrompere tutte le temporizzazioni attive associate all'utente corrente.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Inidica se il comando necessita di parametri. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulizia del comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Abilitazione dal contesto. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esecuzione del comando. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Settaggio del contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Costruttore EndAllActiveTimingsCommand
Crea una nuova istanza della classe 'EndAllTimingsCommand' utilizzata per interrompere tutte le temporizzazioni attive associate all'utente corrente.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public EndAllActiveTimingsCommand(
    DedNetApplication app,
    string internalName,
    string name
)
Public Sub New (
    app As DedNetApplication,
    internalName As String,
    name As String
)
public:
EndAllActiveTimingsCommand(
    DedNetApplication^ app,
    String^ internalName,
    String^ name
)
new :
        app : DedNetApplication *
        internalName : string *
        name : string -> EndAllActiveTimingsCommand

Parametri

app DedNetApplication
Applicazione DedNet.
internalName String
Nome interno del comando.
name String
Nome visualizzato del comando.
Vedi anche

Documentazione

Classe EndAllActiveTimingsCommand
Namespace DedNet.Commands


Proprietà di EndAllActiveTimingsCommand

Il tipo EndAllActiveTimingsCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Inidica se il comando necessita di parametri. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe EndAllActiveTimingsCommand
Namespace DedNet.Commands


Proprietà EndAllActiveTimingsCommand.NeedParameters

Proprietà EndAllActiveTimingsCommandNeedParameters
Inidica se il comando necessita di parametri.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe EndAllActiveTimingsCommand
Namespace DedNet.Commands


Metodi di EndAllActiveTimingsCommand

Il tipo EndAllActiveTimingsCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulizia del comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Abilitazione dal contesto. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esecuzione del comando. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Settaggio del contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe EndAllActiveTimingsCommand
Namespace DedNet.Commands


Metodo EndAllActiveTimingsCommand.ClearCommand

Metodo EndAllActiveTimingsCommandClearCommand
Pulizia del comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe EndAllActiveTimingsCommand
Namespace DedNet.Commands


Metodo EndAllActiveTimingsCommand.Enabled

Metodo EndAllActiveTimingsCommandEnabled
Abilitazione dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe EndAllActiveTimingsCommand
Namespace DedNet.Commands


Metodo EndAllActiveTimingsCommand.ExecuteCommand

Metodo EndAllActiveTimingsCommandExecuteCommand
Esecuzione del comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe EndAllActiveTimingsCommand
Namespace DedNet.Commands


Metodo EndAllActiveTimingsCommand.SetContext

Metodo EndAllActiveTimingsCommandSetContext
Settaggio del contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe EndAllActiveTimingsCommand
Namespace DedNet.Commands


Classe EndTimingCommand
Comando utilizzato per interrompere una temporizzazione su una anagrafica, commessa, ECO, ecc..
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsTimingCommand
DedNet.CommandsEndTimingCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class EndTimingCommand : TimingCommand
Public Class EndTimingCommand
    Inherits TimingCommand
public ref class EndTimingCommand : public TimingCommand
type EndTimingCommand =
    class
        inherit TimingCommand
    end

Il tipo EndTimingCommand espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | EndTimingCommand | Crea una nuova istanza della classe 'StartTimingCommand' utilizzata per interrompere una temporizzazione su una anagrafica, commessa, eco, ecc..
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Inidica se il comando necessita di parametri. (Ereditato da TimingCommand)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Parent | Oggetto su cui si vuole avviare/interrompere la temporizzazione.
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulizia del comando. (Ereditato da TimingCommand)
Metodo pubblico | Enabled | Abilitazione dal contesto. (Sovrascrive TimingCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esecuzione del comando. (Ereditato da TimingCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Settaggio del contesto. (Ereditato da TimingCommand)
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Costruttore EndTimingCommand
Crea una nuova istanza della classe 'StartTimingCommand' utilizzata per interrompere una temporizzazione su una anagrafica, commessa, eco, ecc..

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public EndTimingCommand(
    DedNetApplication app,
    string internalName,
    string name
)
Public Sub New (
    app As DedNetApplication,
    internalName As String,
    name As String
)
public:
EndTimingCommand(
    DedNetApplication^ app,
    String^ internalName,
    String^ name
)
new :
        app : DedNetApplication *
        internalName : string *
        name : string -> EndTimingCommand

Parametri

app DedNetApplication
Applicazione DedNet.
internalName String
Nome interno del comando.
name String
Nome visualizzato del comando.
Vedi anche

Documentazione

Classe EndTimingCommand
Namespace DedNet.Commands


Proprietà di EndTimingCommand

Il tipo EndTimingCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Inidica se il comando necessita di parametri. (Ereditato da TimingCommand)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Parent | Oggetto su cui si vuole avviare/interrompere la temporizzazione.
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe EndTimingCommand
Namespace DedNet.Commands


Proprietà EndTimingCommand.Parent

Proprietà EndTimingCommandParent
Oggetto su cui si vuole avviare/interrompere la temporizzazione.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTimedDbItem Parent { get; set; }
Public Property Parent As DedTimedDbItem
    Get
    Set
public:
property DedTimedDbItem^ Parent {
    DedTimedDbItem^ get ();
    void set (DedTimedDbItem^ value);
}
member Parent : DedTimedDbItem with get, set

Valore della proprietà

DedTimedDbItem
Vedi anche

Documentazione

Classe EndTimingCommand
Namespace DedNet.Commands


Metodi di EndTimingCommand

Il tipo EndTimingCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulizia del comando. (Ereditato da TimingCommand)
Metodo pubblico | Enabled | Abilitazione dal contesto. (Sovrascrive TimingCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esecuzione del comando. (Ereditato da TimingCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Settaggio del contesto. (Ereditato da TimingCommand)
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe EndTimingCommand
Namespace DedNet.Commands


Metodo EndTimingCommand.Enabled

Metodo EndTimingCommandEnabled
Abilitazione dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe EndTimingCommand
Namespace DedNet.Commands


Classe EnsureLocalDocument
Permette di assicurarsi che un documento e tutte le sue dipendenze siano disponibili nell'area locale. Quando un documento è già presente nell'area locale confronta la versione scaricata con quella attualmente presente sul server. Se la versione in locale non è da aggiornare non copia il file, altrimenti chiede conferma all'utente e copia sovrascrivendo.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsEnsureLocalDocument

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class EnsureLocalDocument : DedCommand
Public Class EnsureLocalDocument
    Inherits DedCommand
public ref class EnsureLocalDocument : public DedCommand
type EnsureLocalDocument =
    class
        inherit DedCommand
    end

Il tipo EnsureLocalDocument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | EnforceFileCopy | Restituisce o imposta se il documento deve essere copiato nell'area locale indipendentemente dall'allineamento del ROWVER. E' utile durante le oerazioni di sblocca e annulla all'interno del client.
Proprietà pubblica | FileList | Restituisce la lista dei file dei quali si deve assicurare la presenza nell'area locale. Inserire in questa lista solo i file che si desidera elaborare e non le dipendenze.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non sono presenti documenti da elaborare. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | ReadOnly | ATTENZIONE! Deprecata. La proprietà non è più usata perchè il sola lettura viene calcolato in base allo stato del documento. Viene lasciata per la compatibilità di chiamata da script.
Proprietà pubblica | ReferenceNotFoundExceptionList | Lista di eccezioni riservata ai riferimenti mancanti
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce sempre false in quanto si tratta di un sotto-comando. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Restituisce sempre false in quanto si tratta di un sotto-comando. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di EnsureLocalDocument

Il tipo EnsureLocalDocument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | EnforceFileCopy | Restituisce o imposta se il documento deve essere copiato nell'area locale indipendentemente dall'allineamento del ROWVER. E' utile durante le oerazioni di sblocca e annulla all'interno del client.
Proprietà pubblica | FileList | Restituisce la lista dei file dei quali si deve assicurare la presenza nell'area locale. Inserire in questa lista solo i file che si desidera elaborare e non le dipendenze.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non sono presenti documenti da elaborare. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | ReadOnly | ATTENZIONE! Deprecata. La proprietà non è più usata perchè il sola lettura viene calcolato in base allo stato del documento. Viene lasciata per la compatibilità di chiamata da script.
Proprietà pubblica | ReferenceNotFoundExceptionList | Lista di eccezioni riservata ai riferimenti mancanti
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe EnsureLocalDocument
Namespace DedNet.Commands


Proprietà EnsureLocalDocument.EnforceFileCopy

Proprietà EnsureLocalDocumentEnforceFileCopy
Restituisce o imposta se il documento deve essere copiato nell'area locale indipendentemente dall'allineamento del ROWVER. E' utile durante le oerazioni di sblocca e annulla all'interno del client.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool EnforceFileCopy { get; set; }
Public Property EnforceFileCopy As Boolean
    Get
    Set
public:
property bool EnforceFileCopy {
    bool get ();
    void set (bool value);
}
member EnforceFileCopy : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe EnsureLocalDocument
Namespace DedNet.Commands


Proprietà EnsureLocalDocument.FileList

Proprietà EnsureLocalDocumentFileList
Restituisce la lista dei file dei quali si deve assicurare la presenza nell'area locale. Inserire in questa lista solo i file che si desidera elaborare e non le dipendenze.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfoList FileList { get; }
Public ReadOnly Property FileList As DocStructInfoList
    Get
public:
property DocStructInfoList^ FileList {
    DocStructInfoList^ get ();
}
member FileList : DocStructInfoList with get

Valore della proprietà

DocStructInfoList
Vedi anche

Documentazione

Classe EnsureLocalDocument
Namespace DedNet.Commands


Proprietà EnsureLocalDocument.NeedParameters

Proprietà EnsureLocalDocumentNeedParameters
Restituisce true se non sono presenti documenti da elaborare.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe EnsureLocalDocument
Namespace DedNet.Commands


Proprietà EnsureLocalDocument.ReadOnly

Proprietà EnsureLocalDocumentReadOnly
ATTENZIONE! Deprecata. La proprietà non è più usata perchè il sola lettura viene calcolato in base allo stato del documento. Viene lasciata per la compatibilità di chiamata da script.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ReadOnly { get; set; }
Public Property ReadOnly As Boolean
    Get
    Set
public:
property bool ReadOnly {
    bool get ();
    void set (bool value);
}
member ReadOnly : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe EnsureLocalDocument
Namespace DedNet.Commands


Proprietà EnsureLocalDocument.ReferenceNotFoundExceptionList

Proprietà EnsureLocalDocumentReferenceNotFoundExceptionList
Lista di eccezioni riservata ai riferimenti mancanti

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<Exception> ReferenceNotFoundExceptionList { get; set; }
Public Property ReferenceNotFoundExceptionList As List(Of Exception)
    Get
    Set
public:
property List<Exception^>^ ReferenceNotFoundExceptionList {
    List<Exception^>^ get ();
    void set (List<Exception^>^ value);
}
member ReferenceNotFoundExceptionList : List<Exception> with get, set

Valore della proprietà

List Exception
Vedi anche

Documentazione

Classe EnsureLocalDocument
Namespace DedNet.Commands


Metodi di EnsureLocalDocument

Il tipo EnsureLocalDocument espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce sempre false in quanto si tratta di un sotto-comando. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Restituisce sempre false in quanto si tratta di un sotto-comando. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe EnsureLocalDocument
Namespace DedNet.Commands


Metodo EnsureLocalDocument.ClearCommand

Metodo EnsureLocalDocumentClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe EnsureLocalDocument
Namespace DedNet.Commands


Metodo EnsureLocalDocument.Enabled

Metodo EnsureLocalDocumentEnabled
Restituisce sempre false in quanto si tratta di un sotto-comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe EnsureLocalDocument
Namespace DedNet.Commands


Metodo EnsureLocalDocument.ExecuteCommand

Metodo EnsureLocalDocumentExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe EnsureLocalDocument
Namespace DedNet.Commands


Metodo EnsureLocalDocument.SetContext

Metodo EnsureLocalDocumentSetContext
Restituisce sempre false in quanto si tratta di un sotto-comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto c'è una sola anagrafica alla quale associare il file.
Vedi anche

Documentazione

Classe EnsureLocalDocument
Namespace DedNet.Commands


Classe EnsureLocalFolder
Permette di assicurarsi che un documento e tutte le sue dipendenze siano disponibili nell'area locale. Quando un documento è già presente nell'area locale confronta la versione scaricata con quella attualmente presente sul server. Se la versione in locale non è da aggiornare non copia il file, altrimenti chiede conferma all'utente e copia sovrascrivendo.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsEnsureLocalFolder

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class EnsureLocalFolder : DedCommand
Public Class EnsureLocalFolder
    Inherits DedCommand
public ref class EnsureLocalFolder : public DedCommand
type EnsureLocalFolder =
    class
        inherit DedCommand
    end

Il tipo EnsureLocalFolder espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllStructure | Indica se scaricare in locale tutta la struttura o solo la cartella singola.
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | FolderList | Restituisce la lista delle cartelle dei quali si deve assicurare la presenza nell'area locale.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non sono presenti documenti da elaborare. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OnlyFolderStructure |
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce sempre false in quanto si tratta di un sotto-comando. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Restituisce sempre false in quanto si tratta di un sotto-comando. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di EnsureLocalFolder

Il tipo EnsureLocalFolder espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllStructure | Indica se scaricare in locale tutta la struttura o solo la cartella singola.
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | FolderList | Restituisce la lista delle cartelle dei quali si deve assicurare la presenza nell'area locale.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non sono presenti documenti da elaborare. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OnlyFolderStructure |
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe EnsureLocalFolder
Namespace DedNet.Commands


Proprietà EnsureLocalFolder.AllStructure

Proprietà EnsureLocalFolderAllStructure
Indica se scaricare in locale tutta la struttura o solo la cartella singola.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AllStructure { get; set; }
Public Property AllStructure As Boolean
    Get
    Set
public:
property bool AllStructure {
    bool get ();
    void set (bool value);
}
member AllStructure : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe EnsureLocalFolder
Namespace DedNet.Commands


Proprietà EnsureLocalFolder.FolderList

Proprietà EnsureLocalFolderFolderList
Restituisce la lista delle cartelle dei quali si deve assicurare la presenza nell'area locale.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> FolderList { get; set; }
Public Property FolderList As List(Of String)
    Get
    Set
public:
property List<String^>^ FolderList {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
member FolderList : List<string> with get, set

Valore della proprietà

List String
Vedi anche

Documentazione

Classe EnsureLocalFolder
Namespace DedNet.Commands


Proprietà EnsureLocalFolder.NeedParameters

Proprietà EnsureLocalFolderNeedParameters
Restituisce true se non sono presenti documenti da elaborare.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe EnsureLocalFolder
Namespace DedNet.Commands


Proprietà EnsureLocalFolder.OnlyFolderStructure

Proprietà EnsureLocalFolderOnlyFolderStructure

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool OnlyFolderStructure { get; set; }
Public Property OnlyFolderStructure As Boolean
    Get
    Set
public:
property bool OnlyFolderStructure {
    bool get ();
    void set (bool value);
}
member OnlyFolderStructure : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe EnsureLocalFolder
Namespace DedNet.Commands


Metodi di EnsureLocalFolder

Il tipo EnsureLocalFolder espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce sempre false in quanto si tratta di un sotto-comando. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Restituisce sempre false in quanto si tratta di un sotto-comando. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe EnsureLocalFolder
Namespace DedNet.Commands


Metodo EnsureLocalFolder.ClearCommand

Metodo EnsureLocalFolderClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe EnsureLocalFolder
Namespace DedNet.Commands


Metodo EnsureLocalFolder.Enabled

Metodo EnsureLocalFolderEnabled
Restituisce sempre false in quanto si tratta di un sotto-comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe EnsureLocalFolder
Namespace DedNet.Commands


Metodo EnsureLocalFolder.ExecuteCommand

Metodo EnsureLocalFolderExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe EnsureLocalFolder
Namespace DedNet.Commands


Metodo EnsureLocalFolder.SetContext

Metodo EnsureLocalFolderSetContext
Restituisce sempre false in quanto si tratta di un sotto-comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto c'è una sola anagrafica alla quale associare il file.
Vedi anche

Documentazione

Classe EnsureLocalFolder
Namespace DedNet.Commands


Classe ExportCommand
Classe che rappresenta il comando per editare gli utenti e i permessi.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsExportCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ExportCommand : DedCommand
Public Class ExportCommand
    Inherits DedCommand
public ref class ExportCommand : public DedCommand
type ExportCommand =
    class
        inherit DedCommand
    end

Il tipo ExportCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | ToExport | Oggetto che si vuole esportare.
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | ExpandAllRows | Metodo per expandere tutte le viste.
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di ExportCommand

Il tipo ExportCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | ToExport | Oggetto che si vuole esportare.
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ExportCommand
Namespace DedNet.Commands


Proprietà ExportCommand.NeedParameters

Proprietà ExportCommandNeedParameters

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ExportCommand
Namespace DedNet.Commands


Proprietà ExportCommand.ToExport

Proprietà ExportCommandToExport
Oggetto che si vuole esportare.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public IPrintable ToExport { get; set; }
Public Property ToExport As IPrintable
    Get
    Set
public:
property IPrintable^ ToExport {
    IPrintable^ get ();
    void set (IPrintable^ value);
}
member ToExport : IPrintable with get, set

Valore della proprietà

IPrintable
Vedi anche

Documentazione

Classe ExportCommand
Namespace DedNet.Commands


Metodi di ExportCommand

Il tipo ExportCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | ExpandAllRows | Metodo per expandere tutte le viste.
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ExportCommand
Namespace DedNet.Commands


Metodo ExportCommand.ClearCommand

Metodo ExportCommandClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe ExportCommand
Namespace DedNet.Commands


Metodo ExportCommand.Enabled

Metodo ExportCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe ExportCommand
Namespace DedNet.Commands


Metodo ExportCommand.ExecuteCommand

Metodo ExportCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe ExportCommand
Namespace DedNet.Commands


Metodo ExportCommand.ExpandAllRows

Metodo ExportCommandExpandAllRows
Metodo per expandere tutte le viste.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ExpandAllRows(
    GridView view
)
Public Sub ExpandAllRows (
    view As GridView
)
public:
void ExpandAllRows(
    GridView^ view
)
member ExpandAllRows :
        view : GridView -> unit

Parametri

view GridView
Vedi anche

Documentazione

Classe ExportCommand
Namespace DedNet.Commands


Metodo ExportCommand.SetContext

Metodo ExportCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe ExportCommand
Namespace DedNet.Commands


Classe ExportDocument
Permette di esportare il documento copiandolo in una destinazione all'esterno dei path del database. Non registra nulla. E' utilizzato per fornire la documentazione a terzi. Fornisce la possibilità di porre in checkout i documenti all'atto dell'esportazione. Necessita di un percorso di destinazione valido.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsExportDocument

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ExportDocument : DedCommand
Public Class ExportDocument
    Inherits DedCommand
public ref class ExportDocument : public DedCommand
type ExportDocument =
    class
        inherit DedCommand
    end

Il tipo ExportDocument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | AttachDocList | Documenti allegati ricavati dal comando. Sono da esportare in lista parallela per non inquinare la lista originale.
Proprietà pubblica | CheckOutOnExport | Inidica se in fase di esportazione il documento debba contestualmente essere posto in checkout (di default è false).
Proprietà pubblica | CheckOutUser | Utente da utilizzare per l'operazione di CheckOut.
Proprietà pubblica | CheckPathExists | Controllo se il path di esportazione esiste o meno (di default è false).
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CreateFolderStructure | Indica se creare la struttura delle cartelle nel pacchetto di esportazione ( in Autocad è false )
Proprietà pubblica | ExportAttachments | Determina se nel contesto dell'anagrafica è necessario esportare anche gli allegati
Proprietà pubblica | ExportPublishingDocs | Determina se nel contesto della stessa anagrafica è necessario esportare anche i documenti di pubblicazione
Proprietà pubblica | ExtraDocList | Documenti extra ricavati dal comando. Sono da esportare in lista parallela per non inquinare la lista originale.
Proprietà pubblica | FileList | Restituisce la lista dei documenti da esportare Inserire in questa lista solo i file che si desidera elaborare e non le dipendenze.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non sono presenti documenti da elaborare. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | PublishingDocList | Documenti di pubblicazione ricavati dal comando. Sono da esportare in lista parallela per non inquinare la lista originale.
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RootDestPath | Percorso di destinazione dell'esportazione. Per la copia dei file il path viene uniti al path relativo alla root per ottenere il percorso assoluto di destinazione.
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | Restitusice o imposta se il comando debba essere effettuato su tutta la struttura.
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di ExportDocument

Il tipo ExportDocument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | AttachDocList | Documenti allegati ricavati dal comando. Sono da esportare in lista parallela per non inquinare la lista originale.
Proprietà pubblica | CheckOutOnExport | Inidica se in fase di esportazione il documento debba contestualmente essere posto in checkout (di default è false).
Proprietà pubblica | CheckOutUser | Utente da utilizzare per l'operazione di CheckOut.
Proprietà pubblica | CheckPathExists | Controllo se il path di esportazione esiste o meno (di default è false).
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CreateFolderStructure | Indica se creare la struttura delle cartelle nel pacchetto di esportazione ( in Autocad è false )
Proprietà pubblica | ExportAttachments | Determina se nel contesto dell'anagrafica è necessario esportare anche gli allegati
Proprietà pubblica | ExportPublishingDocs | Determina se nel contesto della stessa anagrafica è necessario esportare anche i documenti di pubblicazione
Proprietà pubblica | ExtraDocList | Documenti extra ricavati dal comando. Sono da esportare in lista parallela per non inquinare la lista originale.
Proprietà pubblica | FileList | Restituisce la lista dei documenti da esportare Inserire in questa lista solo i file che si desidera elaborare e non le dipendenze.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non sono presenti documenti da elaborare. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | PublishingDocList | Documenti di pubblicazione ricavati dal comando. Sono da esportare in lista parallela per non inquinare la lista originale.
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RootDestPath | Percorso di destinazione dell'esportazione. Per la copia dei file il path viene uniti al path relativo alla root per ottenere il percorso assoluto di destinazione.
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | Restitusice o imposta se il comando debba essere effettuato su tutta la struttura.
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ExportDocument
Namespace DedNet.Commands


Proprietà ExportDocument.AttachDocList

Proprietà ExportDocumentAttachDocList
Documenti allegati ricavati dal comando. Sono da esportare in lista parallela per non inquinare la lista originale.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfoList AttachDocList { get; }
Public ReadOnly Property AttachDocList As DocStructInfoList
    Get
public:
property DocStructInfoList^ AttachDocList {
    DocStructInfoList^ get ();
}
member AttachDocList : DocStructInfoList with get

Valore della proprietà

DocStructInfoList
Vedi anche

Documentazione

Classe ExportDocument
Namespace DedNet.Commands


Proprietà ExportDocument.CheckOutOnExport

Proprietà ExportDocumentCheckOutOnExport
Inidica se in fase di esportazione il documento debba contestualmente essere posto in checkout (di default è false).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CheckOutOnExport { get; set; }
Public Property CheckOutOnExport As Boolean
    Get
    Set
public:
property bool CheckOutOnExport {
    bool get ();
    void set (bool value);
}
member CheckOutOnExport : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ExportDocument
Namespace DedNet.Commands


Proprietà ExportDocument.CheckOutUser

Proprietà ExportDocumentCheckOutUser
Utente da utilizzare per l'operazione di CheckOut.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string CheckOutUser { get; set; }
Public Property CheckOutUser As String
    Get
    Set
public:
property String^ CheckOutUser {
    String^ get ();
    void set (String^ value);
}
member CheckOutUser : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe ExportDocument
Namespace DedNet.Commands


Proprietà ExportDocument.CheckPathExists

Proprietà ExportDocumentCheckPathExists
Controllo se il path di esportazione esiste o meno (di default è false).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CheckPathExists { get; set; }
Public Property CheckPathExists As Boolean
    Get
    Set
public:
property bool CheckPathExists {
    bool get ();
    void set (bool value);
}
member CheckPathExists : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ExportDocument
Namespace DedNet.Commands


Proprietà ExportDocument.CreateFolderStructure

Proprietà ExportDocumentCreateFolderStructure
Indica se creare la struttura delle cartelle nel pacchetto di esportazione ( in Autocad è false )

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CreateFolderStructure { get; set; }
Public Property CreateFolderStructure As Boolean
    Get
    Set
public:
property bool CreateFolderStructure {
    bool get ();
    void set (bool value);
}
member CreateFolderStructure : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ExportDocument
Namespace DedNet.Commands


Proprietà ExportDocument.ExportAttachments

Proprietà ExportDocumentExportAttachments
Determina se nel contesto dell'anagrafica è necessario esportare anche gli allegati

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ExportAttachments { get; set; }
Public Property ExportAttachments As Boolean
    Get
    Set
public:
property bool ExportAttachments {
    bool get ();
    void set (bool value);
}
member ExportAttachments : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ExportDocument
Namespace DedNet.Commands


Proprietà ExportDocument.ExportPublishingDocs

Proprietà ExportDocumentExportPublishingDocs
Determina se nel contesto della stessa anagrafica è necessario esportare anche i documenti di pubblicazione

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ExportPublishingDocs { get; set; }
Public Property ExportPublishingDocs As Boolean
    Get
    Set
public:
property bool ExportPublishingDocs {
    bool get ();
    void set (bool value);
}
member ExportPublishingDocs : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ExportDocument
Namespace DedNet.Commands


Proprietà ExportDocument.ExtraDocList

Proprietà ExportDocumentExtraDocList
Documenti extra ricavati dal comando. Sono da esportare in lista parallela per non inquinare la lista originale.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfoList ExtraDocList { get; set; }
Public Property ExtraDocList As DocStructInfoList
    Get
    Set
public:
property DocStructInfoList^ ExtraDocList {
    DocStructInfoList^ get ();
    void set (DocStructInfoList^ value);
}
member ExtraDocList : DocStructInfoList with get, set

Valore della proprietà

DocStructInfoList
Vedi anche

Documentazione

Classe ExportDocument
Namespace DedNet.Commands


Proprietà ExportDocument.FileList

Proprietà ExportDocumentFileList
Restituisce la lista dei documenti da esportare Inserire in questa lista solo i file che si desidera elaborare e non le dipendenze.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfoList FileList { get; }
Public ReadOnly Property FileList As DocStructInfoList
    Get
public:
property DocStructInfoList^ FileList {
    DocStructInfoList^ get ();
}
member FileList : DocStructInfoList with get

Valore della proprietà

DocStructInfoList
Vedi anche

Documentazione

Classe ExportDocument
Namespace DedNet.Commands


Proprietà ExportDocument.NeedParameters

Proprietà ExportDocumentNeedParameters
Restituisce true se non sono presenti documenti da elaborare.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ExportDocument
Namespace DedNet.Commands


Proprietà ExportDocument.PublishingDocList

Proprietà ExportDocumentPublishingDocList
Documenti di pubblicazione ricavati dal comando. Sono da esportare in lista parallela per non inquinare la lista originale.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfoList PublishingDocList { get; }
Public ReadOnly Property PublishingDocList As DocStructInfoList
    Get
public:
property DocStructInfoList^ PublishingDocList {
    DocStructInfoList^ get ();
}
member PublishingDocList : DocStructInfoList with get

Valore della proprietà

DocStructInfoList
Vedi anche

Documentazione

Classe ExportDocument
Namespace DedNet.Commands


Proprietà ExportDocument.RootDestPath

Proprietà ExportDocumentRootDestPath
Percorso di destinazione dell'esportazione. Per la copia dei file il path viene uniti al path relativo alla root per ottenere il percorso assoluto di destinazione.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string RootDestPath { get; set; }
Public Property RootDestPath As String
    Get
    Set
public:
property String^ RootDestPath {
    String^ get ();
    void set (String^ value);
}
member RootDestPath : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe ExportDocument
Namespace DedNet.Commands


Proprietà ExportDocument.Struttura

Proprietà ExportDocumentStruttura
Restitusice o imposta se il comando debba essere effettuato su tutta la struttura.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Struttura { get; set; }
Public Property Struttura As Boolean
    Get
    Set
public:
property bool Struttura {
    bool get ();
    void set (bool value);
}
member Struttura : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ExportDocument
Namespace DedNet.Commands


Metodi di ExportDocument

Il tipo ExportDocument espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ExportDocument
Namespace DedNet.Commands


Metodo ExportDocument.ClearCommand

Metodo ExportDocumentClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override sealed void ClearCommand()
Public Overrides NotOverridable Sub ClearCommand
public:
virtual void ClearCommand() override sealed
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe ExportDocument
Namespace DedNet.Commands


Metodo ExportDocument.Enabled

Metodo ExportDocumentEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe ExportDocument
Namespace DedNet.Commands


Metodo ExportDocument.ExecuteCommand

Metodo ExportDocumentExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe ExportDocument
Namespace DedNet.Commands


Metodo ExportDocument.SetContext

Metodo ExportDocumentSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto c'è una sola anagrafica alla quale associare il file.
Vedi anche

Documentazione

Classe ExportDocument
Namespace DedNet.Commands


Delegate FileOperationDelegate<T>

Delegate FileOperationDelegateT
Delegate utilizzato per elaborare i file fisici dal client. Il client dovrà restituire Success se riesce nell'operazione sui file di suo interesse, altrimenti restituirà un altro valore che sarà poi restituito dal comando stesso.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public delegate DedCmdResult FileOperationDelegate<T>(
    T argument
)

Public Delegate Function FileOperationDelegate(Of T) (
    argument As T
) As DedCmdResult
generic<typename T>
public delegate DedCmdResult FileOperationDelegate(
    T argument
)
type FileOperationDelegate =
    delegate of
        argument : 'T -> DedCmdResult

Parametri

argument T

Parametri di tipo

T
Parametro da passare al client per effettuare le operazioni sui file, normalmente si tratta di un oggetto di tipo DocStructInfo o DocStructInfoList.

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Namespace DedNet.Commands


Classe FileZip
Esegue lo zip di un insieme di documenti, chiedendo all'utente vuole archiviarli.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsDedDocumentCommand
DedNet.CommandsFileZip

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class FileZip : DedDocumentCommand
Public Class FileZip
    Inherits DedDocumentCommand
public ref class FileZip : public DedDocumentCommand
type FileZip =
    class
        inherit DedDocumentCommand
    end

Il tipo FileZip espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DocumentInfos | Restituisce la lista dei documenti con abbinato il contesto di anagrafica di elaborazione comando. (Ereditato da DedDocumentCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce false se non esiste nemmeno un documento sul quale eseguire il comando. (Ereditato da DedDocumentCommand)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Reinizializza il comando. (Ereditato da DedDocumentCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedDocumentCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedDocumentCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedDocumentCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedDocumentCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di FileZip

Il tipo FileZip espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DocumentInfos | Restituisce la lista dei documenti con abbinato il contesto di anagrafica di elaborazione comando. (Ereditato da DedDocumentCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce false se non esiste nemmeno un documento sul quale eseguire il comando. (Ereditato da DedDocumentCommand)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe FileZip
Namespace DedNet.Commands


Metodi di FileZip

Il tipo FileZip espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Reinizializza il comando. (Ereditato da DedDocumentCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedDocumentCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedDocumentCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedDocumentCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedDocumentCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe FileZip
Namespace DedNet.Commands


Metodo FileZip.Enabled

Metodo FileZipEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe FileZip
Namespace DedNet.Commands


Metodo FileZip.ExecuteCommand

Metodo FileZipExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe FileZip
Namespace DedNet.Commands


Metodo FileZip.SetContext

Metodo FileZipSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe FileZip
Namespace DedNet.Commands


Classe FileZipStruct
Esegue lo zip di un insieme di documenti, chiedendo all'utente vuole archiviarli.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsDedDocumentCommand
DedNet.CommandsFileZipStruct

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class FileZipStruct : DedDocumentCommand
Public Class FileZipStruct
    Inherits DedDocumentCommand
public ref class FileZipStruct : public DedDocumentCommand
type FileZipStruct =
    class
        inherit DedDocumentCommand
    end

Il tipo FileZipStruct espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DocumentInfos | Restituisce la lista dei documenti con abbinato il contesto di anagrafica di elaborazione comando. (Ereditato da DedDocumentCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce false se non esiste nemmeno un documento sul quale eseguire il comando. (Ereditato da DedDocumentCommand)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Reinizializza il comando. (Ereditato da DedDocumentCommand)
Metodo pubblico | CreateDedDataList | Restituisce la lista delle anagrafiche presenti nella distinta. Esegue un controllo ricorsivo sui BomItemCollection
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedDocumentCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedDocumentCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedDocumentCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedDocumentCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di FileZipStruct

Il tipo FileZipStruct espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DocumentInfos | Restituisce la lista dei documenti con abbinato il contesto di anagrafica di elaborazione comando. (Ereditato da DedDocumentCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce false se non esiste nemmeno un documento sul quale eseguire il comando. (Ereditato da DedDocumentCommand)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe FileZipStruct
Namespace DedNet.Commands


Metodi di FileZipStruct

Il tipo FileZipStruct espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Reinizializza il comando. (Ereditato da DedDocumentCommand)
Metodo pubblico | CreateDedDataList | Restituisce la lista delle anagrafiche presenti nella distinta. Esegue un controllo ricorsivo sui BomItemCollection
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedDocumentCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedDocumentCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedDocumentCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedDocumentCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe FileZipStruct
Namespace DedNet.Commands


Metodo FileZipStruct.CreateDedDataList

Metodo FileZipStructCreateDedDataList
Restituisce la lista delle anagrafiche presenti nella distinta. Esegue un controllo ricorsivo sui BomItemCollection

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<DedData> CreateDedDataList(
    DistManager dm,
    BomItemCollection bic,
    DateTime? date
)
Public Function CreateDedDataList (
    dm As DistManager,
    bic As BomItemCollection,
    date As DateTime?
) As List(Of DedData)
public:
List<DedData^>^ CreateDedDataList(
    DistManager^ dm,
    BomItemCollection^ bic,
    Nullable<DateTime> date
)
member CreateDedDataList :
        dm : DistManager *
        bic : BomItemCollection *
        date : Nullable<DateTime> -> List<DedData>

Parametri

dm DistManager
DistManager
bic BomItemCollection
BomItemCollection dove vengono prese le anagrafiche
date Nullable DateTime
DataTime del padre

Valore di ritorno

List DedData
Vedi anche

Documentazione

Classe FileZipStruct
Namespace DedNet.Commands


Metodo FileZipStruct.Enabled

Metodo FileZipStructEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe FileZipStruct
Namespace DedNet.Commands


Metodo FileZipStruct.ExecuteCommand

Metodo FileZipStructExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe FileZipStruct
Namespace DedNet.Commands


Metodo FileZipStruct.SetContext

Metodo FileZipStructSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe FileZipStruct
Namespace DedNet.Commands


Classe FillDedDataEncodeTableCommand
Compila la tabella DED_DATA_ENCODE con tutte le anagrafiche presenti nel DB.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsFillDedDataEncodeTableCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class FillDedDataEncodeTableCommand : DedCommand
Public Class FillDedDataEncodeTableCommand
    Inherits DedCommand
public ref class FillDedDataEncodeTableCommand : public DedCommand
type FillDedDataEncodeTableCommand =
    class
        inherit DedCommand
    end

Il tipo FillDedDataEncodeTableCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di FillDedDataEncodeTableCommand

Il tipo FillDedDataEncodeTableCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe FillDedDataEncodeTableCommand
Namespace DedNet.Commands


Proprietà FillDedDataEncodeTableCommand.NeedParameters

Proprietà FillDedDataEncodeTableCommandNeedParameters

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe FillDedDataEncodeTableCommand
Namespace DedNet.Commands


Metodi di FillDedDataEncodeTableCommand

Il tipo FillDedDataEncodeTableCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe FillDedDataEncodeTableCommand
Namespace DedNet.Commands


Metodo FillDedDataEncodeTableCommand.ClearCommand

Metodo FillDedDataEncodeTableCommandClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe FillDedDataEncodeTableCommand
Namespace DedNet.Commands


Metodo FillDedDataEncodeTableCommand.Enabled

Metodo FillDedDataEncodeTableCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di eselezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe FillDedDataEncodeTableCommand
Namespace DedNet.Commands


Metodo FillDedDataEncodeTableCommand.ExecuteCommand

Metodo FillDedDataEncodeTableCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe FillDedDataEncodeTableCommand
Namespace DedNet.Commands


Metodo FillDedDataEncodeTableCommand.SetContext

Metodo FillDedDataEncodeTableCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe FillDedDataEncodeTableCommand
Namespace DedNet.Commands


Classe FindCodeCommand
Comando che permette l'apertura della finestra di ricerca codice con in primo piano un comando specifico.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsFindCodeCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class FindCodeCommand : DedCommand
Public Class FindCodeCommand
    Inherits DedCommand
public ref class FindCodeCommand : public DedCommand
type FindCodeCommand =
    class
        inherit DedCommand
    end

Il tipo FindCodeCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Sovrascrive DedCommandClient)
Proprietà pubblica | Code | Restituisce o imposta il codice da pre-impostare.
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DefaultCommand | Restituisce o imposta il comando da visualizzare come default.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | Id | Restituisce o imposta la revisione da pre-impostare.
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine abbinata al comando. (Sovrascrive DedCommandImg16)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine abbinata al comando. (Sovrascrive DedCommandImg32)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Sovrascrive DedCommandMinimumPerm)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Sovrascrive DedCommandName)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | Rev | Restituisce o imposta la revisione da pre-impostare.
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Sovrascrive DedCommandSubMenuName)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Sovrascrive DedCommandSubMenuText)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Sovrascrive DedCommandTooltip)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio: Apre la finestra di ricerca codice con il pulsante sul comando di default. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Sovrascrive DedCommandRun)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di FindCodeCommand

Il tipo FindCodeCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Sovrascrive DedCommandClient)
Proprietà pubblica | Code | Restituisce o imposta il codice da pre-impostare.
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DefaultCommand | Restituisce o imposta il comando da visualizzare come default.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | Id | Restituisce o imposta la revisione da pre-impostare.
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine abbinata al comando. (Sovrascrive DedCommandImg16)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine abbinata al comando. (Sovrascrive DedCommandImg32)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Sovrascrive DedCommandMinimumPerm)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Sovrascrive DedCommandName)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | Rev | Restituisce o imposta la revisione da pre-impostare.
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Sovrascrive DedCommandSubMenuName)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Sovrascrive DedCommandSubMenuText)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Sovrascrive DedCommandTooltip)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe FindCodeCommand
Namespace DedNet.Commands


Proprietà FindCodeCommand.Client

Proprietà FindCodeCommandClient
Restituisce o imposta le applicazioni client per le quali questo comando è disponibile.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override ClientApplicationEnum Client { get; set; }
Public Overrides Property Client As ClientApplicationEnum
    Get
    Set
public:
virtual property ClientApplicationEnum Client {
    ClientApplicationEnum get () override;
    void set (ClientApplicationEnum value) override;
}
abstract Client : ClientApplicationEnum with get, set
override Client : ClientApplicationEnum with get, set

Valore della proprietà

ClientApplicationEnum
Vedi anche

Documentazione

Classe FindCodeCommand
Namespace DedNet.Commands


Proprietà FindCodeCommand.Code

Proprietà FindCodeCommandCode
Restituisce o imposta il codice da pre-impostare.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Code { get; set; }
Public Property Code As String
    Get
    Set
public:
property String^ Code {
    String^ get ();
    void set (String^ value);
}
member Code : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe FindCodeCommand
Namespace DedNet.Commands


Proprietà FindCodeCommand.DefaultCommand

Proprietà FindCodeCommandDefaultCommand
Restituisce o imposta il comando da visualizzare come default.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommand DefaultCommand { get; set; }
Public Property DefaultCommand As DedCommand
    Get
    Set
public:
property DedCommand^ DefaultCommand {
    DedCommand^ get ();
    void set (DedCommand^ value);
}
member DefaultCommand : DedCommand with get, set

Valore della proprietà

DedCommand
Vedi anche

Documentazione

Classe FindCodeCommand
Namespace DedNet.Commands


Proprietà FindCodeCommand.Id

Proprietà FindCodeCommandId
Restituisce o imposta la revisione da pre-impostare.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Id { get; set; }
Public Property Id As String
    Get
    Set
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}
member Id : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe FindCodeCommand
Namespace DedNet.Commands


Proprietà FindCodeCommand.Img16

Proprietà FindCodeCommandImg16
Restituisce o imposta l'immagine abbinata al comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override Image Img16 { get; set; }
Public Overrides Property Img16 As Image
    Get
    Set
public:
virtual property Image^ Img16 {
    Image^ get () override;
    void set (Image^ value) override;
}
abstract Img16 : Image with get, set
override Img16 : Image with get, set

Valore della proprietà

Image
Vedi anche

Documentazione

Classe FindCodeCommand
Namespace DedNet.Commands


Proprietà FindCodeCommand.Img32

Proprietà FindCodeCommandImg32
Restituisce o imposta l'immagine abbinata al comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override Image Img32 { get; set; }
Public Overrides Property Img32 As Image
    Get
    Set
public:
virtual property Image^ Img32 {
    Image^ get () override;
    void set (Image^ value) override;
}
abstract Img32 : Image with get, set
override Img32 : Image with get, set

Valore della proprietà

Image
Vedi anche

Documentazione

Classe FindCodeCommand
Namespace DedNet.Commands


Proprietà FindCodeCommand.MinimumPerm

Proprietà FindCodeCommandMinimumPerm
Restituisce o imposta il permesso minimo necessario per eseguire il comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override DedStandardPerm MinimumPerm { get; set; }
Public Overrides Property MinimumPerm As DedStandardPerm
    Get
    Set
public:
virtual property DedStandardPerm MinimumPerm {
    DedStandardPerm get () override;
    void set (DedStandardPerm value) override;
}
abstract MinimumPerm : DedStandardPerm with get, set
override MinimumPerm : DedStandardPerm with get, set

Valore della proprietà

DedStandardPerm
Vedi anche

Documentazione

Classe FindCodeCommand
Namespace DedNet.Commands


Proprietà FindCodeCommand.Name

Proprietà FindCodeCommandName
Restituisce il nome visualizzato del comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string Name { get; }
Public Overrides ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () override;
}
abstract Name : string with get
override Name : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe FindCodeCommand
Namespace DedNet.Commands


Proprietà FindCodeCommand.NeedParameters

Proprietà FindCodeCommandNeedParameters
Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe FindCodeCommand
Namespace DedNet.Commands


Proprietà FindCodeCommand.Rev

Proprietà FindCodeCommandRev
Restituisce o imposta la revisione da pre-impostare.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Rev { get; set; }
Public Property Rev As String
    Get
    Set
public:
property String^ Rev {
    String^ get ();
    void set (String^ value);
}
member Rev : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe FindCodeCommand
Namespace DedNet.Commands


Proprietà FindCodeCommand.SubMenuName

Proprietà FindCodeCommandSubMenuName
Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string SubMenuName { get; set; }
Public Overrides Property SubMenuName As String
    Get
    Set
public:
virtual property String^ SubMenuName {
    String^ get () override;
    void set (String^ value) override;
}
abstract SubMenuName : string with get, set
override SubMenuName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe FindCodeCommand
Namespace DedNet.Commands


Proprietà FindCodeCommand.SubMenuText

Proprietà FindCodeCommandSubMenuText
Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string SubMenuText { get; set; }
Public Overrides Property SubMenuText As String
    Get
    Set
public:
virtual property String^ SubMenuText {
    String^ get () override;
    void set (String^ value) override;
}
abstract SubMenuText : string with get, set
override SubMenuText : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe FindCodeCommand
Namespace DedNet.Commands


Proprietà FindCodeCommand.Tooltip

Proprietà FindCodeCommandTooltip
Restituisce o imposta il Tooltip descrittivo del comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string Tooltip { get; set; }
Public Overrides Property Tooltip As String
    Get
    Set
public:
virtual property String^ Tooltip {
    String^ get () override;
    void set (String^ value) override;
}
abstract Tooltip : string with get, set
override Tooltip : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe FindCodeCommand
Namespace DedNet.Commands


Metodi di FindCodeCommand

Il tipo FindCodeCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio: Apre la finestra di ricerca codice con il pulsante sul comando di default. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Sovrascrive DedCommandRun)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe FindCodeCommand
Namespace DedNet.Commands


Metodo FindCodeCommand.ClearCommand

Metodo FindCodeCommandClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe FindCodeCommand
Namespace DedNet.Commands


Metodo FindCodeCommand.Enabled

Metodo FindCodeCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext commandContext
)
Public Overrides Function Enabled (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ commandContext
) override
abstract Enabled :
        commandContext : DedCommandContext -> bool
override Enabled :
        commandContext : DedCommandContext -> bool

Parametri

commandContext DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe FindCodeCommand
Namespace DedNet.Commands


Metodo FindCodeCommand.ExecuteCommand

Metodo FindCodeCommandExecuteCommand
Esegue il comando vero e proprio: Apre la finestra di ricerca codice con il pulsante sul comando di default.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe FindCodeCommand
Namespace DedNet.Commands


Metodo FindCodeCommand.Run

Metodo FindCodeCommandRun
Esegue il comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override DedCmdResult Run()
Public Overrides Function Run As DedCmdResult
public:
virtual DedCmdResult Run() override
abstract Run : unit -> DedCmdResult
override Run : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe FindCodeCommand
Namespace DedNet.Commands


Metodo FindCodeCommand.SetContext

Metodo FindCodeCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext commandContext
)
Public Overrides Function SetContext (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ commandContext
) override
abstract SetContext :
        commandContext : DedCommandContext -> bool
override SetContext :
        commandContext : DedCommandContext -> bool

Parametri

commandContext DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe FindCodeCommand
Namespace DedNet.Commands


Classe FindCommand
Classe che rappresenta il comando per ricercare dentro al DataBase. Lancia il form della ricerca in modalità non modale.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsFindCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class FindCommand : DedCommand
Public Class FindCommand
    Inherits DedCommand
public ref class FindCommand : public DedCommand
type FindCommand =
    class
        inherit DedCommand
    end

Il tipo FindCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CloseDialogOnQuit | Restituisce o imposta se la finestra, su chiusura, tramite x o tramite menu, si debba chiudere invece di nascondersi. Di default è false.
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | FindForm | Restituisce il form utilizzato da questo comando. Restituisce null se non è mai stato lanciato.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | IndividuaAnagrafica | Imposta l'anagrafica da visualizzare nel tab dei recenti.
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di FindCommand

Il tipo FindCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CloseDialogOnQuit | Restituisce o imposta se la finestra, su chiusura, tramite x o tramite menu, si debba chiudere invece di nascondersi. Di default è false.
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | FindForm | Restituisce il form utilizzato da questo comando. Restituisce null se non è mai stato lanciato.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | IndividuaAnagrafica | Imposta l'anagrafica da visualizzare nel tab dei recenti.
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe FindCommand
Namespace DedNet.Commands


Proprietà FindCommand.CloseDialogOnQuit

Proprietà FindCommandCloseDialogOnQuit
Restituisce o imposta se la finestra, su chiusura, tramite x o tramite menu, si debba chiudere invece di nascondersi. Di default è false.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CloseDialogOnQuit { get; set; }
Public Property CloseDialogOnQuit As Boolean
    Get
    Set
public:
property bool CloseDialogOnQuit {
    bool get ();
    void set (bool value);
}
member CloseDialogOnQuit : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe FindCommand
Namespace DedNet.Commands


Proprietà FindCommand.FindForm

Proprietà FindCommandFindForm
Restituisce il form utilizzato da questo comando. Restituisce null se non è mai stato lanciato.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormMain FindForm { get; }
Public ReadOnly Property FindForm As DedFormMain
    Get
public:
property DedFormMain^ FindForm {
    DedFormMain^ get ();
}
member FindForm : DedFormMain with get

Valore della proprietà

DedFormMain
Vedi anche

Documentazione

Classe FindCommand
Namespace DedNet.Commands


Proprietà FindCommand.IndividuaAnagrafica

Proprietà FindCommandIndividuaAnagrafica
Imposta l'anagrafica da visualizzare nel tab dei recenti.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData IndividuaAnagrafica { get; set; }
Public Property IndividuaAnagrafica As DedData
    Get
    Set
public:
property DedData^ IndividuaAnagrafica {
    DedData^ get ();
    void set (DedData^ value);
}
member IndividuaAnagrafica : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe FindCommand
Namespace DedNet.Commands


Proprietà FindCommand.NeedParameters

Proprietà FindCommandNeedParameters

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe FindCommand
Namespace DedNet.Commands


Metodi di FindCommand

Il tipo FindCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe FindCommand
Namespace DedNet.Commands


Metodo FindCommand.ClearCommand

Metodo FindCommandClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe FindCommand
Namespace DedNet.Commands


Metodo FindCommand.Enabled

Metodo FindCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe FindCommand
Namespace DedNet.Commands


Metodo FindCommand.ExecuteCommand

Metodo FindCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe FindCommand
Namespace DedNet.Commands


Metodo FindCommand.SetContext

Metodo FindCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe FindCommand
Namespace DedNet.Commands


Classe FindDataDocCommand
Classe che rappresenta il comando per ricercare i documenti all'interno del Database.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsDedDataCommand
DedNet.CommandsFindDataDocCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class FindDataDocCommand : DedDataCommand
Public Class FindDataDocCommand
    Inherits DedDataCommand
public ref class FindDataDocCommand : public DedDataCommand
type FindDataDocCommand =
    class
        inherit DedDataCommand
    end

Il tipo FindDataDocCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DataInfos | Restituisce la lista delle anagrafiche di elaborazione comando. (Ereditato da DedDataCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedDataCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Esegue la pulizia del comando. Azzera tutte le variabili. (Ereditato da DedDataCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedDataCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedDataCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedDataCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedDataCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di FindDataDocCommand

Il tipo FindDataDocCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DataInfos | Restituisce la lista delle anagrafiche di elaborazione comando. (Ereditato da DedDataCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedDataCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe FindDataDocCommand
Namespace DedNet.Commands


Proprietà FindDataDocCommand.NeedParameters

Proprietà FindDataDocCommandNeedParameters

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe FindDataDocCommand
Namespace DedNet.Commands


Metodi di FindDataDocCommand

Il tipo FindDataDocCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Esegue la pulizia del comando. Azzera tutte le variabili. (Ereditato da DedDataCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedDataCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedDataCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedDataCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedDataCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe FindDataDocCommand
Namespace DedNet.Commands


Metodo FindDataDocCommand.Enabled

Metodo FindDataDocCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe FindDataDocCommand
Namespace DedNet.Commands


Metodo FindDataDocCommand.ExecuteCommand

Metodo FindDataDocCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe FindDataDocCommand
Namespace DedNet.Commands


Metodo FindDataDocCommand.SetContext

Metodo FindDataDocCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe FindDataDocCommand
Namespace DedNet.Commands


Classe FindDocCommand
Classe che rappresenta il comando per ricercare i documenti all'interno del Database.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsFindDocCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class FindDocCommand : DedCommand
Public Class FindDocCommand
    Inherits DedCommand
public ref class FindDocCommand : public DedCommand
type FindDocCommand =
    class
        inherit DedCommand
    end

Il tipo FindDocCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CloseDialogOnQuit | Restituisce o imposta se la finestra, su chiusura, tramite x o tramite menu, si debba chiudere invece di nascondersi. Di default è false.
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | FindDocsForm | Restituisce il form utilizzato da questo comando. Restituisce null se non è mai stato lanciato.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di FindDocCommand

Il tipo FindDocCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CloseDialogOnQuit | Restituisce o imposta se la finestra, su chiusura, tramite x o tramite menu, si debba chiudere invece di nascondersi. Di default è false.
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | FindDocsForm | Restituisce il form utilizzato da questo comando. Restituisce null se non è mai stato lanciato.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe FindDocCommand
Namespace DedNet.Commands


Proprietà FindDocCommand.CloseDialogOnQuit

Proprietà FindDocCommandCloseDialogOnQuit
Restituisce o imposta se la finestra, su chiusura, tramite x o tramite menu, si debba chiudere invece di nascondersi. Di default è false.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CloseDialogOnQuit { get; set; }
Public Property CloseDialogOnQuit As Boolean
    Get
    Set
public:
property bool CloseDialogOnQuit {
    bool get ();
    void set (bool value);
}
member CloseDialogOnQuit : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe FindDocCommand
Namespace DedNet.Commands


Proprietà FindDocCommand.FindDocsForm

Proprietà FindDocCommandFindDocsForm
Restituisce il form utilizzato da questo comando. Restituisce null se non è mai stato lanciato.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormDocSearch FindDocsForm { get; }
Public ReadOnly Property FindDocsForm As DedFormDocSearch
    Get
public:
property DedFormDocSearch^ FindDocsForm {
    DedFormDocSearch^ get ();
}
member FindDocsForm : DedFormDocSearch with get

Valore della proprietà

DedFormDocSearch
Vedi anche

Documentazione

Classe FindDocCommand
Namespace DedNet.Commands


Proprietà FindDocCommand.NeedParameters

Proprietà FindDocCommandNeedParameters

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe FindDocCommand
Namespace DedNet.Commands


Metodi di FindDocCommand

Il tipo FindDocCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe FindDocCommand
Namespace DedNet.Commands


Metodo FindDocCommand.ClearCommand

Metodo FindDocCommandClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe FindDocCommand
Namespace DedNet.Commands


Metodo FindDocCommand.Enabled

Metodo FindDocCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe FindDocCommand
Namespace DedNet.Commands


Metodo FindDocCommand.ExecuteCommand

Metodo FindDocCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe FindDocCommand
Namespace DedNet.Commands


Metodo FindDocCommand.SetContext

Metodo FindDocCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe FindDocCommand
Namespace DedNet.Commands


Classe FindInRicercaCommand
Comando che permette di aprire la ricerca con selezionata l'anagrafica associata al documento selezionato.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsDedDocumentCommand
DedNet.CommandsFindInRicercaCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class FindInRicercaCommand : DedDocumentCommand
Public Class FindInRicercaCommand
    Inherits DedDocumentCommand
public ref class FindInRicercaCommand : public DedDocumentCommand
type FindInRicercaCommand =
    class
        inherit DedDocumentCommand
    end

Il tipo FindInRicercaCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DocumentInfos | Restituisce la lista dei documenti con abbinato il contesto di anagrafica di elaborazione comando. (Ereditato da DedDocumentCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedDocumentCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Reinizializza il comando. (Ereditato da DedDocumentCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedDocumentCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedDocumentCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedDocumentCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedDocumentCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di FindInRicercaCommand

Il tipo FindInRicercaCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DocumentInfos | Restituisce la lista dei documenti con abbinato il contesto di anagrafica di elaborazione comando. (Ereditato da DedDocumentCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedDocumentCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe FindInRicercaCommand
Namespace DedNet.Commands


Proprietà FindInRicercaCommand.NeedParameters

Proprietà FindInRicercaCommandNeedParameters

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe FindInRicercaCommand
Namespace DedNet.Commands


Metodi di FindInRicercaCommand

Il tipo FindInRicercaCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Reinizializza il comando. (Ereditato da DedDocumentCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedDocumentCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedDocumentCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedDocumentCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedDocumentCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe FindInRicercaCommand
Namespace DedNet.Commands


Metodo FindInRicercaCommand.Enabled

Metodo FindInRicercaCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe FindInRicercaCommand
Namespace DedNet.Commands


Metodo FindInRicercaCommand.ExecuteCommand

Metodo FindInRicercaCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe FindInRicercaCommand
Namespace DedNet.Commands


Metodo FindInRicercaCommand.SetContext

Metodo FindInRicercaCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe FindInRicercaCommand
Namespace DedNet.Commands


Classe ForceMarkerAlingmentCommand
Comando per forzare l'allinemento del documento nel caso si DFS attivo.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsDedDocumentCommand
DedNet.CommandsForceMarkerAlingmentCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ForceMarkerAlingmentCommand : DedDocumentCommand
Public Class ForceMarkerAlingmentCommand
    Inherits DedDocumentCommand
public ref class ForceMarkerAlingmentCommand : public DedDocumentCommand
type ForceMarkerAlingmentCommand =
    class
        inherit DedDocumentCommand
    end

Il tipo ForceMarkerAlingmentCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DocumentInfos | Restituisce la lista dei documenti con abbinato il contesto di anagrafica di elaborazione comando. (Ereditato da DedDocumentCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedDocumentCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Reinizializza il comando. (Ereditato da DedDocumentCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedDocumentCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedDocumentCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedDocumentCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedDocumentCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di ForceMarkerAlingmentCommand

Il tipo ForceMarkerAlingmentCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DocumentInfos | Restituisce la lista dei documenti con abbinato il contesto di anagrafica di elaborazione comando. (Ereditato da DedDocumentCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedDocumentCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ForceMarkerAlingmentCommand
Namespace DedNet.Commands


Proprietà ForceMarkerAlingmentCommand.NeedParameters

Proprietà ForceMarkerAlingmentCommandNeedParameters

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ForceMarkerAlingmentCommand
Namespace DedNet.Commands


Metodi di ForceMarkerAlingmentCommand

Il tipo ForceMarkerAlingmentCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Reinizializza il comando. (Ereditato da DedDocumentCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedDocumentCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedDocumentCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedDocumentCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedDocumentCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ForceMarkerAlingmentCommand
Namespace DedNet.Commands


Metodo ForceMarkerAlingmentCommand.Enabled

Metodo ForceMarkerAlingmentCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe ForceMarkerAlingmentCommand
Namespace DedNet.Commands


Metodo ForceMarkerAlingmentCommand.ExecuteCommand

Metodo ForceMarkerAlingmentCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe ForceMarkerAlingmentCommand
Namespace DedNet.Commands


Metodo ForceMarkerAlingmentCommand.SetContext

Metodo ForceMarkerAlingmentCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe ForceMarkerAlingmentCommand
Namespace DedNet.Commands


Classe ForzaCheckInDocument
Effettua il checkin forzato dei documenti. I documenti presenti nell'area locale non vengono rimossi (verranno mantenuti quelli presenti sul server). Se si imposta l'opzione Struttura viene effettuato il checkin dei documenti di testata più tutte le dipendenze che risultano in checkout.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsForzaCheckInDocument

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ForzaCheckInDocument : DedCommand
Public Class ForzaCheckInDocument
    Inherits DedCommand
public ref class ForzaCheckInDocument : public DedCommand
type ForzaCheckInDocument =
    class
        inherit DedCommand
    end

Il tipo ForzaCheckInDocument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | FileList | Restituisce la lista dei documenti da impostare in checkout. Inserire in questa lista solo i file che si desidera elaborare e non le dipendenze.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non sono presenti documenti da elaborare. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | Restitusice o imposta se il check-in debba essere effettuato su tutta la struttura (di default è false).
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di ForzaCheckInDocument

Il tipo ForzaCheckInDocument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | FileList | Restituisce la lista dei documenti da impostare in checkout. Inserire in questa lista solo i file che si desidera elaborare e non le dipendenze.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non sono presenti documenti da elaborare. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | Restitusice o imposta se il check-in debba essere effettuato su tutta la struttura (di default è false).
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ForzaCheckInDocument
Namespace DedNet.Commands


Proprietà ForzaCheckInDocument.FileList

Proprietà ForzaCheckInDocumentFileList
Restituisce la lista dei documenti da impostare in checkout. Inserire in questa lista solo i file che si desidera elaborare e non le dipendenze.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfoList FileList { get; }
Public ReadOnly Property FileList As DocStructInfoList
    Get
public:
property DocStructInfoList^ FileList {
    DocStructInfoList^ get ();
}
member FileList : DocStructInfoList with get

Valore della proprietà

DocStructInfoList
Vedi anche

Documentazione

Classe ForzaCheckInDocument
Namespace DedNet.Commands


Proprietà ForzaCheckInDocument.NeedParameters

Proprietà ForzaCheckInDocumentNeedParameters
Restituisce true se non sono presenti documenti da elaborare.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ForzaCheckInDocument
Namespace DedNet.Commands


Proprietà ForzaCheckInDocument.Struttura

Proprietà ForzaCheckInDocumentStruttura
Restitusice o imposta se il check-in debba essere effettuato su tutta la struttura (di default è false).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Struttura { get; set; }
Public Property Struttura As Boolean
    Get
    Set
public:
property bool Struttura {
    bool get ();
    void set (bool value);
}
member Struttura : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ForzaCheckInDocument
Namespace DedNet.Commands


Metodi di ForzaCheckInDocument

Il tipo ForzaCheckInDocument espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ForzaCheckInDocument
Namespace DedNet.Commands


Metodo ForzaCheckInDocument.ClearCommand

Metodo ForzaCheckInDocumentClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe ForzaCheckInDocument
Namespace DedNet.Commands


Metodo ForzaCheckInDocument.Enabled

Metodo ForzaCheckInDocumentEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe ForzaCheckInDocument
Namespace DedNet.Commands


Metodo ForzaCheckInDocument.ExecuteCommand

Metodo ForzaCheckInDocumentExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe ForzaCheckInDocument
Namespace DedNet.Commands


Metodo ForzaCheckInDocument.SetContext

Metodo ForzaCheckInDocumentSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto c'è una sola anagrafica alla quale associare il file.
Vedi anche

Documentazione

Classe ForzaCheckInDocument
Namespace DedNet.Commands


Classe GridInfoDataList
Lista bindabile alla griglia per la gestione dei documenti primari ed allegati in fase di creazione di una nuova revisione.
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList GridInfoDataRow
DedNet.CommandsGridInfoDataList

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class GridInfoDataList : List<GridInfoDataRow>
Public Class GridInfoDataList
    Inherits List(Of GridInfoDataRow)
public ref class GridInfoDataList : public List<GridInfoDataRow^>
type GridInfoDataList =
    class
        inherit List<GridInfoDataRow>
    end

Il tipo GridInfoDataList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | GridInfoDataList | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllSelectedDocs | Restituisce la lista dei documenti di partenza che risultano selezionati. All'interno ci possono essere anche i DocStructInfo che il client mi ha passato di file non ancora registrati nel Database. Restituisce sempre una lista inizializzata.
Proprietà pubblica | AttachBehaviour | Restituisce il comportamento per gli allegati preselezionato o scelto dall'utente.
Proprietà pubblica | AttachToManage | Lista degli allegati da gestire (impostata dal chiamante)
Proprietà pubblica | ClientDocs | Restituisce la lista dei documenti primari di interesse del client.
Proprietà pubblica | ContainsAttach | Restituisce true se l'anagrafica di partenza contiene degli allegati
Proprietà pubblica | EnableLinkNotCopy | Restituisce/Imposta se abilitare il flag di linknocopy
Proprietà pubblica | ForcedMoveInfo |
Proprietà pubblica | FromDocList | Restituisce la lista dei documenti primari di partenza.
Proprietà pubblica | IsRevNewType | Restituisce se si tratti di una revisione senza tassello della revisione nel nome file.
Proprietà pubblica | LastRevData | Restituisce/Imposta l'ultima revisione
Proprietà pubblica | LinkNotCopy | Restituisce/Imposta il flag che indica se linkare i documenti invece di copiarli
Proprietà pubblica | Mdres |
Proprietà pubblica | NewData | Restituisce/Imposta l'anagrafica di destinazione dei documenti
Proprietà pubblica | OperationKind | REstituisce/Imposta il tipo di operazione in corso
Proprietà pubblica | PrimaryContext | Restituisce/Imposta il flag di file primari o meno
Proprietà pubblica | SelectedClientDocs | Restituisce la lista dei documenti di partenza che risultano selezionati. All'interno ci possono essere anche i DocStructInfo che il client mi ha passato di file non ancora registrati nel Database. Restituisce sempre una lista inizializzata.
Proprietà pubblica | SelectedFromDocs | Restituisce la lista dei documenti di partenza che risultano selezionati. All'interno ci possono essere anche i DocStructInfo che il client mi ha passato di file non ancora registrati nel Database. Restituisce sempre una lista inizializzata.
Proprietà pubblica | SelectedFromDocsExcludedClient | Restituisce la lista dei documenti di partenza che risultano selezionati. All'interno ci possono essere anche i DocStructInfo che il client mi ha passato di file non ancora registrati nel Database. Restituisce sempre una lista inizializzata.
Proprietà pubblica | SelectedToDocs | Restituisce la lista dei documenti di arrivo che risultano selezionati. Restituisce sempre una lista inizializzata.
Proprietà pubblica | StartCodIsLastRev | Restituisce se il codice di partenza sia o meno anche l'ultima revisione.
Proprietà pubblica | StartData | Restituisce l'anagrafica di partenza
Proprietà pubblica | ToDocList | Restituisce la lista dei documenti primari di arrivo.
Proprietà pubblica | UserCanChoose | Restituisce true se l'utente può scegliere qualcosa nel form
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Costruttore GridInfoDataList
Costruttore unico.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public GridInfoDataList(
    DedNetApplication app,
    DocStructInfoList clientDocs,
    DedData startData,
    DedData newData,
    OperationKindEnum operationKind
)
Public Sub New (
    app As DedNetApplication,
    clientDocs As DocStructInfoList,
    startData As DedData,
    newData As DedData,
    operationKind As OperationKindEnum
)
public:
GridInfoDataList(
    DedNetApplication^ app,
    DocStructInfoList^ clientDocs,
    DedData^ startData,
    DedData^ newData,
    OperationKindEnum operationKind
)
new :
        app : DedNetApplication *
        clientDocs : DocStructInfoList *
        startData : DedData *
        newData : DedData *
        operationKind : OperationKindEnum -> GridInfoDataList

Parametri

app DedNetApplication
DedNetApplication
clientDocs DocStructInfoList
Lista doc. di interesse del client.
startData DedData
Anagrafica di partenza
newData DedData
Anagrafica di destinazione
operationKind OperationKindEnum
Tipo di operazione in corso
Vedi anche

Documentazione

Classe GridInfoDataList
Namespace DedNet.Commands


Proprietà di GridInfoDataList

Il tipo GridInfoDataList espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllSelectedDocs | Restituisce la lista dei documenti di partenza che risultano selezionati. All'interno ci possono essere anche i DocStructInfo che il client mi ha passato di file non ancora registrati nel Database. Restituisce sempre una lista inizializzata.
Proprietà pubblica | AttachBehaviour | Restituisce il comportamento per gli allegati preselezionato o scelto dall'utente.
Proprietà pubblica | AttachToManage | Lista degli allegati da gestire (impostata dal chiamante)
Proprietà pubblica | ClientDocs | Restituisce la lista dei documenti primari di interesse del client.
Proprietà pubblica | ContainsAttach | Restituisce true se l'anagrafica di partenza contiene degli allegati
Proprietà pubblica | EnableLinkNotCopy | Restituisce/Imposta se abilitare il flag di linknocopy
Proprietà pubblica | ForcedMoveInfo |
Proprietà pubblica | FromDocList | Restituisce la lista dei documenti primari di partenza.
Proprietà pubblica | IsRevNewType | Restituisce se si tratti di una revisione senza tassello della revisione nel nome file.
Proprietà pubblica | LastRevData | Restituisce/Imposta l'ultima revisione
Proprietà pubblica | LinkNotCopy | Restituisce/Imposta il flag che indica se linkare i documenti invece di copiarli
Proprietà pubblica | Mdres |
Proprietà pubblica | NewData | Restituisce/Imposta l'anagrafica di destinazione dei documenti
Proprietà pubblica | OperationKind | REstituisce/Imposta il tipo di operazione in corso
Proprietà pubblica | PrimaryContext | Restituisce/Imposta il flag di file primari o meno
Proprietà pubblica | SelectedClientDocs | Restituisce la lista dei documenti di partenza che risultano selezionati. All'interno ci possono essere anche i DocStructInfo che il client mi ha passato di file non ancora registrati nel Database. Restituisce sempre una lista inizializzata.
Proprietà pubblica | SelectedFromDocs | Restituisce la lista dei documenti di partenza che risultano selezionati. All'interno ci possono essere anche i DocStructInfo che il client mi ha passato di file non ancora registrati nel Database. Restituisce sempre una lista inizializzata.
Proprietà pubblica | SelectedFromDocsExcludedClient | Restituisce la lista dei documenti di partenza che risultano selezionati. All'interno ci possono essere anche i DocStructInfo che il client mi ha passato di file non ancora registrati nel Database. Restituisce sempre una lista inizializzata.
Proprietà pubblica | SelectedToDocs | Restituisce la lista dei documenti di arrivo che risultano selezionati. Restituisce sempre una lista inizializzata.
Proprietà pubblica | StartCodIsLastRev | Restituisce se il codice di partenza sia o meno anche l'ultima revisione.
Proprietà pubblica | StartData | Restituisce l'anagrafica di partenza
Proprietà pubblica | ToDocList | Restituisce la lista dei documenti primari di arrivo.
Proprietà pubblica | UserCanChoose | Restituisce true se l'utente può scegliere qualcosa nel form
Torna su
Vedi anche

Documentazione

Classe GridInfoDataList
Namespace DedNet.Commands


Proprietà GridInfoDataList.AllSelectedDocs

Proprietà GridInfoDataListAllSelectedDocs
Restituisce la lista dei documenti di partenza che risultano selezionati. All'interno ci possono essere anche i DocStructInfo che il client mi ha passato di file non ancora registrati nel Database. Restituisce sempre una lista inizializzata.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfoList AllSelectedDocs { get; }
Public ReadOnly Property AllSelectedDocs As DocStructInfoList
    Get
public:
property DocStructInfoList^ AllSelectedDocs {
    DocStructInfoList^ get ();
}
member AllSelectedDocs : DocStructInfoList with get

Valore della proprietà

DocStructInfoList
Vedi anche

Documentazione

Classe GridInfoDataList
Namespace DedNet.Commands


Proprietà GridInfoDataList.AttachBehaviour

Proprietà GridInfoDataListAttachBehaviour
Restituisce il comportamento per gli allegati preselezionato o scelto dall'utente.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public AttachBehaviourEnum AttachBehaviour { get; set; }
Public Property AttachBehaviour As AttachBehaviourEnum
    Get
    Set
public:
property AttachBehaviourEnum AttachBehaviour {
    AttachBehaviourEnum get ();
    void set (AttachBehaviourEnum value);
}
member AttachBehaviour : AttachBehaviourEnum with get, set

Valore della proprietà

AttachBehaviourEnum
Vedi anche

Documentazione

Classe GridInfoDataList
Namespace DedNet.Commands


Proprietà GridInfoDataList.AttachToManage

Proprietà GridInfoDataListAttachToManage
Lista degli allegati da gestire (impostata dal chiamante)

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfoList AttachToManage { get; set; }
Public Property AttachToManage As DocStructInfoList
    Get
    Set
public:
property DocStructInfoList^ AttachToManage {
    DocStructInfoList^ get ();
    void set (DocStructInfoList^ value);
}
member AttachToManage : DocStructInfoList with get, set

Valore della proprietà

DocStructInfoList
Vedi anche

Documentazione

Classe GridInfoDataList
Namespace DedNet.Commands


Proprietà GridInfoDataList.ClientDocs

Proprietà GridInfoDataListClientDocs
Restituisce la lista dei documenti primari di interesse del client.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfoList ClientDocs { get; }
Public ReadOnly Property ClientDocs As DocStructInfoList
    Get
public:
property DocStructInfoList^ ClientDocs {
    DocStructInfoList^ get ();
}
member ClientDocs : DocStructInfoList with get

Valore della proprietà

DocStructInfoList
Vedi anche

Documentazione

Classe GridInfoDataList
Namespace DedNet.Commands


Proprietà GridInfoDataList.ContainsAttach

Proprietà GridInfoDataListContainsAttach
Restituisce true se l'anagrafica di partenza contiene degli allegati

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ContainsAttach { get; }
Public ReadOnly Property ContainsAttach As Boolean
    Get
public:
property bool ContainsAttach {
    bool get ();
}
member ContainsAttach : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe GridInfoDataList
Namespace DedNet.Commands


Proprietà GridInfoDataList.EnableLinkNotCopy

Proprietà GridInfoDataListEnableLinkNotCopy
Restituisce/Imposta se abilitare il flag di linknocopy

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool EnableLinkNotCopy { get; set; }
Public Property EnableLinkNotCopy As Boolean
    Get
    Set
public:
property bool EnableLinkNotCopy {
    bool get ();
    void set (bool value);
}
member EnableLinkNotCopy : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe GridInfoDataList
Namespace DedNet.Commands


Proprietà GridInfoDataList.ForcedMoveInfo

Proprietà GridInfoDataListForcedMoveInfo

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public MoveDocumentInfoForcedMoveInfo ForcedMoveInfo { get; }
Public ReadOnly Property ForcedMoveInfo As MoveDocumentInfoForcedMoveInfo
    Get
public:
property MoveDocumentInfoForcedMoveInfo^ ForcedMoveInfo {
    MoveDocumentInfoForcedMoveInfo^ get ();
}
member ForcedMoveInfo : MoveDocumentInfoForcedMoveInfo with get

Valore della proprietà

MoveDocumentInfoForcedMoveInfo
Vedi anche

Documentazione

Classe GridInfoDataList
Namespace DedNet.Commands


Proprietà GridInfoDataList.FromDocList

Proprietà GridInfoDataListFromDocList
Restituisce la lista dei documenti primari di partenza.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocList FromDocList { get; }
Public ReadOnly Property FromDocList As DedDocList
    Get
public:
property DedDocList^ FromDocList {
    DedDocList^ get ();
}
member FromDocList : DedDocList with get

Valore della proprietà

DedDocList
Vedi anche

Documentazione

Classe GridInfoDataList
Namespace DedNet.Commands


Proprietà GridInfoDataList.IsRevNewType

Proprietà GridInfoDataListIsRevNewType
Restituisce se si tratti di una revisione senza tassello della revisione nel nome file.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsRevNewType { get; }
Public ReadOnly Property IsRevNewType As Boolean
    Get
public:
property bool IsRevNewType {
    bool get ();
}
member IsRevNewType : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe GridInfoDataList
Namespace DedNet.Commands


Proprietà GridInfoDataList.LastRevData

Proprietà GridInfoDataListLastRevData
Restituisce/Imposta l'ultima revisione

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData LastRevData { get; set; }
Public Property LastRevData As DedData
    Get
    Set
public:
property DedData^ LastRevData {
    DedData^ get ();
    void set (DedData^ value);
}
member LastRevData : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe GridInfoDataList
Namespace DedNet.Commands


Proprietà GridInfoDataList.LinkNotCopy

Proprietà GridInfoDataListLinkNotCopy
Restituisce/Imposta il flag che indica se linkare i documenti invece di copiarli

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool LinkNotCopy { get; set; }
Public Property LinkNotCopy As Boolean
    Get
    Set
public:
property bool LinkNotCopy {
    bool get ();
    void set (bool value);
}
member LinkNotCopy : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe GridInfoDataList
Namespace DedNet.Commands


Proprietà GridInfoDataList.Mdres

Proprietà GridInfoDataListMdres

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public MoveDocumentResult Mdres { get; set; }
Public Property Mdres As MoveDocumentResult
    Get
    Set
public:
property MoveDocumentResult^ Mdres {
    MoveDocumentResult^ get ();
    void set (MoveDocumentResult^ value);
}
member Mdres : MoveDocumentResult with get, set

Valore della proprietà

MoveDocumentResult
Vedi anche

Documentazione

Classe GridInfoDataList
Namespace DedNet.Commands


Proprietà GridInfoDataList.NewData

Proprietà GridInfoDataListNewData
Restituisce/Imposta l'anagrafica di destinazione dei documenti

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData NewData { get; set; }
Public Property NewData As DedData
    Get
    Set
public:
property DedData^ NewData {
    DedData^ get ();
    void set (DedData^ value);
}
member NewData : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe GridInfoDataList
Namespace DedNet.Commands


Proprietà GridInfoDataList.OperationKind

Proprietà GridInfoDataListOperationKind
REstituisce/Imposta il tipo di operazione in corso

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public OperationKindEnum OperationKind { get; set; }
Public Property OperationKind As OperationKindEnum
    Get
    Set
public:
property OperationKindEnum OperationKind {
    OperationKindEnum get ();
    void set (OperationKindEnum value);
}
member OperationKind : OperationKindEnum with get, set

Valore della proprietà

OperationKindEnum
Vedi anche

Documentazione

Classe GridInfoDataList
Namespace DedNet.Commands


Proprietà GridInfoDataList.PrimaryContext

Proprietà GridInfoDataListPrimaryContext
Restituisce/Imposta il flag di file primari o meno

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool PrimaryContext { get; set; }
Public Property PrimaryContext As Boolean
    Get
    Set
public:
property bool PrimaryContext {
    bool get ();
    void set (bool value);
}
member PrimaryContext : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe GridInfoDataList
Namespace DedNet.Commands


Proprietà GridInfoDataList.SelectedClientDocs

Proprietà GridInfoDataListSelectedClientDocs
Restituisce la lista dei documenti di partenza che risultano selezionati. All'interno ci possono essere anche i DocStructInfo che il client mi ha passato di file non ancora registrati nel Database. Restituisce sempre una lista inizializzata.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfoList SelectedClientDocs { get; }
Public ReadOnly Property SelectedClientDocs As DocStructInfoList
    Get
public:
property DocStructInfoList^ SelectedClientDocs {
    DocStructInfoList^ get ();
}
member SelectedClientDocs : DocStructInfoList with get

Valore della proprietà

DocStructInfoList
Vedi anche

Documentazione

Classe GridInfoDataList
Namespace DedNet.Commands


Proprietà GridInfoDataList.SelectedFromDocs

Proprietà GridInfoDataListSelectedFromDocs
Restituisce la lista dei documenti di partenza che risultano selezionati. All'interno ci possono essere anche i DocStructInfo che il client mi ha passato di file non ancora registrati nel Database. Restituisce sempre una lista inizializzata.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfoList SelectedFromDocs { get; }
Public ReadOnly Property SelectedFromDocs As DocStructInfoList
    Get
public:
property DocStructInfoList^ SelectedFromDocs {
    DocStructInfoList^ get ();
}
member SelectedFromDocs : DocStructInfoList with get

Valore della proprietà

DocStructInfoList
Vedi anche

Documentazione

Classe GridInfoDataList
Namespace DedNet.Commands


Proprietà GridInfoDataList.SelectedFromDocsExcludedClient

Proprietà GridInfoDataListSelectedFromDocsExcludedClient
Restituisce la lista dei documenti di partenza che risultano selezionati. All'interno ci possono essere anche i DocStructInfo che il client mi ha passato di file non ancora registrati nel Database. Restituisce sempre una lista inizializzata.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfoList SelectedFromDocsExcludedClient { get; }
Public ReadOnly Property SelectedFromDocsExcludedClient As DocStructInfoList
    Get
public:
property DocStructInfoList^ SelectedFromDocsExcludedClient {
    DocStructInfoList^ get ();
}
member SelectedFromDocsExcludedClient : DocStructInfoList with get

Valore della proprietà

DocStructInfoList
Vedi anche

Documentazione

Classe GridInfoDataList
Namespace DedNet.Commands


Proprietà GridInfoDataList.SelectedToDocs

Proprietà GridInfoDataListSelectedToDocs
Restituisce la lista dei documenti di arrivo che risultano selezionati. Restituisce sempre una lista inizializzata.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfoList SelectedToDocs { get; }
Public ReadOnly Property SelectedToDocs As DocStructInfoList
    Get
public:
property DocStructInfoList^ SelectedToDocs {
    DocStructInfoList^ get ();
}
member SelectedToDocs : DocStructInfoList with get

Valore della proprietà

DocStructInfoList
Vedi anche

Documentazione

Classe GridInfoDataList
Namespace DedNet.Commands


Proprietà GridInfoDataList.StartCodIsLastRev

Proprietà GridInfoDataListStartCodIsLastRev
Restituisce se il codice di partenza sia o meno anche l'ultima revisione.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool StartCodIsLastRev { get; }
Public ReadOnly Property StartCodIsLastRev As Boolean
    Get
public:
property bool StartCodIsLastRev {
    bool get ();
}
member StartCodIsLastRev : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe GridInfoDataList
Namespace DedNet.Commands


Proprietà GridInfoDataList.StartData

Proprietà GridInfoDataListStartData
Restituisce l'anagrafica di partenza

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData StartData { get; }
Public ReadOnly Property StartData As DedData
    Get
public:
property DedData^ StartData {
    DedData^ get ();
}
member StartData : DedData with get

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe GridInfoDataList
Namespace DedNet.Commands


Proprietà GridInfoDataList.ToDocList

Proprietà GridInfoDataListToDocList
Restituisce la lista dei documenti primari di arrivo.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocList ToDocList { get; }
Public ReadOnly Property ToDocList As DedDocList
    Get
public:
property DedDocList^ ToDocList {
    DedDocList^ get ();
}
member ToDocList : DedDocList with get

Valore della proprietà

DedDocList
Vedi anche

Documentazione

Classe GridInfoDataList
Namespace DedNet.Commands


Proprietà GridInfoDataList.UserCanChoose

Proprietà GridInfoDataListUserCanChoose
Restituisce true se l'utente può scegliere qualcosa nel form

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool UserCanChoose { get; }
Public ReadOnly Property UserCanChoose As Boolean
    Get
public:
property bool UserCanChoose {
    bool get ();
}
member UserCanChoose : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe GridInfoDataList
Namespace DedNet.Commands


Classe GridInfoDataRow
Singolo elemento bindabile alla griglia specificante una riga. Attraverso questo elemento si memorizza quale documento si desidera portare nella nuova revisione.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsGridInfoDataRow

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class GridInfoDataRow
Public Class GridInfoDataRow
public ref class GridInfoDataRow
type GridInfoDataRow = class end

Il tipo GridInfoDataRow espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Context | Restituisce il contesto del documento
Proprietà pubblica | Enabled | Restituisce o imposta se l'utente possa modificare l'elemento. Dipende se il documento è di interesse del client.
Proprietà pubblica | FromDoc |
Proprietà pubblica | FromFile |
Proprietà pubblica | FromFullFileName | Restituisce il percorso completo del documento di partenza.
Proprietà pubblica | FromId | Restituisce l'id del doc. di partenza.
Proprietà pubblica | FromValue |
Proprietà pubblica | InfoClient | Restituisce o imposta le informazioni dell'elemento di partenza, passate dal client.
Proprietà pubblica | NewId | Restituisce l'id del nuovo documento alla fine dell'operazione. Usato dal comando per la sostituzione degli id documento nelle dipendenze dei padri.
Proprietà pubblica | ToDoc |
Proprietà pubblica | ToDocInfo |
Proprietà pubblica | ToFile |
Proprietà pubblica | ToFullFileName | Restituisce il percorso completo del documento di arrivo.
Proprietà pubblica | ToId | Restituisce l'id del doc. di arrivo.
Proprietà pubblica | ToValue |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di GridInfoDataRow

Il tipo GridInfoDataRow espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Context | Restituisce il contesto del documento
Proprietà pubblica | Enabled | Restituisce o imposta se l'utente possa modificare l'elemento. Dipende se il documento è di interesse del client.
Proprietà pubblica | FromDoc |
Proprietà pubblica | FromFile |
Proprietà pubblica | FromFullFileName | Restituisce il percorso completo del documento di partenza.
Proprietà pubblica | FromId | Restituisce l'id del doc. di partenza.
Proprietà pubblica | FromValue |
Proprietà pubblica | InfoClient | Restituisce o imposta le informazioni dell'elemento di partenza, passate dal client.
Proprietà pubblica | NewId | Restituisce l'id del nuovo documento alla fine dell'operazione. Usato dal comando per la sostituzione degli id documento nelle dipendenze dei padri.
Proprietà pubblica | ToDoc |
Proprietà pubblica | ToDocInfo |
Proprietà pubblica | ToFile |
Proprietà pubblica | ToFullFileName | Restituisce il percorso completo del documento di arrivo.
Proprietà pubblica | ToId | Restituisce l'id del doc. di arrivo.
Proprietà pubblica | ToValue |
Torna su
Vedi anche

Documentazione

Classe GridInfoDataRow
Namespace DedNet.Commands


Proprietà GridInfoDataRow.Context

Proprietà GridInfoDataRowContext
Restituisce il contesto del documento

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocContextEnum Context { get; set; }
Public Property Context As DedDocContextEnum
    Get
    Set
public:
property DedDocContextEnum Context {
    DedDocContextEnum get ();
    void set (DedDocContextEnum value);
}
member Context : DedDocContextEnum with get, set

Valore della proprietà

DedDocContextEnum
Vedi anche

Documentazione

Classe GridInfoDataRow
Namespace DedNet.Commands


Proprietà GridInfoDataRow.Enabled

Proprietà GridInfoDataRowEnabled
Restituisce o imposta se l'utente possa modificare l'elemento. Dipende se il documento è di interesse del client.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
member Enabled : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe GridInfoDataRow
Namespace DedNet.Commands


Proprietà GridInfoDataRow.FromDoc

Proprietà GridInfoDataRowFromDoc

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDoc FromDoc { get; set; }
Public Property FromDoc As DedDoc
    Get
    Set
public:
property DedDoc^ FromDoc {
    DedDoc^ get ();
    void set (DedDoc^ value);
}
member FromDoc : DedDoc with get, set

Valore della proprietà

DedDoc
Vedi anche

Documentazione

Classe GridInfoDataRow
Namespace DedNet.Commands


Proprietà GridInfoDataRow.FromFile

Proprietà GridInfoDataRowFromFile

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string FromFile { get; set; }
Public Property FromFile As String
    Get
    Set
public:
property String^ FromFile {
    String^ get ();
    void set (String^ value);
}
member FromFile : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe GridInfoDataRow
Namespace DedNet.Commands


Proprietà GridInfoDataRow.FromFullFileName

Proprietà GridInfoDataRowFromFullFileName
Restituisce il percorso completo del documento di partenza.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string FromFullFileName { get; set; }
Public Property FromFullFileName As String
    Get
    Set
public:
property String^ FromFullFileName {
    String^ get ();
    void set (String^ value);
}
member FromFullFileName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe GridInfoDataRow
Namespace DedNet.Commands


Proprietà GridInfoDataRow.FromId

Proprietà GridInfoDataRowFromId
Restituisce l'id del doc. di partenza.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Guid FromId { get; }
Public ReadOnly Property FromId As Guid
    Get
public:
property Guid FromId {
    Guid get ();
}
member FromId : Guid with get

Valore della proprietà

Guid
Vedi anche

Documentazione

Classe GridInfoDataRow
Namespace DedNet.Commands


Proprietà GridInfoDataRow.FromValue

Proprietà GridInfoDataRowFromValue

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool FromValue { get; set; }
Public Property FromValue As Boolean
    Get
    Set
public:
property bool FromValue {
    bool get ();
    void set (bool value);
}
member FromValue : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe GridInfoDataRow
Namespace DedNet.Commands


Proprietà GridInfoDataRow.InfoClient

Proprietà GridInfoDataRowInfoClient
Restituisce o imposta le informazioni dell'elemento di partenza, passate dal client.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfo InfoClient { get; set; }
Public Property InfoClient As DocStructInfo
    Get
    Set
public:
property DocStructInfo^ InfoClient {
    DocStructInfo^ get ();
    void set (DocStructInfo^ value);
}
member InfoClient : DocStructInfo with get, set

Valore della proprietà

DocStructInfo
Vedi anche

Documentazione

Classe GridInfoDataRow
Namespace DedNet.Commands


Proprietà GridInfoDataRow.NewId

Proprietà GridInfoDataRowNewId
Restituisce l'id del nuovo documento alla fine dell'operazione. Usato dal comando per la sostituzione degli id documento nelle dipendenze dei padri.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Guid NewId { get; set; }
Public Property NewId As Guid
    Get
    Set
public:
property Guid NewId {
    Guid get ();
    void set (Guid value);
}
member NewId : Guid with get, set

Valore della proprietà

Guid
Vedi anche

Documentazione

Classe GridInfoDataRow
Namespace DedNet.Commands


Proprietà GridInfoDataRow.ToDoc

Proprietà GridInfoDataRowToDoc

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDoc ToDoc { get; set; }
Public Property ToDoc As DedDoc
    Get
    Set
public:
property DedDoc^ ToDoc {
    DedDoc^ get ();
    void set (DedDoc^ value);
}
member ToDoc : DedDoc with get, set

Valore della proprietà

DedDoc
Vedi anche

Documentazione

Classe GridInfoDataRow
Namespace DedNet.Commands


Proprietà GridInfoDataRow.ToDocInfo

Proprietà GridInfoDataRowToDocInfo

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfo ToDocInfo { get; set; }
Public Property ToDocInfo As DocStructInfo
    Get
    Set
public:
property DocStructInfo^ ToDocInfo {
    DocStructInfo^ get ();
    void set (DocStructInfo^ value);
}
member ToDocInfo : DocStructInfo with get, set

Valore della proprietà

DocStructInfo
Vedi anche

Documentazione

Classe GridInfoDataRow
Namespace DedNet.Commands


Proprietà GridInfoDataRow.ToFile

Proprietà GridInfoDataRowToFile

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string ToFile { get; set; }
Public Property ToFile As String
    Get
    Set
public:
property String^ ToFile {
    String^ get ();
    void set (String^ value);
}
member ToFile : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe GridInfoDataRow
Namespace DedNet.Commands


Proprietà GridInfoDataRow.ToFullFileName

Proprietà GridInfoDataRowToFullFileName
Restituisce il percorso completo del documento di arrivo.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string ToFullFileName { get; set; }
Public Property ToFullFileName As String
    Get
    Set
public:
property String^ ToFullFileName {
    String^ get ();
    void set (String^ value);
}
member ToFullFileName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe GridInfoDataRow
Namespace DedNet.Commands


Proprietà GridInfoDataRow.ToId

Proprietà GridInfoDataRowToId
Restituisce l'id del doc. di arrivo.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Guid ToId { get; }
Public ReadOnly Property ToId As Guid
    Get
public:
property Guid ToId {
    Guid get ();
}
member ToId : Guid with get

Valore della proprietà

Guid
Vedi anche

Documentazione

Classe GridInfoDataRow
Namespace DedNet.Commands


Proprietà GridInfoDataRow.ToValue

Proprietà GridInfoDataRowToValue

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ToValue { get; set; }
Public Property ToValue As Boolean
    Get
    Set
public:
property bool ToValue {
    bool get ();
    void set (bool value);
}
member ToValue : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe GridInfoDataRow
Namespace DedNet.Commands


Interfaccia IMoveCopyDocumentItem
Interfaccia comune agli oggetti contenenti informazioni sullo spostamento/copia dei file.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public interface IMoveCopyDocumentItem
Public Interface IMoveCopyDocumentItem
public interface class IMoveCopyDocumentItem
type IMoveCopyDocumentItem = interface end

Il tipo IMoveCopyDocumentItem espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | InfoItem |
Proprietà pubblica | NewPath |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di IMoveCopyDocumentItem

Il tipo IMoveCopyDocumentItem espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | InfoItem |
Proprietà pubblica | NewPath |
Torna su
Vedi anche

Documentazione

Interfaccia IMoveCopyDocumentItem
Namespace DedNet.Commands


Proprietà IMoveCopyDocumentItem.InfoItem

Proprietà IMoveCopyDocumentItemInfoItem

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
DocStructInfo InfoItem { get; }
ReadOnly Property InfoItem As DocStructInfo
    Get
property DocStructInfo^ InfoItem {
    DocStructInfo^ get ();
}
abstract InfoItem : DocStructInfo with get

Valore della proprietà

DocStructInfo
Vedi anche

Documentazione

Interfaccia IMoveCopyDocumentItem
Namespace DedNet.Commands


Proprietà IMoveCopyDocumentItem.NewPath

Proprietà IMoveCopyDocumentItemNewPath

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
string NewPath { get; set; }
Property NewPath As String
    Get
    Set
property String^ NewPath {
    String^ get ();
    void set (String^ value);
}
abstract NewPath : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Interfaccia IMoveCopyDocumentItem
Namespace DedNet.Commands


Classe ImportCommDocument
Associa uno o più documenti ad una commessa.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsImportCommDocument

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ImportCommDocument : DedCommand
Public Class ImportCommDocument
    Inherits DedCommand
public ref class ImportCommDocument : public DedCommand
type ImportCommDocument =
    class
        inherit DedCommand
    end

Il tipo ImportCommDocument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Comm | Restituisce o imposta la commessa nella quale importare i documenti.
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DelegateFileCopy | Restituisce o imposta il delegate che, dopo la creazione dei record, viene chiamato dal comando per la copia effettiva dei file. Se viene lasciato vuoto la copia viene effettuatata dal comando. Chi implementa il delegate dovrebbe sollevare eccezioni in caso di errore per interrompere ed annullare tutta la procedura di importazione documenti.
Proprietà pubblica | FileList | Restituisce la lista dei file da importare come documenti e da associare alla commessa. Inserire in questa lista solo i file che si desidera importare e non le dipendenze, a meno ché non siano a loro volta da importare.
Proprietà pubblica | FileListSuccess | Restituisce la lista dei file che hanno finito con successo le varie operazioni di spostamento
Proprietà pubblica | Folder | Cartella di destinazione
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsDocSelection | Restituisce o imposta se si tratta di una selezione di documenti o file ( default = file ).
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non è impostata la commessa nella quale importare il documento. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere la commessa alla quale associare il file. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere la commessa alla quale associare il file. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di ImportCommDocument

Il tipo ImportCommDocument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Comm | Restituisce o imposta la commessa nella quale importare i documenti.
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DelegateFileCopy | Restituisce o imposta il delegate che, dopo la creazione dei record, viene chiamato dal comando per la copia effettiva dei file. Se viene lasciato vuoto la copia viene effettuatata dal comando. Chi implementa il delegate dovrebbe sollevare eccezioni in caso di errore per interrompere ed annullare tutta la procedura di importazione documenti.
Proprietà pubblica | FileList | Restituisce la lista dei file da importare come documenti e da associare alla commessa. Inserire in questa lista solo i file che si desidera importare e non le dipendenze, a meno ché non siano a loro volta da importare.
Proprietà pubblica | FileListSuccess | Restituisce la lista dei file che hanno finito con successo le varie operazioni di spostamento
Proprietà pubblica | Folder | Cartella di destinazione
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsDocSelection | Restituisce o imposta se si tratta di una selezione di documenti o file ( default = file ).
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non è impostata la commessa nella quale importare il documento. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ImportCommDocument
Namespace DedNet.Commands


Proprietà ImportCommDocument.Comm

Proprietà ImportCommDocumentComm
Restituisce o imposta la commessa nella quale importare i documenti.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedComm Comm { get; set; }
Public Property Comm As DedComm
    Get
    Set
public:
property DedComm^ Comm {
    DedComm^ get ();
    void set (DedComm^ value);
}
member Comm : DedComm with get, set

Valore della proprietà

DedComm
Vedi anche

Documentazione

Classe ImportCommDocument
Namespace DedNet.Commands


Proprietà ImportCommDocument.DelegateFileCopy

Proprietà ImportCommDocumentDelegateFileCopy
Restituisce o imposta il delegate che, dopo la creazione dei record, viene chiamato dal comando per la copia effettiva dei file. Se viene lasciato vuoto la copia viene effettuatata dal comando. Chi implementa il delegate dovrebbe sollevare eccezioni in caso di errore per interrompere ed annullare tutta la procedura di importazione documenti.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public FileOperationDelegate<DocStructInfoList> DelegateFileCopy { get; set; }
Public Property DelegateFileCopy As FileOperationDelegate(Of DocStructInfoList)
    Get
    Set
public:
property FileOperationDelegate<DocStructInfoList^>^ DelegateFileCopy {
    FileOperationDelegate<DocStructInfoList^>^ get ();
    void set (FileOperationDelegate<DocStructInfoList^>^ value);
}
member DelegateFileCopy : FileOperationDelegate<DocStructInfoList> with get, set

Valore della proprietà

FileOperationDelegate DocStructInfoList
Vedi anche

Documentazione

Classe ImportCommDocument
Namespace DedNet.Commands


Proprietà ImportCommDocument.FileList

Proprietà ImportCommDocumentFileList
Restituisce la lista dei file da importare come documenti e da associare alla commessa. Inserire in questa lista solo i file che si desidera importare e non le dipendenze, a meno ché non siano a loro volta da importare.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfoList FileList { get; }
Public ReadOnly Property FileList As DocStructInfoList
    Get
public:
property DocStructInfoList^ FileList {
    DocStructInfoList^ get ();
}
member FileList : DocStructInfoList with get

Valore della proprietà

DocStructInfoList
Vedi anche

Documentazione

Classe ImportCommDocument
Namespace DedNet.Commands


Proprietà ImportCommDocument.FileListSuccess

Proprietà ImportCommDocumentFileListSuccess
Restituisce la lista dei file che hanno finito con successo le varie operazioni di spostamento

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfoList FileListSuccess { get; }
Public ReadOnly Property FileListSuccess As DocStructInfoList
    Get
public:
property DocStructInfoList^ FileListSuccess {
    DocStructInfoList^ get ();
}
member FileListSuccess : DocStructInfoList with get

Valore della proprietà

DocStructInfoList
Vedi anche

Documentazione

Classe ImportCommDocument
Namespace DedNet.Commands


Proprietà ImportCommDocument.Folder

Proprietà ImportCommDocumentFolder
Cartella di destinazione

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Folder { get; set; }
Public Property Folder As String
    Get
    Set
public:
property String^ Folder {
    String^ get ();
    void set (String^ value);
}
member Folder : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe ImportCommDocument
Namespace DedNet.Commands


Proprietà ImportCommDocument.IsDocSelection

Proprietà ImportCommDocumentIsDocSelection
Restituisce o imposta se si tratta di una selezione di documenti o file ( default = file ).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsDocSelection { get; set; }
Public Property IsDocSelection As Boolean
    Get
    Set
public:
property bool IsDocSelection {
    bool get ();
    void set (bool value);
}
member IsDocSelection : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ImportCommDocument
Namespace DedNet.Commands


Proprietà ImportCommDocument.NeedParameters

Proprietà ImportCommDocumentNeedParameters
Restituisce true se non è impostata la commessa nella quale importare il documento.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ImportCommDocument
Namespace DedNet.Commands


Metodi di ImportCommDocument

Il tipo ImportCommDocument espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere la commessa alla quale associare il file. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere la commessa alla quale associare il file. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ImportCommDocument
Namespace DedNet.Commands


Metodo ImportCommDocument.ClearCommand

Metodo ImportCommDocumentClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe ImportCommDocument
Namespace DedNet.Commands


Metodo ImportCommDocument.Enabled

Metodo ImportCommDocumentEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere la commessa alla quale associare il file.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe ImportCommDocument
Namespace DedNet.Commands


Metodo ImportCommDocument.ExecuteCommand

Metodo ImportCommDocumentExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe ImportCommDocument
Namespace DedNet.Commands


Metodo ImportCommDocument.SetContext

Metodo ImportCommDocumentSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere la commessa alla quale associare il file.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto c'è la commessa alla quale associare il file.
Vedi anche

Documentazione

Classe ImportCommDocument
Namespace DedNet.Commands


Classe ImportDocument
Associa uno o più documenti ad un'anagrafica. Se i documenti da associare non sono presenti ne viene chiesta la selezione all'utente. Se l'anagrafica alla quale associare il documento non è presente viene chiesta all'utente attraverso la finestra di dialogo ricerca (modale). Se il contesto specificato è Primario ed il file da riconoscere ha una estensione già presente nei primari allora, se questa estensione rientra nella lista delle estensioni disponibili alle nuove rappresentazioni, diventa una nuova rappresentazione altrimenti viene sollevato un errore. Questo comando copia il documento nella posizione di destinazione calcolata in base all'anagrafica. Se il file non è presente nel Database e viene associato come allegato, cerca di copiarlo mantenendo lo stesso nome. Se viene invece associato come primario o pubblicazione calcola il nome corretto di destinazione in base all'anagrafica ed alla sua famiglia di appartenenza. Se esiste già un documento con stesso nome di destinazione, se si tratta di una estensione per la quale si può creare una nuova rappresentazione allora procedere creando una nuova rappresentazione ed aggiunge ^xxxx al nome file. Diversamente interrompe l'esecuzione. Se è attiva l'area locale il file viene copiato nell'area locale e poi riconosciuto come documento associato all'anagrafica. Non viene contestualmente pubblicato nel vault ma rimane in checkout dall'utente corrente. Per ogni documento vengono chieste le dipendenze e, se presenti, anche queste sono inserite nel Database (a meno ché non vi fossero già) ed impostate in checkout (se pws attiva) ed aggiunte come dipendenze del nuovo documento creato. L'elaborazione è racchiusa in una transazione quindi se non ha successo la creazione del documento o di una sua dipendenza oppure l'associazione all'anagrafica, tutte le operazioni vengono annullate. Questo anche se l'errore è avvenuto su di un solo file tra quelli elaborati.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsImportDocument

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ImportDocument : DedCommand
Public Class ImportDocument
    Inherits DedCommand
public ref class ImportDocument : public DedCommand
type ImportDocument =
    class
        inherit DedCommand
    end

Il tipo ImportDocument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Data | Restituisce o imposta l'anagrafica nella quale importare i documenti.
Proprietà pubblica | DelegateFileCopy | Restituisce o imposta il delegate che, dopo la creazione dei record, viene chiamato dal comando per la copia effettiva dei file. Se viene lasciato vuoto la copia viene effettuatata dal comando. Chi implementa il delegate dovrebbe sollevare eccezioni in caso di errore per interrompere ed annullare tutta la procedura di importazione documenti.
Proprietà pubblica | DelegateNewAttachFileName | Restitusice o imposta il delegate che viene chiamato per reperire il nome file nel caso di importazione di un nuovo documento come allegato. Il valore restituito deve essere il nome file compreso di estensione ma senza percorso: viene calcolato dal comando. Chi implementa il delegate dovrebbe sollevare eccezioni in caso di errore per interrompere ed annullare tutta la procedura di importazione documenti.
Proprietà pubblica | DestFileName | Permette di fare un import senza anagrafica(effettua un copia o un move).
Proprietà pubblica | EnforceOverWriteMode | Indica se è nel caso sovrascrivere o creare una rappresentazione.
Proprietà pubblica | EnforceRepresentation | Indica se è nel caso sovrascrivere o creare una rappresentazione.
Proprietà pubblica | ExtFilter | Filtro estensioni da utilizzare in caso di selezione file. Formato richiesto (Tutti i file (*.*)|*.*)
Proprietà pubblica | FileList | Restituisce la lista dei file da importare come documenti e da associare all'anagrafica. Inserire in questa lista solo i file che si desidera importare e non le dipendenze, a meno ché non siano a loro volta da importare.
Proprietà pubblica | Folder | Cartella di destinazione
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsCreateNewRep | Indica se è un importazione chiamata dal comando crea nuova rappresentazione.
Proprietà pubblica | IsCreateRevision | Indica se è una importazione chiamata dal comando salva revisione
Proprietà pubblica | IsDocSelection | Restituisce o imposta se si tratta di una selezione di documenti o file ( default = file ).
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | Mdres |
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non è impostata l'anagrafica nella quale importare il documento. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | PrimaryContext | Restituisce o imposta il contesto con il quale importare i documenti. Di default è true ed i documenti vengono importati come primari.
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SparePartsContext | Indica se importare il documento associandolo all'anagrafica con contesto 'PubblicazioneRicambio' o 'TavolaRicambio'.
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | ToBeCheckIn | Indica se effettuare il checkin o meno alla fine del comando (default True).
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseOriginalSparePartsFileName | Indica se, in caso di importazione file ricambio, utilizzare il nome originale o calcolarne uno valido. Di default è False.
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere l'anagrafica alla quale associare il file. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere l'anagrafica alla quale associare il file. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di ImportDocument

Il tipo ImportDocument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Data | Restituisce o imposta l'anagrafica nella quale importare i documenti.
Proprietà pubblica | DelegateFileCopy | Restituisce o imposta il delegate che, dopo la creazione dei record, viene chiamato dal comando per la copia effettiva dei file. Se viene lasciato vuoto la copia viene effettuatata dal comando. Chi implementa il delegate dovrebbe sollevare eccezioni in caso di errore per interrompere ed annullare tutta la procedura di importazione documenti.
Proprietà pubblica | DelegateNewAttachFileName | Restitusice o imposta il delegate che viene chiamato per reperire il nome file nel caso di importazione di un nuovo documento come allegato. Il valore restituito deve essere il nome file compreso di estensione ma senza percorso: viene calcolato dal comando. Chi implementa il delegate dovrebbe sollevare eccezioni in caso di errore per interrompere ed annullare tutta la procedura di importazione documenti.
Proprietà pubblica | DestFileName | Permette di fare un import senza anagrafica(effettua un copia o un move).
Proprietà pubblica | EnforceOverWriteMode | Indica se è nel caso sovrascrivere o creare una rappresentazione.
Proprietà pubblica | EnforceRepresentation | Indica se è nel caso sovrascrivere o creare una rappresentazione.
Proprietà pubblica | ExtFilter | Filtro estensioni da utilizzare in caso di selezione file. Formato richiesto (Tutti i file (*.*)|*.*)
Proprietà pubblica | FileList | Restituisce la lista dei file da importare come documenti e da associare all'anagrafica. Inserire in questa lista solo i file che si desidera importare e non le dipendenze, a meno ché non siano a loro volta da importare.
Proprietà pubblica | Folder | Cartella di destinazione
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsCreateNewRep | Indica se è un importazione chiamata dal comando crea nuova rappresentazione.
Proprietà pubblica | IsCreateRevision | Indica se è una importazione chiamata dal comando salva revisione
Proprietà pubblica | IsDocSelection | Restituisce o imposta se si tratta di una selezione di documenti o file ( default = file ).
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | Mdres |
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non è impostata l'anagrafica nella quale importare il documento. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | PrimaryContext | Restituisce o imposta il contesto con il quale importare i documenti. Di default è true ed i documenti vengono importati come primari.
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SparePartsContext | Indica se importare il documento associandolo all'anagrafica con contesto 'PubblicazioneRicambio' o 'TavolaRicambio'.
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | ToBeCheckIn | Indica se effettuare il checkin o meno alla fine del comando (default True).
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseOriginalSparePartsFileName | Indica se, in caso di importazione file ricambio, utilizzare il nome originale o calcolarne uno valido. Di default è False.
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ImportDocument
Namespace DedNet.Commands


Proprietà ImportDocument.Data

Proprietà ImportDocumentData
Restituisce o imposta l'anagrafica nella quale importare i documenti.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; set; }
Public Property Data As DedData
    Get
    Set
public:
property DedData^ Data {
    DedData^ get ();
    void set (DedData^ value);
}
member Data : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe ImportDocument
Namespace DedNet.Commands


Proprietà ImportDocument.DelegateFileCopy

Proprietà ImportDocumentDelegateFileCopy
Restituisce o imposta il delegate che, dopo la creazione dei record, viene chiamato dal comando per la copia effettiva dei file. Se viene lasciato vuoto la copia viene effettuatata dal comando. Chi implementa il delegate dovrebbe sollevare eccezioni in caso di errore per interrompere ed annullare tutta la procedura di importazione documenti.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public FileOperationDelegate<DocStructInfoList> DelegateFileCopy { get; set; }
Public Property DelegateFileCopy As FileOperationDelegate(Of DocStructInfoList)
    Get
    Set
public:
property FileOperationDelegate<DocStructInfoList^>^ DelegateFileCopy {
    FileOperationDelegate<DocStructInfoList^>^ get ();
    void set (FileOperationDelegate<DocStructInfoList^>^ value);
}
member DelegateFileCopy : FileOperationDelegate<DocStructInfoList> with get, set

Valore della proprietà

FileOperationDelegate DocStructInfoList
Vedi anche

Documentazione

Classe ImportDocument
Namespace DedNet.Commands


Proprietà ImportDocument.DelegateNewAttachFileName

Proprietà ImportDocumentDelegateNewAttachFileName
Restitusice o imposta il delegate che viene chiamato per reperire il nome file nel caso di importazione di un nuovo documento come allegato. Il valore restituito deve essere il nome file compreso di estensione ma senza percorso: viene calcolato dal comando. Chi implementa il delegate dovrebbe sollevare eccezioni in caso di errore per interrompere ed annullare tutta la procedura di importazione documenti.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ParamRest<DocStructInfo, string> DelegateNewAttachFileName { get; set; }
Public Property DelegateNewAttachFileName As ParamRest(Of DocStructInfo, String)
    Get
    Set
public:
property ParamRest<DocStructInfo^, String^>^ DelegateNewAttachFileName {
    ParamRest<DocStructInfo^, String^>^ get ();
    void set (ParamRest<DocStructInfo^, String^>^ value);
}
member DelegateNewAttachFileName : ParamRest<DocStructInfo, string> with get, set

Valore della proprietà

ParamRest DocStructInfo, String
Vedi anche

Documentazione

Classe ImportDocument
Namespace DedNet.Commands


Proprietà ImportDocument.DestFileName

Proprietà ImportDocumentDestFileName
Permette di fare un import senza anagrafica(effettua un copia o un move).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string DestFileName { get; set; }
Public Property DestFileName As String
    Get
    Set
public:
property String^ DestFileName {
    String^ get ();
    void set (String^ value);
}
member DestFileName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe ImportDocument
Namespace DedNet.Commands


Proprietà ImportDocument.EnforceOverWriteMode

Proprietà ImportDocumentEnforceOverWriteMode
Indica se è nel caso sovrascrivere o creare una rappresentazione.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool EnforceOverWriteMode { get; set; }
Public Property EnforceOverWriteMode As Boolean
    Get
    Set
public:
property bool EnforceOverWriteMode {
    bool get ();
    void set (bool value);
}
member EnforceOverWriteMode : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ImportDocument
Namespace DedNet.Commands


Proprietà ImportDocument.EnforceRepresentation

Proprietà ImportDocumentEnforceRepresentation
Indica se è nel caso sovrascrivere o creare una rappresentazione.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool EnforceRepresentation { get; set; }
Public Property EnforceRepresentation As Boolean
    Get
    Set
public:
property bool EnforceRepresentation {
    bool get ();
    void set (bool value);
}
member EnforceRepresentation : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ImportDocument
Namespace DedNet.Commands


Proprietà ImportDocument.ExtFilter

Proprietà ImportDocumentExtFilter
Filtro estensioni da utilizzare in caso di selezione file. Formato richiesto (Tutti i file (*.*)|*.*)

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string ExtFilter { get; set; }
Public Property ExtFilter As String
    Get
    Set
public:
property String^ ExtFilter {
    String^ get ();
    void set (String^ value);
}
member ExtFilter : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe ImportDocument
Namespace DedNet.Commands


Proprietà ImportDocument.FileList

Proprietà ImportDocumentFileList
Restituisce la lista dei file da importare come documenti e da associare all'anagrafica. Inserire in questa lista solo i file che si desidera importare e non le dipendenze, a meno ché non siano a loro volta da importare.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfoList FileList { get; }
Public ReadOnly Property FileList As DocStructInfoList
    Get
public:
property DocStructInfoList^ FileList {
    DocStructInfoList^ get ();
}
member FileList : DocStructInfoList with get

Valore della proprietà

DocStructInfoList
Vedi anche

Documentazione

Classe ImportDocument
Namespace DedNet.Commands


Proprietà ImportDocument.Folder

Proprietà ImportDocumentFolder
Cartella di destinazione

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Folder { get; set; }
Public Property Folder As String
    Get
    Set
public:
property String^ Folder {
    String^ get ();
    void set (String^ value);
}
member Folder : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe ImportDocument
Namespace DedNet.Commands


Proprietà ImportDocument.IsCreateNewRep

Proprietà ImportDocumentIsCreateNewRep
Indica se è un importazione chiamata dal comando crea nuova rappresentazione.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsCreateNewRep { get; set; }
Public Property IsCreateNewRep As Boolean
    Get
    Set
public:
property bool IsCreateNewRep {
    bool get ();
    void set (bool value);
}
member IsCreateNewRep : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ImportDocument
Namespace DedNet.Commands


Proprietà ImportDocument.IsCreateRevision

Proprietà ImportDocumentIsCreateRevision
Indica se è una importazione chiamata dal comando salva revisione

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsCreateRevision { get; set; }
Public Property IsCreateRevision As Boolean
    Get
    Set
public:
property bool IsCreateRevision {
    bool get ();
    void set (bool value);
}
member IsCreateRevision : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ImportDocument
Namespace DedNet.Commands


Proprietà ImportDocument.IsDocSelection

Proprietà ImportDocumentIsDocSelection
Restituisce o imposta se si tratta di una selezione di documenti o file ( default = file ).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsDocSelection { get; set; }
Public Property IsDocSelection As Boolean
    Get
    Set
public:
property bool IsDocSelection {
    bool get ();
    void set (bool value);
}
member IsDocSelection : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ImportDocument
Namespace DedNet.Commands


Proprietà ImportDocument.Mdres

Proprietà ImportDocumentMdres

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public MoveDocumentResult Mdres { get; set; }
Public Property Mdres As MoveDocumentResult
    Get
    Set
public:
property MoveDocumentResult^ Mdres {
    MoveDocumentResult^ get ();
    void set (MoveDocumentResult^ value);
}
member Mdres : MoveDocumentResult with get, set

Valore della proprietà

MoveDocumentResult
Vedi anche

Documentazione

Classe ImportDocument
Namespace DedNet.Commands


Proprietà ImportDocument.NeedParameters

Proprietà ImportDocumentNeedParameters
Restituisce true se non è impostata l'anagrafica nella quale importare il documento.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ImportDocument
Namespace DedNet.Commands


Proprietà ImportDocument.PrimaryContext

Proprietà ImportDocumentPrimaryContext
Restituisce o imposta il contesto con il quale importare i documenti. Di default è true ed i documenti vengono importati come primari.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool PrimaryContext { get; set; }
Public Property PrimaryContext As Boolean
    Get
    Set
public:
property bool PrimaryContext {
    bool get ();
    void set (bool value);
}
member PrimaryContext : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ImportDocument
Namespace DedNet.Commands


Proprietà ImportDocument.SparePartsContext

Proprietà ImportDocumentSparePartsContext
Indica se importare il documento associandolo all'anagrafica con contesto 'PubblicazioneRicambio' o 'TavolaRicambio'.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocContextEnum SparePartsContext { get; set; }
Public Property SparePartsContext As DedDocContextEnum
    Get
    Set
public:
property DedDocContextEnum SparePartsContext {
    DedDocContextEnum get ();
    void set (DedDocContextEnum value);
}
member SparePartsContext : DedDocContextEnum with get, set

Valore della proprietà

DedDocContextEnum
Vedi anche

Documentazione

Classe ImportDocument
Namespace DedNet.Commands


Proprietà ImportDocument.ToBeCheckIn

Proprietà ImportDocumentToBeCheckIn
Indica se effettuare il checkin o meno alla fine del comando (default True).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ToBeCheckIn { get; set; }
Public Property ToBeCheckIn As Boolean
    Get
    Set
public:
property bool ToBeCheckIn {
    bool get ();
    void set (bool value);
}
member ToBeCheckIn : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ImportDocument
Namespace DedNet.Commands


Proprietà ImportDocument.UseOriginalSparePartsFileName

Proprietà ImportDocumentUseOriginalSparePartsFileName
Indica se, in caso di importazione file ricambio, utilizzare il nome originale o calcolarne uno valido. Di default è False.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool UseOriginalSparePartsFileName { get; set; }
Public Property UseOriginalSparePartsFileName As Boolean
    Get
    Set
public:
property bool UseOriginalSparePartsFileName {
    bool get ();
    void set (bool value);
}
member UseOriginalSparePartsFileName : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ImportDocument
Namespace DedNet.Commands


Metodi di ImportDocument

Il tipo ImportDocument espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere l'anagrafica alla quale associare il file. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere l'anagrafica alla quale associare il file. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ImportDocument
Namespace DedNet.Commands


Metodo ImportDocument.ClearCommand

Metodo ImportDocumentClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe ImportDocument
Namespace DedNet.Commands


Metodo ImportDocument.Enabled

Metodo ImportDocumentEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere l'anagrafica alla quale associare il file.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe ImportDocument
Namespace DedNet.Commands


Metodo ImportDocument.ExecuteCommand

Metodo ImportDocumentExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe ImportDocument
Namespace DedNet.Commands


Metodo ImportDocument.SetContext

Metodo ImportDocumentSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere l'anagrafica alla quale associare il file.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto c'è una sola anagrafica alla quale associare il file.
Vedi anche

Documentazione

Classe ImportDocument
Namespace DedNet.Commands


Classe ImportEcoFiles
Associa uno o più documenti ad un ECO.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsImportEcoFiles

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ImportEcoFiles : DedCommand
Public Class ImportEcoFiles
    Inherits DedCommand
public ref class ImportEcoFiles : public DedCommand
type ImportEcoFiles =
    class
        inherit DedCommand
    end

Il tipo ImportEcoFiles espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DelegateFileCopy | Restituisce o imposta il delegate che, dopo la creazione dei record, viene chiamato dal comando per la copia effettiva dei file. Se viene lasciato vuoto la copia viene effettuatata dal comando. Chi implementa il delegate dovrebbe sollevare eccezioni in caso di errore per interrompere ed annullare tutta la procedura di importazione documenti.
Proprietà pubblica | Eco | Restituisce o imposta l'Eco nel quale importare i documenti.
Proprietà pubblica | FileList | Restituisce la lista dei file da importare come documenti e da associare all'Eco. Inserire in questa lista solo i file che si desidera importare e non le dipendenze, a meno ché non siano a loro volta da importare.
Proprietà pubblica | FileListSuccess | Restituisce la lista dei file che hanno finito con successo le varie operazioni di spostamento
Proprietà pubblica | Folder | Cartella di destinazione
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsDocSelection | Restituisce o imposta se si tratta di una selezione di documenti o file ( default = file ).
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non è impostato l'Eco nel quale importare il documento. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere l'Eco al quale associare il file. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere l'Eco al quale associare il file. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di ImportEcoFiles

Il tipo ImportEcoFiles espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DelegateFileCopy | Restituisce o imposta il delegate che, dopo la creazione dei record, viene chiamato dal comando per la copia effettiva dei file. Se viene lasciato vuoto la copia viene effettuatata dal comando. Chi implementa il delegate dovrebbe sollevare eccezioni in caso di errore per interrompere ed annullare tutta la procedura di importazione documenti.
Proprietà pubblica | Eco | Restituisce o imposta l'Eco nel quale importare i documenti.
Proprietà pubblica | FileList | Restituisce la lista dei file da importare come documenti e da associare all'Eco. Inserire in questa lista solo i file che si desidera importare e non le dipendenze, a meno ché non siano a loro volta da importare.
Proprietà pubblica | FileListSuccess | Restituisce la lista dei file che hanno finito con successo le varie operazioni di spostamento
Proprietà pubblica | Folder | Cartella di destinazione
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsDocSelection | Restituisce o imposta se si tratta di una selezione di documenti o file ( default = file ).
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non è impostato l'Eco nel quale importare il documento. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ImportEcoFiles
Namespace DedNet.Commands


Proprietà ImportEcoFiles.DelegateFileCopy

Proprietà ImportEcoFilesDelegateFileCopy
Restituisce o imposta il delegate che, dopo la creazione dei record, viene chiamato dal comando per la copia effettiva dei file. Se viene lasciato vuoto la copia viene effettuatata dal comando. Chi implementa il delegate dovrebbe sollevare eccezioni in caso di errore per interrompere ed annullare tutta la procedura di importazione documenti.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public FileOperationDelegate<DocStructInfoList> DelegateFileCopy { get; set; }
Public Property DelegateFileCopy As FileOperationDelegate(Of DocStructInfoList)
    Get
    Set
public:
property FileOperationDelegate<DocStructInfoList^>^ DelegateFileCopy {
    FileOperationDelegate<DocStructInfoList^>^ get ();
    void set (FileOperationDelegate<DocStructInfoList^>^ value);
}
member DelegateFileCopy : FileOperationDelegate<DocStructInfoList> with get, set

Valore della proprietà

FileOperationDelegate DocStructInfoList
Vedi anche

Documentazione

Classe ImportEcoFiles
Namespace DedNet.Commands


Proprietà ImportEcoFiles.Eco

Proprietà ImportEcoFilesEco
Restituisce o imposta l'Eco nel quale importare i documenti.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEco Eco { get; set; }
Public Property Eco As DedEco
    Get
    Set
public:
property DedEco^ Eco {
    DedEco^ get ();
    void set (DedEco^ value);
}
member Eco : DedEco with get, set

Valore della proprietà

DedEco
Vedi anche

Documentazione

Classe ImportEcoFiles
Namespace DedNet.Commands


Proprietà ImportEcoFiles.FileList

Proprietà ImportEcoFilesFileList
Restituisce la lista dei file da importare come documenti e da associare all'Eco. Inserire in questa lista solo i file che si desidera importare e non le dipendenze, a meno ché non siano a loro volta da importare.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfoList FileList { get; }
Public ReadOnly Property FileList As DocStructInfoList
    Get
public:
property DocStructInfoList^ FileList {
    DocStructInfoList^ get ();
}
member FileList : DocStructInfoList with get

Valore della proprietà

DocStructInfoList
Vedi anche

Documentazione

Classe ImportEcoFiles
Namespace DedNet.Commands


Proprietà ImportEcoFiles.FileListSuccess

Proprietà ImportEcoFilesFileListSuccess
Restituisce la lista dei file che hanno finito con successo le varie operazioni di spostamento

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfoList FileListSuccess { get; }
Public ReadOnly Property FileListSuccess As DocStructInfoList
    Get
public:
property DocStructInfoList^ FileListSuccess {
    DocStructInfoList^ get ();
}
member FileListSuccess : DocStructInfoList with get

Valore della proprietà

DocStructInfoList
Vedi anche

Documentazione

Classe ImportEcoFiles
Namespace DedNet.Commands


Proprietà ImportEcoFiles.Folder

Proprietà ImportEcoFilesFolder
Cartella di destinazione

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Folder { get; set; }
Public Property Folder As String
    Get
    Set
public:
property String^ Folder {
    String^ get ();
    void set (String^ value);
}
member Folder : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe ImportEcoFiles
Namespace DedNet.Commands


Proprietà ImportEcoFiles.IsDocSelection

Proprietà ImportEcoFilesIsDocSelection
Restituisce o imposta se si tratta di una selezione di documenti o file ( default = file ).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsDocSelection { get; set; }
Public Property IsDocSelection As Boolean
    Get
    Set
public:
property bool IsDocSelection {
    bool get ();
    void set (bool value);
}
member IsDocSelection : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ImportEcoFiles
Namespace DedNet.Commands


Proprietà ImportEcoFiles.NeedParameters

Proprietà ImportEcoFilesNeedParameters
Restituisce true se non è impostato l'Eco nel quale importare il documento.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ImportEcoFiles
Namespace DedNet.Commands


Metodi di ImportEcoFiles

Il tipo ImportEcoFiles espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere l'Eco al quale associare il file. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere l'Eco al quale associare il file. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ImportEcoFiles
Namespace DedNet.Commands


Metodo ImportEcoFiles.ClearCommand

Metodo ImportEcoFilesClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe ImportEcoFiles
Namespace DedNet.Commands


Metodo ImportEcoFiles.Enabled

Metodo ImportEcoFilesEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere l'Eco al quale associare il file.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe ImportEcoFiles
Namespace DedNet.Commands


Metodo ImportEcoFiles.ExecuteCommand

Metodo ImportEcoFilesExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe ImportEcoFiles
Namespace DedNet.Commands


Metodo ImportEcoFiles.SetContext

Metodo ImportEcoFilesSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere l'Eco al quale associare il file.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto c'è l'Eco al quale associare il file.
Vedi anche

Documentazione

Classe ImportEcoFiles
Namespace DedNet.Commands


Classe ImporterCommand
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsImporterCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ImporterCommand : DedCommand
Public Class ImporterCommand
    Inherits DedCommand
public ref class ImporterCommand : public DedCommand
type ImporterCommand =
    class
        inherit DedCommand
    end

Il tipo ImporterCommand espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ImporterCommand | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | ImporterMode | Indica il tipo di importazione che si vuole eseguire (se di anagrafiche, traduzioni, ecc..)
Proprietà pubblica | ImporterTranslationType | Indica il tipo di importazione traduzione attributi ricambio o dizionario aziendale
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Inidica se il comando necessita di parametri. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulizia del comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Abilitazione dal contesto (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esecuzione del comando. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Settaggio del contesto (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Costruttore ImporterCommand
Costruttore unico.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ImporterCommand(
    DedNetApplication app,
    string internalName,
    string name
)
Public Sub New (
    app As DedNetApplication,
    internalName As String,
    name As String
)
public:
ImporterCommand(
    DedNetApplication^ app,
    String^ internalName,
    String^ name
)
new :
        app : DedNetApplication *
        internalName : string *
        name : string -> ImporterCommand

Parametri

app DedNetApplication
Applicazione DedNet.
internalName String
Nome interno del comando.
name String
Nome visualizzato del comando.
Vedi anche

Documentazione

Classe ImporterCommand
Namespace DedNet.Commands


Proprietà di ImporterCommand

Il tipo ImporterCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | ImporterMode | Indica il tipo di importazione che si vuole eseguire (se di anagrafiche, traduzioni, ecc..)
Proprietà pubblica | ImporterTranslationType | Indica il tipo di importazione traduzione attributi ricambio o dizionario aziendale
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Inidica se il comando necessita di parametri. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ImporterCommand
Namespace DedNet.Commands


Proprietà ImporterCommand.ImporterMode

Proprietà ImporterCommandImporterMode
Indica il tipo di importazione che si vuole eseguire (se di anagrafiche, traduzioni, ecc..)

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ImporterModeEnum ImporterMode { get; set; }
Public Property ImporterMode As ImporterModeEnum
    Get
    Set
public:
property ImporterModeEnum ImporterMode {
    ImporterModeEnum get ();
    void set (ImporterModeEnum value);
}
member ImporterMode : ImporterModeEnum with get, set

Valore della proprietà

ImporterModeEnum
Vedi anche

Documentazione

Classe ImporterCommand
Namespace DedNet.Commands


Proprietà ImporterCommand.ImporterTranslationType

Proprietà ImporterCommandImporterTranslationType
Indica il tipo di importazione traduzione attributi ricambio o dizionario aziendale

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ImporterTranslationTypeEnum ImporterTranslationType { get; set; }
Public Property ImporterTranslationType As ImporterTranslationTypeEnum
    Get
    Set
public:
property ImporterTranslationTypeEnum ImporterTranslationType {
    ImporterTranslationTypeEnum get ();
    void set (ImporterTranslationTypeEnum value);
}
member ImporterTranslationType : ImporterTranslationTypeEnum with get, set

Valore della proprietà

ImporterTranslationTypeEnum
Vedi anche

Documentazione

Classe ImporterCommand
Namespace DedNet.Commands


Proprietà ImporterCommand.NeedParameters

Proprietà ImporterCommandNeedParameters
Inidica se il comando necessita di parametri.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ImporterCommand
Namespace DedNet.Commands


Metodi di ImporterCommand

Il tipo ImporterCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulizia del comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Abilitazione dal contesto (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esecuzione del comando. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Settaggio del contesto (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ImporterCommand
Namespace DedNet.Commands


Metodo ImporterCommand.ClearCommand

Metodo ImporterCommandClearCommand
Pulizia del comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe ImporterCommand
Namespace DedNet.Commands


Metodo ImporterCommand.Enabled

Metodo ImporterCommandEnabled
Abilitazione dal contesto

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext commandContext
)
Public Overrides Function Enabled (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ commandContext
) override
abstract Enabled :
        commandContext : DedCommandContext -> bool
override Enabled :
        commandContext : DedCommandContext -> bool

Parametri

commandContext DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe ImporterCommand
Namespace DedNet.Commands


Metodo ImporterCommand.ExecuteCommand

Metodo ImporterCommandExecuteCommand
Esecuzione del comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe ImporterCommand
Namespace DedNet.Commands


Metodo ImporterCommand.SetContext

Metodo ImporterCommandSetContext
Settaggio del contesto

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext commandContext
)
Public Overrides Function SetContext (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ commandContext
) override
abstract SetContext :
        commandContext : DedCommandContext -> bool
override SetContext :
        commandContext : DedCommandContext -> bool

Parametri

commandContext DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe ImporterCommand
Namespace DedNet.Commands


Classe ImportTransferPacket
Comando ricezione richieste di traferimento
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsImportTransferPacket

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ImportTransferPacket : DedCommand
Public Class ImportTransferPacket
    Inherits DedCommand
public ref class ImportTransferPacket : public DedCommand
type ImportTransferPacket =
    class
        inherit DedCommand
    end

Il tipo ImportTransferPacket espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ImportTransferPacket | Costruttore unico
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Inidica se il comando necessita di parametri (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulizia del comando (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Abilitazione dal contesto (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esecuzione (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Settaggio del contesto (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Costruttore ImportTransferPacket
Costruttore unico

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ImportTransferPacket(
    DedNetApplication app,
    string internalName,
    string name
)
Public Sub New (
    app As DedNetApplication,
    internalName As String,
    name As String
)
public:
ImportTransferPacket(
    DedNetApplication^ app,
    String^ internalName,
    String^ name
)
new :
        app : DedNetApplication *
        internalName : string *
        name : string -> ImportTransferPacket

Parametri

app DedNetApplication
internalName String
name String
Vedi anche

Documentazione

Classe ImportTransferPacket
Namespace DedNet.Commands


Proprietà di ImportTransferPacket

Il tipo ImportTransferPacket espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Inidica se il comando necessita di parametri (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ImportTransferPacket
Namespace DedNet.Commands


Proprietà ImportTransferPacket.NeedParameters

Proprietà ImportTransferPacketNeedParameters
Inidica se il comando necessita di parametri

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ImportTransferPacket
Namespace DedNet.Commands


Metodi di ImportTransferPacket

Il tipo ImportTransferPacket espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulizia del comando (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Abilitazione dal contesto (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esecuzione (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Settaggio del contesto (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ImportTransferPacket
Namespace DedNet.Commands


Metodo ImportTransferPacket.ClearCommand

Metodo ImportTransferPacketClearCommand
Pulizia del comando

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe ImportTransferPacket
Namespace DedNet.Commands


Metodo ImportTransferPacket.Enabled

Metodo ImportTransferPacketEnabled
Abilitazione dal contesto

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext commandContext
)
Public Overrides Function Enabled (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ commandContext
) override
abstract Enabled :
        commandContext : DedCommandContext -> bool
override Enabled :
        commandContext : DedCommandContext -> bool

Parametri

commandContext DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe ImportTransferPacket
Namespace DedNet.Commands


Metodo ImportTransferPacket.ExecuteCommand

Metodo ImportTransferPacketExecuteCommand
Esecuzione

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe ImportTransferPacket
Namespace DedNet.Commands


Metodo ImportTransferPacket.SetContext

Metodo ImportTransferPacketSetContext
Settaggio del contesto

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext commandContext
)
Public Overrides Function SetContext (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ commandContext
) override
abstract SetContext :
        commandContext : DedCommandContext -> bool
override SetContext :
        commandContext : DedCommandContext -> bool

Parametri

commandContext DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe ImportTransferPacket
Namespace DedNet.Commands


Classe LiberateCommCommand
Comando per liberare una commessa dopo che è stata presa in carico
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsLiberateCommCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class LiberateCommCommand : DedCommand
Public Class LiberateCommCommand
    Inherits DedCommand
public ref class LiberateCommCommand : public DedCommand
type LiberateCommCommand =
    class
        inherit DedCommand
    end

Il tipo LiberateCommCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se si vuole creare una sotto commessa ma non si passa il riferimento. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | ReferenceComm | Commessa di riferimento
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di LiberateCommCommand

Il tipo LiberateCommCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se si vuole creare una sotto commessa ma non si passa il riferimento. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | ReferenceComm | Commessa di riferimento
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe LiberateCommCommand
Namespace DedNet.Commands


Proprietà LiberateCommCommand.NeedParameters

Proprietà LiberateCommCommandNeedParameters
Restituisce true se si vuole creare una sotto commessa ma non si passa il riferimento.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe LiberateCommCommand
Namespace DedNet.Commands


Proprietà LiberateCommCommand.ReferenceComm

Proprietà LiberateCommCommandReferenceComm
Commessa di riferimento

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedComm ReferenceComm { get; set; }
Public Property ReferenceComm As DedComm
    Get
    Set
public:
property DedComm^ ReferenceComm {
    DedComm^ get ();
    void set (DedComm^ value);
}
member ReferenceComm : DedComm with get, set

Valore della proprietà

DedComm
Vedi anche

Documentazione

Classe LiberateCommCommand
Namespace DedNet.Commands


Metodi di LiberateCommCommand

Il tipo LiberateCommCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe LiberateCommCommand
Namespace DedNet.Commands


Metodo LiberateCommCommand.ClearCommand

Metodo LiberateCommCommandClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe LiberateCommCommand
Namespace DedNet.Commands


Metodo LiberateCommCommand.Enabled

Metodo LiberateCommCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe LiberateCommCommand
Namespace DedNet.Commands


Metodo LiberateCommCommand.ExecuteCommand

Metodo LiberateCommCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe LiberateCommCommand
Namespace DedNet.Commands


Metodo LiberateCommCommand.SetContext

Metodo LiberateCommCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto c'è una sola anagrafica alla quale associare il file.
Vedi anche

Documentazione

Classe LiberateCommCommand
Namespace DedNet.Commands


Classe LinkCommDocument
Comando che permette di collegare uno o più documenti preesistenti ad una commessa.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsLinkCommDocument

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class LinkCommDocument : DedCommand
Public Class LinkCommDocument
    Inherits DedCommand
public ref class LinkCommDocument : public DedCommand
type LinkCommDocument =
    class
        inherit DedCommand
    end

Il tipo LinkCommDocument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Comm | Restituisce o imposta la commesssa nella quale collegare i documenti.
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | FileList | Restituisce la lista dei documenti da associare alla commessa. Inserire in questa lista solo i documenti che si desidera importare e non le dipendenze, a meno ché non siano a loro volta da collegare.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non è impostata la commessa alla quale associare il documento. La commessa è l'unico dato richiesto all'interfaccia utente. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere la commessa alla quale associare il file. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere la commessa alla quale associare il file. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di LinkCommDocument

Il tipo LinkCommDocument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Comm | Restituisce o imposta la commesssa nella quale collegare i documenti.
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | FileList | Restituisce la lista dei documenti da associare alla commessa. Inserire in questa lista solo i documenti che si desidera importare e non le dipendenze, a meno ché non siano a loro volta da collegare.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non è impostata la commessa alla quale associare il documento. La commessa è l'unico dato richiesto all'interfaccia utente. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe LinkCommDocument
Namespace DedNet.Commands


Proprietà LinkCommDocument.Comm

Proprietà LinkCommDocumentComm
Restituisce o imposta la commesssa nella quale collegare i documenti.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedComm Comm { get; set; }
Public Property Comm As DedComm
    Get
    Set
public:
property DedComm^ Comm {
    DedComm^ get ();
    void set (DedComm^ value);
}
member Comm : DedComm with get, set

Valore della proprietà

DedComm
Vedi anche

Documentazione

Classe LinkCommDocument
Namespace DedNet.Commands


Proprietà LinkCommDocument.FileList

Proprietà LinkCommDocumentFileList
Restituisce la lista dei documenti da associare alla commessa. Inserire in questa lista solo i documenti che si desidera importare e non le dipendenze, a meno ché non siano a loro volta da collegare.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfoList FileList { get; }
Public ReadOnly Property FileList As DocStructInfoList
    Get
public:
property DocStructInfoList^ FileList {
    DocStructInfoList^ get ();
}
member FileList : DocStructInfoList with get

Valore della proprietà

DocStructInfoList
Vedi anche

Documentazione

Classe LinkCommDocument
Namespace DedNet.Commands


Proprietà LinkCommDocument.NeedParameters

Proprietà LinkCommDocumentNeedParameters
Restituisce true se non è impostata la commessa alla quale associare il documento. La commessa è l'unico dato richiesto all'interfaccia utente.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe LinkCommDocument
Namespace DedNet.Commands


Metodi di LinkCommDocument

Il tipo LinkCommDocument espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere la commessa alla quale associare il file. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere la commessa alla quale associare il file. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe LinkCommDocument
Namespace DedNet.Commands


Metodo LinkCommDocument.ClearCommand

Metodo LinkCommDocumentClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe LinkCommDocument
Namespace DedNet.Commands


Metodo LinkCommDocument.Enabled

Metodo LinkCommDocumentEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere la commessa alla quale associare il file.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe LinkCommDocument
Namespace DedNet.Commands


Metodo LinkCommDocument.ExecuteCommand

Metodo LinkCommDocumentExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe LinkCommDocument
Namespace DedNet.Commands


Metodo LinkCommDocument.SetContext

Metodo LinkCommDocumentSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere la commessa alla quale associare il file.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto esiste la commessa.
Vedi anche

Documentazione

Classe LinkCommDocument
Namespace DedNet.Commands


Classe LinkDocument
Comando che permette di collegare uno o più documenti preesistenti ad un'anagrafica anch'essa preesistente. Se i documenti da associare non sono presenti ne viene chiesta la selezione all'utente attraverso la finestra di dialogo ricerca (modale). Se l'anagrafica alla quale associare il documento non è presente viene chiesta all'utente attraverso la finestra di dialogo ricerca (modale). Se il contesto specificato è Primario ed il file da riconoscere ha una estensione già presente nei primari allora, se questa estensione rientra nella lista delle estensioni disponibili alle nuove rappresentazioni, diventa una nuova rappresentazione altrimenti viene sollevato un errore.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsLinkDocument

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class LinkDocument : DedCommand
Public Class LinkDocument
    Inherits DedCommand
public ref class LinkDocument : public DedCommand
type LinkDocument =
    class
        inherit DedCommand
    end

Il tipo LinkDocument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Data | Restituisce o imposta l'anagrafica nella quale collegare i documenti.
Proprietà pubblica | DataList | Lista di anagrafiche alle quali collegare i documenti.
Proprietà pubblica | FileList | Restituisce la lista dei documenti da associare all'anagrafica. Inserire in questa lista solo i documenti che si desidera importare e non le dipendenze, a meno ché non siano a loro volta da collegare.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | LinkingData | Restituisce o imposta l'anagrafica di partenza del documento da collegare. Viene utilizzare per segnare nel contesto di collegamento l'anagrafica di provenienza come link.
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non è impostata l'anagrafica alla quale associare il documento. L'anagrafica è l'unico dato richiesto all'interfaccia utente. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | PrimaryContext | Restituisce o imposta il contesto con il quale importare i documenti. Di default è false ed i documenti vengono collegati come allegati.
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere l'anagrafica alla quale associare il file. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere l'anagrafica alla quale associare il file. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di LinkDocument

Il tipo LinkDocument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Data | Restituisce o imposta l'anagrafica nella quale collegare i documenti.
Proprietà pubblica | DataList | Lista di anagrafiche alle quali collegare i documenti.
Proprietà pubblica | FileList | Restituisce la lista dei documenti da associare all'anagrafica. Inserire in questa lista solo i documenti che si desidera importare e non le dipendenze, a meno ché non siano a loro volta da collegare.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | LinkingData | Restituisce o imposta l'anagrafica di partenza del documento da collegare. Viene utilizzare per segnare nel contesto di collegamento l'anagrafica di provenienza come link.
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non è impostata l'anagrafica alla quale associare il documento. L'anagrafica è l'unico dato richiesto all'interfaccia utente. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | PrimaryContext | Restituisce o imposta il contesto con il quale importare i documenti. Di default è false ed i documenti vengono collegati come allegati.
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe LinkDocument
Namespace DedNet.Commands


Proprietà LinkDocument.Data

Proprietà LinkDocumentData
Restituisce o imposta l'anagrafica nella quale collegare i documenti.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; set; }
Public Property Data As DedData
    Get
    Set
public:
property DedData^ Data {
    DedData^ get ();
    void set (DedData^ value);
}
member Data : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe LinkDocument
Namespace DedNet.Commands


Proprietà LinkDocument.DataList

Proprietà LinkDocumentDataList
Lista di anagrafiche alle quali collegare i documenti.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataList DataList { get; set; }
Public Property DataList As DedDataList
    Get
    Set
public:
property DedDataList^ DataList {
    DedDataList^ get ();
    void set (DedDataList^ value);
}
member DataList : DedDataList with get, set

Valore della proprietà

DedDataList
Vedi anche

Documentazione

Classe LinkDocument
Namespace DedNet.Commands


Proprietà LinkDocument.FileList

Proprietà LinkDocumentFileList
Restituisce la lista dei documenti da associare all'anagrafica. Inserire in questa lista solo i documenti che si desidera importare e non le dipendenze, a meno ché non siano a loro volta da collegare.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfoList FileList { get; }
Public ReadOnly Property FileList As DocStructInfoList
    Get
public:
property DocStructInfoList^ FileList {
    DocStructInfoList^ get ();
}
member FileList : DocStructInfoList with get

Valore della proprietà

DocStructInfoList
Vedi anche

Documentazione

Classe LinkDocument
Namespace DedNet.Commands


Proprietà LinkDocument.LinkingData

Proprietà LinkDocumentLinkingData
Restituisce o imposta l'anagrafica di partenza del documento da collegare. Viene utilizzare per segnare nel contesto di collegamento l'anagrafica di provenienza come link.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData LinkingData { get; set; }
Public Property LinkingData As DedData
    Get
    Set
public:
property DedData^ LinkingData {
    DedData^ get ();
    void set (DedData^ value);
}
member LinkingData : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe LinkDocument
Namespace DedNet.Commands


Proprietà LinkDocument.NeedParameters

Proprietà LinkDocumentNeedParameters
Restituisce true se non è impostata l'anagrafica alla quale associare il documento. L'anagrafica è l'unico dato richiesto all'interfaccia utente.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe LinkDocument
Namespace DedNet.Commands


Proprietà LinkDocument.PrimaryContext

Proprietà LinkDocumentPrimaryContext
Restituisce o imposta il contesto con il quale importare i documenti. Di default è false ed i documenti vengono collegati come allegati.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool PrimaryContext { get; set; }
Public Property PrimaryContext As Boolean
    Get
    Set
public:
property bool PrimaryContext {
    bool get ();
    void set (bool value);
}
member PrimaryContext : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe LinkDocument
Namespace DedNet.Commands


Metodi di LinkDocument

Il tipo LinkDocument espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere l'anagrafica alla quale associare il file. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere l'anagrafica alla quale associare il file. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe LinkDocument
Namespace DedNet.Commands


Metodo LinkDocument.ClearCommand

Metodo LinkDocumentClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe LinkDocument
Namespace DedNet.Commands


Metodo LinkDocument.Enabled

Metodo LinkDocumentEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere l'anagrafica alla quale associare il file.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe LinkDocument
Namespace DedNet.Commands


Metodo LinkDocument.ExecuteCommand

Metodo LinkDocumentExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe LinkDocument
Namespace DedNet.Commands


Metodo LinkDocument.SetContext

Metodo LinkDocumentSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere l'anagrafica alla quale associare il file.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto c'è una sola anagrafica alla quale associare il file.
Vedi anche

Documentazione

Classe LinkDocument
Namespace DedNet.Commands


Classe LoginCommand
Classe che rappresenta il comando per effettuare il login con un utente specifico.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsLoginCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class LoginCommand : DedCommand
Public Class LoginCommand
    Inherits DedCommand
public ref class LoginCommand : public DedCommand
type LoginCommand =
    class
        inherit DedCommand
    end

Il tipo LoginCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce se i parametri siano o meno sufficienti per l'esecuzione del comando. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di LoginCommand

Il tipo LoginCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce se i parametri siano o meno sufficienti per l'esecuzione del comando. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe LoginCommand
Namespace DedNet.Commands


Proprietà LoginCommand.NeedParameters

Proprietà LoginCommandNeedParameters
Restituisce se i parametri siano o meno sufficienti per l'esecuzione del comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe LoginCommand
Namespace DedNet.Commands


Metodi di LoginCommand

Il tipo LoginCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe LoginCommand
Namespace DedNet.Commands


Metodo LoginCommand.ClearCommand

Metodo LoginCommandClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe LoginCommand
Namespace DedNet.Commands


Metodo LoginCommand.Enabled

Metodo LoginCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe LoginCommand
Namespace DedNet.Commands


Metodo LoginCommand.ExecuteCommand

Metodo LoginCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe LoginCommand
Namespace DedNet.Commands


Metodo LoginCommand.SetContext

Metodo LoginCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe LoginCommand
Namespace DedNet.Commands


Classe LogViewCommand
Apre il dialogo di visualizzazione dei log presenti nella tabella DED_LOG.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsLogViewCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class LogViewCommand : DedCommand
Public Class LogViewCommand
    Inherits DedCommand
public ref class LogViewCommand : public DedCommand
type LogViewCommand =
    class
        inherit DedCommand
    end

Il tipo LogViewCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Ritorna se il comando necessita dei parametri. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di LogViewCommand

Il tipo LogViewCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Ritorna se il comando necessita dei parametri. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe LogViewCommand
Namespace DedNet.Commands


Proprietà LogViewCommand.NeedParameters

Proprietà LogViewCommandNeedParameters
Ritorna se il comando necessita dei parametri.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe LogViewCommand
Namespace DedNet.Commands


Metodi di LogViewCommand

Il tipo LogViewCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe LogViewCommand
Namespace DedNet.Commands


Metodo LogViewCommand.ClearCommand

Metodo LogViewCommandClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe LogViewCommand
Namespace DedNet.Commands


Metodo LogViewCommand.Enabled

Metodo LogViewCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe LogViewCommand
Namespace DedNet.Commands


Metodo LogViewCommand.ExecuteCommand

Metodo LogViewCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe LogViewCommand
Namespace DedNet.Commands


Metodo LogViewCommand.SetContext

Metodo LogViewCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe LogViewCommand
Namespace DedNet.Commands


Classe ManageOperationsCommand
Classe che rappresenta il comando per eseguire il gestore delle operazioni del DED.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsManageOperationsCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ManageOperationsCommand : DedCommand
Public Class ManageOperationsCommand
    Inherits DedCommand
public ref class ManageOperationsCommand : public DedCommand
type ManageOperationsCommand =
    class
        inherit DedCommand
    end

Il tipo ManageOperationsCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di ManageOperationsCommand

Il tipo ManageOperationsCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ManageOperationsCommand
Namespace DedNet.Commands


Proprietà ManageOperationsCommand.NeedParameters

Proprietà ManageOperationsCommandNeedParameters

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ManageOperationsCommand
Namespace DedNet.Commands


Metodi di ManageOperationsCommand

Il tipo ManageOperationsCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ManageOperationsCommand
Namespace DedNet.Commands


Metodo ManageOperationsCommand.ClearCommand

Metodo ManageOperationsCommandClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe ManageOperationsCommand
Namespace DedNet.Commands


Metodo ManageOperationsCommand.Enabled

Metodo ManageOperationsCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe ManageOperationsCommand
Namespace DedNet.Commands


Metodo ManageOperationsCommand.ExecuteCommand

Metodo ManageOperationsCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe ManageOperationsCommand
Namespace DedNet.Commands


Metodo ManageOperationsCommand.SetContext

Metodo ManageOperationsCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe ManageOperationsCommand
Namespace DedNet.Commands


Classe MarkerInfoCommand
Comando per visualizzare lo stato di allinemento del documento nel caso si DFS attivo.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsDedDocumentCommand
DedNet.CommandsMarkerInfoCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class MarkerInfoCommand : DedDocumentCommand
Public Class MarkerInfoCommand
    Inherits DedDocumentCommand
public ref class MarkerInfoCommand : public DedDocumentCommand
type MarkerInfoCommand =
    class
        inherit DedDocumentCommand
    end

Il tipo MarkerInfoCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DocumentInfos | Restituisce la lista dei documenti con abbinato il contesto di anagrafica di elaborazione comando. (Ereditato da DedDocumentCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedDocumentCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Reinizializza il comando. (Ereditato da DedDocumentCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedDocumentCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedDocumentCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedDocumentCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedDocumentCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di MarkerInfoCommand

Il tipo MarkerInfoCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DocumentInfos | Restituisce la lista dei documenti con abbinato il contesto di anagrafica di elaborazione comando. (Ereditato da DedDocumentCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedDocumentCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe MarkerInfoCommand
Namespace DedNet.Commands


Proprietà MarkerInfoCommand.NeedParameters

Proprietà MarkerInfoCommandNeedParameters

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe MarkerInfoCommand
Namespace DedNet.Commands


Metodi di MarkerInfoCommand

Il tipo MarkerInfoCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Reinizializza il comando. (Ereditato da DedDocumentCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedDocumentCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedDocumentCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedDocumentCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedDocumentCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe MarkerInfoCommand
Namespace DedNet.Commands


Metodo MarkerInfoCommand.Enabled

Metodo MarkerInfoCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe MarkerInfoCommand
Namespace DedNet.Commands


Metodo MarkerInfoCommand.ExecuteCommand

Metodo MarkerInfoCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe MarkerInfoCommand
Namespace DedNet.Commands


Metodo MarkerInfoCommand.SetContext

Metodo MarkerInfoCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe MarkerInfoCommand
Namespace DedNet.Commands


Classe MessageLocalIsOlderNotifier
Classe di servizio per unificare i messaggi di richiesta sovrascrittura file nel caso in cui sul server ci sia un file più recente rispetto a quello già presente nell'area locale.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsMessageLocalIsOlderNotifier

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class MessageLocalIsOlderNotifier
Public Class MessageLocalIsOlderNotifier
public ref class MessageLocalIsOlderNotifier
type MessageLocalIsOlderNotifier = class end

Il tipo MessageLocalIsOlderNotifier espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | MessageLocalIsOlderNotifier |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Owner | Da utilizzare per impostare l'owner del form.
Proprietà pubblica | Risposta | Variabile utilizzata (letta e scritta) dal metodo LocalIsOlderNotifier.
Proprietà pubblica | UseUI | Restituisce o imposta l'uso o meno dell'interfaccia utente.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | LocalIsOlderNotifier | Chiede all'utente se dovrascrivere il documento nell'area locale perché più vecchio della versione sul vault. Restituisce true se è da sovrascrivere altrimenti false.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Costruttore MessageLocalIsOlderNotifier

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public MessageLocalIsOlderNotifier()
Public Sub New
public:
MessageLocalIsOlderNotifier()
new : unit -> MessageLocalIsOlderNotifier
Vedi anche

Documentazione

Classe MessageLocalIsOlderNotifier
Namespace DedNet.Commands


Proprietà di MessageLocalIsOlderNotifier

Il tipo MessageLocalIsOlderNotifier espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Owner | Da utilizzare per impostare l'owner del form.
Proprietà pubblica | Risposta | Variabile utilizzata (letta e scritta) dal metodo LocalIsOlderNotifier.
Proprietà pubblica | UseUI | Restituisce o imposta l'uso o meno dell'interfaccia utente.
Torna su
Vedi anche

Documentazione

Classe MessageLocalIsOlderNotifier
Namespace DedNet.Commands


Proprietà MessageLocalIsOlderNotifier.Owner

Proprietà MessageLocalIsOlderNotifierOwner
Da utilizzare per impostare l'owner del form.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public IWin32Window Owner { get; set; }
Public Property Owner As IWin32Window
    Get
    Set
public:
property IWin32Window^ Owner {
    IWin32Window^ get ();
    void set (IWin32Window^ value);
}
member Owner : IWin32Window with get, set

Valore della proprietà

IWin32Window
Vedi anche

Documentazione

Classe MessageLocalIsOlderNotifier
Namespace DedNet.Commands


Proprietà MessageLocalIsOlderNotifier.Risposta

Proprietà MessageLocalIsOlderNotifierRisposta
Variabile utilizzata (letta e scritta) dal metodo LocalIsOlderNotifier.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QuestionResult Risposta { get; set; }
Public Property Risposta As QuestionResult
    Get
    Set
public:
property QuestionResult Risposta {
    QuestionResult get ();
    void set (QuestionResult value);
}
member Risposta : QuestionResult with get, set

Valore della proprietà

QuestionResult
Vedi anche

Documentazione

Classe MessageLocalIsOlderNotifier
Namespace DedNet.Commands


Proprietà MessageLocalIsOlderNotifier.UseUI

Proprietà MessageLocalIsOlderNotifierUseUI
Restituisce o imposta l'uso o meno dell'interfaccia utente.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool UseUI { get; set; }
Public Property UseUI As Boolean
    Get
    Set
public:
property bool UseUI {
    bool get ();
    void set (bool value);
}
member UseUI : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe MessageLocalIsOlderNotifier
Namespace DedNet.Commands


Metodi di MessageLocalIsOlderNotifier

Il tipo MessageLocalIsOlderNotifier espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | LocalIsOlderNotifier | Chiede all'utente se dovrascrivere il documento nell'area locale perché più vecchio della versione sul vault. Restituisce true se è da sovrascrivere altrimenti false.
Torna su
Vedi anche

Documentazione

Classe MessageLocalIsOlderNotifier
Namespace DedNet.Commands


Metodo MessageLocalIsOlderNotifier.LocalIsOlderNotifier

Metodo MessageLocalIsOlderNotifierLocalIsOlderNotifier
Chiede all'utente se dovrascrivere il documento nell'area locale perché più vecchio della versione sul vault. Restituisce true se è da sovrascrivere altrimenti false.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool LocalIsOlderNotifier(
    DedDoc doc
)
Public Function LocalIsOlderNotifier (
    doc As DedDoc
) As Boolean
public:
bool LocalIsOlderNotifier(
    DedDoc^ doc
)
member LocalIsOlderNotifier :
        doc : DedDoc -> bool

Parametri

doc DedDoc
Documento da elaborare.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe MessageLocalIsOlderNotifier
Namespace DedNet.Commands


Classe MoveAnagrCommand
Classe che rappresenta il comando per spostare un'anagrafica in un'altra famiglia.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsDedDataCommand
DedNet.CommandsMoveAnagrCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class MoveAnagrCommand : DedDataCommand
Public Class MoveAnagrCommand
    Inherits DedDataCommand
public ref class MoveAnagrCommand : public DedDataCommand
type MoveAnagrCommand =
    class
        inherit DedDataCommand
    end

Il tipo MoveAnagrCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DataInfos | Restituisce la lista delle anagrafiche di elaborazione comando. (Ereditato da DedDataCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedDataCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Esegue la pulizia del comando. Azzera tutte le variabili. (Ereditato da DedDataCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedDataCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedDataCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedDataCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Sovrascrive DedDataCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di MoveAnagrCommand

Il tipo MoveAnagrCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DataInfos | Restituisce la lista delle anagrafiche di elaborazione comando. (Ereditato da DedDataCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedDataCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe MoveAnagrCommand
Namespace DedNet.Commands


Proprietà MoveAnagrCommand.NeedParameters

Proprietà MoveAnagrCommandNeedParameters

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe MoveAnagrCommand
Namespace DedNet.Commands


Metodi di MoveAnagrCommand

Il tipo MoveAnagrCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Esegue la pulizia del comando. Azzera tutte le variabili. (Ereditato da DedDataCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedDataCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedDataCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedDataCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Sovrascrive DedDataCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe MoveAnagrCommand
Namespace DedNet.Commands


Metodo MoveAnagrCommand.Enabled

Metodo MoveAnagrCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe MoveAnagrCommand
Namespace DedNet.Commands


Metodo MoveAnagrCommand.ExecuteCommand

Metodo MoveAnagrCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe MoveAnagrCommand
Namespace DedNet.Commands


Metodo MoveAnagrCommand.SetContext

Metodo MoveAnagrCommandSetContext

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe MoveAnagrCommand
Namespace DedNet.Commands


Classe MovedEditorCommand
Comando utilizzato per visualizzare e gestire i .moved dei vari documenti.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsMovedEditorCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class MovedEditorCommand : DedCommand
Public Class MovedEditorCommand
    Inherits DedCommand
public ref class MovedEditorCommand : public DedCommand
type MovedEditorCommand =
    class
        inherit DedCommand
    end

Il tipo MovedEditorCommand espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | MovedEditorCommand | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve essere impostata la struttura di salvataggio distinta. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Eseguo il comando. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Imposto il contesto per l'esecuzione del comando (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Costruttore MovedEditorCommand
Costruttore unico.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public MovedEditorCommand(
    DedNetApplication app,
    string internalName,
    string name
)
Public Sub New (
    app As DedNetApplication,
    internalName As String,
    name As String
)
public:
MovedEditorCommand(
    DedNetApplication^ app,
    String^ internalName,
    String^ name
)
new :
        app : DedNetApplication *
        internalName : string *
        name : string -> MovedEditorCommand

Parametri

app DedNetApplication
Riferimento all'oggetto DedNetApplication.
internalName String
Nome interno del comando.
name String
Nome visualizzato del comando.
Vedi anche

Documentazione

Classe MovedEditorCommand
Namespace DedNet.Commands


Proprietà di MovedEditorCommand

Il tipo MovedEditorCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve essere impostata la struttura di salvataggio distinta. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe MovedEditorCommand
Namespace DedNet.Commands


Proprietà MovedEditorCommand.NeedParameters

Proprietà MovedEditorCommandNeedParameters
Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve essere impostata la struttura di salvataggio distinta.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe MovedEditorCommand
Namespace DedNet.Commands


Metodi di MovedEditorCommand

Il tipo MovedEditorCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Eseguo il comando. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Imposto il contesto per l'esecuzione del comando (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe MovedEditorCommand
Namespace DedNet.Commands


Metodo MovedEditorCommand.ClearCommand

Metodo MovedEditorCommandClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe MovedEditorCommand
Namespace DedNet.Commands


Metodo MovedEditorCommand.Enabled

Metodo MovedEditorCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce True se il comando deve risultare abilitato all'utente, False altrimenti.
Vedi anche

Documentazione

Classe MovedEditorCommand
Namespace DedNet.Commands


Metodo MovedEditorCommand.ExecuteCommand

Metodo MovedEditorCommandExecuteCommand
Eseguo il comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe MovedEditorCommand
Namespace DedNet.Commands


Metodo MovedEditorCommand.SetContext

Metodo MovedEditorCommandSetContext
Imposto il contesto per l'esecuzione del comando

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe MovedEditorCommand
Namespace DedNet.Commands


Classe MoveDocument
Permette di rinominare o spostare una lista di documenti già registrati nel Database. Sposta il file sul server e nell'area locale (se attiva e se il documento è in check-out dall'utente corrente) chiamando un evento che permette al client di sostituirsi allo spostamento del file. Aggiorna poi i riferimenti presenti nei file di Inventor, per quanto riguarda i documenti coinvolti nello spostamento, e, opzionalmente, per tutti i padri che contengono i file che si stanno spostando/rinominando, in modo che rispecchino la situazione reale. In base ad una opzione è anche possibile premettere lo spostamento dei file primari, che di default non è consentita.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsMoveDocument

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class MoveDocument : DedCommand
Public Class MoveDocument
    Inherits DedCommand
public ref class MoveDocument : public DedCommand
type MoveDocument =
    class
        inherit DedCommand
    end

Il tipo MoveDocument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddMoveMarker | Indica se creare il .moved
Proprietà pubblica | AllowedPrimaryFiles | Restituisce o imposta se si debba concedere la possibilità di spostare / rinominare i file che sono referenziati come primari in una o più anagrafiche. Di default il valore è false quindi non è consentita l'operazione.
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DelegateFileMove | Restituisce o imposta il delegate che, dopo la modifica dei record, viene chiamato dal comando per lo spostamento effettivo dei file. Se viene lasciato vuoto lo spostamento viene effettuatata dal comando. Chi implementa il delegate dovrebbe sollevare eccezioni in caso di errore per interrompere ed annullare tutta la procedura di spostamento documenti.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | MovingDocuments | Restituisce la lista dei documenti da spostare.
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non è impostato almeno un documento da spostare. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | NotToEraseStartingDocs | Restitusice la lista dei documenti di partenza che non devono essere eliminati. Risulteranno non più riconosciuti nel Database ma non saranno eliminati durante lo spostamento del documento.
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | ReplaceInAllParents | Restituisce o imposta se il comando debba aggiornare le dipendenze fisiche dei documenti che referenziano i file che si stanno rinominando ma che non sono compresi dall'operazione di rinomina (nel caso di file di Inventor). Di default è true quindi le dipendenze vengono aggiornate tutte, se false invece vengono aggiornate solo tra i file in fase di spostamento / rinomina.
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato o meno in base alla selezione contestuale. Gli basta che sia selezionato un documento. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Gli basta che sia selezionato un documento. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di MoveDocument

Il tipo MoveDocument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddMoveMarker | Indica se creare il .moved
Proprietà pubblica | AllowedPrimaryFiles | Restituisce o imposta se si debba concedere la possibilità di spostare / rinominare i file che sono referenziati come primari in una o più anagrafiche. Di default il valore è false quindi non è consentita l'operazione.
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DelegateFileMove | Restituisce o imposta il delegate che, dopo la modifica dei record, viene chiamato dal comando per lo spostamento effettivo dei file. Se viene lasciato vuoto lo spostamento viene effettuatata dal comando. Chi implementa il delegate dovrebbe sollevare eccezioni in caso di errore per interrompere ed annullare tutta la procedura di spostamento documenti.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | MovingDocuments | Restituisce la lista dei documenti da spostare.
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non è impostato almeno un documento da spostare. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | NotToEraseStartingDocs | Restitusice la lista dei documenti di partenza che non devono essere eliminati. Risulteranno non più riconosciuti nel Database ma non saranno eliminati durante lo spostamento del documento.
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | ReplaceInAllParents | Restituisce o imposta se il comando debba aggiornare le dipendenze fisiche dei documenti che referenziano i file che si stanno rinominando ma che non sono compresi dall'operazione di rinomina (nel caso di file di Inventor). Di default è true quindi le dipendenze vengono aggiornate tutte, se false invece vengono aggiornate solo tra i file in fase di spostamento / rinomina.
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe MoveDocument
Namespace DedNet.Commands


Proprietà MoveDocument.AddMoveMarker

Proprietà MoveDocumentAddMoveMarker
Indica se creare il .moved

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AddMoveMarker { get; set; }
Public Property AddMoveMarker As Boolean
    Get
    Set
public:
property bool AddMoveMarker {
    bool get ();
    void set (bool value);
}
member AddMoveMarker : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe MoveDocument
Namespace DedNet.Commands


Proprietà MoveDocument.AllowedPrimaryFiles

Proprietà MoveDocumentAllowedPrimaryFiles
Restituisce o imposta se si debba concedere la possibilità di spostare / rinominare i file che sono referenziati come primari in una o più anagrafiche. Di default il valore è false quindi non è consentita l'operazione.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AllowedPrimaryFiles { get; set; }
Public Property AllowedPrimaryFiles As Boolean
    Get
    Set
public:
property bool AllowedPrimaryFiles {
    bool get ();
    void set (bool value);
}
member AllowedPrimaryFiles : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe MoveDocument
Namespace DedNet.Commands


Proprietà MoveDocument.DelegateFileMove

Proprietà MoveDocumentDelegateFileMove
Restituisce o imposta il delegate che, dopo la modifica dei record, viene chiamato dal comando per lo spostamento effettivo dei file. Se viene lasciato vuoto lo spostamento viene effettuatata dal comando. Chi implementa il delegate dovrebbe sollevare eccezioni in caso di errore per interrompere ed annullare tutta la procedura di spostamento documenti.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public FileOperationDelegate<MoveDocumentMoveDocumentList> DelegateFileMove { get; set; }
Public Property DelegateFileMove As FileOperationDelegate(Of MoveDocumentMoveDocumentList)
    Get
    Set
public:
property FileOperationDelegate<MoveDocumentMoveDocumentList^>^ DelegateFileMove {
    FileOperationDelegate<MoveDocumentMoveDocumentList^>^ get ();
    void set (FileOperationDelegate<MoveDocumentMoveDocumentList^>^ value);
}
member DelegateFileMove : FileOperationDelegate<MoveDocumentMoveDocumentList> with get, set

Valore della proprietà

FileOperationDelegate MoveDocumentMoveDocumentList
Vedi anche

Documentazione

Classe MoveDocument
Namespace DedNet.Commands


Proprietà MoveDocument.MovingDocuments

Proprietà MoveDocumentMovingDocuments
Restituisce la lista dei documenti da spostare.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public MoveDocumentMoveDocumentList MovingDocuments { get; }
Public ReadOnly Property MovingDocuments As MoveDocumentMoveDocumentList
    Get
public:
property MoveDocumentMoveDocumentList^ MovingDocuments {
    MoveDocumentMoveDocumentList^ get ();
}
member MovingDocuments : MoveDocumentMoveDocumentList with get

Valore della proprietà

MoveDocumentMoveDocumentList
Vedi anche

Documentazione

Classe MoveDocument
Namespace DedNet.Commands


Proprietà MoveDocument.NeedParameters

Proprietà MoveDocumentNeedParameters
Restituisce true se non è impostato almeno un documento da spostare.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe MoveDocument
Namespace DedNet.Commands


Proprietà MoveDocument.NotToEraseStartingDocs

Proprietà MoveDocumentNotToEraseStartingDocs
Restitusice la lista dei documenti di partenza che non devono essere eliminati. Risulteranno non più riconosciuti nel Database ma non saranno eliminati durante lo spostamento del documento.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocList NotToEraseStartingDocs { get; }
Public ReadOnly Property NotToEraseStartingDocs As DedDocList
    Get
public:
property DedDocList^ NotToEraseStartingDocs {
    DedDocList^ get ();
}
member NotToEraseStartingDocs : DedDocList with get

Valore della proprietà

DedDocList
Vedi anche

Documentazione

Classe MoveDocument
Namespace DedNet.Commands


Proprietà MoveDocument.ReplaceInAllParents

Proprietà MoveDocumentReplaceInAllParents
Restituisce o imposta se il comando debba aggiornare le dipendenze fisiche dei documenti che referenziano i file che si stanno rinominando ma che non sono compresi dall'operazione di rinomina (nel caso di file di Inventor). Di default è true quindi le dipendenze vengono aggiornate tutte, se false invece vengono aggiornate solo tra i file in fase di spostamento / rinomina.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ReplaceInAllParents { get; set; }
Public Property ReplaceInAllParents As Boolean
    Get
    Set
public:
property bool ReplaceInAllParents {
    bool get ();
    void set (bool value);
}
member ReplaceInAllParents : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe MoveDocument
Namespace DedNet.Commands


Metodi di MoveDocument

Il tipo MoveDocument espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato o meno in base alla selezione contestuale. Gli basta che sia selezionato un documento. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Gli basta che sia selezionato un documento. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe MoveDocument
Namespace DedNet.Commands


Metodo MoveDocument.ClearCommand

Metodo MoveDocumentClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe MoveDocument
Namespace DedNet.Commands


Metodo MoveDocument.Enabled

Metodo MoveDocumentEnabled
Restituisce se il comando sia abilitato o meno in base alla selezione contestuale. Gli basta che sia selezionato un documento.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe MoveDocument
Namespace DedNet.Commands


Metodo MoveDocument.ExecuteCommand

Metodo MoveDocumentExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe MoveDocument
Namespace DedNet.Commands


Metodo MoveDocument.SetContext

Metodo MoveDocumentSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Gli basta che sia selezionato un documento.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce sempre false.
Vedi anche

Documentazione

Classe MoveDocument
Namespace DedNet.Commands


Classe MoveDocument.MoveDocumentItem

Classe MoveDocumentMoveDocumentItem
Descrive un singolo documento da spostare.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsMoveDocumentMoveDocumentItem

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class MoveDocumentItem : IMoveCopyDocumentItem
Public Class MoveDocumentItem
    Implements IMoveCopyDocumentItem
public ref class MoveDocumentItem : IMoveCopyDocumentItem
type MoveDocumentItem =
    class
        interface IMoveCopyDocumentItem
    end

Il tipo MoveDocumentMoveDocumentItem espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | MoveDocumentMoveDocumentItem | Inizializza l'elemento.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | InfoItem | Restituisce la struttura del documento da spostare.
Proprietà pubblica | NewPath | Restituisce il nuovo path di destinazione del documento.
Proprietà pubblica | Reason | Restituisce il motivo dello spostamento.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Costruttore MoveDocument.MoveDocumentItem

Costruttore MoveDocumentMoveDocumentItem
Inizializza l'elemento.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public MoveDocumentItem(
    DocStructInfo infoItem,
    string newPath,
    DedDocMovReasonEnum reason
)
Public Sub New (
    infoItem As DocStructInfo,
    newPath As String,
    reason As DedDocMovReasonEnum
)
public:
MoveDocumentItem(
    DocStructInfo^ infoItem,
    String^ newPath,
    DedDocMovReasonEnum reason
)
new :
        infoItem : DocStructInfo *
        newPath : string *
        reason : DedDocMovReasonEnum -> MoveDocumentItem

Parametri

infoItem DocStructInfo
newPath String
reason DedDocMovReasonEnum
Vedi anche

Documentazione

Classe MoveDocumentMoveDocumentItem
Namespace DedNet.Commands


Proprietà di MoveDocumentItem

Il tipo MoveDocumentMoveDocumentItem espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | InfoItem | Restituisce la struttura del documento da spostare.
Proprietà pubblica | NewPath | Restituisce il nuovo path di destinazione del documento.
Proprietà pubblica | Reason | Restituisce il motivo dello spostamento.
Torna su
Vedi anche

Documentazione

Classe MoveDocumentMoveDocumentItem
Namespace DedNet.Commands


Proprietà MoveDocument.MoveDocumentItem.InfoItem

Proprietà MoveDocumentMoveDocumentItemInfoItem
Restituisce la struttura del documento da spostare.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfo InfoItem { get; }
Public ReadOnly Property InfoItem As DocStructInfo
    Get
public:
virtual property DocStructInfo^ InfoItem {
    DocStructInfo^ get () sealed;
}
abstract InfoItem : DocStructInfo with get
override InfoItem : DocStructInfo with get

Valore della proprietà

DocStructInfo

Implementa

IMoveCopyDocumentItemInfoItem
Vedi anche

Documentazione

Classe MoveDocumentMoveDocumentItem
Namespace DedNet.Commands


Proprietà MoveDocument.MoveDocumentItem.NewPath

Proprietà MoveDocumentMoveDocumentItemNewPath
Restituisce il nuovo path di destinazione del documento.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string NewPath { get; set; }
Public Property NewPath As String
    Get
    Set
public:
virtual property String^ NewPath {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract NewPath : string with get, set
override NewPath : string with get, set

Valore della proprietà

String

Implementa

IMoveCopyDocumentItemNewPath
Vedi anche

Documentazione

Classe MoveDocumentMoveDocumentItem
Namespace DedNet.Commands


Proprietà MoveDocument.MoveDocumentItem.Reason

Proprietà MoveDocumentMoveDocumentItemReason
Restituisce il motivo dello spostamento.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocMovReasonEnum Reason { get; }
Public ReadOnly Property Reason As DedDocMovReasonEnum
    Get
public:
property DedDocMovReasonEnum Reason {
    DedDocMovReasonEnum get ();
}
member Reason : DedDocMovReasonEnum with get

Valore della proprietà

DedDocMovReasonEnum
Vedi anche

Documentazione

Classe MoveDocumentMoveDocumentItem
Namespace DedNet.Commands


Classe MoveDocument.MoveDocumentList

Classe MoveDocumentMoveDocumentList
Lista di oggetti MoveDocumentItem.
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList IMoveCopyDocumentItem
DedNet.CommandsMoveDocumentMoveDocumentList

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class MoveDocumentList : List<IMoveCopyDocumentItem>
Public Class MoveDocumentList
    Inherits List(Of IMoveCopyDocumentItem)
public ref class MoveDocumentList : public List<IMoveCopyDocumentItem^>
type MoveDocumentList =
    class
        inherit List<IMoveCopyDocumentItem>
    end

Il tipo MoveDocumentMoveDocumentList espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllNewFileSpecified | Restituisce true se sono stati specificati dei percorsi di destinazione per tutti gli elementi della collezione.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Add(DocStructInfo, String, DedDocMovReasonEnum) | Aggiunge un nuovo elemento alla collezione.
Metodo pubblico | Add(String, String, DedDocMovReasonEnum) | Aggiunge un nuovo elemento alla collezione.
Metodo pubblico | FindByDocId | Restituisce l'elemento avente DocId specificato, oppure null se non è presente.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di MoveDocumentList

Il tipo MoveDocumentMoveDocumentList espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllNewFileSpecified | Restituisce true se sono stati specificati dei percorsi di destinazione per tutti gli elementi della collezione.
Torna su
Vedi anche

Documentazione

Classe MoveDocumentMoveDocumentList
Namespace DedNet.Commands


Proprietà MoveDocument.MoveDocumentList.AllNewFileSpecified

Proprietà MoveDocumentMoveDocumentListAllNewFileSpecified
Restituisce true se sono stati specificati dei percorsi di destinazione per tutti gli elementi della collezione.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AllNewFileSpecified { get; }
Public ReadOnly Property AllNewFileSpecified As Boolean
    Get
public:
property bool AllNewFileSpecified {
    bool get ();
}
member AllNewFileSpecified : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe MoveDocumentMoveDocumentList
Namespace DedNet.Commands


Metodi di MoveDocumentList

Il tipo MoveDocumentMoveDocumentList espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Add(DocStructInfo, String, DedDocMovReasonEnum) | Aggiunge un nuovo elemento alla collezione.
Metodo pubblico | Add(String, String, DedDocMovReasonEnum) | Aggiunge un nuovo elemento alla collezione.
Metodo pubblico | FindByDocId | Restituisce l'elemento avente DocId specificato, oppure null se non è presente.
Torna su
Vedi anche

Documentazione

Classe MoveDocumentMoveDocumentList
Namespace DedNet.Commands


Metodo MoveDocument.MoveDocumentList.Add

Metodo MoveDocumentMoveDocumentListAdd
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Add(DocStructInfo, String, DedDocMovReasonEnum) | Aggiunge un nuovo elemento alla collezione.
Metodo pubblico | Add(String, String, DedDocMovReasonEnum) | Aggiunge un nuovo elemento alla collezione.
Torna su
Vedi anche

Documentazione

Classe MoveDocumentMoveDocumentList
Namespace DedNet.Commands


Metodo MoveDocument.MoveDocumentList.Add(DocStructInfo, String, DedDoc.MovReasonEnum)

Metodo MoveDocumentMoveDocumentListAdd(DocStructInfo, String, DedDocMovReasonEnum)
Aggiunge un nuovo elemento alla collezione.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public MoveDocumentMoveDocumentItem Add(
    DocStructInfo _ds,
    string newPath,
    DedDocMovReasonEnum reason
)
Public Function Add (
    _ds As DocStructInfo,
    newPath As String,
    reason As DedDocMovReasonEnum
) As MoveDocumentMoveDocumentItem
public:
MoveDocumentMoveDocumentItem^ Add(
    DocStructInfo^ _ds,
    String^ newPath,
    DedDocMovReasonEnum reason
)
member Add :
        _ds : DocStructInfo *
        newPath : string *
        reason : DedDocMovReasonEnum -> MoveDocumentMoveDocumentItem

Parametri

_ds DocStructInfo
newPath String
Nome completo che l'elemento dovrà avere.
reason DedDocMovReasonEnum
Motivo dello spostamento.

Valore di ritorno

MoveDocumentMoveDocumentItem
Vedi anche

Documentazione

Classe MoveDocumentMoveDocumentList
Overload di Add
Namespace DedNet.Commands


Metodo MoveDocument.MoveDocumentList.Add(String, String, DedDoc.MovReasonEnum)

Metodo MoveDocumentMoveDocumentListAdd(String, String, DedDocMovReasonEnum)
Aggiunge un nuovo elemento alla collezione.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public MoveDocumentMoveDocumentItem Add(
    string fileName,
    string newPath,
    DedDocMovReasonEnum reason
)
Public Function Add (
    fileName As String,
    newPath As String,
    reason As DedDocMovReasonEnum
) As MoveDocumentMoveDocumentItem
public:
MoveDocumentMoveDocumentItem^ Add(
    String^ fileName,
    String^ newPath,
    DedDocMovReasonEnum reason
)
member Add :
        fileName : string *
        newPath : string *
        reason : DedDocMovReasonEnum -> MoveDocumentMoveDocumentItem

Parametri

fileName String
Elemento da aggiungere.
newPath String
Nome completo che l'elemento dovrà avere.
reason DedDocMovReasonEnum
Motivo dello spostamento.

Valore di ritorno

MoveDocumentMoveDocumentItem
Vedi anche

Documentazione

Classe MoveDocumentMoveDocumentList
Overload di Add
Namespace DedNet.Commands


Metodo MoveDocument.MoveDocumentList.FindByDocId

Metodo MoveDocumentMoveDocumentListFindByDocId
Restituisce l'elemento avente DocId specificato, oppure null se non è presente.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public MoveDocumentMoveDocumentItem FindByDocId(
    Guid docid
)
Public Function FindByDocId (
    docid As Guid
) As MoveDocumentMoveDocumentItem
public:
MoveDocumentMoveDocumentItem^ FindByDocId(
    Guid docid
)
member FindByDocId :
        docid : Guid -> MoveDocumentMoveDocumentItem

Parametri

docid Guid
DocId da utilizzare pe cercare l'elemento.

Valore di ritorno

MoveDocumentMoveDocumentItem
Restituisce l'elemento trovato oppure null.
Vedi anche

Documentazione

Classe MoveDocumentMoveDocumentList
Namespace DedNet.Commands


Classe NotifyCommand
Classe che rappresenta il comando per visualizzare i backup.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsNotifyCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class NotifyCommand : DedCommand
Public Class NotifyCommand
    Inherits DedCommand
public ref class NotifyCommand : public DedCommand
type NotifyCommand =
    class
        inherit DedCommand
    end

Il tipo NotifyCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di NotifyCommand

Il tipo NotifyCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe NotifyCommand
Namespace DedNet.Commands


Proprietà NotifyCommand.NeedParameters

Proprietà NotifyCommandNeedParameters

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe NotifyCommand
Namespace DedNet.Commands


Metodi di NotifyCommand

Il tipo NotifyCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe NotifyCommand
Namespace DedNet.Commands


Metodo NotifyCommand.ClearCommand

Metodo NotifyCommandClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe NotifyCommand
Namespace DedNet.Commands


Metodo NotifyCommand.Enabled

Metodo NotifyCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe NotifyCommand
Namespace DedNet.Commands


Metodo NotifyCommand.ExecuteCommand

Metodo NotifyCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe NotifyCommand
Namespace DedNet.Commands


Metodo NotifyCommand.SetContext

Metodo NotifyCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe NotifyCommand
Namespace DedNet.Commands


Classe OpenAssocFilesCommand
Classe che rappresenta il comando per aprire uno o più file associati ad una anagrafica escludo un particolare documento.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsOpenAssocFilesCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class OpenAssocFilesCommand : DedCommand
Public Class OpenAssocFilesCommand
    Inherits DedCommand
public ref class OpenAssocFilesCommand : public DedCommand
type OpenAssocFilesCommand =
    class
        inherit DedCommand
    end

Il tipo OpenAssocFilesCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Config | Configurazione
Proprietà pubblica | Data | Restituisce o imposta l'anagrafica della quale aprire i file associati (primari).
Proprietà pubblica | Doc | Restituisce o imposta il Documento, che se presente, deve essere escluso dalla lista di selezione. Può essere null.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce se il comando non sia ancora stato inizializzato a sufficienza. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OpenReadOnly | Restitusice o imposta se l'apertura debba essere in sola lettura. Di default è false ed apre in scrittura.
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowAttachFiles | Restitusice o imposta se l'apertura debba visualizzare i file allegati. Di default è false ed apre i file associati.
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulisce il comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di OpenAssocFilesCommand

Il tipo OpenAssocFilesCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Config | Configurazione
Proprietà pubblica | Data | Restituisce o imposta l'anagrafica della quale aprire i file associati (primari).
Proprietà pubblica | Doc | Restituisce o imposta il Documento, che se presente, deve essere escluso dalla lista di selezione. Può essere null.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce se il comando non sia ancora stato inizializzato a sufficienza. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OpenReadOnly | Restitusice o imposta se l'apertura debba essere in sola lettura. Di default è false ed apre in scrittura.
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowAttachFiles | Restitusice o imposta se l'apertura debba visualizzare i file allegati. Di default è false ed apre i file associati.
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe OpenAssocFilesCommand
Namespace DedNet.Commands


Proprietà OpenAssocFilesCommand.Config

Proprietà OpenAssocFilesCommandConfig
Configurazione

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Config { get; set; }
Public Property Config As String
    Get
    Set
public:
property String^ Config {
    String^ get ();
    void set (String^ value);
}
member Config : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe OpenAssocFilesCommand
Namespace DedNet.Commands


Proprietà OpenAssocFilesCommand.Data

Proprietà OpenAssocFilesCommandData
Restituisce o imposta l'anagrafica della quale aprire i file associati (primari).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; set; }
Public Property Data As DedData
    Get
    Set
public:
property DedData^ Data {
    DedData^ get ();
    void set (DedData^ value);
}
member Data : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe OpenAssocFilesCommand
Namespace DedNet.Commands


Proprietà OpenAssocFilesCommand.Doc

Proprietà OpenAssocFilesCommandDoc
Restituisce o imposta il Documento, che se presente, deve essere escluso dalla lista di selezione. Può essere null.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDoc Doc { get; set; }
Public Property Doc As DedDoc
    Get
    Set
public:
property DedDoc^ Doc {
    DedDoc^ get ();
    void set (DedDoc^ value);
}
member Doc : DedDoc with get, set

Valore della proprietà

DedDoc
Vedi anche

Documentazione

Classe OpenAssocFilesCommand
Namespace DedNet.Commands


Proprietà OpenAssocFilesCommand.NeedParameters

Proprietà OpenAssocFilesCommandNeedParameters
Restituisce se il comando non sia ancora stato inizializzato a sufficienza.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe OpenAssocFilesCommand
Namespace DedNet.Commands


Proprietà OpenAssocFilesCommand.OpenReadOnly

Proprietà OpenAssocFilesCommandOpenReadOnly
Restitusice o imposta se l'apertura debba essere in sola lettura. Di default è false ed apre in scrittura.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool OpenReadOnly { get; set; }
Public Property OpenReadOnly As Boolean
    Get
    Set
public:
property bool OpenReadOnly {
    bool get ();
    void set (bool value);
}
member OpenReadOnly : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe OpenAssocFilesCommand
Namespace DedNet.Commands


Proprietà OpenAssocFilesCommand.ShowAttachFiles

Proprietà OpenAssocFilesCommandShowAttachFiles
Restitusice o imposta se l'apertura debba visualizzare i file allegati. Di default è false ed apre i file associati.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ShowAttachFiles { get; set; }
Public Property ShowAttachFiles As Boolean
    Get
    Set
public:
property bool ShowAttachFiles {
    bool get ();
    void set (bool value);
}
member ShowAttachFiles : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe OpenAssocFilesCommand
Namespace DedNet.Commands


Metodi di OpenAssocFilesCommand

Il tipo OpenAssocFilesCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulisce il comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe OpenAssocFilesCommand
Namespace DedNet.Commands


Metodo OpenAssocFilesCommand.ClearCommand

Metodo OpenAssocFilesCommandClearCommand
Pulisce il comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe OpenAssocFilesCommand
Namespace DedNet.Commands


Metodo OpenAssocFilesCommand.Enabled

Metodo OpenAssocFilesCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe OpenAssocFilesCommand
Namespace DedNet.Commands


Metodo OpenAssocFilesCommand.ExecuteCommand

Metodo OpenAssocFilesCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe OpenAssocFilesCommand
Namespace DedNet.Commands


Metodo OpenAssocFilesCommand.SetContext

Metodo OpenAssocFilesCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe OpenAssocFilesCommand
Namespace DedNet.Commands


Classe OpenCommCommand
Comando apertura di una commessa.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsOpenCommCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class OpenCommCommand : DedCommand
Public Class OpenCommCommand
    Inherits DedCommand
public ref class OpenCommCommand : public DedCommand
type OpenCommCommand =
    class
        inherit DedCommand
    end

Il tipo OpenCommCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se si vuole creare una sotto commessa ma non si passa il riferimento. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | ReferenceComm | Commessa di riferimento
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di OpenCommCommand

Il tipo OpenCommCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se si vuole creare una sotto commessa ma non si passa il riferimento. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | ReferenceComm | Commessa di riferimento
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe OpenCommCommand
Namespace DedNet.Commands


Proprietà OpenCommCommand.NeedParameters

Proprietà OpenCommCommandNeedParameters
Restituisce true se si vuole creare una sotto commessa ma non si passa il riferimento.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe OpenCommCommand
Namespace DedNet.Commands


Proprietà OpenCommCommand.ReferenceComm

Proprietà OpenCommCommandReferenceComm
Commessa di riferimento

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedComm ReferenceComm { get; set; }
Public Property ReferenceComm As DedComm
    Get
    Set
public:
property DedComm^ ReferenceComm {
    DedComm^ get ();
    void set (DedComm^ value);
}
member ReferenceComm : DedComm with get, set

Valore della proprietà

DedComm
Vedi anche

Documentazione

Classe OpenCommCommand
Namespace DedNet.Commands


Metodi di OpenCommCommand

Il tipo OpenCommCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe OpenCommCommand
Namespace DedNet.Commands


Metodo OpenCommCommand.ClearCommand

Metodo OpenCommCommandClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe OpenCommCommand
Namespace DedNet.Commands


Metodo OpenCommCommand.Enabled

Metodo OpenCommCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe OpenCommCommand
Namespace DedNet.Commands


Metodo OpenCommCommand.ExecuteCommand

Metodo OpenCommCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe OpenCommCommand
Namespace DedNet.Commands


Metodo OpenCommCommand.SetContext

Metodo OpenCommCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto c'è una sola anagrafica alla quale associare il file.
Vedi anche

Documentazione

Classe OpenCommCommand
Namespace DedNet.Commands


Classe OpenFilePathCommand
Classe che rappresenta il comando per cambiare la password dell'utente.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsOpenFilePathCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class OpenFilePathCommand : DedCommand
Public Class OpenFilePathCommand
    Inherits DedCommand
public ref class OpenFilePathCommand : public DedCommand
type OpenFilePathCommand =
    class
        inherit DedCommand
    end

Il tipo OpenFilePathCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Doc |
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di OpenFilePathCommand

Il tipo OpenFilePathCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Doc |
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe OpenFilePathCommand
Namespace DedNet.Commands


Proprietà OpenFilePathCommand.Doc

Proprietà OpenFilePathCommandDoc

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDoc Doc { get; set; }
Public Property Doc As DedDoc
    Get
    Set
public:
property DedDoc^ Doc {
    DedDoc^ get ();
    void set (DedDoc^ value);
}
member Doc : DedDoc with get, set

Valore della proprietà

DedDoc
Vedi anche

Documentazione

Classe OpenFilePathCommand
Namespace DedNet.Commands


Proprietà OpenFilePathCommand.NeedParameters

Proprietà OpenFilePathCommandNeedParameters

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe OpenFilePathCommand
Namespace DedNet.Commands


Metodi di OpenFilePathCommand

Il tipo OpenFilePathCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe OpenFilePathCommand
Namespace DedNet.Commands


Metodo OpenFilePathCommand.ClearCommand

Metodo OpenFilePathCommandClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe OpenFilePathCommand
Namespace DedNet.Commands


Metodo OpenFilePathCommand.Enabled

Metodo OpenFilePathCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe OpenFilePathCommand
Namespace DedNet.Commands


Metodo OpenFilePathCommand.ExecuteCommand

Metodo OpenFilePathCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe OpenFilePathCommand
Namespace DedNet.Commands


Metodo OpenFilePathCommand.SetContext

Metodo OpenFilePathCommandSetContext

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe OpenFilePathCommand
Namespace DedNet.Commands


Classe OpenReadDocument
Apre un documento in lettura.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsDedDocumentCommand
DedNet.CommandsOpenReadDocument

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class OpenReadDocument : DedDocumentCommand
Public Class OpenReadDocument
    Inherits DedDocumentCommand
public ref class OpenReadDocument : public DedDocumentCommand
type OpenReadDocument =
    class
        inherit DedDocumentCommand
    end

Il tipo OpenReadDocument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DocumentInfos | Restituisce la lista dei documenti con abbinato il contesto di anagrafica di elaborazione comando. (Ereditato da DedDocumentCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce false se non esiste nemmeno un documento sul quale eseguire il comando. (Ereditato da DedDocumentCommand)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Reinizializza il comando. (Ereditato da DedDocumentCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedDocumentCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedDocumentCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedDocumentCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedDocumentCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di OpenReadDocument

Il tipo OpenReadDocument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DocumentInfos | Restituisce la lista dei documenti con abbinato il contesto di anagrafica di elaborazione comando. (Ereditato da DedDocumentCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce false se non esiste nemmeno un documento sul quale eseguire il comando. (Ereditato da DedDocumentCommand)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe OpenReadDocument
Namespace DedNet.Commands


Metodi di OpenReadDocument

Il tipo OpenReadDocument espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Reinizializza il comando. (Ereditato da DedDocumentCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedDocumentCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedDocumentCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedDocumentCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedDocumentCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe OpenReadDocument
Namespace DedNet.Commands


Metodo OpenReadDocument.Enabled

Metodo OpenReadDocumentEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe OpenReadDocument
Namespace DedNet.Commands


Metodo OpenReadDocument.ExecuteCommand

Metodo OpenReadDocumentExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe OpenReadDocument
Namespace DedNet.Commands


Metodo OpenReadDocument.SetContext

Metodo OpenReadDocumentSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe OpenReadDocument
Namespace DedNet.Commands


Classe OpenWriteDocument
Apre un documento in scrittura.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsDedDocumentCommand
DedNet.CommandsOpenWriteDocument

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class OpenWriteDocument : DedDocumentCommand
Public Class OpenWriteDocument
    Inherits DedDocumentCommand
public ref class OpenWriteDocument : public DedDocumentCommand
type OpenWriteDocument =
    class
        inherit DedDocumentCommand
    end

Il tipo OpenWriteDocument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DocumentInfos | Restituisce la lista dei documenti con abbinato il contesto di anagrafica di elaborazione comando. (Ereditato da DedDocumentCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce false se non esiste nemmeno un documento sul quale eseguire il comando. (Ereditato da DedDocumentCommand)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | ReadOnly | Restituisce se, pur trattandosi del comando di apertura in scrittura, si stia aprendo in sola lettura per via dei permessi dell'utente o per lo stato del documento.
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Sovrascrive DedDocumentCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedDocumentCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedDocumentCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedDocumentCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedDocumentCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di OpenWriteDocument

Il tipo OpenWriteDocument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DocumentInfos | Restituisce la lista dei documenti con abbinato il contesto di anagrafica di elaborazione comando. (Ereditato da DedDocumentCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce false se non esiste nemmeno un documento sul quale eseguire il comando. (Ereditato da DedDocumentCommand)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | ReadOnly | Restituisce se, pur trattandosi del comando di apertura in scrittura, si stia aprendo in sola lettura per via dei permessi dell'utente o per lo stato del documento.
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe OpenWriteDocument
Namespace DedNet.Commands


Proprietà OpenWriteDocument.ReadOnly

Proprietà OpenWriteDocumentReadOnly
Restituisce se, pur trattandosi del comando di apertura in scrittura, si stia aprendo in sola lettura per via dei permessi dell'utente o per lo stato del documento.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ReadOnly { get; }
Public ReadOnly Property ReadOnly As Boolean
    Get
public:
property bool ReadOnly {
    bool get ();
}
member ReadOnly : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe OpenWriteDocument
Namespace DedNet.Commands


Metodi di OpenWriteDocument

Il tipo OpenWriteDocument espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Sovrascrive DedDocumentCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedDocumentCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedDocumentCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedDocumentCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedDocumentCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe OpenWriteDocument
Namespace DedNet.Commands


Metodo OpenWriteDocument.ClearCommand

Metodo OpenWriteDocumentClearCommand
Azzera il comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe OpenWriteDocument
Namespace DedNet.Commands


Metodo OpenWriteDocument.Enabled

Metodo OpenWriteDocumentEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe OpenWriteDocument
Namespace DedNet.Commands


Metodo OpenWriteDocument.ExecuteCommand

Metodo OpenWriteDocumentExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe OpenWriteDocument
Namespace DedNet.Commands


Metodo OpenWriteDocument.SetContext

Metodo OpenWriteDocumentSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe OpenWriteDocument
Namespace DedNet.Commands


Enumerazione OperationKindEnum

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum OperationKindEnum
Public Enumeration OperationKindEnum
public enum class OperationKindEnum
type OperationKindEnum
Membri
Nome | Valore | Descrizione
Revisione | 0 |
Salva | 1 |
Variante | 2 |
Duplica | 3 |
Associa | 4 |
Rappresentazione | 5 |
Archivia | 6 |
Vedi anche

Documentazione

Namespace DedNet.Commands


Delegate ParamRest<T, A>

Delegate ParamRestT, A
Delegate utilizzato per passare un parametro e averne restituito un altro che può essere differente.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public delegate A ParamRest<T, A>(
    T obj
)

Public Delegate Function ParamRest(Of T, A) (
    obj As T
) As A
generic<typename T, typename A>
public delegate A ParamRest(
    T obj
)
type ParamRest =
    delegate of
        obj : 'T -> 'A

Parametri

obj T
Nome della variabile passata come argomento.

Parametri di tipo

T
Parametro argomento.
A
Parametro restituito.

Valore di ritorno

A
Restitusice il parametro di tipo A.
Vedi anche

Documentazione

Namespace DedNet.Commands


Classe PrintDocumentCommand
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsPrintDocumentCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class PrintDocumentCommand : DedCommand
Public Class PrintDocumentCommand
    Inherits DedCommand
public ref class PrintDocumentCommand : public DedCommand
type PrintDocumentCommand =
    class
        inherit DedCommand
    end

Il tipo PrintDocumentCommand espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | PrintDocumentCommand | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve essere impostata la struttura di salvataggio distinta. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Eseguo il comando. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Imposto il contesto per l'esecuzione del comando (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Costruttore PrintDocumentCommand
Costruttore unico.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public PrintDocumentCommand(
    DedNetApplication app,
    string internalName,
    string name
)
Public Sub New (
    app As DedNetApplication,
    internalName As String,
    name As String
)
public:
PrintDocumentCommand(
    DedNetApplication^ app,
    String^ internalName,
    String^ name
)
new :
        app : DedNetApplication *
        internalName : string *
        name : string -> PrintDocumentCommand

Parametri

app DedNetApplication
Riferimento all'oggetto DedNetApplication.
internalName String
Nome interno del comando.
name String
Nome visualizzato del comando.
Vedi anche

Documentazione

Classe PrintDocumentCommand
Namespace DedNet.Commands


Proprietà di PrintDocumentCommand

Il tipo PrintDocumentCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve essere impostata la struttura di salvataggio distinta. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe PrintDocumentCommand
Namespace DedNet.Commands


Proprietà PrintDocumentCommand.NeedParameters

Proprietà PrintDocumentCommandNeedParameters
Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve essere impostata la struttura di salvataggio distinta.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe PrintDocumentCommand
Namespace DedNet.Commands


Metodi di PrintDocumentCommand

Il tipo PrintDocumentCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Eseguo il comando. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Imposto il contesto per l'esecuzione del comando (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe PrintDocumentCommand
Namespace DedNet.Commands


Metodo PrintDocumentCommand.ClearCommand

Metodo PrintDocumentCommandClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe PrintDocumentCommand
Namespace DedNet.Commands


Metodo PrintDocumentCommand.Enabled

Metodo PrintDocumentCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce True se il comando deve risultare abilitato all'utente, False altrimenti.
Vedi anche

Documentazione

Classe PrintDocumentCommand
Namespace DedNet.Commands


Metodo PrintDocumentCommand.ExecuteCommand

Metodo PrintDocumentCommandExecuteCommand
Eseguo il comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe PrintDocumentCommand
Namespace DedNet.Commands


Metodo PrintDocumentCommand.SetContext

Metodo PrintDocumentCommandSetContext
Imposto il contesto per l'esecuzione del comando

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe PrintDocumentCommand
Namespace DedNet.Commands


Classe PropertiesManagerCommand
Classe che rappresenta il comando per editare le variabili delle DedDocProperties.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsPropertiesManagerCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class PropertiesManagerCommand : DedCommand
Public Class PropertiesManagerCommand
    Inherits DedCommand
public ref class PropertiesManagerCommand : public DedCommand
type PropertiesManagerCommand =
    class
        inherit DedCommand
    end

Il tipo PropertiesManagerCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Ritorna se il comando necessita di parametri. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di PropertiesManagerCommand

Il tipo PropertiesManagerCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Ritorna se il comando necessita di parametri. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe PropertiesManagerCommand
Namespace DedNet.Commands


Proprietà PropertiesManagerCommand.NeedParameters

Proprietà PropertiesManagerCommandNeedParameters
Ritorna se il comando necessita di parametri.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe PropertiesManagerCommand
Namespace DedNet.Commands


Metodi di PropertiesManagerCommand

Il tipo PropertiesManagerCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe PropertiesManagerCommand
Namespace DedNet.Commands


Metodo PropertiesManagerCommand.ClearCommand

Metodo PropertiesManagerCommandClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe PropertiesManagerCommand
Namespace DedNet.Commands


Metodo PropertiesManagerCommand.Enabled

Metodo PropertiesManagerCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe PropertiesManagerCommand
Namespace DedNet.Commands


Metodo PropertiesManagerCommand.ExecuteCommand

Metodo PropertiesManagerCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe PropertiesManagerCommand
Namespace DedNet.Commands


Metodo PropertiesManagerCommand.SetContext

Metodo PropertiesManagerCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe PropertiesManagerCommand
Namespace DedNet.Commands


Classe PublicationFilesMangerCommand
Classe che rappresenta il comando per editare gli stati.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsPublicationFilesMangerCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class PublicationFilesMangerCommand : DedCommand
Public Class PublicationFilesMangerCommand
    Inherits DedCommand
public ref class PublicationFilesMangerCommand : public DedCommand
type PublicationFilesMangerCommand =
    class
        inherit DedCommand
    end

Il tipo PublicationFilesMangerCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Indica se il comando ha bisogno di parametri o meno. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di PublicationFilesMangerCommand

Il tipo PublicationFilesMangerCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Indica se il comando ha bisogno di parametri o meno. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe PublicationFilesMangerCommand
Namespace DedNet.Commands


Proprietà PublicationFilesMangerCommand.NeedParameters

Proprietà PublicationFilesMangerCommandNeedParameters
Indica se il comando ha bisogno di parametri o meno.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe PublicationFilesMangerCommand
Namespace DedNet.Commands


Metodi di PublicationFilesMangerCommand

Il tipo PublicationFilesMangerCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe PublicationFilesMangerCommand
Namespace DedNet.Commands


Metodo PublicationFilesMangerCommand.ClearCommand

Metodo PublicationFilesMangerCommandClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe PublicationFilesMangerCommand
Namespace DedNet.Commands


Metodo PublicationFilesMangerCommand.Enabled

Metodo PublicationFilesMangerCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe PublicationFilesMangerCommand
Namespace DedNet.Commands


Metodo PublicationFilesMangerCommand.ExecuteCommand

Metodo PublicationFilesMangerCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe PublicationFilesMangerCommand
Namespace DedNet.Commands


Metodo PublicationFilesMangerCommand.SetContext

Metodo PublicationFilesMangerCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe PublicationFilesMangerCommand
Namespace DedNet.Commands


Classe PublishDocument
Effettua la pubblicazione di una lista di documenti che precedentemente sono stati messi in checkout.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsPublishDocument

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class PublishDocument : DedCommand
Public Class PublishDocument
    Inherits DedCommand
public ref class PublishDocument : public DedCommand
type PublishDocument =
    class
        inherit DedCommand
    end

Il tipo PublishDocument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | FileList | Restituisce la lista dei documenti da impostare in checkout. Inserire in questa lista solo i file che si desidera elaborare e non le dipendenze.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non sono presenti documenti da elaborare. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | Restitusice o imposta se il check-in debba essere effettuato su tutta la struttura (di default è false).
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di PublishDocument

Il tipo PublishDocument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | FileList | Restituisce la lista dei documenti da impostare in checkout. Inserire in questa lista solo i file che si desidera elaborare e non le dipendenze.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non sono presenti documenti da elaborare. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | Struttura | Restitusice o imposta se il check-in debba essere effettuato su tutta la struttura (di default è false).
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe PublishDocument
Namespace DedNet.Commands


Proprietà PublishDocument.FileList

Proprietà PublishDocumentFileList
Restituisce la lista dei documenti da impostare in checkout. Inserire in questa lista solo i file che si desidera elaborare e non le dipendenze.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfoList FileList { get; }
Public ReadOnly Property FileList As DocStructInfoList
    Get
public:
property DocStructInfoList^ FileList {
    DocStructInfoList^ get ();
}
member FileList : DocStructInfoList with get

Valore della proprietà

DocStructInfoList
Vedi anche

Documentazione

Classe PublishDocument
Namespace DedNet.Commands


Proprietà PublishDocument.NeedParameters

Proprietà PublishDocumentNeedParameters
Restituisce true se non sono presenti documenti da elaborare.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe PublishDocument
Namespace DedNet.Commands


Proprietà PublishDocument.Struttura

Proprietà PublishDocumentStruttura
Restitusice o imposta se il check-in debba essere effettuato su tutta la struttura (di default è false).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Struttura { get; set; }
Public Property Struttura As Boolean
    Get
    Set
public:
property bool Struttura {
    bool get ();
    void set (bool value);
}
member Struttura : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe PublishDocument
Namespace DedNet.Commands


Metodi di PublishDocument

Il tipo PublishDocument espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe PublishDocument
Namespace DedNet.Commands


Metodo PublishDocument.ClearCommand

Metodo PublishDocumentClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe PublishDocument
Namespace DedNet.Commands


Metodo PublishDocument.Enabled

Metodo PublishDocumentEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe PublishDocument
Namespace DedNet.Commands


Metodo PublishDocument.ExecuteCommand

Metodo PublishDocumentExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe PublishDocument
Namespace DedNet.Commands


Metodo PublishDocument.SetContext

Metodo PublishDocumentSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto c'è una sola anagrafica alla quale associare il file.
Vedi anche

Documentazione

Classe PublishDocument
Namespace DedNet.Commands


Classe PwsBackupCommand
Classe che rappresenta il comando per visualizzare i backup.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsPwsBackupCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class PwsBackupCommand : DedCommand
Public Class PwsBackupCommand
    Inherits DedCommand
public ref class PwsBackupCommand : public DedCommand
type PwsBackupCommand =
    class
        inherit DedCommand
    end

Il tipo PwsBackupCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | EraseBackup |
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di PwsBackupCommand

Il tipo PwsBackupCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | EraseBackup |
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe PwsBackupCommand
Namespace DedNet.Commands


Proprietà PwsBackupCommand.EraseBackup

Proprietà PwsBackupCommandEraseBackup

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool EraseBackup { get; set; }
Public Property EraseBackup As Boolean
    Get
    Set
public:
property bool EraseBackup {
    bool get ();
    void set (bool value);
}
member EraseBackup : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe PwsBackupCommand
Namespace DedNet.Commands


Proprietà PwsBackupCommand.NeedParameters

Proprietà PwsBackupCommandNeedParameters

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe PwsBackupCommand
Namespace DedNet.Commands


Metodi di PwsBackupCommand

Il tipo PwsBackupCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe PwsBackupCommand
Namespace DedNet.Commands


Metodo PwsBackupCommand.ClearCommand

Metodo PwsBackupCommandClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe PwsBackupCommand
Namespace DedNet.Commands


Metodo PwsBackupCommand.Enabled

Metodo PwsBackupCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe PwsBackupCommand
Namespace DedNet.Commands


Metodo PwsBackupCommand.ExecuteCommand

Metodo PwsBackupCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe PwsBackupCommand
Namespace DedNet.Commands


Metodo PwsBackupCommand.SetContext

Metodo PwsBackupCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe PwsBackupCommand
Namespace DedNet.Commands


Classe PwsCacheCommand
Classe che rappresenta il comando per visualizzare lo stato dell'area locale..
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsPwsCacheCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class PwsCacheCommand : DedCommand
Public Class PwsCacheCommand
    Inherits DedCommand
public ref class PwsCacheCommand : public DedCommand
type PwsCacheCommand =
    class
        inherit DedCommand
    end

Il tipo PwsCacheCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | ExtToHide | Permette di impostare la lista delle estensioni da non visualizzare.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di PwsCacheCommand

Il tipo PwsCacheCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | ExtToHide | Permette di impostare la lista delle estensioni da non visualizzare.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe PwsCacheCommand
Namespace DedNet.Commands


Proprietà PwsCacheCommand.ExtToHide

Proprietà PwsCacheCommandExtToHide
Permette di impostare la lista delle estensioni da non visualizzare.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> ExtToHide { get; }
Public ReadOnly Property ExtToHide As List(Of String)
    Get
public:
property List<String^>^ ExtToHide {
    List<String^>^ get ();
}
member ExtToHide : List<string> with get

Valore della proprietà

List String
Vedi anche

Documentazione

Classe PwsCacheCommand
Namespace DedNet.Commands


Proprietà PwsCacheCommand.NeedParameters

Proprietà PwsCacheCommandNeedParameters

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe PwsCacheCommand
Namespace DedNet.Commands


Metodi di PwsCacheCommand

Il tipo PwsCacheCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe PwsCacheCommand
Namespace DedNet.Commands


Metodo PwsCacheCommand.ClearCommand

Metodo PwsCacheCommandClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe PwsCacheCommand
Namespace DedNet.Commands


Metodo PwsCacheCommand.Enabled

Metodo PwsCacheCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe PwsCacheCommand
Namespace DedNet.Commands


Metodo PwsCacheCommand.ExecuteCommand

Metodo PwsCacheCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe PwsCacheCommand
Namespace DedNet.Commands


Metodo PwsCacheCommand.SetContext

Metodo PwsCacheCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe PwsCacheCommand
Namespace DedNet.Commands


Classe QsManagerCommand
Classe che rappresenta il comando per editare le famiglie e gli attributi.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsQsManagerCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class QsManagerCommand : DedCommand
Public Class QsManagerCommand
    Inherits DedCommand
public ref class QsManagerCommand : public DedCommand
type QsManagerCommand =
    class
        inherit DedCommand
    end

Il tipo QsManagerCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di QsManagerCommand

Il tipo QsManagerCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe QsManagerCommand
Namespace DedNet.Commands


Proprietà QsManagerCommand.NeedParameters

Proprietà QsManagerCommandNeedParameters

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe QsManagerCommand
Namespace DedNet.Commands


Metodi di QsManagerCommand

Il tipo QsManagerCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe QsManagerCommand
Namespace DedNet.Commands


Metodo QsManagerCommand.ClearCommand

Metodo QsManagerCommandClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe QsManagerCommand
Namespace DedNet.Commands


Metodo QsManagerCommand.Enabled

Metodo QsManagerCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe QsManagerCommand
Namespace DedNet.Commands


Metodo QsManagerCommand.ExecuteCommand

Metodo QsManagerCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe QsManagerCommand
Namespace DedNet.Commands


Metodo QsManagerCommand.SetContext

Metodo QsManagerCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe QsManagerCommand
Namespace DedNet.Commands


Classe QsManagerCommCommand
Classe che rappresenta il comando per editare le famiglie e gli attributi.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsQsManagerCommCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class QsManagerCommCommand : DedCommand
Public Class QsManagerCommCommand
    Inherits DedCommand
public ref class QsManagerCommCommand : public DedCommand
type QsManagerCommCommand =
    class
        inherit DedCommand
    end

Il tipo QsManagerCommCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di QsManagerCommCommand

Il tipo QsManagerCommCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe QsManagerCommCommand
Namespace DedNet.Commands


Proprietà QsManagerCommCommand.NeedParameters

Proprietà QsManagerCommCommandNeedParameters

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe QsManagerCommCommand
Namespace DedNet.Commands


Metodi di QsManagerCommCommand

Il tipo QsManagerCommCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe QsManagerCommCommand
Namespace DedNet.Commands


Metodo QsManagerCommCommand.ClearCommand

Metodo QsManagerCommCommandClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe QsManagerCommCommand
Namespace DedNet.Commands


Metodo QsManagerCommCommand.Enabled

Metodo QsManagerCommCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe QsManagerCommCommand
Namespace DedNet.Commands


Metodo QsManagerCommCommand.ExecuteCommand

Metodo QsManagerCommCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe QsManagerCommCommand
Namespace DedNet.Commands


Metodo QsManagerCommCommand.SetContext

Metodo QsManagerCommCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe QsManagerCommCommand
Namespace DedNet.Commands


Classe QsReserveProgCommand
Classe che rappresenta il comando per riservare i progressivi ai vari utenti.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsQsReserveProgCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class QsReserveProgCommand : DedCommand
Public Class QsReserveProgCommand
    Inherits DedCommand
public ref class QsReserveProgCommand : public DedCommand
type QsReserveProgCommand =
    class
        inherit DedCommand
    end

Il tipo QsReserveProgCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di QsReserveProgCommand

Il tipo QsReserveProgCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe QsReserveProgCommand
Namespace DedNet.Commands


Proprietà QsReserveProgCommand.NeedParameters

Proprietà QsReserveProgCommandNeedParameters

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe QsReserveProgCommand
Namespace DedNet.Commands


Metodi di QsReserveProgCommand

Il tipo QsReserveProgCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe QsReserveProgCommand
Namespace DedNet.Commands


Metodo QsReserveProgCommand.ClearCommand

Metodo QsReserveProgCommandClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe QsReserveProgCommand
Namespace DedNet.Commands


Metodo QsReserveProgCommand.Enabled

Metodo QsReserveProgCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe QsReserveProgCommand
Namespace DedNet.Commands


Metodo QsReserveProgCommand.ExecuteCommand

Metodo QsReserveProgCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe QsReserveProgCommand
Namespace DedNet.Commands


Metodo QsReserveProgCommand.SetContext

Metodo QsReserveProgCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe QsReserveProgCommand
Namespace DedNet.Commands


Classe RecognaiseCommDocument
Riconosce uno o più documenti da associare ad una commessa. Se i documenti da associare non sono presenti ne viene chiesta la selezione all'utente. Questo comando non copia e non rinomina il documento da associare, verifica i permessi dell'utente e che il percorso sia nelle root di vault o di pws (nel caso sia attiva l'area locale). Se attiva l'area locale il documento riconosciuto non viene contestualmente pubblicato nel vault ma rimane in checkout dall'utente corrente. Per ogni documento vengono registrate le dipendenze, se presenti, ed anche queste sono inserite nel Database (a meno ché non vi fossero già) ed impostate in checkout (se pws attiva) ed aggiunte come dipendenze del nuovo documento creato. L'elaborazione è racchiusa in una transazione quindi se non ha successo la creazione del documento o di una sua dipendenza oppure l'associazione alla commessa, tutte le operazioni vengono annullate. Questo anche se l'errore è avvenuto su di un solo file tra quelli elaborati.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsRecognaiseCommDocument

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class RecognaiseCommDocument : DedCommand
Public Class RecognaiseCommDocument
    Inherits DedCommand
public ref class RecognaiseCommDocument : public DedCommand
type RecognaiseCommDocument =
    class
        inherit DedCommand
    end

Il tipo RecognaiseCommDocument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Comm | Restituisce o imposta la commessa alla quale associare i documenti.
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | FileList | Restituisce la lista dei file da riconoscere come documenti e da associare alla commessa.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsDocSelection | Restituisce o imposta se si tratta di una selezione di documenti o file ( default = file ).
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non è impostata la commessa alla quale associare il documento. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere la commessa alla quale associare il file. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere la commessa alla quale associare il file. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di RecognaiseCommDocument

Il tipo RecognaiseCommDocument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Comm | Restituisce o imposta la commessa alla quale associare i documenti.
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | FileList | Restituisce la lista dei file da riconoscere come documenti e da associare alla commessa.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsDocSelection | Restituisce o imposta se si tratta di una selezione di documenti o file ( default = file ).
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non è impostata la commessa alla quale associare il documento. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe RecognaiseCommDocument
Namespace DedNet.Commands


Proprietà RecognaiseCommDocument.Comm

Proprietà RecognaiseCommDocumentComm
Restituisce o imposta la commessa alla quale associare i documenti.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedComm Comm { get; set; }
Public Property Comm As DedComm
    Get
    Set
public:
property DedComm^ Comm {
    DedComm^ get ();
    void set (DedComm^ value);
}
member Comm : DedComm with get, set

Valore della proprietà

DedComm
Vedi anche

Documentazione

Classe RecognaiseCommDocument
Namespace DedNet.Commands


Proprietà RecognaiseCommDocument.FileList

Proprietà RecognaiseCommDocumentFileList
Restituisce la lista dei file da riconoscere come documenti e da associare alla commessa.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfoList FileList { get; protected set; }
Public Property FileList As DocStructInfoList
    Get
    Protected Set
public:
property DocStructInfoList^ FileList {
    DocStructInfoList^ get ();
    protected: void set (DocStructInfoList^ value);
}
member FileList : DocStructInfoList with get, set

Valore della proprietà

DocStructInfoList
Vedi anche

Documentazione

Classe RecognaiseCommDocument
Namespace DedNet.Commands


Proprietà RecognaiseCommDocument.IsDocSelection

Proprietà RecognaiseCommDocumentIsDocSelection
Restituisce o imposta se si tratta di una selezione di documenti o file ( default = file ).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsDocSelection { get; set; }
Public Property IsDocSelection As Boolean
    Get
    Set
public:
property bool IsDocSelection {
    bool get ();
    void set (bool value);
}
member IsDocSelection : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe RecognaiseCommDocument
Namespace DedNet.Commands


Proprietà RecognaiseCommDocument.NeedParameters

Proprietà RecognaiseCommDocumentNeedParameters
Restituisce true se non è impostata la commessa alla quale associare il documento.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe RecognaiseCommDocument
Namespace DedNet.Commands


Metodi di RecognaiseCommDocument

Il tipo RecognaiseCommDocument espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere la commessa alla quale associare il file. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere la commessa alla quale associare il file. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe RecognaiseCommDocument
Namespace DedNet.Commands


Metodo RecognaiseCommDocument.ClearCommand

Metodo RecognaiseCommDocumentClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe RecognaiseCommDocument
Namespace DedNet.Commands


Metodo RecognaiseCommDocument.Enabled

Metodo RecognaiseCommDocumentEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere la commessa alla quale associare il file.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe RecognaiseCommDocument
Namespace DedNet.Commands


Metodo RecognaiseCommDocument.ExecuteCommand

Metodo RecognaiseCommDocumentExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe RecognaiseCommDocument
Namespace DedNet.Commands


Metodo RecognaiseCommDocument.SetContext

Metodo RecognaiseCommDocumentSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere la commessa alla quale associare il file.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto c'è una commessa alla quale associare il file.
Vedi anche

Documentazione

Classe RecognaiseCommDocument
Namespace DedNet.Commands


Classe RecognaiseDocument
Riconosce uno o più documenti da associare ad un'anagrafica. Il comando lavora sia sui file primari che sugli allegati ma nell'interfaccia utente è disponibile solo negli allegati. Se i documenti da associare non sono presenti ne viene chiesta la selezione all'utente. Se l'anagrafica alla quale associare il documento non è presente viene chiesta all'utente attraverso la finestra di dialogo ricerca (modale). Questo comando non copia e non rinomina il documento da associare, verifica i permessi dell'utente e che il percorso sia nelle root di vault o di pws (nel caso sia attiva l'area locale). Se attiva l'area locale il documento riconosciuto non viene contestualmente pubblicato nel vault ma rimane in checkout dall'utente corrente. Per ogni documento vengono registrate le dipendenze, se presenti, ed anche queste sono inserite nel Database (a meno ché non vi fossero già) ed impostate in checkout (se pws attiva) ed aggiunte come dipendenze del nuovo documento creato. L'elaborazione è racchiusa in una transazione quindi se non ha successo la creazione del documento o di una sua dipendenza oppure l'associazione all'anagrafica, tutte le operazioni vengono annullate. Questo anche se l'errore è avvenuto su di un solo file tra quelli elaborati.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsRecognaiseDocument

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class RecognaiseDocument : DedCommand
Public Class RecognaiseDocument
    Inherits DedCommand
public ref class RecognaiseDocument : public DedCommand
type RecognaiseDocument =
    class
        inherit DedCommand
    end

Il tipo RecognaiseDocument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Data | Restituisce o imposta l'anagrafica alla quale associare i documenti.
Proprietà pubblica | DataList | Lista di anagrafiche di associazione.
Proprietà pubblica | DelegateFileRecognize | Restituisce o imposta il delegate che viene chiamato dal comando di riconoscimento. Chi implementa il delegate dovrebbe sollevare eccezioni in caso di errore per interrompere ed annullare tutta la procedura di importazione documenti.
Proprietà pubblica | FileList | Restituisce la lista dei file da riconoscere come documenti e da associare all'anagrafica.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsDocSelection | Restituisce o imposta se si tratta di una selezione di documenti o file ( default = file ).
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non è impostata l'anagrafica alla quale associare il documento. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OverwriteContext | Se compilato indica i contesti da mantenere durante le operazioni
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | PrimaryContext | Restituisce o imposta il contesto con il quale collegare i nuovi documenti. Di default è false ed i documenti vengono collegati come allegati.
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere l'anagrafica alla quale associare il file. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere l'anagrafica alla quale associare il file. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di RecognaiseDocument

Il tipo RecognaiseDocument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Data | Restituisce o imposta l'anagrafica alla quale associare i documenti.
Proprietà pubblica | DataList | Lista di anagrafiche di associazione.
Proprietà pubblica | DelegateFileRecognize | Restituisce o imposta il delegate che viene chiamato dal comando di riconoscimento. Chi implementa il delegate dovrebbe sollevare eccezioni in caso di errore per interrompere ed annullare tutta la procedura di importazione documenti.
Proprietà pubblica | FileList | Restituisce la lista dei file da riconoscere come documenti e da associare all'anagrafica.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsDocSelection | Restituisce o imposta se si tratta di una selezione di documenti o file ( default = file ).
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non è impostata l'anagrafica alla quale associare il documento. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OverwriteContext | Se compilato indica i contesti da mantenere durante le operazioni
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | PrimaryContext | Restituisce o imposta il contesto con il quale collegare i nuovi documenti. Di default è false ed i documenti vengono collegati come allegati.
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe RecognaiseDocument
Namespace DedNet.Commands


Proprietà RecognaiseDocument.Data

Proprietà RecognaiseDocumentData
Restituisce o imposta l'anagrafica alla quale associare i documenti.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; set; }
Public Property Data As DedData
    Get
    Set
public:
property DedData^ Data {
    DedData^ get ();
    void set (DedData^ value);
}
member Data : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe RecognaiseDocument
Namespace DedNet.Commands


Proprietà RecognaiseDocument.DataList

Proprietà RecognaiseDocumentDataList
Lista di anagrafiche di associazione.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataList DataList { get; set; }
Public Property DataList As DedDataList
    Get
    Set
public:
property DedDataList^ DataList {
    DedDataList^ get ();
    void set (DedDataList^ value);
}
member DataList : DedDataList with get, set

Valore della proprietà

DedDataList
Vedi anche

Documentazione

Classe RecognaiseDocument
Namespace DedNet.Commands


Proprietà RecognaiseDocument.DelegateFileRecognize

Proprietà RecognaiseDocumentDelegateFileRecognize
Restituisce o imposta il delegate che viene chiamato dal comando di riconoscimento. Chi implementa il delegate dovrebbe sollevare eccezioni in caso di errore per interrompere ed annullare tutta la procedura di importazione documenti.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public FileOperationDelegate<DocStructInfoList> DelegateFileRecognize { get; set; }
Public Property DelegateFileRecognize As FileOperationDelegate(Of DocStructInfoList)
    Get
    Set
public:
property FileOperationDelegate<DocStructInfoList^>^ DelegateFileRecognize {
    FileOperationDelegate<DocStructInfoList^>^ get ();
    void set (FileOperationDelegate<DocStructInfoList^>^ value);
}
member DelegateFileRecognize : FileOperationDelegate<DocStructInfoList> with get, set

Valore della proprietà

FileOperationDelegate DocStructInfoList
Vedi anche

Documentazione

Classe RecognaiseDocument
Namespace DedNet.Commands


Proprietà RecognaiseDocument.FileList

Proprietà RecognaiseDocumentFileList
Restituisce la lista dei file da riconoscere come documenti e da associare all'anagrafica.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfoList FileList { get; protected set; }
Public Property FileList As DocStructInfoList
    Get
    Protected Set
public:
property DocStructInfoList^ FileList {
    DocStructInfoList^ get ();
    protected: void set (DocStructInfoList^ value);
}
member FileList : DocStructInfoList with get, set

Valore della proprietà

DocStructInfoList
Vedi anche

Documentazione

Classe RecognaiseDocument
Namespace DedNet.Commands


Proprietà RecognaiseDocument.IsDocSelection

Proprietà RecognaiseDocumentIsDocSelection
Restituisce o imposta se si tratta di una selezione di documenti o file ( default = file ).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsDocSelection { get; set; }
Public Property IsDocSelection As Boolean
    Get
    Set
public:
property bool IsDocSelection {
    bool get ();
    void set (bool value);
}
member IsDocSelection : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe RecognaiseDocument
Namespace DedNet.Commands


Proprietà RecognaiseDocument.NeedParameters

Proprietà RecognaiseDocumentNeedParameters
Restituisce true se non è impostata l'anagrafica alla quale associare il documento.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe RecognaiseDocument
Namespace DedNet.Commands


Proprietà RecognaiseDocument.OverwriteContext

Proprietà RecognaiseDocumentOverwriteContext
Se compilato indica i contesti da mantenere durante le operazioni

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<string, DedDocContext> OverwriteContext { get; set; }
Public Property OverwriteContext As Dictionary(Of String, DedDocContext)
    Get
    Set
public:
property Dictionary<String^, DedDocContext^>^ OverwriteContext {
    Dictionary<String^, DedDocContext^>^ get ();
    void set (Dictionary<String^, DedDocContext^>^ value);
}
member OverwriteContext : Dictionary<string, DedDocContext> with get, set

Valore della proprietà

Dictionary String, DedDocContext
Vedi anche

Documentazione

Classe RecognaiseDocument
Namespace DedNet.Commands


Proprietà RecognaiseDocument.PrimaryContext

Proprietà RecognaiseDocumentPrimaryContext
Restituisce o imposta il contesto con il quale collegare i nuovi documenti. Di default è false ed i documenti vengono collegati come allegati.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool PrimaryContext { get; set; }
Public Property PrimaryContext As Boolean
    Get
    Set
public:
property bool PrimaryContext {
    bool get ();
    void set (bool value);
}
member PrimaryContext : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe RecognaiseDocument
Namespace DedNet.Commands


Metodi di RecognaiseDocument

Il tipo RecognaiseDocument espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere l'anagrafica alla quale associare il file. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere l'anagrafica alla quale associare il file. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe RecognaiseDocument
Namespace DedNet.Commands


Metodo RecognaiseDocument.ClearCommand

Metodo RecognaiseDocumentClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe RecognaiseDocument
Namespace DedNet.Commands


Metodo RecognaiseDocument.Enabled

Metodo RecognaiseDocumentEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere l'anagrafica alla quale associare il file.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe RecognaiseDocument
Namespace DedNet.Commands


Metodo RecognaiseDocument.ExecuteCommand

Metodo RecognaiseDocumentExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe RecognaiseDocument
Namespace DedNet.Commands


Metodo RecognaiseDocument.SetContext

Metodo RecognaiseDocumentSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere l'anagrafica alla quale associare il file.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto c'è una sola anagrafica alla quale associare il file.
Vedi anche

Documentazione

Classe RecognaiseDocument
Namespace DedNet.Commands


Classe RemoveDocument
Elimina una lista di documenti. Se il documento è collegato a qualche anagrafica viene scollegato prima da tutte (dopo richiesta di conferma dell'utente). Se il documento è legato come dipendenza diretta e vitale a qualche altro documento (non in elaborazione dal comando) allora viene richiesta conferma all'utente.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsRemoveDocument

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class RemoveDocument : DedCommand
Public Class RemoveDocument
    Inherits DedCommand
public ref class RemoveDocument : public DedCommand
type RemoveDocument =
    class
        inherit DedCommand
    end

Il tipo RemoveDocument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Comm | Commessa associata ai documenti
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | ECO | ECO dal quale eliminare i documenti.
Proprietà pubblica | FileList | Restituisce la lista dei documenti da eliminare.
Proprietà pubblica | GeneralAsk | Richiesta generale se procedere con l'eliminazione dei documenti. Questa proprietà ha effetto solo se la proprietà UseUI è impostata a True.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreVitalParentship | Inidica se ignorare o meno di controllare i legami documentali.
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | IsInLoop | Indica se il comando è eseguito in un ciclo o meno. Di default è False. Questa variabile ha effetto solamente se la proprietà UseUI è impostata a True.
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non è impostato qualche documento da eliminare. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SkipDeletionTracking | Indica di saltare il tracciamento dell'eliminazione (DED_DOC_ERASED).
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di RemoveDocument

Il tipo RemoveDocument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Comm | Commessa associata ai documenti
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | ECO | ECO dal quale eliminare i documenti.
Proprietà pubblica | FileList | Restituisce la lista dei documenti da eliminare.
Proprietà pubblica | GeneralAsk | Richiesta generale se procedere con l'eliminazione dei documenti. Questa proprietà ha effetto solo se la proprietà UseUI è impostata a True.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreVitalParentship | Inidica se ignorare o meno di controllare i legami documentali.
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | IsInLoop | Indica se il comando è eseguito in un ciclo o meno. Di default è False. Questa variabile ha effetto solamente se la proprietà UseUI è impostata a True.
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non è impostato qualche documento da eliminare. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SkipDeletionTracking | Indica di saltare il tracciamento dell'eliminazione (DED_DOC_ERASED).
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe RemoveDocument
Namespace DedNet.Commands


Proprietà RemoveDocument.Comm

Proprietà RemoveDocumentComm
Commessa associata ai documenti

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedComm Comm { get; set; }
Public Property Comm As DedComm
    Get
    Set
public:
property DedComm^ Comm {
    DedComm^ get ();
    void set (DedComm^ value);
}
member Comm : DedComm with get, set

Valore della proprietà

DedComm
Vedi anche

Documentazione

Classe RemoveDocument
Namespace DedNet.Commands


Proprietà RemoveDocument.ECO

Proprietà RemoveDocumentECO
ECO dal quale eliminare i documenti.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEco ECO { get; set; }
Public Property ECO As DedEco
    Get
    Set
public:
property DedEco^ ECO {
    DedEco^ get ();
    void set (DedEco^ value);
}
member ECO : DedEco with get, set

Valore della proprietà

DedEco
Vedi anche

Documentazione

Classe RemoveDocument
Namespace DedNet.Commands


Proprietà RemoveDocument.FileList

Proprietà RemoveDocumentFileList
Restituisce la lista dei documenti da eliminare.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfoList FileList { get; }
Public ReadOnly Property FileList As DocStructInfoList
    Get
public:
property DocStructInfoList^ FileList {
    DocStructInfoList^ get ();
}
member FileList : DocStructInfoList with get

Valore della proprietà

DocStructInfoList
Vedi anche

Documentazione

Classe RemoveDocument
Namespace DedNet.Commands


Proprietà RemoveDocument.GeneralAsk

Proprietà RemoveDocumentGeneralAsk
Richiesta generale se procedere con l'eliminazione dei documenti. Questa proprietà ha effetto solo se la proprietà UseUI è impostata a True.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QuestionResult GeneralAsk { get; set; }
Public Property GeneralAsk As QuestionResult
    Get
    Set
public:
property QuestionResult GeneralAsk {
    QuestionResult get ();
    void set (QuestionResult value);
}
member GeneralAsk : QuestionResult with get, set

Valore della proprietà

QuestionResult
Vedi anche

Documentazione

Classe RemoveDocument
Namespace DedNet.Commands


Proprietà RemoveDocument.IgnoreVitalParentship

Proprietà RemoveDocumentIgnoreVitalParentship
Inidica se ignorare o meno di controllare i legami documentali.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IgnoreVitalParentship { get; set; }
Public Property IgnoreVitalParentship As Boolean
    Get
    Set
public:
property bool IgnoreVitalParentship {
    bool get ();
    void set (bool value);
}
member IgnoreVitalParentship : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe RemoveDocument
Namespace DedNet.Commands


Proprietà RemoveDocument.IsInLoop

Proprietà RemoveDocumentIsInLoop
Indica se il comando è eseguito in un ciclo o meno. Di default è False. Questa variabile ha effetto solamente se la proprietà UseUI è impostata a True.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsInLoop { get; set; }
Public Property IsInLoop As Boolean
    Get
    Set
public:
property bool IsInLoop {
    bool get ();
    void set (bool value);
}
member IsInLoop : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe RemoveDocument
Namespace DedNet.Commands


Proprietà RemoveDocument.NeedParameters

Proprietà RemoveDocumentNeedParameters
Restituisce true se non è impostato qualche documento da eliminare.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe RemoveDocument
Namespace DedNet.Commands


Proprietà RemoveDocument.SkipDeletionTracking

Proprietà RemoveDocumentSkipDeletionTracking
Indica di saltare il tracciamento dell'eliminazione (DED_DOC_ERASED).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool SkipDeletionTracking { get; set; }
Public Property SkipDeletionTracking As Boolean
    Get
    Set
public:
property bool SkipDeletionTracking {
    bool get ();
    void set (bool value);
}
member SkipDeletionTracking : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe RemoveDocument
Namespace DedNet.Commands


Metodi di RemoveDocument

Il tipo RemoveDocument espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe RemoveDocument
Namespace DedNet.Commands


Metodo RemoveDocument.ClearCommand

Metodo RemoveDocumentClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe RemoveDocument
Namespace DedNet.Commands


Metodo RemoveDocument.Enabled

Metodo RemoveDocumentEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe RemoveDocument
Namespace DedNet.Commands


Metodo RemoveDocument.ExecuteCommand

Metodo RemoveDocumentExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe RemoveDocument
Namespace DedNet.Commands


Metodo RemoveDocument.SetContext

Metodo RemoveDocumentSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe RemoveDocument
Namespace DedNet.Commands


Classe RemoveEcoDocument
Rimuove uno o più documenti da un ECO.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsRemoveEcoDocument

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class RemoveEcoDocument : DedCommand
Public Class RemoveEcoDocument
    Inherits DedCommand
public ref class RemoveEcoDocument : public DedCommand
type RemoveEcoDocument =
    class
        inherit DedCommand
    end

Il tipo RemoveEcoDocument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non è impostato l'Eco nel quale importare il documento. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere l'Eco al quale associare il file. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere l'Eco al quale associare il file. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di RemoveEcoDocument

Il tipo RemoveEcoDocument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non è impostato l'Eco nel quale importare il documento. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe RemoveEcoDocument
Namespace DedNet.Commands


Proprietà RemoveEcoDocument.NeedParameters

Proprietà RemoveEcoDocumentNeedParameters
Restituisce true se non è impostato l'Eco nel quale importare il documento.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe RemoveEcoDocument
Namespace DedNet.Commands


Metodi di RemoveEcoDocument

Il tipo RemoveEcoDocument espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere l'Eco al quale associare il file. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere l'Eco al quale associare il file. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe RemoveEcoDocument
Namespace DedNet.Commands


Metodo RemoveEcoDocument.ClearCommand

Metodo RemoveEcoDocumentClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe RemoveEcoDocument
Namespace DedNet.Commands


Metodo RemoveEcoDocument.Enabled

Metodo RemoveEcoDocumentEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere l'Eco al quale associare il file.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe RemoveEcoDocument
Namespace DedNet.Commands


Metodo RemoveEcoDocument.ExecuteCommand

Metodo RemoveEcoDocumentExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe RemoveEcoDocument
Namespace DedNet.Commands


Metodo RemoveEcoDocument.SetContext

Metodo RemoveEcoDocumentSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere l'Eco al quale associare il file.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto c'è l'Eco al quale associare il file.
Vedi anche

Documentazione

Classe RemoveEcoDocument
Namespace DedNet.Commands


Classe RemoveRecurrentTimingCommand
Comando utilizzato per rimuovere anagrafiche, commesse, ECO dall'elenco delle temporizzazioni ricorrenti.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsAddRemoveRecurrentTiming
DedNet.CommandsRemoveRecurrentTimingCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class RemoveRecurrentTimingCommand : AddRemoveRecurrentTiming
Public Class RemoveRecurrentTimingCommand
    Inherits AddRemoveRecurrentTiming
public ref class RemoveRecurrentTimingCommand : public AddRemoveRecurrentTiming
type RemoveRecurrentTimingCommand =
    class
        inherit AddRemoveRecurrentTiming
    end

Il tipo RemoveRecurrentTimingCommand espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | RemoveRecurrentTimingCommand | Crea una nuova istanza della classe 'RemoveRecurrentTimingCommand' utilizzata per rimuovere anagrafiche, commesse, ECO dall'elenco delle temporizzazioni ricorrenti.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Inidica se il comando necessita di parametri. (Ereditato da AddRemoveRecurrentTiming)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulizia del comando. (Ereditato da AddRemoveRecurrentTiming)
Metodo pubblico | Enabled | Abilitazione dal contesto. (Ereditato da AddRemoveRecurrentTiming)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esecuzione del comando. (Ereditato da AddRemoveRecurrentTiming)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Settaggio del contesto. (Ereditato da AddRemoveRecurrentTiming)
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Costruttore RemoveRecurrentTimingCommand
Crea una nuova istanza della classe 'RemoveRecurrentTimingCommand' utilizzata per rimuovere anagrafiche, commesse, ECO dall'elenco delle temporizzazioni ricorrenti.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public RemoveRecurrentTimingCommand(
    DedNetApplication app,
    string internalName,
    string name
)
Public Sub New (
    app As DedNetApplication,
    internalName As String,
    name As String
)
public:
RemoveRecurrentTimingCommand(
    DedNetApplication^ app,
    String^ internalName,
    String^ name
)
new :
        app : DedNetApplication *
        internalName : string *
        name : string -> RemoveRecurrentTimingCommand

Parametri

app DedNetApplication
Applicazione DedNet.
internalName String
Nome interno del comando.
name String
Nome visualizzato del comando.
Vedi anche

Documentazione

Classe RemoveRecurrentTimingCommand
Namespace DedNet.Commands


Proprietà di RemoveRecurrentTimingCommand

Il tipo RemoveRecurrentTimingCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Inidica se il comando necessita di parametri. (Ereditato da AddRemoveRecurrentTiming)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe RemoveRecurrentTimingCommand
Namespace DedNet.Commands


Metodi di RemoveRecurrentTimingCommand

Il tipo RemoveRecurrentTimingCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulizia del comando. (Ereditato da AddRemoveRecurrentTiming)
Metodo pubblico | Enabled | Abilitazione dal contesto. (Ereditato da AddRemoveRecurrentTiming)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esecuzione del comando. (Ereditato da AddRemoveRecurrentTiming)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Settaggio del contesto. (Ereditato da AddRemoveRecurrentTiming)
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe RemoveRecurrentTimingCommand
Namespace DedNet.Commands


Classe RenameDocument
Rinomina un documento
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsRenameDocument

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class RenameDocument : DedCommand
Public Class RenameDocument
    Inherits DedCommand
public ref class RenameDocument : public DedCommand
type RenameDocument =
    class
        inherit DedCommand
    end

Il tipo RenameDocument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Doc |
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non è impostato alcun file dal quale creare il documento. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NewPath |
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OldPath |
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. Restituisce sempre false perché questo è utilizzato come sotto-comando. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Restituisce sempre false perché questo è utilizzato come sotto-comando. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di RenameDocument

Il tipo RenameDocument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Doc |
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non è impostato alcun file dal quale creare il documento. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NewPath |
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OldPath |
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe RenameDocument
Namespace DedNet.Commands


Proprietà RenameDocument.Doc

Proprietà RenameDocumentDoc

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDoc Doc { get; set; }
Public Property Doc As DedDoc
    Get
    Set
public:
property DedDoc^ Doc {
    DedDoc^ get ();
    void set (DedDoc^ value);
}
member Doc : DedDoc with get, set

Valore della proprietà

DedDoc
Vedi anche

Documentazione

Classe RenameDocument
Namespace DedNet.Commands


Proprietà RenameDocument.NeedParameters

Proprietà RenameDocumentNeedParameters
Restituisce true se non è impostato alcun file dal quale creare il documento.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe RenameDocument
Namespace DedNet.Commands


Proprietà RenameDocument.NewPath

Proprietà RenameDocumentNewPath

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string NewPath { get; set; }
Public Property NewPath As String
    Get
    Set
public:
property String^ NewPath {
    String^ get ();
    void set (String^ value);
}
member NewPath : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe RenameDocument
Namespace DedNet.Commands


Proprietà RenameDocument.OldPath

Proprietà RenameDocumentOldPath

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string OldPath { get; set; }
Public Property OldPath As String
    Get
    Set
public:
property String^ OldPath {
    String^ get ();
    void set (String^ value);
}
member OldPath : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe RenameDocument
Namespace DedNet.Commands


Metodi di RenameDocument

Il tipo RenameDocument espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. Restituisce sempre false perché questo è utilizzato come sotto-comando. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Restituisce sempre false perché questo è utilizzato come sotto-comando. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe RenameDocument
Namespace DedNet.Commands


Metodo RenameDocument.ClearCommand

Metodo RenameDocumentClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe RenameDocument
Namespace DedNet.Commands


Metodo RenameDocument.Enabled

Metodo RenameDocumentEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale. Restituisce sempre false perché questo è utilizzato come sotto-comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce sempre false.
Vedi anche

Documentazione

Classe RenameDocument
Namespace DedNet.Commands


Metodo RenameDocument.ExecuteCommand

Metodo RenameDocumentExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe RenameDocument
Namespace DedNet.Commands


Metodo RenameDocument.SetContext

Metodo RenameDocumentSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Restituisce sempre false perché questo è utilizzato come sotto-comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe RenameDocument
Namespace DedNet.Commands


Classe RenameFolder
Elimina una cartella.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsRenameFolder

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class RenameFolder : DedCommand
Public Class RenameFolder
    Inherits DedCommand
public ref class RenameFolder : public DedCommand
type RenameFolder =
    class
        inherit DedCommand
    end

Il tipo RenameFolder espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non è impostato alcun file dal quale creare il documento. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NewPath |
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OldPath |
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. Restituisce sempre false perché questo è utilizzato come sotto-comando. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Restituisce sempre false perché questo è utilizzato come sotto-comando. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di RenameFolder

Il tipo RenameFolder espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non è impostato alcun file dal quale creare il documento. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NewPath |
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OldPath |
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe RenameFolder
Namespace DedNet.Commands


Proprietà RenameFolder.NeedParameters

Proprietà RenameFolderNeedParameters
Restituisce true se non è impostato alcun file dal quale creare il documento.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe RenameFolder
Namespace DedNet.Commands


Proprietà RenameFolder.NewPath

Proprietà RenameFolderNewPath

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string NewPath { get; set; }
Public Property NewPath As String
    Get
    Set
public:
property String^ NewPath {
    String^ get ();
    void set (String^ value);
}
member NewPath : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe RenameFolder
Namespace DedNet.Commands


Proprietà RenameFolder.OldPath

Proprietà RenameFolderOldPath

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string OldPath { get; set; }
Public Property OldPath As String
    Get
    Set
public:
property String^ OldPath {
    String^ get ();
    void set (String^ value);
}
member OldPath : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe RenameFolder
Namespace DedNet.Commands


Metodi di RenameFolder

Il tipo RenameFolder espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. Restituisce sempre false perché questo è utilizzato come sotto-comando. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Restituisce sempre false perché questo è utilizzato come sotto-comando. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe RenameFolder
Namespace DedNet.Commands


Metodo RenameFolder.ClearCommand

Metodo RenameFolderClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe RenameFolder
Namespace DedNet.Commands


Metodo RenameFolder.Enabled

Metodo RenameFolderEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale. Restituisce sempre false perché questo è utilizzato come sotto-comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce sempre false.
Vedi anche

Documentazione

Classe RenameFolder
Namespace DedNet.Commands


Metodo RenameFolder.ExecuteCommand

Metodo RenameFolderExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe RenameFolder
Namespace DedNet.Commands


Metodo RenameFolder.SetContext

Metodo RenameFolderSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Restituisce sempre false perché questo è utilizzato come sotto-comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce sempre false.
Vedi anche

Documentazione

Classe RenameFolder
Namespace DedNet.Commands


Classe ReplaceAnagrBom
Classe che rappresenta il comando per visualizzare la storia di un'anagrafica.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsDedDataCommand
DedNet.CommandsReplaceAnagrBom

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ReplaceAnagrBom : DedDataCommand
Public Class ReplaceAnagrBom
    Inherits DedDataCommand
public ref class ReplaceAnagrBom : public DedDataCommand
type ReplaceAnagrBom =
    class
        inherit DedDataCommand
    end

Il tipo ReplaceAnagrBom espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DataDx |
Proprietà pubblica | DataInfos | Restituisce la lista delle anagrafiche di elaborazione comando. (Ereditato da DedDataCommand)
Proprietà pubblica | DataSx |
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedDataCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Esegue la pulizia del comando. Azzera tutte le variabili. (Ereditato da DedDataCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedDataCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedDataCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedDataCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Sovrascrive DedDataCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di ReplaceAnagrBom

Il tipo ReplaceAnagrBom espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DataDx |
Proprietà pubblica | DataInfos | Restituisce la lista delle anagrafiche di elaborazione comando. (Ereditato da DedDataCommand)
Proprietà pubblica | DataSx |
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedDataCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ReplaceAnagrBom
Namespace DedNet.Commands


Proprietà ReplaceAnagrBom.DataDx

Proprietà ReplaceAnagrBomDataDx

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData DataDx { get; set; }
Public Property DataDx As DedData
    Get
    Set
public:
property DedData^ DataDx {
    DedData^ get ();
    void set (DedData^ value);
}
member DataDx : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe ReplaceAnagrBom
Namespace DedNet.Commands


Proprietà ReplaceAnagrBom.DataSx

Proprietà ReplaceAnagrBomDataSx

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData DataSx { get; set; }
Public Property DataSx As DedData
    Get
    Set
public:
property DedData^ DataSx {
    DedData^ get ();
    void set (DedData^ value);
}
member DataSx : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe ReplaceAnagrBom
Namespace DedNet.Commands


Proprietà ReplaceAnagrBom.NeedParameters

Proprietà ReplaceAnagrBomNeedParameters

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ReplaceAnagrBom
Namespace DedNet.Commands


Metodi di ReplaceAnagrBom

Il tipo ReplaceAnagrBom espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Esegue la pulizia del comando. Azzera tutte le variabili. (Ereditato da DedDataCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedDataCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedDataCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedDataCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | (Sovrascrive DedDataCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ReplaceAnagrBom
Namespace DedNet.Commands


Metodo ReplaceAnagrBom.Enabled

Metodo ReplaceAnagrBomEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe ReplaceAnagrBom
Namespace DedNet.Commands


Metodo ReplaceAnagrBom.ExecuteCommand

Metodo ReplaceAnagrBomExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe ReplaceAnagrBom
Namespace DedNet.Commands


Metodo ReplaceAnagrBom.SetContext

Metodo ReplaceAnagrBomSetContext

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe ReplaceAnagrBom
Namespace DedNet.Commands


Classe ReplaceDocument
Sostituisce il file di un documento già esistente con un nuovo file. Per attuare l'operazione, con attiva l'area locale, si deve avere in check-out il documento. Se il file con il quale sostituire il documento non è presente ne viene chiesta la selezione all'utente. Vengono aggiornate le dipendenze del documento in base alle dipendenze presenti nella struttura documento. L'elaborazione è racchiusa in una transazione quindi se non ha successo un qualsiasi operazione tutto viene annullato.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsReplaceDocument

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ReplaceDocument : DedCommand
Public Class ReplaceDocument
    Inherits DedCommand
public ref class ReplaceDocument : public DedCommand
type ReplaceDocument =
    class
        inherit DedCommand
    end

Il tipo ReplaceDocument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DelegateFileCopy | Restituisce o imposta il delegate che viene chiamato dal comando per la copia effettiva dei file. Se viene lasciato vuoto la copia viene effettuatata dal comando. Chi implementa il delegate dovrebbe sollevare eccezioni in caso di errore per interrompere ed annullare tutta la procedura.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsDocSelection | Restituisce o imposta se si tratta di una selezione di documenti o file ( default = file ).
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non è impostato il documento da sostituire. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | ReferenceDocInfo | Imposta/Restituisce le informazioni del documento che si desidera sostituire.
Proprietà pubblica | ReplaceDocInfo | Imposta/Restituisce le informazioni del documento che si desidera usare per la sostituzione.
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere il documento da sostituire. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere il documento da sostituire. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di ReplaceDocument

Il tipo ReplaceDocument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DelegateFileCopy | Restituisce o imposta il delegate che viene chiamato dal comando per la copia effettiva dei file. Se viene lasciato vuoto la copia viene effettuatata dal comando. Chi implementa il delegate dovrebbe sollevare eccezioni in caso di errore per interrompere ed annullare tutta la procedura.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsDocSelection | Restituisce o imposta se si tratta di una selezione di documenti o file ( default = file ).
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non è impostato il documento da sostituire. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | ReferenceDocInfo | Imposta/Restituisce le informazioni del documento che si desidera sostituire.
Proprietà pubblica | ReplaceDocInfo | Imposta/Restituisce le informazioni del documento che si desidera usare per la sostituzione.
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ReplaceDocument
Namespace DedNet.Commands


Proprietà ReplaceDocument.DelegateFileCopy

Proprietà ReplaceDocumentDelegateFileCopy
Restituisce o imposta il delegate che viene chiamato dal comando per la copia effettiva dei file. Se viene lasciato vuoto la copia viene effettuatata dal comando. Chi implementa il delegate dovrebbe sollevare eccezioni in caso di errore per interrompere ed annullare tutta la procedura.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public FileOperationDelegate<DocStructInfo> DelegateFileCopy { get; set; }
Public Property DelegateFileCopy As FileOperationDelegate(Of DocStructInfo)
    Get
    Set
public:
property FileOperationDelegate<DocStructInfo^>^ DelegateFileCopy {
    FileOperationDelegate<DocStructInfo^>^ get ();
    void set (FileOperationDelegate<DocStructInfo^>^ value);
}
member DelegateFileCopy : FileOperationDelegate<DocStructInfo> with get, set

Valore della proprietà

FileOperationDelegate DocStructInfo
Vedi anche

Documentazione

Classe ReplaceDocument
Namespace DedNet.Commands


Proprietà ReplaceDocument.IsDocSelection

Proprietà ReplaceDocumentIsDocSelection
Restituisce o imposta se si tratta di una selezione di documenti o file ( default = file ).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsDocSelection { get; set; }
Public Property IsDocSelection As Boolean
    Get
    Set
public:
property bool IsDocSelection {
    bool get ();
    void set (bool value);
}
member IsDocSelection : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ReplaceDocument
Namespace DedNet.Commands


Proprietà ReplaceDocument.NeedParameters

Proprietà ReplaceDocumentNeedParameters
Restituisce true se non è impostato il documento da sostituire.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ReplaceDocument
Namespace DedNet.Commands


Proprietà ReplaceDocument.ReferenceDocInfo

Proprietà ReplaceDocumentReferenceDocInfo
Imposta/Restituisce le informazioni del documento che si desidera sostituire.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfo ReferenceDocInfo { get; set; }
Public Property ReferenceDocInfo As DocStructInfo
    Get
    Set
public:
property DocStructInfo^ ReferenceDocInfo {
    DocStructInfo^ get ();
    void set (DocStructInfo^ value);
}
member ReferenceDocInfo : DocStructInfo with get, set

Valore della proprietà

DocStructInfo
Vedi anche

Documentazione

Classe ReplaceDocument
Namespace DedNet.Commands


Proprietà ReplaceDocument.ReplaceDocInfo

Proprietà ReplaceDocumentReplaceDocInfo
Imposta/Restituisce le informazioni del documento che si desidera usare per la sostituzione.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfo ReplaceDocInfo { get; set; }
Public Property ReplaceDocInfo As DocStructInfo
    Get
    Set
public:
property DocStructInfo^ ReplaceDocInfo {
    DocStructInfo^ get ();
    void set (DocStructInfo^ value);
}
member ReplaceDocInfo : DocStructInfo with get, set

Valore della proprietà

DocStructInfo
Vedi anche

Documentazione

Classe ReplaceDocument
Namespace DedNet.Commands


Metodi di ReplaceDocument

Il tipo ReplaceDocument espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere il documento da sostituire. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere il documento da sostituire. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ReplaceDocument
Namespace DedNet.Commands


Metodo ReplaceDocument.ClearCommand

Metodo ReplaceDocumentClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe ReplaceDocument
Namespace DedNet.Commands


Metodo ReplaceDocument.Enabled

Metodo ReplaceDocumentEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere il documento da sostituire.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe ReplaceDocument
Namespace DedNet.Commands


Metodo ReplaceDocument.ExecuteCommand

Metodo ReplaceDocumentExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe ReplaceDocument
Namespace DedNet.Commands


Metodo ReplaceDocument.SetContext

Metodo ReplaceDocumentSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere il documento da sostituire.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto c'è una sola anagrafica alla quale associare il file.
Vedi anche

Documentazione

Classe ReplaceDocument
Namespace DedNet.Commands


Classe ReplaceDocumentReference
Comando esposto ai CAD che chiama il comando di aggiorna riferimenti. Inzializza il comando e lo lancia senza un documento di sostituzione, in modo che debba essere l'utente a selezionarlo manualmente.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsReplaceDocumentReference

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ReplaceDocumentReference : DedCommand
Public Class ReplaceDocumentReference
    Inherits DedCommand
public ref class ReplaceDocumentReference : public DedCommand
type ReplaceDocumentReference =
    class
        inherit DedCommand
    end

Il tipo ReplaceDocumentReference espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DocList |
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Ritorna True se la lista di riferimenti è vuota. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Reinizializza il comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Comando sempre abilitato. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Il contesto non è da settare. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di ReplaceDocumentReference

Il tipo ReplaceDocumentReference espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DocList |
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Ritorna True se la lista di riferimenti è vuota. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ReplaceDocumentReference
Namespace DedNet.Commands


Proprietà ReplaceDocumentReference.DocList

Proprietà ReplaceDocumentReferenceDocList

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocList DocList { get; set; }
Public Property DocList As DedDocList
    Get
    Set
public:
property DedDocList^ DocList {
    DedDocList^ get ();
    void set (DedDocList^ value);
}
member DocList : DedDocList with get, set

Valore della proprietà

DedDocList
Vedi anche

Documentazione

Classe ReplaceDocumentReference
Namespace DedNet.Commands


Proprietà ReplaceDocumentReference.NeedParameters

Proprietà ReplaceDocumentReferenceNeedParameters
Ritorna True se la lista di riferimenti è vuota.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ReplaceDocumentReference
Namespace DedNet.Commands


Metodi di ReplaceDocumentReference

Il tipo ReplaceDocumentReference espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Reinizializza il comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Comando sempre abilitato. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Il contesto non è da settare. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ReplaceDocumentReference
Namespace DedNet.Commands


Metodo ReplaceDocumentReference.ClearCommand

Metodo ReplaceDocumentReferenceClearCommand
Reinizializza il comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe ReplaceDocumentReference
Namespace DedNet.Commands


Metodo ReplaceDocumentReference.Enabled

Metodo ReplaceDocumentReferenceEnabled
Comando sempre abilitato.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext commandContext
)
Public Overrides Function Enabled (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ commandContext
) override
abstract Enabled :
        commandContext : DedCommandContext -> bool
override Enabled :
        commandContext : DedCommandContext -> bool

Parametri

commandContext DedCommandContext
Contesto.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe ReplaceDocumentReference
Namespace DedNet.Commands


Metodo ReplaceDocumentReference.ExecuteCommand

Metodo ReplaceDocumentReferenceExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe ReplaceDocumentReference
Namespace DedNet.Commands


Metodo ReplaceDocumentReference.SetContext

Metodo ReplaceDocumentReferenceSetContext
Il contesto non è da settare.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext commandContext
)
Public Overrides Function SetContext (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ commandContext
) override
abstract SetContext :
        commandContext : DedCommandContext -> bool
override SetContext :
        commandContext : DedCommandContext -> bool

Parametri

commandContext DedCommandContext
Contesto.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe ReplaceDocumentReference
Namespace DedNet.Commands


Classe RevCommand
Crea una nuova revisione partendo da un'anagrafica già esistente. È possibile partire con la revisione da un'anagrafica che non sia l'ultima. Fa scegliere all'utente come comportarsi con gli allegati: se collegarli o clonarli dalla revisione di partenza o dall'ultima, se diversa da quella di partenza. Impostare la proprietà Info.Data con l'anagrafica di partenza (letta dal Database e clonata tramite il metodo MakeClonePart()) oppure, se si desidera creare la revisione partendo da un'anagrafica già modificata, (come nel caso di un documento CAD) impostare i vari campi della proprietà Info secondo le esigenze. Impostare in Info.Data gli attributi precompilati desiderati. Ogni proprietà impostata dell'oggetto Info, come il progressivo, la revisione o il tassello utente, ha la priorità su quanto presente nell'anagrafica Info.Data. Questo comando non ricalcola il DedId ma lo tiene buono così com'é. Tutto il resto come il nome file, il DED_DIS ecc. sono ricalcolati come nel comando di creazione anagrafica. I file primari sono trattati in modo differente in base al fatto che si tratti o meno di anagrafica con tassello revisione nel nome file. La scelata viene comunque fatta dall'utente, anche se c'é un default: - Se il file ha la revisione, nessun file priamario viene portato dietro, la nuova anagrafica risulta senza documenti primari. - Se il file NON ha la revisione: 1) Caso di file presente nella revisione di partenza ma non nell'ultima revisione: - Il documento viene importato nella nuova revisione. 2) Caso di file presente nell'ultima revisione ma non nella revisione di partenza. - Il documento rimane nell'ultima revisione. 3) Caso di file presente in entrambe: - Di default viene tenuto il documento proveniente dalla revisione di partenza. Utilizzare la proprietà UseUI per visualizzare o meno all'utente la finestra di salvataggio per la convalida dei dati e la finestra di selezione file di revisione. Aggiungere nella lista ClientInterstingDocs i documenti dei quali si vuole occupare il client.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsRevCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class RevCommand : DedCommand
Public Class RevCommand
    Inherits DedCommand
public ref class RevCommand : public DedCommand
type RevCommand =
    class
        inherit DedCommand
    end

Il tipo RevCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | ApplyRule | Permette di decidere se applicare o meno le regole di autocomposizione (di default è true).
Proprietà pubblica | BomCloneMode | Tipo di clonazione dei dati di distinta
Proprietà pubblica | CheckReservedProgr | Indica se controllare o meno se si sta salvando in un progressivo riservato.
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | ClientInterstingDocs | Restituisce la lista dei documenti di interesse del client. Questi documenti sono portati nella nuova revisione senza che l'utente possa scegliere (sono i documenti del client dai quali l'utente ha lanciato il comando di salva revisione).
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DelegateFileCopy | Restituisce o imposta il delegate che, dopo la creazione della revisione, viene chiamato dal comando per la copia effettiva dei file. Se viene lasciato vuoto la copia viene effettuatata dal comando. Chi implementa il delegate dovrebbe sollevare eccezioni in caso di errore per interrompere ed annullare tutta la procedura.
Proprietà pubblica | DelegateFileMove | Restituisce o imposta il delegate che, dopo la creazione della revisione in caso NGR si occupa di gestire le operazioni da effettuare come ausilio al backup della revisione.
Proprietà pubblica | ForcedData | Indica se i dati sono stati forzati e quindi non vanno ricalcolati ( ID , CODICE, DISEGNO, FILE )
Proprietà pubblica | Frm | Form di salvataggio.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | HideDocSelectionForm | Determina se nascondere il form di selezione dei documenti da portare nella nuova revisione
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Info | Restituisce le informazioni di codifica correntemente utilizzate dal comando. Queste informazioni non sono utilizzate per la modifica del DEDID ma solo per il calcolo di tutti gli altri campi e del nome file.
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | IsRevNewType | Restituisce se la famiglia di appartenenza delle anagrafiche abbia o meno nella codifica del file il tassello della revisione.
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | LastRevAttachDocs | Restituisce la lista dei documenti allegati all'ultima revisione.
Proprietà pubblica | LastRevData | Restituisce l'anagrafica dell'ultima revisione che può o meno concidere con quella di partenza.
Proprietà pubblica | LastRevPrimaryDocs | Restituisce la lista dei documenti primari dell'ultima revisione.
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non è impostata l'anagrafica della quale creare la nuova revisione. L'anagrafica è l'unico dato richiesto all'interfaccia utente. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NewRevData | Restituisce l'anagrafica della nuova revisione creata.
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OverriddenRevAttributes |
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Prt | Parte in salvataggio.
Proprietà pubblica | RelocatingInfos | Restituisce il dizionario delle associazioni per il relocating in caso di revisione di model state non master
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | Revs | Restituisce la lista delle revisioni dell'anagrafica compresa quella di partenza e dell'ultima revisione.
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | StartingAnagrIsLastRev | Restituisce true se l'anagrafica di partenza è anche l'ultima revisione, altrimenti false.
Proprietà pubblica | StartingAttachDocs | Restituisce la lista dei documenti allegati allanagrafica di partenza.
Proprietà pubblica | StartingData | Restituisce l'anagrafica di partenza dalla quale partire a creare la nuova revisione.
Proprietà pubblica | StartingPrimaryDocs | Restituisce la lista dei documenti primari dell'anagrafica di partenza.
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere l'anagrafica della quale creare la nuova revisione. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere l'anagrafica della quale creare la revisione. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Metodo pubblico | UpdateData | Ricalcola i campi presenti nell'anagrafica temporanea in base ai valori presenti nelle info. Chiama l'evento di personalizzazione e poi li ricalcola in modo che se l'evento ha modificato le info si riflettano i valori nell'anagrafica.
Torna su
Campi
 | Nome | Descrizione
Campo pubblico | _overriddenRevAttributes | Override degli attributi di revisione per i model state non master
Campo pubblico | CalledFromImportDataCmd | Indica se il salvataggio è chiamato dal comando di "ImportaDati"
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di RevCommand

Il tipo RevCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | ApplyRule | Permette di decidere se applicare o meno le regole di autocomposizione (di default è true).
Proprietà pubblica | BomCloneMode | Tipo di clonazione dei dati di distinta
Proprietà pubblica | CheckReservedProgr | Indica se controllare o meno se si sta salvando in un progressivo riservato.
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | ClientInterstingDocs | Restituisce la lista dei documenti di interesse del client. Questi documenti sono portati nella nuova revisione senza che l'utente possa scegliere (sono i documenti del client dai quali l'utente ha lanciato il comando di salva revisione).
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DelegateFileCopy | Restituisce o imposta il delegate che, dopo la creazione della revisione, viene chiamato dal comando per la copia effettiva dei file. Se viene lasciato vuoto la copia viene effettuatata dal comando. Chi implementa il delegate dovrebbe sollevare eccezioni in caso di errore per interrompere ed annullare tutta la procedura.
Proprietà pubblica | DelegateFileMove | Restituisce o imposta il delegate che, dopo la creazione della revisione in caso NGR si occupa di gestire le operazioni da effettuare come ausilio al backup della revisione.
Proprietà pubblica | ForcedData | Indica se i dati sono stati forzati e quindi non vanno ricalcolati ( ID , CODICE, DISEGNO, FILE )
Proprietà pubblica | Frm | Form di salvataggio.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | HideDocSelectionForm | Determina se nascondere il form di selezione dei documenti da portare nella nuova revisione
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Info | Restituisce le informazioni di codifica correntemente utilizzate dal comando. Queste informazioni non sono utilizzate per la modifica del DEDID ma solo per il calcolo di tutti gli altri campi e del nome file.
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | IsRevNewType | Restituisce se la famiglia di appartenenza delle anagrafiche abbia o meno nella codifica del file il tassello della revisione.
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | LastRevAttachDocs | Restituisce la lista dei documenti allegati all'ultima revisione.
Proprietà pubblica | LastRevData | Restituisce l'anagrafica dell'ultima revisione che può o meno concidere con quella di partenza.
Proprietà pubblica | LastRevPrimaryDocs | Restituisce la lista dei documenti primari dell'ultima revisione.
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non è impostata l'anagrafica della quale creare la nuova revisione. L'anagrafica è l'unico dato richiesto all'interfaccia utente. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NewRevData | Restituisce l'anagrafica della nuova revisione creata.
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OverriddenRevAttributes |
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Prt | Parte in salvataggio.
Proprietà pubblica | RelocatingInfos | Restituisce il dizionario delle associazioni per il relocating in caso di revisione di model state non master
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | Revs | Restituisce la lista delle revisioni dell'anagrafica compresa quella di partenza e dell'ultima revisione.
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | StartingAnagrIsLastRev | Restituisce true se l'anagrafica di partenza è anche l'ultima revisione, altrimenti false.
Proprietà pubblica | StartingAttachDocs | Restituisce la lista dei documenti allegati allanagrafica di partenza.
Proprietà pubblica | StartingData | Restituisce l'anagrafica di partenza dalla quale partire a creare la nuova revisione.
Proprietà pubblica | StartingPrimaryDocs | Restituisce la lista dei documenti primari dell'anagrafica di partenza.
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe RevCommand
Namespace DedNet.Commands


Proprietà RevCommand.ApplyRule

Proprietà RevCommandApplyRule
Permette di decidere se applicare o meno le regole di autocomposizione (di default è true).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ApplyRule { get; set; }
Public Property ApplyRule As Boolean
    Get
    Set
public:
property bool ApplyRule {
    bool get ();
    void set (bool value);
}
member ApplyRule : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe RevCommand
Namespace DedNet.Commands


Proprietà RevCommand.BomCloneMode

Proprietà RevCommandBomCloneMode
Tipo di clonazione dei dati di distinta

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomCloneMode BomCloneMode { get; set; }
Public Property BomCloneMode As BomCloneMode
    Get
    Set
public:
property BomCloneMode BomCloneMode {
    BomCloneMode get ();
    void set (BomCloneMode value);
}
member BomCloneMode : BomCloneMode with get, set

Valore della proprietà

BomCloneMode
Vedi anche

Documentazione

Classe RevCommand
Namespace DedNet.Commands


Proprietà RevCommand.CheckReservedProgr

Proprietà RevCommandCheckReservedProgr
Indica se controllare o meno se si sta salvando in un progressivo riservato.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CheckReservedProgr { get; set; }
Public Property CheckReservedProgr As Boolean
    Get
    Set
public:
property bool CheckReservedProgr {
    bool get ();
    void set (bool value);
}
member CheckReservedProgr : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe RevCommand
Namespace DedNet.Commands


Proprietà RevCommand.ClientInterstingDocs

Proprietà RevCommandClientInterstingDocs
Restituisce la lista dei documenti di interesse del client. Questi documenti sono portati nella nuova revisione senza che l'utente possa scegliere (sono i documenti del client dai quali l'utente ha lanciato il comando di salva revisione).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfoList ClientInterstingDocs { get; }
Public ReadOnly Property ClientInterstingDocs As DocStructInfoList
    Get
public:
property DocStructInfoList^ ClientInterstingDocs {
    DocStructInfoList^ get ();
}
member ClientInterstingDocs : DocStructInfoList with get

Valore della proprietà

DocStructInfoList
Vedi anche

Documentazione

Classe RevCommand
Namespace DedNet.Commands


Proprietà RevCommand.DelegateFileCopy

Proprietà RevCommandDelegateFileCopy
Restituisce o imposta il delegate che, dopo la creazione della revisione, viene chiamato dal comando per la copia effettiva dei file. Se viene lasciato vuoto la copia viene effettuatata dal comando. Chi implementa il delegate dovrebbe sollevare eccezioni in caso di errore per interrompere ed annullare tutta la procedura.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public FileOperationDelegate<DocStructInfoList> DelegateFileCopy { get; set; }
Public Property DelegateFileCopy As FileOperationDelegate(Of DocStructInfoList)
    Get
    Set
public:
property FileOperationDelegate<DocStructInfoList^>^ DelegateFileCopy {
    FileOperationDelegate<DocStructInfoList^>^ get ();
    void set (FileOperationDelegate<DocStructInfoList^>^ value);
}
member DelegateFileCopy : FileOperationDelegate<DocStructInfoList> with get, set

Valore della proprietà

FileOperationDelegate DocStructInfoList
Vedi anche

Documentazione

Classe RevCommand
Namespace DedNet.Commands


Proprietà RevCommand.DelegateFileMove

Proprietà RevCommandDelegateFileMove
Restituisce o imposta il delegate che, dopo la creazione della revisione in caso NGR si occupa di gestire le operazioni da effettuare come ausilio al backup della revisione.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public FileOperationDelegate<MoveDocumentMoveDocumentList> DelegateFileMove { get; set; }
Public Property DelegateFileMove As FileOperationDelegate(Of MoveDocumentMoveDocumentList)
    Get
    Set
public:
property FileOperationDelegate<MoveDocumentMoveDocumentList^>^ DelegateFileMove {
    FileOperationDelegate<MoveDocumentMoveDocumentList^>^ get ();
    void set (FileOperationDelegate<MoveDocumentMoveDocumentList^>^ value);
}
member DelegateFileMove : FileOperationDelegate<MoveDocumentMoveDocumentList> with get, set

Valore della proprietà

FileOperationDelegate MoveDocumentMoveDocumentList
Vedi anche

Documentazione

Classe RevCommand
Namespace DedNet.Commands


Proprietà RevCommand.ForcedData

Proprietà RevCommandForcedData
Indica se i dati sono stati forzati e quindi non vanno ricalcolati ( ID , CODICE, DISEGNO, FILE )

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ForcedData { get; set; }
Public Property ForcedData As Boolean
    Get
    Set
public:
property bool ForcedData {
    bool get ();
    void set (bool value);
}
member ForcedData : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe RevCommand
Namespace DedNet.Commands


Proprietà RevCommand.Frm

Proprietà RevCommandFrm
Form di salvataggio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormSave Frm { get; }
Public ReadOnly Property Frm As DedFormSave
    Get
public:
property DedFormSave^ Frm {
    DedFormSave^ get ();
}
member Frm : DedFormSave with get

Valore della proprietà

DedFormSave
Vedi anche

Documentazione

Classe RevCommand
Namespace DedNet.Commands


Proprietà RevCommand.HideDocSelectionForm

Proprietà RevCommandHideDocSelectionForm
Determina se nascondere il form di selezione dei documenti da portare nella nuova revisione

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HideDocSelectionForm { get; set; }
Public Property HideDocSelectionForm As Boolean
    Get
    Set
public:
property bool HideDocSelectionForm {
    bool get ();
    void set (bool value);
}
member HideDocSelectionForm : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe RevCommand
Namespace DedNet.Commands


Proprietà RevCommand.Info

Proprietà RevCommandInfo
Restituisce le informazioni di codifica correntemente utilizzate dal comando. Queste informazioni non sono utilizzate per la modifica del DEDID ma solo per il calcolo di tutti gli altri campi e del nome file.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEncodeInfo Info { get; }
Public ReadOnly Property Info As DedEncodeInfo
    Get
public:
property DedEncodeInfo^ Info {
    DedEncodeInfo^ get ();
}
member Info : DedEncodeInfo with get

Valore della proprietà

DedEncodeInfo
Vedi anche

Documentazione

Classe RevCommand
Namespace DedNet.Commands


Proprietà RevCommand.IsRevNewType

Proprietà RevCommandIsRevNewType
Restituisce se la famiglia di appartenenza delle anagrafiche abbia o meno nella codifica del file il tassello della revisione.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsRevNewType { get; }
Public ReadOnly Property IsRevNewType As Boolean
    Get
public:
property bool IsRevNewType {
    bool get ();
}
member IsRevNewType : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe RevCommand
Namespace DedNet.Commands


Proprietà RevCommand.LastRevAttachDocs

Proprietà RevCommandLastRevAttachDocs
Restituisce la lista dei documenti allegati all'ultima revisione.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocList LastRevAttachDocs { get; }
Public ReadOnly Property LastRevAttachDocs As DedDocList
    Get
public:
property DedDocList^ LastRevAttachDocs {
    DedDocList^ get ();
}
member LastRevAttachDocs : DedDocList with get

Valore della proprietà

DedDocList
Vedi anche

Documentazione

Classe RevCommand
Namespace DedNet.Commands


Proprietà RevCommand.LastRevData

Proprietà RevCommandLastRevData
Restituisce l'anagrafica dell'ultima revisione che può o meno concidere con quella di partenza.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData LastRevData { get; }
Public ReadOnly Property LastRevData As DedData
    Get
public:
property DedData^ LastRevData {
    DedData^ get ();
}
member LastRevData : DedData with get

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe RevCommand
Namespace DedNet.Commands


Proprietà RevCommand.LastRevPrimaryDocs

Proprietà RevCommandLastRevPrimaryDocs
Restituisce la lista dei documenti primari dell'ultima revisione.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocList LastRevPrimaryDocs { get; }
Public ReadOnly Property LastRevPrimaryDocs As DedDocList
    Get
public:
property DedDocList^ LastRevPrimaryDocs {
    DedDocList^ get ();
}
member LastRevPrimaryDocs : DedDocList with get

Valore della proprietà

DedDocList
Vedi anche

Documentazione

Classe RevCommand
Namespace DedNet.Commands


Proprietà RevCommand.NeedParameters

Proprietà RevCommandNeedParameters
Restituisce true se non è impostata l'anagrafica della quale creare la nuova revisione. L'anagrafica è l'unico dato richiesto all'interfaccia utente.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe RevCommand
Namespace DedNet.Commands


Proprietà RevCommand.NewRevData

Proprietà RevCommandNewRevData
Restituisce l'anagrafica della nuova revisione creata.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData NewRevData { get; }
Public ReadOnly Property NewRevData As DedData
    Get
public:
property DedData^ NewRevData {
    DedData^ get ();
}
member NewRevData : DedData with get

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe RevCommand
Namespace DedNet.Commands


Proprietà RevCommand.OverriddenRevAttributes

Proprietà RevCommandOverriddenRevAttributes

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDictionary OverriddenRevAttributes { get; set; }
Public Property OverriddenRevAttributes As DedDictionary
    Get
    Set
public:
property DedDictionary^ OverriddenRevAttributes {
    DedDictionary^ get ();
    void set (DedDictionary^ value);
}
member OverriddenRevAttributes : DedDictionary with get, set

Valore della proprietà

DedDictionary
Vedi anche

Documentazione

Classe RevCommand
Namespace DedNet.Commands


Proprietà RevCommand.Prt

Proprietà RevCommandPrt
Parte in salvataggio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object Prt { get; set; }
Public Property Prt As Object
    Get
    Set
public:
property Object^ Prt {
    Object^ get ();
    void set (Object^ value);
}
member Prt : Object with get, set

Valore della proprietà

Object
Vedi anche

Documentazione

Classe RevCommand
Namespace DedNet.Commands


Proprietà RevCommand.RelocatingInfos

Proprietà RevCommandRelocatingInfos
Restituisce il dizionario delle associazioni per il relocating in caso di revisione di model state non master

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ModelStateRelocationInfos RelocatingInfos { get; }
Public ReadOnly Property RelocatingInfos As ModelStateRelocationInfos
    Get
public:
property ModelStateRelocationInfos^ RelocatingInfos {
    ModelStateRelocationInfos^ get ();
}
member RelocatingInfos : ModelStateRelocationInfos with get

Valore della proprietà

ModelStateRelocationInfos
Vedi anche

Documentazione

Classe RevCommand
Namespace DedNet.Commands


Proprietà RevCommand.Revs

Proprietà RevCommandRevs
Restituisce la lista delle revisioni dell'anagrafica compresa quella di partenza e dell'ultima revisione.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataList Revs { get; }
Public ReadOnly Property Revs As DedDataList
    Get
public:
property DedDataList^ Revs {
    DedDataList^ get ();
}
member Revs : DedDataList with get

Valore della proprietà

DedDataList
Vedi anche

Documentazione

Classe RevCommand
Namespace DedNet.Commands


Proprietà RevCommand.StartingAnagrIsLastRev

Proprietà RevCommandStartingAnagrIsLastRev
Restituisce true se l'anagrafica di partenza è anche l'ultima revisione, altrimenti false.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool StartingAnagrIsLastRev { get; }
Public ReadOnly Property StartingAnagrIsLastRev As Boolean
    Get
public:
property bool StartingAnagrIsLastRev {
    bool get ();
}
member StartingAnagrIsLastRev : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe RevCommand
Namespace DedNet.Commands


Proprietà RevCommand.StartingAttachDocs

Proprietà RevCommandStartingAttachDocs
Restituisce la lista dei documenti allegati allanagrafica di partenza.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocList StartingAttachDocs { get; }
Public ReadOnly Property StartingAttachDocs As DedDocList
    Get
public:
property DedDocList^ StartingAttachDocs {
    DedDocList^ get ();
}
member StartingAttachDocs : DedDocList with get

Valore della proprietà

DedDocList
Vedi anche

Documentazione

Classe RevCommand
Namespace DedNet.Commands


Proprietà RevCommand.StartingData

Proprietà RevCommandStartingData
Restituisce l'anagrafica di partenza dalla quale partire a creare la nuova revisione.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData StartingData { get; }
Public ReadOnly Property StartingData As DedData
    Get
public:
property DedData^ StartingData {
    DedData^ get ();
}
member StartingData : DedData with get

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe RevCommand
Namespace DedNet.Commands


Proprietà RevCommand.StartingPrimaryDocs

Proprietà RevCommandStartingPrimaryDocs
Restituisce la lista dei documenti primari dell'anagrafica di partenza.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocList StartingPrimaryDocs { get; }
Public ReadOnly Property StartingPrimaryDocs As DedDocList
    Get
public:
property DedDocList^ StartingPrimaryDocs {
    DedDocList^ get ();
}
member StartingPrimaryDocs : DedDocList with get

Valore della proprietà

DedDocList
Vedi anche

Documentazione

Classe RevCommand
Namespace DedNet.Commands


Metodi di RevCommand

Il tipo RevCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere l'anagrafica della quale creare la nuova revisione. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere l'anagrafica della quale creare la revisione. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Metodo pubblico | UpdateData | Ricalcola i campi presenti nell'anagrafica temporanea in base ai valori presenti nelle info. Chiama l'evento di personalizzazione e poi li ricalcola in modo che se l'evento ha modificato le info si riflettano i valori nell'anagrafica.
Torna su
Vedi anche

Documentazione

Classe RevCommand
Namespace DedNet.Commands


Metodo RevCommand.ClearCommand

Metodo RevCommandClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe RevCommand
Namespace DedNet.Commands


Metodo RevCommand.Enabled

Metodo RevCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere l'anagrafica della quale creare la nuova revisione.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe RevCommand
Namespace DedNet.Commands


Metodo RevCommand.ExecuteCommand

Metodo RevCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe RevCommand
Namespace DedNet.Commands


Metodo RevCommand.SetContext

Metodo RevCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere l'anagrafica della quale creare la revisione.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto c'è una sola anagrafica alla quale associare il file.
Vedi anche

Documentazione

Classe RevCommand
Namespace DedNet.Commands


Metodo RevCommand.UpdateData

Metodo RevCommandUpdateData
Ricalcola i campi presenti nell'anagrafica temporanea in base ai valori presenti nelle info. Chiama l'evento di personalizzazione e poi li ricalcola in modo che se l'evento ha modificato le info si riflettano i valori nell'anagrafica.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void UpdateData()
Public Sub UpdateData
public:
void UpdateData()
member UpdateData : unit -> unit
Vedi anche

Documentazione

Classe RevCommand
Namespace DedNet.Commands


Campi di RevCommand

Il tipo RevCommand espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | _overriddenRevAttributes | Override degli attributi di revisione per i model state non master
Campo pubblico | CalledFromImportDataCmd | Indica se il salvataggio è chiamato dal comando di "ImportaDati"
Torna su
Vedi anche

Documentazione

Classe RevCommand
Namespace DedNet.Commands


Campo RevCommand._overriddenRevAttributes

Campo RevCommand_overriddenRevAttributes
Override degli attributi di revisione per i model state non master

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDictionary _overriddenRevAttributes
Public _overriddenRevAttributes As DedDictionary
public:
DedDictionary^ _overriddenRevAttributes
val mutable _overriddenRevAttributes: DedDictionary

Valore del campo

DedDictionary
Vedi anche

Documentazione

Classe RevCommand
Namespace DedNet.Commands


Campo RevCommand.CalledFromImportDataCmd

Campo RevCommandCalledFromImportDataCmd
Indica se il salvataggio è chiamato dal comando di "ImportaDati"

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CalledFromImportDataCmd
Public CalledFromImportDataCmd As Boolean
public:
bool CalledFromImportDataCmd
val mutable CalledFromImportDataCmd: bool

Valore del campo

Boolean
Vedi anche

Documentazione

Classe RevCommand
Namespace DedNet.Commands


Classe RootManagerCommand
Classe che rappresenta il comando per editare le root.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsRootManagerCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class RootManagerCommand : DedCommand
Public Class RootManagerCommand
    Inherits DedCommand
public ref class RootManagerCommand : public DedCommand
type RootManagerCommand =
    class
        inherit DedCommand
    end

Il tipo RootManagerCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DbAlreadyLocked | Indica se il database è già stato bloccato. Di conseguenza non verrà effettuato un altro blocco. Di default è false;
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Verifica se il comando necessita di parametri fondamentali. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di RootManagerCommand

Il tipo RootManagerCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DbAlreadyLocked | Indica se il database è già stato bloccato. Di conseguenza non verrà effettuato un altro blocco. Di default è false;
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Verifica se il comando necessita di parametri fondamentali. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe RootManagerCommand
Namespace DedNet.Commands


Proprietà RootManagerCommand.DbAlreadyLocked

Proprietà RootManagerCommandDbAlreadyLocked
Indica se il database è già stato bloccato. Di conseguenza non verrà effettuato un altro blocco. Di default è false;

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool DbAlreadyLocked { get; set; }
Public Property DbAlreadyLocked As Boolean
    Get
    Set
public:
property bool DbAlreadyLocked {
    bool get ();
    void set (bool value);
}
member DbAlreadyLocked : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe RootManagerCommand
Namespace DedNet.Commands


Proprietà RootManagerCommand.NeedParameters

Proprietà RootManagerCommandNeedParameters
Verifica se il comando necessita di parametri fondamentali.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe RootManagerCommand
Namespace DedNet.Commands


Metodi di RootManagerCommand

Il tipo RootManagerCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe RootManagerCommand
Namespace DedNet.Commands


Metodo RootManagerCommand.ClearCommand

Metodo RootManagerCommandClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe RootManagerCommand
Namespace DedNet.Commands


Metodo RootManagerCommand.Enabled

Metodo RootManagerCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe RootManagerCommand
Namespace DedNet.Commands


Metodo RootManagerCommand.ExecuteCommand

Metodo RootManagerCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe RootManagerCommand
Namespace DedNet.Commands


Metodo RootManagerCommand.SetContext

Metodo RootManagerCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe RootManagerCommand
Namespace DedNet.Commands


Classe SaveCommand
Crea una nuova anagrafica partendo dal nulla o da un'anagrafica già esistente. Non si porta dietro alcun documento dell'anagrafica di partenza. Se si vuole attuare un Duplica anagrafica facendo creare un nuovo progressivo e salvando nella stessa famiglia dell'anagrafica di partenza, impostare la proprietà Info.Data con l'anagrafica di partenza (clonata tramite il metodo MakeClonePart()). Se invece si desidera creare una nuova anagrafica utilizzando dati personalizzati, impostare i vari campi della proprietà Info secondo le esigenze. Impostare in Info.Data gli attributi precompilati desiderati. Ogni proprietà impostata dell'oggetto Info, come il progressivo, la revisione o il tassello utente, ha la priorità su quanto presente nell'anagrafica Info.Data. Utilizzare la proprietà UseUI per visualizzare o meno all'utente la finestra di salvataggio per la convalida dei dati.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsSaveCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class SaveCommand : DedCommand
Public Class SaveCommand
    Inherits DedCommand
public ref class SaveCommand : public DedCommand
type SaveCommand =
    class
        inherit DedCommand
    end

Il tipo SaveCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | ApplyRule | Permette di decidere se applicare o meno le regole di autocomposizione (quando lanciato da script).
Proprietà pubblica | BomCloneMode | Tipo di clonazione dei dati di distinta
Proprietà pubblica | CheckReservedProgr | Indica se controllare o meno se si sta salvando in un progressivo riservato.
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | ClientDocs | Lista dei documenti che sono gestiti dal client.
Proprietà pubblica | CloneDist | Imposta o restituisce se clonare o meno la distinta nel caso in cui il comando sia un "Duplica Anagrafica".
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CreazioneVariante | Restituisce se il comando sia utilizzato per creare la variante di un codice. In tal caso sarà permessa la modifica dei soli attributi e non del progressivo. Questa opzione viene impostata dal metodo costruttore dell'Application utilizzato per la creazione dell'oggetto.
Proprietà pubblica | DuplicazioneAnagrafica | Indica se il comando sia utilizzato come duplicazione di anagrafica.
Proprietà pubblica | ForcedData | Indica se i dati sono stati forzati e quindi non vanno ricalcolati ( ID , CODICE, DISEGNO, FILE )
Proprietà pubblica | ForcedMoveInfo | Restituisce le informazioni di codifica correntemente utilizzate dal comando.
Proprietà pubblica | ForceRecognize | Indica se forzare un Riconosci (tipicamente da Inventor in caso siano presenti dei Member).
Proprietà pubblica | Frm | Form di salvataggio.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HandleRecognize | Indica al chiamante se gestire un Riconosci.
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Info | Restituisce le informazioni di codifica correntemente utilizzate dal comando.
Proprietà pubblica | InfoFile | Imposta/Restituisce l'oggetto GridInfoDataList relativo alla selezione dei documenti dell'utente.
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | ManageDocsOnSave | Indica se gestire i documenti.
Proprietà pubblica | Mdres | Restituisce le informazioni di codifica correntemente utilizzate dal comando.
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce sempre false perché il salvataggio può essere lanciato anche senza informazioni, ma chiedendo all'utente di selezionare la famiglia di archiviazione. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NewData | Restituisce l'anagrafica creata.
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | NotIncreaseProgr | Indica di non incrementare il progressivo della famiglia
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Prt | Parte in salvataggio.
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | SaveMultiple | Imposta o restituisce se è stato chiamato all'interno di un comando di salva multipo.
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | StartingData | Restituisce l'anagrafica di partenza, se presente, ricavata dal DEDID e DEDREV presenti nelle info.
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Proprietà pubblica | ValidateAttrs | Indica se considerare eventuali errori negli attributi.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Metodo pubblico | UpdateData | Ricalcola i campi presenti nell'anagrafica temporanea in base ai valori presenti nelle info. Chiama l'evento di personalizzazione e poi li ricalcola in modo che se l'evento ha modificato le info si riflettano i valori nell'anagrafica.
Torna su
Campi
 | Nome | Descrizione
Campo pubblico | CalledFromImportDataCmd | Indica se il salvataggio è chiamato dal comando di "ImportaDati"
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di SaveCommand

Il tipo SaveCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | ApplyRule | Permette di decidere se applicare o meno le regole di autocomposizione (quando lanciato da script).
Proprietà pubblica | BomCloneMode | Tipo di clonazione dei dati di distinta
Proprietà pubblica | CheckReservedProgr | Indica se controllare o meno se si sta salvando in un progressivo riservato.
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | ClientDocs | Lista dei documenti che sono gestiti dal client.
Proprietà pubblica | CloneDist | Imposta o restituisce se clonare o meno la distinta nel caso in cui il comando sia un "Duplica Anagrafica".
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CreazioneVariante | Restituisce se il comando sia utilizzato per creare la variante di un codice. In tal caso sarà permessa la modifica dei soli attributi e non del progressivo. Questa opzione viene impostata dal metodo costruttore dell'Application utilizzato per la creazione dell'oggetto.
Proprietà pubblica | DuplicazioneAnagrafica | Indica se il comando sia utilizzato come duplicazione di anagrafica.
Proprietà pubblica | ForcedData | Indica se i dati sono stati forzati e quindi non vanno ricalcolati ( ID , CODICE, DISEGNO, FILE )
Proprietà pubblica | ForcedMoveInfo | Restituisce le informazioni di codifica correntemente utilizzate dal comando.
Proprietà pubblica | ForceRecognize | Indica se forzare un Riconosci (tipicamente da Inventor in caso siano presenti dei Member).
Proprietà pubblica | Frm | Form di salvataggio.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HandleRecognize | Indica al chiamante se gestire un Riconosci.
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Info | Restituisce le informazioni di codifica correntemente utilizzate dal comando.
Proprietà pubblica | InfoFile | Imposta/Restituisce l'oggetto GridInfoDataList relativo alla selezione dei documenti dell'utente.
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | ManageDocsOnSave | Indica se gestire i documenti.
Proprietà pubblica | Mdres | Restituisce le informazioni di codifica correntemente utilizzate dal comando.
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce sempre false perché il salvataggio può essere lanciato anche senza informazioni, ma chiedendo all'utente di selezionare la famiglia di archiviazione. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NewData | Restituisce l'anagrafica creata.
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | NotIncreaseProgr | Indica di non incrementare il progressivo della famiglia
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Prt | Parte in salvataggio.
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | SaveMultiple | Imposta o restituisce se è stato chiamato all'interno di un comando di salva multipo.
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | StartingData | Restituisce l'anagrafica di partenza, se presente, ricavata dal DEDID e DEDREV presenti nelle info.
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Proprietà pubblica | ValidateAttrs | Indica se considerare eventuali errori negli attributi.
Torna su
Vedi anche

Documentazione

Classe SaveCommand
Namespace DedNet.Commands


Proprietà SaveCommand.ApplyRule

Proprietà SaveCommandApplyRule
Permette di decidere se applicare o meno le regole di autocomposizione (quando lanciato da script).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ApplyRule { set; }
Public WriteOnly Property ApplyRule As Boolean
    Set
public:
property bool ApplyRule {
    void set (bool value);
}
member ApplyRule : bool with set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SaveCommand
Namespace DedNet.Commands


Proprietà SaveCommand.BomCloneMode

Proprietà SaveCommandBomCloneMode
Tipo di clonazione dei dati di distinta

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomCloneMode BomCloneMode { get; set; }
Public Property BomCloneMode As BomCloneMode
    Get
    Set
public:
property BomCloneMode BomCloneMode {
    BomCloneMode get ();
    void set (BomCloneMode value);
}
member BomCloneMode : BomCloneMode with get, set

Valore della proprietà

BomCloneMode
Vedi anche

Documentazione

Classe SaveCommand
Namespace DedNet.Commands


Proprietà SaveCommand.CheckReservedProgr

Proprietà SaveCommandCheckReservedProgr
Indica se controllare o meno se si sta salvando in un progressivo riservato.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CheckReservedProgr { get; set; }
Public Property CheckReservedProgr As Boolean
    Get
    Set
public:
property bool CheckReservedProgr {
    bool get ();
    void set (bool value);
}
member CheckReservedProgr : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SaveCommand
Namespace DedNet.Commands


Proprietà SaveCommand.ClientDocs

Proprietà SaveCommandClientDocs
Lista dei documenti che sono gestiti dal client.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfoList ClientDocs { get; set; }
Public Property ClientDocs As DocStructInfoList
    Get
    Set
public:
property DocStructInfoList^ ClientDocs {
    DocStructInfoList^ get ();
    void set (DocStructInfoList^ value);
}
member ClientDocs : DocStructInfoList with get, set

Valore della proprietà

DocStructInfoList
Vedi anche

Documentazione

Classe SaveCommand
Namespace DedNet.Commands


Proprietà SaveCommand.CloneDist

Proprietà SaveCommandCloneDist
Imposta o restituisce se clonare o meno la distinta nel caso in cui il comando sia un "Duplica Anagrafica".

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CloneDist { set; }
Public WriteOnly Property CloneDist As Boolean
    Set
public:
property bool CloneDist {
    void set (bool value);
}
member CloneDist : bool with set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SaveCommand
Namespace DedNet.Commands


Proprietà SaveCommand.CreazioneVariante

Proprietà SaveCommandCreazioneVariante
Restituisce se il comando sia utilizzato per creare la variante di un codice. In tal caso sarà permessa la modifica dei soli attributi e non del progressivo. Questa opzione viene impostata dal metodo costruttore dell'Application utilizzato per la creazione dell'oggetto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CreazioneVariante { get; set; }
Public Property CreazioneVariante As Boolean
    Get
    Set
public:
property bool CreazioneVariante {
    bool get ();
    void set (bool value);
}
member CreazioneVariante : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SaveCommand
Namespace DedNet.Commands


Proprietà SaveCommand.DuplicazioneAnagrafica

Proprietà SaveCommandDuplicazioneAnagrafica
Indica se il comando sia utilizzato come duplicazione di anagrafica.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool DuplicazioneAnagrafica { get; set; }
Public Property DuplicazioneAnagrafica As Boolean
    Get
    Set
public:
property bool DuplicazioneAnagrafica {
    bool get ();
    void set (bool value);
}
member DuplicazioneAnagrafica : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SaveCommand
Namespace DedNet.Commands


Proprietà SaveCommand.ForcedData

Proprietà SaveCommandForcedData
Indica se i dati sono stati forzati e quindi non vanno ricalcolati ( ID , CODICE, DISEGNO, FILE )

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ForcedData { get; set; }
Public Property ForcedData As Boolean
    Get
    Set
public:
property bool ForcedData {
    bool get ();
    void set (bool value);
}
member ForcedData : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SaveCommand
Namespace DedNet.Commands


Proprietà SaveCommand.ForcedMoveInfo

Proprietà SaveCommandForcedMoveInfo
Restituisce le informazioni di codifica correntemente utilizzate dal comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public MoveDocumentInfoForcedMoveInfo ForcedMoveInfo { get; set; }
Public Property ForcedMoveInfo As MoveDocumentInfoForcedMoveInfo
    Get
    Set
public:
property MoveDocumentInfoForcedMoveInfo^ ForcedMoveInfo {
    MoveDocumentInfoForcedMoveInfo^ get ();
    void set (MoveDocumentInfoForcedMoveInfo^ value);
}
member ForcedMoveInfo : MoveDocumentInfoForcedMoveInfo with get, set

Valore della proprietà

MoveDocumentInfoForcedMoveInfo
Vedi anche

Documentazione

Classe SaveCommand
Namespace DedNet.Commands


Proprietà SaveCommand.ForceRecognize

Proprietà SaveCommandForceRecognize
Indica se forzare un Riconosci (tipicamente da Inventor in caso siano presenti dei Member).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ForceRecognize { get; set; }
Public Property ForceRecognize As Boolean
    Get
    Set
public:
property bool ForceRecognize {
    bool get ();
    void set (bool value);
}
member ForceRecognize : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SaveCommand
Namespace DedNet.Commands


Proprietà SaveCommand.Frm

Proprietà SaveCommandFrm
Form di salvataggio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormSave Frm { get; }
Public ReadOnly Property Frm As DedFormSave
    Get
public:
property DedFormSave^ Frm {
    DedFormSave^ get ();
}
member Frm : DedFormSave with get

Valore della proprietà

DedFormSave
Vedi anche

Documentazione

Classe SaveCommand
Namespace DedNet.Commands


Proprietà SaveCommand.HandleRecognize

Proprietà SaveCommandHandleRecognize
Indica al chiamante se gestire un Riconosci.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HandleRecognize { get; }
Public ReadOnly Property HandleRecognize As Boolean
    Get
public:
property bool HandleRecognize {
    bool get ();
}
member HandleRecognize : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SaveCommand
Namespace DedNet.Commands


Proprietà SaveCommand.Info

Proprietà SaveCommandInfo
Restituisce le informazioni di codifica correntemente utilizzate dal comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEncodeInfo Info { get; }
Public ReadOnly Property Info As DedEncodeInfo
    Get
public:
property DedEncodeInfo^ Info {
    DedEncodeInfo^ get ();
}
member Info : DedEncodeInfo with get

Valore della proprietà

DedEncodeInfo
Vedi anche

Documentazione

Classe SaveCommand
Namespace DedNet.Commands


Proprietà SaveCommand.InfoFile

Proprietà SaveCommandInfoFile
Imposta/Restituisce l'oggetto GridInfoDataList relativo alla selezione dei documenti dell'utente.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public GridInfoDataList InfoFile { get; set; }
Public Property InfoFile As GridInfoDataList
    Get
    Set
public:
property GridInfoDataList^ InfoFile {
    GridInfoDataList^ get ();
    void set (GridInfoDataList^ value);
}
member InfoFile : GridInfoDataList with get, set

Valore della proprietà

GridInfoDataList
Vedi anche

Documentazione

Classe SaveCommand
Namespace DedNet.Commands


Proprietà SaveCommand.ManageDocsOnSave

Proprietà SaveCommandManageDocsOnSave
Indica se gestire i documenti.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ManageDocsOnSave { get; set; }
Public Property ManageDocsOnSave As Boolean
    Get
    Set
public:
property bool ManageDocsOnSave {
    bool get ();
    void set (bool value);
}
member ManageDocsOnSave : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SaveCommand
Namespace DedNet.Commands


Proprietà SaveCommand.Mdres

Proprietà SaveCommandMdres
Restituisce le informazioni di codifica correntemente utilizzate dal comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public MoveDocumentResult Mdres { get; set; }
Public Property Mdres As MoveDocumentResult
    Get
    Set
public:
property MoveDocumentResult^ Mdres {
    MoveDocumentResult^ get ();
    void set (MoveDocumentResult^ value);
}
member Mdres : MoveDocumentResult with get, set

Valore della proprietà

MoveDocumentResult
Vedi anche

Documentazione

Classe SaveCommand
Namespace DedNet.Commands


Proprietà SaveCommand.NeedParameters

Proprietà SaveCommandNeedParameters
Restituisce sempre false perché il salvataggio può essere lanciato anche senza informazioni, ma chiedendo all'utente di selezionare la famiglia di archiviazione.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SaveCommand
Namespace DedNet.Commands


Proprietà SaveCommand.NewData

Proprietà SaveCommandNewData
Restituisce l'anagrafica creata.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData NewData { get; protected set; }
Public Property NewData As DedData
    Get
    Protected Set
public:
property DedData^ NewData {
    DedData^ get ();
    protected: void set (DedData^ value);
}
member NewData : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe SaveCommand
Namespace DedNet.Commands


Proprietà SaveCommand.NotIncreaseProgr

Proprietà SaveCommandNotIncreaseProgr
Indica di non incrementare il progressivo della famiglia

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool NotIncreaseProgr { get; set; }
Public Property NotIncreaseProgr As Boolean
    Get
    Set
public:
property bool NotIncreaseProgr {
    bool get ();
    void set (bool value);
}
member NotIncreaseProgr : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SaveCommand
Namespace DedNet.Commands


Proprietà SaveCommand.Prt

Proprietà SaveCommandPrt
Parte in salvataggio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object Prt { get; set; }
Public Property Prt As Object
    Get
    Set
public:
property Object^ Prt {
    Object^ get ();
    void set (Object^ value);
}
member Prt : Object with get, set

Valore della proprietà

Object
Vedi anche

Documentazione

Classe SaveCommand
Namespace DedNet.Commands


Proprietà SaveCommand.SaveMultiple

Proprietà SaveCommandSaveMultiple
Imposta o restituisce se è stato chiamato all'interno di un comando di salva multipo.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool SaveMultiple { get; set; }
Public Property SaveMultiple As Boolean
    Get
    Set
public:
property bool SaveMultiple {
    bool get ();
    void set (bool value);
}
member SaveMultiple : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SaveCommand
Namespace DedNet.Commands


Proprietà SaveCommand.StartingData

Proprietà SaveCommandStartingData
Restituisce l'anagrafica di partenza, se presente, ricavata dal DEDID e DEDREV presenti nelle info.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData StartingData { get; }
Public ReadOnly Property StartingData As DedData
    Get
public:
property DedData^ StartingData {
    DedData^ get ();
}
member StartingData : DedData with get

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe SaveCommand
Namespace DedNet.Commands


Proprietà SaveCommand.ValidateAttrs

Proprietà SaveCommandValidateAttrs
Indica se considerare eventuali errori negli attributi.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ValidateAttrs { get; set; }
Public Property ValidateAttrs As Boolean
    Get
    Set
public:
property bool ValidateAttrs {
    bool get ();
    void set (bool value);
}
member ValidateAttrs : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SaveCommand
Namespace DedNet.Commands


Metodi di SaveCommand

Il tipo SaveCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Metodo pubblico | UpdateData | Ricalcola i campi presenti nell'anagrafica temporanea in base ai valori presenti nelle info. Chiama l'evento di personalizzazione e poi li ricalcola in modo che se l'evento ha modificato le info si riflettano i valori nell'anagrafica.
Torna su
Vedi anche

Documentazione

Classe SaveCommand
Namespace DedNet.Commands


Metodo SaveCommand.ClearCommand

Metodo SaveCommandClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe SaveCommand
Namespace DedNet.Commands


Metodo SaveCommand.Enabled

Metodo SaveCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe SaveCommand
Namespace DedNet.Commands


Metodo SaveCommand.ExecuteCommand

Metodo SaveCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe SaveCommand
Namespace DedNet.Commands


Metodo SaveCommand.SetContext

Metodo SaveCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto c'è una sola anagrafica alla quale associare il file.
Vedi anche

Documentazione

Classe SaveCommand
Namespace DedNet.Commands


Metodo SaveCommand.UpdateData

Metodo SaveCommandUpdateData
Ricalcola i campi presenti nell'anagrafica temporanea in base ai valori presenti nelle info. Chiama l'evento di personalizzazione e poi li ricalcola in modo che se l'evento ha modificato le info si riflettano i valori nell'anagrafica.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void UpdateData()
Public Sub UpdateData
public:
void UpdateData()
member UpdateData : unit -> unit
Vedi anche

Documentazione

Classe SaveCommand
Namespace DedNet.Commands


Campi di SaveCommand

Il tipo SaveCommand espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | CalledFromImportDataCmd | Indica se il salvataggio è chiamato dal comando di "ImportaDati"
Torna su
Vedi anche

Documentazione

Classe SaveCommand
Namespace DedNet.Commands


Campo SaveCommand.CalledFromImportDataCmd

Campo SaveCommandCalledFromImportDataCmd
Indica se il salvataggio è chiamato dal comando di "ImportaDati"

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CalledFromImportDataCmd
Public CalledFromImportDataCmd As Boolean
public:
bool CalledFromImportDataCmd
val mutable CalledFromImportDataCmd: bool

Valore del campo

Boolean
Vedi anche

Documentazione

Classe SaveCommand
Namespace DedNet.Commands


Classe SaveDistCommand
Comando che implementa il salvataggio della distinta nel Database. Riceve come parametro una struttura di archiviazione. Opzionalmente è possibile visualizzare in anteprima la distinta in salvataggio. TODO : Ancora la finestra di anteprima non è disponibile... Le anagrafiche che non sono nel Database vengono create nella famiglia di default oppure in una particolare famiglia. O il salvataggio funziona completamente altrimenti viene effettuato il rollback di tutto. Se l'elemento di testa in salvataggio è solo e non ha figli la distinta viene svuotata (chiedendo conferma all'utente se UseUI = true), questo però vale solo per l'elemento di testa.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsSaveDistCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class SaveDistCommand : DedCommand
Public Class SaveDistCommand
    Inherits DedCommand
public ref class SaveDistCommand : public DedCommand
type SaveDistCommand =
    class
        inherit DedCommand
    end

Il tipo SaveDistCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllowNoDbCode | Restituisce o imposta se consentire il salvataggio di distinte contenenti codici non presenti nel Database. Di default è inizializzata con la variabile CreaAnagrInSalvaDist (che di default è true) e cerca di creare le anagrafiche mancanti.
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | ChildDataStateSaveRestrictions | Descrittore delle restrizioni dal salvataggio sugli stati delle anagrafiche figlie
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DataStateSaveRestrictions | Descrittore delle restrizione del salvataggio sugli stati dell'anagrafica
Proprietà pubblica | DistManager | Restituisce il DistManager utilizzato dal comando.
Proprietà pubblica | ElemType | Restituisce o imposta il tipo di elemento in salvataggio (CAD di default).
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreDataState | Indica se nel lock dell'header in salvataggio deve ignorare lo stato dell'anagrafica. Di default è false
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | LazyMode | Restituisce o imposta se ignorare i nodi sui quali non è possibile risalire o creare una anagrafica. Se attivo il salvataggio continua senza sollevare eccezioni. (Default = false)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | MultiLevel | Restituisce o imposta se effettuare il salvataggio della distinta multilivello. Di default è inizializzata con la variabile SalvaDistMultiLiv (che di default è true) e viene salvata la distinta multilivello.
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve essere impostata la struttura di salvataggio distinta. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RootElement | Restitusice o imposta l'elemento root della struttura in salvataggio. Questo elemento deve necessariamente essere presente nel Database. Se non ha figli la sua distinta viene cancellata.
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Esegue la pulizia del comando. Azzera tutte le variabili. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). Restituisce sempre false perché non è direttamente chiamato dall'utente. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
 | GetRestrictSaveDistState | Dato il valore in stringa ritorna il tipo associato
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Restituisce sempre false perché non è direttamente chiamato dall'utente. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di SaveDistCommand

Il tipo SaveDistCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllowNoDbCode | Restituisce o imposta se consentire il salvataggio di distinte contenenti codici non presenti nel Database. Di default è inizializzata con la variabile CreaAnagrInSalvaDist (che di default è true) e cerca di creare le anagrafiche mancanti.
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | ChildDataStateSaveRestrictions | Descrittore delle restrizioni dal salvataggio sugli stati delle anagrafiche figlie
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DataStateSaveRestrictions | Descrittore delle restrizione del salvataggio sugli stati dell'anagrafica
Proprietà pubblica | DistManager | Restituisce il DistManager utilizzato dal comando.
Proprietà pubblica | ElemType | Restituisce o imposta il tipo di elemento in salvataggio (CAD di default).
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreDataState | Indica se nel lock dell'header in salvataggio deve ignorare lo stato dell'anagrafica. Di default è false
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | LazyMode | Restituisce o imposta se ignorare i nodi sui quali non è possibile risalire o creare una anagrafica. Se attivo il salvataggio continua senza sollevare eccezioni. (Default = false)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | MultiLevel | Restituisce o imposta se effettuare il salvataggio della distinta multilivello. Di default è inizializzata con la variabile SalvaDistMultiLiv (che di default è true) e viene salvata la distinta multilivello.
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve essere impostata la struttura di salvataggio distinta. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RootElement | Restitusice o imposta l'elemento root della struttura in salvataggio. Questo elemento deve necessariamente essere presente nel Database. Se non ha figli la sua distinta viene cancellata.
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe SaveDistCommand
Namespace DedNet.Commands


Proprietà SaveDistCommand.AllowNoDbCode

Proprietà SaveDistCommandAllowNoDbCode
Restituisce o imposta se consentire il salvataggio di distinte contenenti codici non presenti nel Database. Di default è inizializzata con la variabile CreaAnagrInSalvaDist (che di default è true) e cerca di creare le anagrafiche mancanti.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AllowNoDbCode { get; set; }
Public Property AllowNoDbCode As Boolean
    Get
    Set
public:
property bool AllowNoDbCode {
    bool get ();
    void set (bool value);
}
member AllowNoDbCode : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SaveDistCommand
Namespace DedNet.Commands


Proprietà SaveDistCommand.ChildDataStateSaveRestrictions

Proprietà SaveDistCommandChildDataStateSaveRestrictions
Descrittore delle restrizioni dal salvataggio sugli stati delle anagrafiche figlie

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<DedState, bool> ChildDataStateSaveRestrictions { get; }
Public ReadOnly Property ChildDataStateSaveRestrictions As Dictionary(Of DedState, Boolean)
    Get
public:
property Dictionary<DedState^, bool>^ ChildDataStateSaveRestrictions {
    Dictionary<DedState^, bool>^ get ();
}
member ChildDataStateSaveRestrictions : Dictionary<DedState, bool> with get

Valore della proprietà

Dictionary DedState, Boolean
Vedi anche

Documentazione

Classe SaveDistCommand
Namespace DedNet.Commands


Proprietà SaveDistCommand.DataStateSaveRestrictions

Proprietà SaveDistCommandDataStateSaveRestrictions
Descrittore delle restrizione del salvataggio sugli stati dell'anagrafica

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<DedState, SaveDistCommandRestrictSaveDistStates> DataStateSaveRestrictions { get; }
Public ReadOnly Property DataStateSaveRestrictions As Dictionary(Of DedState, SaveDistCommandRestrictSaveDistStates)
    Get
public:
property Dictionary<DedState^, SaveDistCommandRestrictSaveDistStates>^ DataStateSaveRestrictions {
    Dictionary<DedState^, SaveDistCommandRestrictSaveDistStates>^ get ();
}
member DataStateSaveRestrictions : Dictionary<DedState, SaveDistCommandRestrictSaveDistStates> with get

Valore della proprietà

Dictionary DedState, SaveDistCommandRestrictSaveDistStates
Vedi anche

Documentazione

Classe SaveDistCommand
Namespace DedNet.Commands


Proprietà SaveDistCommand.DistManager

Proprietà SaveDistCommandDistManager
Restituisce il DistManager utilizzato dal comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DistManager DistManager { get; }
Public ReadOnly Property DistManager As DistManager
    Get
public:
property DistManager^ DistManager {
    DistManager^ get ();
}
member DistManager : DistManager with get

Valore della proprietà

DistManager
Vedi anche

Documentazione

Classe SaveDistCommand
Namespace DedNet.Commands


Proprietà SaveDistCommand.ElemType

Proprietà SaveDistCommandElemType
Restituisce o imposta il tipo di elemento in salvataggio (CAD di default).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItemManEnum ElemType { get; set; }
Public Property ElemType As BomItemManEnum
    Get
    Set
public:
property BomItemManEnum ElemType {
    BomItemManEnum get ();
    void set (BomItemManEnum value);
}
member ElemType : BomItemManEnum with get, set

Valore della proprietà

BomItemManEnum
Vedi anche

Documentazione

Classe SaveDistCommand
Namespace DedNet.Commands


Proprietà SaveDistCommand.IgnoreDataState

Proprietà SaveDistCommandIgnoreDataState
Indica se nel lock dell'header in salvataggio deve ignorare lo stato dell'anagrafica. Di default è false

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IgnoreDataState { get; set; }
Public Property IgnoreDataState As Boolean
    Get
    Set
public:
property bool IgnoreDataState {
    bool get ();
    void set (bool value);
}
member IgnoreDataState : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SaveDistCommand
Namespace DedNet.Commands


Proprietà SaveDistCommand.LazyMode

Proprietà SaveDistCommandLazyMode
Restituisce o imposta se ignorare i nodi sui quali non è possibile risalire o creare una anagrafica. Se attivo il salvataggio continua senza sollevare eccezioni. (Default = false)

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool LazyMode { get; set; }
Public Property LazyMode As Boolean
    Get
    Set
public:
property bool LazyMode {
    bool get ();
    void set (bool value);
}
member LazyMode : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SaveDistCommand
Namespace DedNet.Commands


Proprietà SaveDistCommand.MultiLevel

Proprietà SaveDistCommandMultiLevel
Restituisce o imposta se effettuare il salvataggio della distinta multilivello. Di default è inizializzata con la variabile SalvaDistMultiLiv (che di default è true) e viene salvata la distinta multilivello.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool MultiLevel { get; set; }
Public Property MultiLevel As Boolean
    Get
    Set
public:
property bool MultiLevel {
    bool get ();
    void set (bool value);
}
member MultiLevel : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SaveDistCommand
Namespace DedNet.Commands


Proprietà SaveDistCommand.NeedParameters

Proprietà SaveDistCommandNeedParameters
Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve essere impostata la struttura di salvataggio distinta.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SaveDistCommand
Namespace DedNet.Commands


Proprietà SaveDistCommand.RootElement

Proprietà SaveDistCommandRootElement
Restitusice o imposta l'elemento root della struttura in salvataggio. Questo elemento deve necessariamente essere presente nel Database. Se non ha figli la sua distinta viene cancellata.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public SaveDistCommandSavingDistElement RootElement { get; set; }
Public Property RootElement As SaveDistCommandSavingDistElement
    Get
    Set
public:
property SaveDistCommandSavingDistElement^ RootElement {
    SaveDistCommandSavingDistElement^ get ();
    void set (SaveDistCommandSavingDistElement^ value);
}
member RootElement : SaveDistCommandSavingDistElement with get, set

Valore della proprietà

SaveDistCommandSavingDistElement
Vedi anche

Documentazione

Classe SaveDistCommand
Namespace DedNet.Commands


Metodi di SaveDistCommand

Il tipo SaveDistCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Esegue la pulizia del comando. Azzera tutte le variabili. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). Restituisce sempre false perché non è direttamente chiamato dall'utente. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
 | GetRestrictSaveDistState | Dato il valore in stringa ritorna il tipo associato
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Restituisce sempre false perché non è direttamente chiamato dall'utente. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe SaveDistCommand
Namespace DedNet.Commands


Metodo SaveDistCommand.ClearCommand

Metodo SaveDistCommandClearCommand
Esegue la pulizia del comando. Azzera tutte le variabili.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe SaveDistCommand
Namespace DedNet.Commands


Metodo SaveDistCommand.Enabled

Metodo SaveDistCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). Restituisce sempre false perché non è direttamente chiamato dall'utente.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext commandContext
)
Public Overrides Function Enabled (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ commandContext
) override
abstract Enabled :
        commandContext : DedCommandContext -> bool
override Enabled :
        commandContext : DedCommandContext -> bool

Parametri

commandContext DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe SaveDistCommand
Namespace DedNet.Commands


Metodo SaveDistCommand.ExecuteCommand

Metodo SaveDistCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe SaveDistCommand
Namespace DedNet.Commands


Metodo SaveDistCommand.GetRestrictSaveDistState

Metodo SaveDistCommandGetRestrictSaveDistState
Dato il valore in stringa ritorna il tipo associato

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static SaveDistCommandRestrictSaveDistStates GetRestrictSaveDistState(
    string descriptor
)
Public Shared Function GetRestrictSaveDistState (
    descriptor As String
) As SaveDistCommandRestrictSaveDistStates
public:
static SaveDistCommandRestrictSaveDistStates GetRestrictSaveDistState(
    String^ descriptor
)
static member GetRestrictSaveDistState :
        descriptor : string -> SaveDistCommandRestrictSaveDistStates

Parametri

descriptor String

Valore di ritorno

SaveDistCommandRestrictSaveDistStates
Vedi anche

Documentazione

Classe SaveDistCommand
Namespace DedNet.Commands


Metodo SaveDistCommand.SetContext

Metodo SaveDistCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Restituisce sempre false perché non è direttamente chiamato dall'utente.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext commandContext
)
Public Overrides Function SetContext (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ commandContext
) override
abstract SetContext :
        commandContext : DedCommandContext -> bool
override SetContext :
        commandContext : DedCommandContext -> bool

Parametri

commandContext DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe SaveDistCommand
Namespace DedNet.Commands


Enumerazione SaveDistCommand.RestrictSaveDistStates

Enumerazione SaveDistCommandRestrictSaveDistStates
Possibili stati di restrizione salvataggio in base allo stato anagrafico

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum RestrictSaveDistStates
Public Enumeration RestrictSaveDistStates
public enum class RestrictSaveDistStates
type RestrictSaveDistStates
Membri
Nome | Valore | Descrizione
Consenti | 0 |
Salta | 1 |
Blocca | 2 |
Vedi anche

Documentazione

Namespace DedNet.Commands


Classe SaveDistCommand.SavingDistElement

Classe SaveDistCommandSavingDistElement
Oggetto descrittivo del singolo elemento in salvataggio. Contiene il riferimento agli oggetti figli. E' del tutto simile all'oggetto BomItem solo lascia più libertà d'azione per elaborare l'albero di distinta. Se l'elemento in salvataggio è solo e non ha figli la distinta viene svuotata (chiedendo conferma all'utente), questo però vale solo per l'elemento di testa.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsSaveDistCommandSavingDistElement

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class SavingDistElement
Public Class SavingDistElement
public ref class SavingDistElement
type SavingDistElement = class end

Il tipo SaveDistCommandSavingDistElement espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application |
Proprietà pubblica | Data |
Proprietà pubblica | Descrizione | Restituisce o imposta la descrizione dell'elemento (come il nome della parte).
Proprietà pubblica | DistAttrs |
Proprietà pubblica | IsMainElement |
Proprietà pubblica | Items |
Proprietà pubblica | ObjInfo |
Proprietà pubblica | Parent |
Torna su
Metodi
 | Nome | Descrizione
 | CreateMainSavingDistElement |
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di SavingDistElement

Il tipo SaveDistCommandSavingDistElement espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application |
Proprietà pubblica | Data |
Proprietà pubblica | Descrizione | Restituisce o imposta la descrizione dell'elemento (come il nome della parte).
Proprietà pubblica | DistAttrs |
Proprietà pubblica | IsMainElement |
Proprietà pubblica | Items |
Proprietà pubblica | ObjInfo |
Proprietà pubblica | Parent |
Torna su
Vedi anche

Documentazione

Classe SaveDistCommandSavingDistElement
Namespace DedNet.Commands


Proprietà SaveDistCommand.SavingDistElement.Application

Proprietà SaveDistCommandSavingDistElementApplication

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedNetApplication Application { get; }
Public ReadOnly Property Application As DedNetApplication
    Get
public:
property DedNetApplication^ Application {
    DedNetApplication^ get ();
}
member Application : DedNetApplication with get

Valore della proprietà

DedNetApplication
Vedi anche

Documentazione

Classe SaveDistCommandSavingDistElement
Namespace DedNet.Commands


Proprietà SaveDistCommand.SavingDistElement.Data

Proprietà SaveDistCommandSavingDistElementData

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public IDedData Data { get; set; }
Public Property Data As IDedData
    Get
    Set
public:
property IDedData^ Data {
    IDedData^ get ();
    void set (IDedData^ value);
}
member Data : IDedData with get, set

Valore della proprietà

IDedData
Vedi anche

Documentazione

Classe SaveDistCommandSavingDistElement
Namespace DedNet.Commands


Proprietà SaveDistCommand.SavingDistElement.Descrizione

Proprietà SaveDistCommandSavingDistElementDescrizione
Restituisce o imposta la descrizione dell'elemento (come il nome della parte).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Descrizione { get; set; }
Public Property Descrizione As String
    Get
    Set
public:
property String^ Descrizione {
    String^ get ();
    void set (String^ value);
}
member Descrizione : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe SaveDistCommandSavingDistElement
Namespace DedNet.Commands


Proprietà SaveDistCommand.SavingDistElement.DistAttrs

Proprietà SaveDistCommandSavingDistElementDistAttrs

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<string, Object> DistAttrs { get; set; }
Public Property DistAttrs As Dictionary(Of String, Object)
    Get
    Set
public:
property Dictionary<String^, Object^>^ DistAttrs {
    Dictionary<String^, Object^>^ get ();
    void set (Dictionary<String^, Object^>^ value);
}
member DistAttrs : Dictionary<string, Object> with get, set

Valore della proprietà

Dictionary String, Object
Vedi anche

Documentazione

Classe SaveDistCommandSavingDistElement
Namespace DedNet.Commands


Proprietà SaveDistCommand.SavingDistElement.IsMainElement

Proprietà SaveDistCommandSavingDistElementIsMainElement

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsMainElement { get; }
Public ReadOnly Property IsMainElement As Boolean
    Get
public:
property bool IsMainElement {
    bool get ();
}
member IsMainElement : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SaveDistCommandSavingDistElement
Namespace DedNet.Commands


Proprietà SaveDistCommand.SavingDistElement.Items

Proprietà SaveDistCommandSavingDistElementItems

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public SaveDistCommandSavingDistElementCollection Items { get; }
Public ReadOnly Property Items As SaveDistCommandSavingDistElementCollection
    Get
public:
property SaveDistCommandSavingDistElementCollection^ Items {
    SaveDistCommandSavingDistElementCollection^ get ();
}
member Items : SaveDistCommandSavingDistElementCollection with get

Valore della proprietà

SaveDistCommandSavingDistElementCollection
Vedi anche

Documentazione

Classe SaveDistCommandSavingDistElement
Namespace DedNet.Commands


Proprietà SaveDistCommand.SavingDistElement.ObjInfo

Proprietà SaveDistCommandSavingDistElementObjInfo

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object ObjInfo { get; set; }
Public Property ObjInfo As Object
    Get
    Set
public:
property Object^ ObjInfo {
    Object^ get ();
    void set (Object^ value);
}
member ObjInfo : Object with get, set

Valore della proprietà

Object
Vedi anche

Documentazione

Classe SaveDistCommandSavingDistElement
Namespace DedNet.Commands


Proprietà SaveDistCommand.SavingDistElement.Parent

Proprietà SaveDistCommandSavingDistElementParent

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public SaveDistCommandSavingDistElement Parent { get; }
Public ReadOnly Property Parent As SaveDistCommandSavingDistElement
    Get
public:
property SaveDistCommandSavingDistElement^ Parent {
    SaveDistCommandSavingDistElement^ get ();
}
member Parent : SaveDistCommandSavingDistElement with get

Valore della proprietà

SaveDistCommandSavingDistElement
Vedi anche

Documentazione

Classe SaveDistCommandSavingDistElement
Namespace DedNet.Commands


Metodi di SavingDistElement

Il tipo SaveDistCommandSavingDistElement espone i seguenti membri.

Metodi
 | Nome | Descrizione
 | CreateMainSavingDistElement |
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Torna su
Vedi anche

Documentazione

Classe SaveDistCommandSavingDistElement
Namespace DedNet.Commands


Metodo SaveDistCommand.SavingDistElement.CreateMainSavingDistElement

Metodo SaveDistCommandSavingDistElementCreateMainSavingDistElement

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static SaveDistCommandSavingDistElement CreateMainSavingDistElement(
    DedNetApplication app,
    IDedData data
)
Public Shared Function CreateMainSavingDistElement (
    app As DedNetApplication,
    data As IDedData
) As SaveDistCommandSavingDistElement
public:
static SaveDistCommandSavingDistElement^ CreateMainSavingDistElement(
    DedNetApplication^ app,
    IDedData^ data
)
static member CreateMainSavingDistElement :
        app : DedNetApplication *
        data : IDedData -> SaveDistCommandSavingDistElement

Parametri

app DedNetApplication
data IDedData

Valore di ritorno

SaveDistCommandSavingDistElement
Vedi anche

Documentazione

Classe SaveDistCommandSavingDistElement
Namespace DedNet.Commands


Metodo SaveDistCommand.SavingDistElement.ToString

Metodo SaveDistCommandSavingDistElementToString

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe SaveDistCommandSavingDistElement
Namespace DedNet.Commands


Classe SaveDistCommand.SavingDistElementCollection

Classe SaveDistCommandSavingDistElementCollection
Collezione elementi di distinta in salvataggio
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsSaveDistCommandSavingDistElementCollection

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class SavingDistElementCollection : IEnumerable<SaveDistCommandSavingDistElement>,
    IEnumerable
Public Class SavingDistElementCollection
    Implements IEnumerable(Of SaveDistCommandSavingDistElement), IEnumerable
public ref class SavingDistElementCollection : IEnumerable<SaveDistCommandSavingDistElement^>,
    IEnumerable
type SavingDistElementCollection =
    class
        interface IEnumerable<SaveDistCommandSavingDistElement>
        interface IEnumerable
    end

Il tipo SaveDistCommandSavingDistElementCollection espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Count |
Proprietà pubblica | Item |
Proprietà pubblica | Owner |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Add |
Metodo pubblico | Clear |
Metodo pubblico | Contains |
Metodo pubblico | CopyTo |
Metodo pubblico | GetEnumerator |
Metodo pubblico | IndexOf |
Metodo pubblico | Insert |
Metodo pubblico | Remove |
Metodo pubblico | RemoveAt |
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | IEnumerableGetEnumerator |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di SavingDistElementCollection

Il tipo SaveDistCommandSavingDistElementCollection espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Count |
Proprietà pubblica | Item |
Proprietà pubblica | Owner |
Torna su
Vedi anche

Documentazione

Classe SaveDistCommandSavingDistElementCollection
Namespace DedNet.Commands


Proprietà SaveDistCommand.SavingDistElementCollection.Count

Proprietà SaveDistCommandSavingDistElementCollectionCount

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
public:
property int Count {
    int get ();
}
member Count : int with get

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe SaveDistCommandSavingDistElementCollection
Namespace DedNet.Commands


Proprietà SaveDistCommand.SavingDistElementCollection.Item

Proprietà SaveDistCommandSavingDistElementCollectionItem

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public SaveDistCommandSavingDistElement this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As SaveDistCommandSavingDistElement
    Get
    Set
public:
property SaveDistCommandSavingDistElement^ default[int index] {
    SaveDistCommandSavingDistElement^ get (int index);
    void set (int index, SaveDistCommandSavingDistElement^ value);
}
member Item : SaveDistCommandSavingDistElement with get, set

Parametri

index Int32

Valore della proprietà

SaveDistCommandSavingDistElement
Vedi anche

Documentazione

Classe SaveDistCommandSavingDistElementCollection
Namespace DedNet.Commands


Proprietà SaveDistCommand.SavingDistElementCollection.Owner

Proprietà SaveDistCommandSavingDistElementCollectionOwner

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public SaveDistCommandSavingDistElement Owner { get; }
Public ReadOnly Property Owner As SaveDistCommandSavingDistElement
    Get
public:
property SaveDistCommandSavingDistElement^ Owner {
    SaveDistCommandSavingDistElement^ get ();
}
member Owner : SaveDistCommandSavingDistElement with get

Valore della proprietà

SaveDistCommandSavingDistElement
Vedi anche

Documentazione

Classe SaveDistCommandSavingDistElementCollection
Namespace DedNet.Commands


Metodi di SavingDistElementCollection

Il tipo SaveDistCommandSavingDistElementCollection espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Add |
Metodo pubblico | Clear |
Metodo pubblico | Contains |
Metodo pubblico | CopyTo |
Metodo pubblico | GetEnumerator |
Metodo pubblico | IndexOf |
Metodo pubblico | Insert |
Metodo pubblico | Remove |
Metodo pubblico | RemoveAt |
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | IEnumerableGetEnumerator |
Torna su
Vedi anche

Documentazione

Classe SaveDistCommandSavingDistElementCollection
Namespace DedNet.Commands


Metodo SaveDistCommand.SavingDistElementCollection.Add

Metodo SaveDistCommandSavingDistElementCollectionAdd

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public SaveDistCommandSavingDistElement Add(
    IDedData data
)
Public Function Add (
    data As IDedData
) As SaveDistCommandSavingDistElement
public:
SaveDistCommandSavingDistElement^ Add(
    IDedData^ data
)
member Add :
        data : IDedData -> SaveDistCommandSavingDistElement

Parametri

data IDedData

Valore di ritorno

SaveDistCommandSavingDistElement
Vedi anche

Documentazione

Classe SaveDistCommandSavingDistElementCollection
Namespace DedNet.Commands


Metodo SaveDistCommand.SavingDistElementCollection.Clear

Metodo SaveDistCommandSavingDistElementCollectionClear

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
Vedi anche

Documentazione

Classe SaveDistCommandSavingDistElementCollection
Namespace DedNet.Commands


Metodo SaveDistCommand.SavingDistElementCollection.Contains

Metodo SaveDistCommandSavingDistElementCollectionContains

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Contains(
    SaveDistCommandSavingDistElement item
)
Public Function Contains (
    item As SaveDistCommandSavingDistElement
) As Boolean
public:
bool Contains(
    SaveDistCommandSavingDistElement^ item
)
member Contains :
        item : SaveDistCommandSavingDistElement -> bool

Parametri

item SaveDistCommandSavingDistElement

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe SaveDistCommandSavingDistElementCollection
Namespace DedNet.Commands


Metodo SaveDistCommand.SavingDistElementCollection.CopyTo

Metodo SaveDistCommandSavingDistElementCollectionCopyTo

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void CopyTo(
    SaveDistCommandSavingDistElement[] array,
    int arrayIndex
)
Public Sub CopyTo (
    array As SaveDistCommandSavingDistElement(),
    arrayIndex As Integer
)
public:
void CopyTo(
    array<SaveDistCommandSavingDistElement^>^ array,
    int arrayIndex
)
member CopyTo :
        array : SaveDistCommandSavingDistElement[] *
        arrayIndex : int -> unit

Parametri

array SaveDistCommandSavingDistElement
arrayIndex Int32
Vedi anche

Documentazione

Classe SaveDistCommandSavingDistElementCollection
Namespace DedNet.Commands


Metodo SaveDistCommand.SavingDistElementCollection.GetEnumerator

Metodo SaveDistCommandSavingDistElementCollectionGetEnumerator

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public IEnumerator<SaveDistCommandSavingDistElement> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of SaveDistCommandSavingDistElement)
public:
virtual IEnumerator<SaveDistCommandSavingDistElement^>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<SaveDistCommandSavingDistElement>
override GetEnumerator : unit -> IEnumerator<SaveDistCommandSavingDistElement>

Valore di ritorno

IEnumerator SaveDistCommandSavingDistElement

Implementa

IEnumerableTGetEnumerator
Vedi anche

Documentazione

Classe SaveDistCommandSavingDistElementCollection
Namespace DedNet.Commands


Metodo SaveDistCommand.SavingDistElementCollection.IEnumerable.GetEnumerator

Metodo SaveDistCommandSavingDistElementCollectionIEnumerableGetEnumerator

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
IEnumerator IEnumerable.GetEnumerator()
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator

Valore di ritorno

IEnumerator

Implementa

IEnumerableGetEnumerator
Vedi anche

Documentazione

Classe SaveDistCommandSavingDistElementCollection
Namespace DedNet.Commands


Metodo SaveDistCommand.SavingDistElementCollection.IndexOf

Metodo SaveDistCommandSavingDistElementCollectionIndexOf

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int IndexOf(
    SaveDistCommandSavingDistElement item
)
Public Function IndexOf (
    item As SaveDistCommandSavingDistElement
) As Integer
public:
int IndexOf(
    SaveDistCommandSavingDistElement^ item
)
member IndexOf :
        item : SaveDistCommandSavingDistElement -> int

Parametri

item SaveDistCommandSavingDistElement

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe SaveDistCommandSavingDistElementCollection
Namespace DedNet.Commands


Metodo SaveDistCommand.SavingDistElementCollection.Insert

Metodo SaveDistCommandSavingDistElementCollectionInsert

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public SaveDistCommandSavingDistElement Insert(
    int index,
    IDedData data
)
Public Function Insert (
    index As Integer,
    data As IDedData
) As SaveDistCommandSavingDistElement
public:
SaveDistCommandSavingDistElement^ Insert(
    int index,
    IDedData^ data
)
member Insert :
        index : int *
        data : IDedData -> SaveDistCommandSavingDistElement

Parametri

index Int32
data IDedData

Valore di ritorno

SaveDistCommandSavingDistElement
Vedi anche

Documentazione

Classe SaveDistCommandSavingDistElementCollection
Namespace DedNet.Commands


Metodo SaveDistCommand.SavingDistElementCollection.Remove

Metodo SaveDistCommandSavingDistElementCollectionRemove

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Remove(
    SaveDistCommandSavingDistElement item
)
Public Function Remove (
    item As SaveDistCommandSavingDistElement
) As Boolean
public:
bool Remove(
    SaveDistCommandSavingDistElement^ item
)
member Remove :
        item : SaveDistCommandSavingDistElement -> bool

Parametri

item SaveDistCommandSavingDistElement

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe SaveDistCommandSavingDistElementCollection
Namespace DedNet.Commands


Metodo SaveDistCommand.SavingDistElementCollection.RemoveAt

Metodo SaveDistCommandSavingDistElementCollectionRemoveAt

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void RemoveAt(
    int index
)
Public Sub RemoveAt (
    index As Integer
)
public:
void RemoveAt(
    int index
)
member RemoveAt :
        index : int -> unit

Parametri

index Int32
Vedi anche

Documentazione

Classe SaveDistCommandSavingDistElementCollection
Namespace DedNet.Commands


Classe SaveDistVariantCommand
Comando che implementa la creazione della distinta di produzione. La funzionalità è nativamente multilivello. Il nuovo discriminante di distinta viene applicato a tutta la struttura
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsSaveDistVariantCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class SaveDistVariantCommand : DedCommand
Public Class SaveDistVariantCommand
    Inherits DedCommand
public ref class SaveDistVariantCommand : public DedCommand
type SaveDistVariantCommand =
    class
        inherit DedCommand
    end

Il tipo SaveDistVariantCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DistManager | Restituisce il DistManager utilizzato dal comando.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | MultiLevel | Restituisce o imposta se effettuare la clonazione della distinta in modalità multilivello. Di default è inizializzata a true.
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve essere impostata la struttura di salvataggio distinta. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OverwriteSubHeaders | Indica se è necessario sovrascrivere gli header figli se sono già stati definiti col discriminante di destinazione.
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | SavingDiscrimDist | Discriminante di distinta col quale verrà creata la nuova produzione
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | StartingData | Restitusice o imposta l'anagrafica la cui distinta deve essere clonata come produzione
Proprietà pubblica | StartingDiscrimDist | Discriminante di distinta di partenza
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Esegue la pulizia del comando. Azzera tutte le variabili. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). Restituisce sempre false perché non è direttamente chiamato dall'utente. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Restituisce sempre false perché non è direttamente chiamato dall'utente. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di SaveDistVariantCommand

Il tipo SaveDistVariantCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DistManager | Restituisce il DistManager utilizzato dal comando.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | MultiLevel | Restituisce o imposta se effettuare la clonazione della distinta in modalità multilivello. Di default è inizializzata a true.
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve essere impostata la struttura di salvataggio distinta. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OverwriteSubHeaders | Indica se è necessario sovrascrivere gli header figli se sono già stati definiti col discriminante di destinazione.
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | SavingDiscrimDist | Discriminante di distinta col quale verrà creata la nuova produzione
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | StartingData | Restitusice o imposta l'anagrafica la cui distinta deve essere clonata come produzione
Proprietà pubblica | StartingDiscrimDist | Discriminante di distinta di partenza
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe SaveDistVariantCommand
Namespace DedNet.Commands


Proprietà SaveDistVariantCommand.DistManager

Proprietà SaveDistVariantCommandDistManager
Restituisce il DistManager utilizzato dal comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DistManager DistManager { get; }
Public ReadOnly Property DistManager As DistManager
    Get
public:
property DistManager^ DistManager {
    DistManager^ get ();
}
member DistManager : DistManager with get

Valore della proprietà

DistManager
Vedi anche

Documentazione

Classe SaveDistVariantCommand
Namespace DedNet.Commands


Proprietà SaveDistVariantCommand.MultiLevel

Proprietà SaveDistVariantCommandMultiLevel
Restituisce o imposta se effettuare la clonazione della distinta in modalità multilivello. Di default è inizializzata a true.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool MultiLevel { get; set; }
Public Property MultiLevel As Boolean
    Get
    Set
public:
property bool MultiLevel {
    bool get ();
    void set (bool value);
}
member MultiLevel : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SaveDistVariantCommand
Namespace DedNet.Commands


Proprietà SaveDistVariantCommand.NeedParameters

Proprietà SaveDistVariantCommandNeedParameters
Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve essere impostata la struttura di salvataggio distinta.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SaveDistVariantCommand
Namespace DedNet.Commands


Proprietà SaveDistVariantCommand.OverwriteSubHeaders

Proprietà SaveDistVariantCommandOverwriteSubHeaders
Indica se è necessario sovrascrivere gli header figli se sono già stati definiti col discriminante di destinazione.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool OverwriteSubHeaders { get; set; }
Public Property OverwriteSubHeaders As Boolean
    Get
    Set
public:
property bool OverwriteSubHeaders {
    bool get ();
    void set (bool value);
}
member OverwriteSubHeaders : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SaveDistVariantCommand
Namespace DedNet.Commands


Proprietà SaveDistVariantCommand.SavingDiscrimDist

Proprietà SaveDistVariantCommandSavingDiscrimDist
Discriminante di distinta col quale verrà creata la nuova produzione

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string SavingDiscrimDist { get; set; }
Public Property SavingDiscrimDist As String
    Get
    Set
public:
property String^ SavingDiscrimDist {
    String^ get ();
    void set (String^ value);
}
member SavingDiscrimDist : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe SaveDistVariantCommand
Namespace DedNet.Commands


Proprietà SaveDistVariantCommand.StartingData

Proprietà SaveDistVariantCommandStartingData
Restitusice o imposta l'anagrafica la cui distinta deve essere clonata come produzione

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData StartingData { get; set; }
Public Property StartingData As DedData
    Get
    Set
public:
property DedData^ StartingData {
    DedData^ get ();
    void set (DedData^ value);
}
member StartingData : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe SaveDistVariantCommand
Namespace DedNet.Commands


Proprietà SaveDistVariantCommand.StartingDiscrimDist

Proprietà SaveDistVariantCommandStartingDiscrimDist
Discriminante di distinta di partenza

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string StartingDiscrimDist { get; set; }
Public Property StartingDiscrimDist As String
    Get
    Set
public:
property String^ StartingDiscrimDist {
    String^ get ();
    void set (String^ value);
}
member StartingDiscrimDist : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe SaveDistVariantCommand
Namespace DedNet.Commands


Metodi di SaveDistVariantCommand

Il tipo SaveDistVariantCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Esegue la pulizia del comando. Azzera tutte le variabili. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). Restituisce sempre false perché non è direttamente chiamato dall'utente. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Restituisce sempre false perché non è direttamente chiamato dall'utente. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe SaveDistVariantCommand
Namespace DedNet.Commands


Metodo SaveDistVariantCommand.ClearCommand

Metodo SaveDistVariantCommandClearCommand
Esegue la pulizia del comando. Azzera tutte le variabili.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe SaveDistVariantCommand
Namespace DedNet.Commands


Metodo SaveDistVariantCommand.Enabled

Metodo SaveDistVariantCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). Restituisce sempre false perché non è direttamente chiamato dall'utente.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext commandContext
)
Public Overrides Function Enabled (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ commandContext
) override
abstract Enabled :
        commandContext : DedCommandContext -> bool
override Enabled :
        commandContext : DedCommandContext -> bool

Parametri

commandContext DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe SaveDistVariantCommand
Namespace DedNet.Commands


Metodo SaveDistVariantCommand.ExecuteCommand

Metodo SaveDistVariantCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe SaveDistVariantCommand
Namespace DedNet.Commands


Metodo SaveDistVariantCommand.SetContext

Metodo SaveDistVariantCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Restituisce sempre false perché non è direttamente chiamato dall'utente.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext commandContext
)
Public Overrides Function SetContext (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ commandContext
) override
abstract SetContext :
        commandContext : DedCommandContext -> bool
override SetContext :
        commandContext : DedCommandContext -> bool

Parametri

commandContext DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe SaveDistVariantCommand
Namespace DedNet.Commands


Classe SaveSparePartsDistVariantCommand
Comando che crea la distinta MONOLIVELLO e MULTILIVELLO dei ricambio.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsSaveSparePartsDistVariantCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class SaveSparePartsDistVariantCommand : DedCommand
Public Class SaveSparePartsDistVariantCommand
    Inherits DedCommand
public ref class SaveSparePartsDistVariantCommand : public DedCommand
type SaveSparePartsDistVariantCommand =
    class
        inherit DedCommand
    end

Il tipo SaveSparePartsDistVariantCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreDataState | Indica se nel lock dell'header in salvataggio deve ignorare lo stato dell'anagrafica. Di default è false
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve essere impostata la struttura di salvataggio distinta. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Recursive | Indica se l'aggiornamento deve propagarsi anche per le distinte figlie. Di default è true;
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | StartingData | Restitusice o imposta l'anagrafica la cui distinta deve essere clonata come produzione
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Esegue la pulizia del comando. Azzera tutte le variabili. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). Restituisce sempre false perché non è direttamente chiamato dall'utente. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Restituisce sempre false perché non è direttamente chiamato dall'utente. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di SaveSparePartsDistVariantCommand

Il tipo SaveSparePartsDistVariantCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreDataState | Indica se nel lock dell'header in salvataggio deve ignorare lo stato dell'anagrafica. Di default è false
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve essere impostata la struttura di salvataggio distinta. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Recursive | Indica se l'aggiornamento deve propagarsi anche per le distinte figlie. Di default è true;
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | StartingData | Restitusice o imposta l'anagrafica la cui distinta deve essere clonata come produzione
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe SaveSparePartsDistVariantCommand
Namespace DedNet.Commands


Proprietà SaveSparePartsDistVariantCommand.IgnoreDataState

Proprietà SaveSparePartsDistVariantCommandIgnoreDataState
Indica se nel lock dell'header in salvataggio deve ignorare lo stato dell'anagrafica. Di default è false

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IgnoreDataState { get; set; }
Public Property IgnoreDataState As Boolean
    Get
    Set
public:
property bool IgnoreDataState {
    bool get ();
    void set (bool value);
}
member IgnoreDataState : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SaveSparePartsDistVariantCommand
Namespace DedNet.Commands


Proprietà SaveSparePartsDistVariantCommand.NeedParameters

Proprietà SaveSparePartsDistVariantCommandNeedParameters
Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve essere impostata la struttura di salvataggio distinta.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SaveSparePartsDistVariantCommand
Namespace DedNet.Commands


Proprietà SaveSparePartsDistVariantCommand.Recursive

Proprietà SaveSparePartsDistVariantCommandRecursive
Indica se l'aggiornamento deve propagarsi anche per le distinte figlie. Di default è true;

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Recursive { get; set; }
Public Property Recursive As Boolean
    Get
    Set
public:
property bool Recursive {
    bool get ();
    void set (bool value);
}
member Recursive : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SaveSparePartsDistVariantCommand
Namespace DedNet.Commands


Proprietà SaveSparePartsDistVariantCommand.StartingData

Proprietà SaveSparePartsDistVariantCommandStartingData
Restitusice o imposta l'anagrafica la cui distinta deve essere clonata come produzione

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData StartingData { get; set; }
Public Property StartingData As DedData
    Get
    Set
public:
property DedData^ StartingData {
    DedData^ get ();
    void set (DedData^ value);
}
member StartingData : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe SaveSparePartsDistVariantCommand
Namespace DedNet.Commands


Metodi di SaveSparePartsDistVariantCommand

Il tipo SaveSparePartsDistVariantCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Esegue la pulizia del comando. Azzera tutte le variabili. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). Restituisce sempre false perché non è direttamente chiamato dall'utente. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Restituisce sempre false perché non è direttamente chiamato dall'utente. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe SaveSparePartsDistVariantCommand
Namespace DedNet.Commands


Metodo SaveSparePartsDistVariantCommand.ClearCommand

Metodo SaveSparePartsDistVariantCommandClearCommand
Esegue la pulizia del comando. Azzera tutte le variabili.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe SaveSparePartsDistVariantCommand
Namespace DedNet.Commands


Metodo SaveSparePartsDistVariantCommand.Enabled

Metodo SaveSparePartsDistVariantCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). Restituisce sempre false perché non è direttamente chiamato dall'utente.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext commandContext
)
Public Overrides Function Enabled (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ commandContext
) override
abstract Enabled :
        commandContext : DedCommandContext -> bool
override Enabled :
        commandContext : DedCommandContext -> bool

Parametri

commandContext DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe SaveSparePartsDistVariantCommand
Namespace DedNet.Commands


Metodo SaveSparePartsDistVariantCommand.ExecuteCommand

Metodo SaveSparePartsDistVariantCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe SaveSparePartsDistVariantCommand
Namespace DedNet.Commands


Metodo SaveSparePartsDistVariantCommand.SetContext

Metodo SaveSparePartsDistVariantCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Restituisce sempre false perché non è direttamente chiamato dall'utente.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext commandContext
)
Public Overrides Function SetContext (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ commandContext
) override
abstract SetContext :
        commandContext : DedCommandContext -> bool
override SetContext :
        commandContext : DedCommandContext -> bool

Parametri

commandContext DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe SaveSparePartsDistVariantCommand
Namespace DedNet.Commands


Classe SbloccaDocument
Permette di sbloccare una lista di documenti senza effettuarne la pubblicazione sul server. Vengono mantenuti gli effetti delle precedenti eventuali pubblicazioni ma viene eliminato il backup effettuato durante il check-out.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsSbloccaDocument

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class SbloccaDocument : DedCommand
Public Class SbloccaDocument
    Inherits DedCommand
public ref class SbloccaDocument : public DedCommand
type SbloccaDocument =
    class
        inherit DedCommand
    end

Il tipo SbloccaDocument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | AskEraseFromPws | Restituisce o imposta se chiedere all'utente di eliminare o meno il documento dall'area locale una volta sbloccato (di default è true).
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | EraseFromPws | Restituisce o imposta se cancellare i documenti dalla pws dopo il comando (di default è false).
Proprietà pubblica | FileList | Restituisce la lista dei documenti da sbloccare. Inserire in questa lista solo i file che si desidera elaborare e non le dipendenze.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non sono presenti documenti da elaborare. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di SbloccaDocument

Il tipo SbloccaDocument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | AskEraseFromPws | Restituisce o imposta se chiedere all'utente di eliminare o meno il documento dall'area locale una volta sbloccato (di default è true).
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | EraseFromPws | Restituisce o imposta se cancellare i documenti dalla pws dopo il comando (di default è false).
Proprietà pubblica | FileList | Restituisce la lista dei documenti da sbloccare. Inserire in questa lista solo i file che si desidera elaborare e non le dipendenze.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non sono presenti documenti da elaborare. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe SbloccaDocument
Namespace DedNet.Commands


Proprietà SbloccaDocument.AskEraseFromPws

Proprietà SbloccaDocumentAskEraseFromPws
Restituisce o imposta se chiedere all'utente di eliminare o meno il documento dall'area locale una volta sbloccato (di default è true).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AskEraseFromPws { get; set; }
Public Property AskEraseFromPws As Boolean
    Get
    Set
public:
property bool AskEraseFromPws {
    bool get ();
    void set (bool value);
}
member AskEraseFromPws : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SbloccaDocument
Namespace DedNet.Commands


Proprietà SbloccaDocument.EraseFromPws

Proprietà SbloccaDocumentEraseFromPws
Restituisce o imposta se cancellare i documenti dalla pws dopo il comando (di default è false).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool EraseFromPws { get; set; }
Public Property EraseFromPws As Boolean
    Get
    Set
public:
property bool EraseFromPws {
    bool get ();
    void set (bool value);
}
member EraseFromPws : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SbloccaDocument
Namespace DedNet.Commands


Proprietà SbloccaDocument.FileList

Proprietà SbloccaDocumentFileList
Restituisce la lista dei documenti da sbloccare. Inserire in questa lista solo i file che si desidera elaborare e non le dipendenze.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfoList FileList { get; }
Public ReadOnly Property FileList As DocStructInfoList
    Get
public:
property DocStructInfoList^ FileList {
    DocStructInfoList^ get ();
}
member FileList : DocStructInfoList with get

Valore della proprietà

DocStructInfoList
Vedi anche

Documentazione

Classe SbloccaDocument
Namespace DedNet.Commands


Proprietà SbloccaDocument.NeedParameters

Proprietà SbloccaDocumentNeedParameters
Restituisce true se non sono presenti documenti da elaborare.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SbloccaDocument
Namespace DedNet.Commands


Metodi di SbloccaDocument

Il tipo SbloccaDocument espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe SbloccaDocument
Namespace DedNet.Commands


Metodo SbloccaDocument.ClearCommand

Metodo SbloccaDocumentClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe SbloccaDocument
Namespace DedNet.Commands


Metodo SbloccaDocument.Enabled

Metodo SbloccaDocumentEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe SbloccaDocument
Namespace DedNet.Commands


Metodo SbloccaDocument.ExecuteCommand

Metodo SbloccaDocumentExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe SbloccaDocument
Namespace DedNet.Commands


Metodo SbloccaDocument.SetContext

Metodo SbloccaDocumentSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto c'è una sola anagrafica alla quale associare il file.
Vedi anche

Documentazione

Classe SbloccaDocument
Namespace DedNet.Commands


Classe SendTransferPacket
Comando aggiunta richieste di traferimento
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsSendTransferPacket

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class SendTransferPacket : DedCommand
Public Class SendTransferPacket
    Inherits DedCommand
public ref class SendTransferPacket : public DedCommand
type SendTransferPacket =
    class
        inherit DedCommand
    end

Il tipo SendTransferPacket espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | SendTransferPacket | Costruttore unico
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Inidica se il comando necessita di parametri (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulizia del comando (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Abilitazione dal contesto (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esecuzione (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Settaggio del contesto (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Costruttore SendTransferPacket
Costruttore unico

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public SendTransferPacket(
    DedNetApplication app,
    string internalName,
    string name
)
Public Sub New (
    app As DedNetApplication,
    internalName As String,
    name As String
)
public:
SendTransferPacket(
    DedNetApplication^ app,
    String^ internalName,
    String^ name
)
new :
        app : DedNetApplication *
        internalName : string *
        name : string -> SendTransferPacket

Parametri

app DedNetApplication
internalName String
name String
Vedi anche

Documentazione

Classe SendTransferPacket
Namespace DedNet.Commands


Proprietà di SendTransferPacket

Il tipo SendTransferPacket espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Inidica se il comando necessita di parametri (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe SendTransferPacket
Namespace DedNet.Commands


Proprietà SendTransferPacket.NeedParameters

Proprietà SendTransferPacketNeedParameters
Inidica se il comando necessita di parametri

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SendTransferPacket
Namespace DedNet.Commands


Metodi di SendTransferPacket

Il tipo SendTransferPacket espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulizia del comando (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Abilitazione dal contesto (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esecuzione (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Settaggio del contesto (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe SendTransferPacket
Namespace DedNet.Commands


Metodo SendTransferPacket.ClearCommand

Metodo SendTransferPacketClearCommand
Pulizia del comando

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe SendTransferPacket
Namespace DedNet.Commands


Metodo SendTransferPacket.Enabled

Metodo SendTransferPacketEnabled
Abilitazione dal contesto

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext commandContext
)
Public Overrides Function Enabled (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ commandContext
) override
abstract Enabled :
        commandContext : DedCommandContext -> bool
override Enabled :
        commandContext : DedCommandContext -> bool

Parametri

commandContext DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe SendTransferPacket
Namespace DedNet.Commands


Metodo SendTransferPacket.ExecuteCommand

Metodo SendTransferPacketExecuteCommand
Esecuzione

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe SendTransferPacket
Namespace DedNet.Commands


Metodo SendTransferPacket.SetContext

Metodo SendTransferPacketSetContext
Settaggio del contesto

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext commandContext
)
Public Overrides Function SetContext (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ commandContext
) override
abstract SetContext :
        commandContext : DedCommandContext -> bool
override SetContext :
        commandContext : DedCommandContext -> bool

Parametri

commandContext DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe SendTransferPacket
Namespace DedNet.Commands


Classe SendZipViaEmail
Esegue lo zip di un insieme do documenti, crea una mail con lo zip come allegato e poi cancella lo zip una volta inviata la mail.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsDedDocumentCommand
DedNet.CommandsSendZipViaEmail

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class SendZipViaEmail : DedDocumentCommand
Public Class SendZipViaEmail
    Inherits DedDocumentCommand
public ref class SendZipViaEmail : public DedDocumentCommand
type SendZipViaEmail =
    class
        inherit DedDocumentCommand
    end

Il tipo SendZipViaEmail espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DocumentInfos | Restituisce la lista dei documenti con abbinato il contesto di anagrafica di elaborazione comando. (Ereditato da DedDocumentCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce false se non esiste nemmeno un documento sul quale eseguire il comando. (Ereditato da DedDocumentCommand)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Reinizializza il comando. (Ereditato da DedDocumentCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedDocumentCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedDocumentCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedDocumentCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedDocumentCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di SendZipViaEmail

Il tipo SendZipViaEmail espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DocumentInfos | Restituisce la lista dei documenti con abbinato il contesto di anagrafica di elaborazione comando. (Ereditato da DedDocumentCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce false se non esiste nemmeno un documento sul quale eseguire il comando. (Ereditato da DedDocumentCommand)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe SendZipViaEmail
Namespace DedNet.Commands


Metodi di SendZipViaEmail

Il tipo SendZipViaEmail espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Reinizializza il comando. (Ereditato da DedDocumentCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedDocumentCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedDocumentCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedDocumentCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedDocumentCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe SendZipViaEmail
Namespace DedNet.Commands


Metodo SendZipViaEmail.Enabled

Metodo SendZipViaEmailEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe SendZipViaEmail
Namespace DedNet.Commands


Metodo SendZipViaEmail.ExecuteCommand

Metodo SendZipViaEmailExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe SendZipViaEmail
Namespace DedNet.Commands


Metodo SendZipViaEmail.SetContext

Metodo SendZipViaEmailSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe SendZipViaEmail
Namespace DedNet.Commands


Classe ShowAllActiveTimingsCommand
Comando utilizzato per visualizzare tutte le temporizzazioni attive associate all'utente corrente.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsShowAllActiveTimingsCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ShowAllActiveTimingsCommand : DedCommand
Public Class ShowAllActiveTimingsCommand
    Inherits DedCommand
public ref class ShowAllActiveTimingsCommand : public DedCommand
type ShowAllActiveTimingsCommand =
    class
        inherit DedCommand
    end

Il tipo ShowAllActiveTimingsCommand espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ShowAllActiveTimingsCommand | Crea una nuova istanza della classe 'ShowAllActiveTimingsCommand' utilizzata per visualizzare tutte le temporizzazioni attive associate all'utente corrente.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Inidica se il comando necessita di parametri. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulizia del comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Abilitazione dal contesto. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esecuzione del comando. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Settaggio del contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Costruttore ShowAllActiveTimingsCommand
Crea una nuova istanza della classe 'ShowAllActiveTimingsCommand' utilizzata per visualizzare tutte le temporizzazioni attive associate all'utente corrente.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ShowAllActiveTimingsCommand(
    DedNetApplication app,
    string internalName,
    string name
)
Public Sub New (
    app As DedNetApplication,
    internalName As String,
    name As String
)
public:
ShowAllActiveTimingsCommand(
    DedNetApplication^ app,
    String^ internalName,
    String^ name
)
new :
        app : DedNetApplication *
        internalName : string *
        name : string -> ShowAllActiveTimingsCommand

Parametri

app DedNetApplication
Applicazione DedNet.
internalName String
Nome interno del comando.
name String
Nome visualizzato del comando.
Vedi anche

Documentazione

Classe ShowAllActiveTimingsCommand
Namespace DedNet.Commands


Proprietà di ShowAllActiveTimingsCommand

Il tipo ShowAllActiveTimingsCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Inidica se il comando necessita di parametri. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ShowAllActiveTimingsCommand
Namespace DedNet.Commands


Proprietà ShowAllActiveTimingsCommand.NeedParameters

Proprietà ShowAllActiveTimingsCommandNeedParameters
Inidica se il comando necessita di parametri.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ShowAllActiveTimingsCommand
Namespace DedNet.Commands


Metodi di ShowAllActiveTimingsCommand

Il tipo ShowAllActiveTimingsCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulizia del comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Abilitazione dal contesto. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esecuzione del comando. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Settaggio del contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ShowAllActiveTimingsCommand
Namespace DedNet.Commands


Metodo ShowAllActiveTimingsCommand.ClearCommand

Metodo ShowAllActiveTimingsCommandClearCommand
Pulizia del comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe ShowAllActiveTimingsCommand
Namespace DedNet.Commands


Metodo ShowAllActiveTimingsCommand.Enabled

Metodo ShowAllActiveTimingsCommandEnabled
Abilitazione dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe ShowAllActiveTimingsCommand
Namespace DedNet.Commands


Metodo ShowAllActiveTimingsCommand.ExecuteCommand

Metodo ShowAllActiveTimingsCommandExecuteCommand
Esecuzione del comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe ShowAllActiveTimingsCommand
Namespace DedNet.Commands


Metodo ShowAllActiveTimingsCommand.SetContext

Metodo ShowAllActiveTimingsCommandSetContext
Settaggio del contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe ShowAllActiveTimingsCommand
Namespace DedNet.Commands


Classe ShowAnagrCommand
Apre la finestra di Visualizzazione delle anagrafiche.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsEditAnagrCommandBase
DedNet.CommandsShowAnagrCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ShowAnagrCommand : EditAnagrCommandBase
Public Class ShowAnagrCommand
    Inherits EditAnagrCommandBase
public ref class ShowAnagrCommand : public EditAnagrCommandBase
type ShowAnagrCommand =
    class
        inherit EditAnagrCommandBase
    end

Il tipo ShowAnagrCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | ApplyRule | Imposta / Restiruisce se aplpicare le regole. (Ereditato da EditAnagrCommandBase)
Proprietà pubblica | AttrList | Restituisce la lista che viene utilizzata dal comando. (Ereditato da EditAnagrCommandBase)
Proprietà pubblica | BtnRefreshClick | Imposta/Restituisce l'evento chiamato sul click del puldante di Refresh. (Ereditato da EditAnagrCommandBase)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DataInfos | Restituisce la lista delle anagrafiche di elaborazione comando. (Ereditato da EditAnagrCommandBase)
Proprietà pubblica | DisableEditingForOnlyDbAttrs | Indica se abilitare o meno l'editazione per gli attributi marchiati come "Solo Db". (Ereditato da EditAnagrCommandBase)
Proprietà pubblica | EnableDedContextMenu | Indica se abilitare il menu contestuale con i comandi del DED. (Ereditato da EditAnagrCommandBase)
Proprietà pubblica | FormAnagr | Restituisce il form utilizzato dal comando.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnorePerm | Indica se ignorare il controllo sui permessi. (Ereditato da EditAnagrCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | IsInDb | Restituisce o imposta se le anagrafiche siano o meno da considerarsi nel Database. (Ereditato da EditAnagrCommandBase)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | LockAnagr | Indica se effettuare il lock dell'anagrafica. Di defualt è True. (Ereditato da EditAnagrCommandBase)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Il comando necessita di almeno una IDedData nella lista. (Ereditato da EditAnagrCommandBase)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | RefreshButtonEnabled | Imposta/Restituisce se abilitare il tasto di refresh. (Ereditato da EditAnagrCommandBase)
Proprietà pubblica | RefreshButtonTooltip | Imposta/Restituisce il tooltip del tasto di refresh. (Ereditato da EditAnagrCommandBase)
Proprietà pubblica | RefreshButtonVisible | Imposta/Restituisce se visualizzare il tasto di refresh. (Ereditato da EditAnagrCommandBase)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Proprietà pubblica | ValidateAttr | Indica se validare gli attributi. (Ereditato da EditAnagrCommandBase)
Proprietà pubblica | WindowTitle | Restituisce o imposta il titolo della finestra di dialogo. (Ereditato da EditAnagrCommandBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive EditAnagrCommandBaseClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Ereditato da EditAnagrCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Ereditato da EditAnagrCommandBase)
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di ShowAnagrCommand

Il tipo ShowAnagrCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | ApplyRule | Imposta / Restiruisce se aplpicare le regole. (Ereditato da EditAnagrCommandBase)
Proprietà pubblica | AttrList | Restituisce la lista che viene utilizzata dal comando. (Ereditato da EditAnagrCommandBase)
Proprietà pubblica | BtnRefreshClick | Imposta/Restituisce l'evento chiamato sul click del puldante di Refresh. (Ereditato da EditAnagrCommandBase)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DataInfos | Restituisce la lista delle anagrafiche di elaborazione comando. (Ereditato da EditAnagrCommandBase)
Proprietà pubblica | DisableEditingForOnlyDbAttrs | Indica se abilitare o meno l'editazione per gli attributi marchiati come "Solo Db". (Ereditato da EditAnagrCommandBase)
Proprietà pubblica | EnableDedContextMenu | Indica se abilitare il menu contestuale con i comandi del DED. (Ereditato da EditAnagrCommandBase)
Proprietà pubblica | FormAnagr | Restituisce il form utilizzato dal comando.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnorePerm | Indica se ignorare il controllo sui permessi. (Ereditato da EditAnagrCommandBase)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | IsInDb | Restituisce o imposta se le anagrafiche siano o meno da considerarsi nel Database. (Ereditato da EditAnagrCommandBase)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | LockAnagr | Indica se effettuare il lock dell'anagrafica. Di defualt è True. (Ereditato da EditAnagrCommandBase)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Il comando necessita di almeno una IDedData nella lista. (Ereditato da EditAnagrCommandBase)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | RefreshButtonEnabled | Imposta/Restituisce se abilitare il tasto di refresh. (Ereditato da EditAnagrCommandBase)
Proprietà pubblica | RefreshButtonTooltip | Imposta/Restituisce il tooltip del tasto di refresh. (Ereditato da EditAnagrCommandBase)
Proprietà pubblica | RefreshButtonVisible | Imposta/Restituisce se visualizzare il tasto di refresh. (Ereditato da EditAnagrCommandBase)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Proprietà pubblica | ValidateAttr | Indica se validare gli attributi. (Ereditato da EditAnagrCommandBase)
Proprietà pubblica | WindowTitle | Restituisce o imposta il titolo della finestra di dialogo. (Ereditato da EditAnagrCommandBase)
Torna su
Vedi anche

Documentazione

Classe ShowAnagrCommand
Namespace DedNet.Commands


Proprietà ShowAnagrCommand.FormAnagr

Proprietà ShowAnagrCommandFormAnagr
Restituisce il form utilizzato dal comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormAnagrafica FormAnagr { get; }
Public ReadOnly Property FormAnagr As DedFormAnagrafica
    Get
public:
property DedFormAnagrafica^ FormAnagr {
    DedFormAnagrafica^ get ();
}
member FormAnagr : DedFormAnagrafica with get

Valore della proprietà

DedFormAnagrafica
Vedi anche

Documentazione

Classe ShowAnagrCommand
Namespace DedNet.Commands


Metodi di ShowAnagrCommand

Il tipo ShowAnagrCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive EditAnagrCommandBaseClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Ereditato da EditAnagrCommandBase)
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Ereditato da EditAnagrCommandBase)
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ShowAnagrCommand
Namespace DedNet.Commands


Metodo ShowAnagrCommand.ClearCommand

Metodo ShowAnagrCommandClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe ShowAnagrCommand
Namespace DedNet.Commands


Metodo ShowAnagrCommand.ExecuteCommand

Metodo ShowAnagrCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe ShowAnagrCommand
Namespace DedNet.Commands


Classe ShowRecurrentTimingCommand
Comando utilizzato per visualizzare le temporizzazioni ricorrenti.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsShowRecurrentTimingCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ShowRecurrentTimingCommand : DedCommand
Public Class ShowRecurrentTimingCommand
    Inherits DedCommand
public ref class ShowRecurrentTimingCommand : public DedCommand
type ShowRecurrentTimingCommand =
    class
        inherit DedCommand
    end

Il tipo ShowRecurrentTimingCommand espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ShowRecurrentTimingCommand | Crea una nuova istanza della classe 'ShowRecurrentTimingCommand' utilizzata per visualizzare le le temporizzazioni ricorrenti.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Inidica se il comando necessita di parametri. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulizia del comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Abilitazione dal contesto. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esecuzione del comando. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Settaggio del contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Costruttore ShowRecurrentTimingCommand
Crea una nuova istanza della classe 'ShowRecurrentTimingCommand' utilizzata per visualizzare le le temporizzazioni ricorrenti.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ShowRecurrentTimingCommand(
    DedNetApplication app,
    string internalName,
    string name
)
Public Sub New (
    app As DedNetApplication,
    internalName As String,
    name As String
)
public:
ShowRecurrentTimingCommand(
    DedNetApplication^ app,
    String^ internalName,
    String^ name
)
new :
        app : DedNetApplication *
        internalName : string *
        name : string -> ShowRecurrentTimingCommand

Parametri

app DedNetApplication
Applicazione DedNet.
internalName String
Nome interno del comando.
name String
Nome visualizzato del comando.
Vedi anche

Documentazione

Classe ShowRecurrentTimingCommand
Namespace DedNet.Commands


Proprietà di ShowRecurrentTimingCommand

Il tipo ShowRecurrentTimingCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Inidica se il comando necessita di parametri. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ShowRecurrentTimingCommand
Namespace DedNet.Commands


Proprietà ShowRecurrentTimingCommand.NeedParameters

Proprietà ShowRecurrentTimingCommandNeedParameters
Inidica se il comando necessita di parametri.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ShowRecurrentTimingCommand
Namespace DedNet.Commands


Metodi di ShowRecurrentTimingCommand

Il tipo ShowRecurrentTimingCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulizia del comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Abilitazione dal contesto. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esecuzione del comando. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Settaggio del contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ShowRecurrentTimingCommand
Namespace DedNet.Commands


Metodo ShowRecurrentTimingCommand.ClearCommand

Metodo ShowRecurrentTimingCommandClearCommand
Pulizia del comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe ShowRecurrentTimingCommand
Namespace DedNet.Commands


Metodo ShowRecurrentTimingCommand.Enabled

Metodo ShowRecurrentTimingCommandEnabled
Abilitazione dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe ShowRecurrentTimingCommand
Namespace DedNet.Commands


Metodo ShowRecurrentTimingCommand.ExecuteCommand

Metodo ShowRecurrentTimingCommandExecuteCommand
Esecuzione del comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe ShowRecurrentTimingCommand
Namespace DedNet.Commands


Metodo ShowRecurrentTimingCommand.SetContext

Metodo ShowRecurrentTimingCommandSetContext
Settaggio del contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe ShowRecurrentTimingCommand
Namespace DedNet.Commands


Classe ShowSparePartsDistVariantCommand
Comando utilizzato per visualizzare la distinta MULTILIVELLO del codice specificato.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsShowSparePartsDistVariantCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ShowSparePartsDistVariantCommand : DedCommand
Public Class ShowSparePartsDistVariantCommand
    Inherits DedCommand
public ref class ShowSparePartsDistVariantCommand : public DedCommand
type ShowSparePartsDistVariantCommand =
    class
        inherit DedCommand
    end

Il tipo ShowSparePartsDistVariantCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Data | Anagrafica di cui si vuole visualizzare il codice.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve essere impostata la struttura di salvataggio distinta. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Esegue la pulizia del comando. Azzera tutte le variabili. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). Restituisce sempre false perché non è direttamente chiamato dall'utente. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Restituisce sempre false perché non è direttamente chiamato dall'utente. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di ShowSparePartsDistVariantCommand

Il tipo ShowSparePartsDistVariantCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Data | Anagrafica di cui si vuole visualizzare il codice.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve essere impostata la struttura di salvataggio distinta. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ShowSparePartsDistVariantCommand
Namespace DedNet.Commands


Proprietà ShowSparePartsDistVariantCommand.Data

Proprietà ShowSparePartsDistVariantCommandData
Anagrafica di cui si vuole visualizzare il codice.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; set; }
Public Property Data As DedData
    Get
    Set
public:
property DedData^ Data {
    DedData^ get ();
    void set (DedData^ value);
}
member Data : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe ShowSparePartsDistVariantCommand
Namespace DedNet.Commands


Proprietà ShowSparePartsDistVariantCommand.NeedParameters

Proprietà ShowSparePartsDistVariantCommandNeedParameters
Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve essere impostata la struttura di salvataggio distinta.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ShowSparePartsDistVariantCommand
Namespace DedNet.Commands


Metodi di ShowSparePartsDistVariantCommand

Il tipo ShowSparePartsDistVariantCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Esegue la pulizia del comando. Azzera tutte le variabili. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). Restituisce sempre false perché non è direttamente chiamato dall'utente. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Restituisce sempre false perché non è direttamente chiamato dall'utente. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ShowSparePartsDistVariantCommand
Namespace DedNet.Commands


Metodo ShowSparePartsDistVariantCommand.ClearCommand

Metodo ShowSparePartsDistVariantCommandClearCommand
Esegue la pulizia del comando. Azzera tutte le variabili.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe ShowSparePartsDistVariantCommand
Namespace DedNet.Commands


Metodo ShowSparePartsDistVariantCommand.Enabled

Metodo ShowSparePartsDistVariantCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). Restituisce sempre false perché non è direttamente chiamato dall'utente.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext commandContext
)
Public Overrides Function Enabled (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ commandContext
) override
abstract Enabled :
        commandContext : DedCommandContext -> bool
override Enabled :
        commandContext : DedCommandContext -> bool

Parametri

commandContext DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe ShowSparePartsDistVariantCommand
Namespace DedNet.Commands


Metodo ShowSparePartsDistVariantCommand.ExecuteCommand

Metodo ShowSparePartsDistVariantCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe ShowSparePartsDistVariantCommand
Namespace DedNet.Commands


Metodo ShowSparePartsDistVariantCommand.SetContext

Metodo ShowSparePartsDistVariantCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Restituisce sempre false perché non è direttamente chiamato dall'utente.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext commandContext
)
Public Overrides Function SetContext (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ commandContext
) override
abstract SetContext :
        commandContext : DedCommandContext -> bool
override SetContext :
        commandContext : DedCommandContext -> bool

Parametri

commandContext DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe ShowSparePartsDistVariantCommand
Namespace DedNet.Commands


Classe ShowTimingCommand
Comando utilizzato per visualizzare tutte le temporizzazioni di una determinata anagrafica, commessa, ECO, ecc..
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsShowTimingCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ShowTimingCommand : DedCommand
Public Class ShowTimingCommand
    Inherits DedCommand
public ref class ShowTimingCommand : public DedCommand
type ShowTimingCommand =
    class
        inherit DedCommand
    end

Il tipo ShowTimingCommand espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ShowTimingCommand | Crea una nuova istanza della classe 'ShowTimingCommand' visualizzare tutte le temporizzazioni di una determinata anagrafica, commessa, ECO, ecc..
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Inidica se il comando necessita di parametri. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulizia del comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Abilitazione dal contesto. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esecuzione del comando. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Settaggio del contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Costruttore ShowTimingCommand
Crea una nuova istanza della classe 'ShowTimingCommand' visualizzare tutte le temporizzazioni di una determinata anagrafica, commessa, ECO, ecc..

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ShowTimingCommand(
    DedNetApplication app,
    string internalName,
    string name
)
Public Sub New (
    app As DedNetApplication,
    internalName As String,
    name As String
)
public:
ShowTimingCommand(
    DedNetApplication^ app,
    String^ internalName,
    String^ name
)
new :
        app : DedNetApplication *
        internalName : string *
        name : string -> ShowTimingCommand

Parametri

app DedNetApplication
Applicazione DedNet.
internalName String
Nome interno del comando.
name String
Nome visualizzato del comando.
Vedi anche

Documentazione

Classe ShowTimingCommand
Namespace DedNet.Commands


Proprietà di ShowTimingCommand

Il tipo ShowTimingCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Inidica se il comando necessita di parametri. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ShowTimingCommand
Namespace DedNet.Commands


Proprietà ShowTimingCommand.NeedParameters

Proprietà ShowTimingCommandNeedParameters
Inidica se il comando necessita di parametri.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ShowTimingCommand
Namespace DedNet.Commands


Metodi di ShowTimingCommand

Il tipo ShowTimingCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulizia del comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Abilitazione dal contesto. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esecuzione del comando. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Settaggio del contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ShowTimingCommand
Namespace DedNet.Commands


Metodo ShowTimingCommand.ClearCommand

Metodo ShowTimingCommandClearCommand
Pulizia del comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe ShowTimingCommand
Namespace DedNet.Commands


Metodo ShowTimingCommand.Enabled

Metodo ShowTimingCommandEnabled
Abilitazione dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe ShowTimingCommand
Namespace DedNet.Commands


Metodo ShowTimingCommand.ExecuteCommand

Metodo ShowTimingCommandExecuteCommand
Esecuzione del comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe ShowTimingCommand
Namespace DedNet.Commands


Metodo ShowTimingCommand.SetContext

Metodo ShowTimingCommandSetContext
Settaggio del contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe ShowTimingCommand
Namespace DedNet.Commands


Classe StartTimingCommand
Comando utilizzato per avviare una temporizzazione su una anagrafica, commessa, ECO, ecc..
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsTimingCommand
DedNet.CommandsStartTimingCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class StartTimingCommand : TimingCommand
Public Class StartTimingCommand
    Inherits TimingCommand
public ref class StartTimingCommand : public TimingCommand
type StartTimingCommand =
    class
        inherit TimingCommand
    end

Il tipo StartTimingCommand espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | StartTimingCommand | Crea una nuova istanza della classe 'StartTimingCommand' utilizzata per avviare una temporizzazione su una anagrafica, commessa, eco, ecc..
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Inidica se il comando necessita di parametri. (Ereditato da TimingCommand)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Parent | Oggetto su cui si vuole avviare/interrompere la temporizzazione.
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulizia del comando. (Ereditato da TimingCommand)
Metodo pubblico | Enabled | Abilitazione dal contesto. (Sovrascrive TimingCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esecuzione del comando. (Ereditato da TimingCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Settaggio del contesto. (Ereditato da TimingCommand)
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Costruttore StartTimingCommand
Crea una nuova istanza della classe 'StartTimingCommand' utilizzata per avviare una temporizzazione su una anagrafica, commessa, eco, ecc..

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public StartTimingCommand(
    DedNetApplication app,
    string internalName,
    string name
)
Public Sub New (
    app As DedNetApplication,
    internalName As String,
    name As String
)
public:
StartTimingCommand(
    DedNetApplication^ app,
    String^ internalName,
    String^ name
)
new :
        app : DedNetApplication *
        internalName : string *
        name : string -> StartTimingCommand

Parametri

app DedNetApplication
Applicazione DedNet.
internalName String
Nome interno del comando.
name String
Nome visualizzato del comando.
Vedi anche

Documentazione

Classe StartTimingCommand
Namespace DedNet.Commands


Proprietà di StartTimingCommand

Il tipo StartTimingCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Inidica se il comando necessita di parametri. (Ereditato da TimingCommand)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Parent | Oggetto su cui si vuole avviare/interrompere la temporizzazione.
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe StartTimingCommand
Namespace DedNet.Commands


Proprietà StartTimingCommand.Parent

Proprietà StartTimingCommandParent
Oggetto su cui si vuole avviare/interrompere la temporizzazione.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTimedDbItem Parent { get; set; }
Public Property Parent As DedTimedDbItem
    Get
    Set
public:
property DedTimedDbItem^ Parent {
    DedTimedDbItem^ get ();
    void set (DedTimedDbItem^ value);
}
member Parent : DedTimedDbItem with get, set

Valore della proprietà

DedTimedDbItem
Vedi anche

Documentazione

Classe StartTimingCommand
Namespace DedNet.Commands


Metodi di StartTimingCommand

Il tipo StartTimingCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulizia del comando. (Ereditato da TimingCommand)
Metodo pubblico | Enabled | Abilitazione dal contesto. (Sovrascrive TimingCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esecuzione del comando. (Ereditato da TimingCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Settaggio del contesto. (Ereditato da TimingCommand)
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe StartTimingCommand
Namespace DedNet.Commands


Metodo StartTimingCommand.Enabled

Metodo StartTimingCommandEnabled
Abilitazione dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe StartTimingCommand
Namespace DedNet.Commands


Classe StateManagerCommand
Classe che rappresenta il comando per editare gli stati.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsStateManagerCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class StateManagerCommand : DedCommand
Public Class StateManagerCommand
    Inherits DedCommand
public ref class StateManagerCommand : public DedCommand
type StateManagerCommand =
    class
        inherit DedCommand
    end

Il tipo StateManagerCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di StateManagerCommand

Il tipo StateManagerCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe StateManagerCommand
Namespace DedNet.Commands


Proprietà StateManagerCommand.NeedParameters

Proprietà StateManagerCommandNeedParameters

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe StateManagerCommand
Namespace DedNet.Commands


Metodi di StateManagerCommand

Il tipo StateManagerCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe StateManagerCommand
Namespace DedNet.Commands


Metodo StateManagerCommand.ClearCommand

Metodo StateManagerCommandClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe StateManagerCommand
Namespace DedNet.Commands


Metodo StateManagerCommand.Enabled

Metodo StateManagerCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe StateManagerCommand
Namespace DedNet.Commands


Metodo StateManagerCommand.ExecuteCommand

Metodo StateManagerCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe StateManagerCommand
Namespace DedNet.Commands


Metodo StateManagerCommand.SetContext

Metodo StateManagerCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe StateManagerCommand
Namespace DedNet.Commands


Classe TimingCommand
Comando utilizzato per avviare/interrompere una temporizzazione su una anagrafica, commessa, ECO, ecc..
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsTimingCommand
DedNet.CommandsEndTimingCommand
DedNet.CommandsStartTimingCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public abstract class TimingCommand : DedCommand
Public MustInherit Class TimingCommand
    Inherits DedCommand
public ref class TimingCommand abstract : public DedCommand
[<AbstractClassAttribute>]
type TimingCommand =
    class
        inherit DedCommand
    end

Il tipo TimingCommand espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | TimingCommand | Crea una nuova istanza della classe 'TimesCommand' utilizzata per avviare/interrompere una temporizzazione su una anagrafica, commessa, eco, ecc..
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Inidica se il comando necessita di parametri. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Parent | Oggetto su cui si vuole avviare/interrompere la temporizzazione.
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulizia del comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Abilitazione dal contesto. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esecuzione del comando. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Settaggio del contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Costruttore TimingCommand
Crea una nuova istanza della classe 'TimesCommand' utilizzata per avviare/interrompere una temporizzazione su una anagrafica, commessa, eco, ecc..

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public TimingCommand(
    DedNetApplication app,
    string internalName,
    string name,
    bool isStartTiming
)
Public Sub New (
    app As DedNetApplication,
    internalName As String,
    name As String,
    isStartTiming As Boolean
)
public:
TimingCommand(
    DedNetApplication^ app,
    String^ internalName,
    String^ name,
    bool isStartTiming
)
new :
        app : DedNetApplication *
        internalName : string *
        name : string *
        isStartTiming : bool -> TimingCommand

Parametri

app DedNetApplication
Applicazione DedNet.
internalName String
Nome interno del comando.
name String
Nome visualizzato del comando.
isStartTiming Boolean
Indica se il comando deve avviare o interrompere una temporizzazione.
Vedi anche

Documentazione

Classe TimingCommand
Namespace DedNet.Commands


Proprietà di TimingCommand

Il tipo TimingCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Inidica se il comando necessita di parametri. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Parent | Oggetto su cui si vuole avviare/interrompere la temporizzazione.
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe TimingCommand
Namespace DedNet.Commands


Proprietà TimingCommand.NeedParameters

Proprietà TimingCommandNeedParameters
Inidica se il comando necessita di parametri.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe TimingCommand
Namespace DedNet.Commands


Proprietà TimingCommand.Parent

Proprietà TimingCommandParent
Oggetto su cui si vuole avviare/interrompere la temporizzazione.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTimedDbItem Parent { get; set; }
Public Property Parent As DedTimedDbItem
    Get
    Set
public:
property DedTimedDbItem^ Parent {
    DedTimedDbItem^ get ();
    void set (DedTimedDbItem^ value);
}
member Parent : DedTimedDbItem with get, set

Valore della proprietà

DedTimedDbItem
Vedi anche

Documentazione

Classe TimingCommand
Namespace DedNet.Commands


Metodi di TimingCommand

Il tipo TimingCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulizia del comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Abilitazione dal contesto. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esecuzione del comando. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Settaggio del contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe TimingCommand
Namespace DedNet.Commands


Metodo TimingCommand.ClearCommand

Metodo TimingCommandClearCommand
Pulizia del comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe TimingCommand
Namespace DedNet.Commands


Metodo TimingCommand.Enabled

Metodo TimingCommandEnabled
Abilitazione dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe TimingCommand
Namespace DedNet.Commands


Metodo TimingCommand.ExecuteCommand

Metodo TimingCommandExecuteCommand
Esecuzione del comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe TimingCommand
Namespace DedNet.Commands


Metodo TimingCommand.SetContext

Metodo TimingCommandSetContext
Settaggio del contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe TimingCommand
Namespace DedNet.Commands


Classe TranslationsMangerCommand
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsTranslationsMangerCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class TranslationsMangerCommand : DedCommand
Public Class TranslationsMangerCommand
    Inherits DedCommand
public ref class TranslationsMangerCommand : public DedCommand
type TranslationsMangerCommand =
    class
        inherit DedCommand
    end

Il tipo TranslationsMangerCommand espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | TranslationsMangerCommand | Costruttore unico
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | AttributesList | Attributi di cui si vogliono gestire le traduzioni.
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommAttrs | Indica se utilizzare gli attributi di commessa.
Proprietà pubblica | CustomTranslations | Indica se le traduzioni sono relative alle stinghe custom.
Proprietà pubblica | DataList | Anagrafica della quale si vogliono gestire le traduzioni.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Inidica se il comando necessita di parametri. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | TranslateAttributesPrompt | Indica se le traduzioni sono relative ai prompt degli attributi e non ai valori di essi.
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulizia del comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Abilitazione dal contesto. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esecuzione del comando. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Settaggio del contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Costruttore TranslationsMangerCommand
Costruttore unico

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public TranslationsMangerCommand(
    DedNetApplication app,
    string internalName,
    string name
)
Public Sub New (
    app As DedNetApplication,
    internalName As String,
    name As String
)
public:
TranslationsMangerCommand(
    DedNetApplication^ app,
    String^ internalName,
    String^ name
)
new :
        app : DedNetApplication *
        internalName : string *
        name : string -> TranslationsMangerCommand

Parametri

app DedNetApplication
Applicazione DedNet.
internalName String
Nome interno del comando.
name String
Nome visualizzato del comando.
Vedi anche

Documentazione

Classe TranslationsMangerCommand
Namespace DedNet.Commands


Proprietà di TranslationsMangerCommand

Il tipo TranslationsMangerCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | AttributesList | Attributi di cui si vogliono gestire le traduzioni.
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommAttrs | Indica se utilizzare gli attributi di commessa.
Proprietà pubblica | CustomTranslations | Indica se le traduzioni sono relative alle stinghe custom.
Proprietà pubblica | DataList | Anagrafica della quale si vogliono gestire le traduzioni.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Inidica se il comando necessita di parametri. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | TranslateAttributesPrompt | Indica se le traduzioni sono relative ai prompt degli attributi e non ai valori di essi.
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe TranslationsMangerCommand
Namespace DedNet.Commands


Proprietà TranslationsMangerCommand.AttributesList

Proprietà TranslationsMangerCommandAttributesList
Attributi di cui si vogliono gestire le traduzioni.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList AttributesList { get; }
Public ReadOnly Property AttributesList As DedAttrList
    Get
public:
property DedAttrList^ AttributesList {
    DedAttrList^ get ();
}
member AttributesList : DedAttrList with get

Valore della proprietà

DedAttrList
Vedi anche

Documentazione

Classe TranslationsMangerCommand
Namespace DedNet.Commands


Proprietà TranslationsMangerCommand.CommAttrs

Proprietà TranslationsMangerCommandCommAttrs
Indica se utilizzare gli attributi di commessa.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CommAttrs { get; set; }
Public Property CommAttrs As Boolean
    Get
    Set
public:
property bool CommAttrs {
    bool get ();
    void set (bool value);
}
member CommAttrs : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe TranslationsMangerCommand
Namespace DedNet.Commands


Proprietà TranslationsMangerCommand.CustomTranslations

Proprietà TranslationsMangerCommandCustomTranslations
Indica se le traduzioni sono relative alle stinghe custom.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CustomTranslations { get; set; }
Public Property CustomTranslations As Boolean
    Get
    Set
public:
property bool CustomTranslations {
    bool get ();
    void set (bool value);
}
member CustomTranslations : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe TranslationsMangerCommand
Namespace DedNet.Commands


Proprietà TranslationsMangerCommand.DataList

Proprietà TranslationsMangerCommandDataList
Anagrafica della quale si vogliono gestire le traduzioni.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataList DataList { get; set; }
Public Property DataList As DedDataList
    Get
    Set
public:
property DedDataList^ DataList {
    DedDataList^ get ();
    void set (DedDataList^ value);
}
member DataList : DedDataList with get, set

Valore della proprietà

DedDataList
Vedi anche

Documentazione

Classe TranslationsMangerCommand
Namespace DedNet.Commands


Proprietà TranslationsMangerCommand.NeedParameters

Proprietà TranslationsMangerCommandNeedParameters
Inidica se il comando necessita di parametri.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe TranslationsMangerCommand
Namespace DedNet.Commands


Proprietà TranslationsMangerCommand.TranslateAttributesPrompt

Proprietà TranslationsMangerCommandTranslateAttributesPrompt
Indica se le traduzioni sono relative ai prompt degli attributi e non ai valori di essi.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool TranslateAttributesPrompt { get; set; }
Public Property TranslateAttributesPrompt As Boolean
    Get
    Set
public:
property bool TranslateAttributesPrompt {
    bool get ();
    void set (bool value);
}
member TranslateAttributesPrompt : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe TranslationsMangerCommand
Namespace DedNet.Commands


Metodi di TranslationsMangerCommand

Il tipo TranslationsMangerCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulizia del comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Abilitazione dal contesto. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esecuzione del comando. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Settaggio del contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe TranslationsMangerCommand
Namespace DedNet.Commands


Metodo TranslationsMangerCommand.ClearCommand

Metodo TranslationsMangerCommandClearCommand
Pulizia del comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe TranslationsMangerCommand
Namespace DedNet.Commands


Metodo TranslationsMangerCommand.Enabled

Metodo TranslationsMangerCommandEnabled
Abilitazione dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe TranslationsMangerCommand
Namespace DedNet.Commands


Metodo TranslationsMangerCommand.ExecuteCommand

Metodo TranslationsMangerCommandExecuteCommand
Esecuzione del comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe TranslationsMangerCommand
Namespace DedNet.Commands


Metodo TranslationsMangerCommand.SetContext

Metodo TranslationsMangerCommandSetContext
Settaggio del contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe TranslationsMangerCommand
Namespace DedNet.Commands


Classe UpdateDocument
Si occupa di aggiornare i dati di uno o più documenti nel Database e di riconoscere i documenti dipendenti a cascata. Aggiorna la versione del documento nel Database per segnalare che il file fisico è stato modificato. I client, se l'area locale non è attiva, devono chiamare questo comando subito dopo il salvataggio. Con l'area locale attiva invece non devono fare niente perché verrà invocato dal comando di pubblicazione. Anche se non ci sono dati particolari da aggiornare nel Database (come il formato, la scala ed il foglio) visto che il file fisico è stato modificato, è bene aggiornare anche la versione del documento che dovrebbe essere suggerita dal client al comando (a questo comando oppure al comando di pubblicazione) utilizzando il guid presente nella struttura DocStructInfo (es.: Inventor ed Autocad).
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsUpdateDocument

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class UpdateDocument : DedCommand
Public Class UpdateDocument
    Inherits DedCommand
public ref class UpdateDocument : public DedCommand
type UpdateDocument =
    class
        inherit DedCommand
    end

Il tipo UpdateDocument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | FileList | Restituisce la lista dei documenti per i quali effettuare l'aggiornamento. Inserire in questa lista solo i file che si desidera elaborare e non le dipendenze, a meno ché non siano a loro volta da elaborare.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | LazyMode | Se vero attiva la modalità che non invalida il comando in caso di errori
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non è impostato alcun documento da aggiornare. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. Restituisce sempre false perché questo è utilizzato come sotto-comando. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Restituisce sempre false perché questo è utilizzato come sotto-comando. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di UpdateDocument

Il tipo UpdateDocument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | FileList | Restituisce la lista dei documenti per i quali effettuare l'aggiornamento. Inserire in questa lista solo i file che si desidera elaborare e non le dipendenze, a meno ché non siano a loro volta da elaborare.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | LazyMode | Se vero attiva la modalità che non invalida il comando in caso di errori
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se non è impostato alcun documento da aggiornare. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe UpdateDocument
Namespace DedNet.Commands


Proprietà UpdateDocument.FileList

Proprietà UpdateDocumentFileList
Restituisce la lista dei documenti per i quali effettuare l'aggiornamento. Inserire in questa lista solo i file che si desidera elaborare e non le dipendenze, a meno ché non siano a loro volta da elaborare.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfoList FileList { get; }
Public ReadOnly Property FileList As DocStructInfoList
    Get
public:
property DocStructInfoList^ FileList {
    DocStructInfoList^ get ();
}
member FileList : DocStructInfoList with get

Valore della proprietà

DocStructInfoList
Vedi anche

Documentazione

Classe UpdateDocument
Namespace DedNet.Commands


Proprietà UpdateDocument.LazyMode

Proprietà UpdateDocumentLazyMode
Se vero attiva la modalità che non invalida il comando in caso di errori

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool LazyMode { get; set; }
Public Property LazyMode As Boolean
    Get
    Set
public:
property bool LazyMode {
    bool get ();
    void set (bool value);
}
member LazyMode : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe UpdateDocument
Namespace DedNet.Commands


Proprietà UpdateDocument.NeedParameters

Proprietà UpdateDocumentNeedParameters
Restituisce true se non è impostato alcun documento da aggiornare.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe UpdateDocument
Namespace DedNet.Commands


Metodi di UpdateDocument

Il tipo UpdateDocument espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. Restituisce sempre false perché questo è utilizzato come sotto-comando. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Restituisce sempre false perché questo è utilizzato come sotto-comando. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe UpdateDocument
Namespace DedNet.Commands


Metodo UpdateDocument.ClearCommand

Metodo UpdateDocumentClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe UpdateDocument
Namespace DedNet.Commands


Metodo UpdateDocument.Enabled

Metodo UpdateDocumentEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale. Restituisce sempre false perché questo è utilizzato come sotto-comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce sempre false.
Vedi anche

Documentazione

Classe UpdateDocument
Namespace DedNet.Commands


Metodo UpdateDocument.ExecuteCommand

Metodo UpdateDocumentExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe UpdateDocument
Namespace DedNet.Commands


Metodo UpdateDocument.SetContext

Metodo UpdateDocumentSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Restituisce sempre false perché questo è utilizzato come sotto-comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce sempre false.
Vedi anche

Documentazione

Classe UpdateDocument
Namespace DedNet.Commands


Classe UpdateDocumentReference
Si occupa di eseguire la sostituzione fisica dei riferimenti di un file all'interno dei suoi padri con un documento di sostituzione. Il comando effettua prima di tutto un'analisi della lista di padri passata e, sulla base del documento di partenza e quello di sostituzione, mostra all'utente su quali padri la sostituzione è possibile e su quali no. L'utente può poi scegliere tramite una spunta su quali padri effettuare la sostituzione effettiva (tra quelli su cui è possibile). In seguito, viene lanciato un Elaboration Report che si occupa di effettuare le sostituzioni effettive. Esse dipendono da un delegate (ExecuteReferenceUpdateDelegate) a cui CAD e Plugin si attachano in modo che ognuno esegua la sostituzione sulla base delle proprie logiche. Per salvare le modifiche, ogni documento padre viene prima posto in check-out e poi, dopo l'avvenuta sostituzione, riposto in check-in, a meno che il file non fosse in check-out già prima che venisse lanciato il comando.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsUpdateDocumentReference

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class UpdateDocumentReference : DedCommand
Public Class UpdateDocumentReference
    Inherits DedCommand
public ref class UpdateDocumentReference : public DedCommand
type UpdateDocumentReference =
    class
        inherit DedCommand
    end

Il tipo UpdateDocumentReference espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | EnableDocSelection | Indica se l'utente ha la possibilità di selezionare manualmente il documento di sostituzione.
Proprietà pubblica | ExecuteUpdateDelegate | Delegate per effettuare l'operazione di aggiornamento vera e propria.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | IsUpdateMoved | Indica se il comando è lanciato dall'aggiornamento riferimenti moved.
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Ritorna True se la lista di riferimenti è vuota. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OverrideGridInfo | Delegate per sovrascrivere le informazioni visualizzate all'interno della griglia dell'ElaborationReport.
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | RefAnalysisDelegate | Delegate per eventuali analisi ulteriori del CAD/plugin sulla possibilità di effettuare l'aggiornamento.
Proprietà pubblica | ReplaceList | Lista di riferimenti da aggiornare. L'ordine degli elementi deve essere: DedDoc vecchio - DedDoc nuovo - Lista di DedDoc padri.
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Reinizializza il comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Comando sempre abilitato. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Il contesto non è da settare. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di UpdateDocumentReference

Il tipo UpdateDocumentReference espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | EnableDocSelection | Indica se l'utente ha la possibilità di selezionare manualmente il documento di sostituzione.
Proprietà pubblica | ExecuteUpdateDelegate | Delegate per effettuare l'operazione di aggiornamento vera e propria.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | IsUpdateMoved | Indica se il comando è lanciato dall'aggiornamento riferimenti moved.
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Ritorna True se la lista di riferimenti è vuota. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OverrideGridInfo | Delegate per sovrascrivere le informazioni visualizzate all'interno della griglia dell'ElaborationReport.
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | RefAnalysisDelegate | Delegate per eventuali analisi ulteriori del CAD/plugin sulla possibilità di effettuare l'aggiornamento.
Proprietà pubblica | ReplaceList | Lista di riferimenti da aggiornare. L'ordine degli elementi deve essere: DedDoc vecchio - DedDoc nuovo - Lista di DedDoc padri.
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe UpdateDocumentReference
Namespace DedNet.Commands


Proprietà UpdateDocumentReference.EnableDocSelection

Proprietà UpdateDocumentReferenceEnableDocSelection
Indica se l'utente ha la possibilità di selezionare manualmente il documento di sostituzione.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool EnableDocSelection { get; set; }
Public Property EnableDocSelection As Boolean
    Get
    Set
public:
property bool EnableDocSelection {
    bool get ();
    void set (bool value);
}
member EnableDocSelection : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe UpdateDocumentReference
Namespace DedNet.Commands


Proprietà UpdateDocumentReference.ExecuteUpdateDelegate

Proprietà UpdateDocumentReferenceExecuteUpdateDelegate
Delegate per effettuare l'operazione di aggiornamento vera e propria.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public UpdateDocumentReferenceExecuteReferenceUpdateDelegate ExecuteUpdateDelegate { get; set; }
Public Property ExecuteUpdateDelegate As UpdateDocumentReferenceExecuteReferenceUpdateDelegate
    Get
    Set
public:
property UpdateDocumentReferenceExecuteReferenceUpdateDelegate^ ExecuteUpdateDelegate {
    UpdateDocumentReferenceExecuteReferenceUpdateDelegate^ get ();
    void set (UpdateDocumentReferenceExecuteReferenceUpdateDelegate^ value);
}
member ExecuteUpdateDelegate : UpdateDocumentReferenceExecuteReferenceUpdateDelegate with get, set

Valore della proprietà

UpdateDocumentReferenceExecuteReferenceUpdateDelegate
Vedi anche

Documentazione

Classe UpdateDocumentReference
Namespace DedNet.Commands


Proprietà UpdateDocumentReference.IsUpdateMoved

Proprietà UpdateDocumentReferenceIsUpdateMoved
Indica se il comando è lanciato dall'aggiornamento riferimenti moved.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsUpdateMoved { get; set; }
Public Property IsUpdateMoved As Boolean
    Get
    Set
public:
property bool IsUpdateMoved {
    bool get ();
    void set (bool value);
}
member IsUpdateMoved : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe UpdateDocumentReference
Namespace DedNet.Commands


Proprietà UpdateDocumentReference.NeedParameters

Proprietà UpdateDocumentReferenceNeedParameters
Ritorna True se la lista di riferimenti è vuota.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe UpdateDocumentReference
Namespace DedNet.Commands


Proprietà UpdateDocumentReference.OverrideGridInfo

Proprietà UpdateDocumentReferenceOverrideGridInfo
Delegate per sovrascrivere le informazioni visualizzate all'interno della griglia dell'ElaborationReport.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public UpdateDocumentReferenceElaborationOverrideGridInfo OverrideGridInfo { get; set; }
Public Property OverrideGridInfo As UpdateDocumentReferenceElaborationOverrideGridInfo
    Get
    Set
public:
property UpdateDocumentReferenceElaborationOverrideGridInfo^ OverrideGridInfo {
    UpdateDocumentReferenceElaborationOverrideGridInfo^ get ();
    void set (UpdateDocumentReferenceElaborationOverrideGridInfo^ value);
}
member OverrideGridInfo : UpdateDocumentReferenceElaborationOverrideGridInfo with get, set

Valore della proprietà

UpdateDocumentReferenceElaborationOverrideGridInfo
Vedi anche

Documentazione

Classe UpdateDocumentReference
Namespace DedNet.Commands


Proprietà UpdateDocumentReference.RefAnalysisDelegate

Proprietà UpdateDocumentReferenceRefAnalysisDelegate
Delegate per eventuali analisi ulteriori del CAD/plugin sulla possibilità di effettuare l'aggiornamento.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public UpdateDocumentReferenceReferenceAnalysisDelegate RefAnalysisDelegate { get; set; }
Public Property RefAnalysisDelegate As UpdateDocumentReferenceReferenceAnalysisDelegate
    Get
    Set
public:
property UpdateDocumentReferenceReferenceAnalysisDelegate^ RefAnalysisDelegate {
    UpdateDocumentReferenceReferenceAnalysisDelegate^ get ();
    void set (UpdateDocumentReferenceReferenceAnalysisDelegate^ value);
}
member RefAnalysisDelegate : UpdateDocumentReferenceReferenceAnalysisDelegate with get, set

Valore della proprietà

UpdateDocumentReferenceReferenceAnalysisDelegate
Vedi anche

Documentazione

Classe UpdateDocumentReference
Namespace DedNet.Commands


Proprietà UpdateDocumentReference.ReplaceList

Proprietà UpdateDocumentReferenceReplaceList
Lista di riferimenti da aggiornare. L'ordine degli elementi deve essere: DedDoc vecchio - DedDoc nuovo - Lista di DedDoc padri.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<Tuple<DedDoc, DedDoc, DedDocList>> ReplaceList { get; set; }
Public Property ReplaceList As List(Of Tuple(Of DedDoc, DedDoc, DedDocList))
    Get
    Set
public:
property List<Tuple<DedDoc^, DedDoc^, DedDocList^>^>^ ReplaceList {
    List<Tuple<DedDoc^, DedDoc^, DedDocList^>^>^ get ();
    void set (List<Tuple<DedDoc^, DedDoc^, DedDocList^>^>^ value);
}
member ReplaceList : List<Tuple<DedDoc, DedDoc, DedDocList>> with get, set

Valore della proprietà

List Tuple DedDoc, DedDoc, DedDocList
Vedi anche

Documentazione

Classe UpdateDocumentReference
Namespace DedNet.Commands


Metodi di UpdateDocumentReference

Il tipo UpdateDocumentReference espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Reinizializza il comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Comando sempre abilitato. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Il contesto non è da settare. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe UpdateDocumentReference
Namespace DedNet.Commands


Metodo UpdateDocumentReference.ClearCommand

Metodo UpdateDocumentReferenceClearCommand
Reinizializza il comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe UpdateDocumentReference
Namespace DedNet.Commands


Metodo UpdateDocumentReference.Enabled

Metodo UpdateDocumentReferenceEnabled
Comando sempre abilitato.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext commandContext
)
Public Overrides Function Enabled (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ commandContext
) override
abstract Enabled :
        commandContext : DedCommandContext -> bool
override Enabled :
        commandContext : DedCommandContext -> bool

Parametri

commandContext DedCommandContext
Contesto.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe UpdateDocumentReference
Namespace DedNet.Commands


Metodo UpdateDocumentReference.ExecuteCommand

Metodo UpdateDocumentReferenceExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Vedi anche

Documentazione

Classe UpdateDocumentReference
Namespace DedNet.Commands


Metodo UpdateDocumentReference.SetContext

Metodo UpdateDocumentReferenceSetContext
Il contesto non è da settare.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext commandContext
)
Public Overrides Function SetContext (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ commandContext
) override
abstract SetContext :
        commandContext : DedCommandContext -> bool
override SetContext :
        commandContext : DedCommandContext -> bool

Parametri

commandContext DedCommandContext
Contesto.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe UpdateDocumentReference
Namespace DedNet.Commands


Delegate UpdateDocumentReference.ElaborationOverrideGridInfo

Delegate UpdateDocumentReferenceElaborationOverrideGridInfo

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public delegate void ElaborationOverrideGridInfo(
    Object argument
)
Public Delegate Sub ElaborationOverrideGridInfo (
    argument As Object
)
public delegate void ElaborationOverrideGridInfo(
    Object^ argument
)
type ElaborationOverrideGridInfo =
    delegate of
        argument : Object -> unit

Parametri

argument Object
Vedi anche

Documentazione

Namespace DedNet.Commands


Delegate UpdateDocumentReference.ExecuteReferenceUpdateDelegate

Delegate UpdateDocumentReferenceExecuteReferenceUpdateDelegate

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public delegate void ExecuteReferenceUpdateDelegate(
    Object argument
)
Public Delegate Sub ExecuteReferenceUpdateDelegate (
    argument As Object
)
public delegate void ExecuteReferenceUpdateDelegate(
    Object^ argument
)
type ExecuteReferenceUpdateDelegate =
    delegate of
        argument : Object -> unit

Parametri

argument Object
Vedi anche

Documentazione

Namespace DedNet.Commands


Classe UpdateDocumentReference.OverrideGridInfoArgument

Classe UpdateDocumentReferenceOverrideGridInfoArgument
Classe che descrive le informazioni neecssarie per il delegate ElaborationOverrideGridInfo.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsUpdateDocumentReferenceOverrideGridInfoArgument

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class OverrideGridInfoArgument
Public Class OverrideGridInfoArgument
public ref class OverrideGridInfoArgument
type OverrideGridInfoArgument = class end

Il tipo UpdateDocumentReferenceOverrideGridInfoArgument espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | UpdateDocumentReferenceOverrideGridInfoArgument |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Descriptor | Descrittore della riga.
Proprietà pubblica | FieldName | Nome del campo della griglia.
Proprietà pubblica | Value | Valore della cella.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Costruttore UpdateDocumentReference.OverrideGridInfoArgument

Costruttore UpdateDocumentReferenceOverrideGridInfoArgument

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public OverrideGridInfoArgument()
Public Sub New
public:
OverrideGridInfoArgument()
new : unit -> OverrideGridInfoArgument
Vedi anche

Documentazione

Classe UpdateDocumentReferenceOverrideGridInfoArgument
Namespace DedNet.Commands


Proprietà di OverrideGridInfoArgument

Il tipo UpdateDocumentReferenceOverrideGridInfoArgument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Descriptor | Descrittore della riga.
Proprietà pubblica | FieldName | Nome del campo della griglia.
Proprietà pubblica | Value | Valore della cella.
Torna su
Vedi anche

Documentazione

Classe UpdateDocumentReferenceOverrideGridInfoArgument
Namespace DedNet.Commands


Proprietà UpdateDocumentReference.OverrideGridInfoArgument.Descriptor

Proprietà UpdateDocumentReferenceOverrideGridInfoArgumentDescriptor
Descrittore della riga.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public UpdateDocumentReferenceReferenceUpdateDescriptor Descriptor { get; }
Public ReadOnly Property Descriptor As UpdateDocumentReferenceReferenceUpdateDescriptor
    Get
public:
property UpdateDocumentReferenceReferenceUpdateDescriptor^ Descriptor {
    UpdateDocumentReferenceReferenceUpdateDescriptor^ get ();
}
member Descriptor : UpdateDocumentReferenceReferenceUpdateDescriptor with get

Valore della proprietà

UpdateDocumentReferenceReferenceUpdateDescriptor
Vedi anche

Documentazione

Classe UpdateDocumentReferenceOverrideGridInfoArgument
Namespace DedNet.Commands


Proprietà UpdateDocumentReference.OverrideGridInfoArgument.FieldName

Proprietà UpdateDocumentReferenceOverrideGridInfoArgumentFieldName
Nome del campo della griglia.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string FieldName { get; }
Public ReadOnly Property FieldName As String
    Get
public:
property String^ FieldName {
    String^ get ();
}
member FieldName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe UpdateDocumentReferenceOverrideGridInfoArgument
Namespace DedNet.Commands


Proprietà UpdateDocumentReference.OverrideGridInfoArgument.Value

Proprietà UpdateDocumentReferenceOverrideGridInfoArgumentValue
Valore della cella.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}
member Value : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe UpdateDocumentReferenceOverrideGridInfoArgument
Namespace DedNet.Commands


Classe UpdateDocumentReference.ReferenceAnalysisArgument

Classe UpdateDocumentReferenceReferenceAnalysisArgument
Classe che descrive le informazioni per l'analisi di una sostituzione riferimenti.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsUpdateDocumentReferenceReferenceAnalysisArgument

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ReferenceAnalysisArgument
Public Class ReferenceAnalysisArgument
public ref class ReferenceAnalysisArgument
type ReferenceAnalysisArgument = class end

Il tipo UpdateDocumentReferenceReferenceAnalysisArgument espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | UpdateDocumentReferenceReferenceAnalysisArgument |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | NewDoc | Documento di sostituzione.
Proprietà pubblica | NodeChecked | Indica se il nodo deve essere checkato.
Proprietà pubblica | Notes | Note sostituzione.
Proprietà pubblica | OldDoc | Documento da sostituire.
Proprietà pubblica | ParentDoc | Documento padre.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Costruttore UpdateDocumentReference.ReferenceAnalysisArgument

Costruttore UpdateDocumentReferenceReferenceAnalysisArgument

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ReferenceAnalysisArgument()
Public Sub New
public:
ReferenceAnalysisArgument()
new : unit -> ReferenceAnalysisArgument
Vedi anche

Documentazione

Classe UpdateDocumentReferenceReferenceAnalysisArgument
Namespace DedNet.Commands


Proprietà di ReferenceAnalysisArgument

Il tipo UpdateDocumentReferenceReferenceAnalysisArgument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | NewDoc | Documento di sostituzione.
Proprietà pubblica | NodeChecked | Indica se il nodo deve essere checkato.
Proprietà pubblica | Notes | Note sostituzione.
Proprietà pubblica | OldDoc | Documento da sostituire.
Proprietà pubblica | ParentDoc | Documento padre.
Torna su
Vedi anche

Documentazione

Classe UpdateDocumentReferenceReferenceAnalysisArgument
Namespace DedNet.Commands


Proprietà UpdateDocumentReference.ReferenceAnalysisArgument.NewDoc

Proprietà UpdateDocumentReferenceReferenceAnalysisArgumentNewDoc
Documento di sostituzione.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDoc NewDoc { get; }
Public ReadOnly Property NewDoc As DedDoc
    Get
public:
property DedDoc^ NewDoc {
    DedDoc^ get ();
}
member NewDoc : DedDoc with get

Valore della proprietà

DedDoc
Vedi anche

Documentazione

Classe UpdateDocumentReferenceReferenceAnalysisArgument
Namespace DedNet.Commands


Proprietà UpdateDocumentReference.ReferenceAnalysisArgument.NodeChecked

Proprietà UpdateDocumentReferenceReferenceAnalysisArgumentNodeChecked
Indica se il nodo deve essere checkato.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool NodeChecked { get; set; }
Public Property NodeChecked As Boolean
    Get
    Set
public:
property bool NodeChecked {
    bool get ();
    void set (bool value);
}
member NodeChecked : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe UpdateDocumentReferenceReferenceAnalysisArgument
Namespace DedNet.Commands


Proprietà UpdateDocumentReference.ReferenceAnalysisArgument.Notes

Proprietà UpdateDocumentReferenceReferenceAnalysisArgumentNotes
Note sostituzione.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Notes { get; set; }
Public Property Notes As String
    Get
    Set
public:
property String^ Notes {
    String^ get ();
    void set (String^ value);
}
member Notes : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe UpdateDocumentReferenceReferenceAnalysisArgument
Namespace DedNet.Commands


Proprietà UpdateDocumentReference.ReferenceAnalysisArgument.OldDoc

Proprietà UpdateDocumentReferenceReferenceAnalysisArgumentOldDoc
Documento da sostituire.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDoc OldDoc { get; }
Public ReadOnly Property OldDoc As DedDoc
    Get
public:
property DedDoc^ OldDoc {
    DedDoc^ get ();
}
member OldDoc : DedDoc with get

Valore della proprietà

DedDoc
Vedi anche

Documentazione

Classe UpdateDocumentReferenceReferenceAnalysisArgument
Namespace DedNet.Commands


Proprietà UpdateDocumentReference.ReferenceAnalysisArgument.ParentDoc

Proprietà UpdateDocumentReferenceReferenceAnalysisArgumentParentDoc
Documento padre.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDoc ParentDoc { get; }
Public ReadOnly Property ParentDoc As DedDoc
    Get
public:
property DedDoc^ ParentDoc {
    DedDoc^ get ();
}
member ParentDoc : DedDoc with get

Valore della proprietà

DedDoc
Vedi anche

Documentazione

Classe UpdateDocumentReferenceReferenceAnalysisArgument
Namespace DedNet.Commands


Delegate UpdateDocumentReference.ReferenceAnalysisDelegate

Delegate UpdateDocumentReferenceReferenceAnalysisDelegate

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public delegate bool ReferenceAnalysisDelegate(
    Object argument
)
Public Delegate Function ReferenceAnalysisDelegate (
    argument As Object
) As Boolean
public delegate bool ReferenceAnalysisDelegate(
    Object^ argument
)
type ReferenceAnalysisDelegate =
    delegate of
        argument : Object -> bool

Parametri

argument Object

Valore di ritorno

Boolean
Vedi anche

Documentazione

Namespace DedNet.Commands


Classe UpdateDocumentReference.ReferenceUpdateDescriptor

Classe UpdateDocumentReferenceReferenceUpdateDescriptor
Classe usata per descrivere l'operazione di aggiornamento dei riferimenti.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsUpdateDocumentReferenceReferenceUpdateDescriptor

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ReferenceUpdateDescriptor
Public Class ReferenceUpdateDescriptor
public ref class ReferenceUpdateDescriptor
type ReferenceUpdateDescriptor = class end

Il tipo UpdateDocumentReferenceReferenceUpdateDescriptor espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | UpdateDocumentReferenceReferenceUpdateDescriptor | Costruttore dell'oggetto
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | DestPath | Percorso del file di destinazione.
Proprietà pubblica | Id | ID unico del record.
Proprietà pubblica | OldDoc | DedDoc di partenza.
Proprietà pubblica | ParentPath | Percorso del file padre.
Proprietà pubblica | StartPath | Percorso del file di partenza.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | Ridefinizione di uguaglianza. (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetHashCode | Restituisce l'HashCode di questo oggetto. (Sovrascrive ObjectGetHashCode)
Torna su
Operatori
Nome | Descrizione
Equality(UpdateDocumentReferenceReferenceUpdateDescriptor, UpdateDocumentReferenceReferenceUpdateDescriptor) | Ridefinizione dell'operatore ==.
Inequality(UpdateDocumentReferenceReferenceUpdateDescriptor, UpdateDocumentReferenceReferenceUpdateDescriptor) | Ridefinizione dell'operatore !=.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Costruttore UpdateDocumentReference.ReferenceUpdateDescriptor

Costruttore UpdateDocumentReferenceReferenceUpdateDescriptor
Costruttore dell'oggetto

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ReferenceUpdateDescriptor(
    string parentPath,
    string startPath,
    DedDoc oldDoc,
    string destPath
)
Public Sub New (
    parentPath As String,
    startPath As String,
    oldDoc As DedDoc,
    destPath As String
)
public:
ReferenceUpdateDescriptor(
    String^ parentPath,
    String^ startPath,
    DedDoc^ oldDoc,
    String^ destPath
)
new :
        parentPath : string *
        startPath : string *
        oldDoc : DedDoc *
        destPath : string -> ReferenceUpdateDescriptor

Parametri

parentPath String
startPath String
oldDoc DedDoc
destPath String
Vedi anche

Documentazione

Classe UpdateDocumentReferenceReferenceUpdateDescriptor
Namespace DedNet.Commands


Proprietà di ReferenceUpdateDescriptor

Il tipo UpdateDocumentReferenceReferenceUpdateDescriptor espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | DestPath | Percorso del file di destinazione.
Proprietà pubblica | Id | ID unico del record.
Proprietà pubblica | OldDoc | DedDoc di partenza.
Proprietà pubblica | ParentPath | Percorso del file padre.
Proprietà pubblica | StartPath | Percorso del file di partenza.
Torna su
Vedi anche

Documentazione

Classe UpdateDocumentReferenceReferenceUpdateDescriptor
Namespace DedNet.Commands


Proprietà UpdateDocumentReference.ReferenceUpdateDescriptor.DestPath

Proprietà UpdateDocumentReferenceReferenceUpdateDescriptorDestPath
Percorso del file di destinazione.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string DestPath { get; }
Public ReadOnly Property DestPath As String
    Get
public:
property String^ DestPath {
    String^ get ();
}
member DestPath : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe UpdateDocumentReferenceReferenceUpdateDescriptor
Namespace DedNet.Commands


Proprietà UpdateDocumentReference.ReferenceUpdateDescriptor.Id

Proprietà UpdateDocumentReferenceReferenceUpdateDescriptorId
ID unico del record.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Id { get; }
Public ReadOnly Property Id As String
    Get
public:
property String^ Id {
    String^ get ();
}
member Id : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe UpdateDocumentReferenceReferenceUpdateDescriptor
Namespace DedNet.Commands


Proprietà UpdateDocumentReference.ReferenceUpdateDescriptor.OldDoc

Proprietà UpdateDocumentReferenceReferenceUpdateDescriptorOldDoc
DedDoc di partenza.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDoc OldDoc { get; }
Public ReadOnly Property OldDoc As DedDoc
    Get
public:
property DedDoc^ OldDoc {
    DedDoc^ get ();
}
member OldDoc : DedDoc with get

Valore della proprietà

DedDoc
Vedi anche

Documentazione

Classe UpdateDocumentReferenceReferenceUpdateDescriptor
Namespace DedNet.Commands


Proprietà UpdateDocumentReference.ReferenceUpdateDescriptor.ParentPath

Proprietà UpdateDocumentReferenceReferenceUpdateDescriptorParentPath
Percorso del file padre.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string ParentPath { get; }
Public ReadOnly Property ParentPath As String
    Get
public:
property String^ ParentPath {
    String^ get ();
}
member ParentPath : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe UpdateDocumentReferenceReferenceUpdateDescriptor
Namespace DedNet.Commands


Proprietà UpdateDocumentReference.ReferenceUpdateDescriptor.StartPath

Proprietà UpdateDocumentReferenceReferenceUpdateDescriptorStartPath
Percorso del file di partenza.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string StartPath { get; }
Public ReadOnly Property StartPath As String
    Get
public:
property String^ StartPath {
    String^ get ();
}
member StartPath : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe UpdateDocumentReferenceReferenceUpdateDescriptor
Namespace DedNet.Commands


Metodi di ReferenceUpdateDescriptor

Il tipo UpdateDocumentReferenceReferenceUpdateDescriptor espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | Ridefinizione di uguaglianza. (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetHashCode | Restituisce l'HashCode di questo oggetto. (Sovrascrive ObjectGetHashCode)
Torna su
Vedi anche

Documentazione

Classe UpdateDocumentReferenceReferenceUpdateDescriptor
Namespace DedNet.Commands


Metodo UpdateDocumentReference.ReferenceUpdateDescriptor.Equals

Metodo UpdateDocumentReferenceReferenceUpdateDescriptorEquals
Ridefinizione di uguaglianza.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj Object
Oggetto da confrontare.

Valore di ritorno

Boolean
Restituisce true se l'oggetto è uguale a questo.
Vedi anche

Documentazione

Classe UpdateDocumentReferenceReferenceUpdateDescriptor
Namespace DedNet.Commands


Metodo UpdateDocumentReference.ReferenceUpdateDescriptor.GetHashCode

Metodo UpdateDocumentReferenceReferenceUpdateDescriptorGetHashCode
Restituisce l'HashCode di questo oggetto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe UpdateDocumentReferenceReferenceUpdateDescriptor
Namespace DedNet.Commands


ReferenceUpdateDescriptor Operators

Il tipo UpdateDocumentReferenceReferenceUpdateDescriptor espone i seguenti membri.

Operatori
Nome | Descrizione
Equality(UpdateDocumentReferenceReferenceUpdateDescriptor, UpdateDocumentReferenceReferenceUpdateDescriptor) | Ridefinizione dell'operatore ==.
Inequality(UpdateDocumentReferenceReferenceUpdateDescriptor, UpdateDocumentReferenceReferenceUpdateDescriptor) | Ridefinizione dell'operatore !=.
Torna su
Vedi anche

Documentazione

Classe UpdateDocumentReferenceReferenceUpdateDescriptor
Namespace DedNet.Commands


UpdateDocumentReference.ReferenceUpdateDescriptor.Equality Operatore

UpdateDocumentReferenceReferenceUpdateDescriptorEquality Operatore
Ridefinizione dell'operatore ==.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool operator ==(
    UpdateDocumentReferenceReferenceUpdateDescriptor a,
    UpdateDocumentReferenceReferenceUpdateDescriptor b
)
Public Shared Operator = (
    a As UpdateDocumentReferenceReferenceUpdateDescriptor,
    b As UpdateDocumentReferenceReferenceUpdateDescriptor
) As Boolean
public:
static bool operator ==(
    UpdateDocumentReferenceReferenceUpdateDescriptor^ a,
    UpdateDocumentReferenceReferenceUpdateDescriptor^ b
)
static let inline (=)
        a : UpdateDocumentReferenceReferenceUpdateDescriptor *
        b : UpdateDocumentReferenceReferenceUpdateDescriptor  : bool

Parametri

a UpdateDocumentReferenceReferenceUpdateDescriptor
b UpdateDocumentReferenceReferenceUpdateDescriptor

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe UpdateDocumentReferenceReferenceUpdateDescriptor
Namespace DedNet.Commands


UpdateDocumentReference.ReferenceUpdateDescriptor.Inequality Operatore

UpdateDocumentReferenceReferenceUpdateDescriptorInequality Operatore
Ridefinizione dell'operatore !=.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool operator !=(
    UpdateDocumentReferenceReferenceUpdateDescriptor a,
    UpdateDocumentReferenceReferenceUpdateDescriptor b
)
Public Shared Operator <> (
    a As UpdateDocumentReferenceReferenceUpdateDescriptor,
    b As UpdateDocumentReferenceReferenceUpdateDescriptor
) As Boolean
public:
static bool operator !=(
    UpdateDocumentReferenceReferenceUpdateDescriptor^ a,
    UpdateDocumentReferenceReferenceUpdateDescriptor^ b
)
static let inline (<>)
        a : UpdateDocumentReferenceReferenceUpdateDescriptor *
        b : UpdateDocumentReferenceReferenceUpdateDescriptor  : bool

Parametri

a UpdateDocumentReferenceReferenceUpdateDescriptor
b UpdateDocumentReferenceReferenceUpdateDescriptor

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe UpdateDocumentReferenceReferenceUpdateDescriptor
Namespace DedNet.Commands


Classe UpdateOldRevCommand
Classe che rappresenta il comando per aggiornare le vecchie revisioni.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsUpdateOldRevCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class UpdateOldRevCommand : DedCommand
Public Class UpdateOldRevCommand
    Inherits DedCommand
public ref class UpdateOldRevCommand : public DedCommand
type UpdateOldRevCommand =
    class
        inherit DedCommand
    end

Il tipo UpdateOldRevCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | ElementList | Imposta la lista di elementi da valutare.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | ResultList | Restituisce la lista di elementi da aggiornare.
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowOnly | Imposta il form in visualizzazione.
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | AggiornaRevEvent |
Evento pubblico | Apri |
Evento pubblico | ApriPadre |
Evento pubblico | Individua |
Evento pubblico | TrovaDipendenze |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di UpdateOldRevCommand

Il tipo UpdateOldRevCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | ElementList | Imposta la lista di elementi da valutare.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | ResultList | Restituisce la lista di elementi da aggiornare.
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | ShowOnly | Imposta il form in visualizzazione.
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe UpdateOldRevCommand
Namespace DedNet.Commands


Proprietà UpdateOldRevCommand.ElementList

Proprietà UpdateOldRevCommandElementList
Imposta la lista di elementi da valutare.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ListObjToUpdate ElementList { get; }
Public ReadOnly Property ElementList As ListObjToUpdate
    Get
public:
property ListObjToUpdate^ ElementList {
    ListObjToUpdate^ get ();
}
member ElementList : ListObjToUpdate with get

Valore della proprietà

ListObjToUpdate
Vedi anche

Documentazione

Classe UpdateOldRevCommand
Namespace DedNet.Commands


Proprietà UpdateOldRevCommand.NeedParameters

Proprietà UpdateOldRevCommandNeedParameters

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe UpdateOldRevCommand
Namespace DedNet.Commands


Proprietà UpdateOldRevCommand.ResultList

Proprietà UpdateOldRevCommandResultList
Restituisce la lista di elementi da aggiornare.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ListObjToUpdate ResultList { get; }
Public ReadOnly Property ResultList As ListObjToUpdate
    Get
public:
property ListObjToUpdate^ ResultList {
    ListObjToUpdate^ get ();
}
member ResultList : ListObjToUpdate with get

Valore della proprietà

ListObjToUpdate
Vedi anche

Documentazione

Classe UpdateOldRevCommand
Namespace DedNet.Commands


Proprietà UpdateOldRevCommand.ShowOnly

Proprietà UpdateOldRevCommandShowOnly
Imposta il form in visualizzazione.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ShowOnly { set; }
Public WriteOnly Property ShowOnly As Boolean
    Set
public:
property bool ShowOnly {
    void set (bool value);
}
member ShowOnly : bool with set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe UpdateOldRevCommand
Namespace DedNet.Commands


Metodi di UpdateOldRevCommand

Il tipo UpdateOldRevCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe UpdateOldRevCommand
Namespace DedNet.Commands


Metodo UpdateOldRevCommand.ClearCommand

Metodo UpdateOldRevCommandClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe UpdateOldRevCommand
Namespace DedNet.Commands


Metodo UpdateOldRevCommand.Enabled

Metodo UpdateOldRevCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe UpdateOldRevCommand
Namespace DedNet.Commands


Metodo UpdateOldRevCommand.ExecuteCommand

Metodo UpdateOldRevCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe UpdateOldRevCommand
Namespace DedNet.Commands


Metodo UpdateOldRevCommand.SetContext

Metodo UpdateOldRevCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe UpdateOldRevCommand
Namespace DedNet.Commands


Eventi di UpdateOldRevCommand

Il tipo UpdateOldRevCommand espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | AggiornaRevEvent |
Evento pubblico | Apri |
Evento pubblico | ApriPadre |
Evento pubblico | Individua |
Evento pubblico | TrovaDipendenze |
Torna su
Vedi anche

Documentazione

Classe UpdateOldRevCommand
Namespace DedNet.Commands


Evento UpdateOldRevCommand.AggiornaRevEvent

Evento UpdateOldRevCommandAggiornaRevEvent

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event DedFormUpdateOldRevViewResult AggiornaRevEvent
Public Event AggiornaRevEvent As DedFormUpdateOldRevViewResult
public:
 event DedFormUpdateOldRevViewResult^ AggiornaRevEvent {
    void add (DedFormUpdateOldRevViewResult^ value);
    void remove (DedFormUpdateOldRevViewResult^ value);
}
member AggiornaRevEvent : IEvent<DedFormUpdateOldRevViewResult,
    EventArgs>

Valore

DedFormUpdateOldRevViewResult
Vedi anche

Documentazione

Classe UpdateOldRevCommand
Namespace DedNet.Commands


Evento UpdateOldRevCommand.Apri

Evento UpdateOldRevCommandApri

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event DedFormUpdateOldRevAction Apri
Public Event Apri As DedFormUpdateOldRevAction
public:
 event DedFormUpdateOldRevAction^ Apri {
    void add (DedFormUpdateOldRevAction^ value);
    void remove (DedFormUpdateOldRevAction^ value);
}
member Apri : IEvent<DedFormUpdateOldRevAction,
    EventArgs>

Valore

DedFormUpdateOldRevAction
Vedi anche

Documentazione

Classe UpdateOldRevCommand
Namespace DedNet.Commands


Evento UpdateOldRevCommand.ApriPadre

Evento UpdateOldRevCommandApriPadre

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event DedFormUpdateOldRevAction ApriPadre
Public Event ApriPadre As DedFormUpdateOldRevAction
public:
 event DedFormUpdateOldRevAction^ ApriPadre {
    void add (DedFormUpdateOldRevAction^ value);
    void remove (DedFormUpdateOldRevAction^ value);
}
member ApriPadre : IEvent<DedFormUpdateOldRevAction,
    EventArgs>

Valore

DedFormUpdateOldRevAction
Vedi anche

Documentazione

Classe UpdateOldRevCommand
Namespace DedNet.Commands


Evento UpdateOldRevCommand.Individua

Evento UpdateOldRevCommandIndividua

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event DedFormUpdateOldRevAction Individua
Public Event Individua As DedFormUpdateOldRevAction
public:
 event DedFormUpdateOldRevAction^ Individua {
    void add (DedFormUpdateOldRevAction^ value);
    void remove (DedFormUpdateOldRevAction^ value);
}
member Individua : IEvent<DedFormUpdateOldRevAction,
    EventArgs>

Valore

DedFormUpdateOldRevAction
Vedi anche

Documentazione

Classe UpdateOldRevCommand
Namespace DedNet.Commands


Evento UpdateOldRevCommand.TrovaDipendenze

Evento UpdateOldRevCommandTrovaDipendenze

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event DedFormUpdateOldRevAction TrovaDipendenze
Public Event TrovaDipendenze As DedFormUpdateOldRevAction
public:
 event DedFormUpdateOldRevAction^ TrovaDipendenze {
    void add (DedFormUpdateOldRevAction^ value);
    void remove (DedFormUpdateOldRevAction^ value);
}
member TrovaDipendenze : IEvent<DedFormUpdateOldRevAction,
    EventArgs>

Valore

DedFormUpdateOldRevAction
Vedi anche

Documentazione

Classe UpdateOldRevCommand
Namespace DedNet.Commands


Classe UpdateSparePartsBoms
Comando utilizzato per aggiornare le distinte ricambio con i nuovi valori di anagrafica.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsUpdateSparePartsBoms

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class UpdateSparePartsBoms : DedCommand
Public Class UpdateSparePartsBoms
    Inherits DedCommand
public ref class UpdateSparePartsBoms : public DedCommand
type UpdateSparePartsBoms =
    class
        inherit DedCommand
    end

Il tipo UpdateSparePartsBoms espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve essere impostata la struttura di salvataggio distinta. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Recursive | Indica se l'aggiornamento deve propagarsi anche per le distinte figlie. Di default è true;
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Esegue la pulizia del comando. Azzera tutte le variabili. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). Restituisce sempre false perché non è direttamente chiamato dall'utente. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Restituisce sempre false perché non è direttamente chiamato dall'utente. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Campi
 | Nome | Descrizione
Campo pubblico | _recursive | Indica se l'aggiornamento deve propagarsi anche per le distinte figlie. Di default è true;
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di UpdateSparePartsBoms

Il tipo UpdateSparePartsBoms espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve essere impostata la struttura di salvataggio distinta. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Recursive | Indica se l'aggiornamento deve propagarsi anche per le distinte figlie. Di default è true;
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe UpdateSparePartsBoms
Namespace DedNet.Commands


Proprietà UpdateSparePartsBoms.NeedParameters

Proprietà UpdateSparePartsBomsNeedParameters
Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve essere impostata la struttura di salvataggio distinta.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe UpdateSparePartsBoms
Namespace DedNet.Commands


Proprietà UpdateSparePartsBoms.Recursive

Proprietà UpdateSparePartsBomsRecursive
Indica se l'aggiornamento deve propagarsi anche per le distinte figlie. Di default è true;

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Recursive { get; set; }
Public Property Recursive As Boolean
    Get
    Set
public:
property bool Recursive {
    bool get ();
    void set (bool value);
}
member Recursive : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe UpdateSparePartsBoms
Namespace DedNet.Commands


Metodi di UpdateSparePartsBoms

Il tipo UpdateSparePartsBoms espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Esegue la pulizia del comando. Azzera tutte le variabili. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). Restituisce sempre false perché non è direttamente chiamato dall'utente. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Restituisce sempre false perché non è direttamente chiamato dall'utente. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe UpdateSparePartsBoms
Namespace DedNet.Commands


Metodo UpdateSparePartsBoms.ClearCommand

Metodo UpdateSparePartsBomsClearCommand
Esegue la pulizia del comando. Azzera tutte le variabili.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe UpdateSparePartsBoms
Namespace DedNet.Commands


Metodo UpdateSparePartsBoms.Enabled

Metodo UpdateSparePartsBomsEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). Restituisce sempre false perché non è direttamente chiamato dall'utente.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext commandContext
)
Public Overrides Function Enabled (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ commandContext
) override
abstract Enabled :
        commandContext : DedCommandContext -> bool
override Enabled :
        commandContext : DedCommandContext -> bool

Parametri

commandContext DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe UpdateSparePartsBoms
Namespace DedNet.Commands


Metodo UpdateSparePartsBoms.ExecuteCommand

Metodo UpdateSparePartsBomsExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe UpdateSparePartsBoms
Namespace DedNet.Commands


Metodo UpdateSparePartsBoms.SetContext

Metodo UpdateSparePartsBomsSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Restituisce sempre false perché non è direttamente chiamato dall'utente.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext commandContext
)
Public Overrides Function SetContext (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ commandContext
) override
abstract SetContext :
        commandContext : DedCommandContext -> bool
override SetContext :
        commandContext : DedCommandContext -> bool

Parametri

commandContext DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe UpdateSparePartsBoms
Namespace DedNet.Commands


Campi di UpdateSparePartsBoms

Il tipo UpdateSparePartsBoms espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | _recursive | Indica se l'aggiornamento deve propagarsi anche per le distinte figlie. Di default è true;
Torna su
Vedi anche

Documentazione

Classe UpdateSparePartsBoms
Namespace DedNet.Commands


Campo UpdateSparePartsBoms._recursive

Campo UpdateSparePartsBoms_recursive
Indica se l'aggiornamento deve propagarsi anche per le distinte figlie. Di default è true;

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool _recursive
Public _recursive As Boolean
public:
bool _recursive
val mutable _recursive: bool

Valore del campo

Boolean
Vedi anche

Documentazione

Classe UpdateSparePartsBoms
Namespace DedNet.Commands


Classe UsersCommand
Classe che rappresenta il comando per editare gli utenti e i permessi.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsUsersCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class UsersCommand : DedCommand
Public Class UsersCommand
    Inherits DedCommand
public ref class UsersCommand : public DedCommand
type UsersCommand =
    class
        inherit DedCommand
    end

Il tipo UsersCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di UsersCommand

Il tipo UsersCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe UsersCommand
Namespace DedNet.Commands


Proprietà UsersCommand.NeedParameters

Proprietà UsersCommandNeedParameters

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe UsersCommand
Namespace DedNet.Commands


Metodi di UsersCommand

Il tipo UsersCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe UsersCommand
Namespace DedNet.Commands


Metodo UsersCommand.ClearCommand

Metodo UsersCommandClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe UsersCommand
Namespace DedNet.Commands


Metodo UsersCommand.Enabled

Metodo UsersCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe UsersCommand
Namespace DedNet.Commands


Metodo UsersCommand.ExecuteCommand

Metodo UsersCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe UsersCommand
Namespace DedNet.Commands


Metodo UsersCommand.SetContext

Metodo UsersCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe UsersCommand
Namespace DedNet.Commands


Classe VarsCommand
Classe che rappresenta il comando per editare le variabili.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsVarsCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class VarsCommand : DedCommand
Public Class VarsCommand
    Inherits DedCommand
public ref class VarsCommand : public DedCommand
type VarsCommand =
    class
        inherit DedCommand
    end

Il tipo VarsCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di VarsCommand

Il tipo VarsCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe VarsCommand
Namespace DedNet.Commands


Proprietà VarsCommand.NeedParameters

Proprietà VarsCommandNeedParameters

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe VarsCommand
Namespace DedNet.Commands


Metodi di VarsCommand

Il tipo VarsCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe VarsCommand
Namespace DedNet.Commands


Metodo VarsCommand.ClearCommand

Metodo VarsCommandClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe VarsCommand
Namespace DedNet.Commands


Metodo VarsCommand.Enabled

Metodo VarsCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe VarsCommand
Namespace DedNet.Commands


Metodo VarsCommand.ExecuteCommand

Metodo VarsCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe VarsCommand
Namespace DedNet.Commands


Metodo VarsCommand.SetContext

Metodo VarsCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe VarsCommand
Namespace DedNet.Commands


Classe ViewCommCommand
Comando visuliazziazione di una commessa.
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsViewCommCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ViewCommCommand : DedCommand
Public Class ViewCommCommand
    Inherits DedCommand
public ref class ViewCommCommand : public DedCommand
type ViewCommCommand =
    class
        inherit DedCommand
    end

Il tipo ViewCommCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Comm | Commessa da modificare.
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommData | Restituisce il dizionario utilizzato dal Form per la modifica della commessa. Inizialmente è null, ed è impostato al runtime dal comando durante l'elaborazione, leggendo i dati dalla commessa da modificare.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se la commessa da modificare non è disponibile. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di ViewCommCommand

Il tipo ViewCommCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | Comm | Commessa da modificare.
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommData | Restituisce il dizionario utilizzato dal Form per la modifica della commessa. Inizialmente è null, ed è impostato al runtime dal comando durante l'elaborazione, leggendo i dati dalla commessa da modificare.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | Restituisce true se la commessa da modificare non è disponibile. (Sovrascrive DedCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ViewCommCommand
Namespace DedNet.Commands


Proprietà ViewCommCommand.Comm

Proprietà ViewCommCommandComm
Commessa da modificare.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedComm Comm { get; set; }
Public Property Comm As DedComm
    Get
    Set
public:
property DedComm^ Comm {
    DedComm^ get ();
    void set (DedComm^ value);
}
member Comm : DedComm with get, set

Valore della proprietà

DedComm
Vedi anche

Documentazione

Classe ViewCommCommand
Namespace DedNet.Commands


Proprietà ViewCommCommand.CommData

Proprietà ViewCommCommandCommData
Restituisce il dizionario utilizzato dal Form per la modifica della commessa. Inizialmente è null, ed è impostato al runtime dal comando durante l'elaborazione, leggendo i dati dalla commessa da modificare.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDictionary CommData { get; }
Public ReadOnly Property CommData As DedDictionary
    Get
public:
property DedDictionary^ CommData {
    DedDictionary^ get ();
}
member CommData : DedDictionary with get

Valore della proprietà

DedDictionary
Vedi anche

Documentazione

Classe ViewCommCommand
Namespace DedNet.Commands


Proprietà ViewCommCommand.NeedParameters

Proprietà ViewCommCommandNeedParameters
Restituisce true se la commessa da modificare non è disponibile.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ViewCommCommand
Namespace DedNet.Commands


Metodi di ViewCommCommand

Il tipo ViewCommCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il Comando. (Sovrascrive DedCommandClearCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova. (Sovrascrive DedCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova. (Sovrascrive DedCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe ViewCommCommand
Namespace DedNet.Commands


Metodo ViewCommCommand.ClearCommand

Metodo ViewCommCommandClearCommand
Azzera il Comando.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe ViewCommCommand
Namespace DedNet.Commands


Metodo ViewCommCommand.Enabled

Metodo ViewCommCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe ViewCommCommand
Namespace DedNet.Commands


Metodo ViewCommCommand.ExecuteCommand

Metodo ViewCommCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe ViewCommCommand
Namespace DedNet.Commands


Metodo ViewCommCommand.SetContext

Metodo ViewCommCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Si accontenta di avere l'anagrafica dalla quale partire per creare la nuova.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto c'è una sola anagrafica alla quale associare il file.
Vedi anche

Documentazione

Classe ViewCommCommand
Namespace DedNet.Commands


Classe VisualDepCommand
Comando che visualizza in un diagramma le dipendenza tra i documenti
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsDedDocumentCommand
DedNet.CommandsVisualDepCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class VisualDepCommand : DedDocumentCommand
Public Class VisualDepCommand
    Inherits DedDocumentCommand
public ref class VisualDepCommand : public DedDocumentCommand
type VisualDepCommand =
    class
        inherit DedDocumentCommand
    end

Il tipo VisualDepCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DocumentInfos | Restituisce la lista dei documenti con abbinato il contesto di anagrafica di elaborazione comando. (Ereditato da DedDocumentCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedDocumentCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Reinizializza il comando. (Ereditato da DedDocumentCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedDocumentCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedDocumentCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedDocumentCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedDocumentCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di VisualDepCommand

Il tipo VisualDepCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DocumentInfos | Restituisce la lista dei documenti con abbinato il contesto di anagrafica di elaborazione comando. (Ereditato da DedDocumentCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedDocumentCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe VisualDepCommand
Namespace DedNet.Commands


Proprietà VisualDepCommand.NeedParameters

Proprietà VisualDepCommandNeedParameters

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe VisualDepCommand
Namespace DedNet.Commands


Metodi di VisualDepCommand

Il tipo VisualDepCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Reinizializza il comando. (Ereditato da DedDocumentCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedDocumentCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedDocumentCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedDocumentCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedDocumentCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe VisualDepCommand
Namespace DedNet.Commands


Metodo VisualDepCommand.Enabled

Metodo VisualDepCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe VisualDepCommand
Namespace DedNet.Commands


Metodo VisualDepCommand.ExecuteCommand

Metodo VisualDepCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe VisualDepCommand
Namespace DedNet.Commands


Metodo VisualDepCommand.SetContext

Metodo VisualDepCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe VisualDepCommand
Namespace DedNet.Commands


Classe WhereUsedCommand
Classe che rappresenta il comando per visualizzare tutti i padri di un determinato documento ( ovvero dove viene usato in altri documenti ).
Gerarchia di ereditarietà
SystemObject
DedNet.CommandsDedCommand
DedNet.CommandsDedDocumentCommand
DedNet.CommandsWhereUsedCommand

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class WhereUsedCommand : DedDocumentCommand
Public Class WhereUsedCommand
    Inherits DedDocumentCommand
public ref class WhereUsedCommand : public DedDocumentCommand
type WhereUsedCommand =
    class
        inherit DedDocumentCommand
    end

Il tipo WhereUsedCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DocumentInfos | Restituisce la lista dei documenti con abbinato il contesto di anagrafica di elaborazione comando. (Ereditato da DedDocumentCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedDocumentCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Reinizializza il comando. (Ereditato da DedDocumentCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedDocumentCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedDocumentCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedDocumentCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedDocumentCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Commands


Proprietà di WhereUsedCommand

Il tipo WhereUsedCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand)
Proprietà pubblica | DocumentInfos | Restituisce la lista dei documenti con abbinato il contesto di anagrafica di elaborazione comando. (Ereditato da DedDocumentCommand)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand)
Proprietà pubblica | NeedParameters | (Sovrascrive DedDocumentCommandNeedParameters)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe WhereUsedCommand
Namespace DedNet.Commands


Proprietà WhereUsedCommand.NeedParameters

Proprietà WhereUsedCommandNeedParameters

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe WhereUsedCommand
Namespace DedNet.Commands


Metodi di WhereUsedCommand

Il tipo WhereUsedCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Reinizializza il comando. (Ereditato da DedDocumentCommand)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedDocumentCommandEnabled(DedCommandContext))
Metodo pubblico | Equals | (Ereditato da DedCommand)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedDocumentCommandExecuteCommand)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedDocumentCommand)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedDocumentCommandSetContext(DedCommandContext))
Metodo pubblico | ToString | (Ereditato da DedCommand)
Torna su
Vedi anche

Documentazione

Classe WhereUsedCommand
Namespace DedNet.Commands


Metodo WhereUsedCommand.Enabled

Metodo WhereUsedCommandEnabled
Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione.

Valore di ritorno

Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe WhereUsedCommand
Namespace DedNet.Commands


Metodo WhereUsedCommand.ExecuteCommand

Metodo WhereUsedCommandExecuteCommand
Esegue il comando vero e proprio.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe WhereUsedCommand
Namespace DedNet.Commands


Metodo WhereUsedCommand.SetContext

Metodo WhereUsedCommandSetContext
Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNet.Commands
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe WhereUsedCommand
Namespace DedNet.Commands


DedNet.Controls Namespace
Spazio dei nomi contenente tutte le classi dedicate ai controlli utente.
Classi
 | Classe | Descrizione
Classe pubblica | BinderItem | Singola riga del ControlBinder.
Classe pubblica | ComboItem | Classe usata per gestire i casi con valore-descrizione es : 100-Lavorazione
Classe pubblica | ControlBinder | Classe che rappresenta il datasource di un ListBox. Uso questo in modo da poter gestire facilmente l'icona della ridefinizione.
Classe pubblica | CustomImageListBoxControl | ImageListBoxControl Custom che permette di impostare l'indice selezionato a -1 al cambio di datasource.
Classe pubblica | CustomProcessNewValueEventArgs | Oggetto EventArgs dedicato alla gestione dell'evento ProcessNewValue. Impostare la proprietà "ListItemToAdd" per aggiungere i codici nel menu a tendina.
Classe pubblica | DedAnagrViewControl | Classe per visualizzare e gestire il risultato di una ricerca
Classe pubblica | DedAnagrViewControlDedAnagrEventArgs | Classe contenente le informazioni per l'evento SelectionChanged.
Classe pubblica | DedAnagrViewControlFilterEventArgs | Classe per la gestione del filtro effettuato dopo la ricerca.
Classe pubblica | DedBomExplorerControl |
Classe pubblica | DedBomExplorerControlContextCreatedEventArgs | EventArgs utilizzato per modificare il contesto da utilizzare per la generazione del menu contestuale.
Classe pubblica | DedBomExplorerControlDedDataListEventArgs | Classe Data List Argument
Classe pubblica | DedBomExplorerControlLoadedDataEventArgs | Classe Loaded Data
Classe pubblica | DedBomExplorerControlSelectedDedDataEventArgs | Classe Selected Ded Data
Classe pubblica | DedButtonClickEventArgs | EventArgs dell'evento DedButtonClickEvent.
Classe pubblica | DedCascadeViewControl | Controllo che visualizza l'albero delle cascate.
Classe pubblica | DedComboBox |
Classe pubblica | DedComboBoxPainter |
Classe pubblica | DedComboBoxPopupForm |
Classe pubblica | DedComboBoxViewInfo |
Classe pubblica | DedCommAnagExplorer |
Classe pubblica | DedCommAnagExplorerCommAnagWrapper | Gestione visualizzazione singola commessa
Classe pubblica | DedCommAnagExplorerTagStructure |
Classe pubblica | DedCommStructExplorer |
Classe pubblica | DedCommStructExplorerDedOverrideRepositoryIconCommEventArgs | Argomento utilizzato per override delle repository sulle commesse.
Classe pubblica | DedCommStructExplorerDedOverrideStatusIconCommEventArgs | Argomento utilizzato per override delle icone sulle commesse.
Classe pubblica | DedCommStructExplorerSelectedCommEventArgs | Classe Selected Comm
Classe pubblica | DedCustomDependency | Oggetto utilizzato per visualizzare a schermo una struttura gerarchica di tipo generico.
Classe pubblica | DedDependenciesControl | Controllo utilizzato per visualizzare una struttura gerarchica di dipendenze generiche.
Classe pubblica | DedDependenciesControlMyTreeListDedDependencies | Ridefinito l'albero in modo da espandere i nodi durante la ricerca.
Classe pubblica | DedDistControl | Controllo per la visualizzazione della struttura della distinta
Classe pubblica | DedDistControlBomSelInfo | Classe che definisce l'oggetto selezionato
Classe pubblica | DedDistControlBomSelInfoList | Lista contenente la selezione attuale
Classe pubblica | DedDistControlCoordinateValue | Classe usata per scrivere il valore nella cella excel
Classe pubblica | DedDistControlDedBomAnagrEventArgs | Classe gestione argomenti
Classe pubblica | DedDistControlDedBomEventArgs | Classe derivata da EventArgs
Classe pubblica | DedDocControl | Controllo per la gesitione della visualizzazione dei file primari/allegati
Classe pubblica | DedDocControlDedDocControlEventArgs | Gestisce gli eventi che necessitano di conoscere i documenti selezionati.
Classe pubblica | DedDocControlNotifyDocStatusChangedEventArgs | Gestisce gli eventi che necessitano di sapere se ad un determinato documento è stato cambiato lo stato documentale
Classe pubblica | DedDropDownButtonControl | Classe per gestire un controllo di tipo DropDown ( bottone con menu a tendina )
Classe pubblica | DedEcoViewControl | Controllo rappresentante gli ECO
Classe pubblica | DedEditAnagrControl | Controllo di editazione e visualizzazione degli attributi.
Classe pubblica | DedFileExplorerControl | Controllo usato come esplora risorse per il Gestore Commesse.
Classe pubblica | DedFindCodeControl |
Classe pubblica | DedFindCommControl |
Classe pubblica | DedFindCommControlDedCommControlTextChangedEventArgs | Gestisce gli eventi che necessitano di conoscere i documenti selezionati.
Classe pubblica | DedFontEdit | Controllo DedFontEdit.
Classe pubblica | DedGridControl |
Classe pubblica | DedOkCancelControl | Classe che implementa il controllo di due bottoni ( ok , cancel )
Classe pubblica | DedPreviewControl | Classe che gestisce l'anteprima di un file e la sua eventuale immagine anteprima ingrandita.
Classe pubblica | DedRootExplorerControl |
Classe pubblica | DedSearchControl | Classe rappresentante il controllo per la ricerca
Classe pubblica | DedSearchControlChangeVisibleFieldsEventArgs | Classe per la gestione dell'event args
Classe pubblica | DedSelectedIndexEventArgs | EventArgs dell'evento DedSelectedIndexEvent.
Classe pubblica | DedTextSpinEdit |
Classe pubblica | DedTextSpinEditPainter |
Classe pubblica | DedTextSpinEditPopupForm |
Classe pubblica | DedTextSpinEditViewInfo |
Classe pubblica | DedTypeTreeControl | Controllo per la visualizzazione delle famiglie di archiviazione
Classe pubblica | EcoFocusChanged | Classe usata per gestire l'evento di FocusedRowChanged della griglia.
Classe pubblica | Filter | Classe rappresentante l'oggetto per la ricerca
Classe pubblica | FilterList |
Classe pubblica | Item |
Classe pubblica | ManageAnagrControl | Classe per la gestione del raccoglitore di anagrafiche
Classe pubblica | MyAnagrViewGridControl |
Classe pubblica | MyDataRow | Riga del datasource con tag anagrafica aggiuntivo.
Classe pubblica | MyDataTable | Datasource da bindare alla griglia.
Classe pubblica | MyTreeList |
Classe pubblica | MyTreeListBom | Ridefinito l'albero in modo da espandere i nodi durante la ricerca.
Classe pubblica | MyTreeListRoot | Ridefinito l'albero in modo da espandere i nodi durante la ricerca.
Classe pubblica | ReloadDistNodes | Classe che scorre tutti i nodi e se ha la stessa anagrafica di quello di riferimento ne aggiorna i figli.
Classe pubblica | RepositoryItemDedComboBox |
Classe pubblica | RepositoryItemDedFontEdit | Oggetto repository per il funzionamento e la registrazione del controllo DedFontEdit.
Classe pubblica | RepositoryItemDedTextSpinEdit |
Classe pubblica | TreeListSafePaint |
Classe pubblica | UpdateHeaderNodes | Classe che scorre tutti i nodi e se ha la stessa anagrafica di quello di riferimento ne aggiorna l'Header.
Classe pubblica | UpdateInfoNodes | Classe che scorre tutti i nodi e se ha la stessa anagrafica di quello di riferimento ne aggiorna i dati.
Classe pubblica | UserControlBase |
Delegate
 | Delegate | Descrizione
Delegate pubblico | DedDistControlDedBomEventDelegate | Definizione del Delegate da utilizzare per gli eventi.
Delegate pubblico | DedSearchControlChangeVisibleFieldsEventHandler |
Enumerazioni
 | Enumerazione | Descrizione
Enumerazione pubblica | DedBomExplorerControlDedBomExplorerBehaviourEnum | Enumerazioni dei possibili comportamenti del controllo
Enumerazione pubblica | DedBomExplorerControlDropTargetControlsEnum | Enumerazione dei possibili target del drop sul controllo
Enumerazione pubblica | DedBomExplorerControllkuComboBehaviouyrEnum | Enumerazioni dei possibili comportamenti del lookUpEdit delle anagrafiche
Enumerazione pubblica | DedDistControlAddNodeActionEnum | Enumerazione sull'azione in aggiunta del nodo
Enumerazione pubblica | DedDistControlDedCompareDistEnum | Enumerazione sugli stati possibili in confronto delle distinta
Enumerazione pubblica | DedFindCodeControlFonteDati | Fonte dati selezionata.


Classe BinderItem
Singola riga del ControlBinder.
Gerarchia di ereditarietà
SystemObject
DedNet.ControlsBinderItem

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class BinderItem
Public Class BinderItem
public ref class BinderItem
type BinderItem = class end

Il tipo BinderItem espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | BinderItem | Costruttore unico.
Metodo pubblico | BinderItem(String) | Costruttore unico.
Metodo pubblico | BinderItem(Image, String) | Costruttore unico.
Metodo pubblico | BinderItem(Image, String, DedAttr) | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Attr | Attributo rappresentato da questo item.
Proprietà pubblica | Icon | Icona della ridefinizione.
Proprietà pubblica | Value | Valore (nome) da mostrare.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore BinderItem
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | BinderItem | Costruttore unico.
Metodo pubblico | BinderItem(String) | Costruttore unico.
Metodo pubblico | BinderItem(Image, String) | Costruttore unico.
Metodo pubblico | BinderItem(Image, String, DedAttr) | Costruttore unico.
Torna su
Vedi anche

Documentazione

Classe BinderItem
Namespace DedNet.Controls


Costruttore BinderItem
Costruttore unico.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BinderItem()
Public Sub New
public:
BinderItem()
new : unit -> BinderItem
Vedi anche

Documentazione

Classe BinderItem
Overload di BinderItem
Namespace DedNet.Controls


Costruttore BinderItem(String)
Costruttore unico.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BinderItem(
    string value
)
Public Sub New (
    value As String
)
public:
BinderItem(
    String^ value
)
new :
        value : string -> BinderItem

Parametri

value String
Valore (nome) da mostrare.
Vedi anche

Documentazione

Classe BinderItem
Overload di BinderItem
Namespace DedNet.Controls


Costruttore BinderItem(Image, String)
Costruttore unico.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BinderItem(
    Image icon,
    string value
)
Public Sub New (
    icon As Image,
    value As String
)
public:
BinderItem(
    Image^ icon,
    String^ value
)
new :
        icon : Image *
        value : string -> BinderItem

Parametri

icon Image
Icona della ridefinizione.
value String
Valore (nome) da mostrare.
Vedi anche

Documentazione

Classe BinderItem
Overload di BinderItem
Namespace DedNet.Controls


Costruttore BinderItem(Image, String, DedAttr)
Costruttore unico.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BinderItem(
    Image icon,
    string value,
    DedAttr attr
)
Public Sub New (
    icon As Image,
    value As String,
    attr As DedAttr
)
public:
BinderItem(
    Image^ icon,
    String^ value,
    DedAttr^ attr
)
new :
        icon : Image *
        value : string *
        attr : DedAttr -> BinderItem

Parametri

icon Image
Icona della ridefinizione.
value String
Valore (nome) da mostrare.
attr DedAttr
Attributo rappresentato da questo item.
Vedi anche

Documentazione

Classe BinderItem
Overload di BinderItem
Namespace DedNet.Controls


Proprietà di BinderItem

Il tipo BinderItem espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Attr | Attributo rappresentato da questo item.
Proprietà pubblica | Icon | Icona della ridefinizione.
Proprietà pubblica | Value | Valore (nome) da mostrare.
Torna su
Vedi anche

Documentazione

Classe BinderItem
Namespace DedNet.Controls


Proprietà BinderItem.Attr

Proprietà BinderItemAttr
Attributo rappresentato da questo item.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttr Attr { get; set; }
Public Property Attr As DedAttr
    Get
    Set
public:
property DedAttr^ Attr {
    DedAttr^ get ();
    void set (DedAttr^ value);
}
member Attr : DedAttr with get, set

Valore della proprietà

DedAttr
Vedi anche

Documentazione

Classe BinderItem
Namespace DedNet.Controls


Proprietà BinderItem.Icon

Proprietà BinderItemIcon
Icona della ridefinizione.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Image Icon { get; set; }
Public Property Icon As Image
    Get
    Set
public:
property Image^ Icon {
    Image^ get ();
    void set (Image^ value);
}
member Icon : Image with get, set

Valore della proprietà

Image
Vedi anche

Documentazione

Classe BinderItem
Namespace DedNet.Controls


Proprietà BinderItem.Value

Proprietà BinderItemValue
Valore (nome) da mostrare.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}
member Value : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe BinderItem
Namespace DedNet.Controls


Classe ComboItem
Classe usata per gestire i casi con valore-descrizione es : 100-Lavorazione
Gerarchia di ereditarietà
SystemObject
DedNet.ControlsComboItem

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ComboItem
Public Class ComboItem
public ref class ComboItem
type ComboItem = class end

Il tipo ComboItem espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ComboItem | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Descrizione |
Proprietà pubblica | Valore |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore ComboItem
Costruttore

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ComboItem(
    string valore,
    string descrizione
)
Public Sub New (
    valore As String,
    descrizione As String
)
public:
ComboItem(
    String^ valore,
    String^ descrizione
)
new :
        valore : string *
        descrizione : string -> ComboItem

Parametri

valore String
campo valore
descrizione String
campo descrizione
Vedi anche

Documentazione

Classe ComboItem
Namespace DedNet.Controls


Proprietà di ComboItem

Il tipo ComboItem espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Descrizione |
Proprietà pubblica | Valore |
Torna su
Vedi anche

Documentazione

Classe ComboItem
Namespace DedNet.Controls


Proprietà ComboItem.Descrizione

Proprietà ComboItemDescrizione

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Descrizione { get; set; }
Public Property Descrizione As String
    Get
    Set
public:
property String^ Descrizione {
    String^ get ();
    void set (String^ value);
}
member Descrizione : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe ComboItem
Namespace DedNet.Controls


Proprietà ComboItem.Valore

Proprietà ComboItemValore

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Valore { get; set; }
Public Property Valore As String
    Get
    Set
public:
property String^ Valore {
    String^ get ();
    void set (String^ value);
}
member Valore : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe ComboItem
Namespace DedNet.Controls


Classe ControlBinder
Classe che rappresenta il datasource di un ListBox. Uso questo in modo da poter gestire facilmente l'icona della ridefinizione.
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList BinderItem
DedNet.ControlsControlBinder

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ControlBinder : List<BinderItem>
Public Class ControlBinder
    Inherits List(Of BinderItem)
public ref class ControlBinder : public List<BinderItem^>
type ControlBinder =
    class
        inherit List<BinderItem>
    end

Il tipo ControlBinder espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ControlBinder | Costruttore unico.
Metodo pubblico | ControlBinder(ControlBinder) | Costruttore unico.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ContainsValue | Ritorna se il datasource contiene il valore passato.
Metodo pubblico | GetItem | Ritorna il primo elemento che corrisponde al valore passato.
Metodo pubblico | RemoveValue | Rimuove l'item che corrisponde al valore passato.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore ControlBinder
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | ControlBinder | Costruttore unico.
Metodo pubblico | ControlBinder(ControlBinder) | Costruttore unico.
Torna su
Vedi anche

Documentazione

Classe ControlBinder
Namespace DedNet.Controls


Costruttore ControlBinder
Costruttore unico.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ControlBinder()
Public Sub New
public:
ControlBinder()
new : unit -> ControlBinder
Vedi anche

Documentazione

Classe ControlBinder
Overload di ControlBinder
Namespace DedNet.Controls


Costruttore ControlBinder(ControlBinder)
Costruttore unico.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ControlBinder(
    ControlBinder binder
)
Public Sub New (
    binder As ControlBinder
)
public:
ControlBinder(
    ControlBinder^ binder
)
new :
        binder : ControlBinder -> ControlBinder

Parametri

binder ControlBinder
Binder da clonare.
Vedi anche

Documentazione

Classe ControlBinder
Overload di ControlBinder
Namespace DedNet.Controls


Metodi di ControlBinder

Il tipo ControlBinder espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ContainsValue | Ritorna se il datasource contiene il valore passato.
Metodo pubblico | GetItem | Ritorna il primo elemento che corrisponde al valore passato.
Metodo pubblico | RemoveValue | Rimuove l'item che corrisponde al valore passato.
Torna su
Vedi anche

Documentazione

Classe ControlBinder
Namespace DedNet.Controls


Metodo ControlBinder.ContainsValue

Metodo ControlBinderContainsValue
Ritorna se il datasource contiene il valore passato.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ContainsValue(
    string value
)
Public Function ContainsValue (
    value As String
) As Boolean
public:
bool ContainsValue(
    String^ value
)
member ContainsValue :
        value : string -> bool

Parametri

value String
Valore da controllare.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe ControlBinder
Namespace DedNet.Controls


Metodo ControlBinder.GetItem

Metodo ControlBinderGetItem
Ritorna il primo elemento che corrisponde al valore passato.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BinderItem GetItem(
    string value
)
Public Function GetItem (
    value As String
) As BinderItem
public:
BinderItem^ GetItem(
    String^ value
)
member GetItem :
        value : string -> BinderItem

Parametri

value String
Valore dell'elemento richiesto.

Valore di ritorno

BinderItem
Vedi anche

Documentazione

Classe ControlBinder
Namespace DedNet.Controls


Metodo ControlBinder.RemoveValue

Metodo ControlBinderRemoveValue
Rimuove l'item che corrisponde al valore passato.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool RemoveValue(
    string value
)
Public Function RemoveValue (
    value As String
) As Boolean
public:
bool RemoveValue(
    String^ value
)
member RemoveValue :
        value : string -> bool

Parametri

value String
Valore da rimuovere.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe ControlBinder
Namespace DedNet.Controls


Classe CustomImageListBoxControl
ImageListBoxControl Custom che permette di impostare l'indice selezionato a -1 al cambio di datasource.
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
XtraControl
ControlBase
BaseControl
BaseStyleControl
BaseListBoxControl
BaseImageListBoxControl
ImageListBoxControl
DedNet.ControlsCustomImageListBoxControl

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class CustomImageListBoxControl : ImageListBoxControl
Public Class CustomImageListBoxControl
    Inherits ImageListBoxControl
public ref class CustomImageListBoxControl : public ImageListBoxControl
type CustomImageListBoxControl =
    class
        inherit ImageListBoxControl
    end

Il tipo CustomImageListBoxControl espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | CustomImageListBoxControl |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllowHtmlDraw | (Ereditato da BaseListBoxControl)
Proprietà pubblica | AllowHtmlTextInToolTip | (Ereditato da BaseControl)
Proprietà protetta | AllowProcessPaint | (Ereditato da BaseControl)
Proprietà pubblica | Appearance | (Ereditato da BaseStyleControl)
Proprietà pubblica | AppearanceDisabled | (Ereditato da BaseListBoxControl)
Proprietà pubblica | AppearanceHighlight | (Ereditato da BaseListBoxControl)
Proprietà pubblica | AppearanceSelected | (Ereditato da BaseListBoxControl)
Proprietà pubblica | AutoSizeInLayoutControl | (Ereditato da BaseControl)
Proprietà pubblica | BackColor | (Ereditato da BaseListBoxControl)
Proprietà protetta | BaseBorderStyle | (Ereditato da BaseControl)
Proprietà protetta | BindingManager | (Ereditato da BaseListBoxControl)
Proprietà pubblica | BorderStyle | (Ereditato da BaseControl)
Proprietà protetta | CanAnimateCore | (Ereditato da BaseControl)
Proprietà protetta | CanFocusListBox | (Ereditato da BaseListBoxControl)
Proprietà protetta | CanHotTrack | (Ereditato da BaseListBoxControl)
Proprietà protetta | CanShowToolTipForTrimmedText | (Ereditato da BaseListBoxControl)
Proprietà pubblica | ColumnWidth | (Ereditato da BaseListBoxControl)
Proprietà pubblica | ContextButtonOptions | (Ereditato da BaseListBoxControl)
Proprietà pubblica | ContextButtons | (Ereditato da BaseListBoxControl)
Proprietà protetta | CreateParams | (Ereditato da BaseListBoxControl)
Proprietà protetta | CurrentSearch | (Ereditato da BaseListBoxControl)
Proprietà pubblica | Cursor | (Ereditato da ControlBase)
Proprietà protetta | DataAdapter | (Ereditato da BaseListBoxControl)
Proprietà protetta | DataAdapterReady | (Ereditato da BaseListBoxControl)
Proprietà pubblica | DataSource | (Ereditato da BaseListBoxControl)
Proprietà protetta | DefaultSize | (Ereditato da BaseListBoxControl)
Proprietà protetta | DirectXProvider | (Ereditato da XtraControl)
Proprietà protetta | DirectXScroller | (Ereditato da XtraControl)
Proprietà pubblica | DisplayMember | (Ereditato da BaseListBoxControl)
Proprietà protetta | DXAccessible | (Ereditato da BaseControl)
Proprietà protetta | FindStringCompareOptions | (Ereditato da BaseListBoxControl)
Proprietà protetta | FocusOnMouseDown | (Ereditato da BaseControl)
Proprietà pubblica | Font | (Ereditato da BaseStyleControl)
Proprietà pubblica | ForeColor | (Ereditato da BaseStyleControl)
Proprietà pubblica | GlyphAlignment | (Ereditato da BaseImageListBoxControl)
Proprietà protetta | Handler | (Ereditato da BaseListBoxControl)
Proprietà protetta | HasAccessible | (Ereditato da BaseControl)
Proprietà protetta | HasContextButtons | (Ereditato da BaseListBoxControl)
Proprietà protetta | HasCustomSortEvent | (Ereditato da BaseListBoxControl)
Proprietà protetta | HasDataItemsLookup | (Ereditato da BaseListBoxControl)
Proprietà protetta | HasHtmlTemplates | (Ereditato da BaseListBoxControl)
Proprietà protetta | HasItemActions | (Ereditato da BaseListBoxControl)
Proprietà protetta | HasSearchResults | (Ereditato da BaseListBoxControl)
Proprietà protetta | HasSorting | (Ereditato da BaseListBoxControl)
Proprietà pubblica | HighlightedItemStyle | (Ereditato da BaseListBoxControl)
Proprietà pubblica | HorizontalScrollbar | (Ereditato da BaseListBoxControl)
Proprietà pubblica | HorzScrollStep | (Ereditato da BaseListBoxControl)
Proprietà pubblica | HotItemIndex | (Ereditato da BaseListBoxControl)
Proprietà pubblica | HotTrackItems | (Ereditato da BaseListBoxControl)
Proprietà pubblica | HotTrackSelectMode | (Ereditato da BaseListBoxControl)
Proprietà pubblica | HtmlImages | (Ereditato da BaseListBoxControl)
Proprietà pubblica | HtmlTemplates | (Ereditato da BaseListBoxControl)
Proprietà pubblica | ImageIndexMember | (Ereditato da BaseImageListBoxControl)
Proprietà protetta | ImageIndexMemberCore | (Ereditato da ImageListBoxControl)
Proprietà pubblica | ImageList | (Ereditato da BaseImageListBoxControl)
Proprietà protetta | ImageListCore | (Ereditato da ImageListBoxControl)
Proprietà pubblica | ImageMember | (Ereditato da BaseImageListBoxControl)
Proprietà protetta | ImageMemberCore | (Ereditato da ImageListBoxControl)
Proprietà pubblica | IncrementalSearch | (Ereditato da BaseListBoxControl)
Proprietà protetta | IsAttachedToSearchControl | (Ereditato da BaseListBoxControl)
Proprietà protetta | IsBoundMode | (Ereditato da BaseListBoxControl)
Proprietà pubblica | IsDesignMode | (Ereditato da BaseControl)
Proprietà protetta | IsDisposing | (Ereditato da BaseControl)
Proprietà protetta | IsLayoutLocked | (Ereditato da BaseControl)
Proprietà pubblica | IsLoading | (Ereditato da BaseListBoxControl)
Proprietà protetta | IsLockSorting | (Ereditato da BaseListBoxControl)
Proprietà pubblica | IsLockUpdate | (Ereditato da BaseListBoxControl)
Proprietà pubblica | IsRightToLeft | (Ereditato da ControlBase)
Proprietà protetta | IsSearching | (Ereditato da BaseListBoxControl)
Proprietà protetta | IsTemplateMode | (Ereditato da BaseListBoxControl)
Proprietà pubblica | ItemAutoHeight | (Ereditato da BaseListBoxControl)
Proprietà pubblica | ItemCount | (Ereditato da BaseListBoxControl)
Proprietà protetta | ItemCountCore | (Ereditato da BaseListBoxControl)
Proprietà pubblica | ItemHeight | (Ereditato da BaseListBoxControl)
Proprietà pubblica | ItemPadding | (Ereditato da BaseListBoxControl)
Proprietà pubblica | Items | (Ereditato da BaseImageListBoxControl)
Proprietà protetta | ItemsCore | (Ereditato da BaseListBoxControl)
Proprietà pubblica | LeftCoord | (Ereditato da BaseListBoxControl)
Proprietà pubblica | LookAndFeel | (Ereditato da BaseControl)
Proprietà protetta | Model | (Ereditato da BaseListBoxControl)
Proprietà pubblica | MultiColumn | (Ereditato da BaseListBoxControl)
Proprietà protetta | Painter | (Ereditato da BaseStyleControl)
Proprietà protetta | ScaleDPI | (Ereditato da BaseControl)
Proprietà pubblica | ScaleFactor | (Ereditato da BaseControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraControl)
Proprietà protetta | ScrollInfo | (Ereditato da BaseListBoxControl)
Proprietà protetta | SearchResults | (Ereditato da BaseListBoxControl)
Proprietà protetta | SearchText | (Ereditato da BaseListBoxControl)
Proprietà pubblica | SelectedIndex | (Sovrascrive BaseListBoxControl.SelectedIndex)
Proprietà pubblica | SelectedIndices | (Ereditato da BaseListBoxControl)
Proprietà pubblica | SelectedItem | (Ereditato da BaseListBoxControl)
Proprietà pubblica | SelectedItems | (Ereditato da BaseListBoxControl)
Proprietà pubblica | SelectedValue | (Ereditato da BaseListBoxControl)
Proprietà pubblica | SelectionMode | (Ereditato da BaseListBoxControl)
Proprietà pubblica | SetSelectedIndexOnHotTrack | Obsoleto. (Ereditato da BaseListBoxControl)
Proprietà protetta | ShouldDrawBackgroundOnDirectXPaint | (Ereditato da XtraControl)
Proprietà protetta | ShouldNotifyAccessibilityClients | (Ereditato da BaseControl)
Proprietà pubblica | ShowFocusRect | (Ereditato da BaseListBoxControl)
Proprietà protetta | ShowKeyboardCuesCore | (Ereditato da BaseControl)
Proprietà pubblica | ShowToolTipForTrimmedText | (Ereditato da BaseListBoxControl)
Proprietà pubblica | ShowToolTips | (Ereditato da BaseControl)
Proprietà protetta | ShowToolTipsCore | (Ereditato da BaseControl)
Proprietà protetta | SizeableIsCaptionVisible | (Ereditato da BaseControl)
Proprietà protetta | SizeableMaxSize | (Ereditato da BaseControl)
Proprietà protetta | SizeableMinSize | (Ereditato da BaseControl)
Proprietà pubblica | SortOrder | (Ereditato da BaseListBoxControl)
Proprietà pubblica | StyleController | (Ereditato da BaseControl)
Proprietà pubblica | SuperTip | (Ereditato da BaseControl)
Proprietà pubblica | Templates | (Ereditato da BaseListBoxControl)
Proprietà pubblica | Text | (Ereditato da BaseListBoxControl)
Proprietà pubblica | ToolTip | (Ereditato da BaseControl)
Proprietà pubblica | ToolTipAnchor | (Ereditato da BaseControl)
Proprietà pubblica | ToolTipController | (Ereditato da BaseControl)
Proprietà pubblica | ToolTipIconType | (Ereditato da BaseControl)
Proprietà pubblica | ToolTipTitle | (Ereditato da BaseControl)
Proprietà pubblica | TopIndex | (Ereditato da BaseListBoxControl)
Proprietà protetta | UseBaseBackColor | (Ereditato da BaseStyleControl)
Proprietà pubblica | UseDisabledStatePainter | (Ereditato da BaseListBoxControl)
Proprietà pubblica | ValueMember | (Ereditato da BaseListBoxControl)
Proprietà protetta | ViewInfo | (Ereditato da BaseImageListBoxControl)
Proprietà protetta | ViewMember | (Ereditato da BaseListBoxControl)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateDataSource | (Ereditato da BaseListBoxControl)
Metodo protetto | AddCustomSortHandler``1 | (Ereditato da BaseListBoxControl)
Metodo pubblico | AddEnum(Type) | (Ereditato da BaseListBoxControl)
Metodo pubblico | AddEnum(Type, Boolean) | (Ereditato da BaseListBoxControl)
Metodo pubblico | AddEnum``1 | (Ereditato da BaseListBoxControl)
Metodo pubblico | AddEnum``1(ConverterUMP, String) | (Ereditato da BaseListBoxControl)
Metodo pubblico | AddEnum``1(ConverterUMP, String, Boolean) | (Ereditato da BaseListBoxControl)
Metodo protetto | ApplyDelayedOperations | (Ereditato da BaseListBoxControl)
Metodo protetto | ApplyInlineSearch | (Ereditato da BaseListBoxControl)
Metodo protetto | ApplyItemsFilter | (Ereditato da BaseListBoxControl)
Metodo protetto | ApplySort | (Ereditato da BaseListBoxControl)
Metodo protetto | BaseWndProc | (Ereditato da ControlBase)
Metodo pubblico | BeginUpdate | (Ereditato da BaseListBoxControl)
Metodo pubblico | BindCommand(Object, String, FuncObject) | (Ereditato da BaseListBoxControl)
Metodo pubblico | BindCommand(ExpressionAction, Object, String, FuncObject) | (Ereditato da BaseListBoxControl)
Metodo pubblico | BindCommand``1(ExpressionActionUMP, Object, String, FuncUMP) | (Ereditato da BaseListBoxControl)
Metodo pubblico | CalcBestSize | (Ereditato da BaseControl)
Metodo protetto | CalcDefaultSizeableMinWidth | (Ereditato da BaseControl)
Metodo protetto | CalcHandlerState | (Ereditato da BaseListBoxControl)
Metodo protetto | CalcSizeableMaxSize | (Ereditato da BaseListBoxControl)
Metodo protetto | CalcSizeableMinSize | (Ereditato da BaseListBoxControl)
Metodo protetto | CanApplyItemsFilter | (Ereditato da BaseListBoxControl)
Metodo pubblico | CancelUpdate | (Ereditato da BaseListBoxControl)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da BaseControl)
Metodo protetto | CheckRightToLeft | (Ereditato da ControlBase)
Metodo protetto | CheckStopAnimation | (Ereditato da BaseListBoxControl)
Metodo protetto | ClearItemSizes | (Ereditato da BaseListBoxControl)
Metodo protetto | ConvertValueToString | (Ereditato da BaseListBoxControl)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da BaseControl)
Metodo protetto | CreateAccessibleInstance | (Ereditato da BaseListBoxControl)
Metodo protetto | CreateAppearance | (Ereditato da BaseStyleControl)
Metodo protetto | CreateCache | (Ereditato da BaseControl)
Metodo protetto | CreateContextButtonOptions | (Ereditato da BaseListBoxControl)
Metodo protetto | CreateContextButtonsCollection | (Ereditato da BaseListBoxControl)
Metodo protetto | CreateCustomSortComparer``1 | (Ereditato da BaseListBoxControl)
Metodo protetto | CreateDataAdapter | (Ereditato da BaseListBoxControl)
Metodo protetto | CreateDirectXProvider | (Ereditato da XtraControl)
Metodo protetto | CreateHandler | (Ereditato da BaseListBoxControl)
Metodo protetto | CreateHtmlTemplates | (Ereditato da BaseListBoxControl)
Metodo protetto | CreateItemActions | (Ereditato da BaseListBoxControl)
Metodo protetto | CreateItemsCollection | (Ereditato da ImageListBoxControl)
Metodo protetto | CreateListBoxModel | (Ereditato da BaseListBoxControl)
Metodo protetto | CreateLookAndFeel | (Ereditato da BaseControl)
Metodo protetto | CreatePainter | (Ereditato da ImageListBoxControl)
Metodo protetto | CreateScrollInfo | (Ereditato da BaseListBoxControl)
Metodo protetto | CreateSearchControlProviderBase | (Ereditato da BaseListBoxControl)
Metodo protetto | CreateSelectedIndexCollection | (Ereditato da BaseListBoxControl)
Metodo protetto | CreateViewInfo | (Ereditato da ImageListBoxControl)
Metodo protetto | DescaleInteger | (Ereditato da BaseControl)
Metodo protetto | DestroyAppearance | (Ereditato da BaseStyleControl)
Metodo protetto | DestroyDataAdapter | (Ereditato da BaseListBoxControl)
Metodo protetto | Dispose | (Ereditato da ImageListBoxControl)
Metodo protetto | DoDpiChange | (Ereditato da BaseListBoxControl)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da BaseListBoxControl)
Metodo protetto | DoSort | (Ereditato da ImageListBoxControl)
Metodo pubblico | EndUpdate | (Ereditato da BaseListBoxControl)
Metodo protetto | EnsureControlRowSource | (Ereditato da BaseListBoxControl)
Metodo protetto | FilterDescriptorCollectionCore | (Ereditato da BaseStyleControl)
Metodo pubblico | FindItem(Object) | (Ereditato da BaseListBoxControl)
Metodo pubblico | FindItem(Int32, Boolean, ListBoxFindItemDelegate) | (Ereditato da BaseListBoxControl)
Metodo pubblico | FindString(String) | (Ereditato da BaseListBoxControl)
Metodo pubblico | FindString(String, Int32) | (Ereditato da BaseListBoxControl)
Metodo pubblico | FindString(String, Int32, Boolean) | (Ereditato da BaseListBoxControl)
Metodo pubblico | FindStringExact(String) | (Ereditato da BaseListBoxControl)
Metodo pubblico | FindStringExact(String, Int32) | (Ereditato da BaseListBoxControl)
Metodo protetto | FindValueIndex | (Ereditato da BaseListBoxControl)
Metodo protetto | FireChanged | (Ereditato da BaseControl)
Metodo pubblico | ForceInitialize | (Ereditato da BaseListBoxControl)
Metodo protetto | GetAccessibilityObjectById | (Ereditato da BaseListBoxControl)
Metodo pubblico | GetAccessible | (Ereditato da BaseControl)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da BaseControl)
Metodo protetto | GetAllowHtmlDraw | (Ereditato da BaseListBoxControl)
Metodo protetto | GetAllowHtmlDraw(Int32) | (Ereditato da BaseListBoxControl)
Metodo pubblico | GetBaseTextBounds | (Ereditato da BaseListBoxControl)
Metodo protetto | GetBoundItemImage | (Ereditato da BaseImageListBoxControl)
Metodo protetto | GetBoundItemImageIndex | (Ereditato da BaseImageListBoxControl)
Metodo protetto | GetBoundItemImageOptions | (Ereditato da BaseImageListBoxControl)
Metodo protetto | GetColor(Color, Color) | (Ereditato da BaseControl)
Metodo protetto | GetColor(Color, Color, Boolean) | (Ereditato da BaseControl)
Metodo protetto | GetDataItemsLookupItem(Int32) | (Ereditato da BaseListBoxControl)
Metodo protetto | GetDataItemsLookupItem(Object) | (Ereditato da BaseListBoxControl)
Metodo protetto | GetDataSourceDisplayText | (Ereditato da BaseListBoxControl)
Metodo protetto | GetDataSourceDisplayValue | (Ereditato da BaseListBoxControl)
Metodo protetto | GetDataSourceValue(Int32) | (Ereditato da BaseListBoxControl)
Metodo protetto | GetDataSourceValue(Int32, String) | (Ereditato da BaseListBoxControl)
Metodo protetto | GetDeviceSize | (Ereditato da XtraControl)
Metodo pubblico | GetDisplayItemValue | (Ereditato da BaseListBoxControl)
Metodo protetto | GetDrawItemText(Int32) | (Ereditato da BaseListBoxControl)
Metodo protetto | GetDrawItemText(Int32, Int32) | (Ereditato da BaseListBoxControl)
Metodo protetto | GetDrawItemTextCore | (Ereditato da BaseListBoxControl)
Metodo protetto | GetForceHtmlDraw | (Ereditato da BaseListBoxControl)
Metodo protetto | GetHtmlDraw | (Ereditato da BaseListBoxControl)
Metodo protetto | GetHtmlIntellisenceFields | (Ereditato da ImageListBoxControl)
Metodo protetto | GetIndex | (Ereditato da BaseListBoxControl)
Metodo pubblico | GetItem | (Ereditato da BaseListBoxControl)
Metodo protetto | GetItemAccessibilityText | (Ereditato da BaseListBoxControl)
Metodo protetto | GetItemCore | (Ereditato da BaseListBoxControl)
Metodo protetto | GetItemDisplayValue | (Ereditato da ImageListBoxControl)
Metodo protetto | GetItemDisplayValueGetter | (Ereditato da BaseListBoxControl)
Metodo protetto | GetItemEnabledCore | (Ereditato da BaseListBoxControl)
Metodo pubblico | GetItemImage | (Ereditato da BaseImageListBoxControl)
Metodo protetto | GetItemImageCore | (Ereditato da ImageListBoxControl)
Metodo pubblico | GetItemImageIndex | (Ereditato da BaseImageListBoxControl)
Metodo protetto | GetItemImageIndexCore | (Ereditato da ImageListBoxControl)
Metodo pubblico | GetItemImageOptions | (Ereditato da BaseImageListBoxControl)
Metodo protetto | GetItemImageOptionsCore | (Ereditato da ImageListBoxControl)
Metodo pubblico | GetItemImageSize | (Ereditato da BaseImageListBoxControl)
Metodo protetto | GetItemImageSizeCore | (Ereditato da ImageListBoxControl)
Metodo pubblico | GetItemRectangle | (Ereditato da BaseListBoxControl)
Metodo protetto | GetItemsComparer | (Ereditato da BaseListBoxControl)
Metodo protetto | GetItemTemplateArgs | (Ereditato da BaseListBoxControl)
Metodo pubblico | GetItemText | (Ereditato da BaseListBoxControl)
Metodo protetto | GetItemTextCore | (Ereditato da BaseListBoxControl)
Metodo pubblico | GetItemValue | (Ereditato da BaseListBoxControl)
Metodo protetto | GetItemValueCore | (Ereditato da ImageListBoxControl)
Metodo protetto | GetItemVisibleCore | (Ereditato da BaseListBoxControl)
Metodo protetto | GetMatchedRanges | (Ereditato da BaseListBoxControl)
Metodo protetto | GetNextVisibleItem | (Ereditato da BaseListBoxControl)
Metodo protetto | GetScaleDpiCore | (Ereditato da BaseControl)
Metodo protetto | GetSearchMember | (Ereditato da BaseListBoxControl)
Metodo protetto | GetSelectedRowSource | (Ereditato da BaseListBoxControl)
Metodo protetto | GetToolTipAnchor | (Ereditato da BaseControl)
Metodo protetto | GetToolTipInfo | (Ereditato da BaseListBoxControl)
Metodo protetto | GetUnboundColumns | (Ereditato da BaseImageListBoxControl)
Metodo protetto | GetUsedColumns | (Ereditato da BaseListBoxControl)
Metodo protetto | GetUseDirectXPaint | (Ereditato da XtraControl)
Metodo protetto | GetValidationCanceled | (Ereditato da ControlBase)
Metodo pubblico | GetViewInfo | (Ereditato da BaseControl)
Metodo protetto | GetVisibleIndex | (Ereditato da BaseListBoxControl)
Metodo protetto | GetVisibleItemsCount | (Ereditato da BaseListBoxControl)
Metodo pubblico | IndexFromPoint | (Ereditato da BaseListBoxControl)
Metodo protetto | InitializeItemDisplayValueGetter | (Ereditato da BaseListBoxControl)
Metodo protetto | IsAdvHotTrackEnabled | (Ereditato da BaseListBoxControl)
Metodo protetto | IsInputChar | (Ereditato da BaseListBoxControl)
Metodo protetto | IsInputKey | (Ereditato da BaseListBoxControl)
Metodo protetto | IsNotLoadedItem | (Ereditato da BaseListBoxControl)
Metodo protetto | IsSkinnedHightlighingEnabled | (Ereditato da BaseListBoxControl)
Metodo protetto | IsValidDataSource | (Ereditato da BaseListBoxControl)
Metodo protetto | LayoutChanged | (Ereditato da BaseListBoxControl)
Metodo protetto | LayoutChangedCore | (Ereditato da BaseControl)
Metodo protetto | LockSorting | (Ereditato da BaseListBoxControl)
Metodo pubblico | MakeItemVisible | (Ereditato da BaseListBoxControl)
Metodo protetto | NotifyAccessibilityClients(AccessibleEvents, Int32, Int32) | (Ereditato da BaseControl)
Metodo protetto | NotifyAccessibilityClients(AccessibleEvents, AutomationElementProvider, Int32, Int32) | (Ereditato da BaseControl)
Metodo protetto | NotifyAccessibilitySelectedIndexChanged | (Ereditato da BaseListBoxControl)
Metodo protetto | OnActionItemClick | (Ereditato da BaseListBoxControl)
Metodo protetto | OnAfterUpdateViewInfo | (Ereditato da BaseControl)
Metodo protetto | OnBeforeUpdateViewInfo | (Ereditato da BaseControl)
Metodo protetto | OnBindingContextChanged | (Ereditato da BaseListBoxControl)
Metodo protetto | OnBorderStyleChanged | (Ereditato da BaseControl)
Metodo protetto | OnCollectionChanged | (Ereditato da ImageListBoxControl)
Metodo protetto | OnCreateControl | (Ereditato da BaseListBoxControl)
Metodo protetto | OnDataSourceChanged(Object, EventArgs) |
Metodo protetto | OnDataSourceChanged(Object, EventArgs) | (Ereditato da BaseImageListBoxControl)
Metodo protetto | OnDirectXPaintDisabled | (Ereditato da XtraControl)
Metodo protetto | OnDirectXPaintEnabled | (Ereditato da XtraControl)
Metodo protetto | OnEnabledChanged | (Ereditato da BaseListBoxControl)
Metodo protetto | OnExpandItem | (Ereditato da BaseListBoxControl)
Metodo protetto | OnGotCapture | (Ereditato da ControlBase)
Metodo protetto | OnGotFocus | (Ereditato da BaseListBoxControl)
Metodo protetto | OnHandleCreated | (Ereditato da BaseListBoxControl)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraControl)
Metodo protetto | OnItemFound | (Ereditato da BaseListBoxControl)
Metodo protetto | OnKeyDown | (Ereditato da BaseListBoxControl)
Metodo protetto | OnKeyPress | (Ereditato da BaseListBoxControl)
Metodo protetto | OnKeyUp | (Ereditato da BaseListBoxControl)
Metodo protetto | OnListChanged | (Ereditato da BaseListBoxControl)
Metodo protetto | OnListChangedDefault | (Ereditato da BaseListBoxControl)
Metodo protetto | OnListItemAdded | (Ereditato da BaseListBoxControl)
Metodo protetto | OnListItemDeleted | (Ereditato da BaseListBoxControl)
Metodo protetto | OnListReset | (Ereditato da BaseListBoxControl)
Metodo protetto | OnLoaded | (Ereditato da BaseListBoxControl)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da BaseListBoxControl)
Metodo protetto | OnLostCapture | (Ereditato da BaseListBoxControl)
Metodo protetto | OnLostFocus | (Ereditato da BaseListBoxControl)
Metodo protetto | OnMouseDown | (Ereditato da BaseListBoxControl)
Metodo protetto | OnMouseEnter | (Ereditato da BaseListBoxControl)
Metodo protetto | OnMouseLeave | (Ereditato da BaseListBoxControl)
Metodo protetto | OnMouseMove | (Ereditato da BaseListBoxControl)
Metodo protetto | OnMouseUp | (Ereditato da BaseListBoxControl)
Metodo protetto | OnMouseWheel | (Ereditato da BaseListBoxControl)
Metodo protetto | OnMouseWheelCore | (Ereditato da BaseListBoxControl)
Metodo protetto | OnMultiColumnChanged | (Ereditato da BaseListBoxControl)
Metodo protetto | OnPaddingChanged | (Ereditato da BaseControl)
Metodo protetto | OnPaint | (Ereditato da BaseListBoxControl)
Metodo protetto | OnPaintBackground | (Ereditato da BaseListBoxControl)
Metodo protetto | OnParentChanged | (Ereditato da ControlBase)
Metodo protetto | OnPositionChanged | (Ereditato da BaseListBoxControl)
Metodo protetto | OnPropertiesChanged | (Ereditato da BaseControl)
Metodo protetto | OnResize | (Ereditato da BaseListBoxControl)
Metodo protetto | OnRightToLeftChanged | (Ereditato da BaseControl)
Metodo protetto | OnRightToLeftChanged(EventArgs) | (Ereditato da BaseListBoxControl)
Metodo protetto | OnScaleControl | (Ereditato da BaseListBoxControl)
Metodo protetto | OnScaleDpiChanged | (Ereditato da ControlBase)
Metodo protetto | OnSelectionChanged | (Ereditato da BaseListBoxControl)
Metodo protetto | OnSetSelectedValue | (Ereditato da BaseListBoxControl)
Metodo protetto | OnStyleChanged | (Ereditato da BaseListBoxControl)
Metodo protetto | OnStyleController_Disposed | (Ereditato da BaseControl)
Metodo protetto | OnStyleController_PropertiesChanged | (Ereditato da BaseControl)
Metodo protetto | OnStyleControllerChanged | (Ereditato da BaseListBoxControl)
Metodo protetto | OnVisibleChanged | (Ereditato da BaseListBoxControl)
Metodo protetto | OnVisibleRowCountChanged | (Ereditato da BaseListBoxControl)
Metodo protetto | PostApplyItemsFilter | (Ereditato da BaseListBoxControl)
Metodo protetto | PreApplyItemsFilter | (Ereditato da BaseListBoxControl)
Metodo protetto | ProcessDialogKey | (Ereditato da BaseListBoxControl)
Metodo protetto | ProcessPaintAction | (Ereditato da XtraControl)
Metodo protetto | RaiseContextButtonClick | (Ereditato da BaseListBoxControl)
Metodo protetto | RaiseContextButtonValueChanged | (Ereditato da BaseListBoxControl)
Metodo protetto | RaiseControlRowSourceChanged | (Ereditato da BaseListBoxControl)
Metodo protetto | RaiseCustomContextButtonToolTip | (Ereditato da BaseListBoxControl)
Metodo protetto | RaiseCustomDrawEmptyForeground | (Ereditato da BaseListBoxControl)
Metodo protetto | RaiseCustomItemTemplate | (Ereditato da BaseListBoxControl)
Metodo protetto | RaiseCustomizeContextItem | (Ereditato da BaseListBoxControl)
Metodo protetto | RaiseCustomizeTemplatedItem | (Ereditato da BaseListBoxControl)
Metodo protetto | RaiseCustomSort``1 | (Ereditato da BaseListBoxControl)
Metodo protetto | RaiseDataSourceChanged | (Ereditato da BaseListBoxControl)
Metodo protetto | RaiseDisplayMemberChanged | (Ereditato da BaseListBoxControl)
Metodo protetto | RaiseDrawItem | (Ereditato da BaseListBoxControl)
Metodo protetto | RaiseFocusedIndexChanged | (Ereditato da BaseListBoxControl)
Metodo protetto | RaiseHtmlElementMouseClick | (Ereditato da BaseListBoxControl)
Metodo protetto | RaiseHtmlElementMouseDown | (Ereditato da BaseListBoxControl)
Metodo protetto | RaiseHtmlElementMouseMove | (Ereditato da BaseListBoxControl)
Metodo protetto | RaiseHtmlElementMouseOut | (Ereditato da BaseListBoxControl)
Metodo protetto | RaiseHtmlElementMouseOver | (Ereditato da BaseListBoxControl)
Metodo protetto | RaiseHtmlElementMouseUp | (Ereditato da BaseListBoxControl)
Metodo protetto | RaiseImageIndexMemberChanged | (Ereditato da BaseImageListBoxControl)
Metodo protetto | RaiseImageMemberChanged | (Ereditato da BaseImageListBoxControl)
Metodo protetto | RaiseMeasureItem | (Ereditato da BaseListBoxControl)
Metodo protetto | RaisePaintEvent | (Ereditato da BaseControl)
Metodo protetto | RaisePaintExEvent | (Ereditato da XtraControl)
Metodo protetto | RaiseParseSearchControlText | (Ereditato da BaseListBoxControl)
Metodo protetto | RaiseSearch | (Ereditato da BaseListBoxControl)
Metodo protetto | RaiseSelectedIndexChanged | (Ereditato da BaseListBoxControl)
Metodo protetto | RaiseSelectedValueChanged | (Ereditato da BaseListBoxControl)
Metodo protetto | RaiseSizeableChanged | (Ereditato da BaseControl)
Metodo protetto | RaiseValueMemberChanged | (Ereditato da BaseListBoxControl)
Metodo protetto | RecalcViewInfoState | (Ereditato da BaseListBoxControl)
Metodo pubblico | Refresh | (Ereditato da BaseControl)
Metodo protetto | ReleaseDirectXResources | (Ereditato da XtraControl)
Metodo protetto | ReleaseStyleController | (Ereditato da BaseControl)
Metodo protetto | RemoveCustomSortHandler``1 | (Ereditato da BaseListBoxControl)
Metodo protetto | RemoveXtraAnimator | (Ereditato da BaseControl)
Metodo protetto | ResetAccessible | (Ereditato da BaseControl)
Metodo pubblico | ResetBackColor | (Ereditato da BaseStyleControl)
Metodo pubblico | ResetForeColor | (Ereditato da BaseStyleControl)
Metodo protetto | ResetInlineSearchMode | (Ereditato da BaseListBoxControl)
Metodo pubblico | ResetPainter | (Ereditato da BaseStyleControl)
Metodo pubblico | ResetSuperTip | (Ereditato da BaseControl)
Metodo pubblico | ResetViewInfo | (Ereditato da BaseStyleControl)
Metodo protetto | ScaleControl | (Ereditato da ControlBase)
Metodo protetto | ScaleInteger | (Ereditato da BaseControl)
Metodo protetto | ScaleSize | (Ereditato da BaseControl)
Metodo pubblico | SelectAll | (Ereditato da BaseListBoxControl)
Metodo protetto | SetBackColor | (Ereditato da BaseControl)
Metodo protetto | SetDataSourceValue | (Ereditato da BaseListBoxControl)
Metodo protetto | SetInlineSearchMode | (Ereditato da BaseListBoxControl)
Metodo protetto | SetItemCore | (Ereditato da BaseListBoxControl)
Metodo protetto | SetItems | (Ereditato da BaseListBoxControl)
Metodo pubblico | SetItemValue | (Ereditato da BaseListBoxControl)
Metodo protetto | SetItemValueCore | (Ereditato da ImageListBoxControl)
Metodo protetto | SetLeftCoordCore | (Ereditato da BaseListBoxControl)
Metodo pubblico | SetSelected | (Ereditato da BaseListBoxControl)
Metodo protetto | SetSelectedIndexCore | (Ereditato da BaseListBoxControl)
Metodo protetto | SetTopIndexCore | (Ereditato da BaseListBoxControl)
Metodo protetto | SetVisibleCore | (Ereditato da ControlBase)
Metodo pubblico | Sort | (Ereditato da BaseListBoxControl)
Metodo protetto | SubscribeDataAdapterEvents | (Ereditato da BaseListBoxControl)
Metodo protetto | SubscribeImageListEvents | (Ereditato da ImageListBoxControl)
Metodo protetto | UnlockSorting | (Ereditato da BaseListBoxControl)
Metodo pubblico | UnSelectAll | (Ereditato da BaseListBoxControl)
Metodo protetto | UnsubscribeDataAdapterEvents | (Ereditato da BaseListBoxControl)
Metodo protetto | UnsubscribeImageListEvents | (Ereditato da ImageListBoxControl)
Metodo protetto | UpdateBindingManager | (Ereditato da BaseListBoxControl)
Metodo protetto | UpdateDataItemsLookup | (Ereditato da BaseListBoxControl)
Metodo protetto | UpdateLeftCoord | (Ereditato da BaseListBoxControl)
Metodo protetto | UpdateScaleDpi | (Ereditato da XtraControl)
Metodo protetto | UpdateScaleFactorForScaleHelper | (Ereditato da XtraControl)
Metodo protetto | UpdateScrollBars | (Ereditato da BaseListBoxControl)
Metodo protetto | UpdateViewInfo | (Ereditato da BaseControl)
Metodo protetto | UpdateViewInfoState | (Ereditato da BaseControl)
Metodo protetto | UpdateViewInfoState(Boolean) | (Ereditato da BaseControl)
Metodo protetto | UpdateViewInfoState(Boolean, Point) | (Ereditato da BaseControl)
Metodo protetto | WndProc | (Ereditato da BaseListBoxControl)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | BackColorChanged | (Ereditato da BaseStyleControl)
Evento pubblico | ContextButtonClick | (Ereditato da BaseListBoxControl)
Evento pubblico | ContextButtonValueChanged | (Ereditato da BaseListBoxControl)
Evento pubblico | CustomContextButtonToolTip | (Ereditato da BaseListBoxControl)
Evento pubblico | CustomDrawEmptyForeground | (Ereditato da BaseListBoxControl)
Evento pubblico | CustomDrawScroll | (Ereditato da BaseListBoxControl)
Evento pubblico | CustomItemDisplayText | (Ereditato da BaseListBoxControl)
Evento pubblico | CustomItemTemplate | (Ereditato da BaseListBoxControl)
Evento pubblico | CustomizeContextItem | (Ereditato da BaseListBoxControl)
Evento pubblico | CustomizeItem | (Ereditato da BaseListBoxControl)
Evento pubblico | CustomSort | (Ereditato da ImageListBoxControl)
Evento pubblico | DataSourceChanged | (Ereditato da BaseListBoxControl)
Evento pubblico | DisplayMemberChanged | (Ereditato da BaseListBoxControl)
Evento pubblico | DrawItem | (Ereditato da BaseListBoxControl)
Evento protetto | FocusedIndexChanged | (Ereditato da BaseListBoxControl)
Evento pubblico | FontChanged | (Ereditato da BaseStyleControl)
Evento pubblico | ForeColorChanged | (Ereditato da BaseStyleControl)
Evento pubblico | HtmlElementMouseClick | (Ereditato da BaseListBoxControl)
Evento pubblico | HtmlElementMouseDown | (Ereditato da BaseListBoxControl)
Evento pubblico | HtmlElementMouseMove | (Ereditato da BaseListBoxControl)
Evento pubblico | HtmlElementMouseOut | (Ereditato da BaseListBoxControl)
Evento pubblico | HtmlElementMouseOver | (Ereditato da BaseListBoxControl)
Evento pubblico | HtmlElementMouseUp | (Ereditato da BaseListBoxControl)
Evento pubblico | ImageIndexMemberChanged | (Ereditato da BaseImageListBoxControl)
Evento pubblico | ImageMemberChanged | (Ereditato da BaseImageListBoxControl)
Evento pubblico | MeasureItem | (Ereditato da BaseListBoxControl)
Evento pubblico | PaintEx | (Ereditato da XtraControl)
Evento pubblico | ParseSearchControlText | (Ereditato da BaseListBoxControl)
Evento protetto | Search | (Ereditato da BaseListBoxControl)
Evento pubblico | SelectedIndexChanged | (Ereditato da BaseListBoxControl)
Evento pubblico | SelectedValueChanged | (Ereditato da BaseListBoxControl)
Evento pubblico | ValueMemberChanged | (Ereditato da BaseListBoxControl)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | fDisposing | (Ereditato da BaseControl)
Campo protetto | fGlyphAlignment | (Ereditato da BaseImageListBoxControl)
Campo protetto | fShowToolTips | (Ereditato da BaseControl)
Campo protetto | shouldRaiseSizeableChanged | (Ereditato da BaseControl)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore CustomImageListBoxControl

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public CustomImageListBoxControl()
Public Sub New
public:
CustomImageListBoxControl()
new : unit -> CustomImageListBoxControl
Vedi anche

Documentazione

Classe CustomImageListBoxControl
Namespace DedNet.Controls


Proprietà di CustomImageListBoxControl

Il tipo CustomImageListBoxControl espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllowHtmlDraw | (Ereditato da BaseListBoxControl)
Proprietà pubblica | AllowHtmlTextInToolTip | (Ereditato da BaseControl)
Proprietà protetta | AllowProcessPaint | (Ereditato da BaseControl)
Proprietà pubblica | Appearance | (Ereditato da BaseStyleControl)
Proprietà pubblica | AppearanceDisabled | (Ereditato da BaseListBoxControl)
Proprietà pubblica | AppearanceHighlight | (Ereditato da BaseListBoxControl)
Proprietà pubblica | AppearanceSelected | (Ereditato da BaseListBoxControl)
Proprietà pubblica | AutoSizeInLayoutControl | (Ereditato da BaseControl)
Proprietà pubblica | BackColor | (Ereditato da BaseListBoxControl)
Proprietà protetta | BaseBorderStyle | (Ereditato da BaseControl)
Proprietà protetta | BindingManager | (Ereditato da BaseListBoxControl)
Proprietà pubblica | BorderStyle | (Ereditato da BaseControl)
Proprietà protetta | CanAnimateCore | (Ereditato da BaseControl)
Proprietà protetta | CanFocusListBox | (Ereditato da BaseListBoxControl)
Proprietà protetta | CanHotTrack | (Ereditato da BaseListBoxControl)
Proprietà protetta | CanShowToolTipForTrimmedText | (Ereditato da BaseListBoxControl)
Proprietà pubblica | ColumnWidth | (Ereditato da BaseListBoxControl)
Proprietà pubblica | ContextButtonOptions | (Ereditato da BaseListBoxControl)
Proprietà pubblica | ContextButtons | (Ereditato da BaseListBoxControl)
Proprietà protetta | CreateParams | (Ereditato da BaseListBoxControl)
Proprietà protetta | CurrentSearch | (Ereditato da BaseListBoxControl)
Proprietà pubblica | Cursor | (Ereditato da ControlBase)
Proprietà protetta | DataAdapter | (Ereditato da BaseListBoxControl)
Proprietà protetta | DataAdapterReady | (Ereditato da BaseListBoxControl)
Proprietà pubblica | DataSource | (Ereditato da BaseListBoxControl)
Proprietà protetta | DefaultSize | (Ereditato da BaseListBoxControl)
Proprietà protetta | DirectXProvider | (Ereditato da XtraControl)
Proprietà protetta | DirectXScroller | (Ereditato da XtraControl)
Proprietà pubblica | DisplayMember | (Ereditato da BaseListBoxControl)
Proprietà protetta | DXAccessible | (Ereditato da BaseControl)
Proprietà protetta | FindStringCompareOptions | (Ereditato da BaseListBoxControl)
Proprietà protetta | FocusOnMouseDown | (Ereditato da BaseControl)
Proprietà pubblica | Font | (Ereditato da BaseStyleControl)
Proprietà pubblica | ForeColor | (Ereditato da BaseStyleControl)
Proprietà pubblica | GlyphAlignment | (Ereditato da BaseImageListBoxControl)
Proprietà protetta | Handler | (Ereditato da BaseListBoxControl)
Proprietà protetta | HasAccessible | (Ereditato da BaseControl)
Proprietà protetta | HasContextButtons | (Ereditato da BaseListBoxControl)
Proprietà protetta | HasCustomSortEvent | (Ereditato da BaseListBoxControl)
Proprietà protetta | HasDataItemsLookup | (Ereditato da BaseListBoxControl)
Proprietà protetta | HasHtmlTemplates | (Ereditato da BaseListBoxControl)
Proprietà protetta | HasItemActions | (Ereditato da BaseListBoxControl)
Proprietà protetta | HasSearchResults | (Ereditato da BaseListBoxControl)
Proprietà protetta | HasSorting | (Ereditato da BaseListBoxControl)
Proprietà pubblica | HighlightedItemStyle | (Ereditato da BaseListBoxControl)
Proprietà pubblica | HorizontalScrollbar | (Ereditato da BaseListBoxControl)
Proprietà pubblica | HorzScrollStep | (Ereditato da BaseListBoxControl)
Proprietà pubblica | HotItemIndex | (Ereditato da BaseListBoxControl)
Proprietà pubblica | HotTrackItems | (Ereditato da BaseListBoxControl)
Proprietà pubblica | HotTrackSelectMode | (Ereditato da BaseListBoxControl)
Proprietà pubblica | HtmlImages | (Ereditato da BaseListBoxControl)
Proprietà pubblica | HtmlTemplates | (Ereditato da BaseListBoxControl)
Proprietà pubblica | ImageIndexMember | (Ereditato da BaseImageListBoxControl)
Proprietà protetta | ImageIndexMemberCore | (Ereditato da ImageListBoxControl)
Proprietà pubblica | ImageList | (Ereditato da BaseImageListBoxControl)
Proprietà protetta | ImageListCore | (Ereditato da ImageListBoxControl)
Proprietà pubblica | ImageMember | (Ereditato da BaseImageListBoxControl)
Proprietà protetta | ImageMemberCore | (Ereditato da ImageListBoxControl)
Proprietà pubblica | IncrementalSearch | (Ereditato da BaseListBoxControl)
Proprietà protetta | IsAttachedToSearchControl | (Ereditato da BaseListBoxControl)
Proprietà protetta | IsBoundMode | (Ereditato da BaseListBoxControl)
Proprietà pubblica | IsDesignMode | (Ereditato da BaseControl)
Proprietà protetta | IsDisposing | (Ereditato da BaseControl)
Proprietà protetta | IsLayoutLocked | (Ereditato da BaseControl)
Proprietà pubblica | IsLoading | (Ereditato da BaseListBoxControl)
Proprietà protetta | IsLockSorting | (Ereditato da BaseListBoxControl)
Proprietà pubblica | IsLockUpdate | (Ereditato da BaseListBoxControl)
Proprietà pubblica | IsRightToLeft | (Ereditato da ControlBase)
Proprietà protetta | IsSearching | (Ereditato da BaseListBoxControl)
Proprietà protetta | IsTemplateMode | (Ereditato da BaseListBoxControl)
Proprietà pubblica | ItemAutoHeight | (Ereditato da BaseListBoxControl)
Proprietà pubblica | ItemCount | (Ereditato da BaseListBoxControl)
Proprietà protetta | ItemCountCore | (Ereditato da BaseListBoxControl)
Proprietà pubblica | ItemHeight | (Ereditato da BaseListBoxControl)
Proprietà pubblica | ItemPadding | (Ereditato da BaseListBoxControl)
Proprietà pubblica | Items | (Ereditato da BaseImageListBoxControl)
Proprietà protetta | ItemsCore | (Ereditato da BaseListBoxControl)
Proprietà pubblica | LeftCoord | (Ereditato da BaseListBoxControl)
Proprietà pubblica | LookAndFeel | (Ereditato da BaseControl)
Proprietà protetta | Model | (Ereditato da BaseListBoxControl)
Proprietà pubblica | MultiColumn | (Ereditato da BaseListBoxControl)
Proprietà protetta | Painter | (Ereditato da BaseStyleControl)
Proprietà protetta | ScaleDPI | (Ereditato da BaseControl)
Proprietà pubblica | ScaleFactor | (Ereditato da BaseControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraControl)
Proprietà protetta | ScrollInfo | (Ereditato da BaseListBoxControl)
Proprietà protetta | SearchResults | (Ereditato da BaseListBoxControl)
Proprietà protetta | SearchText | (Ereditato da BaseListBoxControl)
Proprietà pubblica | SelectedIndex | (Sovrascrive BaseListBoxControl.SelectedIndex)
Proprietà pubblica | SelectedIndices | (Ereditato da BaseListBoxControl)
Proprietà pubblica | SelectedItem | (Ereditato da BaseListBoxControl)
Proprietà pubblica | SelectedItems | (Ereditato da BaseListBoxControl)
Proprietà pubblica | SelectedValue | (Ereditato da BaseListBoxControl)
Proprietà pubblica | SelectionMode | (Ereditato da BaseListBoxControl)
Proprietà pubblica | SetSelectedIndexOnHotTrack | Obsoleto. (Ereditato da BaseListBoxControl)
Proprietà protetta | ShouldDrawBackgroundOnDirectXPaint | (Ereditato da XtraControl)
Proprietà protetta | ShouldNotifyAccessibilityClients | (Ereditato da BaseControl)
Proprietà pubblica | ShowFocusRect | (Ereditato da BaseListBoxControl)
Proprietà protetta | ShowKeyboardCuesCore | (Ereditato da BaseControl)
Proprietà pubblica | ShowToolTipForTrimmedText | (Ereditato da BaseListBoxControl)
Proprietà pubblica | ShowToolTips | (Ereditato da BaseControl)
Proprietà protetta | ShowToolTipsCore | (Ereditato da BaseControl)
Proprietà protetta | SizeableIsCaptionVisible | (Ereditato da BaseControl)
Proprietà protetta | SizeableMaxSize | (Ereditato da BaseControl)
Proprietà protetta | SizeableMinSize | (Ereditato da BaseControl)
Proprietà pubblica | SortOrder | (Ereditato da BaseListBoxControl)
Proprietà pubblica | StyleController | (Ereditato da BaseControl)
Proprietà pubblica | SuperTip | (Ereditato da BaseControl)
Proprietà pubblica | Templates | (Ereditato da BaseListBoxControl)
Proprietà pubblica | Text | (Ereditato da BaseListBoxControl)
Proprietà pubblica | ToolTip | (Ereditato da BaseControl)
Proprietà pubblica | ToolTipAnchor | (Ereditato da BaseControl)
Proprietà pubblica | ToolTipController | (Ereditato da BaseControl)
Proprietà pubblica | ToolTipIconType | (Ereditato da BaseControl)
Proprietà pubblica | ToolTipTitle | (Ereditato da BaseControl)
Proprietà pubblica | TopIndex | (Ereditato da BaseListBoxControl)
Proprietà protetta | UseBaseBackColor | (Ereditato da BaseStyleControl)
Proprietà pubblica | UseDisabledStatePainter | (Ereditato da BaseListBoxControl)
Proprietà pubblica | ValueMember | (Ereditato da BaseListBoxControl)
Proprietà protetta | ViewInfo | (Ereditato da BaseImageListBoxControl)
Proprietà protetta | ViewMember | (Ereditato da BaseListBoxControl)
Torna su
Vedi anche

Documentazione

Classe CustomImageListBoxControl
Namespace DedNet.Controls


Proprietà CustomImageListBoxControl.SelectedIndex

Proprietà CustomImageListBoxControlSelectedIndex

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override int SelectedIndex { get; set; }
Public Overrides Property SelectedIndex As Integer
    Get
    Set
public:
virtual property int SelectedIndex {
    int get () override;
    void set (int value) override;
}
abstract SelectedIndex : int with get, set
override SelectedIndex : int with get, set

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe CustomImageListBoxControl
Namespace DedNet.Controls


Metodi di CustomImageListBoxControl

Il tipo CustomImageListBoxControl espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateDataSource | (Ereditato da BaseListBoxControl)
Metodo protetto | AddCustomSortHandler``1 | (Ereditato da BaseListBoxControl)
Metodo pubblico | AddEnum(Type) | (Ereditato da BaseListBoxControl)
Metodo pubblico | AddEnum(Type, Boolean) | (Ereditato da BaseListBoxControl)
Metodo pubblico | AddEnum``1 | (Ereditato da BaseListBoxControl)
Metodo pubblico | AddEnum``1(ConverterUMP, String) | (Ereditato da BaseListBoxControl)
Metodo pubblico | AddEnum``1(ConverterUMP, String, Boolean) | (Ereditato da BaseListBoxControl)
Metodo protetto | ApplyDelayedOperations | (Ereditato da BaseListBoxControl)
Metodo protetto | ApplyInlineSearch | (Ereditato da BaseListBoxControl)
Metodo protetto | ApplyItemsFilter | (Ereditato da BaseListBoxControl)
Metodo protetto | ApplySort | (Ereditato da BaseListBoxControl)
Metodo protetto | BaseWndProc | (Ereditato da ControlBase)
Metodo pubblico | BeginUpdate | (Ereditato da BaseListBoxControl)
Metodo pubblico | BindCommand(Object, String, FuncObject) | (Ereditato da BaseListBoxControl)
Metodo pubblico | BindCommand(ExpressionAction, Object, String, FuncObject) | (Ereditato da BaseListBoxControl)
Metodo pubblico | BindCommand``1(ExpressionActionUMP, Object, String, FuncUMP) | (Ereditato da BaseListBoxControl)
Metodo pubblico | CalcBestSize | (Ereditato da BaseControl)
Metodo protetto | CalcDefaultSizeableMinWidth | (Ereditato da BaseControl)
Metodo protetto | CalcHandlerState | (Ereditato da BaseListBoxControl)
Metodo protetto | CalcSizeableMaxSize | (Ereditato da BaseListBoxControl)
Metodo protetto | CalcSizeableMinSize | (Ereditato da BaseListBoxControl)
Metodo protetto | CanApplyItemsFilter | (Ereditato da BaseListBoxControl)
Metodo pubblico | CancelUpdate | (Ereditato da BaseListBoxControl)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da BaseControl)
Metodo protetto | CheckRightToLeft | (Ereditato da ControlBase)
Metodo protetto | CheckStopAnimation | (Ereditato da BaseListBoxControl)
Metodo protetto | ClearItemSizes | (Ereditato da BaseListBoxControl)
Metodo protetto | ConvertValueToString | (Ereditato da BaseListBoxControl)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da BaseControl)
Metodo protetto | CreateAccessibleInstance | (Ereditato da BaseListBoxControl)
Metodo protetto | CreateAppearance | (Ereditato da BaseStyleControl)
Metodo protetto | CreateCache | (Ereditato da BaseControl)
Metodo protetto | CreateContextButtonOptions | (Ereditato da BaseListBoxControl)
Metodo protetto | CreateContextButtonsCollection | (Ereditato da BaseListBoxControl)
Metodo protetto | CreateCustomSortComparer``1 | (Ereditato da BaseListBoxControl)
Metodo protetto | CreateDataAdapter | (Ereditato da BaseListBoxControl)
Metodo protetto | CreateDirectXProvider | (Ereditato da XtraControl)
Metodo protetto | CreateHandler | (Ereditato da BaseListBoxControl)
Metodo protetto | CreateHtmlTemplates | (Ereditato da BaseListBoxControl)
Metodo protetto | CreateItemActions | (Ereditato da BaseListBoxControl)
Metodo protetto | CreateItemsCollection | (Ereditato da ImageListBoxControl)
Metodo protetto | CreateListBoxModel | (Ereditato da BaseListBoxControl)
Metodo protetto | CreateLookAndFeel | (Ereditato da BaseControl)
Metodo protetto | CreatePainter | (Ereditato da ImageListBoxControl)
Metodo protetto | CreateScrollInfo | (Ereditato da BaseListBoxControl)
Metodo protetto | CreateSearchControlProviderBase | (Ereditato da BaseListBoxControl)
Metodo protetto | CreateSelectedIndexCollection | (Ereditato da BaseListBoxControl)
Metodo protetto | CreateViewInfo | (Ereditato da ImageListBoxControl)
Metodo protetto | DescaleInteger | (Ereditato da BaseControl)
Metodo protetto | DestroyAppearance | (Ereditato da BaseStyleControl)
Metodo protetto | DestroyDataAdapter | (Ereditato da BaseListBoxControl)
Metodo protetto | Dispose | (Ereditato da ImageListBoxControl)
Metodo protetto | DoDpiChange | (Ereditato da BaseListBoxControl)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da BaseListBoxControl)
Metodo protetto | DoSort | (Ereditato da ImageListBoxControl)
Metodo pubblico | EndUpdate | (Ereditato da BaseListBoxControl)
Metodo protetto | EnsureControlRowSource | (Ereditato da BaseListBoxControl)
Metodo protetto | FilterDescriptorCollectionCore | (Ereditato da BaseStyleControl)
Metodo pubblico | FindItem(Object) | (Ereditato da BaseListBoxControl)
Metodo pubblico | FindItem(Int32, Boolean, ListBoxFindItemDelegate) | (Ereditato da BaseListBoxControl)
Metodo pubblico | FindString(String) | (Ereditato da BaseListBoxControl)
Metodo pubblico | FindString(String, Int32) | (Ereditato da BaseListBoxControl)
Metodo pubblico | FindString(String, Int32, Boolean) | (Ereditato da BaseListBoxControl)
Metodo pubblico | FindStringExact(String) | (Ereditato da BaseListBoxControl)
Metodo pubblico | FindStringExact(String, Int32) | (Ereditato da BaseListBoxControl)
Metodo protetto | FindValueIndex | (Ereditato da BaseListBoxControl)
Metodo protetto | FireChanged | (Ereditato da BaseControl)
Metodo pubblico | ForceInitialize | (Ereditato da BaseListBoxControl)
Metodo protetto | GetAccessibilityObjectById | (Ereditato da BaseListBoxControl)
Metodo pubblico | GetAccessible | (Ereditato da BaseControl)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da BaseControl)
Metodo protetto | GetAllowHtmlDraw | (Ereditato da BaseListBoxControl)
Metodo protetto | GetAllowHtmlDraw(Int32) | (Ereditato da BaseListBoxControl)
Metodo pubblico | GetBaseTextBounds | (Ereditato da BaseListBoxControl)
Metodo protetto | GetBoundItemImage | (Ereditato da BaseImageListBoxControl)
Metodo protetto | GetBoundItemImageIndex | (Ereditato da BaseImageListBoxControl)
Metodo protetto | GetBoundItemImageOptions | (Ereditato da BaseImageListBoxControl)
Metodo protetto | GetColor(Color, Color) | (Ereditato da BaseControl)
Metodo protetto | GetColor(Color, Color, Boolean) | (Ereditato da BaseControl)
Metodo protetto | GetDataItemsLookupItem(Int32) | (Ereditato da BaseListBoxControl)
Metodo protetto | GetDataItemsLookupItem(Object) | (Ereditato da BaseListBoxControl)
Metodo protetto | GetDataSourceDisplayText | (Ereditato da BaseListBoxControl)
Metodo protetto | GetDataSourceDisplayValue | (Ereditato da BaseListBoxControl)
Metodo protetto | GetDataSourceValue(Int32) | (Ereditato da BaseListBoxControl)
Metodo protetto | GetDataSourceValue(Int32, String) | (Ereditato da BaseListBoxControl)
Metodo protetto | GetDeviceSize | (Ereditato da XtraControl)
Metodo pubblico | GetDisplayItemValue | (Ereditato da BaseListBoxControl)
Metodo protetto | GetDrawItemText(Int32) | (Ereditato da BaseListBoxControl)
Metodo protetto | GetDrawItemText(Int32, Int32) | (Ereditato da BaseListBoxControl)
Metodo protetto | GetDrawItemTextCore | (Ereditato da BaseListBoxControl)
Metodo protetto | GetForceHtmlDraw | (Ereditato da BaseListBoxControl)
Metodo protetto | GetHtmlDraw | (Ereditato da BaseListBoxControl)
Metodo protetto | GetHtmlIntellisenceFields | (Ereditato da ImageListBoxControl)
Metodo protetto | GetIndex | (Ereditato da BaseListBoxControl)
Metodo pubblico | GetItem | (Ereditato da BaseListBoxControl)
Metodo protetto | GetItemAccessibilityText | (Ereditato da BaseListBoxControl)
Metodo protetto | GetItemCore | (Ereditato da BaseListBoxControl)
Metodo protetto | GetItemDisplayValue | (Ereditato da ImageListBoxControl)
Metodo protetto | GetItemDisplayValueGetter | (Ereditato da BaseListBoxControl)
Metodo protetto | GetItemEnabledCore | (Ereditato da BaseListBoxControl)
Metodo pubblico | GetItemImage | (Ereditato da BaseImageListBoxControl)
Metodo protetto | GetItemImageCore | (Ereditato da ImageListBoxControl)
Metodo pubblico | GetItemImageIndex | (Ereditato da BaseImageListBoxControl)
Metodo protetto | GetItemImageIndexCore | (Ereditato da ImageListBoxControl)
Metodo pubblico | GetItemImageOptions | (Ereditato da BaseImageListBoxControl)
Metodo protetto | GetItemImageOptionsCore | (Ereditato da ImageListBoxControl)
Metodo pubblico | GetItemImageSize | (Ereditato da BaseImageListBoxControl)
Metodo protetto | GetItemImageSizeCore | (Ereditato da ImageListBoxControl)
Metodo pubblico | GetItemRectangle | (Ereditato da BaseListBoxControl)
Metodo protetto | GetItemsComparer | (Ereditato da BaseListBoxControl)
Metodo protetto | GetItemTemplateArgs | (Ereditato da BaseListBoxControl)
Metodo pubblico | GetItemText | (Ereditato da BaseListBoxControl)
Metodo protetto | GetItemTextCore | (Ereditato da BaseListBoxControl)
Metodo pubblico | GetItemValue | (Ereditato da BaseListBoxControl)
Metodo protetto | GetItemValueCore | (Ereditato da ImageListBoxControl)
Metodo protetto | GetItemVisibleCore | (Ereditato da BaseListBoxControl)
Metodo protetto | GetMatchedRanges | (Ereditato da BaseListBoxControl)
Metodo protetto | GetNextVisibleItem | (Ereditato da BaseListBoxControl)
Metodo protetto | GetScaleDpiCore | (Ereditato da BaseControl)
Metodo protetto | GetSearchMember | (Ereditato da BaseListBoxControl)
Metodo protetto | GetSelectedRowSource | (Ereditato da BaseListBoxControl)
Metodo protetto | GetToolTipAnchor | (Ereditato da BaseControl)
Metodo protetto | GetToolTipInfo | (Ereditato da BaseListBoxControl)
Metodo protetto | GetUnboundColumns | (Ereditato da BaseImageListBoxControl)
Metodo protetto | GetUsedColumns | (Ereditato da BaseListBoxControl)
Metodo protetto | GetUseDirectXPaint | (Ereditato da XtraControl)
Metodo protetto | GetValidationCanceled | (Ereditato da ControlBase)
Metodo pubblico | GetViewInfo | (Ereditato da BaseControl)
Metodo protetto | GetVisibleIndex | (Ereditato da BaseListBoxControl)
Metodo protetto | GetVisibleItemsCount | (Ereditato da BaseListBoxControl)
Metodo pubblico | IndexFromPoint | (Ereditato da BaseListBoxControl)
Metodo protetto | InitializeItemDisplayValueGetter | (Ereditato da BaseListBoxControl)
Metodo protetto | IsAdvHotTrackEnabled | (Ereditato da BaseListBoxControl)
Metodo protetto | IsInputChar | (Ereditato da BaseListBoxControl)
Metodo protetto | IsInputKey | (Ereditato da BaseListBoxControl)
Metodo protetto | IsNotLoadedItem | (Ereditato da BaseListBoxControl)
Metodo protetto | IsSkinnedHightlighingEnabled | (Ereditato da BaseListBoxControl)
Metodo protetto | IsValidDataSource | (Ereditato da BaseListBoxControl)
Metodo protetto | LayoutChanged | (Ereditato da BaseListBoxControl)
Metodo protetto | LayoutChangedCore | (Ereditato da BaseControl)
Metodo protetto | LockSorting | (Ereditato da BaseListBoxControl)
Metodo pubblico | MakeItemVisible | (Ereditato da BaseListBoxControl)
Metodo protetto | NotifyAccessibilityClients(AccessibleEvents, Int32, Int32) | (Ereditato da BaseControl)
Metodo protetto | NotifyAccessibilityClients(AccessibleEvents, AutomationElementProvider, Int32, Int32) | (Ereditato da BaseControl)
Metodo protetto | NotifyAccessibilitySelectedIndexChanged | (Ereditato da BaseListBoxControl)
Metodo protetto | OnActionItemClick | (Ereditato da BaseListBoxControl)
Metodo protetto | OnAfterUpdateViewInfo | (Ereditato da BaseControl)
Metodo protetto | OnBeforeUpdateViewInfo | (Ereditato da BaseControl)
Metodo protetto | OnBindingContextChanged | (Ereditato da BaseListBoxControl)
Metodo protetto | OnBorderStyleChanged | (Ereditato da BaseControl)
Metodo protetto | OnCollectionChanged | (Ereditato da ImageListBoxControl)
Metodo protetto | OnCreateControl | (Ereditato da BaseListBoxControl)
Metodo protetto | OnDataSourceChanged(Object, EventArgs) |
Metodo protetto | OnDataSourceChanged(Object, EventArgs) | (Ereditato da BaseImageListBoxControl)
Metodo protetto | OnDirectXPaintDisabled | (Ereditato da XtraControl)
Metodo protetto | OnDirectXPaintEnabled | (Ereditato da XtraControl)
Metodo protetto | OnEnabledChanged | (Ereditato da BaseListBoxControl)
Metodo protetto | OnExpandItem | (Ereditato da BaseListBoxControl)
Metodo protetto | OnGotCapture | (Ereditato da ControlBase)
Metodo protetto | OnGotFocus | (Ereditato da BaseListBoxControl)
Metodo protetto | OnHandleCreated | (Ereditato da BaseListBoxControl)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraControl)
Metodo protetto | OnItemFound | (Ereditato da BaseListBoxControl)
Metodo protetto | OnKeyDown | (Ereditato da BaseListBoxControl)
Metodo protetto | OnKeyPress | (Ereditato da BaseListBoxControl)
Metodo protetto | OnKeyUp | (Ereditato da BaseListBoxControl)
Metodo protetto | OnListChanged | (Ereditato da BaseListBoxControl)
Metodo protetto | OnListChangedDefault | (Ereditato da BaseListBoxControl)
Metodo protetto | OnListItemAdded | (Ereditato da BaseListBoxControl)
Metodo protetto | OnListItemDeleted | (Ereditato da BaseListBoxControl)
Metodo protetto | OnListReset | (Ereditato da BaseListBoxControl)
Metodo protetto | OnLoaded | (Ereditato da BaseListBoxControl)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da BaseListBoxControl)
Metodo protetto | OnLostCapture | (Ereditato da BaseListBoxControl)
Metodo protetto | OnLostFocus | (Ereditato da BaseListBoxControl)
Metodo protetto | OnMouseDown | (Ereditato da BaseListBoxControl)
Metodo protetto | OnMouseEnter | (Ereditato da BaseListBoxControl)
Metodo protetto | OnMouseLeave | (Ereditato da BaseListBoxControl)
Metodo protetto | OnMouseMove | (Ereditato da BaseListBoxControl)
Metodo protetto | OnMouseUp | (Ereditato da BaseListBoxControl)
Metodo protetto | OnMouseWheel | (Ereditato da BaseListBoxControl)
Metodo protetto | OnMouseWheelCore | (Ereditato da BaseListBoxControl)
Metodo protetto | OnMultiColumnChanged | (Ereditato da BaseListBoxControl)
Metodo protetto | OnPaddingChanged | (Ereditato da BaseControl)
Metodo protetto | OnPaint | (Ereditato da BaseListBoxControl)
Metodo protetto | OnPaintBackground | (Ereditato da BaseListBoxControl)
Metodo protetto | OnParentChanged | (Ereditato da ControlBase)
Metodo protetto | OnPositionChanged | (Ereditato da BaseListBoxControl)
Metodo protetto | OnPropertiesChanged | (Ereditato da BaseControl)
Metodo protetto | OnResize | (Ereditato da BaseListBoxControl)
Metodo protetto | OnRightToLeftChanged | (Ereditato da BaseControl)
Metodo protetto | OnRightToLeftChanged(EventArgs) | (Ereditato da BaseListBoxControl)
Metodo protetto | OnScaleControl | (Ereditato da BaseListBoxControl)
Metodo protetto | OnScaleDpiChanged | (Ereditato da ControlBase)
Metodo protetto | OnSelectionChanged | (Ereditato da BaseListBoxControl)
Metodo protetto | OnSetSelectedValue | (Ereditato da BaseListBoxControl)
Metodo protetto | OnStyleChanged | (Ereditato da BaseListBoxControl)
Metodo protetto | OnStyleController_Disposed | (Ereditato da BaseControl)
Metodo protetto | OnStyleController_PropertiesChanged | (Ereditato da BaseControl)
Metodo protetto | OnStyleControllerChanged | (Ereditato da BaseListBoxControl)
Metodo protetto | OnVisibleChanged | (Ereditato da BaseListBoxControl)
Metodo protetto | OnVisibleRowCountChanged | (Ereditato da BaseListBoxControl)
Metodo protetto | PostApplyItemsFilter | (Ereditato da BaseListBoxControl)
Metodo protetto | PreApplyItemsFilter | (Ereditato da BaseListBoxControl)
Metodo protetto | ProcessDialogKey | (Ereditato da BaseListBoxControl)
Metodo protetto | ProcessPaintAction | (Ereditato da XtraControl)
Metodo protetto | RaiseContextButtonClick | (Ereditato da BaseListBoxControl)
Metodo protetto | RaiseContextButtonValueChanged | (Ereditato da BaseListBoxControl)
Metodo protetto | RaiseControlRowSourceChanged | (Ereditato da BaseListBoxControl)
Metodo protetto | RaiseCustomContextButtonToolTip | (Ereditato da BaseListBoxControl)
Metodo protetto | RaiseCustomDrawEmptyForeground | (Ereditato da BaseListBoxControl)
Metodo protetto | RaiseCustomItemTemplate | (Ereditato da BaseListBoxControl)
Metodo protetto | RaiseCustomizeContextItem | (Ereditato da BaseListBoxControl)
Metodo protetto | RaiseCustomizeTemplatedItem | (Ereditato da BaseListBoxControl)
Metodo protetto | RaiseCustomSort``1 | (Ereditato da BaseListBoxControl)
Metodo protetto | RaiseDataSourceChanged | (Ereditato da BaseListBoxControl)
Metodo protetto | RaiseDisplayMemberChanged | (Ereditato da BaseListBoxControl)
Metodo protetto | RaiseDrawItem | (Ereditato da BaseListBoxControl)
Metodo protetto | RaiseFocusedIndexChanged | (Ereditato da BaseListBoxControl)
Metodo protetto | RaiseHtmlElementMouseClick | (Ereditato da BaseListBoxControl)
Metodo protetto | RaiseHtmlElementMouseDown | (Ereditato da BaseListBoxControl)
Metodo protetto | RaiseHtmlElementMouseMove | (Ereditato da BaseListBoxControl)
Metodo protetto | RaiseHtmlElementMouseOut | (Ereditato da BaseListBoxControl)
Metodo protetto | RaiseHtmlElementMouseOver | (Ereditato da BaseListBoxControl)
Metodo protetto | RaiseHtmlElementMouseUp | (Ereditato da BaseListBoxControl)
Metodo protetto | RaiseImageIndexMemberChanged | (Ereditato da BaseImageListBoxControl)
Metodo protetto | RaiseImageMemberChanged | (Ereditato da BaseImageListBoxControl)
Metodo protetto | RaiseMeasureItem | (Ereditato da BaseListBoxControl)
Metodo protetto | RaisePaintEvent | (Ereditato da BaseControl)
Metodo protetto | RaisePaintExEvent | (Ereditato da XtraControl)
Metodo protetto | RaiseParseSearchControlText | (Ereditato da BaseListBoxControl)
Metodo protetto | RaiseSearch | (Ereditato da BaseListBoxControl)
Metodo protetto | RaiseSelectedIndexChanged | (Ereditato da BaseListBoxControl)
Metodo protetto | RaiseSelectedValueChanged | (Ereditato da BaseListBoxControl)
Metodo protetto | RaiseSizeableChanged | (Ereditato da BaseControl)
Metodo protetto | RaiseValueMemberChanged | (Ereditato da BaseListBoxControl)
Metodo protetto | RecalcViewInfoState | (Ereditato da BaseListBoxControl)
Metodo pubblico | Refresh | (Ereditato da BaseControl)
Metodo protetto | ReleaseDirectXResources | (Ereditato da XtraControl)
Metodo protetto | ReleaseStyleController | (Ereditato da BaseControl)
Metodo protetto | RemoveCustomSortHandler``1 | (Ereditato da BaseListBoxControl)
Metodo protetto | RemoveXtraAnimator | (Ereditato da BaseControl)
Metodo protetto | ResetAccessible | (Ereditato da BaseControl)
Metodo pubblico | ResetBackColor | (Ereditato da BaseStyleControl)
Metodo pubblico | ResetForeColor | (Ereditato da BaseStyleControl)
Metodo protetto | ResetInlineSearchMode | (Ereditato da BaseListBoxControl)
Metodo pubblico | ResetPainter | (Ereditato da BaseStyleControl)
Metodo pubblico | ResetSuperTip | (Ereditato da BaseControl)
Metodo pubblico | ResetViewInfo | (Ereditato da BaseStyleControl)
Metodo protetto | ScaleControl | (Ereditato da ControlBase)
Metodo protetto | ScaleInteger | (Ereditato da BaseControl)
Metodo protetto | ScaleSize | (Ereditato da BaseControl)
Metodo pubblico | SelectAll | (Ereditato da BaseListBoxControl)
Metodo protetto | SetBackColor | (Ereditato da BaseControl)
Metodo protetto | SetDataSourceValue | (Ereditato da BaseListBoxControl)
Metodo protetto | SetInlineSearchMode | (Ereditato da BaseListBoxControl)
Metodo protetto | SetItemCore | (Ereditato da BaseListBoxControl)
Metodo protetto | SetItems | (Ereditato da BaseListBoxControl)
Metodo pubblico | SetItemValue | (Ereditato da BaseListBoxControl)
Metodo protetto | SetItemValueCore | (Ereditato da ImageListBoxControl)
Metodo protetto | SetLeftCoordCore | (Ereditato da BaseListBoxControl)
Metodo pubblico | SetSelected | (Ereditato da BaseListBoxControl)
Metodo protetto | SetSelectedIndexCore | (Ereditato da BaseListBoxControl)
Metodo protetto | SetTopIndexCore | (Ereditato da BaseListBoxControl)
Metodo protetto | SetVisibleCore | (Ereditato da ControlBase)
Metodo pubblico | Sort | (Ereditato da BaseListBoxControl)
Metodo protetto | SubscribeDataAdapterEvents | (Ereditato da BaseListBoxControl)
Metodo protetto | SubscribeImageListEvents | (Ereditato da ImageListBoxControl)
Metodo protetto | UnlockSorting | (Ereditato da BaseListBoxControl)
Metodo pubblico | UnSelectAll | (Ereditato da BaseListBoxControl)
Metodo protetto | UnsubscribeDataAdapterEvents | (Ereditato da BaseListBoxControl)
Metodo protetto | UnsubscribeImageListEvents | (Ereditato da ImageListBoxControl)
Metodo protetto | UpdateBindingManager | (Ereditato da BaseListBoxControl)
Metodo protetto | UpdateDataItemsLookup | (Ereditato da BaseListBoxControl)
Metodo protetto | UpdateLeftCoord | (Ereditato da BaseListBoxControl)
Metodo protetto | UpdateScaleDpi | (Ereditato da XtraControl)
Metodo protetto | UpdateScaleFactorForScaleHelper | (Ereditato da XtraControl)
Metodo protetto | UpdateScrollBars | (Ereditato da BaseListBoxControl)
Metodo protetto | UpdateViewInfo | (Ereditato da BaseControl)
Metodo protetto | UpdateViewInfoState | (Ereditato da BaseControl)
Metodo protetto | UpdateViewInfoState(Boolean) | (Ereditato da BaseControl)
Metodo protetto | UpdateViewInfoState(Boolean, Point) | (Ereditato da BaseControl)
Metodo protetto | WndProc | (Ereditato da BaseListBoxControl)
Torna su
Vedi anche

Documentazione

Classe CustomImageListBoxControl
Namespace DedNet.Controls


Metodo CustomImageListBoxControl.OnDataSourceChanged

Metodo CustomImageListBoxControlOnDataSourceChanged
Lista degli overload
 | Nome | Descrizione
Metodo protetto | OnDataSourceChanged(Object, EventArgs) |
Metodo protetto | OnDataSourceChanged(Object, EventArgs) |
Torna su
Vedi anche

Documentazione

Classe CustomImageListBoxControl
Namespace DedNet.Controls


Metodo CustomImageListBoxControl.OnDataSourceChanged(Object, EventArgs)

Metodo CustomImageListBoxControlOnDataSourceChanged(Object, EventArgs)

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected virtual void OnDataSourceChanged(
    Object sender,
    EventArgs e
)
Protected Overridable Sub OnDataSourceChanged (
    sender As Object,
    e As EventArgs
)
protected:
virtual void OnDataSourceChanged(
    Object^ sender,
    EventArgs^ e
)
abstract OnDataSourceChanged :
        sender : Object *
        e : EventArgs -> unit
override OnDataSourceChanged :
        sender : Object *
        e : EventArgs -> unit

Parametri

sender Object
e EventArgs
Vedi anche

Documentazione

Classe CustomImageListBoxControl
Overload di OnDataSourceChanged
Namespace DedNet.Controls


Eventi di CustomImageListBoxControl

Il tipo CustomImageListBoxControl espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | BackColorChanged | (Ereditato da BaseStyleControl)
Evento pubblico | ContextButtonClick | (Ereditato da BaseListBoxControl)
Evento pubblico | ContextButtonValueChanged | (Ereditato da BaseListBoxControl)
Evento pubblico | CustomContextButtonToolTip | (Ereditato da BaseListBoxControl)
Evento pubblico | CustomDrawEmptyForeground | (Ereditato da BaseListBoxControl)
Evento pubblico | CustomDrawScroll | (Ereditato da BaseListBoxControl)
Evento pubblico | CustomItemDisplayText | (Ereditato da BaseListBoxControl)
Evento pubblico | CustomItemTemplate | (Ereditato da BaseListBoxControl)
Evento pubblico | CustomizeContextItem | (Ereditato da BaseListBoxControl)
Evento pubblico | CustomizeItem | (Ereditato da BaseListBoxControl)
Evento pubblico | CustomSort | (Ereditato da ImageListBoxControl)
Evento pubblico | DataSourceChanged | (Ereditato da BaseListBoxControl)
Evento pubblico | DisplayMemberChanged | (Ereditato da BaseListBoxControl)
Evento pubblico | DrawItem | (Ereditato da BaseListBoxControl)
Evento protetto | FocusedIndexChanged | (Ereditato da BaseListBoxControl)
Evento pubblico | FontChanged | (Ereditato da BaseStyleControl)
Evento pubblico | ForeColorChanged | (Ereditato da BaseStyleControl)
Evento pubblico | HtmlElementMouseClick | (Ereditato da BaseListBoxControl)
Evento pubblico | HtmlElementMouseDown | (Ereditato da BaseListBoxControl)
Evento pubblico | HtmlElementMouseMove | (Ereditato da BaseListBoxControl)
Evento pubblico | HtmlElementMouseOut | (Ereditato da BaseListBoxControl)
Evento pubblico | HtmlElementMouseOver | (Ereditato da BaseListBoxControl)
Evento pubblico | HtmlElementMouseUp | (Ereditato da BaseListBoxControl)
Evento pubblico | ImageIndexMemberChanged | (Ereditato da BaseImageListBoxControl)
Evento pubblico | ImageMemberChanged | (Ereditato da BaseImageListBoxControl)
Evento pubblico | MeasureItem | (Ereditato da BaseListBoxControl)
Evento pubblico | PaintEx | (Ereditato da XtraControl)
Evento pubblico | ParseSearchControlText | (Ereditato da BaseListBoxControl)
Evento protetto | Search | (Ereditato da BaseListBoxControl)
Evento pubblico | SelectedIndexChanged | (Ereditato da BaseListBoxControl)
Evento pubblico | SelectedValueChanged | (Ereditato da BaseListBoxControl)
Evento pubblico | ValueMemberChanged | (Ereditato da BaseListBoxControl)
Torna su
Vedi anche

Documentazione

Classe CustomImageListBoxControl
Namespace DedNet.Controls


Campi di CustomImageListBoxControl

Il tipo CustomImageListBoxControl espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | fDisposing | (Ereditato da BaseControl)
Campo protetto | fGlyphAlignment | (Ereditato da BaseImageListBoxControl)
Campo protetto | fShowToolTips | (Ereditato da BaseControl)
Campo protetto | shouldRaiseSizeableChanged | (Ereditato da BaseControl)
Torna su
Vedi anche

Documentazione

Classe CustomImageListBoxControl
Namespace DedNet.Controls


Classe CustomProcessNewValueEventArgs
Oggetto EventArgs dedicato alla gestione dell'evento ProcessNewValue. Impostare la proprietà "ListItemToAdd" per aggiungere i codici nel menu a tendina.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNet.ControlsCustomProcessNewValueEventArgs

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class CustomProcessNewValueEventArgs : EventArgs
Public Class CustomProcessNewValueEventArgs
    Inherits EventArgs
public ref class CustomProcessNewValueEventArgs : public EventArgs
type CustomProcessNewValueEventArgs =
    class
        inherit EventArgs
    end

Il tipo CustomProcessNewValueEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | CustomProcessNewValueEventArgs | Custruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Cancel | Elementi da aggiungere al lookupedit.
Proprietà pubblica | Data | Elementi da aggiungere al lookupedit.
Proprietà pubblica | ProcessNewValue | Ritorna il ProcessNewValueEventArgs originale, quello generato dal lookupedit.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore CustomProcessNewValueEventArgs
Custruttore unico.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public CustomProcessNewValueEventArgs(
    DedData data,
    ProcessNewValueEventArgs ev
)
Public Sub New (
    data As DedData,
    ev As ProcessNewValueEventArgs
)
public:
CustomProcessNewValueEventArgs(
    DedData^ data,
    ProcessNewValueEventArgs^ ev
)
new :
        data : DedData *
        ev : ProcessNewValueEventArgs -> CustomProcessNewValueEventArgs

Parametri

data DedData
Anagrafica da aggiungere all'elenco.
ev ProcessNewValueEventArgs
ProcessNewValueEventArgs generato dal lookupedit.
Vedi anche

Documentazione

Classe CustomProcessNewValueEventArgs
Namespace DedNet.Controls


Proprietà di CustomProcessNewValueEventArgs

Il tipo CustomProcessNewValueEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Cancel | Elementi da aggiungere al lookupedit.
Proprietà pubblica | Data | Elementi da aggiungere al lookupedit.
Proprietà pubblica | ProcessNewValue | Ritorna il ProcessNewValueEventArgs originale, quello generato dal lookupedit.
Torna su
Vedi anche

Documentazione

Classe CustomProcessNewValueEventArgs
Namespace DedNet.Controls


Proprietà CustomProcessNewValueEventArgs.Cancel

Proprietà CustomProcessNewValueEventArgsCancel
Elementi da aggiungere al lookupedit.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Cancel { get; set; }
Public Property Cancel As Boolean
    Get
    Set
public:
property bool Cancel {
    bool get ();
    void set (bool value);
}
member Cancel : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CustomProcessNewValueEventArgs
Namespace DedNet.Controls


Proprietà CustomProcessNewValueEventArgs.Data

Proprietà CustomProcessNewValueEventArgsData
Elementi da aggiungere al lookupedit.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; }
Public ReadOnly Property Data As DedData
    Get
public:
property DedData^ Data {
    DedData^ get ();
}
member Data : DedData with get

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe CustomProcessNewValueEventArgs
Namespace DedNet.Controls


Proprietà CustomProcessNewValueEventArgs.ProcessNewValue

Proprietà CustomProcessNewValueEventArgsProcessNewValue
Ritorna il ProcessNewValueEventArgs originale, quello generato dal lookupedit.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ProcessNewValueEventArgs ProcessNewValue { get; }
Public ReadOnly Property ProcessNewValue As ProcessNewValueEventArgs
    Get
public:
property ProcessNewValueEventArgs^ ProcessNewValue {
    ProcessNewValueEventArgs^ get ();
}
member ProcessNewValue : ProcessNewValueEventArgs with get

Valore della proprietà

ProcessNewValueEventArgs
Vedi anche

Documentazione

Classe CustomProcessNewValueEventArgs
Namespace DedNet.Controls


Classe DedAnagrViewControl
Classe per visualizzare e gestire il risultato di una ricerca
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
XtraUserControl
DedNet.ControlsUserControlBase
DedNet.ControlsDedAnagrViewControl

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedAnagrViewControl : UserControlBase
Public Class DedAnagrViewControl
    Inherits UserControlBase
public ref class DedAnagrViewControl : public UserControlBase
type DedAnagrViewControl =
    class
        inherit UserControlBase
    end

Il tipo DedAnagrViewControl espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedAnagrViewControl | Costruttore della classe
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Appearance | (Ereditato da XtraUserControl)
Proprietà pubblica | Application | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Proprietà pubblica | AttrList | Lista degli attributi della famiglia
Proprietà pubblica | BackColor | (Ereditato da XtraUserControl)
Proprietà pubblica | BottomPanelVisible | Proprietà per settare la visibilita del pannello in basso.
Proprietà protetta | CheckDoubleScaling | (Ereditato da XtraUserControl)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraUserControl)
Proprietà protetta | DirectXContainer | (Ereditato da XtraUserControl)
Proprietà pubblica | EnableIXtraResizeableControlInterfaceProxy | (Ereditato da XtraUserControl)
Proprietà pubblica | ExternalFilter | Indica se è presente una vista filtrata o no ( visualizzando una label )
Proprietà pubblica | FieldsDisplayOrder | Restituisce o imposta il dizionario contenente l'ordine di visualizzazione dei campi.
Proprietà pubblica | Font | (Ereditato da XtraUserControl)
Proprietà pubblica | ForeColor | (Ereditato da XtraUserControl)
Proprietà protetta | Helper | (Ereditato da XtraUserControl)
Proprietà pubblica | LabelMsgText | Imposta o ritorna il testo della label Msg.
Proprietà pubblica | LabelMsgVisible | Imposta o ritorna la visibilità della label Msg.
Proprietà pubblica | LastQueryCommand | Restuituisce l'ultimo comando utilizzato per effettuare la query. Restituisce null se non è ancora stata fatta una ricerca.
Proprietà pubblica | LastSelectedTypes | Restituisce le famiglie sulle quali è stata effettuala l'ultima query.
Proprietà pubblica | LookAndFeel | (Ereditato da XtraUserControl)
Proprietà protetta | Painter | (Ereditato da XtraUserControl)
Proprietà pubblica | RegistryBaseKey | Restituisce o imposta la chiave dalla quale leggere e nella quale scrivere le impostazioni.
Proprietà protetta | ScaleChildren | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleDPI | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraUserControl)
Proprietà pubblica | SelectedData | Restituisce la lista delle anagrafiche attualmente selezionante oppure null se non sono presenti anagrafiche.
Proprietà pubblica | SelectedNodes | Restituisce la lista dei nodi attualmente selezionati.
Proprietà protetta | ShouldCheckDpiScaleFactorOnParentChanged | (Ereditato da XtraUserControl)
Proprietà pubblica | ShowFamilyToolTip | Proprietà per visualizzare la tooltip con la famiglia
Proprietà pubblica | ShowPreview | Indica se mostrare la colonna di Anteprima.
Proprietà pubblica | Site | (Ereditato da XtraUserControl)
Proprietà pubblica | VisibleFields | Restituisce o imposta i campi che l'utente ha selezionato come visibili.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AddFilters | Dizionario dei filtri (Nome funzione filtro da chiamare)- (Prompt da visualizzare).
Metodo pubblico | AddRow | Aggiunge l'anagrafica al controllo.
Metodo protetto | BaseWndProc | (Ereditato da XtraUserControl)
Metodo pubblico | BoundQueryNull | Esegue una query con nessun valore solo per avere il RowFilter con i filtri corretti per tipologia di colonna.
Metodo pubblico | ClearMessageText | Svuota il testo della label Msg e la nasconde.
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraUserControl)
Metodo protetto | CreatePainter | (Ereditato da XtraUserControl)
Metodo protetto | Dispose | Liberare le risorse in uso. (Sovrascrive UserControlBaseDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraUserControl)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraUserControl)
Metodo pubblico | FindDataRowInControl | Controlla se il nodo è già presente nella lista.
Metodo pubblico | FireEventSelectionChanged | Controlla i parametri e lancia l'evento OnAnagrSelectionChanged
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraUserControl)
Metodo protetto | GetBackColor | (Ereditato da XtraUserControl)
Metodo protetto | GetBackgroundSkinElement | (Ereditato da XtraUserControl)
Metodo protetto | GetInnerIXtraResizableControl | (Ereditato da XtraUserControl)
Metodo pubblico | GetTree | Ritorna il controllo TreeList
Metodo protetto | IsChildControlsRequiredScalingEnabled | (Ereditato da XtraUserControl)
Metodo protetto | IsParentHandleCreatedRecursive | (Ereditato da XtraUserControl)
Metodo pubblico | LoadRegistrySetting | Legge dal registro le impostazioni della tabella.
Metodo protetto | OnAnagrSelectionChanged |
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraUserControl)
Metodo protetto | OnBackColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnContextMenuOpening | (Sovrascrive UserControlBaseOnContextMenuOpening(Object, CancelEventArgs))
Metodo protetto | OnControlAdded | (Ereditato da XtraUserControl)
Metodo protetto | OnControlRemoved | (Ereditato da XtraUserControl)
Metodo protetto | OnDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnFirstLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnForeColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleCreated | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraUserControl)
Metodo protetto | OnLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnMenuItemClicked | Evento di pressione di un comando del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnMouseDoubleClick |
Metodo protetto | OnPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnPaintCore | (Ereditato da XtraUserControl)
Metodo protetto | OnParentChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | OnSizeChanged | (Ereditato da XtraUserControl)
Metodo protetto | RaisePaintExEvent | (Ereditato da XtraUserControl)
Metodo pubblico | ReloadFilterInfo | Ricarica il filtro attivo nella colonna ECO (risolve il problema al display text)
Metodo pubblico | RemoveRows | Rimuove l'anagrafica dal controllo se presente.
Metodo pubblico | Requery | Rieffettua la query con i valori presenti (aggiorna il controllo).
Metodo pubblico | ResetBackColor | (Ereditato da XtraUserControl)
Metodo pubblico | ResetForeColor | (Ereditato da XtraUserControl)
Metodo protetto | RestoreAutoScaleModeChangedByPM2 | (Ereditato da XtraUserControl)
Metodo pubblico | RunSelect | Imposta le famiglie sulle quale eseguire la query ed esegue la query passata.
Metodo pubblico | SaveRegistrySetting | Salva nel registro le impostazioni della tabella.
Metodo protetto | ScaleControl | (Ereditato da XtraUserControl)
Metodo pubblico | SelectNodeList | Seleziona i nodi passati come parametro
Metodo pubblico | SetCommandList | Rigenera il menu contestuale di questo controllo con la lista dei comandi passati. (Sovrascrive UserControlBaseSetCommandList(DedCommandList, CommandContextEnum))
Metodo pubblico | SetFocus | Imposta il focus sulla griglia se sono presenti nodi.
Metodo pubblico | SetMessageText | Imposta nella label Msg il testo passato e la rende visibile.
Metodo protetto | SetVisibleCore | (Ereditato da XtraUserControl)
Metodo protetto | ShouldPaintTransparentBackground | (Ereditato da XtraUserControl)
Metodo protetto | ShouldUseDirectXPaint | (Ereditato da XtraUserControl)
Metodo pubblico | UpdateAnagraf | Aggiorna le anagrafiche attualmente selezionate
Metodo protetto | WndProc | (Ereditato da XtraUserControl)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | ContextMenuOpening | Evento su apertura del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | MenuItemClicked | Evento su click su un elemento del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | MouseDoubleClick | Evento di doppio click.
Evento pubblico | onAddToPrefer |
Evento pubblico | PaintEx | (Ereditato da XtraUserControl)
Evento pubblico | SelectionChanged | Evento su modifica della selezione.
Torna su
Campi
 | Nome | Descrizione
Campo protetto | _app | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Campo protetto | _RegistryBaseKey | Chiave nel registro di sistema di salvataggio impostazioni. (Ereditato da UserControlBase)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore DedAnagrViewControl
Costruttore della classe

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAnagrViewControl()
Public Sub New
public:
DedAnagrViewControl()
new : unit -> DedAnagrViewControl
Vedi anche

Documentazione

Classe DedAnagrViewControl
Namespace DedNet.Controls


Proprietà di DedAnagrViewControl

Il tipo DedAnagrViewControl espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Appearance | (Ereditato da XtraUserControl)
Proprietà pubblica | Application | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Proprietà pubblica | AttrList | Lista degli attributi della famiglia
Proprietà pubblica | BackColor | (Ereditato da XtraUserControl)
Proprietà pubblica | BottomPanelVisible | Proprietà per settare la visibilita del pannello in basso.
Proprietà protetta | CheckDoubleScaling | (Ereditato da XtraUserControl)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraUserControl)
Proprietà protetta | DirectXContainer | (Ereditato da XtraUserControl)
Proprietà pubblica | EnableIXtraResizeableControlInterfaceProxy | (Ereditato da XtraUserControl)
Proprietà pubblica | ExternalFilter | Indica se è presente una vista filtrata o no ( visualizzando una label )
Proprietà pubblica | FieldsDisplayOrder | Restituisce o imposta il dizionario contenente l'ordine di visualizzazione dei campi.
Proprietà pubblica | Font | (Ereditato da XtraUserControl)
Proprietà pubblica | ForeColor | (Ereditato da XtraUserControl)
Proprietà protetta | Helper | (Ereditato da XtraUserControl)
Proprietà pubblica | LabelMsgText | Imposta o ritorna il testo della label Msg.
Proprietà pubblica | LabelMsgVisible | Imposta o ritorna la visibilità della label Msg.
Proprietà pubblica | LastQueryCommand | Restuituisce l'ultimo comando utilizzato per effettuare la query. Restituisce null se non è ancora stata fatta una ricerca.
Proprietà pubblica | LastSelectedTypes | Restituisce le famiglie sulle quali è stata effettuala l'ultima query.
Proprietà pubblica | LookAndFeel | (Ereditato da XtraUserControl)
Proprietà protetta | Painter | (Ereditato da XtraUserControl)
Proprietà pubblica | RegistryBaseKey | Restituisce o imposta la chiave dalla quale leggere e nella quale scrivere le impostazioni.
Proprietà protetta | ScaleChildren | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleDPI | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraUserControl)
Proprietà pubblica | SelectedData | Restituisce la lista delle anagrafiche attualmente selezionante oppure null se non sono presenti anagrafiche.
Proprietà pubblica | SelectedNodes | Restituisce la lista dei nodi attualmente selezionati.
Proprietà protetta | ShouldCheckDpiScaleFactorOnParentChanged | (Ereditato da XtraUserControl)
Proprietà pubblica | ShowFamilyToolTip | Proprietà per visualizzare la tooltip con la famiglia
Proprietà pubblica | ShowPreview | Indica se mostrare la colonna di Anteprima.
Proprietà pubblica | Site | (Ereditato da XtraUserControl)
Proprietà pubblica | VisibleFields | Restituisce o imposta i campi che l'utente ha selezionato come visibili.
Torna su
Vedi anche

Documentazione

Classe DedAnagrViewControl
Namespace DedNet.Controls


Proprietà DedAnagrViewControl.AttrList

Proprietà DedAnagrViewControlAttrList
Lista degli attributi della famiglia

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList AttrList { get; set; }
Public Property AttrList As DedAttrList
    Get
    Set
public:
property DedAttrList^ AttrList {
    DedAttrList^ get ();
    void set (DedAttrList^ value);
}
member AttrList : DedAttrList with get, set

Valore della proprietà

DedAttrList
Vedi anche

Documentazione

Classe DedAnagrViewControl
Namespace DedNet.Controls


Proprietà DedAnagrViewControl.BottomPanelVisible

Proprietà DedAnagrViewControlBottomPanelVisible
Proprietà per settare la visibilita del pannello in basso.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool BottomPanelVisible { get; set; }
Public Property BottomPanelVisible As Boolean
    Get
    Set
public:
property bool BottomPanelVisible {
    bool get ();
    void set (bool value);
}
member BottomPanelVisible : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAnagrViewControl
Namespace DedNet.Controls


Proprietà DedAnagrViewControl.ExternalFilter

Proprietà DedAnagrViewControlExternalFilter
Indica se è presente una vista filtrata o no ( visualizzando una label )

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ExternalFilter { set; }
Public WriteOnly Property ExternalFilter As Boolean
    Set
public:
property bool ExternalFilter {
    void set (bool value);
}
member ExternalFilter : bool with set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAnagrViewControl
Namespace DedNet.Controls


Proprietà DedAnagrViewControl.FieldsDisplayOrder

Proprietà DedAnagrViewControlFieldsDisplayOrder
Restituisce o imposta il dizionario contenente l'ordine di visualizzazione dei campi.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<string, int> FieldsDisplayOrder { get; set; }
Public Property FieldsDisplayOrder As Dictionary(Of String, Integer)
    Get
    Set
public:
property Dictionary<String^, int>^ FieldsDisplayOrder {
    Dictionary<String^, int>^ get ();
    void set (Dictionary<String^, int>^ value);
}
member FieldsDisplayOrder : Dictionary<string, int> with get, set

Valore della proprietà

Dictionary String, Int32
Vedi anche

Documentazione

Classe DedAnagrViewControl
Namespace DedNet.Controls


Proprietà DedAnagrViewControl.LabelMsgText

Proprietà DedAnagrViewControlLabelMsgText
Imposta o ritorna il testo della label Msg.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string LabelMsgText { get; set; }
Public Property LabelMsgText As String
    Get
    Set
public:
property String^ LabelMsgText {
    String^ get ();
    void set (String^ value);
}
member LabelMsgText : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedAnagrViewControl
Namespace DedNet.Controls


Proprietà DedAnagrViewControl.LabelMsgVisible

Proprietà DedAnagrViewControlLabelMsgVisible
Imposta o ritorna la visibilità della label Msg.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool LabelMsgVisible { get; set; }
Public Property LabelMsgVisible As Boolean
    Get
    Set
public:
property bool LabelMsgVisible {
    bool get ();
    void set (bool value);
}
member LabelMsgVisible : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAnagrViewControl
Namespace DedNet.Controls


Proprietà DedAnagrViewControl.LastQueryCommand

Proprietà DedAnagrViewControlLastQueryCommand
Restuituisce l'ultimo comando utilizzato per effettuare la query. Restituisce null se non è ancora stata fatta una ricerca.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QSSelectCommand LastQueryCommand { get; }
Public ReadOnly Property LastQueryCommand As QSSelectCommand
    Get
public:
property QSSelectCommand^ LastQueryCommand {
    QSSelectCommand^ get ();
}
member LastQueryCommand : QSSelectCommand with get

Valore della proprietà

QSSelectCommand
Vedi anche

Documentazione

Classe DedAnagrViewControl
Namespace DedNet.Controls


Proprietà DedAnagrViewControl.LastSelectedTypes

Proprietà DedAnagrViewControlLastSelectedTypes
Restituisce le famiglie sulle quali è stata effettuala l'ultima query.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeBaseList LastSelectedTypes { get; }
Public ReadOnly Property LastSelectedTypes As DedTypeBaseList
    Get
public:
property DedTypeBaseList^ LastSelectedTypes {
    DedTypeBaseList^ get ();
}
member LastSelectedTypes : DedTypeBaseList with get

Valore della proprietà

DedTypeBaseList
Vedi anche

Documentazione

Classe DedAnagrViewControl
Namespace DedNet.Controls


Proprietà DedAnagrViewControl.RegistryBaseKey

Proprietà DedAnagrViewControlRegistryBaseKey
Restituisce o imposta la chiave dalla quale leggere e nella quale scrivere le impostazioni.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string RegistryBaseKey { get; set; }
Public Property RegistryBaseKey As String
    Get
    Set
public:
property String^ RegistryBaseKey {
    String^ get ();
    void set (String^ value);
}
member RegistryBaseKey : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedAnagrViewControl
Namespace DedNet.Controls


Proprietà DedAnagrViewControl.SelectedData

Proprietà DedAnagrViewControlSelectedData
Restituisce la lista delle anagrafiche attualmente selezionante oppure null se non sono presenti anagrafiche.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataList SelectedData { get; }
Public ReadOnly Property SelectedData As DedDataList
    Get
public:
property DedDataList^ SelectedData {
    DedDataList^ get ();
}
member SelectedData : DedDataList with get

Valore della proprietà

DedDataList
Vedi anche

Documentazione

Classe DedAnagrViewControl
Namespace DedNet.Controls


Proprietà DedAnagrViewControl.SelectedNodes

Proprietà DedAnagrViewControlSelectedNodes
Restituisce la lista dei nodi attualmente selezionati.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<int> SelectedNodes { get; }
Public ReadOnly Property SelectedNodes As List(Of Integer)
    Get
public:
property List<int>^ SelectedNodes {
    List<int>^ get ();
}
member SelectedNodes : List<int> with get

Valore della proprietà

List Int32
Vedi anche

Documentazione

Classe DedAnagrViewControl
Namespace DedNet.Controls


Proprietà DedAnagrViewControl.ShowFamilyToolTip

Proprietà DedAnagrViewControlShowFamilyToolTip
Proprietà per visualizzare la tooltip con la famiglia

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ShowFamilyToolTip { get; set; }
Public Property ShowFamilyToolTip As Boolean
    Get
    Set
public:
property bool ShowFamilyToolTip {
    bool get ();
    void set (bool value);
}
member ShowFamilyToolTip : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAnagrViewControl
Namespace DedNet.Controls


Proprietà DedAnagrViewControl.ShowPreview

Proprietà DedAnagrViewControlShowPreview
Indica se mostrare la colonna di Anteprima.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ShowPreview { get; set; }
Public Property ShowPreview As Boolean
    Get
    Set
public:
property bool ShowPreview {
    bool get ();
    void set (bool value);
}
member ShowPreview : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAnagrViewControl
Namespace DedNet.Controls


Proprietà DedAnagrViewControl.VisibleFields

Proprietà DedAnagrViewControlVisibleFields
Restituisce o imposta i campi che l'utente ha selezionato come visibili.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<DedAttr> VisibleFields { get; set; }
Public Property VisibleFields As List(Of DedAttr)
    Get
    Set
public:
property List<DedAttr^>^ VisibleFields {
    List<DedAttr^>^ get ();
    void set (List<DedAttr^>^ value);
}
member VisibleFields : List<DedAttr> with get, set

Valore della proprietà

List DedAttr
Vedi anche

Documentazione

Classe DedAnagrViewControl
Namespace DedNet.Controls


Metodi di DedAnagrViewControl

Il tipo DedAnagrViewControl espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AddFilters | Dizionario dei filtri (Nome funzione filtro da chiamare)- (Prompt da visualizzare).
Metodo pubblico | AddRow | Aggiunge l'anagrafica al controllo.
Metodo protetto | BaseWndProc | (Ereditato da XtraUserControl)
Metodo pubblico | BoundQueryNull | Esegue una query con nessun valore solo per avere il RowFilter con i filtri corretti per tipologia di colonna.
Metodo pubblico | ClearMessageText | Svuota il testo della label Msg e la nasconde.
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraUserControl)
Metodo protetto | CreatePainter | (Ereditato da XtraUserControl)
Metodo protetto | Dispose | Liberare le risorse in uso. (Sovrascrive UserControlBaseDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraUserControl)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraUserControl)
Metodo pubblico | FindDataRowInControl | Controlla se il nodo è già presente nella lista.
Metodo pubblico | FireEventSelectionChanged | Controlla i parametri e lancia l'evento OnAnagrSelectionChanged
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraUserControl)
Metodo protetto | GetBackColor | (Ereditato da XtraUserControl)
Metodo protetto | GetBackgroundSkinElement | (Ereditato da XtraUserControl)
Metodo protetto | GetInnerIXtraResizableControl | (Ereditato da XtraUserControl)
Metodo pubblico | GetTree | Ritorna il controllo TreeList
Metodo protetto | IsChildControlsRequiredScalingEnabled | (Ereditato da XtraUserControl)
Metodo protetto | IsParentHandleCreatedRecursive | (Ereditato da XtraUserControl)
Metodo pubblico | LoadRegistrySetting | Legge dal registro le impostazioni della tabella.
Metodo protetto | OnAnagrSelectionChanged |
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraUserControl)
Metodo protetto | OnBackColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnContextMenuOpening | (Sovrascrive UserControlBaseOnContextMenuOpening(Object, CancelEventArgs))
Metodo protetto | OnControlAdded | (Ereditato da XtraUserControl)
Metodo protetto | OnControlRemoved | (Ereditato da XtraUserControl)
Metodo protetto | OnDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnFirstLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnForeColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleCreated | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraUserControl)
Metodo protetto | OnLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnMenuItemClicked | Evento di pressione di un comando del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnMouseDoubleClick |
Metodo protetto | OnPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnPaintCore | (Ereditato da XtraUserControl)
Metodo protetto | OnParentChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | OnSizeChanged | (Ereditato da XtraUserControl)
Metodo protetto | RaisePaintExEvent | (Ereditato da XtraUserControl)
Metodo pubblico | ReloadFilterInfo | Ricarica il filtro attivo nella colonna ECO (risolve il problema al display text)
Metodo pubblico | RemoveRows | Rimuove l'anagrafica dal controllo se presente.
Metodo pubblico | Requery | Rieffettua la query con i valori presenti (aggiorna il controllo).
Metodo pubblico | ResetBackColor | (Ereditato da XtraUserControl)
Metodo pubblico | ResetForeColor | (Ereditato da XtraUserControl)
Metodo protetto | RestoreAutoScaleModeChangedByPM2 | (Ereditato da XtraUserControl)
Metodo pubblico | RunSelect | Imposta le famiglie sulle quale eseguire la query ed esegue la query passata.
Metodo pubblico | SaveRegistrySetting | Salva nel registro le impostazioni della tabella.
Metodo protetto | ScaleControl | (Ereditato da XtraUserControl)
Metodo pubblico | SelectNodeList | Seleziona i nodi passati come parametro
Metodo pubblico | SetCommandList | Rigenera il menu contestuale di questo controllo con la lista dei comandi passati. (Sovrascrive UserControlBaseSetCommandList(DedCommandList, CommandContextEnum))
Metodo pubblico | SetFocus | Imposta il focus sulla griglia se sono presenti nodi.
Metodo pubblico | SetMessageText | Imposta nella label Msg il testo passato e la rende visibile.
Metodo protetto | SetVisibleCore | (Ereditato da XtraUserControl)
Metodo protetto | ShouldPaintTransparentBackground | (Ereditato da XtraUserControl)
Metodo protetto | ShouldUseDirectXPaint | (Ereditato da XtraUserControl)
Metodo pubblico | UpdateAnagraf | Aggiorna le anagrafiche attualmente selezionate
Metodo protetto | WndProc | (Ereditato da XtraUserControl)
Torna su
Vedi anche

Documentazione

Classe DedAnagrViewControl
Namespace DedNet.Controls


Metodo DedAnagrViewControl.AddFilters

Metodo DedAnagrViewControlAddFilters
Dizionario dei filtri (Nome funzione filtro da chiamare)- (Prompt da visualizzare).

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddFilters(
    Dictionary<string, string> filters
)
Public Sub AddFilters (
    filters As Dictionary(Of String, String)
)
public:
void AddFilters(
    Dictionary<String^, String^>^ filters
)
member AddFilters :
        filters : Dictionary<string, string> -> unit

Parametri

filters Dictionary String, String
Vedi anche

Documentazione

Classe DedAnagrViewControl
Namespace DedNet.Controls


Metodo DedAnagrViewControl.AddRow

Metodo DedAnagrViewControlAddRow
Aggiunge l'anagrafica al controllo.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddRow(
    DedData data
)
Public Sub AddRow (
    data As DedData
)
public:
void AddRow(
    DedData^ data
)
member AddRow :
        data : DedData -> unit

Parametri

data DedData
Anagrafica da aggiungere
Vedi anche

Documentazione

Classe DedAnagrViewControl
Namespace DedNet.Controls


Metodo DedAnagrViewControl.BoundQueryNull

Metodo DedAnagrViewControlBoundQueryNull
Esegue una query con nessun valore solo per avere il RowFilter con i filtri corretti per tipologia di colonna.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void BoundQueryNull()
Public Sub BoundQueryNull
public:
void BoundQueryNull()
member BoundQueryNull : unit -> unit
Vedi anche

Documentazione

Classe DedAnagrViewControl
Namespace DedNet.Controls


Metodo DedAnagrViewControl.ClearMessageText

Metodo DedAnagrViewControlClearMessageText
Svuota il testo della label Msg e la nasconde.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ClearMessageText()
Public Sub ClearMessageText
public:
void ClearMessageText()
member ClearMessageText : unit -> unit
Vedi anche

Documentazione

Classe DedAnagrViewControl
Namespace DedNet.Controls


Metodo DedAnagrViewControl.Dispose

Metodo DedAnagrViewControlDispose
Liberare le risorse in uso.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
ha valore true se le risorse gestite devono essere eliminate, false in caso contrario.
Vedi anche

Documentazione

Classe DedAnagrViewControl
Namespace DedNet.Controls


Metodo DedAnagrViewControl.FindDataRowInControl

Metodo DedAnagrViewControlFindDataRowInControl
Controlla se il nodo è già presente nella lista.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DataRow[] FindDataRowInControl(
    DedData data
)
Public Function FindDataRowInControl (
    data As DedData
) As DataRow()
public:
array<DataRow^>^ FindDataRowInControl(
    DedData^ data
)
member FindDataRowInControl :
        data : DedData -> DataRow[]

Parametri

data DedData
Nodo da cercare.

Valore di ritorno

DataRow
True se il nodo è già presente, altrimenti false
Vedi anche

Documentazione

Classe DedAnagrViewControl
Namespace DedNet.Controls


Metodo DedAnagrViewControl.FireEventSelectionChanged

Metodo DedAnagrViewControlFireEventSelectionChanged
Controlla i parametri e lancia l'evento OnAnagrSelectionChanged

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void FireEventSelectionChanged()
Public Sub FireEventSelectionChanged
public:
void FireEventSelectionChanged()
member FireEventSelectionChanged : unit -> unit
Vedi anche

Documentazione

Classe DedAnagrViewControl
Namespace DedNet.Controls


Metodo DedAnagrViewControl.GetTree

Metodo DedAnagrViewControlGetTree
Ritorna il controllo TreeList

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public GridControl GetTree()
Public Function GetTree As GridControl
public:
GridControl^ GetTree()
member GetTree : unit -> GridControl

Valore di ritorno

GridControl
Vedi anche

Documentazione

Classe DedAnagrViewControl
Namespace DedNet.Controls


Metodo DedAnagrViewControl.LoadRegistrySetting

Metodo DedAnagrViewControlLoadRegistrySetting
Legge dal registro le impostazioni della tabella.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void LoadRegistrySetting()
Public Sub LoadRegistrySetting
public:
void LoadRegistrySetting()
member LoadRegistrySetting : unit -> unit
Vedi anche

Documentazione

Classe DedAnagrViewControl
Namespace DedNet.Controls


Metodo DedAnagrViewControl.OnAnagrSelectionChanged

Metodo DedAnagrViewControlOnAnagrSelectionChanged

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected void OnAnagrSelectionChanged(
    Object sender,
    DedAnagrViewControlDedAnagrEventArgs ev
)
Protected Sub OnAnagrSelectionChanged (
    sender As Object,
    ev As DedAnagrViewControlDedAnagrEventArgs
)
protected:
void OnAnagrSelectionChanged(
    Object^ sender,
    DedAnagrViewControlDedAnagrEventArgs^ ev
)
member OnAnagrSelectionChanged :
        sender : Object *
        ev : DedAnagrViewControlDedAnagrEventArgs -> unit

Parametri

sender Object
ev DedAnagrViewControlDedAnagrEventArgs
Vedi anche

Documentazione

Classe DedAnagrViewControl
Namespace DedNet.Controls


Metodo DedAnagrViewControl.OnContextMenuOpening

Metodo DedAnagrViewControlOnContextMenuOpening

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void OnContextMenuOpening(
    Object sender,
    CancelEventArgs e
)
Protected Overrides Sub OnContextMenuOpening (
    sender As Object,
    e As CancelEventArgs
)
protected:
virtual void OnContextMenuOpening(
    Object^ sender,
    CancelEventArgs^ e
) override
abstract OnContextMenuOpening :
        sender : Object *
        e : CancelEventArgs -> unit
override OnContextMenuOpening :
        sender : Object *
        e : CancelEventArgs -> unit

Parametri

sender Object
e CancelEventArgs
Vedi anche

Documentazione

Classe DedAnagrViewControl
Namespace DedNet.Controls


Metodo DedAnagrViewControl.OnMouseDoubleClick

Metodo DedAnagrViewControlOnMouseDoubleClick

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected void OnMouseDoubleClick(
    Object sender,
    MouseEventArgs e
)
Protected Sub OnMouseDoubleClick (
    sender As Object,
    e As MouseEventArgs
)
protected:
void OnMouseDoubleClick(
    Object^ sender,
    MouseEventArgs^ e
)
member OnMouseDoubleClick :
        sender : Object *
        e : MouseEventArgs -> unit

Parametri

sender Object
e MouseEventArgs
Vedi anche

Documentazione

Classe DedAnagrViewControl
Namespace DedNet.Controls


Metodo DedAnagrViewControl.ReloadFilterInfo

Metodo DedAnagrViewControlReloadFilterInfo
Ricarica il filtro attivo nella colonna ECO (risolve il problema al display text)

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ReloadFilterInfo()
Public Sub ReloadFilterInfo
public:
void ReloadFilterInfo()
member ReloadFilterInfo : unit -> unit
Vedi anche

Documentazione

Classe DedAnagrViewControl
Namespace DedNet.Controls


Metodo DedAnagrViewControl.RemoveRows

Metodo DedAnagrViewControlRemoveRows
Rimuove l'anagrafica dal controllo se presente.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void RemoveRows(
    DedDataList datas
)
Public Sub RemoveRows (
    datas As DedDataList
)
public:
void RemoveRows(
    DedDataList^ datas
)
member RemoveRows :
        datas : DedDataList -> unit

Parametri

datas DedDataList
Anagrafiche da rimuovere
Vedi anche

Documentazione

Classe DedAnagrViewControl
Namespace DedNet.Controls


Metodo DedAnagrViewControl.Requery

Metodo DedAnagrViewControlRequery
Rieffettua la query con i valori presenti (aggiorna il controllo).

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Requery()
Public Sub Requery
public:
void Requery()
member Requery : unit -> unit
Vedi anche

Documentazione

Classe DedAnagrViewControl
Namespace DedNet.Controls


Metodo DedAnagrViewControl.RunSelect

Metodo DedAnagrViewControlRunSelect
Imposta le famiglie sulle quale eseguire la query ed esegue la query passata.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void RunSelect(
    DedTypeBaseList selectedTypes,
    QSSelectCommand cmd
)
Public Sub RunSelect (
    selectedTypes As DedTypeBaseList,
    cmd As QSSelectCommand
)
public:
void RunSelect(
    DedTypeBaseList^ selectedTypes,
    QSSelectCommand^ cmd
)
member RunSelect :
        selectedTypes : DedTypeBaseList *
        cmd : QSSelectCommand -> unit

Parametri

selectedTypes DedTypeBaseList
Famiglie sulle quale effettuare la query.
cmd QSSelectCommand
Query da effettuare.
Vedi anche

Documentazione

Classe DedAnagrViewControl
Namespace DedNet.Controls


Metodo DedAnagrViewControl.SaveRegistrySetting

Metodo DedAnagrViewControlSaveRegistrySetting
Salva nel registro le impostazioni della tabella.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SaveRegistrySetting()
Public Sub SaveRegistrySetting
public:
void SaveRegistrySetting()
member SaveRegistrySetting : unit -> unit
Vedi anche

Documentazione

Classe DedAnagrViewControl
Namespace DedNet.Controls


Metodo DedAnagrViewControl.SelectNodeList

Metodo DedAnagrViewControlSelectNodeList
Seleziona i nodi passati come parametro

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SelectNodeList(
    List<int> nodeList
)
Public Sub SelectNodeList (
    nodeList As List(Of Integer)
)
public:
void SelectNodeList(
    List<int>^ nodeList
)
member SelectNodeList :
        nodeList : List<int> -> unit

Parametri

nodeList List Int32
nodi da selezionare
Vedi anche

Documentazione

Classe DedAnagrViewControl
Namespace DedNet.Controls


Metodo DedAnagrViewControl.SetCommandList

Metodo DedAnagrViewControlSetCommandList
Rigenera il menu contestuale di questo controllo con la lista dei comandi passati.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void SetCommandList(
    DedCommandList commandList,
    CommandContextEnum commandContext
)
Public Overrides Sub SetCommandList (
    commandList As DedCommandList,
    commandContext As CommandContextEnum
)
public:
virtual void SetCommandList(
    DedCommandList^ commandList,
    CommandContextEnum commandContext
) override
abstract SetCommandList :
        commandList : DedCommandList *
        commandContext : CommandContextEnum -> unit
override SetCommandList :
        commandList : DedCommandList *
        commandContext : CommandContextEnum -> unit

Parametri

commandList DedCommandList
Lista completa dei comandi.
commandContext CommandContextEnum
Contesto da utilizzare per filtrare i comandi da inserire.
Note
Filtra i comandi in modo da aggiungere soltanto quelli coerenti con il contesto passato.
Vedi anche

Documentazione

Classe DedAnagrViewControl
Namespace DedNet.Controls


Metodo DedAnagrViewControl.SetFocus

Metodo DedAnagrViewControlSetFocus
Imposta il focus sulla griglia se sono presenti nodi.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetFocus()
Public Sub SetFocus
public:
void SetFocus()
member SetFocus : unit -> unit
Vedi anche

Documentazione

Classe DedAnagrViewControl
Namespace DedNet.Controls


Metodo DedAnagrViewControl.SetMessageText

Metodo DedAnagrViewControlSetMessageText
Imposta nella label Msg il testo passato e la rende visibile.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetMessageText(
    string msg
)
Public Sub SetMessageText (
    msg As String
)
public:
void SetMessageText(
    String^ msg
)
member SetMessageText :
        msg : string -> unit

Parametri

msg String
Messaggio da impostare sulla label.
Vedi anche

Documentazione

Classe DedAnagrViewControl
Namespace DedNet.Controls


Metodo DedAnagrViewControl.UpdateAnagraf

Metodo DedAnagrViewControlUpdateAnagraf
Aggiorna le anagrafiche attualmente selezionate

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void UpdateAnagraf()
Public Sub UpdateAnagraf
public:
void UpdateAnagraf()
member UpdateAnagraf : unit -> unit
Vedi anche

Documentazione

Classe DedAnagrViewControl
Namespace DedNet.Controls


Eventi di DedAnagrViewControl

Il tipo DedAnagrViewControl espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | ContextMenuOpening | Evento su apertura del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | MenuItemClicked | Evento su click su un elemento del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | MouseDoubleClick | Evento di doppio click.
Evento pubblico | onAddToPrefer |
Evento pubblico | PaintEx | (Ereditato da XtraUserControl)
Evento pubblico | SelectionChanged | Evento su modifica della selezione.
Torna su
Vedi anche

Documentazione

Classe DedAnagrViewControl
Namespace DedNet.Controls


Evento DedAnagrViewControl.MouseDoubleClick

Evento DedAnagrViewControlMouseDoubleClick
Evento di doppio click.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event MouseEventHandler MouseDoubleClick
Public Event MouseDoubleClick As MouseEventHandler
public:
 event MouseEventHandler^ MouseDoubleClick {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}
member MouseDoubleClick : IEvent<MouseEventHandler,
    MouseEventArgs>

Valore

MouseEventHandler
Vedi anche

Documentazione

Classe DedAnagrViewControl
Namespace DedNet.Controls


Evento DedAnagrViewControl.onAddToPrefer

Evento DedAnagrViewControlonAddToPrefer

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<ItemClickEventArgs> onAddToPrefer
Public Event onAddToPrefer As EventHandler(Of ItemClickEventArgs)
public:
 event EventHandler<ItemClickEventArgs^>^ onAddToPrefer {
    void add (EventHandler<ItemClickEventArgs^>^ value);
    void remove (EventHandler<ItemClickEventArgs^>^ value);
}
member onAddToPrefer : IEvent<EventHandler<ItemClickEventArgs>,
    ItemClickEventArgs>

Valore

EventHandler ItemClickEventArgs
Vedi anche

Documentazione

Classe DedAnagrViewControl
Namespace DedNet.Controls


Evento DedAnagrViewControl.SelectionChanged

Evento DedAnagrViewControlSelectionChanged
Evento su modifica della selezione.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DedAnagrViewControlDedAnagrEventArgs> SelectionChanged
Public Event SelectionChanged As EventHandler(Of DedAnagrViewControlDedAnagrEventArgs)
public:
 event EventHandler<DedAnagrViewControlDedAnagrEventArgs^>^ SelectionChanged {
    void add (EventHandler<DedAnagrViewControlDedAnagrEventArgs^>^ value);
    void remove (EventHandler<DedAnagrViewControlDedAnagrEventArgs^>^ value);
}
member SelectionChanged : IEvent<EventHandler<DedAnagrViewControlDedAnagrEventArgs>,
    DedAnagrViewControlDedAnagrEventArgs>

Valore

EventHandler DedAnagrViewControlDedAnagrEventArgs
Vedi anche

Documentazione

Classe DedAnagrViewControl
Namespace DedNet.Controls


Campi di DedAnagrViewControl

Il tipo DedAnagrViewControl espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | _app | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Campo protetto | _RegistryBaseKey | Chiave nel registro di sistema di salvataggio impostazioni. (Ereditato da UserControlBase)
Torna su
Vedi anche

Documentazione

Classe DedAnagrViewControl
Namespace DedNet.Controls


Classe DedAnagrViewControl.DedAnagrEventArgs

Classe DedAnagrViewControlDedAnagrEventArgs
Classe contenente le informazioni per l'evento SelectionChanged.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNet.ControlsDedAnagrViewControlDedAnagrEventArgs

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedAnagrEventArgs : EventArgs
Public Class DedAnagrEventArgs
    Inherits EventArgs
public ref class DedAnagrEventArgs : public EventArgs
type DedAnagrEventArgs =
    class
        inherit EventArgs
    end

Il tipo DedAnagrViewControlDedAnagrEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedAnagrViewControlDedAnagrEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | DataList | Lista delle anagrafiche selezionate
Proprietà pubblica | NodeList | Lista dei nodi selezionati
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore DedAnagrViewControl.DedAnagrEventArgs

Costruttore DedAnagrViewControlDedAnagrEventArgs

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAnagrEventArgs()
Public Sub New
public:
DedAnagrEventArgs()
new : unit -> DedAnagrEventArgs
Vedi anche

Documentazione

Classe DedAnagrViewControlDedAnagrEventArgs
Namespace DedNet.Controls


Proprietà di DedAnagrEventArgs

Il tipo DedAnagrViewControlDedAnagrEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | DataList | Lista delle anagrafiche selezionate
Proprietà pubblica | NodeList | Lista dei nodi selezionati
Torna su
Vedi anche

Documentazione

Classe DedAnagrViewControlDedAnagrEventArgs
Namespace DedNet.Controls


Proprietà DedAnagrViewControl.DedAnagrEventArgs.DataList

Proprietà DedAnagrViewControlDedAnagrEventArgsDataList
Lista delle anagrafiche selezionate

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataList DataList { get; }
Public ReadOnly Property DataList As DedDataList
    Get
public:
property DedDataList^ DataList {
    DedDataList^ get ();
}
member DataList : DedDataList with get

Valore della proprietà

DedDataList
Vedi anche

Documentazione

Classe DedAnagrViewControlDedAnagrEventArgs
Namespace DedNet.Controls


Proprietà DedAnagrViewControl.DedAnagrEventArgs.NodeList

Proprietà DedAnagrViewControlDedAnagrEventArgsNodeList
Lista dei nodi selezionati

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<int> NodeList { get; }
Public ReadOnly Property NodeList As List(Of Integer)
    Get
public:
property List<int>^ NodeList {
    List<int>^ get ();
}
member NodeList : List<int> with get

Valore della proprietà

List Int32
Vedi anche

Documentazione

Classe DedAnagrViewControlDedAnagrEventArgs
Namespace DedNet.Controls


Classe DedAnagrViewControl.FilterEventArgs

Classe DedAnagrViewControlFilterEventArgs
Classe per la gestione del filtro effettuato dopo la ricerca.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNet.ControlsDedAnagrViewControlFilterEventArgs

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class FilterEventArgs : CancelEventArgs
Public Class FilterEventArgs
    Inherits CancelEventArgs
public ref class FilterEventArgs : public CancelEventArgs
type FilterEventArgs =
    class
        inherit CancelEventArgs
    end

Il tipo DedAnagrViewControlFilterEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedAnagrViewControlFilterEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | FilterSelected | Nome del filtro selezionato.
Proprietà pubblica | Row | Dizionario con nome colonne e oggetto riga.
Proprietà pubblica | Visible | Indica se visualizzare o meno la riga.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore DedAnagrViewControl.FilterEventArgs

Costruttore DedAnagrViewControlFilterEventArgs

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public FilterEventArgs()
Public Sub New
public:
FilterEventArgs()
new : unit -> FilterEventArgs
Vedi anche

Documentazione

Classe DedAnagrViewControlFilterEventArgs
Namespace DedNet.Controls


Proprietà di FilterEventArgs

Il tipo DedAnagrViewControlFilterEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | FilterSelected | Nome del filtro selezionato.
Proprietà pubblica | Row | Dizionario con nome colonne e oggetto riga.
Proprietà pubblica | Visible | Indica se visualizzare o meno la riga.
Torna su
Vedi anche

Documentazione

Classe DedAnagrViewControlFilterEventArgs
Namespace DedNet.Controls


Proprietà DedAnagrViewControl.FilterEventArgs.FilterSelected

Proprietà DedAnagrViewControlFilterEventArgsFilterSelected
Nome del filtro selezionato.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string FilterSelected { get; set; }
Public Property FilterSelected As String
    Get
    Set
public:
property String^ FilterSelected {
    String^ get ();
    void set (String^ value);
}
member FilterSelected : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedAnagrViewControlFilterEventArgs
Namespace DedNet.Controls


Proprietà DedAnagrViewControl.FilterEventArgs.Row

Proprietà DedAnagrViewControlFilterEventArgsRow
Dizionario con nome colonne e oggetto riga.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<string, Object> Row { get; }
Public ReadOnly Property Row As Dictionary(Of String, Object)
    Get
public:
property Dictionary<String^, Object^>^ Row {
    Dictionary<String^, Object^>^ get ();
}
member Row : Dictionary<string, Object> with get

Valore della proprietà

Dictionary String, Object
Vedi anche

Documentazione

Classe DedAnagrViewControlFilterEventArgs
Namespace DedNet.Controls


Proprietà DedAnagrViewControl.FilterEventArgs.Visible

Proprietà DedAnagrViewControlFilterEventArgsVisible
Indica se visualizzare o meno la riga.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Visible { get; set; }
Public Property Visible As Boolean
    Get
    Set
public:
property bool Visible {
    bool get ();
    void set (bool value);
}
member Visible : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAnagrViewControlFilterEventArgs
Namespace DedNet.Controls


Classe DedBomExplorerControl
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
XtraUserControl
DedNet.ControlsUserControlBase
DedNet.ControlsDedBomExplorerControl

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedBomExplorerControl : UserControlBase
Public Class DedBomExplorerControl
    Inherits UserControlBase
public ref class DedBomExplorerControl : public UserControlBase
type DedBomExplorerControl =
    class
        inherit UserControlBase
    end

Il tipo DedBomExplorerControl espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedBomExplorerControl | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Appearance | (Ereditato da XtraUserControl)
Proprietà pubblica | Application | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Proprietà pubblica | BackColor | (Ereditato da XtraUserControl)
Proprietà pubblica | Behaviour | Restituisce o imposta il comportamento del controllo.
Proprietà protetta | CheckDoubleScaling | (Ereditato da XtraUserControl)
Proprietà pubblica | DedDistControl | Ritorna il controllo interno di visualizzazione distinta
Proprietà protetta | DefaultAppearance | (Ereditato da XtraUserControl)
Proprietà protetta | DirectXContainer | (Ereditato da XtraUserControl)
Proprietà pubblica | DiscrimAnagAttrs | Lista degli attributi di anagrafica da usare come discriminante per il confronto
Proprietà pubblica | DiscrimDistAttrs | Lista degli attributi di distinta da usare come discriminante per il confronto
Proprietà pubblica | EnableIXtraResizeableControlInterfaceProxy | (Ereditato da XtraUserControl)
Proprietà pubblica | Font | (Ereditato da XtraUserControl)
Proprietà pubblica | ForeColor | (Ereditato da XtraUserControl)
Proprietà pubblica | Header | Restituisce l'header della distinta corrente
Proprietà protetta | Helper | (Ereditato da XtraUserControl)
Proprietà pubblica | InitComm | Restituisce o imposta la commessa di inizializzazione
Proprietà pubblica | InitData | Restituisce o imposta l'anagrafica di inizializzazione
Proprietà pubblica | InitDiscrimDist | Restituisce o imposta il discriminante di inizializzazione
Proprietà pubblica | KeyRunQueryOnEnter | Chiave dalla quale leggere l'opzione di ricerca su invio.
Proprietà pubblica | LookAndFeel | (Ereditato da XtraUserControl)
Proprietà pubblica | MultiLevel | Tipo di visualizzazione multi/mono livello
Proprietà pubblica | MultiSelectModeUser | Tipo di selezione cella/riga
Proprietà pubblica | NotSaveState | Indicate se lo stato dell'albero non deve essere salvato
Proprietà protetta | Painter | (Ereditato da XtraUserControl)
Proprietà pubblica | RegistryDistPanelKey | Restituisce o imposta la chiave per i settaggi del pannello della distinta.
Proprietà protetta | ScaleChildren | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleDPI | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraUserControl)
Proprietà protetta | ShouldCheckDpiScaleFactorOnParentChanged | (Ereditato da XtraUserControl)
Proprietà pubblica | ShowAttr | Visualizzare o no il pannello attributi
Proprietà pubblica | ShowColor | Colora o no le righe pari nella griglia
Proprietà pubblica | ShowGrid | Visualizzare o no la griglia
Proprietà pubblica | ShowPreview | Visualizzare o no la colonna con anteprima
Proprietà pubblica | Site | (Ereditato da XtraUserControl)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AddAnagrData(BomItemCollection, DedDataPart) | Aggiunge un elemento dall'anagrafica
Metodo pubblico | AddAnagrData(BomItemCollection, Row) | Aggiunge un elemento dall'anagrafica
Metodo pubblico | AddAnagrData(BomItemCollection, DedDataPart, BomItem) | Aggiunge un elemento dall'anagrafica
Metodo pubblico | AddAnagrData(BomItemCollection, DedDataPart, Boolean) | Aggiunge un elemento dall'anagrafica. Permette il controllo del refresh della lista
Metodo pubblico | AddAnagrData(BomItemCollection, Row, Boolean) | Aggiunge un elemento dall'anagrafica. Permette il controllo del refresh della lista
Metodo pubblico | AddAnagrData(BomItemCollection, DedDataPart, BomItem, Boolean) | Aggiunge un elemento dall'anagrafica. Permette il controllo del refresh della lista
Metodo pubblico | AddAnagrData(BomItemCollection, DedDataPart, Double, Object, Boolean) | Aggiunge un elemento dall'anagrafica. Permette il controllo del refresh della lista
Metodo protetto | BaseWndProc | (Ereditato da XtraUserControl)
Metodo pubblico | CanBeUnloaded | Indica se il controllo può essere scaricato od esistono dei sospesi
Metodo pubblico | CompareDist | Confronta la distinta caricata con l'elemento passato.
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraUserControl)
Metodo protetto | CreatePainter | (Ereditato da XtraUserControl)
Metodo pubblico | Dispose | Esegue il dispose dei controlli utente particolarmente dispendiosi
Metodo protetto | Dispose(Boolean) | Clean up any resources being used. (Sovrascrive UserControlBaseDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraUserControl)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraUserControl)
Metodo pubblico | GetActiveBomItem | Restituisce il bomItem dell'elemento selezionato
Metodo pubblico | GetActiveBomItemCollection | Restituisce la bomItemcollection attiva in editazione
Metodo pubblico | GetActiveBomItemCollectionNode | Restituisce il nodo relativo alla bomitemcollection attiva in editazione
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraUserControl)
Metodo pubblico | GetActiveNode | Restituisce il nodo dell'elemento selezionato
Metodo protetto | GetBackColor | (Ereditato da XtraUserControl)
Metodo protetto | GetBackgroundSkinElement | (Ereditato da XtraUserControl)
Metodo pubblico | GetDropTarget | Ritorna un identificatore del controllo figlio bersaglio del drop
Metodo protetto | GetInnerIXtraResizableControl | (Ereditato da XtraUserControl)
Metodo pubblico | GetMinWidth | Ritorna le dimensioni minime che deve avere questo controllo se non si vuole che i controlli all'interno del LayoutControl si sovrappongano e vengano tagliati.
Metodo pubblico | InitCommOnLoad | Funzione per caricare le distinte precompilate.
Metodo pubblico | InitDataOnLoad | Funzione per caricare le distinte precompilate.
Metodo protetto | IsChildControlsRequiredScalingEnabled | (Ereditato da XtraUserControl)
Metodo protetto | IsParentHandleCreatedRecursive | (Ereditato da XtraUserControl)
Metodo pubblico | LoadData | Permette di aprire la distinta dell'anagrafica passata
Metodo pubblico | LoadInitPrtAnagrData | Se possibile carica una distinta dalla riga di inizia parte veloce
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraUserControl)
Metodo protetto | OnBackColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnContextMenuOpening | Evento di apertura del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnControlAdded | (Ereditato da XtraUserControl)
Metodo protetto | OnControlRemoved | (Ereditato da XtraUserControl)
Metodo protetto | OnDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnFirstLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnForeColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleCreated | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleDestroyed(EventArgs) | Evento che scatta quando sta per essere chiuso il controllo. (Sovrascrive ControlOnHandleDestroyed(EventArgs))
Metodo protetto | OnHandleDestroyed(EventArgs) | (Ereditato da XtraUserControl)
Metodo protetto | OnLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnMenuItemClicked | Evento di pressione di un comando del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnPaintCore | (Ereditato da XtraUserControl)
Metodo protetto | OnParentChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | OnSizeChanged | (Ereditato da XtraUserControl)
Metodo protetto | RaisePaintExEvent | (Ereditato da XtraUserControl)
Metodo pubblico | ReloadData | Ricarica i dati della distinta
Metodo pubblico | ReloadOptions | Ricarica le impostazioni dei FindCodeControl rileggendo dall'Application.
Metodo pubblico | ResetBackColor | (Ereditato da XtraUserControl)
Metodo pubblico | ResetForeColor | (Ereditato da XtraUserControl)
Metodo protetto | RestoreAutoScaleModeChangedByPM2 | (Ereditato da XtraUserControl)
Metodo pubblico | RestoreDist | Confronta la distinta caricata con l'elemento passato.
Metodo pubblico | SaveRegistrySettings | Salva nel registro di sistema le informazioni necessarie
Metodo protetto | ScaleControl | (Ereditato da XtraUserControl)
Metodo pubblico | SetCommandList | Rigenera il menu contestuale di questo controllo con la lista dei comandi passati. (Ereditato da UserControlBase)
Metodo protetto | SetVisibleCore | (Ereditato da XtraUserControl)
Metodo protetto | ShouldPaintTransparentBackground | (Ereditato da XtraUserControl)
Metodo protetto | ShouldUseDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | WndProc | (Ereditato da XtraUserControl)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | ContextCreated | Evento che scatta quando si sta creando il contesto da utilizzare per la generazione del menu contestuale.
Evento pubblico | ContextMenuOpening | Evento su apertura del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | DistLoaded | Evento che scatta quando viene caricata una distinta
Evento pubblico | DistReLoadedInsideGrid | Evento che scatta quando viene caricata una distinta
Evento pubblico | getDuplicatedDist | Evento per caricare la distinta duplicata dall'altro pannello
Evento pubblico | MenuItemClicked | Evento su click su un elemento del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | moveCodeList | Evento per lo spostamento dei codici da un pannello all'altro
Evento pubblico | openOppositePanel | Evento per il caricamento dell'anagrafica nell'altro pannello
Evento pubblico | PaintEx | (Ereditato da XtraUserControl)
Evento pubblico | SelectedDataChanged | Evento per il cambiamento della selezione corrente all'interno dell'albero di distinta
Torna su
Campi
 | Nome | Descrizione
Campo protetto | _app | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Campo protetto | _RegistryBaseKey | Chiave nel registro di sistema di salvataggio impostazioni. (Ereditato da UserControlBase)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore DedBomExplorerControl
Costruttore

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedBomExplorerControl()
Public Sub New
public:
DedBomExplorerControl()
new : unit -> DedBomExplorerControl
Vedi anche

Documentazione

Classe DedBomExplorerControl
Namespace DedNet.Controls


Proprietà di DedBomExplorerControl

Il tipo DedBomExplorerControl espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Appearance | (Ereditato da XtraUserControl)
Proprietà pubblica | Application | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Proprietà pubblica | BackColor | (Ereditato da XtraUserControl)
Proprietà pubblica | Behaviour | Restituisce o imposta il comportamento del controllo.
Proprietà protetta | CheckDoubleScaling | (Ereditato da XtraUserControl)
Proprietà pubblica | DedDistControl | Ritorna il controllo interno di visualizzazione distinta
Proprietà protetta | DefaultAppearance | (Ereditato da XtraUserControl)
Proprietà protetta | DirectXContainer | (Ereditato da XtraUserControl)
Proprietà pubblica | DiscrimAnagAttrs | Lista degli attributi di anagrafica da usare come discriminante per il confronto
Proprietà pubblica | DiscrimDistAttrs | Lista degli attributi di distinta da usare come discriminante per il confronto
Proprietà pubblica | EnableIXtraResizeableControlInterfaceProxy | (Ereditato da XtraUserControl)
Proprietà pubblica | Font | (Ereditato da XtraUserControl)
Proprietà pubblica | ForeColor | (Ereditato da XtraUserControl)
Proprietà pubblica | Header | Restituisce l'header della distinta corrente
Proprietà protetta | Helper | (Ereditato da XtraUserControl)
Proprietà pubblica | InitComm | Restituisce o imposta la commessa di inizializzazione
Proprietà pubblica | InitData | Restituisce o imposta l'anagrafica di inizializzazione
Proprietà pubblica | InitDiscrimDist | Restituisce o imposta il discriminante di inizializzazione
Proprietà pubblica | KeyRunQueryOnEnter | Chiave dalla quale leggere l'opzione di ricerca su invio.
Proprietà pubblica | LookAndFeel | (Ereditato da XtraUserControl)
Proprietà pubblica | MultiLevel | Tipo di visualizzazione multi/mono livello
Proprietà pubblica | MultiSelectModeUser | Tipo di selezione cella/riga
Proprietà pubblica | NotSaveState | Indicate se lo stato dell'albero non deve essere salvato
Proprietà protetta | Painter | (Ereditato da XtraUserControl)
Proprietà pubblica | RegistryDistPanelKey | Restituisce o imposta la chiave per i settaggi del pannello della distinta.
Proprietà protetta | ScaleChildren | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleDPI | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraUserControl)
Proprietà protetta | ShouldCheckDpiScaleFactorOnParentChanged | (Ereditato da XtraUserControl)
Proprietà pubblica | ShowAttr | Visualizzare o no il pannello attributi
Proprietà pubblica | ShowColor | Colora o no le righe pari nella griglia
Proprietà pubblica | ShowGrid | Visualizzare o no la griglia
Proprietà pubblica | ShowPreview | Visualizzare o no la colonna con anteprima
Proprietà pubblica | Site | (Ereditato da XtraUserControl)
Torna su
Vedi anche

Documentazione

Classe DedBomExplorerControl
Namespace DedNet.Controls


Proprietà DedBomExplorerControl.Behaviour

Proprietà DedBomExplorerControlBehaviour
Restituisce o imposta il comportamento del controllo.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedBomExplorerControlDedBomExplorerBehaviourEnum Behaviour { get; set; }
Public Property Behaviour As DedBomExplorerControlDedBomExplorerBehaviourEnum
    Get
    Set
public:
property DedBomExplorerControlDedBomExplorerBehaviourEnum Behaviour {
    DedBomExplorerControlDedBomExplorerBehaviourEnum get ();
    void set (DedBomExplorerControlDedBomExplorerBehaviourEnum value);
}
member Behaviour : DedBomExplorerControlDedBomExplorerBehaviourEnum with get, set

Valore della proprietà

DedBomExplorerControlDedBomExplorerBehaviourEnum
Vedi anche

Documentazione

Classe DedBomExplorerControl
Namespace DedNet.Controls


Proprietà DedBomExplorerControl.DedDistControl

Proprietà DedBomExplorerControlDedDistControl
Ritorna il controllo interno di visualizzazione distinta

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDistControl DedDistControl { get; }
Public ReadOnly Property DedDistControl As DedDistControl
    Get
public:
property DedDistControl^ DedDistControl {
    DedDistControl^ get ();
}
member DedDistControl : DedDistControl with get

Valore della proprietà

DedDistControl
Vedi anche

Documentazione

Classe DedBomExplorerControl
Namespace DedNet.Controls


Proprietà DedBomExplorerControl.DiscrimAnagAttrs

Proprietà DedBomExplorerControlDiscrimAnagAttrs
Lista degli attributi di anagrafica da usare come discriminante per il confronto

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList DiscrimAnagAttrs { get; set; }
Public Property DiscrimAnagAttrs As DedAttrList
    Get
    Set
public:
property DedAttrList^ DiscrimAnagAttrs {
    DedAttrList^ get ();
    void set (DedAttrList^ value);
}
member DiscrimAnagAttrs : DedAttrList with get, set

Valore della proprietà

DedAttrList
Vedi anche

Documentazione

Classe DedBomExplorerControl
Namespace DedNet.Controls


Proprietà DedBomExplorerControl.DiscrimDistAttrs

Proprietà DedBomExplorerControlDiscrimDistAttrs
Lista degli attributi di distinta da usare come discriminante per il confronto

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList DiscrimDistAttrs { get; set; }
Public Property DiscrimDistAttrs As DedAttrList
    Get
    Set
public:
property DedAttrList^ DiscrimDistAttrs {
    DedAttrList^ get ();
    void set (DedAttrList^ value);
}
member DiscrimDistAttrs : DedAttrList with get, set

Valore della proprietà

DedAttrList
Vedi anche

Documentazione

Classe DedBomExplorerControl
Namespace DedNet.Controls


Proprietà DedBomExplorerControl.Header

Proprietà DedBomExplorerControlHeader
Restituisce l'header della distinta corrente

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DistHeader Header { get; }
Public ReadOnly Property Header As DistHeader
    Get
public:
property DistHeader^ Header {
    DistHeader^ get ();
}
member Header : DistHeader with get

Valore della proprietà

DistHeader
Vedi anche

Documentazione

Classe DedBomExplorerControl
Namespace DedNet.Controls


Proprietà DedBomExplorerControl.InitComm

Proprietà DedBomExplorerControlInitComm
Restituisce o imposta la commessa di inizializzazione

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedComm InitComm { get; set; }
Public Property InitComm As DedComm
    Get
    Set
public:
property DedComm^ InitComm {
    DedComm^ get ();
    void set (DedComm^ value);
}
member InitComm : DedComm with get, set

Valore della proprietà

DedComm
Vedi anche

Documentazione

Classe DedBomExplorerControl
Namespace DedNet.Controls


Proprietà DedBomExplorerControl.InitData

Proprietà DedBomExplorerControlInitData
Restituisce o imposta l'anagrafica di inizializzazione

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData InitData { get; set; }
Public Property InitData As DedData
    Get
    Set
public:
property DedData^ InitData {
    DedData^ get ();
    void set (DedData^ value);
}
member InitData : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe DedBomExplorerControl
Namespace DedNet.Controls


Proprietà DedBomExplorerControl.InitDiscrimDist

Proprietà DedBomExplorerControlInitDiscrimDist
Restituisce o imposta il discriminante di inizializzazione

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string InitDiscrimDist { get; set; }
Public Property InitDiscrimDist As String
    Get
    Set
public:
property String^ InitDiscrimDist {
    String^ get ();
    void set (String^ value);
}
member InitDiscrimDist : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedBomExplorerControl
Namespace DedNet.Controls


Proprietà DedBomExplorerControl.KeyRunQueryOnEnter

Proprietà DedBomExplorerControlKeyRunQueryOnEnter
Chiave dalla quale leggere l'opzione di ricerca su invio.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string KeyRunQueryOnEnter { get; }
Public ReadOnly Property KeyRunQueryOnEnter As String
    Get
public:
property String^ KeyRunQueryOnEnter {
    String^ get ();
}
member KeyRunQueryOnEnter : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedBomExplorerControl
Namespace DedNet.Controls


Proprietà DedBomExplorerControl.MultiLevel

Proprietà DedBomExplorerControlMultiLevel
Tipo di visualizzazione multi/mono livello

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool MultiLevel { get; set; }
Public Property MultiLevel As Boolean
    Get
    Set
public:
property bool MultiLevel {
    bool get ();
    void set (bool value);
}
member MultiLevel : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedBomExplorerControl
Namespace DedNet.Controls


Proprietà DedBomExplorerControl.MultiSelectModeUser

Proprietà DedBomExplorerControlMultiSelectModeUser
Tipo di selezione cella/riga

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string MultiSelectModeUser { set; }
Public WriteOnly Property MultiSelectModeUser As String
    Set
public:
property String^ MultiSelectModeUser {
    void set (String^ value);
}
member MultiSelectModeUser : string with set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedBomExplorerControl
Namespace DedNet.Controls


Proprietà DedBomExplorerControl.NotSaveState

Proprietà DedBomExplorerControlNotSaveState
Indicate se lo stato dell'albero non deve essere salvato

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool NotSaveState { set; }
Public WriteOnly Property NotSaveState As Boolean
    Set
public:
property bool NotSaveState {
    void set (bool value);
}
member NotSaveState : bool with set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedBomExplorerControl
Namespace DedNet.Controls


Proprietà DedBomExplorerControl.RegistryDistPanelKey

Proprietà DedBomExplorerControlRegistryDistPanelKey
Restituisce o imposta la chiave per i settaggi del pannello della distinta.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string RegistryDistPanelKey { get; set; }
Public Property RegistryDistPanelKey As String
    Get
    Set
public:
property String^ RegistryDistPanelKey {
    String^ get ();
    void set (String^ value);
}
member RegistryDistPanelKey : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedBomExplorerControl
Namespace DedNet.Controls


Proprietà DedBomExplorerControl.ShowAttr

Proprietà DedBomExplorerControlShowAttr
Visualizzare o no il pannello attributi

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ShowAttr { set; }
Public WriteOnly Property ShowAttr As Boolean
    Set
public:
property bool ShowAttr {
    void set (bool value);
}
member ShowAttr : bool with set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedBomExplorerControl
Namespace DedNet.Controls


Proprietà DedBomExplorerControl.ShowColor

Proprietà DedBomExplorerControlShowColor
Colora o no le righe pari nella griglia

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ShowColor { set; }
Public WriteOnly Property ShowColor As Boolean
    Set
public:
property bool ShowColor {
    void set (bool value);
}
member ShowColor : bool with set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedBomExplorerControl
Namespace DedNet.Controls


Proprietà DedBomExplorerControl.ShowGrid

Proprietà DedBomExplorerControlShowGrid
Visualizzare o no la griglia

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ShowGrid { set; }
Public WriteOnly Property ShowGrid As Boolean
    Set
public:
property bool ShowGrid {
    void set (bool value);
}
member ShowGrid : bool with set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedBomExplorerControl
Namespace DedNet.Controls


Proprietà DedBomExplorerControl.ShowPreview

Proprietà DedBomExplorerControlShowPreview
Visualizzare o no la colonna con anteprima

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ShowPreview { set; }
Public WriteOnly Property ShowPreview As Boolean
    Set
public:
property bool ShowPreview {
    void set (bool value);
}
member ShowPreview : bool with set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedBomExplorerControl
Namespace DedNet.Controls


Metodi di DedBomExplorerControl

Il tipo DedBomExplorerControl espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AddAnagrData(BomItemCollection, DedDataPart) | Aggiunge un elemento dall'anagrafica
Metodo pubblico | AddAnagrData(BomItemCollection, Row) | Aggiunge un elemento dall'anagrafica
Metodo pubblico | AddAnagrData(BomItemCollection, DedDataPart, BomItem) | Aggiunge un elemento dall'anagrafica
Metodo pubblico | AddAnagrData(BomItemCollection, DedDataPart, Boolean) | Aggiunge un elemento dall'anagrafica. Permette il controllo del refresh della lista
Metodo pubblico | AddAnagrData(BomItemCollection, Row, Boolean) | Aggiunge un elemento dall'anagrafica. Permette il controllo del refresh della lista
Metodo pubblico | AddAnagrData(BomItemCollection, DedDataPart, BomItem, Boolean) | Aggiunge un elemento dall'anagrafica. Permette il controllo del refresh della lista
Metodo pubblico | AddAnagrData(BomItemCollection, DedDataPart, Double, Object, Boolean) | Aggiunge un elemento dall'anagrafica. Permette il controllo del refresh della lista
Metodo protetto | BaseWndProc | (Ereditato da XtraUserControl)
Metodo pubblico | CanBeUnloaded | Indica se il controllo può essere scaricato od esistono dei sospesi
Metodo pubblico | CompareDist | Confronta la distinta caricata con l'elemento passato.
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraUserControl)
Metodo protetto | CreatePainter | (Ereditato da XtraUserControl)
Metodo pubblico | Dispose | Esegue il dispose dei controlli utente particolarmente dispendiosi
Metodo protetto | Dispose(Boolean) | Clean up any resources being used. (Sovrascrive UserControlBaseDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraUserControl)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraUserControl)
Metodo pubblico | GetActiveBomItem | Restituisce il bomItem dell'elemento selezionato
Metodo pubblico | GetActiveBomItemCollection | Restituisce la bomItemcollection attiva in editazione
Metodo pubblico | GetActiveBomItemCollectionNode | Restituisce il nodo relativo alla bomitemcollection attiva in editazione
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraUserControl)
Metodo pubblico | GetActiveNode | Restituisce il nodo dell'elemento selezionato
Metodo protetto | GetBackColor | (Ereditato da XtraUserControl)
Metodo protetto | GetBackgroundSkinElement | (Ereditato da XtraUserControl)
Metodo pubblico | GetDropTarget | Ritorna un identificatore del controllo figlio bersaglio del drop
Metodo protetto | GetInnerIXtraResizableControl | (Ereditato da XtraUserControl)
Metodo pubblico | GetMinWidth | Ritorna le dimensioni minime che deve avere questo controllo se non si vuole che i controlli all'interno del LayoutControl si sovrappongano e vengano tagliati.
Metodo pubblico | InitCommOnLoad | Funzione per caricare le distinte precompilate.
Metodo pubblico | InitDataOnLoad | Funzione per caricare le distinte precompilate.
Metodo protetto | IsChildControlsRequiredScalingEnabled | (Ereditato da XtraUserControl)
Metodo protetto | IsParentHandleCreatedRecursive | (Ereditato da XtraUserControl)
Metodo pubblico | LoadData | Permette di aprire la distinta dell'anagrafica passata
Metodo pubblico | LoadInitPrtAnagrData | Se possibile carica una distinta dalla riga di inizia parte veloce
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraUserControl)
Metodo protetto | OnBackColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnContextMenuOpening | Evento di apertura del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnControlAdded | (Ereditato da XtraUserControl)
Metodo protetto | OnControlRemoved | (Ereditato da XtraUserControl)
Metodo protetto | OnDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnFirstLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnForeColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleCreated | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleDestroyed(EventArgs) | Evento che scatta quando sta per essere chiuso il controllo. (Sovrascrive ControlOnHandleDestroyed(EventArgs))
Metodo protetto | OnHandleDestroyed(EventArgs) | (Ereditato da XtraUserControl)
Metodo protetto | OnLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnMenuItemClicked | Evento di pressione di un comando del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnPaintCore | (Ereditato da XtraUserControl)
Metodo protetto | OnParentChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | OnSizeChanged | (Ereditato da XtraUserControl)
Metodo protetto | RaisePaintExEvent | (Ereditato da XtraUserControl)
Metodo pubblico | ReloadData | Ricarica i dati della distinta
Metodo pubblico | ReloadOptions | Ricarica le impostazioni dei FindCodeControl rileggendo dall'Application.
Metodo pubblico | ResetBackColor | (Ereditato da XtraUserControl)
Metodo pubblico | ResetForeColor | (Ereditato da XtraUserControl)
Metodo protetto | RestoreAutoScaleModeChangedByPM2 | (Ereditato da XtraUserControl)
Metodo pubblico | RestoreDist | Confronta la distinta caricata con l'elemento passato.
Metodo pubblico | SaveRegistrySettings | Salva nel registro di sistema le informazioni necessarie
Metodo protetto | ScaleControl | (Ereditato da XtraUserControl)
Metodo pubblico | SetCommandList | Rigenera il menu contestuale di questo controllo con la lista dei comandi passati. (Ereditato da UserControlBase)
Metodo protetto | SetVisibleCore | (Ereditato da XtraUserControl)
Metodo protetto | ShouldPaintTransparentBackground | (Ereditato da XtraUserControl)
Metodo protetto | ShouldUseDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | WndProc | (Ereditato da XtraUserControl)
Torna su
Vedi anche

Documentazione

Classe DedBomExplorerControl
Namespace DedNet.Controls


Metodo DedBomExplorerControl.AddAnagrData

Metodo DedBomExplorerControlAddAnagrData
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AddAnagrData(BomItemCollection, DedDataPart) | Aggiunge un elemento dall'anagrafica
Metodo pubblico | AddAnagrData(BomItemCollection, Row) | Aggiunge un elemento dall'anagrafica
Metodo pubblico | AddAnagrData(BomItemCollection, DedDataPart, BomItem) | Aggiunge un elemento dall'anagrafica
Metodo pubblico | AddAnagrData(BomItemCollection, DedDataPart, Boolean) | Aggiunge un elemento dall'anagrafica. Permette il controllo del refresh della lista
Metodo pubblico | AddAnagrData(BomItemCollection, Row, Boolean) | Aggiunge un elemento dall'anagrafica. Permette il controllo del refresh della lista
Metodo pubblico | AddAnagrData(BomItemCollection, DedDataPart, BomItem, Boolean) | Aggiunge un elemento dall'anagrafica. Permette il controllo del refresh della lista
Metodo pubblico | AddAnagrData(BomItemCollection, DedDataPart, Double, Object, Boolean) | Aggiunge un elemento dall'anagrafica. Permette il controllo del refresh della lista
Torna su
Vedi anche

Documentazione

Classe DedBomExplorerControl
Namespace DedNet.Controls


Metodo DedBomExplorerControl.AddAnagrData(BomItemCollection, DedDataPart)

Metodo DedBomExplorerControlAddAnagrData(BomItemCollection, DedDataPart)
Aggiunge un elemento dall'anagrafica

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItem AddAnagrData(
    BomItemCollection bom,
    DedDataPart item
)
Public Function AddAnagrData (
    bom As BomItemCollection,
    item As DedDataPart
) As BomItem
public:
BomItem^ AddAnagrData(
    BomItemCollection^ bom,
    DedDataPart^ item
)
member AddAnagrData :
        bom : BomItemCollection *
        item : DedDataPart -> BomItem

Parametri

bom BomItemCollection
Distinta di arrivo.
item DedDataPart
Anagrafica da aggiungere.

Valore di ritorno

BomItem
Vedi anche

Documentazione

Classe DedBomExplorerControl
Overload di AddAnagrData
Namespace DedNet.Controls


Metodo DedBomExplorerControl.AddAnagrData(BomItemCollection, InitPrtFast.Row)

Metodo DedBomExplorerControlAddAnagrData(BomItemCollection, InitPrtFastRow)
Aggiunge un elemento dall'anagrafica

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItem AddAnagrData(
    BomItemCollection bom,
    Row item
)
Public Function AddAnagrData (
    bom As BomItemCollection,
    item As Row
) As BomItem
public:
BomItem^ AddAnagrData(
    BomItemCollection^ bom,
    Row^ item
)
member AddAnagrData :
        bom : BomItemCollection *
        item : Row -> BomItem

Parametri

bom BomItemCollection
item Row

Valore di ritorno

BomItem
Vedi anche

Documentazione

Classe DedBomExplorerControl
Overload di AddAnagrData
Namespace DedNet.Controls


Metodo DedBomExplorerControl.AddAnagrData(BomItemCollection, DedDataPart, BomItem)

Metodo DedBomExplorerControlAddAnagrData(BomItemCollection, DedDataPart, BomItem)
Aggiunge un elemento dall'anagrafica

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItem AddAnagrData(
    BomItemCollection bom,
    DedDataPart item,
    BomItem bi
)
Public Function AddAnagrData (
    bom As BomItemCollection,
    item As DedDataPart,
    bi As BomItem
) As BomItem
public:
BomItem^ AddAnagrData(
    BomItemCollection^ bom,
    DedDataPart^ item,
    BomItem^ bi
)
member AddAnagrData :
        bom : BomItemCollection *
        item : DedDataPart *
        bi : BomItem -> BomItem

Parametri

bom BomItemCollection
Distinta di arrivo.
item DedDataPart
Anagrafica da aggiungere.
bi BomItem
Elemento della distinta da aggiungere.

Valore di ritorno

BomItem
Vedi anche

Documentazione

Classe DedBomExplorerControl
Overload di AddAnagrData
Namespace DedNet.Controls


Metodo DedBomExplorerControl.AddAnagrData(BomItemCollection, DedDataPart, Boolean)

Metodo DedBomExplorerControlAddAnagrData(BomItemCollection, DedDataPart, Boolean)
Aggiunge un elemento dall'anagrafica. Permette il controllo del refresh della lista

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItem AddAnagrData(
    BomItemCollection bom,
    DedDataPart item,
    bool reloadList
)
Public Function AddAnagrData (
    bom As BomItemCollection,
    item As DedDataPart,
    reloadList As Boolean
) As BomItem
public:
BomItem^ AddAnagrData(
    BomItemCollection^ bom,
    DedDataPart^ item,
    bool reloadList
)
member AddAnagrData :
        bom : BomItemCollection *
        item : DedDataPart *
        reloadList : bool -> BomItem

Parametri

bom BomItemCollection
Distinta di arrivo.
item DedDataPart
Anagrafica da aggiungere.
reloadList Boolean
Indica se effettuare il refresh della distinta.

Valore di ritorno

BomItem
Vedi anche

Documentazione

Classe DedBomExplorerControl
Overload di AddAnagrData
Namespace DedNet.Controls


Metodo DedBomExplorerControl.AddAnagrData(BomItemCollection, InitPrtFast.Row, Boolean)

Metodo DedBomExplorerControlAddAnagrData(BomItemCollection, InitPrtFastRow, Boolean)
Aggiunge un elemento dall'anagrafica. Permette il controllo del refresh della lista

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItem AddAnagrData(
    BomItemCollection bom,
    Row item,
    bool reloadList
)
Public Function AddAnagrData (
    bom As BomItemCollection,
    item As Row,
    reloadList As Boolean
) As BomItem
public:
BomItem^ AddAnagrData(
    BomItemCollection^ bom,
    Row^ item,
    bool reloadList
)
member AddAnagrData :
        bom : BomItemCollection *
        item : Row *
        reloadList : bool -> BomItem

Parametri

bom BomItemCollection
item Row
reloadList Boolean

Valore di ritorno

BomItem
Vedi anche

Documentazione

Classe DedBomExplorerControl
Overload di AddAnagrData
Namespace DedNet.Controls


Metodo DedBomExplorerControl.AddAnagrData(BomItemCollection, DedDataPart, BomItem, Boolean)

Metodo DedBomExplorerControlAddAnagrData(BomItemCollection, DedDataPart, BomItem, Boolean)
Aggiunge un elemento dall'anagrafica. Permette il controllo del refresh della lista

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItem AddAnagrData(
    BomItemCollection bom,
    DedDataPart item,
    BomItem bi,
    bool reloadList
)
Public Function AddAnagrData (
    bom As BomItemCollection,
    item As DedDataPart,
    bi As BomItem,
    reloadList As Boolean
) As BomItem
public:
BomItem^ AddAnagrData(
    BomItemCollection^ bom,
    DedDataPart^ item,
    BomItem^ bi,
    bool reloadList
)
member AddAnagrData :
        bom : BomItemCollection *
        item : DedDataPart *
        bi : BomItem *
        reloadList : bool -> BomItem

Parametri

bom BomItemCollection
Distinta di arrivo.
item DedDataPart
Anagrafica da aggiungere.
bi BomItem
Elemento della distinta da aggiungere.
reloadList Boolean
Indica se effettuare il refresh della distinta.

Valore di ritorno

BomItem
Vedi anche

Documentazione

Classe DedBomExplorerControl
Overload di AddAnagrData
Namespace DedNet.Controls


Metodo DedBomExplorerControl.AddAnagrData(BomItemCollection, DedDataPart, Double, Object[], Boolean)

Metodo DedBomExplorerControlAddAnagrData(BomItemCollection, DedDataPart, Double, Object, Boolean)
Aggiunge un elemento dall'anagrafica. Permette il controllo del refresh della lista

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItem AddAnagrData(
    BomItemCollection bom,
    DedDataPart item,
    double qta,
    Object[] distValues,
    bool reloadList
)
Public Function AddAnagrData (
    bom As BomItemCollection,
    item As DedDataPart,
    qta As Double,
    distValues As Object(),
    reloadList As Boolean
) As BomItem
public:
BomItem^ AddAnagrData(
    BomItemCollection^ bom,
    DedDataPart^ item,
    double qta,
    array<Object^>^ distValues,
    bool reloadList
)
member AddAnagrData :
        bom : BomItemCollection *
        item : DedDataPart *
        qta : float *
        distValues : Object[] *
        reloadList : bool -> BomItem

Parametri

bom BomItemCollection
Distinta di arrivo.
item DedDataPart
Anagrafica da aggiungere.
qta Double
Quantità.
distValues Object
Valori attributi di distinta.
reloadList Boolean
Indica se effettuare il refresh della distinta.

Valore di ritorno

BomItem
Vedi anche

Documentazione

Classe DedBomExplorerControl
Overload di AddAnagrData
Namespace DedNet.Controls


Metodo DedBomExplorerControl.CanBeUnloaded

Metodo DedBomExplorerControlCanBeUnloaded
Indica se il controllo può essere scaricato od esistono dei sospesi

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CanBeUnloaded()
Public Function CanBeUnloaded As Boolean
public:
bool CanBeUnloaded()
member CanBeUnloaded : unit -> bool

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedBomExplorerControl
Namespace DedNet.Controls


Metodo DedBomExplorerControl.CompareDist

Metodo DedBomExplorerControlCompareDist
Confronta la distinta caricata con l'elemento passato.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void CompareDist(
    TreeListNode node,
    BomItemComparer bic
)
Public Sub CompareDist (
    node As TreeListNode,
    bic As BomItemComparer
)
public:
void CompareDist(
    TreeListNode^ node,
    BomItemComparer^ bic
)
member CompareDist :
        node : TreeListNode *
        bic : BomItemComparer -> unit

Parametri

node TreeListNode
bic BomItemComparer
Vedi anche

Documentazione

Classe DedBomExplorerControl
Namespace DedNet.Controls


Metodo DedBomExplorerControl.Dispose

Metodo DedBomExplorerControlDispose
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Dispose | Esegue il dispose dei controlli utente particolarmente dispendiosi
Metodo protetto | Dispose(Boolean) | Clean up any resources being used.
Torna su
Vedi anche

Documentazione

Classe DedBomExplorerControl
Namespace DedNet.Controls


Metodo DedBomExplorerControl.Dispose

Metodo DedBomExplorerControlDispose
Esegue il dispose dei controlli utente particolarmente dispendiosi

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
void Dispose()
member Dispose : unit -> unit
Vedi anche

Documentazione

Classe DedBomExplorerControl
Overload di Dispose
Namespace DedNet.Controls


Metodo DedBomExplorerControl.Dispose(Boolean)

Metodo DedBomExplorerControlDispose(Boolean)
Clean up any resources being used.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedBomExplorerControl
Overload di Dispose
Namespace DedNet.Controls


Metodo DedBomExplorerControl.GetActiveBomItem

Metodo DedBomExplorerControlGetActiveBomItem
Restituisce il bomItem dell'elemento selezionato

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItem GetActiveBomItem()
Public Function GetActiveBomItem As BomItem
public:
BomItem^ GetActiveBomItem()
member GetActiveBomItem : unit -> BomItem

Valore di ritorno

BomItem
Vedi anche

Documentazione

Classe DedBomExplorerControl
Namespace DedNet.Controls


Metodo DedBomExplorerControl.GetActiveBomItemCollection

Metodo DedBomExplorerControlGetActiveBomItemCollection
Restituisce la bomItemcollection attiva in editazione

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItemCollection GetActiveBomItemCollection()
Public Function GetActiveBomItemCollection As BomItemCollection
public:
BomItemCollection^ GetActiveBomItemCollection()
member GetActiveBomItemCollection : unit -> BomItemCollection

Valore di ritorno

BomItemCollection
Vedi anche

Documentazione

Classe DedBomExplorerControl
Namespace DedNet.Controls


Metodo DedBomExplorerControl.GetActiveBomItemCollectionNode

Metodo DedBomExplorerControlGetActiveBomItemCollectionNode
Restituisce il nodo relativo alla bomitemcollection attiva in editazione

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public TreeListNode GetActiveBomItemCollectionNode()
Public Function GetActiveBomItemCollectionNode As TreeListNode
public:
TreeListNode^ GetActiveBomItemCollectionNode()
member GetActiveBomItemCollectionNode : unit -> TreeListNode

Valore di ritorno

TreeListNode
Vedi anche

Documentazione

Classe DedBomExplorerControl
Namespace DedNet.Controls


Metodo DedBomExplorerControl.GetActiveNode

Metodo DedBomExplorerControlGetActiveNode
Restituisce il nodo dell'elemento selezionato

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public TreeListNode GetActiveNode()
Public Function GetActiveNode As TreeListNode
public:
TreeListNode^ GetActiveNode()
member GetActiveNode : unit -> TreeListNode

Valore di ritorno

TreeListNode
Vedi anche

Documentazione

Classe DedBomExplorerControl
Namespace DedNet.Controls


Metodo DedBomExplorerControl.GetDropTarget

Metodo DedBomExplorerControlGetDropTarget
Ritorna un identificatore del controllo figlio bersaglio del drop

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedBomExplorerControlDropTargetControlsEnum GetDropTarget(
    Point pointScreen
)
Public Function GetDropTarget (
    pointScreen As Point
) As DedBomExplorerControlDropTargetControlsEnum
public:
DedBomExplorerControlDropTargetControlsEnum GetDropTarget(
    Point pointScreen
)
member GetDropTarget :
        pointScreen : Point -> DedBomExplorerControlDropTargetControlsEnum

Parametri

pointScreen Point

Valore di ritorno

DedBomExplorerControlDropTargetControlsEnum
Vedi anche

Documentazione

Classe DedBomExplorerControl
Namespace DedNet.Controls


Metodo DedBomExplorerControl.GetMinWidth

Metodo DedBomExplorerControlGetMinWidth
Ritorna le dimensioni minime che deve avere questo controllo se non si vuole che i controlli all'interno del LayoutControl si sovrappongano e vengano tagliati.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int GetMinWidth()
Public Function GetMinWidth As Integer
public:
int GetMinWidth()
member GetMinWidth : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedBomExplorerControl
Namespace DedNet.Controls


Metodo DedBomExplorerControl.InitCommOnLoad

Metodo DedBomExplorerControlInitCommOnLoad
Funzione per caricare le distinte precompilate.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void InitCommOnLoad()
Public Sub InitCommOnLoad
public:
void InitCommOnLoad()
member InitCommOnLoad : unit -> unit
Vedi anche

Documentazione

Classe DedBomExplorerControl
Namespace DedNet.Controls


Metodo DedBomExplorerControl.InitDataOnLoad

Metodo DedBomExplorerControlInitDataOnLoad
Funzione per caricare le distinte precompilate.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void InitDataOnLoad()
Public Sub InitDataOnLoad
public:
void InitDataOnLoad()
member InitDataOnLoad : unit -> unit
Vedi anche

Documentazione

Classe DedBomExplorerControl
Namespace DedNet.Controls


Metodo DedBomExplorerControl.LoadData

Metodo DedBomExplorerControlLoadData
Permette di aprire la distinta dell'anagrafica passata

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void LoadData(
    DedData newdd,
    string discrimDist
)
Public Sub LoadData (
    newdd As DedData,
    discrimDist As String
)
public:
void LoadData(
    DedData^ newdd,
    String^ discrimDist
)
member LoadData :
        newdd : DedData *
        discrimDist : string -> unit

Parametri

newdd DedData
Anagrafica da utilizzare per l'apertura della distinta
discrimDist String
Tipo di distinta da caricare
Vedi anche

Documentazione

Classe DedBomExplorerControl
Namespace DedNet.Controls


Metodo DedBomExplorerControl.LoadInitPrtAnagrData

Metodo DedBomExplorerControlLoadInitPrtAnagrData
Se possibile carica una distinta dalla riga di inizia parte veloce

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void LoadInitPrtAnagrData(
    Row item
)
Public Sub LoadInitPrtAnagrData (
    item As Row
)
public:
void LoadInitPrtAnagrData(
    Row^ item
)
member LoadInitPrtAnagrData :
        item : Row -> unit

Parametri

item Row
Riga di inizia parte veloce
Vedi anche

Documentazione

Classe DedBomExplorerControl
Namespace DedNet.Controls


Metodo DedBomExplorerControl.OnHandleDestroyed

Metodo DedBomExplorerControlOnHandleDestroyed
Lista degli overload
 | Nome | Descrizione
Metodo protetto | OnHandleDestroyed(EventArgs) | Evento che scatta quando sta per essere chiuso il controllo.
Metodo protetto | OnHandleDestroyed(EventArgs) |
Torna su
Vedi anche

Documentazione

Classe DedBomExplorerControl
Namespace DedNet.Controls


Metodo DedBomExplorerControl.OnHandleDestroyed(EventArgs)

Metodo DedBomExplorerControlOnHandleDestroyed(EventArgs)
Evento che scatta quando sta per essere chiuso il controllo.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void OnHandleDestroyed(
    EventArgs e
)
Protected Overrides Sub OnHandleDestroyed (
    e As EventArgs
)
protected:
virtual void OnHandleDestroyed(
    EventArgs^ e
) override
abstract OnHandleDestroyed :
        e : EventArgs -> unit
override OnHandleDestroyed :
        e : EventArgs -> unit

Parametri

e EventArgs
Vedi anche

Documentazione

Classe DedBomExplorerControl
Overload di OnHandleDestroyed
Namespace DedNet.Controls


Metodo DedBomExplorerControl.ReloadData

Metodo DedBomExplorerControlReloadData
Ricarica i dati della distinta

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ReloadData()
Public Sub ReloadData
public:
void ReloadData()
member ReloadData : unit -> unit
Vedi anche

Documentazione

Classe DedBomExplorerControl
Namespace DedNet.Controls


Metodo DedBomExplorerControl.ReloadOptions

Metodo DedBomExplorerControlReloadOptions
Ricarica le impostazioni dei FindCodeControl rileggendo dall'Application.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ReloadOptions()
Public Sub ReloadOptions
public:
void ReloadOptions()
member ReloadOptions : unit -> unit
Vedi anche

Documentazione

Classe DedBomExplorerControl
Namespace DedNet.Controls


Metodo DedBomExplorerControl.RestoreDist

Metodo DedBomExplorerControlRestoreDist
Confronta la distinta caricata con l'elemento passato.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void RestoreDist()
Public Sub RestoreDist
public:
void RestoreDist()
member RestoreDist : unit -> unit
Vedi anche

Documentazione

Classe DedBomExplorerControl
Namespace DedNet.Controls


Metodo DedBomExplorerControl.SaveRegistrySettings

Metodo DedBomExplorerControlSaveRegistrySettings
Salva nel registro di sistema le informazioni necessarie

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SaveRegistrySettings()
Public Sub SaveRegistrySettings
public:
void SaveRegistrySettings()
member SaveRegistrySettings : unit -> unit
Vedi anche

Documentazione

Classe DedBomExplorerControl
Namespace DedNet.Controls


Eventi di DedBomExplorerControl

Il tipo DedBomExplorerControl espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | ContextCreated | Evento che scatta quando si sta creando il contesto da utilizzare per la generazione del menu contestuale.
Evento pubblico | ContextMenuOpening | Evento su apertura del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | DistLoaded | Evento che scatta quando viene caricata una distinta
Evento pubblico | DistReLoadedInsideGrid | Evento che scatta quando viene caricata una distinta
Evento pubblico | getDuplicatedDist | Evento per caricare la distinta duplicata dall'altro pannello
Evento pubblico | MenuItemClicked | Evento su click su un elemento del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | moveCodeList | Evento per lo spostamento dei codici da un pannello all'altro
Evento pubblico | openOppositePanel | Evento per il caricamento dell'anagrafica nell'altro pannello
Evento pubblico | PaintEx | (Ereditato da XtraUserControl)
Evento pubblico | SelectedDataChanged | Evento per il cambiamento della selezione corrente all'interno dell'albero di distinta
Torna su
Vedi anche

Documentazione

Classe DedBomExplorerControl
Namespace DedNet.Controls


Evento DedBomExplorerControl.ContextCreated

Evento DedBomExplorerControlContextCreated
Evento che scatta quando si sta creando il contesto da utilizzare per la generazione del menu contestuale.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DedBomExplorerControlContextCreatedEventArgs> ContextCreated
Public Event ContextCreated As EventHandler(Of DedBomExplorerControlContextCreatedEventArgs)
public:
 event EventHandler<DedBomExplorerControlContextCreatedEventArgs^>^ ContextCreated {
    void add (EventHandler<DedBomExplorerControlContextCreatedEventArgs^>^ value);
    void remove (EventHandler<DedBomExplorerControlContextCreatedEventArgs^>^ value);
}
member ContextCreated : IEvent<EventHandler<DedBomExplorerControlContextCreatedEventArgs>,
    DedBomExplorerControlContextCreatedEventArgs>

Valore

EventHandler DedBomExplorerControlContextCreatedEventArgs
Vedi anche

Documentazione

Classe DedBomExplorerControl
Namespace DedNet.Controls


Evento DedBomExplorerControl.DistLoaded

Evento DedBomExplorerControlDistLoaded
Evento che scatta quando viene caricata una distinta

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DedBomExplorerControlLoadedDataEventArgs> DistLoaded
Public Event DistLoaded As EventHandler(Of DedBomExplorerControlLoadedDataEventArgs)
public:
 event EventHandler<DedBomExplorerControlLoadedDataEventArgs^>^ DistLoaded {
    void add (EventHandler<DedBomExplorerControlLoadedDataEventArgs^>^ value);
    void remove (EventHandler<DedBomExplorerControlLoadedDataEventArgs^>^ value);
}
member DistLoaded : IEvent<EventHandler<DedBomExplorerControlLoadedDataEventArgs>,
    DedBomExplorerControlLoadedDataEventArgs>

Valore

EventHandler DedBomExplorerControlLoadedDataEventArgs
Vedi anche

Documentazione

Classe DedBomExplorerControl
Namespace DedNet.Controls


Evento DedBomExplorerControl.DistReLoadedInsideGrid

Evento DedBomExplorerControlDistReLoadedInsideGrid
Evento che scatta quando viene caricata una distinta

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DedBomExplorerControlLoadedDataEventArgs> DistReLoadedInsideGrid
Public Event DistReLoadedInsideGrid As EventHandler(Of DedBomExplorerControlLoadedDataEventArgs)
public:
 event EventHandler<DedBomExplorerControlLoadedDataEventArgs^>^ DistReLoadedInsideGrid {
    void add (EventHandler<DedBomExplorerControlLoadedDataEventArgs^>^ value);
    void remove (EventHandler<DedBomExplorerControlLoadedDataEventArgs^>^ value);
}
member DistReLoadedInsideGrid : IEvent<EventHandler<DedBomExplorerControlLoadedDataEventArgs>,
    DedBomExplorerControlLoadedDataEventArgs>

Valore

EventHandler DedBomExplorerControlLoadedDataEventArgs
Vedi anche

Documentazione

Classe DedBomExplorerControl
Namespace DedNet.Controls


Evento DedBomExplorerControl.getDuplicatedDist

Evento DedBomExplorerControlgetDuplicatedDist
Evento per caricare la distinta duplicata dall'altro pannello

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler getDuplicatedDist
Public Event getDuplicatedDist As EventHandler
public:
 event EventHandler^ getDuplicatedDist {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member getDuplicatedDist : IEvent<EventHandler,
    EventArgs>

Valore

EventHandler
Vedi anche

Documentazione

Classe DedBomExplorerControl
Namespace DedNet.Controls


Evento DedBomExplorerControl.moveCodeList

Evento DedBomExplorerControlmoveCodeList
Evento per lo spostamento dei codici da un pannello all'altro

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DedBomExplorerControlDedDataListEventArgs> moveCodeList
Public Event moveCodeList As EventHandler(Of DedBomExplorerControlDedDataListEventArgs)
public:
 event EventHandler<DedBomExplorerControlDedDataListEventArgs^>^ moveCodeList {
    void add (EventHandler<DedBomExplorerControlDedDataListEventArgs^>^ value);
    void remove (EventHandler<DedBomExplorerControlDedDataListEventArgs^>^ value);
}
member moveCodeList : IEvent<EventHandler<DedBomExplorerControlDedDataListEventArgs>,
    DedBomExplorerControlDedDataListEventArgs>

Valore

EventHandler DedBomExplorerControlDedDataListEventArgs
Vedi anche

Documentazione

Classe DedBomExplorerControl
Namespace DedNet.Controls


Evento DedBomExplorerControl.openOppositePanel

Evento DedBomExplorerControlopenOppositePanel
Evento per il caricamento dell'anagrafica nell'altro pannello

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DedBomExplorerControlSelectedDedDataEventArgs> openOppositePanel
Public Event openOppositePanel As EventHandler(Of DedBomExplorerControlSelectedDedDataEventArgs)
public:
 event EventHandler<DedBomExplorerControlSelectedDedDataEventArgs^>^ openOppositePanel {
    void add (EventHandler<DedBomExplorerControlSelectedDedDataEventArgs^>^ value);
    void remove (EventHandler<DedBomExplorerControlSelectedDedDataEventArgs^>^ value);
}
member openOppositePanel : IEvent<EventHandler<DedBomExplorerControlSelectedDedDataEventArgs>,
    DedBomExplorerControlSelectedDedDataEventArgs>

Valore

EventHandler DedBomExplorerControlSelectedDedDataEventArgs
Vedi anche

Documentazione

Classe DedBomExplorerControl
Namespace DedNet.Controls


Evento DedBomExplorerControl.SelectedDataChanged

Evento DedBomExplorerControlSelectedDataChanged
Evento per il cambiamento della selezione corrente all'interno dell'albero di distinta

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DedDistControlDedBomEventArgs> SelectedDataChanged
Public Event SelectedDataChanged As EventHandler(Of DedDistControlDedBomEventArgs)
public:
 event EventHandler<DedDistControlDedBomEventArgs^>^ SelectedDataChanged {
    void add (EventHandler<DedDistControlDedBomEventArgs^>^ value);
    void remove (EventHandler<DedDistControlDedBomEventArgs^>^ value);
}
member SelectedDataChanged : IEvent<EventHandler<DedDistControlDedBomEventArgs>,
    DedDistControlDedBomEventArgs>

Valore

EventHandler DedDistControlDedBomEventArgs
Vedi anche

Documentazione

Classe DedBomExplorerControl
Namespace DedNet.Controls


Campi di DedBomExplorerControl

Il tipo DedBomExplorerControl espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | _app | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Campo protetto | _RegistryBaseKey | Chiave nel registro di sistema di salvataggio impostazioni. (Ereditato da UserControlBase)
Torna su
Vedi anche

Documentazione

Classe DedBomExplorerControl
Namespace DedNet.Controls


Classe DedBomExplorerControl.ContextCreatedEventArgs

Classe DedBomExplorerControlContextCreatedEventArgs
EventArgs utilizzato per modificare il contesto da utilizzare per la generazione del menu contestuale.
Gerarchia di ereditarietà
SystemObject
DedNet.ControlsDedBomExplorerControlContextCreatedEventArgs

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ContextCreatedEventArgs
Public Class ContextCreatedEventArgs
public ref class ContextCreatedEventArgs
type ContextCreatedEventArgs = class end

Il tipo DedBomExplorerControlContextCreatedEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedBomExplorerControlContextCreatedEventArgs | Crea una nuova istanza della classe 'ContextCreated' utilizzata per modificare il contesto da utilizzare per la generazione del menu contestuale.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Context | Contesto appena creato.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore DedBomExplorerControl.ContextCreatedEventArgs

Costruttore DedBomExplorerControlContextCreatedEventArgs
Crea una nuova istanza della classe 'ContextCreated' utilizzata per modificare il contesto da utilizzare per la generazione del menu contestuale.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ContextCreatedEventArgs(
    DedCommandContext context
)
Public Sub New (
    context As DedCommandContext
)
public:
ContextCreatedEventArgs(
    DedCommandContext^ context
)
new :
        context : DedCommandContext -> ContextCreatedEventArgs

Parametri

context DedCommandContext
Contesto appena creato.
Vedi anche

Documentazione

Classe DedBomExplorerControlContextCreatedEventArgs
Namespace DedNet.Controls


Proprietà di ContextCreatedEventArgs

Il tipo DedBomExplorerControlContextCreatedEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Context | Contesto appena creato.
Torna su
Vedi anche

Documentazione

Classe DedBomExplorerControlContextCreatedEventArgs
Namespace DedNet.Controls


Proprietà DedBomExplorerControl.ContextCreatedEventArgs.Context

Proprietà DedBomExplorerControlContextCreatedEventArgsContext
Contesto appena creato.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommandContext Context { get; }
Public ReadOnly Property Context As DedCommandContext
    Get
public:
property DedCommandContext^ Context {
    DedCommandContext^ get ();
}
member Context : DedCommandContext with get

Valore della proprietà

DedCommandContext
Vedi anche

Documentazione

Classe DedBomExplorerControlContextCreatedEventArgs
Namespace DedNet.Controls


Enumerazione DedBomExplorerControl.DedBomExplorerBehaviourEnum

Enumerazione DedBomExplorerControlDedBomExplorerBehaviourEnum
Enumerazioni dei possibili comportamenti del controllo

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum DedBomExplorerBehaviourEnum
Public Enumeration DedBomExplorerBehaviourEnum
public enum class DedBomExplorerBehaviourEnum
type DedBomExplorerBehaviourEnum
Membri
Nome | Valore | Descrizione
None | 0 | Non specificato.
ReadOnly | 1 | Sola Lettura
ReadWrite | 2 | Lettura e Scrittura
BomImpl | 3 | Dsitinta implosa
BomExpl | 4 | Distinta esplosa
BomComm | 5 | Distinta commessa
Vedi anche

Documentazione

Namespace DedNet.Controls


Classe DedBomExplorerControl.DedDataListEventArgs

Classe DedBomExplorerControlDedDataListEventArgs
Classe Data List Argument
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNet.ControlsDedBomExplorerControlDedDataListEventArgs

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedDataListEventArgs : EventArgs
Public Class DedDataListEventArgs
    Inherits EventArgs
public ref class DedDataListEventArgs : public EventArgs
type DedDataListEventArgs =
    class
        inherit EventArgs
    end

Il tipo DedBomExplorerControlDedDataListEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BomItemList | Lista BomItem Selezionati
Proprietà pubblica | BomNodeList | Lista BomItem Selezionati
Proprietà pubblica | CodeList | Lista Codici Selezionati
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Proprietà di DedDataListEventArgs

Il tipo DedBomExplorerControlDedDataListEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BomItemList | Lista BomItem Selezionati
Proprietà pubblica | BomNodeList | Lista BomItem Selezionati
Proprietà pubblica | CodeList | Lista Codici Selezionati
Torna su
Vedi anche

Documentazione

Classe DedBomExplorerControlDedDataListEventArgs
Namespace DedNet.Controls


Proprietà DedBomExplorerControl.DedDataListEventArgs.BomItemList

Proprietà DedBomExplorerControlDedDataListEventArgsBomItemList
Lista BomItem Selezionati

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<BomItem> BomItemList { get; }
Public ReadOnly Property BomItemList As List(Of BomItem)
    Get
public:
property List<BomItem^>^ BomItemList {
    List<BomItem^>^ get ();
}
member BomItemList : List<BomItem> with get

Valore della proprietà

List BomItem
Vedi anche

Documentazione

Classe DedBomExplorerControlDedDataListEventArgs
Namespace DedNet.Controls


Proprietà DedBomExplorerControl.DedDataListEventArgs.BomNodeList

Proprietà DedBomExplorerControlDedDataListEventArgsBomNodeList
Lista BomItem Selezionati

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<TreeListNode> BomNodeList { get; }
Public ReadOnly Property BomNodeList As List(Of TreeListNode)
    Get
public:
property List<TreeListNode^>^ BomNodeList {
    List<TreeListNode^>^ get ();
}
member BomNodeList : List<TreeListNode> with get

Valore della proprietà

List TreeListNode
Vedi anche

Documentazione

Classe DedBomExplorerControlDedDataListEventArgs
Namespace DedNet.Controls


Proprietà DedBomExplorerControl.DedDataListEventArgs.CodeList

Proprietà DedBomExplorerControlDedDataListEventArgsCodeList
Lista Codici Selezionati

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataList CodeList { get; }
Public ReadOnly Property CodeList As DedDataList
    Get
public:
property DedDataList^ CodeList {
    DedDataList^ get ();
}
member CodeList : DedDataList with get

Valore della proprietà

DedDataList
Vedi anche

Documentazione

Classe DedBomExplorerControlDedDataListEventArgs
Namespace DedNet.Controls


Enumerazione DedBomExplorerControl.DropTargetControlsEnum

Enumerazione DedBomExplorerControlDropTargetControlsEnum
Enumerazione dei possibili target del drop sul controllo

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum DropTargetControlsEnum
Public Enumeration DropTargetControlsEnum
public enum class DropTargetControlsEnum
type DropTargetControlsEnum
Membri
Nome | Valore | Descrizione
None | 0 | Nessuno
DistControl | 1 | Sola Lettura
DataLookUp | 2 | Lettura e Scrittura
Vedi anche

Documentazione

Namespace DedNet.Controls


Enumerazione DedBomExplorerControl.lkuComboBehaviouyrEnum

Enumerazione DedBomExplorerControllkuComboBehaviouyrEnum
Enumerazioni dei possibili comportamenti del lookUpEdit delle anagrafiche

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum lkuComboBehaviouyrEnum
Public Enumeration lkuComboBehaviouyrEnum
public enum class lkuComboBehaviouyrEnum
type lkuComboBehaviouyrEnum
Membri
Nome | Valore | Descrizione
Standard | 0 | Anagrafica
Mru | 1 | Recenti
Vedi anche

Documentazione

Namespace DedNet.Controls


Classe DedBomExplorerControl.LoadedDataEventArgs

Classe DedBomExplorerControlLoadedDataEventArgs
Classe Loaded Data
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNet.ControlsDedBomExplorerControlLoadedDataEventArgs

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class LoadedDataEventArgs : EventArgs
Public Class LoadedDataEventArgs
    Inherits EventArgs
public ref class LoadedDataEventArgs : public EventArgs
type LoadedDataEventArgs =
    class
        inherit EventArgs
    end

Il tipo DedBomExplorerControlLoadedDataEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | LoadedData | Anagrafica Caricata
Proprietà pubblica | LoadedDistType | Tipo di distinta
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Proprietà di LoadedDataEventArgs

Il tipo DedBomExplorerControlLoadedDataEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | LoadedData | Anagrafica Caricata
Proprietà pubblica | LoadedDistType | Tipo di distinta
Torna su
Vedi anche

Documentazione

Classe DedBomExplorerControlLoadedDataEventArgs
Namespace DedNet.Controls


Proprietà DedBomExplorerControl.LoadedDataEventArgs.LoadedData

Proprietà DedBomExplorerControlLoadedDataEventArgsLoadedData
Anagrafica Caricata

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData LoadedData { get; }
Public ReadOnly Property LoadedData As DedData
    Get
public:
property DedData^ LoadedData {
    DedData^ get ();
}
member LoadedData : DedData with get

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe DedBomExplorerControlLoadedDataEventArgs
Namespace DedNet.Controls


Proprietà DedBomExplorerControl.LoadedDataEventArgs.LoadedDistType

Proprietà DedBomExplorerControlLoadedDataEventArgsLoadedDistType
Tipo di distinta

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string LoadedDistType { get; }
Public ReadOnly Property LoadedDistType As String
    Get
public:
property String^ LoadedDistType {
    String^ get ();
}
member LoadedDistType : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedBomExplorerControlLoadedDataEventArgs
Namespace DedNet.Controls


Classe DedBomExplorerControl.SelectedDedDataEventArgs

Classe DedBomExplorerControlSelectedDedDataEventArgs
Classe Selected Ded Data
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNet.ControlsDedBomExplorerControlSelectedDedDataEventArgs

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class SelectedDedDataEventArgs : EventArgs
Public Class SelectedDedDataEventArgs
    Inherits EventArgs
public ref class SelectedDedDataEventArgs : public EventArgs
type SelectedDedDataEventArgs =
    class
        inherit EventArgs
    end

Il tipo DedBomExplorerControlSelectedDedDataEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | DiscrimDist | Tipo di distinta corrente
Proprietà pubblica | Selection | Anagrafica Selezionata
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Proprietà di SelectedDedDataEventArgs

Il tipo DedBomExplorerControlSelectedDedDataEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | DiscrimDist | Tipo di distinta corrente
Proprietà pubblica | Selection | Anagrafica Selezionata
Torna su
Vedi anche

Documentazione

Classe DedBomExplorerControlSelectedDedDataEventArgs
Namespace DedNet.Controls


Proprietà DedBomExplorerControl.SelectedDedDataEventArgs.DiscrimDist

Proprietà DedBomExplorerControlSelectedDedDataEventArgsDiscrimDist
Tipo di distinta corrente

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string DiscrimDist { get; }
Public ReadOnly Property DiscrimDist As String
    Get
public:
property String^ DiscrimDist {
    String^ get ();
}
member DiscrimDist : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedBomExplorerControlSelectedDedDataEventArgs
Namespace DedNet.Controls


Proprietà DedBomExplorerControl.SelectedDedDataEventArgs.Selection

Proprietà DedBomExplorerControlSelectedDedDataEventArgsSelection
Anagrafica Selezionata

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Selection { get; }
Public ReadOnly Property Selection As DedData
    Get
public:
property DedData^ Selection {
    DedData^ get ();
}
member Selection : DedData with get

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe DedBomExplorerControlSelectedDedDataEventArgs
Namespace DedNet.Controls


Classe DedButtonClickEventArgs
EventArgs dell'evento DedButtonClickEvent.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedNet.ControlsDedButtonClickEventArgs

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedButtonClickEventArgs : CancelEventArgs
Public Class DedButtonClickEventArgs
    Inherits CancelEventArgs
public ref class DedButtonClickEventArgs : public CancelEventArgs
type DedButtonClickEventArgs =
    class
        inherit CancelEventArgs
    end

Il tipo DedButtonClickEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedButtonClickEventArgs | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | IsPadre | Indica se il comando è stato chiamato sul controllo padre.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore DedButtonClickEventArgs
Costruttore unico.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedButtonClickEventArgs(
    bool isPadre
)
Public Sub New (
    isPadre As Boolean
)
public:
DedButtonClickEventArgs(
    bool isPadre
)
new :
        isPadre : bool -> DedButtonClickEventArgs

Parametri

isPadre Boolean
Indica se il comando è stato chiamato sul controllo padre.
Vedi anche

Documentazione

Classe DedButtonClickEventArgs
Namespace DedNet.Controls


Proprietà di DedButtonClickEventArgs

Il tipo DedButtonClickEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | IsPadre | Indica se il comando è stato chiamato sul controllo padre.
Torna su
Vedi anche

Documentazione

Classe DedButtonClickEventArgs
Namespace DedNet.Controls


Proprietà DedButtonClickEventArgs.IsPadre

Proprietà DedButtonClickEventArgsIsPadre
Indica se il comando è stato chiamato sul controllo padre.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsPadre { get; set; }
Public Property IsPadre As Boolean
    Get
    Set
public:
property bool IsPadre {
    bool get ();
    void set (bool value);
}
member IsPadre : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedButtonClickEventArgs
Namespace DedNet.Controls


Classe DedCascadeViewControl
Controllo che visualizza l'albero delle cascate.
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
XtraUserControl
DedNet.ControlsUserControlBase
DedNet.ControlsDedCascadeViewControl

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedCascadeViewControl : UserControlBase
Public Class DedCascadeViewControl
    Inherits UserControlBase
public ref class DedCascadeViewControl : public UserControlBase
type DedCascadeViewControl =
    class
        inherit UserControlBase
    end

Il tipo DedCascadeViewControl espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedCascadeViewControl | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Appearance | (Ereditato da XtraUserControl)
Proprietà pubblica | Application | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Proprietà pubblica | BackColor | (Ereditato da XtraUserControl)
Proprietà pubblica | CascadeList | Restituisce la lista delle cascate presenti nella famiglia selezionata.
Proprietà protetta | CheckDoubleScaling | (Ereditato da XtraUserControl)
Proprietà pubblica | CtrLev1 | Restituisce il ListBoxControl di primo livello.
Proprietà pubblica | CtrLev2 | Restituisce il ListBoxControl di secondo livello.
Proprietà protetta | DefaultAppearance | (Ereditato da XtraUserControl)
Proprietà protetta | DirectXContainer | (Ereditato da XtraUserControl)
Proprietà pubblica | EnableIXtraResizeableControlInterfaceProxy | (Ereditato da XtraUserControl)
Proprietà pubblica | Font | (Ereditato da XtraUserControl)
Proprietà pubblica | ForeColor | (Ereditato da XtraUserControl)
Proprietà protetta | Helper | (Ereditato da XtraUserControl)
Proprietà pubblica | ListBoxList | Restituisce la lista degli ImageListBoxControl presenti nel controllo.
Proprietà pubblica | LookAndFeel | (Ereditato da XtraUserControl)
Proprietà protetta | Painter | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleChildren | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleDPI | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraUserControl)
Proprietà pubblica | SelectedCtr | Restituisce l'ImageListBoxControl selezionato.
Proprietà pubblica | SelectedType | Restituisce o imposta la famiglia selezionata.
Proprietà protetta | ShouldCheckDpiScaleFactorOnParentChanged | (Ereditato da XtraUserControl)
Proprietà pubblica | Site | (Ereditato da XtraUserControl)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | BaseWndProc | (Ereditato da XtraUserControl)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraUserControl)
Metodo protetto | CreatePainter | (Ereditato da XtraUserControl)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive UserControlBaseDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraUserControl)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraUserControl)
Metodo pubblico | ForceCtrRefresh | Forza un refresh di tutti i controlli.
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraUserControl)
Metodo protetto | GetBackColor | (Ereditato da XtraUserControl)
Metodo protetto | GetBackgroundSkinElement | (Ereditato da XtraUserControl)
Metodo protetto | GetInnerIXtraResizableControl | (Ereditato da XtraUserControl)
Metodo pubblico | GetPadriFromSelectedControl | Restituisce la lista di tutti gli elementi selezionati nel controllo selezionato.
Metodo pubblico | InitPadri | Inizializza il controllo che mostra i nomi dei padri.
Metodo protetto | IsChildControlsRequiredScalingEnabled | (Ereditato da XtraUserControl)
Metodo protetto | IsParentHandleCreatedRecursive | (Ereditato da XtraUserControl)
Metodo protetto | OnAddButtonClick | Fa scattare il AddButtonClickEvent.
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraUserControl)
Metodo protetto | OnBackColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnContextMenuOpening | Evento di apertura del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnControlAdded | (Ereditato da XtraUserControl)
Metodo protetto | OnControlRemoved | (Ereditato da XtraUserControl)
Metodo protetto | OnCustomRidefinisci | Fa scattare il CustomRidefinisciEvent.
Metodo protetto | OnCustomSelectedIndexChanged | Fa scattare il CustomSelectedIndexChangedEvent.
Metodo protetto | OnDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnFirstLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnForeColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleCreated | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraUserControl)
Metodo protetto | OnLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnMenuItemClicked | Evento di pressione di un comando del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnPaintCore | (Ereditato da XtraUserControl)
Metodo protetto | OnParentChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnRemoveButtonClick | Fa scattare il RemoveButtonClickEvent.
Metodo protetto | OnScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | OnSelectedCtrChanged | Fa scattare il SelectedCtrChangedEvent.
Metodo protetto | OnSizeChanged | (Ereditato da XtraUserControl)
Metodo protetto | RaisePaintExEvent | (Ereditato da XtraUserControl)
Metodo pubblico | ResetBackColor | (Ereditato da XtraUserControl)
Metodo pubblico | ResetForeColor | (Ereditato da XtraUserControl)
Metodo protetto | RestoreAutoScaleModeChangedByPM2 | (Ereditato da XtraUserControl)
Metodo protetto | ScaleControl | (Ereditato da XtraUserControl)
Metodo pubblico | SetCommandList | Rigenera il menu contestuale di questo controllo con la lista dei comandi passati. (Ereditato da UserControlBase)
Metodo protetto | SetVisibleCore | (Ereditato da XtraUserControl)
Metodo protetto | ShouldPaintTransparentBackground | (Ereditato da XtraUserControl)
Metodo protetto | ShouldUseDirectXPaint | (Ereditato da XtraUserControl)
Metodo pubblico | UpdateListBoxPadri | Effettua un update del datasource del primo ListBox.
Metodo protetto | WndProc | (Ereditato da XtraUserControl)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | AddButtonClickEvent | Evento di click sul pulsante di aggiunta.
Evento pubblico | ContextMenuOpening | Evento su apertura del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | CustomRidefinisciEvent | Evento di ridefinizione.
Evento pubblico | CustomSelectedIndexChangedEvent | Evento di cambio di selezione dell'indice custom.
Evento pubblico | MenuItemClicked | Evento su click su un elemento del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | PaintEx | (Ereditato da XtraUserControl)
Evento pubblico | RemoveButtonClickEvent | Evento di click sul pulsante di eliminazione.
Evento pubblico | SelectedCtrChangedEvent | Evento di cambio di selezione dell'ImageListBoxControl.
Torna su
Campi
 | Nome | Descrizione
Campo protetto | _app | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Campo protetto | _RegistryBaseKey | Chiave nel registro di sistema di salvataggio impostazioni. (Ereditato da UserControlBase)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore DedCascadeViewControl
Costruttore unico.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCascadeViewControl()
Public Sub New
public:
DedCascadeViewControl()
new : unit -> DedCascadeViewControl
Vedi anche

Documentazione

Classe DedCascadeViewControl
Namespace DedNet.Controls


Proprietà di DedCascadeViewControl

Il tipo DedCascadeViewControl espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Appearance | (Ereditato da XtraUserControl)
Proprietà pubblica | Application | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Proprietà pubblica | BackColor | (Ereditato da XtraUserControl)
Proprietà pubblica | CascadeList | Restituisce la lista delle cascate presenti nella famiglia selezionata.
Proprietà protetta | CheckDoubleScaling | (Ereditato da XtraUserControl)
Proprietà pubblica | CtrLev1 | Restituisce il ListBoxControl di primo livello.
Proprietà pubblica | CtrLev2 | Restituisce il ListBoxControl di secondo livello.
Proprietà protetta | DefaultAppearance | (Ereditato da XtraUserControl)
Proprietà protetta | DirectXContainer | (Ereditato da XtraUserControl)
Proprietà pubblica | EnableIXtraResizeableControlInterfaceProxy | (Ereditato da XtraUserControl)
Proprietà pubblica | Font | (Ereditato da XtraUserControl)
Proprietà pubblica | ForeColor | (Ereditato da XtraUserControl)
Proprietà protetta | Helper | (Ereditato da XtraUserControl)
Proprietà pubblica | ListBoxList | Restituisce la lista degli ImageListBoxControl presenti nel controllo.
Proprietà pubblica | LookAndFeel | (Ereditato da XtraUserControl)
Proprietà protetta | Painter | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleChildren | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleDPI | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraUserControl)
Proprietà pubblica | SelectedCtr | Restituisce l'ImageListBoxControl selezionato.
Proprietà pubblica | SelectedType | Restituisce o imposta la famiglia selezionata.
Proprietà protetta | ShouldCheckDpiScaleFactorOnParentChanged | (Ereditato da XtraUserControl)
Proprietà pubblica | Site | (Ereditato da XtraUserControl)
Torna su
Vedi anche

Documentazione

Classe DedCascadeViewControl
Namespace DedNet.Controls


Proprietà DedCascadeViewControl.CascadeList

Proprietà DedCascadeViewControlCascadeList
Restituisce la lista delle cascate presenti nella famiglia selezionata.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCascadeList CascadeList { get; }
Public ReadOnly Property CascadeList As DedCascadeList
    Get
public:
property DedCascadeList^ CascadeList {
    DedCascadeList^ get ();
}
member CascadeList : DedCascadeList with get

Valore della proprietà

DedCascadeList
Vedi anche

Documentazione

Classe DedCascadeViewControl
Namespace DedNet.Controls


Proprietà DedCascadeViewControl.CtrLev1

Proprietà DedCascadeViewControlCtrLev1
Restituisce il ListBoxControl di primo livello.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public CustomImageListBoxControl CtrLev1 { get; }
Public ReadOnly Property CtrLev1 As CustomImageListBoxControl
    Get
public:
property CustomImageListBoxControl^ CtrLev1 {
    CustomImageListBoxControl^ get ();
}
member CtrLev1 : CustomImageListBoxControl with get

Valore della proprietà

CustomImageListBoxControl
Vedi anche

Documentazione

Classe DedCascadeViewControl
Namespace DedNet.Controls


Proprietà DedCascadeViewControl.CtrLev2

Proprietà DedCascadeViewControlCtrLev2
Restituisce il ListBoxControl di secondo livello.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public CustomImageListBoxControl CtrLev2 { get; }
Public ReadOnly Property CtrLev2 As CustomImageListBoxControl
    Get
public:
property CustomImageListBoxControl^ CtrLev2 {
    CustomImageListBoxControl^ get ();
}
member CtrLev2 : CustomImageListBoxControl with get

Valore della proprietà

CustomImageListBoxControl
Vedi anche

Documentazione

Classe DedCascadeViewControl
Namespace DedNet.Controls


Proprietà DedCascadeViewControl.ListBoxList

Proprietà DedCascadeViewControlListBoxList
Restituisce la lista degli ImageListBoxControl presenti nel controllo.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<CustomImageListBoxControl> ListBoxList { get; }
Public ReadOnly Property ListBoxList As List(Of CustomImageListBoxControl)
    Get
public:
property List<CustomImageListBoxControl^>^ ListBoxList {
    List<CustomImageListBoxControl^>^ get ();
}
member ListBoxList : List<CustomImageListBoxControl> with get

Valore della proprietà

List CustomImageListBoxControl
Vedi anche

Documentazione

Classe DedCascadeViewControl
Namespace DedNet.Controls


Proprietà DedCascadeViewControl.SelectedCtr

Proprietà DedCascadeViewControlSelectedCtr
Restituisce l'ImageListBoxControl selezionato.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public CustomImageListBoxControl SelectedCtr { get; }
Public ReadOnly Property SelectedCtr As CustomImageListBoxControl
    Get
public:
property CustomImageListBoxControl^ SelectedCtr {
    CustomImageListBoxControl^ get ();
}
member SelectedCtr : CustomImageListBoxControl with get

Valore della proprietà

CustomImageListBoxControl
Vedi anche

Documentazione

Classe DedCascadeViewControl
Namespace DedNet.Controls


Proprietà DedCascadeViewControl.SelectedType

Proprietà DedCascadeViewControlSelectedType
Restituisce o imposta la famiglia selezionata.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeBase SelectedType { get; set; }
Public Property SelectedType As DedTypeBase
    Get
    Set
public:
property DedTypeBase^ SelectedType {
    DedTypeBase^ get ();
    void set (DedTypeBase^ value);
}
member SelectedType : DedTypeBase with get, set

Valore della proprietà

DedTypeBase
Vedi anche

Documentazione

Classe DedCascadeViewControl
Namespace DedNet.Controls


Metodi di DedCascadeViewControl

Il tipo DedCascadeViewControl espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | BaseWndProc | (Ereditato da XtraUserControl)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraUserControl)
Metodo protetto | CreatePainter | (Ereditato da XtraUserControl)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive UserControlBaseDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraUserControl)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraUserControl)
Metodo pubblico | ForceCtrRefresh | Forza un refresh di tutti i controlli.
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraUserControl)
Metodo protetto | GetBackColor | (Ereditato da XtraUserControl)
Metodo protetto | GetBackgroundSkinElement | (Ereditato da XtraUserControl)
Metodo protetto | GetInnerIXtraResizableControl | (Ereditato da XtraUserControl)
Metodo pubblico | GetPadriFromSelectedControl | Restituisce la lista di tutti gli elementi selezionati nel controllo selezionato.
Metodo pubblico | InitPadri | Inizializza il controllo che mostra i nomi dei padri.
Metodo protetto | IsChildControlsRequiredScalingEnabled | (Ereditato da XtraUserControl)
Metodo protetto | IsParentHandleCreatedRecursive | (Ereditato da XtraUserControl)
Metodo protetto | OnAddButtonClick | Fa scattare il AddButtonClickEvent.
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraUserControl)
Metodo protetto | OnBackColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnContextMenuOpening | Evento di apertura del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnControlAdded | (Ereditato da XtraUserControl)
Metodo protetto | OnControlRemoved | (Ereditato da XtraUserControl)
Metodo protetto | OnCustomRidefinisci | Fa scattare il CustomRidefinisciEvent.
Metodo protetto | OnCustomSelectedIndexChanged | Fa scattare il CustomSelectedIndexChangedEvent.
Metodo protetto | OnDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnFirstLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnForeColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleCreated | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraUserControl)
Metodo protetto | OnLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnMenuItemClicked | Evento di pressione di un comando del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnPaintCore | (Ereditato da XtraUserControl)
Metodo protetto | OnParentChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnRemoveButtonClick | Fa scattare il RemoveButtonClickEvent.
Metodo protetto | OnScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | OnSelectedCtrChanged | Fa scattare il SelectedCtrChangedEvent.
Metodo protetto | OnSizeChanged | (Ereditato da XtraUserControl)
Metodo protetto | RaisePaintExEvent | (Ereditato da XtraUserControl)
Metodo pubblico | ResetBackColor | (Ereditato da XtraUserControl)
Metodo pubblico | ResetForeColor | (Ereditato da XtraUserControl)
Metodo protetto | RestoreAutoScaleModeChangedByPM2 | (Ereditato da XtraUserControl)
Metodo protetto | ScaleControl | (Ereditato da XtraUserControl)
Metodo pubblico | SetCommandList | Rigenera il menu contestuale di questo controllo con la lista dei comandi passati. (Ereditato da UserControlBase)
Metodo protetto | SetVisibleCore | (Ereditato da XtraUserControl)
Metodo protetto | ShouldPaintTransparentBackground | (Ereditato da XtraUserControl)
Metodo protetto | ShouldUseDirectXPaint | (Ereditato da XtraUserControl)
Metodo pubblico | UpdateListBoxPadri | Effettua un update del datasource del primo ListBox.
Metodo protetto | WndProc | (Ereditato da XtraUserControl)
Torna su
Vedi anche

Documentazione

Classe DedCascadeViewControl
Namespace DedNet.Controls


Metodo DedCascadeViewControl.Dispose

Metodo DedCascadeViewControlDispose
Clean up any resources being used.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedCascadeViewControl
Namespace DedNet.Controls


Metodo DedCascadeViewControl.ForceCtrRefresh

Metodo DedCascadeViewControlForceCtrRefresh
Forza un refresh di tutti i controlli.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ForceCtrRefresh()
Public Sub ForceCtrRefresh
public:
void ForceCtrRefresh()
member ForceCtrRefresh : unit -> unit
Vedi anche

Documentazione

Classe DedCascadeViewControl
Namespace DedNet.Controls


Metodo DedCascadeViewControl.GetPadriFromSelectedControl

Metodo DedCascadeViewControlGetPadriFromSelectedControl
Restituisce la lista di tutti gli elementi selezionati nel controllo selezionato.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> GetPadriFromSelectedControl()
Public Function GetPadriFromSelectedControl As List(Of String)
public:
List<String^>^ GetPadriFromSelectedControl()
member GetPadriFromSelectedControl : unit -> List<string>

Valore di ritorno

List String
Vedi anche

Documentazione

Classe DedCascadeViewControl
Namespace DedNet.Controls


Metodo DedCascadeViewControl.InitPadri

Metodo DedCascadeViewControlInitPadri
Inizializza il controllo che mostra i nomi dei padri.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void InitPadri()
Public Sub InitPadri
public:
void InitPadri()
member InitPadri : unit -> unit
Vedi anche

Documentazione

Classe DedCascadeViewControl
Namespace DedNet.Controls


Metodo DedCascadeViewControl.OnAddButtonClick

Metodo DedCascadeViewControlOnAddButtonClick
Fa scattare il AddButtonClickEvent.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnAddButtonClick(
    Object sender,
    DedButtonClickEventArgs e
)
Protected Friend Sub OnAddButtonClick (
    sender As Object,
    e As DedButtonClickEventArgs
)
protected public:
void OnAddButtonClick(
    Object^ sender,
    DedButtonClickEventArgs^ e
)
member OnAddButtonClick :
        sender : Object *
        e : DedButtonClickEventArgs -> unit

Parametri

sender Object
e DedButtonClickEventArgs
Vedi anche

Documentazione

Classe DedCascadeViewControl
Namespace DedNet.Controls


Metodo DedCascadeViewControl.OnCustomRidefinisci

Metodo DedCascadeViewControlOnCustomRidefinisci
Fa scattare il CustomRidefinisciEvent.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnCustomRidefinisci(
    Object sender,
    ItemClickEventArgs e
)
Protected Friend Sub OnCustomRidefinisci (
    sender As Object,
    e As ItemClickEventArgs
)
protected public:
void OnCustomRidefinisci(
    Object^ sender,
    ItemClickEventArgs^ e
)
member OnCustomRidefinisci :
        sender : Object *
        e : ItemClickEventArgs -> unit

Parametri

sender Object
e ItemClickEventArgs
Vedi anche

Documentazione

Classe DedCascadeViewControl
Namespace DedNet.Controls


Metodo DedCascadeViewControl.OnCustomSelectedIndexChanged

Metodo DedCascadeViewControlOnCustomSelectedIndexChanged
Fa scattare il CustomSelectedIndexChangedEvent.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnCustomSelectedIndexChanged(
    Object sender,
    DedSelectedIndexEventArgs e
)
Protected Friend Sub OnCustomSelectedIndexChanged (
    sender As Object,
    e As DedSelectedIndexEventArgs
)
protected public:
void OnCustomSelectedIndexChanged(
    Object^ sender,
    DedSelectedIndexEventArgs^ e
)
member OnCustomSelectedIndexChanged :
        sender : Object *
        e : DedSelectedIndexEventArgs -> unit

Parametri

sender Object
e DedSelectedIndexEventArgs
Vedi anche

Documentazione

Classe DedCascadeViewControl
Namespace DedNet.Controls


Metodo DedCascadeViewControl.OnRemoveButtonClick

Metodo DedCascadeViewControlOnRemoveButtonClick
Fa scattare il RemoveButtonClickEvent.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnRemoveButtonClick(
    Object sender,
    DedButtonClickEventArgs e
)
Protected Friend Sub OnRemoveButtonClick (
    sender As Object,
    e As DedButtonClickEventArgs
)
protected public:
void OnRemoveButtonClick(
    Object^ sender,
    DedButtonClickEventArgs^ e
)
member OnRemoveButtonClick :
        sender : Object *
        e : DedButtonClickEventArgs -> unit

Parametri

sender Object
e DedButtonClickEventArgs
Vedi anche

Documentazione

Classe DedCascadeViewControl
Namespace DedNet.Controls


Metodo DedCascadeViewControl.OnSelectedCtrChanged

Metodo DedCascadeViewControlOnSelectedCtrChanged
Fa scattare il SelectedCtrChangedEvent.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnSelectedCtrChanged(
    Object sender,
    EventArgs e
)
Protected Friend Sub OnSelectedCtrChanged (
    sender As Object,
    e As EventArgs
)
protected public:
void OnSelectedCtrChanged(
    Object^ sender,
    EventArgs^ e
)
member OnSelectedCtrChanged :
        sender : Object *
        e : EventArgs -> unit

Parametri

sender Object
e EventArgs
Vedi anche

Documentazione

Classe DedCascadeViewControl
Namespace DedNet.Controls


Metodo DedCascadeViewControl.UpdateListBoxPadri

Metodo DedCascadeViewControlUpdateListBoxPadri
Effettua un update del datasource del primo ListBox.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void UpdateListBoxPadri(
    Object datasource
)
Public Sub UpdateListBoxPadri (
    datasource As Object
)
public:
void UpdateListBoxPadri(
    Object^ datasource
)
member UpdateListBoxPadri :
        datasource : Object -> unit

Parametri

datasource Object
Nuovo datasource da bindare.
Vedi anche

Documentazione

Classe DedCascadeViewControl
Namespace DedNet.Controls


Eventi di DedCascadeViewControl

Il tipo DedCascadeViewControl espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | AddButtonClickEvent | Evento di click sul pulsante di aggiunta.
Evento pubblico | ContextMenuOpening | Evento su apertura del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | CustomRidefinisciEvent | Evento di ridefinizione.
Evento pubblico | CustomSelectedIndexChangedEvent | Evento di cambio di selezione dell'indice custom.
Evento pubblico | MenuItemClicked | Evento su click su un elemento del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | PaintEx | (Ereditato da XtraUserControl)
Evento pubblico | RemoveButtonClickEvent | Evento di click sul pulsante di eliminazione.
Evento pubblico | SelectedCtrChangedEvent | Evento di cambio di selezione dell'ImageListBoxControl.
Torna su
Vedi anche

Documentazione

Classe DedCascadeViewControl
Namespace DedNet.Controls


Evento DedCascadeViewControl.AddButtonClickEvent

Evento DedCascadeViewControlAddButtonClickEvent
Evento di click sul pulsante di aggiunta.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DedButtonClickEventArgs> AddButtonClickEvent
Public Event AddButtonClickEvent As EventHandler(Of DedButtonClickEventArgs)
public:
 event EventHandler<DedButtonClickEventArgs^>^ AddButtonClickEvent {
    void add (EventHandler<DedButtonClickEventArgs^>^ value);
    void remove (EventHandler<DedButtonClickEventArgs^>^ value);
}
member AddButtonClickEvent : IEvent<EventHandler<DedButtonClickEventArgs>,
    DedButtonClickEventArgs>

Valore

EventHandler DedButtonClickEventArgs
Vedi anche

Documentazione

Classe DedCascadeViewControl
Namespace DedNet.Controls


Evento DedCascadeViewControl.CustomRidefinisciEvent

Evento DedCascadeViewControlCustomRidefinisciEvent
Evento di ridefinizione.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<ItemClickEventArgs> CustomRidefinisciEvent
Public Event CustomRidefinisciEvent As EventHandler(Of ItemClickEventArgs)
public:
 event EventHandler<ItemClickEventArgs^>^ CustomRidefinisciEvent {
    void add (EventHandler<ItemClickEventArgs^>^ value);
    void remove (EventHandler<ItemClickEventArgs^>^ value);
}
member CustomRidefinisciEvent : IEvent<EventHandler<ItemClickEventArgs>,
    ItemClickEventArgs>

Valore

EventHandler ItemClickEventArgs
Vedi anche

Documentazione

Classe DedCascadeViewControl
Namespace DedNet.Controls


Evento DedCascadeViewControl.CustomSelectedIndexChangedEvent

Evento DedCascadeViewControlCustomSelectedIndexChangedEvent
Evento di cambio di selezione dell'indice custom.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DedSelectedIndexEventArgs> CustomSelectedIndexChangedEvent
Public Event CustomSelectedIndexChangedEvent As EventHandler(Of DedSelectedIndexEventArgs)
public:
 event EventHandler<DedSelectedIndexEventArgs^>^ CustomSelectedIndexChangedEvent {
    void add (EventHandler<DedSelectedIndexEventArgs^>^ value);
    void remove (EventHandler<DedSelectedIndexEventArgs^>^ value);
}
member CustomSelectedIndexChangedEvent : IEvent<EventHandler<DedSelectedIndexEventArgs>,
    DedSelectedIndexEventArgs>

Valore

EventHandler DedSelectedIndexEventArgs
Vedi anche

Documentazione

Classe DedCascadeViewControl
Namespace DedNet.Controls


Evento DedCascadeViewControl.RemoveButtonClickEvent

Evento DedCascadeViewControlRemoveButtonClickEvent
Evento di click sul pulsante di eliminazione.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DedButtonClickEventArgs> RemoveButtonClickEvent
Public Event RemoveButtonClickEvent As EventHandler(Of DedButtonClickEventArgs)
public:
 event EventHandler<DedButtonClickEventArgs^>^ RemoveButtonClickEvent {
    void add (EventHandler<DedButtonClickEventArgs^>^ value);
    void remove (EventHandler<DedButtonClickEventArgs^>^ value);
}
member RemoveButtonClickEvent : IEvent<EventHandler<DedButtonClickEventArgs>,
    DedButtonClickEventArgs>

Valore

EventHandler DedButtonClickEventArgs
Vedi anche

Documentazione

Classe DedCascadeViewControl
Namespace DedNet.Controls


Evento DedCascadeViewControl.SelectedCtrChangedEvent

Evento DedCascadeViewControlSelectedCtrChangedEvent
Evento di cambio di selezione dell'ImageListBoxControl.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler SelectedCtrChangedEvent
Public Event SelectedCtrChangedEvent As EventHandler
public:
 event EventHandler^ SelectedCtrChangedEvent {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member SelectedCtrChangedEvent : IEvent<EventHandler,
    EventArgs>

Valore

EventHandler
Vedi anche

Documentazione

Classe DedCascadeViewControl
Namespace DedNet.Controls


Campi di DedCascadeViewControl

Il tipo DedCascadeViewControl espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | _app | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Campo protetto | _RegistryBaseKey | Chiave nel registro di sistema di salvataggio impostazioni. (Ereditato da UserControlBase)
Torna su
Vedi anche

Documentazione

Classe DedCascadeViewControl
Namespace DedNet.Controls


Classe DedComboBox
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
XtraControl
ControlBase
BaseControl
BaseEdit
TextEdit
ButtonEdit
PopupBaseEdit
PopupBaseAutoSearchEdit
ComboBoxEdit
DedNet.ControlsDedComboBox

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedComboBox : ComboBoxEdit
Public Class DedComboBox
    Inherits ComboBoxEdit
public ref class DedComboBox : public ComboBoxEdit
type DedComboBox =
    class
        inherit ComboBoxEdit
    end

Il tipo DedComboBox espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedComboBox |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà protetta | AcceptsReturn | (Ereditato da TextEdit)
Proprietà protetta | AcceptsSpace | (Ereditato da TextEdit)
Proprietà protetta | AcceptsTab | (Ereditato da TextEdit)
Proprietà pubblica | AccessibleDefaultActionDescription | (Ereditato da BaseEdit)
Proprietà pubblica | AccessibleDescription | (Ereditato da BaseEdit)
Proprietà pubblica | AccessibleName | (Ereditato da BaseEdit)
Proprietà pubblica | AccessibleRole | (Ereditato da BaseEdit)
Proprietà protetta | AdvancedMode | (Ereditato da TextEdit)
Proprietà protetta | AllowAutoSearchSelectionLength | (Ereditato da ComboBoxEdit)
Proprietà protetta | AllowButtonPress | (Ereditato da ButtonEdit)
Proprietà protetta | AllowCloseByEscape | (Ereditato da PopupBaseEdit)
Proprietà protetta | AllowDefaultClearButtonAction | (Ereditato da PopupBaseEdit)
Proprietà protetta | AllowEmptyStringToNullValue | (Ereditato da PopupBaseAutoSearchEdit)
Proprietà protetta | AllowFireEditValueChanged | (Ereditato da BaseEdit)
Proprietà protetta | AllowHideClearButtonWhenNotFocused | (Ereditato da PopupBaseEdit)
Proprietà pubblica | AllowHtmlTextInToolTip | (Ereditato da BaseControl)
Proprietà protetta | AllowImmediateClose | (Ereditato da PopupBaseEdit)
Proprietà protetta | AllowPaintBackground | (Ereditato da TextEdit)
Proprietà protetta | AllowPopupTabOut | (Ereditato da PopupBaseEdit)
Proprietà protetta | AllowProcessPaint | (Ereditato da BaseControl)
Proprietà protetta | AllowSelectAllOnPopupClose | (Ereditato da ComboBoxEdit)
Proprietà protetta | AllowSelectOnPopupSelectedIndexChanged | (Ereditato da ComboBoxEdit)
Proprietà protetta | AllowSmartMouseWheel | (Ereditato da PopupBaseEdit)
Proprietà protetta | AllowTransparency | (Ereditato da TextEdit)
Proprietà protetta | AllowUpdateIsModifiedOnValueChanging | (Ereditato da ComboBoxEdit)
Proprietà protetta | AllowValidateOnEnterKey | (Ereditato da TextEdit)
Proprietà protetta | AltBounds | (Ereditato da PopupBaseEdit)
Proprietà protetta | AutoHideClearButtonWhenNotFocused | (Ereditato da PopupBaseEdit)
Proprietà pubblica | AutoSearchText | (Ereditato da PopupBaseAutoSearchEdit)
Proprietà pubblica | AutoSizeInLayoutControl | (Ereditato da BaseControl)
Proprietà pubblica | BackColor | (Ereditato da TextEdit)
Proprietà pubblica | BackgroundImage | (Ereditato da TextEdit)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da TextEdit)
Proprietà protetta | BaseBorderStyle | (Ereditato da BaseControl)
Proprietà pubblica | BindingManager | (Ereditato da BaseEdit)
Proprietà pubblica | BorderStyle | (Ereditato da BaseEdit)
Proprietà protetta | CanAnimateCore | (Ereditato da BaseControl)
Proprietà protetta | CanProcessAutoSearchText | (Ereditato da PopupBaseAutoSearchEdit)
Proprietà pubblica | CanShowDialog | (Ereditato da BaseEdit)
Proprietà protetta | CanShowPopup | (Ereditato da ComboBoxEdit)
Proprietà protetta | CanTabStop | (Ereditato da TextEdit)
Proprietà pubblica | CanUndo | (Ereditato da TextEdit)
Proprietà pubblica | ContextMenu | (Ereditato da BaseEdit)
Proprietà pubblica | ContextMenuStrip | (Ereditato da BaseEdit)
Proprietà protetta | CreateParams | (Ereditato da TextEdit)
Proprietà pubblica | Cursor | (Ereditato da ControlBase)
Proprietà protetta | DefaultCursor | (Ereditato da TextEdit)
Proprietà protetta | DefaultSize | (Ereditato da TextEdit)
Proprietà protetta | DefaultUseCtrlScroll | (Ereditato da ComboBoxEdit)
Proprietà protetta | DelayedAddContainerControl | (Ereditato da PopupBaseEdit)
Proprietà protetta | DirectXProvider | (Ereditato da XtraControl)
Proprietà protetta | DirectXScroller | (Ereditato da XtraControl)
Proprietà protetta | DXAccessible | (Ereditato da TextEdit)
Proprietà protetta | EditorClassInfo | (Ereditato da BaseEdit)
Proprietà protetta | EditorContainer | (Ereditato da BaseEdit)
Proprietà pubblica | EditorContainsFocus | (Ereditato da PopupBaseEdit)
Proprietà pubblica | EditorTypeName | (Sovrascrive ComboBoxEdit.EditorTypeName)
Proprietà pubblica | EditValue | (Ereditato da ComboBoxEdit)
Proprietà protetta | EditValueDataBindingType | (Ereditato da BaseEdit)
Proprietà protetta | EditViewInfo | (Ereditato da BaseEdit)
Proprietà pubblica | EnterMoveNextControl | (Ereditato da BaseEdit)
Proprietà pubblica | ErrorIcon | (Ereditato da BaseEdit)
Proprietà pubblica | ErrorIconAlignment | (Ereditato da BaseEdit)
Proprietà pubblica | ErrorImageOptions | (Ereditato da BaseEdit)
Proprietà pubblica | ErrorText | (Ereditato da BaseEdit)
Proprietà protetta | EventSender | (Ereditato da BaseEdit)
Proprietà protetta | FindItemCompareOptions | (Ereditato da ComboBoxEdit)
Proprietà protetta | FocusOnMouseDown | (Ereditato da BaseControl)
Proprietà pubblica | Font | (Ereditato da BaseEdit)
Proprietà protetta | ForceCalcPopupFormSizeByPM2 | (Ereditato da PopupBaseEdit)
Proprietà pubblica | ForeColor | (Ereditato da BaseEdit)
Proprietà protetta | HasAccessible | (Ereditato da BaseControl)
Proprietà protetta | HasItemActions | (Ereditato da ComboBoxEdit)
Proprietà protetta | InnerControl | (Ereditato da TextEdit)
Proprietà pubblica | InplaceType | (Ereditato da BaseEdit)
Proprietà protetta | IsAcceptingEditValue | (Ereditato da BaseEdit)
Proprietà protetta | IsAllowMaskBoxPropertiesUpdate | (Ereditato da TextEdit)
Proprietà protetta | IsAllowValidate | (Ereditato da BaseEdit)
Proprietà protetta | IsClearAutoSearchOnCancelPopup | (Ereditato da PopupBaseAutoSearchEdit)
Proprietà pubblica | IsDesignMode | (Ereditato da BaseControl)
Proprietà protetta | IsDisposing | (Ereditato da BaseControl)
Proprietà pubblica | IsDrawing | (Ereditato da BaseEdit)
Proprietà pubblica | IsEditorActive | (Ereditato da TextEdit)
Proprietà protetta | IsExistsNullValuePrompt | (Ereditato da TextEdit)
Proprietà protetta | IsImmediatePopup | (Ereditato da PopupBaseAutoSearchEdit)
Proprietà protetta | IsLayoutLocked | (Ereditato da BaseEdit)
Proprietà pubblica | IsLoading | (Ereditato da BaseEdit)
Proprietà protetta | IsMaskBoxAvailable | (Ereditato da TextEdit)
Proprietà protetta | IsMaskBoxUpdate | (Ereditato da TextEdit)
Proprietà protetta | IsMatch | (Ereditato da TextEdit)
Proprietà pubblica | IsModified | (Ereditato da BaseEdit)
Proprietà pubblica | IsNeedFocus | (Ereditato da ButtonEdit)
Proprietà protetta | IsNeedHideCursorOnPopup | (Ereditato da PopupBaseEdit)
Proprietà protetta | IsNullValuePromptVisible | (Ereditato da TextEdit)
Proprietà pubblica | IsPopupOpen | (Ereditato da PopupBaseEdit)
Proprietà protetta | IsQueryCloseUpCancelled | (Ereditato da PopupBaseEdit)
Proprietà pubblica | IsRightToLeft | (Ereditato da ControlBase)
Proprietà protetta | IsUpdatingClearButtonVisibility | (Ereditato da PopupBaseEdit)
Proprietà protetta | IsVisualLayoutUpdate | (Ereditato da BaseEdit)
Proprietà protetta | IsWindowsXPStyle | (Ereditato da TextEdit)
Proprietà pubblica | LookAndFeel | (Ereditato da BaseEdit)
Proprietà pubblica | MaskBox | (Ereditato da TextEdit)
Proprietà protetta | MaskBoxInternal | (Ereditato da TextEdit)
Proprietà protetta | Menu | (Ereditato da TextEdit)
Proprietà pubblica | MenuManager | (Ereditato da BaseEdit)
Proprietà protetta | MouseHere | (Ereditato da TextEdit)
Proprietà pubblica | OldEditValue | (Ereditato da BaseEdit)
Proprietà pubblica | Padding | (Ereditato da BaseEdit)
Proprietà protetta | Painter | (Ereditato da BaseEdit)
Proprietà pubblica | PopupCloseMode | (Ereditato da PopupBaseEdit)
Proprietà protetta | PopupForm | (Ereditato da ComboBoxEdit)
Proprietà protetta | PopupShowing | (Ereditato da PopupBaseEdit)
Proprietà protetta | PreferredHeight | (Ereditato da BaseEdit)
Proprietà protetta | ProcessInplaceEditValueChangedEventCore | (Ereditato da PopupBaseEdit)
Proprietà pubblica | Properties |
Proprietà pubblica | ReadOnly | (Ereditato da BaseEdit)
Proprietà protetta | RealEditValue | (Ereditato da ComboBoxEdit)
Proprietà protetta | ScaleDPI | (Ereditato da BaseControl)
Proprietà pubblica | ScaleFactor | (Ereditato da BaseControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraControl)
Proprietà pubblica | SelectedIndex | (Ereditato da ComboBoxEdit)
Proprietà pubblica | SelectedItem | (Ereditato da ComboBoxEdit)
Proprietà pubblica | SelectedText | (Ereditato da TextEdit)
Proprietà pubblica | SelectionLength | (Ereditato da TextEdit)
Proprietà pubblica | SelectionStart | (Ereditato da TextEdit)
Proprietà pubblica | ServiceObject | (Ereditato da BaseEdit)
Proprietà protetta | ShouldDrawBackgroundOnDirectXPaint | (Ereditato da XtraControl)
Proprietà protetta | ShouldNotifyAccessibilityClients | (Ereditato da BaseControl)
Proprietà protetta | ShouldProcessMouseWheelInPopup | (Ereditato da BaseEdit)
Proprietà protetta | ShowKeyboardCuesCore | (Ereditato da BaseControl)
Proprietà pubblica | ShowToolTips | (Ereditato da BaseControl)
Proprietà protetta | ShowToolTipsCore | (Ereditato da BaseEdit)
Proprietà protetta | SizeableIsCaptionVisible | (Ereditato da BaseEdit)
Proprietà protetta | SizeableMaxSize | (Ereditato da BaseControl)
Proprietà protetta | SizeableMinSize | (Ereditato da BaseControl)
Proprietà pubblica | StyleController | (Ereditato da BaseControl)
Proprietà pubblica | SuperTip | (Ereditato da BaseControl)
Proprietà protetta | SuppressSelectAll | (Ereditato da BaseEdit)
Proprietà pubblica | TabStop | (Ereditato da TextEdit)
Proprietà pubblica | Text | (Ereditato da TextEdit)
Proprietà pubblica | ToolTip | (Ereditato da BaseControl)
Proprietà pubblica | ToolTipAnchor | (Ereditato da BaseEdit)
Proprietà pubblica | ToolTipController | (Ereditato da BaseControl)
Proprietà pubblica | ToolTipIconType | (Ereditato da BaseControl)
Proprietà pubblica | ToolTipTitle | (Ereditato da BaseControl)
Proprietà protetta | UseParentOnTransparentPaintBackground | (Ereditato da TextEdit)
Proprietà protetta | ViewInfo | (Ereditato da ButtonEdit)
Proprietà protetta | WorkingStrategy | (Ereditato da TextEdit)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | AcceptPopupValue | (Ereditato da PopupBaseEdit)
Metodo protetto | AccessibilityNotifyTextChanged | (Ereditato da TextEdit)
Metodo protetto | ActionShowPopup(EditorButtonObjectInfoArgs) | (Ereditato da PopupBaseEdit)
Metodo protetto | ActionShowPopup(Keys) | (Ereditato da PopupBaseEdit)
Metodo pubblico | AllowMouseClick | (Ereditato da PopupBaseEdit)
Metodo pubblico | AppendText | (Ereditato da TextEdit)
Metodo protetto | BaseEditWndProc | (Ereditato da TextEdit)
Metodo protetto | BaseWndProc | (Ereditato da ControlBase)
Metodo protetto | BeginAcceptEditValue | (Ereditato da BaseEdit)
Metodo protetto | BeginClosePopup | (Ereditato da PopupBaseEdit)
Metodo protetto | BeginInternalTextChange | (Ereditato da TextEdit)
Metodo protetto | BeginUpdate | (Ereditato da BaseEdit)
Metodo pubblico | CalcBestSize | (Ereditato da BaseControl)
Metodo protetto | CalcDefaultSizeableMinWidth | (Ereditato da BaseEdit)
Metodo pubblico | CalcMinHeight | (Ereditato da BaseEdit)
Metodo protetto | CalcPopupFormBounds | (Ereditato da PopupBaseEdit)
Metodo protetto | CalcPopupFormSize | (Ereditato da PopupBaseEdit)
Metodo protetto | CalcPopupFormSizeByPM2AfterCreateHandle | (Ereditato da PopupBaseEdit)
Metodo protetto | CalcPreferredHeight | (Ereditato da BaseEdit)
Metodo protetto | CalcSizeableMaxSize | (Ereditato da TextEdit)
Metodo protetto | CalcSizeableMinSize | (Ereditato da TextEdit)
Metodo pubblico | CancelPopup | (Ereditato da PopupBaseEdit)
Metodo protetto | CancelUpdate | (Ereditato da BaseEdit)
Metodo protetto | CanProcessNullInputKeys | (Ereditato da TextEdit)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da TextEdit)
Metodo protetto | CanValidateObjectViaAnnotationAttributes | (Ereditato da BaseEdit)
Metodo protetto | CanValidateValueViaAnnotationAttributes | (Ereditato da BaseEdit)
Metodo protetto | CanValidateViaAnnotationAttributesCore | (Ereditato da BaseEdit)
Metodo protetto | CheckAutoHeight | (Ereditato da BaseEdit)
Metodo protetto | CheckAutoSearchText | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | CheckAutoSearchText(Boolean) | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | CheckDoubleClick | (Ereditato da BaseEdit)
Metodo protetto | CheckEnabled | (Ereditato da BaseEdit)
Metodo protetto | CheckErrorIcon | (Ereditato da BaseEdit)
Metodo protetto | CheckHighlightPopupAutoSearchText | (Ereditato da ComboBoxEdit)
Metodo protetto | CheckIfNullString | (Ereditato da TextEdit)
Metodo protetto | CheckInplaceAutoSearchText | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | CheckMouseHere | (Ereditato da TextEdit)
Metodo protetto | CheckRightToLeft | (Ereditato da ControlBase)
Metodo pubblico | Clear | (Ereditato da TextEdit)
Metodo protetto | ClearHotPressed | (Ereditato da BaseEdit)
Metodo protetto | ClearHotPressed(EditHitInfo) | (Ereditato da BaseEdit)
Metodo protetto | ClearHotPressedCore | (Ereditato da BaseEdit)
Metodo protetto | ClearHotPressedOnLostFocus | (Ereditato da ButtonEdit)
Metodo protetto | ClearPreferredHeight | (Ereditato da BaseEdit)
Metodo pubblico | CloseAutoCompletePopup | (Ereditato da TextEdit)
Metodo pubblico | ClosePopup | (Ereditato da PopupBaseEdit)
Metodo protetto | ClosePopup(PopupCloseMode) | (Ereditato da PopupBaseEdit)
Metodo protetto | CompareEditValue | (Ereditato da BaseEdit)
Metodo protetto | CompareEditValueOnChange | (Ereditato da BaseEdit)
Metodo protetto | CompareFonts | (Ereditato da TextEdit)
Metodo protetto | CompleteChanges | (Ereditato da BaseEdit)
Metodo protetto | ConstrainFormBounds | (Ereditato da PopupBaseEdit)
Metodo protetto | ControlOnGotFocus | (Ereditato da BaseEdit)
Metodo protetto | ControlOnLostFocus | (Ereditato da BaseEdit)
Metodo pubblico | Copy | (Ereditato da TextEdit)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da BaseControl)
Metodo protetto | CreateAccessibleInstance | (Ereditato da BaseEdit)
Metodo protetto | CreateAdvancedStrategy | (Ereditato da TextEdit)
Metodo protetto | CreateCache | (Ereditato da BaseControl)
Metodo protetto | CreateDirectXProvider | (Ereditato da XtraControl)
Metodo protetto | CreateEditController | (Ereditato da ComboBoxEdit)
Metodo protetto | CreateEditControllerInstance | (Ereditato da ComboBoxEdit)
Metodo protetto | CreateEventSender | (Ereditato da BaseEdit)
Metodo protetto | CreateHandle | (Ereditato da PopupBaseEdit)
Metodo protetto | CreateItemActions | (Ereditato da ComboBoxEdit)
Metodo protetto | CreateLookAndFeel | (Ereditato da BaseEdit)
Metodo protetto | CreateMaskBox | (Ereditato da ComboBoxEdit)
Metodo protetto | CreateMaskBoxInstance | (Ereditato da TextEdit)
Metodo protetto | CreateMaskManager | (Ereditato da TextEdit)
Metodo protetto | CreateMenu | (Ereditato da TextEdit)
Metodo protetto | CreatePopupForm | (Sovrascrive ComboBoxEdit.CreatePopupForm)
Metodo protetto | CreateRepositoryItem | (Ereditato da BaseEdit)
Metodo protetto | CreateRepositoryItemCore | (Ereditato da BaseEdit)
Metodo pubblico | Cut | (Ereditato da TextEdit)
Metodo protetto | DescaleInteger | (Ereditato da BaseControl)
Metodo pubblico | DeselectAll | (Ereditato da TextEdit)
Metodo protetto | DestroyHandleCore | (Ereditato da BaseEdit)
Metodo protetto | DestroyMaskBox | (Ereditato da TextEdit)
Metodo protetto | DestroyPopupForm | (Ereditato da PopupBaseEdit)
Metodo protetto | DestroyPopupFormCore | (Ereditato da PopupBaseEdit)
Metodo protetto | Dispose | (Ereditato da PopupBaseEdit)
Metodo protetto | DoBaseSetBoundsCore | (Ereditato da BaseEdit)
Metodo protetto | DoClosePopup | (Ereditato da PopupBaseEdit)
Metodo protetto | DoDpiChange | (Ereditato da PopupBaseEdit)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraControl)
Metodo protetto | DoImmediatePopup | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | DoIsMatchValidating | (Ereditato da TextEdit)
Metodo protetto | DoNullInputKeysCore | (Ereditato da PopupBaseEdit)
Metodo protetto | DoShowPopup | (Ereditato da PopupBaseEdit)
Metodo protetto | DoSpin | (Ereditato da TextEdit)
Metodo protetto | DoSynchronizePopupFormControls | (Ereditato da PopupBaseEdit)
Metodo pubblico | DoValidate | (Ereditato da BaseEdit)
Metodo pubblico | DoValidate(PopupCloseMode) | (Ereditato da BaseEdit)
Metodo protetto | DoValidateOnEnterKey | (Ereditato da BaseEdit)
Metodo protetto | EndAcceptEditValue | (Ereditato da BaseEdit)
Metodo protetto | EndClosePopup | (Ereditato da PopupBaseEdit)
Metodo protetto | EndInternalTextChange | (Ereditato da TextEdit)
Metodo protetto | EndUpdate | (Ereditato da BaseEdit)
Metodo protetto | EnsureAnnotationAttributes | (Ereditato da BaseEdit)
Metodo pubblico | EnsureInnerEditorFocused | (Ereditato da TextEdit)
Metodo protetto | ExecInnerEditMouseDown | (Ereditato da ButtonEdit)
Metodo protetto | ExtractParsedValue | (Ereditato da BaseEdit)
Metodo protetto | FindCurrentText | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | FindItem(String, Int32) | (Sovrascrive ComboBoxEdit.FindItem(String, Int32))
Metodo protetto | FindItem(String, Boolean, Int32) | (Ereditato da ComboBoxEdit)
Metodo protetto | FindUpdateEditValue | (Ereditato da ComboBoxEdit)
Metodo protetto | FindUpdateEditValueAutoSearchText | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | FindUpdatePopupSelectedItem | (Ereditato da ComboBoxEdit)
Metodo protetto | FireChanged | (Ereditato da BaseControl)
Metodo protetto | FireSpinRequest | (Ereditato da ComboBoxEdit)
Metodo protetto | FlushPendingEditActions | (Ereditato da TextEdit)
Metodo pubblico | ForceClosePopup | (Ereditato da PopupBaseEdit)
Metodo protetto | GetAccessibilityObjectById | (Ereditato da ComboBoxEdit)
Metodo pubblico | GetAccessible | (Ereditato da BaseControl)
Metodo protetto | GetAccessibleToNotify | (Ereditato da TextEdit)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da BaseControl)
Metodo protetto | GetActualText | (Ereditato da ComboBoxEdit)
Metodo protetto | GetAutoSearchCharKeyPressHelper | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | GetAutoSearchCharKeyPressHelperCore | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | GetAutoSearchTextFilter | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | GetChangingOldEditValue | (Ereditato da BaseEdit)
Metodo pubblico | GetCharFromPosition | (Ereditato da TextEdit)
Metodo pubblico | GetCharIndexFromPosition | (Ereditato da TextEdit)
Metodo protetto | GetColor(Color, Color) | (Ereditato da BaseControl)
Metodo protetto | GetColor(Color, Color, Boolean) | (Ereditato da BaseControl)
Metodo protetto | GetDeviceSize | (Ereditato da XtraControl)
Metodo protetto | GetDropDownEditorBorderWeight | (Ereditato da PopupBaseEdit)
Metodo protetto | GetDropDownOrigin | (Ereditato da PopupBaseEdit)
Metodo protetto | GetDropDownPadding | (Ereditato da PopupBaseEdit)
Metodo pubblico | GetFirstCharIndexFromLine | (Ereditato da TextEdit)
Metodo pubblico | GetFirstCharIndexOfCurrentLine | (Ereditato da TextEdit)
Metodo protetto | GetItemDescription | (Ereditato da ComboBoxEdit)
Metodo pubblico | GetLineFromCharIndex | (Ereditato da TextEdit)
Metodo protetto | GetNewScrollIndex | (Ereditato da ComboBoxEdit)
Metodo protetto | GetNullInputKeysValue | (Ereditato da TextEdit)
Metodo protetto | GetObjectToValidate | (Ereditato da BaseEdit)
Metodo pubblico | GetPopupEditForm | (Ereditato da ComboBoxEdit)
Metodo protetto | GetPopupForm | (Ereditato da PopupBaseEdit)
Metodo protetto | GetPopupFormCore | (Ereditato da PopupBaseEdit)
Metodo pubblico | GetPositionFromCharIndex | (Ereditato da TextEdit)
Metodo pubblico | GetPreferredSize | (Ereditato da BaseEdit)
Metodo protetto | GetScaledBounds | (Ereditato da BaseEdit)
Metodo protetto | GetScaleDpiCore | (Ereditato da BaseControl)
Metodo protetto | GetSkinnedCellPadding | (Ereditato da PopupBaseEdit)
Metodo protetto | GetSkinnedEditorBorderWeight | (Ereditato da PopupBaseEdit)
Metodo protetto | GetTextEditController | (Ereditato da TextEdit)
Metodo protetto | GetToolTipAnchor | (Ereditato da BaseControl)
Metodo protetto | GetToolTipInfo | (Ereditato da BaseEdit)
Metodo protetto | GetUseDirectXPaint | (Ereditato da XtraControl)
Metodo protetto | GetValidationCanceled | (Ereditato da BaseEdit)
Metodo pubblico | GetViewInfo | (Ereditato da BaseControl)
Metodo protetto | HideCaret | (Ereditato da TextEdit)
Metodo protetto | InitializeDefault | (Ereditato da BaseEdit)
Metodo protetto | InitializeDefaultProperties | (Ereditato da ComboBoxEdit)
Metodo pubblico | InnerEditorPaste | (Ereditato da TextEdit)
Metodo pubblico | InnerEditorSpin | (Ereditato da TextEdit)
Metodo protetto | InvalidateFormBoundsByPM2BeforeShow | (Ereditato da PopupBaseEdit)
Metodo protetto | IsAcceptCloseMode | (Ereditato da PopupBaseEdit)
Metodo protetto | IsActionButton | (Ereditato da PopupBaseEdit)
Metodo protetto | IsAutoSearchCharHandled | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | IsBindingDataAccessible | (Ereditato da BaseEdit)
Metodo protetto | IsBindingManagerPositionValid | (Ereditato da BaseEdit)
Metodo protetto | IsClearButton | (Ereditato da PopupBaseEdit)
Metodo protetto | IsClearButtonVisible | (Ereditato da PopupBaseEdit)
Metodo pubblico | IsInnerEditorReadOnly | (Ereditato da TextEdit)
Metodo protetto | IsInputChar | (Ereditato da TextEdit)
Metodo protetto | IsInputKey | (Ereditato da TextEdit)
Metodo protetto | IsInputKeyCore | (Ereditato da BaseEdit)
Metodo protetto | IsItemVisible | (Ereditato da ComboBoxEdit)
Metodo pubblico | IsNeededCursorKey | (Ereditato da TextEdit)
Metodo protetto | IsNeededExtraKey | (Ereditato da TextEdit)
Metodo pubblico | IsNeededKey | (Ereditato da PopupBaseEdit)
Metodo protetto | IsNullValue | (Ereditato da BaseEdit)
Metodo protetto | IsShowNullValuePrompt | (Ereditato da TextEdit)
Metodo protetto | IsTextCommand | (Ereditato da TextEdit)
Metodo protetto | KeepPopupFormSize | (Ereditato da PopupBaseEdit)
Metodo protetto | LayoutChanged | (Ereditato da TextEdit)
Metodo protetto | LayoutChanged(Boolean) | (Ereditato da TextEdit)
Metodo protetto | LayoutChangedCore | (Ereditato da TextEdit)
Metodo protetto | LayoutChangedCore(Boolean) | (Ereditato da BaseControl)
Metodo protetto | LockEditValueChanged | (Ereditato da BaseEdit)
Metodo protetto | LockMaskBoxPropertiesUpdate | (Ereditato da TextEdit)
Metodo protetto | MaskBoxGetEditValue | (Ereditato da TextEdit)
Metodo protetto | NeedLayoutUpdateValidating | (Ereditato da TextEdit)
Metodo protetto | NotifyAccessibilityClients(AccessibleEvents, Int32, Int32) | (Ereditato da BaseControl)
Metodo protetto | NotifyAccessibilityClients(AccessibleEvents, AutomationElementProvider, Int32, Int32) | (Ereditato da BaseControl)
Metodo protetto | NotifyButtonStateChanged | (Ereditato da ButtonEdit)
Metodo protetto | OnActionItemClick | (Ereditato da ComboBoxEdit)
Metodo protetto | OnAfterUpdateViewInfo | (Ereditato da TextEdit)
Metodo protetto | OnAppearancePaintChanged | (Ereditato da TextEdit)
Metodo protetto | OnAutoHeightChanged | (Ereditato da BaseEdit)
Metodo protetto | OnBeforeUpdateViewInfo | (Ereditato da TextEdit)
Metodo protetto | OnBorderStyleChanged | (Ereditato da BaseControl)
Metodo protetto | OnCancelEditValueChanging | (Ereditato da BaseEdit)
Metodo protetto | OnClickButton | (Ereditato da PopupBaseEdit)
Metodo protetto | OnClickButtonCore | (Ereditato da ButtonEdit)
Metodo protetto | OnClientSizeChanged | (Ereditato da TextEdit)
Metodo protetto | OnContextMenuChanged | (Ereditato da BaseEdit)
Metodo protetto | OnContextMenuStripChanged | (Ereditato da BaseEdit)
Metodo protetto | OnControllerValueChanged | (Ereditato da TextEdit)
Metodo protetto | OnControllerValueChanging | (Ereditato da TextEdit)
Metodo protetto | OnCreateControl | (Ereditato da TextEdit)
Metodo protetto | OnDefaultPressButton | (Ereditato da PopupBaseEdit)
Metodo protetto | OnDirectXPaintDisabled | (Ereditato da XtraControl)
Metodo protetto | OnDirectXPaintEnabled | (Ereditato da XtraControl)
Metodo protetto | OnEditorEnter | (Ereditato da TextEdit)
Metodo protetto | OnEditorKeyDown | (Ereditato da ComboBoxEdit)
Metodo protetto | OnEditorKeyDownProcessNullInputKeys | (Ereditato da TextEdit)
Metodo protetto | OnEditorKeyPress | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | OnEditorKeyUp | (Ereditato da PopupBaseEdit)
Metodo protetto | OnEditorLeave | (Ereditato da TextEdit)
Metodo protetto | OnEditValueChanged | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | OnEditValueChanging | (Ereditato da TextEdit)
Metodo protetto | OnEnabledChanged | (Ereditato da TextEdit)
Metodo protetto | OnEnableNonMaskedInput | (Ereditato da TextEdit)
Metodo protetto | OnEndIme | (Ereditato da PopupBaseEdit)
Metodo protetto | OnEnter | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | OnErrorInfoChanged | (Ereditato da BaseEdit)
Metodo protetto | OnErrorTextChanged | (Ereditato da TextEdit)
Metodo protetto | OnGlassMaskBoxPreWndProc | (Ereditato da TextEdit)
Metodo protetto | OnGlassMaskBoxWndProc | (Ereditato da TextEdit)
Metodo protetto | OnGotCapture | (Ereditato da ControlBase)
Metodo protetto | OnGotFocus | (Ereditato da PopupBaseEdit)
Metodo protetto | OnHandleCreated | (Ereditato da TextEdit)
Metodo protetto | OnHandleDestroyed | (Ereditato da TextEdit)
Metodo protetto | OnImeModeChanged | (Ereditato da TextEdit)
Metodo protetto | OnInvalidValue | (Ereditato da BaseEdit)
Metodo protetto | OnKeyDown | (Ereditato da TextEdit)
Metodo protetto | OnKeyPress | (Ereditato da TextEdit)
Metodo protetto | OnKeyUp | (Ereditato da TextEdit)
Metodo protetto | OnLeave | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | OnLoaded | (Ereditato da PopupBaseEdit)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da TextEdit)
Metodo protetto | OnLostCapture | (Ereditato da ControlBase)
Metodo protetto | OnLostFocus | (Ereditato da PopupBaseEdit)
Metodo protetto | OnMaskBox_Click | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_DoubleClick | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_GotFocus | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_KeyDown | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_KeyPress | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_KeyUp | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_LostFocus | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_MouseDown | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_MouseEnter | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_MouseLeave | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_MouseMove | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_MouseUp | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_MouseWheel | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_TextValidated | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_ValueChanged | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_ValueChanging | (Ereditato da TextEdit)
Metodo protetto | OnMaskBoxMouseSelection | (Ereditato da TextEdit)
Metodo protetto | OnMaskBoxPreWndProc | (Ereditato da TextEdit)
Metodo protetto | OnMaskBoxTextResetToNullValuePromptOrNullText | (Ereditato da TextEdit)
Metodo protetto | OnMaskBoxWndProc | (Ereditato da TextEdit)
Metodo protetto | OnMaskEditValueChanging | (Ereditato da TextEdit)
Metodo protetto | OnMouseDown | (Ereditato da ComboBoxEdit)
Metodo protetto | OnMouseDownClosePopup | (Ereditato da PopupBaseEdit)
Metodo protetto | OnMouseEnter | (Ereditato da TextEdit)
Metodo protetto | OnMouseLeave | (Ereditato da TextEdit)
Metodo protetto | OnMouseMove | (Ereditato da TextEdit)
Metodo protetto | OnMouseUp | (Ereditato da ButtonEdit)
Metodo protetto | OnMouseWheel | (Ereditato da ComboBoxEdit)
Metodo protetto | OnMove | (Ereditato da PopupBaseEdit)
Metodo protetto | OnPaddingChanged | (Ereditato da BaseControl)
Metodo protetto | OnPaint | (Ereditato da TextEdit)
Metodo protetto | OnPaintBackground | (Ereditato da TextEdit)
Metodo protetto | OnParentChanged | (Ereditato da ControlBase)
Metodo protetto | OnParentVisibleChanged | (Ereditato da PopupBaseEdit)
Metodo protetto | OnPopupClosed | (Ereditato da ComboBoxEdit)
Metodo protetto | OnPopupClosing | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | OnPopupFormValueChanged | (Ereditato da ComboBoxEdit)
Metodo protetto | OnPopupSelectedIndexChanged | (Ereditato da ComboBoxEdit)
Metodo protetto | OnPopupShown | (Ereditato da PopupBaseEdit)
Metodo protetto | OnPressButton | (Ereditato da PopupBaseEdit)
Metodo protetto | OnPreviewKeyDown | (Ereditato da TextEdit)
Metodo protetto | OnProperties_PropertiesChanged | (Ereditato da BaseEdit)
Metodo protetto | OnPropertiesChanged | (Ereditato da PopupBaseEdit)
Metodo protetto | OnPropertiesChanged_SyncPopup | (Ereditato da PopupBaseEdit)
Metodo protetto | OnResize | (Ereditato da TextEdit)
Metodo protetto | OnRightToLeftChanged | (Ereditato da PopupBaseEdit)
Metodo protetto | OnRightToLeftChanged(EventArgs) | (Ereditato da ControlBase)
Metodo protetto | OnScaleControl | (Ereditato da BaseEdit)
Metodo protetto | OnScaleDpiChanged | (Ereditato da ControlBase)
Metodo protetto | OnSizeChanged | (Ereditato da TextEdit)
Metodo protetto | OnSpin | (Ereditato da TextEdit)
Metodo protetto | OnStyleController_Disposed | (Ereditato da BaseControl)
Metodo protetto | OnStyleController_PropertiesChanged | (Ereditato da BaseControl)
Metodo protetto | OnStyleControllerChanged | (Ereditato da TextEdit)
Metodo protetto | OnTabStopChanged | (Ereditato da TextEdit)
Metodo protetto | OnTextChanged | (Ereditato da TextEdit)
Metodo protetto | OnTextEditPropertiesChanged | (Ereditato da TextEdit)
Metodo protetto | OnValidated | (Ereditato da TextEdit)
Metodo protetto | OnValidating | (Ereditato da TextEdit)
Metodo protetto | OnValidatingCore | (Ereditato da BaseEdit)
Metodo protetto | OnVisibleChanged | (Ereditato da PopupBaseEdit)
Metodo protetto | PaintErrorIconBackground | (Ereditato da TextEdit)
Metodo protetto | ParseEditorValue | (Ereditato da BaseEdit)
Metodo pubblico | Paste | (Ereditato da TextEdit)
Metodo protetto | PendingEditActionPerformed | (Ereditato da TextEdit)
Metodo pubblico | PerformClick | (Ereditato da ButtonEdit)
Metodo protetto | PerformDefaultClearButtonAction | (Ereditato da PopupBaseEdit)
Metodo protetto | ProcessAutoSearchChar | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | ProcessAutoSearchNavKey | (Ereditato da ComboBoxEdit)
Metodo protetto | ProcessChar | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | ProcessCmdKey | (Ereditato da TextEdit)
Metodo protetto | ProcessDialogKey | (Ereditato da PopupBaseEdit)
Metodo protetto | ProcessDialogKeyCore | (Ereditato da TextEdit)
Metodo protetto | ProcessFindItem | (Sovrascrive PopupBaseAutoSearchEdit.ProcessFindItem(KeyPressHelper, Char))
Metodo protetto | ProcessPaintAction | (Ereditato da XtraControl)
Metodo protetto | ProcessPopupMouseWheel | (Ereditato da BaseEdit)
Metodo protetto | ProcessPopupTabKey | (Ereditato da PopupBaseEdit)
Metodo protetto | ProcessRemoveWord | (Ereditato da TextEdit)
Metodo protetto | QueryEditorModeFromSkin | (Ereditato da TextEdit)
Metodo protetto | QueryMaskEditValue | (Ereditato da TextEdit)
Metodo protetto | RaiseDropDownCustomDrawItem | (Ereditato da ComboBoxEdit)
Metodo protetto | RaiseEditValueChanged | (Ereditato da BaseEdit)
Metodo protetto | RaiseInvalidValue | (Ereditato da BaseEdit)
Metodo protetto | RaiseModified | (Ereditato da BaseEdit)
Metodo protetto | RaisePaintEvent | (Ereditato da TextEdit)
Metodo protetto | RaisePaintExEvent(TextEditPaintExEventArgs) | (Ereditato da TextEdit)
Metodo protetto | RaisePaintExEvent(GraphicsCache, PaintEventArgs) | (Ereditato da XtraControl)
Metodo protetto | RaisePopupAllowClick | (Ereditato da PopupBaseEdit)
Metodo protetto | RaiseQueryAdvancedMode | (Ereditato da TextEdit)
Metodo protetto | RaiseQueryCompletion | (Ereditato da TextEdit)
Metodo protetto | RaiseSizeableChanged | (Ereditato da BaseControl)
Metodo pubblico | Refresh | (Ereditato da BaseControl)
Metodo pubblico | RefreshEditValue | (Ereditato da PopupBaseEdit)
Metodo protetto | RefreshEnabledState | (Ereditato da TextEdit)
Metodo protetto | RefreshPopup | (Ereditato da ComboBoxEdit)
Metodo protetto | RefreshVisualLayout | (Ereditato da BaseEdit)
Metodo protetto | RefreshVisualLayoutCore | (Ereditato da BaseEdit)
Metodo protetto | RejectPopupValue | (Ereditato da PopupBaseEdit)
Metodo protetto | ReleaseDirectXResources | (Ereditato da XtraControl)
Metodo protetto | ReleaseStyleController | (Ereditato da BaseControl)
Metodo protetto | RemoveXtraAnimator | (Ereditato da BaseControl)
Metodo pubblico | Reset | (Ereditato da ComboBoxEdit)
Metodo protetto | ResetAccessible | (Ereditato da BaseControl)
Metodo pubblico | ResetBackColor | (Ereditato da BaseEdit)
Metodo protetto | ResetEvents | (Ereditato da BaseEdit)
Metodo pubblico | ResetForeColor | (Ereditato da BaseEdit)
Metodo pubblico | ResetSelection | (Ereditato da TextEdit)
Metodo pubblico | ResetSuperTip | (Ereditato da BaseControl)
Metodo protetto | ScaleControl | (Ereditato da ControlBase)
Metodo protetto | ScaleFont | (Ereditato da TextEdit)
Metodo protetto | ScaleInteger | (Ereditato da BaseControl)
Metodo protetto | ScaleSize | (Ereditato da BaseControl)
Metodo protetto | ScrollIndex | (Ereditato da ComboBoxEdit)
Metodo pubblico | ScrollToCaret | (Ereditato da TextEdit)
Metodo protetto | ScrollValue | (Ereditato da ComboBoxEdit)
Metodo protetto | Select(Boolean, Boolean) | (Ereditato da TextEdit)
Metodo pubblico | Select(Int32, Int32) | (Ereditato da TextEdit)
Metodo pubblico | SelectAll | (Ereditato da TextEdit)
Metodo pubblico | SendKey(KeyEventArgs) | (Ereditato da BaseEdit)
Metodo pubblico | SendKey(Object, KeyPressEventArgs) | (Ereditato da BaseEdit)
Metodo pubblico | SendKeyUp | (Ereditato da BaseEdit)
Metodo pubblico | SendMouse(MouseEventArgs) | (Ereditato da BaseEdit)
Metodo pubblico | SendMouse(Point, MouseButtons) | (Ereditato da BaseEdit)
Metodo protetto | SendMouseUp(MouseEventArgs) | (Ereditato da BaseEdit)
Metodo pubblico | SendMouseUp(Point, MouseButtons) | (Ereditato da BaseEdit)
Metodo protetto | SetBackColor | (Ereditato da BaseControl)
Metodo protetto | SetBoundsCore | (Ereditato da BaseEdit)
Metodo protetto | SetEmptyEditValue | (Ereditato da PopupBaseEdit)
Metodo protetto | SetErrorIcon | (Ereditato da BaseEdit)
Metodo protetto | SetPopupEditValueOnClose | (Ereditato da PopupBaseEdit)
Metodo protetto | SetTextCore | (Ereditato da TextEdit)
Metodo protetto | SetVisibleCore | (Ereditato da ControlBase)
Metodo protetto | ShouldSuppressFormDeactivation | (Ereditato da TextEdit)
Metodo protetto | ShouldSuppressTextCommand | (Ereditato da TextEdit)
Metodo pubblico | ShowAutoCompletePopup | (Ereditato da TextEdit)
Metodo protetto | ShowCaret | (Ereditato da TextEdit)
Metodo protetto | ShowMenu | (Ereditato da TextEdit)
Metodo protetto | ShowMenuCore | (Ereditato da TextEdit)
Metodo pubblico | ShowPopup | (Ereditato da PopupBaseEdit)
Metodo protetto | SilentRemove | (Ereditato da ComboBoxEdit)
Metodo protetto | SilentRemoveCore | (Ereditato da ComboBoxEdit)
Metodo protetto | SubscribePopupFormEvents | (Ereditato da PopupBaseEdit)
Metodo protetto | SuppressMouseWheel | (Ereditato da PopupBaseEdit)
Metodo protetto | SwitchModeAccordingToSkinSettings | (Ereditato da TextEdit)
Metodo protetto | SwitchPopupState | (Ereditato da PopupBaseEdit)
Metodo protetto | TryNotifyAccessibilitySelectedIndexChanged | (Ereditato da ComboBoxEdit)
Metodo pubblico | Undo | (Ereditato da TextEdit)
Metodo protetto | UnLockEditValueChanged | (Ereditato da BaseEdit)
Metodo protetto | UnlockMaskBoxPropertiesUpdate | (Ereditato da TextEdit)
Metodo protetto | UpdateClearButtonVisibility | (Ereditato da PopupBaseEdit)
Metodo protetto | UpdateClearButtonVisibilityCore | (Ereditato da PopupBaseEdit)
Metodo protetto | UpdateDisplayText | (Ereditato da TextEdit)
Metodo protetto | UpdateEditControllerProperties | (Ereditato da TextEdit)
Metodo protetto | UpdateEditValueOnClose | (Ereditato da ComboBoxEdit)
Metodo protetto | UpdateFixedHeight | (Ereditato da BaseEdit)
Metodo protetto | UpdateHideSelection | (Ereditato da TextEdit)
Metodo protetto | UpdateInactiveInnerEditorProperties | (Ereditato da TextEdit)
Metodo protetto | UpdateMaskBox | (Ereditato da TextEdit)
Metodo protetto | UpdateMaskBox(Boolean) | (Ereditato da TextEdit)
Metodo protetto | UpdateMaskBoxBounds | (Ereditato da TextEdit)
Metodo protetto | UpdateMaskBoxDisplayText | (Ereditato da TextEdit)
Metodo protetto | UpdateMaskBoxFontByScaleDpi | (Ereditato da TextEdit)
Metodo protetto | UpdateMaskBoxProperties | (Ereditato da TextEdit)
Metodo protetto | UpdateMaskBoxPropertiesCore | (Ereditato da TextEdit)
Metodo protetto | UpdateMenu | (Ereditato da TextEdit)
Metodo protetto | UpdateMenuCoords | (Ereditato da TextEdit)
Metodo protetto | UpdatePasswordChar | (Ereditato da TextEdit)
Metodo protetto | UpdatePopupEditValueIndex | (Ereditato da ComboBoxEdit)
Metodo protetto | UpdateScaleDpi | (Ereditato da XtraControl)
Metodo protetto | UpdateScaleFactorForScaleHelper | (Ereditato da XtraControl)
Metodo pubblico | UpdateTextHighlight | (Ereditato da TextEdit)
Metodo protetto | UpdateViewInfo | (Ereditato da BaseControl)
Metodo protetto | UpdateViewInfoEditValue | (Ereditato da BaseEdit)
Metodo protetto | UpdateViewInfoState | (Ereditato da BaseControl)
Metodo protetto | UpdateViewInfoState(Boolean) | (Ereditato da BaseControl)
Metodo protetto | UpdateViewInfoState(Boolean, Point) | (Ereditato da BaseControl)
Metodo protetto | WndProc | (Ereditato da PopupBaseEdit)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | BackColorChanged | (Ereditato da BaseEdit)
Evento pubblico | BeforePopup | (Ereditato da PopupBaseEdit)
Evento pubblico | ButtonClick | (Ereditato da ButtonEdit)
Evento pubblico | ButtonPressed | (Ereditato da ButtonEdit)
Evento pubblico | Closed | (Ereditato da PopupBaseEdit)
Evento pubblico | CloseUp | (Ereditato da PopupBaseEdit)
Evento pubblico | CustomDisplayText | (Ereditato da BaseEdit)
Evento pubblico | CustomHighlightText | (Ereditato da TextEdit)
Evento pubblico | CustomizeAutoCompleteSource | (Ereditato da TextEdit)
Evento pubblico | CustomTextLineHeight | (Ereditato da TextEdit)
Evento pubblico | DrawItem | (Ereditato da ComboBoxEdit)
Evento pubblico | DropDownCustomDrawItem | Obsoleto. (Ereditato da ComboBoxEdit)
Evento pubblico | EditValueChanged | (Ereditato da BaseEdit)
Evento pubblico | EditValueChanging | (Ereditato da BaseEdit)
Evento pubblico | FontChanged | (Ereditato da BaseEdit)
Evento pubblico | ForeColorChanged | (Ereditato da BaseEdit)
Evento pubblico | FormatEditValue | (Ereditato da BaseEdit)
Evento pubblico | InvalidValue | (Ereditato da BaseEdit)
Evento pubblico | Modified | (Ereditato da BaseEdit)
Evento pubblico | PaintEx | (Ereditato da TextEdit)
Evento pubblico | ParseEditValue | (Ereditato da BaseEdit)
Evento pubblico | Popup | (Ereditato da PopupBaseEdit)
Evento pubblico | PopupAllowClick | (Ereditato da PopupBaseEdit)
Evento pubblico | PropertiesChanged | (Ereditato da BaseEdit)
Evento pubblico | QueryAccessibilityHelp | (Ereditato da BaseEdit)
Evento pubblico | QueryCloseUp | (Ereditato da PopupBaseEdit)
Evento pubblico | QueryPopUp | (Ereditato da PopupBaseEdit)
Evento pubblico | QueryProcessKey | (Ereditato da BaseEdit)
Evento pubblico | SelectedIndexChanged | (Ereditato da ComboBoxEdit)
Evento pubblico | SelectedValueChanged | (Ereditato da ComboBoxEdit)
Evento pubblico | Spin | (Ereditato da TextEdit)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | fDisposing | (Ereditato da BaseControl)
Campo protetto | fEditValue | (Ereditato da BaseEdit)
Campo protetto | fOldEditValue | (Ereditato da BaseEdit)
Campo protetto | fProperties | (Ereditato da BaseEdit)
Campo protetto | fShowToolTips | (Ereditato da BaseControl)
Campo protetto | lastChangedEditValue | (Ereditato da BaseEdit)
Campo protetto | shouldRaiseSizeableChanged | (Ereditato da BaseControl)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore DedComboBox

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedComboBox()
Public Sub New
public:
DedComboBox()
new : unit -> DedComboBox
Vedi anche

Documentazione

Classe DedComboBox
Namespace DedNet.Controls


Proprietà di DedComboBox

Il tipo DedComboBox espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà protetta | AcceptsReturn | (Ereditato da TextEdit)
Proprietà protetta | AcceptsSpace | (Ereditato da TextEdit)
Proprietà protetta | AcceptsTab | (Ereditato da TextEdit)
Proprietà pubblica | AccessibleDefaultActionDescription | (Ereditato da BaseEdit)
Proprietà pubblica | AccessibleDescription | (Ereditato da BaseEdit)
Proprietà pubblica | AccessibleName | (Ereditato da BaseEdit)
Proprietà pubblica | AccessibleRole | (Ereditato da BaseEdit)
Proprietà protetta | AdvancedMode | (Ereditato da TextEdit)
Proprietà protetta | AllowAutoSearchSelectionLength | (Ereditato da ComboBoxEdit)
Proprietà protetta | AllowButtonPress | (Ereditato da ButtonEdit)
Proprietà protetta | AllowCloseByEscape | (Ereditato da PopupBaseEdit)
Proprietà protetta | AllowDefaultClearButtonAction | (Ereditato da PopupBaseEdit)
Proprietà protetta | AllowEmptyStringToNullValue | (Ereditato da PopupBaseAutoSearchEdit)
Proprietà protetta | AllowFireEditValueChanged | (Ereditato da BaseEdit)
Proprietà protetta | AllowHideClearButtonWhenNotFocused | (Ereditato da PopupBaseEdit)
Proprietà pubblica | AllowHtmlTextInToolTip | (Ereditato da BaseControl)
Proprietà protetta | AllowImmediateClose | (Ereditato da PopupBaseEdit)
Proprietà protetta | AllowPaintBackground | (Ereditato da TextEdit)
Proprietà protetta | AllowPopupTabOut | (Ereditato da PopupBaseEdit)
Proprietà protetta | AllowProcessPaint | (Ereditato da BaseControl)
Proprietà protetta | AllowSelectAllOnPopupClose | (Ereditato da ComboBoxEdit)
Proprietà protetta | AllowSelectOnPopupSelectedIndexChanged | (Ereditato da ComboBoxEdit)
Proprietà protetta | AllowSmartMouseWheel | (Ereditato da PopupBaseEdit)
Proprietà protetta | AllowTransparency | (Ereditato da TextEdit)
Proprietà protetta | AllowUpdateIsModifiedOnValueChanging | (Ereditato da ComboBoxEdit)
Proprietà protetta | AllowValidateOnEnterKey | (Ereditato da TextEdit)
Proprietà protetta | AltBounds | (Ereditato da PopupBaseEdit)
Proprietà protetta | AutoHideClearButtonWhenNotFocused | (Ereditato da PopupBaseEdit)
Proprietà pubblica | AutoSearchText | (Ereditato da PopupBaseAutoSearchEdit)
Proprietà pubblica | AutoSizeInLayoutControl | (Ereditato da BaseControl)
Proprietà pubblica | BackColor | (Ereditato da TextEdit)
Proprietà pubblica | BackgroundImage | (Ereditato da TextEdit)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da TextEdit)
Proprietà protetta | BaseBorderStyle | (Ereditato da BaseControl)
Proprietà pubblica | BindingManager | (Ereditato da BaseEdit)
Proprietà pubblica | BorderStyle | (Ereditato da BaseEdit)
Proprietà protetta | CanAnimateCore | (Ereditato da BaseControl)
Proprietà protetta | CanProcessAutoSearchText | (Ereditato da PopupBaseAutoSearchEdit)
Proprietà pubblica | CanShowDialog | (Ereditato da BaseEdit)
Proprietà protetta | CanShowPopup | (Ereditato da ComboBoxEdit)
Proprietà protetta | CanTabStop | (Ereditato da TextEdit)
Proprietà pubblica | CanUndo | (Ereditato da TextEdit)
Proprietà pubblica | ContextMenu | (Ereditato da BaseEdit)
Proprietà pubblica | ContextMenuStrip | (Ereditato da BaseEdit)
Proprietà protetta | CreateParams | (Ereditato da TextEdit)
Proprietà pubblica | Cursor | (Ereditato da ControlBase)
Proprietà protetta | DefaultCursor | (Ereditato da TextEdit)
Proprietà protetta | DefaultSize | (Ereditato da TextEdit)
Proprietà protetta | DefaultUseCtrlScroll | (Ereditato da ComboBoxEdit)
Proprietà protetta | DelayedAddContainerControl | (Ereditato da PopupBaseEdit)
Proprietà protetta | DirectXProvider | (Ereditato da XtraControl)
Proprietà protetta | DirectXScroller | (Ereditato da XtraControl)
Proprietà protetta | DXAccessible | (Ereditato da TextEdit)
Proprietà protetta | EditorClassInfo | (Ereditato da BaseEdit)
Proprietà protetta | EditorContainer | (Ereditato da BaseEdit)
Proprietà pubblica | EditorContainsFocus | (Ereditato da PopupBaseEdit)
Proprietà pubblica | EditorTypeName | (Sovrascrive ComboBoxEdit.EditorTypeName)
Proprietà pubblica | EditValue | (Ereditato da ComboBoxEdit)
Proprietà protetta | EditValueDataBindingType | (Ereditato da BaseEdit)
Proprietà protetta | EditViewInfo | (Ereditato da BaseEdit)
Proprietà pubblica | EnterMoveNextControl | (Ereditato da BaseEdit)
Proprietà pubblica | ErrorIcon | (Ereditato da BaseEdit)
Proprietà pubblica | ErrorIconAlignment | (Ereditato da BaseEdit)
Proprietà pubblica | ErrorImageOptions | (Ereditato da BaseEdit)
Proprietà pubblica | ErrorText | (Ereditato da BaseEdit)
Proprietà protetta | EventSender | (Ereditato da BaseEdit)
Proprietà protetta | FindItemCompareOptions | (Ereditato da ComboBoxEdit)
Proprietà protetta | FocusOnMouseDown | (Ereditato da BaseControl)
Proprietà pubblica | Font | (Ereditato da BaseEdit)
Proprietà protetta | ForceCalcPopupFormSizeByPM2 | (Ereditato da PopupBaseEdit)
Proprietà pubblica | ForeColor | (Ereditato da BaseEdit)
Proprietà protetta | HasAccessible | (Ereditato da BaseControl)
Proprietà protetta | HasItemActions | (Ereditato da ComboBoxEdit)
Proprietà protetta | InnerControl | (Ereditato da TextEdit)
Proprietà pubblica | InplaceType | (Ereditato da BaseEdit)
Proprietà protetta | IsAcceptingEditValue | (Ereditato da BaseEdit)
Proprietà protetta | IsAllowMaskBoxPropertiesUpdate | (Ereditato da TextEdit)
Proprietà protetta | IsAllowValidate | (Ereditato da BaseEdit)
Proprietà protetta | IsClearAutoSearchOnCancelPopup | (Ereditato da PopupBaseAutoSearchEdit)
Proprietà pubblica | IsDesignMode | (Ereditato da BaseControl)
Proprietà protetta | IsDisposing | (Ereditato da BaseControl)
Proprietà pubblica | IsDrawing | (Ereditato da BaseEdit)
Proprietà pubblica | IsEditorActive | (Ereditato da TextEdit)
Proprietà protetta | IsExistsNullValuePrompt | (Ereditato da TextEdit)
Proprietà protetta | IsImmediatePopup | (Ereditato da PopupBaseAutoSearchEdit)
Proprietà protetta | IsLayoutLocked | (Ereditato da BaseEdit)
Proprietà pubblica | IsLoading | (Ereditato da BaseEdit)
Proprietà protetta | IsMaskBoxAvailable | (Ereditato da TextEdit)
Proprietà protetta | IsMaskBoxUpdate | (Ereditato da TextEdit)
Proprietà protetta | IsMatch | (Ereditato da TextEdit)
Proprietà pubblica | IsModified | (Ereditato da BaseEdit)
Proprietà pubblica | IsNeedFocus | (Ereditato da ButtonEdit)
Proprietà protetta | IsNeedHideCursorOnPopup | (Ereditato da PopupBaseEdit)
Proprietà protetta | IsNullValuePromptVisible | (Ereditato da TextEdit)
Proprietà pubblica | IsPopupOpen | (Ereditato da PopupBaseEdit)
Proprietà protetta | IsQueryCloseUpCancelled | (Ereditato da PopupBaseEdit)
Proprietà pubblica | IsRightToLeft | (Ereditato da ControlBase)
Proprietà protetta | IsUpdatingClearButtonVisibility | (Ereditato da PopupBaseEdit)
Proprietà protetta | IsVisualLayoutUpdate | (Ereditato da BaseEdit)
Proprietà protetta | IsWindowsXPStyle | (Ereditato da TextEdit)
Proprietà pubblica | LookAndFeel | (Ereditato da BaseEdit)
Proprietà pubblica | MaskBox | (Ereditato da TextEdit)
Proprietà protetta | MaskBoxInternal | (Ereditato da TextEdit)
Proprietà protetta | Menu | (Ereditato da TextEdit)
Proprietà pubblica | MenuManager | (Ereditato da BaseEdit)
Proprietà protetta | MouseHere | (Ereditato da TextEdit)
Proprietà pubblica | OldEditValue | (Ereditato da BaseEdit)
Proprietà pubblica | Padding | (Ereditato da BaseEdit)
Proprietà protetta | Painter | (Ereditato da BaseEdit)
Proprietà pubblica | PopupCloseMode | (Ereditato da PopupBaseEdit)
Proprietà protetta | PopupForm | (Ereditato da ComboBoxEdit)
Proprietà protetta | PopupShowing | (Ereditato da PopupBaseEdit)
Proprietà protetta | PreferredHeight | (Ereditato da BaseEdit)
Proprietà protetta | ProcessInplaceEditValueChangedEventCore | (Ereditato da PopupBaseEdit)
Proprietà pubblica | Properties |
Proprietà pubblica | ReadOnly | (Ereditato da BaseEdit)
Proprietà protetta | RealEditValue | (Ereditato da ComboBoxEdit)
Proprietà protetta | ScaleDPI | (Ereditato da BaseControl)
Proprietà pubblica | ScaleFactor | (Ereditato da BaseControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraControl)
Proprietà pubblica | SelectedIndex | (Ereditato da ComboBoxEdit)
Proprietà pubblica | SelectedItem | (Ereditato da ComboBoxEdit)
Proprietà pubblica | SelectedText | (Ereditato da TextEdit)
Proprietà pubblica | SelectionLength | (Ereditato da TextEdit)
Proprietà pubblica | SelectionStart | (Ereditato da TextEdit)
Proprietà pubblica | ServiceObject | (Ereditato da BaseEdit)
Proprietà protetta | ShouldDrawBackgroundOnDirectXPaint | (Ereditato da XtraControl)
Proprietà protetta | ShouldNotifyAccessibilityClients | (Ereditato da BaseControl)
Proprietà protetta | ShouldProcessMouseWheelInPopup | (Ereditato da BaseEdit)
Proprietà protetta | ShowKeyboardCuesCore | (Ereditato da BaseControl)
Proprietà pubblica | ShowToolTips | (Ereditato da BaseControl)
Proprietà protetta | ShowToolTipsCore | (Ereditato da BaseEdit)
Proprietà protetta | SizeableIsCaptionVisible | (Ereditato da BaseEdit)
Proprietà protetta | SizeableMaxSize | (Ereditato da BaseControl)
Proprietà protetta | SizeableMinSize | (Ereditato da BaseControl)
Proprietà pubblica | StyleController | (Ereditato da BaseControl)
Proprietà pubblica | SuperTip | (Ereditato da BaseControl)
Proprietà protetta | SuppressSelectAll | (Ereditato da BaseEdit)
Proprietà pubblica | TabStop | (Ereditato da TextEdit)
Proprietà pubblica | Text | (Ereditato da TextEdit)
Proprietà pubblica | ToolTip | (Ereditato da BaseControl)
Proprietà pubblica | ToolTipAnchor | (Ereditato da BaseEdit)
Proprietà pubblica | ToolTipController | (Ereditato da BaseControl)
Proprietà pubblica | ToolTipIconType | (Ereditato da BaseControl)
Proprietà pubblica | ToolTipTitle | (Ereditato da BaseControl)
Proprietà protetta | UseParentOnTransparentPaintBackground | (Ereditato da TextEdit)
Proprietà protetta | ViewInfo | (Ereditato da ButtonEdit)
Proprietà protetta | WorkingStrategy | (Ereditato da TextEdit)
Torna su
Vedi anche

Documentazione

Classe DedComboBox
Namespace DedNet.Controls


Proprietà DedComboBox.EditorTypeName

Proprietà DedComboBoxEditorTypeName

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string EditorTypeName { get; }
Public Overrides ReadOnly Property EditorTypeName As String
    Get
public:
virtual property String^ EditorTypeName {
    String^ get () override;
}
abstract EditorTypeName : string with get
override EditorTypeName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedComboBox
Namespace DedNet.Controls


Proprietà DedComboBox.Properties

Proprietà DedComboBoxProperties

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public RepositoryItemDedComboBox Properties { get; }
Public ReadOnly Property Properties As RepositoryItemDedComboBox
    Get
public:
property RepositoryItemDedComboBox^ Properties {
    RepositoryItemDedComboBox^ get ();
}
member Properties : RepositoryItemDedComboBox with get

Valore della proprietà

RepositoryItemDedComboBox
Vedi anche

Documentazione

Classe DedComboBox
Namespace DedNet.Controls


Metodi di DedComboBox

Il tipo DedComboBox espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | AcceptPopupValue | (Ereditato da PopupBaseEdit)
Metodo protetto | AccessibilityNotifyTextChanged | (Ereditato da TextEdit)
Metodo protetto | ActionShowPopup(EditorButtonObjectInfoArgs) | (Ereditato da PopupBaseEdit)
Metodo protetto | ActionShowPopup(Keys) | (Ereditato da PopupBaseEdit)
Metodo pubblico | AllowMouseClick | (Ereditato da PopupBaseEdit)
Metodo pubblico | AppendText | (Ereditato da TextEdit)
Metodo protetto | BaseEditWndProc | (Ereditato da TextEdit)
Metodo protetto | BaseWndProc | (Ereditato da ControlBase)
Metodo protetto | BeginAcceptEditValue | (Ereditato da BaseEdit)
Metodo protetto | BeginClosePopup | (Ereditato da PopupBaseEdit)
Metodo protetto | BeginInternalTextChange | (Ereditato da TextEdit)
Metodo protetto | BeginUpdate | (Ereditato da BaseEdit)
Metodo pubblico | CalcBestSize | (Ereditato da BaseControl)
Metodo protetto | CalcDefaultSizeableMinWidth | (Ereditato da BaseEdit)
Metodo pubblico | CalcMinHeight | (Ereditato da BaseEdit)
Metodo protetto | CalcPopupFormBounds | (Ereditato da PopupBaseEdit)
Metodo protetto | CalcPopupFormSize | (Ereditato da PopupBaseEdit)
Metodo protetto | CalcPopupFormSizeByPM2AfterCreateHandle | (Ereditato da PopupBaseEdit)
Metodo protetto | CalcPreferredHeight | (Ereditato da BaseEdit)
Metodo protetto | CalcSizeableMaxSize | (Ereditato da TextEdit)
Metodo protetto | CalcSizeableMinSize | (Ereditato da TextEdit)
Metodo pubblico | CancelPopup | (Ereditato da PopupBaseEdit)
Metodo protetto | CancelUpdate | (Ereditato da BaseEdit)
Metodo protetto | CanProcessNullInputKeys | (Ereditato da TextEdit)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da TextEdit)
Metodo protetto | CanValidateObjectViaAnnotationAttributes | (Ereditato da BaseEdit)
Metodo protetto | CanValidateValueViaAnnotationAttributes | (Ereditato da BaseEdit)
Metodo protetto | CanValidateViaAnnotationAttributesCore | (Ereditato da BaseEdit)
Metodo protetto | CheckAutoHeight | (Ereditato da BaseEdit)
Metodo protetto | CheckAutoSearchText | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | CheckAutoSearchText(Boolean) | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | CheckDoubleClick | (Ereditato da BaseEdit)
Metodo protetto | CheckEnabled | (Ereditato da BaseEdit)
Metodo protetto | CheckErrorIcon | (Ereditato da BaseEdit)
Metodo protetto | CheckHighlightPopupAutoSearchText | (Ereditato da ComboBoxEdit)
Metodo protetto | CheckIfNullString | (Ereditato da TextEdit)
Metodo protetto | CheckInplaceAutoSearchText | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | CheckMouseHere | (Ereditato da TextEdit)
Metodo protetto | CheckRightToLeft | (Ereditato da ControlBase)
Metodo pubblico | Clear | (Ereditato da TextEdit)
Metodo protetto | ClearHotPressed | (Ereditato da BaseEdit)
Metodo protetto | ClearHotPressed(EditHitInfo) | (Ereditato da BaseEdit)
Metodo protetto | ClearHotPressedCore | (Ereditato da BaseEdit)
Metodo protetto | ClearHotPressedOnLostFocus | (Ereditato da ButtonEdit)
Metodo protetto | ClearPreferredHeight | (Ereditato da BaseEdit)
Metodo pubblico | CloseAutoCompletePopup | (Ereditato da TextEdit)
Metodo pubblico | ClosePopup | (Ereditato da PopupBaseEdit)
Metodo protetto | ClosePopup(PopupCloseMode) | (Ereditato da PopupBaseEdit)
Metodo protetto | CompareEditValue | (Ereditato da BaseEdit)
Metodo protetto | CompareEditValueOnChange | (Ereditato da BaseEdit)
Metodo protetto | CompareFonts | (Ereditato da TextEdit)
Metodo protetto | CompleteChanges | (Ereditato da BaseEdit)
Metodo protetto | ConstrainFormBounds | (Ereditato da PopupBaseEdit)
Metodo protetto | ControlOnGotFocus | (Ereditato da BaseEdit)
Metodo protetto | ControlOnLostFocus | (Ereditato da BaseEdit)
Metodo pubblico | Copy | (Ereditato da TextEdit)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da BaseControl)
Metodo protetto | CreateAccessibleInstance | (Ereditato da BaseEdit)
Metodo protetto | CreateAdvancedStrategy | (Ereditato da TextEdit)
Metodo protetto | CreateCache | (Ereditato da BaseControl)
Metodo protetto | CreateDirectXProvider | (Ereditato da XtraControl)
Metodo protetto | CreateEditController | (Ereditato da ComboBoxEdit)
Metodo protetto | CreateEditControllerInstance | (Ereditato da ComboBoxEdit)
Metodo protetto | CreateEventSender | (Ereditato da BaseEdit)
Metodo protetto | CreateHandle | (Ereditato da PopupBaseEdit)
Metodo protetto | CreateItemActions | (Ereditato da ComboBoxEdit)
Metodo protetto | CreateLookAndFeel | (Ereditato da BaseEdit)
Metodo protetto | CreateMaskBox | (Ereditato da ComboBoxEdit)
Metodo protetto | CreateMaskBoxInstance | (Ereditato da TextEdit)
Metodo protetto | CreateMaskManager | (Ereditato da TextEdit)
Metodo protetto | CreateMenu | (Ereditato da TextEdit)
Metodo protetto | CreatePopupForm | (Sovrascrive ComboBoxEdit.CreatePopupForm)
Metodo protetto | CreateRepositoryItem | (Ereditato da BaseEdit)
Metodo protetto | CreateRepositoryItemCore | (Ereditato da BaseEdit)
Metodo pubblico | Cut | (Ereditato da TextEdit)
Metodo protetto | DescaleInteger | (Ereditato da BaseControl)
Metodo pubblico | DeselectAll | (Ereditato da TextEdit)
Metodo protetto | DestroyHandleCore | (Ereditato da BaseEdit)
Metodo protetto | DestroyMaskBox | (Ereditato da TextEdit)
Metodo protetto | DestroyPopupForm | (Ereditato da PopupBaseEdit)
Metodo protetto | DestroyPopupFormCore | (Ereditato da PopupBaseEdit)
Metodo protetto | Dispose | (Ereditato da PopupBaseEdit)
Metodo protetto | DoBaseSetBoundsCore | (Ereditato da BaseEdit)
Metodo protetto | DoClosePopup | (Ereditato da PopupBaseEdit)
Metodo protetto | DoDpiChange | (Ereditato da PopupBaseEdit)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraControl)
Metodo protetto | DoImmediatePopup | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | DoIsMatchValidating | (Ereditato da TextEdit)
Metodo protetto | DoNullInputKeysCore | (Ereditato da PopupBaseEdit)
Metodo protetto | DoShowPopup | (Ereditato da PopupBaseEdit)
Metodo protetto | DoSpin | (Ereditato da TextEdit)
Metodo protetto | DoSynchronizePopupFormControls | (Ereditato da PopupBaseEdit)
Metodo pubblico | DoValidate | (Ereditato da BaseEdit)
Metodo pubblico | DoValidate(PopupCloseMode) | (Ereditato da BaseEdit)
Metodo protetto | DoValidateOnEnterKey | (Ereditato da BaseEdit)
Metodo protetto | EndAcceptEditValue | (Ereditato da BaseEdit)
Metodo protetto | EndClosePopup | (Ereditato da PopupBaseEdit)
Metodo protetto | EndInternalTextChange | (Ereditato da TextEdit)
Metodo protetto | EndUpdate | (Ereditato da BaseEdit)
Metodo protetto | EnsureAnnotationAttributes | (Ereditato da BaseEdit)
Metodo pubblico | EnsureInnerEditorFocused | (Ereditato da TextEdit)
Metodo protetto | ExecInnerEditMouseDown | (Ereditato da ButtonEdit)
Metodo protetto | ExtractParsedValue | (Ereditato da BaseEdit)
Metodo protetto | FindCurrentText | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | FindItem(String, Int32) | (Sovrascrive ComboBoxEdit.FindItem(String, Int32))
Metodo protetto | FindItem(String, Boolean, Int32) | (Ereditato da ComboBoxEdit)
Metodo protetto | FindUpdateEditValue | (Ereditato da ComboBoxEdit)
Metodo protetto | FindUpdateEditValueAutoSearchText | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | FindUpdatePopupSelectedItem | (Ereditato da ComboBoxEdit)
Metodo protetto | FireChanged | (Ereditato da BaseControl)
Metodo protetto | FireSpinRequest | (Ereditato da ComboBoxEdit)
Metodo protetto | FlushPendingEditActions | (Ereditato da TextEdit)
Metodo pubblico | ForceClosePopup | (Ereditato da PopupBaseEdit)
Metodo protetto | GetAccessibilityObjectById | (Ereditato da ComboBoxEdit)
Metodo pubblico | GetAccessible | (Ereditato da BaseControl)
Metodo protetto | GetAccessibleToNotify | (Ereditato da TextEdit)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da BaseControl)
Metodo protetto | GetActualText | (Ereditato da ComboBoxEdit)
Metodo protetto | GetAutoSearchCharKeyPressHelper | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | GetAutoSearchCharKeyPressHelperCore | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | GetAutoSearchTextFilter | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | GetChangingOldEditValue | (Ereditato da BaseEdit)
Metodo pubblico | GetCharFromPosition | (Ereditato da TextEdit)
Metodo pubblico | GetCharIndexFromPosition | (Ereditato da TextEdit)
Metodo protetto | GetColor(Color, Color) | (Ereditato da BaseControl)
Metodo protetto | GetColor(Color, Color, Boolean) | (Ereditato da BaseControl)
Metodo protetto | GetDeviceSize | (Ereditato da XtraControl)
Metodo protetto | GetDropDownEditorBorderWeight | (Ereditato da PopupBaseEdit)
Metodo protetto | GetDropDownOrigin | (Ereditato da PopupBaseEdit)
Metodo protetto | GetDropDownPadding | (Ereditato da PopupBaseEdit)
Metodo pubblico | GetFirstCharIndexFromLine | (Ereditato da TextEdit)
Metodo pubblico | GetFirstCharIndexOfCurrentLine | (Ereditato da TextEdit)
Metodo protetto | GetItemDescription | (Ereditato da ComboBoxEdit)
Metodo pubblico | GetLineFromCharIndex | (Ereditato da TextEdit)
Metodo protetto | GetNewScrollIndex | (Ereditato da ComboBoxEdit)
Metodo protetto | GetNullInputKeysValue | (Ereditato da TextEdit)
Metodo protetto | GetObjectToValidate | (Ereditato da BaseEdit)
Metodo pubblico | GetPopupEditForm | (Ereditato da ComboBoxEdit)
Metodo protetto | GetPopupForm | (Ereditato da PopupBaseEdit)
Metodo protetto | GetPopupFormCore | (Ereditato da PopupBaseEdit)
Metodo pubblico | GetPositionFromCharIndex | (Ereditato da TextEdit)
Metodo pubblico | GetPreferredSize | (Ereditato da BaseEdit)
Metodo protetto | GetScaledBounds | (Ereditato da BaseEdit)
Metodo protetto | GetScaleDpiCore | (Ereditato da BaseControl)
Metodo protetto | GetSkinnedCellPadding | (Ereditato da PopupBaseEdit)
Metodo protetto | GetSkinnedEditorBorderWeight | (Ereditato da PopupBaseEdit)
Metodo protetto | GetTextEditController | (Ereditato da TextEdit)
Metodo protetto | GetToolTipAnchor | (Ereditato da BaseControl)
Metodo protetto | GetToolTipInfo | (Ereditato da BaseEdit)
Metodo protetto | GetUseDirectXPaint | (Ereditato da XtraControl)
Metodo protetto | GetValidationCanceled | (Ereditato da BaseEdit)
Metodo pubblico | GetViewInfo | (Ereditato da BaseControl)
Metodo protetto | HideCaret | (Ereditato da TextEdit)
Metodo protetto | InitializeDefault | (Ereditato da BaseEdit)
Metodo protetto | InitializeDefaultProperties | (Ereditato da ComboBoxEdit)
Metodo pubblico | InnerEditorPaste | (Ereditato da TextEdit)
Metodo pubblico | InnerEditorSpin | (Ereditato da TextEdit)
Metodo protetto | InvalidateFormBoundsByPM2BeforeShow | (Ereditato da PopupBaseEdit)
Metodo protetto | IsAcceptCloseMode | (Ereditato da PopupBaseEdit)
Metodo protetto | IsActionButton | (Ereditato da PopupBaseEdit)
Metodo protetto | IsAutoSearchCharHandled | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | IsBindingDataAccessible | (Ereditato da BaseEdit)
Metodo protetto | IsBindingManagerPositionValid | (Ereditato da BaseEdit)
Metodo protetto | IsClearButton | (Ereditato da PopupBaseEdit)
Metodo protetto | IsClearButtonVisible | (Ereditato da PopupBaseEdit)
Metodo pubblico | IsInnerEditorReadOnly | (Ereditato da TextEdit)
Metodo protetto | IsInputChar | (Ereditato da TextEdit)
Metodo protetto | IsInputKey | (Ereditato da TextEdit)
Metodo protetto | IsInputKeyCore | (Ereditato da BaseEdit)
Metodo protetto | IsItemVisible | (Ereditato da ComboBoxEdit)
Metodo pubblico | IsNeededCursorKey | (Ereditato da TextEdit)
Metodo protetto | IsNeededExtraKey | (Ereditato da TextEdit)
Metodo pubblico | IsNeededKey | (Ereditato da PopupBaseEdit)
Metodo protetto | IsNullValue | (Ereditato da BaseEdit)
Metodo protetto | IsShowNullValuePrompt | (Ereditato da TextEdit)
Metodo protetto | IsTextCommand | (Ereditato da TextEdit)
Metodo protetto | KeepPopupFormSize | (Ereditato da PopupBaseEdit)
Metodo protetto | LayoutChanged | (Ereditato da TextEdit)
Metodo protetto | LayoutChanged(Boolean) | (Ereditato da TextEdit)
Metodo protetto | LayoutChangedCore | (Ereditato da TextEdit)
Metodo protetto | LayoutChangedCore(Boolean) | (Ereditato da BaseControl)
Metodo protetto | LockEditValueChanged | (Ereditato da BaseEdit)
Metodo protetto | LockMaskBoxPropertiesUpdate | (Ereditato da TextEdit)
Metodo protetto | MaskBoxGetEditValue | (Ereditato da TextEdit)
Metodo protetto | NeedLayoutUpdateValidating | (Ereditato da TextEdit)
Metodo protetto | NotifyAccessibilityClients(AccessibleEvents, Int32, Int32) | (Ereditato da BaseControl)
Metodo protetto | NotifyAccessibilityClients(AccessibleEvents, AutomationElementProvider, Int32, Int32) | (Ereditato da BaseControl)
Metodo protetto | NotifyButtonStateChanged | (Ereditato da ButtonEdit)
Metodo protetto | OnActionItemClick | (Ereditato da ComboBoxEdit)
Metodo protetto | OnAfterUpdateViewInfo | (Ereditato da TextEdit)
Metodo protetto | OnAppearancePaintChanged | (Ereditato da TextEdit)
Metodo protetto | OnAutoHeightChanged | (Ereditato da BaseEdit)
Metodo protetto | OnBeforeUpdateViewInfo | (Ereditato da TextEdit)
Metodo protetto | OnBorderStyleChanged | (Ereditato da BaseControl)
Metodo protetto | OnCancelEditValueChanging | (Ereditato da BaseEdit)
Metodo protetto | OnClickButton | (Ereditato da PopupBaseEdit)
Metodo protetto | OnClickButtonCore | (Ereditato da ButtonEdit)
Metodo protetto | OnClientSizeChanged | (Ereditato da TextEdit)
Metodo protetto | OnContextMenuChanged | (Ereditato da BaseEdit)
Metodo protetto | OnContextMenuStripChanged | (Ereditato da BaseEdit)
Metodo protetto | OnControllerValueChanged | (Ereditato da TextEdit)
Metodo protetto | OnControllerValueChanging | (Ereditato da TextEdit)
Metodo protetto | OnCreateControl | (Ereditato da TextEdit)
Metodo protetto | OnDefaultPressButton | (Ereditato da PopupBaseEdit)
Metodo protetto | OnDirectXPaintDisabled | (Ereditato da XtraControl)
Metodo protetto | OnDirectXPaintEnabled | (Ereditato da XtraControl)
Metodo protetto | OnEditorEnter | (Ereditato da TextEdit)
Metodo protetto | OnEditorKeyDown | (Ereditato da ComboBoxEdit)
Metodo protetto | OnEditorKeyDownProcessNullInputKeys | (Ereditato da TextEdit)
Metodo protetto | OnEditorKeyPress | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | OnEditorKeyUp | (Ereditato da PopupBaseEdit)
Metodo protetto | OnEditorLeave | (Ereditato da TextEdit)
Metodo protetto | OnEditValueChanged | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | OnEditValueChanging | (Ereditato da TextEdit)
Metodo protetto | OnEnabledChanged | (Ereditato da TextEdit)
Metodo protetto | OnEnableNonMaskedInput | (Ereditato da TextEdit)
Metodo protetto | OnEndIme | (Ereditato da PopupBaseEdit)
Metodo protetto | OnEnter | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | OnErrorInfoChanged | (Ereditato da BaseEdit)
Metodo protetto | OnErrorTextChanged | (Ereditato da TextEdit)
Metodo protetto | OnGlassMaskBoxPreWndProc | (Ereditato da TextEdit)
Metodo protetto | OnGlassMaskBoxWndProc | (Ereditato da TextEdit)
Metodo protetto | OnGotCapture | (Ereditato da ControlBase)
Metodo protetto | OnGotFocus | (Ereditato da PopupBaseEdit)
Metodo protetto | OnHandleCreated | (Ereditato da TextEdit)
Metodo protetto | OnHandleDestroyed | (Ereditato da TextEdit)
Metodo protetto | OnImeModeChanged | (Ereditato da TextEdit)
Metodo protetto | OnInvalidValue | (Ereditato da BaseEdit)
Metodo protetto | OnKeyDown | (Ereditato da TextEdit)
Metodo protetto | OnKeyPress | (Ereditato da TextEdit)
Metodo protetto | OnKeyUp | (Ereditato da TextEdit)
Metodo protetto | OnLeave | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | OnLoaded | (Ereditato da PopupBaseEdit)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da TextEdit)
Metodo protetto | OnLostCapture | (Ereditato da ControlBase)
Metodo protetto | OnLostFocus | (Ereditato da PopupBaseEdit)
Metodo protetto | OnMaskBox_Click | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_DoubleClick | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_GotFocus | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_KeyDown | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_KeyPress | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_KeyUp | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_LostFocus | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_MouseDown | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_MouseEnter | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_MouseLeave | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_MouseMove | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_MouseUp | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_MouseWheel | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_TextValidated | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_ValueChanged | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_ValueChanging | (Ereditato da TextEdit)
Metodo protetto | OnMaskBoxMouseSelection | (Ereditato da TextEdit)
Metodo protetto | OnMaskBoxPreWndProc | (Ereditato da TextEdit)
Metodo protetto | OnMaskBoxTextResetToNullValuePromptOrNullText | (Ereditato da TextEdit)
Metodo protetto | OnMaskBoxWndProc | (Ereditato da TextEdit)
Metodo protetto | OnMaskEditValueChanging | (Ereditato da TextEdit)
Metodo protetto | OnMouseDown | (Ereditato da ComboBoxEdit)
Metodo protetto | OnMouseDownClosePopup | (Ereditato da PopupBaseEdit)
Metodo protetto | OnMouseEnter | (Ereditato da TextEdit)
Metodo protetto | OnMouseLeave | (Ereditato da TextEdit)
Metodo protetto | OnMouseMove | (Ereditato da TextEdit)
Metodo protetto | OnMouseUp | (Ereditato da ButtonEdit)
Metodo protetto | OnMouseWheel | (Ereditato da ComboBoxEdit)
Metodo protetto | OnMove | (Ereditato da PopupBaseEdit)
Metodo protetto | OnPaddingChanged | (Ereditato da BaseControl)
Metodo protetto | OnPaint | (Ereditato da TextEdit)
Metodo protetto | OnPaintBackground | (Ereditato da TextEdit)
Metodo protetto | OnParentChanged | (Ereditato da ControlBase)
Metodo protetto | OnParentVisibleChanged | (Ereditato da PopupBaseEdit)
Metodo protetto | OnPopupClosed | (Ereditato da ComboBoxEdit)
Metodo protetto | OnPopupClosing | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | OnPopupFormValueChanged | (Ereditato da ComboBoxEdit)
Metodo protetto | OnPopupSelectedIndexChanged | (Ereditato da ComboBoxEdit)
Metodo protetto | OnPopupShown | (Ereditato da PopupBaseEdit)
Metodo protetto | OnPressButton | (Ereditato da PopupBaseEdit)
Metodo protetto | OnPreviewKeyDown | (Ereditato da TextEdit)
Metodo protetto | OnProperties_PropertiesChanged | (Ereditato da BaseEdit)
Metodo protetto | OnPropertiesChanged | (Ereditato da PopupBaseEdit)
Metodo protetto | OnPropertiesChanged_SyncPopup | (Ereditato da PopupBaseEdit)
Metodo protetto | OnResize | (Ereditato da TextEdit)
Metodo protetto | OnRightToLeftChanged | (Ereditato da PopupBaseEdit)
Metodo protetto | OnRightToLeftChanged(EventArgs) | (Ereditato da ControlBase)
Metodo protetto | OnScaleControl | (Ereditato da BaseEdit)
Metodo protetto | OnScaleDpiChanged | (Ereditato da ControlBase)
Metodo protetto | OnSizeChanged | (Ereditato da TextEdit)
Metodo protetto | OnSpin | (Ereditato da TextEdit)
Metodo protetto | OnStyleController_Disposed | (Ereditato da BaseControl)
Metodo protetto | OnStyleController_PropertiesChanged | (Ereditato da BaseControl)
Metodo protetto | OnStyleControllerChanged | (Ereditato da TextEdit)
Metodo protetto | OnTabStopChanged | (Ereditato da TextEdit)
Metodo protetto | OnTextChanged | (Ereditato da TextEdit)
Metodo protetto | OnTextEditPropertiesChanged | (Ereditato da TextEdit)
Metodo protetto | OnValidated | (Ereditato da TextEdit)
Metodo protetto | OnValidating | (Ereditato da TextEdit)
Metodo protetto | OnValidatingCore | (Ereditato da BaseEdit)
Metodo protetto | OnVisibleChanged | (Ereditato da PopupBaseEdit)
Metodo protetto | PaintErrorIconBackground | (Ereditato da TextEdit)
Metodo protetto | ParseEditorValue | (Ereditato da BaseEdit)
Metodo pubblico | Paste | (Ereditato da TextEdit)
Metodo protetto | PendingEditActionPerformed | (Ereditato da TextEdit)
Metodo pubblico | PerformClick | (Ereditato da ButtonEdit)
Metodo protetto | PerformDefaultClearButtonAction | (Ereditato da PopupBaseEdit)
Metodo protetto | ProcessAutoSearchChar | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | ProcessAutoSearchNavKey | (Ereditato da ComboBoxEdit)
Metodo protetto | ProcessChar | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | ProcessCmdKey | (Ereditato da TextEdit)
Metodo protetto | ProcessDialogKey | (Ereditato da PopupBaseEdit)
Metodo protetto | ProcessDialogKeyCore | (Ereditato da TextEdit)
Metodo protetto | ProcessFindItem | (Sovrascrive PopupBaseAutoSearchEdit.ProcessFindItem(KeyPressHelper, Char))
Metodo protetto | ProcessPaintAction | (Ereditato da XtraControl)
Metodo protetto | ProcessPopupMouseWheel | (Ereditato da BaseEdit)
Metodo protetto | ProcessPopupTabKey | (Ereditato da PopupBaseEdit)
Metodo protetto | ProcessRemoveWord | (Ereditato da TextEdit)
Metodo protetto | QueryEditorModeFromSkin | (Ereditato da TextEdit)
Metodo protetto | QueryMaskEditValue | (Ereditato da TextEdit)
Metodo protetto | RaiseDropDownCustomDrawItem | (Ereditato da ComboBoxEdit)
Metodo protetto | RaiseEditValueChanged | (Ereditato da BaseEdit)
Metodo protetto | RaiseInvalidValue | (Ereditato da BaseEdit)
Metodo protetto | RaiseModified | (Ereditato da BaseEdit)
Metodo protetto | RaisePaintEvent | (Ereditato da TextEdit)
Metodo protetto | RaisePaintExEvent(TextEditPaintExEventArgs) | (Ereditato da TextEdit)
Metodo protetto | RaisePaintExEvent(GraphicsCache, PaintEventArgs) | (Ereditato da XtraControl)
Metodo protetto | RaisePopupAllowClick | (Ereditato da PopupBaseEdit)
Metodo protetto | RaiseQueryAdvancedMode | (Ereditato da TextEdit)
Metodo protetto | RaiseQueryCompletion | (Ereditato da TextEdit)
Metodo protetto | RaiseSizeableChanged | (Ereditato da BaseControl)
Metodo pubblico | Refresh | (Ereditato da BaseControl)
Metodo pubblico | RefreshEditValue | (Ereditato da PopupBaseEdit)
Metodo protetto | RefreshEnabledState | (Ereditato da TextEdit)
Metodo protetto | RefreshPopup | (Ereditato da ComboBoxEdit)
Metodo protetto | RefreshVisualLayout | (Ereditato da BaseEdit)
Metodo protetto | RefreshVisualLayoutCore | (Ereditato da BaseEdit)
Metodo protetto | RejectPopupValue | (Ereditato da PopupBaseEdit)
Metodo protetto | ReleaseDirectXResources | (Ereditato da XtraControl)
Metodo protetto | ReleaseStyleController | (Ereditato da BaseControl)
Metodo protetto | RemoveXtraAnimator | (Ereditato da BaseControl)
Metodo pubblico | Reset | (Ereditato da ComboBoxEdit)
Metodo protetto | ResetAccessible | (Ereditato da BaseControl)
Metodo pubblico | ResetBackColor | (Ereditato da BaseEdit)
Metodo protetto | ResetEvents | (Ereditato da BaseEdit)
Metodo pubblico | ResetForeColor | (Ereditato da BaseEdit)
Metodo pubblico | ResetSelection | (Ereditato da TextEdit)
Metodo pubblico | ResetSuperTip | (Ereditato da BaseControl)
Metodo protetto | ScaleControl | (Ereditato da ControlBase)
Metodo protetto | ScaleFont | (Ereditato da TextEdit)
Metodo protetto | ScaleInteger | (Ereditato da BaseControl)
Metodo protetto | ScaleSize | (Ereditato da BaseControl)
Metodo protetto | ScrollIndex | (Ereditato da ComboBoxEdit)
Metodo pubblico | ScrollToCaret | (Ereditato da TextEdit)
Metodo protetto | ScrollValue | (Ereditato da ComboBoxEdit)
Metodo protetto | Select(Boolean, Boolean) | (Ereditato da TextEdit)
Metodo pubblico | Select(Int32, Int32) | (Ereditato da TextEdit)
Metodo pubblico | SelectAll | (Ereditato da TextEdit)
Metodo pubblico | SendKey(KeyEventArgs) | (Ereditato da BaseEdit)
Metodo pubblico | SendKey(Object, KeyPressEventArgs) | (Ereditato da BaseEdit)
Metodo pubblico | SendKeyUp | (Ereditato da BaseEdit)
Metodo pubblico | SendMouse(MouseEventArgs) | (Ereditato da BaseEdit)
Metodo pubblico | SendMouse(Point, MouseButtons) | (Ereditato da BaseEdit)
Metodo protetto | SendMouseUp(MouseEventArgs) | (Ereditato da BaseEdit)
Metodo pubblico | SendMouseUp(Point, MouseButtons) | (Ereditato da BaseEdit)
Metodo protetto | SetBackColor | (Ereditato da BaseControl)
Metodo protetto | SetBoundsCore | (Ereditato da BaseEdit)
Metodo protetto | SetEmptyEditValue | (Ereditato da PopupBaseEdit)
Metodo protetto | SetErrorIcon | (Ereditato da BaseEdit)
Metodo protetto | SetPopupEditValueOnClose | (Ereditato da PopupBaseEdit)
Metodo protetto | SetTextCore | (Ereditato da TextEdit)
Metodo protetto | SetVisibleCore | (Ereditato da ControlBase)
Metodo protetto | ShouldSuppressFormDeactivation | (Ereditato da TextEdit)
Metodo protetto | ShouldSuppressTextCommand | (Ereditato da TextEdit)
Metodo pubblico | ShowAutoCompletePopup | (Ereditato da TextEdit)
Metodo protetto | ShowCaret | (Ereditato da TextEdit)
Metodo protetto | ShowMenu | (Ereditato da TextEdit)
Metodo protetto | ShowMenuCore | (Ereditato da TextEdit)
Metodo pubblico | ShowPopup | (Ereditato da PopupBaseEdit)
Metodo protetto | SilentRemove | (Ereditato da ComboBoxEdit)
Metodo protetto | SilentRemoveCore | (Ereditato da ComboBoxEdit)
Metodo protetto | SubscribePopupFormEvents | (Ereditato da PopupBaseEdit)
Metodo protetto | SuppressMouseWheel | (Ereditato da PopupBaseEdit)
Metodo protetto | SwitchModeAccordingToSkinSettings | (Ereditato da TextEdit)
Metodo protetto | SwitchPopupState | (Ereditato da PopupBaseEdit)
Metodo protetto | TryNotifyAccessibilitySelectedIndexChanged | (Ereditato da ComboBoxEdit)
Metodo pubblico | Undo | (Ereditato da TextEdit)
Metodo protetto | UnLockEditValueChanged | (Ereditato da BaseEdit)
Metodo protetto | UnlockMaskBoxPropertiesUpdate | (Ereditato da TextEdit)
Metodo protetto | UpdateClearButtonVisibility | (Ereditato da PopupBaseEdit)
Metodo protetto | UpdateClearButtonVisibilityCore | (Ereditato da PopupBaseEdit)
Metodo protetto | UpdateDisplayText | (Ereditato da TextEdit)
Metodo protetto | UpdateEditControllerProperties | (Ereditato da TextEdit)
Metodo protetto | UpdateEditValueOnClose | (Ereditato da ComboBoxEdit)
Metodo protetto | UpdateFixedHeight | (Ereditato da BaseEdit)
Metodo protetto | UpdateHideSelection | (Ereditato da TextEdit)
Metodo protetto | UpdateInactiveInnerEditorProperties | (Ereditato da TextEdit)
Metodo protetto | UpdateMaskBox | (Ereditato da TextEdit)
Metodo protetto | UpdateMaskBox(Boolean) | (Ereditato da TextEdit)
Metodo protetto | UpdateMaskBoxBounds | (Ereditato da TextEdit)
Metodo protetto | UpdateMaskBoxDisplayText | (Ereditato da TextEdit)
Metodo protetto | UpdateMaskBoxFontByScaleDpi | (Ereditato da TextEdit)
Metodo protetto | UpdateMaskBoxProperties | (Ereditato da TextEdit)
Metodo protetto | UpdateMaskBoxPropertiesCore | (Ereditato da TextEdit)
Metodo protetto | UpdateMenu | (Ereditato da TextEdit)
Metodo protetto | UpdateMenuCoords | (Ereditato da TextEdit)
Metodo protetto | UpdatePasswordChar | (Ereditato da TextEdit)
Metodo protetto | UpdatePopupEditValueIndex | (Ereditato da ComboBoxEdit)
Metodo protetto | UpdateScaleDpi | (Ereditato da XtraControl)
Metodo protetto | UpdateScaleFactorForScaleHelper | (Ereditato da XtraControl)
Metodo pubblico | UpdateTextHighlight | (Ereditato da TextEdit)
Metodo protetto | UpdateViewInfo | (Ereditato da BaseControl)
Metodo protetto | UpdateViewInfoEditValue | (Ereditato da BaseEdit)
Metodo protetto | UpdateViewInfoState | (Ereditato da BaseControl)
Metodo protetto | UpdateViewInfoState(Boolean) | (Ereditato da BaseControl)
Metodo protetto | UpdateViewInfoState(Boolean, Point) | (Ereditato da BaseControl)
Metodo protetto | WndProc | (Ereditato da PopupBaseEdit)
Torna su
Vedi anche

Documentazione

Classe DedComboBox
Namespace DedNet.Controls


Metodo DedComboBox.CreatePopupForm

Metodo DedComboBoxCreatePopupForm

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override PopupBaseForm CreatePopupForm()
Protected Overrides Function CreatePopupForm As PopupBaseForm
protected:
virtual PopupBaseForm^ CreatePopupForm() override
abstract CreatePopupForm : unit -> PopupBaseForm
override CreatePopupForm : unit -> PopupBaseForm

Valore di ritorno

PopupBaseForm
Vedi anche

Documentazione

Classe DedComboBox
Namespace DedNet.Controls


Metodo DedComboBox.FindItem

Metodo DedComboBoxFindItem
Lista degli overload
 | Nome | Descrizione
Metodo protetto | FindItem(String, Int32) |
Metodo protetto | FindItem(String, Boolean, Int32) |
Torna su
Vedi anche

Documentazione

Classe DedComboBox
Namespace DedNet.Controls


Metodo DedComboBox.FindItem(String, Int32)

Metodo DedComboBoxFindItem(String, Int32)

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override int FindItem(
    string text,
    int startIndex
)
Protected Overrides Function FindItem (
    text As String,
    startIndex As Integer
) As Integer
protected:
virtual int FindItem(
    String^ text,
    int startIndex
) override
abstract FindItem :
        text : string *
        startIndex : int -> int
override FindItem :
        text : string *
        startIndex : int -> int

Parametri

text String
startIndex Int32

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedComboBox
Overload di FindItem
Namespace DedNet.Controls


Metodo DedComboBox.ProcessFindItem

Metodo DedComboBoxProcessFindItem

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void ProcessFindItem(
    KeyPressHelper helper,
    char pressedKey
)
Protected Overrides Sub ProcessFindItem (
    helper As KeyPressHelper,
    pressedKey As Char
)
protected:
virtual void ProcessFindItem(
    KeyPressHelper^ helper,
    wchar_t pressedKey
) override
abstract ProcessFindItem :
        helper : KeyPressHelper *
        pressedKey : char -> unit
override ProcessFindItem :
        helper : KeyPressHelper *
        pressedKey : char -> unit

Parametri

helper KeyPressHelper
pressedKey Char
Vedi anche

Documentazione

Classe DedComboBox
Namespace DedNet.Controls


Eventi di DedComboBox

Il tipo DedComboBox espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | BackColorChanged | (Ereditato da BaseEdit)
Evento pubblico | BeforePopup | (Ereditato da PopupBaseEdit)
Evento pubblico | ButtonClick | (Ereditato da ButtonEdit)
Evento pubblico | ButtonPressed | (Ereditato da ButtonEdit)
Evento pubblico | Closed | (Ereditato da PopupBaseEdit)
Evento pubblico | CloseUp | (Ereditato da PopupBaseEdit)
Evento pubblico | CustomDisplayText | (Ereditato da BaseEdit)
Evento pubblico | CustomHighlightText | (Ereditato da TextEdit)
Evento pubblico | CustomizeAutoCompleteSource | (Ereditato da TextEdit)
Evento pubblico | CustomTextLineHeight | (Ereditato da TextEdit)
Evento pubblico | DrawItem | (Ereditato da ComboBoxEdit)
Evento pubblico | DropDownCustomDrawItem | Obsoleto. (Ereditato da ComboBoxEdit)
Evento pubblico | EditValueChanged | (Ereditato da BaseEdit)
Evento pubblico | EditValueChanging | (Ereditato da BaseEdit)
Evento pubblico | FontChanged | (Ereditato da BaseEdit)
Evento pubblico | ForeColorChanged | (Ereditato da BaseEdit)
Evento pubblico | FormatEditValue | (Ereditato da BaseEdit)
Evento pubblico | InvalidValue | (Ereditato da BaseEdit)
Evento pubblico | Modified | (Ereditato da BaseEdit)
Evento pubblico | PaintEx | (Ereditato da TextEdit)
Evento pubblico | ParseEditValue | (Ereditato da BaseEdit)
Evento pubblico | Popup | (Ereditato da PopupBaseEdit)
Evento pubblico | PopupAllowClick | (Ereditato da PopupBaseEdit)
Evento pubblico | PropertiesChanged | (Ereditato da BaseEdit)
Evento pubblico | QueryAccessibilityHelp | (Ereditato da BaseEdit)
Evento pubblico | QueryCloseUp | (Ereditato da PopupBaseEdit)
Evento pubblico | QueryPopUp | (Ereditato da PopupBaseEdit)
Evento pubblico | QueryProcessKey | (Ereditato da BaseEdit)
Evento pubblico | SelectedIndexChanged | (Ereditato da ComboBoxEdit)
Evento pubblico | SelectedValueChanged | (Ereditato da ComboBoxEdit)
Evento pubblico | Spin | (Ereditato da TextEdit)
Torna su
Vedi anche

Documentazione

Classe DedComboBox
Namespace DedNet.Controls


Campi di DedComboBox

Il tipo DedComboBox espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | fDisposing | (Ereditato da BaseControl)
Campo protetto | fEditValue | (Ereditato da BaseEdit)
Campo protetto | fOldEditValue | (Ereditato da BaseEdit)
Campo protetto | fProperties | (Ereditato da BaseEdit)
Campo protetto | fShowToolTips | (Ereditato da BaseControl)
Campo protetto | lastChangedEditValue | (Ereditato da BaseEdit)
Campo protetto | shouldRaiseSizeableChanged | (Ereditato da BaseControl)
Torna su
Vedi anche

Documentazione

Classe DedComboBox
Namespace DedNet.Controls


Classe DedComboBoxPainter
Gerarchia di ereditarietà
SystemObject
BaseControlPainter
BaseEditPainter
TextEditPainter
ButtonEditPainter
DedNet.ControlsDedComboBoxPainter

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedComboBoxPainter : ButtonEditPainter
Public Class DedComboBoxPainter
    Inherits ButtonEditPainter
public ref class DedComboBoxPainter : public ButtonEditPainter
type DedComboBoxPainter =
    class
        inherit ButtonEditPainter
    end

Il tipo DedComboBoxPainter espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedComboBoxPainter |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà protetta | ShouldUpdateStringInfoAppearanceColors | (Ereditato da ButtonEditPainter)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | CheckAllowDrawMatchedText | (Ereditato da TextEditPainter)
Metodo protetto | CheckPrepareHtmlString | (Ereditato da TextEditPainter)
Metodo protetto | CreateBorderInfoArgs | (Ereditato da BaseEditPainter)
Metodo protetto | CreateStringCalculateArgs | (Ereditato da TextEditPainter)
Metodo pubblico | Draw | (Ereditato da BaseEditPainter)
Metodo protetto | DrawAdornments | (Ereditato da BaseEditPainter)
Metodo protetto | DrawAnimatedContextImage | (Ereditato da TextEditPainter)
Metodo protetto | DrawBackgroundCore | (Ereditato da TextEditPainter)
Metodo protetto | DrawBorder | (Ereditato da TextEditPainter)
Metodo protetto | DrawButton | (Ereditato da ButtonEditPainter)
Metodo protetto | DrawButtons(ControlGraphicsInfoArgs) | (Ereditato da ButtonEditPainter)
Metodo protetto | DrawButtons(ControlGraphicsInfoArgs, EditorButtonObjectCollection, Boolean) | (Ereditato da ButtonEditPainter)
Metodo protetto | DrawContent | (Ereditato da ButtonEditPainter)
Metodo protetto | DrawContentCore | (Ereditato da BaseEditPainter)
Metodo protetto | DrawContextImage | (Ereditato da TextEditPainter)
Metodo protetto | DrawContextImageCore | (Ereditato da TextEditPainter)
Metodo protetto | DrawEmptyArea | (Ereditato da TextEditPainter)
Metodo protetto | DrawErrorIcon | (Ereditato da BaseEditPainter)
Metodo protetto | DrawFocusRect | (Ereditato da TextEditPainter)
Metodo protetto | DrawFocusRectCore | (Ereditato da TextEditPainter)
Metodo protetto | DrawGlyph | (Ereditato da ButtonEditPainter)
Metodo protetto | DrawGlyphCore | (Ereditato da ButtonEditPainter)
Metodo protetto | DrawMatchedRanges | (Ereditato da TextEditPainter)
Metodo protetto | DrawMatchedString | (Ereditato da TextEditPainter)
Metodo protetto | DrawParentBackground(ControlGraphicsInfoArgs) | (Ereditato da BaseEditPainter)
Metodo protetto | DrawParentBackground(BaseEditViewInfo, GraphicsCache) | (Ereditato da BaseEditPainter)
Metodo protetto | DrawRectangle | (Ereditato da BaseEditPainter)
Metodo protetto | DrawSkinInplaceBackground | (Ereditato da BaseEditPainter)
Metodo protetto | DrawString(ControlGraphicsInfoArgs, Rectangle, String, AppearanceObject) | (Ereditato da TextEditPainter)
Metodo protetto | DrawString(ControlGraphicsInfoArgs, Rectangle, String, AppearanceObject, Color) | (Ereditato da TextEditPainter)
Metodo protetto | DrawText | (Ereditato da TextEditPainter)
Metodo protetto | DrawTextBoxArea | (Ereditato da TextEditPainter)
Metodo protetto | DrawValueChangeAnimationDx | (Ereditato da BaseEditPainter)
Metodo protetto | DrawValueChangeAnimationGdi | (Ereditato da BaseEditPainter)
Metodo protetto | GetAnimatedColorMatrix | (Ereditato da TextEditPainter)
Metodo protetto | GetSvgPalette | (Ereditato da ButtonEditPainter)
Metodo protetto | IsDrawBorderLast | (Ereditato da BaseControlPainter)
Metodo protetto | ProcessDrawBackground | (Ereditato da TextEditPainter)
Metodo protetto | ShouldDrawBorder | (Ereditato da BaseControlPainter)
Metodo protetto | ShouldDrawButtonInBackground | (Ereditato da ButtonEditPainter)
Metodo protetto | ShouldUseHighlightedDXSkinColor | (Ereditato da TextEditPainter)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore DedComboBoxPainter

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedComboBoxPainter()
Public Sub New
public:
DedComboBoxPainter()
new : unit -> DedComboBoxPainter
Vedi anche

Documentazione

Classe DedComboBoxPainter
Namespace DedNet.Controls


Proprietà di DedComboBoxPainter

Il tipo DedComboBoxPainter espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà protetta | ShouldUpdateStringInfoAppearanceColors | (Ereditato da ButtonEditPainter)
Torna su
Vedi anche

Documentazione

Classe DedComboBoxPainter
Namespace DedNet.Controls


Metodi di DedComboBoxPainter

Il tipo DedComboBoxPainter espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | CheckAllowDrawMatchedText | (Ereditato da TextEditPainter)
Metodo protetto | CheckPrepareHtmlString | (Ereditato da TextEditPainter)
Metodo protetto | CreateBorderInfoArgs | (Ereditato da BaseEditPainter)
Metodo protetto | CreateStringCalculateArgs | (Ereditato da TextEditPainter)
Metodo pubblico | Draw | (Ereditato da BaseEditPainter)
Metodo protetto | DrawAdornments | (Ereditato da BaseEditPainter)
Metodo protetto | DrawAnimatedContextImage | (Ereditato da TextEditPainter)
Metodo protetto | DrawBackgroundCore | (Ereditato da TextEditPainter)
Metodo protetto | DrawBorder | (Ereditato da TextEditPainter)
Metodo protetto | DrawButton | (Ereditato da ButtonEditPainter)
Metodo protetto | DrawButtons(ControlGraphicsInfoArgs) | (Ereditato da ButtonEditPainter)
Metodo protetto | DrawButtons(ControlGraphicsInfoArgs, EditorButtonObjectCollection, Boolean) | (Ereditato da ButtonEditPainter)
Metodo protetto | DrawContent | (Ereditato da ButtonEditPainter)
Metodo protetto | DrawContentCore | (Ereditato da BaseEditPainter)
Metodo protetto | DrawContextImage | (Ereditato da TextEditPainter)
Metodo protetto | DrawContextImageCore | (Ereditato da TextEditPainter)
Metodo protetto | DrawEmptyArea | (Ereditato da TextEditPainter)
Metodo protetto | DrawErrorIcon | (Ereditato da BaseEditPainter)
Metodo protetto | DrawFocusRect | (Ereditato da TextEditPainter)
Metodo protetto | DrawFocusRectCore | (Ereditato da TextEditPainter)
Metodo protetto | DrawGlyph | (Ereditato da ButtonEditPainter)
Metodo protetto | DrawGlyphCore | (Ereditato da ButtonEditPainter)
Metodo protetto | DrawMatchedRanges | (Ereditato da TextEditPainter)
Metodo protetto | DrawMatchedString | (Ereditato da TextEditPainter)
Metodo protetto | DrawParentBackground(ControlGraphicsInfoArgs) | (Ereditato da BaseEditPainter)
Metodo protetto | DrawParentBackground(BaseEditViewInfo, GraphicsCache) | (Ereditato da BaseEditPainter)
Metodo protetto | DrawRectangle | (Ereditato da BaseEditPainter)
Metodo protetto | DrawSkinInplaceBackground | (Ereditato da BaseEditPainter)
Metodo protetto | DrawString(ControlGraphicsInfoArgs, Rectangle, String, AppearanceObject) | (Ereditato da TextEditPainter)
Metodo protetto | DrawString(ControlGraphicsInfoArgs, Rectangle, String, AppearanceObject, Color) | (Ereditato da TextEditPainter)
Metodo protetto | DrawText | (Ereditato da TextEditPainter)
Metodo protetto | DrawTextBoxArea | (Ereditato da TextEditPainter)
Metodo protetto | DrawValueChangeAnimationDx | (Ereditato da BaseEditPainter)
Metodo protetto | DrawValueChangeAnimationGdi | (Ereditato da BaseEditPainter)
Metodo protetto | GetAnimatedColorMatrix | (Ereditato da TextEditPainter)
Metodo protetto | GetSvgPalette | (Ereditato da ButtonEditPainter)
Metodo protetto | IsDrawBorderLast | (Ereditato da BaseControlPainter)
Metodo protetto | ProcessDrawBackground | (Ereditato da TextEditPainter)
Metodo protetto | ShouldDrawBorder | (Ereditato da BaseControlPainter)
Metodo protetto | ShouldDrawButtonInBackground | (Ereditato da ButtonEditPainter)
Metodo protetto | ShouldUseHighlightedDXSkinColor | (Ereditato da TextEditPainter)
Torna su
Vedi anche

Documentazione

Classe DedComboBoxPainter
Namespace DedNet.Controls


Classe DedComboBoxPopupForm
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
SimplePopupBaseForm
PopupBaseForm
PopupBaseSizeableForm
PopupListBoxForm
ComboBoxPopupListBoxForm
DedNet.ControlsDedComboBoxPopupForm

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedComboBoxPopupForm : ComboBoxPopupListBoxForm
Public Class DedComboBoxPopupForm
    Inherits ComboBoxPopupListBoxForm
public ref class DedComboBoxPopupForm : public ComboBoxPopupListBoxForm
type DedComboBoxPopupForm =
    class
        inherit ComboBoxPopupListBoxForm
    end

Il tipo DedComboBoxPopupForm espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedComboBoxPopupForm |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà protetta | AllowCloseByEscape | (Ereditato da PopupBaseForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà protetta | AllowLayoutChanged | (Ereditato da SimplePopupBaseForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowPopupTabOut | (Ereditato da PopupBaseForm)
Proprietà pubblica | AllowSizing | (Ereditato da PopupBaseSizeableForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà protetta | AllowUpdateSelectedItem | (Ereditato da PopupListBoxForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | AppearanceDropDown | (Ereditato da PopupBaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | CanIgnoreImeInput | (Ereditato da PopupBaseForm)
Proprietà protetta | CanShowShadow | (Ereditato da PopupBaseForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | CloseUpKey | (Ereditato da PopupBaseForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da SimplePopupBaseForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DefaultMinFormSize | (Ereditato da PopupListBoxForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DropDownRows | (Ereditato da PopupListBoxForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà protetta | EmbeddedControl | (Ereditato da PopupListBoxForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà pubblica | FormContainsFocus | (Ereditato da SimplePopupBaseForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà pubblica | FormResized | (Ereditato da PopupBaseSizeableForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasAccessible | (Ereditato da SimplePopupBaseForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà protetta | IgnoreOldEditValue | (Ereditato da SimplePopupBaseForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsImeInProgress | (Ereditato da PopupBaseForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsPopupFormClosing | (Ereditato da SimplePopupBaseForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LastSelectedIndex | (Ereditato da PopupListBoxForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | ListBox | (Ereditato da PopupListBoxForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà protetta | MinFormSize | (Ereditato da SimplePopupBaseForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | OldEditValue | (Ereditato da SimplePopupBaseForm)
Proprietà pubblica | OwnerEdit | (Ereditato da PopupListBoxForm)
Proprietà protetta | Painter | (Ereditato da SimplePopupBaseForm)
Proprietà pubblica | PopupBorderStyle | (Ereditato da PopupBaseForm)
Proprietà protetta | PopupFormMinSize | (Ereditato da PopupBaseForm)
Proprietà protetta | PopupFormWidthPadding | (Ereditato da SimplePopupBaseForm)
Proprietà protetta | PopupListFormHelper | (Ereditato da PopupListBoxForm)
Proprietà protetta | PopupShadow | (Ereditato da SimplePopupBaseForm)
Proprietà protetta | PrevParentFormSize | (Ereditato da SimplePopupBaseForm)
Proprietà pubblica | Properties | (Ereditato da PopupListBoxForm)
Proprietà pubblica | ResultValue | (Ereditato da PopupListBoxForm)
Proprietà protetta | ScaleDPI | (Ereditato da SimplePopupBaseForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà pubblica | SelectedItemIndex | (Ereditato da PopupListBoxForm)
Proprietà protetta | SeparatorControl | (Ereditato da SimplePopupBaseForm)
Proprietà protetta | ServiceObject | (Ereditato da SimplePopupBaseForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà protetta | ShowWithoutActivation | (Ereditato da SimplePopupBaseForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SizablePopupHelper | (Ereditato da PopupBaseSizeableForm)
Proprietà protetta | Sizing | (Ereditato da PopupBaseSizeableForm)
Proprietà protetta | SizingBounds | (Ereditato da PopupBaseSizeableForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Proprietà protetta | UseSimpleVisible | (Ereditato da SimplePopupBaseForm)
Proprietà protetta | ViewInfo | (Ereditato da PopupBaseSizeableForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo pubblico | AllowMouseClick | (Ereditato da PopupBaseForm)
Metodo protetto | AllowMouseClickCore | (Ereditato da SimplePopupBaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo pubblico | BeginUpdate | (Ereditato da SimplePopupBaseForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcFormHeight | (Ereditato da PopupListBoxForm)
Metodo pubblico | CalcFormSize | (Ereditato da SimplePopupBaseForm)
Metodo pubblico | CalcFormSize(Size) | (Ereditato da SimplePopupBaseForm)
Metodo protetto | CalcFormSizeCore | (Ereditato da PopupListBoxForm)
Metodo protetto | CalcFormWidth | (Ereditato da PopupListBoxForm)
Metodo pubblico | CalcMinimumComboWidth | (Ereditato da PopupListBoxForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CancelPopup | (Ereditato da PopupBaseForm)
Metodo pubblico | CancelUpdate | (Ereditato da SimplePopupBaseForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo pubblico | CheckClosePopup | (Ereditato da SimplePopupBaseForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckFormWidth | (Ereditato da PopupBaseSizeableForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateTopMost | (Ereditato da SimplePopupBaseForm)
Metodo protetto | CheckZOrder | (Ereditato da SimplePopupBaseForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo pubblico | ClosePopup | (Ereditato da SimplePopupBaseForm)
Metodo protetto | ClosePopup(PopupCloseMode) | (Ereditato da PopupBaseForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da SimplePopupBaseForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da SimplePopupBaseForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da SimplePopupBaseForm)
Metodo protetto | CreateListBox | (Ereditato da ComboBoxPopupListBoxForm)
Metodo protetto | CreatePainter | (Ereditato da PopupBaseSizeableForm)
Metodo protetto | CreatePopupFormShadow | (Ereditato da SimplePopupBaseForm)
Metodo protetto | CreatePopupListFormHelper | (Ereditato da PopupListBoxForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | CreateSizablePopupHelper | (Ereditato da PopupBaseSizeableForm)
Metodo protetto | CreateViewInfo | (Ereditato da PopupBaseSizeableForm)
Metodo protetto | DestroyHandle | (Ereditato da SimplePopupBaseForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | DestroyPopupForm | (Ereditato da PopupBaseForm)
Metodo protetto | Dispose | (Ereditato da PopupListBoxForm)
Metodo protetto | DisposeFormShadow | (Ereditato da SimplePopupBaseForm)
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | DrawSizingRect | (Ereditato da PopupBaseSizeableForm)
Metodo pubblico | EndUpdate | (Ereditato da SimplePopupBaseForm)
Metodo protetto | FocusFormControl | (Ereditato da SimplePopupBaseForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo pubblico | ForceCreateHandle | (Ereditato da SimplePopupBaseForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | ForceShowShadow | (Ereditato da SimplePopupBaseForm)
Metodo protetto | ForceUpdateRemoting | (Ereditato da SimplePopupBaseForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da SimplePopupBaseForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetItemCountForEmptyList | (Ereditato da PopupListBoxForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da SimplePopupBaseForm)
Metodo pubblico | HidePopupForm | (Ereditato da PopupListBoxForm)
Metodo pubblico | HideShadows | (Ereditato da SimplePopupBaseForm)
Metodo protetto | InitCore | (Ereditato da SimplePopupBaseForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | InitializeFormShadow | (Ereditato da SimplePopupBaseForm)
Metodo protetto | IsInputKey | (Ereditato da SimplePopupBaseForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsNeededKey | (Ereditato da PopupBaseForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LayoutChanged | (Ereditato da SimplePopupBaseForm)
Metodo protetto | LockUpdateControlPositions | (Ereditato da SimplePopupBaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnBeforeShowPopup | (Ereditato da PopupBaseForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnEndIme | (Ereditato da PopupBaseForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnForm_Move | (Ereditato da SimplePopupBaseForm)
Metodo protetto | OnForm_Resize | (Ereditato da SimplePopupBaseForm)
Metodo protetto | OnForm_VisibleChanged | (Ereditato da SimplePopupBaseForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnKeyDown | (Ereditato da SimplePopupBaseForm)
Metodo protetto | OnKeyDownCore | (Ereditato da SimplePopupBaseForm)
Metodo protetto | OnKeyPress | (Ereditato da SimplePopupBaseForm)
Metodo protetto | OnKeyUp | (Ereditato da SimplePopupBaseForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnListBox_SelectedIndexChanged | (Ereditato da PopupListBoxForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLocationChanged | (Ereditato da SimplePopupBaseForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseDown | (Ereditato da PopupBaseSizeableForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseMove | (Ereditato da PopupBaseSizeableForm)
Metodo protetto | OnMouseUp | (Ereditato da PopupBaseSizeableForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da SimplePopupBaseForm)
Metodo protetto | OnPaintBackground | (Ereditato da PopupBaseForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnResize | (Ereditato da SimplePopupBaseForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | (Ereditato da SimplePopupBaseForm)
Metodo protetto | OnVisibleRowCountChanged | (Ereditato da PopupListBoxForm)
Metodo protetto | OwnerFormIsTopMost | (Ereditato da SimplePopupBaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | ProcessEscapeKeyDown | (Ereditato da SimplePopupBaseForm)
Metodo pubblico | ProcessKeyDown | (Ereditato da PopupListBoxForm)
Metodo pubblico | ProcessKeyPress | (Ereditato da PopupListBoxForm)
Metodo pubblico | ProcessKeyUp | (Ereditato da SimplePopupBaseForm)
Metodo protetto | ProcessMouseWheel | (Ereditato da PopupListBoxForm)
Metodo protetto | ProcessPopupTabKey | (Ereditato da PopupBaseForm)
Metodo protetto | QueryOldEditValue | (Ereditato da SimplePopupBaseForm)
Metodo protetto | QueryResultValue | (Ereditato da SimplePopupBaseForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | RaiseResultValueChanged | (Ereditato da SimplePopupBaseForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo protetto | ResetResultValue | (Ereditato da PopupListBoxForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetupListBoxOnShow | (Ereditato da PopupListBoxForm)
Metodo protetto | SetVisibleCore | (Ereditato da SimplePopupBaseForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo protetto | ShouldUseFormShadow | (Ereditato da SimplePopupBaseForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo pubblico | ShowHideShadows | (Ereditato da SimplePopupBaseForm)
Metodo pubblico | ShowPopupForm | (Ereditato da ComboBoxPopupListBoxForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SubscribeFormEvents | (Ereditato da SimplePopupBaseForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UnlockUpdateControlPositions | (Ereditato da SimplePopupBaseForm)
Metodo protetto | UnsubscribeFormEvents | (Ereditato da SimplePopupBaseForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateControlPositions | (Ereditato da SimplePopupBaseForm)
Metodo protetto | UpdateControlPositionsCore | (Ereditato da SimplePopupBaseForm)
Metodo protetto | UpdateDelayedViewInfo | (Ereditato da PopupBaseForm)
Metodo protetto | UpdateMinFormSize | (Ereditato da PopupBaseSizeableForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateViewInfo | (Ereditato da SimplePopupBaseForm)
Metodo protetto | UpdateViewInfo(Graphics) | (Ereditato da SimplePopupBaseForm)
Metodo protetto | UpdateWidthWhenRightGrip | (Ereditato da PopupBaseSizeableForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da SimplePopupBaseForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Evento pubblico | ResultValueChanged | (Ereditato da SimplePopupBaseForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore DedComboBoxPopupForm

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedComboBoxPopupForm(
    DedComboBox ownerEdit
)
Public Sub New (
    ownerEdit As DedComboBox
)
public:
DedComboBoxPopupForm(
    DedComboBox^ ownerEdit
)
new :
        ownerEdit : DedComboBox -> DedComboBoxPopupForm

Parametri

ownerEdit DedComboBox
Vedi anche

Documentazione

Classe DedComboBoxPopupForm
Namespace DedNet.Controls


Proprietà di DedComboBoxPopupForm

Il tipo DedComboBoxPopupForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà protetta | AllowCloseByEscape | (Ereditato da PopupBaseForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà protetta | AllowLayoutChanged | (Ereditato da SimplePopupBaseForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowPopupTabOut | (Ereditato da PopupBaseForm)
Proprietà pubblica | AllowSizing | (Ereditato da PopupBaseSizeableForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà protetta | AllowUpdateSelectedItem | (Ereditato da PopupListBoxForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | AppearanceDropDown | (Ereditato da PopupBaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | CanIgnoreImeInput | (Ereditato da PopupBaseForm)
Proprietà protetta | CanShowShadow | (Ereditato da PopupBaseForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | CloseUpKey | (Ereditato da PopupBaseForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da SimplePopupBaseForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DefaultMinFormSize | (Ereditato da PopupListBoxForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DropDownRows | (Ereditato da PopupListBoxForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà protetta | EmbeddedControl | (Ereditato da PopupListBoxForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà pubblica | FormContainsFocus | (Ereditato da SimplePopupBaseForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà pubblica | FormResized | (Ereditato da PopupBaseSizeableForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasAccessible | (Ereditato da SimplePopupBaseForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà protetta | IgnoreOldEditValue | (Ereditato da SimplePopupBaseForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsImeInProgress | (Ereditato da PopupBaseForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsPopupFormClosing | (Ereditato da SimplePopupBaseForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LastSelectedIndex | (Ereditato da PopupListBoxForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | ListBox | (Ereditato da PopupListBoxForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà protetta | MinFormSize | (Ereditato da SimplePopupBaseForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | OldEditValue | (Ereditato da SimplePopupBaseForm)
Proprietà pubblica | OwnerEdit | (Ereditato da PopupListBoxForm)
Proprietà protetta | Painter | (Ereditato da SimplePopupBaseForm)
Proprietà pubblica | PopupBorderStyle | (Ereditato da PopupBaseForm)
Proprietà protetta | PopupFormMinSize | (Ereditato da PopupBaseForm)
Proprietà protetta | PopupFormWidthPadding | (Ereditato da SimplePopupBaseForm)
Proprietà protetta | PopupListFormHelper | (Ereditato da PopupListBoxForm)
Proprietà protetta | PopupShadow | (Ereditato da SimplePopupBaseForm)
Proprietà protetta | PrevParentFormSize | (Ereditato da SimplePopupBaseForm)
Proprietà pubblica | Properties | (Ereditato da PopupListBoxForm)
Proprietà pubblica | ResultValue | (Ereditato da PopupListBoxForm)
Proprietà protetta | ScaleDPI | (Ereditato da SimplePopupBaseForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà pubblica | SelectedItemIndex | (Ereditato da PopupListBoxForm)
Proprietà protetta | SeparatorControl | (Ereditato da SimplePopupBaseForm)
Proprietà protetta | ServiceObject | (Ereditato da SimplePopupBaseForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà protetta | ShowWithoutActivation | (Ereditato da SimplePopupBaseForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SizablePopupHelper | (Ereditato da PopupBaseSizeableForm)
Proprietà protetta | Sizing | (Ereditato da PopupBaseSizeableForm)
Proprietà protetta | SizingBounds | (Ereditato da PopupBaseSizeableForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Proprietà protetta | UseSimpleVisible | (Ereditato da SimplePopupBaseForm)
Proprietà protetta | ViewInfo | (Ereditato da PopupBaseSizeableForm)
Torna su
Vedi anche

Documentazione

Classe DedComboBoxPopupForm
Namespace DedNet.Controls


Metodi di DedComboBoxPopupForm

Il tipo DedComboBoxPopupForm espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo pubblico | AllowMouseClick | (Ereditato da PopupBaseForm)
Metodo protetto | AllowMouseClickCore | (Ereditato da SimplePopupBaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo pubblico | BeginUpdate | (Ereditato da SimplePopupBaseForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcFormHeight | (Ereditato da PopupListBoxForm)
Metodo pubblico | CalcFormSize | (Ereditato da SimplePopupBaseForm)
Metodo pubblico | CalcFormSize(Size) | (Ereditato da SimplePopupBaseForm)
Metodo protetto | CalcFormSizeCore | (Ereditato da PopupListBoxForm)
Metodo protetto | CalcFormWidth | (Ereditato da PopupListBoxForm)
Metodo pubblico | CalcMinimumComboWidth | (Ereditato da PopupListBoxForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CancelPopup | (Ereditato da PopupBaseForm)
Metodo pubblico | CancelUpdate | (Ereditato da SimplePopupBaseForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo pubblico | CheckClosePopup | (Ereditato da SimplePopupBaseForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckFormWidth | (Ereditato da PopupBaseSizeableForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateTopMost | (Ereditato da SimplePopupBaseForm)
Metodo protetto | CheckZOrder | (Ereditato da SimplePopupBaseForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo pubblico | ClosePopup | (Ereditato da SimplePopupBaseForm)
Metodo protetto | ClosePopup(PopupCloseMode) | (Ereditato da PopupBaseForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da SimplePopupBaseForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da SimplePopupBaseForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da SimplePopupBaseForm)
Metodo protetto | CreateListBox | (Ereditato da ComboBoxPopupListBoxForm)
Metodo protetto | CreatePainter | (Ereditato da PopupBaseSizeableForm)
Metodo protetto | CreatePopupFormShadow | (Ereditato da SimplePopupBaseForm)
Metodo protetto | CreatePopupListFormHelper | (Ereditato da PopupListBoxForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | CreateSizablePopupHelper | (Ereditato da PopupBaseSizeableForm)
Metodo protetto | CreateViewInfo | (Ereditato da PopupBaseSizeableForm)
Metodo protetto | DestroyHandle | (Ereditato da SimplePopupBaseForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | DestroyPopupForm | (Ereditato da PopupBaseForm)
Metodo protetto | Dispose | (Ereditato da PopupListBoxForm)
Metodo protetto | DisposeFormShadow | (Ereditato da SimplePopupBaseForm)
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | DrawSizingRect | (Ereditato da PopupBaseSizeableForm)
Metodo pubblico | EndUpdate | (Ereditato da SimplePopupBaseForm)
Metodo protetto | FocusFormControl | (Ereditato da SimplePopupBaseForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo pubblico | ForceCreateHandle | (Ereditato da SimplePopupBaseForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | ForceShowShadow | (Ereditato da SimplePopupBaseForm)
Metodo protetto | ForceUpdateRemoting | (Ereditato da SimplePopupBaseForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da SimplePopupBaseForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetItemCountForEmptyList | (Ereditato da PopupListBoxForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da SimplePopupBaseForm)
Metodo pubblico | HidePopupForm | (Ereditato da PopupListBoxForm)
Metodo pubblico | HideShadows | (Ereditato da SimplePopupBaseForm)
Metodo protetto | InitCore | (Ereditato da SimplePopupBaseForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | InitializeFormShadow | (Ereditato da SimplePopupBaseForm)
Metodo protetto | IsInputKey | (Ereditato da SimplePopupBaseForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsNeededKey | (Ereditato da PopupBaseForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LayoutChanged | (Ereditato da SimplePopupBaseForm)
Metodo protetto | LockUpdateControlPositions | (Ereditato da SimplePopupBaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnBeforeShowPopup | (Ereditato da PopupBaseForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnEndIme | (Ereditato da PopupBaseForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnForm_Move | (Ereditato da SimplePopupBaseForm)
Metodo protetto | OnForm_Resize | (Ereditato da SimplePopupBaseForm)
Metodo protetto | OnForm_VisibleChanged | (Ereditato da SimplePopupBaseForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnKeyDown | (Ereditato da SimplePopupBaseForm)
Metodo protetto | OnKeyDownCore | (Ereditato da SimplePopupBaseForm)
Metodo protetto | OnKeyPress | (Ereditato da SimplePopupBaseForm)
Metodo protetto | OnKeyUp | (Ereditato da SimplePopupBaseForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnListBox_SelectedIndexChanged | (Ereditato da PopupListBoxForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLocationChanged | (Ereditato da SimplePopupBaseForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseDown | (Ereditato da PopupBaseSizeableForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseMove | (Ereditato da PopupBaseSizeableForm)
Metodo protetto | OnMouseUp | (Ereditato da PopupBaseSizeableForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da SimplePopupBaseForm)
Metodo protetto | OnPaintBackground | (Ereditato da PopupBaseForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnResize | (Ereditato da SimplePopupBaseForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | (Ereditato da SimplePopupBaseForm)
Metodo protetto | OnVisibleRowCountChanged | (Ereditato da PopupListBoxForm)
Metodo protetto | OwnerFormIsTopMost | (Ereditato da SimplePopupBaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | ProcessEscapeKeyDown | (Ereditato da SimplePopupBaseForm)
Metodo pubblico | ProcessKeyDown | (Ereditato da PopupListBoxForm)
Metodo pubblico | ProcessKeyPress | (Ereditato da PopupListBoxForm)
Metodo pubblico | ProcessKeyUp | (Ereditato da SimplePopupBaseForm)
Metodo protetto | ProcessMouseWheel | (Ereditato da PopupListBoxForm)
Metodo protetto | ProcessPopupTabKey | (Ereditato da PopupBaseForm)
Metodo protetto | QueryOldEditValue | (Ereditato da SimplePopupBaseForm)
Metodo protetto | QueryResultValue | (Ereditato da SimplePopupBaseForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | RaiseResultValueChanged | (Ereditato da SimplePopupBaseForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo protetto | ResetResultValue | (Ereditato da PopupListBoxForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetupListBoxOnShow | (Ereditato da PopupListBoxForm)
Metodo protetto | SetVisibleCore | (Ereditato da SimplePopupBaseForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo protetto | ShouldUseFormShadow | (Ereditato da SimplePopupBaseForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo pubblico | ShowHideShadows | (Ereditato da SimplePopupBaseForm)
Metodo pubblico | ShowPopupForm | (Ereditato da ComboBoxPopupListBoxForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SubscribeFormEvents | (Ereditato da SimplePopupBaseForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UnlockUpdateControlPositions | (Ereditato da SimplePopupBaseForm)
Metodo protetto | UnsubscribeFormEvents | (Ereditato da SimplePopupBaseForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateControlPositions | (Ereditato da SimplePopupBaseForm)
Metodo protetto | UpdateControlPositionsCore | (Ereditato da SimplePopupBaseForm)
Metodo protetto | UpdateDelayedViewInfo | (Ereditato da PopupBaseForm)
Metodo protetto | UpdateMinFormSize | (Ereditato da PopupBaseSizeableForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateViewInfo | (Ereditato da SimplePopupBaseForm)
Metodo protetto | UpdateViewInfo(Graphics) | (Ereditato da SimplePopupBaseForm)
Metodo protetto | UpdateWidthWhenRightGrip | (Ereditato da PopupBaseSizeableForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da SimplePopupBaseForm)
Torna su
Vedi anche

Documentazione

Classe DedComboBoxPopupForm
Namespace DedNet.Controls


Eventi di DedComboBoxPopupForm

Il tipo DedComboBoxPopupForm espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Evento pubblico | ResultValueChanged | (Ereditato da SimplePopupBaseForm)
Torna su
Vedi anche

Documentazione

Classe DedComboBoxPopupForm
Namespace DedNet.Controls


Campi di DedComboBoxPopupForm

Il tipo DedComboBoxPopupForm espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedComboBoxPopupForm
Namespace DedNet.Controls


Classe DedComboBoxViewInfo
Gerarchia di ereditarietà
SystemObject
BaseControlViewInfo
BaseEditViewInfo
TextEditViewInfo
ButtonEditViewInfo
PopupBaseEditViewInfo
PopupBaseAutoSearchEditViewInfo
ComboBoxViewInfo
DedNet.ControlsDedComboBoxViewInfo

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedComboBoxViewInfo : ComboBoxViewInfo
Public Class DedComboBoxViewInfo
    Inherits ComboBoxViewInfo
public ref class DedComboBoxViewInfo : public ComboBoxViewInfo
type DedComboBoxViewInfo =
    class
        inherit ComboBoxViewInfo
    end

Il tipo DedComboBoxViewInfo espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedComboBoxViewInfo |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà protetta | ActiveLookAndFeel | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | AllowAnimation | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | AllowDrawContent | (Ereditato da TextEditViewInfo)
Proprietà protetta | AllowDrawErrorIconParentBackground | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | AllowDrawFocusRect | (Ereditato da BaseEditViewInfo)
Proprietà protetta | AllowDrawParentBackground | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | AllowDrawText | (Ereditato da ButtonEditViewInfo)
Proprietà protetta | AllowedSkinElementsForBackgroundSkinningMode | (Ereditato da TextEditViewInfo)
Proprietà pubblica | AllowHtmlString | (Ereditato da TextEditViewInfo)
Proprietà pubblica | AllowMaskBox | (Ereditato da ButtonEditViewInfo)
Proprietà protetta | AllowMaskBoxWhenDisabled | (Ereditato da TextEditViewInfo)
Proprietà pubblica | AllowOverridedState | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | AllowScaleWidth | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | AllowTextToolTip | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | AllowValueChangeAnimation | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | AnimatedDisplayStringProvider | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | Appearance | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | AppearanceDisabled | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | AutoCorrectForeColor | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | BackgroundPainter | (Ereditato da TextEditViewInfo)
Proprietà pubblica | BaselinePosition | (Ereditato da TextEditViewInfo)
Proprietà pubblica | BestFitIsLookUp | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | BorderPainter | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | BorderRect | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | BorderStyle | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | Bounds | (Ereditato da BaseControlViewInfo)
Proprietà protetta | CalculatingTextSize | (Ereditato da BaseControlViewInfo)
Proprietà protetta | CanUseFocusedAppearance | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | ClientRect | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | ContentRect | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | ContextImage | (Ereditato da TextEditViewInfo)
Proprietà pubblica | ContextImageAlignment | (Ereditato da TextEditViewInfo)
Proprietà pubblica | ContextImageBounds | (Ereditato da TextEditViewInfo)
Proprietà protetta | ContextImageContainer | (Ereditato da TextEditViewInfo)
Proprietà pubblica | ContextImagePadding | (Ereditato da TextEditViewInfo)
Proprietà protetta | ContextImageSizeCompensation | (Ereditato da TextEditViewInfo)
Proprietà protetta | DefaultAllowBackgroundSkinningMode | (Ereditato da TextEditViewInfo)
Proprietà pubblica | DefaultAllowDrawFocusRect | (Ereditato da TextEditViewInfo)
Proprietà pubblica | DefaultAppearance | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | DefaultBorderStyle | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | DefaultTextOptions | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | DetailLevel | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | DisplayText | (Ereditato da TextEditViewInfo)
Proprietà protetta | DrawBackgroundSkinElement | (Ereditato da TextEditViewInfo)
Proprietà pubblica | DrawFocusRect | (Ereditato da PopupBaseEditViewInfo)
Proprietà pubblica | Editable | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | EditorButtonPainter | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | EditValue | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | Enabled | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | ErrorIcon | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | ErrorIconAlignment | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | ErrorIconBounds | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | ErrorIconText | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | FillBackground | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | Focused | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | FocusRect | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | FocusRectThin | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | ForceShowErrorIcon | (Ereditato da BaseEditViewInfo)
Proprietà protetta | ForceUseSimpleMaskStrategy | (Ereditato da TextEditViewInfo)
Proprietà pubblica | Format | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | FormatFromContainer | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | GInfo | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | GlyphAlignment | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | GlyphBounds | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | GlyphDrawMode | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | HasMatchedString | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | HotInfo | (Ereditato da BaseEditViewInfo)
Proprietà protetta | HtmlTextBoundsWithoutImages | (Ereditato da TextEditViewInfo)
Proprietà protetta | HtmlTextSizeCore | (Ereditato da TextEditViewInfo)
Proprietà protetta | ImageAnimationProvider | (Ereditato da TextEditViewInfo)
Proprietà pubblica | ImageIndex | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | Images | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | ImageSize | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | InplaceAnimationBounds | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | InplaceOwnerControl | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | InplaceStringImageProvider | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | InplaceStringSvgImageProvider | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | InplaceType | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | InternalButtons | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | InValueChangeAnimation | (Ereditato da BaseEditViewInfo)
Proprietà protetta | IsAutoHotSingleButton | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | IsCalcBestFit | (Ereditato da TextEditViewInfo)
Proprietà pubblica | IsCellFocused | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | IsCellSelected | (Ereditato da BaseEditViewInfo)
Proprietà protetta | IsDrawButtons | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | IsEmptyValue | (Ereditato da TextEditViewInfo)
Proprietà protetta | IsEqualsEditValueCore | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | IsExistImage | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | IsGridAllowsFocus | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | IsGridFocused | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | IsInFocusedRow | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | IsInvertIncrementalSearchString | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | IsLoadingValue | (Ereditato da BaseEditViewInfo)
Proprietà protetta | IsLockStateChanging | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | IsNullValue | (Ereditato da BaseEditViewInfo)
Proprietà protetta | IsPopupOpen | (Ereditato da PopupBaseEditViewInfo)
Proprietà pubblica | IsPrinting | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | IsReady | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | IsRequiredUpdateOnMouseMove | (Ereditato da ButtonEditViewInfo)
Proprietà protetta | IsSkinLookAndFeel | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | IsSupportFastViewInfo | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | IsSupportIncrementalSearch | (Ereditato da ButtonEditViewInfo)
Proprietà protetta | IsTryGetThreadSafeFuncValid | (Ereditato da ComboBoxViewInfo)
Proprietà pubblica | Item | (Ereditato da ComboBoxViewInfo)
Proprietà pubblica | LeftButtons | (Ereditato da ButtonEditViewInfo)
Proprietà protetta | LinkColor | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | LookAndFeel | (Ereditato da BaseEditViewInfo)
Proprietà protetta | MaskBoxPadding | (Ereditato da TextEditViewInfo)
Proprietà pubblica | MaskBoxRect | (Ereditato da TextEditViewInfo)
Proprietà pubblica | MatchedRanges | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | MatchedString | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | MatchedStringAllowPartial | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | MatchedStringUseContains | (Ereditato da BaseEditViewInfo)
Proprietà protetta | MaxTextWidth | (Ereditato da TextEditViewInfo)
Proprietà pubblica | MouseButtons | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | MousePosition | (Ereditato da BaseControlViewInfo)
Proprietà protetta | NullValuePromptForeColor | (Ereditato da TextEditViewInfo)
Proprietà pubblica | OverridedState | (Ereditato da BaseEditViewInfo)
Proprietà protetta | Owner | (Ereditato da BaseControlViewInfo)
Proprietà protetta | OwnerControl | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | OwnerEdit | (Ereditato da ComboBoxViewInfo)
Proprietà pubblica | PaintAppearance | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | Painter | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | PCount | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | PressedInfo | (Ereditato da BaseEditViewInfo)
Proprietà protetta | PrevButtons | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | PrevDisplayText | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | PrevEditValue | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | PrevImageIndex | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | RefreshDisplayText | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | RequireClipping | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | RightButtons | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | RightToLeft | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | ShowErrorIcon | (Ereditato da BaseEditViewInfo)
Proprietà protetta | ShowNullValuePromptWhenFocused | (Ereditato da TextEditViewInfo)
Proprietà protetta | ShowNullValuePromptWhenReadOnly | (Ereditato da TextEditViewInfo)
Proprietà protetta | ShowTextToolTip | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | State | (Ereditato da BaseEditViewInfo)
Proprietà protetta | StringInfo | (Ereditato da BaseControlViewInfo)
Proprietà protetta | StyleController | (Ereditato da BaseControlViewInfo)
Proprietà protetta | SupportValueChangeAnimation | (Ereditato da TextEditViewInfo)
Proprietà pubblica | Tag | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | TextBaselineOffset | (Ereditato da TextEditViewInfo)
Proprietà protetta | TextGlyphIndent | (Ereditato da ButtonEditViewInfo)
Proprietà protetta | TextSize | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | TextUseFullBounds | (Ereditato da BaseEditViewInfo)
Proprietà protetta | UseAdvancedHtmlTextAndImageLayout | (Ereditato da TextEditViewInfo)
Proprietà pubblica | UseAdvancedMode | (Ereditato da TextEditViewInfo)
Proprietà protetta | UseBackgroundSkinElement | (Ereditato da TextEditViewInfo)
Proprietà protetta | UseDisabledAppearance | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | UseHighlightSearchAppearance | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | UseParentBackground | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | ValueChangeAnimation | (Ereditato da BaseEditViewInfo)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | AdjustEditorSize | (Ereditato da TextEditViewInfo)
Metodo protetto | AllowDrawInplaceBackground | (Ereditato da BaseEditViewInfo)
Metodo pubblico | AnimateValueChanged | (Ereditato da BaseEditViewInfo)
Metodo protetto | AnimateValueChanged(Object, Object) | (Ereditato da TextEditViewInfo)
Metodo protetto | ApplySkinElement | (Ereditato da BaseControlViewInfo)
Metodo protetto | AreObjectsEquals | (Ereditato da TextEditViewInfo)
Metodo protetto | Assign | (Ereditato da ButtonEditViewInfo)
Metodo pubblico | BeginPaint | (Ereditato da BaseControlViewInfo)
Metodo protetto | BestFitUpdateToMaximumWidthString(Object) | (Ereditato da TextEditViewInfo)
Metodo pubblico | BestFitUpdateToMaximumWidthString(String) | (Ereditato da BaseEditViewInfo)
Metodo pubblico | ButtonInfoByButton | (Ereditato da ButtonEditViewInfo)
Metodo pubblico | ButtonInfoById | (Ereditato da ButtonEditViewInfo)
Metodo pubblico | ButtonInfoByPoint | (Ereditato da ButtonEditViewInfo)
Metodo protetto | CalcAdvancedModeTextSize | (Ereditato da TextEditViewInfo)
Metodo pubblico | CalcBestFit(Graphics) | (Ereditato da BaseEditViewInfo)
Metodo pubblico | CalcBestFit(Graphics, String) | (Ereditato da BaseEditViewInfo)
Metodo protetto | CalcBestFitTextSize | (Ereditato da ButtonEditViewInfo)
Metodo pubblico | CalcBorderState | (Ereditato da TextEditViewInfo)
Metodo protetto | CalcButtons | (Ereditato da ButtonEditViewInfo)
Metodo protetto | CalcButtonState | (Ereditato da ButtonEditViewInfo)
Metodo protetto | CalcClientRect | (Ereditato da BaseEditViewInfo)
Metodo protetto | CalcClientRectCore | (Ereditato da TextEditViewInfo)
Metodo protetto | CalcClientSize | (Ereditato da ButtonEditViewInfo)
Metodo protetto | CalcConstants | (Ereditato da BaseEditViewInfo)
Metodo protetto | CalcContentRect | (Ereditato da ButtonEditViewInfo)
Metodo protetto | CalcContentSize | (Ereditato da TextEditViewInfo)
Metodo protetto | CalcContentTextSize | (Ereditato da ButtonEditViewInfo)
Metodo protetto | CalcContextImageSize | (Ereditato da TextEditViewInfo)
Metodo protetto | CalcFocusRect | (Ereditato da BaseEditViewInfo)
Metodo protetto | CalcGlyphBounds | (Ereditato da ButtonEditViewInfo)
Metodo pubblico | CalcHitInfo | (Ereditato da ButtonEditViewInfo)
Metodo protetto | CalcHtmlTextSize | (Ereditato da TextEditViewInfo)
Metodo protetto | CalcMaskBoxRect(Rectangle) | (Ereditato da TextEditViewInfo)
Metodo protetto | CalcMaskBoxRect(Rectangle, Rectangle) | (Ereditato da TextEditViewInfo)
Metodo protetto | CalcMinButtonBounds | (Ereditato da ButtonEditViewInfo)
Metodo pubblico | CalcMinHeight | (Ereditato da BaseEditViewInfo)
Metodo protetto | CalcMinHeightCore | (Ereditato da TextEditViewInfo)
Metodo protetto | CalcObjectState | (Ereditato da BaseEditViewInfo)
Metodo protetto | CalcRects | (Ereditato da BaseControlViewInfo)
Metodo protetto | CalcShowHint | (Ereditato da TextEditViewInfo)
Metodo protetto | CalcTextBaseline | (Ereditato da TextEditViewInfo)
Metodo protetto | CalcTextSize(Graphics) | (Ereditato da BaseControlViewInfo)
Metodo protetto | CalcTextSize(GraphicsCache) | (Ereditato da BaseControlViewInfo)
Metodo protetto | CalcTextSize(Graphics, Boolean) | (Ereditato da ButtonEditViewInfo)
Metodo protetto | CalcTextSize(GraphicsCache, Boolean) | (Ereditato da BaseControlViewInfo)
Metodo protetto | CalcTextSizeCore(Graphics, String, Int32) | (Ereditato da BaseControlViewInfo)
Metodo protetto | CalcTextSizeCore(GraphicsCache, String, Int32) | (Ereditato da TextEditViewInfo)
Metodo protetto | CalcTextToolTipInfo | (Ereditato da TextEditViewInfo)
Metodo pubblico | CalcViewInfo | (Ereditato da BaseControlViewInfo)
Metodo pubblico | CalcViewInfo(Graphics) | (Ereditato da TextEditViewInfo)
Metodo pubblico | CalcViewInfo(Graphics, MouseButtons, Point, Rectangle) | (Ereditato da BaseControlViewInfo)
Metodo protetto | CanDisplayButton | (Ereditato da ButtonEditViewInfo)
Metodo protetto | CanFastRecalcViewInfo | (Ereditato da TextEditViewInfo)
Metodo pubblico | CanPress | (Ereditato da ButtonEditViewInfo)
Metodo protetto | CheckAdvancedLabelBounds | (Ereditato da ButtonEditViewInfo)
Metodo protetto | CheckShowHint | (Ereditato da BaseControlViewInfo)
Metodo pubblico | CleanUp | (Ereditato da BaseEditViewInfo)
Metodo pubblico | Clear | (Ereditato da ButtonEditViewInfo)
Metodo pubblico | ClearMatchedText | (Ereditato da BaseEditViewInfo)
Metodo pubblico | Clone | (Ereditato da BaseEditViewInfo)
Metodo pubblico | Compare | (Ereditato da ButtonEditViewInfo)
Metodo pubblico | CompareHitInfo | (Ereditato da ButtonEditViewInfo)
Metodo protetto | CreateButtonInfo | (Ereditato da ButtonEditViewInfo)
Metodo protetto | CreateButtonInfoInstance | (Ereditato da ButtonEditViewInfo)
Metodo protetto | CreateButtonPainter | (Ereditato da ButtonEditViewInfo)
Metodo protetto | CreateCalcButtonsRectsArgs | (Ereditato da ButtonEditViewInfo)
Metodo protetto | CreateDefaultAppearance | (Ereditato da TextEditViewInfo)
Metodo protetto | CreateEditorBackgroundPainter | (Ereditato da TextEditViewInfo)
Metodo protetto | CreateHitInfo | (Ereditato da BaseEditViewInfo)
Metodo protetto | CreatePaintAppearance | (Ereditato da BaseControlViewInfo)
Metodo protetto | CreateTextPainter | (Ereditato da TextEditViewInfo)
Metodo pubblico | Dispose | (Ereditato da TextEditViewInfo)
Metodo pubblico | EndPaint | (Ereditato da BaseControlViewInfo)
Metodo protetto | ForceEditValueChanged | (Ereditato da BaseEditViewInfo)
Metodo protetto | ForceHideNullValuePrompt | (Ereditato da TextEditViewInfo)
Metodo pubblico | GenerateAnimatedDisplayText | (Ereditato da BaseEditViewInfo)
Metodo pubblico | GenerateStartDisplayText | (Ereditato da BaseEditViewInfo)
Metodo pubblico | GenerateStartEditValue | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetAllowBackgroundSkinningMode | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetAnimateDisplayString | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetAutoCorrectForeColor | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetBackgroundSkinElement | (Ereditato da TextEditViewInfo)
Metodo pubblico | GetBeginGetDisplayTextsBulkScope | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetBorderArgs | (Ereditato da BaseControlViewInfo)
Metodo protetto | GetBorderPainter | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetBorderPainterCore | (Ereditato da TextEditViewInfo)
Metodo protetto | GetButtonAllowGlyphSkinning | (Ereditato da ButtonEditViewInfo)
Metodo pubblico | GetButtonPainter | (Ereditato da ButtonEditViewInfo)
Metodo protetto | GetCanAnimate | (Ereditato da TextEditViewInfo)
Metodo pubblico | GetContextImageSize | (Ereditato da TextEditViewInfo)
Metodo pubblico | GetDataBindingText | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetDefaultDuration | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetDefaultFont | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetDefaultSkinBorderPainter | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetDefaultSkinFont | (Ereditato da BaseControlViewInfo)
Metodo protetto | GetDefaultTextOptionsForHtmlText | (Ereditato da TextEditViewInfo)
Metodo protetto | GetDirectXClient | (Ereditato da BaseControlViewInfo)
Metodo protetto | GetDisplayText | (Ereditato da TextEditViewInfo)
Metodo protetto | GetDisplayTextCore | (Ereditato da TextEditViewInfo)
Metodo protetto | GetDuration | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetEditorAppearance | (Ereditato da BaseEditViewInfo)
Metodo pubblico | GetErrorIcon | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetErrorIconBestSize | (Ereditato da BaseEditViewInfo)
Metodo pubblico | GetErrorIconSize | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetHtmlContext | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetInplaceBorderPainter | (Ereditato da BaseEditViewInfo)
Metodo pubblico | GetMouseCursor(Point) | (Ereditato da BaseEditViewInfo)
Metodo pubblico | GetMouseCursor(Int32, Int32) | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetPrevButtonState | (Ereditato da ButtonEditViewInfo)
Metodo protetto | GetRealLookAndFeelForSvgPalette | (Ereditato da TextEditViewInfo)
Metodo protetto | GetScaleDpi | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetShowHotKeyPrefix | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetSkinElement | (Ereditato da BaseControlViewInfo)
Metodo protetto | GetSvgPaletteProviderForContextImage | (Ereditato da TextEditViewInfo)
Metodo pubblico | GetSystemColor | (Ereditato da BaseControlViewInfo)
Metodo pubblico | GetTextAscentHeight | (Ereditato da BaseEditViewInfo)
Metodo pubblico | GetTextBounds | (Ereditato da TextEditViewInfo)
Metodo protetto | GetTextBoxContentPadding | (Ereditato da ButtonEditViewInfo)
Metodo protetto | GetTextBoxContentPaddingCore | (Ereditato da TextEditViewInfo)
Metodo protetto | GetTextToButtonPadding | (Ereditato da ButtonEditViewInfo)
Metodo protetto | GetTextToolTipWidth | (Ereditato da TextEditViewInfo)
Metodo pubblico | GetToolTipInfo | (Ereditato da ButtonEditViewInfo)
Metodo protetto | GetToolTipText | (Ereditato da TextEditViewInfo)
Metodo pubblico | GetValueChangeAnimation | (Ereditato da BaseEditViewInfo)
Metodo pubblico | GetWidthForAutoHeight | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetWidthForAutoHeightCore | (Ereditato da BaseEditViewInfo)
Metodo protetto | IsAnyButtonPressed | (Ereditato da PopupBaseEditViewInfo)
Metodo protetto | IsButtonPressed | (Ereditato da PopupBaseEditViewInfo)
Metodo protetto | IsHotEdit | (Ereditato da PopupBaseEditViewInfo)
Metodo protetto | IsOffice2003ExBorder | (Ereditato da BaseEditViewInfo)
Metodo protetto | IsShowNullValuePrompt | (Ereditato da TextEditViewInfo)
Metodo protetto | IsTextToolTipPoint | (Ereditato da ButtonEditViewInfo)
Metodo protetto | IsVisualEqualsEditValue | (Ereditato da TextEditViewInfo)
Metodo pubblico | Offset(Point) | (Ereditato da BaseEditViewInfo)
Metodo pubblico | Offset(Int32, Int32) | (Ereditato da ButtonEditViewInfo)
Metodo protetto | OnBeforeButtonStateChanged | (Ereditato da ButtonEditViewInfo)
Metodo protetto | OnBeginPaint | (Ereditato da BaseControlViewInfo)
Metodo protetto | OnEditValueChanged | (Ereditato da BaseEditViewInfo)
Metodo protetto | OnEndPaint | (Ereditato da BaseControlViewInfo)
Metodo protetto | OnInplaceTpeChanged | (Ereditato da BaseEditViewInfo)
Metodo protetto | OnInplaceTypeChanged | (Ereditato da BaseEditViewInfo)
Metodo protetto | OnIsCellSelectedChanged | (Ereditato da BaseEditViewInfo)
Metodo protetto | OnIsGridFocusedChanged | (Ereditato da BaseEditViewInfo)
Metodo protetto | OnPaintAppearanceChanged | (Ereditato da ButtonEditViewInfo)
Metodo pubblico | PermitSkinInplaceSateLeftEdge | (Ereditato da BaseEditViewInfo)
Metodo pubblico | PermitSkinInplaceState | (Ereditato da BaseEditViewInfo)
Metodo protetto | QuerySkinPaddings | (Ereditato da ButtonEditViewInfo)
Metodo protetto | QueryUseAdvancedMode | (Ereditato da TextEditViewInfo)
Metodo protetto | ReCalcRects | (Ereditato da BaseControlViewInfo)
Metodo pubblico | ReCalcViewInfo | (Ereditato da BaseControlViewInfo)
Metodo protetto | ReCalcViewInfoCore | (Ereditato da BaseEditViewInfo)
Metodo protetto | RequestInplaceBackgroundElement | (Ereditato da BaseEditViewInfo)
Metodo protetto | RequestUseAdvancedMode | (Ereditato da BaseEditViewInfo)
Metodo pubblico | Reset | (Ereditato da TextEditViewInfo)
Metodo protetto | ResetAppearanceDefault | (Ereditato da BaseControlViewInfo)
Metodo pubblico | ResetCachedData | (Ereditato da BaseEditViewInfo)
Metodo protetto | ResetForceHideNullValuePrompt | (Ereditato da TextEditViewInfo)
Metodo protetto | ResetState | (Ereditato da ButtonEditViewInfo)
Metodo protetto | ResetTextSize | (Ereditato da BaseControlViewInfo)
Metodo pubblico | ScaleInteger | (Ereditato da BaseControlViewInfo)
Metodo protetto | ScalePaddingInternal | (Ereditato da BaseControlViewInfo)
Metodo pubblico | ScaleSize | (Ereditato da BaseControlViewInfo)
Metodo pubblico | SetDisplayText(String) | (Ereditato da BaseEditViewInfo)
Metodo pubblico | SetDisplayText(String, Object) | (Ereditato da BaseEditViewInfo)
Metodo pubblico | SetGraphicsInfo | (Ereditato da BaseControlViewInfo)
Metodo pubblico | SetMaskBoxRect | (Ereditato da TextEditViewInfo)
Metodo protetto | SetPaintAppearance | (Ereditato da BaseControlViewInfo)
Metodo pubblico | SetPrevEditValue | (Ereditato da BaseEditViewInfo)
Metodo protetto | ShouldDrawFocusRectCore | (Ereditato da BaseControlViewInfo)
Metodo protetto | SupportValueChangeAnimationCore | (Ereditato da BaseEditViewInfo)
Metodo protetto | SuppressBackgroundSkinElement | (Ereditato da TextEditViewInfo)
Metodo pubblico | SuppressSkinInplaceState | (Ereditato da BaseEditViewInfo)
Metodo pubblico | SuppressSkinInplaceStateLeftEdge | (Ereditato da BaseEditViewInfo)
Metodo pubblico | TryGetThreadSafeGetDisplayTextFunc | (Ereditato da TextEditViewInfo)
Metodo protetto | TryGetThreadSafeOnEditValueChangedFunc | (Ereditato da BaseEditViewInfo)
Metodo pubblico | UpdateAppearances | (Ereditato da BaseControlViewInfo)
Metodo protetto | UpdateBestFitAppearance | (Ereditato da BaseControlViewInfo)
Metodo pubblico | UpdateBoundValues | (Ereditato da BaseEditViewInfo)
Metodo protetto | UpdateByGlyphSize | (Ereditato da ButtonEditViewInfo)
Metodo protetto | UpdateContentRectByFocusRect | (Ereditato da TextEditViewInfo)
Metodo pubblico | UpdateEditValue | (Ereditato da ComboBoxViewInfo)
Metodo protetto | UpdateEnabledState | (Ereditato da BaseEditViewInfo)
Metodo protetto | UpdateFromEditor | (Ereditato da PopupBaseAutoSearchEditViewInfo)
Metodo protetto | UpdateFromOwner | (Ereditato da BaseEditViewInfo)
Metodo pubblico | UpdateGridState | (Ereditato da BaseEditViewInfo)
Metodo pubblico | UpdateGroupValueDisplayText | (Ereditato da BaseEditViewInfo)
Metodo pubblico | UpdateInplaceAnimation | (Ereditato da BaseEditViewInfo)
Metodo protetto | UpdateMaskBoxPadding | (Ereditato da TextEditViewInfo)
Metodo protetto | UpdateMaxBoxRectangle | (Ereditato da TextEditViewInfo)
Metodo protetto | UpdateObjectState | (Ereditato da ButtonEditViewInfo)
Metodo pubblico | UpdateObjectState(MouseButtons, Point) | (Ereditato da BaseControlViewInfo)
Metodo protetto | UpdateObjectStateCore | (Ereditato da BaseControlViewInfo)
Metodo pubblico | UpdatePaintAppearance | (Ereditato da TextEditViewInfo)
Metodo protetto | UpdatePaintAppearance(IStyleController, AppearanceDefault) | (Ereditato da BaseControlViewInfo)
Metodo protetto | UpdatePainters | (Ereditato da ButtonEditViewInfo)
Metodo protetto | UpdateSizeByFocusRect | (Ereditato da TextEditViewInfo)
Metodo protetto | UseSkinSpecifiedSettings | (Ereditato da TextEditViewInfo)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | fAppearance | (Ereditato da BaseControlViewInfo)
Campo protetto | fAppearanceDisabled | (Ereditato da BaseEditViewInfo)
Campo protetto | fBorderRect | (Ereditato da BaseControlViewInfo)
Campo protetto | fBounds | (Ereditato da BaseControlViewInfo)
Campo protetto | fClientRect | (Ereditato da BaseControlViewInfo)
Campo protetto | fContentRect | (Ereditato da BaseControlViewInfo)
Campo protetto | fDisplayText | (Ereditato da BaseEditViewInfo)
Campo protetto | fEditValue | (Ereditato da BaseEditViewInfo)
Campo protetto | fErrorIcon | (Ereditato da BaseEditViewInfo)
Campo protetto | fErrorIconBounds | (Ereditato da BaseEditViewInfo)
Campo protetto | fErrorIconSize | (Ereditato da BaseEditViewInfo)
Campo protetto | fFocusRect | (Ereditato da BaseControlViewInfo)
Campo protetto | fFormat | (Ereditato da BaseEditViewInfo)
Campo protetto | fHotInfo | (Ereditato da BaseEditViewInfo)
Campo protetto | fLookAndFeel | (Ereditato da BaseEditViewInfo)
Campo protetto | fMaskBoxRect | (Ereditato da TextEditViewInfo)
Campo protetto | fMatchedString | (Ereditato da BaseEditViewInfo)
Campo protetto | fPressedInfo | (Ereditato da BaseEditViewInfo)
Campo protetto | fState | (Ereditato da BaseControlViewInfo)
Campo protetto | fTextSize | (Ereditato da BaseEditViewInfo)
Campo protetto | lockCalculatingTextSize | (Ereditato da BaseControlViewInfo)
Campo protetto | toolTipInfoCalculated | (Ereditato da BaseControlViewInfo)
Campo protetto | ValueChangeAnimationId | (Ereditato da BaseEditViewInfo)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore DedComboBoxViewInfo

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedComboBoxViewInfo(
    RepositoryItem item
)
Public Sub New (
    item As RepositoryItem
)
public:
DedComboBoxViewInfo(
    RepositoryItem^ item
)
new :
        item : RepositoryItem -> DedComboBoxViewInfo

Parametri

item RepositoryItem
Vedi anche

Documentazione

Classe DedComboBoxViewInfo
Namespace DedNet.Controls


Proprietà di DedComboBoxViewInfo

Il tipo DedComboBoxViewInfo espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà protetta | ActiveLookAndFeel | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | AllowAnimation | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | AllowDrawContent | (Ereditato da TextEditViewInfo)
Proprietà protetta | AllowDrawErrorIconParentBackground | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | AllowDrawFocusRect | (Ereditato da BaseEditViewInfo)
Proprietà protetta | AllowDrawParentBackground | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | AllowDrawText | (Ereditato da ButtonEditViewInfo)
Proprietà protetta | AllowedSkinElementsForBackgroundSkinningMode | (Ereditato da TextEditViewInfo)
Proprietà pubblica | AllowHtmlString | (Ereditato da TextEditViewInfo)
Proprietà pubblica | AllowMaskBox | (Ereditato da ButtonEditViewInfo)
Proprietà protetta | AllowMaskBoxWhenDisabled | (Ereditato da TextEditViewInfo)
Proprietà pubblica | AllowOverridedState | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | AllowScaleWidth | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | AllowTextToolTip | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | AllowValueChangeAnimation | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | AnimatedDisplayStringProvider | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | Appearance | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | AppearanceDisabled | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | AutoCorrectForeColor | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | BackgroundPainter | (Ereditato da TextEditViewInfo)
Proprietà pubblica | BaselinePosition | (Ereditato da TextEditViewInfo)
Proprietà pubblica | BestFitIsLookUp | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | BorderPainter | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | BorderRect | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | BorderStyle | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | Bounds | (Ereditato da BaseControlViewInfo)
Proprietà protetta | CalculatingTextSize | (Ereditato da BaseControlViewInfo)
Proprietà protetta | CanUseFocusedAppearance | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | ClientRect | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | ContentRect | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | ContextImage | (Ereditato da TextEditViewInfo)
Proprietà pubblica | ContextImageAlignment | (Ereditato da TextEditViewInfo)
Proprietà pubblica | ContextImageBounds | (Ereditato da TextEditViewInfo)
Proprietà protetta | ContextImageContainer | (Ereditato da TextEditViewInfo)
Proprietà pubblica | ContextImagePadding | (Ereditato da TextEditViewInfo)
Proprietà protetta | ContextImageSizeCompensation | (Ereditato da TextEditViewInfo)
Proprietà protetta | DefaultAllowBackgroundSkinningMode | (Ereditato da TextEditViewInfo)
Proprietà pubblica | DefaultAllowDrawFocusRect | (Ereditato da TextEditViewInfo)
Proprietà pubblica | DefaultAppearance | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | DefaultBorderStyle | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | DefaultTextOptions | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | DetailLevel | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | DisplayText | (Ereditato da TextEditViewInfo)
Proprietà protetta | DrawBackgroundSkinElement | (Ereditato da TextEditViewInfo)
Proprietà pubblica | DrawFocusRect | (Ereditato da PopupBaseEditViewInfo)
Proprietà pubblica | Editable | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | EditorButtonPainter | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | EditValue | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | Enabled | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | ErrorIcon | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | ErrorIconAlignment | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | ErrorIconBounds | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | ErrorIconText | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | FillBackground | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | Focused | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | FocusRect | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | FocusRectThin | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | ForceShowErrorIcon | (Ereditato da BaseEditViewInfo)
Proprietà protetta | ForceUseSimpleMaskStrategy | (Ereditato da TextEditViewInfo)
Proprietà pubblica | Format | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | FormatFromContainer | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | GInfo | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | GlyphAlignment | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | GlyphBounds | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | GlyphDrawMode | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | HasMatchedString | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | HotInfo | (Ereditato da BaseEditViewInfo)
Proprietà protetta | HtmlTextBoundsWithoutImages | (Ereditato da TextEditViewInfo)
Proprietà protetta | HtmlTextSizeCore | (Ereditato da TextEditViewInfo)
Proprietà protetta | ImageAnimationProvider | (Ereditato da TextEditViewInfo)
Proprietà pubblica | ImageIndex | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | Images | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | ImageSize | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | InplaceAnimationBounds | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | InplaceOwnerControl | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | InplaceStringImageProvider | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | InplaceStringSvgImageProvider | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | InplaceType | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | InternalButtons | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | InValueChangeAnimation | (Ereditato da BaseEditViewInfo)
Proprietà protetta | IsAutoHotSingleButton | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | IsCalcBestFit | (Ereditato da TextEditViewInfo)
Proprietà pubblica | IsCellFocused | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | IsCellSelected | (Ereditato da BaseEditViewInfo)
Proprietà protetta | IsDrawButtons | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | IsEmptyValue | (Ereditato da TextEditViewInfo)
Proprietà protetta | IsEqualsEditValueCore | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | IsExistImage | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | IsGridAllowsFocus | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | IsGridFocused | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | IsInFocusedRow | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | IsInvertIncrementalSearchString | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | IsLoadingValue | (Ereditato da BaseEditViewInfo)
Proprietà protetta | IsLockStateChanging | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | IsNullValue | (Ereditato da BaseEditViewInfo)
Proprietà protetta | IsPopupOpen | (Ereditato da PopupBaseEditViewInfo)
Proprietà pubblica | IsPrinting | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | IsReady | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | IsRequiredUpdateOnMouseMove | (Ereditato da ButtonEditViewInfo)
Proprietà protetta | IsSkinLookAndFeel | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | IsSupportFastViewInfo | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | IsSupportIncrementalSearch | (Ereditato da ButtonEditViewInfo)
Proprietà protetta | IsTryGetThreadSafeFuncValid | (Ereditato da ComboBoxViewInfo)
Proprietà pubblica | Item | (Ereditato da ComboBoxViewInfo)
Proprietà pubblica | LeftButtons | (Ereditato da ButtonEditViewInfo)
Proprietà protetta | LinkColor | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | LookAndFeel | (Ereditato da BaseEditViewInfo)
Proprietà protetta | MaskBoxPadding | (Ereditato da TextEditViewInfo)
Proprietà pubblica | MaskBoxRect | (Ereditato da TextEditViewInfo)
Proprietà pubblica | MatchedRanges | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | MatchedString | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | MatchedStringAllowPartial | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | MatchedStringUseContains | (Ereditato da BaseEditViewInfo)
Proprietà protetta | MaxTextWidth | (Ereditato da TextEditViewInfo)
Proprietà pubblica | MouseButtons | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | MousePosition | (Ereditato da BaseControlViewInfo)
Proprietà protetta | NullValuePromptForeColor | (Ereditato da TextEditViewInfo)
Proprietà pubblica | OverridedState | (Ereditato da BaseEditViewInfo)
Proprietà protetta | Owner | (Ereditato da BaseControlViewInfo)
Proprietà protetta | OwnerControl | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | OwnerEdit | (Ereditato da ComboBoxViewInfo)
Proprietà pubblica | PaintAppearance | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | Painter | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | PCount | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | PressedInfo | (Ereditato da BaseEditViewInfo)
Proprietà protetta | PrevButtons | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | PrevDisplayText | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | PrevEditValue | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | PrevImageIndex | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | RefreshDisplayText | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | RequireClipping | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | RightButtons | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | RightToLeft | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | ShowErrorIcon | (Ereditato da BaseEditViewInfo)
Proprietà protetta | ShowNullValuePromptWhenFocused | (Ereditato da TextEditViewInfo)
Proprietà protetta | ShowNullValuePromptWhenReadOnly | (Ereditato da TextEditViewInfo)
Proprietà protetta | ShowTextToolTip | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | State | (Ereditato da BaseEditViewInfo)
Proprietà protetta | StringInfo | (Ereditato da BaseControlViewInfo)
Proprietà protetta | StyleController | (Ereditato da BaseControlViewInfo)
Proprietà protetta | SupportValueChangeAnimation | (Ereditato da TextEditViewInfo)
Proprietà pubblica | Tag | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | TextBaselineOffset | (Ereditato da TextEditViewInfo)
Proprietà protetta | TextGlyphIndent | (Ereditato da ButtonEditViewInfo)
Proprietà protetta | TextSize | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | TextUseFullBounds | (Ereditato da BaseEditViewInfo)
Proprietà protetta | UseAdvancedHtmlTextAndImageLayout | (Ereditato da TextEditViewInfo)
Proprietà pubblica | UseAdvancedMode | (Ereditato da TextEditViewInfo)
Proprietà protetta | UseBackgroundSkinElement | (Ereditato da TextEditViewInfo)
Proprietà protetta | UseDisabledAppearance | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | UseHighlightSearchAppearance | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | UseParentBackground | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | ValueChangeAnimation | (Ereditato da BaseEditViewInfo)
Torna su
Vedi anche

Documentazione

Classe DedComboBoxViewInfo
Namespace DedNet.Controls


Metodi di DedComboBoxViewInfo

Il tipo DedComboBoxViewInfo espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | AdjustEditorSize | (Ereditato da TextEditViewInfo)
Metodo protetto | AllowDrawInplaceBackground | (Ereditato da BaseEditViewInfo)
Metodo pubblico | AnimateValueChanged | (Ereditato da BaseEditViewInfo)
Metodo protetto | AnimateValueChanged(Object, Object) | (Ereditato da TextEditViewInfo)
Metodo protetto | ApplySkinElement | (Ereditato da BaseControlViewInfo)
Metodo protetto | AreObjectsEquals | (Ereditato da TextEditViewInfo)
Metodo protetto | Assign | (Ereditato da ButtonEditViewInfo)
Metodo pubblico | BeginPaint | (Ereditato da BaseControlViewInfo)
Metodo protetto | BestFitUpdateToMaximumWidthString(Object) | (Ereditato da TextEditViewInfo)
Metodo pubblico | BestFitUpdateToMaximumWidthString(String) | (Ereditato da BaseEditViewInfo)
Metodo pubblico | ButtonInfoByButton | (Ereditato da ButtonEditViewInfo)
Metodo pubblico | ButtonInfoById | (Ereditato da ButtonEditViewInfo)
Metodo pubblico | ButtonInfoByPoint | (Ereditato da ButtonEditViewInfo)
Metodo protetto | CalcAdvancedModeTextSize | (Ereditato da TextEditViewInfo)
Metodo pubblico | CalcBestFit(Graphics) | (Ereditato da BaseEditViewInfo)
Metodo pubblico | CalcBestFit(Graphics, String) | (Ereditato da BaseEditViewInfo)
Metodo protetto | CalcBestFitTextSize | (Ereditato da ButtonEditViewInfo)
Metodo pubblico | CalcBorderState | (Ereditato da TextEditViewInfo)
Metodo protetto | CalcButtons | (Ereditato da ButtonEditViewInfo)
Metodo protetto | CalcButtonState | (Ereditato da ButtonEditViewInfo)
Metodo protetto | CalcClientRect | (Ereditato da BaseEditViewInfo)
Metodo protetto | CalcClientRectCore | (Ereditato da TextEditViewInfo)
Metodo protetto | CalcClientSize | (Ereditato da ButtonEditViewInfo)
Metodo protetto | CalcConstants | (Ereditato da BaseEditViewInfo)
Metodo protetto | CalcContentRect | (Ereditato da ButtonEditViewInfo)
Metodo protetto | CalcContentSize | (Ereditato da TextEditViewInfo)
Metodo protetto | CalcContentTextSize | (Ereditato da ButtonEditViewInfo)
Metodo protetto | CalcContextImageSize | (Ereditato da TextEditViewInfo)
Metodo protetto | CalcFocusRect | (Ereditato da BaseEditViewInfo)
Metodo protetto | CalcGlyphBounds | (Ereditato da ButtonEditViewInfo)
Metodo pubblico | CalcHitInfo | (Ereditato da ButtonEditViewInfo)
Metodo protetto | CalcHtmlTextSize | (Ereditato da TextEditViewInfo)
Metodo protetto | CalcMaskBoxRect(Rectangle) | (Ereditato da TextEditViewInfo)
Metodo protetto | CalcMaskBoxRect(Rectangle, Rectangle) | (Ereditato da TextEditViewInfo)
Metodo protetto | CalcMinButtonBounds | (Ereditato da ButtonEditViewInfo)
Metodo pubblico | CalcMinHeight | (Ereditato da BaseEditViewInfo)
Metodo protetto | CalcMinHeightCore | (Ereditato da TextEditViewInfo)
Metodo protetto | CalcObjectState | (Ereditato da BaseEditViewInfo)
Metodo protetto | CalcRects | (Ereditato da BaseControlViewInfo)
Metodo protetto | CalcShowHint | (Ereditato da TextEditViewInfo)
Metodo protetto | CalcTextBaseline | (Ereditato da TextEditViewInfo)
Metodo protetto | CalcTextSize(Graphics) | (Ereditato da BaseControlViewInfo)
Metodo protetto | CalcTextSize(GraphicsCache) | (Ereditato da BaseControlViewInfo)
Metodo protetto | CalcTextSize(Graphics, Boolean) | (Ereditato da ButtonEditViewInfo)
Metodo protetto | CalcTextSize(GraphicsCache, Boolean) | (Ereditato da BaseControlViewInfo)
Metodo protetto | CalcTextSizeCore(Graphics, String, Int32) | (Ereditato da BaseControlViewInfo)
Metodo protetto | CalcTextSizeCore(GraphicsCache, String, Int32) | (Ereditato da TextEditViewInfo)
Metodo protetto | CalcTextToolTipInfo | (Ereditato da TextEditViewInfo)
Metodo pubblico | CalcViewInfo | (Ereditato da BaseControlViewInfo)
Metodo pubblico | CalcViewInfo(Graphics) | (Ereditato da TextEditViewInfo)
Metodo pubblico | CalcViewInfo(Graphics, MouseButtons, Point, Rectangle) | (Ereditato da BaseControlViewInfo)
Metodo protetto | CanDisplayButton | (Ereditato da ButtonEditViewInfo)
Metodo protetto | CanFastRecalcViewInfo | (Ereditato da TextEditViewInfo)
Metodo pubblico | CanPress | (Ereditato da ButtonEditViewInfo)
Metodo protetto | CheckAdvancedLabelBounds | (Ereditato da ButtonEditViewInfo)
Metodo protetto | CheckShowHint | (Ereditato da BaseControlViewInfo)
Metodo pubblico | CleanUp | (Ereditato da BaseEditViewInfo)
Metodo pubblico | Clear | (Ereditato da ButtonEditViewInfo)
Metodo pubblico | ClearMatchedText | (Ereditato da BaseEditViewInfo)
Metodo pubblico | Clone | (Ereditato da BaseEditViewInfo)
Metodo pubblico | Compare | (Ereditato da ButtonEditViewInfo)
Metodo pubblico | CompareHitInfo | (Ereditato da ButtonEditViewInfo)
Metodo protetto | CreateButtonInfo | (Ereditato da ButtonEditViewInfo)
Metodo protetto | CreateButtonInfoInstance | (Ereditato da ButtonEditViewInfo)
Metodo protetto | CreateButtonPainter | (Ereditato da ButtonEditViewInfo)
Metodo protetto | CreateCalcButtonsRectsArgs | (Ereditato da ButtonEditViewInfo)
Metodo protetto | CreateDefaultAppearance | (Ereditato da TextEditViewInfo)
Metodo protetto | CreateEditorBackgroundPainter | (Ereditato da TextEditViewInfo)
Metodo protetto | CreateHitInfo | (Ereditato da BaseEditViewInfo)
Metodo protetto | CreatePaintAppearance | (Ereditato da BaseControlViewInfo)
Metodo protetto | CreateTextPainter | (Ereditato da TextEditViewInfo)
Metodo pubblico | Dispose | (Ereditato da TextEditViewInfo)
Metodo pubblico | EndPaint | (Ereditato da BaseControlViewInfo)
Metodo protetto | ForceEditValueChanged | (Ereditato da BaseEditViewInfo)
Metodo protetto | ForceHideNullValuePrompt | (Ereditato da TextEditViewInfo)
Metodo pubblico | GenerateAnimatedDisplayText | (Ereditato da BaseEditViewInfo)
Metodo pubblico | GenerateStartDisplayText | (Ereditato da BaseEditViewInfo)
Metodo pubblico | GenerateStartEditValue | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetAllowBackgroundSkinningMode | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetAnimateDisplayString | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetAutoCorrectForeColor | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetBackgroundSkinElement | (Ereditato da TextEditViewInfo)
Metodo pubblico | GetBeginGetDisplayTextsBulkScope | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetBorderArgs | (Ereditato da BaseControlViewInfo)
Metodo protetto | GetBorderPainter | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetBorderPainterCore | (Ereditato da TextEditViewInfo)
Metodo protetto | GetButtonAllowGlyphSkinning | (Ereditato da ButtonEditViewInfo)
Metodo pubblico | GetButtonPainter | (Ereditato da ButtonEditViewInfo)
Metodo protetto | GetCanAnimate | (Ereditato da TextEditViewInfo)
Metodo pubblico | GetContextImageSize | (Ereditato da TextEditViewInfo)
Metodo pubblico | GetDataBindingText | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetDefaultDuration | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetDefaultFont | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetDefaultSkinBorderPainter | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetDefaultSkinFont | (Ereditato da BaseControlViewInfo)
Metodo protetto | GetDefaultTextOptionsForHtmlText | (Ereditato da TextEditViewInfo)
Metodo protetto | GetDirectXClient | (Ereditato da BaseControlViewInfo)
Metodo protetto | GetDisplayText | (Ereditato da TextEditViewInfo)
Metodo protetto | GetDisplayTextCore | (Ereditato da TextEditViewInfo)
Metodo protetto | GetDuration | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetEditorAppearance | (Ereditato da BaseEditViewInfo)
Metodo pubblico | GetErrorIcon | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetErrorIconBestSize | (Ereditato da BaseEditViewInfo)
Metodo pubblico | GetErrorIconSize | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetHtmlContext | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetInplaceBorderPainter | (Ereditato da BaseEditViewInfo)
Metodo pubblico | GetMouseCursor(Point) | (Ereditato da BaseEditViewInfo)
Metodo pubblico | GetMouseCursor(Int32, Int32) | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetPrevButtonState | (Ereditato da ButtonEditViewInfo)
Metodo protetto | GetRealLookAndFeelForSvgPalette | (Ereditato da TextEditViewInfo)
Metodo protetto | GetScaleDpi | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetShowHotKeyPrefix | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetSkinElement | (Ereditato da BaseControlViewInfo)
Metodo protetto | GetSvgPaletteProviderForContextImage | (Ereditato da TextEditViewInfo)
Metodo pubblico | GetSystemColor | (Ereditato da BaseControlViewInfo)
Metodo pubblico | GetTextAscentHeight | (Ereditato da BaseEditViewInfo)
Metodo pubblico | GetTextBounds | (Ereditato da TextEditViewInfo)
Metodo protetto | GetTextBoxContentPadding | (Ereditato da ButtonEditViewInfo)
Metodo protetto | GetTextBoxContentPaddingCore | (Ereditato da TextEditViewInfo)
Metodo protetto | GetTextToButtonPadding | (Ereditato da ButtonEditViewInfo)
Metodo protetto | GetTextToolTipWidth | (Ereditato da TextEditViewInfo)
Metodo pubblico | GetToolTipInfo | (Ereditato da ButtonEditViewInfo)
Metodo protetto | GetToolTipText | (Ereditato da TextEditViewInfo)
Metodo pubblico | GetValueChangeAnimation | (Ereditato da BaseEditViewInfo)
Metodo pubblico | GetWidthForAutoHeight | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetWidthForAutoHeightCore | (Ereditato da BaseEditViewInfo)
Metodo protetto | IsAnyButtonPressed | (Ereditato da PopupBaseEditViewInfo)
Metodo protetto | IsButtonPressed | (Ereditato da PopupBaseEditViewInfo)
Metodo protetto | IsHotEdit | (Ereditato da PopupBaseEditViewInfo)
Metodo protetto | IsOffice2003ExBorder | (Ereditato da BaseEditViewInfo)
Metodo protetto | IsShowNullValuePrompt | (Ereditato da TextEditViewInfo)
Metodo protetto | IsTextToolTipPoint | (Ereditato da ButtonEditViewInfo)
Metodo protetto | IsVisualEqualsEditValue | (Ereditato da TextEditViewInfo)
Metodo pubblico | Offset(Point) | (Ereditato da BaseEditViewInfo)
Metodo pubblico | Offset(Int32, Int32) | (Ereditato da ButtonEditViewInfo)
Metodo protetto | OnBeforeButtonStateChanged | (Ereditato da ButtonEditViewInfo)
Metodo protetto | OnBeginPaint | (Ereditato da BaseControlViewInfo)
Metodo protetto | OnEditValueChanged | (Ereditato da BaseEditViewInfo)
Metodo protetto | OnEndPaint | (Ereditato da BaseControlViewInfo)
Metodo protetto | OnInplaceTpeChanged | (Ereditato da BaseEditViewInfo)
Metodo protetto | OnInplaceTypeChanged | (Ereditato da BaseEditViewInfo)
Metodo protetto | OnIsCellSelectedChanged | (Ereditato da BaseEditViewInfo)
Metodo protetto | OnIsGridFocusedChanged | (Ereditato da BaseEditViewInfo)
Metodo protetto | OnPaintAppearanceChanged | (Ereditato da ButtonEditViewInfo)
Metodo pubblico | PermitSkinInplaceSateLeftEdge | (Ereditato da BaseEditViewInfo)
Metodo pubblico | PermitSkinInplaceState | (Ereditato da BaseEditViewInfo)
Metodo protetto | QuerySkinPaddings | (Ereditato da ButtonEditViewInfo)
Metodo protetto | QueryUseAdvancedMode | (Ereditato da TextEditViewInfo)
Metodo protetto | ReCalcRects | (Ereditato da BaseControlViewInfo)
Metodo pubblico | ReCalcViewInfo | (Ereditato da BaseControlViewInfo)
Metodo protetto | ReCalcViewInfoCore | (Ereditato da BaseEditViewInfo)
Metodo protetto | RequestInplaceBackgroundElement | (Ereditato da BaseEditViewInfo)
Metodo protetto | RequestUseAdvancedMode | (Ereditato da BaseEditViewInfo)
Metodo pubblico | Reset | (Ereditato da TextEditViewInfo)
Metodo protetto | ResetAppearanceDefault | (Ereditato da BaseControlViewInfo)
Metodo pubblico | ResetCachedData | (Ereditato da BaseEditViewInfo)
Metodo protetto | ResetForceHideNullValuePrompt | (Ereditato da TextEditViewInfo)
Metodo protetto | ResetState | (Ereditato da ButtonEditViewInfo)
Metodo protetto | ResetTextSize | (Ereditato da BaseControlViewInfo)
Metodo pubblico | ScaleInteger | (Ereditato da BaseControlViewInfo)
Metodo protetto | ScalePaddingInternal | (Ereditato da BaseControlViewInfo)
Metodo pubblico | ScaleSize | (Ereditato da BaseControlViewInfo)
Metodo pubblico | SetDisplayText(String) | (Ereditato da BaseEditViewInfo)
Metodo pubblico | SetDisplayText(String, Object) | (Ereditato da BaseEditViewInfo)
Metodo pubblico | SetGraphicsInfo | (Ereditato da BaseControlViewInfo)
Metodo pubblico | SetMaskBoxRect | (Ereditato da TextEditViewInfo)
Metodo protetto | SetPaintAppearance | (Ereditato da BaseControlViewInfo)
Metodo pubblico | SetPrevEditValue | (Ereditato da BaseEditViewInfo)
Metodo protetto | ShouldDrawFocusRectCore | (Ereditato da BaseControlViewInfo)
Metodo protetto | SupportValueChangeAnimationCore | (Ereditato da BaseEditViewInfo)
Metodo protetto | SuppressBackgroundSkinElement | (Ereditato da TextEditViewInfo)
Metodo pubblico | SuppressSkinInplaceState | (Ereditato da BaseEditViewInfo)
Metodo pubblico | SuppressSkinInplaceStateLeftEdge | (Ereditato da BaseEditViewInfo)
Metodo pubblico | TryGetThreadSafeGetDisplayTextFunc | (Ereditato da TextEditViewInfo)
Metodo protetto | TryGetThreadSafeOnEditValueChangedFunc | (Ereditato da BaseEditViewInfo)
Metodo pubblico | UpdateAppearances | (Ereditato da BaseControlViewInfo)
Metodo protetto | UpdateBestFitAppearance | (Ereditato da BaseControlViewInfo)
Metodo pubblico | UpdateBoundValues | (Ereditato da BaseEditViewInfo)
Metodo protetto | UpdateByGlyphSize | (Ereditato da ButtonEditViewInfo)
Metodo protetto | UpdateContentRectByFocusRect | (Ereditato da TextEditViewInfo)
Metodo pubblico | UpdateEditValue | (Ereditato da ComboBoxViewInfo)
Metodo protetto | UpdateEnabledState | (Ereditato da BaseEditViewInfo)
Metodo protetto | UpdateFromEditor | (Ereditato da PopupBaseAutoSearchEditViewInfo)
Metodo protetto | UpdateFromOwner | (Ereditato da BaseEditViewInfo)
Metodo pubblico | UpdateGridState | (Ereditato da BaseEditViewInfo)
Metodo pubblico | UpdateGroupValueDisplayText | (Ereditato da BaseEditViewInfo)
Metodo pubblico | UpdateInplaceAnimation | (Ereditato da BaseEditViewInfo)
Metodo protetto | UpdateMaskBoxPadding | (Ereditato da TextEditViewInfo)
Metodo protetto | UpdateMaxBoxRectangle | (Ereditato da TextEditViewInfo)
Metodo protetto | UpdateObjectState | (Ereditato da ButtonEditViewInfo)
Metodo pubblico | UpdateObjectState(MouseButtons, Point) | (Ereditato da BaseControlViewInfo)
Metodo protetto | UpdateObjectStateCore | (Ereditato da BaseControlViewInfo)
Metodo pubblico | UpdatePaintAppearance | (Ereditato da TextEditViewInfo)
Metodo protetto | UpdatePaintAppearance(IStyleController, AppearanceDefault) | (Ereditato da BaseControlViewInfo)
Metodo protetto | UpdatePainters | (Ereditato da ButtonEditViewInfo)
Metodo protetto | UpdateSizeByFocusRect | (Ereditato da TextEditViewInfo)
Metodo protetto | UseSkinSpecifiedSettings | (Ereditato da TextEditViewInfo)
Torna su
Vedi anche

Documentazione

Classe DedComboBoxViewInfo
Namespace DedNet.Controls


Campi di DedComboBoxViewInfo

Il tipo DedComboBoxViewInfo espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | fAppearance | (Ereditato da BaseControlViewInfo)
Campo protetto | fAppearanceDisabled | (Ereditato da BaseEditViewInfo)
Campo protetto | fBorderRect | (Ereditato da BaseControlViewInfo)
Campo protetto | fBounds | (Ereditato da BaseControlViewInfo)
Campo protetto | fClientRect | (Ereditato da BaseControlViewInfo)
Campo protetto | fContentRect | (Ereditato da BaseControlViewInfo)
Campo protetto | fDisplayText | (Ereditato da BaseEditViewInfo)
Campo protetto | fEditValue | (Ereditato da BaseEditViewInfo)
Campo protetto | fErrorIcon | (Ereditato da BaseEditViewInfo)
Campo protetto | fErrorIconBounds | (Ereditato da BaseEditViewInfo)
Campo protetto | fErrorIconSize | (Ereditato da BaseEditViewInfo)
Campo protetto | fFocusRect | (Ereditato da BaseControlViewInfo)
Campo protetto | fFormat | (Ereditato da BaseEditViewInfo)
Campo protetto | fHotInfo | (Ereditato da BaseEditViewInfo)
Campo protetto | fLookAndFeel | (Ereditato da BaseEditViewInfo)
Campo protetto | fMaskBoxRect | (Ereditato da TextEditViewInfo)
Campo protetto | fMatchedString | (Ereditato da BaseEditViewInfo)
Campo protetto | fPressedInfo | (Ereditato da BaseEditViewInfo)
Campo protetto | fState | (Ereditato da BaseControlViewInfo)
Campo protetto | fTextSize | (Ereditato da BaseEditViewInfo)
Campo protetto | lockCalculatingTextSize | (Ereditato da BaseControlViewInfo)
Campo protetto | toolTipInfoCalculated | (Ereditato da BaseControlViewInfo)
Campo protetto | ValueChangeAnimationId | (Ereditato da BaseEditViewInfo)
Torna su
Vedi anche

Documentazione

Classe DedComboBoxViewInfo
Namespace DedNet.Controls


Classe DedCommAnagExplorer
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
XtraUserControl
DedNet.ControlsUserControlBase
DedNet.ControlsDedCommAnagExplorer

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedCommAnagExplorer : UserControlBase
Public Class DedCommAnagExplorer
    Inherits UserControlBase
public ref class DedCommAnagExplorer : public UserControlBase
type DedCommAnagExplorer =
    class
        inherit UserControlBase
    end

Il tipo DedCommAnagExplorer espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedCommAnagExplorer |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Appearance | (Ereditato da XtraUserControl)
Proprietà pubblica | Application | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Proprietà pubblica | BackColor | (Ereditato da XtraUserControl)
Proprietà protetta | CheckDoubleScaling | (Ereditato da XtraUserControl)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraUserControl)
Proprietà protetta | DirectXContainer | (Ereditato da XtraUserControl)
Proprietà pubblica | EnableIXtraResizeableControlInterfaceProxy | (Ereditato da XtraUserControl)
Proprietà pubblica | Font | (Ereditato da XtraUserControl)
Proprietà pubblica | ForeColor | (Ereditato da XtraUserControl)
Proprietà protetta | Helper | (Ereditato da XtraUserControl)
Proprietà pubblica | IsDragging | Indica se è in corso un dragging
Proprietà pubblica | LookAndFeel | (Ereditato da XtraUserControl)
Proprietà protetta | Painter | (Ereditato da XtraUserControl)
Proprietà pubblica | RefComm | Restituisce o imposta la commessa di riferimento del controllo.
Proprietà pubblica | RegistryAnagPanelKey | Restituisce o imposta la chiave per i settaggi del pannello delle commesse.
Proprietà protetta | ScaleChildren | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleDPI | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraUserControl)
Proprietà pubblica | SelectedCommAnagrs | Selezione corrente delle anagrafiche
Proprietà pubblica | SelectedDatas | Selezione corrente delle anagrafiche
Proprietà pubblica | SelectedDca | Selezione corrente delle anagrafiche di commessa
Proprietà protetta | ShouldCheckDpiScaleFactorOnParentChanged | (Ereditato da XtraUserControl)
Proprietà pubblica | Site | (Ereditato da XtraUserControl)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AddAnagrData | Aggiunge una anagrafica dell'inizia parte veloce
Metodo protetto | BaseWndProc | (Ereditato da XtraUserControl)
Metodo pubblico | CheckAnagrSup | Restituisce true se sono presenti delle anagrafiche superate.
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraUserControl)
Metodo protetto | CreatePainter | (Ereditato da XtraUserControl)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive UserControlBaseDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraUserControl)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraUserControl)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraUserControl)
Metodo protetto | GetBackColor | (Ereditato da XtraUserControl)
Metodo protetto | GetBackgroundSkinElement | (Ereditato da XtraUserControl)
Metodo pubblico | GetGrid | Restituisce la griglia.
Metodo protetto | GetInnerIXtraResizableControl | (Ereditato da XtraUserControl)
Metodo pubblico | Initialize | Metodo pubblico per l'inizializzazione del controllo
Metodo protetto | IsChildControlsRequiredScalingEnabled | (Ereditato da XtraUserControl)
Metodo protetto | IsParentHandleCreatedRecursive | (Ereditato da XtraUserControl)
Metodo pubblico | LoadAnag | Metodo pubblico per il caricamento delle anagrafiche di commessa
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraUserControl)
Metodo protetto | OnBackColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnContextMenuOpening | (Sovrascrive UserControlBaseOnContextMenuOpening(Object, CancelEventArgs))
Metodo protetto | OnControlAdded | (Ereditato da XtraUserControl)
Metodo protetto | OnControlRemoved | (Ereditato da XtraUserControl)
Metodo protetto | OnDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnFirstLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnForeColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleCreated | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraUserControl)
Metodo protetto | OnLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnMenuItemClicked | Evento di pressione di un comando del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnPaintCore | (Ereditato da XtraUserControl)
Metodo protetto | OnParentChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | OnSizeChanged | (Ereditato da XtraUserControl)
Metodo protetto | RaisePaintExEvent | (Ereditato da XtraUserControl)
Metodo pubblico | RefreshAnagrData | Effettua il refresh del controllo delle anagrafiche.
Metodo pubblico | ReloadData | Ricarica i dati partendo dalla commessa di riferimento
Metodo pubblico | ResetBackColor | (Ereditato da XtraUserControl)
Metodo pubblico | ResetForeColor | (Ereditato da XtraUserControl)
Metodo protetto | RestoreAutoScaleModeChangedByPM2 | (Ereditato da XtraUserControl)
Metodo pubblico | SaveRegistrySettings | Salvataggio dati nel registro
Metodo protetto | ScaleControl | (Ereditato da XtraUserControl)
Metodo pubblico | SetCommandList | Rigenera il menu contestuale di questo controllo con la lista dei comandi passati. (Sovrascrive UserControlBaseSetCommandList(DedCommandList, CommandContextEnum))
Metodo protetto | SetVisibleCore | (Ereditato da XtraUserControl)
Metodo protetto | ShouldPaintTransparentBackground | (Ereditato da XtraUserControl)
Metodo protetto | ShouldUseDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | WndProc | (Ereditato da XtraUserControl)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | ContextMenuOpening | Evento su apertura del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | MenuItemClicked | Evento su click su un elemento del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | MyMouseDoubleClick |
Evento pubblico | PaintEx | (Ereditato da XtraUserControl)
Evento pubblico | SelectionChanged |
Torna su
Campi
 | Nome | Descrizione
Campo protetto | _app | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Campo protetto | _RegistryBaseKey | Chiave nel registro di sistema di salvataggio impostazioni. (Ereditato da UserControlBase)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore DedCommAnagExplorer

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommAnagExplorer()
Public Sub New
public:
DedCommAnagExplorer()
new : unit -> DedCommAnagExplorer
Vedi anche

Documentazione

Classe DedCommAnagExplorer
Namespace DedNet.Controls


Proprietà di DedCommAnagExplorer

Il tipo DedCommAnagExplorer espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Appearance | (Ereditato da XtraUserControl)
Proprietà pubblica | Application | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Proprietà pubblica | BackColor | (Ereditato da XtraUserControl)
Proprietà protetta | CheckDoubleScaling | (Ereditato da XtraUserControl)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraUserControl)
Proprietà protetta | DirectXContainer | (Ereditato da XtraUserControl)
Proprietà pubblica | EnableIXtraResizeableControlInterfaceProxy | (Ereditato da XtraUserControl)
Proprietà pubblica | Font | (Ereditato da XtraUserControl)
Proprietà pubblica | ForeColor | (Ereditato da XtraUserControl)
Proprietà protetta | Helper | (Ereditato da XtraUserControl)
Proprietà pubblica | IsDragging | Indica se è in corso un dragging
Proprietà pubblica | LookAndFeel | (Ereditato da XtraUserControl)
Proprietà protetta | Painter | (Ereditato da XtraUserControl)
Proprietà pubblica | RefComm | Restituisce o imposta la commessa di riferimento del controllo.
Proprietà pubblica | RegistryAnagPanelKey | Restituisce o imposta la chiave per i settaggi del pannello delle commesse.
Proprietà protetta | ScaleChildren | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleDPI | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraUserControl)
Proprietà pubblica | SelectedCommAnagrs | Selezione corrente delle anagrafiche
Proprietà pubblica | SelectedDatas | Selezione corrente delle anagrafiche
Proprietà pubblica | SelectedDca | Selezione corrente delle anagrafiche di commessa
Proprietà protetta | ShouldCheckDpiScaleFactorOnParentChanged | (Ereditato da XtraUserControl)
Proprietà pubblica | Site | (Ereditato da XtraUserControl)
Torna su
Vedi anche

Documentazione

Classe DedCommAnagExplorer
Namespace DedNet.Controls


Proprietà DedCommAnagExplorer.IsDragging

Proprietà DedCommAnagExplorerIsDragging
Indica se è in corso un dragging

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsDragging { get; }
Public ReadOnly Property IsDragging As Boolean
    Get
public:
property bool IsDragging {
    bool get ();
}
member IsDragging : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedCommAnagExplorer
Namespace DedNet.Controls


Proprietà DedCommAnagExplorer.RefComm

Proprietà DedCommAnagExplorerRefComm
Restituisce o imposta la commessa di riferimento del controllo.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedComm RefComm { get; }
Public ReadOnly Property RefComm As DedComm
    Get
public:
property DedComm^ RefComm {
    DedComm^ get ();
}
member RefComm : DedComm with get

Valore della proprietà

DedComm
Vedi anche

Documentazione

Classe DedCommAnagExplorer
Namespace DedNet.Controls


Proprietà DedCommAnagExplorer.RegistryAnagPanelKey

Proprietà DedCommAnagExplorerRegistryAnagPanelKey
Restituisce o imposta la chiave per i settaggi del pannello delle commesse.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string RegistryAnagPanelKey { get; set; }
Public Property RegistryAnagPanelKey As String
    Get
    Set
public:
property String^ RegistryAnagPanelKey {
    String^ get ();
    void set (String^ value);
}
member RegistryAnagPanelKey : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedCommAnagExplorer
Namespace DedNet.Controls


Proprietà DedCommAnagExplorer.SelectedCommAnagrs

Proprietà DedCommAnagExplorerSelectedCommAnagrs
Selezione corrente delle anagrafiche

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<DedCommAnagExplorerCommAnagWrapper> SelectedCommAnagrs { get; }
Public ReadOnly Property SelectedCommAnagrs As List(Of DedCommAnagExplorerCommAnagWrapper)
    Get
public:
property List<DedCommAnagExplorerCommAnagWrapper^>^ SelectedCommAnagrs {
    List<DedCommAnagExplorerCommAnagWrapper^>^ get ();
}
member SelectedCommAnagrs : List<DedCommAnagExplorerCommAnagWrapper> with get

Valore della proprietà

List DedCommAnagExplorerCommAnagWrapper
Vedi anche

Documentazione

Classe DedCommAnagExplorer
Namespace DedNet.Controls


Proprietà DedCommAnagExplorer.SelectedDatas

Proprietà DedCommAnagExplorerSelectedDatas
Selezione corrente delle anagrafiche

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataList SelectedDatas { get; }
Public ReadOnly Property SelectedDatas As DedDataList
    Get
public:
property DedDataList^ SelectedDatas {
    DedDataList^ get ();
}
member SelectedDatas : DedDataList with get

Valore della proprietà

DedDataList
Vedi anche

Documentazione

Classe DedCommAnagExplorer
Namespace DedNet.Controls


Proprietà DedCommAnagExplorer.SelectedDca

Proprietà DedCommAnagExplorerSelectedDca
Selezione corrente delle anagrafiche di commessa

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<DedCommAnagrItem> SelectedDca { get; }
Public ReadOnly Property SelectedDca As List(Of DedCommAnagrItem)
    Get
public:
property List<DedCommAnagrItem^>^ SelectedDca {
    List<DedCommAnagrItem^>^ get ();
}
member SelectedDca : List<DedCommAnagrItem> with get

Valore della proprietà

List DedCommAnagrItem
Vedi anche

Documentazione

Classe DedCommAnagExplorer
Namespace DedNet.Controls


Metodi di DedCommAnagExplorer

Il tipo DedCommAnagExplorer espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AddAnagrData | Aggiunge una anagrafica dell'inizia parte veloce
Metodo protetto | BaseWndProc | (Ereditato da XtraUserControl)
Metodo pubblico | CheckAnagrSup | Restituisce true se sono presenti delle anagrafiche superate.
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraUserControl)
Metodo protetto | CreatePainter | (Ereditato da XtraUserControl)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive UserControlBaseDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraUserControl)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraUserControl)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraUserControl)
Metodo protetto | GetBackColor | (Ereditato da XtraUserControl)
Metodo protetto | GetBackgroundSkinElement | (Ereditato da XtraUserControl)
Metodo pubblico | GetGrid | Restituisce la griglia.
Metodo protetto | GetInnerIXtraResizableControl | (Ereditato da XtraUserControl)
Metodo pubblico | Initialize | Metodo pubblico per l'inizializzazione del controllo
Metodo protetto | IsChildControlsRequiredScalingEnabled | (Ereditato da XtraUserControl)
Metodo protetto | IsParentHandleCreatedRecursive | (Ereditato da XtraUserControl)
Metodo pubblico | LoadAnag | Metodo pubblico per il caricamento delle anagrafiche di commessa
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraUserControl)
Metodo protetto | OnBackColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnContextMenuOpening | (Sovrascrive UserControlBaseOnContextMenuOpening(Object, CancelEventArgs))
Metodo protetto | OnControlAdded | (Ereditato da XtraUserControl)
Metodo protetto | OnControlRemoved | (Ereditato da XtraUserControl)
Metodo protetto | OnDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnFirstLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnForeColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleCreated | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraUserControl)
Metodo protetto | OnLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnMenuItemClicked | Evento di pressione di un comando del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnPaintCore | (Ereditato da XtraUserControl)
Metodo protetto | OnParentChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | OnSizeChanged | (Ereditato da XtraUserControl)
Metodo protetto | RaisePaintExEvent | (Ereditato da XtraUserControl)
Metodo pubblico | RefreshAnagrData | Effettua il refresh del controllo delle anagrafiche.
Metodo pubblico | ReloadData | Ricarica i dati partendo dalla commessa di riferimento
Metodo pubblico | ResetBackColor | (Ereditato da XtraUserControl)
Metodo pubblico | ResetForeColor | (Ereditato da XtraUserControl)
Metodo protetto | RestoreAutoScaleModeChangedByPM2 | (Ereditato da XtraUserControl)
Metodo pubblico | SaveRegistrySettings | Salvataggio dati nel registro
Metodo protetto | ScaleControl | (Ereditato da XtraUserControl)
Metodo pubblico | SetCommandList | Rigenera il menu contestuale di questo controllo con la lista dei comandi passati. (Sovrascrive UserControlBaseSetCommandList(DedCommandList, CommandContextEnum))
Metodo protetto | SetVisibleCore | (Ereditato da XtraUserControl)
Metodo protetto | ShouldPaintTransparentBackground | (Ereditato da XtraUserControl)
Metodo protetto | ShouldUseDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | WndProc | (Ereditato da XtraUserControl)
Torna su
Vedi anche

Documentazione

Classe DedCommAnagExplorer
Namespace DedNet.Controls


Metodo DedCommAnagExplorer.AddAnagrData

Metodo DedCommAnagExplorerAddAnagrData
Aggiunge una anagrafica dell'inizia parte veloce

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddAnagrData(
    DedData anag,
    bool reloadData
)
Public Sub AddAnagrData (
    anag As DedData,
    reloadData As Boolean
)
public:
void AddAnagrData(
    DedData^ anag,
    bool reloadData
)
member AddAnagrData :
        anag : DedData *
        reloadData : bool -> unit

Parametri

anag DedData
reloadData Boolean
Vedi anche

Documentazione

Classe DedCommAnagExplorer
Namespace DedNet.Controls


Metodo DedCommAnagExplorer.CheckAnagrSup

Metodo DedCommAnagExplorerCheckAnagrSup
Restituisce true se sono presenti delle anagrafiche superate.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void CheckAnagrSup()
Public Sub CheckAnagrSup
public:
void CheckAnagrSup()
member CheckAnagrSup : unit -> unit
Vedi anche

Documentazione

Classe DedCommAnagExplorer
Namespace DedNet.Controls


Metodo DedCommAnagExplorer.Dispose

Metodo DedCommAnagExplorerDispose
Clean up any resources being used.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedCommAnagExplorer
Namespace DedNet.Controls


Metodo DedCommAnagExplorer.GetGrid

Metodo DedCommAnagExplorerGetGrid
Restituisce la griglia.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public GridControl GetGrid()
Public Function GetGrid As GridControl
public:
GridControl^ GetGrid()
member GetGrid : unit -> GridControl

Valore di ritorno

GridControl
Vedi anche

Documentazione

Classe DedCommAnagExplorer
Namespace DedNet.Controls


Metodo DedCommAnagExplorer.Initialize

Metodo DedCommAnagExplorerInitialize
Metodo pubblico per l'inizializzazione del controllo

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Initialize()
Public Sub Initialize
public:
void Initialize()
member Initialize : unit -> unit
Vedi anche

Documentazione

Classe DedCommAnagExplorer
Namespace DedNet.Controls


Metodo DedCommAnagExplorer.LoadAnag

Metodo DedCommAnagExplorerLoadAnag
Metodo pubblico per il caricamento delle anagrafiche di commessa

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void LoadAnag(
    DedComm dc
)
Public Sub LoadAnag (
    dc As DedComm
)
public:
void LoadAnag(
    DedComm^ dc
)
member LoadAnag :
        dc : DedComm -> unit

Parametri

dc DedComm
Vedi anche

Documentazione

Classe DedCommAnagExplorer
Namespace DedNet.Controls


Metodo DedCommAnagExplorer.OnContextMenuOpening

Metodo DedCommAnagExplorerOnContextMenuOpening

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void OnContextMenuOpening(
    Object sender,
    CancelEventArgs e
)
Protected Overrides Sub OnContextMenuOpening (
    sender As Object,
    e As CancelEventArgs
)
protected:
virtual void OnContextMenuOpening(
    Object^ sender,
    CancelEventArgs^ e
) override
abstract OnContextMenuOpening :
        sender : Object *
        e : CancelEventArgs -> unit
override OnContextMenuOpening :
        sender : Object *
        e : CancelEventArgs -> unit

Parametri

sender Object
e CancelEventArgs
Vedi anche

Documentazione

Classe DedCommAnagExplorer
Namespace DedNet.Controls


Metodo DedCommAnagExplorer.RefreshAnagrData

Metodo DedCommAnagExplorerRefreshAnagrData
Effettua il refresh del controllo delle anagrafiche.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void RefreshAnagrData()
Public Sub RefreshAnagrData
public:
void RefreshAnagrData()
member RefreshAnagrData : unit -> unit
Vedi anche

Documentazione

Classe DedCommAnagExplorer
Namespace DedNet.Controls


Metodo DedCommAnagExplorer.ReloadData

Metodo DedCommAnagExplorerReloadData
Ricarica i dati partendo dalla commessa di riferimento

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ReloadData()
Public Sub ReloadData
public:
void ReloadData()
member ReloadData : unit -> unit
Vedi anche

Documentazione

Classe DedCommAnagExplorer
Namespace DedNet.Controls


Metodo DedCommAnagExplorer.SaveRegistrySettings

Metodo DedCommAnagExplorerSaveRegistrySettings
Salvataggio dati nel registro

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SaveRegistrySettings()
Public Sub SaveRegistrySettings
public:
void SaveRegistrySettings()
member SaveRegistrySettings : unit -> unit
Vedi anche

Documentazione

Classe DedCommAnagExplorer
Namespace DedNet.Controls


Metodo DedCommAnagExplorer.SetCommandList

Metodo DedCommAnagExplorerSetCommandList
Rigenera il menu contestuale di questo controllo con la lista dei comandi passati.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void SetCommandList(
    DedCommandList commandList,
    CommandContextEnum commandContext
)
Public Overrides Sub SetCommandList (
    commandList As DedCommandList,
    commandContext As CommandContextEnum
)
public:
virtual void SetCommandList(
    DedCommandList^ commandList,
    CommandContextEnum commandContext
) override
abstract SetCommandList :
        commandList : DedCommandList *
        commandContext : CommandContextEnum -> unit
override SetCommandList :
        commandList : DedCommandList *
        commandContext : CommandContextEnum -> unit

Parametri

commandList DedCommandList
Lista completa dei comandi.
commandContext CommandContextEnum
Contesto da utilizzare per filtrare i comandi da inserire.
Note
Filtra i comandi in modo da aggiungere soltanto quelli coerenti con il contesto passato.
Vedi anche

Documentazione

Classe DedCommAnagExplorer
Namespace DedNet.Controls


Eventi di DedCommAnagExplorer

Il tipo DedCommAnagExplorer espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | ContextMenuOpening | Evento su apertura del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | MenuItemClicked | Evento su click su un elemento del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | MyMouseDoubleClick |
Evento pubblico | PaintEx | (Ereditato da XtraUserControl)
Evento pubblico | SelectionChanged |
Torna su
Vedi anche

Documentazione

Classe DedCommAnagExplorer
Namespace DedNet.Controls


Evento DedCommAnagExplorer.MyMouseDoubleClick

Evento DedCommAnagExplorerMyMouseDoubleClick

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event MouseEventHandler MyMouseDoubleClick
Public Event MyMouseDoubleClick As MouseEventHandler
public:
 event MouseEventHandler^ MyMouseDoubleClick {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}
member MyMouseDoubleClick : IEvent<MouseEventHandler,
    MouseEventArgs>

Valore

MouseEventHandler
Vedi anche

Documentazione

Classe DedCommAnagExplorer
Namespace DedNet.Controls


Evento DedCommAnagExplorer.SelectionChanged

Evento DedCommAnagExplorerSelectionChanged

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler SelectionChanged
Public Event SelectionChanged As EventHandler
public:
 event EventHandler^ SelectionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member SelectionChanged : IEvent<EventHandler,
    EventArgs>

Valore

EventHandler
Vedi anche

Documentazione

Classe DedCommAnagExplorer
Namespace DedNet.Controls


Campi di DedCommAnagExplorer

Il tipo DedCommAnagExplorer espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | _app | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Campo protetto | _RegistryBaseKey | Chiave nel registro di sistema di salvataggio impostazioni. (Ereditato da UserControlBase)
Torna su
Vedi anche

Documentazione

Classe DedCommAnagExplorer
Namespace DedNet.Controls


Classe DedCommAnagExplorer.CommAnagWrapper

Classe DedCommAnagExplorerCommAnagWrapper
Gestione visualizzazione singola commessa
Gerarchia di ereditarietà
SystemObject
DedNet.ControlsDedCommAnagExplorerCommAnagWrapper

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class CommAnagWrapper
Public Class CommAnagWrapper
public ref class CommAnagWrapper
type CommAnagWrapper = class end

Il tipo DedCommAnagExplorerCommAnagWrapper espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | DataHasOnlyEcr | Indica se TUTTI gli ECO associati alla commessa sono in realtà degli ECR.
Proprietà pubblica | NumEco |
Proprietà pubblica | NumEcr |
Proprietà pubblica | Qta |
Proprietà pubblica | TagAnag |
Proprietà pubblica | TotelEcoEcr |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | GetAnagr |
Metodo pubblico | GetDedCommAnagrItem |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Proprietà di CommAnagWrapper

Il tipo DedCommAnagExplorerCommAnagWrapper espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | DataHasOnlyEcr | Indica se TUTTI gli ECO associati alla commessa sono in realtà degli ECR.
Proprietà pubblica | NumEco |
Proprietà pubblica | NumEcr |
Proprietà pubblica | Qta |
Proprietà pubblica | TagAnag |
Proprietà pubblica | TotelEcoEcr |
Torna su
Vedi anche

Documentazione

Classe DedCommAnagExplorerCommAnagWrapper
Namespace DedNet.Controls


Proprietà DedCommAnagExplorer.CommAnagWrapper.DataHasOnlyEcr

Proprietà DedCommAnagExplorerCommAnagWrapperDataHasOnlyEcr
Indica se TUTTI gli ECO associati alla commessa sono in realtà degli ECR.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool DataHasOnlyEcr { get; }
Public ReadOnly Property DataHasOnlyEcr As Boolean
    Get
public:
property bool DataHasOnlyEcr {
    bool get ();
}
member DataHasOnlyEcr : bool with get

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedCommAnagExplorerCommAnagWrapper
Namespace DedNet.Controls


Proprietà DedCommAnagExplorer.CommAnagWrapper.NumEco

Proprietà DedCommAnagExplorerCommAnagWrapperNumEco

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int NumEco { get; }
Public ReadOnly Property NumEco As Integer
    Get
public:
property int NumEco {
    int get ();
}
member NumEco : int with get

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe DedCommAnagExplorerCommAnagWrapper
Namespace DedNet.Controls


Proprietà DedCommAnagExplorer.CommAnagWrapper.NumEcr

Proprietà DedCommAnagExplorerCommAnagWrapperNumEcr

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int NumEcr { get; }
Public ReadOnly Property NumEcr As Integer
    Get
public:
property int NumEcr {
    int get ();
}
member NumEcr : int with get

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe DedCommAnagExplorerCommAnagWrapper
Namespace DedNet.Controls


Proprietà DedCommAnagExplorer.CommAnagWrapper.Qta

Proprietà DedCommAnagExplorerCommAnagWrapperQta

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public double Qta { get; set; }
Public Property Qta As Double
    Get
    Set
public:
property double Qta {
    double get ();
    void set (double value);
}
member Qta : float with get, set

Valore della proprietà

Double
Vedi anche

Documentazione

Classe DedCommAnagExplorerCommAnagWrapper
Namespace DedNet.Controls


Proprietà DedCommAnagExplorer.CommAnagWrapper.TagAnag

Proprietà DedCommAnagExplorerCommAnagWrapperTagAnag

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData TagAnag { get; set; }
Public Property TagAnag As DedData
    Get
    Set
public:
property DedData^ TagAnag {
    DedData^ get ();
    void set (DedData^ value);
}
member TagAnag : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe DedCommAnagExplorerCommAnagWrapper
Namespace DedNet.Controls


Proprietà DedCommAnagExplorer.CommAnagWrapper.TotelEcoEcr

Proprietà DedCommAnagExplorerCommAnagWrapperTotelEcoEcr

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int TotelEcoEcr { get; }
Public ReadOnly Property TotelEcoEcr As Integer
    Get
public:
property int TotelEcoEcr {
    int get ();
}
member TotelEcoEcr : int with get

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe DedCommAnagExplorerCommAnagWrapper
Namespace DedNet.Controls


Metodi di CommAnagWrapper

Il tipo DedCommAnagExplorerCommAnagWrapper espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | GetAnagr |
Metodo pubblico | GetDedCommAnagrItem |
Torna su
Vedi anche

Documentazione

Classe DedCommAnagExplorerCommAnagWrapper
Namespace DedNet.Controls


Metodo DedCommAnagExplorer.CommAnagWrapper.GetAnagr

Metodo DedCommAnagExplorerCommAnagWrapperGetAnagr

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData GetAnagr()
Public Function GetAnagr As DedData
public:
DedData^ GetAnagr()
member GetAnagr : unit -> DedData

Valore di ritorno

DedData
Vedi anche

Documentazione

Classe DedCommAnagExplorerCommAnagWrapper
Namespace DedNet.Controls


Metodo DedCommAnagExplorer.CommAnagWrapper.GetDedCommAnagrItem

Metodo DedCommAnagExplorerCommAnagWrapperGetDedCommAnagrItem

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommAnagrItem GetDedCommAnagrItem()
Public Function GetDedCommAnagrItem As DedCommAnagrItem
public:
DedCommAnagrItem^ GetDedCommAnagrItem()
member GetDedCommAnagrItem : unit -> DedCommAnagrItem

Valore di ritorno

DedCommAnagrItem
Vedi anche

Documentazione

Classe DedCommAnagExplorerCommAnagWrapper
Namespace DedNet.Controls


Classe DedCommAnagExplorer.TagStructure

Classe DedCommAnagExplorerTagStructure
Gerarchia di ereditarietà
SystemObject
DedNet.ControlsDedCommAnagExplorerTagStructure

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class TagStructure
Public Class TagStructure
public ref class TagStructure
type TagStructure = class end

Il tipo DedCommAnagExplorerTagStructure espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedCommAnagExplorerTagStructure |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Attr |
Proprietà pubblica | Env |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore DedCommAnagExplorer.TagStructure

Costruttore DedCommAnagExplorerTagStructure

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public TagStructure(
    DedAttr attr,
    DedAttrEnvDestEnum env
)
Public Sub New (
    attr As DedAttr,
    env As DedAttrEnvDestEnum
)
public:
TagStructure(
    DedAttr^ attr,
    DedAttrEnvDestEnum env
)
new :
        attr : DedAttr *
        env : DedAttrEnvDestEnum -> TagStructure

Parametri

attr DedAttr
env DedAttrEnvDestEnum
Vedi anche

Documentazione

Classe DedCommAnagExplorerTagStructure
Namespace DedNet.Controls


Proprietà di TagStructure

Il tipo DedCommAnagExplorerTagStructure espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Attr |
Proprietà pubblica | Env |
Torna su
Vedi anche

Documentazione

Classe DedCommAnagExplorerTagStructure
Namespace DedNet.Controls


Proprietà DedCommAnagExplorer.TagStructure.Attr

Proprietà DedCommAnagExplorerTagStructureAttr

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttr Attr { get; }
Public ReadOnly Property Attr As DedAttr
    Get
public:
property DedAttr^ Attr {
    DedAttr^ get ();
}
member Attr : DedAttr with get

Valore della proprietà

DedAttr
Vedi anche

Documentazione

Classe DedCommAnagExplorerTagStructure
Namespace DedNet.Controls


Proprietà DedCommAnagExplorer.TagStructure.Env

Proprietà DedCommAnagExplorerTagStructureEnv

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrEnvDestEnum Env { get; }
Public ReadOnly Property Env As DedAttrEnvDestEnum
    Get
public:
property DedAttrEnvDestEnum Env {
    DedAttrEnvDestEnum get ();
}
member Env : DedAttrEnvDestEnum with get

Valore della proprietà

DedAttrEnvDestEnum
Vedi anche

Documentazione

Classe DedCommAnagExplorerTagStructure
Namespace DedNet.Controls


Classe DedCommStructExplorer
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
XtraUserControl
DedNet.ControlsUserControlBase
DedNet.ControlsDedCommStructExplorer

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedCommStructExplorer : UserControlBase
Public Class DedCommStructExplorer
    Inherits UserControlBase
public ref class DedCommStructExplorer : public UserControlBase
type DedCommStructExplorer =
    class
        inherit UserControlBase
    end

Il tipo DedCommStructExplorer espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedCommStructExplorer | Costruttore del controllo
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllImplData |
Proprietà pubblica | AllLev | Indica se visualizzare anche le commesse collegate tramite la distinta implosa del codice.
Proprietà pubblica | Anagr | Restituisce o Imposta l'anagrafica della quale vedere le commesse.
Proprietà pubblica | Appearance | (Ereditato da XtraUserControl)
Proprietà pubblica | Application | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Proprietà pubblica | BackColor | (Ereditato da XtraUserControl)
Proprietà protetta | CheckDoubleScaling | (Ereditato da XtraUserControl)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraUserControl)
Proprietà protetta | DirectXContainer | (Ereditato da XtraUserControl)
Proprietà pubblica | DisableStandardCtx | Indica se disabilitare il menu constestuale stantard
Proprietà pubblica | EnableIXtraResizeableControlInterfaceProxy | (Ereditato da XtraUserControl)
Proprietà pubblica | Font | (Ereditato da XtraUserControl)
Proprietà pubblica | ForeColor | (Ereditato da XtraUserControl)
Proprietà pubblica | FreeTextSearch | Restituisce o Imposta il testo libero di ricerca.
Proprietà protetta | Helper | (Ereditato da XtraUserControl)
Proprietà pubblica | HideToolbar | Indica se disabilitare la toolbar.
Proprietà pubblica | IsDragging | Proprietà che indica se il controllo è in fase di dragging
Proprietà pubblica | LookAndFeel | (Ereditato da XtraUserControl)
Proprietà pubblica | MainFormRegistryKey | Chiave di registro
Proprietà protetta | Painter | (Ereditato da XtraUserControl)
Proprietà pubblica | RegistryCommPanelKey | Restituisce o imposta la chiave per i settaggi del pannello delle commesse.
Proprietà protetta | ScaleChildren | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleDPI | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraUserControl)
Proprietà pubblica | SelectedType | Famiglia selezionata
Proprietà pubblica | SelectedTypes | Lista delle tipologie selezionate
Proprietà protetta | ShouldCheckDpiScaleFactorOnParentChanged | (Ereditato da XtraUserControl)
Proprietà pubblica | Site | (Ereditato da XtraUserControl)
Proprietà pubblica | UseParentSorting | Indica se le griglie figlie devono utilizzare lo stesso ordinamento presente nella griglia padre. Di default è False;
Proprietà pubblica | ViewMode | Indica se il controllo è in modalità view o no.
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | BaseWndProc | (Ereditato da XtraUserControl)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraUserControl)
Metodo protetto | CreatePainter | (Ereditato da XtraUserControl)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive UserControlBaseDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraUserControl)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraUserControl)
Metodo pubblico | DropAnagrData(DragEventArgs, DedCommAnagExplorerCommAnagWrapper) | Inserisce l'anagrafica draggata da altri controlli
Metodo pubblico | DropAnagrData(DragEventArgs, DedData) | Inserisce l'anagrafica draggata da altri controlli
Metodo pubblico | DropComm |
Metodo pubblico | DropDocs | Inserisce l'anagrafica draggata da altri controlli
Metodo pubblico | FireSelection | Evento per far scattare un cambio di selezione.
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraUserControl)
Metodo protetto | GetBackColor | (Ereditato da XtraUserControl)
Metodo protetto | GetBackgroundSkinElement | (Ereditato da XtraUserControl)
Metodo protetto | GetInnerIXtraResizableControl | (Ereditato da XtraUserControl)
Metodo protetto | IsChildControlsRequiredScalingEnabled | (Ereditato da XtraUserControl)
Metodo protetto | IsParentHandleCreatedRecursive | (Ereditato da XtraUserControl)
Metodo pubblico | LoadComm | Metodo pubblico per il caricamento delle commmesse
Metodo pubblico | NavigateDetails | Scorre tutte le viste finche non trova la commessa desiderata.
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraUserControl)
Metodo protetto | OnBackColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnContextMenuOpening | Evento di apertura del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnControlAdded | (Ereditato da XtraUserControl)
Metodo protetto | OnControlRemoved | (Ereditato da XtraUserControl)
Metodo protetto | OnDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnFirstLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnForeColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleCreated | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraUserControl)
Metodo protetto | OnLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnMenuItemClicked | Evento di pressione di un comando del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnMouseDown |
Metodo protetto | OnOverrideRepositoryIconComm | Lancia l'evento per effettuare override del repository delle commesse.
Metodo protetto | OnOverrideStatusIconComm | Lancia l'evento per effettuare override delle icone delle commesse.
Metodo protetto | OnPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnPaintCore | (Ereditato da XtraUserControl)
Metodo protetto | OnParentChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | OnSizeChanged | (Ereditato da XtraUserControl)
Metodo protetto | RaisePaintExEvent | (Ereditato da XtraUserControl)
Metodo pubblico | RefreshAttributePanel | Aggiorna il pannello degli attributi
Metodo pubblico | ResetBackColor | (Ereditato da XtraUserControl)
Metodo pubblico | ResetForeColor | (Ereditato da XtraUserControl)
Metodo protetto | RestoreAutoScaleModeChangedByPM2 | (Ereditato da XtraUserControl)
Metodo pubblico | SaveRegistrySettings | Salvataggio dati nel registro
Metodo protetto | ScaleControl | (Ereditato da XtraUserControl)
Metodo pubblico | SearchSelectedComm | Metodo che ricerca in modo ricorsivo la view contenente il nodo da selezionare
Metodo pubblico | SetCommandList | Rigenera il menu contestuale di questo controllo con la lista dei comandi passati. (Ereditato da UserControlBase)
Metodo pubblico | SetFocusOnComm | Imposta il focus su una determinata commessa.
Metodo protetto | SetVisibleCore | (Ereditato da XtraUserControl)
Metodo protetto | ShouldPaintTransparentBackground | (Ereditato da XtraUserControl)
Metodo protetto | ShouldUseDirectXPaint | (Ereditato da XtraUserControl)
Metodo pubblico | UserCanDropAnag | Controllo se l'utente può rilasciare delle anagrafiche
Metodo pubblico | UserCanDropComm | Controllo se l'utente può effettuare il dragging per la riorganizzazione delle commesse
Metodo pubblico | UserCanDropDocs | Controllo se l'utente può rilasciare dei documenti
Metodo protetto | WndProc | (Ereditato da XtraUserControl)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | CommDataChanged |
Evento pubblico | ContextMenuOpening | Evento su apertura del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | MenuItemClicked | Evento su click su un elemento del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | MyMouseDown | Evento per la gestione del movimento del mouse.
Evento pubblico | OverrideRepositoryIconComm | Evento per override del repository delle icone delle commesse.
Evento pubblico | OverrideStatusIconComm | Evento per override icone delle commesse.
Evento pubblico | PaintEx | (Ereditato da XtraUserControl)
Evento pubblico | SelectedCommChanged |
Torna su
Campi
 | Nome | Descrizione
Campo protetto | _app | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Campo protetto | _RegistryBaseKey | Chiave nel registro di sistema di salvataggio impostazioni. (Ereditato da UserControlBase)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore DedCommStructExplorer
Costruttore del controllo

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommStructExplorer()
Public Sub New
public:
DedCommStructExplorer()
new : unit -> DedCommStructExplorer
Vedi anche

Documentazione

Classe DedCommStructExplorer
Namespace DedNet.Controls


Proprietà di DedCommStructExplorer

Il tipo DedCommStructExplorer espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllImplData |
Proprietà pubblica | AllLev | Indica se visualizzare anche le commesse collegate tramite la distinta implosa del codice.
Proprietà pubblica | Anagr | Restituisce o Imposta l'anagrafica della quale vedere le commesse.
Proprietà pubblica | Appearance | (Ereditato da XtraUserControl)
Proprietà pubblica | Application | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Proprietà pubblica | BackColor | (Ereditato da XtraUserControl)
Proprietà protetta | CheckDoubleScaling | (Ereditato da XtraUserControl)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraUserControl)
Proprietà protetta | DirectXContainer | (Ereditato da XtraUserControl)
Proprietà pubblica | DisableStandardCtx | Indica se disabilitare il menu constestuale stantard
Proprietà pubblica | EnableIXtraResizeableControlInterfaceProxy | (Ereditato da XtraUserControl)
Proprietà pubblica | Font | (Ereditato da XtraUserControl)
Proprietà pubblica | ForeColor | (Ereditato da XtraUserControl)
Proprietà pubblica | FreeTextSearch | Restituisce o Imposta il testo libero di ricerca.
Proprietà protetta | Helper | (Ereditato da XtraUserControl)
Proprietà pubblica | HideToolbar | Indica se disabilitare la toolbar.
Proprietà pubblica | IsDragging | Proprietà che indica se il controllo è in fase di dragging
Proprietà pubblica | LookAndFeel | (Ereditato da XtraUserControl)
Proprietà pubblica | MainFormRegistryKey | Chiave di registro
Proprietà protetta | Painter | (Ereditato da XtraUserControl)
Proprietà pubblica | RegistryCommPanelKey | Restituisce o imposta la chiave per i settaggi del pannello delle commesse.
Proprietà protetta | ScaleChildren | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleDPI | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraUserControl)
Proprietà pubblica | SelectedType | Famiglia selezionata
Proprietà pubblica | SelectedTypes | Lista delle tipologie selezionate
Proprietà protetta | ShouldCheckDpiScaleFactorOnParentChanged | (Ereditato da XtraUserControl)
Proprietà pubblica | Site | (Ereditato da XtraUserControl)
Proprietà pubblica | UseParentSorting | Indica se le griglie figlie devono utilizzare lo stesso ordinamento presente nella griglia padre. Di default è False;
Proprietà pubblica | ViewMode | Indica se il controllo è in modalità view o no.
Torna su
Vedi anche

Documentazione

Classe DedCommStructExplorer
Namespace DedNet.Controls


Proprietà DedCommStructExplorer.AllImplData

Proprietà DedCommStructExplorerAllImplData

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataList AllImplData { get; set; }
Public Property AllImplData As DedDataList
    Get
    Set
public:
property DedDataList^ AllImplData {
    DedDataList^ get ();
    void set (DedDataList^ value);
}
member AllImplData : DedDataList with get, set

Valore della proprietà

DedDataList
Vedi anche

Documentazione

Classe DedCommStructExplorer
Namespace DedNet.Controls


Proprietà DedCommStructExplorer.AllLev

Proprietà DedCommStructExplorerAllLev
Indica se visualizzare anche le commesse collegate tramite la distinta implosa del codice.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AllLev { get; set; }
Public Property AllLev As Boolean
    Get
    Set
public:
property bool AllLev {
    bool get ();
    void set (bool value);
}
member AllLev : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedCommStructExplorer
Namespace DedNet.Controls


Proprietà DedCommStructExplorer.Anagr

Proprietà DedCommStructExplorerAnagr
Restituisce o Imposta l'anagrafica della quale vedere le commesse.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Anagr { get; set; }
Public Property Anagr As DedData
    Get
    Set
public:
property DedData^ Anagr {
    DedData^ get ();
    void set (DedData^ value);
}
member Anagr : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe DedCommStructExplorer
Namespace DedNet.Controls


Proprietà DedCommStructExplorer.DisableStandardCtx

Proprietà DedCommStructExplorerDisableStandardCtx
Indica se disabilitare il menu constestuale stantard

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool DisableStandardCtx { get; set; }
Public Property DisableStandardCtx As Boolean
    Get
    Set
public:
property bool DisableStandardCtx {
    bool get ();
    void set (bool value);
}
member DisableStandardCtx : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedCommStructExplorer
Namespace DedNet.Controls


Proprietà DedCommStructExplorer.FreeTextSearch

Proprietà DedCommStructExplorerFreeTextSearch
Restituisce o Imposta il testo libero di ricerca.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string FreeTextSearch { get; set; }
Public Property FreeTextSearch As String
    Get
    Set
public:
property String^ FreeTextSearch {
    String^ get ();
    void set (String^ value);
}
member FreeTextSearch : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedCommStructExplorer
Namespace DedNet.Controls


Proprietà DedCommStructExplorer.HideToolbar

Proprietà DedCommStructExplorerHideToolbar
Indica se disabilitare la toolbar.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HideToolbar { set; }
Public WriteOnly Property HideToolbar As Boolean
    Set
public:
property bool HideToolbar {
    void set (bool value);
}
member HideToolbar : bool with set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedCommStructExplorer
Namespace DedNet.Controls


Proprietà DedCommStructExplorer.IsDragging

Proprietà DedCommStructExplorerIsDragging
Proprietà che indica se il controllo è in fase di dragging

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsDragging { get; }
Public ReadOnly Property IsDragging As Boolean
    Get
public:
property bool IsDragging {
    bool get ();
}
member IsDragging : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedCommStructExplorer
Namespace DedNet.Controls


Proprietà DedCommStructExplorer.MainFormRegistryKey

Proprietà DedCommStructExplorerMainFormRegistryKey
Chiave di registro

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string MainFormRegistryKey { get; set; }
Public Property MainFormRegistryKey As String
    Get
    Set
public:
property String^ MainFormRegistryKey {
    String^ get ();
    void set (String^ value);
}
member MainFormRegistryKey : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedCommStructExplorer
Namespace DedNet.Controls


Proprietà DedCommStructExplorer.RegistryCommPanelKey

Proprietà DedCommStructExplorerRegistryCommPanelKey
Restituisce o imposta la chiave per i settaggi del pannello delle commesse.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string RegistryCommPanelKey { get; set; }
Public Property RegistryCommPanelKey As String
    Get
    Set
public:
property String^ RegistryCommPanelKey {
    String^ get ();
    void set (String^ value);
}
member RegistryCommPanelKey : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedCommStructExplorer
Namespace DedNet.Controls


Proprietà DedCommStructExplorer.SelectedType

Proprietà DedCommStructExplorerSelectedType
Famiglia selezionata

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommType SelectedType { get; set; }
Public Property SelectedType As DedCommType
    Get
    Set
public:
property DedCommType^ SelectedType {
    DedCommType^ get ();
    void set (DedCommType^ value);
}
member SelectedType : DedCommType with get, set

Valore della proprietà

DedCommType
Vedi anche

Documentazione

Classe DedCommStructExplorer
Namespace DedNet.Controls


Proprietà DedCommStructExplorer.SelectedTypes

Proprietà DedCommStructExplorerSelectedTypes
Lista delle tipologie selezionate

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommTypeList SelectedTypes { get; set; }
Public Property SelectedTypes As DedCommTypeList
    Get
    Set
public:
property DedCommTypeList^ SelectedTypes {
    DedCommTypeList^ get ();
    void set (DedCommTypeList^ value);
}
member SelectedTypes : DedCommTypeList with get, set

Valore della proprietà

DedCommTypeList
Vedi anche

Documentazione

Classe DedCommStructExplorer
Namespace DedNet.Controls


Proprietà DedCommStructExplorer.UseParentSorting

Proprietà DedCommStructExplorerUseParentSorting
Indica se le griglie figlie devono utilizzare lo stesso ordinamento presente nella griglia padre. Di default è False;

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool UseParentSorting { get; set; }
Public Property UseParentSorting As Boolean
    Get
    Set
public:
property bool UseParentSorting {
    bool get ();
    void set (bool value);
}
member UseParentSorting : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedCommStructExplorer
Namespace DedNet.Controls


Proprietà DedCommStructExplorer.ViewMode

Proprietà DedCommStructExplorerViewMode
Indica se il controllo è in modalità view o no.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ViewMode { get; set; }
Public Property ViewMode As Boolean
    Get
    Set
public:
property bool ViewMode {
    bool get ();
    void set (bool value);
}
member ViewMode : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedCommStructExplorer
Namespace DedNet.Controls


Metodi di DedCommStructExplorer

Il tipo DedCommStructExplorer espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | BaseWndProc | (Ereditato da XtraUserControl)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraUserControl)
Metodo protetto | CreatePainter | (Ereditato da XtraUserControl)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive UserControlBaseDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraUserControl)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraUserControl)
Metodo pubblico | DropAnagrData(DragEventArgs, DedCommAnagExplorerCommAnagWrapper) | Inserisce l'anagrafica draggata da altri controlli
Metodo pubblico | DropAnagrData(DragEventArgs, DedData) | Inserisce l'anagrafica draggata da altri controlli
Metodo pubblico | DropComm |
Metodo pubblico | DropDocs | Inserisce l'anagrafica draggata da altri controlli
Metodo pubblico | FireSelection | Evento per far scattare un cambio di selezione.
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraUserControl)
Metodo protetto | GetBackColor | (Ereditato da XtraUserControl)
Metodo protetto | GetBackgroundSkinElement | (Ereditato da XtraUserControl)
Metodo protetto | GetInnerIXtraResizableControl | (Ereditato da XtraUserControl)
Metodo protetto | IsChildControlsRequiredScalingEnabled | (Ereditato da XtraUserControl)
Metodo protetto | IsParentHandleCreatedRecursive | (Ereditato da XtraUserControl)
Metodo pubblico | LoadComm | Metodo pubblico per il caricamento delle commmesse
Metodo pubblico | NavigateDetails | Scorre tutte le viste finche non trova la commessa desiderata.
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraUserControl)
Metodo protetto | OnBackColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnContextMenuOpening | Evento di apertura del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnControlAdded | (Ereditato da XtraUserControl)
Metodo protetto | OnControlRemoved | (Ereditato da XtraUserControl)
Metodo protetto | OnDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnFirstLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnForeColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleCreated | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraUserControl)
Metodo protetto | OnLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnMenuItemClicked | Evento di pressione di un comando del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnMouseDown |
Metodo protetto | OnOverrideRepositoryIconComm | Lancia l'evento per effettuare override del repository delle commesse.
Metodo protetto | OnOverrideStatusIconComm | Lancia l'evento per effettuare override delle icone delle commesse.
Metodo protetto | OnPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnPaintCore | (Ereditato da XtraUserControl)
Metodo protetto | OnParentChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | OnSizeChanged | (Ereditato da XtraUserControl)
Metodo protetto | RaisePaintExEvent | (Ereditato da XtraUserControl)
Metodo pubblico | RefreshAttributePanel | Aggiorna il pannello degli attributi
Metodo pubblico | ResetBackColor | (Ereditato da XtraUserControl)
Metodo pubblico | ResetForeColor | (Ereditato da XtraUserControl)
Metodo protetto | RestoreAutoScaleModeChangedByPM2 | (Ereditato da XtraUserControl)
Metodo pubblico | SaveRegistrySettings | Salvataggio dati nel registro
Metodo protetto | ScaleControl | (Ereditato da XtraUserControl)
Metodo pubblico | SearchSelectedComm | Metodo che ricerca in modo ricorsivo la view contenente il nodo da selezionare
Metodo pubblico | SetCommandList | Rigenera il menu contestuale di questo controllo con la lista dei comandi passati. (Ereditato da UserControlBase)
Metodo pubblico | SetFocusOnComm | Imposta il focus su una determinata commessa.
Metodo protetto | SetVisibleCore | (Ereditato da XtraUserControl)
Metodo protetto | ShouldPaintTransparentBackground | (Ereditato da XtraUserControl)
Metodo protetto | ShouldUseDirectXPaint | (Ereditato da XtraUserControl)
Metodo pubblico | UserCanDropAnag | Controllo se l'utente può rilasciare delle anagrafiche
Metodo pubblico | UserCanDropComm | Controllo se l'utente può effettuare il dragging per la riorganizzazione delle commesse
Metodo pubblico | UserCanDropDocs | Controllo se l'utente può rilasciare dei documenti
Metodo protetto | WndProc | (Ereditato da XtraUserControl)
Torna su
Vedi anche

Documentazione

Classe DedCommStructExplorer
Namespace DedNet.Controls


Metodo DedCommStructExplorer.Dispose

Metodo DedCommStructExplorerDispose
Clean up any resources being used.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedCommStructExplorer
Namespace DedNet.Controls


Metodo DedCommStructExplorer.DropAnagrData

Metodo DedCommStructExplorerDropAnagrData
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | DropAnagrData(DragEventArgs, DedCommAnagExplorerCommAnagWrapper) | Inserisce l'anagrafica draggata da altri controlli
Metodo pubblico | DropAnagrData(DragEventArgs, DedData) | Inserisce l'anagrafica draggata da altri controlli
Torna su
Vedi anche

Documentazione

Classe DedCommStructExplorer
Namespace DedNet.Controls


Metodo DedCommStructExplorer.DropAnagrData(DragEventArgs, DedCommAnagExplorer.CommAnagWrapper)

Metodo DedCommStructExplorerDropAnagrData(DragEventArgs, DedCommAnagExplorerCommAnagWrapper)
Inserisce l'anagrafica draggata da altri controlli

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void DropAnagrData(
    DragEventArgs e,
    DedCommAnagExplorerCommAnagWrapper item
)
Public Sub DropAnagrData (
    e As DragEventArgs,
    item As DedCommAnagExplorerCommAnagWrapper
)
public:
void DropAnagrData(
    DragEventArgs^ e,
    DedCommAnagExplorerCommAnagWrapper^ item
)
member DropAnagrData :
        e : DragEventArgs *
        item : DedCommAnagExplorerCommAnagWrapper -> unit

Parametri

e DragEventArgs
item DedCommAnagExplorerCommAnagWrapper
Vedi anche

Documentazione

Classe DedCommStructExplorer
Overload di DropAnagrData
Namespace DedNet.Controls


Metodo DedCommStructExplorer.DropAnagrData(DragEventArgs, DedData)

Metodo DedCommStructExplorerDropAnagrData(DragEventArgs, DedData)
Inserisce l'anagrafica draggata da altri controlli

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void DropAnagrData(
    DragEventArgs e,
    DedData anag
)
Public Sub DropAnagrData (
    e As DragEventArgs,
    anag As DedData
)
public:
void DropAnagrData(
    DragEventArgs^ e,
    DedData^ anag
)
member DropAnagrData :
        e : DragEventArgs *
        anag : DedData -> unit

Parametri

e DragEventArgs
anag DedData
Vedi anche

Documentazione

Classe DedCommStructExplorer
Overload di DropAnagrData
Namespace DedNet.Controls


Metodo DedCommStructExplorer.DropComm

Metodo DedCommStructExplorerDropComm

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void DropComm(
    DragEventArgs e
)
Public Sub DropComm (
    e As DragEventArgs
)
public:
void DropComm(
    DragEventArgs^ e
)
member DropComm :
        e : DragEventArgs -> unit

Parametri

e DragEventArgs
Vedi anche

Documentazione

Classe DedCommStructExplorer
Namespace DedNet.Controls


Metodo DedCommStructExplorer.DropDocs

Metodo DedCommStructExplorerDropDocs
Inserisce l'anagrafica draggata da altri controlli

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void DropDocs(
    DragEventArgs e
)
Public Sub DropDocs (
    e As DragEventArgs
)
public:
void DropDocs(
    DragEventArgs^ e
)
member DropDocs :
        e : DragEventArgs -> unit

Parametri

e DragEventArgs
Vedi anche

Documentazione

Classe DedCommStructExplorer
Namespace DedNet.Controls


Metodo DedCommStructExplorer.FireSelection

Metodo DedCommStructExplorerFireSelection
Evento per far scattare un cambio di selezione.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void FireSelection()
Public Sub FireSelection
public:
void FireSelection()
member FireSelection : unit -> unit
Vedi anche

Documentazione

Classe DedCommStructExplorer
Namespace DedNet.Controls


Metodo DedCommStructExplorer.LoadComm

Metodo DedCommStructExplorerLoadComm
Metodo pubblico per il caricamento delle commmesse

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void LoadComm(
    bool refresh,
    string selectComm = null
)
Public Sub LoadComm (
    refresh As Boolean,
    Optional selectComm As String = Nothing
)
public:
void LoadComm(
    bool refresh,
    String^ selectComm = nullptr
)
member LoadComm :
        refresh : bool *
        ?selectComm : string
(* Defaults:
        let _selectComm = defaultArg selectComm null
*)
-> unit

Parametri

refresh Boolean
selectComm String (Optional)
Vedi anche

Documentazione

Classe DedCommStructExplorer
Namespace DedNet.Controls


Metodo DedCommStructExplorer.NavigateDetails

Metodo DedCommStructExplorerNavigateDetails
Scorre tutte le viste finche non trova la commessa desiderata.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool NavigateDetails(
    GridView inspectedView,
    string commname
)
Public Function NavigateDetails (
    inspectedView As GridView,
    commname As String
) As Boolean
public:
bool NavigateDetails(
    GridView^ inspectedView,
    String^ commname
)
member NavigateDetails :
        inspectedView : GridView *
        commname : string -> bool

Parametri

inspectedView GridView
Vista da analizzare.
commname String
Nome della commessa da ricercare.

Valore di ritorno

Boolean
Restituisce true se la trova.
Vedi anche

Documentazione

Classe DedCommStructExplorer
Namespace DedNet.Controls


Metodo DedCommStructExplorer.OnMouseDown

Metodo DedCommStructExplorerOnMouseDown

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected void OnMouseDown(
    Object sender,
    MouseEventArgs e
)
Protected Sub OnMouseDown (
    sender As Object,
    e As MouseEventArgs
)
protected:
void OnMouseDown(
    Object^ sender,
    MouseEventArgs^ e
)
member OnMouseDown :
        sender : Object *
        e : MouseEventArgs -> unit

Parametri

sender Object
e MouseEventArgs
Vedi anche

Documentazione

Classe DedCommStructExplorer
Namespace DedNet.Controls


Metodo DedCommStructExplorer.OnOverrideRepositoryIconComm

Metodo DedCommStructExplorerOnOverrideRepositoryIconComm
Lancia l'evento per effettuare override del repository delle commesse.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnOverrideRepositoryIconComm(
    DedCommStructExplorerDedOverrideRepositoryIconCommEventArgs e
)
Protected Friend Sub OnOverrideRepositoryIconComm (
    e As DedCommStructExplorerDedOverrideRepositoryIconCommEventArgs
)
protected public:
void OnOverrideRepositoryIconComm(
    DedCommStructExplorerDedOverrideRepositoryIconCommEventArgs^ e
)
member OnOverrideRepositoryIconComm :
        e : DedCommStructExplorerDedOverrideRepositoryIconCommEventArgs -> unit

Parametri

e DedCommStructExplorerDedOverrideRepositoryIconCommEventArgs
Vedi anche

Documentazione

Classe DedCommStructExplorer
Namespace DedNet.Controls


Metodo DedCommStructExplorer.OnOverrideStatusIconComm

Metodo DedCommStructExplorerOnOverrideStatusIconComm
Lancia l'evento per effettuare override delle icone delle commesse.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnOverrideStatusIconComm(
    DedCommStructExplorerDedOverrideStatusIconCommEventArgs e
)
Protected Friend Sub OnOverrideStatusIconComm (
    e As DedCommStructExplorerDedOverrideStatusIconCommEventArgs
)
protected public:
void OnOverrideStatusIconComm(
    DedCommStructExplorerDedOverrideStatusIconCommEventArgs^ e
)
member OnOverrideStatusIconComm :
        e : DedCommStructExplorerDedOverrideStatusIconCommEventArgs -> unit

Parametri

e DedCommStructExplorerDedOverrideStatusIconCommEventArgs
Vedi anche

Documentazione

Classe DedCommStructExplorer
Namespace DedNet.Controls


Metodo DedCommStructExplorer.RefreshAttributePanel

Metodo DedCommStructExplorerRefreshAttributePanel
Aggiorna il pannello degli attributi

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void RefreshAttributePanel()
Public Sub RefreshAttributePanel
public:
void RefreshAttributePanel()
member RefreshAttributePanel : unit -> unit
Vedi anche

Documentazione

Classe DedCommStructExplorer
Namespace DedNet.Controls


Metodo DedCommStructExplorer.SaveRegistrySettings

Metodo DedCommStructExplorerSaveRegistrySettings
Salvataggio dati nel registro

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SaveRegistrySettings()
Public Sub SaveRegistrySettings
public:
void SaveRegistrySettings()
member SaveRegistrySettings : unit -> unit
Vedi anche

Documentazione

Classe DedCommStructExplorer
Namespace DedNet.Controls


Metodo DedCommStructExplorer.SearchSelectedComm

Metodo DedCommStructExplorerSearchSelectedComm
Metodo che ricerca in modo ricorsivo la view contenente il nodo da selezionare

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SearchSelectedComm(
    GridView gridView,
    string[] comms,
    int countArray
)
Public Sub SearchSelectedComm (
    gridView As GridView,
    comms As String(),
    countArray As Integer
)
public:
void SearchSelectedComm(
    GridView^ gridView,
    array<String^>^ comms,
    int countArray
)
member SearchSelectedComm :
        gridView : GridView *
        comms : string[] *
        countArray : int -> unit

Parametri

gridView GridView
Vista da analizzare
comms String
Array di nomi delle commesse da cercare
countArray Int32
Numero di elementi presenti nell'array
Vedi anche

Documentazione

Classe DedCommStructExplorer
Namespace DedNet.Controls


Metodo DedCommStructExplorer.SetFocusOnComm

Metodo DedCommStructExplorerSetFocusOnComm
Imposta il focus su una determinata commessa.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetFocusOnComm(
    string commname
)
Public Sub SetFocusOnComm (
    commname As String
)
public:
void SetFocusOnComm(
    String^ commname
)
member SetFocusOnComm :
        commname : string -> unit

Parametri

commname String
Nome della commessa da selezionare.
Vedi anche

Documentazione

Classe DedCommStructExplorer
Namespace DedNet.Controls


Metodo DedCommStructExplorer.UserCanDropAnag

Metodo DedCommStructExplorerUserCanDropAnag
Controllo se l'utente può rilasciare delle anagrafiche

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool UserCanDropAnag(
    DragEventArgs e,
    DedComm _refComm
)
Public Function UserCanDropAnag (
    e As DragEventArgs,
    _refComm As DedComm
) As Boolean
public:
bool UserCanDropAnag(
    DragEventArgs^ e,
    DedComm^ _refComm
)
member UserCanDropAnag :
        e : DragEventArgs *
        _refComm : DedComm -> bool

Parametri

e DragEventArgs
_refComm DedComm

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedCommStructExplorer
Namespace DedNet.Controls


Metodo DedCommStructExplorer.UserCanDropComm

Metodo DedCommStructExplorerUserCanDropComm
Controllo se l'utente può effettuare il dragging per la riorganizzazione delle commesse

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool UserCanDropComm(
    DragEventArgs e
)
Public Function UserCanDropComm (
    e As DragEventArgs
) As Boolean
public:
bool UserCanDropComm(
    DragEventArgs^ e
)
member UserCanDropComm :
        e : DragEventArgs -> bool

Parametri

e DragEventArgs

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedCommStructExplorer
Namespace DedNet.Controls


Metodo DedCommStructExplorer.UserCanDropDocs

Metodo DedCommStructExplorerUserCanDropDocs
Controllo se l'utente può rilasciare dei documenti

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool UserCanDropDocs(
    DragEventArgs e
)
Public Function UserCanDropDocs (
    e As DragEventArgs
) As Boolean
public:
bool UserCanDropDocs(
    DragEventArgs^ e
)
member UserCanDropDocs :
        e : DragEventArgs -> bool

Parametri

e DragEventArgs

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedCommStructExplorer
Namespace DedNet.Controls


Eventi di DedCommStructExplorer

Il tipo DedCommStructExplorer espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | CommDataChanged |
Evento pubblico | ContextMenuOpening | Evento su apertura del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | MenuItemClicked | Evento su click su un elemento del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | MyMouseDown | Evento per la gestione del movimento del mouse.
Evento pubblico | OverrideRepositoryIconComm | Evento per override del repository delle icone delle commesse.
Evento pubblico | OverrideStatusIconComm | Evento per override icone delle commesse.
Evento pubblico | PaintEx | (Ereditato da XtraUserControl)
Evento pubblico | SelectedCommChanged |
Torna su
Vedi anche

Documentazione

Classe DedCommStructExplorer
Namespace DedNet.Controls


Evento DedCommStructExplorer.CommDataChanged

Evento DedCommStructExplorerCommDataChanged

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DedCommStructExplorerSelectedCommEventArgs> CommDataChanged
Public Event CommDataChanged As EventHandler(Of DedCommStructExplorerSelectedCommEventArgs)
public:
 event EventHandler<DedCommStructExplorerSelectedCommEventArgs^>^ CommDataChanged {
    void add (EventHandler<DedCommStructExplorerSelectedCommEventArgs^>^ value);
    void remove (EventHandler<DedCommStructExplorerSelectedCommEventArgs^>^ value);
}
member CommDataChanged : IEvent<EventHandler<DedCommStructExplorerSelectedCommEventArgs>,
    DedCommStructExplorerSelectedCommEventArgs>

Valore

EventHandler DedCommStructExplorerSelectedCommEventArgs
Vedi anche

Documentazione

Classe DedCommStructExplorer
Namespace DedNet.Controls


Evento DedCommStructExplorer.MyMouseDown

Evento DedCommStructExplorerMyMouseDown
Evento per la gestione del movimento del mouse.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<MouseEventArgs> MyMouseDown
Public Event MyMouseDown As EventHandler(Of MouseEventArgs)
public:
 event EventHandler<MouseEventArgs^>^ MyMouseDown {
    void add (EventHandler<MouseEventArgs^>^ value);
    void remove (EventHandler<MouseEventArgs^>^ value);
}
member MyMouseDown : IEvent<EventHandler<MouseEventArgs>,
    MouseEventArgs>

Valore

EventHandler MouseEventArgs
Vedi anche

Documentazione

Classe DedCommStructExplorer
Namespace DedNet.Controls


Evento DedCommStructExplorer.OverrideRepositoryIconComm

Evento DedCommStructExplorerOverrideRepositoryIconComm
Evento per override del repository delle icone delle commesse.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DedCommStructExplorerDedOverrideRepositoryIconCommEventArgs> OverrideRepositoryIconComm
Public Event OverrideRepositoryIconComm As EventHandler(Of DedCommStructExplorerDedOverrideRepositoryIconCommEventArgs)
public:
 event EventHandler<DedCommStructExplorerDedOverrideRepositoryIconCommEventArgs^>^ OverrideRepositoryIconComm {
    void add (EventHandler<DedCommStructExplorerDedOverrideRepositoryIconCommEventArgs^>^ value);
    void remove (EventHandler<DedCommStructExplorerDedOverrideRepositoryIconCommEventArgs^>^ value);
}
member OverrideRepositoryIconComm : IEvent<EventHandler<DedCommStructExplorerDedOverrideRepositoryIconCommEventArgs>,
    DedCommStructExplorerDedOverrideRepositoryIconCommEventArgs>

Valore

EventHandler DedCommStructExplorerDedOverrideRepositoryIconCommEventArgs
Vedi anche

Documentazione

Classe DedCommStructExplorer
Namespace DedNet.Controls


Evento DedCommStructExplorer.OverrideStatusIconComm

Evento DedCommStructExplorerOverrideStatusIconComm
Evento per override icone delle commesse.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DedCommStructExplorerDedOverrideStatusIconCommEventArgs> OverrideStatusIconComm
Public Event OverrideStatusIconComm As EventHandler(Of DedCommStructExplorerDedOverrideStatusIconCommEventArgs)
public:
 event EventHandler<DedCommStructExplorerDedOverrideStatusIconCommEventArgs^>^ OverrideStatusIconComm {
    void add (EventHandler<DedCommStructExplorerDedOverrideStatusIconCommEventArgs^>^ value);
    void remove (EventHandler<DedCommStructExplorerDedOverrideStatusIconCommEventArgs^>^ value);
}
member OverrideStatusIconComm : IEvent<EventHandler<DedCommStructExplorerDedOverrideStatusIconCommEventArgs>,
    DedCommStructExplorerDedOverrideStatusIconCommEventArgs>

Valore

EventHandler DedCommStructExplorerDedOverrideStatusIconCommEventArgs
Vedi anche

Documentazione

Classe DedCommStructExplorer
Namespace DedNet.Controls


Evento DedCommStructExplorer.SelectedCommChanged

Evento DedCommStructExplorerSelectedCommChanged

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DedCommStructExplorerSelectedCommEventArgs> SelectedCommChanged
Public Event SelectedCommChanged As EventHandler(Of DedCommStructExplorerSelectedCommEventArgs)
public:
 event EventHandler<DedCommStructExplorerSelectedCommEventArgs^>^ SelectedCommChanged {
    void add (EventHandler<DedCommStructExplorerSelectedCommEventArgs^>^ value);
    void remove (EventHandler<DedCommStructExplorerSelectedCommEventArgs^>^ value);
}
member SelectedCommChanged : IEvent<EventHandler<DedCommStructExplorerSelectedCommEventArgs>,
    DedCommStructExplorerSelectedCommEventArgs>

Valore

EventHandler DedCommStructExplorerSelectedCommEventArgs
Vedi anche

Documentazione

Classe DedCommStructExplorer
Namespace DedNet.Controls


Campi di DedCommStructExplorer

Il tipo DedCommStructExplorer espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | _app | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Campo protetto | _RegistryBaseKey | Chiave nel registro di sistema di salvataggio impostazioni. (Ereditato da UserControlBase)
Torna su
Vedi anche

Documentazione

Classe DedCommStructExplorer
Namespace DedNet.Controls


Classe DedCommStructExplorer.DedOverrideRepositoryIconCommEventArgs

Classe DedCommStructExplorerDedOverrideRepositoryIconCommEventArgs
Argomento utilizzato per override delle repository sulle commesse.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNet.ControlsDedCommStructExplorerDedOverrideRepositoryIconCommEventArgs

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedOverrideRepositoryIconCommEventArgs : EventArgs
Public Class DedOverrideRepositoryIconCommEventArgs
    Inherits EventArgs
public ref class DedOverrideRepositoryIconCommEventArgs : public EventArgs
type DedOverrideRepositoryIconCommEventArgs =
    class
        inherit EventArgs
    end

Il tipo DedCommStructExplorerDedOverrideRepositoryIconCommEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Handled |
Proprietà pubblica | Rep | Restituisce la lista delle famiglie selezionate.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Proprietà di DedOverrideRepositoryIconCommEventArgs

Il tipo DedCommStructExplorerDedOverrideRepositoryIconCommEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Handled |
Proprietà pubblica | Rep | Restituisce la lista delle famiglie selezionate.
Torna su
Vedi anche

Documentazione

Classe DedCommStructExplorerDedOverrideRepositoryIconCommEventArgs
Namespace DedNet.Controls


Proprietà DedCommStructExplorer.DedOverrideRepositoryIconCommEventArgs.Handled

Proprietà DedCommStructExplorerDedOverrideRepositoryIconCommEventArgsHandled

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Handled { get; set; }
Public Property Handled As Boolean
    Get
    Set
public:
property bool Handled {
    bool get ();
    void set (bool value);
}
member Handled : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedCommStructExplorerDedOverrideRepositoryIconCommEventArgs
Namespace DedNet.Controls


Proprietà DedCommStructExplorer.DedOverrideRepositoryIconCommEventArgs.Rep

Proprietà DedCommStructExplorerDedOverrideRepositoryIconCommEventArgsRep
Restituisce la lista delle famiglie selezionate.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public RepositoryItemImageComboBox Rep { get; }
Public ReadOnly Property Rep As RepositoryItemImageComboBox
    Get
public:
property RepositoryItemImageComboBox^ Rep {
    RepositoryItemImageComboBox^ get ();
}
member Rep : RepositoryItemImageComboBox with get

Valore della proprietà

RepositoryItemImageComboBox
Vedi anche

Documentazione

Classe DedCommStructExplorerDedOverrideRepositoryIconCommEventArgs
Namespace DedNet.Controls


Classe DedCommStructExplorer.DedOverrideStatusIconCommEventArgs

Classe DedCommStructExplorerDedOverrideStatusIconCommEventArgs
Argomento utilizzato per override delle icone sulle commesse.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNet.ControlsDedCommStructExplorerDedOverrideStatusIconCommEventArgs

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedOverrideStatusIconCommEventArgs : EventArgs
Public Class DedOverrideStatusIconCommEventArgs
    Inherits EventArgs
public ref class DedOverrideStatusIconCommEventArgs : public EventArgs
type DedOverrideStatusIconCommEventArgs =
    class
        inherit EventArgs
    end

Il tipo DedCommStructExplorerDedOverrideStatusIconCommEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Comm | Restituisce la lista delle famiglie selezionate.
Proprietà pubblica | Handled |
Proprietà pubblica | ImageName |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Proprietà di DedOverrideStatusIconCommEventArgs

Il tipo DedCommStructExplorerDedOverrideStatusIconCommEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Comm | Restituisce la lista delle famiglie selezionate.
Proprietà pubblica | Handled |
Proprietà pubblica | ImageName |
Torna su
Vedi anche

Documentazione

Classe DedCommStructExplorerDedOverrideStatusIconCommEventArgs
Namespace DedNet.Controls


Proprietà DedCommStructExplorer.DedOverrideStatusIconCommEventArgs.Comm

Proprietà DedCommStructExplorerDedOverrideStatusIconCommEventArgsComm
Restituisce la lista delle famiglie selezionate.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedComm Comm { get; }
Public ReadOnly Property Comm As DedComm
    Get
public:
property DedComm^ Comm {
    DedComm^ get ();
}
member Comm : DedComm with get

Valore della proprietà

DedComm
Vedi anche

Documentazione

Classe DedCommStructExplorerDedOverrideStatusIconCommEventArgs
Namespace DedNet.Controls


Proprietà DedCommStructExplorer.DedOverrideStatusIconCommEventArgs.Handled

Proprietà DedCommStructExplorerDedOverrideStatusIconCommEventArgsHandled

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Handled { get; set; }
Public Property Handled As Boolean
    Get
    Set
public:
property bool Handled {
    bool get ();
    void set (bool value);
}
member Handled : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedCommStructExplorerDedOverrideStatusIconCommEventArgs
Namespace DedNet.Controls


Proprietà DedCommStructExplorer.DedOverrideStatusIconCommEventArgs.ImageName

Proprietà DedCommStructExplorerDedOverrideStatusIconCommEventArgsImageName

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string ImageName { get; set; }
Public Property ImageName As String
    Get
    Set
public:
property String^ ImageName {
    String^ get ();
    void set (String^ value);
}
member ImageName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedCommStructExplorerDedOverrideStatusIconCommEventArgs
Namespace DedNet.Controls


Classe DedCommStructExplorer.SelectedCommEventArgs

Classe DedCommStructExplorerSelectedCommEventArgs
Classe Selected Comm
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNet.ControlsDedCommStructExplorerSelectedCommEventArgs

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class SelectedCommEventArgs : EventArgs
Public Class SelectedCommEventArgs
    Inherits EventArgs
public ref class SelectedCommEventArgs : public EventArgs
type SelectedCommEventArgs =
    class
        inherit EventArgs
    end

Il tipo DedCommStructExplorerSelectedCommEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Selection | Commessa Selezionata
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Proprietà di SelectedCommEventArgs

Il tipo DedCommStructExplorerSelectedCommEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Selection | Commessa Selezionata
Torna su
Vedi anche

Documentazione

Classe DedCommStructExplorerSelectedCommEventArgs
Namespace DedNet.Controls


Proprietà DedCommStructExplorer.SelectedCommEventArgs.Selection

Proprietà DedCommStructExplorerSelectedCommEventArgsSelection
Commessa Selezionata

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedComm Selection { get; }
Public ReadOnly Property Selection As DedComm
    Get
public:
property DedComm^ Selection {
    DedComm^ get ();
}
member Selection : DedComm with get

Valore della proprietà

DedComm
Vedi anche

Documentazione

Classe DedCommStructExplorerSelectedCommEventArgs
Namespace DedNet.Controls


Classe DedCustomDependency
Oggetto utilizzato per visualizzare a schermo una struttura gerarchica di tipo generico.
Gerarchia di ereditarietà
SystemObject
DedNet.ControlsDedCustomDependency

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedCustomDependency
Public Class DedCustomDependency
public ref class DedCustomDependency
type DedCustomDependency = class end

Il tipo DedCustomDependency espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedCustomDependency | Oggetto utilizzato per visualizzare a schermo una struttura gerarchica di tipo generico.
Metodo pubblico | DedCustomDependency(DedCustomDependency) | Oggetto utilizzato per visualizzare a schermo una struttura gerarchica di tipo generico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Children | Nome utilizzato per "ItemsPath property"
Proprietà pubblica | Config | Configurazione associata al documento
Proprietà pubblica | Data | Anagrafica di riferimento per l'oggetto
Proprietà pubblica | Description | Descrizione dell'oggetto
Proprietà pubblica | Document |
Proprietà pubblica | ID | Identificativo univoco dell'elemento corrente.
Proprietà pubblica | Name | Nome di riferimento dell'oggetto
Proprietà pubblica | Parent | Elemento genitore
Proprietà pubblica | ParentID | Identificativo univoco dell'elemento genitore.
Proprietà pubblica | Title | Titolo descrittivo dell'oggetto
Proprietà pubblica | Values | Valori da riportare a schermo.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | GetHashString |
Metodo pubblico | GetValue | Ritorna il valore della proprietà indicata.
Metodo pubblico | SetValue | Imposta il valore della proprietà indicata.
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Torna su
Campi
 | Nome | Descrizione
Campo pubblico | _children | Nome utilizzato per "ItemsPath property"
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore DedCustomDependency
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | DedCustomDependency | Oggetto utilizzato per visualizzare a schermo una struttura gerarchica di tipo generico.
Metodo pubblico | DedCustomDependency(DedCustomDependency) | Oggetto utilizzato per visualizzare a schermo una struttura gerarchica di tipo generico.
Torna su
Vedi anche

Documentazione

Classe DedCustomDependency
Namespace DedNet.Controls


Costruttore DedCustomDependency
Oggetto utilizzato per visualizzare a schermo una struttura gerarchica di tipo generico.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCustomDependency()
Public Sub New
public:
DedCustomDependency()
new : unit -> DedCustomDependency
Vedi anche

Documentazione

Classe DedCustomDependency
Overload di DedCustomDependency
Namespace DedNet.Controls


Costruttore DedCustomDependency(DedCustomDependency)
Oggetto utilizzato per visualizzare a schermo una struttura gerarchica di tipo generico.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCustomDependency(
    DedCustomDependency parent
)
Public Sub New (
    parent As DedCustomDependency
)
public:
DedCustomDependency(
    DedCustomDependency^ parent
)
new :
        parent : DedCustomDependency -> DedCustomDependency

Parametri

parent DedCustomDependency
Vedi anche

Documentazione

Classe DedCustomDependency
Overload di DedCustomDependency
Namespace DedNet.Controls


Proprietà di DedCustomDependency

Il tipo DedCustomDependency espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Children | Nome utilizzato per "ItemsPath property"
Proprietà pubblica | Config | Configurazione associata al documento
Proprietà pubblica | Data | Anagrafica di riferimento per l'oggetto
Proprietà pubblica | Description | Descrizione dell'oggetto
Proprietà pubblica | Document |
Proprietà pubblica | ID | Identificativo univoco dell'elemento corrente.
Proprietà pubblica | Name | Nome di riferimento dell'oggetto
Proprietà pubblica | Parent | Elemento genitore
Proprietà pubblica | ParentID | Identificativo univoco dell'elemento genitore.
Proprietà pubblica | Title | Titolo descrittivo dell'oggetto
Proprietà pubblica | Values | Valori da riportare a schermo.
Torna su
Vedi anche

Documentazione

Classe DedCustomDependency
Namespace DedNet.Controls


Proprietà DedCustomDependency.Children

Proprietà DedCustomDependencyChildren
Nome utilizzato per "ItemsPath property"

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ObservableCollection<DedCustomDependency> Children { get; set; }
Public Property Children As ObservableCollection(Of DedCustomDependency)
    Get
    Set
public:
property ObservableCollection<DedCustomDependency^>^ Children {
    ObservableCollection<DedCustomDependency^>^ get ();
    void set (ObservableCollection<DedCustomDependency^>^ value);
}
member Children : ObservableCollection<DedCustomDependency> with get, set

Valore della proprietà

ObservableCollection DedCustomDependency
Vedi anche

Documentazione

Classe DedCustomDependency
Namespace DedNet.Controls


Proprietà DedCustomDependency.Config

Proprietà DedCustomDependencyConfig
Configurazione associata al documento

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Config { get; set; }
Public Property Config As String
    Get
    Set
public:
property String^ Config {
    String^ get ();
    void set (String^ value);
}
member Config : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedCustomDependency
Namespace DedNet.Controls


Proprietà DedCustomDependency.Data

Proprietà DedCustomDependencyData
Anagrafica di riferimento per l'oggetto

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; set; }
Public Property Data As DedData
    Get
    Set
public:
property DedData^ Data {
    DedData^ get ();
    void set (DedData^ value);
}
member Data : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe DedCustomDependency
Namespace DedNet.Controls


Proprietà DedCustomDependency.Description

Proprietà DedCustomDependencyDescription
Descrizione dell'oggetto

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get
public:
property String^ Description {
    String^ get ();
}
member Description : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedCustomDependency
Namespace DedNet.Controls


Proprietà DedCustomDependency.Document

Proprietà DedCustomDependencyDocument

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDoc Document { get; set; }
Public Property Document As DedDoc
    Get
    Set
public:
property DedDoc^ Document {
    DedDoc^ get ();
    void set (DedDoc^ value);
}
member Document : DedDoc with get, set

Valore della proprietà

DedDoc
Vedi anche

Documentazione

Classe DedCustomDependency
Namespace DedNet.Controls


Proprietà DedCustomDependency.ID

Proprietà DedCustomDependencyID
Identificativo univoco dell'elemento corrente.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string ID { get; set; }
Public Property ID As String
    Get
    Set
public:
property String^ ID {
    String^ get ();
    void set (String^ value);
}
member ID : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedCustomDependency
Namespace DedNet.Controls


Proprietà DedCustomDependency.Name

Proprietà DedCustomDependencyName
Nome di riferimento dell'oggetto

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedCustomDependency
Namespace DedNet.Controls


Proprietà DedCustomDependency.Parent

Proprietà DedCustomDependencyParent
Elemento genitore

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCustomDependency Parent { get; set; }
Public Property Parent As DedCustomDependency
    Get
    Set
public:
property DedCustomDependency^ Parent {
    DedCustomDependency^ get ();
    void set (DedCustomDependency^ value);
}
member Parent : DedCustomDependency with get, set

Valore della proprietà

DedCustomDependency
Vedi anche

Documentazione

Classe DedCustomDependency
Namespace DedNet.Controls


Proprietà DedCustomDependency.ParentID

Proprietà DedCustomDependencyParentID
Identificativo univoco dell'elemento genitore.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string ParentID { get; }
Public ReadOnly Property ParentID As String
    Get
public:
property String^ ParentID {
    String^ get ();
}
member ParentID : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedCustomDependency
Namespace DedNet.Controls


Proprietà DedCustomDependency.Title

Proprietà DedCustomDependencyTitle
Titolo descrittivo dell'oggetto

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Title { get; }
Public ReadOnly Property Title As String
    Get
public:
property String^ Title {
    String^ get ();
}
member Title : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedCustomDependency
Namespace DedNet.Controls


Proprietà DedCustomDependency.Values

Proprietà DedCustomDependencyValues
Valori da riportare a schermo.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<string, Object> Values { get; }
Public ReadOnly Property Values As Dictionary(Of String, Object)
    Get
public:
property Dictionary<String^, Object^>^ Values {
    Dictionary<String^, Object^>^ get ();
}
member Values : Dictionary<string, Object> with get

Valore della proprietà

Dictionary String, Object
Vedi anche

Documentazione

Classe DedCustomDependency
Namespace DedNet.Controls


Metodi di DedCustomDependency

Il tipo DedCustomDependency espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | GetHashString |
Metodo pubblico | GetValue | Ritorna il valore della proprietà indicata.
Metodo pubblico | SetValue | Imposta il valore della proprietà indicata.
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Torna su
Vedi anche

Documentazione

Classe DedCustomDependency
Namespace DedNet.Controls


Metodo DedCustomDependency.Equals

Metodo DedCustomDependencyEquals

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj Object

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedCustomDependency
Namespace DedNet.Controls


Metodo DedCustomDependency.GetHashCode

Metodo DedCustomDependencyGetHashCode

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedCustomDependency
Namespace DedNet.Controls


Metodo DedCustomDependency.GetHashString

Metodo DedCustomDependencyGetHashString

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string GetHashString()
Public Function GetHashString As String
public:
String^ GetHashString()
member GetHashString : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedCustomDependency
Namespace DedNet.Controls


Metodo DedCustomDependency.GetValue

Metodo DedCustomDependencyGetValue
Ritorna il valore della proprietà indicata.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object GetValue(
    string property
)
Public Function GetValue (
    property As String
) As Object
public:
Object^ GetValue(
    String^ property
)
member GetValue :
        property : string -> Object

Parametri

property String

Valore di ritorno

Object
Vedi anche

Documentazione

Classe DedCustomDependency
Namespace DedNet.Controls


Metodo DedCustomDependency.SetValue

Metodo DedCustomDependencySetValue
Imposta il valore della proprietà indicata.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetValue(
    string property,
    Object val
)
Public Sub SetValue (
    property As String,
    val As Object
)
public:
void SetValue(
    String^ property,
    Object^ val
)
member SetValue :
        property : string *
        val : Object -> unit

Parametri

property String
val Object
Vedi anche

Documentazione

Classe DedCustomDependency
Namespace DedNet.Controls


Metodo DedCustomDependency.ToString

Metodo DedCustomDependencyToString

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedCustomDependency
Namespace DedNet.Controls


Campi di DedCustomDependency

Il tipo DedCustomDependency espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | _children | Nome utilizzato per "ItemsPath property"
Torna su
Vedi anche

Documentazione

Classe DedCustomDependency
Namespace DedNet.Controls


Campo DedCustomDependency._children

Campo DedCustomDependency_children
Nome utilizzato per "ItemsPath property"

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ObservableCollection<DedCustomDependency> _children
Public _children As ObservableCollection(Of DedCustomDependency)
public:
ObservableCollection<DedCustomDependency^>^ _children
val mutable _children: ObservableCollection<DedCustomDependency>

Valore del campo

ObservableCollection DedCustomDependency
Vedi anche

Documentazione

Classe DedCustomDependency
Namespace DedNet.Controls


Classe DedDependenciesControl
Controllo utilizzato per visualizzare una struttura gerarchica di dipendenze generiche.
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
XtraUserControl
DedNet.ControlsUserControlBase
DedNet.ControlsDedDependenciesControl

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedDependenciesControl : UserControlBase
Public Class DedDependenciesControl
    Inherits UserControlBase
public ref class DedDependenciesControl : public UserControlBase
type DedDependenciesControl =
    class
        inherit UserControlBase
    end

Il tipo DedDependenciesControl espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedDependenciesControl | Controllo utilizzato per visualizzare una struttura gerarchica di dipendenze generiche.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Appearance | (Ereditato da XtraUserControl)
Proprietà pubblica | Application | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Proprietà pubblica | BackColor | (Ereditato da XtraUserControl)
Proprietà protetta | CheckDoubleScaling | (Ereditato da XtraUserControl)
Proprietà pubblica | DataSource | Fonte dati da riportare nel controllo ad albero.
Proprietà protetta | DefaultAppearance | (Ereditato da XtraUserControl)
Proprietà protetta | DirectXContainer | (Ereditato da XtraUserControl)
Proprietà pubblica | EnableIXtraResizeableControlInterfaceProxy | (Ereditato da XtraUserControl)
Proprietà pubblica | Font | (Ereditato da XtraUserControl)
Proprietà pubblica | ForeColor | (Ereditato da XtraUserControl)
Proprietà protetta | Helper | (Ereditato da XtraUserControl)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraUserControl)
Proprietà pubblica | Message | Messaggio personalizzato da visualizzare.
Proprietà protetta | Painter | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleChildren | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleDPI | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraUserControl)
Proprietà protetta | ShouldCheckDpiScaleFactorOnParentChanged | (Ereditato da XtraUserControl)
Proprietà pubblica | ShowOnlyTree | Se viene effettuata l'impostazione di visualizzare solo l'albero nascondo gli altri controlli
Proprietà pubblica | Site | (Ereditato da XtraUserControl)
Proprietà pubblica | Tree | Albero contenente le dipendenze.
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | BaseWndProc | (Ereditato da XtraUserControl)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraUserControl)
Metodo protetto | CreatePainter | (Ereditato da XtraUserControl)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive UserControlBaseDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraUserControl)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraUserControl)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraUserControl)
Metodo protetto | GetBackColor | (Ereditato da XtraUserControl)
Metodo protetto | GetBackgroundSkinElement | (Ereditato da XtraUserControl)
Metodo protetto | GetInnerIXtraResizableControl | (Ereditato da XtraUserControl)
Metodo protetto | IsChildControlsRequiredScalingEnabled | (Ereditato da XtraUserControl)
Metodo protetto | IsParentHandleCreatedRecursive | (Ereditato da XtraUserControl)
Metodo pubblico | LoadBom | Data l'anagrafica specificata carica la distinta
Metodo pubblico | LoadDocStructInfo | Carica la struttura del DocStructInfo all'interno dell'albero. È possibile specificare se riportare la struttura a scendere (quindi dei figli) o a salire (quindi dei genitori).
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraUserControl)
Metodo protetto | OnBackColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnContextMenuOpening | Evento di apertura del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnControlAdded | (Ereditato da XtraUserControl)
Metodo protetto | OnControlRemoved | (Ereditato da XtraUserControl)
Metodo protetto | OnDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnFirstLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnForeColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleCreated | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraUserControl)
Metodo protetto | OnLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnMenuItemClicked | Evento di pressione di un comando del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnPaintCore | (Ereditato da XtraUserControl)
Metodo protetto | OnParentChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | OnSizeChanged | (Ereditato da XtraUserControl)
Metodo protetto | RaisePaintExEvent | (Ereditato da XtraUserControl)
Metodo pubblico | ResetBackColor | (Ereditato da XtraUserControl)
Metodo pubblico | ResetForeColor | (Ereditato da XtraUserControl)
Metodo protetto | RestoreAutoScaleModeChangedByPM2 | (Ereditato da XtraUserControl)
Metodo pubblico | RestoreLayoutFromRegistry | Ripristina il layout dei controlli leggendo le informazioni dal registro.
Metodo pubblico | SaveLayoutToRegistry | Salva il layout dei controlli all'interno del registro.
Metodo protetto | ScaleControl | (Ereditato da XtraUserControl)
Metodo pubblico | SetCommandList | Rigenera il menu contestuale di questo controllo con la lista dei comandi passati. (Ereditato da UserControlBase)
Metodo protetto | SetVisibleCore | (Ereditato da XtraUserControl)
Metodo protetto | ShouldPaintTransparentBackground | (Ereditato da XtraUserControl)
Metodo protetto | ShouldUseDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | WndProc | (Ereditato da XtraUserControl)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | ContextMenuOpening | Evento su apertura del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | CustomRowFilter | Evento associato al filtraggio del singolo nodo del treelist.
Evento pubblico | MenuItemClicked | Evento su click su un elemento del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | PaintEx | (Ereditato da XtraUserControl)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | _app | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Campo protetto | _RegistryBaseKey | Chiave nel registro di sistema di salvataggio impostazioni. (Ereditato da UserControlBase)
 | ANAG_COLUMN |
 | DESC_COLUMN |
 | DOC_COLUMN |
 | ID_COLUMN |
 | REV_COLUMN |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore DedDependenciesControl
Controllo utilizzato per visualizzare una struttura gerarchica di dipendenze generiche.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDependenciesControl()
Public Sub New
public:
DedDependenciesControl()
new : unit -> DedDependenciesControl
Vedi anche

Documentazione

Classe DedDependenciesControl
Namespace DedNet.Controls


Proprietà di DedDependenciesControl

Il tipo DedDependenciesControl espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Appearance | (Ereditato da XtraUserControl)
Proprietà pubblica | Application | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Proprietà pubblica | BackColor | (Ereditato da XtraUserControl)
Proprietà protetta | CheckDoubleScaling | (Ereditato da XtraUserControl)
Proprietà pubblica | DataSource | Fonte dati da riportare nel controllo ad albero.
Proprietà protetta | DefaultAppearance | (Ereditato da XtraUserControl)
Proprietà protetta | DirectXContainer | (Ereditato da XtraUserControl)
Proprietà pubblica | EnableIXtraResizeableControlInterfaceProxy | (Ereditato da XtraUserControl)
Proprietà pubblica | Font | (Ereditato da XtraUserControl)
Proprietà pubblica | ForeColor | (Ereditato da XtraUserControl)
Proprietà protetta | Helper | (Ereditato da XtraUserControl)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraUserControl)
Proprietà pubblica | Message | Messaggio personalizzato da visualizzare.
Proprietà protetta | Painter | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleChildren | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleDPI | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraUserControl)
Proprietà protetta | ShouldCheckDpiScaleFactorOnParentChanged | (Ereditato da XtraUserControl)
Proprietà pubblica | ShowOnlyTree | Se viene effettuata l'impostazione di visualizzare solo l'albero nascondo gli altri controlli
Proprietà pubblica | Site | (Ereditato da XtraUserControl)
Proprietà pubblica | Tree | Albero contenente le dipendenze.
Torna su
Vedi anche

Documentazione

Classe DedDependenciesControl
Namespace DedNet.Controls


Proprietà DedDependenciesControl.DataSource

Proprietà DedDependenciesControlDataSource
Fonte dati da riportare nel controllo ad albero.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public IEnumerable<DedCustomDependency> DataSource { set; }
Public WriteOnly Property DataSource As IEnumerable(Of DedCustomDependency)
    Set
public:
property IEnumerable<DedCustomDependency^>^ DataSource {
    void set (IEnumerable<DedCustomDependency^>^ value);
}
member DataSource : IEnumerable<DedCustomDependency> with set

Valore della proprietà

IEnumerable DedCustomDependency
Vedi anche

Documentazione

Classe DedDependenciesControl
Namespace DedNet.Controls


Proprietà DedDependenciesControl.Message

Proprietà DedDependenciesControlMessage
Messaggio personalizzato da visualizzare.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Message { set; }
Public WriteOnly Property Message As String
    Set
public:
property String^ Message {
    void set (String^ value);
}
member Message : string with set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedDependenciesControl
Namespace DedNet.Controls


Proprietà DedDependenciesControl.ShowOnlyTree

Proprietà DedDependenciesControlShowOnlyTree
Se viene effettuata l'impostazione di visualizzare solo l'albero nascondo gli altri controlli

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ShowOnlyTree { set; }
Public WriteOnly Property ShowOnlyTree As Boolean
    Set
public:
property bool ShowOnlyTree {
    void set (bool value);
}
member ShowOnlyTree : bool with set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDependenciesControl
Namespace DedNet.Controls


Proprietà DedDependenciesControl.Tree

Proprietà DedDependenciesControlTree
Albero contenente le dipendenze.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public TreeList Tree { get; }
Public ReadOnly Property Tree As TreeList
    Get
public:
property TreeList^ Tree {
    TreeList^ get ();
}
member Tree : TreeList with get

Valore della proprietà

TreeList
Vedi anche

Documentazione

Classe DedDependenciesControl
Namespace DedNet.Controls


Metodi di DedDependenciesControl

Il tipo DedDependenciesControl espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | BaseWndProc | (Ereditato da XtraUserControl)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraUserControl)
Metodo protetto | CreatePainter | (Ereditato da XtraUserControl)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive UserControlBaseDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraUserControl)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraUserControl)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraUserControl)
Metodo protetto | GetBackColor | (Ereditato da XtraUserControl)
Metodo protetto | GetBackgroundSkinElement | (Ereditato da XtraUserControl)
Metodo protetto | GetInnerIXtraResizableControl | (Ereditato da XtraUserControl)
Metodo protetto | IsChildControlsRequiredScalingEnabled | (Ereditato da XtraUserControl)
Metodo protetto | IsParentHandleCreatedRecursive | (Ereditato da XtraUserControl)
Metodo pubblico | LoadBom | Data l'anagrafica specificata carica la distinta
Metodo pubblico | LoadDocStructInfo | Carica la struttura del DocStructInfo all'interno dell'albero. È possibile specificare se riportare la struttura a scendere (quindi dei figli) o a salire (quindi dei genitori).
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraUserControl)
Metodo protetto | OnBackColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnContextMenuOpening | Evento di apertura del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnControlAdded | (Ereditato da XtraUserControl)
Metodo protetto | OnControlRemoved | (Ereditato da XtraUserControl)
Metodo protetto | OnDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnFirstLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnForeColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleCreated | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraUserControl)
Metodo protetto | OnLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnMenuItemClicked | Evento di pressione di un comando del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnPaintCore | (Ereditato da XtraUserControl)
Metodo protetto | OnParentChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | OnSizeChanged | (Ereditato da XtraUserControl)
Metodo protetto | RaisePaintExEvent | (Ereditato da XtraUserControl)
Metodo pubblico | ResetBackColor | (Ereditato da XtraUserControl)
Metodo pubblico | ResetForeColor | (Ereditato da XtraUserControl)
Metodo protetto | RestoreAutoScaleModeChangedByPM2 | (Ereditato da XtraUserControl)
Metodo pubblico | RestoreLayoutFromRegistry | Ripristina il layout dei controlli leggendo le informazioni dal registro.
Metodo pubblico | SaveLayoutToRegistry | Salva il layout dei controlli all'interno del registro.
Metodo protetto | ScaleControl | (Ereditato da XtraUserControl)
Metodo pubblico | SetCommandList | Rigenera il menu contestuale di questo controllo con la lista dei comandi passati. (Ereditato da UserControlBase)
Metodo protetto | SetVisibleCore | (Ereditato da XtraUserControl)
Metodo protetto | ShouldPaintTransparentBackground | (Ereditato da XtraUserControl)
Metodo protetto | ShouldUseDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | WndProc | (Ereditato da XtraUserControl)
Torna su
Vedi anche

Documentazione

Classe DedDependenciesControl
Namespace DedNet.Controls


Metodo DedDependenciesControl.Dispose

Metodo DedDependenciesControlDispose
Clean up any resources being used.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedDependenciesControl
Namespace DedNet.Controls


Metodo DedDependenciesControl.LoadBom

Metodo DedDependenciesControlLoadBom
Data l'anagrafica specificata carica la distinta

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void LoadBom(
    DedData data,
    bool showParentsStructure
)
Public Sub LoadBom (
    data As DedData,
    showParentsStructure As Boolean
)
public:
void LoadBom(
    DedData^ data,
    bool showParentsStructure
)
member LoadBom :
        data : DedData *
        showParentsStructure : bool -> unit

Parametri

data DedData
showParentsStructure Boolean
Vedi anche

Documentazione

Classe DedDependenciesControl
Namespace DedNet.Controls


Metodo DedDependenciesControl.LoadDocStructInfo

Metodo DedDependenciesControlLoadDocStructInfo
Carica la struttura del DocStructInfo all'interno dell'albero. È possibile specificare se riportare la struttura a scendere (quindi dei figli) o a salire (quindi dei genitori).

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void LoadDocStructInfo(
    DocStructInfo dsinfo,
    bool showParentsStructure
)
Public Sub LoadDocStructInfo (
    dsinfo As DocStructInfo,
    showParentsStructure As Boolean
)
public:
void LoadDocStructInfo(
    DocStructInfo^ dsinfo,
    bool showParentsStructure
)
member LoadDocStructInfo :
        dsinfo : DocStructInfo *
        showParentsStructure : bool -> unit

Parametri

dsinfo DocStructInfo
showParentsStructure Boolean
Vedi anche

Documentazione

Classe DedDependenciesControl
Namespace DedNet.Controls


Metodo DedDependenciesControl.RestoreLayoutFromRegistry

Metodo DedDependenciesControlRestoreLayoutFromRegistry
Ripristina il layout dei controlli leggendo le informazioni dal registro.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void RestoreLayoutFromRegistry(
    string key
)
Public Sub RestoreLayoutFromRegistry (
    key As String
)
public:
void RestoreLayoutFromRegistry(
    String^ key
)
member RestoreLayoutFromRegistry :
        key : string -> unit

Parametri

key String
Vedi anche

Documentazione

Classe DedDependenciesControl
Namespace DedNet.Controls


Metodo DedDependenciesControl.SaveLayoutToRegistry

Metodo DedDependenciesControlSaveLayoutToRegistry
Salva il layout dei controlli all'interno del registro.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SaveLayoutToRegistry(
    string key
)
Public Sub SaveLayoutToRegistry (
    key As String
)
public:
void SaveLayoutToRegistry(
    String^ key
)
member SaveLayoutToRegistry :
        key : string -> unit

Parametri

key String
Vedi anche

Documentazione

Classe DedDependenciesControl
Namespace DedNet.Controls


Eventi di DedDependenciesControl

Il tipo DedDependenciesControl espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | ContextMenuOpening | Evento su apertura del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | CustomRowFilter | Evento associato al filtraggio del singolo nodo del treelist.
Evento pubblico | MenuItemClicked | Evento su click su un elemento del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | PaintEx | (Ereditato da XtraUserControl)
Torna su
Vedi anche

Documentazione

Classe DedDependenciesControl
Namespace DedNet.Controls


Evento DedDependenciesControl.CustomRowFilter

Evento DedDependenciesControlCustomRowFilter
Evento associato al filtraggio del singolo nodo del treelist.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event CustomRowFilterEventHandler CustomRowFilter
Public Event CustomRowFilter As CustomRowFilterEventHandler
public:
 event CustomRowFilterEventHandler^ CustomRowFilter {
    void add (CustomRowFilterEventHandler^ value);
    void remove (CustomRowFilterEventHandler^ value);
}
member CustomRowFilter : IEvent<CustomRowFilterEventHandler,
    EventArgs>

Valore

CustomRowFilterEventHandler
Vedi anche

Documentazione

Classe DedDependenciesControl
Namespace DedNet.Controls


Campi di DedDependenciesControl

Il tipo DedDependenciesControl espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | _app | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Campo protetto | _RegistryBaseKey | Chiave nel registro di sistema di salvataggio impostazioni. (Ereditato da UserControlBase)
 | ANAG_COLUMN |
 | DESC_COLUMN |
 | DOC_COLUMN |
 | ID_COLUMN |
 | REV_COLUMN |
Torna su
Vedi anche

Documentazione

Classe DedDependenciesControl
Namespace DedNet.Controls


Campo DedDependenciesControl.ANAG_COLUMN

Campo DedDependenciesControlANAG_COLUMN

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static readonly string ANAG_COLUMN
Public Shared ReadOnly ANAG_COLUMN As String
public:
static initonly String^ ANAG_COLUMN
static val ANAG_COLUMN: string

Valore del campo

String
Vedi anche

Documentazione

Classe DedDependenciesControl
Namespace DedNet.Controls


Campo DedDependenciesControl.DESC_COLUMN

Campo DedDependenciesControlDESC_COLUMN

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static readonly string DESC_COLUMN
Public Shared ReadOnly DESC_COLUMN As String
public:
static initonly String^ DESC_COLUMN
static val DESC_COLUMN: string

Valore del campo

String
Vedi anche

Documentazione

Classe DedDependenciesControl
Namespace DedNet.Controls


Campo DedDependenciesControl.DOC_COLUMN

Campo DedDependenciesControlDOC_COLUMN

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static readonly string DOC_COLUMN
Public Shared ReadOnly DOC_COLUMN As String
public:
static initonly String^ DOC_COLUMN
static val DOC_COLUMN: string

Valore del campo

String
Vedi anche

Documentazione

Classe DedDependenciesControl
Namespace DedNet.Controls


Campo DedDependenciesControl.ID_COLUMN

Campo DedDependenciesControlID_COLUMN

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static readonly string ID_COLUMN
Public Shared ReadOnly ID_COLUMN As String
public:
static initonly String^ ID_COLUMN
static val ID_COLUMN: string

Valore del campo

String
Vedi anche

Documentazione

Classe DedDependenciesControl
Namespace DedNet.Controls


Campo DedDependenciesControl.REV_COLUMN

Campo DedDependenciesControlREV_COLUMN

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static readonly string REV_COLUMN
Public Shared ReadOnly REV_COLUMN As String
public:
static initonly String^ REV_COLUMN
static val REV_COLUMN: string

Valore del campo

String
Vedi anche

Documentazione

Classe DedDependenciesControl
Namespace DedNet.Controls


Classe DedDependenciesControl.MyTreeListDedDependencies

Classe DedDependenciesControlMyTreeListDedDependencies
Ridefinito l'albero in modo da espandere i nodi durante la ricerca.
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
EditorContainer
TreeList
DedNet.ControlsDedDependenciesControlMyTreeListDedDependencies

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class MyTreeListDedDependencies : TreeList
Public Class MyTreeListDedDependencies
    Inherits TreeList
public ref class MyTreeListDedDependencies : public TreeList
type MyTreeListDedDependencies =
    class
        inherit TreeList
    end

Il tipo DedDependenciesControlMyTreeListDedDependencies espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedDependenciesControlMyTreeListDedDependencies |
Metodo protetto | DedDependenciesControlMyTreeListDedDependencies(Object) |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | ActiveEditor | (Ereditato da TreeList)
Proprietà pubblica | ActiveFilter | (Ereditato da TreeList)
Proprietà pubblica | ActiveFilterCriteria | (Ereditato da TreeList)
Proprietà pubblica | ActiveFilterEnabled | (Ereditato da TreeList)
Proprietà pubblica | ActiveFilterInfo | (Ereditato da TreeList)
Proprietà pubblica | ActiveFilterString | (Ereditato da TreeList)
Proprietà protetta | ActualAutoNodeHeight | (Ereditato da TreeList)
Proprietà protetta | ActualFilterCriteria | (Ereditato da TreeList)
Proprietà protetta | ActualShowBands | (Ereditato da TreeList)
Proprietà pubblica | AllNodesCount | (Ereditato da TreeList)
Proprietà protetta | AllowAnimatedScrolling | (Ereditato da TreeList)
Proprietà protetta | AllowAutoFilterConditionChange | (Ereditato da TreeList)
Proprietà protetta | AllowBandColumnsMultiRow | (Ereditato da TreeList)
Proprietà protetta | AllowExpandAnimation | (Ereditato da TreeList)
Proprietà protetta | AllowFiltering | (Ereditato da TreeList)
Proprietà protetta | AllowFilteringAfterLoadingData | (Ereditato da TreeList)
Proprietà protetta | AllowFilterNodes | (Ereditato da TreeList)
Proprietà protetta | AllowFindPanel | (Ereditato da TreeList)
Proprietà protetta | AllowPrintProgress | (Ereditato da TreeList)
Proprietà protetta | AllowScaleOnLoad | (Ereditato da EditorContainer)
Proprietà pubblica | AllowTouchGestures | (Ereditato da EditorContainer)
Proprietà protetta | AllowTouchScroll | (Ereditato da TreeList)
Proprietà protetta | AnnotationManager | (Ereditato da TreeList)
Proprietà pubblica | Appearance | (Ereditato da TreeList)
Proprietà pubblica | AppearancePrint | (Ereditato da TreeList)
Proprietà pubblica | AutoFillColumn | (Ereditato da TreeList)
Proprietà pubblica | AutoFillColumnName | (Ereditato da TreeList)
Proprietà pubblica | AutoFillFieldName | (Ereditato da TreeList)
Proprietà protetta | AutoFilterNode | (Ereditato da TreeList)
Proprietà pubblica | BackColor | (Ereditato da TreeList)
Proprietà pubblica | BandPanelRowHeight | (Ereditato da TreeList)
Proprietà pubblica | Bands | (Ereditato da TreeList)
Proprietà pubblica | BestFitVisibleOnly | (Ereditato da TreeList)
Proprietà pubblica | BorderStyle | (Ereditato da TreeList)
Proprietà protetta | CanExpandNodesOnIncrementalSearch | (Ereditato da TreeList)
Proprietà protetta | CanLoadNodes | (Ereditato da TreeList)
Proprietà protetta | CanShowBandsInCustomizationForm | (Ereditato da TreeList)
Proprietà pubblica | CanShowEditor | (Ereditato da TreeList)
Proprietà pubblica | CanShowRowFooterSummary | (Ereditato da TreeList)
Proprietà pubblica | Caption | (Ereditato da TreeList)
Proprietà pubblica | CaptionHeight | (Ereditato da TreeList)
Proprietà protetta | CheckBoxesStrategy | (Ereditato da TreeList)
Proprietà pubblica | CheckBoxFieldName | (Ereditato da TreeList)
Proprietà pubblica | ChildListFieldName | (Ereditato da TreeList)
Proprietà protetta | ClientHeight | (Ereditato da TreeList)
Proprietà protetta | ClientWidth | (Ereditato da TreeList)
Proprietà pubblica | ClipboardDataProvider | (Ereditato da TreeList)
Proprietà protetta | ClipboardPasteHelper | (Ereditato da TreeList)
Proprietà protetta | ClipboardPasteManager | (Ereditato da TreeList)
Proprietà protetta | CloneInfoList | (Ereditato da TreeList)
Proprietà pubblica | ColumnPanelRowHeight | (Ereditato da TreeList)
Proprietà pubblica | Columns | (Ereditato da TreeList)
Proprietà pubblica | ColumnsImageList | (Ereditato da TreeList)
Proprietà protetta | ContainerHelper | (Ereditato da TreeList)
Proprietà pubblica | ContextMenuStrip | (Ereditato da EditorContainer)
Proprietà protetta | CurrencyManager | (Ereditato da TreeList)
Proprietà pubblica | Cursor | (Ereditato da TreeList)
Proprietà pubblica | CustomizationForm | (Ereditato da TreeList)
Proprietà pubblica | CustomizationFormBounds | (Ereditato da TreeList)
Proprietà pubblica | CustomizationRowCount | Obsoleto. (Ereditato da TreeList)
Proprietà protetta | Data | (Ereditato da TreeList)
Proprietà pubblica | DataMember | (Ereditato da TreeList)
Proprietà pubblica | DataSource | (Ereditato da TreeList)
Proprietà protetta | DefaultSize | (Ereditato da TreeList)
Proprietà protetta | DirectXProvider | (Ereditato da TreeList)
Proprietà protetta | DirectXScroller | (Ereditato da TreeList)
Proprietà pubblica | DragExpandDelay | Obsoleto. (Ereditato da TreeList)
Proprietà pubblica | DragNodesMode | Obsoleto. (Ereditato da TreeList)
Proprietà protetta | DXAccessible | (Ereditato da TreeList)
Proprietà protetta | Editable | (Ereditato da TreeList)
Proprietà protetta | EditFormController | (Ereditato da TreeList)
Proprietà pubblica | EditingValue | (Ereditato da TreeList)
Proprietà protetta | EditorHelper | (Ereditato da EditorContainer)
Proprietà protetta | ElementsLookAndFeel | (Ereditato da TreeList)
Proprietà pubblica | EmptyTreeHtmlTemplate | (Ereditato da TreeList)
Proprietà protetta | EnableDirectXPaint | (Ereditato da TreeList)
Proprietà pubblica | EnableDynamicLoading | (Ereditato da TreeList)
Proprietà pubblica | EnableEnhancedScrolling | (Ereditato da TreeList)
Proprietà protetta | EnableEnhancedSorting | (Ereditato da TreeList)
Proprietà protetta | EnableFirstPaintTrigger | (Ereditato da EditorContainer)
Proprietà pubblica | EnableImprovedColumnSizing | (Ereditato da TreeList)
Proprietà protetta | ErrorInfo | (Ereditato da TreeList)
Proprietà protetta | ExcelFilteringProvider | (Ereditato da TreeList)
Proprietà protetta | ExceptionThrown | (Ereditato da TreeList)
Proprietà pubblica | ExternalRepository | (Ereditato da EditorContainer)
Proprietà protetta | ExtraFilter | (Ereditato da TreeList)
Proprietà protetta | ExtraFilterCriteria | (Ereditato da TreeList)
Proprietà protetta | ExtraFilterHightlightText | (Ereditato da TreeList)
Proprietà protetta | FilterColumnsProvider | (Ereditato da TreeList)
Proprietà protetta | FilterHelper | (Ereditato da TreeList)
Proprietà protetta | FilteringService | (Ereditato da TreeList)
Proprietà pubblica | FilterPanelText | (Ereditato da TreeList)
Proprietà protetta | FilterPopup | (Ereditato da TreeList)
Proprietà protetta | FindFilterCriteria | (Ereditato da TreeList)
Proprietà pubblica | FindFilterText | (Ereditato da TreeList)
Proprietà protetta | FindPanel | (Ereditato da TreeList)
Proprietà pubblica | FindPanelVisible | (Ereditato da TreeList)
Proprietà protetta | FireOnLoadOnPaint | (Ereditato da TreeList)
Proprietà pubblica | FixedLineWidth | (Ereditato da TreeList)
Proprietà protetta | FocusedCellIndex | (Ereditato da TreeList)
Proprietà pubblica | FocusedColumn | (Ereditato da TreeList)
Proprietà pubblica | FocusedNode | (Ereditato da TreeList)
Proprietà protetta | FocusedRow | (Ereditato da TreeList)
Proprietà protetta | FocusedRowIndex | (Ereditato da TreeList)
Proprietà pubblica | FocusedValue | (Ereditato da TreeList)
Proprietà pubblica | FooterPanelHeight | (Ereditato da TreeList)
Proprietà protetta | ForceLoadingPanel | (Ereditato da TreeList)
Proprietà pubblica | ForeColor | (Ereditato da EditorContainer)
Proprietà pubblica | FormatConditions | (Ereditato da TreeList)
Proprietà pubblica | FormatRules | (Ereditato da TreeList)
Proprietà pubblica | GroupButtonSize | Obsoleto. (Ereditato da TreeList)
Proprietà protetta | Handler | (Ereditato da TreeList)
Proprietà protetta | HasAccessible | (Ereditato da TreeList)
Proprietà protetta | HasAllColumnsFixedRight | (Ereditato da TreeList)
Proprietà protetta | HasBands | (Ereditato da TreeList)
Proprietà pubblica | HasColumnErrors | (Ereditato da TreeList)
Proprietà protetta | HasCustomNodeCellEdit | (Ereditato da TreeList)
Proprietà pubblica | HasFocus | (Ereditato da TreeList)
Proprietà protetta | HasHierarchicalColumn | (Ereditato da TreeList)
Proprietà protetta | HasTreeViewColumn | (Ereditato da TreeList)
Proprietà protetta | HeaderLayoutCalculator | (Ereditato da TreeList)
Proprietà protetta | HeaderWidthCalculator | (Ereditato da TreeList)
Proprietà pubblica | HierarchyColumn | (Ereditato da TreeList)
Proprietà pubblica | HierarchyColumnIndent | (Ereditato da TreeList)
Proprietà pubblica | HierarchyColumnName | (Ereditato da TreeList)
Proprietà pubblica | HierarchyFieldName | (Ereditato da TreeList)
Proprietà pubblica | HorzScrollStep | (Ereditato da TreeList)
Proprietà pubblica | HorzScrollVisibility | (Ereditato da TreeList)
Proprietà protetta | HtmlContext | (Ereditato da TreeList)
Proprietà pubblica | HtmlImages | (Ereditato da TreeList)
Proprietà protetta | HtmlObjectCache | (Ereditato da TreeList)
Proprietà pubblica | HtmlTemplates | (Ereditato da TreeList)
Proprietà protetta | IBasePrintableCreatesIntersectedBricks | (Ereditato da TreeList)
Proprietà pubblica | ImageIndexFieldName | (Ereditato da TreeList)
Proprietà protetta | IncrementalText | (Ereditato da TreeList)
Proprietà pubblica | IndicatorWidth | (Ereditato da TreeList)
Proprietà protetta | IsAllowBusyIndicator | (Ereditato da TreeList)
Proprietà protetta | IsAllowBusyPanel | (Ereditato da TreeList)
Proprietà protetta | IsAlt | (Ereditato da TreeList)
Proprietà protetta | IsAttachedToSearchControl | (Ereditato da TreeList)
Proprietà protetta | IsAutoWidth | (Ereditato da TreeList)
Proprietà protetta | IsCellSelect | (Ereditato da TreeList)
Proprietà protetta | IsClosingEditor | (Ereditato da TreeList)
Proprietà protetta | IsColumnHeaderAutoHeight | (Ereditato da TreeList)
Proprietà protetta | IsControl | (Ereditato da TreeList)
Proprietà protetta | IsDataReady | (Ereditato da TreeList)
Proprietà protetta | IsDeserializing | (Ereditato da TreeList)
Proprietà pubblica | IsDesignMode | (Ereditato da EditorContainer)
Proprietà protetta | IsDynamicLoadingAllowed | (Ereditato da TreeList)
Proprietà protetta | IsEditFormMode | (Ereditato da TreeList)
Proprietà pubblica | IsFilterByStateActive |
Proprietà protetta | IsFilterPopupActive | (Ereditato da TreeList)
Proprietà protetta | IsFindFilterActive | (Ereditato da TreeList)
Proprietà pubblica | IsFindPanelVisible | (Ereditato da TreeList)
Proprietà protetta | IsFocusedNodeChangedLocked | (Ereditato da TreeList)
Proprietà protetta | IsFocusedNodeDataModified | (Ereditato da TreeList)
Proprietà protetta | IsGroupDeleteOperation | (Ereditato da TreeList)
Proprietà protetta | IsHScrollBarVisible | (Ereditato da TreeList)
Proprietà protetta | IsInitialized | (Ereditato da EditorContainer)
Proprietà protetta | IsIniting | (Ereditato da TreeList)
Proprietà pubblica | IsLoading | (Ereditato da EditorContainer)
Proprietà protetta | IsLockDirectXRendering | (Ereditato da TreeList)
Proprietà protetta | IsLockExpandCollapse | (Ereditato da TreeList)
Proprietà protetta | IsLockUpdate | (Ereditato da TreeList)
Proprietà pubblica | IsLookUpMode | (Ereditato da TreeList)
Proprietà protetta | IsMultiSelect | (Ereditato da TreeList)
Proprietà protetta | IsNotificationInfoVisible | (Ereditato da TreeList)
Proprietà protetta | IsPainting | (Ereditato da TreeList)
Proprietà protetta | IsPixelScrolling | (Ereditato da TreeList)
Proprietà protetta | IsPopupEditFormVisible | (Ereditato da TreeList)
Proprietà pubblica | IsPrinting | (Ereditato da TreeList)
Proprietà pubblica | IsPrintingAvailable | (Ereditato da TreeList)
Proprietà protetta | IsRightToLeft | (Ereditato da TreeList)
Proprietà protetta | IsRowCountReady | (Ereditato da TreeList)
Proprietà protetta | IsScrollAnimationInProgress | (Ereditato da TreeList)
Proprietà protetta | IsSearchMode | (Ereditato da TreeList)
Proprietà protetta | IsSerializing | (Ereditato da TreeList)
Proprietà protetta | IsShift | (Ereditato da TreeList)
Proprietà protetta | IsSorted | (Ereditato da TreeList)
Proprietà protetta | IsUnboundLoad | (Ereditato da TreeList)
Proprietà pubblica | IsUnboundMode | (Ereditato da TreeList)
Proprietà protetta | IsUpdateSize | (Ereditato da TreeList)
Proprietà protetta | IsVirtualMode | (Ereditato da TreeList)
Proprietà protetta | IsVScrollBarVisible | (Ereditato da TreeList)
Proprietà pubblica | KeyFieldName | (Ereditato da TreeList)
Proprietà pubblica | LayoutVersion | Obsoleto. (Ereditato da TreeList)
Proprietà pubblica | LeftCoord | (Ereditato da TreeList)
Proprietà pubblica | LoadingPanelVisible | (Ereditato da TreeList)
Proprietà pubblica | LookAndFeel | (Ereditato da EditorContainer)
Proprietà protetta | LookAndFeelIgnoreChildren | (Ereditato da EditorContainer)
Proprietà protetta | LookUpDisplayColumn | (Ereditato da TreeList)
Proprietà protetta | LookUpOwner | (Ereditato da TreeList)
Proprietà pubblica | MenuManager | (Ereditato da EditorContainer)
Proprietà protetta | MinRowHeight | (Ereditato da TreeList)
Proprietà pubblica | MinWidth | (Ereditato da TreeList)
Proprietà protetta | MRUFilterPopup | (Ereditato da TreeList)
Proprietà pubblica | MRUFilters | (Ereditato da TreeList)
Proprietà protetta | NewItemNode | (Ereditato da TreeList)
Proprietà pubblica | NewItemRowText | (Ereditato da TreeList)
Proprietà pubblica | NodeHtmlTemplate | (Ereditato da TreeList)
Proprietà pubblica | Nodes | (Ereditato da TreeList)
Proprietà pubblica | NodesIterator | (Ereditato da TreeList)
Proprietà pubblica | NonColumnFilterCriteria | (Ereditato da TreeList)
Proprietà pubblica | NonColumnFilterString | (Ereditato da TreeList)
Proprietà protetta | NotificationInfo | (Ereditato da TreeList)
Proprietà protetta | OfficeScroller | (Ereditato da TreeList)
Proprietà pubblica | OptionsBehavior | (Ereditato da TreeList)
Proprietà pubblica | OptionsClipboard | (Ereditato da TreeList)
Proprietà pubblica | OptionsCustomization | (Ereditato da TreeList)
Proprietà pubblica | OptionsDragAndDrop | (Ereditato da TreeList)
Proprietà pubblica | OptionsEditForm | (Ereditato da TreeList)
Proprietà pubblica | OptionsFilter | (Ereditato da TreeList)
Proprietà pubblica | OptionsFind | (Ereditato da TreeList)
Proprietà pubblica | OptionsHtmlTemplate | (Ereditato da TreeList)
Proprietà pubblica | OptionsLayout | (Ereditato da TreeList)
Proprietà pubblica | OptionsMenu | (Ereditato da TreeList)
Proprietà pubblica | OptionsNavigation | (Ereditato da TreeList)
Proprietà pubblica | OptionsPrint | (Ereditato da TreeList)
Proprietà pubblica | OptionsScrollAnnotations | (Ereditato da TreeList)
Proprietà pubblica | OptionsSelection | (Ereditato da TreeList)
Proprietà pubblica | OptionsView | (Ereditato da TreeList)
Proprietà pubblica | Painter | (Ereditato da TreeList)
Proprietà pubblica | ParentFieldName | (Ereditato da TreeList)
Proprietà protetta | Position | (Ereditato da TreeList)
Proprietà protetta | PressedBand | (Ereditato da TreeList)
Proprietà protetta | PressedColumn | (Ereditato da TreeList)
Proprietà protetta | PressedNode | (Ereditato da TreeList)
Proprietà pubblica | PreviewFieldName | (Ereditato da TreeList)
Proprietà pubblica | PreviewIndent | (Ereditato da TreeList)
Proprietà pubblica | PreviewLineCount | (Ereditato da TreeList)
Proprietà protetta | Printer | (Ereditato da TreeList)
Proprietà protetta | PrinterCore | (Ereditato da TreeList)
Proprietà protetta | ProgressWindow | (Ereditato da TreeList)
Proprietà pubblica | RepositoryItems | (Ereditato da EditorContainer)
Proprietà pubblica | RootValue | (Ereditato da TreeList)
Proprietà protetta | RowCount | (Ereditato da TreeList)
Proprietà pubblica | RowHeight | (Ereditato da TreeList)
Proprietà protetta | ScaleDPI | (Ereditato da EditorContainer)
Proprietà pubblica | ScaleFactor | (Ereditato da EditorContainer)
Proprietà protetta | ScaleHelper | (Ereditato da EditorContainer)
Proprietà protetta | ScrollInfo | (Ereditato da TreeList)
Proprietà pubblica | SelectedHtmlText | (Ereditato da TreeList)
Proprietà pubblica | SelectImageList | (Ereditato da TreeList)
Proprietà pubblica | Selection | (Ereditato da TreeList)
Proprietà protetta | SelectionRange | (Ereditato da TreeList)
Proprietà pubblica | ShowButtonMode | (Ereditato da TreeList)
Proprietà protetta | ShowEditorAfterAnimatedScroll | (Ereditato da TreeList)
Proprietà protetta | ShowPreview | (Ereditato da TreeList)
Proprietà protetta | SizedBand | (Ereditato da TreeList)
Proprietà protetta | SizedColumn | (Ereditato da TreeList)
Proprietà protetta | SmartVisibility | (Ereditato da TreeList)
Proprietà pubblica | SortedColumnCount | (Ereditato da TreeList)
Proprietà pubblica | State | (Ereditato da TreeList)
Proprietà pubblica | StateImageList | (Ereditato da TreeList)
Proprietà pubblica | SyncCheckStateWithSourceOnChecking | (Ereditato da TreeList)
Proprietà pubblica | Text | (Ereditato da EditorContainer)
Proprietà pubblica | ToolTipController | (Ereditato da EditorContainer)
Proprietà protetta | TopVisibleNode | (Ereditato da TreeList)
Proprietà pubblica | TopVisibleNodeIndex | (Ereditato da TreeList)
Proprietà pubblica | TopVisibleNodePixel | (Ereditato da TreeList)
Proprietà pubblica | TreeLevelWidth | (Ereditato da TreeList)
Proprietà pubblica | TreeLineStyle | (Ereditato da TreeList)
Proprietà pubblica | TreeListDisposing | (Ereditato da TreeList)
Proprietà pubblica | TreeViewColumn | (Ereditato da TreeList)
Proprietà pubblica | TreeViewColumnName | (Ereditato da TreeList)
Proprietà pubblica | TreeViewFieldName | (Ereditato da TreeList)
Proprietà pubblica | UpdateTopVisibleNodeIndexOnCollapse | (Ereditato da TreeList)
Proprietà protetta | UseBandsAdvancedHorizontalNavigation | (Ereditato da TreeList)
Proprietà protetta | UseBandsAdvancedVerticalNavigation | (Ereditato da TreeList)
Proprietà pubblica | UseDirectXPaint | (Ereditato da TreeList)
Proprietà pubblica | UseDisabledStatePainter | (Ereditato da TreeList)
Proprietà protetta | UseStandardFilter | (Ereditato da TreeList)
Proprietà pubblica | VertScrollVisibility | (Ereditato da TreeList)
Proprietà pubblica | ViewInfo | (Ereditato da TreeList)
Proprietà pubblica | ViewStyle | (Ereditato da TreeList)
Proprietà protetta | VirtualDataHelper | (Ereditato da TreeList)
Proprietà pubblica | VisibleColumnCount | Obsoleto. (Ereditato da TreeList)
Proprietà pubblica | VisibleColumns | (Ereditato da TreeList)
Proprietà pubblica | VisibleNodesCount | (Ereditato da TreeList)
Proprietà protetta | WorkAsLookup | (Ereditato da TreeList)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AccessibleNotifyClients(AccessibleEvents, BaseAccessible) | (Ereditato da TreeList)
Metodo pubblico | AccessibleNotifyClients(AccessibleEvents, Int32, Int32) | (Ereditato da TreeList)
Metodo pubblico | AddFilter(CriteriaOperator) | (Ereditato da TreeList)
Metodo pubblico | AddFilter(String) | (Ereditato da TreeList)
Metodo protetto | AddToDefaultTooltipController | (Ereditato da EditorContainer)
Metodo protetto | AllowAutoFilterCondition | (Ereditato da TreeList)
Metodo protetto | AnimateKeyboardNavigation | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, TreeListNode) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, TreeListNode, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, TreeListNode, CheckState) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, CheckState) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, TreeListNode, CheckState, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, CheckState, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, TreeListNode, CheckState, NodeCheckBoxStyle, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, Int32, Int32, Int32) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, Int32, Int32, Int32, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, Int32, Int32, Int32, CheckState) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, Int32, Int32, Int32, CheckState, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, Int32, Int32, Int32, CheckState, NodeCheckBoxStyle, Object) | (Ereditato da TreeList)
Metodo protetto | ApplyFilter | (Ereditato da TreeList)
Metodo pubblico | ApplyFindFilter | (Ereditato da TreeList)
Metodo protetto | BeforeShowEditForm | (Ereditato da TreeList)
Metodo pubblico | BeginDelete | (Ereditato da TreeList)
Metodo protetto | BeginDragDrop | (Ereditato da TreeList)
Metodo protetto | BeginExpandCollapse | (Ereditato da TreeList)
Metodo pubblico | BeginInit | (Ereditato da EditorContainer)
Metodo protetto | BeginLockListChanged | (Ereditato da TreeList)
Metodo pubblico | BeginSelection | (Ereditato da TreeList)
Metodo pubblico | BeginSort | (Ereditato da TreeList)
Metodo pubblico | BeginUnboundLoad | (Ereditato da TreeList)
Metodo pubblico | BeginUpdate | (Ereditato da TreeList)
Metodo pubblico | BestFitColumns | (Ereditato da TreeList)
Metodo pubblico | BestFitColumns(Boolean) | (Ereditato da TreeList)
Metodo pubblico | BindCommand(Object, String, FuncObject) | (Ereditato da TreeList)
Metodo pubblico | BindCommand(ExpressionAction, Object, String, FuncObject) | (Ereditato da TreeList)
Metodo pubblico | BindCommand``1(ExpressionActionUMP, Object, String, FuncUMP) | (Ereditato da TreeList)
Metodo protetto | CalcActiveEditorBounds | (Ereditato da TreeList)
Metodo protetto | CalcColumnBestWidth | (Ereditato da TreeList)
Metodo pubblico | CalcHitInfo | (Ereditato da TreeList)
Metodo protetto | CalcHScrollRange | (Ereditato da TreeList)
Metodo protetto | CalcNodeAutoHeight | (Ereditato da TreeList)
Metodo protetto | CalcRowCount | (Ereditato da TreeList)
Metodo protetto | CalcScrollClientRect | (Ereditato da TreeList)
Metodo protetto | CalculateScrollBars | (Ereditato da TreeList)
Metodo protetto | CalculateVisibleRowsAreaHeight | (Ereditato da TreeList)
Metodo pubblico | CancelCurrentEdit | (Ereditato da TreeList)
Metodo protetto | CancelDirectXRendering | (Ereditato da TreeList)
Metodo protetto | CancelLockListChanged | (Ereditato da TreeList)
Metodo protetto | CancelSelection | (Ereditato da TreeList)
Metodo pubblico | CancelSort | (Ereditato da TreeList)
Metodo pubblico | CancelUpdate | (Ereditato da TreeList)
Metodo protetto | CanClearAllSorting | (Ereditato da TreeList)
Metodo protetto | CanCloneChildren | (Ereditato da TreeList)
Metodo protetto | CanFilterByColumnEdit | (Ereditato da TreeList)
Metodo pubblico | CanFilterColumn | (Ereditato da TreeList)
Metodo protetto | CanFindColumn | (Ereditato da TreeList)
Metodo protetto | CanFocusNode | (Ereditato da TreeList)
Metodo protetto | CanHandleTouchGestures | (Ereditato da EditorContainer)
Metodo protetto | CanIncrementalSearch | (Ereditato da TreeList)
Metodo pubblico | CanIndentNodes | (Ereditato da TreeList)
Metodo protetto | CanMove | (Ereditato da TreeList)
Metodo protetto | CanMoveBand | (Ereditato da TreeList)
Metodo protetto | CanMoveColumn | (Ereditato da TreeList)
Metodo pubblico | CanOutdentNodes | (Ereditato da TreeList)
Metodo protetto | CanResizeBand | (Ereditato da TreeList)
Metodo protetto | CanResizeColumn | (Ereditato da TreeList)
Metodo protetto | CanShowHScrollBar | (Ereditato da TreeList)
Metodo protetto | CanShowHScrollBarCore | (Ereditato da TreeList)
Metodo protetto | CanShowVScrollBar | (Ereditato da TreeList)
Metodo protetto | CanSortByColumnEdit | (Ereditato da TreeList)
Metodo pubblico | CanSortColumn | (Ereditato da TreeList)
Metodo protetto | CanStartTouchScrolling | (Ereditato da TreeList)
Metodo protetto | ChangeLeftCoord | (Ereditato da TreeList)
Metodo pubblico | CheckAll | (Ereditato da TreeList)
Metodo protetto | CheckAllowGestures | (Ereditato da TreeList)
Metodo protetto | CheckAllowNotifications | (Ereditato da TreeList)
Metodo protetto | CheckData | (Ereditato da TreeList)
Metodo protetto | CheckIncreaseVisibleRows | (Ereditato da TreeList)
Metodo protetto | CheckModifierKeys | (Ereditato da TreeList)
Metodo protetto | CheckNeedScale | (Ereditato da EditorContainer)
Metodo protetto | CheckRightToLeft | (Ereditato da EditorContainer)
Metodo protetto | CheckSearchMode | (Ereditato da TreeList)
Metodo protetto | CheckTopVisibleNodeAfterItemAdded | (Ereditato da TreeList)
Metodo protetto | CheckTopVisibleNodePixelValue | (Ereditato da TreeList)
Metodo pubblico | ClearColumnErrors | (Ereditato da TreeList)
Metodo pubblico | ClearColumnFilter | (Ereditato da TreeList)
Metodo protetto | ClearColumnFilterCore(String) | (Ereditato da TreeList)
Metodo protetto | ClearColumnFilterCore(TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | ClearColumnsFilter | (Ereditato da TreeList)
Metodo pubblico | ClearDocument | (Ereditato da TreeList)
Metodo pubblico | ClearFindFilter | (Ereditato da TreeList)
Metodo pubblico | ClearFocusedColumn | (Ereditato da TreeList)
Metodo pubblico | ClearNodes | (Ereditato da TreeList)
Metodo pubblico | ClearSelection | (Ereditato da TreeList)
Metodo pubblico | ClearSorting | (Ereditato da TreeList)
Metodo protetto | ClearVisibleIndicesCache | (Ereditato da TreeList)
Metodo pubblico | CloseEditForm | (Ereditato da TreeList)
Metodo pubblico | CloseEditor | (Ereditato da TreeList)
Metodo protetto | CloseEditor(Boolean) | (Ereditato da TreeList)
Metodo pubblico | CollapseAll | (Ereditato da TreeList)
Metodo protetto | CollapseAllCore | (Ereditato da TreeList)
Metodo pubblico | CollapseToLevel | (Ereditato da TreeList)
Metodo pubblico | ColumnsCustomization | (Ereditato da TreeList)
Metodo pubblico | ColumnsCustomization(Point) | (Ereditato da TreeList)
Metodo protetto | ControlRowSourceSelectedChanged | (Ereditato da TreeList)
Metodo protetto | ControlRowSourceVisibleChanged | (Ereditato da TreeList)
Metodo pubblico | ConvertFormatConditionToFormatRules | (Ereditato da TreeList)
Metodo pubblico | CopyNode(TreeListNode, TreeListNode, Boolean) | (Ereditato da TreeList)
Metodo pubblico | CopyNode(TreeListNode, TreeListNode, Boolean, Boolean) | (Ereditato da TreeList)
Metodo pubblico | CopyNode(TreeListNode, TreeListNode, Boolean, Int32) | (Ereditato da TreeList)
Metodo pubblico | CopyNode(TreeListNode, TreeListNode, Boolean, Boolean, Int32) | (Ereditato da TreeList)
Metodo protetto | CopyNodeCore | (Ereditato da TreeList)
Metodo pubblico | CopyNodes(IEnumerableTreeListNode, TreeListNode, Boolean, Int32) | (Ereditato da TreeList)
Metodo pubblico | CopyNodes(IEnumerableTreeListNode, TreeListNode, Boolean, Boolean, Int32) | (Ereditato da TreeList)
Metodo pubblico | CopyToClipboard | (Ereditato da TreeList)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da TreeList)
Metodo protetto | CreateAccessibleDataRow | (Ereditato da TreeList)
Metodo protetto | CreateAccessibleInstance | (Ereditato da TreeList)
Metodo protetto | CreateAllOptions | (Ereditato da TreeList)
Metodo protetto | CreateAnnotationManager | (Ereditato da TreeList)
Metodo protetto | CreateAppearances | (Ereditato da TreeList)
Metodo protetto | CreateAutoFilterCriterion | (Ereditato da TreeList)
Metodo protetto | CreateBands | (Ereditato da TreeList)
Metodo protetto | CreateCheckBoxesStrategy | (Ereditato da TreeList)
Metodo protetto | CreateCheckedListFilterPopup | (Ereditato da TreeList)
Metodo protetto | CreateColumn | (Ereditato da TreeList)
Metodo protetto | CreateColumnEditViewInfo | (Ereditato da TreeList)
Metodo protetto | CreateColumnFilterCriteriaByValue(TreeListColumn, Object) | (Ereditato da TreeList)
Metodo protetto | CreateColumnFilterCriteriaByValue(TreeListColumn, Object, Boolean) | (Ereditato da TreeList)
Metodo protetto | CreateColumnFilterPopup | (Ereditato da TreeList)
Metodo protetto | CreateColumns | (Ereditato da TreeList)
Metodo pubblico | CreateCustomization | Obsoleto. (Ereditato da TreeList)
Metodo protetto | CreateCustomizationForm | (Ereditato da TreeList)
Metodo protetto | CreateData | (Ereditato da TreeList)
Metodo protetto | CreateDataViewData | (Ereditato da TreeList)
Metodo protetto | CreateDateFilterPopup | (Ereditato da TreeList)
Metodo protetto | CreateDragNodesProvider | (Ereditato da TreeList)
Metodo protetto | CreateEditFormController | (Ereditato da TreeList)
Metodo protetto | CreateElementsLookAndFeel | (Ereditato da TreeList)
Metodo protetto | CreateExcelFilterPopup | (Ereditato da TreeList)
Metodo protetto | CreateFilterColumnCollection | (Ereditato da TreeList)
Metodo protetto | CreateFilterColumnRuleCollection | (Ereditato da TreeList)
Metodo protetto | CreateFilterColumnsProvider | (Ereditato da TreeList)
Metodo protetto | CreateFilterCriteriaBindingTarget | (Ereditato da TreeList)
Metodo protetto | CreateFilterEditorForm | (Ereditato da TreeList)
Metodo protetto | CreateFilterHelper | (Ereditato da TreeList)
Metodo protetto | CreateFindPanel | (Ereditato da TreeList)
Metodo protetto | CreateFindPanelCore | (Ereditato da TreeList)
Metodo pubblico | CreateGraphicsCache | (Ereditato da TreeList)
Metodo protetto | CreateHandler | (Ereditato da TreeList)
Metodo protetto | CreateHeaderLayoutCalculator | (Ereditato da TreeList)
Metodo protetto | CreateHeaderWidthCalculator | (Ereditato da TreeList)
Metodo protetto | CreateHelper | (Ereditato da TreeList)
Metodo protetto | CreateHierarchicalListData | (Ereditato da TreeList)
Metodo protetto | CreateHtmlContext | (Ereditato da TreeList)
Metodo protetto | CreateHyperlinkClickEventArgs | (Ereditato da TreeList)
Metodo protetto | CreateInternalRepository | (Ereditato da EditorContainer)
Metodo protetto | CreateListColumnFilterPopup | (Ereditato da TreeList)
Metodo protetto | CreateListData | (Ereditato da TreeList)
Metodo protetto | CreateLoadingAnimator | (Ereditato da TreeList)
Metodo protetto | CreateLoadingPanel | (Ereditato da TreeList)
Metodo protetto | CreateLookAndFeel | (Ereditato da EditorContainer)
Metodo protetto | CreateNewItemNode | (Ereditato da TreeList)
Metodo protetto | CreateNode(Int32, TreeListNodes) | (Ereditato da TreeList)
Metodo protetto | CreateNode(Int32, TreeListNodes, Object) | (Ereditato da TreeList)
Metodo protetto | CreateNodes | (Ereditato da TreeList)
Metodo protetto | CreateNodesComparer | (Ereditato da TreeList)
Metodo protetto | CreateNodesIterator | (Ereditato da TreeList)
Metodo protetto | CreateNotificationInfo | (Ereditato da TreeList)
Metodo protetto | CreateOfficeScroller | (Ereditato da TreeList)
Metodo protetto | CreateOptionsBehavior | (Ereditato da TreeList)
Metodo protetto | CreateOptionsClipboard | (Ereditato da TreeList)
Metodo protetto | CreateOptionsCustomization | (Ereditato da TreeList)
Metodo protetto | CreateOptionsDragAndDrop | (Ereditato da TreeList)
Metodo protetto | CreateOptionsEditForm | (Ereditato da TreeList)
Metodo protetto | CreateOptionsFilter | (Ereditato da TreeList)
Metodo protetto | CreateOptionsFind | (Ereditato da TreeList)
Metodo protetto | CreateOptionsHtmlTemplate | (Ereditato da TreeList)
Metodo protetto | CreateOptionsLayout | (Ereditato da TreeList)
Metodo protetto | CreateOptionsMenu | (Ereditato da TreeList)
Metodo protetto | CreateOptionsNavigation | (Ereditato da TreeList)
Metodo protetto | CreateOptionsPrint | (Ereditato da TreeList)
Metodo protetto | CreateOptionsScrollAnnotations | (Ereditato da TreeList)
Metodo protetto | CreateOptionsSelection | (Ereditato da TreeList)
Metodo protetto | CreateOptionsView | (Ereditato da TreeList)
Metodo protetto | CreatePainter | (Ereditato da TreeList)
Metodo protetto | CreatePrinter | (Ereditato da TreeList)
Metodo protetto | CreateProvider | (Ereditato da TreeList)
Metodo protetto | CreateScrollInfo | (Ereditato da TreeList)
Metodo protetto | CreateSelection | (Ereditato da TreeList)
Metodo protetto | CreateUnboundData | (Ereditato da TreeList)
Metodo protetto | CreateViewInfo | (Ereditato da TreeList)
Metodo protetto | CreateVirtualData | (Ereditato da TreeList)
Metodo protetto | CreateVirtualDataHelper | (Ereditato da TreeList)
Metodo protetto | CurrencyManager_ItemChanged | (Ereditato da TreeList)
Metodo protetto | CurrencyManager_PositionChanged | (Ereditato da TreeList)
Metodo protetto | DeferredLoadChildren | (Ereditato da TreeList)
Metodo protetto | DelayedInvalidate | (Ereditato da TreeList)
Metodo pubblico | DeleteNode | (Ereditato da TreeList)
Metodo pubblico | DeleteNodes | (Ereditato da TreeList)
Metodo pubblico | DeleteSelectedNodes | (Ereditato da TreeList)
Metodo pubblico | DestroyCustomization | (Ereditato da TreeList)
Metodo protetto | DestroyDirectXProvider | (Ereditato da EditorContainer)
Metodo protetto | DestroyFindPanel | (Ereditato da TreeList)
Metodo protetto | Dispose | (Ereditato da TreeList)
Metodo protetto | DoDataSourceChanged | (Ereditato da TreeList)
Metodo protetto | DoDpiChange | (Ereditato da EditorContainer)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da TreeList)
Metodo protetto | DoDragDrop | (Ereditato da TreeList)
Metodo pubblico | DoDragDropNode | (Ereditato da TreeList)
Metodo pubblico | DoDragDropNodes | (Ereditato da TreeList)
Metodo protetto | DoFilterNode | (Ereditato da TreeList)
Metodo protetto | DoForEachBand | (Ereditato da TreeList)
Metodo pubblico | DoIncrementalSearch | (Ereditato da TreeList)
Metodo protetto | DoShowTreeListMenu(TreeListMenu, TreeListHitTest) | (Ereditato da TreeList)
Metodo protetto | DoShowTreeListMenu(TreeListMenu, Control, Point) | (Ereditato da TreeList)
Metodo protetto | DoTopVisibleNodeChanged | (Ereditato da TreeList)
Metodo pubblico | EndCurrentEdit | (Ereditato da TreeList)
Metodo pubblico | EndCurrentEdit(Boolean) | (Ereditato da TreeList)
Metodo pubblico | EndDelete | (Ereditato da TreeList)
Metodo protetto | EndDragDrop | (Ereditato da TreeList)
Metodo protetto | EndEdit | (Ereditato da TreeList)
Metodo protetto | EndExpandCollapse | (Ereditato da TreeList)
Metodo pubblico | EndInit | (Ereditato da EditorContainer)
Metodo pubblico | EndSelection | (Ereditato da TreeList)
Metodo pubblico | EndSort | (Ereditato da TreeList)
Metodo pubblico | EndUnboundLoad | (Ereditato da TreeList)
Metodo pubblico | EndUpdate | (Ereditato da TreeList)
Metodo protetto | EnsureControlRowSource | (Ereditato da TreeList)
Metodo protetto | EnsureEditFormController | (Ereditato da TreeList)
Metodo protetto | EnsureFilteringClientDataBinding | (Ereditato da TreeList)
Metodo protetto | ExecutePrinterAction | (Ereditato da TreeList)
Metodo pubblico | ExpandAll | (Ereditato da TreeList)
Metodo protetto | ExpandAllCore | (Ereditato da TreeList)
Metodo protetto | ExpandToLast | (Ereditato da TreeList)
Metodo pubblico | ExpandToLevel | (Ereditato da TreeList)
Metodo protetto | ExpandToRoot | (Ereditato da TreeList)
Metodo protetto | Export(ExportTarget, Stream) | (Ereditato da TreeList)
Metodo protetto | Export(ExportTarget, String) | (Ereditato da TreeList)
Metodo protetto | Export(ExportTarget, Stream, ExportOptionsBase) | (Ereditato da TreeList)
Metodo protetto | Export(ExportTarget, String, ExportOptionsBase) | (Ereditato da TreeList)
Metodo pubblico | ExportToCsv(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToCsv(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToCsv(Stream, CsvExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToCsv(String, CsvExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToDocx(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToDocx(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToDocx(Stream, DocxExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToDocx(String, DocxExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToHtml(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToHtml(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToHtml(Stream, HtmlExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToHtml(String, HtmlExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToMht(Stream, MhtExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToMht(String, MhtExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToMht(String, String) | Obsoleto. (Ereditato da TreeList)
Metodo pubblico | ExportToMht(Stream, String, String, Boolean) | Obsoleto. (Ereditato da TreeList)
Metodo pubblico | ExportToMht(String, String, String, Boolean) | Obsoleto. (Ereditato da TreeList)
Metodo pubblico | ExportToPdf(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToPdf(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToPdf(Stream, PdfExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToPdf(String, PdfExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToRtf(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToRtf(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToText(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToText(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToText(Stream, TextExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToText(String, TextExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToXls(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToXls(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToXls(Stream, XlsExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToXls(String, XlsExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToXlsx(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToXlsx(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToXlsx(Stream, XlsxExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToXlsx(String, XlsxExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToXml(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToXml(String) | (Ereditato da TreeList)
Metodo protetto | ExportToXmlCore | (Ereditato da TreeList)
Metodo protetto | ExtractTemplateRootNode | (Ereditato da TreeList)
Metodo pubblico | FilterNodes | (Sovrascrive TreeList.FilterNodes)
Metodo pubblico | FilterNodes(TreeListNodes) | (Ereditato da TreeList)
Metodo protetto | FilterNodesCore | (Ereditato da TreeList)
Metodo pubblico | FindNode | (Ereditato da TreeList)
Metodo pubblico | FindNodeByFieldValue | (Ereditato da TreeList)
Metodo pubblico | FindNodeByID | (Ereditato da TreeList)
Metodo pubblico | FindNodeByKeyID | (Ereditato da TreeList)
Metodo protetto | FindNodeByParentID | (Ereditato da TreeList)
Metodo pubblico | FindNodes | (Ereditato da TreeList)
Metodo protetto | FindPanelNext | (Ereditato da TreeList)
Metodo protetto | FindPanelPrev | (Ereditato da TreeList)
Metodo pubblico | FireChanged | (Ereditato da TreeList)
Metodo protetto | FitColumns | (Ereditato da TreeList)
Metodo pubblico | FocusNewItemNode | (Ereditato da TreeList)
Metodo protetto | ForceCalcRowCount | (Ereditato da TreeList)
Metodo pubblico | ForceInitialize | (Ereditato da TreeList)
Metodo protetto | ForceSetTopVisibleNodeIndex | (Ereditato da TreeList)
Metodo pubblico | FullCollapse | Obsoleto. (Ereditato da TreeList)
Metodo pubblico | FullExpand | Obsoleto. (Ereditato da TreeList)
Metodo pubblico | FullExpandNode | Obsoleto. (Ereditato da TreeList)
Metodo protetto | GetAccessibilityObjectById | (Ereditato da TreeList)
Metodo protetto | GetAccessibleNodeCell | (Ereditato da TreeList)
Metodo protetto | GetActiveEditorHighAppearance | (Ereditato da TreeList)
Metodo protetto | GetActualAnimationType | (Ereditato da TreeList)
Metodo protetto | GetActualTreeListFilterMode | (Ereditato da TreeList)
Metodo pubblico | GetAllCheckedNodes | (Ereditato da TreeList)
Metodo protetto | GetAllowChangeBandParent | (Ereditato da TreeList)
Metodo protetto | GetAllowColumnFilterPopup | (Ereditato da TreeList)
Metodo protetto | GetAllowFilterEditor | (Ereditato da TreeList)
Metodo protetto | GetAllowFindColumn | (Ereditato da TreeList)
Metodo protetto | GetAllowFocus | (Ereditato da TreeList)
Metodo protetto | GetAllowHighlightFindResults | (Ereditato da TreeList)
Metodo protetto | GetAllowMRUFilterList | (Ereditato da TreeList)
Metodo protetto | GetAutoFilterRowColumnEdit | (Ereditato da TreeList)
Metodo pubblico | GetAutoFilterValue | (Ereditato da TreeList)
Metodo protetto | GetAutoNodeHeight | (Ereditato da TreeList)
Metodo protetto | GetBandRows | (Ereditato da TreeList)
Metodo protetto | GetBandRowsCore | (Ereditato da TreeList)
Metodo protetto | GetBandVisibleIndex | (Ereditato da TreeList)
Metodo protetto | GetCanShowEditor | (Ereditato da TreeList)
Metodo pubblico | GetColumnByColumnHandle | (Ereditato da TreeList)
Metodo pubblico | GetColumnByVisibleIndex | (Ereditato da TreeList)
Metodo protetto | GetColumnDefaultRepositoryItem | (Ereditato da TreeList)
Metodo protetto | GetColumnDefaultRepositoryItemForEditing | (Ereditato da TreeList)
Metodo protetto | GetColumnEdit | (Ereditato da TreeList)
Metodo protetto | GetColumnEditForEditing | (Ereditato da TreeList)
Metodo pubblico | GetColumnError(TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | GetColumnError(TreeListColumn, TreeListNode) | (Ereditato da TreeList)
Metodo pubblico | GetColumnErrorType(TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | GetColumnErrorType(TreeListColumn, TreeListNode) | (Ereditato da TreeList)
Metodo protetto | GetColumnFieldNameSort | (Ereditato da TreeList)
Metodo protetto | GetColumnFilterCriteria | (Ereditato da TreeList)
Metodo protetto | GetColumnFilterMode | (Ereditato da TreeList)
Metodo pubblico | GetColumnHeaderBestWidth | (Ereditato da TreeList)
Metodo protetto | GetColumnName | (Ereditato da TreeList)
Metodo protetto | GetCurrencyManager | (Ereditato da TreeList)
Metodo protetto | GetDataColumnInfo | (Ereditato da TreeList)
Metodo pubblico | GetDataRecordByNode | (Ereditato da TreeList)
Metodo pubblico | GetDataRow | (Ereditato da TreeList)
Metodo protetto | GetDirectXDeviceBackColor | (Ereditato da EditorContainer)
Metodo protetto | GetDirectXProvider | (Ereditato da EditorContainer)
Metodo protetto | GetEditableObject | (Ereditato da TreeList)
Metodo pubblico | GetEditorShowMode | (Ereditato da TreeList)
Metodo protetto | GetEditorViewInfo | (Ereditato da TreeList)
Metodo protetto | GetFilterColumn | (Ereditato da TreeList)
Metodo protetto | GetFilterColumnByTreeListColumn | (Ereditato da TreeList)
Metodo protetto | GetFilterCriteriaDisplayStyle | (Ereditato da TreeList)
Metodo protetto | GetFilterDisplayText | (Ereditato da TreeList)
Metodo protetto | GetFilterDisplayTextByColumn | (Ereditato da TreeList)
Metodo protetto | GetFilterPopupTexts | (Ereditato da TreeList)
Metodo protetto | GetFilterPopupValues(TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | GetFilterPopupValues(TreeListColumn, Boolean) | (Ereditato da TreeList)
Metodo protetto | GetFilterPopupValues(TreeListColumn, CriteriaOperator, Boolean) | (Ereditato da TreeList)
Metodo protetto | GetFilterPopupValues(TreeListColumn, Boolean, Boolean) | (Ereditato da TreeList)
Metodo protetto | GetFilterRowValue(Object) | (Ereditato da TreeList)
Metodo protetto | GetFilterRowValue(TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | GetFindMatchedRanges | (Ereditato da TreeList)
Metodo protetto | GetFindMatchedText | (Ereditato da TreeList)
Metodo protetto | GetFindToColumnsCollection | (Ereditato da TreeList)
Metodo pubblico | GetFocusedDataRow | (Ereditato da TreeList)
Metodo pubblico | GetFocusedDisplayText | (Ereditato da TreeList)
Metodo pubblico | GetFocusedRow | (Ereditato da TreeList)
Metodo pubblico | GetFocusedRowCellDisplayText(String) | (Ereditato da TreeList)
Metodo pubblico | GetFocusedRowCellDisplayText(TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetFocusedRowCellValue(String) | (Ereditato da TreeList)
Metodo pubblico | GetFocusedRowCellValue(TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetGroupSummaryValue | (Ereditato da TreeList)
Metodo protetto | GetHeaderFilterButtonShowMode | (Ereditato da TreeList)
Metodo pubblico | GetHitInfo | Obsoleto. (Ereditato da TreeList)
Metodo protetto | GetImageIndexFromDataSource | (Ereditato da TreeList)
Metodo protetto | GetMaxIndent | (Ereditato da TreeList)
Metodo protetto | GetNativePreviewText | (Ereditato da TreeList)
Metodo pubblico | GetNodeAt(Point) | (Ereditato da TreeList)
Metodo pubblico | GetNodeAt(Int32, Int32) | (Ereditato da TreeList)
Metodo pubblico | GetNodeByVisibleIndex | (Ereditato da TreeList)
Metodo protetto | GetNodeCellRepositoryItem | (Ereditato da TreeList)
Metodo protetto | GetNodeComparer(IComparerTreeListNode) | (Ereditato da TreeList)
Metodo protetto | GetNodeComparer(TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetNodeIndex | (Ereditato da TreeList)
Metodo pubblico | GetNodeList | (Ereditato da TreeList)
Metodo protetto | GetNodeValue(TreeListNode, TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | GetNodeValue(TreeListNode, Object) | (Ereditato da TreeList)
Metodo protetto | GetNodeValue(TreeListNode, String) | (Ereditato da TreeList)
Metodo protetto | GetNonFormattedCaption | (Ereditato da TreeList)
Metodo protetto | GetParentColumnFieldNameSort | (Ereditato da TreeList)
Metodo pubblico | GetRow | (Ereditato da TreeList)
Metodo pubblico | GetRowCellDisplayText(TreeListNode, TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetRowCellDisplayText(TreeListNode, String) | (Ereditato da TreeList)
Metodo pubblico | GetRowCellValue(TreeListNode, TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetRowCellValue(TreeListNode, String) | (Ereditato da TreeList)
Metodo protetto | GetRowsAsFootersCount | (Ereditato da TreeList)
Metodo pubblico | GetScrollAnnotations | (Ereditato da TreeList)
Metodo pubblico | GetSelectedCells | (Ereditato da TreeList)
Metodo pubblico | GetSelectedCells(TreeListNode) | (Ereditato da TreeList)
Metodo protetto | GetShowBandsMode | (Ereditato da TreeList)
Metodo protetto | GetShowFirstLines | (Ereditato da TreeList)
Metodo protetto | GetShowIndentAsRowStyle | (Ereditato da TreeList)
Metodo pubblico | GetSortColumn(Int32) | (Ereditato da TreeList)
Metodo protetto | GetSortColumn(TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetSummaryValue(TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetSummaryValue(TreeListColumn, Boolean) | (Ereditato da TreeList)
Metodo protetto | GetSummaryValueCore | (Ereditato da TreeList)
Metodo protetto | GetSummaryValueEx | (Ereditato da TreeList)
Metodo pubblico | GetToolTipController | (Ereditato da EditorContainer)
Metodo protetto | GetUseDirectXPaint | (Ereditato da TreeList)
Metodo pubblico | GetVisibleIndexByNode | (Ereditato da TreeList)
Metodo protetto | GetVisibleIndexByNodeCore | (Ereditato da TreeList)
Metodo protetto | GetVisibleParentNodesCount | (Ereditato da TreeList)
Metodo pubblico | HideCustomization | (Ereditato da TreeList)
Metodo pubblico | HideEditor | (Ereditato da TreeList)
Metodo protetto | HideEditorCore | (Ereditato da TreeList)
Metodo pubblico | HideFindPanel | (Ereditato da TreeList)
Metodo pubblico | HideLoadingPanel | (Ereditato da TreeList)
Metodo protetto | HookOnLoaded | (Ereditato da EditorContainer)
Metodo pubblico | ImportFromXml(Stream) | (Ereditato da TreeList)
Metodo pubblico | ImportFromXml(String) | (Ereditato da TreeList)
Metodo protetto | ImportFromXmlCore | (Ereditato da TreeList)
Metodo pubblico | IndentNodes | (Ereditato da TreeList)
Metodo protetto | InitFindPanel | (Ereditato da TreeList)
Metodo protetto | InitializeDirectXProvider | (Ereditato da EditorContainer)
Metodo protetto | InitScrollInfo | (Ereditato da TreeList)
Metodo protetto | InternalDeleteNode | (Ereditato da TreeList)
Metodo protetto | InternalDeleteNodeCore | (Ereditato da TreeList)
Metodo protetto | InternalDeleteNodes(DictionaryTreeListNodes, ListTreeListNode) | (Ereditato da TreeList)
Metodo protetto | InternalDeleteNodes(TreeListNodes) | (Ereditato da TreeList)
Metodo protetto | InternalFullCollapseNode | (Ereditato da TreeList)
Metodo protetto | InternalFullExpandNode | (Ereditato da TreeList)
Metodo protetto | InternalGetCustomNodeCellEdit | (Ereditato da TreeList)
Metodo protetto | InternalGetCustomNodeCellStyle | (Ereditato da TreeList)
Metodo pubblico | InternalGetService | (Ereditato da TreeList)
Metodo protetto | InternalNodeAdded | (Ereditato da TreeList)
Metodo protetto | InternalNodeChanged | (Ereditato da TreeList)
Metodo protetto | InternalSetTopVisibleNodePixel | (Ereditato da TreeList)
Metodo pubblico | InvalidateBand | (Ereditato da TreeList)
Metodo pubblico | InvalidateBandPanel | (Ereditato da TreeList)
Metodo pubblico | InvalidateCell | (Ereditato da TreeList)
Metodo pubblico | InvalidateColumnHeader | (Ereditato da TreeList)
Metodo pubblico | InvalidateColumnPanel | (Ereditato da TreeList)
Metodo pubblico | InvalidateFilterPanel | (Ereditato da TreeList)
Metodo pubblico | InvalidateNode | (Ereditato da TreeList)
Metodo pubblico | InvalidateNodes | (Ereditato da TreeList)
Metodo pubblico | InvalidateRow | (Ereditato da TreeList)
Metodo pubblico | InvalidateRowPreview | (Ereditato da TreeList)
Metodo protetto | InvalidateRows | (Ereditato da TreeList)
Metodo pubblico | InvalidateScrollAnnotations | (Ereditato da TreeList)
Metodo pubblico | InvalidateSummaryFooterPanel | (Ereditato da TreeList)
Metodo pubblico | InvokeMenuItemClick | (Ereditato da TreeList)
Metodo protetto | IsAllowDefaultFastBestFit | (Ereditato da TreeList)
Metodo protetto | IsAllowEditForm | (Ereditato da TreeList)
Metodo pubblico | IsAutoFilterNode | (Ereditato da TreeList)
Metodo pubblico | IsCellSelected | (Ereditato da TreeList)
Metodo protetto | IsColumnAllowAutoFilter | (Ereditato da TreeList)
Metodo protetto | IsColumnAllowFilter | (Ereditato da TreeList)
Metodo pubblico | IsColumnAllowFilterEditor | (Ereditato da TreeList)
Metodo protetto | IsColumnFieldNameSortExist | (Ereditato da TreeList)
Metodo protetto | IsColumnFiltered | (Ereditato da TreeList)
Metodo protetto | IsFilterByDisplayText | (Ereditato da TreeList)
Metodo protetto | IsFilterRow | (Ereditato da TreeList)
Metodo protetto | IsImplyNullLikeEmptyStringWhenFiltering | (Ereditato da TreeList)
Metodo protetto | IsInputChar | (Ereditato da TreeList)
Metodo protetto | IsInputKey | (Ereditato da TreeList)
Metodo pubblico | IsNewItemRow | (Ereditato da TreeList)
Metodo protetto | IsParentColumnFieldNameSortExist | (Ereditato da TreeList)
Metodo pubblico | IsRootNode | (Ereditato da TreeList)
Metodo protetto | IsRoundDateTime | (Ereditato da TreeList)
Metodo protetto | IsShowAllValuesInFilterPopup | (Ereditato da TreeList)
Metodo protetto | IsTopNewItemRow | (Ereditato da TreeList)
Metodo protetto | IsUserAutoFilterCondition | (Ereditato da TreeList)
Metodo pubblico | LayoutChanged | (Ereditato da TreeList)
Metodo protetto | LoadDataColumns | (Ereditato da TreeList)
Metodo protetto | LoadDataSource | (Ereditato da TreeList)
Metodo protetto | LockDirectXRendering | (Ereditato da TreeList)
Metodo protetto | LockFilteringUIClientFilterCriteriaBinding | (Ereditato da TreeList)
Metodo pubblico | LockReloadNodes | (Ereditato da TreeList)
Metodo pubblico | MakeColumnVisible | (Ereditato da TreeList)
Metodo protetto | MakeFocusedRowVisible | (Ereditato da TreeList)
Metodo pubblico | MakeNodeVisible | (Ereditato da TreeList)
Metodo protetto | MergeColumnFiltersCore | (Ereditato da TreeList)
Metodo pubblico | MoveFirst | (Ereditato da TreeList)
Metodo protetto | MoveFocusedCell | (Ereditato da TreeList)
Metodo pubblico | MoveLast | (Ereditato da TreeList)
Metodo pubblico | MoveLastVisible | (Ereditato da TreeList)
Metodo pubblico | MoveNext | (Ereditato da TreeList)
Metodo pubblico | MoveNextVisible | (Ereditato da TreeList)
Metodo pubblico | MoveNode(TreeListNode, TreeListNode) | (Ereditato da TreeList)
Metodo pubblico | MoveNode(TreeListNode, TreeListNode, Boolean) | (Ereditato da TreeList)
Metodo pubblico | MoveNode(TreeListNode, TreeListNode, Boolean, Int32) | (Ereditato da TreeList)
Metodo pubblico | MoveNodes | (Ereditato da TreeList)
Metodo protetto | MoveNodesCore | (Ereditato da TreeList)
Metodo pubblico | MovePrev | (Ereditato da TreeList)
Metodo pubblico | MovePrevVisible | (Ereditato da TreeList)
Metodo pubblico | MoveToNextScrollAnnotation | (Ereditato da TreeList)
Metodo pubblico | MoveToParent | (Ereditato da TreeList)
Metodo pubblico | MoveToPrevScrollAnnotation | (Ereditato da TreeList)
Metodo protetto | NormalizeVisibleBandIndices | (Ereditato da TreeList)
Metodo protetto | NormalizeVisibleColumnIndices | (Ereditato da TreeList)
Metodo protetto | OnActiveEditor_GotFocus | (Ereditato da TreeList)
Metodo protetto | OnActiveEditor_LostFocus | (Ereditato da TreeList)
Metodo protetto | OnActiveEditor_Modified | (Ereditato da TreeList)
Metodo protetto | OnActiveEditor_ValueChanged | (Ereditato da TreeList)
Metodo protetto | OnActiveEditor_ValueChanging | (Ereditato da TreeList)
Metodo protetto | OnActiveFilterChanged | (Ereditato da TreeList)
Metodo protetto | OnActiveFilterCriteriaChanged | (Ereditato da TreeList)
Metodo protetto | OnActiveFilterEnabledChanged | (Ereditato da TreeList)
Metodo protetto | OnAfterAddingNode | (Ereditato da TreeList)
Metodo protetto | OnAfterChangeCollapsed | (Ereditato da TreeList)
Metodo protetto | OnAfterChangeExpanded | (Ereditato da TreeList)
Metodo protetto | OnAfterDeletingNodes | (Ereditato da TreeList)
Metodo protetto | OnAllowBandColumnMultiRowChanged | (Ereditato da TreeList)
Metodo protetto | OnAllowSerializationProperty | (Ereditato da TreeList)
Metodo protetto | OnAppearancePrintChanged | (Ereditato da TreeList)
Metodo protetto | OnBandChanged | (Ereditato da TreeList)
Metodo protetto | OnBandCollectionChanged | (Ereditato da TreeList)
Metodo protetto | OnBandColumnCollectionChanged | (Ereditato da TreeList)
Metodo protetto | OnBandFixedChanged | (Ereditato da TreeList)
Metodo protetto | OnBandWidthChanged | (Ereditato da TreeList)
Metodo protetto | OnBeginTouchScroll | (Ereditato da TreeList)
Metodo protetto | OnBindingContextChanged | (Ereditato da TreeList)
Metodo protetto | OnCheckBoxFieldNameChanged | (Ereditato da TreeList)
Metodo protetto | OnClearNodes | (Ereditato da TreeList)
Metodo protetto | OnClearNodesComplete | (Ereditato da TreeList)
Metodo protetto | OnClick | (Ereditato da TreeList)
Metodo protetto | OnColumnAdded | (Ereditato da TreeList)
Metodo protetto | OnColumnChanged | (Ereditato da TreeList)
Metodo protetto | OnColumnFilterModeChanged | (Ereditato da TreeList)
Metodo protetto | OnColumnFilterRestored | (Ereditato da TreeList)
Metodo protetto | OnColumnInfosPopulated | (Ereditato da TreeList)
Metodo protetto | OnColumnRemoved | (Ereditato da TreeList)
Metodo protetto | OnColumnRowIndexChanged | (Ereditato da TreeList)
Metodo protetto | OnColumnsChanged | (Ereditato da TreeList)
Metodo protetto | OnColumnUnboundChanged | (Ereditato da TreeList)
Metodo protetto | OnColumnUnboundExpressionChanged | (Ereditato da TreeList)
Metodo protetto | OnContainerEnter | (Ereditato da EditorContainer)
Metodo protetto | OnContainerLeave | (Ereditato da EditorContainer)
Metodo protetto | OnContextMenuKey | (Ereditato da TreeList)
Metodo protetto | OnCreateControl | (Ereditato da EditorContainer)
Metodo protetto | OnDataListChanged | (Ereditato da TreeList)
Metodo protetto | OnDesignerHost_LoadComplete | (Ereditato da EditorContainer)
Metodo protetto | OnDesignerHost_TransactionClosed | (Ereditato da EditorContainer)
Metodo protetto | OnDirectXPaintDisabled | (Ereditato da TreeList)
Metodo protetto | OnDoubleClick | (Ereditato da TreeList)
Metodo protetto | OnDragDrop | (Ereditato da TreeList)
Metodo protetto | OnDragEnter | (Ereditato da TreeList)
Metodo protetto | OnDragLeave | (Ereditato da TreeList)
Metodo protetto | OnDragOver | (Ereditato da TreeList)
Metodo protetto | OnEnabledChanged | (Ereditato da TreeList)
Metodo protetto | OnEndInit | (Ereditato da EditorContainer)
Metodo protetto | OnEndSerializing | (Ereditato da TreeList)
Metodo protetto | OnEndSorting | (Ereditato da TreeList)
Metodo protetto | OnEnter | (Ereditato da EditorContainer)
Metodo protetto | OnErrorInfo_Changed | (Ereditato da TreeList)
Metodo protetto | OnFilterRowValueChanging | (Ereditato da TreeList)
Metodo protetto | OnFirstInit | (Ereditato da EditorContainer)
Metodo protetto | OnFormatConditionChanged | (Ereditato da TreeList)
Metodo protetto | OnFormatRuleExpressionEditorCreated | (Ereditato da TreeList)
Metodo protetto | OnFormatRulesCollectionChanged | (Ereditato da TreeList)
Metodo protetto | OnGotCapture | (Ereditato da EditorContainer)
Metodo protetto | OnGotFocus | (Ereditato da TreeList)
Metodo protetto | OnHandleCreated | (Ereditato da TreeList)
Metodo protetto | OnHandleDestroyed | (Ereditato da TreeList)
Metodo protetto | OnHorizontalTouchScroll | (Ereditato da TreeList)
Metodo protetto | OnHScroll | (Ereditato da TreeList)
Metodo protetto | OnItemAdded | (Ereditato da TreeList)
Metodo protetto | OnItemAdding | (Ereditato da TreeList)
Metodo protetto | OnItemChanged(Int32, PropertyDescriptor) | (Ereditato da TreeList)
Metodo protetto | OnItemChanged(Int32, PropertyDescriptor, TreeListNode) | (Ereditato da TreeList)
Metodo protetto | OnItemDeleted | (Ereditato da TreeList)
Metodo protetto | OnItemMoved | (Ereditato da TreeList)
Metodo protetto | OnKeyDown | (Ereditato da TreeList)
Metodo protetto | OnKeyPress | (Ereditato da TreeList)
Metodo protetto | OnKeyUp | (Ereditato da TreeList)
Metodo protetto | OnLeave | (Ereditato da EditorContainer)
Metodo protetto | OnLoaded | (Ereditato da TreeList)
Metodo protetto | OnLoadedCore | (Ereditato da TreeList)
Metodo protetto | OnLookAndFeelChanged(LookAndFeelChangedEventArgs) | (Ereditato da TreeList)
Metodo protetto | OnLookAndFeelChanged(Object, EventArgs) | (Ereditato da EditorContainer)
Metodo protetto | OnLostCapture | (Ereditato da TreeList)
Metodo protetto | OnLostFocus | (Ereditato da TreeList)
Metodo protetto | OnMenuShowing | (Ereditato da TreeList)
Metodo protetto | OnMouseClick | (Ereditato da EditorContainer)
Metodo protetto | OnMouseDoubleClick | (Ereditato da EditorContainer)
Metodo protetto | OnMouseDown | (Ereditato da TreeList)
Metodo protetto | OnMouseEnter | (Ereditato da TreeList)
Metodo protetto | OnMouseHWheel | (Ereditato da EditorContainer)
Metodo protetto | OnMouseLeave | (Ereditato da TreeList)
Metodo protetto | OnMouseMove | (Ereditato da TreeList)
Metodo protetto | OnMouseUp | (Ereditato da TreeList)
Metodo protetto | OnMouseWheel | (Ereditato da EditorContainer)
Metodo protetto | OnMouseWheelCore | (Ereditato da TreeList)
Metodo protetto | OnNodeCheckedChanged | (Ereditato da TreeList)
Metodo protetto | OnNodeRemoved | (Ereditato da TreeList)
Metodo protetto | OnNodesLoaded | (Ereditato da TreeList)
Metodo protetto | OnNodesLoading | (Ereditato da TreeList)
Metodo protetto | OnNodesRemoved | (Ereditato da TreeList)
Metodo protetto | OnOptionsBehaviorChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsCustomizationChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsDragAndDropChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsEditFormChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsFilterChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsFindChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsHtmlChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsNavigationChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsPrintChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsScrollAnnotationsChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsSelectionChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsViewChanged | (Ereditato da TreeList)
Metodo protetto | OnPaint | Implementazione dell'override di onPaint. Grazie al catch delle eccezioni evita l'uscita della X rossa sul form (Sovrascrive TreeList.OnPaint(PaintEventArgs))
Metodo protetto | OnPaintBackground | (Ereditato da TreeList)
Metodo protetto | OnParentChanged | (Ereditato da TreeList)
Metodo protetto | OnPressedBandChanged | (Ereditato da TreeList)
Metodo protetto | OnPrintProgress | (Ereditato da TreeList)
Metodo protetto | OnPropertyChanged | (Ereditato da TreeList)
Metodo protetto | OnPropertyDescriptorChanged | (Ereditato da TreeList)
Metodo protetto | OnQueryContinueDrag | (Ereditato da TreeList)
Metodo protetto | OnRepositoryItemRefreshRequired | (Ereditato da TreeList)
Metodo protetto | OnReset | (Ereditato da TreeList)
Metodo protetto | OnResetSerializationProperties | (Ereditato da TreeList)
Metodo protetto | OnResize | (Ereditato da TreeList)
Metodo protetto | OnRightToLeftChanged | (Ereditato da TreeList)
Metodo protetto | OnRightToLeftChanged(EventArgs) | (Ereditato da EditorContainer)
Metodo protetto | OnScaleControl | (Ereditato da TreeList)
Metodo protetto | OnScaleTreeListCore | (Ereditato da TreeList)
Metodo protetto | OnSelectionChanged | (Ereditato da TreeList)
Metodo protetto | OnSetValue | (Ereditato da TreeList)
Metodo protetto | OnSortModeChanged | (Ereditato da TreeList)
Metodo protetto | OnSourceItemChanged | (Ereditato da TreeList)
Metodo protetto | OnStartSerializing | (Ereditato da TreeList)
Metodo protetto | OnStartSorting | (Ereditato da TreeList)
Metodo protetto | OnSystemColorsChanged | (Ereditato da TreeList)
Metodo protetto | OnToolTipControllerDisposed | (Ereditato da EditorContainer)
Metodo protetto | OnTouchScroll | (Ereditato da TreeList)
Metodo protetto | OnTouchZoom | (Ereditato da TreeList)
Metodo protetto | OnValidated | (Ereditato da EditorContainer)
Metodo protetto | OnValidating | (Ereditato da TreeList)
Metodo protetto | OnVerticalTouchScroll | (Ereditato da TreeList)
Metodo protetto | OnVisibleChanged | (Ereditato da TreeList)
Metodo protetto | OnVScroll | (Ereditato da TreeList)
Metodo protetto | OnVScrollCore | (Ereditato da TreeList)
Metodo pubblico | OutdentNodes | (Ereditato da TreeList)
Metodo protetto | ParseAutoFilter | (Ereditato da TreeList)
Metodo protetto | ParseAutoFilterValues | (Ereditato da TreeList)
Metodo pubblico | PasteFromClipboard | (Ereditato da TreeList)
Metodo pubblico | PopulateColumns | (Ereditato da TreeList)
Metodo pubblico | PostEditor | (Ereditato da TreeList)
Metodo protetto | PostEditor(Boolean) | (Ereditato da TreeList)
Metodo pubblico | Print | (Ereditato da TreeList)
Metodo protetto | PrintCore | (Ereditato da TreeList)
Metodo pubblico | PrintDialog | (Ereditato da TreeList)
Metodo protetto | PrintDialogCore | (Ereditato da TreeList)
Metodo protetto | ProcessControlTab | (Ereditato da TreeList)
Metodo protetto | ProcessControlTab(Boolean) | (Ereditato da TreeList)
Metodo protetto | ProcessDialogKey | (Ereditato da TreeList)
Metodo protetto | ProcessDirectXPaint | (Ereditato da TreeList)
Metodo protetto | RaiseAfterCheckNode | (Ereditato da TreeList)
Metodo protetto | RaiseAfterCollapse | (Ereditato da TreeList)
Metodo protetto | RaiseAfterDragNode | (Ereditato da TreeList)
Metodo protetto | RaiseAfterDropNode | (Ereditato da TreeList)
Metodo protetto | RaiseAfterExpand | (Ereditato da TreeList)
Metodo protetto | RaiseAfterFocusNode | (Ereditato da TreeList)
Metodo protetto | RaiseBandPositionChanged | (Ereditato da TreeList)
Metodo protetto | RaiseBandWidthChanged | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeCheckNode | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeCollapse | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeDragNode | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeDropNode | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeExpand | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeFocusNode | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeLoadLayout | (Ereditato da TreeList)
Metodo protetto | RaiseCalcNodeDragImageIndex | (Ereditato da TreeList)
Metodo protetto | RaiseCalcNodeHeight(TreeListNode, Int32) | (Ereditato da TreeList)
Metodo protetto | RaiseCalcNodeHeight(TreeListNode, RowInfo, Int32) | (Ereditato da TreeList)
Metodo protetto | RaiseCellValueChanged | (Ereditato da TreeList)
Metodo protetto | RaiseCellValueChanging | (Ereditato da TreeList)
Metodo protetto | RaiseCheckedColumnFilterPopupEvent | (Ereditato da TreeList)
Metodo protetto | RaiseClipboardNodeCopying | (Ereditato da TreeList)
Metodo protetto | RaiseClipboardNodePasting | (Ereditato da TreeList)
Metodo protetto | RaiseColumnButtonClick | (Ereditato da TreeList)
Metodo protetto | RaiseColumnChanged | (Ereditato da TreeList)
Metodo protetto | RaiseColumnFilterChanged | (Ereditato da TreeList)
Metodo protetto | RaiseColumnFilterPopupEvent | (Ereditato da TreeList)
Metodo protetto | RaiseColumnPositionChanged | (Ereditato da TreeList)
Metodo protetto | RaiseColumnUnboundExpressionChanged | (Ereditato da TreeList)
Metodo protetto | RaiseColumnWidthChanged | (Ereditato da TreeList)
Metodo protetto | RaiseCompareNodeValues | (Ereditato da TreeList)
Metodo protetto | RaiseCreateCustomNode | (Ereditato da TreeList)
Metodo protetto | RaiseCustomColumnDisplayText(CustomColumnDisplayTextEventArgs) | (Ereditato da TreeList)
Metodo protetto | RaiseCustomColumnDisplayText(TreeListNode, CellInfo) | (Ereditato da TreeList)
Metodo protetto | RaiseCustomColumnDisplayText(TreeListNode, TreeListColumn, BaseEditViewInfo) | (Ereditato da TreeList)
Metodo protetto | RaiseCustomColumnDisplayText(TreeListNode, TreeListColumn, Object, String) | (Ereditato da TreeList)
Metodo protetto | RaiseCustomColumnSort | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawBandHeader | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawColumnHeader | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawEmptyArea | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawFilterPanel | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawFooter | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawFooterCell | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodeButton | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodeCell | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodeCheckBox | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodeImages | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodeIndent | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodeIndicator | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodePreview | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawRow | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawRowFooter | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawRowFooterCell | (Ereditato da TreeList)
Metodo protetto | RaiseCustomFilterDisplayText | (Ereditato da TreeList)
Metodo protetto | RaiseCustomizationFormSearch | (Ereditato da TreeList)
Metodo protetto | RaiseCustomizeNewNodeFromOuterData | (Ereditato da TreeList)
Metodo protetto | RaiseCustomRowFilter | (Ereditato da TreeList)
Metodo protetto | RaiseCustomRowFilterEvent | (Ereditato da TreeList)
Metodo protetto | RaiseCustomUnboundColumnData | (Ereditato da TreeList)
Metodo protetto | RaiseDataSourceChanged | (Ereditato da TreeList)
Metodo protetto | RaiseDefaultPaintHelperChanged | (Ereditato da TreeList)
Metodo protetto | RaiseDragCancelNode | (Ereditato da TreeList)
Metodo protetto | RaiseDragObjectDrop | (Ereditato da TreeList)
Metodo protetto | RaiseDragObjectOver | (Ereditato da TreeList)
Metodo protetto | RaiseDragObjectStart | (Ereditato da TreeList)
Metodo protetto | RaiseEditFormHidden | (Ereditato da TreeList)
Metodo protetto | RaiseEditFormPrepared | (Ereditato da TreeList)
Metodo protetto | RaiseEditFormShowing | (Ereditato da TreeList)
Metodo protetto | RaiseEditorKeyDown | (Ereditato da TreeList)
Metodo protetto | RaiseEditorKeyPress | (Ereditato da EditorContainer)
Metodo protetto | RaiseEditorKeyUp | (Ereditato da EditorContainer)
Metodo protetto | RaiseEndSorting | (Ereditato da TreeList)
Metodo protetto | RaiseExcelColumnFilterPopupEvent | (Ereditato da TreeList)
Metodo protetto | RaiseFilterEditorCreated | (Ereditato da TreeList)
Metodo protetto | RaiseFilterExpressionEditorCreated | (Ereditato da TreeList)
Metodo protetto | RaiseFilterNodeEvent | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupDate | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelCustomizeTemplate | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelData(FilterPopupExcelDataEventArgs) | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelData(TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelData(TreeListColumn, CriteriaOperator) | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelData(TreeListColumn, TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelParseFilterCriteria | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelPrepareTemplate | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelQueryFilterCriteria | (Ereditato da TreeList)
Metodo protetto | RaiseFocusedColumnChanged | (Ereditato da TreeList)
Metodo protetto | RaiseFocusedNodeChanged | (Ereditato da TreeList)
Metodo protetto | RaiseGetCustomAnnotations | (Ereditato da TreeList)
Metodo protetto | RaiseGetCustomNodeCellEdit | (Ereditato da TreeList)
Metodo protetto | RaiseGetCustomNodeCellStyle | (Ereditato da TreeList)
Metodo protetto | RaiseGetCustomSummaryValue | (Ereditato da TreeList)
Metodo protetto | RaiseGetNodeDisplayValue | (Ereditato da TreeList)
Metodo protetto | RaiseGetPreviewText | (Ereditato da TreeList)
Metodo protetto | RaiseGetPrintCustomSummaryValue | (Ereditato da TreeList)
Metodo protetto | RaiseGetPrintPreviewText | (Ereditato da TreeList)
Metodo protetto | RaiseGetSelectImage | (Ereditato da TreeList)
Metodo protetto | RaiseGetStateImage | (Ereditato da TreeList)
Metodo protetto | RaiseHiddenEditor | (Ereditato da TreeList)
Metodo protetto | RaiseHideCustomizationForm | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementBlur | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementFocus | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseClick | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseDoubleClick | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseDown | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseMove | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseOut | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseOver | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseUp | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlSelectedTextChanged | (Ereditato da TreeList)
Metodo protetto | RaiseInitNewRow | (Ereditato da TreeList)
Metodo protetto | RaiseInvalidNodeException | (Ereditato da TreeList)
Metodo protetto | RaiseInvalidValueException | (Ereditato da TreeList)
Metodo protetto | RaiseLayoutUpdated | (Ereditato da TreeList)
Metodo protetto | RaiseLayoutUpgrade | (Ereditato da TreeList)
Metodo protetto | RaiseLeftCoordChanged | (Ereditato da TreeList)
Metodo protetto | RaiseLoad | (Ereditato da TreeList)
Metodo protetto | RaiseMeasurePreviewHeight | (Ereditato da TreeList)
Metodo protetto | RaiseNodeChanged | (Ereditato da TreeList)
Metodo protetto | RaiseNodesReloaded | (Ereditato da TreeList)
Metodo protetto | RaisePaintEx | (Ereditato da TreeList)
Metodo protetto | RaiseParseFindPanelText | (Ereditato da TreeList)
Metodo protetto | RaisePopupMenuShowing | (Ereditato da TreeList)
Metodo protetto | RaisePrintExportProgress | (Ereditato da TreeList)
Metodo protetto | RaiseQueryCustomFunctions | (Ereditato da TreeList)
Metodo protetto | RaiseRequireHideEditor | (Ereditato da EditorContainer)
Metodo protetto | RaiseRowCellClick | (Ereditato da TreeList)
Metodo protetto | RaiseRowClick | (Ereditato da TreeList)
Metodo protetto | RaiseRowSelectImageClick | (Ereditato da TreeList)
Metodo protetto | RaiseRowStateImageClick | (Ereditato da TreeList)
Metodo protetto | RaiseSelectImageClick | (Ereditato da TreeList)
Metodo protetto | RaiseSelectionChanged | (Ereditato da TreeList)
Metodo protetto | RaiseSelectionChanging | (Ereditato da TreeList)
Metodo protetto | RaiseShowCustomizationForm | (Ereditato da TreeList)
Metodo protetto | RaiseShowingEditor | (Ereditato da TreeList)
Metodo protetto | RaiseShownEditor | (Ereditato da TreeList)
Metodo protetto | RaiseShowTreeListMenu | Obsoleto. (Ereditato da TreeList)
Metodo protetto | RaiseStartSorting | (Ereditato da TreeList)
Metodo protetto | RaiseStateChanged | (Ereditato da TreeList)
Metodo protetto | RaiseStateImageClick | (Ereditato da TreeList)
Metodo protetto | RaiseSubstituteFilter | (Ereditato da TreeList)
Metodo protetto | RaiseTopVisibleNodeIndexChanged | (Ereditato da TreeList)
Metodo protetto | RaiseTreeListMenuItemClick | (Ereditato da TreeList)
Metodo protetto | RaiseUnboundExpressionEditorCreated | (Ereditato da TreeList)
Metodo protetto | RaiseValidateNode | (Ereditato da TreeList)
Metodo protetto | RaiseValidatingEditor | (Ereditato da TreeList)
Metodo protetto | RecalcSortColumns | (Ereditato da TreeList)
Metodo protetto | RecreateRowsInfoCore | (Ereditato da TreeList)
Metodo pubblico | Refresh | (Ereditato da TreeList)
Metodo pubblico | Refresh(Boolean) | (Ereditato da TreeList)
Metodo pubblico | RefreshCell | (Ereditato da TreeList)
Metodo protetto | RefreshCellCore | (Ereditato da TreeList)
Metodo protetto | RefreshColumnsInfo | (Ereditato da TreeList)
Metodo pubblico | RefreshDataSource | (Ereditato da TreeList)
Metodo pubblico | RefreshEditor | (Ereditato da TreeList)
Metodo protetto | RefreshEditorError | (Ereditato da TreeList)
Metodo protetto | RefreshHeadersInfo | (Ereditato da TreeList)
Metodo protetto | RefreshHtmlNodeCore | (Ereditato da TreeList)
Metodo pubblico | RefreshNode | (Ereditato da TreeList)
Metodo protetto | RefreshNodeCore | (Ereditato da TreeList)
Metodo protetto | RefreshRowsInfo | (Ereditato da TreeList)
Metodo protetto | RefreshRowsInfo(Boolean, Boolean) | (Ereditato da TreeList)
Metodo pubblico | RefreshScrollAnnotations(ScrollAnnotationKind) | (Ereditato da TreeList)
Metodo pubblico | RefreshScrollAnnotations(ScrollAnnotationKind, Int32) | (Ereditato da TreeList)
Metodo protetto | RefreshVirtualCellCore | (Ereditato da TreeList)
Metodo protetto | RefreshVirtualNodeCore | (Ereditato da TreeList)
Metodo protetto | RejectCurrentChanges | (Ereditato da TreeList)
Metodo protetto | RemoveFromDefaultTooltipController | (Ereditato da EditorContainer)
Metodo protetto | RemoveHookOnLoaded | (Ereditato da EditorContainer)
Metodo protetto | RemoveNodeHeight | (Ereditato da TreeList)
Metodo protetto | RequestCellEditor | (Ereditato da TreeList)
Metodo protetto | ResetAccessibility | (Ereditato da TreeList)
Metodo pubblico | ResetAutoFilterCondition | (Ereditato da TreeList)
Metodo pubblico | ResetAutoFilterConditions | (Ereditato da TreeList)
Metodo pubblico | ResetAutoFilterConditions(IEnumerableTreeListColumn) | (Ereditato da TreeList)
Metodo protetto | ResetAutoFilterConditionsCore | (Ereditato da TreeList)
Metodo protetto | ResetColumnAutoFilterConditions | (Ereditato da TreeList)
Metodo pubblico | ResetEditorsCache(RepositoryItem) | (Ereditato da EditorContainer)
Metodo pubblico | ResetEditorsCache(Type) | (Ereditato da EditorContainer)
Metodo protetto | ResetExcelFilteringProvider | (Ereditato da TreeList)
Metodo protetto | ResetLookAndFeel | (Ereditato da EditorContainer)
Metodo protetto | ResetRowCount | (Ereditato da TreeList)
Metodo protetto | ResetSortedColumns | (Ereditato da TreeList)
Metodo protetto | ResizeBand | (Ereditato da TreeList)
Metodo protetto | ResizeColumn | (Ereditato da TreeList)
Metodo protetto | ResolveAutoFilterCondition | (Ereditato da TreeList)
Metodo protetto | RestoreLayoutCore | (Ereditato da TreeList)
Metodo pubblico | RestoreLayoutFromRegistry(String) | (Ereditato da TreeList)
Metodo pubblico | RestoreLayoutFromRegistry(String, OptionsLayoutBase) | (Ereditato da TreeList)
Metodo pubblico | RestoreLayoutFromStream(Stream) | (Ereditato da TreeList)
Metodo pubblico | RestoreLayoutFromStream(Stream, OptionsLayoutBase) | (Ereditato da TreeList)
Metodo pubblico | RestoreLayoutFromXml(String) | (Ereditato da TreeList)
Metodo pubblico | RestoreLayoutFromXml(String, OptionsLayoutBase) | (Ereditato da TreeList)
Metodo protetto | RestoreNodesData | (Ereditato da TreeList)
Metodo protetto | SaveLayoutCore | (Ereditato da TreeList)
Metodo pubblico | SaveLayoutToRegistry(String) | (Ereditato da TreeList)
Metodo pubblico | SaveLayoutToRegistry(String, OptionsLayoutBase) | (Ereditato da TreeList)
Metodo pubblico | SaveLayoutToStream(Stream) | (Ereditato da TreeList)
Metodo pubblico | SaveLayoutToStream(Stream, OptionsLayoutBase) | (Ereditato da TreeList)
Metodo pubblico | SaveLayoutToXml(String) | (Ereditato da TreeList)
Metodo pubblico | SaveLayoutToXml(String, OptionsLayoutBase) | (Ereditato da TreeList)
Metodo protetto | SaveNodesData | (Ereditato da TreeList)
Metodo protetto | ScaleControl | (Ereditato da EditorContainer)
Metodo protetto | Scrollbar_MouseEnter | (Ereditato da TreeList)
Metodo protetto | Scrollbar_MouseLeave | (Ereditato da TreeList)
Metodo protetto | ScrollHorizontalEx | (Ereditato da TreeList)
Metodo protetto | ScrollVerticalEx | (Ereditato da TreeList)
Metodo pubblico | SelectAll | (Ereditato da TreeList)
Metodo pubblico | SelectCell | (Ereditato da TreeList)
Metodo protetto | SelectCellCore | (Ereditato da TreeList)
Metodo pubblico | SelectCells(Int32, String, Int32, String) | (Ereditato da TreeList)
Metodo pubblico | SelectCells(TreeListNode, TreeListColumn, TreeListNode, TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | SelectNode | (Ereditato da TreeList)
Metodo protetto | SelectNodeCore | (Ereditato da TreeList)
Metodo pubblico | SelectNodes(Int32, Int32) | (Ereditato da TreeList)
Metodo pubblico | SelectNodes(TreeListNode, TreeListNode) | (Ereditato da TreeList)
Metodo protetto | SelectNodesCore | (Ereditato da TreeList)
Metodo protetto | ServiceColumnChanged | (Ereditato da TreeList)
Metodo pubblico | SetAutoFilterValue | (Ereditato da TreeList)
Metodo protetto | SetCellSelection | (Ereditato da TreeList)
Metodo protetto | SetCellSelectionCore | (Ereditato da TreeList)
Metodo pubblico | SetColumnError(TreeListColumn, String) | (Ereditato da TreeList)
Metodo pubblico | SetColumnError(TreeListColumn, String, ErrorType) | (Ereditato da TreeList)
Metodo protetto | SetColumnFixedStyle | (Ereditato da TreeList)
Metodo pubblico | SetColumnPosition | (Ereditato da TreeList)
Metodo protetto | SetColumnVisibleIndex | (Ereditato da TreeList)
Metodo pubblico | SetDefaultBehaviorOptions | (Ereditato da TreeList)
Metodo pubblico | SetDefaultCustomizationOptions | (Ereditato da TreeList)
Metodo pubblico | SetDefaultNavigationOptions | (Ereditato da TreeList)
Metodo pubblico | SetDefaultOptionsView | (Ereditato da TreeList)
Metodo pubblico | SetDefaultPrintOptions | (Ereditato da TreeList)
Metodo pubblico | SetDefaultRowHeight | (Ereditato da TreeList)
Metodo pubblico | SetDefaultSelectionOptions | (Ereditato da TreeList)
Metodo protetto | SetExtraFilter | (Ereditato da TreeList)
Metodo protetto | SetFilterRowValue(Object, Object) | (Ereditato da TreeList)
Metodo protetto | SetFilterRowValue(TreeListColumn, Object) | (Ereditato da TreeList)
Metodo pubblico | SetFocusedNode | (Ereditato da TreeList)
Metodo protetto | SetFocusedNodeCore | (Ereditato da TreeList)
Metodo pubblico | SetFocusedRowCellValue(String, Object) | (Ereditato da TreeList)
Metodo pubblico | SetFocusedRowCellValue(TreeListColumn, Object) | (Ereditato da TreeList)
Metodo protetto | SetFocusedRowIndexCore | (Ereditato da TreeList)
Metodo pubblico | SetFocusedValue | (Ereditato da TreeList)
Metodo pubblico | SetNodeCheckState(TreeListNode, CheckState) | (Ereditato da TreeList)
Metodo pubblico | SetNodeCheckState(TreeListNode, CheckState, Boolean) | (Ereditato da TreeList)
Metodo pubblico | SetNodeIndex | (Ereditato da TreeList)
Metodo protetto | SetNodeIndexCore | (Ereditato da TreeList)
Metodo protetto | SetNodeValue | (Ereditato da TreeList)
Metodo pubblico | SetRowCellValue(TreeListNode, TreeListColumn, Object) | (Ereditato da TreeList)
Metodo pubblico | SetRowCellValue(TreeListNode, String, Object) | (Ereditato da TreeList)
Metodo pubblico | SetSearchControl | (Ereditato da TreeList)
Metodo pubblico | SetSelectionAnchor | (Ereditato da TreeList)
Metodo protetto | SetUseDirectXPaint | (Ereditato da TreeList)
Metodo protetto | ShouldResortNodesOnItemChanged | (Ereditato da TreeList)
Metodo protetto | ShouldSerializeLookAndFeel | (Ereditato da EditorContainer)
Metodo pubblico | ShowAutoFilterConditionsMenu | (Ereditato da TreeList)
Metodo pubblico | ShowContextMenu | (Ereditato da TreeList)
Metodo pubblico | ShowCustomization | (Ereditato da TreeList)
Metodo pubblico | ShowCustomization(Point) | (Ereditato da TreeList)
Metodo pubblico | ShowEditForm | (Ereditato da TreeList)
Metodo protetto | ShowEditFormCore | (Ereditato da TreeList)
Metodo protetto | ShowEditFormDialogCore | (Ereditato da TreeList)
Metodo pubblico | ShowEditor | (Ereditato da TreeList)
Metodo pubblico | ShowEditor(String) | (Ereditato da TreeList)
Metodo pubblico | ShowFilterEditor | (Ereditato da TreeList)
Metodo protetto | ShowFilterExpressionEditor | (Ereditato da TreeList)
Metodo pubblico | ShowFilterPopup | (Ereditato da TreeList)
Metodo pubblico | ShowFindPanel | (Ereditato da TreeList)
Metodo pubblico | ShowLoadingPanel | (Ereditato da TreeList)
Metodo protetto | ShowMenu | (Ereditato da TreeList)
Metodo protetto | ShowMRUFilterPopup | (Ereditato da TreeList)
Metodo pubblico | ShowPrintPreview | (Ereditato da TreeList)
Metodo protetto | ShowPrintPreviewCore | (Ereditato da TreeList)
Metodo protetto | ShowProgressForm | (Ereditato da TreeList)
Metodo pubblico | ShowRibbonPrintPreview | (Ereditato da TreeList)
Metodo protetto | ShowRibbonPrintPreviewCore | (Ereditato da TreeList)
Metodo pubblico | ShowUnboundExpressionEditor | (Ereditato da TreeList)
Metodo pubblico | Sort(TreeListNode, IComparerTreeListNode, Boolean) | (Ereditato da TreeList)
Metodo protetto | Sort(TreeListNodes, Boolean, Boolean) | (Ereditato da TreeList)
Metodo pubblico | Sort(TreeListNode, TreeListColumn, SortOrder, Boolean) | (Ereditato da TreeList)
Metodo pubblico | StartIncrementalSearch | (Ereditato da TreeList)
Metodo protetto | StartOfficeScrolling | (Ereditato da TreeList)
Metodo pubblico | StopIncrementalSearch | (Ereditato da TreeList)
Metodo protetto | StopOfficeScrolling | (Ereditato da TreeList)
Metodo pubblico | UncheckAll | (Ereditato da TreeList)
Metodo protetto | UnlockDirectXRendering | (Ereditato da TreeList)
Metodo pubblico | UnlockReloadNodes | (Ereditato da TreeList)
Metodo pubblico | UnselectCell | (Ereditato da TreeList)
Metodo protetto | UnselectCellCore | (Ereditato da TreeList)
Metodo pubblico | UnselectCells(Int32, String, Int32, String) | (Ereditato da TreeList)
Metodo pubblico | UnselectCells(TreeListNode, TreeListColumn, TreeListNode, TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | UnselectNode | (Ereditato da TreeList)
Metodo pubblico | UnselectNodes(Int32, Int32) | (Ereditato da TreeList)
Metodo pubblico | UnselectNodes(TreeListNode, TreeListNode) | (Ereditato da TreeList)
Metodo protetto | UpdateActiveFilterInfo | (Ereditato da TreeList)
Metodo protetto | UpdateAutoFilterRowActiveEditor | (Ereditato da TreeList)
Metodo protetto | UpdateBandColumnsIndices | (Ereditato da TreeList)
Metodo protetto | UpdateBandColumnsOrder | (Ereditato da TreeList)
Metodo protetto | UpdateColumnAutoFilter | (Ereditato da TreeList)
Metodo protetto | UpdateColumnsSortIndices | (Ereditato da TreeList)
Metodo protetto | UpdateElementsLookAndFeel | (Ereditato da TreeList)
Metodo protetto | UpdateFilter | (Ereditato da TreeList)
Metodo protetto | UpdateFilterInfo | (Ereditato da TreeList)
Metodo protetto | UpdateFindPanelFilterText | (Ereditato da TreeList)
Metodo protetto | UpdateLayout | (Ereditato da TreeList)
Metodo protetto | UpdateRootBands | (Ereditato da TreeList)
Metodo protetto | UpdateSelectCell | (Ereditato da TreeList)
Metodo protetto | UpdateSelectCell(TreeListNode, TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | UpdateSelectNode | (Ereditato da TreeList)
Metodo protetto | UpdateSelectNode(TreeListNode) | (Ereditato da TreeList)
Metodo protetto | UpdateVScrollBarCore | (Ereditato da TreeList)
Metodo protetto | ValidateAndEndCurrentEdit | (Ereditato da TreeList)
Metodo protetto | WndProc | (Ereditato da TreeList)
Metodo protetto | XtraClearColumns | (Ereditato da TreeList)
Metodo protetto | XtraCreateColumnsItem | (Ereditato da TreeList)
Metodo protetto | XtraFindColumnsItem | (Ereditato da TreeList)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | AfterCheckNode | (Ereditato da TreeList)
Evento pubblico | AfterCollapse | (Ereditato da TreeList)
Evento pubblico | AfterDragNode | (Ereditato da TreeList)
Evento pubblico | AfterDropNode | (Ereditato da TreeList)
Evento pubblico | AfterExpand | (Ereditato da TreeList)
Evento pubblico | AfterFocusNode | (Ereditato da TreeList)
Evento pubblico | BandPositionChanged | (Ereditato da TreeList)
Evento pubblico | BandWidthChanged | (Ereditato da TreeList)
Evento pubblico | BeforeCheckNode | (Ereditato da TreeList)
Evento pubblico | BeforeCollapse | (Ereditato da TreeList)
Evento pubblico | BeforeDragNode | (Ereditato da TreeList)
Evento pubblico | BeforeDropNode | (Ereditato da TreeList)
Evento pubblico | BeforeExpand | (Ereditato da TreeList)
Evento pubblico | BeforeFocusNode | (Ereditato da TreeList)
Evento pubblico | BeforeLoadLayout | (Ereditato da TreeList)
Evento pubblico | CalcNodeDragImageIndex | (Ereditato da TreeList)
Evento pubblico | CalcNodeHeight | (Ereditato da TreeList)
Evento pubblico | CellValueChanged | (Ereditato da TreeList)
Evento pubblico | CellValueChanging | (Ereditato da TreeList)
Evento pubblico | ClipboardNodeCopying | (Ereditato da TreeList)
Evento pubblico | ClipboardNodePasting | (Ereditato da TreeList)
Evento pubblico | ColumnButtonClick | (Ereditato da TreeList)
Evento pubblico | ColumnChanged | (Ereditato da TreeList)
Evento pubblico | ColumnFilterChanged | (Ereditato da TreeList)
Evento pubblico | ColumnPositionChanged | (Ereditato da TreeList)
Evento pubblico | ColumnUnboundExpressionChanged | (Ereditato da TreeList)
Evento pubblico | ColumnWidthChanged | (Ereditato da TreeList)
Evento pubblico | CompareNodeValues | (Ereditato da TreeList)
Evento pubblico | CreateCustomNode | (Ereditato da TreeList)
Evento pubblico | CustomColumnDisplayText | (Ereditato da TreeList)
Evento pubblico | CustomColumnSort | (Ereditato da TreeList)
Evento pubblico | CustomDrawBandHeader | (Ereditato da TreeList)
Evento pubblico | CustomDrawColumnHeader | (Ereditato da TreeList)
Evento pubblico | CustomDrawEmptyArea | (Ereditato da TreeList)
Evento pubblico | CustomDrawFilterPanel | (Ereditato da TreeList)
Evento pubblico | CustomDrawFooter | (Ereditato da TreeList)
Evento pubblico | CustomDrawFooterCell | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodeButton | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodeCell | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodeCheckBox | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodeImages | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodeIndent | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodeIndicator | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodePreview | (Ereditato da TreeList)
Evento pubblico | CustomDrawRow | (Ereditato da TreeList)
Evento pubblico | CustomDrawRowFooter | (Ereditato da TreeList)
Evento pubblico | CustomDrawRowFooterCell | (Ereditato da TreeList)
Evento pubblico | CustomDrawScroll | (Ereditato da TreeList)
Evento pubblico | CustomFilterDisplayText | (Ereditato da TreeList)
Evento pubblico | CustomizationFormSearch | (Ereditato da TreeList)
Evento pubblico | CustomizeNewNodeFromOuterData | (Ereditato da TreeList)
Evento pubblico | CustomizeNodeTemplate | (Ereditato da TreeList)
Evento pubblico | CustomNodeCellEdit | (Ereditato da TreeList)
Evento pubblico | CustomNodeCellEditForEditing | (Ereditato da TreeList)
Evento pubblico | CustomRowFilter | (Ereditato da TreeList)
Evento pubblico | CustomScrollAnnotation | (Ereditato da TreeList)
Evento pubblico | CustomUnboundColumnData | (Ereditato da TreeList)
Evento pubblico | DataSourceChanged | (Ereditato da TreeList)
Evento pubblico | DefaultPaintHelperChanged | (Ereditato da TreeList)
Evento pubblico | DragCancelNode | (Ereditato da TreeList)
Evento pubblico | DragObjectDrop | (Ereditato da TreeList)
Evento pubblico | DragObjectOver | (Ereditato da TreeList)
Evento pubblico | DragObjectStart | (Ereditato da TreeList)
Evento pubblico | EditFormHidden | (Ereditato da TreeList)
Evento pubblico | EditFormPrepared | (Ereditato da TreeList)
Evento pubblico | EditFormShowing | (Ereditato da TreeList)
Evento pubblico | EditorKeyDown | (Ereditato da EditorContainer)
Evento pubblico | EditorKeyPress | (Ereditato da EditorContainer)
Evento pubblico | EditorKeyUp | (Ereditato da EditorContainer)
Evento pubblico | EndSorting | (Ereditato da TreeList)
Evento pubblico | FilterEditorCreated | (Ereditato da TreeList)
Evento pubblico | FilterExpressionEditorCreated | (Ereditato da TreeList)
Evento pubblico | FilterNode | (Ereditato da TreeList)
Evento pubblico | FilterPopupExcelCustomizeTemplate | (Ereditato da TreeList)
Evento pubblico | FilterPopupExcelData | (Ereditato da TreeList)
Evento pubblico | FilterPopupExcelParseFilterCriteria | (Ereditato da TreeList)
Evento pubblico | FilterPopupExcelPrepareTemplate | (Ereditato da TreeList)
Evento pubblico | FilterPopupExcelQueryFilterCriteria | (Ereditato da TreeList)
Evento pubblico | FocusedColumnChanged | (Ereditato da TreeList)
Evento pubblico | FocusedNodeChanged | (Ereditato da TreeList)
Evento pubblico | FormatRuleExpressionEditorCreated | (Ereditato da TreeList)
Evento pubblico | GetCustomNodeCellEdit | Obsoleto. (Ereditato da TreeList)
Evento pubblico | GetCustomNodeCellStyle | Obsoleto. (Ereditato da TreeList)
Evento pubblico | GetCustomSummaryValue | (Ereditato da TreeList)
Evento pubblico | GetNodeDisplayValue | (Ereditato da TreeList)
Evento pubblico | GetPreviewText | (Ereditato da TreeList)
Evento pubblico | GetPrintCustomSummaryValue | (Ereditato da TreeList)
Evento pubblico | GetPrintPreviewText | (Ereditato da TreeList)
Evento pubblico | GetSelectImage | (Ereditato da TreeList)
Evento pubblico | GetStateImage | (Ereditato da TreeList)
Evento pubblico | HiddenEditor | (Ereditato da TreeList)
Evento pubblico | HideCustomizationForm | (Ereditato da TreeList)
Evento pubblico | HtmlElementBlur | (Ereditato da TreeList)
Evento pubblico | HtmlElementFocus | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseClick | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseDoubleClick | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseDown | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseMove | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseOut | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseOver | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseUp | (Ereditato da TreeList)
Evento pubblico | HtmlSelectedTextChanged | (Ereditato da TreeList)
Evento pubblico | HyperlinkClick | (Ereditato da TreeList)
Evento pubblico | InitNewRow | (Ereditato da TreeList)
Evento pubblico | InvalidNodeException | (Ereditato da TreeList)
Evento pubblico | InvalidValueException | (Ereditato da TreeList)
Evento pubblico | LayoutUpdated | (Ereditato da TreeList)
Evento pubblico | LayoutUpgrade | (Ereditato da TreeList)
Evento pubblico | LeftCoordChanged | (Ereditato da TreeList)
Evento pubblico | Load | (Ereditato da TreeList)
Evento pubblico | MeasurePreviewHeight | (Ereditato da TreeList)
Evento pubblico | NodeCellStyle | (Ereditato da TreeList)
Evento pubblico | NodeChanged | (Ereditato da TreeList)
Evento pubblico | NodesReloaded | (Ereditato da TreeList)
Evento pubblico | PaintEx | (Ereditato da TreeList)
Evento pubblico | ParseFindPanelText | (Ereditato da TreeList)
Evento pubblico | PopupMenuShowing | (Ereditato da TreeList)
Evento pubblico | PrintExportProgress | (Ereditato da TreeList)
Evento pubblico | PropertyDeserializing | (Ereditato da TreeList)
Evento pubblico | PropertySerializing | (Ereditato da TreeList)
Evento pubblico | QueryCustomFunctions | (Ereditato da TreeList)
Evento pubblico | QueryEmptyTreeTemplate | (Ereditato da TreeList)
Evento pubblico | QueryNodeTemplate | (Ereditato da TreeList)
Evento pubblico | RowCellClick | (Ereditato da TreeList)
Evento pubblico | RowClick | (Ereditato da TreeList)
Evento pubblico | RowSelectImageClick | (Ereditato da TreeList)
Evento pubblico | RowStateImageClick | (Ereditato da TreeList)
Evento pubblico | ScrollAnnotationsStyle | (Ereditato da TreeList)
Evento pubblico | SelectImageClick | (Ereditato da TreeList)
Evento pubblico | SelectionChanged | (Ereditato da TreeList)
Evento pubblico | SelectionChanging | (Ereditato da TreeList)
Evento pubblico | ShowCustomizationForm | (Ereditato da TreeList)
Evento pubblico | ShowFilterPopupCheckedListBox | (Ereditato da TreeList)
Evento pubblico | ShowFilterPopupDate | (Ereditato da TreeList)
Evento pubblico | ShowFilterPopupExcel | (Ereditato da TreeList)
Evento pubblico | ShowFilterPopupListBox | (Ereditato da TreeList)
Evento pubblico | ShowingEditor | (Ereditato da TreeList)
Evento pubblico | ShownEditor | (Ereditato da TreeList)
Evento pubblico | ShowTreeListMenu | Obsoleto. (Ereditato da TreeList)
Evento pubblico | StartSorting | (Ereditato da TreeList)
Evento pubblico | StateChanged | (Ereditato da TreeList)
Evento pubblico | StateImageClick | (Ereditato da TreeList)
Evento pubblico | SubstituteFilter | (Ereditato da TreeList)
Evento pubblico | TopVisibleNodeIndexChanged | (Ereditato da TreeList)
Evento pubblico | TreeListMenuItemClick | (Ereditato da TreeList)
Evento pubblico | UnboundExpressionEditorCreated | (Ereditato da TreeList)
Evento pubblico | ValidateNode | (Ereditato da TreeList)
Evento pubblico | ValidatingEditor | (Ereditato da TreeList)
Evento pubblico | VirtualTreeGetCellValue | (Ereditato da TreeList)
Evento pubblico | VirtualTreeGetChildNodes | (Ereditato da TreeList)
Evento pubblico | VirtualTreeSetCellValue | (Ereditato da TreeList)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | allowCloseEditor | (Ereditato da TreeList)
Campo pubblico | FilterByState |
Campo protetto | fInitializing | (Ereditato da EditorContainer)
Campo protetto | fUpdateSize | (Ereditato da TreeList)
Campo protetto | SortedColumns | (Ereditato da TreeList)
Campo pubblico | ViewState |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore DedDependenciesControl.MyTreeListDedDependencies

Costruttore DedDependenciesControlMyTreeListDedDependencies
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | DedDependenciesControlMyTreeListDedDependencies |
Metodo protetto | DedDependenciesControlMyTreeListDedDependencies(Object) |
Torna su
Vedi anche

Documentazione

Classe DedDependenciesControlMyTreeListDedDependencies
Namespace DedNet.Controls


Costruttore DedDependenciesControl.MyTreeListDedDependencies

Costruttore DedDependenciesControlMyTreeListDedDependencies

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public MyTreeListDedDependencies()
Public Sub New
public:
MyTreeListDedDependencies()
new : unit -> MyTreeListDedDependencies
Vedi anche

Documentazione

Classe DedDependenciesControlMyTreeListDedDependencies
Overload di DedDependenciesControlMyTreeListDedDependencies
Namespace DedNet.Controls


Costruttore DedDependenciesControl.MyTreeListDedDependencies(Object)

Costruttore DedDependenciesControlMyTreeListDedDependencies(Object)

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected MyTreeListDedDependencies(
    Object ignore
)
Protected Sub New (
    ignore As Object
)
protected:
MyTreeListDedDependencies(
    Object^ ignore
)
new :
        ignore : Object -> MyTreeListDedDependencies

Parametri

ignore Object
Vedi anche

Documentazione

Classe DedDependenciesControlMyTreeListDedDependencies
Overload di DedDependenciesControlMyTreeListDedDependencies
Namespace DedNet.Controls


Proprietà di MyTreeListDedDependencies

Il tipo DedDependenciesControlMyTreeListDedDependencies espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | ActiveEditor | (Ereditato da TreeList)
Proprietà pubblica | ActiveFilter | (Ereditato da TreeList)
Proprietà pubblica | ActiveFilterCriteria | (Ereditato da TreeList)
Proprietà pubblica | ActiveFilterEnabled | (Ereditato da TreeList)
Proprietà pubblica | ActiveFilterInfo | (Ereditato da TreeList)
Proprietà pubblica | ActiveFilterString | (Ereditato da TreeList)
Proprietà protetta | ActualAutoNodeHeight | (Ereditato da TreeList)
Proprietà protetta | ActualFilterCriteria | (Ereditato da TreeList)
Proprietà protetta | ActualShowBands | (Ereditato da TreeList)
Proprietà pubblica | AllNodesCount | (Ereditato da TreeList)
Proprietà protetta | AllowAnimatedScrolling | (Ereditato da TreeList)
Proprietà protetta | AllowAutoFilterConditionChange | (Ereditato da TreeList)
Proprietà protetta | AllowBandColumnsMultiRow | (Ereditato da TreeList)
Proprietà protetta | AllowExpandAnimation | (Ereditato da TreeList)
Proprietà protetta | AllowFiltering | (Ereditato da TreeList)
Proprietà protetta | AllowFilteringAfterLoadingData | (Ereditato da TreeList)
Proprietà protetta | AllowFilterNodes | (Ereditato da TreeList)
Proprietà protetta | AllowFindPanel | (Ereditato da TreeList)
Proprietà protetta | AllowPrintProgress | (Ereditato da TreeList)
Proprietà protetta | AllowScaleOnLoad | (Ereditato da EditorContainer)
Proprietà pubblica | AllowTouchGestures | (Ereditato da EditorContainer)
Proprietà protetta | AllowTouchScroll | (Ereditato da TreeList)
Proprietà protetta | AnnotationManager | (Ereditato da TreeList)
Proprietà pubblica | Appearance | (Ereditato da TreeList)
Proprietà pubblica | AppearancePrint | (Ereditato da TreeList)
Proprietà pubblica | AutoFillColumn | (Ereditato da TreeList)
Proprietà pubblica | AutoFillColumnName | (Ereditato da TreeList)
Proprietà pubblica | AutoFillFieldName | (Ereditato da TreeList)
Proprietà protetta | AutoFilterNode | (Ereditato da TreeList)
Proprietà pubblica | BackColor | (Ereditato da TreeList)
Proprietà pubblica | BandPanelRowHeight | (Ereditato da TreeList)
Proprietà pubblica | Bands | (Ereditato da TreeList)
Proprietà pubblica | BestFitVisibleOnly | (Ereditato da TreeList)
Proprietà pubblica | BorderStyle | (Ereditato da TreeList)
Proprietà protetta | CanExpandNodesOnIncrementalSearch | (Ereditato da TreeList)
Proprietà protetta | CanLoadNodes | (Ereditato da TreeList)
Proprietà protetta | CanShowBandsInCustomizationForm | (Ereditato da TreeList)
Proprietà pubblica | CanShowEditor | (Ereditato da TreeList)
Proprietà pubblica | CanShowRowFooterSummary | (Ereditato da TreeList)
Proprietà pubblica | Caption | (Ereditato da TreeList)
Proprietà pubblica | CaptionHeight | (Ereditato da TreeList)
Proprietà protetta | CheckBoxesStrategy | (Ereditato da TreeList)
Proprietà pubblica | CheckBoxFieldName | (Ereditato da TreeList)
Proprietà pubblica | ChildListFieldName | (Ereditato da TreeList)
Proprietà protetta | ClientHeight | (Ereditato da TreeList)
Proprietà protetta | ClientWidth | (Ereditato da TreeList)
Proprietà pubblica | ClipboardDataProvider | (Ereditato da TreeList)
Proprietà protetta | ClipboardPasteHelper | (Ereditato da TreeList)
Proprietà protetta | ClipboardPasteManager | (Ereditato da TreeList)
Proprietà protetta | CloneInfoList | (Ereditato da TreeList)
Proprietà pubblica | ColumnPanelRowHeight | (Ereditato da TreeList)
Proprietà pubblica | Columns | (Ereditato da TreeList)
Proprietà pubblica | ColumnsImageList | (Ereditato da TreeList)
Proprietà protetta | ContainerHelper | (Ereditato da TreeList)
Proprietà pubblica | ContextMenuStrip | (Ereditato da EditorContainer)
Proprietà protetta | CurrencyManager | (Ereditato da TreeList)
Proprietà pubblica | Cursor | (Ereditato da TreeList)
Proprietà pubblica | CustomizationForm | (Ereditato da TreeList)
Proprietà pubblica | CustomizationFormBounds | (Ereditato da TreeList)
Proprietà pubblica | CustomizationRowCount | Obsoleto. (Ereditato da TreeList)
Proprietà protetta | Data | (Ereditato da TreeList)
Proprietà pubblica | DataMember | (Ereditato da TreeList)
Proprietà pubblica | DataSource | (Ereditato da TreeList)
Proprietà protetta | DefaultSize | (Ereditato da TreeList)
Proprietà protetta | DirectXProvider | (Ereditato da TreeList)
Proprietà protetta | DirectXScroller | (Ereditato da TreeList)
Proprietà pubblica | DragExpandDelay | Obsoleto. (Ereditato da TreeList)
Proprietà pubblica | DragNodesMode | Obsoleto. (Ereditato da TreeList)
Proprietà protetta | DXAccessible | (Ereditato da TreeList)
Proprietà protetta | Editable | (Ereditato da TreeList)
Proprietà protetta | EditFormController | (Ereditato da TreeList)
Proprietà pubblica | EditingValue | (Ereditato da TreeList)
Proprietà protetta | EditorHelper | (Ereditato da EditorContainer)
Proprietà protetta | ElementsLookAndFeel | (Ereditato da TreeList)
Proprietà pubblica | EmptyTreeHtmlTemplate | (Ereditato da TreeList)
Proprietà protetta | EnableDirectXPaint | (Ereditato da TreeList)
Proprietà pubblica | EnableDynamicLoading | (Ereditato da TreeList)
Proprietà pubblica | EnableEnhancedScrolling | (Ereditato da TreeList)
Proprietà protetta | EnableEnhancedSorting | (Ereditato da TreeList)
Proprietà protetta | EnableFirstPaintTrigger | (Ereditato da EditorContainer)
Proprietà pubblica | EnableImprovedColumnSizing | (Ereditato da TreeList)
Proprietà protetta | ErrorInfo | (Ereditato da TreeList)
Proprietà protetta | ExcelFilteringProvider | (Ereditato da TreeList)
Proprietà protetta | ExceptionThrown | (Ereditato da TreeList)
Proprietà pubblica | ExternalRepository | (Ereditato da EditorContainer)
Proprietà protetta | ExtraFilter | (Ereditato da TreeList)
Proprietà protetta | ExtraFilterCriteria | (Ereditato da TreeList)
Proprietà protetta | ExtraFilterHightlightText | (Ereditato da TreeList)
Proprietà protetta | FilterColumnsProvider | (Ereditato da TreeList)
Proprietà protetta | FilterHelper | (Ereditato da TreeList)
Proprietà protetta | FilteringService | (Ereditato da TreeList)
Proprietà pubblica | FilterPanelText | (Ereditato da TreeList)
Proprietà protetta | FilterPopup | (Ereditato da TreeList)
Proprietà protetta | FindFilterCriteria | (Ereditato da TreeList)
Proprietà pubblica | FindFilterText | (Ereditato da TreeList)
Proprietà protetta | FindPanel | (Ereditato da TreeList)
Proprietà pubblica | FindPanelVisible | (Ereditato da TreeList)
Proprietà protetta | FireOnLoadOnPaint | (Ereditato da TreeList)
Proprietà pubblica | FixedLineWidth | (Ereditato da TreeList)
Proprietà protetta | FocusedCellIndex | (Ereditato da TreeList)
Proprietà pubblica | FocusedColumn | (Ereditato da TreeList)
Proprietà pubblica | FocusedNode | (Ereditato da TreeList)
Proprietà protetta | FocusedRow | (Ereditato da TreeList)
Proprietà protetta | FocusedRowIndex | (Ereditato da TreeList)
Proprietà pubblica | FocusedValue | (Ereditato da TreeList)
Proprietà pubblica | FooterPanelHeight | (Ereditato da TreeList)
Proprietà protetta | ForceLoadingPanel | (Ereditato da TreeList)
Proprietà pubblica | ForeColor | (Ereditato da EditorContainer)
Proprietà pubblica | FormatConditions | (Ereditato da TreeList)
Proprietà pubblica | FormatRules | (Ereditato da TreeList)
Proprietà pubblica | GroupButtonSize | Obsoleto. (Ereditato da TreeList)
Proprietà protetta | Handler | (Ereditato da TreeList)
Proprietà protetta | HasAccessible | (Ereditato da TreeList)
Proprietà protetta | HasAllColumnsFixedRight | (Ereditato da TreeList)
Proprietà protetta | HasBands | (Ereditato da TreeList)
Proprietà pubblica | HasColumnErrors | (Ereditato da TreeList)
Proprietà protetta | HasCustomNodeCellEdit | (Ereditato da TreeList)
Proprietà pubblica | HasFocus | (Ereditato da TreeList)
Proprietà protetta | HasHierarchicalColumn | (Ereditato da TreeList)
Proprietà protetta | HasTreeViewColumn | (Ereditato da TreeList)
Proprietà protetta | HeaderLayoutCalculator | (Ereditato da TreeList)
Proprietà protetta | HeaderWidthCalculator | (Ereditato da TreeList)
Proprietà pubblica | HierarchyColumn | (Ereditato da TreeList)
Proprietà pubblica | HierarchyColumnIndent | (Ereditato da TreeList)
Proprietà pubblica | HierarchyColumnName | (Ereditato da TreeList)
Proprietà pubblica | HierarchyFieldName | (Ereditato da TreeList)
Proprietà pubblica | HorzScrollStep | (Ereditato da TreeList)
Proprietà pubblica | HorzScrollVisibility | (Ereditato da TreeList)
Proprietà protetta | HtmlContext | (Ereditato da TreeList)
Proprietà pubblica | HtmlImages | (Ereditato da TreeList)
Proprietà protetta | HtmlObjectCache | (Ereditato da TreeList)
Proprietà pubblica | HtmlTemplates | (Ereditato da TreeList)
Proprietà protetta | IBasePrintableCreatesIntersectedBricks | (Ereditato da TreeList)
Proprietà pubblica | ImageIndexFieldName | (Ereditato da TreeList)
Proprietà protetta | IncrementalText | (Ereditato da TreeList)
Proprietà pubblica | IndicatorWidth | (Ereditato da TreeList)
Proprietà protetta | IsAllowBusyIndicator | (Ereditato da TreeList)
Proprietà protetta | IsAllowBusyPanel | (Ereditato da TreeList)
Proprietà protetta | IsAlt | (Ereditato da TreeList)
Proprietà protetta | IsAttachedToSearchControl | (Ereditato da TreeList)
Proprietà protetta | IsAutoWidth | (Ereditato da TreeList)
Proprietà protetta | IsCellSelect | (Ereditato da TreeList)
Proprietà protetta | IsClosingEditor | (Ereditato da TreeList)
Proprietà protetta | IsColumnHeaderAutoHeight | (Ereditato da TreeList)
Proprietà protetta | IsControl | (Ereditato da TreeList)
Proprietà protetta | IsDataReady | (Ereditato da TreeList)
Proprietà protetta | IsDeserializing | (Ereditato da TreeList)
Proprietà pubblica | IsDesignMode | (Ereditato da EditorContainer)
Proprietà protetta | IsDynamicLoadingAllowed | (Ereditato da TreeList)
Proprietà protetta | IsEditFormMode | (Ereditato da TreeList)
Proprietà pubblica | IsFilterByStateActive |
Proprietà protetta | IsFilterPopupActive | (Ereditato da TreeList)
Proprietà protetta | IsFindFilterActive | (Ereditato da TreeList)
Proprietà pubblica | IsFindPanelVisible | (Ereditato da TreeList)
Proprietà protetta | IsFocusedNodeChangedLocked | (Ereditato da TreeList)
Proprietà protetta | IsFocusedNodeDataModified | (Ereditato da TreeList)
Proprietà protetta | IsGroupDeleteOperation | (Ereditato da TreeList)
Proprietà protetta | IsHScrollBarVisible | (Ereditato da TreeList)
Proprietà protetta | IsInitialized | (Ereditato da EditorContainer)
Proprietà protetta | IsIniting | (Ereditato da TreeList)
Proprietà pubblica | IsLoading | (Ereditato da EditorContainer)
Proprietà protetta | IsLockDirectXRendering | (Ereditato da TreeList)
Proprietà protetta | IsLockExpandCollapse | (Ereditato da TreeList)
Proprietà protetta | IsLockUpdate | (Ereditato da TreeList)
Proprietà pubblica | IsLookUpMode | (Ereditato da TreeList)
Proprietà protetta | IsMultiSelect | (Ereditato da TreeList)
Proprietà protetta | IsNotificationInfoVisible | (Ereditato da TreeList)
Proprietà protetta | IsPainting | (Ereditato da TreeList)
Proprietà protetta | IsPixelScrolling | (Ereditato da TreeList)
Proprietà protetta | IsPopupEditFormVisible | (Ereditato da TreeList)
Proprietà pubblica | IsPrinting | (Ereditato da TreeList)
Proprietà pubblica | IsPrintingAvailable | (Ereditato da TreeList)
Proprietà protetta | IsRightToLeft | (Ereditato da TreeList)
Proprietà protetta | IsRowCountReady | (Ereditato da TreeList)
Proprietà protetta | IsScrollAnimationInProgress | (Ereditato da TreeList)
Proprietà protetta | IsSearchMode | (Ereditato da TreeList)
Proprietà protetta | IsSerializing | (Ereditato da TreeList)
Proprietà protetta | IsShift | (Ereditato da TreeList)
Proprietà protetta | IsSorted | (Ereditato da TreeList)
Proprietà protetta | IsUnboundLoad | (Ereditato da TreeList)
Proprietà pubblica | IsUnboundMode | (Ereditato da TreeList)
Proprietà protetta | IsUpdateSize | (Ereditato da TreeList)
Proprietà protetta | IsVirtualMode | (Ereditato da TreeList)
Proprietà protetta | IsVScrollBarVisible | (Ereditato da TreeList)
Proprietà pubblica | KeyFieldName | (Ereditato da TreeList)
Proprietà pubblica | LayoutVersion | Obsoleto. (Ereditato da TreeList)
Proprietà pubblica | LeftCoord | (Ereditato da TreeList)
Proprietà pubblica | LoadingPanelVisible | (Ereditato da TreeList)
Proprietà pubblica | LookAndFeel | (Ereditato da EditorContainer)
Proprietà protetta | LookAndFeelIgnoreChildren | (Ereditato da EditorContainer)
Proprietà protetta | LookUpDisplayColumn | (Ereditato da TreeList)
Proprietà protetta | LookUpOwner | (Ereditato da TreeList)
Proprietà pubblica | MenuManager | (Ereditato da EditorContainer)
Proprietà protetta | MinRowHeight | (Ereditato da TreeList)
Proprietà pubblica | MinWidth | (Ereditato da TreeList)
Proprietà protetta | MRUFilterPopup | (Ereditato da TreeList)
Proprietà pubblica | MRUFilters | (Ereditato da TreeList)
Proprietà protetta | NewItemNode | (Ereditato da TreeList)
Proprietà pubblica | NewItemRowText | (Ereditato da TreeList)
Proprietà pubblica | NodeHtmlTemplate | (Ereditato da TreeList)
Proprietà pubblica | Nodes | (Ereditato da TreeList)
Proprietà pubblica | NodesIterator | (Ereditato da TreeList)
Proprietà pubblica | NonColumnFilterCriteria | (Ereditato da TreeList)
Proprietà pubblica | NonColumnFilterString | (Ereditato da TreeList)
Proprietà protetta | NotificationInfo | (Ereditato da TreeList)
Proprietà protetta | OfficeScroller | (Ereditato da TreeList)
Proprietà pubblica | OptionsBehavior | (Ereditato da TreeList)
Proprietà pubblica | OptionsClipboard | (Ereditato da TreeList)
Proprietà pubblica | OptionsCustomization | (Ereditato da TreeList)
Proprietà pubblica | OptionsDragAndDrop | (Ereditato da TreeList)
Proprietà pubblica | OptionsEditForm | (Ereditato da TreeList)
Proprietà pubblica | OptionsFilter | (Ereditato da TreeList)
Proprietà pubblica | OptionsFind | (Ereditato da TreeList)
Proprietà pubblica | OptionsHtmlTemplate | (Ereditato da TreeList)
Proprietà pubblica | OptionsLayout | (Ereditato da TreeList)
Proprietà pubblica | OptionsMenu | (Ereditato da TreeList)
Proprietà pubblica | OptionsNavigation | (Ereditato da TreeList)
Proprietà pubblica | OptionsPrint | (Ereditato da TreeList)
Proprietà pubblica | OptionsScrollAnnotations | (Ereditato da TreeList)
Proprietà pubblica | OptionsSelection | (Ereditato da TreeList)
Proprietà pubblica | OptionsView | (Ereditato da TreeList)
Proprietà pubblica | Painter | (Ereditato da TreeList)
Proprietà pubblica | ParentFieldName | (Ereditato da TreeList)
Proprietà protetta | Position | (Ereditato da TreeList)
Proprietà protetta | PressedBand | (Ereditato da TreeList)
Proprietà protetta | PressedColumn | (Ereditato da TreeList)
Proprietà protetta | PressedNode | (Ereditato da TreeList)
Proprietà pubblica | PreviewFieldName | (Ereditato da TreeList)
Proprietà pubblica | PreviewIndent | (Ereditato da TreeList)
Proprietà pubblica | PreviewLineCount | (Ereditato da TreeList)
Proprietà protetta | Printer | (Ereditato da TreeList)
Proprietà protetta | PrinterCore | (Ereditato da TreeList)
Proprietà protetta | ProgressWindow | (Ereditato da TreeList)
Proprietà pubblica | RepositoryItems | (Ereditato da EditorContainer)
Proprietà pubblica | RootValue | (Ereditato da TreeList)
Proprietà protetta | RowCount | (Ereditato da TreeList)
Proprietà pubblica | RowHeight | (Ereditato da TreeList)
Proprietà protetta | ScaleDPI | (Ereditato da EditorContainer)
Proprietà pubblica | ScaleFactor | (Ereditato da EditorContainer)
Proprietà protetta | ScaleHelper | (Ereditato da EditorContainer)
Proprietà protetta | ScrollInfo | (Ereditato da TreeList)
Proprietà pubblica | SelectedHtmlText | (Ereditato da TreeList)
Proprietà pubblica | SelectImageList | (Ereditato da TreeList)
Proprietà pubblica | Selection | (Ereditato da TreeList)
Proprietà protetta | SelectionRange | (Ereditato da TreeList)
Proprietà pubblica | ShowButtonMode | (Ereditato da TreeList)
Proprietà protetta | ShowEditorAfterAnimatedScroll | (Ereditato da TreeList)
Proprietà protetta | ShowPreview | (Ereditato da TreeList)
Proprietà protetta | SizedBand | (Ereditato da TreeList)
Proprietà protetta | SizedColumn | (Ereditato da TreeList)
Proprietà protetta | SmartVisibility | (Ereditato da TreeList)
Proprietà pubblica | SortedColumnCount | (Ereditato da TreeList)
Proprietà pubblica | State | (Ereditato da TreeList)
Proprietà pubblica | StateImageList | (Ereditato da TreeList)
Proprietà pubblica | SyncCheckStateWithSourceOnChecking | (Ereditato da TreeList)
Proprietà pubblica | Text | (Ereditato da EditorContainer)
Proprietà pubblica | ToolTipController | (Ereditato da EditorContainer)
Proprietà protetta | TopVisibleNode | (Ereditato da TreeList)
Proprietà pubblica | TopVisibleNodeIndex | (Ereditato da TreeList)
Proprietà pubblica | TopVisibleNodePixel | (Ereditato da TreeList)
Proprietà pubblica | TreeLevelWidth | (Ereditato da TreeList)
Proprietà pubblica | TreeLineStyle | (Ereditato da TreeList)
Proprietà pubblica | TreeListDisposing | (Ereditato da TreeList)
Proprietà pubblica | TreeViewColumn | (Ereditato da TreeList)
Proprietà pubblica | TreeViewColumnName | (Ereditato da TreeList)
Proprietà pubblica | TreeViewFieldName | (Ereditato da TreeList)
Proprietà pubblica | UpdateTopVisibleNodeIndexOnCollapse | (Ereditato da TreeList)
Proprietà protetta | UseBandsAdvancedHorizontalNavigation | (Ereditato da TreeList)
Proprietà protetta | UseBandsAdvancedVerticalNavigation | (Ereditato da TreeList)
Proprietà pubblica | UseDirectXPaint | (Ereditato da TreeList)
Proprietà pubblica | UseDisabledStatePainter | (Ereditato da TreeList)
Proprietà protetta | UseStandardFilter | (Ereditato da TreeList)
Proprietà pubblica | VertScrollVisibility | (Ereditato da TreeList)
Proprietà pubblica | ViewInfo | (Ereditato da TreeList)
Proprietà pubblica | ViewStyle | (Ereditato da TreeList)
Proprietà protetta | VirtualDataHelper | (Ereditato da TreeList)
Proprietà pubblica | VisibleColumnCount | Obsoleto. (Ereditato da TreeList)
Proprietà pubblica | VisibleColumns | (Ereditato da TreeList)
Proprietà pubblica | VisibleNodesCount | (Ereditato da TreeList)
Proprietà protetta | WorkAsLookup | (Ereditato da TreeList)
Torna su
Vedi anche

Documentazione

Classe DedDependenciesControlMyTreeListDedDependencies
Namespace DedNet.Controls


Proprietà DedDependenciesControl.MyTreeListDedDependencies.IsFilterByStateActive

Proprietà DedDependenciesControlMyTreeListDedDependenciesIsFilterByStateActive

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsFilterByStateActive { get; }
Public ReadOnly Property IsFilterByStateActive As Boolean
    Get
public:
property bool IsFilterByStateActive {
    bool get ();
}
member IsFilterByStateActive : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDependenciesControlMyTreeListDedDependencies
Namespace DedNet.Controls


Metodi di MyTreeListDedDependencies

Il tipo DedDependenciesControlMyTreeListDedDependencies espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AccessibleNotifyClients(AccessibleEvents, BaseAccessible) | (Ereditato da TreeList)
Metodo pubblico | AccessibleNotifyClients(AccessibleEvents, Int32, Int32) | (Ereditato da TreeList)
Metodo pubblico | AddFilter(CriteriaOperator) | (Ereditato da TreeList)
Metodo pubblico | AddFilter(String) | (Ereditato da TreeList)
Metodo protetto | AddToDefaultTooltipController | (Ereditato da EditorContainer)
Metodo protetto | AllowAutoFilterCondition | (Ereditato da TreeList)
Metodo protetto | AnimateKeyboardNavigation | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, TreeListNode) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, TreeListNode, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, TreeListNode, CheckState) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, CheckState) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, TreeListNode, CheckState, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, CheckState, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, TreeListNode, CheckState, NodeCheckBoxStyle, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, Int32, Int32, Int32) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, Int32, Int32, Int32, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, Int32, Int32, Int32, CheckState) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, Int32, Int32, Int32, CheckState, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, Int32, Int32, Int32, CheckState, NodeCheckBoxStyle, Object) | (Ereditato da TreeList)
Metodo protetto | ApplyFilter | (Ereditato da TreeList)
Metodo pubblico | ApplyFindFilter | (Ereditato da TreeList)
Metodo protetto | BeforeShowEditForm | (Ereditato da TreeList)
Metodo pubblico | BeginDelete | (Ereditato da TreeList)
Metodo protetto | BeginDragDrop | (Ereditato da TreeList)
Metodo protetto | BeginExpandCollapse | (Ereditato da TreeList)
Metodo pubblico | BeginInit | (Ereditato da EditorContainer)
Metodo protetto | BeginLockListChanged | (Ereditato da TreeList)
Metodo pubblico | BeginSelection | (Ereditato da TreeList)
Metodo pubblico | BeginSort | (Ereditato da TreeList)
Metodo pubblico | BeginUnboundLoad | (Ereditato da TreeList)
Metodo pubblico | BeginUpdate | (Ereditato da TreeList)
Metodo pubblico | BestFitColumns | (Ereditato da TreeList)
Metodo pubblico | BestFitColumns(Boolean) | (Ereditato da TreeList)
Metodo pubblico | BindCommand(Object, String, FuncObject) | (Ereditato da TreeList)
Metodo pubblico | BindCommand(ExpressionAction, Object, String, FuncObject) | (Ereditato da TreeList)
Metodo pubblico | BindCommand``1(ExpressionActionUMP, Object, String, FuncUMP) | (Ereditato da TreeList)
Metodo protetto | CalcActiveEditorBounds | (Ereditato da TreeList)
Metodo protetto | CalcColumnBestWidth | (Ereditato da TreeList)
Metodo pubblico | CalcHitInfo | (Ereditato da TreeList)
Metodo protetto | CalcHScrollRange | (Ereditato da TreeList)
Metodo protetto | CalcNodeAutoHeight | (Ereditato da TreeList)
Metodo protetto | CalcRowCount | (Ereditato da TreeList)
Metodo protetto | CalcScrollClientRect | (Ereditato da TreeList)
Metodo protetto | CalculateScrollBars | (Ereditato da TreeList)
Metodo protetto | CalculateVisibleRowsAreaHeight | (Ereditato da TreeList)
Metodo pubblico | CancelCurrentEdit | (Ereditato da TreeList)
Metodo protetto | CancelDirectXRendering | (Ereditato da TreeList)
Metodo protetto | CancelLockListChanged | (Ereditato da TreeList)
Metodo protetto | CancelSelection | (Ereditato da TreeList)
Metodo pubblico | CancelSort | (Ereditato da TreeList)
Metodo pubblico | CancelUpdate | (Ereditato da TreeList)
Metodo protetto | CanClearAllSorting | (Ereditato da TreeList)
Metodo protetto | CanCloneChildren | (Ereditato da TreeList)
Metodo protetto | CanFilterByColumnEdit | (Ereditato da TreeList)
Metodo pubblico | CanFilterColumn | (Ereditato da TreeList)
Metodo protetto | CanFindColumn | (Ereditato da TreeList)
Metodo protetto | CanFocusNode | (Ereditato da TreeList)
Metodo protetto | CanHandleTouchGestures | (Ereditato da EditorContainer)
Metodo protetto | CanIncrementalSearch | (Ereditato da TreeList)
Metodo pubblico | CanIndentNodes | (Ereditato da TreeList)
Metodo protetto | CanMove | (Ereditato da TreeList)
Metodo protetto | CanMoveBand | (Ereditato da TreeList)
Metodo protetto | CanMoveColumn | (Ereditato da TreeList)
Metodo pubblico | CanOutdentNodes | (Ereditato da TreeList)
Metodo protetto | CanResizeBand | (Ereditato da TreeList)
Metodo protetto | CanResizeColumn | (Ereditato da TreeList)
Metodo protetto | CanShowHScrollBar | (Ereditato da TreeList)
Metodo protetto | CanShowHScrollBarCore | (Ereditato da TreeList)
Metodo protetto | CanShowVScrollBar | (Ereditato da TreeList)
Metodo protetto | CanSortByColumnEdit | (Ereditato da TreeList)
Metodo pubblico | CanSortColumn | (Ereditato da TreeList)
Metodo protetto | CanStartTouchScrolling | (Ereditato da TreeList)
Metodo protetto | ChangeLeftCoord | (Ereditato da TreeList)
Metodo pubblico | CheckAll | (Ereditato da TreeList)
Metodo protetto | CheckAllowGestures | (Ereditato da TreeList)
Metodo protetto | CheckAllowNotifications | (Ereditato da TreeList)
Metodo protetto | CheckData | (Ereditato da TreeList)
Metodo protetto | CheckIncreaseVisibleRows | (Ereditato da TreeList)
Metodo protetto | CheckModifierKeys | (Ereditato da TreeList)
Metodo protetto | CheckNeedScale | (Ereditato da EditorContainer)
Metodo protetto | CheckRightToLeft | (Ereditato da EditorContainer)
Metodo protetto | CheckSearchMode | (Ereditato da TreeList)
Metodo protetto | CheckTopVisibleNodeAfterItemAdded | (Ereditato da TreeList)
Metodo protetto | CheckTopVisibleNodePixelValue | (Ereditato da TreeList)
Metodo pubblico | ClearColumnErrors | (Ereditato da TreeList)
Metodo pubblico | ClearColumnFilter | (Ereditato da TreeList)
Metodo protetto | ClearColumnFilterCore(String) | (Ereditato da TreeList)
Metodo protetto | ClearColumnFilterCore(TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | ClearColumnsFilter | (Ereditato da TreeList)
Metodo pubblico | ClearDocument | (Ereditato da TreeList)
Metodo pubblico | ClearFindFilter | (Ereditato da TreeList)
Metodo pubblico | ClearFocusedColumn | (Ereditato da TreeList)
Metodo pubblico | ClearNodes | (Ereditato da TreeList)
Metodo pubblico | ClearSelection | (Ereditato da TreeList)
Metodo pubblico | ClearSorting | (Ereditato da TreeList)
Metodo protetto | ClearVisibleIndicesCache | (Ereditato da TreeList)
Metodo pubblico | CloseEditForm | (Ereditato da TreeList)
Metodo pubblico | CloseEditor | (Ereditato da TreeList)
Metodo protetto | CloseEditor(Boolean) | (Ereditato da TreeList)
Metodo pubblico | CollapseAll | (Ereditato da TreeList)
Metodo protetto | CollapseAllCore | (Ereditato da TreeList)
Metodo pubblico | CollapseToLevel | (Ereditato da TreeList)
Metodo pubblico | ColumnsCustomization | (Ereditato da TreeList)
Metodo pubblico | ColumnsCustomization(Point) | (Ereditato da TreeList)
Metodo protetto | ControlRowSourceSelectedChanged | (Ereditato da TreeList)
Metodo protetto | ControlRowSourceVisibleChanged | (Ereditato da TreeList)
Metodo pubblico | ConvertFormatConditionToFormatRules | (Ereditato da TreeList)
Metodo pubblico | CopyNode(TreeListNode, TreeListNode, Boolean) | (Ereditato da TreeList)
Metodo pubblico | CopyNode(TreeListNode, TreeListNode, Boolean, Boolean) | (Ereditato da TreeList)
Metodo pubblico | CopyNode(TreeListNode, TreeListNode, Boolean, Int32) | (Ereditato da TreeList)
Metodo pubblico | CopyNode(TreeListNode, TreeListNode, Boolean, Boolean, Int32) | (Ereditato da TreeList)
Metodo protetto | CopyNodeCore | (Ereditato da TreeList)
Metodo pubblico | CopyNodes(IEnumerableTreeListNode, TreeListNode, Boolean, Int32) | (Ereditato da TreeList)
Metodo pubblico | CopyNodes(IEnumerableTreeListNode, TreeListNode, Boolean, Boolean, Int32) | (Ereditato da TreeList)
Metodo pubblico | CopyToClipboard | (Ereditato da TreeList)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da TreeList)
Metodo protetto | CreateAccessibleDataRow | (Ereditato da TreeList)
Metodo protetto | CreateAccessibleInstance | (Ereditato da TreeList)
Metodo protetto | CreateAllOptions | (Ereditato da TreeList)
Metodo protetto | CreateAnnotationManager | (Ereditato da TreeList)
Metodo protetto | CreateAppearances | (Ereditato da TreeList)
Metodo protetto | CreateAutoFilterCriterion | (Ereditato da TreeList)
Metodo protetto | CreateBands | (Ereditato da TreeList)
Metodo protetto | CreateCheckBoxesStrategy | (Ereditato da TreeList)
Metodo protetto | CreateCheckedListFilterPopup | (Ereditato da TreeList)
Metodo protetto | CreateColumn | (Ereditato da TreeList)
Metodo protetto | CreateColumnEditViewInfo | (Ereditato da TreeList)
Metodo protetto | CreateColumnFilterCriteriaByValue(TreeListColumn, Object) | (Ereditato da TreeList)
Metodo protetto | CreateColumnFilterCriteriaByValue(TreeListColumn, Object, Boolean) | (Ereditato da TreeList)
Metodo protetto | CreateColumnFilterPopup | (Ereditato da TreeList)
Metodo protetto | CreateColumns | (Ereditato da TreeList)
Metodo pubblico | CreateCustomization | Obsoleto. (Ereditato da TreeList)
Metodo protetto | CreateCustomizationForm | (Ereditato da TreeList)
Metodo protetto | CreateData | (Ereditato da TreeList)
Metodo protetto | CreateDataViewData | (Ereditato da TreeList)
Metodo protetto | CreateDateFilterPopup | (Ereditato da TreeList)
Metodo protetto | CreateDragNodesProvider | (Ereditato da TreeList)
Metodo protetto | CreateEditFormController | (Ereditato da TreeList)
Metodo protetto | CreateElementsLookAndFeel | (Ereditato da TreeList)
Metodo protetto | CreateExcelFilterPopup | (Ereditato da TreeList)
Metodo protetto | CreateFilterColumnCollection | (Ereditato da TreeList)
Metodo protetto | CreateFilterColumnRuleCollection | (Ereditato da TreeList)
Metodo protetto | CreateFilterColumnsProvider | (Ereditato da TreeList)
Metodo protetto | CreateFilterCriteriaBindingTarget | (Ereditato da TreeList)
Metodo protetto | CreateFilterEditorForm | (Ereditato da TreeList)
Metodo protetto | CreateFilterHelper | (Ereditato da TreeList)
Metodo protetto | CreateFindPanel | (Ereditato da TreeList)
Metodo protetto | CreateFindPanelCore | (Ereditato da TreeList)
Metodo pubblico | CreateGraphicsCache | (Ereditato da TreeList)
Metodo protetto | CreateHandler | (Ereditato da TreeList)
Metodo protetto | CreateHeaderLayoutCalculator | (Ereditato da TreeList)
Metodo protetto | CreateHeaderWidthCalculator | (Ereditato da TreeList)
Metodo protetto | CreateHelper | (Ereditato da TreeList)
Metodo protetto | CreateHierarchicalListData | (Ereditato da TreeList)
Metodo protetto | CreateHtmlContext | (Ereditato da TreeList)
Metodo protetto | CreateHyperlinkClickEventArgs | (Ereditato da TreeList)
Metodo protetto | CreateInternalRepository | (Ereditato da EditorContainer)
Metodo protetto | CreateListColumnFilterPopup | (Ereditato da TreeList)
Metodo protetto | CreateListData | (Ereditato da TreeList)
Metodo protetto | CreateLoadingAnimator | (Ereditato da TreeList)
Metodo protetto | CreateLoadingPanel | (Ereditato da TreeList)
Metodo protetto | CreateLookAndFeel | (Ereditato da EditorContainer)
Metodo protetto | CreateNewItemNode | (Ereditato da TreeList)
Metodo protetto | CreateNode(Int32, TreeListNodes) | (Ereditato da TreeList)
Metodo protetto | CreateNode(Int32, TreeListNodes, Object) | (Ereditato da TreeList)
Metodo protetto | CreateNodes | (Ereditato da TreeList)
Metodo protetto | CreateNodesComparer | (Ereditato da TreeList)
Metodo protetto | CreateNodesIterator | (Ereditato da TreeList)
Metodo protetto | CreateNotificationInfo | (Ereditato da TreeList)
Metodo protetto | CreateOfficeScroller | (Ereditato da TreeList)
Metodo protetto | CreateOptionsBehavior | (Ereditato da TreeList)
Metodo protetto | CreateOptionsClipboard | (Ereditato da TreeList)
Metodo protetto | CreateOptionsCustomization | (Ereditato da TreeList)
Metodo protetto | CreateOptionsDragAndDrop | (Ereditato da TreeList)
Metodo protetto | CreateOptionsEditForm | (Ereditato da TreeList)
Metodo protetto | CreateOptionsFilter | (Ereditato da TreeList)
Metodo protetto | CreateOptionsFind | (Ereditato da TreeList)
Metodo protetto | CreateOptionsHtmlTemplate | (Ereditato da TreeList)
Metodo protetto | CreateOptionsLayout | (Ereditato da TreeList)
Metodo protetto | CreateOptionsMenu | (Ereditato da TreeList)
Metodo protetto | CreateOptionsNavigation | (Ereditato da TreeList)
Metodo protetto | CreateOptionsPrint | (Ereditato da TreeList)
Metodo protetto | CreateOptionsScrollAnnotations | (Ereditato da TreeList)
Metodo protetto | CreateOptionsSelection | (Ereditato da TreeList)
Metodo protetto | CreateOptionsView | (Ereditato da TreeList)
Metodo protetto | CreatePainter | (Ereditato da TreeList)
Metodo protetto | CreatePrinter | (Ereditato da TreeList)
Metodo protetto | CreateProvider | (Ereditato da TreeList)
Metodo protetto | CreateScrollInfo | (Ereditato da TreeList)
Metodo protetto | CreateSelection | (Ereditato da TreeList)
Metodo protetto | CreateUnboundData | (Ereditato da TreeList)
Metodo protetto | CreateViewInfo | (Ereditato da TreeList)
Metodo protetto | CreateVirtualData | (Ereditato da TreeList)
Metodo protetto | CreateVirtualDataHelper | (Ereditato da TreeList)
Metodo protetto | CurrencyManager_ItemChanged | (Ereditato da TreeList)
Metodo protetto | CurrencyManager_PositionChanged | (Ereditato da TreeList)
Metodo protetto | DeferredLoadChildren | (Ereditato da TreeList)
Metodo protetto | DelayedInvalidate | (Ereditato da TreeList)
Metodo pubblico | DeleteNode | (Ereditato da TreeList)
Metodo pubblico | DeleteNodes | (Ereditato da TreeList)
Metodo pubblico | DeleteSelectedNodes | (Ereditato da TreeList)
Metodo pubblico | DestroyCustomization | (Ereditato da TreeList)
Metodo protetto | DestroyDirectXProvider | (Ereditato da EditorContainer)
Metodo protetto | DestroyFindPanel | (Ereditato da TreeList)
Metodo protetto | Dispose | (Ereditato da TreeList)
Metodo protetto | DoDataSourceChanged | (Ereditato da TreeList)
Metodo protetto | DoDpiChange | (Ereditato da EditorContainer)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da TreeList)
Metodo protetto | DoDragDrop | (Ereditato da TreeList)
Metodo pubblico | DoDragDropNode | (Ereditato da TreeList)
Metodo pubblico | DoDragDropNodes | (Ereditato da TreeList)
Metodo protetto | DoFilterNode | (Ereditato da TreeList)
Metodo protetto | DoForEachBand | (Ereditato da TreeList)
Metodo pubblico | DoIncrementalSearch | (Ereditato da TreeList)
Metodo protetto | DoShowTreeListMenu(TreeListMenu, TreeListHitTest) | (Ereditato da TreeList)
Metodo protetto | DoShowTreeListMenu(TreeListMenu, Control, Point) | (Ereditato da TreeList)
Metodo protetto | DoTopVisibleNodeChanged | (Ereditato da TreeList)
Metodo pubblico | EndCurrentEdit | (Ereditato da TreeList)
Metodo pubblico | EndCurrentEdit(Boolean) | (Ereditato da TreeList)
Metodo pubblico | EndDelete | (Ereditato da TreeList)
Metodo protetto | EndDragDrop | (Ereditato da TreeList)
Metodo protetto | EndEdit | (Ereditato da TreeList)
Metodo protetto | EndExpandCollapse | (Ereditato da TreeList)
Metodo pubblico | EndInit | (Ereditato da EditorContainer)
Metodo pubblico | EndSelection | (Ereditato da TreeList)
Metodo pubblico | EndSort | (Ereditato da TreeList)
Metodo pubblico | EndUnboundLoad | (Ereditato da TreeList)
Metodo pubblico | EndUpdate | (Ereditato da TreeList)
Metodo protetto | EnsureControlRowSource | (Ereditato da TreeList)
Metodo protetto | EnsureEditFormController | (Ereditato da TreeList)
Metodo protetto | EnsureFilteringClientDataBinding | (Ereditato da TreeList)
Metodo protetto | ExecutePrinterAction | (Ereditato da TreeList)
Metodo pubblico | ExpandAll | (Ereditato da TreeList)
Metodo protetto | ExpandAllCore | (Ereditato da TreeList)
Metodo protetto | ExpandToLast | (Ereditato da TreeList)
Metodo pubblico | ExpandToLevel | (Ereditato da TreeList)
Metodo protetto | ExpandToRoot | (Ereditato da TreeList)
Metodo protetto | Export(ExportTarget, Stream) | (Ereditato da TreeList)
Metodo protetto | Export(ExportTarget, String) | (Ereditato da TreeList)
Metodo protetto | Export(ExportTarget, Stream, ExportOptionsBase) | (Ereditato da TreeList)
Metodo protetto | Export(ExportTarget, String, ExportOptionsBase) | (Ereditato da TreeList)
Metodo pubblico | ExportToCsv(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToCsv(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToCsv(Stream, CsvExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToCsv(String, CsvExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToDocx(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToDocx(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToDocx(Stream, DocxExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToDocx(String, DocxExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToHtml(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToHtml(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToHtml(Stream, HtmlExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToHtml(String, HtmlExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToMht(Stream, MhtExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToMht(String, MhtExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToMht(String, String) | Obsoleto. (Ereditato da TreeList)
Metodo pubblico | ExportToMht(Stream, String, String, Boolean) | Obsoleto. (Ereditato da TreeList)
Metodo pubblico | ExportToMht(String, String, String, Boolean) | Obsoleto. (Ereditato da TreeList)
Metodo pubblico | ExportToPdf(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToPdf(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToPdf(Stream, PdfExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToPdf(String, PdfExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToRtf(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToRtf(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToText(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToText(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToText(Stream, TextExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToText(String, TextExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToXls(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToXls(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToXls(Stream, XlsExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToXls(String, XlsExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToXlsx(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToXlsx(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToXlsx(Stream, XlsxExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToXlsx(String, XlsxExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToXml(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToXml(String) | (Ereditato da TreeList)
Metodo protetto | ExportToXmlCore | (Ereditato da TreeList)
Metodo protetto | ExtractTemplateRootNode | (Ereditato da TreeList)
Metodo pubblico | FilterNodes | (Sovrascrive TreeList.FilterNodes)
Metodo pubblico | FilterNodes(TreeListNodes) | (Ereditato da TreeList)
Metodo protetto | FilterNodesCore | (Ereditato da TreeList)
Metodo pubblico | FindNode | (Ereditato da TreeList)
Metodo pubblico | FindNodeByFieldValue | (Ereditato da TreeList)
Metodo pubblico | FindNodeByID | (Ereditato da TreeList)
Metodo pubblico | FindNodeByKeyID | (Ereditato da TreeList)
Metodo protetto | FindNodeByParentID | (Ereditato da TreeList)
Metodo pubblico | FindNodes | (Ereditato da TreeList)
Metodo protetto | FindPanelNext | (Ereditato da TreeList)
Metodo protetto | FindPanelPrev | (Ereditato da TreeList)
Metodo pubblico | FireChanged | (Ereditato da TreeList)
Metodo protetto | FitColumns | (Ereditato da TreeList)
Metodo pubblico | FocusNewItemNode | (Ereditato da TreeList)
Metodo protetto | ForceCalcRowCount | (Ereditato da TreeList)
Metodo pubblico | ForceInitialize | (Ereditato da TreeList)
Metodo protetto | ForceSetTopVisibleNodeIndex | (Ereditato da TreeList)
Metodo pubblico | FullCollapse | Obsoleto. (Ereditato da TreeList)
Metodo pubblico | FullExpand | Obsoleto. (Ereditato da TreeList)
Metodo pubblico | FullExpandNode | Obsoleto. (Ereditato da TreeList)
Metodo protetto | GetAccessibilityObjectById | (Ereditato da TreeList)
Metodo protetto | GetAccessibleNodeCell | (Ereditato da TreeList)
Metodo protetto | GetActiveEditorHighAppearance | (Ereditato da TreeList)
Metodo protetto | GetActualAnimationType | (Ereditato da TreeList)
Metodo protetto | GetActualTreeListFilterMode | (Ereditato da TreeList)
Metodo pubblico | GetAllCheckedNodes | (Ereditato da TreeList)
Metodo protetto | GetAllowChangeBandParent | (Ereditato da TreeList)
Metodo protetto | GetAllowColumnFilterPopup | (Ereditato da TreeList)
Metodo protetto | GetAllowFilterEditor | (Ereditato da TreeList)
Metodo protetto | GetAllowFindColumn | (Ereditato da TreeList)
Metodo protetto | GetAllowFocus | (Ereditato da TreeList)
Metodo protetto | GetAllowHighlightFindResults | (Ereditato da TreeList)
Metodo protetto | GetAllowMRUFilterList | (Ereditato da TreeList)
Metodo protetto | GetAutoFilterRowColumnEdit | (Ereditato da TreeList)
Metodo pubblico | GetAutoFilterValue | (Ereditato da TreeList)
Metodo protetto | GetAutoNodeHeight | (Ereditato da TreeList)
Metodo protetto | GetBandRows | (Ereditato da TreeList)
Metodo protetto | GetBandRowsCore | (Ereditato da TreeList)
Metodo protetto | GetBandVisibleIndex | (Ereditato da TreeList)
Metodo protetto | GetCanShowEditor | (Ereditato da TreeList)
Metodo pubblico | GetColumnByColumnHandle | (Ereditato da TreeList)
Metodo pubblico | GetColumnByVisibleIndex | (Ereditato da TreeList)
Metodo protetto | GetColumnDefaultRepositoryItem | (Ereditato da TreeList)
Metodo protetto | GetColumnDefaultRepositoryItemForEditing | (Ereditato da TreeList)
Metodo protetto | GetColumnEdit | (Ereditato da TreeList)
Metodo protetto | GetColumnEditForEditing | (Ereditato da TreeList)
Metodo pubblico | GetColumnError(TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | GetColumnError(TreeListColumn, TreeListNode) | (Ereditato da TreeList)
Metodo pubblico | GetColumnErrorType(TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | GetColumnErrorType(TreeListColumn, TreeListNode) | (Ereditato da TreeList)
Metodo protetto | GetColumnFieldNameSort | (Ereditato da TreeList)
Metodo protetto | GetColumnFilterCriteria | (Ereditato da TreeList)
Metodo protetto | GetColumnFilterMode | (Ereditato da TreeList)
Metodo pubblico | GetColumnHeaderBestWidth | (Ereditato da TreeList)
Metodo protetto | GetColumnName | (Ereditato da TreeList)
Metodo protetto | GetCurrencyManager | (Ereditato da TreeList)
Metodo protetto | GetDataColumnInfo | (Ereditato da TreeList)
Metodo pubblico | GetDataRecordByNode | (Ereditato da TreeList)
Metodo pubblico | GetDataRow | (Ereditato da TreeList)
Metodo protetto | GetDirectXDeviceBackColor | (Ereditato da EditorContainer)
Metodo protetto | GetDirectXProvider | (Ereditato da EditorContainer)
Metodo protetto | GetEditableObject | (Ereditato da TreeList)
Metodo pubblico | GetEditorShowMode | (Ereditato da TreeList)
Metodo protetto | GetEditorViewInfo | (Ereditato da TreeList)
Metodo protetto | GetFilterColumn | (Ereditato da TreeList)
Metodo protetto | GetFilterColumnByTreeListColumn | (Ereditato da TreeList)
Metodo protetto | GetFilterCriteriaDisplayStyle | (Ereditato da TreeList)
Metodo protetto | GetFilterDisplayText | (Ereditato da TreeList)
Metodo protetto | GetFilterDisplayTextByColumn | (Ereditato da TreeList)
Metodo protetto | GetFilterPopupTexts | (Ereditato da TreeList)
Metodo protetto | GetFilterPopupValues(TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | GetFilterPopupValues(TreeListColumn, Boolean) | (Ereditato da TreeList)
Metodo protetto | GetFilterPopupValues(TreeListColumn, CriteriaOperator, Boolean) | (Ereditato da TreeList)
Metodo protetto | GetFilterPopupValues(TreeListColumn, Boolean, Boolean) | (Ereditato da TreeList)
Metodo protetto | GetFilterRowValue(Object) | (Ereditato da TreeList)
Metodo protetto | GetFilterRowValue(TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | GetFindMatchedRanges | (Ereditato da TreeList)
Metodo protetto | GetFindMatchedText | (Ereditato da TreeList)
Metodo protetto | GetFindToColumnsCollection | (Ereditato da TreeList)
Metodo pubblico | GetFocusedDataRow | (Ereditato da TreeList)
Metodo pubblico | GetFocusedDisplayText | (Ereditato da TreeList)
Metodo pubblico | GetFocusedRow | (Ereditato da TreeList)
Metodo pubblico | GetFocusedRowCellDisplayText(String) | (Ereditato da TreeList)
Metodo pubblico | GetFocusedRowCellDisplayText(TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetFocusedRowCellValue(String) | (Ereditato da TreeList)
Metodo pubblico | GetFocusedRowCellValue(TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetGroupSummaryValue | (Ereditato da TreeList)
Metodo protetto | GetHeaderFilterButtonShowMode | (Ereditato da TreeList)
Metodo pubblico | GetHitInfo | Obsoleto. (Ereditato da TreeList)
Metodo protetto | GetImageIndexFromDataSource | (Ereditato da TreeList)
Metodo protetto | GetMaxIndent | (Ereditato da TreeList)
Metodo protetto | GetNativePreviewText | (Ereditato da TreeList)
Metodo pubblico | GetNodeAt(Point) | (Ereditato da TreeList)
Metodo pubblico | GetNodeAt(Int32, Int32) | (Ereditato da TreeList)
Metodo pubblico | GetNodeByVisibleIndex | (Ereditato da TreeList)
Metodo protetto | GetNodeCellRepositoryItem | (Ereditato da TreeList)
Metodo protetto | GetNodeComparer(IComparerTreeListNode) | (Ereditato da TreeList)
Metodo protetto | GetNodeComparer(TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetNodeIndex | (Ereditato da TreeList)
Metodo pubblico | GetNodeList | (Ereditato da TreeList)
Metodo protetto | GetNodeValue(TreeListNode, TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | GetNodeValue(TreeListNode, Object) | (Ereditato da TreeList)
Metodo protetto | GetNodeValue(TreeListNode, String) | (Ereditato da TreeList)
Metodo protetto | GetNonFormattedCaption | (Ereditato da TreeList)
Metodo protetto | GetParentColumnFieldNameSort | (Ereditato da TreeList)
Metodo pubblico | GetRow | (Ereditato da TreeList)
Metodo pubblico | GetRowCellDisplayText(TreeListNode, TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetRowCellDisplayText(TreeListNode, String) | (Ereditato da TreeList)
Metodo pubblico | GetRowCellValue(TreeListNode, TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetRowCellValue(TreeListNode, String) | (Ereditato da TreeList)
Metodo protetto | GetRowsAsFootersCount | (Ereditato da TreeList)
Metodo pubblico | GetScrollAnnotations | (Ereditato da TreeList)
Metodo pubblico | GetSelectedCells | (Ereditato da TreeList)
Metodo pubblico | GetSelectedCells(TreeListNode) | (Ereditato da TreeList)
Metodo protetto | GetShowBandsMode | (Ereditato da TreeList)
Metodo protetto | GetShowFirstLines | (Ereditato da TreeList)
Metodo protetto | GetShowIndentAsRowStyle | (Ereditato da TreeList)
Metodo pubblico | GetSortColumn(Int32) | (Ereditato da TreeList)
Metodo protetto | GetSortColumn(TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetSummaryValue(TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetSummaryValue(TreeListColumn, Boolean) | (Ereditato da TreeList)
Metodo protetto | GetSummaryValueCore | (Ereditato da TreeList)
Metodo protetto | GetSummaryValueEx | (Ereditato da TreeList)
Metodo pubblico | GetToolTipController | (Ereditato da EditorContainer)
Metodo protetto | GetUseDirectXPaint | (Ereditato da TreeList)
Metodo pubblico | GetVisibleIndexByNode | (Ereditato da TreeList)
Metodo protetto | GetVisibleIndexByNodeCore | (Ereditato da TreeList)
Metodo protetto | GetVisibleParentNodesCount | (Ereditato da TreeList)
Metodo pubblico | HideCustomization | (Ereditato da TreeList)
Metodo pubblico | HideEditor | (Ereditato da TreeList)
Metodo protetto | HideEditorCore | (Ereditato da TreeList)
Metodo pubblico | HideFindPanel | (Ereditato da TreeList)
Metodo pubblico | HideLoadingPanel | (Ereditato da TreeList)
Metodo protetto | HookOnLoaded | (Ereditato da EditorContainer)
Metodo pubblico | ImportFromXml(Stream) | (Ereditato da TreeList)
Metodo pubblico | ImportFromXml(String) | (Ereditato da TreeList)
Metodo protetto | ImportFromXmlCore | (Ereditato da TreeList)
Metodo pubblico | IndentNodes | (Ereditato da TreeList)
Metodo protetto | InitFindPanel | (Ereditato da TreeList)
Metodo protetto | InitializeDirectXProvider | (Ereditato da EditorContainer)
Metodo protetto | InitScrollInfo | (Ereditato da TreeList)
Metodo protetto | InternalDeleteNode | (Ereditato da TreeList)
Metodo protetto | InternalDeleteNodeCore | (Ereditato da TreeList)
Metodo protetto | InternalDeleteNodes(DictionaryTreeListNodes, ListTreeListNode) | (Ereditato da TreeList)
Metodo protetto | InternalDeleteNodes(TreeListNodes) | (Ereditato da TreeList)
Metodo protetto | InternalFullCollapseNode | (Ereditato da TreeList)
Metodo protetto | InternalFullExpandNode | (Ereditato da TreeList)
Metodo protetto | InternalGetCustomNodeCellEdit | (Ereditato da TreeList)
Metodo protetto | InternalGetCustomNodeCellStyle | (Ereditato da TreeList)
Metodo pubblico | InternalGetService | (Ereditato da TreeList)
Metodo protetto | InternalNodeAdded | (Ereditato da TreeList)
Metodo protetto | InternalNodeChanged | (Ereditato da TreeList)
Metodo protetto | InternalSetTopVisibleNodePixel | (Ereditato da TreeList)
Metodo pubblico | InvalidateBand | (Ereditato da TreeList)
Metodo pubblico | InvalidateBandPanel | (Ereditato da TreeList)
Metodo pubblico | InvalidateCell | (Ereditato da TreeList)
Metodo pubblico | InvalidateColumnHeader | (Ereditato da TreeList)
Metodo pubblico | InvalidateColumnPanel | (Ereditato da TreeList)
Metodo pubblico | InvalidateFilterPanel | (Ereditato da TreeList)
Metodo pubblico | InvalidateNode | (Ereditato da TreeList)
Metodo pubblico | InvalidateNodes | (Ereditato da TreeList)
Metodo pubblico | InvalidateRow | (Ereditato da TreeList)
Metodo pubblico | InvalidateRowPreview | (Ereditato da TreeList)
Metodo protetto | InvalidateRows | (Ereditato da TreeList)
Metodo pubblico | InvalidateScrollAnnotations | (Ereditato da TreeList)
Metodo pubblico | InvalidateSummaryFooterPanel | (Ereditato da TreeList)
Metodo pubblico | InvokeMenuItemClick | (Ereditato da TreeList)
Metodo protetto | IsAllowDefaultFastBestFit | (Ereditato da TreeList)
Metodo protetto | IsAllowEditForm | (Ereditato da TreeList)
Metodo pubblico | IsAutoFilterNode | (Ereditato da TreeList)
Metodo pubblico | IsCellSelected | (Ereditato da TreeList)
Metodo protetto | IsColumnAllowAutoFilter | (Ereditato da TreeList)
Metodo protetto | IsColumnAllowFilter | (Ereditato da TreeList)
Metodo pubblico | IsColumnAllowFilterEditor | (Ereditato da TreeList)
Metodo protetto | IsColumnFieldNameSortExist | (Ereditato da TreeList)
Metodo protetto | IsColumnFiltered | (Ereditato da TreeList)
Metodo protetto | IsFilterByDisplayText | (Ereditato da TreeList)
Metodo protetto | IsFilterRow | (Ereditato da TreeList)
Metodo protetto | IsImplyNullLikeEmptyStringWhenFiltering | (Ereditato da TreeList)
Metodo protetto | IsInputChar | (Ereditato da TreeList)
Metodo protetto | IsInputKey | (Ereditato da TreeList)
Metodo pubblico | IsNewItemRow | (Ereditato da TreeList)
Metodo protetto | IsParentColumnFieldNameSortExist | (Ereditato da TreeList)
Metodo pubblico | IsRootNode | (Ereditato da TreeList)
Metodo protetto | IsRoundDateTime | (Ereditato da TreeList)
Metodo protetto | IsShowAllValuesInFilterPopup | (Ereditato da TreeList)
Metodo protetto | IsTopNewItemRow | (Ereditato da TreeList)
Metodo protetto | IsUserAutoFilterCondition | (Ereditato da TreeList)
Metodo pubblico | LayoutChanged | (Ereditato da TreeList)
Metodo protetto | LoadDataColumns | (Ereditato da TreeList)
Metodo protetto | LoadDataSource | (Ereditato da TreeList)
Metodo protetto | LockDirectXRendering | (Ereditato da TreeList)
Metodo protetto | LockFilteringUIClientFilterCriteriaBinding | (Ereditato da TreeList)
Metodo pubblico | LockReloadNodes | (Ereditato da TreeList)
Metodo pubblico | MakeColumnVisible | (Ereditato da TreeList)
Metodo protetto | MakeFocusedRowVisible | (Ereditato da TreeList)
Metodo pubblico | MakeNodeVisible | (Ereditato da TreeList)
Metodo protetto | MergeColumnFiltersCore | (Ereditato da TreeList)
Metodo pubblico | MoveFirst | (Ereditato da TreeList)
Metodo protetto | MoveFocusedCell | (Ereditato da TreeList)
Metodo pubblico | MoveLast | (Ereditato da TreeList)
Metodo pubblico | MoveLastVisible | (Ereditato da TreeList)
Metodo pubblico | MoveNext | (Ereditato da TreeList)
Metodo pubblico | MoveNextVisible | (Ereditato da TreeList)
Metodo pubblico | MoveNode(TreeListNode, TreeListNode) | (Ereditato da TreeList)
Metodo pubblico | MoveNode(TreeListNode, TreeListNode, Boolean) | (Ereditato da TreeList)
Metodo pubblico | MoveNode(TreeListNode, TreeListNode, Boolean, Int32) | (Ereditato da TreeList)
Metodo pubblico | MoveNodes | (Ereditato da TreeList)
Metodo protetto | MoveNodesCore | (Ereditato da TreeList)
Metodo pubblico | MovePrev | (Ereditato da TreeList)
Metodo pubblico | MovePrevVisible | (Ereditato da TreeList)
Metodo pubblico | MoveToNextScrollAnnotation | (Ereditato da TreeList)
Metodo pubblico | MoveToParent | (Ereditato da TreeList)
Metodo pubblico | MoveToPrevScrollAnnotation | (Ereditato da TreeList)
Metodo protetto | NormalizeVisibleBandIndices | (Ereditato da TreeList)
Metodo protetto | NormalizeVisibleColumnIndices | (Ereditato da TreeList)
Metodo protetto | OnActiveEditor_GotFocus | (Ereditato da TreeList)
Metodo protetto | OnActiveEditor_LostFocus | (Ereditato da TreeList)
Metodo protetto | OnActiveEditor_Modified | (Ereditato da TreeList)
Metodo protetto | OnActiveEditor_ValueChanged | (Ereditato da TreeList)
Metodo protetto | OnActiveEditor_ValueChanging | (Ereditato da TreeList)
Metodo protetto | OnActiveFilterChanged | (Ereditato da TreeList)
Metodo protetto | OnActiveFilterCriteriaChanged | (Ereditato da TreeList)
Metodo protetto | OnActiveFilterEnabledChanged | (Ereditato da TreeList)
Metodo protetto | OnAfterAddingNode | (Ereditato da TreeList)
Metodo protetto | OnAfterChangeCollapsed | (Ereditato da TreeList)
Metodo protetto | OnAfterChangeExpanded | (Ereditato da TreeList)
Metodo protetto | OnAfterDeletingNodes | (Ereditato da TreeList)
Metodo protetto | OnAllowBandColumnMultiRowChanged | (Ereditato da TreeList)
Metodo protetto | OnAllowSerializationProperty | (Ereditato da TreeList)
Metodo protetto | OnAppearancePrintChanged | (Ereditato da TreeList)
Metodo protetto | OnBandChanged | (Ereditato da TreeList)
Metodo protetto | OnBandCollectionChanged | (Ereditato da TreeList)
Metodo protetto | OnBandColumnCollectionChanged | (Ereditato da TreeList)
Metodo protetto | OnBandFixedChanged | (Ereditato da TreeList)
Metodo protetto | OnBandWidthChanged | (Ereditato da TreeList)
Metodo protetto | OnBeginTouchScroll | (Ereditato da TreeList)
Metodo protetto | OnBindingContextChanged | (Ereditato da TreeList)
Metodo protetto | OnCheckBoxFieldNameChanged | (Ereditato da TreeList)
Metodo protetto | OnClearNodes | (Ereditato da TreeList)
Metodo protetto | OnClearNodesComplete | (Ereditato da TreeList)
Metodo protetto | OnClick | (Ereditato da TreeList)
Metodo protetto | OnColumnAdded | (Ereditato da TreeList)
Metodo protetto | OnColumnChanged | (Ereditato da TreeList)
Metodo protetto | OnColumnFilterModeChanged | (Ereditato da TreeList)
Metodo protetto | OnColumnFilterRestored | (Ereditato da TreeList)
Metodo protetto | OnColumnInfosPopulated | (Ereditato da TreeList)
Metodo protetto | OnColumnRemoved | (Ereditato da TreeList)
Metodo protetto | OnColumnRowIndexChanged | (Ereditato da TreeList)
Metodo protetto | OnColumnsChanged | (Ereditato da TreeList)
Metodo protetto | OnColumnUnboundChanged | (Ereditato da TreeList)
Metodo protetto | OnColumnUnboundExpressionChanged | (Ereditato da TreeList)
Metodo protetto | OnContainerEnter | (Ereditato da EditorContainer)
Metodo protetto | OnContainerLeave | (Ereditato da EditorContainer)
Metodo protetto | OnContextMenuKey | (Ereditato da TreeList)
Metodo protetto | OnCreateControl | (Ereditato da EditorContainer)
Metodo protetto | OnDataListChanged | (Ereditato da TreeList)
Metodo protetto | OnDesignerHost_LoadComplete | (Ereditato da EditorContainer)
Metodo protetto | OnDesignerHost_TransactionClosed | (Ereditato da EditorContainer)
Metodo protetto | OnDirectXPaintDisabled | (Ereditato da TreeList)
Metodo protetto | OnDoubleClick | (Ereditato da TreeList)
Metodo protetto | OnDragDrop | (Ereditato da TreeList)
Metodo protetto | OnDragEnter | (Ereditato da TreeList)
Metodo protetto | OnDragLeave | (Ereditato da TreeList)
Metodo protetto | OnDragOver | (Ereditato da TreeList)
Metodo protetto | OnEnabledChanged | (Ereditato da TreeList)
Metodo protetto | OnEndInit | (Ereditato da EditorContainer)
Metodo protetto | OnEndSerializing | (Ereditato da TreeList)
Metodo protetto | OnEndSorting | (Ereditato da TreeList)
Metodo protetto | OnEnter | (Ereditato da EditorContainer)
Metodo protetto | OnErrorInfo_Changed | (Ereditato da TreeList)
Metodo protetto | OnFilterRowValueChanging | (Ereditato da TreeList)
Metodo protetto | OnFirstInit | (Ereditato da EditorContainer)
Metodo protetto | OnFormatConditionChanged | (Ereditato da TreeList)
Metodo protetto | OnFormatRuleExpressionEditorCreated | (Ereditato da TreeList)
Metodo protetto | OnFormatRulesCollectionChanged | (Ereditato da TreeList)
Metodo protetto | OnGotCapture | (Ereditato da EditorContainer)
Metodo protetto | OnGotFocus | (Ereditato da TreeList)
Metodo protetto | OnHandleCreated | (Ereditato da TreeList)
Metodo protetto | OnHandleDestroyed | (Ereditato da TreeList)
Metodo protetto | OnHorizontalTouchScroll | (Ereditato da TreeList)
Metodo protetto | OnHScroll | (Ereditato da TreeList)
Metodo protetto | OnItemAdded | (Ereditato da TreeList)
Metodo protetto | OnItemAdding | (Ereditato da TreeList)
Metodo protetto | OnItemChanged(Int32, PropertyDescriptor) | (Ereditato da TreeList)
Metodo protetto | OnItemChanged(Int32, PropertyDescriptor, TreeListNode) | (Ereditato da TreeList)
Metodo protetto | OnItemDeleted | (Ereditato da TreeList)
Metodo protetto | OnItemMoved | (Ereditato da TreeList)
Metodo protetto | OnKeyDown | (Ereditato da TreeList)
Metodo protetto | OnKeyPress | (Ereditato da TreeList)
Metodo protetto | OnKeyUp | (Ereditato da TreeList)
Metodo protetto | OnLeave | (Ereditato da EditorContainer)
Metodo protetto | OnLoaded | (Ereditato da TreeList)
Metodo protetto | OnLoadedCore | (Ereditato da TreeList)
Metodo protetto | OnLookAndFeelChanged(LookAndFeelChangedEventArgs) | (Ereditato da TreeList)
Metodo protetto | OnLookAndFeelChanged(Object, EventArgs) | (Ereditato da EditorContainer)
Metodo protetto | OnLostCapture | (Ereditato da TreeList)
Metodo protetto | OnLostFocus | (Ereditato da TreeList)
Metodo protetto | OnMenuShowing | (Ereditato da TreeList)
Metodo protetto | OnMouseClick | (Ereditato da EditorContainer)
Metodo protetto | OnMouseDoubleClick | (Ereditato da EditorContainer)
Metodo protetto | OnMouseDown | (Ereditato da TreeList)
Metodo protetto | OnMouseEnter | (Ereditato da TreeList)
Metodo protetto | OnMouseHWheel | (Ereditato da EditorContainer)
Metodo protetto | OnMouseLeave | (Ereditato da TreeList)
Metodo protetto | OnMouseMove | (Ereditato da TreeList)
Metodo protetto | OnMouseUp | (Ereditato da TreeList)
Metodo protetto | OnMouseWheel | (Ereditato da EditorContainer)
Metodo protetto | OnMouseWheelCore | (Ereditato da TreeList)
Metodo protetto | OnNodeCheckedChanged | (Ereditato da TreeList)
Metodo protetto | OnNodeRemoved | (Ereditato da TreeList)
Metodo protetto | OnNodesLoaded | (Ereditato da TreeList)
Metodo protetto | OnNodesLoading | (Ereditato da TreeList)
Metodo protetto | OnNodesRemoved | (Ereditato da TreeList)
Metodo protetto | OnOptionsBehaviorChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsCustomizationChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsDragAndDropChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsEditFormChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsFilterChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsFindChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsHtmlChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsNavigationChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsPrintChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsScrollAnnotationsChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsSelectionChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsViewChanged | (Ereditato da TreeList)
Metodo protetto | OnPaint | Implementazione dell'override di onPaint. Grazie al catch delle eccezioni evita l'uscita della X rossa sul form (Sovrascrive TreeList.OnPaint(PaintEventArgs))
Metodo protetto | OnPaintBackground | (Ereditato da TreeList)
Metodo protetto | OnParentChanged | (Ereditato da TreeList)
Metodo protetto | OnPressedBandChanged | (Ereditato da TreeList)
Metodo protetto | OnPrintProgress | (Ereditato da TreeList)
Metodo protetto | OnPropertyChanged | (Ereditato da TreeList)
Metodo protetto | OnPropertyDescriptorChanged | (Ereditato da TreeList)
Metodo protetto | OnQueryContinueDrag | (Ereditato da TreeList)
Metodo protetto | OnRepositoryItemRefreshRequired | (Ereditato da TreeList)
Metodo protetto | OnReset | (Ereditato da TreeList)
Metodo protetto | OnResetSerializationProperties | (Ereditato da TreeList)
Metodo protetto | OnResize | (Ereditato da TreeList)
Metodo protetto | OnRightToLeftChanged | (Ereditato da TreeList)
Metodo protetto | OnRightToLeftChanged(EventArgs) | (Ereditato da EditorContainer)
Metodo protetto | OnScaleControl | (Ereditato da TreeList)
Metodo protetto | OnScaleTreeListCore | (Ereditato da TreeList)
Metodo protetto | OnSelectionChanged | (Ereditato da TreeList)
Metodo protetto | OnSetValue | (Ereditato da TreeList)
Metodo protetto | OnSortModeChanged | (Ereditato da TreeList)
Metodo protetto | OnSourceItemChanged | (Ereditato da TreeList)
Metodo protetto | OnStartSerializing | (Ereditato da TreeList)
Metodo protetto | OnStartSorting | (Ereditato da TreeList)
Metodo protetto | OnSystemColorsChanged | (Ereditato da TreeList)
Metodo protetto | OnToolTipControllerDisposed | (Ereditato da EditorContainer)
Metodo protetto | OnTouchScroll | (Ereditato da TreeList)
Metodo protetto | OnTouchZoom | (Ereditato da TreeList)
Metodo protetto | OnValidated | (Ereditato da EditorContainer)
Metodo protetto | OnValidating | (Ereditato da TreeList)
Metodo protetto | OnVerticalTouchScroll | (Ereditato da TreeList)
Metodo protetto | OnVisibleChanged | (Ereditato da TreeList)
Metodo protetto | OnVScroll | (Ereditato da TreeList)
Metodo protetto | OnVScrollCore | (Ereditato da TreeList)
Metodo pubblico | OutdentNodes | (Ereditato da TreeList)
Metodo protetto | ParseAutoFilter | (Ereditato da TreeList)
Metodo protetto | ParseAutoFilterValues | (Ereditato da TreeList)
Metodo pubblico | PasteFromClipboard | (Ereditato da TreeList)
Metodo pubblico | PopulateColumns | (Ereditato da TreeList)
Metodo pubblico | PostEditor | (Ereditato da TreeList)
Metodo protetto | PostEditor(Boolean) | (Ereditato da TreeList)
Metodo pubblico | Print | (Ereditato da TreeList)
Metodo protetto | PrintCore | (Ereditato da TreeList)
Metodo pubblico | PrintDialog | (Ereditato da TreeList)
Metodo protetto | PrintDialogCore | (Ereditato da TreeList)
Metodo protetto | ProcessControlTab | (Ereditato da TreeList)
Metodo protetto | ProcessControlTab(Boolean) | (Ereditato da TreeList)
Metodo protetto | ProcessDialogKey | (Ereditato da TreeList)
Metodo protetto | ProcessDirectXPaint | (Ereditato da TreeList)
Metodo protetto | RaiseAfterCheckNode | (Ereditato da TreeList)
Metodo protetto | RaiseAfterCollapse | (Ereditato da TreeList)
Metodo protetto | RaiseAfterDragNode | (Ereditato da TreeList)
Metodo protetto | RaiseAfterDropNode | (Ereditato da TreeList)
Metodo protetto | RaiseAfterExpand | (Ereditato da TreeList)
Metodo protetto | RaiseAfterFocusNode | (Ereditato da TreeList)
Metodo protetto | RaiseBandPositionChanged | (Ereditato da TreeList)
Metodo protetto | RaiseBandWidthChanged | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeCheckNode | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeCollapse | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeDragNode | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeDropNode | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeExpand | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeFocusNode | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeLoadLayout | (Ereditato da TreeList)
Metodo protetto | RaiseCalcNodeDragImageIndex | (Ereditato da TreeList)
Metodo protetto | RaiseCalcNodeHeight(TreeListNode, Int32) | (Ereditato da TreeList)
Metodo protetto | RaiseCalcNodeHeight(TreeListNode, RowInfo, Int32) | (Ereditato da TreeList)
Metodo protetto | RaiseCellValueChanged | (Ereditato da TreeList)
Metodo protetto | RaiseCellValueChanging | (Ereditato da TreeList)
Metodo protetto | RaiseCheckedColumnFilterPopupEvent | (Ereditato da TreeList)
Metodo protetto | RaiseClipboardNodeCopying | (Ereditato da TreeList)
Metodo protetto | RaiseClipboardNodePasting | (Ereditato da TreeList)
Metodo protetto | RaiseColumnButtonClick | (Ereditato da TreeList)
Metodo protetto | RaiseColumnChanged | (Ereditato da TreeList)
Metodo protetto | RaiseColumnFilterChanged | (Ereditato da TreeList)
Metodo protetto | RaiseColumnFilterPopupEvent | (Ereditato da TreeList)
Metodo protetto | RaiseColumnPositionChanged | (Ereditato da TreeList)
Metodo protetto | RaiseColumnUnboundExpressionChanged | (Ereditato da TreeList)
Metodo protetto | RaiseColumnWidthChanged | (Ereditato da TreeList)
Metodo protetto | RaiseCompareNodeValues | (Ereditato da TreeList)
Metodo protetto | RaiseCreateCustomNode | (Ereditato da TreeList)
Metodo protetto | RaiseCustomColumnDisplayText(CustomColumnDisplayTextEventArgs) | (Ereditato da TreeList)
Metodo protetto | RaiseCustomColumnDisplayText(TreeListNode, CellInfo) | (Ereditato da TreeList)
Metodo protetto | RaiseCustomColumnDisplayText(TreeListNode, TreeListColumn, BaseEditViewInfo) | (Ereditato da TreeList)
Metodo protetto | RaiseCustomColumnDisplayText(TreeListNode, TreeListColumn, Object, String) | (Ereditato da TreeList)
Metodo protetto | RaiseCustomColumnSort | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawBandHeader | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawColumnHeader | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawEmptyArea | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawFilterPanel | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawFooter | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawFooterCell | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodeButton | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodeCell | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodeCheckBox | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodeImages | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodeIndent | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodeIndicator | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodePreview | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawRow | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawRowFooter | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawRowFooterCell | (Ereditato da TreeList)
Metodo protetto | RaiseCustomFilterDisplayText | (Ereditato da TreeList)
Metodo protetto | RaiseCustomizationFormSearch | (Ereditato da TreeList)
Metodo protetto | RaiseCustomizeNewNodeFromOuterData | (Ereditato da TreeList)
Metodo protetto | RaiseCustomRowFilter | (Ereditato da TreeList)
Metodo protetto | RaiseCustomRowFilterEvent | (Ereditato da TreeList)
Metodo protetto | RaiseCustomUnboundColumnData | (Ereditato da TreeList)
Metodo protetto | RaiseDataSourceChanged | (Ereditato da TreeList)
Metodo protetto | RaiseDefaultPaintHelperChanged | (Ereditato da TreeList)
Metodo protetto | RaiseDragCancelNode | (Ereditato da TreeList)
Metodo protetto | RaiseDragObjectDrop | (Ereditato da TreeList)
Metodo protetto | RaiseDragObjectOver | (Ereditato da TreeList)
Metodo protetto | RaiseDragObjectStart | (Ereditato da TreeList)
Metodo protetto | RaiseEditFormHidden | (Ereditato da TreeList)
Metodo protetto | RaiseEditFormPrepared | (Ereditato da TreeList)
Metodo protetto | RaiseEditFormShowing | (Ereditato da TreeList)
Metodo protetto | RaiseEditorKeyDown | (Ereditato da TreeList)
Metodo protetto | RaiseEditorKeyPress | (Ereditato da EditorContainer)
Metodo protetto | RaiseEditorKeyUp | (Ereditato da EditorContainer)
Metodo protetto | RaiseEndSorting | (Ereditato da TreeList)
Metodo protetto | RaiseExcelColumnFilterPopupEvent | (Ereditato da TreeList)
Metodo protetto | RaiseFilterEditorCreated | (Ereditato da TreeList)
Metodo protetto | RaiseFilterExpressionEditorCreated | (Ereditato da TreeList)
Metodo protetto | RaiseFilterNodeEvent | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupDate | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelCustomizeTemplate | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelData(FilterPopupExcelDataEventArgs) | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelData(TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelData(TreeListColumn, CriteriaOperator) | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelData(TreeListColumn, TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelParseFilterCriteria | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelPrepareTemplate | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelQueryFilterCriteria | (Ereditato da TreeList)
Metodo protetto | RaiseFocusedColumnChanged | (Ereditato da TreeList)
Metodo protetto | RaiseFocusedNodeChanged | (Ereditato da TreeList)
Metodo protetto | RaiseGetCustomAnnotations | (Ereditato da TreeList)
Metodo protetto | RaiseGetCustomNodeCellEdit | (Ereditato da TreeList)
Metodo protetto | RaiseGetCustomNodeCellStyle | (Ereditato da TreeList)
Metodo protetto | RaiseGetCustomSummaryValue | (Ereditato da TreeList)
Metodo protetto | RaiseGetNodeDisplayValue | (Ereditato da TreeList)
Metodo protetto | RaiseGetPreviewText | (Ereditato da TreeList)
Metodo protetto | RaiseGetPrintCustomSummaryValue | (Ereditato da TreeList)
Metodo protetto | RaiseGetPrintPreviewText | (Ereditato da TreeList)
Metodo protetto | RaiseGetSelectImage | (Ereditato da TreeList)
Metodo protetto | RaiseGetStateImage | (Ereditato da TreeList)
Metodo protetto | RaiseHiddenEditor | (Ereditato da TreeList)
Metodo protetto | RaiseHideCustomizationForm | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementBlur | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementFocus | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseClick | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseDoubleClick | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseDown | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseMove | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseOut | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseOver | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseUp | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlSelectedTextChanged | (Ereditato da TreeList)
Metodo protetto | RaiseInitNewRow | (Ereditato da TreeList)
Metodo protetto | RaiseInvalidNodeException | (Ereditato da TreeList)
Metodo protetto | RaiseInvalidValueException | (Ereditato da TreeList)
Metodo protetto | RaiseLayoutUpdated | (Ereditato da TreeList)
Metodo protetto | RaiseLayoutUpgrade | (Ereditato da TreeList)
Metodo protetto | RaiseLeftCoordChanged | (Ereditato da TreeList)
Metodo protetto | RaiseLoad | (Ereditato da TreeList)
Metodo protetto | RaiseMeasurePreviewHeight | (Ereditato da TreeList)
Metodo protetto | RaiseNodeChanged | (Ereditato da TreeList)
Metodo protetto | RaiseNodesReloaded | (Ereditato da TreeList)
Metodo protetto | RaisePaintEx | (Ereditato da TreeList)
Metodo protetto | RaiseParseFindPanelText | (Ereditato da TreeList)
Metodo protetto | RaisePopupMenuShowing | (Ereditato da TreeList)
Metodo protetto | RaisePrintExportProgress | (Ereditato da TreeList)
Metodo protetto | RaiseQueryCustomFunctions | (Ereditato da TreeList)
Metodo protetto | RaiseRequireHideEditor | (Ereditato da EditorContainer)
Metodo protetto | RaiseRowCellClick | (Ereditato da TreeList)
Metodo protetto | RaiseRowClick | (Ereditato da TreeList)
Metodo protetto | RaiseRowSelectImageClick | (Ereditato da TreeList)
Metodo protetto | RaiseRowStateImageClick | (Ereditato da TreeList)
Metodo protetto | RaiseSelectImageClick | (Ereditato da TreeList)
Metodo protetto | RaiseSelectionChanged | (Ereditato da TreeList)
Metodo protetto | RaiseSelectionChanging | (Ereditato da TreeList)
Metodo protetto | RaiseShowCustomizationForm | (Ereditato da TreeList)
Metodo protetto | RaiseShowingEditor | (Ereditato da TreeList)
Metodo protetto | RaiseShownEditor | (Ereditato da TreeList)
Metodo protetto | RaiseShowTreeListMenu | Obsoleto. (Ereditato da TreeList)
Metodo protetto | RaiseStartSorting | (Ereditato da TreeList)
Metodo protetto | RaiseStateChanged | (Ereditato da TreeList)
Metodo protetto | RaiseStateImageClick | (Ereditato da TreeList)
Metodo protetto | RaiseSubstituteFilter | (Ereditato da TreeList)
Metodo protetto | RaiseTopVisibleNodeIndexChanged | (Ereditato da TreeList)
Metodo protetto | RaiseTreeListMenuItemClick | (Ereditato da TreeList)
Metodo protetto | RaiseUnboundExpressionEditorCreated | (Ereditato da TreeList)
Metodo protetto | RaiseValidateNode | (Ereditato da TreeList)
Metodo protetto | RaiseValidatingEditor | (Ereditato da TreeList)
Metodo protetto | RecalcSortColumns | (Ereditato da TreeList)
Metodo protetto | RecreateRowsInfoCore | (Ereditato da TreeList)
Metodo pubblico | Refresh | (Ereditato da TreeList)
Metodo pubblico | Refresh(Boolean) | (Ereditato da TreeList)
Metodo pubblico | RefreshCell | (Ereditato da TreeList)
Metodo protetto | RefreshCellCore | (Ereditato da TreeList)
Metodo protetto | RefreshColumnsInfo | (Ereditato da TreeList)
Metodo pubblico | RefreshDataSource | (Ereditato da TreeList)
Metodo pubblico | RefreshEditor | (Ereditato da TreeList)
Metodo protetto | RefreshEditorError | (Ereditato da TreeList)
Metodo protetto | RefreshHeadersInfo | (Ereditato da TreeList)
Metodo protetto | RefreshHtmlNodeCore | (Ereditato da TreeList)
Metodo pubblico | RefreshNode | (Ereditato da TreeList)
Metodo protetto | RefreshNodeCore | (Ereditato da TreeList)
Metodo protetto | RefreshRowsInfo | (Ereditato da TreeList)
Metodo protetto | RefreshRowsInfo(Boolean, Boolean) | (Ereditato da TreeList)
Metodo pubblico | RefreshScrollAnnotations(ScrollAnnotationKind) | (Ereditato da TreeList)
Metodo pubblico | RefreshScrollAnnotations(ScrollAnnotationKind, Int32) | (Ereditato da TreeList)
Metodo protetto | RefreshVirtualCellCore | (Ereditato da TreeList)
Metodo protetto | RefreshVirtualNodeCore | (Ereditato da TreeList)
Metodo protetto | RejectCurrentChanges | (Ereditato da TreeList)
Metodo protetto | RemoveFromDefaultTooltipController | (Ereditato da EditorContainer)
Metodo protetto | RemoveHookOnLoaded | (Ereditato da EditorContainer)
Metodo protetto | RemoveNodeHeight | (Ereditato da TreeList)
Metodo protetto | RequestCellEditor | (Ereditato da TreeList)
Metodo protetto | ResetAccessibility | (Ereditato da TreeList)
Metodo pubblico | ResetAutoFilterCondition | (Ereditato da TreeList)
Metodo pubblico | ResetAutoFilterConditions | (Ereditato da TreeList)
Metodo pubblico | ResetAutoFilterConditions(IEnumerableTreeListColumn) | (Ereditato da TreeList)
Metodo protetto | ResetAutoFilterConditionsCore | (Ereditato da TreeList)
Metodo protetto | ResetColumnAutoFilterConditions | (Ereditato da TreeList)
Metodo pubblico | ResetEditorsCache(RepositoryItem) | (Ereditato da EditorContainer)
Metodo pubblico | ResetEditorsCache(Type) | (Ereditato da EditorContainer)
Metodo protetto | ResetExcelFilteringProvider | (Ereditato da TreeList)
Metodo protetto | ResetLookAndFeel | (Ereditato da EditorContainer)
Metodo protetto | ResetRowCount | (Ereditato da TreeList)
Metodo protetto | ResetSortedColumns | (Ereditato da TreeList)
Metodo protetto | ResizeBand | (Ereditato da TreeList)
Metodo protetto | ResizeColumn | (Ereditato da TreeList)
Metodo protetto | ResolveAutoFilterCondition | (Ereditato da TreeList)
Metodo protetto | RestoreLayoutCore | (Ereditato da TreeList)
Metodo pubblico | RestoreLayoutFromRegistry(String) | (Ereditato da TreeList)
Metodo pubblico | RestoreLayoutFromRegistry(String, OptionsLayoutBase) | (Ereditato da TreeList)
Metodo pubblico | RestoreLayoutFromStream(Stream) | (Ereditato da TreeList)
Metodo pubblico | RestoreLayoutFromStream(Stream, OptionsLayoutBase) | (Ereditato da TreeList)
Metodo pubblico | RestoreLayoutFromXml(String) | (Ereditato da TreeList)
Metodo pubblico | RestoreLayoutFromXml(String, OptionsLayoutBase) | (Ereditato da TreeList)
Metodo protetto | RestoreNodesData | (Ereditato da TreeList)
Metodo protetto | SaveLayoutCore | (Ereditato da TreeList)
Metodo pubblico | SaveLayoutToRegistry(String) | (Ereditato da TreeList)
Metodo pubblico | SaveLayoutToRegistry(String, OptionsLayoutBase) | (Ereditato da TreeList)
Metodo pubblico | SaveLayoutToStream(Stream) | (Ereditato da TreeList)
Metodo pubblico | SaveLayoutToStream(Stream, OptionsLayoutBase) | (Ereditato da TreeList)
Metodo pubblico | SaveLayoutToXml(String) | (Ereditato da TreeList)
Metodo pubblico | SaveLayoutToXml(String, OptionsLayoutBase) | (Ereditato da TreeList)
Metodo protetto | SaveNodesData | (Ereditato da TreeList)
Metodo protetto | ScaleControl | (Ereditato da EditorContainer)
Metodo protetto | Scrollbar_MouseEnter | (Ereditato da TreeList)
Metodo protetto | Scrollbar_MouseLeave | (Ereditato da TreeList)
Metodo protetto | ScrollHorizontalEx | (Ereditato da TreeList)
Metodo protetto | ScrollVerticalEx | (Ereditato da TreeList)
Metodo pubblico | SelectAll | (Ereditato da TreeList)
Metodo pubblico | SelectCell | (Ereditato da TreeList)
Metodo protetto | SelectCellCore | (Ereditato da TreeList)
Metodo pubblico | SelectCells(Int32, String, Int32, String) | (Ereditato da TreeList)
Metodo pubblico | SelectCells(TreeListNode, TreeListColumn, TreeListNode, TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | SelectNode | (Ereditato da TreeList)
Metodo protetto | SelectNodeCore | (Ereditato da TreeList)
Metodo pubblico | SelectNodes(Int32, Int32) | (Ereditato da TreeList)
Metodo pubblico | SelectNodes(TreeListNode, TreeListNode) | (Ereditato da TreeList)
Metodo protetto | SelectNodesCore | (Ereditato da TreeList)
Metodo protetto | ServiceColumnChanged | (Ereditato da TreeList)
Metodo pubblico | SetAutoFilterValue | (Ereditato da TreeList)
Metodo protetto | SetCellSelection | (Ereditato da TreeList)
Metodo protetto | SetCellSelectionCore | (Ereditato da TreeList)
Metodo pubblico | SetColumnError(TreeListColumn, String) | (Ereditato da TreeList)
Metodo pubblico | SetColumnError(TreeListColumn, String, ErrorType) | (Ereditato da TreeList)
Metodo protetto | SetColumnFixedStyle | (Ereditato da TreeList)
Metodo pubblico | SetColumnPosition | (Ereditato da TreeList)
Metodo protetto | SetColumnVisibleIndex | (Ereditato da TreeList)
Metodo pubblico | SetDefaultBehaviorOptions | (Ereditato da TreeList)
Metodo pubblico | SetDefaultCustomizationOptions | (Ereditato da TreeList)
Metodo pubblico | SetDefaultNavigationOptions | (Ereditato da TreeList)
Metodo pubblico | SetDefaultOptionsView | (Ereditato da TreeList)
Metodo pubblico | SetDefaultPrintOptions | (Ereditato da TreeList)
Metodo pubblico | SetDefaultRowHeight | (Ereditato da TreeList)
Metodo pubblico | SetDefaultSelectionOptions | (Ereditato da TreeList)
Metodo protetto | SetExtraFilter | (Ereditato da TreeList)
Metodo protetto | SetFilterRowValue(Object, Object) | (Ereditato da TreeList)
Metodo protetto | SetFilterRowValue(TreeListColumn, Object) | (Ereditato da TreeList)
Metodo pubblico | SetFocusedNode | (Ereditato da TreeList)
Metodo protetto | SetFocusedNodeCore | (Ereditato da TreeList)
Metodo pubblico | SetFocusedRowCellValue(String, Object) | (Ereditato da TreeList)
Metodo pubblico | SetFocusedRowCellValue(TreeListColumn, Object) | (Ereditato da TreeList)
Metodo protetto | SetFocusedRowIndexCore | (Ereditato da TreeList)
Metodo pubblico | SetFocusedValue | (Ereditato da TreeList)
Metodo pubblico | SetNodeCheckState(TreeListNode, CheckState) | (Ereditato da TreeList)
Metodo pubblico | SetNodeCheckState(TreeListNode, CheckState, Boolean) | (Ereditato da TreeList)
Metodo pubblico | SetNodeIndex | (Ereditato da TreeList)
Metodo protetto | SetNodeIndexCore | (Ereditato da TreeList)
Metodo protetto | SetNodeValue | (Ereditato da TreeList)
Metodo pubblico | SetRowCellValue(TreeListNode, TreeListColumn, Object) | (Ereditato da TreeList)
Metodo pubblico | SetRowCellValue(TreeListNode, String, Object) | (Ereditato da TreeList)
Metodo pubblico | SetSearchControl | (Ereditato da TreeList)
Metodo pubblico | SetSelectionAnchor | (Ereditato da TreeList)
Metodo protetto | SetUseDirectXPaint | (Ereditato da TreeList)
Metodo protetto | ShouldResortNodesOnItemChanged | (Ereditato da TreeList)
Metodo protetto | ShouldSerializeLookAndFeel | (Ereditato da EditorContainer)
Metodo pubblico | ShowAutoFilterConditionsMenu | (Ereditato da TreeList)
Metodo pubblico | ShowContextMenu | (Ereditato da TreeList)
Metodo pubblico | ShowCustomization | (Ereditato da TreeList)
Metodo pubblico | ShowCustomization(Point) | (Ereditato da TreeList)
Metodo pubblico | ShowEditForm | (Ereditato da TreeList)
Metodo protetto | ShowEditFormCore | (Ereditato da TreeList)
Metodo protetto | ShowEditFormDialogCore | (Ereditato da TreeList)
Metodo pubblico | ShowEditor | (Ereditato da TreeList)
Metodo pubblico | ShowEditor(String) | (Ereditato da TreeList)
Metodo pubblico | ShowFilterEditor | (Ereditato da TreeList)
Metodo protetto | ShowFilterExpressionEditor | (Ereditato da TreeList)
Metodo pubblico | ShowFilterPopup | (Ereditato da TreeList)
Metodo pubblico | ShowFindPanel | (Ereditato da TreeList)
Metodo pubblico | ShowLoadingPanel | (Ereditato da TreeList)
Metodo protetto | ShowMenu | (Ereditato da TreeList)
Metodo protetto | ShowMRUFilterPopup | (Ereditato da TreeList)
Metodo pubblico | ShowPrintPreview | (Ereditato da TreeList)
Metodo protetto | ShowPrintPreviewCore | (Ereditato da TreeList)
Metodo protetto | ShowProgressForm | (Ereditato da TreeList)
Metodo pubblico | ShowRibbonPrintPreview | (Ereditato da TreeList)
Metodo protetto | ShowRibbonPrintPreviewCore | (Ereditato da TreeList)
Metodo pubblico | ShowUnboundExpressionEditor | (Ereditato da TreeList)
Metodo pubblico | Sort(TreeListNode, IComparerTreeListNode, Boolean) | (Ereditato da TreeList)
Metodo protetto | Sort(TreeListNodes, Boolean, Boolean) | (Ereditato da TreeList)
Metodo pubblico | Sort(TreeListNode, TreeListColumn, SortOrder, Boolean) | (Ereditato da TreeList)
Metodo pubblico | StartIncrementalSearch | (Ereditato da TreeList)
Metodo protetto | StartOfficeScrolling | (Ereditato da TreeList)
Metodo pubblico | StopIncrementalSearch | (Ereditato da TreeList)
Metodo protetto | StopOfficeScrolling | (Ereditato da TreeList)
Metodo pubblico | UncheckAll | (Ereditato da TreeList)
Metodo protetto | UnlockDirectXRendering | (Ereditato da TreeList)
Metodo pubblico | UnlockReloadNodes | (Ereditato da TreeList)
Metodo pubblico | UnselectCell | (Ereditato da TreeList)
Metodo protetto | UnselectCellCore | (Ereditato da TreeList)
Metodo pubblico | UnselectCells(Int32, String, Int32, String) | (Ereditato da TreeList)
Metodo pubblico | UnselectCells(TreeListNode, TreeListColumn, TreeListNode, TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | UnselectNode | (Ereditato da TreeList)
Metodo pubblico | UnselectNodes(Int32, Int32) | (Ereditato da TreeList)
Metodo pubblico | UnselectNodes(TreeListNode, TreeListNode) | (Ereditato da TreeList)
Metodo protetto | UpdateActiveFilterInfo | (Ereditato da TreeList)
Metodo protetto | UpdateAutoFilterRowActiveEditor | (Ereditato da TreeList)
Metodo protetto | UpdateBandColumnsIndices | (Ereditato da TreeList)
Metodo protetto | UpdateBandColumnsOrder | (Ereditato da TreeList)
Metodo protetto | UpdateColumnAutoFilter | (Ereditato da TreeList)
Metodo protetto | UpdateColumnsSortIndices | (Ereditato da TreeList)
Metodo protetto | UpdateElementsLookAndFeel | (Ereditato da TreeList)
Metodo protetto | UpdateFilter | (Ereditato da TreeList)
Metodo protetto | UpdateFilterInfo | (Ereditato da TreeList)
Metodo protetto | UpdateFindPanelFilterText | (Ereditato da TreeList)
Metodo protetto | UpdateLayout | (Ereditato da TreeList)
Metodo protetto | UpdateRootBands | (Ereditato da TreeList)
Metodo protetto | UpdateSelectCell | (Ereditato da TreeList)
Metodo protetto | UpdateSelectCell(TreeListNode, TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | UpdateSelectNode | (Ereditato da TreeList)
Metodo protetto | UpdateSelectNode(TreeListNode) | (Ereditato da TreeList)
Metodo protetto | UpdateVScrollBarCore | (Ereditato da TreeList)
Metodo protetto | ValidateAndEndCurrentEdit | (Ereditato da TreeList)
Metodo protetto | WndProc | (Ereditato da TreeList)
Metodo protetto | XtraClearColumns | (Ereditato da TreeList)
Metodo protetto | XtraCreateColumnsItem | (Ereditato da TreeList)
Metodo protetto | XtraFindColumnsItem | (Ereditato da TreeList)
Torna su
Vedi anche

Documentazione

Classe DedDependenciesControlMyTreeListDedDependencies
Namespace DedNet.Controls


Metodo DedDependenciesControl.MyTreeListDedDependencies.FilterNodes

Metodo DedDependenciesControlMyTreeListDedDependenciesFilterNodes
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | FilterNodes |
Metodo pubblico | FilterNodes(TreeListNodes) |
Torna su
Vedi anche

Documentazione

Classe DedDependenciesControlMyTreeListDedDependencies
Namespace DedNet.Controls


Metodo DedDependenciesControl.MyTreeListDedDependencies.FilterNodes

Metodo DedDependenciesControlMyTreeListDedDependenciesFilterNodes

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void FilterNodes()
Public Overrides Sub FilterNodes
public:
virtual void FilterNodes() override
abstract FilterNodes : unit -> unit
override FilterNodes : unit -> unit
Vedi anche

Documentazione

Classe DedDependenciesControlMyTreeListDedDependencies
Overload di FilterNodes
Namespace DedNet.Controls


Metodo DedDependenciesControl.MyTreeListDedDependencies.OnPaint

Metodo DedDependenciesControlMyTreeListDedDependenciesOnPaint
Implementazione dell'override di onPaint. Grazie al catch delle eccezioni evita l'uscita della X rossa sul form

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void OnPaint(
    PaintEventArgs e
)
Protected Overrides Sub OnPaint (
    e As PaintEventArgs
)
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override
abstract OnPaint :
        e : PaintEventArgs -> unit
override OnPaint :
        e : PaintEventArgs -> unit

Parametri

e PaintEventArgs
Vedi anche

Documentazione

Classe DedDependenciesControlMyTreeListDedDependencies
Namespace DedNet.Controls


Eventi di MyTreeListDedDependencies

Il tipo DedDependenciesControlMyTreeListDedDependencies espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | AfterCheckNode | (Ereditato da TreeList)
Evento pubblico | AfterCollapse | (Ereditato da TreeList)
Evento pubblico | AfterDragNode | (Ereditato da TreeList)
Evento pubblico | AfterDropNode | (Ereditato da TreeList)
Evento pubblico | AfterExpand | (Ereditato da TreeList)
Evento pubblico | AfterFocusNode | (Ereditato da TreeList)
Evento pubblico | BandPositionChanged | (Ereditato da TreeList)
Evento pubblico | BandWidthChanged | (Ereditato da TreeList)
Evento pubblico | BeforeCheckNode | (Ereditato da TreeList)
Evento pubblico | BeforeCollapse | (Ereditato da TreeList)
Evento pubblico | BeforeDragNode | (Ereditato da TreeList)
Evento pubblico | BeforeDropNode | (Ereditato da TreeList)
Evento pubblico | BeforeExpand | (Ereditato da TreeList)
Evento pubblico | BeforeFocusNode | (Ereditato da TreeList)
Evento pubblico | BeforeLoadLayout | (Ereditato da TreeList)
Evento pubblico | CalcNodeDragImageIndex | (Ereditato da TreeList)
Evento pubblico | CalcNodeHeight | (Ereditato da TreeList)
Evento pubblico | CellValueChanged | (Ereditato da TreeList)
Evento pubblico | CellValueChanging | (Ereditato da TreeList)
Evento pubblico | ClipboardNodeCopying | (Ereditato da TreeList)
Evento pubblico | ClipboardNodePasting | (Ereditato da TreeList)
Evento pubblico | ColumnButtonClick | (Ereditato da TreeList)
Evento pubblico | ColumnChanged | (Ereditato da TreeList)
Evento pubblico | ColumnFilterChanged | (Ereditato da TreeList)
Evento pubblico | ColumnPositionChanged | (Ereditato da TreeList)
Evento pubblico | ColumnUnboundExpressionChanged | (Ereditato da TreeList)
Evento pubblico | ColumnWidthChanged | (Ereditato da TreeList)
Evento pubblico | CompareNodeValues | (Ereditato da TreeList)
Evento pubblico | CreateCustomNode | (Ereditato da TreeList)
Evento pubblico | CustomColumnDisplayText | (Ereditato da TreeList)
Evento pubblico | CustomColumnSort | (Ereditato da TreeList)
Evento pubblico | CustomDrawBandHeader | (Ereditato da TreeList)
Evento pubblico | CustomDrawColumnHeader | (Ereditato da TreeList)
Evento pubblico | CustomDrawEmptyArea | (Ereditato da TreeList)
Evento pubblico | CustomDrawFilterPanel | (Ereditato da TreeList)
Evento pubblico | CustomDrawFooter | (Ereditato da TreeList)
Evento pubblico | CustomDrawFooterCell | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodeButton | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodeCell | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodeCheckBox | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodeImages | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodeIndent | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodeIndicator | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodePreview | (Ereditato da TreeList)
Evento pubblico | CustomDrawRow | (Ereditato da TreeList)
Evento pubblico | CustomDrawRowFooter | (Ereditato da TreeList)
Evento pubblico | CustomDrawRowFooterCell | (Ereditato da TreeList)
Evento pubblico | CustomDrawScroll | (Ereditato da TreeList)
Evento pubblico | CustomFilterDisplayText | (Ereditato da TreeList)
Evento pubblico | CustomizationFormSearch | (Ereditato da TreeList)
Evento pubblico | CustomizeNewNodeFromOuterData | (Ereditato da TreeList)
Evento pubblico | CustomizeNodeTemplate | (Ereditato da TreeList)
Evento pubblico | CustomNodeCellEdit | (Ereditato da TreeList)
Evento pubblico | CustomNodeCellEditForEditing | (Ereditato da TreeList)
Evento pubblico | CustomRowFilter | (Ereditato da TreeList)
Evento pubblico | CustomScrollAnnotation | (Ereditato da TreeList)
Evento pubblico | CustomUnboundColumnData | (Ereditato da TreeList)
Evento pubblico | DataSourceChanged | (Ereditato da TreeList)
Evento pubblico | DefaultPaintHelperChanged | (Ereditato da TreeList)
Evento pubblico | DragCancelNode | (Ereditato da TreeList)
Evento pubblico | DragObjectDrop | (Ereditato da TreeList)
Evento pubblico | DragObjectOver | (Ereditato da TreeList)
Evento pubblico | DragObjectStart | (Ereditato da TreeList)
Evento pubblico | EditFormHidden | (Ereditato da TreeList)
Evento pubblico | EditFormPrepared | (Ereditato da TreeList)
Evento pubblico | EditFormShowing | (Ereditato da TreeList)
Evento pubblico | EditorKeyDown | (Ereditato da EditorContainer)
Evento pubblico | EditorKeyPress | (Ereditato da EditorContainer)
Evento pubblico | EditorKeyUp | (Ereditato da EditorContainer)
Evento pubblico | EndSorting | (Ereditato da TreeList)
Evento pubblico | FilterEditorCreated | (Ereditato da TreeList)
Evento pubblico | FilterExpressionEditorCreated | (Ereditato da TreeList)
Evento pubblico | FilterNode | (Ereditato da TreeList)
Evento pubblico | FilterPopupExcelCustomizeTemplate | (Ereditato da TreeList)
Evento pubblico | FilterPopupExcelData | (Ereditato da TreeList)
Evento pubblico | FilterPopupExcelParseFilterCriteria | (Ereditato da TreeList)
Evento pubblico | FilterPopupExcelPrepareTemplate | (Ereditato da TreeList)
Evento pubblico | FilterPopupExcelQueryFilterCriteria | (Ereditato da TreeList)
Evento pubblico | FocusedColumnChanged | (Ereditato da TreeList)
Evento pubblico | FocusedNodeChanged | (Ereditato da TreeList)
Evento pubblico | FormatRuleExpressionEditorCreated | (Ereditato da TreeList)
Evento pubblico | GetCustomNodeCellEdit | Obsoleto. (Ereditato da TreeList)
Evento pubblico | GetCustomNodeCellStyle | Obsoleto. (Ereditato da TreeList)
Evento pubblico | GetCustomSummaryValue | (Ereditato da TreeList)
Evento pubblico | GetNodeDisplayValue | (Ereditato da TreeList)
Evento pubblico | GetPreviewText | (Ereditato da TreeList)
Evento pubblico | GetPrintCustomSummaryValue | (Ereditato da TreeList)
Evento pubblico | GetPrintPreviewText | (Ereditato da TreeList)
Evento pubblico | GetSelectImage | (Ereditato da TreeList)
Evento pubblico | GetStateImage | (Ereditato da TreeList)
Evento pubblico | HiddenEditor | (Ereditato da TreeList)
Evento pubblico | HideCustomizationForm | (Ereditato da TreeList)
Evento pubblico | HtmlElementBlur | (Ereditato da TreeList)
Evento pubblico | HtmlElementFocus | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseClick | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseDoubleClick | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseDown | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseMove | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseOut | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseOver | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseUp | (Ereditato da TreeList)
Evento pubblico | HtmlSelectedTextChanged | (Ereditato da TreeList)
Evento pubblico | HyperlinkClick | (Ereditato da TreeList)
Evento pubblico | InitNewRow | (Ereditato da TreeList)
Evento pubblico | InvalidNodeException | (Ereditato da TreeList)
Evento pubblico | InvalidValueException | (Ereditato da TreeList)
Evento pubblico | LayoutUpdated | (Ereditato da TreeList)
Evento pubblico | LayoutUpgrade | (Ereditato da TreeList)
Evento pubblico | LeftCoordChanged | (Ereditato da TreeList)
Evento pubblico | Load | (Ereditato da TreeList)
Evento pubblico | MeasurePreviewHeight | (Ereditato da TreeList)
Evento pubblico | NodeCellStyle | (Ereditato da TreeList)
Evento pubblico | NodeChanged | (Ereditato da TreeList)
Evento pubblico | NodesReloaded | (Ereditato da TreeList)
Evento pubblico | PaintEx | (Ereditato da TreeList)
Evento pubblico | ParseFindPanelText | (Ereditato da TreeList)
Evento pubblico | PopupMenuShowing | (Ereditato da TreeList)
Evento pubblico | PrintExportProgress | (Ereditato da TreeList)
Evento pubblico | PropertyDeserializing | (Ereditato da TreeList)
Evento pubblico | PropertySerializing | (Ereditato da TreeList)
Evento pubblico | QueryCustomFunctions | (Ereditato da TreeList)
Evento pubblico | QueryEmptyTreeTemplate | (Ereditato da TreeList)
Evento pubblico | QueryNodeTemplate | (Ereditato da TreeList)
Evento pubblico | RowCellClick | (Ereditato da TreeList)
Evento pubblico | RowClick | (Ereditato da TreeList)
Evento pubblico | RowSelectImageClick | (Ereditato da TreeList)
Evento pubblico | RowStateImageClick | (Ereditato da TreeList)
Evento pubblico | ScrollAnnotationsStyle | (Ereditato da TreeList)
Evento pubblico | SelectImageClick | (Ereditato da TreeList)
Evento pubblico | SelectionChanged | (Ereditato da TreeList)
Evento pubblico | SelectionChanging | (Ereditato da TreeList)
Evento pubblico | ShowCustomizationForm | (Ereditato da TreeList)
Evento pubblico | ShowFilterPopupCheckedListBox | (Ereditato da TreeList)
Evento pubblico | ShowFilterPopupDate | (Ereditato da TreeList)
Evento pubblico | ShowFilterPopupExcel | (Ereditato da TreeList)
Evento pubblico | ShowFilterPopupListBox | (Ereditato da TreeList)
Evento pubblico | ShowingEditor | (Ereditato da TreeList)
Evento pubblico | ShownEditor | (Ereditato da TreeList)
Evento pubblico | ShowTreeListMenu | Obsoleto. (Ereditato da TreeList)
Evento pubblico | StartSorting | (Ereditato da TreeList)
Evento pubblico | StateChanged | (Ereditato da TreeList)
Evento pubblico | StateImageClick | (Ereditato da TreeList)
Evento pubblico | SubstituteFilter | (Ereditato da TreeList)
Evento pubblico | TopVisibleNodeIndexChanged | (Ereditato da TreeList)
Evento pubblico | TreeListMenuItemClick | (Ereditato da TreeList)
Evento pubblico | UnboundExpressionEditorCreated | (Ereditato da TreeList)
Evento pubblico | ValidateNode | (Ereditato da TreeList)
Evento pubblico | ValidatingEditor | (Ereditato da TreeList)
Evento pubblico | VirtualTreeGetCellValue | (Ereditato da TreeList)
Evento pubblico | VirtualTreeGetChildNodes | (Ereditato da TreeList)
Evento pubblico | VirtualTreeSetCellValue | (Ereditato da TreeList)
Torna su
Vedi anche

Documentazione

Classe DedDependenciesControlMyTreeListDedDependencies
Namespace DedNet.Controls


Campi di MyTreeListDedDependencies

Il tipo DedDependenciesControlMyTreeListDedDependencies espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | allowCloseEditor | (Ereditato da TreeList)
Campo pubblico | FilterByState |
Campo protetto | fInitializing | (Ereditato da EditorContainer)
Campo protetto | fUpdateSize | (Ereditato da TreeList)
Campo protetto | SortedColumns | (Ereditato da TreeList)
Campo pubblico | ViewState |
Torna su
Vedi anche

Documentazione

Classe DedDependenciesControlMyTreeListDedDependencies
Namespace DedNet.Controls


Campo DedDependenciesControl.MyTreeListDedDependencies.FilterByState

Campo DedDependenciesControlMyTreeListDedDependenciesFilterByState

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<int> FilterByState
Public FilterByState As List(Of Integer)
public:
List<int>^ FilterByState
val mutable FilterByState: List<int>

Valore del campo

List Int32
Vedi anche

Documentazione

Classe DedDependenciesControlMyTreeListDedDependencies
Namespace DedNet.Controls


Campo DedDependenciesControl.MyTreeListDedDependencies.ViewState

Campo DedDependenciesControlMyTreeListDedDependenciesViewState

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public UtilityTreeListViewState ViewState
Public ViewState As UtilityTreeListViewState
public:
UtilityTreeListViewState^ ViewState
val mutable ViewState: UtilityTreeListViewState

Valore del campo

UtilityTreeListViewState
Vedi anche

Documentazione

Classe DedDependenciesControlMyTreeListDedDependencies
Namespace DedNet.Controls


Classe DedDistControl
Controllo per la visualizzazione della struttura della distinta
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
XtraUserControl
DedNet.ControlsUserControlBase
DedNet.ControlsDedDistControl

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedDistControl : UserControlBase
Public Class DedDistControl
    Inherits UserControlBase
public ref class DedDistControl : public UserControlBase
type DedDistControl =
    class
        inherit UserControlBase
    end

Il tipo DedDistControl espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedDistControl |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllowEditAttrDist | Restituisce o imposta il campo che indica la possibilità di editare gli attributi di distinta
Proprietà pubblica | Appearance | (Ereditato da XtraUserControl)
Proprietà pubblica | Application | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Proprietà pubblica | BackColor | (Ereditato da XtraUserControl)
Proprietà pubblica | Behaviour | Behaviour del controllo
Proprietà pubblica | Bom | Restituisce la Bom in editazione.
Proprietà pubblica | BomFakeMode | Indica se la distinta è finta
Proprietà pubblica | BomItemComparer | BomItemComparer da utilizzare
Proprietà protetta | CheckDoubleScaling | (Ereditato da XtraUserControl)
Proprietà pubblica | ChkExp | Indica se esportare anche i vecchi valori degli attributi (gestito dal check)
Proprietà pubblica | Closing | Indica se se sta chiudendo il form che lo contiene
Proprietà pubblica | Comm | Commessa di riferimento
Proprietà pubblica | CompareItems | Dizionario per la gestione del confronto
Proprietà pubblica | CompareMode | Indica se siamo in modalità comparazione
Proprietà pubblica | CtrDistOtherPanel | Contiene il DistControl presente nell'altro pannello durante il comando di confronto
Proprietà pubblica | CurrentActionAdd | Indica l'azione che sta eseguendo l'add del nodo
Proprietà protetta | DefaultAppearance | (Ereditato da XtraUserControl)
Proprietà protetta | DirectXContainer | (Ereditato da XtraUserControl)
Proprietà pubblica | Dm | Dist Manager
Proprietà pubblica | EnableIXtraResizeableControlInterfaceProxy | (Ereditato da XtraUserControl)
Proprietà pubblica | ExportMode | Indica se siamo in modalità Esporta
Proprietà pubblica | Font | (Ereditato da XtraUserControl)
Proprietà pubblica | ForeColor | (Ereditato da XtraUserControl)
Proprietà pubblica | Header | Ritorna l'header della bom corrente
Proprietà protetta | Helper | (Ereditato da XtraUserControl)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraUserControl)
Proprietà pubblica | MultiLevel | Restituisce o imposta il settaggio di visualizzazione multilivello dell'albero
Proprietà pubblica | NotSaveState | Indicate se lo stato dell'albero non deve essere salvato
Proprietà protetta | Painter | (Ereditato da XtraUserControl)
Proprietà pubblica | PreviewColumnName | Restituisce il nome della colonna dell'anteprima
Proprietà pubblica | RegistryBaseKey | Restituisce o imposta la chiave dalla quale leggere e nella quale scrivere le impostazioni.
Proprietà protetta | ScaleChildren | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleDPI | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraUserControl)
Proprietà pubblica | ScrollHorizontal | Abilitazione/Disabilitazione della sincronizzazione dello scroll orizzontale durante il comando di confronto
Proprietà pubblica | ScrollVertical | Abilitazione/Disabilitazione della sincronizzazione dello scroll verticale durante il comando di confronto
Proprietà pubblica | SelBomInfo | Restituisce la lista degli elementi selezionati
Proprietà protetta | ShouldCheckDpiScaleFactorOnParentChanged | (Ereditato da XtraUserControl)
Proprietà pubblica | ShowAttr | Indica se visualizzare il pannello attributi
Proprietà pubblica | ShowCadDiff | Indica se visualizzare le differenze tra CAD ed Edited
Proprietà pubblica | ShowPreview | Indica se visualizzare le anteprime
Proprietà pubblica | ShowRibbonStatusBar | Indica se visualizzare o meno il ribbon con i pulsanti.
Proprietà pubblica | Site | (Ereditato da XtraUserControl)
Proprietà pubblica | SortColumn | Abilitazione/Disabilitazione dell'ordinamento sulle colonne durante il comando di confronto
Proprietà pubblica | Stack | Stack
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AddNode(BomItemCollection, DedData, Double) | Aggiunge l'anagrafica passata alla distinta
Metodo pubblico | AddNode(BomItemCollection, DedDataPart, Double) | Aggiunge l'anagrafica passata alla distinta
Metodo pubblico | AddNode(BomItemCollection, Row, Double) | Aggiunge l'anagrafica passata alla distinta
Metodo pubblico | AddNode(BomItemCollection, DedData, Double, Boolean) | Aggiunge l'anagrafica passata alla distinta
Metodo pubblico | AddNode(BomItemCollection, DedData, Double, Object) | Aggiunge l'anagrafica passata alla distinta
Metodo pubblico | AddNode(BomItemCollection, DedDataPart, Double, Boolean) | Aggiunge l'anagrafica passata alla distinta
Metodo pubblico | AddNode(BomItemCollection, Row, Double, Boolean) | Aggiunge l'anagrafica passata alla distinta
Metodo pubblico | AddNode(BomItemCollection, DedData, Double, Boolean, Object) | Aggiunge l'anagrafica passata alla distinta
Metodo pubblico | AddNode(BomItemCollection, DedDataPart, Double, Boolean, Object) | Aggiunge l'anagrafica passata alla distinta
Metodo protetto | BaseWndProc | (Ereditato da XtraUserControl)
Metodo pubblico | CompareDist | Compara i due header passati e compila i dizionari usati per evidenziare i nodi nell'albero in base allo stato di comparazione della distinta
Metodo pubblico | CompareDistExp(BomItemCollection, BomItemCollection, BomItemCollection, Boolean) | Effettua la comparazione e salva le informazioni nei BomItem
Metodo pubblico | CompareDistExp(DistHeader, DistHeader, BomItemCollection, Boolean) | Effettua la comparazione e salva le informazioni nei BomItem
Metodo pubblico | CompareDistExport | Effettua la comparazione (usato da DEDAPI)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraUserControl)
Metodo protetto | CreatePainter | (Ereditato da XtraUserControl)
Metodo pubblico | DiscardChanges | Annualla le modifiche apportate dal controllo di distinta
Metodo pubblico | Dispose | Esegue il dispose dei controlli utente particolarmente dispendiosi
Metodo protetto | Dispose(Boolean) | Clean up any resources being used. (Sovrascrive UserControlBaseDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraUserControl)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraUserControl)
Metodo pubblico | EditColumns | Modifica l'editabilità delle colonne e i relativi edit associati.
Metodo pubblico | EraseAllNodes | Tutti i nodi vengono marcati come eliminati. Quelli già eliminati vengono ripristinati
Metodo pubblico | EraseSelectedNode | I nodi selezionati vengono marcati come eliminati. Quelli già eliminati vengono ripristinati.
Metodo pubblico | ExportToExcel | Metodo usato per esportare la distinta su file excel
Metodo pubblico | FireSelectionChanged |
Metodo pubblico | GetActiveBomItem | Restituisce il bomItem dell'elemento selezionato
Metodo pubblico | GetActiveBomItemCollection | Restituisce la bomItem collection dell'elemento selezionato
Metodo pubblico | GetActiveBomItemCollectionNode | Restituisce il nodo relativo alla bomitemcollection attiva in editazione
Metodo pubblico | GetActiveBomItemCollections | Restituisce la bomItem collection degli elementi selezionati
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraUserControl)
Metodo pubblico | GetActiveNode | Restituisce il nodo dell'elemento selezionato
Metodo protetto | GetBackColor | (Ereditato da XtraUserControl)
Metodo protetto | GetBackgroundSkinElement | (Ereditato da XtraUserControl)
Metodo pubblico | GetBicFromNode | Restiruisce il BomItemCollection del nodo passato.
Metodo pubblico | GetDataByRootNode | Restituisce l'anagrafica associata al nodo di testa.
Metodo pubblico | GetDictionaryFromObjectList(BomItem) | Restruisce gil attributi di distinta in un dizionario nome valore (leggendoli dal BomItem).
Metodo pubblico | GetDictionaryFromObjectList(BomItemCollection, DedData) | Restruisce gil attributi di distinta in un dizionario nome valore (leggendoli dall'anagrafica).
Metodo protetto | GetInnerIXtraResizableControl | (Ereditato da XtraUserControl)
Metodo pubblico | GetSelectedBomItems | Restituisce il nodo dell'elemento selezionato
Metodo pubblico | GetSelectedDatas | Restituisce le anagrafiche degli elementi selezionati
Metodo pubblico | GetSelectedNodes | Restituisce i nodi degli elementi selezionati.
Metodo pubblico | GetTree | Ritorna il controllo TreeList
Metodo protetto | IsChildControlsRequiredScalingEnabled | (Ereditato da XtraUserControl)
Metodo pubblico | IsDirty | Ritorna un booleano che stabilisce se la distinta è dirty o meno
Metodo protetto | IsParentHandleCreatedRecursive | (Ereditato da XtraUserControl)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraUserControl)
Metodo protetto | OnBackColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnContextMenuOpening | (Sovrascrive UserControlBaseOnContextMenuOpening(Object, CancelEventArgs))
Metodo protetto | OnControlAdded | (Ereditato da XtraUserControl)
Metodo protetto | OnControlRemoved | (Ereditato da XtraUserControl)
Metodo protetto | OnDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnFirstLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnForeColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleCreated | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraUserControl)
Metodo protetto | OnLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnMenuItemClicked | Evento di pressione di un comando del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnPaintCore | (Ereditato da XtraUserControl)
Metodo protetto | OnParentChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | onSelectionChanged | Metodo che esegue l'evento custom di 'SelectionChanged'.
Metodo protetto | OnSizeChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnUpdateButtonClick | Esegue l'evento custom di 'UpdateButtonClick'.
Metodo protetto | RaisePaintExEvent | (Ereditato da XtraUserControl)
Metodo pubblico | RefreshAttributePane | Aggiorna il pannello degli attributi con i dati del nodo passato
Metodo pubblico | RefreshCompareInfo | Effettua un espansione/collasso del nodo passato per ricalcolare i dati di comparazione
Metodo pubblico | RefreshDist | Permette di aggiornare l'elenco
Metodo pubblico | RefreshHeader | Metodo per effettuare il Refresh dell'header della collection del BomItem passato
Metodo pubblico | ReloadSubDist | Ricaricamento figli del nodo passato. Utile dopo una modifica alla distinta
Metodo pubblico | ResetBackColor | (Ereditato da XtraUserControl)
Metodo pubblico | ResetForeColor | (Ereditato da XtraUserControl)
Metodo pubblico | RestoreAfterXml | Ripristina i Tag delle colonne e l'opzione ShowIndicator
Metodo protetto | RestoreAutoScaleModeChangedByPM2 | (Ereditato da XtraUserControl)
Metodo pubblico | RestoreDist | Evidenzia un nodo dell'albero in base allo stato di comparazione della distinta
Metodo pubblico | RestoreLayoutXml | Metodo usato per caricare la configurazione
Metodo pubblico | ResultBomCompareExp | Ritorna un dizionario contenente gli elementi di distinta e campi di distinta modificati
Metodo pubblico | SaveChanges | Salva le modifiche sulla bom attualmente caricata
Metodo pubblico | SaveRegistrySettings | Salva nel registro le impostazioni dell'albero.
Metodo pubblico | SaveRegistrySettingsExp | Salva nel registro le impostazioni dell'albero usato per il confronto
Metodo protetto | ScaleControl | (Ereditato da XtraUserControl)
Metodo pubblico | SelectBomFirstLevel | Seleziona gli elementi al primo livello di distinta
Metodo pubblico | SelectBomHeader | Seleziona solo l'elemento padre ripulendo la selezione corrente
Metodo pubblico | SetCommandList | Rigenera il menu contestuale di questo controllo con la lista dei comandi passati. (Sovrascrive UserControlBaseSetCommandList(DedCommandList, CommandContextEnum))
Metodo protetto | SetVisibleCore | (Ereditato da XtraUserControl)
Metodo protetto | ShouldPaintTransparentBackground | (Ereditato da XtraUserControl)
Metodo protetto | ShouldUseDirectXPaint | (Ereditato da XtraUserControl)
Metodo pubblico | ShowDist | Metodo per impostare la distinta da visualizzare
Metodo pubblico | ShowDistInfo(String) | Metodo pubblico per la gestione messaggi sulla barra di stato
Metodo pubblico | ShowDistInfo(DistHeader, DedBomExplorerControlDedBomExplorerBehaviourEnum) | Metodo pubblico per la gestione messaggi sulla barra di stato
Metodo pubblico | SubstNode(BomItemCollection, DedData, DedData, DictionaryString, Object) | Sostituisce l'anagrafica con quella passa
Metodo pubblico | SubstNode(BomItemCollection, DedData, DedData, BomItemManEnum, DictionaryString, Object) | Sostituisce l'anagrafica con quella passa
Metodo pubblico | SubstNode(BomItemCollection, DedData, DedData, BomItemManEnum, BomItemManEnum, DictionaryString, Object) | Sostituisce l'anagrafica con quella passa
Metodo pubblico | ToolTipLegend | Crea la legenda utilizzando un SuperToolTip
Metodo pubblico | UnloadDist | Scarica la distinta corrente
Metodo pubblico | UnLock |
Metodo pubblico | UpdateNode | Aggiorna le anagrafiche dei nodi selezionati.
Metodo pubblico | UpdateSelectedNode | Aggiorna le anagrafiche dei nodi selezionati.
Metodo pubblico | UpdateSup | Effettua l'aggiornamento delle revisioni superate sulla collection passata
Metodo protetto | WndProc | (Ereditato da XtraUserControl)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | ContextMenuOpening | Evento su apertura del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | DataLoadedInsideGrid | Evento che permette di riordinare le distinte nella griglia appena dopo l'esecuzione del comando di salvataggio.
Evento pubblico | MenuItemClicked | Evento su click su un elemento del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | onInsertFromAnagr | Definizione evento aggiunto elemento proveniente da anagrafica
Evento pubblico | PaintEx | (Ereditato da XtraUserControl)
Evento pubblico | SelectionChanged | Evento cambio selezione famiglia.
Evento pubblico | UpdateButtonClick | Evento associato al click del bottone Ok
Torna su
Campi
 | Nome | Descrizione
Campo protetto | _app | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Campo protetto | _RegistryBaseKey | Chiave nel registro di sistema di salvataggio impostazioni. (Ereditato da UserControlBase)
 | CONFDIST_SETTINGS |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore DedDistControl

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDistControl()
Public Sub New
public:
DedDistControl()
new : unit -> DedDistControl
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Proprietà di DedDistControl

Il tipo DedDistControl espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllowEditAttrDist | Restituisce o imposta il campo che indica la possibilità di editare gli attributi di distinta
Proprietà pubblica | Appearance | (Ereditato da XtraUserControl)
Proprietà pubblica | Application | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Proprietà pubblica | BackColor | (Ereditato da XtraUserControl)
Proprietà pubblica | Behaviour | Behaviour del controllo
Proprietà pubblica | Bom | Restituisce la Bom in editazione.
Proprietà pubblica | BomFakeMode | Indica se la distinta è finta
Proprietà pubblica | BomItemComparer | BomItemComparer da utilizzare
Proprietà protetta | CheckDoubleScaling | (Ereditato da XtraUserControl)
Proprietà pubblica | ChkExp | Indica se esportare anche i vecchi valori degli attributi (gestito dal check)
Proprietà pubblica | Closing | Indica se se sta chiudendo il form che lo contiene
Proprietà pubblica | Comm | Commessa di riferimento
Proprietà pubblica | CompareItems | Dizionario per la gestione del confronto
Proprietà pubblica | CompareMode | Indica se siamo in modalità comparazione
Proprietà pubblica | CtrDistOtherPanel | Contiene il DistControl presente nell'altro pannello durante il comando di confronto
Proprietà pubblica | CurrentActionAdd | Indica l'azione che sta eseguendo l'add del nodo
Proprietà protetta | DefaultAppearance | (Ereditato da XtraUserControl)
Proprietà protetta | DirectXContainer | (Ereditato da XtraUserControl)
Proprietà pubblica | Dm | Dist Manager
Proprietà pubblica | EnableIXtraResizeableControlInterfaceProxy | (Ereditato da XtraUserControl)
Proprietà pubblica | ExportMode | Indica se siamo in modalità Esporta
Proprietà pubblica | Font | (Ereditato da XtraUserControl)
Proprietà pubblica | ForeColor | (Ereditato da XtraUserControl)
Proprietà pubblica | Header | Ritorna l'header della bom corrente
Proprietà protetta | Helper | (Ereditato da XtraUserControl)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraUserControl)
Proprietà pubblica | MultiLevel | Restituisce o imposta il settaggio di visualizzazione multilivello dell'albero
Proprietà pubblica | NotSaveState | Indicate se lo stato dell'albero non deve essere salvato
Proprietà protetta | Painter | (Ereditato da XtraUserControl)
Proprietà pubblica | PreviewColumnName | Restituisce il nome della colonna dell'anteprima
Proprietà pubblica | RegistryBaseKey | Restituisce o imposta la chiave dalla quale leggere e nella quale scrivere le impostazioni.
Proprietà protetta | ScaleChildren | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleDPI | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraUserControl)
Proprietà pubblica | ScrollHorizontal | Abilitazione/Disabilitazione della sincronizzazione dello scroll orizzontale durante il comando di confronto
Proprietà pubblica | ScrollVertical | Abilitazione/Disabilitazione della sincronizzazione dello scroll verticale durante il comando di confronto
Proprietà pubblica | SelBomInfo | Restituisce la lista degli elementi selezionati
Proprietà protetta | ShouldCheckDpiScaleFactorOnParentChanged | (Ereditato da XtraUserControl)
Proprietà pubblica | ShowAttr | Indica se visualizzare il pannello attributi
Proprietà pubblica | ShowCadDiff | Indica se visualizzare le differenze tra CAD ed Edited
Proprietà pubblica | ShowPreview | Indica se visualizzare le anteprime
Proprietà pubblica | ShowRibbonStatusBar | Indica se visualizzare o meno il ribbon con i pulsanti.
Proprietà pubblica | Site | (Ereditato da XtraUserControl)
Proprietà pubblica | SortColumn | Abilitazione/Disabilitazione dell'ordinamento sulle colonne durante il comando di confronto
Proprietà pubblica | Stack | Stack
Torna su
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Proprietà DedDistControl.AllowEditAttrDist

Proprietà DedDistControlAllowEditAttrDist
Restituisce o imposta il campo che indica la possibilità di editare gli attributi di distinta

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AllowEditAttrDist { get; set; }
Public Property AllowEditAttrDist As Boolean
    Get
    Set
public:
property bool AllowEditAttrDist {
    bool get ();
    void set (bool value);
}
member AllowEditAttrDist : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Proprietà DedDistControl.Behaviour

Proprietà DedDistControlBehaviour
Behaviour del controllo

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedBomExplorerControlDedBomExplorerBehaviourEnum Behaviour { get; set; }
Public Property Behaviour As DedBomExplorerControlDedBomExplorerBehaviourEnum
    Get
    Set
public:
property DedBomExplorerControlDedBomExplorerBehaviourEnum Behaviour {
    DedBomExplorerControlDedBomExplorerBehaviourEnum get ();
    void set (DedBomExplorerControlDedBomExplorerBehaviourEnum value);
}
member Behaviour : DedBomExplorerControlDedBomExplorerBehaviourEnum with get, set

Valore della proprietà

DedBomExplorerControlDedBomExplorerBehaviourEnum
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Proprietà DedDistControl.Bom

Proprietà DedDistControlBom
Restituisce la Bom in editazione.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItemCollection Bom { get; }
Public ReadOnly Property Bom As BomItemCollection
    Get
public:
property BomItemCollection^ Bom {
    BomItemCollection^ get ();
}
member Bom : BomItemCollection with get

Valore della proprietà

BomItemCollection
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Proprietà DedDistControl.BomFakeMode

Proprietà DedDistControlBomFakeMode
Indica se la distinta è finta

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool BomFakeMode { get; }
Public ReadOnly Property BomFakeMode As Boolean
    Get
public:
property bool BomFakeMode {
    bool get ();
}
member BomFakeMode : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Proprietà DedDistControl.BomItemComparer

Proprietà DedDistControlBomItemComparer
BomItemComparer da utilizzare

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItemComparer BomItemComparer { get; set; }
Public Property BomItemComparer As BomItemComparer
    Get
    Set
public:
property BomItemComparer^ BomItemComparer {
    BomItemComparer^ get ();
    void set (BomItemComparer^ value);
}
member BomItemComparer : BomItemComparer with get, set

Valore della proprietà

BomItemComparer
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Proprietà DedDistControl.ChkExp

Proprietà DedDistControlChkExp
Indica se esportare anche i vecchi valori degli attributi (gestito dal check)

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ChkExp { get; set; }
Public Property ChkExp As Boolean
    Get
    Set
public:
property bool ChkExp {
    bool get ();
    void set (bool value);
}
member ChkExp : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Proprietà DedDistControl.Closing

Proprietà DedDistControlClosing
Indica se se sta chiudendo il form che lo contiene

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Closing { get; set; }
Public Property Closing As Boolean
    Get
    Set
public:
property bool Closing {
    bool get ();
    void set (bool value);
}
member Closing : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Proprietà DedDistControl.Comm

Proprietà DedDistControlComm
Commessa di riferimento

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedComm Comm { get; set; }
Public Property Comm As DedComm
    Get
    Set
public:
property DedComm^ Comm {
    DedComm^ get ();
    void set (DedComm^ value);
}
member Comm : DedComm with get, set

Valore della proprietà

DedComm
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Proprietà DedDistControl.CompareItems

Proprietà DedDistControlCompareItems
Dizionario per la gestione del confronto

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<TreeListNode, Dictionary<TreeListNode, DedDistControlDedCompareDistEnum>> CompareItems { get; }
Public ReadOnly Property CompareItems As Dictionary(Of TreeListNode, Dictionary(Of TreeListNode, DedDistControlDedCompareDistEnum))
    Get
public:
property Dictionary<TreeListNode^, Dictionary<TreeListNode^, DedDistControlDedCompareDistEnum>^>^ CompareItems {
    Dictionary<TreeListNode^, Dictionary<TreeListNode^, DedDistControlDedCompareDistEnum>^>^ get ();
}
member CompareItems : Dictionary<TreeListNode, Dictionary<TreeListNode, DedDistControlDedCompareDistEnum>> with get

Valore della proprietà

Dictionary TreeListNode, Dictionary TreeListNode, DedDistControlDedCompareDistEnum
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Proprietà DedDistControl.CompareMode

Proprietà DedDistControlCompareMode
Indica se siamo in modalità comparazione

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CompareMode { get; set; }
Public Property CompareMode As Boolean
    Get
    Set
public:
property bool CompareMode {
    bool get ();
    void set (bool value);
}
member CompareMode : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Proprietà DedDistControl.CtrDistOtherPanel

Proprietà DedDistControlCtrDistOtherPanel
Contiene il DistControl presente nell'altro pannello durante il comando di confronto

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDistControl CtrDistOtherPanel { get; set; }
Public Property CtrDistOtherPanel As DedDistControl
    Get
    Set
public:
property DedDistControl^ CtrDistOtherPanel {
    DedDistControl^ get ();
    void set (DedDistControl^ value);
}
member CtrDistOtherPanel : DedDistControl with get, set

Valore della proprietà

DedDistControl
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Proprietà DedDistControl.CurrentActionAdd

Proprietà DedDistControlCurrentActionAdd
Indica l'azione che sta eseguendo l'add del nodo

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDistControlAddNodeActionEnum CurrentActionAdd { get; set; }
Public Property CurrentActionAdd As DedDistControlAddNodeActionEnum
    Get
    Set
public:
property DedDistControlAddNodeActionEnum CurrentActionAdd {
    DedDistControlAddNodeActionEnum get ();
    void set (DedDistControlAddNodeActionEnum value);
}
member CurrentActionAdd : DedDistControlAddNodeActionEnum with get, set

Valore della proprietà

DedDistControlAddNodeActionEnum
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Proprietà DedDistControl.Dm

Proprietà DedDistControlDm
Dist Manager

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DistManager Dm { get; set; }
Public Property Dm As DistManager
    Get
    Set
public:
property DistManager^ Dm {
    DistManager^ get ();
    void set (DistManager^ value);
}
member Dm : DistManager with get, set

Valore della proprietà

DistManager
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Proprietà DedDistControl.ExportMode

Proprietà DedDistControlExportMode
Indica se siamo in modalità Esporta

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ExportMode { get; set; }
Public Property ExportMode As Boolean
    Get
    Set
public:
property bool ExportMode {
    bool get ();
    void set (bool value);
}
member ExportMode : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Proprietà DedDistControl.Header

Proprietà DedDistControlHeader
Ritorna l'header della bom corrente

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DistHeader Header { get; }
Public ReadOnly Property Header As DistHeader
    Get
public:
property DistHeader^ Header {
    DistHeader^ get ();
}
member Header : DistHeader with get

Valore della proprietà

DistHeader
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Proprietà DedDistControl.MultiLevel

Proprietà DedDistControlMultiLevel
Restituisce o imposta il settaggio di visualizzazione multilivello dell'albero

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool MultiLevel { get; set; }
Public Property MultiLevel As Boolean
    Get
    Set
public:
property bool MultiLevel {
    bool get ();
    void set (bool value);
}
member MultiLevel : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Proprietà DedDistControl.NotSaveState

Proprietà DedDistControlNotSaveState
Indicate se lo stato dell'albero non deve essere salvato

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool NotSaveState { get; set; }
Public Property NotSaveState As Boolean
    Get
    Set
public:
property bool NotSaveState {
    bool get ();
    void set (bool value);
}
member NotSaveState : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Proprietà DedDistControl.PreviewColumnName

Proprietà DedDistControlPreviewColumnName
Restituisce il nome della colonna dell'anteprima

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string PreviewColumnName { get; }
Public ReadOnly Property PreviewColumnName As String
    Get
public:
property String^ PreviewColumnName {
    String^ get ();
}
member PreviewColumnName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Proprietà DedDistControl.RegistryBaseKey

Proprietà DedDistControlRegistryBaseKey
Restituisce o imposta la chiave dalla quale leggere e nella quale scrivere le impostazioni.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string RegistryBaseKey { get; set; }
Public Property RegistryBaseKey As String
    Get
    Set
public:
property String^ RegistryBaseKey {
    String^ get ();
    void set (String^ value);
}
member RegistryBaseKey : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Proprietà DedDistControl.ScrollHorizontal

Proprietà DedDistControlScrollHorizontal
Abilitazione/Disabilitazione della sincronizzazione dello scroll orizzontale durante il comando di confronto

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ScrollHorizontal { get; set; }
Public Property ScrollHorizontal As Boolean
    Get
    Set
public:
property bool ScrollHorizontal {
    bool get ();
    void set (bool value);
}
member ScrollHorizontal : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Proprietà DedDistControl.ScrollVertical

Proprietà DedDistControlScrollVertical
Abilitazione/Disabilitazione della sincronizzazione dello scroll verticale durante il comando di confronto

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ScrollVertical { get; set; }
Public Property ScrollVertical As Boolean
    Get
    Set
public:
property bool ScrollVertical {
    bool get ();
    void set (bool value);
}
member ScrollVertical : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Proprietà DedDistControl.SelBomInfo

Proprietà DedDistControlSelBomInfo
Restituisce la lista degli elementi selezionati

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDistControlBomSelInfoList SelBomInfo { get; }
Public ReadOnly Property SelBomInfo As DedDistControlBomSelInfoList
    Get
public:
property DedDistControlBomSelInfoList^ SelBomInfo {
    DedDistControlBomSelInfoList^ get ();
}
member SelBomInfo : DedDistControlBomSelInfoList with get

Valore della proprietà

DedDistControlBomSelInfoList
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Proprietà DedDistControl.ShowAttr

Proprietà DedDistControlShowAttr
Indica se visualizzare il pannello attributi

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ShowAttr { set; }
Public WriteOnly Property ShowAttr As Boolean
    Set
public:
property bool ShowAttr {
    void set (bool value);
}
member ShowAttr : bool with set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Proprietà DedDistControl.ShowCadDiff

Proprietà DedDistControlShowCadDiff
Indica se visualizzare le differenze tra CAD ed Edited

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ShowCadDiff { get; set; }
Public Property ShowCadDiff As Boolean
    Get
    Set
public:
property bool ShowCadDiff {
    bool get ();
    void set (bool value);
}
member ShowCadDiff : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Proprietà DedDistControl.ShowPreview

Proprietà DedDistControlShowPreview
Indica se visualizzare le anteprime

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ShowPreview { get; set; }
Public Property ShowPreview As Boolean
    Get
    Set
public:
property bool ShowPreview {
    bool get ();
    void set (bool value);
}
member ShowPreview : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Proprietà DedDistControl.ShowRibbonStatusBar

Proprietà DedDistControlShowRibbonStatusBar
Indica se visualizzare o meno il ribbon con i pulsanti.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ShowRibbonStatusBar { get; set; }
Public Property ShowRibbonStatusBar As Boolean
    Get
    Set
public:
property bool ShowRibbonStatusBar {
    bool get ();
    void set (bool value);
}
member ShowRibbonStatusBar : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Proprietà DedDistControl.SortColumn

Proprietà DedDistControlSortColumn
Abilitazione/Disabilitazione dell'ordinamento sulle colonne durante il comando di confronto

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool SortColumn { get; set; }
Public Property SortColumn As Boolean
    Get
    Set
public:
property bool SortColumn {
    bool get ();
    void set (bool value);
}
member SortColumn : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Proprietà DedDistControl.Stack

Proprietà DedDistControlStack
Stack

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Stack Stack { get; set; }
Public Property Stack As Stack
    Get
    Set
public:
property Stack^ Stack {
    Stack^ get ();
    void set (Stack^ value);
}
member Stack : Stack with get, set

Valore della proprietà

Stack
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Metodi di DedDistControl

Il tipo DedDistControl espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AddNode(BomItemCollection, DedData, Double) | Aggiunge l'anagrafica passata alla distinta
Metodo pubblico | AddNode(BomItemCollection, DedDataPart, Double) | Aggiunge l'anagrafica passata alla distinta
Metodo pubblico | AddNode(BomItemCollection, Row, Double) | Aggiunge l'anagrafica passata alla distinta
Metodo pubblico | AddNode(BomItemCollection, DedData, Double, Boolean) | Aggiunge l'anagrafica passata alla distinta
Metodo pubblico | AddNode(BomItemCollection, DedData, Double, Object) | Aggiunge l'anagrafica passata alla distinta
Metodo pubblico | AddNode(BomItemCollection, DedDataPart, Double, Boolean) | Aggiunge l'anagrafica passata alla distinta
Metodo pubblico | AddNode(BomItemCollection, Row, Double, Boolean) | Aggiunge l'anagrafica passata alla distinta
Metodo pubblico | AddNode(BomItemCollection, DedData, Double, Boolean, Object) | Aggiunge l'anagrafica passata alla distinta
Metodo pubblico | AddNode(BomItemCollection, DedDataPart, Double, Boolean, Object) | Aggiunge l'anagrafica passata alla distinta
Metodo protetto | BaseWndProc | (Ereditato da XtraUserControl)
Metodo pubblico | CompareDist | Compara i due header passati e compila i dizionari usati per evidenziare i nodi nell'albero in base allo stato di comparazione della distinta
Metodo pubblico | CompareDistExp(BomItemCollection, BomItemCollection, BomItemCollection, Boolean) | Effettua la comparazione e salva le informazioni nei BomItem
Metodo pubblico | CompareDistExp(DistHeader, DistHeader, BomItemCollection, Boolean) | Effettua la comparazione e salva le informazioni nei BomItem
Metodo pubblico | CompareDistExport | Effettua la comparazione (usato da DEDAPI)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraUserControl)
Metodo protetto | CreatePainter | (Ereditato da XtraUserControl)
Metodo pubblico | DiscardChanges | Annualla le modifiche apportate dal controllo di distinta
Metodo pubblico | Dispose | Esegue il dispose dei controlli utente particolarmente dispendiosi
Metodo protetto | Dispose(Boolean) | Clean up any resources being used. (Sovrascrive UserControlBaseDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraUserControl)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraUserControl)
Metodo pubblico | EditColumns | Modifica l'editabilità delle colonne e i relativi edit associati.
Metodo pubblico | EraseAllNodes | Tutti i nodi vengono marcati come eliminati. Quelli già eliminati vengono ripristinati
Metodo pubblico | EraseSelectedNode | I nodi selezionati vengono marcati come eliminati. Quelli già eliminati vengono ripristinati.
Metodo pubblico | ExportToExcel | Metodo usato per esportare la distinta su file excel
Metodo pubblico | FireSelectionChanged |
Metodo pubblico | GetActiveBomItem | Restituisce il bomItem dell'elemento selezionato
Metodo pubblico | GetActiveBomItemCollection | Restituisce la bomItem collection dell'elemento selezionato
Metodo pubblico | GetActiveBomItemCollectionNode | Restituisce il nodo relativo alla bomitemcollection attiva in editazione
Metodo pubblico | GetActiveBomItemCollections | Restituisce la bomItem collection degli elementi selezionati
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraUserControl)
Metodo pubblico | GetActiveNode | Restituisce il nodo dell'elemento selezionato
Metodo protetto | GetBackColor | (Ereditato da XtraUserControl)
Metodo protetto | GetBackgroundSkinElement | (Ereditato da XtraUserControl)
Metodo pubblico | GetBicFromNode | Restiruisce il BomItemCollection del nodo passato.
Metodo pubblico | GetDataByRootNode | Restituisce l'anagrafica associata al nodo di testa.
Metodo pubblico | GetDictionaryFromObjectList(BomItem) | Restruisce gil attributi di distinta in un dizionario nome valore (leggendoli dal BomItem).
Metodo pubblico | GetDictionaryFromObjectList(BomItemCollection, DedData) | Restruisce gil attributi di distinta in un dizionario nome valore (leggendoli dall'anagrafica).
Metodo protetto | GetInnerIXtraResizableControl | (Ereditato da XtraUserControl)
Metodo pubblico | GetSelectedBomItems | Restituisce il nodo dell'elemento selezionato
Metodo pubblico | GetSelectedDatas | Restituisce le anagrafiche degli elementi selezionati
Metodo pubblico | GetSelectedNodes | Restituisce i nodi degli elementi selezionati.
Metodo pubblico | GetTree | Ritorna il controllo TreeList
Metodo protetto | IsChildControlsRequiredScalingEnabled | (Ereditato da XtraUserControl)
Metodo pubblico | IsDirty | Ritorna un booleano che stabilisce se la distinta è dirty o meno
Metodo protetto | IsParentHandleCreatedRecursive | (Ereditato da XtraUserControl)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraUserControl)
Metodo protetto | OnBackColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnContextMenuOpening | (Sovrascrive UserControlBaseOnContextMenuOpening(Object, CancelEventArgs))
Metodo protetto | OnControlAdded | (Ereditato da XtraUserControl)
Metodo protetto | OnControlRemoved | (Ereditato da XtraUserControl)
Metodo protetto | OnDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnFirstLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnForeColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleCreated | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraUserControl)
Metodo protetto | OnLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnMenuItemClicked | Evento di pressione di un comando del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnPaintCore | (Ereditato da XtraUserControl)
Metodo protetto | OnParentChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | onSelectionChanged | Metodo che esegue l'evento custom di 'SelectionChanged'.
Metodo protetto | OnSizeChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnUpdateButtonClick | Esegue l'evento custom di 'UpdateButtonClick'.
Metodo protetto | RaisePaintExEvent | (Ereditato da XtraUserControl)
Metodo pubblico | RefreshAttributePane | Aggiorna il pannello degli attributi con i dati del nodo passato
Metodo pubblico | RefreshCompareInfo | Effettua un espansione/collasso del nodo passato per ricalcolare i dati di comparazione
Metodo pubblico | RefreshDist | Permette di aggiornare l'elenco
Metodo pubblico | RefreshHeader | Metodo per effettuare il Refresh dell'header della collection del BomItem passato
Metodo pubblico | ReloadSubDist | Ricaricamento figli del nodo passato. Utile dopo una modifica alla distinta
Metodo pubblico | ResetBackColor | (Ereditato da XtraUserControl)
Metodo pubblico | ResetForeColor | (Ereditato da XtraUserControl)
Metodo pubblico | RestoreAfterXml | Ripristina i Tag delle colonne e l'opzione ShowIndicator
Metodo protetto | RestoreAutoScaleModeChangedByPM2 | (Ereditato da XtraUserControl)
Metodo pubblico | RestoreDist | Evidenzia un nodo dell'albero in base allo stato di comparazione della distinta
Metodo pubblico | RestoreLayoutXml | Metodo usato per caricare la configurazione
Metodo pubblico | ResultBomCompareExp | Ritorna un dizionario contenente gli elementi di distinta e campi di distinta modificati
Metodo pubblico | SaveChanges | Salva le modifiche sulla bom attualmente caricata
Metodo pubblico | SaveRegistrySettings | Salva nel registro le impostazioni dell'albero.
Metodo pubblico | SaveRegistrySettingsExp | Salva nel registro le impostazioni dell'albero usato per il confronto
Metodo protetto | ScaleControl | (Ereditato da XtraUserControl)
Metodo pubblico | SelectBomFirstLevel | Seleziona gli elementi al primo livello di distinta
Metodo pubblico | SelectBomHeader | Seleziona solo l'elemento padre ripulendo la selezione corrente
Metodo pubblico | SetCommandList | Rigenera il menu contestuale di questo controllo con la lista dei comandi passati. (Sovrascrive UserControlBaseSetCommandList(DedCommandList, CommandContextEnum))
Metodo protetto | SetVisibleCore | (Ereditato da XtraUserControl)
Metodo protetto | ShouldPaintTransparentBackground | (Ereditato da XtraUserControl)
Metodo protetto | ShouldUseDirectXPaint | (Ereditato da XtraUserControl)
Metodo pubblico | ShowDist | Metodo per impostare la distinta da visualizzare
Metodo pubblico | ShowDistInfo(String) | Metodo pubblico per la gestione messaggi sulla barra di stato
Metodo pubblico | ShowDistInfo(DistHeader, DedBomExplorerControlDedBomExplorerBehaviourEnum) | Metodo pubblico per la gestione messaggi sulla barra di stato
Metodo pubblico | SubstNode(BomItemCollection, DedData, DedData, DictionaryString, Object) | Sostituisce l'anagrafica con quella passa
Metodo pubblico | SubstNode(BomItemCollection, DedData, DedData, BomItemManEnum, DictionaryString, Object) | Sostituisce l'anagrafica con quella passa
Metodo pubblico | SubstNode(BomItemCollection, DedData, DedData, BomItemManEnum, BomItemManEnum, DictionaryString, Object) | Sostituisce l'anagrafica con quella passa
Metodo pubblico | ToolTipLegend | Crea la legenda utilizzando un SuperToolTip
Metodo pubblico | UnloadDist | Scarica la distinta corrente
Metodo pubblico | UnLock |
Metodo pubblico | UpdateNode | Aggiorna le anagrafiche dei nodi selezionati.
Metodo pubblico | UpdateSelectedNode | Aggiorna le anagrafiche dei nodi selezionati.
Metodo pubblico | UpdateSup | Effettua l'aggiornamento delle revisioni superate sulla collection passata
Metodo protetto | WndProc | (Ereditato da XtraUserControl)
Torna su
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Metodo DedDistControl.AddNode

Metodo DedDistControlAddNode
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AddNode(BomItemCollection, DedData, Double) | Aggiunge l'anagrafica passata alla distinta
Metodo pubblico | AddNode(BomItemCollection, DedDataPart, Double) | Aggiunge l'anagrafica passata alla distinta
Metodo pubblico | AddNode(BomItemCollection, Row, Double) | Aggiunge l'anagrafica passata alla distinta
Metodo pubblico | AddNode(BomItemCollection, DedData, Double, Boolean) | Aggiunge l'anagrafica passata alla distinta
Metodo pubblico | AddNode(BomItemCollection, DedData, Double, Object) | Aggiunge l'anagrafica passata alla distinta
Metodo pubblico | AddNode(BomItemCollection, DedDataPart, Double, Boolean) | Aggiunge l'anagrafica passata alla distinta
Metodo pubblico | AddNode(BomItemCollection, Row, Double, Boolean) | Aggiunge l'anagrafica passata alla distinta
Metodo pubblico | AddNode(BomItemCollection, DedData, Double, Boolean, Object) | Aggiunge l'anagrafica passata alla distinta
Metodo pubblico | AddNode(BomItemCollection, DedDataPart, Double, Boolean, Object) | Aggiunge l'anagrafica passata alla distinta
Torna su
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Metodo DedDistControl.AddNode(BomItemCollection, DedData, Double)

Metodo DedDistControlAddNode(BomItemCollection, DedData, Double)
Aggiunge l'anagrafica passata alla distinta

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItem AddNode(
    BomItemCollection bom,
    DedData anagdata,
    double qta
)
Public Function AddNode (
    bom As BomItemCollection,
    anagdata As DedData,
    qta As Double
) As BomItem
public:
BomItem^ AddNode(
    BomItemCollection^ bom,
    DedData^ anagdata,
    double qta
)
member AddNode :
        bom : BomItemCollection *
        anagdata : DedData *
        qta : float -> BomItem

Parametri

bom BomItemCollection
anagdata DedData
qta Double

Valore di ritorno

BomItem
Vedi anche

Documentazione

Classe DedDistControl
Overload di AddNode
Namespace DedNet.Controls


Metodo DedDistControl.AddNode(BomItemCollection, DedDataPart, Double)

Metodo DedDistControlAddNode(BomItemCollection, DedDataPart, Double)
Aggiunge l'anagrafica passata alla distinta

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItem AddNode(
    BomItemCollection bom,
    DedDataPart item,
    double qta
)
Public Function AddNode (
    bom As BomItemCollection,
    item As DedDataPart,
    qta As Double
) As BomItem
public:
BomItem^ AddNode(
    BomItemCollection^ bom,
    DedDataPart^ item,
    double qta
)
member AddNode :
        bom : BomItemCollection *
        item : DedDataPart *
        qta : float -> BomItem

Parametri

bom BomItemCollection
Distinta di arrivo.
item DedDataPart
Anagrafica da aggiungere.
qta Double
Quantità.

Valore di ritorno

BomItem
Vedi anche

Documentazione

Classe DedDistControl
Overload di AddNode
Namespace DedNet.Controls


Metodo DedDistControl.AddNode(BomItemCollection, InitPrtFast.Row, Double)

Metodo DedDistControlAddNode(BomItemCollection, InitPrtFastRow, Double)
Aggiunge l'anagrafica passata alla distinta

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItem AddNode(
    BomItemCollection bom,
    Row item,
    double qta
)
Public Function AddNode (
    bom As BomItemCollection,
    item As Row,
    qta As Double
) As BomItem
public:
BomItem^ AddNode(
    BomItemCollection^ bom,
    Row^ item,
    double qta
)
member AddNode :
        bom : BomItemCollection *
        item : Row *
        qta : float -> BomItem

Parametri

bom BomItemCollection
item Row
qta Double

Valore di ritorno

BomItem
Vedi anche

Documentazione

Classe DedDistControl
Overload di AddNode
Namespace DedNet.Controls


Metodo DedDistControl.AddNode(BomItemCollection, DedData, Double, Boolean)

Metodo DedDistControlAddNode(BomItemCollection, DedData, Double, Boolean)
Aggiunge l'anagrafica passata alla distinta

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItem AddNode(
    BomItemCollection bom,
    DedData anagdata,
    double qta,
    bool reloadList
)
Public Function AddNode (
    bom As BomItemCollection,
    anagdata As DedData,
    qta As Double,
    reloadList As Boolean
) As BomItem
public:
BomItem^ AddNode(
    BomItemCollection^ bom,
    DedData^ anagdata,
    double qta,
    bool reloadList
)
member AddNode :
        bom : BomItemCollection *
        anagdata : DedData *
        qta : float *
        reloadList : bool -> BomItem

Parametri

bom BomItemCollection
anagdata DedData
qta Double
reloadList Boolean

Valore di ritorno

BomItem
Vedi anche

Documentazione

Classe DedDistControl
Overload di AddNode
Namespace DedNet.Controls


Metodo DedDistControl.AddNode(BomItemCollection, DedData, Double, Object[])

Metodo DedDistControlAddNode(BomItemCollection, DedData, Double, Object)
Aggiunge l'anagrafica passata alla distinta

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItem AddNode(
    BomItemCollection bom,
    DedData anagdata,
    double qta,
    Object[] distValues
)
Public Function AddNode (
    bom As BomItemCollection,
    anagdata As DedData,
    qta As Double,
    distValues As Object()
) As BomItem
public:
BomItem^ AddNode(
    BomItemCollection^ bom,
    DedData^ anagdata,
    double qta,
    array<Object^>^ distValues
)
member AddNode :
        bom : BomItemCollection *
        anagdata : DedData *
        qta : float *
        distValues : Object[] -> BomItem

Parametri

bom BomItemCollection
anagdata DedData
qta Double
distValues Object

Valore di ritorno

BomItem
Vedi anche

Documentazione

Classe DedDistControl
Overload di AddNode
Namespace DedNet.Controls


Metodo DedDistControl.AddNode(BomItemCollection, DedDataPart, Double, Boolean)

Metodo DedDistControlAddNode(BomItemCollection, DedDataPart, Double, Boolean)
Aggiunge l'anagrafica passata alla distinta

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItem AddNode(
    BomItemCollection bom,
    DedDataPart item,
    double qta,
    bool reloadList
)
Public Function AddNode (
    bom As BomItemCollection,
    item As DedDataPart,
    qta As Double,
    reloadList As Boolean
) As BomItem
public:
BomItem^ AddNode(
    BomItemCollection^ bom,
    DedDataPart^ item,
    double qta,
    bool reloadList
)
member AddNode :
        bom : BomItemCollection *
        item : DedDataPart *
        qta : float *
        reloadList : bool -> BomItem

Parametri

bom BomItemCollection
Distinta di arrivo.
item DedDataPart
Anagrafica da aggiungere.
qta Double
Quantità.
reloadList Boolean
Indica se effettuare il refresh della distinta.

Valore di ritorno

BomItem
Vedi anche

Documentazione

Classe DedDistControl
Overload di AddNode
Namespace DedNet.Controls


Metodo DedDistControl.AddNode(BomItemCollection, InitPrtFast.Row, Double, Boolean)

Metodo DedDistControlAddNode(BomItemCollection, InitPrtFastRow, Double, Boolean)
Aggiunge l'anagrafica passata alla distinta

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItem AddNode(
    BomItemCollection bom,
    Row item,
    double qta,
    bool reloadList
)
Public Function AddNode (
    bom As BomItemCollection,
    item As Row,
    qta As Double,
    reloadList As Boolean
) As BomItem
public:
BomItem^ AddNode(
    BomItemCollection^ bom,
    Row^ item,
    double qta,
    bool reloadList
)
member AddNode :
        bom : BomItemCollection *
        item : Row *
        qta : float *
        reloadList : bool -> BomItem

Parametri

bom BomItemCollection
item Row
qta Double
reloadList Boolean

Valore di ritorno

BomItem
Vedi anche

Documentazione

Classe DedDistControl
Overload di AddNode
Namespace DedNet.Controls


Metodo DedDistControl.AddNode(BomItemCollection, DedData, Double, Boolean, Object[])

Metodo DedDistControlAddNode(BomItemCollection, DedData, Double, Boolean, Object)
Aggiunge l'anagrafica passata alla distinta

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItem AddNode(
    BomItemCollection bom,
    DedData anagdata,
    double qta,
    bool reloadList,
    Object[] distValues
)
Public Function AddNode (
    bom As BomItemCollection,
    anagdata As DedData,
    qta As Double,
    reloadList As Boolean,
    distValues As Object()
) As BomItem
public:
BomItem^ AddNode(
    BomItemCollection^ bom,
    DedData^ anagdata,
    double qta,
    bool reloadList,
    array<Object^>^ distValues
)
member AddNode :
        bom : BomItemCollection *
        anagdata : DedData *
        qta : float *
        reloadList : bool *
        distValues : Object[] -> BomItem

Parametri

bom BomItemCollection
anagdata DedData
qta Double
reloadList Boolean
distValues Object

Valore di ritorno

BomItem
Vedi anche

Documentazione

Classe DedDistControl
Overload di AddNode
Namespace DedNet.Controls


Metodo DedDistControl.AddNode(BomItemCollection, DedDataPart, Double, Boolean, Object[])

Metodo DedDistControlAddNode(BomItemCollection, DedDataPart, Double, Boolean, Object)
Aggiunge l'anagrafica passata alla distinta

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItem AddNode(
    BomItemCollection bom,
    DedDataPart item,
    double qta,
    bool reloadList,
    Object[] distValues
)
Public Function AddNode (
    bom As BomItemCollection,
    item As DedDataPart,
    qta As Double,
    reloadList As Boolean,
    distValues As Object()
) As BomItem
public:
BomItem^ AddNode(
    BomItemCollection^ bom,
    DedDataPart^ item,
    double qta,
    bool reloadList,
    array<Object^>^ distValues
)
member AddNode :
        bom : BomItemCollection *
        item : DedDataPart *
        qta : float *
        reloadList : bool *
        distValues : Object[] -> BomItem

Parametri

bom BomItemCollection
Distinta di arrivo.
item DedDataPart
Anagrafica da aggiungere.
qta Double
Quantità.
reloadList Boolean
Indica se effettuare il refresh della distinta.
distValues Object
Valori attributi di distinta.

Valore di ritorno

BomItem
Vedi anche

Documentazione

Classe DedDistControl
Overload di AddNode
Namespace DedNet.Controls


Metodo DedDistControl.CompareDist

Metodo DedDistControlCompareDist
Compara i due header passati e compila i dizionari usati per evidenziare i nodi nell'albero in base allo stato di comparazione della distinta

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void CompareDist(
    TreeListNode nodeSx,
    TreeListNode nodeDx,
    BomItemComparer bic,
    bool resetCache = true
)
Public Sub CompareDist (
    nodeSx As TreeListNode,
    nodeDx As TreeListNode,
    bic As BomItemComparer,
    Optional resetCache As Boolean = true
)
public:
void CompareDist(
    TreeListNode^ nodeSx,
    TreeListNode^ nodeDx,
    BomItemComparer^ bic,
    bool resetCache = true
)
member CompareDist :
        nodeSx : TreeListNode *
        nodeDx : TreeListNode *
        bic : BomItemComparer *
        ?resetCache : bool
(* Defaults:
        let _resetCache = defaultArg resetCache true
*)
-> unit

Parametri

nodeSx TreeListNode
nodeDx TreeListNode
bic BomItemComparer
resetCache Boolean (Optional)
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Metodo DedDistControl.CompareDistExp

Metodo DedDistControlCompareDistExp
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | CompareDistExp(BomItemCollection, BomItemCollection, BomItemCollection, Boolean) | Effettua la comparazione e salva le informazioni nei BomItem
Metodo pubblico | CompareDistExp(DistHeader, DistHeader, BomItemCollection, Boolean) | Effettua la comparazione e salva le informazioni nei BomItem
Torna su
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Metodo DedDistControl.CompareDistExp(BomItemCollection, BomItemCollection, BomItemCollection, Boolean)

Metodo DedDistControlCompareDistExp(BomItemCollection, BomItemCollection, BomItemCollection, Boolean)
Effettua la comparazione e salva le informazioni nei BomItem

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void CompareDistExp(
    BomItemCollection bicSx,
    BomItemCollection bicDx,
    ref BomItemCollection bomExp,
    bool resetCache = true
)
Public Sub CompareDistExp (
    bicSx As BomItemCollection,
    bicDx As BomItemCollection,
    ByRef bomExp As BomItemCollection,
    Optional resetCache As Boolean = true
)
public:
void CompareDistExp(
    BomItemCollection^ bicSx,
    BomItemCollection^ bicDx,
    BomItemCollection^% bomExp,
    bool resetCache = true
)
member CompareDistExp :
        bicSx : BomItemCollection *
        bicDx : BomItemCollection *
        bomExp : BomItemCollection byref *
        ?resetCache : bool
(* Defaults:
        let _resetCache = defaultArg resetCache true
*)
-> unit

Parametri

bicSx BomItemCollection
bicDx BomItemCollection
bomExp BomItemCollection
resetCache Boolean (Optional)
Vedi anche

Documentazione

Classe DedDistControl
Overload di CompareDistExp
Namespace DedNet.Controls


Metodo DedDistControl.CompareDistExp(DistHeader, DistHeader, BomItemCollection, Boolean)

Metodo DedDistControlCompareDistExp(DistHeader, DistHeader, BomItemCollection, Boolean)
Effettua la comparazione e salva le informazioni nei BomItem

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void CompareDistExp(
    DistHeader hdSx,
    DistHeader hdDx,
    ref BomItemCollection bomExp,
    bool resetCache = true
)
Public Sub CompareDistExp (
    hdSx As DistHeader,
    hdDx As DistHeader,
    ByRef bomExp As BomItemCollection,
    Optional resetCache As Boolean = true
)
public:
void CompareDistExp(
    DistHeader^ hdSx,
    DistHeader^ hdDx,
    BomItemCollection^% bomExp,
    bool resetCache = true
)
member CompareDistExp :
        hdSx : DistHeader *
        hdDx : DistHeader *
        bomExp : BomItemCollection byref *
        ?resetCache : bool
(* Defaults:
        let _resetCache = defaultArg resetCache true
*)
-> unit

Parametri

hdSx DistHeader
hdDx DistHeader
bomExp BomItemCollection
resetCache Boolean (Optional)
Vedi anche

Documentazione

Classe DedDistControl
Overload di CompareDistExp
Namespace DedNet.Controls


Metodo DedDistControl.CompareDistExport

Metodo DedDistControlCompareDistExport
Effettua la comparazione (usato da DEDAPI)

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void CompareDistExport(
    DistHeader hdSx,
    DistHeader hdDx
)
Public Sub CompareDistExport (
    hdSx As DistHeader,
    hdDx As DistHeader
)
public:
void CompareDistExport(
    DistHeader^ hdSx,
    DistHeader^ hdDx
)
member CompareDistExport :
        hdSx : DistHeader *
        hdDx : DistHeader -> unit

Parametri

hdSx DistHeader
hdDx DistHeader
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Metodo DedDistControl.DiscardChanges

Metodo DedDistControlDiscardChanges
Annualla le modifiche apportate dal controllo di distinta

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void DiscardChanges()
Public Sub DiscardChanges
public:
void DiscardChanges()
member DiscardChanges : unit -> unit
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Metodo DedDistControl.Dispose

Metodo DedDistControlDispose
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Dispose | Esegue il dispose dei controlli utente particolarmente dispendiosi
Metodo protetto | Dispose(Boolean) | Clean up any resources being used.
Torna su
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Metodo DedDistControl.Dispose

Metodo DedDistControlDispose
Esegue il dispose dei controlli utente particolarmente dispendiosi

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
void Dispose()
member Dispose : unit -> unit
Vedi anche

Documentazione

Classe DedDistControl
Overload di Dispose
Namespace DedNet.Controls


Metodo DedDistControl.Dispose(Boolean)

Metodo DedDistControlDispose(Boolean)
Clean up any resources being used.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedDistControl
Overload di Dispose
Namespace DedNet.Controls


Metodo DedDistControl.EditColumns

Metodo DedDistControlEditColumns
Modifica l'editabilità delle colonne e i relativi edit associati.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void EditColumns()
Public Sub EditColumns
public:
void EditColumns()
member EditColumns : unit -> unit
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Metodo DedDistControl.EraseAllNodes

Metodo DedDistControlEraseAllNodes
Tutti i nodi vengono marcati come eliminati. Quelli già eliminati vengono ripristinati

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void EraseAllNodes()
Public Sub EraseAllNodes
public:
void EraseAllNodes()
member EraseAllNodes : unit -> unit
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Metodo DedDistControl.EraseSelectedNode

Metodo DedDistControlEraseSelectedNode
I nodi selezionati vengono marcati come eliminati. Quelli già eliminati vengono ripristinati.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void EraseSelectedNode()
Public Sub EraseSelectedNode
public:
void EraseSelectedNode()
member EraseSelectedNode : unit -> unit
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Metodo DedDistControl.ExportToExcel

Metodo DedDistControlExportToExcel
Metodo usato per esportare la distinta su file excel

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ExportToExcel(
    string file
)
Public Sub ExportToExcel (
    file As String
)
public:
void ExportToExcel(
    String^ file
)
member ExportToExcel :
        file : string -> unit

Parametri

file String
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Metodo DedDistControl.FireSelectionChanged

Metodo DedDistControlFireSelectionChanged

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void FireSelectionChanged()
Public Sub FireSelectionChanged
public:
void FireSelectionChanged()
member FireSelectionChanged : unit -> unit
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Metodo DedDistControl.GetActiveBomItem

Metodo DedDistControlGetActiveBomItem
Restituisce il bomItem dell'elemento selezionato

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItem GetActiveBomItem()
Public Function GetActiveBomItem As BomItem
public:
BomItem^ GetActiveBomItem()
member GetActiveBomItem : unit -> BomItem

Valore di ritorno

BomItem
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Metodo DedDistControl.GetActiveBomItemCollection

Metodo DedDistControlGetActiveBomItemCollection
Restituisce la bomItem collection dell'elemento selezionato

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItemCollection GetActiveBomItemCollection()
Public Function GetActiveBomItemCollection As BomItemCollection
public:
BomItemCollection^ GetActiveBomItemCollection()
member GetActiveBomItemCollection : unit -> BomItemCollection

Valore di ritorno

BomItemCollection
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Metodo DedDistControl.GetActiveBomItemCollectionNode

Metodo DedDistControlGetActiveBomItemCollectionNode
Restituisce il nodo relativo alla bomitemcollection attiva in editazione

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public TreeListNode GetActiveBomItemCollectionNode()
Public Function GetActiveBomItemCollectionNode As TreeListNode
public:
TreeListNode^ GetActiveBomItemCollectionNode()
member GetActiveBomItemCollectionNode : unit -> TreeListNode

Valore di ritorno

TreeListNode
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Metodo DedDistControl.GetActiveBomItemCollections

Metodo DedDistControlGetActiveBomItemCollections
Restituisce la bomItem collection degli elementi selezionati

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<BomItemCollection> GetActiveBomItemCollections()
Public Function GetActiveBomItemCollections As List(Of BomItemCollection)
public:
List<BomItemCollection^>^ GetActiveBomItemCollections()
member GetActiveBomItemCollections : unit -> List<BomItemCollection>

Valore di ritorno

List BomItemCollection
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Metodo DedDistControl.GetActiveNode

Metodo DedDistControlGetActiveNode
Restituisce il nodo dell'elemento selezionato

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public TreeListNode GetActiveNode()
Public Function GetActiveNode As TreeListNode
public:
TreeListNode^ GetActiveNode()
member GetActiveNode : unit -> TreeListNode

Valore di ritorno

TreeListNode
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Metodo DedDistControl.GetBicFromNode

Metodo DedDistControlGetBicFromNode
Restiruisce il BomItemCollection del nodo passato.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItemCollection GetBicFromNode(
    TreeListNode node
)
Public Function GetBicFromNode (
    node As TreeListNode
) As BomItemCollection
public:
BomItemCollection^ GetBicFromNode(
    TreeListNode^ node
)
member GetBicFromNode :
        node : TreeListNode -> BomItemCollection

Parametri

node TreeListNode

Valore di ritorno

BomItemCollection
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Metodo DedDistControl.GetDataByRootNode

Metodo DedDistControlGetDataByRootNode
Restituisce l'anagrafica associata al nodo di testa.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData GetDataByRootNode()
Public Function GetDataByRootNode As DedData
public:
DedData^ GetDataByRootNode()
member GetDataByRootNode : unit -> DedData

Valore di ritorno

DedData
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Metodo DedDistControl.GetDictionaryFromObjectList

Metodo DedDistControlGetDictionaryFromObjectList
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | GetDictionaryFromObjectList(BomItem) | Restruisce gil attributi di distinta in un dizionario nome valore (leggendoli dal BomItem).
Metodo pubblico | GetDictionaryFromObjectList(BomItemCollection, DedData) | Restruisce gil attributi di distinta in un dizionario nome valore (leggendoli dall'anagrafica).
Torna su
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Metodo DedDistControl.GetDictionaryFromObjectList(BomItem)

Metodo DedDistControlGetDictionaryFromObjectList(BomItem)
Restruisce gil attributi di distinta in un dizionario nome valore (leggendoli dal BomItem).

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<string, Object> GetDictionaryFromObjectList(
    BomItem item
)
Public Function GetDictionaryFromObjectList (
    item As BomItem
) As Dictionary(Of String, Object)
public:
Dictionary<String^, Object^>^ GetDictionaryFromObjectList(
    BomItem^ item
)
member GetDictionaryFromObjectList :
        item : BomItem -> Dictionary<string, Object>

Parametri

item BomItem
Elemento del quale copiare i valori degli attributi di distinta in una dizionario

Valore di ritorno

Dictionary String, Object
Vedi anche

Documentazione

Classe DedDistControl
Overload di GetDictionaryFromObjectList
Namespace DedNet.Controls


Metodo DedDistControl.GetDictionaryFromObjectList(BomItemCollection, DedData)

Metodo DedDistControlGetDictionaryFromObjectList(BomItemCollection, DedData)
Restruisce gil attributi di distinta in un dizionario nome valore (leggendoli dall'anagrafica).

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<string, Object> GetDictionaryFromObjectList(
    BomItemCollection bic,
    DedData anagr
)
Public Function GetDictionaryFromObjectList (
    bic As BomItemCollection,
    anagr As DedData
) As Dictionary(Of String, Object)
public:
Dictionary<String^, Object^>^ GetDictionaryFromObjectList(
    BomItemCollection^ bic,
    DedData^ anagr
)
member GetDictionaryFromObjectList :
        bic : BomItemCollection *
        anagr : DedData -> Dictionary<string, Object>

Parametri

bic BomItemCollection
BomItemCollection dove andare a prendere il DistManager
anagr DedData
Anagrafica dove andiamo a leggare i valori degli attributi di distinta

Valore di ritorno

Dictionary String, Object
Vedi anche

Documentazione

Classe DedDistControl
Overload di GetDictionaryFromObjectList
Namespace DedNet.Controls


Metodo DedDistControl.GetSelectedBomItems

Metodo DedDistControlGetSelectedBomItems
Restituisce il nodo dell'elemento selezionato

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<BomItem> GetSelectedBomItems()
Public Function GetSelectedBomItems As List(Of BomItem)
public:
List<BomItem^>^ GetSelectedBomItems()
member GetSelectedBomItems : unit -> List<BomItem>

Valore di ritorno

List BomItem
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Metodo DedDistControl.GetSelectedDatas

Metodo DedDistControlGetSelectedDatas
Restituisce le anagrafiche degli elementi selezionati

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataList GetSelectedDatas()
Public Function GetSelectedDatas As DedDataList
public:
DedDataList^ GetSelectedDatas()
member GetSelectedDatas : unit -> DedDataList

Valore di ritorno

DedDataList
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Metodo DedDistControl.GetSelectedNodes

Metodo DedDistControlGetSelectedNodes
Restituisce i nodi degli elementi selezionati.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<TreeListNode> GetSelectedNodes()
Public Function GetSelectedNodes As List(Of TreeListNode)
public:
List<TreeListNode^>^ GetSelectedNodes()
member GetSelectedNodes : unit -> List<TreeListNode>

Valore di ritorno

List TreeListNode
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Metodo DedDistControl.GetTree

Metodo DedDistControlGetTree
Ritorna il controllo TreeList

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public MyTreeListBom GetTree()
Public Function GetTree As MyTreeListBom
public:
MyTreeListBom^ GetTree()
member GetTree : unit -> MyTreeListBom

Valore di ritorno

MyTreeListBom
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Metodo DedDistControl.IsDirty

Metodo DedDistControlIsDirty
Ritorna un booleano che stabilisce se la distinta è dirty o meno

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsDirty()
Public Function IsDirty As Boolean
public:
bool IsDirty()
member IsDirty : unit -> bool

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Metodo DedDistControl.OnContextMenuOpening

Metodo DedDistControlOnContextMenuOpening

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void OnContextMenuOpening(
    Object sender,
    CancelEventArgs e
)
Protected Overrides Sub OnContextMenuOpening (
    sender As Object,
    e As CancelEventArgs
)
protected:
virtual void OnContextMenuOpening(
    Object^ sender,
    CancelEventArgs^ e
) override
abstract OnContextMenuOpening :
        sender : Object *
        e : CancelEventArgs -> unit
override OnContextMenuOpening :
        sender : Object *
        e : CancelEventArgs -> unit

Parametri

sender Object
e CancelEventArgs
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Metodo DedDistControl.onSelectionChanged

Metodo DedDistControlonSelectionChanged
Metodo che esegue l'evento custom di 'SelectionChanged'.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected void onSelectionChanged(
    Object sender,
    DedDistControlDedBomEventArgs e
)
Protected Sub onSelectionChanged (
    sender As Object,
    e As DedDistControlDedBomEventArgs
)
protected:
void onSelectionChanged(
    Object^ sender,
    DedDistControlDedBomEventArgs^ e
)
member onSelectionChanged :
        sender : Object *
        e : DedDistControlDedBomEventArgs -> unit

Parametri

sender Object
e DedDistControlDedBomEventArgs
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Metodo DedDistControl.OnUpdateButtonClick

Metodo DedDistControlOnUpdateButtonClick
Esegue l'evento custom di 'UpdateButtonClick'.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected void OnUpdateButtonClick(
    Object sender,
    EventArgs e
)
Protected Sub OnUpdateButtonClick (
    sender As Object,
    e As EventArgs
)
protected:
void OnUpdateButtonClick(
    Object^ sender,
    EventArgs^ e
)
member OnUpdateButtonClick :
        sender : Object *
        e : EventArgs -> unit

Parametri

sender Object
e EventArgs
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Metodo DedDistControl.RefreshAttributePane

Metodo DedDistControlRefreshAttributePane
Aggiorna il pannello degli attributi con i dati del nodo passato

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void RefreshAttributePane()
Public Sub RefreshAttributePane
public:
void RefreshAttributePane()
member RefreshAttributePane : unit -> unit
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Metodo DedDistControl.RefreshCompareInfo

Metodo DedDistControlRefreshCompareInfo
Effettua un espansione/collasso del nodo passato per ricalcolare i dati di comparazione

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void RefreshCompareInfo(
    TreeListNode node
)
Public Sub RefreshCompareInfo (
    node As TreeListNode
)
public:
void RefreshCompareInfo(
    TreeListNode^ node
)
member RefreshCompareInfo :
        node : TreeListNode -> unit

Parametri

node TreeListNode
Nodo da aggiornare
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Metodo DedDistControl.RefreshDist

Metodo DedDistControlRefreshDist
Permette di aggiornare l'elenco

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void RefreshDist()
Public Sub RefreshDist
public:
void RefreshDist()
member RefreshDist : unit -> unit
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Metodo DedDistControl.RefreshHeader

Metodo DedDistControlRefreshHeader
Metodo per effettuare il Refresh dell'header della collection del BomItem passato

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void RefreshHeader(
    TreeListNode node
)
Public Sub RefreshHeader (
    node As TreeListNode
)
public:
void RefreshHeader(
    TreeListNode^ node
)
member RefreshHeader :
        node : TreeListNode -> unit

Parametri

node TreeListNode
Nodo del quale aggiornare l'header la collezione
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Metodo DedDistControl.ReloadSubDist

Metodo DedDistControlReloadSubDist
Ricaricamento figli del nodo passato. Utile dopo una modifica alla distinta

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ReloadSubDist(
    TreeListNode node
)
Public Sub ReloadSubDist (
    node As TreeListNode
)
public:
void ReloadSubDist(
    TreeListNode^ node
)
member ReloadSubDist :
        node : TreeListNode -> unit

Parametri

node TreeListNode
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Metodo DedDistControl.RestoreAfterXml

Metodo DedDistControlRestoreAfterXml
Ripristina i Tag delle colonne e l'opzione ShowIndicator

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void RestoreAfterXml()
Public Sub RestoreAfterXml
public:
void RestoreAfterXml()
member RestoreAfterXml : unit -> unit
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Metodo DedDistControl.RestoreDist

Metodo DedDistControlRestoreDist
Evidenzia un nodo dell'albero in base allo stato di comparazione della distinta

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void RestoreDist()
Public Sub RestoreDist
public:
void RestoreDist()
member RestoreDist : unit -> unit
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Metodo DedDistControl.RestoreLayoutXml

Metodo DedDistControlRestoreLayoutXml
Metodo usato per caricare la configurazione

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool RestoreLayoutXml()
Public Function RestoreLayoutXml As Boolean
public:
bool RestoreLayoutXml()
member RestoreLayoutXml : unit -> bool

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Metodo DedDistControl.ResultBomCompareExp

Metodo DedDistControlResultBomCompareExp
Ritorna un dizionario contenente gli elementi di distinta e campi di distinta modificati

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<BomItem, Dictionary<string, Object>> ResultBomCompareExp()
Public Function ResultBomCompareExp As Dictionary(Of BomItem, Dictionary(Of String, Object))
public:
Dictionary<BomItem^, Dictionary<String^, Object^>^>^ ResultBomCompareExp()
member ResultBomCompareExp : unit -> Dictionary<BomItem, Dictionary<string, Object>>

Valore di ritorno

Dictionary BomItem, Dictionary String, Object
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Metodo DedDistControl.SaveChanges

Metodo DedDistControlSaveChanges
Salva le modifiche sulla bom attualmente caricata

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SaveChanges()
Public Sub SaveChanges
public:
void SaveChanges()
member SaveChanges : unit -> unit
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Metodo DedDistControl.SaveRegistrySettings

Metodo DedDistControlSaveRegistrySettings
Salva nel registro le impostazioni dell'albero.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SaveRegistrySettings()
Public Sub SaveRegistrySettings
public:
void SaveRegistrySettings()
member SaveRegistrySettings : unit -> unit
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Metodo DedDistControl.SaveRegistrySettingsExp

Metodo DedDistControlSaveRegistrySettingsExp
Salva nel registro le impostazioni dell'albero usato per il confronto

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SaveRegistrySettingsExp()
Public Sub SaveRegistrySettingsExp
public:
void SaveRegistrySettingsExp()
member SaveRegistrySettingsExp : unit -> unit
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Metodo DedDistControl.SelectBomFirstLevel

Metodo DedDistControlSelectBomFirstLevel
Seleziona gli elementi al primo livello di distinta

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SelectBomFirstLevel()
Public Sub SelectBomFirstLevel
public:
void SelectBomFirstLevel()
member SelectBomFirstLevel : unit -> unit
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Metodo DedDistControl.SelectBomHeader

Metodo DedDistControlSelectBomHeader
Seleziona solo l'elemento padre ripulendo la selezione corrente

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SelectBomHeader()
Public Sub SelectBomHeader
public:
void SelectBomHeader()
member SelectBomHeader : unit -> unit
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Metodo DedDistControl.SetCommandList

Metodo DedDistControlSetCommandList
Rigenera il menu contestuale di questo controllo con la lista dei comandi passati.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void SetCommandList(
    DedCommandList commandList,
    CommandContextEnum commandContext
)
Public Overrides Sub SetCommandList (
    commandList As DedCommandList,
    commandContext As CommandContextEnum
)
public:
virtual void SetCommandList(
    DedCommandList^ commandList,
    CommandContextEnum commandContext
) override
abstract SetCommandList :
        commandList : DedCommandList *
        commandContext : CommandContextEnum -> unit
override SetCommandList :
        commandList : DedCommandList *
        commandContext : CommandContextEnum -> unit

Parametri

commandList DedCommandList
Lista completa dei comandi.
commandContext CommandContextEnum
Contesto da utilizzare per filtrare i comandi da inserire.
Note
Filtra i comandi in modo da aggiungere soltanto quelli coerenti con il contesto passato.
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Metodo DedDistControl.ShowDist

Metodo DedDistControlShowDist
Metodo per impostare la distinta da visualizzare

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ShowDist(
    BomItemCollection bom
)
Public Sub ShowDist (
    bom As BomItemCollection
)
public:
void ShowDist(
    BomItemCollection^ bom
)
member ShowDist :
        bom : BomItemCollection -> unit

Parametri

bom BomItemCollection
BomItemCollection della distinta da visualizzare
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Metodo DedDistControl.ShowDistInfo

Metodo DedDistControlShowDistInfo
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | ShowDistInfo(String) | Metodo pubblico per la gestione messaggi sulla barra di stato
Metodo pubblico | ShowDistInfo(DistHeader, DedBomExplorerControlDedBomExplorerBehaviourEnum) | Metodo pubblico per la gestione messaggi sulla barra di stato
Torna su
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Metodo DedDistControl.ShowDistInfo(String)

Metodo DedDistControlShowDistInfo(String)
Metodo pubblico per la gestione messaggi sulla barra di stato

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ShowDistInfo(
    string strMsg
)
Public Sub ShowDistInfo (
    strMsg As String
)
public:
void ShowDistInfo(
    String^ strMsg
)
member ShowDistInfo :
        strMsg : string -> unit

Parametri

strMsg String
Stringa da inserire nel controllo
Vedi anche

Documentazione

Classe DedDistControl
Overload di ShowDistInfo
Namespace DedNet.Controls


Metodo DedDistControl.ShowDistInfo(DistHeader, DedBomExplorerControl.DedBomExplorerBehaviourEnum)

Metodo DedDistControlShowDistInfo(DistHeader, DedBomExplorerControlDedBomExplorerBehaviourEnum)
Metodo pubblico per la gestione messaggi sulla barra di stato

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ShowDistInfo(
    DistHeader header,
    DedBomExplorerControlDedBomExplorerBehaviourEnum behaviour
)
Public Sub ShowDistInfo (
    header As DistHeader,
    behaviour As DedBomExplorerControlDedBomExplorerBehaviourEnum
)
public:
void ShowDistInfo(
    DistHeader^ header,
    DedBomExplorerControlDedBomExplorerBehaviourEnum behaviour
)
member ShowDistInfo :
        header : DistHeader *
        behaviour : DedBomExplorerControlDedBomExplorerBehaviourEnum -> unit

Parametri

header DistHeader
behaviour DedBomExplorerControlDedBomExplorerBehaviourEnum
Vedi anche

Documentazione

Classe DedDistControl
Overload di ShowDistInfo
Namespace DedNet.Controls


Metodo DedDistControl.SubstNode

Metodo DedDistControlSubstNode
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | SubstNode(BomItemCollection, DedData, DedData, DictionaryString, Object) | Sostituisce l'anagrafica con quella passa
Metodo pubblico | SubstNode(BomItemCollection, DedData, DedData, BomItemManEnum, DictionaryString, Object) | Sostituisce l'anagrafica con quella passa
Metodo pubblico | SubstNode(BomItemCollection, DedData, DedData, BomItemManEnum, BomItemManEnum, DictionaryString, Object) | Sostituisce l'anagrafica con quella passa
Torna su
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Metodo DedDistControl.SubstNode(BomItemCollection, DedData, DedData, Dictionary<String, Object>)

Metodo DedDistControlSubstNode(BomItemCollection, DedData, DedData, DictionaryString, Object)
Sostituisce l'anagrafica con quella passa

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<BomItem> SubstNode(
    BomItemCollection bom,
    DedData origData,
    DedData newData,
    Dictionary<string, Object> searchDiscrimValues
)
Public Function SubstNode (
    bom As BomItemCollection,
    origData As DedData,
    newData As DedData,
    searchDiscrimValues As Dictionary(Of String, Object)
) As List(Of BomItem)
public:
List<BomItem^>^ SubstNode(
    BomItemCollection^ bom,
    DedData^ origData,
    DedData^ newData,
    Dictionary<String^, Object^>^ searchDiscrimValues
)
member SubstNode :
        bom : BomItemCollection *
        origData : DedData *
        newData : DedData *
        searchDiscrimValues : Dictionary<string, Object> -> List<BomItem>

Parametri

bom BomItemCollection
origData DedData
Anagrafica da sostituire
newData DedData
Anagrafica sostituta
searchDiscrimValues Dictionary String, Object
Valori di distinta discriminati per la sostituzione

Valore di ritorno

List BomItem
Vedi anche

Documentazione

Classe DedDistControl
Overload di SubstNode
Namespace DedNet.Controls


Metodo DedDistControl.SubstNode(BomItemCollection, DedData, DedData, BomItemManEnum, Dictionary<String, Object>)

Metodo DedDistControlSubstNode(BomItemCollection, DedData, DedData, BomItemManEnum, DictionaryString, Object)
Sostituisce l'anagrafica con quella passa

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<BomItem> SubstNode(
    BomItemCollection bom,
    DedData origData,
    DedData newData,
    BomItemManEnum destman,
    Dictionary<string, Object> searchDiscrimValues
)
Public Function SubstNode (
    bom As BomItemCollection,
    origData As DedData,
    newData As DedData,
    destman As BomItemManEnum,
    searchDiscrimValues As Dictionary(Of String, Object)
) As List(Of BomItem)
public:
List<BomItem^>^ SubstNode(
    BomItemCollection^ bom,
    DedData^ origData,
    DedData^ newData,
    BomItemManEnum destman,
    Dictionary<String^, Object^>^ searchDiscrimValues
)
member SubstNode :
        bom : BomItemCollection *
        origData : DedData *
        newData : DedData *
        destman : BomItemManEnum *
        searchDiscrimValues : Dictionary<string, Object> -> List<BomItem>

Parametri

bom BomItemCollection
origData DedData
Anagrafica da sostituire
newData DedData
Anagrafica sostituta
destman BomItemManEnum
Man da assegnare al nuovo elemento
searchDiscrimValues Dictionary String, Object
Valori di distinta discriminati per la sostituzione

Valore di ritorno

List BomItem
Vedi anche

Documentazione

Classe DedDistControl
Overload di SubstNode
Namespace DedNet.Controls


Metodo DedDistControl.SubstNode(BomItemCollection, DedData, DedData, BomItemManEnum, BomItemManEnum, Dictionary<String, Object>)

Metodo DedDistControlSubstNode(BomItemCollection, DedData, DedData, BomItemManEnum, BomItemManEnum, DictionaryString, Object)
Sostituisce l'anagrafica con quella passa

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<BomItem> SubstNode(
    BomItemCollection bom,
    DedData origData,
    DedData newData,
    BomItemManEnum destman,
    BomItemManEnum discrimman,
    Dictionary<string, Object> searchDiscrimValues
)
Public Function SubstNode (
    bom As BomItemCollection,
    origData As DedData,
    newData As DedData,
    destman As BomItemManEnum,
    discrimman As BomItemManEnum,
    searchDiscrimValues As Dictionary(Of String, Object)
) As List(Of BomItem)
public:
List<BomItem^>^ SubstNode(
    BomItemCollection^ bom,
    DedData^ origData,
    DedData^ newData,
    BomItemManEnum destman,
    BomItemManEnum discrimman,
    Dictionary<String^, Object^>^ searchDiscrimValues
)
member SubstNode :
        bom : BomItemCollection *
        origData : DedData *
        newData : DedData *
        destman : BomItemManEnum *
        discrimman : BomItemManEnum *
        searchDiscrimValues : Dictionary<string, Object> -> List<BomItem>

Parametri

bom BomItemCollection
origData DedData
Anagrafica da sostituire
newData DedData
Anagrafica sostituta
destman BomItemManEnum
Man da assegnare al nuovo elemento
discrimman BomItemManEnum
Man da usare come discriminante per la sostituzione
searchDiscrimValues Dictionary String, Object
Valori di distinta discriminati per la sostituzione

Valore di ritorno

List BomItem
Vedi anche

Documentazione

Classe DedDistControl
Overload di SubstNode
Namespace DedNet.Controls


Metodo DedDistControl.ToolTipLegend

Metodo DedDistControlToolTipLegend
Crea la legenda utilizzando un SuperToolTip

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public SuperToolTip ToolTipLegend()
Public Function ToolTipLegend As SuperToolTip
public:
SuperToolTip^ ToolTipLegend()
member ToolTipLegend : unit -> SuperToolTip

Valore di ritorno

SuperToolTip
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Metodo DedDistControl.UnloadDist

Metodo DedDistControlUnloadDist
Scarica la distinta corrente

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void UnloadDist()
Public Sub UnloadDist
public:
void UnloadDist()
member UnloadDist : unit -> unit
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Metodo DedDistControl.UnLock

Metodo DedDistControlUnLock

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void UnLock()
Public Sub UnLock
public:
void UnLock()
member UnLock : unit -> unit
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Metodo DedDistControl.UpdateNode

Metodo DedDistControlUpdateNode
Aggiorna le anagrafiche dei nodi selezionati.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void UpdateNode(
    TreeListNode node
)
Public Sub UpdateNode (
    node As TreeListNode
)
public:
void UpdateNode(
    TreeListNode^ node
)
member UpdateNode :
        node : TreeListNode -> unit

Parametri

node TreeListNode
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Metodo DedDistControl.UpdateSelectedNode

Metodo DedDistControlUpdateSelectedNode
Aggiorna le anagrafiche dei nodi selezionati.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void UpdateSelectedNode()
Public Sub UpdateSelectedNode
public:
void UpdateSelectedNode()
member UpdateSelectedNode : unit -> unit
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Metodo DedDistControl.UpdateSup

Metodo DedDistControlUpdateSup
Effettua l'aggiornamento delle revisioni superate sulla collection passata

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void UpdateSup(
    BomItemCollection bic
)
Public Sub UpdateSup (
    bic As BomItemCollection
)
public:
void UpdateSup(
    BomItemCollection^ bic
)
member UpdateSup :
        bic : BomItemCollection -> unit

Parametri

bic BomItemCollection
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Eventi di DedDistControl

Il tipo DedDistControl espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | ContextMenuOpening | Evento su apertura del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | DataLoadedInsideGrid | Evento che permette di riordinare le distinte nella griglia appena dopo l'esecuzione del comando di salvataggio.
Evento pubblico | MenuItemClicked | Evento su click su un elemento del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | onInsertFromAnagr | Definizione evento aggiunto elemento proveniente da anagrafica
Evento pubblico | PaintEx | (Ereditato da XtraUserControl)
Evento pubblico | SelectionChanged | Evento cambio selezione famiglia.
Evento pubblico | UpdateButtonClick | Evento associato al click del bottone Ok
Torna su
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Evento DedDistControl.DataLoadedInsideGrid

Evento DedDistControlDataLoadedInsideGrid
Evento che permette di riordinare le distinte nella griglia appena dopo l'esecuzione del comando di salvataggio.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<EventArgs> DataLoadedInsideGrid
Public Event DataLoadedInsideGrid As EventHandler(Of EventArgs)
public:
 event EventHandler<EventArgs^>^ DataLoadedInsideGrid {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}
member DataLoadedInsideGrid : IEvent<EventHandler<EventArgs>,
    EventArgs>

Valore

EventHandler EventArgs
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Evento DedDistControl.onInsertFromAnagr

Evento DedDistControlonInsertFromAnagr
Definizione evento aggiunto elemento proveniente da anagrafica

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DedDistControlDedBomAnagrEventArgs> onInsertFromAnagr
Public Event onInsertFromAnagr As EventHandler(Of DedDistControlDedBomAnagrEventArgs)
public:
 event EventHandler<DedDistControlDedBomAnagrEventArgs^>^ onInsertFromAnagr {
    void add (EventHandler<DedDistControlDedBomAnagrEventArgs^>^ value);
    void remove (EventHandler<DedDistControlDedBomAnagrEventArgs^>^ value);
}
member onInsertFromAnagr : IEvent<EventHandler<DedDistControlDedBomAnagrEventArgs>,
    DedDistControlDedBomAnagrEventArgs>

Valore

EventHandler DedDistControlDedBomAnagrEventArgs
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Evento DedDistControl.SelectionChanged

Evento DedDistControlSelectionChanged
Evento cambio selezione famiglia.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event DedDistControlDedBomEventDelegate SelectionChanged
Public Event SelectionChanged As DedDistControlDedBomEventDelegate
public:
 event DedDistControlDedBomEventDelegate^ SelectionChanged {
    void add (DedDistControlDedBomEventDelegate^ value);
    void remove (DedDistControlDedBomEventDelegate^ value);
}
member SelectionChanged : IEvent<DedDistControlDedBomEventDelegate,
    DedDistControlDedBomEventArgs>

Valore

DedDistControlDedBomEventDelegate
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Evento DedDistControl.UpdateButtonClick

Evento DedDistControlUpdateButtonClick
Evento associato al click del bottone Ok

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler UpdateButtonClick
Public Event UpdateButtonClick As EventHandler
public:
 event EventHandler^ UpdateButtonClick {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member UpdateButtonClick : IEvent<EventHandler,
    EventArgs>

Valore

EventHandler
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Campi di DedDistControl

Il tipo DedDistControl espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | _app | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Campo protetto | _RegistryBaseKey | Chiave nel registro di sistema di salvataggio impostazioni. (Ereditato da UserControlBase)
 | CONFDIST_SETTINGS |
Torna su
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Campo DedDistControl.CONFDIST_SETTINGS

Campo DedDistControlCONFDIST_SETTINGS

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string CONFDIST_SETTINGS = "ConfigDistinte"
Public Const CONFDIST_SETTINGS As String = "ConfigDistinte"
public:
literal String^ CONFDIST_SETTINGS = "ConfigDistinte"
static val mutable CONFDIST_SETTINGS: string

Valore del campo

String
Vedi anche

Documentazione

Classe DedDistControl
Namespace DedNet.Controls


Enumerazione DedDistControl.AddNodeActionEnum

Enumerazione DedDistControlAddNodeActionEnum
Enumerazione sull'azione in aggiunta del nodo

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum AddNodeActionEnum
Public Enumeration AddNodeActionEnum
public enum class AddNodeActionEnum
type AddNodeActionEnum
Membri
Nome | Valore | Descrizione
Standard | 0 | Aggiunta nodo standard
Clone | 1 | Aggiunta nodo in clonazione
Vedi anche

Documentazione

Namespace DedNet.Controls


Classe DedDistControl.BomSelInfo

Classe DedDistControlBomSelInfo
Classe che definisce l'oggetto selezionato
Gerarchia di ereditarietà
SystemObject
DedNet.ControlsDedDistControlBomSelInfo

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class BomSelInfo
Public Class BomSelInfo
public ref class BomSelInfo
type BomSelInfo = class end

Il tipo DedDistControlBomSelInfo espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedDistControlBomSelInfo | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Bic | Collezione di figli dell'oggetto
Proprietà pubblica | BomItem | BomItem ( è nullo se è selezionata la Root )
Proprietà pubblica | Data | Anagrafica
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore DedDistControl.BomSelInfo

Costruttore DedDistControlBomSelInfo
Costruttore

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomSelInfo(
    DedData data,
    BomItem bi,
    BomItemCollection pdrBic
)
Public Sub New (
    data As DedData,
    bi As BomItem,
    pdrBic As BomItemCollection
)
public:
BomSelInfo(
    DedData^ data,
    BomItem^ bi,
    BomItemCollection^ pdrBic
)
new :
        data : DedData *
        bi : BomItem *
        pdrBic : BomItemCollection -> BomSelInfo

Parametri

data DedData
Anagrafica
bi BomItem
BomItem
pdrBic BomItemCollection
Collezione della Root
Vedi anche

Documentazione

Classe DedDistControlBomSelInfo
Namespace DedNet.Controls


Proprietà di BomSelInfo

Il tipo DedDistControlBomSelInfo espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Bic | Collezione di figli dell'oggetto
Proprietà pubblica | BomItem | BomItem ( è nullo se è selezionata la Root )
Proprietà pubblica | Data | Anagrafica
Torna su
Vedi anche

Documentazione

Classe DedDistControlBomSelInfo
Namespace DedNet.Controls


Proprietà DedDistControl.BomSelInfo.Bic

Proprietà DedDistControlBomSelInfoBic
Collezione di figli dell'oggetto

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItemCollection Bic { get; }
Public ReadOnly Property Bic As BomItemCollection
    Get
public:
property BomItemCollection^ Bic {
    BomItemCollection^ get ();
}
member Bic : BomItemCollection with get

Valore della proprietà

BomItemCollection
Vedi anche

Documentazione

Classe DedDistControlBomSelInfo
Namespace DedNet.Controls


Proprietà DedDistControl.BomSelInfo.BomItem

Proprietà DedDistControlBomSelInfoBomItem
BomItem ( è nullo se è selezionata la Root )

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItem BomItem { get; set; }
Public Property BomItem As BomItem
    Get
    Set
public:
property BomItem^ BomItem {
    BomItem^ get ();
    void set (BomItem^ value);
}
member BomItem : BomItem with get, set

Valore della proprietà

BomItem
Vedi anche

Documentazione

Classe DedDistControlBomSelInfo
Namespace DedNet.Controls


Proprietà DedDistControl.BomSelInfo.Data

Proprietà DedDistControlBomSelInfoData
Anagrafica

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; set; }
Public Property Data As DedData
    Get
    Set
public:
property DedData^ Data {
    DedData^ get ();
    void set (DedData^ value);
}
member Data : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe DedDistControlBomSelInfo
Namespace DedNet.Controls


Classe DedDistControl.BomSelInfoList

Classe DedDistControlBomSelInfoList
Lista contenente la selezione attuale
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList DedDistControlBomSelInfo
DedNet.ControlsDedDistControlBomSelInfoList

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class BomSelInfoList : List<DedDistControlBomSelInfo>
Public Class BomSelInfoList
    Inherits List(Of DedDistControlBomSelInfo)
public ref class BomSelInfoList : public List<DedDistControlBomSelInfo^>
type BomSelInfoList =
    class
        inherit List<DedDistControlBomSelInfo>
    end

Il tipo DedDistControlBomSelInfoList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedDistControlBomSelInfoList | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | IsAnySelected | Indica se c'è qualcosa di selezionato
Proprietà pubblica | IsMultiSelected | Indica se è selezionato più di un elemento
Proprietà pubblica | IsNothingSelected | Indica se non c'è niente di selezionato
Proprietà pubblica | IsNotRootNodeSelected | Indica se non è selezionato il nodo Root
Proprietà pubblica | IsOnlyRootNodeSelected | Indica se è selezionato solo il nodo Root
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore DedDistControl.BomSelInfoList

Costruttore DedDistControlBomSelInfoList
Costruttore

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomSelInfoList()
Public Sub New
public:
BomSelInfoList()
new : unit -> BomSelInfoList
Vedi anche

Documentazione

Classe DedDistControlBomSelInfoList
Namespace DedNet.Controls


Proprietà di BomSelInfoList

Il tipo DedDistControlBomSelInfoList espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | IsAnySelected | Indica se c'è qualcosa di selezionato
Proprietà pubblica | IsMultiSelected | Indica se è selezionato più di un elemento
Proprietà pubblica | IsNothingSelected | Indica se non c'è niente di selezionato
Proprietà pubblica | IsNotRootNodeSelected | Indica se non è selezionato il nodo Root
Proprietà pubblica | IsOnlyRootNodeSelected | Indica se è selezionato solo il nodo Root
Torna su
Vedi anche

Documentazione

Classe DedDistControlBomSelInfoList
Namespace DedNet.Controls


Proprietà DedDistControl.BomSelInfoList.IsAnySelected

Proprietà DedDistControlBomSelInfoListIsAnySelected
Indica se c'è qualcosa di selezionato

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsAnySelected { get; }
Public ReadOnly Property IsAnySelected As Boolean
    Get
public:
property bool IsAnySelected {
    bool get ();
}
member IsAnySelected : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDistControlBomSelInfoList
Namespace DedNet.Controls


Proprietà DedDistControl.BomSelInfoList.IsMultiSelected

Proprietà DedDistControlBomSelInfoListIsMultiSelected
Indica se è selezionato più di un elemento

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsMultiSelected { get; }
Public ReadOnly Property IsMultiSelected As Boolean
    Get
public:
property bool IsMultiSelected {
    bool get ();
}
member IsMultiSelected : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDistControlBomSelInfoList
Namespace DedNet.Controls


Proprietà DedDistControl.BomSelInfoList.IsNothingSelected

Proprietà DedDistControlBomSelInfoListIsNothingSelected
Indica se non c'è niente di selezionato

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsNothingSelected { get; }
Public ReadOnly Property IsNothingSelected As Boolean
    Get
public:
property bool IsNothingSelected {
    bool get ();
}
member IsNothingSelected : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDistControlBomSelInfoList
Namespace DedNet.Controls


Proprietà DedDistControl.BomSelInfoList.IsNotRootNodeSelected

Proprietà DedDistControlBomSelInfoListIsNotRootNodeSelected
Indica se non è selezionato il nodo Root

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsNotRootNodeSelected { get; }
Public ReadOnly Property IsNotRootNodeSelected As Boolean
    Get
public:
property bool IsNotRootNodeSelected {
    bool get ();
}
member IsNotRootNodeSelected : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDistControlBomSelInfoList
Namespace DedNet.Controls


Proprietà DedDistControl.BomSelInfoList.IsOnlyRootNodeSelected

Proprietà DedDistControlBomSelInfoListIsOnlyRootNodeSelected
Indica se è selezionato solo il nodo Root

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsOnlyRootNodeSelected { get; }
Public ReadOnly Property IsOnlyRootNodeSelected As Boolean
    Get
public:
property bool IsOnlyRootNodeSelected {
    bool get ();
}
member IsOnlyRootNodeSelected : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDistControlBomSelInfoList
Namespace DedNet.Controls


Classe DedDistControl.CoordinateValue

Classe DedDistControlCoordinateValue
Classe usata per scrivere il valore nella cella excel
Gerarchia di ereditarietà
SystemObject
DedNet.ControlsDedDistControlCoordinateValue

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class CoordinateValue
Public Class CoordinateValue
public ref class CoordinateValue
type CoordinateValue = class end

Il tipo DedDistControlCoordinateValue espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedDistControlCoordinateValue | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Colonna | Nome della colonna
Proprietà pubblica | PosRiga | Numero di riga
Proprietà pubblica | Value | Valore da scrivere nella cella
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore DedDistControl.CoordinateValue

Costruttore DedDistControlCoordinateValue
Costruttore unico.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public CoordinateValue(
    int posRiga,
    string colonna,
    Object value
)
Public Sub New (
    posRiga As Integer,
    colonna As String,
    value As Object
)
public:
CoordinateValue(
    int posRiga,
    String^ colonna,
    Object^ value
)
new :
        posRiga : int *
        colonna : string *
        value : Object -> CoordinateValue

Parametri

posRiga Int32
colonna String
value Object
Vedi anche

Documentazione

Classe DedDistControlCoordinateValue
Namespace DedNet.Controls


Proprietà di CoordinateValue

Il tipo DedDistControlCoordinateValue espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Colonna | Nome della colonna
Proprietà pubblica | PosRiga | Numero di riga
Proprietà pubblica | Value | Valore da scrivere nella cella
Torna su
Vedi anche

Documentazione

Classe DedDistControlCoordinateValue
Namespace DedNet.Controls


Proprietà DedDistControl.CoordinateValue.Colonna

Proprietà DedDistControlCoordinateValueColonna
Nome della colonna

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Colonna { get; set; }
Public Property Colonna As String
    Get
    Set
public:
property String^ Colonna {
    String^ get ();
    void set (String^ value);
}
member Colonna : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedDistControlCoordinateValue
Namespace DedNet.Controls


Proprietà DedDistControl.CoordinateValue.PosRiga

Proprietà DedDistControlCoordinateValuePosRiga
Numero di riga

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int PosRiga { get; set; }
Public Property PosRiga As Integer
    Get
    Set
public:
property int PosRiga {
    int get ();
    void set (int value);
}
member PosRiga : int with get, set

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe DedDistControlCoordinateValue
Namespace DedNet.Controls


Proprietà DedDistControl.CoordinateValue.Value

Proprietà DedDistControlCoordinateValueValue
Valore da scrivere nella cella

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object Value { get; set; }
Public Property Value As Object
    Get
    Set
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}
member Value : Object with get, set

Valore della proprietà

Object
Vedi anche

Documentazione

Classe DedDistControlCoordinateValue
Namespace DedNet.Controls


Classe DedDistControl.DedBomAnagrEventArgs

Classe DedDistControlDedBomAnagrEventArgs
Classe gestione argomenti
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNet.ControlsDedDistControlDedBomAnagrEventArgs

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedBomAnagrEventArgs : EventArgs
Public Class DedBomAnagrEventArgs
    Inherits EventArgs
public ref class DedBomAnagrEventArgs : public EventArgs
type DedBomAnagrEventArgs =
    class
        inherit EventArgs
    end

Il tipo DedDistControlDedBomAnagrEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Anagr |
Proprietà pubblica | Cancel |
Proprietà pubblica | DedDis |
Proprietà pubblica | DedId |
Proprietà pubblica | DedRev |
Proprietà pubblica | Family |
Proprietà pubblica | Message |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Proprietà di DedBomAnagrEventArgs

Il tipo DedDistControlDedBomAnagrEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Anagr |
Proprietà pubblica | Cancel |
Proprietà pubblica | DedDis |
Proprietà pubblica | DedId |
Proprietà pubblica | DedRev |
Proprietà pubblica | Family |
Proprietà pubblica | Message |
Torna su
Vedi anche

Documentazione

Classe DedDistControlDedBomAnagrEventArgs
Namespace DedNet.Controls


Proprietà DedDistControl.DedBomAnagrEventArgs.Anagr

Proprietà DedDistControlDedBomAnagrEventArgsAnagr

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Anagr { get; set; }
Public Property Anagr As DedData
    Get
    Set
public:
property DedData^ Anagr {
    DedData^ get ();
    void set (DedData^ value);
}
member Anagr : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe DedDistControlDedBomAnagrEventArgs
Namespace DedNet.Controls


Proprietà DedDistControl.DedBomAnagrEventArgs.Cancel

Proprietà DedDistControlDedBomAnagrEventArgsCancel

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Cancel { get; set; }
Public Property Cancel As Boolean
    Get
    Set
public:
property bool Cancel {
    bool get ();
    void set (bool value);
}
member Cancel : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDistControlDedBomAnagrEventArgs
Namespace DedNet.Controls


Proprietà DedDistControl.DedBomAnagrEventArgs.DedDis

Proprietà DedDistControlDedBomAnagrEventArgsDedDis

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string DedDis { get; set; }
Public Property DedDis As String
    Get
    Set
public:
property String^ DedDis {
    String^ get ();
    void set (String^ value);
}
member DedDis : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedDistControlDedBomAnagrEventArgs
Namespace DedNet.Controls


Proprietà DedDistControl.DedBomAnagrEventArgs.DedId

Proprietà DedDistControlDedBomAnagrEventArgsDedId

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string DedId { get; set; }
Public Property DedId As String
    Get
    Set
public:
property String^ DedId {
    String^ get ();
    void set (String^ value);
}
member DedId : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedDistControlDedBomAnagrEventArgs
Namespace DedNet.Controls


Proprietà DedDistControl.DedBomAnagrEventArgs.DedRev

Proprietà DedDistControlDedBomAnagrEventArgsDedRev

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string DedRev { get; set; }
Public Property DedRev As String
    Get
    Set
public:
property String^ DedRev {
    String^ get ();
    void set (String^ value);
}
member DedRev : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedDistControlDedBomAnagrEventArgs
Namespace DedNet.Controls


Proprietà DedDistControl.DedBomAnagrEventArgs.Family

Proprietà DedDistControlDedBomAnagrEventArgsFamily

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedType Family { get; set; }
Public Property Family As DedType
    Get
    Set
public:
property DedType^ Family {
    DedType^ get ();
    void set (DedType^ value);
}
member Family : DedType with get, set

Valore della proprietà

DedType
Vedi anche

Documentazione

Classe DedDistControlDedBomAnagrEventArgs
Namespace DedNet.Controls


Proprietà DedDistControl.DedBomAnagrEventArgs.Message

Proprietà DedDistControlDedBomAnagrEventArgsMessage

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Message { get; set; }
Public Property Message As String
    Get
    Set
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}
member Message : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedDistControlDedBomAnagrEventArgs
Namespace DedNet.Controls


Classe DedDistControl.DedBomEventArgs

Classe DedDistControlDedBomEventArgs
Classe derivata da EventArgs
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNet.ControlsDedDistControlDedBomEventArgs

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedBomEventArgs : EventArgs
Public Class DedBomEventArgs
    Inherits EventArgs
public ref class DedBomEventArgs : public EventArgs
type DedBomEventArgs =
    class
        inherit EventArgs
    end

Il tipo DedDistControlDedBomEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BomItemList |
Proprietà pubblica | DataList |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Proprietà di DedBomEventArgs

Il tipo DedDistControlDedBomEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BomItemList |
Proprietà pubblica | DataList |
Torna su
Vedi anche

Documentazione

Classe DedDistControlDedBomEventArgs
Namespace DedNet.Controls


Proprietà DedDistControl.DedBomEventArgs.BomItemList

Proprietà DedDistControlDedBomEventArgsBomItemList

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<BomItem> BomItemList { get; }
Public ReadOnly Property BomItemList As List(Of BomItem)
    Get
public:
property List<BomItem^>^ BomItemList {
    List<BomItem^>^ get ();
}
member BomItemList : List<BomItem> with get

Valore della proprietà

List BomItem
Vedi anche

Documentazione

Classe DedDistControlDedBomEventArgs
Namespace DedNet.Controls


Proprietà DedDistControl.DedBomEventArgs.DataList

Proprietà DedDistControlDedBomEventArgsDataList

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataList DataList { get; }
Public ReadOnly Property DataList As DedDataList
    Get
public:
property DedDataList^ DataList {
    DedDataList^ get ();
}
member DataList : DedDataList with get

Valore della proprietà

DedDataList
Vedi anche

Documentazione

Classe DedDistControlDedBomEventArgs
Namespace DedNet.Controls


Delegate DedDistControl.DedBomEventDelegate

Delegate DedDistControlDedBomEventDelegate
Definizione del Delegate da utilizzare per gli eventi.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public delegate void DedBomEventDelegate(
    Object sender,
    DedDistControlDedBomEventArgs e
)
Public Delegate Sub DedBomEventDelegate (
    sender As Object,
    e As DedDistControlDedBomEventArgs
)
public delegate void DedBomEventDelegate(
    Object^ sender,
    DedDistControlDedBomEventArgs^ e
)
type DedBomEventDelegate =
    delegate of
        sender : Object *
        e : DedDistControlDedBomEventArgs -> unit

Parametri

sender Object
Oggetto chiamante.
e DedDistControlDedBomEventArgs
Oggetto DedTreeViewEventArgs.
Vedi anche

Documentazione

Namespace DedNet.Controls


Enumerazione DedDistControl.DedCompareDistEnum

Enumerazione DedDistControlDedCompareDistEnum
Enumerazione sugli stati possibili in confronto delle distinta

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum DedCompareDistEnum
Public Enumeration DedCompareDistEnum
public enum class DedCompareDistEnum
type DedCompareDistEnum
Membri
Nome | Valore | Descrizione
Equal | 0 | Uguale
NotEqual | 1 | Diverso
NotPresent | 2 | Non presente
Added | 3 | Aggiunto
Vedi anche

Documentazione

Namespace DedNet.Controls


Classe DedDocControl
Controllo per la gesitione della visualizzazione dei file primari/allegati
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
XtraUserControl
DedNet.ControlsUserControlBase
DedNet.ControlsDedDocControl

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedDocControl : UserControlBase
Public Class DedDocControl
    Inherits UserControlBase
public ref class DedDocControl : public UserControlBase
type DedDocControl =
    class
        inherit UserControlBase
    end

Il tipo DedDocControl espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedDocControl | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Appearance | (Ereditato da XtraUserControl)
Proprietà pubblica | Application | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Proprietà pubblica | AutoExpandRoot | Restituisce o imposta se espandere la root in automatico al caricamento.
Proprietà pubblica | AutoSelectFile | Restituisce o imposta se selezionare in automatico i file al caricamento.
Proprietà pubblica | BackColor | (Ereditato da XtraUserControl)
Proprietà protetta | CheckDoubleScaling | (Ereditato da XtraUserControl)
Proprietà pubblica | CheckIn | Restituisce o imposta se il controllo è abilitato a differenziare i documenti in base al CheckIn-CheckOut.
Proprietà pubblica | Comm | Commessa che contiene i documenti.
Proprietà pubblica | Datas | Restituisce / Imposta le anagrafiche associate ai documenti.
Proprietà protetta | DefaultAppearance | (Ereditato da XtraUserControl)
Proprietà protetta | DirectXContainer | (Ereditato da XtraUserControl)
Proprietà pubblica | DocContextType | Tipologia di contesto del DedDocControl
Proprietà pubblica | DocList | Lista dei documenti gestiti dal controllo.
Proprietà pubblica | ECO | ECO che contiene i documenti.
Proprietà pubblica | EnableHideRepresentationButton | Restituisce o imposta se abilitare il pulsante per controllare la visualizzazione delle rappresentazioni
Proprietà pubblica | EnableIXtraResizeableControlInterfaceProxy | (Ereditato da XtraUserControl)
Proprietà pubblica | Font | (Ereditato da XtraUserControl)
Proprietà pubblica | ForeColor | (Ereditato da XtraUserControl)
Proprietà protetta | Helper | (Ereditato da XtraUserControl)
Proprietà pubblica | HideDataState | Indica se visualizzare o meno lo stato dell'anagrafica alla quale è associato il documento.
Proprietà pubblica | IsDragging | Restituisce il semaforo che indica se il controllo sta draggando dei dati.
Proprietà pubblica | LookAndFeel | (Ereditato da XtraUserControl)
Proprietà pubblica | ManageFolder | Restituisce o imposta se il controllo è abilitato a raggruppare i documenti in base alle cartelle di appartenenza.
Proprietà protetta | Painter | (Ereditato da XtraUserControl)
Proprietà pubblica | PriorityExtList | Restituisce o imposta la lista delle estensioni che hanno la priorità di selezione. Questa proprietà viene considerata solo se AutoSelectFile è impostata a true.
Proprietà protetta | ScaleChildren | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleDPI | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraUserControl)
Proprietà pubblica | SelectedDocuments | Restituisce la lista dei documenti attualmente selezionati.
Proprietà pubblica | SelectedDocumentsConfig | Restituisce la lista delle configurazioni dei documenti attualmente selezionati.
Proprietà pubblica | SelectedFolder | Restituisce la lista delle cartelle attualmente selezionate.
Proprietà protetta | ShouldCheckDpiScaleFactorOnParentChanged | (Ereditato da XtraUserControl)
Proprietà pubblica | ShowChildAsDep | Imposta o restituisce se i figli vengono mostrati come dipendenza.
Proprietà pubblica | ShowExtraData | Indica se visualizzare anche i dati dell'anagrafica alla quale il documento è associato.
Proprietà pubblica | ShowManageFolderButton | Restituisce o imposta se visualizzare il pulsante per visualizzare le cartelle.
Proprietà pubblica | ShowParentAsDep | Restituisce o imposta se mostrare i padri come dipendenza (vedi comando [whereUsed]).
Proprietà pubblica | Site | (Ereditato da XtraUserControl)
Proprietà pubblica | Title | Restituisce o imposta il titolo del controllo.
Proprietà pubblica | TitleAlignement | Restituisce o imposta l'allineamento del titolo.
Proprietà pubblica | Tree | Oggetto TreeList riportante la struttura dei documenti.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AddDocuments | Aggiunge i documenti passati ai documenti già presenti.
Metodo protetto | BaseWndProc | (Ereditato da XtraUserControl)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraUserControl)
Metodo protetto | CreatePainter | (Ereditato da XtraUserControl)
Metodo protetto | Dispose | Liberare le risorse in uso. (Sovrascrive UserControlBaseDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraUserControl)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraUserControl)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraUserControl)
Metodo protetto | GetBackColor | (Ereditato da XtraUserControl)
Metodo protetto | GetBackgroundSkinElement | (Ereditato da XtraUserControl)
Metodo protetto | GetInnerIXtraResizableControl | (Ereditato da XtraUserControl)
Metodo protetto | IsChildControlsRequiredScalingEnabled | (Ereditato da XtraUserControl)
Metodo protetto | IsParentHandleCreatedRecursive | (Ereditato da XtraUserControl)
Metodo pubblico | LoadRegistrySettings | Carica dal registro le dimensioni e la visibilità delle colonne.
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraUserControl)
Metodo protetto | OnBackColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnContextMenuOpening | (Sovrascrive UserControlBaseOnContextMenuOpening(Object, CancelEventArgs))
Metodo protetto | OnControlAdded | (Ereditato da XtraUserControl)
Metodo protetto | OnControlRemoved | (Ereditato da XtraUserControl)
Metodo protetto | OnDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnFirstLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnForeColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleCreated | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraUserControl)
Metodo protetto | OnKeyPress |
Metodo protetto | OnLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnMenuItemClicked | Evento di pressione di un comando del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnMouseDoubleClick |
Metodo protetto | OnNotifyDocStatusChanged | Lancio l'evento di NotifyDocStatusChanged
Metodo protetto | OnPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnPaintCore | (Ereditato da XtraUserControl)
Metodo protetto | OnParentChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | OnSelectionChanged | Lancia l'evento di SelectionChanged passando i documenti correntemente selezionati.
Metodo protetto | OnSizeChanged | (Ereditato da XtraUserControl)
Metodo protetto | RaisePaintExEvent | (Ereditato da XtraUserControl)
Metodo pubblico | ResetBackColor | (Ereditato da XtraUserControl)
Metodo pubblico | ResetForeColor | (Ereditato da XtraUserControl)
Metodo protetto | RestoreAutoScaleModeChangedByPM2 | (Ereditato da XtraUserControl)
Metodo pubblico | SaveRegistrySettings | Salva nel registro le dimensioni e la visibilità delle colonne.
Metodo protetto | ScaleControl | (Ereditato da XtraUserControl)
Metodo pubblico | SetCommandList | Rigenera il menu contestuale di questo controllo con la lista dei comandi passati. (Sovrascrive UserControlBaseSetCommandList(DedCommandList, CommandContextEnum))
Metodo protetto | SetVisibleCore | (Ereditato da XtraUserControl)
Metodo protetto | ShouldPaintTransparentBackground | (Ereditato da XtraUserControl)
Metodo protetto | ShouldUseDirectXPaint | (Ereditato da XtraUserControl)
Metodo pubblico | ViewDocuments(DedDocList, Boolean) | Carica la lista dei documenti e li visualizza nel controllo in base alle impostazioni correnti. Se è già presente una selezione viene azzerata e ricaricata. Se viene passato null come argomento viene solo svuotato il contenuto del controllo.
Metodo pubblico | ViewDocuments(DedDocList, String, Boolean) | Carica la lista dei documenti e li visualizza nel controllo in base alle impostazioni correnti. Se è già presente una selezione viene azzerata e ricaricata. Se viene passato null come argomento viene solo svuotato il contenuto del controllo.
Metodo protetto | WndProc | (Ereditato da XtraUserControl)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | ContextMenuOpening | Evento su apertura del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | KeyPress | Pressione di un tasto.
Evento pubblico | MenuItemClicked | Evento su click su un elemento del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | MouseDoubleClick | Evento di doppio click.
Evento pubblico | NotifyDocStatusChanged | Evento lanciato sul cambio stato del documento
Evento pubblico | PaintEx | (Ereditato da XtraUserControl)
Evento pubblico | SelectionChanged | Evento lanciato sulla modifica della selezione dei documenti.
Torna su
Campi
 | Nome | Descrizione
Campo protetto | _app | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Campo protetto | _RegistryBaseKey | Chiave nel registro di sistema di salvataggio impostazioni. (Ereditato da UserControlBase)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore DedDocControl
Costruttore unico.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocControl()
Public Sub New
public:
DedDocControl()
new : unit -> DedDocControl
Vedi anche

Documentazione

Classe DedDocControl
Namespace DedNet.Controls


Proprietà di DedDocControl

Il tipo DedDocControl espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Appearance | (Ereditato da XtraUserControl)
Proprietà pubblica | Application | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Proprietà pubblica | AutoExpandRoot | Restituisce o imposta se espandere la root in automatico al caricamento.
Proprietà pubblica | AutoSelectFile | Restituisce o imposta se selezionare in automatico i file al caricamento.
Proprietà pubblica | BackColor | (Ereditato da XtraUserControl)
Proprietà protetta | CheckDoubleScaling | (Ereditato da XtraUserControl)
Proprietà pubblica | CheckIn | Restituisce o imposta se il controllo è abilitato a differenziare i documenti in base al CheckIn-CheckOut.
Proprietà pubblica | Comm | Commessa che contiene i documenti.
Proprietà pubblica | Datas | Restituisce / Imposta le anagrafiche associate ai documenti.
Proprietà protetta | DefaultAppearance | (Ereditato da XtraUserControl)
Proprietà protetta | DirectXContainer | (Ereditato da XtraUserControl)
Proprietà pubblica | DocContextType | Tipologia di contesto del DedDocControl
Proprietà pubblica | DocList | Lista dei documenti gestiti dal controllo.
Proprietà pubblica | ECO | ECO che contiene i documenti.
Proprietà pubblica | EnableHideRepresentationButton | Restituisce o imposta se abilitare il pulsante per controllare la visualizzazione delle rappresentazioni
Proprietà pubblica | EnableIXtraResizeableControlInterfaceProxy | (Ereditato da XtraUserControl)
Proprietà pubblica | Font | (Ereditato da XtraUserControl)
Proprietà pubblica | ForeColor | (Ereditato da XtraUserControl)
Proprietà protetta | Helper | (Ereditato da XtraUserControl)
Proprietà pubblica | HideDataState | Indica se visualizzare o meno lo stato dell'anagrafica alla quale è associato il documento.
Proprietà pubblica | IsDragging | Restituisce il semaforo che indica se il controllo sta draggando dei dati.
Proprietà pubblica | LookAndFeel | (Ereditato da XtraUserControl)
Proprietà pubblica | ManageFolder | Restituisce o imposta se il controllo è abilitato a raggruppare i documenti in base alle cartelle di appartenenza.
Proprietà protetta | Painter | (Ereditato da XtraUserControl)
Proprietà pubblica | PriorityExtList | Restituisce o imposta la lista delle estensioni che hanno la priorità di selezione. Questa proprietà viene considerata solo se AutoSelectFile è impostata a true.
Proprietà protetta | ScaleChildren | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleDPI | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraUserControl)
Proprietà pubblica | SelectedDocuments | Restituisce la lista dei documenti attualmente selezionati.
Proprietà pubblica | SelectedDocumentsConfig | Restituisce la lista delle configurazioni dei documenti attualmente selezionati.
Proprietà pubblica | SelectedFolder | Restituisce la lista delle cartelle attualmente selezionate.
Proprietà protetta | ShouldCheckDpiScaleFactorOnParentChanged | (Ereditato da XtraUserControl)
Proprietà pubblica | ShowChildAsDep | Imposta o restituisce se i figli vengono mostrati come dipendenza.
Proprietà pubblica | ShowExtraData | Indica se visualizzare anche i dati dell'anagrafica alla quale il documento è associato.
Proprietà pubblica | ShowManageFolderButton | Restituisce o imposta se visualizzare il pulsante per visualizzare le cartelle.
Proprietà pubblica | ShowParentAsDep | Restituisce o imposta se mostrare i padri come dipendenza (vedi comando [whereUsed]).
Proprietà pubblica | Site | (Ereditato da XtraUserControl)
Proprietà pubblica | Title | Restituisce o imposta il titolo del controllo.
Proprietà pubblica | TitleAlignement | Restituisce o imposta l'allineamento del titolo.
Proprietà pubblica | Tree | Oggetto TreeList riportante la struttura dei documenti.
Torna su
Vedi anche

Documentazione

Classe DedDocControl
Namespace DedNet.Controls


Proprietà DedDocControl.AutoExpandRoot

Proprietà DedDocControlAutoExpandRoot
Restituisce o imposta se espandere la root in automatico al caricamento.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AutoExpandRoot { get; set; }
Public Property AutoExpandRoot As Boolean
    Get
    Set
public:
property bool AutoExpandRoot {
    bool get ();
    void set (bool value);
}
member AutoExpandRoot : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDocControl
Namespace DedNet.Controls


Proprietà DedDocControl.AutoSelectFile

Proprietà DedDocControlAutoSelectFile
Restituisce o imposta se selezionare in automatico i file al caricamento.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AutoSelectFile { get; set; }
Public Property AutoSelectFile As Boolean
    Get
    Set
public:
property bool AutoSelectFile {
    bool get ();
    void set (bool value);
}
member AutoSelectFile : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDocControl
Namespace DedNet.Controls


Proprietà DedDocControl.CheckIn

Proprietà DedDocControlCheckIn
Restituisce o imposta se il controllo è abilitato a differenziare i documenti in base al CheckIn-CheckOut.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CheckIn { get; set; }
Public Property CheckIn As Boolean
    Get
    Set
public:
property bool CheckIn {
    bool get ();
    void set (bool value);
}
member CheckIn : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDocControl
Namespace DedNet.Controls


Proprietà DedDocControl.Comm

Proprietà DedDocControlComm
Commessa che contiene i documenti.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedComm Comm { get; set; }
Public Property Comm As DedComm
    Get
    Set
public:
property DedComm^ Comm {
    DedComm^ get ();
    void set (DedComm^ value);
}
member Comm : DedComm with get, set

Valore della proprietà

DedComm
Vedi anche

Documentazione

Classe DedDocControl
Namespace DedNet.Controls


Proprietà DedDocControl.Datas

Proprietà DedDocControlDatas
Restituisce / Imposta le anagrafiche associate ai documenti.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataList Datas { get; set; }
Public Property Datas As DedDataList
    Get
    Set
public:
property DedDataList^ Datas {
    DedDataList^ get ();
    void set (DedDataList^ value);
}
member Datas : DedDataList with get, set

Valore della proprietà

DedDataList
Vedi anche

Documentazione

Classe DedDocControl
Namespace DedNet.Controls


Proprietà DedDocControl.DocContextType

Proprietà DedDocControlDocContextType
Tipologia di contesto del DedDocControl

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocContextTypeEnum DocContextType { get; set; }
Public Property DocContextType As DedDocContextTypeEnum
    Get
    Set
public:
property DedDocContextTypeEnum DocContextType {
    DedDocContextTypeEnum get ();
    void set (DedDocContextTypeEnum value);
}
member DocContextType : DedDocContextTypeEnum with get, set

Valore della proprietà

DedDocContextTypeEnum
Vedi anche

Documentazione

Classe DedDocControl
Namespace DedNet.Controls


Proprietà DedDocControl.DocList

Proprietà DedDocControlDocList
Lista dei documenti gestiti dal controllo.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocList DocList { get; }
Public ReadOnly Property DocList As DedDocList
    Get
public:
property DedDocList^ DocList {
    DedDocList^ get ();
}
member DocList : DedDocList with get

Valore della proprietà

DedDocList
Vedi anche

Documentazione

Classe DedDocControl
Namespace DedNet.Controls


Proprietà DedDocControl.ECO

Proprietà DedDocControlECO
ECO che contiene i documenti.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEco ECO { get; set; }
Public Property ECO As DedEco
    Get
    Set
public:
property DedEco^ ECO {
    DedEco^ get ();
    void set (DedEco^ value);
}
member ECO : DedEco with get, set

Valore della proprietà

DedEco
Vedi anche

Documentazione

Classe DedDocControl
Namespace DedNet.Controls


Proprietà DedDocControl.EnableHideRepresentationButton

Proprietà DedDocControlEnableHideRepresentationButton
Restituisce o imposta se abilitare il pulsante per controllare la visualizzazione delle rappresentazioni

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool EnableHideRepresentationButton { get; set; }
Public Property EnableHideRepresentationButton As Boolean
    Get
    Set
public:
property bool EnableHideRepresentationButton {
    bool get ();
    void set (bool value);
}
member EnableHideRepresentationButton : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDocControl
Namespace DedNet.Controls


Proprietà DedDocControl.HideDataState

Proprietà DedDocControlHideDataState
Indica se visualizzare o meno lo stato dell'anagrafica alla quale è associato il documento.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HideDataState { get; set; }
Public Property HideDataState As Boolean
    Get
    Set
public:
property bool HideDataState {
    bool get ();
    void set (bool value);
}
member HideDataState : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDocControl
Namespace DedNet.Controls


Proprietà DedDocControl.IsDragging

Proprietà DedDocControlIsDragging
Restituisce il semaforo che indica se il controllo sta draggando dei dati.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsDragging { get; }
Public ReadOnly Property IsDragging As Boolean
    Get
public:
property bool IsDragging {
    bool get ();
}
member IsDragging : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDocControl
Namespace DedNet.Controls


Proprietà DedDocControl.ManageFolder

Proprietà DedDocControlManageFolder
Restituisce o imposta se il controllo è abilitato a raggruppare i documenti in base alle cartelle di appartenenza.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ManageFolder { get; set; }
Public Property ManageFolder As Boolean
    Get
    Set
public:
property bool ManageFolder {
    bool get ();
    void set (bool value);
}
member ManageFolder : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDocControl
Namespace DedNet.Controls


Proprietà DedDocControl.PriorityExtList

Proprietà DedDocControlPriorityExtList
Restituisce o imposta la lista delle estensioni che hanno la priorità di selezione. Questa proprietà viene considerata solo se AutoSelectFile è impostata a true.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> PriorityExtList { get; set; }
Public Property PriorityExtList As List(Of String)
    Get
    Set
public:
property List<String^>^ PriorityExtList {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
member PriorityExtList : List<string> with get, set

Valore della proprietà

List String
Vedi anche

Documentazione

Classe DedDocControl
Namespace DedNet.Controls


Proprietà DedDocControl.SelectedDocuments

Proprietà DedDocControlSelectedDocuments
Restituisce la lista dei documenti attualmente selezionati.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocList SelectedDocuments { get; }
Public ReadOnly Property SelectedDocuments As DedDocList
    Get
public:
property DedDocList^ SelectedDocuments {
    DedDocList^ get ();
}
member SelectedDocuments : DedDocList with get

Valore della proprietà

DedDocList
Vedi anche

Documentazione

Classe DedDocControl
Namespace DedNet.Controls


Proprietà DedDocControl.SelectedDocumentsConfig

Proprietà DedDocControlSelectedDocumentsConfig
Restituisce la lista delle configurazioni dei documenti attualmente selezionati.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<DedDoc, List<string>> SelectedDocumentsConfig { get; }
Public ReadOnly Property SelectedDocumentsConfig As Dictionary(Of DedDoc, List(Of String))
    Get
public:
property Dictionary<DedDoc^, List<String^>^>^ SelectedDocumentsConfig {
    Dictionary<DedDoc^, List<String^>^>^ get ();
}
member SelectedDocumentsConfig : Dictionary<DedDoc, List<string>> with get

Valore della proprietà

Dictionary DedDoc, List String
Vedi anche

Documentazione

Classe DedDocControl
Namespace DedNet.Controls


Proprietà DedDocControl.SelectedFolder

Proprietà DedDocControlSelectedFolder
Restituisce la lista delle cartelle attualmente selezionate.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> SelectedFolder { get; }
Public ReadOnly Property SelectedFolder As List(Of String)
    Get
public:
property List<String^>^ SelectedFolder {
    List<String^>^ get ();
}
member SelectedFolder : List<string> with get

Valore della proprietà

List String
Vedi anche

Documentazione

Classe DedDocControl
Namespace DedNet.Controls


Proprietà DedDocControl.ShowChildAsDep

Proprietà DedDocControlShowChildAsDep
Imposta o restituisce se i figli vengono mostrati come dipendenza.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ShowChildAsDep { get; set; }
Public Property ShowChildAsDep As Boolean
    Get
    Set
public:
property bool ShowChildAsDep {
    bool get ();
    void set (bool value);
}
member ShowChildAsDep : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDocControl
Namespace DedNet.Controls


Proprietà DedDocControl.ShowExtraData

Proprietà DedDocControlShowExtraData
Indica se visualizzare anche i dati dell'anagrafica alla quale il documento è associato.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ShowExtraData { get; set; }
Public Property ShowExtraData As Boolean
    Get
    Set
public:
property bool ShowExtraData {
    bool get ();
    void set (bool value);
}
member ShowExtraData : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDocControl
Namespace DedNet.Controls


Proprietà DedDocControl.ShowManageFolderButton

Proprietà DedDocControlShowManageFolderButton
Restituisce o imposta se visualizzare il pulsante per visualizzare le cartelle.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ShowManageFolderButton { get; set; }
Public Property ShowManageFolderButton As Boolean
    Get
    Set
public:
property bool ShowManageFolderButton {
    bool get ();
    void set (bool value);
}
member ShowManageFolderButton : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDocControl
Namespace DedNet.Controls


Proprietà DedDocControl.ShowParentAsDep

Proprietà DedDocControlShowParentAsDep
Restituisce o imposta se mostrare i padri come dipendenza (vedi comando [whereUsed]).

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ShowParentAsDep { get; set; }
Public Property ShowParentAsDep As Boolean
    Get
    Set
public:
property bool ShowParentAsDep {
    bool get ();
    void set (bool value);
}
member ShowParentAsDep : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDocControl
Namespace DedNet.Controls


Proprietà DedDocControl.Title

Proprietà DedDocControlTitle
Restituisce o imposta il titolo del controllo.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Title { get; set; }
Public Property Title As String
    Get
    Set
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}
member Title : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedDocControl
Namespace DedNet.Controls


Proprietà DedDocControl.TitleAlignement

Proprietà DedDocControlTitleAlignement
Restituisce o imposta l'allineamento del titolo.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public HorzAlignment TitleAlignement { get; set; }
Public Property TitleAlignement As HorzAlignment
    Get
    Set
public:
property HorzAlignment^ TitleAlignement {
    HorzAlignment^ get ();
    void set (HorzAlignment^ value);
}
member TitleAlignement : HorzAlignment with get, set

Valore della proprietà

HorzAlignment
Vedi anche

Documentazione

Classe DedDocControl
Namespace DedNet.Controls


Proprietà DedDocControl.Tree

Proprietà DedDocControlTree
Oggetto TreeList riportante la struttura dei documenti.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public TreeList Tree { get; }
Public ReadOnly Property Tree As TreeList
    Get
public:
property TreeList^ Tree {
    TreeList^ get ();
}
member Tree : TreeList with get

Valore della proprietà

TreeList
Vedi anche

Documentazione

Classe DedDocControl
Namespace DedNet.Controls


Metodi di DedDocControl

Il tipo DedDocControl espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AddDocuments | Aggiunge i documenti passati ai documenti già presenti.
Metodo protetto | BaseWndProc | (Ereditato da XtraUserControl)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraUserControl)
Metodo protetto | CreatePainter | (Ereditato da XtraUserControl)
Metodo protetto | Dispose | Liberare le risorse in uso. (Sovrascrive UserControlBaseDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraUserControl)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraUserControl)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraUserControl)
Metodo protetto | GetBackColor | (Ereditato da XtraUserControl)
Metodo protetto | GetBackgroundSkinElement | (Ereditato da XtraUserControl)
Metodo protetto | GetInnerIXtraResizableControl | (Ereditato da XtraUserControl)
Metodo protetto | IsChildControlsRequiredScalingEnabled | (Ereditato da XtraUserControl)
Metodo protetto | IsParentHandleCreatedRecursive | (Ereditato da XtraUserControl)
Metodo pubblico | LoadRegistrySettings | Carica dal registro le dimensioni e la visibilità delle colonne.
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraUserControl)
Metodo protetto | OnBackColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnContextMenuOpening | (Sovrascrive UserControlBaseOnContextMenuOpening(Object, CancelEventArgs))
Metodo protetto | OnControlAdded | (Ereditato da XtraUserControl)
Metodo protetto | OnControlRemoved | (Ereditato da XtraUserControl)
Metodo protetto | OnDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnFirstLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnForeColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleCreated | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraUserControl)
Metodo protetto | OnKeyPress |
Metodo protetto | OnLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnMenuItemClicked | Evento di pressione di un comando del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnMouseDoubleClick |
Metodo protetto | OnNotifyDocStatusChanged | Lancio l'evento di NotifyDocStatusChanged
Metodo protetto | OnPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnPaintCore | (Ereditato da XtraUserControl)
Metodo protetto | OnParentChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | OnSelectionChanged | Lancia l'evento di SelectionChanged passando i documenti correntemente selezionati.
Metodo protetto | OnSizeChanged | (Ereditato da XtraUserControl)
Metodo protetto | RaisePaintExEvent | (Ereditato da XtraUserControl)
Metodo pubblico | ResetBackColor | (Ereditato da XtraUserControl)
Metodo pubblico | ResetForeColor | (Ereditato da XtraUserControl)
Metodo protetto | RestoreAutoScaleModeChangedByPM2 | (Ereditato da XtraUserControl)
Metodo pubblico | SaveRegistrySettings | Salva nel registro le dimensioni e la visibilità delle colonne.
Metodo protetto | ScaleControl | (Ereditato da XtraUserControl)
Metodo pubblico | SetCommandList | Rigenera il menu contestuale di questo controllo con la lista dei comandi passati. (Sovrascrive UserControlBaseSetCommandList(DedCommandList, CommandContextEnum))
Metodo protetto | SetVisibleCore | (Ereditato da XtraUserControl)
Metodo protetto | ShouldPaintTransparentBackground | (Ereditato da XtraUserControl)
Metodo protetto | ShouldUseDirectXPaint | (Ereditato da XtraUserControl)
Metodo pubblico | ViewDocuments(DedDocList, Boolean) | Carica la lista dei documenti e li visualizza nel controllo in base alle impostazioni correnti. Se è già presente una selezione viene azzerata e ricaricata. Se viene passato null come argomento viene solo svuotato il contenuto del controllo.
Metodo pubblico | ViewDocuments(DedDocList, String, Boolean) | Carica la lista dei documenti e li visualizza nel controllo in base alle impostazioni correnti. Se è già presente una selezione viene azzerata e ricaricata. Se viene passato null come argomento viene solo svuotato il contenuto del controllo.
Metodo protetto | WndProc | (Ereditato da XtraUserControl)
Torna su
Vedi anche

Documentazione

Classe DedDocControl
Namespace DedNet.Controls


Metodo DedDocControl.AddDocuments

Metodo DedDocControlAddDocuments
Aggiunge i documenti passati ai documenti già presenti.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddDocuments(
    DedDocList doclist
)
Public Sub AddDocuments (
    doclist As DedDocList
)
public:
void AddDocuments(
    DedDocList^ doclist
)
member AddDocuments :
        doclist : DedDocList -> unit

Parametri

doclist DedDocList
Lista dei documenti da visualizzare.
Vedi anche

Documentazione

Classe DedDocControl
Namespace DedNet.Controls


Metodo DedDocControl.Dispose

Metodo DedDocControlDispose
Liberare le risorse in uso.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
ha valore true se le risorse gestite devono essere eliminate, false in caso contrario.
Vedi anche

Documentazione

Classe DedDocControl
Namespace DedNet.Controls


Metodo DedDocControl.LoadRegistrySettings

Metodo DedDocControlLoadRegistrySettings
Carica dal registro le dimensioni e la visibilità delle colonne.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void LoadRegistrySettings(
    string key
)
Public Sub LoadRegistrySettings (
    key As String
)
public:
void LoadRegistrySettings(
    String^ key
)
member LoadRegistrySettings :
        key : string -> unit

Parametri

key String
Chiave di registro dalla quale leggere le impostazioni.
Vedi anche

Documentazione

Classe DedDocControl
Namespace DedNet.Controls


Metodo DedDocControl.OnContextMenuOpening

Metodo DedDocControlOnContextMenuOpening

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void OnContextMenuOpening(
    Object sender,
    CancelEventArgs e
)
Protected Overrides Sub OnContextMenuOpening (
    sender As Object,
    e As CancelEventArgs
)
protected:
virtual void OnContextMenuOpening(
    Object^ sender,
    CancelEventArgs^ e
) override
abstract OnContextMenuOpening :
        sender : Object *
        e : CancelEventArgs -> unit
override OnContextMenuOpening :
        sender : Object *
        e : CancelEventArgs -> unit

Parametri

sender Object
e CancelEventArgs
Vedi anche

Documentazione

Classe DedDocControl
Namespace DedNet.Controls


Metodo DedDocControl.OnKeyPress

Metodo DedDocControlOnKeyPress

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected void OnKeyPress(
    Object sender,
    KeyPressEventArgs e
)
Protected Sub OnKeyPress (
    sender As Object,
    e As KeyPressEventArgs
)
protected:
void OnKeyPress(
    Object^ sender,
    KeyPressEventArgs^ e
)
member OnKeyPress :
        sender : Object *
        e : KeyPressEventArgs -> unit

Parametri

sender Object
e KeyPressEventArgs
Vedi anche

Documentazione

Classe DedDocControl
Namespace DedNet.Controls


Metodo DedDocControl.OnMouseDoubleClick

Metodo DedDocControlOnMouseDoubleClick

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected void OnMouseDoubleClick(
    Object sender,
    MouseEventArgs e
)
Protected Sub OnMouseDoubleClick (
    sender As Object,
    e As MouseEventArgs
)
protected:
void OnMouseDoubleClick(
    Object^ sender,
    MouseEventArgs^ e
)
member OnMouseDoubleClick :
        sender : Object *
        e : MouseEventArgs -> unit

Parametri

sender Object
e MouseEventArgs
Vedi anche

Documentazione

Classe DedDocControl
Namespace DedNet.Controls


Metodo DedDocControl.OnNotifyDocStatusChanged

Metodo DedDocControlOnNotifyDocStatusChanged
Lancio l'evento di NotifyDocStatusChanged

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected void OnNotifyDocStatusChanged(
    DedDoc doc,
    bool needRefresh
)
Protected Sub OnNotifyDocStatusChanged (
    doc As DedDoc,
    needRefresh As Boolean
)
protected:
void OnNotifyDocStatusChanged(
    DedDoc^ doc,
    bool needRefresh
)
member OnNotifyDocStatusChanged :
        doc : DedDoc *
        needRefresh : bool -> unit

Parametri

doc DedDoc
Documento selezionato
needRefresh Boolean
Indica se il cambio stato è avvenuto
Vedi anche

Documentazione

Classe DedDocControl
Namespace DedNet.Controls


Metodo DedDocControl.OnSelectionChanged

Metodo DedDocControlOnSelectionChanged
Lancia l'evento di SelectionChanged passando i documenti correntemente selezionati.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected void OnSelectionChanged()
Protected Sub OnSelectionChanged
protected:
void OnSelectionChanged()
member OnSelectionChanged : unit -> unit
Vedi anche

Documentazione

Classe DedDocControl
Namespace DedNet.Controls


Metodo DedDocControl.SaveRegistrySettings

Metodo DedDocControlSaveRegistrySettings
Salva nel registro le dimensioni e la visibilità delle colonne.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SaveRegistrySettings(
    string key
)
Public Sub SaveRegistrySettings (
    key As String
)
public:
void SaveRegistrySettings(
    String^ key
)
member SaveRegistrySettings :
        key : string -> unit

Parametri

key String
Chiave di registro nella quale scrivere le impostazioni.
Vedi anche

Documentazione

Classe DedDocControl
Namespace DedNet.Controls


Metodo DedDocControl.SetCommandList

Metodo DedDocControlSetCommandList
Rigenera il menu contestuale di questo controllo con la lista dei comandi passati.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void SetCommandList(
    DedCommandList commandList,
    CommandContextEnum commandContext
)
Public Overrides Sub SetCommandList (
    commandList As DedCommandList,
    commandContext As CommandContextEnum
)
public:
virtual void SetCommandList(
    DedCommandList^ commandList,
    CommandContextEnum commandContext
) override
abstract SetCommandList :
        commandList : DedCommandList *
        commandContext : CommandContextEnum -> unit
override SetCommandList :
        commandList : DedCommandList *
        commandContext : CommandContextEnum -> unit

Parametri

commandList DedCommandList
Lista completa dei comandi.
commandContext CommandContextEnum
Contesto da utilizzare per filtrare i comandi da inserire.
Note
Filtra i comandi in modo da aggiungere soltanto quelli coerenti con il contesto passato.
Vedi anche

Documentazione

Classe DedDocControl
Namespace DedNet.Controls


Metodo DedDocControl.ViewDocuments

Metodo DedDocControlViewDocuments
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | ViewDocuments(DedDocList, Boolean) | Carica la lista dei documenti e li visualizza nel controllo in base alle impostazioni correnti. Se è già presente una selezione viene azzerata e ricaricata. Se viene passato null come argomento viene solo svuotato il contenuto del controllo.
Metodo pubblico | ViewDocuments(DedDocList, String, Boolean) | Carica la lista dei documenti e li visualizza nel controllo in base alle impostazioni correnti. Se è già presente una selezione viene azzerata e ricaricata. Se viene passato null come argomento viene solo svuotato il contenuto del controllo.
Torna su
Vedi anche

Documentazione

Classe DedDocControl
Namespace DedNet.Controls


Metodo DedDocControl.ViewDocuments(DedDocList, Boolean)

Metodo DedDocControlViewDocuments(DedDocList, Boolean)
Carica la lista dei documenti e li visualizza nel controllo in base alle impostazioni correnti. Se è già presente una selezione viene azzerata e ricaricata. Se viene passato null come argomento viene solo svuotato il contenuto del controllo.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ViewDocuments(
    DedDocList doclist,
    bool restore = false
)
Public Sub ViewDocuments (
    doclist As DedDocList,
    Optional restore As Boolean = false
)
public:
void ViewDocuments(
    DedDocList^ doclist,
    bool restore = false
)
member ViewDocuments :
        doclist : DedDocList *
        ?restore : bool
(* Defaults:
        let _restore = defaultArg restore false
*)
-> unit

Parametri

doclist DedDocList
Lista dei documenti da visualizzare.
restore Boolean (Optional)
Indica
Vedi anche

Documentazione

Classe DedDocControl
Overload di ViewDocuments
Namespace DedNet.Controls


Metodo DedDocControl.ViewDocuments(DedDocList, String, Boolean)

Metodo DedDocControlViewDocuments(DedDocList, String, Boolean)
Carica la lista dei documenti e li visualizza nel controllo in base alle impostazioni correnti. Se è già presente una selezione viene azzerata e ricaricata. Se viene passato null come argomento viene solo svuotato il contenuto del controllo.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ViewDocuments(
    DedDocList doclist,
    string config,
    bool restore = false
)
Public Sub ViewDocuments (
    doclist As DedDocList,
    config As String,
    Optional restore As Boolean = false
)
public:
void ViewDocuments(
    DedDocList^ doclist,
    String^ config,
    bool restore = false
)
member ViewDocuments :
        doclist : DedDocList *
        config : string *
        ?restore : bool
(* Defaults:
        let _restore = defaultArg restore false
*)
-> unit

Parametri

doclist DedDocList
Lista dei documenti da visualizzare.
config String
Nome del model state attivo
restore Boolean (Optional)
Indica
Vedi anche

Documentazione

Classe DedDocControl
Overload di ViewDocuments
Namespace DedNet.Controls


Eventi di DedDocControl

Il tipo DedDocControl espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | ContextMenuOpening | Evento su apertura del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | KeyPress | Pressione di un tasto.
Evento pubblico | MenuItemClicked | Evento su click su un elemento del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | MouseDoubleClick | Evento di doppio click.
Evento pubblico | NotifyDocStatusChanged | Evento lanciato sul cambio stato del documento
Evento pubblico | PaintEx | (Ereditato da XtraUserControl)
Evento pubblico | SelectionChanged | Evento lanciato sulla modifica della selezione dei documenti.
Torna su
Vedi anche

Documentazione

Classe DedDocControl
Namespace DedNet.Controls


Evento DedDocControl.KeyPress

Evento DedDocControlKeyPress
Pressione di un tasto.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event KeyPressEventHandler KeyPress
Public Event KeyPress As KeyPressEventHandler
public:
 event KeyPressEventHandler^ KeyPress {
    void add (KeyPressEventHandler^ value);
    void remove (KeyPressEventHandler^ value);
}
member KeyPress : IEvent<KeyPressEventHandler,
    KeyPressEventArgs>

Valore

KeyPressEventHandler
Vedi anche

Documentazione

Classe DedDocControl
Namespace DedNet.Controls


Evento DedDocControl.MouseDoubleClick

Evento DedDocControlMouseDoubleClick
Evento di doppio click.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event MouseEventHandler MouseDoubleClick
Public Event MouseDoubleClick As MouseEventHandler
public:
 event MouseEventHandler^ MouseDoubleClick {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}
member MouseDoubleClick : IEvent<MouseEventHandler,
    MouseEventArgs>

Valore

MouseEventHandler
Vedi anche

Documentazione

Classe DedDocControl
Namespace DedNet.Controls


Evento DedDocControl.NotifyDocStatusChanged

Evento DedDocControlNotifyDocStatusChanged
Evento lanciato sul cambio stato del documento

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DedDocControlNotifyDocStatusChangedEventArgs> NotifyDocStatusChanged
Public Event NotifyDocStatusChanged As EventHandler(Of DedDocControlNotifyDocStatusChangedEventArgs)
public:
 event EventHandler<DedDocControlNotifyDocStatusChangedEventArgs^>^ NotifyDocStatusChanged {
    void add (EventHandler<DedDocControlNotifyDocStatusChangedEventArgs^>^ value);
    void remove (EventHandler<DedDocControlNotifyDocStatusChangedEventArgs^>^ value);
}
member NotifyDocStatusChanged : IEvent<EventHandler<DedDocControlNotifyDocStatusChangedEventArgs>,
    DedDocControlNotifyDocStatusChangedEventArgs>

Valore

EventHandler DedDocControlNotifyDocStatusChangedEventArgs
Vedi anche

Documentazione

Classe DedDocControl
Namespace DedNet.Controls


Evento DedDocControl.SelectionChanged

Evento DedDocControlSelectionChanged
Evento lanciato sulla modifica della selezione dei documenti.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DedDocControlDedDocControlEventArgs> SelectionChanged
Public Event SelectionChanged As EventHandler(Of DedDocControlDedDocControlEventArgs)
public:
 event EventHandler<DedDocControlDedDocControlEventArgs^>^ SelectionChanged {
    void add (EventHandler<DedDocControlDedDocControlEventArgs^>^ value);
    void remove (EventHandler<DedDocControlDedDocControlEventArgs^>^ value);
}
member SelectionChanged : IEvent<EventHandler<DedDocControlDedDocControlEventArgs>,
    DedDocControlDedDocControlEventArgs>

Valore

EventHandler DedDocControlDedDocControlEventArgs
Vedi anche

Documentazione

Classe DedDocControl
Namespace DedNet.Controls


Campi di DedDocControl

Il tipo DedDocControl espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | _app | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Campo protetto | _RegistryBaseKey | Chiave nel registro di sistema di salvataggio impostazioni. (Ereditato da UserControlBase)
Torna su
Vedi anche

Documentazione

Classe DedDocControl
Namespace DedNet.Controls


Classe DedDocControl.DedDocControlEventArgs

Classe DedDocControlDedDocControlEventArgs
Gestisce gli eventi che necessitano di conoscere i documenti selezionati.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNet.ControlsDedDocControlDedDocControlEventArgs

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedDocControlEventArgs : EventArgs
Public Class DedDocControlEventArgs
    Inherits EventArgs
public ref class DedDocControlEventArgs : public EventArgs
type DedDocControlEventArgs =
    class
        inherit EventArgs
    end

Il tipo DedDocControlDedDocControlEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | SelectedDocuments | Restituisce la lista dei documenti correntemente selezionati nel controllo.
Proprietà pubblica | SelectedDocumentsConfig |
Proprietà pubblica | SelectedFolder | Restituisce la cartella selezionata.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Proprietà di DedDocControlEventArgs

Il tipo DedDocControlDedDocControlEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | SelectedDocuments | Restituisce la lista dei documenti correntemente selezionati nel controllo.
Proprietà pubblica | SelectedDocumentsConfig |
Proprietà pubblica | SelectedFolder | Restituisce la cartella selezionata.
Torna su
Vedi anche

Documentazione

Classe DedDocControlDedDocControlEventArgs
Namespace DedNet.Controls


Proprietà DedDocControl.DedDocControlEventArgs.SelectedDocuments

Proprietà DedDocControlDedDocControlEventArgsSelectedDocuments
Restituisce la lista dei documenti correntemente selezionati nel controllo.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocList SelectedDocuments { get; }
Public ReadOnly Property SelectedDocuments As DedDocList
    Get
public:
property DedDocList^ SelectedDocuments {
    DedDocList^ get ();
}
member SelectedDocuments : DedDocList with get

Valore della proprietà

DedDocList
Vedi anche

Documentazione

Classe DedDocControlDedDocControlEventArgs
Namespace DedNet.Controls


Proprietà DedDocControl.DedDocControlEventArgs.SelectedDocumentsConfig

Proprietà DedDocControlDedDocControlEventArgsSelectedDocumentsConfig

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<DedDoc, List<string>> SelectedDocumentsConfig { get; set; }
Public Property SelectedDocumentsConfig As Dictionary(Of DedDoc, List(Of String))
    Get
    Set
public:
property Dictionary<DedDoc^, List<String^>^>^ SelectedDocumentsConfig {
    Dictionary<DedDoc^, List<String^>^>^ get ();
    void set (Dictionary<DedDoc^, List<String^>^>^ value);
}
member SelectedDocumentsConfig : Dictionary<DedDoc, List<string>> with get, set

Valore della proprietà

Dictionary DedDoc, List String
Vedi anche

Documentazione

Classe DedDocControlDedDocControlEventArgs
Namespace DedNet.Controls


Proprietà DedDocControl.DedDocControlEventArgs.SelectedFolder

Proprietà DedDocControlDedDocControlEventArgsSelectedFolder
Restituisce la cartella selezionata.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> SelectedFolder { get; set; }
Public Property SelectedFolder As List(Of String)
    Get
    Set
public:
property List<String^>^ SelectedFolder {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
member SelectedFolder : List<string> with get, set

Valore della proprietà

List String
Vedi anche

Documentazione

Classe DedDocControlDedDocControlEventArgs
Namespace DedNet.Controls


Classe DedDocControl.NotifyDocStatusChangedEventArgs

Classe DedDocControlNotifyDocStatusChangedEventArgs
Gestisce gli eventi che necessitano di sapere se ad un determinato documento è stato cambiato lo stato documentale
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNet.ControlsDedDocControlNotifyDocStatusChangedEventArgs

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class NotifyDocStatusChangedEventArgs : EventArgs
Public Class NotifyDocStatusChangedEventArgs
    Inherits EventArgs
public ref class NotifyDocStatusChangedEventArgs : public EventArgs
type NotifyDocStatusChangedEventArgs =
    class
        inherit EventArgs
    end

Il tipo DedDocControlNotifyDocStatusChangedEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Doc | Documento selezionato
Proprietà pubblica | NeedRefresh | Indica se lo stato documentale è stato cambiato
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Proprietà di NotifyDocStatusChangedEventArgs

Il tipo DedDocControlNotifyDocStatusChangedEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Doc | Documento selezionato
Proprietà pubblica | NeedRefresh | Indica se lo stato documentale è stato cambiato
Torna su
Vedi anche

Documentazione

Classe DedDocControlNotifyDocStatusChangedEventArgs
Namespace DedNet.Controls


Proprietà DedDocControl.NotifyDocStatusChangedEventArgs.Doc

Proprietà DedDocControlNotifyDocStatusChangedEventArgsDoc
Documento selezionato

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDoc Doc { get; }
Public ReadOnly Property Doc As DedDoc
    Get
public:
property DedDoc^ Doc {
    DedDoc^ get ();
}
member Doc : DedDoc with get

Valore della proprietà

DedDoc
Vedi anche

Documentazione

Classe DedDocControlNotifyDocStatusChangedEventArgs
Namespace DedNet.Controls


Proprietà DedDocControl.NotifyDocStatusChangedEventArgs.NeedRefresh

Proprietà DedDocControlNotifyDocStatusChangedEventArgsNeedRefresh
Indica se lo stato documentale è stato cambiato

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool NeedRefresh { get; }
Public ReadOnly Property NeedRefresh As Boolean
    Get
public:
property bool NeedRefresh {
    bool get ();
}
member NeedRefresh : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDocControlNotifyDocStatusChangedEventArgs
Namespace DedNet.Controls


Classe DedDropDownButtonControl
Classe per gestire un controllo di tipo DropDown ( bottone con menu a tendina )
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
XtraUserControl
DedNet.ControlsUserControlBase
DedNet.ControlsDedDropDownButtonControl

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedDropDownButtonControl : UserControlBase
Public Class DedDropDownButtonControl
    Inherits UserControlBase
public ref class DedDropDownButtonControl : public UserControlBase
type DedDropDownButtonControl =
    class
        inherit UserControlBase
    end

Il tipo DedDropDownButtonControl espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedDropDownButtonControl | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Appearance | (Ereditato da XtraUserControl)
Proprietà pubblica | Application | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Proprietà pubblica | BackColor | (Ereditato da XtraUserControl)
Proprietà protetta | CheckDoubleScaling | (Ereditato da XtraUserControl)
Proprietà pubblica | ContextMenuControl | Restituisce il menu a tendina associto al pulsante.
Proprietà protetta | DefaultAppearance | (Ereditato da XtraUserControl)
Proprietà protetta | DirectXContainer | (Ereditato da XtraUserControl)
Proprietà pubblica | DropDownImage | Restituisce o imposta l'immagine principale del pulsante.
Proprietà pubblica | DropDownTag | Restituisce o imposta la proprietà Tag del pulsante.
Proprietà pubblica | DropDownText | Restituisce o imposta il testo principale del pulsante.
Proprietà pubblica | EnableIXtraResizeableControlInterfaceProxy | (Ereditato da XtraUserControl)
Proprietà pubblica | Font | (Ereditato da XtraUserControl)
Proprietà pubblica | ForeColor | (Ereditato da XtraUserControl)
Proprietà protetta | Helper | (Ereditato da XtraUserControl)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraUserControl)
Proprietà protetta | Painter | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleChildren | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleDPI | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraUserControl)
Proprietà protetta | ShouldCheckDpiScaleFactorOnParentChanged | (Ereditato da XtraUserControl)
Proprietà pubblica | Site | (Ereditato da XtraUserControl)
Proprietà pubblica | ToolTip | Restituisce o imposta il tooltip del pulsante.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AddItem | Aggiunge un elemento al menu contestuale.
Metodo protetto | BaseWndProc | (Ereditato da XtraUserControl)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraUserControl)
Metodo protetto | CreatePainter | (Ereditato da XtraUserControl)
Metodo protetto | Dispose | Liberare le risorse in uso. (Sovrascrive UserControlBaseDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraUserControl)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraUserControl)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraUserControl)
Metodo protetto | GetBackColor | (Ereditato da XtraUserControl)
Metodo protetto | GetBackgroundSkinElement | (Ereditato da XtraUserControl)
Metodo protetto | GetInnerIXtraResizableControl | (Ereditato da XtraUserControl)
Metodo pubblico | GetItem(Int32) | Restituisce l'item in base all'indice.
Metodo pubblico | GetItem(String) | Restituisce l'item in base al nome.
Metodo protetto | IsChildControlsRequiredScalingEnabled | (Ereditato da XtraUserControl)
Metodo protetto | IsParentHandleCreatedRecursive | (Ereditato da XtraUserControl)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraUserControl)
Metodo protetto | OnBackColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnButtonButtonClick | Chiama l'evento ButtonClick.
Metodo protetto | OnContextMenuOpening | Evento di apertura del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnControlAdded | (Ereditato da XtraUserControl)
Metodo protetto | OnControlRemoved | (Ereditato da XtraUserControl)
Metodo protetto | OnDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnFirstLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnForeColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleCreated | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraUserControl)
Metodo protetto | OnItemClick | Chiama l'evento ItemClick.
Metodo protetto | OnLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnMenuItemClicked | Evento di pressione di un comando del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnPaintCore | (Ereditato da XtraUserControl)
Metodo protetto | OnParentChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | OnSizeChanged | (Ereditato da XtraUserControl)
Metodo pubblico | PerformClick | Esegue il click sul pulsante.
Metodo protetto | RaisePaintExEvent | (Ereditato da XtraUserControl)
Metodo pubblico | ResetBackColor | (Ereditato da XtraUserControl)
Metodo pubblico | ResetForeColor | (Ereditato da XtraUserControl)
Metodo protetto | RestoreAutoScaleModeChangedByPM2 | (Ereditato da XtraUserControl)
Metodo protetto | ScaleControl | (Ereditato da XtraUserControl)
Metodo pubblico | SetCommandList | Rigenera il menu contestuale di questo controllo con la lista dei comandi passati. (Ereditato da UserControlBase)
Metodo protetto | SetVisibleCore | (Ereditato da XtraUserControl)
Metodo protetto | ShouldPaintTransparentBackground | (Ereditato da XtraUserControl)
Metodo protetto | ShouldUseDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | WndProc | (Ereditato da XtraUserControl)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | ButtonClick | Evanto associato al click del pulsante principale.
Evento pubblico | ContextMenuOpening | Evento su apertura del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | ItemClick | Evento associato al click di un elemento del menù a tendina.
Evento pubblico | MenuItemClicked | Evento su click su un elemento del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | PaintEx | (Ereditato da XtraUserControl)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | _app | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Campo protetto | _RegistryBaseKey | Chiave nel registro di sistema di salvataggio impostazioni. (Ereditato da UserControlBase)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore DedDropDownButtonControl
Costruttore unico.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDropDownButtonControl()
Public Sub New
public:
DedDropDownButtonControl()
new : unit -> DedDropDownButtonControl
Vedi anche

Documentazione

Classe DedDropDownButtonControl
Namespace DedNet.Controls


Proprietà di DedDropDownButtonControl

Il tipo DedDropDownButtonControl espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Appearance | (Ereditato da XtraUserControl)
Proprietà pubblica | Application | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Proprietà pubblica | BackColor | (Ereditato da XtraUserControl)
Proprietà protetta | CheckDoubleScaling | (Ereditato da XtraUserControl)
Proprietà pubblica | ContextMenuControl | Restituisce il menu a tendina associto al pulsante.
Proprietà protetta | DefaultAppearance | (Ereditato da XtraUserControl)
Proprietà protetta | DirectXContainer | (Ereditato da XtraUserControl)
Proprietà pubblica | DropDownImage | Restituisce o imposta l'immagine principale del pulsante.
Proprietà pubblica | DropDownTag | Restituisce o imposta la proprietà Tag del pulsante.
Proprietà pubblica | DropDownText | Restituisce o imposta il testo principale del pulsante.
Proprietà pubblica | EnableIXtraResizeableControlInterfaceProxy | (Ereditato da XtraUserControl)
Proprietà pubblica | Font | (Ereditato da XtraUserControl)
Proprietà pubblica | ForeColor | (Ereditato da XtraUserControl)
Proprietà protetta | Helper | (Ereditato da XtraUserControl)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraUserControl)
Proprietà protetta | Painter | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleChildren | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleDPI | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraUserControl)
Proprietà protetta | ShouldCheckDpiScaleFactorOnParentChanged | (Ereditato da XtraUserControl)
Proprietà pubblica | Site | (Ereditato da XtraUserControl)
Proprietà pubblica | ToolTip | Restituisce o imposta il tooltip del pulsante.
Torna su
Vedi anche

Documentazione

Classe DedDropDownButtonControl
Namespace DedNet.Controls


Proprietà DedDropDownButtonControl.ContextMenuControl

Proprietà DedDropDownButtonControlContextMenuControl
Restituisce il menu a tendina associto al pulsante.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public PopupMenu ContextMenuControl { get; }
Public ReadOnly Property ContextMenuControl As PopupMenu
    Get
public:
property PopupMenu^ ContextMenuControl {
    PopupMenu^ get ();
}
member ContextMenuControl : PopupMenu with get

Valore della proprietà

PopupMenu
Vedi anche

Documentazione

Classe DedDropDownButtonControl
Namespace DedNet.Controls


Proprietà DedDropDownButtonControl.DropDownImage

Proprietà DedDropDownButtonControlDropDownImage
Restituisce o imposta l'immagine principale del pulsante.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Image DropDownImage { get; set; }
Public Property DropDownImage As Image
    Get
    Set
public:
property Image^ DropDownImage {
    Image^ get ();
    void set (Image^ value);
}
member DropDownImage : Image with get, set

Valore della proprietà

Image
Vedi anche

Documentazione

Classe DedDropDownButtonControl
Namespace DedNet.Controls


Proprietà DedDropDownButtonControl.DropDownTag

Proprietà DedDropDownButtonControlDropDownTag
Restituisce o imposta la proprietà Tag del pulsante.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object DropDownTag { get; set; }
Public Property DropDownTag As Object
    Get
    Set
public:
property Object^ DropDownTag {
    Object^ get ();
    void set (Object^ value);
}
member DropDownTag : Object with get, set

Valore della proprietà

Object
Vedi anche

Documentazione

Classe DedDropDownButtonControl
Namespace DedNet.Controls


Proprietà DedDropDownButtonControl.DropDownText

Proprietà DedDropDownButtonControlDropDownText
Restituisce o imposta il testo principale del pulsante.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string DropDownText { get; set; }
Public Property DropDownText As String
    Get
    Set
public:
property String^ DropDownText {
    String^ get ();
    void set (String^ value);
}
member DropDownText : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedDropDownButtonControl
Namespace DedNet.Controls


Proprietà DedDropDownButtonControl.ToolTip

Proprietà DedDropDownButtonControlToolTip
Restituisce o imposta il tooltip del pulsante.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string ToolTip { get; set; }
Public Property ToolTip As String
    Get
    Set
public:
property String^ ToolTip {
    String^ get ();
    void set (String^ value);
}
member ToolTip : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedDropDownButtonControl
Namespace DedNet.Controls


Metodi di DedDropDownButtonControl

Il tipo DedDropDownButtonControl espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AddItem | Aggiunge un elemento al menu contestuale.
Metodo protetto | BaseWndProc | (Ereditato da XtraUserControl)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraUserControl)
Metodo protetto | CreatePainter | (Ereditato da XtraUserControl)
Metodo protetto | Dispose | Liberare le risorse in uso. (Sovrascrive UserControlBaseDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraUserControl)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraUserControl)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraUserControl)
Metodo protetto | GetBackColor | (Ereditato da XtraUserControl)
Metodo protetto | GetBackgroundSkinElement | (Ereditato da XtraUserControl)
Metodo protetto | GetInnerIXtraResizableControl | (Ereditato da XtraUserControl)
Metodo pubblico | GetItem(Int32) | Restituisce l'item in base all'indice.
Metodo pubblico | GetItem(String) | Restituisce l'item in base al nome.
Metodo protetto | IsChildControlsRequiredScalingEnabled | (Ereditato da XtraUserControl)
Metodo protetto | IsParentHandleCreatedRecursive | (Ereditato da XtraUserControl)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraUserControl)
Metodo protetto | OnBackColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnButtonButtonClick | Chiama l'evento ButtonClick.
Metodo protetto | OnContextMenuOpening | Evento di apertura del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnControlAdded | (Ereditato da XtraUserControl)
Metodo protetto | OnControlRemoved | (Ereditato da XtraUserControl)
Metodo protetto | OnDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnFirstLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnForeColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleCreated | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraUserControl)
Metodo protetto | OnItemClick | Chiama l'evento ItemClick.
Metodo protetto | OnLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnMenuItemClicked | Evento di pressione di un comando del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnPaintCore | (Ereditato da XtraUserControl)
Metodo protetto | OnParentChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | OnSizeChanged | (Ereditato da XtraUserControl)
Metodo pubblico | PerformClick | Esegue il click sul pulsante.
Metodo protetto | RaisePaintExEvent | (Ereditato da XtraUserControl)
Metodo pubblico | ResetBackColor | (Ereditato da XtraUserControl)
Metodo pubblico | ResetForeColor | (Ereditato da XtraUserControl)
Metodo protetto | RestoreAutoScaleModeChangedByPM2 | (Ereditato da XtraUserControl)
Metodo protetto | ScaleControl | (Ereditato da XtraUserControl)
Metodo pubblico | SetCommandList | Rigenera il menu contestuale di questo controllo con la lista dei comandi passati. (Ereditato da UserControlBase)
Metodo protetto | SetVisibleCore | (Ereditato da XtraUserControl)
Metodo protetto | ShouldPaintTransparentBackground | (Ereditato da XtraUserControl)
Metodo protetto | ShouldUseDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | WndProc | (Ereditato da XtraUserControl)
Torna su
Vedi anche

Documentazione

Classe DedDropDownButtonControl
Namespace DedNet.Controls


Metodo DedDropDownButtonControl.AddItem

Metodo DedDropDownButtonControlAddItem
Aggiunge un elemento al menu contestuale.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddItem(
    string itemName
)
Public Sub AddItem (
    itemName As String
)
public:
void AddItem(
    String^ itemName
)
member AddItem :
        itemName : string -> unit

Parametri

itemName String
Nome dell'elemento da aggiungere
Vedi anche

Documentazione

Classe DedDropDownButtonControl
Namespace DedNet.Controls


Metodo DedDropDownButtonControl.Dispose

Metodo DedDropDownButtonControlDispose
Liberare le risorse in uso.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
ha valore true se le risorse gestite devono essere eliminate, false in caso contrario.
Vedi anche

Documentazione

Classe DedDropDownButtonControl
Namespace DedNet.Controls


Metodo DedDropDownButtonControl.GetItem

Metodo DedDropDownButtonControlGetItem
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | GetItem(Int32) | Restituisce l'item in base all'indice.
Metodo pubblico | GetItem(String) | Restituisce l'item in base al nome.
Torna su
Vedi anche

Documentazione

Classe DedDropDownButtonControl
Namespace DedNet.Controls


Metodo DedDropDownButtonControl.GetItem(Int32)

Metodo DedDropDownButtonControlGetItem(Int32)
Restituisce l'item in base all'indice.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BarButtonItem GetItem(
    int idx
)
Public Function GetItem (
    idx As Integer
) As BarButtonItem
public:
BarButtonItem^ GetItem(
    int idx
)
member GetItem :
        idx : int -> BarButtonItem

Parametri

idx Int32
Indice dell'elemento

Valore di ritorno

BarButtonItem
Vedi anche

Documentazione

Classe DedDropDownButtonControl
Overload di GetItem
Namespace DedNet.Controls


Metodo DedDropDownButtonControl.GetItem(String)

Metodo DedDropDownButtonControlGetItem(String)
Restituisce l'item in base al nome.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BarButtonItem GetItem(
    string itemName
)
Public Function GetItem (
    itemName As String
) As BarButtonItem
public:
BarButtonItem^ GetItem(
    String^ itemName
)
member GetItem :
        itemName : string -> BarButtonItem

Parametri

itemName String
Nome dell'elemento

Valore di ritorno

BarButtonItem
Vedi anche

Documentazione

Classe DedDropDownButtonControl
Overload di GetItem
Namespace DedNet.Controls


Metodo DedDropDownButtonControl.OnButtonButtonClick

Metodo DedDropDownButtonControlOnButtonButtonClick
Chiama l'evento ButtonClick.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected void OnButtonButtonClick(
    Object sender
)
Protected Sub OnButtonButtonClick (
    sender As Object
)
protected:
void OnButtonButtonClick(
    Object^ sender
)
member OnButtonButtonClick :
        sender : Object -> unit

Parametri

sender Object
Vedi anche

Documentazione

Classe DedDropDownButtonControl
Namespace DedNet.Controls


Metodo DedDropDownButtonControl.OnItemClick

Metodo DedDropDownButtonControlOnItemClick
Chiama l'evento ItemClick.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected void OnItemClick(
    Object sender,
    ItemClickEventArgs e
)
Protected Sub OnItemClick (
    sender As Object,
    e As ItemClickEventArgs
)
protected:
void OnItemClick(
    Object^ sender,
    ItemClickEventArgs^ e
)
member OnItemClick :
        sender : Object *
        e : ItemClickEventArgs -> unit

Parametri

sender Object
e ItemClickEventArgs
Vedi anche

Documentazione

Classe DedDropDownButtonControl
Namespace DedNet.Controls


Metodo DedDropDownButtonControl.PerformClick

Metodo DedDropDownButtonControlPerformClick
Esegue il click sul pulsante.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void PerformClick()
Public Sub PerformClick
public:
void PerformClick()
member PerformClick : unit -> unit
Vedi anche

Documentazione

Classe DedDropDownButtonControl
Namespace DedNet.Controls


Eventi di DedDropDownButtonControl

Il tipo DedDropDownButtonControl espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | ButtonClick | Evanto associato al click del pulsante principale.
Evento pubblico | ContextMenuOpening | Evento su apertura del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | ItemClick | Evento associato al click di un elemento del menù a tendina.
Evento pubblico | MenuItemClicked | Evento su click su un elemento del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | PaintEx | (Ereditato da XtraUserControl)
Torna su
Vedi anche

Documentazione

Classe DedDropDownButtonControl
Namespace DedNet.Controls


Evento DedDropDownButtonControl.ButtonClick

Evento DedDropDownButtonControlButtonClick
Evanto associato al click del pulsante principale.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler ButtonClick
Public Event ButtonClick As EventHandler
public:
 event EventHandler^ ButtonClick {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member ButtonClick : IEvent<EventHandler,
    EventArgs>

Valore

EventHandler
Vedi anche

Documentazione

Classe DedDropDownButtonControl
Namespace DedNet.Controls


Evento DedDropDownButtonControl.ItemClick

Evento DedDropDownButtonControlItemClick
Evento associato al click di un elemento del menù a tendina.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<ItemClickEventArgs> ItemClick
Public Event ItemClick As EventHandler(Of ItemClickEventArgs)
public:
 event EventHandler<ItemClickEventArgs^>^ ItemClick {
    void add (EventHandler<ItemClickEventArgs^>^ value);
    void remove (EventHandler<ItemClickEventArgs^>^ value);
}
member ItemClick : IEvent<EventHandler<ItemClickEventArgs>,
    ItemClickEventArgs>

Valore

EventHandler ItemClickEventArgs
Vedi anche

Documentazione

Classe DedDropDownButtonControl
Namespace DedNet.Controls


Campi di DedDropDownButtonControl

Il tipo DedDropDownButtonControl espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | _app | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Campo protetto | _RegistryBaseKey | Chiave nel registro di sistema di salvataggio impostazioni. (Ereditato da UserControlBase)
Torna su
Vedi anche

Documentazione

Classe DedDropDownButtonControl
Namespace DedNet.Controls


Classe DedEcoViewControl
Controllo rappresentante gli ECO
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
XtraUserControl
DedNet.ControlsUserControlBase
DedNet.ControlsDedEcoViewControl

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedEcoViewControl : UserControlBase
Public Class DedEcoViewControl
    Inherits UserControlBase
public ref class DedEcoViewControl : public UserControlBase
type DedEcoViewControl =
    class
        inherit UserControlBase
    end

Il tipo DedEcoViewControl espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedEcoViewControl | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Appearance | (Ereditato da XtraUserControl)
Proprietà pubblica | Application | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Proprietà pubblica | BackColor | (Ereditato da XtraUserControl)
Proprietà protetta | CheckDoubleScaling | (Ereditato da XtraUserControl)
Proprietà pubblica | Comm | Commessa alla quale associare/visualizzare gli Eco.
Proprietà pubblica | Data | Anagrafica alla quale associare/visualizzare gli Eco.
Proprietà protetta | DefaultAppearance | (Ereditato da XtraUserControl)
Proprietà pubblica | DefaultECOType | Selezione tra ECO o ECR
Proprietà protetta | DirectXContainer | (Ereditato da XtraUserControl)
Proprietà pubblica | ECO | Eco correntemente selezionato.
Proprietà pubblica | EnableIXtraResizeableControlInterfaceProxy | (Ereditato da XtraUserControl)
Proprietà pubblica | Font | (Ereditato da XtraUserControl)
Proprietà pubblica | ForeColor | (Ereditato da XtraUserControl)
Proprietà protetta | Helper | (Ereditato da XtraUserControl)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraUserControl)
Proprietà protetta | Painter | (Ereditato da XtraUserControl)
Proprietà pubblica | RowHandle | Ritorna l'indice della riga correntemente selezionata.
Proprietà protetta | ScaleChildren | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleDPI | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraUserControl)
Proprietà protetta | ShouldCheckDpiScaleFactorOnParentChanged | (Ereditato da XtraUserControl)
Proprietà pubblica | Site | (Ereditato da XtraUserControl)
Proprietà pubblica | VisibilitySubMenuCreateEco | Property che se impostata a True mostra il submenu per la creazione di un Eco facendo selezionare l'anagrafica/commessa, altrimenti lo nasconde.
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | BaseWndProc | (Ereditato da XtraUserControl)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraUserControl)
Metodo protetto | CreatePainter | (Ereditato da XtraUserControl)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive UserControlBaseDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraUserControl)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraUserControl)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraUserControl)
Metodo protetto | GetBackColor | (Ereditato da XtraUserControl)
Metodo protetto | GetBackgroundSkinElement | (Ereditato da XtraUserControl)
Metodo protetto | GetInnerIXtraResizableControl | (Ereditato da XtraUserControl)
Metodo pubblico | Initialize | Metodo usato per caricare i dati a schermo.
Metodo pubblico | InsertEcoInGrid | Metodo che inserisce l'ECO nella griglia.
Metodo protetto | IsChildControlsRequiredScalingEnabled | (Ereditato da XtraUserControl)
Metodo protetto | IsParentHandleCreatedRecursive | (Ereditato da XtraUserControl)
Metodo pubblico | MakeContext | Metodo che crea il contesto da utilizzare con i vari comandi.
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraUserControl)
Metodo protetto | OnBackColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnContextMenuOpening | Evento di apertura del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnControlAdded | (Ereditato da XtraUserControl)
Metodo protetto | OnControlRemoved | (Ereditato da XtraUserControl)
Metodo protetto | OnDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnFirstLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnForeColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleCreated | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraUserControl)
Metodo protetto | OnLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnMenuItemClicked | Evento di pressione di un comando del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnPaintCore | (Ereditato da XtraUserControl)
Metodo protetto | OnParentChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | OnSizeChanged | (Ereditato da XtraUserControl)
Metodo protetto | RaisePaintExEvent | (Ereditato da XtraUserControl)
Metodo pubblico | ResetBackColor | (Ereditato da XtraUserControl)
Metodo pubblico | ResetForeColor | (Ereditato da XtraUserControl)
Metodo protetto | RestoreAutoScaleModeChangedByPM2 | (Ereditato da XtraUserControl)
Metodo pubblico | RestoreLayoutFromRegistry | Metodo che permette di caricare le impostazioni del layout dal registro.
Metodo pubblico | SaveLayoutToRegistry | Metodo che permette di salvare le impostazioni del layout nel registro.
Metodo protetto | ScaleControl | (Ereditato da XtraUserControl)
Metodo pubblico | SetCommandList | Rigenera il menu contestuale di questo controllo con la lista dei comandi passati.
Metodo protetto | SetVisibleCore | (Ereditato da XtraUserControl)
Metodo protetto | ShouldPaintTransparentBackground | (Ereditato da XtraUserControl)
Metodo protetto | ShouldUseDirectXPaint | (Ereditato da XtraUserControl)
Metodo pubblico | UpdateSelectedEcoInGrid | Metodo che aggiorna l'ECO (correntemente selezionato nella griglia) dopo l'esecuzione di un comando.
Metodo protetto | WndProc | (Ereditato da XtraUserControl)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | ContextMenuOpening | Evento su apertura del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | MenuItemClicked | Evento su click su un elemento del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | PaintEx | (Ereditato da XtraUserControl)
Evento pubblico | SelectionChanged | Evento di cambio selezione riga.
Torna su
Campi
 | Nome | Descrizione
Campo protetto | _app | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Campo protetto | _RegistryBaseKey | Chiave nel registro di sistema di salvataggio impostazioni. (Ereditato da UserControlBase)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore DedEcoViewControl
Costruttore unico.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEcoViewControl()
Public Sub New
public:
DedEcoViewControl()
new : unit -> DedEcoViewControl
Vedi anche

Documentazione

Classe DedEcoViewControl
Namespace DedNet.Controls


Proprietà di DedEcoViewControl

Il tipo DedEcoViewControl espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Appearance | (Ereditato da XtraUserControl)
Proprietà pubblica | Application | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Proprietà pubblica | BackColor | (Ereditato da XtraUserControl)
Proprietà protetta | CheckDoubleScaling | (Ereditato da XtraUserControl)
Proprietà pubblica | Comm | Commessa alla quale associare/visualizzare gli Eco.
Proprietà pubblica | Data | Anagrafica alla quale associare/visualizzare gli Eco.
Proprietà protetta | DefaultAppearance | (Ereditato da XtraUserControl)
Proprietà pubblica | DefaultECOType | Selezione tra ECO o ECR
Proprietà protetta | DirectXContainer | (Ereditato da XtraUserControl)
Proprietà pubblica | ECO | Eco correntemente selezionato.
Proprietà pubblica | EnableIXtraResizeableControlInterfaceProxy | (Ereditato da XtraUserControl)
Proprietà pubblica | Font | (Ereditato da XtraUserControl)
Proprietà pubblica | ForeColor | (Ereditato da XtraUserControl)
Proprietà protetta | Helper | (Ereditato da XtraUserControl)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraUserControl)
Proprietà protetta | Painter | (Ereditato da XtraUserControl)
Proprietà pubblica | RowHandle | Ritorna l'indice della riga correntemente selezionata.
Proprietà protetta | ScaleChildren | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleDPI | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraUserControl)
Proprietà protetta | ShouldCheckDpiScaleFactorOnParentChanged | (Ereditato da XtraUserControl)
Proprietà pubblica | Site | (Ereditato da XtraUserControl)
Proprietà pubblica | VisibilitySubMenuCreateEco | Property che se impostata a True mostra il submenu per la creazione di un Eco facendo selezionare l'anagrafica/commessa, altrimenti lo nasconde.
Torna su
Vedi anche

Documentazione

Classe DedEcoViewControl
Namespace DedNet.Controls


Proprietà DedEcoViewControl.Comm

Proprietà DedEcoViewControlComm
Commessa alla quale associare/visualizzare gli Eco.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedComm Comm { set; }
Public WriteOnly Property Comm As DedComm
    Set
public:
property DedComm^ Comm {
    void set (DedComm^ value);
}
member Comm : DedComm with set

Valore della proprietà

DedComm
Vedi anche

Documentazione

Classe DedEcoViewControl
Namespace DedNet.Controls


Proprietà DedEcoViewControl.Data

Proprietà DedEcoViewControlData
Anagrafica alla quale associare/visualizzare gli Eco.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { set; }
Public WriteOnly Property Data As DedData
    Set
public:
property DedData^ Data {
    void set (DedData^ value);
}
member Data : DedData with set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe DedEcoViewControl
Namespace DedNet.Controls


Proprietà DedEcoViewControl.DefaultECOType

Proprietà DedEcoViewControlDefaultECOType
Selezione tra ECO o ECR

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEcoEcoTypeEnum DefaultECOType { set; }
Public WriteOnly Property DefaultECOType As DedEcoEcoTypeEnum
    Set
public:
property DedEcoEcoTypeEnum DefaultECOType {
    void set (DedEcoEcoTypeEnum value);
}
member DefaultECOType : DedEcoEcoTypeEnum with set

Valore della proprietà

DedEcoEcoTypeEnum
Vedi anche

Documentazione

Classe DedEcoViewControl
Namespace DedNet.Controls


Proprietà DedEcoViewControl.ECO

Proprietà DedEcoViewControlECO
Eco correntemente selezionato.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEco ECO { get; }
Public ReadOnly Property ECO As DedEco
    Get
public:
property DedEco^ ECO {
    DedEco^ get ();
}
member ECO : DedEco with get

Valore della proprietà

DedEco
Vedi anche

Documentazione

Classe DedEcoViewControl
Namespace DedNet.Controls


Proprietà DedEcoViewControl.RowHandle

Proprietà DedEcoViewControlRowHandle
Ritorna l'indice della riga correntemente selezionata.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int RowHandle { get; set; }
Public Property RowHandle As Integer
    Get
    Set
public:
property int RowHandle {
    int get ();
    void set (int value);
}
member RowHandle : int with get, set

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe DedEcoViewControl
Namespace DedNet.Controls


Proprietà DedEcoViewControl.VisibilitySubMenuCreateEco

Proprietà DedEcoViewControlVisibilitySubMenuCreateEco
Property che se impostata a True mostra il submenu per la creazione di un Eco facendo selezionare l'anagrafica/commessa, altrimenti lo nasconde.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool VisibilitySubMenuCreateEco { set; }
Public WriteOnly Property VisibilitySubMenuCreateEco As Boolean
    Set
public:
property bool VisibilitySubMenuCreateEco {
    void set (bool value);
}
member VisibilitySubMenuCreateEco : bool with set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedEcoViewControl
Namespace DedNet.Controls


Metodi di DedEcoViewControl

Il tipo DedEcoViewControl espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | BaseWndProc | (Ereditato da XtraUserControl)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraUserControl)
Metodo protetto | CreatePainter | (Ereditato da XtraUserControl)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive UserControlBaseDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraUserControl)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraUserControl)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraUserControl)
Metodo protetto | GetBackColor | (Ereditato da XtraUserControl)
Metodo protetto | GetBackgroundSkinElement | (Ereditato da XtraUserControl)
Metodo protetto | GetInnerIXtraResizableControl | (Ereditato da XtraUserControl)
Metodo pubblico | Initialize | Metodo usato per caricare i dati a schermo.
Metodo pubblico | InsertEcoInGrid | Metodo che inserisce l'ECO nella griglia.
Metodo protetto | IsChildControlsRequiredScalingEnabled | (Ereditato da XtraUserControl)
Metodo protetto | IsParentHandleCreatedRecursive | (Ereditato da XtraUserControl)
Metodo pubblico | MakeContext | Metodo che crea il contesto da utilizzare con i vari comandi.
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraUserControl)
Metodo protetto | OnBackColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnContextMenuOpening | Evento di apertura del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnControlAdded | (Ereditato da XtraUserControl)
Metodo protetto | OnControlRemoved | (Ereditato da XtraUserControl)
Metodo protetto | OnDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnFirstLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnForeColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleCreated | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraUserControl)
Metodo protetto | OnLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnMenuItemClicked | Evento di pressione di un comando del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnPaintCore | (Ereditato da XtraUserControl)
Metodo protetto | OnParentChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | OnSizeChanged | (Ereditato da XtraUserControl)
Metodo protetto | RaisePaintExEvent | (Ereditato da XtraUserControl)
Metodo pubblico | ResetBackColor | (Ereditato da XtraUserControl)
Metodo pubblico | ResetForeColor | (Ereditato da XtraUserControl)
Metodo protetto | RestoreAutoScaleModeChangedByPM2 | (Ereditato da XtraUserControl)
Metodo pubblico | RestoreLayoutFromRegistry | Metodo che permette di caricare le impostazioni del layout dal registro.
Metodo pubblico | SaveLayoutToRegistry | Metodo che permette di salvare le impostazioni del layout nel registro.
Metodo protetto | ScaleControl | (Ereditato da XtraUserControl)
Metodo pubblico | SetCommandList | Rigenera il menu contestuale di questo controllo con la lista dei comandi passati.
Metodo protetto | SetVisibleCore | (Ereditato da XtraUserControl)
Metodo protetto | ShouldPaintTransparentBackground | (Ereditato da XtraUserControl)
Metodo protetto | ShouldUseDirectXPaint | (Ereditato da XtraUserControl)
Metodo pubblico | UpdateSelectedEcoInGrid | Metodo che aggiorna l'ECO (correntemente selezionato nella griglia) dopo l'esecuzione di un comando.
Metodo protetto | WndProc | (Ereditato da XtraUserControl)
Torna su
Vedi anche

Documentazione

Classe DedEcoViewControl
Namespace DedNet.Controls


Metodo DedEcoViewControl.Dispose

Metodo DedEcoViewControlDispose
Clean up any resources being used.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedEcoViewControl
Namespace DedNet.Controls


Metodo DedEcoViewControl.Initialize

Metodo DedEcoViewControlInitialize
Metodo usato per caricare i dati a schermo.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Initialize()
Public Sub Initialize
public:
void Initialize()
member Initialize : unit -> unit
Vedi anche

Documentazione

Classe DedEcoViewControl
Namespace DedNet.Controls


Metodo DedEcoViewControl.InsertEcoInGrid

Metodo DedEcoViewControlInsertEcoInGrid
Metodo che inserisce l'ECO nella griglia.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void InsertEcoInGrid(
    DedEco eco
)
Public Sub InsertEcoInGrid (
    eco As DedEco
)
public:
void InsertEcoInGrid(
    DedEco^ eco
)
member InsertEcoInGrid :
        eco : DedEco -> unit

Parametri

eco DedEco
Vedi anche

Documentazione

Classe DedEcoViewControl
Namespace DedNet.Controls


Metodo DedEcoViewControl.MakeContext

Metodo DedEcoViewControlMakeContext
Metodo che crea il contesto da utilizzare con i vari comandi.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommandContext MakeContext()
Public Function MakeContext As DedCommandContext
public:
DedCommandContext^ MakeContext()
member MakeContext : unit -> DedCommandContext

Valore di ritorno

DedCommandContext
Oggetto DedCommandContext.
Vedi anche

Documentazione

Classe DedEcoViewControl
Namespace DedNet.Controls


Metodo DedEcoViewControl.RestoreLayoutFromRegistry

Metodo DedEcoViewControlRestoreLayoutFromRegistry
Metodo che permette di caricare le impostazioni del layout dal registro.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void RestoreLayoutFromRegistry(
    string regKey
)
Public Sub RestoreLayoutFromRegistry (
    regKey As String
)
public:
void RestoreLayoutFromRegistry(
    String^ regKey
)
member RestoreLayoutFromRegistry :
        regKey : string -> unit

Parametri

regKey String
Path da dove leggere le impostazioni.
Vedi anche

Documentazione

Classe DedEcoViewControl
Namespace DedNet.Controls


Metodo DedEcoViewControl.SaveLayoutToRegistry

Metodo DedEcoViewControlSaveLayoutToRegistry
Metodo che permette di salvare le impostazioni del layout nel registro.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SaveLayoutToRegistry(
    string regKey
)
Public Sub SaveLayoutToRegistry (
    regKey As String
)
public:
void SaveLayoutToRegistry(
    String^ regKey
)
member SaveLayoutToRegistry :
        regKey : string -> unit

Parametri

regKey String
Path dove salvare le impostazioni.
Vedi anche

Documentazione

Classe DedEcoViewControl
Namespace DedNet.Controls


Metodo DedEcoViewControl.SetCommandList

Metodo DedEcoViewControlSetCommandList
Rigenera il menu contestuale di questo controllo con la lista dei comandi passati.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetCommandList(
    DedCommandList commandList,
    CommandContextEnum commandContext
)
Public Sub SetCommandList (
    commandList As DedCommandList,
    commandContext As CommandContextEnum
)
public:
void SetCommandList(
    DedCommandList^ commandList,
    CommandContextEnum commandContext
)
member SetCommandList :
        commandList : DedCommandList *
        commandContext : CommandContextEnum -> unit

Parametri

commandList DedCommandList
Lista completa dei comandi.
commandContext CommandContextEnum
Contesto da utilizzare per filtrare i comandi da inserire.
Note
Filtra i comandi in modo da aggiungere soltanto quelli coerenti con il contesto passato.
Vedi anche

Documentazione

Classe DedEcoViewControl
Namespace DedNet.Controls


Metodo DedEcoViewControl.UpdateSelectedEcoInGrid

Metodo DedEcoViewControlUpdateSelectedEcoInGrid
Metodo che aggiorna l'ECO (correntemente selezionato nella griglia) dopo l'esecuzione di un comando.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEco UpdateSelectedEcoInGrid()
Public Function UpdateSelectedEcoInGrid As DedEco
public:
DedEco^ UpdateSelectedEcoInGrid()
member UpdateSelectedEcoInGrid : unit -> DedEco

Valore di ritorno

DedEco
Vedi anche

Documentazione

Classe DedEcoViewControl
Namespace DedNet.Controls


Eventi di DedEcoViewControl

Il tipo DedEcoViewControl espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | ContextMenuOpening | Evento su apertura del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | MenuItemClicked | Evento su click su un elemento del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | PaintEx | (Ereditato da XtraUserControl)
Evento pubblico | SelectionChanged | Evento di cambio selezione riga.
Torna su
Vedi anche

Documentazione

Classe DedEcoViewControl
Namespace DedNet.Controls


Evento DedEcoViewControl.SelectionChanged

Evento DedEcoViewControlSelectionChanged
Evento di cambio selezione riga.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<EcoFocusChanged> SelectionChanged
Public Event SelectionChanged As EventHandler(Of EcoFocusChanged)
public:
 event EventHandler<EcoFocusChanged^>^ SelectionChanged {
    void add (EventHandler<EcoFocusChanged^>^ value);
    void remove (EventHandler<EcoFocusChanged^>^ value);
}
member SelectionChanged : IEvent<EventHandler<EcoFocusChanged>,
    EcoFocusChanged>

Valore

EventHandler EcoFocusChanged
Vedi anche

Documentazione

Classe DedEcoViewControl
Namespace DedNet.Controls


Campi di DedEcoViewControl

Il tipo DedEcoViewControl espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | _app | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Campo protetto | _RegistryBaseKey | Chiave nel registro di sistema di salvataggio impostazioni. (Ereditato da UserControlBase)
Torna su
Vedi anche

Documentazione

Classe DedEcoViewControl
Namespace DedNet.Controls


Classe DedEditAnagrControl
Controllo di editazione e visualizzazione degli attributi.
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
XtraUserControl
EditAttrControlBase
DedNet.ControlsDedEditAnagrControl

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedEditAnagrControl : EditAttrControlBase
Public Class DedEditAnagrControl
    Inherits EditAttrControlBase
public ref class DedEditAnagrControl : public EditAttrControlBase
type DedEditAnagrControl =
    class
        inherit EditAttrControlBase
    end

Il tipo DedEditAnagrControl espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedEditAnagrControl | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AnyValChar | (Ereditato da EditAttrControlBase)
Proprietà pubblica | Appearance | (Ereditato da XtraUserControl)
Proprietà pubblica | Application | Applicazione DedNet.
Proprietà pubblica | ApplyRule | Imposta / Restituisce se applicare le regole.
Proprietà pubblica | AsInDb | Indica se in fase di applicazione delle regole valutarlo con se fosse codificato o meno.
Proprietà pubblica | AttrList | Restituisce la lista degli attributi da visualizzare.
Proprietà pubblica | BackColor | (Ereditato da XtraUserControl)
Proprietà pubblica | CascadeAutocomplete | (Ereditato da EditAttrControlBase)
Proprietà protetta | CheckDoubleScaling | (Ereditato da XtraUserControl)
Proprietà pubblica | ColumnNome | (Ereditato da EditAttrControlBase)
Proprietà pubblica | CreatingAnagr | Indica se si tratta di una creazione di un'angrafica o meno.
Proprietà pubblica | CtrTab | (Ereditato da EditAttrControlBase)
Proprietà pubblica | DataSource | (Ereditato da EditAttrControlBase)
Proprietà pubblica | DbPathPicture | (Ereditato da EditAttrControlBase)
Proprietà pubblica | DedData | Anagrafica in visualizzazione/modifica.
Proprietà pubblica | DedType | Indica la famiglia letta dal DedData passato.
Proprietà protetta | DefaultAppearance | (Ereditato da XtraUserControl)
Proprietà protetta | DirectXContainer | (Ereditato da XtraUserControl)
Proprietà pubblica | DisableEditingForOnlyDbAttrs | Indica se abilitare o meno l'editazione per gli attributi marchiati come "Solo Db".
Proprietà pubblica | Editable | (Ereditato da EditAttrControlBase)
Proprietà pubblica | EditAllConfButtonDefintion | (Ereditato da EditAttrControlBase)
Proprietà pubblica | EditAllConfButtonEnabled | (Ereditato da EditAttrControlBase)
Proprietà pubblica | EditAllConfButtonVisible | (Ereditato da EditAttrControlBase)
Proprietà pubblica | EditAttrUpperize | (Ereditato da EditAttrControlBase)
Proprietà pubblica | EditButtonEnabled | (Ereditato da EditAttrControlBase)
Proprietà pubblica | EditButtonVisible | (Ereditato da EditAttrControlBase)
Proprietà pubblica | EnableIXtraResizeableControlInterfaceProxy | (Ereditato da XtraUserControl)
Proprietà pubblica | Font | (Ereditato da XtraUserControl)
Proprietà pubblica | ForeColor | (Ereditato da XtraUserControl)
Proprietà pubblica | Grid | (Ereditato da EditAttrControlBase)
Proprietà pubblica | GroupAttribute | (Ereditato da EditAttrControlBase)
Proprietà protetta | Helper | (Ereditato da XtraUserControl)
Proprietà pubblica | IsInitDataInEditMode | (Ereditato da EditAttrControlBase)
Proprietà pubblica | IsValid | (Ereditato da EditAttrControlBase)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraUserControl)
Proprietà pubblica | NumCharMemo | (Ereditato da EditAttrControlBase)
Proprietà protetta | Painter | (Ereditato da XtraUserControl)
Proprietà pubblica | PanelVisible | (Ereditato da EditAttrControlBase)
Proprietà pubblica | PopupMenu | (Ereditato da EditAttrControlBase)
Proprietà pubblica | RefreshButtonDefintion | (Ereditato da EditAttrControlBase)
Proprietà pubblica | RefreshButtonEnabled | (Ereditato da EditAttrControlBase)
Proprietà pubblica | RefreshButtonVisible | (Ereditato da EditAttrControlBase)
Proprietà pubblica | RegistryBaseDir | (Ereditato da EditAttrControlBase)
Proprietà pubblica | ReloadButtonDefintion | (Ereditato da EditAttrControlBase)
Proprietà pubblica | ReloadButtonEnabled | (Ereditato da EditAttrControlBase)
Proprietà pubblica | ReloadButtonVisible | (Ereditato da EditAttrControlBase)
Proprietà pubblica | RepItems | (Ereditato da EditAttrControlBase)
Proprietà pubblica | RevisionAnagr | Indica se si tratta di una creazione revisione o meno.
Proprietà protetta | ScaleChildren | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleDPI | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraUserControl)
Proprietà protetta | ShouldCheckDpiScaleFactorOnParentChanged | (Ereditato da XtraUserControl)
Proprietà pubblica | Site | (Ereditato da XtraUserControl)
Proprietà pubblica | ValidateAttr | (Ereditato da EditAttrControlBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AggiornaRegole | Aggiorna l'anagrafica applicando le regole con i nuovi dati anagrafici.
Metodo pubblico | AttrNameFromPrompt(String) | (Ereditato da EditAttrControlBase)
Metodo protetto | AttrNameFromPrompt(Object, AttrNameFromPromptEventArgs) | Evento che permette di ricavare il nome dell'attributo dal prompt
Metodo protetto | AttrValidation | Evento di validazione di un attributo.
Metodo protetto | AttrValueSet | Evento di set di un attributo.
Metodo protetto | BaseWndProc | (Ereditato da XtraUserControl)
Metodo pubblico | CategoryHasError | (Ereditato da EditAttrControlBase)
Metodo protetto | ClassListClick | Evento di pressione su un elemento del ClassList.
Metodo protetto | ClassListFill | Evento di riempimento del ClassList.
Metodo protetto | classListItemClick | (Ereditato da EditAttrControlBase)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraUserControl)
Metodo protetto | CreatePainter | (Ereditato da XtraUserControl)
Metodo protetto | DataInitializationDone | Evento di fine inizializzazione del datasource.
Metodo pubblico | DataSourceInit | (Ereditato da EditAttrControlBase)
Metodo protetto | DataSourceInitialization | Evento di inizializzazione del datasource. Crea la tabella da bindare.
Metodo protetto | DedEditAnagrControl_IsDirtyEvent | Override del metodo che imposta se il controllo è dirty.
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive EditAttrControlBase.Dispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraUserControl)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraUserControl)
Metodo pubblico | EnableDedContextMenu | Abilita il menu contestuale di questo controllo.
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraUserControl)
Metodo protetto | GetBackColor | (Ereditato da XtraUserControl)
Metodo protetto | GetBackgroundSkinElement | (Ereditato da XtraUserControl)
Metodo protetto | GetInnerIXtraResizableControl | (Ereditato da XtraUserControl)
Metodo pubblico | GetValue | (Ereditato da EditAttrControlBase)
Metodo pubblico | HasError | (Ereditato da EditAttrControlBase)
Metodo pubblico | ImpostaStatoPulsanti | (Ereditato da EditAttrControlBase)
Metodo pubblico | InitData | Inizializza il controllo in base ai parametri passati. Se si passa una anagrafica null o una lista di attributi null o vuota svuota completamente il controllo.
Metodo protetto | IsChildControlsRequiredScalingEnabled | (Ereditato da XtraUserControl)
Metodo pubblico | IsDirty | (Ereditato da EditAttrControlBase)
Metodo protetto | IsParentHandleCreatedRecursive | (Ereditato da XtraUserControl)
Metodo protetto | LabelTextSet | Evento di set del testo della label di informazioni.
Metodo protetto | LuaValidation | Evento che fa scattare la validazione Lua.
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraUserControl)
Metodo protetto | OnAttrNameFromPromptEvent | (Ereditato da EditAttrControlBase)
Metodo protetto | OnBackColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnButtonCancelClick | (Ereditato da EditAttrControlBase)
Metodo protetto | OnButtonEditClick | (Ereditato da EditAttrControlBase)
Metodo protetto | OnButtonOkClick | (Ereditato da EditAttrControlBase)
Metodo protetto | OnClassListFill | (Ereditato da EditAttrControlBase)
Metodo protetto | OnClassListItemClicked | (Ereditato da EditAttrControlBase)
Metodo protetto | OnControlAdded | (Ereditato da XtraUserControl)
Metodo protetto | OnControlRemoved | (Ereditato da XtraUserControl)
Metodo protetto | OnDataInitDone | (Ereditato da EditAttrControlBase)
Metodo protetto | OnDataSourceInit | (Ereditato da EditAttrControlBase)
Metodo protetto | OnDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnFirstLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnForeColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleCreated | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraUserControl)
Metodo protetto | OnIsDirty | (Ereditato da EditAttrControlBase)
Metodo protetto | OnLabelTextSet | (Ereditato da EditAttrControlBase)
Metodo protetto | OnLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnLuaValidating | (Ereditato da EditAttrControlBase)
Metodo protetto | OnMenuItemClicked | Fa scattare l'evento MenuItemClicked.
Metodo protetto | OnOrderTabPages | (Ereditato da EditAttrControlBase)
Metodo protetto | OnOverrideCellValueChanged | (Ereditato da EditAttrControlBase)
Metodo protetto | OnOverrideCustomDrawCell | (Ereditato da EditAttrControlBase)
Metodo protetto | OnOverrideImpostaStatoPulsanti | (Ereditato da EditAttrControlBase)
Metodo protetto | OnOverrideRowCellStyle | (Ereditato da EditAttrControlBase)
Metodo protetto | OnOverrideValidatingEditor | (Ereditato da EditAttrControlBase)
Metodo protetto | OnPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnPaintCore | (Ereditato da XtraUserControl)
Metodo protetto | OnParentChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnPopupOpening | (Ereditato da EditAttrControlBase)
Metodo protetto | OnPostButtonCancelClick | (Ereditato da EditAttrControlBase)
Metodo protetto | OnPostButtonOkClick | (Ereditato da EditAttrControlBase)
Metodo protetto | OnRepositoryBind | (Ereditato da EditAttrControlBase)
Metodo protetto | OnRulesImageChange | (Ereditato da EditAttrControlBase)
Metodo protetto | OnScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | OnSetAttrValue | (Ereditato da EditAttrControlBase)
Metodo protetto | OnSizeChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnValidateAttr | (Ereditato da EditAttrControlBase)
Metodo protetto | OnValueChanged | (Ereditato da EditAttrControlBase)
Metodo protetto | OrderTabPages | Evento che permette di riordinare la lista di pagine in base all'ordine delle categorie del DED.
Metodo protetto | OverrideCellValueChanged | Override dell'evento di CellValueChanged.
Metodo protetto | OverrideCustomDrawCell | Evento di Override del draw delle celle.
Metodo pubblico | OverrideLabelTextCursor | (Ereditato da EditAttrControlBase)
Metodo protetto | OverrideRepositoryBind | Override del bind del repository. Permette di modificarne le proprietà prima che venga bindato alla cella.
Metodo protetto | OverrideRowCellStyle | Override dell'aspetto delle celle (colore di sfondo e testo).
Metodo protetto | OverrideValidatingEditor | Override della validazione del contenuto di un editor.
Metodo pubblico | PerformCancelClick | (Ereditato da EditAttrControlBase)
Metodo pubblico | PerformEditClick | (Ereditato da EditAttrControlBase)
Metodo pubblico | PerformOkClick | (Ereditato da EditAttrControlBase)
Metodo pubblico | PerformPostCancelClick | (Ereditato da EditAttrControlBase)
Metodo pubblico | PerformPostOkClick | (Ereditato da EditAttrControlBase)
Metodo protetto | PopupMenuItemClicked | Evento di pressione di un elemento del menù contestuale. Fa scattare il comando selezionato.
Metodo protetto | PopupMenuOpening | Evento di apertura del menù contestuale.
Metodo protetto | RaisePaintExEvent | (Ereditato da XtraUserControl)
Metodo pubblico | RefreshData |
Metodo pubblico | ResetBackColor | (Ereditato da XtraUserControl)
Metodo pubblico | ResetForeColor | (Ereditato da XtraUserControl)
Metodo protetto | RestoreAutoScaleModeChangedByPM2 | (Ereditato da XtraUserControl)
Metodo pubblico | RestoreLayoutFromRegistry | (Ereditato da EditAttrControlBase)
Metodo protetto | RulesImageChange | Evento che cambia l'immagine del PictureEdit se è presente una regola associata all'attributo.
Metodo pubblico | SaveLayoutToRegistry | (Ereditato da EditAttrControlBase)
Metodo protetto | ScaleControl | (Ereditato da XtraUserControl)
Metodo pubblico | SetValue | (Ereditato da EditAttrControlBase)
Metodo protetto | SetVisibleCore | (Ereditato da XtraUserControl)
Metodo protetto | ShouldPaintTransparentBackground | (Ereditato da XtraUserControl)
Metodo protetto | ShouldUseDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | UpdateGridDataSource | (Ereditato da EditAttrControlBase)
Metodo pubblico | ValidateLuaEvent | (Ereditato da EditAttrControlBase)
Metodo protetto | WndProc | (Ereditato da XtraUserControl)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | AttrNameFromPromptEvent | (Ereditato da EditAttrControlBase)
Evento pubblico | ButtonCancelClick | (Ereditato da EditAttrControlBase)
Evento pubblico | ButtonEditClick | (Ereditato da EditAttrControlBase)
Evento pubblico | ButtonOkClick | (Ereditato da EditAttrControlBase)
Evento pubblico | ClassListFillEvent | (Ereditato da EditAttrControlBase)
Evento pubblico | ClassListItemClickedEvent | (Ereditato da EditAttrControlBase)
Evento pubblico | DataInitDoneEvent | (Ereditato da EditAttrControlBase)
Evento pubblico | DataSourceInitEvent | (Ereditato da EditAttrControlBase)
Evento pubblico | IsDirtyEvent | (Ereditato da EditAttrControlBase)
Evento pubblico | LabelTextSetEvent | (Ereditato da EditAttrControlBase)
Evento pubblico | LuaValidatingEvent | (Ereditato da EditAttrControlBase)
Evento pubblico | MenuItemClicked | Evento su click su un elemento del menu contestuale.
Evento pubblico | OrderTabPagesEvent | (Ereditato da EditAttrControlBase)
Evento pubblico | OverrideCellValueChangedEvent | (Ereditato da EditAttrControlBase)
Evento pubblico | OverrideCustomDrawCellEvent | (Ereditato da EditAttrControlBase)
Evento pubblico | OverrideImpostaStatoPulsantiEvent | (Ereditato da EditAttrControlBase)
Evento pubblico | OverrideRowCellStyleEvent | (Ereditato da EditAttrControlBase)
Evento pubblico | OverrideValidatingEditorEvent | (Ereditato da EditAttrControlBase)
Evento pubblico | PaintEx | (Ereditato da XtraUserControl)
Evento pubblico | PopupOpeningEvent | (Ereditato da EditAttrControlBase)
Evento pubblico | PostButtonCancelClick | (Ereditato da EditAttrControlBase)
Evento pubblico | PostButtonOkClick | (Ereditato da EditAttrControlBase)
Evento pubblico | RepositoryBindEvent | (Ereditato da EditAttrControlBase)
Evento pubblico | RulesImageChangeEvent | (Ereditato da EditAttrControlBase)
Evento pubblico | SetAttrValueEvent | (Ereditato da EditAttrControlBase)
Evento pubblico | ValidateAttrEvent | (Ereditato da EditAttrControlBase)
Evento pubblico | ValueChanged | (Ereditato da EditAttrControlBase)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore DedEditAnagrControl
Costruttore unico.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEditAnagrControl()
Public Sub New
public:
DedEditAnagrControl()
new : unit -> DedEditAnagrControl
Vedi anche

Documentazione

Classe DedEditAnagrControl
Namespace DedNet.Controls


Proprietà di DedEditAnagrControl

Il tipo DedEditAnagrControl espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AnyValChar | (Ereditato da EditAttrControlBase)
Proprietà pubblica | Appearance | (Ereditato da XtraUserControl)
Proprietà pubblica | Application | Applicazione DedNet.
Proprietà pubblica | ApplyRule | Imposta / Restituisce se applicare le regole.
Proprietà pubblica | AsInDb | Indica se in fase di applicazione delle regole valutarlo con se fosse codificato o meno.
Proprietà pubblica | AttrList | Restituisce la lista degli attributi da visualizzare.
Proprietà pubblica | BackColor | (Ereditato da XtraUserControl)
Proprietà pubblica | CascadeAutocomplete | (Ereditato da EditAttrControlBase)
Proprietà protetta | CheckDoubleScaling | (Ereditato da XtraUserControl)
Proprietà pubblica | ColumnNome | (Ereditato da EditAttrControlBase)
Proprietà pubblica | CreatingAnagr | Indica se si tratta di una creazione di un'angrafica o meno.
Proprietà pubblica | CtrTab | (Ereditato da EditAttrControlBase)
Proprietà pubblica | DataSource | (Ereditato da EditAttrControlBase)
Proprietà pubblica | DbPathPicture | (Ereditato da EditAttrControlBase)
Proprietà pubblica | DedData | Anagrafica in visualizzazione/modifica.
Proprietà pubblica | DedType | Indica la famiglia letta dal DedData passato.
Proprietà protetta | DefaultAppearance | (Ereditato da XtraUserControl)
Proprietà protetta | DirectXContainer | (Ereditato da XtraUserControl)
Proprietà pubblica | DisableEditingForOnlyDbAttrs | Indica se abilitare o meno l'editazione per gli attributi marchiati come "Solo Db".
Proprietà pubblica | Editable | (Ereditato da EditAttrControlBase)
Proprietà pubblica | EditAllConfButtonDefintion | (Ereditato da EditAttrControlBase)
Proprietà pubblica | EditAllConfButtonEnabled | (Ereditato da EditAttrControlBase)
Proprietà pubblica | EditAllConfButtonVisible | (Ereditato da EditAttrControlBase)
Proprietà pubblica | EditAttrUpperize | (Ereditato da EditAttrControlBase)
Proprietà pubblica | EditButtonEnabled | (Ereditato da EditAttrControlBase)
Proprietà pubblica | EditButtonVisible | (Ereditato da EditAttrControlBase)
Proprietà pubblica | EnableIXtraResizeableControlInterfaceProxy | (Ereditato da XtraUserControl)
Proprietà pubblica | Font | (Ereditato da XtraUserControl)
Proprietà pubblica | ForeColor | (Ereditato da XtraUserControl)
Proprietà pubblica | Grid | (Ereditato da EditAttrControlBase)
Proprietà pubblica | GroupAttribute | (Ereditato da EditAttrControlBase)
Proprietà protetta | Helper | (Ereditato da XtraUserControl)
Proprietà pubblica | IsInitDataInEditMode | (Ereditato da EditAttrControlBase)
Proprietà pubblica | IsValid | (Ereditato da EditAttrControlBase)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraUserControl)
Proprietà pubblica | NumCharMemo | (Ereditato da EditAttrControlBase)
Proprietà protetta | Painter | (Ereditato da XtraUserControl)
Proprietà pubblica | PanelVisible | (Ereditato da EditAttrControlBase)
Proprietà pubblica | PopupMenu | (Ereditato da EditAttrControlBase)
Proprietà pubblica | RefreshButtonDefintion | (Ereditato da EditAttrControlBase)
Proprietà pubblica | RefreshButtonEnabled | (Ereditato da EditAttrControlBase)
Proprietà pubblica | RefreshButtonVisible | (Ereditato da EditAttrControlBase)
Proprietà pubblica | RegistryBaseDir | (Ereditato da EditAttrControlBase)
Proprietà pubblica | ReloadButtonDefintion | (Ereditato da EditAttrControlBase)
Proprietà pubblica | ReloadButtonEnabled | (Ereditato da EditAttrControlBase)
Proprietà pubblica | ReloadButtonVisible | (Ereditato da EditAttrControlBase)
Proprietà pubblica | RepItems | (Ereditato da EditAttrControlBase)
Proprietà pubblica | RevisionAnagr | Indica se si tratta di una creazione revisione o meno.
Proprietà protetta | ScaleChildren | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleDPI | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraUserControl)
Proprietà protetta | ShouldCheckDpiScaleFactorOnParentChanged | (Ereditato da XtraUserControl)
Proprietà pubblica | Site | (Ereditato da XtraUserControl)
Proprietà pubblica | ValidateAttr | (Ereditato da EditAttrControlBase)
Torna su
Vedi anche

Documentazione

Classe DedEditAnagrControl
Namespace DedNet.Controls


Proprietà DedEditAnagrControl.Application

Proprietà DedEditAnagrControlApplication
Applicazione DedNet.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedNetApplication Application { get; }
Public ReadOnly Property Application As DedNetApplication
    Get
public:
property DedNetApplication^ Application {
    DedNetApplication^ get ();
}
member Application : DedNetApplication with get

Valore della proprietà

DedNetApplication
Vedi anche

Documentazione

Classe DedEditAnagrControl
Namespace DedNet.Controls


Proprietà DedEditAnagrControl.ApplyRule

Proprietà DedEditAnagrControlApplyRule
Imposta / Restituisce se applicare le regole.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ApplyRule { get; set; }
Public Property ApplyRule As Boolean
    Get
    Set
public:
property bool ApplyRule {
    bool get ();
    void set (bool value);
}
member ApplyRule : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedEditAnagrControl
Namespace DedNet.Controls


Proprietà DedEditAnagrControl.AsInDb

Proprietà DedEditAnagrControlAsInDb
Indica se in fase di applicazione delle regole valutarlo con se fosse codificato o meno.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AsInDb { get; set; }
Public Property AsInDb As Boolean
    Get
    Set
public:
property bool AsInDb {
    bool get ();
    void set (bool value);
}
member AsInDb : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedEditAnagrControl
Namespace DedNet.Controls


Proprietà DedEditAnagrControl.AttrList

Proprietà DedEditAnagrControlAttrList
Restituisce la lista degli attributi da visualizzare.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList AttrList { get; }
Public ReadOnly Property AttrList As DedAttrList
    Get
public:
property DedAttrList^ AttrList {
    DedAttrList^ get ();
}
member AttrList : DedAttrList with get

Valore della proprietà

DedAttrList
Vedi anche

Documentazione

Classe DedEditAnagrControl
Namespace DedNet.Controls


Proprietà DedEditAnagrControl.CreatingAnagr

Proprietà DedEditAnagrControlCreatingAnagr
Indica se si tratta di una creazione di un'angrafica o meno.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CreatingAnagr { get; set; }
Public Property CreatingAnagr As Boolean
    Get
    Set
public:
property bool CreatingAnagr {
    bool get ();
    void set (bool value);
}
member CreatingAnagr : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedEditAnagrControl
Namespace DedNet.Controls


Proprietà DedEditAnagrControl.DedData

Proprietà DedEditAnagrControlDedData
Anagrafica in visualizzazione/modifica.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public IDedEditable DedData { get; set; }
Public Property DedData As IDedEditable
    Get
    Set
public:
property IDedEditable^ DedData {
    IDedEditable^ get ();
    void set (IDedEditable^ value);
}
member DedData : IDedEditable with get, set

Valore della proprietà

IDedEditable
Vedi anche

Documentazione

Classe DedEditAnagrControl
Namespace DedNet.Controls


Proprietà DedEditAnagrControl.DedType

Proprietà DedEditAnagrControlDedType
Indica la famiglia letta dal DedData passato.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeBase DedType { get; set; }
Public Property DedType As DedTypeBase
    Get
    Set
public:
property DedTypeBase^ DedType {
    DedTypeBase^ get ();
    void set (DedTypeBase^ value);
}
member DedType : DedTypeBase with get, set

Valore della proprietà

DedTypeBase
Vedi anche

Documentazione

Classe DedEditAnagrControl
Namespace DedNet.Controls


Proprietà DedEditAnagrControl.DisableEditingForOnlyDbAttrs

Proprietà DedEditAnagrControlDisableEditingForOnlyDbAttrs
Indica se abilitare o meno l'editazione per gli attributi marchiati come "Solo Db".

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool DisableEditingForOnlyDbAttrs { get; set; }
Public Property DisableEditingForOnlyDbAttrs As Boolean
    Get
    Set
public:
property bool DisableEditingForOnlyDbAttrs {
    bool get ();
    void set (bool value);
}
member DisableEditingForOnlyDbAttrs : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedEditAnagrControl
Namespace DedNet.Controls


Proprietà DedEditAnagrControl.RevisionAnagr

Proprietà DedEditAnagrControlRevisionAnagr
Indica se si tratta di una creazione revisione o meno.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool RevisionAnagr { get; set; }
Public Property RevisionAnagr As Boolean
    Get
    Set
public:
property bool RevisionAnagr {
    bool get ();
    void set (bool value);
}
member RevisionAnagr : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedEditAnagrControl
Namespace DedNet.Controls


Metodi di DedEditAnagrControl

Il tipo DedEditAnagrControl espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AggiornaRegole | Aggiorna l'anagrafica applicando le regole con i nuovi dati anagrafici.
Metodo pubblico | AttrNameFromPrompt(String) | (Ereditato da EditAttrControlBase)
Metodo protetto | AttrNameFromPrompt(Object, AttrNameFromPromptEventArgs) | Evento che permette di ricavare il nome dell'attributo dal prompt
Metodo protetto | AttrValidation | Evento di validazione di un attributo.
Metodo protetto | AttrValueSet | Evento di set di un attributo.
Metodo protetto | BaseWndProc | (Ereditato da XtraUserControl)
Metodo pubblico | CategoryHasError | (Ereditato da EditAttrControlBase)
Metodo protetto | ClassListClick | Evento di pressione su un elemento del ClassList.
Metodo protetto | ClassListFill | Evento di riempimento del ClassList.
Metodo protetto | classListItemClick | (Ereditato da EditAttrControlBase)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraUserControl)
Metodo protetto | CreatePainter | (Ereditato da XtraUserControl)
Metodo protetto | DataInitializationDone | Evento di fine inizializzazione del datasource.
Metodo pubblico | DataSourceInit | (Ereditato da EditAttrControlBase)
Metodo protetto | DataSourceInitialization | Evento di inizializzazione del datasource. Crea la tabella da bindare.
Metodo protetto | DedEditAnagrControl_IsDirtyEvent | Override del metodo che imposta se il controllo è dirty.
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive EditAttrControlBase.Dispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraUserControl)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraUserControl)
Metodo pubblico | EnableDedContextMenu | Abilita il menu contestuale di questo controllo.
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraUserControl)
Metodo protetto | GetBackColor | (Ereditato da XtraUserControl)
Metodo protetto | GetBackgroundSkinElement | (Ereditato da XtraUserControl)
Metodo protetto | GetInnerIXtraResizableControl | (Ereditato da XtraUserControl)
Metodo pubblico | GetValue | (Ereditato da EditAttrControlBase)
Metodo pubblico | HasError | (Ereditato da EditAttrControlBase)
Metodo pubblico | ImpostaStatoPulsanti | (Ereditato da EditAttrControlBase)
Metodo pubblico | InitData | Inizializza il controllo in base ai parametri passati. Se si passa una anagrafica null o una lista di attributi null o vuota svuota completamente il controllo.
Metodo protetto | IsChildControlsRequiredScalingEnabled | (Ereditato da XtraUserControl)
Metodo pubblico | IsDirty | (Ereditato da EditAttrControlBase)
Metodo protetto | IsParentHandleCreatedRecursive | (Ereditato da XtraUserControl)
Metodo protetto | LabelTextSet | Evento di set del testo della label di informazioni.
Metodo protetto | LuaValidation | Evento che fa scattare la validazione Lua.
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraUserControl)
Metodo protetto | OnAttrNameFromPromptEvent | (Ereditato da EditAttrControlBase)
Metodo protetto | OnBackColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnButtonCancelClick | (Ereditato da EditAttrControlBase)
Metodo protetto | OnButtonEditClick | (Ereditato da EditAttrControlBase)
Metodo protetto | OnButtonOkClick | (Ereditato da EditAttrControlBase)
Metodo protetto | OnClassListFill | (Ereditato da EditAttrControlBase)
Metodo protetto | OnClassListItemClicked | (Ereditato da EditAttrControlBase)
Metodo protetto | OnControlAdded | (Ereditato da XtraUserControl)
Metodo protetto | OnControlRemoved | (Ereditato da XtraUserControl)
Metodo protetto | OnDataInitDone | (Ereditato da EditAttrControlBase)
Metodo protetto | OnDataSourceInit | (Ereditato da EditAttrControlBase)
Metodo protetto | OnDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnFirstLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnForeColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleCreated | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraUserControl)
Metodo protetto | OnIsDirty | (Ereditato da EditAttrControlBase)
Metodo protetto | OnLabelTextSet | (Ereditato da EditAttrControlBase)
Metodo protetto | OnLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnLuaValidating | (Ereditato da EditAttrControlBase)
Metodo protetto | OnMenuItemClicked | Fa scattare l'evento MenuItemClicked.
Metodo protetto | OnOrderTabPages | (Ereditato da EditAttrControlBase)
Metodo protetto | OnOverrideCellValueChanged | (Ereditato da EditAttrControlBase)
Metodo protetto | OnOverrideCustomDrawCell | (Ereditato da EditAttrControlBase)
Metodo protetto | OnOverrideImpostaStatoPulsanti | (Ereditato da EditAttrControlBase)
Metodo protetto | OnOverrideRowCellStyle | (Ereditato da EditAttrControlBase)
Metodo protetto | OnOverrideValidatingEditor | (Ereditato da EditAttrControlBase)
Metodo protetto | OnPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnPaintCore | (Ereditato da XtraUserControl)
Metodo protetto | OnParentChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnPopupOpening | (Ereditato da EditAttrControlBase)
Metodo protetto | OnPostButtonCancelClick | (Ereditato da EditAttrControlBase)
Metodo protetto | OnPostButtonOkClick | (Ereditato da EditAttrControlBase)
Metodo protetto | OnRepositoryBind | (Ereditato da EditAttrControlBase)
Metodo protetto | OnRulesImageChange | (Ereditato da EditAttrControlBase)
Metodo protetto | OnScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | OnSetAttrValue | (Ereditato da EditAttrControlBase)
Metodo protetto | OnSizeChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnValidateAttr | (Ereditato da EditAttrControlBase)
Metodo protetto | OnValueChanged | (Ereditato da EditAttrControlBase)
Metodo protetto | OrderTabPages | Evento che permette di riordinare la lista di pagine in base all'ordine delle categorie del DED.
Metodo protetto | OverrideCellValueChanged | Override dell'evento di CellValueChanged.
Metodo protetto | OverrideCustomDrawCell | Evento di Override del draw delle celle.
Metodo pubblico | OverrideLabelTextCursor | (Ereditato da EditAttrControlBase)
Metodo protetto | OverrideRepositoryBind | Override del bind del repository. Permette di modificarne le proprietà prima che venga bindato alla cella.
Metodo protetto | OverrideRowCellStyle | Override dell'aspetto delle celle (colore di sfondo e testo).
Metodo protetto | OverrideValidatingEditor | Override della validazione del contenuto di un editor.
Metodo pubblico | PerformCancelClick | (Ereditato da EditAttrControlBase)
Metodo pubblico | PerformEditClick | (Ereditato da EditAttrControlBase)
Metodo pubblico | PerformOkClick | (Ereditato da EditAttrControlBase)
Metodo pubblico | PerformPostCancelClick | (Ereditato da EditAttrControlBase)
Metodo pubblico | PerformPostOkClick | (Ereditato da EditAttrControlBase)
Metodo protetto | PopupMenuItemClicked | Evento di pressione di un elemento del menù contestuale. Fa scattare il comando selezionato.
Metodo protetto | PopupMenuOpening | Evento di apertura del menù contestuale.
Metodo protetto | RaisePaintExEvent | (Ereditato da XtraUserControl)
Metodo pubblico | RefreshData |
Metodo pubblico | ResetBackColor | (Ereditato da XtraUserControl)
Metodo pubblico | ResetForeColor | (Ereditato da XtraUserControl)
Metodo protetto | RestoreAutoScaleModeChangedByPM2 | (Ereditato da XtraUserControl)
Metodo pubblico | RestoreLayoutFromRegistry | (Ereditato da EditAttrControlBase)
Metodo protetto | RulesImageChange | Evento che cambia l'immagine del PictureEdit se è presente una regola associata all'attributo.
Metodo pubblico | SaveLayoutToRegistry | (Ereditato da EditAttrControlBase)
Metodo protetto | ScaleControl | (Ereditato da XtraUserControl)
Metodo pubblico | SetValue | (Ereditato da EditAttrControlBase)
Metodo protetto | SetVisibleCore | (Ereditato da XtraUserControl)
Metodo protetto | ShouldPaintTransparentBackground | (Ereditato da XtraUserControl)
Metodo protetto | ShouldUseDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | UpdateGridDataSource | (Ereditato da EditAttrControlBase)
Metodo pubblico | ValidateLuaEvent | (Ereditato da EditAttrControlBase)
Metodo protetto | WndProc | (Ereditato da XtraUserControl)
Torna su
Vedi anche

Documentazione

Classe DedEditAnagrControl
Namespace DedNet.Controls


Metodo DedEditAnagrControl.AggiornaRegole

Metodo DedEditAnagrControlAggiornaRegole
Aggiorna l'anagrafica applicando le regole con i nuovi dati anagrafici.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AggiornaRegole()
Public Sub AggiornaRegole
public:
void AggiornaRegole()
member AggiornaRegole : unit -> unit
Vedi anche

Documentazione

Classe DedEditAnagrControl
Namespace DedNet.Controls


Metodo DedEditAnagrControl.AttrNameFromPrompt

Metodo DedEditAnagrControlAttrNameFromPrompt
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AttrNameFromPrompt(String) |
Metodo protetto | AttrNameFromPrompt(Object, AttrNameFromPromptEventArgs) | Evento che permette di ricavare il nome dell'attributo dal prompt
Torna su
Vedi anche

Documentazione

Classe DedEditAnagrControl
Namespace DedNet.Controls


Metodo DedEditAnagrControl.AttrNameFromPrompt(Object, AttrNameFromPromptEventArgs)

Metodo DedEditAnagrControlAttrNameFromPrompt(Object, AttrNameFromPromptEventArgs)
Evento che permette di ricavare il nome dell'attributo dal prompt

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void AttrNameFromPrompt(
    Object sender,
    AttrNameFromPromptEventArgs e
)
Protected Friend Sub AttrNameFromPrompt (
    sender As Object,
    e As AttrNameFromPromptEventArgs
)
protected public:
void AttrNameFromPrompt(
    Object^ sender,
    AttrNameFromPromptEventArgs^ e
)
member AttrNameFromPrompt :
        sender : Object *
        e : AttrNameFromPromptEventArgs -> unit

Parametri

sender Object
e AttrNameFromPromptEventArgs
Vedi anche

Documentazione

Classe DedEditAnagrControl
Overload di AttrNameFromPrompt
Namespace DedNet.Controls


Metodo DedEditAnagrControl.AttrValidation

Metodo DedEditAnagrControlAttrValidation
Evento di validazione di un attributo.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void AttrValidation(
    Object sender,
    ValidateAttrEventArgs e
)
Protected Friend Sub AttrValidation (
    sender As Object,
    e As ValidateAttrEventArgs
)
protected public:
void AttrValidation(
    Object^ sender,
    ValidateAttrEventArgs^ e
)
member AttrValidation :
        sender : Object *
        e : ValidateAttrEventArgs -> unit

Parametri

sender Object
e ValidateAttrEventArgs
Vedi anche

Documentazione

Classe DedEditAnagrControl
Namespace DedNet.Controls


Metodo DedEditAnagrControl.AttrValueSet

Metodo DedEditAnagrControlAttrValueSet
Evento di set di un attributo.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void AttrValueSet(
    Object sender,
    SetAttrValueEventArgs e
)
Protected Friend Sub AttrValueSet (
    sender As Object,
    e As SetAttrValueEventArgs
)
protected public:
void AttrValueSet(
    Object^ sender,
    SetAttrValueEventArgs^ e
)
member AttrValueSet :
        sender : Object *
        e : SetAttrValueEventArgs -> unit

Parametri

sender Object
e SetAttrValueEventArgs
Vedi anche

Documentazione

Classe DedEditAnagrControl
Namespace DedNet.Controls


Metodo DedEditAnagrControl.ClassListClick

Metodo DedEditAnagrControlClassListClick
Evento di pressione su un elemento del ClassList.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void ClassListClick(
    Object sender,
    ClassListItemClickedEventArgs e
)
Protected Friend Sub ClassListClick (
    sender As Object,
    e As ClassListItemClickedEventArgs
)
protected public:
void ClassListClick(
    Object^ sender,
    ClassListItemClickedEventArgs^ e
)
member ClassListClick :
        sender : Object *
        e : ClassListItemClickedEventArgs -> unit

Parametri

sender Object
e ClassListItemClickedEventArgs
Vedi anche

Documentazione

Classe DedEditAnagrControl
Namespace DedNet.Controls


Metodo DedEditAnagrControl.ClassListFill

Metodo DedEditAnagrControlClassListFill
Evento di riempimento del ClassList.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void ClassListFill(
    Object sender,
    ClassListFillEventArgs e
)
Protected Friend Sub ClassListFill (
    sender As Object,
    e As ClassListFillEventArgs
)
protected public:
void ClassListFill(
    Object^ sender,
    ClassListFillEventArgs^ e
)
member ClassListFill :
        sender : Object *
        e : ClassListFillEventArgs -> unit

Parametri

sender Object
e ClassListFillEventArgs
Vedi anche

Documentazione

Classe DedEditAnagrControl
Namespace DedNet.Controls


Metodo DedEditAnagrControl.DataInitializationDone

Metodo DedEditAnagrControlDataInitializationDone
Evento di fine inizializzazione del datasource.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void DataInitializationDone(
    Object sender,
    EventArgs e
)
Protected Friend Sub DataInitializationDone (
    sender As Object,
    e As EventArgs
)
protected public:
void DataInitializationDone(
    Object^ sender,
    EventArgs^ e
)
member DataInitializationDone :
        sender : Object *
        e : EventArgs -> unit

Parametri

sender Object
e EventArgs
Vedi anche

Documentazione

Classe DedEditAnagrControl
Namespace DedNet.Controls


Metodo DedEditAnagrControl.DataSourceInitialization

Metodo DedEditAnagrControlDataSourceInitialization
Evento di inizializzazione del datasource. Crea la tabella da bindare.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void DataSourceInitialization(
    Object sender,
    DataSourceInitEventArgs e
)
Protected Friend Sub DataSourceInitialization (
    sender As Object,
    e As DataSourceInitEventArgs
)
protected public:
void DataSourceInitialization(
    Object^ sender,
    DataSourceInitEventArgs^ e
)
member DataSourceInitialization :
        sender : Object *
        e : DataSourceInitEventArgs -> unit

Parametri

sender Object
e DataSourceInitEventArgs
Vedi anche

Documentazione

Classe DedEditAnagrControl
Namespace DedNet.Controls


Metodo DedEditAnagrControl.DedEditAnagrControl_IsDirtyEvent

Metodo DedEditAnagrControlDedEditAnagrControl_IsDirtyEvent
Override del metodo che imposta se il controllo è dirty.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void DedEditAnagrControl_IsDirtyEvent(
    Object sender,
    IsDirtyEventArgs e
)
Protected Friend Sub DedEditAnagrControl_IsDirtyEvent (
    sender As Object,
    e As IsDirtyEventArgs
)
protected public:
void DedEditAnagrControl_IsDirtyEvent(
    Object^ sender,
    IsDirtyEventArgs^ e
)
member DedEditAnagrControl_IsDirtyEvent :
        sender : Object *
        e : IsDirtyEventArgs -> unit

Parametri

sender Object
e IsDirtyEventArgs
Vedi anche

Documentazione

Classe DedEditAnagrControl
Namespace DedNet.Controls


Metodo DedEditAnagrControl.Dispose

Metodo DedEditAnagrControlDispose
Clean up any resources being used.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedEditAnagrControl
Namespace DedNet.Controls


Metodo DedEditAnagrControl.EnableDedContextMenu

Metodo DedEditAnagrControlEnableDedContextMenu
Abilita il menu contestuale di questo controllo.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void EnableDedContextMenu()
Public Sub EnableDedContextMenu
public:
void EnableDedContextMenu()
member EnableDedContextMenu : unit -> unit
Vedi anche

Documentazione

Classe DedEditAnagrControl
Namespace DedNet.Controls


Metodo DedEditAnagrControl.InitData

Metodo DedEditAnagrControlInitData
Inizializza il controllo in base ai parametri passati. Se si passa una anagrafica null o una lista di attributi null o vuota svuota completamente il controllo.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void InitData(
    IDedEditable dedData,
    DedAttrList attrList,
    DedTypeBase fam
)
Public Sub InitData (
    dedData As IDedEditable,
    attrList As DedAttrList,
    fam As DedTypeBase
)
public:
void InitData(
    IDedEditable^ dedData,
    DedAttrList^ attrList,
    DedTypeBase^ fam
)
member InitData :
        dedData : IDedEditable *
        attrList : DedAttrList *
        fam : DedTypeBase -> unit

Parametri

dedData IDedEditable
Anagrafica o commessa da visualizzare.
attrList DedAttrList
Lista degli attributi da visualizzare.
fam DedTypeBase
Famiglia a cui appartiene l'anagrafica passata in ingresso (la famiglia è stata passata come parametro perchè non è sempre possibile ricavarla dalle informazioni dell'anagrafica).
Vedi anche

Documentazione

Classe DedEditAnagrControl
Namespace DedNet.Controls


Metodo DedEditAnagrControl.LabelTextSet

Metodo DedEditAnagrControlLabelTextSet
Evento di set del testo della label di informazioni.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void LabelTextSet(
    Object sender,
    LabelTextSetEventArgs e
)
Protected Friend Sub LabelTextSet (
    sender As Object,
    e As LabelTextSetEventArgs
)
protected public:
void LabelTextSet(
    Object^ sender,
    LabelTextSetEventArgs^ e
)
member LabelTextSet :
        sender : Object *
        e : LabelTextSetEventArgs -> unit

Parametri

sender Object
e LabelTextSetEventArgs
Vedi anche

Documentazione

Classe DedEditAnagrControl
Namespace DedNet.Controls


Metodo DedEditAnagrControl.LuaValidation

Metodo DedEditAnagrControlLuaValidation
Evento che fa scattare la validazione Lua.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void LuaValidation(
    Object sender,
    LuaValidatingEventArgs e
)
Protected Friend Sub LuaValidation (
    sender As Object,
    e As LuaValidatingEventArgs
)
protected public:
void LuaValidation(
    Object^ sender,
    LuaValidatingEventArgs^ e
)
member LuaValidation :
        sender : Object *
        e : LuaValidatingEventArgs -> unit

Parametri

sender Object
e LuaValidatingEventArgs
Vedi anche

Documentazione

Classe DedEditAnagrControl
Namespace DedNet.Controls


Metodo DedEditAnagrControl.OnMenuItemClicked

Metodo DedEditAnagrControlOnMenuItemClicked
Fa scattare l'evento MenuItemClicked.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected void OnMenuItemClicked(
    Object sender,
    ItemClickEventArgs e
)
Protected Sub OnMenuItemClicked (
    sender As Object,
    e As ItemClickEventArgs
)
protected:
void OnMenuItemClicked(
    Object^ sender,
    ItemClickEventArgs^ e
)
member OnMenuItemClicked :
        sender : Object *
        e : ItemClickEventArgs -> unit

Parametri

sender Object
e ItemClickEventArgs
Vedi anche

Documentazione

Classe DedEditAnagrControl
Namespace DedNet.Controls


Metodo DedEditAnagrControl.OrderTabPages

Metodo DedEditAnagrControlOrderTabPages
Evento che permette di riordinare la lista di pagine in base all'ordine delle categorie del DED.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OrderTabPages(
    Object sender,
    OrderTabPagesEventArgs e
)
Protected Friend Sub OrderTabPages (
    sender As Object,
    e As OrderTabPagesEventArgs
)
protected public:
void OrderTabPages(
    Object^ sender,
    OrderTabPagesEventArgs^ e
)
member OrderTabPages :
        sender : Object *
        e : OrderTabPagesEventArgs -> unit

Parametri

sender Object
e OrderTabPagesEventArgs
Vedi anche

Documentazione

Classe DedEditAnagrControl
Namespace DedNet.Controls


Metodo DedEditAnagrControl.OverrideCellValueChanged

Metodo DedEditAnagrControlOverrideCellValueChanged
Override dell'evento di CellValueChanged.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OverrideCellValueChanged(
    Object sender,
    CellValueChangedEventArgs e
)
Protected Friend Sub OverrideCellValueChanged (
    sender As Object,
    e As CellValueChangedEventArgs
)
protected public:
void OverrideCellValueChanged(
    Object^ sender,
    CellValueChangedEventArgs^ e
)
member OverrideCellValueChanged :
        sender : Object *
        e : CellValueChangedEventArgs -> unit

Parametri

sender Object
e CellValueChangedEventArgs
Vedi anche

Documentazione

Classe DedEditAnagrControl
Namespace DedNet.Controls


Metodo DedEditAnagrControl.OverrideCustomDrawCell

Metodo DedEditAnagrControlOverrideCustomDrawCell
Evento di Override del draw delle celle.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OverrideCustomDrawCell(
    Object sender,
    OverrideCustomDrawCellEventArgs e
)
Protected Friend Sub OverrideCustomDrawCell (
    sender As Object,
    e As OverrideCustomDrawCellEventArgs
)
protected public:
void OverrideCustomDrawCell(
    Object^ sender,
    OverrideCustomDrawCellEventArgs^ e
)
member OverrideCustomDrawCell :
        sender : Object *
        e : OverrideCustomDrawCellEventArgs -> unit

Parametri

sender Object
e OverrideCustomDrawCellEventArgs
Vedi anche

Documentazione

Classe DedEditAnagrControl
Namespace DedNet.Controls


Metodo DedEditAnagrControl.OverrideRepositoryBind

Metodo DedEditAnagrControlOverrideRepositoryBind
Override del bind del repository. Permette di modificarne le proprietà prima che venga bindato alla cella.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OverrideRepositoryBind(
    Object sender,
    RepositoryBindEventArgs e
)
Protected Friend Sub OverrideRepositoryBind (
    sender As Object,
    e As RepositoryBindEventArgs
)
protected public:
void OverrideRepositoryBind(
    Object^ sender,
    RepositoryBindEventArgs^ e
)
member OverrideRepositoryBind :
        sender : Object *
        e : RepositoryBindEventArgs -> unit

Parametri

sender Object
e RepositoryBindEventArgs
Vedi anche

Documentazione

Classe DedEditAnagrControl
Namespace DedNet.Controls


Metodo DedEditAnagrControl.OverrideRowCellStyle

Metodo DedEditAnagrControlOverrideRowCellStyle
Override dell'aspetto delle celle (colore di sfondo e testo).

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OverrideRowCellStyle(
    Object sender,
    OverrideRowCellStyleEventArgs e
)
Protected Friend Sub OverrideRowCellStyle (
    sender As Object,
    e As OverrideRowCellStyleEventArgs
)
protected public:
void OverrideRowCellStyle(
    Object^ sender,
    OverrideRowCellStyleEventArgs^ e
)
member OverrideRowCellStyle :
        sender : Object *
        e : OverrideRowCellStyleEventArgs -> unit

Parametri

sender Object
e OverrideRowCellStyleEventArgs
Vedi anche

Documentazione

Classe DedEditAnagrControl
Namespace DedNet.Controls


Metodo DedEditAnagrControl.OverrideValidatingEditor

Metodo DedEditAnagrControlOverrideValidatingEditor
Override della validazione del contenuto di un editor.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OverrideValidatingEditor(
    Object sender,
    OverrideValidatingEditorEventArgs e
)
Protected Friend Sub OverrideValidatingEditor (
    sender As Object,
    e As OverrideValidatingEditorEventArgs
)
protected public:
void OverrideValidatingEditor(
    Object^ sender,
    OverrideValidatingEditorEventArgs^ e
)
member OverrideValidatingEditor :
        sender : Object *
        e : OverrideValidatingEditorEventArgs -> unit

Parametri

sender Object
e OverrideValidatingEditorEventArgs
Vedi anche

Documentazione

Classe DedEditAnagrControl
Namespace DedNet.Controls


Metodo DedEditAnagrControl.PopupMenuItemClicked

Metodo DedEditAnagrControlPopupMenuItemClicked
Evento di pressione di un elemento del menù contestuale. Fa scattare il comando selezionato.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void PopupMenuItemClicked(
    Object sender,
    ItemClickEventArgs e
)
Protected Friend Sub PopupMenuItemClicked (
    sender As Object,
    e As ItemClickEventArgs
)
protected public:
void PopupMenuItemClicked(
    Object^ sender,
    ItemClickEventArgs^ e
)
member PopupMenuItemClicked :
        sender : Object *
        e : ItemClickEventArgs -> unit

Parametri

sender Object
e ItemClickEventArgs
Vedi anche

Documentazione

Classe DedEditAnagrControl
Namespace DedNet.Controls


Metodo DedEditAnagrControl.PopupMenuOpening

Metodo DedEditAnagrControlPopupMenuOpening
Evento di apertura del menù contestuale.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void PopupMenuOpening(
    Object sender,
    CancelEventArgs e
)
Protected Friend Sub PopupMenuOpening (
    sender As Object,
    e As CancelEventArgs
)
protected public:
void PopupMenuOpening(
    Object^ sender,
    CancelEventArgs^ e
)
member PopupMenuOpening :
        sender : Object *
        e : CancelEventArgs -> unit

Parametri

sender Object
e CancelEventArgs
Vedi anche

Documentazione

Classe DedEditAnagrControl
Namespace DedNet.Controls


Metodo DedEditAnagrControl.RefreshData

Metodo DedEditAnagrControlRefreshData

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void RefreshData()
Public Sub RefreshData
public:
void RefreshData()
member RefreshData : unit -> unit
Vedi anche

Documentazione

Classe DedEditAnagrControl
Namespace DedNet.Controls


Metodo DedEditAnagrControl.RulesImageChange

Metodo DedEditAnagrControlRulesImageChange
Evento che cambia l'immagine del PictureEdit se è presente una regola associata all'attributo.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void RulesImageChange(
    Object sender,
    RulesImagesChangeEventArgs e
)
Protected Friend Sub RulesImageChange (
    sender As Object,
    e As RulesImagesChangeEventArgs
)
protected public:
void RulesImageChange(
    Object^ sender,
    RulesImagesChangeEventArgs^ e
)
member RulesImageChange :
        sender : Object *
        e : RulesImagesChangeEventArgs -> unit

Parametri

sender Object
e RulesImagesChangeEventArgs
Vedi anche

Documentazione

Classe DedEditAnagrControl
Namespace DedNet.Controls


Eventi di DedEditAnagrControl

Il tipo DedEditAnagrControl espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | AttrNameFromPromptEvent | (Ereditato da EditAttrControlBase)
Evento pubblico | ButtonCancelClick | (Ereditato da EditAttrControlBase)
Evento pubblico | ButtonEditClick | (Ereditato da EditAttrControlBase)
Evento pubblico | ButtonOkClick | (Ereditato da EditAttrControlBase)
Evento pubblico | ClassListFillEvent | (Ereditato da EditAttrControlBase)
Evento pubblico | ClassListItemClickedEvent | (Ereditato da EditAttrControlBase)
Evento pubblico | DataInitDoneEvent | (Ereditato da EditAttrControlBase)
Evento pubblico | DataSourceInitEvent | (Ereditato da EditAttrControlBase)
Evento pubblico | IsDirtyEvent | (Ereditato da EditAttrControlBase)
Evento pubblico | LabelTextSetEvent | (Ereditato da EditAttrControlBase)
Evento pubblico | LuaValidatingEvent | (Ereditato da EditAttrControlBase)
Evento pubblico | MenuItemClicked | Evento su click su un elemento del menu contestuale.
Evento pubblico | OrderTabPagesEvent | (Ereditato da EditAttrControlBase)
Evento pubblico | OverrideCellValueChangedEvent | (Ereditato da EditAttrControlBase)
Evento pubblico | OverrideCustomDrawCellEvent | (Ereditato da EditAttrControlBase)
Evento pubblico | OverrideImpostaStatoPulsantiEvent | (Ereditato da EditAttrControlBase)
Evento pubblico | OverrideRowCellStyleEvent | (Ereditato da EditAttrControlBase)
Evento pubblico | OverrideValidatingEditorEvent | (Ereditato da EditAttrControlBase)
Evento pubblico | PaintEx | (Ereditato da XtraUserControl)
Evento pubblico | PopupOpeningEvent | (Ereditato da EditAttrControlBase)
Evento pubblico | PostButtonCancelClick | (Ereditato da EditAttrControlBase)
Evento pubblico | PostButtonOkClick | (Ereditato da EditAttrControlBase)
Evento pubblico | RepositoryBindEvent | (Ereditato da EditAttrControlBase)
Evento pubblico | RulesImageChangeEvent | (Ereditato da EditAttrControlBase)
Evento pubblico | SetAttrValueEvent | (Ereditato da EditAttrControlBase)
Evento pubblico | ValidateAttrEvent | (Ereditato da EditAttrControlBase)
Evento pubblico | ValueChanged | (Ereditato da EditAttrControlBase)
Torna su
Vedi anche

Documentazione

Classe DedEditAnagrControl
Namespace DedNet.Controls


Evento DedEditAnagrControl.MenuItemClicked

Evento DedEditAnagrControlMenuItemClicked
Evento su click su un elemento del menu contestuale.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<ItemClickEventArgs> MenuItemClicked
Public Event MenuItemClicked As EventHandler(Of ItemClickEventArgs)
public:
 event EventHandler<ItemClickEventArgs^>^ MenuItemClicked {
    void add (EventHandler<ItemClickEventArgs^>^ value);
    void remove (EventHandler<ItemClickEventArgs^>^ value);
}
member MenuItemClicked : IEvent<EventHandler<ItemClickEventArgs>,
    ItemClickEventArgs>

Valore

EventHandler ItemClickEventArgs
Vedi anche

Documentazione

Classe DedEditAnagrControl
Namespace DedNet.Controls


Classe DedFileExplorerControl
Controllo usato come esplora risorse per il Gestore Commesse.
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
XtraUserControl
DedNet.ControlsUserControlBase
DedNet.ControlsDedFileExplorerControl

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFileExplorerControl : UserControlBase
Public Class DedFileExplorerControl
    Inherits UserControlBase
public ref class DedFileExplorerControl : public UserControlBase
type DedFileExplorerControl =
    class
        inherit UserControlBase
    end

Il tipo DedFileExplorerControl espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFileExplorerControl | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Appearance | (Ereditato da XtraUserControl)
Proprietà pubblica | Application | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Proprietà pubblica | BackColor | (Ereditato da XtraUserControl)
Proprietà protetta | CheckDoubleScaling | (Ereditato da XtraUserControl)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraUserControl)
Proprietà protetta | DirectXContainer | (Ereditato da XtraUserControl)
Proprietà pubblica | EnableIXtraResizeableControlInterfaceProxy | (Ereditato da XtraUserControl)
Proprietà pubblica | Font | (Ereditato da XtraUserControl)
Proprietà pubblica | ForeColor | (Ereditato da XtraUserControl)
Proprietà protetta | Helper | (Ereditato da XtraUserControl)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraUserControl)
Proprietà protetta | Painter | (Ereditato da XtraUserControl)
Proprietà pubblica | RootPathList | Ritorna il percorso radice da visualizzare.
Proprietà protetta | ScaleChildren | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleDPI | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraUserControl)
Proprietà protetta | ShouldCheckDpiScaleFactorOnParentChanged | (Ereditato da XtraUserControl)
Proprietà pubblica | Site | (Ereditato da XtraUserControl)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | BaseWndProc | (Ereditato da XtraUserControl)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraUserControl)
Metodo protetto | CreatePainter | (Ereditato da XtraUserControl)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive UserControlBaseDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraUserControl)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraUserControl)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraUserControl)
Metodo protetto | GetBackColor | (Ereditato da XtraUserControl)
Metodo protetto | GetBackgroundSkinElement | (Ereditato da XtraUserControl)
Metodo protetto | GetInnerIXtraResizableControl | (Ereditato da XtraUserControl)
Metodo protetto | IsChildControlsRequiredScalingEnabled | (Ereditato da XtraUserControl)
Metodo protetto | IsParentHandleCreatedRecursive | (Ereditato da XtraUserControl)
Metodo pubblico | LoadRegistrySetting | Legge dal registro le impostazioni della tabella.
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraUserControl)
Metodo protetto | OnBackColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnContextMenuOpening | Evento di apertura del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnControlAdded | (Ereditato da XtraUserControl)
Metodo protetto | OnControlRemoved | (Ereditato da XtraUserControl)
Metodo protetto | OnCreateControl | Override del metodo OnCreateControl. Mi permette di usare la Reflection per ricavare gli eventhandler dei MouseMove e disabilitare la gestione del DragAndDrop. (Sovrascrive UserControlOnCreateControl)
Metodo protetto | OnDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnFirstLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnForeColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleCreated | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraUserControl)
Metodo protetto | OnLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnMenuItemClicked | Evento di pressione di un comando del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnPaintCore | (Ereditato da XtraUserControl)
Metodo protetto | OnParentChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | OnSizeChanged | (Ereditato da XtraUserControl)
Metodo protetto | RaisePaintExEvent | (Ereditato da XtraUserControl)
Metodo pubblico | ResetBackColor | (Ereditato da XtraUserControl)
Metodo pubblico | ResetForeColor | (Ereditato da XtraUserControl)
Metodo protetto | RestoreAutoScaleModeChangedByPM2 | (Ereditato da XtraUserControl)
Metodo pubblico | SaveRegistrySetting | Salva nel registro le impostazioni della tabella.
Metodo protetto | ScaleControl | (Ereditato da XtraUserControl)
Metodo pubblico | SetCommandList | Rigenera il menu contestuale di questo controllo con la lista dei comandi passati. (Ereditato da UserControlBase)
Metodo pubblico | SetRegistryKey | Imposta la chiave di registro.
Metodo pubblico | SetRootPath | Imposta il percorso di root da visualizzare.
Metodo protetto | SetVisibleCore | (Ereditato da XtraUserControl)
Metodo protetto | ShouldPaintTransparentBackground | (Ereditato da XtraUserControl)
Metodo protetto | ShouldUseDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | WndProc | (Ereditato da XtraUserControl)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | ContextMenuOpening | Evento su apertura del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | MenuItemClicked | Evento su click su un elemento del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | PaintEx | (Ereditato da XtraUserControl)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | _app | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Campo protetto | _RegistryBaseKey | Chiave nel registro di sistema di salvataggio impostazioni. (Ereditato da UserControlBase)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore DedFileExplorerControl
Costruttore unico.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFileExplorerControl()
Public Sub New
public:
DedFileExplorerControl()
new : unit -> DedFileExplorerControl
Vedi anche

Documentazione

Classe DedFileExplorerControl
Namespace DedNet.Controls


Proprietà di DedFileExplorerControl

Il tipo DedFileExplorerControl espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Appearance | (Ereditato da XtraUserControl)
Proprietà pubblica | Application | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Proprietà pubblica | BackColor | (Ereditato da XtraUserControl)
Proprietà protetta | CheckDoubleScaling | (Ereditato da XtraUserControl)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraUserControl)
Proprietà protetta | DirectXContainer | (Ereditato da XtraUserControl)
Proprietà pubblica | EnableIXtraResizeableControlInterfaceProxy | (Ereditato da XtraUserControl)
Proprietà pubblica | Font | (Ereditato da XtraUserControl)
Proprietà pubblica | ForeColor | (Ereditato da XtraUserControl)
Proprietà protetta | Helper | (Ereditato da XtraUserControl)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraUserControl)
Proprietà protetta | Painter | (Ereditato da XtraUserControl)
Proprietà pubblica | RootPathList | Ritorna il percorso radice da visualizzare.
Proprietà protetta | ScaleChildren | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleDPI | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraUserControl)
Proprietà protetta | ShouldCheckDpiScaleFactorOnParentChanged | (Ereditato da XtraUserControl)
Proprietà pubblica | Site | (Ereditato da XtraUserControl)
Torna su
Vedi anche

Documentazione

Classe DedFileExplorerControl
Namespace DedNet.Controls


Proprietà DedFileExplorerControl.RootPathList

Proprietà DedFileExplorerControlRootPathList
Ritorna il percorso radice da visualizzare.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> RootPathList { get; }
Public ReadOnly Property RootPathList As List(Of String)
    Get
public:
property List<String^>^ RootPathList {
    List<String^>^ get ();
}
member RootPathList : List<string> with get

Valore della proprietà

List String
Vedi anche

Documentazione

Classe DedFileExplorerControl
Namespace DedNet.Controls


Metodi di DedFileExplorerControl

Il tipo DedFileExplorerControl espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | BaseWndProc | (Ereditato da XtraUserControl)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraUserControl)
Metodo protetto | CreatePainter | (Ereditato da XtraUserControl)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive UserControlBaseDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraUserControl)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraUserControl)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraUserControl)
Metodo protetto | GetBackColor | (Ereditato da XtraUserControl)
Metodo protetto | GetBackgroundSkinElement | (Ereditato da XtraUserControl)
Metodo protetto | GetInnerIXtraResizableControl | (Ereditato da XtraUserControl)
Metodo protetto | IsChildControlsRequiredScalingEnabled | (Ereditato da XtraUserControl)
Metodo protetto | IsParentHandleCreatedRecursive | (Ereditato da XtraUserControl)
Metodo pubblico | LoadRegistrySetting | Legge dal registro le impostazioni della tabella.
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraUserControl)
Metodo protetto | OnBackColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnContextMenuOpening | Evento di apertura del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnControlAdded | (Ereditato da XtraUserControl)
Metodo protetto | OnControlRemoved | (Ereditato da XtraUserControl)
Metodo protetto | OnCreateControl | Override del metodo OnCreateControl. Mi permette di usare la Reflection per ricavare gli eventhandler dei MouseMove e disabilitare la gestione del DragAndDrop. (Sovrascrive UserControlOnCreateControl)
Metodo protetto | OnDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnFirstLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnForeColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleCreated | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraUserControl)
Metodo protetto | OnLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnMenuItemClicked | Evento di pressione di un comando del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnPaintCore | (Ereditato da XtraUserControl)
Metodo protetto | OnParentChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | OnSizeChanged | (Ereditato da XtraUserControl)
Metodo protetto | RaisePaintExEvent | (Ereditato da XtraUserControl)
Metodo pubblico | ResetBackColor | (Ereditato da XtraUserControl)
Metodo pubblico | ResetForeColor | (Ereditato da XtraUserControl)
Metodo protetto | RestoreAutoScaleModeChangedByPM2 | (Ereditato da XtraUserControl)
Metodo pubblico | SaveRegistrySetting | Salva nel registro le impostazioni della tabella.
Metodo protetto | ScaleControl | (Ereditato da XtraUserControl)
Metodo pubblico | SetCommandList | Rigenera il menu contestuale di questo controllo con la lista dei comandi passati. (Ereditato da UserControlBase)
Metodo pubblico | SetRegistryKey | Imposta la chiave di registro.
Metodo pubblico | SetRootPath | Imposta il percorso di root da visualizzare.
Metodo protetto | SetVisibleCore | (Ereditato da XtraUserControl)
Metodo protetto | ShouldPaintTransparentBackground | (Ereditato da XtraUserControl)
Metodo protetto | ShouldUseDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | WndProc | (Ereditato da XtraUserControl)
Torna su
Vedi anche

Documentazione

Classe DedFileExplorerControl
Namespace DedNet.Controls


Metodo DedFileExplorerControl.Dispose

Metodo DedFileExplorerControlDispose
Clean up any resources being used.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFileExplorerControl
Namespace DedNet.Controls


Metodo DedFileExplorerControl.LoadRegistrySetting

Metodo DedFileExplorerControlLoadRegistrySetting
Legge dal registro le impostazioni della tabella.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void LoadRegistrySetting()
Public Sub LoadRegistrySetting
public:
void LoadRegistrySetting()
member LoadRegistrySetting : unit -> unit
Vedi anche

Documentazione

Classe DedFileExplorerControl
Namespace DedNet.Controls


Metodo DedFileExplorerControl.OnCreateControl

Metodo DedFileExplorerControlOnCreateControl
Override del metodo OnCreateControl. Mi permette di usare la Reflection per ricavare gli eventhandler dei MouseMove e disabilitare la gestione del DragAndDrop.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void OnCreateControl()
Protected Overrides Sub OnCreateControl
protected:
virtual void OnCreateControl() override
abstract OnCreateControl : unit -> unit
override OnCreateControl : unit -> unit
Vedi anche

Documentazione

Classe DedFileExplorerControl
Namespace DedNet.Controls


Metodo DedFileExplorerControl.SaveRegistrySetting

Metodo DedFileExplorerControlSaveRegistrySetting
Salva nel registro le impostazioni della tabella.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SaveRegistrySetting()
Public Sub SaveRegistrySetting
public:
void SaveRegistrySetting()
member SaveRegistrySetting : unit -> unit
Vedi anche

Documentazione

Classe DedFileExplorerControl
Namespace DedNet.Controls


Metodo DedFileExplorerControl.SetRegistryKey

Metodo DedFileExplorerControlSetRegistryKey
Imposta la chiave di registro.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetRegistryKey(
    string key
)
Public Sub SetRegistryKey (
    key As String
)
public:
void SetRegistryKey(
    String^ key
)
member SetRegistryKey :
        key : string -> unit

Parametri

key String
Chiave di registro.
Vedi anche

Documentazione

Classe DedFileExplorerControl
Namespace DedNet.Controls


Metodo DedFileExplorerControl.SetRootPath

Metodo DedFileExplorerControlSetRootPath
Imposta il percorso di root da visualizzare.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetRootPath(
    List<string> paths
)
Public Sub SetRootPath (
    paths As List(Of String)
)
public:
void SetRootPath(
    List<String^>^ paths
)
member SetRootPath :
        paths : List<string> -> unit

Parametri

paths List String
Vedi anche

Documentazione

Classe DedFileExplorerControl
Namespace DedNet.Controls


Eventi di DedFileExplorerControl

Il tipo DedFileExplorerControl espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | ContextMenuOpening | Evento su apertura del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | MenuItemClicked | Evento su click su un elemento del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | PaintEx | (Ereditato da XtraUserControl)
Torna su
Vedi anche

Documentazione

Classe DedFileExplorerControl
Namespace DedNet.Controls


Campi di DedFileExplorerControl

Il tipo DedFileExplorerControl espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | _app | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Campo protetto | _RegistryBaseKey | Chiave nel registro di sistema di salvataggio impostazioni. (Ereditato da UserControlBase)
Torna su
Vedi anche

Documentazione

Classe DedFileExplorerControl
Namespace DedNet.Controls


Classe DedFindCodeControl
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
XtraUserControl
DedNet.ControlsUserControlBase
DedNet.ControlsDedFindCodeControl

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFindCodeControl : UserControlBase
Public Class DedFindCodeControl
    Inherits UserControlBase
public ref class DedFindCodeControl : public UserControlBase
type DedFindCodeControl =
    class
        inherit UserControlBase
    end

Il tipo DedFindCodeControl espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFindCodeControl | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllowEditValueChangeEvent | Variabile semaforo che abilita/disabilita l'evento di "EditValueChange".
Proprietà pubblica | AllQueryFields | Lista dei campi su cui effettuare la query per ottenere l'elenco dei codici da mostrare del lookupedit.
Proprietà pubblica | Appearance | (Ereditato da XtraUserControl)
Proprietà pubblica | Application | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Proprietà pubblica | BackColor | (Ereditato da XtraUserControl)
Proprietà protetta | CheckDoubleScaling | (Ereditato da XtraUserControl)
Proprietà pubblica | ClearTextOnProcessNewValue | Imposta se ripulire il testo sull'evento ProcessNewValue.
Proprietà pubblica | ComboBox | Oggetto ComboBoxEdit.
Proprietà protetta | DefaultAppearance | (Ereditato da XtraUserControl)
Proprietà protetta | DirectXContainer | (Ereditato da XtraUserControl)
Proprietà pubblica | EnableIXtraResizeableControlInterfaceProxy | (Ereditato da XtraUserControl)
Proprietà pubblica | FilterBy | Rappresenta l'attributo dell'anagrafica da visualizzare nel lookupedit. Deve essere impostato con l'internalname dell'attributo che si intende visualizzare.
Proprietà pubblica | Font | (Ereditato da XtraUserControl)
Proprietà pubblica | ForeColor | (Ereditato da XtraUserControl)
Proprietà protetta | Helper | (Ereditato da XtraUserControl)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraUserControl)
Proprietà pubblica | LookUp | Oggetto LookUpEdit.
Proprietà pubblica | LookUpFields | Lista dei campi da avere sempre visibili nella tendina del lookupedit.
Proprietà pubblica | OldSearch | Stringa di ricerca presente prima del cambio di flag (mostra ultima revisione).
Proprietà protetta | Painter | (Ereditato da XtraUserControl)
Proprietà pubblica | PathRegistryKey | Chiave di registro dove salvare i recenti.
Proprietà pubblica | RunQueryOnEnter | Indica se effettuare la ricerca sulla pressione del tasto "Invio". Se True visualizza il combobox, altrimenti il lookupedit. Impostando questa variabile si modifica il layout a schermo.
Proprietà protetta | ScaleChildren | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleDPI | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraUserControl)
Proprietà pubblica | SelFonteDati | Indica se eseguire la ricerca dopo la pressione del tasto "Invio" da tastiera.
Proprietà protetta | ShouldCheckDpiScaleFactorOnParentChanged | (Ereditato da XtraUserControl)
Proprietà pubblica | Site | (Ereditato da XtraUserControl)
Proprietà pubblica | SkipEditValueChanged |
Proprietà pubblica | SupplementaryQueryFields | Lista contenente i campi supplementari su cui effettuare la query per il reperimento dei codici da riportare nel lookupedit. Contiene i prompt degli attributi e non l'internalName.
Proprietà pubblica | TextFilterBy | Rappresenta il PROMPT dell'attributo per il quale si stanno ricercando i codici.
Proprietà pubblica | VisibleCancelButton | Mostra/Nasconde il bottone di Annulla nel lookupedit.
Proprietà pubblica | VisibleOkButton | Mostra/Nasconde il bottone di Ok nel lookupedit.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AddLookUpField | Metodo che aggiunge una colonna al lookupedit.
Metodo pubblico | AddQueryField | Aggiunge un campo nel combo di sinistra con la lista dei campi selezionabili dall'utente.
Metodo pubblico | AddValueToRecentListInTheRegistry | Metodo che aggiorna l'elenco dei recenti nel registro. Nel caso in cui sia visibile il combobox, l'anagrafica in ingresso viene ignorata. Se il codice ricavato è una stringa vuota, non viene inserita nell'elenco dei recenti.
Metodo protetto | BaseWndProc | (Ereditato da XtraUserControl)
Metodo pubblico | ClearText | Ripulisce il testo del controllo attualmente visibile
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraUserControl)
Metodo protetto | CreatePainter | (Ereditato da XtraUserControl)
Metodo pubblico | Dispose | Esegue il dispose dei controlli utente particolarmente dispendiosi
Metodo protetto | Dispose(Boolean) | Clean up any resources being used. (Sovrascrive UserControlBaseDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraUserControl)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraUserControl)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraUserControl)
Metodo protetto | GetBackColor | (Ereditato da XtraUserControl)
Metodo protetto | GetBackgroundSkinElement | (Ereditato da XtraUserControl)
Metodo pubblico | GetColumnValue | Metodo che ritorna il valore di una specifica colonna per la riga correntemente selezionata.
Metodo pubblico | GetDataFromCurrentCode(Boolean, Boolean) | Ritorna l'anagrafica (in ultima revisione) in base al codice presente.
Metodo pubblico | GetDataFromCurrentCode(Boolean, Boolean, Boolean) | Ritorna l'anagrafica (in ultima revisione) in base al codice presente.
Metodo protetto | GetInnerIXtraResizableControl | (Ereditato da XtraUserControl)
Metodo pubblico | GetListOfRecents | Metodo che legge dal registro la lista delle anagrafiche recenti. Elimina dalla lista eventuali spazi vuoti.
Metodo pubblico | GetSubKey | Riorna il nome della chiave di registro dalla quale leggere l'elenco delle anagrafiche recenti.
Metodo pubblico | GetSupplementaryQueryFields | Metodo che ritorna un array di stringhe contenente l'internalName dei dei campi supplementari su cui effettuare la query.
Metodo pubblico | GetText | Metodo che ritorna il testo del controllo attualmente visibile.
Metodo pubblico | Initialize(String, String, DedFindCodeContextEnum) | Evento che scatta in fase di caricamento del controllo.
Metodo pubblico | Initialize(String, String, DedFindCodeContextEnum, Boolean) | Evento che scatta in fase di caricamento del controllo.
Metodo protetto | IsChildControlsRequiredScalingEnabled | (Ereditato da XtraUserControl)
Metodo protetto | IsParentHandleCreatedRecursive | (Ereditato da XtraUserControl)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraUserControl)
Metodo protetto | OnBackColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnContextMenuOpening | Evento di apertura del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnControlAdded | (Ereditato da XtraUserControl)
Metodo protetto | OnControlRemoved | (Ereditato da XtraUserControl)
Metodo protetto | OnDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnFirstLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnForeColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleCreated | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleDestroyed(EventArgs) | Evento usato per terminare il task di recupero codici nel database. It is raised, when the underlying HWnd is destroyed(which usually happens, when the parent form is closed). (Sovrascrive ControlOnHandleDestroyed(EventArgs))
Metodo protetto | OnHandleDestroyed(EventArgs) | (Ereditato da XtraUserControl)
Metodo protetto | OnLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnMenuItemClicked | Evento di pressione di un comando del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnPaintCore | (Ereditato da XtraUserControl)
Metodo protetto | OnParentChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | OnSizeChanged | (Ereditato da XtraUserControl)
Metodo protetto | RaisePaintExEvent | (Ereditato da XtraUserControl)
Metodo pubblico | ResetBackColor | (Ereditato da XtraUserControl)
Metodo pubblico | ResetForeColor | (Ereditato da XtraUserControl)
Metodo protetto | RestoreAutoScaleModeChangedByPM2 | (Ereditato da XtraUserControl)
Metodo pubblico | RunFind | Lancia il comando di ricerca e imposta l'anagrafica selezionata
Metodo pubblico | RunTask | Invoca il task per effettuare la query e riempire la DataTable del lookupedit.
Metodo protetto | ScaleControl | (Ereditato da XtraUserControl)
Metodo pubblico | SelectAll | Metodo che seleziona tutto il testo del controllo attualmente visibile.
Metodo pubblico | SetCommandList | Rigenera il menu contestuale di questo controllo con la lista dei comandi passati. (Ereditato da UserControlBase)
Metodo pubblico | SetInternalActiveControl | Imposto il controllo attivo in base all'opzione 'RunQueryOnEnter'.
Metodo pubblico | SetOnlyLastRev | Imposta il flag che determina se mostrare solo le anagrafiche in ultima revisione o meno.
Metodo pubblico | SetRecentsRegistryKeyName | Nome della chiave di registro contenente l'elenco dei recenti.
Metodo pubblico | SetText | Metodo che imposta il testo del controllo attualmente visibile.
Metodo pubblico | SetValue | Metodo che imposta il testo del controllo attualmente visibile.
Metodo protetto | SetVisibleCore | (Ereditato da XtraUserControl)
Metodo protetto | ShouldPaintTransparentBackground | (Ereditato da XtraUserControl)
Metodo protetto | ShouldUseDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | WndProc | (Ereditato da XtraUserControl)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | ContextMenuOpening | Evento su apertura del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | EditValueChangedCombo | Evento che scatta quando cambia il valore del combobox.
Evento pubblico | EditValueChangedLookUp | Evento che scatta quando cambia il valore del lookupedit.
Evento pubblico | FilterByChanged | Evento che scatta se cambiato l'attributo di ricerca.
Evento pubblico | KeyDownCombo | Evento che scatta ogni volta che è stato premuto un tasto all'interno del combobox.
Evento pubblico | KeyDownLookUp | Evento che scatta quando premuto un tasto da tastiera nel lookupedit.
Evento pubblico | KeyUpCombo | Evento che scatta ogni volta che è stato rilasciato un tasto all'interno del combobox.
Evento pubblico | LookUpCancelButtonPressed | Evento che scatta quando premuto il bottono di annulla nel lookupedit.
Evento pubblico | LookUpOkButtonPressed | Evento che scatta quando premuto il bottono di conferma nel lookupedit.
Evento pubblico | MenuItemClicked | Evento su click su un elemento del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | PaintEx | (Ereditato da XtraUserControl)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | _app | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Campo protetto | _RegistryBaseKey | Chiave nel registro di sistema di salvataggio impostazioni. (Ereditato da UserControlBase)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore DedFindCodeControl
Costruttore unico.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFindCodeControl()
Public Sub New
public:
DedFindCodeControl()
new : unit -> DedFindCodeControl
Vedi anche

Documentazione

Classe DedFindCodeControl
Namespace DedNet.Controls


Proprietà di DedFindCodeControl

Il tipo DedFindCodeControl espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllowEditValueChangeEvent | Variabile semaforo che abilita/disabilita l'evento di "EditValueChange".
Proprietà pubblica | AllQueryFields | Lista dei campi su cui effettuare la query per ottenere l'elenco dei codici da mostrare del lookupedit.
Proprietà pubblica | Appearance | (Ereditato da XtraUserControl)
Proprietà pubblica | Application | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Proprietà pubblica | BackColor | (Ereditato da XtraUserControl)
Proprietà protetta | CheckDoubleScaling | (Ereditato da XtraUserControl)
Proprietà pubblica | ClearTextOnProcessNewValue | Imposta se ripulire il testo sull'evento ProcessNewValue.
Proprietà pubblica | ComboBox | Oggetto ComboBoxEdit.
Proprietà protetta | DefaultAppearance | (Ereditato da XtraUserControl)
Proprietà protetta | DirectXContainer | (Ereditato da XtraUserControl)
Proprietà pubblica | EnableIXtraResizeableControlInterfaceProxy | (Ereditato da XtraUserControl)
Proprietà pubblica | FilterBy | Rappresenta l'attributo dell'anagrafica da visualizzare nel lookupedit. Deve essere impostato con l'internalname dell'attributo che si intende visualizzare.
Proprietà pubblica | Font | (Ereditato da XtraUserControl)
Proprietà pubblica | ForeColor | (Ereditato da XtraUserControl)
Proprietà protetta | Helper | (Ereditato da XtraUserControl)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraUserControl)
Proprietà pubblica | LookUp | Oggetto LookUpEdit.
Proprietà pubblica | LookUpFields | Lista dei campi da avere sempre visibili nella tendina del lookupedit.
Proprietà pubblica | OldSearch | Stringa di ricerca presente prima del cambio di flag (mostra ultima revisione).
Proprietà protetta | Painter | (Ereditato da XtraUserControl)
Proprietà pubblica | PathRegistryKey | Chiave di registro dove salvare i recenti.
Proprietà pubblica | RunQueryOnEnter | Indica se effettuare la ricerca sulla pressione del tasto "Invio". Se True visualizza il combobox, altrimenti il lookupedit. Impostando questa variabile si modifica il layout a schermo.
Proprietà protetta | ScaleChildren | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleDPI | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraUserControl)
Proprietà pubblica | SelFonteDati | Indica se eseguire la ricerca dopo la pressione del tasto "Invio" da tastiera.
Proprietà protetta | ShouldCheckDpiScaleFactorOnParentChanged | (Ereditato da XtraUserControl)
Proprietà pubblica | Site | (Ereditato da XtraUserControl)
Proprietà pubblica | SkipEditValueChanged |
Proprietà pubblica | SupplementaryQueryFields | Lista contenente i campi supplementari su cui effettuare la query per il reperimento dei codici da riportare nel lookupedit. Contiene i prompt degli attributi e non l'internalName.
Proprietà pubblica | TextFilterBy | Rappresenta il PROMPT dell'attributo per il quale si stanno ricercando i codici.
Proprietà pubblica | VisibleCancelButton | Mostra/Nasconde il bottone di Annulla nel lookupedit.
Proprietà pubblica | VisibleOkButton | Mostra/Nasconde il bottone di Ok nel lookupedit.
Torna su
Vedi anche

Documentazione

Classe DedFindCodeControl
Namespace DedNet.Controls


Proprietà DedFindCodeControl.AllowEditValueChangeEvent

Proprietà DedFindCodeControlAllowEditValueChangeEvent
Variabile semaforo che abilita/disabilita l'evento di "EditValueChange".

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AllowEditValueChangeEvent { get; set; }
Public Property AllowEditValueChangeEvent As Boolean
    Get
    Set
public:
property bool AllowEditValueChangeEvent {
    bool get ();
    void set (bool value);
}
member AllowEditValueChangeEvent : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFindCodeControl
Namespace DedNet.Controls


Proprietà DedFindCodeControl.AllQueryFields

Proprietà DedFindCodeControlAllQueryFields
Lista dei campi su cui effettuare la query per ottenere l'elenco dei codici da mostrare del lookupedit.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> AllQueryFields { get; }
Public ReadOnly Property AllQueryFields As List(Of String)
    Get
public:
property List<String^>^ AllQueryFields {
    List<String^>^ get ();
}
member AllQueryFields : List<string> with get

Valore della proprietà

List String
Vedi anche

Documentazione

Classe DedFindCodeControl
Namespace DedNet.Controls


Proprietà DedFindCodeControl.ClearTextOnProcessNewValue

Proprietà DedFindCodeControlClearTextOnProcessNewValue
Imposta se ripulire il testo sull'evento ProcessNewValue.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ClearTextOnProcessNewValue { get; set; }
Public Property ClearTextOnProcessNewValue As Boolean
    Get
    Set
public:
property bool ClearTextOnProcessNewValue {
    bool get ();
    void set (bool value);
}
member ClearTextOnProcessNewValue : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFindCodeControl
Namespace DedNet.Controls


Proprietà DedFindCodeControl.ComboBox

Proprietà DedFindCodeControlComboBox
Oggetto ComboBoxEdit.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ComboBoxEdit ComboBox { get; }
Public ReadOnly Property ComboBox As ComboBoxEdit
    Get
public:
property ComboBoxEdit^ ComboBox {
    ComboBoxEdit^ get ();
}
member ComboBox : ComboBoxEdit with get

Valore della proprietà

ComboBoxEdit
Vedi anche

Documentazione

Classe DedFindCodeControl
Namespace DedNet.Controls


Proprietà DedFindCodeControl.FilterBy

Proprietà DedFindCodeControlFilterBy
Rappresenta l'attributo dell'anagrafica da visualizzare nel lookupedit. Deve essere impostato con l'internalname dell'attributo che si intende visualizzare.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string FilterBy { get; }
Public ReadOnly Property FilterBy As String
    Get
public:
property String^ FilterBy {
    String^ get ();
}
member FilterBy : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedFindCodeControl
Namespace DedNet.Controls


Proprietà DedFindCodeControl.LookUp

Proprietà DedFindCodeControlLookUp
Oggetto LookUpEdit.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public LookUpEdit LookUp { get; }
Public ReadOnly Property LookUp As LookUpEdit
    Get
public:
property LookUpEdit^ LookUp {
    LookUpEdit^ get ();
}
member LookUp : LookUpEdit with get

Valore della proprietà

LookUpEdit
Vedi anche

Documentazione

Classe DedFindCodeControl
Namespace DedNet.Controls


Proprietà DedFindCodeControl.LookUpFields

Proprietà DedFindCodeControlLookUpFields
Lista dei campi da avere sempre visibili nella tendina del lookupedit.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> LookUpFields { get; }
Public ReadOnly Property LookUpFields As List(Of String)
    Get
public:
property List<String^>^ LookUpFields {
    List<String^>^ get ();
}
member LookUpFields : List<string> with get

Valore della proprietà

List String
Vedi anche

Documentazione

Classe DedFindCodeControl
Namespace DedNet.Controls


Proprietà DedFindCodeControl.OldSearch

Proprietà DedFindCodeControlOldSearch
Stringa di ricerca presente prima del cambio di flag (mostra ultima revisione).

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string OldSearch { get; set; }
Public Property OldSearch As String
    Get
    Set
public:
property String^ OldSearch {
    String^ get ();
    void set (String^ value);
}
member OldSearch : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedFindCodeControl
Namespace DedNet.Controls


Proprietà DedFindCodeControl.PathRegistryKey

Proprietà DedFindCodeControlPathRegistryKey
Chiave di registro dove salvare i recenti.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string PathRegistryKey { get; set; }
Public Property PathRegistryKey As String
    Get
    Set
public:
property String^ PathRegistryKey {
    String^ get ();
    void set (String^ value);
}
member PathRegistryKey : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedFindCodeControl
Namespace DedNet.Controls


Proprietà DedFindCodeControl.RunQueryOnEnter

Proprietà DedFindCodeControlRunQueryOnEnter
Indica se effettuare la ricerca sulla pressione del tasto "Invio". Se True visualizza il combobox, altrimenti il lookupedit. Impostando questa variabile si modifica il layout a schermo.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool RunQueryOnEnter { get; set; }
Public Property RunQueryOnEnter As Boolean
    Get
    Set
public:
property bool RunQueryOnEnter {
    bool get ();
    void set (bool value);
}
member RunQueryOnEnter : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFindCodeControl
Namespace DedNet.Controls


Proprietà DedFindCodeControl.SelFonteDati

Proprietà DedFindCodeControlSelFonteDati
Indica se eseguire la ricerca dopo la pressione del tasto "Invio" da tastiera.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFindCodeControlFonteDati SelFonteDati { get; }
Public ReadOnly Property SelFonteDati As DedFindCodeControlFonteDati
    Get
public:
property DedFindCodeControlFonteDati SelFonteDati {
    DedFindCodeControlFonteDati get ();
}
member SelFonteDati : DedFindCodeControlFonteDati with get

Valore della proprietà

DedFindCodeControlFonteDati
Vedi anche

Documentazione

Classe DedFindCodeControl
Namespace DedNet.Controls


Proprietà DedFindCodeControl.SkipEditValueChanged

Proprietà DedFindCodeControlSkipEditValueChanged

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool SkipEditValueChanged { get; set; }
Public Property SkipEditValueChanged As Boolean
    Get
    Set
public:
property bool SkipEditValueChanged {
    bool get ();
    void set (bool value);
}
member SkipEditValueChanged : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFindCodeControl
Namespace DedNet.Controls


Proprietà DedFindCodeControl.SupplementaryQueryFields

Proprietà DedFindCodeControlSupplementaryQueryFields
Lista contenente i campi supplementari su cui effettuare la query per il reperimento dei codici da riportare nel lookupedit. Contiene i prompt degli attributi e non l'internalName.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> SupplementaryQueryFields { get; }
Public ReadOnly Property SupplementaryQueryFields As List(Of String)
    Get
public:
property List<String^>^ SupplementaryQueryFields {
    List<String^>^ get ();
}
member SupplementaryQueryFields : List<string> with get

Valore della proprietà

List String
Vedi anche

Documentazione

Classe DedFindCodeControl
Namespace DedNet.Controls


Proprietà DedFindCodeControl.TextFilterBy

Proprietà DedFindCodeControlTextFilterBy
Rappresenta il PROMPT dell'attributo per il quale si stanno ricercando i codici.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string TextFilterBy { get; }
Public ReadOnly Property TextFilterBy As String
    Get
public:
property String^ TextFilterBy {
    String^ get ();
}
member TextFilterBy : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedFindCodeControl
Namespace DedNet.Controls


Proprietà DedFindCodeControl.VisibleCancelButton

Proprietà DedFindCodeControlVisibleCancelButton
Mostra/Nasconde il bottone di Annulla nel lookupedit.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool VisibleCancelButton { get; set; }
Public Property VisibleCancelButton As Boolean
    Get
    Set
public:
property bool VisibleCancelButton {
    bool get ();
    void set (bool value);
}
member VisibleCancelButton : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFindCodeControl
Namespace DedNet.Controls


Proprietà DedFindCodeControl.VisibleOkButton

Proprietà DedFindCodeControlVisibleOkButton
Mostra/Nasconde il bottone di Ok nel lookupedit.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool VisibleOkButton { get; set; }
Public Property VisibleOkButton As Boolean
    Get
    Set
public:
property bool VisibleOkButton {
    bool get ();
    void set (bool value);
}
member VisibleOkButton : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFindCodeControl
Namespace DedNet.Controls


Metodi di DedFindCodeControl

Il tipo DedFindCodeControl espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AddLookUpField | Metodo che aggiunge una colonna al lookupedit.
Metodo pubblico | AddQueryField | Aggiunge un campo nel combo di sinistra con la lista dei campi selezionabili dall'utente.
Metodo pubblico | AddValueToRecentListInTheRegistry | Metodo che aggiorna l'elenco dei recenti nel registro. Nel caso in cui sia visibile il combobox, l'anagrafica in ingresso viene ignorata. Se il codice ricavato è una stringa vuota, non viene inserita nell'elenco dei recenti.
Metodo protetto | BaseWndProc | (Ereditato da XtraUserControl)
Metodo pubblico | ClearText | Ripulisce il testo del controllo attualmente visibile
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraUserControl)
Metodo protetto | CreatePainter | (Ereditato da XtraUserControl)
Metodo pubblico | Dispose | Esegue il dispose dei controlli utente particolarmente dispendiosi
Metodo protetto | Dispose(Boolean) | Clean up any resources being used. (Sovrascrive UserControlBaseDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraUserControl)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraUserControl)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraUserControl)
Metodo protetto | GetBackColor | (Ereditato da XtraUserControl)
Metodo protetto | GetBackgroundSkinElement | (Ereditato da XtraUserControl)
Metodo pubblico | GetColumnValue | Metodo che ritorna il valore di una specifica colonna per la riga correntemente selezionata.
Metodo pubblico | GetDataFromCurrentCode(Boolean, Boolean) | Ritorna l'anagrafica (in ultima revisione) in base al codice presente.
Metodo pubblico | GetDataFromCurrentCode(Boolean, Boolean, Boolean) | Ritorna l'anagrafica (in ultima revisione) in base al codice presente.
Metodo protetto | GetInnerIXtraResizableControl | (Ereditato da XtraUserControl)
Metodo pubblico | GetListOfRecents | Metodo che legge dal registro la lista delle anagrafiche recenti. Elimina dalla lista eventuali spazi vuoti.
Metodo pubblico | GetSubKey | Riorna il nome della chiave di registro dalla quale leggere l'elenco delle anagrafiche recenti.
Metodo pubblico | GetSupplementaryQueryFields | Metodo che ritorna un array di stringhe contenente l'internalName dei dei campi supplementari su cui effettuare la query.
Metodo pubblico | GetText | Metodo che ritorna il testo del controllo attualmente visibile.
Metodo pubblico | Initialize(String, String, DedFindCodeContextEnum) | Evento che scatta in fase di caricamento del controllo.
Metodo pubblico | Initialize(String, String, DedFindCodeContextEnum, Boolean) | Evento che scatta in fase di caricamento del controllo.
Metodo protetto | IsChildControlsRequiredScalingEnabled | (Ereditato da XtraUserControl)
Metodo protetto | IsParentHandleCreatedRecursive | (Ereditato da XtraUserControl)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraUserControl)
Metodo protetto | OnBackColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnContextMenuOpening | Evento di apertura del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnControlAdded | (Ereditato da XtraUserControl)
Metodo protetto | OnControlRemoved | (Ereditato da XtraUserControl)
Metodo protetto | OnDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnFirstLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnForeColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleCreated | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleDestroyed(EventArgs) | Evento usato per terminare il task di recupero codici nel database. It is raised, when the underlying HWnd is destroyed(which usually happens, when the parent form is closed). (Sovrascrive ControlOnHandleDestroyed(EventArgs))
Metodo protetto | OnHandleDestroyed(EventArgs) | (Ereditato da XtraUserControl)
Metodo protetto | OnLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnMenuItemClicked | Evento di pressione di un comando del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnPaintCore | (Ereditato da XtraUserControl)
Metodo protetto | OnParentChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | OnSizeChanged | (Ereditato da XtraUserControl)
Metodo protetto | RaisePaintExEvent | (Ereditato da XtraUserControl)
Metodo pubblico | ResetBackColor | (Ereditato da XtraUserControl)
Metodo pubblico | ResetForeColor | (Ereditato da XtraUserControl)
Metodo protetto | RestoreAutoScaleModeChangedByPM2 | (Ereditato da XtraUserControl)
Metodo pubblico | RunFind | Lancia il comando di ricerca e imposta l'anagrafica selezionata
Metodo pubblico | RunTask | Invoca il task per effettuare la query e riempire la DataTable del lookupedit.
Metodo protetto | ScaleControl | (Ereditato da XtraUserControl)
Metodo pubblico | SelectAll | Metodo che seleziona tutto il testo del controllo attualmente visibile.
Metodo pubblico | SetCommandList | Rigenera il menu contestuale di questo controllo con la lista dei comandi passati. (Ereditato da UserControlBase)
Metodo pubblico | SetInternalActiveControl | Imposto il controllo attivo in base all'opzione 'RunQueryOnEnter'.
Metodo pubblico | SetOnlyLastRev | Imposta il flag che determina se mostrare solo le anagrafiche in ultima revisione o meno.
Metodo pubblico | SetRecentsRegistryKeyName | Nome della chiave di registro contenente l'elenco dei recenti.
Metodo pubblico | SetText | Metodo che imposta il testo del controllo attualmente visibile.
Metodo pubblico | SetValue | Metodo che imposta il testo del controllo attualmente visibile.
Metodo protetto | SetVisibleCore | (Ereditato da XtraUserControl)
Metodo protetto | ShouldPaintTransparentBackground | (Ereditato da XtraUserControl)
Metodo protetto | ShouldUseDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | WndProc | (Ereditato da XtraUserControl)
Torna su
Vedi anche

Documentazione

Classe DedFindCodeControl
Namespace DedNet.Controls


Metodo DedFindCodeControl.AddLookUpField

Metodo DedFindCodeControlAddLookUpField
Metodo che aggiunge una colonna al lookupedit.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddLookUpField(
    string field
)
Public Sub AddLookUpField (
    field As String
)
public:
void AddLookUpField(
    String^ field
)
member AddLookUpField :
        field : string -> unit

Parametri

field String
Nome colonna da aggiungere al lookupedit.
Vedi anche

Documentazione

Classe DedFindCodeControl
Namespace DedNet.Controls


Metodo DedFindCodeControl.AddQueryField

Metodo DedFindCodeControlAddQueryField
Aggiunge un campo nel combo di sinistra con la lista dei campi selezionabili dall'utente.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddQueryField(
    string field
)
Public Sub AddQueryField (
    field As String
)
public:
void AddQueryField(
    String^ field
)
member AddQueryField :
        field : string -> unit

Parametri

field String
Nome del campo da aggiungere.
Vedi anche

Documentazione

Classe DedFindCodeControl
Namespace DedNet.Controls


Metodo DedFindCodeControl.AddValueToRecentListInTheRegistry

Metodo DedFindCodeControlAddValueToRecentListInTheRegistry
Metodo che aggiorna l'elenco dei recenti nel registro. Nel caso in cui sia visibile il combobox, l'anagrafica in ingresso viene ignorata. Se il codice ricavato è una stringa vuota, non viene inserita nell'elenco dei recenti.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddValueToRecentListInTheRegistry(
    DedData data = null
)
Public Sub AddValueToRecentListInTheRegistry (
    Optional data As DedData = Nothing
)
public:
void AddValueToRecentListInTheRegistry(
    DedData^ data = nullptr
)
member AddValueToRecentListInTheRegistry :
        ?data : DedData
(* Defaults:
        let _data = defaultArg data null
*)
-> unit

Parametri

data DedData (Optional)
Anagrafica da aggiungere all'elenco dei recenti. Viene presa in cosiderazione solamente nel caso in cui sia visibile il lookupedit
Vedi anche

Documentazione

Classe DedFindCodeControl
Namespace DedNet.Controls


Metodo DedFindCodeControl.ClearText

Metodo DedFindCodeControlClearText
Ripulisce il testo del controllo attualmente visibile

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ClearText()
Public Sub ClearText
public:
void ClearText()
member ClearText : unit -> unit
Vedi anche

Documentazione

Classe DedFindCodeControl
Namespace DedNet.Controls


Metodo DedFindCodeControl.Dispose

Metodo DedFindCodeControlDispose
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Dispose | Esegue il dispose dei controlli utente particolarmente dispendiosi
Metodo protetto | Dispose(Boolean) | Clean up any resources being used.
Torna su
Vedi anche

Documentazione

Classe DedFindCodeControl
Namespace DedNet.Controls


Metodo DedFindCodeControl.Dispose

Metodo DedFindCodeControlDispose
Esegue il dispose dei controlli utente particolarmente dispendiosi

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
void Dispose()
member Dispose : unit -> unit
Vedi anche

Documentazione

Classe DedFindCodeControl
Overload di Dispose
Namespace DedNet.Controls


Metodo DedFindCodeControl.Dispose(Boolean)

Metodo DedFindCodeControlDispose(Boolean)
Clean up any resources being used.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFindCodeControl
Overload di Dispose
Namespace DedNet.Controls


Metodo DedFindCodeControl.GetColumnValue

Metodo DedFindCodeControlGetColumnValue
Metodo che ritorna il valore di una specifica colonna per la riga correntemente selezionata.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object GetColumnValue(
    string columnName
)
Public Function GetColumnValue (
    columnName As String
) As Object
public:
Object^ GetColumnValue(
    String^ columnName
)
member GetColumnValue :
        columnName : string -> Object

Parametri

columnName String
Nome della colonna.

Valore di ritorno

Object
Valore della riga.
Vedi anche

Documentazione

Classe DedFindCodeControl
Namespace DedNet.Controls


Metodo DedFindCodeControl.GetDataFromCurrentCode

Metodo DedFindCodeControlGetDataFromCurrentCode
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | GetDataFromCurrentCode(Boolean, Boolean) | Ritorna l'anagrafica (in ultima revisione) in base al codice presente.
Metodo pubblico | GetDataFromCurrentCode(Boolean, Boolean, Boolean) | Ritorna l'anagrafica (in ultima revisione) in base al codice presente.
Torna su
Vedi anche

Documentazione

Classe DedFindCodeControl
Namespace DedNet.Controls


Metodo DedFindCodeControl.GetDataFromCurrentCode(Boolean, Boolean)

Metodo DedFindCodeControlGetDataFromCurrentCode(Boolean, Boolean)
Ritorna l'anagrafica (in ultima revisione) in base al codice presente.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData GetDataFromCurrentCode(
    bool silent = false,
    bool forceQueryOnEnter = false
)
Public Function GetDataFromCurrentCode (
    Optional silent As Boolean = false,
    Optional forceQueryOnEnter As Boolean = false
) As DedData
public:
DedData^ GetDataFromCurrentCode(
    bool silent = false,
    bool forceQueryOnEnter = false
)
member GetDataFromCurrentCode :
        ?silent : bool *
        ?forceQueryOnEnter : bool
(* Defaults:
        let _silent = defaultArg silent false
        let _forceQueryOnEnter = defaultArg forceQueryOnEnter false
*)
-> DedData

Parametri

silent Boolean (Optional)
Indica se mostrare (True) o meno (False) eventuali messaggi d'errore. Di default è False.
forceQueryOnEnter Boolean (Optional)
Indica se forzare l'utilizzo del QueryOnEnter.

Valore di ritorno

DedData
Oggetto anagrafica in ultima revisione.
Vedi anche

Documentazione

Classe DedFindCodeControl
Overload di GetDataFromCurrentCode
Namespace DedNet.Controls


Metodo DedFindCodeControl.GetDataFromCurrentCode(Boolean, Boolean, Boolean)

Metodo DedFindCodeControlGetDataFromCurrentCode(Boolean, Boolean, Boolean)
Ritorna l'anagrafica (in ultima revisione) in base al codice presente.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData GetDataFromCurrentCode(
    bool silent,
    bool forceQueryOnEnter,
    out bool showedMessage
)
Public Function GetDataFromCurrentCode (
    silent As Boolean,
    forceQueryOnEnter As Boolean,
    <OutAttribute> ByRef showedMessage As Boolean
) As DedData
public:
DedData^ GetDataFromCurrentCode(
    bool silent,
    bool forceQueryOnEnter,
    [OutAttribute] bool% showedMessage
)
member GetDataFromCurrentCode :
        silent : bool *
        forceQueryOnEnter : bool *
        showedMessage : bool byref -> DedData

Parametri

silent Boolean
Indica se mostrare (True) o meno (False) eventuali messaggi d'errore. Di default è False.
forceQueryOnEnter Boolean
Indica se forzare l'utilizzo del QueryOnEnter
showedMessage Boolean
Variabile che indica se è stato mostrato il messaggio d'errore o meno.

Valore di ritorno

DedData
Oggetto anagrafica in ultima revisione.
Vedi anche

Documentazione

Classe DedFindCodeControl
Overload di GetDataFromCurrentCode
Namespace DedNet.Controls


Metodo DedFindCodeControl.GetListOfRecents

Metodo DedFindCodeControlGetListOfRecents
Metodo che legge dal registro la lista delle anagrafiche recenti. Elimina dalla lista eventuali spazi vuoti.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string[] GetListOfRecents()
Public Function GetListOfRecents As String()
public:
array<String^>^ GetListOfRecents()
member GetListOfRecents : unit -> string[]

Valore di ritorno

String
Ritorna un array di stringhe.
Vedi anche

Documentazione

Classe DedFindCodeControl
Namespace DedNet.Controls


Metodo DedFindCodeControl.GetSubKey

Metodo DedFindCodeControlGetSubKey
Riorna il nome della chiave di registro dalla quale leggere l'elenco delle anagrafiche recenti.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string GetSubKey()
Public Function GetSubKey As String
public:
String^ GetSubKey()
member GetSubKey : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedFindCodeControl
Namespace DedNet.Controls


Metodo DedFindCodeControl.GetSupplementaryQueryFields

Metodo DedFindCodeControlGetSupplementaryQueryFields
Metodo che ritorna un array di stringhe contenente l'internalName dei dei campi supplementari su cui effettuare la query.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string[] GetSupplementaryQueryFields()
Public Function GetSupplementaryQueryFields As String()
public:
array<String^>^ GetSupplementaryQueryFields()
member GetSupplementaryQueryFields : unit -> string[]

Valore di ritorno

String
Array di stringhe contenenente tutti i campi supplementari.
Vedi anche

Documentazione

Classe DedFindCodeControl
Namespace DedNet.Controls


Metodo DedFindCodeControl.GetText

Metodo DedFindCodeControlGetText
Metodo che ritorna il testo del controllo attualmente visibile.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string GetText()
Public Function GetText As String
public:
String^ GetText()
member GetText : unit -> string

Valore di ritorno

String
Testo contenuto all'interno del combobox o del lookupedit.
Vedi anche

Documentazione

Classe DedFindCodeControl
Namespace DedNet.Controls


Metodo DedFindCodeControl.Initialize

Metodo DedFindCodeControlInitialize
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Initialize(String, String, DedFindCodeContextEnum) | Evento che scatta in fase di caricamento del controllo.
Metodo pubblico | Initialize(String, String, DedFindCodeContextEnum, Boolean) | Evento che scatta in fase di caricamento del controllo.
Torna su
Vedi anche

Documentazione

Classe DedFindCodeControl
Namespace DedNet.Controls


Metodo DedFindCodeControl.Initialize(String, String, DedFindCodeContextEnum)

Metodo DedFindCodeControlInitialize(String, String, DedFindCodeContextEnum)
Evento che scatta in fase di caricamento del controllo.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Initialize(
    string pathRegKey,
    string nameRegKey,
    DedFindCodeContextEnum context
)
Public Sub Initialize (
    pathRegKey As String,
    nameRegKey As String,
    context As DedFindCodeContextEnum
)
public:
void Initialize(
    String^ pathRegKey,
    String^ nameRegKey,
    DedFindCodeContextEnum context
)
member Initialize :
        pathRegKey : string *
        nameRegKey : string *
        context : DedFindCodeContextEnum -> unit

Parametri

pathRegKey String
Path della chiave di registro dove salvare le informazioni.
nameRegKey String
Nome della sottochiave di registro dove leggere l'elenco dei recenti.
context DedFindCodeContextEnum
Contesto di utilizzo del controllo.
Vedi anche

Documentazione

Classe DedFindCodeControl
Overload di Initialize
Namespace DedNet.Controls


Metodo DedFindCodeControl.Initialize(String, String, DedFindCodeContextEnum, Boolean)

Metodo DedFindCodeControlInitialize(String, String, DedFindCodeContextEnum, Boolean)
Evento che scatta in fase di caricamento del controllo.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Initialize(
    string pathRegKey,
    string nameRegKey,
    DedFindCodeContextEnum context,
    bool onlyLastRev
)
Public Sub Initialize (
    pathRegKey As String,
    nameRegKey As String,
    context As DedFindCodeContextEnum,
    onlyLastRev As Boolean
)
public:
void Initialize(
    String^ pathRegKey,
    String^ nameRegKey,
    DedFindCodeContextEnum context,
    bool onlyLastRev
)
member Initialize :
        pathRegKey : string *
        nameRegKey : string *
        context : DedFindCodeContextEnum *
        onlyLastRev : bool -> unit

Parametri

pathRegKey String
Path della chiave di registro dove salvare le informazioni.
nameRegKey String
Nome della sottochiave di registro dove leggere l'elenco dei recenti.
context DedFindCodeContextEnum
Contesto di utilizzo del controllo.
onlyLastRev Boolean
Indica se visualizzare o meno solo le anagrafiche in ultima revisione nel lookup.
Vedi anche

Documentazione

Classe DedFindCodeControl
Overload di Initialize
Namespace DedNet.Controls


Metodo DedFindCodeControl.OnHandleDestroyed

Metodo DedFindCodeControlOnHandleDestroyed
Lista degli overload
 | Nome | Descrizione
Metodo protetto | OnHandleDestroyed(EventArgs) | Evento usato per terminare il task di recupero codici nel database. It is raised, when the underlying HWnd is destroyed(which usually happens, when the parent form is closed).
Metodo protetto | OnHandleDestroyed(EventArgs) |
Torna su
Vedi anche

Documentazione

Classe DedFindCodeControl
Namespace DedNet.Controls


Metodo DedFindCodeControl.OnHandleDestroyed(EventArgs)

Metodo DedFindCodeControlOnHandleDestroyed(EventArgs)
Evento usato per terminare il task di recupero codici nel database. It is raised, when the underlying HWnd is destroyed(which usually happens, when the parent form is closed).

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void OnHandleDestroyed(
    EventArgs e
)
Protected Overrides Sub OnHandleDestroyed (
    e As EventArgs
)
protected:
virtual void OnHandleDestroyed(
    EventArgs^ e
) override
abstract OnHandleDestroyed :
        e : EventArgs -> unit
override OnHandleDestroyed :
        e : EventArgs -> unit

Parametri

e EventArgs
Vedi anche

Documentazione

Classe DedFindCodeControl
Overload di OnHandleDestroyed
Namespace DedNet.Controls


Metodo DedFindCodeControl.RunFind

Metodo DedFindCodeControlRunFind
Lancia il comando di ricerca e imposta l'anagrafica selezionata

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void RunFind()
Public Sub RunFind
public:
void RunFind()
member RunFind : unit -> unit
Vedi anche

Documentazione

Classe DedFindCodeControl
Namespace DedNet.Controls


Metodo DedFindCodeControl.RunTask

Metodo DedFindCodeControlRunTask
Invoca il task per effettuare la query e riempire la DataTable del lookupedit.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void RunTask()
Public Sub RunTask
public:
void RunTask()
member RunTask : unit -> unit
Vedi anche

Documentazione

Classe DedFindCodeControl
Namespace DedNet.Controls


Metodo DedFindCodeControl.SelectAll

Metodo DedFindCodeControlSelectAll
Metodo che seleziona tutto il testo del controllo attualmente visibile.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SelectAll()
Public Sub SelectAll
public:
void SelectAll()
member SelectAll : unit -> unit
Vedi anche

Documentazione

Classe DedFindCodeControl
Namespace DedNet.Controls


Metodo DedFindCodeControl.SetInternalActiveControl

Metodo DedFindCodeControlSetInternalActiveControl
Imposto il controllo attivo in base all'opzione 'RunQueryOnEnter'.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetInternalActiveControl()
Public Sub SetInternalActiveControl
public:
void SetInternalActiveControl()
member SetInternalActiveControl : unit -> unit
Vedi anche

Documentazione

Classe DedFindCodeControl
Namespace DedNet.Controls


Metodo DedFindCodeControl.SetOnlyLastRev

Metodo DedFindCodeControlSetOnlyLastRev
Imposta il flag che determina se mostrare solo le anagrafiche in ultima revisione o meno.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetOnlyLastRev(
    bool newOnlyLastRev
)
Public Sub SetOnlyLastRev (
    newOnlyLastRev As Boolean
)
public:
void SetOnlyLastRev(
    bool newOnlyLastRev
)
member SetOnlyLastRev :
        newOnlyLastRev : bool -> unit

Parametri

newOnlyLastRev Boolean
Se True visualizza solo le anagrafiche in ultima revisione, altrimenti tutte.
Vedi anche

Documentazione

Classe DedFindCodeControl
Namespace DedNet.Controls


Metodo DedFindCodeControl.SetRecentsRegistryKeyName

Metodo DedFindCodeControlSetRecentsRegistryKeyName
Nome della chiave di registro contenente l'elenco dei recenti.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetRecentsRegistryKeyName(
    string regKey
)
Public Sub SetRecentsRegistryKeyName (
    regKey As String
)
public:
void SetRecentsRegistryKeyName(
    String^ regKey
)
member SetRecentsRegistryKeyName :
        regKey : string -> unit

Parametri

regKey String
Vedi anche

Documentazione

Classe DedFindCodeControl
Namespace DedNet.Controls


Metodo DedFindCodeControl.SetText

Metodo DedFindCodeControlSetText
Metodo che imposta il testo del controllo attualmente visibile.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetText(
    string txt
)
Public Sub SetText (
    txt As String
)
public:
void SetText(
    String^ txt
)
member SetText :
        txt : string -> unit

Parametri

txt String
Testo da inserire nel controllo.
Vedi anche

Documentazione

Classe DedFindCodeControl
Namespace DedNet.Controls


Metodo DedFindCodeControl.SetValue

Metodo DedFindCodeControlSetValue
Metodo che imposta il testo del controllo attualmente visibile.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetValue(
    DedData data
)
Public Sub SetValue (
    data As DedData
)
public:
void SetValue(
    DedData^ data
)
member SetValue :
        data : DedData -> unit

Parametri

data DedData
Anagrafica di riferimento.
Vedi anche

Documentazione

Classe DedFindCodeControl
Namespace DedNet.Controls


Eventi di DedFindCodeControl

Il tipo DedFindCodeControl espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | ContextMenuOpening | Evento su apertura del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | EditValueChangedCombo | Evento che scatta quando cambia il valore del combobox.
Evento pubblico | EditValueChangedLookUp | Evento che scatta quando cambia il valore del lookupedit.
Evento pubblico | FilterByChanged | Evento che scatta se cambiato l'attributo di ricerca.
Evento pubblico | KeyDownCombo | Evento che scatta ogni volta che è stato premuto un tasto all'interno del combobox.
Evento pubblico | KeyDownLookUp | Evento che scatta quando premuto un tasto da tastiera nel lookupedit.
Evento pubblico | KeyUpCombo | Evento che scatta ogni volta che è stato rilasciato un tasto all'interno del combobox.
Evento pubblico | LookUpCancelButtonPressed | Evento che scatta quando premuto il bottono di annulla nel lookupedit.
Evento pubblico | LookUpOkButtonPressed | Evento che scatta quando premuto il bottono di conferma nel lookupedit.
Evento pubblico | MenuItemClicked | Evento su click su un elemento del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | PaintEx | (Ereditato da XtraUserControl)
Torna su
Vedi anche

Documentazione

Classe DedFindCodeControl
Namespace DedNet.Controls


Evento DedFindCodeControl.EditValueChangedCombo

Evento DedFindCodeControlEditValueChangedCombo
Evento che scatta quando cambia il valore del combobox.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler EditValueChangedCombo
Public Event EditValueChangedCombo As EventHandler
public:
 event EventHandler^ EditValueChangedCombo {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member EditValueChangedCombo : IEvent<EventHandler,
    EventArgs>

Valore

EventHandler
Vedi anche

Documentazione

Classe DedFindCodeControl
Namespace DedNet.Controls


Evento DedFindCodeControl.EditValueChangedLookUp

Evento DedFindCodeControlEditValueChangedLookUp
Evento che scatta quando cambia il valore del lookupedit.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler EditValueChangedLookUp
Public Event EditValueChangedLookUp As EventHandler
public:
 event EventHandler^ EditValueChangedLookUp {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member EditValueChangedLookUp : IEvent<EventHandler,
    EventArgs>

Valore

EventHandler
Vedi anche

Documentazione

Classe DedFindCodeControl
Namespace DedNet.Controls


Evento DedFindCodeControl.FilterByChanged

Evento DedFindCodeControlFilterByChanged
Evento che scatta se cambiato l'attributo di ricerca.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler FilterByChanged
Public Event FilterByChanged As EventHandler
public:
 event EventHandler^ FilterByChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member FilterByChanged : IEvent<EventHandler,
    EventArgs>

Valore

EventHandler
Vedi anche

Documentazione

Classe DedFindCodeControl
Namespace DedNet.Controls


Evento DedFindCodeControl.KeyDownCombo

Evento DedFindCodeControlKeyDownCombo
Evento che scatta ogni volta che è stato premuto un tasto all'interno del combobox.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event KeyEventHandler KeyDownCombo
Public Event KeyDownCombo As KeyEventHandler
public:
 event KeyEventHandler^ KeyDownCombo {
    void add (KeyEventHandler^ value);
    void remove (KeyEventHandler^ value);
}
member KeyDownCombo : IEvent<KeyEventHandler,
    KeyEventArgs>

Valore

KeyEventHandler
Vedi anche

Documentazione

Classe DedFindCodeControl
Namespace DedNet.Controls


Evento DedFindCodeControl.KeyDownLookUp

Evento DedFindCodeControlKeyDownLookUp
Evento che scatta quando premuto un tasto da tastiera nel lookupedit.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event KeyEventHandler KeyDownLookUp
Public Event KeyDownLookUp As KeyEventHandler
public:
 event KeyEventHandler^ KeyDownLookUp {
    void add (KeyEventHandler^ value);
    void remove (KeyEventHandler^ value);
}
member KeyDownLookUp : IEvent<KeyEventHandler,
    KeyEventArgs>

Valore

KeyEventHandler
Vedi anche

Documentazione

Classe DedFindCodeControl
Namespace DedNet.Controls


Evento DedFindCodeControl.KeyUpCombo

Evento DedFindCodeControlKeyUpCombo
Evento che scatta ogni volta che è stato rilasciato un tasto all'interno del combobox.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event KeyEventHandler KeyUpCombo
Public Event KeyUpCombo As KeyEventHandler
public:
 event KeyEventHandler^ KeyUpCombo {
    void add (KeyEventHandler^ value);
    void remove (KeyEventHandler^ value);
}
member KeyUpCombo : IEvent<KeyEventHandler,
    KeyEventArgs>

Valore

KeyEventHandler
Vedi anche

Documentazione

Classe DedFindCodeControl
Namespace DedNet.Controls


Evento DedFindCodeControl.LookUpCancelButtonPressed

Evento DedFindCodeControlLookUpCancelButtonPressed
Evento che scatta quando premuto il bottono di annulla nel lookupedit.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler LookUpCancelButtonPressed
Public Event LookUpCancelButtonPressed As EventHandler
public:
 event EventHandler^ LookUpCancelButtonPressed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member LookUpCancelButtonPressed : IEvent<EventHandler,
    EventArgs>

Valore

EventHandler
Vedi anche

Documentazione

Classe DedFindCodeControl
Namespace DedNet.Controls


Evento DedFindCodeControl.LookUpOkButtonPressed

Evento DedFindCodeControlLookUpOkButtonPressed
Evento che scatta quando premuto il bottono di conferma nel lookupedit.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler LookUpOkButtonPressed
Public Event LookUpOkButtonPressed As EventHandler
public:
 event EventHandler^ LookUpOkButtonPressed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member LookUpOkButtonPressed : IEvent<EventHandler,
    EventArgs>

Valore

EventHandler
Vedi anche

Documentazione

Classe DedFindCodeControl
Namespace DedNet.Controls


Campi di DedFindCodeControl

Il tipo DedFindCodeControl espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | _app | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Campo protetto | _RegistryBaseKey | Chiave nel registro di sistema di salvataggio impostazioni. (Ereditato da UserControlBase)
Torna su
Vedi anche

Documentazione

Classe DedFindCodeControl
Namespace DedNet.Controls


Enumerazione DedFindCodeControl.FonteDati

Enumerazione DedFindCodeControlFonteDati
Fonte dati selezionata.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum FonteDati
Public Enumeration FonteDati
public enum class FonteDati
type FonteDati
Membri
Nome | Valore | Descrizione
Db | 0 | Codici presenti nel database.
Recenti | 1 | Codici presenti nella chiave di registro contenente i recenti.
Vedi anche

Documentazione

Namespace DedNet.Controls


Classe DedFindCommControl
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
XtraUserControl
DedNet.ControlsUserControlBase
DedNet.ControlsDedFindCommControl

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFindCommControl : UserControlBase
Public Class DedFindCommControl
    Inherits UserControlBase
public ref class DedFindCommControl : public UserControlBase
type DedFindCommControl =
    class
        inherit UserControlBase
    end

Il tipo DedFindCommControl espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFindCommControl |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Appearance | (Ereditato da XtraUserControl)
Proprietà pubblica | Application | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Proprietà pubblica | BackColor | (Ereditato da XtraUserControl)
Proprietà pubblica | BtnCurComEnabled | Indica se abilitare il pulsante di commessa corrente
Proprietà protetta | CheckDoubleScaling | (Ereditato da XtraUserControl)
Proprietà pubblica | ComEnabled | Indica se abilitare il controllo della selezione commessa
Proprietà protetta | DefaultAppearance | (Ereditato da XtraUserControl)
Proprietà protetta | DirectXContainer | (Ereditato da XtraUserControl)
Proprietà pubblica | EnableIXtraResizeableControlInterfaceProxy | (Ereditato da XtraUserControl)
Proprietà pubblica | Font | (Ereditato da XtraUserControl)
Proprietà pubblica | ForeColor | (Ereditato da XtraUserControl)
Proprietà protetta | Helper | (Ereditato da XtraUserControl)
Proprietà pubblica | HideCreateCommBtn | Se True rimuove il controllo di scelta quantità
Proprietà pubblica | HideCurCommBtn | Se True rimuove il controllo di scelta quantità
Proprietà pubblica | HideQta | Se True rimuove il controllo di scelta quantità
Proprietà pubblica | Inherited | Se il colore testo deve evidenziare l'ereditarietà della proprietà
Proprietà pubblica | LookAndFeel | (Ereditato da XtraUserControl)
Proprietà pubblica | MainRegistryKey |
Proprietà protetta | Painter | (Ereditato da XtraUserControl)
Proprietà pubblica | Qta | Restituisce la quantità impostata
Proprietà pubblica | QtaEnabled | Disabilita i controlli della quantità
Proprietà protetta | ScaleChildren | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleDPI | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraUserControl)
Proprietà pubblica | SelComm | Restituisce la commessa selezionata
Proprietà pubblica | SelCommName | Restiruisce il nome della commessa
Proprietà pubblica | SetLabel | Imposta la label
Proprietà protetta | ShouldCheckDpiScaleFactorOnParentChanged | (Ereditato da XtraUserControl)
Proprietà pubblica | Site | (Ereditato da XtraUserControl)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | BaseWndProc | (Ereditato da XtraUserControl)
Metodo pubblico | Clear | Pulisce il text edit
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraUserControl)
Metodo protetto | CreatePainter | (Ereditato da XtraUserControl)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive UserControlBaseDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraUserControl)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraUserControl)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraUserControl)
Metodo protetto | GetBackColor | (Ereditato da XtraUserControl)
Metodo protetto | GetBackgroundSkinElement | (Ereditato da XtraUserControl)
Metodo protetto | GetInnerIXtraResizableControl | (Ereditato da XtraUserControl)
Metodo protetto | IsChildControlsRequiredScalingEnabled | (Ereditato da XtraUserControl)
Metodo protetto | IsParentHandleCreatedRecursive | (Ereditato da XtraUserControl)
Metodo pubblico | Load(DedNetApplication, String) | Effettua il caricamento dei dati
Metodo pubblico | Load(DedNetApplication, String, DedCommCommKindEnum) | Effettua il caricamento dei dati
Metodo pubblico | LoadAllComm | Effettua il caricamento di tutte le commesse
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraUserControl)
Metodo protetto | OnBackColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnContextMenuOpening | Evento di apertura del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnControlAdded | (Ereditato da XtraUserControl)
Metodo protetto | OnControlRemoved | (Ereditato da XtraUserControl)
Metodo protetto | OnDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnFirstLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnForeColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleCreated | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraUserControl)
Metodo protetto | OnLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnMenuItemClicked | Evento di pressione di un comando del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnPaintCore | (Ereditato da XtraUserControl)
Metodo protetto | OnParentChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | OnSizeChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnTextCommChanged | Lancia l'evento di SelectionChanged passando i documenti correntemente selezionati.
Metodo protetto | RaisePaintExEvent | (Ereditato da XtraUserControl)
Metodo pubblico | ResetBackColor | (Ereditato da XtraUserControl)
Metodo pubblico | ResetForeColor | (Ereditato da XtraUserControl)
Metodo protetto | RestoreAutoScaleModeChangedByPM2 | (Ereditato da XtraUserControl)
Metodo protetto | ScaleControl | (Ereditato da XtraUserControl)
Metodo pubblico | SetCommandList | Rigenera il menu contestuale di questo controllo con la lista dei comandi passati. (Ereditato da UserControlBase)
Metodo protetto | SetVisibleCore | (Ereditato da XtraUserControl)
Metodo protetto | ShouldPaintTransparentBackground | (Ereditato da XtraUserControl)
Metodo protetto | ShouldUseDirectXPaint | (Ereditato da XtraUserControl)
Metodo pubblico | Update | Aggiorna la lista delle commesse master
Metodo protetto | WndProc | (Ereditato da XtraUserControl)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | ContextMenuOpening | Evento su apertura del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | MenuItemClicked | Evento su click su un elemento del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | PaintEx | (Ereditato da XtraUserControl)
Evento pubblico | TextCommChanged | Evento lanciato sulla modifica della selezione dei documenti.
Torna su
Campi
 | Nome | Descrizione
Campo protetto | _app | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Campo protetto | _RegistryBaseKey | Chiave nel registro di sistema di salvataggio impostazioni. (Ereditato da UserControlBase)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore DedFindCommControl

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFindCommControl()
Public Sub New
public:
DedFindCommControl()
new : unit -> DedFindCommControl
Vedi anche

Documentazione

Classe DedFindCommControl
Namespace DedNet.Controls


Proprietà di DedFindCommControl

Il tipo DedFindCommControl espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Appearance | (Ereditato da XtraUserControl)
Proprietà pubblica | Application | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Proprietà pubblica | BackColor | (Ereditato da XtraUserControl)
Proprietà pubblica | BtnCurComEnabled | Indica se abilitare il pulsante di commessa corrente
Proprietà protetta | CheckDoubleScaling | (Ereditato da XtraUserControl)
Proprietà pubblica | ComEnabled | Indica se abilitare il controllo della selezione commessa
Proprietà protetta | DefaultAppearance | (Ereditato da XtraUserControl)
Proprietà protetta | DirectXContainer | (Ereditato da XtraUserControl)
Proprietà pubblica | EnableIXtraResizeableControlInterfaceProxy | (Ereditato da XtraUserControl)
Proprietà pubblica | Font | (Ereditato da XtraUserControl)
Proprietà pubblica | ForeColor | (Ereditato da XtraUserControl)
Proprietà protetta | Helper | (Ereditato da XtraUserControl)
Proprietà pubblica | HideCreateCommBtn | Se True rimuove il controllo di scelta quantità
Proprietà pubblica | HideCurCommBtn | Se True rimuove il controllo di scelta quantità
Proprietà pubblica | HideQta | Se True rimuove il controllo di scelta quantità
Proprietà pubblica | Inherited | Se il colore testo deve evidenziare l'ereditarietà della proprietà
Proprietà pubblica | LookAndFeel | (Ereditato da XtraUserControl)
Proprietà pubblica | MainRegistryKey |
Proprietà protetta | Painter | (Ereditato da XtraUserControl)
Proprietà pubblica | Qta | Restituisce la quantità impostata
Proprietà pubblica | QtaEnabled | Disabilita i controlli della quantità
Proprietà protetta | ScaleChildren | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleDPI | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraUserControl)
Proprietà pubblica | SelComm | Restituisce la commessa selezionata
Proprietà pubblica | SelCommName | Restiruisce il nome della commessa
Proprietà pubblica | SetLabel | Imposta la label
Proprietà protetta | ShouldCheckDpiScaleFactorOnParentChanged | (Ereditato da XtraUserControl)
Proprietà pubblica | Site | (Ereditato da XtraUserControl)
Torna su
Vedi anche

Documentazione

Classe DedFindCommControl
Namespace DedNet.Controls


Proprietà DedFindCommControl.BtnCurComEnabled

Proprietà DedFindCommControlBtnCurComEnabled
Indica se abilitare il pulsante di commessa corrente

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool BtnCurComEnabled { set; }
Public WriteOnly Property BtnCurComEnabled As Boolean
    Set
public:
property bool BtnCurComEnabled {
    void set (bool value);
}
member BtnCurComEnabled : bool with set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFindCommControl
Namespace DedNet.Controls


Proprietà DedFindCommControl.ComEnabled

Proprietà DedFindCommControlComEnabled
Indica se abilitare il controllo della selezione commessa

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ComEnabled { set; }
Public WriteOnly Property ComEnabled As Boolean
    Set
public:
property bool ComEnabled {
    void set (bool value);
}
member ComEnabled : bool with set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFindCommControl
Namespace DedNet.Controls


Proprietà DedFindCommControl.HideCreateCommBtn

Proprietà DedFindCommControlHideCreateCommBtn
Se True rimuove il controllo di scelta quantità

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HideCreateCommBtn { set; }
Public WriteOnly Property HideCreateCommBtn As Boolean
    Set
public:
property bool HideCreateCommBtn {
    void set (bool value);
}
member HideCreateCommBtn : bool with set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFindCommControl
Namespace DedNet.Controls


Proprietà DedFindCommControl.HideCurCommBtn

Proprietà DedFindCommControlHideCurCommBtn
Se True rimuove il controllo di scelta quantità

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HideCurCommBtn { set; }
Public WriteOnly Property HideCurCommBtn As Boolean
    Set
public:
property bool HideCurCommBtn {
    void set (bool value);
}
member HideCurCommBtn : bool with set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFindCommControl
Namespace DedNet.Controls


Proprietà DedFindCommControl.HideQta

Proprietà DedFindCommControlHideQta
Se True rimuove il controllo di scelta quantità

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HideQta { set; }
Public WriteOnly Property HideQta As Boolean
    Set
public:
property bool HideQta {
    void set (bool value);
}
member HideQta : bool with set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFindCommControl
Namespace DedNet.Controls


Proprietà DedFindCommControl.Inherited

Proprietà DedFindCommControlInherited
Se il colore testo deve evidenziare l'ereditarietà della proprietà

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Inherited { set; }
Public WriteOnly Property Inherited As Boolean
    Set
public:
property bool Inherited {
    void set (bool value);
}
member Inherited : bool with set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFindCommControl
Namespace DedNet.Controls


Proprietà DedFindCommControl.MainRegistryKey

Proprietà DedFindCommControlMainRegistryKey

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string MainRegistryKey { get; set; }
Public Property MainRegistryKey As String
    Get
    Set
public:
property String^ MainRegistryKey {
    String^ get ();
    void set (String^ value);
}
member MainRegistryKey : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedFindCommControl
Namespace DedNet.Controls


Proprietà DedFindCommControl.Qta

Proprietà DedFindCommControlQta
Restituisce la quantità impostata

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int Qta { get; set; }
Public Property Qta As Integer
    Get
    Set
public:
property int Qta {
    int get ();
    void set (int value);
}
member Qta : int with get, set

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe DedFindCommControl
Namespace DedNet.Controls


Proprietà DedFindCommControl.QtaEnabled

Proprietà DedFindCommControlQtaEnabled
Disabilita i controlli della quantità

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool QtaEnabled { set; }
Public WriteOnly Property QtaEnabled As Boolean
    Set
public:
property bool QtaEnabled {
    void set (bool value);
}
member QtaEnabled : bool with set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFindCommControl
Namespace DedNet.Controls


Proprietà DedFindCommControl.SelComm

Proprietà DedFindCommControlSelComm
Restituisce la commessa selezionata

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedComm SelComm { get; set; }
Public Property SelComm As DedComm
    Get
    Set
public:
property DedComm^ SelComm {
    DedComm^ get ();
    void set (DedComm^ value);
}
member SelComm : DedComm with get, set

Valore della proprietà

DedComm
Vedi anche

Documentazione

Classe DedFindCommControl
Namespace DedNet.Controls


Proprietà DedFindCommControl.SelCommName

Proprietà DedFindCommControlSelCommName
Restiruisce il nome della commessa

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string SelCommName { get; set; }
Public Property SelCommName As String
    Get
    Set
public:
property String^ SelCommName {
    String^ get ();
    void set (String^ value);
}
member SelCommName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedFindCommControl
Namespace DedNet.Controls


Proprietà DedFindCommControl.SetLabel

Proprietà DedFindCommControlSetLabel
Imposta la label

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string SetLabel { set; }
Public WriteOnly Property SetLabel As String
    Set
public:
property String^ SetLabel {
    void set (String^ value);
}
member SetLabel : string with set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedFindCommControl
Namespace DedNet.Controls


Metodi di DedFindCommControl

Il tipo DedFindCommControl espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | BaseWndProc | (Ereditato da XtraUserControl)
Metodo pubblico | Clear | Pulisce il text edit
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraUserControl)
Metodo protetto | CreatePainter | (Ereditato da XtraUserControl)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive UserControlBaseDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraUserControl)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraUserControl)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraUserControl)
Metodo protetto | GetBackColor | (Ereditato da XtraUserControl)
Metodo protetto | GetBackgroundSkinElement | (Ereditato da XtraUserControl)
Metodo protetto | GetInnerIXtraResizableControl | (Ereditato da XtraUserControl)
Metodo protetto | IsChildControlsRequiredScalingEnabled | (Ereditato da XtraUserControl)
Metodo protetto | IsParentHandleCreatedRecursive | (Ereditato da XtraUserControl)
Metodo pubblico | Load(DedNetApplication, String) | Effettua il caricamento dei dati
Metodo pubblico | Load(DedNetApplication, String, DedCommCommKindEnum) | Effettua il caricamento dei dati
Metodo pubblico | LoadAllComm | Effettua il caricamento di tutte le commesse
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraUserControl)
Metodo protetto | OnBackColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnContextMenuOpening | Evento di apertura del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnControlAdded | (Ereditato da XtraUserControl)
Metodo protetto | OnControlRemoved | (Ereditato da XtraUserControl)
Metodo protetto | OnDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnFirstLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnForeColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleCreated | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraUserControl)
Metodo protetto | OnLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnMenuItemClicked | Evento di pressione di un comando del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnPaintCore | (Ereditato da XtraUserControl)
Metodo protetto | OnParentChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | OnSizeChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnTextCommChanged | Lancia l'evento di SelectionChanged passando i documenti correntemente selezionati.
Metodo protetto | RaisePaintExEvent | (Ereditato da XtraUserControl)
Metodo pubblico | ResetBackColor | (Ereditato da XtraUserControl)
Metodo pubblico | ResetForeColor | (Ereditato da XtraUserControl)
Metodo protetto | RestoreAutoScaleModeChangedByPM2 | (Ereditato da XtraUserControl)
Metodo protetto | ScaleControl | (Ereditato da XtraUserControl)
Metodo pubblico | SetCommandList | Rigenera il menu contestuale di questo controllo con la lista dei comandi passati. (Ereditato da UserControlBase)
Metodo protetto | SetVisibleCore | (Ereditato da XtraUserControl)
Metodo protetto | ShouldPaintTransparentBackground | (Ereditato da XtraUserControl)
Metodo protetto | ShouldUseDirectXPaint | (Ereditato da XtraUserControl)
Metodo pubblico | Update | Aggiorna la lista delle commesse master
Metodo protetto | WndProc | (Ereditato da XtraUserControl)
Torna su
Vedi anche

Documentazione

Classe DedFindCommControl
Namespace DedNet.Controls


Metodo DedFindCommControl.Clear

Metodo DedFindCommControlClear
Pulisce il text edit

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
Vedi anche

Documentazione

Classe DedFindCommControl
Namespace DedNet.Controls


Metodo DedFindCommControl.Dispose

Metodo DedFindCommControlDispose
Clean up any resources being used.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFindCommControl
Namespace DedNet.Controls


Metodo DedFindCommControl.Load

Metodo DedFindCommControlLoad
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Load(DedNetApplication, String) | Effettua il caricamento dei dati
Metodo pubblico | Load(DedNetApplication, String, DedCommCommKindEnum) | Effettua il caricamento dei dati
Torna su
Vedi anche

Documentazione

Classe DedFindCommControl
Namespace DedNet.Controls


Metodo DedFindCommControl.Load(DedNetApplication, String)

Metodo DedFindCommControlLoad(DedNetApplication, String)
Effettua il caricamento dei dati

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Load(
    DedNetApplication app,
    string mainRegKey
)
Public Sub Load (
    app As DedNetApplication,
    mainRegKey As String
)
public:
void Load(
    DedNetApplication^ app,
    String^ mainRegKey
)
member Load :
        app : DedNetApplication *
        mainRegKey : string -> unit

Parametri

app DedNetApplication
mainRegKey String
Vedi anche

Documentazione

Classe DedFindCommControl
Overload di Load
Namespace DedNet.Controls


Metodo DedFindCommControl.Load(DedNetApplication, String, DedComm.CommKindEnum)

Metodo DedFindCommControlLoad(DedNetApplication, String, DedCommCommKindEnum)
Effettua il caricamento dei dati

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Load(
    DedNetApplication app,
    string mainRegKey,
    DedCommCommKindEnum commKind
)
Public Sub Load (
    app As DedNetApplication,
    mainRegKey As String,
    commKind As DedCommCommKindEnum
)
public:
void Load(
    DedNetApplication^ app,
    String^ mainRegKey,
    DedCommCommKindEnum commKind
)
member Load :
        app : DedNetApplication *
        mainRegKey : string *
        commKind : DedCommCommKindEnum -> unit

Parametri

app DedNetApplication
mainRegKey String
commKind DedCommCommKindEnum
Vedi anche

Documentazione

Classe DedFindCommControl
Overload di Load
Namespace DedNet.Controls


Metodo DedFindCommControl.LoadAllComm

Metodo DedFindCommControlLoadAllComm
Effettua il caricamento di tutte le commesse

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void LoadAllComm(
    DedNetApplication app,
    string mainRegKey,
    DedCommCommKindEnum commKind
)
Public Sub LoadAllComm (
    app As DedNetApplication,
    mainRegKey As String,
    commKind As DedCommCommKindEnum
)
public:
void LoadAllComm(
    DedNetApplication^ app,
    String^ mainRegKey,
    DedCommCommKindEnum commKind
)
member LoadAllComm :
        app : DedNetApplication *
        mainRegKey : string *
        commKind : DedCommCommKindEnum -> unit

Parametri

app DedNetApplication
mainRegKey String
commKind DedCommCommKindEnum
Vedi anche

Documentazione

Classe DedFindCommControl
Namespace DedNet.Controls


Metodo DedFindCommControl.OnTextCommChanged

Metodo DedFindCommControlOnTextCommChanged
Lancia l'evento di SelectionChanged passando i documenti correntemente selezionati.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected void OnTextCommChanged()
Protected Sub OnTextCommChanged
protected:
void OnTextCommChanged()
member OnTextCommChanged : unit -> unit
Vedi anche

Documentazione

Classe DedFindCommControl
Namespace DedNet.Controls


Metodo DedFindCommControl.Update

Metodo DedFindCommControlUpdate
Aggiorna la lista delle commesse master

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Update()
Public Sub Update
public:
void Update()
member Update : unit -> unit
Vedi anche

Documentazione

Classe DedFindCommControl
Namespace DedNet.Controls


Eventi di DedFindCommControl

Il tipo DedFindCommControl espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | ContextMenuOpening | Evento su apertura del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | MenuItemClicked | Evento su click su un elemento del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | PaintEx | (Ereditato da XtraUserControl)
Evento pubblico | TextCommChanged | Evento lanciato sulla modifica della selezione dei documenti.
Torna su
Vedi anche

Documentazione

Classe DedFindCommControl
Namespace DedNet.Controls


Evento DedFindCommControl.TextCommChanged

Evento DedFindCommControlTextCommChanged
Evento lanciato sulla modifica della selezione dei documenti.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DedFindCommControlDedCommControlTextChangedEventArgs> TextCommChanged
Public Event TextCommChanged As EventHandler(Of DedFindCommControlDedCommControlTextChangedEventArgs)
public:
 event EventHandler<DedFindCommControlDedCommControlTextChangedEventArgs^>^ TextCommChanged {
    void add (EventHandler<DedFindCommControlDedCommControlTextChangedEventArgs^>^ value);
    void remove (EventHandler<DedFindCommControlDedCommControlTextChangedEventArgs^>^ value);
}
member TextCommChanged : IEvent<EventHandler<DedFindCommControlDedCommControlTextChangedEventArgs>,
    DedFindCommControlDedCommControlTextChangedEventArgs>

Valore

EventHandler DedFindCommControlDedCommControlTextChangedEventArgs
Vedi anche

Documentazione

Classe DedFindCommControl
Namespace DedNet.Controls


Campi di DedFindCommControl

Il tipo DedFindCommControl espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | _app | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Campo protetto | _RegistryBaseKey | Chiave nel registro di sistema di salvataggio impostazioni. (Ereditato da UserControlBase)
Torna su
Vedi anche

Documentazione

Classe DedFindCommControl
Namespace DedNet.Controls


Classe DedFindCommControl.DedCommControlTextChangedEventArgs

Classe DedFindCommControlDedCommControlTextChangedEventArgs
Gestisce gli eventi che necessitano di conoscere i documenti selezionati.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNet.ControlsDedFindCommControlDedCommControlTextChangedEventArgs

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedCommControlTextChangedEventArgs : EventArgs
Public Class DedCommControlTextChangedEventArgs
    Inherits EventArgs
public ref class DedCommControlTextChangedEventArgs : public EventArgs
type DedCommControlTextChangedEventArgs =
    class
        inherit EventArgs
    end

Il tipo DedFindCommControlDedCommControlTextChangedEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Qta | Restituisce la lista dei documenti correntemente selezionati nel controllo.
Proprietà pubblica | SelectedComm | Restituisce la commessa selezionata
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Proprietà di DedCommControlTextChangedEventArgs

Il tipo DedFindCommControlDedCommControlTextChangedEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Qta | Restituisce la lista dei documenti correntemente selezionati nel controllo.
Proprietà pubblica | SelectedComm | Restituisce la commessa selezionata
Torna su
Vedi anche

Documentazione

Classe DedFindCommControlDedCommControlTextChangedEventArgs
Namespace DedNet.Controls


Proprietà DedFindCommControl.DedCommControlTextChangedEventArgs.Qta

Proprietà DedFindCommControlDedCommControlTextChangedEventArgsQta
Restituisce la lista dei documenti correntemente selezionati nel controllo.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int Qta { get; set; }
Public Property Qta As Integer
    Get
    Set
public:
property int Qta {
    int get ();
    void set (int value);
}
member Qta : int with get, set

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe DedFindCommControlDedCommControlTextChangedEventArgs
Namespace DedNet.Controls


Proprietà DedFindCommControl.DedCommControlTextChangedEventArgs.SelectedComm

Proprietà DedFindCommControlDedCommControlTextChangedEventArgsSelectedComm
Restituisce la commessa selezionata

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedComm SelectedComm { get; set; }
Public Property SelectedComm As DedComm
    Get
    Set
public:
property DedComm^ SelectedComm {
    DedComm^ get ();
    void set (DedComm^ value);
}
member SelectedComm : DedComm with get, set

Valore della proprietà

DedComm
Vedi anche

Documentazione

Classe DedFindCommControlDedCommControlTextChangedEventArgs
Namespace DedNet.Controls


Classe DedFontEdit
Controllo DedFontEdit.
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
XtraControl
ControlBase
BaseControl
BaseEdit
TextEdit
ButtonEdit
PopupBaseEdit
PopupBaseAutoSearchEdit
ComboBoxEdit
FontEdit
DedNet.ControlsDedFontEdit

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFontEdit : FontEdit
Public Class DedFontEdit
    Inherits FontEdit
public ref class DedFontEdit : public FontEdit
type DedFontEdit =
    class
        inherit FontEdit
    end

Il tipo DedFontEdit espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFontEdit | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà protetta | AcceptsReturn | (Ereditato da TextEdit)
Proprietà protetta | AcceptsSpace | (Ereditato da TextEdit)
Proprietà protetta | AcceptsTab | (Ereditato da TextEdit)
Proprietà pubblica | AccessibleDefaultActionDescription | (Ereditato da BaseEdit)
Proprietà pubblica | AccessibleDescription | (Ereditato da BaseEdit)
Proprietà pubblica | AccessibleName | (Ereditato da BaseEdit)
Proprietà pubblica | AccessibleRole | (Ereditato da BaseEdit)
Proprietà protetta | AdvancedMode | (Ereditato da TextEdit)
Proprietà protetta | AllowAutoSearchSelectionLength | (Ereditato da ComboBoxEdit)
Proprietà protetta | AllowButtonPress | (Ereditato da ButtonEdit)
Proprietà protetta | AllowCloseByEscape | (Ereditato da PopupBaseEdit)
Proprietà protetta | AllowDefaultClearButtonAction | (Ereditato da PopupBaseEdit)
Proprietà protetta | AllowEmptyStringToNullValue | (Ereditato da PopupBaseAutoSearchEdit)
Proprietà protetta | AllowFireEditValueChanged | (Ereditato da BaseEdit)
Proprietà protetta | AllowHideClearButtonWhenNotFocused | (Ereditato da PopupBaseEdit)
Proprietà pubblica | AllowHtmlTextInToolTip | (Ereditato da BaseControl)
Proprietà protetta | AllowImmediateClose | (Ereditato da PopupBaseEdit)
Proprietà protetta | AllowPaintBackground | (Ereditato da TextEdit)
Proprietà protetta | AllowPopupTabOut | (Ereditato da PopupBaseEdit)
Proprietà protetta | AllowProcessPaint | (Ereditato da BaseControl)
Proprietà protetta | AllowSelectAllOnPopupClose | (Ereditato da ComboBoxEdit)
Proprietà protetta | AllowSelectOnPopupSelectedIndexChanged | (Ereditato da ComboBoxEdit)
Proprietà protetta | AllowSmartMouseWheel | (Ereditato da PopupBaseEdit)
Proprietà protetta | AllowTransparency | (Ereditato da TextEdit)
Proprietà protetta | AllowUpdateIsModifiedOnValueChanging | (Ereditato da ComboBoxEdit)
Proprietà protetta | AllowValidateOnEnterKey | (Ereditato da TextEdit)
Proprietà protetta | AltBounds | (Ereditato da PopupBaseEdit)
Proprietà protetta | AutoHideClearButtonWhenNotFocused | (Ereditato da PopupBaseEdit)
Proprietà pubblica | AutoSearchText | (Ereditato da PopupBaseAutoSearchEdit)
Proprietà pubblica | AutoSizeInLayoutControl | (Ereditato da BaseControl)
Proprietà pubblica | BackColor | (Ereditato da TextEdit)
Proprietà pubblica | BackgroundImage | (Ereditato da TextEdit)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da TextEdit)
Proprietà protetta | BaseBorderStyle | (Ereditato da BaseControl)
Proprietà pubblica | BindingManager | (Ereditato da BaseEdit)
Proprietà pubblica | BorderStyle | (Ereditato da BaseEdit)
Proprietà protetta | CanAnimateCore | (Ereditato da BaseControl)
Proprietà protetta | CanProcessAutoSearchText | (Ereditato da PopupBaseAutoSearchEdit)
Proprietà pubblica | CanShowDialog | (Ereditato da BaseEdit)
Proprietà protetta | CanShowPopup | (Ereditato da ComboBoxEdit)
Proprietà protetta | CanTabStop | (Ereditato da TextEdit)
Proprietà pubblica | CanUndo | (Ereditato da TextEdit)
Proprietà pubblica | ContextMenu | (Ereditato da BaseEdit)
Proprietà pubblica | ContextMenuStrip | (Ereditato da BaseEdit)
Proprietà protetta | CreateParams | (Ereditato da TextEdit)
Proprietà pubblica | Cursor | (Ereditato da ControlBase)
Proprietà protetta | DefaultCursor | (Ereditato da TextEdit)
Proprietà protetta | DefaultSize | (Ereditato da TextEdit)
Proprietà protetta | DefaultUseCtrlScroll | (Ereditato da ComboBoxEdit)
Proprietà protetta | DelayedAddContainerControl | (Ereditato da PopupBaseEdit)
Proprietà protetta | DirectXProvider | (Ereditato da XtraControl)
Proprietà protetta | DirectXScroller | (Ereditato da XtraControl)
Proprietà protetta | DXAccessible | (Ereditato da TextEdit)
Proprietà protetta | EditorClassInfo | (Ereditato da BaseEdit)
Proprietà protetta | EditorContainer | (Ereditato da BaseEdit)
Proprietà pubblica | EditorContainsFocus | (Ereditato da PopupBaseEdit)
Proprietà pubblica | EditorTypeName | Override EditorTypeName. (Sovrascrive FontEdit.EditorTypeName)
Proprietà pubblica | EditValue | (Ereditato da ComboBoxEdit)
Proprietà protetta | EditValueDataBindingType | (Ereditato da BaseEdit)
Proprietà protetta | EditViewInfo | (Ereditato da BaseEdit)
Proprietà pubblica | EnterMoveNextControl | (Ereditato da BaseEdit)
Proprietà pubblica | ErrorIcon | (Ereditato da BaseEdit)
Proprietà pubblica | ErrorIconAlignment | (Ereditato da BaseEdit)
Proprietà pubblica | ErrorImageOptions | (Ereditato da BaseEdit)
Proprietà pubblica | ErrorText | (Ereditato da BaseEdit)
Proprietà protetta | EventSender | (Ereditato da BaseEdit)
Proprietà protetta | FindItemCompareOptions | (Ereditato da ComboBoxEdit)
Proprietà protetta | FocusOnMouseDown | (Ereditato da BaseControl)
Proprietà pubblica | Font | (Ereditato da BaseEdit)
Proprietà protetta | ForceCalcPopupFormSizeByPM2 | (Ereditato da PopupBaseEdit)
Proprietà pubblica | ForeColor | (Ereditato da BaseEdit)
Proprietà protetta | HasAccessible | (Ereditato da BaseControl)
Proprietà protetta | HasItemActions | (Ereditato da ComboBoxEdit)
Proprietà protetta | InnerControl | (Ereditato da TextEdit)
Proprietà pubblica | InplaceType | (Ereditato da BaseEdit)
Proprietà protetta | IsAcceptingEditValue | (Ereditato da BaseEdit)
Proprietà protetta | IsAllowMaskBoxPropertiesUpdate | (Ereditato da TextEdit)
Proprietà protetta | IsAllowValidate | (Ereditato da BaseEdit)
Proprietà protetta | IsClearAutoSearchOnCancelPopup | (Ereditato da PopupBaseAutoSearchEdit)
Proprietà pubblica | IsDesignMode | (Ereditato da BaseControl)
Proprietà protetta | IsDisposing | (Ereditato da BaseControl)
Proprietà pubblica | IsDrawing | (Ereditato da BaseEdit)
Proprietà pubblica | IsEditorActive | (Ereditato da TextEdit)
Proprietà protetta | IsExistsNullValuePrompt | (Ereditato da TextEdit)
Proprietà protetta | IsImmediatePopup | (Ereditato da PopupBaseAutoSearchEdit)
Proprietà protetta | IsLayoutLocked | (Ereditato da BaseEdit)
Proprietà pubblica | IsLoading | (Ereditato da BaseEdit)
Proprietà protetta | IsMaskBoxAvailable | (Ereditato da TextEdit)
Proprietà protetta | IsMaskBoxUpdate | (Ereditato da TextEdit)
Proprietà protetta | IsMatch | (Ereditato da TextEdit)
Proprietà pubblica | IsModified | (Ereditato da BaseEdit)
Proprietà pubblica | IsNeedFocus | (Ereditato da ButtonEdit)
Proprietà protetta | IsNeedHideCursorOnPopup | (Ereditato da PopupBaseEdit)
Proprietà protetta | IsNullValuePromptVisible | (Ereditato da TextEdit)
Proprietà pubblica | IsPopupOpen | (Ereditato da PopupBaseEdit)
Proprietà protetta | IsQueryCloseUpCancelled | (Ereditato da PopupBaseEdit)
Proprietà pubblica | IsRightToLeft | (Ereditato da ControlBase)
Proprietà protetta | IsUpdatingClearButtonVisibility | (Ereditato da PopupBaseEdit)
Proprietà protetta | IsVisualLayoutUpdate | (Ereditato da BaseEdit)
Proprietà protetta | IsWindowsXPStyle | (Ereditato da TextEdit)
Proprietà pubblica | LookAndFeel | (Ereditato da BaseEdit)
Proprietà pubblica | MaskBox | (Ereditato da TextEdit)
Proprietà protetta | MaskBoxInternal | (Ereditato da TextEdit)
Proprietà protetta | Menu | (Ereditato da TextEdit)
Proprietà pubblica | MenuManager | (Ereditato da BaseEdit)
Proprietà protetta | MouseHere | (Ereditato da TextEdit)
Proprietà pubblica | OldEditValue | (Ereditato da BaseEdit)
Proprietà pubblica | Padding | (Ereditato da BaseEdit)
Proprietà protetta | Painter | (Ereditato da BaseEdit)
Proprietà pubblica | PopupCloseMode | (Ereditato da PopupBaseEdit)
Proprietà pubblica | PopupCommonForm | Form utilizzato come popup.
Proprietà protetta | PopupForm | (Ereditato da ComboBoxEdit)
Proprietà protetta | PopupShowing | (Ereditato da PopupBaseEdit)
Proprietà protetta | PreferredHeight | (Ereditato da BaseEdit)
Proprietà protetta | ProcessInplaceEditValueChangedEventCore | (Ereditato da PopupBaseEdit)
Proprietà pubblica | Properties | Ritorna le Properties come RepositoryItemDedFontEdit.
Proprietà pubblica | ReadOnly | (Ereditato da BaseEdit)
Proprietà protetta | RealEditValue | (Ereditato da ComboBoxEdit)
Proprietà protetta | ScaleDPI | (Ereditato da BaseControl)
Proprietà pubblica | ScaleFactor | (Ereditato da BaseControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraControl)
Proprietà pubblica | SelectedIndex | Ritorna l'indice correntemente selezionato nella tendina. In questo caso sempre 0. (Sovrascrive FontEdit.SelectedIndex)
Proprietà pubblica | SelectedItem | (Ereditato da ComboBoxEdit)
Proprietà pubblica | SelectedText | (Ereditato da TextEdit)
Proprietà pubblica | SelectionLength | (Ereditato da TextEdit)
Proprietà pubblica | SelectionStart | (Ereditato da TextEdit)
Proprietà pubblica | ServiceObject | (Ereditato da BaseEdit)
Proprietà protetta | ShouldDrawBackgroundOnDirectXPaint | (Ereditato da XtraControl)
Proprietà protetta | ShouldNotifyAccessibilityClients | (Ereditato da BaseControl)
Proprietà protetta | ShouldProcessMouseWheelInPopup | (Ereditato da BaseEdit)
Proprietà protetta | ShowKeyboardCuesCore | (Ereditato da BaseControl)
Proprietà pubblica | ShowToolTips | (Ereditato da BaseControl)
Proprietà protetta | ShowToolTipsCore | (Ereditato da BaseEdit)
Proprietà protetta | SizeableIsCaptionVisible | (Ereditato da BaseEdit)
Proprietà protetta | SizeableMaxSize | (Ereditato da BaseControl)
Proprietà protetta | SizeableMinSize | (Ereditato da BaseControl)
Proprietà pubblica | StyleController | (Ereditato da BaseControl)
Proprietà pubblica | SuperTip | (Ereditato da BaseControl)
Proprietà protetta | SuppressSelectAll | (Ereditato da BaseEdit)
Proprietà pubblica | TabStop | (Ereditato da TextEdit)
Proprietà pubblica | Text | (Ereditato da TextEdit)
Proprietà pubblica | ToolTip | (Ereditato da BaseControl)
Proprietà pubblica | ToolTipAnchor | (Ereditato da BaseEdit)
Proprietà pubblica | ToolTipController | (Ereditato da BaseControl)
Proprietà pubblica | ToolTipIconType | (Ereditato da BaseControl)
Proprietà pubblica | ToolTipTitle | (Ereditato da BaseControl)
Proprietà protetta | UseParentOnTransparentPaintBackground | (Ereditato da TextEdit)
Proprietà protetta | ViewInfo | (Ereditato da ButtonEdit)
Proprietà protetta | WorkingStrategy | (Ereditato da TextEdit)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | AcceptPopupValue | (Ereditato da PopupBaseEdit)
Metodo protetto | AccessibilityNotifyTextChanged | (Ereditato da TextEdit)
Metodo protetto | ActionShowPopup(EditorButtonObjectInfoArgs) | (Ereditato da PopupBaseEdit)
Metodo protetto | ActionShowPopup(Keys) | (Ereditato da PopupBaseEdit)
Metodo pubblico | AllowMouseClick | (Ereditato da PopupBaseEdit)
Metodo pubblico | AppendText | (Ereditato da TextEdit)
Metodo protetto | BaseEditWndProc | (Ereditato da TextEdit)
Metodo protetto | BaseWndProc | (Ereditato da ControlBase)
Metodo protetto | BeginAcceptEditValue | (Ereditato da BaseEdit)
Metodo protetto | BeginClosePopup | (Ereditato da PopupBaseEdit)
Metodo protetto | BeginInternalTextChange | (Ereditato da TextEdit)
Metodo protetto | BeginUpdate | (Ereditato da BaseEdit)
Metodo pubblico | CalcBestSize | (Ereditato da BaseControl)
Metodo protetto | CalcDefaultSizeableMinWidth | (Ereditato da BaseEdit)
Metodo pubblico | CalcMinHeight | (Ereditato da BaseEdit)
Metodo protetto | CalcPopupFormBounds | (Ereditato da PopupBaseEdit)
Metodo protetto | CalcPopupFormSize | (Ereditato da PopupBaseEdit)
Metodo protetto | CalcPopupFormSizeByPM2AfterCreateHandle | (Ereditato da PopupBaseEdit)
Metodo protetto | CalcPreferredHeight | (Ereditato da BaseEdit)
Metodo protetto | CalcSizeableMaxSize | (Ereditato da TextEdit)
Metodo protetto | CalcSizeableMinSize | (Ereditato da TextEdit)
Metodo pubblico | CancelPopup | (Ereditato da PopupBaseEdit)
Metodo protetto | CancelUpdate | (Ereditato da BaseEdit)
Metodo protetto | CanProcessNullInputKeys | (Ereditato da TextEdit)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da TextEdit)
Metodo protetto | CanValidateObjectViaAnnotationAttributes | (Ereditato da BaseEdit)
Metodo protetto | CanValidateValueViaAnnotationAttributes | (Ereditato da BaseEdit)
Metodo protetto | CanValidateViaAnnotationAttributesCore | (Ereditato da BaseEdit)
Metodo protetto | CheckAutoHeight | (Ereditato da BaseEdit)
Metodo protetto | CheckAutoSearchText | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | CheckAutoSearchText(Boolean) | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | CheckDoubleClick | (Ereditato da BaseEdit)
Metodo protetto | CheckEnabled | (Ereditato da BaseEdit)
Metodo protetto | CheckErrorIcon | (Ereditato da BaseEdit)
Metodo protetto | CheckHighlightPopupAutoSearchText | (Ereditato da ComboBoxEdit)
Metodo protetto | CheckIfNullString | (Ereditato da TextEdit)
Metodo protetto | CheckInplaceAutoSearchText | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | CheckMouseHere | (Ereditato da TextEdit)
Metodo protetto | CheckRightToLeft | (Ereditato da ControlBase)
Metodo pubblico | Clear | (Ereditato da TextEdit)
Metodo protetto | ClearHotPressed | (Ereditato da BaseEdit)
Metodo protetto | ClearHotPressed(EditHitInfo) | (Ereditato da BaseEdit)
Metodo protetto | ClearHotPressedCore | (Ereditato da BaseEdit)
Metodo protetto | ClearHotPressedOnLostFocus | (Ereditato da ButtonEdit)
Metodo protetto | ClearPreferredHeight | (Ereditato da BaseEdit)
Metodo pubblico | CloseAutoCompletePopup | (Ereditato da TextEdit)
Metodo pubblico | ClosePopup | (Ereditato da FontEdit)
Metodo protetto | ClosePopup(PopupCloseMode) | (Ereditato da PopupBaseEdit)
Metodo protetto | CompareEditValue | (Ereditato da BaseEdit)
Metodo protetto | CompareEditValueOnChange | (Ereditato da BaseEdit)
Metodo protetto | CompareFonts | (Ereditato da TextEdit)
Metodo protetto | CompleteChanges | (Ereditato da BaseEdit)
Metodo protetto | ConstrainFormBounds | (Ereditato da PopupBaseEdit)
Metodo protetto | ControlOnGotFocus | (Ereditato da BaseEdit)
Metodo protetto | ControlOnLostFocus | (Ereditato da BaseEdit)
Metodo pubblico | Copy | (Ereditato da TextEdit)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da BaseControl)
Metodo protetto | CreateAccessibleInstance | (Ereditato da BaseEdit)
Metodo protetto | CreateAdvancedStrategy | (Ereditato da TextEdit)
Metodo protetto | CreateCache | (Ereditato da BaseControl)
Metodo protetto | CreateDirectXProvider | (Ereditato da XtraControl)
Metodo protetto | CreateEditController | (Ereditato da ComboBoxEdit)
Metodo protetto | CreateEditControllerInstance | (Ereditato da ComboBoxEdit)
Metodo protetto | CreateEventSender | (Ereditato da BaseEdit)
Metodo protetto | CreateHandle | (Ereditato da PopupBaseEdit)
Metodo protetto | CreateItemActions | (Ereditato da ComboBoxEdit)
Metodo protetto | CreateLookAndFeel | (Ereditato da BaseEdit)
Metodo protetto | CreateMaskBox | (Ereditato da ComboBoxEdit)
Metodo protetto | CreateMaskBoxInstance | (Ereditato da TextEdit)
Metodo protetto | CreateMaskManager | (Ereditato da TextEdit)
Metodo protetto | CreateMenu | (Ereditato da TextEdit)
Metodo protetto | CreatePopupForm | Crea e restituisce il form di popup. (Sovrascrive ComboBoxEdit.CreatePopupForm)
Metodo protetto | CreateRepositoryItem | (Ereditato da BaseEdit)
Metodo protetto | CreateRepositoryItemCore | (Ereditato da BaseEdit)
Metodo pubblico | Cut | (Ereditato da TextEdit)
Metodo protetto | DescaleInteger | (Ereditato da BaseControl)
Metodo pubblico | DeselectAll | (Ereditato da TextEdit)
Metodo protetto | DestroyHandleCore | (Ereditato da BaseEdit)
Metodo protetto | DestroyMaskBox | (Ereditato da TextEdit)
Metodo protetto | DestroyPopupForm | (Ereditato da PopupBaseEdit)
Metodo protetto | DestroyPopupFormCore | (Ereditato da PopupBaseEdit)
Metodo protetto | Dispose | (Ereditato da PopupBaseEdit)
Metodo protetto | DoBaseSetBoundsCore | (Ereditato da BaseEdit)
Metodo protetto | DoClosePopup | (Ereditato da PopupBaseEdit)
Metodo protetto | DoDpiChange | (Ereditato da PopupBaseEdit)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraControl)
Metodo protetto | DoImmediatePopup | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | DoIsMatchValidating | (Ereditato da TextEdit)
Metodo protetto | DoNullInputKeysCore | (Ereditato da PopupBaseEdit)
Metodo protetto | DoShowPopup | (Ereditato da PopupBaseEdit)
Metodo protetto | DoSpin | (Ereditato da TextEdit)
Metodo protetto | DoSynchronizePopupFormControls | (Ereditato da PopupBaseEdit)
Metodo pubblico | DoValidate | (Ereditato da BaseEdit)
Metodo pubblico | DoValidate(PopupCloseMode) | (Ereditato da BaseEdit)
Metodo protetto | DoValidateOnEnterKey | (Ereditato da BaseEdit)
Metodo protetto | EndAcceptEditValue | (Ereditato da BaseEdit)
Metodo protetto | EndClosePopup | (Ereditato da PopupBaseEdit)
Metodo protetto | EndInternalTextChange | (Ereditato da TextEdit)
Metodo protetto | EndUpdate | (Ereditato da BaseEdit)
Metodo protetto | EnsureAnnotationAttributes | (Ereditato da BaseEdit)
Metodo pubblico | EnsureInnerEditorFocused | (Ereditato da TextEdit)
Metodo protetto | ExecInnerEditMouseDown | (Ereditato da ButtonEdit)
Metodo protetto | ExtractParsedValue | (Ereditato da BaseEdit)
Metodo protetto | FindCurrentText | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | FindItem(String, Int32) | (Ereditato da ComboBoxEdit)
Metodo protetto | FindItem(String, Boolean, Int32) | (Ereditato da ComboBoxEdit)
Metodo protetto | FindUpdateEditValue | (Ereditato da ComboBoxEdit)
Metodo protetto | FindUpdateEditValueAutoSearchText | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | FindUpdatePopupSelectedItem | (Ereditato da ComboBoxEdit)
Metodo protetto | FireChanged | (Ereditato da BaseControl)
Metodo protetto | FireSpinRequest | (Ereditato da ComboBoxEdit)
Metodo protetto | FlushPendingEditActions | (Ereditato da TextEdit)
Metodo pubblico | ForceClosePopup | (Ereditato da PopupBaseEdit)
Metodo protetto | GetAccessibilityObjectById | (Ereditato da ComboBoxEdit)
Metodo pubblico | GetAccessible | (Ereditato da BaseControl)
Metodo protetto | GetAccessibleToNotify | (Ereditato da TextEdit)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da BaseControl)
Metodo protetto | GetActualText | (Ereditato da ComboBoxEdit)
Metodo protetto | GetAutoSearchCharKeyPressHelper | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | GetAutoSearchCharKeyPressHelperCore | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | GetAutoSearchTextFilter | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | GetChangingOldEditValue | (Ereditato da BaseEdit)
Metodo pubblico | GetCharFromPosition | (Ereditato da TextEdit)
Metodo pubblico | GetCharIndexFromPosition | (Ereditato da TextEdit)
Metodo protetto | GetColor(Color, Color) | (Ereditato da BaseControl)
Metodo protetto | GetColor(Color, Color, Boolean) | (Ereditato da BaseControl)
Metodo protetto | GetDeviceSize | (Ereditato da XtraControl)
Metodo protetto | GetDropDownEditorBorderWeight | (Ereditato da PopupBaseEdit)
Metodo protetto | GetDropDownOrigin | (Ereditato da PopupBaseEdit)
Metodo protetto | GetDropDownPadding | (Ereditato da PopupBaseEdit)
Metodo pubblico | GetFirstCharIndexFromLine | (Ereditato da TextEdit)
Metodo pubblico | GetFirstCharIndexOfCurrentLine | (Ereditato da TextEdit)
Metodo protetto | GetItemDescription | (Ereditato da ComboBoxEdit)
Metodo pubblico | GetLineFromCharIndex | (Ereditato da TextEdit)
Metodo protetto | GetNewScrollIndex | (Ereditato da FontEdit)
Metodo protetto | GetNullInputKeysValue | (Ereditato da TextEdit)
Metodo protetto | GetObjectToValidate | (Ereditato da BaseEdit)
Metodo pubblico | GetPopupEditForm | (Ereditato da ComboBoxEdit)
Metodo protetto | GetPopupForm | (Ereditato da PopupBaseEdit)
Metodo protetto | GetPopupFormCore | (Ereditato da PopupBaseEdit)
Metodo pubblico | GetPositionFromCharIndex | (Ereditato da TextEdit)
Metodo pubblico | GetPreferredSize | (Ereditato da BaseEdit)
Metodo protetto | GetScaledBounds | (Ereditato da BaseEdit)
Metodo protetto | GetScaleDpiCore | (Ereditato da BaseControl)
Metodo protetto | GetSkinnedCellPadding | (Ereditato da PopupBaseEdit)
Metodo protetto | GetSkinnedEditorBorderWeight | (Ereditato da PopupBaseEdit)
Metodo protetto | GetTextEditController | (Ereditato da TextEdit)
Metodo protetto | GetToolTipAnchor | (Ereditato da BaseControl)
Metodo protetto | GetToolTipInfo | (Ereditato da BaseEdit)
Metodo protetto | GetUseDirectXPaint | (Ereditato da XtraControl)
Metodo protetto | GetValidationCanceled | (Ereditato da BaseEdit)
Metodo pubblico | GetViewInfo | (Ereditato da BaseControl)
Metodo protetto | HideCaret | (Ereditato da TextEdit)
Metodo protetto | InitializeDefault | (Ereditato da BaseEdit)
Metodo protetto | InitializeDefaultProperties | (Ereditato da ComboBoxEdit)
Metodo pubblico | InnerEditorPaste | (Ereditato da TextEdit)
Metodo pubblico | InnerEditorSpin | (Ereditato da TextEdit)
Metodo protetto | InvalidateFormBoundsByPM2BeforeShow | (Ereditato da PopupBaseEdit)
Metodo protetto | IsAcceptCloseMode | (Ereditato da PopupBaseEdit)
Metodo protetto | IsActionButton | (Ereditato da PopupBaseEdit)
Metodo protetto | IsAutoSearchCharHandled | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | IsBindingDataAccessible | (Ereditato da BaseEdit)
Metodo protetto | IsBindingManagerPositionValid | (Ereditato da BaseEdit)
Metodo protetto | IsClearButton | (Ereditato da PopupBaseEdit)
Metodo protetto | IsClearButtonVisible | (Ereditato da PopupBaseEdit)
Metodo pubblico | IsInnerEditorReadOnly | (Ereditato da TextEdit)
Metodo protetto | IsInputChar | (Ereditato da TextEdit)
Metodo protetto | IsInputKey | (Ereditato da TextEdit)
Metodo protetto | IsInputKeyCore | (Ereditato da BaseEdit)
Metodo protetto | IsItemVisible | (Ereditato da ComboBoxEdit)
Metodo pubblico | IsNeededCursorKey | (Ereditato da TextEdit)
Metodo protetto | IsNeededExtraKey | (Ereditato da TextEdit)
Metodo pubblico | IsNeededKey | (Ereditato da PopupBaseEdit)
Metodo protetto | IsNullValue | (Ereditato da BaseEdit)
Metodo protetto | IsShowNullValuePrompt | (Ereditato da TextEdit)
Metodo protetto | IsTextCommand | (Ereditato da TextEdit)
Metodo protetto | KeepPopupFormSize | (Ereditato da PopupBaseEdit)
Metodo protetto | LayoutChanged | (Ereditato da TextEdit)
Metodo protetto | LayoutChanged(Boolean) | (Ereditato da TextEdit)
Metodo protetto | LayoutChangedCore | (Ereditato da TextEdit)
Metodo protetto | LayoutChangedCore(Boolean) | (Ereditato da BaseControl)
Metodo protetto | LockEditValueChanged | (Ereditato da BaseEdit)
Metodo protetto | LockMaskBoxPropertiesUpdate | (Ereditato da TextEdit)
Metodo protetto | MaskBoxGetEditValue | (Ereditato da TextEdit)
Metodo protetto | NeedLayoutUpdateValidating | (Ereditato da TextEdit)
Metodo protetto | NotifyAccessibilityClients(AccessibleEvents, Int32, Int32) | (Ereditato da BaseControl)
Metodo protetto | NotifyAccessibilityClients(AccessibleEvents, AutomationElementProvider, Int32, Int32) | (Ereditato da BaseControl)
Metodo protetto | NotifyButtonStateChanged | (Ereditato da ButtonEdit)
Metodo protetto | OnActionItemClick | (Ereditato da ComboBoxEdit)
Metodo protetto | OnAfterUpdateViewInfo | (Ereditato da TextEdit)
Metodo protetto | OnAppearancePaintChanged | (Ereditato da TextEdit)
Metodo protetto | OnAutoHeightChanged | (Ereditato da BaseEdit)
Metodo protetto | OnBeforeUpdateViewInfo | (Ereditato da TextEdit)
Metodo protetto | OnBorderStyleChanged | (Ereditato da BaseControl)
Metodo protetto | OnCancelEditValueChanging | (Ereditato da BaseEdit)
Metodo protetto | OnClickButton | (Ereditato da PopupBaseEdit)
Metodo protetto | OnClickButtonCore | (Ereditato da ButtonEdit)
Metodo protetto | OnClientSizeChanged | (Ereditato da TextEdit)
Metodo protetto | OnContextMenuChanged | (Ereditato da BaseEdit)
Metodo protetto | OnContextMenuStripChanged | (Ereditato da BaseEdit)
Metodo protetto | OnControllerValueChanged | (Ereditato da TextEdit)
Metodo protetto | OnControllerValueChanging | (Ereditato da TextEdit)
Metodo protetto | OnCreateControl | (Ereditato da TextEdit)
Metodo protetto | OnDefaultPressButton | (Ereditato da PopupBaseEdit)
Metodo protetto | OnDirectXPaintDisabled | (Ereditato da XtraControl)
Metodo protetto | OnDirectXPaintEnabled | (Ereditato da XtraControl)
Metodo protetto | OnEditorEnter | (Ereditato da TextEdit)
Metodo protetto | OnEditorKeyDown | (Ereditato da ComboBoxEdit)
Metodo protetto | OnEditorKeyDownProcessNullInputKeys | (Ereditato da TextEdit)
Metodo protetto | OnEditorKeyPress | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | OnEditorKeyUp | (Ereditato da PopupBaseEdit)
Metodo protetto | OnEditorLeave | (Ereditato da TextEdit)
Metodo protetto | OnEditValueChanged | (Ereditato da FontEdit)
Metodo protetto | OnEditValueChanging | (Ereditato da TextEdit)
Metodo protetto | OnEnabledChanged | (Ereditato da TextEdit)
Metodo protetto | OnEnableNonMaskedInput | (Ereditato da TextEdit)
Metodo protetto | OnEndIme | (Ereditato da PopupBaseEdit)
Metodo protetto | OnEnter | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | OnErrorInfoChanged | (Ereditato da BaseEdit)
Metodo protetto | OnErrorTextChanged | (Ereditato da TextEdit)
Metodo protetto | OnGlassMaskBoxPreWndProc | (Ereditato da TextEdit)
Metodo protetto | OnGlassMaskBoxWndProc | (Ereditato da TextEdit)
Metodo protetto | OnGotCapture | (Ereditato da ControlBase)
Metodo protetto | OnGotFocus | (Ereditato da PopupBaseEdit)
Metodo protetto | OnHandleCreated | (Ereditato da TextEdit)
Metodo protetto | OnHandleDestroyed | (Ereditato da TextEdit)
Metodo protetto | OnImeModeChanged | (Ereditato da TextEdit)
Metodo protetto | OnInvalidValue | (Ereditato da BaseEdit)
Metodo protetto | OnKeyDown | (Ereditato da TextEdit)
Metodo protetto | OnKeyPress | (Ereditato da TextEdit)
Metodo protetto | OnKeyUp | (Ereditato da TextEdit)
Metodo protetto | OnLeave | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | OnLoaded | (Ereditato da PopupBaseEdit)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da TextEdit)
Metodo protetto | OnLostCapture | (Ereditato da ControlBase)
Metodo protetto | OnLostFocus | (Ereditato da PopupBaseEdit)
Metodo protetto | OnMaskBox_Click | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_DoubleClick | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_GotFocus | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_KeyDown | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_KeyPress | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_KeyUp | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_LostFocus | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_MouseDown | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_MouseEnter | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_MouseLeave | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_MouseMove | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_MouseUp | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_MouseWheel | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_TextValidated | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_ValueChanged | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_ValueChanging | (Ereditato da TextEdit)
Metodo protetto | OnMaskBoxMouseSelection | (Ereditato da TextEdit)
Metodo protetto | OnMaskBoxPreWndProc | (Ereditato da TextEdit)
Metodo protetto | OnMaskBoxTextResetToNullValuePromptOrNullText | (Ereditato da TextEdit)
Metodo protetto | OnMaskBoxWndProc | (Ereditato da TextEdit)
Metodo protetto | OnMaskEditValueChanging | (Ereditato da TextEdit)
Metodo protetto | OnMouseDown | (Ereditato da ComboBoxEdit)
Metodo protetto | OnMouseDownClosePopup | (Ereditato da PopupBaseEdit)
Metodo protetto | OnMouseEnter | (Ereditato da TextEdit)
Metodo protetto | OnMouseLeave | (Ereditato da TextEdit)
Metodo protetto | OnMouseMove | (Ereditato da TextEdit)
Metodo protetto | OnMouseUp | (Ereditato da ButtonEdit)
Metodo protetto | OnMouseWheel | (Ereditato da ComboBoxEdit)
Metodo protetto | OnMove | (Ereditato da PopupBaseEdit)
Metodo protetto | OnPaddingChanged | (Ereditato da BaseControl)
Metodo protetto | OnPaint | (Ereditato da TextEdit)
Metodo protetto | OnPaintBackground | (Ereditato da TextEdit)
Metodo protetto | OnParentChanged | (Ereditato da ControlBase)
Metodo protetto | OnParentVisibleChanged | (Ereditato da PopupBaseEdit)
Metodo protetto | OnPopupClosed | (Ereditato da ComboBoxEdit)
Metodo protetto | OnPopupClosing | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | OnPopupFormValueChanged | (Ereditato da ComboBoxEdit)
Metodo protetto | OnPopupSelectedIndexChanged | (Ereditato da ComboBoxEdit)
Metodo protetto | OnPopupShown | (Ereditato da PopupBaseEdit)
Metodo protetto | OnPressButton | (Ereditato da PopupBaseEdit)
Metodo protetto | OnPreviewKeyDown | (Ereditato da TextEdit)
Metodo protetto | OnProperties_PropertiesChanged | (Ereditato da BaseEdit)
Metodo protetto | OnPropertiesChanged | (Ereditato da PopupBaseEdit)
Metodo protetto | OnPropertiesChanged_SyncPopup | (Ereditato da PopupBaseEdit)
Metodo protetto | OnResize | (Ereditato da TextEdit)
Metodo protetto | OnRightToLeftChanged | (Ereditato da PopupBaseEdit)
Metodo protetto | OnRightToLeftChanged(EventArgs) | (Ereditato da ControlBase)
Metodo protetto | OnScaleControl | (Ereditato da BaseEdit)
Metodo protetto | OnScaleDpiChanged | (Ereditato da ControlBase)
Metodo protetto | OnSizeChanged | (Ereditato da TextEdit)
Metodo protetto | OnSpin | (Ereditato da TextEdit)
Metodo protetto | OnStyleController_Disposed | (Ereditato da BaseControl)
Metodo protetto | OnStyleController_PropertiesChanged | (Ereditato da BaseControl)
Metodo protetto | OnStyleControllerChanged | (Ereditato da TextEdit)
Metodo protetto | OnTabStopChanged | (Ereditato da TextEdit)
Metodo protetto | OnTextChanged | (Ereditato da TextEdit)
Metodo protetto | OnTextEditPropertiesChanged | (Ereditato da TextEdit)
Metodo protetto | OnValidated | (Ereditato da FontEdit)
Metodo protetto | OnValidating | (Ereditato da TextEdit)
Metodo protetto | OnValidatingCore | (Ereditato da BaseEdit)
Metodo protetto | OnVisibleChanged | (Ereditato da PopupBaseEdit)
Metodo protetto | PaintErrorIconBackground | (Ereditato da TextEdit)
Metodo protetto | ParseEditorValue | (Ereditato da BaseEdit)
Metodo pubblico | Paste | (Ereditato da TextEdit)
Metodo protetto | PendingEditActionPerformed | (Ereditato da TextEdit)
Metodo pubblico | PerformClick | (Ereditato da ButtonEdit)
Metodo protetto | PerformDefaultClearButtonAction | (Ereditato da PopupBaseEdit)
Metodo protetto | ProcessAutoSearchChar | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | ProcessAutoSearchNavKey | (Ereditato da ComboBoxEdit)
Metodo protetto | ProcessChar | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | ProcessCmdKey | (Ereditato da TextEdit)
Metodo protetto | ProcessDialogKey | (Ereditato da PopupBaseEdit)
Metodo protetto | ProcessDialogKeyCore | (Ereditato da TextEdit)
Metodo protetto | ProcessFindItem | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | ProcessPaintAction | (Ereditato da XtraControl)
Metodo protetto | ProcessPopupMouseWheel | (Ereditato da BaseEdit)
Metodo protetto | ProcessPopupTabKey | (Ereditato da PopupBaseEdit)
Metodo protetto | ProcessRemoveWord | (Ereditato da TextEdit)
Metodo protetto | QueryEditorModeFromSkin | (Ereditato da TextEdit)
Metodo protetto | QueryMaskEditValue | (Ereditato da TextEdit)
Metodo protetto | RaiseDropDownCustomDrawItem | (Ereditato da ComboBoxEdit)
Metodo protetto | RaiseEditValueChanged | (Ereditato da BaseEdit)
Metodo protetto | RaiseInvalidValue | (Ereditato da BaseEdit)
Metodo protetto | RaiseModified | (Ereditato da BaseEdit)
Metodo protetto | RaisePaintEvent | (Ereditato da TextEdit)
Metodo protetto | RaisePaintExEvent(TextEditPaintExEventArgs) | (Ereditato da TextEdit)
Metodo protetto | RaisePaintExEvent(GraphicsCache, PaintEventArgs) | (Ereditato da XtraControl)
Metodo protetto | RaisePopupAllowClick | (Ereditato da PopupBaseEdit)
Metodo protetto | RaiseQueryAdvancedMode | (Ereditato da TextEdit)
Metodo protetto | RaiseQueryCompletion | (Ereditato da TextEdit)
Metodo protetto | RaiseSizeableChanged | (Ereditato da BaseControl)
Metodo pubblico | Refresh | (Ereditato da BaseControl)
Metodo pubblico | RefreshEditValue | (Ereditato da PopupBaseEdit)
Metodo protetto | RefreshEnabledState | (Ereditato da TextEdit)
Metodo protetto | RefreshPopup | (Ereditato da ComboBoxEdit)
Metodo protetto | RefreshVisualLayout | (Ereditato da BaseEdit)
Metodo protetto | RefreshVisualLayoutCore | (Ereditato da BaseEdit)
Metodo protetto | RejectPopupValue | (Ereditato da PopupBaseEdit)
Metodo protetto | ReleaseDirectXResources | (Ereditato da XtraControl)
Metodo protetto | ReleaseStyleController | (Ereditato da BaseControl)
Metodo protetto | RemoveXtraAnimator | (Ereditato da BaseControl)
Metodo pubblico | Reset | (Ereditato da ComboBoxEdit)
Metodo protetto | ResetAccessible | (Ereditato da BaseControl)
Metodo pubblico | ResetBackColor | (Ereditato da BaseEdit)
Metodo protetto | ResetEvents | (Ereditato da BaseEdit)
Metodo pubblico | ResetForeColor | (Ereditato da BaseEdit)
Metodo pubblico | ResetSelection | (Ereditato da TextEdit)
Metodo pubblico | ResetSuperTip | (Ereditato da BaseControl)
Metodo protetto | ScaleControl | (Ereditato da ControlBase)
Metodo protetto | ScaleFont | (Ereditato da TextEdit)
Metodo protetto | ScaleInteger | (Ereditato da BaseControl)
Metodo protetto | ScaleSize | (Ereditato da BaseControl)
Metodo protetto | ScrollIndex | (Ereditato da ComboBoxEdit)
Metodo pubblico | ScrollToCaret | (Ereditato da TextEdit)
Metodo protetto | ScrollValue | (Ereditato da ComboBoxEdit)
Metodo protetto | Select(Boolean, Boolean) | (Ereditato da TextEdit)
Metodo pubblico | Select(Int32, Int32) | (Ereditato da TextEdit)
Metodo pubblico | SelectAll | (Ereditato da TextEdit)
Metodo pubblico | SendKey(KeyEventArgs) | (Ereditato da BaseEdit)
Metodo pubblico | SendKey(Object, KeyPressEventArgs) | (Ereditato da BaseEdit)
Metodo pubblico | SendKeyUp | (Ereditato da BaseEdit)
Metodo pubblico | SendMouse(MouseEventArgs) | (Ereditato da BaseEdit)
Metodo pubblico | SendMouse(Point, MouseButtons) | (Ereditato da BaseEdit)
Metodo protetto | SendMouseUp(MouseEventArgs) | (Ereditato da BaseEdit)
Metodo pubblico | SendMouseUp(Point, MouseButtons) | (Ereditato da BaseEdit)
Metodo protetto | SetBackColor | (Ereditato da BaseControl)
Metodo protetto | SetBoundsCore | (Ereditato da BaseEdit)
Metodo protetto | SetEmptyEditValue | (Ereditato da PopupBaseEdit)
Metodo protetto | SetErrorIcon | (Ereditato da BaseEdit)
Metodo protetto | SetPopupEditValueOnClose | (Ereditato da PopupBaseEdit)
Metodo protetto | SetTextCore | (Ereditato da TextEdit)
Metodo protetto | SetVisibleCore | (Ereditato da ControlBase)
Metodo protetto | ShouldSuppressFormDeactivation | (Ereditato da TextEdit)
Metodo protetto | ShouldSuppressTextCommand | (Ereditato da TextEdit)
Metodo pubblico | ShowAutoCompletePopup | (Ereditato da TextEdit)
Metodo protetto | ShowCaret | (Ereditato da TextEdit)
Metodo protetto | ShowMenu | (Ereditato da TextEdit)
Metodo protetto | ShowMenuCore | (Ereditato da TextEdit)
Metodo pubblico | ShowPopup | (Ereditato da PopupBaseEdit)
Metodo protetto | SilentRemove | (Ereditato da ComboBoxEdit)
Metodo protetto | SilentRemoveCore | (Ereditato da ComboBoxEdit)
Metodo protetto | SubscribePopupFormEvents | (Ereditato da PopupBaseEdit)
Metodo protetto | SuppressMouseWheel | (Ereditato da PopupBaseEdit)
Metodo protetto | SwitchModeAccordingToSkinSettings | (Ereditato da TextEdit)
Metodo protetto | SwitchPopupState | (Ereditato da PopupBaseEdit)
Metodo protetto | TryNotifyAccessibilitySelectedIndexChanged | (Ereditato da ComboBoxEdit)
Metodo pubblico | Undo | (Ereditato da TextEdit)
Metodo protetto | UnLockEditValueChanged | (Ereditato da BaseEdit)
Metodo protetto | UnlockMaskBoxPropertiesUpdate | (Ereditato da TextEdit)
Metodo protetto | UpdateClearButtonVisibility | (Ereditato da PopupBaseEdit)
Metodo protetto | UpdateClearButtonVisibilityCore | (Ereditato da PopupBaseEdit)
Metodo protetto | UpdateDisplayText | (Ereditato da TextEdit)
Metodo protetto | UpdateEditControllerProperties | (Ereditato da TextEdit)
Metodo protetto | UpdateEditValueOnClose | (Ereditato da ComboBoxEdit)
Metodo protetto | UpdateFixedHeight | (Ereditato da BaseEdit)
Metodo protetto | UpdateHideSelection | (Ereditato da TextEdit)
Metodo protetto | UpdateInactiveInnerEditorProperties | (Ereditato da TextEdit)
Metodo protetto | UpdateMaskBox | (Ereditato da TextEdit)
Metodo protetto | UpdateMaskBox(Boolean) | (Ereditato da TextEdit)
Metodo protetto | UpdateMaskBoxBounds | (Ereditato da TextEdit)
Metodo protetto | UpdateMaskBoxDisplayText | (Ereditato da TextEdit)
Metodo protetto | UpdateMaskBoxFontByScaleDpi | (Ereditato da TextEdit)
Metodo protetto | UpdateMaskBoxProperties | (Ereditato da TextEdit)
Metodo protetto | UpdateMaskBoxPropertiesCore | (Ereditato da TextEdit)
Metodo protetto | UpdateMenu | (Ereditato da TextEdit)
Metodo protetto | UpdateMenuCoords | (Ereditato da TextEdit)
Metodo protetto | UpdatePasswordChar | (Ereditato da TextEdit)
Metodo protetto | UpdatePopupEditValueIndex | (Ereditato da ComboBoxEdit)
Metodo protetto | UpdateScaleDpi | (Ereditato da XtraControl)
Metodo protetto | UpdateScaleFactorForScaleHelper | (Ereditato da XtraControl)
Metodo pubblico | UpdateTextHighlight | (Ereditato da TextEdit)
Metodo protetto | UpdateViewInfo | (Ereditato da BaseControl)
Metodo protetto | UpdateViewInfoEditValue | (Ereditato da BaseEdit)
Metodo protetto | UpdateViewInfoState | (Ereditato da BaseControl)
Metodo protetto | UpdateViewInfoState(Boolean) | (Ereditato da BaseControl)
Metodo protetto | UpdateViewInfoState(Boolean, Point) | (Ereditato da BaseControl)
Metodo protetto | WndProc | (Ereditato da PopupBaseEdit)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | BackColorChanged | (Ereditato da BaseEdit)
Evento pubblico | BeforePopup | (Ereditato da PopupBaseEdit)
Evento pubblico | ButtonClick | (Ereditato da ButtonEdit)
Evento pubblico | ButtonPressed | (Ereditato da ButtonEdit)
Evento pubblico | Closed | (Ereditato da PopupBaseEdit)
Evento pubblico | CloseUp | (Ereditato da PopupBaseEdit)
Evento pubblico | CustomDisplayText | (Ereditato da BaseEdit)
Evento pubblico | CustomHighlightText | (Ereditato da TextEdit)
Evento pubblico | CustomizeAutoCompleteSource | (Ereditato da TextEdit)
Evento pubblico | CustomTextLineHeight | (Ereditato da TextEdit)
Evento pubblico | DrawItem | (Ereditato da ComboBoxEdit)
Evento pubblico | DropDownCustomDrawItem | Obsoleto. (Ereditato da ComboBoxEdit)
Evento pubblico | EditValueChanged | (Ereditato da BaseEdit)
Evento pubblico | EditValueChanging | (Ereditato da BaseEdit)
Evento pubblico | FontChanged | (Ereditato da BaseEdit)
Evento pubblico | ForeColorChanged | (Ereditato da BaseEdit)
Evento pubblico | FormatEditValue | (Ereditato da BaseEdit)
Evento pubblico | InvalidValue | (Ereditato da BaseEdit)
Evento pubblico | Modified | (Ereditato da BaseEdit)
Evento pubblico | PaintEx | (Ereditato da TextEdit)
Evento pubblico | ParseEditValue | (Ereditato da BaseEdit)
Evento pubblico | Popup | (Ereditato da PopupBaseEdit)
Evento pubblico | PopupAllowClick | (Ereditato da PopupBaseEdit)
Evento pubblico | PropertiesChanged | (Ereditato da BaseEdit)
Evento pubblico | QueryAccessibilityHelp | (Ereditato da BaseEdit)
Evento pubblico | QueryCloseUp | (Ereditato da PopupBaseEdit)
Evento pubblico | QueryPopUp | (Ereditato da PopupBaseEdit)
Evento pubblico | QueryProcessKey | (Ereditato da BaseEdit)
Evento pubblico | SelectedIndexChanged | (Ereditato da ComboBoxEdit)
Evento pubblico | SelectedValueChanged | (Ereditato da ComboBoxEdit)
Evento pubblico | Spin | (Ereditato da TextEdit)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | fDisposing | (Ereditato da BaseControl)
Campo protetto | fEditValue | (Ereditato da BaseEdit)
Campo protetto | fOldEditValue | (Ereditato da BaseEdit)
Campo protetto | fProperties | (Ereditato da BaseEdit)
Campo protetto | fShowToolTips | (Ereditato da BaseControl)
Campo protetto | lastChangedEditValue | (Ereditato da BaseEdit)
Campo protetto | shouldRaiseSizeableChanged | (Ereditato da BaseControl)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore DedFontEdit
Costruttore unico.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFontEdit()
Public Sub New
public:
DedFontEdit()
new : unit -> DedFontEdit
Vedi anche

Documentazione

Classe DedFontEdit
Namespace DedNet.Controls


Proprietà di DedFontEdit

Il tipo DedFontEdit espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà protetta | AcceptsReturn | (Ereditato da TextEdit)
Proprietà protetta | AcceptsSpace | (Ereditato da TextEdit)
Proprietà protetta | AcceptsTab | (Ereditato da TextEdit)
Proprietà pubblica | AccessibleDefaultActionDescription | (Ereditato da BaseEdit)
Proprietà pubblica | AccessibleDescription | (Ereditato da BaseEdit)
Proprietà pubblica | AccessibleName | (Ereditato da BaseEdit)
Proprietà pubblica | AccessibleRole | (Ereditato da BaseEdit)
Proprietà protetta | AdvancedMode | (Ereditato da TextEdit)
Proprietà protetta | AllowAutoSearchSelectionLength | (Ereditato da ComboBoxEdit)
Proprietà protetta | AllowButtonPress | (Ereditato da ButtonEdit)
Proprietà protetta | AllowCloseByEscape | (Ereditato da PopupBaseEdit)
Proprietà protetta | AllowDefaultClearButtonAction | (Ereditato da PopupBaseEdit)
Proprietà protetta | AllowEmptyStringToNullValue | (Ereditato da PopupBaseAutoSearchEdit)
Proprietà protetta | AllowFireEditValueChanged | (Ereditato da BaseEdit)
Proprietà protetta | AllowHideClearButtonWhenNotFocused | (Ereditato da PopupBaseEdit)
Proprietà pubblica | AllowHtmlTextInToolTip | (Ereditato da BaseControl)
Proprietà protetta | AllowImmediateClose | (Ereditato da PopupBaseEdit)
Proprietà protetta | AllowPaintBackground | (Ereditato da TextEdit)
Proprietà protetta | AllowPopupTabOut | (Ereditato da PopupBaseEdit)
Proprietà protetta | AllowProcessPaint | (Ereditato da BaseControl)
Proprietà protetta | AllowSelectAllOnPopupClose | (Ereditato da ComboBoxEdit)
Proprietà protetta | AllowSelectOnPopupSelectedIndexChanged | (Ereditato da ComboBoxEdit)
Proprietà protetta | AllowSmartMouseWheel | (Ereditato da PopupBaseEdit)
Proprietà protetta | AllowTransparency | (Ereditato da TextEdit)
Proprietà protetta | AllowUpdateIsModifiedOnValueChanging | (Ereditato da ComboBoxEdit)
Proprietà protetta | AllowValidateOnEnterKey | (Ereditato da TextEdit)
Proprietà protetta | AltBounds | (Ereditato da PopupBaseEdit)
Proprietà protetta | AutoHideClearButtonWhenNotFocused | (Ereditato da PopupBaseEdit)
Proprietà pubblica | AutoSearchText | (Ereditato da PopupBaseAutoSearchEdit)
Proprietà pubblica | AutoSizeInLayoutControl | (Ereditato da BaseControl)
Proprietà pubblica | BackColor | (Ereditato da TextEdit)
Proprietà pubblica | BackgroundImage | (Ereditato da TextEdit)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da TextEdit)
Proprietà protetta | BaseBorderStyle | (Ereditato da BaseControl)
Proprietà pubblica | BindingManager | (Ereditato da BaseEdit)
Proprietà pubblica | BorderStyle | (Ereditato da BaseEdit)
Proprietà protetta | CanAnimateCore | (Ereditato da BaseControl)
Proprietà protetta | CanProcessAutoSearchText | (Ereditato da PopupBaseAutoSearchEdit)
Proprietà pubblica | CanShowDialog | (Ereditato da BaseEdit)
Proprietà protetta | CanShowPopup | (Ereditato da ComboBoxEdit)
Proprietà protetta | CanTabStop | (Ereditato da TextEdit)
Proprietà pubblica | CanUndo | (Ereditato da TextEdit)
Proprietà pubblica | ContextMenu | (Ereditato da BaseEdit)
Proprietà pubblica | ContextMenuStrip | (Ereditato da BaseEdit)
Proprietà protetta | CreateParams | (Ereditato da TextEdit)
Proprietà pubblica | Cursor | (Ereditato da ControlBase)
Proprietà protetta | DefaultCursor | (Ereditato da TextEdit)
Proprietà protetta | DefaultSize | (Ereditato da TextEdit)
Proprietà protetta | DefaultUseCtrlScroll | (Ereditato da ComboBoxEdit)
Proprietà protetta | DelayedAddContainerControl | (Ereditato da PopupBaseEdit)
Proprietà protetta | DirectXProvider | (Ereditato da XtraControl)
Proprietà protetta | DirectXScroller | (Ereditato da XtraControl)
Proprietà protetta | DXAccessible | (Ereditato da TextEdit)
Proprietà protetta | EditorClassInfo | (Ereditato da BaseEdit)
Proprietà protetta | EditorContainer | (Ereditato da BaseEdit)
Proprietà pubblica | EditorContainsFocus | (Ereditato da PopupBaseEdit)
Proprietà pubblica | EditorTypeName | Override EditorTypeName. (Sovrascrive FontEdit.EditorTypeName)
Proprietà pubblica | EditValue | (Ereditato da ComboBoxEdit)
Proprietà protetta | EditValueDataBindingType | (Ereditato da BaseEdit)
Proprietà protetta | EditViewInfo | (Ereditato da BaseEdit)
Proprietà pubblica | EnterMoveNextControl | (Ereditato da BaseEdit)
Proprietà pubblica | ErrorIcon | (Ereditato da BaseEdit)
Proprietà pubblica | ErrorIconAlignment | (Ereditato da BaseEdit)
Proprietà pubblica | ErrorImageOptions | (Ereditato da BaseEdit)
Proprietà pubblica | ErrorText | (Ereditato da BaseEdit)
Proprietà protetta | EventSender | (Ereditato da BaseEdit)
Proprietà protetta | FindItemCompareOptions | (Ereditato da ComboBoxEdit)
Proprietà protetta | FocusOnMouseDown | (Ereditato da BaseControl)
Proprietà pubblica | Font | (Ereditato da BaseEdit)
Proprietà protetta | ForceCalcPopupFormSizeByPM2 | (Ereditato da PopupBaseEdit)
Proprietà pubblica | ForeColor | (Ereditato da BaseEdit)
Proprietà protetta | HasAccessible | (Ereditato da BaseControl)
Proprietà protetta | HasItemActions | (Ereditato da ComboBoxEdit)
Proprietà protetta | InnerControl | (Ereditato da TextEdit)
Proprietà pubblica | InplaceType | (Ereditato da BaseEdit)
Proprietà protetta | IsAcceptingEditValue | (Ereditato da BaseEdit)
Proprietà protetta | IsAllowMaskBoxPropertiesUpdate | (Ereditato da TextEdit)
Proprietà protetta | IsAllowValidate | (Ereditato da BaseEdit)
Proprietà protetta | IsClearAutoSearchOnCancelPopup | (Ereditato da PopupBaseAutoSearchEdit)
Proprietà pubblica | IsDesignMode | (Ereditato da BaseControl)
Proprietà protetta | IsDisposing | (Ereditato da BaseControl)
Proprietà pubblica | IsDrawing | (Ereditato da BaseEdit)
Proprietà pubblica | IsEditorActive | (Ereditato da TextEdit)
Proprietà protetta | IsExistsNullValuePrompt | (Ereditato da TextEdit)
Proprietà protetta | IsImmediatePopup | (Ereditato da PopupBaseAutoSearchEdit)
Proprietà protetta | IsLayoutLocked | (Ereditato da BaseEdit)
Proprietà pubblica | IsLoading | (Ereditato da BaseEdit)
Proprietà protetta | IsMaskBoxAvailable | (Ereditato da TextEdit)
Proprietà protetta | IsMaskBoxUpdate | (Ereditato da TextEdit)
Proprietà protetta | IsMatch | (Ereditato da TextEdit)
Proprietà pubblica | IsModified | (Ereditato da BaseEdit)
Proprietà pubblica | IsNeedFocus | (Ereditato da ButtonEdit)
Proprietà protetta | IsNeedHideCursorOnPopup | (Ereditato da PopupBaseEdit)
Proprietà protetta | IsNullValuePromptVisible | (Ereditato da TextEdit)
Proprietà pubblica | IsPopupOpen | (Ereditato da PopupBaseEdit)
Proprietà protetta | IsQueryCloseUpCancelled | (Ereditato da PopupBaseEdit)
Proprietà pubblica | IsRightToLeft | (Ereditato da ControlBase)
Proprietà protetta | IsUpdatingClearButtonVisibility | (Ereditato da PopupBaseEdit)
Proprietà protetta | IsVisualLayoutUpdate | (Ereditato da BaseEdit)
Proprietà protetta | IsWindowsXPStyle | (Ereditato da TextEdit)
Proprietà pubblica | LookAndFeel | (Ereditato da BaseEdit)
Proprietà pubblica | MaskBox | (Ereditato da TextEdit)
Proprietà protetta | MaskBoxInternal | (Ereditato da TextEdit)
Proprietà protetta | Menu | (Ereditato da TextEdit)
Proprietà pubblica | MenuManager | (Ereditato da BaseEdit)
Proprietà protetta | MouseHere | (Ereditato da TextEdit)
Proprietà pubblica | OldEditValue | (Ereditato da BaseEdit)
Proprietà pubblica | Padding | (Ereditato da BaseEdit)
Proprietà protetta | Painter | (Ereditato da BaseEdit)
Proprietà pubblica | PopupCloseMode | (Ereditato da PopupBaseEdit)
Proprietà pubblica | PopupCommonForm | Form utilizzato come popup.
Proprietà protetta | PopupForm | (Ereditato da ComboBoxEdit)
Proprietà protetta | PopupShowing | (Ereditato da PopupBaseEdit)
Proprietà protetta | PreferredHeight | (Ereditato da BaseEdit)
Proprietà protetta | ProcessInplaceEditValueChangedEventCore | (Ereditato da PopupBaseEdit)
Proprietà pubblica | Properties | Ritorna le Properties come RepositoryItemDedFontEdit.
Proprietà pubblica | ReadOnly | (Ereditato da BaseEdit)
Proprietà protetta | RealEditValue | (Ereditato da ComboBoxEdit)
Proprietà protetta | ScaleDPI | (Ereditato da BaseControl)
Proprietà pubblica | ScaleFactor | (Ereditato da BaseControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraControl)
Proprietà pubblica | SelectedIndex | Ritorna l'indice correntemente selezionato nella tendina. In questo caso sempre 0. (Sovrascrive FontEdit.SelectedIndex)
Proprietà pubblica | SelectedItem | (Ereditato da ComboBoxEdit)
Proprietà pubblica | SelectedText | (Ereditato da TextEdit)
Proprietà pubblica | SelectionLength | (Ereditato da TextEdit)
Proprietà pubblica | SelectionStart | (Ereditato da TextEdit)
Proprietà pubblica | ServiceObject | (Ereditato da BaseEdit)
Proprietà protetta | ShouldDrawBackgroundOnDirectXPaint | (Ereditato da XtraControl)
Proprietà protetta | ShouldNotifyAccessibilityClients | (Ereditato da BaseControl)
Proprietà protetta | ShouldProcessMouseWheelInPopup | (Ereditato da BaseEdit)
Proprietà protetta | ShowKeyboardCuesCore | (Ereditato da BaseControl)
Proprietà pubblica | ShowToolTips | (Ereditato da BaseControl)
Proprietà protetta | ShowToolTipsCore | (Ereditato da BaseEdit)
Proprietà protetta | SizeableIsCaptionVisible | (Ereditato da BaseEdit)
Proprietà protetta | SizeableMaxSize | (Ereditato da BaseControl)
Proprietà protetta | SizeableMinSize | (Ereditato da BaseControl)
Proprietà pubblica | StyleController | (Ereditato da BaseControl)
Proprietà pubblica | SuperTip | (Ereditato da BaseControl)
Proprietà protetta | SuppressSelectAll | (Ereditato da BaseEdit)
Proprietà pubblica | TabStop | (Ereditato da TextEdit)
Proprietà pubblica | Text | (Ereditato da TextEdit)
Proprietà pubblica | ToolTip | (Ereditato da BaseControl)
Proprietà pubblica | ToolTipAnchor | (Ereditato da BaseEdit)
Proprietà pubblica | ToolTipController | (Ereditato da BaseControl)
Proprietà pubblica | ToolTipIconType | (Ereditato da BaseControl)
Proprietà pubblica | ToolTipTitle | (Ereditato da BaseControl)
Proprietà protetta | UseParentOnTransparentPaintBackground | (Ereditato da TextEdit)
Proprietà protetta | ViewInfo | (Ereditato da ButtonEdit)
Proprietà protetta | WorkingStrategy | (Ereditato da TextEdit)
Torna su
Vedi anche

Documentazione

Classe DedFontEdit
Namespace DedNet.Controls


Proprietà DedFontEdit.EditorTypeName

Proprietà DedFontEditEditorTypeName
Override EditorTypeName.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string EditorTypeName { get; }
Public Overrides ReadOnly Property EditorTypeName As String
    Get
public:
virtual property String^ EditorTypeName {
    String^ get () override;
}
abstract EditorTypeName : string with get
override EditorTypeName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedFontEdit
Namespace DedNet.Controls


Proprietà DedFontEdit.PopupCommonForm

Proprietà DedFontEditPopupCommonForm
Form utilizzato come popup.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormFontDialog PopupCommonForm { get; }
Public ReadOnly Property PopupCommonForm As DedFormFontDialog
    Get
public:
property DedFormFontDialog^ PopupCommonForm {
    DedFormFontDialog^ get ();
}
member PopupCommonForm : DedFormFontDialog with get

Valore della proprietà

DedFormFontDialog
Vedi anche

Documentazione

Classe DedFontEdit
Namespace DedNet.Controls


Proprietà DedFontEdit.Properties

Proprietà DedFontEditProperties
Ritorna le Properties come RepositoryItemDedFontEdit.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public RepositoryItemDedFontEdit Properties { get; }
Public ReadOnly Property Properties As RepositoryItemDedFontEdit
    Get
public:
property RepositoryItemDedFontEdit^ Properties {
    RepositoryItemDedFontEdit^ get ();
}
member Properties : RepositoryItemDedFontEdit with get

Valore della proprietà

RepositoryItemDedFontEdit
Vedi anche

Documentazione

Classe DedFontEdit
Namespace DedNet.Controls


Proprietà DedFontEdit.SelectedIndex

Proprietà DedFontEditSelectedIndex
Ritorna l'indice correntemente selezionato nella tendina. In questo caso sempre 0.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override int SelectedIndex { get; set; }
Public Overrides Property SelectedIndex As Integer
    Get
    Set
public:
virtual property int SelectedIndex {
    int get () override;
    void set (int value) override;
}
abstract SelectedIndex : int with get, set
override SelectedIndex : int with get, set

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe DedFontEdit
Namespace DedNet.Controls


Metodi di DedFontEdit

Il tipo DedFontEdit espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | AcceptPopupValue | (Ereditato da PopupBaseEdit)
Metodo protetto | AccessibilityNotifyTextChanged | (Ereditato da TextEdit)
Metodo protetto | ActionShowPopup(EditorButtonObjectInfoArgs) | (Ereditato da PopupBaseEdit)
Metodo protetto | ActionShowPopup(Keys) | (Ereditato da PopupBaseEdit)
Metodo pubblico | AllowMouseClick | (Ereditato da PopupBaseEdit)
Metodo pubblico | AppendText | (Ereditato da TextEdit)
Metodo protetto | BaseEditWndProc | (Ereditato da TextEdit)
Metodo protetto | BaseWndProc | (Ereditato da ControlBase)
Metodo protetto | BeginAcceptEditValue | (Ereditato da BaseEdit)
Metodo protetto | BeginClosePopup | (Ereditato da PopupBaseEdit)
Metodo protetto | BeginInternalTextChange | (Ereditato da TextEdit)
Metodo protetto | BeginUpdate | (Ereditato da BaseEdit)
Metodo pubblico | CalcBestSize | (Ereditato da BaseControl)
Metodo protetto | CalcDefaultSizeableMinWidth | (Ereditato da BaseEdit)
Metodo pubblico | CalcMinHeight | (Ereditato da BaseEdit)
Metodo protetto | CalcPopupFormBounds | (Ereditato da PopupBaseEdit)
Metodo protetto | CalcPopupFormSize | (Ereditato da PopupBaseEdit)
Metodo protetto | CalcPopupFormSizeByPM2AfterCreateHandle | (Ereditato da PopupBaseEdit)
Metodo protetto | CalcPreferredHeight | (Ereditato da BaseEdit)
Metodo protetto | CalcSizeableMaxSize | (Ereditato da TextEdit)
Metodo protetto | CalcSizeableMinSize | (Ereditato da TextEdit)
Metodo pubblico | CancelPopup | (Ereditato da PopupBaseEdit)
Metodo protetto | CancelUpdate | (Ereditato da BaseEdit)
Metodo protetto | CanProcessNullInputKeys | (Ereditato da TextEdit)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da TextEdit)
Metodo protetto | CanValidateObjectViaAnnotationAttributes | (Ereditato da BaseEdit)
Metodo protetto | CanValidateValueViaAnnotationAttributes | (Ereditato da BaseEdit)
Metodo protetto | CanValidateViaAnnotationAttributesCore | (Ereditato da BaseEdit)
Metodo protetto | CheckAutoHeight | (Ereditato da BaseEdit)
Metodo protetto | CheckAutoSearchText | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | CheckAutoSearchText(Boolean) | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | CheckDoubleClick | (Ereditato da BaseEdit)
Metodo protetto | CheckEnabled | (Ereditato da BaseEdit)
Metodo protetto | CheckErrorIcon | (Ereditato da BaseEdit)
Metodo protetto | CheckHighlightPopupAutoSearchText | (Ereditato da ComboBoxEdit)
Metodo protetto | CheckIfNullString | (Ereditato da TextEdit)
Metodo protetto | CheckInplaceAutoSearchText | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | CheckMouseHere | (Ereditato da TextEdit)
Metodo protetto | CheckRightToLeft | (Ereditato da ControlBase)
Metodo pubblico | Clear | (Ereditato da TextEdit)
Metodo protetto | ClearHotPressed | (Ereditato da BaseEdit)
Metodo protetto | ClearHotPressed(EditHitInfo) | (Ereditato da BaseEdit)
Metodo protetto | ClearHotPressedCore | (Ereditato da BaseEdit)
Metodo protetto | ClearHotPressedOnLostFocus | (Ereditato da ButtonEdit)
Metodo protetto | ClearPreferredHeight | (Ereditato da BaseEdit)
Metodo pubblico | CloseAutoCompletePopup | (Ereditato da TextEdit)
Metodo pubblico | ClosePopup | (Ereditato da FontEdit)
Metodo protetto | ClosePopup(PopupCloseMode) | (Ereditato da PopupBaseEdit)
Metodo protetto | CompareEditValue | (Ereditato da BaseEdit)
Metodo protetto | CompareEditValueOnChange | (Ereditato da BaseEdit)
Metodo protetto | CompareFonts | (Ereditato da TextEdit)
Metodo protetto | CompleteChanges | (Ereditato da BaseEdit)
Metodo protetto | ConstrainFormBounds | (Ereditato da PopupBaseEdit)
Metodo protetto | ControlOnGotFocus | (Ereditato da BaseEdit)
Metodo protetto | ControlOnLostFocus | (Ereditato da BaseEdit)
Metodo pubblico | Copy | (Ereditato da TextEdit)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da BaseControl)
Metodo protetto | CreateAccessibleInstance | (Ereditato da BaseEdit)
Metodo protetto | CreateAdvancedStrategy | (Ereditato da TextEdit)
Metodo protetto | CreateCache | (Ereditato da BaseControl)
Metodo protetto | CreateDirectXProvider | (Ereditato da XtraControl)
Metodo protetto | CreateEditController | (Ereditato da ComboBoxEdit)
Metodo protetto | CreateEditControllerInstance | (Ereditato da ComboBoxEdit)
Metodo protetto | CreateEventSender | (Ereditato da BaseEdit)
Metodo protetto | CreateHandle | (Ereditato da PopupBaseEdit)
Metodo protetto | CreateItemActions | (Ereditato da ComboBoxEdit)
Metodo protetto | CreateLookAndFeel | (Ereditato da BaseEdit)
Metodo protetto | CreateMaskBox | (Ereditato da ComboBoxEdit)
Metodo protetto | CreateMaskBoxInstance | (Ereditato da TextEdit)
Metodo protetto | CreateMaskManager | (Ereditato da TextEdit)
Metodo protetto | CreateMenu | (Ereditato da TextEdit)
Metodo protetto | CreatePopupForm | Crea e restituisce il form di popup. (Sovrascrive ComboBoxEdit.CreatePopupForm)
Metodo protetto | CreateRepositoryItem | (Ereditato da BaseEdit)
Metodo protetto | CreateRepositoryItemCore | (Ereditato da BaseEdit)
Metodo pubblico | Cut | (Ereditato da TextEdit)
Metodo protetto | DescaleInteger | (Ereditato da BaseControl)
Metodo pubblico | DeselectAll | (Ereditato da TextEdit)
Metodo protetto | DestroyHandleCore | (Ereditato da BaseEdit)
Metodo protetto | DestroyMaskBox | (Ereditato da TextEdit)
Metodo protetto | DestroyPopupForm | (Ereditato da PopupBaseEdit)
Metodo protetto | DestroyPopupFormCore | (Ereditato da PopupBaseEdit)
Metodo protetto | Dispose | (Ereditato da PopupBaseEdit)
Metodo protetto | DoBaseSetBoundsCore | (Ereditato da BaseEdit)
Metodo protetto | DoClosePopup | (Ereditato da PopupBaseEdit)
Metodo protetto | DoDpiChange | (Ereditato da PopupBaseEdit)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraControl)
Metodo protetto | DoImmediatePopup | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | DoIsMatchValidating | (Ereditato da TextEdit)
Metodo protetto | DoNullInputKeysCore | (Ereditato da PopupBaseEdit)
Metodo protetto | DoShowPopup | (Ereditato da PopupBaseEdit)
Metodo protetto | DoSpin | (Ereditato da TextEdit)
Metodo protetto | DoSynchronizePopupFormControls | (Ereditato da PopupBaseEdit)
Metodo pubblico | DoValidate | (Ereditato da BaseEdit)
Metodo pubblico | DoValidate(PopupCloseMode) | (Ereditato da BaseEdit)
Metodo protetto | DoValidateOnEnterKey | (Ereditato da BaseEdit)
Metodo protetto | EndAcceptEditValue | (Ereditato da BaseEdit)
Metodo protetto | EndClosePopup | (Ereditato da PopupBaseEdit)
Metodo protetto | EndInternalTextChange | (Ereditato da TextEdit)
Metodo protetto | EndUpdate | (Ereditato da BaseEdit)
Metodo protetto | EnsureAnnotationAttributes | (Ereditato da BaseEdit)
Metodo pubblico | EnsureInnerEditorFocused | (Ereditato da TextEdit)
Metodo protetto | ExecInnerEditMouseDown | (Ereditato da ButtonEdit)
Metodo protetto | ExtractParsedValue | (Ereditato da BaseEdit)
Metodo protetto | FindCurrentText | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | FindItem(String, Int32) | (Ereditato da ComboBoxEdit)
Metodo protetto | FindItem(String, Boolean, Int32) | (Ereditato da ComboBoxEdit)
Metodo protetto | FindUpdateEditValue | (Ereditato da ComboBoxEdit)
Metodo protetto | FindUpdateEditValueAutoSearchText | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | FindUpdatePopupSelectedItem | (Ereditato da ComboBoxEdit)
Metodo protetto | FireChanged | (Ereditato da BaseControl)
Metodo protetto | FireSpinRequest | (Ereditato da ComboBoxEdit)
Metodo protetto | FlushPendingEditActions | (Ereditato da TextEdit)
Metodo pubblico | ForceClosePopup | (Ereditato da PopupBaseEdit)
Metodo protetto | GetAccessibilityObjectById | (Ereditato da ComboBoxEdit)
Metodo pubblico | GetAccessible | (Ereditato da BaseControl)
Metodo protetto | GetAccessibleToNotify | (Ereditato da TextEdit)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da BaseControl)
Metodo protetto | GetActualText | (Ereditato da ComboBoxEdit)
Metodo protetto | GetAutoSearchCharKeyPressHelper | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | GetAutoSearchCharKeyPressHelperCore | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | GetAutoSearchTextFilter | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | GetChangingOldEditValue | (Ereditato da BaseEdit)
Metodo pubblico | GetCharFromPosition | (Ereditato da TextEdit)
Metodo pubblico | GetCharIndexFromPosition | (Ereditato da TextEdit)
Metodo protetto | GetColor(Color, Color) | (Ereditato da BaseControl)
Metodo protetto | GetColor(Color, Color, Boolean) | (Ereditato da BaseControl)
Metodo protetto | GetDeviceSize | (Ereditato da XtraControl)
Metodo protetto | GetDropDownEditorBorderWeight | (Ereditato da PopupBaseEdit)
Metodo protetto | GetDropDownOrigin | (Ereditato da PopupBaseEdit)
Metodo protetto | GetDropDownPadding | (Ereditato da PopupBaseEdit)
Metodo pubblico | GetFirstCharIndexFromLine | (Ereditato da TextEdit)
Metodo pubblico | GetFirstCharIndexOfCurrentLine | (Ereditato da TextEdit)
Metodo protetto | GetItemDescription | (Ereditato da ComboBoxEdit)
Metodo pubblico | GetLineFromCharIndex | (Ereditato da TextEdit)
Metodo protetto | GetNewScrollIndex | (Ereditato da FontEdit)
Metodo protetto | GetNullInputKeysValue | (Ereditato da TextEdit)
Metodo protetto | GetObjectToValidate | (Ereditato da BaseEdit)
Metodo pubblico | GetPopupEditForm | (Ereditato da ComboBoxEdit)
Metodo protetto | GetPopupForm | (Ereditato da PopupBaseEdit)
Metodo protetto | GetPopupFormCore | (Ereditato da PopupBaseEdit)
Metodo pubblico | GetPositionFromCharIndex | (Ereditato da TextEdit)
Metodo pubblico | GetPreferredSize | (Ereditato da BaseEdit)
Metodo protetto | GetScaledBounds | (Ereditato da BaseEdit)
Metodo protetto | GetScaleDpiCore | (Ereditato da BaseControl)
Metodo protetto | GetSkinnedCellPadding | (Ereditato da PopupBaseEdit)
Metodo protetto | GetSkinnedEditorBorderWeight | (Ereditato da PopupBaseEdit)
Metodo protetto | GetTextEditController | (Ereditato da TextEdit)
Metodo protetto | GetToolTipAnchor | (Ereditato da BaseControl)
Metodo protetto | GetToolTipInfo | (Ereditato da BaseEdit)
Metodo protetto | GetUseDirectXPaint | (Ereditato da XtraControl)
Metodo protetto | GetValidationCanceled | (Ereditato da BaseEdit)
Metodo pubblico | GetViewInfo | (Ereditato da BaseControl)
Metodo protetto | HideCaret | (Ereditato da TextEdit)
Metodo protetto | InitializeDefault | (Ereditato da BaseEdit)
Metodo protetto | InitializeDefaultProperties | (Ereditato da ComboBoxEdit)
Metodo pubblico | InnerEditorPaste | (Ereditato da TextEdit)
Metodo pubblico | InnerEditorSpin | (Ereditato da TextEdit)
Metodo protetto | InvalidateFormBoundsByPM2BeforeShow | (Ereditato da PopupBaseEdit)
Metodo protetto | IsAcceptCloseMode | (Ereditato da PopupBaseEdit)
Metodo protetto | IsActionButton | (Ereditato da PopupBaseEdit)
Metodo protetto | IsAutoSearchCharHandled | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | IsBindingDataAccessible | (Ereditato da BaseEdit)
Metodo protetto | IsBindingManagerPositionValid | (Ereditato da BaseEdit)
Metodo protetto | IsClearButton | (Ereditato da PopupBaseEdit)
Metodo protetto | IsClearButtonVisible | (Ereditato da PopupBaseEdit)
Metodo pubblico | IsInnerEditorReadOnly | (Ereditato da TextEdit)
Metodo protetto | IsInputChar | (Ereditato da TextEdit)
Metodo protetto | IsInputKey | (Ereditato da TextEdit)
Metodo protetto | IsInputKeyCore | (Ereditato da BaseEdit)
Metodo protetto | IsItemVisible | (Ereditato da ComboBoxEdit)
Metodo pubblico | IsNeededCursorKey | (Ereditato da TextEdit)
Metodo protetto | IsNeededExtraKey | (Ereditato da TextEdit)
Metodo pubblico | IsNeededKey | (Ereditato da PopupBaseEdit)
Metodo protetto | IsNullValue | (Ereditato da BaseEdit)
Metodo protetto | IsShowNullValuePrompt | (Ereditato da TextEdit)
Metodo protetto | IsTextCommand | (Ereditato da TextEdit)
Metodo protetto | KeepPopupFormSize | (Ereditato da PopupBaseEdit)
Metodo protetto | LayoutChanged | (Ereditato da TextEdit)
Metodo protetto | LayoutChanged(Boolean) | (Ereditato da TextEdit)
Metodo protetto | LayoutChangedCore | (Ereditato da TextEdit)
Metodo protetto | LayoutChangedCore(Boolean) | (Ereditato da BaseControl)
Metodo protetto | LockEditValueChanged | (Ereditato da BaseEdit)
Metodo protetto | LockMaskBoxPropertiesUpdate | (Ereditato da TextEdit)
Metodo protetto | MaskBoxGetEditValue | (Ereditato da TextEdit)
Metodo protetto | NeedLayoutUpdateValidating | (Ereditato da TextEdit)
Metodo protetto | NotifyAccessibilityClients(AccessibleEvents, Int32, Int32) | (Ereditato da BaseControl)
Metodo protetto | NotifyAccessibilityClients(AccessibleEvents, AutomationElementProvider, Int32, Int32) | (Ereditato da BaseControl)
Metodo protetto | NotifyButtonStateChanged | (Ereditato da ButtonEdit)
Metodo protetto | OnActionItemClick | (Ereditato da ComboBoxEdit)
Metodo protetto | OnAfterUpdateViewInfo | (Ereditato da TextEdit)
Metodo protetto | OnAppearancePaintChanged | (Ereditato da TextEdit)
Metodo protetto | OnAutoHeightChanged | (Ereditato da BaseEdit)
Metodo protetto | OnBeforeUpdateViewInfo | (Ereditato da TextEdit)
Metodo protetto | OnBorderStyleChanged | (Ereditato da BaseControl)
Metodo protetto | OnCancelEditValueChanging | (Ereditato da BaseEdit)
Metodo protetto | OnClickButton | (Ereditato da PopupBaseEdit)
Metodo protetto | OnClickButtonCore | (Ereditato da ButtonEdit)
Metodo protetto | OnClientSizeChanged | (Ereditato da TextEdit)
Metodo protetto | OnContextMenuChanged | (Ereditato da BaseEdit)
Metodo protetto | OnContextMenuStripChanged | (Ereditato da BaseEdit)
Metodo protetto | OnControllerValueChanged | (Ereditato da TextEdit)
Metodo protetto | OnControllerValueChanging | (Ereditato da TextEdit)
Metodo protetto | OnCreateControl | (Ereditato da TextEdit)
Metodo protetto | OnDefaultPressButton | (Ereditato da PopupBaseEdit)
Metodo protetto | OnDirectXPaintDisabled | (Ereditato da XtraControl)
Metodo protetto | OnDirectXPaintEnabled | (Ereditato da XtraControl)
Metodo protetto | OnEditorEnter | (Ereditato da TextEdit)
Metodo protetto | OnEditorKeyDown | (Ereditato da ComboBoxEdit)
Metodo protetto | OnEditorKeyDownProcessNullInputKeys | (Ereditato da TextEdit)
Metodo protetto | OnEditorKeyPress | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | OnEditorKeyUp | (Ereditato da PopupBaseEdit)
Metodo protetto | OnEditorLeave | (Ereditato da TextEdit)
Metodo protetto | OnEditValueChanged | (Ereditato da FontEdit)
Metodo protetto | OnEditValueChanging | (Ereditato da TextEdit)
Metodo protetto | OnEnabledChanged | (Ereditato da TextEdit)
Metodo protetto | OnEnableNonMaskedInput | (Ereditato da TextEdit)
Metodo protetto | OnEndIme | (Ereditato da PopupBaseEdit)
Metodo protetto | OnEnter | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | OnErrorInfoChanged | (Ereditato da BaseEdit)
Metodo protetto | OnErrorTextChanged | (Ereditato da TextEdit)
Metodo protetto | OnGlassMaskBoxPreWndProc | (Ereditato da TextEdit)
Metodo protetto | OnGlassMaskBoxWndProc | (Ereditato da TextEdit)
Metodo protetto | OnGotCapture | (Ereditato da ControlBase)
Metodo protetto | OnGotFocus | (Ereditato da PopupBaseEdit)
Metodo protetto | OnHandleCreated | (Ereditato da TextEdit)
Metodo protetto | OnHandleDestroyed | (Ereditato da TextEdit)
Metodo protetto | OnImeModeChanged | (Ereditato da TextEdit)
Metodo protetto | OnInvalidValue | (Ereditato da BaseEdit)
Metodo protetto | OnKeyDown | (Ereditato da TextEdit)
Metodo protetto | OnKeyPress | (Ereditato da TextEdit)
Metodo protetto | OnKeyUp | (Ereditato da TextEdit)
Metodo protetto | OnLeave | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | OnLoaded | (Ereditato da PopupBaseEdit)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da TextEdit)
Metodo protetto | OnLostCapture | (Ereditato da ControlBase)
Metodo protetto | OnLostFocus | (Ereditato da PopupBaseEdit)
Metodo protetto | OnMaskBox_Click | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_DoubleClick | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_GotFocus | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_KeyDown | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_KeyPress | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_KeyUp | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_LostFocus | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_MouseDown | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_MouseEnter | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_MouseLeave | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_MouseMove | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_MouseUp | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_MouseWheel | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_TextValidated | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_ValueChanged | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_ValueChanging | (Ereditato da TextEdit)
Metodo protetto | OnMaskBoxMouseSelection | (Ereditato da TextEdit)
Metodo protetto | OnMaskBoxPreWndProc | (Ereditato da TextEdit)
Metodo protetto | OnMaskBoxTextResetToNullValuePromptOrNullText | (Ereditato da TextEdit)
Metodo protetto | OnMaskBoxWndProc | (Ereditato da TextEdit)
Metodo protetto | OnMaskEditValueChanging | (Ereditato da TextEdit)
Metodo protetto | OnMouseDown | (Ereditato da ComboBoxEdit)
Metodo protetto | OnMouseDownClosePopup | (Ereditato da PopupBaseEdit)
Metodo protetto | OnMouseEnter | (Ereditato da TextEdit)
Metodo protetto | OnMouseLeave | (Ereditato da TextEdit)
Metodo protetto | OnMouseMove | (Ereditato da TextEdit)
Metodo protetto | OnMouseUp | (Ereditato da ButtonEdit)
Metodo protetto | OnMouseWheel | (Ereditato da ComboBoxEdit)
Metodo protetto | OnMove | (Ereditato da PopupBaseEdit)
Metodo protetto | OnPaddingChanged | (Ereditato da BaseControl)
Metodo protetto | OnPaint | (Ereditato da TextEdit)
Metodo protetto | OnPaintBackground | (Ereditato da TextEdit)
Metodo protetto | OnParentChanged | (Ereditato da ControlBase)
Metodo protetto | OnParentVisibleChanged | (Ereditato da PopupBaseEdit)
Metodo protetto | OnPopupClosed | (Ereditato da ComboBoxEdit)
Metodo protetto | OnPopupClosing | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | OnPopupFormValueChanged | (Ereditato da ComboBoxEdit)
Metodo protetto | OnPopupSelectedIndexChanged | (Ereditato da ComboBoxEdit)
Metodo protetto | OnPopupShown | (Ereditato da PopupBaseEdit)
Metodo protetto | OnPressButton | (Ereditato da PopupBaseEdit)
Metodo protetto | OnPreviewKeyDown | (Ereditato da TextEdit)
Metodo protetto | OnProperties_PropertiesChanged | (Ereditato da BaseEdit)
Metodo protetto | OnPropertiesChanged | (Ereditato da PopupBaseEdit)
Metodo protetto | OnPropertiesChanged_SyncPopup | (Ereditato da PopupBaseEdit)
Metodo protetto | OnResize | (Ereditato da TextEdit)
Metodo protetto | OnRightToLeftChanged | (Ereditato da PopupBaseEdit)
Metodo protetto | OnRightToLeftChanged(EventArgs) | (Ereditato da ControlBase)
Metodo protetto | OnScaleControl | (Ereditato da BaseEdit)
Metodo protetto | OnScaleDpiChanged | (Ereditato da ControlBase)
Metodo protetto | OnSizeChanged | (Ereditato da TextEdit)
Metodo protetto | OnSpin | (Ereditato da TextEdit)
Metodo protetto | OnStyleController_Disposed | (Ereditato da BaseControl)
Metodo protetto | OnStyleController_PropertiesChanged | (Ereditato da BaseControl)
Metodo protetto | OnStyleControllerChanged | (Ereditato da TextEdit)
Metodo protetto | OnTabStopChanged | (Ereditato da TextEdit)
Metodo protetto | OnTextChanged | (Ereditato da TextEdit)
Metodo protetto | OnTextEditPropertiesChanged | (Ereditato da TextEdit)
Metodo protetto | OnValidated | (Ereditato da FontEdit)
Metodo protetto | OnValidating | (Ereditato da TextEdit)
Metodo protetto | OnValidatingCore | (Ereditato da BaseEdit)
Metodo protetto | OnVisibleChanged | (Ereditato da PopupBaseEdit)
Metodo protetto | PaintErrorIconBackground | (Ereditato da TextEdit)
Metodo protetto | ParseEditorValue | (Ereditato da BaseEdit)
Metodo pubblico | Paste | (Ereditato da TextEdit)
Metodo protetto | PendingEditActionPerformed | (Ereditato da TextEdit)
Metodo pubblico | PerformClick | (Ereditato da ButtonEdit)
Metodo protetto | PerformDefaultClearButtonAction | (Ereditato da PopupBaseEdit)
Metodo protetto | ProcessAutoSearchChar | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | ProcessAutoSearchNavKey | (Ereditato da ComboBoxEdit)
Metodo protetto | ProcessChar | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | ProcessCmdKey | (Ereditato da TextEdit)
Metodo protetto | ProcessDialogKey | (Ereditato da PopupBaseEdit)
Metodo protetto | ProcessDialogKeyCore | (Ereditato da TextEdit)
Metodo protetto | ProcessFindItem | (Ereditato da PopupBaseAutoSearchEdit)
Metodo protetto | ProcessPaintAction | (Ereditato da XtraControl)
Metodo protetto | ProcessPopupMouseWheel | (Ereditato da BaseEdit)
Metodo protetto | ProcessPopupTabKey | (Ereditato da PopupBaseEdit)
Metodo protetto | ProcessRemoveWord | (Ereditato da TextEdit)
Metodo protetto | QueryEditorModeFromSkin | (Ereditato da TextEdit)
Metodo protetto | QueryMaskEditValue | (Ereditato da TextEdit)
Metodo protetto | RaiseDropDownCustomDrawItem | (Ereditato da ComboBoxEdit)
Metodo protetto | RaiseEditValueChanged | (Ereditato da BaseEdit)
Metodo protetto | RaiseInvalidValue | (Ereditato da BaseEdit)
Metodo protetto | RaiseModified | (Ereditato da BaseEdit)
Metodo protetto | RaisePaintEvent | (Ereditato da TextEdit)
Metodo protetto | RaisePaintExEvent(TextEditPaintExEventArgs) | (Ereditato da TextEdit)
Metodo protetto | RaisePaintExEvent(GraphicsCache, PaintEventArgs) | (Ereditato da XtraControl)
Metodo protetto | RaisePopupAllowClick | (Ereditato da PopupBaseEdit)
Metodo protetto | RaiseQueryAdvancedMode | (Ereditato da TextEdit)
Metodo protetto | RaiseQueryCompletion | (Ereditato da TextEdit)
Metodo protetto | RaiseSizeableChanged | (Ereditato da BaseControl)
Metodo pubblico | Refresh | (Ereditato da BaseControl)
Metodo pubblico | RefreshEditValue | (Ereditato da PopupBaseEdit)
Metodo protetto | RefreshEnabledState | (Ereditato da TextEdit)
Metodo protetto | RefreshPopup | (Ereditato da ComboBoxEdit)
Metodo protetto | RefreshVisualLayout | (Ereditato da BaseEdit)
Metodo protetto | RefreshVisualLayoutCore | (Ereditato da BaseEdit)
Metodo protetto | RejectPopupValue | (Ereditato da PopupBaseEdit)
Metodo protetto | ReleaseDirectXResources | (Ereditato da XtraControl)
Metodo protetto | ReleaseStyleController | (Ereditato da BaseControl)
Metodo protetto | RemoveXtraAnimator | (Ereditato da BaseControl)
Metodo pubblico | Reset | (Ereditato da ComboBoxEdit)
Metodo protetto | ResetAccessible | (Ereditato da BaseControl)
Metodo pubblico | ResetBackColor | (Ereditato da BaseEdit)
Metodo protetto | ResetEvents | (Ereditato da BaseEdit)
Metodo pubblico | ResetForeColor | (Ereditato da BaseEdit)
Metodo pubblico | ResetSelection | (Ereditato da TextEdit)
Metodo pubblico | ResetSuperTip | (Ereditato da BaseControl)
Metodo protetto | ScaleControl | (Ereditato da ControlBase)
Metodo protetto | ScaleFont | (Ereditato da TextEdit)
Metodo protetto | ScaleInteger | (Ereditato da BaseControl)
Metodo protetto | ScaleSize | (Ereditato da BaseControl)
Metodo protetto | ScrollIndex | (Ereditato da ComboBoxEdit)
Metodo pubblico | ScrollToCaret | (Ereditato da TextEdit)
Metodo protetto | ScrollValue | (Ereditato da ComboBoxEdit)
Metodo protetto | Select(Boolean, Boolean) | (Ereditato da TextEdit)
Metodo pubblico | Select(Int32, Int32) | (Ereditato da TextEdit)
Metodo pubblico | SelectAll | (Ereditato da TextEdit)
Metodo pubblico | SendKey(KeyEventArgs) | (Ereditato da BaseEdit)
Metodo pubblico | SendKey(Object, KeyPressEventArgs) | (Ereditato da BaseEdit)
Metodo pubblico | SendKeyUp | (Ereditato da BaseEdit)
Metodo pubblico | SendMouse(MouseEventArgs) | (Ereditato da BaseEdit)
Metodo pubblico | SendMouse(Point, MouseButtons) | (Ereditato da BaseEdit)
Metodo protetto | SendMouseUp(MouseEventArgs) | (Ereditato da BaseEdit)
Metodo pubblico | SendMouseUp(Point, MouseButtons) | (Ereditato da BaseEdit)
Metodo protetto | SetBackColor | (Ereditato da BaseControl)
Metodo protetto | SetBoundsCore | (Ereditato da BaseEdit)
Metodo protetto | SetEmptyEditValue | (Ereditato da PopupBaseEdit)
Metodo protetto | SetErrorIcon | (Ereditato da BaseEdit)
Metodo protetto | SetPopupEditValueOnClose | (Ereditato da PopupBaseEdit)
Metodo protetto | SetTextCore | (Ereditato da TextEdit)
Metodo protetto | SetVisibleCore | (Ereditato da ControlBase)
Metodo protetto | ShouldSuppressFormDeactivation | (Ereditato da TextEdit)
Metodo protetto | ShouldSuppressTextCommand | (Ereditato da TextEdit)
Metodo pubblico | ShowAutoCompletePopup | (Ereditato da TextEdit)
Metodo protetto | ShowCaret | (Ereditato da TextEdit)
Metodo protetto | ShowMenu | (Ereditato da TextEdit)
Metodo protetto | ShowMenuCore | (Ereditato da TextEdit)
Metodo pubblico | ShowPopup | (Ereditato da PopupBaseEdit)
Metodo protetto | SilentRemove | (Ereditato da ComboBoxEdit)
Metodo protetto | SilentRemoveCore | (Ereditato da ComboBoxEdit)
Metodo protetto | SubscribePopupFormEvents | (Ereditato da PopupBaseEdit)
Metodo protetto | SuppressMouseWheel | (Ereditato da PopupBaseEdit)
Metodo protetto | SwitchModeAccordingToSkinSettings | (Ereditato da TextEdit)
Metodo protetto | SwitchPopupState | (Ereditato da PopupBaseEdit)
Metodo protetto | TryNotifyAccessibilitySelectedIndexChanged | (Ereditato da ComboBoxEdit)
Metodo pubblico | Undo | (Ereditato da TextEdit)
Metodo protetto | UnLockEditValueChanged | (Ereditato da BaseEdit)
Metodo protetto | UnlockMaskBoxPropertiesUpdate | (Ereditato da TextEdit)
Metodo protetto | UpdateClearButtonVisibility | (Ereditato da PopupBaseEdit)
Metodo protetto | UpdateClearButtonVisibilityCore | (Ereditato da PopupBaseEdit)
Metodo protetto | UpdateDisplayText | (Ereditato da TextEdit)
Metodo protetto | UpdateEditControllerProperties | (Ereditato da TextEdit)
Metodo protetto | UpdateEditValueOnClose | (Ereditato da ComboBoxEdit)
Metodo protetto | UpdateFixedHeight | (Ereditato da BaseEdit)
Metodo protetto | UpdateHideSelection | (Ereditato da TextEdit)
Metodo protetto | UpdateInactiveInnerEditorProperties | (Ereditato da TextEdit)
Metodo protetto | UpdateMaskBox | (Ereditato da TextEdit)
Metodo protetto | UpdateMaskBox(Boolean) | (Ereditato da TextEdit)
Metodo protetto | UpdateMaskBoxBounds | (Ereditato da TextEdit)
Metodo protetto | UpdateMaskBoxDisplayText | (Ereditato da TextEdit)
Metodo protetto | UpdateMaskBoxFontByScaleDpi | (Ereditato da TextEdit)
Metodo protetto | UpdateMaskBoxProperties | (Ereditato da TextEdit)
Metodo protetto | UpdateMaskBoxPropertiesCore | (Ereditato da TextEdit)
Metodo protetto | UpdateMenu | (Ereditato da TextEdit)
Metodo protetto | UpdateMenuCoords | (Ereditato da TextEdit)
Metodo protetto | UpdatePasswordChar | (Ereditato da TextEdit)
Metodo protetto | UpdatePopupEditValueIndex | (Ereditato da ComboBoxEdit)
Metodo protetto | UpdateScaleDpi | (Ereditato da XtraControl)
Metodo protetto | UpdateScaleFactorForScaleHelper | (Ereditato da XtraControl)
Metodo pubblico | UpdateTextHighlight | (Ereditato da TextEdit)
Metodo protetto | UpdateViewInfo | (Ereditato da BaseControl)
Metodo protetto | UpdateViewInfoEditValue | (Ereditato da BaseEdit)
Metodo protetto | UpdateViewInfoState | (Ereditato da BaseControl)
Metodo protetto | UpdateViewInfoState(Boolean) | (Ereditato da BaseControl)
Metodo protetto | UpdateViewInfoState(Boolean, Point) | (Ereditato da BaseControl)
Metodo protetto | WndProc | (Ereditato da PopupBaseEdit)
Torna su
Vedi anche

Documentazione

Classe DedFontEdit
Namespace DedNet.Controls


Metodo DedFontEdit.CreatePopupForm

Metodo DedFontEditCreatePopupForm
Crea e restituisce il form di popup.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override PopupBaseForm CreatePopupForm()
Protected Overrides Function CreatePopupForm As PopupBaseForm
protected:
virtual PopupBaseForm^ CreatePopupForm() override
abstract CreatePopupForm : unit -> PopupBaseForm
override CreatePopupForm : unit -> PopupBaseForm

Valore di ritorno

PopupBaseForm
Vedi anche

Documentazione

Classe DedFontEdit
Namespace DedNet.Controls


Eventi di DedFontEdit

Il tipo DedFontEdit espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | BackColorChanged | (Ereditato da BaseEdit)
Evento pubblico | BeforePopup | (Ereditato da PopupBaseEdit)
Evento pubblico | ButtonClick | (Ereditato da ButtonEdit)
Evento pubblico | ButtonPressed | (Ereditato da ButtonEdit)
Evento pubblico | Closed | (Ereditato da PopupBaseEdit)
Evento pubblico | CloseUp | (Ereditato da PopupBaseEdit)
Evento pubblico | CustomDisplayText | (Ereditato da BaseEdit)
Evento pubblico | CustomHighlightText | (Ereditato da TextEdit)
Evento pubblico | CustomizeAutoCompleteSource | (Ereditato da TextEdit)
Evento pubblico | CustomTextLineHeight | (Ereditato da TextEdit)
Evento pubblico | DrawItem | (Ereditato da ComboBoxEdit)
Evento pubblico | DropDownCustomDrawItem | Obsoleto. (Ereditato da ComboBoxEdit)
Evento pubblico | EditValueChanged | (Ereditato da BaseEdit)
Evento pubblico | EditValueChanging | (Ereditato da BaseEdit)
Evento pubblico | FontChanged | (Ereditato da BaseEdit)
Evento pubblico | ForeColorChanged | (Ereditato da BaseEdit)
Evento pubblico | FormatEditValue | (Ereditato da BaseEdit)
Evento pubblico | InvalidValue | (Ereditato da BaseEdit)
Evento pubblico | Modified | (Ereditato da BaseEdit)
Evento pubblico | PaintEx | (Ereditato da TextEdit)
Evento pubblico | ParseEditValue | (Ereditato da BaseEdit)
Evento pubblico | Popup | (Ereditato da PopupBaseEdit)
Evento pubblico | PopupAllowClick | (Ereditato da PopupBaseEdit)
Evento pubblico | PropertiesChanged | (Ereditato da BaseEdit)
Evento pubblico | QueryAccessibilityHelp | (Ereditato da BaseEdit)
Evento pubblico | QueryCloseUp | (Ereditato da PopupBaseEdit)
Evento pubblico | QueryPopUp | (Ereditato da PopupBaseEdit)
Evento pubblico | QueryProcessKey | (Ereditato da BaseEdit)
Evento pubblico | SelectedIndexChanged | (Ereditato da ComboBoxEdit)
Evento pubblico | SelectedValueChanged | (Ereditato da ComboBoxEdit)
Evento pubblico | Spin | (Ereditato da TextEdit)
Torna su
Vedi anche

Documentazione

Classe DedFontEdit
Namespace DedNet.Controls


Campi di DedFontEdit

Il tipo DedFontEdit espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | fDisposing | (Ereditato da BaseControl)
Campo protetto | fEditValue | (Ereditato da BaseEdit)
Campo protetto | fOldEditValue | (Ereditato da BaseEdit)
Campo protetto | fProperties | (Ereditato da BaseEdit)
Campo protetto | fShowToolTips | (Ereditato da BaseControl)
Campo protetto | lastChangedEditValue | (Ereditato da BaseEdit)
Campo protetto | shouldRaiseSizeableChanged | (Ereditato da BaseControl)
Torna su
Vedi anche

Documentazione

Classe DedFontEdit
Namespace DedNet.Controls


Classe DedGridControl
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
EditorContainer
GridControl
DedNet.ControlsDedGridControl

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedGridControl : GridControl
Public Class DedGridControl
    Inherits GridControl
public ref class DedGridControl : public GridControl
type DedGridControl =
    class
        inherit GridControl
    end

Il tipo DedGridControl espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedGridControl |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà protetta | AllowLayoutEvent | (Ereditato da GridControl)
Proprietà pubblica | AllowRestoreSelectionAndFocusedRow | (Ereditato da GridControl)
Proprietà protetta | AllowScaleOnLoad | (Ereditato da EditorContainer)
Proprietà pubblica | AllowTouchGestures | (Ereditato da EditorContainer)
Proprietà pubblica | AvailableViews | (Ereditato da GridControl)
Proprietà pubblica | BackColor | (Ereditato da GridControl)
Proprietà pubblica | BindingContext | (Ereditato da GridControl)
Proprietà pubblica | ContextMenuStrip | (Ereditato da GridControl)
Proprietà pubblica | Controls | (Ereditato da GridControl)
Proprietà pubblica | Cursor | (Ereditato da GridControl)
Proprietà pubblica | DataMember | (Ereditato da GridControl)
Proprietà pubblica | DataSource | (Ereditato da GridControl)
Proprietà protetta | DefaultSize | (Ereditato da GridControl)
Proprietà pubblica | DefaultView | (Ereditato da GridControl)
Proprietà protetta | DirectXProvider | (Ereditato da GridControl)
Proprietà protetta | DirectXScroller | (Ereditato da GridControl)
Proprietà pubblica | Dock | (Ereditato da GridControl)
Proprietà protetta | DragController | (Ereditato da GridControl)
Proprietà protetta | EditorHelper | (Ereditato da GridControl)
Proprietà pubblica | EmbeddedNavigator | (Ereditato da GridControl)
Proprietà pubblica | EnableAutomaticRowHeightForFocusedCell |
Proprietà pubblica | EnableCopyWithDragDrop | Indica se trascinando la cella il valore al suo interno deve essere copiato anche nelle altre celle (come in Excel).
Proprietà protetta | EnableFirstPaintTrigger | (Ereditato da GridControl)
Proprietà protetta | ExceptionThrown | (Ereditato da GridControl)
Proprietà pubblica | ExternalRepository | (Ereditato da EditorContainer)
Proprietà protetta | FireOnLoadOnPaint | (Ereditato da GridControl)
Proprietà pubblica | FocusedView | (Ereditato da GridControl)
Proprietà pubblica | ForeColor | (Ereditato da EditorContainer)
Proprietà pubblica | FormsUseDefaultLookAndFeel | (Ereditato da GridControl)
Proprietà pubblica | GridDisposing | (Ereditato da GridControl)
Proprietà pubblica | IsAttachedToSearchControl | (Ereditato da GridControl)
Proprietà pubblica | IsDesignMode | (Ereditato da EditorContainer)
Proprietà pubblica | IsFocused | (Ereditato da GridControl)
Proprietà protetta | IsInitialized | (Ereditato da EditorContainer)
Proprietà protetta | IsInPrintMessage | (Ereditato da GridControl)
Proprietà pubblica | IsLoaded | (Ereditato da GridControl)
Proprietà pubblica | IsLoading | (Ereditato da EditorContainer)
Proprietà protetta | IsLockUpdate | (Ereditato da GridControl)
Proprietà protetta | IsPrinterExist | (Ereditato da GridControl)
Proprietà pubblica | IsPrinting | (Ereditato da GridControl)
Proprietà pubblica | IsPrintingAvailable | (Ereditato da GridControl)
Proprietà protetta | IsPrintWrapperValid | (Ereditato da GridControl)
Proprietà protetta | IsRightToLeft | (Ereditato da GridControl)
Proprietà pubblica | IsSplitGrid | (Ereditato da GridControl)
Proprietà pubblica | KeyboardFocusView | Obsoleto. (Ereditato da GridControl)
Proprietà pubblica | LevelTree | (Ereditato da GridControl)
Proprietà pubblica | LookAndFeel | (Ereditato da EditorContainer)
Proprietà protetta | LookAndFeelIgnoreChildren | (Ereditato da EditorContainer)
Proprietà protetta | LookUpOwner | (Ereditato da GridControl)
Proprietà pubblica | MainView | (Ereditato da GridControl)
Proprietà pubblica | MenuManager | (Ereditato da EditorContainer)
Proprietà protetta | MouseCaptureOwner | (Ereditato da GridControl)
Proprietà protetta | NavigatableHelper | (Ereditato da GridControl)
Proprietà protetta | NavView | (Ereditato da GridControl)
Proprietà protetta | Printer | (Ereditato da GridControl)
Proprietà protetta | PrintWrapper | (Ereditato da GridControl)
Proprietà pubblica | RepositoryItems | (Ereditato da EditorContainer)
Proprietà protetta | ScaleDPI | (Ereditato da EditorContainer)
Proprietà pubblica | ScaleFactor | (Ereditato da EditorContainer)
Proprietà protetta | ScaleHelper | (Ereditato da EditorContainer)
Proprietà protetta | Scroller | (Ereditato da GridControl)
Proprietà pubblica | ServerMode | Obsoleto. (Ereditato da GridControl)
Proprietà pubblica | ShowOnlyPredefinedDetails | (Ereditato da GridControl)
Proprietà protetta | SplitContainer | (Ereditato da GridControl)
Proprietà pubblica | Text | (Ereditato da EditorContainer)
Proprietà pubblica | ToolTipController | (Ereditato da EditorContainer)
Proprietà protetta | TouchClient | (Ereditato da GridControl)
Proprietà pubblica | UseDirectXPaint | (Ereditato da GridControl)
Proprietà protetta | UseDirectXPaintCore | (Ereditato da GridControl)
Proprietà pubblica | UseDisabledStatePainter | (Ereditato da GridControl)
Proprietà pubblica | UseEmbeddedNavigator | (Ereditato da GridControl)
Proprietà pubblica | UseReadonlyAppearanceForColumns | Indica se le colonne ReadOnly devono utilizzare il colore di sfondo dedicato.
Proprietà pubblica | ViewCollection | (Ereditato da GridControl)
Proprietà protetta | ViewRepository | (Ereditato da GridControl)
Proprietà pubblica | Views | (Ereditato da GridControl)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AccessibleNotifyClients(AccessibleEvents, BaseAccessible) | (Ereditato da GridControl)
Metodo pubblico | AccessibleNotifyClients(AccessibleEvents, Int32) | (Ereditato da GridControl)
Metodo protetto | ActivateDataSource | (Ereditato da GridControl)
Metodo protetto | AddToDefaultTooltipController | (Ereditato da EditorContainer)
Metodo pubblico | BeginInit | (Ereditato da GridControl)
Metodo pubblico | BeginUpdate | (Ereditato da GridControl)
Metodo protetto | CancelUpdate | (Ereditato da GridControl)
Metodo protetto | CanHandleTouchGestures | (Ereditato da EditorContainer)
Metodo protetto | CheckMousePos | (Ereditato da GridControl)
Metodo protetto | CheckNeedScale | (Ereditato da EditorContainer)
Metodo protetto | CheckPrintWrapper | (Ereditato da GridControl)
Metodo protetto | CheckProcessMsg | (Ereditato da GridControl)
Metodo protetto | CheckRightToLeft | (Ereditato da EditorContainer)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da GridControl)
Metodo protetto | CreateComponentPrinter | (Ereditato da GridControl)
Metodo protetto | CreateDefaultView | (Ereditato da GridControl)
Metodo protetto | CreateEmbeddedNavigator | (Ereditato da GridControl)
Metodo pubblico | CreateGraphicsCache | (Ereditato da GridControl)
Metodo protetto | CreateHelper | (Ereditato da GridControl)
Metodo protetto | CreateInternalRepository | (Ereditato da EditorContainer)
Metodo protetto | CreateLookAndFeel | (Ereditato da EditorContainer)
Metodo protetto | CreateMainView | (Ereditato da GridControl)
Metodo pubblico | CreateSplitContainer | (Ereditato da GridControl)
Metodo pubblico | CreateView | (Ereditato da GridControl)
Metodo protetto | CreateViewPrintWrapper | (Ereditato da GridControl)
Metodo protetto | DestroyAvailableViews | (Ereditato da GridControl)
Metodo protetto | DestroyDirectXProvider | (Ereditato da EditorContainer)
Metodo protetto | DestroyPrinting | (Ereditato da GridControl)
Metodo protetto | Dispose | (Ereditato da GridControl)
Metodo protetto | DoDpiChange | (Ereditato da EditorContainer)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da GridControl)
Metodo pubblico | EndInit | (Ereditato da EditorContainer)
Metodo pubblico | EndUpdate | (Ereditato da GridControl)
Metodo protetto | EndUpdate(Boolean) | (Ereditato da GridControl)
Metodo protetto | EnforceValidDataMember | (Ereditato da GridControl)
Metodo pubblico | ExportToCsv(Stream) | (Ereditato da GridControl)
Metodo pubblico | ExportToCsv(String) | (Ereditato da GridControl)
Metodo pubblico | ExportToCsv(Stream, CsvExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToCsv(String, CsvExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToDocx(Stream) | (Ereditato da GridControl)
Metodo pubblico | ExportToDocx(String) | (Ereditato da GridControl)
Metodo pubblico | ExportToDocx(Stream, DocxExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToDocx(String, DocxExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToExcelOld | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToHtml(Stream) | (Ereditato da GridControl)
Metodo pubblico | ExportToHtml(String) | (Ereditato da GridControl)
Metodo pubblico | ExportToHtml(Stream, HtmlExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToHtml(String, HtmlExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToHtml(String, String) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToHtml(Stream, String, String, Boolean) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToHtml(String, String, String, Boolean) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToHtmlOld | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToMht(String) | (Ereditato da GridControl)
Metodo pubblico | ExportToMht(Stream, MhtExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToMht(String, MhtExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToMht(String, String) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToMht(Stream, String, String, Boolean) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToMht(String, String, String, Boolean) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToPdf(Stream) | (Ereditato da GridControl)
Metodo pubblico | ExportToPdf(String) | (Ereditato da GridControl)
Metodo pubblico | ExportToRtf(Stream) | (Ereditato da GridControl)
Metodo pubblico | ExportToRtf(String) | (Ereditato da GridControl)
Metodo pubblico | ExportToRtf(Stream, RtfExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToRtf(String, RtfExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToText(Stream) | (Ereditato da GridControl)
Metodo pubblico | ExportToText(String) | (Ereditato da GridControl)
Metodo pubblico | ExportToText(Stream, TextExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToText(Stream, String) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToText(String, TextExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToText(String, String) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToText(Stream, String, Boolean) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToText(String, String, Boolean) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToText(Stream, String, Boolean, Encoding) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToText(String, String, Boolean, Encoding) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToTextOld | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToXls(Stream) | (Ereditato da GridControl)
Metodo pubblico | ExportToXls(String) | (Ereditato da GridControl)
Metodo pubblico | ExportToXls(Stream, XlsExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToXls(Stream, Boolean) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToXls(String, XlsExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToXls(String, Boolean) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToXlsx(Stream) | (Ereditato da GridControl)
Metodo pubblico | ExportToXlsx(String) | (Ereditato da GridControl)
Metodo pubblico | ExportToXlsx(Stream, XlsxExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToXlsx(String, XlsxExportOptions) | (Ereditato da GridControl)
Metodo pubblico | FireChanged | (Ereditato da GridControl)
Metodo protetto | FireChanged(Object) | (Ereditato da GridControl)
Metodo protetto | FocusViewByMouse | (Ereditato da GridControl)
Metodo pubblico | ForceInitialize | (Ereditato da GridControl)
Metodo protetto | ForceViewInitialize | (Ereditato da GridControl)
Metodo protetto | GetAccessibilityObjectById | (Ereditato da GridControl)
Metodo protetto | GetComponentSelected | (Ereditato da GridControl)
Metodo protetto | GetDirectXDeviceBackColor | (Ereditato da GridControl)
Metodo protetto | GetDirectXProvider | (Ereditato da EditorContainer)
Metodo protetto | GetMouseViews | (Ereditato da GridControl)
Metodo protetto | GetSelectedObjects | (Ereditato da GridControl)
Metodo protetto | GetSelectionService | (Ereditato da GridControl)
Metodo pubblico | GetToolTipController | (Ereditato da EditorContainer)
Metodo protetto | GetUseDirectXPaint | (Ereditato da GridControl)
Metodo pubblico | GetViewAt | (Ereditato da GridControl)
Metodo protetto | HookOnLoaded | (Ereditato da EditorContainer)
Metodo protetto | InitializeDirectXProvider | (Ereditato da EditorContainer)
Metodo pubblico | InternalGetService | (Ereditato da GridControl)
Metodo protetto | IsControlPressed | (Ereditato da GridControl)
Metodo protetto | IsInputChar | (Ereditato da GridControl)
Metodo protetto | IsInputKey | (Ereditato da GridControl)
Metodo protetto | IsNeededKey | (Ereditato da GridControl)
Metodo protetto | IsPaintAnimateItems | (Ereditato da GridControl)
Metodo protetto | IsShiftPressed | (Ereditato da GridControl)
Metodo protetto | IsTabPressed | (Ereditato da GridControl)
Metodo protetto | IsValidDataSource | (Ereditato da GridControl)
Metodo pubblico | IsVisibleView | (Ereditato da GridControl)
Metodo pubblico | LockFireChanged | (Ereditato da GridControl)
Metodo protetto | NormalView | (Ereditato da GridControl)
Metodo protetto | OnBackgroundImageChanged | (Ereditato da GridControl)
Metodo protetto | OnBackgroundImageLayoutChanged | (Ereditato da GridControl)
Metodo protetto | OnBindingContextChanged | (Ereditato da GridControl)
Metodo protetto | OnClick | (Ereditato da GridControl)
Metodo protetto | OnContainerEnter | (Ereditato da GridControl)
Metodo protetto | OnContainerLeave | (Ereditato da GridControl)
Metodo protetto | OnContextMenuKey | (Ereditato da GridControl)
Metodo protetto | OnCreateControl | (Ereditato da GridControl)
Metodo protetto | OnCursorChanged | (Ereditato da GridControl)
Metodo protetto | OnDataSourceChanging | (Ereditato da GridControl)
Metodo protetto | OnDesignerHost_LoadComplete | (Ereditato da EditorContainer)
Metodo protetto | OnDesignerHost_TransactionClosed | (Ereditato da EditorContainer)
Metodo protetto | OnDirectXPaintDisabled | (Ereditato da EditorContainer)
Metodo protetto | OnDoubleClick | (Ereditato da GridControl)
Metodo protetto | OnDragDrop | (Ereditato da GridControl)
Metodo protetto | OnDragOver | (Ereditato da GridControl)
Metodo protetto | OnEmbeddedNavigator_SizeChanged | (Ereditato da GridControl)
Metodo protetto | OnEnabledChanged | (Ereditato da GridControl)
Metodo protetto | OnEndInit | (Ereditato da GridControl)
Metodo protetto | OnEnter | (Ereditato da GridControl)
Metodo protetto | OnFirstInit | (Ereditato da EditorContainer)
Metodo protetto | OnGotCapture | (Ereditato da EditorContainer)
Metodo protetto | OnGotFocus | (Ereditato da GridControl)
Metodo protetto | OnHandleCreated(EventArgs) | (Sovrascrive ControlOnHandleCreated(EventArgs))
Metodo protetto | OnHandleCreated(EventArgs) | (Ereditato da GridControl)
Metodo protetto | OnHandleDestroyed(EventArgs) | (Sovrascrive ControlOnHandleDestroyed(EventArgs))
Metodo protetto | OnHandleDestroyed(EventArgs) | (Ereditato da GridControl)
Metodo protetto | OnKeyDown | (Ereditato da GridControl)
Metodo protetto | OnKeyPress | (Ereditato da GridControl)
Metodo protetto | OnKeyUp | (Ereditato da GridControl)
Metodo protetto | OnLeave | (Ereditato da EditorContainer)
Metodo protetto | OnLoaded | (Ereditato da GridControl)
Metodo protetto | OnLookAndFeelChanged(LookAndFeelChangedEventArgs) | (Ereditato da GridControl)
Metodo protetto | OnLookAndFeelChanged(Object, EventArgs) | (Ereditato da EditorContainer)
Metodo protetto | OnLostCapture | (Ereditato da GridControl)
Metodo protetto | OnLostFocus | (Ereditato da GridControl)
Metodo protetto | OnMouseCaptureChanged | (Ereditato da GridControl)
Metodo protetto | OnMouseClick | (Ereditato da EditorContainer)
Metodo protetto | OnMouseDoubleClick | (Ereditato da EditorContainer)
Metodo protetto | OnMouseDown | (Sovrascrive GridControl.OnMouseDown(MouseEventArgs))
Metodo protetto | OnMouseEnter | (Ereditato da GridControl)
Metodo protetto | OnMouseHWheel | (Ereditato da EditorContainer)
Metodo protetto | OnMouseLeave | (Ereditato da GridControl)
Metodo protetto | OnMouseMove | (Ereditato da GridControl)
Metodo protetto | OnMouseUp | (Ereditato da GridControl)
Metodo protetto | OnMouseWheel | (Ereditato da EditorContainer)
Metodo protetto | OnMouseWheelCore | (Ereditato da GridControl)
Metodo protetto | OnPaint | (Ereditato da GridControl)
Metodo protetto | OnPaintBackground | (Ereditato da GridControl)
Metodo protetto | OnParentChanged | (Ereditato da GridControl)
Metodo protetto | OnResize | (Ereditato da GridControl)
Metodo protetto | OnRightToLeftChanged | (Ereditato da GridControl)
Metodo protetto | OnRightToLeftChanged(EventArgs) | (Ereditato da EditorContainer)
Metodo protetto | OnScaleControl | (Ereditato da GridControl)
Metodo protetto | OnSystemColorsChanged | (Ereditato da GridControl)
Metodo protetto | OnSystemColorsChanged(EventArgs) | (Ereditato da GridControl)
Metodo protetto | OnToolTipControllerDisposed | (Ereditato da EditorContainer)
Metodo protetto | OnValidated | (Ereditato da EditorContainer)
Metodo protetto | OnValidating | (Ereditato da GridControl)
Metodo protetto | OnVisibleChanged | (Ereditato da GridControl)
Metodo pubblico | Print | (Ereditato da GridControl)
Metodo pubblico | PrintDialog | (Ereditato da GridControl)
Metodo protetto | ProcessControlTab | (Ereditato da GridControl)
Metodo protetto | ProcessDialogKey | (Ereditato da GridControl)
Metodo protetto | ProcessDirectXPaint | (Ereditato da GridControl)
Metodo protetto | ProcessGridKeys | (Ereditato da GridControl)
Metodo protetto | RaiseDataSourceChanged | (Ereditato da GridControl)
Metodo protetto | RaiseEditorKeyDown | (Ereditato da GridControl)
Metodo protetto | RaiseEditorKeyPress | (Ereditato da EditorContainer)
Metodo protetto | RaiseEditorKeyUp | (Ereditato da EditorContainer)
Metodo protetto | RaiseLoad | (Ereditato da GridControl)
Metodo protetto | RaiseOnDefaultViewChanged | (Ereditato da GridControl)
Metodo protetto | RaiseOnFocusedViewChanged | (Ereditato da GridControl)
Metodo protetto | RaiseOnRegisterView | (Ereditato da GridControl)
Metodo protetto | RaiseOnRemoveView | (Ereditato da GridControl)
Metodo protetto | RaisePaintEx | (Ereditato da GridControl)
Metodo protetto | RaiseRequireHideEditor | (Ereditato da EditorContainer)
Metodo protetto | RaiseViewGridLoadComplete | (Ereditato da GridControl)
Metodo pubblico | RefreshDataSource | (Ereditato da GridControl)
Metodo protetto | RegisterAvailableViews | (Ereditato da GridControl)
Metodo protetto | RegisterAvailableViewsCore | (Ereditato da GridControl)
Metodo protetto | RegisterBorders | (Ereditato da GridControl)
Metodo protetto | RegisterView | (Ereditato da GridControl)
Metodo protetto | RemoveFromDefaultTooltipController | (Ereditato da EditorContainer)
Metodo protetto | RemoveHookOnLoaded | (Ereditato da EditorContainer)
Metodo pubblico | RemoveSplitContainer | (Ereditato da GridControl)
Metodo protetto | RemoveView(BaseView) | (Ereditato da GridControl)
Metodo protetto | RemoveView(BaseView, Boolean) | (Ereditato da GridControl)
Metodo pubblico | RenderToBitmap | (Ereditato da GridControl)
Metodo pubblico | ResetEditorsCache(RepositoryItem) | (Ereditato da EditorContainer)
Metodo pubblico | ResetEditorsCache(Type) | (Ereditato da EditorContainer)
Metodo protetto | ResetLookAndFeel | (Ereditato da EditorContainer)
Metodo protetto | ScaleControl | (Ereditato da EditorContainer)
Metodo protetto | SetComponentsSelected | (Ereditato da GridControl)
Metodo protetto | SetDataSourceCore | (Ereditato da GridControl)
Metodo protetto | SetDefaultView | (Ereditato da GridControl)
Metodo protetto | SetupLookUp | (Ereditato da GridControl)
Metodo protetto | SetUseDirectXPaint | (Ereditato da GridControl)
Metodo protetto | ShouldSerializeLookAndFeel | (Ereditato da EditorContainer)
Metodo pubblico | ShowPreview | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ShowPrintPreview | (Ereditato da GridControl)
Metodo pubblico | ShowRibbonPrintPreview | (Ereditato da GridControl)
Metodo protetto | StopScroller | (Ereditato da GridControl)
Metodo pubblico | SwitchPaintStyle | (Ereditato da GridControl)
Metodo pubblico | UnlockFireChanged | (Ereditato da GridControl)
Metodo protetto | UpdateNavigator | (Ereditato da GridControl)
Metodo protetto | UpdateRepositoryOwner | (Ereditato da GridControl)
Metodo protetto | UpdateViewCollection | (Ereditato da GridControl)
Metodo protetto | UpdateViewStyles | (Ereditato da GridControl)
Metodo protetto | ViewByPoint | (Ereditato da GridControl)
Metodo protetto | WndProc | (Ereditato da GridControl)
Metodo protetto | ZoomView | (Ereditato da GridControl)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | DataSourceChanged | (Ereditato da GridControl)
Evento pubblico | DefaultViewChanged | (Ereditato da GridControl)
Evento pubblico | EditorKeyDown | (Ereditato da EditorContainer)
Evento pubblico | EditorKeyPress | (Ereditato da EditorContainer)
Evento pubblico | EditorKeyUp | (Ereditato da EditorContainer)
Evento pubblico | FocusedViewChanged | (Ereditato da GridControl)
Evento pubblico | KeyboardFocusViewChanged | Obsoleto. (Ereditato da GridControl)
Evento pubblico | Load | (Ereditato da GridControl)
Evento pubblico | Paint | (Ereditato da GridControl)
Evento pubblico | PaintEx | (Ereditato da GridControl)
Evento pubblico | ProcessGridKey | (Ereditato da GridControl)
Evento pubblico | ViewRegistered | (Ereditato da GridControl)
Evento pubblico | ViewRemoved | (Ereditato da GridControl)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | fInitializing | (Ereditato da EditorContainer)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore DedGridControl

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedGridControl()
Public Sub New
public:
DedGridControl()
new : unit -> DedGridControl
Vedi anche

Documentazione

Classe DedGridControl
Namespace DedNet.Controls


Proprietà di DedGridControl

Il tipo DedGridControl espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà protetta | AllowLayoutEvent | (Ereditato da GridControl)
Proprietà pubblica | AllowRestoreSelectionAndFocusedRow | (Ereditato da GridControl)
Proprietà protetta | AllowScaleOnLoad | (Ereditato da EditorContainer)
Proprietà pubblica | AllowTouchGestures | (Ereditato da EditorContainer)
Proprietà pubblica | AvailableViews | (Ereditato da GridControl)
Proprietà pubblica | BackColor | (Ereditato da GridControl)
Proprietà pubblica | BindingContext | (Ereditato da GridControl)
Proprietà pubblica | ContextMenuStrip | (Ereditato da GridControl)
Proprietà pubblica | Controls | (Ereditato da GridControl)
Proprietà pubblica | Cursor | (Ereditato da GridControl)
Proprietà pubblica | DataMember | (Ereditato da GridControl)
Proprietà pubblica | DataSource | (Ereditato da GridControl)
Proprietà protetta | DefaultSize | (Ereditato da GridControl)
Proprietà pubblica | DefaultView | (Ereditato da GridControl)
Proprietà protetta | DirectXProvider | (Ereditato da GridControl)
Proprietà protetta | DirectXScroller | (Ereditato da GridControl)
Proprietà pubblica | Dock | (Ereditato da GridControl)
Proprietà protetta | DragController | (Ereditato da GridControl)
Proprietà protetta | EditorHelper | (Ereditato da GridControl)
Proprietà pubblica | EmbeddedNavigator | (Ereditato da GridControl)
Proprietà pubblica | EnableAutomaticRowHeightForFocusedCell |
Proprietà pubblica | EnableCopyWithDragDrop | Indica se trascinando la cella il valore al suo interno deve essere copiato anche nelle altre celle (come in Excel).
Proprietà protetta | EnableFirstPaintTrigger | (Ereditato da GridControl)
Proprietà protetta | ExceptionThrown | (Ereditato da GridControl)
Proprietà pubblica | ExternalRepository | (Ereditato da EditorContainer)
Proprietà protetta | FireOnLoadOnPaint | (Ereditato da GridControl)
Proprietà pubblica | FocusedView | (Ereditato da GridControl)
Proprietà pubblica | ForeColor | (Ereditato da EditorContainer)
Proprietà pubblica | FormsUseDefaultLookAndFeel | (Ereditato da GridControl)
Proprietà pubblica | GridDisposing | (Ereditato da GridControl)
Proprietà pubblica | IsAttachedToSearchControl | (Ereditato da GridControl)
Proprietà pubblica | IsDesignMode | (Ereditato da EditorContainer)
Proprietà pubblica | IsFocused | (Ereditato da GridControl)
Proprietà protetta | IsInitialized | (Ereditato da EditorContainer)
Proprietà protetta | IsInPrintMessage | (Ereditato da GridControl)
Proprietà pubblica | IsLoaded | (Ereditato da GridControl)
Proprietà pubblica | IsLoading | (Ereditato da EditorContainer)
Proprietà protetta | IsLockUpdate | (Ereditato da GridControl)
Proprietà protetta | IsPrinterExist | (Ereditato da GridControl)
Proprietà pubblica | IsPrinting | (Ereditato da GridControl)
Proprietà pubblica | IsPrintingAvailable | (Ereditato da GridControl)
Proprietà protetta | IsPrintWrapperValid | (Ereditato da GridControl)
Proprietà protetta | IsRightToLeft | (Ereditato da GridControl)
Proprietà pubblica | IsSplitGrid | (Ereditato da GridControl)
Proprietà pubblica | KeyboardFocusView | Obsoleto. (Ereditato da GridControl)
Proprietà pubblica | LevelTree | (Ereditato da GridControl)
Proprietà pubblica | LookAndFeel | (Ereditato da EditorContainer)
Proprietà protetta | LookAndFeelIgnoreChildren | (Ereditato da EditorContainer)
Proprietà protetta | LookUpOwner | (Ereditato da GridControl)
Proprietà pubblica | MainView | (Ereditato da GridControl)
Proprietà pubblica | MenuManager | (Ereditato da EditorContainer)
Proprietà protetta | MouseCaptureOwner | (Ereditato da GridControl)
Proprietà protetta | NavigatableHelper | (Ereditato da GridControl)
Proprietà protetta | NavView | (Ereditato da GridControl)
Proprietà protetta | Printer | (Ereditato da GridControl)
Proprietà protetta | PrintWrapper | (Ereditato da GridControl)
Proprietà pubblica | RepositoryItems | (Ereditato da EditorContainer)
Proprietà protetta | ScaleDPI | (Ereditato da EditorContainer)
Proprietà pubblica | ScaleFactor | (Ereditato da EditorContainer)
Proprietà protetta | ScaleHelper | (Ereditato da EditorContainer)
Proprietà protetta | Scroller | (Ereditato da GridControl)
Proprietà pubblica | ServerMode | Obsoleto. (Ereditato da GridControl)
Proprietà pubblica | ShowOnlyPredefinedDetails | (Ereditato da GridControl)
Proprietà protetta | SplitContainer | (Ereditato da GridControl)
Proprietà pubblica | Text | (Ereditato da EditorContainer)
Proprietà pubblica | ToolTipController | (Ereditato da EditorContainer)
Proprietà protetta | TouchClient | (Ereditato da GridControl)
Proprietà pubblica | UseDirectXPaint | (Ereditato da GridControl)
Proprietà protetta | UseDirectXPaintCore | (Ereditato da GridControl)
Proprietà pubblica | UseDisabledStatePainter | (Ereditato da GridControl)
Proprietà pubblica | UseEmbeddedNavigator | (Ereditato da GridControl)
Proprietà pubblica | UseReadonlyAppearanceForColumns | Indica se le colonne ReadOnly devono utilizzare il colore di sfondo dedicato.
Proprietà pubblica | ViewCollection | (Ereditato da GridControl)
Proprietà protetta | ViewRepository | (Ereditato da GridControl)
Proprietà pubblica | Views | (Ereditato da GridControl)
Torna su
Vedi anche

Documentazione

Classe DedGridControl
Namespace DedNet.Controls


Proprietà DedGridControl.EnableAutomaticRowHeightForFocusedCell

Proprietà DedGridControlEnableAutomaticRowHeightForFocusedCell

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool EnableAutomaticRowHeightForFocusedCell { get; set; }
Public Property EnableAutomaticRowHeightForFocusedCell As Boolean
    Get
    Set
public:
property bool EnableAutomaticRowHeightForFocusedCell {
    bool get ();
    void set (bool value);
}
member EnableAutomaticRowHeightForFocusedCell : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedGridControl
Namespace DedNet.Controls


Proprietà DedGridControl.EnableCopyWithDragDrop

Proprietà DedGridControlEnableCopyWithDragDrop
Indica se trascinando la cella il valore al suo interno deve essere copiato anche nelle altre celle (come in Excel).

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool EnableCopyWithDragDrop { get; set; }
Public Property EnableCopyWithDragDrop As Boolean
    Get
    Set
public:
property bool EnableCopyWithDragDrop {
    bool get ();
    void set (bool value);
}
member EnableCopyWithDragDrop : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedGridControl
Namespace DedNet.Controls


Proprietà DedGridControl.UseReadonlyAppearanceForColumns

Proprietà DedGridControlUseReadonlyAppearanceForColumns
Indica se le colonne ReadOnly devono utilizzare il colore di sfondo dedicato.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool UseReadonlyAppearanceForColumns { get; set; }
Public Property UseReadonlyAppearanceForColumns As Boolean
    Get
    Set
public:
property bool UseReadonlyAppearanceForColumns {
    bool get ();
    void set (bool value);
}
member UseReadonlyAppearanceForColumns : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedGridControl
Namespace DedNet.Controls


Metodi di DedGridControl

Il tipo DedGridControl espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AccessibleNotifyClients(AccessibleEvents, BaseAccessible) | (Ereditato da GridControl)
Metodo pubblico | AccessibleNotifyClients(AccessibleEvents, Int32) | (Ereditato da GridControl)
Metodo protetto | ActivateDataSource | (Ereditato da GridControl)
Metodo protetto | AddToDefaultTooltipController | (Ereditato da EditorContainer)
Metodo pubblico | BeginInit | (Ereditato da GridControl)
Metodo pubblico | BeginUpdate | (Ereditato da GridControl)
Metodo protetto | CancelUpdate | (Ereditato da GridControl)
Metodo protetto | CanHandleTouchGestures | (Ereditato da EditorContainer)
Metodo protetto | CheckMousePos | (Ereditato da GridControl)
Metodo protetto | CheckNeedScale | (Ereditato da EditorContainer)
Metodo protetto | CheckPrintWrapper | (Ereditato da GridControl)
Metodo protetto | CheckProcessMsg | (Ereditato da GridControl)
Metodo protetto | CheckRightToLeft | (Ereditato da EditorContainer)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da GridControl)
Metodo protetto | CreateComponentPrinter | (Ereditato da GridControl)
Metodo protetto | CreateDefaultView | (Ereditato da GridControl)
Metodo protetto | CreateEmbeddedNavigator | (Ereditato da GridControl)
Metodo pubblico | CreateGraphicsCache | (Ereditato da GridControl)
Metodo protetto | CreateHelper | (Ereditato da GridControl)
Metodo protetto | CreateInternalRepository | (Ereditato da EditorContainer)
Metodo protetto | CreateLookAndFeel | (Ereditato da EditorContainer)
Metodo protetto | CreateMainView | (Ereditato da GridControl)
Metodo pubblico | CreateSplitContainer | (Ereditato da GridControl)
Metodo pubblico | CreateView | (Ereditato da GridControl)
Metodo protetto | CreateViewPrintWrapper | (Ereditato da GridControl)
Metodo protetto | DestroyAvailableViews | (Ereditato da GridControl)
Metodo protetto | DestroyDirectXProvider | (Ereditato da EditorContainer)
Metodo protetto | DestroyPrinting | (Ereditato da GridControl)
Metodo protetto | Dispose | (Ereditato da GridControl)
Metodo protetto | DoDpiChange | (Ereditato da EditorContainer)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da GridControl)
Metodo pubblico | EndInit | (Ereditato da EditorContainer)
Metodo pubblico | EndUpdate | (Ereditato da GridControl)
Metodo protetto | EndUpdate(Boolean) | (Ereditato da GridControl)
Metodo protetto | EnforceValidDataMember | (Ereditato da GridControl)
Metodo pubblico | ExportToCsv(Stream) | (Ereditato da GridControl)
Metodo pubblico | ExportToCsv(String) | (Ereditato da GridControl)
Metodo pubblico | ExportToCsv(Stream, CsvExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToCsv(String, CsvExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToDocx(Stream) | (Ereditato da GridControl)
Metodo pubblico | ExportToDocx(String) | (Ereditato da GridControl)
Metodo pubblico | ExportToDocx(Stream, DocxExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToDocx(String, DocxExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToExcelOld | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToHtml(Stream) | (Ereditato da GridControl)
Metodo pubblico | ExportToHtml(String) | (Ereditato da GridControl)
Metodo pubblico | ExportToHtml(Stream, HtmlExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToHtml(String, HtmlExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToHtml(String, String) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToHtml(Stream, String, String, Boolean) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToHtml(String, String, String, Boolean) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToHtmlOld | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToMht(String) | (Ereditato da GridControl)
Metodo pubblico | ExportToMht(Stream, MhtExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToMht(String, MhtExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToMht(String, String) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToMht(Stream, String, String, Boolean) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToMht(String, String, String, Boolean) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToPdf(Stream) | (Ereditato da GridControl)
Metodo pubblico | ExportToPdf(String) | (Ereditato da GridControl)
Metodo pubblico | ExportToRtf(Stream) | (Ereditato da GridControl)
Metodo pubblico | ExportToRtf(String) | (Ereditato da GridControl)
Metodo pubblico | ExportToRtf(Stream, RtfExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToRtf(String, RtfExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToText(Stream) | (Ereditato da GridControl)
Metodo pubblico | ExportToText(String) | (Ereditato da GridControl)
Metodo pubblico | ExportToText(Stream, TextExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToText(Stream, String) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToText(String, TextExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToText(String, String) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToText(Stream, String, Boolean) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToText(String, String, Boolean) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToText(Stream, String, Boolean, Encoding) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToText(String, String, Boolean, Encoding) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToTextOld | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToXls(Stream) | (Ereditato da GridControl)
Metodo pubblico | ExportToXls(String) | (Ereditato da GridControl)
Metodo pubblico | ExportToXls(Stream, XlsExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToXls(Stream, Boolean) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToXls(String, XlsExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToXls(String, Boolean) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToXlsx(Stream) | (Ereditato da GridControl)
Metodo pubblico | ExportToXlsx(String) | (Ereditato da GridControl)
Metodo pubblico | ExportToXlsx(Stream, XlsxExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToXlsx(String, XlsxExportOptions) | (Ereditato da GridControl)
Metodo pubblico | FireChanged | (Ereditato da GridControl)
Metodo protetto | FireChanged(Object) | (Ereditato da GridControl)
Metodo protetto | FocusViewByMouse | (Ereditato da GridControl)
Metodo pubblico | ForceInitialize | (Ereditato da GridControl)
Metodo protetto | ForceViewInitialize | (Ereditato da GridControl)
Metodo protetto | GetAccessibilityObjectById | (Ereditato da GridControl)
Metodo protetto | GetComponentSelected | (Ereditato da GridControl)
Metodo protetto | GetDirectXDeviceBackColor | (Ereditato da GridControl)
Metodo protetto | GetDirectXProvider | (Ereditato da EditorContainer)
Metodo protetto | GetMouseViews | (Ereditato da GridControl)
Metodo protetto | GetSelectedObjects | (Ereditato da GridControl)
Metodo protetto | GetSelectionService | (Ereditato da GridControl)
Metodo pubblico | GetToolTipController | (Ereditato da EditorContainer)
Metodo protetto | GetUseDirectXPaint | (Ereditato da GridControl)
Metodo pubblico | GetViewAt | (Ereditato da GridControl)
Metodo protetto | HookOnLoaded | (Ereditato da EditorContainer)
Metodo protetto | InitializeDirectXProvider | (Ereditato da EditorContainer)
Metodo pubblico | InternalGetService | (Ereditato da GridControl)
Metodo protetto | IsControlPressed | (Ereditato da GridControl)
Metodo protetto | IsInputChar | (Ereditato da GridControl)
Metodo protetto | IsInputKey | (Ereditato da GridControl)
Metodo protetto | IsNeededKey | (Ereditato da GridControl)
Metodo protetto | IsPaintAnimateItems | (Ereditato da GridControl)
Metodo protetto | IsShiftPressed | (Ereditato da GridControl)
Metodo protetto | IsTabPressed | (Ereditato da GridControl)
Metodo protetto | IsValidDataSource | (Ereditato da GridControl)
Metodo pubblico | IsVisibleView | (Ereditato da GridControl)
Metodo pubblico | LockFireChanged | (Ereditato da GridControl)
Metodo protetto | NormalView | (Ereditato da GridControl)
Metodo protetto | OnBackgroundImageChanged | (Ereditato da GridControl)
Metodo protetto | OnBackgroundImageLayoutChanged | (Ereditato da GridControl)
Metodo protetto | OnBindingContextChanged | (Ereditato da GridControl)
Metodo protetto | OnClick | (Ereditato da GridControl)
Metodo protetto | OnContainerEnter | (Ereditato da GridControl)
Metodo protetto | OnContainerLeave | (Ereditato da GridControl)
Metodo protetto | OnContextMenuKey | (Ereditato da GridControl)
Metodo protetto | OnCreateControl | (Ereditato da GridControl)
Metodo protetto | OnCursorChanged | (Ereditato da GridControl)
Metodo protetto | OnDataSourceChanging | (Ereditato da GridControl)
Metodo protetto | OnDesignerHost_LoadComplete | (Ereditato da EditorContainer)
Metodo protetto | OnDesignerHost_TransactionClosed | (Ereditato da EditorContainer)
Metodo protetto | OnDirectXPaintDisabled | (Ereditato da EditorContainer)
Metodo protetto | OnDoubleClick | (Ereditato da GridControl)
Metodo protetto | OnDragDrop | (Ereditato da GridControl)
Metodo protetto | OnDragOver | (Ereditato da GridControl)
Metodo protetto | OnEmbeddedNavigator_SizeChanged | (Ereditato da GridControl)
Metodo protetto | OnEnabledChanged | (Ereditato da GridControl)
Metodo protetto | OnEndInit | (Ereditato da GridControl)
Metodo protetto | OnEnter | (Ereditato da GridControl)
Metodo protetto | OnFirstInit | (Ereditato da EditorContainer)
Metodo protetto | OnGotCapture | (Ereditato da EditorContainer)
Metodo protetto | OnGotFocus | (Ereditato da GridControl)
Metodo protetto | OnHandleCreated(EventArgs) | (Sovrascrive ControlOnHandleCreated(EventArgs))
Metodo protetto | OnHandleCreated(EventArgs) | (Ereditato da GridControl)
Metodo protetto | OnHandleDestroyed(EventArgs) | (Sovrascrive ControlOnHandleDestroyed(EventArgs))
Metodo protetto | OnHandleDestroyed(EventArgs) | (Ereditato da GridControl)
Metodo protetto | OnKeyDown | (Ereditato da GridControl)
Metodo protetto | OnKeyPress | (Ereditato da GridControl)
Metodo protetto | OnKeyUp | (Ereditato da GridControl)
Metodo protetto | OnLeave | (Ereditato da EditorContainer)
Metodo protetto | OnLoaded | (Ereditato da GridControl)
Metodo protetto | OnLookAndFeelChanged(LookAndFeelChangedEventArgs) | (Ereditato da GridControl)
Metodo protetto | OnLookAndFeelChanged(Object, EventArgs) | (Ereditato da EditorContainer)
Metodo protetto | OnLostCapture | (Ereditato da GridControl)
Metodo protetto | OnLostFocus | (Ereditato da GridControl)
Metodo protetto | OnMouseCaptureChanged | (Ereditato da GridControl)
Metodo protetto | OnMouseClick | (Ereditato da EditorContainer)
Metodo protetto | OnMouseDoubleClick | (Ereditato da EditorContainer)
Metodo protetto | OnMouseDown | (Sovrascrive GridControl.OnMouseDown(MouseEventArgs))
Metodo protetto | OnMouseEnter | (Ereditato da GridControl)
Metodo protetto | OnMouseHWheel | (Ereditato da EditorContainer)
Metodo protetto | OnMouseLeave | (Ereditato da GridControl)
Metodo protetto | OnMouseMove | (Ereditato da GridControl)
Metodo protetto | OnMouseUp | (Ereditato da GridControl)
Metodo protetto | OnMouseWheel | (Ereditato da EditorContainer)
Metodo protetto | OnMouseWheelCore | (Ereditato da GridControl)
Metodo protetto | OnPaint | (Ereditato da GridControl)
Metodo protetto | OnPaintBackground | (Ereditato da GridControl)
Metodo protetto | OnParentChanged | (Ereditato da GridControl)
Metodo protetto | OnResize | (Ereditato da GridControl)
Metodo protetto | OnRightToLeftChanged | (Ereditato da GridControl)
Metodo protetto | OnRightToLeftChanged(EventArgs) | (Ereditato da EditorContainer)
Metodo protetto | OnScaleControl | (Ereditato da GridControl)
Metodo protetto | OnSystemColorsChanged | (Ereditato da GridControl)
Metodo protetto | OnSystemColorsChanged(EventArgs) | (Ereditato da GridControl)
Metodo protetto | OnToolTipControllerDisposed | (Ereditato da EditorContainer)
Metodo protetto | OnValidated | (Ereditato da EditorContainer)
Metodo protetto | OnValidating | (Ereditato da GridControl)
Metodo protetto | OnVisibleChanged | (Ereditato da GridControl)
Metodo pubblico | Print | (Ereditato da GridControl)
Metodo pubblico | PrintDialog | (Ereditato da GridControl)
Metodo protetto | ProcessControlTab | (Ereditato da GridControl)
Metodo protetto | ProcessDialogKey | (Ereditato da GridControl)
Metodo protetto | ProcessDirectXPaint | (Ereditato da GridControl)
Metodo protetto | ProcessGridKeys | (Ereditato da GridControl)
Metodo protetto | RaiseDataSourceChanged | (Ereditato da GridControl)
Metodo protetto | RaiseEditorKeyDown | (Ereditato da GridControl)
Metodo protetto | RaiseEditorKeyPress | (Ereditato da EditorContainer)
Metodo protetto | RaiseEditorKeyUp | (Ereditato da EditorContainer)
Metodo protetto | RaiseLoad | (Ereditato da GridControl)
Metodo protetto | RaiseOnDefaultViewChanged | (Ereditato da GridControl)
Metodo protetto | RaiseOnFocusedViewChanged | (Ereditato da GridControl)
Metodo protetto | RaiseOnRegisterView | (Ereditato da GridControl)
Metodo protetto | RaiseOnRemoveView | (Ereditato da GridControl)
Metodo protetto | RaisePaintEx | (Ereditato da GridControl)
Metodo protetto | RaiseRequireHideEditor | (Ereditato da EditorContainer)
Metodo protetto | RaiseViewGridLoadComplete | (Ereditato da GridControl)
Metodo pubblico | RefreshDataSource | (Ereditato da GridControl)
Metodo protetto | RegisterAvailableViews | (Ereditato da GridControl)
Metodo protetto | RegisterAvailableViewsCore | (Ereditato da GridControl)
Metodo protetto | RegisterBorders | (Ereditato da GridControl)
Metodo protetto | RegisterView | (Ereditato da GridControl)
Metodo protetto | RemoveFromDefaultTooltipController | (Ereditato da EditorContainer)
Metodo protetto | RemoveHookOnLoaded | (Ereditato da EditorContainer)
Metodo pubblico | RemoveSplitContainer | (Ereditato da GridControl)
Metodo protetto | RemoveView(BaseView) | (Ereditato da GridControl)
Metodo protetto | RemoveView(BaseView, Boolean) | (Ereditato da GridControl)
Metodo pubblico | RenderToBitmap | (Ereditato da GridControl)
Metodo pubblico | ResetEditorsCache(RepositoryItem) | (Ereditato da EditorContainer)
Metodo pubblico | ResetEditorsCache(Type) | (Ereditato da EditorContainer)
Metodo protetto | ResetLookAndFeel | (Ereditato da EditorContainer)
Metodo protetto | ScaleControl | (Ereditato da EditorContainer)
Metodo protetto | SetComponentsSelected | (Ereditato da GridControl)
Metodo protetto | SetDataSourceCore | (Ereditato da GridControl)
Metodo protetto | SetDefaultView | (Ereditato da GridControl)
Metodo protetto | SetupLookUp | (Ereditato da GridControl)
Metodo protetto | SetUseDirectXPaint | (Ereditato da GridControl)
Metodo protetto | ShouldSerializeLookAndFeel | (Ereditato da EditorContainer)
Metodo pubblico | ShowPreview | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ShowPrintPreview | (Ereditato da GridControl)
Metodo pubblico | ShowRibbonPrintPreview | (Ereditato da GridControl)
Metodo protetto | StopScroller | (Ereditato da GridControl)
Metodo pubblico | SwitchPaintStyle | (Ereditato da GridControl)
Metodo pubblico | UnlockFireChanged | (Ereditato da GridControl)
Metodo protetto | UpdateNavigator | (Ereditato da GridControl)
Metodo protetto | UpdateRepositoryOwner | (Ereditato da GridControl)
Metodo protetto | UpdateViewCollection | (Ereditato da GridControl)
Metodo protetto | UpdateViewStyles | (Ereditato da GridControl)
Metodo protetto | ViewByPoint | (Ereditato da GridControl)
Metodo protetto | WndProc | (Ereditato da GridControl)
Metodo protetto | ZoomView | (Ereditato da GridControl)
Torna su
Vedi anche

Documentazione

Classe DedGridControl
Namespace DedNet.Controls


Metodo DedGridControl.OnHandleCreated

Metodo DedGridControlOnHandleCreated
Lista degli overload
 | Nome | Descrizione
Metodo protetto | OnHandleCreated(EventArgs) |
Metodo protetto | OnHandleCreated(EventArgs) |
Torna su
Vedi anche

Documentazione

Classe DedGridControl
Namespace DedNet.Controls


Metodo DedGridControl.OnHandleCreated(EventArgs)

Metodo DedGridControlOnHandleCreated(EventArgs)

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void OnHandleCreated(
    EventArgs e
)
Protected Overrides Sub OnHandleCreated (
    e As EventArgs
)
protected:
virtual void OnHandleCreated(
    EventArgs^ e
) override
abstract OnHandleCreated :
        e : EventArgs -> unit
override OnHandleCreated :
        e : EventArgs -> unit

Parametri

e EventArgs
Vedi anche

Documentazione

Classe DedGridControl
Overload di OnHandleCreated
Namespace DedNet.Controls


Metodo DedGridControl.OnHandleDestroyed

Metodo DedGridControlOnHandleDestroyed
Lista degli overload
 | Nome | Descrizione
Metodo protetto | OnHandleDestroyed(EventArgs) |
Metodo protetto | OnHandleDestroyed(EventArgs) |
Torna su
Vedi anche

Documentazione

Classe DedGridControl
Namespace DedNet.Controls


Metodo DedGridControl.OnHandleDestroyed(EventArgs)

Metodo DedGridControlOnHandleDestroyed(EventArgs)

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void OnHandleDestroyed(
    EventArgs e
)
Protected Overrides Sub OnHandleDestroyed (
    e As EventArgs
)
protected:
virtual void OnHandleDestroyed(
    EventArgs^ e
) override
abstract OnHandleDestroyed :
        e : EventArgs -> unit
override OnHandleDestroyed :
        e : EventArgs -> unit

Parametri

e EventArgs
Vedi anche

Documentazione

Classe DedGridControl
Overload di OnHandleDestroyed
Namespace DedNet.Controls


Metodo DedGridControl.OnMouseDown

Metodo DedGridControlOnMouseDown

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void OnMouseDown(
    MouseEventArgs e
)
Protected Overrides Sub OnMouseDown (
    e As MouseEventArgs
)
protected:
virtual void OnMouseDown(
    MouseEventArgs^ e
) override
abstract OnMouseDown :
        e : MouseEventArgs -> unit
override OnMouseDown :
        e : MouseEventArgs -> unit

Parametri

e MouseEventArgs
Vedi anche

Documentazione

Classe DedGridControl
Namespace DedNet.Controls


Eventi di DedGridControl

Il tipo DedGridControl espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | DataSourceChanged | (Ereditato da GridControl)
Evento pubblico | DefaultViewChanged | (Ereditato da GridControl)
Evento pubblico | EditorKeyDown | (Ereditato da EditorContainer)
Evento pubblico | EditorKeyPress | (Ereditato da EditorContainer)
Evento pubblico | EditorKeyUp | (Ereditato da EditorContainer)
Evento pubblico | FocusedViewChanged | (Ereditato da GridControl)
Evento pubblico | KeyboardFocusViewChanged | Obsoleto. (Ereditato da GridControl)
Evento pubblico | Load | (Ereditato da GridControl)
Evento pubblico | Paint | (Ereditato da GridControl)
Evento pubblico | PaintEx | (Ereditato da GridControl)
Evento pubblico | ProcessGridKey | (Ereditato da GridControl)
Evento pubblico | ViewRegistered | (Ereditato da GridControl)
Evento pubblico | ViewRemoved | (Ereditato da GridControl)
Torna su
Vedi anche

Documentazione

Classe DedGridControl
Namespace DedNet.Controls


Campi di DedGridControl

Il tipo DedGridControl espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | fInitializing | (Ereditato da EditorContainer)
Torna su
Vedi anche

Documentazione

Classe DedGridControl
Namespace DedNet.Controls


Classe DedOkCancelControl
Classe che implementa il controllo di due bottoni ( ok , cancel )
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
XtraUserControl
DedNet.ControlsUserControlBase
DedNet.ControlsDedOkCancelControl

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedOkCancelControl : UserControlBase
Public Class DedOkCancelControl
    Inherits UserControlBase
public ref class DedOkCancelControl : public UserControlBase
type DedOkCancelControl =
    class
        inherit UserControlBase
    end

Il tipo DedOkCancelControl espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedOkCancelControl | Costruttore della classe
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Appearance | (Ereditato da XtraUserControl)
Proprietà pubblica | Application | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Proprietà pubblica | BackColor | (Ereditato da XtraUserControl)
Proprietà pubblica | CancelButton | Ritorna il bottone Cancel
Proprietà protetta | CheckDoubleScaling | (Ereditato da XtraUserControl)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraUserControl)
Proprietà protetta | DirectXContainer | (Ereditato da XtraUserControl)
Proprietà pubblica | EnableIXtraResizeableControlInterfaceProxy | (Ereditato da XtraUserControl)
Proprietà pubblica | Font | (Ereditato da XtraUserControl)
Proprietà pubblica | ForeColor | (Ereditato da XtraUserControl)
Proprietà protetta | Helper | (Ereditato da XtraUserControl)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraUserControl)
Proprietà pubblica | OkButton | Ritorna il bottone Ok
Proprietà protetta | Painter | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleChildren | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleDPI | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraUserControl)
Proprietà protetta | ShouldCheckDpiScaleFactorOnParentChanged | (Ereditato da XtraUserControl)
Proprietà pubblica | Site | (Ereditato da XtraUserControl)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | BaseWndProc | (Ereditato da XtraUserControl)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraUserControl)
Metodo protetto | CreatePainter | (Ereditato da XtraUserControl)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive UserControlBaseDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraUserControl)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraUserControl)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraUserControl)
Metodo protetto | GetBackColor | (Ereditato da XtraUserControl)
Metodo protetto | GetBackgroundSkinElement | (Ereditato da XtraUserControl)
Metodo protetto | GetInnerIXtraResizableControl | (Ereditato da XtraUserControl)
Metodo protetto | IsChildControlsRequiredScalingEnabled | (Ereditato da XtraUserControl)
Metodo protetto | IsParentHandleCreatedRecursive | (Ereditato da XtraUserControl)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraUserControl)
Metodo protetto | OnBackColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | onClickCancel |
Metodo protetto | onClickOk |
Metodo protetto | OnContextMenuOpening | Evento di apertura del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnControlAdded | (Ereditato da XtraUserControl)
Metodo protetto | OnControlRemoved | (Ereditato da XtraUserControl)
Metodo protetto | OnDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnFirstLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnForeColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleCreated | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraUserControl)
Metodo protetto | OnLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnMenuItemClicked | Evento di pressione di un comando del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnPaintCore | (Ereditato da XtraUserControl)
Metodo protetto | OnParentChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | OnSizeChanged | (Ereditato da XtraUserControl)
Metodo protetto | RaisePaintExEvent | (Ereditato da XtraUserControl)
Metodo pubblico | ResetBackColor | (Ereditato da XtraUserControl)
Metodo pubblico | ResetForeColor | (Ereditato da XtraUserControl)
Metodo protetto | RestoreAutoScaleModeChangedByPM2 | (Ereditato da XtraUserControl)
Metodo protetto | ScaleControl | (Ereditato da XtraUserControl)
Metodo pubblico | SetCommandList | Rigenera il menu contestuale di questo controllo con la lista dei comandi passati. (Ereditato da UserControlBase)
Metodo protetto | SetVisibleCore | (Ereditato da XtraUserControl)
Metodo protetto | ShouldPaintTransparentBackground | (Ereditato da XtraUserControl)
Metodo protetto | ShouldUseDirectXPaint | (Ereditato da XtraUserControl)
Metodo pubblico | UseOnlyOkButton | Sposta il bottone 'Ok' nella posizione del bottone 'Cancel' in modo tale da coprirlo. Internamente sposta il bottone 'Ok' e imposta la proprietà 'Visible' del bottone 'Cancel'.
Metodo protetto | WndProc | (Ereditato da XtraUserControl)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | CancelClick | Evento associato al click del bottone Cancel
Evento pubblico | ContextMenuOpening | Evento su apertura del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | MenuItemClicked | Evento su click su un elemento del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | OKClick | Evento associato al click del bottone Ok
Evento pubblico | PaintEx | (Ereditato da XtraUserControl)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | _app | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Campo protetto | _RegistryBaseKey | Chiave nel registro di sistema di salvataggio impostazioni. (Ereditato da UserControlBase)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore DedOkCancelControl
Costruttore della classe

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedOkCancelControl()
Public Sub New
public:
DedOkCancelControl()
new : unit -> DedOkCancelControl
Vedi anche

Documentazione

Classe DedOkCancelControl
Namespace DedNet.Controls


Proprietà di DedOkCancelControl

Il tipo DedOkCancelControl espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Appearance | (Ereditato da XtraUserControl)
Proprietà pubblica | Application | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Proprietà pubblica | BackColor | (Ereditato da XtraUserControl)
Proprietà pubblica | CancelButton | Ritorna il bottone Cancel
Proprietà protetta | CheckDoubleScaling | (Ereditato da XtraUserControl)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraUserControl)
Proprietà protetta | DirectXContainer | (Ereditato da XtraUserControl)
Proprietà pubblica | EnableIXtraResizeableControlInterfaceProxy | (Ereditato da XtraUserControl)
Proprietà pubblica | Font | (Ereditato da XtraUserControl)
Proprietà pubblica | ForeColor | (Ereditato da XtraUserControl)
Proprietà protetta | Helper | (Ereditato da XtraUserControl)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraUserControl)
Proprietà pubblica | OkButton | Ritorna il bottone Ok
Proprietà protetta | Painter | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleChildren | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleDPI | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraUserControl)
Proprietà protetta | ShouldCheckDpiScaleFactorOnParentChanged | (Ereditato da XtraUserControl)
Proprietà pubblica | Site | (Ereditato da XtraUserControl)
Torna su
Vedi anche

Documentazione

Classe DedOkCancelControl
Namespace DedNet.Controls


Proprietà DedOkCancelControl.CancelButton

Proprietà DedOkCancelControlCancelButton
Ritorna il bottone Cancel

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public SimpleButton CancelButton { get; }
Public ReadOnly Property CancelButton As SimpleButton
    Get
public:
property SimpleButton^ CancelButton {
    SimpleButton^ get ();
}
member CancelButton : SimpleButton with get

Valore della proprietà

SimpleButton
Vedi anche

Documentazione

Classe DedOkCancelControl
Namespace DedNet.Controls


Proprietà DedOkCancelControl.OkButton

Proprietà DedOkCancelControlOkButton
Ritorna il bottone Ok

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public SimpleButton OkButton { get; }
Public ReadOnly Property OkButton As SimpleButton
    Get
public:
property SimpleButton^ OkButton {
    SimpleButton^ get ();
}
member OkButton : SimpleButton with get

Valore della proprietà

SimpleButton
Vedi anche

Documentazione

Classe DedOkCancelControl
Namespace DedNet.Controls


Metodi di DedOkCancelControl

Il tipo DedOkCancelControl espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | BaseWndProc | (Ereditato da XtraUserControl)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraUserControl)
Metodo protetto | CreatePainter | (Ereditato da XtraUserControl)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive UserControlBaseDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraUserControl)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraUserControl)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraUserControl)
Metodo protetto | GetBackColor | (Ereditato da XtraUserControl)
Metodo protetto | GetBackgroundSkinElement | (Ereditato da XtraUserControl)
Metodo protetto | GetInnerIXtraResizableControl | (Ereditato da XtraUserControl)
Metodo protetto | IsChildControlsRequiredScalingEnabled | (Ereditato da XtraUserControl)
Metodo protetto | IsParentHandleCreatedRecursive | (Ereditato da XtraUserControl)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraUserControl)
Metodo protetto | OnBackColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | onClickCancel |
Metodo protetto | onClickOk |
Metodo protetto | OnContextMenuOpening | Evento di apertura del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnControlAdded | (Ereditato da XtraUserControl)
Metodo protetto | OnControlRemoved | (Ereditato da XtraUserControl)
Metodo protetto | OnDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnFirstLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnForeColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleCreated | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraUserControl)
Metodo protetto | OnLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnMenuItemClicked | Evento di pressione di un comando del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnPaintCore | (Ereditato da XtraUserControl)
Metodo protetto | OnParentChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | OnSizeChanged | (Ereditato da XtraUserControl)
Metodo protetto | RaisePaintExEvent | (Ereditato da XtraUserControl)
Metodo pubblico | ResetBackColor | (Ereditato da XtraUserControl)
Metodo pubblico | ResetForeColor | (Ereditato da XtraUserControl)
Metodo protetto | RestoreAutoScaleModeChangedByPM2 | (Ereditato da XtraUserControl)
Metodo protetto | ScaleControl | (Ereditato da XtraUserControl)
Metodo pubblico | SetCommandList | Rigenera il menu contestuale di questo controllo con la lista dei comandi passati. (Ereditato da UserControlBase)
Metodo protetto | SetVisibleCore | (Ereditato da XtraUserControl)
Metodo protetto | ShouldPaintTransparentBackground | (Ereditato da XtraUserControl)
Metodo protetto | ShouldUseDirectXPaint | (Ereditato da XtraUserControl)
Metodo pubblico | UseOnlyOkButton | Sposta il bottone 'Ok' nella posizione del bottone 'Cancel' in modo tale da coprirlo. Internamente sposta il bottone 'Ok' e imposta la proprietà 'Visible' del bottone 'Cancel'.
Metodo protetto | WndProc | (Ereditato da XtraUserControl)
Torna su
Vedi anche

Documentazione

Classe DedOkCancelControl
Namespace DedNet.Controls


Metodo DedOkCancelControl.Dispose

Metodo DedOkCancelControlDispose
Clean up any resources being used.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedOkCancelControl
Namespace DedNet.Controls


Metodo DedOkCancelControl.onClickCancel

Metodo DedOkCancelControlonClickCancel

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected void onClickCancel(
    Object sender,
    EventArgs e
)
Protected Sub onClickCancel (
    sender As Object,
    e As EventArgs
)
protected:
void onClickCancel(
    Object^ sender,
    EventArgs^ e
)
member onClickCancel :
        sender : Object *
        e : EventArgs -> unit

Parametri

sender Object
e EventArgs
Vedi anche

Documentazione

Classe DedOkCancelControl
Namespace DedNet.Controls


Metodo DedOkCancelControl.onClickOk

Metodo DedOkCancelControlonClickOk

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected void onClickOk(
    Object sender,
    EventArgs e
)
Protected Sub onClickOk (
    sender As Object,
    e As EventArgs
)
protected:
void onClickOk(
    Object^ sender,
    EventArgs^ e
)
member onClickOk :
        sender : Object *
        e : EventArgs -> unit

Parametri

sender Object
e EventArgs
Vedi anche

Documentazione

Classe DedOkCancelControl
Namespace DedNet.Controls


Metodo DedOkCancelControl.UseOnlyOkButton

Metodo DedOkCancelControlUseOnlyOkButton
Sposta il bottone 'Ok' nella posizione del bottone 'Cancel' in modo tale da coprirlo. Internamente sposta il bottone 'Ok' e imposta la proprietà 'Visible' del bottone 'Cancel'.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void UseOnlyOkButton()
Public Sub UseOnlyOkButton
public:
void UseOnlyOkButton()
member UseOnlyOkButton : unit -> unit
Vedi anche

Documentazione

Classe DedOkCancelControl
Namespace DedNet.Controls


Eventi di DedOkCancelControl

Il tipo DedOkCancelControl espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | CancelClick | Evento associato al click del bottone Cancel
Evento pubblico | ContextMenuOpening | Evento su apertura del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | MenuItemClicked | Evento su click su un elemento del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | OKClick | Evento associato al click del bottone Ok
Evento pubblico | PaintEx | (Ereditato da XtraUserControl)
Torna su
Vedi anche

Documentazione

Classe DedOkCancelControl
Namespace DedNet.Controls


Evento DedOkCancelControl.CancelClick

Evento DedOkCancelControlCancelClick
Evento associato al click del bottone Cancel

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler CancelClick
Public Event CancelClick As EventHandler
public:
 event EventHandler^ CancelClick {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member CancelClick : IEvent<EventHandler,
    EventArgs>

Valore

EventHandler
Vedi anche

Documentazione

Classe DedOkCancelControl
Namespace DedNet.Controls


Evento DedOkCancelControl.OKClick

Evento DedOkCancelControlOKClick
Evento associato al click del bottone Ok

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler OKClick
Public Event OKClick As EventHandler
public:
 event EventHandler^ OKClick {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member OKClick : IEvent<EventHandler,
    EventArgs>

Valore

EventHandler
Vedi anche

Documentazione

Classe DedOkCancelControl
Namespace DedNet.Controls


Campi di DedOkCancelControl

Il tipo DedOkCancelControl espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | _app | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Campo protetto | _RegistryBaseKey | Chiave nel registro di sistema di salvataggio impostazioni. (Ereditato da UserControlBase)
Torna su
Vedi anche

Documentazione

Classe DedOkCancelControl
Namespace DedNet.Controls


Classe DedPreviewControl
Classe che gestisce l'anteprima di un file e la sua eventuale immagine anteprima ingrandita.
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
XtraUserControl
DedNet.ControlsUserControlBase
DedNet.ControlsDedPreviewControl

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedPreviewControl : UserControlBase
Public Class DedPreviewControl
    Inherits UserControlBase
public ref class DedPreviewControl : public UserControlBase
type DedPreviewControl =
    class
        inherit UserControlBase
    end

Il tipo DedPreviewControl espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedPreviewControl | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Appearance | (Ereditato da XtraUserControl)
Proprietà pubblica | Application | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Proprietà pubblica | BackColor | (Ereditato da XtraUserControl)
Proprietà protetta | CheckDoubleScaling | (Ereditato da XtraUserControl)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraUserControl)
Proprietà protetta | DirectXContainer | (Ereditato da XtraUserControl)
Proprietà pubblica | EnableIXtraResizeableControlInterfaceProxy | (Ereditato da XtraUserControl)
Proprietà pubblica | ExpandedPreview | Restituisce o imposta se l'anteprima estesa è abilitata.
Proprietà pubblica | Font | (Ereditato da XtraUserControl)
Proprietà pubblica | ForeColor | (Ereditato da XtraUserControl)
Proprietà protetta | Helper | (Ereditato da XtraUserControl)
Proprietà pubblica | Image | Proprietà per ottenere l'immagine del controllo.
Proprietà pubblica | LookAndFeel | (Ereditato da XtraUserControl)
Proprietà protetta | Painter | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleChildren | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleDPI | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraUserControl)
Proprietà protetta | ShouldCheckDpiScaleFactorOnParentChanged | (Ereditato da XtraUserControl)
Proprietà pubblica | Site | (Ereditato da XtraUserControl)
Proprietà pubblica | SourceFile | Restituisce il file correntemente visualizzato che è stato impostato tramite Show().
Proprietà pubblica | Title | Imposta o restituisce il titolo del controllo.
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | BaseWndProc | (Ereditato da XtraUserControl)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraUserControl)
Metodo protetto | CreatePainter | (Ereditato da XtraUserControl)
Metodo protetto | Dispose | Liberare le risorse in uso. (Sovrascrive UserControlBaseDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraUserControl)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraUserControl)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraUserControl)
Metodo protetto | GetBackColor | (Ereditato da XtraUserControl)
Metodo protetto | GetBackgroundSkinElement | (Ereditato da XtraUserControl)
Metodo protetto | GetInnerIXtraResizableControl | (Ereditato da XtraUserControl)
Metodo pubblico | InnerShow | Mostra l'anteprima di un file. Se la gestione dell'anteprima viene fatta dall'utente imposta l'immagine scelta dall'utente, altrimenti usa la gestione standard.
Metodo protetto | IsChildControlsRequiredScalingEnabled | (Ereditato da XtraUserControl)
Metodo protetto | IsParentHandleCreatedRecursive | (Ereditato da XtraUserControl)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraUserControl)
Metodo protetto | OnBackColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnContextMenuOpening | Evento di apertura del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnControlAdded | (Ereditato da XtraUserControl)
Metodo protetto | OnControlRemoved | (Ereditato da XtraUserControl)
Metodo protetto | OnDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnFirstLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnForeColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleCreated | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraUserControl)
Metodo protetto | OnLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnMenuItemClicked | Evento di pressione di un comando del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnPaintCore | (Ereditato da XtraUserControl)
Metodo protetto | OnParentChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | OnSizeChanged | (Ereditato da XtraUserControl)
Metodo pubblico | PreviewNotAvailable | Visualizza immagine di "immagine non disponibile".
Metodo protetto | RaisePaintExEvent | (Ereditato da XtraUserControl)
Metodo pubblico | ResetBackColor | (Ereditato da XtraUserControl)
Metodo pubblico | ResetForeColor | (Ereditato da XtraUserControl)
Metodo protetto | RestoreAutoScaleModeChangedByPM2 | (Ereditato da XtraUserControl)
Metodo protetto | ScaleControl | (Ereditato da XtraUserControl)
Metodo pubblico | SetCommandList | Rigenera il menu contestuale di questo controllo con la lista dei comandi passati. (Ereditato da UserControlBase)
Metodo protetto | SetVisibleCore | (Ereditato da XtraUserControl)
Metodo protetto | ShouldPaintTransparentBackground | (Ereditato da XtraUserControl)
Metodo protetto | ShouldUseDirectXPaint | (Ereditato da XtraUserControl)
Metodo pubblico | Show | Mostra l'anteprima di un file. Se la gestione dell'anteprima viene fatta dall'utente imposta l'immagine scelta dall'utente, altrimenti usa la gestione standard.
Metodo protetto | WndProc | (Ereditato da XtraUserControl)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | ContextMenuOpening | Evento su apertura del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | MenuItemClicked | Evento su click su un elemento del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | PaintEx | (Ereditato da XtraUserControl)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | _app | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Campo protetto | _RegistryBaseKey | Chiave nel registro di sistema di salvataggio impostazioni. (Ereditato da UserControlBase)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore DedPreviewControl
Costruttore unico.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedPreviewControl()
Public Sub New
public:
DedPreviewControl()
new : unit -> DedPreviewControl
Vedi anche

Documentazione

Classe DedPreviewControl
Namespace DedNet.Controls


Proprietà di DedPreviewControl

Il tipo DedPreviewControl espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Appearance | (Ereditato da XtraUserControl)
Proprietà pubblica | Application | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Proprietà pubblica | BackColor | (Ereditato da XtraUserControl)
Proprietà protetta | CheckDoubleScaling | (Ereditato da XtraUserControl)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraUserControl)
Proprietà protetta | DirectXContainer | (Ereditato da XtraUserControl)
Proprietà pubblica | EnableIXtraResizeableControlInterfaceProxy | (Ereditato da XtraUserControl)
Proprietà pubblica | ExpandedPreview | Restituisce o imposta se l'anteprima estesa è abilitata.
Proprietà pubblica | Font | (Ereditato da XtraUserControl)
Proprietà pubblica | ForeColor | (Ereditato da XtraUserControl)
Proprietà protetta | Helper | (Ereditato da XtraUserControl)
Proprietà pubblica | Image | Proprietà per ottenere l'immagine del controllo.
Proprietà pubblica | LookAndFeel | (Ereditato da XtraUserControl)
Proprietà protetta | Painter | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleChildren | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleDPI | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraUserControl)
Proprietà protetta | ShouldCheckDpiScaleFactorOnParentChanged | (Ereditato da XtraUserControl)
Proprietà pubblica | Site | (Ereditato da XtraUserControl)
Proprietà pubblica | SourceFile | Restituisce il file correntemente visualizzato che è stato impostato tramite Show().
Proprietà pubblica | Title | Imposta o restituisce il titolo del controllo.
Torna su
Vedi anche

Documentazione

Classe DedPreviewControl
Namespace DedNet.Controls


Proprietà DedPreviewControl.ExpandedPreview

Proprietà DedPreviewControlExpandedPreview
Restituisce o imposta se l'anteprima estesa è abilitata.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ExpandedPreview { get; set; }
Public Property ExpandedPreview As Boolean
    Get
    Set
public:
property bool ExpandedPreview {
    bool get ();
    void set (bool value);
}
member ExpandedPreview : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedPreviewControl
Namespace DedNet.Controls


Proprietà DedPreviewControl.Image

Proprietà DedPreviewControlImage
Proprietà per ottenere l'immagine del controllo.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Image Image { get; }
Public ReadOnly Property Image As Image
    Get
public:
property Image^ Image {
    Image^ get ();
}
member Image : Image with get

Valore della proprietà

Image
Vedi anche

Documentazione

Classe DedPreviewControl
Namespace DedNet.Controls


Proprietà DedPreviewControl.SourceFile

Proprietà DedPreviewControlSourceFile
Restituisce il file correntemente visualizzato che è stato impostato tramite Show().

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string SourceFile { get; }
Public ReadOnly Property SourceFile As String
    Get
public:
property String^ SourceFile {
    String^ get ();
}
member SourceFile : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedPreviewControl
Namespace DedNet.Controls


Proprietà DedPreviewControl.Title

Proprietà DedPreviewControlTitle
Imposta o restituisce il titolo del controllo.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Title { get; set; }
Public Property Title As String
    Get
    Set
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}
member Title : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedPreviewControl
Namespace DedNet.Controls


Metodi di DedPreviewControl

Il tipo DedPreviewControl espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | BaseWndProc | (Ereditato da XtraUserControl)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraUserControl)
Metodo protetto | CreatePainter | (Ereditato da XtraUserControl)
Metodo protetto | Dispose | Liberare le risorse in uso. (Sovrascrive UserControlBaseDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraUserControl)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraUserControl)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraUserControl)
Metodo protetto | GetBackColor | (Ereditato da XtraUserControl)
Metodo protetto | GetBackgroundSkinElement | (Ereditato da XtraUserControl)
Metodo protetto | GetInnerIXtraResizableControl | (Ereditato da XtraUserControl)
Metodo pubblico | InnerShow | Mostra l'anteprima di un file. Se la gestione dell'anteprima viene fatta dall'utente imposta l'immagine scelta dall'utente, altrimenti usa la gestione standard.
Metodo protetto | IsChildControlsRequiredScalingEnabled | (Ereditato da XtraUserControl)
Metodo protetto | IsParentHandleCreatedRecursive | (Ereditato da XtraUserControl)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraUserControl)
Metodo protetto | OnBackColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnContextMenuOpening | Evento di apertura del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnControlAdded | (Ereditato da XtraUserControl)
Metodo protetto | OnControlRemoved | (Ereditato da XtraUserControl)
Metodo protetto | OnDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnFirstLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnForeColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleCreated | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraUserControl)
Metodo protetto | OnLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnMenuItemClicked | Evento di pressione di un comando del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnPaintCore | (Ereditato da XtraUserControl)
Metodo protetto | OnParentChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | OnSizeChanged | (Ereditato da XtraUserControl)
Metodo pubblico | PreviewNotAvailable | Visualizza immagine di "immagine non disponibile".
Metodo protetto | RaisePaintExEvent | (Ereditato da XtraUserControl)
Metodo pubblico | ResetBackColor | (Ereditato da XtraUserControl)
Metodo pubblico | ResetForeColor | (Ereditato da XtraUserControl)
Metodo protetto | RestoreAutoScaleModeChangedByPM2 | (Ereditato da XtraUserControl)
Metodo protetto | ScaleControl | (Ereditato da XtraUserControl)
Metodo pubblico | SetCommandList | Rigenera il menu contestuale di questo controllo con la lista dei comandi passati. (Ereditato da UserControlBase)
Metodo protetto | SetVisibleCore | (Ereditato da XtraUserControl)
Metodo protetto | ShouldPaintTransparentBackground | (Ereditato da XtraUserControl)
Metodo protetto | ShouldUseDirectXPaint | (Ereditato da XtraUserControl)
Metodo pubblico | Show | Mostra l'anteprima di un file. Se la gestione dell'anteprima viene fatta dall'utente imposta l'immagine scelta dall'utente, altrimenti usa la gestione standard.
Metodo protetto | WndProc | (Ereditato da XtraUserControl)
Torna su
Vedi anche

Documentazione

Classe DedPreviewControl
Namespace DedNet.Controls


Metodo DedPreviewControl.Dispose

Metodo DedPreviewControlDispose
Liberare le risorse in uso.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
ha valore true se le risorse gestite devono essere eliminate, false in caso contrario.
Vedi anche

Documentazione

Classe DedPreviewControl
Namespace DedNet.Controls


Metodo DedPreviewControl.InnerShow

Metodo DedPreviewControlInnerShow
Mostra l'anteprima di un file. Se la gestione dell'anteprima viene fatta dall'utente imposta l'immagine scelta dall'utente, altrimenti usa la gestione standard.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void InnerShow(
    string fileName
)
Public Sub InnerShow (
    fileName As String
)
public:
void InnerShow(
    String^ fileName
)
member InnerShow :
        fileName : string -> unit

Parametri

fileName String
Percorso del file da visualizzare.
Vedi anche

Documentazione

Classe DedPreviewControl
Namespace DedNet.Controls


Metodo DedPreviewControl.PreviewNotAvailable

Metodo DedPreviewControlPreviewNotAvailable
Visualizza immagine di "immagine non disponibile".

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void PreviewNotAvailable(
    bool zoomEnabled
)
Public Sub PreviewNotAvailable (
    zoomEnabled As Boolean
)
public:
void PreviewNotAvailable(
    bool zoomEnabled
)
member PreviewNotAvailable :
        zoomEnabled : bool -> unit

Parametri

zoomEnabled Boolean
Indica se abilitare o meno lo zoom.
Vedi anche

Documentazione

Classe DedPreviewControl
Namespace DedNet.Controls


Metodo DedPreviewControl.Show

Metodo DedPreviewControlShow
Mostra l'anteprima di un file. Se la gestione dell'anteprima viene fatta dall'utente imposta l'immagine scelta dall'utente, altrimenti usa la gestione standard.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Show(
    string fileName
)
Public Sub Show (
    fileName As String
)
public:
void Show(
    String^ fileName
)
member Show :
        fileName : string -> unit

Parametri

fileName String
Percorso del file da visualizzare.
Vedi anche

Documentazione

Classe DedPreviewControl
Namespace DedNet.Controls


Eventi di DedPreviewControl

Il tipo DedPreviewControl espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | ContextMenuOpening | Evento su apertura del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | MenuItemClicked | Evento su click su un elemento del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | PaintEx | (Ereditato da XtraUserControl)
Torna su
Vedi anche

Documentazione

Classe DedPreviewControl
Namespace DedNet.Controls


Campi di DedPreviewControl

Il tipo DedPreviewControl espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | _app | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Campo protetto | _RegistryBaseKey | Chiave nel registro di sistema di salvataggio impostazioni. (Ereditato da UserControlBase)
Torna su
Vedi anche

Documentazione

Classe DedPreviewControl
Namespace DedNet.Controls


Classe DedRootExplorerControl
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
XtraUserControl
DedNet.ControlsUserControlBase
DedNet.ControlsDedRootExplorerControl

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedRootExplorerControl : UserControlBase
Public Class DedRootExplorerControl
    Inherits UserControlBase
public ref class DedRootExplorerControl : public UserControlBase
type DedRootExplorerControl =
    class
        inherit UserControlBase
    end

Il tipo DedRootExplorerControl espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedRootExplorerControl |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AdditionalFolders | Ritorna la lista delle cartelle aggiuntive
Proprietà pubblica | AllDocumentsPaths | Ritorna il dizionario di tutta la struttura cartelle, comprese quelle aggiuntive
Proprietà pubblica | AllowDragOperation | Indica se l'albero permette il Drag dei nodi.
Proprietà pubblica | AllowDropOperation | Indica se l'albero permette il Drop sui nodi.
Proprietà pubblica | AllowExpandOnDoubleClick | Restituisce o imposata se abilitare o meno l'espandione del nodo con il doppio click.
Proprietà pubblica | Appearance | (Ereditato da XtraUserControl)
Proprietà pubblica | Application | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Proprietà pubblica | BackColor | (Ereditato da XtraUserControl)
Proprietà protetta | CheckDoubleScaling | (Ereditato da XtraUserControl)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraUserControl)
Proprietà protetta | DirectXContainer | (Ereditato da XtraUserControl)
Proprietà pubblica | EnableIXtraResizeableControlInterfaceProxy | (Ereditato da XtraUserControl)
Proprietà pubblica | Font | (Ereditato da XtraUserControl)
Proprietà pubblica | ForeColor | (Ereditato da XtraUserControl)
Proprietà protetta | Helper | (Ereditato da XtraUserControl)
Proprietà pubblica | ImageList | Imposta l'insieme delle immagini dalle quali disegnare l'icona.
Proprietà pubblica | InnerControl | Restituisce l'albero.
Proprietà pubblica | LookAndFeel | (Ereditato da XtraUserControl)
Proprietà pubblica | MultiSelect | Indica se è attiva la selezione multipla delle famiglie.
Proprietà protetta | Painter | (Ereditato da XtraUserControl)
Proprietà pubblica | PathToHide | Imposta / restituisce lista dei path da non visualizzare.
Proprietà protetta | ScaleChildren | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleDPI | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraUserControl)
Proprietà protetta | ShouldCheckDpiScaleFactorOnParentChanged | (Ereditato da XtraUserControl)
Proprietà pubblica | Site | (Ereditato da XtraUserControl)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AddAdditionalFolder | Aggiunge la cartella specificata in ingresso all'elenco delle root aggiuntive. Ritorna True se la cartella viene aggiunta all'elenco, False altrimenti.
Metodo protetto | BaseWndProc | (Ereditato da XtraUserControl)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraUserControl)
Metodo protetto | CreatePainter | (Ereditato da XtraUserControl)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive UserControlBaseDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraUserControl)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraUserControl)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraUserControl)
Metodo protetto | GetBackColor | (Ereditato da XtraUserControl)
Metodo protetto | GetBackgroundSkinElement | (Ereditato da XtraUserControl)
Metodo protetto | GetInnerIXtraResizableControl | (Ereditato da XtraUserControl)
Metodo pubblico | GetNodePath | Restituisce il percorso del nodo rootato.
Metodo pubblico | GetVisibleChildren | Restituisce la lista delle sotto-cartelle visibili
Metodo pubblico | Init | Metodo di inizializzazioen dell'albero
Metodo protetto | IsChildControlsRequiredScalingEnabled | (Ereditato da XtraUserControl)
Metodo protetto | IsParentHandleCreatedRecursive | (Ereditato da XtraUserControl)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraUserControl)
Metodo protetto | OnBackColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnContextMenuOpening | Evento di apertura del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnControlAdded | (Ereditato da XtraUserControl)
Metodo protetto | OnControlRemoved | (Ereditato da XtraUserControl)
Metodo protetto | OnDblClick |
Metodo protetto | OnDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnDrawIcon |
Metodo protetto | OnFirstLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnForeColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleCreated | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraUserControl)
Metodo protetto | OnLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnMenuItemClicked | Evento di pressione di un comando del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnMouseDown |
Metodo protetto | OnPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnPaintCore | (Ereditato da XtraUserControl)
Metodo protetto | OnParentChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | OnSelectionChanged |
Metodo protetto | OnSizeChanged | (Ereditato da XtraUserControl)
Metodo protetto | RaisePaintExEvent | (Ereditato da XtraUserControl)
Metodo pubblico | RefreshStructure | Aggiorna l'intera struttura senza rileggere i dati dal database.
Metodo pubblico | Reload | Aggiorna l'intera struttura rileggendo i dati dal database.
Metodo pubblico | RemoveAdditionalFolder | Rimuove la cartella specificata in ingresso dall'elenco delle root aggiuntive. Ritorna True se la cartella viene rimossa dall'elenco, False altrimenti.
Metodo pubblico | RenameAdditionalFolder | Cancella la vecchia cartella dall'elenco delle cartelle aggiuntive inserendo successivamente quella nuova. Ritorna True se la cartella viene rinominata, False altrimenti.
Metodo pubblico | ResetBackColor | (Ereditato da XtraUserControl)
Metodo pubblico | ResetForeColor | (Ereditato da XtraUserControl)
Metodo protetto | RestoreAutoScaleModeChangedByPM2 | (Ereditato da XtraUserControl)
Metodo pubblico | RestoreLayoutFromRegistry | Metodo per ripristinare le impostazioni dal registro.
Metodo pubblico | SaveLayoutToRegistry | Metodo per salvare le impostazioni dal registro.
Metodo protetto | ScaleControl | (Ereditato da XtraUserControl)
Metodo pubblico | SetCommandList | Rigenera il menu contestuale di questo controllo con la lista dei comandi passati. (Ereditato da UserControlBase)
Metodo protetto | SetVisibleCore | (Ereditato da XtraUserControl)
Metodo protetto | ShouldPaintTransparentBackground | (Ereditato da XtraUserControl)
Metodo protetto | ShouldUseDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | WndProc | (Ereditato da XtraUserControl)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | ContextMenuOpening | Evento su apertura del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | DblClick | Evento di doppio click sui nodi selezionati.
Evento pubblico | DrawIcon | Evento per selezionare l'icona da visualizzare.
Evento pubblico | MenuItemClicked | Evento su click su un elemento del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | MyDragDrop | Evento per la gestione del dragDrop.
Evento pubblico | MyDragOver | Evento per la gestione del dragOver.
Evento pubblico | MyMouseDown | Evento per la gestione del movimento del mouse.
Evento pubblico | MyMouseMove | Evento per la gestione del movimento del mouse.
Evento pubblico | PaintEx | (Ereditato da XtraUserControl)
Evento pubblico | SelectionChanged | Evento generato sul cambio selezione della famiglia da parte dell'utente.
Torna su
Campi
 | Nome | Descrizione
Campo protetto | _app | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Campo protetto | _RegistryBaseKey | Chiave nel registro di sistema di salvataggio impostazioni. (Ereditato da UserControlBase)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore DedRootExplorerControl

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedRootExplorerControl()
Public Sub New
public:
DedRootExplorerControl()
new : unit -> DedRootExplorerControl
Vedi anche

Documentazione

Classe DedRootExplorerControl
Namespace DedNet.Controls


Proprietà di DedRootExplorerControl

Il tipo DedRootExplorerControl espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AdditionalFolders | Ritorna la lista delle cartelle aggiuntive
Proprietà pubblica | AllDocumentsPaths | Ritorna il dizionario di tutta la struttura cartelle, comprese quelle aggiuntive
Proprietà pubblica | AllowDragOperation | Indica se l'albero permette il Drag dei nodi.
Proprietà pubblica | AllowDropOperation | Indica se l'albero permette il Drop sui nodi.
Proprietà pubblica | AllowExpandOnDoubleClick | Restituisce o imposata se abilitare o meno l'espandione del nodo con il doppio click.
Proprietà pubblica | Appearance | (Ereditato da XtraUserControl)
Proprietà pubblica | Application | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Proprietà pubblica | BackColor | (Ereditato da XtraUserControl)
Proprietà protetta | CheckDoubleScaling | (Ereditato da XtraUserControl)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraUserControl)
Proprietà protetta | DirectXContainer | (Ereditato da XtraUserControl)
Proprietà pubblica | EnableIXtraResizeableControlInterfaceProxy | (Ereditato da XtraUserControl)
Proprietà pubblica | Font | (Ereditato da XtraUserControl)
Proprietà pubblica | ForeColor | (Ereditato da XtraUserControl)
Proprietà protetta | Helper | (Ereditato da XtraUserControl)
Proprietà pubblica | ImageList | Imposta l'insieme delle immagini dalle quali disegnare l'icona.
Proprietà pubblica | InnerControl | Restituisce l'albero.
Proprietà pubblica | LookAndFeel | (Ereditato da XtraUserControl)
Proprietà pubblica | MultiSelect | Indica se è attiva la selezione multipla delle famiglie.
Proprietà protetta | Painter | (Ereditato da XtraUserControl)
Proprietà pubblica | PathToHide | Imposta / restituisce lista dei path da non visualizzare.
Proprietà protetta | ScaleChildren | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleDPI | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraUserControl)
Proprietà protetta | ShouldCheckDpiScaleFactorOnParentChanged | (Ereditato da XtraUserControl)
Proprietà pubblica | Site | (Ereditato da XtraUserControl)
Torna su
Vedi anche

Documentazione

Classe DedRootExplorerControl
Namespace DedNet.Controls


Proprietà DedRootExplorerControl.AdditionalFolders

Proprietà DedRootExplorerControlAdditionalFolders
Ritorna la lista delle cartelle aggiuntive

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public IEnumerable<string> AdditionalFolders { get; }
Public ReadOnly Property AdditionalFolders As IEnumerable(Of String)
    Get
public:
property IEnumerable<String^>^ AdditionalFolders {
    IEnumerable<String^>^ get ();
}
member AdditionalFolders : IEnumerable<string> with get

Valore di ritorno

IEnumerable String
Vedi anche

Documentazione

Classe DedRootExplorerControl
Namespace DedNet.Controls


Proprietà DedRootExplorerControl.AllDocumentsPaths

Proprietà DedRootExplorerControlAllDocumentsPaths
Ritorna il dizionario di tutta la struttura cartelle, comprese quelle aggiuntive

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<string, List<string>> AllDocumentsPaths { get; }
Public ReadOnly Property AllDocumentsPaths As Dictionary(Of String, List(Of String))
    Get
public:
property Dictionary<String^, List<String^>^>^ AllDocumentsPaths {
    Dictionary<String^, List<String^>^>^ get ();
}
member AllDocumentsPaths : Dictionary<string, List<string>> with get

Valore di ritorno

Dictionary String, List String
Vedi anche

Documentazione

Classe DedRootExplorerControl
Namespace DedNet.Controls


Proprietà DedRootExplorerControl.AllowDragOperation

Proprietà DedRootExplorerControlAllowDragOperation
Indica se l'albero permette il Drag dei nodi.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AllowDragOperation { get; set; }
Public Property AllowDragOperation As Boolean
    Get
    Set
public:
property bool AllowDragOperation {
    bool get ();
    void set (bool value);
}
member AllowDragOperation : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedRootExplorerControl
Namespace DedNet.Controls


Proprietà DedRootExplorerControl.AllowDropOperation

Proprietà DedRootExplorerControlAllowDropOperation
Indica se l'albero permette il Drop sui nodi.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AllowDropOperation { get; set; }
Public Property AllowDropOperation As Boolean
    Get
    Set
public:
property bool AllowDropOperation {
    bool get ();
    void set (bool value);
}
member AllowDropOperation : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedRootExplorerControl
Namespace DedNet.Controls


Proprietà DedRootExplorerControl.AllowExpandOnDoubleClick

Proprietà DedRootExplorerControlAllowExpandOnDoubleClick
Restituisce o imposata se abilitare o meno l'espandione del nodo con il doppio click.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AllowExpandOnDoubleClick { get; set; }
Public Property AllowExpandOnDoubleClick As Boolean
    Get
    Set
public:
property bool AllowExpandOnDoubleClick {
    bool get ();
    void set (bool value);
}
member AllowExpandOnDoubleClick : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedRootExplorerControl
Namespace DedNet.Controls


Proprietà DedRootExplorerControl.ImageList

Proprietà DedRootExplorerControlImageList
Imposta l'insieme delle immagini dalle quali disegnare l'icona.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ImageCollection ImageList { set; }
Public WriteOnly Property ImageList As ImageCollection
    Set
public:
property ImageCollection^ ImageList {
    void set (ImageCollection^ value);
}
member ImageList : ImageCollection with set

Valore della proprietà

ImageCollection
Vedi anche

Documentazione

Classe DedRootExplorerControl
Namespace DedNet.Controls


Proprietà DedRootExplorerControl.InnerControl

Proprietà DedRootExplorerControlInnerControl
Restituisce l'albero.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public MyTreeListRoot InnerControl { get; }
Public ReadOnly Property InnerControl As MyTreeListRoot
    Get
public:
property MyTreeListRoot^ InnerControl {
    MyTreeListRoot^ get ();
}
member InnerControl : MyTreeListRoot with get

Valore della proprietà

MyTreeListRoot
Vedi anche

Documentazione

Classe DedRootExplorerControl
Namespace DedNet.Controls


Proprietà DedRootExplorerControl.MultiSelect

Proprietà DedRootExplorerControlMultiSelect
Indica se è attiva la selezione multipla delle famiglie.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool MultiSelect { get; set; }
Public Property MultiSelect As Boolean
    Get
    Set
public:
property bool MultiSelect {
    bool get ();
    void set (bool value);
}
member MultiSelect : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedRootExplorerControl
Namespace DedNet.Controls


Proprietà DedRootExplorerControl.PathToHide

Proprietà DedRootExplorerControlPathToHide
Imposta / restituisce lista dei path da non visualizzare.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> PathToHide { get; set; }
Public Property PathToHide As List(Of String)
    Get
    Set
public:
property List<String^>^ PathToHide {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
member PathToHide : List<string> with get, set

Valore della proprietà

List String
Vedi anche

Documentazione

Classe DedRootExplorerControl
Namespace DedNet.Controls


Metodi di DedRootExplorerControl

Il tipo DedRootExplorerControl espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AddAdditionalFolder | Aggiunge la cartella specificata in ingresso all'elenco delle root aggiuntive. Ritorna True se la cartella viene aggiunta all'elenco, False altrimenti.
Metodo protetto | BaseWndProc | (Ereditato da XtraUserControl)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraUserControl)
Metodo protetto | CreatePainter | (Ereditato da XtraUserControl)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive UserControlBaseDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraUserControl)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraUserControl)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraUserControl)
Metodo protetto | GetBackColor | (Ereditato da XtraUserControl)
Metodo protetto | GetBackgroundSkinElement | (Ereditato da XtraUserControl)
Metodo protetto | GetInnerIXtraResizableControl | (Ereditato da XtraUserControl)
Metodo pubblico | GetNodePath | Restituisce il percorso del nodo rootato.
Metodo pubblico | GetVisibleChildren | Restituisce la lista delle sotto-cartelle visibili
Metodo pubblico | Init | Metodo di inizializzazioen dell'albero
Metodo protetto | IsChildControlsRequiredScalingEnabled | (Ereditato da XtraUserControl)
Metodo protetto | IsParentHandleCreatedRecursive | (Ereditato da XtraUserControl)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraUserControl)
Metodo protetto | OnBackColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnContextMenuOpening | Evento di apertura del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnControlAdded | (Ereditato da XtraUserControl)
Metodo protetto | OnControlRemoved | (Ereditato da XtraUserControl)
Metodo protetto | OnDblClick |
Metodo protetto | OnDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnDrawIcon |
Metodo protetto | OnFirstLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnForeColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleCreated | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraUserControl)
Metodo protetto | OnLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnMenuItemClicked | Evento di pressione di un comando del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnMouseDown |
Metodo protetto | OnPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnPaintCore | (Ereditato da XtraUserControl)
Metodo protetto | OnParentChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | OnSelectionChanged |
Metodo protetto | OnSizeChanged | (Ereditato da XtraUserControl)
Metodo protetto | RaisePaintExEvent | (Ereditato da XtraUserControl)
Metodo pubblico | RefreshStructure | Aggiorna l'intera struttura senza rileggere i dati dal database.
Metodo pubblico | Reload | Aggiorna l'intera struttura rileggendo i dati dal database.
Metodo pubblico | RemoveAdditionalFolder | Rimuove la cartella specificata in ingresso dall'elenco delle root aggiuntive. Ritorna True se la cartella viene rimossa dall'elenco, False altrimenti.
Metodo pubblico | RenameAdditionalFolder | Cancella la vecchia cartella dall'elenco delle cartelle aggiuntive inserendo successivamente quella nuova. Ritorna True se la cartella viene rinominata, False altrimenti.
Metodo pubblico | ResetBackColor | (Ereditato da XtraUserControl)
Metodo pubblico | ResetForeColor | (Ereditato da XtraUserControl)
Metodo protetto | RestoreAutoScaleModeChangedByPM2 | (Ereditato da XtraUserControl)
Metodo pubblico | RestoreLayoutFromRegistry | Metodo per ripristinare le impostazioni dal registro.
Metodo pubblico | SaveLayoutToRegistry | Metodo per salvare le impostazioni dal registro.
Metodo protetto | ScaleControl | (Ereditato da XtraUserControl)
Metodo pubblico | SetCommandList | Rigenera il menu contestuale di questo controllo con la lista dei comandi passati. (Ereditato da UserControlBase)
Metodo protetto | SetVisibleCore | (Ereditato da XtraUserControl)
Metodo protetto | ShouldPaintTransparentBackground | (Ereditato da XtraUserControl)
Metodo protetto | ShouldUseDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | WndProc | (Ereditato da XtraUserControl)
Torna su
Vedi anche

Documentazione

Classe DedRootExplorerControl
Namespace DedNet.Controls


Metodo DedRootExplorerControl.AddAdditionalFolder

Metodo DedRootExplorerControlAddAdditionalFolder
Aggiunge la cartella specificata in ingresso all'elenco delle root aggiuntive. Ritorna True se la cartella viene aggiunta all'elenco, False altrimenti.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AddAdditionalFolder(
    string folder
)
Public Function AddAdditionalFolder (
    folder As String
) As Boolean
public:
bool AddAdditionalFolder(
    String^ folder
)
member AddAdditionalFolder :
        folder : string -> bool

Parametri

folder String
Path della cartella da aggiungere.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedRootExplorerControl
Namespace DedNet.Controls


Metodo DedRootExplorerControl.Dispose

Metodo DedRootExplorerControlDispose
Clean up any resources being used.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedRootExplorerControl
Namespace DedNet.Controls


Metodo DedRootExplorerControl.GetNodePath

Metodo DedRootExplorerControlGetNodePath
Restituisce il percorso del nodo rootato.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string GetNodePath(
    TreeListNode tn
)
Public Function GetNodePath (
    tn As TreeListNode
) As String
public:
String^ GetNodePath(
    TreeListNode^ tn
)
member GetNodePath :
        tn : TreeListNode -> string

Parametri

tn TreeListNode
Nodo del quale si vuole il percorso.

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedRootExplorerControl
Namespace DedNet.Controls


Metodo DedRootExplorerControl.GetVisibleChildren

Metodo DedRootExplorerControlGetVisibleChildren
Restituisce la lista delle sotto-cartelle visibili

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> GetVisibleChildren(
    string path
)
Public Function GetVisibleChildren (
    path As String
) As List(Of String)
public:
List<String^>^ GetVisibleChildren(
    String^ path
)
member GetVisibleChildren :
        path : string -> List<string>

Parametri

path String

Valore di ritorno

List String
Vedi anche

Documentazione

Classe DedRootExplorerControl
Namespace DedNet.Controls


Metodo DedRootExplorerControl.Init

Metodo DedRootExplorerControlInit
Metodo di inizializzazioen dell'albero

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Init()
Public Sub Init
public:
void Init()
member Init : unit -> unit
Vedi anche

Documentazione

Classe DedRootExplorerControl
Namespace DedNet.Controls


Metodo DedRootExplorerControl.OnDblClick

Metodo DedRootExplorerControlOnDblClick

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected void OnDblClick(
    Object sender
)
Protected Sub OnDblClick (
    sender As Object
)
protected:
void OnDblClick(
    Object^ sender
)
member OnDblClick :
        sender : Object -> unit

Parametri

sender Object
Vedi anche

Documentazione

Classe DedRootExplorerControl
Namespace DedNet.Controls


Metodo DedRootExplorerControl.OnDrawIcon

Metodo DedRootExplorerControlOnDrawIcon

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected void OnDrawIcon(
    Object sender,
    DrawIconEventArgs ev
)
Protected Sub OnDrawIcon (
    sender As Object,
    ev As DrawIconEventArgs
)
protected:
void OnDrawIcon(
    Object^ sender,
    DrawIconEventArgs^ ev
)
member OnDrawIcon :
        sender : Object *
        ev : DrawIconEventArgs -> unit

Parametri

sender Object
ev DrawIconEventArgs
Vedi anche

Documentazione

Classe DedRootExplorerControl
Namespace DedNet.Controls


Metodo DedRootExplorerControl.OnMouseDown

Metodo DedRootExplorerControlOnMouseDown

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected void OnMouseDown(
    Object sender,
    MouseEventArgs e
)
Protected Sub OnMouseDown (
    sender As Object,
    e As MouseEventArgs
)
protected:
void OnMouseDown(
    Object^ sender,
    MouseEventArgs^ e
)
member OnMouseDown :
        sender : Object *
        e : MouseEventArgs -> unit

Parametri

sender Object
e MouseEventArgs
Vedi anche

Documentazione

Classe DedRootExplorerControl
Namespace DedNet.Controls


Metodo DedRootExplorerControl.OnSelectionChanged

Metodo DedRootExplorerControlOnSelectionChanged

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected void OnSelectionChanged(
    Object sender
)
Protected Sub OnSelectionChanged (
    sender As Object
)
protected:
void OnSelectionChanged(
    Object^ sender
)
member OnSelectionChanged :
        sender : Object -> unit

Parametri

sender Object
Vedi anche

Documentazione

Classe DedRootExplorerControl
Namespace DedNet.Controls


Metodo DedRootExplorerControl.RefreshStructure

Metodo DedRootExplorerControlRefreshStructure
Aggiorna l'intera struttura senza rileggere i dati dal database.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void RefreshStructure()
Public Sub RefreshStructure
public:
void RefreshStructure()
member RefreshStructure : unit -> unit
Vedi anche

Documentazione

Classe DedRootExplorerControl
Namespace DedNet.Controls


Metodo DedRootExplorerControl.Reload

Metodo DedRootExplorerControlReload
Aggiorna l'intera struttura rileggendo i dati dal database.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Reload()
Public Sub Reload
public:
void Reload()
member Reload : unit -> unit
Vedi anche

Documentazione

Classe DedRootExplorerControl
Namespace DedNet.Controls


Metodo DedRootExplorerControl.RemoveAdditionalFolder

Metodo DedRootExplorerControlRemoveAdditionalFolder
Rimuove la cartella specificata in ingresso dall'elenco delle root aggiuntive. Ritorna True se la cartella viene rimossa dall'elenco, False altrimenti.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool RemoveAdditionalFolder(
    string folder
)
Public Function RemoveAdditionalFolder (
    folder As String
) As Boolean
public:
bool RemoveAdditionalFolder(
    String^ folder
)
member RemoveAdditionalFolder :
        folder : string -> bool

Parametri

folder String
Path della cartella da rimuovere.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedRootExplorerControl
Namespace DedNet.Controls


Metodo DedRootExplorerControl.RenameAdditionalFolder

Metodo DedRootExplorerControlRenameAdditionalFolder
Cancella la vecchia cartella dall'elenco delle cartelle aggiuntive inserendo successivamente quella nuova. Ritorna True se la cartella viene rinominata, False altrimenti.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool RenameAdditionalFolder(
    string oldFolder,
    string newFolder
)
Public Function RenameAdditionalFolder (
    oldFolder As String,
    newFolder As String
) As Boolean
public:
bool RenameAdditionalFolder(
    String^ oldFolder,
    String^ newFolder
)
member RenameAdditionalFolder :
        oldFolder : string *
        newFolder : string -> bool

Parametri

oldFolder String
Vecchia cartella da rimuovere.
newFolder String
Nuova cartella da aggiungere.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedRootExplorerControl
Namespace DedNet.Controls


Metodo DedRootExplorerControl.RestoreLayoutFromRegistry

Metodo DedRootExplorerControlRestoreLayoutFromRegistry
Metodo per ripristinare le impostazioni dal registro.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void RestoreLayoutFromRegistry(
    string key
)
Public Sub RestoreLayoutFromRegistry (
    key As String
)
public:
void RestoreLayoutFromRegistry(
    String^ key
)
member RestoreLayoutFromRegistry :
        key : string -> unit

Parametri

key String
Chiave di registro
Vedi anche

Documentazione

Classe DedRootExplorerControl
Namespace DedNet.Controls


Metodo DedRootExplorerControl.SaveLayoutToRegistry

Metodo DedRootExplorerControlSaveLayoutToRegistry
Metodo per salvare le impostazioni dal registro.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SaveLayoutToRegistry(
    string key
)
Public Sub SaveLayoutToRegistry (
    key As String
)
public:
void SaveLayoutToRegistry(
    String^ key
)
member SaveLayoutToRegistry :
        key : string -> unit

Parametri

key String
Chiave di registro
Vedi anche

Documentazione

Classe DedRootExplorerControl
Namespace DedNet.Controls


Eventi di DedRootExplorerControl

Il tipo DedRootExplorerControl espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | ContextMenuOpening | Evento su apertura del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | DblClick | Evento di doppio click sui nodi selezionati.
Evento pubblico | DrawIcon | Evento per selezionare l'icona da visualizzare.
Evento pubblico | MenuItemClicked | Evento su click su un elemento del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | MyDragDrop | Evento per la gestione del dragDrop.
Evento pubblico | MyDragOver | Evento per la gestione del dragOver.
Evento pubblico | MyMouseDown | Evento per la gestione del movimento del mouse.
Evento pubblico | MyMouseMove | Evento per la gestione del movimento del mouse.
Evento pubblico | PaintEx | (Ereditato da XtraUserControl)
Evento pubblico | SelectionChanged | Evento generato sul cambio selezione della famiglia da parte dell'utente.
Torna su
Vedi anche

Documentazione

Classe DedRootExplorerControl
Namespace DedNet.Controls


Evento DedRootExplorerControl.DblClick

Evento DedRootExplorerControlDblClick
Evento di doppio click sui nodi selezionati.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<EventArgs> DblClick
Public Event DblClick As EventHandler(Of EventArgs)
public:
 event EventHandler<EventArgs^>^ DblClick {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}
member DblClick : IEvent<EventHandler<EventArgs>,
    EventArgs>

Valore

EventHandler EventArgs
Vedi anche

Documentazione

Classe DedRootExplorerControl
Namespace DedNet.Controls


Evento DedRootExplorerControl.DrawIcon

Evento DedRootExplorerControlDrawIcon
Evento per selezionare l'icona da visualizzare.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DrawIconEventArgs> DrawIcon
Public Event DrawIcon As EventHandler(Of DrawIconEventArgs)
public:
 event EventHandler<DrawIconEventArgs^>^ DrawIcon {
    void add (EventHandler<DrawIconEventArgs^>^ value);
    void remove (EventHandler<DrawIconEventArgs^>^ value);
}
member DrawIcon : IEvent<EventHandler<DrawIconEventArgs>,
    DrawIconEventArgs>

Valore

EventHandler DrawIconEventArgs
Vedi anche

Documentazione

Classe DedRootExplorerControl
Namespace DedNet.Controls


Evento DedRootExplorerControl.MyDragDrop

Evento DedRootExplorerControlMyDragDrop
Evento per la gestione del dragDrop.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<MyDragDropNodeEventArgs> MyDragDrop
Public Event MyDragDrop As EventHandler(Of MyDragDropNodeEventArgs)
public:
 event EventHandler<MyDragDropNodeEventArgs^>^ MyDragDrop {
    void add (EventHandler<MyDragDropNodeEventArgs^>^ value);
    void remove (EventHandler<MyDragDropNodeEventArgs^>^ value);
}
member MyDragDrop : IEvent<EventHandler<MyDragDropNodeEventArgs>,
    MyDragDropNodeEventArgs>

Valore

EventHandler MyDragDropNodeEventArgs
Vedi anche

Documentazione

Classe DedRootExplorerControl
Namespace DedNet.Controls


Evento DedRootExplorerControl.MyDragOver

Evento DedRootExplorerControlMyDragOver
Evento per la gestione del dragOver.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<MyDragDropNodeEventArgs> MyDragOver
Public Event MyDragOver As EventHandler(Of MyDragDropNodeEventArgs)
public:
 event EventHandler<MyDragDropNodeEventArgs^>^ MyDragOver {
    void add (EventHandler<MyDragDropNodeEventArgs^>^ value);
    void remove (EventHandler<MyDragDropNodeEventArgs^>^ value);
}
member MyDragOver : IEvent<EventHandler<MyDragDropNodeEventArgs>,
    MyDragDropNodeEventArgs>

Valore

EventHandler MyDragDropNodeEventArgs
Vedi anche

Documentazione

Classe DedRootExplorerControl
Namespace DedNet.Controls


Evento DedRootExplorerControl.MyMouseDown

Evento DedRootExplorerControlMyMouseDown
Evento per la gestione del movimento del mouse.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<MouseEventArgs> MyMouseDown
Public Event MyMouseDown As EventHandler(Of MouseEventArgs)
public:
 event EventHandler<MouseEventArgs^>^ MyMouseDown {
    void add (EventHandler<MouseEventArgs^>^ value);
    void remove (EventHandler<MouseEventArgs^>^ value);
}
member MyMouseDown : IEvent<EventHandler<MouseEventArgs>,
    MouseEventArgs>

Valore

EventHandler MouseEventArgs
Vedi anche

Documentazione

Classe DedRootExplorerControl
Namespace DedNet.Controls


Evento DedRootExplorerControl.MyMouseMove

Evento DedRootExplorerControlMyMouseMove
Evento per la gestione del movimento del mouse.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<MouseEventArgs> MyMouseMove
Public Event MyMouseMove As EventHandler(Of MouseEventArgs)
public:
 event EventHandler<MouseEventArgs^>^ MyMouseMove {
    void add (EventHandler<MouseEventArgs^>^ value);
    void remove (EventHandler<MouseEventArgs^>^ value);
}
member MyMouseMove : IEvent<EventHandler<MouseEventArgs>,
    MouseEventArgs>

Valore

EventHandler MouseEventArgs
Vedi anche

Documentazione

Classe DedRootExplorerControl
Namespace DedNet.Controls


Evento DedRootExplorerControl.SelectionChanged

Evento DedRootExplorerControlSelectionChanged
Evento generato sul cambio selezione della famiglia da parte dell'utente.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<EventArgs> SelectionChanged
Public Event SelectionChanged As EventHandler(Of EventArgs)
public:
 event EventHandler<EventArgs^>^ SelectionChanged {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}
member SelectionChanged : IEvent<EventHandler<EventArgs>,
    EventArgs>

Valore

EventHandler EventArgs
Vedi anche

Documentazione

Classe DedRootExplorerControl
Namespace DedNet.Controls


Campi di DedRootExplorerControl

Il tipo DedRootExplorerControl espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | _app | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Campo protetto | _RegistryBaseKey | Chiave nel registro di sistema di salvataggio impostazioni. (Ereditato da UserControlBase)
Torna su
Vedi anche

Documentazione

Classe DedRootExplorerControl
Namespace DedNet.Controls


Classe DedSearchControl
Classe rappresentante il controllo per la ricerca
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
XtraUserControl
DedNet.ControlsUserControlBase
DedNet.ControlsDedSearchControl

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedSearchControl : UserControlBase
Public Class DedSearchControl
    Inherits UserControlBase
public ref class DedSearchControl : public UserControlBase
type DedSearchControl =
    class
        inherit UserControlBase
    end

Il tipo DedSearchControl espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedSearchControl | Costruttore della classe.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Appearance | (Ereditato da XtraUserControl)
Proprietà pubblica | Application | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Proprietà pubblica | AttrList | Permette di impostare gli attributi da visualizzare
Proprietà pubblica | BackColor | (Ereditato da XtraUserControl)
Proprietà protetta | CheckDoubleScaling | (Ereditato da XtraUserControl)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraUserControl)
Proprietà protetta | DirectXContainer | (Ereditato da XtraUserControl)
Proprietà pubblica | EnableIXtraResizeableControlInterfaceProxy | (Ereditato da XtraUserControl)
Proprietà pubblica | Filters | Lista di filtri attualemte presenti
Proprietà pubblica | Font | (Ereditato da XtraUserControl)
Proprietà pubblica | ForeColor | (Ereditato da XtraUserControl)
Proprietà pubblica | GroupAttribute | Indica se raggruppare gli attributi in base al loro ambiente.
Proprietà protetta | Helper | (Ereditato da XtraUserControl)
Proprietà pubblica | InnerControl | Restituisce il controllo
Proprietà pubblica | IsFilteredQuery | Indica se nella query sono stati specificati dei criteri di ricerca.
Proprietà pubblica | IsFindOnSearchMode | Indica se la ricerca è eseguita in modalita Individua nella ricerca.
Proprietà pubblica | LookAndFeel | (Ereditato da XtraUserControl)
Proprietà protetta | Painter | (Ereditato da XtraUserControl)
Proprietà pubblica | Query | Comando con la query risultante
Proprietà pubblica | RegistryBaseKey | Restituisce o imposta la chiave dalla quale leggere e nella quale scrivere le impostazioni.
Proprietà pubblica | SaveSearchPath | Path di salvataggio delle ricerche
Proprietà protetta | ScaleChildren | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleDPI | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraUserControl)
Proprietà pubblica | SearchOnDedData | Indica se effettuare le query in DED_DATA ( in caso contrario usa DED_DOC )
Proprietà pubblica | SearchOnErased | Indica se si sta cercando negli eliminati.
Proprietà protetta | ShouldCheckDpiScaleFactorOnParentChanged | (Ereditato da XtraUserControl)
Proprietà pubblica | Site | (Ereditato da XtraUserControl)
Proprietà pubblica | VisibleFields | Lista dei campi visibili ( selezionati con la checkbox )
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | BaseWndProc | (Ereditato da XtraUserControl)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraUserControl)
Metodo protetto | CreatePainter | (Ereditato da XtraUserControl)
Metodo protetto | Dispose | Liberare le risorse in uso. (Sovrascrive UserControlBaseDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraUserControl)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraUserControl)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraUserControl)
Metodo protetto | GetBackColor | (Ereditato da XtraUserControl)
Metodo protetto | GetBackgroundSkinElement | (Ereditato da XtraUserControl)
Metodo protetto | GetInnerIXtraResizableControl | (Ereditato da XtraUserControl)
Metodo protetto | IsChildControlsRequiredScalingEnabled | (Ereditato da XtraUserControl)
Metodo protetto | IsParentHandleCreatedRecursive | (Ereditato da XtraUserControl)
Metodo pubblico | LoadRegistrySettings | Carica dal registro le dimensioni e la visibilità delle colonne.
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraUserControl)
Metodo protetto | OnBackColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnContextMenuOpening | Evento di apertura del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnControlAdded | (Ereditato da XtraUserControl)
Metodo protetto | OnControlRemoved | (Ereditato da XtraUserControl)
Metodo protetto | OnDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnFirstLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnForeColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleCreated | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraUserControl)
Metodo protetto | OnLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnMenuItemClicked | Evento di pressione di un comando del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnPaintCore | (Ereditato da XtraUserControl)
Metodo protetto | OnParentChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | OnSizeChanged | (Ereditato da XtraUserControl)
Metodo protetto | RaisePaintExEvent | (Ereditato da XtraUserControl)
Metodo pubblico | ResetBackColor | (Ereditato da XtraUserControl)
Metodo pubblico | ResetForeColor | (Ereditato da XtraUserControl)
Metodo protetto | RestoreAutoScaleModeChangedByPM2 | (Ereditato da XtraUserControl)
Metodo pubblico | SaveRegistrySettings | Salva nel registro le dimensioni e la visibilità delle colonne.
Metodo protetto | ScaleControl | (Ereditato da XtraUserControl)
Metodo pubblico | SetCommandList | Rigenera il menu contestuale di questo controllo con la lista dei comandi passati. (Ereditato da UserControlBase)
Metodo pubblico | SetFilterOnLoad | Imposta l'EditValue dell'elenco estensioni in modo che parta il filtraggio in apertura.
Metodo protetto | SetVisibleCore | (Ereditato da XtraUserControl)
Metodo protetto | ShouldPaintTransparentBackground | (Ereditato da XtraUserControl)
Metodo protetto | ShouldUseDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | WndProc | (Ereditato da XtraUserControl)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | ChangeVisibleFields |
Evento pubblico | ContextMenuOpening | Evento su apertura del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | MenuItemClicked | Evento su click su un elemento del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | onSearchClick | Evento di pressione sul tasto Cerca.
Evento pubblico | PaintEx | (Ereditato da XtraUserControl)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | _app | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Campo protetto | _RegistryBaseKey | Chiave nel registro di sistema di salvataggio impostazioni. (Ereditato da UserControlBase)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore DedSearchControl
Costruttore della classe.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedSearchControl()
Public Sub New
public:
DedSearchControl()
new : unit -> DedSearchControl
Vedi anche

Documentazione

Classe DedSearchControl
Namespace DedNet.Controls


Proprietà di DedSearchControl

Il tipo DedSearchControl espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Appearance | (Ereditato da XtraUserControl)
Proprietà pubblica | Application | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Proprietà pubblica | AttrList | Permette di impostare gli attributi da visualizzare
Proprietà pubblica | BackColor | (Ereditato da XtraUserControl)
Proprietà protetta | CheckDoubleScaling | (Ereditato da XtraUserControl)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraUserControl)
Proprietà protetta | DirectXContainer | (Ereditato da XtraUserControl)
Proprietà pubblica | EnableIXtraResizeableControlInterfaceProxy | (Ereditato da XtraUserControl)
Proprietà pubblica | Filters | Lista di filtri attualemte presenti
Proprietà pubblica | Font | (Ereditato da XtraUserControl)
Proprietà pubblica | ForeColor | (Ereditato da XtraUserControl)
Proprietà pubblica | GroupAttribute | Indica se raggruppare gli attributi in base al loro ambiente.
Proprietà protetta | Helper | (Ereditato da XtraUserControl)
Proprietà pubblica | InnerControl | Restituisce il controllo
Proprietà pubblica | IsFilteredQuery | Indica se nella query sono stati specificati dei criteri di ricerca.
Proprietà pubblica | IsFindOnSearchMode | Indica se la ricerca è eseguita in modalita Individua nella ricerca.
Proprietà pubblica | LookAndFeel | (Ereditato da XtraUserControl)
Proprietà protetta | Painter | (Ereditato da XtraUserControl)
Proprietà pubblica | Query | Comando con la query risultante
Proprietà pubblica | RegistryBaseKey | Restituisce o imposta la chiave dalla quale leggere e nella quale scrivere le impostazioni.
Proprietà pubblica | SaveSearchPath | Path di salvataggio delle ricerche
Proprietà protetta | ScaleChildren | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleDPI | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraUserControl)
Proprietà pubblica | SearchOnDedData | Indica se effettuare le query in DED_DATA ( in caso contrario usa DED_DOC )
Proprietà pubblica | SearchOnErased | Indica se si sta cercando negli eliminati.
Proprietà protetta | ShouldCheckDpiScaleFactorOnParentChanged | (Ereditato da XtraUserControl)
Proprietà pubblica | Site | (Ereditato da XtraUserControl)
Proprietà pubblica | VisibleFields | Lista dei campi visibili ( selezionati con la checkbox )
Torna su
Vedi anche

Documentazione

Classe DedSearchControl
Namespace DedNet.Controls


Proprietà DedSearchControl.AttrList

Proprietà DedSearchControlAttrList
Permette di impostare gli attributi da visualizzare

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList AttrList { set; }
Public WriteOnly Property AttrList As DedAttrList
    Set
public:
property DedAttrList^ AttrList {
    void set (DedAttrList^ value);
}
member AttrList : DedAttrList with set

Valore della proprietà

DedAttrList
Vedi anche

Documentazione

Classe DedSearchControl
Namespace DedNet.Controls


Proprietà DedSearchControl.Filters

Proprietà DedSearchControlFilters
Lista di filtri attualemte presenti

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public FilterList Filters { get; }
Public ReadOnly Property Filters As FilterList
    Get
public:
property FilterList^ Filters {
    FilterList^ get ();
}
member Filters : FilterList with get

Valore della proprietà

FilterList
Vedi anche

Documentazione

Classe DedSearchControl
Namespace DedNet.Controls


Proprietà DedSearchControl.GroupAttribute

Proprietà DedSearchControlGroupAttribute
Indica se raggruppare gli attributi in base al loro ambiente.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool GroupAttribute { get; set; }
Public Property GroupAttribute As Boolean
    Get
    Set
public:
property bool GroupAttribute {
    bool get ();
    void set (bool value);
}
member GroupAttribute : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedSearchControl
Namespace DedNet.Controls


Proprietà DedSearchControl.InnerControl

Proprietà DedSearchControlInnerControl
Restituisce il controllo

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public GridControl InnerControl { get; }
Public ReadOnly Property InnerControl As GridControl
    Get
public:
property GridControl^ InnerControl {
    GridControl^ get ();
}
member InnerControl : GridControl with get

Valore della proprietà

GridControl
Vedi anche

Documentazione

Classe DedSearchControl
Namespace DedNet.Controls


Proprietà DedSearchControl.IsFilteredQuery

Proprietà DedSearchControlIsFilteredQuery
Indica se nella query sono stati specificati dei criteri di ricerca.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsFilteredQuery { get; set; }
Public Property IsFilteredQuery As Boolean
    Get
    Set
public:
property bool IsFilteredQuery {
    bool get ();
    void set (bool value);
}
member IsFilteredQuery : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedSearchControl
Namespace DedNet.Controls


Proprietà DedSearchControl.IsFindOnSearchMode

Proprietà DedSearchControlIsFindOnSearchMode
Indica se la ricerca è eseguita in modalita Individua nella ricerca.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsFindOnSearchMode { get; set; }
Public Property IsFindOnSearchMode As Boolean
    Get
    Set
public:
property bool IsFindOnSearchMode {
    bool get ();
    void set (bool value);
}
member IsFindOnSearchMode : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedSearchControl
Namespace DedNet.Controls


Proprietà DedSearchControl.Query

Proprietà DedSearchControlQuery
Comando con la query risultante

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public QSSelectCommand Query { get; }
Public ReadOnly Property Query As QSSelectCommand
    Get
public:
property QSSelectCommand^ Query {
    QSSelectCommand^ get ();
}
member Query : QSSelectCommand with get

Valore della proprietà

QSSelectCommand
Vedi anche

Documentazione

Classe DedSearchControl
Namespace DedNet.Controls


Proprietà DedSearchControl.RegistryBaseKey

Proprietà DedSearchControlRegistryBaseKey
Restituisce o imposta la chiave dalla quale leggere e nella quale scrivere le impostazioni.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string RegistryBaseKey { get; set; }
Public Property RegistryBaseKey As String
    Get
    Set
public:
property String^ RegistryBaseKey {
    String^ get ();
    void set (String^ value);
}
member RegistryBaseKey : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedSearchControl
Namespace DedNet.Controls


Proprietà DedSearchControl.SaveSearchPath

Proprietà DedSearchControlSaveSearchPath
Path di salvataggio delle ricerche

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string SaveSearchPath { get; set; }
Public Property SaveSearchPath As String
    Get
    Set
public:
property String^ SaveSearchPath {
    String^ get ();
    void set (String^ value);
}
member SaveSearchPath : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedSearchControl
Namespace DedNet.Controls


Proprietà DedSearchControl.SearchOnDedData

Proprietà DedSearchControlSearchOnDedData
Indica se effettuare le query in DED_DATA ( in caso contrario usa DED_DOC )

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool SearchOnDedData { get; set; }
Public Property SearchOnDedData As Boolean
    Get
    Set
public:
property bool SearchOnDedData {
    bool get ();
    void set (bool value);
}
member SearchOnDedData : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedSearchControl
Namespace DedNet.Controls


Proprietà DedSearchControl.SearchOnErased

Proprietà DedSearchControlSearchOnErased
Indica se si sta cercando negli eliminati.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool SearchOnErased { get; }
Public ReadOnly Property SearchOnErased As Boolean
    Get
public:
property bool SearchOnErased {
    bool get ();
}
member SearchOnErased : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedSearchControl
Namespace DedNet.Controls


Proprietà DedSearchControl.VisibleFields

Proprietà DedSearchControlVisibleFields
Lista dei campi visibili ( selezionati con la checkbox )

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<DedAttr> VisibleFields { get; }
Public ReadOnly Property VisibleFields As List(Of DedAttr)
    Get
public:
property List<DedAttr^>^ VisibleFields {
    List<DedAttr^>^ get ();
}
member VisibleFields : List<DedAttr> with get

Valore della proprietà

List DedAttr
Vedi anche

Documentazione

Classe DedSearchControl
Namespace DedNet.Controls


Metodi di DedSearchControl

Il tipo DedSearchControl espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | BaseWndProc | (Ereditato da XtraUserControl)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraUserControl)
Metodo protetto | CreatePainter | (Ereditato da XtraUserControl)
Metodo protetto | Dispose | Liberare le risorse in uso. (Sovrascrive UserControlBaseDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraUserControl)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraUserControl)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraUserControl)
Metodo protetto | GetBackColor | (Ereditato da XtraUserControl)
Metodo protetto | GetBackgroundSkinElement | (Ereditato da XtraUserControl)
Metodo protetto | GetInnerIXtraResizableControl | (Ereditato da XtraUserControl)
Metodo protetto | IsChildControlsRequiredScalingEnabled | (Ereditato da XtraUserControl)
Metodo protetto | IsParentHandleCreatedRecursive | (Ereditato da XtraUserControl)
Metodo pubblico | LoadRegistrySettings | Carica dal registro le dimensioni e la visibilità delle colonne.
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraUserControl)
Metodo protetto | OnBackColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnContextMenuOpening | Evento di apertura del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnControlAdded | (Ereditato da XtraUserControl)
Metodo protetto | OnControlRemoved | (Ereditato da XtraUserControl)
Metodo protetto | OnDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnFirstLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnForeColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleCreated | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraUserControl)
Metodo protetto | OnLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnMenuItemClicked | Evento di pressione di un comando del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnPaintCore | (Ereditato da XtraUserControl)
Metodo protetto | OnParentChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | OnSizeChanged | (Ereditato da XtraUserControl)
Metodo protetto | RaisePaintExEvent | (Ereditato da XtraUserControl)
Metodo pubblico | ResetBackColor | (Ereditato da XtraUserControl)
Metodo pubblico | ResetForeColor | (Ereditato da XtraUserControl)
Metodo protetto | RestoreAutoScaleModeChangedByPM2 | (Ereditato da XtraUserControl)
Metodo pubblico | SaveRegistrySettings | Salva nel registro le dimensioni e la visibilità delle colonne.
Metodo protetto | ScaleControl | (Ereditato da XtraUserControl)
Metodo pubblico | SetCommandList | Rigenera il menu contestuale di questo controllo con la lista dei comandi passati. (Ereditato da UserControlBase)
Metodo pubblico | SetFilterOnLoad | Imposta l'EditValue dell'elenco estensioni in modo che parta il filtraggio in apertura.
Metodo protetto | SetVisibleCore | (Ereditato da XtraUserControl)
Metodo protetto | ShouldPaintTransparentBackground | (Ereditato da XtraUserControl)
Metodo protetto | ShouldUseDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | WndProc | (Ereditato da XtraUserControl)
Torna su
Vedi anche

Documentazione

Classe DedSearchControl
Namespace DedNet.Controls


Metodo DedSearchControl.Dispose

Metodo DedSearchControlDispose
Liberare le risorse in uso.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
ha valore true se le risorse gestite devono essere eliminate, false in caso contrario.
Vedi anche

Documentazione

Classe DedSearchControl
Namespace DedNet.Controls


Metodo DedSearchControl.LoadRegistrySettings

Metodo DedSearchControlLoadRegistrySettings
Carica dal registro le dimensioni e la visibilità delle colonne.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void LoadRegistrySettings(
    string key
)
Public Sub LoadRegistrySettings (
    key As String
)
public:
void LoadRegistrySettings(
    String^ key
)
member LoadRegistrySettings :
        key : string -> unit

Parametri

key String
Chiave di registro dalla quale leggere le impostazioni.
Vedi anche

Documentazione

Classe DedSearchControl
Namespace DedNet.Controls


Metodo DedSearchControl.SaveRegistrySettings

Metodo DedSearchControlSaveRegistrySettings
Salva nel registro le dimensioni e la visibilità delle colonne.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SaveRegistrySettings(
    string key
)
Public Sub SaveRegistrySettings (
    key As String
)
public:
void SaveRegistrySettings(
    String^ key
)
member SaveRegistrySettings :
        key : string -> unit

Parametri

key String
Chiave di registro nella quale scrivere le impostazioni.
Vedi anche

Documentazione

Classe DedSearchControl
Namespace DedNet.Controls


Metodo DedSearchControl.SetFilterOnLoad

Metodo DedSearchControlSetFilterOnLoad
Imposta l'EditValue dell'elenco estensioni in modo che parta il filtraggio in apertura.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetFilterOnLoad(
    List<string> extensions
)
Public Sub SetFilterOnLoad (
    extensions As List(Of String)
)
public:
void SetFilterOnLoad(
    List<String^>^ extensions
)
member SetFilterOnLoad :
        extensions : List<string> -> unit

Parametri

extensions List String
Estensioni su cui effettuare il filtraggio.
Vedi anche

Documentazione

Classe DedSearchControl
Namespace DedNet.Controls


Eventi di DedSearchControl

Il tipo DedSearchControl espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | ChangeVisibleFields |
Evento pubblico | ContextMenuOpening | Evento su apertura del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | MenuItemClicked | Evento su click su un elemento del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | onSearchClick | Evento di pressione sul tasto Cerca.
Evento pubblico | PaintEx | (Ereditato da XtraUserControl)
Torna su
Vedi anche

Documentazione

Classe DedSearchControl
Namespace DedNet.Controls


Evento DedSearchControl.ChangeVisibleFields

Evento DedSearchControlChangeVisibleFields

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event DedSearchControlChangeVisibleFieldsEventHandler ChangeVisibleFields
Public Event ChangeVisibleFields As DedSearchControlChangeVisibleFieldsEventHandler
public:
 event DedSearchControlChangeVisibleFieldsEventHandler^ ChangeVisibleFields {
    void add (DedSearchControlChangeVisibleFieldsEventHandler^ value);
    void remove (DedSearchControlChangeVisibleFieldsEventHandler^ value);
}
member ChangeVisibleFields : IEvent<DedSearchControlChangeVisibleFieldsEventHandler,
    DedSearchControlChangeVisibleFieldsEventArgs>

Valore

DedSearchControlChangeVisibleFieldsEventHandler
Vedi anche

Documentazione

Classe DedSearchControl
Namespace DedNet.Controls


Evento DedSearchControl.onSearchClick

Evento DedSearchControlonSearchClick
Evento di pressione sul tasto Cerca.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler onSearchClick
Public Event onSearchClick As EventHandler
public:
 event EventHandler^ onSearchClick {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member onSearchClick : IEvent<EventHandler,
    EventArgs>

Valore

EventHandler
Vedi anche

Documentazione

Classe DedSearchControl
Namespace DedNet.Controls


Campi di DedSearchControl

Il tipo DedSearchControl espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | _app | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Campo protetto | _RegistryBaseKey | Chiave nel registro di sistema di salvataggio impostazioni. (Ereditato da UserControlBase)
Torna su
Vedi anche

Documentazione

Classe DedSearchControl
Namespace DedNet.Controls


Classe DedSearchControl.ChangeVisibleFieldsEventArgs

Classe DedSearchControlChangeVisibleFieldsEventArgs
Classe per la gestione dell'event args
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNet.ControlsDedSearchControlChangeVisibleFieldsEventArgs

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ChangeVisibleFieldsEventArgs : EventArgs
Public Class ChangeVisibleFieldsEventArgs
    Inherits EventArgs
public ref class ChangeVisibleFieldsEventArgs : public EventArgs
type ChangeVisibleFieldsEventArgs =
    class
        inherit EventArgs
    end

Il tipo DedSearchControlChangeVisibleFieldsEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedSearchControlChangeVisibleFieldsEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | VisibleFields |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore DedSearchControl.ChangeVisibleFieldsEventArgs

Costruttore DedSearchControlChangeVisibleFieldsEventArgs

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ChangeVisibleFieldsEventArgs()
Public Sub New
public:
ChangeVisibleFieldsEventArgs()
new : unit -> ChangeVisibleFieldsEventArgs
Vedi anche

Documentazione

Classe DedSearchControlChangeVisibleFieldsEventArgs
Namespace DedNet.Controls


Proprietà di ChangeVisibleFieldsEventArgs

Il tipo DedSearchControlChangeVisibleFieldsEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | VisibleFields |
Torna su
Vedi anche

Documentazione

Classe DedSearchControlChangeVisibleFieldsEventArgs
Namespace DedNet.Controls


Proprietà DedSearchControl.ChangeVisibleFieldsEventArgs.VisibleFields

Proprietà DedSearchControlChangeVisibleFieldsEventArgsVisibleFields

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<DedAttr> VisibleFields { get; set; }
Public Property VisibleFields As List(Of DedAttr)
    Get
    Set
public:
property List<DedAttr^>^ VisibleFields {
    List<DedAttr^>^ get ();
    void set (List<DedAttr^>^ value);
}
member VisibleFields : List<DedAttr> with get, set

Valore della proprietà

List DedAttr
Vedi anche

Documentazione

Classe DedSearchControlChangeVisibleFieldsEventArgs
Namespace DedNet.Controls


Delegate DedSearchControl.ChangeVisibleFieldsEventHandler

Delegate DedSearchControlChangeVisibleFieldsEventHandler

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public delegate void ChangeVisibleFieldsEventHandler(
    Object sender,
    DedSearchControlChangeVisibleFieldsEventArgs ev
)
Public Delegate Sub ChangeVisibleFieldsEventHandler (
    sender As Object,
    ev As DedSearchControlChangeVisibleFieldsEventArgs
)
public delegate void ChangeVisibleFieldsEventHandler(
    Object^ sender,
    DedSearchControlChangeVisibleFieldsEventArgs^ ev
)
type ChangeVisibleFieldsEventHandler =
    delegate of
        sender : Object *
        ev : DedSearchControlChangeVisibleFieldsEventArgs -> unit

Parametri

sender Object
ev DedSearchControlChangeVisibleFieldsEventArgs
Vedi anche

Documentazione

Namespace DedNet.Controls


Classe DedSelectedIndexEventArgs
EventArgs dell'evento DedSelectedIndexEvent.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNet.ControlsDedSelectedIndexEventArgs

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedSelectedIndexEventArgs : EventArgs
Public Class DedSelectedIndexEventArgs
    Inherits EventArgs
public ref class DedSelectedIndexEventArgs : public EventArgs
type DedSelectedIndexEventArgs =
    class
        inherit EventArgs
    end

Il tipo DedSelectedIndexEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedSelectedIndexEventArgs | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Selected | Elemento selezionato.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore DedSelectedIndexEventArgs
Costruttore unico.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedSelectedIndexEventArgs(
    DedAttr selected
)
Public Sub New (
    selected As DedAttr
)
public:
DedSelectedIndexEventArgs(
    DedAttr^ selected
)
new :
        selected : DedAttr -> DedSelectedIndexEventArgs

Parametri

selected DedAttr
Elemento selezionato.
Vedi anche

Documentazione

Classe DedSelectedIndexEventArgs
Namespace DedNet.Controls


Proprietà di DedSelectedIndexEventArgs

Il tipo DedSelectedIndexEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Selected | Elemento selezionato.
Torna su
Vedi anche

Documentazione

Classe DedSelectedIndexEventArgs
Namespace DedNet.Controls


Proprietà DedSelectedIndexEventArgs.Selected

Proprietà DedSelectedIndexEventArgsSelected
Elemento selezionato.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttr Selected { get; set; }
Public Property Selected As DedAttr
    Get
    Set
public:
property DedAttr^ Selected {
    DedAttr^ get ();
    void set (DedAttr^ value);
}
member Selected : DedAttr with get, set

Valore della proprietà

DedAttr
Vedi anche

Documentazione

Classe DedSelectedIndexEventArgs
Namespace DedNet.Controls


Classe DedTextSpinEdit
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
XtraControl
ControlBase
BaseControl
BaseEdit
TextEdit
ButtonEdit
PopupBaseEdit
BaseSpinEdit
DedNet.ControlsDedTextSpinEdit

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedTextSpinEdit : BaseSpinEdit
Public Class DedTextSpinEdit
    Inherits BaseSpinEdit
public ref class DedTextSpinEdit : public BaseSpinEdit
type DedTextSpinEdit =
    class
        inherit BaseSpinEdit
    end

Il tipo DedTextSpinEdit espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedTextSpinEdit |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà protetta | AcceptsReturn | (Ereditato da TextEdit)
Proprietà protetta | AcceptsSpace | (Ereditato da TextEdit)
Proprietà protetta | AcceptsTab | (Ereditato da TextEdit)
Proprietà pubblica | AccessibleDefaultActionDescription | (Ereditato da BaseEdit)
Proprietà pubblica | AccessibleDescription | (Ereditato da BaseEdit)
Proprietà pubblica | AccessibleName | (Ereditato da BaseEdit)
Proprietà pubblica | AccessibleRole | (Ereditato da BaseEdit)
Proprietà protetta | AdvancedMode | (Ereditato da TextEdit)
Proprietà protetta | AllowButtonPress | (Ereditato da ButtonEdit)
Proprietà protetta | AllowCloseByEscape | (Ereditato da PopupBaseEdit)
Proprietà protetta | AllowDefaultClearButtonAction | (Ereditato da PopupBaseEdit)
Proprietà protetta | AllowEmptyStringToNullValue | (Ereditato da TextEdit)
Proprietà protetta | AllowFireEditValueChanged | (Ereditato da BaseEdit)
Proprietà protetta | AllowHideClearButtonWhenNotFocused | (Ereditato da PopupBaseEdit)
Proprietà pubblica | AllowHtmlTextInToolTip | (Ereditato da BaseControl)
Proprietà protetta | AllowImmediateClose | (Ereditato da PopupBaseEdit)
Proprietà protetta | AllowPaintBackground | (Ereditato da TextEdit)
Proprietà protetta | AllowPopupTabOut | (Ereditato da PopupBaseEdit)
Proprietà protetta | AllowProcessPaint | (Ereditato da BaseControl)
Proprietà protetta | AllowSmartMouseWheel | (Ereditato da PopupBaseEdit)
Proprietà protetta | AllowTransparency | (Ereditato da TextEdit)
Proprietà protetta | AllowUpdateIsModifiedOnValueChanging | (Ereditato da BaseEdit)
Proprietà protetta | AllowValidateOnEnterKey | (Ereditato da TextEdit)
Proprietà protetta | AltBounds | (Ereditato da PopupBaseEdit)
Proprietà protetta | AutoHideClearButtonWhenNotFocused | (Ereditato da PopupBaseEdit)
Proprietà pubblica | AutoSizeInLayoutControl | (Ereditato da BaseControl)
Proprietà pubblica | BackColor | (Ereditato da TextEdit)
Proprietà pubblica | BackgroundImage | (Ereditato da TextEdit)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da TextEdit)
Proprietà protetta | BaseBorderStyle | (Ereditato da BaseControl)
Proprietà pubblica | BindingManager | (Ereditato da BaseEdit)
Proprietà pubblica | BorderStyle | (Ereditato da BaseEdit)
Proprietà protetta | CanAnimateCore | (Ereditato da BaseControl)
Proprietà pubblica | CanShowDialog | (Ereditato da BaseEdit)
Proprietà protetta | CanShowPopup | (Ereditato da PopupBaseEdit)
Proprietà protetta | CanTabStop | (Ereditato da TextEdit)
Proprietà pubblica | CanUndo | (Ereditato da TextEdit)
Proprietà pubblica | ContextMenu | (Ereditato da BaseEdit)
Proprietà pubblica | ContextMenuStrip | (Ereditato da BaseEdit)
Proprietà protetta | CreateParams | (Ereditato da TextEdit)
Proprietà pubblica | Cursor | (Ereditato da ControlBase)
Proprietà protetta | DefaultCursor | (Ereditato da TextEdit)
Proprietà protetta | DefaultSize | (Ereditato da TextEdit)
Proprietà protetta | DelayedAddContainerControl | (Ereditato da PopupBaseEdit)
Proprietà protetta | DirectXProvider | (Ereditato da XtraControl)
Proprietà protetta | DirectXScroller | (Ereditato da XtraControl)
Proprietà protetta | DXAccessible | (Ereditato da TextEdit)
Proprietà protetta | EditorClassInfo | (Ereditato da BaseEdit)
Proprietà protetta | EditorContainer | (Ereditato da BaseEdit)
Proprietà pubblica | EditorContainsFocus | (Ereditato da PopupBaseEdit)
Proprietà pubblica | EditorTypeName | (Sovrascrive BaseSpinEdit.EditorTypeName)
Proprietà pubblica | EditValue | (Ereditato da BaseEdit)
Proprietà protetta | EditValueDataBindingType | (Ereditato da BaseEdit)
Proprietà protetta | EditViewInfo | (Ereditato da BaseEdit)
Proprietà pubblica | EnterMoveNextControl | (Ereditato da BaseEdit)
Proprietà pubblica | ErrorIcon | (Ereditato da BaseEdit)
Proprietà pubblica | ErrorIconAlignment | (Ereditato da BaseEdit)
Proprietà pubblica | ErrorImageOptions | (Ereditato da BaseEdit)
Proprietà pubblica | ErrorText | (Ereditato da BaseEdit)
Proprietà protetta | EventSender | (Ereditato da BaseEdit)
Proprietà protetta | FocusOnMouseDown | (Ereditato da BaseControl)
Proprietà pubblica | Font | (Ereditato da BaseEdit)
Proprietà protetta | ForceCalcPopupFormSizeByPM2 | (Ereditato da PopupBaseEdit)
Proprietà pubblica | ForeColor | (Ereditato da BaseEdit)
Proprietà protetta | HasAccessible | (Ereditato da BaseControl)
Proprietà protetta | InnerControl | (Ereditato da TextEdit)
Proprietà pubblica | InplaceType | (Ereditato da BaseEdit)
Proprietà protetta | IsAcceptingEditValue | (Ereditato da BaseEdit)
Proprietà protetta | IsAllowMaskBoxPropertiesUpdate | (Ereditato da TextEdit)
Proprietà protetta | IsAllowValidate | (Ereditato da BaseEdit)
Proprietà pubblica | IsDesignMode | (Ereditato da BaseControl)
Proprietà protetta | IsDisposing | (Ereditato da BaseControl)
Proprietà pubblica | IsDrawing | (Ereditato da BaseEdit)
Proprietà pubblica | IsEditorActive | (Ereditato da TextEdit)
Proprietà protetta | IsExistsNullValuePrompt | (Ereditato da TextEdit)
Proprietà protetta | IsLayoutLocked | (Ereditato da BaseEdit)
Proprietà pubblica | IsLoading | (Ereditato da BaseEdit)
Proprietà protetta | IsMaskBoxAvailable | (Ereditato da TextEdit)
Proprietà protetta | IsMaskBoxUpdate | (Ereditato da TextEdit)
Proprietà protetta | IsMatch | (Ereditato da TextEdit)
Proprietà pubblica | IsModified | (Ereditato da BaseEdit)
Proprietà pubblica | IsNeedFocus | (Ereditato da ButtonEdit)
Proprietà protetta | IsNeedHideCursorOnPopup | (Ereditato da PopupBaseEdit)
Proprietà protetta | IsNullValuePromptVisible | (Ereditato da TextEdit)
Proprietà pubblica | IsPopupOpen | (Ereditato da PopupBaseEdit)
Proprietà protetta | IsQueryCloseUpCancelled | (Ereditato da PopupBaseEdit)
Proprietà pubblica | IsRightToLeft | (Ereditato da ControlBase)
Proprietà protetta | IsUpdatingClearButtonVisibility | (Ereditato da PopupBaseEdit)
Proprietà protetta | IsVisualLayoutUpdate | (Ereditato da BaseEdit)
Proprietà protetta | IsWindowsXPStyle | (Ereditato da TextEdit)
Proprietà pubblica | LookAndFeel | (Ereditato da BaseEdit)
Proprietà pubblica | MaskBox | (Ereditato da TextEdit)
Proprietà protetta | MaskBoxInternal | (Ereditato da TextEdit)
Proprietà protetta | Menu | (Ereditato da TextEdit)
Proprietà pubblica | MenuManager | (Ereditato da BaseEdit)
Proprietà protetta | MouseHere | (Ereditato da TextEdit)
Proprietà pubblica | OldEditValue | (Ereditato da BaseEdit)
Proprietà pubblica | Padding | (Ereditato da BaseEdit)
Proprietà protetta | Painter | (Ereditato da BaseEdit)
Proprietà pubblica | PopupCloseMode | (Ereditato da PopupBaseEdit)
Proprietà protetta | PopupForm | (Ereditato da PopupBaseEdit)
Proprietà protetta | PopupShowing | (Ereditato da PopupBaseEdit)
Proprietà protetta | PreferredHeight | (Ereditato da BaseEdit)
Proprietà protetta | ProcessInplaceEditValueChangedEventCore | (Ereditato da PopupBaseEdit)
Proprietà pubblica | Properties |
Proprietà pubblica | ReadOnly | (Ereditato da BaseEdit)
Proprietà protetta | ScaleDPI | (Ereditato da BaseControl)
Proprietà pubblica | ScaleFactor | (Ereditato da BaseControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraControl)
Proprietà pubblica | SelectedText | (Ereditato da TextEdit)
Proprietà pubblica | SelectionLength | (Ereditato da TextEdit)
Proprietà pubblica | SelectionStart | (Ereditato da TextEdit)
Proprietà pubblica | ServiceObject | (Ereditato da BaseEdit)
Proprietà protetta | ShouldDrawBackgroundOnDirectXPaint | (Ereditato da XtraControl)
Proprietà protetta | ShouldNotifyAccessibilityClients | (Ereditato da BaseControl)
Proprietà protetta | ShouldProcessMouseWheelInPopup | (Ereditato da BaseEdit)
Proprietà protetta | ShowKeyboardCuesCore | (Ereditato da BaseControl)
Proprietà pubblica | ShowToolTips | (Ereditato da BaseControl)
Proprietà protetta | ShowToolTipsCore | (Ereditato da BaseEdit)
Proprietà protetta | SizeableIsCaptionVisible | (Ereditato da BaseEdit)
Proprietà protetta | SizeableMaxSize | (Ereditato da BaseControl)
Proprietà protetta | SizeableMinSize | (Ereditato da BaseControl)
Proprietà protetta | SpinTimer | (Ereditato da BaseSpinEdit)
Proprietà protetta | SpinTimerAction | (Ereditato da BaseSpinEdit)
Proprietà pubblica | StyleController | (Ereditato da BaseControl)
Proprietà pubblica | SuperTip | (Ereditato da BaseControl)
Proprietà protetta | SuppressSelectAll | (Ereditato da BaseEdit)
Proprietà pubblica | TabStop | (Ereditato da TextEdit)
Proprietà pubblica | Text | (Ereditato da TextEdit)
Proprietà protetta | TimerDecrementValue | (Ereditato da BaseSpinEdit)
Proprietà protetta | TimerStartValue | (Ereditato da BaseSpinEdit)
Proprietà pubblica | ToolTip | (Ereditato da BaseControl)
Proprietà pubblica | ToolTipAnchor | (Ereditato da BaseEdit)
Proprietà pubblica | ToolTipController | (Ereditato da BaseControl)
Proprietà pubblica | ToolTipIconType | (Ereditato da BaseControl)
Proprietà pubblica | ToolTipTitle | (Ereditato da BaseControl)
Proprietà protetta | UseParentOnTransparentPaintBackground | (Ereditato da TextEdit)
Proprietà protetta | ViewInfo | (Ereditato da ButtonEdit)
Proprietà protetta | WorkingStrategy | (Ereditato da TextEdit)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | AcceptPopupValue | (Ereditato da PopupBaseEdit)
Metodo protetto | AccessibilityNotifyTextChanged | (Ereditato da TextEdit)
Metodo protetto | ActionShowPopup(EditorButtonObjectInfoArgs) | (Ereditato da PopupBaseEdit)
Metodo protetto | ActionShowPopup(Keys) | (Ereditato da PopupBaseEdit)
Metodo pubblico | AllowMouseClick | (Ereditato da PopupBaseEdit)
Metodo pubblico | AppendText | (Ereditato da TextEdit)
Metodo protetto | BaseEditWndProc | (Ereditato da TextEdit)
Metodo protetto | BaseWndProc | (Ereditato da ControlBase)
Metodo protetto | BeginAcceptEditValue | (Ereditato da BaseEdit)
Metodo protetto | BeginClosePopup | (Ereditato da PopupBaseEdit)
Metodo protetto | BeginInternalTextChange | (Ereditato da TextEdit)
Metodo protetto | BeginUpdate | (Ereditato da BaseEdit)
Metodo pubblico | CalcBestSize | (Ereditato da BaseControl)
Metodo protetto | CalcDefaultSizeableMinWidth | (Ereditato da BaseEdit)
Metodo pubblico | CalcMinHeight | (Ereditato da BaseEdit)
Metodo protetto | CalcPopupFormBounds | (Ereditato da PopupBaseEdit)
Metodo protetto | CalcPopupFormSize | (Ereditato da PopupBaseEdit)
Metodo protetto | CalcPopupFormSizeByPM2AfterCreateHandle | (Ereditato da PopupBaseEdit)
Metodo protetto | CalcPreferredHeight | (Ereditato da BaseEdit)
Metodo protetto | CalcSizeableMaxSize | (Ereditato da TextEdit)
Metodo protetto | CalcSizeableMinSize | (Ereditato da TextEdit)
Metodo pubblico | CancelPopup | (Ereditato da BaseSpinEdit)
Metodo protetto | CancelUpdate | (Ereditato da BaseEdit)
Metodo protetto | CanProcessNullInputKeys | (Ereditato da TextEdit)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da TextEdit)
Metodo protetto | CanValidateObjectViaAnnotationAttributes | (Ereditato da BaseEdit)
Metodo protetto | CanValidateValueViaAnnotationAttributes | (Ereditato da BaseEdit)
Metodo protetto | CanValidateViaAnnotationAttributesCore | (Ereditato da BaseEdit)
Metodo protetto | CheckAutoHeight | (Ereditato da BaseEdit)
Metodo protetto | CheckDoubleClick | (Ereditato da BaseEdit)
Metodo protetto | CheckEnabled | (Ereditato da BaseEdit)
Metodo protetto | CheckErrorIcon | (Ereditato da BaseEdit)
Metodo protetto | CheckIfNullString | (Ereditato da TextEdit)
Metodo protetto | CheckMouseHere | (Ereditato da TextEdit)
Metodo protetto | CheckRightToLeft | (Ereditato da ControlBase)
Metodo pubblico | Clear | (Ereditato da TextEdit)
Metodo protetto | ClearHotPressed | (Ereditato da BaseEdit)
Metodo protetto | ClearHotPressed(EditHitInfo) | (Ereditato da BaseEdit)
Metodo protetto | ClearHotPressedCore | (Ereditato da BaseEdit)
Metodo protetto | ClearHotPressedOnLostFocus | (Ereditato da ButtonEdit)
Metodo protetto | ClearPreferredHeight | (Ereditato da BaseEdit)
Metodo pubblico | CloseAutoCompletePopup | (Ereditato da TextEdit)
Metodo pubblico | ClosePopup | (Ereditato da BaseSpinEdit)
Metodo protetto | ClosePopup(PopupCloseMode) | (Ereditato da PopupBaseEdit)
Metodo protetto | CompareEditValue | (Ereditato da BaseEdit)
Metodo protetto | CompareEditValueOnChange | (Ereditato da BaseEdit)
Metodo protetto | CompareFonts | (Ereditato da TextEdit)
Metodo protetto | CompleteChanges | (Ereditato da BaseEdit)
Metodo protetto | ConstrainFormBounds | (Ereditato da PopupBaseEdit)
Metodo protetto | ControlOnGotFocus | (Ereditato da BaseEdit)
Metodo protetto | ControlOnLostFocus | (Ereditato da BaseEdit)
Metodo pubblico | Copy | (Ereditato da TextEdit)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da BaseControl)
Metodo protetto | CreateAccessibleInstance | (Ereditato da BaseEdit)
Metodo protetto | CreateAdvancedStrategy | (Ereditato da TextEdit)
Metodo protetto | CreateCache | (Ereditato da BaseControl)
Metodo protetto | CreateDirectXProvider | (Ereditato da XtraControl)
Metodo protetto | CreateEditController | (Ereditato da TextEdit)
Metodo protetto | CreateEditControllerInstance | (Ereditato da TextEdit)
Metodo protetto | CreateEventSender | (Ereditato da BaseEdit)
Metodo protetto | CreateHandle | (Ereditato da PopupBaseEdit)
Metodo protetto | CreateLookAndFeel | (Ereditato da BaseEdit)
Metodo protetto | CreateMaskBox | (Ereditato da TextEdit)
Metodo protetto | CreateMaskBoxInstance | (Ereditato da TextEdit)
Metodo protetto | CreateMaskManager | (Ereditato da TextEdit)
Metodo protetto | CreateMenu | (Ereditato da TextEdit)
Metodo protetto | CreatePopupForm | (Sovrascrive BaseSpinEdit.CreatePopupForm)
Metodo protetto | CreateRepositoryItem | (Ereditato da BaseEdit)
Metodo protetto | CreateRepositoryItemCore | (Ereditato da BaseEdit)
Metodo pubblico | Cut | (Ereditato da TextEdit)
Metodo protetto | DescaleInteger | (Ereditato da BaseControl)
Metodo pubblico | DeselectAll | (Ereditato da TextEdit)
Metodo protetto | DestroyHandleCore | (Ereditato da BaseEdit)
Metodo protetto | DestroyMaskBox | (Ereditato da TextEdit)
Metodo protetto | DestroyPopupForm | (Ereditato da PopupBaseEdit)
Metodo protetto | DestroyPopupFormCore | (Ereditato da PopupBaseEdit)
Metodo protetto | Dispose | (Ereditato da BaseSpinEdit)
Metodo protetto | DoBaseSetBoundsCore | (Ereditato da BaseEdit)
Metodo protetto | DoClosePopup | (Ereditato da PopupBaseEdit)
Metodo protetto | DoDpiChange | (Ereditato da PopupBaseEdit)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraControl)
Metodo protetto | DoIsMatchValidating | (Ereditato da TextEdit)
Metodo protetto | DoNullInputKeysCore | (Ereditato da PopupBaseEdit)
Metodo protetto | DoShowPopup | (Ereditato da PopupBaseEdit)
Metodo protetto | DoSpin | (Ereditato da TextEdit)
Metodo protetto | DoSynchronizePopupFormControls | (Ereditato da PopupBaseEdit)
Metodo pubblico | DoValidate | (Ereditato da BaseEdit)
Metodo pubblico | DoValidate(PopupCloseMode) | (Ereditato da BaseEdit)
Metodo protetto | DoValidateOnEnterKey | (Ereditato da BaseEdit)
Metodo protetto | EndAcceptEditValue | (Ereditato da BaseEdit)
Metodo protetto | EndClosePopup | (Ereditato da PopupBaseEdit)
Metodo protetto | EndInternalTextChange | (Ereditato da TextEdit)
Metodo protetto | EndUpdate | (Ereditato da BaseEdit)
Metodo protetto | EnsureAnnotationAttributes | (Ereditato da BaseEdit)
Metodo pubblico | EnsureInnerEditorFocused | (Ereditato da TextEdit)
Metodo protetto | ExecInnerEditMouseDown | (Ereditato da ButtonEdit)
Metodo protetto | ExtractParsedValue | (Ereditato da BaseEdit)
Metodo protetto | FireChanged | (Ereditato da BaseControl)
Metodo protetto | FireSpinRequest | (Ereditato da TextEdit)
Metodo protetto | FlushPendingEditActions | (Ereditato da TextEdit)
Metodo pubblico | ForceClosePopup | (Ereditato da PopupBaseEdit)
Metodo protetto | GetAccessibilityObjectById | (Ereditato da TextEdit)
Metodo pubblico | GetAccessible | (Ereditato da BaseControl)
Metodo protetto | GetAccessibleToNotify | (Ereditato da TextEdit)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da BaseControl)
Metodo protetto | GetChangingOldEditValue | (Ereditato da BaseEdit)
Metodo pubblico | GetCharFromPosition | (Ereditato da TextEdit)
Metodo pubblico | GetCharIndexFromPosition | (Ereditato da TextEdit)
Metodo protetto | GetColor(Color, Color) | (Ereditato da BaseControl)
Metodo protetto | GetColor(Color, Color, Boolean) | (Ereditato da BaseControl)
Metodo protetto | GetDeviceSize | (Ereditato da XtraControl)
Metodo protetto | GetDropDownEditorBorderWeight | (Ereditato da PopupBaseEdit)
Metodo protetto | GetDropDownOrigin | (Ereditato da PopupBaseEdit)
Metodo protetto | GetDropDownPadding | (Ereditato da PopupBaseEdit)
Metodo pubblico | GetFirstCharIndexFromLine | (Ereditato da TextEdit)
Metodo pubblico | GetFirstCharIndexOfCurrentLine | (Ereditato da TextEdit)
Metodo pubblico | GetLineFromCharIndex | (Ereditato da TextEdit)
Metodo protetto | GetNullInputKeysValue | (Ereditato da TextEdit)
Metodo protetto | GetObjectToValidate | (Ereditato da BaseEdit)
Metodo pubblico | GetPopupEditForm | (Ereditato da PopupBaseEdit)
Metodo protetto | GetPopupForm | (Ereditato da PopupBaseEdit)
Metodo protetto | GetPopupFormCore | (Ereditato da PopupBaseEdit)
Metodo pubblico | GetPositionFromCharIndex | (Ereditato da TextEdit)
Metodo pubblico | GetPreferredSize | (Ereditato da BaseEdit)
Metodo protetto | GetScaledBounds | (Ereditato da BaseEdit)
Metodo protetto | GetScaleDpiCore | (Ereditato da BaseControl)
Metodo protetto | GetSkinnedCellPadding | (Ereditato da PopupBaseEdit)
Metodo protetto | GetSkinnedEditorBorderWeight | (Ereditato da PopupBaseEdit)
Metodo protetto | GetSpinButton | (Ereditato da BaseSpinEdit)
Metodo protetto | GetTextEditController | (Ereditato da TextEdit)
Metodo protetto | GetToolTipAnchor | (Ereditato da BaseControl)
Metodo protetto | GetToolTipInfo | (Ereditato da BaseEdit)
Metodo protetto | GetUseDirectXPaint | (Ereditato da XtraControl)
Metodo protetto | GetValidationCanceled | (Ereditato da BaseEdit)
Metodo pubblico | GetViewInfo | (Ereditato da BaseControl)
Metodo protetto | HideCaret | (Ereditato da TextEdit)
Metodo protetto | InitializeDefault | (Ereditato da BaseEdit)
Metodo protetto | InitializeDefaultProperties | (Ereditato da BaseEdit)
Metodo pubblico | InnerEditorPaste | (Ereditato da TextEdit)
Metodo pubblico | InnerEditorSpin | (Ereditato da TextEdit)
Metodo protetto | InvalidateFormBoundsByPM2BeforeShow | (Ereditato da PopupBaseEdit)
Metodo protetto | IsAcceptCloseMode | (Ereditato da PopupBaseEdit)
Metodo protetto | IsActionButton | (Ereditato da PopupBaseEdit)
Metodo protetto | IsBindingDataAccessible | (Ereditato da BaseEdit)
Metodo protetto | IsBindingManagerPositionValid | (Ereditato da BaseEdit)
Metodo protetto | IsClearButton | (Ereditato da PopupBaseEdit)
Metodo protetto | IsClearButtonVisible | (Ereditato da PopupBaseEdit)
Metodo pubblico | IsInnerEditorReadOnly | (Ereditato da TextEdit)
Metodo protetto | IsInputChar | (Ereditato da TextEdit)
Metodo protetto | IsInputKey | (Ereditato da TextEdit)
Metodo protetto | IsInputKeyCore | (Ereditato da BaseEdit)
Metodo pubblico | IsNeededCursorKey | (Ereditato da TextEdit)
Metodo protetto | IsNeededExtraKey | (Ereditato da TextEdit)
Metodo pubblico | IsNeededKey | (Ereditato da PopupBaseEdit)
Metodo protetto | IsNullValue | (Ereditato da BaseEdit)
Metodo protetto | IsShowNullValuePrompt | (Ereditato da TextEdit)
Metodo protetto | IsTextCommand | (Ereditato da TextEdit)
Metodo protetto | KeepPopupFormSize | (Ereditato da PopupBaseEdit)
Metodo protetto | LayoutChanged | (Ereditato da TextEdit)
Metodo protetto | LayoutChanged(Boolean) | (Ereditato da TextEdit)
Metodo protetto | LayoutChangedCore | (Ereditato da TextEdit)
Metodo protetto | LayoutChangedCore(Boolean) | (Ereditato da BaseControl)
Metodo protetto | LockEditValueChanged | (Ereditato da BaseEdit)
Metodo protetto | LockMaskBoxPropertiesUpdate | (Ereditato da TextEdit)
Metodo protetto | MaskBoxGetEditValue | (Ereditato da TextEdit)
Metodo protetto | NeedLayoutUpdateValidating | (Ereditato da TextEdit)
Metodo protetto | NotifyAccessibilityClients(AccessibleEvents, Int32, Int32) | (Ereditato da BaseControl)
Metodo protetto | NotifyAccessibilityClients(AccessibleEvents, AutomationElementProvider, Int32, Int32) | (Ereditato da BaseControl)
Metodo protetto | NotifyButtonStateChanged | (Ereditato da ButtonEdit)
Metodo protetto | OnAfterUpdateViewInfo | (Ereditato da TextEdit)
Metodo protetto | OnAppearancePaintChanged | (Ereditato da TextEdit)
Metodo protetto | OnAutoHeightChanged | (Ereditato da BaseEdit)
Metodo protetto | OnBeforeUpdateViewInfo | (Ereditato da TextEdit)
Metodo protetto | OnBorderStyleChanged | (Ereditato da BaseControl)
Metodo protetto | OnCancelEditValueChanging | (Ereditato da BaseEdit)
Metodo protetto | OnClickButton | (Ereditato da BaseSpinEdit)
Metodo protetto | OnClickButtonCore | (Ereditato da ButtonEdit)
Metodo protetto | OnClientSizeChanged | (Ereditato da TextEdit)
Metodo protetto | OnContextMenuChanged | (Ereditato da BaseEdit)
Metodo protetto | OnContextMenuStripChanged | (Ereditato da BaseEdit)
Metodo protetto | OnControllerValueChanged | (Ereditato da TextEdit)
Metodo protetto | OnControllerValueChanging | (Ereditato da TextEdit)
Metodo protetto | OnCreateControl | (Ereditato da TextEdit)
Metodo protetto | OnDefaultPressButton | (Ereditato da PopupBaseEdit)
Metodo protetto | OnDirectXPaintDisabled | (Ereditato da XtraControl)
Metodo protetto | OnDirectXPaintEnabled | (Ereditato da XtraControl)
Metodo protetto | OnEditorEnter | (Ereditato da TextEdit)
Metodo protetto | OnEditorKeyDown | (Ereditato da PopupBaseEdit)
Metodo protetto | OnEditorKeyDownProcessNullInputKeys | (Ereditato da TextEdit)
Metodo protetto | OnEditorKeyPress | (Ereditato da PopupBaseEdit)
Metodo protetto | OnEditorKeyUp | (Ereditato da PopupBaseEdit)
Metodo protetto | OnEditorLeave | (Ereditato da TextEdit)
Metodo protetto | OnEditValueChanged | (Ereditato da PopupBaseEdit)
Metodo protetto | OnEditValueChanging | (Ereditato da TextEdit)
Metodo protetto | OnEnabledChanged | (Ereditato da TextEdit)
Metodo protetto | OnEnableNonMaskedInput | (Ereditato da TextEdit)
Metodo protetto | OnEndIme | (Ereditato da PopupBaseEdit)
Metodo protetto | OnEnter | (Ereditato da TextEdit)
Metodo protetto | OnErrorInfoChanged | (Ereditato da BaseEdit)
Metodo protetto | OnErrorTextChanged | (Ereditato da TextEdit)
Metodo protetto | OnGlassMaskBoxPreWndProc | (Ereditato da TextEdit)
Metodo protetto | OnGlassMaskBoxWndProc | (Ereditato da TextEdit)
Metodo protetto | OnGotCapture | (Ereditato da ControlBase)
Metodo protetto | OnGotFocus | (Ereditato da PopupBaseEdit)
Metodo protetto | OnHandleCreated | (Ereditato da TextEdit)
Metodo protetto | OnHandleDestroyed | (Ereditato da TextEdit)
Metodo protetto | OnImeModeChanged | (Ereditato da TextEdit)
Metodo protetto | OnInvalidValue | (Ereditato da BaseEdit)
Metodo protetto | OnKeyDown | (Ereditato da TextEdit)
Metodo protetto | OnKeyPress | (Ereditato da TextEdit)
Metodo protetto | OnKeyUp | (Ereditato da TextEdit)
Metodo protetto | OnLeave | (Ereditato da TextEdit)
Metodo protetto | OnLoaded | (Ereditato da PopupBaseEdit)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da TextEdit)
Metodo protetto | OnLostCapture | (Ereditato da ControlBase)
Metodo protetto | OnLostFocus | (Ereditato da PopupBaseEdit)
Metodo protetto | OnMaskBox_Click | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_DoubleClick | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_GotFocus | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_KeyDown | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_KeyPress | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_KeyUp | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_LostFocus | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_MouseDown | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_MouseEnter | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_MouseLeave | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_MouseMove | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_MouseUp | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_MouseWheel | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_TextValidated | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_ValueChanged | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_ValueChanging | (Ereditato da TextEdit)
Metodo protetto | OnMaskBoxMouseSelection | (Ereditato da TextEdit)
Metodo protetto | OnMaskBoxPreWndProc | (Ereditato da TextEdit)
Metodo protetto | OnMaskBoxTextResetToNullValuePromptOrNullText | (Ereditato da TextEdit)
Metodo protetto | OnMaskBoxWndProc | (Ereditato da TextEdit)
Metodo protetto | OnMaskEditValueChanging | (Ereditato da TextEdit)
Metodo protetto | OnMouseDown | (Ereditato da PopupBaseEdit)
Metodo protetto | OnMouseDownClosePopup | (Ereditato da PopupBaseEdit)
Metodo protetto | OnMouseEnter | (Ereditato da TextEdit)
Metodo protetto | OnMouseLeave | (Ereditato da TextEdit)
Metodo protetto | OnMouseMove | (Ereditato da TextEdit)
Metodo protetto | OnMouseUp | (Ereditato da BaseSpinEdit)
Metodo protetto | OnMouseWheel | (Ereditato da TextEdit)
Metodo protetto | OnMove | (Ereditato da PopupBaseEdit)
Metodo protetto | OnPaddingChanged | (Ereditato da BaseControl)
Metodo protetto | OnPaint | (Ereditato da TextEdit)
Metodo protetto | OnPaintBackground | (Ereditato da TextEdit)
Metodo protetto | OnParentChanged | (Ereditato da ControlBase)
Metodo protetto | OnParentVisibleChanged | (Ereditato da PopupBaseEdit)
Metodo protetto | OnPopupClosed | (Ereditato da PopupBaseEdit)
Metodo protetto | OnPopupClosing | (Ereditato da PopupBaseEdit)
Metodo protetto | OnPopupFormValueChanged | (Ereditato da PopupBaseEdit)
Metodo protetto | OnPopupShown | (Ereditato da PopupBaseEdit)
Metodo protetto | OnPressButton | (Ereditato da BaseSpinEdit)
Metodo protetto | OnPressSpinDown | (Ereditato da BaseSpinEdit)
Metodo protetto | OnPressSpinUp | (Ereditato da BaseSpinEdit)
Metodo protetto | OnPreviewKeyDown | (Ereditato da TextEdit)
Metodo protetto | OnProperties_PropertiesChanged | (Ereditato da BaseEdit)
Metodo protetto | OnPropertiesChanged | (Ereditato da PopupBaseEdit)
Metodo protetto | OnPropertiesChanged_SyncPopup | (Ereditato da PopupBaseEdit)
Metodo protetto | OnResize | (Ereditato da TextEdit)
Metodo protetto | OnRightToLeftChanged | (Ereditato da PopupBaseEdit)
Metodo protetto | OnRightToLeftChanged(EventArgs) | (Ereditato da ControlBase)
Metodo protetto | OnScaleControl | (Ereditato da BaseEdit)
Metodo protetto | OnScaleDpiChanged | (Ereditato da ControlBase)
Metodo protetto | OnSizeChanged | (Ereditato da TextEdit)
Metodo protetto | OnSpin | (Ereditato da TextEdit)
Metodo protetto | OnSpinTimer_Tick | (Ereditato da BaseSpinEdit)
Metodo protetto | OnStyleController_Disposed | (Ereditato da BaseControl)
Metodo protetto | OnStyleController_PropertiesChanged | (Ereditato da BaseControl)
Metodo protetto | OnStyleControllerChanged | (Ereditato da TextEdit)
Metodo protetto | OnTabStopChanged | (Ereditato da TextEdit)
Metodo protetto | OnTextChanged | (Ereditato da TextEdit)
Metodo protetto | OnTextEditPropertiesChanged | (Ereditato da TextEdit)
Metodo protetto | OnValidated | (Ereditato da TextEdit)
Metodo protetto | OnValidating | (Ereditato da TextEdit)
Metodo protetto | OnValidatingCore | (Ereditato da BaseEdit)
Metodo protetto | OnVisibleChanged | (Ereditato da PopupBaseEdit)
Metodo protetto | PaintErrorIconBackground | (Ereditato da TextEdit)
Metodo protetto | ParseEditorValue | (Ereditato da BaseEdit)
Metodo pubblico | Paste | (Ereditato da TextEdit)
Metodo protetto | PendingEditActionPerformed | (Ereditato da TextEdit)
Metodo pubblico | PerformClick | (Ereditato da ButtonEdit)
Metodo protetto | PerformDefaultClearButtonAction | (Ereditato da PopupBaseEdit)
Metodo protetto | ProcessCmdKey | (Ereditato da TextEdit)
Metodo protetto | ProcessDialogKey | (Ereditato da PopupBaseEdit)
Metodo protetto | ProcessDialogKeyCore | (Ereditato da TextEdit)
Metodo protetto | ProcessPaintAction | (Ereditato da XtraControl)
Metodo protetto | ProcessPopupMouseWheel | (Ereditato da BaseEdit)
Metodo protetto | ProcessPopupTabKey | (Ereditato da PopupBaseEdit)
Metodo protetto | ProcessRemoveWord | (Ereditato da TextEdit)
Metodo protetto | QueryEditorModeFromSkin | (Ereditato da TextEdit)
Metodo protetto | QueryMaskEditValue | (Ereditato da TextEdit)
Metodo protetto | RaiseEditValueChanged | (Ereditato da BaseEdit)
Metodo protetto | RaiseInvalidValue | (Ereditato da BaseEdit)
Metodo protetto | RaiseModified | (Ereditato da BaseEdit)
Metodo protetto | RaisePaintEvent | (Ereditato da TextEdit)
Metodo protetto | RaisePaintExEvent(TextEditPaintExEventArgs) | (Ereditato da TextEdit)
Metodo protetto | RaisePaintExEvent(GraphicsCache, PaintEventArgs) | (Ereditato da XtraControl)
Metodo protetto | RaisePopupAllowClick | (Ereditato da PopupBaseEdit)
Metodo protetto | RaiseQueryAdvancedMode | (Ereditato da TextEdit)
Metodo protetto | RaiseQueryCompletion | (Ereditato da TextEdit)
Metodo protetto | RaiseSizeableChanged | (Ereditato da BaseControl)
Metodo pubblico | Refresh | (Ereditato da BaseControl)
Metodo pubblico | RefreshEditValue | (Ereditato da BaseSpinEdit)
Metodo protetto | RefreshEnabledState | (Ereditato da TextEdit)
Metodo protetto | RefreshPopup | (Ereditato da PopupBaseEdit)
Metodo protetto | RefreshVisualLayout | (Ereditato da BaseEdit)
Metodo protetto | RefreshVisualLayoutCore | (Ereditato da BaseEdit)
Metodo protetto | RejectPopupValue | (Ereditato da PopupBaseEdit)
Metodo protetto | ReleaseDirectXResources | (Ereditato da XtraControl)
Metodo protetto | ReleaseStyleController | (Ereditato da BaseControl)
Metodo protetto | RemoveXtraAnimator | (Ereditato da BaseControl)
Metodo pubblico | Reset | (Ereditato da TextEdit)
Metodo protetto | ResetAccessible | (Ereditato da BaseControl)
Metodo pubblico | ResetBackColor | (Ereditato da BaseEdit)
Metodo protetto | ResetEvents | (Ereditato da BaseEdit)
Metodo pubblico | ResetForeColor | (Ereditato da BaseEdit)
Metodo pubblico | ResetSelection | (Ereditato da TextEdit)
Metodo pubblico | ResetSuperTip | (Ereditato da BaseControl)
Metodo protetto | ScaleControl | (Ereditato da ControlBase)
Metodo protetto | ScaleFont | (Ereditato da TextEdit)
Metodo protetto | ScaleInteger | (Ereditato da BaseControl)
Metodo protetto | ScaleSize | (Ereditato da BaseControl)
Metodo pubblico | ScrollToCaret | (Ereditato da TextEdit)
Metodo protetto | Select(Boolean, Boolean) | (Ereditato da TextEdit)
Metodo pubblico | Select(Int32, Int32) | (Ereditato da TextEdit)
Metodo pubblico | SelectAll | (Ereditato da TextEdit)
Metodo pubblico | SendKey(KeyEventArgs) | (Ereditato da BaseEdit)
Metodo pubblico | SendKey(Object, KeyPressEventArgs) | (Ereditato da BaseEdit)
Metodo pubblico | SendKeyUp | (Ereditato da BaseEdit)
Metodo pubblico | SendMouse(MouseEventArgs) | (Ereditato da BaseEdit)
Metodo pubblico | SendMouse(Point, MouseButtons) | (Ereditato da BaseEdit)
Metodo protetto | SendMouseUp(MouseEventArgs) | (Ereditato da BaseEdit)
Metodo pubblico | SendMouseUp(Point, MouseButtons) | (Ereditato da BaseEdit)
Metodo protetto | SetBackColor | (Ereditato da BaseControl)
Metodo protetto | SetBoundsCore | (Ereditato da BaseEdit)
Metodo protetto | SetEmptyEditValue | (Ereditato da PopupBaseEdit)
Metodo protetto | SetErrorIcon | (Ereditato da BaseEdit)
Metodo protetto | SetPopupEditValueOnClose | (Ereditato da PopupBaseEdit)
Metodo protetto | SetTextCore | (Ereditato da TextEdit)
Metodo protetto | SetVisibleCore | (Ereditato da ControlBase)
Metodo protetto | ShouldSuppressFormDeactivation | (Ereditato da TextEdit)
Metodo protetto | ShouldSuppressTextCommand | (Ereditato da TextEdit)
Metodo pubblico | ShowAutoCompletePopup | (Ereditato da TextEdit)
Metodo protetto | ShowCaret | (Ereditato da TextEdit)
Metodo protetto | ShowMenu | (Ereditato da TextEdit)
Metodo protetto | ShowMenuCore | (Ereditato da TextEdit)
Metodo pubblico | ShowPopup | (Ereditato da BaseSpinEdit)
Metodo protetto | StartSpinTimer | (Ereditato da BaseSpinEdit)
Metodo protetto | StopSpinTimer | (Ereditato da BaseSpinEdit)
Metodo protetto | SubscribePopupFormEvents | (Ereditato da PopupBaseEdit)
Metodo protetto | SuppressMouseWheel | (Ereditato da PopupBaseEdit)
Metodo protetto | SwitchModeAccordingToSkinSettings | (Ereditato da TextEdit)
Metodo protetto | SwitchPopupState | (Ereditato da PopupBaseEdit)
Metodo pubblico | Undo | (Ereditato da TextEdit)
Metodo protetto | UnLockEditValueChanged | (Ereditato da BaseEdit)
Metodo protetto | UnlockMaskBoxPropertiesUpdate | (Ereditato da TextEdit)
Metodo protetto | UpdateClearButtonVisibility | (Ereditato da PopupBaseEdit)
Metodo protetto | UpdateClearButtonVisibilityCore | (Ereditato da PopupBaseEdit)
Metodo protetto | UpdateDisplayText | (Ereditato da TextEdit)
Metodo protetto | UpdateEditControllerProperties | (Ereditato da TextEdit)
Metodo protetto | UpdateEditValueOnClose | (Ereditato da PopupBaseEdit)
Metodo protetto | UpdateFixedHeight | (Ereditato da BaseEdit)
Metodo protetto | UpdateHideSelection | (Ereditato da TextEdit)
Metodo protetto | UpdateInactiveInnerEditorProperties | (Ereditato da TextEdit)
Metodo protetto | UpdateMaskBox | (Ereditato da TextEdit)
Metodo protetto | UpdateMaskBox(Boolean) | (Ereditato da TextEdit)
Metodo protetto | UpdateMaskBoxBounds | (Ereditato da TextEdit)
Metodo protetto | UpdateMaskBoxDisplayText | (Ereditato da TextEdit)
Metodo protetto | UpdateMaskBoxFontByScaleDpi | (Ereditato da TextEdit)
Metodo protetto | UpdateMaskBoxProperties | (Ereditato da TextEdit)
Metodo protetto | UpdateMaskBoxPropertiesCore | (Ereditato da TextEdit)
Metodo protetto | UpdateMenu | (Ereditato da TextEdit)
Metodo protetto | UpdateMenuCoords | (Ereditato da TextEdit)
Metodo protetto | UpdatePasswordChar | (Ereditato da TextEdit)
Metodo protetto | UpdateScaleDpi | (Ereditato da XtraControl)
Metodo protetto | UpdateScaleFactorForScaleHelper | (Ereditato da XtraControl)
Metodo pubblico | UpdateTextHighlight | (Ereditato da TextEdit)
Metodo protetto | UpdateViewInfo | (Ereditato da BaseControl)
Metodo protetto | UpdateViewInfoEditValue | (Ereditato da BaseEdit)
Metodo protetto | UpdateViewInfoState | (Ereditato da BaseControl)
Metodo protetto | UpdateViewInfoState(Boolean) | (Ereditato da BaseControl)
Metodo protetto | UpdateViewInfoState(Boolean, Point) | (Ereditato da BaseControl)
Metodo protetto | WndProc | (Ereditato da PopupBaseEdit)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | BackColorChanged | (Ereditato da BaseEdit)
Evento pubblico | BeforePopup | (Ereditato da PopupBaseEdit)
Evento pubblico | ButtonClick | (Ereditato da ButtonEdit)
Evento pubblico | ButtonPressed | (Ereditato da ButtonEdit)
Evento pubblico | Closed | (Ereditato da BaseSpinEdit)
Evento pubblico | CloseUp | (Ereditato da BaseSpinEdit)
Evento pubblico | CustomDisplayText | (Ereditato da BaseEdit)
Evento pubblico | CustomHighlightText | (Ereditato da TextEdit)
Evento pubblico | CustomizeAutoCompleteSource | (Ereditato da TextEdit)
Evento pubblico | CustomTextLineHeight | (Ereditato da TextEdit)
Evento pubblico | EditValueChanged | (Ereditato da BaseEdit)
Evento pubblico | EditValueChanging | (Ereditato da BaseEdit)
Evento pubblico | FontChanged | (Ereditato da BaseEdit)
Evento pubblico | ForeColorChanged | (Ereditato da BaseEdit)
Evento pubblico | FormatEditValue | (Ereditato da BaseEdit)
Evento pubblico | InvalidValue | (Ereditato da BaseEdit)
Evento pubblico | Modified | (Ereditato da BaseEdit)
Evento pubblico | PaintEx | (Ereditato da TextEdit)
Evento pubblico | ParseEditValue | (Ereditato da BaseEdit)
Evento pubblico | Popup | (Ereditato da BaseSpinEdit)
Evento pubblico | PopupAllowClick | (Ereditato da PopupBaseEdit)
Evento pubblico | PropertiesChanged | (Ereditato da BaseEdit)
Evento pubblico | QueryAccessibilityHelp | (Ereditato da BaseEdit)
Evento pubblico | QueryCloseUp | (Ereditato da BaseSpinEdit)
Evento pubblico | QueryPopUp | (Ereditato da BaseSpinEdit)
Evento pubblico | QueryProcessKey | (Ereditato da BaseEdit)
Evento pubblico | Spin | (Ereditato da TextEdit)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | fDisposing | (Ereditato da BaseControl)
Campo protetto | fEditValue | (Ereditato da BaseEdit)
Campo protetto | fOldEditValue | (Ereditato da BaseEdit)
Campo protetto | fProperties | (Ereditato da BaseEdit)
Campo protetto | fShowToolTips | (Ereditato da BaseControl)
Campo protetto | lastChangedEditValue | (Ereditato da BaseEdit)
Campo protetto | shouldRaiseSizeableChanged | (Ereditato da BaseControl)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore DedTextSpinEdit

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTextSpinEdit()
Public Sub New
public:
DedTextSpinEdit()
new : unit -> DedTextSpinEdit
Vedi anche

Documentazione

Classe DedTextSpinEdit
Namespace DedNet.Controls


Proprietà di DedTextSpinEdit

Il tipo DedTextSpinEdit espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà protetta | AcceptsReturn | (Ereditato da TextEdit)
Proprietà protetta | AcceptsSpace | (Ereditato da TextEdit)
Proprietà protetta | AcceptsTab | (Ereditato da TextEdit)
Proprietà pubblica | AccessibleDefaultActionDescription | (Ereditato da BaseEdit)
Proprietà pubblica | AccessibleDescription | (Ereditato da BaseEdit)
Proprietà pubblica | AccessibleName | (Ereditato da BaseEdit)
Proprietà pubblica | AccessibleRole | (Ereditato da BaseEdit)
Proprietà protetta | AdvancedMode | (Ereditato da TextEdit)
Proprietà protetta | AllowButtonPress | (Ereditato da ButtonEdit)
Proprietà protetta | AllowCloseByEscape | (Ereditato da PopupBaseEdit)
Proprietà protetta | AllowDefaultClearButtonAction | (Ereditato da PopupBaseEdit)
Proprietà protetta | AllowEmptyStringToNullValue | (Ereditato da TextEdit)
Proprietà protetta | AllowFireEditValueChanged | (Ereditato da BaseEdit)
Proprietà protetta | AllowHideClearButtonWhenNotFocused | (Ereditato da PopupBaseEdit)
Proprietà pubblica | AllowHtmlTextInToolTip | (Ereditato da BaseControl)
Proprietà protetta | AllowImmediateClose | (Ereditato da PopupBaseEdit)
Proprietà protetta | AllowPaintBackground | (Ereditato da TextEdit)
Proprietà protetta | AllowPopupTabOut | (Ereditato da PopupBaseEdit)
Proprietà protetta | AllowProcessPaint | (Ereditato da BaseControl)
Proprietà protetta | AllowSmartMouseWheel | (Ereditato da PopupBaseEdit)
Proprietà protetta | AllowTransparency | (Ereditato da TextEdit)
Proprietà protetta | AllowUpdateIsModifiedOnValueChanging | (Ereditato da BaseEdit)
Proprietà protetta | AllowValidateOnEnterKey | (Ereditato da TextEdit)
Proprietà protetta | AltBounds | (Ereditato da PopupBaseEdit)
Proprietà protetta | AutoHideClearButtonWhenNotFocused | (Ereditato da PopupBaseEdit)
Proprietà pubblica | AutoSizeInLayoutControl | (Ereditato da BaseControl)
Proprietà pubblica | BackColor | (Ereditato da TextEdit)
Proprietà pubblica | BackgroundImage | (Ereditato da TextEdit)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da TextEdit)
Proprietà protetta | BaseBorderStyle | (Ereditato da BaseControl)
Proprietà pubblica | BindingManager | (Ereditato da BaseEdit)
Proprietà pubblica | BorderStyle | (Ereditato da BaseEdit)
Proprietà protetta | CanAnimateCore | (Ereditato da BaseControl)
Proprietà pubblica | CanShowDialog | (Ereditato da BaseEdit)
Proprietà protetta | CanShowPopup | (Ereditato da PopupBaseEdit)
Proprietà protetta | CanTabStop | (Ereditato da TextEdit)
Proprietà pubblica | CanUndo | (Ereditato da TextEdit)
Proprietà pubblica | ContextMenu | (Ereditato da BaseEdit)
Proprietà pubblica | ContextMenuStrip | (Ereditato da BaseEdit)
Proprietà protetta | CreateParams | (Ereditato da TextEdit)
Proprietà pubblica | Cursor | (Ereditato da ControlBase)
Proprietà protetta | DefaultCursor | (Ereditato da TextEdit)
Proprietà protetta | DefaultSize | (Ereditato da TextEdit)
Proprietà protetta | DelayedAddContainerControl | (Ereditato da PopupBaseEdit)
Proprietà protetta | DirectXProvider | (Ereditato da XtraControl)
Proprietà protetta | DirectXScroller | (Ereditato da XtraControl)
Proprietà protetta | DXAccessible | (Ereditato da TextEdit)
Proprietà protetta | EditorClassInfo | (Ereditato da BaseEdit)
Proprietà protetta | EditorContainer | (Ereditato da BaseEdit)
Proprietà pubblica | EditorContainsFocus | (Ereditato da PopupBaseEdit)
Proprietà pubblica | EditorTypeName | (Sovrascrive BaseSpinEdit.EditorTypeName)
Proprietà pubblica | EditValue | (Ereditato da BaseEdit)
Proprietà protetta | EditValueDataBindingType | (Ereditato da BaseEdit)
Proprietà protetta | EditViewInfo | (Ereditato da BaseEdit)
Proprietà pubblica | EnterMoveNextControl | (Ereditato da BaseEdit)
Proprietà pubblica | ErrorIcon | (Ereditato da BaseEdit)
Proprietà pubblica | ErrorIconAlignment | (Ereditato da BaseEdit)
Proprietà pubblica | ErrorImageOptions | (Ereditato da BaseEdit)
Proprietà pubblica | ErrorText | (Ereditato da BaseEdit)
Proprietà protetta | EventSender | (Ereditato da BaseEdit)
Proprietà protetta | FocusOnMouseDown | (Ereditato da BaseControl)
Proprietà pubblica | Font | (Ereditato da BaseEdit)
Proprietà protetta | ForceCalcPopupFormSizeByPM2 | (Ereditato da PopupBaseEdit)
Proprietà pubblica | ForeColor | (Ereditato da BaseEdit)
Proprietà protetta | HasAccessible | (Ereditato da BaseControl)
Proprietà protetta | InnerControl | (Ereditato da TextEdit)
Proprietà pubblica | InplaceType | (Ereditato da BaseEdit)
Proprietà protetta | IsAcceptingEditValue | (Ereditato da BaseEdit)
Proprietà protetta | IsAllowMaskBoxPropertiesUpdate | (Ereditato da TextEdit)
Proprietà protetta | IsAllowValidate | (Ereditato da BaseEdit)
Proprietà pubblica | IsDesignMode | (Ereditato da BaseControl)
Proprietà protetta | IsDisposing | (Ereditato da BaseControl)
Proprietà pubblica | IsDrawing | (Ereditato da BaseEdit)
Proprietà pubblica | IsEditorActive | (Ereditato da TextEdit)
Proprietà protetta | IsExistsNullValuePrompt | (Ereditato da TextEdit)
Proprietà protetta | IsLayoutLocked | (Ereditato da BaseEdit)
Proprietà pubblica | IsLoading | (Ereditato da BaseEdit)
Proprietà protetta | IsMaskBoxAvailable | (Ereditato da TextEdit)
Proprietà protetta | IsMaskBoxUpdate | (Ereditato da TextEdit)
Proprietà protetta | IsMatch | (Ereditato da TextEdit)
Proprietà pubblica | IsModified | (Ereditato da BaseEdit)
Proprietà pubblica | IsNeedFocus | (Ereditato da ButtonEdit)
Proprietà protetta | IsNeedHideCursorOnPopup | (Ereditato da PopupBaseEdit)
Proprietà protetta | IsNullValuePromptVisible | (Ereditato da TextEdit)
Proprietà pubblica | IsPopupOpen | (Ereditato da PopupBaseEdit)
Proprietà protetta | IsQueryCloseUpCancelled | (Ereditato da PopupBaseEdit)
Proprietà pubblica | IsRightToLeft | (Ereditato da ControlBase)
Proprietà protetta | IsUpdatingClearButtonVisibility | (Ereditato da PopupBaseEdit)
Proprietà protetta | IsVisualLayoutUpdate | (Ereditato da BaseEdit)
Proprietà protetta | IsWindowsXPStyle | (Ereditato da TextEdit)
Proprietà pubblica | LookAndFeel | (Ereditato da BaseEdit)
Proprietà pubblica | MaskBox | (Ereditato da TextEdit)
Proprietà protetta | MaskBoxInternal | (Ereditato da TextEdit)
Proprietà protetta | Menu | (Ereditato da TextEdit)
Proprietà pubblica | MenuManager | (Ereditato da BaseEdit)
Proprietà protetta | MouseHere | (Ereditato da TextEdit)
Proprietà pubblica | OldEditValue | (Ereditato da BaseEdit)
Proprietà pubblica | Padding | (Ereditato da BaseEdit)
Proprietà protetta | Painter | (Ereditato da BaseEdit)
Proprietà pubblica | PopupCloseMode | (Ereditato da PopupBaseEdit)
Proprietà protetta | PopupForm | (Ereditato da PopupBaseEdit)
Proprietà protetta | PopupShowing | (Ereditato da PopupBaseEdit)
Proprietà protetta | PreferredHeight | (Ereditato da BaseEdit)
Proprietà protetta | ProcessInplaceEditValueChangedEventCore | (Ereditato da PopupBaseEdit)
Proprietà pubblica | Properties |
Proprietà pubblica | ReadOnly | (Ereditato da BaseEdit)
Proprietà protetta | ScaleDPI | (Ereditato da BaseControl)
Proprietà pubblica | ScaleFactor | (Ereditato da BaseControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraControl)
Proprietà pubblica | SelectedText | (Ereditato da TextEdit)
Proprietà pubblica | SelectionLength | (Ereditato da TextEdit)
Proprietà pubblica | SelectionStart | (Ereditato da TextEdit)
Proprietà pubblica | ServiceObject | (Ereditato da BaseEdit)
Proprietà protetta | ShouldDrawBackgroundOnDirectXPaint | (Ereditato da XtraControl)
Proprietà protetta | ShouldNotifyAccessibilityClients | (Ereditato da BaseControl)
Proprietà protetta | ShouldProcessMouseWheelInPopup | (Ereditato da BaseEdit)
Proprietà protetta | ShowKeyboardCuesCore | (Ereditato da BaseControl)
Proprietà pubblica | ShowToolTips | (Ereditato da BaseControl)
Proprietà protetta | ShowToolTipsCore | (Ereditato da BaseEdit)
Proprietà protetta | SizeableIsCaptionVisible | (Ereditato da BaseEdit)
Proprietà protetta | SizeableMaxSize | (Ereditato da BaseControl)
Proprietà protetta | SizeableMinSize | (Ereditato da BaseControl)
Proprietà protetta | SpinTimer | (Ereditato da BaseSpinEdit)
Proprietà protetta | SpinTimerAction | (Ereditato da BaseSpinEdit)
Proprietà pubblica | StyleController | (Ereditato da BaseControl)
Proprietà pubblica | SuperTip | (Ereditato da BaseControl)
Proprietà protetta | SuppressSelectAll | (Ereditato da BaseEdit)
Proprietà pubblica | TabStop | (Ereditato da TextEdit)
Proprietà pubblica | Text | (Ereditato da TextEdit)
Proprietà protetta | TimerDecrementValue | (Ereditato da BaseSpinEdit)
Proprietà protetta | TimerStartValue | (Ereditato da BaseSpinEdit)
Proprietà pubblica | ToolTip | (Ereditato da BaseControl)
Proprietà pubblica | ToolTipAnchor | (Ereditato da BaseEdit)
Proprietà pubblica | ToolTipController | (Ereditato da BaseControl)
Proprietà pubblica | ToolTipIconType | (Ereditato da BaseControl)
Proprietà pubblica | ToolTipTitle | (Ereditato da BaseControl)
Proprietà protetta | UseParentOnTransparentPaintBackground | (Ereditato da TextEdit)
Proprietà protetta | ViewInfo | (Ereditato da ButtonEdit)
Proprietà protetta | WorkingStrategy | (Ereditato da TextEdit)
Torna su
Vedi anche

Documentazione

Classe DedTextSpinEdit
Namespace DedNet.Controls


Proprietà DedTextSpinEdit.EditorTypeName

Proprietà DedTextSpinEditEditorTypeName

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string EditorTypeName { get; }
Public Overrides ReadOnly Property EditorTypeName As String
    Get
public:
virtual property String^ EditorTypeName {
    String^ get () override;
}
abstract EditorTypeName : string with get
override EditorTypeName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedTextSpinEdit
Namespace DedNet.Controls


Proprietà DedTextSpinEdit.Properties

Proprietà DedTextSpinEditProperties

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public RepositoryItemDedTextSpinEdit Properties { get; }
Public ReadOnly Property Properties As RepositoryItemDedTextSpinEdit
    Get
public:
property RepositoryItemDedTextSpinEdit^ Properties {
    RepositoryItemDedTextSpinEdit^ get ();
}
member Properties : RepositoryItemDedTextSpinEdit with get

Valore della proprietà

RepositoryItemDedTextSpinEdit
Vedi anche

Documentazione

Classe DedTextSpinEdit
Namespace DedNet.Controls


Metodi di DedTextSpinEdit

Il tipo DedTextSpinEdit espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | AcceptPopupValue | (Ereditato da PopupBaseEdit)
Metodo protetto | AccessibilityNotifyTextChanged | (Ereditato da TextEdit)
Metodo protetto | ActionShowPopup(EditorButtonObjectInfoArgs) | (Ereditato da PopupBaseEdit)
Metodo protetto | ActionShowPopup(Keys) | (Ereditato da PopupBaseEdit)
Metodo pubblico | AllowMouseClick | (Ereditato da PopupBaseEdit)
Metodo pubblico | AppendText | (Ereditato da TextEdit)
Metodo protetto | BaseEditWndProc | (Ereditato da TextEdit)
Metodo protetto | BaseWndProc | (Ereditato da ControlBase)
Metodo protetto | BeginAcceptEditValue | (Ereditato da BaseEdit)
Metodo protetto | BeginClosePopup | (Ereditato da PopupBaseEdit)
Metodo protetto | BeginInternalTextChange | (Ereditato da TextEdit)
Metodo protetto | BeginUpdate | (Ereditato da BaseEdit)
Metodo pubblico | CalcBestSize | (Ereditato da BaseControl)
Metodo protetto | CalcDefaultSizeableMinWidth | (Ereditato da BaseEdit)
Metodo pubblico | CalcMinHeight | (Ereditato da BaseEdit)
Metodo protetto | CalcPopupFormBounds | (Ereditato da PopupBaseEdit)
Metodo protetto | CalcPopupFormSize | (Ereditato da PopupBaseEdit)
Metodo protetto | CalcPopupFormSizeByPM2AfterCreateHandle | (Ereditato da PopupBaseEdit)
Metodo protetto | CalcPreferredHeight | (Ereditato da BaseEdit)
Metodo protetto | CalcSizeableMaxSize | (Ereditato da TextEdit)
Metodo protetto | CalcSizeableMinSize | (Ereditato da TextEdit)
Metodo pubblico | CancelPopup | (Ereditato da BaseSpinEdit)
Metodo protetto | CancelUpdate | (Ereditato da BaseEdit)
Metodo protetto | CanProcessNullInputKeys | (Ereditato da TextEdit)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da TextEdit)
Metodo protetto | CanValidateObjectViaAnnotationAttributes | (Ereditato da BaseEdit)
Metodo protetto | CanValidateValueViaAnnotationAttributes | (Ereditato da BaseEdit)
Metodo protetto | CanValidateViaAnnotationAttributesCore | (Ereditato da BaseEdit)
Metodo protetto | CheckAutoHeight | (Ereditato da BaseEdit)
Metodo protetto | CheckDoubleClick | (Ereditato da BaseEdit)
Metodo protetto | CheckEnabled | (Ereditato da BaseEdit)
Metodo protetto | CheckErrorIcon | (Ereditato da BaseEdit)
Metodo protetto | CheckIfNullString | (Ereditato da TextEdit)
Metodo protetto | CheckMouseHere | (Ereditato da TextEdit)
Metodo protetto | CheckRightToLeft | (Ereditato da ControlBase)
Metodo pubblico | Clear | (Ereditato da TextEdit)
Metodo protetto | ClearHotPressed | (Ereditato da BaseEdit)
Metodo protetto | ClearHotPressed(EditHitInfo) | (Ereditato da BaseEdit)
Metodo protetto | ClearHotPressedCore | (Ereditato da BaseEdit)
Metodo protetto | ClearHotPressedOnLostFocus | (Ereditato da ButtonEdit)
Metodo protetto | ClearPreferredHeight | (Ereditato da BaseEdit)
Metodo pubblico | CloseAutoCompletePopup | (Ereditato da TextEdit)
Metodo pubblico | ClosePopup | (Ereditato da BaseSpinEdit)
Metodo protetto | ClosePopup(PopupCloseMode) | (Ereditato da PopupBaseEdit)
Metodo protetto | CompareEditValue | (Ereditato da BaseEdit)
Metodo protetto | CompareEditValueOnChange | (Ereditato da BaseEdit)
Metodo protetto | CompareFonts | (Ereditato da TextEdit)
Metodo protetto | CompleteChanges | (Ereditato da BaseEdit)
Metodo protetto | ConstrainFormBounds | (Ereditato da PopupBaseEdit)
Metodo protetto | ControlOnGotFocus | (Ereditato da BaseEdit)
Metodo protetto | ControlOnLostFocus | (Ereditato da BaseEdit)
Metodo pubblico | Copy | (Ereditato da TextEdit)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da BaseControl)
Metodo protetto | CreateAccessibleInstance | (Ereditato da BaseEdit)
Metodo protetto | CreateAdvancedStrategy | (Ereditato da TextEdit)
Metodo protetto | CreateCache | (Ereditato da BaseControl)
Metodo protetto | CreateDirectXProvider | (Ereditato da XtraControl)
Metodo protetto | CreateEditController | (Ereditato da TextEdit)
Metodo protetto | CreateEditControllerInstance | (Ereditato da TextEdit)
Metodo protetto | CreateEventSender | (Ereditato da BaseEdit)
Metodo protetto | CreateHandle | (Ereditato da PopupBaseEdit)
Metodo protetto | CreateLookAndFeel | (Ereditato da BaseEdit)
Metodo protetto | CreateMaskBox | (Ereditato da TextEdit)
Metodo protetto | CreateMaskBoxInstance | (Ereditato da TextEdit)
Metodo protetto | CreateMaskManager | (Ereditato da TextEdit)
Metodo protetto | CreateMenu | (Ereditato da TextEdit)
Metodo protetto | CreatePopupForm | (Sovrascrive BaseSpinEdit.CreatePopupForm)
Metodo protetto | CreateRepositoryItem | (Ereditato da BaseEdit)
Metodo protetto | CreateRepositoryItemCore | (Ereditato da BaseEdit)
Metodo pubblico | Cut | (Ereditato da TextEdit)
Metodo protetto | DescaleInteger | (Ereditato da BaseControl)
Metodo pubblico | DeselectAll | (Ereditato da TextEdit)
Metodo protetto | DestroyHandleCore | (Ereditato da BaseEdit)
Metodo protetto | DestroyMaskBox | (Ereditato da TextEdit)
Metodo protetto | DestroyPopupForm | (Ereditato da PopupBaseEdit)
Metodo protetto | DestroyPopupFormCore | (Ereditato da PopupBaseEdit)
Metodo protetto | Dispose | (Ereditato da BaseSpinEdit)
Metodo protetto | DoBaseSetBoundsCore | (Ereditato da BaseEdit)
Metodo protetto | DoClosePopup | (Ereditato da PopupBaseEdit)
Metodo protetto | DoDpiChange | (Ereditato da PopupBaseEdit)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraControl)
Metodo protetto | DoIsMatchValidating | (Ereditato da TextEdit)
Metodo protetto | DoNullInputKeysCore | (Ereditato da PopupBaseEdit)
Metodo protetto | DoShowPopup | (Ereditato da PopupBaseEdit)
Metodo protetto | DoSpin | (Ereditato da TextEdit)
Metodo protetto | DoSynchronizePopupFormControls | (Ereditato da PopupBaseEdit)
Metodo pubblico | DoValidate | (Ereditato da BaseEdit)
Metodo pubblico | DoValidate(PopupCloseMode) | (Ereditato da BaseEdit)
Metodo protetto | DoValidateOnEnterKey | (Ereditato da BaseEdit)
Metodo protetto | EndAcceptEditValue | (Ereditato da BaseEdit)
Metodo protetto | EndClosePopup | (Ereditato da PopupBaseEdit)
Metodo protetto | EndInternalTextChange | (Ereditato da TextEdit)
Metodo protetto | EndUpdate | (Ereditato da BaseEdit)
Metodo protetto | EnsureAnnotationAttributes | (Ereditato da BaseEdit)
Metodo pubblico | EnsureInnerEditorFocused | (Ereditato da TextEdit)
Metodo protetto | ExecInnerEditMouseDown | (Ereditato da ButtonEdit)
Metodo protetto | ExtractParsedValue | (Ereditato da BaseEdit)
Metodo protetto | FireChanged | (Ereditato da BaseControl)
Metodo protetto | FireSpinRequest | (Ereditato da TextEdit)
Metodo protetto | FlushPendingEditActions | (Ereditato da TextEdit)
Metodo pubblico | ForceClosePopup | (Ereditato da PopupBaseEdit)
Metodo protetto | GetAccessibilityObjectById | (Ereditato da TextEdit)
Metodo pubblico | GetAccessible | (Ereditato da BaseControl)
Metodo protetto | GetAccessibleToNotify | (Ereditato da TextEdit)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da BaseControl)
Metodo protetto | GetChangingOldEditValue | (Ereditato da BaseEdit)
Metodo pubblico | GetCharFromPosition | (Ereditato da TextEdit)
Metodo pubblico | GetCharIndexFromPosition | (Ereditato da TextEdit)
Metodo protetto | GetColor(Color, Color) | (Ereditato da BaseControl)
Metodo protetto | GetColor(Color, Color, Boolean) | (Ereditato da BaseControl)
Metodo protetto | GetDeviceSize | (Ereditato da XtraControl)
Metodo protetto | GetDropDownEditorBorderWeight | (Ereditato da PopupBaseEdit)
Metodo protetto | GetDropDownOrigin | (Ereditato da PopupBaseEdit)
Metodo protetto | GetDropDownPadding | (Ereditato da PopupBaseEdit)
Metodo pubblico | GetFirstCharIndexFromLine | (Ereditato da TextEdit)
Metodo pubblico | GetFirstCharIndexOfCurrentLine | (Ereditato da TextEdit)
Metodo pubblico | GetLineFromCharIndex | (Ereditato da TextEdit)
Metodo protetto | GetNullInputKeysValue | (Ereditato da TextEdit)
Metodo protetto | GetObjectToValidate | (Ereditato da BaseEdit)
Metodo pubblico | GetPopupEditForm | (Ereditato da PopupBaseEdit)
Metodo protetto | GetPopupForm | (Ereditato da PopupBaseEdit)
Metodo protetto | GetPopupFormCore | (Ereditato da PopupBaseEdit)
Metodo pubblico | GetPositionFromCharIndex | (Ereditato da TextEdit)
Metodo pubblico | GetPreferredSize | (Ereditato da BaseEdit)
Metodo protetto | GetScaledBounds | (Ereditato da BaseEdit)
Metodo protetto | GetScaleDpiCore | (Ereditato da BaseControl)
Metodo protetto | GetSkinnedCellPadding | (Ereditato da PopupBaseEdit)
Metodo protetto | GetSkinnedEditorBorderWeight | (Ereditato da PopupBaseEdit)
Metodo protetto | GetSpinButton | (Ereditato da BaseSpinEdit)
Metodo protetto | GetTextEditController | (Ereditato da TextEdit)
Metodo protetto | GetToolTipAnchor | (Ereditato da BaseControl)
Metodo protetto | GetToolTipInfo | (Ereditato da BaseEdit)
Metodo protetto | GetUseDirectXPaint | (Ereditato da XtraControl)
Metodo protetto | GetValidationCanceled | (Ereditato da BaseEdit)
Metodo pubblico | GetViewInfo | (Ereditato da BaseControl)
Metodo protetto | HideCaret | (Ereditato da TextEdit)
Metodo protetto | InitializeDefault | (Ereditato da BaseEdit)
Metodo protetto | InitializeDefaultProperties | (Ereditato da BaseEdit)
Metodo pubblico | InnerEditorPaste | (Ereditato da TextEdit)
Metodo pubblico | InnerEditorSpin | (Ereditato da TextEdit)
Metodo protetto | InvalidateFormBoundsByPM2BeforeShow | (Ereditato da PopupBaseEdit)
Metodo protetto | IsAcceptCloseMode | (Ereditato da PopupBaseEdit)
Metodo protetto | IsActionButton | (Ereditato da PopupBaseEdit)
Metodo protetto | IsBindingDataAccessible | (Ereditato da BaseEdit)
Metodo protetto | IsBindingManagerPositionValid | (Ereditato da BaseEdit)
Metodo protetto | IsClearButton | (Ereditato da PopupBaseEdit)
Metodo protetto | IsClearButtonVisible | (Ereditato da PopupBaseEdit)
Metodo pubblico | IsInnerEditorReadOnly | (Ereditato da TextEdit)
Metodo protetto | IsInputChar | (Ereditato da TextEdit)
Metodo protetto | IsInputKey | (Ereditato da TextEdit)
Metodo protetto | IsInputKeyCore | (Ereditato da BaseEdit)
Metodo pubblico | IsNeededCursorKey | (Ereditato da TextEdit)
Metodo protetto | IsNeededExtraKey | (Ereditato da TextEdit)
Metodo pubblico | IsNeededKey | (Ereditato da PopupBaseEdit)
Metodo protetto | IsNullValue | (Ereditato da BaseEdit)
Metodo protetto | IsShowNullValuePrompt | (Ereditato da TextEdit)
Metodo protetto | IsTextCommand | (Ereditato da TextEdit)
Metodo protetto | KeepPopupFormSize | (Ereditato da PopupBaseEdit)
Metodo protetto | LayoutChanged | (Ereditato da TextEdit)
Metodo protetto | LayoutChanged(Boolean) | (Ereditato da TextEdit)
Metodo protetto | LayoutChangedCore | (Ereditato da TextEdit)
Metodo protetto | LayoutChangedCore(Boolean) | (Ereditato da BaseControl)
Metodo protetto | LockEditValueChanged | (Ereditato da BaseEdit)
Metodo protetto | LockMaskBoxPropertiesUpdate | (Ereditato da TextEdit)
Metodo protetto | MaskBoxGetEditValue | (Ereditato da TextEdit)
Metodo protetto | NeedLayoutUpdateValidating | (Ereditato da TextEdit)
Metodo protetto | NotifyAccessibilityClients(AccessibleEvents, Int32, Int32) | (Ereditato da BaseControl)
Metodo protetto | NotifyAccessibilityClients(AccessibleEvents, AutomationElementProvider, Int32, Int32) | (Ereditato da BaseControl)
Metodo protetto | NotifyButtonStateChanged | (Ereditato da ButtonEdit)
Metodo protetto | OnAfterUpdateViewInfo | (Ereditato da TextEdit)
Metodo protetto | OnAppearancePaintChanged | (Ereditato da TextEdit)
Metodo protetto | OnAutoHeightChanged | (Ereditato da BaseEdit)
Metodo protetto | OnBeforeUpdateViewInfo | (Ereditato da TextEdit)
Metodo protetto | OnBorderStyleChanged | (Ereditato da BaseControl)
Metodo protetto | OnCancelEditValueChanging | (Ereditato da BaseEdit)
Metodo protetto | OnClickButton | (Ereditato da BaseSpinEdit)
Metodo protetto | OnClickButtonCore | (Ereditato da ButtonEdit)
Metodo protetto | OnClientSizeChanged | (Ereditato da TextEdit)
Metodo protetto | OnContextMenuChanged | (Ereditato da BaseEdit)
Metodo protetto | OnContextMenuStripChanged | (Ereditato da BaseEdit)
Metodo protetto | OnControllerValueChanged | (Ereditato da TextEdit)
Metodo protetto | OnControllerValueChanging | (Ereditato da TextEdit)
Metodo protetto | OnCreateControl | (Ereditato da TextEdit)
Metodo protetto | OnDefaultPressButton | (Ereditato da PopupBaseEdit)
Metodo protetto | OnDirectXPaintDisabled | (Ereditato da XtraControl)
Metodo protetto | OnDirectXPaintEnabled | (Ereditato da XtraControl)
Metodo protetto | OnEditorEnter | (Ereditato da TextEdit)
Metodo protetto | OnEditorKeyDown | (Ereditato da PopupBaseEdit)
Metodo protetto | OnEditorKeyDownProcessNullInputKeys | (Ereditato da TextEdit)
Metodo protetto | OnEditorKeyPress | (Ereditato da PopupBaseEdit)
Metodo protetto | OnEditorKeyUp | (Ereditato da PopupBaseEdit)
Metodo protetto | OnEditorLeave | (Ereditato da TextEdit)
Metodo protetto | OnEditValueChanged | (Ereditato da PopupBaseEdit)
Metodo protetto | OnEditValueChanging | (Ereditato da TextEdit)
Metodo protetto | OnEnabledChanged | (Ereditato da TextEdit)
Metodo protetto | OnEnableNonMaskedInput | (Ereditato da TextEdit)
Metodo protetto | OnEndIme | (Ereditato da PopupBaseEdit)
Metodo protetto | OnEnter | (Ereditato da TextEdit)
Metodo protetto | OnErrorInfoChanged | (Ereditato da BaseEdit)
Metodo protetto | OnErrorTextChanged | (Ereditato da TextEdit)
Metodo protetto | OnGlassMaskBoxPreWndProc | (Ereditato da TextEdit)
Metodo protetto | OnGlassMaskBoxWndProc | (Ereditato da TextEdit)
Metodo protetto | OnGotCapture | (Ereditato da ControlBase)
Metodo protetto | OnGotFocus | (Ereditato da PopupBaseEdit)
Metodo protetto | OnHandleCreated | (Ereditato da TextEdit)
Metodo protetto | OnHandleDestroyed | (Ereditato da TextEdit)
Metodo protetto | OnImeModeChanged | (Ereditato da TextEdit)
Metodo protetto | OnInvalidValue | (Ereditato da BaseEdit)
Metodo protetto | OnKeyDown | (Ereditato da TextEdit)
Metodo protetto | OnKeyPress | (Ereditato da TextEdit)
Metodo protetto | OnKeyUp | (Ereditato da TextEdit)
Metodo protetto | OnLeave | (Ereditato da TextEdit)
Metodo protetto | OnLoaded | (Ereditato da PopupBaseEdit)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da TextEdit)
Metodo protetto | OnLostCapture | (Ereditato da ControlBase)
Metodo protetto | OnLostFocus | (Ereditato da PopupBaseEdit)
Metodo protetto | OnMaskBox_Click | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_DoubleClick | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_GotFocus | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_KeyDown | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_KeyPress | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_KeyUp | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_LostFocus | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_MouseDown | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_MouseEnter | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_MouseLeave | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_MouseMove | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_MouseUp | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_MouseWheel | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_TextValidated | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_ValueChanged | (Ereditato da TextEdit)
Metodo protetto | OnMaskBox_ValueChanging | (Ereditato da TextEdit)
Metodo protetto | OnMaskBoxMouseSelection | (Ereditato da TextEdit)
Metodo protetto | OnMaskBoxPreWndProc | (Ereditato da TextEdit)
Metodo protetto | OnMaskBoxTextResetToNullValuePromptOrNullText | (Ereditato da TextEdit)
Metodo protetto | OnMaskBoxWndProc | (Ereditato da TextEdit)
Metodo protetto | OnMaskEditValueChanging | (Ereditato da TextEdit)
Metodo protetto | OnMouseDown | (Ereditato da PopupBaseEdit)
Metodo protetto | OnMouseDownClosePopup | (Ereditato da PopupBaseEdit)
Metodo protetto | OnMouseEnter | (Ereditato da TextEdit)
Metodo protetto | OnMouseLeave | (Ereditato da TextEdit)
Metodo protetto | OnMouseMove | (Ereditato da TextEdit)
Metodo protetto | OnMouseUp | (Ereditato da BaseSpinEdit)
Metodo protetto | OnMouseWheel | (Ereditato da TextEdit)
Metodo protetto | OnMove | (Ereditato da PopupBaseEdit)
Metodo protetto | OnPaddingChanged | (Ereditato da BaseControl)
Metodo protetto | OnPaint | (Ereditato da TextEdit)
Metodo protetto | OnPaintBackground | (Ereditato da TextEdit)
Metodo protetto | OnParentChanged | (Ereditato da ControlBase)
Metodo protetto | OnParentVisibleChanged | (Ereditato da PopupBaseEdit)
Metodo protetto | OnPopupClosed | (Ereditato da PopupBaseEdit)
Metodo protetto | OnPopupClosing | (Ereditato da PopupBaseEdit)
Metodo protetto | OnPopupFormValueChanged | (Ereditato da PopupBaseEdit)
Metodo protetto | OnPopupShown | (Ereditato da PopupBaseEdit)
Metodo protetto | OnPressButton | (Ereditato da BaseSpinEdit)
Metodo protetto | OnPressSpinDown | (Ereditato da BaseSpinEdit)
Metodo protetto | OnPressSpinUp | (Ereditato da BaseSpinEdit)
Metodo protetto | OnPreviewKeyDown | (Ereditato da TextEdit)
Metodo protetto | OnProperties_PropertiesChanged | (Ereditato da BaseEdit)
Metodo protetto | OnPropertiesChanged | (Ereditato da PopupBaseEdit)
Metodo protetto | OnPropertiesChanged_SyncPopup | (Ereditato da PopupBaseEdit)
Metodo protetto | OnResize | (Ereditato da TextEdit)
Metodo protetto | OnRightToLeftChanged | (Ereditato da PopupBaseEdit)
Metodo protetto | OnRightToLeftChanged(EventArgs) | (Ereditato da ControlBase)
Metodo protetto | OnScaleControl | (Ereditato da BaseEdit)
Metodo protetto | OnScaleDpiChanged | (Ereditato da ControlBase)
Metodo protetto | OnSizeChanged | (Ereditato da TextEdit)
Metodo protetto | OnSpin | (Ereditato da TextEdit)
Metodo protetto | OnSpinTimer_Tick | (Ereditato da BaseSpinEdit)
Metodo protetto | OnStyleController_Disposed | (Ereditato da BaseControl)
Metodo protetto | OnStyleController_PropertiesChanged | (Ereditato da BaseControl)
Metodo protetto | OnStyleControllerChanged | (Ereditato da TextEdit)
Metodo protetto | OnTabStopChanged | (Ereditato da TextEdit)
Metodo protetto | OnTextChanged | (Ereditato da TextEdit)
Metodo protetto | OnTextEditPropertiesChanged | (Ereditato da TextEdit)
Metodo protetto | OnValidated | (Ereditato da TextEdit)
Metodo protetto | OnValidating | (Ereditato da TextEdit)
Metodo protetto | OnValidatingCore | (Ereditato da BaseEdit)
Metodo protetto | OnVisibleChanged | (Ereditato da PopupBaseEdit)
Metodo protetto | PaintErrorIconBackground | (Ereditato da TextEdit)
Metodo protetto | ParseEditorValue | (Ereditato da BaseEdit)
Metodo pubblico | Paste | (Ereditato da TextEdit)
Metodo protetto | PendingEditActionPerformed | (Ereditato da TextEdit)
Metodo pubblico | PerformClick | (Ereditato da ButtonEdit)
Metodo protetto | PerformDefaultClearButtonAction | (Ereditato da PopupBaseEdit)
Metodo protetto | ProcessCmdKey | (Ereditato da TextEdit)
Metodo protetto | ProcessDialogKey | (Ereditato da PopupBaseEdit)
Metodo protetto | ProcessDialogKeyCore | (Ereditato da TextEdit)
Metodo protetto | ProcessPaintAction | (Ereditato da XtraControl)
Metodo protetto | ProcessPopupMouseWheel | (Ereditato da BaseEdit)
Metodo protetto | ProcessPopupTabKey | (Ereditato da PopupBaseEdit)
Metodo protetto | ProcessRemoveWord | (Ereditato da TextEdit)
Metodo protetto | QueryEditorModeFromSkin | (Ereditato da TextEdit)
Metodo protetto | QueryMaskEditValue | (Ereditato da TextEdit)
Metodo protetto | RaiseEditValueChanged | (Ereditato da BaseEdit)
Metodo protetto | RaiseInvalidValue | (Ereditato da BaseEdit)
Metodo protetto | RaiseModified | (Ereditato da BaseEdit)
Metodo protetto | RaisePaintEvent | (Ereditato da TextEdit)
Metodo protetto | RaisePaintExEvent(TextEditPaintExEventArgs) | (Ereditato da TextEdit)
Metodo protetto | RaisePaintExEvent(GraphicsCache, PaintEventArgs) | (Ereditato da XtraControl)
Metodo protetto | RaisePopupAllowClick | (Ereditato da PopupBaseEdit)
Metodo protetto | RaiseQueryAdvancedMode | (Ereditato da TextEdit)
Metodo protetto | RaiseQueryCompletion | (Ereditato da TextEdit)
Metodo protetto | RaiseSizeableChanged | (Ereditato da BaseControl)
Metodo pubblico | Refresh | (Ereditato da BaseControl)
Metodo pubblico | RefreshEditValue | (Ereditato da BaseSpinEdit)
Metodo protetto | RefreshEnabledState | (Ereditato da TextEdit)
Metodo protetto | RefreshPopup | (Ereditato da PopupBaseEdit)
Metodo protetto | RefreshVisualLayout | (Ereditato da BaseEdit)
Metodo protetto | RefreshVisualLayoutCore | (Ereditato da BaseEdit)
Metodo protetto | RejectPopupValue | (Ereditato da PopupBaseEdit)
Metodo protetto | ReleaseDirectXResources | (Ereditato da XtraControl)
Metodo protetto | ReleaseStyleController | (Ereditato da BaseControl)
Metodo protetto | RemoveXtraAnimator | (Ereditato da BaseControl)
Metodo pubblico | Reset | (Ereditato da TextEdit)
Metodo protetto | ResetAccessible | (Ereditato da BaseControl)
Metodo pubblico | ResetBackColor | (Ereditato da BaseEdit)
Metodo protetto | ResetEvents | (Ereditato da BaseEdit)
Metodo pubblico | ResetForeColor | (Ereditato da BaseEdit)
Metodo pubblico | ResetSelection | (Ereditato da TextEdit)
Metodo pubblico | ResetSuperTip | (Ereditato da BaseControl)
Metodo protetto | ScaleControl | (Ereditato da ControlBase)
Metodo protetto | ScaleFont | (Ereditato da TextEdit)
Metodo protetto | ScaleInteger | (Ereditato da BaseControl)
Metodo protetto | ScaleSize | (Ereditato da BaseControl)
Metodo pubblico | ScrollToCaret | (Ereditato da TextEdit)
Metodo protetto | Select(Boolean, Boolean) | (Ereditato da TextEdit)
Metodo pubblico | Select(Int32, Int32) | (Ereditato da TextEdit)
Metodo pubblico | SelectAll | (Ereditato da TextEdit)
Metodo pubblico | SendKey(KeyEventArgs) | (Ereditato da BaseEdit)
Metodo pubblico | SendKey(Object, KeyPressEventArgs) | (Ereditato da BaseEdit)
Metodo pubblico | SendKeyUp | (Ereditato da BaseEdit)
Metodo pubblico | SendMouse(MouseEventArgs) | (Ereditato da BaseEdit)
Metodo pubblico | SendMouse(Point, MouseButtons) | (Ereditato da BaseEdit)
Metodo protetto | SendMouseUp(MouseEventArgs) | (Ereditato da BaseEdit)
Metodo pubblico | SendMouseUp(Point, MouseButtons) | (Ereditato da BaseEdit)
Metodo protetto | SetBackColor | (Ereditato da BaseControl)
Metodo protetto | SetBoundsCore | (Ereditato da BaseEdit)
Metodo protetto | SetEmptyEditValue | (Ereditato da PopupBaseEdit)
Metodo protetto | SetErrorIcon | (Ereditato da BaseEdit)
Metodo protetto | SetPopupEditValueOnClose | (Ereditato da PopupBaseEdit)
Metodo protetto | SetTextCore | (Ereditato da TextEdit)
Metodo protetto | SetVisibleCore | (Ereditato da ControlBase)
Metodo protetto | ShouldSuppressFormDeactivation | (Ereditato da TextEdit)
Metodo protetto | ShouldSuppressTextCommand | (Ereditato da TextEdit)
Metodo pubblico | ShowAutoCompletePopup | (Ereditato da TextEdit)
Metodo protetto | ShowCaret | (Ereditato da TextEdit)
Metodo protetto | ShowMenu | (Ereditato da TextEdit)
Metodo protetto | ShowMenuCore | (Ereditato da TextEdit)
Metodo pubblico | ShowPopup | (Ereditato da BaseSpinEdit)
Metodo protetto | StartSpinTimer | (Ereditato da BaseSpinEdit)
Metodo protetto | StopSpinTimer | (Ereditato da BaseSpinEdit)
Metodo protetto | SubscribePopupFormEvents | (Ereditato da PopupBaseEdit)
Metodo protetto | SuppressMouseWheel | (Ereditato da PopupBaseEdit)
Metodo protetto | SwitchModeAccordingToSkinSettings | (Ereditato da TextEdit)
Metodo protetto | SwitchPopupState | (Ereditato da PopupBaseEdit)
Metodo pubblico | Undo | (Ereditato da TextEdit)
Metodo protetto | UnLockEditValueChanged | (Ereditato da BaseEdit)
Metodo protetto | UnlockMaskBoxPropertiesUpdate | (Ereditato da TextEdit)
Metodo protetto | UpdateClearButtonVisibility | (Ereditato da PopupBaseEdit)
Metodo protetto | UpdateClearButtonVisibilityCore | (Ereditato da PopupBaseEdit)
Metodo protetto | UpdateDisplayText | (Ereditato da TextEdit)
Metodo protetto | UpdateEditControllerProperties | (Ereditato da TextEdit)
Metodo protetto | UpdateEditValueOnClose | (Ereditato da PopupBaseEdit)
Metodo protetto | UpdateFixedHeight | (Ereditato da BaseEdit)
Metodo protetto | UpdateHideSelection | (Ereditato da TextEdit)
Metodo protetto | UpdateInactiveInnerEditorProperties | (Ereditato da TextEdit)
Metodo protetto | UpdateMaskBox | (Ereditato da TextEdit)
Metodo protetto | UpdateMaskBox(Boolean) | (Ereditato da TextEdit)
Metodo protetto | UpdateMaskBoxBounds | (Ereditato da TextEdit)
Metodo protetto | UpdateMaskBoxDisplayText | (Ereditato da TextEdit)
Metodo protetto | UpdateMaskBoxFontByScaleDpi | (Ereditato da TextEdit)
Metodo protetto | UpdateMaskBoxProperties | (Ereditato da TextEdit)
Metodo protetto | UpdateMaskBoxPropertiesCore | (Ereditato da TextEdit)
Metodo protetto | UpdateMenu | (Ereditato da TextEdit)
Metodo protetto | UpdateMenuCoords | (Ereditato da TextEdit)
Metodo protetto | UpdatePasswordChar | (Ereditato da TextEdit)
Metodo protetto | UpdateScaleDpi | (Ereditato da XtraControl)
Metodo protetto | UpdateScaleFactorForScaleHelper | (Ereditato da XtraControl)
Metodo pubblico | UpdateTextHighlight | (Ereditato da TextEdit)
Metodo protetto | UpdateViewInfo | (Ereditato da BaseControl)
Metodo protetto | UpdateViewInfoEditValue | (Ereditato da BaseEdit)
Metodo protetto | UpdateViewInfoState | (Ereditato da BaseControl)
Metodo protetto | UpdateViewInfoState(Boolean) | (Ereditato da BaseControl)
Metodo protetto | UpdateViewInfoState(Boolean, Point) | (Ereditato da BaseControl)
Metodo protetto | WndProc | (Ereditato da PopupBaseEdit)
Torna su
Vedi anche

Documentazione

Classe DedTextSpinEdit
Namespace DedNet.Controls


Metodo DedTextSpinEdit.CreatePopupForm

Metodo DedTextSpinEditCreatePopupForm

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override PopupBaseForm CreatePopupForm()
Protected Overrides Function CreatePopupForm As PopupBaseForm
protected:
virtual PopupBaseForm^ CreatePopupForm() override
abstract CreatePopupForm : unit -> PopupBaseForm
override CreatePopupForm : unit -> PopupBaseForm

Valore di ritorno

PopupBaseForm
Vedi anche

Documentazione

Classe DedTextSpinEdit
Namespace DedNet.Controls


Eventi di DedTextSpinEdit

Il tipo DedTextSpinEdit espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | BackColorChanged | (Ereditato da BaseEdit)
Evento pubblico | BeforePopup | (Ereditato da PopupBaseEdit)
Evento pubblico | ButtonClick | (Ereditato da ButtonEdit)
Evento pubblico | ButtonPressed | (Ereditato da ButtonEdit)
Evento pubblico | Closed | (Ereditato da BaseSpinEdit)
Evento pubblico | CloseUp | (Ereditato da BaseSpinEdit)
Evento pubblico | CustomDisplayText | (Ereditato da BaseEdit)
Evento pubblico | CustomHighlightText | (Ereditato da TextEdit)
Evento pubblico | CustomizeAutoCompleteSource | (Ereditato da TextEdit)
Evento pubblico | CustomTextLineHeight | (Ereditato da TextEdit)
Evento pubblico | EditValueChanged | (Ereditato da BaseEdit)
Evento pubblico | EditValueChanging | (Ereditato da BaseEdit)
Evento pubblico | FontChanged | (Ereditato da BaseEdit)
Evento pubblico | ForeColorChanged | (Ereditato da BaseEdit)
Evento pubblico | FormatEditValue | (Ereditato da BaseEdit)
Evento pubblico | InvalidValue | (Ereditato da BaseEdit)
Evento pubblico | Modified | (Ereditato da BaseEdit)
Evento pubblico | PaintEx | (Ereditato da TextEdit)
Evento pubblico | ParseEditValue | (Ereditato da BaseEdit)
Evento pubblico | Popup | (Ereditato da BaseSpinEdit)
Evento pubblico | PopupAllowClick | (Ereditato da PopupBaseEdit)
Evento pubblico | PropertiesChanged | (Ereditato da BaseEdit)
Evento pubblico | QueryAccessibilityHelp | (Ereditato da BaseEdit)
Evento pubblico | QueryCloseUp | (Ereditato da BaseSpinEdit)
Evento pubblico | QueryPopUp | (Ereditato da BaseSpinEdit)
Evento pubblico | QueryProcessKey | (Ereditato da BaseEdit)
Evento pubblico | Spin | (Ereditato da TextEdit)
Torna su
Vedi anche

Documentazione

Classe DedTextSpinEdit
Namespace DedNet.Controls


Campi di DedTextSpinEdit

Il tipo DedTextSpinEdit espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | fDisposing | (Ereditato da BaseControl)
Campo protetto | fEditValue | (Ereditato da BaseEdit)
Campo protetto | fOldEditValue | (Ereditato da BaseEdit)
Campo protetto | fProperties | (Ereditato da BaseEdit)
Campo protetto | fShowToolTips | (Ereditato da BaseControl)
Campo protetto | lastChangedEditValue | (Ereditato da BaseEdit)
Campo protetto | shouldRaiseSizeableChanged | (Ereditato da BaseControl)
Torna su
Vedi anche

Documentazione

Classe DedTextSpinEdit
Namespace DedNet.Controls


Classe DedTextSpinEditPainter
Gerarchia di ereditarietà
SystemObject
BaseControlPainter
BaseEditPainter
TextEditPainter
ButtonEditPainter
DedNet.ControlsDedTextSpinEditPainter

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedTextSpinEditPainter : ButtonEditPainter
Public Class DedTextSpinEditPainter
    Inherits ButtonEditPainter
public ref class DedTextSpinEditPainter : public ButtonEditPainter
type DedTextSpinEditPainter =
    class
        inherit ButtonEditPainter
    end

Il tipo DedTextSpinEditPainter espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedTextSpinEditPainter |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà protetta | ShouldUpdateStringInfoAppearanceColors | (Ereditato da ButtonEditPainter)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | CheckAllowDrawMatchedText | (Ereditato da TextEditPainter)
Metodo protetto | CheckPrepareHtmlString | (Ereditato da TextEditPainter)
Metodo protetto | CreateBorderInfoArgs | (Ereditato da BaseEditPainter)
Metodo protetto | CreateStringCalculateArgs | (Ereditato da TextEditPainter)
Metodo pubblico | Draw | (Ereditato da BaseEditPainter)
Metodo protetto | DrawAdornments | (Ereditato da BaseEditPainter)
Metodo protetto | DrawAnimatedContextImage | (Ereditato da TextEditPainter)
Metodo protetto | DrawBackgroundCore | (Ereditato da TextEditPainter)
Metodo protetto | DrawBorder | (Ereditato da TextEditPainter)
Metodo protetto | DrawButton | (Ereditato da ButtonEditPainter)
Metodo protetto | DrawButtons(ControlGraphicsInfoArgs) | (Ereditato da ButtonEditPainter)
Metodo protetto | DrawButtons(ControlGraphicsInfoArgs, EditorButtonObjectCollection, Boolean) | (Ereditato da ButtonEditPainter)
Metodo protetto | DrawContent | (Ereditato da ButtonEditPainter)
Metodo protetto | DrawContentCore | (Ereditato da BaseEditPainter)
Metodo protetto | DrawContextImage | (Ereditato da TextEditPainter)
Metodo protetto | DrawContextImageCore | (Ereditato da TextEditPainter)
Metodo protetto | DrawEmptyArea | (Ereditato da TextEditPainter)
Metodo protetto | DrawErrorIcon | (Ereditato da BaseEditPainter)
Metodo protetto | DrawFocusRect | (Ereditato da TextEditPainter)
Metodo protetto | DrawFocusRectCore | (Ereditato da TextEditPainter)
Metodo protetto | DrawGlyph | (Ereditato da ButtonEditPainter)
Metodo protetto | DrawGlyphCore | (Ereditato da ButtonEditPainter)
Metodo protetto | DrawMatchedRanges | (Ereditato da TextEditPainter)
Metodo protetto | DrawMatchedString | (Ereditato da TextEditPainter)
Metodo protetto | DrawParentBackground(ControlGraphicsInfoArgs) | (Ereditato da BaseEditPainter)
Metodo protetto | DrawParentBackground(BaseEditViewInfo, GraphicsCache) | (Ereditato da BaseEditPainter)
Metodo protetto | DrawRectangle | (Ereditato da BaseEditPainter)
Metodo protetto | DrawSkinInplaceBackground | (Ereditato da BaseEditPainter)
Metodo protetto | DrawString(ControlGraphicsInfoArgs, Rectangle, String, AppearanceObject) | (Ereditato da TextEditPainter)
Metodo protetto | DrawString(ControlGraphicsInfoArgs, Rectangle, String, AppearanceObject, Color) | (Ereditato da TextEditPainter)
Metodo protetto | DrawText | (Ereditato da TextEditPainter)
Metodo protetto | DrawTextBoxArea | (Ereditato da TextEditPainter)
Metodo protetto | DrawValueChangeAnimationDx | (Ereditato da BaseEditPainter)
Metodo protetto | DrawValueChangeAnimationGdi | (Ereditato da BaseEditPainter)
Metodo protetto | GetAnimatedColorMatrix | (Ereditato da TextEditPainter)
Metodo protetto | GetSvgPalette | (Ereditato da ButtonEditPainter)
Metodo protetto | IsDrawBorderLast | (Ereditato da BaseControlPainter)
Metodo protetto | ProcessDrawBackground | (Ereditato da TextEditPainter)
Metodo protetto | ShouldDrawBorder | (Ereditato da BaseControlPainter)
Metodo protetto | ShouldDrawButtonInBackground | (Ereditato da ButtonEditPainter)
Metodo protetto | ShouldUseHighlightedDXSkinColor | (Ereditato da TextEditPainter)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore DedTextSpinEditPainter

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTextSpinEditPainter()
Public Sub New
public:
DedTextSpinEditPainter()
new : unit -> DedTextSpinEditPainter
Vedi anche

Documentazione

Classe DedTextSpinEditPainter
Namespace DedNet.Controls


Proprietà di DedTextSpinEditPainter

Il tipo DedTextSpinEditPainter espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà protetta | ShouldUpdateStringInfoAppearanceColors | (Ereditato da ButtonEditPainter)
Torna su
Vedi anche

Documentazione

Classe DedTextSpinEditPainter
Namespace DedNet.Controls


Metodi di DedTextSpinEditPainter

Il tipo DedTextSpinEditPainter espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | CheckAllowDrawMatchedText | (Ereditato da TextEditPainter)
Metodo protetto | CheckPrepareHtmlString | (Ereditato da TextEditPainter)
Metodo protetto | CreateBorderInfoArgs | (Ereditato da BaseEditPainter)
Metodo protetto | CreateStringCalculateArgs | (Ereditato da TextEditPainter)
Metodo pubblico | Draw | (Ereditato da BaseEditPainter)
Metodo protetto | DrawAdornments | (Ereditato da BaseEditPainter)
Metodo protetto | DrawAnimatedContextImage | (Ereditato da TextEditPainter)
Metodo protetto | DrawBackgroundCore | (Ereditato da TextEditPainter)
Metodo protetto | DrawBorder | (Ereditato da TextEditPainter)
Metodo protetto | DrawButton | (Ereditato da ButtonEditPainter)
Metodo protetto | DrawButtons(ControlGraphicsInfoArgs) | (Ereditato da ButtonEditPainter)
Metodo protetto | DrawButtons(ControlGraphicsInfoArgs, EditorButtonObjectCollection, Boolean) | (Ereditato da ButtonEditPainter)
Metodo protetto | DrawContent | (Ereditato da ButtonEditPainter)
Metodo protetto | DrawContentCore | (Ereditato da BaseEditPainter)
Metodo protetto | DrawContextImage | (Ereditato da TextEditPainter)
Metodo protetto | DrawContextImageCore | (Ereditato da TextEditPainter)
Metodo protetto | DrawEmptyArea | (Ereditato da TextEditPainter)
Metodo protetto | DrawErrorIcon | (Ereditato da BaseEditPainter)
Metodo protetto | DrawFocusRect | (Ereditato da TextEditPainter)
Metodo protetto | DrawFocusRectCore | (Ereditato da TextEditPainter)
Metodo protetto | DrawGlyph | (Ereditato da ButtonEditPainter)
Metodo protetto | DrawGlyphCore | (Ereditato da ButtonEditPainter)
Metodo protetto | DrawMatchedRanges | (Ereditato da TextEditPainter)
Metodo protetto | DrawMatchedString | (Ereditato da TextEditPainter)
Metodo protetto | DrawParentBackground(ControlGraphicsInfoArgs) | (Ereditato da BaseEditPainter)
Metodo protetto | DrawParentBackground(BaseEditViewInfo, GraphicsCache) | (Ereditato da BaseEditPainter)
Metodo protetto | DrawRectangle | (Ereditato da BaseEditPainter)
Metodo protetto | DrawSkinInplaceBackground | (Ereditato da BaseEditPainter)
Metodo protetto | DrawString(ControlGraphicsInfoArgs, Rectangle, String, AppearanceObject) | (Ereditato da TextEditPainter)
Metodo protetto | DrawString(ControlGraphicsInfoArgs, Rectangle, String, AppearanceObject, Color) | (Ereditato da TextEditPainter)
Metodo protetto | DrawText | (Ereditato da TextEditPainter)
Metodo protetto | DrawTextBoxArea | (Ereditato da TextEditPainter)
Metodo protetto | DrawValueChangeAnimationDx | (Ereditato da BaseEditPainter)
Metodo protetto | DrawValueChangeAnimationGdi | (Ereditato da BaseEditPainter)
Metodo protetto | GetAnimatedColorMatrix | (Ereditato da TextEditPainter)
Metodo protetto | GetSvgPalette | (Ereditato da ButtonEditPainter)
Metodo protetto | IsDrawBorderLast | (Ereditato da BaseControlPainter)
Metodo protetto | ProcessDrawBackground | (Ereditato da TextEditPainter)
Metodo protetto | ShouldDrawBorder | (Ereditato da BaseControlPainter)
Metodo protetto | ShouldDrawButtonInBackground | (Ereditato da ButtonEditPainter)
Metodo protetto | ShouldUseHighlightedDXSkinColor | (Ereditato da TextEditPainter)
Torna su
Vedi anche

Documentazione

Classe DedTextSpinEditPainter
Namespace DedNet.Controls


Classe DedTextSpinEditPopupForm
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
SimplePopupBaseForm
PopupBaseForm
DedNet.ControlsDedTextSpinEditPopupForm

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedTextSpinEditPopupForm : PopupBaseForm
Public Class DedTextSpinEditPopupForm
    Inherits PopupBaseForm
public ref class DedTextSpinEditPopupForm : public PopupBaseForm
type DedTextSpinEditPopupForm =
    class
        inherit PopupBaseForm
    end

Il tipo DedTextSpinEditPopupForm espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedTextSpinEditPopupForm |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà protetta | AllowCloseByEscape | (Ereditato da PopupBaseForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà protetta | AllowLayoutChanged | (Ereditato da SimplePopupBaseForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowPopupTabOut | (Ereditato da PopupBaseForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | AppearanceDropDown | (Ereditato da PopupBaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | CanIgnoreImeInput | (Ereditato da PopupBaseForm)
Proprietà protetta | CanShowShadow | (Ereditato da PopupBaseForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | CloseUpKey | (Ereditato da PopupBaseForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da SimplePopupBaseForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DefaultMinFormSize | (Ereditato da SimplePopupBaseForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà protetta | EmbeddedControl | (Ereditato da SimplePopupBaseForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà pubblica | FormContainsFocus | (Ereditato da SimplePopupBaseForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasAccessible | (Ereditato da SimplePopupBaseForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà protetta | IgnoreOldEditValue | (Ereditato da SimplePopupBaseForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsImeInProgress | (Ereditato da PopupBaseForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsPopupFormClosing | (Ereditato da SimplePopupBaseForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà protetta | MinFormSize | (Ereditato da SimplePopupBaseForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | OldEditValue | (Ereditato da SimplePopupBaseForm)
Proprietà pubblica | OwnerEdit | (Ereditato da PopupBaseForm)
Proprietà protetta | Painter | (Ereditato da SimplePopupBaseForm)
Proprietà pubblica | PopupBorderStyle | (Ereditato da PopupBaseForm)
Proprietà protetta | PopupFormMinSize | (Ereditato da PopupBaseForm)
Proprietà protetta | PopupFormWidthPadding | (Ereditato da SimplePopupBaseForm)
Proprietà protetta | PopupShadow | (Ereditato da SimplePopupBaseForm)
Proprietà protetta | PrevParentFormSize | (Ereditato da SimplePopupBaseForm)
Proprietà pubblica | Properties | (Ereditato da PopupBaseForm)
Proprietà pubblica | ResultValue | (Sovrascrive SimplePopupBaseForm.ResultValue)
Proprietà protetta | ScaleDPI | (Ereditato da SimplePopupBaseForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | SeparatorControl | (Ereditato da SimplePopupBaseForm)
Proprietà protetta | ServiceObject | (Ereditato da SimplePopupBaseForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà protetta | ShowWithoutActivation | (Ereditato da SimplePopupBaseForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Proprietà protetta | UseSimpleVisible | (Ereditato da SimplePopupBaseForm)
Proprietà protetta | ViewInfo | (Ereditato da SimplePopupBaseForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo pubblico | AllowMouseClick | (Ereditato da PopupBaseForm)
Metodo protetto | AllowMouseClickCore | (Ereditato da SimplePopupBaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo pubblico | BeginUpdate | (Ereditato da SimplePopupBaseForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo pubblico | CalcFormSize | (Ereditato da SimplePopupBaseForm)
Metodo pubblico | CalcFormSize(Size) | (Ereditato da SimplePopupBaseForm)
Metodo protetto | CalcFormSizeCore | (Sovrascrive SimplePopupBaseForm.CalcFormSizeCore)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CancelPopup | (Ereditato da PopupBaseForm)
Metodo pubblico | CancelUpdate | (Ereditato da SimplePopupBaseForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo pubblico | CheckClosePopup | (Ereditato da SimplePopupBaseForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateTopMost | (Ereditato da SimplePopupBaseForm)
Metodo protetto | CheckZOrder | (Ereditato da SimplePopupBaseForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo pubblico | ClosePopup | (Ereditato da SimplePopupBaseForm)
Metodo protetto | ClosePopup(PopupCloseMode) | (Ereditato da PopupBaseForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da SimplePopupBaseForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da SimplePopupBaseForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da SimplePopupBaseForm)
Metodo protetto | CreatePainter | (Ereditato da SimplePopupBaseForm)
Metodo protetto | CreatePopupFormShadow | (Ereditato da SimplePopupBaseForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | CreateViewInfo | (Ereditato da SimplePopupBaseForm)
Metodo protetto | DestroyHandle | (Ereditato da SimplePopupBaseForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | DestroyPopupForm | (Ereditato da PopupBaseForm)
Metodo protetto | Dispose | (Ereditato da SimplePopupBaseForm)
Metodo protetto | DisposeFormShadow | (Ereditato da SimplePopupBaseForm)
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo pubblico | EndUpdate | (Ereditato da SimplePopupBaseForm)
Metodo protetto | FocusFormControl | (Ereditato da SimplePopupBaseForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo pubblico | ForceCreateHandle | (Ereditato da SimplePopupBaseForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | ForceShowShadow | (Ereditato da SimplePopupBaseForm)
Metodo protetto | ForceUpdateRemoting | (Ereditato da SimplePopupBaseForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da SimplePopupBaseForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da SimplePopupBaseForm)
Metodo pubblico | HidePopupForm | (Ereditato da SimplePopupBaseForm)
Metodo pubblico | HideShadows | (Ereditato da SimplePopupBaseForm)
Metodo protetto | InitCore | (Ereditato da SimplePopupBaseForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | InitializeFormShadow | (Ereditato da SimplePopupBaseForm)
Metodo protetto | IsInputKey | (Ereditato da SimplePopupBaseForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsNeededKey | (Ereditato da PopupBaseForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LayoutChanged | (Ereditato da SimplePopupBaseForm)
Metodo protetto | LockUpdateControlPositions | (Ereditato da SimplePopupBaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnBeforeShowPopup | (Ereditato da PopupBaseForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnEndIme | (Ereditato da PopupBaseForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnForm_Move | (Ereditato da SimplePopupBaseForm)
Metodo protetto | OnForm_Resize | (Ereditato da SimplePopupBaseForm)
Metodo protetto | OnForm_VisibleChanged | (Ereditato da SimplePopupBaseForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnKeyDown | (Ereditato da SimplePopupBaseForm)
Metodo protetto | OnKeyDownCore | (Ereditato da SimplePopupBaseForm)
Metodo protetto | OnKeyPress | (Ereditato da SimplePopupBaseForm)
Metodo protetto | OnKeyUp | (Ereditato da SimplePopupBaseForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLocationChanged | (Ereditato da SimplePopupBaseForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da SimplePopupBaseForm)
Metodo protetto | OnPaintBackground | (Ereditato da PopupBaseForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnResize | (Ereditato da SimplePopupBaseForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | (Ereditato da SimplePopupBaseForm)
Metodo protetto | OwnerFormIsTopMost | (Ereditato da SimplePopupBaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | ProcessEscapeKeyDown | (Ereditato da SimplePopupBaseForm)
Metodo pubblico | ProcessKeyDown | (Ereditato da SimplePopupBaseForm)
Metodo pubblico | ProcessKeyPress | (Ereditato da PopupBaseForm)
Metodo pubblico | ProcessKeyUp | (Ereditato da SimplePopupBaseForm)
Metodo protetto | ProcessPopupTabKey | (Ereditato da PopupBaseForm)
Metodo protetto | QueryOldEditValue | (Ereditato da SimplePopupBaseForm)
Metodo protetto | QueryResultValue | (Ereditato da SimplePopupBaseForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | RaiseResultValueChanged | (Ereditato da SimplePopupBaseForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo protetto | ResetResultValue | (Ereditato da SimplePopupBaseForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da SimplePopupBaseForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo protetto | ShouldUseFormShadow | (Ereditato da SimplePopupBaseForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo pubblico | ShowHideShadows | (Ereditato da SimplePopupBaseForm)
Metodo pubblico | ShowPopupForm | (Ereditato da SimplePopupBaseForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SubscribeFormEvents | (Ereditato da SimplePopupBaseForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UnlockUpdateControlPositions | (Ereditato da SimplePopupBaseForm)
Metodo protetto | UnsubscribeFormEvents | (Ereditato da SimplePopupBaseForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateControlPositions | (Ereditato da SimplePopupBaseForm)
Metodo protetto | UpdateControlPositionsCore | (Ereditato da SimplePopupBaseForm)
Metodo protetto | UpdateDelayedViewInfo | (Ereditato da PopupBaseForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateViewInfo | (Ereditato da SimplePopupBaseForm)
Metodo protetto | UpdateViewInfo(Graphics) | (Ereditato da SimplePopupBaseForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da SimplePopupBaseForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Evento pubblico | ResultValueChanged | (Ereditato da SimplePopupBaseForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore DedTextSpinEditPopupForm

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTextSpinEditPopupForm(
    DedTextSpinEdit ownerEdit
)
Public Sub New (
    ownerEdit As DedTextSpinEdit
)
public:
DedTextSpinEditPopupForm(
    DedTextSpinEdit^ ownerEdit
)
new :
        ownerEdit : DedTextSpinEdit -> DedTextSpinEditPopupForm

Parametri

ownerEdit DedTextSpinEdit
Vedi anche

Documentazione

Classe DedTextSpinEditPopupForm
Namespace DedNet.Controls


Proprietà di DedTextSpinEditPopupForm

Il tipo DedTextSpinEditPopupForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà protetta | AllowCloseByEscape | (Ereditato da PopupBaseForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà protetta | AllowLayoutChanged | (Ereditato da SimplePopupBaseForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowPopupTabOut | (Ereditato da PopupBaseForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | AppearanceDropDown | (Ereditato da PopupBaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | CanIgnoreImeInput | (Ereditato da PopupBaseForm)
Proprietà protetta | CanShowShadow | (Ereditato da PopupBaseForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | CloseUpKey | (Ereditato da PopupBaseForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da SimplePopupBaseForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DefaultMinFormSize | (Ereditato da SimplePopupBaseForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà protetta | EmbeddedControl | (Ereditato da SimplePopupBaseForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà pubblica | FormContainsFocus | (Ereditato da SimplePopupBaseForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasAccessible | (Ereditato da SimplePopupBaseForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà protetta | IgnoreOldEditValue | (Ereditato da SimplePopupBaseForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsImeInProgress | (Ereditato da PopupBaseForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsPopupFormClosing | (Ereditato da SimplePopupBaseForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà protetta | MinFormSize | (Ereditato da SimplePopupBaseForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | OldEditValue | (Ereditato da SimplePopupBaseForm)
Proprietà pubblica | OwnerEdit | (Ereditato da PopupBaseForm)
Proprietà protetta | Painter | (Ereditato da SimplePopupBaseForm)
Proprietà pubblica | PopupBorderStyle | (Ereditato da PopupBaseForm)
Proprietà protetta | PopupFormMinSize | (Ereditato da PopupBaseForm)
Proprietà protetta | PopupFormWidthPadding | (Ereditato da SimplePopupBaseForm)
Proprietà protetta | PopupShadow | (Ereditato da SimplePopupBaseForm)
Proprietà protetta | PrevParentFormSize | (Ereditato da SimplePopupBaseForm)
Proprietà pubblica | Properties | (Ereditato da PopupBaseForm)
Proprietà pubblica | ResultValue | (Sovrascrive SimplePopupBaseForm.ResultValue)
Proprietà protetta | ScaleDPI | (Ereditato da SimplePopupBaseForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | SeparatorControl | (Ereditato da SimplePopupBaseForm)
Proprietà protetta | ServiceObject | (Ereditato da SimplePopupBaseForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà protetta | ShowWithoutActivation | (Ereditato da SimplePopupBaseForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Proprietà protetta | UseSimpleVisible | (Ereditato da SimplePopupBaseForm)
Proprietà protetta | ViewInfo | (Ereditato da SimplePopupBaseForm)
Torna su
Vedi anche

Documentazione

Classe DedTextSpinEditPopupForm
Namespace DedNet.Controls


Proprietà DedTextSpinEditPopupForm.ResultValue

Proprietà DedTextSpinEditPopupFormResultValue

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override Object ResultValue { get; }
Public Overrides ReadOnly Property ResultValue As Object
    Get
public:
virtual property Object^ ResultValue {
    Object^ get () override;
}
abstract ResultValue : Object with get
override ResultValue : Object with get

Valore della proprietà

Object
Vedi anche

Documentazione

Classe DedTextSpinEditPopupForm
Namespace DedNet.Controls


Metodi di DedTextSpinEditPopupForm

Il tipo DedTextSpinEditPopupForm espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo pubblico | AllowMouseClick | (Ereditato da PopupBaseForm)
Metodo protetto | AllowMouseClickCore | (Ereditato da SimplePopupBaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo pubblico | BeginUpdate | (Ereditato da SimplePopupBaseForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo pubblico | CalcFormSize | (Ereditato da SimplePopupBaseForm)
Metodo pubblico | CalcFormSize(Size) | (Ereditato da SimplePopupBaseForm)
Metodo protetto | CalcFormSizeCore | (Sovrascrive SimplePopupBaseForm.CalcFormSizeCore)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CancelPopup | (Ereditato da PopupBaseForm)
Metodo pubblico | CancelUpdate | (Ereditato da SimplePopupBaseForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo pubblico | CheckClosePopup | (Ereditato da SimplePopupBaseForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateTopMost | (Ereditato da SimplePopupBaseForm)
Metodo protetto | CheckZOrder | (Ereditato da SimplePopupBaseForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo pubblico | ClosePopup | (Ereditato da SimplePopupBaseForm)
Metodo protetto | ClosePopup(PopupCloseMode) | (Ereditato da PopupBaseForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da SimplePopupBaseForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da SimplePopupBaseForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da SimplePopupBaseForm)
Metodo protetto | CreatePainter | (Ereditato da SimplePopupBaseForm)
Metodo protetto | CreatePopupFormShadow | (Ereditato da SimplePopupBaseForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | CreateViewInfo | (Ereditato da SimplePopupBaseForm)
Metodo protetto | DestroyHandle | (Ereditato da SimplePopupBaseForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | DestroyPopupForm | (Ereditato da PopupBaseForm)
Metodo protetto | Dispose | (Ereditato da SimplePopupBaseForm)
Metodo protetto | DisposeFormShadow | (Ereditato da SimplePopupBaseForm)
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo pubblico | EndUpdate | (Ereditato da SimplePopupBaseForm)
Metodo protetto | FocusFormControl | (Ereditato da SimplePopupBaseForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo pubblico | ForceCreateHandle | (Ereditato da SimplePopupBaseForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | ForceShowShadow | (Ereditato da SimplePopupBaseForm)
Metodo protetto | ForceUpdateRemoting | (Ereditato da SimplePopupBaseForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da SimplePopupBaseForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da SimplePopupBaseForm)
Metodo pubblico | HidePopupForm | (Ereditato da SimplePopupBaseForm)
Metodo pubblico | HideShadows | (Ereditato da SimplePopupBaseForm)
Metodo protetto | InitCore | (Ereditato da SimplePopupBaseForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | InitializeFormShadow | (Ereditato da SimplePopupBaseForm)
Metodo protetto | IsInputKey | (Ereditato da SimplePopupBaseForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsNeededKey | (Ereditato da PopupBaseForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LayoutChanged | (Ereditato da SimplePopupBaseForm)
Metodo protetto | LockUpdateControlPositions | (Ereditato da SimplePopupBaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnBeforeShowPopup | (Ereditato da PopupBaseForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnEndIme | (Ereditato da PopupBaseForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnForm_Move | (Ereditato da SimplePopupBaseForm)
Metodo protetto | OnForm_Resize | (Ereditato da SimplePopupBaseForm)
Metodo protetto | OnForm_VisibleChanged | (Ereditato da SimplePopupBaseForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnKeyDown | (Ereditato da SimplePopupBaseForm)
Metodo protetto | OnKeyDownCore | (Ereditato da SimplePopupBaseForm)
Metodo protetto | OnKeyPress | (Ereditato da SimplePopupBaseForm)
Metodo protetto | OnKeyUp | (Ereditato da SimplePopupBaseForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLocationChanged | (Ereditato da SimplePopupBaseForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da SimplePopupBaseForm)
Metodo protetto | OnPaintBackground | (Ereditato da PopupBaseForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnResize | (Ereditato da SimplePopupBaseForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | (Ereditato da SimplePopupBaseForm)
Metodo protetto | OwnerFormIsTopMost | (Ereditato da SimplePopupBaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | ProcessEscapeKeyDown | (Ereditato da SimplePopupBaseForm)
Metodo pubblico | ProcessKeyDown | (Ereditato da SimplePopupBaseForm)
Metodo pubblico | ProcessKeyPress | (Ereditato da PopupBaseForm)
Metodo pubblico | ProcessKeyUp | (Ereditato da SimplePopupBaseForm)
Metodo protetto | ProcessPopupTabKey | (Ereditato da PopupBaseForm)
Metodo protetto | QueryOldEditValue | (Ereditato da SimplePopupBaseForm)
Metodo protetto | QueryResultValue | (Ereditato da SimplePopupBaseForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | RaiseResultValueChanged | (Ereditato da SimplePopupBaseForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo protetto | ResetResultValue | (Ereditato da SimplePopupBaseForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da SimplePopupBaseForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo protetto | ShouldUseFormShadow | (Ereditato da SimplePopupBaseForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo pubblico | ShowHideShadows | (Ereditato da SimplePopupBaseForm)
Metodo pubblico | ShowPopupForm | (Ereditato da SimplePopupBaseForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SubscribeFormEvents | (Ereditato da SimplePopupBaseForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UnlockUpdateControlPositions | (Ereditato da SimplePopupBaseForm)
Metodo protetto | UnsubscribeFormEvents | (Ereditato da SimplePopupBaseForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateControlPositions | (Ereditato da SimplePopupBaseForm)
Metodo protetto | UpdateControlPositionsCore | (Ereditato da SimplePopupBaseForm)
Metodo protetto | UpdateDelayedViewInfo | (Ereditato da PopupBaseForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateViewInfo | (Ereditato da SimplePopupBaseForm)
Metodo protetto | UpdateViewInfo(Graphics) | (Ereditato da SimplePopupBaseForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da SimplePopupBaseForm)
Torna su
Vedi anche

Documentazione

Classe DedTextSpinEditPopupForm
Namespace DedNet.Controls


Metodo DedTextSpinEditPopupForm.CalcFormSizeCore

Metodo DedTextSpinEditPopupFormCalcFormSizeCore

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override Size CalcFormSizeCore()
Protected Overrides Function CalcFormSizeCore As Size
protected:
virtual Size CalcFormSizeCore() override
abstract CalcFormSizeCore : unit -> Size
override CalcFormSizeCore : unit -> Size

Valore di ritorno

Size
Vedi anche

Documentazione

Classe DedTextSpinEditPopupForm
Namespace DedNet.Controls


Eventi di DedTextSpinEditPopupForm

Il tipo DedTextSpinEditPopupForm espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Evento pubblico | ResultValueChanged | (Ereditato da SimplePopupBaseForm)
Torna su
Vedi anche

Documentazione

Classe DedTextSpinEditPopupForm
Namespace DedNet.Controls


Campi di DedTextSpinEditPopupForm

Il tipo DedTextSpinEditPopupForm espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedTextSpinEditPopupForm
Namespace DedNet.Controls


Classe DedTextSpinEditViewInfo
Gerarchia di ereditarietà
SystemObject
BaseControlViewInfo
BaseEditViewInfo
TextEditViewInfo
ButtonEditViewInfo
BaseSpinEditViewInfo
DedNet.ControlsDedTextSpinEditViewInfo

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedTextSpinEditViewInfo : BaseSpinEditViewInfo
Public Class DedTextSpinEditViewInfo
    Inherits BaseSpinEditViewInfo
public ref class DedTextSpinEditViewInfo : public BaseSpinEditViewInfo
type DedTextSpinEditViewInfo =
    class
        inherit BaseSpinEditViewInfo
    end

Il tipo DedTextSpinEditViewInfo espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedTextSpinEditViewInfo |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà protetta | ActiveLookAndFeel | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | AllowAnimation | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | AllowDrawContent | (Ereditato da TextEditViewInfo)
Proprietà protetta | AllowDrawErrorIconParentBackground | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | AllowDrawFocusRect | (Ereditato da BaseEditViewInfo)
Proprietà protetta | AllowDrawParentBackground | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | AllowDrawText | (Ereditato da ButtonEditViewInfo)
Proprietà protetta | AllowedSkinElementsForBackgroundSkinningMode | (Ereditato da TextEditViewInfo)
Proprietà pubblica | AllowHtmlString | (Ereditato da TextEditViewInfo)
Proprietà pubblica | AllowMaskBox | (Ereditato da ButtonEditViewInfo)
Proprietà protetta | AllowMaskBoxWhenDisabled | (Ereditato da TextEditViewInfo)
Proprietà pubblica | AllowOverridedState | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | AllowScaleWidth | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | AllowTextToolTip | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | AllowValueChangeAnimation | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | AnimatedDisplayStringProvider | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | Appearance | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | AppearanceDisabled | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | AutoCorrectForeColor | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | BackgroundPainter | (Ereditato da TextEditViewInfo)
Proprietà pubblica | BaselinePosition | (Ereditato da TextEditViewInfo)
Proprietà pubblica | BestFitIsLookUp | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | BorderPainter | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | BorderRect | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | BorderStyle | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | Bounds | (Ereditato da BaseControlViewInfo)
Proprietà protetta | CalculatingTextSize | (Ereditato da BaseControlViewInfo)
Proprietà protetta | CanUseFocusedAppearance | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | ClientRect | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | ContentRect | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | ContextImage | (Ereditato da TextEditViewInfo)
Proprietà pubblica | ContextImageAlignment | (Ereditato da TextEditViewInfo)
Proprietà pubblica | ContextImageBounds | (Ereditato da TextEditViewInfo)
Proprietà protetta | ContextImageContainer | (Ereditato da TextEditViewInfo)
Proprietà pubblica | ContextImagePadding | (Ereditato da TextEditViewInfo)
Proprietà protetta | ContextImageSizeCompensation | (Ereditato da TextEditViewInfo)
Proprietà protetta | DefaultAllowBackgroundSkinningMode | (Ereditato da TextEditViewInfo)
Proprietà pubblica | DefaultAllowDrawFocusRect | (Ereditato da TextEditViewInfo)
Proprietà pubblica | DefaultAppearance | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | DefaultBorderStyle | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | DefaultTextOptions | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | DetailLevel | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | DisplayText | (Ereditato da TextEditViewInfo)
Proprietà protetta | DrawBackgroundSkinElement | (Ereditato da TextEditViewInfo)
Proprietà pubblica | DrawFocusRect | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | Editable | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | EditorButtonPainter | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | EditValue | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | Enabled | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | ErrorIcon | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | ErrorIconAlignment | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | ErrorIconBounds | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | ErrorIconText | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | FillBackground | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | Focused | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | FocusRect | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | FocusRectThin | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | ForceShowErrorIcon | (Ereditato da BaseEditViewInfo)
Proprietà protetta | ForceUseSimpleMaskStrategy | (Ereditato da TextEditViewInfo)
Proprietà pubblica | Format | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | FormatFromContainer | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | GInfo | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | GlyphAlignment | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | GlyphBounds | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | GlyphDrawMode | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | HasMatchedString | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | HotInfo | (Ereditato da BaseEditViewInfo)
Proprietà protetta | HtmlTextBoundsWithoutImages | (Ereditato da TextEditViewInfo)
Proprietà protetta | HtmlTextSizeCore | (Ereditato da TextEditViewInfo)
Proprietà protetta | ImageAnimationProvider | (Ereditato da TextEditViewInfo)
Proprietà pubblica | ImageIndex | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | Images | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | ImageSize | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | InplaceAnimationBounds | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | InplaceOwnerControl | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | InplaceStringImageProvider | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | InplaceStringSvgImageProvider | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | InplaceType | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | InternalButtons | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | InValueChangeAnimation | (Ereditato da BaseEditViewInfo)
Proprietà protetta | IsAutoHotSingleButton | (Ereditato da BaseSpinEditViewInfo)
Proprietà pubblica | IsCalcBestFit | (Ereditato da TextEditViewInfo)
Proprietà pubblica | IsCellFocused | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | IsCellSelected | (Ereditato da BaseEditViewInfo)
Proprietà protetta | IsDrawButtons | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | IsEmptyValue | (Ereditato da TextEditViewInfo)
Proprietà protetta | IsEqualsEditValueCore | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | IsExistImage | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | IsGridAllowsFocus | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | IsGridFocused | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | IsInFocusedRow | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | IsInvertIncrementalSearchString | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | IsLoadingValue | (Ereditato da BaseEditViewInfo)
Proprietà protetta | IsLockStateChanging | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | IsNullValue | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | IsPrinting | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | IsReady | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | IsRequiredUpdateOnMouseMove | (Ereditato da ButtonEditViewInfo)
Proprietà protetta | IsSkinLookAndFeel | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | IsSupportFastViewInfo | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | IsSupportIncrementalSearch | (Ereditato da ButtonEditViewInfo)
Proprietà protetta | IsTryGetThreadSafeFuncValid | (Ereditato da BaseSpinEditViewInfo)
Proprietà pubblica | Item | (Ereditato da BaseSpinEditViewInfo)
Proprietà pubblica | LeftButtons | (Ereditato da ButtonEditViewInfo)
Proprietà protetta | LinkColor | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | LookAndFeel | (Ereditato da BaseEditViewInfo)
Proprietà protetta | MaskBoxPadding | (Ereditato da TextEditViewInfo)
Proprietà pubblica | MaskBoxRect | (Ereditato da TextEditViewInfo)
Proprietà pubblica | MatchedRanges | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | MatchedString | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | MatchedStringAllowPartial | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | MatchedStringUseContains | (Ereditato da BaseEditViewInfo)
Proprietà protetta | MaxTextWidth | (Ereditato da TextEditViewInfo)
Proprietà pubblica | MouseButtons | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | MousePosition | (Ereditato da BaseControlViewInfo)
Proprietà protetta | NullValuePromptForeColor | (Ereditato da TextEditViewInfo)
Proprietà pubblica | OverridedState | (Ereditato da BaseEditViewInfo)
Proprietà protetta | Owner | (Ereditato da BaseControlViewInfo)
Proprietà protetta | OwnerControl | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | OwnerEdit | (Ereditato da TextEditViewInfo)
Proprietà pubblica | PaintAppearance | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | Painter | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | PCount | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | PressedInfo | (Ereditato da BaseEditViewInfo)
Proprietà protetta | PrevButtons | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | PrevDisplayText | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | PrevEditValue | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | PrevImageIndex | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | RefreshDisplayText | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | RequireClipping | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | RightButtons | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | RightToLeft | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | ShowErrorIcon | (Ereditato da BaseEditViewInfo)
Proprietà protetta | ShowNullValuePromptWhenFocused | (Ereditato da TextEditViewInfo)
Proprietà protetta | ShowNullValuePromptWhenReadOnly | (Ereditato da TextEditViewInfo)
Proprietà protetta | ShowTextToolTip | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | SpinButtonPainter | (Ereditato da BaseSpinEditViewInfo)
Proprietà pubblica | State | (Ereditato da BaseEditViewInfo)
Proprietà protetta | StringInfo | (Ereditato da BaseControlViewInfo)
Proprietà protetta | StyleController | (Ereditato da BaseControlViewInfo)
Proprietà protetta | SupportValueChangeAnimation | (Ereditato da TextEditViewInfo)
Proprietà pubblica | Tag | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | TextBaselineOffset | (Ereditato da TextEditViewInfo)
Proprietà protetta | TextGlyphIndent | (Ereditato da ButtonEditViewInfo)
Proprietà protetta | TextSize | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | TextUseFullBounds | (Ereditato da BaseEditViewInfo)
Proprietà protetta | UseAdvancedHtmlTextAndImageLayout | (Ereditato da TextEditViewInfo)
Proprietà pubblica | UseAdvancedMode | (Ereditato da TextEditViewInfo)
Proprietà protetta | UseBackgroundSkinElement | (Ereditato da TextEditViewInfo)
Proprietà protetta | UseDisabledAppearance | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | UseHighlightSearchAppearance | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | UseParentBackground | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | ValueChangeAnimation | (Ereditato da BaseEditViewInfo)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | AdjustEditorSize | (Ereditato da TextEditViewInfo)
Metodo protetto | AllowDrawInplaceBackground | (Ereditato da BaseEditViewInfo)
Metodo pubblico | AnimateValueChanged | (Ereditato da BaseEditViewInfo)
Metodo protetto | AnimateValueChanged(Object, Object) | (Ereditato da TextEditViewInfo)
Metodo protetto | ApplySkinElement | (Ereditato da BaseControlViewInfo)
Metodo protetto | AreObjectsEquals | (Ereditato da TextEditViewInfo)
Metodo protetto | Assign | (Ereditato da BaseSpinEditViewInfo)
Metodo pubblico | BeginPaint | (Ereditato da BaseControlViewInfo)
Metodo protetto | BestFitUpdateToMaximumWidthString(Object) | (Ereditato da TextEditViewInfo)
Metodo pubblico | BestFitUpdateToMaximumWidthString(String) | (Ereditato da BaseEditViewInfo)
Metodo pubblico | ButtonInfoByButton | (Ereditato da ButtonEditViewInfo)
Metodo pubblico | ButtonInfoById | (Ereditato da BaseSpinEditViewInfo)
Metodo pubblico | ButtonInfoByPoint | (Ereditato da BaseSpinEditViewInfo)
Metodo protetto | CalcAdvancedModeTextSize | (Ereditato da TextEditViewInfo)
Metodo pubblico | CalcBestFit(Graphics) | (Ereditato da BaseEditViewInfo)
Metodo pubblico | CalcBestFit(Graphics, String) | (Ereditato da BaseEditViewInfo)
Metodo protetto | CalcBestFitTextSize | (Ereditato da ButtonEditViewInfo)
Metodo pubblico | CalcBorderState | (Ereditato da TextEditViewInfo)
Metodo protetto | CalcButtons | (Ereditato da ButtonEditViewInfo)
Metodo protetto | CalcButtonState | (Ereditato da BaseSpinEditViewInfo)
Metodo protetto | CalcClientRect | (Ereditato da BaseEditViewInfo)
Metodo protetto | CalcClientRectCore | (Ereditato da TextEditViewInfo)
Metodo protetto | CalcClientSize | (Ereditato da ButtonEditViewInfo)
Metodo protetto | CalcConstants | (Ereditato da BaseEditViewInfo)
Metodo protetto | CalcContentRect | (Ereditato da ButtonEditViewInfo)
Metodo protetto | CalcContentSize | (Ereditato da TextEditViewInfo)
Metodo protetto | CalcContentTextSize | (Ereditato da ButtonEditViewInfo)
Metodo protetto | CalcContextImageSize | (Ereditato da TextEditViewInfo)
Metodo protetto | CalcFocusRect | (Ereditato da BaseEditViewInfo)
Metodo protetto | CalcGlyphBounds | (Ereditato da ButtonEditViewInfo)
Metodo pubblico | CalcHitInfo | (Ereditato da ButtonEditViewInfo)
Metodo protetto | CalcHtmlTextSize | (Ereditato da TextEditViewInfo)
Metodo protetto | CalcMaskBoxRect(Rectangle) | (Ereditato da TextEditViewInfo)
Metodo protetto | CalcMaskBoxRect(Rectangle, Rectangle) | (Ereditato da TextEditViewInfo)
Metodo protetto | CalcMinButtonBounds | (Ereditato da BaseSpinEditViewInfo)
Metodo pubblico | CalcMinHeight | (Ereditato da BaseEditViewInfo)
Metodo protetto | CalcMinHeightCore | (Ereditato da TextEditViewInfo)
Metodo protetto | CalcObjectState | (Ereditato da BaseEditViewInfo)
Metodo protetto | CalcRects | (Ereditato da BaseControlViewInfo)
Metodo protetto | CalcShowHint | (Ereditato da TextEditViewInfo)
Metodo protetto | CalcTextBaseline | (Ereditato da TextEditViewInfo)
Metodo protetto | CalcTextSize(Graphics) | (Ereditato da BaseControlViewInfo)
Metodo protetto | CalcTextSize(GraphicsCache) | (Ereditato da BaseControlViewInfo)
Metodo protetto | CalcTextSize(Graphics, Boolean) | (Ereditato da ButtonEditViewInfo)
Metodo protetto | CalcTextSize(GraphicsCache, Boolean) | (Ereditato da BaseControlViewInfo)
Metodo protetto | CalcTextSizeCore(Graphics, String, Int32) | (Ereditato da BaseControlViewInfo)
Metodo protetto | CalcTextSizeCore(GraphicsCache, String, Int32) | (Ereditato da TextEditViewInfo)
Metodo protetto | CalcTextToolTipInfo | (Ereditato da TextEditViewInfo)
Metodo pubblico | CalcViewInfo | (Ereditato da BaseControlViewInfo)
Metodo pubblico | CalcViewInfo(Graphics) | (Ereditato da TextEditViewInfo)
Metodo pubblico | CalcViewInfo(Graphics, MouseButtons, Point, Rectangle) | (Ereditato da BaseControlViewInfo)
Metodo protetto | CanDisplayButton | (Ereditato da ButtonEditViewInfo)
Metodo protetto | CanFastRecalcViewInfo | (Ereditato da TextEditViewInfo)
Metodo pubblico | CanPress | (Ereditato da ButtonEditViewInfo)
Metodo protetto | CheckAdvancedLabelBounds | (Ereditato da ButtonEditViewInfo)
Metodo protetto | CheckShowHint | (Ereditato da BaseControlViewInfo)
Metodo pubblico | CleanUp | (Ereditato da BaseEditViewInfo)
Metodo pubblico | Clear | (Ereditato da ButtonEditViewInfo)
Metodo pubblico | ClearMatchedText | (Ereditato da BaseEditViewInfo)
Metodo pubblico | Clone | (Ereditato da BaseEditViewInfo)
Metodo pubblico | Compare | (Ereditato da ButtonEditViewInfo)
Metodo pubblico | CompareHitInfo | (Ereditato da ButtonEditViewInfo)
Metodo protetto | CreateButtonInfo | (Ereditato da BaseSpinEditViewInfo)
Metodo protetto | CreateButtonInfoInstance | (Ereditato da ButtonEditViewInfo)
Metodo protetto | CreateButtonPainter | (Ereditato da ButtonEditViewInfo)
Metodo protetto | CreateCalcButtonsRectsArgs | (Ereditato da ButtonEditViewInfo)
Metodo protetto | CreateDefaultAppearance | (Ereditato da TextEditViewInfo)
Metodo protetto | CreateEditorBackgroundPainter | (Ereditato da TextEditViewInfo)
Metodo protetto | CreateHitInfo | (Ereditato da BaseEditViewInfo)
Metodo protetto | CreatePaintAppearance | (Ereditato da BaseControlViewInfo)
Metodo protetto | CreateSpinButtonPainter | (Ereditato da BaseSpinEditViewInfo)
Metodo protetto | CreateTextPainter | (Ereditato da TextEditViewInfo)
Metodo pubblico | Dispose | (Ereditato da TextEditViewInfo)
Metodo pubblico | EndPaint | (Ereditato da BaseControlViewInfo)
Metodo protetto | ForceEditValueChanged | (Ereditato da BaseEditViewInfo)
Metodo protetto | ForceHideNullValuePrompt | (Ereditato da TextEditViewInfo)
Metodo pubblico | GenerateAnimatedDisplayText | (Ereditato da BaseEditViewInfo)
Metodo pubblico | GenerateStartDisplayText | (Ereditato da BaseEditViewInfo)
Metodo pubblico | GenerateStartEditValue | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetAllowBackgroundSkinningMode | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetAnimateDisplayString | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetAutoCorrectForeColor | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetBackgroundSkinElement | (Ereditato da TextEditViewInfo)
Metodo pubblico | GetBeginGetDisplayTextsBulkScope | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetBorderArgs | (Ereditato da BaseControlViewInfo)
Metodo protetto | GetBorderPainter | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetBorderPainterCore | (Ereditato da TextEditViewInfo)
Metodo protetto | GetButtonAllowGlyphSkinning | (Ereditato da ButtonEditViewInfo)
Metodo pubblico | GetButtonPainter | (Ereditato da BaseSpinEditViewInfo)
Metodo protetto | GetCanAnimate | (Ereditato da TextEditViewInfo)
Metodo pubblico | GetContextImageSize | (Ereditato da TextEditViewInfo)
Metodo pubblico | GetDataBindingText | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetDefaultDuration | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetDefaultFont | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetDefaultSkinBorderPainter | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetDefaultSkinFont | (Ereditato da BaseControlViewInfo)
Metodo protetto | GetDefaultTextOptionsForHtmlText | (Ereditato da TextEditViewInfo)
Metodo protetto | GetDirectXClient | (Ereditato da BaseControlViewInfo)
Metodo protetto | GetDisplayText | (Ereditato da TextEditViewInfo)
Metodo protetto | GetDisplayTextCore | (Ereditato da TextEditViewInfo)
Metodo protetto | GetDuration | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetEditorAppearance | (Ereditato da BaseEditViewInfo)
Metodo pubblico | GetErrorIcon | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetErrorIconBestSize | (Ereditato da BaseEditViewInfo)
Metodo pubblico | GetErrorIconSize | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetHtmlContext | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetInplaceBorderPainter | (Ereditato da BaseEditViewInfo)
Metodo pubblico | GetMouseCursor(Point) | (Ereditato da BaseEditViewInfo)
Metodo pubblico | GetMouseCursor(Int32, Int32) | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetPrevButtonState | (Ereditato da ButtonEditViewInfo)
Metodo protetto | GetRealLookAndFeelForSvgPalette | (Ereditato da TextEditViewInfo)
Metodo protetto | GetScaleDpi | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetShowHotKeyPrefix | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetSkinElement | (Ereditato da BaseControlViewInfo)
Metodo protetto | GetSvgPaletteProviderForContextImage | (Ereditato da TextEditViewInfo)
Metodo pubblico | GetSystemColor | (Ereditato da BaseControlViewInfo)
Metodo pubblico | GetTextAscentHeight | (Ereditato da BaseEditViewInfo)
Metodo pubblico | GetTextBounds | (Ereditato da TextEditViewInfo)
Metodo protetto | GetTextBoxContentPadding | (Ereditato da ButtonEditViewInfo)
Metodo protetto | GetTextBoxContentPaddingCore | (Ereditato da TextEditViewInfo)
Metodo protetto | GetTextToButtonPadding | (Ereditato da ButtonEditViewInfo)
Metodo protetto | GetTextToolTipWidth | (Ereditato da TextEditViewInfo)
Metodo pubblico | GetToolTipInfo | (Ereditato da ButtonEditViewInfo)
Metodo protetto | GetToolTipText | (Ereditato da TextEditViewInfo)
Metodo pubblico | GetValueChangeAnimation | (Ereditato da BaseEditViewInfo)
Metodo pubblico | GetWidthForAutoHeight | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetWidthForAutoHeightCore | (Ereditato da BaseEditViewInfo)
Metodo protetto | IsAnyButtonPressed | (Ereditato da ButtonEditViewInfo)
Metodo protetto | IsButtonPressed | (Ereditato da ButtonEditViewInfo)
Metodo protetto | IsHotEdit | (Ereditato da BaseEditViewInfo)
Metodo protetto | IsOffice2003ExBorder | (Ereditato da BaseEditViewInfo)
Metodo protetto | IsShowNullValuePrompt | (Ereditato da TextEditViewInfo)
Metodo protetto | IsTextToolTipPoint | (Ereditato da ButtonEditViewInfo)
Metodo protetto | IsVisualEqualsEditValue | (Ereditato da TextEditViewInfo)
Metodo pubblico | Offset(Point) | (Ereditato da BaseEditViewInfo)
Metodo pubblico | Offset(Int32, Int32) | (Ereditato da ButtonEditViewInfo)
Metodo protetto | OnBeforeButtonStateChanged | (Ereditato da ButtonEditViewInfo)
Metodo protetto | OnBeginPaint | (Ereditato da BaseControlViewInfo)
Metodo protetto | OnEditValueChanged | (Ereditato da BaseEditViewInfo)
Metodo protetto | OnEndPaint | (Ereditato da BaseControlViewInfo)
Metodo protetto | OnInplaceTpeChanged | (Ereditato da BaseEditViewInfo)
Metodo protetto | OnInplaceTypeChanged | (Ereditato da BaseEditViewInfo)
Metodo protetto | OnIsCellSelectedChanged | (Ereditato da BaseEditViewInfo)
Metodo protetto | OnIsGridFocusedChanged | (Ereditato da BaseEditViewInfo)
Metodo protetto | OnPaintAppearanceChanged | (Ereditato da ButtonEditViewInfo)
Metodo pubblico | PermitSkinInplaceSateLeftEdge | (Ereditato da BaseEditViewInfo)
Metodo pubblico | PermitSkinInplaceState | (Ereditato da BaseEditViewInfo)
Metodo protetto | QuerySkinPaddings | (Ereditato da ButtonEditViewInfo)
Metodo protetto | QueryUseAdvancedMode | (Ereditato da TextEditViewInfo)
Metodo protetto | ReCalcRects | (Ereditato da BaseControlViewInfo)
Metodo pubblico | ReCalcViewInfo | (Ereditato da BaseControlViewInfo)
Metodo protetto | ReCalcViewInfoCore | (Ereditato da BaseEditViewInfo)
Metodo protetto | RequestInplaceBackgroundElement | (Ereditato da BaseEditViewInfo)
Metodo protetto | RequestUseAdvancedMode | (Ereditato da BaseEditViewInfo)
Metodo pubblico | Reset | (Ereditato da TextEditViewInfo)
Metodo protetto | ResetAppearanceDefault | (Ereditato da BaseControlViewInfo)
Metodo pubblico | ResetCachedData | (Ereditato da BaseEditViewInfo)
Metodo protetto | ResetForceHideNullValuePrompt | (Ereditato da TextEditViewInfo)
Metodo protetto | ResetState | (Ereditato da ButtonEditViewInfo)
Metodo protetto | ResetTextSize | (Ereditato da BaseControlViewInfo)
Metodo pubblico | ScaleInteger | (Ereditato da BaseControlViewInfo)
Metodo protetto | ScalePaddingInternal | (Ereditato da BaseControlViewInfo)
Metodo pubblico | ScaleSize | (Ereditato da BaseControlViewInfo)
Metodo pubblico | SetDisplayText(String) | (Ereditato da BaseEditViewInfo)
Metodo pubblico | SetDisplayText(String, Object) | (Ereditato da BaseEditViewInfo)
Metodo pubblico | SetGraphicsInfo | (Ereditato da BaseControlViewInfo)
Metodo pubblico | SetMaskBoxRect | (Ereditato da TextEditViewInfo)
Metodo protetto | SetPaintAppearance | (Ereditato da BaseControlViewInfo)
Metodo pubblico | SetPrevEditValue | (Ereditato da BaseEditViewInfo)
Metodo protetto | ShouldDrawFocusRectCore | (Ereditato da BaseControlViewInfo)
Metodo protetto | SupportValueChangeAnimationCore | (Ereditato da BaseEditViewInfo)
Metodo protetto | SuppressBackgroundSkinElement | (Ereditato da TextEditViewInfo)
Metodo pubblico | SuppressSkinInplaceState | (Ereditato da BaseEditViewInfo)
Metodo pubblico | SuppressSkinInplaceStateLeftEdge | (Ereditato da BaseEditViewInfo)
Metodo pubblico | TryGetThreadSafeGetDisplayTextFunc | (Ereditato da TextEditViewInfo)
Metodo protetto | TryGetThreadSafeOnEditValueChangedFunc | (Ereditato da BaseEditViewInfo)
Metodo pubblico | UpdateAppearances | (Ereditato da BaseControlViewInfo)
Metodo protetto | UpdateBestFitAppearance | (Ereditato da BaseControlViewInfo)
Metodo pubblico | UpdateBoundValues | (Ereditato da BaseEditViewInfo)
Metodo protetto | UpdateByGlyphSize | (Ereditato da ButtonEditViewInfo)
Metodo protetto | UpdateContentRectByFocusRect | (Ereditato da TextEditViewInfo)
Metodo pubblico | UpdateEditValue | (Ereditato da BaseEditViewInfo)
Metodo protetto | UpdateEnabledState | (Ereditato da BaseEditViewInfo)
Metodo protetto | UpdateFromEditor | (Ereditato da ButtonEditViewInfo)
Metodo protetto | UpdateFromOwner | (Ereditato da BaseEditViewInfo)
Metodo pubblico | UpdateGridState | (Ereditato da BaseEditViewInfo)
Metodo pubblico | UpdateGroupValueDisplayText | (Ereditato da BaseEditViewInfo)
Metodo pubblico | UpdateInplaceAnimation | (Ereditato da BaseEditViewInfo)
Metodo protetto | UpdateMaskBoxPadding | (Ereditato da TextEditViewInfo)
Metodo protetto | UpdateMaxBoxRectangle | (Ereditato da TextEditViewInfo)
Metodo protetto | UpdateObjectState | (Ereditato da ButtonEditViewInfo)
Metodo pubblico | UpdateObjectState(MouseButtons, Point) | (Ereditato da BaseControlViewInfo)
Metodo protetto | UpdateObjectStateCore | (Ereditato da BaseControlViewInfo)
Metodo pubblico | UpdatePaintAppearance | (Ereditato da TextEditViewInfo)
Metodo protetto | UpdatePaintAppearance(IStyleController, AppearanceDefault) | (Ereditato da BaseControlViewInfo)
Metodo protetto | UpdatePainters | (Ereditato da BaseSpinEditViewInfo)
Metodo protetto | UpdateSizeByFocusRect | (Ereditato da TextEditViewInfo)
Metodo protetto | UseSkinSpecifiedSettings | (Ereditato da TextEditViewInfo)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | fAppearance | (Ereditato da BaseControlViewInfo)
Campo protetto | fAppearanceDisabled | (Ereditato da BaseEditViewInfo)
Campo protetto | fBorderRect | (Ereditato da BaseControlViewInfo)
Campo protetto | fBounds | (Ereditato da BaseControlViewInfo)
Campo protetto | fClientRect | (Ereditato da BaseControlViewInfo)
Campo protetto | fContentRect | (Ereditato da BaseControlViewInfo)
Campo protetto | fDisplayText | (Ereditato da BaseEditViewInfo)
Campo protetto | fEditValue | (Ereditato da BaseEditViewInfo)
Campo protetto | fErrorIcon | (Ereditato da BaseEditViewInfo)
Campo protetto | fErrorIconBounds | (Ereditato da BaseEditViewInfo)
Campo protetto | fErrorIconSize | (Ereditato da BaseEditViewInfo)
Campo protetto | fFocusRect | (Ereditato da BaseControlViewInfo)
Campo protetto | fFormat | (Ereditato da BaseEditViewInfo)
Campo protetto | fHotInfo | (Ereditato da BaseEditViewInfo)
Campo protetto | fLookAndFeel | (Ereditato da BaseEditViewInfo)
Campo protetto | fMaskBoxRect | (Ereditato da TextEditViewInfo)
Campo protetto | fMatchedString | (Ereditato da BaseEditViewInfo)
Campo protetto | fPressedInfo | (Ereditato da BaseEditViewInfo)
Campo protetto | fState | (Ereditato da BaseControlViewInfo)
Campo protetto | fTextSize | (Ereditato da BaseEditViewInfo)
Campo protetto | lockCalculatingTextSize | (Ereditato da BaseControlViewInfo)
Campo protetto | toolTipInfoCalculated | (Ereditato da BaseControlViewInfo)
Campo protetto | ValueChangeAnimationId | (Ereditato da BaseEditViewInfo)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore DedTextSpinEditViewInfo

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTextSpinEditViewInfo(
    RepositoryItem item
)
Public Sub New (
    item As RepositoryItem
)
public:
DedTextSpinEditViewInfo(
    RepositoryItem^ item
)
new :
        item : RepositoryItem -> DedTextSpinEditViewInfo

Parametri

item RepositoryItem
Vedi anche

Documentazione

Classe DedTextSpinEditViewInfo
Namespace DedNet.Controls


Proprietà di DedTextSpinEditViewInfo

Il tipo DedTextSpinEditViewInfo espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà protetta | ActiveLookAndFeel | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | AllowAnimation | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | AllowDrawContent | (Ereditato da TextEditViewInfo)
Proprietà protetta | AllowDrawErrorIconParentBackground | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | AllowDrawFocusRect | (Ereditato da BaseEditViewInfo)
Proprietà protetta | AllowDrawParentBackground | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | AllowDrawText | (Ereditato da ButtonEditViewInfo)
Proprietà protetta | AllowedSkinElementsForBackgroundSkinningMode | (Ereditato da TextEditViewInfo)
Proprietà pubblica | AllowHtmlString | (Ereditato da TextEditViewInfo)
Proprietà pubblica | AllowMaskBox | (Ereditato da ButtonEditViewInfo)
Proprietà protetta | AllowMaskBoxWhenDisabled | (Ereditato da TextEditViewInfo)
Proprietà pubblica | AllowOverridedState | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | AllowScaleWidth | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | AllowTextToolTip | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | AllowValueChangeAnimation | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | AnimatedDisplayStringProvider | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | Appearance | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | AppearanceDisabled | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | AutoCorrectForeColor | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | BackgroundPainter | (Ereditato da TextEditViewInfo)
Proprietà pubblica | BaselinePosition | (Ereditato da TextEditViewInfo)
Proprietà pubblica | BestFitIsLookUp | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | BorderPainter | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | BorderRect | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | BorderStyle | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | Bounds | (Ereditato da BaseControlViewInfo)
Proprietà protetta | CalculatingTextSize | (Ereditato da BaseControlViewInfo)
Proprietà protetta | CanUseFocusedAppearance | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | ClientRect | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | ContentRect | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | ContextImage | (Ereditato da TextEditViewInfo)
Proprietà pubblica | ContextImageAlignment | (Ereditato da TextEditViewInfo)
Proprietà pubblica | ContextImageBounds | (Ereditato da TextEditViewInfo)
Proprietà protetta | ContextImageContainer | (Ereditato da TextEditViewInfo)
Proprietà pubblica | ContextImagePadding | (Ereditato da TextEditViewInfo)
Proprietà protetta | ContextImageSizeCompensation | (Ereditato da TextEditViewInfo)
Proprietà protetta | DefaultAllowBackgroundSkinningMode | (Ereditato da TextEditViewInfo)
Proprietà pubblica | DefaultAllowDrawFocusRect | (Ereditato da TextEditViewInfo)
Proprietà pubblica | DefaultAppearance | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | DefaultBorderStyle | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | DefaultTextOptions | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | DetailLevel | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | DisplayText | (Ereditato da TextEditViewInfo)
Proprietà protetta | DrawBackgroundSkinElement | (Ereditato da TextEditViewInfo)
Proprietà pubblica | DrawFocusRect | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | Editable | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | EditorButtonPainter | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | EditValue | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | Enabled | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | ErrorIcon | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | ErrorIconAlignment | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | ErrorIconBounds | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | ErrorIconText | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | FillBackground | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | Focused | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | FocusRect | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | FocusRectThin | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | ForceShowErrorIcon | (Ereditato da BaseEditViewInfo)
Proprietà protetta | ForceUseSimpleMaskStrategy | (Ereditato da TextEditViewInfo)
Proprietà pubblica | Format | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | FormatFromContainer | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | GInfo | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | GlyphAlignment | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | GlyphBounds | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | GlyphDrawMode | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | HasMatchedString | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | HotInfo | (Ereditato da BaseEditViewInfo)
Proprietà protetta | HtmlTextBoundsWithoutImages | (Ereditato da TextEditViewInfo)
Proprietà protetta | HtmlTextSizeCore | (Ereditato da TextEditViewInfo)
Proprietà protetta | ImageAnimationProvider | (Ereditato da TextEditViewInfo)
Proprietà pubblica | ImageIndex | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | Images | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | ImageSize | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | InplaceAnimationBounds | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | InplaceOwnerControl | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | InplaceStringImageProvider | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | InplaceStringSvgImageProvider | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | InplaceType | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | InternalButtons | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | InValueChangeAnimation | (Ereditato da BaseEditViewInfo)
Proprietà protetta | IsAutoHotSingleButton | (Ereditato da BaseSpinEditViewInfo)
Proprietà pubblica | IsCalcBestFit | (Ereditato da TextEditViewInfo)
Proprietà pubblica | IsCellFocused | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | IsCellSelected | (Ereditato da BaseEditViewInfo)
Proprietà protetta | IsDrawButtons | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | IsEmptyValue | (Ereditato da TextEditViewInfo)
Proprietà protetta | IsEqualsEditValueCore | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | IsExistImage | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | IsGridAllowsFocus | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | IsGridFocused | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | IsInFocusedRow | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | IsInvertIncrementalSearchString | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | IsLoadingValue | (Ereditato da BaseEditViewInfo)
Proprietà protetta | IsLockStateChanging | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | IsNullValue | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | IsPrinting | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | IsReady | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | IsRequiredUpdateOnMouseMove | (Ereditato da ButtonEditViewInfo)
Proprietà protetta | IsSkinLookAndFeel | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | IsSupportFastViewInfo | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | IsSupportIncrementalSearch | (Ereditato da ButtonEditViewInfo)
Proprietà protetta | IsTryGetThreadSafeFuncValid | (Ereditato da BaseSpinEditViewInfo)
Proprietà pubblica | Item | (Ereditato da BaseSpinEditViewInfo)
Proprietà pubblica | LeftButtons | (Ereditato da ButtonEditViewInfo)
Proprietà protetta | LinkColor | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | LookAndFeel | (Ereditato da BaseEditViewInfo)
Proprietà protetta | MaskBoxPadding | (Ereditato da TextEditViewInfo)
Proprietà pubblica | MaskBoxRect | (Ereditato da TextEditViewInfo)
Proprietà pubblica | MatchedRanges | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | MatchedString | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | MatchedStringAllowPartial | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | MatchedStringUseContains | (Ereditato da BaseEditViewInfo)
Proprietà protetta | MaxTextWidth | (Ereditato da TextEditViewInfo)
Proprietà pubblica | MouseButtons | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | MousePosition | (Ereditato da BaseControlViewInfo)
Proprietà protetta | NullValuePromptForeColor | (Ereditato da TextEditViewInfo)
Proprietà pubblica | OverridedState | (Ereditato da BaseEditViewInfo)
Proprietà protetta | Owner | (Ereditato da BaseControlViewInfo)
Proprietà protetta | OwnerControl | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | OwnerEdit | (Ereditato da TextEditViewInfo)
Proprietà pubblica | PaintAppearance | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | Painter | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | PCount | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | PressedInfo | (Ereditato da BaseEditViewInfo)
Proprietà protetta | PrevButtons | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | PrevDisplayText | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | PrevEditValue | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | PrevImageIndex | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | RefreshDisplayText | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | RequireClipping | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | RightButtons | (Ereditato da ButtonEditViewInfo)
Proprietà pubblica | RightToLeft | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | ShowErrorIcon | (Ereditato da BaseEditViewInfo)
Proprietà protetta | ShowNullValuePromptWhenFocused | (Ereditato da TextEditViewInfo)
Proprietà protetta | ShowNullValuePromptWhenReadOnly | (Ereditato da TextEditViewInfo)
Proprietà protetta | ShowTextToolTip | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | SpinButtonPainter | (Ereditato da BaseSpinEditViewInfo)
Proprietà pubblica | State | (Ereditato da BaseEditViewInfo)
Proprietà protetta | StringInfo | (Ereditato da BaseControlViewInfo)
Proprietà protetta | StyleController | (Ereditato da BaseControlViewInfo)
Proprietà protetta | SupportValueChangeAnimation | (Ereditato da TextEditViewInfo)
Proprietà pubblica | Tag | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | TextBaselineOffset | (Ereditato da TextEditViewInfo)
Proprietà protetta | TextGlyphIndent | (Ereditato da ButtonEditViewInfo)
Proprietà protetta | TextSize | (Ereditato da BaseControlViewInfo)
Proprietà pubblica | TextUseFullBounds | (Ereditato da BaseEditViewInfo)
Proprietà protetta | UseAdvancedHtmlTextAndImageLayout | (Ereditato da TextEditViewInfo)
Proprietà pubblica | UseAdvancedMode | (Ereditato da TextEditViewInfo)
Proprietà protetta | UseBackgroundSkinElement | (Ereditato da TextEditViewInfo)
Proprietà protetta | UseDisabledAppearance | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | UseHighlightSearchAppearance | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | UseParentBackground | (Ereditato da BaseEditViewInfo)
Proprietà pubblica | ValueChangeAnimation | (Ereditato da BaseEditViewInfo)
Torna su
Vedi anche

Documentazione

Classe DedTextSpinEditViewInfo
Namespace DedNet.Controls


Metodi di DedTextSpinEditViewInfo

Il tipo DedTextSpinEditViewInfo espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | AdjustEditorSize | (Ereditato da TextEditViewInfo)
Metodo protetto | AllowDrawInplaceBackground | (Ereditato da BaseEditViewInfo)
Metodo pubblico | AnimateValueChanged | (Ereditato da BaseEditViewInfo)
Metodo protetto | AnimateValueChanged(Object, Object) | (Ereditato da TextEditViewInfo)
Metodo protetto | ApplySkinElement | (Ereditato da BaseControlViewInfo)
Metodo protetto | AreObjectsEquals | (Ereditato da TextEditViewInfo)
Metodo protetto | Assign | (Ereditato da BaseSpinEditViewInfo)
Metodo pubblico | BeginPaint | (Ereditato da BaseControlViewInfo)
Metodo protetto | BestFitUpdateToMaximumWidthString(Object) | (Ereditato da TextEditViewInfo)
Metodo pubblico | BestFitUpdateToMaximumWidthString(String) | (Ereditato da BaseEditViewInfo)
Metodo pubblico | ButtonInfoByButton | (Ereditato da ButtonEditViewInfo)
Metodo pubblico | ButtonInfoById | (Ereditato da BaseSpinEditViewInfo)
Metodo pubblico | ButtonInfoByPoint | (Ereditato da BaseSpinEditViewInfo)
Metodo protetto | CalcAdvancedModeTextSize | (Ereditato da TextEditViewInfo)
Metodo pubblico | CalcBestFit(Graphics) | (Ereditato da BaseEditViewInfo)
Metodo pubblico | CalcBestFit(Graphics, String) | (Ereditato da BaseEditViewInfo)
Metodo protetto | CalcBestFitTextSize | (Ereditato da ButtonEditViewInfo)
Metodo pubblico | CalcBorderState | (Ereditato da TextEditViewInfo)
Metodo protetto | CalcButtons | (Ereditato da ButtonEditViewInfo)
Metodo protetto | CalcButtonState | (Ereditato da BaseSpinEditViewInfo)
Metodo protetto | CalcClientRect | (Ereditato da BaseEditViewInfo)
Metodo protetto | CalcClientRectCore | (Ereditato da TextEditViewInfo)
Metodo protetto | CalcClientSize | (Ereditato da ButtonEditViewInfo)
Metodo protetto | CalcConstants | (Ereditato da BaseEditViewInfo)
Metodo protetto | CalcContentRect | (Ereditato da ButtonEditViewInfo)
Metodo protetto | CalcContentSize | (Ereditato da TextEditViewInfo)
Metodo protetto | CalcContentTextSize | (Ereditato da ButtonEditViewInfo)
Metodo protetto | CalcContextImageSize | (Ereditato da TextEditViewInfo)
Metodo protetto | CalcFocusRect | (Ereditato da BaseEditViewInfo)
Metodo protetto | CalcGlyphBounds | (Ereditato da ButtonEditViewInfo)
Metodo pubblico | CalcHitInfo | (Ereditato da ButtonEditViewInfo)
Metodo protetto | CalcHtmlTextSize | (Ereditato da TextEditViewInfo)
Metodo protetto | CalcMaskBoxRect(Rectangle) | (Ereditato da TextEditViewInfo)
Metodo protetto | CalcMaskBoxRect(Rectangle, Rectangle) | (Ereditato da TextEditViewInfo)
Metodo protetto | CalcMinButtonBounds | (Ereditato da BaseSpinEditViewInfo)
Metodo pubblico | CalcMinHeight | (Ereditato da BaseEditViewInfo)
Metodo protetto | CalcMinHeightCore | (Ereditato da TextEditViewInfo)
Metodo protetto | CalcObjectState | (Ereditato da BaseEditViewInfo)
Metodo protetto | CalcRects | (Ereditato da BaseControlViewInfo)
Metodo protetto | CalcShowHint | (Ereditato da TextEditViewInfo)
Metodo protetto | CalcTextBaseline | (Ereditato da TextEditViewInfo)
Metodo protetto | CalcTextSize(Graphics) | (Ereditato da BaseControlViewInfo)
Metodo protetto | CalcTextSize(GraphicsCache) | (Ereditato da BaseControlViewInfo)
Metodo protetto | CalcTextSize(Graphics, Boolean) | (Ereditato da ButtonEditViewInfo)
Metodo protetto | CalcTextSize(GraphicsCache, Boolean) | (Ereditato da BaseControlViewInfo)
Metodo protetto | CalcTextSizeCore(Graphics, String, Int32) | (Ereditato da BaseControlViewInfo)
Metodo protetto | CalcTextSizeCore(GraphicsCache, String, Int32) | (Ereditato da TextEditViewInfo)
Metodo protetto | CalcTextToolTipInfo | (Ereditato da TextEditViewInfo)
Metodo pubblico | CalcViewInfo | (Ereditato da BaseControlViewInfo)
Metodo pubblico | CalcViewInfo(Graphics) | (Ereditato da TextEditViewInfo)
Metodo pubblico | CalcViewInfo(Graphics, MouseButtons, Point, Rectangle) | (Ereditato da BaseControlViewInfo)
Metodo protetto | CanDisplayButton | (Ereditato da ButtonEditViewInfo)
Metodo protetto | CanFastRecalcViewInfo | (Ereditato da TextEditViewInfo)
Metodo pubblico | CanPress | (Ereditato da ButtonEditViewInfo)
Metodo protetto | CheckAdvancedLabelBounds | (Ereditato da ButtonEditViewInfo)
Metodo protetto | CheckShowHint | (Ereditato da BaseControlViewInfo)
Metodo pubblico | CleanUp | (Ereditato da BaseEditViewInfo)
Metodo pubblico | Clear | (Ereditato da ButtonEditViewInfo)
Metodo pubblico | ClearMatchedText | (Ereditato da BaseEditViewInfo)
Metodo pubblico | Clone | (Ereditato da BaseEditViewInfo)
Metodo pubblico | Compare | (Ereditato da ButtonEditViewInfo)
Metodo pubblico | CompareHitInfo | (Ereditato da ButtonEditViewInfo)
Metodo protetto | CreateButtonInfo | (Ereditato da BaseSpinEditViewInfo)
Metodo protetto | CreateButtonInfoInstance | (Ereditato da ButtonEditViewInfo)
Metodo protetto | CreateButtonPainter | (Ereditato da ButtonEditViewInfo)
Metodo protetto | CreateCalcButtonsRectsArgs | (Ereditato da ButtonEditViewInfo)
Metodo protetto | CreateDefaultAppearance | (Ereditato da TextEditViewInfo)
Metodo protetto | CreateEditorBackgroundPainter | (Ereditato da TextEditViewInfo)
Metodo protetto | CreateHitInfo | (Ereditato da BaseEditViewInfo)
Metodo protetto | CreatePaintAppearance | (Ereditato da BaseControlViewInfo)
Metodo protetto | CreateSpinButtonPainter | (Ereditato da BaseSpinEditViewInfo)
Metodo protetto | CreateTextPainter | (Ereditato da TextEditViewInfo)
Metodo pubblico | Dispose | (Ereditato da TextEditViewInfo)
Metodo pubblico | EndPaint | (Ereditato da BaseControlViewInfo)
Metodo protetto | ForceEditValueChanged | (Ereditato da BaseEditViewInfo)
Metodo protetto | ForceHideNullValuePrompt | (Ereditato da TextEditViewInfo)
Metodo pubblico | GenerateAnimatedDisplayText | (Ereditato da BaseEditViewInfo)
Metodo pubblico | GenerateStartDisplayText | (Ereditato da BaseEditViewInfo)
Metodo pubblico | GenerateStartEditValue | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetAllowBackgroundSkinningMode | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetAnimateDisplayString | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetAutoCorrectForeColor | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetBackgroundSkinElement | (Ereditato da TextEditViewInfo)
Metodo pubblico | GetBeginGetDisplayTextsBulkScope | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetBorderArgs | (Ereditato da BaseControlViewInfo)
Metodo protetto | GetBorderPainter | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetBorderPainterCore | (Ereditato da TextEditViewInfo)
Metodo protetto | GetButtonAllowGlyphSkinning | (Ereditato da ButtonEditViewInfo)
Metodo pubblico | GetButtonPainter | (Ereditato da BaseSpinEditViewInfo)
Metodo protetto | GetCanAnimate | (Ereditato da TextEditViewInfo)
Metodo pubblico | GetContextImageSize | (Ereditato da TextEditViewInfo)
Metodo pubblico | GetDataBindingText | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetDefaultDuration | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetDefaultFont | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetDefaultSkinBorderPainter | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetDefaultSkinFont | (Ereditato da BaseControlViewInfo)
Metodo protetto | GetDefaultTextOptionsForHtmlText | (Ereditato da TextEditViewInfo)
Metodo protetto | GetDirectXClient | (Ereditato da BaseControlViewInfo)
Metodo protetto | GetDisplayText | (Ereditato da TextEditViewInfo)
Metodo protetto | GetDisplayTextCore | (Ereditato da TextEditViewInfo)
Metodo protetto | GetDuration | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetEditorAppearance | (Ereditato da BaseEditViewInfo)
Metodo pubblico | GetErrorIcon | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetErrorIconBestSize | (Ereditato da BaseEditViewInfo)
Metodo pubblico | GetErrorIconSize | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetHtmlContext | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetInplaceBorderPainter | (Ereditato da BaseEditViewInfo)
Metodo pubblico | GetMouseCursor(Point) | (Ereditato da BaseEditViewInfo)
Metodo pubblico | GetMouseCursor(Int32, Int32) | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetPrevButtonState | (Ereditato da ButtonEditViewInfo)
Metodo protetto | GetRealLookAndFeelForSvgPalette | (Ereditato da TextEditViewInfo)
Metodo protetto | GetScaleDpi | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetShowHotKeyPrefix | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetSkinElement | (Ereditato da BaseControlViewInfo)
Metodo protetto | GetSvgPaletteProviderForContextImage | (Ereditato da TextEditViewInfo)
Metodo pubblico | GetSystemColor | (Ereditato da BaseControlViewInfo)
Metodo pubblico | GetTextAscentHeight | (Ereditato da BaseEditViewInfo)
Metodo pubblico | GetTextBounds | (Ereditato da TextEditViewInfo)
Metodo protetto | GetTextBoxContentPadding | (Ereditato da ButtonEditViewInfo)
Metodo protetto | GetTextBoxContentPaddingCore | (Ereditato da TextEditViewInfo)
Metodo protetto | GetTextToButtonPadding | (Ereditato da ButtonEditViewInfo)
Metodo protetto | GetTextToolTipWidth | (Ereditato da TextEditViewInfo)
Metodo pubblico | GetToolTipInfo | (Ereditato da ButtonEditViewInfo)
Metodo protetto | GetToolTipText | (Ereditato da TextEditViewInfo)
Metodo pubblico | GetValueChangeAnimation | (Ereditato da BaseEditViewInfo)
Metodo pubblico | GetWidthForAutoHeight | (Ereditato da BaseEditViewInfo)
Metodo protetto | GetWidthForAutoHeightCore | (Ereditato da BaseEditViewInfo)
Metodo protetto | IsAnyButtonPressed | (Ereditato da ButtonEditViewInfo)
Metodo protetto | IsButtonPressed | (Ereditato da ButtonEditViewInfo)
Metodo protetto | IsHotEdit | (Ereditato da BaseEditViewInfo)
Metodo protetto | IsOffice2003ExBorder | (Ereditato da BaseEditViewInfo)
Metodo protetto | IsShowNullValuePrompt | (Ereditato da TextEditViewInfo)
Metodo protetto | IsTextToolTipPoint | (Ereditato da ButtonEditViewInfo)
Metodo protetto | IsVisualEqualsEditValue | (Ereditato da TextEditViewInfo)
Metodo pubblico | Offset(Point) | (Ereditato da BaseEditViewInfo)
Metodo pubblico | Offset(Int32, Int32) | (Ereditato da ButtonEditViewInfo)
Metodo protetto | OnBeforeButtonStateChanged | (Ereditato da ButtonEditViewInfo)
Metodo protetto | OnBeginPaint | (Ereditato da BaseControlViewInfo)
Metodo protetto | OnEditValueChanged | (Ereditato da BaseEditViewInfo)
Metodo protetto | OnEndPaint | (Ereditato da BaseControlViewInfo)
Metodo protetto | OnInplaceTpeChanged | (Ereditato da BaseEditViewInfo)
Metodo protetto | OnInplaceTypeChanged | (Ereditato da BaseEditViewInfo)
Metodo protetto | OnIsCellSelectedChanged | (Ereditato da BaseEditViewInfo)
Metodo protetto | OnIsGridFocusedChanged | (Ereditato da BaseEditViewInfo)
Metodo protetto | OnPaintAppearanceChanged | (Ereditato da ButtonEditViewInfo)
Metodo pubblico | PermitSkinInplaceSateLeftEdge | (Ereditato da BaseEditViewInfo)
Metodo pubblico | PermitSkinInplaceState | (Ereditato da BaseEditViewInfo)
Metodo protetto | QuerySkinPaddings | (Ereditato da ButtonEditViewInfo)
Metodo protetto | QueryUseAdvancedMode | (Ereditato da TextEditViewInfo)
Metodo protetto | ReCalcRects | (Ereditato da BaseControlViewInfo)
Metodo pubblico | ReCalcViewInfo | (Ereditato da BaseControlViewInfo)
Metodo protetto | ReCalcViewInfoCore | (Ereditato da BaseEditViewInfo)
Metodo protetto | RequestInplaceBackgroundElement | (Ereditato da BaseEditViewInfo)
Metodo protetto | RequestUseAdvancedMode | (Ereditato da BaseEditViewInfo)
Metodo pubblico | Reset | (Ereditato da TextEditViewInfo)
Metodo protetto | ResetAppearanceDefault | (Ereditato da BaseControlViewInfo)
Metodo pubblico | ResetCachedData | (Ereditato da BaseEditViewInfo)
Metodo protetto | ResetForceHideNullValuePrompt | (Ereditato da TextEditViewInfo)
Metodo protetto | ResetState | (Ereditato da ButtonEditViewInfo)
Metodo protetto | ResetTextSize | (Ereditato da BaseControlViewInfo)
Metodo pubblico | ScaleInteger | (Ereditato da BaseControlViewInfo)
Metodo protetto | ScalePaddingInternal | (Ereditato da BaseControlViewInfo)
Metodo pubblico | ScaleSize | (Ereditato da BaseControlViewInfo)
Metodo pubblico | SetDisplayText(String) | (Ereditato da BaseEditViewInfo)
Metodo pubblico | SetDisplayText(String, Object) | (Ereditato da BaseEditViewInfo)
Metodo pubblico | SetGraphicsInfo | (Ereditato da BaseControlViewInfo)
Metodo pubblico | SetMaskBoxRect | (Ereditato da TextEditViewInfo)
Metodo protetto | SetPaintAppearance | (Ereditato da BaseControlViewInfo)
Metodo pubblico | SetPrevEditValue | (Ereditato da BaseEditViewInfo)
Metodo protetto | ShouldDrawFocusRectCore | (Ereditato da BaseControlViewInfo)
Metodo protetto | SupportValueChangeAnimationCore | (Ereditato da BaseEditViewInfo)
Metodo protetto | SuppressBackgroundSkinElement | (Ereditato da TextEditViewInfo)
Metodo pubblico | SuppressSkinInplaceState | (Ereditato da BaseEditViewInfo)
Metodo pubblico | SuppressSkinInplaceStateLeftEdge | (Ereditato da BaseEditViewInfo)
Metodo pubblico | TryGetThreadSafeGetDisplayTextFunc | (Ereditato da TextEditViewInfo)
Metodo protetto | TryGetThreadSafeOnEditValueChangedFunc | (Ereditato da BaseEditViewInfo)
Metodo pubblico | UpdateAppearances | (Ereditato da BaseControlViewInfo)
Metodo protetto | UpdateBestFitAppearance | (Ereditato da BaseControlViewInfo)
Metodo pubblico | UpdateBoundValues | (Ereditato da BaseEditViewInfo)
Metodo protetto | UpdateByGlyphSize | (Ereditato da ButtonEditViewInfo)
Metodo protetto | UpdateContentRectByFocusRect | (Ereditato da TextEditViewInfo)
Metodo pubblico | UpdateEditValue | (Ereditato da BaseEditViewInfo)
Metodo protetto | UpdateEnabledState | (Ereditato da BaseEditViewInfo)
Metodo protetto | UpdateFromEditor | (Ereditato da ButtonEditViewInfo)
Metodo protetto | UpdateFromOwner | (Ereditato da BaseEditViewInfo)
Metodo pubblico | UpdateGridState | (Ereditato da BaseEditViewInfo)
Metodo pubblico | UpdateGroupValueDisplayText | (Ereditato da BaseEditViewInfo)
Metodo pubblico | UpdateInplaceAnimation | (Ereditato da BaseEditViewInfo)
Metodo protetto | UpdateMaskBoxPadding | (Ereditato da TextEditViewInfo)
Metodo protetto | UpdateMaxBoxRectangle | (Ereditato da TextEditViewInfo)
Metodo protetto | UpdateObjectState | (Ereditato da ButtonEditViewInfo)
Metodo pubblico | UpdateObjectState(MouseButtons, Point) | (Ereditato da BaseControlViewInfo)
Metodo protetto | UpdateObjectStateCore | (Ereditato da BaseControlViewInfo)
Metodo pubblico | UpdatePaintAppearance | (Ereditato da TextEditViewInfo)
Metodo protetto | UpdatePaintAppearance(IStyleController, AppearanceDefault) | (Ereditato da BaseControlViewInfo)
Metodo protetto | UpdatePainters | (Ereditato da BaseSpinEditViewInfo)
Metodo protetto | UpdateSizeByFocusRect | (Ereditato da TextEditViewInfo)
Metodo protetto | UseSkinSpecifiedSettings | (Ereditato da TextEditViewInfo)
Torna su
Vedi anche

Documentazione

Classe DedTextSpinEditViewInfo
Namespace DedNet.Controls


Campi di DedTextSpinEditViewInfo

Il tipo DedTextSpinEditViewInfo espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | fAppearance | (Ereditato da BaseControlViewInfo)
Campo protetto | fAppearanceDisabled | (Ereditato da BaseEditViewInfo)
Campo protetto | fBorderRect | (Ereditato da BaseControlViewInfo)
Campo protetto | fBounds | (Ereditato da BaseControlViewInfo)
Campo protetto | fClientRect | (Ereditato da BaseControlViewInfo)
Campo protetto | fContentRect | (Ereditato da BaseControlViewInfo)
Campo protetto | fDisplayText | (Ereditato da BaseEditViewInfo)
Campo protetto | fEditValue | (Ereditato da BaseEditViewInfo)
Campo protetto | fErrorIcon | (Ereditato da BaseEditViewInfo)
Campo protetto | fErrorIconBounds | (Ereditato da BaseEditViewInfo)
Campo protetto | fErrorIconSize | (Ereditato da BaseEditViewInfo)
Campo protetto | fFocusRect | (Ereditato da BaseControlViewInfo)
Campo protetto | fFormat | (Ereditato da BaseEditViewInfo)
Campo protetto | fHotInfo | (Ereditato da BaseEditViewInfo)
Campo protetto | fLookAndFeel | (Ereditato da BaseEditViewInfo)
Campo protetto | fMaskBoxRect | (Ereditato da TextEditViewInfo)
Campo protetto | fMatchedString | (Ereditato da BaseEditViewInfo)
Campo protetto | fPressedInfo | (Ereditato da BaseEditViewInfo)
Campo protetto | fState | (Ereditato da BaseControlViewInfo)
Campo protetto | fTextSize | (Ereditato da BaseEditViewInfo)
Campo protetto | lockCalculatingTextSize | (Ereditato da BaseControlViewInfo)
Campo protetto | toolTipInfoCalculated | (Ereditato da BaseControlViewInfo)
Campo protetto | ValueChangeAnimationId | (Ereditato da BaseEditViewInfo)
Torna su
Vedi anche

Documentazione

Classe DedTextSpinEditViewInfo
Namespace DedNet.Controls


Classe DedTypeTreeControl
Controllo per la visualizzazione delle famiglie di archiviazione
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
XtraUserControl
DedNet.ControlsUserControlBase
DedNet.ControlsDedTypeTreeControl

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedTypeTreeControl : UserControlBase
Public Class DedTypeTreeControl
    Inherits UserControlBase
public ref class DedTypeTreeControl : public UserControlBase
type DedTypeTreeControl =
    class
        inherit UserControlBase
    end

Il tipo DedTypeTreeControl espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedTypeTreeControl | Costruttore.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | ActiveTreeControl | Restituisce l'albero attivo.
Proprietà pubblica | AllowDragOperation | Indica se l'albero permette il Drag dei nodi.
Proprietà pubblica | AllowDropOperation | Indica se l'albero permette il Drop sui nodi.
Proprietà pubblica | AllowExpandOnDoubleClick | Restituisce o imposata se abilitare o meno l'espandione del nodo con il doppio click.
Proprietà pubblica | Appearance | (Ereditato da XtraUserControl)
Proprietà pubblica | Application | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Proprietà pubblica | BackColor | (Ereditato da XtraUserControl)
Proprietà protetta | CheckDoubleScaling | (Ereditato da XtraUserControl)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraUserControl)
Proprietà protetta | DirectXContainer | (Ereditato da XtraUserControl)
Proprietà pubblica | DisableStandardCtx | Indica se disabilitare il menu constestuale stantard
Proprietà pubblica | EnableIXtraResizeableControlInterfaceProxy | (Ereditato da XtraUserControl)
Proprietà pubblica | Font | (Ereditato da XtraUserControl)
Proprietà pubblica | ForeColor | (Ereditato da XtraUserControl)
Proprietà pubblica | Freezed | Restituisce o imposta se bloccare l'albero in modo che l'utente non possa selezionare le famiglie.
Proprietà protetta | Helper | (Ereditato da XtraUserControl)
Proprietà pubblica | imageList | Imposta l'insieme delle immagini dalle quali disegnare l'icona.
Proprietà pubblica | InfoFamVisible | Indica se mostrare il pannello con le infomazioni sulle famiglie.
Proprietà pubblica | InnerControl | Restituisce l'albero.
Proprietà pubblica | InnerControlPref | Restituisce l'albero dei preferiti.
Proprietà pubblica | IsCommType | Indica il tipo di famiglie da visualizzare (Famiglie o Famiglie di commessa)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraUserControl)
Proprietà pubblica | MultiSelect | Indica se è attiva la selezione multipla delle famiglie.
Proprietà protetta | Painter | (Ereditato da XtraUserControl)
Proprietà pubblica | Perm | Restituisce o imposta il permesso di accesso alle famiglie.
Proprietà pubblica | PrefVisible | Indica se mostrare il tab dei preferiti.
Proprietà pubblica | PreventLostFocusAppareance | Se impostata a True, fa in modo che l'aspetto della riga selezionata NON cambi anche se il controllo perde il Focus. Se impostata a False, ripristina il comportamento standard.
Proprietà pubblica | RegistryBaseKey | Restituisce o imposta la chiave dalla quale leggere e nella quale scrivere le impostazioni.
Proprietà protetta | ScaleChildren | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleDPI | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraUserControl)
Proprietà pubblica | SearchedPaths | Restiruisce o imposta le famiglie sulle quali è stata effettuata la ricerca.
Proprietà pubblica | SelectedDBPaths | Restituisce la lista dei DbPath selezionati. Restituisce una lista vuota se non sono selezionate famiglie.
Proprietà pubblica | SelectedType | Restituisce o imposta la famiglia attualmente selezionata. Utilizzato nella selezione singola ma utilizzabile anche nella selezione multipla: Restituisce la prima famiglia selezionata ed imposta una sola famiglia selezionata.
Proprietà pubblica | SelectedTypes | Restituisce o imposta la lista delle famiglie attualmente selezionate. Utilizzato nella selezione multipla ma disponibile anche per la selezione singola.
Proprietà protetta | ShouldCheckDpiScaleFactorOnParentChanged | (Ereditato da XtraUserControl)
Proprietà pubblica | Site | (Ereditato da XtraUserControl)
Proprietà pubblica | UpdateButtonVisible | Restituisce o imposta se visualizzare il bottone per il refresh.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ActivateFamPage | Attiva l'albero delle famiglie.
Metodo pubblico | ActivateFamPrefPage | Attiva l'albero dei preferiti.
Metodo pubblico | AddCommandPref | Aggiunge i comandi per la gestione dei preferiti.
Metodo protetto | BaseWndProc | (Ereditato da XtraUserControl)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraUserControl)
Metodo protetto | CreatePainter | (Ereditato da XtraUserControl)
Metodo protetto | Dispose | Liberare le risorse in uso. (Sovrascrive UserControlBaseDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraUserControl)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraUserControl)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraUserControl)
Metodo protetto | GetBackColor | (Ereditato da XtraUserControl)
Metodo protetto | GetBackgroundSkinElement | (Ereditato da XtraUserControl)
Metodo protetto | GetInnerIXtraResizableControl | (Ereditato da XtraUserControl)
Metodo protetto | IsChildControlsRequiredScalingEnabled | (Ereditato da XtraUserControl)
Metodo protetto | IsParentHandleCreatedRecursive | (Ereditato da XtraUserControl)
Metodo pubblico | LoadRegistrySettings | Carica dal registro le dimensioni e la visibilità delle colonne.
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraUserControl)
Metodo protetto | OnBackColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnContextMenuOpening | Evento di apertura del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnControlAdded | (Ereditato da XtraUserControl)
Metodo protetto | OnControlRemoved | (Ereditato da XtraUserControl)
Metodo protetto | OnDblClick |
Metodo protetto | OnDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnDrawIcon |
Metodo protetto | OnFirstLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnForeColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleCreated | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraUserControl)
Metodo protetto | OnLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnMenuItemClicked | Evento di pressione di un comando del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnMouseClick |
Metodo protetto | OnPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnPaintCore | (Ereditato da XtraUserControl)
Metodo protetto | OnParentChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | OnSelectionChanged |
Metodo protetto | OnSizeChanged | (Ereditato da XtraUserControl)
Metodo protetto | RaisePaintExEvent | (Ereditato da XtraUserControl)
Metodo pubblico | RefreshNode | Metodo per effettuare il refresh della famiglia.
Metodo pubblico | ResetBackColor | (Ereditato da XtraUserControl)
Metodo pubblico | ResetForeColor | (Ereditato da XtraUserControl)
Metodo protetto | RestoreAutoScaleModeChangedByPM2 | (Ereditato da XtraUserControl)
Metodo pubblico | SaveRegistrySettings | Salva nel registro le dimensioni e la visibilità delle colonne.
Metodo protetto | ScaleControl | (Ereditato da XtraUserControl)
Metodo pubblico | SetCommandList | Rigenera il menu contestuale di questo controllo con la lista dei comandi passati. (Sovrascrive UserControlBaseSetCommandList(DedCommandList, CommandContextEnum))
Metodo pubblico | SetRootType | Imposta la root dell'albero ed inizializza le famiglie sottostanti a primo livello. Utilizzato per una root singola.
Metodo pubblico | SetRootTypes | Imposta le root dell'albero ed inizializza le famiglie sottostanti a primo livello. Utilizzato per root multiple.
Metodo protetto | SetVisibleCore | (Ereditato da XtraUserControl)
Metodo protetto | ShouldPaintTransparentBackground | (Ereditato da XtraUserControl)
Metodo protetto | ShouldUseDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | WndProc | (Ereditato da XtraUserControl)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | ContextMenuOpening | Evento su apertura del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | DblClick | Evento di doppio click sui nodi selezionati.
Evento pubblico | DrawIcon | Evento per selezionare l'icona da visualizzare.
Evento pubblico | MenuItemClicked | Evento su click su un elemento del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | MouseClick | Evento sul singolo click sul controllo
Evento pubblico | MyDragDrop | Evento per la gestione del dragDrop.
Evento pubblico | MyDragOver | Evento per la gestione del dragOver.
Evento pubblico | MyMouseMove | Evento per la gestione del movimento del mouse.
Evento pubblico | PaintEx | (Ereditato da XtraUserControl)
Evento pubblico | SelectionChanged | Evento generato sul cambio selezione della famiglia da parte dell'utente.
Torna su
Campi
 | Nome | Descrizione
Campo protetto | _app | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Campo protetto | _RegistryBaseKey | Chiave nel registro di sistema di salvataggio impostazioni. (Ereditato da UserControlBase)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore DedTypeTreeControl
Costruttore.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeTreeControl()
Public Sub New
public:
DedTypeTreeControl()
new : unit -> DedTypeTreeControl
Vedi anche

Documentazione

Classe DedTypeTreeControl
Namespace DedNet.Controls


Proprietà di DedTypeTreeControl

Il tipo DedTypeTreeControl espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | ActiveTreeControl | Restituisce l'albero attivo.
Proprietà pubblica | AllowDragOperation | Indica se l'albero permette il Drag dei nodi.
Proprietà pubblica | AllowDropOperation | Indica se l'albero permette il Drop sui nodi.
Proprietà pubblica | AllowExpandOnDoubleClick | Restituisce o imposata se abilitare o meno l'espandione del nodo con il doppio click.
Proprietà pubblica | Appearance | (Ereditato da XtraUserControl)
Proprietà pubblica | Application | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Proprietà pubblica | BackColor | (Ereditato da XtraUserControl)
Proprietà protetta | CheckDoubleScaling | (Ereditato da XtraUserControl)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraUserControl)
Proprietà protetta | DirectXContainer | (Ereditato da XtraUserControl)
Proprietà pubblica | DisableStandardCtx | Indica se disabilitare il menu constestuale stantard
Proprietà pubblica | EnableIXtraResizeableControlInterfaceProxy | (Ereditato da XtraUserControl)
Proprietà pubblica | Font | (Ereditato da XtraUserControl)
Proprietà pubblica | ForeColor | (Ereditato da XtraUserControl)
Proprietà pubblica | Freezed | Restituisce o imposta se bloccare l'albero in modo che l'utente non possa selezionare le famiglie.
Proprietà protetta | Helper | (Ereditato da XtraUserControl)
Proprietà pubblica | imageList | Imposta l'insieme delle immagini dalle quali disegnare l'icona.
Proprietà pubblica | InfoFamVisible | Indica se mostrare il pannello con le infomazioni sulle famiglie.
Proprietà pubblica | InnerControl | Restituisce l'albero.
Proprietà pubblica | InnerControlPref | Restituisce l'albero dei preferiti.
Proprietà pubblica | IsCommType | Indica il tipo di famiglie da visualizzare (Famiglie o Famiglie di commessa)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraUserControl)
Proprietà pubblica | MultiSelect | Indica se è attiva la selezione multipla delle famiglie.
Proprietà protetta | Painter | (Ereditato da XtraUserControl)
Proprietà pubblica | Perm | Restituisce o imposta il permesso di accesso alle famiglie.
Proprietà pubblica | PrefVisible | Indica se mostrare il tab dei preferiti.
Proprietà pubblica | PreventLostFocusAppareance | Se impostata a True, fa in modo che l'aspetto della riga selezionata NON cambi anche se il controllo perde il Focus. Se impostata a False, ripristina il comportamento standard.
Proprietà pubblica | RegistryBaseKey | Restituisce o imposta la chiave dalla quale leggere e nella quale scrivere le impostazioni.
Proprietà protetta | ScaleChildren | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleDPI | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraUserControl)
Proprietà pubblica | SearchedPaths | Restiruisce o imposta le famiglie sulle quali è stata effettuata la ricerca.
Proprietà pubblica | SelectedDBPaths | Restituisce la lista dei DbPath selezionati. Restituisce una lista vuota se non sono selezionate famiglie.
Proprietà pubblica | SelectedType | Restituisce o imposta la famiglia attualmente selezionata. Utilizzato nella selezione singola ma utilizzabile anche nella selezione multipla: Restituisce la prima famiglia selezionata ed imposta una sola famiglia selezionata.
Proprietà pubblica | SelectedTypes | Restituisce o imposta la lista delle famiglie attualmente selezionate. Utilizzato nella selezione multipla ma disponibile anche per la selezione singola.
Proprietà protetta | ShouldCheckDpiScaleFactorOnParentChanged | (Ereditato da XtraUserControl)
Proprietà pubblica | Site | (Ereditato da XtraUserControl)
Proprietà pubblica | UpdateButtonVisible | Restituisce o imposta se visualizzare il bottone per il refresh.
Torna su
Vedi anche

Documentazione

Classe DedTypeTreeControl
Namespace DedNet.Controls


Proprietà DedTypeTreeControl.ActiveTreeControl

Proprietà DedTypeTreeControlActiveTreeControl
Restituisce l'albero attivo.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public TreeList ActiveTreeControl { get; }
Public ReadOnly Property ActiveTreeControl As TreeList
    Get
public:
property TreeList^ ActiveTreeControl {
    TreeList^ get ();
}
member ActiveTreeControl : TreeList with get

Valore della proprietà

TreeList
Vedi anche

Documentazione

Classe DedTypeTreeControl
Namespace DedNet.Controls


Proprietà DedTypeTreeControl.AllowDragOperation

Proprietà DedTypeTreeControlAllowDragOperation
Indica se l'albero permette il Drag dei nodi.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AllowDragOperation { set; }
Public WriteOnly Property AllowDragOperation As Boolean
    Set
public:
property bool AllowDragOperation {
    void set (bool value);
}
member AllowDragOperation : bool with set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedTypeTreeControl
Namespace DedNet.Controls


Proprietà DedTypeTreeControl.AllowDropOperation

Proprietà DedTypeTreeControlAllowDropOperation
Indica se l'albero permette il Drop sui nodi.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AllowDropOperation { set; }
Public WriteOnly Property AllowDropOperation As Boolean
    Set
public:
property bool AllowDropOperation {
    void set (bool value);
}
member AllowDropOperation : bool with set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedTypeTreeControl
Namespace DedNet.Controls


Proprietà DedTypeTreeControl.AllowExpandOnDoubleClick

Proprietà DedTypeTreeControlAllowExpandOnDoubleClick
Restituisce o imposata se abilitare o meno l'espandione del nodo con il doppio click.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AllowExpandOnDoubleClick { get; set; }
Public Property AllowExpandOnDoubleClick As Boolean
    Get
    Set
public:
property bool AllowExpandOnDoubleClick {
    bool get ();
    void set (bool value);
}
member AllowExpandOnDoubleClick : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedTypeTreeControl
Namespace DedNet.Controls


Proprietà DedTypeTreeControl.DisableStandardCtx

Proprietà DedTypeTreeControlDisableStandardCtx
Indica se disabilitare il menu constestuale stantard

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool DisableStandardCtx { get; set; }
Public Property DisableStandardCtx As Boolean
    Get
    Set
public:
property bool DisableStandardCtx {
    bool get ();
    void set (bool value);
}
member DisableStandardCtx : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedTypeTreeControl
Namespace DedNet.Controls


Proprietà DedTypeTreeControl.Freezed

Proprietà DedTypeTreeControlFreezed
Restituisce o imposta se bloccare l'albero in modo che l'utente non possa selezionare le famiglie.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Freezed { get; set; }
Public Property Freezed As Boolean
    Get
    Set
public:
property bool Freezed {
    bool get ();
    void set (bool value);
}
member Freezed : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedTypeTreeControl
Namespace DedNet.Controls


Proprietà DedTypeTreeControl.imageList

Proprietà DedTypeTreeControlimageList
Imposta l'insieme delle immagini dalle quali disegnare l'icona.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ImageCollection imageList { set; }
Public WriteOnly Property imageList As ImageCollection
    Set
public:
property ImageCollection^ imageList {
    void set (ImageCollection^ value);
}
member imageList : ImageCollection with set

Valore della proprietà

ImageCollection
Vedi anche

Documentazione

Classe DedTypeTreeControl
Namespace DedNet.Controls


Proprietà DedTypeTreeControl.InfoFamVisible

Proprietà DedTypeTreeControlInfoFamVisible
Indica se mostrare il pannello con le infomazioni sulle famiglie.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool InfoFamVisible { get; set; }
Public Property InfoFamVisible As Boolean
    Get
    Set
public:
property bool InfoFamVisible {
    bool get ();
    void set (bool value);
}
member InfoFamVisible : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedTypeTreeControl
Namespace DedNet.Controls


Proprietà DedTypeTreeControl.InnerControl

Proprietà DedTypeTreeControlInnerControl
Restituisce l'albero.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public TreeList InnerControl { get; }
Public ReadOnly Property InnerControl As TreeList
    Get
public:
property TreeList^ InnerControl {
    TreeList^ get ();
}
member InnerControl : TreeList with get

Valore della proprietà

TreeList
Vedi anche

Documentazione

Classe DedTypeTreeControl
Namespace DedNet.Controls


Proprietà DedTypeTreeControl.InnerControlPref

Proprietà DedTypeTreeControlInnerControlPref
Restituisce l'albero dei preferiti.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public TreeList InnerControlPref { get; }
Public ReadOnly Property InnerControlPref As TreeList
    Get
public:
property TreeList^ InnerControlPref {
    TreeList^ get ();
}
member InnerControlPref : TreeList with get

Valore della proprietà

TreeList
Vedi anche

Documentazione

Classe DedTypeTreeControl
Namespace DedNet.Controls


Proprietà DedTypeTreeControl.IsCommType

Proprietà DedTypeTreeControlIsCommType
Indica il tipo di famiglie da visualizzare (Famiglie o Famiglie di commessa)

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsCommType { get; set; }
Public Property IsCommType As Boolean
    Get
    Set
public:
property bool IsCommType {
    bool get ();
    void set (bool value);
}
member IsCommType : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedTypeTreeControl
Namespace DedNet.Controls


Proprietà DedTypeTreeControl.MultiSelect

Proprietà DedTypeTreeControlMultiSelect
Indica se è attiva la selezione multipla delle famiglie.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool MultiSelect { get; set; }
Public Property MultiSelect As Boolean
    Get
    Set
public:
property bool MultiSelect {
    bool get ();
    void set (bool value);
}
member MultiSelect : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedTypeTreeControl
Namespace DedNet.Controls


Proprietà DedTypeTreeControl.Perm

Proprietà DedTypeTreeControlPerm
Restituisce o imposta il permesso di accesso alle famiglie.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Perm { get; set; }
Public Property Perm As String
    Get
    Set
public:
property String^ Perm {
    String^ get ();
    void set (String^ value);
}
member Perm : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedTypeTreeControl
Namespace DedNet.Controls


Proprietà DedTypeTreeControl.PrefVisible

Proprietà DedTypeTreeControlPrefVisible
Indica se mostrare il tab dei preferiti.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool PrefVisible { get; set; }
Public Property PrefVisible As Boolean
    Get
    Set
public:
property bool PrefVisible {
    bool get ();
    void set (bool value);
}
member PrefVisible : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedTypeTreeControl
Namespace DedNet.Controls


Proprietà DedTypeTreeControl.PreventLostFocusAppareance

Proprietà DedTypeTreeControlPreventLostFocusAppareance
Se impostata a True, fa in modo che l'aspetto della riga selezionata NON cambi anche se il controllo perde il Focus. Se impostata a False, ripristina il comportamento standard.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool PreventLostFocusAppareance { set; }
Public WriteOnly Property PreventLostFocusAppareance As Boolean
    Set
public:
property bool PreventLostFocusAppareance {
    void set (bool value);
}
member PreventLostFocusAppareance : bool with set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedTypeTreeControl
Namespace DedNet.Controls


Proprietà DedTypeTreeControl.RegistryBaseKey

Proprietà DedTypeTreeControlRegistryBaseKey
Restituisce o imposta la chiave dalla quale leggere e nella quale scrivere le impostazioni.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string RegistryBaseKey { get; set; }
Public Property RegistryBaseKey As String
    Get
    Set
public:
property String^ RegistryBaseKey {
    String^ get ();
    void set (String^ value);
}
member RegistryBaseKey : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedTypeTreeControl
Namespace DedNet.Controls


Proprietà DedTypeTreeControl.SearchedPaths

Proprietà DedTypeTreeControlSearchedPaths
Restiruisce o imposta le famiglie sulle quali è stata effettuata la ricerca.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> SearchedPaths { get; set; }
Public Property SearchedPaths As List(Of String)
    Get
    Set
public:
property List<String^>^ SearchedPaths {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
member SearchedPaths : List<string> with get, set

Valore della proprietà

List String
Vedi anche

Documentazione

Classe DedTypeTreeControl
Namespace DedNet.Controls


Proprietà DedTypeTreeControl.SelectedDBPaths

Proprietà DedTypeTreeControlSelectedDBPaths
Restituisce la lista dei DbPath selezionati. Restituisce una lista vuota se non sono selezionate famiglie.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> SelectedDBPaths { get; }
Public ReadOnly Property SelectedDBPaths As List(Of String)
    Get
public:
property List<String^>^ SelectedDBPaths {
    List<String^>^ get ();
}
member SelectedDBPaths : List<string> with get

Valore della proprietà

List String
Vedi anche

Documentazione

Classe DedTypeTreeControl
Namespace DedNet.Controls


Proprietà DedTypeTreeControl.SelectedType

Proprietà DedTypeTreeControlSelectedType
Restituisce o imposta la famiglia attualmente selezionata. Utilizzato nella selezione singola ma utilizzabile anche nella selezione multipla: Restituisce la prima famiglia selezionata ed imposta una sola famiglia selezionata.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeBase SelectedType { get; set; }
Public Property SelectedType As DedTypeBase
    Get
    Set
public:
property DedTypeBase^ SelectedType {
    DedTypeBase^ get ();
    void set (DedTypeBase^ value);
}
member SelectedType : DedTypeBase with get, set

Valore della proprietà

DedTypeBase
Vedi anche

Documentazione

Classe DedTypeTreeControl
Namespace DedNet.Controls


Proprietà DedTypeTreeControl.SelectedTypes

Proprietà DedTypeTreeControlSelectedTypes
Restituisce o imposta la lista delle famiglie attualmente selezionate. Utilizzato nella selezione multipla ma disponibile anche per la selezione singola.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeBaseList SelectedTypes { get; set; }
Public Property SelectedTypes As DedTypeBaseList
    Get
    Set
public:
property DedTypeBaseList^ SelectedTypes {
    DedTypeBaseList^ get ();
    void set (DedTypeBaseList^ value);
}
member SelectedTypes : DedTypeBaseList with get, set

Valore della proprietà

DedTypeBaseList
Vedi anche

Documentazione

Classe DedTypeTreeControl
Namespace DedNet.Controls


Proprietà DedTypeTreeControl.UpdateButtonVisible

Proprietà DedTypeTreeControlUpdateButtonVisible
Restituisce o imposta se visualizzare il bottone per il refresh.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool UpdateButtonVisible { get; set; }
Public Property UpdateButtonVisible As Boolean
    Get
    Set
public:
property bool UpdateButtonVisible {
    bool get ();
    void set (bool value);
}
member UpdateButtonVisible : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedTypeTreeControl
Namespace DedNet.Controls


Metodi di DedTypeTreeControl

Il tipo DedTypeTreeControl espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ActivateFamPage | Attiva l'albero delle famiglie.
Metodo pubblico | ActivateFamPrefPage | Attiva l'albero dei preferiti.
Metodo pubblico | AddCommandPref | Aggiunge i comandi per la gestione dei preferiti.
Metodo protetto | BaseWndProc | (Ereditato da XtraUserControl)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraUserControl)
Metodo protetto | CreatePainter | (Ereditato da XtraUserControl)
Metodo protetto | Dispose | Liberare le risorse in uso. (Sovrascrive UserControlBaseDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraUserControl)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraUserControl)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraUserControl)
Metodo protetto | GetBackColor | (Ereditato da XtraUserControl)
Metodo protetto | GetBackgroundSkinElement | (Ereditato da XtraUserControl)
Metodo protetto | GetInnerIXtraResizableControl | (Ereditato da XtraUserControl)
Metodo protetto | IsChildControlsRequiredScalingEnabled | (Ereditato da XtraUserControl)
Metodo protetto | IsParentHandleCreatedRecursive | (Ereditato da XtraUserControl)
Metodo pubblico | LoadRegistrySettings | Carica dal registro le dimensioni e la visibilità delle colonne.
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraUserControl)
Metodo protetto | OnBackColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnContextMenuOpening | Evento di apertura del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnControlAdded | (Ereditato da XtraUserControl)
Metodo protetto | OnControlRemoved | (Ereditato da XtraUserControl)
Metodo protetto | OnDblClick |
Metodo protetto | OnDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnDrawIcon |
Metodo protetto | OnFirstLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnForeColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleCreated | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraUserControl)
Metodo protetto | OnLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnMenuItemClicked | Evento di pressione di un comando del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnMouseClick |
Metodo protetto | OnPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnPaintCore | (Ereditato da XtraUserControl)
Metodo protetto | OnParentChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | OnSelectionChanged |
Metodo protetto | OnSizeChanged | (Ereditato da XtraUserControl)
Metodo protetto | RaisePaintExEvent | (Ereditato da XtraUserControl)
Metodo pubblico | RefreshNode | Metodo per effettuare il refresh della famiglia.
Metodo pubblico | ResetBackColor | (Ereditato da XtraUserControl)
Metodo pubblico | ResetForeColor | (Ereditato da XtraUserControl)
Metodo protetto | RestoreAutoScaleModeChangedByPM2 | (Ereditato da XtraUserControl)
Metodo pubblico | SaveRegistrySettings | Salva nel registro le dimensioni e la visibilità delle colonne.
Metodo protetto | ScaleControl | (Ereditato da XtraUserControl)
Metodo pubblico | SetCommandList | Rigenera il menu contestuale di questo controllo con la lista dei comandi passati. (Sovrascrive UserControlBaseSetCommandList(DedCommandList, CommandContextEnum))
Metodo pubblico | SetRootType | Imposta la root dell'albero ed inizializza le famiglie sottostanti a primo livello. Utilizzato per una root singola.
Metodo pubblico | SetRootTypes | Imposta le root dell'albero ed inizializza le famiglie sottostanti a primo livello. Utilizzato per root multiple.
Metodo protetto | SetVisibleCore | (Ereditato da XtraUserControl)
Metodo protetto | ShouldPaintTransparentBackground | (Ereditato da XtraUserControl)
Metodo protetto | ShouldUseDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | WndProc | (Ereditato da XtraUserControl)
Torna su
Vedi anche

Documentazione

Classe DedTypeTreeControl
Namespace DedNet.Controls


Metodo DedTypeTreeControl.ActivateFamPage

Metodo DedTypeTreeControlActivateFamPage
Attiva l'albero delle famiglie.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ActivateFamPage()
Public Sub ActivateFamPage
public:
void ActivateFamPage()
member ActivateFamPage : unit -> unit
Vedi anche

Documentazione

Classe DedTypeTreeControl
Namespace DedNet.Controls


Metodo DedTypeTreeControl.ActivateFamPrefPage

Metodo DedTypeTreeControlActivateFamPrefPage
Attiva l'albero dei preferiti.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ActivateFamPrefPage()
Public Sub ActivateFamPrefPage
public:
void ActivateFamPrefPage()
member ActivateFamPrefPage : unit -> unit
Vedi anche

Documentazione

Classe DedTypeTreeControl
Namespace DedNet.Controls


Metodo DedTypeTreeControl.AddCommandPref

Metodo DedTypeTreeControlAddCommandPref
Aggiunge i comandi per la gestione dei preferiti.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddCommandPref()
Public Sub AddCommandPref
public:
void AddCommandPref()
member AddCommandPref : unit -> unit
Vedi anche

Documentazione

Classe DedTypeTreeControl
Namespace DedNet.Controls


Metodo DedTypeTreeControl.Dispose

Metodo DedTypeTreeControlDispose
Liberare le risorse in uso.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
ha valore true se le risorse gestite devono essere eliminate, false in caso contrario.
Vedi anche

Documentazione

Classe DedTypeTreeControl
Namespace DedNet.Controls


Metodo DedTypeTreeControl.LoadRegistrySettings

Metodo DedTypeTreeControlLoadRegistrySettings
Carica dal registro le dimensioni e la visibilità delle colonne.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void LoadRegistrySettings(
    string key,
    bool onlyLayout = false
)
Public Sub LoadRegistrySettings (
    key As String,
    Optional onlyLayout As Boolean = false
)
public:
void LoadRegistrySettings(
    String^ key,
    bool onlyLayout = false
)
member LoadRegistrySettings :
        key : string *
        ?onlyLayout : bool
(* Defaults:
        let _onlyLayout = defaultArg onlyLayout false
*)
-> unit

Parametri

key String
Chiave di registro dalla quale leggere le impostazioni.
onlyLayout Boolean (Optional)
Vedi anche

Documentazione

Classe DedTypeTreeControl
Namespace DedNet.Controls


Metodo DedTypeTreeControl.OnDblClick

Metodo DedTypeTreeControlOnDblClick

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected void OnDblClick(
    Object sender
)
Protected Sub OnDblClick (
    sender As Object
)
protected:
void OnDblClick(
    Object^ sender
)
member OnDblClick :
        sender : Object -> unit

Parametri

sender Object
Vedi anche

Documentazione

Classe DedTypeTreeControl
Namespace DedNet.Controls


Metodo DedTypeTreeControl.OnDrawIcon

Metodo DedTypeTreeControlOnDrawIcon

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected void OnDrawIcon(
    Object sender,
    DrawIconEventArgs ev
)
Protected Sub OnDrawIcon (
    sender As Object,
    ev As DrawIconEventArgs
)
protected:
void OnDrawIcon(
    Object^ sender,
    DrawIconEventArgs^ ev
)
member OnDrawIcon :
        sender : Object *
        ev : DrawIconEventArgs -> unit

Parametri

sender Object
ev DrawIconEventArgs
Vedi anche

Documentazione

Classe DedTypeTreeControl
Namespace DedNet.Controls


Metodo DedTypeTreeControl.OnMouseClick

Metodo DedTypeTreeControlOnMouseClick

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected void OnMouseClick(
    Object sender,
    MouseEventArgs ev
)
Protected Sub OnMouseClick (
    sender As Object,
    ev As MouseEventArgs
)
protected:
void OnMouseClick(
    Object^ sender,
    MouseEventArgs^ ev
)
member OnMouseClick :
        sender : Object *
        ev : MouseEventArgs -> unit

Parametri

sender Object
ev MouseEventArgs
Vedi anche

Documentazione

Classe DedTypeTreeControl
Namespace DedNet.Controls


Metodo DedTypeTreeControl.OnSelectionChanged

Metodo DedTypeTreeControlOnSelectionChanged

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected void OnSelectionChanged(
    Object sender
)
Protected Sub OnSelectionChanged (
    sender As Object
)
protected:
void OnSelectionChanged(
    Object^ sender
)
member OnSelectionChanged :
        sender : Object -> unit

Parametri

sender Object
Vedi anche

Documentazione

Classe DedTypeTreeControl
Namespace DedNet.Controls


Metodo DedTypeTreeControl.RefreshNode

Metodo DedTypeTreeControlRefreshNode
Metodo per effettuare il refresh della famiglia.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void RefreshNode(
    DedTypeBase type
)
Public Sub RefreshNode (
    type As DedTypeBase
)
public:
void RefreshNode(
    DedTypeBase^ type
)
member RefreshNode :
        type : DedTypeBase -> unit

Parametri

type DedTypeBase
Famiglia della quale effettuare i l refresh.
Vedi anche

Documentazione

Classe DedTypeTreeControl
Namespace DedNet.Controls


Metodo DedTypeTreeControl.SaveRegistrySettings

Metodo DedTypeTreeControlSaveRegistrySettings
Salva nel registro le dimensioni e la visibilità delle colonne.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SaveRegistrySettings(
    string key
)
Public Sub SaveRegistrySettings (
    key As String
)
public:
void SaveRegistrySettings(
    String^ key
)
member SaveRegistrySettings :
        key : string -> unit

Parametri

key String
Chiave di registro nella quale scrivere le impostazioni.
Vedi anche

Documentazione

Classe DedTypeTreeControl
Namespace DedNet.Controls


Metodo DedTypeTreeControl.SetCommandList

Metodo DedTypeTreeControlSetCommandList
Rigenera il menu contestuale di questo controllo con la lista dei comandi passati.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void SetCommandList(
    DedCommandList commandList,
    CommandContextEnum commandContext
)
Public Overrides Sub SetCommandList (
    commandList As DedCommandList,
    commandContext As CommandContextEnum
)
public:
virtual void SetCommandList(
    DedCommandList^ commandList,
    CommandContextEnum commandContext
) override
abstract SetCommandList :
        commandList : DedCommandList *
        commandContext : CommandContextEnum -> unit
override SetCommandList :
        commandList : DedCommandList *
        commandContext : CommandContextEnum -> unit

Parametri

commandList DedCommandList
Lista completa dei comandi.
commandContext CommandContextEnum
Contesto da utilizzare per filtrare i comandi da inserire.
Note
Filtra i comandi in modo da aggiungere soltanto quelli coerenti con il contesto passato.
Vedi anche

Documentazione

Classe DedTypeTreeControl
Namespace DedNet.Controls


Metodo DedTypeTreeControl.SetRootType

Metodo DedTypeTreeControlSetRootType
Imposta la root dell'albero ed inizializza le famiglie sottostanti a primo livello. Utilizzato per una root singola.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetRootType(
    DedTypeBase root
)
Public Sub SetRootType (
    root As DedTypeBase
)
public:
void SetRootType(
    DedTypeBase^ root
)
member SetRootType :
        root : DedTypeBase -> unit

Parametri

root DedTypeBase
Vedi anche

Documentazione

Classe DedTypeTreeControl
Namespace DedNet.Controls


Metodo DedTypeTreeControl.SetRootTypes

Metodo DedTypeTreeControlSetRootTypes
Imposta le root dell'albero ed inizializza le famiglie sottostanti a primo livello. Utilizzato per root multiple.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetRootTypes(
    DedTypeBase[] roots
)
Public Sub SetRootTypes (
    roots As DedTypeBase()
)
public:
void SetRootTypes(
    array<DedTypeBase^>^ roots
)
member SetRootTypes :
        roots : DedTypeBase[] -> unit

Parametri

roots DedTypeBase
Famiglie radice di livello 0 dell'albero.
Vedi anche

Documentazione

Classe DedTypeTreeControl
Namespace DedNet.Controls


Eventi di DedTypeTreeControl

Il tipo DedTypeTreeControl espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | ContextMenuOpening | Evento su apertura del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | DblClick | Evento di doppio click sui nodi selezionati.
Evento pubblico | DrawIcon | Evento per selezionare l'icona da visualizzare.
Evento pubblico | MenuItemClicked | Evento su click su un elemento del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | MouseClick | Evento sul singolo click sul controllo
Evento pubblico | MyDragDrop | Evento per la gestione del dragDrop.
Evento pubblico | MyDragOver | Evento per la gestione del dragOver.
Evento pubblico | MyMouseMove | Evento per la gestione del movimento del mouse.
Evento pubblico | PaintEx | (Ereditato da XtraUserControl)
Evento pubblico | SelectionChanged | Evento generato sul cambio selezione della famiglia da parte dell'utente.
Torna su
Vedi anche

Documentazione

Classe DedTypeTreeControl
Namespace DedNet.Controls


Evento DedTypeTreeControl.DblClick

Evento DedTypeTreeControlDblClick
Evento di doppio click sui nodi selezionati.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DedTreeViewEventArgs> DblClick
Public Event DblClick As EventHandler(Of DedTreeViewEventArgs)
public:
 event EventHandler<DedTreeViewEventArgs^>^ DblClick {
    void add (EventHandler<DedTreeViewEventArgs^>^ value);
    void remove (EventHandler<DedTreeViewEventArgs^>^ value);
}
member DblClick : IEvent<EventHandler<DedTreeViewEventArgs>,
    DedTreeViewEventArgs>

Valore

EventHandler DedTreeViewEventArgs
Vedi anche

Documentazione

Classe DedTypeTreeControl
Namespace DedNet.Controls


Evento DedTypeTreeControl.DrawIcon

Evento DedTypeTreeControlDrawIcon
Evento per selezionare l'icona da visualizzare.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DrawIconEventArgs> DrawIcon
Public Event DrawIcon As EventHandler(Of DrawIconEventArgs)
public:
 event EventHandler<DrawIconEventArgs^>^ DrawIcon {
    void add (EventHandler<DrawIconEventArgs^>^ value);
    void remove (EventHandler<DrawIconEventArgs^>^ value);
}
member DrawIcon : IEvent<EventHandler<DrawIconEventArgs>,
    DrawIconEventArgs>

Valore

EventHandler DrawIconEventArgs
Vedi anche

Documentazione

Classe DedTypeTreeControl
Namespace DedNet.Controls


Evento DedTypeTreeControl.MouseClick

Evento DedTypeTreeControlMouseClick
Evento sul singolo click sul controllo

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<MouseEventArgs> MouseClick
Public Event MouseClick As EventHandler(Of MouseEventArgs)
public:
 event EventHandler<MouseEventArgs^>^ MouseClick {
    void add (EventHandler<MouseEventArgs^>^ value);
    void remove (EventHandler<MouseEventArgs^>^ value);
}
member MouseClick : IEvent<EventHandler<MouseEventArgs>,
    MouseEventArgs>

Valore

EventHandler MouseEventArgs
Vedi anche

Documentazione

Classe DedTypeTreeControl
Namespace DedNet.Controls


Evento DedTypeTreeControl.MyDragDrop

Evento DedTypeTreeControlMyDragDrop
Evento per la gestione del dragDrop.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<MyDragDropEventArgs> MyDragDrop
Public Event MyDragDrop As EventHandler(Of MyDragDropEventArgs)
public:
 event EventHandler<MyDragDropEventArgs^>^ MyDragDrop {
    void add (EventHandler<MyDragDropEventArgs^>^ value);
    void remove (EventHandler<MyDragDropEventArgs^>^ value);
}
member MyDragDrop : IEvent<EventHandler<MyDragDropEventArgs>,
    MyDragDropEventArgs>

Valore

EventHandler MyDragDropEventArgs
Vedi anche

Documentazione

Classe DedTypeTreeControl
Namespace DedNet.Controls


Evento DedTypeTreeControl.MyDragOver

Evento DedTypeTreeControlMyDragOver
Evento per la gestione del dragOver.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<MyDragDropEventArgs> MyDragOver
Public Event MyDragOver As EventHandler(Of MyDragDropEventArgs)
public:
 event EventHandler<MyDragDropEventArgs^>^ MyDragOver {
    void add (EventHandler<MyDragDropEventArgs^>^ value);
    void remove (EventHandler<MyDragDropEventArgs^>^ value);
}
member MyDragOver : IEvent<EventHandler<MyDragDropEventArgs>,
    MyDragDropEventArgs>

Valore

EventHandler MyDragDropEventArgs
Vedi anche

Documentazione

Classe DedTypeTreeControl
Namespace DedNet.Controls


Evento DedTypeTreeControl.MyMouseMove

Evento DedTypeTreeControlMyMouseMove
Evento per la gestione del movimento del mouse.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<MouseEventArgs> MyMouseMove
Public Event MyMouseMove As EventHandler(Of MouseEventArgs)
public:
 event EventHandler<MouseEventArgs^>^ MyMouseMove {
    void add (EventHandler<MouseEventArgs^>^ value);
    void remove (EventHandler<MouseEventArgs^>^ value);
}
member MyMouseMove : IEvent<EventHandler<MouseEventArgs>,
    MouseEventArgs>

Valore

EventHandler MouseEventArgs
Vedi anche

Documentazione

Classe DedTypeTreeControl
Namespace DedNet.Controls


Evento DedTypeTreeControl.SelectionChanged

Evento DedTypeTreeControlSelectionChanged
Evento generato sul cambio selezione della famiglia da parte dell'utente.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DedTreeViewEventArgs> SelectionChanged
Public Event SelectionChanged As EventHandler(Of DedTreeViewEventArgs)
public:
 event EventHandler<DedTreeViewEventArgs^>^ SelectionChanged {
    void add (EventHandler<DedTreeViewEventArgs^>^ value);
    void remove (EventHandler<DedTreeViewEventArgs^>^ value);
}
member SelectionChanged : IEvent<EventHandler<DedTreeViewEventArgs>,
    DedTreeViewEventArgs>

Valore

EventHandler DedTreeViewEventArgs
Vedi anche

Documentazione

Classe DedTypeTreeControl
Namespace DedNet.Controls


Campi di DedTypeTreeControl

Il tipo DedTypeTreeControl espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | _app | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Campo protetto | _RegistryBaseKey | Chiave nel registro di sistema di salvataggio impostazioni. (Ereditato da UserControlBase)
Torna su
Vedi anche

Documentazione

Classe DedTypeTreeControl
Namespace DedNet.Controls


Classe EcoFocusChanged
Classe usata per gestire l'evento di FocusedRowChanged della griglia.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNet.ControlsEcoFocusChanged

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class EcoFocusChanged : EventArgs
Public Class EcoFocusChanged
    Inherits EventArgs
public ref class EcoFocusChanged : public EventArgs
type EcoFocusChanged =
    class
        inherit EventArgs
    end

Il tipo EcoFocusChanged espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | EcoFocusChanged | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Eco | Oggetto DedEco.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore EcoFocusChanged
Costruttore unico.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public EcoFocusChanged(
    DedEco eco
)
Public Sub New (
    eco As DedEco
)
public:
EcoFocusChanged(
    DedEco^ eco
)
new :
        eco : DedEco -> EcoFocusChanged

Parametri

eco DedEco
Vedi anche

Documentazione

Classe EcoFocusChanged
Namespace DedNet.Controls


Proprietà di EcoFocusChanged

Il tipo EcoFocusChanged espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Eco | Oggetto DedEco.
Torna su
Vedi anche

Documentazione

Classe EcoFocusChanged
Namespace DedNet.Controls


Proprietà EcoFocusChanged.Eco

Proprietà EcoFocusChangedEco
Oggetto DedEco.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEco Eco { get; }
Public ReadOnly Property Eco As DedEco
    Get
public:
property DedEco^ Eco {
    DedEco^ get ();
}
member Eco : DedEco with get

Valore della proprietà

DedEco
Vedi anche

Documentazione

Classe EcoFocusChanged
Namespace DedNet.Controls


Classe Filter
Classe rappresentante l'oggetto per la ricerca
Gerarchia di ereditarietà
SystemObject
DedNet.ControlsFilter

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class Filter
Public Class Filter
public ref class Filter
type Filter = class end

Il tipo Filter espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | Filter | Costruttore
Metodo pubblico | Filter(DedAttr, Boolean) | Costruttore con 2 parametri
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Attr |
Proprietà pubblica | Criterio |
Proprietà pubblica | Group |
Proprietà pubblica | MultiCheck |
Proprietà pubblica | Nome |
Proprietà pubblica | Prompt |
Proprietà pubblica | Selected |
Proprietà pubblica | Type |
Proprietà pubblica | Valore |
Torna su
Campi
 | Nome | Descrizione
Campo pubblico | attList |
Campo pubblico | list | Lista contenente i valori nell'AttrList se non c'è la descrizione
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore Filter
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Filter | Costruttore
Metodo pubblico | Filter(DedAttr, Boolean) | Costruttore con 2 parametri
Torna su
Vedi anche

Documentazione

Classe Filter
Namespace DedNet.Controls


Costruttore Filter
Costruttore

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Filter()
Public Sub New
public:
Filter()
new : unit -> Filter
Vedi anche

Documentazione

Classe Filter
Overload di Filter
Namespace DedNet.Controls


Costruttore Filter(DedAttr, Boolean)
Costruttore con 2 parametri

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Filter(
    DedAttr attr,
    bool sel
)
Public Sub New (
    attr As DedAttr,
    sel As Boolean
)
public:
Filter(
    DedAttr^ attr,
    bool sel
)
new :
        attr : DedAttr *
        sel : bool -> Filter

Parametri

attr DedAttr
Attributo
sel Boolean
Vedi anche

Documentazione

Classe Filter
Overload di Filter
Namespace DedNet.Controls


Proprietà di Filter

Il tipo Filter espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Attr |
Proprietà pubblica | Criterio |
Proprietà pubblica | Group |
Proprietà pubblica | MultiCheck |
Proprietà pubblica | Nome |
Proprietà pubblica | Prompt |
Proprietà pubblica | Selected |
Proprietà pubblica | Type |
Proprietà pubblica | Valore |
Torna su
Vedi anche

Documentazione

Classe Filter
Namespace DedNet.Controls


Proprietà Filter.Attr

Proprietà FilterAttr

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttr Attr { get; set; }
Public Property Attr As DedAttr
    Get
    Set
public:
property DedAttr^ Attr {
    DedAttr^ get ();
    void set (DedAttr^ value);
}
member Attr : DedAttr with get, set

Valore della proprietà

DedAttr
Vedi anche

Documentazione

Classe Filter
Namespace DedNet.Controls


Proprietà Filter.Criterio

Proprietà FilterCriterio

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Criterio { get; set; }
Public Property Criterio As String
    Get
    Set
public:
property String^ Criterio {
    String^ get ();
    void set (String^ value);
}
member Criterio : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe Filter
Namespace DedNet.Controls


Proprietà Filter.Group

Proprietà FilterGroup

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Group { get; set; }
Public Property Group As String
    Get
    Set
public:
property String^ Group {
    String^ get ();
    void set (String^ value);
}
member Group : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe Filter
Namespace DedNet.Controls


Proprietà Filter.MultiCheck

Proprietà FilterMultiCheck

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool MultiCheck { get; set; }
Public Property MultiCheck As Boolean
    Get
    Set
public:
property bool MultiCheck {
    bool get ();
    void set (bool value);
}
member MultiCheck : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe Filter
Namespace DedNet.Controls


Proprietà Filter.Nome

Proprietà FilterNome

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Nome { get; set; }
Public Property Nome As String
    Get
    Set
public:
property String^ Nome {
    String^ get ();
    void set (String^ value);
}
member Nome : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe Filter
Namespace DedNet.Controls


Proprietà Filter.Prompt

Proprietà FilterPrompt

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Prompt { get; set; }
Public Property Prompt As String
    Get
    Set
public:
property String^ Prompt {
    String^ get ();
    void set (String^ value);
}
member Prompt : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe Filter
Namespace DedNet.Controls


Proprietà Filter.Selected

Proprietà FilterSelected

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Selected { get; set; }
Public Property Selected As Boolean
    Get
    Set
public:
property bool Selected {
    bool get ();
    void set (bool value);
}
member Selected : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe Filter
Namespace DedNet.Controls


Proprietà Filter.Type

Proprietà FilterType

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Type Type { get; set; }
Public Property Type As Type
    Get
    Set
public:
property Type^ Type {
    Type^ get ();
    void set (Type^ value);
}
member Type : Type with get, set

Valore della proprietà

Type
Vedi anche

Documentazione

Classe Filter
Namespace DedNet.Controls


Proprietà Filter.Valore

Proprietà FilterValore

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object Valore { get; set; }
Public Property Valore As Object
    Get
    Set
public:
property Object^ Valore {
    Object^ get ();
    void set (Object^ value);
}
member Valore : Object with get, set

Valore della proprietà

Object
Vedi anche

Documentazione

Classe Filter
Namespace DedNet.Controls


Campi di Filter

Il tipo Filter espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | attList |
Campo pubblico | list | Lista contenente i valori nell'AttrList se non c'è la descrizione
Torna su
Vedi anche

Documentazione

Classe Filter
Namespace DedNet.Controls


Campo Filter.attList

Campo FilterattList

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<ComboItem> attList
Public attList As List(Of ComboItem)
public:
List<ComboItem^>^ attList
val mutable attList: List<ComboItem>

Valore del campo

List ComboItem
Vedi anche

Documentazione

Classe Filter
Namespace DedNet.Controls


Campo Filter.list

Campo Filterlist
Lista contenente i valori nell'AttrList se non c'è la descrizione

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> list
Public list As List(Of String)
public:
List<String^>^ list
val mutable list: List<string>

Valore del campo

List String
Vedi anche

Documentazione

Classe Filter
Namespace DedNet.Controls


Classe FilterList
Gerarchia di ereditarietà
SystemObject
DedNet.ControlsFilterList

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class FilterList
<SerializableAttribute>
Public Class FilterList
[SerializableAttribute]
public ref class FilterList
[<SerializableAttribute>]
type FilterList = class end

Il tipo FilterList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | FilterList | Costruttore classe
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | elencoFilters |
Proprietà pubblica | elencoFiltersBase |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore FilterList
Costruttore classe

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public FilterList()
Public Sub New
public:
FilterList()
new : unit -> FilterList
Vedi anche

Documentazione

Classe FilterList
Namespace DedNet.Controls


Proprietà di FilterList

Il tipo FilterList espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | elencoFilters |
Proprietà pubblica | elencoFiltersBase |
Torna su
Vedi anche

Documentazione

Classe FilterList
Namespace DedNet.Controls


Proprietà FilterList.elencoFilters

Proprietà FilterListelencoFilters

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<Filter> elencoFilters { get; set; }
Public Property elencoFilters As List(Of Filter)
    Get
    Set
public:
property List<Filter^>^ elencoFilters {
    List<Filter^>^ get ();
    void set (List<Filter^>^ value);
}
member elencoFilters : List<Filter> with get, set

Valore della proprietà

List Filter
Vedi anche

Documentazione

Classe FilterList
Namespace DedNet.Controls


Proprietà FilterList.elencoFiltersBase

Proprietà FilterListelencoFiltersBase

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<Item> elencoFiltersBase { get; set; }
Public Property elencoFiltersBase As List(Of Item)
    Get
    Set
public:
property List<Item^>^ elencoFiltersBase {
    List<Item^>^ get ();
    void set (List<Item^>^ value);
}
member elencoFiltersBase : List<Item> with get, set

Valore della proprietà

List Item
Vedi anche

Documentazione

Classe FilterList
Namespace DedNet.Controls


Classe Item
Gerarchia di ereditarietà
SystemObject
DedNet.ControlsItem

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class Item
Public Class Item
public ref class Item
type Item = class end

Il tipo Item espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | Item | Costruttore della classe
Metodo pubblico | Item(String, String) | Cortuttore della classe
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Nome | Nome dell'item da serializzare
Proprietà pubblica | Valore | Valore dell'item da serializzare
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore Item
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Item | Costruttore della classe
Metodo pubblico | Item(String, String) | Cortuttore della classe
Torna su
Vedi anche

Documentazione

Classe Item
Namespace DedNet.Controls


Costruttore Item
Costruttore della classe

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Item()
Public Sub New
public:
Item()
new : unit -> Item
Vedi anche

Documentazione

Classe Item
Overload di Item
Namespace DedNet.Controls


Costruttore Item(String, String)
Cortuttore della classe

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Item(
    string nome,
    string valore
)
Public Sub New (
    nome As String,
    valore As String
)
public:
Item(
    String^ nome,
    String^ valore
)
new :
        nome : string *
        valore : string -> Item

Parametri

nome String
Nome
valore String
Valore
Vedi anche

Documentazione

Classe Item
Overload di Item
Namespace DedNet.Controls


Proprietà di Item

Il tipo Item espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Nome | Nome dell'item da serializzare
Proprietà pubblica | Valore | Valore dell'item da serializzare
Torna su
Vedi anche

Documentazione

Classe Item
Namespace DedNet.Controls


Proprietà Item.Nome

Proprietà ItemNome
Nome dell'item da serializzare

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Nome { get; set; }
Public Property Nome As String
    Get
    Set
public:
property String^ Nome {
    String^ get ();
    void set (String^ value);
}
member Nome : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe Item
Namespace DedNet.Controls


Proprietà Item.Valore

Proprietà ItemValore
Valore dell'item da serializzare

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Valore { get; set; }
Public Property Valore As String
    Get
    Set
public:
property String^ Valore {
    String^ get ();
    void set (String^ value);
}
member Valore : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe Item
Namespace DedNet.Controls


Classe ManageAnagrControl
Classe per la gestione del raccoglitore di anagrafiche
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
XtraUserControl
DedNet.ControlsUserControlBase
DedNet.ControlsManageAnagrControl

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ManageAnagrControl : UserControlBase
Public Class ManageAnagrControl
    Inherits UserControlBase
public ref class ManageAnagrControl : public UserControlBase
type ManageAnagrControl =
    class
        inherit UserControlBase
    end

Il tipo ManageAnagrControl espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ManageAnagrControl | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Appearance | (Ereditato da XtraUserControl)
Proprietà pubblica | Application | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Proprietà pubblica | BackColor | (Ereditato da XtraUserControl)
Proprietà protetta | CheckDoubleScaling | (Ereditato da XtraUserControl)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraUserControl)
Proprietà protetta | DirectXContainer | (Ereditato da XtraUserControl)
Proprietà pubblica | EnableIXtraResizeableControlInterfaceProxy | (Ereditato da XtraUserControl)
Proprietà pubblica | Font | (Ereditato da XtraUserControl)
Proprietà pubblica | ForeColor | (Ereditato da XtraUserControl)
Proprietà protetta | Helper | (Ereditato da XtraUserControl)
Proprietà pubblica | HideBottomPanel | Proprietà per nascondere il Bottom Panel
Proprietà pubblica | HideInternalCtx | Proprietà per nascondere i comandi interni del menu contestuale
Proprietà pubblica | LookAndFeel | (Ereditato da XtraUserControl)
Proprietà pubblica | NumRecordToRead | Indica il numero di record da leggere/scrivere dal/nel file
Proprietà pubblica | OldFile |
Proprietà protetta | Painter | (Ereditato da XtraUserControl)
Proprietà pubblica | RegistryBaseKey | Restituisce o imposta la chiave dalla quale leggere e nella quale scrivere le impostazioni.
Proprietà protetta | ScaleChildren | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleDPI | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraUserControl)
Proprietà pubblica | SelectAnagr | Permette di selezionare una determinata anagrafica.
Proprietà pubblica | SelectedAnagr | Anagrafiche attualmente selezionate
Proprietà pubblica | SelectedNodes | Lista dei nodi attualmente selezionati
Proprietà protetta | ShouldCheckDpiScaleFactorOnParentChanged | (Ereditato da XtraUserControl)
Proprietà pubblica | ShowCheckBox | Proprietà per abilitare la colonna di selezione tramite checkbox
Proprietà pubblica | ShowFamilyToolTip | Proprietà per visualizzare la tooltip con la famiglia
Proprietà pubblica | ShowPreview | Indica se mostrare la colonna di Anteprima.
Proprietà pubblica | Site | (Ereditato da XtraUserControl)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Add(DedDataList) | Permette di aggiungere una lista di anagrafiche al controllo.
Metodo pubblico | Add(DedDataList, Int32) | Permette di aggiungere una lista di anagrafiche al controllo.
Metodo protetto | BaseWndProc | (Ereditato da XtraUserControl)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraUserControl)
Metodo protetto | CreatePainter | (Ereditato da XtraUserControl)
Metodo protetto | Dispose | Liberare le risorse in uso. (Sovrascrive UserControlBaseDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraUserControl)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraUserControl)
Metodo pubblico | FindDataRowInControl | Controlla se il nodo è già presente nella lista.
Metodo pubblico | FireEventSelectionChanged | Controlla i parametri e lancia l'evento OnAnagrSelectionChanged
Metodo pubblico | ForceRefresh | Forza il riaggiornamento del controllo.
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraUserControl)
Metodo protetto | GetBackColor | (Ereditato da XtraUserControl)
Metodo protetto | GetBackgroundSkinElement | (Ereditato da XtraUserControl)
Metodo protetto | GetInnerIXtraResizableControl | (Ereditato da XtraUserControl)
Metodo pubblico | GetTree | Ritorna il controllo TreeList
Metodo protetto | IsChildControlsRequiredScalingEnabled | (Ereditato da XtraUserControl)
Metodo protetto | IsParentHandleCreatedRecursive | (Ereditato da XtraUserControl)
Metodo pubblico | LoadRegistrySettings | Carica dal registro le dimensioni e la visibilità delle colonne.
Metodo protetto | OnAnagrSelectionChanged |
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraUserControl)
Metodo protetto | OnBackColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnContextMenuOpening | (Sovrascrive UserControlBaseOnContextMenuOpening(Object, CancelEventArgs))
Metodo protetto | OnControlAdded | (Ereditato da XtraUserControl)
Metodo protetto | OnControlRemoved | (Ereditato da XtraUserControl)
Metodo protetto | OnDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnFirstLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnForeColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnGetActiveObjectInfo |
Metodo protetto | OnHandleCreated | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraUserControl)
Metodo protetto | OnLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnMenuItemClicked | Evento di pressione di un comando del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnMouseDoubleClick |
Metodo protetto | OnPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnPaintCore | (Ereditato da XtraUserControl)
Metodo protetto | OnParentChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | OnSizeChanged | (Ereditato da XtraUserControl)
Metodo protetto | RaisePaintExEvent | (Ereditato da XtraUserControl)
Metodo pubblico | ReloadFilterInfo | Ricarica il filtro attivo nella colonna ECO (risolve il problema al display text)
Metodo pubblico | RemoveRows | Rimuove l'anagrafica dal controllo se presente.
Metodo pubblico | ResetBackColor | (Ereditato da XtraUserControl)
Metodo pubblico | ResetForeColor | (Ereditato da XtraUserControl)
Metodo protetto | RestoreAutoScaleModeChangedByPM2 | (Ereditato da XtraUserControl)
Metodo pubblico | SaveRegistrySettings | Salva nel registro le dimensioni e la visibilità delle colonne.
Metodo pubblico | SaveSettingsInRegKey | Metodo che salva le impostazioni sul file.
Metodo protetto | ScaleControl | (Ereditato da XtraUserControl)
Metodo pubblico | SelectNodeList | Seleziona i nodi passati come parametro
Metodo pubblico | SetCommandList | Rigenera il menu contestuale di questo controllo con la lista dei comandi passati. (Sovrascrive UserControlBaseSetCommandList(DedCommandList, CommandContextEnum))
Metodo protetto | SetVisibleCore | (Ereditato da XtraUserControl)
Metodo protetto | ShouldPaintTransparentBackground | (Ereditato da XtraUserControl)
Metodo protetto | ShouldUseDirectXPaint | (Ereditato da XtraUserControl)
Metodo pubblico | UpdateAnagraf | Aggiorna le anagrafiche attualmente selezionate
Metodo protetto | WndProc | (Ereditato da XtraUserControl)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | ContextMenuOpening | Evento su apertura del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | GetActiveObjectInfo |
Evento pubblico | MenuItemClicked | Evento su click su un elemento del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | MouseDoubleClick | Evento di doppio click.
Evento pubblico | onAddToPrefer |
Evento pubblico | PaintEx | (Ereditato da XtraUserControl)
Evento pubblico | SelectionChanged |
Torna su
Campi
 | Nome | Descrizione
Campo protetto | _app | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Campo protetto | _RegistryBaseKey | Chiave nel registro di sistema di salvataggio impostazioni. (Ereditato da UserControlBase)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore ManageAnagrControl
Costruttore

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ManageAnagrControl()
Public Sub New
public:
ManageAnagrControl()
new : unit -> ManageAnagrControl
Vedi anche

Documentazione

Classe ManageAnagrControl
Namespace DedNet.Controls


Proprietà di ManageAnagrControl

Il tipo ManageAnagrControl espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Appearance | (Ereditato da XtraUserControl)
Proprietà pubblica | Application | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Proprietà pubblica | BackColor | (Ereditato da XtraUserControl)
Proprietà protetta | CheckDoubleScaling | (Ereditato da XtraUserControl)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraUserControl)
Proprietà protetta | DirectXContainer | (Ereditato da XtraUserControl)
Proprietà pubblica | EnableIXtraResizeableControlInterfaceProxy | (Ereditato da XtraUserControl)
Proprietà pubblica | Font | (Ereditato da XtraUserControl)
Proprietà pubblica | ForeColor | (Ereditato da XtraUserControl)
Proprietà protetta | Helper | (Ereditato da XtraUserControl)
Proprietà pubblica | HideBottomPanel | Proprietà per nascondere il Bottom Panel
Proprietà pubblica | HideInternalCtx | Proprietà per nascondere i comandi interni del menu contestuale
Proprietà pubblica | LookAndFeel | (Ereditato da XtraUserControl)
Proprietà pubblica | NumRecordToRead | Indica il numero di record da leggere/scrivere dal/nel file
Proprietà pubblica | OldFile |
Proprietà protetta | Painter | (Ereditato da XtraUserControl)
Proprietà pubblica | RegistryBaseKey | Restituisce o imposta la chiave dalla quale leggere e nella quale scrivere le impostazioni.
Proprietà protetta | ScaleChildren | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleDPI | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraUserControl)
Proprietà pubblica | SelectAnagr | Permette di selezionare una determinata anagrafica.
Proprietà pubblica | SelectedAnagr | Anagrafiche attualmente selezionate
Proprietà pubblica | SelectedNodes | Lista dei nodi attualmente selezionati
Proprietà protetta | ShouldCheckDpiScaleFactorOnParentChanged | (Ereditato da XtraUserControl)
Proprietà pubblica | ShowCheckBox | Proprietà per abilitare la colonna di selezione tramite checkbox
Proprietà pubblica | ShowFamilyToolTip | Proprietà per visualizzare la tooltip con la famiglia
Proprietà pubblica | ShowPreview | Indica se mostrare la colonna di Anteprima.
Proprietà pubblica | Site | (Ereditato da XtraUserControl)
Torna su
Vedi anche

Documentazione

Classe ManageAnagrControl
Namespace DedNet.Controls


Proprietà ManageAnagrControl.HideBottomPanel

Proprietà ManageAnagrControlHideBottomPanel
Proprietà per nascondere il Bottom Panel

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HideBottomPanel { set; }
Public WriteOnly Property HideBottomPanel As Boolean
    Set
public:
property bool HideBottomPanel {
    void set (bool value);
}
member HideBottomPanel : bool with set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ManageAnagrControl
Namespace DedNet.Controls


Proprietà ManageAnagrControl.HideInternalCtx

Proprietà ManageAnagrControlHideInternalCtx
Proprietà per nascondere i comandi interni del menu contestuale

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HideInternalCtx { get; set; }
Public Property HideInternalCtx As Boolean
    Get
    Set
public:
property bool HideInternalCtx {
    bool get ();
    void set (bool value);
}
member HideInternalCtx : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ManageAnagrControl
Namespace DedNet.Controls


Proprietà ManageAnagrControl.NumRecordToRead

Proprietà ManageAnagrControlNumRecordToRead
Indica il numero di record da leggere/scrivere dal/nel file

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int NumRecordToRead { get; set; }
Public Property NumRecordToRead As Integer
    Get
    Set
public:
property int NumRecordToRead {
    int get ();
    void set (int value);
}
member NumRecordToRead : int with get, set

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe ManageAnagrControl
Namespace DedNet.Controls


Proprietà ManageAnagrControl.OldFile

Proprietà ManageAnagrControlOldFile

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string OldFile { get; set; }
Public Property OldFile As String
    Get
    Set
public:
property String^ OldFile {
    String^ get ();
    void set (String^ value);
}
member OldFile : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe ManageAnagrControl
Namespace DedNet.Controls


Proprietà ManageAnagrControl.RegistryBaseKey

Proprietà ManageAnagrControlRegistryBaseKey
Restituisce o imposta la chiave dalla quale leggere e nella quale scrivere le impostazioni.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string RegistryBaseKey { get; set; }
Public Property RegistryBaseKey As String
    Get
    Set
public:
property String^ RegistryBaseKey {
    String^ get ();
    void set (String^ value);
}
member RegistryBaseKey : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe ManageAnagrControl
Namespace DedNet.Controls


Proprietà ManageAnagrControl.SelectAnagr

Proprietà ManageAnagrControlSelectAnagr
Permette di selezionare una determinata anagrafica.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData SelectAnagr { set; }
Public WriteOnly Property SelectAnagr As DedData
    Set
public:
property DedData^ SelectAnagr {
    void set (DedData^ value);
}
member SelectAnagr : DedData with set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe ManageAnagrControl
Namespace DedNet.Controls


Proprietà ManageAnagrControl.SelectedAnagr

Proprietà ManageAnagrControlSelectedAnagr
Anagrafiche attualmente selezionate

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataList SelectedAnagr { get; }
Public ReadOnly Property SelectedAnagr As DedDataList
    Get
public:
property DedDataList^ SelectedAnagr {
    DedDataList^ get ();
}
member SelectedAnagr : DedDataList with get

Valore della proprietà

DedDataList
Vedi anche

Documentazione

Classe ManageAnagrControl
Namespace DedNet.Controls


Proprietà ManageAnagrControl.SelectedNodes

Proprietà ManageAnagrControlSelectedNodes
Lista dei nodi attualmente selezionati

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<int> SelectedNodes { get; }
Public ReadOnly Property SelectedNodes As List(Of Integer)
    Get
public:
property List<int>^ SelectedNodes {
    List<int>^ get ();
}
member SelectedNodes : List<int> with get

Valore della proprietà

List Int32
Vedi anche

Documentazione

Classe ManageAnagrControl
Namespace DedNet.Controls


Proprietà ManageAnagrControl.ShowCheckBox

Proprietà ManageAnagrControlShowCheckBox
Proprietà per abilitare la colonna di selezione tramite checkbox

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ShowCheckBox { set; }
Public WriteOnly Property ShowCheckBox As Boolean
    Set
public:
property bool ShowCheckBox {
    void set (bool value);
}
member ShowCheckBox : bool with set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ManageAnagrControl
Namespace DedNet.Controls


Proprietà ManageAnagrControl.ShowFamilyToolTip

Proprietà ManageAnagrControlShowFamilyToolTip
Proprietà per visualizzare la tooltip con la famiglia

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ShowFamilyToolTip { get; set; }
Public Property ShowFamilyToolTip As Boolean
    Get
    Set
public:
property bool ShowFamilyToolTip {
    bool get ();
    void set (bool value);
}
member ShowFamilyToolTip : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ManageAnagrControl
Namespace DedNet.Controls


Proprietà ManageAnagrControl.ShowPreview

Proprietà ManageAnagrControlShowPreview
Indica se mostrare la colonna di Anteprima.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ShowPreview { get; set; }
Public Property ShowPreview As Boolean
    Get
    Set
public:
property bool ShowPreview {
    bool get ();
    void set (bool value);
}
member ShowPreview : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ManageAnagrControl
Namespace DedNet.Controls


Metodi di ManageAnagrControl

Il tipo ManageAnagrControl espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Add(DedDataList) | Permette di aggiungere una lista di anagrafiche al controllo.
Metodo pubblico | Add(DedDataList, Int32) | Permette di aggiungere una lista di anagrafiche al controllo.
Metodo protetto | BaseWndProc | (Ereditato da XtraUserControl)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraUserControl)
Metodo protetto | CreatePainter | (Ereditato da XtraUserControl)
Metodo protetto | Dispose | Liberare le risorse in uso. (Sovrascrive UserControlBaseDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraUserControl)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraUserControl)
Metodo pubblico | FindDataRowInControl | Controlla se il nodo è già presente nella lista.
Metodo pubblico | FireEventSelectionChanged | Controlla i parametri e lancia l'evento OnAnagrSelectionChanged
Metodo pubblico | ForceRefresh | Forza il riaggiornamento del controllo.
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraUserControl)
Metodo protetto | GetBackColor | (Ereditato da XtraUserControl)
Metodo protetto | GetBackgroundSkinElement | (Ereditato da XtraUserControl)
Metodo protetto | GetInnerIXtraResizableControl | (Ereditato da XtraUserControl)
Metodo pubblico | GetTree | Ritorna il controllo TreeList
Metodo protetto | IsChildControlsRequiredScalingEnabled | (Ereditato da XtraUserControl)
Metodo protetto | IsParentHandleCreatedRecursive | (Ereditato da XtraUserControl)
Metodo pubblico | LoadRegistrySettings | Carica dal registro le dimensioni e la visibilità delle colonne.
Metodo protetto | OnAnagrSelectionChanged |
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraUserControl)
Metodo protetto | OnBackColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnContextMenuOpening | (Sovrascrive UserControlBaseOnContextMenuOpening(Object, CancelEventArgs))
Metodo protetto | OnControlAdded | (Ereditato da XtraUserControl)
Metodo protetto | OnControlRemoved | (Ereditato da XtraUserControl)
Metodo protetto | OnDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnFirstLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnForeColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnGetActiveObjectInfo |
Metodo protetto | OnHandleCreated | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraUserControl)
Metodo protetto | OnLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnMenuItemClicked | Evento di pressione di un comando del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnMouseDoubleClick |
Metodo protetto | OnPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnPaintCore | (Ereditato da XtraUserControl)
Metodo protetto | OnParentChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | OnSizeChanged | (Ereditato da XtraUserControl)
Metodo protetto | RaisePaintExEvent | (Ereditato da XtraUserControl)
Metodo pubblico | ReloadFilterInfo | Ricarica il filtro attivo nella colonna ECO (risolve il problema al display text)
Metodo pubblico | RemoveRows | Rimuove l'anagrafica dal controllo se presente.
Metodo pubblico | ResetBackColor | (Ereditato da XtraUserControl)
Metodo pubblico | ResetForeColor | (Ereditato da XtraUserControl)
Metodo protetto | RestoreAutoScaleModeChangedByPM2 | (Ereditato da XtraUserControl)
Metodo pubblico | SaveRegistrySettings | Salva nel registro le dimensioni e la visibilità delle colonne.
Metodo pubblico | SaveSettingsInRegKey | Metodo che salva le impostazioni sul file.
Metodo protetto | ScaleControl | (Ereditato da XtraUserControl)
Metodo pubblico | SelectNodeList | Seleziona i nodi passati come parametro
Metodo pubblico | SetCommandList | Rigenera il menu contestuale di questo controllo con la lista dei comandi passati. (Sovrascrive UserControlBaseSetCommandList(DedCommandList, CommandContextEnum))
Metodo protetto | SetVisibleCore | (Ereditato da XtraUserControl)
Metodo protetto | ShouldPaintTransparentBackground | (Ereditato da XtraUserControl)
Metodo protetto | ShouldUseDirectXPaint | (Ereditato da XtraUserControl)
Metodo pubblico | UpdateAnagraf | Aggiorna le anagrafiche attualmente selezionate
Metodo protetto | WndProc | (Ereditato da XtraUserControl)
Torna su
Vedi anche

Documentazione

Classe ManageAnagrControl
Namespace DedNet.Controls


Metodo ManageAnagrControl.Add

Metodo ManageAnagrControlAdd
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Add(DedDataList) | Permette di aggiungere una lista di anagrafiche al controllo.
Metodo pubblico | Add(DedDataList, Int32) | Permette di aggiungere una lista di anagrafiche al controllo.
Torna su
Vedi anche

Documentazione

Classe ManageAnagrControl
Namespace DedNet.Controls


Metodo ManageAnagrControl.Add(DedDataList)

Metodo ManageAnagrControlAdd(DedDataList)
Permette di aggiungere una lista di anagrafiche al controllo.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Add(
    DedDataList dataList
)
Public Sub Add (
    dataList As DedDataList
)
public:
void Add(
    DedDataList^ dataList
)
member Add :
        dataList : DedDataList -> unit

Parametri

dataList DedDataList
Elenco delle anagrafiche da aggiungere.
Vedi anche

Documentazione

Classe ManageAnagrControl
Overload di Add
Namespace DedNet.Controls


Metodo ManageAnagrControl.Add(DedDataList, Int32)

Metodo ManageAnagrControlAdd(DedDataList, Int32)
Permette di aggiungere una lista di anagrafiche al controllo.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Add(
    DedDataList dataList,
    int typeCtrl
)
Public Sub Add (
    dataList As DedDataList,
    typeCtrl As Integer
)
public:
void Add(
    DedDataList^ dataList,
    int typeCtrl
)
member Add :
        dataList : DedDataList *
        typeCtrl : int -> unit

Parametri

dataList DedDataList
Elenco delle anagrafiche da aggiungere.
typeCtrl Int32
Variabile che indica il controllo corrente (0 = "TabPage Preferiti"; 1 = "TabPage Recenti")
Vedi anche

Documentazione

Classe ManageAnagrControl
Overload di Add
Namespace DedNet.Controls


Metodo ManageAnagrControl.Dispose

Metodo ManageAnagrControlDispose
Liberare le risorse in uso.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
ha valore true se le risorse gestite devono essere eliminate, false in caso contrario.
Vedi anche

Documentazione

Classe ManageAnagrControl
Namespace DedNet.Controls


Metodo ManageAnagrControl.FindDataRowInControl

Metodo ManageAnagrControlFindDataRowInControl
Controlla se il nodo è già presente nella lista.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DataRow[] FindDataRowInControl(
    DedData data
)
Public Function FindDataRowInControl (
    data As DedData
) As DataRow()
public:
array<DataRow^>^ FindDataRowInControl(
    DedData^ data
)
member FindDataRowInControl :
        data : DedData -> DataRow[]

Parametri

data DedData
Nodo da cercare.

Valore di ritorno

DataRow
True se il nodo è già presente, altrimenti false
Vedi anche

Documentazione

Classe ManageAnagrControl
Namespace DedNet.Controls


Metodo ManageAnagrControl.FireEventSelectionChanged

Metodo ManageAnagrControlFireEventSelectionChanged
Controlla i parametri e lancia l'evento OnAnagrSelectionChanged

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void FireEventSelectionChanged()
Public Sub FireEventSelectionChanged
public:
void FireEventSelectionChanged()
member FireEventSelectionChanged : unit -> unit
Vedi anche

Documentazione

Classe ManageAnagrControl
Namespace DedNet.Controls


Metodo ManageAnagrControl.ForceRefresh

Metodo ManageAnagrControlForceRefresh
Forza il riaggiornamento del controllo.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ForceRefresh()
Public Sub ForceRefresh
public:
void ForceRefresh()
member ForceRefresh : unit -> unit
Vedi anche

Documentazione

Classe ManageAnagrControl
Namespace DedNet.Controls


Metodo ManageAnagrControl.GetTree

Metodo ManageAnagrControlGetTree
Ritorna il controllo TreeList

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public GridControl GetTree()
Public Function GetTree As GridControl
public:
GridControl^ GetTree()
member GetTree : unit -> GridControl

Valore di ritorno

GridControl
Vedi anche

Documentazione

Classe ManageAnagrControl
Namespace DedNet.Controls


Metodo ManageAnagrControl.LoadRegistrySettings

Metodo ManageAnagrControlLoadRegistrySettings
Carica dal registro le dimensioni e la visibilità delle colonne.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void LoadRegistrySettings(
    string key
)
Public Sub LoadRegistrySettings (
    key As String
)
public:
void LoadRegistrySettings(
    String^ key
)
member LoadRegistrySettings :
        key : string -> unit

Parametri

key String
Chiave di registro dalla quale leggere le impostazioni.
Vedi anche

Documentazione

Classe ManageAnagrControl
Namespace DedNet.Controls


Metodo ManageAnagrControl.OnAnagrSelectionChanged

Metodo ManageAnagrControlOnAnagrSelectionChanged

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected void OnAnagrSelectionChanged(
    Object sender,
    DedAnagrViewControlDedAnagrEventArgs ev
)
Protected Sub OnAnagrSelectionChanged (
    sender As Object,
    ev As DedAnagrViewControlDedAnagrEventArgs
)
protected:
void OnAnagrSelectionChanged(
    Object^ sender,
    DedAnagrViewControlDedAnagrEventArgs^ ev
)
member OnAnagrSelectionChanged :
        sender : Object *
        ev : DedAnagrViewControlDedAnagrEventArgs -> unit

Parametri

sender Object
ev DedAnagrViewControlDedAnagrEventArgs
Vedi anche

Documentazione

Classe ManageAnagrControl
Namespace DedNet.Controls


Metodo ManageAnagrControl.OnContextMenuOpening

Metodo ManageAnagrControlOnContextMenuOpening

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void OnContextMenuOpening(
    Object sender,
    CancelEventArgs e
)
Protected Overrides Sub OnContextMenuOpening (
    sender As Object,
    e As CancelEventArgs
)
protected:
virtual void OnContextMenuOpening(
    Object^ sender,
    CancelEventArgs^ e
) override
abstract OnContextMenuOpening :
        sender : Object *
        e : CancelEventArgs -> unit
override OnContextMenuOpening :
        sender : Object *
        e : CancelEventArgs -> unit

Parametri

sender Object
e CancelEventArgs
Vedi anche

Documentazione

Classe ManageAnagrControl
Namespace DedNet.Controls


Metodo ManageAnagrControl.OnGetActiveObjectInfo

Metodo ManageAnagrControlOnGetActiveObjectInfo

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected void OnGetActiveObjectInfo(
    Object sender,
    ToolTipControllerGetActiveObjectInfoEventArgs ev
)
Protected Sub OnGetActiveObjectInfo (
    sender As Object,
    ev As ToolTipControllerGetActiveObjectInfoEventArgs
)
protected:
void OnGetActiveObjectInfo(
    Object^ sender,
    ToolTipControllerGetActiveObjectInfoEventArgs^ ev
)
member OnGetActiveObjectInfo :
        sender : Object *
        ev : ToolTipControllerGetActiveObjectInfoEventArgs -> unit

Parametri

sender Object
ev ToolTipControllerGetActiveObjectInfoEventArgs
Vedi anche

Documentazione

Classe ManageAnagrControl
Namespace DedNet.Controls


Metodo ManageAnagrControl.OnMouseDoubleClick

Metodo ManageAnagrControlOnMouseDoubleClick

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected void OnMouseDoubleClick(
    Object sender,
    MouseEventArgs e
)
Protected Sub OnMouseDoubleClick (
    sender As Object,
    e As MouseEventArgs
)
protected:
void OnMouseDoubleClick(
    Object^ sender,
    MouseEventArgs^ e
)
member OnMouseDoubleClick :
        sender : Object *
        e : MouseEventArgs -> unit

Parametri

sender Object
e MouseEventArgs
Vedi anche

Documentazione

Classe ManageAnagrControl
Namespace DedNet.Controls


Metodo ManageAnagrControl.ReloadFilterInfo

Metodo ManageAnagrControlReloadFilterInfo
Ricarica il filtro attivo nella colonna ECO (risolve il problema al display text)

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ReloadFilterInfo()
Public Sub ReloadFilterInfo
public:
void ReloadFilterInfo()
member ReloadFilterInfo : unit -> unit
Vedi anche

Documentazione

Classe ManageAnagrControl
Namespace DedNet.Controls


Metodo ManageAnagrControl.RemoveRows

Metodo ManageAnagrControlRemoveRows
Rimuove l'anagrafica dal controllo se presente.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void RemoveRows(
    DedDataList datas
)
Public Sub RemoveRows (
    datas As DedDataList
)
public:
void RemoveRows(
    DedDataList^ datas
)
member RemoveRows :
        datas : DedDataList -> unit

Parametri

datas DedDataList
Anagrafiche da rimuovere
Vedi anche

Documentazione

Classe ManageAnagrControl
Namespace DedNet.Controls


Metodo ManageAnagrControl.SaveRegistrySettings

Metodo ManageAnagrControlSaveRegistrySettings
Salva nel registro le dimensioni e la visibilità delle colonne.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SaveRegistrySettings()
Public Sub SaveRegistrySettings
public:
void SaveRegistrySettings()
member SaveRegistrySettings : unit -> unit
Vedi anche

Documentazione

Classe ManageAnagrControl
Namespace DedNet.Controls


Metodo ManageAnagrControl.SaveSettingsInRegKey

Metodo ManageAnagrControlSaveSettingsInRegKey
Metodo che salva le impostazioni sul file.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SaveSettingsInRegKey()
Public Sub SaveSettingsInRegKey
public:
void SaveSettingsInRegKey()
member SaveSettingsInRegKey : unit -> unit
Vedi anche

Documentazione

Classe ManageAnagrControl
Namespace DedNet.Controls


Metodo ManageAnagrControl.SelectNodeList

Metodo ManageAnagrControlSelectNodeList
Seleziona i nodi passati come parametro

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SelectNodeList(
    List<int> nodeList
)
Public Sub SelectNodeList (
    nodeList As List(Of Integer)
)
public:
void SelectNodeList(
    List<int>^ nodeList
)
member SelectNodeList :
        nodeList : List<int> -> unit

Parametri

nodeList List Int32
nodi da selezionare
Vedi anche

Documentazione

Classe ManageAnagrControl
Namespace DedNet.Controls


Metodo ManageAnagrControl.SetCommandList

Metodo ManageAnagrControlSetCommandList
Rigenera il menu contestuale di questo controllo con la lista dei comandi passati.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void SetCommandList(
    DedCommandList commandList,
    CommandContextEnum commandContext
)
Public Overrides Sub SetCommandList (
    commandList As DedCommandList,
    commandContext As CommandContextEnum
)
public:
virtual void SetCommandList(
    DedCommandList^ commandList,
    CommandContextEnum commandContext
) override
abstract SetCommandList :
        commandList : DedCommandList *
        commandContext : CommandContextEnum -> unit
override SetCommandList :
        commandList : DedCommandList *
        commandContext : CommandContextEnum -> unit

Parametri

commandList DedCommandList
Lista completa dei comandi.
commandContext CommandContextEnum
Contesto da utilizzare per filtrare i comandi da inserire.
Note
Filtra i comandi in modo da aggiungere soltanto quelli coerenti con il contesto passato.
Vedi anche

Documentazione

Classe ManageAnagrControl
Namespace DedNet.Controls


Metodo ManageAnagrControl.UpdateAnagraf

Metodo ManageAnagrControlUpdateAnagraf
Aggiorna le anagrafiche attualmente selezionate

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void UpdateAnagraf()
Public Sub UpdateAnagraf
public:
void UpdateAnagraf()
member UpdateAnagraf : unit -> unit
Vedi anche

Documentazione

Classe ManageAnagrControl
Namespace DedNet.Controls


Eventi di ManageAnagrControl

Il tipo ManageAnagrControl espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | ContextMenuOpening | Evento su apertura del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | GetActiveObjectInfo |
Evento pubblico | MenuItemClicked | Evento su click su un elemento del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | MouseDoubleClick | Evento di doppio click.
Evento pubblico | onAddToPrefer |
Evento pubblico | PaintEx | (Ereditato da XtraUserControl)
Evento pubblico | SelectionChanged |
Torna su
Vedi anche

Documentazione

Classe ManageAnagrControl
Namespace DedNet.Controls


Evento ManageAnagrControl.GetActiveObjectInfo

Evento ManageAnagrControlGetActiveObjectInfo

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<ToolTipControllerGetActiveObjectInfoEventArgs> GetActiveObjectInfo
Public Event GetActiveObjectInfo As EventHandler(Of ToolTipControllerGetActiveObjectInfoEventArgs)
public:
 event EventHandler<ToolTipControllerGetActiveObjectInfoEventArgs^>^ GetActiveObjectInfo {
    void add (EventHandler<ToolTipControllerGetActiveObjectInfoEventArgs^>^ value);
    void remove (EventHandler<ToolTipControllerGetActiveObjectInfoEventArgs^>^ value);
}
member GetActiveObjectInfo : IEvent<EventHandler<ToolTipControllerGetActiveObjectInfoEventArgs>,
    ToolTipControllerGetActiveObjectInfoEventArgs>

Valore

EventHandler ToolTipControllerGetActiveObjectInfoEventArgs
Vedi anche

Documentazione

Classe ManageAnagrControl
Namespace DedNet.Controls


Evento ManageAnagrControl.MouseDoubleClick

Evento ManageAnagrControlMouseDoubleClick
Evento di doppio click.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event MouseEventHandler MouseDoubleClick
Public Event MouseDoubleClick As MouseEventHandler
public:
 event MouseEventHandler^ MouseDoubleClick {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}
member MouseDoubleClick : IEvent<MouseEventHandler,
    MouseEventArgs>

Valore

MouseEventHandler
Vedi anche

Documentazione

Classe ManageAnagrControl
Namespace DedNet.Controls


Evento ManageAnagrControl.onAddToPrefer

Evento ManageAnagrControlonAddToPrefer

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler onAddToPrefer
Public Event onAddToPrefer As EventHandler
public:
 event EventHandler^ onAddToPrefer {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member onAddToPrefer : IEvent<EventHandler,
    EventArgs>

Valore

EventHandler
Vedi anche

Documentazione

Classe ManageAnagrControl
Namespace DedNet.Controls


Evento ManageAnagrControl.SelectionChanged

Evento ManageAnagrControlSelectionChanged

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DedAnagrViewControlDedAnagrEventArgs> SelectionChanged
Public Event SelectionChanged As EventHandler(Of DedAnagrViewControlDedAnagrEventArgs)
public:
 event EventHandler<DedAnagrViewControlDedAnagrEventArgs^>^ SelectionChanged {
    void add (EventHandler<DedAnagrViewControlDedAnagrEventArgs^>^ value);
    void remove (EventHandler<DedAnagrViewControlDedAnagrEventArgs^>^ value);
}
member SelectionChanged : IEvent<EventHandler<DedAnagrViewControlDedAnagrEventArgs>,
    DedAnagrViewControlDedAnagrEventArgs>

Valore

EventHandler DedAnagrViewControlDedAnagrEventArgs
Vedi anche

Documentazione

Classe ManageAnagrControl
Namespace DedNet.Controls


Campi di ManageAnagrControl

Il tipo ManageAnagrControl espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | _app | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Campo protetto | _RegistryBaseKey | Chiave nel registro di sistema di salvataggio impostazioni. (Ereditato da UserControlBase)
Torna su
Vedi anche

Documentazione

Classe ManageAnagrControl
Namespace DedNet.Controls


Classe MyAnagrViewGridControl
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
EditorContainer
GridControl
DedNet.ControlsMyAnagrViewGridControl

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class MyAnagrViewGridControl : GridControl
Public Class MyAnagrViewGridControl
    Inherits GridControl
public ref class MyAnagrViewGridControl : public GridControl
type MyAnagrViewGridControl =
    class
        inherit GridControl
    end

Il tipo MyAnagrViewGridControl espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | MyAnagrViewGridControl |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà protetta | AllowLayoutEvent | (Ereditato da GridControl)
Proprietà pubblica | AllowRestoreSelectionAndFocusedRow | (Ereditato da GridControl)
Proprietà protetta | AllowScaleOnLoad | (Ereditato da EditorContainer)
Proprietà pubblica | AllowTouchGestures | (Ereditato da EditorContainer)
Proprietà pubblica | AvailableViews | (Ereditato da GridControl)
Proprietà pubblica | BackColor | (Ereditato da GridControl)
Proprietà pubblica | BindingContext | (Ereditato da GridControl)
Proprietà pubblica | ContextMenuStrip | (Ereditato da GridControl)
Proprietà pubblica | Controls | (Ereditato da GridControl)
Proprietà pubblica | Cursor | (Ereditato da GridControl)
Proprietà pubblica | DataMember | (Ereditato da GridControl)
Proprietà pubblica | DataSource | (Ereditato da GridControl)
Proprietà protetta | DefaultSize | (Ereditato da GridControl)
Proprietà pubblica | DefaultView | (Ereditato da GridControl)
Proprietà protetta | DirectXProvider | (Ereditato da GridControl)
Proprietà protetta | DirectXScroller | (Ereditato da GridControl)
Proprietà pubblica | Dock | (Ereditato da GridControl)
Proprietà protetta | DragController | (Ereditato da GridControl)
Proprietà protetta | EditorHelper | (Ereditato da GridControl)
Proprietà pubblica | EmbeddedNavigator | (Ereditato da GridControl)
Proprietà protetta | EnableFirstPaintTrigger | (Ereditato da GridControl)
Proprietà protetta | ExceptionThrown | (Ereditato da GridControl)
Proprietà pubblica | ExternalRepository | (Ereditato da EditorContainer)
Proprietà protetta | FireOnLoadOnPaint | (Ereditato da GridControl)
Proprietà pubblica | FocusedView | (Ereditato da GridControl)
Proprietà pubblica | ForeColor | (Ereditato da EditorContainer)
Proprietà pubblica | FormsUseDefaultLookAndFeel | (Ereditato da GridControl)
Proprietà pubblica | GridDisposing | (Ereditato da GridControl)
Proprietà pubblica | IsAttachedToSearchControl | (Ereditato da GridControl)
Proprietà pubblica | IsDesignMode | (Ereditato da EditorContainer)
Proprietà pubblica | IsFocused | (Ereditato da GridControl)
Proprietà protetta | IsInitialized | (Ereditato da EditorContainer)
Proprietà protetta | IsInPrintMessage | (Ereditato da GridControl)
Proprietà pubblica | IsLoaded | (Ereditato da GridControl)
Proprietà pubblica | IsLoading | (Ereditato da EditorContainer)
Proprietà protetta | IsLockUpdate | (Ereditato da GridControl)
Proprietà protetta | IsPrinterExist | (Ereditato da GridControl)
Proprietà pubblica | IsPrinting | (Ereditato da GridControl)
Proprietà pubblica | IsPrintingAvailable | (Ereditato da GridControl)
Proprietà protetta | IsPrintWrapperValid | (Ereditato da GridControl)
Proprietà protetta | IsRightToLeft | (Ereditato da GridControl)
Proprietà pubblica | IsSplitGrid | (Ereditato da GridControl)
Proprietà pubblica | KeyboardFocusView | Obsoleto. (Ereditato da GridControl)
Proprietà pubblica | LevelTree | (Ereditato da GridControl)
Proprietà pubblica | LookAndFeel | (Ereditato da EditorContainer)
Proprietà protetta | LookAndFeelIgnoreChildren | (Ereditato da EditorContainer)
Proprietà protetta | LookUpOwner | (Ereditato da GridControl)
Proprietà pubblica | MainView | (Ereditato da GridControl)
Proprietà pubblica | MenuManager | (Ereditato da EditorContainer)
Proprietà protetta | MouseCaptureOwner | (Ereditato da GridControl)
Proprietà protetta | NavigatableHelper | (Ereditato da GridControl)
Proprietà protetta | NavView | (Ereditato da GridControl)
Proprietà protetta | Printer | (Ereditato da GridControl)
Proprietà protetta | PrintWrapper | (Ereditato da GridControl)
Proprietà pubblica | RepositoryItems | (Ereditato da EditorContainer)
Proprietà protetta | ScaleDPI | (Ereditato da EditorContainer)
Proprietà pubblica | ScaleFactor | (Ereditato da EditorContainer)
Proprietà protetta | ScaleHelper | (Ereditato da EditorContainer)
Proprietà protetta | Scroller | (Ereditato da GridControl)
Proprietà pubblica | ServerMode | Obsoleto. (Ereditato da GridControl)
Proprietà pubblica | ShowOnlyPredefinedDetails | (Ereditato da GridControl)
Proprietà protetta | SplitContainer | (Ereditato da GridControl)
Proprietà pubblica | Text | (Ereditato da EditorContainer)
Proprietà pubblica | ToolTipController | (Ereditato da EditorContainer)
Proprietà protetta | TouchClient | (Ereditato da GridControl)
Proprietà pubblica | UseDirectXPaint | (Ereditato da GridControl)
Proprietà protetta | UseDirectXPaintCore | (Ereditato da GridControl)
Proprietà pubblica | UseDisabledStatePainter | (Ereditato da GridControl)
Proprietà pubblica | UseEmbeddedNavigator | (Ereditato da GridControl)
Proprietà pubblica | ViewCollection | (Ereditato da GridControl)
Proprietà protetta | ViewRepository | (Ereditato da GridControl)
Proprietà pubblica | Views | (Ereditato da GridControl)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AccessibleNotifyClients(AccessibleEvents, BaseAccessible) | (Ereditato da GridControl)
Metodo pubblico | AccessibleNotifyClients(AccessibleEvents, Int32) | (Ereditato da GridControl)
Metodo protetto | ActivateDataSource | (Ereditato da GridControl)
Metodo protetto | AddToDefaultTooltipController | (Ereditato da EditorContainer)
Metodo pubblico | BeginInit | (Ereditato da GridControl)
Metodo pubblico | BeginUpdate | (Ereditato da GridControl)
Metodo protetto | CancelUpdate | (Ereditato da GridControl)
Metodo protetto | CanHandleTouchGestures | (Ereditato da EditorContainer)
Metodo protetto | CheckMousePos | (Ereditato da GridControl)
Metodo protetto | CheckNeedScale | (Ereditato da EditorContainer)
Metodo protetto | CheckPrintWrapper | (Ereditato da GridControl)
Metodo protetto | CheckProcessMsg | (Ereditato da GridControl)
Metodo protetto | CheckRightToLeft | (Ereditato da EditorContainer)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da GridControl)
Metodo protetto | CreateComponentPrinter | (Ereditato da GridControl)
Metodo protetto | CreateDefaultView | (Ereditato da GridControl)
Metodo protetto | CreateEmbeddedNavigator | (Ereditato da GridControl)
Metodo pubblico | CreateGraphicsCache | (Ereditato da GridControl)
Metodo protetto | CreateHelper | (Ereditato da GridControl)
Metodo protetto | CreateInternalRepository | (Ereditato da EditorContainer)
Metodo protetto | CreateLookAndFeel | (Ereditato da EditorContainer)
Metodo protetto | CreateMainView | (Ereditato da GridControl)
Metodo pubblico | CreateSplitContainer | (Ereditato da GridControl)
Metodo pubblico | CreateView | (Ereditato da GridControl)
Metodo protetto | CreateViewPrintWrapper | (Ereditato da GridControl)
Metodo protetto | DestroyAvailableViews | (Ereditato da GridControl)
Metodo protetto | DestroyDirectXProvider | (Ereditato da EditorContainer)
Metodo protetto | DestroyPrinting | (Ereditato da GridControl)
Metodo protetto | Dispose | (Ereditato da GridControl)
Metodo protetto | DoDpiChange | (Ereditato da EditorContainer)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da GridControl)
Metodo pubblico | EndInit | (Ereditato da EditorContainer)
Metodo pubblico | EndUpdate | (Ereditato da GridControl)
Metodo protetto | EndUpdate(Boolean) | (Ereditato da GridControl)
Metodo protetto | EnforceValidDataMember | (Ereditato da GridControl)
Metodo pubblico | ExportToCsv(Stream) | (Ereditato da GridControl)
Metodo pubblico | ExportToCsv(String) | (Ereditato da GridControl)
Metodo pubblico | ExportToCsv(Stream, CsvExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToCsv(String, CsvExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToDocx(Stream) | (Ereditato da GridControl)
Metodo pubblico | ExportToDocx(String) | (Ereditato da GridControl)
Metodo pubblico | ExportToDocx(Stream, DocxExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToDocx(String, DocxExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToExcelOld | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToHtml(Stream) | (Ereditato da GridControl)
Metodo pubblico | ExportToHtml(String) | (Ereditato da GridControl)
Metodo pubblico | ExportToHtml(Stream, HtmlExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToHtml(String, HtmlExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToHtml(String, String) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToHtml(Stream, String, String, Boolean) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToHtml(String, String, String, Boolean) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToHtmlOld | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToMht(String) | (Ereditato da GridControl)
Metodo pubblico | ExportToMht(Stream, MhtExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToMht(String, MhtExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToMht(String, String) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToMht(Stream, String, String, Boolean) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToMht(String, String, String, Boolean) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToPdf(Stream) | (Ereditato da GridControl)
Metodo pubblico | ExportToPdf(String) | (Ereditato da GridControl)
Metodo pubblico | ExportToRtf(Stream) | (Ereditato da GridControl)
Metodo pubblico | ExportToRtf(String) | (Ereditato da GridControl)
Metodo pubblico | ExportToRtf(Stream, RtfExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToRtf(String, RtfExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToText(Stream) | (Ereditato da GridControl)
Metodo pubblico | ExportToText(String) | (Ereditato da GridControl)
Metodo pubblico | ExportToText(Stream, TextExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToText(Stream, String) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToText(String, TextExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToText(String, String) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToText(Stream, String, Boolean) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToText(String, String, Boolean) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToText(Stream, String, Boolean, Encoding) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToText(String, String, Boolean, Encoding) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToTextOld | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToXls(Stream) | (Ereditato da GridControl)
Metodo pubblico | ExportToXls(String) | (Ereditato da GridControl)
Metodo pubblico | ExportToXls(Stream, XlsExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToXls(Stream, Boolean) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToXls(String, XlsExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToXls(String, Boolean) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToXlsx(Stream) | (Ereditato da GridControl)
Metodo pubblico | ExportToXlsx(String) | (Ereditato da GridControl)
Metodo pubblico | ExportToXlsx(Stream, XlsxExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToXlsx(String, XlsxExportOptions) | (Ereditato da GridControl)
Metodo pubblico | FireChanged | (Ereditato da GridControl)
Metodo protetto | FireChanged(Object) | (Ereditato da GridControl)
Metodo protetto | FocusViewByMouse | (Ereditato da GridControl)
Metodo pubblico | ForceInitialize | (Ereditato da GridControl)
Metodo protetto | ForceViewInitialize | (Ereditato da GridControl)
Metodo protetto | GetAccessibilityObjectById | (Ereditato da GridControl)
Metodo protetto | GetComponentSelected | (Ereditato da GridControl)
Metodo protetto | GetDirectXDeviceBackColor | (Ereditato da GridControl)
Metodo protetto | GetDirectXProvider | (Ereditato da EditorContainer)
Metodo protetto | GetMouseViews | (Ereditato da GridControl)
Metodo protetto | GetSelectedObjects | (Ereditato da GridControl)
Metodo protetto | GetSelectionService | (Ereditato da GridControl)
Metodo pubblico | GetToolTipController | (Ereditato da EditorContainer)
Metodo protetto | GetUseDirectXPaint | (Ereditato da GridControl)
Metodo pubblico | GetViewAt | (Ereditato da GridControl)
Metodo protetto | HookOnLoaded | (Ereditato da EditorContainer)
Metodo protetto | InitializeDirectXProvider | (Ereditato da EditorContainer)
Metodo pubblico | InternalGetService | (Ereditato da GridControl)
Metodo protetto | IsControlPressed | (Ereditato da GridControl)
Metodo protetto | IsInputChar | (Ereditato da GridControl)
Metodo protetto | IsInputKey | (Ereditato da GridControl)
Metodo protetto | IsNeededKey | (Ereditato da GridControl)
Metodo protetto | IsPaintAnimateItems | (Ereditato da GridControl)
Metodo protetto | IsShiftPressed | (Ereditato da GridControl)
Metodo protetto | IsTabPressed | (Ereditato da GridControl)
Metodo protetto | IsValidDataSource | (Ereditato da GridControl)
Metodo pubblico | IsVisibleView | (Ereditato da GridControl)
Metodo pubblico | LockFireChanged | (Ereditato da GridControl)
Metodo protetto | NormalView | (Ereditato da GridControl)
Metodo protetto | OnBackgroundImageChanged | (Ereditato da GridControl)
Metodo protetto | OnBackgroundImageLayoutChanged | (Ereditato da GridControl)
Metodo protetto | OnBindingContextChanged | (Ereditato da GridControl)
Metodo protetto | OnClick | (Ereditato da GridControl)
Metodo protetto | OnContainerEnter | (Ereditato da GridControl)
Metodo protetto | OnContainerLeave | (Ereditato da GridControl)
Metodo protetto | OnContextMenuKey | (Ereditato da GridControl)
Metodo protetto | OnCreateControl | (Ereditato da GridControl)
Metodo protetto | OnCursorChanged | (Ereditato da GridControl)
Metodo protetto | OnDataSourceChanging | (Ereditato da GridControl)
Metodo protetto | OnDesignerHost_LoadComplete | (Ereditato da EditorContainer)
Metodo protetto | OnDesignerHost_TransactionClosed | (Ereditato da EditorContainer)
Metodo protetto | OnDirectXPaintDisabled | (Ereditato da EditorContainer)
Metodo protetto | OnDoubleClick | (Ereditato da GridControl)
Metodo protetto | OnDragDrop | (Ereditato da GridControl)
Metodo protetto | OnDragOver | (Ereditato da GridControl)
Metodo protetto | OnEmbeddedNavigator_SizeChanged | (Ereditato da GridControl)
Metodo protetto | OnEnabledChanged | (Ereditato da GridControl)
Metodo protetto | OnEndInit | (Ereditato da GridControl)
Metodo protetto | OnEnter | (Ereditato da GridControl)
Metodo protetto | OnFirstInit | (Ereditato da EditorContainer)
Metodo protetto | OnGotCapture | (Ereditato da EditorContainer)
Metodo protetto | OnGotFocus | (Ereditato da GridControl)
Metodo protetto | OnHandleCreated | (Ereditato da GridControl)
Metodo protetto | OnHandleDestroyed | (Ereditato da GridControl)
Metodo protetto | OnKeyDown | (Ereditato da GridControl)
Metodo protetto | OnKeyPress | (Ereditato da GridControl)
Metodo protetto | OnKeyUp | (Ereditato da GridControl)
Metodo protetto | OnLeave | (Ereditato da EditorContainer)
Metodo protetto | OnLoaded | (Ereditato da GridControl)
Metodo protetto | OnLookAndFeelChanged(LookAndFeelChangedEventArgs) | (Ereditato da GridControl)
Metodo protetto | OnLookAndFeelChanged(Object, EventArgs) | (Ereditato da EditorContainer)
Metodo protetto | OnLostCapture | (Ereditato da GridControl)
Metodo protetto | OnLostFocus | (Ereditato da GridControl)
Metodo protetto | OnMouseCaptureChanged | (Ereditato da GridControl)
Metodo protetto | OnMouseClick | (Ereditato da EditorContainer)
Metodo protetto | OnMouseDoubleClick | (Ereditato da EditorContainer)
Metodo protetto | OnMouseDown | (Ereditato da GridControl)
Metodo protetto | OnMouseEnter | (Ereditato da GridControl)
Metodo protetto | OnMouseHWheel | (Ereditato da EditorContainer)
Metodo protetto | OnMouseLeave | (Ereditato da GridControl)
Metodo protetto | OnMouseMove | (Ereditato da GridControl)
Metodo protetto | OnMouseUp | (Ereditato da GridControl)
Metodo protetto | OnMouseWheel | (Ereditato da EditorContainer)
Metodo protetto | OnMouseWheelCore | (Ereditato da GridControl)
Metodo protetto | OnPaint | Implementazione dell'override di onPaint. Grazie al catch delle eccezioni evita l'uscita della X rossa sul form e logga comunque call stack ed eccezione. (Sovrascrive GridControl.OnPaint(PaintEventArgs))
Metodo protetto | OnPaintBackground | (Ereditato da GridControl)
Metodo protetto | OnParentChanged | (Ereditato da GridControl)
Metodo protetto | OnResize | (Ereditato da GridControl)
Metodo protetto | OnRightToLeftChanged | (Ereditato da GridControl)
Metodo protetto | OnRightToLeftChanged(EventArgs) | (Ereditato da EditorContainer)
Metodo protetto | OnScaleControl | (Ereditato da GridControl)
Metodo protetto | OnSystemColorsChanged | (Ereditato da GridControl)
Metodo protetto | OnSystemColorsChanged(EventArgs) | (Ereditato da GridControl)
Metodo protetto | OnToolTipControllerDisposed | (Ereditato da EditorContainer)
Metodo protetto | OnValidated | (Ereditato da EditorContainer)
Metodo protetto | OnValidating | (Ereditato da GridControl)
Metodo protetto | OnVisibleChanged | (Ereditato da GridControl)
Metodo pubblico | Print | (Ereditato da GridControl)
Metodo pubblico | PrintDialog | (Ereditato da GridControl)
Metodo protetto | ProcessControlTab | (Ereditato da GridControl)
Metodo protetto | ProcessDialogKey | (Ereditato da GridControl)
Metodo protetto | ProcessDirectXPaint | (Ereditato da GridControl)
Metodo protetto | ProcessGridKeys | (Ereditato da GridControl)
Metodo protetto | RaiseDataSourceChanged | (Ereditato da GridControl)
Metodo protetto | RaiseEditorKeyDown | (Ereditato da GridControl)
Metodo protetto | RaiseEditorKeyPress | (Ereditato da EditorContainer)
Metodo protetto | RaiseEditorKeyUp | (Ereditato da EditorContainer)
Metodo protetto | RaiseLoad | (Ereditato da GridControl)
Metodo protetto | RaiseOnDefaultViewChanged | (Ereditato da GridControl)
Metodo protetto | RaiseOnFocusedViewChanged | (Ereditato da GridControl)
Metodo protetto | RaiseOnRegisterView | (Ereditato da GridControl)
Metodo protetto | RaiseOnRemoveView | (Ereditato da GridControl)
Metodo protetto | RaisePaintEx | (Ereditato da GridControl)
Metodo protetto | RaiseRequireHideEditor | (Ereditato da EditorContainer)
Metodo protetto | RaiseViewGridLoadComplete | (Ereditato da GridControl)
Metodo pubblico | RefreshDataSource | (Ereditato da GridControl)
Metodo protetto | RegisterAvailableViews | (Ereditato da GridControl)
Metodo protetto | RegisterAvailableViewsCore | (Ereditato da GridControl)
Metodo protetto | RegisterBorders | (Ereditato da GridControl)
Metodo protetto | RegisterView | (Ereditato da GridControl)
Metodo protetto | RemoveFromDefaultTooltipController | (Ereditato da EditorContainer)
Metodo protetto | RemoveHookOnLoaded | (Ereditato da EditorContainer)
Metodo pubblico | RemoveSplitContainer | (Ereditato da GridControl)
Metodo protetto | RemoveView(BaseView) | (Ereditato da GridControl)
Metodo protetto | RemoveView(BaseView, Boolean) | (Ereditato da GridControl)
Metodo pubblico | RenderToBitmap | (Ereditato da GridControl)
Metodo pubblico | ResetEditorsCache(RepositoryItem) | (Ereditato da EditorContainer)
Metodo pubblico | ResetEditorsCache(Type) | (Ereditato da EditorContainer)
Metodo protetto | ResetLookAndFeel | (Ereditato da EditorContainer)
Metodo protetto | ScaleControl | (Ereditato da EditorContainer)
Metodo protetto | SetComponentsSelected | (Ereditato da GridControl)
Metodo protetto | SetDataSourceCore | (Ereditato da GridControl)
Metodo protetto | SetDefaultView | (Ereditato da GridControl)
Metodo protetto | SetupLookUp | (Ereditato da GridControl)
Metodo protetto | SetUseDirectXPaint | (Ereditato da GridControl)
Metodo protetto | ShouldSerializeLookAndFeel | (Ereditato da EditorContainer)
Metodo pubblico | ShowPreview | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ShowPrintPreview | (Ereditato da GridControl)
Metodo pubblico | ShowRibbonPrintPreview | (Ereditato da GridControl)
Metodo protetto | StopScroller | (Ereditato da GridControl)
Metodo pubblico | SwitchPaintStyle | (Ereditato da GridControl)
Metodo pubblico | UnlockFireChanged | (Ereditato da GridControl)
Metodo protetto | UpdateNavigator | (Ereditato da GridControl)
Metodo protetto | UpdateRepositoryOwner | (Ereditato da GridControl)
Metodo protetto | UpdateViewCollection | (Ereditato da GridControl)
Metodo protetto | UpdateViewStyles | (Ereditato da GridControl)
Metodo protetto | ViewByPoint | (Ereditato da GridControl)
Metodo protetto | WndProc | (Ereditato da GridControl)
Metodo protetto | ZoomView | (Ereditato da GridControl)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | DataSourceChanged | (Ereditato da GridControl)
Evento pubblico | DefaultViewChanged | (Ereditato da GridControl)
Evento pubblico | EditorKeyDown | (Ereditato da EditorContainer)
Evento pubblico | EditorKeyPress | (Ereditato da EditorContainer)
Evento pubblico | EditorKeyUp | (Ereditato da EditorContainer)
Evento pubblico | FocusedViewChanged | (Ereditato da GridControl)
Evento pubblico | KeyboardFocusViewChanged | Obsoleto. (Ereditato da GridControl)
Evento pubblico | Load | (Ereditato da GridControl)
Evento pubblico | Paint | (Ereditato da GridControl)
Evento pubblico | PaintEx | (Ereditato da GridControl)
Evento pubblico | ProcessGridKey | (Ereditato da GridControl)
Evento pubblico | ViewRegistered | (Ereditato da GridControl)
Evento pubblico | ViewRemoved | (Ereditato da GridControl)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | fInitializing | (Ereditato da EditorContainer)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore MyAnagrViewGridControl

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public MyAnagrViewGridControl()
Public Sub New
public:
MyAnagrViewGridControl()
new : unit -> MyAnagrViewGridControl
Vedi anche

Documentazione

Classe MyAnagrViewGridControl
Namespace DedNet.Controls


Proprietà di MyAnagrViewGridControl

Il tipo MyAnagrViewGridControl espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà protetta | AllowLayoutEvent | (Ereditato da GridControl)
Proprietà pubblica | AllowRestoreSelectionAndFocusedRow | (Ereditato da GridControl)
Proprietà protetta | AllowScaleOnLoad | (Ereditato da EditorContainer)
Proprietà pubblica | AllowTouchGestures | (Ereditato da EditorContainer)
Proprietà pubblica | AvailableViews | (Ereditato da GridControl)
Proprietà pubblica | BackColor | (Ereditato da GridControl)
Proprietà pubblica | BindingContext | (Ereditato da GridControl)
Proprietà pubblica | ContextMenuStrip | (Ereditato da GridControl)
Proprietà pubblica | Controls | (Ereditato da GridControl)
Proprietà pubblica | Cursor | (Ereditato da GridControl)
Proprietà pubblica | DataMember | (Ereditato da GridControl)
Proprietà pubblica | DataSource | (Ereditato da GridControl)
Proprietà protetta | DefaultSize | (Ereditato da GridControl)
Proprietà pubblica | DefaultView | (Ereditato da GridControl)
Proprietà protetta | DirectXProvider | (Ereditato da GridControl)
Proprietà protetta | DirectXScroller | (Ereditato da GridControl)
Proprietà pubblica | Dock | (Ereditato da GridControl)
Proprietà protetta | DragController | (Ereditato da GridControl)
Proprietà protetta | EditorHelper | (Ereditato da GridControl)
Proprietà pubblica | EmbeddedNavigator | (Ereditato da GridControl)
Proprietà protetta | EnableFirstPaintTrigger | (Ereditato da GridControl)
Proprietà protetta | ExceptionThrown | (Ereditato da GridControl)
Proprietà pubblica | ExternalRepository | (Ereditato da EditorContainer)
Proprietà protetta | FireOnLoadOnPaint | (Ereditato da GridControl)
Proprietà pubblica | FocusedView | (Ereditato da GridControl)
Proprietà pubblica | ForeColor | (Ereditato da EditorContainer)
Proprietà pubblica | FormsUseDefaultLookAndFeel | (Ereditato da GridControl)
Proprietà pubblica | GridDisposing | (Ereditato da GridControl)
Proprietà pubblica | IsAttachedToSearchControl | (Ereditato da GridControl)
Proprietà pubblica | IsDesignMode | (Ereditato da EditorContainer)
Proprietà pubblica | IsFocused | (Ereditato da GridControl)
Proprietà protetta | IsInitialized | (Ereditato da EditorContainer)
Proprietà protetta | IsInPrintMessage | (Ereditato da GridControl)
Proprietà pubblica | IsLoaded | (Ereditato da GridControl)
Proprietà pubblica | IsLoading | (Ereditato da EditorContainer)
Proprietà protetta | IsLockUpdate | (Ereditato da GridControl)
Proprietà protetta | IsPrinterExist | (Ereditato da GridControl)
Proprietà pubblica | IsPrinting | (Ereditato da GridControl)
Proprietà pubblica | IsPrintingAvailable | (Ereditato da GridControl)
Proprietà protetta | IsPrintWrapperValid | (Ereditato da GridControl)
Proprietà protetta | IsRightToLeft | (Ereditato da GridControl)
Proprietà pubblica | IsSplitGrid | (Ereditato da GridControl)
Proprietà pubblica | KeyboardFocusView | Obsoleto. (Ereditato da GridControl)
Proprietà pubblica | LevelTree | (Ereditato da GridControl)
Proprietà pubblica | LookAndFeel | (Ereditato da EditorContainer)
Proprietà protetta | LookAndFeelIgnoreChildren | (Ereditato da EditorContainer)
Proprietà protetta | LookUpOwner | (Ereditato da GridControl)
Proprietà pubblica | MainView | (Ereditato da GridControl)
Proprietà pubblica | MenuManager | (Ereditato da EditorContainer)
Proprietà protetta | MouseCaptureOwner | (Ereditato da GridControl)
Proprietà protetta | NavigatableHelper | (Ereditato da GridControl)
Proprietà protetta | NavView | (Ereditato da GridControl)
Proprietà protetta | Printer | (Ereditato da GridControl)
Proprietà protetta | PrintWrapper | (Ereditato da GridControl)
Proprietà pubblica | RepositoryItems | (Ereditato da EditorContainer)
Proprietà protetta | ScaleDPI | (Ereditato da EditorContainer)
Proprietà pubblica | ScaleFactor | (Ereditato da EditorContainer)
Proprietà protetta | ScaleHelper | (Ereditato da EditorContainer)
Proprietà protetta | Scroller | (Ereditato da GridControl)
Proprietà pubblica | ServerMode | Obsoleto. (Ereditato da GridControl)
Proprietà pubblica | ShowOnlyPredefinedDetails | (Ereditato da GridControl)
Proprietà protetta | SplitContainer | (Ereditato da GridControl)
Proprietà pubblica | Text | (Ereditato da EditorContainer)
Proprietà pubblica | ToolTipController | (Ereditato da EditorContainer)
Proprietà protetta | TouchClient | (Ereditato da GridControl)
Proprietà pubblica | UseDirectXPaint | (Ereditato da GridControl)
Proprietà protetta | UseDirectXPaintCore | (Ereditato da GridControl)
Proprietà pubblica | UseDisabledStatePainter | (Ereditato da GridControl)
Proprietà pubblica | UseEmbeddedNavigator | (Ereditato da GridControl)
Proprietà pubblica | ViewCollection | (Ereditato da GridControl)
Proprietà protetta | ViewRepository | (Ereditato da GridControl)
Proprietà pubblica | Views | (Ereditato da GridControl)
Torna su
Vedi anche

Documentazione

Classe MyAnagrViewGridControl
Namespace DedNet.Controls


Metodi di MyAnagrViewGridControl

Il tipo MyAnagrViewGridControl espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AccessibleNotifyClients(AccessibleEvents, BaseAccessible) | (Ereditato da GridControl)
Metodo pubblico | AccessibleNotifyClients(AccessibleEvents, Int32) | (Ereditato da GridControl)
Metodo protetto | ActivateDataSource | (Ereditato da GridControl)
Metodo protetto | AddToDefaultTooltipController | (Ereditato da EditorContainer)
Metodo pubblico | BeginInit | (Ereditato da GridControl)
Metodo pubblico | BeginUpdate | (Ereditato da GridControl)
Metodo protetto | CancelUpdate | (Ereditato da GridControl)
Metodo protetto | CanHandleTouchGestures | (Ereditato da EditorContainer)
Metodo protetto | CheckMousePos | (Ereditato da GridControl)
Metodo protetto | CheckNeedScale | (Ereditato da EditorContainer)
Metodo protetto | CheckPrintWrapper | (Ereditato da GridControl)
Metodo protetto | CheckProcessMsg | (Ereditato da GridControl)
Metodo protetto | CheckRightToLeft | (Ereditato da EditorContainer)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da GridControl)
Metodo protetto | CreateComponentPrinter | (Ereditato da GridControl)
Metodo protetto | CreateDefaultView | (Ereditato da GridControl)
Metodo protetto | CreateEmbeddedNavigator | (Ereditato da GridControl)
Metodo pubblico | CreateGraphicsCache | (Ereditato da GridControl)
Metodo protetto | CreateHelper | (Ereditato da GridControl)
Metodo protetto | CreateInternalRepository | (Ereditato da EditorContainer)
Metodo protetto | CreateLookAndFeel | (Ereditato da EditorContainer)
Metodo protetto | CreateMainView | (Ereditato da GridControl)
Metodo pubblico | CreateSplitContainer | (Ereditato da GridControl)
Metodo pubblico | CreateView | (Ereditato da GridControl)
Metodo protetto | CreateViewPrintWrapper | (Ereditato da GridControl)
Metodo protetto | DestroyAvailableViews | (Ereditato da GridControl)
Metodo protetto | DestroyDirectXProvider | (Ereditato da EditorContainer)
Metodo protetto | DestroyPrinting | (Ereditato da GridControl)
Metodo protetto | Dispose | (Ereditato da GridControl)
Metodo protetto | DoDpiChange | (Ereditato da EditorContainer)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da GridControl)
Metodo pubblico | EndInit | (Ereditato da EditorContainer)
Metodo pubblico | EndUpdate | (Ereditato da GridControl)
Metodo protetto | EndUpdate(Boolean) | (Ereditato da GridControl)
Metodo protetto | EnforceValidDataMember | (Ereditato da GridControl)
Metodo pubblico | ExportToCsv(Stream) | (Ereditato da GridControl)
Metodo pubblico | ExportToCsv(String) | (Ereditato da GridControl)
Metodo pubblico | ExportToCsv(Stream, CsvExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToCsv(String, CsvExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToDocx(Stream) | (Ereditato da GridControl)
Metodo pubblico | ExportToDocx(String) | (Ereditato da GridControl)
Metodo pubblico | ExportToDocx(Stream, DocxExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToDocx(String, DocxExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToExcelOld | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToHtml(Stream) | (Ereditato da GridControl)
Metodo pubblico | ExportToHtml(String) | (Ereditato da GridControl)
Metodo pubblico | ExportToHtml(Stream, HtmlExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToHtml(String, HtmlExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToHtml(String, String) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToHtml(Stream, String, String, Boolean) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToHtml(String, String, String, Boolean) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToHtmlOld | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToMht(String) | (Ereditato da GridControl)
Metodo pubblico | ExportToMht(Stream, MhtExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToMht(String, MhtExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToMht(String, String) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToMht(Stream, String, String, Boolean) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToMht(String, String, String, Boolean) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToPdf(Stream) | (Ereditato da GridControl)
Metodo pubblico | ExportToPdf(String) | (Ereditato da GridControl)
Metodo pubblico | ExportToRtf(Stream) | (Ereditato da GridControl)
Metodo pubblico | ExportToRtf(String) | (Ereditato da GridControl)
Metodo pubblico | ExportToRtf(Stream, RtfExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToRtf(String, RtfExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToText(Stream) | (Ereditato da GridControl)
Metodo pubblico | ExportToText(String) | (Ereditato da GridControl)
Metodo pubblico | ExportToText(Stream, TextExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToText(Stream, String) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToText(String, TextExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToText(String, String) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToText(Stream, String, Boolean) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToText(String, String, Boolean) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToText(Stream, String, Boolean, Encoding) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToText(String, String, Boolean, Encoding) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToTextOld | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToXls(Stream) | (Ereditato da GridControl)
Metodo pubblico | ExportToXls(String) | (Ereditato da GridControl)
Metodo pubblico | ExportToXls(Stream, XlsExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToXls(Stream, Boolean) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToXls(String, XlsExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToXls(String, Boolean) | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ExportToXlsx(Stream) | (Ereditato da GridControl)
Metodo pubblico | ExportToXlsx(String) | (Ereditato da GridControl)
Metodo pubblico | ExportToXlsx(Stream, XlsxExportOptions) | (Ereditato da GridControl)
Metodo pubblico | ExportToXlsx(String, XlsxExportOptions) | (Ereditato da GridControl)
Metodo pubblico | FireChanged | (Ereditato da GridControl)
Metodo protetto | FireChanged(Object) | (Ereditato da GridControl)
Metodo protetto | FocusViewByMouse | (Ereditato da GridControl)
Metodo pubblico | ForceInitialize | (Ereditato da GridControl)
Metodo protetto | ForceViewInitialize | (Ereditato da GridControl)
Metodo protetto | GetAccessibilityObjectById | (Ereditato da GridControl)
Metodo protetto | GetComponentSelected | (Ereditato da GridControl)
Metodo protetto | GetDirectXDeviceBackColor | (Ereditato da GridControl)
Metodo protetto | GetDirectXProvider | (Ereditato da EditorContainer)
Metodo protetto | GetMouseViews | (Ereditato da GridControl)
Metodo protetto | GetSelectedObjects | (Ereditato da GridControl)
Metodo protetto | GetSelectionService | (Ereditato da GridControl)
Metodo pubblico | GetToolTipController | (Ereditato da EditorContainer)
Metodo protetto | GetUseDirectXPaint | (Ereditato da GridControl)
Metodo pubblico | GetViewAt | (Ereditato da GridControl)
Metodo protetto | HookOnLoaded | (Ereditato da EditorContainer)
Metodo protetto | InitializeDirectXProvider | (Ereditato da EditorContainer)
Metodo pubblico | InternalGetService | (Ereditato da GridControl)
Metodo protetto | IsControlPressed | (Ereditato da GridControl)
Metodo protetto | IsInputChar | (Ereditato da GridControl)
Metodo protetto | IsInputKey | (Ereditato da GridControl)
Metodo protetto | IsNeededKey | (Ereditato da GridControl)
Metodo protetto | IsPaintAnimateItems | (Ereditato da GridControl)
Metodo protetto | IsShiftPressed | (Ereditato da GridControl)
Metodo protetto | IsTabPressed | (Ereditato da GridControl)
Metodo protetto | IsValidDataSource | (Ereditato da GridControl)
Metodo pubblico | IsVisibleView | (Ereditato da GridControl)
Metodo pubblico | LockFireChanged | (Ereditato da GridControl)
Metodo protetto | NormalView | (Ereditato da GridControl)
Metodo protetto | OnBackgroundImageChanged | (Ereditato da GridControl)
Metodo protetto | OnBackgroundImageLayoutChanged | (Ereditato da GridControl)
Metodo protetto | OnBindingContextChanged | (Ereditato da GridControl)
Metodo protetto | OnClick | (Ereditato da GridControl)
Metodo protetto | OnContainerEnter | (Ereditato da GridControl)
Metodo protetto | OnContainerLeave | (Ereditato da GridControl)
Metodo protetto | OnContextMenuKey | (Ereditato da GridControl)
Metodo protetto | OnCreateControl | (Ereditato da GridControl)
Metodo protetto | OnCursorChanged | (Ereditato da GridControl)
Metodo protetto | OnDataSourceChanging | (Ereditato da GridControl)
Metodo protetto | OnDesignerHost_LoadComplete | (Ereditato da EditorContainer)
Metodo protetto | OnDesignerHost_TransactionClosed | (Ereditato da EditorContainer)
Metodo protetto | OnDirectXPaintDisabled | (Ereditato da EditorContainer)
Metodo protetto | OnDoubleClick | (Ereditato da GridControl)
Metodo protetto | OnDragDrop | (Ereditato da GridControl)
Metodo protetto | OnDragOver | (Ereditato da GridControl)
Metodo protetto | OnEmbeddedNavigator_SizeChanged | (Ereditato da GridControl)
Metodo protetto | OnEnabledChanged | (Ereditato da GridControl)
Metodo protetto | OnEndInit | (Ereditato da GridControl)
Metodo protetto | OnEnter | (Ereditato da GridControl)
Metodo protetto | OnFirstInit | (Ereditato da EditorContainer)
Metodo protetto | OnGotCapture | (Ereditato da EditorContainer)
Metodo protetto | OnGotFocus | (Ereditato da GridControl)
Metodo protetto | OnHandleCreated | (Ereditato da GridControl)
Metodo protetto | OnHandleDestroyed | (Ereditato da GridControl)
Metodo protetto | OnKeyDown | (Ereditato da GridControl)
Metodo protetto | OnKeyPress | (Ereditato da GridControl)
Metodo protetto | OnKeyUp | (Ereditato da GridControl)
Metodo protetto | OnLeave | (Ereditato da EditorContainer)
Metodo protetto | OnLoaded | (Ereditato da GridControl)
Metodo protetto | OnLookAndFeelChanged(LookAndFeelChangedEventArgs) | (Ereditato da GridControl)
Metodo protetto | OnLookAndFeelChanged(Object, EventArgs) | (Ereditato da EditorContainer)
Metodo protetto | OnLostCapture | (Ereditato da GridControl)
Metodo protetto | OnLostFocus | (Ereditato da GridControl)
Metodo protetto | OnMouseCaptureChanged | (Ereditato da GridControl)
Metodo protetto | OnMouseClick | (Ereditato da EditorContainer)
Metodo protetto | OnMouseDoubleClick | (Ereditato da EditorContainer)
Metodo protetto | OnMouseDown | (Ereditato da GridControl)
Metodo protetto | OnMouseEnter | (Ereditato da GridControl)
Metodo protetto | OnMouseHWheel | (Ereditato da EditorContainer)
Metodo protetto | OnMouseLeave | (Ereditato da GridControl)
Metodo protetto | OnMouseMove | (Ereditato da GridControl)
Metodo protetto | OnMouseUp | (Ereditato da GridControl)
Metodo protetto | OnMouseWheel | (Ereditato da EditorContainer)
Metodo protetto | OnMouseWheelCore | (Ereditato da GridControl)
Metodo protetto | OnPaint | Implementazione dell'override di onPaint. Grazie al catch delle eccezioni evita l'uscita della X rossa sul form e logga comunque call stack ed eccezione. (Sovrascrive GridControl.OnPaint(PaintEventArgs))
Metodo protetto | OnPaintBackground | (Ereditato da GridControl)
Metodo protetto | OnParentChanged | (Ereditato da GridControl)
Metodo protetto | OnResize | (Ereditato da GridControl)
Metodo protetto | OnRightToLeftChanged | (Ereditato da GridControl)
Metodo protetto | OnRightToLeftChanged(EventArgs) | (Ereditato da EditorContainer)
Metodo protetto | OnScaleControl | (Ereditato da GridControl)
Metodo protetto | OnSystemColorsChanged | (Ereditato da GridControl)
Metodo protetto | OnSystemColorsChanged(EventArgs) | (Ereditato da GridControl)
Metodo protetto | OnToolTipControllerDisposed | (Ereditato da EditorContainer)
Metodo protetto | OnValidated | (Ereditato da EditorContainer)
Metodo protetto | OnValidating | (Ereditato da GridControl)
Metodo protetto | OnVisibleChanged | (Ereditato da GridControl)
Metodo pubblico | Print | (Ereditato da GridControl)
Metodo pubblico | PrintDialog | (Ereditato da GridControl)
Metodo protetto | ProcessControlTab | (Ereditato da GridControl)
Metodo protetto | ProcessDialogKey | (Ereditato da GridControl)
Metodo protetto | ProcessDirectXPaint | (Ereditato da GridControl)
Metodo protetto | ProcessGridKeys | (Ereditato da GridControl)
Metodo protetto | RaiseDataSourceChanged | (Ereditato da GridControl)
Metodo protetto | RaiseEditorKeyDown | (Ereditato da GridControl)
Metodo protetto | RaiseEditorKeyPress | (Ereditato da EditorContainer)
Metodo protetto | RaiseEditorKeyUp | (Ereditato da EditorContainer)
Metodo protetto | RaiseLoad | (Ereditato da GridControl)
Metodo protetto | RaiseOnDefaultViewChanged | (Ereditato da GridControl)
Metodo protetto | RaiseOnFocusedViewChanged | (Ereditato da GridControl)
Metodo protetto | RaiseOnRegisterView | (Ereditato da GridControl)
Metodo protetto | RaiseOnRemoveView | (Ereditato da GridControl)
Metodo protetto | RaisePaintEx | (Ereditato da GridControl)
Metodo protetto | RaiseRequireHideEditor | (Ereditato da EditorContainer)
Metodo protetto | RaiseViewGridLoadComplete | (Ereditato da GridControl)
Metodo pubblico | RefreshDataSource | (Ereditato da GridControl)
Metodo protetto | RegisterAvailableViews | (Ereditato da GridControl)
Metodo protetto | RegisterAvailableViewsCore | (Ereditato da GridControl)
Metodo protetto | RegisterBorders | (Ereditato da GridControl)
Metodo protetto | RegisterView | (Ereditato da GridControl)
Metodo protetto | RemoveFromDefaultTooltipController | (Ereditato da EditorContainer)
Metodo protetto | RemoveHookOnLoaded | (Ereditato da EditorContainer)
Metodo pubblico | RemoveSplitContainer | (Ereditato da GridControl)
Metodo protetto | RemoveView(BaseView) | (Ereditato da GridControl)
Metodo protetto | RemoveView(BaseView, Boolean) | (Ereditato da GridControl)
Metodo pubblico | RenderToBitmap | (Ereditato da GridControl)
Metodo pubblico | ResetEditorsCache(RepositoryItem) | (Ereditato da EditorContainer)
Metodo pubblico | ResetEditorsCache(Type) | (Ereditato da EditorContainer)
Metodo protetto | ResetLookAndFeel | (Ereditato da EditorContainer)
Metodo protetto | ScaleControl | (Ereditato da EditorContainer)
Metodo protetto | SetComponentsSelected | (Ereditato da GridControl)
Metodo protetto | SetDataSourceCore | (Ereditato da GridControl)
Metodo protetto | SetDefaultView | (Ereditato da GridControl)
Metodo protetto | SetupLookUp | (Ereditato da GridControl)
Metodo protetto | SetUseDirectXPaint | (Ereditato da GridControl)
Metodo protetto | ShouldSerializeLookAndFeel | (Ereditato da EditorContainer)
Metodo pubblico | ShowPreview | Obsoleto. (Ereditato da GridControl)
Metodo pubblico | ShowPrintPreview | (Ereditato da GridControl)
Metodo pubblico | ShowRibbonPrintPreview | (Ereditato da GridControl)
Metodo protetto | StopScroller | (Ereditato da GridControl)
Metodo pubblico | SwitchPaintStyle | (Ereditato da GridControl)
Metodo pubblico | UnlockFireChanged | (Ereditato da GridControl)
Metodo protetto | UpdateNavigator | (Ereditato da GridControl)
Metodo protetto | UpdateRepositoryOwner | (Ereditato da GridControl)
Metodo protetto | UpdateViewCollection | (Ereditato da GridControl)
Metodo protetto | UpdateViewStyles | (Ereditato da GridControl)
Metodo protetto | ViewByPoint | (Ereditato da GridControl)
Metodo protetto | WndProc | (Ereditato da GridControl)
Metodo protetto | ZoomView | (Ereditato da GridControl)
Torna su
Vedi anche

Documentazione

Classe MyAnagrViewGridControl
Namespace DedNet.Controls


Metodo MyAnagrViewGridControl.OnPaint

Metodo MyAnagrViewGridControlOnPaint
Implementazione dell'override di onPaint. Grazie al catch delle eccezioni evita l'uscita della X rossa sul form e logga comunque call stack ed eccezione.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void OnPaint(
    PaintEventArgs e
)
Protected Overrides Sub OnPaint (
    e As PaintEventArgs
)
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override
abstract OnPaint :
        e : PaintEventArgs -> unit
override OnPaint :
        e : PaintEventArgs -> unit

Parametri

e PaintEventArgs
Vedi anche

Documentazione

Classe MyAnagrViewGridControl
Namespace DedNet.Controls


Eventi di MyAnagrViewGridControl

Il tipo MyAnagrViewGridControl espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | DataSourceChanged | (Ereditato da GridControl)
Evento pubblico | DefaultViewChanged | (Ereditato da GridControl)
Evento pubblico | EditorKeyDown | (Ereditato da EditorContainer)
Evento pubblico | EditorKeyPress | (Ereditato da EditorContainer)
Evento pubblico | EditorKeyUp | (Ereditato da EditorContainer)
Evento pubblico | FocusedViewChanged | (Ereditato da GridControl)
Evento pubblico | KeyboardFocusViewChanged | Obsoleto. (Ereditato da GridControl)
Evento pubblico | Load | (Ereditato da GridControl)
Evento pubblico | Paint | (Ereditato da GridControl)
Evento pubblico | PaintEx | (Ereditato da GridControl)
Evento pubblico | ProcessGridKey | (Ereditato da GridControl)
Evento pubblico | ViewRegistered | (Ereditato da GridControl)
Evento pubblico | ViewRemoved | (Ereditato da GridControl)
Torna su
Vedi anche

Documentazione

Classe MyAnagrViewGridControl
Namespace DedNet.Controls


Campi di MyAnagrViewGridControl

Il tipo MyAnagrViewGridControl espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | fInitializing | (Ereditato da EditorContainer)
Torna su
Vedi anche

Documentazione

Classe MyAnagrViewGridControl
Namespace DedNet.Controls


Classe MyDataRow
Riga del datasource con tag anagrafica aggiuntivo.
Gerarchia di ereditarietà
SystemObject
System.DataDataRow
DedNet.ControlsMyDataRow

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class MyDataRow : DataRow
Public Class MyDataRow
    Inherits DataRow
public ref class MyDataRow : public DataRow
type MyDataRow =
    class
        inherit DataRow
    end

Il tipo MyDataRow espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo protetto | MyDataRow | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Tag | Tag della riga.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore MyDataRow
Costruttore unico.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal MyDataRow(
    DataRowBuilder builder
)
Protected Friend Sub New (
    builder As DataRowBuilder
)
protected public:
MyDataRow(
    DataRowBuilder^ builder
)
new :
        builder : DataRowBuilder -> MyDataRow

Parametri

builder DataRowBuilder
Oggetto builder.
Vedi anche

Documentazione

Classe MyDataRow
Namespace DedNet.Controls


Proprietà di MyDataRow

Il tipo MyDataRow espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Tag | Tag della riga.
Torna su
Vedi anche

Documentazione

Classe MyDataRow
Namespace DedNet.Controls


Proprietà MyDataRow.Tag

Proprietà MyDataRowTag
Tag della riga.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object Tag { get; set; }
Public Property Tag As Object
    Get
    Set
public:
property Object^ Tag {
    Object^ get ();
    void set (Object^ value);
}
member Tag : Object with get, set

Valore della proprietà

Object
Vedi anche

Documentazione

Classe MyDataRow
Namespace DedNet.Controls


Classe MyDataTable
Datasource da bindare alla griglia.
Gerarchia di ereditarietà
SystemObject
System.ComponentModelMarshalByValueComponent
System.DataDataTable
DedNet.ControlsMyDataTable

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class MyDataTable : DataTable
Public Class MyDataTable
    Inherits DataTable
public ref class MyDataTable : public DataTable
type MyDataTable =
    class
        inherit DataTable
    end

Il tipo MyDataTable espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | MyDataTable |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Item | Indexer della classe.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Add | Metodo di aggiunta di una riga.
Metodo pubblico | GetNewRow | Metodo che crea e ritorna una nuova riga.
Metodo protetto | GetRowType | Ritorna il tipo della riga. (Sovrascrive DataTableGetRowType)
Metodo protetto | NewRowFromBuilder | Crea e ritorna una nuova riga. (Sovrascrive DataTableNewRowFromBuilder(DataRowBuilder))
Metodo pubblico | Remove | Metodo di eliminazione di una riga.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore MyDataTable

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public MyDataTable()
Public Sub New
public:
MyDataTable()
new : unit -> MyDataTable
Vedi anche

Documentazione

Classe MyDataTable
Namespace DedNet.Controls


Proprietà di MyDataTable

Il tipo MyDataTable espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Item | Indexer della classe.
Torna su
Vedi anche

Documentazione

Classe MyDataTable
Namespace DedNet.Controls


Proprietà MyDataTable.Item

Proprietà MyDataTableItem
Indexer della classe.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public MyDataRow this[
    int idx
] { get; }
Public ReadOnly Default Property Item (
    idx As Integer
) As MyDataRow
    Get
public:
property MyDataRow^ default[int idx] {
    MyDataRow^ get (int idx);
}
member Item : MyDataRow with get

Parametri

idx Int32
Indice.

Valore della proprietà

MyDataRow
Vedi anche

Documentazione

Classe MyDataTable
Namespace DedNet.Controls


Metodi di MyDataTable

Il tipo MyDataTable espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Add | Metodo di aggiunta di una riga.
Metodo pubblico | GetNewRow | Metodo che crea e ritorna una nuova riga.
Metodo protetto | GetRowType | Ritorna il tipo della riga. (Sovrascrive DataTableGetRowType)
Metodo protetto | NewRowFromBuilder | Crea e ritorna una nuova riga. (Sovrascrive DataTableNewRowFromBuilder(DataRowBuilder))
Metodo pubblico | Remove | Metodo di eliminazione di una riga.
Torna su
Vedi anche

Documentazione

Classe MyDataTable
Namespace DedNet.Controls


Metodo MyDataTable.Add

Metodo MyDataTableAdd
Metodo di aggiunta di una riga.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Add(
    MyDataRow row
)
Public Sub Add (
    row As MyDataRow
)
public:
void Add(
    MyDataRow^ row
)
member Add :
        row : MyDataRow -> unit

Parametri

row MyDataRow
Vedi anche

Documentazione

Classe MyDataTable
Namespace DedNet.Controls


Metodo MyDataTable.GetNewRow

Metodo MyDataTableGetNewRow
Metodo che crea e ritorna una nuova riga.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public MyDataRow GetNewRow()
Public Function GetNewRow As MyDataRow
public:
MyDataRow^ GetNewRow()
member GetNewRow : unit -> MyDataRow

Valore di ritorno

MyDataRow
Vedi anche

Documentazione

Classe MyDataTable
Namespace DedNet.Controls


Metodo MyDataTable.GetRowType

Metodo MyDataTableGetRowType
Ritorna il tipo della riga.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override Type GetRowType()
Protected Overrides Function GetRowType As Type
protected:
virtual Type^ GetRowType() override
abstract GetRowType : unit -> Type
override GetRowType : unit -> Type

Valore di ritorno

Type
Vedi anche

Documentazione

Classe MyDataTable
Namespace DedNet.Controls


Metodo MyDataTable.NewRowFromBuilder

Metodo MyDataTableNewRowFromBuilder
Crea e ritorna una nuova riga.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DataRow NewRowFromBuilder(
    DataRowBuilder builder
)
Protected Overrides Function NewRowFromBuilder (
    builder As DataRowBuilder
) As DataRow
protected:
virtual DataRow^ NewRowFromBuilder(
    DataRowBuilder^ builder
) override
abstract NewRowFromBuilder :
        builder : DataRowBuilder -> DataRow
override NewRowFromBuilder :
        builder : DataRowBuilder -> DataRow

Parametri

builder DataRowBuilder

Valore di ritorno

DataRow
Vedi anche

Documentazione

Classe MyDataTable
Namespace DedNet.Controls


Metodo MyDataTable.Remove

Metodo MyDataTableRemove
Metodo di eliminazione di una riga.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Remove(
    MyDataRow row
)
Public Sub Remove (
    row As MyDataRow
)
public:
void Remove(
    MyDataRow^ row
)
member Remove :
        row : MyDataRow -> unit

Parametri

row MyDataRow
Vedi anche

Documentazione

Classe MyDataTable
Namespace DedNet.Controls


Classe MyTreeList
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
EditorContainer
TreeList
DedNet.ControlsMyTreeList

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class MyTreeList : TreeList
Public Class MyTreeList
    Inherits TreeList
public ref class MyTreeList : public TreeList
type MyTreeList =
    class
        inherit TreeList
    end

Il tipo MyTreeList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | MyTreeList |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | ActiveEditor | (Ereditato da TreeList)
Proprietà pubblica | ActiveFilter | (Ereditato da TreeList)
Proprietà pubblica | ActiveFilterCriteria | (Ereditato da TreeList)
Proprietà pubblica | ActiveFilterEnabled | (Ereditato da TreeList)
Proprietà pubblica | ActiveFilterInfo | (Ereditato da TreeList)
Proprietà pubblica | ActiveFilterString | (Ereditato da TreeList)
Proprietà protetta | ActualAutoNodeHeight | (Ereditato da TreeList)
Proprietà protetta | ActualFilterCriteria | (Ereditato da TreeList)
Proprietà protetta | ActualShowBands | (Ereditato da TreeList)
Proprietà pubblica | AllNodesCount | (Ereditato da TreeList)
Proprietà protetta | AllowAnimatedScrolling | (Ereditato da TreeList)
Proprietà protetta | AllowAutoFilterConditionChange | (Ereditato da TreeList)
Proprietà protetta | AllowBandColumnsMultiRow | (Ereditato da TreeList)
Proprietà protetta | AllowExpandAnimation | (Ereditato da TreeList)
Proprietà protetta | AllowFiltering | (Ereditato da TreeList)
Proprietà protetta | AllowFilteringAfterLoadingData | (Ereditato da TreeList)
Proprietà protetta | AllowFilterNodes | (Ereditato da TreeList)
Proprietà protetta | AllowFindPanel | (Ereditato da TreeList)
Proprietà protetta | AllowPrintProgress | (Ereditato da TreeList)
Proprietà protetta | AllowScaleOnLoad | (Ereditato da EditorContainer)
Proprietà pubblica | AllowTouchGestures | (Ereditato da EditorContainer)
Proprietà protetta | AllowTouchScroll | (Ereditato da TreeList)
Proprietà protetta | AnnotationManager | (Ereditato da TreeList)
Proprietà pubblica | Appearance | (Ereditato da TreeList)
Proprietà pubblica | AppearancePrint | (Ereditato da TreeList)
Proprietà pubblica | AutoFillColumn | (Ereditato da TreeList)
Proprietà pubblica | AutoFillColumnName | (Ereditato da TreeList)
Proprietà pubblica | AutoFillFieldName | (Ereditato da TreeList)
Proprietà protetta | AutoFilterNode | (Ereditato da TreeList)
Proprietà pubblica | BackColor | (Ereditato da TreeList)
Proprietà pubblica | BandPanelRowHeight | (Ereditato da TreeList)
Proprietà pubblica | Bands | (Ereditato da TreeList)
Proprietà pubblica | BestFitVisibleOnly | (Ereditato da TreeList)
Proprietà pubblica | BorderStyle | (Ereditato da TreeList)
Proprietà protetta | CanExpandNodesOnIncrementalSearch | (Ereditato da TreeList)
Proprietà protetta | CanLoadNodes | (Ereditato da TreeList)
Proprietà protetta | CanShowBandsInCustomizationForm | (Ereditato da TreeList)
Proprietà pubblica | CanShowEditor | (Ereditato da TreeList)
Proprietà pubblica | CanShowRowFooterSummary | (Ereditato da TreeList)
Proprietà pubblica | Caption | (Ereditato da TreeList)
Proprietà pubblica | CaptionHeight | (Ereditato da TreeList)
Proprietà protetta | CheckBoxesStrategy | (Ereditato da TreeList)
Proprietà pubblica | CheckBoxFieldName | (Ereditato da TreeList)
Proprietà pubblica | ChildListFieldName | (Ereditato da TreeList)
Proprietà protetta | ClientHeight | (Ereditato da TreeList)
Proprietà protetta | ClientWidth | (Ereditato da TreeList)
Proprietà pubblica | ClipboardDataProvider | (Ereditato da TreeList)
Proprietà protetta | ClipboardPasteHelper | (Ereditato da TreeList)
Proprietà protetta | ClipboardPasteManager | (Ereditato da TreeList)
Proprietà protetta | CloneInfoList | (Ereditato da TreeList)
Proprietà pubblica | ColumnPanelRowHeight | (Ereditato da TreeList)
Proprietà pubblica | Columns | (Ereditato da TreeList)
Proprietà pubblica | ColumnsImageList | (Ereditato da TreeList)
Proprietà protetta | ContainerHelper | (Ereditato da TreeList)
Proprietà pubblica | ContextMenuStrip | (Ereditato da EditorContainer)
Proprietà protetta | CurrencyManager | (Ereditato da TreeList)
Proprietà pubblica | Cursor | (Ereditato da TreeList)
Proprietà pubblica | CustomizationForm | (Ereditato da TreeList)
Proprietà pubblica | CustomizationFormBounds | (Ereditato da TreeList)
Proprietà pubblica | CustomizationRowCount | Obsoleto. (Ereditato da TreeList)
Proprietà protetta | Data | (Ereditato da TreeList)
Proprietà pubblica | DataMember | (Ereditato da TreeList)
Proprietà pubblica | DataSource | (Ereditato da TreeList)
Proprietà protetta | DefaultSize | (Ereditato da TreeList)
Proprietà protetta | DirectXProvider | (Ereditato da TreeList)
Proprietà protetta | DirectXScroller | (Ereditato da TreeList)
Proprietà pubblica | DragExpandDelay | Obsoleto. (Ereditato da TreeList)
Proprietà pubblica | DragNodesMode | Obsoleto. (Ereditato da TreeList)
Proprietà protetta | DXAccessible | (Ereditato da TreeList)
Proprietà protetta | Editable | (Ereditato da TreeList)
Proprietà protetta | EditFormController | (Ereditato da TreeList)
Proprietà pubblica | EditingValue | (Ereditato da TreeList)
Proprietà protetta | EditorHelper | (Ereditato da EditorContainer)
Proprietà protetta | ElementsLookAndFeel | (Ereditato da TreeList)
Proprietà pubblica | EmptyTreeHtmlTemplate | (Ereditato da TreeList)
Proprietà protetta | EnableDirectXPaint | (Ereditato da TreeList)
Proprietà pubblica | EnableDynamicLoading | (Ereditato da TreeList)
Proprietà pubblica | EnableEnhancedScrolling | (Ereditato da TreeList)
Proprietà protetta | EnableEnhancedSorting | (Ereditato da TreeList)
Proprietà protetta | EnableFirstPaintTrigger | (Ereditato da EditorContainer)
Proprietà pubblica | EnableImprovedColumnSizing | (Ereditato da TreeList)
Proprietà protetta | ErrorInfo | (Ereditato da TreeList)
Proprietà protetta | ExcelFilteringProvider | (Ereditato da TreeList)
Proprietà protetta | ExceptionThrown | (Ereditato da TreeList)
Proprietà pubblica | ExternalRepository | (Ereditato da EditorContainer)
Proprietà protetta | ExtraFilter | (Ereditato da TreeList)
Proprietà protetta | ExtraFilterCriteria | (Ereditato da TreeList)
Proprietà protetta | ExtraFilterHightlightText | (Ereditato da TreeList)
Proprietà protetta | FilterColumnsProvider | (Ereditato da TreeList)
Proprietà protetta | FilterHelper | (Ereditato da TreeList)
Proprietà protetta | FilteringService | (Ereditato da TreeList)
Proprietà pubblica | FilterPanelText | (Ereditato da TreeList)
Proprietà protetta | FilterPopup | (Ereditato da TreeList)
Proprietà protetta | FindFilterCriteria | (Ereditato da TreeList)
Proprietà pubblica | FindFilterText | (Ereditato da TreeList)
Proprietà protetta | FindPanel | (Ereditato da TreeList)
Proprietà pubblica | FindPanelVisible | (Ereditato da TreeList)
Proprietà protetta | FireOnLoadOnPaint | (Ereditato da TreeList)
Proprietà pubblica | FixedLineWidth | (Ereditato da TreeList)
Proprietà protetta | FocusedCellIndex | (Ereditato da TreeList)
Proprietà pubblica | FocusedColumn | (Ereditato da TreeList)
Proprietà pubblica | FocusedNode | (Ereditato da TreeList)
Proprietà protetta | FocusedRow | (Ereditato da TreeList)
Proprietà protetta | FocusedRowIndex | (Ereditato da TreeList)
Proprietà pubblica | FocusedValue | (Ereditato da TreeList)
Proprietà pubblica | FooterPanelHeight | (Ereditato da TreeList)
Proprietà protetta | ForceLoadingPanel | (Ereditato da TreeList)
Proprietà pubblica | ForeColor | (Ereditato da EditorContainer)
Proprietà pubblica | FormatConditions | (Ereditato da TreeList)
Proprietà pubblica | FormatRules | (Ereditato da TreeList)
Proprietà pubblica | GroupButtonSize | Obsoleto. (Ereditato da TreeList)
Proprietà protetta | Handler | (Ereditato da TreeList)
Proprietà protetta | HasAccessible | (Ereditato da TreeList)
Proprietà protetta | HasAllColumnsFixedRight | (Ereditato da TreeList)
Proprietà protetta | HasBands | (Ereditato da TreeList)
Proprietà pubblica | HasColumnErrors | (Ereditato da TreeList)
Proprietà protetta | HasCustomNodeCellEdit | (Ereditato da TreeList)
Proprietà pubblica | HasFocus | (Ereditato da TreeList)
Proprietà protetta | HasHierarchicalColumn | (Ereditato da TreeList)
Proprietà protetta | HasTreeViewColumn | (Ereditato da TreeList)
Proprietà protetta | HeaderLayoutCalculator | (Ereditato da TreeList)
Proprietà protetta | HeaderWidthCalculator | (Ereditato da TreeList)
Proprietà pubblica | HierarchyColumn | (Ereditato da TreeList)
Proprietà pubblica | HierarchyColumnIndent | (Ereditato da TreeList)
Proprietà pubblica | HierarchyColumnName | (Ereditato da TreeList)
Proprietà pubblica | HierarchyFieldName | (Ereditato da TreeList)
Proprietà pubblica | HorzScrollStep | (Ereditato da TreeList)
Proprietà pubblica | HorzScrollVisibility | (Ereditato da TreeList)
Proprietà protetta | HtmlContext | (Ereditato da TreeList)
Proprietà pubblica | HtmlImages | (Ereditato da TreeList)
Proprietà protetta | HtmlObjectCache | (Ereditato da TreeList)
Proprietà pubblica | HtmlTemplates | (Ereditato da TreeList)
Proprietà protetta | IBasePrintableCreatesIntersectedBricks | (Ereditato da TreeList)
Proprietà pubblica | ImageIndexFieldName | (Ereditato da TreeList)
Proprietà protetta | IncrementalText | (Ereditato da TreeList)
Proprietà pubblica | IndicatorWidth | (Ereditato da TreeList)
Proprietà protetta | IsAllowBusyIndicator | (Ereditato da TreeList)
Proprietà protetta | IsAllowBusyPanel | (Ereditato da TreeList)
Proprietà protetta | IsAlt | (Ereditato da TreeList)
Proprietà protetta | IsAttachedToSearchControl | (Ereditato da TreeList)
Proprietà protetta | IsAutoWidth | (Ereditato da TreeList)
Proprietà protetta | IsCellSelect | (Ereditato da TreeList)
Proprietà protetta | IsClosingEditor | (Ereditato da TreeList)
Proprietà protetta | IsColumnHeaderAutoHeight | (Ereditato da TreeList)
Proprietà protetta | IsControl | (Ereditato da TreeList)
Proprietà protetta | IsDataReady | (Ereditato da TreeList)
Proprietà protetta | IsDeserializing | (Ereditato da TreeList)
Proprietà pubblica | IsDesignMode | (Ereditato da EditorContainer)
Proprietà protetta | IsDynamicLoadingAllowed | (Ereditato da TreeList)
Proprietà protetta | IsEditFormMode | (Ereditato da TreeList)
Proprietà protetta | IsFilterPopupActive | (Ereditato da TreeList)
Proprietà protetta | IsFindFilterActive | (Ereditato da TreeList)
Proprietà pubblica | IsFindPanelVisible | (Ereditato da TreeList)
Proprietà protetta | IsFocusedNodeChangedLocked | (Ereditato da TreeList)
Proprietà protetta | IsFocusedNodeDataModified | (Ereditato da TreeList)
Proprietà protetta | IsGroupDeleteOperation | (Ereditato da TreeList)
Proprietà protetta | IsHScrollBarVisible | (Ereditato da TreeList)
Proprietà protetta | IsInitialized | (Ereditato da EditorContainer)
Proprietà protetta | IsIniting | (Ereditato da TreeList)
Proprietà pubblica | IsLoading | (Ereditato da EditorContainer)
Proprietà protetta | IsLockDirectXRendering | (Ereditato da TreeList)
Proprietà protetta | IsLockExpandCollapse | (Ereditato da TreeList)
Proprietà protetta | IsLockUpdate | (Ereditato da TreeList)
Proprietà pubblica | IsLookUpMode | (Ereditato da TreeList)
Proprietà protetta | IsMultiSelect | (Ereditato da TreeList)
Proprietà protetta | IsNotificationInfoVisible | (Ereditato da TreeList)
Proprietà protetta | IsPainting | (Ereditato da TreeList)
Proprietà protetta | IsPixelScrolling | (Ereditato da TreeList)
Proprietà protetta | IsPopupEditFormVisible | (Ereditato da TreeList)
Proprietà pubblica | IsPrinting | (Ereditato da TreeList)
Proprietà pubblica | IsPrintingAvailable | (Ereditato da TreeList)
Proprietà protetta | IsRightToLeft | (Ereditato da TreeList)
Proprietà protetta | IsRowCountReady | (Ereditato da TreeList)
Proprietà protetta | IsScrollAnimationInProgress | (Ereditato da TreeList)
Proprietà protetta | IsSearchMode | (Ereditato da TreeList)
Proprietà protetta | IsSerializing | (Ereditato da TreeList)
Proprietà protetta | IsShift | (Ereditato da TreeList)
Proprietà protetta | IsSorted | (Ereditato da TreeList)
Proprietà protetta | IsUnboundLoad | (Ereditato da TreeList)
Proprietà pubblica | IsUnboundMode | (Ereditato da TreeList)
Proprietà protetta | IsUpdateSize | (Ereditato da TreeList)
Proprietà protetta | IsVirtualMode | (Ereditato da TreeList)
Proprietà protetta | IsVScrollBarVisible | (Ereditato da TreeList)
Proprietà pubblica | KeyFieldName | (Ereditato da TreeList)
Proprietà pubblica | LayoutVersion | Obsoleto. (Ereditato da TreeList)
Proprietà pubblica | LeftCoord | (Ereditato da TreeList)
Proprietà pubblica | LoadingPanelVisible | (Ereditato da TreeList)
Proprietà pubblica | LookAndFeel | (Ereditato da EditorContainer)
Proprietà protetta | LookAndFeelIgnoreChildren | (Ereditato da EditorContainer)
Proprietà protetta | LookUpDisplayColumn | (Ereditato da TreeList)
Proprietà protetta | LookUpOwner | (Ereditato da TreeList)
Proprietà pubblica | MenuManager | (Ereditato da EditorContainer)
Proprietà protetta | MinRowHeight | (Ereditato da TreeList)
Proprietà pubblica | MinWidth | (Ereditato da TreeList)
Proprietà protetta | MRUFilterPopup | (Ereditato da TreeList)
Proprietà pubblica | MRUFilters | (Ereditato da TreeList)
Proprietà protetta | NewItemNode | (Ereditato da TreeList)
Proprietà pubblica | NewItemRowText | (Ereditato da TreeList)
Proprietà pubblica | NodeHtmlTemplate | (Ereditato da TreeList)
Proprietà pubblica | Nodes | (Ereditato da TreeList)
Proprietà pubblica | NodesIterator | (Ereditato da TreeList)
Proprietà pubblica | NonColumnFilterCriteria | (Ereditato da TreeList)
Proprietà pubblica | NonColumnFilterString | (Ereditato da TreeList)
Proprietà protetta | NotificationInfo | (Ereditato da TreeList)
Proprietà protetta | OfficeScroller | (Ereditato da TreeList)
Proprietà pubblica | OptionsBehavior | (Ereditato da TreeList)
Proprietà pubblica | OptionsClipboard | (Ereditato da TreeList)
Proprietà pubblica | OptionsCustomization | (Ereditato da TreeList)
Proprietà pubblica | OptionsDragAndDrop | (Ereditato da TreeList)
Proprietà pubblica | OptionsEditForm | (Ereditato da TreeList)
Proprietà pubblica | OptionsFilter | (Ereditato da TreeList)
Proprietà pubblica | OptionsFind | (Ereditato da TreeList)
Proprietà pubblica | OptionsHtmlTemplate | (Ereditato da TreeList)
Proprietà pubblica | OptionsLayout | (Ereditato da TreeList)
Proprietà pubblica | OptionsMenu | (Ereditato da TreeList)
Proprietà pubblica | OptionsNavigation | (Ereditato da TreeList)
Proprietà pubblica | OptionsPrint | (Ereditato da TreeList)
Proprietà pubblica | OptionsScrollAnnotations | (Ereditato da TreeList)
Proprietà pubblica | OptionsSelection | (Ereditato da TreeList)
Proprietà pubblica | OptionsView | (Ereditato da TreeList)
Proprietà pubblica | Painter | (Ereditato da TreeList)
Proprietà pubblica | ParentFieldName | (Ereditato da TreeList)
Proprietà protetta | Position | (Ereditato da TreeList)
Proprietà protetta | PressedBand | (Ereditato da TreeList)
Proprietà protetta | PressedColumn | (Ereditato da TreeList)
Proprietà protetta | PressedNode | (Ereditato da TreeList)
Proprietà pubblica | PreviewFieldName | (Ereditato da TreeList)
Proprietà pubblica | PreviewIndent | (Ereditato da TreeList)
Proprietà pubblica | PreviewLineCount | (Ereditato da TreeList)
Proprietà protetta | Printer | (Ereditato da TreeList)
Proprietà protetta | PrinterCore | (Ereditato da TreeList)
Proprietà protetta | ProgressWindow | (Ereditato da TreeList)
Proprietà pubblica | RepositoryItems | (Ereditato da EditorContainer)
Proprietà pubblica | RootValue | (Ereditato da TreeList)
Proprietà protetta | RowCount | (Ereditato da TreeList)
Proprietà pubblica | RowHeight | (Ereditato da TreeList)
Proprietà protetta | ScaleDPI | (Ereditato da EditorContainer)
Proprietà pubblica | ScaleFactor | (Ereditato da EditorContainer)
Proprietà protetta | ScaleHelper | (Ereditato da EditorContainer)
Proprietà protetta | ScrollInfo | (Ereditato da TreeList)
Proprietà pubblica | SelectedHtmlText | (Ereditato da TreeList)
Proprietà pubblica | SelectImageList | (Ereditato da TreeList)
Proprietà pubblica | Selection | (Ereditato da TreeList)
Proprietà protetta | SelectionRange | (Ereditato da TreeList)
Proprietà pubblica | ShowButtonMode | (Ereditato da TreeList)
Proprietà protetta | ShowEditorAfterAnimatedScroll | (Ereditato da TreeList)
Proprietà protetta | ShowPreview | (Ereditato da TreeList)
Proprietà protetta | SizedBand | (Ereditato da TreeList)
Proprietà protetta | SizedColumn | (Ereditato da TreeList)
Proprietà protetta | SmartVisibility | (Ereditato da TreeList)
Proprietà pubblica | SortedColumnCount | (Ereditato da TreeList)
Proprietà pubblica | State | (Ereditato da TreeList)
Proprietà pubblica | StateImageList | (Ereditato da TreeList)
Proprietà pubblica | SyncCheckStateWithSourceOnChecking | (Ereditato da TreeList)
Proprietà pubblica | Text | (Ereditato da EditorContainer)
Proprietà pubblica | ToolTipController | (Ereditato da EditorContainer)
Proprietà protetta | TopVisibleNode | (Ereditato da TreeList)
Proprietà pubblica | TopVisibleNodeIndex | (Ereditato da TreeList)
Proprietà pubblica | TopVisibleNodePixel | (Ereditato da TreeList)
Proprietà pubblica | TreeLevelWidth | (Ereditato da TreeList)
Proprietà pubblica | TreeLineStyle | (Ereditato da TreeList)
Proprietà pubblica | TreeListDisposing | (Ereditato da TreeList)
Proprietà pubblica | TreeViewColumn | (Ereditato da TreeList)
Proprietà pubblica | TreeViewColumnName | (Ereditato da TreeList)
Proprietà pubblica | TreeViewFieldName | (Ereditato da TreeList)
Proprietà pubblica | UpdateTopVisibleNodeIndexOnCollapse | (Ereditato da TreeList)
Proprietà protetta | UseBandsAdvancedHorizontalNavigation | (Ereditato da TreeList)
Proprietà protetta | UseBandsAdvancedVerticalNavigation | (Ereditato da TreeList)
Proprietà pubblica | UseDirectXPaint | (Ereditato da TreeList)
Proprietà pubblica | UseDisabledStatePainter | (Ereditato da TreeList)
Proprietà protetta | UseStandardFilter | (Ereditato da TreeList)
Proprietà pubblica | VertScrollVisibility | (Ereditato da TreeList)
Proprietà pubblica | ViewInfo | (Ereditato da TreeList)
Proprietà pubblica | ViewStyle | (Ereditato da TreeList)
Proprietà protetta | VirtualDataHelper | (Ereditato da TreeList)
Proprietà pubblica | VisibleColumnCount | Obsoleto. (Ereditato da TreeList)
Proprietà pubblica | VisibleColumns | (Ereditato da TreeList)
Proprietà pubblica | VisibleNodesCount | (Ereditato da TreeList)
Proprietà protetta | WorkAsLookup | (Ereditato da TreeList)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AccessibleNotifyClients(AccessibleEvents, BaseAccessible) | (Ereditato da TreeList)
Metodo pubblico | AccessibleNotifyClients(AccessibleEvents, Int32, Int32) | (Ereditato da TreeList)
Metodo pubblico | AddFilter(CriteriaOperator) | (Ereditato da TreeList)
Metodo pubblico | AddFilter(String) | (Ereditato da TreeList)
Metodo protetto | AddToDefaultTooltipController | (Ereditato da EditorContainer)
Metodo protetto | AllowAutoFilterCondition | (Ereditato da TreeList)
Metodo protetto | AnimateKeyboardNavigation | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, TreeListNode) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, TreeListNode, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, TreeListNode, CheckState) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, CheckState) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, TreeListNode, CheckState, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, CheckState, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, TreeListNode, CheckState, NodeCheckBoxStyle, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, Int32, Int32, Int32) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, Int32, Int32, Int32, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, Int32, Int32, Int32, CheckState) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, Int32, Int32, Int32, CheckState, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, Int32, Int32, Int32, CheckState, NodeCheckBoxStyle, Object) | (Ereditato da TreeList)
Metodo protetto | ApplyFilter | (Ereditato da TreeList)
Metodo pubblico | ApplyFindFilter | (Ereditato da TreeList)
Metodo protetto | BeforeShowEditForm | (Ereditato da TreeList)
Metodo pubblico | BeginDelete | (Ereditato da TreeList)
Metodo protetto | BeginDragDrop | (Ereditato da TreeList)
Metodo protetto | BeginExpandCollapse | (Ereditato da TreeList)
Metodo pubblico | BeginInit | (Ereditato da EditorContainer)
Metodo protetto | BeginLockListChanged | (Ereditato da TreeList)
Metodo pubblico | BeginSelection | (Ereditato da TreeList)
Metodo pubblico | BeginSort | (Ereditato da TreeList)
Metodo pubblico | BeginUnboundLoad | (Ereditato da TreeList)
Metodo pubblico | BeginUpdate | (Ereditato da TreeList)
Metodo pubblico | BestFitColumns | (Ereditato da TreeList)
Metodo pubblico | BestFitColumns(Boolean) | (Ereditato da TreeList)
Metodo pubblico | BindCommand(Object, String, FuncObject) | (Ereditato da TreeList)
Metodo pubblico | BindCommand(ExpressionAction, Object, String, FuncObject) | (Ereditato da TreeList)
Metodo pubblico | BindCommand``1(ExpressionActionUMP, Object, String, FuncUMP) | (Ereditato da TreeList)
Metodo protetto | CalcActiveEditorBounds | (Ereditato da TreeList)
Metodo protetto | CalcColumnBestWidth | (Ereditato da TreeList)
Metodo pubblico | CalcHitInfo | (Ereditato da TreeList)
Metodo protetto | CalcHScrollRange | (Ereditato da TreeList)
Metodo protetto | CalcNodeAutoHeight | (Ereditato da TreeList)
Metodo protetto | CalcRowCount | (Ereditato da TreeList)
Metodo protetto | CalcScrollClientRect | (Ereditato da TreeList)
Metodo protetto | CalculateScrollBars | (Ereditato da TreeList)
Metodo protetto | CalculateVisibleRowsAreaHeight | (Ereditato da TreeList)
Metodo pubblico | CancelCurrentEdit | (Ereditato da TreeList)
Metodo protetto | CancelDirectXRendering | (Ereditato da TreeList)
Metodo protetto | CancelLockListChanged | (Ereditato da TreeList)
Metodo protetto | CancelSelection | (Ereditato da TreeList)
Metodo pubblico | CancelSort | (Ereditato da TreeList)
Metodo pubblico | CancelUpdate | (Ereditato da TreeList)
Metodo protetto | CanClearAllSorting | (Ereditato da TreeList)
Metodo protetto | CanCloneChildren | (Ereditato da TreeList)
Metodo protetto | CanFilterByColumnEdit | (Ereditato da TreeList)
Metodo pubblico | CanFilterColumn | (Ereditato da TreeList)
Metodo protetto | CanFindColumn | (Ereditato da TreeList)
Metodo protetto | CanFocusNode | (Ereditato da TreeList)
Metodo protetto | CanHandleTouchGestures | (Ereditato da EditorContainer)
Metodo protetto | CanIncrementalSearch | (Ereditato da TreeList)
Metodo pubblico | CanIndentNodes | (Ereditato da TreeList)
Metodo protetto | CanMove | (Ereditato da TreeList)
Metodo protetto | CanMoveBand | (Ereditato da TreeList)
Metodo protetto | CanMoveColumn | (Ereditato da TreeList)
Metodo pubblico | CanOutdentNodes | (Ereditato da TreeList)
Metodo protetto | CanResizeBand | (Ereditato da TreeList)
Metodo protetto | CanResizeColumn | (Ereditato da TreeList)
Metodo protetto | CanShowHScrollBar | (Ereditato da TreeList)
Metodo protetto | CanShowHScrollBarCore | (Ereditato da TreeList)
Metodo protetto | CanShowVScrollBar | (Ereditato da TreeList)
Metodo protetto | CanSortByColumnEdit | (Ereditato da TreeList)
Metodo pubblico | CanSortColumn | (Ereditato da TreeList)
Metodo protetto | CanStartTouchScrolling | (Ereditato da TreeList)
Metodo protetto | ChangeLeftCoord | (Ereditato da TreeList)
Metodo pubblico | CheckAll | (Ereditato da TreeList)
Metodo protetto | CheckAllowGestures | (Ereditato da TreeList)
Metodo protetto | CheckAllowNotifications | (Ereditato da TreeList)
Metodo protetto | CheckData | (Ereditato da TreeList)
Metodo protetto | CheckIncreaseVisibleRows | (Ereditato da TreeList)
Metodo protetto | CheckModifierKeys | (Ereditato da TreeList)
Metodo protetto | CheckNeedScale | (Ereditato da EditorContainer)
Metodo protetto | CheckRightToLeft | (Ereditato da EditorContainer)
Metodo protetto | CheckSearchMode | (Ereditato da TreeList)
Metodo protetto | CheckTopVisibleNodeAfterItemAdded | (Ereditato da TreeList)
Metodo protetto | CheckTopVisibleNodePixelValue | (Ereditato da TreeList)
Metodo pubblico | ClearColumnErrors | (Ereditato da TreeList)
Metodo pubblico | ClearColumnFilter | (Ereditato da TreeList)
Metodo protetto | ClearColumnFilterCore(String) | (Ereditato da TreeList)
Metodo protetto | ClearColumnFilterCore(TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | ClearColumnsFilter | (Ereditato da TreeList)
Metodo pubblico | ClearDocument | (Ereditato da TreeList)
Metodo pubblico | ClearFindFilter | (Ereditato da TreeList)
Metodo pubblico | ClearFocusedColumn | (Ereditato da TreeList)
Metodo pubblico | ClearNodes | (Ereditato da TreeList)
Metodo pubblico | ClearSelection | (Ereditato da TreeList)
Metodo pubblico | ClearSorting | (Ereditato da TreeList)
Metodo protetto | ClearVisibleIndicesCache | (Ereditato da TreeList)
Metodo pubblico | CloseEditForm | (Ereditato da TreeList)
Metodo pubblico | CloseEditor | (Ereditato da TreeList)
Metodo protetto | CloseEditor(Boolean) | (Ereditato da TreeList)
Metodo pubblico | CollapseAll | (Ereditato da TreeList)
Metodo protetto | CollapseAllCore | (Ereditato da TreeList)
Metodo pubblico | CollapseToLevel | (Ereditato da TreeList)
Metodo pubblico | ColumnsCustomization | (Ereditato da TreeList)
Metodo pubblico | ColumnsCustomization(Point) | (Ereditato da TreeList)
Metodo protetto | ControlRowSourceSelectedChanged | (Ereditato da TreeList)
Metodo protetto | ControlRowSourceVisibleChanged | (Ereditato da TreeList)
Metodo pubblico | ConvertFormatConditionToFormatRules | (Ereditato da TreeList)
Metodo pubblico | CopyNode(TreeListNode, TreeListNode, Boolean) | (Ereditato da TreeList)
Metodo pubblico | CopyNode(TreeListNode, TreeListNode, Boolean, Boolean) | (Ereditato da TreeList)
Metodo pubblico | CopyNode(TreeListNode, TreeListNode, Boolean, Int32) | (Ereditato da TreeList)
Metodo pubblico | CopyNode(TreeListNode, TreeListNode, Boolean, Boolean, Int32) | (Ereditato da TreeList)
Metodo protetto | CopyNodeCore | (Ereditato da TreeList)
Metodo pubblico | CopyNodes(IEnumerableTreeListNode, TreeListNode, Boolean, Int32) | (Ereditato da TreeList)
Metodo pubblico | CopyNodes(IEnumerableTreeListNode, TreeListNode, Boolean, Boolean, Int32) | (Ereditato da TreeList)
Metodo pubblico | CopyToClipboard | (Ereditato da TreeList)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da TreeList)
Metodo protetto | CreateAccessibleDataRow | (Ereditato da TreeList)
Metodo protetto | CreateAccessibleInstance | (Ereditato da TreeList)
Metodo protetto | CreateAllOptions | (Ereditato da TreeList)
Metodo protetto | CreateAnnotationManager | (Ereditato da TreeList)
Metodo protetto | CreateAppearances | (Ereditato da TreeList)
Metodo protetto | CreateAutoFilterCriterion | (Ereditato da TreeList)
Metodo protetto | CreateBands | (Ereditato da TreeList)
Metodo protetto | CreateCheckBoxesStrategy | (Ereditato da TreeList)
Metodo protetto | CreateCheckedListFilterPopup | (Ereditato da TreeList)
Metodo protetto | CreateColumn | (Ereditato da TreeList)
Metodo protetto | CreateColumnEditViewInfo | (Ereditato da TreeList)
Metodo protetto | CreateColumnFilterCriteriaByValue(TreeListColumn, Object) | (Ereditato da TreeList)
Metodo protetto | CreateColumnFilterCriteriaByValue(TreeListColumn, Object, Boolean) | (Ereditato da TreeList)
Metodo protetto | CreateColumnFilterPopup | (Ereditato da TreeList)
Metodo protetto | CreateColumns | (Ereditato da TreeList)
Metodo pubblico | CreateCustomization | Obsoleto. (Ereditato da TreeList)
Metodo protetto | CreateCustomizationForm | (Ereditato da TreeList)
Metodo protetto | CreateData | (Ereditato da TreeList)
Metodo protetto | CreateDataViewData | (Ereditato da TreeList)
Metodo protetto | CreateDateFilterPopup | (Ereditato da TreeList)
Metodo protetto | CreateDragNodesProvider | (Ereditato da TreeList)
Metodo protetto | CreateEditFormController | (Ereditato da TreeList)
Metodo protetto | CreateElementsLookAndFeel | (Ereditato da TreeList)
Metodo protetto | CreateExcelFilterPopup | (Ereditato da TreeList)
Metodo protetto | CreateFilterColumnCollection | (Ereditato da TreeList)
Metodo protetto | CreateFilterColumnRuleCollection | (Ereditato da TreeList)
Metodo protetto | CreateFilterColumnsProvider | (Ereditato da TreeList)
Metodo protetto | CreateFilterCriteriaBindingTarget | (Ereditato da TreeList)
Metodo protetto | CreateFilterEditorForm | (Ereditato da TreeList)
Metodo protetto | CreateFilterHelper | (Ereditato da TreeList)
Metodo protetto | CreateFindPanel | (Ereditato da TreeList)
Metodo protetto | CreateFindPanelCore | (Ereditato da TreeList)
Metodo pubblico | CreateGraphicsCache | (Ereditato da TreeList)
Metodo protetto | CreateHandler | (Ereditato da TreeList)
Metodo protetto | CreateHeaderLayoutCalculator | (Ereditato da TreeList)
Metodo protetto | CreateHeaderWidthCalculator | (Ereditato da TreeList)
Metodo protetto | CreateHelper | (Ereditato da TreeList)
Metodo protetto | CreateHierarchicalListData | (Ereditato da TreeList)
Metodo protetto | CreateHtmlContext | (Ereditato da TreeList)
Metodo protetto | CreateHyperlinkClickEventArgs | (Ereditato da TreeList)
Metodo protetto | CreateInternalRepository | (Ereditato da EditorContainer)
Metodo protetto | CreateListColumnFilterPopup | (Ereditato da TreeList)
Metodo protetto | CreateListData | (Ereditato da TreeList)
Metodo protetto | CreateLoadingAnimator | (Ereditato da TreeList)
Metodo protetto | CreateLoadingPanel | (Ereditato da TreeList)
Metodo protetto | CreateLookAndFeel | (Ereditato da EditorContainer)
Metodo protetto | CreateNewItemNode | (Ereditato da TreeList)
Metodo protetto | CreateNode(Int32, TreeListNodes) | (Ereditato da TreeList)
Metodo protetto | CreateNode(Int32, TreeListNodes, Object) | (Ereditato da TreeList)
Metodo protetto | CreateNodes | (Ereditato da TreeList)
Metodo protetto | CreateNodesComparer | (Ereditato da TreeList)
Metodo protetto | CreateNodesIterator | (Ereditato da TreeList)
Metodo protetto | CreateNotificationInfo | (Ereditato da TreeList)
Metodo protetto | CreateOfficeScroller | (Ereditato da TreeList)
Metodo protetto | CreateOptionsBehavior | (Ereditato da TreeList)
Metodo protetto | CreateOptionsClipboard | (Ereditato da TreeList)
Metodo protetto | CreateOptionsCustomization | (Ereditato da TreeList)
Metodo protetto | CreateOptionsDragAndDrop | (Ereditato da TreeList)
Metodo protetto | CreateOptionsEditForm | (Ereditato da TreeList)
Metodo protetto | CreateOptionsFilter | (Ereditato da TreeList)
Metodo protetto | CreateOptionsFind | (Ereditato da TreeList)
Metodo protetto | CreateOptionsHtmlTemplate | (Ereditato da TreeList)
Metodo protetto | CreateOptionsLayout | (Ereditato da TreeList)
Metodo protetto | CreateOptionsMenu | (Ereditato da TreeList)
Metodo protetto | CreateOptionsNavigation | (Ereditato da TreeList)
Metodo protetto | CreateOptionsPrint | (Ereditato da TreeList)
Metodo protetto | CreateOptionsScrollAnnotations | (Ereditato da TreeList)
Metodo protetto | CreateOptionsSelection | (Ereditato da TreeList)
Metodo protetto | CreateOptionsView | (Ereditato da TreeList)
Metodo protetto | CreatePainter | (Ereditato da TreeList)
Metodo protetto | CreatePrinter | (Ereditato da TreeList)
Metodo protetto | CreateProvider | (Ereditato da TreeList)
Metodo protetto | CreateScrollInfo | (Ereditato da TreeList)
Metodo protetto | CreateSelection | (Ereditato da TreeList)
Metodo protetto | CreateUnboundData | (Ereditato da TreeList)
Metodo protetto | CreateViewInfo | (Ereditato da TreeList)
Metodo protetto | CreateVirtualData | (Ereditato da TreeList)
Metodo protetto | CreateVirtualDataHelper | (Ereditato da TreeList)
Metodo protetto | CurrencyManager_ItemChanged | (Ereditato da TreeList)
Metodo protetto | CurrencyManager_PositionChanged | (Ereditato da TreeList)
Metodo protetto | DeferredLoadChildren | (Ereditato da TreeList)
Metodo protetto | DelayedInvalidate | (Ereditato da TreeList)
Metodo pubblico | DeleteNode | (Ereditato da TreeList)
Metodo pubblico | DeleteNodes | (Ereditato da TreeList)
Metodo pubblico | DeleteSelectedNodes | (Ereditato da TreeList)
Metodo pubblico | DestroyCustomization | (Ereditato da TreeList)
Metodo protetto | DestroyDirectXProvider | (Ereditato da EditorContainer)
Metodo protetto | DestroyFindPanel | (Ereditato da TreeList)
Metodo protetto | Dispose | (Ereditato da TreeList)
Metodo protetto | DoDataSourceChanged | (Ereditato da TreeList)
Metodo protetto | DoDpiChange | (Ereditato da EditorContainer)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da TreeList)
Metodo protetto | DoDragDrop | (Ereditato da TreeList)
Metodo pubblico | DoDragDropNode | (Ereditato da TreeList)
Metodo pubblico | DoDragDropNodes | (Ereditato da TreeList)
Metodo protetto | DoFilterNode | (Ereditato da TreeList)
Metodo protetto | DoForEachBand | (Ereditato da TreeList)
Metodo pubblico | DoIncrementalSearch | (Ereditato da TreeList)
Metodo protetto | DoShowTreeListMenu(TreeListMenu, TreeListHitTest) | (Ereditato da TreeList)
Metodo protetto | DoShowTreeListMenu(TreeListMenu, Control, Point) | (Ereditato da TreeList)
Metodo protetto | DoTopVisibleNodeChanged | (Ereditato da TreeList)
Metodo pubblico | EndCurrentEdit | (Ereditato da TreeList)
Metodo pubblico | EndCurrentEdit(Boolean) | (Ereditato da TreeList)
Metodo pubblico | EndDelete | (Ereditato da TreeList)
Metodo protetto | EndDragDrop | (Ereditato da TreeList)
Metodo protetto | EndEdit | (Ereditato da TreeList)
Metodo protetto | EndExpandCollapse | (Ereditato da TreeList)
Metodo pubblico | EndInit | (Ereditato da EditorContainer)
Metodo pubblico | EndSelection | (Ereditato da TreeList)
Metodo pubblico | EndSort | (Ereditato da TreeList)
Metodo pubblico | EndUnboundLoad | (Ereditato da TreeList)
Metodo pubblico | EndUpdate | (Ereditato da TreeList)
Metodo protetto | EnsureControlRowSource | (Ereditato da TreeList)
Metodo protetto | EnsureEditFormController | (Ereditato da TreeList)
Metodo protetto | EnsureFilteringClientDataBinding | (Ereditato da TreeList)
Metodo protetto | ExecutePrinterAction | (Ereditato da TreeList)
Metodo pubblico | ExpandAll | (Ereditato da TreeList)
Metodo protetto | ExpandAllCore | (Ereditato da TreeList)
Metodo protetto | ExpandToLast | (Ereditato da TreeList)
Metodo pubblico | ExpandToLevel | (Ereditato da TreeList)
Metodo protetto | ExpandToRoot | (Ereditato da TreeList)
Metodo protetto | Export(ExportTarget, Stream) | (Ereditato da TreeList)
Metodo protetto | Export(ExportTarget, String) | (Ereditato da TreeList)
Metodo protetto | Export(ExportTarget, Stream, ExportOptionsBase) | (Ereditato da TreeList)
Metodo protetto | Export(ExportTarget, String, ExportOptionsBase) | (Ereditato da TreeList)
Metodo pubblico | ExportToCsv(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToCsv(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToCsv(Stream, CsvExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToCsv(String, CsvExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToDocx(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToDocx(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToDocx(Stream, DocxExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToDocx(String, DocxExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToHtml(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToHtml(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToHtml(Stream, HtmlExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToHtml(String, HtmlExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToMht(Stream, MhtExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToMht(String, MhtExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToMht(String, String) | Obsoleto. (Ereditato da TreeList)
Metodo pubblico | ExportToMht(Stream, String, String, Boolean) | Obsoleto. (Ereditato da TreeList)
Metodo pubblico | ExportToMht(String, String, String, Boolean) | Obsoleto. (Ereditato da TreeList)
Metodo pubblico | ExportToPdf(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToPdf(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToPdf(Stream, PdfExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToPdf(String, PdfExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToRtf(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToRtf(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToText(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToText(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToText(Stream, TextExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToText(String, TextExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToXls(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToXls(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToXls(Stream, XlsExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToXls(String, XlsExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToXlsx(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToXlsx(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToXlsx(Stream, XlsxExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToXlsx(String, XlsxExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToXml(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToXml(String) | (Ereditato da TreeList)
Metodo protetto | ExportToXmlCore | (Ereditato da TreeList)
Metodo protetto | ExtractTemplateRootNode | (Ereditato da TreeList)
Metodo pubblico | FilterNodes | (Ereditato da TreeList)
Metodo pubblico | FilterNodes(TreeListNodes) | (Ereditato da TreeList)
Metodo protetto | FilterNodesCore | (Ereditato da TreeList)
Metodo pubblico | FindNode | (Ereditato da TreeList)
Metodo pubblico | FindNodeByFieldValue | (Ereditato da TreeList)
Metodo pubblico | FindNodeByID | (Ereditato da TreeList)
Metodo pubblico | FindNodeByKeyID | (Ereditato da TreeList)
Metodo protetto | FindNodeByParentID | (Ereditato da TreeList)
Metodo pubblico | FindNodes | (Ereditato da TreeList)
Metodo protetto | FindPanelNext | (Ereditato da TreeList)
Metodo protetto | FindPanelPrev | (Ereditato da TreeList)
Metodo pubblico | FireChanged | (Ereditato da TreeList)
Metodo protetto | FitColumns | (Ereditato da TreeList)
Metodo pubblico | FocusNewItemNode | (Ereditato da TreeList)
Metodo protetto | ForceCalcRowCount | (Ereditato da TreeList)
Metodo pubblico | ForceInitialize | (Ereditato da TreeList)
Metodo protetto | ForceSetTopVisibleNodeIndex | (Ereditato da TreeList)
Metodo pubblico | FullCollapse | Obsoleto. (Ereditato da TreeList)
Metodo pubblico | FullExpand | Obsoleto. (Ereditato da TreeList)
Metodo pubblico | FullExpandNode | Obsoleto. (Ereditato da TreeList)
Metodo protetto | GetAccessibilityObjectById | (Ereditato da TreeList)
Metodo protetto | GetAccessibleNodeCell | (Ereditato da TreeList)
Metodo protetto | GetActiveEditorHighAppearance | (Ereditato da TreeList)
Metodo protetto | GetActualAnimationType | (Ereditato da TreeList)
Metodo protetto | GetActualTreeListFilterMode | (Ereditato da TreeList)
Metodo pubblico | GetAllCheckedNodes | (Ereditato da TreeList)
Metodo protetto | GetAllowChangeBandParent | (Ereditato da TreeList)
Metodo protetto | GetAllowColumnFilterPopup | (Ereditato da TreeList)
Metodo protetto | GetAllowFilterEditor | (Ereditato da TreeList)
Metodo protetto | GetAllowFindColumn | (Ereditato da TreeList)
Metodo protetto | GetAllowFocus | (Ereditato da TreeList)
Metodo protetto | GetAllowHighlightFindResults | (Ereditato da TreeList)
Metodo protetto | GetAllowMRUFilterList | (Ereditato da TreeList)
Metodo protetto | GetAutoFilterRowColumnEdit | (Ereditato da TreeList)
Metodo pubblico | GetAutoFilterValue | (Ereditato da TreeList)
Metodo protetto | GetAutoNodeHeight | (Ereditato da TreeList)
Metodo protetto | GetBandRows | (Ereditato da TreeList)
Metodo protetto | GetBandRowsCore | (Ereditato da TreeList)
Metodo protetto | GetBandVisibleIndex | (Ereditato da TreeList)
Metodo protetto | GetCanShowEditor | (Ereditato da TreeList)
Metodo pubblico | GetColumnByColumnHandle | (Ereditato da TreeList)
Metodo pubblico | GetColumnByVisibleIndex | (Ereditato da TreeList)
Metodo protetto | GetColumnDefaultRepositoryItem | (Ereditato da TreeList)
Metodo protetto | GetColumnDefaultRepositoryItemForEditing | (Ereditato da TreeList)
Metodo protetto | GetColumnEdit | (Ereditato da TreeList)
Metodo protetto | GetColumnEditForEditing | (Ereditato da TreeList)
Metodo pubblico | GetColumnError(TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | GetColumnError(TreeListColumn, TreeListNode) | (Ereditato da TreeList)
Metodo pubblico | GetColumnErrorType(TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | GetColumnErrorType(TreeListColumn, TreeListNode) | (Ereditato da TreeList)
Metodo protetto | GetColumnFieldNameSort | (Ereditato da TreeList)
Metodo protetto | GetColumnFilterCriteria | (Ereditato da TreeList)
Metodo protetto | GetColumnFilterMode | (Ereditato da TreeList)
Metodo pubblico | GetColumnHeaderBestWidth | (Ereditato da TreeList)
Metodo protetto | GetColumnName | (Ereditato da TreeList)
Metodo protetto | GetCurrencyManager | (Ereditato da TreeList)
Metodo protetto | GetDataColumnInfo | (Ereditato da TreeList)
Metodo pubblico | GetDataRecordByNode | (Ereditato da TreeList)
Metodo pubblico | GetDataRow | (Ereditato da TreeList)
Metodo protetto | GetDirectXDeviceBackColor | (Ereditato da EditorContainer)
Metodo protetto | GetDirectXProvider | (Ereditato da EditorContainer)
Metodo protetto | GetEditableObject | (Ereditato da TreeList)
Metodo pubblico | GetEditorShowMode | (Ereditato da TreeList)
Metodo protetto | GetEditorViewInfo | (Ereditato da TreeList)
Metodo protetto | GetFilterColumn | (Ereditato da TreeList)
Metodo protetto | GetFilterColumnByTreeListColumn | (Ereditato da TreeList)
Metodo protetto | GetFilterCriteriaDisplayStyle | (Ereditato da TreeList)
Metodo protetto | GetFilterDisplayText | (Ereditato da TreeList)
Metodo protetto | GetFilterDisplayTextByColumn | (Ereditato da TreeList)
Metodo protetto | GetFilterPopupTexts | (Ereditato da TreeList)
Metodo protetto | GetFilterPopupValues(TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | GetFilterPopupValues(TreeListColumn, Boolean) | (Ereditato da TreeList)
Metodo protetto | GetFilterPopupValues(TreeListColumn, CriteriaOperator, Boolean) | (Ereditato da TreeList)
Metodo protetto | GetFilterPopupValues(TreeListColumn, Boolean, Boolean) | (Ereditato da TreeList)
Metodo protetto | GetFilterRowValue(Object) | (Ereditato da TreeList)
Metodo protetto | GetFilterRowValue(TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | GetFindMatchedRanges | (Ereditato da TreeList)
Metodo protetto | GetFindMatchedText | (Ereditato da TreeList)
Metodo protetto | GetFindToColumnsCollection | (Ereditato da TreeList)
Metodo pubblico | GetFocusedDataRow | (Ereditato da TreeList)
Metodo pubblico | GetFocusedDisplayText | (Ereditato da TreeList)
Metodo pubblico | GetFocusedRow | (Ereditato da TreeList)
Metodo pubblico | GetFocusedRowCellDisplayText(String) | (Ereditato da TreeList)
Metodo pubblico | GetFocusedRowCellDisplayText(TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetFocusedRowCellValue(String) | (Ereditato da TreeList)
Metodo pubblico | GetFocusedRowCellValue(TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetGroupSummaryValue | (Ereditato da TreeList)
Metodo protetto | GetHeaderFilterButtonShowMode | (Ereditato da TreeList)
Metodo pubblico | GetHitInfo | Obsoleto. (Ereditato da TreeList)
Metodo protetto | GetImageIndexFromDataSource | (Ereditato da TreeList)
Metodo protetto | GetMaxIndent | (Ereditato da TreeList)
Metodo protetto | GetNativePreviewText | (Ereditato da TreeList)
Metodo pubblico | GetNodeAt(Point) | (Ereditato da TreeList)
Metodo pubblico | GetNodeAt(Int32, Int32) | (Ereditato da TreeList)
Metodo pubblico | GetNodeByVisibleIndex | (Ereditato da TreeList)
Metodo protetto | GetNodeCellRepositoryItem | (Ereditato da TreeList)
Metodo protetto | GetNodeComparer(IComparerTreeListNode) | (Ereditato da TreeList)
Metodo protetto | GetNodeComparer(TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetNodeIndex | (Ereditato da TreeList)
Metodo pubblico | GetNodeList | (Ereditato da TreeList)
Metodo protetto | GetNodeValue(TreeListNode, TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | GetNodeValue(TreeListNode, Object) | (Ereditato da TreeList)
Metodo protetto | GetNodeValue(TreeListNode, String) | (Ereditato da TreeList)
Metodo protetto | GetNonFormattedCaption | (Ereditato da TreeList)
Metodo protetto | GetParentColumnFieldNameSort | (Ereditato da TreeList)
Metodo pubblico | GetRow | (Ereditato da TreeList)
Metodo pubblico | GetRowCellDisplayText(TreeListNode, TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetRowCellDisplayText(TreeListNode, String) | (Ereditato da TreeList)
Metodo pubblico | GetRowCellValue(TreeListNode, TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetRowCellValue(TreeListNode, String) | (Ereditato da TreeList)
Metodo protetto | GetRowsAsFootersCount | (Ereditato da TreeList)
Metodo pubblico | GetScrollAnnotations | (Ereditato da TreeList)
Metodo pubblico | GetSelectedCells | (Ereditato da TreeList)
Metodo pubblico | GetSelectedCells(TreeListNode) | (Ereditato da TreeList)
Metodo protetto | GetShowBandsMode | (Ereditato da TreeList)
Metodo protetto | GetShowFirstLines | (Ereditato da TreeList)
Metodo protetto | GetShowIndentAsRowStyle | (Ereditato da TreeList)
Metodo pubblico | GetSortColumn(Int32) | (Ereditato da TreeList)
Metodo protetto | GetSortColumn(TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetSummaryValue(TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetSummaryValue(TreeListColumn, Boolean) | (Ereditato da TreeList)
Metodo protetto | GetSummaryValueCore | (Ereditato da TreeList)
Metodo protetto | GetSummaryValueEx | (Ereditato da TreeList)
Metodo pubblico | GetToolTipController | (Ereditato da EditorContainer)
Metodo protetto | GetUseDirectXPaint | (Ereditato da TreeList)
Metodo pubblico | GetVisibleIndexByNode | (Ereditato da TreeList)
Metodo protetto | GetVisibleIndexByNodeCore | (Ereditato da TreeList)
Metodo protetto | GetVisibleParentNodesCount | (Ereditato da TreeList)
Metodo pubblico | HideCustomization | (Ereditato da TreeList)
Metodo pubblico | HideEditor | (Ereditato da TreeList)
Metodo protetto | HideEditorCore | (Ereditato da TreeList)
Metodo pubblico | HideFindPanel | (Ereditato da TreeList)
Metodo pubblico | HideLoadingPanel | (Ereditato da TreeList)
Metodo protetto | HookOnLoaded | (Ereditato da EditorContainer)
Metodo pubblico | ImportFromXml(Stream) | (Ereditato da TreeList)
Metodo pubblico | ImportFromXml(String) | (Ereditato da TreeList)
Metodo protetto | ImportFromXmlCore | (Ereditato da TreeList)
Metodo pubblico | IndentNodes | (Ereditato da TreeList)
Metodo protetto | InitFindPanel | (Ereditato da TreeList)
Metodo protetto | InitializeDirectXProvider | (Ereditato da EditorContainer)
Metodo protetto | InitScrollInfo | (Ereditato da TreeList)
Metodo protetto | InternalDeleteNode | (Ereditato da TreeList)
Metodo protetto | InternalDeleteNodeCore | (Ereditato da TreeList)
Metodo protetto | InternalDeleteNodes(DictionaryTreeListNodes, ListTreeListNode) | (Ereditato da TreeList)
Metodo protetto | InternalDeleteNodes(TreeListNodes) | (Ereditato da TreeList)
Metodo protetto | InternalFullCollapseNode | (Ereditato da TreeList)
Metodo protetto | InternalFullExpandNode | (Ereditato da TreeList)
Metodo protetto | InternalGetCustomNodeCellEdit | (Ereditato da TreeList)
Metodo protetto | InternalGetCustomNodeCellStyle | (Ereditato da TreeList)
Metodo pubblico | InternalGetService | (Ereditato da TreeList)
Metodo protetto | InternalNodeAdded | (Ereditato da TreeList)
Metodo protetto | InternalNodeChanged | (Ereditato da TreeList)
Metodo protetto | InternalSetTopVisibleNodePixel | (Ereditato da TreeList)
Metodo pubblico | InvalidateBand | (Ereditato da TreeList)
Metodo pubblico | InvalidateBandPanel | (Ereditato da TreeList)
Metodo pubblico | InvalidateCell | (Ereditato da TreeList)
Metodo pubblico | InvalidateColumnHeader | (Ereditato da TreeList)
Metodo pubblico | InvalidateColumnPanel | (Ereditato da TreeList)
Metodo pubblico | InvalidateFilterPanel | (Ereditato da TreeList)
Metodo pubblico | InvalidateNode | (Ereditato da TreeList)
Metodo pubblico | InvalidateNodes | (Ereditato da TreeList)
Metodo pubblico | InvalidateRow | (Ereditato da TreeList)
Metodo pubblico | InvalidateRowPreview | (Ereditato da TreeList)
Metodo protetto | InvalidateRows | (Ereditato da TreeList)
Metodo pubblico | InvalidateScrollAnnotations | (Ereditato da TreeList)
Metodo pubblico | InvalidateSummaryFooterPanel | (Ereditato da TreeList)
Metodo pubblico | InvokeMenuItemClick | (Ereditato da TreeList)
Metodo protetto | IsAllowDefaultFastBestFit | (Ereditato da TreeList)
Metodo protetto | IsAllowEditForm | (Ereditato da TreeList)
Metodo pubblico | IsAutoFilterNode | (Ereditato da TreeList)
Metodo pubblico | IsCellSelected | (Ereditato da TreeList)
Metodo protetto | IsColumnAllowAutoFilter | (Ereditato da TreeList)
Metodo protetto | IsColumnAllowFilter | (Ereditato da TreeList)
Metodo pubblico | IsColumnAllowFilterEditor | (Ereditato da TreeList)
Metodo protetto | IsColumnFieldNameSortExist | (Ereditato da TreeList)
Metodo protetto | IsColumnFiltered | (Ereditato da TreeList)
Metodo protetto | IsFilterByDisplayText | (Ereditato da TreeList)
Metodo protetto | IsFilterRow | (Ereditato da TreeList)
Metodo protetto | IsImplyNullLikeEmptyStringWhenFiltering | (Ereditato da TreeList)
Metodo protetto | IsInputChar | (Ereditato da TreeList)
Metodo protetto | IsInputKey | (Ereditato da TreeList)
Metodo pubblico | IsNewItemRow | (Ereditato da TreeList)
Metodo protetto | IsParentColumnFieldNameSortExist | (Ereditato da TreeList)
Metodo pubblico | IsRootNode | (Ereditato da TreeList)
Metodo protetto | IsRoundDateTime | (Ereditato da TreeList)
Metodo protetto | IsShowAllValuesInFilterPopup | (Ereditato da TreeList)
Metodo protetto | IsTopNewItemRow | (Ereditato da TreeList)
Metodo protetto | IsUserAutoFilterCondition | (Ereditato da TreeList)
Metodo pubblico | LayoutChanged | (Ereditato da TreeList)
Metodo protetto | LoadDataColumns | (Ereditato da TreeList)
Metodo protetto | LoadDataSource | (Ereditato da TreeList)
Metodo protetto | LockDirectXRendering | (Ereditato da TreeList)
Metodo protetto | LockFilteringUIClientFilterCriteriaBinding | (Ereditato da TreeList)
Metodo pubblico | LockReloadNodes | (Ereditato da TreeList)
Metodo pubblico | MakeColumnVisible | (Ereditato da TreeList)
Metodo protetto | MakeFocusedRowVisible | (Ereditato da TreeList)
Metodo pubblico | MakeNodeVisible | (Ereditato da TreeList)
Metodo protetto | MergeColumnFiltersCore | (Ereditato da TreeList)
Metodo pubblico | MoveFirst | (Ereditato da TreeList)
Metodo protetto | MoveFocusedCell | (Ereditato da TreeList)
Metodo pubblico | MoveLast | (Ereditato da TreeList)
Metodo pubblico | MoveLastVisible | (Ereditato da TreeList)
Metodo pubblico | MoveNext | (Ereditato da TreeList)
Metodo pubblico | MoveNextVisible | (Ereditato da TreeList)
Metodo pubblico | MoveNode(TreeListNode, TreeListNode) | (Ereditato da TreeList)
Metodo pubblico | MoveNode(TreeListNode, TreeListNode, Boolean) | (Ereditato da TreeList)
Metodo pubblico | MoveNode(TreeListNode, TreeListNode, Boolean, Int32) | (Ereditato da TreeList)
Metodo pubblico | MoveNodes | (Ereditato da TreeList)
Metodo protetto | MoveNodesCore | (Ereditato da TreeList)
Metodo pubblico | MovePrev | (Ereditato da TreeList)
Metodo pubblico | MovePrevVisible | (Ereditato da TreeList)
Metodo pubblico | MoveToNextScrollAnnotation | (Ereditato da TreeList)
Metodo pubblico | MoveToParent | (Ereditato da TreeList)
Metodo pubblico | MoveToPrevScrollAnnotation | (Ereditato da TreeList)
Metodo protetto | NormalizeVisibleBandIndices | (Ereditato da TreeList)
Metodo protetto | NormalizeVisibleColumnIndices | (Ereditato da TreeList)
Metodo protetto | OnActiveEditor_GotFocus | (Ereditato da TreeList)
Metodo protetto | OnActiveEditor_LostFocus | (Ereditato da TreeList)
Metodo protetto | OnActiveEditor_Modified | (Ereditato da TreeList)
Metodo protetto | OnActiveEditor_ValueChanged | (Ereditato da TreeList)
Metodo protetto | OnActiveEditor_ValueChanging | (Ereditato da TreeList)
Metodo protetto | OnActiveFilterChanged | (Ereditato da TreeList)
Metodo protetto | OnActiveFilterCriteriaChanged | (Ereditato da TreeList)
Metodo protetto | OnActiveFilterEnabledChanged | (Ereditato da TreeList)
Metodo protetto | OnAfterAddingNode | (Ereditato da TreeList)
Metodo protetto | OnAfterChangeCollapsed | (Ereditato da TreeList)
Metodo protetto | OnAfterChangeExpanded | (Ereditato da TreeList)
Metodo protetto | OnAfterDeletingNodes | (Ereditato da TreeList)
Metodo protetto | OnAllowBandColumnMultiRowChanged | (Ereditato da TreeList)
Metodo protetto | OnAllowSerializationProperty | (Ereditato da TreeList)
Metodo protetto | OnAppearancePrintChanged | (Ereditato da TreeList)
Metodo protetto | OnBandChanged | (Ereditato da TreeList)
Metodo protetto | OnBandCollectionChanged | (Ereditato da TreeList)
Metodo protetto | OnBandColumnCollectionChanged | (Ereditato da TreeList)
Metodo protetto | OnBandFixedChanged | (Ereditato da TreeList)
Metodo protetto | OnBandWidthChanged | (Ereditato da TreeList)
Metodo protetto | OnBeginTouchScroll | (Ereditato da TreeList)
Metodo protetto | OnBindingContextChanged | (Ereditato da TreeList)
Metodo protetto | OnCheckBoxFieldNameChanged | (Ereditato da TreeList)
Metodo protetto | OnClearNodes | (Ereditato da TreeList)
Metodo protetto | OnClearNodesComplete | (Ereditato da TreeList)
Metodo protetto | OnClick | (Ereditato da TreeList)
Metodo protetto | OnColumnAdded | (Ereditato da TreeList)
Metodo protetto | OnColumnChanged | (Ereditato da TreeList)
Metodo protetto | OnColumnFilterModeChanged | (Ereditato da TreeList)
Metodo protetto | OnColumnFilterRestored | (Ereditato da TreeList)
Metodo protetto | OnColumnInfosPopulated | (Ereditato da TreeList)
Metodo protetto | OnColumnRemoved | (Ereditato da TreeList)
Metodo protetto | OnColumnRowIndexChanged | (Ereditato da TreeList)
Metodo protetto | OnColumnsChanged | (Ereditato da TreeList)
Metodo protetto | OnColumnUnboundChanged | (Ereditato da TreeList)
Metodo protetto | OnColumnUnboundExpressionChanged | (Ereditato da TreeList)
Metodo protetto | OnContainerEnter | (Ereditato da EditorContainer)
Metodo protetto | OnContainerLeave | (Ereditato da EditorContainer)
Metodo protetto | OnContextMenuKey | (Ereditato da TreeList)
Metodo protetto | OnCreateControl | (Ereditato da EditorContainer)
Metodo protetto | OnDataListChanged | (Ereditato da TreeList)
Metodo protetto | OnDesignerHost_LoadComplete | (Ereditato da EditorContainer)
Metodo protetto | OnDesignerHost_TransactionClosed | (Ereditato da EditorContainer)
Metodo protetto | OnDirectXPaintDisabled | (Ereditato da TreeList)
Metodo protetto | OnDoubleClick | (Ereditato da TreeList)
Metodo protetto | OnDragDrop | (Ereditato da TreeList)
Metodo protetto | OnDragEnter | (Ereditato da TreeList)
Metodo protetto | OnDragLeave | (Ereditato da TreeList)
Metodo protetto | OnDragOver | (Ereditato da TreeList)
Metodo protetto | OnEnabledChanged | (Ereditato da TreeList)
Metodo protetto | OnEndInit | (Ereditato da EditorContainer)
Metodo protetto | OnEndSerializing | (Ereditato da TreeList)
Metodo protetto | OnEndSorting | (Ereditato da TreeList)
Metodo protetto | OnEnter | (Ereditato da EditorContainer)
Metodo protetto | OnErrorInfo_Changed | (Ereditato da TreeList)
Metodo protetto | OnFilterRowValueChanging | (Ereditato da TreeList)
Metodo protetto | OnFirstInit | (Ereditato da EditorContainer)
Metodo protetto | OnFormatConditionChanged | (Ereditato da TreeList)
Metodo protetto | OnFormatRuleExpressionEditorCreated | (Ereditato da TreeList)
Metodo protetto | OnFormatRulesCollectionChanged | (Ereditato da TreeList)
Metodo protetto | OnGotCapture | (Ereditato da EditorContainer)
Metodo protetto | OnGotFocus | (Ereditato da TreeList)
Metodo protetto | OnHandleCreated | (Ereditato da TreeList)
Metodo protetto | OnHandleDestroyed | (Ereditato da TreeList)
Metodo protetto | OnHorizontalTouchScroll | (Ereditato da TreeList)
Metodo protetto | OnHScroll | (Ereditato da TreeList)
Metodo protetto | OnItemAdded | (Ereditato da TreeList)
Metodo protetto | OnItemAdding | (Ereditato da TreeList)
Metodo protetto | OnItemChanged(Int32, PropertyDescriptor) | (Ereditato da TreeList)
Metodo protetto | OnItemChanged(Int32, PropertyDescriptor, TreeListNode) | (Ereditato da TreeList)
Metodo protetto | OnItemDeleted | (Ereditato da TreeList)
Metodo protetto | OnItemMoved | (Ereditato da TreeList)
Metodo protetto | OnKeyDown | (Ereditato da TreeList)
Metodo protetto | OnKeyPress | (Ereditato da TreeList)
Metodo protetto | OnKeyUp | (Ereditato da TreeList)
Metodo protetto | OnLeave | (Ereditato da EditorContainer)
Metodo protetto | OnLoaded | (Ereditato da TreeList)
Metodo protetto | OnLoadedCore | (Ereditato da TreeList)
Metodo protetto | OnLookAndFeelChanged(LookAndFeelChangedEventArgs) | (Ereditato da TreeList)
Metodo protetto | OnLookAndFeelChanged(Object, EventArgs) | (Ereditato da EditorContainer)
Metodo protetto | OnLostCapture | (Ereditato da TreeList)
Metodo protetto | OnLostFocus | (Ereditato da TreeList)
Metodo protetto | OnMenuShowing | (Ereditato da TreeList)
Metodo protetto | OnMouseClick | (Ereditato da EditorContainer)
Metodo protetto | OnMouseDoubleClick | (Ereditato da EditorContainer)
Metodo protetto | OnMouseDown | (Sovrascrive TreeList.OnMouseDown(MouseEventArgs))
Metodo protetto | OnMouseEnter | (Ereditato da TreeList)
Metodo protetto | OnMouseHWheel | (Ereditato da EditorContainer)
Metodo protetto | OnMouseLeave | (Ereditato da TreeList)
Metodo protetto | OnMouseMove | (Sovrascrive TreeList.OnMouseMove(MouseEventArgs))
Metodo protetto | OnMouseUp | (Sovrascrive TreeList.OnMouseUp(MouseEventArgs))
Metodo protetto | OnMouseWheel | (Ereditato da EditorContainer)
Metodo protetto | OnMouseWheelCore | (Ereditato da TreeList)
Metodo protetto | OnNodeCheckedChanged | (Ereditato da TreeList)
Metodo protetto | OnNodeRemoved | (Ereditato da TreeList)
Metodo protetto | OnNodesLoaded | (Ereditato da TreeList)
Metodo protetto | OnNodesLoading | (Ereditato da TreeList)
Metodo protetto | OnNodesRemoved | (Ereditato da TreeList)
Metodo protetto | OnOptionsBehaviorChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsCustomizationChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsDragAndDropChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsEditFormChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsFilterChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsFindChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsHtmlChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsNavigationChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsPrintChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsScrollAnnotationsChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsSelectionChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsViewChanged | (Ereditato da TreeList)
Metodo protetto | OnPaint | (Sovrascrive TreeList.OnPaint(PaintEventArgs))
Metodo protetto | OnPaintBackground | (Ereditato da TreeList)
Metodo protetto | OnParentChanged | (Ereditato da TreeList)
Metodo protetto | OnPressedBandChanged | (Ereditato da TreeList)
Metodo protetto | OnPrintProgress | (Ereditato da TreeList)
Metodo protetto | OnPropertyChanged | (Ereditato da TreeList)
Metodo protetto | OnPropertyDescriptorChanged | (Ereditato da TreeList)
Metodo protetto | OnQueryContinueDrag | (Ereditato da TreeList)
Metodo protetto | OnRepositoryItemRefreshRequired | (Ereditato da TreeList)
Metodo protetto | OnReset | (Ereditato da TreeList)
Metodo protetto | OnResetSerializationProperties | (Ereditato da TreeList)
Metodo protetto | OnResize | (Ereditato da TreeList)
Metodo protetto | OnRightToLeftChanged | (Ereditato da TreeList)
Metodo protetto | OnRightToLeftChanged(EventArgs) | (Ereditato da EditorContainer)
Metodo protetto | OnScaleControl | (Ereditato da TreeList)
Metodo protetto | OnScaleTreeListCore | (Ereditato da TreeList)
Metodo protetto | OnSelectionChanged | (Ereditato da TreeList)
Metodo protetto | OnSetValue | (Ereditato da TreeList)
Metodo protetto | OnSortModeChanged | (Ereditato da TreeList)
Metodo protetto | OnSourceItemChanged | (Ereditato da TreeList)
Metodo protetto | OnStartSerializing | (Ereditato da TreeList)
Metodo protetto | OnStartSorting | (Ereditato da TreeList)
Metodo protetto | OnSystemColorsChanged | (Ereditato da TreeList)
Metodo protetto | OnToolTipControllerDisposed | (Ereditato da EditorContainer)
Metodo protetto | OnTouchScroll | (Ereditato da TreeList)
Metodo protetto | OnTouchZoom | (Ereditato da TreeList)
Metodo protetto | OnValidated | (Ereditato da EditorContainer)
Metodo protetto | OnValidating | (Ereditato da TreeList)
Metodo protetto | OnVerticalTouchScroll | (Ereditato da TreeList)
Metodo protetto | OnVisibleChanged | (Ereditato da TreeList)
Metodo protetto | OnVScroll | (Ereditato da TreeList)
Metodo protetto | OnVScrollCore | (Ereditato da TreeList)
Metodo pubblico | OutdentNodes | (Ereditato da TreeList)
Metodo protetto | ParseAutoFilter | (Ereditato da TreeList)
Metodo protetto | ParseAutoFilterValues | (Ereditato da TreeList)
Metodo pubblico | PasteFromClipboard | (Ereditato da TreeList)
Metodo pubblico | PopulateColumns | (Ereditato da TreeList)
Metodo pubblico | PostEditor | (Ereditato da TreeList)
Metodo protetto | PostEditor(Boolean) | (Ereditato da TreeList)
Metodo pubblico | Print | (Ereditato da TreeList)
Metodo protetto | PrintCore | (Ereditato da TreeList)
Metodo pubblico | PrintDialog | (Ereditato da TreeList)
Metodo protetto | PrintDialogCore | (Ereditato da TreeList)
Metodo protetto | ProcessControlTab | (Ereditato da TreeList)
Metodo protetto | ProcessControlTab(Boolean) | (Ereditato da TreeList)
Metodo protetto | ProcessDialogKey | (Ereditato da TreeList)
Metodo protetto | ProcessDirectXPaint | (Ereditato da TreeList)
Metodo protetto | RaiseAfterCheckNode | (Ereditato da TreeList)
Metodo protetto | RaiseAfterCollapse | (Ereditato da TreeList)
Metodo protetto | RaiseAfterDragNode | (Ereditato da TreeList)
Metodo protetto | RaiseAfterDropNode | (Ereditato da TreeList)
Metodo protetto | RaiseAfterExpand | (Ereditato da TreeList)
Metodo protetto | RaiseAfterFocusNode | (Ereditato da TreeList)
Metodo protetto | RaiseBandPositionChanged | (Ereditato da TreeList)
Metodo protetto | RaiseBandWidthChanged | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeCheckNode | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeCollapse | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeDragNode | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeDropNode | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeExpand | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeFocusNode | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeLoadLayout | (Ereditato da TreeList)
Metodo protetto | RaiseCalcNodeDragImageIndex | (Ereditato da TreeList)
Metodo protetto | RaiseCalcNodeHeight(TreeListNode, Int32) | (Ereditato da TreeList)
Metodo protetto | RaiseCalcNodeHeight(TreeListNode, RowInfo, Int32) | (Ereditato da TreeList)
Metodo protetto | RaiseCellValueChanged | (Ereditato da TreeList)
Metodo protetto | RaiseCellValueChanging | (Ereditato da TreeList)
Metodo protetto | RaiseCheckedColumnFilterPopupEvent | (Ereditato da TreeList)
Metodo protetto | RaiseClipboardNodeCopying | (Ereditato da TreeList)
Metodo protetto | RaiseClipboardNodePasting | (Ereditato da TreeList)
Metodo protetto | RaiseColumnButtonClick | (Ereditato da TreeList)
Metodo protetto | RaiseColumnChanged | (Ereditato da TreeList)
Metodo protetto | RaiseColumnFilterChanged | (Ereditato da TreeList)
Metodo protetto | RaiseColumnFilterPopupEvent | (Ereditato da TreeList)
Metodo protetto | RaiseColumnPositionChanged | (Ereditato da TreeList)
Metodo protetto | RaiseColumnUnboundExpressionChanged | (Ereditato da TreeList)
Metodo protetto | RaiseColumnWidthChanged | (Ereditato da TreeList)
Metodo protetto | RaiseCompareNodeValues | (Ereditato da TreeList)
Metodo protetto | RaiseCreateCustomNode | (Ereditato da TreeList)
Metodo protetto | RaiseCustomColumnDisplayText(CustomColumnDisplayTextEventArgs) | (Ereditato da TreeList)
Metodo protetto | RaiseCustomColumnDisplayText(TreeListNode, CellInfo) | (Ereditato da TreeList)
Metodo protetto | RaiseCustomColumnDisplayText(TreeListNode, TreeListColumn, BaseEditViewInfo) | (Ereditato da TreeList)
Metodo protetto | RaiseCustomColumnDisplayText(TreeListNode, TreeListColumn, Object, String) | (Ereditato da TreeList)
Metodo protetto | RaiseCustomColumnSort | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawBandHeader | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawColumnHeader | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawEmptyArea | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawFilterPanel | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawFooter | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawFooterCell | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodeButton | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodeCell | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodeCheckBox | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodeImages | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodeIndent | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodeIndicator | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodePreview | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawRow | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawRowFooter | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawRowFooterCell | (Ereditato da TreeList)
Metodo protetto | RaiseCustomFilterDisplayText | (Ereditato da TreeList)
Metodo protetto | RaiseCustomizationFormSearch | (Ereditato da TreeList)
Metodo protetto | RaiseCustomizeNewNodeFromOuterData | (Ereditato da TreeList)
Metodo protetto | RaiseCustomRowFilter | (Ereditato da TreeList)
Metodo protetto | RaiseCustomRowFilterEvent | (Ereditato da TreeList)
Metodo protetto | RaiseCustomUnboundColumnData | (Ereditato da TreeList)
Metodo protetto | RaiseDataSourceChanged | (Ereditato da TreeList)
Metodo protetto | RaiseDefaultPaintHelperChanged | (Ereditato da TreeList)
Metodo protetto | RaiseDragCancelNode | (Ereditato da TreeList)
Metodo protetto | RaiseDragObjectDrop | (Ereditato da TreeList)
Metodo protetto | RaiseDragObjectOver | (Ereditato da TreeList)
Metodo protetto | RaiseDragObjectStart | (Ereditato da TreeList)
Metodo protetto | RaiseEditFormHidden | (Ereditato da TreeList)
Metodo protetto | RaiseEditFormPrepared | (Ereditato da TreeList)
Metodo protetto | RaiseEditFormShowing | (Ereditato da TreeList)
Metodo protetto | RaiseEditorKeyDown | (Ereditato da TreeList)
Metodo protetto | RaiseEditorKeyPress | (Ereditato da EditorContainer)
Metodo protetto | RaiseEditorKeyUp | (Ereditato da EditorContainer)
Metodo protetto | RaiseEndSorting | (Ereditato da TreeList)
Metodo protetto | RaiseExcelColumnFilterPopupEvent | (Ereditato da TreeList)
Metodo protetto | RaiseFilterEditorCreated | (Ereditato da TreeList)
Metodo protetto | RaiseFilterExpressionEditorCreated | (Ereditato da TreeList)
Metodo protetto | RaiseFilterNodeEvent | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupDate | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelCustomizeTemplate | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelData(FilterPopupExcelDataEventArgs) | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelData(TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelData(TreeListColumn, CriteriaOperator) | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelData(TreeListColumn, TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelParseFilterCriteria | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelPrepareTemplate | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelQueryFilterCriteria | (Ereditato da TreeList)
Metodo protetto | RaiseFocusedColumnChanged | (Ereditato da TreeList)
Metodo protetto | RaiseFocusedNodeChanged | (Ereditato da TreeList)
Metodo protetto | RaiseGetCustomAnnotations | (Ereditato da TreeList)
Metodo protetto | RaiseGetCustomNodeCellEdit | (Ereditato da TreeList)
Metodo protetto | RaiseGetCustomNodeCellStyle | (Ereditato da TreeList)
Metodo protetto | RaiseGetCustomSummaryValue | (Ereditato da TreeList)
Metodo protetto | RaiseGetNodeDisplayValue | (Ereditato da TreeList)
Metodo protetto | RaiseGetPreviewText | (Ereditato da TreeList)
Metodo protetto | RaiseGetPrintCustomSummaryValue | (Ereditato da TreeList)
Metodo protetto | RaiseGetPrintPreviewText | (Ereditato da TreeList)
Metodo protetto | RaiseGetSelectImage | (Ereditato da TreeList)
Metodo protetto | RaiseGetStateImage | (Ereditato da TreeList)
Metodo protetto | RaiseHiddenEditor | (Ereditato da TreeList)
Metodo protetto | RaiseHideCustomizationForm | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementBlur | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementFocus | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseClick | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseDoubleClick | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseDown | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseMove | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseOut | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseOver | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseUp | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlSelectedTextChanged | (Ereditato da TreeList)
Metodo protetto | RaiseInitNewRow | (Ereditato da TreeList)
Metodo protetto | RaiseInvalidNodeException | (Ereditato da TreeList)
Metodo protetto | RaiseInvalidValueException | (Ereditato da TreeList)
Metodo protetto | RaiseLayoutUpdated | (Ereditato da TreeList)
Metodo protetto | RaiseLayoutUpgrade | (Ereditato da TreeList)
Metodo protetto | RaiseLeftCoordChanged | (Ereditato da TreeList)
Metodo protetto | RaiseLoad | (Ereditato da TreeList)
Metodo protetto | RaiseMeasurePreviewHeight | (Ereditato da TreeList)
Metodo protetto | RaiseNodeChanged | (Ereditato da TreeList)
Metodo protetto | RaiseNodesReloaded | (Ereditato da TreeList)
Metodo protetto | RaisePaintEx | (Ereditato da TreeList)
Metodo protetto | RaiseParseFindPanelText | (Ereditato da TreeList)
Metodo protetto | RaisePopupMenuShowing | (Ereditato da TreeList)
Metodo protetto | RaisePrintExportProgress | (Ereditato da TreeList)
Metodo protetto | RaiseQueryCustomFunctions | (Ereditato da TreeList)
Metodo protetto | RaiseRequireHideEditor | (Ereditato da EditorContainer)
Metodo protetto | RaiseRowCellClick | (Ereditato da TreeList)
Metodo protetto | RaiseRowClick | (Ereditato da TreeList)
Metodo protetto | RaiseRowSelectImageClick | (Ereditato da TreeList)
Metodo protetto | RaiseRowStateImageClick | (Ereditato da TreeList)
Metodo protetto | RaiseSelectImageClick | (Ereditato da TreeList)
Metodo protetto | RaiseSelectionChanged | (Ereditato da TreeList)
Metodo protetto | RaiseSelectionChanging | (Ereditato da TreeList)
Metodo protetto | RaiseShowCustomizationForm | (Ereditato da TreeList)
Metodo protetto | RaiseShowingEditor | (Ereditato da TreeList)
Metodo protetto | RaiseShownEditor | (Ereditato da TreeList)
Metodo protetto | RaiseShowTreeListMenu | Obsoleto. (Ereditato da TreeList)
Metodo protetto | RaiseStartSorting | (Ereditato da TreeList)
Metodo protetto | RaiseStateChanged | (Ereditato da TreeList)
Metodo protetto | RaiseStateImageClick | (Ereditato da TreeList)
Metodo protetto | RaiseSubstituteFilter | (Ereditato da TreeList)
Metodo protetto | RaiseTopVisibleNodeIndexChanged | (Ereditato da TreeList)
Metodo protetto | RaiseTreeListMenuItemClick | (Ereditato da TreeList)
Metodo protetto | RaiseUnboundExpressionEditorCreated | (Ereditato da TreeList)
Metodo protetto | RaiseValidateNode | (Ereditato da TreeList)
Metodo protetto | RaiseValidatingEditor | (Ereditato da TreeList)
Metodo protetto | RecalcSortColumns | (Ereditato da TreeList)
Metodo protetto | RecreateRowsInfoCore | (Ereditato da TreeList)
Metodo pubblico | Refresh | (Ereditato da TreeList)
Metodo pubblico | Refresh(Boolean) | (Ereditato da TreeList)
Metodo pubblico | RefreshCell | (Ereditato da TreeList)
Metodo protetto | RefreshCellCore | (Ereditato da TreeList)
Metodo protetto | RefreshColumnsInfo | (Ereditato da TreeList)
Metodo pubblico | RefreshDataSource | (Ereditato da TreeList)
Metodo pubblico | RefreshEditor | (Ereditato da TreeList)
Metodo protetto | RefreshEditorError | (Ereditato da TreeList)
Metodo protetto | RefreshHeadersInfo | (Ereditato da TreeList)
Metodo protetto | RefreshHtmlNodeCore | (Ereditato da TreeList)
Metodo pubblico | RefreshNode | (Ereditato da TreeList)
Metodo protetto | RefreshNodeCore | (Ereditato da TreeList)
Metodo protetto | RefreshRowsInfo | (Ereditato da TreeList)
Metodo protetto | RefreshRowsInfo(Boolean, Boolean) | (Ereditato da TreeList)
Metodo pubblico | RefreshScrollAnnotations(ScrollAnnotationKind) | (Ereditato da TreeList)
Metodo pubblico | RefreshScrollAnnotations(ScrollAnnotationKind, Int32) | (Ereditato da TreeList)
Metodo protetto | RefreshVirtualCellCore | (Ereditato da TreeList)
Metodo protetto | RefreshVirtualNodeCore | (Ereditato da TreeList)
Metodo protetto | RejectCurrentChanges | (Ereditato da TreeList)
Metodo protetto | RemoveFromDefaultTooltipController | (Ereditato da EditorContainer)
Metodo protetto | RemoveHookOnLoaded | (Ereditato da EditorContainer)
Metodo protetto | RemoveNodeHeight | (Ereditato da TreeList)
Metodo protetto | RequestCellEditor | (Ereditato da TreeList)
Metodo protetto | ResetAccessibility | (Ereditato da TreeList)
Metodo pubblico | ResetAutoFilterCondition | (Ereditato da TreeList)
Metodo pubblico | ResetAutoFilterConditions | (Ereditato da TreeList)
Metodo pubblico | ResetAutoFilterConditions(IEnumerableTreeListColumn) | (Ereditato da TreeList)
Metodo protetto | ResetAutoFilterConditionsCore | (Ereditato da TreeList)
Metodo protetto | ResetColumnAutoFilterConditions | (Ereditato da TreeList)
Metodo pubblico | ResetEditorsCache(RepositoryItem) | (Ereditato da EditorContainer)
Metodo pubblico | ResetEditorsCache(Type) | (Ereditato da EditorContainer)
Metodo protetto | ResetExcelFilteringProvider | (Ereditato da TreeList)
Metodo protetto | ResetLookAndFeel | (Ereditato da EditorContainer)
Metodo protetto | ResetRowCount | (Ereditato da TreeList)
Metodo protetto | ResetSortedColumns | (Ereditato da TreeList)
Metodo protetto | ResizeBand | (Ereditato da TreeList)
Metodo protetto | ResizeColumn | (Ereditato da TreeList)
Metodo protetto | ResolveAutoFilterCondition | (Ereditato da TreeList)
Metodo protetto | RestoreLayoutCore | (Ereditato da TreeList)
Metodo pubblico | RestoreLayoutFromRegistry(String) | (Ereditato da TreeList)
Metodo pubblico | RestoreLayoutFromRegistry(String, OptionsLayoutBase) | (Ereditato da TreeList)
Metodo pubblico | RestoreLayoutFromStream(Stream) | (Ereditato da TreeList)
Metodo pubblico | RestoreLayoutFromStream(Stream, OptionsLayoutBase) | (Ereditato da TreeList)
Metodo pubblico | RestoreLayoutFromXml(String) | (Ereditato da TreeList)
Metodo pubblico | RestoreLayoutFromXml(String, OptionsLayoutBase) | (Ereditato da TreeList)
Metodo protetto | RestoreNodesData | (Ereditato da TreeList)
Metodo protetto | SaveLayoutCore | (Ereditato da TreeList)
Metodo pubblico | SaveLayoutToRegistry(String) | (Ereditato da TreeList)
Metodo pubblico | SaveLayoutToRegistry(String, OptionsLayoutBase) | (Ereditato da TreeList)
Metodo pubblico | SaveLayoutToStream(Stream) | (Ereditato da TreeList)
Metodo pubblico | SaveLayoutToStream(Stream, OptionsLayoutBase) | (Ereditato da TreeList)
Metodo pubblico | SaveLayoutToXml(String) | (Ereditato da TreeList)
Metodo pubblico | SaveLayoutToXml(String, OptionsLayoutBase) | (Ereditato da TreeList)
Metodo protetto | SaveNodesData | (Ereditato da TreeList)
Metodo protetto | ScaleControl | (Ereditato da EditorContainer)
Metodo protetto | Scrollbar_MouseEnter | (Ereditato da TreeList)
Metodo protetto | Scrollbar_MouseLeave | (Ereditato da TreeList)
Metodo protetto | ScrollHorizontalEx | (Ereditato da TreeList)
Metodo protetto | ScrollVerticalEx | (Ereditato da TreeList)
Metodo pubblico | SelectAll | (Ereditato da TreeList)
Metodo pubblico | SelectCell | (Ereditato da TreeList)
Metodo protetto | SelectCellCore | (Ereditato da TreeList)
Metodo pubblico | SelectCells(Int32, String, Int32, String) | (Ereditato da TreeList)
Metodo pubblico | SelectCells(TreeListNode, TreeListColumn, TreeListNode, TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | SelectNode | (Ereditato da TreeList)
Metodo protetto | SelectNodeCore | (Ereditato da TreeList)
Metodo pubblico | SelectNodes(Int32, Int32) | (Ereditato da TreeList)
Metodo pubblico | SelectNodes(TreeListNode, TreeListNode) | (Ereditato da TreeList)
Metodo protetto | SelectNodesCore | (Ereditato da TreeList)
Metodo protetto | ServiceColumnChanged | (Ereditato da TreeList)
Metodo pubblico | SetAutoFilterValue | (Ereditato da TreeList)
Metodo protetto | SetCellSelection | (Ereditato da TreeList)
Metodo protetto | SetCellSelectionCore | (Ereditato da TreeList)
Metodo pubblico | SetColumnError(TreeListColumn, String) | (Ereditato da TreeList)
Metodo pubblico | SetColumnError(TreeListColumn, String, ErrorType) | (Ereditato da TreeList)
Metodo protetto | SetColumnFixedStyle | (Ereditato da TreeList)
Metodo pubblico | SetColumnPosition | (Ereditato da TreeList)
Metodo protetto | SetColumnVisibleIndex | (Ereditato da TreeList)
Metodo pubblico | SetDefaultBehaviorOptions | (Ereditato da TreeList)
Metodo pubblico | SetDefaultCustomizationOptions | (Ereditato da TreeList)
Metodo pubblico | SetDefaultNavigationOptions | (Ereditato da TreeList)
Metodo pubblico | SetDefaultOptionsView | (Ereditato da TreeList)
Metodo pubblico | SetDefaultPrintOptions | (Ereditato da TreeList)
Metodo pubblico | SetDefaultRowHeight | (Ereditato da TreeList)
Metodo pubblico | SetDefaultSelectionOptions | (Ereditato da TreeList)
Metodo protetto | SetExtraFilter | (Ereditato da TreeList)
Metodo protetto | SetFilterRowValue(Object, Object) | (Ereditato da TreeList)
Metodo protetto | SetFilterRowValue(TreeListColumn, Object) | (Ereditato da TreeList)
Metodo pubblico | SetFocusedNode | (Ereditato da TreeList)
Metodo protetto | SetFocusedNodeCore | (Ereditato da TreeList)
Metodo pubblico | SetFocusedRowCellValue(String, Object) | (Ereditato da TreeList)
Metodo pubblico | SetFocusedRowCellValue(TreeListColumn, Object) | (Ereditato da TreeList)
Metodo protetto | SetFocusedRowIndexCore | (Ereditato da TreeList)
Metodo pubblico | SetFocusedValue | (Ereditato da TreeList)
Metodo pubblico | SetNodeCheckState(TreeListNode, CheckState) | (Ereditato da TreeList)
Metodo pubblico | SetNodeCheckState(TreeListNode, CheckState, Boolean) | (Ereditato da TreeList)
Metodo pubblico | SetNodeIndex | (Ereditato da TreeList)
Metodo protetto | SetNodeIndexCore | (Ereditato da TreeList)
Metodo protetto | SetNodeValue | (Ereditato da TreeList)
Metodo pubblico | SetRowCellValue(TreeListNode, TreeListColumn, Object) | (Ereditato da TreeList)
Metodo pubblico | SetRowCellValue(TreeListNode, String, Object) | (Ereditato da TreeList)
Metodo pubblico | SetSearchControl | (Ereditato da TreeList)
Metodo pubblico | SetSelectionAnchor | (Ereditato da TreeList)
Metodo protetto | SetUseDirectXPaint | (Ereditato da TreeList)
Metodo protetto | ShouldResortNodesOnItemChanged | (Ereditato da TreeList)
Metodo protetto | ShouldSerializeLookAndFeel | (Ereditato da EditorContainer)
Metodo pubblico | ShowAutoFilterConditionsMenu | (Ereditato da TreeList)
Metodo pubblico | ShowContextMenu | (Ereditato da TreeList)
Metodo pubblico | ShowCustomization | (Ereditato da TreeList)
Metodo pubblico | ShowCustomization(Point) | (Ereditato da TreeList)
Metodo pubblico | ShowEditForm | (Ereditato da TreeList)
Metodo protetto | ShowEditFormCore | (Ereditato da TreeList)
Metodo protetto | ShowEditFormDialogCore | (Ereditato da TreeList)
Metodo pubblico | ShowEditor | (Ereditato da TreeList)
Metodo pubblico | ShowEditor(String) | (Ereditato da TreeList)
Metodo pubblico | ShowFilterEditor | (Ereditato da TreeList)
Metodo protetto | ShowFilterExpressionEditor | (Ereditato da TreeList)
Metodo pubblico | ShowFilterPopup | (Ereditato da TreeList)
Metodo pubblico | ShowFindPanel | (Ereditato da TreeList)
Metodo pubblico | ShowLoadingPanel | (Ereditato da TreeList)
Metodo protetto | ShowMenu | (Ereditato da TreeList)
Metodo protetto | ShowMRUFilterPopup | (Ereditato da TreeList)
Metodo pubblico | ShowPrintPreview | (Ereditato da TreeList)
Metodo protetto | ShowPrintPreviewCore | (Ereditato da TreeList)
Metodo protetto | ShowProgressForm | (Ereditato da TreeList)
Metodo pubblico | ShowRibbonPrintPreview | (Ereditato da TreeList)
Metodo protetto | ShowRibbonPrintPreviewCore | (Ereditato da TreeList)
Metodo pubblico | ShowUnboundExpressionEditor | (Ereditato da TreeList)
Metodo pubblico | Sort(TreeListNode, IComparerTreeListNode, Boolean) | (Ereditato da TreeList)
Metodo protetto | Sort(TreeListNodes, Boolean, Boolean) | (Ereditato da TreeList)
Metodo pubblico | Sort(TreeListNode, TreeListColumn, SortOrder, Boolean) | (Ereditato da TreeList)
Metodo pubblico | StartIncrementalSearch | (Ereditato da TreeList)
Metodo protetto | StartOfficeScrolling | (Ereditato da TreeList)
Metodo pubblico | StopIncrementalSearch | (Ereditato da TreeList)
Metodo protetto | StopOfficeScrolling | (Ereditato da TreeList)
Metodo pubblico | UncheckAll | (Ereditato da TreeList)
Metodo protetto | UnlockDirectXRendering | (Ereditato da TreeList)
Metodo pubblico | UnlockReloadNodes | (Ereditato da TreeList)
Metodo pubblico | UnselectCell | (Ereditato da TreeList)
Metodo protetto | UnselectCellCore | (Ereditato da TreeList)
Metodo pubblico | UnselectCells(Int32, String, Int32, String) | (Ereditato da TreeList)
Metodo pubblico | UnselectCells(TreeListNode, TreeListColumn, TreeListNode, TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | UnselectNode | (Ereditato da TreeList)
Metodo pubblico | UnselectNodes(Int32, Int32) | (Ereditato da TreeList)
Metodo pubblico | UnselectNodes(TreeListNode, TreeListNode) | (Ereditato da TreeList)
Metodo protetto | UpdateActiveFilterInfo | (Ereditato da TreeList)
Metodo protetto | UpdateAutoFilterRowActiveEditor | (Ereditato da TreeList)
Metodo protetto | UpdateBandColumnsIndices | (Ereditato da TreeList)
Metodo protetto | UpdateBandColumnsOrder | (Ereditato da TreeList)
Metodo protetto | UpdateColumnAutoFilter | (Ereditato da TreeList)
Metodo protetto | UpdateColumnsSortIndices | (Ereditato da TreeList)
Metodo protetto | UpdateElementsLookAndFeel | (Ereditato da TreeList)
Metodo protetto | UpdateFilter | (Ereditato da TreeList)
Metodo protetto | UpdateFilterInfo | (Ereditato da TreeList)
Metodo protetto | UpdateFindPanelFilterText | (Ereditato da TreeList)
Metodo protetto | UpdateLayout | (Ereditato da TreeList)
Metodo protetto | UpdateRootBands | (Ereditato da TreeList)
Metodo protetto | UpdateSelectCell | (Ereditato da TreeList)
Metodo protetto | UpdateSelectCell(TreeListNode, TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | UpdateSelectNode | (Ereditato da TreeList)
Metodo protetto | UpdateSelectNode(TreeListNode) | (Ereditato da TreeList)
Metodo protetto | UpdateVScrollBarCore | (Ereditato da TreeList)
Metodo protetto | ValidateAndEndCurrentEdit | (Ereditato da TreeList)
Metodo protetto | WndProc | (Ereditato da TreeList)
Metodo protetto | XtraClearColumns | (Ereditato da TreeList)
Metodo protetto | XtraCreateColumnsItem | (Ereditato da TreeList)
Metodo protetto | XtraFindColumnsItem | (Ereditato da TreeList)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | AfterCheckNode | (Ereditato da TreeList)
Evento pubblico | AfterCollapse | (Ereditato da TreeList)
Evento pubblico | AfterDragNode | (Ereditato da TreeList)
Evento pubblico | AfterDropNode | (Ereditato da TreeList)
Evento pubblico | AfterExpand | (Ereditato da TreeList)
Evento pubblico | AfterFocusNode | (Ereditato da TreeList)
Evento pubblico | BandPositionChanged | (Ereditato da TreeList)
Evento pubblico | BandWidthChanged | (Ereditato da TreeList)
Evento pubblico | BeforeCheckNode | (Ereditato da TreeList)
Evento pubblico | BeforeCollapse | (Ereditato da TreeList)
Evento pubblico | BeforeDragNode | (Ereditato da TreeList)
Evento pubblico | BeforeDropNode | (Ereditato da TreeList)
Evento pubblico | BeforeExpand | (Ereditato da TreeList)
Evento pubblico | BeforeFocusNode | (Ereditato da TreeList)
Evento pubblico | BeforeLoadLayout | (Ereditato da TreeList)
Evento pubblico | CalcNodeDragImageIndex | (Ereditato da TreeList)
Evento pubblico | CalcNodeHeight | (Ereditato da TreeList)
Evento pubblico | CellValueChanged | (Ereditato da TreeList)
Evento pubblico | CellValueChanging | (Ereditato da TreeList)
Evento pubblico | ClipboardNodeCopying | (Ereditato da TreeList)
Evento pubblico | ClipboardNodePasting | (Ereditato da TreeList)
Evento pubblico | ColumnButtonClick | (Ereditato da TreeList)
Evento pubblico | ColumnChanged | (Ereditato da TreeList)
Evento pubblico | ColumnFilterChanged | (Ereditato da TreeList)
Evento pubblico | ColumnPositionChanged | (Ereditato da TreeList)
Evento pubblico | ColumnUnboundExpressionChanged | (Ereditato da TreeList)
Evento pubblico | ColumnWidthChanged | (Ereditato da TreeList)
Evento pubblico | CompareNodeValues | (Ereditato da TreeList)
Evento pubblico | CreateCustomNode | (Ereditato da TreeList)
Evento pubblico | CustomColumnDisplayText | (Ereditato da TreeList)
Evento pubblico | CustomColumnSort | (Ereditato da TreeList)
Evento pubblico | CustomDrawBandHeader | (Ereditato da TreeList)
Evento pubblico | CustomDrawColumnHeader | (Ereditato da TreeList)
Evento pubblico | CustomDrawEmptyArea | (Ereditato da TreeList)
Evento pubblico | CustomDrawFilterPanel | (Ereditato da TreeList)
Evento pubblico | CustomDrawFooter | (Ereditato da TreeList)
Evento pubblico | CustomDrawFooterCell | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodeButton | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodeCell | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodeCheckBox | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodeImages | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodeIndent | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodeIndicator | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodePreview | (Ereditato da TreeList)
Evento pubblico | CustomDrawRow | (Ereditato da TreeList)
Evento pubblico | CustomDrawRowFooter | (Ereditato da TreeList)
Evento pubblico | CustomDrawRowFooterCell | (Ereditato da TreeList)
Evento pubblico | CustomDrawScroll | (Ereditato da TreeList)
Evento pubblico | CustomFilterDisplayText | (Ereditato da TreeList)
Evento pubblico | CustomizationFormSearch | (Ereditato da TreeList)
Evento pubblico | CustomizeNewNodeFromOuterData | (Ereditato da TreeList)
Evento pubblico | CustomizeNodeTemplate | (Ereditato da TreeList)
Evento pubblico | CustomNodeCellEdit | (Ereditato da TreeList)
Evento pubblico | CustomNodeCellEditForEditing | (Ereditato da TreeList)
Evento pubblico | CustomRowFilter | (Ereditato da TreeList)
Evento pubblico | CustomScrollAnnotation | (Ereditato da TreeList)
Evento pubblico | CustomUnboundColumnData | (Ereditato da TreeList)
Evento pubblico | DataSourceChanged | (Ereditato da TreeList)
Evento pubblico | DefaultPaintHelperChanged | (Ereditato da TreeList)
Evento pubblico | DragCancelNode | (Ereditato da TreeList)
Evento pubblico | DragObjectDrop | (Ereditato da TreeList)
Evento pubblico | DragObjectOver | (Ereditato da TreeList)
Evento pubblico | DragObjectStart | (Ereditato da TreeList)
Evento pubblico | EditFormHidden | (Ereditato da TreeList)
Evento pubblico | EditFormPrepared | (Ereditato da TreeList)
Evento pubblico | EditFormShowing | (Ereditato da TreeList)
Evento pubblico | EditorKeyDown | (Ereditato da EditorContainer)
Evento pubblico | EditorKeyPress | (Ereditato da EditorContainer)
Evento pubblico | EditorKeyUp | (Ereditato da EditorContainer)
Evento pubblico | EndSorting | (Ereditato da TreeList)
Evento pubblico | FilterEditorCreated | (Ereditato da TreeList)
Evento pubblico | FilterExpressionEditorCreated | (Ereditato da TreeList)
Evento pubblico | FilterNode | (Ereditato da TreeList)
Evento pubblico | FilterPopupExcelCustomizeTemplate | (Ereditato da TreeList)
Evento pubblico | FilterPopupExcelData | (Ereditato da TreeList)
Evento pubblico | FilterPopupExcelParseFilterCriteria | (Ereditato da TreeList)
Evento pubblico | FilterPopupExcelPrepareTemplate | (Ereditato da TreeList)
Evento pubblico | FilterPopupExcelQueryFilterCriteria | (Ereditato da TreeList)
Evento pubblico | FocusedColumnChanged | (Ereditato da TreeList)
Evento pubblico | FocusedNodeChanged | (Ereditato da TreeList)
Evento pubblico | FormatRuleExpressionEditorCreated | (Ereditato da TreeList)
Evento pubblico | GetCustomNodeCellEdit | Obsoleto. (Ereditato da TreeList)
Evento pubblico | GetCustomNodeCellStyle | Obsoleto. (Ereditato da TreeList)
Evento pubblico | GetCustomSummaryValue | (Ereditato da TreeList)
Evento pubblico | GetNodeDisplayValue | (Ereditato da TreeList)
Evento pubblico | GetPreviewText | (Ereditato da TreeList)
Evento pubblico | GetPrintCustomSummaryValue | (Ereditato da TreeList)
Evento pubblico | GetPrintPreviewText | (Ereditato da TreeList)
Evento pubblico | GetSelectImage | (Ereditato da TreeList)
Evento pubblico | GetStateImage | (Ereditato da TreeList)
Evento pubblico | HiddenEditor | (Ereditato da TreeList)
Evento pubblico | HideCustomizationForm | (Ereditato da TreeList)
Evento pubblico | HtmlElementBlur | (Ereditato da TreeList)
Evento pubblico | HtmlElementFocus | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseClick | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseDoubleClick | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseDown | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseMove | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseOut | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseOver | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseUp | (Ereditato da TreeList)
Evento pubblico | HtmlSelectedTextChanged | (Ereditato da TreeList)
Evento pubblico | HyperlinkClick | (Ereditato da TreeList)
Evento pubblico | InitNewRow | (Ereditato da TreeList)
Evento pubblico | InvalidNodeException | (Ereditato da TreeList)
Evento pubblico | InvalidValueException | (Ereditato da TreeList)
Evento pubblico | LayoutUpdated | (Ereditato da TreeList)
Evento pubblico | LayoutUpgrade | (Ereditato da TreeList)
Evento pubblico | LeftCoordChanged | (Ereditato da TreeList)
Evento pubblico | Load | (Ereditato da TreeList)
Evento pubblico | MeasurePreviewHeight | (Ereditato da TreeList)
Evento pubblico | NodeCellStyle | (Ereditato da TreeList)
Evento pubblico | NodeChanged | (Ereditato da TreeList)
Evento pubblico | NodesReloaded | (Ereditato da TreeList)
Evento pubblico | PaintEx | (Ereditato da TreeList)
Evento pubblico | ParseFindPanelText | (Ereditato da TreeList)
Evento pubblico | PopupMenuShowing | (Ereditato da TreeList)
Evento pubblico | PrintExportProgress | (Ereditato da TreeList)
Evento pubblico | PropertyDeserializing | (Ereditato da TreeList)
Evento pubblico | PropertySerializing | (Ereditato da TreeList)
Evento pubblico | QueryCustomFunctions | (Ereditato da TreeList)
Evento pubblico | QueryEmptyTreeTemplate | (Ereditato da TreeList)
Evento pubblico | QueryNodeTemplate | (Ereditato da TreeList)
Evento pubblico | RowCellClick | (Ereditato da TreeList)
Evento pubblico | RowClick | (Ereditato da TreeList)
Evento pubblico | RowSelectImageClick | (Ereditato da TreeList)
Evento pubblico | RowStateImageClick | (Ereditato da TreeList)
Evento pubblico | ScrollAnnotationsStyle | (Ereditato da TreeList)
Evento pubblico | SelectImageClick | (Ereditato da TreeList)
Evento pubblico | SelectionChanged | (Ereditato da TreeList)
Evento pubblico | SelectionChanging | (Ereditato da TreeList)
Evento pubblico | ShowCustomizationForm | (Ereditato da TreeList)
Evento pubblico | ShowFilterPopupCheckedListBox | (Ereditato da TreeList)
Evento pubblico | ShowFilterPopupDate | (Ereditato da TreeList)
Evento pubblico | ShowFilterPopupExcel | (Ereditato da TreeList)
Evento pubblico | ShowFilterPopupListBox | (Ereditato da TreeList)
Evento pubblico | ShowingEditor | (Ereditato da TreeList)
Evento pubblico | ShownEditor | (Ereditato da TreeList)
Evento pubblico | ShowTreeListMenu | Obsoleto. (Ereditato da TreeList)
Evento pubblico | StartSorting | (Ereditato da TreeList)
Evento pubblico | StateChanged | (Ereditato da TreeList)
Evento pubblico | StateImageClick | (Ereditato da TreeList)
Evento pubblico | SubstituteFilter | (Ereditato da TreeList)
Evento pubblico | TopVisibleNodeIndexChanged | (Ereditato da TreeList)
Evento pubblico | TreeListMenuItemClick | (Ereditato da TreeList)
Evento pubblico | UnboundExpressionEditorCreated | (Ereditato da TreeList)
Evento pubblico | ValidateNode | (Ereditato da TreeList)
Evento pubblico | ValidatingEditor | (Ereditato da TreeList)
Evento pubblico | VirtualTreeGetCellValue | (Ereditato da TreeList)
Evento pubblico | VirtualTreeGetChildNodes | (Ereditato da TreeList)
Evento pubblico | VirtualTreeSetCellValue | (Ereditato da TreeList)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | allowCloseEditor | (Ereditato da TreeList)
Campo protetto | fInitializing | (Ereditato da EditorContainer)
Campo protetto | fUpdateSize | (Ereditato da TreeList)
Campo protetto | SortedColumns | (Ereditato da TreeList)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore MyTreeList

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public MyTreeList()
Public Sub New
public:
MyTreeList()
new : unit -> MyTreeList
Vedi anche

Documentazione

Classe MyTreeList
Namespace DedNet.Controls


Proprietà di MyTreeList

Il tipo MyTreeList espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | ActiveEditor | (Ereditato da TreeList)
Proprietà pubblica | ActiveFilter | (Ereditato da TreeList)
Proprietà pubblica | ActiveFilterCriteria | (Ereditato da TreeList)
Proprietà pubblica | ActiveFilterEnabled | (Ereditato da TreeList)
Proprietà pubblica | ActiveFilterInfo | (Ereditato da TreeList)
Proprietà pubblica | ActiveFilterString | (Ereditato da TreeList)
Proprietà protetta | ActualAutoNodeHeight | (Ereditato da TreeList)
Proprietà protetta | ActualFilterCriteria | (Ereditato da TreeList)
Proprietà protetta | ActualShowBands | (Ereditato da TreeList)
Proprietà pubblica | AllNodesCount | (Ereditato da TreeList)
Proprietà protetta | AllowAnimatedScrolling | (Ereditato da TreeList)
Proprietà protetta | AllowAutoFilterConditionChange | (Ereditato da TreeList)
Proprietà protetta | AllowBandColumnsMultiRow | (Ereditato da TreeList)
Proprietà protetta | AllowExpandAnimation | (Ereditato da TreeList)
Proprietà protetta | AllowFiltering | (Ereditato da TreeList)
Proprietà protetta | AllowFilteringAfterLoadingData | (Ereditato da TreeList)
Proprietà protetta | AllowFilterNodes | (Ereditato da TreeList)
Proprietà protetta | AllowFindPanel | (Ereditato da TreeList)
Proprietà protetta | AllowPrintProgress | (Ereditato da TreeList)
Proprietà protetta | AllowScaleOnLoad | (Ereditato da EditorContainer)
Proprietà pubblica | AllowTouchGestures | (Ereditato da EditorContainer)
Proprietà protetta | AllowTouchScroll | (Ereditato da TreeList)
Proprietà protetta | AnnotationManager | (Ereditato da TreeList)
Proprietà pubblica | Appearance | (Ereditato da TreeList)
Proprietà pubblica | AppearancePrint | (Ereditato da TreeList)
Proprietà pubblica | AutoFillColumn | (Ereditato da TreeList)
Proprietà pubblica | AutoFillColumnName | (Ereditato da TreeList)
Proprietà pubblica | AutoFillFieldName | (Ereditato da TreeList)
Proprietà protetta | AutoFilterNode | (Ereditato da TreeList)
Proprietà pubblica | BackColor | (Ereditato da TreeList)
Proprietà pubblica | BandPanelRowHeight | (Ereditato da TreeList)
Proprietà pubblica | Bands | (Ereditato da TreeList)
Proprietà pubblica | BestFitVisibleOnly | (Ereditato da TreeList)
Proprietà pubblica | BorderStyle | (Ereditato da TreeList)
Proprietà protetta | CanExpandNodesOnIncrementalSearch | (Ereditato da TreeList)
Proprietà protetta | CanLoadNodes | (Ereditato da TreeList)
Proprietà protetta | CanShowBandsInCustomizationForm | (Ereditato da TreeList)
Proprietà pubblica | CanShowEditor | (Ereditato da TreeList)
Proprietà pubblica | CanShowRowFooterSummary | (Ereditato da TreeList)
Proprietà pubblica | Caption | (Ereditato da TreeList)
Proprietà pubblica | CaptionHeight | (Ereditato da TreeList)
Proprietà protetta | CheckBoxesStrategy | (Ereditato da TreeList)
Proprietà pubblica | CheckBoxFieldName | (Ereditato da TreeList)
Proprietà pubblica | ChildListFieldName | (Ereditato da TreeList)
Proprietà protetta | ClientHeight | (Ereditato da TreeList)
Proprietà protetta | ClientWidth | (Ereditato da TreeList)
Proprietà pubblica | ClipboardDataProvider | (Ereditato da TreeList)
Proprietà protetta | ClipboardPasteHelper | (Ereditato da TreeList)
Proprietà protetta | ClipboardPasteManager | (Ereditato da TreeList)
Proprietà protetta | CloneInfoList | (Ereditato da TreeList)
Proprietà pubblica | ColumnPanelRowHeight | (Ereditato da TreeList)
Proprietà pubblica | Columns | (Ereditato da TreeList)
Proprietà pubblica | ColumnsImageList | (Ereditato da TreeList)
Proprietà protetta | ContainerHelper | (Ereditato da TreeList)
Proprietà pubblica | ContextMenuStrip | (Ereditato da EditorContainer)
Proprietà protetta | CurrencyManager | (Ereditato da TreeList)
Proprietà pubblica | Cursor | (Ereditato da TreeList)
Proprietà pubblica | CustomizationForm | (Ereditato da TreeList)
Proprietà pubblica | CustomizationFormBounds | (Ereditato da TreeList)
Proprietà pubblica | CustomizationRowCount | Obsoleto. (Ereditato da TreeList)
Proprietà protetta | Data | (Ereditato da TreeList)
Proprietà pubblica | DataMember | (Ereditato da TreeList)
Proprietà pubblica | DataSource | (Ereditato da TreeList)
Proprietà protetta | DefaultSize | (Ereditato da TreeList)
Proprietà protetta | DirectXProvider | (Ereditato da TreeList)
Proprietà protetta | DirectXScroller | (Ereditato da TreeList)
Proprietà pubblica | DragExpandDelay | Obsoleto. (Ereditato da TreeList)
Proprietà pubblica | DragNodesMode | Obsoleto. (Ereditato da TreeList)
Proprietà protetta | DXAccessible | (Ereditato da TreeList)
Proprietà protetta | Editable | (Ereditato da TreeList)
Proprietà protetta | EditFormController | (Ereditato da TreeList)
Proprietà pubblica | EditingValue | (Ereditato da TreeList)
Proprietà protetta | EditorHelper | (Ereditato da EditorContainer)
Proprietà protetta | ElementsLookAndFeel | (Ereditato da TreeList)
Proprietà pubblica | EmptyTreeHtmlTemplate | (Ereditato da TreeList)
Proprietà protetta | EnableDirectXPaint | (Ereditato da TreeList)
Proprietà pubblica | EnableDynamicLoading | (Ereditato da TreeList)
Proprietà pubblica | EnableEnhancedScrolling | (Ereditato da TreeList)
Proprietà protetta | EnableEnhancedSorting | (Ereditato da TreeList)
Proprietà protetta | EnableFirstPaintTrigger | (Ereditato da EditorContainer)
Proprietà pubblica | EnableImprovedColumnSizing | (Ereditato da TreeList)
Proprietà protetta | ErrorInfo | (Ereditato da TreeList)
Proprietà protetta | ExcelFilteringProvider | (Ereditato da TreeList)
Proprietà protetta | ExceptionThrown | (Ereditato da TreeList)
Proprietà pubblica | ExternalRepository | (Ereditato da EditorContainer)
Proprietà protetta | ExtraFilter | (Ereditato da TreeList)
Proprietà protetta | ExtraFilterCriteria | (Ereditato da TreeList)
Proprietà protetta | ExtraFilterHightlightText | (Ereditato da TreeList)
Proprietà protetta | FilterColumnsProvider | (Ereditato da TreeList)
Proprietà protetta | FilterHelper | (Ereditato da TreeList)
Proprietà protetta | FilteringService | (Ereditato da TreeList)
Proprietà pubblica | FilterPanelText | (Ereditato da TreeList)
Proprietà protetta | FilterPopup | (Ereditato da TreeList)
Proprietà protetta | FindFilterCriteria | (Ereditato da TreeList)
Proprietà pubblica | FindFilterText | (Ereditato da TreeList)
Proprietà protetta | FindPanel | (Ereditato da TreeList)
Proprietà pubblica | FindPanelVisible | (Ereditato da TreeList)
Proprietà protetta | FireOnLoadOnPaint | (Ereditato da TreeList)
Proprietà pubblica | FixedLineWidth | (Ereditato da TreeList)
Proprietà protetta | FocusedCellIndex | (Ereditato da TreeList)
Proprietà pubblica | FocusedColumn | (Ereditato da TreeList)
Proprietà pubblica | FocusedNode | (Ereditato da TreeList)
Proprietà protetta | FocusedRow | (Ereditato da TreeList)
Proprietà protetta | FocusedRowIndex | (Ereditato da TreeList)
Proprietà pubblica | FocusedValue | (Ereditato da TreeList)
Proprietà pubblica | FooterPanelHeight | (Ereditato da TreeList)
Proprietà protetta | ForceLoadingPanel | (Ereditato da TreeList)
Proprietà pubblica | ForeColor | (Ereditato da EditorContainer)
Proprietà pubblica | FormatConditions | (Ereditato da TreeList)
Proprietà pubblica | FormatRules | (Ereditato da TreeList)
Proprietà pubblica | GroupButtonSize | Obsoleto. (Ereditato da TreeList)
Proprietà protetta | Handler | (Ereditato da TreeList)
Proprietà protetta | HasAccessible | (Ereditato da TreeList)
Proprietà protetta | HasAllColumnsFixedRight | (Ereditato da TreeList)
Proprietà protetta | HasBands | (Ereditato da TreeList)
Proprietà pubblica | HasColumnErrors | (Ereditato da TreeList)
Proprietà protetta | HasCustomNodeCellEdit | (Ereditato da TreeList)
Proprietà pubblica | HasFocus | (Ereditato da TreeList)
Proprietà protetta | HasHierarchicalColumn | (Ereditato da TreeList)
Proprietà protetta | HasTreeViewColumn | (Ereditato da TreeList)
Proprietà protetta | HeaderLayoutCalculator | (Ereditato da TreeList)
Proprietà protetta | HeaderWidthCalculator | (Ereditato da TreeList)
Proprietà pubblica | HierarchyColumn | (Ereditato da TreeList)
Proprietà pubblica | HierarchyColumnIndent | (Ereditato da TreeList)
Proprietà pubblica | HierarchyColumnName | (Ereditato da TreeList)
Proprietà pubblica | HierarchyFieldName | (Ereditato da TreeList)
Proprietà pubblica | HorzScrollStep | (Ereditato da TreeList)
Proprietà pubblica | HorzScrollVisibility | (Ereditato da TreeList)
Proprietà protetta | HtmlContext | (Ereditato da TreeList)
Proprietà pubblica | HtmlImages | (Ereditato da TreeList)
Proprietà protetta | HtmlObjectCache | (Ereditato da TreeList)
Proprietà pubblica | HtmlTemplates | (Ereditato da TreeList)
Proprietà protetta | IBasePrintableCreatesIntersectedBricks | (Ereditato da TreeList)
Proprietà pubblica | ImageIndexFieldName | (Ereditato da TreeList)
Proprietà protetta | IncrementalText | (Ereditato da TreeList)
Proprietà pubblica | IndicatorWidth | (Ereditato da TreeList)
Proprietà protetta | IsAllowBusyIndicator | (Ereditato da TreeList)
Proprietà protetta | IsAllowBusyPanel | (Ereditato da TreeList)
Proprietà protetta | IsAlt | (Ereditato da TreeList)
Proprietà protetta | IsAttachedToSearchControl | (Ereditato da TreeList)
Proprietà protetta | IsAutoWidth | (Ereditato da TreeList)
Proprietà protetta | IsCellSelect | (Ereditato da TreeList)
Proprietà protetta | IsClosingEditor | (Ereditato da TreeList)
Proprietà protetta | IsColumnHeaderAutoHeight | (Ereditato da TreeList)
Proprietà protetta | IsControl | (Ereditato da TreeList)
Proprietà protetta | IsDataReady | (Ereditato da TreeList)
Proprietà protetta | IsDeserializing | (Ereditato da TreeList)
Proprietà pubblica | IsDesignMode | (Ereditato da EditorContainer)
Proprietà protetta | IsDynamicLoadingAllowed | (Ereditato da TreeList)
Proprietà protetta | IsEditFormMode | (Ereditato da TreeList)
Proprietà protetta | IsFilterPopupActive | (Ereditato da TreeList)
Proprietà protetta | IsFindFilterActive | (Ereditato da TreeList)
Proprietà pubblica | IsFindPanelVisible | (Ereditato da TreeList)
Proprietà protetta | IsFocusedNodeChangedLocked | (Ereditato da TreeList)
Proprietà protetta | IsFocusedNodeDataModified | (Ereditato da TreeList)
Proprietà protetta | IsGroupDeleteOperation | (Ereditato da TreeList)
Proprietà protetta | IsHScrollBarVisible | (Ereditato da TreeList)
Proprietà protetta | IsInitialized | (Ereditato da EditorContainer)
Proprietà protetta | IsIniting | (Ereditato da TreeList)
Proprietà pubblica | IsLoading | (Ereditato da EditorContainer)
Proprietà protetta | IsLockDirectXRendering | (Ereditato da TreeList)
Proprietà protetta | IsLockExpandCollapse | (Ereditato da TreeList)
Proprietà protetta | IsLockUpdate | (Ereditato da TreeList)
Proprietà pubblica | IsLookUpMode | (Ereditato da TreeList)
Proprietà protetta | IsMultiSelect | (Ereditato da TreeList)
Proprietà protetta | IsNotificationInfoVisible | (Ereditato da TreeList)
Proprietà protetta | IsPainting | (Ereditato da TreeList)
Proprietà protetta | IsPixelScrolling | (Ereditato da TreeList)
Proprietà protetta | IsPopupEditFormVisible | (Ereditato da TreeList)
Proprietà pubblica | IsPrinting | (Ereditato da TreeList)
Proprietà pubblica | IsPrintingAvailable | (Ereditato da TreeList)
Proprietà protetta | IsRightToLeft | (Ereditato da TreeList)
Proprietà protetta | IsRowCountReady | (Ereditato da TreeList)
Proprietà protetta | IsScrollAnimationInProgress | (Ereditato da TreeList)
Proprietà protetta | IsSearchMode | (Ereditato da TreeList)
Proprietà protetta | IsSerializing | (Ereditato da TreeList)
Proprietà protetta | IsShift | (Ereditato da TreeList)
Proprietà protetta | IsSorted | (Ereditato da TreeList)
Proprietà protetta | IsUnboundLoad | (Ereditato da TreeList)
Proprietà pubblica | IsUnboundMode | (Ereditato da TreeList)
Proprietà protetta | IsUpdateSize | (Ereditato da TreeList)
Proprietà protetta | IsVirtualMode | (Ereditato da TreeList)
Proprietà protetta | IsVScrollBarVisible | (Ereditato da TreeList)
Proprietà pubblica | KeyFieldName | (Ereditato da TreeList)
Proprietà pubblica | LayoutVersion | Obsoleto. (Ereditato da TreeList)
Proprietà pubblica | LeftCoord | (Ereditato da TreeList)
Proprietà pubblica | LoadingPanelVisible | (Ereditato da TreeList)
Proprietà pubblica | LookAndFeel | (Ereditato da EditorContainer)
Proprietà protetta | LookAndFeelIgnoreChildren | (Ereditato da EditorContainer)
Proprietà protetta | LookUpDisplayColumn | (Ereditato da TreeList)
Proprietà protetta | LookUpOwner | (Ereditato da TreeList)
Proprietà pubblica | MenuManager | (Ereditato da EditorContainer)
Proprietà protetta | MinRowHeight | (Ereditato da TreeList)
Proprietà pubblica | MinWidth | (Ereditato da TreeList)
Proprietà protetta | MRUFilterPopup | (Ereditato da TreeList)
Proprietà pubblica | MRUFilters | (Ereditato da TreeList)
Proprietà protetta | NewItemNode | (Ereditato da TreeList)
Proprietà pubblica | NewItemRowText | (Ereditato da TreeList)
Proprietà pubblica | NodeHtmlTemplate | (Ereditato da TreeList)
Proprietà pubblica | Nodes | (Ereditato da TreeList)
Proprietà pubblica | NodesIterator | (Ereditato da TreeList)
Proprietà pubblica | NonColumnFilterCriteria | (Ereditato da TreeList)
Proprietà pubblica | NonColumnFilterString | (Ereditato da TreeList)
Proprietà protetta | NotificationInfo | (Ereditato da TreeList)
Proprietà protetta | OfficeScroller | (Ereditato da TreeList)
Proprietà pubblica | OptionsBehavior | (Ereditato da TreeList)
Proprietà pubblica | OptionsClipboard | (Ereditato da TreeList)
Proprietà pubblica | OptionsCustomization | (Ereditato da TreeList)
Proprietà pubblica | OptionsDragAndDrop | (Ereditato da TreeList)
Proprietà pubblica | OptionsEditForm | (Ereditato da TreeList)
Proprietà pubblica | OptionsFilter | (Ereditato da TreeList)
Proprietà pubblica | OptionsFind | (Ereditato da TreeList)
Proprietà pubblica | OptionsHtmlTemplate | (Ereditato da TreeList)
Proprietà pubblica | OptionsLayout | (Ereditato da TreeList)
Proprietà pubblica | OptionsMenu | (Ereditato da TreeList)
Proprietà pubblica | OptionsNavigation | (Ereditato da TreeList)
Proprietà pubblica | OptionsPrint | (Ereditato da TreeList)
Proprietà pubblica | OptionsScrollAnnotations | (Ereditato da TreeList)
Proprietà pubblica | OptionsSelection | (Ereditato da TreeList)
Proprietà pubblica | OptionsView | (Ereditato da TreeList)
Proprietà pubblica | Painter | (Ereditato da TreeList)
Proprietà pubblica | ParentFieldName | (Ereditato da TreeList)
Proprietà protetta | Position | (Ereditato da TreeList)
Proprietà protetta | PressedBand | (Ereditato da TreeList)
Proprietà protetta | PressedColumn | (Ereditato da TreeList)
Proprietà protetta | PressedNode | (Ereditato da TreeList)
Proprietà pubblica | PreviewFieldName | (Ereditato da TreeList)
Proprietà pubblica | PreviewIndent | (Ereditato da TreeList)
Proprietà pubblica | PreviewLineCount | (Ereditato da TreeList)
Proprietà protetta | Printer | (Ereditato da TreeList)
Proprietà protetta | PrinterCore | (Ereditato da TreeList)
Proprietà protetta | ProgressWindow | (Ereditato da TreeList)
Proprietà pubblica | RepositoryItems | (Ereditato da EditorContainer)
Proprietà pubblica | RootValue | (Ereditato da TreeList)
Proprietà protetta | RowCount | (Ereditato da TreeList)
Proprietà pubblica | RowHeight | (Ereditato da TreeList)
Proprietà protetta | ScaleDPI | (Ereditato da EditorContainer)
Proprietà pubblica | ScaleFactor | (Ereditato da EditorContainer)
Proprietà protetta | ScaleHelper | (Ereditato da EditorContainer)
Proprietà protetta | ScrollInfo | (Ereditato da TreeList)
Proprietà pubblica | SelectedHtmlText | (Ereditato da TreeList)
Proprietà pubblica | SelectImageList | (Ereditato da TreeList)
Proprietà pubblica | Selection | (Ereditato da TreeList)
Proprietà protetta | SelectionRange | (Ereditato da TreeList)
Proprietà pubblica | ShowButtonMode | (Ereditato da TreeList)
Proprietà protetta | ShowEditorAfterAnimatedScroll | (Ereditato da TreeList)
Proprietà protetta | ShowPreview | (Ereditato da TreeList)
Proprietà protetta | SizedBand | (Ereditato da TreeList)
Proprietà protetta | SizedColumn | (Ereditato da TreeList)
Proprietà protetta | SmartVisibility | (Ereditato da TreeList)
Proprietà pubblica | SortedColumnCount | (Ereditato da TreeList)
Proprietà pubblica | State | (Ereditato da TreeList)
Proprietà pubblica | StateImageList | (Ereditato da TreeList)
Proprietà pubblica | SyncCheckStateWithSourceOnChecking | (Ereditato da TreeList)
Proprietà pubblica | Text | (Ereditato da EditorContainer)
Proprietà pubblica | ToolTipController | (Ereditato da EditorContainer)
Proprietà protetta | TopVisibleNode | (Ereditato da TreeList)
Proprietà pubblica | TopVisibleNodeIndex | (Ereditato da TreeList)
Proprietà pubblica | TopVisibleNodePixel | (Ereditato da TreeList)
Proprietà pubblica | TreeLevelWidth | (Ereditato da TreeList)
Proprietà pubblica | TreeLineStyle | (Ereditato da TreeList)
Proprietà pubblica | TreeListDisposing | (Ereditato da TreeList)
Proprietà pubblica | TreeViewColumn | (Ereditato da TreeList)
Proprietà pubblica | TreeViewColumnName | (Ereditato da TreeList)
Proprietà pubblica | TreeViewFieldName | (Ereditato da TreeList)
Proprietà pubblica | UpdateTopVisibleNodeIndexOnCollapse | (Ereditato da TreeList)
Proprietà protetta | UseBandsAdvancedHorizontalNavigation | (Ereditato da TreeList)
Proprietà protetta | UseBandsAdvancedVerticalNavigation | (Ereditato da TreeList)
Proprietà pubblica | UseDirectXPaint | (Ereditato da TreeList)
Proprietà pubblica | UseDisabledStatePainter | (Ereditato da TreeList)
Proprietà protetta | UseStandardFilter | (Ereditato da TreeList)
Proprietà pubblica | VertScrollVisibility | (Ereditato da TreeList)
Proprietà pubblica | ViewInfo | (Ereditato da TreeList)
Proprietà pubblica | ViewStyle | (Ereditato da TreeList)
Proprietà protetta | VirtualDataHelper | (Ereditato da TreeList)
Proprietà pubblica | VisibleColumnCount | Obsoleto. (Ereditato da TreeList)
Proprietà pubblica | VisibleColumns | (Ereditato da TreeList)
Proprietà pubblica | VisibleNodesCount | (Ereditato da TreeList)
Proprietà protetta | WorkAsLookup | (Ereditato da TreeList)
Torna su
Vedi anche

Documentazione

Classe MyTreeList
Namespace DedNet.Controls


Metodi di MyTreeList

Il tipo MyTreeList espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AccessibleNotifyClients(AccessibleEvents, BaseAccessible) | (Ereditato da TreeList)
Metodo pubblico | AccessibleNotifyClients(AccessibleEvents, Int32, Int32) | (Ereditato da TreeList)
Metodo pubblico | AddFilter(CriteriaOperator) | (Ereditato da TreeList)
Metodo pubblico | AddFilter(String) | (Ereditato da TreeList)
Metodo protetto | AddToDefaultTooltipController | (Ereditato da EditorContainer)
Metodo protetto | AllowAutoFilterCondition | (Ereditato da TreeList)
Metodo protetto | AnimateKeyboardNavigation | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, TreeListNode) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, TreeListNode, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, TreeListNode, CheckState) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, CheckState) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, TreeListNode, CheckState, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, CheckState, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, TreeListNode, CheckState, NodeCheckBoxStyle, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, Int32, Int32, Int32) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, Int32, Int32, Int32, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, Int32, Int32, Int32, CheckState) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, Int32, Int32, Int32, CheckState, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, Int32, Int32, Int32, CheckState, NodeCheckBoxStyle, Object) | (Ereditato da TreeList)
Metodo protetto | ApplyFilter | (Ereditato da TreeList)
Metodo pubblico | ApplyFindFilter | (Ereditato da TreeList)
Metodo protetto | BeforeShowEditForm | (Ereditato da TreeList)
Metodo pubblico | BeginDelete | (Ereditato da TreeList)
Metodo protetto | BeginDragDrop | (Ereditato da TreeList)
Metodo protetto | BeginExpandCollapse | (Ereditato da TreeList)
Metodo pubblico | BeginInit | (Ereditato da EditorContainer)
Metodo protetto | BeginLockListChanged | (Ereditato da TreeList)
Metodo pubblico | BeginSelection | (Ereditato da TreeList)
Metodo pubblico | BeginSort | (Ereditato da TreeList)
Metodo pubblico | BeginUnboundLoad | (Ereditato da TreeList)
Metodo pubblico | BeginUpdate | (Ereditato da TreeList)
Metodo pubblico | BestFitColumns | (Ereditato da TreeList)
Metodo pubblico | BestFitColumns(Boolean) | (Ereditato da TreeList)
Metodo pubblico | BindCommand(Object, String, FuncObject) | (Ereditato da TreeList)
Metodo pubblico | BindCommand(ExpressionAction, Object, String, FuncObject) | (Ereditato da TreeList)
Metodo pubblico | BindCommand``1(ExpressionActionUMP, Object, String, FuncUMP) | (Ereditato da TreeList)
Metodo protetto | CalcActiveEditorBounds | (Ereditato da TreeList)
Metodo protetto | CalcColumnBestWidth | (Ereditato da TreeList)
Metodo pubblico | CalcHitInfo | (Ereditato da TreeList)
Metodo protetto | CalcHScrollRange | (Ereditato da TreeList)
Metodo protetto | CalcNodeAutoHeight | (Ereditato da TreeList)
Metodo protetto | CalcRowCount | (Ereditato da TreeList)
Metodo protetto | CalcScrollClientRect | (Ereditato da TreeList)
Metodo protetto | CalculateScrollBars | (Ereditato da TreeList)
Metodo protetto | CalculateVisibleRowsAreaHeight | (Ereditato da TreeList)
Metodo pubblico | CancelCurrentEdit | (Ereditato da TreeList)
Metodo protetto | CancelDirectXRendering | (Ereditato da TreeList)
Metodo protetto | CancelLockListChanged | (Ereditato da TreeList)
Metodo protetto | CancelSelection | (Ereditato da TreeList)
Metodo pubblico | CancelSort | (Ereditato da TreeList)
Metodo pubblico | CancelUpdate | (Ereditato da TreeList)
Metodo protetto | CanClearAllSorting | (Ereditato da TreeList)
Metodo protetto | CanCloneChildren | (Ereditato da TreeList)
Metodo protetto | CanFilterByColumnEdit | (Ereditato da TreeList)
Metodo pubblico | CanFilterColumn | (Ereditato da TreeList)
Metodo protetto | CanFindColumn | (Ereditato da TreeList)
Metodo protetto | CanFocusNode | (Ereditato da TreeList)
Metodo protetto | CanHandleTouchGestures | (Ereditato da EditorContainer)
Metodo protetto | CanIncrementalSearch | (Ereditato da TreeList)
Metodo pubblico | CanIndentNodes | (Ereditato da TreeList)
Metodo protetto | CanMove | (Ereditato da TreeList)
Metodo protetto | CanMoveBand | (Ereditato da TreeList)
Metodo protetto | CanMoveColumn | (Ereditato da TreeList)
Metodo pubblico | CanOutdentNodes | (Ereditato da TreeList)
Metodo protetto | CanResizeBand | (Ereditato da TreeList)
Metodo protetto | CanResizeColumn | (Ereditato da TreeList)
Metodo protetto | CanShowHScrollBar | (Ereditato da TreeList)
Metodo protetto | CanShowHScrollBarCore | (Ereditato da TreeList)
Metodo protetto | CanShowVScrollBar | (Ereditato da TreeList)
Metodo protetto | CanSortByColumnEdit | (Ereditato da TreeList)
Metodo pubblico | CanSortColumn | (Ereditato da TreeList)
Metodo protetto | CanStartTouchScrolling | (Ereditato da TreeList)
Metodo protetto | ChangeLeftCoord | (Ereditato da TreeList)
Metodo pubblico | CheckAll | (Ereditato da TreeList)
Metodo protetto | CheckAllowGestures | (Ereditato da TreeList)
Metodo protetto | CheckAllowNotifications | (Ereditato da TreeList)
Metodo protetto | CheckData | (Ereditato da TreeList)
Metodo protetto | CheckIncreaseVisibleRows | (Ereditato da TreeList)
Metodo protetto | CheckModifierKeys | (Ereditato da TreeList)
Metodo protetto | CheckNeedScale | (Ereditato da EditorContainer)
Metodo protetto | CheckRightToLeft | (Ereditato da EditorContainer)
Metodo protetto | CheckSearchMode | (Ereditato da TreeList)
Metodo protetto | CheckTopVisibleNodeAfterItemAdded | (Ereditato da TreeList)
Metodo protetto | CheckTopVisibleNodePixelValue | (Ereditato da TreeList)
Metodo pubblico | ClearColumnErrors | (Ereditato da TreeList)
Metodo pubblico | ClearColumnFilter | (Ereditato da TreeList)
Metodo protetto | ClearColumnFilterCore(String) | (Ereditato da TreeList)
Metodo protetto | ClearColumnFilterCore(TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | ClearColumnsFilter | (Ereditato da TreeList)
Metodo pubblico | ClearDocument | (Ereditato da TreeList)
Metodo pubblico | ClearFindFilter | (Ereditato da TreeList)
Metodo pubblico | ClearFocusedColumn | (Ereditato da TreeList)
Metodo pubblico | ClearNodes | (Ereditato da TreeList)
Metodo pubblico | ClearSelection | (Ereditato da TreeList)
Metodo pubblico | ClearSorting | (Ereditato da TreeList)
Metodo protetto | ClearVisibleIndicesCache | (Ereditato da TreeList)
Metodo pubblico | CloseEditForm | (Ereditato da TreeList)
Metodo pubblico | CloseEditor | (Ereditato da TreeList)
Metodo protetto | CloseEditor(Boolean) | (Ereditato da TreeList)
Metodo pubblico | CollapseAll | (Ereditato da TreeList)
Metodo protetto | CollapseAllCore | (Ereditato da TreeList)
Metodo pubblico | CollapseToLevel | (Ereditato da TreeList)
Metodo pubblico | ColumnsCustomization | (Ereditato da TreeList)
Metodo pubblico | ColumnsCustomization(Point) | (Ereditato da TreeList)
Metodo protetto | ControlRowSourceSelectedChanged | (Ereditato da TreeList)
Metodo protetto | ControlRowSourceVisibleChanged | (Ereditato da TreeList)
Metodo pubblico | ConvertFormatConditionToFormatRules | (Ereditato da TreeList)
Metodo pubblico | CopyNode(TreeListNode, TreeListNode, Boolean) | (Ereditato da TreeList)
Metodo pubblico | CopyNode(TreeListNode, TreeListNode, Boolean, Boolean) | (Ereditato da TreeList)
Metodo pubblico | CopyNode(TreeListNode, TreeListNode, Boolean, Int32) | (Ereditato da TreeList)
Metodo pubblico | CopyNode(TreeListNode, TreeListNode, Boolean, Boolean, Int32) | (Ereditato da TreeList)
Metodo protetto | CopyNodeCore | (Ereditato da TreeList)
Metodo pubblico | CopyNodes(IEnumerableTreeListNode, TreeListNode, Boolean, Int32) | (Ereditato da TreeList)
Metodo pubblico | CopyNodes(IEnumerableTreeListNode, TreeListNode, Boolean, Boolean, Int32) | (Ereditato da TreeList)
Metodo pubblico | CopyToClipboard | (Ereditato da TreeList)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da TreeList)
Metodo protetto | CreateAccessibleDataRow | (Ereditato da TreeList)
Metodo protetto | CreateAccessibleInstance | (Ereditato da TreeList)
Metodo protetto | CreateAllOptions | (Ereditato da TreeList)
Metodo protetto | CreateAnnotationManager | (Ereditato da TreeList)
Metodo protetto | CreateAppearances | (Ereditato da TreeList)
Metodo protetto | CreateAutoFilterCriterion | (Ereditato da TreeList)
Metodo protetto | CreateBands | (Ereditato da TreeList)
Metodo protetto | CreateCheckBoxesStrategy | (Ereditato da TreeList)
Metodo protetto | CreateCheckedListFilterPopup | (Ereditato da TreeList)
Metodo protetto | CreateColumn | (Ereditato da TreeList)
Metodo protetto | CreateColumnEditViewInfo | (Ereditato da TreeList)
Metodo protetto | CreateColumnFilterCriteriaByValue(TreeListColumn, Object) | (Ereditato da TreeList)
Metodo protetto | CreateColumnFilterCriteriaByValue(TreeListColumn, Object, Boolean) | (Ereditato da TreeList)
Metodo protetto | CreateColumnFilterPopup | (Ereditato da TreeList)
Metodo protetto | CreateColumns | (Ereditato da TreeList)
Metodo pubblico | CreateCustomization | Obsoleto. (Ereditato da TreeList)
Metodo protetto | CreateCustomizationForm | (Ereditato da TreeList)
Metodo protetto | CreateData | (Ereditato da TreeList)
Metodo protetto | CreateDataViewData | (Ereditato da TreeList)
Metodo protetto | CreateDateFilterPopup | (Ereditato da TreeList)
Metodo protetto | CreateDragNodesProvider | (Ereditato da TreeList)
Metodo protetto | CreateEditFormController | (Ereditato da TreeList)
Metodo protetto | CreateElementsLookAndFeel | (Ereditato da TreeList)
Metodo protetto | CreateExcelFilterPopup | (Ereditato da TreeList)
Metodo protetto | CreateFilterColumnCollection | (Ereditato da TreeList)
Metodo protetto | CreateFilterColumnRuleCollection | (Ereditato da TreeList)
Metodo protetto | CreateFilterColumnsProvider | (Ereditato da TreeList)
Metodo protetto | CreateFilterCriteriaBindingTarget | (Ereditato da TreeList)
Metodo protetto | CreateFilterEditorForm | (Ereditato da TreeList)
Metodo protetto | CreateFilterHelper | (Ereditato da TreeList)
Metodo protetto | CreateFindPanel | (Ereditato da TreeList)
Metodo protetto | CreateFindPanelCore | (Ereditato da TreeList)
Metodo pubblico | CreateGraphicsCache | (Ereditato da TreeList)
Metodo protetto | CreateHandler | (Ereditato da TreeList)
Metodo protetto | CreateHeaderLayoutCalculator | (Ereditato da TreeList)
Metodo protetto | CreateHeaderWidthCalculator | (Ereditato da TreeList)
Metodo protetto | CreateHelper | (Ereditato da TreeList)
Metodo protetto | CreateHierarchicalListData | (Ereditato da TreeList)
Metodo protetto | CreateHtmlContext | (Ereditato da TreeList)
Metodo protetto | CreateHyperlinkClickEventArgs | (Ereditato da TreeList)
Metodo protetto | CreateInternalRepository | (Ereditato da EditorContainer)
Metodo protetto | CreateListColumnFilterPopup | (Ereditato da TreeList)
Metodo protetto | CreateListData | (Ereditato da TreeList)
Metodo protetto | CreateLoadingAnimator | (Ereditato da TreeList)
Metodo protetto | CreateLoadingPanel | (Ereditato da TreeList)
Metodo protetto | CreateLookAndFeel | (Ereditato da EditorContainer)
Metodo protetto | CreateNewItemNode | (Ereditato da TreeList)
Metodo protetto | CreateNode(Int32, TreeListNodes) | (Ereditato da TreeList)
Metodo protetto | CreateNode(Int32, TreeListNodes, Object) | (Ereditato da TreeList)
Metodo protetto | CreateNodes | (Ereditato da TreeList)
Metodo protetto | CreateNodesComparer | (Ereditato da TreeList)
Metodo protetto | CreateNodesIterator | (Ereditato da TreeList)
Metodo protetto | CreateNotificationInfo | (Ereditato da TreeList)
Metodo protetto | CreateOfficeScroller | (Ereditato da TreeList)
Metodo protetto | CreateOptionsBehavior | (Ereditato da TreeList)
Metodo protetto | CreateOptionsClipboard | (Ereditato da TreeList)
Metodo protetto | CreateOptionsCustomization | (Ereditato da TreeList)
Metodo protetto | CreateOptionsDragAndDrop | (Ereditato da TreeList)
Metodo protetto | CreateOptionsEditForm | (Ereditato da TreeList)
Metodo protetto | CreateOptionsFilter | (Ereditato da TreeList)
Metodo protetto | CreateOptionsFind | (Ereditato da TreeList)
Metodo protetto | CreateOptionsHtmlTemplate | (Ereditato da TreeList)
Metodo protetto | CreateOptionsLayout | (Ereditato da TreeList)
Metodo protetto | CreateOptionsMenu | (Ereditato da TreeList)
Metodo protetto | CreateOptionsNavigation | (Ereditato da TreeList)
Metodo protetto | CreateOptionsPrint | (Ereditato da TreeList)
Metodo protetto | CreateOptionsScrollAnnotations | (Ereditato da TreeList)
Metodo protetto | CreateOptionsSelection | (Ereditato da TreeList)
Metodo protetto | CreateOptionsView | (Ereditato da TreeList)
Metodo protetto | CreatePainter | (Ereditato da TreeList)
Metodo protetto | CreatePrinter | (Ereditato da TreeList)
Metodo protetto | CreateProvider | (Ereditato da TreeList)
Metodo protetto | CreateScrollInfo | (Ereditato da TreeList)
Metodo protetto | CreateSelection | (Ereditato da TreeList)
Metodo protetto | CreateUnboundData | (Ereditato da TreeList)
Metodo protetto | CreateViewInfo | (Ereditato da TreeList)
Metodo protetto | CreateVirtualData | (Ereditato da TreeList)
Metodo protetto | CreateVirtualDataHelper | (Ereditato da TreeList)
Metodo protetto | CurrencyManager_ItemChanged | (Ereditato da TreeList)
Metodo protetto | CurrencyManager_PositionChanged | (Ereditato da TreeList)
Metodo protetto | DeferredLoadChildren | (Ereditato da TreeList)
Metodo protetto | DelayedInvalidate | (Ereditato da TreeList)
Metodo pubblico | DeleteNode | (Ereditato da TreeList)
Metodo pubblico | DeleteNodes | (Ereditato da TreeList)
Metodo pubblico | DeleteSelectedNodes | (Ereditato da TreeList)
Metodo pubblico | DestroyCustomization | (Ereditato da TreeList)
Metodo protetto | DestroyDirectXProvider | (Ereditato da EditorContainer)
Metodo protetto | DestroyFindPanel | (Ereditato da TreeList)
Metodo protetto | Dispose | (Ereditato da TreeList)
Metodo protetto | DoDataSourceChanged | (Ereditato da TreeList)
Metodo protetto | DoDpiChange | (Ereditato da EditorContainer)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da TreeList)
Metodo protetto | DoDragDrop | (Ereditato da TreeList)
Metodo pubblico | DoDragDropNode | (Ereditato da TreeList)
Metodo pubblico | DoDragDropNodes | (Ereditato da TreeList)
Metodo protetto | DoFilterNode | (Ereditato da TreeList)
Metodo protetto | DoForEachBand | (Ereditato da TreeList)
Metodo pubblico | DoIncrementalSearch | (Ereditato da TreeList)
Metodo protetto | DoShowTreeListMenu(TreeListMenu, TreeListHitTest) | (Ereditato da TreeList)
Metodo protetto | DoShowTreeListMenu(TreeListMenu, Control, Point) | (Ereditato da TreeList)
Metodo protetto | DoTopVisibleNodeChanged | (Ereditato da TreeList)
Metodo pubblico | EndCurrentEdit | (Ereditato da TreeList)
Metodo pubblico | EndCurrentEdit(Boolean) | (Ereditato da TreeList)
Metodo pubblico | EndDelete | (Ereditato da TreeList)
Metodo protetto | EndDragDrop | (Ereditato da TreeList)
Metodo protetto | EndEdit | (Ereditato da TreeList)
Metodo protetto | EndExpandCollapse | (Ereditato da TreeList)
Metodo pubblico | EndInit | (Ereditato da EditorContainer)
Metodo pubblico | EndSelection | (Ereditato da TreeList)
Metodo pubblico | EndSort | (Ereditato da TreeList)
Metodo pubblico | EndUnboundLoad | (Ereditato da TreeList)
Metodo pubblico | EndUpdate | (Ereditato da TreeList)
Metodo protetto | EnsureControlRowSource | (Ereditato da TreeList)
Metodo protetto | EnsureEditFormController | (Ereditato da TreeList)
Metodo protetto | EnsureFilteringClientDataBinding | (Ereditato da TreeList)
Metodo protetto | ExecutePrinterAction | (Ereditato da TreeList)
Metodo pubblico | ExpandAll | (Ereditato da TreeList)
Metodo protetto | ExpandAllCore | (Ereditato da TreeList)
Metodo protetto | ExpandToLast | (Ereditato da TreeList)
Metodo pubblico | ExpandToLevel | (Ereditato da TreeList)
Metodo protetto | ExpandToRoot | (Ereditato da TreeList)
Metodo protetto | Export(ExportTarget, Stream) | (Ereditato da TreeList)
Metodo protetto | Export(ExportTarget, String) | (Ereditato da TreeList)
Metodo protetto | Export(ExportTarget, Stream, ExportOptionsBase) | (Ereditato da TreeList)
Metodo protetto | Export(ExportTarget, String, ExportOptionsBase) | (Ereditato da TreeList)
Metodo pubblico | ExportToCsv(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToCsv(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToCsv(Stream, CsvExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToCsv(String, CsvExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToDocx(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToDocx(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToDocx(Stream, DocxExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToDocx(String, DocxExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToHtml(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToHtml(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToHtml(Stream, HtmlExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToHtml(String, HtmlExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToMht(Stream, MhtExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToMht(String, MhtExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToMht(String, String) | Obsoleto. (Ereditato da TreeList)
Metodo pubblico | ExportToMht(Stream, String, String, Boolean) | Obsoleto. (Ereditato da TreeList)
Metodo pubblico | ExportToMht(String, String, String, Boolean) | Obsoleto. (Ereditato da TreeList)
Metodo pubblico | ExportToPdf(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToPdf(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToPdf(Stream, PdfExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToPdf(String, PdfExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToRtf(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToRtf(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToText(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToText(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToText(Stream, TextExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToText(String, TextExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToXls(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToXls(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToXls(Stream, XlsExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToXls(String, XlsExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToXlsx(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToXlsx(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToXlsx(Stream, XlsxExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToXlsx(String, XlsxExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToXml(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToXml(String) | (Ereditato da TreeList)
Metodo protetto | ExportToXmlCore | (Ereditato da TreeList)
Metodo protetto | ExtractTemplateRootNode | (Ereditato da TreeList)
Metodo pubblico | FilterNodes | (Ereditato da TreeList)
Metodo pubblico | FilterNodes(TreeListNodes) | (Ereditato da TreeList)
Metodo protetto | FilterNodesCore | (Ereditato da TreeList)
Metodo pubblico | FindNode | (Ereditato da TreeList)
Metodo pubblico | FindNodeByFieldValue | (Ereditato da TreeList)
Metodo pubblico | FindNodeByID | (Ereditato da TreeList)
Metodo pubblico | FindNodeByKeyID | (Ereditato da TreeList)
Metodo protetto | FindNodeByParentID | (Ereditato da TreeList)
Metodo pubblico | FindNodes | (Ereditato da TreeList)
Metodo protetto | FindPanelNext | (Ereditato da TreeList)
Metodo protetto | FindPanelPrev | (Ereditato da TreeList)
Metodo pubblico | FireChanged | (Ereditato da TreeList)
Metodo protetto | FitColumns | (Ereditato da TreeList)
Metodo pubblico | FocusNewItemNode | (Ereditato da TreeList)
Metodo protetto | ForceCalcRowCount | (Ereditato da TreeList)
Metodo pubblico | ForceInitialize | (Ereditato da TreeList)
Metodo protetto | ForceSetTopVisibleNodeIndex | (Ereditato da TreeList)
Metodo pubblico | FullCollapse | Obsoleto. (Ereditato da TreeList)
Metodo pubblico | FullExpand | Obsoleto. (Ereditato da TreeList)
Metodo pubblico | FullExpandNode | Obsoleto. (Ereditato da TreeList)
Metodo protetto | GetAccessibilityObjectById | (Ereditato da TreeList)
Metodo protetto | GetAccessibleNodeCell | (Ereditato da TreeList)
Metodo protetto | GetActiveEditorHighAppearance | (Ereditato da TreeList)
Metodo protetto | GetActualAnimationType | (Ereditato da TreeList)
Metodo protetto | GetActualTreeListFilterMode | (Ereditato da TreeList)
Metodo pubblico | GetAllCheckedNodes | (Ereditato da TreeList)
Metodo protetto | GetAllowChangeBandParent | (Ereditato da TreeList)
Metodo protetto | GetAllowColumnFilterPopup | (Ereditato da TreeList)
Metodo protetto | GetAllowFilterEditor | (Ereditato da TreeList)
Metodo protetto | GetAllowFindColumn | (Ereditato da TreeList)
Metodo protetto | GetAllowFocus | (Ereditato da TreeList)
Metodo protetto | GetAllowHighlightFindResults | (Ereditato da TreeList)
Metodo protetto | GetAllowMRUFilterList | (Ereditato da TreeList)
Metodo protetto | GetAutoFilterRowColumnEdit | (Ereditato da TreeList)
Metodo pubblico | GetAutoFilterValue | (Ereditato da TreeList)
Metodo protetto | GetAutoNodeHeight | (Ereditato da TreeList)
Metodo protetto | GetBandRows | (Ereditato da TreeList)
Metodo protetto | GetBandRowsCore | (Ereditato da TreeList)
Metodo protetto | GetBandVisibleIndex | (Ereditato da TreeList)
Metodo protetto | GetCanShowEditor | (Ereditato da TreeList)
Metodo pubblico | GetColumnByColumnHandle | (Ereditato da TreeList)
Metodo pubblico | GetColumnByVisibleIndex | (Ereditato da TreeList)
Metodo protetto | GetColumnDefaultRepositoryItem | (Ereditato da TreeList)
Metodo protetto | GetColumnDefaultRepositoryItemForEditing | (Ereditato da TreeList)
Metodo protetto | GetColumnEdit | (Ereditato da TreeList)
Metodo protetto | GetColumnEditForEditing | (Ereditato da TreeList)
Metodo pubblico | GetColumnError(TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | GetColumnError(TreeListColumn, TreeListNode) | (Ereditato da TreeList)
Metodo pubblico | GetColumnErrorType(TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | GetColumnErrorType(TreeListColumn, TreeListNode) | (Ereditato da TreeList)
Metodo protetto | GetColumnFieldNameSort | (Ereditato da TreeList)
Metodo protetto | GetColumnFilterCriteria | (Ereditato da TreeList)
Metodo protetto | GetColumnFilterMode | (Ereditato da TreeList)
Metodo pubblico | GetColumnHeaderBestWidth | (Ereditato da TreeList)
Metodo protetto | GetColumnName | (Ereditato da TreeList)
Metodo protetto | GetCurrencyManager | (Ereditato da TreeList)
Metodo protetto | GetDataColumnInfo | (Ereditato da TreeList)
Metodo pubblico | GetDataRecordByNode | (Ereditato da TreeList)
Metodo pubblico | GetDataRow | (Ereditato da TreeList)
Metodo protetto | GetDirectXDeviceBackColor | (Ereditato da EditorContainer)
Metodo protetto | GetDirectXProvider | (Ereditato da EditorContainer)
Metodo protetto | GetEditableObject | (Ereditato da TreeList)
Metodo pubblico | GetEditorShowMode | (Ereditato da TreeList)
Metodo protetto | GetEditorViewInfo | (Ereditato da TreeList)
Metodo protetto | GetFilterColumn | (Ereditato da TreeList)
Metodo protetto | GetFilterColumnByTreeListColumn | (Ereditato da TreeList)
Metodo protetto | GetFilterCriteriaDisplayStyle | (Ereditato da TreeList)
Metodo protetto | GetFilterDisplayText | (Ereditato da TreeList)
Metodo protetto | GetFilterDisplayTextByColumn | (Ereditato da TreeList)
Metodo protetto | GetFilterPopupTexts | (Ereditato da TreeList)
Metodo protetto | GetFilterPopupValues(TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | GetFilterPopupValues(TreeListColumn, Boolean) | (Ereditato da TreeList)
Metodo protetto | GetFilterPopupValues(TreeListColumn, CriteriaOperator, Boolean) | (Ereditato da TreeList)
Metodo protetto | GetFilterPopupValues(TreeListColumn, Boolean, Boolean) | (Ereditato da TreeList)
Metodo protetto | GetFilterRowValue(Object) | (Ereditato da TreeList)
Metodo protetto | GetFilterRowValue(TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | GetFindMatchedRanges | (Ereditato da TreeList)
Metodo protetto | GetFindMatchedText | (Ereditato da TreeList)
Metodo protetto | GetFindToColumnsCollection | (Ereditato da TreeList)
Metodo pubblico | GetFocusedDataRow | (Ereditato da TreeList)
Metodo pubblico | GetFocusedDisplayText | (Ereditato da TreeList)
Metodo pubblico | GetFocusedRow | (Ereditato da TreeList)
Metodo pubblico | GetFocusedRowCellDisplayText(String) | (Ereditato da TreeList)
Metodo pubblico | GetFocusedRowCellDisplayText(TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetFocusedRowCellValue(String) | (Ereditato da TreeList)
Metodo pubblico | GetFocusedRowCellValue(TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetGroupSummaryValue | (Ereditato da TreeList)
Metodo protetto | GetHeaderFilterButtonShowMode | (Ereditato da TreeList)
Metodo pubblico | GetHitInfo | Obsoleto. (Ereditato da TreeList)
Metodo protetto | GetImageIndexFromDataSource | (Ereditato da TreeList)
Metodo protetto | GetMaxIndent | (Ereditato da TreeList)
Metodo protetto | GetNativePreviewText | (Ereditato da TreeList)
Metodo pubblico | GetNodeAt(Point) | (Ereditato da TreeList)
Metodo pubblico | GetNodeAt(Int32, Int32) | (Ereditato da TreeList)
Metodo pubblico | GetNodeByVisibleIndex | (Ereditato da TreeList)
Metodo protetto | GetNodeCellRepositoryItem | (Ereditato da TreeList)
Metodo protetto | GetNodeComparer(IComparerTreeListNode) | (Ereditato da TreeList)
Metodo protetto | GetNodeComparer(TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetNodeIndex | (Ereditato da TreeList)
Metodo pubblico | GetNodeList | (Ereditato da TreeList)
Metodo protetto | GetNodeValue(TreeListNode, TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | GetNodeValue(TreeListNode, Object) | (Ereditato da TreeList)
Metodo protetto | GetNodeValue(TreeListNode, String) | (Ereditato da TreeList)
Metodo protetto | GetNonFormattedCaption | (Ereditato da TreeList)
Metodo protetto | GetParentColumnFieldNameSort | (Ereditato da TreeList)
Metodo pubblico | GetRow | (Ereditato da TreeList)
Metodo pubblico | GetRowCellDisplayText(TreeListNode, TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetRowCellDisplayText(TreeListNode, String) | (Ereditato da TreeList)
Metodo pubblico | GetRowCellValue(TreeListNode, TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetRowCellValue(TreeListNode, String) | (Ereditato da TreeList)
Metodo protetto | GetRowsAsFootersCount | (Ereditato da TreeList)
Metodo pubblico | GetScrollAnnotations | (Ereditato da TreeList)
Metodo pubblico | GetSelectedCells | (Ereditato da TreeList)
Metodo pubblico | GetSelectedCells(TreeListNode) | (Ereditato da TreeList)
Metodo protetto | GetShowBandsMode | (Ereditato da TreeList)
Metodo protetto | GetShowFirstLines | (Ereditato da TreeList)
Metodo protetto | GetShowIndentAsRowStyle | (Ereditato da TreeList)
Metodo pubblico | GetSortColumn(Int32) | (Ereditato da TreeList)
Metodo protetto | GetSortColumn(TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetSummaryValue(TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetSummaryValue(TreeListColumn, Boolean) | (Ereditato da TreeList)
Metodo protetto | GetSummaryValueCore | (Ereditato da TreeList)
Metodo protetto | GetSummaryValueEx | (Ereditato da TreeList)
Metodo pubblico | GetToolTipController | (Ereditato da EditorContainer)
Metodo protetto | GetUseDirectXPaint | (Ereditato da TreeList)
Metodo pubblico | GetVisibleIndexByNode | (Ereditato da TreeList)
Metodo protetto | GetVisibleIndexByNodeCore | (Ereditato da TreeList)
Metodo protetto | GetVisibleParentNodesCount | (Ereditato da TreeList)
Metodo pubblico | HideCustomization | (Ereditato da TreeList)
Metodo pubblico | HideEditor | (Ereditato da TreeList)
Metodo protetto | HideEditorCore | (Ereditato da TreeList)
Metodo pubblico | HideFindPanel | (Ereditato da TreeList)
Metodo pubblico | HideLoadingPanel | (Ereditato da TreeList)
Metodo protetto | HookOnLoaded | (Ereditato da EditorContainer)
Metodo pubblico | ImportFromXml(Stream) | (Ereditato da TreeList)
Metodo pubblico | ImportFromXml(String) | (Ereditato da TreeList)
Metodo protetto | ImportFromXmlCore | (Ereditato da TreeList)
Metodo pubblico | IndentNodes | (Ereditato da TreeList)
Metodo protetto | InitFindPanel | (Ereditato da TreeList)
Metodo protetto | InitializeDirectXProvider | (Ereditato da EditorContainer)
Metodo protetto | InitScrollInfo | (Ereditato da TreeList)
Metodo protetto | InternalDeleteNode | (Ereditato da TreeList)
Metodo protetto | InternalDeleteNodeCore | (Ereditato da TreeList)
Metodo protetto | InternalDeleteNodes(DictionaryTreeListNodes, ListTreeListNode) | (Ereditato da TreeList)
Metodo protetto | InternalDeleteNodes(TreeListNodes) | (Ereditato da TreeList)
Metodo protetto | InternalFullCollapseNode | (Ereditato da TreeList)
Metodo protetto | InternalFullExpandNode | (Ereditato da TreeList)
Metodo protetto | InternalGetCustomNodeCellEdit | (Ereditato da TreeList)
Metodo protetto | InternalGetCustomNodeCellStyle | (Ereditato da TreeList)
Metodo pubblico | InternalGetService | (Ereditato da TreeList)
Metodo protetto | InternalNodeAdded | (Ereditato da TreeList)
Metodo protetto | InternalNodeChanged | (Ereditato da TreeList)
Metodo protetto | InternalSetTopVisibleNodePixel | (Ereditato da TreeList)
Metodo pubblico | InvalidateBand | (Ereditato da TreeList)
Metodo pubblico | InvalidateBandPanel | (Ereditato da TreeList)
Metodo pubblico | InvalidateCell | (Ereditato da TreeList)
Metodo pubblico | InvalidateColumnHeader | (Ereditato da TreeList)
Metodo pubblico | InvalidateColumnPanel | (Ereditato da TreeList)
Metodo pubblico | InvalidateFilterPanel | (Ereditato da TreeList)
Metodo pubblico | InvalidateNode | (Ereditato da TreeList)
Metodo pubblico | InvalidateNodes | (Ereditato da TreeList)
Metodo pubblico | InvalidateRow | (Ereditato da TreeList)
Metodo pubblico | InvalidateRowPreview | (Ereditato da TreeList)
Metodo protetto | InvalidateRows | (Ereditato da TreeList)
Metodo pubblico | InvalidateScrollAnnotations | (Ereditato da TreeList)
Metodo pubblico | InvalidateSummaryFooterPanel | (Ereditato da TreeList)
Metodo pubblico | InvokeMenuItemClick | (Ereditato da TreeList)
Metodo protetto | IsAllowDefaultFastBestFit | (Ereditato da TreeList)
Metodo protetto | IsAllowEditForm | (Ereditato da TreeList)
Metodo pubblico | IsAutoFilterNode | (Ereditato da TreeList)
Metodo pubblico | IsCellSelected | (Ereditato da TreeList)
Metodo protetto | IsColumnAllowAutoFilter | (Ereditato da TreeList)
Metodo protetto | IsColumnAllowFilter | (Ereditato da TreeList)
Metodo pubblico | IsColumnAllowFilterEditor | (Ereditato da TreeList)
Metodo protetto | IsColumnFieldNameSortExist | (Ereditato da TreeList)
Metodo protetto | IsColumnFiltered | (Ereditato da TreeList)
Metodo protetto | IsFilterByDisplayText | (Ereditato da TreeList)
Metodo protetto | IsFilterRow | (Ereditato da TreeList)
Metodo protetto | IsImplyNullLikeEmptyStringWhenFiltering | (Ereditato da TreeList)
Metodo protetto | IsInputChar | (Ereditato da TreeList)
Metodo protetto | IsInputKey | (Ereditato da TreeList)
Metodo pubblico | IsNewItemRow | (Ereditato da TreeList)
Metodo protetto | IsParentColumnFieldNameSortExist | (Ereditato da TreeList)
Metodo pubblico | IsRootNode | (Ereditato da TreeList)
Metodo protetto | IsRoundDateTime | (Ereditato da TreeList)
Metodo protetto | IsShowAllValuesInFilterPopup | (Ereditato da TreeList)
Metodo protetto | IsTopNewItemRow | (Ereditato da TreeList)
Metodo protetto | IsUserAutoFilterCondition | (Ereditato da TreeList)
Metodo pubblico | LayoutChanged | (Ereditato da TreeList)
Metodo protetto | LoadDataColumns | (Ereditato da TreeList)
Metodo protetto | LoadDataSource | (Ereditato da TreeList)
Metodo protetto | LockDirectXRendering | (Ereditato da TreeList)
Metodo protetto | LockFilteringUIClientFilterCriteriaBinding | (Ereditato da TreeList)
Metodo pubblico | LockReloadNodes | (Ereditato da TreeList)
Metodo pubblico | MakeColumnVisible | (Ereditato da TreeList)
Metodo protetto | MakeFocusedRowVisible | (Ereditato da TreeList)
Metodo pubblico | MakeNodeVisible | (Ereditato da TreeList)
Metodo protetto | MergeColumnFiltersCore | (Ereditato da TreeList)
Metodo pubblico | MoveFirst | (Ereditato da TreeList)
Metodo protetto | MoveFocusedCell | (Ereditato da TreeList)
Metodo pubblico | MoveLast | (Ereditato da TreeList)
Metodo pubblico | MoveLastVisible | (Ereditato da TreeList)
Metodo pubblico | MoveNext | (Ereditato da TreeList)
Metodo pubblico | MoveNextVisible | (Ereditato da TreeList)
Metodo pubblico | MoveNode(TreeListNode, TreeListNode) | (Ereditato da TreeList)
Metodo pubblico | MoveNode(TreeListNode, TreeListNode, Boolean) | (Ereditato da TreeList)
Metodo pubblico | MoveNode(TreeListNode, TreeListNode, Boolean, Int32) | (Ereditato da TreeList)
Metodo pubblico | MoveNodes | (Ereditato da TreeList)
Metodo protetto | MoveNodesCore | (Ereditato da TreeList)
Metodo pubblico | MovePrev | (Ereditato da TreeList)
Metodo pubblico | MovePrevVisible | (Ereditato da TreeList)
Metodo pubblico | MoveToNextScrollAnnotation | (Ereditato da TreeList)
Metodo pubblico | MoveToParent | (Ereditato da TreeList)
Metodo pubblico | MoveToPrevScrollAnnotation | (Ereditato da TreeList)
Metodo protetto | NormalizeVisibleBandIndices | (Ereditato da TreeList)
Metodo protetto | NormalizeVisibleColumnIndices | (Ereditato da TreeList)
Metodo protetto | OnActiveEditor_GotFocus | (Ereditato da TreeList)
Metodo protetto | OnActiveEditor_LostFocus | (Ereditato da TreeList)
Metodo protetto | OnActiveEditor_Modified | (Ereditato da TreeList)
Metodo protetto | OnActiveEditor_ValueChanged | (Ereditato da TreeList)
Metodo protetto | OnActiveEditor_ValueChanging | (Ereditato da TreeList)
Metodo protetto | OnActiveFilterChanged | (Ereditato da TreeList)
Metodo protetto | OnActiveFilterCriteriaChanged | (Ereditato da TreeList)
Metodo protetto | OnActiveFilterEnabledChanged | (Ereditato da TreeList)
Metodo protetto | OnAfterAddingNode | (Ereditato da TreeList)
Metodo protetto | OnAfterChangeCollapsed | (Ereditato da TreeList)
Metodo protetto | OnAfterChangeExpanded | (Ereditato da TreeList)
Metodo protetto | OnAfterDeletingNodes | (Ereditato da TreeList)
Metodo protetto | OnAllowBandColumnMultiRowChanged | (Ereditato da TreeList)
Metodo protetto | OnAllowSerializationProperty | (Ereditato da TreeList)
Metodo protetto | OnAppearancePrintChanged | (Ereditato da TreeList)
Metodo protetto | OnBandChanged | (Ereditato da TreeList)
Metodo protetto | OnBandCollectionChanged | (Ereditato da TreeList)
Metodo protetto | OnBandColumnCollectionChanged | (Ereditato da TreeList)
Metodo protetto | OnBandFixedChanged | (Ereditato da TreeList)
Metodo protetto | OnBandWidthChanged | (Ereditato da TreeList)
Metodo protetto | OnBeginTouchScroll | (Ereditato da TreeList)
Metodo protetto | OnBindingContextChanged | (Ereditato da TreeList)
Metodo protetto | OnCheckBoxFieldNameChanged | (Ereditato da TreeList)
Metodo protetto | OnClearNodes | (Ereditato da TreeList)
Metodo protetto | OnClearNodesComplete | (Ereditato da TreeList)
Metodo protetto | OnClick | (Ereditato da TreeList)
Metodo protetto | OnColumnAdded | (Ereditato da TreeList)
Metodo protetto | OnColumnChanged | (Ereditato da TreeList)
Metodo protetto | OnColumnFilterModeChanged | (Ereditato da TreeList)
Metodo protetto | OnColumnFilterRestored | (Ereditato da TreeList)
Metodo protetto | OnColumnInfosPopulated | (Ereditato da TreeList)
Metodo protetto | OnColumnRemoved | (Ereditato da TreeList)
Metodo protetto | OnColumnRowIndexChanged | (Ereditato da TreeList)
Metodo protetto | OnColumnsChanged | (Ereditato da TreeList)
Metodo protetto | OnColumnUnboundChanged | (Ereditato da TreeList)
Metodo protetto | OnColumnUnboundExpressionChanged | (Ereditato da TreeList)
Metodo protetto | OnContainerEnter | (Ereditato da EditorContainer)
Metodo protetto | OnContainerLeave | (Ereditato da EditorContainer)
Metodo protetto | OnContextMenuKey | (Ereditato da TreeList)
Metodo protetto | OnCreateControl | (Ereditato da EditorContainer)
Metodo protetto | OnDataListChanged | (Ereditato da TreeList)
Metodo protetto | OnDesignerHost_LoadComplete | (Ereditato da EditorContainer)
Metodo protetto | OnDesignerHost_TransactionClosed | (Ereditato da EditorContainer)
Metodo protetto | OnDirectXPaintDisabled | (Ereditato da TreeList)
Metodo protetto | OnDoubleClick | (Ereditato da TreeList)
Metodo protetto | OnDragDrop | (Ereditato da TreeList)
Metodo protetto | OnDragEnter | (Ereditato da TreeList)
Metodo protetto | OnDragLeave | (Ereditato da TreeList)
Metodo protetto | OnDragOver | (Ereditato da TreeList)
Metodo protetto | OnEnabledChanged | (Ereditato da TreeList)
Metodo protetto | OnEndInit | (Ereditato da EditorContainer)
Metodo protetto | OnEndSerializing | (Ereditato da TreeList)
Metodo protetto | OnEndSorting | (Ereditato da TreeList)
Metodo protetto | OnEnter | (Ereditato da EditorContainer)
Metodo protetto | OnErrorInfo_Changed | (Ereditato da TreeList)
Metodo protetto | OnFilterRowValueChanging | (Ereditato da TreeList)
Metodo protetto | OnFirstInit | (Ereditato da EditorContainer)
Metodo protetto | OnFormatConditionChanged | (Ereditato da TreeList)
Metodo protetto | OnFormatRuleExpressionEditorCreated | (Ereditato da TreeList)
Metodo protetto | OnFormatRulesCollectionChanged | (Ereditato da TreeList)
Metodo protetto | OnGotCapture | (Ereditato da EditorContainer)
Metodo protetto | OnGotFocus | (Ereditato da TreeList)
Metodo protetto | OnHandleCreated | (Ereditato da TreeList)
Metodo protetto | OnHandleDestroyed | (Ereditato da TreeList)
Metodo protetto | OnHorizontalTouchScroll | (Ereditato da TreeList)
Metodo protetto | OnHScroll | (Ereditato da TreeList)
Metodo protetto | OnItemAdded | (Ereditato da TreeList)
Metodo protetto | OnItemAdding | (Ereditato da TreeList)
Metodo protetto | OnItemChanged(Int32, PropertyDescriptor) | (Ereditato da TreeList)
Metodo protetto | OnItemChanged(Int32, PropertyDescriptor, TreeListNode) | (Ereditato da TreeList)
Metodo protetto | OnItemDeleted | (Ereditato da TreeList)
Metodo protetto | OnItemMoved | (Ereditato da TreeList)
Metodo protetto | OnKeyDown | (Ereditato da TreeList)
Metodo protetto | OnKeyPress | (Ereditato da TreeList)
Metodo protetto | OnKeyUp | (Ereditato da TreeList)
Metodo protetto | OnLeave | (Ereditato da EditorContainer)
Metodo protetto | OnLoaded | (Ereditato da TreeList)
Metodo protetto | OnLoadedCore | (Ereditato da TreeList)
Metodo protetto | OnLookAndFeelChanged(LookAndFeelChangedEventArgs) | (Ereditato da TreeList)
Metodo protetto | OnLookAndFeelChanged(Object, EventArgs) | (Ereditato da EditorContainer)
Metodo protetto | OnLostCapture | (Ereditato da TreeList)
Metodo protetto | OnLostFocus | (Ereditato da TreeList)
Metodo protetto | OnMenuShowing | (Ereditato da TreeList)
Metodo protetto | OnMouseClick | (Ereditato da EditorContainer)
Metodo protetto | OnMouseDoubleClick | (Ereditato da EditorContainer)
Metodo protetto | OnMouseDown | (Sovrascrive TreeList.OnMouseDown(MouseEventArgs))
Metodo protetto | OnMouseEnter | (Ereditato da TreeList)
Metodo protetto | OnMouseHWheel | (Ereditato da EditorContainer)
Metodo protetto | OnMouseLeave | (Ereditato da TreeList)
Metodo protetto | OnMouseMove | (Sovrascrive TreeList.OnMouseMove(MouseEventArgs))
Metodo protetto | OnMouseUp | (Sovrascrive TreeList.OnMouseUp(MouseEventArgs))
Metodo protetto | OnMouseWheel | (Ereditato da EditorContainer)
Metodo protetto | OnMouseWheelCore | (Ereditato da TreeList)
Metodo protetto | OnNodeCheckedChanged | (Ereditato da TreeList)
Metodo protetto | OnNodeRemoved | (Ereditato da TreeList)
Metodo protetto | OnNodesLoaded | (Ereditato da TreeList)
Metodo protetto | OnNodesLoading | (Ereditato da TreeList)
Metodo protetto | OnNodesRemoved | (Ereditato da TreeList)
Metodo protetto | OnOptionsBehaviorChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsCustomizationChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsDragAndDropChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsEditFormChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsFilterChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsFindChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsHtmlChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsNavigationChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsPrintChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsScrollAnnotationsChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsSelectionChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsViewChanged | (Ereditato da TreeList)
Metodo protetto | OnPaint | (Sovrascrive TreeList.OnPaint(PaintEventArgs))
Metodo protetto | OnPaintBackground | (Ereditato da TreeList)
Metodo protetto | OnParentChanged | (Ereditato da TreeList)
Metodo protetto | OnPressedBandChanged | (Ereditato da TreeList)
Metodo protetto | OnPrintProgress | (Ereditato da TreeList)
Metodo protetto | OnPropertyChanged | (Ereditato da TreeList)
Metodo protetto | OnPropertyDescriptorChanged | (Ereditato da TreeList)
Metodo protetto | OnQueryContinueDrag | (Ereditato da TreeList)
Metodo protetto | OnRepositoryItemRefreshRequired | (Ereditato da TreeList)
Metodo protetto | OnReset | (Ereditato da TreeList)
Metodo protetto | OnResetSerializationProperties | (Ereditato da TreeList)
Metodo protetto | OnResize | (Ereditato da TreeList)
Metodo protetto | OnRightToLeftChanged | (Ereditato da TreeList)
Metodo protetto | OnRightToLeftChanged(EventArgs) | (Ereditato da EditorContainer)
Metodo protetto | OnScaleControl | (Ereditato da TreeList)
Metodo protetto | OnScaleTreeListCore | (Ereditato da TreeList)
Metodo protetto | OnSelectionChanged | (Ereditato da TreeList)
Metodo protetto | OnSetValue | (Ereditato da TreeList)
Metodo protetto | OnSortModeChanged | (Ereditato da TreeList)
Metodo protetto | OnSourceItemChanged | (Ereditato da TreeList)
Metodo protetto | OnStartSerializing | (Ereditato da TreeList)
Metodo protetto | OnStartSorting | (Ereditato da TreeList)
Metodo protetto | OnSystemColorsChanged | (Ereditato da TreeList)
Metodo protetto | OnToolTipControllerDisposed | (Ereditato da EditorContainer)
Metodo protetto | OnTouchScroll | (Ereditato da TreeList)
Metodo protetto | OnTouchZoom | (Ereditato da TreeList)
Metodo protetto | OnValidated | (Ereditato da EditorContainer)
Metodo protetto | OnValidating | (Ereditato da TreeList)
Metodo protetto | OnVerticalTouchScroll | (Ereditato da TreeList)
Metodo protetto | OnVisibleChanged | (Ereditato da TreeList)
Metodo protetto | OnVScroll | (Ereditato da TreeList)
Metodo protetto | OnVScrollCore | (Ereditato da TreeList)
Metodo pubblico | OutdentNodes | (Ereditato da TreeList)
Metodo protetto | ParseAutoFilter | (Ereditato da TreeList)
Metodo protetto | ParseAutoFilterValues | (Ereditato da TreeList)
Metodo pubblico | PasteFromClipboard | (Ereditato da TreeList)
Metodo pubblico | PopulateColumns | (Ereditato da TreeList)
Metodo pubblico | PostEditor | (Ereditato da TreeList)
Metodo protetto | PostEditor(Boolean) | (Ereditato da TreeList)
Metodo pubblico | Print | (Ereditato da TreeList)
Metodo protetto | PrintCore | (Ereditato da TreeList)
Metodo pubblico | PrintDialog | (Ereditato da TreeList)
Metodo protetto | PrintDialogCore | (Ereditato da TreeList)
Metodo protetto | ProcessControlTab | (Ereditato da TreeList)
Metodo protetto | ProcessControlTab(Boolean) | (Ereditato da TreeList)
Metodo protetto | ProcessDialogKey | (Ereditato da TreeList)
Metodo protetto | ProcessDirectXPaint | (Ereditato da TreeList)
Metodo protetto | RaiseAfterCheckNode | (Ereditato da TreeList)
Metodo protetto | RaiseAfterCollapse | (Ereditato da TreeList)
Metodo protetto | RaiseAfterDragNode | (Ereditato da TreeList)
Metodo protetto | RaiseAfterDropNode | (Ereditato da TreeList)
Metodo protetto | RaiseAfterExpand | (Ereditato da TreeList)
Metodo protetto | RaiseAfterFocusNode | (Ereditato da TreeList)
Metodo protetto | RaiseBandPositionChanged | (Ereditato da TreeList)
Metodo protetto | RaiseBandWidthChanged | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeCheckNode | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeCollapse | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeDragNode | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeDropNode | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeExpand | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeFocusNode | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeLoadLayout | (Ereditato da TreeList)
Metodo protetto | RaiseCalcNodeDragImageIndex | (Ereditato da TreeList)
Metodo protetto | RaiseCalcNodeHeight(TreeListNode, Int32) | (Ereditato da TreeList)
Metodo protetto | RaiseCalcNodeHeight(TreeListNode, RowInfo, Int32) | (Ereditato da TreeList)
Metodo protetto | RaiseCellValueChanged | (Ereditato da TreeList)
Metodo protetto | RaiseCellValueChanging | (Ereditato da TreeList)
Metodo protetto | RaiseCheckedColumnFilterPopupEvent | (Ereditato da TreeList)
Metodo protetto | RaiseClipboardNodeCopying | (Ereditato da TreeList)
Metodo protetto | RaiseClipboardNodePasting | (Ereditato da TreeList)
Metodo protetto | RaiseColumnButtonClick | (Ereditato da TreeList)
Metodo protetto | RaiseColumnChanged | (Ereditato da TreeList)
Metodo protetto | RaiseColumnFilterChanged | (Ereditato da TreeList)
Metodo protetto | RaiseColumnFilterPopupEvent | (Ereditato da TreeList)
Metodo protetto | RaiseColumnPositionChanged | (Ereditato da TreeList)
Metodo protetto | RaiseColumnUnboundExpressionChanged | (Ereditato da TreeList)
Metodo protetto | RaiseColumnWidthChanged | (Ereditato da TreeList)
Metodo protetto | RaiseCompareNodeValues | (Ereditato da TreeList)
Metodo protetto | RaiseCreateCustomNode | (Ereditato da TreeList)
Metodo protetto | RaiseCustomColumnDisplayText(CustomColumnDisplayTextEventArgs) | (Ereditato da TreeList)
Metodo protetto | RaiseCustomColumnDisplayText(TreeListNode, CellInfo) | (Ereditato da TreeList)
Metodo protetto | RaiseCustomColumnDisplayText(TreeListNode, TreeListColumn, BaseEditViewInfo) | (Ereditato da TreeList)
Metodo protetto | RaiseCustomColumnDisplayText(TreeListNode, TreeListColumn, Object, String) | (Ereditato da TreeList)
Metodo protetto | RaiseCustomColumnSort | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawBandHeader | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawColumnHeader | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawEmptyArea | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawFilterPanel | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawFooter | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawFooterCell | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodeButton | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodeCell | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodeCheckBox | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodeImages | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodeIndent | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodeIndicator | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodePreview | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawRow | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawRowFooter | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawRowFooterCell | (Ereditato da TreeList)
Metodo protetto | RaiseCustomFilterDisplayText | (Ereditato da TreeList)
Metodo protetto | RaiseCustomizationFormSearch | (Ereditato da TreeList)
Metodo protetto | RaiseCustomizeNewNodeFromOuterData | (Ereditato da TreeList)
Metodo protetto | RaiseCustomRowFilter | (Ereditato da TreeList)
Metodo protetto | RaiseCustomRowFilterEvent | (Ereditato da TreeList)
Metodo protetto | RaiseCustomUnboundColumnData | (Ereditato da TreeList)
Metodo protetto | RaiseDataSourceChanged | (Ereditato da TreeList)
Metodo protetto | RaiseDefaultPaintHelperChanged | (Ereditato da TreeList)
Metodo protetto | RaiseDragCancelNode | (Ereditato da TreeList)
Metodo protetto | RaiseDragObjectDrop | (Ereditato da TreeList)
Metodo protetto | RaiseDragObjectOver | (Ereditato da TreeList)
Metodo protetto | RaiseDragObjectStart | (Ereditato da TreeList)
Metodo protetto | RaiseEditFormHidden | (Ereditato da TreeList)
Metodo protetto | RaiseEditFormPrepared | (Ereditato da TreeList)
Metodo protetto | RaiseEditFormShowing | (Ereditato da TreeList)
Metodo protetto | RaiseEditorKeyDown | (Ereditato da TreeList)
Metodo protetto | RaiseEditorKeyPress | (Ereditato da EditorContainer)
Metodo protetto | RaiseEditorKeyUp | (Ereditato da EditorContainer)
Metodo protetto | RaiseEndSorting | (Ereditato da TreeList)
Metodo protetto | RaiseExcelColumnFilterPopupEvent | (Ereditato da TreeList)
Metodo protetto | RaiseFilterEditorCreated | (Ereditato da TreeList)
Metodo protetto | RaiseFilterExpressionEditorCreated | (Ereditato da TreeList)
Metodo protetto | RaiseFilterNodeEvent | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupDate | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelCustomizeTemplate | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelData(FilterPopupExcelDataEventArgs) | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelData(TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelData(TreeListColumn, CriteriaOperator) | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelData(TreeListColumn, TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelParseFilterCriteria | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelPrepareTemplate | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelQueryFilterCriteria | (Ereditato da TreeList)
Metodo protetto | RaiseFocusedColumnChanged | (Ereditato da TreeList)
Metodo protetto | RaiseFocusedNodeChanged | (Ereditato da TreeList)
Metodo protetto | RaiseGetCustomAnnotations | (Ereditato da TreeList)
Metodo protetto | RaiseGetCustomNodeCellEdit | (Ereditato da TreeList)
Metodo protetto | RaiseGetCustomNodeCellStyle | (Ereditato da TreeList)
Metodo protetto | RaiseGetCustomSummaryValue | (Ereditato da TreeList)
Metodo protetto | RaiseGetNodeDisplayValue | (Ereditato da TreeList)
Metodo protetto | RaiseGetPreviewText | (Ereditato da TreeList)
Metodo protetto | RaiseGetPrintCustomSummaryValue | (Ereditato da TreeList)
Metodo protetto | RaiseGetPrintPreviewText | (Ereditato da TreeList)
Metodo protetto | RaiseGetSelectImage | (Ereditato da TreeList)
Metodo protetto | RaiseGetStateImage | (Ereditato da TreeList)
Metodo protetto | RaiseHiddenEditor | (Ereditato da TreeList)
Metodo protetto | RaiseHideCustomizationForm | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementBlur | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementFocus | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseClick | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseDoubleClick | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseDown | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseMove | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseOut | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseOver | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseUp | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlSelectedTextChanged | (Ereditato da TreeList)
Metodo protetto | RaiseInitNewRow | (Ereditato da TreeList)
Metodo protetto | RaiseInvalidNodeException | (Ereditato da TreeList)
Metodo protetto | RaiseInvalidValueException | (Ereditato da TreeList)
Metodo protetto | RaiseLayoutUpdated | (Ereditato da TreeList)
Metodo protetto | RaiseLayoutUpgrade | (Ereditato da TreeList)
Metodo protetto | RaiseLeftCoordChanged | (Ereditato da TreeList)
Metodo protetto | RaiseLoad | (Ereditato da TreeList)
Metodo protetto | RaiseMeasurePreviewHeight | (Ereditato da TreeList)
Metodo protetto | RaiseNodeChanged | (Ereditato da TreeList)
Metodo protetto | RaiseNodesReloaded | (Ereditato da TreeList)
Metodo protetto | RaisePaintEx | (Ereditato da TreeList)
Metodo protetto | RaiseParseFindPanelText | (Ereditato da TreeList)
Metodo protetto | RaisePopupMenuShowing | (Ereditato da TreeList)
Metodo protetto | RaisePrintExportProgress | (Ereditato da TreeList)
Metodo protetto | RaiseQueryCustomFunctions | (Ereditato da TreeList)
Metodo protetto | RaiseRequireHideEditor | (Ereditato da EditorContainer)
Metodo protetto | RaiseRowCellClick | (Ereditato da TreeList)
Metodo protetto | RaiseRowClick | (Ereditato da TreeList)
Metodo protetto | RaiseRowSelectImageClick | (Ereditato da TreeList)
Metodo protetto | RaiseRowStateImageClick | (Ereditato da TreeList)
Metodo protetto | RaiseSelectImageClick | (Ereditato da TreeList)
Metodo protetto | RaiseSelectionChanged | (Ereditato da TreeList)
Metodo protetto | RaiseSelectionChanging | (Ereditato da TreeList)
Metodo protetto | RaiseShowCustomizationForm | (Ereditato da TreeList)
Metodo protetto | RaiseShowingEditor | (Ereditato da TreeList)
Metodo protetto | RaiseShownEditor | (Ereditato da TreeList)
Metodo protetto | RaiseShowTreeListMenu | Obsoleto. (Ereditato da TreeList)
Metodo protetto | RaiseStartSorting | (Ereditato da TreeList)
Metodo protetto | RaiseStateChanged | (Ereditato da TreeList)
Metodo protetto | RaiseStateImageClick | (Ereditato da TreeList)
Metodo protetto | RaiseSubstituteFilter | (Ereditato da TreeList)
Metodo protetto | RaiseTopVisibleNodeIndexChanged | (Ereditato da TreeList)
Metodo protetto | RaiseTreeListMenuItemClick | (Ereditato da TreeList)
Metodo protetto | RaiseUnboundExpressionEditorCreated | (Ereditato da TreeList)
Metodo protetto | RaiseValidateNode | (Ereditato da TreeList)
Metodo protetto | RaiseValidatingEditor | (Ereditato da TreeList)
Metodo protetto | RecalcSortColumns | (Ereditato da TreeList)
Metodo protetto | RecreateRowsInfoCore | (Ereditato da TreeList)
Metodo pubblico | Refresh | (Ereditato da TreeList)
Metodo pubblico | Refresh(Boolean) | (Ereditato da TreeList)
Metodo pubblico | RefreshCell | (Ereditato da TreeList)
Metodo protetto | RefreshCellCore | (Ereditato da TreeList)
Metodo protetto | RefreshColumnsInfo | (Ereditato da TreeList)
Metodo pubblico | RefreshDataSource | (Ereditato da TreeList)
Metodo pubblico | RefreshEditor | (Ereditato da TreeList)
Metodo protetto | RefreshEditorError | (Ereditato da TreeList)
Metodo protetto | RefreshHeadersInfo | (Ereditato da TreeList)
Metodo protetto | RefreshHtmlNodeCore | (Ereditato da TreeList)
Metodo pubblico | RefreshNode | (Ereditato da TreeList)
Metodo protetto | RefreshNodeCore | (Ereditato da TreeList)
Metodo protetto | RefreshRowsInfo | (Ereditato da TreeList)
Metodo protetto | RefreshRowsInfo(Boolean, Boolean) | (Ereditato da TreeList)
Metodo pubblico | RefreshScrollAnnotations(ScrollAnnotationKind) | (Ereditato da TreeList)
Metodo pubblico | RefreshScrollAnnotations(ScrollAnnotationKind, Int32) | (Ereditato da TreeList)
Metodo protetto | RefreshVirtualCellCore | (Ereditato da TreeList)
Metodo protetto | RefreshVirtualNodeCore | (Ereditato da TreeList)
Metodo protetto | RejectCurrentChanges | (Ereditato da TreeList)
Metodo protetto | RemoveFromDefaultTooltipController | (Ereditato da EditorContainer)
Metodo protetto | RemoveHookOnLoaded | (Ereditato da EditorContainer)
Metodo protetto | RemoveNodeHeight | (Ereditato da TreeList)
Metodo protetto | RequestCellEditor | (Ereditato da TreeList)
Metodo protetto | ResetAccessibility | (Ereditato da TreeList)
Metodo pubblico | ResetAutoFilterCondition | (Ereditato da TreeList)
Metodo pubblico | ResetAutoFilterConditions | (Ereditato da TreeList)
Metodo pubblico | ResetAutoFilterConditions(IEnumerableTreeListColumn) | (Ereditato da TreeList)
Metodo protetto | ResetAutoFilterConditionsCore | (Ereditato da TreeList)
Metodo protetto | ResetColumnAutoFilterConditions | (Ereditato da TreeList)
Metodo pubblico | ResetEditorsCache(RepositoryItem) | (Ereditato da EditorContainer)
Metodo pubblico | ResetEditorsCache(Type) | (Ereditato da EditorContainer)
Metodo protetto | ResetExcelFilteringProvider | (Ereditato da TreeList)
Metodo protetto | ResetLookAndFeel | (Ereditato da EditorContainer)
Metodo protetto | ResetRowCount | (Ereditato da TreeList)
Metodo protetto | ResetSortedColumns | (Ereditato da TreeList)
Metodo protetto | ResizeBand | (Ereditato da TreeList)
Metodo protetto | ResizeColumn | (Ereditato da TreeList)
Metodo protetto | ResolveAutoFilterCondition | (Ereditato da TreeList)
Metodo protetto | RestoreLayoutCore | (Ereditato da TreeList)
Metodo pubblico | RestoreLayoutFromRegistry(String) | (Ereditato da TreeList)
Metodo pubblico | RestoreLayoutFromRegistry(String, OptionsLayoutBase) | (Ereditato da TreeList)
Metodo pubblico | RestoreLayoutFromStream(Stream) | (Ereditato da TreeList)
Metodo pubblico | RestoreLayoutFromStream(Stream, OptionsLayoutBase) | (Ereditato da TreeList)
Metodo pubblico | RestoreLayoutFromXml(String) | (Ereditato da TreeList)
Metodo pubblico | RestoreLayoutFromXml(String, OptionsLayoutBase) | (Ereditato da TreeList)
Metodo protetto | RestoreNodesData | (Ereditato da TreeList)
Metodo protetto | SaveLayoutCore | (Ereditato da TreeList)
Metodo pubblico | SaveLayoutToRegistry(String) | (Ereditato da TreeList)
Metodo pubblico | SaveLayoutToRegistry(String, OptionsLayoutBase) | (Ereditato da TreeList)
Metodo pubblico | SaveLayoutToStream(Stream) | (Ereditato da TreeList)
Metodo pubblico | SaveLayoutToStream(Stream, OptionsLayoutBase) | (Ereditato da TreeList)
Metodo pubblico | SaveLayoutToXml(String) | (Ereditato da TreeList)
Metodo pubblico | SaveLayoutToXml(String, OptionsLayoutBase) | (Ereditato da TreeList)
Metodo protetto | SaveNodesData | (Ereditato da TreeList)
Metodo protetto | ScaleControl | (Ereditato da EditorContainer)
Metodo protetto | Scrollbar_MouseEnter | (Ereditato da TreeList)
Metodo protetto | Scrollbar_MouseLeave | (Ereditato da TreeList)
Metodo protetto | ScrollHorizontalEx | (Ereditato da TreeList)
Metodo protetto | ScrollVerticalEx | (Ereditato da TreeList)
Metodo pubblico | SelectAll | (Ereditato da TreeList)
Metodo pubblico | SelectCell | (Ereditato da TreeList)
Metodo protetto | SelectCellCore | (Ereditato da TreeList)
Metodo pubblico | SelectCells(Int32, String, Int32, String) | (Ereditato da TreeList)
Metodo pubblico | SelectCells(TreeListNode, TreeListColumn, TreeListNode, TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | SelectNode | (Ereditato da TreeList)
Metodo protetto | SelectNodeCore | (Ereditato da TreeList)
Metodo pubblico | SelectNodes(Int32, Int32) | (Ereditato da TreeList)
Metodo pubblico | SelectNodes(TreeListNode, TreeListNode) | (Ereditato da TreeList)
Metodo protetto | SelectNodesCore | (Ereditato da TreeList)
Metodo protetto | ServiceColumnChanged | (Ereditato da TreeList)
Metodo pubblico | SetAutoFilterValue | (Ereditato da TreeList)
Metodo protetto | SetCellSelection | (Ereditato da TreeList)
Metodo protetto | SetCellSelectionCore | (Ereditato da TreeList)
Metodo pubblico | SetColumnError(TreeListColumn, String) | (Ereditato da TreeList)
Metodo pubblico | SetColumnError(TreeListColumn, String, ErrorType) | (Ereditato da TreeList)
Metodo protetto | SetColumnFixedStyle | (Ereditato da TreeList)
Metodo pubblico | SetColumnPosition | (Ereditato da TreeList)
Metodo protetto | SetColumnVisibleIndex | (Ereditato da TreeList)
Metodo pubblico | SetDefaultBehaviorOptions | (Ereditato da TreeList)
Metodo pubblico | SetDefaultCustomizationOptions | (Ereditato da TreeList)
Metodo pubblico | SetDefaultNavigationOptions | (Ereditato da TreeList)
Metodo pubblico | SetDefaultOptionsView | (Ereditato da TreeList)
Metodo pubblico | SetDefaultPrintOptions | (Ereditato da TreeList)
Metodo pubblico | SetDefaultRowHeight | (Ereditato da TreeList)
Metodo pubblico | SetDefaultSelectionOptions | (Ereditato da TreeList)
Metodo protetto | SetExtraFilter | (Ereditato da TreeList)
Metodo protetto | SetFilterRowValue(Object, Object) | (Ereditato da TreeList)
Metodo protetto | SetFilterRowValue(TreeListColumn, Object) | (Ereditato da TreeList)
Metodo pubblico | SetFocusedNode | (Ereditato da TreeList)
Metodo protetto | SetFocusedNodeCore | (Ereditato da TreeList)
Metodo pubblico | SetFocusedRowCellValue(String, Object) | (Ereditato da TreeList)
Metodo pubblico | SetFocusedRowCellValue(TreeListColumn, Object) | (Ereditato da TreeList)
Metodo protetto | SetFocusedRowIndexCore | (Ereditato da TreeList)
Metodo pubblico | SetFocusedValue | (Ereditato da TreeList)
Metodo pubblico | SetNodeCheckState(TreeListNode, CheckState) | (Ereditato da TreeList)
Metodo pubblico | SetNodeCheckState(TreeListNode, CheckState, Boolean) | (Ereditato da TreeList)
Metodo pubblico | SetNodeIndex | (Ereditato da TreeList)
Metodo protetto | SetNodeIndexCore | (Ereditato da TreeList)
Metodo protetto | SetNodeValue | (Ereditato da TreeList)
Metodo pubblico | SetRowCellValue(TreeListNode, TreeListColumn, Object) | (Ereditato da TreeList)
Metodo pubblico | SetRowCellValue(TreeListNode, String, Object) | (Ereditato da TreeList)
Metodo pubblico | SetSearchControl | (Ereditato da TreeList)
Metodo pubblico | SetSelectionAnchor | (Ereditato da TreeList)
Metodo protetto | SetUseDirectXPaint | (Ereditato da TreeList)
Metodo protetto | ShouldResortNodesOnItemChanged | (Ereditato da TreeList)
Metodo protetto | ShouldSerializeLookAndFeel | (Ereditato da EditorContainer)
Metodo pubblico | ShowAutoFilterConditionsMenu | (Ereditato da TreeList)
Metodo pubblico | ShowContextMenu | (Ereditato da TreeList)
Metodo pubblico | ShowCustomization | (Ereditato da TreeList)
Metodo pubblico | ShowCustomization(Point) | (Ereditato da TreeList)
Metodo pubblico | ShowEditForm | (Ereditato da TreeList)
Metodo protetto | ShowEditFormCore | (Ereditato da TreeList)
Metodo protetto | ShowEditFormDialogCore | (Ereditato da TreeList)
Metodo pubblico | ShowEditor | (Ereditato da TreeList)
Metodo pubblico | ShowEditor(String) | (Ereditato da TreeList)
Metodo pubblico | ShowFilterEditor | (Ereditato da TreeList)
Metodo protetto | ShowFilterExpressionEditor | (Ereditato da TreeList)
Metodo pubblico | ShowFilterPopup | (Ereditato da TreeList)
Metodo pubblico | ShowFindPanel | (Ereditato da TreeList)
Metodo pubblico | ShowLoadingPanel | (Ereditato da TreeList)
Metodo protetto | ShowMenu | (Ereditato da TreeList)
Metodo protetto | ShowMRUFilterPopup | (Ereditato da TreeList)
Metodo pubblico | ShowPrintPreview | (Ereditato da TreeList)
Metodo protetto | ShowPrintPreviewCore | (Ereditato da TreeList)
Metodo protetto | ShowProgressForm | (Ereditato da TreeList)
Metodo pubblico | ShowRibbonPrintPreview | (Ereditato da TreeList)
Metodo protetto | ShowRibbonPrintPreviewCore | (Ereditato da TreeList)
Metodo pubblico | ShowUnboundExpressionEditor | (Ereditato da TreeList)
Metodo pubblico | Sort(TreeListNode, IComparerTreeListNode, Boolean) | (Ereditato da TreeList)
Metodo protetto | Sort(TreeListNodes, Boolean, Boolean) | (Ereditato da TreeList)
Metodo pubblico | Sort(TreeListNode, TreeListColumn, SortOrder, Boolean) | (Ereditato da TreeList)
Metodo pubblico | StartIncrementalSearch | (Ereditato da TreeList)
Metodo protetto | StartOfficeScrolling | (Ereditato da TreeList)
Metodo pubblico | StopIncrementalSearch | (Ereditato da TreeList)
Metodo protetto | StopOfficeScrolling | (Ereditato da TreeList)
Metodo pubblico | UncheckAll | (Ereditato da TreeList)
Metodo protetto | UnlockDirectXRendering | (Ereditato da TreeList)
Metodo pubblico | UnlockReloadNodes | (Ereditato da TreeList)
Metodo pubblico | UnselectCell | (Ereditato da TreeList)
Metodo protetto | UnselectCellCore | (Ereditato da TreeList)
Metodo pubblico | UnselectCells(Int32, String, Int32, String) | (Ereditato da TreeList)
Metodo pubblico | UnselectCells(TreeListNode, TreeListColumn, TreeListNode, TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | UnselectNode | (Ereditato da TreeList)
Metodo pubblico | UnselectNodes(Int32, Int32) | (Ereditato da TreeList)
Metodo pubblico | UnselectNodes(TreeListNode, TreeListNode) | (Ereditato da TreeList)
Metodo protetto | UpdateActiveFilterInfo | (Ereditato da TreeList)
Metodo protetto | UpdateAutoFilterRowActiveEditor | (Ereditato da TreeList)
Metodo protetto | UpdateBandColumnsIndices | (Ereditato da TreeList)
Metodo protetto | UpdateBandColumnsOrder | (Ereditato da TreeList)
Metodo protetto | UpdateColumnAutoFilter | (Ereditato da TreeList)
Metodo protetto | UpdateColumnsSortIndices | (Ereditato da TreeList)
Metodo protetto | UpdateElementsLookAndFeel | (Ereditato da TreeList)
Metodo protetto | UpdateFilter | (Ereditato da TreeList)
Metodo protetto | UpdateFilterInfo | (Ereditato da TreeList)
Metodo protetto | UpdateFindPanelFilterText | (Ereditato da TreeList)
Metodo protetto | UpdateLayout | (Ereditato da TreeList)
Metodo protetto | UpdateRootBands | (Ereditato da TreeList)
Metodo protetto | UpdateSelectCell | (Ereditato da TreeList)
Metodo protetto | UpdateSelectCell(TreeListNode, TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | UpdateSelectNode | (Ereditato da TreeList)
Metodo protetto | UpdateSelectNode(TreeListNode) | (Ereditato da TreeList)
Metodo protetto | UpdateVScrollBarCore | (Ereditato da TreeList)
Metodo protetto | ValidateAndEndCurrentEdit | (Ereditato da TreeList)
Metodo protetto | WndProc | (Ereditato da TreeList)
Metodo protetto | XtraClearColumns | (Ereditato da TreeList)
Metodo protetto | XtraCreateColumnsItem | (Ereditato da TreeList)
Metodo protetto | XtraFindColumnsItem | (Ereditato da TreeList)
Torna su
Vedi anche

Documentazione

Classe MyTreeList
Namespace DedNet.Controls


Metodo MyTreeList.OnMouseDown

Metodo MyTreeListOnMouseDown

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void OnMouseDown(
    MouseEventArgs e
)
Protected Overrides Sub OnMouseDown (
    e As MouseEventArgs
)
protected:
virtual void OnMouseDown(
    MouseEventArgs^ e
) override
abstract OnMouseDown :
        e : MouseEventArgs -> unit
override OnMouseDown :
        e : MouseEventArgs -> unit

Parametri

e MouseEventArgs
Vedi anche

Documentazione

Classe MyTreeList
Namespace DedNet.Controls


Metodo MyTreeList.OnMouseMove

Metodo MyTreeListOnMouseMove

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void OnMouseMove(
    MouseEventArgs e
)
Protected Overrides Sub OnMouseMove (
    e As MouseEventArgs
)
protected:
virtual void OnMouseMove(
    MouseEventArgs^ e
) override
abstract OnMouseMove :
        e : MouseEventArgs -> unit
override OnMouseMove :
        e : MouseEventArgs -> unit

Parametri

e MouseEventArgs
Vedi anche

Documentazione

Classe MyTreeList
Namespace DedNet.Controls


Metodo MyTreeList.OnMouseUp

Metodo MyTreeListOnMouseUp

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void OnMouseUp(
    MouseEventArgs e
)
Protected Overrides Sub OnMouseUp (
    e As MouseEventArgs
)
protected:
virtual void OnMouseUp(
    MouseEventArgs^ e
) override
abstract OnMouseUp :
        e : MouseEventArgs -> unit
override OnMouseUp :
        e : MouseEventArgs -> unit

Parametri

e MouseEventArgs
Vedi anche

Documentazione

Classe MyTreeList
Namespace DedNet.Controls


Metodo MyTreeList.OnPaint

Metodo MyTreeListOnPaint

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void OnPaint(
    PaintEventArgs e
)
Protected Overrides Sub OnPaint (
    e As PaintEventArgs
)
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override
abstract OnPaint :
        e : PaintEventArgs -> unit
override OnPaint :
        e : PaintEventArgs -> unit

Parametri

e PaintEventArgs
Vedi anche

Documentazione

Classe MyTreeList
Namespace DedNet.Controls


Eventi di MyTreeList

Il tipo MyTreeList espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | AfterCheckNode | (Ereditato da TreeList)
Evento pubblico | AfterCollapse | (Ereditato da TreeList)
Evento pubblico | AfterDragNode | (Ereditato da TreeList)
Evento pubblico | AfterDropNode | (Ereditato da TreeList)
Evento pubblico | AfterExpand | (Ereditato da TreeList)
Evento pubblico | AfterFocusNode | (Ereditato da TreeList)
Evento pubblico | BandPositionChanged | (Ereditato da TreeList)
Evento pubblico | BandWidthChanged | (Ereditato da TreeList)
Evento pubblico | BeforeCheckNode | (Ereditato da TreeList)
Evento pubblico | BeforeCollapse | (Ereditato da TreeList)
Evento pubblico | BeforeDragNode | (Ereditato da TreeList)
Evento pubblico | BeforeDropNode | (Ereditato da TreeList)
Evento pubblico | BeforeExpand | (Ereditato da TreeList)
Evento pubblico | BeforeFocusNode | (Ereditato da TreeList)
Evento pubblico | BeforeLoadLayout | (Ereditato da TreeList)
Evento pubblico | CalcNodeDragImageIndex | (Ereditato da TreeList)
Evento pubblico | CalcNodeHeight | (Ereditato da TreeList)
Evento pubblico | CellValueChanged | (Ereditato da TreeList)
Evento pubblico | CellValueChanging | (Ereditato da TreeList)
Evento pubblico | ClipboardNodeCopying | (Ereditato da TreeList)
Evento pubblico | ClipboardNodePasting | (Ereditato da TreeList)
Evento pubblico | ColumnButtonClick | (Ereditato da TreeList)
Evento pubblico | ColumnChanged | (Ereditato da TreeList)
Evento pubblico | ColumnFilterChanged | (Ereditato da TreeList)
Evento pubblico | ColumnPositionChanged | (Ereditato da TreeList)
Evento pubblico | ColumnUnboundExpressionChanged | (Ereditato da TreeList)
Evento pubblico | ColumnWidthChanged | (Ereditato da TreeList)
Evento pubblico | CompareNodeValues | (Ereditato da TreeList)
Evento pubblico | CreateCustomNode | (Ereditato da TreeList)
Evento pubblico | CustomColumnDisplayText | (Ereditato da TreeList)
Evento pubblico | CustomColumnSort | (Ereditato da TreeList)
Evento pubblico | CustomDrawBandHeader | (Ereditato da TreeList)
Evento pubblico | CustomDrawColumnHeader | (Ereditato da TreeList)
Evento pubblico | CustomDrawEmptyArea | (Ereditato da TreeList)
Evento pubblico | CustomDrawFilterPanel | (Ereditato da TreeList)
Evento pubblico | CustomDrawFooter | (Ereditato da TreeList)
Evento pubblico | CustomDrawFooterCell | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodeButton | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodeCell | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodeCheckBox | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodeImages | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodeIndent | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodeIndicator | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodePreview | (Ereditato da TreeList)
Evento pubblico | CustomDrawRow | (Ereditato da TreeList)
Evento pubblico | CustomDrawRowFooter | (Ereditato da TreeList)
Evento pubblico | CustomDrawRowFooterCell | (Ereditato da TreeList)
Evento pubblico | CustomDrawScroll | (Ereditato da TreeList)
Evento pubblico | CustomFilterDisplayText | (Ereditato da TreeList)
Evento pubblico | CustomizationFormSearch | (Ereditato da TreeList)
Evento pubblico | CustomizeNewNodeFromOuterData | (Ereditato da TreeList)
Evento pubblico | CustomizeNodeTemplate | (Ereditato da TreeList)
Evento pubblico | CustomNodeCellEdit | (Ereditato da TreeList)
Evento pubblico | CustomNodeCellEditForEditing | (Ereditato da TreeList)
Evento pubblico | CustomRowFilter | (Ereditato da TreeList)
Evento pubblico | CustomScrollAnnotation | (Ereditato da TreeList)
Evento pubblico | CustomUnboundColumnData | (Ereditato da TreeList)
Evento pubblico | DataSourceChanged | (Ereditato da TreeList)
Evento pubblico | DefaultPaintHelperChanged | (Ereditato da TreeList)
Evento pubblico | DragCancelNode | (Ereditato da TreeList)
Evento pubblico | DragObjectDrop | (Ereditato da TreeList)
Evento pubblico | DragObjectOver | (Ereditato da TreeList)
Evento pubblico | DragObjectStart | (Ereditato da TreeList)
Evento pubblico | EditFormHidden | (Ereditato da TreeList)
Evento pubblico | EditFormPrepared | (Ereditato da TreeList)
Evento pubblico | EditFormShowing | (Ereditato da TreeList)
Evento pubblico | EditorKeyDown | (Ereditato da EditorContainer)
Evento pubblico | EditorKeyPress | (Ereditato da EditorContainer)
Evento pubblico | EditorKeyUp | (Ereditato da EditorContainer)
Evento pubblico | EndSorting | (Ereditato da TreeList)
Evento pubblico | FilterEditorCreated | (Ereditato da TreeList)
Evento pubblico | FilterExpressionEditorCreated | (Ereditato da TreeList)
Evento pubblico | FilterNode | (Ereditato da TreeList)
Evento pubblico | FilterPopupExcelCustomizeTemplate | (Ereditato da TreeList)
Evento pubblico | FilterPopupExcelData | (Ereditato da TreeList)
Evento pubblico | FilterPopupExcelParseFilterCriteria | (Ereditato da TreeList)
Evento pubblico | FilterPopupExcelPrepareTemplate | (Ereditato da TreeList)
Evento pubblico | FilterPopupExcelQueryFilterCriteria | (Ereditato da TreeList)
Evento pubblico | FocusedColumnChanged | (Ereditato da TreeList)
Evento pubblico | FocusedNodeChanged | (Ereditato da TreeList)
Evento pubblico | FormatRuleExpressionEditorCreated | (Ereditato da TreeList)
Evento pubblico | GetCustomNodeCellEdit | Obsoleto. (Ereditato da TreeList)
Evento pubblico | GetCustomNodeCellStyle | Obsoleto. (Ereditato da TreeList)
Evento pubblico | GetCustomSummaryValue | (Ereditato da TreeList)
Evento pubblico | GetNodeDisplayValue | (Ereditato da TreeList)
Evento pubblico | GetPreviewText | (Ereditato da TreeList)
Evento pubblico | GetPrintCustomSummaryValue | (Ereditato da TreeList)
Evento pubblico | GetPrintPreviewText | (Ereditato da TreeList)
Evento pubblico | GetSelectImage | (Ereditato da TreeList)
Evento pubblico | GetStateImage | (Ereditato da TreeList)
Evento pubblico | HiddenEditor | (Ereditato da TreeList)
Evento pubblico | HideCustomizationForm | (Ereditato da TreeList)
Evento pubblico | HtmlElementBlur | (Ereditato da TreeList)
Evento pubblico | HtmlElementFocus | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseClick | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseDoubleClick | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseDown | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseMove | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseOut | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseOver | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseUp | (Ereditato da TreeList)
Evento pubblico | HtmlSelectedTextChanged | (Ereditato da TreeList)
Evento pubblico | HyperlinkClick | (Ereditato da TreeList)
Evento pubblico | InitNewRow | (Ereditato da TreeList)
Evento pubblico | InvalidNodeException | (Ereditato da TreeList)
Evento pubblico | InvalidValueException | (Ereditato da TreeList)
Evento pubblico | LayoutUpdated | (Ereditato da TreeList)
Evento pubblico | LayoutUpgrade | (Ereditato da TreeList)
Evento pubblico | LeftCoordChanged | (Ereditato da TreeList)
Evento pubblico | Load | (Ereditato da TreeList)
Evento pubblico | MeasurePreviewHeight | (Ereditato da TreeList)
Evento pubblico | NodeCellStyle | (Ereditato da TreeList)
Evento pubblico | NodeChanged | (Ereditato da TreeList)
Evento pubblico | NodesReloaded | (Ereditato da TreeList)
Evento pubblico | PaintEx | (Ereditato da TreeList)
Evento pubblico | ParseFindPanelText | (Ereditato da TreeList)
Evento pubblico | PopupMenuShowing | (Ereditato da TreeList)
Evento pubblico | PrintExportProgress | (Ereditato da TreeList)
Evento pubblico | PropertyDeserializing | (Ereditato da TreeList)
Evento pubblico | PropertySerializing | (Ereditato da TreeList)
Evento pubblico | QueryCustomFunctions | (Ereditato da TreeList)
Evento pubblico | QueryEmptyTreeTemplate | (Ereditato da TreeList)
Evento pubblico | QueryNodeTemplate | (Ereditato da TreeList)
Evento pubblico | RowCellClick | (Ereditato da TreeList)
Evento pubblico | RowClick | (Ereditato da TreeList)
Evento pubblico | RowSelectImageClick | (Ereditato da TreeList)
Evento pubblico | RowStateImageClick | (Ereditato da TreeList)
Evento pubblico | ScrollAnnotationsStyle | (Ereditato da TreeList)
Evento pubblico | SelectImageClick | (Ereditato da TreeList)
Evento pubblico | SelectionChanged | (Ereditato da TreeList)
Evento pubblico | SelectionChanging | (Ereditato da TreeList)
Evento pubblico | ShowCustomizationForm | (Ereditato da TreeList)
Evento pubblico | ShowFilterPopupCheckedListBox | (Ereditato da TreeList)
Evento pubblico | ShowFilterPopupDate | (Ereditato da TreeList)
Evento pubblico | ShowFilterPopupExcel | (Ereditato da TreeList)
Evento pubblico | ShowFilterPopupListBox | (Ereditato da TreeList)
Evento pubblico | ShowingEditor | (Ereditato da TreeList)
Evento pubblico | ShownEditor | (Ereditato da TreeList)
Evento pubblico | ShowTreeListMenu | Obsoleto. (Ereditato da TreeList)
Evento pubblico | StartSorting | (Ereditato da TreeList)
Evento pubblico | StateChanged | (Ereditato da TreeList)
Evento pubblico | StateImageClick | (Ereditato da TreeList)
Evento pubblico | SubstituteFilter | (Ereditato da TreeList)
Evento pubblico | TopVisibleNodeIndexChanged | (Ereditato da TreeList)
Evento pubblico | TreeListMenuItemClick | (Ereditato da TreeList)
Evento pubblico | UnboundExpressionEditorCreated | (Ereditato da TreeList)
Evento pubblico | ValidateNode | (Ereditato da TreeList)
Evento pubblico | ValidatingEditor | (Ereditato da TreeList)
Evento pubblico | VirtualTreeGetCellValue | (Ereditato da TreeList)
Evento pubblico | VirtualTreeGetChildNodes | (Ereditato da TreeList)
Evento pubblico | VirtualTreeSetCellValue | (Ereditato da TreeList)
Torna su
Vedi anche

Documentazione

Classe MyTreeList
Namespace DedNet.Controls


Campi di MyTreeList

Il tipo MyTreeList espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | allowCloseEditor | (Ereditato da TreeList)
Campo protetto | fInitializing | (Ereditato da EditorContainer)
Campo protetto | fUpdateSize | (Ereditato da TreeList)
Campo protetto | SortedColumns | (Ereditato da TreeList)
Torna su
Vedi anche

Documentazione

Classe MyTreeList
Namespace DedNet.Controls


Classe MyTreeListBom
Ridefinito l'albero in modo da espandere i nodi durante la ricerca.
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
EditorContainer
TreeList
DedNet.ControlsMyTreeListBom

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class MyTreeListBom : TreeList
Public Class MyTreeListBom
    Inherits TreeList
public ref class MyTreeListBom : public TreeList
type MyTreeListBom =
    class
        inherit TreeList
    end

Il tipo MyTreeListBom espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | MyTreeListBom |
Metodo protetto | MyTreeListBom(Object) |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | ActiveEditor | (Ereditato da TreeList)
Proprietà pubblica | ActiveFilter | (Ereditato da TreeList)
Proprietà pubblica | ActiveFilterCriteria | (Ereditato da TreeList)
Proprietà pubblica | ActiveFilterEnabled | (Ereditato da TreeList)
Proprietà pubblica | ActiveFilterInfo | (Ereditato da TreeList)
Proprietà pubblica | ActiveFilterString | (Ereditato da TreeList)
Proprietà protetta | ActualAutoNodeHeight | (Ereditato da TreeList)
Proprietà protetta | ActualFilterCriteria | (Ereditato da TreeList)
Proprietà protetta | ActualShowBands | (Ereditato da TreeList)
Proprietà pubblica | AllNodesCount | (Ereditato da TreeList)
Proprietà protetta | AllowAnimatedScrolling | (Ereditato da TreeList)
Proprietà protetta | AllowAutoFilterConditionChange | (Ereditato da TreeList)
Proprietà protetta | AllowBandColumnsMultiRow | (Ereditato da TreeList)
Proprietà protetta | AllowExpandAnimation | (Ereditato da TreeList)
Proprietà protetta | AllowFiltering | (Ereditato da TreeList)
Proprietà protetta | AllowFilteringAfterLoadingData | (Ereditato da TreeList)
Proprietà protetta | AllowFilterNodes | (Ereditato da TreeList)
Proprietà protetta | AllowFindPanel | (Ereditato da TreeList)
Proprietà protetta | AllowPrintProgress | (Ereditato da TreeList)
Proprietà protetta | AllowScaleOnLoad | (Ereditato da EditorContainer)
Proprietà pubblica | AllowTouchGestures | (Ereditato da EditorContainer)
Proprietà protetta | AllowTouchScroll | (Ereditato da TreeList)
Proprietà protetta | AnnotationManager | (Ereditato da TreeList)
Proprietà pubblica | Appearance | (Ereditato da TreeList)
Proprietà pubblica | AppearancePrint | (Ereditato da TreeList)
Proprietà pubblica | AutoFillColumn | (Ereditato da TreeList)
Proprietà pubblica | AutoFillColumnName | (Ereditato da TreeList)
Proprietà pubblica | AutoFillFieldName | (Ereditato da TreeList)
Proprietà protetta | AutoFilterNode | (Ereditato da TreeList)
Proprietà pubblica | BackColor | (Ereditato da TreeList)
Proprietà pubblica | BandPanelRowHeight | (Ereditato da TreeList)
Proprietà pubblica | Bands | (Ereditato da TreeList)
Proprietà pubblica | BestFitVisibleOnly | (Ereditato da TreeList)
Proprietà pubblica | BorderStyle | (Ereditato da TreeList)
Proprietà protetta | CanExpandNodesOnIncrementalSearch | (Ereditato da TreeList)
Proprietà protetta | CanLoadNodes | (Ereditato da TreeList)
Proprietà protetta | CanShowBandsInCustomizationForm | (Ereditato da TreeList)
Proprietà pubblica | CanShowEditor | (Ereditato da TreeList)
Proprietà pubblica | CanShowRowFooterSummary | (Ereditato da TreeList)
Proprietà pubblica | Caption | (Ereditato da TreeList)
Proprietà pubblica | CaptionHeight | (Ereditato da TreeList)
Proprietà protetta | CheckBoxesStrategy | (Ereditato da TreeList)
Proprietà pubblica | CheckBoxFieldName | (Ereditato da TreeList)
Proprietà pubblica | ChildListFieldName | (Ereditato da TreeList)
Proprietà protetta | ClientHeight | (Ereditato da TreeList)
Proprietà protetta | ClientWidth | (Ereditato da TreeList)
Proprietà pubblica | ClipboardDataProvider | (Ereditato da TreeList)
Proprietà protetta | ClipboardPasteHelper | (Ereditato da TreeList)
Proprietà protetta | ClipboardPasteManager | (Ereditato da TreeList)
Proprietà protetta | CloneInfoList | (Ereditato da TreeList)
Proprietà pubblica | ColumnPanelRowHeight | (Ereditato da TreeList)
Proprietà pubblica | Columns | (Ereditato da TreeList)
Proprietà pubblica | ColumnsImageList | (Ereditato da TreeList)
Proprietà protetta | ContainerHelper | (Ereditato da TreeList)
Proprietà pubblica | ContextMenuStrip | (Ereditato da EditorContainer)
Proprietà protetta | CurrencyManager | (Ereditato da TreeList)
Proprietà pubblica | Cursor | (Ereditato da TreeList)
Proprietà pubblica | CustomizationForm | (Ereditato da TreeList)
Proprietà pubblica | CustomizationFormBounds | (Ereditato da TreeList)
Proprietà pubblica | CustomizationRowCount | Obsoleto. (Ereditato da TreeList)
Proprietà protetta | Data | (Ereditato da TreeList)
Proprietà pubblica | DataMember | (Ereditato da TreeList)
Proprietà pubblica | DataSource | (Ereditato da TreeList)
Proprietà protetta | DefaultSize | (Ereditato da TreeList)
Proprietà protetta | DirectXProvider | (Ereditato da TreeList)
Proprietà protetta | DirectXScroller | (Ereditato da TreeList)
Proprietà pubblica | DragExpandDelay | Obsoleto. (Ereditato da TreeList)
Proprietà pubblica | DragNodesMode | Obsoleto. (Ereditato da TreeList)
Proprietà protetta | DXAccessible | (Ereditato da TreeList)
Proprietà pubblica | EcoDictionary |
Proprietà protetta | Editable | (Ereditato da TreeList)
Proprietà protetta | EditFormController | (Ereditato da TreeList)
Proprietà pubblica | EditingValue | (Ereditato da TreeList)
Proprietà protetta | EditorHelper | (Ereditato da EditorContainer)
Proprietà protetta | ElementsLookAndFeel | (Ereditato da TreeList)
Proprietà pubblica | EmptyTreeHtmlTemplate | (Ereditato da TreeList)
Proprietà protetta | EnableDirectXPaint | (Ereditato da TreeList)
Proprietà pubblica | EnableDynamicLoading | (Ereditato da TreeList)
Proprietà pubblica | EnableEnhancedScrolling | (Ereditato da TreeList)
Proprietà protetta | EnableEnhancedSorting | (Ereditato da TreeList)
Proprietà protetta | EnableFirstPaintTrigger | (Ereditato da EditorContainer)
Proprietà pubblica | EnableImprovedColumnSizing | (Ereditato da TreeList)
Proprietà protetta | ErrorInfo | (Ereditato da TreeList)
Proprietà protetta | ExcelFilteringProvider | (Ereditato da TreeList)
Proprietà protetta | ExceptionThrown | (Ereditato da TreeList)
Proprietà pubblica | ExternalRepository | (Ereditato da EditorContainer)
Proprietà protetta | ExtraFilter | (Ereditato da TreeList)
Proprietà protetta | ExtraFilterCriteria | (Ereditato da TreeList)
Proprietà protetta | ExtraFilterHightlightText | (Ereditato da TreeList)
Proprietà protetta | FilterColumnsProvider | (Ereditato da TreeList)
Proprietà protetta | FilterHelper | (Ereditato da TreeList)
Proprietà protetta | FilteringService | (Ereditato da TreeList)
Proprietà pubblica | FilterPanelText | (Ereditato da TreeList)
Proprietà protetta | FilterPopup | (Ereditato da TreeList)
Proprietà protetta | FindFilterCriteria | (Ereditato da TreeList)
Proprietà pubblica | FindFilterText | (Ereditato da TreeList)
Proprietà protetta | FindPanel | (Ereditato da TreeList)
Proprietà pubblica | FindPanelVisible | (Ereditato da TreeList)
Proprietà protetta | FireOnLoadOnPaint | (Ereditato da TreeList)
Proprietà pubblica | FixedLineWidth | (Ereditato da TreeList)
Proprietà protetta | FocusedCellIndex | (Ereditato da TreeList)
Proprietà pubblica | FocusedColumn | (Ereditato da TreeList)
Proprietà pubblica | FocusedNode | (Ereditato da TreeList)
Proprietà protetta | FocusedRow | (Ereditato da TreeList)
Proprietà protetta | FocusedRowIndex | (Ereditato da TreeList)
Proprietà pubblica | FocusedValue | (Ereditato da TreeList)
Proprietà pubblica | FooterPanelHeight | (Ereditato da TreeList)
Proprietà protetta | ForceLoadingPanel | (Ereditato da TreeList)
Proprietà pubblica | ForeColor | (Ereditato da EditorContainer)
Proprietà pubblica | FormatConditions | (Ereditato da TreeList)
Proprietà pubblica | FormatRules | (Ereditato da TreeList)
Proprietà pubblica | GroupButtonSize | Obsoleto. (Ereditato da TreeList)
Proprietà protetta | Handler | (Ereditato da TreeList)
Proprietà protetta | HasAccessible | (Ereditato da TreeList)
Proprietà protetta | HasAllColumnsFixedRight | (Ereditato da TreeList)
Proprietà protetta | HasBands | (Ereditato da TreeList)
Proprietà pubblica | HasColumnErrors | (Ereditato da TreeList)
Proprietà protetta | HasCustomNodeCellEdit | (Ereditato da TreeList)
Proprietà pubblica | HasFocus | (Ereditato da TreeList)
Proprietà protetta | HasHierarchicalColumn | (Ereditato da TreeList)
Proprietà protetta | HasTreeViewColumn | (Ereditato da TreeList)
Proprietà protetta | HeaderLayoutCalculator | (Ereditato da TreeList)
Proprietà protetta | HeaderWidthCalculator | (Ereditato da TreeList)
Proprietà pubblica | HierarchyColumn | (Ereditato da TreeList)
Proprietà pubblica | HierarchyColumnIndent | (Ereditato da TreeList)
Proprietà pubblica | HierarchyColumnName | (Ereditato da TreeList)
Proprietà pubblica | HierarchyFieldName | (Ereditato da TreeList)
Proprietà pubblica | HorzScrollStep | (Ereditato da TreeList)
Proprietà pubblica | HorzScrollVisibility | (Ereditato da TreeList)
Proprietà protetta | HtmlContext | (Ereditato da TreeList)
Proprietà pubblica | HtmlImages | (Ereditato da TreeList)
Proprietà protetta | HtmlObjectCache | (Ereditato da TreeList)
Proprietà pubblica | HtmlTemplates | (Ereditato da TreeList)
Proprietà protetta | IBasePrintableCreatesIntersectedBricks | (Ereditato da TreeList)
Proprietà pubblica | ImageIndexFieldName | (Ereditato da TreeList)
Proprietà protetta | IncrementalText | (Ereditato da TreeList)
Proprietà pubblica | IndicatorWidth | (Ereditato da TreeList)
Proprietà protetta | IsAllowBusyIndicator | (Ereditato da TreeList)
Proprietà protetta | IsAllowBusyPanel | (Ereditato da TreeList)
Proprietà protetta | IsAlt | (Ereditato da TreeList)
Proprietà protetta | IsAttachedToSearchControl | (Ereditato da TreeList)
Proprietà protetta | IsAutoWidth | (Ereditato da TreeList)
Proprietà protetta | IsCellSelect | (Ereditato da TreeList)
Proprietà protetta | IsClosingEditor | (Ereditato da TreeList)
Proprietà protetta | IsColumnHeaderAutoHeight | (Ereditato da TreeList)
Proprietà protetta | IsControl | (Ereditato da TreeList)
Proprietà protetta | IsDataReady | (Ereditato da TreeList)
Proprietà protetta | IsDeserializing | (Ereditato da TreeList)
Proprietà pubblica | IsDesignMode | (Ereditato da EditorContainer)
Proprietà protetta | IsDynamicLoadingAllowed | (Ereditato da TreeList)
Proprietà protetta | IsEditFormMode | (Ereditato da TreeList)
Proprietà pubblica | IsFilterByStateActive |
Proprietà protetta | IsFilterPopupActive | (Ereditato da TreeList)
Proprietà protetta | IsFindFilterActive | (Ereditato da TreeList)
Proprietà pubblica | IsFindPanelVisible | (Ereditato da TreeList)
Proprietà protetta | IsFocusedNodeChangedLocked | (Ereditato da TreeList)
Proprietà protetta | IsFocusedNodeDataModified | (Ereditato da TreeList)
Proprietà protetta | IsGroupDeleteOperation | (Ereditato da TreeList)
Proprietà protetta | IsHScrollBarVisible | (Ereditato da TreeList)
Proprietà protetta | IsInitialized | (Ereditato da EditorContainer)
Proprietà protetta | IsIniting | (Ereditato da TreeList)
Proprietà pubblica | IsLoading | (Ereditato da EditorContainer)
Proprietà protetta | IsLockDirectXRendering | (Ereditato da TreeList)
Proprietà protetta | IsLockExpandCollapse | (Ereditato da TreeList)
Proprietà protetta | IsLockUpdate | (Ereditato da TreeList)
Proprietà pubblica | IsLookUpMode | (Ereditato da TreeList)
Proprietà protetta | IsMultiSelect | (Ereditato da TreeList)
Proprietà protetta | IsNotificationInfoVisible | (Ereditato da TreeList)
Proprietà protetta | IsPainting | (Ereditato da TreeList)
Proprietà protetta | IsPixelScrolling | (Ereditato da TreeList)
Proprietà protetta | IsPopupEditFormVisible | (Ereditato da TreeList)
Proprietà pubblica | IsPrinting | (Ereditato da TreeList)
Proprietà pubblica | IsPrintingAvailable | (Ereditato da TreeList)
Proprietà protetta | IsRightToLeft | (Ereditato da TreeList)
Proprietà protetta | IsRowCountReady | (Ereditato da TreeList)
Proprietà protetta | IsScrollAnimationInProgress | (Ereditato da TreeList)
Proprietà protetta | IsSearchMode | (Ereditato da TreeList)
Proprietà protetta | IsSerializing | (Ereditato da TreeList)
Proprietà protetta | IsShift | (Ereditato da TreeList)
Proprietà protetta | IsSorted | (Ereditato da TreeList)
Proprietà protetta | IsUnboundLoad | (Ereditato da TreeList)
Proprietà pubblica | IsUnboundMode | (Ereditato da TreeList)
Proprietà protetta | IsUpdateSize | (Ereditato da TreeList)
Proprietà protetta | IsVirtualMode | (Ereditato da TreeList)
Proprietà protetta | IsVScrollBarVisible | (Ereditato da TreeList)
Proprietà pubblica | KeyFieldName | (Ereditato da TreeList)
Proprietà pubblica | LayoutVersion | Obsoleto. (Ereditato da TreeList)
Proprietà pubblica | LeftCoord | (Ereditato da TreeList)
Proprietà pubblica | LoadingPanelVisible | (Ereditato da TreeList)
Proprietà pubblica | LookAndFeel | (Ereditato da EditorContainer)
Proprietà protetta | LookAndFeelIgnoreChildren | (Ereditato da EditorContainer)
Proprietà protetta | LookUpDisplayColumn | (Ereditato da TreeList)
Proprietà protetta | LookUpOwner | (Ereditato da TreeList)
Proprietà pubblica | MenuManager | (Ereditato da EditorContainer)
Proprietà protetta | MinRowHeight | (Ereditato da TreeList)
Proprietà pubblica | MinWidth | (Ereditato da TreeList)
Proprietà protetta | MRUFilterPopup | (Ereditato da TreeList)
Proprietà pubblica | MRUFilters | (Ereditato da TreeList)
Proprietà protetta | NewItemNode | (Ereditato da TreeList)
Proprietà pubblica | NewItemRowText | (Ereditato da TreeList)
Proprietà pubblica | NodeHtmlTemplate | (Ereditato da TreeList)
Proprietà pubblica | Nodes | (Ereditato da TreeList)
Proprietà pubblica | NodesIterator | (Ereditato da TreeList)
Proprietà pubblica | NonColumnFilterCriteria | (Ereditato da TreeList)
Proprietà pubblica | NonColumnFilterString | (Ereditato da TreeList)
Proprietà protetta | NotificationInfo | (Ereditato da TreeList)
Proprietà protetta | OfficeScroller | (Ereditato da TreeList)
Proprietà pubblica | OptionsBehavior | (Ereditato da TreeList)
Proprietà pubblica | OptionsClipboard | (Ereditato da TreeList)
Proprietà pubblica | OptionsCustomization | (Ereditato da TreeList)
Proprietà pubblica | OptionsDragAndDrop | (Ereditato da TreeList)
Proprietà pubblica | OptionsEditForm | (Ereditato da TreeList)
Proprietà pubblica | OptionsFilter | (Ereditato da TreeList)
Proprietà pubblica | OptionsFind | (Ereditato da TreeList)
Proprietà pubblica | OptionsHtmlTemplate | (Ereditato da TreeList)
Proprietà pubblica | OptionsLayout | (Ereditato da TreeList)
Proprietà pubblica | OptionsMenu | (Ereditato da TreeList)
Proprietà pubblica | OptionsNavigation | (Ereditato da TreeList)
Proprietà pubblica | OptionsPrint | (Ereditato da TreeList)
Proprietà pubblica | OptionsScrollAnnotations | (Ereditato da TreeList)
Proprietà pubblica | OptionsSelection | (Ereditato da TreeList)
Proprietà pubblica | OptionsView | (Ereditato da TreeList)
Proprietà pubblica | Painter | (Ereditato da TreeList)
Proprietà pubblica | ParentFieldName | (Ereditato da TreeList)
Proprietà protetta | Position | (Ereditato da TreeList)
Proprietà protetta | PressedBand | (Ereditato da TreeList)
Proprietà protetta | PressedColumn | (Ereditato da TreeList)
Proprietà protetta | PressedNode | (Ereditato da TreeList)
Proprietà pubblica | PreviewFieldName | (Ereditato da TreeList)
Proprietà pubblica | PreviewIndent | (Ereditato da TreeList)
Proprietà pubblica | PreviewLineCount | (Ereditato da TreeList)
Proprietà protetta | Printer | (Ereditato da TreeList)
Proprietà protetta | PrinterCore | (Ereditato da TreeList)
Proprietà protetta | ProgressWindow | (Ereditato da TreeList)
Proprietà pubblica | RepositoryItems | (Ereditato da EditorContainer)
Proprietà pubblica | RootValue | (Ereditato da TreeList)
Proprietà protetta | RowCount | (Ereditato da TreeList)
Proprietà pubblica | RowHeight | (Ereditato da TreeList)
Proprietà protetta | ScaleDPI | (Ereditato da EditorContainer)
Proprietà pubblica | ScaleFactor | (Ereditato da EditorContainer)
Proprietà protetta | ScaleHelper | (Ereditato da EditorContainer)
Proprietà protetta | ScrollInfo | (Ereditato da TreeList)
Proprietà pubblica | SelectedHtmlText | (Ereditato da TreeList)
Proprietà pubblica | SelectImageList | (Ereditato da TreeList)
Proprietà pubblica | Selection | (Ereditato da TreeList)
Proprietà protetta | SelectionRange | (Ereditato da TreeList)
Proprietà pubblica | ShowButtonMode | (Ereditato da TreeList)
Proprietà protetta | ShowEditorAfterAnimatedScroll | (Ereditato da TreeList)
Proprietà pubblica | ShowOnlyAlternativeCode |
Proprietà protetta | ShowPreview | (Ereditato da TreeList)
Proprietà protetta | SizedBand | (Ereditato da TreeList)
Proprietà protetta | SizedColumn | (Ereditato da TreeList)
Proprietà protetta | SmartVisibility | (Ereditato da TreeList)
Proprietà pubblica | SortedColumnCount | (Ereditato da TreeList)
Proprietà pubblica | State | (Ereditato da TreeList)
Proprietà pubblica | StateImageList | (Ereditato da TreeList)
Proprietà pubblica | SyncCheckStateWithSourceOnChecking | (Ereditato da TreeList)
Proprietà pubblica | Text | (Ereditato da EditorContainer)
Proprietà pubblica | ToolTipController | (Ereditato da EditorContainer)
Proprietà protetta | TopVisibleNode | (Ereditato da TreeList)
Proprietà pubblica | TopVisibleNodeIndex | (Ereditato da TreeList)
Proprietà pubblica | TopVisibleNodePixel | (Ereditato da TreeList)
Proprietà pubblica | TreeLevelWidth | (Ereditato da TreeList)
Proprietà pubblica | TreeLineStyle | (Ereditato da TreeList)
Proprietà pubblica | TreeListDisposing | (Ereditato da TreeList)
Proprietà pubblica | TreeViewColumn | (Ereditato da TreeList)
Proprietà pubblica | TreeViewColumnName | (Ereditato da TreeList)
Proprietà pubblica | TreeViewFieldName | (Ereditato da TreeList)
Proprietà pubblica | UpdateTopVisibleNodeIndexOnCollapse | (Ereditato da TreeList)
Proprietà protetta | UseBandsAdvancedHorizontalNavigation | (Ereditato da TreeList)
Proprietà protetta | UseBandsAdvancedVerticalNavigation | (Ereditato da TreeList)
Proprietà pubblica | UseDirectXPaint | (Ereditato da TreeList)
Proprietà pubblica | UseDisabledStatePainter | (Ereditato da TreeList)
Proprietà protetta | UseStandardFilter | (Ereditato da TreeList)
Proprietà pubblica | VertScrollVisibility | (Ereditato da TreeList)
Proprietà pubblica | ViewInfo | (Ereditato da TreeList)
Proprietà pubblica | ViewState |
Proprietà pubblica | ViewStyle | (Ereditato da TreeList)
Proprietà protetta | VirtualDataHelper | (Ereditato da TreeList)
Proprietà pubblica | VisibleColumnCount | Obsoleto. (Ereditato da TreeList)
Proprietà pubblica | VisibleColumns | (Ereditato da TreeList)
Proprietà pubblica | VisibleNodesCount | (Ereditato da TreeList)
Proprietà protetta | WorkAsLookup | (Ereditato da TreeList)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AccessibleNotifyClients(AccessibleEvents, BaseAccessible) | (Ereditato da TreeList)
Metodo pubblico | AccessibleNotifyClients(AccessibleEvents, Int32, Int32) | (Ereditato da TreeList)
Metodo pubblico | AddFilter(CriteriaOperator) | (Ereditato da TreeList)
Metodo pubblico | AddFilter(String) | (Ereditato da TreeList)
Metodo protetto | AddToDefaultTooltipController | (Ereditato da EditorContainer)
Metodo protetto | AllowAutoFilterCondition | (Ereditato da TreeList)
Metodo protetto | AnimateKeyboardNavigation | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, TreeListNode) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, TreeListNode, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, TreeListNode, CheckState) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, CheckState) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, TreeListNode, CheckState, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, CheckState, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, TreeListNode, CheckState, NodeCheckBoxStyle, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, Int32, Int32, Int32) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, Int32, Int32, Int32, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, Int32, Int32, Int32, CheckState) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, Int32, Int32, Int32, CheckState, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, Int32, Int32, Int32, CheckState, NodeCheckBoxStyle, Object) | (Ereditato da TreeList)
Metodo protetto | ApplyFilter | (Ereditato da TreeList)
Metodo pubblico | ApplyFindFilter | (Ereditato da TreeList)
Metodo protetto | BeforeShowEditForm | (Ereditato da TreeList)
Metodo pubblico | BeginDelete | (Ereditato da TreeList)
Metodo protetto | BeginDragDrop | (Ereditato da TreeList)
Metodo protetto | BeginExpandCollapse | (Ereditato da TreeList)
Metodo pubblico | BeginInit | (Ereditato da EditorContainer)
Metodo protetto | BeginLockListChanged | (Ereditato da TreeList)
Metodo pubblico | BeginSelection | (Ereditato da TreeList)
Metodo pubblico | BeginSort | (Ereditato da TreeList)
Metodo pubblico | BeginUnboundLoad | (Ereditato da TreeList)
Metodo pubblico | BeginUpdate | (Ereditato da TreeList)
Metodo pubblico | BestFitColumns | (Ereditato da TreeList)
Metodo pubblico | BestFitColumns(Boolean) | (Ereditato da TreeList)
Metodo pubblico | BindCommand(Object, String, FuncObject) | (Ereditato da TreeList)
Metodo pubblico | BindCommand(ExpressionAction, Object, String, FuncObject) | (Ereditato da TreeList)
Metodo pubblico | BindCommand``1(ExpressionActionUMP, Object, String, FuncUMP) | (Ereditato da TreeList)
Metodo protetto | CalcActiveEditorBounds | (Ereditato da TreeList)
Metodo protetto | CalcColumnBestWidth | (Ereditato da TreeList)
Metodo pubblico | CalcHitInfo | (Ereditato da TreeList)
Metodo protetto | CalcHScrollRange | (Ereditato da TreeList)
Metodo protetto | CalcNodeAutoHeight | (Ereditato da TreeList)
Metodo protetto | CalcRowCount | (Ereditato da TreeList)
Metodo protetto | CalcScrollClientRect | (Ereditato da TreeList)
Metodo protetto | CalculateScrollBars | (Ereditato da TreeList)
Metodo protetto | CalculateVisibleRowsAreaHeight | (Ereditato da TreeList)
Metodo pubblico | CancelCurrentEdit | (Ereditato da TreeList)
Metodo protetto | CancelDirectXRendering | (Ereditato da TreeList)
Metodo protetto | CancelLockListChanged | (Ereditato da TreeList)
Metodo protetto | CancelSelection | (Ereditato da TreeList)
Metodo pubblico | CancelSort | (Ereditato da TreeList)
Metodo pubblico | CancelUpdate | (Ereditato da TreeList)
Metodo protetto | CanClearAllSorting | (Ereditato da TreeList)
Metodo protetto | CanCloneChildren | (Ereditato da TreeList)
Metodo protetto | CanFilterByColumnEdit | (Ereditato da TreeList)
Metodo pubblico | CanFilterColumn | (Ereditato da TreeList)
Metodo protetto | CanFindColumn | (Ereditato da TreeList)
Metodo protetto | CanFocusNode | (Ereditato da TreeList)
Metodo protetto | CanHandleTouchGestures | (Ereditato da EditorContainer)
Metodo protetto | CanIncrementalSearch | (Ereditato da TreeList)
Metodo pubblico | CanIndentNodes | (Ereditato da TreeList)
Metodo protetto | CanMove | (Ereditato da TreeList)
Metodo protetto | CanMoveBand | (Ereditato da TreeList)
Metodo protetto | CanMoveColumn | (Ereditato da TreeList)
Metodo pubblico | CanOutdentNodes | (Ereditato da TreeList)
Metodo protetto | CanResizeBand | (Ereditato da TreeList)
Metodo protetto | CanResizeColumn | (Ereditato da TreeList)
Metodo protetto | CanShowHScrollBar | (Ereditato da TreeList)
Metodo protetto | CanShowHScrollBarCore | (Ereditato da TreeList)
Metodo protetto | CanShowVScrollBar | (Ereditato da TreeList)
Metodo protetto | CanSortByColumnEdit | (Ereditato da TreeList)
Metodo pubblico | CanSortColumn | (Ereditato da TreeList)
Metodo protetto | CanStartTouchScrolling | (Ereditato da TreeList)
Metodo protetto | ChangeLeftCoord | (Ereditato da TreeList)
Metodo pubblico | CheckAll | (Ereditato da TreeList)
Metodo protetto | CheckAllowGestures | (Ereditato da TreeList)
Metodo protetto | CheckAllowNotifications | (Ereditato da TreeList)
Metodo protetto | CheckData | (Ereditato da TreeList)
Metodo protetto | CheckIncreaseVisibleRows | (Ereditato da TreeList)
Metodo protetto | CheckModifierKeys | (Ereditato da TreeList)
Metodo protetto | CheckNeedScale | (Ereditato da EditorContainer)
Metodo protetto | CheckRightToLeft | (Ereditato da EditorContainer)
Metodo protetto | CheckSearchMode | (Ereditato da TreeList)
Metodo protetto | CheckTopVisibleNodeAfterItemAdded | (Ereditato da TreeList)
Metodo protetto | CheckTopVisibleNodePixelValue | (Ereditato da TreeList)
Metodo pubblico | ClearColumnErrors | (Ereditato da TreeList)
Metodo pubblico | ClearColumnFilter | (Ereditato da TreeList)
Metodo protetto | ClearColumnFilterCore(String) | (Ereditato da TreeList)
Metodo protetto | ClearColumnFilterCore(TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | ClearColumnsFilter | (Ereditato da TreeList)
Metodo pubblico | ClearData | Metodo richiamato per azzerare i dati e i semafori utilizzati dal filtraggio
Metodo pubblico | ClearDocument | (Ereditato da TreeList)
Metodo pubblico | ClearFindFilter | (Ereditato da TreeList)
Metodo pubblico | ClearFocusedColumn | (Ereditato da TreeList)
Metodo pubblico | ClearNodes | (Ereditato da TreeList)
Metodo pubblico | ClearSelection | (Ereditato da TreeList)
Metodo pubblico | ClearSorting | (Ereditato da TreeList)
Metodo protetto | ClearVisibleIndicesCache | (Ereditato da TreeList)
Metodo pubblico | CloseEditForm | (Ereditato da TreeList)
Metodo pubblico | CloseEditor | (Ereditato da TreeList)
Metodo protetto | CloseEditor(Boolean) | (Ereditato da TreeList)
Metodo pubblico | CollapseAll | (Ereditato da TreeList)
Metodo protetto | CollapseAllCore | (Ereditato da TreeList)
Metodo pubblico | CollapseToLevel | (Ereditato da TreeList)
Metodo pubblico | ColumnsCustomization | (Ereditato da TreeList)
Metodo pubblico | ColumnsCustomization(Point) | (Ereditato da TreeList)
Metodo protetto | ControlRowSourceSelectedChanged | (Ereditato da TreeList)
Metodo protetto | ControlRowSourceVisibleChanged | (Ereditato da TreeList)
Metodo pubblico | ConvertFormatConditionToFormatRules | (Ereditato da TreeList)
Metodo pubblico | CopyNode(TreeListNode, TreeListNode, Boolean) | (Ereditato da TreeList)
Metodo pubblico | CopyNode(TreeListNode, TreeListNode, Boolean, Boolean) | (Ereditato da TreeList)
Metodo pubblico | CopyNode(TreeListNode, TreeListNode, Boolean, Int32) | (Ereditato da TreeList)
Metodo pubblico | CopyNode(TreeListNode, TreeListNode, Boolean, Boolean, Int32) | (Ereditato da TreeList)
Metodo protetto | CopyNodeCore | (Ereditato da TreeList)
Metodo pubblico | CopyNodes(IEnumerableTreeListNode, TreeListNode, Boolean, Int32) | (Ereditato da TreeList)
Metodo pubblico | CopyNodes(IEnumerableTreeListNode, TreeListNode, Boolean, Boolean, Int32) | (Ereditato da TreeList)
Metodo pubblico | CopyToClipboard | (Ereditato da TreeList)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da TreeList)
Metodo protetto | CreateAccessibleDataRow | (Ereditato da TreeList)
Metodo protetto | CreateAccessibleInstance | (Ereditato da TreeList)
Metodo protetto | CreateAllOptions | (Ereditato da TreeList)
Metodo protetto | CreateAnnotationManager | (Ereditato da TreeList)
Metodo protetto | CreateAppearances | (Ereditato da TreeList)
Metodo protetto | CreateAutoFilterCriterion | (Ereditato da TreeList)
Metodo protetto | CreateBands | (Ereditato da TreeList)
Metodo protetto | CreateCheckBoxesStrategy | (Ereditato da TreeList)
Metodo protetto | CreateCheckedListFilterPopup | (Ereditato da TreeList)
Metodo protetto | CreateColumn | (Ereditato da TreeList)
Metodo protetto | CreateColumnEditViewInfo | (Ereditato da TreeList)
Metodo protetto | CreateColumnFilterCriteriaByValue(TreeListColumn, Object) | (Ereditato da TreeList)
Metodo protetto | CreateColumnFilterCriteriaByValue(TreeListColumn, Object, Boolean) | (Ereditato da TreeList)
Metodo protetto | CreateColumnFilterPopup | (Ereditato da TreeList)
Metodo protetto | CreateColumns | (Ereditato da TreeList)
Metodo pubblico | CreateCustomization | Obsoleto. (Ereditato da TreeList)
Metodo protetto | CreateCustomizationForm | (Ereditato da TreeList)
Metodo protetto | CreateData | (Ereditato da TreeList)
Metodo protetto | CreateDataViewData | (Ereditato da TreeList)
Metodo protetto | CreateDateFilterPopup | (Ereditato da TreeList)
Metodo protetto | CreateDragNodesProvider | (Ereditato da TreeList)
Metodo protetto | CreateEditFormController | (Ereditato da TreeList)
Metodo protetto | CreateElementsLookAndFeel | (Ereditato da TreeList)
Metodo protetto | CreateExcelFilterPopup | (Ereditato da TreeList)
Metodo protetto | CreateFilterColumnCollection | (Ereditato da TreeList)
Metodo protetto | CreateFilterColumnRuleCollection | (Ereditato da TreeList)
Metodo protetto | CreateFilterColumnsProvider | (Ereditato da TreeList)
Metodo protetto | CreateFilterCriteriaBindingTarget | (Ereditato da TreeList)
Metodo protetto | CreateFilterEditorForm | (Ereditato da TreeList)
Metodo protetto | CreateFilterHelper | (Ereditato da TreeList)
Metodo protetto | CreateFindPanel | (Ereditato da TreeList)
Metodo protetto | CreateFindPanelCore | (Ereditato da TreeList)
Metodo pubblico | CreateGraphicsCache | (Ereditato da TreeList)
Metodo protetto | CreateHandler | (Ereditato da TreeList)
Metodo protetto | CreateHeaderLayoutCalculator | (Ereditato da TreeList)
Metodo protetto | CreateHeaderWidthCalculator | (Ereditato da TreeList)
Metodo protetto | CreateHelper | (Ereditato da TreeList)
Metodo protetto | CreateHierarchicalListData | (Ereditato da TreeList)
Metodo protetto | CreateHtmlContext | (Ereditato da TreeList)
Metodo protetto | CreateHyperlinkClickEventArgs | (Ereditato da TreeList)
Metodo protetto | CreateInternalRepository | (Ereditato da EditorContainer)
Metodo protetto | CreateListColumnFilterPopup | (Ereditato da TreeList)
Metodo protetto | CreateListData | (Ereditato da TreeList)
Metodo protetto | CreateLoadingAnimator | (Ereditato da TreeList)
Metodo protetto | CreateLoadingPanel | (Ereditato da TreeList)
Metodo protetto | CreateLookAndFeel | (Ereditato da EditorContainer)
Metodo protetto | CreateNewItemNode | (Ereditato da TreeList)
Metodo protetto | CreateNode(Int32, TreeListNodes) | (Ereditato da TreeList)
Metodo protetto | CreateNode(Int32, TreeListNodes, Object) | (Ereditato da TreeList)
Metodo protetto | CreateNodes | (Ereditato da TreeList)
Metodo protetto | CreateNodesComparer | (Ereditato da TreeList)
Metodo protetto | CreateNodesIterator | (Ereditato da TreeList)
Metodo protetto | CreateNotificationInfo | (Ereditato da TreeList)
Metodo protetto | CreateOfficeScroller | (Ereditato da TreeList)
Metodo protetto | CreateOptionsBehavior | (Ereditato da TreeList)
Metodo protetto | CreateOptionsClipboard | (Ereditato da TreeList)
Metodo protetto | CreateOptionsCustomization | (Ereditato da TreeList)
Metodo protetto | CreateOptionsDragAndDrop | (Ereditato da TreeList)
Metodo protetto | CreateOptionsEditForm | (Ereditato da TreeList)
Metodo protetto | CreateOptionsFilter | (Ereditato da TreeList)
Metodo protetto | CreateOptionsFind | (Ereditato da TreeList)
Metodo protetto | CreateOptionsHtmlTemplate | (Ereditato da TreeList)
Metodo protetto | CreateOptionsLayout | (Ereditato da TreeList)
Metodo protetto | CreateOptionsMenu | (Ereditato da TreeList)
Metodo protetto | CreateOptionsNavigation | (Ereditato da TreeList)
Metodo protetto | CreateOptionsPrint | (Ereditato da TreeList)
Metodo protetto | CreateOptionsScrollAnnotations | (Ereditato da TreeList)
Metodo protetto | CreateOptionsSelection | (Ereditato da TreeList)
Metodo protetto | CreateOptionsView | (Ereditato da TreeList)
Metodo protetto | CreatePainter | (Ereditato da TreeList)
Metodo protetto | CreatePrinter | (Ereditato da TreeList)
Metodo protetto | CreateProvider | (Ereditato da TreeList)
Metodo protetto | CreateScrollInfo | (Ereditato da TreeList)
Metodo protetto | CreateSelection | (Ereditato da TreeList)
Metodo protetto | CreateUnboundData | (Ereditato da TreeList)
Metodo protetto | CreateViewInfo | (Ereditato da TreeList)
Metodo protetto | CreateVirtualData | (Ereditato da TreeList)
Metodo protetto | CreateVirtualDataHelper | (Ereditato da TreeList)
Metodo protetto | CurrencyManager_ItemChanged | (Ereditato da TreeList)
Metodo protetto | CurrencyManager_PositionChanged | (Ereditato da TreeList)
Metodo protetto | DeferredLoadChildren | (Ereditato da TreeList)
Metodo protetto | DelayedInvalidate | (Ereditato da TreeList)
Metodo pubblico | DeleteNode | (Ereditato da TreeList)
Metodo pubblico | DeleteNodes | (Ereditato da TreeList)
Metodo pubblico | DeleteSelectedNodes | (Ereditato da TreeList)
Metodo pubblico | DestroyCustomization | (Ereditato da TreeList)
Metodo protetto | DestroyDirectXProvider | (Ereditato da EditorContainer)
Metodo protetto | DestroyFindPanel | (Ereditato da TreeList)
Metodo protetto | Dispose | (Ereditato da TreeList)
Metodo protetto | DoDataSourceChanged | (Ereditato da TreeList)
Metodo protetto | DoDpiChange | (Ereditato da EditorContainer)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da TreeList)
Metodo protetto | DoDragDrop | (Ereditato da TreeList)
Metodo pubblico | DoDragDropNode | (Ereditato da TreeList)
Metodo pubblico | DoDragDropNodes | (Ereditato da TreeList)
Metodo protetto | DoFilterNode | (Ereditato da TreeList)
Metodo protetto | DoForEachBand | (Ereditato da TreeList)
Metodo pubblico | DoIncrementalSearch | (Ereditato da TreeList)
Metodo protetto | DoShowTreeListMenu(TreeListMenu, TreeListHitTest) | (Ereditato da TreeList)
Metodo protetto | DoShowTreeListMenu(TreeListMenu, Control, Point) | (Ereditato da TreeList)
Metodo protetto | DoTopVisibleNodeChanged | (Ereditato da TreeList)
Metodo pubblico | EndCurrentEdit | (Ereditato da TreeList)
Metodo pubblico | EndCurrentEdit(Boolean) | (Ereditato da TreeList)
Metodo pubblico | EndDelete | (Ereditato da TreeList)
Metodo protetto | EndDragDrop | (Ereditato da TreeList)
Metodo protetto | EndEdit | (Ereditato da TreeList)
Metodo protetto | EndExpandCollapse | (Ereditato da TreeList)
Metodo pubblico | EndInit | (Ereditato da EditorContainer)
Metodo pubblico | EndSelection | (Ereditato da TreeList)
Metodo pubblico | EndSort | (Ereditato da TreeList)
Metodo pubblico | EndUnboundLoad | (Ereditato da TreeList)
Metodo pubblico | EndUpdate | (Ereditato da TreeList)
Metodo protetto | EnsureControlRowSource | (Ereditato da TreeList)
Metodo protetto | EnsureEditFormController | (Ereditato da TreeList)
Metodo protetto | EnsureFilteringClientDataBinding | (Ereditato da TreeList)
Metodo protetto | ExecutePrinterAction | (Ereditato da TreeList)
Metodo pubblico | ExpandAll | (Ereditato da TreeList)
Metodo protetto | ExpandAllCore | (Ereditato da TreeList)
Metodo protetto | ExpandToLast | (Ereditato da TreeList)
Metodo pubblico | ExpandToLevel | (Ereditato da TreeList)
Metodo protetto | ExpandToRoot | (Ereditato da TreeList)
Metodo protetto | Export(ExportTarget, Stream) | (Ereditato da TreeList)
Metodo protetto | Export(ExportTarget, String) | (Ereditato da TreeList)
Metodo protetto | Export(ExportTarget, Stream, ExportOptionsBase) | (Ereditato da TreeList)
Metodo protetto | Export(ExportTarget, String, ExportOptionsBase) | (Ereditato da TreeList)
Metodo pubblico | ExportToCsv(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToCsv(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToCsv(Stream, CsvExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToCsv(String, CsvExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToDocx(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToDocx(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToDocx(Stream, DocxExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToDocx(String, DocxExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToHtml(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToHtml(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToHtml(Stream, HtmlExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToHtml(String, HtmlExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToMht(Stream, MhtExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToMht(String, MhtExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToMht(String, String) | Obsoleto. (Ereditato da TreeList)
Metodo pubblico | ExportToMht(Stream, String, String, Boolean) | Obsoleto. (Ereditato da TreeList)
Metodo pubblico | ExportToMht(String, String, String, Boolean) | Obsoleto. (Ereditato da TreeList)
Metodo pubblico | ExportToPdf(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToPdf(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToPdf(Stream, PdfExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToPdf(String, PdfExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToRtf(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToRtf(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToText(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToText(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToText(Stream, TextExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToText(String, TextExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToXls(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToXls(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToXls(Stream, XlsExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToXls(String, XlsExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToXlsx(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToXlsx(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToXlsx(Stream, XlsxExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToXlsx(String, XlsxExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToXml(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToXml(String) | (Ereditato da TreeList)
Metodo protetto | ExportToXmlCore | (Ereditato da TreeList)
Metodo protetto | ExtractTemplateRootNode | (Ereditato da TreeList)
Metodo pubblico | FilterNodes | (Sovrascrive TreeList.FilterNodes)
Metodo pubblico | FilterNodes(TreeListNodes) | (Ereditato da TreeList)
Metodo protetto | FilterNodesCore | (Ereditato da TreeList)
Metodo pubblico | FindNode | (Ereditato da TreeList)
Metodo pubblico | FindNodeByFieldValue | (Ereditato da TreeList)
Metodo pubblico | FindNodeByID | (Ereditato da TreeList)
Metodo pubblico | FindNodeByKeyID | (Ereditato da TreeList)
Metodo protetto | FindNodeByParentID | (Ereditato da TreeList)
Metodo pubblico | FindNodes | (Ereditato da TreeList)
Metodo protetto | FindPanelNext | (Ereditato da TreeList)
Metodo protetto | FindPanelPrev | (Ereditato da TreeList)
Metodo pubblico | FireChanged | (Ereditato da TreeList)
Metodo protetto | FitColumns | (Ereditato da TreeList)
Metodo pubblico | FocusNewItemNode | (Ereditato da TreeList)
Metodo protetto | ForceCalcRowCount | (Ereditato da TreeList)
Metodo pubblico | ForceInitialize | (Ereditato da TreeList)
Metodo protetto | ForceSetTopVisibleNodeIndex | (Ereditato da TreeList)
Metodo pubblico | FullCollapse | Obsoleto. (Ereditato da TreeList)
Metodo pubblico | FullExpand | Obsoleto. (Ereditato da TreeList)
Metodo pubblico | FullExpandNode | Obsoleto. (Ereditato da TreeList)
Metodo protetto | GetAccessibilityObjectById | (Ereditato da TreeList)
Metodo protetto | GetAccessibleNodeCell | (Ereditato da TreeList)
Metodo protetto | GetActiveEditorHighAppearance | (Ereditato da TreeList)
Metodo protetto | GetActualAnimationType | (Ereditato da TreeList)
Metodo protetto | GetActualTreeListFilterMode | (Ereditato da TreeList)
Metodo pubblico | GetAllCheckedNodes | (Ereditato da TreeList)
Metodo protetto | GetAllowChangeBandParent | (Ereditato da TreeList)
Metodo protetto | GetAllowColumnFilterPopup | (Ereditato da TreeList)
Metodo protetto | GetAllowFilterEditor | (Ereditato da TreeList)
Metodo protetto | GetAllowFindColumn | (Ereditato da TreeList)
Metodo protetto | GetAllowFocus | (Ereditato da TreeList)
Metodo protetto | GetAllowHighlightFindResults | (Ereditato da TreeList)
Metodo protetto | GetAllowMRUFilterList | (Ereditato da TreeList)
Metodo protetto | GetAutoFilterRowColumnEdit | (Ereditato da TreeList)
Metodo pubblico | GetAutoFilterValue | (Ereditato da TreeList)
Metodo protetto | GetAutoNodeHeight | (Ereditato da TreeList)
Metodo protetto | GetBandRows | (Ereditato da TreeList)
Metodo protetto | GetBandRowsCore | (Ereditato da TreeList)
Metodo protetto | GetBandVisibleIndex | (Ereditato da TreeList)
Metodo protetto | GetCanShowEditor | (Ereditato da TreeList)
Metodo pubblico | GetColumnByColumnHandle | (Ereditato da TreeList)
Metodo pubblico | GetColumnByVisibleIndex | (Ereditato da TreeList)
Metodo protetto | GetColumnDefaultRepositoryItem | (Ereditato da TreeList)
Metodo protetto | GetColumnDefaultRepositoryItemForEditing | (Ereditato da TreeList)
Metodo protetto | GetColumnEdit | (Ereditato da TreeList)
Metodo protetto | GetColumnEditForEditing | (Ereditato da TreeList)
Metodo pubblico | GetColumnError(TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | GetColumnError(TreeListColumn, TreeListNode) | (Ereditato da TreeList)
Metodo pubblico | GetColumnErrorType(TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | GetColumnErrorType(TreeListColumn, TreeListNode) | (Ereditato da TreeList)
Metodo protetto | GetColumnFieldNameSort | (Ereditato da TreeList)
Metodo protetto | GetColumnFilterCriteria | (Ereditato da TreeList)
Metodo protetto | GetColumnFilterMode | (Ereditato da TreeList)
Metodo pubblico | GetColumnHeaderBestWidth | (Ereditato da TreeList)
Metodo protetto | GetColumnName | (Ereditato da TreeList)
Metodo protetto | GetCurrencyManager | (Ereditato da TreeList)
Metodo protetto | GetDataColumnInfo | (Ereditato da TreeList)
Metodo pubblico | GetDataRecordByNode | (Ereditato da TreeList)
Metodo pubblico | GetDataRow | (Ereditato da TreeList)
Metodo protetto | GetDirectXDeviceBackColor | (Ereditato da EditorContainer)
Metodo protetto | GetDirectXProvider | (Ereditato da EditorContainer)
Metodo protetto | GetEditableObject | (Ereditato da TreeList)
Metodo pubblico | GetEditorShowMode | (Ereditato da TreeList)
Metodo protetto | GetEditorViewInfo | (Ereditato da TreeList)
Metodo protetto | GetFilterColumn | (Ereditato da TreeList)
Metodo protetto | GetFilterColumnByTreeListColumn | (Ereditato da TreeList)
Metodo protetto | GetFilterCriteriaDisplayStyle | (Ereditato da TreeList)
Metodo protetto | GetFilterDisplayText | (Ereditato da TreeList)
Metodo protetto | GetFilterDisplayTextByColumn | (Ereditato da TreeList)
Metodo protetto | GetFilterPopupTexts | (Ereditato da TreeList)
Metodo protetto | GetFilterPopupValues(TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | GetFilterPopupValues(TreeListColumn, Boolean) | (Ereditato da TreeList)
Metodo protetto | GetFilterPopupValues(TreeListColumn, CriteriaOperator, Boolean) | (Ereditato da TreeList)
Metodo protetto | GetFilterPopupValues(TreeListColumn, Boolean, Boolean) | (Ereditato da TreeList)
Metodo protetto | GetFilterRowValue(Object) | (Ereditato da TreeList)
Metodo protetto | GetFilterRowValue(TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | GetFindMatchedRanges | (Ereditato da TreeList)
Metodo protetto | GetFindMatchedText | (Ereditato da TreeList)
Metodo protetto | GetFindToColumnsCollection | (Ereditato da TreeList)
Metodo pubblico | GetFocusedDataRow | (Ereditato da TreeList)
Metodo pubblico | GetFocusedDisplayText | (Ereditato da TreeList)
Metodo pubblico | GetFocusedRow | (Ereditato da TreeList)
Metodo pubblico | GetFocusedRowCellDisplayText(String) | (Ereditato da TreeList)
Metodo pubblico | GetFocusedRowCellDisplayText(TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetFocusedRowCellValue(String) | (Ereditato da TreeList)
Metodo pubblico | GetFocusedRowCellValue(TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetGroupSummaryValue | (Ereditato da TreeList)
Metodo protetto | GetHeaderFilterButtonShowMode | (Ereditato da TreeList)
Metodo pubblico | GetHitInfo | Obsoleto. (Ereditato da TreeList)
Metodo protetto | GetImageIndexFromDataSource | (Ereditato da TreeList)
Metodo protetto | GetMaxIndent | (Ereditato da TreeList)
Metodo protetto | GetNativePreviewText | (Ereditato da TreeList)
Metodo pubblico | GetNodeAt(Point) | (Ereditato da TreeList)
Metodo pubblico | GetNodeAt(Int32, Int32) | (Ereditato da TreeList)
Metodo pubblico | GetNodeByVisibleIndex | (Ereditato da TreeList)
Metodo protetto | GetNodeCellRepositoryItem | (Ereditato da TreeList)
Metodo protetto | GetNodeComparer(IComparerTreeListNode) | (Ereditato da TreeList)
Metodo protetto | GetNodeComparer(TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetNodeIndex | (Ereditato da TreeList)
Metodo pubblico | GetNodeList | (Ereditato da TreeList)
Metodo protetto | GetNodeValue(TreeListNode, TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | GetNodeValue(TreeListNode, Object) | (Ereditato da TreeList)
Metodo protetto | GetNodeValue(TreeListNode, String) | (Ereditato da TreeList)
Metodo protetto | GetNonFormattedCaption | (Ereditato da TreeList)
Metodo protetto | GetParentColumnFieldNameSort | (Ereditato da TreeList)
Metodo pubblico | GetRow | (Ereditato da TreeList)
Metodo pubblico | GetRowCellDisplayText(TreeListNode, TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetRowCellDisplayText(TreeListNode, String) | (Ereditato da TreeList)
Metodo pubblico | GetRowCellValue(TreeListNode, TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetRowCellValue(TreeListNode, String) | (Ereditato da TreeList)
Metodo protetto | GetRowsAsFootersCount | (Ereditato da TreeList)
Metodo pubblico | GetScrollAnnotations | (Ereditato da TreeList)
Metodo pubblico | GetSelectedCells | (Ereditato da TreeList)
Metodo pubblico | GetSelectedCells(TreeListNode) | (Ereditato da TreeList)
Metodo protetto | GetShowBandsMode | (Ereditato da TreeList)
Metodo protetto | GetShowFirstLines | (Ereditato da TreeList)
Metodo protetto | GetShowIndentAsRowStyle | (Ereditato da TreeList)
Metodo pubblico | GetSortColumn(Int32) | (Ereditato da TreeList)
Metodo protetto | GetSortColumn(TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetSummaryValue(TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetSummaryValue(TreeListColumn, Boolean) | (Ereditato da TreeList)
Metodo protetto | GetSummaryValueCore | (Ereditato da TreeList)
Metodo protetto | GetSummaryValueEx | (Ereditato da TreeList)
Metodo pubblico | GetToolTipController | (Ereditato da EditorContainer)
Metodo protetto | GetUseDirectXPaint | (Ereditato da TreeList)
Metodo pubblico | GetVisibleIndexByNode | (Ereditato da TreeList)
Metodo protetto | GetVisibleIndexByNodeCore | (Ereditato da TreeList)
Metodo protetto | GetVisibleParentNodesCount | (Ereditato da TreeList)
Metodo pubblico | HideCustomization | (Ereditato da TreeList)
Metodo pubblico | HideEditor | (Ereditato da TreeList)
Metodo protetto | HideEditorCore | (Ereditato da TreeList)
Metodo pubblico | HideFindPanel | (Ereditato da TreeList)
Metodo pubblico | HideLoadingPanel | (Ereditato da TreeList)
Metodo protetto | HookOnLoaded | (Ereditato da EditorContainer)
Metodo pubblico | ImportFromXml(Stream) | (Ereditato da TreeList)
Metodo pubblico | ImportFromXml(String) | (Ereditato da TreeList)
Metodo protetto | ImportFromXmlCore | (Ereditato da TreeList)
Metodo pubblico | IndentNodes | (Ereditato da TreeList)
Metodo protetto | InitFindPanel | (Ereditato da TreeList)
Metodo protetto | InitializeDirectXProvider | (Ereditato da EditorContainer)
Metodo protetto | InitScrollInfo | (Ereditato da TreeList)
Metodo protetto | InternalDeleteNode | (Ereditato da TreeList)
Metodo protetto | InternalDeleteNodeCore | (Ereditato da TreeList)
Metodo protetto | InternalDeleteNodes(DictionaryTreeListNodes, ListTreeListNode) | (Ereditato da TreeList)
Metodo protetto | InternalDeleteNodes(TreeListNodes) | (Ereditato da TreeList)
Metodo protetto | InternalFullCollapseNode | (Ereditato da TreeList)
Metodo protetto | InternalFullExpandNode | (Ereditato da TreeList)
Metodo protetto | InternalGetCustomNodeCellEdit | (Ereditato da TreeList)
Metodo protetto | InternalGetCustomNodeCellStyle | (Ereditato da TreeList)
Metodo pubblico | InternalGetService | (Ereditato da TreeList)
Metodo protetto | InternalNodeAdded | (Ereditato da TreeList)
Metodo protetto | InternalNodeChanged | (Ereditato da TreeList)
Metodo protetto | InternalSetTopVisibleNodePixel | (Ereditato da TreeList)
Metodo pubblico | InvalidateBand | (Ereditato da TreeList)
Metodo pubblico | InvalidateBandPanel | (Ereditato da TreeList)
Metodo pubblico | InvalidateCell | (Ereditato da TreeList)
Metodo pubblico | InvalidateColumnHeader | (Ereditato da TreeList)
Metodo pubblico | InvalidateColumnPanel | (Ereditato da TreeList)
Metodo pubblico | InvalidateFilterPanel | (Ereditato da TreeList)
Metodo pubblico | InvalidateNode | (Ereditato da TreeList)
Metodo pubblico | InvalidateNodes | (Ereditato da TreeList)
Metodo pubblico | InvalidateRow | (Ereditato da TreeList)
Metodo pubblico | InvalidateRowPreview | (Ereditato da TreeList)
Metodo protetto | InvalidateRows | (Ereditato da TreeList)
Metodo pubblico | InvalidateScrollAnnotations | (Ereditato da TreeList)
Metodo pubblico | InvalidateSummaryFooterPanel | (Ereditato da TreeList)
Metodo pubblico | InvokeMenuItemClick | (Ereditato da TreeList)
Metodo protetto | IsAllowDefaultFastBestFit | (Ereditato da TreeList)
Metodo protetto | IsAllowEditForm | (Ereditato da TreeList)
Metodo pubblico | IsAutoFilterNode | (Ereditato da TreeList)
Metodo pubblico | IsCellSelected | (Ereditato da TreeList)
Metodo protetto | IsColumnAllowAutoFilter | (Ereditato da TreeList)
Metodo protetto | IsColumnAllowFilter | (Ereditato da TreeList)
Metodo pubblico | IsColumnAllowFilterEditor | (Ereditato da TreeList)
Metodo protetto | IsColumnFieldNameSortExist | (Ereditato da TreeList)
Metodo protetto | IsColumnFiltered | (Ereditato da TreeList)
Metodo protetto | IsFilterByDisplayText | (Ereditato da TreeList)
Metodo protetto | IsFilterRow | (Ereditato da TreeList)
Metodo protetto | IsImplyNullLikeEmptyStringWhenFiltering | (Ereditato da TreeList)
Metodo protetto | IsInputChar | (Ereditato da TreeList)
Metodo protetto | IsInputKey | (Ereditato da TreeList)
Metodo pubblico | IsNewItemRow | (Ereditato da TreeList)
Metodo protetto | IsParentColumnFieldNameSortExist | (Ereditato da TreeList)
Metodo pubblico | IsRootNode | (Ereditato da TreeList)
Metodo protetto | IsRoundDateTime | (Ereditato da TreeList)
Metodo protetto | IsShowAllValuesInFilterPopup | (Ereditato da TreeList)
Metodo protetto | IsTopNewItemRow | (Ereditato da TreeList)
Metodo protetto | IsUserAutoFilterCondition | (Ereditato da TreeList)
Metodo pubblico | LayoutChanged | (Ereditato da TreeList)
Metodo protetto | LoadDataColumns | (Ereditato da TreeList)
Metodo protetto | LoadDataSource | (Ereditato da TreeList)
Metodo protetto | LockDirectXRendering | (Ereditato da TreeList)
Metodo protetto | LockFilteringUIClientFilterCriteriaBinding | (Ereditato da TreeList)
Metodo pubblico | LockReloadNodes | (Ereditato da TreeList)
Metodo pubblico | MakeColumnVisible | (Ereditato da TreeList)
Metodo protetto | MakeFocusedRowVisible | (Ereditato da TreeList)
Metodo pubblico | MakeNodeVisible | (Ereditato da TreeList)
Metodo protetto | MergeColumnFiltersCore | (Ereditato da TreeList)
Metodo pubblico | MoveFirst | (Ereditato da TreeList)
Metodo protetto | MoveFocusedCell | (Ereditato da TreeList)
Metodo pubblico | MoveLast | (Ereditato da TreeList)
Metodo pubblico | MoveLastVisible | (Ereditato da TreeList)
Metodo pubblico | MoveNext | (Ereditato da TreeList)
Metodo pubblico | MoveNextVisible | (Ereditato da TreeList)
Metodo pubblico | MoveNode(TreeListNode, TreeListNode) | (Ereditato da TreeList)
Metodo pubblico | MoveNode(TreeListNode, TreeListNode, Boolean) | (Ereditato da TreeList)
Metodo pubblico | MoveNode(TreeListNode, TreeListNode, Boolean, Int32) | (Ereditato da TreeList)
Metodo pubblico | MoveNodes | (Ereditato da TreeList)
Metodo protetto | MoveNodesCore | (Ereditato da TreeList)
Metodo pubblico | MovePrev | (Ereditato da TreeList)
Metodo pubblico | MovePrevVisible | (Ereditato da TreeList)
Metodo pubblico | MoveToNextScrollAnnotation | (Ereditato da TreeList)
Metodo pubblico | MoveToParent | (Ereditato da TreeList)
Metodo pubblico | MoveToPrevScrollAnnotation | (Ereditato da TreeList)
Metodo protetto | NormalizeVisibleBandIndices | (Ereditato da TreeList)
Metodo protetto | NormalizeVisibleColumnIndices | (Ereditato da TreeList)
Metodo protetto | OnActiveEditor_GotFocus | (Ereditato da TreeList)
Metodo protetto | OnActiveEditor_LostFocus | (Ereditato da TreeList)
Metodo protetto | OnActiveEditor_Modified | (Ereditato da TreeList)
Metodo protetto | OnActiveEditor_ValueChanged | (Ereditato da TreeList)
Metodo protetto | OnActiveEditor_ValueChanging | (Ereditato da TreeList)
Metodo protetto | OnActiveFilterChanged | (Ereditato da TreeList)
Metodo protetto | OnActiveFilterCriteriaChanged | (Ereditato da TreeList)
Metodo protetto | OnActiveFilterEnabledChanged | (Ereditato da TreeList)
Metodo protetto | OnAfterAddingNode | (Ereditato da TreeList)
Metodo protetto | OnAfterChangeCollapsed | (Ereditato da TreeList)
Metodo protetto | OnAfterChangeExpanded | (Ereditato da TreeList)
Metodo protetto | OnAfterDeletingNodes | (Ereditato da TreeList)
Metodo protetto | OnAllowBandColumnMultiRowChanged | (Ereditato da TreeList)
Metodo protetto | OnAllowSerializationProperty | (Ereditato da TreeList)
Metodo protetto | OnAppearancePrintChanged | (Ereditato da TreeList)
Metodo protetto | OnBandChanged | (Ereditato da TreeList)
Metodo protetto | OnBandCollectionChanged | (Ereditato da TreeList)
Metodo protetto | OnBandColumnCollectionChanged | (Ereditato da TreeList)
Metodo protetto | OnBandFixedChanged | (Ereditato da TreeList)
Metodo protetto | OnBandWidthChanged | (Ereditato da TreeList)
Metodo protetto | OnBeginTouchScroll | (Ereditato da TreeList)
Metodo protetto | OnBindingContextChanged | (Ereditato da TreeList)
Metodo protetto | OnCheckBoxFieldNameChanged | (Ereditato da TreeList)
Metodo protetto | OnClearNodes | (Ereditato da TreeList)
Metodo protetto | OnClearNodesComplete | (Ereditato da TreeList)
Metodo protetto | OnClick | (Ereditato da TreeList)
Metodo protetto | OnColumnAdded | (Ereditato da TreeList)
Metodo protetto | OnColumnChanged | (Ereditato da TreeList)
Metodo protetto | OnColumnFilterModeChanged | (Ereditato da TreeList)
Metodo protetto | OnColumnFilterRestored | (Ereditato da TreeList)
Metodo protetto | OnColumnInfosPopulated | (Ereditato da TreeList)
Metodo protetto | OnColumnRemoved | (Ereditato da TreeList)
Metodo protetto | OnColumnRowIndexChanged | (Ereditato da TreeList)
Metodo protetto | OnColumnsChanged | (Ereditato da TreeList)
Metodo protetto | OnColumnUnboundChanged | (Ereditato da TreeList)
Metodo protetto | OnColumnUnboundExpressionChanged | (Ereditato da TreeList)
Metodo protetto | OnContainerEnter | (Ereditato da EditorContainer)
Metodo protetto | OnContainerLeave | (Ereditato da EditorContainer)
Metodo protetto | OnContextMenuKey | (Ereditato da TreeList)
Metodo protetto | OnCreateControl | (Ereditato da EditorContainer)
Metodo protetto | OnDataListChanged | (Ereditato da TreeList)
Metodo protetto | OnDesignerHost_LoadComplete | (Ereditato da EditorContainer)
Metodo protetto | OnDesignerHost_TransactionClosed | (Ereditato da EditorContainer)
Metodo protetto | OnDirectXPaintDisabled | (Ereditato da TreeList)
Metodo protetto | OnDoubleClick | (Ereditato da TreeList)
Metodo protetto | OnDragDrop | (Ereditato da TreeList)
Metodo protetto | OnDragEnter | (Ereditato da TreeList)
Metodo protetto | OnDragLeave | (Ereditato da TreeList)
Metodo protetto | OnDragOver | (Ereditato da TreeList)
Metodo protetto | OnEnabledChanged | (Ereditato da TreeList)
Metodo protetto | OnEndInit | (Ereditato da EditorContainer)
Metodo protetto | OnEndSerializing | (Ereditato da TreeList)
Metodo protetto | OnEndSorting | (Ereditato da TreeList)
Metodo protetto | OnEnter | (Ereditato da EditorContainer)
Metodo protetto | OnErrorInfo_Changed | (Ereditato da TreeList)
Metodo protetto | OnFilterRowValueChanging | (Ereditato da TreeList)
Metodo protetto | OnFirstInit | (Ereditato da EditorContainer)
Metodo protetto | OnFormatConditionChanged | (Ereditato da TreeList)
Metodo protetto | OnFormatRuleExpressionEditorCreated | (Ereditato da TreeList)
Metodo protetto | OnFormatRulesCollectionChanged | (Ereditato da TreeList)
Metodo protetto | OnGotCapture | (Ereditato da EditorContainer)
Metodo protetto | OnGotFocus | (Ereditato da TreeList)
Metodo protetto | OnHandleCreated | (Ereditato da TreeList)
Metodo protetto | OnHandleDestroyed | (Ereditato da TreeList)
Metodo protetto | OnHorizontalTouchScroll | (Ereditato da TreeList)
Metodo protetto | OnHScroll | (Ereditato da TreeList)
Metodo protetto | OnItemAdded | (Ereditato da TreeList)
Metodo protetto | OnItemAdding | (Ereditato da TreeList)
Metodo protetto | OnItemChanged(Int32, PropertyDescriptor) | (Ereditato da TreeList)
Metodo protetto | OnItemChanged(Int32, PropertyDescriptor, TreeListNode) | (Ereditato da TreeList)
Metodo protetto | OnItemDeleted | (Ereditato da TreeList)
Metodo protetto | OnItemMoved | (Ereditato da TreeList)
Metodo protetto | OnKeyDown | (Ereditato da TreeList)
Metodo protetto | OnKeyPress | (Ereditato da TreeList)
Metodo protetto | OnKeyUp | (Ereditato da TreeList)
Metodo protetto | OnLeave | (Ereditato da EditorContainer)
Metodo protetto | OnLoaded | (Ereditato da TreeList)
Metodo protetto | OnLoadedCore | (Ereditato da TreeList)
Metodo protetto | OnLookAndFeelChanged(LookAndFeelChangedEventArgs) | (Ereditato da TreeList)
Metodo protetto | OnLookAndFeelChanged(Object, EventArgs) | (Ereditato da EditorContainer)
Metodo protetto | OnLostCapture | (Ereditato da TreeList)
Metodo protetto | OnLostFocus | (Ereditato da TreeList)
Metodo protetto | OnMenuShowing | (Ereditato da TreeList)
Metodo protetto | OnMouseClick | (Ereditato da EditorContainer)
Metodo protetto | OnMouseDoubleClick | (Ereditato da EditorContainer)
Metodo protetto | OnMouseDown | (Ereditato da TreeList)
Metodo protetto | OnMouseEnter | (Ereditato da TreeList)
Metodo protetto | OnMouseHWheel | (Ereditato da EditorContainer)
Metodo protetto | OnMouseLeave | (Ereditato da TreeList)
Metodo protetto | OnMouseMove | (Ereditato da TreeList)
Metodo protetto | OnMouseUp | (Ereditato da TreeList)
Metodo protetto | OnMouseWheel | (Ereditato da EditorContainer)
Metodo protetto | OnMouseWheelCore | (Ereditato da TreeList)
Metodo protetto | OnNodeCheckedChanged | (Ereditato da TreeList)
Metodo protetto | OnNodeRemoved | (Ereditato da TreeList)
Metodo protetto | OnNodesLoaded | (Ereditato da TreeList)
Metodo protetto | OnNodesLoading | (Ereditato da TreeList)
Metodo protetto | OnNodesRemoved | (Ereditato da TreeList)
Metodo protetto | OnOptionsBehaviorChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsCustomizationChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsDragAndDropChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsEditFormChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsFilterChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsFindChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsHtmlChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsNavigationChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsPrintChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsScrollAnnotationsChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsSelectionChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsViewChanged | (Ereditato da TreeList)
Metodo protetto | OnPaint | Implementazione dell'override di onPaint. Grazie al catch delle eccezioni evita l'uscita della X rossa sul form (Sovrascrive TreeList.OnPaint(PaintEventArgs))
Metodo protetto | OnPaintBackground | (Ereditato da TreeList)
Metodo protetto | OnParentChanged | (Ereditato da TreeList)
Metodo protetto | OnPressedBandChanged | (Ereditato da TreeList)
Metodo protetto | OnPrintProgress | (Ereditato da TreeList)
Metodo protetto | OnPropertyChanged | (Ereditato da TreeList)
Metodo protetto | OnPropertyDescriptorChanged | (Ereditato da TreeList)
Metodo protetto | OnQueryContinueDrag | (Ereditato da TreeList)
Metodo protetto | OnRepositoryItemRefreshRequired | (Ereditato da TreeList)
Metodo protetto | OnReset | (Ereditato da TreeList)
Metodo protetto | OnResetSerializationProperties | (Ereditato da TreeList)
Metodo protetto | OnResize | (Ereditato da TreeList)
Metodo protetto | OnRightToLeftChanged | (Ereditato da TreeList)
Metodo protetto | OnRightToLeftChanged(EventArgs) | (Ereditato da EditorContainer)
Metodo protetto | OnScaleControl | (Ereditato da TreeList)
Metodo protetto | OnScaleTreeListCore | (Ereditato da TreeList)
Metodo protetto | OnSelectionChanged | (Ereditato da TreeList)
Metodo protetto | OnSetValue | (Ereditato da TreeList)
Metodo protetto | OnSortModeChanged | (Ereditato da TreeList)
Metodo protetto | OnSourceItemChanged | (Ereditato da TreeList)
Metodo protetto | OnStartSerializing | (Ereditato da TreeList)
Metodo protetto | OnStartSorting | (Ereditato da TreeList)
Metodo protetto | OnSystemColorsChanged | (Ereditato da TreeList)
Metodo protetto | OnToolTipControllerDisposed | (Ereditato da EditorContainer)
Metodo protetto | OnTouchScroll | (Ereditato da TreeList)
Metodo protetto | OnTouchZoom | (Ereditato da TreeList)
Metodo protetto | OnValidated | (Ereditato da EditorContainer)
Metodo protetto | OnValidating | (Ereditato da TreeList)
Metodo protetto | OnVerticalTouchScroll | (Ereditato da TreeList)
Metodo protetto | OnVisibleChanged | (Ereditato da TreeList)
Metodo protetto | OnVScroll | (Ereditato da TreeList)
Metodo protetto | OnVScrollCore | (Ereditato da TreeList)
Metodo pubblico | OutdentNodes | (Ereditato da TreeList)
Metodo protetto | ParseAutoFilter | (Ereditato da TreeList)
Metodo protetto | ParseAutoFilterValues | (Ereditato da TreeList)
Metodo pubblico | PasteFromClipboard | (Ereditato da TreeList)
Metodo pubblico | PopulateColumns | (Ereditato da TreeList)
Metodo pubblico | PostEditor | (Ereditato da TreeList)
Metodo protetto | PostEditor(Boolean) | (Ereditato da TreeList)
Metodo pubblico | Print | (Ereditato da TreeList)
Metodo protetto | PrintCore | (Ereditato da TreeList)
Metodo pubblico | PrintDialog | (Ereditato da TreeList)
Metodo protetto | PrintDialogCore | (Ereditato da TreeList)
Metodo protetto | ProcessControlTab | (Ereditato da TreeList)
Metodo protetto | ProcessControlTab(Boolean) | (Ereditato da TreeList)
Metodo protetto | ProcessDialogKey | (Ereditato da TreeList)
Metodo protetto | ProcessDirectXPaint | (Ereditato da TreeList)
Metodo protetto | RaiseAfterCheckNode | (Ereditato da TreeList)
Metodo protetto | RaiseAfterCollapse | (Ereditato da TreeList)
Metodo protetto | RaiseAfterDragNode | (Ereditato da TreeList)
Metodo protetto | RaiseAfterDropNode | (Ereditato da TreeList)
Metodo protetto | RaiseAfterExpand | (Ereditato da TreeList)
Metodo protetto | RaiseAfterFocusNode | (Ereditato da TreeList)
Metodo protetto | RaiseBandPositionChanged | (Ereditato da TreeList)
Metodo protetto | RaiseBandWidthChanged | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeCheckNode | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeCollapse | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeDragNode | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeDropNode | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeExpand | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeFocusNode | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeLoadLayout | (Ereditato da TreeList)
Metodo protetto | RaiseCalcNodeDragImageIndex | (Ereditato da TreeList)
Metodo protetto | RaiseCalcNodeHeight(TreeListNode, Int32) | (Ereditato da TreeList)
Metodo protetto | RaiseCalcNodeHeight(TreeListNode, RowInfo, Int32) | (Ereditato da TreeList)
Metodo protetto | RaiseCellValueChanged | (Ereditato da TreeList)
Metodo protetto | RaiseCellValueChanging | (Ereditato da TreeList)
Metodo protetto | RaiseCheckedColumnFilterPopupEvent | (Ereditato da TreeList)
Metodo protetto | RaiseClipboardNodeCopying | (Ereditato da TreeList)
Metodo protetto | RaiseClipboardNodePasting | (Ereditato da TreeList)
Metodo protetto | RaiseColumnButtonClick | (Ereditato da TreeList)
Metodo protetto | RaiseColumnChanged | (Ereditato da TreeList)
Metodo protetto | RaiseColumnFilterChanged | (Ereditato da TreeList)
Metodo protetto | RaiseColumnFilterPopupEvent | (Ereditato da TreeList)
Metodo protetto | RaiseColumnPositionChanged | (Ereditato da TreeList)
Metodo protetto | RaiseColumnUnboundExpressionChanged | (Ereditato da TreeList)
Metodo protetto | RaiseColumnWidthChanged | (Ereditato da TreeList)
Metodo protetto | RaiseCompareNodeValues | (Ereditato da TreeList)
Metodo protetto | RaiseCreateCustomNode | (Ereditato da TreeList)
Metodo protetto | RaiseCustomColumnDisplayText(CustomColumnDisplayTextEventArgs) | (Ereditato da TreeList)
Metodo protetto | RaiseCustomColumnDisplayText(TreeListNode, CellInfo) | (Ereditato da TreeList)
Metodo protetto | RaiseCustomColumnDisplayText(TreeListNode, TreeListColumn, BaseEditViewInfo) | (Ereditato da TreeList)
Metodo protetto | RaiseCustomColumnDisplayText(TreeListNode, TreeListColumn, Object, String) | (Ereditato da TreeList)
Metodo protetto | RaiseCustomColumnSort | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawBandHeader | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawColumnHeader | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawEmptyArea | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawFilterPanel | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawFooter | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawFooterCell | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodeButton | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodeCell | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodeCheckBox | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodeImages | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodeIndent | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodeIndicator | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodePreview | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawRow | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawRowFooter | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawRowFooterCell | (Ereditato da TreeList)
Metodo protetto | RaiseCustomFilterDisplayText | (Ereditato da TreeList)
Metodo protetto | RaiseCustomizationFormSearch | (Ereditato da TreeList)
Metodo protetto | RaiseCustomizeNewNodeFromOuterData | (Ereditato da TreeList)
Metodo protetto | RaiseCustomRowFilter | (Ereditato da TreeList)
Metodo protetto | RaiseCustomRowFilterEvent | (Ereditato da TreeList)
Metodo protetto | RaiseCustomUnboundColumnData | (Ereditato da TreeList)
Metodo protetto | RaiseDataSourceChanged | (Ereditato da TreeList)
Metodo protetto | RaiseDefaultPaintHelperChanged | (Ereditato da TreeList)
Metodo protetto | RaiseDragCancelNode | (Ereditato da TreeList)
Metodo protetto | RaiseDragObjectDrop | (Ereditato da TreeList)
Metodo protetto | RaiseDragObjectOver | (Ereditato da TreeList)
Metodo protetto | RaiseDragObjectStart | (Ereditato da TreeList)
Metodo protetto | RaiseEditFormHidden | (Ereditato da TreeList)
Metodo protetto | RaiseEditFormPrepared | (Ereditato da TreeList)
Metodo protetto | RaiseEditFormShowing | (Ereditato da TreeList)
Metodo protetto | RaiseEditorKeyDown | (Ereditato da TreeList)
Metodo protetto | RaiseEditorKeyPress | (Ereditato da EditorContainer)
Metodo protetto | RaiseEditorKeyUp | (Ereditato da EditorContainer)
Metodo protetto | RaiseEndSorting | (Ereditato da TreeList)
Metodo protetto | RaiseExcelColumnFilterPopupEvent | (Ereditato da TreeList)
Metodo protetto | RaiseFilterEditorCreated | (Ereditato da TreeList)
Metodo protetto | RaiseFilterExpressionEditorCreated | (Ereditato da TreeList)
Metodo protetto | RaiseFilterNodeEvent | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupDate | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelCustomizeTemplate | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelData(FilterPopupExcelDataEventArgs) | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelData(TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelData(TreeListColumn, CriteriaOperator) | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelData(TreeListColumn, TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelParseFilterCriteria | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelPrepareTemplate | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelQueryFilterCriteria | (Ereditato da TreeList)
Metodo protetto | RaiseFocusedColumnChanged | (Ereditato da TreeList)
Metodo protetto | RaiseFocusedNodeChanged | (Ereditato da TreeList)
Metodo protetto | RaiseGetCustomAnnotations | (Ereditato da TreeList)
Metodo protetto | RaiseGetCustomNodeCellEdit | (Ereditato da TreeList)
Metodo protetto | RaiseGetCustomNodeCellStyle | (Ereditato da TreeList)
Metodo protetto | RaiseGetCustomSummaryValue | (Ereditato da TreeList)
Metodo protetto | RaiseGetNodeDisplayValue | (Ereditato da TreeList)
Metodo protetto | RaiseGetPreviewText | (Ereditato da TreeList)
Metodo protetto | RaiseGetPrintCustomSummaryValue | (Ereditato da TreeList)
Metodo protetto | RaiseGetPrintPreviewText | (Ereditato da TreeList)
Metodo protetto | RaiseGetSelectImage | (Ereditato da TreeList)
Metodo protetto | RaiseGetStateImage | (Ereditato da TreeList)
Metodo protetto | RaiseHiddenEditor | (Ereditato da TreeList)
Metodo protetto | RaiseHideCustomizationForm | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementBlur | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementFocus | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseClick | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseDoubleClick | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseDown | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseMove | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseOut | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseOver | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseUp | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlSelectedTextChanged | (Ereditato da TreeList)
Metodo protetto | RaiseInitNewRow | (Ereditato da TreeList)
Metodo protetto | RaiseInvalidNodeException | (Ereditato da TreeList)
Metodo protetto | RaiseInvalidValueException | (Ereditato da TreeList)
Metodo protetto | RaiseLayoutUpdated | (Ereditato da TreeList)
Metodo protetto | RaiseLayoutUpgrade | (Ereditato da TreeList)
Metodo protetto | RaiseLeftCoordChanged | (Ereditato da TreeList)
Metodo protetto | RaiseLoad | (Ereditato da TreeList)
Metodo protetto | RaiseMeasurePreviewHeight | (Ereditato da TreeList)
Metodo protetto | RaiseNodeChanged | (Ereditato da TreeList)
Metodo protetto | RaiseNodesReloaded | (Ereditato da TreeList)
Metodo protetto | RaisePaintEx | (Ereditato da TreeList)
Metodo protetto | RaiseParseFindPanelText | (Ereditato da TreeList)
Metodo protetto | RaisePopupMenuShowing | (Ereditato da TreeList)
Metodo protetto | RaisePrintExportProgress | (Ereditato da TreeList)
Metodo protetto | RaiseQueryCustomFunctions | (Ereditato da TreeList)
Metodo protetto | RaiseRequireHideEditor | (Ereditato da EditorContainer)
Metodo protetto | RaiseRowCellClick | (Ereditato da TreeList)
Metodo protetto | RaiseRowClick | (Ereditato da TreeList)
Metodo protetto | RaiseRowSelectImageClick | (Ereditato da TreeList)
Metodo protetto | RaiseRowStateImageClick | (Ereditato da TreeList)
Metodo protetto | RaiseSelectImageClick | (Ereditato da TreeList)
Metodo protetto | RaiseSelectionChanged | (Ereditato da TreeList)
Metodo protetto | RaiseSelectionChanging | (Ereditato da TreeList)
Metodo protetto | RaiseShowCustomizationForm | (Ereditato da TreeList)
Metodo protetto | RaiseShowingEditor | (Ereditato da TreeList)
Metodo protetto | RaiseShownEditor | (Ereditato da TreeList)
Metodo protetto | RaiseShowTreeListMenu | Obsoleto. (Ereditato da TreeList)
Metodo protetto | RaiseStartSorting | (Ereditato da TreeList)
Metodo protetto | RaiseStateChanged | (Ereditato da TreeList)
Metodo protetto | RaiseStateImageClick | (Ereditato da TreeList)
Metodo protetto | RaiseSubstituteFilter | (Ereditato da TreeList)
Metodo protetto | RaiseTopVisibleNodeIndexChanged | (Ereditato da TreeList)
Metodo protetto | RaiseTreeListMenuItemClick | (Ereditato da TreeList)
Metodo protetto | RaiseUnboundExpressionEditorCreated | (Ereditato da TreeList)
Metodo protetto | RaiseValidateNode | (Ereditato da TreeList)
Metodo protetto | RaiseValidatingEditor | (Ereditato da TreeList)
Metodo protetto | RecalcSortColumns | (Ereditato da TreeList)
Metodo protetto | RecreateRowsInfoCore | (Ereditato da TreeList)
Metodo pubblico | Refresh | (Ereditato da TreeList)
Metodo pubblico | Refresh(Boolean) | (Ereditato da TreeList)
Metodo pubblico | RefreshCell | (Ereditato da TreeList)
Metodo protetto | RefreshCellCore | (Ereditato da TreeList)
Metodo protetto | RefreshColumnsInfo | (Ereditato da TreeList)
Metodo pubblico | RefreshDataSource | (Ereditato da TreeList)
Metodo pubblico | RefreshEditor | (Ereditato da TreeList)
Metodo protetto | RefreshEditorError | (Ereditato da TreeList)
Metodo protetto | RefreshHeadersInfo | (Ereditato da TreeList)
Metodo protetto | RefreshHtmlNodeCore | (Ereditato da TreeList)
Metodo pubblico | RefreshNode | (Ereditato da TreeList)
Metodo protetto | RefreshNodeCore | (Ereditato da TreeList)
Metodo protetto | RefreshRowsInfo | (Ereditato da TreeList)
Metodo protetto | RefreshRowsInfo(Boolean, Boolean) | (Ereditato da TreeList)
Metodo pubblico | RefreshScrollAnnotations(ScrollAnnotationKind) | (Ereditato da TreeList)
Metodo pubblico | RefreshScrollAnnotations(ScrollAnnotationKind, Int32) | (Ereditato da TreeList)
Metodo protetto | RefreshVirtualCellCore | (Ereditato da TreeList)
Metodo protetto | RefreshVirtualNodeCore | (Ereditato da TreeList)
Metodo protetto | RejectCurrentChanges | (Ereditato da TreeList)
Metodo protetto | RemoveFromDefaultTooltipController | (Ereditato da EditorContainer)
Metodo protetto | RemoveHookOnLoaded | (Ereditato da EditorContainer)
Metodo protetto | RemoveNodeHeight | (Ereditato da TreeList)
Metodo protetto | RequestCellEditor | (Ereditato da TreeList)
Metodo protetto | ResetAccessibility | (Ereditato da TreeList)
Metodo pubblico | ResetAutoFilterCondition | (Ereditato da TreeList)
Metodo pubblico | ResetAutoFilterConditions | (Ereditato da TreeList)
Metodo pubblico | ResetAutoFilterConditions(IEnumerableTreeListColumn) | (Ereditato da TreeList)
Metodo protetto | ResetAutoFilterConditionsCore | (Ereditato da TreeList)
Metodo protetto | ResetColumnAutoFilterConditions | (Ereditato da TreeList)
Metodo pubblico | ResetEditorsCache(RepositoryItem) | (Ereditato da EditorContainer)
Metodo pubblico | ResetEditorsCache(Type) | (Ereditato da EditorContainer)
Metodo protetto | ResetExcelFilteringProvider | (Ereditato da TreeList)
Metodo protetto | ResetLookAndFeel | (Ereditato da EditorContainer)
Metodo protetto | ResetRowCount | (Ereditato da TreeList)
Metodo protetto | ResetSortedColumns | (Ereditato da TreeList)
Metodo protetto | ResizeBand | (Ereditato da TreeList)
Metodo protetto | ResizeColumn | (Ereditato da TreeList)
Metodo protetto | ResolveAutoFilterCondition | (Ereditato da TreeList)
Metodo protetto | RestoreLayoutCore | (Ereditato da TreeList)
Metodo pubblico | RestoreLayoutFromRegistry(String) | (Ereditato da TreeList)
Metodo pubblico | RestoreLayoutFromRegistry(String, OptionsLayoutBase) | (Ereditato da TreeList)
Metodo pubblico | RestoreLayoutFromStream(Stream) | (Ereditato da TreeList)
Metodo pubblico | RestoreLayoutFromStream(Stream, OptionsLayoutBase) | (Ereditato da TreeList)
Metodo pubblico | RestoreLayoutFromXml(String) | (Ereditato da TreeList)
Metodo pubblico | RestoreLayoutFromXml(String, OptionsLayoutBase) | (Ereditato da TreeList)
Metodo protetto | RestoreNodesData | (Ereditato da TreeList)
Metodo protetto | SaveLayoutCore | (Ereditato da TreeList)
Metodo pubblico | SaveLayoutToRegistry(String) | (Ereditato da TreeList)
Metodo pubblico | SaveLayoutToRegistry(String, OptionsLayoutBase) | (Ereditato da TreeList)
Metodo pubblico | SaveLayoutToStream(Stream) | (Ereditato da TreeList)
Metodo pubblico | SaveLayoutToStream(Stream, OptionsLayoutBase) | (Ereditato da TreeList)
Metodo pubblico | SaveLayoutToXml(String) | (Ereditato da TreeList)
Metodo pubblico | SaveLayoutToXml(String, OptionsLayoutBase) | (Ereditato da TreeList)
Metodo protetto | SaveNodesData | (Ereditato da TreeList)
Metodo protetto | ScaleControl | (Ereditato da EditorContainer)
Metodo protetto | Scrollbar_MouseEnter | (Ereditato da TreeList)
Metodo protetto | Scrollbar_MouseLeave | (Ereditato da TreeList)
Metodo protetto | ScrollHorizontalEx | (Ereditato da TreeList)
Metodo protetto | ScrollVerticalEx | (Ereditato da TreeList)
Metodo pubblico | SelectAll | (Ereditato da TreeList)
Metodo pubblico | SelectCell | (Ereditato da TreeList)
Metodo protetto | SelectCellCore | (Ereditato da TreeList)
Metodo pubblico | SelectCells(Int32, String, Int32, String) | (Ereditato da TreeList)
Metodo pubblico | SelectCells(TreeListNode, TreeListColumn, TreeListNode, TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | SelectNode | (Ereditato da TreeList)
Metodo protetto | SelectNodeCore | (Ereditato da TreeList)
Metodo pubblico | SelectNodes(Int32, Int32) | (Ereditato da TreeList)
Metodo pubblico | SelectNodes(TreeListNode, TreeListNode) | (Ereditato da TreeList)
Metodo protetto | SelectNodesCore | (Ereditato da TreeList)
Metodo protetto | ServiceColumnChanged | (Ereditato da TreeList)
Metodo pubblico | SetAutoFilterValue | (Ereditato da TreeList)
Metodo protetto | SetCellSelection | (Ereditato da TreeList)
Metodo protetto | SetCellSelectionCore | (Ereditato da TreeList)
Metodo pubblico | SetColumnError(TreeListColumn, String) | (Ereditato da TreeList)
Metodo pubblico | SetColumnError(TreeListColumn, String, ErrorType) | (Ereditato da TreeList)
Metodo protetto | SetColumnFixedStyle | (Ereditato da TreeList)
Metodo pubblico | SetColumnPosition | (Ereditato da TreeList)
Metodo protetto | SetColumnVisibleIndex | (Ereditato da TreeList)
Metodo pubblico | SetDefaultBehaviorOptions | (Ereditato da TreeList)
Metodo pubblico | SetDefaultCustomizationOptions | (Ereditato da TreeList)
Metodo pubblico | SetDefaultNavigationOptions | (Ereditato da TreeList)
Metodo pubblico | SetDefaultOptionsView | (Ereditato da TreeList)
Metodo pubblico | SetDefaultPrintOptions | (Ereditato da TreeList)
Metodo pubblico | SetDefaultRowHeight | (Ereditato da TreeList)
Metodo pubblico | SetDefaultSelectionOptions | (Ereditato da TreeList)
Metodo protetto | SetExtraFilter | (Ereditato da TreeList)
Metodo protetto | SetFilterRowValue(Object, Object) | (Ereditato da TreeList)
Metodo protetto | SetFilterRowValue(TreeListColumn, Object) | (Ereditato da TreeList)
Metodo pubblico | SetFocusedNode | (Ereditato da TreeList)
Metodo protetto | SetFocusedNodeCore | (Ereditato da TreeList)
Metodo pubblico | SetFocusedRowCellValue(String, Object) | (Ereditato da TreeList)
Metodo pubblico | SetFocusedRowCellValue(TreeListColumn, Object) | (Ereditato da TreeList)
Metodo protetto | SetFocusedRowIndexCore | (Ereditato da TreeList)
Metodo pubblico | SetFocusedValue | (Ereditato da TreeList)
Metodo pubblico | SetNodeCheckState(TreeListNode, CheckState) | (Ereditato da TreeList)
Metodo pubblico | SetNodeCheckState(TreeListNode, CheckState, Boolean) | (Ereditato da TreeList)
Metodo pubblico | SetNodeIndex | (Ereditato da TreeList)
Metodo protetto | SetNodeIndexCore | (Ereditato da TreeList)
Metodo protetto | SetNodeValue | (Ereditato da TreeList)
Metodo pubblico | SetRowCellValue(TreeListNode, TreeListColumn, Object) | (Ereditato da TreeList)
Metodo pubblico | SetRowCellValue(TreeListNode, String, Object) | (Ereditato da TreeList)
Metodo pubblico | SetSearchControl | (Ereditato da TreeList)
Metodo pubblico | SetSelectionAnchor | (Ereditato da TreeList)
Metodo protetto | SetUseDirectXPaint | (Ereditato da TreeList)
Metodo protetto | ShouldResortNodesOnItemChanged | (Ereditato da TreeList)
Metodo protetto | ShouldSerializeLookAndFeel | (Ereditato da EditorContainer)
Metodo pubblico | ShowAutoFilterConditionsMenu | (Ereditato da TreeList)
Metodo pubblico | ShowContextMenu | (Ereditato da TreeList)
Metodo pubblico | ShowCustomization | (Ereditato da TreeList)
Metodo pubblico | ShowCustomization(Point) | (Ereditato da TreeList)
Metodo pubblico | ShowEditForm | (Ereditato da TreeList)
Metodo protetto | ShowEditFormCore | (Ereditato da TreeList)
Metodo protetto | ShowEditFormDialogCore | (Ereditato da TreeList)
Metodo pubblico | ShowEditor | (Ereditato da TreeList)
Metodo pubblico | ShowEditor(String) | (Ereditato da TreeList)
Metodo pubblico | ShowFilterEditor | (Ereditato da TreeList)
Metodo protetto | ShowFilterExpressionEditor | (Ereditato da TreeList)
Metodo pubblico | ShowFilterPopup | (Ereditato da TreeList)
Metodo pubblico | ShowFindPanel | (Ereditato da TreeList)
Metodo pubblico | ShowLoadingPanel | (Ereditato da TreeList)
Metodo protetto | ShowMenu | (Ereditato da TreeList)
Metodo protetto | ShowMRUFilterPopup | (Ereditato da TreeList)
Metodo pubblico | ShowPrintPreview | (Ereditato da TreeList)
Metodo protetto | ShowPrintPreviewCore | (Ereditato da TreeList)
Metodo protetto | ShowProgressForm | (Ereditato da TreeList)
Metodo pubblico | ShowRibbonPrintPreview | (Ereditato da TreeList)
Metodo protetto | ShowRibbonPrintPreviewCore | (Ereditato da TreeList)
Metodo pubblico | ShowUnboundExpressionEditor | (Ereditato da TreeList)
Metodo pubblico | Sort(TreeListNode, IComparerTreeListNode, Boolean) | (Ereditato da TreeList)
Metodo protetto | Sort(TreeListNodes, Boolean, Boolean) | (Ereditato da TreeList)
Metodo pubblico | Sort(TreeListNode, TreeListColumn, SortOrder, Boolean) | (Ereditato da TreeList)
Metodo pubblico | StartIncrementalSearch | (Ereditato da TreeList)
Metodo protetto | StartOfficeScrolling | (Ereditato da TreeList)
Metodo pubblico | StopIncrementalSearch | (Ereditato da TreeList)
Metodo protetto | StopOfficeScrolling | (Ereditato da TreeList)
Metodo pubblico | UncheckAll | (Ereditato da TreeList)
Metodo protetto | UnlockDirectXRendering | (Ereditato da TreeList)
Metodo pubblico | UnlockReloadNodes | (Ereditato da TreeList)
Metodo pubblico | UnselectCell | (Ereditato da TreeList)
Metodo protetto | UnselectCellCore | (Ereditato da TreeList)
Metodo pubblico | UnselectCells(Int32, String, Int32, String) | (Ereditato da TreeList)
Metodo pubblico | UnselectCells(TreeListNode, TreeListColumn, TreeListNode, TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | UnselectNode | (Ereditato da TreeList)
Metodo pubblico | UnselectNodes(Int32, Int32) | (Ereditato da TreeList)
Metodo pubblico | UnselectNodes(TreeListNode, TreeListNode) | (Ereditato da TreeList)
Metodo protetto | UpdateActiveFilterInfo | (Ereditato da TreeList)
Metodo protetto | UpdateAutoFilterRowActiveEditor | (Ereditato da TreeList)
Metodo protetto | UpdateBandColumnsIndices | (Ereditato da TreeList)
Metodo protetto | UpdateBandColumnsOrder | (Ereditato da TreeList)
Metodo protetto | UpdateColumnAutoFilter | (Ereditato da TreeList)
Metodo protetto | UpdateColumnsSortIndices | (Ereditato da TreeList)
Metodo protetto | UpdateElementsLookAndFeel | (Ereditato da TreeList)
Metodo protetto | UpdateFilter | (Ereditato da TreeList)
Metodo protetto | UpdateFilterInfo | (Ereditato da TreeList)
Metodo protetto | UpdateFindPanelFilterText | (Ereditato da TreeList)
Metodo protetto | UpdateLayout | (Ereditato da TreeList)
Metodo protetto | UpdateRootBands | (Ereditato da TreeList)
Metodo protetto | UpdateSelectCell | (Ereditato da TreeList)
Metodo protetto | UpdateSelectCell(TreeListNode, TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | UpdateSelectNode | (Ereditato da TreeList)
Metodo protetto | UpdateSelectNode(TreeListNode) | (Ereditato da TreeList)
Metodo protetto | UpdateVScrollBarCore | (Ereditato da TreeList)
Metodo protetto | ValidateAndEndCurrentEdit | (Ereditato da TreeList)
Metodo protetto | WndProc | (Ereditato da TreeList)
Metodo protetto | XtraClearColumns | (Ereditato da TreeList)
Metodo protetto | XtraCreateColumnsItem | (Ereditato da TreeList)
Metodo protetto | XtraFindColumnsItem | (Ereditato da TreeList)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | AfterCheckNode | (Ereditato da TreeList)
Evento pubblico | AfterCollapse | (Ereditato da TreeList)
Evento pubblico | AfterDragNode | (Ereditato da TreeList)
Evento pubblico | AfterDropNode | (Ereditato da TreeList)
Evento pubblico | AfterExpand | (Ereditato da TreeList)
Evento pubblico | AfterFocusNode | (Ereditato da TreeList)
Evento pubblico | BandPositionChanged | (Ereditato da TreeList)
Evento pubblico | BandWidthChanged | (Ereditato da TreeList)
Evento pubblico | BeforeCheckNode | (Ereditato da TreeList)
Evento pubblico | BeforeCollapse | (Ereditato da TreeList)
Evento pubblico | BeforeDragNode | (Ereditato da TreeList)
Evento pubblico | BeforeDropNode | (Ereditato da TreeList)
Evento pubblico | BeforeExpand | (Ereditato da TreeList)
Evento pubblico | BeforeFocusNode | (Ereditato da TreeList)
Evento pubblico | BeforeLoadLayout | (Ereditato da TreeList)
Evento pubblico | CalcNodeDragImageIndex | (Ereditato da TreeList)
Evento pubblico | CalcNodeHeight | (Ereditato da TreeList)
Evento pubblico | CellValueChanged | (Ereditato da TreeList)
Evento pubblico | CellValueChanging | (Ereditato da TreeList)
Evento pubblico | ClipboardNodeCopying | (Ereditato da TreeList)
Evento pubblico | ClipboardNodePasting | (Ereditato da TreeList)
Evento pubblico | ColumnButtonClick | (Ereditato da TreeList)
Evento pubblico | ColumnChanged | (Ereditato da TreeList)
Evento pubblico | ColumnFilterChanged | (Ereditato da TreeList)
Evento pubblico | ColumnPositionChanged | (Ereditato da TreeList)
Evento pubblico | ColumnUnboundExpressionChanged | (Ereditato da TreeList)
Evento pubblico | ColumnWidthChanged | (Ereditato da TreeList)
Evento pubblico | CompareNodeValues | (Ereditato da TreeList)
Evento pubblico | CreateCustomNode | (Ereditato da TreeList)
Evento pubblico | CustomColumnDisplayText | (Ereditato da TreeList)
Evento pubblico | CustomColumnSort | (Ereditato da TreeList)
Evento pubblico | CustomDrawBandHeader | (Ereditato da TreeList)
Evento pubblico | CustomDrawColumnHeader | (Ereditato da TreeList)
Evento pubblico | CustomDrawEmptyArea | (Ereditato da TreeList)
Evento pubblico | CustomDrawFilterPanel | (Ereditato da TreeList)
Evento pubblico | CustomDrawFooter | (Ereditato da TreeList)
Evento pubblico | CustomDrawFooterCell | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodeButton | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodeCell | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodeCheckBox | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodeImages | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodeIndent | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodeIndicator | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodePreview | (Ereditato da TreeList)
Evento pubblico | CustomDrawRow | (Ereditato da TreeList)
Evento pubblico | CustomDrawRowFooter | (Ereditato da TreeList)
Evento pubblico | CustomDrawRowFooterCell | (Ereditato da TreeList)
Evento pubblico | CustomDrawScroll | (Ereditato da TreeList)
Evento pubblico | CustomFilterDisplayText | (Ereditato da TreeList)
Evento pubblico | CustomizationFormSearch | (Ereditato da TreeList)
Evento pubblico | CustomizeNewNodeFromOuterData | (Ereditato da TreeList)
Evento pubblico | CustomizeNodeTemplate | (Ereditato da TreeList)
Evento pubblico | CustomNodeCellEdit | (Ereditato da TreeList)
Evento pubblico | CustomNodeCellEditForEditing | (Ereditato da TreeList)
Evento pubblico | CustomRowFilter | (Ereditato da TreeList)
Evento pubblico | CustomScrollAnnotation | (Ereditato da TreeList)
Evento pubblico | CustomUnboundColumnData | (Ereditato da TreeList)
Evento pubblico | DataSourceChanged | (Ereditato da TreeList)
Evento pubblico | DefaultPaintHelperChanged | (Ereditato da TreeList)
Evento pubblico | DragCancelNode | (Ereditato da TreeList)
Evento pubblico | DragObjectDrop | (Ereditato da TreeList)
Evento pubblico | DragObjectOver | (Ereditato da TreeList)
Evento pubblico | DragObjectStart | (Ereditato da TreeList)
Evento pubblico | EditFormHidden | (Ereditato da TreeList)
Evento pubblico | EditFormPrepared | (Ereditato da TreeList)
Evento pubblico | EditFormShowing | (Ereditato da TreeList)
Evento pubblico | EditorKeyDown | (Ereditato da EditorContainer)
Evento pubblico | EditorKeyPress | (Ereditato da EditorContainer)
Evento pubblico | EditorKeyUp | (Ereditato da EditorContainer)
Evento pubblico | EndSorting | (Ereditato da TreeList)
Evento pubblico | FilterEditorCreated | (Ereditato da TreeList)
Evento pubblico | FilterExpressionEditorCreated | (Ereditato da TreeList)
Evento pubblico | FilterNode | (Ereditato da TreeList)
Evento pubblico | FilterPopupExcelCustomizeTemplate | (Ereditato da TreeList)
Evento pubblico | FilterPopupExcelData | (Ereditato da TreeList)
Evento pubblico | FilterPopupExcelParseFilterCriteria | (Ereditato da TreeList)
Evento pubblico | FilterPopupExcelPrepareTemplate | (Ereditato da TreeList)
Evento pubblico | FilterPopupExcelQueryFilterCriteria | (Ereditato da TreeList)
Evento pubblico | FocusedColumnChanged | (Ereditato da TreeList)
Evento pubblico | FocusedNodeChanged | (Ereditato da TreeList)
Evento pubblico | FormatRuleExpressionEditorCreated | (Ereditato da TreeList)
Evento pubblico | GetCustomNodeCellEdit | Obsoleto. (Ereditato da TreeList)
Evento pubblico | GetCustomNodeCellStyle | Obsoleto. (Ereditato da TreeList)
Evento pubblico | GetCustomSummaryValue | (Ereditato da TreeList)
Evento pubblico | GetNodeDisplayValue | (Ereditato da TreeList)
Evento pubblico | GetPreviewText | (Ereditato da TreeList)
Evento pubblico | GetPrintCustomSummaryValue | (Ereditato da TreeList)
Evento pubblico | GetPrintPreviewText | (Ereditato da TreeList)
Evento pubblico | GetSelectImage | (Ereditato da TreeList)
Evento pubblico | GetStateImage | (Ereditato da TreeList)
Evento pubblico | HiddenEditor | (Ereditato da TreeList)
Evento pubblico | HideCustomizationForm | (Ereditato da TreeList)
Evento pubblico | HtmlElementBlur | (Ereditato da TreeList)
Evento pubblico | HtmlElementFocus | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseClick | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseDoubleClick | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseDown | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseMove | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseOut | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseOver | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseUp | (Ereditato da TreeList)
Evento pubblico | HtmlSelectedTextChanged | (Ereditato da TreeList)
Evento pubblico | HyperlinkClick | (Ereditato da TreeList)
Evento pubblico | InitNewRow | (Ereditato da TreeList)
Evento pubblico | InvalidNodeException | (Ereditato da TreeList)
Evento pubblico | InvalidValueException | (Ereditato da TreeList)
Evento pubblico | LayoutUpdated | (Ereditato da TreeList)
Evento pubblico | LayoutUpgrade | (Ereditato da TreeList)
Evento pubblico | LeftCoordChanged | (Ereditato da TreeList)
Evento pubblico | Load | (Ereditato da TreeList)
Evento pubblico | MeasurePreviewHeight | (Ereditato da TreeList)
Evento pubblico | NodeCellStyle | (Ereditato da TreeList)
Evento pubblico | NodeChanged | (Ereditato da TreeList)
Evento pubblico | NodesReloaded | (Ereditato da TreeList)
Evento pubblico | PaintEx | (Ereditato da TreeList)
Evento pubblico | ParseFindPanelText | (Ereditato da TreeList)
Evento pubblico | PopupMenuShowing | (Ereditato da TreeList)
Evento pubblico | PrintExportProgress | (Ereditato da TreeList)
Evento pubblico | PropertyDeserializing | (Ereditato da TreeList)
Evento pubblico | PropertySerializing | (Ereditato da TreeList)
Evento pubblico | QueryCustomFunctions | (Ereditato da TreeList)
Evento pubblico | QueryEmptyTreeTemplate | (Ereditato da TreeList)
Evento pubblico | QueryNodeTemplate | (Ereditato da TreeList)
Evento pubblico | RowCellClick | (Ereditato da TreeList)
Evento pubblico | RowClick | (Ereditato da TreeList)
Evento pubblico | RowSelectImageClick | (Ereditato da TreeList)
Evento pubblico | RowStateImageClick | (Ereditato da TreeList)
Evento pubblico | ScrollAnnotationsStyle | (Ereditato da TreeList)
Evento pubblico | SelectImageClick | (Ereditato da TreeList)
Evento pubblico | SelectionChanged | (Ereditato da TreeList)
Evento pubblico | SelectionChanging | (Ereditato da TreeList)
Evento pubblico | ShowCustomizationForm | (Ereditato da TreeList)
Evento pubblico | ShowFilterPopupCheckedListBox | (Ereditato da TreeList)
Evento pubblico | ShowFilterPopupDate | (Ereditato da TreeList)
Evento pubblico | ShowFilterPopupExcel | (Ereditato da TreeList)
Evento pubblico | ShowFilterPopupListBox | (Ereditato da TreeList)
Evento pubblico | ShowingEditor | (Ereditato da TreeList)
Evento pubblico | ShownEditor | (Ereditato da TreeList)
Evento pubblico | ShowTreeListMenu | Obsoleto. (Ereditato da TreeList)
Evento pubblico | StartSorting | (Ereditato da TreeList)
Evento pubblico | StateChanged | (Ereditato da TreeList)
Evento pubblico | StateImageClick | (Ereditato da TreeList)
Evento pubblico | SubstituteFilter | (Ereditato da TreeList)
Evento pubblico | TopVisibleNodeIndexChanged | (Ereditato da TreeList)
Evento pubblico | TreeListMenuItemClick | (Ereditato da TreeList)
Evento pubblico | UnboundExpressionEditorCreated | (Ereditato da TreeList)
Evento pubblico | ValidateNode | (Ereditato da TreeList)
Evento pubblico | ValidatingEditor | (Ereditato da TreeList)
Evento pubblico | VirtualTreeGetCellValue | (Ereditato da TreeList)
Evento pubblico | VirtualTreeGetChildNodes | (Ereditato da TreeList)
Evento pubblico | VirtualTreeSetCellValue | (Ereditato da TreeList)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | allowCloseEditor | (Ereditato da TreeList)
Campo pubblico | FilterByState |
Campo protetto | fInitializing | (Ereditato da EditorContainer)
Campo protetto | fUpdateSize | (Ereditato da TreeList)
Campo pubblico | IsFilterByECO |
Campo protetto | SortedColumns | (Ereditato da TreeList)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore MyTreeListBom
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | MyTreeListBom |
Metodo protetto | MyTreeListBom(Object) |
Torna su
Vedi anche

Documentazione

Classe MyTreeListBom
Namespace DedNet.Controls


Costruttore MyTreeListBom

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public MyTreeListBom()
Public Sub New
public:
MyTreeListBom()
new : unit -> MyTreeListBom
Vedi anche

Documentazione

Classe MyTreeListBom
Overload di MyTreeListBom
Namespace DedNet.Controls


Costruttore MyTreeListBom(Object)

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected MyTreeListBom(
    Object ignore
)
Protected Sub New (
    ignore As Object
)
protected:
MyTreeListBom(
    Object^ ignore
)
new :
        ignore : Object -> MyTreeListBom

Parametri

ignore Object
Vedi anche

Documentazione

Classe MyTreeListBom
Overload di MyTreeListBom
Namespace DedNet.Controls


Proprietà di MyTreeListBom

Il tipo MyTreeListBom espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | ActiveEditor | (Ereditato da TreeList)
Proprietà pubblica | ActiveFilter | (Ereditato da TreeList)
Proprietà pubblica | ActiveFilterCriteria | (Ereditato da TreeList)
Proprietà pubblica | ActiveFilterEnabled | (Ereditato da TreeList)
Proprietà pubblica | ActiveFilterInfo | (Ereditato da TreeList)
Proprietà pubblica | ActiveFilterString | (Ereditato da TreeList)
Proprietà protetta | ActualAutoNodeHeight | (Ereditato da TreeList)
Proprietà protetta | ActualFilterCriteria | (Ereditato da TreeList)
Proprietà protetta | ActualShowBands | (Ereditato da TreeList)
Proprietà pubblica | AllNodesCount | (Ereditato da TreeList)
Proprietà protetta | AllowAnimatedScrolling | (Ereditato da TreeList)
Proprietà protetta | AllowAutoFilterConditionChange | (Ereditato da TreeList)
Proprietà protetta | AllowBandColumnsMultiRow | (Ereditato da TreeList)
Proprietà protetta | AllowExpandAnimation | (Ereditato da TreeList)
Proprietà protetta | AllowFiltering | (Ereditato da TreeList)
Proprietà protetta | AllowFilteringAfterLoadingData | (Ereditato da TreeList)
Proprietà protetta | AllowFilterNodes | (Ereditato da TreeList)
Proprietà protetta | AllowFindPanel | (Ereditato da TreeList)
Proprietà protetta | AllowPrintProgress | (Ereditato da TreeList)
Proprietà protetta | AllowScaleOnLoad | (Ereditato da EditorContainer)
Proprietà pubblica | AllowTouchGestures | (Ereditato da EditorContainer)
Proprietà protetta | AllowTouchScroll | (Ereditato da TreeList)
Proprietà protetta | AnnotationManager | (Ereditato da TreeList)
Proprietà pubblica | Appearance | (Ereditato da TreeList)
Proprietà pubblica | AppearancePrint | (Ereditato da TreeList)
Proprietà pubblica | AutoFillColumn | (Ereditato da TreeList)
Proprietà pubblica | AutoFillColumnName | (Ereditato da TreeList)
Proprietà pubblica | AutoFillFieldName | (Ereditato da TreeList)
Proprietà protetta | AutoFilterNode | (Ereditato da TreeList)
Proprietà pubblica | BackColor | (Ereditato da TreeList)
Proprietà pubblica | BandPanelRowHeight | (Ereditato da TreeList)
Proprietà pubblica | Bands | (Ereditato da TreeList)
Proprietà pubblica | BestFitVisibleOnly | (Ereditato da TreeList)
Proprietà pubblica | BorderStyle | (Ereditato da TreeList)
Proprietà protetta | CanExpandNodesOnIncrementalSearch | (Ereditato da TreeList)
Proprietà protetta | CanLoadNodes | (Ereditato da TreeList)
Proprietà protetta | CanShowBandsInCustomizationForm | (Ereditato da TreeList)
Proprietà pubblica | CanShowEditor | (Ereditato da TreeList)
Proprietà pubblica | CanShowRowFooterSummary | (Ereditato da TreeList)
Proprietà pubblica | Caption | (Ereditato da TreeList)
Proprietà pubblica | CaptionHeight | (Ereditato da TreeList)
Proprietà protetta | CheckBoxesStrategy | (Ereditato da TreeList)
Proprietà pubblica | CheckBoxFieldName | (Ereditato da TreeList)
Proprietà pubblica | ChildListFieldName | (Ereditato da TreeList)
Proprietà protetta | ClientHeight | (Ereditato da TreeList)
Proprietà protetta | ClientWidth | (Ereditato da TreeList)
Proprietà pubblica | ClipboardDataProvider | (Ereditato da TreeList)
Proprietà protetta | ClipboardPasteHelper | (Ereditato da TreeList)
Proprietà protetta | ClipboardPasteManager | (Ereditato da TreeList)
Proprietà protetta | CloneInfoList | (Ereditato da TreeList)
Proprietà pubblica | ColumnPanelRowHeight | (Ereditato da TreeList)
Proprietà pubblica | Columns | (Ereditato da TreeList)
Proprietà pubblica | ColumnsImageList | (Ereditato da TreeList)
Proprietà protetta | ContainerHelper | (Ereditato da TreeList)
Proprietà pubblica | ContextMenuStrip | (Ereditato da EditorContainer)
Proprietà protetta | CurrencyManager | (Ereditato da TreeList)
Proprietà pubblica | Cursor | (Ereditato da TreeList)
Proprietà pubblica | CustomizationForm | (Ereditato da TreeList)
Proprietà pubblica | CustomizationFormBounds | (Ereditato da TreeList)
Proprietà pubblica | CustomizationRowCount | Obsoleto. (Ereditato da TreeList)
Proprietà protetta | Data | (Ereditato da TreeList)
Proprietà pubblica | DataMember | (Ereditato da TreeList)
Proprietà pubblica | DataSource | (Ereditato da TreeList)
Proprietà protetta | DefaultSize | (Ereditato da TreeList)
Proprietà protetta | DirectXProvider | (Ereditato da TreeList)
Proprietà protetta | DirectXScroller | (Ereditato da TreeList)
Proprietà pubblica | DragExpandDelay | Obsoleto. (Ereditato da TreeList)
Proprietà pubblica | DragNodesMode | Obsoleto. (Ereditato da TreeList)
Proprietà protetta | DXAccessible | (Ereditato da TreeList)
Proprietà pubblica | EcoDictionary |
Proprietà protetta | Editable | (Ereditato da TreeList)
Proprietà protetta | EditFormController | (Ereditato da TreeList)
Proprietà pubblica | EditingValue | (Ereditato da TreeList)
Proprietà protetta | EditorHelper | (Ereditato da EditorContainer)
Proprietà protetta | ElementsLookAndFeel | (Ereditato da TreeList)
Proprietà pubblica | EmptyTreeHtmlTemplate | (Ereditato da TreeList)
Proprietà protetta | EnableDirectXPaint | (Ereditato da TreeList)
Proprietà pubblica | EnableDynamicLoading | (Ereditato da TreeList)
Proprietà pubblica | EnableEnhancedScrolling | (Ereditato da TreeList)
Proprietà protetta | EnableEnhancedSorting | (Ereditato da TreeList)
Proprietà protetta | EnableFirstPaintTrigger | (Ereditato da EditorContainer)
Proprietà pubblica | EnableImprovedColumnSizing | (Ereditato da TreeList)
Proprietà protetta | ErrorInfo | (Ereditato da TreeList)
Proprietà protetta | ExcelFilteringProvider | (Ereditato da TreeList)
Proprietà protetta | ExceptionThrown | (Ereditato da TreeList)
Proprietà pubblica | ExternalRepository | (Ereditato da EditorContainer)
Proprietà protetta | ExtraFilter | (Ereditato da TreeList)
Proprietà protetta | ExtraFilterCriteria | (Ereditato da TreeList)
Proprietà protetta | ExtraFilterHightlightText | (Ereditato da TreeList)
Proprietà protetta | FilterColumnsProvider | (Ereditato da TreeList)
Proprietà protetta | FilterHelper | (Ereditato da TreeList)
Proprietà protetta | FilteringService | (Ereditato da TreeList)
Proprietà pubblica | FilterPanelText | (Ereditato da TreeList)
Proprietà protetta | FilterPopup | (Ereditato da TreeList)
Proprietà protetta | FindFilterCriteria | (Ereditato da TreeList)
Proprietà pubblica | FindFilterText | (Ereditato da TreeList)
Proprietà protetta | FindPanel | (Ereditato da TreeList)
Proprietà pubblica | FindPanelVisible | (Ereditato da TreeList)
Proprietà protetta | FireOnLoadOnPaint | (Ereditato da TreeList)
Proprietà pubblica | FixedLineWidth | (Ereditato da TreeList)
Proprietà protetta | FocusedCellIndex | (Ereditato da TreeList)
Proprietà pubblica | FocusedColumn | (Ereditato da TreeList)
Proprietà pubblica | FocusedNode | (Ereditato da TreeList)
Proprietà protetta | FocusedRow | (Ereditato da TreeList)
Proprietà protetta | FocusedRowIndex | (Ereditato da TreeList)
Proprietà pubblica | FocusedValue | (Ereditato da TreeList)
Proprietà pubblica | FooterPanelHeight | (Ereditato da TreeList)
Proprietà protetta | ForceLoadingPanel | (Ereditato da TreeList)
Proprietà pubblica | ForeColor | (Ereditato da EditorContainer)
Proprietà pubblica | FormatConditions | (Ereditato da TreeList)
Proprietà pubblica | FormatRules | (Ereditato da TreeList)
Proprietà pubblica | GroupButtonSize | Obsoleto. (Ereditato da TreeList)
Proprietà protetta | Handler | (Ereditato da TreeList)
Proprietà protetta | HasAccessible | (Ereditato da TreeList)
Proprietà protetta | HasAllColumnsFixedRight | (Ereditato da TreeList)
Proprietà protetta | HasBands | (Ereditato da TreeList)
Proprietà pubblica | HasColumnErrors | (Ereditato da TreeList)
Proprietà protetta | HasCustomNodeCellEdit | (Ereditato da TreeList)
Proprietà pubblica | HasFocus | (Ereditato da TreeList)
Proprietà protetta | HasHierarchicalColumn | (Ereditato da TreeList)
Proprietà protetta | HasTreeViewColumn | (Ereditato da TreeList)
Proprietà protetta | HeaderLayoutCalculator | (Ereditato da TreeList)
Proprietà protetta | HeaderWidthCalculator | (Ereditato da TreeList)
Proprietà pubblica | HierarchyColumn | (Ereditato da TreeList)
Proprietà pubblica | HierarchyColumnIndent | (Ereditato da TreeList)
Proprietà pubblica | HierarchyColumnName | (Ereditato da TreeList)
Proprietà pubblica | HierarchyFieldName | (Ereditato da TreeList)
Proprietà pubblica | HorzScrollStep | (Ereditato da TreeList)
Proprietà pubblica | HorzScrollVisibility | (Ereditato da TreeList)
Proprietà protetta | HtmlContext | (Ereditato da TreeList)
Proprietà pubblica | HtmlImages | (Ereditato da TreeList)
Proprietà protetta | HtmlObjectCache | (Ereditato da TreeList)
Proprietà pubblica | HtmlTemplates | (Ereditato da TreeList)
Proprietà protetta | IBasePrintableCreatesIntersectedBricks | (Ereditato da TreeList)
Proprietà pubblica | ImageIndexFieldName | (Ereditato da TreeList)
Proprietà protetta | IncrementalText | (Ereditato da TreeList)
Proprietà pubblica | IndicatorWidth | (Ereditato da TreeList)
Proprietà protetta | IsAllowBusyIndicator | (Ereditato da TreeList)
Proprietà protetta | IsAllowBusyPanel | (Ereditato da TreeList)
Proprietà protetta | IsAlt | (Ereditato da TreeList)
Proprietà protetta | IsAttachedToSearchControl | (Ereditato da TreeList)
Proprietà protetta | IsAutoWidth | (Ereditato da TreeList)
Proprietà protetta | IsCellSelect | (Ereditato da TreeList)
Proprietà protetta | IsClosingEditor | (Ereditato da TreeList)
Proprietà protetta | IsColumnHeaderAutoHeight | (Ereditato da TreeList)
Proprietà protetta | IsControl | (Ereditato da TreeList)
Proprietà protetta | IsDataReady | (Ereditato da TreeList)
Proprietà protetta | IsDeserializing | (Ereditato da TreeList)
Proprietà pubblica | IsDesignMode | (Ereditato da EditorContainer)
Proprietà protetta | IsDynamicLoadingAllowed | (Ereditato da TreeList)
Proprietà protetta | IsEditFormMode | (Ereditato da TreeList)
Proprietà pubblica | IsFilterByStateActive |
Proprietà protetta | IsFilterPopupActive | (Ereditato da TreeList)
Proprietà protetta | IsFindFilterActive | (Ereditato da TreeList)
Proprietà pubblica | IsFindPanelVisible | (Ereditato da TreeList)
Proprietà protetta | IsFocusedNodeChangedLocked | (Ereditato da TreeList)
Proprietà protetta | IsFocusedNodeDataModified | (Ereditato da TreeList)
Proprietà protetta | IsGroupDeleteOperation | (Ereditato da TreeList)
Proprietà protetta | IsHScrollBarVisible | (Ereditato da TreeList)
Proprietà protetta | IsInitialized | (Ereditato da EditorContainer)
Proprietà protetta | IsIniting | (Ereditato da TreeList)
Proprietà pubblica | IsLoading | (Ereditato da EditorContainer)
Proprietà protetta | IsLockDirectXRendering | (Ereditato da TreeList)
Proprietà protetta | IsLockExpandCollapse | (Ereditato da TreeList)
Proprietà protetta | IsLockUpdate | (Ereditato da TreeList)
Proprietà pubblica | IsLookUpMode | (Ereditato da TreeList)
Proprietà protetta | IsMultiSelect | (Ereditato da TreeList)
Proprietà protetta | IsNotificationInfoVisible | (Ereditato da TreeList)
Proprietà protetta | IsPainting | (Ereditato da TreeList)
Proprietà protetta | IsPixelScrolling | (Ereditato da TreeList)
Proprietà protetta | IsPopupEditFormVisible | (Ereditato da TreeList)
Proprietà pubblica | IsPrinting | (Ereditato da TreeList)
Proprietà pubblica | IsPrintingAvailable | (Ereditato da TreeList)
Proprietà protetta | IsRightToLeft | (Ereditato da TreeList)
Proprietà protetta | IsRowCountReady | (Ereditato da TreeList)
Proprietà protetta | IsScrollAnimationInProgress | (Ereditato da TreeList)
Proprietà protetta | IsSearchMode | (Ereditato da TreeList)
Proprietà protetta | IsSerializing | (Ereditato da TreeList)
Proprietà protetta | IsShift | (Ereditato da TreeList)
Proprietà protetta | IsSorted | (Ereditato da TreeList)
Proprietà protetta | IsUnboundLoad | (Ereditato da TreeList)
Proprietà pubblica | IsUnboundMode | (Ereditato da TreeList)
Proprietà protetta | IsUpdateSize | (Ereditato da TreeList)
Proprietà protetta | IsVirtualMode | (Ereditato da TreeList)
Proprietà protetta | IsVScrollBarVisible | (Ereditato da TreeList)
Proprietà pubblica | KeyFieldName | (Ereditato da TreeList)
Proprietà pubblica | LayoutVersion | Obsoleto. (Ereditato da TreeList)
Proprietà pubblica | LeftCoord | (Ereditato da TreeList)
Proprietà pubblica | LoadingPanelVisible | (Ereditato da TreeList)
Proprietà pubblica | LookAndFeel | (Ereditato da EditorContainer)
Proprietà protetta | LookAndFeelIgnoreChildren | (Ereditato da EditorContainer)
Proprietà protetta | LookUpDisplayColumn | (Ereditato da TreeList)
Proprietà protetta | LookUpOwner | (Ereditato da TreeList)
Proprietà pubblica | MenuManager | (Ereditato da EditorContainer)
Proprietà protetta | MinRowHeight | (Ereditato da TreeList)
Proprietà pubblica | MinWidth | (Ereditato da TreeList)
Proprietà protetta | MRUFilterPopup | (Ereditato da TreeList)
Proprietà pubblica | MRUFilters | (Ereditato da TreeList)
Proprietà protetta | NewItemNode | (Ereditato da TreeList)
Proprietà pubblica | NewItemRowText | (Ereditato da TreeList)
Proprietà pubblica | NodeHtmlTemplate | (Ereditato da TreeList)
Proprietà pubblica | Nodes | (Ereditato da TreeList)
Proprietà pubblica | NodesIterator | (Ereditato da TreeList)
Proprietà pubblica | NonColumnFilterCriteria | (Ereditato da TreeList)
Proprietà pubblica | NonColumnFilterString | (Ereditato da TreeList)
Proprietà protetta | NotificationInfo | (Ereditato da TreeList)
Proprietà protetta | OfficeScroller | (Ereditato da TreeList)
Proprietà pubblica | OptionsBehavior | (Ereditato da TreeList)
Proprietà pubblica | OptionsClipboard | (Ereditato da TreeList)
Proprietà pubblica | OptionsCustomization | (Ereditato da TreeList)
Proprietà pubblica | OptionsDragAndDrop | (Ereditato da TreeList)
Proprietà pubblica | OptionsEditForm | (Ereditato da TreeList)
Proprietà pubblica | OptionsFilter | (Ereditato da TreeList)
Proprietà pubblica | OptionsFind | (Ereditato da TreeList)
Proprietà pubblica | OptionsHtmlTemplate | (Ereditato da TreeList)
Proprietà pubblica | OptionsLayout | (Ereditato da TreeList)
Proprietà pubblica | OptionsMenu | (Ereditato da TreeList)
Proprietà pubblica | OptionsNavigation | (Ereditato da TreeList)
Proprietà pubblica | OptionsPrint | (Ereditato da TreeList)
Proprietà pubblica | OptionsScrollAnnotations | (Ereditato da TreeList)
Proprietà pubblica | OptionsSelection | (Ereditato da TreeList)
Proprietà pubblica | OptionsView | (Ereditato da TreeList)
Proprietà pubblica | Painter | (Ereditato da TreeList)
Proprietà pubblica | ParentFieldName | (Ereditato da TreeList)
Proprietà protetta | Position | (Ereditato da TreeList)
Proprietà protetta | PressedBand | (Ereditato da TreeList)
Proprietà protetta | PressedColumn | (Ereditato da TreeList)
Proprietà protetta | PressedNode | (Ereditato da TreeList)
Proprietà pubblica | PreviewFieldName | (Ereditato da TreeList)
Proprietà pubblica | PreviewIndent | (Ereditato da TreeList)
Proprietà pubblica | PreviewLineCount | (Ereditato da TreeList)
Proprietà protetta | Printer | (Ereditato da TreeList)
Proprietà protetta | PrinterCore | (Ereditato da TreeList)
Proprietà protetta | ProgressWindow | (Ereditato da TreeList)
Proprietà pubblica | RepositoryItems | (Ereditato da EditorContainer)
Proprietà pubblica | RootValue | (Ereditato da TreeList)
Proprietà protetta | RowCount | (Ereditato da TreeList)
Proprietà pubblica | RowHeight | (Ereditato da TreeList)
Proprietà protetta | ScaleDPI | (Ereditato da EditorContainer)
Proprietà pubblica | ScaleFactor | (Ereditato da EditorContainer)
Proprietà protetta | ScaleHelper | (Ereditato da EditorContainer)
Proprietà protetta | ScrollInfo | (Ereditato da TreeList)
Proprietà pubblica | SelectedHtmlText | (Ereditato da TreeList)
Proprietà pubblica | SelectImageList | (Ereditato da TreeList)
Proprietà pubblica | Selection | (Ereditato da TreeList)
Proprietà protetta | SelectionRange | (Ereditato da TreeList)
Proprietà pubblica | ShowButtonMode | (Ereditato da TreeList)
Proprietà protetta | ShowEditorAfterAnimatedScroll | (Ereditato da TreeList)
Proprietà pubblica | ShowOnlyAlternativeCode |
Proprietà protetta | ShowPreview | (Ereditato da TreeList)
Proprietà protetta | SizedBand | (Ereditato da TreeList)
Proprietà protetta | SizedColumn | (Ereditato da TreeList)
Proprietà protetta | SmartVisibility | (Ereditato da TreeList)
Proprietà pubblica | SortedColumnCount | (Ereditato da TreeList)
Proprietà pubblica | State | (Ereditato da TreeList)
Proprietà pubblica | StateImageList | (Ereditato da TreeList)
Proprietà pubblica | SyncCheckStateWithSourceOnChecking | (Ereditato da TreeList)
Proprietà pubblica | Text | (Ereditato da EditorContainer)
Proprietà pubblica | ToolTipController | (Ereditato da EditorContainer)
Proprietà protetta | TopVisibleNode | (Ereditato da TreeList)
Proprietà pubblica | TopVisibleNodeIndex | (Ereditato da TreeList)
Proprietà pubblica | TopVisibleNodePixel | (Ereditato da TreeList)
Proprietà pubblica | TreeLevelWidth | (Ereditato da TreeList)
Proprietà pubblica | TreeLineStyle | (Ereditato da TreeList)
Proprietà pubblica | TreeListDisposing | (Ereditato da TreeList)
Proprietà pubblica | TreeViewColumn | (Ereditato da TreeList)
Proprietà pubblica | TreeViewColumnName | (Ereditato da TreeList)
Proprietà pubblica | TreeViewFieldName | (Ereditato da TreeList)
Proprietà pubblica | UpdateTopVisibleNodeIndexOnCollapse | (Ereditato da TreeList)
Proprietà protetta | UseBandsAdvancedHorizontalNavigation | (Ereditato da TreeList)
Proprietà protetta | UseBandsAdvancedVerticalNavigation | (Ereditato da TreeList)
Proprietà pubblica | UseDirectXPaint | (Ereditato da TreeList)
Proprietà pubblica | UseDisabledStatePainter | (Ereditato da TreeList)
Proprietà protetta | UseStandardFilter | (Ereditato da TreeList)
Proprietà pubblica | VertScrollVisibility | (Ereditato da TreeList)
Proprietà pubblica | ViewInfo | (Ereditato da TreeList)
Proprietà pubblica | ViewState |
Proprietà pubblica | ViewStyle | (Ereditato da TreeList)
Proprietà protetta | VirtualDataHelper | (Ereditato da TreeList)
Proprietà pubblica | VisibleColumnCount | Obsoleto. (Ereditato da TreeList)
Proprietà pubblica | VisibleColumns | (Ereditato da TreeList)
Proprietà pubblica | VisibleNodesCount | (Ereditato da TreeList)
Proprietà protetta | WorkAsLookup | (Ereditato da TreeList)
Torna su
Vedi anche

Documentazione

Classe MyTreeListBom
Namespace DedNet.Controls


Proprietà MyTreeListBom.EcoDictionary

Proprietà MyTreeListBomEcoDictionary

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<TreeListNode, Tuple<int, DedEcoEcoTypeEnum, int>> EcoDictionary { get; set; }
Public Property EcoDictionary As Dictionary(Of TreeListNode, Tuple(Of Integer, DedEcoEcoTypeEnum, Integer))
    Get
    Set
public:
property Dictionary<TreeListNode^, Tuple<int, DedEcoEcoTypeEnum, int>^>^ EcoDictionary {
    Dictionary<TreeListNode^, Tuple<int, DedEcoEcoTypeEnum, int>^>^ get ();
    void set (Dictionary<TreeListNode^, Tuple<int, DedEcoEcoTypeEnum, int>^>^ value);
}
member EcoDictionary : Dictionary<TreeListNode, Tuple<int, DedEcoEcoTypeEnum, int>> with get, set

Valore della proprietà

Dictionary TreeListNode, Tuple Int32, DedEcoEcoTypeEnum, Int32
Vedi anche

Documentazione

Classe MyTreeListBom
Namespace DedNet.Controls


Proprietà MyTreeListBom.IsFilterByStateActive

Proprietà MyTreeListBomIsFilterByStateActive

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsFilterByStateActive { get; }
Public ReadOnly Property IsFilterByStateActive As Boolean
    Get
public:
property bool IsFilterByStateActive {
    bool get ();
}
member IsFilterByStateActive : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe MyTreeListBom
Namespace DedNet.Controls


Proprietà MyTreeListBom.ShowOnlyAlternativeCode

Proprietà MyTreeListBomShowOnlyAlternativeCode

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ShowOnlyAlternativeCode { get; set; }
Public Property ShowOnlyAlternativeCode As Boolean
    Get
    Set
public:
property bool ShowOnlyAlternativeCode {
    bool get ();
    void set (bool value);
}
member ShowOnlyAlternativeCode : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe MyTreeListBom
Namespace DedNet.Controls


Proprietà MyTreeListBom.ViewState

Proprietà MyTreeListBomViewState

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public UtilityTreeListViewState ViewState { get; set; }
Public Property ViewState As UtilityTreeListViewState
    Get
    Set
public:
property UtilityTreeListViewState^ ViewState {
    UtilityTreeListViewState^ get ();
    void set (UtilityTreeListViewState^ value);
}
member ViewState : UtilityTreeListViewState with get, set

Valore della proprietà

UtilityTreeListViewState
Vedi anche

Documentazione

Classe MyTreeListBom
Namespace DedNet.Controls


Metodi di MyTreeListBom

Il tipo MyTreeListBom espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AccessibleNotifyClients(AccessibleEvents, BaseAccessible) | (Ereditato da TreeList)
Metodo pubblico | AccessibleNotifyClients(AccessibleEvents, Int32, Int32) | (Ereditato da TreeList)
Metodo pubblico | AddFilter(CriteriaOperator) | (Ereditato da TreeList)
Metodo pubblico | AddFilter(String) | (Ereditato da TreeList)
Metodo protetto | AddToDefaultTooltipController | (Ereditato da EditorContainer)
Metodo protetto | AllowAutoFilterCondition | (Ereditato da TreeList)
Metodo protetto | AnimateKeyboardNavigation | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, TreeListNode) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, TreeListNode, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, TreeListNode, CheckState) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, CheckState) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, TreeListNode, CheckState, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, CheckState, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, TreeListNode, CheckState, NodeCheckBoxStyle, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, Int32, Int32, Int32) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, Int32, Int32, Int32, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, Int32, Int32, Int32, CheckState) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, Int32, Int32, Int32, CheckState, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, Int32, Int32, Int32, CheckState, NodeCheckBoxStyle, Object) | (Ereditato da TreeList)
Metodo protetto | ApplyFilter | (Ereditato da TreeList)
Metodo pubblico | ApplyFindFilter | (Ereditato da TreeList)
Metodo protetto | BeforeShowEditForm | (Ereditato da TreeList)
Metodo pubblico | BeginDelete | (Ereditato da TreeList)
Metodo protetto | BeginDragDrop | (Ereditato da TreeList)
Metodo protetto | BeginExpandCollapse | (Ereditato da TreeList)
Metodo pubblico | BeginInit | (Ereditato da EditorContainer)
Metodo protetto | BeginLockListChanged | (Ereditato da TreeList)
Metodo pubblico | BeginSelection | (Ereditato da TreeList)
Metodo pubblico | BeginSort | (Ereditato da TreeList)
Metodo pubblico | BeginUnboundLoad | (Ereditato da TreeList)
Metodo pubblico | BeginUpdate | (Ereditato da TreeList)
Metodo pubblico | BestFitColumns | (Ereditato da TreeList)
Metodo pubblico | BestFitColumns(Boolean) | (Ereditato da TreeList)
Metodo pubblico | BindCommand(Object, String, FuncObject) | (Ereditato da TreeList)
Metodo pubblico | BindCommand(ExpressionAction, Object, String, FuncObject) | (Ereditato da TreeList)
Metodo pubblico | BindCommand``1(ExpressionActionUMP, Object, String, FuncUMP) | (Ereditato da TreeList)
Metodo protetto | CalcActiveEditorBounds | (Ereditato da TreeList)
Metodo protetto | CalcColumnBestWidth | (Ereditato da TreeList)
Metodo pubblico | CalcHitInfo | (Ereditato da TreeList)
Metodo protetto | CalcHScrollRange | (Ereditato da TreeList)
Metodo protetto | CalcNodeAutoHeight | (Ereditato da TreeList)
Metodo protetto | CalcRowCount | (Ereditato da TreeList)
Metodo protetto | CalcScrollClientRect | (Ereditato da TreeList)
Metodo protetto | CalculateScrollBars | (Ereditato da TreeList)
Metodo protetto | CalculateVisibleRowsAreaHeight | (Ereditato da TreeList)
Metodo pubblico | CancelCurrentEdit | (Ereditato da TreeList)
Metodo protetto | CancelDirectXRendering | (Ereditato da TreeList)
Metodo protetto | CancelLockListChanged | (Ereditato da TreeList)
Metodo protetto | CancelSelection | (Ereditato da TreeList)
Metodo pubblico | CancelSort | (Ereditato da TreeList)
Metodo pubblico | CancelUpdate | (Ereditato da TreeList)
Metodo protetto | CanClearAllSorting | (Ereditato da TreeList)
Metodo protetto | CanCloneChildren | (Ereditato da TreeList)
Metodo protetto | CanFilterByColumnEdit | (Ereditato da TreeList)
Metodo pubblico | CanFilterColumn | (Ereditato da TreeList)
Metodo protetto | CanFindColumn | (Ereditato da TreeList)
Metodo protetto | CanFocusNode | (Ereditato da TreeList)
Metodo protetto | CanHandleTouchGestures | (Ereditato da EditorContainer)
Metodo protetto | CanIncrementalSearch | (Ereditato da TreeList)
Metodo pubblico | CanIndentNodes | (Ereditato da TreeList)
Metodo protetto | CanMove | (Ereditato da TreeList)
Metodo protetto | CanMoveBand | (Ereditato da TreeList)
Metodo protetto | CanMoveColumn | (Ereditato da TreeList)
Metodo pubblico | CanOutdentNodes | (Ereditato da TreeList)
Metodo protetto | CanResizeBand | (Ereditato da TreeList)
Metodo protetto | CanResizeColumn | (Ereditato da TreeList)
Metodo protetto | CanShowHScrollBar | (Ereditato da TreeList)
Metodo protetto | CanShowHScrollBarCore | (Ereditato da TreeList)
Metodo protetto | CanShowVScrollBar | (Ereditato da TreeList)
Metodo protetto | CanSortByColumnEdit | (Ereditato da TreeList)
Metodo pubblico | CanSortColumn | (Ereditato da TreeList)
Metodo protetto | CanStartTouchScrolling | (Ereditato da TreeList)
Metodo protetto | ChangeLeftCoord | (Ereditato da TreeList)
Metodo pubblico | CheckAll | (Ereditato da TreeList)
Metodo protetto | CheckAllowGestures | (Ereditato da TreeList)
Metodo protetto | CheckAllowNotifications | (Ereditato da TreeList)
Metodo protetto | CheckData | (Ereditato da TreeList)
Metodo protetto | CheckIncreaseVisibleRows | (Ereditato da TreeList)
Metodo protetto | CheckModifierKeys | (Ereditato da TreeList)
Metodo protetto | CheckNeedScale | (Ereditato da EditorContainer)
Metodo protetto | CheckRightToLeft | (Ereditato da EditorContainer)
Metodo protetto | CheckSearchMode | (Ereditato da TreeList)
Metodo protetto | CheckTopVisibleNodeAfterItemAdded | (Ereditato da TreeList)
Metodo protetto | CheckTopVisibleNodePixelValue | (Ereditato da TreeList)
Metodo pubblico | ClearColumnErrors | (Ereditato da TreeList)
Metodo pubblico | ClearColumnFilter | (Ereditato da TreeList)
Metodo protetto | ClearColumnFilterCore(String) | (Ereditato da TreeList)
Metodo protetto | ClearColumnFilterCore(TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | ClearColumnsFilter | (Ereditato da TreeList)
Metodo pubblico | ClearData | Metodo richiamato per azzerare i dati e i semafori utilizzati dal filtraggio
Metodo pubblico | ClearDocument | (Ereditato da TreeList)
Metodo pubblico | ClearFindFilter | (Ereditato da TreeList)
Metodo pubblico | ClearFocusedColumn | (Ereditato da TreeList)
Metodo pubblico | ClearNodes | (Ereditato da TreeList)
Metodo pubblico | ClearSelection | (Ereditato da TreeList)
Metodo pubblico | ClearSorting | (Ereditato da TreeList)
Metodo protetto | ClearVisibleIndicesCache | (Ereditato da TreeList)
Metodo pubblico | CloseEditForm | (Ereditato da TreeList)
Metodo pubblico | CloseEditor | (Ereditato da TreeList)
Metodo protetto | CloseEditor(Boolean) | (Ereditato da TreeList)
Metodo pubblico | CollapseAll | (Ereditato da TreeList)
Metodo protetto | CollapseAllCore | (Ereditato da TreeList)
Metodo pubblico | CollapseToLevel | (Ereditato da TreeList)
Metodo pubblico | ColumnsCustomization | (Ereditato da TreeList)
Metodo pubblico | ColumnsCustomization(Point) | (Ereditato da TreeList)
Metodo protetto | ControlRowSourceSelectedChanged | (Ereditato da TreeList)
Metodo protetto | ControlRowSourceVisibleChanged | (Ereditato da TreeList)
Metodo pubblico | ConvertFormatConditionToFormatRules | (Ereditato da TreeList)
Metodo pubblico | CopyNode(TreeListNode, TreeListNode, Boolean) | (Ereditato da TreeList)
Metodo pubblico | CopyNode(TreeListNode, TreeListNode, Boolean, Boolean) | (Ereditato da TreeList)
Metodo pubblico | CopyNode(TreeListNode, TreeListNode, Boolean, Int32) | (Ereditato da TreeList)
Metodo pubblico | CopyNode(TreeListNode, TreeListNode, Boolean, Boolean, Int32) | (Ereditato da TreeList)
Metodo protetto | CopyNodeCore | (Ereditato da TreeList)
Metodo pubblico | CopyNodes(IEnumerableTreeListNode, TreeListNode, Boolean, Int32) | (Ereditato da TreeList)
Metodo pubblico | CopyNodes(IEnumerableTreeListNode, TreeListNode, Boolean, Boolean, Int32) | (Ereditato da TreeList)
Metodo pubblico | CopyToClipboard | (Ereditato da TreeList)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da TreeList)
Metodo protetto | CreateAccessibleDataRow | (Ereditato da TreeList)
Metodo protetto | CreateAccessibleInstance | (Ereditato da TreeList)
Metodo protetto | CreateAllOptions | (Ereditato da TreeList)
Metodo protetto | CreateAnnotationManager | (Ereditato da TreeList)
Metodo protetto | CreateAppearances | (Ereditato da TreeList)
Metodo protetto | CreateAutoFilterCriterion | (Ereditato da TreeList)
Metodo protetto | CreateBands | (Ereditato da TreeList)
Metodo protetto | CreateCheckBoxesStrategy | (Ereditato da TreeList)
Metodo protetto | CreateCheckedListFilterPopup | (Ereditato da TreeList)
Metodo protetto | CreateColumn | (Ereditato da TreeList)
Metodo protetto | CreateColumnEditViewInfo | (Ereditato da TreeList)
Metodo protetto | CreateColumnFilterCriteriaByValue(TreeListColumn, Object) | (Ereditato da TreeList)
Metodo protetto | CreateColumnFilterCriteriaByValue(TreeListColumn, Object, Boolean) | (Ereditato da TreeList)
Metodo protetto | CreateColumnFilterPopup | (Ereditato da TreeList)
Metodo protetto | CreateColumns | (Ereditato da TreeList)
Metodo pubblico | CreateCustomization | Obsoleto. (Ereditato da TreeList)
Metodo protetto | CreateCustomizationForm | (Ereditato da TreeList)
Metodo protetto | CreateData | (Ereditato da TreeList)
Metodo protetto | CreateDataViewData | (Ereditato da TreeList)
Metodo protetto | CreateDateFilterPopup | (Ereditato da TreeList)
Metodo protetto | CreateDragNodesProvider | (Ereditato da TreeList)
Metodo protetto | CreateEditFormController | (Ereditato da TreeList)
Metodo protetto | CreateElementsLookAndFeel | (Ereditato da TreeList)
Metodo protetto | CreateExcelFilterPopup | (Ereditato da TreeList)
Metodo protetto | CreateFilterColumnCollection | (Ereditato da TreeList)
Metodo protetto | CreateFilterColumnRuleCollection | (Ereditato da TreeList)
Metodo protetto | CreateFilterColumnsProvider | (Ereditato da TreeList)
Metodo protetto | CreateFilterCriteriaBindingTarget | (Ereditato da TreeList)
Metodo protetto | CreateFilterEditorForm | (Ereditato da TreeList)
Metodo protetto | CreateFilterHelper | (Ereditato da TreeList)
Metodo protetto | CreateFindPanel | (Ereditato da TreeList)
Metodo protetto | CreateFindPanelCore | (Ereditato da TreeList)
Metodo pubblico | CreateGraphicsCache | (Ereditato da TreeList)
Metodo protetto | CreateHandler | (Ereditato da TreeList)
Metodo protetto | CreateHeaderLayoutCalculator | (Ereditato da TreeList)
Metodo protetto | CreateHeaderWidthCalculator | (Ereditato da TreeList)
Metodo protetto | CreateHelper | (Ereditato da TreeList)
Metodo protetto | CreateHierarchicalListData | (Ereditato da TreeList)
Metodo protetto | CreateHtmlContext | (Ereditato da TreeList)
Metodo protetto | CreateHyperlinkClickEventArgs | (Ereditato da TreeList)
Metodo protetto | CreateInternalRepository | (Ereditato da EditorContainer)
Metodo protetto | CreateListColumnFilterPopup | (Ereditato da TreeList)
Metodo protetto | CreateListData | (Ereditato da TreeList)
Metodo protetto | CreateLoadingAnimator | (Ereditato da TreeList)
Metodo protetto | CreateLoadingPanel | (Ereditato da TreeList)
Metodo protetto | CreateLookAndFeel | (Ereditato da EditorContainer)
Metodo protetto | CreateNewItemNode | (Ereditato da TreeList)
Metodo protetto | CreateNode(Int32, TreeListNodes) | (Ereditato da TreeList)
Metodo protetto | CreateNode(Int32, TreeListNodes, Object) | (Ereditato da TreeList)
Metodo protetto | CreateNodes | (Ereditato da TreeList)
Metodo protetto | CreateNodesComparer | (Ereditato da TreeList)
Metodo protetto | CreateNodesIterator | (Ereditato da TreeList)
Metodo protetto | CreateNotificationInfo | (Ereditato da TreeList)
Metodo protetto | CreateOfficeScroller | (Ereditato da TreeList)
Metodo protetto | CreateOptionsBehavior | (Ereditato da TreeList)
Metodo protetto | CreateOptionsClipboard | (Ereditato da TreeList)
Metodo protetto | CreateOptionsCustomization | (Ereditato da TreeList)
Metodo protetto | CreateOptionsDragAndDrop | (Ereditato da TreeList)
Metodo protetto | CreateOptionsEditForm | (Ereditato da TreeList)
Metodo protetto | CreateOptionsFilter | (Ereditato da TreeList)
Metodo protetto | CreateOptionsFind | (Ereditato da TreeList)
Metodo protetto | CreateOptionsHtmlTemplate | (Ereditato da TreeList)
Metodo protetto | CreateOptionsLayout | (Ereditato da TreeList)
Metodo protetto | CreateOptionsMenu | (Ereditato da TreeList)
Metodo protetto | CreateOptionsNavigation | (Ereditato da TreeList)
Metodo protetto | CreateOptionsPrint | (Ereditato da TreeList)
Metodo protetto | CreateOptionsScrollAnnotations | (Ereditato da TreeList)
Metodo protetto | CreateOptionsSelection | (Ereditato da TreeList)
Metodo protetto | CreateOptionsView | (Ereditato da TreeList)
Metodo protetto | CreatePainter | (Ereditato da TreeList)
Metodo protetto | CreatePrinter | (Ereditato da TreeList)
Metodo protetto | CreateProvider | (Ereditato da TreeList)
Metodo protetto | CreateScrollInfo | (Ereditato da TreeList)
Metodo protetto | CreateSelection | (Ereditato da TreeList)
Metodo protetto | CreateUnboundData | (Ereditato da TreeList)
Metodo protetto | CreateViewInfo | (Ereditato da TreeList)
Metodo protetto | CreateVirtualData | (Ereditato da TreeList)
Metodo protetto | CreateVirtualDataHelper | (Ereditato da TreeList)
Metodo protetto | CurrencyManager_ItemChanged | (Ereditato da TreeList)
Metodo protetto | CurrencyManager_PositionChanged | (Ereditato da TreeList)
Metodo protetto | DeferredLoadChildren | (Ereditato da TreeList)
Metodo protetto | DelayedInvalidate | (Ereditato da TreeList)
Metodo pubblico | DeleteNode | (Ereditato da TreeList)
Metodo pubblico | DeleteNodes | (Ereditato da TreeList)
Metodo pubblico | DeleteSelectedNodes | (Ereditato da TreeList)
Metodo pubblico | DestroyCustomization | (Ereditato da TreeList)
Metodo protetto | DestroyDirectXProvider | (Ereditato da EditorContainer)
Metodo protetto | DestroyFindPanel | (Ereditato da TreeList)
Metodo protetto | Dispose | (Ereditato da TreeList)
Metodo protetto | DoDataSourceChanged | (Ereditato da TreeList)
Metodo protetto | DoDpiChange | (Ereditato da EditorContainer)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da TreeList)
Metodo protetto | DoDragDrop | (Ereditato da TreeList)
Metodo pubblico | DoDragDropNode | (Ereditato da TreeList)
Metodo pubblico | DoDragDropNodes | (Ereditato da TreeList)
Metodo protetto | DoFilterNode | (Ereditato da TreeList)
Metodo protetto | DoForEachBand | (Ereditato da TreeList)
Metodo pubblico | DoIncrementalSearch | (Ereditato da TreeList)
Metodo protetto | DoShowTreeListMenu(TreeListMenu, TreeListHitTest) | (Ereditato da TreeList)
Metodo protetto | DoShowTreeListMenu(TreeListMenu, Control, Point) | (Ereditato da TreeList)
Metodo protetto | DoTopVisibleNodeChanged | (Ereditato da TreeList)
Metodo pubblico | EndCurrentEdit | (Ereditato da TreeList)
Metodo pubblico | EndCurrentEdit(Boolean) | (Ereditato da TreeList)
Metodo pubblico | EndDelete | (Ereditato da TreeList)
Metodo protetto | EndDragDrop | (Ereditato da TreeList)
Metodo protetto | EndEdit | (Ereditato da TreeList)
Metodo protetto | EndExpandCollapse | (Ereditato da TreeList)
Metodo pubblico | EndInit | (Ereditato da EditorContainer)
Metodo pubblico | EndSelection | (Ereditato da TreeList)
Metodo pubblico | EndSort | (Ereditato da TreeList)
Metodo pubblico | EndUnboundLoad | (Ereditato da TreeList)
Metodo pubblico | EndUpdate | (Ereditato da TreeList)
Metodo protetto | EnsureControlRowSource | (Ereditato da TreeList)
Metodo protetto | EnsureEditFormController | (Ereditato da TreeList)
Metodo protetto | EnsureFilteringClientDataBinding | (Ereditato da TreeList)
Metodo protetto | ExecutePrinterAction | (Ereditato da TreeList)
Metodo pubblico | ExpandAll | (Ereditato da TreeList)
Metodo protetto | ExpandAllCore | (Ereditato da TreeList)
Metodo protetto | ExpandToLast | (Ereditato da TreeList)
Metodo pubblico | ExpandToLevel | (Ereditato da TreeList)
Metodo protetto | ExpandToRoot | (Ereditato da TreeList)
Metodo protetto | Export(ExportTarget, Stream) | (Ereditato da TreeList)
Metodo protetto | Export(ExportTarget, String) | (Ereditato da TreeList)
Metodo protetto | Export(ExportTarget, Stream, ExportOptionsBase) | (Ereditato da TreeList)
Metodo protetto | Export(ExportTarget, String, ExportOptionsBase) | (Ereditato da TreeList)
Metodo pubblico | ExportToCsv(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToCsv(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToCsv(Stream, CsvExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToCsv(String, CsvExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToDocx(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToDocx(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToDocx(Stream, DocxExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToDocx(String, DocxExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToHtml(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToHtml(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToHtml(Stream, HtmlExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToHtml(String, HtmlExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToMht(Stream, MhtExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToMht(String, MhtExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToMht(String, String) | Obsoleto. (Ereditato da TreeList)
Metodo pubblico | ExportToMht(Stream, String, String, Boolean) | Obsoleto. (Ereditato da TreeList)
Metodo pubblico | ExportToMht(String, String, String, Boolean) | Obsoleto. (Ereditato da TreeList)
Metodo pubblico | ExportToPdf(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToPdf(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToPdf(Stream, PdfExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToPdf(String, PdfExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToRtf(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToRtf(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToText(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToText(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToText(Stream, TextExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToText(String, TextExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToXls(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToXls(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToXls(Stream, XlsExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToXls(String, XlsExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToXlsx(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToXlsx(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToXlsx(Stream, XlsxExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToXlsx(String, XlsxExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToXml(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToXml(String) | (Ereditato da TreeList)
Metodo protetto | ExportToXmlCore | (Ereditato da TreeList)
Metodo protetto | ExtractTemplateRootNode | (Ereditato da TreeList)
Metodo pubblico | FilterNodes | (Sovrascrive TreeList.FilterNodes)
Metodo pubblico | FilterNodes(TreeListNodes) | (Ereditato da TreeList)
Metodo protetto | FilterNodesCore | (Ereditato da TreeList)
Metodo pubblico | FindNode | (Ereditato da TreeList)
Metodo pubblico | FindNodeByFieldValue | (Ereditato da TreeList)
Metodo pubblico | FindNodeByID | (Ereditato da TreeList)
Metodo pubblico | FindNodeByKeyID | (Ereditato da TreeList)
Metodo protetto | FindNodeByParentID | (Ereditato da TreeList)
Metodo pubblico | FindNodes | (Ereditato da TreeList)
Metodo protetto | FindPanelNext | (Ereditato da TreeList)
Metodo protetto | FindPanelPrev | (Ereditato da TreeList)
Metodo pubblico | FireChanged | (Ereditato da TreeList)
Metodo protetto | FitColumns | (Ereditato da TreeList)
Metodo pubblico | FocusNewItemNode | (Ereditato da TreeList)
Metodo protetto | ForceCalcRowCount | (Ereditato da TreeList)
Metodo pubblico | ForceInitialize | (Ereditato da TreeList)
Metodo protetto | ForceSetTopVisibleNodeIndex | (Ereditato da TreeList)
Metodo pubblico | FullCollapse | Obsoleto. (Ereditato da TreeList)
Metodo pubblico | FullExpand | Obsoleto. (Ereditato da TreeList)
Metodo pubblico | FullExpandNode | Obsoleto. (Ereditato da TreeList)
Metodo protetto | GetAccessibilityObjectById | (Ereditato da TreeList)
Metodo protetto | GetAccessibleNodeCell | (Ereditato da TreeList)
Metodo protetto | GetActiveEditorHighAppearance | (Ereditato da TreeList)
Metodo protetto | GetActualAnimationType | (Ereditato da TreeList)
Metodo protetto | GetActualTreeListFilterMode | (Ereditato da TreeList)
Metodo pubblico | GetAllCheckedNodes | (Ereditato da TreeList)
Metodo protetto | GetAllowChangeBandParent | (Ereditato da TreeList)
Metodo protetto | GetAllowColumnFilterPopup | (Ereditato da TreeList)
Metodo protetto | GetAllowFilterEditor | (Ereditato da TreeList)
Metodo protetto | GetAllowFindColumn | (Ereditato da TreeList)
Metodo protetto | GetAllowFocus | (Ereditato da TreeList)
Metodo protetto | GetAllowHighlightFindResults | (Ereditato da TreeList)
Metodo protetto | GetAllowMRUFilterList | (Ereditato da TreeList)
Metodo protetto | GetAutoFilterRowColumnEdit | (Ereditato da TreeList)
Metodo pubblico | GetAutoFilterValue | (Ereditato da TreeList)
Metodo protetto | GetAutoNodeHeight | (Ereditato da TreeList)
Metodo protetto | GetBandRows | (Ereditato da TreeList)
Metodo protetto | GetBandRowsCore | (Ereditato da TreeList)
Metodo protetto | GetBandVisibleIndex | (Ereditato da TreeList)
Metodo protetto | GetCanShowEditor | (Ereditato da TreeList)
Metodo pubblico | GetColumnByColumnHandle | (Ereditato da TreeList)
Metodo pubblico | GetColumnByVisibleIndex | (Ereditato da TreeList)
Metodo protetto | GetColumnDefaultRepositoryItem | (Ereditato da TreeList)
Metodo protetto | GetColumnDefaultRepositoryItemForEditing | (Ereditato da TreeList)
Metodo protetto | GetColumnEdit | (Ereditato da TreeList)
Metodo protetto | GetColumnEditForEditing | (Ereditato da TreeList)
Metodo pubblico | GetColumnError(TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | GetColumnError(TreeListColumn, TreeListNode) | (Ereditato da TreeList)
Metodo pubblico | GetColumnErrorType(TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | GetColumnErrorType(TreeListColumn, TreeListNode) | (Ereditato da TreeList)
Metodo protetto | GetColumnFieldNameSort | (Ereditato da TreeList)
Metodo protetto | GetColumnFilterCriteria | (Ereditato da TreeList)
Metodo protetto | GetColumnFilterMode | (Ereditato da TreeList)
Metodo pubblico | GetColumnHeaderBestWidth | (Ereditato da TreeList)
Metodo protetto | GetColumnName | (Ereditato da TreeList)
Metodo protetto | GetCurrencyManager | (Ereditato da TreeList)
Metodo protetto | GetDataColumnInfo | (Ereditato da TreeList)
Metodo pubblico | GetDataRecordByNode | (Ereditato da TreeList)
Metodo pubblico | GetDataRow | (Ereditato da TreeList)
Metodo protetto | GetDirectXDeviceBackColor | (Ereditato da EditorContainer)
Metodo protetto | GetDirectXProvider | (Ereditato da EditorContainer)
Metodo protetto | GetEditableObject | (Ereditato da TreeList)
Metodo pubblico | GetEditorShowMode | (Ereditato da TreeList)
Metodo protetto | GetEditorViewInfo | (Ereditato da TreeList)
Metodo protetto | GetFilterColumn | (Ereditato da TreeList)
Metodo protetto | GetFilterColumnByTreeListColumn | (Ereditato da TreeList)
Metodo protetto | GetFilterCriteriaDisplayStyle | (Ereditato da TreeList)
Metodo protetto | GetFilterDisplayText | (Ereditato da TreeList)
Metodo protetto | GetFilterDisplayTextByColumn | (Ereditato da TreeList)
Metodo protetto | GetFilterPopupTexts | (Ereditato da TreeList)
Metodo protetto | GetFilterPopupValues(TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | GetFilterPopupValues(TreeListColumn, Boolean) | (Ereditato da TreeList)
Metodo protetto | GetFilterPopupValues(TreeListColumn, CriteriaOperator, Boolean) | (Ereditato da TreeList)
Metodo protetto | GetFilterPopupValues(TreeListColumn, Boolean, Boolean) | (Ereditato da TreeList)
Metodo protetto | GetFilterRowValue(Object) | (Ereditato da TreeList)
Metodo protetto | GetFilterRowValue(TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | GetFindMatchedRanges | (Ereditato da TreeList)
Metodo protetto | GetFindMatchedText | (Ereditato da TreeList)
Metodo protetto | GetFindToColumnsCollection | (Ereditato da TreeList)
Metodo pubblico | GetFocusedDataRow | (Ereditato da TreeList)
Metodo pubblico | GetFocusedDisplayText | (Ereditato da TreeList)
Metodo pubblico | GetFocusedRow | (Ereditato da TreeList)
Metodo pubblico | GetFocusedRowCellDisplayText(String) | (Ereditato da TreeList)
Metodo pubblico | GetFocusedRowCellDisplayText(TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetFocusedRowCellValue(String) | (Ereditato da TreeList)
Metodo pubblico | GetFocusedRowCellValue(TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetGroupSummaryValue | (Ereditato da TreeList)
Metodo protetto | GetHeaderFilterButtonShowMode | (Ereditato da TreeList)
Metodo pubblico | GetHitInfo | Obsoleto. (Ereditato da TreeList)
Metodo protetto | GetImageIndexFromDataSource | (Ereditato da TreeList)
Metodo protetto | GetMaxIndent | (Ereditato da TreeList)
Metodo protetto | GetNativePreviewText | (Ereditato da TreeList)
Metodo pubblico | GetNodeAt(Point) | (Ereditato da TreeList)
Metodo pubblico | GetNodeAt(Int32, Int32) | (Ereditato da TreeList)
Metodo pubblico | GetNodeByVisibleIndex | (Ereditato da TreeList)
Metodo protetto | GetNodeCellRepositoryItem | (Ereditato da TreeList)
Metodo protetto | GetNodeComparer(IComparerTreeListNode) | (Ereditato da TreeList)
Metodo protetto | GetNodeComparer(TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetNodeIndex | (Ereditato da TreeList)
Metodo pubblico | GetNodeList | (Ereditato da TreeList)
Metodo protetto | GetNodeValue(TreeListNode, TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | GetNodeValue(TreeListNode, Object) | (Ereditato da TreeList)
Metodo protetto | GetNodeValue(TreeListNode, String) | (Ereditato da TreeList)
Metodo protetto | GetNonFormattedCaption | (Ereditato da TreeList)
Metodo protetto | GetParentColumnFieldNameSort | (Ereditato da TreeList)
Metodo pubblico | GetRow | (Ereditato da TreeList)
Metodo pubblico | GetRowCellDisplayText(TreeListNode, TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetRowCellDisplayText(TreeListNode, String) | (Ereditato da TreeList)
Metodo pubblico | GetRowCellValue(TreeListNode, TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetRowCellValue(TreeListNode, String) | (Ereditato da TreeList)
Metodo protetto | GetRowsAsFootersCount | (Ereditato da TreeList)
Metodo pubblico | GetScrollAnnotations | (Ereditato da TreeList)
Metodo pubblico | GetSelectedCells | (Ereditato da TreeList)
Metodo pubblico | GetSelectedCells(TreeListNode) | (Ereditato da TreeList)
Metodo protetto | GetShowBandsMode | (Ereditato da TreeList)
Metodo protetto | GetShowFirstLines | (Ereditato da TreeList)
Metodo protetto | GetShowIndentAsRowStyle | (Ereditato da TreeList)
Metodo pubblico | GetSortColumn(Int32) | (Ereditato da TreeList)
Metodo protetto | GetSortColumn(TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetSummaryValue(TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetSummaryValue(TreeListColumn, Boolean) | (Ereditato da TreeList)
Metodo protetto | GetSummaryValueCore | (Ereditato da TreeList)
Metodo protetto | GetSummaryValueEx | (Ereditato da TreeList)
Metodo pubblico | GetToolTipController | (Ereditato da EditorContainer)
Metodo protetto | GetUseDirectXPaint | (Ereditato da TreeList)
Metodo pubblico | GetVisibleIndexByNode | (Ereditato da TreeList)
Metodo protetto | GetVisibleIndexByNodeCore | (Ereditato da TreeList)
Metodo protetto | GetVisibleParentNodesCount | (Ereditato da TreeList)
Metodo pubblico | HideCustomization | (Ereditato da TreeList)
Metodo pubblico | HideEditor | (Ereditato da TreeList)
Metodo protetto | HideEditorCore | (Ereditato da TreeList)
Metodo pubblico | HideFindPanel | (Ereditato da TreeList)
Metodo pubblico | HideLoadingPanel | (Ereditato da TreeList)
Metodo protetto | HookOnLoaded | (Ereditato da EditorContainer)
Metodo pubblico | ImportFromXml(Stream) | (Ereditato da TreeList)
Metodo pubblico | ImportFromXml(String) | (Ereditato da TreeList)
Metodo protetto | ImportFromXmlCore | (Ereditato da TreeList)
Metodo pubblico | IndentNodes | (Ereditato da TreeList)
Metodo protetto | InitFindPanel | (Ereditato da TreeList)
Metodo protetto | InitializeDirectXProvider | (Ereditato da EditorContainer)
Metodo protetto | InitScrollInfo | (Ereditato da TreeList)
Metodo protetto | InternalDeleteNode | (Ereditato da TreeList)
Metodo protetto | InternalDeleteNodeCore | (Ereditato da TreeList)
Metodo protetto | InternalDeleteNodes(DictionaryTreeListNodes, ListTreeListNode) | (Ereditato da TreeList)
Metodo protetto | InternalDeleteNodes(TreeListNodes) | (Ereditato da TreeList)
Metodo protetto | InternalFullCollapseNode | (Ereditato da TreeList)
Metodo protetto | InternalFullExpandNode | (Ereditato da TreeList)
Metodo protetto | InternalGetCustomNodeCellEdit | (Ereditato da TreeList)
Metodo protetto | InternalGetCustomNodeCellStyle | (Ereditato da TreeList)
Metodo pubblico | InternalGetService | (Ereditato da TreeList)
Metodo protetto | InternalNodeAdded | (Ereditato da TreeList)
Metodo protetto | InternalNodeChanged | (Ereditato da TreeList)
Metodo protetto | InternalSetTopVisibleNodePixel | (Ereditato da TreeList)
Metodo pubblico | InvalidateBand | (Ereditato da TreeList)
Metodo pubblico | InvalidateBandPanel | (Ereditato da TreeList)
Metodo pubblico | InvalidateCell | (Ereditato da TreeList)
Metodo pubblico | InvalidateColumnHeader | (Ereditato da TreeList)
Metodo pubblico | InvalidateColumnPanel | (Ereditato da TreeList)
Metodo pubblico | InvalidateFilterPanel | (Ereditato da TreeList)
Metodo pubblico | InvalidateNode | (Ereditato da TreeList)
Metodo pubblico | InvalidateNodes | (Ereditato da TreeList)
Metodo pubblico | InvalidateRow | (Ereditato da TreeList)
Metodo pubblico | InvalidateRowPreview | (Ereditato da TreeList)
Metodo protetto | InvalidateRows | (Ereditato da TreeList)
Metodo pubblico | InvalidateScrollAnnotations | (Ereditato da TreeList)
Metodo pubblico | InvalidateSummaryFooterPanel | (Ereditato da TreeList)
Metodo pubblico | InvokeMenuItemClick | (Ereditato da TreeList)
Metodo protetto | IsAllowDefaultFastBestFit | (Ereditato da TreeList)
Metodo protetto | IsAllowEditForm | (Ereditato da TreeList)
Metodo pubblico | IsAutoFilterNode | (Ereditato da TreeList)
Metodo pubblico | IsCellSelected | (Ereditato da TreeList)
Metodo protetto | IsColumnAllowAutoFilter | (Ereditato da TreeList)
Metodo protetto | IsColumnAllowFilter | (Ereditato da TreeList)
Metodo pubblico | IsColumnAllowFilterEditor | (Ereditato da TreeList)
Metodo protetto | IsColumnFieldNameSortExist | (Ereditato da TreeList)
Metodo protetto | IsColumnFiltered | (Ereditato da TreeList)
Metodo protetto | IsFilterByDisplayText | (Ereditato da TreeList)
Metodo protetto | IsFilterRow | (Ereditato da TreeList)
Metodo protetto | IsImplyNullLikeEmptyStringWhenFiltering | (Ereditato da TreeList)
Metodo protetto | IsInputChar | (Ereditato da TreeList)
Metodo protetto | IsInputKey | (Ereditato da TreeList)
Metodo pubblico | IsNewItemRow | (Ereditato da TreeList)
Metodo protetto | IsParentColumnFieldNameSortExist | (Ereditato da TreeList)
Metodo pubblico | IsRootNode | (Ereditato da TreeList)
Metodo protetto | IsRoundDateTime | (Ereditato da TreeList)
Metodo protetto | IsShowAllValuesInFilterPopup | (Ereditato da TreeList)
Metodo protetto | IsTopNewItemRow | (Ereditato da TreeList)
Metodo protetto | IsUserAutoFilterCondition | (Ereditato da TreeList)
Metodo pubblico | LayoutChanged | (Ereditato da TreeList)
Metodo protetto | LoadDataColumns | (Ereditato da TreeList)
Metodo protetto | LoadDataSource | (Ereditato da TreeList)
Metodo protetto | LockDirectXRendering | (Ereditato da TreeList)
Metodo protetto | LockFilteringUIClientFilterCriteriaBinding | (Ereditato da TreeList)
Metodo pubblico | LockReloadNodes | (Ereditato da TreeList)
Metodo pubblico | MakeColumnVisible | (Ereditato da TreeList)
Metodo protetto | MakeFocusedRowVisible | (Ereditato da TreeList)
Metodo pubblico | MakeNodeVisible | (Ereditato da TreeList)
Metodo protetto | MergeColumnFiltersCore | (Ereditato da TreeList)
Metodo pubblico | MoveFirst | (Ereditato da TreeList)
Metodo protetto | MoveFocusedCell | (Ereditato da TreeList)
Metodo pubblico | MoveLast | (Ereditato da TreeList)
Metodo pubblico | MoveLastVisible | (Ereditato da TreeList)
Metodo pubblico | MoveNext | (Ereditato da TreeList)
Metodo pubblico | MoveNextVisible | (Ereditato da TreeList)
Metodo pubblico | MoveNode(TreeListNode, TreeListNode) | (Ereditato da TreeList)
Metodo pubblico | MoveNode(TreeListNode, TreeListNode, Boolean) | (Ereditato da TreeList)
Metodo pubblico | MoveNode(TreeListNode, TreeListNode, Boolean, Int32) | (Ereditato da TreeList)
Metodo pubblico | MoveNodes | (Ereditato da TreeList)
Metodo protetto | MoveNodesCore | (Ereditato da TreeList)
Metodo pubblico | MovePrev | (Ereditato da TreeList)
Metodo pubblico | MovePrevVisible | (Ereditato da TreeList)
Metodo pubblico | MoveToNextScrollAnnotation | (Ereditato da TreeList)
Metodo pubblico | MoveToParent | (Ereditato da TreeList)
Metodo pubblico | MoveToPrevScrollAnnotation | (Ereditato da TreeList)
Metodo protetto | NormalizeVisibleBandIndices | (Ereditato da TreeList)
Metodo protetto | NormalizeVisibleColumnIndices | (Ereditato da TreeList)
Metodo protetto | OnActiveEditor_GotFocus | (Ereditato da TreeList)
Metodo protetto | OnActiveEditor_LostFocus | (Ereditato da TreeList)
Metodo protetto | OnActiveEditor_Modified | (Ereditato da TreeList)
Metodo protetto | OnActiveEditor_ValueChanged | (Ereditato da TreeList)
Metodo protetto | OnActiveEditor_ValueChanging | (Ereditato da TreeList)
Metodo protetto | OnActiveFilterChanged | (Ereditato da TreeList)
Metodo protetto | OnActiveFilterCriteriaChanged | (Ereditato da TreeList)
Metodo protetto | OnActiveFilterEnabledChanged | (Ereditato da TreeList)
Metodo protetto | OnAfterAddingNode | (Ereditato da TreeList)
Metodo protetto | OnAfterChangeCollapsed | (Ereditato da TreeList)
Metodo protetto | OnAfterChangeExpanded | (Ereditato da TreeList)
Metodo protetto | OnAfterDeletingNodes | (Ereditato da TreeList)
Metodo protetto | OnAllowBandColumnMultiRowChanged | (Ereditato da TreeList)
Metodo protetto | OnAllowSerializationProperty | (Ereditato da TreeList)
Metodo protetto | OnAppearancePrintChanged | (Ereditato da TreeList)
Metodo protetto | OnBandChanged | (Ereditato da TreeList)
Metodo protetto | OnBandCollectionChanged | (Ereditato da TreeList)
Metodo protetto | OnBandColumnCollectionChanged | (Ereditato da TreeList)
Metodo protetto | OnBandFixedChanged | (Ereditato da TreeList)
Metodo protetto | OnBandWidthChanged | (Ereditato da TreeList)
Metodo protetto | OnBeginTouchScroll | (Ereditato da TreeList)
Metodo protetto | OnBindingContextChanged | (Ereditato da TreeList)
Metodo protetto | OnCheckBoxFieldNameChanged | (Ereditato da TreeList)
Metodo protetto | OnClearNodes | (Ereditato da TreeList)
Metodo protetto | OnClearNodesComplete | (Ereditato da TreeList)
Metodo protetto | OnClick | (Ereditato da TreeList)
Metodo protetto | OnColumnAdded | (Ereditato da TreeList)
Metodo protetto | OnColumnChanged | (Ereditato da TreeList)
Metodo protetto | OnColumnFilterModeChanged | (Ereditato da TreeList)
Metodo protetto | OnColumnFilterRestored | (Ereditato da TreeList)
Metodo protetto | OnColumnInfosPopulated | (Ereditato da TreeList)
Metodo protetto | OnColumnRemoved | (Ereditato da TreeList)
Metodo protetto | OnColumnRowIndexChanged | (Ereditato da TreeList)
Metodo protetto | OnColumnsChanged | (Ereditato da TreeList)
Metodo protetto | OnColumnUnboundChanged | (Ereditato da TreeList)
Metodo protetto | OnColumnUnboundExpressionChanged | (Ereditato da TreeList)
Metodo protetto | OnContainerEnter | (Ereditato da EditorContainer)
Metodo protetto | OnContainerLeave | (Ereditato da EditorContainer)
Metodo protetto | OnContextMenuKey | (Ereditato da TreeList)
Metodo protetto | OnCreateControl | (Ereditato da EditorContainer)
Metodo protetto | OnDataListChanged | (Ereditato da TreeList)
Metodo protetto | OnDesignerHost_LoadComplete | (Ereditato da EditorContainer)
Metodo protetto | OnDesignerHost_TransactionClosed | (Ereditato da EditorContainer)
Metodo protetto | OnDirectXPaintDisabled | (Ereditato da TreeList)
Metodo protetto | OnDoubleClick | (Ereditato da TreeList)
Metodo protetto | OnDragDrop | (Ereditato da TreeList)
Metodo protetto | OnDragEnter | (Ereditato da TreeList)
Metodo protetto | OnDragLeave | (Ereditato da TreeList)
Metodo protetto | OnDragOver | (Ereditato da TreeList)
Metodo protetto | OnEnabledChanged | (Ereditato da TreeList)
Metodo protetto | OnEndInit | (Ereditato da EditorContainer)
Metodo protetto | OnEndSerializing | (Ereditato da TreeList)
Metodo protetto | OnEndSorting | (Ereditato da TreeList)
Metodo protetto | OnEnter | (Ereditato da EditorContainer)
Metodo protetto | OnErrorInfo_Changed | (Ereditato da TreeList)
Metodo protetto | OnFilterRowValueChanging | (Ereditato da TreeList)
Metodo protetto | OnFirstInit | (Ereditato da EditorContainer)
Metodo protetto | OnFormatConditionChanged | (Ereditato da TreeList)
Metodo protetto | OnFormatRuleExpressionEditorCreated | (Ereditato da TreeList)
Metodo protetto | OnFormatRulesCollectionChanged | (Ereditato da TreeList)
Metodo protetto | OnGotCapture | (Ereditato da EditorContainer)
Metodo protetto | OnGotFocus | (Ereditato da TreeList)
Metodo protetto | OnHandleCreated | (Ereditato da TreeList)
Metodo protetto | OnHandleDestroyed | (Ereditato da TreeList)
Metodo protetto | OnHorizontalTouchScroll | (Ereditato da TreeList)
Metodo protetto | OnHScroll | (Ereditato da TreeList)
Metodo protetto | OnItemAdded | (Ereditato da TreeList)
Metodo protetto | OnItemAdding | (Ereditato da TreeList)
Metodo protetto | OnItemChanged(Int32, PropertyDescriptor) | (Ereditato da TreeList)
Metodo protetto | OnItemChanged(Int32, PropertyDescriptor, TreeListNode) | (Ereditato da TreeList)
Metodo protetto | OnItemDeleted | (Ereditato da TreeList)
Metodo protetto | OnItemMoved | (Ereditato da TreeList)
Metodo protetto | OnKeyDown | (Ereditato da TreeList)
Metodo protetto | OnKeyPress | (Ereditato da TreeList)
Metodo protetto | OnKeyUp | (Ereditato da TreeList)
Metodo protetto | OnLeave | (Ereditato da EditorContainer)
Metodo protetto | OnLoaded | (Ereditato da TreeList)
Metodo protetto | OnLoadedCore | (Ereditato da TreeList)
Metodo protetto | OnLookAndFeelChanged(LookAndFeelChangedEventArgs) | (Ereditato da TreeList)
Metodo protetto | OnLookAndFeelChanged(Object, EventArgs) | (Ereditato da EditorContainer)
Metodo protetto | OnLostCapture | (Ereditato da TreeList)
Metodo protetto | OnLostFocus | (Ereditato da TreeList)
Metodo protetto | OnMenuShowing | (Ereditato da TreeList)
Metodo protetto | OnMouseClick | (Ereditato da EditorContainer)
Metodo protetto | OnMouseDoubleClick | (Ereditato da EditorContainer)
Metodo protetto | OnMouseDown | (Ereditato da TreeList)
Metodo protetto | OnMouseEnter | (Ereditato da TreeList)
Metodo protetto | OnMouseHWheel | (Ereditato da EditorContainer)
Metodo protetto | OnMouseLeave | (Ereditato da TreeList)
Metodo protetto | OnMouseMove | (Ereditato da TreeList)
Metodo protetto | OnMouseUp | (Ereditato da TreeList)
Metodo protetto | OnMouseWheel | (Ereditato da EditorContainer)
Metodo protetto | OnMouseWheelCore | (Ereditato da TreeList)
Metodo protetto | OnNodeCheckedChanged | (Ereditato da TreeList)
Metodo protetto | OnNodeRemoved | (Ereditato da TreeList)
Metodo protetto | OnNodesLoaded | (Ereditato da TreeList)
Metodo protetto | OnNodesLoading | (Ereditato da TreeList)
Metodo protetto | OnNodesRemoved | (Ereditato da TreeList)
Metodo protetto | OnOptionsBehaviorChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsCustomizationChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsDragAndDropChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsEditFormChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsFilterChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsFindChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsHtmlChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsNavigationChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsPrintChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsScrollAnnotationsChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsSelectionChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsViewChanged | (Ereditato da TreeList)
Metodo protetto | OnPaint | Implementazione dell'override di onPaint. Grazie al catch delle eccezioni evita l'uscita della X rossa sul form (Sovrascrive TreeList.OnPaint(PaintEventArgs))
Metodo protetto | OnPaintBackground | (Ereditato da TreeList)
Metodo protetto | OnParentChanged | (Ereditato da TreeList)
Metodo protetto | OnPressedBandChanged | (Ereditato da TreeList)
Metodo protetto | OnPrintProgress | (Ereditato da TreeList)
Metodo protetto | OnPropertyChanged | (Ereditato da TreeList)
Metodo protetto | OnPropertyDescriptorChanged | (Ereditato da TreeList)
Metodo protetto | OnQueryContinueDrag | (Ereditato da TreeList)
Metodo protetto | OnRepositoryItemRefreshRequired | (Ereditato da TreeList)
Metodo protetto | OnReset | (Ereditato da TreeList)
Metodo protetto | OnResetSerializationProperties | (Ereditato da TreeList)
Metodo protetto | OnResize | (Ereditato da TreeList)
Metodo protetto | OnRightToLeftChanged | (Ereditato da TreeList)
Metodo protetto | OnRightToLeftChanged(EventArgs) | (Ereditato da EditorContainer)
Metodo protetto | OnScaleControl | (Ereditato da TreeList)
Metodo protetto | OnScaleTreeListCore | (Ereditato da TreeList)
Metodo protetto | OnSelectionChanged | (Ereditato da TreeList)
Metodo protetto | OnSetValue | (Ereditato da TreeList)
Metodo protetto | OnSortModeChanged | (Ereditato da TreeList)
Metodo protetto | OnSourceItemChanged | (Ereditato da TreeList)
Metodo protetto | OnStartSerializing | (Ereditato da TreeList)
Metodo protetto | OnStartSorting | (Ereditato da TreeList)
Metodo protetto | OnSystemColorsChanged | (Ereditato da TreeList)
Metodo protetto | OnToolTipControllerDisposed | (Ereditato da EditorContainer)
Metodo protetto | OnTouchScroll | (Ereditato da TreeList)
Metodo protetto | OnTouchZoom | (Ereditato da TreeList)
Metodo protetto | OnValidated | (Ereditato da EditorContainer)
Metodo protetto | OnValidating | (Ereditato da TreeList)
Metodo protetto | OnVerticalTouchScroll | (Ereditato da TreeList)
Metodo protetto | OnVisibleChanged | (Ereditato da TreeList)
Metodo protetto | OnVScroll | (Ereditato da TreeList)
Metodo protetto | OnVScrollCore | (Ereditato da TreeList)
Metodo pubblico | OutdentNodes | (Ereditato da TreeList)
Metodo protetto | ParseAutoFilter | (Ereditato da TreeList)
Metodo protetto | ParseAutoFilterValues | (Ereditato da TreeList)
Metodo pubblico | PasteFromClipboard | (Ereditato da TreeList)
Metodo pubblico | PopulateColumns | (Ereditato da TreeList)
Metodo pubblico | PostEditor | (Ereditato da TreeList)
Metodo protetto | PostEditor(Boolean) | (Ereditato da TreeList)
Metodo pubblico | Print | (Ereditato da TreeList)
Metodo protetto | PrintCore | (Ereditato da TreeList)
Metodo pubblico | PrintDialog | (Ereditato da TreeList)
Metodo protetto | PrintDialogCore | (Ereditato da TreeList)
Metodo protetto | ProcessControlTab | (Ereditato da TreeList)
Metodo protetto | ProcessControlTab(Boolean) | (Ereditato da TreeList)
Metodo protetto | ProcessDialogKey | (Ereditato da TreeList)
Metodo protetto | ProcessDirectXPaint | (Ereditato da TreeList)
Metodo protetto | RaiseAfterCheckNode | (Ereditato da TreeList)
Metodo protetto | RaiseAfterCollapse | (Ereditato da TreeList)
Metodo protetto | RaiseAfterDragNode | (Ereditato da TreeList)
Metodo protetto | RaiseAfterDropNode | (Ereditato da TreeList)
Metodo protetto | RaiseAfterExpand | (Ereditato da TreeList)
Metodo protetto | RaiseAfterFocusNode | (Ereditato da TreeList)
Metodo protetto | RaiseBandPositionChanged | (Ereditato da TreeList)
Metodo protetto | RaiseBandWidthChanged | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeCheckNode | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeCollapse | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeDragNode | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeDropNode | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeExpand | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeFocusNode | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeLoadLayout | (Ereditato da TreeList)
Metodo protetto | RaiseCalcNodeDragImageIndex | (Ereditato da TreeList)
Metodo protetto | RaiseCalcNodeHeight(TreeListNode, Int32) | (Ereditato da TreeList)
Metodo protetto | RaiseCalcNodeHeight(TreeListNode, RowInfo, Int32) | (Ereditato da TreeList)
Metodo protetto | RaiseCellValueChanged | (Ereditato da TreeList)
Metodo protetto | RaiseCellValueChanging | (Ereditato da TreeList)
Metodo protetto | RaiseCheckedColumnFilterPopupEvent | (Ereditato da TreeList)
Metodo protetto | RaiseClipboardNodeCopying | (Ereditato da TreeList)
Metodo protetto | RaiseClipboardNodePasting | (Ereditato da TreeList)
Metodo protetto | RaiseColumnButtonClick | (Ereditato da TreeList)
Metodo protetto | RaiseColumnChanged | (Ereditato da TreeList)
Metodo protetto | RaiseColumnFilterChanged | (Ereditato da TreeList)
Metodo protetto | RaiseColumnFilterPopupEvent | (Ereditato da TreeList)
Metodo protetto | RaiseColumnPositionChanged | (Ereditato da TreeList)
Metodo protetto | RaiseColumnUnboundExpressionChanged | (Ereditato da TreeList)
Metodo protetto | RaiseColumnWidthChanged | (Ereditato da TreeList)
Metodo protetto | RaiseCompareNodeValues | (Ereditato da TreeList)
Metodo protetto | RaiseCreateCustomNode | (Ereditato da TreeList)
Metodo protetto | RaiseCustomColumnDisplayText(CustomColumnDisplayTextEventArgs) | (Ereditato da TreeList)
Metodo protetto | RaiseCustomColumnDisplayText(TreeListNode, CellInfo) | (Ereditato da TreeList)
Metodo protetto | RaiseCustomColumnDisplayText(TreeListNode, TreeListColumn, BaseEditViewInfo) | (Ereditato da TreeList)
Metodo protetto | RaiseCustomColumnDisplayText(TreeListNode, TreeListColumn, Object, String) | (Ereditato da TreeList)
Metodo protetto | RaiseCustomColumnSort | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawBandHeader | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawColumnHeader | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawEmptyArea | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawFilterPanel | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawFooter | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawFooterCell | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodeButton | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodeCell | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodeCheckBox | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodeImages | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodeIndent | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodeIndicator | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodePreview | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawRow | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawRowFooter | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawRowFooterCell | (Ereditato da TreeList)
Metodo protetto | RaiseCustomFilterDisplayText | (Ereditato da TreeList)
Metodo protetto | RaiseCustomizationFormSearch | (Ereditato da TreeList)
Metodo protetto | RaiseCustomizeNewNodeFromOuterData | (Ereditato da TreeList)
Metodo protetto | RaiseCustomRowFilter | (Ereditato da TreeList)
Metodo protetto | RaiseCustomRowFilterEvent | (Ereditato da TreeList)
Metodo protetto | RaiseCustomUnboundColumnData | (Ereditato da TreeList)
Metodo protetto | RaiseDataSourceChanged | (Ereditato da TreeList)
Metodo protetto | RaiseDefaultPaintHelperChanged | (Ereditato da TreeList)
Metodo protetto | RaiseDragCancelNode | (Ereditato da TreeList)
Metodo protetto | RaiseDragObjectDrop | (Ereditato da TreeList)
Metodo protetto | RaiseDragObjectOver | (Ereditato da TreeList)
Metodo protetto | RaiseDragObjectStart | (Ereditato da TreeList)
Metodo protetto | RaiseEditFormHidden | (Ereditato da TreeList)
Metodo protetto | RaiseEditFormPrepared | (Ereditato da TreeList)
Metodo protetto | RaiseEditFormShowing | (Ereditato da TreeList)
Metodo protetto | RaiseEditorKeyDown | (Ereditato da TreeList)
Metodo protetto | RaiseEditorKeyPress | (Ereditato da EditorContainer)
Metodo protetto | RaiseEditorKeyUp | (Ereditato da EditorContainer)
Metodo protetto | RaiseEndSorting | (Ereditato da TreeList)
Metodo protetto | RaiseExcelColumnFilterPopupEvent | (Ereditato da TreeList)
Metodo protetto | RaiseFilterEditorCreated | (Ereditato da TreeList)
Metodo protetto | RaiseFilterExpressionEditorCreated | (Ereditato da TreeList)
Metodo protetto | RaiseFilterNodeEvent | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupDate | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelCustomizeTemplate | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelData(FilterPopupExcelDataEventArgs) | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelData(TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelData(TreeListColumn, CriteriaOperator) | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelData(TreeListColumn, TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelParseFilterCriteria | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelPrepareTemplate | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelQueryFilterCriteria | (Ereditato da TreeList)
Metodo protetto | RaiseFocusedColumnChanged | (Ereditato da TreeList)
Metodo protetto | RaiseFocusedNodeChanged | (Ereditato da TreeList)
Metodo protetto | RaiseGetCustomAnnotations | (Ereditato da TreeList)
Metodo protetto | RaiseGetCustomNodeCellEdit | (Ereditato da TreeList)
Metodo protetto | RaiseGetCustomNodeCellStyle | (Ereditato da TreeList)
Metodo protetto | RaiseGetCustomSummaryValue | (Ereditato da TreeList)
Metodo protetto | RaiseGetNodeDisplayValue | (Ereditato da TreeList)
Metodo protetto | RaiseGetPreviewText | (Ereditato da TreeList)
Metodo protetto | RaiseGetPrintCustomSummaryValue | (Ereditato da TreeList)
Metodo protetto | RaiseGetPrintPreviewText | (Ereditato da TreeList)
Metodo protetto | RaiseGetSelectImage | (Ereditato da TreeList)
Metodo protetto | RaiseGetStateImage | (Ereditato da TreeList)
Metodo protetto | RaiseHiddenEditor | (Ereditato da TreeList)
Metodo protetto | RaiseHideCustomizationForm | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementBlur | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementFocus | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseClick | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseDoubleClick | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseDown | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseMove | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseOut | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseOver | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseUp | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlSelectedTextChanged | (Ereditato da TreeList)
Metodo protetto | RaiseInitNewRow | (Ereditato da TreeList)
Metodo protetto | RaiseInvalidNodeException | (Ereditato da TreeList)
Metodo protetto | RaiseInvalidValueException | (Ereditato da TreeList)
Metodo protetto | RaiseLayoutUpdated | (Ereditato da TreeList)
Metodo protetto | RaiseLayoutUpgrade | (Ereditato da TreeList)
Metodo protetto | RaiseLeftCoordChanged | (Ereditato da TreeList)
Metodo protetto | RaiseLoad | (Ereditato da TreeList)
Metodo protetto | RaiseMeasurePreviewHeight | (Ereditato da TreeList)
Metodo protetto | RaiseNodeChanged | (Ereditato da TreeList)
Metodo protetto | RaiseNodesReloaded | (Ereditato da TreeList)
Metodo protetto | RaisePaintEx | (Ereditato da TreeList)
Metodo protetto | RaiseParseFindPanelText | (Ereditato da TreeList)
Metodo protetto | RaisePopupMenuShowing | (Ereditato da TreeList)
Metodo protetto | RaisePrintExportProgress | (Ereditato da TreeList)
Metodo protetto | RaiseQueryCustomFunctions | (Ereditato da TreeList)
Metodo protetto | RaiseRequireHideEditor | (Ereditato da EditorContainer)
Metodo protetto | RaiseRowCellClick | (Ereditato da TreeList)
Metodo protetto | RaiseRowClick | (Ereditato da TreeList)
Metodo protetto | RaiseRowSelectImageClick | (Ereditato da TreeList)
Metodo protetto | RaiseRowStateImageClick | (Ereditato da TreeList)
Metodo protetto | RaiseSelectImageClick | (Ereditato da TreeList)
Metodo protetto | RaiseSelectionChanged | (Ereditato da TreeList)
Metodo protetto | RaiseSelectionChanging | (Ereditato da TreeList)
Metodo protetto | RaiseShowCustomizationForm | (Ereditato da TreeList)
Metodo protetto | RaiseShowingEditor | (Ereditato da TreeList)
Metodo protetto | RaiseShownEditor | (Ereditato da TreeList)
Metodo protetto | RaiseShowTreeListMenu | Obsoleto. (Ereditato da TreeList)
Metodo protetto | RaiseStartSorting | (Ereditato da TreeList)
Metodo protetto | RaiseStateChanged | (Ereditato da TreeList)
Metodo protetto | RaiseStateImageClick | (Ereditato da TreeList)
Metodo protetto | RaiseSubstituteFilter | (Ereditato da TreeList)
Metodo protetto | RaiseTopVisibleNodeIndexChanged | (Ereditato da TreeList)
Metodo protetto | RaiseTreeListMenuItemClick | (Ereditato da TreeList)
Metodo protetto | RaiseUnboundExpressionEditorCreated | (Ereditato da TreeList)
Metodo protetto | RaiseValidateNode | (Ereditato da TreeList)
Metodo protetto | RaiseValidatingEditor | (Ereditato da TreeList)
Metodo protetto | RecalcSortColumns | (Ereditato da TreeList)
Metodo protetto | RecreateRowsInfoCore | (Ereditato da TreeList)
Metodo pubblico | Refresh | (Ereditato da TreeList)
Metodo pubblico | Refresh(Boolean) | (Ereditato da TreeList)
Metodo pubblico | RefreshCell | (Ereditato da TreeList)
Metodo protetto | RefreshCellCore | (Ereditato da TreeList)
Metodo protetto | RefreshColumnsInfo | (Ereditato da TreeList)
Metodo pubblico | RefreshDataSource | (Ereditato da TreeList)
Metodo pubblico | RefreshEditor | (Ereditato da TreeList)
Metodo protetto | RefreshEditorError | (Ereditato da TreeList)
Metodo protetto | RefreshHeadersInfo | (Ereditato da TreeList)
Metodo protetto | RefreshHtmlNodeCore | (Ereditato da TreeList)
Metodo pubblico | RefreshNode | (Ereditato da TreeList)
Metodo protetto | RefreshNodeCore | (Ereditato da TreeList)
Metodo protetto | RefreshRowsInfo | (Ereditato da TreeList)
Metodo protetto | RefreshRowsInfo(Boolean, Boolean) | (Ereditato da TreeList)
Metodo pubblico | RefreshScrollAnnotations(ScrollAnnotationKind) | (Ereditato da TreeList)
Metodo pubblico | RefreshScrollAnnotations(ScrollAnnotationKind, Int32) | (Ereditato da TreeList)
Metodo protetto | RefreshVirtualCellCore | (Ereditato da TreeList)
Metodo protetto | RefreshVirtualNodeCore | (Ereditato da TreeList)
Metodo protetto | RejectCurrentChanges | (Ereditato da TreeList)
Metodo protetto | RemoveFromDefaultTooltipController | (Ereditato da EditorContainer)
Metodo protetto | RemoveHookOnLoaded | (Ereditato da EditorContainer)
Metodo protetto | RemoveNodeHeight | (Ereditato da TreeList)
Metodo protetto | RequestCellEditor | (Ereditato da TreeList)
Metodo protetto | ResetAccessibility | (Ereditato da TreeList)
Metodo pubblico | ResetAutoFilterCondition | (Ereditato da TreeList)
Metodo pubblico | ResetAutoFilterConditions | (Ereditato da TreeList)
Metodo pubblico | ResetAutoFilterConditions(IEnumerableTreeListColumn) | (Ereditato da TreeList)
Metodo protetto | ResetAutoFilterConditionsCore | (Ereditato da TreeList)
Metodo protetto | ResetColumnAutoFilterConditions | (Ereditato da TreeList)
Metodo pubblico | ResetEditorsCache(RepositoryItem) | (Ereditato da EditorContainer)
Metodo pubblico | ResetEditorsCache(Type) | (Ereditato da EditorContainer)
Metodo protetto | ResetExcelFilteringProvider | (Ereditato da TreeList)
Metodo protetto | ResetLookAndFeel | (Ereditato da EditorContainer)
Metodo protetto | ResetRowCount | (Ereditato da TreeList)
Metodo protetto | ResetSortedColumns | (Ereditato da TreeList)
Metodo protetto | ResizeBand | (Ereditato da TreeList)
Metodo protetto | ResizeColumn | (Ereditato da TreeList)
Metodo protetto | ResolveAutoFilterCondition | (Ereditato da TreeList)
Metodo protetto | RestoreLayoutCore | (Ereditato da TreeList)
Metodo pubblico | RestoreLayoutFromRegistry(String) | (Ereditato da TreeList)
Metodo pubblico | RestoreLayoutFromRegistry(String, OptionsLayoutBase) | (Ereditato da TreeList)
Metodo pubblico | RestoreLayoutFromStream(Stream) | (Ereditato da TreeList)
Metodo pubblico | RestoreLayoutFromStream(Stream, OptionsLayoutBase) | (Ereditato da TreeList)
Metodo pubblico | RestoreLayoutFromXml(String) | (Ereditato da TreeList)
Metodo pubblico | RestoreLayoutFromXml(String, OptionsLayoutBase) | (Ereditato da TreeList)
Metodo protetto | RestoreNodesData | (Ereditato da TreeList)
Metodo protetto | SaveLayoutCore | (Ereditato da TreeList)
Metodo pubblico | SaveLayoutToRegistry(String) | (Ereditato da TreeList)
Metodo pubblico | SaveLayoutToRegistry(String, OptionsLayoutBase) | (Ereditato da TreeList)
Metodo pubblico | SaveLayoutToStream(Stream) | (Ereditato da TreeList)
Metodo pubblico | SaveLayoutToStream(Stream, OptionsLayoutBase) | (Ereditato da TreeList)
Metodo pubblico | SaveLayoutToXml(String) | (Ereditato da TreeList)
Metodo pubblico | SaveLayoutToXml(String, OptionsLayoutBase) | (Ereditato da TreeList)
Metodo protetto | SaveNodesData | (Ereditato da TreeList)
Metodo protetto | ScaleControl | (Ereditato da EditorContainer)
Metodo protetto | Scrollbar_MouseEnter | (Ereditato da TreeList)
Metodo protetto | Scrollbar_MouseLeave | (Ereditato da TreeList)
Metodo protetto | ScrollHorizontalEx | (Ereditato da TreeList)
Metodo protetto | ScrollVerticalEx | (Ereditato da TreeList)
Metodo pubblico | SelectAll | (Ereditato da TreeList)
Metodo pubblico | SelectCell | (Ereditato da TreeList)
Metodo protetto | SelectCellCore | (Ereditato da TreeList)
Metodo pubblico | SelectCells(Int32, String, Int32, String) | (Ereditato da TreeList)
Metodo pubblico | SelectCells(TreeListNode, TreeListColumn, TreeListNode, TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | SelectNode | (Ereditato da TreeList)
Metodo protetto | SelectNodeCore | (Ereditato da TreeList)
Metodo pubblico | SelectNodes(Int32, Int32) | (Ereditato da TreeList)
Metodo pubblico | SelectNodes(TreeListNode, TreeListNode) | (Ereditato da TreeList)
Metodo protetto | SelectNodesCore | (Ereditato da TreeList)
Metodo protetto | ServiceColumnChanged | (Ereditato da TreeList)
Metodo pubblico | SetAutoFilterValue | (Ereditato da TreeList)
Metodo protetto | SetCellSelection | (Ereditato da TreeList)
Metodo protetto | SetCellSelectionCore | (Ereditato da TreeList)
Metodo pubblico | SetColumnError(TreeListColumn, String) | (Ereditato da TreeList)
Metodo pubblico | SetColumnError(TreeListColumn, String, ErrorType) | (Ereditato da TreeList)
Metodo protetto | SetColumnFixedStyle | (Ereditato da TreeList)
Metodo pubblico | SetColumnPosition | (Ereditato da TreeList)
Metodo protetto | SetColumnVisibleIndex | (Ereditato da TreeList)
Metodo pubblico | SetDefaultBehaviorOptions | (Ereditato da TreeList)
Metodo pubblico | SetDefaultCustomizationOptions | (Ereditato da TreeList)
Metodo pubblico | SetDefaultNavigationOptions | (Ereditato da TreeList)
Metodo pubblico | SetDefaultOptionsView | (Ereditato da TreeList)
Metodo pubblico | SetDefaultPrintOptions | (Ereditato da TreeList)
Metodo pubblico | SetDefaultRowHeight | (Ereditato da TreeList)
Metodo pubblico | SetDefaultSelectionOptions | (Ereditato da TreeList)
Metodo protetto | SetExtraFilter | (Ereditato da TreeList)
Metodo protetto | SetFilterRowValue(Object, Object) | (Ereditato da TreeList)
Metodo protetto | SetFilterRowValue(TreeListColumn, Object) | (Ereditato da TreeList)
Metodo pubblico | SetFocusedNode | (Ereditato da TreeList)
Metodo protetto | SetFocusedNodeCore | (Ereditato da TreeList)
Metodo pubblico | SetFocusedRowCellValue(String, Object) | (Ereditato da TreeList)
Metodo pubblico | SetFocusedRowCellValue(TreeListColumn, Object) | (Ereditato da TreeList)
Metodo protetto | SetFocusedRowIndexCore | (Ereditato da TreeList)
Metodo pubblico | SetFocusedValue | (Ereditato da TreeList)
Metodo pubblico | SetNodeCheckState(TreeListNode, CheckState) | (Ereditato da TreeList)
Metodo pubblico | SetNodeCheckState(TreeListNode, CheckState, Boolean) | (Ereditato da TreeList)
Metodo pubblico | SetNodeIndex | (Ereditato da TreeList)
Metodo protetto | SetNodeIndexCore | (Ereditato da TreeList)
Metodo protetto | SetNodeValue | (Ereditato da TreeList)
Metodo pubblico | SetRowCellValue(TreeListNode, TreeListColumn, Object) | (Ereditato da TreeList)
Metodo pubblico | SetRowCellValue(TreeListNode, String, Object) | (Ereditato da TreeList)
Metodo pubblico | SetSearchControl | (Ereditato da TreeList)
Metodo pubblico | SetSelectionAnchor | (Ereditato da TreeList)
Metodo protetto | SetUseDirectXPaint | (Ereditato da TreeList)
Metodo protetto | ShouldResortNodesOnItemChanged | (Ereditato da TreeList)
Metodo protetto | ShouldSerializeLookAndFeel | (Ereditato da EditorContainer)
Metodo pubblico | ShowAutoFilterConditionsMenu | (Ereditato da TreeList)
Metodo pubblico | ShowContextMenu | (Ereditato da TreeList)
Metodo pubblico | ShowCustomization | (Ereditato da TreeList)
Metodo pubblico | ShowCustomization(Point) | (Ereditato da TreeList)
Metodo pubblico | ShowEditForm | (Ereditato da TreeList)
Metodo protetto | ShowEditFormCore | (Ereditato da TreeList)
Metodo protetto | ShowEditFormDialogCore | (Ereditato da TreeList)
Metodo pubblico | ShowEditor | (Ereditato da TreeList)
Metodo pubblico | ShowEditor(String) | (Ereditato da TreeList)
Metodo pubblico | ShowFilterEditor | (Ereditato da TreeList)
Metodo protetto | ShowFilterExpressionEditor | (Ereditato da TreeList)
Metodo pubblico | ShowFilterPopup | (Ereditato da TreeList)
Metodo pubblico | ShowFindPanel | (Ereditato da TreeList)
Metodo pubblico | ShowLoadingPanel | (Ereditato da TreeList)
Metodo protetto | ShowMenu | (Ereditato da TreeList)
Metodo protetto | ShowMRUFilterPopup | (Ereditato da TreeList)
Metodo pubblico | ShowPrintPreview | (Ereditato da TreeList)
Metodo protetto | ShowPrintPreviewCore | (Ereditato da TreeList)
Metodo protetto | ShowProgressForm | (Ereditato da TreeList)
Metodo pubblico | ShowRibbonPrintPreview | (Ereditato da TreeList)
Metodo protetto | ShowRibbonPrintPreviewCore | (Ereditato da TreeList)
Metodo pubblico | ShowUnboundExpressionEditor | (Ereditato da TreeList)
Metodo pubblico | Sort(TreeListNode, IComparerTreeListNode, Boolean) | (Ereditato da TreeList)
Metodo protetto | Sort(TreeListNodes, Boolean, Boolean) | (Ereditato da TreeList)
Metodo pubblico | Sort(TreeListNode, TreeListColumn, SortOrder, Boolean) | (Ereditato da TreeList)
Metodo pubblico | StartIncrementalSearch | (Ereditato da TreeList)
Metodo protetto | StartOfficeScrolling | (Ereditato da TreeList)
Metodo pubblico | StopIncrementalSearch | (Ereditato da TreeList)
Metodo protetto | StopOfficeScrolling | (Ereditato da TreeList)
Metodo pubblico | UncheckAll | (Ereditato da TreeList)
Metodo protetto | UnlockDirectXRendering | (Ereditato da TreeList)
Metodo pubblico | UnlockReloadNodes | (Ereditato da TreeList)
Metodo pubblico | UnselectCell | (Ereditato da TreeList)
Metodo protetto | UnselectCellCore | (Ereditato da TreeList)
Metodo pubblico | UnselectCells(Int32, String, Int32, String) | (Ereditato da TreeList)
Metodo pubblico | UnselectCells(TreeListNode, TreeListColumn, TreeListNode, TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | UnselectNode | (Ereditato da TreeList)
Metodo pubblico | UnselectNodes(Int32, Int32) | (Ereditato da TreeList)
Metodo pubblico | UnselectNodes(TreeListNode, TreeListNode) | (Ereditato da TreeList)
Metodo protetto | UpdateActiveFilterInfo | (Ereditato da TreeList)
Metodo protetto | UpdateAutoFilterRowActiveEditor | (Ereditato da TreeList)
Metodo protetto | UpdateBandColumnsIndices | (Ereditato da TreeList)
Metodo protetto | UpdateBandColumnsOrder | (Ereditato da TreeList)
Metodo protetto | UpdateColumnAutoFilter | (Ereditato da TreeList)
Metodo protetto | UpdateColumnsSortIndices | (Ereditato da TreeList)
Metodo protetto | UpdateElementsLookAndFeel | (Ereditato da TreeList)
Metodo protetto | UpdateFilter | (Ereditato da TreeList)
Metodo protetto | UpdateFilterInfo | (Ereditato da TreeList)
Metodo protetto | UpdateFindPanelFilterText | (Ereditato da TreeList)
Metodo protetto | UpdateLayout | (Ereditato da TreeList)
Metodo protetto | UpdateRootBands | (Ereditato da TreeList)
Metodo protetto | UpdateSelectCell | (Ereditato da TreeList)
Metodo protetto | UpdateSelectCell(TreeListNode, TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | UpdateSelectNode | (Ereditato da TreeList)
Metodo protetto | UpdateSelectNode(TreeListNode) | (Ereditato da TreeList)
Metodo protetto | UpdateVScrollBarCore | (Ereditato da TreeList)
Metodo protetto | ValidateAndEndCurrentEdit | (Ereditato da TreeList)
Metodo protetto | WndProc | (Ereditato da TreeList)
Metodo protetto | XtraClearColumns | (Ereditato da TreeList)
Metodo protetto | XtraCreateColumnsItem | (Ereditato da TreeList)
Metodo protetto | XtraFindColumnsItem | (Ereditato da TreeList)
Torna su
Vedi anche

Documentazione

Classe MyTreeListBom
Namespace DedNet.Controls


Metodo MyTreeListBom.ClearData

Metodo MyTreeListBomClearData
Metodo richiamato per azzerare i dati e i semafori utilizzati dal filtraggio

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ClearData()
Public Sub ClearData
public:
void ClearData()
member ClearData : unit -> unit
Vedi anche

Documentazione

Classe MyTreeListBom
Namespace DedNet.Controls


Metodo MyTreeListBom.FilterNodes

Metodo MyTreeListBomFilterNodes
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | FilterNodes |
Metodo pubblico | FilterNodes(TreeListNodes) |
Torna su
Vedi anche

Documentazione

Classe MyTreeListBom
Namespace DedNet.Controls


Metodo MyTreeListBom.FilterNodes

Metodo MyTreeListBomFilterNodes

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void FilterNodes()
Public Overrides Sub FilterNodes
public:
virtual void FilterNodes() override
abstract FilterNodes : unit -> unit
override FilterNodes : unit -> unit
Vedi anche

Documentazione

Classe MyTreeListBom
Overload di FilterNodes
Namespace DedNet.Controls


Metodo MyTreeListBom.OnPaint

Metodo MyTreeListBomOnPaint
Implementazione dell'override di onPaint. Grazie al catch delle eccezioni evita l'uscita della X rossa sul form

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void OnPaint(
    PaintEventArgs e
)
Protected Overrides Sub OnPaint (
    e As PaintEventArgs
)
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override
abstract OnPaint :
        e : PaintEventArgs -> unit
override OnPaint :
        e : PaintEventArgs -> unit

Parametri

e PaintEventArgs
Vedi anche

Documentazione

Classe MyTreeListBom
Namespace DedNet.Controls


Eventi di MyTreeListBom

Il tipo MyTreeListBom espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | AfterCheckNode | (Ereditato da TreeList)
Evento pubblico | AfterCollapse | (Ereditato da TreeList)
Evento pubblico | AfterDragNode | (Ereditato da TreeList)
Evento pubblico | AfterDropNode | (Ereditato da TreeList)
Evento pubblico | AfterExpand | (Ereditato da TreeList)
Evento pubblico | AfterFocusNode | (Ereditato da TreeList)
Evento pubblico | BandPositionChanged | (Ereditato da TreeList)
Evento pubblico | BandWidthChanged | (Ereditato da TreeList)
Evento pubblico | BeforeCheckNode | (Ereditato da TreeList)
Evento pubblico | BeforeCollapse | (Ereditato da TreeList)
Evento pubblico | BeforeDragNode | (Ereditato da TreeList)
Evento pubblico | BeforeDropNode | (Ereditato da TreeList)
Evento pubblico | BeforeExpand | (Ereditato da TreeList)
Evento pubblico | BeforeFocusNode | (Ereditato da TreeList)
Evento pubblico | BeforeLoadLayout | (Ereditato da TreeList)
Evento pubblico | CalcNodeDragImageIndex | (Ereditato da TreeList)
Evento pubblico | CalcNodeHeight | (Ereditato da TreeList)
Evento pubblico | CellValueChanged | (Ereditato da TreeList)
Evento pubblico | CellValueChanging | (Ereditato da TreeList)
Evento pubblico | ClipboardNodeCopying | (Ereditato da TreeList)
Evento pubblico | ClipboardNodePasting | (Ereditato da TreeList)
Evento pubblico | ColumnButtonClick | (Ereditato da TreeList)
Evento pubblico | ColumnChanged | (Ereditato da TreeList)
Evento pubblico | ColumnFilterChanged | (Ereditato da TreeList)
Evento pubblico | ColumnPositionChanged | (Ereditato da TreeList)
Evento pubblico | ColumnUnboundExpressionChanged | (Ereditato da TreeList)
Evento pubblico | ColumnWidthChanged | (Ereditato da TreeList)
Evento pubblico | CompareNodeValues | (Ereditato da TreeList)
Evento pubblico | CreateCustomNode | (Ereditato da TreeList)
Evento pubblico | CustomColumnDisplayText | (Ereditato da TreeList)
Evento pubblico | CustomColumnSort | (Ereditato da TreeList)
Evento pubblico | CustomDrawBandHeader | (Ereditato da TreeList)
Evento pubblico | CustomDrawColumnHeader | (Ereditato da TreeList)
Evento pubblico | CustomDrawEmptyArea | (Ereditato da TreeList)
Evento pubblico | CustomDrawFilterPanel | (Ereditato da TreeList)
Evento pubblico | CustomDrawFooter | (Ereditato da TreeList)
Evento pubblico | CustomDrawFooterCell | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodeButton | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodeCell | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodeCheckBox | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodeImages | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodeIndent | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodeIndicator | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodePreview | (Ereditato da TreeList)
Evento pubblico | CustomDrawRow | (Ereditato da TreeList)
Evento pubblico | CustomDrawRowFooter | (Ereditato da TreeList)
Evento pubblico | CustomDrawRowFooterCell | (Ereditato da TreeList)
Evento pubblico | CustomDrawScroll | (Ereditato da TreeList)
Evento pubblico | CustomFilterDisplayText | (Ereditato da TreeList)
Evento pubblico | CustomizationFormSearch | (Ereditato da TreeList)
Evento pubblico | CustomizeNewNodeFromOuterData | (Ereditato da TreeList)
Evento pubblico | CustomizeNodeTemplate | (Ereditato da TreeList)
Evento pubblico | CustomNodeCellEdit | (Ereditato da TreeList)
Evento pubblico | CustomNodeCellEditForEditing | (Ereditato da TreeList)
Evento pubblico | CustomRowFilter | (Ereditato da TreeList)
Evento pubblico | CustomScrollAnnotation | (Ereditato da TreeList)
Evento pubblico | CustomUnboundColumnData | (Ereditato da TreeList)
Evento pubblico | DataSourceChanged | (Ereditato da TreeList)
Evento pubblico | DefaultPaintHelperChanged | (Ereditato da TreeList)
Evento pubblico | DragCancelNode | (Ereditato da TreeList)
Evento pubblico | DragObjectDrop | (Ereditato da TreeList)
Evento pubblico | DragObjectOver | (Ereditato da TreeList)
Evento pubblico | DragObjectStart | (Ereditato da TreeList)
Evento pubblico | EditFormHidden | (Ereditato da TreeList)
Evento pubblico | EditFormPrepared | (Ereditato da TreeList)
Evento pubblico | EditFormShowing | (Ereditato da TreeList)
Evento pubblico | EditorKeyDown | (Ereditato da EditorContainer)
Evento pubblico | EditorKeyPress | (Ereditato da EditorContainer)
Evento pubblico | EditorKeyUp | (Ereditato da EditorContainer)
Evento pubblico | EndSorting | (Ereditato da TreeList)
Evento pubblico | FilterEditorCreated | (Ereditato da TreeList)
Evento pubblico | FilterExpressionEditorCreated | (Ereditato da TreeList)
Evento pubblico | FilterNode | (Ereditato da TreeList)
Evento pubblico | FilterPopupExcelCustomizeTemplate | (Ereditato da TreeList)
Evento pubblico | FilterPopupExcelData | (Ereditato da TreeList)
Evento pubblico | FilterPopupExcelParseFilterCriteria | (Ereditato da TreeList)
Evento pubblico | FilterPopupExcelPrepareTemplate | (Ereditato da TreeList)
Evento pubblico | FilterPopupExcelQueryFilterCriteria | (Ereditato da TreeList)
Evento pubblico | FocusedColumnChanged | (Ereditato da TreeList)
Evento pubblico | FocusedNodeChanged | (Ereditato da TreeList)
Evento pubblico | FormatRuleExpressionEditorCreated | (Ereditato da TreeList)
Evento pubblico | GetCustomNodeCellEdit | Obsoleto. (Ereditato da TreeList)
Evento pubblico | GetCustomNodeCellStyle | Obsoleto. (Ereditato da TreeList)
Evento pubblico | GetCustomSummaryValue | (Ereditato da TreeList)
Evento pubblico | GetNodeDisplayValue | (Ereditato da TreeList)
Evento pubblico | GetPreviewText | (Ereditato da TreeList)
Evento pubblico | GetPrintCustomSummaryValue | (Ereditato da TreeList)
Evento pubblico | GetPrintPreviewText | (Ereditato da TreeList)
Evento pubblico | GetSelectImage | (Ereditato da TreeList)
Evento pubblico | GetStateImage | (Ereditato da TreeList)
Evento pubblico | HiddenEditor | (Ereditato da TreeList)
Evento pubblico | HideCustomizationForm | (Ereditato da TreeList)
Evento pubblico | HtmlElementBlur | (Ereditato da TreeList)
Evento pubblico | HtmlElementFocus | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseClick | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseDoubleClick | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseDown | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseMove | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseOut | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseOver | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseUp | (Ereditato da TreeList)
Evento pubblico | HtmlSelectedTextChanged | (Ereditato da TreeList)
Evento pubblico | HyperlinkClick | (Ereditato da TreeList)
Evento pubblico | InitNewRow | (Ereditato da TreeList)
Evento pubblico | InvalidNodeException | (Ereditato da TreeList)
Evento pubblico | InvalidValueException | (Ereditato da TreeList)
Evento pubblico | LayoutUpdated | (Ereditato da TreeList)
Evento pubblico | LayoutUpgrade | (Ereditato da TreeList)
Evento pubblico | LeftCoordChanged | (Ereditato da TreeList)
Evento pubblico | Load | (Ereditato da TreeList)
Evento pubblico | MeasurePreviewHeight | (Ereditato da TreeList)
Evento pubblico | NodeCellStyle | (Ereditato da TreeList)
Evento pubblico | NodeChanged | (Ereditato da TreeList)
Evento pubblico | NodesReloaded | (Ereditato da TreeList)
Evento pubblico | PaintEx | (Ereditato da TreeList)
Evento pubblico | ParseFindPanelText | (Ereditato da TreeList)
Evento pubblico | PopupMenuShowing | (Ereditato da TreeList)
Evento pubblico | PrintExportProgress | (Ereditato da TreeList)
Evento pubblico | PropertyDeserializing | (Ereditato da TreeList)
Evento pubblico | PropertySerializing | (Ereditato da TreeList)
Evento pubblico | QueryCustomFunctions | (Ereditato da TreeList)
Evento pubblico | QueryEmptyTreeTemplate | (Ereditato da TreeList)
Evento pubblico | QueryNodeTemplate | (Ereditato da TreeList)
Evento pubblico | RowCellClick | (Ereditato da TreeList)
Evento pubblico | RowClick | (Ereditato da TreeList)
Evento pubblico | RowSelectImageClick | (Ereditato da TreeList)
Evento pubblico | RowStateImageClick | (Ereditato da TreeList)
Evento pubblico | ScrollAnnotationsStyle | (Ereditato da TreeList)
Evento pubblico | SelectImageClick | (Ereditato da TreeList)
Evento pubblico | SelectionChanged | (Ereditato da TreeList)
Evento pubblico | SelectionChanging | (Ereditato da TreeList)
Evento pubblico | ShowCustomizationForm | (Ereditato da TreeList)
Evento pubblico | ShowFilterPopupCheckedListBox | (Ereditato da TreeList)
Evento pubblico | ShowFilterPopupDate | (Ereditato da TreeList)
Evento pubblico | ShowFilterPopupExcel | (Ereditato da TreeList)
Evento pubblico | ShowFilterPopupListBox | (Ereditato da TreeList)
Evento pubblico | ShowingEditor | (Ereditato da TreeList)
Evento pubblico | ShownEditor | (Ereditato da TreeList)
Evento pubblico | ShowTreeListMenu | Obsoleto. (Ereditato da TreeList)
Evento pubblico | StartSorting | (Ereditato da TreeList)
Evento pubblico | StateChanged | (Ereditato da TreeList)
Evento pubblico | StateImageClick | (Ereditato da TreeList)
Evento pubblico | SubstituteFilter | (Ereditato da TreeList)
Evento pubblico | TopVisibleNodeIndexChanged | (Ereditato da TreeList)
Evento pubblico | TreeListMenuItemClick | (Ereditato da TreeList)
Evento pubblico | UnboundExpressionEditorCreated | (Ereditato da TreeList)
Evento pubblico | ValidateNode | (Ereditato da TreeList)
Evento pubblico | ValidatingEditor | (Ereditato da TreeList)
Evento pubblico | VirtualTreeGetCellValue | (Ereditato da TreeList)
Evento pubblico | VirtualTreeGetChildNodes | (Ereditato da TreeList)
Evento pubblico | VirtualTreeSetCellValue | (Ereditato da TreeList)
Torna su
Vedi anche

Documentazione

Classe MyTreeListBom
Namespace DedNet.Controls


Campi di MyTreeListBom

Il tipo MyTreeListBom espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | allowCloseEditor | (Ereditato da TreeList)
Campo pubblico | FilterByState |
Campo protetto | fInitializing | (Ereditato da EditorContainer)
Campo protetto | fUpdateSize | (Ereditato da TreeList)
Campo pubblico | IsFilterByECO |
Campo protetto | SortedColumns | (Ereditato da TreeList)
Torna su
Vedi anche

Documentazione

Classe MyTreeListBom
Namespace DedNet.Controls


Campo MyTreeListBom.FilterByState

Campo MyTreeListBomFilterByState

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<int> FilterByState
Public FilterByState As List(Of Integer)
public:
List<int>^ FilterByState
val mutable FilterByState: List<int>

Valore del campo

List Int32
Vedi anche

Documentazione

Classe MyTreeListBom
Namespace DedNet.Controls


Campo MyTreeListBom.IsFilterByECO

Campo MyTreeListBomIsFilterByECO

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsFilterByECO
Public IsFilterByECO As Boolean
public:
bool IsFilterByECO
val mutable IsFilterByECO: bool

Valore del campo

Boolean
Vedi anche

Documentazione

Classe MyTreeListBom
Namespace DedNet.Controls


Classe MyTreeListRoot
Ridefinito l'albero in modo da espandere i nodi durante la ricerca.
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
EditorContainer
TreeList
DedNet.ControlsMyTreeListRoot

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class MyTreeListRoot : TreeList
Public Class MyTreeListRoot
    Inherits TreeList
public ref class MyTreeListRoot : public TreeList
type MyTreeListRoot =
    class
        inherit TreeList
    end

Il tipo MyTreeListRoot espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | MyTreeListRoot |
Metodo protetto | MyTreeListRoot(Object) |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | ActiveEditor | (Ereditato da TreeList)
Proprietà pubblica | ActiveFilter | (Ereditato da TreeList)
Proprietà pubblica | ActiveFilterCriteria | (Ereditato da TreeList)
Proprietà pubblica | ActiveFilterEnabled | (Ereditato da TreeList)
Proprietà pubblica | ActiveFilterInfo | (Ereditato da TreeList)
Proprietà pubblica | ActiveFilterString | (Ereditato da TreeList)
Proprietà protetta | ActualAutoNodeHeight | (Ereditato da TreeList)
Proprietà protetta | ActualFilterCriteria | (Ereditato da TreeList)
Proprietà protetta | ActualShowBands | (Ereditato da TreeList)
Proprietà pubblica | AllNodesCount | (Ereditato da TreeList)
Proprietà protetta | AllowAnimatedScrolling | (Ereditato da TreeList)
Proprietà protetta | AllowAutoFilterConditionChange | (Ereditato da TreeList)
Proprietà protetta | AllowBandColumnsMultiRow | (Ereditato da TreeList)
Proprietà protetta | AllowExpandAnimation | (Ereditato da TreeList)
Proprietà protetta | AllowFiltering | (Ereditato da TreeList)
Proprietà protetta | AllowFilteringAfterLoadingData | (Ereditato da TreeList)
Proprietà protetta | AllowFilterNodes | (Ereditato da TreeList)
Proprietà protetta | AllowFindPanel | (Ereditato da TreeList)
Proprietà protetta | AllowPrintProgress | (Ereditato da TreeList)
Proprietà protetta | AllowScaleOnLoad | (Ereditato da EditorContainer)
Proprietà pubblica | AllowTouchGestures | (Ereditato da EditorContainer)
Proprietà protetta | AllowTouchScroll | (Ereditato da TreeList)
Proprietà protetta | AnnotationManager | (Ereditato da TreeList)
Proprietà pubblica | Appearance | (Ereditato da TreeList)
Proprietà pubblica | AppearancePrint | (Ereditato da TreeList)
Proprietà pubblica | AutoFillColumn | (Ereditato da TreeList)
Proprietà pubblica | AutoFillColumnName | (Ereditato da TreeList)
Proprietà pubblica | AutoFillFieldName | (Ereditato da TreeList)
Proprietà protetta | AutoFilterNode | (Ereditato da TreeList)
Proprietà pubblica | BackColor | (Ereditato da TreeList)
Proprietà pubblica | BandPanelRowHeight | (Ereditato da TreeList)
Proprietà pubblica | Bands | (Ereditato da TreeList)
Proprietà pubblica | BestFitVisibleOnly | (Ereditato da TreeList)
Proprietà pubblica | BorderStyle | (Ereditato da TreeList)
Proprietà protetta | CanExpandNodesOnIncrementalSearch | (Ereditato da TreeList)
Proprietà protetta | CanLoadNodes | (Ereditato da TreeList)
Proprietà protetta | CanShowBandsInCustomizationForm | (Ereditato da TreeList)
Proprietà pubblica | CanShowEditor | (Ereditato da TreeList)
Proprietà pubblica | CanShowRowFooterSummary | (Ereditato da TreeList)
Proprietà pubblica | Caption | (Ereditato da TreeList)
Proprietà pubblica | CaptionHeight | (Ereditato da TreeList)
Proprietà protetta | CheckBoxesStrategy | (Ereditato da TreeList)
Proprietà pubblica | CheckBoxFieldName | (Ereditato da TreeList)
Proprietà pubblica | ChildListFieldName | (Ereditato da TreeList)
Proprietà protetta | ClientHeight | (Ereditato da TreeList)
Proprietà protetta | ClientWidth | (Ereditato da TreeList)
Proprietà pubblica | ClipboardDataProvider | (Ereditato da TreeList)
Proprietà protetta | ClipboardPasteHelper | (Ereditato da TreeList)
Proprietà protetta | ClipboardPasteManager | (Ereditato da TreeList)
Proprietà protetta | CloneInfoList | (Ereditato da TreeList)
Proprietà pubblica | ColumnPanelRowHeight | (Ereditato da TreeList)
Proprietà pubblica | Columns | (Ereditato da TreeList)
Proprietà pubblica | ColumnsImageList | (Ereditato da TreeList)
Proprietà protetta | ContainerHelper | (Ereditato da TreeList)
Proprietà pubblica | ContextMenuStrip | (Ereditato da EditorContainer)
Proprietà protetta | CurrencyManager | (Ereditato da TreeList)
Proprietà pubblica | Cursor | (Ereditato da TreeList)
Proprietà pubblica | CustomizationForm | (Ereditato da TreeList)
Proprietà pubblica | CustomizationFormBounds | (Ereditato da TreeList)
Proprietà pubblica | CustomizationRowCount | Obsoleto. (Ereditato da TreeList)
Proprietà protetta | Data | (Ereditato da TreeList)
Proprietà pubblica | DataMember | (Ereditato da TreeList)
Proprietà pubblica | DataSource | (Ereditato da TreeList)
Proprietà protetta | DefaultSize | (Ereditato da TreeList)
Proprietà protetta | DirectXProvider | (Ereditato da TreeList)
Proprietà protetta | DirectXScroller | (Ereditato da TreeList)
Proprietà pubblica | DragExpandDelay | Obsoleto. (Ereditato da TreeList)
Proprietà pubblica | DragNodesMode | Obsoleto. (Ereditato da TreeList)
Proprietà protetta | DXAccessible | (Ereditato da TreeList)
Proprietà protetta | Editable | (Ereditato da TreeList)
Proprietà protetta | EditFormController | (Ereditato da TreeList)
Proprietà pubblica | EditingValue | (Ereditato da TreeList)
Proprietà protetta | EditorHelper | (Ereditato da EditorContainer)
Proprietà protetta | ElementsLookAndFeel | (Ereditato da TreeList)
Proprietà pubblica | EmptyTreeHtmlTemplate | (Ereditato da TreeList)
Proprietà protetta | EnableDirectXPaint | (Ereditato da TreeList)
Proprietà pubblica | EnableDynamicLoading | (Ereditato da TreeList)
Proprietà pubblica | EnableEnhancedScrolling | (Ereditato da TreeList)
Proprietà protetta | EnableEnhancedSorting | (Ereditato da TreeList)
Proprietà protetta | EnableFirstPaintTrigger | (Ereditato da EditorContainer)
Proprietà pubblica | EnableImprovedColumnSizing | (Ereditato da TreeList)
Proprietà protetta | ErrorInfo | (Ereditato da TreeList)
Proprietà protetta | ExcelFilteringProvider | (Ereditato da TreeList)
Proprietà protetta | ExceptionThrown | (Ereditato da TreeList)
Proprietà pubblica | ExternalRepository | (Ereditato da EditorContainer)
Proprietà protetta | ExtraFilter | (Ereditato da TreeList)
Proprietà protetta | ExtraFilterCriteria | (Ereditato da TreeList)
Proprietà protetta | ExtraFilterHightlightText | (Ereditato da TreeList)
Proprietà protetta | FilterColumnsProvider | (Ereditato da TreeList)
Proprietà protetta | FilterHelper | (Ereditato da TreeList)
Proprietà protetta | FilteringService | (Ereditato da TreeList)
Proprietà pubblica | FilterPanelText | (Ereditato da TreeList)
Proprietà protetta | FilterPopup | (Ereditato da TreeList)
Proprietà protetta | FindFilterCriteria | (Ereditato da TreeList)
Proprietà pubblica | FindFilterText | (Ereditato da TreeList)
Proprietà protetta | FindPanel | (Ereditato da TreeList)
Proprietà pubblica | FindPanelVisible | (Ereditato da TreeList)
Proprietà protetta | FireOnLoadOnPaint | (Ereditato da TreeList)
Proprietà pubblica | FixedLineWidth | (Ereditato da TreeList)
Proprietà protetta | FocusedCellIndex | (Ereditato da TreeList)
Proprietà pubblica | FocusedColumn | (Ereditato da TreeList)
Proprietà pubblica | FocusedNode | (Ereditato da TreeList)
Proprietà protetta | FocusedRow | (Ereditato da TreeList)
Proprietà protetta | FocusedRowIndex | (Ereditato da TreeList)
Proprietà pubblica | FocusedValue | (Ereditato da TreeList)
Proprietà pubblica | FooterPanelHeight | (Ereditato da TreeList)
Proprietà protetta | ForceLoadingPanel | (Ereditato da TreeList)
Proprietà pubblica | ForeColor | (Ereditato da EditorContainer)
Proprietà pubblica | FormatConditions | (Ereditato da TreeList)
Proprietà pubblica | FormatRules | (Ereditato da TreeList)
Proprietà pubblica | GroupButtonSize | Obsoleto. (Ereditato da TreeList)
Proprietà protetta | Handler | (Ereditato da TreeList)
Proprietà protetta | HasAccessible | (Ereditato da TreeList)
Proprietà protetta | HasAllColumnsFixedRight | (Ereditato da TreeList)
Proprietà protetta | HasBands | (Ereditato da TreeList)
Proprietà pubblica | HasColumnErrors | (Ereditato da TreeList)
Proprietà protetta | HasCustomNodeCellEdit | (Ereditato da TreeList)
Proprietà pubblica | HasFocus | (Ereditato da TreeList)
Proprietà protetta | HasHierarchicalColumn | (Ereditato da TreeList)
Proprietà protetta | HasTreeViewColumn | (Ereditato da TreeList)
Proprietà protetta | HeaderLayoutCalculator | (Ereditato da TreeList)
Proprietà protetta | HeaderWidthCalculator | (Ereditato da TreeList)
Proprietà pubblica | HierarchyColumn | (Ereditato da TreeList)
Proprietà pubblica | HierarchyColumnIndent | (Ereditato da TreeList)
Proprietà pubblica | HierarchyColumnName | (Ereditato da TreeList)
Proprietà pubblica | HierarchyFieldName | (Ereditato da TreeList)
Proprietà pubblica | HorzScrollStep | (Ereditato da TreeList)
Proprietà pubblica | HorzScrollVisibility | (Ereditato da TreeList)
Proprietà protetta | HtmlContext | (Ereditato da TreeList)
Proprietà pubblica | HtmlImages | (Ereditato da TreeList)
Proprietà protetta | HtmlObjectCache | (Ereditato da TreeList)
Proprietà pubblica | HtmlTemplates | (Ereditato da TreeList)
Proprietà protetta | IBasePrintableCreatesIntersectedBricks | (Ereditato da TreeList)
Proprietà pubblica | ImageIndexFieldName | (Ereditato da TreeList)
Proprietà protetta | IncrementalText | (Ereditato da TreeList)
Proprietà pubblica | IndicatorWidth | (Ereditato da TreeList)
Proprietà protetta | IsAllowBusyIndicator | (Ereditato da TreeList)
Proprietà protetta | IsAllowBusyPanel | (Ereditato da TreeList)
Proprietà protetta | IsAlt | (Ereditato da TreeList)
Proprietà protetta | IsAttachedToSearchControl | (Ereditato da TreeList)
Proprietà protetta | IsAutoWidth | (Ereditato da TreeList)
Proprietà protetta | IsCellSelect | (Ereditato da TreeList)
Proprietà protetta | IsClosingEditor | (Ereditato da TreeList)
Proprietà protetta | IsColumnHeaderAutoHeight | (Ereditato da TreeList)
Proprietà protetta | IsControl | (Ereditato da TreeList)
Proprietà protetta | IsDataReady | (Ereditato da TreeList)
Proprietà protetta | IsDeserializing | (Ereditato da TreeList)
Proprietà pubblica | IsDesignMode | (Ereditato da EditorContainer)
Proprietà protetta | IsDynamicLoadingAllowed | (Ereditato da TreeList)
Proprietà protetta | IsEditFormMode | (Ereditato da TreeList)
Proprietà protetta | IsFilterPopupActive | (Ereditato da TreeList)
Proprietà protetta | IsFindFilterActive | (Ereditato da TreeList)
Proprietà pubblica | IsFindPanelVisible | (Ereditato da TreeList)
Proprietà protetta | IsFocusedNodeChangedLocked | (Ereditato da TreeList)
Proprietà protetta | IsFocusedNodeDataModified | (Ereditato da TreeList)
Proprietà protetta | IsGroupDeleteOperation | (Ereditato da TreeList)
Proprietà protetta | IsHScrollBarVisible | (Ereditato da TreeList)
Proprietà protetta | IsInitialized | (Ereditato da EditorContainer)
Proprietà protetta | IsIniting | (Ereditato da TreeList)
Proprietà pubblica | IsLoading | (Ereditato da EditorContainer)
Proprietà protetta | IsLockDirectXRendering | (Ereditato da TreeList)
Proprietà protetta | IsLockExpandCollapse | (Ereditato da TreeList)
Proprietà protetta | IsLockUpdate | (Ereditato da TreeList)
Proprietà pubblica | IsLookUpMode | (Ereditato da TreeList)
Proprietà protetta | IsMultiSelect | (Ereditato da TreeList)
Proprietà protetta | IsNotificationInfoVisible | (Ereditato da TreeList)
Proprietà protetta | IsPainting | (Ereditato da TreeList)
Proprietà protetta | IsPixelScrolling | (Ereditato da TreeList)
Proprietà protetta | IsPopupEditFormVisible | (Ereditato da TreeList)
Proprietà pubblica | IsPrinting | (Ereditato da TreeList)
Proprietà pubblica | IsPrintingAvailable | (Ereditato da TreeList)
Proprietà protetta | IsRightToLeft | (Ereditato da TreeList)
Proprietà protetta | IsRowCountReady | (Ereditato da TreeList)
Proprietà protetta | IsScrollAnimationInProgress | (Ereditato da TreeList)
Proprietà protetta | IsSearchMode | (Ereditato da TreeList)
Proprietà protetta | IsSerializing | (Ereditato da TreeList)
Proprietà protetta | IsShift | (Ereditato da TreeList)
Proprietà protetta | IsSorted | (Ereditato da TreeList)
Proprietà protetta | IsUnboundLoad | (Ereditato da TreeList)
Proprietà pubblica | IsUnboundMode | (Ereditato da TreeList)
Proprietà protetta | IsUpdateSize | (Ereditato da TreeList)
Proprietà protetta | IsVirtualMode | (Ereditato da TreeList)
Proprietà protetta | IsVScrollBarVisible | (Ereditato da TreeList)
Proprietà pubblica | KeyFieldName | (Ereditato da TreeList)
Proprietà pubblica | LayoutVersion | Obsoleto. (Ereditato da TreeList)
Proprietà pubblica | LeftCoord | (Ereditato da TreeList)
Proprietà pubblica | LoadingPanelVisible | (Ereditato da TreeList)
Proprietà pubblica | LookAndFeel | (Ereditato da EditorContainer)
Proprietà protetta | LookAndFeelIgnoreChildren | (Ereditato da EditorContainer)
Proprietà protetta | LookUpDisplayColumn | (Ereditato da TreeList)
Proprietà protetta | LookUpOwner | (Ereditato da TreeList)
Proprietà pubblica | MenuManager | (Ereditato da EditorContainer)
Proprietà protetta | MinRowHeight | (Ereditato da TreeList)
Proprietà pubblica | MinWidth | (Ereditato da TreeList)
Proprietà protetta | MRUFilterPopup | (Ereditato da TreeList)
Proprietà pubblica | MRUFilters | (Ereditato da TreeList)
Proprietà protetta | NewItemNode | (Ereditato da TreeList)
Proprietà pubblica | NewItemRowText | (Ereditato da TreeList)
Proprietà pubblica | NodeHtmlTemplate | (Ereditato da TreeList)
Proprietà pubblica | Nodes | (Ereditato da TreeList)
Proprietà pubblica | NodesIterator | (Ereditato da TreeList)
Proprietà pubblica | NonColumnFilterCriteria | (Ereditato da TreeList)
Proprietà pubblica | NonColumnFilterString | (Ereditato da TreeList)
Proprietà protetta | NotificationInfo | (Ereditato da TreeList)
Proprietà protetta | OfficeScroller | (Ereditato da TreeList)
Proprietà pubblica | OptionsBehavior | (Ereditato da TreeList)
Proprietà pubblica | OptionsClipboard | (Ereditato da TreeList)
Proprietà pubblica | OptionsCustomization | (Ereditato da TreeList)
Proprietà pubblica | OptionsDragAndDrop | (Ereditato da TreeList)
Proprietà pubblica | OptionsEditForm | (Ereditato da TreeList)
Proprietà pubblica | OptionsFilter | (Ereditato da TreeList)
Proprietà pubblica | OptionsFind | (Ereditato da TreeList)
Proprietà pubblica | OptionsHtmlTemplate | (Ereditato da TreeList)
Proprietà pubblica | OptionsLayout | (Ereditato da TreeList)
Proprietà pubblica | OptionsMenu | (Ereditato da TreeList)
Proprietà pubblica | OptionsNavigation | (Ereditato da TreeList)
Proprietà pubblica | OptionsPrint | (Ereditato da TreeList)
Proprietà pubblica | OptionsScrollAnnotations | (Ereditato da TreeList)
Proprietà pubblica | OptionsSelection | (Ereditato da TreeList)
Proprietà pubblica | OptionsView | (Ereditato da TreeList)
Proprietà pubblica | Painter | (Ereditato da TreeList)
Proprietà pubblica | ParentFieldName | (Ereditato da TreeList)
Proprietà protetta | Position | (Ereditato da TreeList)
Proprietà protetta | PressedBand | (Ereditato da TreeList)
Proprietà protetta | PressedColumn | (Ereditato da TreeList)
Proprietà protetta | PressedNode | (Ereditato da TreeList)
Proprietà pubblica | PreviewFieldName | (Ereditato da TreeList)
Proprietà pubblica | PreviewIndent | (Ereditato da TreeList)
Proprietà pubblica | PreviewLineCount | (Ereditato da TreeList)
Proprietà protetta | Printer | (Ereditato da TreeList)
Proprietà protetta | PrinterCore | (Ereditato da TreeList)
Proprietà protetta | ProgressWindow | (Ereditato da TreeList)
Proprietà pubblica | RepositoryItems | (Ereditato da EditorContainer)
Proprietà pubblica | RootValue | (Ereditato da TreeList)
Proprietà protetta | RowCount | (Ereditato da TreeList)
Proprietà pubblica | RowHeight | (Ereditato da TreeList)
Proprietà protetta | ScaleDPI | (Ereditato da EditorContainer)
Proprietà pubblica | ScaleFactor | (Ereditato da EditorContainer)
Proprietà protetta | ScaleHelper | (Ereditato da EditorContainer)
Proprietà protetta | ScrollInfo | (Ereditato da TreeList)
Proprietà pubblica | SelectedHtmlText | (Ereditato da TreeList)
Proprietà pubblica | SelectImageList | (Ereditato da TreeList)
Proprietà pubblica | Selection | (Ereditato da TreeList)
Proprietà protetta | SelectionRange | (Ereditato da TreeList)
Proprietà pubblica | ShowButtonMode | (Ereditato da TreeList)
Proprietà protetta | ShowEditorAfterAnimatedScroll | (Ereditato da TreeList)
Proprietà protetta | ShowPreview | (Ereditato da TreeList)
Proprietà protetta | SizedBand | (Ereditato da TreeList)
Proprietà protetta | SizedColumn | (Ereditato da TreeList)
Proprietà protetta | SmartVisibility | (Ereditato da TreeList)
Proprietà pubblica | SortedColumnCount | (Ereditato da TreeList)
Proprietà pubblica | State | (Ereditato da TreeList)
Proprietà pubblica | StateImageList | (Ereditato da TreeList)
Proprietà pubblica | SyncCheckStateWithSourceOnChecking | (Ereditato da TreeList)
Proprietà pubblica | Text | (Ereditato da EditorContainer)
Proprietà pubblica | ToolTipController | (Ereditato da EditorContainer)
Proprietà protetta | TopVisibleNode | (Ereditato da TreeList)
Proprietà pubblica | TopVisibleNodeIndex | (Ereditato da TreeList)
Proprietà pubblica | TopVisibleNodePixel | (Ereditato da TreeList)
Proprietà pubblica | TreeLevelWidth | (Ereditato da TreeList)
Proprietà pubblica | TreeLineStyle | (Ereditato da TreeList)
Proprietà pubblica | TreeListDisposing | (Ereditato da TreeList)
Proprietà pubblica | TreeViewColumn | (Ereditato da TreeList)
Proprietà pubblica | TreeViewColumnName | (Ereditato da TreeList)
Proprietà pubblica | TreeViewFieldName | (Ereditato da TreeList)
Proprietà pubblica | UpdateTopVisibleNodeIndexOnCollapse | (Ereditato da TreeList)
Proprietà protetta | UseBandsAdvancedHorizontalNavigation | (Ereditato da TreeList)
Proprietà protetta | UseBandsAdvancedVerticalNavigation | (Ereditato da TreeList)
Proprietà pubblica | UseDirectXPaint | (Ereditato da TreeList)
Proprietà pubblica | UseDisabledStatePainter | (Ereditato da TreeList)
Proprietà protetta | UseStandardFilter | (Ereditato da TreeList)
Proprietà pubblica | VertScrollVisibility | (Ereditato da TreeList)
Proprietà pubblica | ViewInfo | (Ereditato da TreeList)
Proprietà pubblica | ViewStyle | (Ereditato da TreeList)
Proprietà protetta | VirtualDataHelper | (Ereditato da TreeList)
Proprietà pubblica | VisibleColumnCount | Obsoleto. (Ereditato da TreeList)
Proprietà pubblica | VisibleColumns | (Ereditato da TreeList)
Proprietà pubblica | VisibleNodesCount | (Ereditato da TreeList)
Proprietà protetta | WorkAsLookup | (Ereditato da TreeList)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AccessibleNotifyClients(AccessibleEvents, BaseAccessible) | (Ereditato da TreeList)
Metodo pubblico | AccessibleNotifyClients(AccessibleEvents, Int32, Int32) | (Ereditato da TreeList)
Metodo pubblico | AddFilter(CriteriaOperator) | (Ereditato da TreeList)
Metodo pubblico | AddFilter(String) | (Ereditato da TreeList)
Metodo protetto | AddToDefaultTooltipController | (Ereditato da EditorContainer)
Metodo protetto | AllowAutoFilterCondition | (Ereditato da TreeList)
Metodo protetto | AnimateKeyboardNavigation | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, TreeListNode) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, TreeListNode, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, TreeListNode, CheckState) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, CheckState) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, TreeListNode, CheckState, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, CheckState, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, TreeListNode, CheckState, NodeCheckBoxStyle, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, Int32, Int32, Int32) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, Int32, Int32, Int32, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, Int32, Int32, Int32, CheckState) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, Int32, Int32, Int32, CheckState, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, Int32, Int32, Int32, CheckState, NodeCheckBoxStyle, Object) | (Ereditato da TreeList)
Metodo protetto | ApplyFilter | (Ereditato da TreeList)
Metodo pubblico | ApplyFindFilter | (Ereditato da TreeList)
Metodo protetto | BeforeShowEditForm | (Ereditato da TreeList)
Metodo pubblico | BeginDelete | (Ereditato da TreeList)
Metodo protetto | BeginDragDrop | (Ereditato da TreeList)
Metodo protetto | BeginExpandCollapse | (Ereditato da TreeList)
Metodo pubblico | BeginInit | (Ereditato da EditorContainer)
Metodo protetto | BeginLockListChanged | (Ereditato da TreeList)
Metodo pubblico | BeginSelection | (Ereditato da TreeList)
Metodo pubblico | BeginSort | (Ereditato da TreeList)
Metodo pubblico | BeginUnboundLoad | (Ereditato da TreeList)
Metodo pubblico | BeginUpdate | (Ereditato da TreeList)
Metodo pubblico | BestFitColumns | (Ereditato da TreeList)
Metodo pubblico | BestFitColumns(Boolean) | (Ereditato da TreeList)
Metodo pubblico | BindCommand(Object, String, FuncObject) | (Ereditato da TreeList)
Metodo pubblico | BindCommand(ExpressionAction, Object, String, FuncObject) | (Ereditato da TreeList)
Metodo pubblico | BindCommand``1(ExpressionActionUMP, Object, String, FuncUMP) | (Ereditato da TreeList)
Metodo protetto | CalcActiveEditorBounds | (Ereditato da TreeList)
Metodo protetto | CalcColumnBestWidth | (Ereditato da TreeList)
Metodo pubblico | CalcHitInfo | (Ereditato da TreeList)
Metodo protetto | CalcHScrollRange | (Ereditato da TreeList)
Metodo protetto | CalcNodeAutoHeight | (Ereditato da TreeList)
Metodo protetto | CalcRowCount | (Ereditato da TreeList)
Metodo protetto | CalcScrollClientRect | (Ereditato da TreeList)
Metodo protetto | CalculateScrollBars | (Ereditato da TreeList)
Metodo protetto | CalculateVisibleRowsAreaHeight | (Ereditato da TreeList)
Metodo pubblico | CancelCurrentEdit | (Ereditato da TreeList)
Metodo protetto | CancelDirectXRendering | (Ereditato da TreeList)
Metodo protetto | CancelLockListChanged | (Ereditato da TreeList)
Metodo protetto | CancelSelection | (Ereditato da TreeList)
Metodo pubblico | CancelSort | (Ereditato da TreeList)
Metodo pubblico | CancelUpdate | (Ereditato da TreeList)
Metodo protetto | CanClearAllSorting | (Ereditato da TreeList)
Metodo protetto | CanCloneChildren | (Ereditato da TreeList)
Metodo protetto | CanFilterByColumnEdit | (Ereditato da TreeList)
Metodo pubblico | CanFilterColumn | (Ereditato da TreeList)
Metodo protetto | CanFindColumn | (Ereditato da TreeList)
Metodo protetto | CanFocusNode | (Ereditato da TreeList)
Metodo protetto | CanHandleTouchGestures | (Ereditato da EditorContainer)
Metodo protetto | CanIncrementalSearch | (Ereditato da TreeList)
Metodo pubblico | CanIndentNodes | (Ereditato da TreeList)
Metodo protetto | CanMove | (Ereditato da TreeList)
Metodo protetto | CanMoveBand | (Ereditato da TreeList)
Metodo protetto | CanMoveColumn | (Ereditato da TreeList)
Metodo pubblico | CanOutdentNodes | (Ereditato da TreeList)
Metodo protetto | CanResizeBand | (Ereditato da TreeList)
Metodo protetto | CanResizeColumn | (Ereditato da TreeList)
Metodo protetto | CanShowHScrollBar | (Ereditato da TreeList)
Metodo protetto | CanShowHScrollBarCore | (Ereditato da TreeList)
Metodo protetto | CanShowVScrollBar | (Ereditato da TreeList)
Metodo protetto | CanSortByColumnEdit | (Ereditato da TreeList)
Metodo pubblico | CanSortColumn | (Ereditato da TreeList)
Metodo protetto | CanStartTouchScrolling | (Ereditato da TreeList)
Metodo protetto | ChangeLeftCoord | (Ereditato da TreeList)
Metodo pubblico | CheckAll | (Ereditato da TreeList)
Metodo protetto | CheckAllowGestures | (Ereditato da TreeList)
Metodo protetto | CheckAllowNotifications | (Ereditato da TreeList)
Metodo protetto | CheckData | (Ereditato da TreeList)
Metodo protetto | CheckIncreaseVisibleRows | (Ereditato da TreeList)
Metodo protetto | CheckModifierKeys | (Ereditato da TreeList)
Metodo protetto | CheckNeedScale | (Ereditato da EditorContainer)
Metodo protetto | CheckRightToLeft | (Ereditato da EditorContainer)
Metodo protetto | CheckSearchMode | (Ereditato da TreeList)
Metodo protetto | CheckTopVisibleNodeAfterItemAdded | (Ereditato da TreeList)
Metodo protetto | CheckTopVisibleNodePixelValue | (Ereditato da TreeList)
Metodo pubblico | ClearColumnErrors | (Ereditato da TreeList)
Metodo pubblico | ClearColumnFilter | (Ereditato da TreeList)
Metodo protetto | ClearColumnFilterCore(String) | (Ereditato da TreeList)
Metodo protetto | ClearColumnFilterCore(TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | ClearColumnsFilter | (Ereditato da TreeList)
Metodo pubblico | ClearDocument | (Ereditato da TreeList)
Metodo pubblico | ClearFindFilter | (Ereditato da TreeList)
Metodo pubblico | ClearFocusedColumn | (Ereditato da TreeList)
Metodo pubblico | ClearNodes | (Ereditato da TreeList)
Metodo pubblico | ClearSelection | (Ereditato da TreeList)
Metodo pubblico | ClearSorting | (Ereditato da TreeList)
Metodo protetto | ClearVisibleIndicesCache | (Ereditato da TreeList)
Metodo pubblico | CloseEditForm | (Ereditato da TreeList)
Metodo pubblico | CloseEditor | (Ereditato da TreeList)
Metodo protetto | CloseEditor(Boolean) | (Ereditato da TreeList)
Metodo pubblico | CollapseAll | (Ereditato da TreeList)
Metodo protetto | CollapseAllCore | (Ereditato da TreeList)
Metodo pubblico | CollapseToLevel | (Ereditato da TreeList)
Metodo pubblico | ColumnsCustomization | (Ereditato da TreeList)
Metodo pubblico | ColumnsCustomization(Point) | (Ereditato da TreeList)
Metodo protetto | ControlRowSourceSelectedChanged | (Ereditato da TreeList)
Metodo protetto | ControlRowSourceVisibleChanged | (Ereditato da TreeList)
Metodo pubblico | ConvertFormatConditionToFormatRules | (Ereditato da TreeList)
Metodo pubblico | CopyNode(TreeListNode, TreeListNode, Boolean) | (Ereditato da TreeList)
Metodo pubblico | CopyNode(TreeListNode, TreeListNode, Boolean, Boolean) | (Ereditato da TreeList)
Metodo pubblico | CopyNode(TreeListNode, TreeListNode, Boolean, Int32) | (Ereditato da TreeList)
Metodo pubblico | CopyNode(TreeListNode, TreeListNode, Boolean, Boolean, Int32) | (Ereditato da TreeList)
Metodo protetto | CopyNodeCore | (Ereditato da TreeList)
Metodo pubblico | CopyNodes(IEnumerableTreeListNode, TreeListNode, Boolean, Int32) | (Ereditato da TreeList)
Metodo pubblico | CopyNodes(IEnumerableTreeListNode, TreeListNode, Boolean, Boolean, Int32) | (Ereditato da TreeList)
Metodo pubblico | CopyToClipboard | (Ereditato da TreeList)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da TreeList)
Metodo protetto | CreateAccessibleDataRow | (Ereditato da TreeList)
Metodo protetto | CreateAccessibleInstance | (Ereditato da TreeList)
Metodo protetto | CreateAllOptions | (Ereditato da TreeList)
Metodo protetto | CreateAnnotationManager | (Ereditato da TreeList)
Metodo protetto | CreateAppearances | (Ereditato da TreeList)
Metodo protetto | CreateAutoFilterCriterion | (Ereditato da TreeList)
Metodo protetto | CreateBands | (Ereditato da TreeList)
Metodo protetto | CreateCheckBoxesStrategy | (Ereditato da TreeList)
Metodo protetto | CreateCheckedListFilterPopup | (Ereditato da TreeList)
Metodo protetto | CreateColumn | (Ereditato da TreeList)
Metodo protetto | CreateColumnEditViewInfo | (Ereditato da TreeList)
Metodo protetto | CreateColumnFilterCriteriaByValue(TreeListColumn, Object) | (Ereditato da TreeList)
Metodo protetto | CreateColumnFilterCriteriaByValue(TreeListColumn, Object, Boolean) | (Ereditato da TreeList)
Metodo protetto | CreateColumnFilterPopup | (Ereditato da TreeList)
Metodo protetto | CreateColumns | (Ereditato da TreeList)
Metodo pubblico | CreateCustomization | Obsoleto. (Ereditato da TreeList)
Metodo protetto | CreateCustomizationForm | (Ereditato da TreeList)
Metodo protetto | CreateData | (Ereditato da TreeList)
Metodo protetto | CreateDataViewData | (Ereditato da TreeList)
Metodo protetto | CreateDateFilterPopup | (Ereditato da TreeList)
Metodo protetto | CreateDragNodesProvider | (Ereditato da TreeList)
Metodo protetto | CreateEditFormController | (Ereditato da TreeList)
Metodo protetto | CreateElementsLookAndFeel | (Ereditato da TreeList)
Metodo protetto | CreateExcelFilterPopup | (Ereditato da TreeList)
Metodo protetto | CreateFilterColumnCollection | (Ereditato da TreeList)
Metodo protetto | CreateFilterColumnRuleCollection | (Ereditato da TreeList)
Metodo protetto | CreateFilterColumnsProvider | (Ereditato da TreeList)
Metodo protetto | CreateFilterCriteriaBindingTarget | (Ereditato da TreeList)
Metodo protetto | CreateFilterEditorForm | (Ereditato da TreeList)
Metodo protetto | CreateFilterHelper | (Ereditato da TreeList)
Metodo protetto | CreateFindPanel | (Ereditato da TreeList)
Metodo protetto | CreateFindPanelCore | (Ereditato da TreeList)
Metodo pubblico | CreateGraphicsCache | (Ereditato da TreeList)
Metodo protetto | CreateHandler | (Ereditato da TreeList)
Metodo protetto | CreateHeaderLayoutCalculator | (Ereditato da TreeList)
Metodo protetto | CreateHeaderWidthCalculator | (Ereditato da TreeList)
Metodo protetto | CreateHelper | (Ereditato da TreeList)
Metodo protetto | CreateHierarchicalListData | (Ereditato da TreeList)
Metodo protetto | CreateHtmlContext | (Ereditato da TreeList)
Metodo protetto | CreateHyperlinkClickEventArgs | (Ereditato da TreeList)
Metodo protetto | CreateInternalRepository | (Ereditato da EditorContainer)
Metodo protetto | CreateListColumnFilterPopup | (Ereditato da TreeList)
Metodo protetto | CreateListData | (Ereditato da TreeList)
Metodo protetto | CreateLoadingAnimator | (Ereditato da TreeList)
Metodo protetto | CreateLoadingPanel | (Ereditato da TreeList)
Metodo protetto | CreateLookAndFeel | (Ereditato da EditorContainer)
Metodo protetto | CreateNewItemNode | (Ereditato da TreeList)
Metodo protetto | CreateNode(Int32, TreeListNodes) | (Ereditato da TreeList)
Metodo protetto | CreateNode(Int32, TreeListNodes, Object) | (Ereditato da TreeList)
Metodo protetto | CreateNodes | (Ereditato da TreeList)
Metodo protetto | CreateNodesComparer | (Ereditato da TreeList)
Metodo protetto | CreateNodesIterator | (Ereditato da TreeList)
Metodo protetto | CreateNotificationInfo | (Ereditato da TreeList)
Metodo protetto | CreateOfficeScroller | (Ereditato da TreeList)
Metodo protetto | CreateOptionsBehavior | (Ereditato da TreeList)
Metodo protetto | CreateOptionsClipboard | (Ereditato da TreeList)
Metodo protetto | CreateOptionsCustomization | (Ereditato da TreeList)
Metodo protetto | CreateOptionsDragAndDrop | (Ereditato da TreeList)
Metodo protetto | CreateOptionsEditForm | (Ereditato da TreeList)
Metodo protetto | CreateOptionsFilter | (Ereditato da TreeList)
Metodo protetto | CreateOptionsFind | (Ereditato da TreeList)
Metodo protetto | CreateOptionsHtmlTemplate | (Ereditato da TreeList)
Metodo protetto | CreateOptionsLayout | (Ereditato da TreeList)
Metodo protetto | CreateOptionsMenu | (Ereditato da TreeList)
Metodo protetto | CreateOptionsNavigation | (Ereditato da TreeList)
Metodo protetto | CreateOptionsPrint | (Ereditato da TreeList)
Metodo protetto | CreateOptionsScrollAnnotations | (Ereditato da TreeList)
Metodo protetto | CreateOptionsSelection | (Ereditato da TreeList)
Metodo protetto | CreateOptionsView | (Ereditato da TreeList)
Metodo protetto | CreatePainter | (Ereditato da TreeList)
Metodo protetto | CreatePrinter | (Ereditato da TreeList)
Metodo protetto | CreateProvider | (Ereditato da TreeList)
Metodo protetto | CreateScrollInfo | (Ereditato da TreeList)
Metodo protetto | CreateSelection | (Ereditato da TreeList)
Metodo protetto | CreateUnboundData | (Ereditato da TreeList)
Metodo protetto | CreateViewInfo | (Ereditato da TreeList)
Metodo protetto | CreateVirtualData | (Ereditato da TreeList)
Metodo protetto | CreateVirtualDataHelper | (Ereditato da TreeList)
Metodo protetto | CurrencyManager_ItemChanged | (Ereditato da TreeList)
Metodo protetto | CurrencyManager_PositionChanged | (Ereditato da TreeList)
Metodo protetto | DeferredLoadChildren | (Ereditato da TreeList)
Metodo protetto | DelayedInvalidate | (Ereditato da TreeList)
Metodo pubblico | DeleteNode | (Ereditato da TreeList)
Metodo pubblico | DeleteNodes | (Ereditato da TreeList)
Metodo pubblico | DeleteSelectedNodes | (Ereditato da TreeList)
Metodo pubblico | DestroyCustomization | (Ereditato da TreeList)
Metodo protetto | DestroyDirectXProvider | (Ereditato da EditorContainer)
Metodo protetto | DestroyFindPanel | (Ereditato da TreeList)
Metodo protetto | Dispose | (Ereditato da TreeList)
Metodo protetto | DoDataSourceChanged | (Ereditato da TreeList)
Metodo protetto | DoDpiChange | (Ereditato da EditorContainer)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da TreeList)
Metodo protetto | DoDragDrop | (Ereditato da TreeList)
Metodo pubblico | DoDragDropNode | (Ereditato da TreeList)
Metodo pubblico | DoDragDropNodes | (Ereditato da TreeList)
Metodo protetto | DoFilterNode | (Ereditato da TreeList)
Metodo protetto | DoForEachBand | (Ereditato da TreeList)
Metodo pubblico | DoIncrementalSearch | (Ereditato da TreeList)
Metodo protetto | DoShowTreeListMenu(TreeListMenu, TreeListHitTest) | (Ereditato da TreeList)
Metodo protetto | DoShowTreeListMenu(TreeListMenu, Control, Point) | (Ereditato da TreeList)
Metodo protetto | DoTopVisibleNodeChanged | (Ereditato da TreeList)
Metodo pubblico | EndCurrentEdit | (Ereditato da TreeList)
Metodo pubblico | EndCurrentEdit(Boolean) | (Ereditato da TreeList)
Metodo pubblico | EndDelete | (Ereditato da TreeList)
Metodo protetto | EndDragDrop | (Ereditato da TreeList)
Metodo protetto | EndEdit | (Ereditato da TreeList)
Metodo protetto | EndExpandCollapse | (Ereditato da TreeList)
Metodo pubblico | EndInit | (Ereditato da EditorContainer)
Metodo pubblico | EndSelection | (Ereditato da TreeList)
Metodo pubblico | EndSort | (Ereditato da TreeList)
Metodo pubblico | EndUnboundLoad | (Ereditato da TreeList)
Metodo pubblico | EndUpdate | (Ereditato da TreeList)
Metodo protetto | EnsureControlRowSource | (Ereditato da TreeList)
Metodo protetto | EnsureEditFormController | (Ereditato da TreeList)
Metodo protetto | EnsureFilteringClientDataBinding | (Ereditato da TreeList)
Metodo protetto | ExecutePrinterAction | (Ereditato da TreeList)
Metodo pubblico | ExpandAll | (Ereditato da TreeList)
Metodo protetto | ExpandAllCore | (Ereditato da TreeList)
Metodo protetto | ExpandToLast | (Ereditato da TreeList)
Metodo pubblico | ExpandToLevel | (Ereditato da TreeList)
Metodo protetto | ExpandToRoot | (Ereditato da TreeList)
Metodo protetto | Export(ExportTarget, Stream) | (Ereditato da TreeList)
Metodo protetto | Export(ExportTarget, String) | (Ereditato da TreeList)
Metodo protetto | Export(ExportTarget, Stream, ExportOptionsBase) | (Ereditato da TreeList)
Metodo protetto | Export(ExportTarget, String, ExportOptionsBase) | (Ereditato da TreeList)
Metodo pubblico | ExportToCsv(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToCsv(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToCsv(Stream, CsvExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToCsv(String, CsvExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToDocx(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToDocx(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToDocx(Stream, DocxExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToDocx(String, DocxExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToHtml(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToHtml(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToHtml(Stream, HtmlExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToHtml(String, HtmlExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToMht(Stream, MhtExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToMht(String, MhtExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToMht(String, String) | Obsoleto. (Ereditato da TreeList)
Metodo pubblico | ExportToMht(Stream, String, String, Boolean) | Obsoleto. (Ereditato da TreeList)
Metodo pubblico | ExportToMht(String, String, String, Boolean) | Obsoleto. (Ereditato da TreeList)
Metodo pubblico | ExportToPdf(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToPdf(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToPdf(Stream, PdfExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToPdf(String, PdfExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToRtf(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToRtf(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToText(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToText(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToText(Stream, TextExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToText(String, TextExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToXls(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToXls(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToXls(Stream, XlsExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToXls(String, XlsExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToXlsx(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToXlsx(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToXlsx(Stream, XlsxExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToXlsx(String, XlsxExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToXml(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToXml(String) | (Ereditato da TreeList)
Metodo protetto | ExportToXmlCore | (Ereditato da TreeList)
Metodo protetto | ExtractTemplateRootNode | (Ereditato da TreeList)
Metodo pubblico | FilterNodes | (Sovrascrive TreeList.FilterNodes)
Metodo pubblico | FilterNodes(TreeListNodes) | (Ereditato da TreeList)
Metodo protetto | FilterNodesCore | (Ereditato da TreeList)
Metodo pubblico | FindNode | (Ereditato da TreeList)
Metodo pubblico | FindNodeByFieldValue | (Ereditato da TreeList)
Metodo pubblico | FindNodeByID | (Ereditato da TreeList)
Metodo pubblico | FindNodeByKeyID | (Ereditato da TreeList)
Metodo protetto | FindNodeByParentID | (Ereditato da TreeList)
Metodo pubblico | FindNodes | (Ereditato da TreeList)
Metodo protetto | FindPanelNext | (Ereditato da TreeList)
Metodo protetto | FindPanelPrev | (Ereditato da TreeList)
Metodo pubblico | FireChanged | (Ereditato da TreeList)
Metodo protetto | FitColumns | (Ereditato da TreeList)
Metodo pubblico | FocusNewItemNode | (Ereditato da TreeList)
Metodo protetto | ForceCalcRowCount | (Ereditato da TreeList)
Metodo pubblico | ForceInitialize | (Ereditato da TreeList)
Metodo protetto | ForceSetTopVisibleNodeIndex | (Ereditato da TreeList)
Metodo pubblico | FullCollapse | Obsoleto. (Ereditato da TreeList)
Metodo pubblico | FullExpand | Obsoleto. (Ereditato da TreeList)
Metodo pubblico | FullExpandNode | Obsoleto. (Ereditato da TreeList)
Metodo protetto | GetAccessibilityObjectById | (Ereditato da TreeList)
Metodo protetto | GetAccessibleNodeCell | (Ereditato da TreeList)
Metodo protetto | GetActiveEditorHighAppearance | (Ereditato da TreeList)
Metodo protetto | GetActualAnimationType | (Ereditato da TreeList)
Metodo protetto | GetActualTreeListFilterMode | (Ereditato da TreeList)
Metodo pubblico | GetAllCheckedNodes | (Ereditato da TreeList)
Metodo protetto | GetAllowChangeBandParent | (Ereditato da TreeList)
Metodo protetto | GetAllowColumnFilterPopup | (Ereditato da TreeList)
Metodo protetto | GetAllowFilterEditor | (Ereditato da TreeList)
Metodo protetto | GetAllowFindColumn | (Ereditato da TreeList)
Metodo protetto | GetAllowFocus | (Ereditato da TreeList)
Metodo protetto | GetAllowHighlightFindResults | (Ereditato da TreeList)
Metodo protetto | GetAllowMRUFilterList | (Ereditato da TreeList)
Metodo protetto | GetAutoFilterRowColumnEdit | (Ereditato da TreeList)
Metodo pubblico | GetAutoFilterValue | (Ereditato da TreeList)
Metodo protetto | GetAutoNodeHeight | (Ereditato da TreeList)
Metodo protetto | GetBandRows | (Ereditato da TreeList)
Metodo protetto | GetBandRowsCore | (Ereditato da TreeList)
Metodo protetto | GetBandVisibleIndex | (Ereditato da TreeList)
Metodo protetto | GetCanShowEditor | (Ereditato da TreeList)
Metodo pubblico | GetColumnByColumnHandle | (Ereditato da TreeList)
Metodo pubblico | GetColumnByVisibleIndex | (Ereditato da TreeList)
Metodo protetto | GetColumnDefaultRepositoryItem | (Ereditato da TreeList)
Metodo protetto | GetColumnDefaultRepositoryItemForEditing | (Ereditato da TreeList)
Metodo protetto | GetColumnEdit | (Ereditato da TreeList)
Metodo protetto | GetColumnEditForEditing | (Ereditato da TreeList)
Metodo pubblico | GetColumnError(TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | GetColumnError(TreeListColumn, TreeListNode) | (Ereditato da TreeList)
Metodo pubblico | GetColumnErrorType(TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | GetColumnErrorType(TreeListColumn, TreeListNode) | (Ereditato da TreeList)
Metodo protetto | GetColumnFieldNameSort | (Ereditato da TreeList)
Metodo protetto | GetColumnFilterCriteria | (Ereditato da TreeList)
Metodo protetto | GetColumnFilterMode | (Ereditato da TreeList)
Metodo pubblico | GetColumnHeaderBestWidth | (Ereditato da TreeList)
Metodo protetto | GetColumnName | (Ereditato da TreeList)
Metodo protetto | GetCurrencyManager | (Ereditato da TreeList)
Metodo protetto | GetDataColumnInfo | (Ereditato da TreeList)
Metodo pubblico | GetDataRecordByNode | (Ereditato da TreeList)
Metodo pubblico | GetDataRow | (Ereditato da TreeList)
Metodo protetto | GetDirectXDeviceBackColor | (Ereditato da EditorContainer)
Metodo protetto | GetDirectXProvider | (Ereditato da EditorContainer)
Metodo protetto | GetEditableObject | (Ereditato da TreeList)
Metodo pubblico | GetEditorShowMode | (Ereditato da TreeList)
Metodo protetto | GetEditorViewInfo | (Ereditato da TreeList)
Metodo protetto | GetFilterColumn | (Ereditato da TreeList)
Metodo protetto | GetFilterColumnByTreeListColumn | (Ereditato da TreeList)
Metodo protetto | GetFilterCriteriaDisplayStyle | (Ereditato da TreeList)
Metodo protetto | GetFilterDisplayText | (Ereditato da TreeList)
Metodo protetto | GetFilterDisplayTextByColumn | (Ereditato da TreeList)
Metodo protetto | GetFilterPopupTexts | (Ereditato da TreeList)
Metodo protetto | GetFilterPopupValues(TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | GetFilterPopupValues(TreeListColumn, Boolean) | (Ereditato da TreeList)
Metodo protetto | GetFilterPopupValues(TreeListColumn, CriteriaOperator, Boolean) | (Ereditato da TreeList)
Metodo protetto | GetFilterPopupValues(TreeListColumn, Boolean, Boolean) | (Ereditato da TreeList)
Metodo protetto | GetFilterRowValue(Object) | (Ereditato da TreeList)
Metodo protetto | GetFilterRowValue(TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | GetFindMatchedRanges | (Ereditato da TreeList)
Metodo protetto | GetFindMatchedText | (Ereditato da TreeList)
Metodo protetto | GetFindToColumnsCollection | (Ereditato da TreeList)
Metodo pubblico | GetFocusedDataRow | (Ereditato da TreeList)
Metodo pubblico | GetFocusedDisplayText | (Ereditato da TreeList)
Metodo pubblico | GetFocusedRow | (Ereditato da TreeList)
Metodo pubblico | GetFocusedRowCellDisplayText(String) | (Ereditato da TreeList)
Metodo pubblico | GetFocusedRowCellDisplayText(TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetFocusedRowCellValue(String) | (Ereditato da TreeList)
Metodo pubblico | GetFocusedRowCellValue(TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetGroupSummaryValue | (Ereditato da TreeList)
Metodo protetto | GetHeaderFilterButtonShowMode | (Ereditato da TreeList)
Metodo pubblico | GetHitInfo | Obsoleto. (Ereditato da TreeList)
Metodo protetto | GetImageIndexFromDataSource | (Ereditato da TreeList)
Metodo protetto | GetMaxIndent | (Ereditato da TreeList)
Metodo protetto | GetNativePreviewText | (Ereditato da TreeList)
Metodo pubblico | GetNodeAt(Point) | (Ereditato da TreeList)
Metodo pubblico | GetNodeAt(Int32, Int32) | (Ereditato da TreeList)
Metodo pubblico | GetNodeByVisibleIndex | (Ereditato da TreeList)
Metodo protetto | GetNodeCellRepositoryItem | (Ereditato da TreeList)
Metodo protetto | GetNodeComparer(IComparerTreeListNode) | (Ereditato da TreeList)
Metodo protetto | GetNodeComparer(TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetNodeIndex | (Ereditato da TreeList)
Metodo pubblico | GetNodeList | (Ereditato da TreeList)
Metodo protetto | GetNodeValue(TreeListNode, TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | GetNodeValue(TreeListNode, Object) | (Ereditato da TreeList)
Metodo protetto | GetNodeValue(TreeListNode, String) | (Ereditato da TreeList)
Metodo protetto | GetNonFormattedCaption | (Ereditato da TreeList)
Metodo protetto | GetParentColumnFieldNameSort | (Ereditato da TreeList)
Metodo pubblico | GetRow | (Ereditato da TreeList)
Metodo pubblico | GetRowCellDisplayText(TreeListNode, TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetRowCellDisplayText(TreeListNode, String) | (Ereditato da TreeList)
Metodo pubblico | GetRowCellValue(TreeListNode, TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetRowCellValue(TreeListNode, String) | (Ereditato da TreeList)
Metodo protetto | GetRowsAsFootersCount | (Ereditato da TreeList)
Metodo pubblico | GetScrollAnnotations | (Ereditato da TreeList)
Metodo pubblico | GetSelectedCells | (Ereditato da TreeList)
Metodo pubblico | GetSelectedCells(TreeListNode) | (Ereditato da TreeList)
Metodo protetto | GetShowBandsMode | (Ereditato da TreeList)
Metodo protetto | GetShowFirstLines | (Ereditato da TreeList)
Metodo protetto | GetShowIndentAsRowStyle | (Ereditato da TreeList)
Metodo pubblico | GetSortColumn(Int32) | (Ereditato da TreeList)
Metodo protetto | GetSortColumn(TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetSummaryValue(TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetSummaryValue(TreeListColumn, Boolean) | (Ereditato da TreeList)
Metodo protetto | GetSummaryValueCore | (Ereditato da TreeList)
Metodo protetto | GetSummaryValueEx | (Ereditato da TreeList)
Metodo pubblico | GetToolTipController | (Ereditato da EditorContainer)
Metodo protetto | GetUseDirectXPaint | (Ereditato da TreeList)
Metodo pubblico | GetVisibleIndexByNode | (Ereditato da TreeList)
Metodo protetto | GetVisibleIndexByNodeCore | (Ereditato da TreeList)
Metodo protetto | GetVisibleParentNodesCount | (Ereditato da TreeList)
Metodo pubblico | HideCustomization | (Ereditato da TreeList)
Metodo pubblico | HideEditor | (Ereditato da TreeList)
Metodo protetto | HideEditorCore | (Ereditato da TreeList)
Metodo pubblico | HideFindPanel | (Ereditato da TreeList)
Metodo pubblico | HideLoadingPanel | (Ereditato da TreeList)
Metodo protetto | HookOnLoaded | (Ereditato da EditorContainer)
Metodo pubblico | ImportFromXml(Stream) | (Ereditato da TreeList)
Metodo pubblico | ImportFromXml(String) | (Ereditato da TreeList)
Metodo protetto | ImportFromXmlCore | (Ereditato da TreeList)
Metodo pubblico | IndentNodes | (Ereditato da TreeList)
Metodo protetto | InitFindPanel | (Ereditato da TreeList)
Metodo protetto | InitializeDirectXProvider | (Ereditato da EditorContainer)
Metodo protetto | InitScrollInfo | (Ereditato da TreeList)
Metodo protetto | InternalDeleteNode | (Ereditato da TreeList)
Metodo protetto | InternalDeleteNodeCore | (Ereditato da TreeList)
Metodo protetto | InternalDeleteNodes(DictionaryTreeListNodes, ListTreeListNode) | (Ereditato da TreeList)
Metodo protetto | InternalDeleteNodes(TreeListNodes) | (Ereditato da TreeList)
Metodo protetto | InternalFullCollapseNode | (Ereditato da TreeList)
Metodo protetto | InternalFullExpandNode | (Ereditato da TreeList)
Metodo protetto | InternalGetCustomNodeCellEdit | (Ereditato da TreeList)
Metodo protetto | InternalGetCustomNodeCellStyle | (Ereditato da TreeList)
Metodo pubblico | InternalGetService | (Ereditato da TreeList)
Metodo protetto | InternalNodeAdded | (Ereditato da TreeList)
Metodo protetto | InternalNodeChanged | (Ereditato da TreeList)
Metodo protetto | InternalSetTopVisibleNodePixel | (Ereditato da TreeList)
Metodo pubblico | InvalidateBand | (Ereditato da TreeList)
Metodo pubblico | InvalidateBandPanel | (Ereditato da TreeList)
Metodo pubblico | InvalidateCell | (Ereditato da TreeList)
Metodo pubblico | InvalidateColumnHeader | (Ereditato da TreeList)
Metodo pubblico | InvalidateColumnPanel | (Ereditato da TreeList)
Metodo pubblico | InvalidateFilterPanel | (Ereditato da TreeList)
Metodo pubblico | InvalidateNode | (Ereditato da TreeList)
Metodo pubblico | InvalidateNodes | (Ereditato da TreeList)
Metodo pubblico | InvalidateRow | (Ereditato da TreeList)
Metodo pubblico | InvalidateRowPreview | (Ereditato da TreeList)
Metodo protetto | InvalidateRows | (Ereditato da TreeList)
Metodo pubblico | InvalidateScrollAnnotations | (Ereditato da TreeList)
Metodo pubblico | InvalidateSummaryFooterPanel | (Ereditato da TreeList)
Metodo pubblico | InvokeMenuItemClick | (Ereditato da TreeList)
Metodo protetto | IsAllowDefaultFastBestFit | (Ereditato da TreeList)
Metodo protetto | IsAllowEditForm | (Ereditato da TreeList)
Metodo pubblico | IsAutoFilterNode | (Ereditato da TreeList)
Metodo pubblico | IsCellSelected | (Ereditato da TreeList)
Metodo protetto | IsColumnAllowAutoFilter | (Ereditato da TreeList)
Metodo protetto | IsColumnAllowFilter | (Ereditato da TreeList)
Metodo pubblico | IsColumnAllowFilterEditor | (Ereditato da TreeList)
Metodo protetto | IsColumnFieldNameSortExist | (Ereditato da TreeList)
Metodo protetto | IsColumnFiltered | (Ereditato da TreeList)
Metodo protetto | IsFilterByDisplayText | (Ereditato da TreeList)
Metodo protetto | IsFilterRow | (Ereditato da TreeList)
Metodo protetto | IsImplyNullLikeEmptyStringWhenFiltering | (Ereditato da TreeList)
Metodo protetto | IsInputChar | (Ereditato da TreeList)
Metodo protetto | IsInputKey | (Ereditato da TreeList)
Metodo pubblico | IsNewItemRow | (Ereditato da TreeList)
Metodo protetto | IsParentColumnFieldNameSortExist | (Ereditato da TreeList)
Metodo pubblico | IsRootNode | (Ereditato da TreeList)
Metodo protetto | IsRoundDateTime | (Ereditato da TreeList)
Metodo protetto | IsShowAllValuesInFilterPopup | (Ereditato da TreeList)
Metodo protetto | IsTopNewItemRow | (Ereditato da TreeList)
Metodo protetto | IsUserAutoFilterCondition | (Ereditato da TreeList)
Metodo pubblico | LayoutChanged | (Ereditato da TreeList)
Metodo protetto | LoadDataColumns | (Ereditato da TreeList)
Metodo protetto | LoadDataSource | (Ereditato da TreeList)
Metodo protetto | LockDirectXRendering | (Ereditato da TreeList)
Metodo protetto | LockFilteringUIClientFilterCriteriaBinding | (Ereditato da TreeList)
Metodo pubblico | LockReloadNodes | (Ereditato da TreeList)
Metodo pubblico | MakeColumnVisible | (Ereditato da TreeList)
Metodo protetto | MakeFocusedRowVisible | (Ereditato da TreeList)
Metodo pubblico | MakeNodeVisible | (Ereditato da TreeList)
Metodo protetto | MergeColumnFiltersCore | (Ereditato da TreeList)
Metodo pubblico | MoveFirst | (Ereditato da TreeList)
Metodo protetto | MoveFocusedCell | (Ereditato da TreeList)
Metodo pubblico | MoveLast | (Ereditato da TreeList)
Metodo pubblico | MoveLastVisible | (Ereditato da TreeList)
Metodo pubblico | MoveNext | (Ereditato da TreeList)
Metodo pubblico | MoveNextVisible | (Ereditato da TreeList)
Metodo pubblico | MoveNode(TreeListNode, TreeListNode) | (Ereditato da TreeList)
Metodo pubblico | MoveNode(TreeListNode, TreeListNode, Boolean) | (Ereditato da TreeList)
Metodo pubblico | MoveNode(TreeListNode, TreeListNode, Boolean, Int32) | (Ereditato da TreeList)
Metodo pubblico | MoveNodes | (Ereditato da TreeList)
Metodo protetto | MoveNodesCore | (Ereditato da TreeList)
Metodo pubblico | MovePrev | (Ereditato da TreeList)
Metodo pubblico | MovePrevVisible | (Ereditato da TreeList)
Metodo pubblico | MoveToNextScrollAnnotation | (Ereditato da TreeList)
Metodo pubblico | MoveToParent | (Ereditato da TreeList)
Metodo pubblico | MoveToPrevScrollAnnotation | (Ereditato da TreeList)
Metodo protetto | NormalizeVisibleBandIndices | (Ereditato da TreeList)
Metodo protetto | NormalizeVisibleColumnIndices | (Ereditato da TreeList)
Metodo protetto | OnActiveEditor_GotFocus | (Ereditato da TreeList)
Metodo protetto | OnActiveEditor_LostFocus | (Ereditato da TreeList)
Metodo protetto | OnActiveEditor_Modified | (Ereditato da TreeList)
Metodo protetto | OnActiveEditor_ValueChanged | (Ereditato da TreeList)
Metodo protetto | OnActiveEditor_ValueChanging | (Ereditato da TreeList)
Metodo protetto | OnActiveFilterChanged | (Ereditato da TreeList)
Metodo protetto | OnActiveFilterCriteriaChanged | (Ereditato da TreeList)
Metodo protetto | OnActiveFilterEnabledChanged | (Ereditato da TreeList)
Metodo protetto | OnAfterAddingNode | (Ereditato da TreeList)
Metodo protetto | OnAfterChangeCollapsed | (Ereditato da TreeList)
Metodo protetto | OnAfterChangeExpanded | (Ereditato da TreeList)
Metodo protetto | OnAfterDeletingNodes | (Ereditato da TreeList)
Metodo protetto | OnAllowBandColumnMultiRowChanged | (Ereditato da TreeList)
Metodo protetto | OnAllowSerializationProperty | (Ereditato da TreeList)
Metodo protetto | OnAppearancePrintChanged | (Ereditato da TreeList)
Metodo protetto | OnBandChanged | (Ereditato da TreeList)
Metodo protetto | OnBandCollectionChanged | (Ereditato da TreeList)
Metodo protetto | OnBandColumnCollectionChanged | (Ereditato da TreeList)
Metodo protetto | OnBandFixedChanged | (Ereditato da TreeList)
Metodo protetto | OnBandWidthChanged | (Ereditato da TreeList)
Metodo protetto | OnBeginTouchScroll | (Ereditato da TreeList)
Metodo protetto | OnBindingContextChanged | (Ereditato da TreeList)
Metodo protetto | OnCheckBoxFieldNameChanged | (Ereditato da TreeList)
Metodo protetto | OnClearNodes | (Ereditato da TreeList)
Metodo protetto | OnClearNodesComplete | (Ereditato da TreeList)
Metodo protetto | OnClick | (Ereditato da TreeList)
Metodo protetto | OnColumnAdded | (Ereditato da TreeList)
Metodo protetto | OnColumnChanged | (Ereditato da TreeList)
Metodo protetto | OnColumnFilterModeChanged | (Ereditato da TreeList)
Metodo protetto | OnColumnFilterRestored | (Ereditato da TreeList)
Metodo protetto | OnColumnInfosPopulated | (Ereditato da TreeList)
Metodo protetto | OnColumnRemoved | (Ereditato da TreeList)
Metodo protetto | OnColumnRowIndexChanged | (Ereditato da TreeList)
Metodo protetto | OnColumnsChanged | (Ereditato da TreeList)
Metodo protetto | OnColumnUnboundChanged | (Ereditato da TreeList)
Metodo protetto | OnColumnUnboundExpressionChanged | (Ereditato da TreeList)
Metodo protetto | OnContainerEnter | (Ereditato da EditorContainer)
Metodo protetto | OnContainerLeave | (Ereditato da EditorContainer)
Metodo protetto | OnContextMenuKey | (Ereditato da TreeList)
Metodo protetto | OnCreateControl | (Ereditato da EditorContainer)
Metodo protetto | OnDataListChanged | (Ereditato da TreeList)
Metodo protetto | OnDesignerHost_LoadComplete | (Ereditato da EditorContainer)
Metodo protetto | OnDesignerHost_TransactionClosed | (Ereditato da EditorContainer)
Metodo protetto | OnDirectXPaintDisabled | (Ereditato da TreeList)
Metodo protetto | OnDoubleClick | (Ereditato da TreeList)
Metodo protetto | OnDragDrop | (Ereditato da TreeList)
Metodo protetto | OnDragEnter | (Ereditato da TreeList)
Metodo protetto | OnDragLeave | (Ereditato da TreeList)
Metodo protetto | OnDragOver | (Ereditato da TreeList)
Metodo protetto | OnEnabledChanged | (Ereditato da TreeList)
Metodo protetto | OnEndInit | (Ereditato da EditorContainer)
Metodo protetto | OnEndSerializing | (Ereditato da TreeList)
Metodo protetto | OnEndSorting | (Ereditato da TreeList)
Metodo protetto | OnEnter | (Ereditato da EditorContainer)
Metodo protetto | OnErrorInfo_Changed | (Ereditato da TreeList)
Metodo protetto | OnFilterRowValueChanging | (Ereditato da TreeList)
Metodo protetto | OnFirstInit | (Ereditato da EditorContainer)
Metodo protetto | OnFormatConditionChanged | (Ereditato da TreeList)
Metodo protetto | OnFormatRuleExpressionEditorCreated | (Ereditato da TreeList)
Metodo protetto | OnFormatRulesCollectionChanged | (Ereditato da TreeList)
Metodo protetto | OnGotCapture | (Ereditato da EditorContainer)
Metodo protetto | OnGotFocus | (Ereditato da TreeList)
Metodo protetto | OnHandleCreated | (Ereditato da TreeList)
Metodo protetto | OnHandleDestroyed | (Ereditato da TreeList)
Metodo protetto | OnHorizontalTouchScroll | (Ereditato da TreeList)
Metodo protetto | OnHScroll | (Ereditato da TreeList)
Metodo protetto | OnItemAdded | (Ereditato da TreeList)
Metodo protetto | OnItemAdding | (Ereditato da TreeList)
Metodo protetto | OnItemChanged(Int32, PropertyDescriptor) | (Ereditato da TreeList)
Metodo protetto | OnItemChanged(Int32, PropertyDescriptor, TreeListNode) | (Ereditato da TreeList)
Metodo protetto | OnItemDeleted | (Ereditato da TreeList)
Metodo protetto | OnItemMoved | (Ereditato da TreeList)
Metodo protetto | OnKeyDown | (Ereditato da TreeList)
Metodo protetto | OnKeyPress | (Ereditato da TreeList)
Metodo protetto | OnKeyUp | (Ereditato da TreeList)
Metodo protetto | OnLeave | (Ereditato da EditorContainer)
Metodo protetto | OnLoaded | (Ereditato da TreeList)
Metodo protetto | OnLoadedCore | (Ereditato da TreeList)
Metodo protetto | OnLookAndFeelChanged(LookAndFeelChangedEventArgs) | (Ereditato da TreeList)
Metodo protetto | OnLookAndFeelChanged(Object, EventArgs) | (Ereditato da EditorContainer)
Metodo protetto | OnLostCapture | (Ereditato da TreeList)
Metodo protetto | OnLostFocus | (Ereditato da TreeList)
Metodo protetto | OnMenuShowing | (Ereditato da TreeList)
Metodo protetto | OnMouseClick | (Ereditato da EditorContainer)
Metodo protetto | OnMouseDoubleClick | (Ereditato da EditorContainer)
Metodo protetto | OnMouseDown | (Ereditato da TreeList)
Metodo protetto | OnMouseEnter | (Ereditato da TreeList)
Metodo protetto | OnMouseHWheel | (Ereditato da EditorContainer)
Metodo protetto | OnMouseLeave | (Ereditato da TreeList)
Metodo protetto | OnMouseMove | (Ereditato da TreeList)
Metodo protetto | OnMouseUp | (Ereditato da TreeList)
Metodo protetto | OnMouseWheel | (Ereditato da EditorContainer)
Metodo protetto | OnMouseWheelCore | (Ereditato da TreeList)
Metodo protetto | OnNodeCheckedChanged | (Ereditato da TreeList)
Metodo protetto | OnNodeRemoved | (Ereditato da TreeList)
Metodo protetto | OnNodesLoaded | (Ereditato da TreeList)
Metodo protetto | OnNodesLoading | (Ereditato da TreeList)
Metodo protetto | OnNodesRemoved | (Ereditato da TreeList)
Metodo protetto | OnOptionsBehaviorChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsCustomizationChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsDragAndDropChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsEditFormChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsFilterChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsFindChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsHtmlChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsNavigationChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsPrintChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsScrollAnnotationsChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsSelectionChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsViewChanged | (Ereditato da TreeList)
Metodo protetto | OnPaint | (Ereditato da TreeList)
Metodo protetto | OnPaintBackground | (Ereditato da TreeList)
Metodo protetto | OnParentChanged | (Ereditato da TreeList)
Metodo protetto | OnPressedBandChanged | (Ereditato da TreeList)
Metodo protetto | OnPrintProgress | (Ereditato da TreeList)
Metodo protetto | OnPropertyChanged | (Ereditato da TreeList)
Metodo protetto | OnPropertyDescriptorChanged | (Ereditato da TreeList)
Metodo protetto | OnQueryContinueDrag | (Ereditato da TreeList)
Metodo protetto | OnRepositoryItemRefreshRequired | (Ereditato da TreeList)
Metodo protetto | OnReset | (Ereditato da TreeList)
Metodo protetto | OnResetSerializationProperties | (Ereditato da TreeList)
Metodo protetto | OnResize | (Ereditato da TreeList)
Metodo protetto | OnRightToLeftChanged | (Ereditato da TreeList)
Metodo protetto | OnRightToLeftChanged(EventArgs) | (Ereditato da EditorContainer)
Metodo protetto | OnScaleControl | (Ereditato da TreeList)
Metodo protetto | OnScaleTreeListCore | (Ereditato da TreeList)
Metodo protetto | OnSelectionChanged | (Ereditato da TreeList)
Metodo protetto | OnSetValue | (Ereditato da TreeList)
Metodo protetto | OnSortModeChanged | (Ereditato da TreeList)
Metodo protetto | OnSourceItemChanged | (Ereditato da TreeList)
Metodo protetto | OnStartSerializing | (Ereditato da TreeList)
Metodo protetto | OnStartSorting | (Ereditato da TreeList)
Metodo protetto | OnSystemColorsChanged | (Ereditato da TreeList)
Metodo protetto | OnToolTipControllerDisposed | (Ereditato da EditorContainer)
Metodo protetto | OnTouchScroll | (Ereditato da TreeList)
Metodo protetto | OnTouchZoom | (Ereditato da TreeList)
Metodo protetto | OnValidated | (Ereditato da EditorContainer)
Metodo protetto | OnValidating | (Ereditato da TreeList)
Metodo protetto | OnVerticalTouchScroll | (Ereditato da TreeList)
Metodo protetto | OnVisibleChanged | (Ereditato da TreeList)
Metodo protetto | OnVScroll | (Ereditato da TreeList)
Metodo protetto | OnVScrollCore | (Ereditato da TreeList)
Metodo pubblico | OutdentNodes | (Ereditato da TreeList)
Metodo protetto | ParseAutoFilter | (Ereditato da TreeList)
Metodo protetto | ParseAutoFilterValues | (Ereditato da TreeList)
Metodo pubblico | PasteFromClipboard | (Ereditato da TreeList)
Metodo pubblico | PopulateColumns | (Ereditato da TreeList)
Metodo pubblico | PostEditor | (Ereditato da TreeList)
Metodo protetto | PostEditor(Boolean) | (Ereditato da TreeList)
Metodo pubblico | Print | (Ereditato da TreeList)
Metodo protetto | PrintCore | (Ereditato da TreeList)
Metodo pubblico | PrintDialog | (Ereditato da TreeList)
Metodo protetto | PrintDialogCore | (Ereditato da TreeList)
Metodo protetto | ProcessControlTab | (Ereditato da TreeList)
Metodo protetto | ProcessControlTab(Boolean) | (Ereditato da TreeList)
Metodo protetto | ProcessDialogKey | (Ereditato da TreeList)
Metodo protetto | ProcessDirectXPaint | (Ereditato da TreeList)
Metodo protetto | RaiseAfterCheckNode | (Ereditato da TreeList)
Metodo protetto | RaiseAfterCollapse | (Ereditato da TreeList)
Metodo protetto | RaiseAfterDragNode | (Ereditato da TreeList)
Metodo protetto | RaiseAfterDropNode | (Ereditato da TreeList)
Metodo protetto | RaiseAfterExpand | (Ereditato da TreeList)
Metodo protetto | RaiseAfterFocusNode | (Ereditato da TreeList)
Metodo protetto | RaiseBandPositionChanged | (Ereditato da TreeList)
Metodo protetto | RaiseBandWidthChanged | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeCheckNode | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeCollapse | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeDragNode | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeDropNode | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeExpand | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeFocusNode | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeLoadLayout | (Ereditato da TreeList)
Metodo protetto | RaiseCalcNodeDragImageIndex | (Ereditato da TreeList)
Metodo protetto | RaiseCalcNodeHeight(TreeListNode, Int32) | (Ereditato da TreeList)
Metodo protetto | RaiseCalcNodeHeight(TreeListNode, RowInfo, Int32) | (Ereditato da TreeList)
Metodo protetto | RaiseCellValueChanged | (Ereditato da TreeList)
Metodo protetto | RaiseCellValueChanging | (Ereditato da TreeList)
Metodo protetto | RaiseCheckedColumnFilterPopupEvent | (Ereditato da TreeList)
Metodo protetto | RaiseClipboardNodeCopying | (Ereditato da TreeList)
Metodo protetto | RaiseClipboardNodePasting | (Ereditato da TreeList)
Metodo protetto | RaiseColumnButtonClick | (Ereditato da TreeList)
Metodo protetto | RaiseColumnChanged | (Ereditato da TreeList)
Metodo protetto | RaiseColumnFilterChanged | (Ereditato da TreeList)
Metodo protetto | RaiseColumnFilterPopupEvent | (Ereditato da TreeList)
Metodo protetto | RaiseColumnPositionChanged | (Ereditato da TreeList)
Metodo protetto | RaiseColumnUnboundExpressionChanged | (Ereditato da TreeList)
Metodo protetto | RaiseColumnWidthChanged | (Ereditato da TreeList)
Metodo protetto | RaiseCompareNodeValues | (Ereditato da TreeList)
Metodo protetto | RaiseCreateCustomNode | (Ereditato da TreeList)
Metodo protetto | RaiseCustomColumnDisplayText(CustomColumnDisplayTextEventArgs) | (Ereditato da TreeList)
Metodo protetto | RaiseCustomColumnDisplayText(TreeListNode, CellInfo) | (Ereditato da TreeList)
Metodo protetto | RaiseCustomColumnDisplayText(TreeListNode, TreeListColumn, BaseEditViewInfo) | (Ereditato da TreeList)
Metodo protetto | RaiseCustomColumnDisplayText(TreeListNode, TreeListColumn, Object, String) | (Ereditato da TreeList)
Metodo protetto | RaiseCustomColumnSort | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawBandHeader | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawColumnHeader | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawEmptyArea | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawFilterPanel | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawFooter | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawFooterCell | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodeButton | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodeCell | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodeCheckBox | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodeImages | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodeIndent | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodeIndicator | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodePreview | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawRow | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawRowFooter | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawRowFooterCell | (Ereditato da TreeList)
Metodo protetto | RaiseCustomFilterDisplayText | (Ereditato da TreeList)
Metodo protetto | RaiseCustomizationFormSearch | (Ereditato da TreeList)
Metodo protetto | RaiseCustomizeNewNodeFromOuterData | (Ereditato da TreeList)
Metodo protetto | RaiseCustomRowFilter | (Ereditato da TreeList)
Metodo protetto | RaiseCustomRowFilterEvent | (Ereditato da TreeList)
Metodo protetto | RaiseCustomUnboundColumnData | (Ereditato da TreeList)
Metodo protetto | RaiseDataSourceChanged | (Ereditato da TreeList)
Metodo protetto | RaiseDefaultPaintHelperChanged | (Ereditato da TreeList)
Metodo protetto | RaiseDragCancelNode | (Ereditato da TreeList)
Metodo protetto | RaiseDragObjectDrop | (Ereditato da TreeList)
Metodo protetto | RaiseDragObjectOver | (Ereditato da TreeList)
Metodo protetto | RaiseDragObjectStart | (Ereditato da TreeList)
Metodo protetto | RaiseEditFormHidden | (Ereditato da TreeList)
Metodo protetto | RaiseEditFormPrepared | (Ereditato da TreeList)
Metodo protetto | RaiseEditFormShowing | (Ereditato da TreeList)
Metodo protetto | RaiseEditorKeyDown | (Ereditato da TreeList)
Metodo protetto | RaiseEditorKeyPress | (Ereditato da EditorContainer)
Metodo protetto | RaiseEditorKeyUp | (Ereditato da EditorContainer)
Metodo protetto | RaiseEndSorting | (Ereditato da TreeList)
Metodo protetto | RaiseExcelColumnFilterPopupEvent | (Ereditato da TreeList)
Metodo protetto | RaiseFilterEditorCreated | (Ereditato da TreeList)
Metodo protetto | RaiseFilterExpressionEditorCreated | (Ereditato da TreeList)
Metodo protetto | RaiseFilterNodeEvent | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupDate | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelCustomizeTemplate | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelData(FilterPopupExcelDataEventArgs) | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelData(TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelData(TreeListColumn, CriteriaOperator) | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelData(TreeListColumn, TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelParseFilterCriteria | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelPrepareTemplate | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelQueryFilterCriteria | (Ereditato da TreeList)
Metodo protetto | RaiseFocusedColumnChanged | (Ereditato da TreeList)
Metodo protetto | RaiseFocusedNodeChanged | (Ereditato da TreeList)
Metodo protetto | RaiseGetCustomAnnotations | (Ereditato da TreeList)
Metodo protetto | RaiseGetCustomNodeCellEdit | (Ereditato da TreeList)
Metodo protetto | RaiseGetCustomNodeCellStyle | (Ereditato da TreeList)
Metodo protetto | RaiseGetCustomSummaryValue | (Ereditato da TreeList)
Metodo protetto | RaiseGetNodeDisplayValue | (Ereditato da TreeList)
Metodo protetto | RaiseGetPreviewText | (Ereditato da TreeList)
Metodo protetto | RaiseGetPrintCustomSummaryValue | (Ereditato da TreeList)
Metodo protetto | RaiseGetPrintPreviewText | (Ereditato da TreeList)
Metodo protetto | RaiseGetSelectImage | (Ereditato da TreeList)
Metodo protetto | RaiseGetStateImage | (Ereditato da TreeList)
Metodo protetto | RaiseHiddenEditor | (Ereditato da TreeList)
Metodo protetto | RaiseHideCustomizationForm | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementBlur | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementFocus | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseClick | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseDoubleClick | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseDown | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseMove | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseOut | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseOver | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseUp | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlSelectedTextChanged | (Ereditato da TreeList)
Metodo protetto | RaiseInitNewRow | (Ereditato da TreeList)
Metodo protetto | RaiseInvalidNodeException | (Ereditato da TreeList)
Metodo protetto | RaiseInvalidValueException | (Ereditato da TreeList)
Metodo protetto | RaiseLayoutUpdated | (Ereditato da TreeList)
Metodo protetto | RaiseLayoutUpgrade | (Ereditato da TreeList)
Metodo protetto | RaiseLeftCoordChanged | (Ereditato da TreeList)
Metodo protetto | RaiseLoad | (Ereditato da TreeList)
Metodo protetto | RaiseMeasurePreviewHeight | (Ereditato da TreeList)
Metodo protetto | RaiseNodeChanged | (Ereditato da TreeList)
Metodo protetto | RaiseNodesReloaded | (Ereditato da TreeList)
Metodo protetto | RaisePaintEx | (Ereditato da TreeList)
Metodo protetto | RaiseParseFindPanelText | (Ereditato da TreeList)
Metodo protetto | RaisePopupMenuShowing | (Ereditato da TreeList)
Metodo protetto | RaisePrintExportProgress | (Ereditato da TreeList)
Metodo protetto | RaiseQueryCustomFunctions | (Ereditato da TreeList)
Metodo protetto | RaiseRequireHideEditor | (Ereditato da EditorContainer)
Metodo protetto | RaiseRowCellClick | (Ereditato da TreeList)
Metodo protetto | RaiseRowClick | (Ereditato da TreeList)
Metodo protetto | RaiseRowSelectImageClick | (Ereditato da TreeList)
Metodo protetto | RaiseRowStateImageClick | (Ereditato da TreeList)
Metodo protetto | RaiseSelectImageClick | (Ereditato da TreeList)
Metodo protetto | RaiseSelectionChanged | (Ereditato da TreeList)
Metodo protetto | RaiseSelectionChanging | (Ereditato da TreeList)
Metodo protetto | RaiseShowCustomizationForm | (Ereditato da TreeList)
Metodo protetto | RaiseShowingEditor | (Ereditato da TreeList)
Metodo protetto | RaiseShownEditor | (Ereditato da TreeList)
Metodo protetto | RaiseShowTreeListMenu | Obsoleto. (Ereditato da TreeList)
Metodo protetto | RaiseStartSorting | (Ereditato da TreeList)
Metodo protetto | RaiseStateChanged | (Ereditato da TreeList)
Metodo protetto | RaiseStateImageClick | (Ereditato da TreeList)
Metodo protetto | RaiseSubstituteFilter | (Ereditato da TreeList)
Metodo protetto | RaiseTopVisibleNodeIndexChanged | (Ereditato da TreeList)
Metodo protetto | RaiseTreeListMenuItemClick | (Ereditato da TreeList)
Metodo protetto | RaiseUnboundExpressionEditorCreated | (Ereditato da TreeList)
Metodo protetto | RaiseValidateNode | (Ereditato da TreeList)
Metodo protetto | RaiseValidatingEditor | (Ereditato da TreeList)
Metodo protetto | RecalcSortColumns | (Ereditato da TreeList)
Metodo protetto | RecreateRowsInfoCore | (Ereditato da TreeList)
Metodo pubblico | Refresh | (Ereditato da TreeList)
Metodo pubblico | Refresh(Boolean) | (Ereditato da TreeList)
Metodo pubblico | RefreshCell | (Ereditato da TreeList)
Metodo protetto | RefreshCellCore | (Ereditato da TreeList)
Metodo protetto | RefreshColumnsInfo | (Ereditato da TreeList)
Metodo pubblico | RefreshDataSource | (Ereditato da TreeList)
Metodo pubblico | RefreshEditor | (Ereditato da TreeList)
Metodo protetto | RefreshEditorError | (Ereditato da TreeList)
Metodo protetto | RefreshHeadersInfo | (Ereditato da TreeList)
Metodo protetto | RefreshHtmlNodeCore | (Ereditato da TreeList)
Metodo pubblico | RefreshNode | (Ereditato da TreeList)
Metodo protetto | RefreshNodeCore | (Ereditato da TreeList)
Metodo protetto | RefreshRowsInfo | (Ereditato da TreeList)
Metodo protetto | RefreshRowsInfo(Boolean, Boolean) | (Ereditato da TreeList)
Metodo pubblico | RefreshScrollAnnotations(ScrollAnnotationKind) | (Ereditato da TreeList)
Metodo pubblico | RefreshScrollAnnotations(ScrollAnnotationKind, Int32) | (Ereditato da TreeList)
Metodo protetto | RefreshVirtualCellCore | (Ereditato da TreeList)
Metodo protetto | RefreshVirtualNodeCore | (Ereditato da TreeList)
Metodo protetto | RejectCurrentChanges | (Ereditato da TreeList)
Metodo protetto | RemoveFromDefaultTooltipController | (Ereditato da EditorContainer)
Metodo protetto | RemoveHookOnLoaded | (Ereditato da EditorContainer)
Metodo protetto | RemoveNodeHeight | (Ereditato da TreeList)
Metodo protetto | RequestCellEditor | (Ereditato da TreeList)
Metodo protetto | ResetAccessibility | (Ereditato da TreeList)
Metodo pubblico | ResetAutoFilterCondition | (Ereditato da TreeList)
Metodo pubblico | ResetAutoFilterConditions | (Ereditato da TreeList)
Metodo pubblico | ResetAutoFilterConditions(IEnumerableTreeListColumn) | (Ereditato da TreeList)
Metodo protetto | ResetAutoFilterConditionsCore | (Ereditato da TreeList)
Metodo protetto | ResetColumnAutoFilterConditions | (Ereditato da TreeList)
Metodo pubblico | ResetEditorsCache(RepositoryItem) | (Ereditato da EditorContainer)
Metodo pubblico | ResetEditorsCache(Type) | (Ereditato da EditorContainer)
Metodo protetto | ResetExcelFilteringProvider | (Ereditato da TreeList)
Metodo pubblico | ResetFilterFlag | Reinizializza i flag utilizzati per il filtraggio dei nodi
Metodo protetto | ResetLookAndFeel | (Ereditato da EditorContainer)
Metodo protetto | ResetRowCount | (Ereditato da TreeList)
Metodo protetto | ResetSortedColumns | (Ereditato da TreeList)
Metodo protetto | ResizeBand | (Ereditato da TreeList)
Metodo protetto | ResizeColumn | (Ereditato da TreeList)
Metodo protetto | ResolveAutoFilterCondition | (Ereditato da TreeList)
Metodo protetto | RestoreLayoutCore | (Ereditato da TreeList)
Metodo pubblico | RestoreLayoutFromRegistry(String) | (Ereditato da TreeList)
Metodo pubblico | RestoreLayoutFromRegistry(String, OptionsLayoutBase) | (Ereditato da TreeList)
Metodo pubblico | RestoreLayoutFromStream(Stream) | (Ereditato da TreeList)
Metodo pubblico | RestoreLayoutFromStream(Stream, OptionsLayoutBase) | (Ereditato da TreeList)
Metodo pubblico | RestoreLayoutFromXml(String) | (Ereditato da TreeList)
Metodo pubblico | RestoreLayoutFromXml(String, OptionsLayoutBase) | (Ereditato da TreeList)
Metodo protetto | RestoreNodesData | (Ereditato da TreeList)
Metodo protetto | SaveLayoutCore | (Ereditato da TreeList)
Metodo pubblico | SaveLayoutToRegistry(String) | (Ereditato da TreeList)
Metodo pubblico | SaveLayoutToRegistry(String, OptionsLayoutBase) | (Ereditato da TreeList)
Metodo pubblico | SaveLayoutToStream(Stream) | (Ereditato da TreeList)
Metodo pubblico | SaveLayoutToStream(Stream, OptionsLayoutBase) | (Ereditato da TreeList)
Metodo pubblico | SaveLayoutToXml(String) | (Ereditato da TreeList)
Metodo pubblico | SaveLayoutToXml(String, OptionsLayoutBase) | (Ereditato da TreeList)
Metodo protetto | SaveNodesData | (Ereditato da TreeList)
Metodo protetto | ScaleControl | (Ereditato da EditorContainer)
Metodo protetto | Scrollbar_MouseEnter | (Ereditato da TreeList)
Metodo protetto | Scrollbar_MouseLeave | (Ereditato da TreeList)
Metodo protetto | ScrollHorizontalEx | (Ereditato da TreeList)
Metodo protetto | ScrollVerticalEx | (Ereditato da TreeList)
Metodo pubblico | SelectAll | (Ereditato da TreeList)
Metodo pubblico | SelectCell | (Ereditato da TreeList)
Metodo protetto | SelectCellCore | (Ereditato da TreeList)
Metodo pubblico | SelectCells(Int32, String, Int32, String) | (Ereditato da TreeList)
Metodo pubblico | SelectCells(TreeListNode, TreeListColumn, TreeListNode, TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | SelectNode | (Ereditato da TreeList)
Metodo protetto | SelectNodeCore | (Ereditato da TreeList)
Metodo pubblico | SelectNodes(Int32, Int32) | (Ereditato da TreeList)
Metodo pubblico | SelectNodes(TreeListNode, TreeListNode) | (Ereditato da TreeList)
Metodo protetto | SelectNodesCore | (Ereditato da TreeList)
Metodo protetto | ServiceColumnChanged | (Ereditato da TreeList)
Metodo pubblico | SetAutoFilterValue | (Ereditato da TreeList)
Metodo protetto | SetCellSelection | (Ereditato da TreeList)
Metodo protetto | SetCellSelectionCore | (Ereditato da TreeList)
Metodo pubblico | SetColumnError(TreeListColumn, String) | (Ereditato da TreeList)
Metodo pubblico | SetColumnError(TreeListColumn, String, ErrorType) | (Ereditato da TreeList)
Metodo protetto | SetColumnFixedStyle | (Ereditato da TreeList)
Metodo pubblico | SetColumnPosition | (Ereditato da TreeList)
Metodo protetto | SetColumnVisibleIndex | (Ereditato da TreeList)
Metodo pubblico | SetDefaultBehaviorOptions | (Ereditato da TreeList)
Metodo pubblico | SetDefaultCustomizationOptions | (Ereditato da TreeList)
Metodo pubblico | SetDefaultNavigationOptions | (Ereditato da TreeList)
Metodo pubblico | SetDefaultOptionsView | (Ereditato da TreeList)
Metodo pubblico | SetDefaultPrintOptions | (Ereditato da TreeList)
Metodo pubblico | SetDefaultRowHeight | (Ereditato da TreeList)
Metodo pubblico | SetDefaultSelectionOptions | (Ereditato da TreeList)
Metodo protetto | SetExtraFilter | (Ereditato da TreeList)
Metodo protetto | SetFilterRowValue(Object, Object) | (Ereditato da TreeList)
Metodo protetto | SetFilterRowValue(TreeListColumn, Object) | (Ereditato da TreeList)
Metodo pubblico | SetFocusedNode | (Ereditato da TreeList)
Metodo protetto | SetFocusedNodeCore | (Ereditato da TreeList)
Metodo pubblico | SetFocusedRowCellValue(String, Object) | (Ereditato da TreeList)
Metodo pubblico | SetFocusedRowCellValue(TreeListColumn, Object) | (Ereditato da TreeList)
Metodo protetto | SetFocusedRowIndexCore | (Ereditato da TreeList)
Metodo pubblico | SetFocusedValue | (Ereditato da TreeList)
Metodo pubblico | SetNodeCheckState(TreeListNode, CheckState) | (Ereditato da TreeList)
Metodo pubblico | SetNodeCheckState(TreeListNode, CheckState, Boolean) | (Ereditato da TreeList)
Metodo pubblico | SetNodeIndex | (Ereditato da TreeList)
Metodo protetto | SetNodeIndexCore | (Ereditato da TreeList)
Metodo protetto | SetNodeValue | (Ereditato da TreeList)
Metodo pubblico | SetRowCellValue(TreeListNode, TreeListColumn, Object) | (Ereditato da TreeList)
Metodo pubblico | SetRowCellValue(TreeListNode, String, Object) | (Ereditato da TreeList)
Metodo pubblico | SetSearchControl | (Ereditato da TreeList)
Metodo pubblico | SetSelectionAnchor | (Ereditato da TreeList)
Metodo protetto | SetUseDirectXPaint | (Ereditato da TreeList)
Metodo protetto | ShouldResortNodesOnItemChanged | (Ereditato da TreeList)
Metodo protetto | ShouldSerializeLookAndFeel | (Ereditato da EditorContainer)
Metodo pubblico | ShowAutoFilterConditionsMenu | (Ereditato da TreeList)
Metodo pubblico | ShowContextMenu | (Ereditato da TreeList)
Metodo pubblico | ShowCustomization | (Ereditato da TreeList)
Metodo pubblico | ShowCustomization(Point) | (Ereditato da TreeList)
Metodo pubblico | ShowEditForm | (Ereditato da TreeList)
Metodo protetto | ShowEditFormCore | (Ereditato da TreeList)
Metodo protetto | ShowEditFormDialogCore | (Ereditato da TreeList)
Metodo pubblico | ShowEditor | (Ereditato da TreeList)
Metodo pubblico | ShowEditor(String) | (Ereditato da TreeList)
Metodo pubblico | ShowFilterEditor | (Ereditato da TreeList)
Metodo protetto | ShowFilterExpressionEditor | (Ereditato da TreeList)
Metodo pubblico | ShowFilterPopup | (Ereditato da TreeList)
Metodo pubblico | ShowFindPanel | (Ereditato da TreeList)
Metodo pubblico | ShowLoadingPanel | (Ereditato da TreeList)
Metodo protetto | ShowMenu | (Ereditato da TreeList)
Metodo protetto | ShowMRUFilterPopup | (Ereditato da TreeList)
Metodo pubblico | ShowPrintPreview | (Ereditato da TreeList)
Metodo protetto | ShowPrintPreviewCore | (Ereditato da TreeList)
Metodo protetto | ShowProgressForm | (Ereditato da TreeList)
Metodo pubblico | ShowRibbonPrintPreview | (Ereditato da TreeList)
Metodo protetto | ShowRibbonPrintPreviewCore | (Ereditato da TreeList)
Metodo pubblico | ShowUnboundExpressionEditor | (Ereditato da TreeList)
Metodo pubblico | Sort(TreeListNode, IComparerTreeListNode, Boolean) | (Ereditato da TreeList)
Metodo protetto | Sort(TreeListNodes, Boolean, Boolean) | (Ereditato da TreeList)
Metodo pubblico | Sort(TreeListNode, TreeListColumn, SortOrder, Boolean) | (Ereditato da TreeList)
Metodo pubblico | StartIncrementalSearch | (Ereditato da TreeList)
Metodo protetto | StartOfficeScrolling | (Ereditato da TreeList)
Metodo pubblico | StopIncrementalSearch | (Ereditato da TreeList)
Metodo protetto | StopOfficeScrolling | (Ereditato da TreeList)
Metodo pubblico | UncheckAll | (Ereditato da TreeList)
Metodo protetto | UnlockDirectXRendering | (Ereditato da TreeList)
Metodo pubblico | UnlockReloadNodes | (Ereditato da TreeList)
Metodo pubblico | UnselectCell | (Ereditato da TreeList)
Metodo protetto | UnselectCellCore | (Ereditato da TreeList)
Metodo pubblico | UnselectCells(Int32, String, Int32, String) | (Ereditato da TreeList)
Metodo pubblico | UnselectCells(TreeListNode, TreeListColumn, TreeListNode, TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | UnselectNode | (Ereditato da TreeList)
Metodo pubblico | UnselectNodes(Int32, Int32) | (Ereditato da TreeList)
Metodo pubblico | UnselectNodes(TreeListNode, TreeListNode) | (Ereditato da TreeList)
Metodo protetto | UpdateActiveFilterInfo | (Ereditato da TreeList)
Metodo protetto | UpdateAutoFilterRowActiveEditor | (Ereditato da TreeList)
Metodo protetto | UpdateBandColumnsIndices | (Ereditato da TreeList)
Metodo protetto | UpdateBandColumnsOrder | (Ereditato da TreeList)
Metodo protetto | UpdateColumnAutoFilter | (Ereditato da TreeList)
Metodo protetto | UpdateColumnsSortIndices | (Ereditato da TreeList)
Metodo protetto | UpdateElementsLookAndFeel | (Ereditato da TreeList)
Metodo protetto | UpdateFilter | (Ereditato da TreeList)
Metodo protetto | UpdateFilterInfo | (Ereditato da TreeList)
Metodo protetto | UpdateFindPanelFilterText | (Ereditato da TreeList)
Metodo protetto | UpdateLayout | (Ereditato da TreeList)
Metodo protetto | UpdateRootBands | (Ereditato da TreeList)
Metodo protetto | UpdateSelectCell | (Ereditato da TreeList)
Metodo protetto | UpdateSelectCell(TreeListNode, TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | UpdateSelectNode | (Ereditato da TreeList)
Metodo protetto | UpdateSelectNode(TreeListNode) | (Ereditato da TreeList)
Metodo protetto | UpdateVScrollBarCore | (Ereditato da TreeList)
Metodo protetto | ValidateAndEndCurrentEdit | (Ereditato da TreeList)
Metodo protetto | WndProc | (Ereditato da TreeList)
Metodo protetto | XtraClearColumns | (Ereditato da TreeList)
Metodo protetto | XtraCreateColumnsItem | (Ereditato da TreeList)
Metodo protetto | XtraFindColumnsItem | (Ereditato da TreeList)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | AfterCheckNode | (Ereditato da TreeList)
Evento pubblico | AfterCollapse | (Ereditato da TreeList)
Evento pubblico | AfterDragNode | (Ereditato da TreeList)
Evento pubblico | AfterDropNode | (Ereditato da TreeList)
Evento pubblico | AfterExpand | (Ereditato da TreeList)
Evento pubblico | AfterFocusNode | (Ereditato da TreeList)
Evento pubblico | BandPositionChanged | (Ereditato da TreeList)
Evento pubblico | BandWidthChanged | (Ereditato da TreeList)
Evento pubblico | BeforeCheckNode | (Ereditato da TreeList)
Evento pubblico | BeforeCollapse | (Ereditato da TreeList)
Evento pubblico | BeforeDragNode | (Ereditato da TreeList)
Evento pubblico | BeforeDropNode | (Ereditato da TreeList)
Evento pubblico | BeforeExpand | (Ereditato da TreeList)
Evento pubblico | BeforeFocusNode | (Ereditato da TreeList)
Evento pubblico | BeforeLoadLayout | (Ereditato da TreeList)
Evento pubblico | CalcNodeDragImageIndex | (Ereditato da TreeList)
Evento pubblico | CalcNodeHeight | (Ereditato da TreeList)
Evento pubblico | CellValueChanged | (Ereditato da TreeList)
Evento pubblico | CellValueChanging | (Ereditato da TreeList)
Evento pubblico | ClipboardNodeCopying | (Ereditato da TreeList)
Evento pubblico | ClipboardNodePasting | (Ereditato da TreeList)
Evento pubblico | ColumnButtonClick | (Ereditato da TreeList)
Evento pubblico | ColumnChanged | (Ereditato da TreeList)
Evento pubblico | ColumnFilterChanged | (Ereditato da TreeList)
Evento pubblico | ColumnPositionChanged | (Ereditato da TreeList)
Evento pubblico | ColumnUnboundExpressionChanged | (Ereditato da TreeList)
Evento pubblico | ColumnWidthChanged | (Ereditato da TreeList)
Evento pubblico | CompareNodeValues | (Ereditato da TreeList)
Evento pubblico | CreateCustomNode | (Ereditato da TreeList)
Evento pubblico | CustomColumnDisplayText | (Ereditato da TreeList)
Evento pubblico | CustomColumnSort | (Ereditato da TreeList)
Evento pubblico | CustomDrawBandHeader | (Ereditato da TreeList)
Evento pubblico | CustomDrawColumnHeader | (Ereditato da TreeList)
Evento pubblico | CustomDrawEmptyArea | (Ereditato da TreeList)
Evento pubblico | CustomDrawFilterPanel | (Ereditato da TreeList)
Evento pubblico | CustomDrawFooter | (Ereditato da TreeList)
Evento pubblico | CustomDrawFooterCell | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodeButton | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodeCell | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodeCheckBox | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodeImages | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodeIndent | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodeIndicator | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodePreview | (Ereditato da TreeList)
Evento pubblico | CustomDrawRow | (Ereditato da TreeList)
Evento pubblico | CustomDrawRowFooter | (Ereditato da TreeList)
Evento pubblico | CustomDrawRowFooterCell | (Ereditato da TreeList)
Evento pubblico | CustomDrawScroll | (Ereditato da TreeList)
Evento pubblico | CustomFilterDisplayText | (Ereditato da TreeList)
Evento pubblico | CustomizationFormSearch | (Ereditato da TreeList)
Evento pubblico | CustomizeNewNodeFromOuterData | (Ereditato da TreeList)
Evento pubblico | CustomizeNodeTemplate | (Ereditato da TreeList)
Evento pubblico | CustomNodeCellEdit | (Ereditato da TreeList)
Evento pubblico | CustomNodeCellEditForEditing | (Ereditato da TreeList)
Evento pubblico | CustomRowFilter | (Ereditato da TreeList)
Evento pubblico | CustomScrollAnnotation | (Ereditato da TreeList)
Evento pubblico | CustomUnboundColumnData | (Ereditato da TreeList)
Evento pubblico | DataSourceChanged | (Ereditato da TreeList)
Evento pubblico | DefaultPaintHelperChanged | (Ereditato da TreeList)
Evento pubblico | DragCancelNode | (Ereditato da TreeList)
Evento pubblico | DragObjectDrop | (Ereditato da TreeList)
Evento pubblico | DragObjectOver | (Ereditato da TreeList)
Evento pubblico | DragObjectStart | (Ereditato da TreeList)
Evento pubblico | EditFormHidden | (Ereditato da TreeList)
Evento pubblico | EditFormPrepared | (Ereditato da TreeList)
Evento pubblico | EditFormShowing | (Ereditato da TreeList)
Evento pubblico | EditorKeyDown | (Ereditato da EditorContainer)
Evento pubblico | EditorKeyPress | (Ereditato da EditorContainer)
Evento pubblico | EditorKeyUp | (Ereditato da EditorContainer)
Evento pubblico | EndSorting | (Ereditato da TreeList)
Evento pubblico | FilterEditorCreated | (Ereditato da TreeList)
Evento pubblico | FilterExpressionEditorCreated | (Ereditato da TreeList)
Evento pubblico | FilterNode | (Ereditato da TreeList)
Evento pubblico | FilterPopupExcelCustomizeTemplate | (Ereditato da TreeList)
Evento pubblico | FilterPopupExcelData | (Ereditato da TreeList)
Evento pubblico | FilterPopupExcelParseFilterCriteria | (Ereditato da TreeList)
Evento pubblico | FilterPopupExcelPrepareTemplate | (Ereditato da TreeList)
Evento pubblico | FilterPopupExcelQueryFilterCriteria | (Ereditato da TreeList)
Evento pubblico | FocusedColumnChanged | (Ereditato da TreeList)
Evento pubblico | FocusedNodeChanged | (Ereditato da TreeList)
Evento pubblico | FormatRuleExpressionEditorCreated | (Ereditato da TreeList)
Evento pubblico | GetCustomNodeCellEdit | Obsoleto. (Ereditato da TreeList)
Evento pubblico | GetCustomNodeCellStyle | Obsoleto. (Ereditato da TreeList)
Evento pubblico | GetCustomSummaryValue | (Ereditato da TreeList)
Evento pubblico | GetNodeDisplayValue | (Ereditato da TreeList)
Evento pubblico | GetPreviewText | (Ereditato da TreeList)
Evento pubblico | GetPrintCustomSummaryValue | (Ereditato da TreeList)
Evento pubblico | GetPrintPreviewText | (Ereditato da TreeList)
Evento pubblico | GetSelectImage | (Ereditato da TreeList)
Evento pubblico | GetStateImage | (Ereditato da TreeList)
Evento pubblico | HiddenEditor | (Ereditato da TreeList)
Evento pubblico | HideCustomizationForm | (Ereditato da TreeList)
Evento pubblico | HtmlElementBlur | (Ereditato da TreeList)
Evento pubblico | HtmlElementFocus | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseClick | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseDoubleClick | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseDown | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseMove | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseOut | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseOver | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseUp | (Ereditato da TreeList)
Evento pubblico | HtmlSelectedTextChanged | (Ereditato da TreeList)
Evento pubblico | HyperlinkClick | (Ereditato da TreeList)
Evento pubblico | InitNewRow | (Ereditato da TreeList)
Evento pubblico | InvalidNodeException | (Ereditato da TreeList)
Evento pubblico | InvalidValueException | (Ereditato da TreeList)
Evento pubblico | LayoutUpdated | (Ereditato da TreeList)
Evento pubblico | LayoutUpgrade | (Ereditato da TreeList)
Evento pubblico | LeftCoordChanged | (Ereditato da TreeList)
Evento pubblico | Load | (Ereditato da TreeList)
Evento pubblico | MeasurePreviewHeight | (Ereditato da TreeList)
Evento pubblico | NodeCellStyle | (Ereditato da TreeList)
Evento pubblico | NodeChanged | (Ereditato da TreeList)
Evento pubblico | NodesReloaded | (Ereditato da TreeList)
Evento pubblico | PaintEx | (Ereditato da TreeList)
Evento pubblico | ParseFindPanelText | (Ereditato da TreeList)
Evento pubblico | PopupMenuShowing | (Ereditato da TreeList)
Evento pubblico | PrintExportProgress | (Ereditato da TreeList)
Evento pubblico | PropertyDeserializing | (Ereditato da TreeList)
Evento pubblico | PropertySerializing | (Ereditato da TreeList)
Evento pubblico | QueryCustomFunctions | (Ereditato da TreeList)
Evento pubblico | QueryEmptyTreeTemplate | (Ereditato da TreeList)
Evento pubblico | QueryNodeTemplate | (Ereditato da TreeList)
Evento pubblico | RowCellClick | (Ereditato da TreeList)
Evento pubblico | RowClick | (Ereditato da TreeList)
Evento pubblico | RowSelectImageClick | (Ereditato da TreeList)
Evento pubblico | RowStateImageClick | (Ereditato da TreeList)
Evento pubblico | ScrollAnnotationsStyle | (Ereditato da TreeList)
Evento pubblico | SelectImageClick | (Ereditato da TreeList)
Evento pubblico | SelectionChanged | (Ereditato da TreeList)
Evento pubblico | SelectionChanging | (Ereditato da TreeList)
Evento pubblico | ShowCustomizationForm | (Ereditato da TreeList)
Evento pubblico | ShowFilterPopupCheckedListBox | (Ereditato da TreeList)
Evento pubblico | ShowFilterPopupDate | (Ereditato da TreeList)
Evento pubblico | ShowFilterPopupExcel | (Ereditato da TreeList)
Evento pubblico | ShowFilterPopupListBox | (Ereditato da TreeList)
Evento pubblico | ShowingEditor | (Ereditato da TreeList)
Evento pubblico | ShownEditor | (Ereditato da TreeList)
Evento pubblico | ShowTreeListMenu | Obsoleto. (Ereditato da TreeList)
Evento pubblico | StartSorting | (Ereditato da TreeList)
Evento pubblico | StateChanged | (Ereditato da TreeList)
Evento pubblico | StateImageClick | (Ereditato da TreeList)
Evento pubblico | SubstituteFilter | (Ereditato da TreeList)
Evento pubblico | TopVisibleNodeIndexChanged | (Ereditato da TreeList)
Evento pubblico | TreeListMenuItemClick | (Ereditato da TreeList)
Evento pubblico | UnboundExpressionEditorCreated | (Ereditato da TreeList)
Evento pubblico | ValidateNode | (Ereditato da TreeList)
Evento pubblico | ValidatingEditor | (Ereditato da TreeList)
Evento pubblico | VirtualTreeGetCellValue | (Ereditato da TreeList)
Evento pubblico | VirtualTreeGetChildNodes | (Ereditato da TreeList)
Evento pubblico | VirtualTreeSetCellValue | (Ereditato da TreeList)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | allowCloseEditor | (Ereditato da TreeList)
Campo protetto | fInitializing | (Ereditato da EditorContainer)
Campo protetto | fUpdateSize | (Ereditato da TreeList)
Campo protetto | SortedColumns | (Ereditato da TreeList)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore MyTreeListRoot
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | MyTreeListRoot |
Metodo protetto | MyTreeListRoot(Object) |
Torna su
Vedi anche

Documentazione

Classe MyTreeListRoot
Namespace DedNet.Controls


Costruttore MyTreeListRoot

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public MyTreeListRoot()
Public Sub New
public:
MyTreeListRoot()
new : unit -> MyTreeListRoot
Vedi anche

Documentazione

Classe MyTreeListRoot
Overload di MyTreeListRoot
Namespace DedNet.Controls


Costruttore MyTreeListRoot(Object)

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected MyTreeListRoot(
    Object ignore
)
Protected Sub New (
    ignore As Object
)
protected:
MyTreeListRoot(
    Object^ ignore
)
new :
        ignore : Object -> MyTreeListRoot

Parametri

ignore Object
Vedi anche

Documentazione

Classe MyTreeListRoot
Overload di MyTreeListRoot
Namespace DedNet.Controls


Proprietà di MyTreeListRoot

Il tipo MyTreeListRoot espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | ActiveEditor | (Ereditato da TreeList)
Proprietà pubblica | ActiveFilter | (Ereditato da TreeList)
Proprietà pubblica | ActiveFilterCriteria | (Ereditato da TreeList)
Proprietà pubblica | ActiveFilterEnabled | (Ereditato da TreeList)
Proprietà pubblica | ActiveFilterInfo | (Ereditato da TreeList)
Proprietà pubblica | ActiveFilterString | (Ereditato da TreeList)
Proprietà protetta | ActualAutoNodeHeight | (Ereditato da TreeList)
Proprietà protetta | ActualFilterCriteria | (Ereditato da TreeList)
Proprietà protetta | ActualShowBands | (Ereditato da TreeList)
Proprietà pubblica | AllNodesCount | (Ereditato da TreeList)
Proprietà protetta | AllowAnimatedScrolling | (Ereditato da TreeList)
Proprietà protetta | AllowAutoFilterConditionChange | (Ereditato da TreeList)
Proprietà protetta | AllowBandColumnsMultiRow | (Ereditato da TreeList)
Proprietà protetta | AllowExpandAnimation | (Ereditato da TreeList)
Proprietà protetta | AllowFiltering | (Ereditato da TreeList)
Proprietà protetta | AllowFilteringAfterLoadingData | (Ereditato da TreeList)
Proprietà protetta | AllowFilterNodes | (Ereditato da TreeList)
Proprietà protetta | AllowFindPanel | (Ereditato da TreeList)
Proprietà protetta | AllowPrintProgress | (Ereditato da TreeList)
Proprietà protetta | AllowScaleOnLoad | (Ereditato da EditorContainer)
Proprietà pubblica | AllowTouchGestures | (Ereditato da EditorContainer)
Proprietà protetta | AllowTouchScroll | (Ereditato da TreeList)
Proprietà protetta | AnnotationManager | (Ereditato da TreeList)
Proprietà pubblica | Appearance | (Ereditato da TreeList)
Proprietà pubblica | AppearancePrint | (Ereditato da TreeList)
Proprietà pubblica | AutoFillColumn | (Ereditato da TreeList)
Proprietà pubblica | AutoFillColumnName | (Ereditato da TreeList)
Proprietà pubblica | AutoFillFieldName | (Ereditato da TreeList)
Proprietà protetta | AutoFilterNode | (Ereditato da TreeList)
Proprietà pubblica | BackColor | (Ereditato da TreeList)
Proprietà pubblica | BandPanelRowHeight | (Ereditato da TreeList)
Proprietà pubblica | Bands | (Ereditato da TreeList)
Proprietà pubblica | BestFitVisibleOnly | (Ereditato da TreeList)
Proprietà pubblica | BorderStyle | (Ereditato da TreeList)
Proprietà protetta | CanExpandNodesOnIncrementalSearch | (Ereditato da TreeList)
Proprietà protetta | CanLoadNodes | (Ereditato da TreeList)
Proprietà protetta | CanShowBandsInCustomizationForm | (Ereditato da TreeList)
Proprietà pubblica | CanShowEditor | (Ereditato da TreeList)
Proprietà pubblica | CanShowRowFooterSummary | (Ereditato da TreeList)
Proprietà pubblica | Caption | (Ereditato da TreeList)
Proprietà pubblica | CaptionHeight | (Ereditato da TreeList)
Proprietà protetta | CheckBoxesStrategy | (Ereditato da TreeList)
Proprietà pubblica | CheckBoxFieldName | (Ereditato da TreeList)
Proprietà pubblica | ChildListFieldName | (Ereditato da TreeList)
Proprietà protetta | ClientHeight | (Ereditato da TreeList)
Proprietà protetta | ClientWidth | (Ereditato da TreeList)
Proprietà pubblica | ClipboardDataProvider | (Ereditato da TreeList)
Proprietà protetta | ClipboardPasteHelper | (Ereditato da TreeList)
Proprietà protetta | ClipboardPasteManager | (Ereditato da TreeList)
Proprietà protetta | CloneInfoList | (Ereditato da TreeList)
Proprietà pubblica | ColumnPanelRowHeight | (Ereditato da TreeList)
Proprietà pubblica | Columns | (Ereditato da TreeList)
Proprietà pubblica | ColumnsImageList | (Ereditato da TreeList)
Proprietà protetta | ContainerHelper | (Ereditato da TreeList)
Proprietà pubblica | ContextMenuStrip | (Ereditato da EditorContainer)
Proprietà protetta | CurrencyManager | (Ereditato da TreeList)
Proprietà pubblica | Cursor | (Ereditato da TreeList)
Proprietà pubblica | CustomizationForm | (Ereditato da TreeList)
Proprietà pubblica | CustomizationFormBounds | (Ereditato da TreeList)
Proprietà pubblica | CustomizationRowCount | Obsoleto. (Ereditato da TreeList)
Proprietà protetta | Data | (Ereditato da TreeList)
Proprietà pubblica | DataMember | (Ereditato da TreeList)
Proprietà pubblica | DataSource | (Ereditato da TreeList)
Proprietà protetta | DefaultSize | (Ereditato da TreeList)
Proprietà protetta | DirectXProvider | (Ereditato da TreeList)
Proprietà protetta | DirectXScroller | (Ereditato da TreeList)
Proprietà pubblica | DragExpandDelay | Obsoleto. (Ereditato da TreeList)
Proprietà pubblica | DragNodesMode | Obsoleto. (Ereditato da TreeList)
Proprietà protetta | DXAccessible | (Ereditato da TreeList)
Proprietà protetta | Editable | (Ereditato da TreeList)
Proprietà protetta | EditFormController | (Ereditato da TreeList)
Proprietà pubblica | EditingValue | (Ereditato da TreeList)
Proprietà protetta | EditorHelper | (Ereditato da EditorContainer)
Proprietà protetta | ElementsLookAndFeel | (Ereditato da TreeList)
Proprietà pubblica | EmptyTreeHtmlTemplate | (Ereditato da TreeList)
Proprietà protetta | EnableDirectXPaint | (Ereditato da TreeList)
Proprietà pubblica | EnableDynamicLoading | (Ereditato da TreeList)
Proprietà pubblica | EnableEnhancedScrolling | (Ereditato da TreeList)
Proprietà protetta | EnableEnhancedSorting | (Ereditato da TreeList)
Proprietà protetta | EnableFirstPaintTrigger | (Ereditato da EditorContainer)
Proprietà pubblica | EnableImprovedColumnSizing | (Ereditato da TreeList)
Proprietà protetta | ErrorInfo | (Ereditato da TreeList)
Proprietà protetta | ExcelFilteringProvider | (Ereditato da TreeList)
Proprietà protetta | ExceptionThrown | (Ereditato da TreeList)
Proprietà pubblica | ExternalRepository | (Ereditato da EditorContainer)
Proprietà protetta | ExtraFilter | (Ereditato da TreeList)
Proprietà protetta | ExtraFilterCriteria | (Ereditato da TreeList)
Proprietà protetta | ExtraFilterHightlightText | (Ereditato da TreeList)
Proprietà protetta | FilterColumnsProvider | (Ereditato da TreeList)
Proprietà protetta | FilterHelper | (Ereditato da TreeList)
Proprietà protetta | FilteringService | (Ereditato da TreeList)
Proprietà pubblica | FilterPanelText | (Ereditato da TreeList)
Proprietà protetta | FilterPopup | (Ereditato da TreeList)
Proprietà protetta | FindFilterCriteria | (Ereditato da TreeList)
Proprietà pubblica | FindFilterText | (Ereditato da TreeList)
Proprietà protetta | FindPanel | (Ereditato da TreeList)
Proprietà pubblica | FindPanelVisible | (Ereditato da TreeList)
Proprietà protetta | FireOnLoadOnPaint | (Ereditato da TreeList)
Proprietà pubblica | FixedLineWidth | (Ereditato da TreeList)
Proprietà protetta | FocusedCellIndex | (Ereditato da TreeList)
Proprietà pubblica | FocusedColumn | (Ereditato da TreeList)
Proprietà pubblica | FocusedNode | (Ereditato da TreeList)
Proprietà protetta | FocusedRow | (Ereditato da TreeList)
Proprietà protetta | FocusedRowIndex | (Ereditato da TreeList)
Proprietà pubblica | FocusedValue | (Ereditato da TreeList)
Proprietà pubblica | FooterPanelHeight | (Ereditato da TreeList)
Proprietà protetta | ForceLoadingPanel | (Ereditato da TreeList)
Proprietà pubblica | ForeColor | (Ereditato da EditorContainer)
Proprietà pubblica | FormatConditions | (Ereditato da TreeList)
Proprietà pubblica | FormatRules | (Ereditato da TreeList)
Proprietà pubblica | GroupButtonSize | Obsoleto. (Ereditato da TreeList)
Proprietà protetta | Handler | (Ereditato da TreeList)
Proprietà protetta | HasAccessible | (Ereditato da TreeList)
Proprietà protetta | HasAllColumnsFixedRight | (Ereditato da TreeList)
Proprietà protetta | HasBands | (Ereditato da TreeList)
Proprietà pubblica | HasColumnErrors | (Ereditato da TreeList)
Proprietà protetta | HasCustomNodeCellEdit | (Ereditato da TreeList)
Proprietà pubblica | HasFocus | (Ereditato da TreeList)
Proprietà protetta | HasHierarchicalColumn | (Ereditato da TreeList)
Proprietà protetta | HasTreeViewColumn | (Ereditato da TreeList)
Proprietà protetta | HeaderLayoutCalculator | (Ereditato da TreeList)
Proprietà protetta | HeaderWidthCalculator | (Ereditato da TreeList)
Proprietà pubblica | HierarchyColumn | (Ereditato da TreeList)
Proprietà pubblica | HierarchyColumnIndent | (Ereditato da TreeList)
Proprietà pubblica | HierarchyColumnName | (Ereditato da TreeList)
Proprietà pubblica | HierarchyFieldName | (Ereditato da TreeList)
Proprietà pubblica | HorzScrollStep | (Ereditato da TreeList)
Proprietà pubblica | HorzScrollVisibility | (Ereditato da TreeList)
Proprietà protetta | HtmlContext | (Ereditato da TreeList)
Proprietà pubblica | HtmlImages | (Ereditato da TreeList)
Proprietà protetta | HtmlObjectCache | (Ereditato da TreeList)
Proprietà pubblica | HtmlTemplates | (Ereditato da TreeList)
Proprietà protetta | IBasePrintableCreatesIntersectedBricks | (Ereditato da TreeList)
Proprietà pubblica | ImageIndexFieldName | (Ereditato da TreeList)
Proprietà protetta | IncrementalText | (Ereditato da TreeList)
Proprietà pubblica | IndicatorWidth | (Ereditato da TreeList)
Proprietà protetta | IsAllowBusyIndicator | (Ereditato da TreeList)
Proprietà protetta | IsAllowBusyPanel | (Ereditato da TreeList)
Proprietà protetta | IsAlt | (Ereditato da TreeList)
Proprietà protetta | IsAttachedToSearchControl | (Ereditato da TreeList)
Proprietà protetta | IsAutoWidth | (Ereditato da TreeList)
Proprietà protetta | IsCellSelect | (Ereditato da TreeList)
Proprietà protetta | IsClosingEditor | (Ereditato da TreeList)
Proprietà protetta | IsColumnHeaderAutoHeight | (Ereditato da TreeList)
Proprietà protetta | IsControl | (Ereditato da TreeList)
Proprietà protetta | IsDataReady | (Ereditato da TreeList)
Proprietà protetta | IsDeserializing | (Ereditato da TreeList)
Proprietà pubblica | IsDesignMode | (Ereditato da EditorContainer)
Proprietà protetta | IsDynamicLoadingAllowed | (Ereditato da TreeList)
Proprietà protetta | IsEditFormMode | (Ereditato da TreeList)
Proprietà protetta | IsFilterPopupActive | (Ereditato da TreeList)
Proprietà protetta | IsFindFilterActive | (Ereditato da TreeList)
Proprietà pubblica | IsFindPanelVisible | (Ereditato da TreeList)
Proprietà protetta | IsFocusedNodeChangedLocked | (Ereditato da TreeList)
Proprietà protetta | IsFocusedNodeDataModified | (Ereditato da TreeList)
Proprietà protetta | IsGroupDeleteOperation | (Ereditato da TreeList)
Proprietà protetta | IsHScrollBarVisible | (Ereditato da TreeList)
Proprietà protetta | IsInitialized | (Ereditato da EditorContainer)
Proprietà protetta | IsIniting | (Ereditato da TreeList)
Proprietà pubblica | IsLoading | (Ereditato da EditorContainer)
Proprietà protetta | IsLockDirectXRendering | (Ereditato da TreeList)
Proprietà protetta | IsLockExpandCollapse | (Ereditato da TreeList)
Proprietà protetta | IsLockUpdate | (Ereditato da TreeList)
Proprietà pubblica | IsLookUpMode | (Ereditato da TreeList)
Proprietà protetta | IsMultiSelect | (Ereditato da TreeList)
Proprietà protetta | IsNotificationInfoVisible | (Ereditato da TreeList)
Proprietà protetta | IsPainting | (Ereditato da TreeList)
Proprietà protetta | IsPixelScrolling | (Ereditato da TreeList)
Proprietà protetta | IsPopupEditFormVisible | (Ereditato da TreeList)
Proprietà pubblica | IsPrinting | (Ereditato da TreeList)
Proprietà pubblica | IsPrintingAvailable | (Ereditato da TreeList)
Proprietà protetta | IsRightToLeft | (Ereditato da TreeList)
Proprietà protetta | IsRowCountReady | (Ereditato da TreeList)
Proprietà protetta | IsScrollAnimationInProgress | (Ereditato da TreeList)
Proprietà protetta | IsSearchMode | (Ereditato da TreeList)
Proprietà protetta | IsSerializing | (Ereditato da TreeList)
Proprietà protetta | IsShift | (Ereditato da TreeList)
Proprietà protetta | IsSorted | (Ereditato da TreeList)
Proprietà protetta | IsUnboundLoad | (Ereditato da TreeList)
Proprietà pubblica | IsUnboundMode | (Ereditato da TreeList)
Proprietà protetta | IsUpdateSize | (Ereditato da TreeList)
Proprietà protetta | IsVirtualMode | (Ereditato da TreeList)
Proprietà protetta | IsVScrollBarVisible | (Ereditato da TreeList)
Proprietà pubblica | KeyFieldName | (Ereditato da TreeList)
Proprietà pubblica | LayoutVersion | Obsoleto. (Ereditato da TreeList)
Proprietà pubblica | LeftCoord | (Ereditato da TreeList)
Proprietà pubblica | LoadingPanelVisible | (Ereditato da TreeList)
Proprietà pubblica | LookAndFeel | (Ereditato da EditorContainer)
Proprietà protetta | LookAndFeelIgnoreChildren | (Ereditato da EditorContainer)
Proprietà protetta | LookUpDisplayColumn | (Ereditato da TreeList)
Proprietà protetta | LookUpOwner | (Ereditato da TreeList)
Proprietà pubblica | MenuManager | (Ereditato da EditorContainer)
Proprietà protetta | MinRowHeight | (Ereditato da TreeList)
Proprietà pubblica | MinWidth | (Ereditato da TreeList)
Proprietà protetta | MRUFilterPopup | (Ereditato da TreeList)
Proprietà pubblica | MRUFilters | (Ereditato da TreeList)
Proprietà protetta | NewItemNode | (Ereditato da TreeList)
Proprietà pubblica | NewItemRowText | (Ereditato da TreeList)
Proprietà pubblica | NodeHtmlTemplate | (Ereditato da TreeList)
Proprietà pubblica | Nodes | (Ereditato da TreeList)
Proprietà pubblica | NodesIterator | (Ereditato da TreeList)
Proprietà pubblica | NonColumnFilterCriteria | (Ereditato da TreeList)
Proprietà pubblica | NonColumnFilterString | (Ereditato da TreeList)
Proprietà protetta | NotificationInfo | (Ereditato da TreeList)
Proprietà protetta | OfficeScroller | (Ereditato da TreeList)
Proprietà pubblica | OptionsBehavior | (Ereditato da TreeList)
Proprietà pubblica | OptionsClipboard | (Ereditato da TreeList)
Proprietà pubblica | OptionsCustomization | (Ereditato da TreeList)
Proprietà pubblica | OptionsDragAndDrop | (Ereditato da TreeList)
Proprietà pubblica | OptionsEditForm | (Ereditato da TreeList)
Proprietà pubblica | OptionsFilter | (Ereditato da TreeList)
Proprietà pubblica | OptionsFind | (Ereditato da TreeList)
Proprietà pubblica | OptionsHtmlTemplate | (Ereditato da TreeList)
Proprietà pubblica | OptionsLayout | (Ereditato da TreeList)
Proprietà pubblica | OptionsMenu | (Ereditato da TreeList)
Proprietà pubblica | OptionsNavigation | (Ereditato da TreeList)
Proprietà pubblica | OptionsPrint | (Ereditato da TreeList)
Proprietà pubblica | OptionsScrollAnnotations | (Ereditato da TreeList)
Proprietà pubblica | OptionsSelection | (Ereditato da TreeList)
Proprietà pubblica | OptionsView | (Ereditato da TreeList)
Proprietà pubblica | Painter | (Ereditato da TreeList)
Proprietà pubblica | ParentFieldName | (Ereditato da TreeList)
Proprietà protetta | Position | (Ereditato da TreeList)
Proprietà protetta | PressedBand | (Ereditato da TreeList)
Proprietà protetta | PressedColumn | (Ereditato da TreeList)
Proprietà protetta | PressedNode | (Ereditato da TreeList)
Proprietà pubblica | PreviewFieldName | (Ereditato da TreeList)
Proprietà pubblica | PreviewIndent | (Ereditato da TreeList)
Proprietà pubblica | PreviewLineCount | (Ereditato da TreeList)
Proprietà protetta | Printer | (Ereditato da TreeList)
Proprietà protetta | PrinterCore | (Ereditato da TreeList)
Proprietà protetta | ProgressWindow | (Ereditato da TreeList)
Proprietà pubblica | RepositoryItems | (Ereditato da EditorContainer)
Proprietà pubblica | RootValue | (Ereditato da TreeList)
Proprietà protetta | RowCount | (Ereditato da TreeList)
Proprietà pubblica | RowHeight | (Ereditato da TreeList)
Proprietà protetta | ScaleDPI | (Ereditato da EditorContainer)
Proprietà pubblica | ScaleFactor | (Ereditato da EditorContainer)
Proprietà protetta | ScaleHelper | (Ereditato da EditorContainer)
Proprietà protetta | ScrollInfo | (Ereditato da TreeList)
Proprietà pubblica | SelectedHtmlText | (Ereditato da TreeList)
Proprietà pubblica | SelectImageList | (Ereditato da TreeList)
Proprietà pubblica | Selection | (Ereditato da TreeList)
Proprietà protetta | SelectionRange | (Ereditato da TreeList)
Proprietà pubblica | ShowButtonMode | (Ereditato da TreeList)
Proprietà protetta | ShowEditorAfterAnimatedScroll | (Ereditato da TreeList)
Proprietà protetta | ShowPreview | (Ereditato da TreeList)
Proprietà protetta | SizedBand | (Ereditato da TreeList)
Proprietà protetta | SizedColumn | (Ereditato da TreeList)
Proprietà protetta | SmartVisibility | (Ereditato da TreeList)
Proprietà pubblica | SortedColumnCount | (Ereditato da TreeList)
Proprietà pubblica | State | (Ereditato da TreeList)
Proprietà pubblica | StateImageList | (Ereditato da TreeList)
Proprietà pubblica | SyncCheckStateWithSourceOnChecking | (Ereditato da TreeList)
Proprietà pubblica | Text | (Ereditato da EditorContainer)
Proprietà pubblica | ToolTipController | (Ereditato da EditorContainer)
Proprietà protetta | TopVisibleNode | (Ereditato da TreeList)
Proprietà pubblica | TopVisibleNodeIndex | (Ereditato da TreeList)
Proprietà pubblica | TopVisibleNodePixel | (Ereditato da TreeList)
Proprietà pubblica | TreeLevelWidth | (Ereditato da TreeList)
Proprietà pubblica | TreeLineStyle | (Ereditato da TreeList)
Proprietà pubblica | TreeListDisposing | (Ereditato da TreeList)
Proprietà pubblica | TreeViewColumn | (Ereditato da TreeList)
Proprietà pubblica | TreeViewColumnName | (Ereditato da TreeList)
Proprietà pubblica | TreeViewFieldName | (Ereditato da TreeList)
Proprietà pubblica | UpdateTopVisibleNodeIndexOnCollapse | (Ereditato da TreeList)
Proprietà protetta | UseBandsAdvancedHorizontalNavigation | (Ereditato da TreeList)
Proprietà protetta | UseBandsAdvancedVerticalNavigation | (Ereditato da TreeList)
Proprietà pubblica | UseDirectXPaint | (Ereditato da TreeList)
Proprietà pubblica | UseDisabledStatePainter | (Ereditato da TreeList)
Proprietà protetta | UseStandardFilter | (Ereditato da TreeList)
Proprietà pubblica | VertScrollVisibility | (Ereditato da TreeList)
Proprietà pubblica | ViewInfo | (Ereditato da TreeList)
Proprietà pubblica | ViewStyle | (Ereditato da TreeList)
Proprietà protetta | VirtualDataHelper | (Ereditato da TreeList)
Proprietà pubblica | VisibleColumnCount | Obsoleto. (Ereditato da TreeList)
Proprietà pubblica | VisibleColumns | (Ereditato da TreeList)
Proprietà pubblica | VisibleNodesCount | (Ereditato da TreeList)
Proprietà protetta | WorkAsLookup | (Ereditato da TreeList)
Torna su
Vedi anche

Documentazione

Classe MyTreeListRoot
Namespace DedNet.Controls


Metodi di MyTreeListRoot

Il tipo MyTreeListRoot espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AccessibleNotifyClients(AccessibleEvents, BaseAccessible) | (Ereditato da TreeList)
Metodo pubblico | AccessibleNotifyClients(AccessibleEvents, Int32, Int32) | (Ereditato da TreeList)
Metodo pubblico | AddFilter(CriteriaOperator) | (Ereditato da TreeList)
Metodo pubblico | AddFilter(String) | (Ereditato da TreeList)
Metodo protetto | AddToDefaultTooltipController | (Ereditato da EditorContainer)
Metodo protetto | AllowAutoFilterCondition | (Ereditato da TreeList)
Metodo protetto | AnimateKeyboardNavigation | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, TreeListNode) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, TreeListNode, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, TreeListNode, CheckState) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, CheckState) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, TreeListNode, CheckState, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, CheckState, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, TreeListNode, CheckState, NodeCheckBoxStyle, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, Int32, Int32, Int32) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, Int32, Int32, Int32, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, Int32, Int32, Int32, CheckState) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, Int32, Int32, Int32, CheckState, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, Int32, Int32, Int32, CheckState, NodeCheckBoxStyle, Object) | (Ereditato da TreeList)
Metodo protetto | ApplyFilter | (Ereditato da TreeList)
Metodo pubblico | ApplyFindFilter | (Ereditato da TreeList)
Metodo protetto | BeforeShowEditForm | (Ereditato da TreeList)
Metodo pubblico | BeginDelete | (Ereditato da TreeList)
Metodo protetto | BeginDragDrop | (Ereditato da TreeList)
Metodo protetto | BeginExpandCollapse | (Ereditato da TreeList)
Metodo pubblico | BeginInit | (Ereditato da EditorContainer)
Metodo protetto | BeginLockListChanged | (Ereditato da TreeList)
Metodo pubblico | BeginSelection | (Ereditato da TreeList)
Metodo pubblico | BeginSort | (Ereditato da TreeList)
Metodo pubblico | BeginUnboundLoad | (Ereditato da TreeList)
Metodo pubblico | BeginUpdate | (Ereditato da TreeList)
Metodo pubblico | BestFitColumns | (Ereditato da TreeList)
Metodo pubblico | BestFitColumns(Boolean) | (Ereditato da TreeList)
Metodo pubblico | BindCommand(Object, String, FuncObject) | (Ereditato da TreeList)
Metodo pubblico | BindCommand(ExpressionAction, Object, String, FuncObject) | (Ereditato da TreeList)
Metodo pubblico | BindCommand``1(ExpressionActionUMP, Object, String, FuncUMP) | (Ereditato da TreeList)
Metodo protetto | CalcActiveEditorBounds | (Ereditato da TreeList)
Metodo protetto | CalcColumnBestWidth | (Ereditato da TreeList)
Metodo pubblico | CalcHitInfo | (Ereditato da TreeList)
Metodo protetto | CalcHScrollRange | (Ereditato da TreeList)
Metodo protetto | CalcNodeAutoHeight | (Ereditato da TreeList)
Metodo protetto | CalcRowCount | (Ereditato da TreeList)
Metodo protetto | CalcScrollClientRect | (Ereditato da TreeList)
Metodo protetto | CalculateScrollBars | (Ereditato da TreeList)
Metodo protetto | CalculateVisibleRowsAreaHeight | (Ereditato da TreeList)
Metodo pubblico | CancelCurrentEdit | (Ereditato da TreeList)
Metodo protetto | CancelDirectXRendering | (Ereditato da TreeList)
Metodo protetto | CancelLockListChanged | (Ereditato da TreeList)
Metodo protetto | CancelSelection | (Ereditato da TreeList)
Metodo pubblico | CancelSort | (Ereditato da TreeList)
Metodo pubblico | CancelUpdate | (Ereditato da TreeList)
Metodo protetto | CanClearAllSorting | (Ereditato da TreeList)
Metodo protetto | CanCloneChildren | (Ereditato da TreeList)
Metodo protetto | CanFilterByColumnEdit | (Ereditato da TreeList)
Metodo pubblico | CanFilterColumn | (Ereditato da TreeList)
Metodo protetto | CanFindColumn | (Ereditato da TreeList)
Metodo protetto | CanFocusNode | (Ereditato da TreeList)
Metodo protetto | CanHandleTouchGestures | (Ereditato da EditorContainer)
Metodo protetto | CanIncrementalSearch | (Ereditato da TreeList)
Metodo pubblico | CanIndentNodes | (Ereditato da TreeList)
Metodo protetto | CanMove | (Ereditato da TreeList)
Metodo protetto | CanMoveBand | (Ereditato da TreeList)
Metodo protetto | CanMoveColumn | (Ereditato da TreeList)
Metodo pubblico | CanOutdentNodes | (Ereditato da TreeList)
Metodo protetto | CanResizeBand | (Ereditato da TreeList)
Metodo protetto | CanResizeColumn | (Ereditato da TreeList)
Metodo protetto | CanShowHScrollBar | (Ereditato da TreeList)
Metodo protetto | CanShowHScrollBarCore | (Ereditato da TreeList)
Metodo protetto | CanShowVScrollBar | (Ereditato da TreeList)
Metodo protetto | CanSortByColumnEdit | (Ereditato da TreeList)
Metodo pubblico | CanSortColumn | (Ereditato da TreeList)
Metodo protetto | CanStartTouchScrolling | (Ereditato da TreeList)
Metodo protetto | ChangeLeftCoord | (Ereditato da TreeList)
Metodo pubblico | CheckAll | (Ereditato da TreeList)
Metodo protetto | CheckAllowGestures | (Ereditato da TreeList)
Metodo protetto | CheckAllowNotifications | (Ereditato da TreeList)
Metodo protetto | CheckData | (Ereditato da TreeList)
Metodo protetto | CheckIncreaseVisibleRows | (Ereditato da TreeList)
Metodo protetto | CheckModifierKeys | (Ereditato da TreeList)
Metodo protetto | CheckNeedScale | (Ereditato da EditorContainer)
Metodo protetto | CheckRightToLeft | (Ereditato da EditorContainer)
Metodo protetto | CheckSearchMode | (Ereditato da TreeList)
Metodo protetto | CheckTopVisibleNodeAfterItemAdded | (Ereditato da TreeList)
Metodo protetto | CheckTopVisibleNodePixelValue | (Ereditato da TreeList)
Metodo pubblico | ClearColumnErrors | (Ereditato da TreeList)
Metodo pubblico | ClearColumnFilter | (Ereditato da TreeList)
Metodo protetto | ClearColumnFilterCore(String) | (Ereditato da TreeList)
Metodo protetto | ClearColumnFilterCore(TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | ClearColumnsFilter | (Ereditato da TreeList)
Metodo pubblico | ClearDocument | (Ereditato da TreeList)
Metodo pubblico | ClearFindFilter | (Ereditato da TreeList)
Metodo pubblico | ClearFocusedColumn | (Ereditato da TreeList)
Metodo pubblico | ClearNodes | (Ereditato da TreeList)
Metodo pubblico | ClearSelection | (Ereditato da TreeList)
Metodo pubblico | ClearSorting | (Ereditato da TreeList)
Metodo protetto | ClearVisibleIndicesCache | (Ereditato da TreeList)
Metodo pubblico | CloseEditForm | (Ereditato da TreeList)
Metodo pubblico | CloseEditor | (Ereditato da TreeList)
Metodo protetto | CloseEditor(Boolean) | (Ereditato da TreeList)
Metodo pubblico | CollapseAll | (Ereditato da TreeList)
Metodo protetto | CollapseAllCore | (Ereditato da TreeList)
Metodo pubblico | CollapseToLevel | (Ereditato da TreeList)
Metodo pubblico | ColumnsCustomization | (Ereditato da TreeList)
Metodo pubblico | ColumnsCustomization(Point) | (Ereditato da TreeList)
Metodo protetto | ControlRowSourceSelectedChanged | (Ereditato da TreeList)
Metodo protetto | ControlRowSourceVisibleChanged | (Ereditato da TreeList)
Metodo pubblico | ConvertFormatConditionToFormatRules | (Ereditato da TreeList)
Metodo pubblico | CopyNode(TreeListNode, TreeListNode, Boolean) | (Ereditato da TreeList)
Metodo pubblico | CopyNode(TreeListNode, TreeListNode, Boolean, Boolean) | (Ereditato da TreeList)
Metodo pubblico | CopyNode(TreeListNode, TreeListNode, Boolean, Int32) | (Ereditato da TreeList)
Metodo pubblico | CopyNode(TreeListNode, TreeListNode, Boolean, Boolean, Int32) | (Ereditato da TreeList)
Metodo protetto | CopyNodeCore | (Ereditato da TreeList)
Metodo pubblico | CopyNodes(IEnumerableTreeListNode, TreeListNode, Boolean, Int32) | (Ereditato da TreeList)
Metodo pubblico | CopyNodes(IEnumerableTreeListNode, TreeListNode, Boolean, Boolean, Int32) | (Ereditato da TreeList)
Metodo pubblico | CopyToClipboard | (Ereditato da TreeList)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da TreeList)
Metodo protetto | CreateAccessibleDataRow | (Ereditato da TreeList)
Metodo protetto | CreateAccessibleInstance | (Ereditato da TreeList)
Metodo protetto | CreateAllOptions | (Ereditato da TreeList)
Metodo protetto | CreateAnnotationManager | (Ereditato da TreeList)
Metodo protetto | CreateAppearances | (Ereditato da TreeList)
Metodo protetto | CreateAutoFilterCriterion | (Ereditato da TreeList)
Metodo protetto | CreateBands | (Ereditato da TreeList)
Metodo protetto | CreateCheckBoxesStrategy | (Ereditato da TreeList)
Metodo protetto | CreateCheckedListFilterPopup | (Ereditato da TreeList)
Metodo protetto | CreateColumn | (Ereditato da TreeList)
Metodo protetto | CreateColumnEditViewInfo | (Ereditato da TreeList)
Metodo protetto | CreateColumnFilterCriteriaByValue(TreeListColumn, Object) | (Ereditato da TreeList)
Metodo protetto | CreateColumnFilterCriteriaByValue(TreeListColumn, Object, Boolean) | (Ereditato da TreeList)
Metodo protetto | CreateColumnFilterPopup | (Ereditato da TreeList)
Metodo protetto | CreateColumns | (Ereditato da TreeList)
Metodo pubblico | CreateCustomization | Obsoleto. (Ereditato da TreeList)
Metodo protetto | CreateCustomizationForm | (Ereditato da TreeList)
Metodo protetto | CreateData | (Ereditato da TreeList)
Metodo protetto | CreateDataViewData | (Ereditato da TreeList)
Metodo protetto | CreateDateFilterPopup | (Ereditato da TreeList)
Metodo protetto | CreateDragNodesProvider | (Ereditato da TreeList)
Metodo protetto | CreateEditFormController | (Ereditato da TreeList)
Metodo protetto | CreateElementsLookAndFeel | (Ereditato da TreeList)
Metodo protetto | CreateExcelFilterPopup | (Ereditato da TreeList)
Metodo protetto | CreateFilterColumnCollection | (Ereditato da TreeList)
Metodo protetto | CreateFilterColumnRuleCollection | (Ereditato da TreeList)
Metodo protetto | CreateFilterColumnsProvider | (Ereditato da TreeList)
Metodo protetto | CreateFilterCriteriaBindingTarget | (Ereditato da TreeList)
Metodo protetto | CreateFilterEditorForm | (Ereditato da TreeList)
Metodo protetto | CreateFilterHelper | (Ereditato da TreeList)
Metodo protetto | CreateFindPanel | (Ereditato da TreeList)
Metodo protetto | CreateFindPanelCore | (Ereditato da TreeList)
Metodo pubblico | CreateGraphicsCache | (Ereditato da TreeList)
Metodo protetto | CreateHandler | (Ereditato da TreeList)
Metodo protetto | CreateHeaderLayoutCalculator | (Ereditato da TreeList)
Metodo protetto | CreateHeaderWidthCalculator | (Ereditato da TreeList)
Metodo protetto | CreateHelper | (Ereditato da TreeList)
Metodo protetto | CreateHierarchicalListData | (Ereditato da TreeList)
Metodo protetto | CreateHtmlContext | (Ereditato da TreeList)
Metodo protetto | CreateHyperlinkClickEventArgs | (Ereditato da TreeList)
Metodo protetto | CreateInternalRepository | (Ereditato da EditorContainer)
Metodo protetto | CreateListColumnFilterPopup | (Ereditato da TreeList)
Metodo protetto | CreateListData | (Ereditato da TreeList)
Metodo protetto | CreateLoadingAnimator | (Ereditato da TreeList)
Metodo protetto | CreateLoadingPanel | (Ereditato da TreeList)
Metodo protetto | CreateLookAndFeel | (Ereditato da EditorContainer)
Metodo protetto | CreateNewItemNode | (Ereditato da TreeList)
Metodo protetto | CreateNode(Int32, TreeListNodes) | (Ereditato da TreeList)
Metodo protetto | CreateNode(Int32, TreeListNodes, Object) | (Ereditato da TreeList)
Metodo protetto | CreateNodes | (Ereditato da TreeList)
Metodo protetto | CreateNodesComparer | (Ereditato da TreeList)
Metodo protetto | CreateNodesIterator | (Ereditato da TreeList)
Metodo protetto | CreateNotificationInfo | (Ereditato da TreeList)
Metodo protetto | CreateOfficeScroller | (Ereditato da TreeList)
Metodo protetto | CreateOptionsBehavior | (Ereditato da TreeList)
Metodo protetto | CreateOptionsClipboard | (Ereditato da TreeList)
Metodo protetto | CreateOptionsCustomization | (Ereditato da TreeList)
Metodo protetto | CreateOptionsDragAndDrop | (Ereditato da TreeList)
Metodo protetto | CreateOptionsEditForm | (Ereditato da TreeList)
Metodo protetto | CreateOptionsFilter | (Ereditato da TreeList)
Metodo protetto | CreateOptionsFind | (Ereditato da TreeList)
Metodo protetto | CreateOptionsHtmlTemplate | (Ereditato da TreeList)
Metodo protetto | CreateOptionsLayout | (Ereditato da TreeList)
Metodo protetto | CreateOptionsMenu | (Ereditato da TreeList)
Metodo protetto | CreateOptionsNavigation | (Ereditato da TreeList)
Metodo protetto | CreateOptionsPrint | (Ereditato da TreeList)
Metodo protetto | CreateOptionsScrollAnnotations | (Ereditato da TreeList)
Metodo protetto | CreateOptionsSelection | (Ereditato da TreeList)
Metodo protetto | CreateOptionsView | (Ereditato da TreeList)
Metodo protetto | CreatePainter | (Ereditato da TreeList)
Metodo protetto | CreatePrinter | (Ereditato da TreeList)
Metodo protetto | CreateProvider | (Ereditato da TreeList)
Metodo protetto | CreateScrollInfo | (Ereditato da TreeList)
Metodo protetto | CreateSelection | (Ereditato da TreeList)
Metodo protetto | CreateUnboundData | (Ereditato da TreeList)
Metodo protetto | CreateViewInfo | (Ereditato da TreeList)
Metodo protetto | CreateVirtualData | (Ereditato da TreeList)
Metodo protetto | CreateVirtualDataHelper | (Ereditato da TreeList)
Metodo protetto | CurrencyManager_ItemChanged | (Ereditato da TreeList)
Metodo protetto | CurrencyManager_PositionChanged | (Ereditato da TreeList)
Metodo protetto | DeferredLoadChildren | (Ereditato da TreeList)
Metodo protetto | DelayedInvalidate | (Ereditato da TreeList)
Metodo pubblico | DeleteNode | (Ereditato da TreeList)
Metodo pubblico | DeleteNodes | (Ereditato da TreeList)
Metodo pubblico | DeleteSelectedNodes | (Ereditato da TreeList)
Metodo pubblico | DestroyCustomization | (Ereditato da TreeList)
Metodo protetto | DestroyDirectXProvider | (Ereditato da EditorContainer)
Metodo protetto | DestroyFindPanel | (Ereditato da TreeList)
Metodo protetto | Dispose | (Ereditato da TreeList)
Metodo protetto | DoDataSourceChanged | (Ereditato da TreeList)
Metodo protetto | DoDpiChange | (Ereditato da EditorContainer)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da TreeList)
Metodo protetto | DoDragDrop | (Ereditato da TreeList)
Metodo pubblico | DoDragDropNode | (Ereditato da TreeList)
Metodo pubblico | DoDragDropNodes | (Ereditato da TreeList)
Metodo protetto | DoFilterNode | (Ereditato da TreeList)
Metodo protetto | DoForEachBand | (Ereditato da TreeList)
Metodo pubblico | DoIncrementalSearch | (Ereditato da TreeList)
Metodo protetto | DoShowTreeListMenu(TreeListMenu, TreeListHitTest) | (Ereditato da TreeList)
Metodo protetto | DoShowTreeListMenu(TreeListMenu, Control, Point) | (Ereditato da TreeList)
Metodo protetto | DoTopVisibleNodeChanged | (Ereditato da TreeList)
Metodo pubblico | EndCurrentEdit | (Ereditato da TreeList)
Metodo pubblico | EndCurrentEdit(Boolean) | (Ereditato da TreeList)
Metodo pubblico | EndDelete | (Ereditato da TreeList)
Metodo protetto | EndDragDrop | (Ereditato da TreeList)
Metodo protetto | EndEdit | (Ereditato da TreeList)
Metodo protetto | EndExpandCollapse | (Ereditato da TreeList)
Metodo pubblico | EndInit | (Ereditato da EditorContainer)
Metodo pubblico | EndSelection | (Ereditato da TreeList)
Metodo pubblico | EndSort | (Ereditato da TreeList)
Metodo pubblico | EndUnboundLoad | (Ereditato da TreeList)
Metodo pubblico | EndUpdate | (Ereditato da TreeList)
Metodo protetto | EnsureControlRowSource | (Ereditato da TreeList)
Metodo protetto | EnsureEditFormController | (Ereditato da TreeList)
Metodo protetto | EnsureFilteringClientDataBinding | (Ereditato da TreeList)
Metodo protetto | ExecutePrinterAction | (Ereditato da TreeList)
Metodo pubblico | ExpandAll | (Ereditato da TreeList)
Metodo protetto | ExpandAllCore | (Ereditato da TreeList)
Metodo protetto | ExpandToLast | (Ereditato da TreeList)
Metodo pubblico | ExpandToLevel | (Ereditato da TreeList)
Metodo protetto | ExpandToRoot | (Ereditato da TreeList)
Metodo protetto | Export(ExportTarget, Stream) | (Ereditato da TreeList)
Metodo protetto | Export(ExportTarget, String) | (Ereditato da TreeList)
Metodo protetto | Export(ExportTarget, Stream, ExportOptionsBase) | (Ereditato da TreeList)
Metodo protetto | Export(ExportTarget, String, ExportOptionsBase) | (Ereditato da TreeList)
Metodo pubblico | ExportToCsv(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToCsv(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToCsv(Stream, CsvExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToCsv(String, CsvExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToDocx(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToDocx(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToDocx(Stream, DocxExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToDocx(String, DocxExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToHtml(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToHtml(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToHtml(Stream, HtmlExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToHtml(String, HtmlExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToMht(Stream, MhtExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToMht(String, MhtExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToMht(String, String) | Obsoleto. (Ereditato da TreeList)
Metodo pubblico | ExportToMht(Stream, String, String, Boolean) | Obsoleto. (Ereditato da TreeList)
Metodo pubblico | ExportToMht(String, String, String, Boolean) | Obsoleto. (Ereditato da TreeList)
Metodo pubblico | ExportToPdf(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToPdf(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToPdf(Stream, PdfExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToPdf(String, PdfExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToRtf(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToRtf(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToText(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToText(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToText(Stream, TextExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToText(String, TextExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToXls(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToXls(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToXls(Stream, XlsExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToXls(String, XlsExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToXlsx(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToXlsx(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToXlsx(Stream, XlsxExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToXlsx(String, XlsxExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToXml(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToXml(String) | (Ereditato da TreeList)
Metodo protetto | ExportToXmlCore | (Ereditato da TreeList)
Metodo protetto | ExtractTemplateRootNode | (Ereditato da TreeList)
Metodo pubblico | FilterNodes | (Sovrascrive TreeList.FilterNodes)
Metodo pubblico | FilterNodes(TreeListNodes) | (Ereditato da TreeList)
Metodo protetto | FilterNodesCore | (Ereditato da TreeList)
Metodo pubblico | FindNode | (Ereditato da TreeList)
Metodo pubblico | FindNodeByFieldValue | (Ereditato da TreeList)
Metodo pubblico | FindNodeByID | (Ereditato da TreeList)
Metodo pubblico | FindNodeByKeyID | (Ereditato da TreeList)
Metodo protetto | FindNodeByParentID | (Ereditato da TreeList)
Metodo pubblico | FindNodes | (Ereditato da TreeList)
Metodo protetto | FindPanelNext | (Ereditato da TreeList)
Metodo protetto | FindPanelPrev | (Ereditato da TreeList)
Metodo pubblico | FireChanged | (Ereditato da TreeList)
Metodo protetto | FitColumns | (Ereditato da TreeList)
Metodo pubblico | FocusNewItemNode | (Ereditato da TreeList)
Metodo protetto | ForceCalcRowCount | (Ereditato da TreeList)
Metodo pubblico | ForceInitialize | (Ereditato da TreeList)
Metodo protetto | ForceSetTopVisibleNodeIndex | (Ereditato da TreeList)
Metodo pubblico | FullCollapse | Obsoleto. (Ereditato da TreeList)
Metodo pubblico | FullExpand | Obsoleto. (Ereditato da TreeList)
Metodo pubblico | FullExpandNode | Obsoleto. (Ereditato da TreeList)
Metodo protetto | GetAccessibilityObjectById | (Ereditato da TreeList)
Metodo protetto | GetAccessibleNodeCell | (Ereditato da TreeList)
Metodo protetto | GetActiveEditorHighAppearance | (Ereditato da TreeList)
Metodo protetto | GetActualAnimationType | (Ereditato da TreeList)
Metodo protetto | GetActualTreeListFilterMode | (Ereditato da TreeList)
Metodo pubblico | GetAllCheckedNodes | (Ereditato da TreeList)
Metodo protetto | GetAllowChangeBandParent | (Ereditato da TreeList)
Metodo protetto | GetAllowColumnFilterPopup | (Ereditato da TreeList)
Metodo protetto | GetAllowFilterEditor | (Ereditato da TreeList)
Metodo protetto | GetAllowFindColumn | (Ereditato da TreeList)
Metodo protetto | GetAllowFocus | (Ereditato da TreeList)
Metodo protetto | GetAllowHighlightFindResults | (Ereditato da TreeList)
Metodo protetto | GetAllowMRUFilterList | (Ereditato da TreeList)
Metodo protetto | GetAutoFilterRowColumnEdit | (Ereditato da TreeList)
Metodo pubblico | GetAutoFilterValue | (Ereditato da TreeList)
Metodo protetto | GetAutoNodeHeight | (Ereditato da TreeList)
Metodo protetto | GetBandRows | (Ereditato da TreeList)
Metodo protetto | GetBandRowsCore | (Ereditato da TreeList)
Metodo protetto | GetBandVisibleIndex | (Ereditato da TreeList)
Metodo protetto | GetCanShowEditor | (Ereditato da TreeList)
Metodo pubblico | GetColumnByColumnHandle | (Ereditato da TreeList)
Metodo pubblico | GetColumnByVisibleIndex | (Ereditato da TreeList)
Metodo protetto | GetColumnDefaultRepositoryItem | (Ereditato da TreeList)
Metodo protetto | GetColumnDefaultRepositoryItemForEditing | (Ereditato da TreeList)
Metodo protetto | GetColumnEdit | (Ereditato da TreeList)
Metodo protetto | GetColumnEditForEditing | (Ereditato da TreeList)
Metodo pubblico | GetColumnError(TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | GetColumnError(TreeListColumn, TreeListNode) | (Ereditato da TreeList)
Metodo pubblico | GetColumnErrorType(TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | GetColumnErrorType(TreeListColumn, TreeListNode) | (Ereditato da TreeList)
Metodo protetto | GetColumnFieldNameSort | (Ereditato da TreeList)
Metodo protetto | GetColumnFilterCriteria | (Ereditato da TreeList)
Metodo protetto | GetColumnFilterMode | (Ereditato da TreeList)
Metodo pubblico | GetColumnHeaderBestWidth | (Ereditato da TreeList)
Metodo protetto | GetColumnName | (Ereditato da TreeList)
Metodo protetto | GetCurrencyManager | (Ereditato da TreeList)
Metodo protetto | GetDataColumnInfo | (Ereditato da TreeList)
Metodo pubblico | GetDataRecordByNode | (Ereditato da TreeList)
Metodo pubblico | GetDataRow | (Ereditato da TreeList)
Metodo protetto | GetDirectXDeviceBackColor | (Ereditato da EditorContainer)
Metodo protetto | GetDirectXProvider | (Ereditato da EditorContainer)
Metodo protetto | GetEditableObject | (Ereditato da TreeList)
Metodo pubblico | GetEditorShowMode | (Ereditato da TreeList)
Metodo protetto | GetEditorViewInfo | (Ereditato da TreeList)
Metodo protetto | GetFilterColumn | (Ereditato da TreeList)
Metodo protetto | GetFilterColumnByTreeListColumn | (Ereditato da TreeList)
Metodo protetto | GetFilterCriteriaDisplayStyle | (Ereditato da TreeList)
Metodo protetto | GetFilterDisplayText | (Ereditato da TreeList)
Metodo protetto | GetFilterDisplayTextByColumn | (Ereditato da TreeList)
Metodo protetto | GetFilterPopupTexts | (Ereditato da TreeList)
Metodo protetto | GetFilterPopupValues(TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | GetFilterPopupValues(TreeListColumn, Boolean) | (Ereditato da TreeList)
Metodo protetto | GetFilterPopupValues(TreeListColumn, CriteriaOperator, Boolean) | (Ereditato da TreeList)
Metodo protetto | GetFilterPopupValues(TreeListColumn, Boolean, Boolean) | (Ereditato da TreeList)
Metodo protetto | GetFilterRowValue(Object) | (Ereditato da TreeList)
Metodo protetto | GetFilterRowValue(TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | GetFindMatchedRanges | (Ereditato da TreeList)
Metodo protetto | GetFindMatchedText | (Ereditato da TreeList)
Metodo protetto | GetFindToColumnsCollection | (Ereditato da TreeList)
Metodo pubblico | GetFocusedDataRow | (Ereditato da TreeList)
Metodo pubblico | GetFocusedDisplayText | (Ereditato da TreeList)
Metodo pubblico | GetFocusedRow | (Ereditato da TreeList)
Metodo pubblico | GetFocusedRowCellDisplayText(String) | (Ereditato da TreeList)
Metodo pubblico | GetFocusedRowCellDisplayText(TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetFocusedRowCellValue(String) | (Ereditato da TreeList)
Metodo pubblico | GetFocusedRowCellValue(TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetGroupSummaryValue | (Ereditato da TreeList)
Metodo protetto | GetHeaderFilterButtonShowMode | (Ereditato da TreeList)
Metodo pubblico | GetHitInfo | Obsoleto. (Ereditato da TreeList)
Metodo protetto | GetImageIndexFromDataSource | (Ereditato da TreeList)
Metodo protetto | GetMaxIndent | (Ereditato da TreeList)
Metodo protetto | GetNativePreviewText | (Ereditato da TreeList)
Metodo pubblico | GetNodeAt(Point) | (Ereditato da TreeList)
Metodo pubblico | GetNodeAt(Int32, Int32) | (Ereditato da TreeList)
Metodo pubblico | GetNodeByVisibleIndex | (Ereditato da TreeList)
Metodo protetto | GetNodeCellRepositoryItem | (Ereditato da TreeList)
Metodo protetto | GetNodeComparer(IComparerTreeListNode) | (Ereditato da TreeList)
Metodo protetto | GetNodeComparer(TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetNodeIndex | (Ereditato da TreeList)
Metodo pubblico | GetNodeList | (Ereditato da TreeList)
Metodo protetto | GetNodeValue(TreeListNode, TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | GetNodeValue(TreeListNode, Object) | (Ereditato da TreeList)
Metodo protetto | GetNodeValue(TreeListNode, String) | (Ereditato da TreeList)
Metodo protetto | GetNonFormattedCaption | (Ereditato da TreeList)
Metodo protetto | GetParentColumnFieldNameSort | (Ereditato da TreeList)
Metodo pubblico | GetRow | (Ereditato da TreeList)
Metodo pubblico | GetRowCellDisplayText(TreeListNode, TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetRowCellDisplayText(TreeListNode, String) | (Ereditato da TreeList)
Metodo pubblico | GetRowCellValue(TreeListNode, TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetRowCellValue(TreeListNode, String) | (Ereditato da TreeList)
Metodo protetto | GetRowsAsFootersCount | (Ereditato da TreeList)
Metodo pubblico | GetScrollAnnotations | (Ereditato da TreeList)
Metodo pubblico | GetSelectedCells | (Ereditato da TreeList)
Metodo pubblico | GetSelectedCells(TreeListNode) | (Ereditato da TreeList)
Metodo protetto | GetShowBandsMode | (Ereditato da TreeList)
Metodo protetto | GetShowFirstLines | (Ereditato da TreeList)
Metodo protetto | GetShowIndentAsRowStyle | (Ereditato da TreeList)
Metodo pubblico | GetSortColumn(Int32) | (Ereditato da TreeList)
Metodo protetto | GetSortColumn(TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetSummaryValue(TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetSummaryValue(TreeListColumn, Boolean) | (Ereditato da TreeList)
Metodo protetto | GetSummaryValueCore | (Ereditato da TreeList)
Metodo protetto | GetSummaryValueEx | (Ereditato da TreeList)
Metodo pubblico | GetToolTipController | (Ereditato da EditorContainer)
Metodo protetto | GetUseDirectXPaint | (Ereditato da TreeList)
Metodo pubblico | GetVisibleIndexByNode | (Ereditato da TreeList)
Metodo protetto | GetVisibleIndexByNodeCore | (Ereditato da TreeList)
Metodo protetto | GetVisibleParentNodesCount | (Ereditato da TreeList)
Metodo pubblico | HideCustomization | (Ereditato da TreeList)
Metodo pubblico | HideEditor | (Ereditato da TreeList)
Metodo protetto | HideEditorCore | (Ereditato da TreeList)
Metodo pubblico | HideFindPanel | (Ereditato da TreeList)
Metodo pubblico | HideLoadingPanel | (Ereditato da TreeList)
Metodo protetto | HookOnLoaded | (Ereditato da EditorContainer)
Metodo pubblico | ImportFromXml(Stream) | (Ereditato da TreeList)
Metodo pubblico | ImportFromXml(String) | (Ereditato da TreeList)
Metodo protetto | ImportFromXmlCore | (Ereditato da TreeList)
Metodo pubblico | IndentNodes | (Ereditato da TreeList)
Metodo protetto | InitFindPanel | (Ereditato da TreeList)
Metodo protetto | InitializeDirectXProvider | (Ereditato da EditorContainer)
Metodo protetto | InitScrollInfo | (Ereditato da TreeList)
Metodo protetto | InternalDeleteNode | (Ereditato da TreeList)
Metodo protetto | InternalDeleteNodeCore | (Ereditato da TreeList)
Metodo protetto | InternalDeleteNodes(DictionaryTreeListNodes, ListTreeListNode) | (Ereditato da TreeList)
Metodo protetto | InternalDeleteNodes(TreeListNodes) | (Ereditato da TreeList)
Metodo protetto | InternalFullCollapseNode | (Ereditato da TreeList)
Metodo protetto | InternalFullExpandNode | (Ereditato da TreeList)
Metodo protetto | InternalGetCustomNodeCellEdit | (Ereditato da TreeList)
Metodo protetto | InternalGetCustomNodeCellStyle | (Ereditato da TreeList)
Metodo pubblico | InternalGetService | (Ereditato da TreeList)
Metodo protetto | InternalNodeAdded | (Ereditato da TreeList)
Metodo protetto | InternalNodeChanged | (Ereditato da TreeList)
Metodo protetto | InternalSetTopVisibleNodePixel | (Ereditato da TreeList)
Metodo pubblico | InvalidateBand | (Ereditato da TreeList)
Metodo pubblico | InvalidateBandPanel | (Ereditato da TreeList)
Metodo pubblico | InvalidateCell | (Ereditato da TreeList)
Metodo pubblico | InvalidateColumnHeader | (Ereditato da TreeList)
Metodo pubblico | InvalidateColumnPanel | (Ereditato da TreeList)
Metodo pubblico | InvalidateFilterPanel | (Ereditato da TreeList)
Metodo pubblico | InvalidateNode | (Ereditato da TreeList)
Metodo pubblico | InvalidateNodes | (Ereditato da TreeList)
Metodo pubblico | InvalidateRow | (Ereditato da TreeList)
Metodo pubblico | InvalidateRowPreview | (Ereditato da TreeList)
Metodo protetto | InvalidateRows | (Ereditato da TreeList)
Metodo pubblico | InvalidateScrollAnnotations | (Ereditato da TreeList)
Metodo pubblico | InvalidateSummaryFooterPanel | (Ereditato da TreeList)
Metodo pubblico | InvokeMenuItemClick | (Ereditato da TreeList)
Metodo protetto | IsAllowDefaultFastBestFit | (Ereditato da TreeList)
Metodo protetto | IsAllowEditForm | (Ereditato da TreeList)
Metodo pubblico | IsAutoFilterNode | (Ereditato da TreeList)
Metodo pubblico | IsCellSelected | (Ereditato da TreeList)
Metodo protetto | IsColumnAllowAutoFilter | (Ereditato da TreeList)
Metodo protetto | IsColumnAllowFilter | (Ereditato da TreeList)
Metodo pubblico | IsColumnAllowFilterEditor | (Ereditato da TreeList)
Metodo protetto | IsColumnFieldNameSortExist | (Ereditato da TreeList)
Metodo protetto | IsColumnFiltered | (Ereditato da TreeList)
Metodo protetto | IsFilterByDisplayText | (Ereditato da TreeList)
Metodo protetto | IsFilterRow | (Ereditato da TreeList)
Metodo protetto | IsImplyNullLikeEmptyStringWhenFiltering | (Ereditato da TreeList)
Metodo protetto | IsInputChar | (Ereditato da TreeList)
Metodo protetto | IsInputKey | (Ereditato da TreeList)
Metodo pubblico | IsNewItemRow | (Ereditato da TreeList)
Metodo protetto | IsParentColumnFieldNameSortExist | (Ereditato da TreeList)
Metodo pubblico | IsRootNode | (Ereditato da TreeList)
Metodo protetto | IsRoundDateTime | (Ereditato da TreeList)
Metodo protetto | IsShowAllValuesInFilterPopup | (Ereditato da TreeList)
Metodo protetto | IsTopNewItemRow | (Ereditato da TreeList)
Metodo protetto | IsUserAutoFilterCondition | (Ereditato da TreeList)
Metodo pubblico | LayoutChanged | (Ereditato da TreeList)
Metodo protetto | LoadDataColumns | (Ereditato da TreeList)
Metodo protetto | LoadDataSource | (Ereditato da TreeList)
Metodo protetto | LockDirectXRendering | (Ereditato da TreeList)
Metodo protetto | LockFilteringUIClientFilterCriteriaBinding | (Ereditato da TreeList)
Metodo pubblico | LockReloadNodes | (Ereditato da TreeList)
Metodo pubblico | MakeColumnVisible | (Ereditato da TreeList)
Metodo protetto | MakeFocusedRowVisible | (Ereditato da TreeList)
Metodo pubblico | MakeNodeVisible | (Ereditato da TreeList)
Metodo protetto | MergeColumnFiltersCore | (Ereditato da TreeList)
Metodo pubblico | MoveFirst | (Ereditato da TreeList)
Metodo protetto | MoveFocusedCell | (Ereditato da TreeList)
Metodo pubblico | MoveLast | (Ereditato da TreeList)
Metodo pubblico | MoveLastVisible | (Ereditato da TreeList)
Metodo pubblico | MoveNext | (Ereditato da TreeList)
Metodo pubblico | MoveNextVisible | (Ereditato da TreeList)
Metodo pubblico | MoveNode(TreeListNode, TreeListNode) | (Ereditato da TreeList)
Metodo pubblico | MoveNode(TreeListNode, TreeListNode, Boolean) | (Ereditato da TreeList)
Metodo pubblico | MoveNode(TreeListNode, TreeListNode, Boolean, Int32) | (Ereditato da TreeList)
Metodo pubblico | MoveNodes | (Ereditato da TreeList)
Metodo protetto | MoveNodesCore | (Ereditato da TreeList)
Metodo pubblico | MovePrev | (Ereditato da TreeList)
Metodo pubblico | MovePrevVisible | (Ereditato da TreeList)
Metodo pubblico | MoveToNextScrollAnnotation | (Ereditato da TreeList)
Metodo pubblico | MoveToParent | (Ereditato da TreeList)
Metodo pubblico | MoveToPrevScrollAnnotation | (Ereditato da TreeList)
Metodo protetto | NormalizeVisibleBandIndices | (Ereditato da TreeList)
Metodo protetto | NormalizeVisibleColumnIndices | (Ereditato da TreeList)
Metodo protetto | OnActiveEditor_GotFocus | (Ereditato da TreeList)
Metodo protetto | OnActiveEditor_LostFocus | (Ereditato da TreeList)
Metodo protetto | OnActiveEditor_Modified | (Ereditato da TreeList)
Metodo protetto | OnActiveEditor_ValueChanged | (Ereditato da TreeList)
Metodo protetto | OnActiveEditor_ValueChanging | (Ereditato da TreeList)
Metodo protetto | OnActiveFilterChanged | (Ereditato da TreeList)
Metodo protetto | OnActiveFilterCriteriaChanged | (Ereditato da TreeList)
Metodo protetto | OnActiveFilterEnabledChanged | (Ereditato da TreeList)
Metodo protetto | OnAfterAddingNode | (Ereditato da TreeList)
Metodo protetto | OnAfterChangeCollapsed | (Ereditato da TreeList)
Metodo protetto | OnAfterChangeExpanded | (Ereditato da TreeList)
Metodo protetto | OnAfterDeletingNodes | (Ereditato da TreeList)
Metodo protetto | OnAllowBandColumnMultiRowChanged | (Ereditato da TreeList)
Metodo protetto | OnAllowSerializationProperty | (Ereditato da TreeList)
Metodo protetto | OnAppearancePrintChanged | (Ereditato da TreeList)
Metodo protetto | OnBandChanged | (Ereditato da TreeList)
Metodo protetto | OnBandCollectionChanged | (Ereditato da TreeList)
Metodo protetto | OnBandColumnCollectionChanged | (Ereditato da TreeList)
Metodo protetto | OnBandFixedChanged | (Ereditato da TreeList)
Metodo protetto | OnBandWidthChanged | (Ereditato da TreeList)
Metodo protetto | OnBeginTouchScroll | (Ereditato da TreeList)
Metodo protetto | OnBindingContextChanged | (Ereditato da TreeList)
Metodo protetto | OnCheckBoxFieldNameChanged | (Ereditato da TreeList)
Metodo protetto | OnClearNodes | (Ereditato da TreeList)
Metodo protetto | OnClearNodesComplete | (Ereditato da TreeList)
Metodo protetto | OnClick | (Ereditato da TreeList)
Metodo protetto | OnColumnAdded | (Ereditato da TreeList)
Metodo protetto | OnColumnChanged | (Ereditato da TreeList)
Metodo protetto | OnColumnFilterModeChanged | (Ereditato da TreeList)
Metodo protetto | OnColumnFilterRestored | (Ereditato da TreeList)
Metodo protetto | OnColumnInfosPopulated | (Ereditato da TreeList)
Metodo protetto | OnColumnRemoved | (Ereditato da TreeList)
Metodo protetto | OnColumnRowIndexChanged | (Ereditato da TreeList)
Metodo protetto | OnColumnsChanged | (Ereditato da TreeList)
Metodo protetto | OnColumnUnboundChanged | (Ereditato da TreeList)
Metodo protetto | OnColumnUnboundExpressionChanged | (Ereditato da TreeList)
Metodo protetto | OnContainerEnter | (Ereditato da EditorContainer)
Metodo protetto | OnContainerLeave | (Ereditato da EditorContainer)
Metodo protetto | OnContextMenuKey | (Ereditato da TreeList)
Metodo protetto | OnCreateControl | (Ereditato da EditorContainer)
Metodo protetto | OnDataListChanged | (Ereditato da TreeList)
Metodo protetto | OnDesignerHost_LoadComplete | (Ereditato da EditorContainer)
Metodo protetto | OnDesignerHost_TransactionClosed | (Ereditato da EditorContainer)
Metodo protetto | OnDirectXPaintDisabled | (Ereditato da TreeList)
Metodo protetto | OnDoubleClick | (Ereditato da TreeList)
Metodo protetto | OnDragDrop | (Ereditato da TreeList)
Metodo protetto | OnDragEnter | (Ereditato da TreeList)
Metodo protetto | OnDragLeave | (Ereditato da TreeList)
Metodo protetto | OnDragOver | (Ereditato da TreeList)
Metodo protetto | OnEnabledChanged | (Ereditato da TreeList)
Metodo protetto | OnEndInit | (Ereditato da EditorContainer)
Metodo protetto | OnEndSerializing | (Ereditato da TreeList)
Metodo protetto | OnEndSorting | (Ereditato da TreeList)
Metodo protetto | OnEnter | (Ereditato da EditorContainer)
Metodo protetto | OnErrorInfo_Changed | (Ereditato da TreeList)
Metodo protetto | OnFilterRowValueChanging | (Ereditato da TreeList)
Metodo protetto | OnFirstInit | (Ereditato da EditorContainer)
Metodo protetto | OnFormatConditionChanged | (Ereditato da TreeList)
Metodo protetto | OnFormatRuleExpressionEditorCreated | (Ereditato da TreeList)
Metodo protetto | OnFormatRulesCollectionChanged | (Ereditato da TreeList)
Metodo protetto | OnGotCapture | (Ereditato da EditorContainer)
Metodo protetto | OnGotFocus | (Ereditato da TreeList)
Metodo protetto | OnHandleCreated | (Ereditato da TreeList)
Metodo protetto | OnHandleDestroyed | (Ereditato da TreeList)
Metodo protetto | OnHorizontalTouchScroll | (Ereditato da TreeList)
Metodo protetto | OnHScroll | (Ereditato da TreeList)
Metodo protetto | OnItemAdded | (Ereditato da TreeList)
Metodo protetto | OnItemAdding | (Ereditato da TreeList)
Metodo protetto | OnItemChanged(Int32, PropertyDescriptor) | (Ereditato da TreeList)
Metodo protetto | OnItemChanged(Int32, PropertyDescriptor, TreeListNode) | (Ereditato da TreeList)
Metodo protetto | OnItemDeleted | (Ereditato da TreeList)
Metodo protetto | OnItemMoved | (Ereditato da TreeList)
Metodo protetto | OnKeyDown | (Ereditato da TreeList)
Metodo protetto | OnKeyPress | (Ereditato da TreeList)
Metodo protetto | OnKeyUp | (Ereditato da TreeList)
Metodo protetto | OnLeave | (Ereditato da EditorContainer)
Metodo protetto | OnLoaded | (Ereditato da TreeList)
Metodo protetto | OnLoadedCore | (Ereditato da TreeList)
Metodo protetto | OnLookAndFeelChanged(LookAndFeelChangedEventArgs) | (Ereditato da TreeList)
Metodo protetto | OnLookAndFeelChanged(Object, EventArgs) | (Ereditato da EditorContainer)
Metodo protetto | OnLostCapture | (Ereditato da TreeList)
Metodo protetto | OnLostFocus | (Ereditato da TreeList)
Metodo protetto | OnMenuShowing | (Ereditato da TreeList)
Metodo protetto | OnMouseClick | (Ereditato da EditorContainer)
Metodo protetto | OnMouseDoubleClick | (Ereditato da EditorContainer)
Metodo protetto | OnMouseDown | (Ereditato da TreeList)
Metodo protetto | OnMouseEnter | (Ereditato da TreeList)
Metodo protetto | OnMouseHWheel | (Ereditato da EditorContainer)
Metodo protetto | OnMouseLeave | (Ereditato da TreeList)
Metodo protetto | OnMouseMove | (Ereditato da TreeList)
Metodo protetto | OnMouseUp | (Ereditato da TreeList)
Metodo protetto | OnMouseWheel | (Ereditato da EditorContainer)
Metodo protetto | OnMouseWheelCore | (Ereditato da TreeList)
Metodo protetto | OnNodeCheckedChanged | (Ereditato da TreeList)
Metodo protetto | OnNodeRemoved | (Ereditato da TreeList)
Metodo protetto | OnNodesLoaded | (Ereditato da TreeList)
Metodo protetto | OnNodesLoading | (Ereditato da TreeList)
Metodo protetto | OnNodesRemoved | (Ereditato da TreeList)
Metodo protetto | OnOptionsBehaviorChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsCustomizationChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsDragAndDropChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsEditFormChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsFilterChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsFindChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsHtmlChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsNavigationChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsPrintChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsScrollAnnotationsChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsSelectionChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsViewChanged | (Ereditato da TreeList)
Metodo protetto | OnPaint | (Ereditato da TreeList)
Metodo protetto | OnPaintBackground | (Ereditato da TreeList)
Metodo protetto | OnParentChanged | (Ereditato da TreeList)
Metodo protetto | OnPressedBandChanged | (Ereditato da TreeList)
Metodo protetto | OnPrintProgress | (Ereditato da TreeList)
Metodo protetto | OnPropertyChanged | (Ereditato da TreeList)
Metodo protetto | OnPropertyDescriptorChanged | (Ereditato da TreeList)
Metodo protetto | OnQueryContinueDrag | (Ereditato da TreeList)
Metodo protetto | OnRepositoryItemRefreshRequired | (Ereditato da TreeList)
Metodo protetto | OnReset | (Ereditato da TreeList)
Metodo protetto | OnResetSerializationProperties | (Ereditato da TreeList)
Metodo protetto | OnResize | (Ereditato da TreeList)
Metodo protetto | OnRightToLeftChanged | (Ereditato da TreeList)
Metodo protetto | OnRightToLeftChanged(EventArgs) | (Ereditato da EditorContainer)
Metodo protetto | OnScaleControl | (Ereditato da TreeList)
Metodo protetto | OnScaleTreeListCore | (Ereditato da TreeList)
Metodo protetto | OnSelectionChanged | (Ereditato da TreeList)
Metodo protetto | OnSetValue | (Ereditato da TreeList)
Metodo protetto | OnSortModeChanged | (Ereditato da TreeList)
Metodo protetto | OnSourceItemChanged | (Ereditato da TreeList)
Metodo protetto | OnStartSerializing | (Ereditato da TreeList)
Metodo protetto | OnStartSorting | (Ereditato da TreeList)
Metodo protetto | OnSystemColorsChanged | (Ereditato da TreeList)
Metodo protetto | OnToolTipControllerDisposed | (Ereditato da EditorContainer)
Metodo protetto | OnTouchScroll | (Ereditato da TreeList)
Metodo protetto | OnTouchZoom | (Ereditato da TreeList)
Metodo protetto | OnValidated | (Ereditato da EditorContainer)
Metodo protetto | OnValidating | (Ereditato da TreeList)
Metodo protetto | OnVerticalTouchScroll | (Ereditato da TreeList)
Metodo protetto | OnVisibleChanged | (Ereditato da TreeList)
Metodo protetto | OnVScroll | (Ereditato da TreeList)
Metodo protetto | OnVScrollCore | (Ereditato da TreeList)
Metodo pubblico | OutdentNodes | (Ereditato da TreeList)
Metodo protetto | ParseAutoFilter | (Ereditato da TreeList)
Metodo protetto | ParseAutoFilterValues | (Ereditato da TreeList)
Metodo pubblico | PasteFromClipboard | (Ereditato da TreeList)
Metodo pubblico | PopulateColumns | (Ereditato da TreeList)
Metodo pubblico | PostEditor | (Ereditato da TreeList)
Metodo protetto | PostEditor(Boolean) | (Ereditato da TreeList)
Metodo pubblico | Print | (Ereditato da TreeList)
Metodo protetto | PrintCore | (Ereditato da TreeList)
Metodo pubblico | PrintDialog | (Ereditato da TreeList)
Metodo protetto | PrintDialogCore | (Ereditato da TreeList)
Metodo protetto | ProcessControlTab | (Ereditato da TreeList)
Metodo protetto | ProcessControlTab(Boolean) | (Ereditato da TreeList)
Metodo protetto | ProcessDialogKey | (Ereditato da TreeList)
Metodo protetto | ProcessDirectXPaint | (Ereditato da TreeList)
Metodo protetto | RaiseAfterCheckNode | (Ereditato da TreeList)
Metodo protetto | RaiseAfterCollapse | (Ereditato da TreeList)
Metodo protetto | RaiseAfterDragNode | (Ereditato da TreeList)
Metodo protetto | RaiseAfterDropNode | (Ereditato da TreeList)
Metodo protetto | RaiseAfterExpand | (Ereditato da TreeList)
Metodo protetto | RaiseAfterFocusNode | (Ereditato da TreeList)
Metodo protetto | RaiseBandPositionChanged | (Ereditato da TreeList)
Metodo protetto | RaiseBandWidthChanged | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeCheckNode | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeCollapse | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeDragNode | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeDropNode | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeExpand | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeFocusNode | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeLoadLayout | (Ereditato da TreeList)
Metodo protetto | RaiseCalcNodeDragImageIndex | (Ereditato da TreeList)
Metodo protetto | RaiseCalcNodeHeight(TreeListNode, Int32) | (Ereditato da TreeList)
Metodo protetto | RaiseCalcNodeHeight(TreeListNode, RowInfo, Int32) | (Ereditato da TreeList)
Metodo protetto | RaiseCellValueChanged | (Ereditato da TreeList)
Metodo protetto | RaiseCellValueChanging | (Ereditato da TreeList)
Metodo protetto | RaiseCheckedColumnFilterPopupEvent | (Ereditato da TreeList)
Metodo protetto | RaiseClipboardNodeCopying | (Ereditato da TreeList)
Metodo protetto | RaiseClipboardNodePasting | (Ereditato da TreeList)
Metodo protetto | RaiseColumnButtonClick | (Ereditato da TreeList)
Metodo protetto | RaiseColumnChanged | (Ereditato da TreeList)
Metodo protetto | RaiseColumnFilterChanged | (Ereditato da TreeList)
Metodo protetto | RaiseColumnFilterPopupEvent | (Ereditato da TreeList)
Metodo protetto | RaiseColumnPositionChanged | (Ereditato da TreeList)
Metodo protetto | RaiseColumnUnboundExpressionChanged | (Ereditato da TreeList)
Metodo protetto | RaiseColumnWidthChanged | (Ereditato da TreeList)
Metodo protetto | RaiseCompareNodeValues | (Ereditato da TreeList)
Metodo protetto | RaiseCreateCustomNode | (Ereditato da TreeList)
Metodo protetto | RaiseCustomColumnDisplayText(CustomColumnDisplayTextEventArgs) | (Ereditato da TreeList)
Metodo protetto | RaiseCustomColumnDisplayText(TreeListNode, CellInfo) | (Ereditato da TreeList)
Metodo protetto | RaiseCustomColumnDisplayText(TreeListNode, TreeListColumn, BaseEditViewInfo) | (Ereditato da TreeList)
Metodo protetto | RaiseCustomColumnDisplayText(TreeListNode, TreeListColumn, Object, String) | (Ereditato da TreeList)
Metodo protetto | RaiseCustomColumnSort | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawBandHeader | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawColumnHeader | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawEmptyArea | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawFilterPanel | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawFooter | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawFooterCell | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodeButton | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodeCell | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodeCheckBox | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodeImages | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodeIndent | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodeIndicator | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodePreview | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawRow | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawRowFooter | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawRowFooterCell | (Ereditato da TreeList)
Metodo protetto | RaiseCustomFilterDisplayText | (Ereditato da TreeList)
Metodo protetto | RaiseCustomizationFormSearch | (Ereditato da TreeList)
Metodo protetto | RaiseCustomizeNewNodeFromOuterData | (Ereditato da TreeList)
Metodo protetto | RaiseCustomRowFilter | (Ereditato da TreeList)
Metodo protetto | RaiseCustomRowFilterEvent | (Ereditato da TreeList)
Metodo protetto | RaiseCustomUnboundColumnData | (Ereditato da TreeList)
Metodo protetto | RaiseDataSourceChanged | (Ereditato da TreeList)
Metodo protetto | RaiseDefaultPaintHelperChanged | (Ereditato da TreeList)
Metodo protetto | RaiseDragCancelNode | (Ereditato da TreeList)
Metodo protetto | RaiseDragObjectDrop | (Ereditato da TreeList)
Metodo protetto | RaiseDragObjectOver | (Ereditato da TreeList)
Metodo protetto | RaiseDragObjectStart | (Ereditato da TreeList)
Metodo protetto | RaiseEditFormHidden | (Ereditato da TreeList)
Metodo protetto | RaiseEditFormPrepared | (Ereditato da TreeList)
Metodo protetto | RaiseEditFormShowing | (Ereditato da TreeList)
Metodo protetto | RaiseEditorKeyDown | (Ereditato da TreeList)
Metodo protetto | RaiseEditorKeyPress | (Ereditato da EditorContainer)
Metodo protetto | RaiseEditorKeyUp | (Ereditato da EditorContainer)
Metodo protetto | RaiseEndSorting | (Ereditato da TreeList)
Metodo protetto | RaiseExcelColumnFilterPopupEvent | (Ereditato da TreeList)
Metodo protetto | RaiseFilterEditorCreated | (Ereditato da TreeList)
Metodo protetto | RaiseFilterExpressionEditorCreated | (Ereditato da TreeList)
Metodo protetto | RaiseFilterNodeEvent | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupDate | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelCustomizeTemplate | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelData(FilterPopupExcelDataEventArgs) | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelData(TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelData(TreeListColumn, CriteriaOperator) | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelData(TreeListColumn, TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelParseFilterCriteria | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelPrepareTemplate | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelQueryFilterCriteria | (Ereditato da TreeList)
Metodo protetto | RaiseFocusedColumnChanged | (Ereditato da TreeList)
Metodo protetto | RaiseFocusedNodeChanged | (Ereditato da TreeList)
Metodo protetto | RaiseGetCustomAnnotations | (Ereditato da TreeList)
Metodo protetto | RaiseGetCustomNodeCellEdit | (Ereditato da TreeList)
Metodo protetto | RaiseGetCustomNodeCellStyle | (Ereditato da TreeList)
Metodo protetto | RaiseGetCustomSummaryValue | (Ereditato da TreeList)
Metodo protetto | RaiseGetNodeDisplayValue | (Ereditato da TreeList)
Metodo protetto | RaiseGetPreviewText | (Ereditato da TreeList)
Metodo protetto | RaiseGetPrintCustomSummaryValue | (Ereditato da TreeList)
Metodo protetto | RaiseGetPrintPreviewText | (Ereditato da TreeList)
Metodo protetto | RaiseGetSelectImage | (Ereditato da TreeList)
Metodo protetto | RaiseGetStateImage | (Ereditato da TreeList)
Metodo protetto | RaiseHiddenEditor | (Ereditato da TreeList)
Metodo protetto | RaiseHideCustomizationForm | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementBlur | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementFocus | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseClick | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseDoubleClick | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseDown | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseMove | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseOut | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseOver | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseUp | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlSelectedTextChanged | (Ereditato da TreeList)
Metodo protetto | RaiseInitNewRow | (Ereditato da TreeList)
Metodo protetto | RaiseInvalidNodeException | (Ereditato da TreeList)
Metodo protetto | RaiseInvalidValueException | (Ereditato da TreeList)
Metodo protetto | RaiseLayoutUpdated | (Ereditato da TreeList)
Metodo protetto | RaiseLayoutUpgrade | (Ereditato da TreeList)
Metodo protetto | RaiseLeftCoordChanged | (Ereditato da TreeList)
Metodo protetto | RaiseLoad | (Ereditato da TreeList)
Metodo protetto | RaiseMeasurePreviewHeight | (Ereditato da TreeList)
Metodo protetto | RaiseNodeChanged | (Ereditato da TreeList)
Metodo protetto | RaiseNodesReloaded | (Ereditato da TreeList)
Metodo protetto | RaisePaintEx | (Ereditato da TreeList)
Metodo protetto | RaiseParseFindPanelText | (Ereditato da TreeList)
Metodo protetto | RaisePopupMenuShowing | (Ereditato da TreeList)
Metodo protetto | RaisePrintExportProgress | (Ereditato da TreeList)
Metodo protetto | RaiseQueryCustomFunctions | (Ereditato da TreeList)
Metodo protetto | RaiseRequireHideEditor | (Ereditato da EditorContainer)
Metodo protetto | RaiseRowCellClick | (Ereditato da TreeList)
Metodo protetto | RaiseRowClick | (Ereditato da TreeList)
Metodo protetto | RaiseRowSelectImageClick | (Ereditato da TreeList)
Metodo protetto | RaiseRowStateImageClick | (Ereditato da TreeList)
Metodo protetto | RaiseSelectImageClick | (Ereditato da TreeList)
Metodo protetto | RaiseSelectionChanged | (Ereditato da TreeList)
Metodo protetto | RaiseSelectionChanging | (Ereditato da TreeList)
Metodo protetto | RaiseShowCustomizationForm | (Ereditato da TreeList)
Metodo protetto | RaiseShowingEditor | (Ereditato da TreeList)
Metodo protetto | RaiseShownEditor | (Ereditato da TreeList)
Metodo protetto | RaiseShowTreeListMenu | Obsoleto. (Ereditato da TreeList)
Metodo protetto | RaiseStartSorting | (Ereditato da TreeList)
Metodo protetto | RaiseStateChanged | (Ereditato da TreeList)
Metodo protetto | RaiseStateImageClick | (Ereditato da TreeList)
Metodo protetto | RaiseSubstituteFilter | (Ereditato da TreeList)
Metodo protetto | RaiseTopVisibleNodeIndexChanged | (Ereditato da TreeList)
Metodo protetto | RaiseTreeListMenuItemClick | (Ereditato da TreeList)
Metodo protetto | RaiseUnboundExpressionEditorCreated | (Ereditato da TreeList)
Metodo protetto | RaiseValidateNode | (Ereditato da TreeList)
Metodo protetto | RaiseValidatingEditor | (Ereditato da TreeList)
Metodo protetto | RecalcSortColumns | (Ereditato da TreeList)
Metodo protetto | RecreateRowsInfoCore | (Ereditato da TreeList)
Metodo pubblico | Refresh | (Ereditato da TreeList)
Metodo pubblico | Refresh(Boolean) | (Ereditato da TreeList)
Metodo pubblico | RefreshCell | (Ereditato da TreeList)
Metodo protetto | RefreshCellCore | (Ereditato da TreeList)
Metodo protetto | RefreshColumnsInfo | (Ereditato da TreeList)
Metodo pubblico | RefreshDataSource | (Ereditato da TreeList)
Metodo pubblico | RefreshEditor | (Ereditato da TreeList)
Metodo protetto | RefreshEditorError | (Ereditato da TreeList)
Metodo protetto | RefreshHeadersInfo | (Ereditato da TreeList)
Metodo protetto | RefreshHtmlNodeCore | (Ereditato da TreeList)
Metodo pubblico | RefreshNode | (Ereditato da TreeList)
Metodo protetto | RefreshNodeCore | (Ereditato da TreeList)
Metodo protetto | RefreshRowsInfo | (Ereditato da TreeList)
Metodo protetto | RefreshRowsInfo(Boolean, Boolean) | (Ereditato da TreeList)
Metodo pubblico | RefreshScrollAnnotations(ScrollAnnotationKind) | (Ereditato da TreeList)
Metodo pubblico | RefreshScrollAnnotations(ScrollAnnotationKind, Int32) | (Ereditato da TreeList)
Metodo protetto | RefreshVirtualCellCore | (Ereditato da TreeList)
Metodo protetto | RefreshVirtualNodeCore | (Ereditato da TreeList)
Metodo protetto | RejectCurrentChanges | (Ereditato da TreeList)
Metodo protetto | RemoveFromDefaultTooltipController | (Ereditato da EditorContainer)
Metodo protetto | RemoveHookOnLoaded | (Ereditato da EditorContainer)
Metodo protetto | RemoveNodeHeight | (Ereditato da TreeList)
Metodo protetto | RequestCellEditor | (Ereditato da TreeList)
Metodo protetto | ResetAccessibility | (Ereditato da TreeList)
Metodo pubblico | ResetAutoFilterCondition | (Ereditato da TreeList)
Metodo pubblico | ResetAutoFilterConditions | (Ereditato da TreeList)
Metodo pubblico | ResetAutoFilterConditions(IEnumerableTreeListColumn) | (Ereditato da TreeList)
Metodo protetto | ResetAutoFilterConditionsCore | (Ereditato da TreeList)
Metodo protetto | ResetColumnAutoFilterConditions | (Ereditato da TreeList)
Metodo pubblico | ResetEditorsCache(RepositoryItem) | (Ereditato da EditorContainer)
Metodo pubblico | ResetEditorsCache(Type) | (Ereditato da EditorContainer)
Metodo protetto | ResetExcelFilteringProvider | (Ereditato da TreeList)
Metodo pubblico | ResetFilterFlag | Reinizializza i flag utilizzati per il filtraggio dei nodi
Metodo protetto | ResetLookAndFeel | (Ereditato da EditorContainer)
Metodo protetto | ResetRowCount | (Ereditato da TreeList)
Metodo protetto | ResetSortedColumns | (Ereditato da TreeList)
Metodo protetto | ResizeBand | (Ereditato da TreeList)
Metodo protetto | ResizeColumn | (Ereditato da TreeList)
Metodo protetto | ResolveAutoFilterCondition | (Ereditato da TreeList)
Metodo protetto | RestoreLayoutCore | (Ereditato da TreeList)
Metodo pubblico | RestoreLayoutFromRegistry(String) | (Ereditato da TreeList)
Metodo pubblico | RestoreLayoutFromRegistry(String, OptionsLayoutBase) | (Ereditato da TreeList)
Metodo pubblico | RestoreLayoutFromStream(Stream) | (Ereditato da TreeList)
Metodo pubblico | RestoreLayoutFromStream(Stream, OptionsLayoutBase) | (Ereditato da TreeList)
Metodo pubblico | RestoreLayoutFromXml(String) | (Ereditato da TreeList)
Metodo pubblico | RestoreLayoutFromXml(String, OptionsLayoutBase) | (Ereditato da TreeList)
Metodo protetto | RestoreNodesData | (Ereditato da TreeList)
Metodo protetto | SaveLayoutCore | (Ereditato da TreeList)
Metodo pubblico | SaveLayoutToRegistry(String) | (Ereditato da TreeList)
Metodo pubblico | SaveLayoutToRegistry(String, OptionsLayoutBase) | (Ereditato da TreeList)
Metodo pubblico | SaveLayoutToStream(Stream) | (Ereditato da TreeList)
Metodo pubblico | SaveLayoutToStream(Stream, OptionsLayoutBase) | (Ereditato da TreeList)
Metodo pubblico | SaveLayoutToXml(String) | (Ereditato da TreeList)
Metodo pubblico | SaveLayoutToXml(String, OptionsLayoutBase) | (Ereditato da TreeList)
Metodo protetto | SaveNodesData | (Ereditato da TreeList)
Metodo protetto | ScaleControl | (Ereditato da EditorContainer)
Metodo protetto | Scrollbar_MouseEnter | (Ereditato da TreeList)
Metodo protetto | Scrollbar_MouseLeave | (Ereditato da TreeList)
Metodo protetto | ScrollHorizontalEx | (Ereditato da TreeList)
Metodo protetto | ScrollVerticalEx | (Ereditato da TreeList)
Metodo pubblico | SelectAll | (Ereditato da TreeList)
Metodo pubblico | SelectCell | (Ereditato da TreeList)
Metodo protetto | SelectCellCore | (Ereditato da TreeList)
Metodo pubblico | SelectCells(Int32, String, Int32, String) | (Ereditato da TreeList)
Metodo pubblico | SelectCells(TreeListNode, TreeListColumn, TreeListNode, TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | SelectNode | (Ereditato da TreeList)
Metodo protetto | SelectNodeCore | (Ereditato da TreeList)
Metodo pubblico | SelectNodes(Int32, Int32) | (Ereditato da TreeList)
Metodo pubblico | SelectNodes(TreeListNode, TreeListNode) | (Ereditato da TreeList)
Metodo protetto | SelectNodesCore | (Ereditato da TreeList)
Metodo protetto | ServiceColumnChanged | (Ereditato da TreeList)
Metodo pubblico | SetAutoFilterValue | (Ereditato da TreeList)
Metodo protetto | SetCellSelection | (Ereditato da TreeList)
Metodo protetto | SetCellSelectionCore | (Ereditato da TreeList)
Metodo pubblico | SetColumnError(TreeListColumn, String) | (Ereditato da TreeList)
Metodo pubblico | SetColumnError(TreeListColumn, String, ErrorType) | (Ereditato da TreeList)
Metodo protetto | SetColumnFixedStyle | (Ereditato da TreeList)
Metodo pubblico | SetColumnPosition | (Ereditato da TreeList)
Metodo protetto | SetColumnVisibleIndex | (Ereditato da TreeList)
Metodo pubblico | SetDefaultBehaviorOptions | (Ereditato da TreeList)
Metodo pubblico | SetDefaultCustomizationOptions | (Ereditato da TreeList)
Metodo pubblico | SetDefaultNavigationOptions | (Ereditato da TreeList)
Metodo pubblico | SetDefaultOptionsView | (Ereditato da TreeList)
Metodo pubblico | SetDefaultPrintOptions | (Ereditato da TreeList)
Metodo pubblico | SetDefaultRowHeight | (Ereditato da TreeList)
Metodo pubblico | SetDefaultSelectionOptions | (Ereditato da TreeList)
Metodo protetto | SetExtraFilter | (Ereditato da TreeList)
Metodo protetto | SetFilterRowValue(Object, Object) | (Ereditato da TreeList)
Metodo protetto | SetFilterRowValue(TreeListColumn, Object) | (Ereditato da TreeList)
Metodo pubblico | SetFocusedNode | (Ereditato da TreeList)
Metodo protetto | SetFocusedNodeCore | (Ereditato da TreeList)
Metodo pubblico | SetFocusedRowCellValue(String, Object) | (Ereditato da TreeList)
Metodo pubblico | SetFocusedRowCellValue(TreeListColumn, Object) | (Ereditato da TreeList)
Metodo protetto | SetFocusedRowIndexCore | (Ereditato da TreeList)
Metodo pubblico | SetFocusedValue | (Ereditato da TreeList)
Metodo pubblico | SetNodeCheckState(TreeListNode, CheckState) | (Ereditato da TreeList)
Metodo pubblico | SetNodeCheckState(TreeListNode, CheckState, Boolean) | (Ereditato da TreeList)
Metodo pubblico | SetNodeIndex | (Ereditato da TreeList)
Metodo protetto | SetNodeIndexCore | (Ereditato da TreeList)
Metodo protetto | SetNodeValue | (Ereditato da TreeList)
Metodo pubblico | SetRowCellValue(TreeListNode, TreeListColumn, Object) | (Ereditato da TreeList)
Metodo pubblico | SetRowCellValue(TreeListNode, String, Object) | (Ereditato da TreeList)
Metodo pubblico | SetSearchControl | (Ereditato da TreeList)
Metodo pubblico | SetSelectionAnchor | (Ereditato da TreeList)
Metodo protetto | SetUseDirectXPaint | (Ereditato da TreeList)
Metodo protetto | ShouldResortNodesOnItemChanged | (Ereditato da TreeList)
Metodo protetto | ShouldSerializeLookAndFeel | (Ereditato da EditorContainer)
Metodo pubblico | ShowAutoFilterConditionsMenu | (Ereditato da TreeList)
Metodo pubblico | ShowContextMenu | (Ereditato da TreeList)
Metodo pubblico | ShowCustomization | (Ereditato da TreeList)
Metodo pubblico | ShowCustomization(Point) | (Ereditato da TreeList)
Metodo pubblico | ShowEditForm | (Ereditato da TreeList)
Metodo protetto | ShowEditFormCore | (Ereditato da TreeList)
Metodo protetto | ShowEditFormDialogCore | (Ereditato da TreeList)
Metodo pubblico | ShowEditor | (Ereditato da TreeList)
Metodo pubblico | ShowEditor(String) | (Ereditato da TreeList)
Metodo pubblico | ShowFilterEditor | (Ereditato da TreeList)
Metodo protetto | ShowFilterExpressionEditor | (Ereditato da TreeList)
Metodo pubblico | ShowFilterPopup | (Ereditato da TreeList)
Metodo pubblico | ShowFindPanel | (Ereditato da TreeList)
Metodo pubblico | ShowLoadingPanel | (Ereditato da TreeList)
Metodo protetto | ShowMenu | (Ereditato da TreeList)
Metodo protetto | ShowMRUFilterPopup | (Ereditato da TreeList)
Metodo pubblico | ShowPrintPreview | (Ereditato da TreeList)
Metodo protetto | ShowPrintPreviewCore | (Ereditato da TreeList)
Metodo protetto | ShowProgressForm | (Ereditato da TreeList)
Metodo pubblico | ShowRibbonPrintPreview | (Ereditato da TreeList)
Metodo protetto | ShowRibbonPrintPreviewCore | (Ereditato da TreeList)
Metodo pubblico | ShowUnboundExpressionEditor | (Ereditato da TreeList)
Metodo pubblico | Sort(TreeListNode, IComparerTreeListNode, Boolean) | (Ereditato da TreeList)
Metodo protetto | Sort(TreeListNodes, Boolean, Boolean) | (Ereditato da TreeList)
Metodo pubblico | Sort(TreeListNode, TreeListColumn, SortOrder, Boolean) | (Ereditato da TreeList)
Metodo pubblico | StartIncrementalSearch | (Ereditato da TreeList)
Metodo protetto | StartOfficeScrolling | (Ereditato da TreeList)
Metodo pubblico | StopIncrementalSearch | (Ereditato da TreeList)
Metodo protetto | StopOfficeScrolling | (Ereditato da TreeList)
Metodo pubblico | UncheckAll | (Ereditato da TreeList)
Metodo protetto | UnlockDirectXRendering | (Ereditato da TreeList)
Metodo pubblico | UnlockReloadNodes | (Ereditato da TreeList)
Metodo pubblico | UnselectCell | (Ereditato da TreeList)
Metodo protetto | UnselectCellCore | (Ereditato da TreeList)
Metodo pubblico | UnselectCells(Int32, String, Int32, String) | (Ereditato da TreeList)
Metodo pubblico | UnselectCells(TreeListNode, TreeListColumn, TreeListNode, TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | UnselectNode | (Ereditato da TreeList)
Metodo pubblico | UnselectNodes(Int32, Int32) | (Ereditato da TreeList)
Metodo pubblico | UnselectNodes(TreeListNode, TreeListNode) | (Ereditato da TreeList)
Metodo protetto | UpdateActiveFilterInfo | (Ereditato da TreeList)
Metodo protetto | UpdateAutoFilterRowActiveEditor | (Ereditato da TreeList)
Metodo protetto | UpdateBandColumnsIndices | (Ereditato da TreeList)
Metodo protetto | UpdateBandColumnsOrder | (Ereditato da TreeList)
Metodo protetto | UpdateColumnAutoFilter | (Ereditato da TreeList)
Metodo protetto | UpdateColumnsSortIndices | (Ereditato da TreeList)
Metodo protetto | UpdateElementsLookAndFeel | (Ereditato da TreeList)
Metodo protetto | UpdateFilter | (Ereditato da TreeList)
Metodo protetto | UpdateFilterInfo | (Ereditato da TreeList)
Metodo protetto | UpdateFindPanelFilterText | (Ereditato da TreeList)
Metodo protetto | UpdateLayout | (Ereditato da TreeList)
Metodo protetto | UpdateRootBands | (Ereditato da TreeList)
Metodo protetto | UpdateSelectCell | (Ereditato da TreeList)
Metodo protetto | UpdateSelectCell(TreeListNode, TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | UpdateSelectNode | (Ereditato da TreeList)
Metodo protetto | UpdateSelectNode(TreeListNode) | (Ereditato da TreeList)
Metodo protetto | UpdateVScrollBarCore | (Ereditato da TreeList)
Metodo protetto | ValidateAndEndCurrentEdit | (Ereditato da TreeList)
Metodo protetto | WndProc | (Ereditato da TreeList)
Metodo protetto | XtraClearColumns | (Ereditato da TreeList)
Metodo protetto | XtraCreateColumnsItem | (Ereditato da TreeList)
Metodo protetto | XtraFindColumnsItem | (Ereditato da TreeList)
Torna su
Vedi anche

Documentazione

Classe MyTreeListRoot
Namespace DedNet.Controls


Metodo MyTreeListRoot.FilterNodes

Metodo MyTreeListRootFilterNodes
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | FilterNodes |
Metodo pubblico | FilterNodes(TreeListNodes) |
Torna su
Vedi anche

Documentazione

Classe MyTreeListRoot
Namespace DedNet.Controls


Metodo MyTreeListRoot.FilterNodes

Metodo MyTreeListRootFilterNodes

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void FilterNodes()
Public Overrides Sub FilterNodes
public:
virtual void FilterNodes() override
abstract FilterNodes : unit -> unit
override FilterNodes : unit -> unit
Vedi anche

Documentazione

Classe MyTreeListRoot
Overload di FilterNodes
Namespace DedNet.Controls


Metodo MyTreeListRoot.ResetFilterFlag

Metodo MyTreeListRootResetFilterFlag
Reinizializza i flag utilizzati per il filtraggio dei nodi

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ResetFilterFlag()
Public Sub ResetFilterFlag
public:
void ResetFilterFlag()
member ResetFilterFlag : unit -> unit
Vedi anche

Documentazione

Classe MyTreeListRoot
Namespace DedNet.Controls


Eventi di MyTreeListRoot

Il tipo MyTreeListRoot espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | AfterCheckNode | (Ereditato da TreeList)
Evento pubblico | AfterCollapse | (Ereditato da TreeList)
Evento pubblico | AfterDragNode | (Ereditato da TreeList)
Evento pubblico | AfterDropNode | (Ereditato da TreeList)
Evento pubblico | AfterExpand | (Ereditato da TreeList)
Evento pubblico | AfterFocusNode | (Ereditato da TreeList)
Evento pubblico | BandPositionChanged | (Ereditato da TreeList)
Evento pubblico | BandWidthChanged | (Ereditato da TreeList)
Evento pubblico | BeforeCheckNode | (Ereditato da TreeList)
Evento pubblico | BeforeCollapse | (Ereditato da TreeList)
Evento pubblico | BeforeDragNode | (Ereditato da TreeList)
Evento pubblico | BeforeDropNode | (Ereditato da TreeList)
Evento pubblico | BeforeExpand | (Ereditato da TreeList)
Evento pubblico | BeforeFocusNode | (Ereditato da TreeList)
Evento pubblico | BeforeLoadLayout | (Ereditato da TreeList)
Evento pubblico | CalcNodeDragImageIndex | (Ereditato da TreeList)
Evento pubblico | CalcNodeHeight | (Ereditato da TreeList)
Evento pubblico | CellValueChanged | (Ereditato da TreeList)
Evento pubblico | CellValueChanging | (Ereditato da TreeList)
Evento pubblico | ClipboardNodeCopying | (Ereditato da TreeList)
Evento pubblico | ClipboardNodePasting | (Ereditato da TreeList)
Evento pubblico | ColumnButtonClick | (Ereditato da TreeList)
Evento pubblico | ColumnChanged | (Ereditato da TreeList)
Evento pubblico | ColumnFilterChanged | (Ereditato da TreeList)
Evento pubblico | ColumnPositionChanged | (Ereditato da TreeList)
Evento pubblico | ColumnUnboundExpressionChanged | (Ereditato da TreeList)
Evento pubblico | ColumnWidthChanged | (Ereditato da TreeList)
Evento pubblico | CompareNodeValues | (Ereditato da TreeList)
Evento pubblico | CreateCustomNode | (Ereditato da TreeList)
Evento pubblico | CustomColumnDisplayText | (Ereditato da TreeList)
Evento pubblico | CustomColumnSort | (Ereditato da TreeList)
Evento pubblico | CustomDrawBandHeader | (Ereditato da TreeList)
Evento pubblico | CustomDrawColumnHeader | (Ereditato da TreeList)
Evento pubblico | CustomDrawEmptyArea | (Ereditato da TreeList)
Evento pubblico | CustomDrawFilterPanel | (Ereditato da TreeList)
Evento pubblico | CustomDrawFooter | (Ereditato da TreeList)
Evento pubblico | CustomDrawFooterCell | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodeButton | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodeCell | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodeCheckBox | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodeImages | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodeIndent | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodeIndicator | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodePreview | (Ereditato da TreeList)
Evento pubblico | CustomDrawRow | (Ereditato da TreeList)
Evento pubblico | CustomDrawRowFooter | (Ereditato da TreeList)
Evento pubblico | CustomDrawRowFooterCell | (Ereditato da TreeList)
Evento pubblico | CustomDrawScroll | (Ereditato da TreeList)
Evento pubblico | CustomFilterDisplayText | (Ereditato da TreeList)
Evento pubblico | CustomizationFormSearch | (Ereditato da TreeList)
Evento pubblico | CustomizeNewNodeFromOuterData | (Ereditato da TreeList)
Evento pubblico | CustomizeNodeTemplate | (Ereditato da TreeList)
Evento pubblico | CustomNodeCellEdit | (Ereditato da TreeList)
Evento pubblico | CustomNodeCellEditForEditing | (Ereditato da TreeList)
Evento pubblico | CustomRowFilter | (Ereditato da TreeList)
Evento pubblico | CustomScrollAnnotation | (Ereditato da TreeList)
Evento pubblico | CustomUnboundColumnData | (Ereditato da TreeList)
Evento pubblico | DataSourceChanged | (Ereditato da TreeList)
Evento pubblico | DefaultPaintHelperChanged | (Ereditato da TreeList)
Evento pubblico | DragCancelNode | (Ereditato da TreeList)
Evento pubblico | DragObjectDrop | (Ereditato da TreeList)
Evento pubblico | DragObjectOver | (Ereditato da TreeList)
Evento pubblico | DragObjectStart | (Ereditato da TreeList)
Evento pubblico | EditFormHidden | (Ereditato da TreeList)
Evento pubblico | EditFormPrepared | (Ereditato da TreeList)
Evento pubblico | EditFormShowing | (Ereditato da TreeList)
Evento pubblico | EditorKeyDown | (Ereditato da EditorContainer)
Evento pubblico | EditorKeyPress | (Ereditato da EditorContainer)
Evento pubblico | EditorKeyUp | (Ereditato da EditorContainer)
Evento pubblico | EndSorting | (Ereditato da TreeList)
Evento pubblico | FilterEditorCreated | (Ereditato da TreeList)
Evento pubblico | FilterExpressionEditorCreated | (Ereditato da TreeList)
Evento pubblico | FilterNode | (Ereditato da TreeList)
Evento pubblico | FilterPopupExcelCustomizeTemplate | (Ereditato da TreeList)
Evento pubblico | FilterPopupExcelData | (Ereditato da TreeList)
Evento pubblico | FilterPopupExcelParseFilterCriteria | (Ereditato da TreeList)
Evento pubblico | FilterPopupExcelPrepareTemplate | (Ereditato da TreeList)
Evento pubblico | FilterPopupExcelQueryFilterCriteria | (Ereditato da TreeList)
Evento pubblico | FocusedColumnChanged | (Ereditato da TreeList)
Evento pubblico | FocusedNodeChanged | (Ereditato da TreeList)
Evento pubblico | FormatRuleExpressionEditorCreated | (Ereditato da TreeList)
Evento pubblico | GetCustomNodeCellEdit | Obsoleto. (Ereditato da TreeList)
Evento pubblico | GetCustomNodeCellStyle | Obsoleto. (Ereditato da TreeList)
Evento pubblico | GetCustomSummaryValue | (Ereditato da TreeList)
Evento pubblico | GetNodeDisplayValue | (Ereditato da TreeList)
Evento pubblico | GetPreviewText | (Ereditato da TreeList)
Evento pubblico | GetPrintCustomSummaryValue | (Ereditato da TreeList)
Evento pubblico | GetPrintPreviewText | (Ereditato da TreeList)
Evento pubblico | GetSelectImage | (Ereditato da TreeList)
Evento pubblico | GetStateImage | (Ereditato da TreeList)
Evento pubblico | HiddenEditor | (Ereditato da TreeList)
Evento pubblico | HideCustomizationForm | (Ereditato da TreeList)
Evento pubblico | HtmlElementBlur | (Ereditato da TreeList)
Evento pubblico | HtmlElementFocus | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseClick | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseDoubleClick | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseDown | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseMove | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseOut | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseOver | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseUp | (Ereditato da TreeList)
Evento pubblico | HtmlSelectedTextChanged | (Ereditato da TreeList)
Evento pubblico | HyperlinkClick | (Ereditato da TreeList)
Evento pubblico | InitNewRow | (Ereditato da TreeList)
Evento pubblico | InvalidNodeException | (Ereditato da TreeList)
Evento pubblico | InvalidValueException | (Ereditato da TreeList)
Evento pubblico | LayoutUpdated | (Ereditato da TreeList)
Evento pubblico | LayoutUpgrade | (Ereditato da TreeList)
Evento pubblico | LeftCoordChanged | (Ereditato da TreeList)
Evento pubblico | Load | (Ereditato da TreeList)
Evento pubblico | MeasurePreviewHeight | (Ereditato da TreeList)
Evento pubblico | NodeCellStyle | (Ereditato da TreeList)
Evento pubblico | NodeChanged | (Ereditato da TreeList)
Evento pubblico | NodesReloaded | (Ereditato da TreeList)
Evento pubblico | PaintEx | (Ereditato da TreeList)
Evento pubblico | ParseFindPanelText | (Ereditato da TreeList)
Evento pubblico | PopupMenuShowing | (Ereditato da TreeList)
Evento pubblico | PrintExportProgress | (Ereditato da TreeList)
Evento pubblico | PropertyDeserializing | (Ereditato da TreeList)
Evento pubblico | PropertySerializing | (Ereditato da TreeList)
Evento pubblico | QueryCustomFunctions | (Ereditato da TreeList)
Evento pubblico | QueryEmptyTreeTemplate | (Ereditato da TreeList)
Evento pubblico | QueryNodeTemplate | (Ereditato da TreeList)
Evento pubblico | RowCellClick | (Ereditato da TreeList)
Evento pubblico | RowClick | (Ereditato da TreeList)
Evento pubblico | RowSelectImageClick | (Ereditato da TreeList)
Evento pubblico | RowStateImageClick | (Ereditato da TreeList)
Evento pubblico | ScrollAnnotationsStyle | (Ereditato da TreeList)
Evento pubblico | SelectImageClick | (Ereditato da TreeList)
Evento pubblico | SelectionChanged | (Ereditato da TreeList)
Evento pubblico | SelectionChanging | (Ereditato da TreeList)
Evento pubblico | ShowCustomizationForm | (Ereditato da TreeList)
Evento pubblico | ShowFilterPopupCheckedListBox | (Ereditato da TreeList)
Evento pubblico | ShowFilterPopupDate | (Ereditato da TreeList)
Evento pubblico | ShowFilterPopupExcel | (Ereditato da TreeList)
Evento pubblico | ShowFilterPopupListBox | (Ereditato da TreeList)
Evento pubblico | ShowingEditor | (Ereditato da TreeList)
Evento pubblico | ShownEditor | (Ereditato da TreeList)
Evento pubblico | ShowTreeListMenu | Obsoleto. (Ereditato da TreeList)
Evento pubblico | StartSorting | (Ereditato da TreeList)
Evento pubblico | StateChanged | (Ereditato da TreeList)
Evento pubblico | StateImageClick | (Ereditato da TreeList)
Evento pubblico | SubstituteFilter | (Ereditato da TreeList)
Evento pubblico | TopVisibleNodeIndexChanged | (Ereditato da TreeList)
Evento pubblico | TreeListMenuItemClick | (Ereditato da TreeList)
Evento pubblico | UnboundExpressionEditorCreated | (Ereditato da TreeList)
Evento pubblico | ValidateNode | (Ereditato da TreeList)
Evento pubblico | ValidatingEditor | (Ereditato da TreeList)
Evento pubblico | VirtualTreeGetCellValue | (Ereditato da TreeList)
Evento pubblico | VirtualTreeGetChildNodes | (Ereditato da TreeList)
Evento pubblico | VirtualTreeSetCellValue | (Ereditato da TreeList)
Torna su
Vedi anche

Documentazione

Classe MyTreeListRoot
Namespace DedNet.Controls


Campi di MyTreeListRoot

Il tipo MyTreeListRoot espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | allowCloseEditor | (Ereditato da TreeList)
Campo protetto | fInitializing | (Ereditato da EditorContainer)
Campo protetto | fUpdateSize | (Ereditato da TreeList)
Campo protetto | SortedColumns | (Ereditato da TreeList)
Torna su
Vedi anche

Documentazione

Classe MyTreeListRoot
Namespace DedNet.Controls


Classe ReloadDistNodes
Classe che scorre tutti i nodi e se ha la stessa anagrafica di quello di riferimento ne aggiorna i figli.
Gerarchia di ereditarietà
SystemObject
TreeListOperation
DedNet.ControlsReloadDistNodes

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ReloadDistNodes : TreeListOperation
Public Class ReloadDistNodes
    Inherits TreeListOperation
public ref class ReloadDistNodes : public TreeListOperation
type ReloadDistNodes =
    class
        inherit TreeListOperation
    end

Il tipo ReloadDistNodes espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ReloadDistNodes | Costruttore.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | NeedsFullIteration | (Ereditato da TreeListOperation)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | CanContinueIteration | (Ereditato da TreeListOperation)
Metodo pubblico | CanExecute | (Ereditato da TreeListOperation)
Metodo pubblico | Execute | Scorre tutti i nodi dell'albero. (Sovrascrive TreeListOperation.Execute(TreeListNode))
Metodo pubblico | FinalizeOperation | (Ereditato da TreeListOperation)
Metodo protetto | HasChildren | (Ereditato da TreeListOperation)
Metodo pubblico | NeedsVisitChildren | (Ereditato da TreeListOperation)
Metodo protetto | OnAfterNodesOperation | (Ereditato da TreeListOperation)
Metodo protetto | OnNodesOperation | (Ereditato da TreeListOperation)
Metodo pubblico | ReloadDistNode | Metodo per aggiornare i nodi figli
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore ReloadDistNodes
Costruttore.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ReloadDistNodes(
    TreeListNode node,
    DedDistControl deddistctr
)
Public Sub New (
    node As TreeListNode,
    deddistctr As DedDistControl
)
public:
ReloadDistNodes(
    TreeListNode^ node,
    DedDistControl^ deddistctr
)
new :
        node : TreeListNode *
        deddistctr : DedDistControl -> ReloadDistNodes

Parametri

node TreeListNode
deddistctr DedDistControl
Vedi anche

Documentazione

Classe ReloadDistNodes
Namespace DedNet.Controls


Proprietà di ReloadDistNodes

Il tipo ReloadDistNodes espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | NeedsFullIteration | (Ereditato da TreeListOperation)
Torna su
Vedi anche

Documentazione

Classe ReloadDistNodes
Namespace DedNet.Controls


Metodi di ReloadDistNodes

Il tipo ReloadDistNodes espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | CanContinueIteration | (Ereditato da TreeListOperation)
Metodo pubblico | CanExecute | (Ereditato da TreeListOperation)
Metodo pubblico | Execute | Scorre tutti i nodi dell'albero. (Sovrascrive TreeListOperation.Execute(TreeListNode))
Metodo pubblico | FinalizeOperation | (Ereditato da TreeListOperation)
Metodo protetto | HasChildren | (Ereditato da TreeListOperation)
Metodo pubblico | NeedsVisitChildren | (Ereditato da TreeListOperation)
Metodo protetto | OnAfterNodesOperation | (Ereditato da TreeListOperation)
Metodo protetto | OnNodesOperation | (Ereditato da TreeListOperation)
Metodo pubblico | ReloadDistNode | Metodo per aggiornare i nodi figli
Torna su
Vedi anche

Documentazione

Classe ReloadDistNodes
Namespace DedNet.Controls


Metodo ReloadDistNodes.Execute

Metodo ReloadDistNodesExecute
Scorre tutti i nodi dell'albero.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void Execute(
    TreeListNode refNode
)
Public Overrides Sub Execute (
    refNode As TreeListNode
)
public:
virtual void Execute(
    TreeListNode^ refNode
) override
abstract Execute :
        refNode : TreeListNode -> unit
override Execute :
        refNode : TreeListNode -> unit

Parametri

refNode TreeListNode
Vedi anche

Documentazione

Classe ReloadDistNodes
Namespace DedNet.Controls


Metodo ReloadDistNodes.ReloadDistNode

Metodo ReloadDistNodesReloadDistNode
Metodo per aggiornare i nodi figli

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ReloadDistNode(
    TreeListNode node
)
Public Sub ReloadDistNode (
    node As TreeListNode
)
public:
void ReloadDistNode(
    TreeListNode^ node
)
member ReloadDistNode :
        node : TreeListNode -> unit

Parametri

node TreeListNode
Vedi anche

Documentazione

Classe ReloadDistNodes
Namespace DedNet.Controls


Classe RepositoryItemDedComboBox
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
ComponentBase
RepositoryItem
RepositoryItemTextEdit
RepositoryItemButtonEdit
RepositoryItemPopupBase
RepositoryItemPopupBaseAutoSearchEdit
RepositoryItemComboBox
DedNet.ControlsRepositoryItemDedComboBox

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class RepositoryItemDedComboBox : RepositoryItemComboBox
Public Class RepositoryItemDedComboBox
    Inherits RepositoryItemComboBox
public ref class RepositoryItemDedComboBox : public RepositoryItemComboBox
type RepositoryItemDedComboBox =
    class
        inherit RepositoryItemComboBox
    end

Il tipo RepositoryItemDedComboBox espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | RepositoryItemDedComboBox |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AccessibleDefaultActionDescription | (Ereditato da RepositoryItem)
Proprietà pubblica | AccessibleDescription | (Ereditato da RepositoryItem)
Proprietà pubblica | AccessibleName | (Ereditato da RepositoryItem)
Proprietà pubblica | AccessibleRole | (Ereditato da RepositoryItem)
Proprietà pubblica | ActionButtonIndex | (Ereditato da RepositoryItemPopupBase)
Proprietà protetta | ActiveFormat | (Ereditato da RepositoryItem)
Proprietà pubblica | AdvancedModeOptions | (Ereditato da RepositoryItemTextEdit)
Proprietà protetta | AllowCheckExtraKeys | (Ereditato da RepositoryItemPopupBase)
Proprietà protetta | AllowCloseByEscape | (Ereditato da RepositoryItemPopupBase)
Proprietà protetta | AllowClosePopup | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | AllowContextImageChangeAnimation | (Ereditato da RepositoryItemTextEdit)
Proprietà protetta | AllowDefaultClearButtonAction | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | AllowDropDownWhenReadOnly | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | AllowFocused | (Ereditato da RepositoryItem)
Proprietà pubblica | AllowFocusedAppearance | (Ereditato da RepositoryItem)
Proprietà protetta | AllowFormatEditValue | (Ereditato da RepositoryItem)
Proprietà pubblica | AllowGlyphSkinning | (Ereditato da RepositoryItemTextEdit)
Proprietà protetta | AllowHideClearButtonWhenNotFocused | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | AllowHtmlDraw | (Ereditato da RepositoryItem)
Proprietà pubblica | AllowInplaceAutoFilter | (Ereditato da RepositoryItem)
Proprietà pubblica | AllowInplaceBorderPainter | (Ereditato da RepositoryItem)
Proprietà protetta | AllowInputOnOpenPopup | (Ereditato da RepositoryItemPopupBase)
Proprietà protetta | AllowMaskBox | (Ereditato da RepositoryItem)
Proprietà pubblica | AllowMouseWheel | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | AllowNullInput | (Ereditato da RepositoryItemTextEdit)
Proprietà protetta | AllowParseEditValue | (Ereditato da RepositoryItem)
Proprietà protetta | AllowValidateOnEnterKey | (Ereditato da RepositoryItemPopupBase)
Proprietà protetta | AnnotationAttributes | (Ereditato da RepositoryItem)
Proprietà pubblica | Appearance | (Ereditato da RepositoryItem)
Proprietà pubblica | AppearanceDisabled | (Ereditato da RepositoryItem)
Proprietà pubblica | AppearanceDropDown | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | AppearanceFocused | (Ereditato da RepositoryItem)
Proprietà pubblica | AppearanceItemDisabled | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | AppearanceItemHighlight | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | AppearanceItemSelected | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | AppearanceReadOnly | (Ereditato da RepositoryItem)
Proprietà pubblica | AutoComplete | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | AutoHeight | (Ereditato da RepositoryItem)
Proprietà pubblica | BeepOnError | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | BestFitWidth | (Ereditato da RepositoryItem)
Proprietà pubblica | BorderStyle | (Ereditato da RepositoryItem)
Proprietà pubblica | Buttons | (Ereditato da RepositoryItemButtonEdit)
Proprietà pubblica | ButtonsBorderStyle | Obsoleto. (Ereditato da RepositoryItemButtonEdit)
Proprietà pubblica | ButtonsStyle | (Ereditato da RepositoryItemButtonEdit)
Proprietà protetta | CancelPopupInputOnButtonClose | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | CaseSensitiveSearch | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | CharacterCasing | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | CloseUpKey | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | ContextButtonOptions | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | ContextButtons | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | ContextImage | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | ContextImageAlignment | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | ContextImageOptions | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | ContextMenu | (Ereditato da RepositoryItem)
Proprietà pubblica | ContextMenuStrip | (Ereditato da RepositoryItem)
Proprietà pubblica | CycleOnDblClick | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | DefaultAlignment | (Ereditato da RepositoryItem)
Proprietà pubblica | DefaultBorderStyleInBars | (Ereditato da RepositoryItem)
Proprietà pubblica | DefaultBorderStyleInGrid | (Ereditato da RepositoryItem)
Proprietà protetta | DefaultImmediatePopup | (Ereditato da RepositoryItemPopupBaseAutoSearchEdit)
Proprietà protetta | DefaultPopupSizeable | (Ereditato da RepositoryItemPopupBaseAutoSearchEdit)
Proprietà pubblica | DisplayFormat | (Ereditato da RepositoryItem)
Proprietà pubblica | DropDownItemHeight | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | DropDownRows | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | Editable | (Ereditato da RepositoryItem)
Proprietà pubblica | EditFormat | (Ereditato da RepositoryItem)
Proprietà protetta | EditorClassInfo | (Ereditato da RepositoryItem)
Proprietà pubblica | EditorTypeName | (Sovrascrive RepositoryItemComboBox.EditorTypeName)
Proprietà pubblica | EditValueChangedDelay | (Ereditato da RepositoryItem)
Proprietà pubblica | EditValueChangedFiringMode | (Ereditato da RepositoryItem)
Proprietà pubblica | Enabled | (Ereditato da RepositoryItem)
Proprietà pubblica | ExportMode | (Ereditato da RepositoryItem)
Proprietà protetta | ForceDisableButtonOnReadOnly | (Ereditato da RepositoryItemPopupBase)
Proprietà protetta | HasContextButtons | (Ereditato da RepositoryItemPopupBase)
Proprietà protetta | HasEditValueChangingSubscribers | (Ereditato da RepositoryItem)
Proprietà pubblica | HasEffectiveMaskForDisplayFormating | (Ereditato da RepositoryItemTextEdit)
Proprietà protetta | HasMaskSettings | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | HideSelection | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | HighlightedItemStyle | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | HotTrackDropDownItems | Obsoleto. (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | HotTrackItems | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | HtmlImages | (Ereditato da RepositoryItem)
Proprietà pubblica | HtmlTemplates | (Ereditato da RepositoryItemComboBox)
Proprietà protetta | ImageChangingAnimationProvider | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | ImmediatePopup | (Ereditato da RepositoryItemPopupBaseAutoSearchEdit)
Proprietà pubblica | IsClone | (Ereditato da RepositoryItem)
Proprietà protetta | IsContainerLoaded | (Ereditato da RepositoryItem)
Proprietà pubblica | IsDesignMode | (Ereditato da RepositoryItem)
Proprietà pubblica | IsDisposed | (Ereditato da RepositoryItem)
Proprietà pubblica | IsEditValueChangedEventPending | (Ereditato da RepositoryItem)
Proprietà pubblica | IsFilterLookUp | (Ereditato da RepositoryItem)
Proprietà protetta | IsFirstInit | (Ereditato da RepositoryItem)
Proprietà protetta | IsInImageChangingAnimation | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | IsLoading | (Ereditato da RepositoryItem)
Proprietà protetta | IsLockEvents | (Ereditato da RepositoryItem)
Proprietà pubblica | IsLockUpdate | (Ereditato da RepositoryItem)
Proprietà protetta | IsMeasureItemAssigned | (Ereditato da RepositoryItemComboBox)
Proprietà protetta | IsNeededTextKeys | (Ereditato da RepositoryItemButtonEdit)
Proprietà pubblica | IsNonSortableEditor | (Ereditato da RepositoryItem)
Proprietà protetta | IsNowReadOnly | (Ereditato da RepositoryItemPopupBase)
Proprietà protetta | IsNullInputAllowed | (Ereditato da RepositoryItemTextEdit)
Proprietà protetta | IsPasswordBox | (Ereditato da RepositoryItemTextEdit)
Proprietà protetta | IsReadOnlyAllowsDropDown | (Ereditato da RepositoryItemPopupBase)
Proprietà protetta | IsTryGetThreadSafeFuncValid | (Ereditato da RepositoryItemComboBox)
Proprietà protetta | IsUseDisplayFormat | (Ereditato da RepositoryItemButtonEdit)
Proprietà pubblica | ItemAutoHeight | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | ItemPadding | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | Items | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | LinkCount | (Ereditato da RepositoryItem)
Proprietà protetta | Links | (Ereditato da RepositoryItem)
Proprietà protetta | LockDefaultImmediateUpdateRowPosition | (Ereditato da RepositoryItem)
Proprietà protetta | LockFormatParse | (Ereditato da RepositoryItem)
Proprietà pubblica | LookAndFeel | (Ereditato da RepositoryItem)
Proprietà pubblica | Mask | (Ereditato da RepositoryItemPopupBaseAutoSearchEdit)
Proprietà pubblica | MaskBoxPadding | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | MaskSettings | (Ereditato da RepositoryItemPopupBaseAutoSearchEdit)
Proprietà pubblica | MaxLength | (Ereditato da RepositoryItemTextEdit)
Proprietà protetta | MenuHotKey | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | Name | (Ereditato da RepositoryItem)
Proprietà pubblica | NullText | (Ereditato da RepositoryItem)
Proprietà pubblica | NullValuePrompt | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | NullValuePromptForeColor | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | NullValuePromptShowForEmptyValue | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | OwnerEdit | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | OwnerItem | (Ereditato da RepositoryItem)
Proprietà pubblica | Padding | (Ereditato da RepositoryItemTextEdit)
Proprietà protetta | Painter | (Ereditato da RepositoryItem)
Proprietà pubblica | PasswordChar | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | PopupBorderStyle | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | PopupDisplayFormat | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | PopupFormMinSize | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | PopupFormSize | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | PopupFormWidth | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | PopupOffset | (Ereditato da RepositoryItem)
Proprietà pubblica | PopupResizeMode | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | PopupSizeable | (Ereditato da RepositoryItemPopupBaseAutoSearchEdit)
Proprietà protetta | PostponeDelayedEditValueTimer | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | Properties | Obsoleto. (Ereditato da RepositoryItemComboBox)
Proprietà protetta | PropertyStore | (Ereditato da RepositoryItem)
Proprietà pubblica | ReadOnly | (Ereditato da RepositoryItem)
Proprietà pubblica | RequireDisplayTextSorting | (Ereditato da RepositoryItem)
Proprietà protetta | RequireFakeDesigner | (Ereditato da RepositoryItem)
Proprietà pubblica | ResetTextEditStyleToStandardInFilterControl | (Ereditato da RepositoryItemButtonEdit)
Proprietà protetta | ShouldCreateMaskSettingsWhenMaskLoadedOrUpdated | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | ShowDropDown | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | ShowNullValuePrompt | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | ShowNullValuePromptWhenFocused | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | ShowNullValuePromptWhenReadOnly | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | ShowPopupShadow | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | ShowToolTipForTrimmedText | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | Site | (Ereditato da RepositoryItem)
Proprietà pubblica | Sorted | (Ereditato da RepositoryItemComboBox)
Proprietà protetta | StyleController | (Ereditato da RepositoryItem)
Proprietà pubblica | SuppressMouseEventOnOuterMouseClick | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | Tag | (Ereditato da RepositoryItem)
Proprietà pubblica | TextEditStyle | (Ereditato da RepositoryItemButtonEdit)
Proprietà protetta | UpdateEditValueFromPopup | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | UseAdvancedMode | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | UseCtrlScroll | (Ereditato da RepositoryItemComboBox)
Proprietà protetta | UseDisplayTextAsNullValuePrompt | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | UseMaskAsDisplayFormat | (Ereditato da RepositoryItemPopupBaseAutoSearchEdit)
Proprietà protetta | UseMaskBox | (Ereditato da RepositoryItemTextEdit)
Proprietà protetta | UseMaskedInput | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | UseParentBackground | (Ereditato da RepositoryItem)
Proprietà pubblica | UseReadOnlyAppearance | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | UseSystemPasswordChar | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | UseTextEditorForAutoFilter | (Ereditato da RepositoryItemButtonEdit)
Proprietà pubblica | ValidateOnEnterKey | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | XlsxFormatString | (Ereditato da RepositoryItemTextEdit)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | AcceptModifiedEditValueTextAsEditValue | (Ereditato da RepositoryItemPopupBaseAutoSearchEdit)
Metodo protetto | AcceptSearchTextAsEditValue | (Ereditato da RepositoryItemPopupBaseAutoSearchEdit)
Metodo protetto | ActivationKeysContains | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | AddImageSourceToPrintCache(PrintingSystemBase, MultiKey, SvgImage) | (Ereditato da RepositoryItem)
Metodo protetto | AddImageSourceToPrintCache(PrintingSystemBase, MultiKey, Image) | (Ereditato da RepositoryItem)
Metodo protetto | AddImageSourceToPrintCache(PrintingSystemBase, MultiKey, Object, Int32) | (Ereditato da RepositoryItem)
Metodo protetto | AddImageToPrintCache | (Ereditato da RepositoryItem)
Metodo protetto | AllowMaskManagerType | (Ereditato da RepositoryItemPopupBase)
Metodo pubblico | Assign | (Sovrascrive RepositoryItemComboBox.Assign(RepositoryItem))
Metodo protetto | AssignEvents | (Ereditato da RepositoryItemComboBox)
Metodo protetto | AssignMasks | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | AssignNullValuePromptSettings | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | AssignOwnerEditEvents | (Ereditato da RepositoryItem)
Metodo protetto | AssignTextBrickFormatSettings | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | AssignTextBrickText | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | BeginInit | (Ereditato da RepositoryItemComboBox)
Metodo pubblico | BeginUpdate | (Ereditato da RepositoryItem)
Metodo protetto | BreakAnimations | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | CalcPaddingInfo | (Ereditato da RepositoryItem)
Metodo protetto | CalcPasswordCharMaskedText | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | CancelUpdate | (Ereditato da RepositoryItem)
Metodo protetto | CanEditNumericValueType | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | Clone | (Ereditato da RepositoryItem)
Metodo protetto | CompleteChanges | (Ereditato da RepositoryItem)
Metodo pubblico | Connect | (Ereditato da RepositoryItem)
Metodo protetto | ConvertTextFilterValue | (Ereditato da RepositoryItem)
Metodo protetto | CreateAccessibleInstance | (Ereditato da RepositoryItem)
Metodo protetto | CreateAdvancedModeOptions | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | CreateAppearance | (Ereditato da RepositoryItem)
Metodo protetto | CreateAppearanceCore | (Ereditato da RepositoryItem)
Metodo protetto | CreateBrickStyle | (Ereditato da RepositoryItem)
Metodo protetto | CreateButtonCollection | (Ereditato da RepositoryItemButtonEdit)
Metodo protetto | CreateContextButtonOptions | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | CreateContextButtonsCollection | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | CreateContextImageOptions | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | CreateDefaultButton | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | CreateDefaultMaskManager | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | CreateDefaultMaskManagerCore | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | CreateDisplayFormat | (Ereditato da RepositoryItem)
Metodo protetto | CreateEditFormat | (Ereditato da RepositoryItem)
Metodo pubblico | CreateEditor | (Ereditato da RepositoryItem)
Metodo pubblico | CreateGroupPainter | (Ereditato da RepositoryItem)
Metodo protetto | CreateHtmlTemplates | (Ereditato da RepositoryItemComboBox)
Metodo protetto | CreateImageBrick | (Ereditato da RepositoryItem)
Metodo protetto | CreateItemCollection | (Ereditato da RepositoryItemComboBox)
Metodo protetto | CreateLookAndFeel | (Ereditato da RepositoryItem)
Metodo protetto | CreateMaskManager | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | CreateMaskProperties | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | CreateMaskSettings | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | CreateOwnerEditLookAndFeel | (Ereditato da RepositoryItem)
Metodo pubblico | CreatePainter | (Ereditato da RepositoryItem)
Metodo protetto | CreatePanelBrick(PrintCellHelperInfo, Boolean) | (Ereditato da RepositoryItem)
Metodo protetto | CreatePanelBrick(PrintCellHelperInfo, Boolean, BrickStyle) | (Ereditato da RepositoryItem)
Metodo protetto | CreatePopupDisplayFormat | (Ereditato da RepositoryItemComboBox)
Metodo protetto | CreateRepositoryItem | (Ereditato da RepositoryItem)
Metodo protetto | CreateTextBrick | (Ereditato da RepositoryItem)
Metodo pubblico | CreateViewInfo | (Ereditato da RepositoryItem)
Metodo protetto | DenyStandardTextEditStyle | (Ereditato da RepositoryItemButtonEdit)
Metodo protetto | DestroyAppearance | (Ereditato da RepositoryItem)
Metodo protetto | DestroyAppearances | (Ereditato da RepositoryItemComboBox)
Metodo protetto | DestroyLookAndFeel | (Ereditato da RepositoryItem)
Metodo protetto | DestroyStyles | Obsoleto. (Ereditato da RepositoryItem)
Metodo pubblico | Disconnect | (Ereditato da RepositoryItem)
Metodo protetto | Dispose | (Ereditato da RepositoryItemComboBox)
Metodo protetto | DisposePrevContextImage | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | DoFormatEditValue(Object) | (Ereditato da RepositoryItem)
Metodo protetto | DoFormatEditValue(Object, Boolean) | (Ereditato da RepositoryItem)
Metodo protetto | DoParseEditValue(Object) | (Ereditato da RepositoryItem)
Metodo protetto | DoParseEditValue(Object, Boolean) | (Ereditato da RepositoryItem)
Metodo pubblico | EditMaskSettings(Object) | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | EditMaskSettings(IWin32Window, Object) | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | EditMaskSettings(IWindowsFormsEditorService, Object) | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | EnableCustomMaskTextInput | (Ereditato da RepositoryItemPopupBaseAutoSearchEdit)
Metodo pubblico | EnableNonMaskedInput | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | EndInit | (Ereditato da RepositoryItemComboBox)
Metodo pubblico | EndUpdate | (Ereditato da RepositoryItem)
Metodo protetto | EnsureMaskSettings | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | FilterProperties | (Ereditato da RepositoryItem)
Metodo protetto | FireChanged | (Ereditato da RepositoryItem)
Metodo protetto | FireChangedFromRepository | (Ereditato da RepositoryItem)
Metodo protetto | FireContainerLoaded | (Ereditato da RepositoryItem)
Metodo protetto | ForceDisplayTextAsNullValuePrompt | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da RepositoryItem)
Metodo protetto | GetAllowContextImageChangeAnimation | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetAllowGlyphSkinning | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetAllowHtmlDraw | (Ereditato da RepositoryItem)
Metodo pubblico | GetBrick | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetBrickImageSource | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetCachedPrintImage | (Ereditato da RepositoryItem)
Metodo protetto | GetCachedPrintImageSource | (Ereditato da RepositoryItem)
Metodo protetto | GetCustomMaskTextInputTag | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetDefaultEditMask | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetDefaultMaskManagerType | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetDesiredPopupFormSize | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | GetDisableTextEditorAsDefaultValue | (Ereditato da RepositoryItemButtonEdit)
Metodo pubblico | GetDisplayText(Object) | (Ereditato da RepositoryItem)
Metodo pubblico | GetDisplayText(FormatInfo, Object) | (Ereditato da RepositoryItemComboBox)
Metodo pubblico | GetEditorType | (Ereditato da RepositoryItem)
Metodo protetto | GetEditValueForExport | (Ereditato da RepositoryItem)
Metodo pubblico | GetEditValueForExportByOptions | (Ereditato da RepositoryItem)
Metodo protetto | GetEventSender | (Ereditato da RepositoryItem)
Metodo protetto | GetExportMode | (Ereditato da RepositoryItemComboBox)
Metodo protetto | GetFormattedDisplayText | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | GetHashCode | (Ereditato da RepositoryItem)
Metodo protetto | GetInPanelrect | (Ereditato da RepositoryItem)
Metodo protetto | GetKeyIncludeCtrlScroll | (Ereditato da RepositoryItemComboBox)
Metodo protetto | GetNullEditText | (Ereditato da RepositoryItemButtonEdit)
Metodo protetto | GetNullText | (Ereditato da RepositoryItem)
Metodo protetto | GetNullValuePrompt | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetOrAddImageSource(PrintingSystemBase, MultiKey, SvgImage) | (Ereditato da RepositoryItem)
Metodo protetto | GetOrAddImageSource(PrintingSystemBase, MultiKey, Image) | (Ereditato da RepositoryItem)
Metodo protetto | GetOrAddImageSource(PrintingSystemBase, MultiKey, Object, Int32) | (Ereditato da RepositoryItem)
Metodo protetto | GetOverrideAppearance | (Ereditato da RepositoryItem)
Metodo protetto | GetPasswordCharCore | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetPrevContextImage | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetSender | (Ereditato da RepositoryItem)
Metodo protetto | GetTextFilterCapabilities | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetUseMaskAsDisplayFormat | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | InitializeEditMaskFromDisplayTextService | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | IsActivateKey | (Ereditato da RepositoryItem)
Metodo protetto | IsButtonEnabled | (Ereditato da RepositoryItemPopupBase)
Metodo pubblico | IsDefault | (Ereditato da RepositoryItem)
Metodo protetto | IsEmptyValue | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | IsFormatTypeCustom | (Ereditato da RepositoryItem)
Metodo protetto | IsListBoxKey | (Ereditato da RepositoryItemComboBox)
Metodo pubblico | IsLockDefaultImmediateUpdateRowPosition | (Ereditato da RepositoryItem)
Metodo protetto | IsNeededChar | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | IsNeededKey | (Ereditato da RepositoryItem)
Metodo protetto | IsNeededKeyCore | (Ereditato da RepositoryItemComboBox)
Metodo protetto | IsNullValue | (Ereditato da RepositoryItem)
Metodo protetto | IsStandardTextEditStyle | (Ereditato da RepositoryItemButtonEdit)
Metodo pubblico | LockEvents | (Ereditato da RepositoryItem)
Metodo pubblico | MarkAsClone | (Ereditato da RepositoryItem)
Metodo protetto | NeededKeysContains | (Ereditato da RepositoryItemComboBox)
Metodo protetto | NeededKeysPopupContains | (Ereditato da RepositoryItemComboBox)
Metodo protetto | OnAllowFocusedChanged | (Ereditato da RepositoryItem)
Metodo protetto | OnAnnotationAttributesLoad | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnAppearanceChanged | (Ereditato da RepositoryItem)
Metodo protetto | OnAppearancePaintChanged | (Ereditato da RepositoryItem)
Metodo protetto | OnAppearanceSizeChanged | (Ereditato da RepositoryItem)
Metodo protetto | OnAutoHeightChanged | (Ereditato da RepositoryItem)
Metodo protetto | OnButtons_CollectionChanged | (Ereditato da RepositoryItemButtonEdit)
Metodo protetto | OnContainerLoaded | (Ereditato da RepositoryItem)
Metodo protetto | OnContextImageChanged | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnContextImageChanging | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnContextImageOptionsChanged | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnContextImageOptionsChanging | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnEnabledChanged | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnFormat_Changed | (Ereditato da RepositoryItemComboBox)
Metodo protetto | OnItems_CollectionChanged | (Ereditato da RepositoryItemComboBox)
Metodo protetto | OnLoaded | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnMaskChanged | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnMaskSettingsChanged | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnOwnerEditChanged | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnPopupFormSizeChanged | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | OnPropertiesChanged | (Ereditato da RepositoryItem)
Metodo protetto | OnPropertiesChanged(EventArgs) | (Ereditato da RepositoryItem)
Metodo protetto | OnStyleChanged | (Ereditato da RepositoryItem)
Metodo protetto | OnTextEditStyleChanged | (Ereditato da RepositoryItemButtonEdit)
Metodo protetto | OnUpdateMaskSettings | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | PreparePrintViewInfo(PrintCellHelperInfo, Boolean) | (Ereditato da RepositoryItem)
Metodo protetto | PreparePrintViewInfo(PrintCellHelperInfo, BaseEditViewInfo, Boolean) | (Ereditato da RepositoryItem)
Metodo protetto | RaiseBeforePopup | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | RaiseBeforeShowMenu | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | RaiseButtonClick | (Ereditato da RepositoryItemButtonEdit)
Metodo protetto | RaiseButtonPressed | (Ereditato da RepositoryItemButtonEdit)
Metodo protetto | RaiseClosed | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | RaiseCloseUp | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | RaiseContextButtonClick | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | RaiseContextButtonValueChanged | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | RaiseCustomDisplayText(CustomDisplayTextEventArgs) | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | RaiseCustomDisplayText(Object, String) | (Ereditato da RepositoryItem)
Metodo protetto | RaiseCustomDisplayText(FormatInfo, Object, String) | (Ereditato da RepositoryItem)
Metodo protetto | RaiseCustomDrawButton | (Ereditato da RepositoryItemButtonEdit)
Metodo protetto | RaiseCustomHighlightText | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | RaiseCustomItemDisplayText | (Ereditato da RepositoryItemComboBox)
Metodo protetto | RaiseCustomItemTemplate | (Ereditato da RepositoryItemComboBox)
Metodo protetto | RaiseCustomizeAutoCompleteSource | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | RaiseCustomizeContextItem | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | RaiseCustomizeItem | (Ereditato da RepositoryItemComboBox)
Metodo protetto | RaiseCustomTextLineHeight | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | RaiseDropDownCustomDrawItem | (Ereditato da RepositoryItemComboBox)
Metodo protetto | RaiseEditValueChanged | (Ereditato da RepositoryItem)
Metodo protetto | RaiseEditValueChangedCore | (Ereditato da RepositoryItem)
Metodo protetto | RaiseEditValueChanging | (Ereditato da RepositoryItem)
Metodo protetto | RaiseFormatEditValue | (Ereditato da RepositoryItem)
Metodo protetto | RaiseHtmlElementMouseClick | (Ereditato da RepositoryItemComboBox)
Metodo protetto | RaiseHtmlElementMouseDown | (Ereditato da RepositoryItemComboBox)
Metodo protetto | RaiseHtmlElementMouseUp | (Ereditato da RepositoryItemComboBox)
Metodo protetto | RaiseMeasureItem | (Ereditato da RepositoryItemComboBox)
Metodo protetto | RaiseModified | (Ereditato da RepositoryItem)
Metodo protetto | RaiseParseEditValue | (Ereditato da RepositoryItem)
Metodo protetto | RaisePopup | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | RaisePopupAllowClick | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | RaisePropertiesChanged | (Ereditato da RepositoryItem)
Metodo protetto | RaiseQueryAccessibilityHelp | (Ereditato da RepositoryItem)
Metodo protetto | RaiseQueryCloseUp | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | RaiseQueryPopUp | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | RaiseQueryProcessKey | (Ereditato da RepositoryItem)
Metodo protetto | RaiseRefreshRequired | (Ereditato da RepositoryItem)
Metodo protetto | RaiseSelectedIndexChanged | (Ereditato da RepositoryItemComboBox)
Metodo protetto | RaiseSelectedValueChanged | (Ereditato da RepositoryItemComboBox)
Metodo protetto | RaiseSpin | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | RecreateMaskManagerOnIsNullInputAllowedChanged | (Ereditato da RepositoryItemTextEdit)
 | RegisterDedComboBox |
Metodo protetto | ResetAccessibleDescription | (Ereditato da RepositoryItem)
Metodo protetto | ResetAccessibleName | (Ereditato da RepositoryItem)
Metodo protetto | ResetAutoHeight | (Ereditato da RepositoryItem)
Metodo protetto | ResetDefaultMaskManager | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | ResetDropDownRows | (Ereditato da RepositoryItemComboBox)
Metodo pubblico | ResetEvents | (Ereditato da RepositoryItem)
Metodo pubblico | ResetMaskSettings | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | ResetNullText | (Ereditato da RepositoryItem)
Metodo protetto | ResetNullValuePrompt | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | ResetPopupFormMinSize | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | ResetPopupFormSize | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | ResetTextEditStyle | (Ereditato da RepositoryItemButtonEdit)
Metodo pubblico | ScaleProperties | (Ereditato da RepositoryItem)
Metodo protetto | ScalePropertiesCore | (Ereditato da RepositoryItemComboBox)
Metodo pubblico | SetCloned | (Ereditato da RepositoryItem)
Metodo protetto | SetCommonBrickProperties | (Ereditato da RepositoryItem)
Metodo protetto | SetOwnerEdit | (Ereditato da RepositoryItem)
Metodo protetto | SetTextBrickPropertiesCore | (Ereditato da RepositoryItem)
Metodo protetto | SetupCommonBrickStyleProperties | (Ereditato da RepositoryItem)
Metodo protetto | SetupTextBrickStyleProperties | (Ereditato da RepositoryItem)
Metodo protetto | ShouldRaiseCustomDisplayText | (Ereditato da RepositoryItem)
Metodo protetto | ShouldSerializeAccessibleDescription | (Ereditato da RepositoryItem)
Metodo protetto | ShouldSerializeAccessibleName | (Ereditato da RepositoryItem)
Metodo protetto | ShouldSerializeAutoHeight | (Ereditato da RepositoryItem)
Metodo protetto | ShouldSerializeDropDownRows | (Ereditato da RepositoryItemComboBox)
Metodo protetto | ShouldSerializeItems | (Ereditato da RepositoryItemComboBox)
Metodo pubblico | ShouldSerializeMaskSettings | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | ShouldSerializeNullText | (Ereditato da RepositoryItem)
Metodo protetto | ShouldSerializeNullValuePrompt | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | ShouldSerializePopupFormMinSize | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | ShouldSerializePopupFormSize | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | ShouldSerializeTextEditStyle | (Ereditato da RepositoryItemButtonEdit)
Metodo protetto | StartContextImageChangingAnimation | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | SwitchMode | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | ThrowItemNotInRepositoryWarning | (Ereditato da RepositoryItem)
Metodo pubblico | ToString | (Ereditato da RepositoryItem)
Metodo protetto | ToStringTrimming | (Ereditato da RepositoryItem)
Metodo protetto | TriggerDelayedEditValueChanged | (Ereditato da RepositoryItem)
Metodo protetto | TriggerDelayedEditValueChanged(EventArgs) | (Ereditato da RepositoryItem)
Metodo protetto | TryGetThreadSafeDoFormatEditValueFunc | (Ereditato da RepositoryItem)
Metodo protetto | TryGetThreadSafeGetDisplayTextFunc | (Ereditato da RepositoryItem)
Metodo protetto | TryGetThreadSafeGetFormattedDisplayTextFunc | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | TryGetThreadSafeIsNullValueFunc | (Ereditato da RepositoryItem)
Metodo protetto | TryGetThreadSafeRaiseCustomDisplayTextFunc | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | UnLockEvents | (Ereditato da RepositoryItem)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | BeforePopup | (Ereditato da RepositoryItemPopupBase)
Evento pubblico | BeforeShowMenu | (Ereditato da RepositoryItemTextEdit)
Evento pubblico | ButtonClick | (Ereditato da RepositoryItemButtonEdit)
Evento pubblico | ButtonPressed | (Ereditato da RepositoryItemButtonEdit)
Evento pubblico | Click | (Ereditato da RepositoryItem)
Evento pubblico | Closed | (Ereditato da RepositoryItemPopupBase)
Evento pubblico | CloseUp | (Ereditato da RepositoryItemPopupBase)
Evento pubblico | ContextButtonClick | (Ereditato da RepositoryItemPopupBase)
Evento pubblico | ContextButtonValueChanged | (Ereditato da RepositoryItemPopupBase)
Evento pubblico | CustomDisplayText | (Ereditato da RepositoryItem)
Evento pubblico | CustomDrawButton | (Ereditato da RepositoryItemButtonEdit)
Evento pubblico | CustomHighlightText | (Ereditato da RepositoryItemTextEdit)
Evento pubblico | CustomItemDisplayText | (Ereditato da RepositoryItemComboBox)
Evento pubblico | CustomItemTemplate | (Ereditato da RepositoryItemComboBox)
Evento pubblico | CustomizeAutoCompleteSource | (Ereditato da RepositoryItemTextEdit)
Evento pubblico | CustomizeContextItem | (Ereditato da RepositoryItemPopupBase)
Evento pubblico | CustomizeItem | (Ereditato da RepositoryItemComboBox)
Evento pubblico | CustomTextLineHeight | (Ereditato da RepositoryItemTextEdit)
Evento pubblico | DoubleClick | (Ereditato da RepositoryItem)
Evento pubblico | DragDrop | (Ereditato da RepositoryItem)
Evento pubblico | DragEnter | (Ereditato da RepositoryItem)
Evento pubblico | DragLeave | (Ereditato da RepositoryItem)
Evento pubblico | DragOver | (Ereditato da RepositoryItem)
Evento pubblico | DrawItem | (Ereditato da RepositoryItemComboBox)
Evento pubblico | DropDownCustomDrawItem | Obsoleto. (Ereditato da RepositoryItemComboBox)
Evento pubblico | EditValueChanged | (Ereditato da RepositoryItem)
Evento pubblico | EditValueChanging | (Ereditato da RepositoryItem)
Evento pubblico | Enter | (Ereditato da RepositoryItem)
Evento pubblico | FormatEditValue | (Ereditato da RepositoryItem)
Evento pubblico | GiveFeedback | (Ereditato da RepositoryItem)
Evento pubblico | HelpRequested | (Ereditato da RepositoryItem)
Evento pubblico | HtmlElementMouseClick | (Ereditato da RepositoryItemComboBox)
Evento pubblico | HtmlElementMouseDown | (Ereditato da RepositoryItemComboBox)
Evento pubblico | HtmlElementMouseUp | (Ereditato da RepositoryItemComboBox)
Evento pubblico | KeyDown | (Ereditato da RepositoryItem)
Evento pubblico | KeyPress | (Ereditato da RepositoryItem)
Evento pubblico | KeyUp | (Ereditato da RepositoryItem)
Evento pubblico | Leave | (Ereditato da RepositoryItem)
Evento pubblico | MeasureItem | (Ereditato da RepositoryItemComboBox)
Evento pubblico | Modified | (Ereditato da RepositoryItem)
Evento pubblico | MouseDown | (Ereditato da RepositoryItem)
Evento pubblico | MouseEnter | (Ereditato da RepositoryItem)
Evento pubblico | MouseHover | (Ereditato da RepositoryItem)
Evento pubblico | MouseLeave | (Ereditato da RepositoryItem)
Evento pubblico | MouseMove | (Ereditato da RepositoryItem)
Evento pubblico | MouseUp | (Ereditato da RepositoryItem)
Evento pubblico | MouseWheel | (Ereditato da RepositoryItem)
Evento pubblico | ParseEditValue | (Ereditato da RepositoryItem)
Evento pubblico | Popup | (Ereditato da RepositoryItemPopupBase)
Evento pubblico | PopupAllowClick | (Ereditato da RepositoryItemPopupBase)
Evento pubblico | PropertiesChanged | (Ereditato da RepositoryItem)
Evento pubblico | QueryAccessibilityHelp | (Ereditato da RepositoryItem)
Evento pubblico | QueryCloseUp | (Ereditato da RepositoryItemPopupBase)
Evento pubblico | QueryContinueDrag | (Ereditato da RepositoryItem)
Evento pubblico | QueryPopUp | (Ereditato da RepositoryItemPopupBase)
Evento pubblico | QueryProcessKey | (Ereditato da RepositoryItem)
Evento pubblico | SelectedIndexChanged | (Ereditato da RepositoryItemComboBox)
Evento pubblico | SelectedValueChanged | (Ereditato da RepositoryItemComboBox)
Evento pubblico | Spin | (Ereditato da RepositoryItemTextEdit)
Evento pubblico | Validating | (Ereditato da RepositoryItem)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | Cloned | (Ereditato da RepositoryItem)
 | CustomEditName |
Campo protetto | fAllowFocused | (Ereditato da RepositoryItem)
Campo protetto | fAllowMouseWheel | (Ereditato da RepositoryItem)
Campo protetto | fAutoComplete | (Ereditato da RepositoryItemComboBox)
Campo protetto | fAutoHeight | (Ereditato da RepositoryItem)
Campo protetto | fBorderStyle | (Ereditato da RepositoryItem)
Campo protetto | fButtonsStyle | (Ereditato da RepositoryItemButtonEdit)
Campo protetto | fCaseSensitiveSearch | (Ereditato da RepositoryItemComboBox)
Campo protetto | fCharacterCasing | (Ereditato da RepositoryItemTextEdit)
Campo protetto | fCycleOnDblClick | (Ereditato da RepositoryItemComboBox)
Campo protetto | fEditValueChangedFiringMode | (Ereditato da RepositoryItem)
Campo protetto | fEnabled | (Ereditato da RepositoryItem)
Campo protetto | fLockFormatParse | (Ereditato da RepositoryItem)
Campo protetto | fMaxLength | (Ereditato da RepositoryItemTextEdit)
Campo protetto | fNullText | (Ereditato da RepositoryItem)
Campo protetto | fPainter | (Ereditato da RepositoryItem)
Campo protetto | fPasswordChar | (Ereditato da RepositoryItemTextEdit)
Campo protetto | fReadOnly | (Ereditato da RepositoryItem)
Campo protetto | fTextEditStyle | (Ereditato da RepositoryItemButtonEdit)
Campo protetto | fUseCtrlScroll | (Ereditato da RepositoryItemComboBox)
Campo protetto | fValidateOnEnterKey | (Ereditato da RepositoryItemTextEdit)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore RepositoryItemDedComboBox

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public RepositoryItemDedComboBox()
Public Sub New
public:
RepositoryItemDedComboBox()
new : unit -> RepositoryItemDedComboBox
Vedi anche

Documentazione

Classe RepositoryItemDedComboBox
Namespace DedNet.Controls


Proprietà di RepositoryItemDedComboBox

Il tipo RepositoryItemDedComboBox espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AccessibleDefaultActionDescription | (Ereditato da RepositoryItem)
Proprietà pubblica | AccessibleDescription | (Ereditato da RepositoryItem)
Proprietà pubblica | AccessibleName | (Ereditato da RepositoryItem)
Proprietà pubblica | AccessibleRole | (Ereditato da RepositoryItem)
Proprietà pubblica | ActionButtonIndex | (Ereditato da RepositoryItemPopupBase)
Proprietà protetta | ActiveFormat | (Ereditato da RepositoryItem)
Proprietà pubblica | AdvancedModeOptions | (Ereditato da RepositoryItemTextEdit)
Proprietà protetta | AllowCheckExtraKeys | (Ereditato da RepositoryItemPopupBase)
Proprietà protetta | AllowCloseByEscape | (Ereditato da RepositoryItemPopupBase)
Proprietà protetta | AllowClosePopup | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | AllowContextImageChangeAnimation | (Ereditato da RepositoryItemTextEdit)
Proprietà protetta | AllowDefaultClearButtonAction | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | AllowDropDownWhenReadOnly | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | AllowFocused | (Ereditato da RepositoryItem)
Proprietà pubblica | AllowFocusedAppearance | (Ereditato da RepositoryItem)
Proprietà protetta | AllowFormatEditValue | (Ereditato da RepositoryItem)
Proprietà pubblica | AllowGlyphSkinning | (Ereditato da RepositoryItemTextEdit)
Proprietà protetta | AllowHideClearButtonWhenNotFocused | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | AllowHtmlDraw | (Ereditato da RepositoryItem)
Proprietà pubblica | AllowInplaceAutoFilter | (Ereditato da RepositoryItem)
Proprietà pubblica | AllowInplaceBorderPainter | (Ereditato da RepositoryItem)
Proprietà protetta | AllowInputOnOpenPopup | (Ereditato da RepositoryItemPopupBase)
Proprietà protetta | AllowMaskBox | (Ereditato da RepositoryItem)
Proprietà pubblica | AllowMouseWheel | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | AllowNullInput | (Ereditato da RepositoryItemTextEdit)
Proprietà protetta | AllowParseEditValue | (Ereditato da RepositoryItem)
Proprietà protetta | AllowValidateOnEnterKey | (Ereditato da RepositoryItemPopupBase)
Proprietà protetta | AnnotationAttributes | (Ereditato da RepositoryItem)
Proprietà pubblica | Appearance | (Ereditato da RepositoryItem)
Proprietà pubblica | AppearanceDisabled | (Ereditato da RepositoryItem)
Proprietà pubblica | AppearanceDropDown | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | AppearanceFocused | (Ereditato da RepositoryItem)
Proprietà pubblica | AppearanceItemDisabled | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | AppearanceItemHighlight | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | AppearanceItemSelected | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | AppearanceReadOnly | (Ereditato da RepositoryItem)
Proprietà pubblica | AutoComplete | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | AutoHeight | (Ereditato da RepositoryItem)
Proprietà pubblica | BeepOnError | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | BestFitWidth | (Ereditato da RepositoryItem)
Proprietà pubblica | BorderStyle | (Ereditato da RepositoryItem)
Proprietà pubblica | Buttons | (Ereditato da RepositoryItemButtonEdit)
Proprietà pubblica | ButtonsBorderStyle | Obsoleto. (Ereditato da RepositoryItemButtonEdit)
Proprietà pubblica | ButtonsStyle | (Ereditato da RepositoryItemButtonEdit)
Proprietà protetta | CancelPopupInputOnButtonClose | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | CaseSensitiveSearch | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | CharacterCasing | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | CloseUpKey | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | ContextButtonOptions | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | ContextButtons | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | ContextImage | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | ContextImageAlignment | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | ContextImageOptions | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | ContextMenu | (Ereditato da RepositoryItem)
Proprietà pubblica | ContextMenuStrip | (Ereditato da RepositoryItem)
Proprietà pubblica | CycleOnDblClick | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | DefaultAlignment | (Ereditato da RepositoryItem)
Proprietà pubblica | DefaultBorderStyleInBars | (Ereditato da RepositoryItem)
Proprietà pubblica | DefaultBorderStyleInGrid | (Ereditato da RepositoryItem)
Proprietà protetta | DefaultImmediatePopup | (Ereditato da RepositoryItemPopupBaseAutoSearchEdit)
Proprietà protetta | DefaultPopupSizeable | (Ereditato da RepositoryItemPopupBaseAutoSearchEdit)
Proprietà pubblica | DisplayFormat | (Ereditato da RepositoryItem)
Proprietà pubblica | DropDownItemHeight | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | DropDownRows | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | Editable | (Ereditato da RepositoryItem)
Proprietà pubblica | EditFormat | (Ereditato da RepositoryItem)
Proprietà protetta | EditorClassInfo | (Ereditato da RepositoryItem)
Proprietà pubblica | EditorTypeName | (Sovrascrive RepositoryItemComboBox.EditorTypeName)
Proprietà pubblica | EditValueChangedDelay | (Ereditato da RepositoryItem)
Proprietà pubblica | EditValueChangedFiringMode | (Ereditato da RepositoryItem)
Proprietà pubblica | Enabled | (Ereditato da RepositoryItem)
Proprietà pubblica | ExportMode | (Ereditato da RepositoryItem)
Proprietà protetta | ForceDisableButtonOnReadOnly | (Ereditato da RepositoryItemPopupBase)
Proprietà protetta | HasContextButtons | (Ereditato da RepositoryItemPopupBase)
Proprietà protetta | HasEditValueChangingSubscribers | (Ereditato da RepositoryItem)
Proprietà pubblica | HasEffectiveMaskForDisplayFormating | (Ereditato da RepositoryItemTextEdit)
Proprietà protetta | HasMaskSettings | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | HideSelection | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | HighlightedItemStyle | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | HotTrackDropDownItems | Obsoleto. (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | HotTrackItems | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | HtmlImages | (Ereditato da RepositoryItem)
Proprietà pubblica | HtmlTemplates | (Ereditato da RepositoryItemComboBox)
Proprietà protetta | ImageChangingAnimationProvider | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | ImmediatePopup | (Ereditato da RepositoryItemPopupBaseAutoSearchEdit)
Proprietà pubblica | IsClone | (Ereditato da RepositoryItem)
Proprietà protetta | IsContainerLoaded | (Ereditato da RepositoryItem)
Proprietà pubblica | IsDesignMode | (Ereditato da RepositoryItem)
Proprietà pubblica | IsDisposed | (Ereditato da RepositoryItem)
Proprietà pubblica | IsEditValueChangedEventPending | (Ereditato da RepositoryItem)
Proprietà pubblica | IsFilterLookUp | (Ereditato da RepositoryItem)
Proprietà protetta | IsFirstInit | (Ereditato da RepositoryItem)
Proprietà protetta | IsInImageChangingAnimation | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | IsLoading | (Ereditato da RepositoryItem)
Proprietà protetta | IsLockEvents | (Ereditato da RepositoryItem)
Proprietà pubblica | IsLockUpdate | (Ereditato da RepositoryItem)
Proprietà protetta | IsMeasureItemAssigned | (Ereditato da RepositoryItemComboBox)
Proprietà protetta | IsNeededTextKeys | (Ereditato da RepositoryItemButtonEdit)
Proprietà pubblica | IsNonSortableEditor | (Ereditato da RepositoryItem)
Proprietà protetta | IsNowReadOnly | (Ereditato da RepositoryItemPopupBase)
Proprietà protetta | IsNullInputAllowed | (Ereditato da RepositoryItemTextEdit)
Proprietà protetta | IsPasswordBox | (Ereditato da RepositoryItemTextEdit)
Proprietà protetta | IsReadOnlyAllowsDropDown | (Ereditato da RepositoryItemPopupBase)
Proprietà protetta | IsTryGetThreadSafeFuncValid | (Ereditato da RepositoryItemComboBox)
Proprietà protetta | IsUseDisplayFormat | (Ereditato da RepositoryItemButtonEdit)
Proprietà pubblica | ItemAutoHeight | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | ItemPadding | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | Items | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | LinkCount | (Ereditato da RepositoryItem)
Proprietà protetta | Links | (Ereditato da RepositoryItem)
Proprietà protetta | LockDefaultImmediateUpdateRowPosition | (Ereditato da RepositoryItem)
Proprietà protetta | LockFormatParse | (Ereditato da RepositoryItem)
Proprietà pubblica | LookAndFeel | (Ereditato da RepositoryItem)
Proprietà pubblica | Mask | (Ereditato da RepositoryItemPopupBaseAutoSearchEdit)
Proprietà pubblica | MaskBoxPadding | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | MaskSettings | (Ereditato da RepositoryItemPopupBaseAutoSearchEdit)
Proprietà pubblica | MaxLength | (Ereditato da RepositoryItemTextEdit)
Proprietà protetta | MenuHotKey | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | Name | (Ereditato da RepositoryItem)
Proprietà pubblica | NullText | (Ereditato da RepositoryItem)
Proprietà pubblica | NullValuePrompt | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | NullValuePromptForeColor | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | NullValuePromptShowForEmptyValue | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | OwnerEdit | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | OwnerItem | (Ereditato da RepositoryItem)
Proprietà pubblica | Padding | (Ereditato da RepositoryItemTextEdit)
Proprietà protetta | Painter | (Ereditato da RepositoryItem)
Proprietà pubblica | PasswordChar | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | PopupBorderStyle | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | PopupDisplayFormat | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | PopupFormMinSize | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | PopupFormSize | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | PopupFormWidth | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | PopupOffset | (Ereditato da RepositoryItem)
Proprietà pubblica | PopupResizeMode | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | PopupSizeable | (Ereditato da RepositoryItemPopupBaseAutoSearchEdit)
Proprietà protetta | PostponeDelayedEditValueTimer | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | Properties | Obsoleto. (Ereditato da RepositoryItemComboBox)
Proprietà protetta | PropertyStore | (Ereditato da RepositoryItem)
Proprietà pubblica | ReadOnly | (Ereditato da RepositoryItem)
Proprietà pubblica | RequireDisplayTextSorting | (Ereditato da RepositoryItem)
Proprietà protetta | RequireFakeDesigner | (Ereditato da RepositoryItem)
Proprietà pubblica | ResetTextEditStyleToStandardInFilterControl | (Ereditato da RepositoryItemButtonEdit)
Proprietà protetta | ShouldCreateMaskSettingsWhenMaskLoadedOrUpdated | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | ShowDropDown | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | ShowNullValuePrompt | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | ShowNullValuePromptWhenFocused | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | ShowNullValuePromptWhenReadOnly | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | ShowPopupShadow | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | ShowToolTipForTrimmedText | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | Site | (Ereditato da RepositoryItem)
Proprietà pubblica | Sorted | (Ereditato da RepositoryItemComboBox)
Proprietà protetta | StyleController | (Ereditato da RepositoryItem)
Proprietà pubblica | SuppressMouseEventOnOuterMouseClick | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | Tag | (Ereditato da RepositoryItem)
Proprietà pubblica | TextEditStyle | (Ereditato da RepositoryItemButtonEdit)
Proprietà protetta | UpdateEditValueFromPopup | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | UseAdvancedMode | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | UseCtrlScroll | (Ereditato da RepositoryItemComboBox)
Proprietà protetta | UseDisplayTextAsNullValuePrompt | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | UseMaskAsDisplayFormat | (Ereditato da RepositoryItemPopupBaseAutoSearchEdit)
Proprietà protetta | UseMaskBox | (Ereditato da RepositoryItemTextEdit)
Proprietà protetta | UseMaskedInput | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | UseParentBackground | (Ereditato da RepositoryItem)
Proprietà pubblica | UseReadOnlyAppearance | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | UseSystemPasswordChar | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | UseTextEditorForAutoFilter | (Ereditato da RepositoryItemButtonEdit)
Proprietà pubblica | ValidateOnEnterKey | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | XlsxFormatString | (Ereditato da RepositoryItemTextEdit)
Torna su
Vedi anche

Documentazione

Classe RepositoryItemDedComboBox
Namespace DedNet.Controls


Proprietà RepositoryItemDedComboBox.EditorTypeName

Proprietà RepositoryItemDedComboBoxEditorTypeName

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string EditorTypeName { get; }
Public Overrides ReadOnly Property EditorTypeName As String
    Get
public:
virtual property String^ EditorTypeName {
    String^ get () override;
}
abstract EditorTypeName : string with get
override EditorTypeName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe RepositoryItemDedComboBox
Namespace DedNet.Controls


Metodi di RepositoryItemDedComboBox

Il tipo RepositoryItemDedComboBox espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | AcceptModifiedEditValueTextAsEditValue | (Ereditato da RepositoryItemPopupBaseAutoSearchEdit)
Metodo protetto | AcceptSearchTextAsEditValue | (Ereditato da RepositoryItemPopupBaseAutoSearchEdit)
Metodo protetto | ActivationKeysContains | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | AddImageSourceToPrintCache(PrintingSystemBase, MultiKey, SvgImage) | (Ereditato da RepositoryItem)
Metodo protetto | AddImageSourceToPrintCache(PrintingSystemBase, MultiKey, Image) | (Ereditato da RepositoryItem)
Metodo protetto | AddImageSourceToPrintCache(PrintingSystemBase, MultiKey, Object, Int32) | (Ereditato da RepositoryItem)
Metodo protetto | AddImageToPrintCache | (Ereditato da RepositoryItem)
Metodo protetto | AllowMaskManagerType | (Ereditato da RepositoryItemPopupBase)
Metodo pubblico | Assign | (Sovrascrive RepositoryItemComboBox.Assign(RepositoryItem))
Metodo protetto | AssignEvents | (Ereditato da RepositoryItemComboBox)
Metodo protetto | AssignMasks | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | AssignNullValuePromptSettings | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | AssignOwnerEditEvents | (Ereditato da RepositoryItem)
Metodo protetto | AssignTextBrickFormatSettings | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | AssignTextBrickText | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | BeginInit | (Ereditato da RepositoryItemComboBox)
Metodo pubblico | BeginUpdate | (Ereditato da RepositoryItem)
Metodo protetto | BreakAnimations | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | CalcPaddingInfo | (Ereditato da RepositoryItem)
Metodo protetto | CalcPasswordCharMaskedText | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | CancelUpdate | (Ereditato da RepositoryItem)
Metodo protetto | CanEditNumericValueType | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | Clone | (Ereditato da RepositoryItem)
Metodo protetto | CompleteChanges | (Ereditato da RepositoryItem)
Metodo pubblico | Connect | (Ereditato da RepositoryItem)
Metodo protetto | ConvertTextFilterValue | (Ereditato da RepositoryItem)
Metodo protetto | CreateAccessibleInstance | (Ereditato da RepositoryItem)
Metodo protetto | CreateAdvancedModeOptions | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | CreateAppearance | (Ereditato da RepositoryItem)
Metodo protetto | CreateAppearanceCore | (Ereditato da RepositoryItem)
Metodo protetto | CreateBrickStyle | (Ereditato da RepositoryItem)
Metodo protetto | CreateButtonCollection | (Ereditato da RepositoryItemButtonEdit)
Metodo protetto | CreateContextButtonOptions | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | CreateContextButtonsCollection | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | CreateContextImageOptions | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | CreateDefaultButton | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | CreateDefaultMaskManager | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | CreateDefaultMaskManagerCore | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | CreateDisplayFormat | (Ereditato da RepositoryItem)
Metodo protetto | CreateEditFormat | (Ereditato da RepositoryItem)
Metodo pubblico | CreateEditor | (Ereditato da RepositoryItem)
Metodo pubblico | CreateGroupPainter | (Ereditato da RepositoryItem)
Metodo protetto | CreateHtmlTemplates | (Ereditato da RepositoryItemComboBox)
Metodo protetto | CreateImageBrick | (Ereditato da RepositoryItem)
Metodo protetto | CreateItemCollection | (Ereditato da RepositoryItemComboBox)
Metodo protetto | CreateLookAndFeel | (Ereditato da RepositoryItem)
Metodo protetto | CreateMaskManager | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | CreateMaskProperties | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | CreateMaskSettings | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | CreateOwnerEditLookAndFeel | (Ereditato da RepositoryItem)
Metodo pubblico | CreatePainter | (Ereditato da RepositoryItem)
Metodo protetto | CreatePanelBrick(PrintCellHelperInfo, Boolean) | (Ereditato da RepositoryItem)
Metodo protetto | CreatePanelBrick(PrintCellHelperInfo, Boolean, BrickStyle) | (Ereditato da RepositoryItem)
Metodo protetto | CreatePopupDisplayFormat | (Ereditato da RepositoryItemComboBox)
Metodo protetto | CreateRepositoryItem | (Ereditato da RepositoryItem)
Metodo protetto | CreateTextBrick | (Ereditato da RepositoryItem)
Metodo pubblico | CreateViewInfo | (Ereditato da RepositoryItem)
Metodo protetto | DenyStandardTextEditStyle | (Ereditato da RepositoryItemButtonEdit)
Metodo protetto | DestroyAppearance | (Ereditato da RepositoryItem)
Metodo protetto | DestroyAppearances | (Ereditato da RepositoryItemComboBox)
Metodo protetto | DestroyLookAndFeel | (Ereditato da RepositoryItem)
Metodo protetto | DestroyStyles | Obsoleto. (Ereditato da RepositoryItem)
Metodo pubblico | Disconnect | (Ereditato da RepositoryItem)
Metodo protetto | Dispose | (Ereditato da RepositoryItemComboBox)
Metodo protetto | DisposePrevContextImage | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | DoFormatEditValue(Object) | (Ereditato da RepositoryItem)
Metodo protetto | DoFormatEditValue(Object, Boolean) | (Ereditato da RepositoryItem)
Metodo protetto | DoParseEditValue(Object) | (Ereditato da RepositoryItem)
Metodo protetto | DoParseEditValue(Object, Boolean) | (Ereditato da RepositoryItem)
Metodo pubblico | EditMaskSettings(Object) | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | EditMaskSettings(IWin32Window, Object) | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | EditMaskSettings(IWindowsFormsEditorService, Object) | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | EnableCustomMaskTextInput | (Ereditato da RepositoryItemPopupBaseAutoSearchEdit)
Metodo pubblico | EnableNonMaskedInput | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | EndInit | (Ereditato da RepositoryItemComboBox)
Metodo pubblico | EndUpdate | (Ereditato da RepositoryItem)
Metodo protetto | EnsureMaskSettings | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | FilterProperties | (Ereditato da RepositoryItem)
Metodo protetto | FireChanged | (Ereditato da RepositoryItem)
Metodo protetto | FireChangedFromRepository | (Ereditato da RepositoryItem)
Metodo protetto | FireContainerLoaded | (Ereditato da RepositoryItem)
Metodo protetto | ForceDisplayTextAsNullValuePrompt | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da RepositoryItem)
Metodo protetto | GetAllowContextImageChangeAnimation | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetAllowGlyphSkinning | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetAllowHtmlDraw | (Ereditato da RepositoryItem)
Metodo pubblico | GetBrick | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetBrickImageSource | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetCachedPrintImage | (Ereditato da RepositoryItem)
Metodo protetto | GetCachedPrintImageSource | (Ereditato da RepositoryItem)
Metodo protetto | GetCustomMaskTextInputTag | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetDefaultEditMask | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetDefaultMaskManagerType | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetDesiredPopupFormSize | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | GetDisableTextEditorAsDefaultValue | (Ereditato da RepositoryItemButtonEdit)
Metodo pubblico | GetDisplayText(Object) | (Ereditato da RepositoryItem)
Metodo pubblico | GetDisplayText(FormatInfo, Object) | (Ereditato da RepositoryItemComboBox)
Metodo pubblico | GetEditorType | (Ereditato da RepositoryItem)
Metodo protetto | GetEditValueForExport | (Ereditato da RepositoryItem)
Metodo pubblico | GetEditValueForExportByOptions | (Ereditato da RepositoryItem)
Metodo protetto | GetEventSender | (Ereditato da RepositoryItem)
Metodo protetto | GetExportMode | (Ereditato da RepositoryItemComboBox)
Metodo protetto | GetFormattedDisplayText | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | GetHashCode | (Ereditato da RepositoryItem)
Metodo protetto | GetInPanelrect | (Ereditato da RepositoryItem)
Metodo protetto | GetKeyIncludeCtrlScroll | (Ereditato da RepositoryItemComboBox)
Metodo protetto | GetNullEditText | (Ereditato da RepositoryItemButtonEdit)
Metodo protetto | GetNullText | (Ereditato da RepositoryItem)
Metodo protetto | GetNullValuePrompt | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetOrAddImageSource(PrintingSystemBase, MultiKey, SvgImage) | (Ereditato da RepositoryItem)
Metodo protetto | GetOrAddImageSource(PrintingSystemBase, MultiKey, Image) | (Ereditato da RepositoryItem)
Metodo protetto | GetOrAddImageSource(PrintingSystemBase, MultiKey, Object, Int32) | (Ereditato da RepositoryItem)
Metodo protetto | GetOverrideAppearance | (Ereditato da RepositoryItem)
Metodo protetto | GetPasswordCharCore | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetPrevContextImage | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetSender | (Ereditato da RepositoryItem)
Metodo protetto | GetTextFilterCapabilities | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetUseMaskAsDisplayFormat | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | InitializeEditMaskFromDisplayTextService | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | IsActivateKey | (Ereditato da RepositoryItem)
Metodo protetto | IsButtonEnabled | (Ereditato da RepositoryItemPopupBase)
Metodo pubblico | IsDefault | (Ereditato da RepositoryItem)
Metodo protetto | IsEmptyValue | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | IsFormatTypeCustom | (Ereditato da RepositoryItem)
Metodo protetto | IsListBoxKey | (Ereditato da RepositoryItemComboBox)
Metodo pubblico | IsLockDefaultImmediateUpdateRowPosition | (Ereditato da RepositoryItem)
Metodo protetto | IsNeededChar | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | IsNeededKey | (Ereditato da RepositoryItem)
Metodo protetto | IsNeededKeyCore | (Ereditato da RepositoryItemComboBox)
Metodo protetto | IsNullValue | (Ereditato da RepositoryItem)
Metodo protetto | IsStandardTextEditStyle | (Ereditato da RepositoryItemButtonEdit)
Metodo pubblico | LockEvents | (Ereditato da RepositoryItem)
Metodo pubblico | MarkAsClone | (Ereditato da RepositoryItem)
Metodo protetto | NeededKeysContains | (Ereditato da RepositoryItemComboBox)
Metodo protetto | NeededKeysPopupContains | (Ereditato da RepositoryItemComboBox)
Metodo protetto | OnAllowFocusedChanged | (Ereditato da RepositoryItem)
Metodo protetto | OnAnnotationAttributesLoad | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnAppearanceChanged | (Ereditato da RepositoryItem)
Metodo protetto | OnAppearancePaintChanged | (Ereditato da RepositoryItem)
Metodo protetto | OnAppearanceSizeChanged | (Ereditato da RepositoryItem)
Metodo protetto | OnAutoHeightChanged | (Ereditato da RepositoryItem)
Metodo protetto | OnButtons_CollectionChanged | (Ereditato da RepositoryItemButtonEdit)
Metodo protetto | OnContainerLoaded | (Ereditato da RepositoryItem)
Metodo protetto | OnContextImageChanged | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnContextImageChanging | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnContextImageOptionsChanged | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnContextImageOptionsChanging | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnEnabledChanged | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnFormat_Changed | (Ereditato da RepositoryItemComboBox)
Metodo protetto | OnItems_CollectionChanged | (Ereditato da RepositoryItemComboBox)
Metodo protetto | OnLoaded | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnMaskChanged | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnMaskSettingsChanged | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnOwnerEditChanged | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnPopupFormSizeChanged | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | OnPropertiesChanged | (Ereditato da RepositoryItem)
Metodo protetto | OnPropertiesChanged(EventArgs) | (Ereditato da RepositoryItem)
Metodo protetto | OnStyleChanged | (Ereditato da RepositoryItem)
Metodo protetto | OnTextEditStyleChanged | (Ereditato da RepositoryItemButtonEdit)
Metodo protetto | OnUpdateMaskSettings | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | PreparePrintViewInfo(PrintCellHelperInfo, Boolean) | (Ereditato da RepositoryItem)
Metodo protetto | PreparePrintViewInfo(PrintCellHelperInfo, BaseEditViewInfo, Boolean) | (Ereditato da RepositoryItem)
Metodo protetto | RaiseBeforePopup | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | RaiseBeforeShowMenu | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | RaiseButtonClick | (Ereditato da RepositoryItemButtonEdit)
Metodo protetto | RaiseButtonPressed | (Ereditato da RepositoryItemButtonEdit)
Metodo protetto | RaiseClosed | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | RaiseCloseUp | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | RaiseContextButtonClick | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | RaiseContextButtonValueChanged | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | RaiseCustomDisplayText(CustomDisplayTextEventArgs) | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | RaiseCustomDisplayText(Object, String) | (Ereditato da RepositoryItem)
Metodo protetto | RaiseCustomDisplayText(FormatInfo, Object, String) | (Ereditato da RepositoryItem)
Metodo protetto | RaiseCustomDrawButton | (Ereditato da RepositoryItemButtonEdit)
Metodo protetto | RaiseCustomHighlightText | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | RaiseCustomItemDisplayText | (Ereditato da RepositoryItemComboBox)
Metodo protetto | RaiseCustomItemTemplate | (Ereditato da RepositoryItemComboBox)
Metodo protetto | RaiseCustomizeAutoCompleteSource | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | RaiseCustomizeContextItem | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | RaiseCustomizeItem | (Ereditato da RepositoryItemComboBox)
Metodo protetto | RaiseCustomTextLineHeight | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | RaiseDropDownCustomDrawItem | (Ereditato da RepositoryItemComboBox)
Metodo protetto | RaiseEditValueChanged | (Ereditato da RepositoryItem)
Metodo protetto | RaiseEditValueChangedCore | (Ereditato da RepositoryItem)
Metodo protetto | RaiseEditValueChanging | (Ereditato da RepositoryItem)
Metodo protetto | RaiseFormatEditValue | (Ereditato da RepositoryItem)
Metodo protetto | RaiseHtmlElementMouseClick | (Ereditato da RepositoryItemComboBox)
Metodo protetto | RaiseHtmlElementMouseDown | (Ereditato da RepositoryItemComboBox)
Metodo protetto | RaiseHtmlElementMouseUp | (Ereditato da RepositoryItemComboBox)
Metodo protetto | RaiseMeasureItem | (Ereditato da RepositoryItemComboBox)
Metodo protetto | RaiseModified | (Ereditato da RepositoryItem)
Metodo protetto | RaiseParseEditValue | (Ereditato da RepositoryItem)
Metodo protetto | RaisePopup | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | RaisePopupAllowClick | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | RaisePropertiesChanged | (Ereditato da RepositoryItem)
Metodo protetto | RaiseQueryAccessibilityHelp | (Ereditato da RepositoryItem)
Metodo protetto | RaiseQueryCloseUp | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | RaiseQueryPopUp | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | RaiseQueryProcessKey | (Ereditato da RepositoryItem)
Metodo protetto | RaiseRefreshRequired | (Ereditato da RepositoryItem)
Metodo protetto | RaiseSelectedIndexChanged | (Ereditato da RepositoryItemComboBox)
Metodo protetto | RaiseSelectedValueChanged | (Ereditato da RepositoryItemComboBox)
Metodo protetto | RaiseSpin | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | RecreateMaskManagerOnIsNullInputAllowedChanged | (Ereditato da RepositoryItemTextEdit)
 | RegisterDedComboBox |
Metodo protetto | ResetAccessibleDescription | (Ereditato da RepositoryItem)
Metodo protetto | ResetAccessibleName | (Ereditato da RepositoryItem)
Metodo protetto | ResetAutoHeight | (Ereditato da RepositoryItem)
Metodo protetto | ResetDefaultMaskManager | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | ResetDropDownRows | (Ereditato da RepositoryItemComboBox)
Metodo pubblico | ResetEvents | (Ereditato da RepositoryItem)
Metodo pubblico | ResetMaskSettings | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | ResetNullText | (Ereditato da RepositoryItem)
Metodo protetto | ResetNullValuePrompt | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | ResetPopupFormMinSize | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | ResetPopupFormSize | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | ResetTextEditStyle | (Ereditato da RepositoryItemButtonEdit)
Metodo pubblico | ScaleProperties | (Ereditato da RepositoryItem)
Metodo protetto | ScalePropertiesCore | (Ereditato da RepositoryItemComboBox)
Metodo pubblico | SetCloned | (Ereditato da RepositoryItem)
Metodo protetto | SetCommonBrickProperties | (Ereditato da RepositoryItem)
Metodo protetto | SetOwnerEdit | (Ereditato da RepositoryItem)
Metodo protetto | SetTextBrickPropertiesCore | (Ereditato da RepositoryItem)
Metodo protetto | SetupCommonBrickStyleProperties | (Ereditato da RepositoryItem)
Metodo protetto | SetupTextBrickStyleProperties | (Ereditato da RepositoryItem)
Metodo protetto | ShouldRaiseCustomDisplayText | (Ereditato da RepositoryItem)
Metodo protetto | ShouldSerializeAccessibleDescription | (Ereditato da RepositoryItem)
Metodo protetto | ShouldSerializeAccessibleName | (Ereditato da RepositoryItem)
Metodo protetto | ShouldSerializeAutoHeight | (Ereditato da RepositoryItem)
Metodo protetto | ShouldSerializeDropDownRows | (Ereditato da RepositoryItemComboBox)
Metodo protetto | ShouldSerializeItems | (Ereditato da RepositoryItemComboBox)
Metodo pubblico | ShouldSerializeMaskSettings | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | ShouldSerializeNullText | (Ereditato da RepositoryItem)
Metodo protetto | ShouldSerializeNullValuePrompt | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | ShouldSerializePopupFormMinSize | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | ShouldSerializePopupFormSize | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | ShouldSerializeTextEditStyle | (Ereditato da RepositoryItemButtonEdit)
Metodo protetto | StartContextImageChangingAnimation | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | SwitchMode | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | ThrowItemNotInRepositoryWarning | (Ereditato da RepositoryItem)
Metodo pubblico | ToString | (Ereditato da RepositoryItem)
Metodo protetto | ToStringTrimming | (Ereditato da RepositoryItem)
Metodo protetto | TriggerDelayedEditValueChanged | (Ereditato da RepositoryItem)
Metodo protetto | TriggerDelayedEditValueChanged(EventArgs) | (Ereditato da RepositoryItem)
Metodo protetto | TryGetThreadSafeDoFormatEditValueFunc | (Ereditato da RepositoryItem)
Metodo protetto | TryGetThreadSafeGetDisplayTextFunc | (Ereditato da RepositoryItem)
Metodo protetto | TryGetThreadSafeGetFormattedDisplayTextFunc | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | TryGetThreadSafeIsNullValueFunc | (Ereditato da RepositoryItem)
Metodo protetto | TryGetThreadSafeRaiseCustomDisplayTextFunc | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | UnLockEvents | (Ereditato da RepositoryItem)
Torna su
Vedi anche

Documentazione

Classe RepositoryItemDedComboBox
Namespace DedNet.Controls


Metodo RepositoryItemDedComboBox.Assign

Metodo RepositoryItemDedComboBoxAssign

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void Assign(
    RepositoryItem item
)
Public Overrides Sub Assign (
    item As RepositoryItem
)
public:
virtual void Assign(
    RepositoryItem^ item
) override
abstract Assign :
        item : RepositoryItem -> unit
override Assign :
        item : RepositoryItem -> unit

Parametri

item RepositoryItem
Vedi anche

Documentazione

Classe RepositoryItemDedComboBox
Namespace DedNet.Controls


Metodo RepositoryItemDedComboBox.RegisterDedComboBox

Metodo RepositoryItemDedComboBoxRegisterDedComboBox

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void RegisterDedComboBox()
Public Shared Sub RegisterDedComboBox
public:
static void RegisterDedComboBox()
static member RegisterDedComboBox : unit -> unit
Vedi anche

Documentazione

Classe RepositoryItemDedComboBox
Namespace DedNet.Controls


Eventi di RepositoryItemDedComboBox

Il tipo RepositoryItemDedComboBox espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | BeforePopup | (Ereditato da RepositoryItemPopupBase)
Evento pubblico | BeforeShowMenu | (Ereditato da RepositoryItemTextEdit)
Evento pubblico | ButtonClick | (Ereditato da RepositoryItemButtonEdit)
Evento pubblico | ButtonPressed | (Ereditato da RepositoryItemButtonEdit)
Evento pubblico | Click | (Ereditato da RepositoryItem)
Evento pubblico | Closed | (Ereditato da RepositoryItemPopupBase)
Evento pubblico | CloseUp | (Ereditato da RepositoryItemPopupBase)
Evento pubblico | ContextButtonClick | (Ereditato da RepositoryItemPopupBase)
Evento pubblico | ContextButtonValueChanged | (Ereditato da RepositoryItemPopupBase)
Evento pubblico | CustomDisplayText | (Ereditato da RepositoryItem)
Evento pubblico | CustomDrawButton | (Ereditato da RepositoryItemButtonEdit)
Evento pubblico | CustomHighlightText | (Ereditato da RepositoryItemTextEdit)
Evento pubblico | CustomItemDisplayText | (Ereditato da RepositoryItemComboBox)
Evento pubblico | CustomItemTemplate | (Ereditato da RepositoryItemComboBox)
Evento pubblico | CustomizeAutoCompleteSource | (Ereditato da RepositoryItemTextEdit)
Evento pubblico | CustomizeContextItem | (Ereditato da RepositoryItemPopupBase)
Evento pubblico | CustomizeItem | (Ereditato da RepositoryItemComboBox)
Evento pubblico | CustomTextLineHeight | (Ereditato da RepositoryItemTextEdit)
Evento pubblico | DoubleClick | (Ereditato da RepositoryItem)
Evento pubblico | DragDrop | (Ereditato da RepositoryItem)
Evento pubblico | DragEnter | (Ereditato da RepositoryItem)
Evento pubblico | DragLeave | (Ereditato da RepositoryItem)
Evento pubblico | DragOver | (Ereditato da RepositoryItem)
Evento pubblico | DrawItem | (Ereditato da RepositoryItemComboBox)
Evento pubblico | DropDownCustomDrawItem | Obsoleto. (Ereditato da RepositoryItemComboBox)
Evento pubblico | EditValueChanged | (Ereditato da RepositoryItem)
Evento pubblico | EditValueChanging | (Ereditato da RepositoryItem)
Evento pubblico | Enter | (Ereditato da RepositoryItem)
Evento pubblico | FormatEditValue | (Ereditato da RepositoryItem)
Evento pubblico | GiveFeedback | (Ereditato da RepositoryItem)
Evento pubblico | HelpRequested | (Ereditato da RepositoryItem)
Evento pubblico | HtmlElementMouseClick | (Ereditato da RepositoryItemComboBox)
Evento pubblico | HtmlElementMouseDown | (Ereditato da RepositoryItemComboBox)
Evento pubblico | HtmlElementMouseUp | (Ereditato da RepositoryItemComboBox)
Evento pubblico | KeyDown | (Ereditato da RepositoryItem)
Evento pubblico | KeyPress | (Ereditato da RepositoryItem)
Evento pubblico | KeyUp | (Ereditato da RepositoryItem)
Evento pubblico | Leave | (Ereditato da RepositoryItem)
Evento pubblico | MeasureItem | (Ereditato da RepositoryItemComboBox)
Evento pubblico | Modified | (Ereditato da RepositoryItem)
Evento pubblico | MouseDown | (Ereditato da RepositoryItem)
Evento pubblico | MouseEnter | (Ereditato da RepositoryItem)
Evento pubblico | MouseHover | (Ereditato da RepositoryItem)
Evento pubblico | MouseLeave | (Ereditato da RepositoryItem)
Evento pubblico | MouseMove | (Ereditato da RepositoryItem)
Evento pubblico | MouseUp | (Ereditato da RepositoryItem)
Evento pubblico | MouseWheel | (Ereditato da RepositoryItem)
Evento pubblico | ParseEditValue | (Ereditato da RepositoryItem)
Evento pubblico | Popup | (Ereditato da RepositoryItemPopupBase)
Evento pubblico | PopupAllowClick | (Ereditato da RepositoryItemPopupBase)
Evento pubblico | PropertiesChanged | (Ereditato da RepositoryItem)
Evento pubblico | QueryAccessibilityHelp | (Ereditato da RepositoryItem)
Evento pubblico | QueryCloseUp | (Ereditato da RepositoryItemPopupBase)
Evento pubblico | QueryContinueDrag | (Ereditato da RepositoryItem)
Evento pubblico | QueryPopUp | (Ereditato da RepositoryItemPopupBase)
Evento pubblico | QueryProcessKey | (Ereditato da RepositoryItem)
Evento pubblico | SelectedIndexChanged | (Ereditato da RepositoryItemComboBox)
Evento pubblico | SelectedValueChanged | (Ereditato da RepositoryItemComboBox)
Evento pubblico | Spin | (Ereditato da RepositoryItemTextEdit)
Evento pubblico | Validating | (Ereditato da RepositoryItem)
Torna su
Vedi anche

Documentazione

Classe RepositoryItemDedComboBox
Namespace DedNet.Controls


Campi di RepositoryItemDedComboBox

Il tipo RepositoryItemDedComboBox espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | Cloned | (Ereditato da RepositoryItem)
 | CustomEditName |
Campo protetto | fAllowFocused | (Ereditato da RepositoryItem)
Campo protetto | fAllowMouseWheel | (Ereditato da RepositoryItem)
Campo protetto | fAutoComplete | (Ereditato da RepositoryItemComboBox)
Campo protetto | fAutoHeight | (Ereditato da RepositoryItem)
Campo protetto | fBorderStyle | (Ereditato da RepositoryItem)
Campo protetto | fButtonsStyle | (Ereditato da RepositoryItemButtonEdit)
Campo protetto | fCaseSensitiveSearch | (Ereditato da RepositoryItemComboBox)
Campo protetto | fCharacterCasing | (Ereditato da RepositoryItemTextEdit)
Campo protetto | fCycleOnDblClick | (Ereditato da RepositoryItemComboBox)
Campo protetto | fEditValueChangedFiringMode | (Ereditato da RepositoryItem)
Campo protetto | fEnabled | (Ereditato da RepositoryItem)
Campo protetto | fLockFormatParse | (Ereditato da RepositoryItem)
Campo protetto | fMaxLength | (Ereditato da RepositoryItemTextEdit)
Campo protetto | fNullText | (Ereditato da RepositoryItem)
Campo protetto | fPainter | (Ereditato da RepositoryItem)
Campo protetto | fPasswordChar | (Ereditato da RepositoryItemTextEdit)
Campo protetto | fReadOnly | (Ereditato da RepositoryItem)
Campo protetto | fTextEditStyle | (Ereditato da RepositoryItemButtonEdit)
Campo protetto | fUseCtrlScroll | (Ereditato da RepositoryItemComboBox)
Campo protetto | fValidateOnEnterKey | (Ereditato da RepositoryItemTextEdit)
Torna su
Vedi anche

Documentazione

Classe RepositoryItemDedComboBox
Namespace DedNet.Controls


Campo RepositoryItemDedComboBox.CustomEditName

Campo RepositoryItemDedComboBoxCustomEditName

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string CustomEditName = "DedComboBox"
Public Const CustomEditName As String = "DedComboBox"
public:
literal String^ CustomEditName = "DedComboBox"
static val mutable CustomEditName: string

Valore del campo

String
Vedi anche

Documentazione

Classe RepositoryItemDedComboBox
Namespace DedNet.Controls


Classe RepositoryItemDedFontEdit
Oggetto repository per il funzionamento e la registrazione del controllo DedFontEdit.
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
ComponentBase
RepositoryItem
RepositoryItemTextEdit
RepositoryItemButtonEdit
RepositoryItemPopupBase
RepositoryItemPopupBaseAutoSearchEdit
RepositoryItemComboBox
RecentlyUsedItemsComboBox
RepositoryItemFontEdit
DedNet.ControlsRepositoryItemDedFontEdit

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class RepositoryItemDedFontEdit : RepositoryItemFontEdit
Public Class RepositoryItemDedFontEdit
    Inherits RepositoryItemFontEdit
public ref class RepositoryItemDedFontEdit : public RepositoryItemFontEdit
type RepositoryItemDedFontEdit =
    class
        inherit RepositoryItemFontEdit
    end

Il tipo RepositoryItemDedFontEdit espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | RepositoryItemDedFontEdit | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AccessibleDefaultActionDescription | (Ereditato da RepositoryItem)
Proprietà pubblica | AccessibleDescription | (Ereditato da RepositoryItem)
Proprietà pubblica | AccessibleName | (Ereditato da RepositoryItem)
Proprietà pubblica | AccessibleRole | (Ereditato da RepositoryItem)
Proprietà pubblica | ActionButtonIndex | (Ereditato da RepositoryItemPopupBase)
Proprietà protetta | ActiveFormat | (Ereditato da RepositoryItem)
Proprietà pubblica | AdvancedModeOptions | (Ereditato da RepositoryItemTextEdit)
Proprietà protetta | AllowCheckExtraKeys | (Ereditato da RepositoryItemPopupBase)
Proprietà protetta | AllowCloseByEscape | (Ereditato da RepositoryItemPopupBase)
Proprietà protetta | AllowClosePopup | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | AllowContextImageChangeAnimation | (Ereditato da RepositoryItemTextEdit)
Proprietà protetta | AllowDefaultClearButtonAction | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | AllowDropDownWhenReadOnly | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | AllowFocused | (Ereditato da RepositoryItem)
Proprietà pubblica | AllowFocusedAppearance | (Ereditato da RepositoryItem)
Proprietà protetta | AllowFormatEditValue | (Ereditato da RepositoryItem)
Proprietà pubblica | AllowGlyphSkinning | (Ereditato da RepositoryItemTextEdit)
Proprietà protetta | AllowHideClearButtonWhenNotFocused | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | AllowHtmlDraw | (Ereditato da RepositoryItem)
Proprietà pubblica | AllowInplaceAutoFilter | (Ereditato da RepositoryItem)
Proprietà pubblica | AllowInplaceBorderPainter | (Ereditato da RepositoryItem)
Proprietà protetta | AllowInputOnOpenPopup | (Ereditato da RepositoryItemPopupBase)
Proprietà protetta | AllowMaskBox | (Ereditato da RepositoryItem)
Proprietà pubblica | AllowMouseWheel | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | AllowNullInput | (Ereditato da RepositoryItemTextEdit)
Proprietà protetta | AllowParseEditValue | (Ereditato da RepositoryItem)
Proprietà protetta | AllowValidateOnEnterKey | (Ereditato da RepositoryItemPopupBase)
Proprietà protetta | AnnotationAttributes | (Ereditato da RepositoryItem)
Proprietà pubblica | Appearance | (Ereditato da RepositoryItem)
Proprietà pubblica | AppearanceDisabled | (Ereditato da RepositoryItem)
Proprietà pubblica | AppearanceDropDown | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | AppearanceFocused | (Ereditato da RepositoryItem)
Proprietà pubblica | AppearanceItemDisabled | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | AppearanceItemHighlight | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | AppearanceItemSelected | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | AppearanceReadOnly | (Ereditato da RepositoryItem)
Proprietà pubblica | AutoComplete | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | AutoHeight | (Ereditato da RepositoryItem)
Proprietà pubblica | BeepOnError | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | BestFitWidth | (Ereditato da RepositoryItem)
Proprietà pubblica | BorderStyle | (Ereditato da RepositoryItem)
Proprietà pubblica | Buttons | (Ereditato da RepositoryItemButtonEdit)
Proprietà pubblica | ButtonsBorderStyle | Obsoleto. (Ereditato da RepositoryItemButtonEdit)
Proprietà pubblica | ButtonsStyle | (Ereditato da RepositoryItemButtonEdit)
Proprietà protetta | CancelPopupInputOnButtonClose | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | CaseSensitiveSearch | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | CharacterCasing | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | CloseUpKey | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | ContextButtonOptions | (Ereditato da RepositoryItemFontEdit)
Proprietà pubblica | ContextButtons | (Ereditato da RepositoryItemFontEdit)
Proprietà pubblica | ContextImage | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | ContextImageAlignment | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | ContextImageOptions | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | ContextMenu | (Ereditato da RepositoryItem)
Proprietà pubblica | ContextMenuStrip | (Ereditato da RepositoryItem)
Proprietà pubblica | CycleOnDblClick | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | DefaultAlignment | (Ereditato da RepositoryItem)
Proprietà pubblica | DefaultBorderStyleInBars | (Ereditato da RepositoryItem)
Proprietà pubblica | DefaultBorderStyleInGrid | (Ereditato da RepositoryItem)
Proprietà protetta | DefaultImmediatePopup | (Ereditato da RepositoryItemPopupBaseAutoSearchEdit)
Proprietà protetta | DefaultPopupSizeable | (Ereditato da RepositoryItemPopupBaseAutoSearchEdit)
Proprietà pubblica | DisplayFormat | (Ereditato da RepositoryItemFontEdit)
Proprietà pubblica | DropDownItemHeight | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | DropDownRows | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | Editable | (Ereditato da RepositoryItem)
Proprietà pubblica | EditFormat | (Ereditato da RepositoryItemFontEdit)
Proprietà protetta | EditorClassInfo | (Ereditato da RepositoryItem)
Proprietà pubblica | EditorTypeName | Override EditorTypeName. (Sovrascrive RepositoryItemFontEdit.EditorTypeName)
Proprietà pubblica | EditValueChangedDelay | (Ereditato da RepositoryItem)
Proprietà pubblica | EditValueChangedFiringMode | (Ereditato da RepositoryItem)
Proprietà pubblica | Enabled | (Ereditato da RepositoryItem)
Proprietà pubblica | ExportMode | (Ereditato da RepositoryItem)
Proprietà protetta | ForceDisableButtonOnReadOnly | (Ereditato da RepositoryItemPopupBase)
Proprietà protetta | HasContextButtons | (Ereditato da RepositoryItemPopupBase)
Proprietà protetta | HasEditValueChangingSubscribers | (Ereditato da RepositoryItem)
Proprietà pubblica | HasEffectiveMaskForDisplayFormating | (Ereditato da RepositoryItemTextEdit)
Proprietà protetta | HasMaskSettings | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | HideSelection | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | HighlightedItemStyle | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | HotTrackDropDownItems | Obsoleto. (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | HotTrackItems | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | HtmlImages | (Ereditato da RepositoryItem)
Proprietà pubblica | HtmlTemplates | (Ereditato da RepositoryItemComboBox)
Proprietà protetta | ImageChangingAnimationProvider | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | ImmediatePopup | (Ereditato da RepositoryItemPopupBaseAutoSearchEdit)
Proprietà pubblica | IsClone | (Ereditato da RepositoryItem)
Proprietà protetta | IsContainerLoaded | (Ereditato da RepositoryItem)
Proprietà pubblica | IsDesignMode | (Ereditato da RepositoryItem)
Proprietà pubblica | IsDisposed | (Ereditato da RepositoryItem)
Proprietà pubblica | IsEditValueChangedEventPending | (Ereditato da RepositoryItem)
Proprietà pubblica | IsFilterLookUp | (Ereditato da RepositoryItem)
Proprietà protetta | IsFirstInit | (Ereditato da RepositoryItem)
Proprietà protetta | IsInImageChangingAnimation | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | IsLoading | (Ereditato da RepositoryItem)
Proprietà protetta | IsLockEvents | (Ereditato da RepositoryItem)
Proprietà pubblica | IsLockUpdate | (Ereditato da RepositoryItem)
Proprietà protetta | IsMeasureItemAssigned | (Ereditato da RepositoryItemComboBox)
Proprietà protetta | IsNeededTextKeys | (Ereditato da RepositoryItemButtonEdit)
Proprietà pubblica | IsNonSortableEditor | (Ereditato da RepositoryItem)
Proprietà protetta | IsNowReadOnly | (Ereditato da RepositoryItemPopupBase)
Proprietà protetta | IsNullInputAllowed | (Ereditato da RepositoryItemTextEdit)
Proprietà protetta | IsPasswordBox | (Ereditato da RepositoryItemTextEdit)
Proprietà protetta | IsReadOnlyAllowsDropDown | (Ereditato da RepositoryItemPopupBase)
Proprietà protetta | IsTryGetThreadSafeFuncValid | (Ereditato da RepositoryItemComboBox)
Proprietà protetta | IsUseDisplayFormat | (Ereditato da RepositoryItemButtonEdit)
Proprietà pubblica | ItemAutoHeight | (Ereditato da RepositoryItemFontEdit)
Proprietà pubblica | ItemPadding | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | Items | (Ereditato da RepositoryItemFontEdit)
Proprietà pubblica | LinkCount | (Ereditato da RepositoryItem)
Proprietà protetta | Links | (Ereditato da RepositoryItem)
Proprietà protetta | LockDefaultImmediateUpdateRowPosition | (Ereditato da RepositoryItem)
Proprietà protetta | LockFormatParse | (Ereditato da RepositoryItem)
Proprietà pubblica | LookAndFeel | (Ereditato da RepositoryItem)
Proprietà pubblica | Mask | (Ereditato da RepositoryItemFontEdit)
Proprietà pubblica | MaskBoxPadding | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | MaskSettings | (Ereditato da RepositoryItemFontEdit)
Proprietà pubblica | MaxLength | (Ereditato da RepositoryItemTextEdit)
Proprietà protetta | MenuHotKey | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | Name | (Ereditato da RepositoryItem)
Proprietà pubblica | NullText | (Ereditato da RepositoryItem)
Proprietà pubblica | NullValuePrompt | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | NullValuePromptForeColor | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | NullValuePromptShowForEmptyValue | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | OwnerEdit | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | OwnerItem | (Ereditato da RepositoryItem)
Proprietà pubblica | Padding | (Ereditato da RepositoryItemTextEdit)
Proprietà protetta | Painter | (Ereditato da RepositoryItem)
Proprietà pubblica | PasswordChar | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | PopupBorderStyle | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | PopupDisplayFormat | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | PopupFormMinSize | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | PopupFormSize | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | PopupFormWidth | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | PopupOffset | (Ereditato da RepositoryItem)
Proprietà pubblica | PopupResizeMode | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | PopupSizeable | (Ereditato da RepositoryItemPopupBaseAutoSearchEdit)
Proprietà protetta | PostponeDelayedEditValueTimer | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | Properties | Obsoleto. (Ereditato da RepositoryItemComboBox)
Proprietà protetta | PropertyStore | (Ereditato da RepositoryItem)
Proprietà pubblica | ReadOnly | (Ereditato da RepositoryItem)
Proprietà pubblica | RecentlyUsedItemCount | (Ereditato da RepositoryItemFontEdit)
Proprietà pubblica | RequireDisplayTextSorting | (Ereditato da RepositoryItem)
Proprietà protetta | RequireFakeDesigner | (Ereditato da RepositoryItem)
Proprietà pubblica | ResetTextEditStyleToStandardInFilterControl | (Ereditato da RepositoryItemButtonEdit)
Proprietà protetta | ShouldCreateMaskSettingsWhenMaskLoadedOrUpdated | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | ShowDropDown | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | ShowNullValuePrompt | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | ShowNullValuePromptWhenFocused | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | ShowNullValuePromptWhenReadOnly | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | ShowOnlyRegularStyleFonts | (Ereditato da RepositoryItemFontEdit)
Proprietà pubblica | ShowPopupShadow | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | ShowSymbolFontPreview | (Ereditato da RepositoryItemFontEdit)
Proprietà pubblica | ShowToolTipForTrimmedText | (Ereditato da RepositoryItemFontEdit)
Proprietà pubblica | Site | (Ereditato da RepositoryItem)
Proprietà pubblica | Sorted | (Ereditato da RepositoryItemComboBox)
Proprietà protetta | StyleController | (Ereditato da RepositoryItem)
Proprietà pubblica | SuppressMouseEventOnOuterMouseClick | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | Tag | (Ereditato da RepositoryItem)
Proprietà pubblica | TextEditStyle | (Ereditato da RepositoryItemFontEdit)
Proprietà protetta | UpdateEditValueFromPopup | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | UseAdvancedMode | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | UseCtrlScroll | (Ereditato da RepositoryItemComboBox)
Proprietà protetta | UseDisplayTextAsNullValuePrompt | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | UseMaskAsDisplayFormat | (Ereditato da RepositoryItemFontEdit)
Proprietà protetta | UseMaskBox | (Ereditato da RepositoryItemTextEdit)
Proprietà protetta | UseMaskedInput | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | UseParentBackground | (Ereditato da RepositoryItem)
Proprietà pubblica | UseReadOnlyAppearance | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | UseSystemPasswordChar | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | UseTextEditorForAutoFilter | (Ereditato da RepositoryItemButtonEdit)
Proprietà pubblica | ValidateOnEnterKey | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | XlsxFormatString | (Ereditato da RepositoryItemTextEdit)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | AcceptModifiedEditValueTextAsEditValue | (Ereditato da RepositoryItemPopupBaseAutoSearchEdit)
Metodo protetto | AcceptSearchTextAsEditValue | (Ereditato da RepositoryItemPopupBaseAutoSearchEdit)
Metodo protetto | ActivationKeysContains | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | AddImageSourceToPrintCache(PrintingSystemBase, MultiKey, SvgImage) | (Ereditato da RepositoryItem)
Metodo protetto | AddImageSourceToPrintCache(PrintingSystemBase, MultiKey, Image) | (Ereditato da RepositoryItem)
Metodo protetto | AddImageSourceToPrintCache(PrintingSystemBase, MultiKey, Object, Int32) | (Ereditato da RepositoryItem)
Metodo protetto | AddImageToPrintCache | (Ereditato da RepositoryItem)
Metodo protetto | AllowMaskManagerType | (Ereditato da RepositoryItemPopupBase)
Metodo pubblico | Assign | (Ereditato da RepositoryItemFontEdit)
Metodo protetto | AssignEvents | (Ereditato da RepositoryItemComboBox)
Metodo protetto | AssignMasks | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | AssignNullValuePromptSettings | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | AssignOwnerEditEvents | (Ereditato da RepositoryItem)
Metodo protetto | AssignTextBrickFormatSettings | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | AssignTextBrickText | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | BeginInit | (Ereditato da RepositoryItemComboBox)
Metodo pubblico | BeginUpdate | (Ereditato da RepositoryItem)
Metodo protetto | BreakAnimations | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | CalcPaddingInfo | (Ereditato da RepositoryItem)
Metodo protetto | CalcPasswordCharMaskedText | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | CancelUpdate | (Ereditato da RepositoryItem)
Metodo protetto | CanEditNumericValueType | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | Clone | (Ereditato da RepositoryItem)
Metodo protetto | CompleteChanges | (Ereditato da RepositoryItem)
Metodo pubblico | Connect | (Ereditato da RepositoryItem)
Metodo protetto | ConvertTextFilterValue | (Ereditato da RepositoryItem)
Metodo protetto | CreateAccessibleInstance | (Ereditato da RepositoryItem)
Metodo protetto | CreateAdvancedModeOptions | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | CreateAppearance | (Ereditato da RepositoryItem)
Metodo protetto | CreateAppearanceCore | (Ereditato da RepositoryItem)
Metodo protetto | CreateBrickStyle | (Ereditato da RepositoryItem)
Metodo protetto | CreateButtonCollection | (Ereditato da RepositoryItemButtonEdit)
Metodo protetto | CreateContextButtonOptions | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | CreateContextButtonsCollection | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | CreateContextImageOptions | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | CreateDefaultButton | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | CreateDefaultMaskManager | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | CreateDefaultMaskManagerCore | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | CreateDisplayFormat | (Ereditato da RepositoryItem)
Metodo protetto | CreateEditFormat | (Ereditato da RepositoryItem)
Metodo pubblico | CreateEditor | (Ereditato da RepositoryItem)
Metodo pubblico | CreateGroupPainter | (Ereditato da RepositoryItem)
Metodo protetto | CreateHtmlTemplates | (Ereditato da RepositoryItemComboBox)
Metodo protetto | CreateImageBrick | (Ereditato da RepositoryItem)
Metodo protetto | CreateItemCollection | (Ereditato da RepositoryItemComboBox)
Metodo protetto | CreateLookAndFeel | (Ereditato da RepositoryItem)
Metodo protetto | CreateMaskManager | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | CreateMaskProperties | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | CreateMaskSettings | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | CreateOwnerEditLookAndFeel | (Ereditato da RepositoryItem)
Metodo pubblico | CreatePainter | (Ereditato da RepositoryItem)
Metodo protetto | CreatePanelBrick(PrintCellHelperInfo, Boolean) | (Ereditato da RepositoryItem)
Metodo protetto | CreatePanelBrick(PrintCellHelperInfo, Boolean, BrickStyle) | (Ereditato da RepositoryItem)
Metodo protetto | CreatePopupDisplayFormat | (Ereditato da RepositoryItemComboBox)
Metodo protetto | CreateRepositoryItem | (Ereditato da RepositoryItem)
Metodo protetto | CreateTextBrick | (Ereditato da RepositoryItem)
Metodo pubblico | CreateViewInfo | (Ereditato da RepositoryItem)
Metodo protetto | DenyStandardTextEditStyle | (Ereditato da RepositoryItemButtonEdit)
Metodo protetto | DestroyAppearance | (Ereditato da RepositoryItem)
Metodo protetto | DestroyAppearances | (Ereditato da RepositoryItemComboBox)
Metodo protetto | DestroyLookAndFeel | (Ereditato da RepositoryItem)
Metodo protetto | DestroyStyles | Obsoleto. (Ereditato da RepositoryItem)
Metodo pubblico | Disconnect | (Ereditato da RepositoryItem)
Metodo protetto | Dispose | (Ereditato da RecentlyUsedItemsComboBox)
Metodo protetto | DisposePrevContextImage | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | DoFormatEditValue(Object) | (Ereditato da RepositoryItem)
Metodo protetto | DoFormatEditValue(Object, Boolean) | (Ereditato da RepositoryItem)
Metodo protetto | DoParseEditValue(Object) | (Ereditato da RepositoryItem)
Metodo protetto | DoParseEditValue(Object, Boolean) | (Ereditato da RepositoryItem)
Metodo protetto | DrawFontBoxItem | (Ereditato da RepositoryItemFontEdit)
Metodo pubblico | EditMaskSettings(Object) | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | EditMaskSettings(IWin32Window, Object) | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | EditMaskSettings(IWindowsFormsEditorService, Object) | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | EnableCustomMaskTextInput | (Ereditato da RepositoryItemPopupBaseAutoSearchEdit)
Metodo pubblico | EnableNonMaskedInput | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | EndInit | (Ereditato da RepositoryItemComboBox)
Metodo pubblico | EndUpdate | (Ereditato da RepositoryItem)
Metodo protetto | EnsureMaskSettings | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | FilterProperties | (Ereditato da RepositoryItem)
Metodo protetto | FireChanged | (Ereditato da RepositoryItem)
Metodo protetto | FireChangedFromRepository | (Ereditato da RepositoryItem)
Metodo protetto | FireContainerLoaded | (Ereditato da RepositoryItem)
Metodo protetto | ForceDisplayTextAsNullValuePrompt | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da RepositoryItem)
Metodo protetto | GetAllowContextImageChangeAnimation | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetAllowGlyphSkinning | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetAllowHtmlDraw | (Ereditato da RepositoryItem)
Metodo pubblico | GetBrick | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetBrickImageSource | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetCachedPrintImage | (Ereditato da RepositoryItem)
Metodo protetto | GetCachedPrintImageSource | (Ereditato da RepositoryItem)
Metodo protetto | GetCustomMaskTextInputTag | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetDefaultEditMask | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetDefaultMaskManagerType | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetDesiredPopupFormSize | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | GetDisableTextEditorAsDefaultValue | (Ereditato da RepositoryItemButtonEdit)
Metodo pubblico | GetDisplayText(Object) | (Ereditato da RepositoryItem)
Metodo pubblico | GetDisplayText(FormatInfo, Object) | Ritorna il DisplayText utilizzato per visualizzare nel controllo l'EditValue selezionato. (Sovrascrive RepositoryItemComboBox.GetDisplayText(FormatInfo, Object))
Metodo pubblico | GetEditorType | (Ereditato da RepositoryItem)
Metodo protetto | GetEditValueForExport | (Ereditato da RepositoryItem)
Metodo pubblico | GetEditValueForExportByOptions | (Ereditato da RepositoryItem)
Metodo protetto | GetEventSender | (Ereditato da RepositoryItem)
Metodo protetto | GetExportMode | (Ereditato da RepositoryItemComboBox)
Metodo protetto | GetFormattedDisplayText | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | GetHashCode | (Ereditato da RepositoryItem)
Metodo protetto | GetInPanelrect | (Ereditato da RepositoryItem)
Metodo protetto | GetKeyIncludeCtrlScroll | (Ereditato da RepositoryItemComboBox)
Metodo protetto | GetNullEditText | (Ereditato da RepositoryItemButtonEdit)
Metodo protetto | GetNullText | (Ereditato da RepositoryItem)
Metodo protetto | GetNullValuePrompt | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetOrAddImageSource(PrintingSystemBase, MultiKey, SvgImage) | (Ereditato da RepositoryItem)
Metodo protetto | GetOrAddImageSource(PrintingSystemBase, MultiKey, Image) | (Ereditato da RepositoryItem)
Metodo protetto | GetOrAddImageSource(PrintingSystemBase, MultiKey, Object, Int32) | (Ereditato da RepositoryItem)
Metodo protetto | GetOverrideAppearance | (Ereditato da RepositoryItem)
Metodo protetto | GetPasswordCharCore | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetPrevContextImage | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetSender | (Ereditato da RepositoryItem)
Metodo protetto | GetTextFilterCapabilities | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetUseMaskAsDisplayFormat | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | InitFontItems | (Ereditato da RepositoryItemFontEdit)
Metodo protetto | InitializeEditMaskFromDisplayTextService | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | IsActivateKey | (Ereditato da RepositoryItem)
Metodo protetto | IsButtonEnabled | (Ereditato da RepositoryItemPopupBase)
Metodo pubblico | IsDefault | (Ereditato da RepositoryItem)
Metodo protetto | IsEmptyValue | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | IsFormatTypeCustom | (Ereditato da RepositoryItem)
Metodo protetto | IsListBoxKey | (Ereditato da RepositoryItemComboBox)
Metodo pubblico | IsLockDefaultImmediateUpdateRowPosition | (Ereditato da RepositoryItem)
Metodo protetto | IsNeededChar | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | IsNeededKey | (Ereditato da RepositoryItem)
Metodo protetto | IsNeededKeyCore | (Ereditato da RepositoryItemComboBox)
Metodo protetto | IsNullValue | (Ereditato da RepositoryItem)
Metodo protetto | IsStandardTextEditStyle | (Ereditato da RepositoryItemButtonEdit)
Metodo pubblico | LockEvents | (Ereditato da RepositoryItem)
Metodo pubblico | MarkAsClone | (Ereditato da RepositoryItem)
Metodo protetto | NeededKeysContains | (Ereditato da RepositoryItemComboBox)
Metodo protetto | NeededKeysPopupContains | (Ereditato da RepositoryItemComboBox)
Metodo protetto | OnAllowFocusedChanged | (Ereditato da RepositoryItem)
Metodo protetto | OnAnnotationAttributesLoad | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnAppearanceChanged | (Ereditato da RepositoryItem)
Metodo protetto | OnAppearancePaintChanged | (Ereditato da RepositoryItem)
Metodo protetto | OnAppearanceSizeChanged | (Ereditato da RepositoryItem)
Metodo protetto | OnAutoHeightChanged | (Ereditato da RepositoryItem)
Metodo protetto | OnButtons_CollectionChanged | (Ereditato da RepositoryItemButtonEdit)
Metodo protetto | OnContainerLoaded | (Ereditato da RepositoryItem)
Metodo protetto | OnContextImageChanged | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnContextImageChanging | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnContextImageOptionsChanged | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnContextImageOptionsChanging | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnEnabledChanged | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnFormat_Changed | (Ereditato da RepositoryItemComboBox)
Metodo protetto | OnItems_CollectionChanged | (Ereditato da RepositoryItemComboBox)
Metodo protetto | OnLoaded | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnMaskChanged | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnMaskSettingsChanged | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnOwnerEditChanged | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnPopupFormSizeChanged | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | OnPropertiesChanged | (Ereditato da RepositoryItem)
Metodo protetto | OnPropertiesChanged(EventArgs) | (Ereditato da RepositoryItem)
Metodo protetto | OnStyleChanged | (Ereditato da RepositoryItem)
Metodo protetto | OnTextEditStyleChanged | (Ereditato da RepositoryItemButtonEdit)
Metodo protetto | OnUpdateMaskSettings | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | PreparePrintViewInfo(PrintCellHelperInfo, Boolean) | (Ereditato da RepositoryItem)
Metodo protetto | PreparePrintViewInfo(PrintCellHelperInfo, BaseEditViewInfo, Boolean) | (Ereditato da RepositoryItem)
Metodo protetto | RaiseBeforePopup | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | RaiseBeforeShowMenu | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | RaiseButtonClick | (Ereditato da RepositoryItemButtonEdit)
Metodo protetto | RaiseButtonPressed | (Ereditato da RepositoryItemButtonEdit)
Metodo protetto | RaiseClosed | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | RaiseCloseUp | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | RaiseContextButtonClick | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | RaiseContextButtonValueChanged | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | RaiseCustomDisplayText(CustomDisplayTextEventArgs) | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | RaiseCustomDisplayText(Object, String) | (Ereditato da RepositoryItem)
Metodo protetto | RaiseCustomDisplayText(FormatInfo, Object, String) | (Ereditato da RepositoryItem)
Metodo protetto | RaiseCustomDrawButton | (Ereditato da RepositoryItemButtonEdit)
Metodo protetto | RaiseCustomHighlightText | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | RaiseCustomItemDisplayText | (Ereditato da RepositoryItemComboBox)
Metodo protetto | RaiseCustomItemTemplate | (Ereditato da RepositoryItemComboBox)
Metodo protetto | RaiseCustomizeAutoCompleteSource | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | RaiseCustomizeContextItem | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | RaiseCustomizeItem | (Ereditato da RepositoryItemComboBox)
Metodo protetto | RaiseCustomTextLineHeight | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | RaiseDropDownCustomDrawItem | (Ereditato da RepositoryItemComboBox)
Metodo protetto | RaiseEditValueChanged | (Ereditato da RepositoryItem)
Metodo protetto | RaiseEditValueChangedCore | (Ereditato da RepositoryItem)
Metodo protetto | RaiseEditValueChanging | (Ereditato da RepositoryItem)
Metodo protetto | RaiseFormatEditValue | (Ereditato da RepositoryItem)
Metodo protetto | RaiseHtmlElementMouseClick | (Ereditato da RepositoryItemComboBox)
Metodo protetto | RaiseHtmlElementMouseDown | (Ereditato da RepositoryItemComboBox)
Metodo protetto | RaiseHtmlElementMouseUp | (Ereditato da RepositoryItemComboBox)
Metodo protetto | RaiseMeasureItem | (Ereditato da RepositoryItemComboBox)
Metodo protetto | RaiseModified | (Ereditato da RepositoryItem)
Metodo protetto | RaiseParseEditValue | (Ereditato da RepositoryItem)
Metodo protetto | RaisePopup | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | RaisePopupAllowClick | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | RaisePropertiesChanged | (Ereditato da RepositoryItem)
Metodo protetto | RaiseQueryAccessibilityHelp | (Ereditato da RepositoryItem)
Metodo protetto | RaiseQueryCloseUp | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | RaiseQueryPopUp | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | RaiseQueryProcessKey | (Ereditato da RepositoryItem)
Metodo protetto | RaiseRefreshRequired | (Ereditato da RepositoryItem)
Metodo protetto | RaiseSelectedIndexChanged | (Ereditato da RepositoryItemComboBox)
Metodo protetto | RaiseSelectedValueChanged | (Ereditato da RepositoryItemComboBox)
Metodo protetto | RaiseSpin | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | RecreateMaskManagerOnIsNullInputAllowedChanged | (Ereditato da RepositoryItemTextEdit)
 | RegisterDedFontEdit | Metodo di registrazione del controllo.
Metodo protetto | ResetAccessibleDescription | (Ereditato da RepositoryItem)
Metodo protetto | ResetAccessibleName | (Ereditato da RepositoryItem)
Metodo protetto | ResetAutoHeight | (Ereditato da RepositoryItem)
Metodo protetto | ResetDefaultMaskManager | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | ResetDropDownRows | (Ereditato da RepositoryItemFontEdit)
Metodo pubblico | ResetEvents | (Ereditato da RepositoryItem)
Metodo pubblico | ResetMaskSettings | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | ResetNullText | (Ereditato da RepositoryItem)
Metodo protetto | ResetNullValuePrompt | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | ResetPopupFormMinSize | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | ResetPopupFormSize | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | ResetTextEditStyle | (Ereditato da RepositoryItemButtonEdit)
Metodo pubblico | ScaleProperties | (Ereditato da RepositoryItem)
Metodo protetto | ScalePropertiesCore | (Ereditato da RepositoryItemComboBox)
Metodo pubblico | SetCloned | (Ereditato da RepositoryItem)
Metodo protetto | SetCommonBrickProperties | (Ereditato da RepositoryItem)
Metodo protetto | SetOwnerEdit | (Ereditato da RepositoryItem)
Metodo protetto | SetTextBrickPropertiesCore | (Ereditato da RepositoryItem)
Metodo protetto | SetupCommonBrickStyleProperties | (Ereditato da RepositoryItem)
Metodo protetto | SetupTextBrickStyleProperties | (Ereditato da RepositoryItem)
Metodo protetto | ShouldRaiseCustomDisplayText | (Ereditato da RepositoryItem)
Metodo protetto | ShouldSerializeAccessibleDescription | (Ereditato da RepositoryItem)
Metodo protetto | ShouldSerializeAccessibleName | (Ereditato da RepositoryItem)
Metodo protetto | ShouldSerializeAutoHeight | (Ereditato da RepositoryItem)
Metodo protetto | ShouldSerializeDropDownRows | (Ereditato da RepositoryItemFontEdit)
Metodo protetto | ShouldSerializeItems | (Ereditato da RepositoryItemComboBox)
Metodo pubblico | ShouldSerializeMaskSettings | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | ShouldSerializeNullText | (Ereditato da RepositoryItem)
Metodo protetto | ShouldSerializeNullValuePrompt | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | ShouldSerializePopupFormMinSize | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | ShouldSerializePopupFormSize | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | ShouldSerializeTextEditStyle | (Ereditato da RepositoryItemButtonEdit)
Metodo protetto | StartContextImageChangingAnimation | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | StoreRecentItem | (Ereditato da RecentlyUsedItemsComboBox)
Metodo pubblico | SwitchMode | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | ThrowItemNotInRepositoryWarning | (Ereditato da RepositoryItem)
Metodo pubblico | ToString | (Ereditato da RepositoryItem)
Metodo protetto | ToStringTrimming | (Ereditato da RepositoryItem)
Metodo protetto | TriggerDelayedEditValueChanged | (Ereditato da RepositoryItem)
Metodo protetto | TriggerDelayedEditValueChanged(EventArgs) | (Ereditato da RepositoryItem)
Metodo protetto | TryGetThreadSafeDoFormatEditValueFunc | (Ereditato da RepositoryItem)
Metodo protetto | TryGetThreadSafeGetDisplayTextFunc | (Ereditato da RepositoryItem)
Metodo protetto | TryGetThreadSafeGetFormattedDisplayTextFunc | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | TryGetThreadSafeIsNullValueFunc | (Ereditato da RepositoryItem)
Metodo protetto | TryGetThreadSafeRaiseCustomDisplayTextFunc | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | UnLockEvents | (Ereditato da RepositoryItem)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | BeforePopup | (Ereditato da RepositoryItemPopupBase)
Evento pubblico | BeforeShowMenu | (Ereditato da RepositoryItemTextEdit)
Evento pubblico | ButtonClick | (Ereditato da RepositoryItemButtonEdit)
Evento pubblico | ButtonPressed | (Ereditato da RepositoryItemButtonEdit)
Evento pubblico | Click | (Ereditato da RepositoryItem)
Evento pubblico | Closed | (Ereditato da RepositoryItemPopupBase)
Evento pubblico | CloseUp | (Ereditato da RepositoryItemPopupBase)
Evento pubblico | ContextButtonClick | (Ereditato da RepositoryItemPopupBase)
Evento pubblico | ContextButtonValueChanged | (Ereditato da RepositoryItemPopupBase)
Evento pubblico | CustomDisplayText | (Ereditato da RepositoryItem)
Evento pubblico | CustomDrawButton | (Ereditato da RepositoryItemButtonEdit)
Evento pubblico | CustomHighlightText | (Ereditato da RepositoryItemTextEdit)
Evento pubblico | CustomItemDisplayText | (Ereditato da RepositoryItemComboBox)
Evento pubblico | CustomItemTemplate | (Ereditato da RepositoryItemComboBox)
Evento pubblico | CustomizeAutoCompleteSource | (Ereditato da RepositoryItemTextEdit)
Evento pubblico | CustomizeContextItem | (Ereditato da RepositoryItemPopupBase)
Evento pubblico | CustomizeItem | (Ereditato da RepositoryItemComboBox)
Evento pubblico | CustomTextLineHeight | (Ereditato da RepositoryItemTextEdit)
Evento pubblico | DoubleClick | (Ereditato da RepositoryItem)
Evento pubblico | DragDrop | (Ereditato da RepositoryItem)
Evento pubblico | DragEnter | (Ereditato da RepositoryItem)
Evento pubblico | DragLeave | (Ereditato da RepositoryItem)
Evento pubblico | DragOver | (Ereditato da RepositoryItem)
Evento pubblico | DrawItem | (Ereditato da RepositoryItemComboBox)
Evento pubblico | DropDownCustomDrawItem | Obsoleto. (Ereditato da RepositoryItemComboBox)
Evento pubblico | EditValueChanged | (Ereditato da RepositoryItem)
Evento pubblico | EditValueChanging | (Ereditato da RepositoryItem)
Evento pubblico | Enter | (Ereditato da RepositoryItem)
Evento pubblico | FormatEditValue | (Ereditato da RepositoryItem)
Evento pubblico | GiveFeedback | (Ereditato da RepositoryItem)
Evento pubblico | HelpRequested | (Ereditato da RepositoryItem)
Evento pubblico | HtmlElementMouseClick | (Ereditato da RepositoryItemComboBox)
Evento pubblico | HtmlElementMouseDown | (Ereditato da RepositoryItemComboBox)
Evento pubblico | HtmlElementMouseUp | (Ereditato da RepositoryItemComboBox)
Evento pubblico | KeyDown | (Ereditato da RepositoryItem)
Evento pubblico | KeyPress | (Ereditato da RepositoryItem)
Evento pubblico | KeyUp | (Ereditato da RepositoryItem)
Evento pubblico | Leave | (Ereditato da RepositoryItem)
Evento pubblico | MeasureItem | (Ereditato da RepositoryItemComboBox)
Evento pubblico | Modified | (Ereditato da RepositoryItem)
Evento pubblico | MouseDown | (Ereditato da RepositoryItem)
Evento pubblico | MouseEnter | (Ereditato da RepositoryItem)
Evento pubblico | MouseHover | (Ereditato da RepositoryItem)
Evento pubblico | MouseLeave | (Ereditato da RepositoryItem)
Evento pubblico | MouseMove | (Ereditato da RepositoryItem)
Evento pubblico | MouseUp | (Ereditato da RepositoryItem)
Evento pubblico | MouseWheel | (Ereditato da RepositoryItem)
Evento pubblico | ParseEditValue | (Ereditato da RepositoryItem)
Evento pubblico | Popup | (Ereditato da RepositoryItemPopupBase)
Evento pubblico | PopupAllowClick | (Ereditato da RepositoryItemPopupBase)
Evento pubblico | PropertiesChanged | (Ereditato da RepositoryItem)
Evento pubblico | QueryAccessibilityHelp | (Ereditato da RepositoryItem)
Evento pubblico | QueryCloseUp | (Ereditato da RepositoryItemPopupBase)
Evento pubblico | QueryContinueDrag | (Ereditato da RepositoryItem)
Evento pubblico | QueryPopUp | (Ereditato da RepositoryItemPopupBase)
Evento pubblico | QueryProcessKey | (Ereditato da RepositoryItem)
Evento pubblico | SelectedIndexChanged | (Ereditato da RepositoryItemComboBox)
Evento pubblico | SelectedValueChanged | (Ereditato da RepositoryItemComboBox)
Evento pubblico | Spin | (Ereditato da RepositoryItemTextEdit)
Evento pubblico | Validating | (Ereditato da RepositoryItem)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | Cloned | (Ereditato da RepositoryItem)
Campo protetto | fAllowFocused | (Ereditato da RepositoryItem)
Campo protetto | fAllowMouseWheel | (Ereditato da RepositoryItem)
Campo protetto | fAutoComplete | (Ereditato da RepositoryItemComboBox)
Campo protetto | fAutoHeight | (Ereditato da RepositoryItem)
Campo protetto | fBorderStyle | (Ereditato da RepositoryItem)
Campo protetto | fButtonsStyle | (Ereditato da RepositoryItemButtonEdit)
Campo protetto | fCaseSensitiveSearch | (Ereditato da RepositoryItemComboBox)
Campo protetto | fCharacterCasing | (Ereditato da RepositoryItemTextEdit)
Campo protetto | fCycleOnDblClick | (Ereditato da RepositoryItemComboBox)
Campo protetto | fEditValueChangedFiringMode | (Ereditato da RepositoryItem)
Campo protetto | fEnabled | (Ereditato da RepositoryItem)
Campo protetto | fLockFormatParse | (Ereditato da RepositoryItem)
Campo protetto | fMaxLength | (Ereditato da RepositoryItemTextEdit)
Campo protetto | fNullText | (Ereditato da RepositoryItem)
Campo protetto | fPainter | (Ereditato da RepositoryItem)
Campo protetto | fPasswordChar | (Ereditato da RepositoryItemTextEdit)
Campo protetto | fReadOnly | (Ereditato da RepositoryItem)
Campo protetto | fTextEditStyle | (Ereditato da RepositoryItemButtonEdit)
Campo protetto | fUseCtrlScroll | (Ereditato da RepositoryItemComboBox)
Campo protetto | fValidateOnEnterKey | (Ereditato da RepositoryItemTextEdit)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore RepositoryItemDedFontEdit
Costruttore unico.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public RepositoryItemDedFontEdit()
Public Sub New
public:
RepositoryItemDedFontEdit()
new : unit -> RepositoryItemDedFontEdit
Vedi anche

Documentazione

Classe RepositoryItemDedFontEdit
Namespace DedNet.Controls


Proprietà di RepositoryItemDedFontEdit

Il tipo RepositoryItemDedFontEdit espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AccessibleDefaultActionDescription | (Ereditato da RepositoryItem)
Proprietà pubblica | AccessibleDescription | (Ereditato da RepositoryItem)
Proprietà pubblica | AccessibleName | (Ereditato da RepositoryItem)
Proprietà pubblica | AccessibleRole | (Ereditato da RepositoryItem)
Proprietà pubblica | ActionButtonIndex | (Ereditato da RepositoryItemPopupBase)
Proprietà protetta | ActiveFormat | (Ereditato da RepositoryItem)
Proprietà pubblica | AdvancedModeOptions | (Ereditato da RepositoryItemTextEdit)
Proprietà protetta | AllowCheckExtraKeys | (Ereditato da RepositoryItemPopupBase)
Proprietà protetta | AllowCloseByEscape | (Ereditato da RepositoryItemPopupBase)
Proprietà protetta | AllowClosePopup | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | AllowContextImageChangeAnimation | (Ereditato da RepositoryItemTextEdit)
Proprietà protetta | AllowDefaultClearButtonAction | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | AllowDropDownWhenReadOnly | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | AllowFocused | (Ereditato da RepositoryItem)
Proprietà pubblica | AllowFocusedAppearance | (Ereditato da RepositoryItem)
Proprietà protetta | AllowFormatEditValue | (Ereditato da RepositoryItem)
Proprietà pubblica | AllowGlyphSkinning | (Ereditato da RepositoryItemTextEdit)
Proprietà protetta | AllowHideClearButtonWhenNotFocused | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | AllowHtmlDraw | (Ereditato da RepositoryItem)
Proprietà pubblica | AllowInplaceAutoFilter | (Ereditato da RepositoryItem)
Proprietà pubblica | AllowInplaceBorderPainter | (Ereditato da RepositoryItem)
Proprietà protetta | AllowInputOnOpenPopup | (Ereditato da RepositoryItemPopupBase)
Proprietà protetta | AllowMaskBox | (Ereditato da RepositoryItem)
Proprietà pubblica | AllowMouseWheel | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | AllowNullInput | (Ereditato da RepositoryItemTextEdit)
Proprietà protetta | AllowParseEditValue | (Ereditato da RepositoryItem)
Proprietà protetta | AllowValidateOnEnterKey | (Ereditato da RepositoryItemPopupBase)
Proprietà protetta | AnnotationAttributes | (Ereditato da RepositoryItem)
Proprietà pubblica | Appearance | (Ereditato da RepositoryItem)
Proprietà pubblica | AppearanceDisabled | (Ereditato da RepositoryItem)
Proprietà pubblica | AppearanceDropDown | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | AppearanceFocused | (Ereditato da RepositoryItem)
Proprietà pubblica | AppearanceItemDisabled | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | AppearanceItemHighlight | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | AppearanceItemSelected | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | AppearanceReadOnly | (Ereditato da RepositoryItem)
Proprietà pubblica | AutoComplete | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | AutoHeight | (Ereditato da RepositoryItem)
Proprietà pubblica | BeepOnError | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | BestFitWidth | (Ereditato da RepositoryItem)
Proprietà pubblica | BorderStyle | (Ereditato da RepositoryItem)
Proprietà pubblica | Buttons | (Ereditato da RepositoryItemButtonEdit)
Proprietà pubblica | ButtonsBorderStyle | Obsoleto. (Ereditato da RepositoryItemButtonEdit)
Proprietà pubblica | ButtonsStyle | (Ereditato da RepositoryItemButtonEdit)
Proprietà protetta | CancelPopupInputOnButtonClose | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | CaseSensitiveSearch | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | CharacterCasing | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | CloseUpKey | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | ContextButtonOptions | (Ereditato da RepositoryItemFontEdit)
Proprietà pubblica | ContextButtons | (Ereditato da RepositoryItemFontEdit)
Proprietà pubblica | ContextImage | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | ContextImageAlignment | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | ContextImageOptions | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | ContextMenu | (Ereditato da RepositoryItem)
Proprietà pubblica | ContextMenuStrip | (Ereditato da RepositoryItem)
Proprietà pubblica | CycleOnDblClick | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | DefaultAlignment | (Ereditato da RepositoryItem)
Proprietà pubblica | DefaultBorderStyleInBars | (Ereditato da RepositoryItem)
Proprietà pubblica | DefaultBorderStyleInGrid | (Ereditato da RepositoryItem)
Proprietà protetta | DefaultImmediatePopup | (Ereditato da RepositoryItemPopupBaseAutoSearchEdit)
Proprietà protetta | DefaultPopupSizeable | (Ereditato da RepositoryItemPopupBaseAutoSearchEdit)
Proprietà pubblica | DisplayFormat | (Ereditato da RepositoryItemFontEdit)
Proprietà pubblica | DropDownItemHeight | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | DropDownRows | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | Editable | (Ereditato da RepositoryItem)
Proprietà pubblica | EditFormat | (Ereditato da RepositoryItemFontEdit)
Proprietà protetta | EditorClassInfo | (Ereditato da RepositoryItem)
Proprietà pubblica | EditorTypeName | Override EditorTypeName. (Sovrascrive RepositoryItemFontEdit.EditorTypeName)
Proprietà pubblica | EditValueChangedDelay | (Ereditato da RepositoryItem)
Proprietà pubblica | EditValueChangedFiringMode | (Ereditato da RepositoryItem)
Proprietà pubblica | Enabled | (Ereditato da RepositoryItem)
Proprietà pubblica | ExportMode | (Ereditato da RepositoryItem)
Proprietà protetta | ForceDisableButtonOnReadOnly | (Ereditato da RepositoryItemPopupBase)
Proprietà protetta | HasContextButtons | (Ereditato da RepositoryItemPopupBase)
Proprietà protetta | HasEditValueChangingSubscribers | (Ereditato da RepositoryItem)
Proprietà pubblica | HasEffectiveMaskForDisplayFormating | (Ereditato da RepositoryItemTextEdit)
Proprietà protetta | HasMaskSettings | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | HideSelection | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | HighlightedItemStyle | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | HotTrackDropDownItems | Obsoleto. (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | HotTrackItems | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | HtmlImages | (Ereditato da RepositoryItem)
Proprietà pubblica | HtmlTemplates | (Ereditato da RepositoryItemComboBox)
Proprietà protetta | ImageChangingAnimationProvider | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | ImmediatePopup | (Ereditato da RepositoryItemPopupBaseAutoSearchEdit)
Proprietà pubblica | IsClone | (Ereditato da RepositoryItem)
Proprietà protetta | IsContainerLoaded | (Ereditato da RepositoryItem)
Proprietà pubblica | IsDesignMode | (Ereditato da RepositoryItem)
Proprietà pubblica | IsDisposed | (Ereditato da RepositoryItem)
Proprietà pubblica | IsEditValueChangedEventPending | (Ereditato da RepositoryItem)
Proprietà pubblica | IsFilterLookUp | (Ereditato da RepositoryItem)
Proprietà protetta | IsFirstInit | (Ereditato da RepositoryItem)
Proprietà protetta | IsInImageChangingAnimation | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | IsLoading | (Ereditato da RepositoryItem)
Proprietà protetta | IsLockEvents | (Ereditato da RepositoryItem)
Proprietà pubblica | IsLockUpdate | (Ereditato da RepositoryItem)
Proprietà protetta | IsMeasureItemAssigned | (Ereditato da RepositoryItemComboBox)
Proprietà protetta | IsNeededTextKeys | (Ereditato da RepositoryItemButtonEdit)
Proprietà pubblica | IsNonSortableEditor | (Ereditato da RepositoryItem)
Proprietà protetta | IsNowReadOnly | (Ereditato da RepositoryItemPopupBase)
Proprietà protetta | IsNullInputAllowed | (Ereditato da RepositoryItemTextEdit)
Proprietà protetta | IsPasswordBox | (Ereditato da RepositoryItemTextEdit)
Proprietà protetta | IsReadOnlyAllowsDropDown | (Ereditato da RepositoryItemPopupBase)
Proprietà protetta | IsTryGetThreadSafeFuncValid | (Ereditato da RepositoryItemComboBox)
Proprietà protetta | IsUseDisplayFormat | (Ereditato da RepositoryItemButtonEdit)
Proprietà pubblica | ItemAutoHeight | (Ereditato da RepositoryItemFontEdit)
Proprietà pubblica | ItemPadding | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | Items | (Ereditato da RepositoryItemFontEdit)
Proprietà pubblica | LinkCount | (Ereditato da RepositoryItem)
Proprietà protetta | Links | (Ereditato da RepositoryItem)
Proprietà protetta | LockDefaultImmediateUpdateRowPosition | (Ereditato da RepositoryItem)
Proprietà protetta | LockFormatParse | (Ereditato da RepositoryItem)
Proprietà pubblica | LookAndFeel | (Ereditato da RepositoryItem)
Proprietà pubblica | Mask | (Ereditato da RepositoryItemFontEdit)
Proprietà pubblica | MaskBoxPadding | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | MaskSettings | (Ereditato da RepositoryItemFontEdit)
Proprietà pubblica | MaxLength | (Ereditato da RepositoryItemTextEdit)
Proprietà protetta | MenuHotKey | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | Name | (Ereditato da RepositoryItem)
Proprietà pubblica | NullText | (Ereditato da RepositoryItem)
Proprietà pubblica | NullValuePrompt | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | NullValuePromptForeColor | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | NullValuePromptShowForEmptyValue | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | OwnerEdit | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | OwnerItem | (Ereditato da RepositoryItem)
Proprietà pubblica | Padding | (Ereditato da RepositoryItemTextEdit)
Proprietà protetta | Painter | (Ereditato da RepositoryItem)
Proprietà pubblica | PasswordChar | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | PopupBorderStyle | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | PopupDisplayFormat | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | PopupFormMinSize | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | PopupFormSize | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | PopupFormWidth | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | PopupOffset | (Ereditato da RepositoryItem)
Proprietà pubblica | PopupResizeMode | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | PopupSizeable | (Ereditato da RepositoryItemPopupBaseAutoSearchEdit)
Proprietà protetta | PostponeDelayedEditValueTimer | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | Properties | Obsoleto. (Ereditato da RepositoryItemComboBox)
Proprietà protetta | PropertyStore | (Ereditato da RepositoryItem)
Proprietà pubblica | ReadOnly | (Ereditato da RepositoryItem)
Proprietà pubblica | RecentlyUsedItemCount | (Ereditato da RepositoryItemFontEdit)
Proprietà pubblica | RequireDisplayTextSorting | (Ereditato da RepositoryItem)
Proprietà protetta | RequireFakeDesigner | (Ereditato da RepositoryItem)
Proprietà pubblica | ResetTextEditStyleToStandardInFilterControl | (Ereditato da RepositoryItemButtonEdit)
Proprietà protetta | ShouldCreateMaskSettingsWhenMaskLoadedOrUpdated | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | ShowDropDown | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | ShowNullValuePrompt | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | ShowNullValuePromptWhenFocused | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | ShowNullValuePromptWhenReadOnly | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | ShowOnlyRegularStyleFonts | (Ereditato da RepositoryItemFontEdit)
Proprietà pubblica | ShowPopupShadow | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | ShowSymbolFontPreview | (Ereditato da RepositoryItemFontEdit)
Proprietà pubblica | ShowToolTipForTrimmedText | (Ereditato da RepositoryItemFontEdit)
Proprietà pubblica | Site | (Ereditato da RepositoryItem)
Proprietà pubblica | Sorted | (Ereditato da RepositoryItemComboBox)
Proprietà protetta | StyleController | (Ereditato da RepositoryItem)
Proprietà pubblica | SuppressMouseEventOnOuterMouseClick | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | Tag | (Ereditato da RepositoryItem)
Proprietà pubblica | TextEditStyle | (Ereditato da RepositoryItemFontEdit)
Proprietà protetta | UpdateEditValueFromPopup | (Ereditato da RepositoryItemComboBox)
Proprietà pubblica | UseAdvancedMode | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | UseCtrlScroll | (Ereditato da RepositoryItemComboBox)
Proprietà protetta | UseDisplayTextAsNullValuePrompt | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | UseMaskAsDisplayFormat | (Ereditato da RepositoryItemFontEdit)
Proprietà protetta | UseMaskBox | (Ereditato da RepositoryItemTextEdit)
Proprietà protetta | UseMaskedInput | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | UseParentBackground | (Ereditato da RepositoryItem)
Proprietà pubblica | UseReadOnlyAppearance | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | UseSystemPasswordChar | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | UseTextEditorForAutoFilter | (Ereditato da RepositoryItemButtonEdit)
Proprietà pubblica | ValidateOnEnterKey | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | XlsxFormatString | (Ereditato da RepositoryItemTextEdit)
Torna su
Vedi anche

Documentazione

Classe RepositoryItemDedFontEdit
Namespace DedNet.Controls


Proprietà RepositoryItemDedFontEdit.EditorTypeName

Proprietà RepositoryItemDedFontEditEditorTypeName
Override EditorTypeName.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string EditorTypeName { get; }
Public Overrides ReadOnly Property EditorTypeName As String
    Get
public:
virtual property String^ EditorTypeName {
    String^ get () override;
}
abstract EditorTypeName : string with get
override EditorTypeName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe RepositoryItemDedFontEdit
Namespace DedNet.Controls


Metodi di RepositoryItemDedFontEdit

Il tipo RepositoryItemDedFontEdit espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | AcceptModifiedEditValueTextAsEditValue | (Ereditato da RepositoryItemPopupBaseAutoSearchEdit)
Metodo protetto | AcceptSearchTextAsEditValue | (Ereditato da RepositoryItemPopupBaseAutoSearchEdit)
Metodo protetto | ActivationKeysContains | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | AddImageSourceToPrintCache(PrintingSystemBase, MultiKey, SvgImage) | (Ereditato da RepositoryItem)
Metodo protetto | AddImageSourceToPrintCache(PrintingSystemBase, MultiKey, Image) | (Ereditato da RepositoryItem)
Metodo protetto | AddImageSourceToPrintCache(PrintingSystemBase, MultiKey, Object, Int32) | (Ereditato da RepositoryItem)
Metodo protetto | AddImageToPrintCache | (Ereditato da RepositoryItem)
Metodo protetto | AllowMaskManagerType | (Ereditato da RepositoryItemPopupBase)
Metodo pubblico | Assign | (Ereditato da RepositoryItemFontEdit)
Metodo protetto | AssignEvents | (Ereditato da RepositoryItemComboBox)
Metodo protetto | AssignMasks | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | AssignNullValuePromptSettings | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | AssignOwnerEditEvents | (Ereditato da RepositoryItem)
Metodo protetto | AssignTextBrickFormatSettings | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | AssignTextBrickText | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | BeginInit | (Ereditato da RepositoryItemComboBox)
Metodo pubblico | BeginUpdate | (Ereditato da RepositoryItem)
Metodo protetto | BreakAnimations | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | CalcPaddingInfo | (Ereditato da RepositoryItem)
Metodo protetto | CalcPasswordCharMaskedText | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | CancelUpdate | (Ereditato da RepositoryItem)
Metodo protetto | CanEditNumericValueType | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | Clone | (Ereditato da RepositoryItem)
Metodo protetto | CompleteChanges | (Ereditato da RepositoryItem)
Metodo pubblico | Connect | (Ereditato da RepositoryItem)
Metodo protetto | ConvertTextFilterValue | (Ereditato da RepositoryItem)
Metodo protetto | CreateAccessibleInstance | (Ereditato da RepositoryItem)
Metodo protetto | CreateAdvancedModeOptions | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | CreateAppearance | (Ereditato da RepositoryItem)
Metodo protetto | CreateAppearanceCore | (Ereditato da RepositoryItem)
Metodo protetto | CreateBrickStyle | (Ereditato da RepositoryItem)
Metodo protetto | CreateButtonCollection | (Ereditato da RepositoryItemButtonEdit)
Metodo protetto | CreateContextButtonOptions | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | CreateContextButtonsCollection | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | CreateContextImageOptions | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | CreateDefaultButton | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | CreateDefaultMaskManager | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | CreateDefaultMaskManagerCore | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | CreateDisplayFormat | (Ereditato da RepositoryItem)
Metodo protetto | CreateEditFormat | (Ereditato da RepositoryItem)
Metodo pubblico | CreateEditor | (Ereditato da RepositoryItem)
Metodo pubblico | CreateGroupPainter | (Ereditato da RepositoryItem)
Metodo protetto | CreateHtmlTemplates | (Ereditato da RepositoryItemComboBox)
Metodo protetto | CreateImageBrick | (Ereditato da RepositoryItem)
Metodo protetto | CreateItemCollection | (Ereditato da RepositoryItemComboBox)
Metodo protetto | CreateLookAndFeel | (Ereditato da RepositoryItem)
Metodo protetto | CreateMaskManager | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | CreateMaskProperties | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | CreateMaskSettings | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | CreateOwnerEditLookAndFeel | (Ereditato da RepositoryItem)
Metodo pubblico | CreatePainter | (Ereditato da RepositoryItem)
Metodo protetto | CreatePanelBrick(PrintCellHelperInfo, Boolean) | (Ereditato da RepositoryItem)
Metodo protetto | CreatePanelBrick(PrintCellHelperInfo, Boolean, BrickStyle) | (Ereditato da RepositoryItem)
Metodo protetto | CreatePopupDisplayFormat | (Ereditato da RepositoryItemComboBox)
Metodo protetto | CreateRepositoryItem | (Ereditato da RepositoryItem)
Metodo protetto | CreateTextBrick | (Ereditato da RepositoryItem)
Metodo pubblico | CreateViewInfo | (Ereditato da RepositoryItem)
Metodo protetto | DenyStandardTextEditStyle | (Ereditato da RepositoryItemButtonEdit)
Metodo protetto | DestroyAppearance | (Ereditato da RepositoryItem)
Metodo protetto | DestroyAppearances | (Ereditato da RepositoryItemComboBox)
Metodo protetto | DestroyLookAndFeel | (Ereditato da RepositoryItem)
Metodo protetto | DestroyStyles | Obsoleto. (Ereditato da RepositoryItem)
Metodo pubblico | Disconnect | (Ereditato da RepositoryItem)
Metodo protetto | Dispose | (Ereditato da RecentlyUsedItemsComboBox)
Metodo protetto | DisposePrevContextImage | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | DoFormatEditValue(Object) | (Ereditato da RepositoryItem)
Metodo protetto | DoFormatEditValue(Object, Boolean) | (Ereditato da RepositoryItem)
Metodo protetto | DoParseEditValue(Object) | (Ereditato da RepositoryItem)
Metodo protetto | DoParseEditValue(Object, Boolean) | (Ereditato da RepositoryItem)
Metodo protetto | DrawFontBoxItem | (Ereditato da RepositoryItemFontEdit)
Metodo pubblico | EditMaskSettings(Object) | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | EditMaskSettings(IWin32Window, Object) | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | EditMaskSettings(IWindowsFormsEditorService, Object) | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | EnableCustomMaskTextInput | (Ereditato da RepositoryItemPopupBaseAutoSearchEdit)
Metodo pubblico | EnableNonMaskedInput | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | EndInit | (Ereditato da RepositoryItemComboBox)
Metodo pubblico | EndUpdate | (Ereditato da RepositoryItem)
Metodo protetto | EnsureMaskSettings | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | FilterProperties | (Ereditato da RepositoryItem)
Metodo protetto | FireChanged | (Ereditato da RepositoryItem)
Metodo protetto | FireChangedFromRepository | (Ereditato da RepositoryItem)
Metodo protetto | FireContainerLoaded | (Ereditato da RepositoryItem)
Metodo protetto | ForceDisplayTextAsNullValuePrompt | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da RepositoryItem)
Metodo protetto | GetAllowContextImageChangeAnimation | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetAllowGlyphSkinning | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetAllowHtmlDraw | (Ereditato da RepositoryItem)
Metodo pubblico | GetBrick | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetBrickImageSource | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetCachedPrintImage | (Ereditato da RepositoryItem)
Metodo protetto | GetCachedPrintImageSource | (Ereditato da RepositoryItem)
Metodo protetto | GetCustomMaskTextInputTag | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetDefaultEditMask | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetDefaultMaskManagerType | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetDesiredPopupFormSize | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | GetDisableTextEditorAsDefaultValue | (Ereditato da RepositoryItemButtonEdit)
Metodo pubblico | GetDisplayText(Object) | (Ereditato da RepositoryItem)
Metodo pubblico | GetDisplayText(FormatInfo, Object) | Ritorna il DisplayText utilizzato per visualizzare nel controllo l'EditValue selezionato. (Sovrascrive RepositoryItemComboBox.GetDisplayText(FormatInfo, Object))
Metodo pubblico | GetEditorType | (Ereditato da RepositoryItem)
Metodo protetto | GetEditValueForExport | (Ereditato da RepositoryItem)
Metodo pubblico | GetEditValueForExportByOptions | (Ereditato da RepositoryItem)
Metodo protetto | GetEventSender | (Ereditato da RepositoryItem)
Metodo protetto | GetExportMode | (Ereditato da RepositoryItemComboBox)
Metodo protetto | GetFormattedDisplayText | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | GetHashCode | (Ereditato da RepositoryItem)
Metodo protetto | GetInPanelrect | (Ereditato da RepositoryItem)
Metodo protetto | GetKeyIncludeCtrlScroll | (Ereditato da RepositoryItemComboBox)
Metodo protetto | GetNullEditText | (Ereditato da RepositoryItemButtonEdit)
Metodo protetto | GetNullText | (Ereditato da RepositoryItem)
Metodo protetto | GetNullValuePrompt | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetOrAddImageSource(PrintingSystemBase, MultiKey, SvgImage) | (Ereditato da RepositoryItem)
Metodo protetto | GetOrAddImageSource(PrintingSystemBase, MultiKey, Image) | (Ereditato da RepositoryItem)
Metodo protetto | GetOrAddImageSource(PrintingSystemBase, MultiKey, Object, Int32) | (Ereditato da RepositoryItem)
Metodo protetto | GetOverrideAppearance | (Ereditato da RepositoryItem)
Metodo protetto | GetPasswordCharCore | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetPrevContextImage | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetSender | (Ereditato da RepositoryItem)
Metodo protetto | GetTextFilterCapabilities | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetUseMaskAsDisplayFormat | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | InitFontItems | (Ereditato da RepositoryItemFontEdit)
Metodo protetto | InitializeEditMaskFromDisplayTextService | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | IsActivateKey | (Ereditato da RepositoryItem)
Metodo protetto | IsButtonEnabled | (Ereditato da RepositoryItemPopupBase)
Metodo pubblico | IsDefault | (Ereditato da RepositoryItem)
Metodo protetto | IsEmptyValue | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | IsFormatTypeCustom | (Ereditato da RepositoryItem)
Metodo protetto | IsListBoxKey | (Ereditato da RepositoryItemComboBox)
Metodo pubblico | IsLockDefaultImmediateUpdateRowPosition | (Ereditato da RepositoryItem)
Metodo protetto | IsNeededChar | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | IsNeededKey | (Ereditato da RepositoryItem)
Metodo protetto | IsNeededKeyCore | (Ereditato da RepositoryItemComboBox)
Metodo protetto | IsNullValue | (Ereditato da RepositoryItem)
Metodo protetto | IsStandardTextEditStyle | (Ereditato da RepositoryItemButtonEdit)
Metodo pubblico | LockEvents | (Ereditato da RepositoryItem)
Metodo pubblico | MarkAsClone | (Ereditato da RepositoryItem)
Metodo protetto | NeededKeysContains | (Ereditato da RepositoryItemComboBox)
Metodo protetto | NeededKeysPopupContains | (Ereditato da RepositoryItemComboBox)
Metodo protetto | OnAllowFocusedChanged | (Ereditato da RepositoryItem)
Metodo protetto | OnAnnotationAttributesLoad | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnAppearanceChanged | (Ereditato da RepositoryItem)
Metodo protetto | OnAppearancePaintChanged | (Ereditato da RepositoryItem)
Metodo protetto | OnAppearanceSizeChanged | (Ereditato da RepositoryItem)
Metodo protetto | OnAutoHeightChanged | (Ereditato da RepositoryItem)
Metodo protetto | OnButtons_CollectionChanged | (Ereditato da RepositoryItemButtonEdit)
Metodo protetto | OnContainerLoaded | (Ereditato da RepositoryItem)
Metodo protetto | OnContextImageChanged | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnContextImageChanging | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnContextImageOptionsChanged | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnContextImageOptionsChanging | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnEnabledChanged | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnFormat_Changed | (Ereditato da RepositoryItemComboBox)
Metodo protetto | OnItems_CollectionChanged | (Ereditato da RepositoryItemComboBox)
Metodo protetto | OnLoaded | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnMaskChanged | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnMaskSettingsChanged | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnOwnerEditChanged | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnPopupFormSizeChanged | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | OnPropertiesChanged | (Ereditato da RepositoryItem)
Metodo protetto | OnPropertiesChanged(EventArgs) | (Ereditato da RepositoryItem)
Metodo protetto | OnStyleChanged | (Ereditato da RepositoryItem)
Metodo protetto | OnTextEditStyleChanged | (Ereditato da RepositoryItemButtonEdit)
Metodo protetto | OnUpdateMaskSettings | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | PreparePrintViewInfo(PrintCellHelperInfo, Boolean) | (Ereditato da RepositoryItem)
Metodo protetto | PreparePrintViewInfo(PrintCellHelperInfo, BaseEditViewInfo, Boolean) | (Ereditato da RepositoryItem)
Metodo protetto | RaiseBeforePopup | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | RaiseBeforeShowMenu | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | RaiseButtonClick | (Ereditato da RepositoryItemButtonEdit)
Metodo protetto | RaiseButtonPressed | (Ereditato da RepositoryItemButtonEdit)
Metodo protetto | RaiseClosed | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | RaiseCloseUp | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | RaiseContextButtonClick | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | RaiseContextButtonValueChanged | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | RaiseCustomDisplayText(CustomDisplayTextEventArgs) | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | RaiseCustomDisplayText(Object, String) | (Ereditato da RepositoryItem)
Metodo protetto | RaiseCustomDisplayText(FormatInfo, Object, String) | (Ereditato da RepositoryItem)
Metodo protetto | RaiseCustomDrawButton | (Ereditato da RepositoryItemButtonEdit)
Metodo protetto | RaiseCustomHighlightText | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | RaiseCustomItemDisplayText | (Ereditato da RepositoryItemComboBox)
Metodo protetto | RaiseCustomItemTemplate | (Ereditato da RepositoryItemComboBox)
Metodo protetto | RaiseCustomizeAutoCompleteSource | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | RaiseCustomizeContextItem | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | RaiseCustomizeItem | (Ereditato da RepositoryItemComboBox)
Metodo protetto | RaiseCustomTextLineHeight | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | RaiseDropDownCustomDrawItem | (Ereditato da RepositoryItemComboBox)
Metodo protetto | RaiseEditValueChanged | (Ereditato da RepositoryItem)
Metodo protetto | RaiseEditValueChangedCore | (Ereditato da RepositoryItem)
Metodo protetto | RaiseEditValueChanging | (Ereditato da RepositoryItem)
Metodo protetto | RaiseFormatEditValue | (Ereditato da RepositoryItem)
Metodo protetto | RaiseHtmlElementMouseClick | (Ereditato da RepositoryItemComboBox)
Metodo protetto | RaiseHtmlElementMouseDown | (Ereditato da RepositoryItemComboBox)
Metodo protetto | RaiseHtmlElementMouseUp | (Ereditato da RepositoryItemComboBox)
Metodo protetto | RaiseMeasureItem | (Ereditato da RepositoryItemComboBox)
Metodo protetto | RaiseModified | (Ereditato da RepositoryItem)
Metodo protetto | RaiseParseEditValue | (Ereditato da RepositoryItem)
Metodo protetto | RaisePopup | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | RaisePopupAllowClick | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | RaisePropertiesChanged | (Ereditato da RepositoryItem)
Metodo protetto | RaiseQueryAccessibilityHelp | (Ereditato da RepositoryItem)
Metodo protetto | RaiseQueryCloseUp | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | RaiseQueryPopUp | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | RaiseQueryProcessKey | (Ereditato da RepositoryItem)
Metodo protetto | RaiseRefreshRequired | (Ereditato da RepositoryItem)
Metodo protetto | RaiseSelectedIndexChanged | (Ereditato da RepositoryItemComboBox)
Metodo protetto | RaiseSelectedValueChanged | (Ereditato da RepositoryItemComboBox)
Metodo protetto | RaiseSpin | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | RecreateMaskManagerOnIsNullInputAllowedChanged | (Ereditato da RepositoryItemTextEdit)
 | RegisterDedFontEdit | Metodo di registrazione del controllo.
Metodo protetto | ResetAccessibleDescription | (Ereditato da RepositoryItem)
Metodo protetto | ResetAccessibleName | (Ereditato da RepositoryItem)
Metodo protetto | ResetAutoHeight | (Ereditato da RepositoryItem)
Metodo protetto | ResetDefaultMaskManager | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | ResetDropDownRows | (Ereditato da RepositoryItemFontEdit)
Metodo pubblico | ResetEvents | (Ereditato da RepositoryItem)
Metodo pubblico | ResetMaskSettings | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | ResetNullText | (Ereditato da RepositoryItem)
Metodo protetto | ResetNullValuePrompt | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | ResetPopupFormMinSize | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | ResetPopupFormSize | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | ResetTextEditStyle | (Ereditato da RepositoryItemButtonEdit)
Metodo pubblico | ScaleProperties | (Ereditato da RepositoryItem)
Metodo protetto | ScalePropertiesCore | (Ereditato da RepositoryItemComboBox)
Metodo pubblico | SetCloned | (Ereditato da RepositoryItem)
Metodo protetto | SetCommonBrickProperties | (Ereditato da RepositoryItem)
Metodo protetto | SetOwnerEdit | (Ereditato da RepositoryItem)
Metodo protetto | SetTextBrickPropertiesCore | (Ereditato da RepositoryItem)
Metodo protetto | SetupCommonBrickStyleProperties | (Ereditato da RepositoryItem)
Metodo protetto | SetupTextBrickStyleProperties | (Ereditato da RepositoryItem)
Metodo protetto | ShouldRaiseCustomDisplayText | (Ereditato da RepositoryItem)
Metodo protetto | ShouldSerializeAccessibleDescription | (Ereditato da RepositoryItem)
Metodo protetto | ShouldSerializeAccessibleName | (Ereditato da RepositoryItem)
Metodo protetto | ShouldSerializeAutoHeight | (Ereditato da RepositoryItem)
Metodo protetto | ShouldSerializeDropDownRows | (Ereditato da RepositoryItemFontEdit)
Metodo protetto | ShouldSerializeItems | (Ereditato da RepositoryItemComboBox)
Metodo pubblico | ShouldSerializeMaskSettings | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | ShouldSerializeNullText | (Ereditato da RepositoryItem)
Metodo protetto | ShouldSerializeNullValuePrompt | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | ShouldSerializePopupFormMinSize | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | ShouldSerializePopupFormSize | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | ShouldSerializeTextEditStyle | (Ereditato da RepositoryItemButtonEdit)
Metodo protetto | StartContextImageChangingAnimation | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | StoreRecentItem | (Ereditato da RecentlyUsedItemsComboBox)
Metodo pubblico | SwitchMode | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | ThrowItemNotInRepositoryWarning | (Ereditato da RepositoryItem)
Metodo pubblico | ToString | (Ereditato da RepositoryItem)
Metodo protetto | ToStringTrimming | (Ereditato da RepositoryItem)
Metodo protetto | TriggerDelayedEditValueChanged | (Ereditato da RepositoryItem)
Metodo protetto | TriggerDelayedEditValueChanged(EventArgs) | (Ereditato da RepositoryItem)
Metodo protetto | TryGetThreadSafeDoFormatEditValueFunc | (Ereditato da RepositoryItem)
Metodo protetto | TryGetThreadSafeGetDisplayTextFunc | (Ereditato da RepositoryItem)
Metodo protetto | TryGetThreadSafeGetFormattedDisplayTextFunc | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | TryGetThreadSafeIsNullValueFunc | (Ereditato da RepositoryItem)
Metodo protetto | TryGetThreadSafeRaiseCustomDisplayTextFunc | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | UnLockEvents | (Ereditato da RepositoryItem)
Torna su
Vedi anche

Documentazione

Classe RepositoryItemDedFontEdit
Namespace DedNet.Controls


Metodo RepositoryItemDedFontEdit.GetDisplayText

Metodo RepositoryItemDedFontEditGetDisplayText
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | GetDisplayText(Object) |
Metodo pubblico | GetDisplayText(FormatInfo, Object) | Ritorna il DisplayText utilizzato per visualizzare nel controllo l'EditValue selezionato.
Torna su
Vedi anche

Documentazione

Classe RepositoryItemDedFontEdit
Namespace DedNet.Controls


Metodo RepositoryItemDedFontEdit.GetDisplayText(FormatInfo, Object)

Metodo RepositoryItemDedFontEditGetDisplayText(FormatInfo, Object)
Ritorna il DisplayText utilizzato per visualizzare nel controllo l'EditValue selezionato.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string GetDisplayText(
    FormatInfo format,
    Object editValue
)
Public Overrides Function GetDisplayText (
    format As FormatInfo,
    editValue As Object
) As String
public:
virtual String^ GetDisplayText(
    FormatInfo^ format,
    Object^ editValue
) override
abstract GetDisplayText :
        format : FormatInfo *
        editValue : Object -> string
override GetDisplayText :
        format : FormatInfo *
        editValue : Object -> string

Parametri

format FormatInfo
editValue Object

Valore di ritorno

String
Vedi anche

Documentazione

Classe RepositoryItemDedFontEdit
Overload di GetDisplayText
Namespace DedNet.Controls


Metodo RepositoryItemDedFontEdit.RegisterDedFontEdit

Metodo RepositoryItemDedFontEditRegisterDedFontEdit
Metodo di registrazione del controllo.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void RegisterDedFontEdit()
Public Shared Sub RegisterDedFontEdit
public:
static void RegisterDedFontEdit()
static member RegisterDedFontEdit : unit -> unit
Vedi anche

Documentazione

Classe RepositoryItemDedFontEdit
Namespace DedNet.Controls


Eventi di RepositoryItemDedFontEdit

Il tipo RepositoryItemDedFontEdit espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | BeforePopup | (Ereditato da RepositoryItemPopupBase)
Evento pubblico | BeforeShowMenu | (Ereditato da RepositoryItemTextEdit)
Evento pubblico | ButtonClick | (Ereditato da RepositoryItemButtonEdit)
Evento pubblico | ButtonPressed | (Ereditato da RepositoryItemButtonEdit)
Evento pubblico | Click | (Ereditato da RepositoryItem)
Evento pubblico | Closed | (Ereditato da RepositoryItemPopupBase)
Evento pubblico | CloseUp | (Ereditato da RepositoryItemPopupBase)
Evento pubblico | ContextButtonClick | (Ereditato da RepositoryItemPopupBase)
Evento pubblico | ContextButtonValueChanged | (Ereditato da RepositoryItemPopupBase)
Evento pubblico | CustomDisplayText | (Ereditato da RepositoryItem)
Evento pubblico | CustomDrawButton | (Ereditato da RepositoryItemButtonEdit)
Evento pubblico | CustomHighlightText | (Ereditato da RepositoryItemTextEdit)
Evento pubblico | CustomItemDisplayText | (Ereditato da RepositoryItemComboBox)
Evento pubblico | CustomItemTemplate | (Ereditato da RepositoryItemComboBox)
Evento pubblico | CustomizeAutoCompleteSource | (Ereditato da RepositoryItemTextEdit)
Evento pubblico | CustomizeContextItem | (Ereditato da RepositoryItemPopupBase)
Evento pubblico | CustomizeItem | (Ereditato da RepositoryItemComboBox)
Evento pubblico | CustomTextLineHeight | (Ereditato da RepositoryItemTextEdit)
Evento pubblico | DoubleClick | (Ereditato da RepositoryItem)
Evento pubblico | DragDrop | (Ereditato da RepositoryItem)
Evento pubblico | DragEnter | (Ereditato da RepositoryItem)
Evento pubblico | DragLeave | (Ereditato da RepositoryItem)
Evento pubblico | DragOver | (Ereditato da RepositoryItem)
Evento pubblico | DrawItem | (Ereditato da RepositoryItemComboBox)
Evento pubblico | DropDownCustomDrawItem | Obsoleto. (Ereditato da RepositoryItemComboBox)
Evento pubblico | EditValueChanged | (Ereditato da RepositoryItem)
Evento pubblico | EditValueChanging | (Ereditato da RepositoryItem)
Evento pubblico | Enter | (Ereditato da RepositoryItem)
Evento pubblico | FormatEditValue | (Ereditato da RepositoryItem)
Evento pubblico | GiveFeedback | (Ereditato da RepositoryItem)
Evento pubblico | HelpRequested | (Ereditato da RepositoryItem)
Evento pubblico | HtmlElementMouseClick | (Ereditato da RepositoryItemComboBox)
Evento pubblico | HtmlElementMouseDown | (Ereditato da RepositoryItemComboBox)
Evento pubblico | HtmlElementMouseUp | (Ereditato da RepositoryItemComboBox)
Evento pubblico | KeyDown | (Ereditato da RepositoryItem)
Evento pubblico | KeyPress | (Ereditato da RepositoryItem)
Evento pubblico | KeyUp | (Ereditato da RepositoryItem)
Evento pubblico | Leave | (Ereditato da RepositoryItem)
Evento pubblico | MeasureItem | (Ereditato da RepositoryItemComboBox)
Evento pubblico | Modified | (Ereditato da RepositoryItem)
Evento pubblico | MouseDown | (Ereditato da RepositoryItem)
Evento pubblico | MouseEnter | (Ereditato da RepositoryItem)
Evento pubblico | MouseHover | (Ereditato da RepositoryItem)
Evento pubblico | MouseLeave | (Ereditato da RepositoryItem)
Evento pubblico | MouseMove | (Ereditato da RepositoryItem)
Evento pubblico | MouseUp | (Ereditato da RepositoryItem)
Evento pubblico | MouseWheel | (Ereditato da RepositoryItem)
Evento pubblico | ParseEditValue | (Ereditato da RepositoryItem)
Evento pubblico | Popup | (Ereditato da RepositoryItemPopupBase)
Evento pubblico | PopupAllowClick | (Ereditato da RepositoryItemPopupBase)
Evento pubblico | PropertiesChanged | (Ereditato da RepositoryItem)
Evento pubblico | QueryAccessibilityHelp | (Ereditato da RepositoryItem)
Evento pubblico | QueryCloseUp | (Ereditato da RepositoryItemPopupBase)
Evento pubblico | QueryContinueDrag | (Ereditato da RepositoryItem)
Evento pubblico | QueryPopUp | (Ereditato da RepositoryItemPopupBase)
Evento pubblico | QueryProcessKey | (Ereditato da RepositoryItem)
Evento pubblico | SelectedIndexChanged | (Ereditato da RepositoryItemComboBox)
Evento pubblico | SelectedValueChanged | (Ereditato da RepositoryItemComboBox)
Evento pubblico | Spin | (Ereditato da RepositoryItemTextEdit)
Evento pubblico | Validating | (Ereditato da RepositoryItem)
Torna su
Vedi anche

Documentazione

Classe RepositoryItemDedFontEdit
Namespace DedNet.Controls


Campi di RepositoryItemDedFontEdit

Il tipo RepositoryItemDedFontEdit espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | Cloned | (Ereditato da RepositoryItem)
Campo protetto | fAllowFocused | (Ereditato da RepositoryItem)
Campo protetto | fAllowMouseWheel | (Ereditato da RepositoryItem)
Campo protetto | fAutoComplete | (Ereditato da RepositoryItemComboBox)
Campo protetto | fAutoHeight | (Ereditato da RepositoryItem)
Campo protetto | fBorderStyle | (Ereditato da RepositoryItem)
Campo protetto | fButtonsStyle | (Ereditato da RepositoryItemButtonEdit)
Campo protetto | fCaseSensitiveSearch | (Ereditato da RepositoryItemComboBox)
Campo protetto | fCharacterCasing | (Ereditato da RepositoryItemTextEdit)
Campo protetto | fCycleOnDblClick | (Ereditato da RepositoryItemComboBox)
Campo protetto | fEditValueChangedFiringMode | (Ereditato da RepositoryItem)
Campo protetto | fEnabled | (Ereditato da RepositoryItem)
Campo protetto | fLockFormatParse | (Ereditato da RepositoryItem)
Campo protetto | fMaxLength | (Ereditato da RepositoryItemTextEdit)
Campo protetto | fNullText | (Ereditato da RepositoryItem)
Campo protetto | fPainter | (Ereditato da RepositoryItem)
Campo protetto | fPasswordChar | (Ereditato da RepositoryItemTextEdit)
Campo protetto | fReadOnly | (Ereditato da RepositoryItem)
Campo protetto | fTextEditStyle | (Ereditato da RepositoryItemButtonEdit)
Campo protetto | fUseCtrlScroll | (Ereditato da RepositoryItemComboBox)
Campo protetto | fValidateOnEnterKey | (Ereditato da RepositoryItemTextEdit)
Torna su
Vedi anche

Documentazione

Classe RepositoryItemDedFontEdit
Namespace DedNet.Controls


Classe RepositoryItemDedTextSpinEdit
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
ComponentBase
RepositoryItem
RepositoryItemTextEdit
RepositoryItemButtonEdit
RepositoryItemPopupBase
RepositoryItemBaseSpinEdit
DedNet.ControlsRepositoryItemDedTextSpinEdit

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class RepositoryItemDedTextSpinEdit : RepositoryItemBaseSpinEdit
Public Class RepositoryItemDedTextSpinEdit
    Inherits RepositoryItemBaseSpinEdit
public ref class RepositoryItemDedTextSpinEdit : public RepositoryItemBaseSpinEdit
type RepositoryItemDedTextSpinEdit =
    class
        inherit RepositoryItemBaseSpinEdit
    end

Il tipo RepositoryItemDedTextSpinEdit espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | RepositoryItemDedTextSpinEdit |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AccessibleDefaultActionDescription | (Ereditato da RepositoryItem)
Proprietà pubblica | AccessibleDescription | (Ereditato da RepositoryItem)
Proprietà pubblica | AccessibleName | (Ereditato da RepositoryItem)
Proprietà pubblica | AccessibleRole | (Ereditato da RepositoryItem)
Proprietà pubblica | ActionButtonIndex | (Ereditato da RepositoryItemBaseSpinEdit)
Proprietà protetta | ActiveFormat | (Ereditato da RepositoryItem)
Proprietà pubblica | AdvancedModeOptions | (Ereditato da RepositoryItemTextEdit)
Proprietà protetta | AllowCheckExtraKeys | (Ereditato da RepositoryItemPopupBase)
Proprietà protetta | AllowCloseByEscape | (Ereditato da RepositoryItemPopupBase)
Proprietà protetta | AllowClosePopup | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | AllowContextImageChangeAnimation | (Ereditato da RepositoryItemTextEdit)
Proprietà protetta | AllowDefaultClearButtonAction | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | AllowDropDownWhenReadOnly | (Ereditato da RepositoryItemBaseSpinEdit)
Proprietà pubblica | AllowFocused | (Ereditato da RepositoryItem)
Proprietà pubblica | AllowFocusedAppearance | (Ereditato da RepositoryItem)
Proprietà protetta | AllowFormatEditValue | (Ereditato da RepositoryItem)
Proprietà pubblica | AllowGlyphSkinning | (Ereditato da RepositoryItemTextEdit)
Proprietà protetta | AllowHideClearButtonWhenNotFocused | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | AllowHtmlDraw | (Ereditato da RepositoryItem)
Proprietà pubblica | AllowInplaceAutoFilter | (Ereditato da RepositoryItem)
Proprietà pubblica | AllowInplaceBorderPainter | (Ereditato da RepositoryItem)
Proprietà protetta | AllowInputOnOpenPopup | (Ereditato da RepositoryItemPopupBase)
Proprietà protetta | AllowMaskBox | (Ereditato da RepositoryItem)
Proprietà pubblica | AllowMouseWheel | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | AllowNullInput | (Ereditato da RepositoryItemTextEdit)
Proprietà protetta | AllowParseEditValue | (Ereditato da RepositoryItem)
Proprietà protetta | AllowValidateOnEnterKey | (Ereditato da RepositoryItemPopupBase)
Proprietà protetta | AnnotationAttributes | (Ereditato da RepositoryItem)
Proprietà pubblica | Appearance | (Ereditato da RepositoryItem)
Proprietà pubblica | AppearanceDisabled | (Ereditato da RepositoryItem)
Proprietà pubblica | AppearanceDropDown | (Ereditato da RepositoryItemBaseSpinEdit)
Proprietà pubblica | AppearanceFocused | (Ereditato da RepositoryItem)
Proprietà pubblica | AppearanceReadOnly | (Ereditato da RepositoryItem)
Proprietà pubblica | AutoHeight | (Ereditato da RepositoryItem)
Proprietà pubblica | BeepOnError | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | BestFitWidth | (Ereditato da RepositoryItem)
Proprietà pubblica | BorderStyle | (Ereditato da RepositoryItem)
Proprietà pubblica | Buttons | (Ereditato da RepositoryItemButtonEdit)
Proprietà pubblica | ButtonsBorderStyle | Obsoleto. (Ereditato da RepositoryItemButtonEdit)
Proprietà pubblica | ButtonsStyle | (Ereditato da RepositoryItemButtonEdit)
Proprietà protetta | CancelPopupInputOnButtonClose | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | CharacterCasing | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | CloseUpKey | (Ereditato da RepositoryItemBaseSpinEdit)
Proprietà pubblica | ContextButtonOptions | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | ContextButtons | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | ContextImage | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | ContextImageAlignment | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | ContextImageOptions | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | ContextMenu | (Ereditato da RepositoryItem)
Proprietà pubblica | ContextMenuStrip | (Ereditato da RepositoryItem)
Proprietà pubblica | DefaultAlignment | (Ereditato da RepositoryItem)
Proprietà pubblica | DefaultBorderStyleInBars | (Ereditato da RepositoryItem)
Proprietà pubblica | DefaultBorderStyleInGrid | (Ereditato da RepositoryItem)
Proprietà pubblica | DisplayFormat | (Ereditato da RepositoryItem)
Proprietà pubblica | Editable | (Ereditato da RepositoryItem)
Proprietà pubblica | EditFormat | (Ereditato da RepositoryItem)
Proprietà protetta | EditorClassInfo | (Ereditato da RepositoryItem)
Proprietà pubblica | EditorTypeName | (Sovrascrive RepositoryItemBaseSpinEdit.EditorTypeName)
Proprietà pubblica | EditValueChangedDelay | (Ereditato da RepositoryItem)
Proprietà pubblica | EditValueChangedFiringMode | (Ereditato da RepositoryItemBaseSpinEdit)
Proprietà pubblica | Enabled | (Ereditato da RepositoryItem)
Proprietà pubblica | ExportMode | (Ereditato da RepositoryItem)
Proprietà protetta | ForceDisableButtonOnReadOnly | (Ereditato da RepositoryItemPopupBase)
Proprietà protetta | HasContextButtons | (Ereditato da RepositoryItemPopupBase)
Proprietà protetta | HasEditValueChangingSubscribers | (Ereditato da RepositoryItem)
Proprietà pubblica | HasEffectiveMaskForDisplayFormating | (Ereditato da RepositoryItemTextEdit)
Proprietà protetta | HasMaskSettings | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | HideSelection | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | HtmlImages | (Ereditato da RepositoryItem)
Proprietà protetta | ImageChangingAnimationProvider | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | IsClone | (Ereditato da RepositoryItem)
Proprietà protetta | IsContainerLoaded | (Ereditato da RepositoryItem)
Proprietà pubblica | IsDesignMode | (Ereditato da RepositoryItem)
Proprietà pubblica | IsDisposed | (Ereditato da RepositoryItem)
Proprietà pubblica | IsEditValueChangedEventPending | (Ereditato da RepositoryItem)
Proprietà pubblica | IsFilterLookUp | (Ereditato da RepositoryItem)
Proprietà protetta | IsFirstInit | (Ereditato da RepositoryItem)
Proprietà protetta | IsInImageChangingAnimation | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | IsLoading | (Ereditato da RepositoryItem)
Proprietà protetta | IsLockEvents | (Ereditato da RepositoryItem)
Proprietà pubblica | IsLockUpdate | (Ereditato da RepositoryItem)
Proprietà protetta | IsNeededTextKeys | (Ereditato da RepositoryItemButtonEdit)
Proprietà pubblica | IsNonSortableEditor | (Ereditato da RepositoryItem)
Proprietà protetta | IsNowReadOnly | (Ereditato da RepositoryItemPopupBase)
Proprietà protetta | IsNullInputAllowed | (Ereditato da RepositoryItemTextEdit)
Proprietà protetta | IsPasswordBox | (Ereditato da RepositoryItemTextEdit)
Proprietà protetta | IsReadOnlyAllowsDropDown | (Ereditato da RepositoryItemPopupBase)
Proprietà protetta | IsTryGetThreadSafeFuncValid | (Ereditato da RepositoryItemBaseSpinEdit)
Proprietà protetta | IsUseDisplayFormat | (Ereditato da RepositoryItemButtonEdit)
Proprietà pubblica | LinkCount | (Ereditato da RepositoryItem)
Proprietà protetta | Links | (Ereditato da RepositoryItem)
Proprietà protetta | LockDefaultImmediateUpdateRowPosition | (Ereditato da RepositoryItem)
Proprietà protetta | LockFormatParse | (Ereditato da RepositoryItem)
Proprietà pubblica | LookAndFeel | (Ereditato da RepositoryItem)
Proprietà pubblica | Mask | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | MaskBoxPadding | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | MaskSettings | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | MaxLength | (Ereditato da RepositoryItemTextEdit)
Proprietà protetta | MenuHotKey | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | Name | (Ereditato da RepositoryItem)
Proprietà pubblica | NullText | (Ereditato da RepositoryItem)
Proprietà pubblica | NullValuePrompt | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | NullValuePromptForeColor | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | NullValuePromptShowForEmptyValue | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | OwnerEdit | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | OwnerItem | (Ereditato da RepositoryItem)
Proprietà pubblica | Padding | (Ereditato da RepositoryItemTextEdit)
Proprietà protetta | Painter | (Ereditato da RepositoryItem)
Proprietà pubblica | PasswordChar | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | PopupBorderStyle | (Ereditato da RepositoryItemBaseSpinEdit)
Proprietà pubblica | PopupFormMinSize | (Ereditato da RepositoryItemBaseSpinEdit)
Proprietà pubblica | PopupFormSize | (Ereditato da RepositoryItemBaseSpinEdit)
Proprietà pubblica | PopupFormWidth | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | PopupOffset | (Ereditato da RepositoryItem)
Proprietà pubblica | PopupResizeMode | (Ereditato da RepositoryItemBaseSpinEdit)
Proprietà protetta | PostponeDelayedEditValueTimer | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | Properties | Obsoleto. (Ereditato da RepositoryItemBaseSpinEdit)
Proprietà protetta | PropertyStore | (Ereditato da RepositoryItem)
Proprietà pubblica | ReadOnly | (Ereditato da RepositoryItem)
Proprietà pubblica | RequireDisplayTextSorting | (Ereditato da RepositoryItem)
Proprietà protetta | RequireFakeDesigner | (Ereditato da RepositoryItem)
Proprietà pubblica | ResetTextEditStyleToStandardInFilterControl | (Ereditato da RepositoryItemButtonEdit)
Proprietà protetta | ShouldCreateMaskSettingsWhenMaskLoadedOrUpdated | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | ShowDropDown | (Ereditato da RepositoryItemBaseSpinEdit)
Proprietà pubblica | ShowNullValuePrompt | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | ShowNullValuePromptWhenFocused | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | ShowNullValuePromptWhenReadOnly | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | ShowPopupShadow | (Ereditato da RepositoryItemBaseSpinEdit)
Proprietà pubblica | Site | (Ereditato da RepositoryItem)
Proprietà pubblica | SpinButtonIndex | (Ereditato da RepositoryItemBaseSpinEdit)
Proprietà pubblica | SpinStyle | (Ereditato da RepositoryItemBaseSpinEdit)
Proprietà protetta | StyleController | (Ereditato da RepositoryItem)
Proprietà pubblica | SuppressMouseEventOnOuterMouseClick | (Ereditato da RepositoryItemBaseSpinEdit)
Proprietà pubblica | Tag | (Ereditato da RepositoryItem)
Proprietà pubblica | TextEditStyle | (Ereditato da RepositoryItemButtonEdit)
Proprietà pubblica | UseAdvancedMode | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | UseCtrlIncrement | Obsoleto. (Ereditato da RepositoryItemBaseSpinEdit)
Proprietà protetta | UseDisplayTextAsNullValuePrompt | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | UseMaskAsDisplayFormat | (Ereditato da RepositoryItemTextEdit)
Proprietà protetta | UseMaskBox | (Ereditato da RepositoryItemTextEdit)
Proprietà protetta | UseMaskedInput | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | UseParentBackground | (Ereditato da RepositoryItem)
Proprietà pubblica | UseReadOnlyAppearance | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | UseSystemPasswordChar | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | UseTextEditorForAutoFilter | (Ereditato da RepositoryItemButtonEdit)
Proprietà pubblica | ValidateOnEnterKey | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | XlsxFormatString | (Ereditato da RepositoryItemTextEdit)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivationKeysContains | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | AddImageSourceToPrintCache(PrintingSystemBase, MultiKey, SvgImage) | (Ereditato da RepositoryItem)
Metodo protetto | AddImageSourceToPrintCache(PrintingSystemBase, MultiKey, Image) | (Ereditato da RepositoryItem)
Metodo protetto | AddImageSourceToPrintCache(PrintingSystemBase, MultiKey, Object, Int32) | (Ereditato da RepositoryItem)
Metodo protetto | AddImageToPrintCache | (Ereditato da RepositoryItem)
Metodo protetto | AllowMaskManagerType | (Ereditato da RepositoryItemPopupBase)
Metodo pubblico | Assign | (Sovrascrive RepositoryItemBaseSpinEdit.Assign(RepositoryItem))
Metodo protetto | AssignEvents | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | AssignMasks | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | AssignNullValuePromptSettings | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | AssignOwnerEditEvents | (Ereditato da RepositoryItem)
Metodo protetto | AssignTextBrickFormatSettings | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | AssignTextBrickText | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | BeginInit | (Ereditato da RepositoryItemButtonEdit)
Metodo pubblico | BeginUpdate | (Ereditato da RepositoryItem)
Metodo protetto | BreakAnimations | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | CalcPaddingInfo | (Ereditato da RepositoryItem)
Metodo protetto | CalcPasswordCharMaskedText | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | CancelUpdate | (Ereditato da RepositoryItem)
Metodo protetto | CanEditNumericValueType | (Ereditato da RepositoryItemBaseSpinEdit)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | Clone | (Ereditato da RepositoryItem)
Metodo protetto | CompleteChanges | (Ereditato da RepositoryItem)
Metodo pubblico | Connect | (Ereditato da RepositoryItem)
Metodo protetto | ConvertTextFilterValue | (Ereditato da RepositoryItem)
Metodo protetto | CreateAccessibleInstance | (Ereditato da RepositoryItem)
Metodo protetto | CreateAdvancedModeOptions | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | CreateAppearance | (Ereditato da RepositoryItem)
Metodo protetto | CreateAppearanceCore | (Ereditato da RepositoryItem)
Metodo protetto | CreateBrickStyle | (Ereditato da RepositoryItem)
Metodo protetto | CreateButtonCollection | (Ereditato da RepositoryItemButtonEdit)
Metodo protetto | CreateContextButtonOptions | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | CreateContextButtonsCollection | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | CreateContextImageOptions | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | CreateDefaultButton | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | CreateDefaultMaskManager | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | CreateDefaultMaskManagerCore | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | CreateDisplayFormat | (Ereditato da RepositoryItem)
Metodo protetto | CreateEditFormat | (Ereditato da RepositoryItem)
Metodo pubblico | CreateEditor | (Ereditato da RepositoryItem)
Metodo pubblico | CreateGroupPainter | (Ereditato da RepositoryItem)
Metodo protetto | CreateImageBrick | (Ereditato da RepositoryItem)
Metodo protetto | CreateLookAndFeel | (Ereditato da RepositoryItem)
Metodo protetto | CreateMaskManager | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | CreateMaskProperties | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | CreateMaskSettings | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | CreateOwnerEditLookAndFeel | (Ereditato da RepositoryItem)
Metodo pubblico | CreatePainter | (Ereditato da RepositoryItem)
Metodo protetto | CreatePanelBrick(PrintCellHelperInfo, Boolean) | (Ereditato da RepositoryItem)
Metodo protetto | CreatePanelBrick(PrintCellHelperInfo, Boolean, BrickStyle) | (Ereditato da RepositoryItem)
Metodo protetto | CreateRepositoryItem | (Ereditato da RepositoryItem)
Metodo protetto | CreateTextBrick | (Ereditato da RepositoryItem)
Metodo pubblico | CreateViewInfo | (Ereditato da RepositoryItem)
Metodo protetto | DenyStandardTextEditStyle | (Ereditato da RepositoryItemButtonEdit)
Metodo protetto | DestroyAppearance | (Ereditato da RepositoryItem)
Metodo protetto | DestroyAppearances | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | DestroyLookAndFeel | (Ereditato da RepositoryItem)
Metodo protetto | DestroyStyles | Obsoleto. (Ereditato da RepositoryItem)
Metodo pubblico | Disconnect | (Ereditato da RepositoryItem)
Metodo protetto | Dispose | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | DisposePrevContextImage | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | DoFormatEditValue(Object) | (Ereditato da RepositoryItem)
Metodo protetto | DoFormatEditValue(Object, Boolean) | (Ereditato da RepositoryItem)
Metodo protetto | DoParseEditValue(Object) | (Ereditato da RepositoryItem)
Metodo protetto | DoParseEditValue(Object, Boolean) | (Ereditato da RepositoryItem)
Metodo pubblico | EditMaskSettings(Object) | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | EditMaskSettings(IWin32Window, Object) | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | EditMaskSettings(IWindowsFormsEditorService, Object) | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | EnableCustomMaskTextInput | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | EnableNonMaskedInput | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | EndInit | (Ereditato da RepositoryItem)
Metodo pubblico | EndUpdate | (Ereditato da RepositoryItem)
Metodo protetto | EnsureMaskSettings | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | FilterProperties | (Ereditato da RepositoryItem)
Metodo protetto | FireChanged | (Ereditato da RepositoryItem)
Metodo protetto | FireChangedFromRepository | (Ereditato da RepositoryItem)
Metodo protetto | FireContainerLoaded | (Ereditato da RepositoryItem)
Metodo protetto | ForceDisplayTextAsNullValuePrompt | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da RepositoryItem)
Metodo protetto | GetAllowContextImageChangeAnimation | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetAllowGlyphSkinning | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetAllowHtmlDraw | (Ereditato da RepositoryItem)
Metodo pubblico | GetBrick | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetBrickImageSource | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetCachedPrintImage | (Ereditato da RepositoryItem)
Metodo protetto | GetCachedPrintImageSource | (Ereditato da RepositoryItem)
Metodo protetto | GetCustomMaskTextInputTag | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetDefaultEditMask | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetDefaultMaskManagerType | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetDesiredPopupFormSize | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | GetDisableTextEditorAsDefaultValue | (Ereditato da RepositoryItemButtonEdit)
Metodo pubblico | GetDisplayText(Object) | (Ereditato da RepositoryItem)
Metodo pubblico | GetDisplayText(FormatInfo, Object) | (Ereditato da RepositoryItem)
Metodo pubblico | GetEditorType | (Ereditato da RepositoryItem)
Metodo protetto | GetEditValueForExport | (Ereditato da RepositoryItem)
Metodo pubblico | GetEditValueForExportByOptions | (Ereditato da RepositoryItem)
Metodo protetto | GetEventSender | (Ereditato da RepositoryItem)
Metodo protetto | GetExportMode | (Ereditato da RepositoryItem)
Metodo protetto | GetFormattedDisplayText | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | GetHashCode | (Ereditato da RepositoryItem)
Metodo protetto | GetInPanelrect | (Ereditato da RepositoryItem)
Metodo protetto | GetNullEditText | (Ereditato da RepositoryItemButtonEdit)
Metodo protetto | GetNullText | (Ereditato da RepositoryItem)
Metodo protetto | GetNullValuePrompt | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetOrAddImageSource(PrintingSystemBase, MultiKey, SvgImage) | (Ereditato da RepositoryItem)
Metodo protetto | GetOrAddImageSource(PrintingSystemBase, MultiKey, Image) | (Ereditato da RepositoryItem)
Metodo protetto | GetOrAddImageSource(PrintingSystemBase, MultiKey, Object, Int32) | (Ereditato da RepositoryItem)
Metodo protetto | GetOverrideAppearance | (Ereditato da RepositoryItem)
Metodo protetto | GetPasswordCharCore | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetPrevContextImage | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetSender | (Ereditato da RepositoryItem)
Metodo protetto | GetTextFilterCapabilities | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetUseMaskAsDisplayFormat | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | InitializeEditMaskFromDisplayTextService | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | IsActivateKey | (Ereditato da RepositoryItem)
Metodo protetto | IsButtonEnabled | (Ereditato da RepositoryItemBaseSpinEdit)
Metodo pubblico | IsDefault | (Ereditato da RepositoryItem)
Metodo protetto | IsEmptyValue | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | IsFormatTypeCustom | (Ereditato da RepositoryItem)
Metodo pubblico | IsLockDefaultImmediateUpdateRowPosition | (Ereditato da RepositoryItem)
Metodo protetto | IsNeededChar | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | IsNeededKey | (Ereditato da RepositoryItem)
Metodo protetto | IsNeededKeyCore | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | IsNullValue | (Ereditato da RepositoryItem)
Metodo protetto | IsStandardTextEditStyle | (Ereditato da RepositoryItemButtonEdit)
Metodo pubblico | LockEvents | (Ereditato da RepositoryItem)
Metodo pubblico | MarkAsClone | (Ereditato da RepositoryItem)
Metodo protetto | NeededKeysContains | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | NeededKeysPopupContains | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | OnAllowFocusedChanged | (Ereditato da RepositoryItem)
Metodo protetto | OnAnnotationAttributesLoad | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnAppearanceChanged | (Ereditato da RepositoryItem)
Metodo protetto | OnAppearancePaintChanged | (Ereditato da RepositoryItem)
Metodo protetto | OnAppearanceSizeChanged | (Ereditato da RepositoryItem)
Metodo protetto | OnAutoHeightChanged | (Ereditato da RepositoryItem)
Metodo protetto | OnButtons_CollectionChanged | (Ereditato da RepositoryItemButtonEdit)
Metodo protetto | OnContainerLoaded | (Ereditato da RepositoryItem)
Metodo protetto | OnContextImageChanged | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnContextImageChanging | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnContextImageOptionsChanged | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnContextImageOptionsChanging | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnEnabledChanged | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnFormat_Changed | (Ereditato da RepositoryItem)
Metodo protetto | OnLoaded | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnMaskChanged | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnMaskSettingsChanged | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnOwnerEditChanged | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnPopupFormSizeChanged | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | OnPropertiesChanged | (Ereditato da RepositoryItem)
Metodo protetto | OnPropertiesChanged(EventArgs) | (Ereditato da RepositoryItem)
Metodo protetto | OnStyleChanged | (Ereditato da RepositoryItem)
Metodo protetto | OnTextEditStyleChanged | (Ereditato da RepositoryItemButtonEdit)
Metodo protetto | OnUpdateMaskSettings | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | PreparePrintViewInfo(PrintCellHelperInfo, Boolean) | (Ereditato da RepositoryItem)
Metodo protetto | PreparePrintViewInfo(PrintCellHelperInfo, BaseEditViewInfo, Boolean) | (Ereditato da RepositoryItem)
Metodo protetto | RaiseBeforePopup | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | RaiseBeforeShowMenu | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | RaiseButtonClick | (Ereditato da RepositoryItemButtonEdit)
Metodo protetto | RaiseButtonPressed | (Ereditato da RepositoryItemButtonEdit)
Metodo protetto | RaiseClosed | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | RaiseCloseUp | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | RaiseContextButtonClick | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | RaiseContextButtonValueChanged | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | RaiseCustomDisplayText(CustomDisplayTextEventArgs) | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | RaiseCustomDisplayText(Object, String) | (Ereditato da RepositoryItem)
Metodo protetto | RaiseCustomDisplayText(FormatInfo, Object, String) | (Ereditato da RepositoryItem)
Metodo protetto | RaiseCustomDrawButton | (Ereditato da RepositoryItemButtonEdit)
Metodo protetto | RaiseCustomHighlightText | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | RaiseCustomizeAutoCompleteSource | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | RaiseCustomizeContextItem | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | RaiseCustomTextLineHeight | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | RaiseEditValueChanged | (Ereditato da RepositoryItem)
Metodo protetto | RaiseEditValueChangedCore | (Ereditato da RepositoryItem)
Metodo protetto | RaiseEditValueChanging | (Ereditato da RepositoryItem)
Metodo protetto | RaiseFormatEditValue | (Ereditato da RepositoryItem)
Metodo protetto | RaiseModified | (Ereditato da RepositoryItem)
Metodo protetto | RaiseParseEditValue | (Ereditato da RepositoryItem)
Metodo protetto | RaisePopup | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | RaisePopupAllowClick | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | RaisePropertiesChanged | (Ereditato da RepositoryItem)
Metodo protetto | RaiseQueryAccessibilityHelp | (Ereditato da RepositoryItem)
Metodo protetto | RaiseQueryCloseUp | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | RaiseQueryPopUp | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | RaiseQueryProcessKey | (Ereditato da RepositoryItem)
Metodo protetto | RaiseRefreshRequired | (Ereditato da RepositoryItem)
Metodo protetto | RaiseSpin | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | RecreateMaskManagerOnIsNullInputAllowedChanged | (Ereditato da RepositoryItemTextEdit)
 | RegisterDedTextSpinEdit |
Metodo protetto | ResetAccessibleDescription | (Ereditato da RepositoryItem)
Metodo protetto | ResetAccessibleName | (Ereditato da RepositoryItem)
Metodo protetto | ResetAutoHeight | (Ereditato da RepositoryItem)
Metodo protetto | ResetDefaultMaskManager | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | ResetEvents | (Ereditato da RepositoryItem)
Metodo pubblico | ResetMaskSettings | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | ResetNullText | (Ereditato da RepositoryItem)
Metodo protetto | ResetNullValuePrompt | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | ResetPopupFormMinSize | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | ResetPopupFormSize | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | ResetTextEditStyle | (Ereditato da RepositoryItemButtonEdit)
Metodo pubblico | ScaleProperties | (Ereditato da RepositoryItem)
Metodo protetto | ScalePropertiesCore | (Ereditato da RepositoryItemPopupBase)
Metodo pubblico | SetCloned | (Ereditato da RepositoryItem)
Metodo protetto | SetCommonBrickProperties | (Ereditato da RepositoryItem)
Metodo protetto | SetOwnerEdit | (Ereditato da RepositoryItem)
Metodo protetto | SetTextBrickPropertiesCore | (Ereditato da RepositoryItem)
Metodo protetto | SetupCommonBrickStyleProperties | (Ereditato da RepositoryItem)
Metodo protetto | SetupTextBrickStyleProperties | (Ereditato da RepositoryItem)
Metodo protetto | ShouldRaiseCustomDisplayText | (Ereditato da RepositoryItem)
Metodo protetto | ShouldSerializeAccessibleDescription | (Ereditato da RepositoryItem)
Metodo protetto | ShouldSerializeAccessibleName | (Ereditato da RepositoryItem)
Metodo protetto | ShouldSerializeAutoHeight | (Ereditato da RepositoryItem)
Metodo pubblico | ShouldSerializeMaskSettings | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | ShouldSerializeNullText | (Ereditato da RepositoryItem)
Metodo protetto | ShouldSerializeNullValuePrompt | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | ShouldSerializePopupFormMinSize | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | ShouldSerializePopupFormSize | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | ShouldSerializeTextEditStyle | (Ereditato da RepositoryItemButtonEdit)
Metodo protetto | StartContextImageChangingAnimation | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | SwitchMode | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | ThrowItemNotInRepositoryWarning | (Ereditato da RepositoryItem)
Metodo pubblico | ToString | (Ereditato da RepositoryItem)
Metodo protetto | ToStringTrimming | (Ereditato da RepositoryItem)
Metodo protetto | TriggerDelayedEditValueChanged | (Ereditato da RepositoryItem)
Metodo protetto | TriggerDelayedEditValueChanged(EventArgs) | (Ereditato da RepositoryItem)
Metodo protetto | TryGetThreadSafeDoFormatEditValueFunc | (Ereditato da RepositoryItem)
Metodo protetto | TryGetThreadSafeGetDisplayTextFunc | (Ereditato da RepositoryItem)
Metodo protetto | TryGetThreadSafeGetFormattedDisplayTextFunc | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | TryGetThreadSafeIsNullValueFunc | (Ereditato da RepositoryItem)
Metodo protetto | TryGetThreadSafeRaiseCustomDisplayTextFunc | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | UnLockEvents | (Ereditato da RepositoryItem)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | BeforePopup | (Ereditato da RepositoryItemPopupBase)
Evento pubblico | BeforeShowMenu | (Ereditato da RepositoryItemTextEdit)
Evento pubblico | ButtonClick | (Ereditato da RepositoryItemButtonEdit)
Evento pubblico | ButtonPressed | (Ereditato da RepositoryItemButtonEdit)
Evento pubblico | Click | (Ereditato da RepositoryItem)
Evento pubblico | Closed | (Ereditato da RepositoryItemBaseSpinEdit)
Evento pubblico | CloseUp | (Ereditato da RepositoryItemBaseSpinEdit)
Evento pubblico | ContextButtonClick | (Ereditato da RepositoryItemPopupBase)
Evento pubblico | ContextButtonValueChanged | (Ereditato da RepositoryItemPopupBase)
Evento pubblico | CustomDisplayText | (Ereditato da RepositoryItem)
Evento pubblico | CustomDrawButton | (Ereditato da RepositoryItemButtonEdit)
Evento pubblico | CustomHighlightText | (Ereditato da RepositoryItemTextEdit)
Evento pubblico | CustomizeAutoCompleteSource | (Ereditato da RepositoryItemTextEdit)
Evento pubblico | CustomizeContextItem | (Ereditato da RepositoryItemPopupBase)
Evento pubblico | CustomTextLineHeight | (Ereditato da RepositoryItemTextEdit)
Evento pubblico | DoubleClick | (Ereditato da RepositoryItem)
Evento pubblico | DragDrop | (Ereditato da RepositoryItem)
Evento pubblico | DragEnter | (Ereditato da RepositoryItem)
Evento pubblico | DragLeave | (Ereditato da RepositoryItem)
Evento pubblico | DragOver | (Ereditato da RepositoryItem)
Evento pubblico | EditValueChanged | (Ereditato da RepositoryItem)
Evento pubblico | EditValueChanging | (Ereditato da RepositoryItem)
Evento pubblico | Enter | (Ereditato da RepositoryItem)
Evento pubblico | FormatEditValue | (Ereditato da RepositoryItem)
Evento pubblico | GiveFeedback | (Ereditato da RepositoryItem)
Evento pubblico | HelpRequested | (Ereditato da RepositoryItem)
Evento pubblico | KeyDown | (Ereditato da RepositoryItem)
Evento pubblico | KeyPress | (Ereditato da RepositoryItem)
Evento pubblico | KeyUp | (Ereditato da RepositoryItem)
Evento pubblico | Leave | (Ereditato da RepositoryItem)
Evento pubblico | Modified | (Ereditato da RepositoryItem)
Evento pubblico | MouseDown | (Ereditato da RepositoryItem)
Evento pubblico | MouseEnter | (Ereditato da RepositoryItem)
Evento pubblico | MouseHover | (Ereditato da RepositoryItem)
Evento pubblico | MouseLeave | (Ereditato da RepositoryItem)
Evento pubblico | MouseMove | (Ereditato da RepositoryItem)
Evento pubblico | MouseUp | (Ereditato da RepositoryItem)
Evento pubblico | MouseWheel | (Ereditato da RepositoryItem)
Evento pubblico | ParseEditValue | (Ereditato da RepositoryItem)
Evento pubblico | Popup | (Ereditato da RepositoryItemBaseSpinEdit)
Evento pubblico | PopupAllowClick | (Ereditato da RepositoryItemPopupBase)
Evento pubblico | PropertiesChanged | (Ereditato da RepositoryItem)
Evento pubblico | QueryAccessibilityHelp | (Ereditato da RepositoryItem)
Evento pubblico | QueryCloseUp | (Ereditato da RepositoryItemBaseSpinEdit)
Evento pubblico | QueryContinueDrag | (Ereditato da RepositoryItem)
Evento pubblico | QueryPopUp | (Ereditato da RepositoryItemBaseSpinEdit)
Evento pubblico | QueryProcessKey | (Ereditato da RepositoryItem)
Evento pubblico | Spin | (Ereditato da RepositoryItemTextEdit)
Evento pubblico | Validating | (Ereditato da RepositoryItem)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | Cloned | (Ereditato da RepositoryItem)
 | CustomEditName |
Campo protetto | fAllowFocused | (Ereditato da RepositoryItem)
Campo protetto | fAllowMouseWheel | (Ereditato da RepositoryItem)
Campo protetto | fAutoHeight | (Ereditato da RepositoryItem)
Campo protetto | fBorderStyle | (Ereditato da RepositoryItem)
Campo protetto | fButtonsStyle | (Ereditato da RepositoryItemButtonEdit)
Campo protetto | fCharacterCasing | (Ereditato da RepositoryItemTextEdit)
Campo protetto | fEditValueChangedFiringMode | (Ereditato da RepositoryItem)
Campo protetto | fEnabled | (Ereditato da RepositoryItem)
Campo protetto | fLockFormatParse | (Ereditato da RepositoryItem)
Campo protetto | fMaxLength | (Ereditato da RepositoryItemTextEdit)
Campo protetto | fNullText | (Ereditato da RepositoryItem)
Campo protetto | fPainter | (Ereditato da RepositoryItem)
Campo protetto | fPasswordChar | (Ereditato da RepositoryItemTextEdit)
Campo protetto | fReadOnly | (Ereditato da RepositoryItem)
Campo protetto | fTextEditStyle | (Ereditato da RepositoryItemButtonEdit)
Campo protetto | fValidateOnEnterKey | (Ereditato da RepositoryItemTextEdit)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore RepositoryItemDedTextSpinEdit

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public RepositoryItemDedTextSpinEdit()
Public Sub New
public:
RepositoryItemDedTextSpinEdit()
new : unit -> RepositoryItemDedTextSpinEdit
Vedi anche

Documentazione

Classe RepositoryItemDedTextSpinEdit
Namespace DedNet.Controls


Proprietà di RepositoryItemDedTextSpinEdit

Il tipo RepositoryItemDedTextSpinEdit espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AccessibleDefaultActionDescription | (Ereditato da RepositoryItem)
Proprietà pubblica | AccessibleDescription | (Ereditato da RepositoryItem)
Proprietà pubblica | AccessibleName | (Ereditato da RepositoryItem)
Proprietà pubblica | AccessibleRole | (Ereditato da RepositoryItem)
Proprietà pubblica | ActionButtonIndex | (Ereditato da RepositoryItemBaseSpinEdit)
Proprietà protetta | ActiveFormat | (Ereditato da RepositoryItem)
Proprietà pubblica | AdvancedModeOptions | (Ereditato da RepositoryItemTextEdit)
Proprietà protetta | AllowCheckExtraKeys | (Ereditato da RepositoryItemPopupBase)
Proprietà protetta | AllowCloseByEscape | (Ereditato da RepositoryItemPopupBase)
Proprietà protetta | AllowClosePopup | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | AllowContextImageChangeAnimation | (Ereditato da RepositoryItemTextEdit)
Proprietà protetta | AllowDefaultClearButtonAction | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | AllowDropDownWhenReadOnly | (Ereditato da RepositoryItemBaseSpinEdit)
Proprietà pubblica | AllowFocused | (Ereditato da RepositoryItem)
Proprietà pubblica | AllowFocusedAppearance | (Ereditato da RepositoryItem)
Proprietà protetta | AllowFormatEditValue | (Ereditato da RepositoryItem)
Proprietà pubblica | AllowGlyphSkinning | (Ereditato da RepositoryItemTextEdit)
Proprietà protetta | AllowHideClearButtonWhenNotFocused | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | AllowHtmlDraw | (Ereditato da RepositoryItem)
Proprietà pubblica | AllowInplaceAutoFilter | (Ereditato da RepositoryItem)
Proprietà pubblica | AllowInplaceBorderPainter | (Ereditato da RepositoryItem)
Proprietà protetta | AllowInputOnOpenPopup | (Ereditato da RepositoryItemPopupBase)
Proprietà protetta | AllowMaskBox | (Ereditato da RepositoryItem)
Proprietà pubblica | AllowMouseWheel | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | AllowNullInput | (Ereditato da RepositoryItemTextEdit)
Proprietà protetta | AllowParseEditValue | (Ereditato da RepositoryItem)
Proprietà protetta | AllowValidateOnEnterKey | (Ereditato da RepositoryItemPopupBase)
Proprietà protetta | AnnotationAttributes | (Ereditato da RepositoryItem)
Proprietà pubblica | Appearance | (Ereditato da RepositoryItem)
Proprietà pubblica | AppearanceDisabled | (Ereditato da RepositoryItem)
Proprietà pubblica | AppearanceDropDown | (Ereditato da RepositoryItemBaseSpinEdit)
Proprietà pubblica | AppearanceFocused | (Ereditato da RepositoryItem)
Proprietà pubblica | AppearanceReadOnly | (Ereditato da RepositoryItem)
Proprietà pubblica | AutoHeight | (Ereditato da RepositoryItem)
Proprietà pubblica | BeepOnError | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | BestFitWidth | (Ereditato da RepositoryItem)
Proprietà pubblica | BorderStyle | (Ereditato da RepositoryItem)
Proprietà pubblica | Buttons | (Ereditato da RepositoryItemButtonEdit)
Proprietà pubblica | ButtonsBorderStyle | Obsoleto. (Ereditato da RepositoryItemButtonEdit)
Proprietà pubblica | ButtonsStyle | (Ereditato da RepositoryItemButtonEdit)
Proprietà protetta | CancelPopupInputOnButtonClose | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | CharacterCasing | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | CloseUpKey | (Ereditato da RepositoryItemBaseSpinEdit)
Proprietà pubblica | ContextButtonOptions | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | ContextButtons | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | ContextImage | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | ContextImageAlignment | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | ContextImageOptions | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | ContextMenu | (Ereditato da RepositoryItem)
Proprietà pubblica | ContextMenuStrip | (Ereditato da RepositoryItem)
Proprietà pubblica | DefaultAlignment | (Ereditato da RepositoryItem)
Proprietà pubblica | DefaultBorderStyleInBars | (Ereditato da RepositoryItem)
Proprietà pubblica | DefaultBorderStyleInGrid | (Ereditato da RepositoryItem)
Proprietà pubblica | DisplayFormat | (Ereditato da RepositoryItem)
Proprietà pubblica | Editable | (Ereditato da RepositoryItem)
Proprietà pubblica | EditFormat | (Ereditato da RepositoryItem)
Proprietà protetta | EditorClassInfo | (Ereditato da RepositoryItem)
Proprietà pubblica | EditorTypeName | (Sovrascrive RepositoryItemBaseSpinEdit.EditorTypeName)
Proprietà pubblica | EditValueChangedDelay | (Ereditato da RepositoryItem)
Proprietà pubblica | EditValueChangedFiringMode | (Ereditato da RepositoryItemBaseSpinEdit)
Proprietà pubblica | Enabled | (Ereditato da RepositoryItem)
Proprietà pubblica | ExportMode | (Ereditato da RepositoryItem)
Proprietà protetta | ForceDisableButtonOnReadOnly | (Ereditato da RepositoryItemPopupBase)
Proprietà protetta | HasContextButtons | (Ereditato da RepositoryItemPopupBase)
Proprietà protetta | HasEditValueChangingSubscribers | (Ereditato da RepositoryItem)
Proprietà pubblica | HasEffectiveMaskForDisplayFormating | (Ereditato da RepositoryItemTextEdit)
Proprietà protetta | HasMaskSettings | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | HideSelection | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | HtmlImages | (Ereditato da RepositoryItem)
Proprietà protetta | ImageChangingAnimationProvider | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | IsClone | (Ereditato da RepositoryItem)
Proprietà protetta | IsContainerLoaded | (Ereditato da RepositoryItem)
Proprietà pubblica | IsDesignMode | (Ereditato da RepositoryItem)
Proprietà pubblica | IsDisposed | (Ereditato da RepositoryItem)
Proprietà pubblica | IsEditValueChangedEventPending | (Ereditato da RepositoryItem)
Proprietà pubblica | IsFilterLookUp | (Ereditato da RepositoryItem)
Proprietà protetta | IsFirstInit | (Ereditato da RepositoryItem)
Proprietà protetta | IsInImageChangingAnimation | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | IsLoading | (Ereditato da RepositoryItem)
Proprietà protetta | IsLockEvents | (Ereditato da RepositoryItem)
Proprietà pubblica | IsLockUpdate | (Ereditato da RepositoryItem)
Proprietà protetta | IsNeededTextKeys | (Ereditato da RepositoryItemButtonEdit)
Proprietà pubblica | IsNonSortableEditor | (Ereditato da RepositoryItem)
Proprietà protetta | IsNowReadOnly | (Ereditato da RepositoryItemPopupBase)
Proprietà protetta | IsNullInputAllowed | (Ereditato da RepositoryItemTextEdit)
Proprietà protetta | IsPasswordBox | (Ereditato da RepositoryItemTextEdit)
Proprietà protetta | IsReadOnlyAllowsDropDown | (Ereditato da RepositoryItemPopupBase)
Proprietà protetta | IsTryGetThreadSafeFuncValid | (Ereditato da RepositoryItemBaseSpinEdit)
Proprietà protetta | IsUseDisplayFormat | (Ereditato da RepositoryItemButtonEdit)
Proprietà pubblica | LinkCount | (Ereditato da RepositoryItem)
Proprietà protetta | Links | (Ereditato da RepositoryItem)
Proprietà protetta | LockDefaultImmediateUpdateRowPosition | (Ereditato da RepositoryItem)
Proprietà protetta | LockFormatParse | (Ereditato da RepositoryItem)
Proprietà pubblica | LookAndFeel | (Ereditato da RepositoryItem)
Proprietà pubblica | Mask | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | MaskBoxPadding | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | MaskSettings | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | MaxLength | (Ereditato da RepositoryItemTextEdit)
Proprietà protetta | MenuHotKey | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | Name | (Ereditato da RepositoryItem)
Proprietà pubblica | NullText | (Ereditato da RepositoryItem)
Proprietà pubblica | NullValuePrompt | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | NullValuePromptForeColor | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | NullValuePromptShowForEmptyValue | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | OwnerEdit | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | OwnerItem | (Ereditato da RepositoryItem)
Proprietà pubblica | Padding | (Ereditato da RepositoryItemTextEdit)
Proprietà protetta | Painter | (Ereditato da RepositoryItem)
Proprietà pubblica | PasswordChar | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | PopupBorderStyle | (Ereditato da RepositoryItemBaseSpinEdit)
Proprietà pubblica | PopupFormMinSize | (Ereditato da RepositoryItemBaseSpinEdit)
Proprietà pubblica | PopupFormSize | (Ereditato da RepositoryItemBaseSpinEdit)
Proprietà pubblica | PopupFormWidth | (Ereditato da RepositoryItemPopupBase)
Proprietà pubblica | PopupOffset | (Ereditato da RepositoryItem)
Proprietà pubblica | PopupResizeMode | (Ereditato da RepositoryItemBaseSpinEdit)
Proprietà protetta | PostponeDelayedEditValueTimer | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | Properties | Obsoleto. (Ereditato da RepositoryItemBaseSpinEdit)
Proprietà protetta | PropertyStore | (Ereditato da RepositoryItem)
Proprietà pubblica | ReadOnly | (Ereditato da RepositoryItem)
Proprietà pubblica | RequireDisplayTextSorting | (Ereditato da RepositoryItem)
Proprietà protetta | RequireFakeDesigner | (Ereditato da RepositoryItem)
Proprietà pubblica | ResetTextEditStyleToStandardInFilterControl | (Ereditato da RepositoryItemButtonEdit)
Proprietà protetta | ShouldCreateMaskSettingsWhenMaskLoadedOrUpdated | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | ShowDropDown | (Ereditato da RepositoryItemBaseSpinEdit)
Proprietà pubblica | ShowNullValuePrompt | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | ShowNullValuePromptWhenFocused | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | ShowNullValuePromptWhenReadOnly | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | ShowPopupShadow | (Ereditato da RepositoryItemBaseSpinEdit)
Proprietà pubblica | Site | (Ereditato da RepositoryItem)
Proprietà pubblica | SpinButtonIndex | (Ereditato da RepositoryItemBaseSpinEdit)
Proprietà pubblica | SpinStyle | (Ereditato da RepositoryItemBaseSpinEdit)
Proprietà protetta | StyleController | (Ereditato da RepositoryItem)
Proprietà pubblica | SuppressMouseEventOnOuterMouseClick | (Ereditato da RepositoryItemBaseSpinEdit)
Proprietà pubblica | Tag | (Ereditato da RepositoryItem)
Proprietà pubblica | TextEditStyle | (Ereditato da RepositoryItemButtonEdit)
Proprietà pubblica | UseAdvancedMode | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | UseCtrlIncrement | Obsoleto. (Ereditato da RepositoryItemBaseSpinEdit)
Proprietà protetta | UseDisplayTextAsNullValuePrompt | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | UseMaskAsDisplayFormat | (Ereditato da RepositoryItemTextEdit)
Proprietà protetta | UseMaskBox | (Ereditato da RepositoryItemTextEdit)
Proprietà protetta | UseMaskedInput | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | UseParentBackground | (Ereditato da RepositoryItem)
Proprietà pubblica | UseReadOnlyAppearance | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | UseSystemPasswordChar | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | UseTextEditorForAutoFilter | (Ereditato da RepositoryItemButtonEdit)
Proprietà pubblica | ValidateOnEnterKey | (Ereditato da RepositoryItemTextEdit)
Proprietà pubblica | XlsxFormatString | (Ereditato da RepositoryItemTextEdit)
Torna su
Vedi anche

Documentazione

Classe RepositoryItemDedTextSpinEdit
Namespace DedNet.Controls


Proprietà RepositoryItemDedTextSpinEdit.EditorTypeName

Proprietà RepositoryItemDedTextSpinEditEditorTypeName

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string EditorTypeName { get; }
Public Overrides ReadOnly Property EditorTypeName As String
    Get
public:
virtual property String^ EditorTypeName {
    String^ get () override;
}
abstract EditorTypeName : string with get
override EditorTypeName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe RepositoryItemDedTextSpinEdit
Namespace DedNet.Controls


Metodi di RepositoryItemDedTextSpinEdit

Il tipo RepositoryItemDedTextSpinEdit espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivationKeysContains | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | AddImageSourceToPrintCache(PrintingSystemBase, MultiKey, SvgImage) | (Ereditato da RepositoryItem)
Metodo protetto | AddImageSourceToPrintCache(PrintingSystemBase, MultiKey, Image) | (Ereditato da RepositoryItem)
Metodo protetto | AddImageSourceToPrintCache(PrintingSystemBase, MultiKey, Object, Int32) | (Ereditato da RepositoryItem)
Metodo protetto | AddImageToPrintCache | (Ereditato da RepositoryItem)
Metodo protetto | AllowMaskManagerType | (Ereditato da RepositoryItemPopupBase)
Metodo pubblico | Assign | (Sovrascrive RepositoryItemBaseSpinEdit.Assign(RepositoryItem))
Metodo protetto | AssignEvents | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | AssignMasks | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | AssignNullValuePromptSettings | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | AssignOwnerEditEvents | (Ereditato da RepositoryItem)
Metodo protetto | AssignTextBrickFormatSettings | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | AssignTextBrickText | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | BeginInit | (Ereditato da RepositoryItemButtonEdit)
Metodo pubblico | BeginUpdate | (Ereditato da RepositoryItem)
Metodo protetto | BreakAnimations | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | CalcPaddingInfo | (Ereditato da RepositoryItem)
Metodo protetto | CalcPasswordCharMaskedText | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | CancelUpdate | (Ereditato da RepositoryItem)
Metodo protetto | CanEditNumericValueType | (Ereditato da RepositoryItemBaseSpinEdit)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | Clone | (Ereditato da RepositoryItem)
Metodo protetto | CompleteChanges | (Ereditato da RepositoryItem)
Metodo pubblico | Connect | (Ereditato da RepositoryItem)
Metodo protetto | ConvertTextFilterValue | (Ereditato da RepositoryItem)
Metodo protetto | CreateAccessibleInstance | (Ereditato da RepositoryItem)
Metodo protetto | CreateAdvancedModeOptions | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | CreateAppearance | (Ereditato da RepositoryItem)
Metodo protetto | CreateAppearanceCore | (Ereditato da RepositoryItem)
Metodo protetto | CreateBrickStyle | (Ereditato da RepositoryItem)
Metodo protetto | CreateButtonCollection | (Ereditato da RepositoryItemButtonEdit)
Metodo protetto | CreateContextButtonOptions | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | CreateContextButtonsCollection | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | CreateContextImageOptions | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | CreateDefaultButton | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | CreateDefaultMaskManager | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | CreateDefaultMaskManagerCore | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | CreateDisplayFormat | (Ereditato da RepositoryItem)
Metodo protetto | CreateEditFormat | (Ereditato da RepositoryItem)
Metodo pubblico | CreateEditor | (Ereditato da RepositoryItem)
Metodo pubblico | CreateGroupPainter | (Ereditato da RepositoryItem)
Metodo protetto | CreateImageBrick | (Ereditato da RepositoryItem)
Metodo protetto | CreateLookAndFeel | (Ereditato da RepositoryItem)
Metodo protetto | CreateMaskManager | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | CreateMaskProperties | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | CreateMaskSettings | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | CreateOwnerEditLookAndFeel | (Ereditato da RepositoryItem)
Metodo pubblico | CreatePainter | (Ereditato da RepositoryItem)
Metodo protetto | CreatePanelBrick(PrintCellHelperInfo, Boolean) | (Ereditato da RepositoryItem)
Metodo protetto | CreatePanelBrick(PrintCellHelperInfo, Boolean, BrickStyle) | (Ereditato da RepositoryItem)
Metodo protetto | CreateRepositoryItem | (Ereditato da RepositoryItem)
Metodo protetto | CreateTextBrick | (Ereditato da RepositoryItem)
Metodo pubblico | CreateViewInfo | (Ereditato da RepositoryItem)
Metodo protetto | DenyStandardTextEditStyle | (Ereditato da RepositoryItemButtonEdit)
Metodo protetto | DestroyAppearance | (Ereditato da RepositoryItem)
Metodo protetto | DestroyAppearances | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | DestroyLookAndFeel | (Ereditato da RepositoryItem)
Metodo protetto | DestroyStyles | Obsoleto. (Ereditato da RepositoryItem)
Metodo pubblico | Disconnect | (Ereditato da RepositoryItem)
Metodo protetto | Dispose | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | DisposePrevContextImage | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | DoFormatEditValue(Object) | (Ereditato da RepositoryItem)
Metodo protetto | DoFormatEditValue(Object, Boolean) | (Ereditato da RepositoryItem)
Metodo protetto | DoParseEditValue(Object) | (Ereditato da RepositoryItem)
Metodo protetto | DoParseEditValue(Object, Boolean) | (Ereditato da RepositoryItem)
Metodo pubblico | EditMaskSettings(Object) | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | EditMaskSettings(IWin32Window, Object) | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | EditMaskSettings(IWindowsFormsEditorService, Object) | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | EnableCustomMaskTextInput | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | EnableNonMaskedInput | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | EndInit | (Ereditato da RepositoryItem)
Metodo pubblico | EndUpdate | (Ereditato da RepositoryItem)
Metodo protetto | EnsureMaskSettings | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | FilterProperties | (Ereditato da RepositoryItem)
Metodo protetto | FireChanged | (Ereditato da RepositoryItem)
Metodo protetto | FireChangedFromRepository | (Ereditato da RepositoryItem)
Metodo protetto | FireContainerLoaded | (Ereditato da RepositoryItem)
Metodo protetto | ForceDisplayTextAsNullValuePrompt | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da RepositoryItem)
Metodo protetto | GetAllowContextImageChangeAnimation | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetAllowGlyphSkinning | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetAllowHtmlDraw | (Ereditato da RepositoryItem)
Metodo pubblico | GetBrick | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetBrickImageSource | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetCachedPrintImage | (Ereditato da RepositoryItem)
Metodo protetto | GetCachedPrintImageSource | (Ereditato da RepositoryItem)
Metodo protetto | GetCustomMaskTextInputTag | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetDefaultEditMask | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetDefaultMaskManagerType | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetDesiredPopupFormSize | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | GetDisableTextEditorAsDefaultValue | (Ereditato da RepositoryItemButtonEdit)
Metodo pubblico | GetDisplayText(Object) | (Ereditato da RepositoryItem)
Metodo pubblico | GetDisplayText(FormatInfo, Object) | (Ereditato da RepositoryItem)
Metodo pubblico | GetEditorType | (Ereditato da RepositoryItem)
Metodo protetto | GetEditValueForExport | (Ereditato da RepositoryItem)
Metodo pubblico | GetEditValueForExportByOptions | (Ereditato da RepositoryItem)
Metodo protetto | GetEventSender | (Ereditato da RepositoryItem)
Metodo protetto | GetExportMode | (Ereditato da RepositoryItem)
Metodo protetto | GetFormattedDisplayText | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | GetHashCode | (Ereditato da RepositoryItem)
Metodo protetto | GetInPanelrect | (Ereditato da RepositoryItem)
Metodo protetto | GetNullEditText | (Ereditato da RepositoryItemButtonEdit)
Metodo protetto | GetNullText | (Ereditato da RepositoryItem)
Metodo protetto | GetNullValuePrompt | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetOrAddImageSource(PrintingSystemBase, MultiKey, SvgImage) | (Ereditato da RepositoryItem)
Metodo protetto | GetOrAddImageSource(PrintingSystemBase, MultiKey, Image) | (Ereditato da RepositoryItem)
Metodo protetto | GetOrAddImageSource(PrintingSystemBase, MultiKey, Object, Int32) | (Ereditato da RepositoryItem)
Metodo protetto | GetOverrideAppearance | (Ereditato da RepositoryItem)
Metodo protetto | GetPasswordCharCore | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetPrevContextImage | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetSender | (Ereditato da RepositoryItem)
Metodo protetto | GetTextFilterCapabilities | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | GetUseMaskAsDisplayFormat | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | InitializeEditMaskFromDisplayTextService | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | IsActivateKey | (Ereditato da RepositoryItem)
Metodo protetto | IsButtonEnabled | (Ereditato da RepositoryItemBaseSpinEdit)
Metodo pubblico | IsDefault | (Ereditato da RepositoryItem)
Metodo protetto | IsEmptyValue | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | IsFormatTypeCustom | (Ereditato da RepositoryItem)
Metodo pubblico | IsLockDefaultImmediateUpdateRowPosition | (Ereditato da RepositoryItem)
Metodo protetto | IsNeededChar | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | IsNeededKey | (Ereditato da RepositoryItem)
Metodo protetto | IsNeededKeyCore | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | IsNullValue | (Ereditato da RepositoryItem)
Metodo protetto | IsStandardTextEditStyle | (Ereditato da RepositoryItemButtonEdit)
Metodo pubblico | LockEvents | (Ereditato da RepositoryItem)
Metodo pubblico | MarkAsClone | (Ereditato da RepositoryItem)
Metodo protetto | NeededKeysContains | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | NeededKeysPopupContains | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | OnAllowFocusedChanged | (Ereditato da RepositoryItem)
Metodo protetto | OnAnnotationAttributesLoad | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnAppearanceChanged | (Ereditato da RepositoryItem)
Metodo protetto | OnAppearancePaintChanged | (Ereditato da RepositoryItem)
Metodo protetto | OnAppearanceSizeChanged | (Ereditato da RepositoryItem)
Metodo protetto | OnAutoHeightChanged | (Ereditato da RepositoryItem)
Metodo protetto | OnButtons_CollectionChanged | (Ereditato da RepositoryItemButtonEdit)
Metodo protetto | OnContainerLoaded | (Ereditato da RepositoryItem)
Metodo protetto | OnContextImageChanged | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnContextImageChanging | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnContextImageOptionsChanged | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnContextImageOptionsChanging | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnEnabledChanged | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnFormat_Changed | (Ereditato da RepositoryItem)
Metodo protetto | OnLoaded | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnMaskChanged | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnMaskSettingsChanged | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnOwnerEditChanged | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | OnPopupFormSizeChanged | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | OnPropertiesChanged | (Ereditato da RepositoryItem)
Metodo protetto | OnPropertiesChanged(EventArgs) | (Ereditato da RepositoryItem)
Metodo protetto | OnStyleChanged | (Ereditato da RepositoryItem)
Metodo protetto | OnTextEditStyleChanged | (Ereditato da RepositoryItemButtonEdit)
Metodo protetto | OnUpdateMaskSettings | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | PreparePrintViewInfo(PrintCellHelperInfo, Boolean) | (Ereditato da RepositoryItem)
Metodo protetto | PreparePrintViewInfo(PrintCellHelperInfo, BaseEditViewInfo, Boolean) | (Ereditato da RepositoryItem)
Metodo protetto | RaiseBeforePopup | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | RaiseBeforeShowMenu | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | RaiseButtonClick | (Ereditato da RepositoryItemButtonEdit)
Metodo protetto | RaiseButtonPressed | (Ereditato da RepositoryItemButtonEdit)
Metodo protetto | RaiseClosed | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | RaiseCloseUp | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | RaiseContextButtonClick | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | RaiseContextButtonValueChanged | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | RaiseCustomDisplayText(CustomDisplayTextEventArgs) | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | RaiseCustomDisplayText(Object, String) | (Ereditato da RepositoryItem)
Metodo protetto | RaiseCustomDisplayText(FormatInfo, Object, String) | (Ereditato da RepositoryItem)
Metodo protetto | RaiseCustomDrawButton | (Ereditato da RepositoryItemButtonEdit)
Metodo protetto | RaiseCustomHighlightText | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | RaiseCustomizeAutoCompleteSource | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | RaiseCustomizeContextItem | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | RaiseCustomTextLineHeight | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | RaiseEditValueChanged | (Ereditato da RepositoryItem)
Metodo protetto | RaiseEditValueChangedCore | (Ereditato da RepositoryItem)
Metodo protetto | RaiseEditValueChanging | (Ereditato da RepositoryItem)
Metodo protetto | RaiseFormatEditValue | (Ereditato da RepositoryItem)
Metodo protetto | RaiseModified | (Ereditato da RepositoryItem)
Metodo protetto | RaiseParseEditValue | (Ereditato da RepositoryItem)
Metodo protetto | RaisePopup | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | RaisePopupAllowClick | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | RaisePropertiesChanged | (Ereditato da RepositoryItem)
Metodo protetto | RaiseQueryAccessibilityHelp | (Ereditato da RepositoryItem)
Metodo protetto | RaiseQueryCloseUp | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | RaiseQueryPopUp | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | RaiseQueryProcessKey | (Ereditato da RepositoryItem)
Metodo protetto | RaiseRefreshRequired | (Ereditato da RepositoryItem)
Metodo protetto | RaiseSpin | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | RecreateMaskManagerOnIsNullInputAllowedChanged | (Ereditato da RepositoryItemTextEdit)
 | RegisterDedTextSpinEdit |
Metodo protetto | ResetAccessibleDescription | (Ereditato da RepositoryItem)
Metodo protetto | ResetAccessibleName | (Ereditato da RepositoryItem)
Metodo protetto | ResetAutoHeight | (Ereditato da RepositoryItem)
Metodo protetto | ResetDefaultMaskManager | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | ResetEvents | (Ereditato da RepositoryItem)
Metodo pubblico | ResetMaskSettings | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | ResetNullText | (Ereditato da RepositoryItem)
Metodo protetto | ResetNullValuePrompt | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | ResetPopupFormMinSize | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | ResetPopupFormSize | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | ResetTextEditStyle | (Ereditato da RepositoryItemButtonEdit)
Metodo pubblico | ScaleProperties | (Ereditato da RepositoryItem)
Metodo protetto | ScalePropertiesCore | (Ereditato da RepositoryItemPopupBase)
Metodo pubblico | SetCloned | (Ereditato da RepositoryItem)
Metodo protetto | SetCommonBrickProperties | (Ereditato da RepositoryItem)
Metodo protetto | SetOwnerEdit | (Ereditato da RepositoryItem)
Metodo protetto | SetTextBrickPropertiesCore | (Ereditato da RepositoryItem)
Metodo protetto | SetupCommonBrickStyleProperties | (Ereditato da RepositoryItem)
Metodo protetto | SetupTextBrickStyleProperties | (Ereditato da RepositoryItem)
Metodo protetto | ShouldRaiseCustomDisplayText | (Ereditato da RepositoryItem)
Metodo protetto | ShouldSerializeAccessibleDescription | (Ereditato da RepositoryItem)
Metodo protetto | ShouldSerializeAccessibleName | (Ereditato da RepositoryItem)
Metodo protetto | ShouldSerializeAutoHeight | (Ereditato da RepositoryItem)
Metodo pubblico | ShouldSerializeMaskSettings | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | ShouldSerializeNullText | (Ereditato da RepositoryItem)
Metodo protetto | ShouldSerializeNullValuePrompt | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | ShouldSerializePopupFormMinSize | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | ShouldSerializePopupFormSize | (Ereditato da RepositoryItemPopupBase)
Metodo protetto | ShouldSerializeTextEditStyle | (Ereditato da RepositoryItemButtonEdit)
Metodo protetto | StartContextImageChangingAnimation | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | SwitchMode | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | ThrowItemNotInRepositoryWarning | (Ereditato da RepositoryItem)
Metodo pubblico | ToString | (Ereditato da RepositoryItem)
Metodo protetto | ToStringTrimming | (Ereditato da RepositoryItem)
Metodo protetto | TriggerDelayedEditValueChanged | (Ereditato da RepositoryItem)
Metodo protetto | TriggerDelayedEditValueChanged(EventArgs) | (Ereditato da RepositoryItem)
Metodo protetto | TryGetThreadSafeDoFormatEditValueFunc | (Ereditato da RepositoryItem)
Metodo protetto | TryGetThreadSafeGetDisplayTextFunc | (Ereditato da RepositoryItem)
Metodo protetto | TryGetThreadSafeGetFormattedDisplayTextFunc | (Ereditato da RepositoryItemTextEdit)
Metodo protetto | TryGetThreadSafeIsNullValueFunc | (Ereditato da RepositoryItem)
Metodo protetto | TryGetThreadSafeRaiseCustomDisplayTextFunc | (Ereditato da RepositoryItemTextEdit)
Metodo pubblico | UnLockEvents | (Ereditato da RepositoryItem)
Torna su
Vedi anche

Documentazione

Classe RepositoryItemDedTextSpinEdit
Namespace DedNet.Controls


Metodo RepositoryItemDedTextSpinEdit.Assign

Metodo RepositoryItemDedTextSpinEditAssign

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void Assign(
    RepositoryItem item
)
Public Overrides Sub Assign (
    item As RepositoryItem
)
public:
virtual void Assign(
    RepositoryItem^ item
) override
abstract Assign :
        item : RepositoryItem -> unit
override Assign :
        item : RepositoryItem -> unit

Parametri

item RepositoryItem
Vedi anche

Documentazione

Classe RepositoryItemDedTextSpinEdit
Namespace DedNet.Controls


Metodo RepositoryItemDedTextSpinEdit.RegisterDedTextSpinEdit

Metodo RepositoryItemDedTextSpinEditRegisterDedTextSpinEdit

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void RegisterDedTextSpinEdit()
Public Shared Sub RegisterDedTextSpinEdit
public:
static void RegisterDedTextSpinEdit()
static member RegisterDedTextSpinEdit : unit -> unit
Vedi anche

Documentazione

Classe RepositoryItemDedTextSpinEdit
Namespace DedNet.Controls


Eventi di RepositoryItemDedTextSpinEdit

Il tipo RepositoryItemDedTextSpinEdit espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | BeforePopup | (Ereditato da RepositoryItemPopupBase)
Evento pubblico | BeforeShowMenu | (Ereditato da RepositoryItemTextEdit)
Evento pubblico | ButtonClick | (Ereditato da RepositoryItemButtonEdit)
Evento pubblico | ButtonPressed | (Ereditato da RepositoryItemButtonEdit)
Evento pubblico | Click | (Ereditato da RepositoryItem)
Evento pubblico | Closed | (Ereditato da RepositoryItemBaseSpinEdit)
Evento pubblico | CloseUp | (Ereditato da RepositoryItemBaseSpinEdit)
Evento pubblico | ContextButtonClick | (Ereditato da RepositoryItemPopupBase)
Evento pubblico | ContextButtonValueChanged | (Ereditato da RepositoryItemPopupBase)
Evento pubblico | CustomDisplayText | (Ereditato da RepositoryItem)
Evento pubblico | CustomDrawButton | (Ereditato da RepositoryItemButtonEdit)
Evento pubblico | CustomHighlightText | (Ereditato da RepositoryItemTextEdit)
Evento pubblico | CustomizeAutoCompleteSource | (Ereditato da RepositoryItemTextEdit)
Evento pubblico | CustomizeContextItem | (Ereditato da RepositoryItemPopupBase)
Evento pubblico | CustomTextLineHeight | (Ereditato da RepositoryItemTextEdit)
Evento pubblico | DoubleClick | (Ereditato da RepositoryItem)
Evento pubblico | DragDrop | (Ereditato da RepositoryItem)
Evento pubblico | DragEnter | (Ereditato da RepositoryItem)
Evento pubblico | DragLeave | (Ereditato da RepositoryItem)
Evento pubblico | DragOver | (Ereditato da RepositoryItem)
Evento pubblico | EditValueChanged | (Ereditato da RepositoryItem)
Evento pubblico | EditValueChanging | (Ereditato da RepositoryItem)
Evento pubblico | Enter | (Ereditato da RepositoryItem)
Evento pubblico | FormatEditValue | (Ereditato da RepositoryItem)
Evento pubblico | GiveFeedback | (Ereditato da RepositoryItem)
Evento pubblico | HelpRequested | (Ereditato da RepositoryItem)
Evento pubblico | KeyDown | (Ereditato da RepositoryItem)
Evento pubblico | KeyPress | (Ereditato da RepositoryItem)
Evento pubblico | KeyUp | (Ereditato da RepositoryItem)
Evento pubblico | Leave | (Ereditato da RepositoryItem)
Evento pubblico | Modified | (Ereditato da RepositoryItem)
Evento pubblico | MouseDown | (Ereditato da RepositoryItem)
Evento pubblico | MouseEnter | (Ereditato da RepositoryItem)
Evento pubblico | MouseHover | (Ereditato da RepositoryItem)
Evento pubblico | MouseLeave | (Ereditato da RepositoryItem)
Evento pubblico | MouseMove | (Ereditato da RepositoryItem)
Evento pubblico | MouseUp | (Ereditato da RepositoryItem)
Evento pubblico | MouseWheel | (Ereditato da RepositoryItem)
Evento pubblico | ParseEditValue | (Ereditato da RepositoryItem)
Evento pubblico | Popup | (Ereditato da RepositoryItemBaseSpinEdit)
Evento pubblico | PopupAllowClick | (Ereditato da RepositoryItemPopupBase)
Evento pubblico | PropertiesChanged | (Ereditato da RepositoryItem)
Evento pubblico | QueryAccessibilityHelp | (Ereditato da RepositoryItem)
Evento pubblico | QueryCloseUp | (Ereditato da RepositoryItemBaseSpinEdit)
Evento pubblico | QueryContinueDrag | (Ereditato da RepositoryItem)
Evento pubblico | QueryPopUp | (Ereditato da RepositoryItemBaseSpinEdit)
Evento pubblico | QueryProcessKey | (Ereditato da RepositoryItem)
Evento pubblico | Spin | (Ereditato da RepositoryItemTextEdit)
Evento pubblico | Validating | (Ereditato da RepositoryItem)
Torna su
Vedi anche

Documentazione

Classe RepositoryItemDedTextSpinEdit
Namespace DedNet.Controls


Campi di RepositoryItemDedTextSpinEdit

Il tipo RepositoryItemDedTextSpinEdit espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | Cloned | (Ereditato da RepositoryItem)
 | CustomEditName |
Campo protetto | fAllowFocused | (Ereditato da RepositoryItem)
Campo protetto | fAllowMouseWheel | (Ereditato da RepositoryItem)
Campo protetto | fAutoHeight | (Ereditato da RepositoryItem)
Campo protetto | fBorderStyle | (Ereditato da RepositoryItem)
Campo protetto | fButtonsStyle | (Ereditato da RepositoryItemButtonEdit)
Campo protetto | fCharacterCasing | (Ereditato da RepositoryItemTextEdit)
Campo protetto | fEditValueChangedFiringMode | (Ereditato da RepositoryItem)
Campo protetto | fEnabled | (Ereditato da RepositoryItem)
Campo protetto | fLockFormatParse | (Ereditato da RepositoryItem)
Campo protetto | fMaxLength | (Ereditato da RepositoryItemTextEdit)
Campo protetto | fNullText | (Ereditato da RepositoryItem)
Campo protetto | fPainter | (Ereditato da RepositoryItem)
Campo protetto | fPasswordChar | (Ereditato da RepositoryItemTextEdit)
Campo protetto | fReadOnly | (Ereditato da RepositoryItem)
Campo protetto | fTextEditStyle | (Ereditato da RepositoryItemButtonEdit)
Campo protetto | fValidateOnEnterKey | (Ereditato da RepositoryItemTextEdit)
Torna su
Vedi anche

Documentazione

Classe RepositoryItemDedTextSpinEdit
Namespace DedNet.Controls


Campo RepositoryItemDedTextSpinEdit.CustomEditName

Campo RepositoryItemDedTextSpinEditCustomEditName

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string CustomEditName = "DedTextSpinEdit"
Public Const CustomEditName As String = "DedTextSpinEdit"
public:
literal String^ CustomEditName = "DedTextSpinEdit"
static val mutable CustomEditName: string

Valore del campo

String
Vedi anche

Documentazione

Classe RepositoryItemDedTextSpinEdit
Namespace DedNet.Controls


Classe TreeListSafePaint
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
EditorContainer
TreeList
DedNet.ControlsTreeListSafePaint

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class TreeListSafePaint : TreeList
Public Class TreeListSafePaint
    Inherits TreeList
public ref class TreeListSafePaint : public TreeList
type TreeListSafePaint =
    class
        inherit TreeList
    end

Il tipo TreeListSafePaint espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | TreeListSafePaint | Costruttori
Metodo protetto | TreeListSafePaint(Object) |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | ActiveEditor | (Ereditato da TreeList)
Proprietà pubblica | ActiveFilter | (Ereditato da TreeList)
Proprietà pubblica | ActiveFilterCriteria | (Ereditato da TreeList)
Proprietà pubblica | ActiveFilterEnabled | (Ereditato da TreeList)
Proprietà pubblica | ActiveFilterInfo | (Ereditato da TreeList)
Proprietà pubblica | ActiveFilterString | (Ereditato da TreeList)
Proprietà protetta | ActualAutoNodeHeight | (Ereditato da TreeList)
Proprietà protetta | ActualFilterCriteria | (Ereditato da TreeList)
Proprietà protetta | ActualShowBands | (Ereditato da TreeList)
Proprietà pubblica | AllNodesCount | (Ereditato da TreeList)
Proprietà protetta | AllowAnimatedScrolling | (Ereditato da TreeList)
Proprietà protetta | AllowAutoFilterConditionChange | (Ereditato da TreeList)
Proprietà protetta | AllowBandColumnsMultiRow | (Ereditato da TreeList)
Proprietà protetta | AllowExpandAnimation | (Ereditato da TreeList)
Proprietà protetta | AllowFiltering | (Ereditato da TreeList)
Proprietà protetta | AllowFilteringAfterLoadingData | (Ereditato da TreeList)
Proprietà protetta | AllowFilterNodes | (Ereditato da TreeList)
Proprietà protetta | AllowFindPanel | (Ereditato da TreeList)
Proprietà protetta | AllowPrintProgress | (Ereditato da TreeList)
Proprietà protetta | AllowScaleOnLoad | (Ereditato da EditorContainer)
Proprietà pubblica | AllowTouchGestures | (Ereditato da EditorContainer)
Proprietà protetta | AllowTouchScroll | (Ereditato da TreeList)
Proprietà protetta | AnnotationManager | (Ereditato da TreeList)
Proprietà pubblica | Appearance | (Ereditato da TreeList)
Proprietà pubblica | AppearancePrint | (Ereditato da TreeList)
Proprietà pubblica | AutoFillColumn | (Ereditato da TreeList)
Proprietà pubblica | AutoFillColumnName | (Ereditato da TreeList)
Proprietà pubblica | AutoFillFieldName | (Ereditato da TreeList)
Proprietà protetta | AutoFilterNode | (Ereditato da TreeList)
Proprietà pubblica | BackColor | (Ereditato da TreeList)
Proprietà pubblica | BandPanelRowHeight | (Ereditato da TreeList)
Proprietà pubblica | Bands | (Ereditato da TreeList)
Proprietà pubblica | BestFitVisibleOnly | (Ereditato da TreeList)
Proprietà pubblica | BorderStyle | (Ereditato da TreeList)
Proprietà protetta | CanExpandNodesOnIncrementalSearch | (Ereditato da TreeList)
Proprietà protetta | CanLoadNodes | (Ereditato da TreeList)
Proprietà protetta | CanShowBandsInCustomizationForm | (Ereditato da TreeList)
Proprietà pubblica | CanShowEditor | (Ereditato da TreeList)
Proprietà pubblica | CanShowRowFooterSummary | (Ereditato da TreeList)
Proprietà pubblica | Caption | (Ereditato da TreeList)
Proprietà pubblica | CaptionHeight | (Ereditato da TreeList)
Proprietà protetta | CheckBoxesStrategy | (Ereditato da TreeList)
Proprietà pubblica | CheckBoxFieldName | (Ereditato da TreeList)
Proprietà pubblica | ChildListFieldName | (Ereditato da TreeList)
Proprietà protetta | ClientHeight | (Ereditato da TreeList)
Proprietà protetta | ClientWidth | (Ereditato da TreeList)
Proprietà pubblica | ClipboardDataProvider | (Ereditato da TreeList)
Proprietà protetta | ClipboardPasteHelper | (Ereditato da TreeList)
Proprietà protetta | ClipboardPasteManager | (Ereditato da TreeList)
Proprietà protetta | CloneInfoList | (Ereditato da TreeList)
Proprietà pubblica | ColumnPanelRowHeight | (Ereditato da TreeList)
Proprietà pubblica | Columns | (Ereditato da TreeList)
Proprietà pubblica | ColumnsImageList | (Ereditato da TreeList)
Proprietà protetta | ContainerHelper | (Ereditato da TreeList)
Proprietà pubblica | ContextMenuStrip | (Ereditato da EditorContainer)
Proprietà protetta | CurrencyManager | (Ereditato da TreeList)
Proprietà pubblica | Cursor | (Ereditato da TreeList)
Proprietà pubblica | CustomizationForm | (Ereditato da TreeList)
Proprietà pubblica | CustomizationFormBounds | (Ereditato da TreeList)
Proprietà pubblica | CustomizationRowCount | Obsoleto. (Ereditato da TreeList)
Proprietà protetta | Data | (Ereditato da TreeList)
Proprietà pubblica | DataMember | (Ereditato da TreeList)
Proprietà pubblica | DataSource | (Ereditato da TreeList)
Proprietà protetta | DefaultSize | (Ereditato da TreeList)
Proprietà protetta | DirectXProvider | (Ereditato da TreeList)
Proprietà protetta | DirectXScroller | (Ereditato da TreeList)
Proprietà pubblica | DragExpandDelay | Obsoleto. (Ereditato da TreeList)
Proprietà pubblica | DragNodesMode | Obsoleto. (Ereditato da TreeList)
Proprietà protetta | DXAccessible | (Ereditato da TreeList)
Proprietà protetta | Editable | (Ereditato da TreeList)
Proprietà protetta | EditFormController | (Ereditato da TreeList)
Proprietà pubblica | EditingValue | (Ereditato da TreeList)
Proprietà protetta | EditorHelper | (Ereditato da EditorContainer)
Proprietà protetta | ElementsLookAndFeel | (Ereditato da TreeList)
Proprietà pubblica | EmptyTreeHtmlTemplate | (Ereditato da TreeList)
Proprietà protetta | EnableDirectXPaint | (Ereditato da TreeList)
Proprietà pubblica | EnableDynamicLoading | (Ereditato da TreeList)
Proprietà pubblica | EnableEnhancedScrolling | (Ereditato da TreeList)
Proprietà protetta | EnableEnhancedSorting | (Ereditato da TreeList)
Proprietà protetta | EnableFirstPaintTrigger | (Ereditato da EditorContainer)
Proprietà pubblica | EnableImprovedColumnSizing | (Ereditato da TreeList)
Proprietà protetta | ErrorInfo | (Ereditato da TreeList)
Proprietà protetta | ExcelFilteringProvider | (Ereditato da TreeList)
Proprietà protetta | ExceptionThrown | (Ereditato da TreeList)
Proprietà pubblica | ExternalRepository | (Ereditato da EditorContainer)
Proprietà protetta | ExtraFilter | (Ereditato da TreeList)
Proprietà protetta | ExtraFilterCriteria | (Ereditato da TreeList)
Proprietà protetta | ExtraFilterHightlightText | (Ereditato da TreeList)
Proprietà protetta | FilterColumnsProvider | (Ereditato da TreeList)
Proprietà protetta | FilterHelper | (Ereditato da TreeList)
Proprietà protetta | FilteringService | (Ereditato da TreeList)
Proprietà pubblica | FilterPanelText | (Ereditato da TreeList)
Proprietà protetta | FilterPopup | (Ereditato da TreeList)
Proprietà protetta | FindFilterCriteria | (Ereditato da TreeList)
Proprietà pubblica | FindFilterText | (Ereditato da TreeList)
Proprietà protetta | FindPanel | (Ereditato da TreeList)
Proprietà pubblica | FindPanelVisible | (Ereditato da TreeList)
Proprietà protetta | FireOnLoadOnPaint | (Ereditato da TreeList)
Proprietà pubblica | FixedLineWidth | Azzero lo spessore della linea di delimitazione delle colonne fisse (Sovrascrive TreeList.FixedLineWidth)
Proprietà protetta | FocusedCellIndex | (Ereditato da TreeList)
Proprietà pubblica | FocusedColumn | (Ereditato da TreeList)
Proprietà pubblica | FocusedNode | (Ereditato da TreeList)
Proprietà protetta | FocusedRow | (Ereditato da TreeList)
Proprietà protetta | FocusedRowIndex | (Ereditato da TreeList)
Proprietà pubblica | FocusedValue | (Ereditato da TreeList)
Proprietà pubblica | FooterPanelHeight | (Ereditato da TreeList)
Proprietà protetta | ForceLoadingPanel | (Ereditato da TreeList)
Proprietà pubblica | ForeColor | (Ereditato da EditorContainer)
Proprietà pubblica | FormatConditions | (Ereditato da TreeList)
Proprietà pubblica | FormatRules | (Ereditato da TreeList)
Proprietà pubblica | GroupButtonSize | Obsoleto. (Ereditato da TreeList)
Proprietà protetta | Handler | (Ereditato da TreeList)
Proprietà protetta | HasAccessible | (Ereditato da TreeList)
Proprietà protetta | HasAllColumnsFixedRight | (Ereditato da TreeList)
Proprietà protetta | HasBands | (Ereditato da TreeList)
Proprietà pubblica | HasColumnErrors | (Ereditato da TreeList)
Proprietà protetta | HasCustomNodeCellEdit | (Ereditato da TreeList)
Proprietà pubblica | HasFocus | (Ereditato da TreeList)
Proprietà protetta | HasHierarchicalColumn | (Ereditato da TreeList)
Proprietà protetta | HasTreeViewColumn | (Ereditato da TreeList)
Proprietà protetta | HeaderLayoutCalculator | (Ereditato da TreeList)
Proprietà protetta | HeaderWidthCalculator | (Ereditato da TreeList)
Proprietà pubblica | HierarchyColumn | (Ereditato da TreeList)
Proprietà pubblica | HierarchyColumnIndent | (Ereditato da TreeList)
Proprietà pubblica | HierarchyColumnName | (Ereditato da TreeList)
Proprietà pubblica | HierarchyFieldName | (Ereditato da TreeList)
Proprietà pubblica | HorzScrollStep | (Ereditato da TreeList)
Proprietà pubblica | HorzScrollVisibility | (Ereditato da TreeList)
Proprietà protetta | HtmlContext | (Ereditato da TreeList)
Proprietà pubblica | HtmlImages | (Ereditato da TreeList)
Proprietà protetta | HtmlObjectCache | (Ereditato da TreeList)
Proprietà pubblica | HtmlTemplates | (Ereditato da TreeList)
Proprietà protetta | IBasePrintableCreatesIntersectedBricks | (Ereditato da TreeList)
Proprietà pubblica | ImageIndexFieldName | (Ereditato da TreeList)
Proprietà protetta | IncrementalText | (Ereditato da TreeList)
Proprietà pubblica | IndicatorWidth | (Ereditato da TreeList)
Proprietà protetta | IsAllowBusyIndicator | (Ereditato da TreeList)
Proprietà protetta | IsAllowBusyPanel | (Ereditato da TreeList)
Proprietà protetta | IsAlt | (Ereditato da TreeList)
Proprietà protetta | IsAttachedToSearchControl | (Ereditato da TreeList)
Proprietà protetta | IsAutoWidth | (Ereditato da TreeList)
Proprietà protetta | IsCellSelect | (Ereditato da TreeList)
Proprietà protetta | IsClosingEditor | (Ereditato da TreeList)
Proprietà protetta | IsColumnHeaderAutoHeight | (Ereditato da TreeList)
Proprietà protetta | IsControl | (Ereditato da TreeList)
Proprietà protetta | IsDataReady | (Ereditato da TreeList)
Proprietà protetta | IsDeserializing | (Ereditato da TreeList)
Proprietà pubblica | IsDesignMode | (Ereditato da EditorContainer)
Proprietà protetta | IsDynamicLoadingAllowed | (Ereditato da TreeList)
Proprietà protetta | IsEditFormMode | (Ereditato da TreeList)
Proprietà protetta | IsFilterPopupActive | (Ereditato da TreeList)
Proprietà protetta | IsFindFilterActive | (Ereditato da TreeList)
Proprietà pubblica | IsFindPanelVisible | (Ereditato da TreeList)
Proprietà protetta | IsFocusedNodeChangedLocked | (Ereditato da TreeList)
Proprietà protetta | IsFocusedNodeDataModified | (Ereditato da TreeList)
Proprietà protetta | IsGroupDeleteOperation | (Ereditato da TreeList)
Proprietà protetta | IsHScrollBarVisible | (Ereditato da TreeList)
Proprietà protetta | IsInitialized | (Ereditato da EditorContainer)
Proprietà protetta | IsIniting | (Ereditato da TreeList)
Proprietà pubblica | IsLoading | (Ereditato da EditorContainer)
Proprietà protetta | IsLockDirectXRendering | (Ereditato da TreeList)
Proprietà protetta | IsLockExpandCollapse | (Ereditato da TreeList)
Proprietà protetta | IsLockUpdate | (Ereditato da TreeList)
Proprietà pubblica | IsLookUpMode | (Ereditato da TreeList)
Proprietà protetta | IsMultiSelect | (Ereditato da TreeList)
Proprietà protetta | IsNotificationInfoVisible | (Ereditato da TreeList)
Proprietà protetta | IsPainting | (Ereditato da TreeList)
Proprietà protetta | IsPixelScrolling | (Ereditato da TreeList)
Proprietà protetta | IsPopupEditFormVisible | (Ereditato da TreeList)
Proprietà pubblica | IsPrinting | (Ereditato da TreeList)
Proprietà pubblica | IsPrintingAvailable | (Ereditato da TreeList)
Proprietà protetta | IsRightToLeft | (Ereditato da TreeList)
Proprietà protetta | IsRowCountReady | (Ereditato da TreeList)
Proprietà protetta | IsScrollAnimationInProgress | (Ereditato da TreeList)
Proprietà protetta | IsSearchMode | (Ereditato da TreeList)
Proprietà protetta | IsSerializing | (Ereditato da TreeList)
Proprietà protetta | IsShift | (Ereditato da TreeList)
Proprietà protetta | IsSorted | (Ereditato da TreeList)
Proprietà protetta | IsUnboundLoad | (Ereditato da TreeList)
Proprietà pubblica | IsUnboundMode | (Ereditato da TreeList)
Proprietà protetta | IsUpdateSize | (Ereditato da TreeList)
Proprietà protetta | IsVirtualMode | (Ereditato da TreeList)
Proprietà protetta | IsVScrollBarVisible | (Ereditato da TreeList)
Proprietà pubblica | KeyFieldName | (Ereditato da TreeList)
Proprietà pubblica | LayoutVersion | Obsoleto. (Ereditato da TreeList)
Proprietà pubblica | LeftCoord | (Ereditato da TreeList)
Proprietà pubblica | LoadingPanelVisible | (Ereditato da TreeList)
Proprietà pubblica | LookAndFeel | (Ereditato da EditorContainer)
Proprietà protetta | LookAndFeelIgnoreChildren | (Ereditato da EditorContainer)
Proprietà protetta | LookUpDisplayColumn | (Ereditato da TreeList)
Proprietà protetta | LookUpOwner | (Ereditato da TreeList)
Proprietà pubblica | MenuManager | (Ereditato da EditorContainer)
Proprietà protetta | MinRowHeight | (Ereditato da TreeList)
Proprietà pubblica | MinWidth | (Ereditato da TreeList)
Proprietà protetta | MRUFilterPopup | (Ereditato da TreeList)
Proprietà pubblica | MRUFilters | (Ereditato da TreeList)
Proprietà protetta | NewItemNode | (Ereditato da TreeList)
Proprietà pubblica | NewItemRowText | (Ereditato da TreeList)
Proprietà pubblica | NodeHtmlTemplate | (Ereditato da TreeList)
Proprietà pubblica | Nodes | (Ereditato da TreeList)
Proprietà pubblica | NodesIterator | (Ereditato da TreeList)
Proprietà pubblica | NonColumnFilterCriteria | (Ereditato da TreeList)
Proprietà pubblica | NonColumnFilterString | (Ereditato da TreeList)
Proprietà protetta | NotificationInfo | (Ereditato da TreeList)
Proprietà protetta | OfficeScroller | (Ereditato da TreeList)
Proprietà pubblica | OptionsBehavior | (Ereditato da TreeList)
Proprietà pubblica | OptionsClipboard | (Ereditato da TreeList)
Proprietà pubblica | OptionsCustomization | (Ereditato da TreeList)
Proprietà pubblica | OptionsDragAndDrop | (Ereditato da TreeList)
Proprietà pubblica | OptionsEditForm | (Ereditato da TreeList)
Proprietà pubblica | OptionsFilter | (Ereditato da TreeList)
Proprietà pubblica | OptionsFind | (Ereditato da TreeList)
Proprietà pubblica | OptionsHtmlTemplate | (Ereditato da TreeList)
Proprietà pubblica | OptionsLayout | (Ereditato da TreeList)
Proprietà pubblica | OptionsMenu | (Ereditato da TreeList)
Proprietà pubblica | OptionsNavigation | (Ereditato da TreeList)
Proprietà pubblica | OptionsPrint | (Ereditato da TreeList)
Proprietà pubblica | OptionsScrollAnnotations | (Ereditato da TreeList)
Proprietà pubblica | OptionsSelection | (Ereditato da TreeList)
Proprietà pubblica | OptionsView | (Ereditato da TreeList)
Proprietà pubblica | Painter | (Ereditato da TreeList)
Proprietà pubblica | ParentFieldName | (Ereditato da TreeList)
Proprietà protetta | Position | (Ereditato da TreeList)
Proprietà protetta | PressedBand | (Ereditato da TreeList)
Proprietà protetta | PressedColumn | (Ereditato da TreeList)
Proprietà protetta | PressedNode | (Ereditato da TreeList)
Proprietà pubblica | PreviewFieldName | (Ereditato da TreeList)
Proprietà pubblica | PreviewIndent | (Ereditato da TreeList)
Proprietà pubblica | PreviewLineCount | (Ereditato da TreeList)
Proprietà protetta | Printer | (Ereditato da TreeList)
Proprietà protetta | PrinterCore | (Ereditato da TreeList)
Proprietà protetta | ProgressWindow | (Ereditato da TreeList)
Proprietà pubblica | RepositoryItems | (Ereditato da EditorContainer)
Proprietà pubblica | RootValue | (Ereditato da TreeList)
Proprietà protetta | RowCount | (Ereditato da TreeList)
Proprietà pubblica | RowHeight | (Ereditato da TreeList)
Proprietà protetta | ScaleDPI | (Ereditato da EditorContainer)
Proprietà pubblica | ScaleFactor | (Ereditato da EditorContainer)
Proprietà protetta | ScaleHelper | (Ereditato da EditorContainer)
Proprietà protetta | ScrollInfo | (Ereditato da TreeList)
Proprietà pubblica | SelectedHtmlText | (Ereditato da TreeList)
Proprietà pubblica | SelectImageList | (Ereditato da TreeList)
Proprietà pubblica | Selection | (Ereditato da TreeList)
Proprietà protetta | SelectionRange | (Ereditato da TreeList)
Proprietà pubblica | ShowButtonMode | (Ereditato da TreeList)
Proprietà protetta | ShowEditorAfterAnimatedScroll | (Ereditato da TreeList)
Proprietà protetta | ShowPreview | (Ereditato da TreeList)
Proprietà protetta | SizedBand | (Ereditato da TreeList)
Proprietà protetta | SizedColumn | (Ereditato da TreeList)
Proprietà protetta | SmartVisibility | (Ereditato da TreeList)
Proprietà pubblica | SortedColumnCount | (Ereditato da TreeList)
Proprietà pubblica | State | (Ereditato da TreeList)
Proprietà pubblica | StateImageList | (Ereditato da TreeList)
Proprietà pubblica | SyncCheckStateWithSourceOnChecking | (Ereditato da TreeList)
Proprietà pubblica | Text | (Ereditato da EditorContainer)
Proprietà pubblica | ToolTipController | (Ereditato da EditorContainer)
Proprietà protetta | TopVisibleNode | (Ereditato da TreeList)
Proprietà pubblica | TopVisibleNodeIndex | (Ereditato da TreeList)
Proprietà pubblica | TopVisibleNodePixel | (Ereditato da TreeList)
Proprietà pubblica | TreeLevelWidth | (Ereditato da TreeList)
Proprietà pubblica | TreeLineStyle | (Ereditato da TreeList)
Proprietà pubblica | TreeListDisposing | (Ereditato da TreeList)
Proprietà pubblica | TreeViewColumn | (Ereditato da TreeList)
Proprietà pubblica | TreeViewColumnName | (Ereditato da TreeList)
Proprietà pubblica | TreeViewFieldName | (Ereditato da TreeList)
Proprietà pubblica | UpdateTopVisibleNodeIndexOnCollapse | (Ereditato da TreeList)
Proprietà protetta | UseBandsAdvancedHorizontalNavigation | (Ereditato da TreeList)
Proprietà protetta | UseBandsAdvancedVerticalNavigation | (Ereditato da TreeList)
Proprietà pubblica | UseDirectXPaint | (Ereditato da TreeList)
Proprietà pubblica | UseDisabledStatePainter | (Ereditato da TreeList)
Proprietà protetta | UseStandardFilter | (Ereditato da TreeList)
Proprietà pubblica | VertScrollVisibility | (Ereditato da TreeList)
Proprietà pubblica | ViewInfo | (Ereditato da TreeList)
Proprietà pubblica | ViewStyle | (Ereditato da TreeList)
Proprietà protetta | VirtualDataHelper | (Ereditato da TreeList)
Proprietà pubblica | VisibleColumnCount | Obsoleto. (Ereditato da TreeList)
Proprietà pubblica | VisibleColumns | (Ereditato da TreeList)
Proprietà pubblica | VisibleNodesCount | (Ereditato da TreeList)
Proprietà protetta | WorkAsLookup | (Ereditato da TreeList)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AccessibleNotifyClients(AccessibleEvents, BaseAccessible) | (Ereditato da TreeList)
Metodo pubblico | AccessibleNotifyClients(AccessibleEvents, Int32, Int32) | (Ereditato da TreeList)
Metodo pubblico | AddFilter(CriteriaOperator) | (Ereditato da TreeList)
Metodo pubblico | AddFilter(String) | (Ereditato da TreeList)
Metodo protetto | AddToDefaultTooltipController | (Ereditato da EditorContainer)
Metodo protetto | AllowAutoFilterCondition | (Ereditato da TreeList)
Metodo protetto | AnimateKeyboardNavigation | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, TreeListNode) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, TreeListNode, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, TreeListNode, CheckState) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, CheckState) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, TreeListNode, CheckState, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, CheckState, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, TreeListNode, CheckState, NodeCheckBoxStyle, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, Int32, Int32, Int32) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, Int32, Int32, Int32, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, Int32, Int32, Int32, CheckState) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, Int32, Int32, Int32, CheckState, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, Int32, Int32, Int32, CheckState, NodeCheckBoxStyle, Object) | (Ereditato da TreeList)
Metodo protetto | ApplyFilter | (Ereditato da TreeList)
Metodo pubblico | ApplyFindFilter | (Ereditato da TreeList)
Metodo protetto | BeforeShowEditForm | (Ereditato da TreeList)
Metodo pubblico | BeginDelete | (Ereditato da TreeList)
Metodo protetto | BeginDragDrop | (Ereditato da TreeList)
Metodo protetto | BeginExpandCollapse | (Ereditato da TreeList)
Metodo pubblico | BeginInit | (Ereditato da EditorContainer)
Metodo protetto | BeginLockListChanged | (Ereditato da TreeList)
Metodo pubblico | BeginSelection | (Ereditato da TreeList)
Metodo pubblico | BeginSort | (Ereditato da TreeList)
Metodo pubblico | BeginUnboundLoad | (Ereditato da TreeList)
Metodo pubblico | BeginUpdate | (Ereditato da TreeList)
Metodo pubblico | BestFitColumns | (Ereditato da TreeList)
Metodo pubblico | BestFitColumns(Boolean) | (Ereditato da TreeList)
Metodo pubblico | BindCommand(Object, String, FuncObject) | (Ereditato da TreeList)
Metodo pubblico | BindCommand(ExpressionAction, Object, String, FuncObject) | (Ereditato da TreeList)
Metodo pubblico | BindCommand``1(ExpressionActionUMP, Object, String, FuncUMP) | (Ereditato da TreeList)
Metodo protetto | CalcActiveEditorBounds | (Ereditato da TreeList)
Metodo protetto | CalcColumnBestWidth | (Ereditato da TreeList)
Metodo pubblico | CalcHitInfo | (Ereditato da TreeList)
Metodo protetto | CalcHScrollRange | (Ereditato da TreeList)
Metodo protetto | CalcNodeAutoHeight | (Ereditato da TreeList)
Metodo protetto | CalcRowCount | (Ereditato da TreeList)
Metodo protetto | CalcScrollClientRect | (Ereditato da TreeList)
Metodo protetto | CalculateScrollBars | (Ereditato da TreeList)
Metodo protetto | CalculateVisibleRowsAreaHeight | (Ereditato da TreeList)
Metodo pubblico | CancelCurrentEdit | (Ereditato da TreeList)
Metodo protetto | CancelDirectXRendering | (Ereditato da TreeList)
Metodo protetto | CancelLockListChanged | (Ereditato da TreeList)
Metodo protetto | CancelSelection | (Ereditato da TreeList)
Metodo pubblico | CancelSort | (Ereditato da TreeList)
Metodo pubblico | CancelUpdate | (Ereditato da TreeList)
Metodo protetto | CanClearAllSorting | (Ereditato da TreeList)
Metodo protetto | CanCloneChildren | (Ereditato da TreeList)
Metodo protetto | CanFilterByColumnEdit | (Ereditato da TreeList)
Metodo pubblico | CanFilterColumn | (Ereditato da TreeList)
Metodo protetto | CanFindColumn | (Ereditato da TreeList)
Metodo protetto | CanFocusNode | (Ereditato da TreeList)
Metodo protetto | CanHandleTouchGestures | (Ereditato da EditorContainer)
Metodo protetto | CanIncrementalSearch | (Ereditato da TreeList)
Metodo pubblico | CanIndentNodes | (Ereditato da TreeList)
Metodo protetto | CanMove | (Ereditato da TreeList)
Metodo protetto | CanMoveBand | (Ereditato da TreeList)
Metodo protetto | CanMoveColumn | (Ereditato da TreeList)
Metodo pubblico | CanOutdentNodes | (Ereditato da TreeList)
Metodo protetto | CanResizeBand | (Ereditato da TreeList)
Metodo protetto | CanResizeColumn | (Ereditato da TreeList)
Metodo protetto | CanShowHScrollBar | (Ereditato da TreeList)
Metodo protetto | CanShowHScrollBarCore | (Ereditato da TreeList)
Metodo protetto | CanShowVScrollBar | (Ereditato da TreeList)
Metodo protetto | CanSortByColumnEdit | (Ereditato da TreeList)
Metodo pubblico | CanSortColumn | (Ereditato da TreeList)
Metodo protetto | CanStartTouchScrolling | (Ereditato da TreeList)
Metodo protetto | ChangeLeftCoord | (Ereditato da TreeList)
Metodo pubblico | CheckAll | (Ereditato da TreeList)
Metodo protetto | CheckAllowGestures | (Ereditato da TreeList)
Metodo protetto | CheckAllowNotifications | (Ereditato da TreeList)
Metodo protetto | CheckData | (Ereditato da TreeList)
Metodo protetto | CheckIncreaseVisibleRows | (Ereditato da TreeList)
Metodo protetto | CheckModifierKeys | (Ereditato da TreeList)
Metodo protetto | CheckNeedScale | (Ereditato da EditorContainer)
Metodo protetto | CheckRightToLeft | (Ereditato da EditorContainer)
Metodo protetto | CheckSearchMode | (Ereditato da TreeList)
Metodo protetto | CheckTopVisibleNodeAfterItemAdded | (Ereditato da TreeList)
Metodo protetto | CheckTopVisibleNodePixelValue | (Ereditato da TreeList)
Metodo pubblico | ClearColumnErrors | (Ereditato da TreeList)
Metodo pubblico | ClearColumnFilter | (Ereditato da TreeList)
Metodo protetto | ClearColumnFilterCore(String) | (Ereditato da TreeList)
Metodo protetto | ClearColumnFilterCore(TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | ClearColumnsFilter | (Ereditato da TreeList)
Metodo pubblico | ClearDocument | (Ereditato da TreeList)
Metodo pubblico | ClearFindFilter | (Ereditato da TreeList)
Metodo pubblico | ClearFocusedColumn | (Ereditato da TreeList)
Metodo pubblico | ClearNodes | (Ereditato da TreeList)
Metodo pubblico | ClearSelection | (Ereditato da TreeList)
Metodo pubblico | ClearSorting | (Ereditato da TreeList)
Metodo protetto | ClearVisibleIndicesCache | (Ereditato da TreeList)
Metodo pubblico | CloseEditForm | (Ereditato da TreeList)
Metodo pubblico | CloseEditor | (Ereditato da TreeList)
Metodo protetto | CloseEditor(Boolean) | (Ereditato da TreeList)
Metodo pubblico | CollapseAll | (Ereditato da TreeList)
Metodo protetto | CollapseAllCore | (Ereditato da TreeList)
Metodo pubblico | CollapseToLevel | (Ereditato da TreeList)
Metodo pubblico | ColumnsCustomization | (Ereditato da TreeList)
Metodo pubblico | ColumnsCustomization(Point) | (Ereditato da TreeList)
Metodo protetto | ControlRowSourceSelectedChanged | (Ereditato da TreeList)
Metodo protetto | ControlRowSourceVisibleChanged | (Ereditato da TreeList)
Metodo pubblico | ConvertFormatConditionToFormatRules | (Ereditato da TreeList)
Metodo pubblico | CopyNode(TreeListNode, TreeListNode, Boolean) | (Ereditato da TreeList)
Metodo pubblico | CopyNode(TreeListNode, TreeListNode, Boolean, Boolean) | (Ereditato da TreeList)
Metodo pubblico | CopyNode(TreeListNode, TreeListNode, Boolean, Int32) | (Ereditato da TreeList)
Metodo pubblico | CopyNode(TreeListNode, TreeListNode, Boolean, Boolean, Int32) | (Ereditato da TreeList)
Metodo protetto | CopyNodeCore | (Ereditato da TreeList)
Metodo pubblico | CopyNodes(IEnumerableTreeListNode, TreeListNode, Boolean, Int32) | (Ereditato da TreeList)
Metodo pubblico | CopyNodes(IEnumerableTreeListNode, TreeListNode, Boolean, Boolean, Int32) | (Ereditato da TreeList)
Metodo pubblico | CopyToClipboard | (Ereditato da TreeList)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da TreeList)
Metodo protetto | CreateAccessibleDataRow | (Ereditato da TreeList)
Metodo protetto | CreateAccessibleInstance | (Ereditato da TreeList)
Metodo protetto | CreateAllOptions | (Ereditato da TreeList)
Metodo protetto | CreateAnnotationManager | (Ereditato da TreeList)
Metodo protetto | CreateAppearances | (Ereditato da TreeList)
Metodo protetto | CreateAutoFilterCriterion | (Ereditato da TreeList)
Metodo protetto | CreateBands | (Ereditato da TreeList)
Metodo protetto | CreateCheckBoxesStrategy | (Ereditato da TreeList)
Metodo protetto | CreateCheckedListFilterPopup | (Ereditato da TreeList)
Metodo protetto | CreateColumn | (Ereditato da TreeList)
Metodo protetto | CreateColumnEditViewInfo | (Ereditato da TreeList)
Metodo protetto | CreateColumnFilterCriteriaByValue(TreeListColumn, Object) | (Ereditato da TreeList)
Metodo protetto | CreateColumnFilterCriteriaByValue(TreeListColumn, Object, Boolean) | (Ereditato da TreeList)
Metodo protetto | CreateColumnFilterPopup | (Ereditato da TreeList)
Metodo protetto | CreateColumns | (Ereditato da TreeList)
Metodo pubblico | CreateCustomization | Obsoleto. (Ereditato da TreeList)
Metodo protetto | CreateCustomizationForm | (Ereditato da TreeList)
Metodo protetto | CreateData | (Ereditato da TreeList)
Metodo protetto | CreateDataViewData | (Ereditato da TreeList)
Metodo protetto | CreateDateFilterPopup | (Ereditato da TreeList)
Metodo protetto | CreateDragNodesProvider | (Ereditato da TreeList)
Metodo protetto | CreateEditFormController | (Ereditato da TreeList)
Metodo protetto | CreateElementsLookAndFeel | (Ereditato da TreeList)
Metodo protetto | CreateExcelFilterPopup | (Ereditato da TreeList)
Metodo protetto | CreateFilterColumnCollection | (Ereditato da TreeList)
Metodo protetto | CreateFilterColumnRuleCollection | (Ereditato da TreeList)
Metodo protetto | CreateFilterColumnsProvider | (Ereditato da TreeList)
Metodo protetto | CreateFilterCriteriaBindingTarget | (Ereditato da TreeList)
Metodo protetto | CreateFilterEditorForm | (Ereditato da TreeList)
Metodo protetto | CreateFilterHelper | (Ereditato da TreeList)
Metodo protetto | CreateFindPanel | (Ereditato da TreeList)
Metodo protetto | CreateFindPanelCore | (Ereditato da TreeList)
Metodo pubblico | CreateGraphicsCache | (Ereditato da TreeList)
Metodo protetto | CreateHandler | (Ereditato da TreeList)
Metodo protetto | CreateHeaderLayoutCalculator | (Ereditato da TreeList)
Metodo protetto | CreateHeaderWidthCalculator | (Ereditato da TreeList)
Metodo protetto | CreateHelper | (Ereditato da TreeList)
Metodo protetto | CreateHierarchicalListData | (Ereditato da TreeList)
Metodo protetto | CreateHtmlContext | (Ereditato da TreeList)
Metodo protetto | CreateHyperlinkClickEventArgs | (Ereditato da TreeList)
Metodo protetto | CreateInternalRepository | (Ereditato da EditorContainer)
Metodo protetto | CreateListColumnFilterPopup | (Ereditato da TreeList)
Metodo protetto | CreateListData | (Ereditato da TreeList)
Metodo protetto | CreateLoadingAnimator | (Ereditato da TreeList)
Metodo protetto | CreateLoadingPanel | (Ereditato da TreeList)
Metodo protetto | CreateLookAndFeel | (Ereditato da EditorContainer)
Metodo protetto | CreateNewItemNode | (Ereditato da TreeList)
Metodo protetto | CreateNode(Int32, TreeListNodes) | (Ereditato da TreeList)
Metodo protetto | CreateNode(Int32, TreeListNodes, Object) | (Ereditato da TreeList)
Metodo protetto | CreateNodes | (Ereditato da TreeList)
Metodo protetto | CreateNodesComparer | (Ereditato da TreeList)
Metodo protetto | CreateNodesIterator | (Ereditato da TreeList)
Metodo protetto | CreateNotificationInfo | (Ereditato da TreeList)
Metodo protetto | CreateOfficeScroller | (Ereditato da TreeList)
Metodo protetto | CreateOptionsBehavior | (Ereditato da TreeList)
Metodo protetto | CreateOptionsClipboard | (Ereditato da TreeList)
Metodo protetto | CreateOptionsCustomization | (Ereditato da TreeList)
Metodo protetto | CreateOptionsDragAndDrop | (Ereditato da TreeList)
Metodo protetto | CreateOptionsEditForm | (Ereditato da TreeList)
Metodo protetto | CreateOptionsFilter | (Ereditato da TreeList)
Metodo protetto | CreateOptionsFind | (Ereditato da TreeList)
Metodo protetto | CreateOptionsHtmlTemplate | (Ereditato da TreeList)
Metodo protetto | CreateOptionsLayout | (Ereditato da TreeList)
Metodo protetto | CreateOptionsMenu | (Ereditato da TreeList)
Metodo protetto | CreateOptionsNavigation | (Ereditato da TreeList)
Metodo protetto | CreateOptionsPrint | (Ereditato da TreeList)
Metodo protetto | CreateOptionsScrollAnnotations | (Ereditato da TreeList)
Metodo protetto | CreateOptionsSelection | (Ereditato da TreeList)
Metodo protetto | CreateOptionsView | (Ereditato da TreeList)
Metodo protetto | CreatePainter | (Ereditato da TreeList)
Metodo protetto | CreatePrinter | (Ereditato da TreeList)
Metodo protetto | CreateProvider | (Ereditato da TreeList)
Metodo protetto | CreateScrollInfo | (Ereditato da TreeList)
Metodo protetto | CreateSelection | (Ereditato da TreeList)
Metodo protetto | CreateUnboundData | (Ereditato da TreeList)
Metodo protetto | CreateViewInfo | (Ereditato da TreeList)
Metodo protetto | CreateVirtualData | (Ereditato da TreeList)
Metodo protetto | CreateVirtualDataHelper | (Ereditato da TreeList)
Metodo protetto | CurrencyManager_ItemChanged | (Ereditato da TreeList)
Metodo protetto | CurrencyManager_PositionChanged | (Ereditato da TreeList)
Metodo protetto | DeferredLoadChildren | (Ereditato da TreeList)
Metodo protetto | DelayedInvalidate | (Ereditato da TreeList)
Metodo pubblico | DeleteNode | (Ereditato da TreeList)
Metodo pubblico | DeleteNodes | (Ereditato da TreeList)
Metodo pubblico | DeleteSelectedNodes | (Ereditato da TreeList)
Metodo pubblico | DestroyCustomization | (Ereditato da TreeList)
Metodo protetto | DestroyDirectXProvider | (Ereditato da EditorContainer)
Metodo protetto | DestroyFindPanel | (Ereditato da TreeList)
Metodo protetto | Dispose | (Ereditato da TreeList)
Metodo protetto | DoDataSourceChanged | (Ereditato da TreeList)
Metodo protetto | DoDpiChange | (Ereditato da EditorContainer)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da TreeList)
Metodo protetto | DoDragDrop | (Ereditato da TreeList)
Metodo pubblico | DoDragDropNode | (Ereditato da TreeList)
Metodo pubblico | DoDragDropNodes | (Ereditato da TreeList)
Metodo protetto | DoFilterNode | (Ereditato da TreeList)
Metodo protetto | DoForEachBand | (Ereditato da TreeList)
Metodo pubblico | DoIncrementalSearch | (Ereditato da TreeList)
Metodo protetto | DoShowTreeListMenu(TreeListMenu, TreeListHitTest) | (Ereditato da TreeList)
Metodo protetto | DoShowTreeListMenu(TreeListMenu, Control, Point) | (Ereditato da TreeList)
Metodo protetto | DoTopVisibleNodeChanged | (Ereditato da TreeList)
Metodo pubblico | EndCurrentEdit | (Ereditato da TreeList)
Metodo pubblico | EndCurrentEdit(Boolean) | (Ereditato da TreeList)
Metodo pubblico | EndDelete | (Ereditato da TreeList)
Metodo protetto | EndDragDrop | (Ereditato da TreeList)
Metodo protetto | EndEdit | (Ereditato da TreeList)
Metodo protetto | EndExpandCollapse | (Ereditato da TreeList)
Metodo pubblico | EndInit | (Ereditato da EditorContainer)
Metodo pubblico | EndSelection | (Ereditato da TreeList)
Metodo pubblico | EndSort | (Ereditato da TreeList)
Metodo pubblico | EndUnboundLoad | (Ereditato da TreeList)
Metodo pubblico | EndUpdate | (Ereditato da TreeList)
Metodo protetto | EnsureControlRowSource | (Ereditato da TreeList)
Metodo protetto | EnsureEditFormController | (Ereditato da TreeList)
Metodo protetto | EnsureFilteringClientDataBinding | (Ereditato da TreeList)
Metodo protetto | ExecutePrinterAction | (Ereditato da TreeList)
Metodo pubblico | ExpandAll | (Ereditato da TreeList)
Metodo protetto | ExpandAllCore | (Ereditato da TreeList)
Metodo protetto | ExpandToLast | (Ereditato da TreeList)
Metodo pubblico | ExpandToLevel | (Ereditato da TreeList)
Metodo protetto | ExpandToRoot | (Ereditato da TreeList)
Metodo protetto | Export(ExportTarget, Stream) | (Ereditato da TreeList)
Metodo protetto | Export(ExportTarget, String) | (Ereditato da TreeList)
Metodo protetto | Export(ExportTarget, Stream, ExportOptionsBase) | (Ereditato da TreeList)
Metodo protetto | Export(ExportTarget, String, ExportOptionsBase) | (Ereditato da TreeList)
Metodo pubblico | ExportToCsv(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToCsv(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToCsv(Stream, CsvExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToCsv(String, CsvExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToDocx(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToDocx(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToDocx(Stream, DocxExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToDocx(String, DocxExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToHtml(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToHtml(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToHtml(Stream, HtmlExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToHtml(String, HtmlExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToMht(Stream, MhtExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToMht(String, MhtExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToMht(String, String) | Obsoleto. (Ereditato da TreeList)
Metodo pubblico | ExportToMht(Stream, String, String, Boolean) | Obsoleto. (Ereditato da TreeList)
Metodo pubblico | ExportToMht(String, String, String, Boolean) | Obsoleto. (Ereditato da TreeList)
Metodo pubblico | ExportToPdf(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToPdf(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToPdf(Stream, PdfExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToPdf(String, PdfExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToRtf(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToRtf(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToText(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToText(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToText(Stream, TextExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToText(String, TextExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToXls(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToXls(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToXls(Stream, XlsExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToXls(String, XlsExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToXlsx(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToXlsx(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToXlsx(Stream, XlsxExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToXlsx(String, XlsxExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToXml(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToXml(String) | (Ereditato da TreeList)
Metodo protetto | ExportToXmlCore | (Ereditato da TreeList)
Metodo protetto | ExtractTemplateRootNode | (Ereditato da TreeList)
Metodo pubblico | FilterNodes | (Sovrascrive TreeList.FilterNodes)
Metodo pubblico | FilterNodes(TreeListNodes) | (Ereditato da TreeList)
Metodo protetto | FilterNodesCore | (Ereditato da TreeList)
Metodo pubblico | FindNode | (Ereditato da TreeList)
Metodo pubblico | FindNodeByFieldValue | (Ereditato da TreeList)
Metodo pubblico | FindNodeByID | (Ereditato da TreeList)
Metodo pubblico | FindNodeByKeyID | (Ereditato da TreeList)
Metodo protetto | FindNodeByParentID | (Ereditato da TreeList)
Metodo pubblico | FindNodes | (Ereditato da TreeList)
Metodo protetto | FindPanelNext | (Ereditato da TreeList)
Metodo protetto | FindPanelPrev | (Ereditato da TreeList)
Metodo pubblico | FireChanged | (Ereditato da TreeList)
Metodo protetto | FitColumns | (Ereditato da TreeList)
Metodo pubblico | FocusNewItemNode | (Ereditato da TreeList)
Metodo protetto | ForceCalcRowCount | (Ereditato da TreeList)
Metodo pubblico | ForceInitialize | (Ereditato da TreeList)
Metodo protetto | ForceSetTopVisibleNodeIndex | (Ereditato da TreeList)
Metodo pubblico | FullCollapse | Obsoleto. (Ereditato da TreeList)
Metodo pubblico | FullExpand | Obsoleto. (Ereditato da TreeList)
Metodo pubblico | FullExpandNode | Obsoleto. (Ereditato da TreeList)
Metodo protetto | GetAccessibilityObjectById | (Ereditato da TreeList)
Metodo protetto | GetAccessibleNodeCell | (Ereditato da TreeList)
Metodo protetto | GetActiveEditorHighAppearance | (Ereditato da TreeList)
Metodo protetto | GetActualAnimationType | (Ereditato da TreeList)
Metodo protetto | GetActualTreeListFilterMode | (Ereditato da TreeList)
Metodo pubblico | GetAllCheckedNodes | (Ereditato da TreeList)
Metodo protetto | GetAllowChangeBandParent | (Ereditato da TreeList)
Metodo protetto | GetAllowColumnFilterPopup | (Ereditato da TreeList)
Metodo protetto | GetAllowFilterEditor | (Ereditato da TreeList)
Metodo protetto | GetAllowFindColumn | (Ereditato da TreeList)
Metodo protetto | GetAllowFocus | (Ereditato da TreeList)
Metodo protetto | GetAllowHighlightFindResults | (Ereditato da TreeList)
Metodo protetto | GetAllowMRUFilterList | (Ereditato da TreeList)
Metodo protetto | GetAutoFilterRowColumnEdit | (Ereditato da TreeList)
Metodo pubblico | GetAutoFilterValue | (Ereditato da TreeList)
Metodo protetto | GetAutoNodeHeight | (Ereditato da TreeList)
Metodo protetto | GetBandRows | (Ereditato da TreeList)
Metodo protetto | GetBandRowsCore | (Ereditato da TreeList)
Metodo protetto | GetBandVisibleIndex | (Ereditato da TreeList)
Metodo protetto | GetCanShowEditor | (Ereditato da TreeList)
Metodo pubblico | GetColumnByColumnHandle | (Ereditato da TreeList)
Metodo pubblico | GetColumnByVisibleIndex | (Ereditato da TreeList)
Metodo protetto | GetColumnDefaultRepositoryItem | (Ereditato da TreeList)
Metodo protetto | GetColumnDefaultRepositoryItemForEditing | (Ereditato da TreeList)
Metodo protetto | GetColumnEdit | (Ereditato da TreeList)
Metodo protetto | GetColumnEditForEditing | (Ereditato da TreeList)
Metodo pubblico | GetColumnError(TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | GetColumnError(TreeListColumn, TreeListNode) | (Ereditato da TreeList)
Metodo pubblico | GetColumnErrorType(TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | GetColumnErrorType(TreeListColumn, TreeListNode) | (Ereditato da TreeList)
Metodo protetto | GetColumnFieldNameSort | (Ereditato da TreeList)
Metodo protetto | GetColumnFilterCriteria | (Ereditato da TreeList)
Metodo protetto | GetColumnFilterMode | (Ereditato da TreeList)
Metodo pubblico | GetColumnHeaderBestWidth | (Ereditato da TreeList)
Metodo protetto | GetColumnName | (Ereditato da TreeList)
Metodo protetto | GetCurrencyManager | (Ereditato da TreeList)
Metodo protetto | GetDataColumnInfo | (Ereditato da TreeList)
Metodo pubblico | GetDataRecordByNode | (Ereditato da TreeList)
Metodo pubblico | GetDataRow | (Ereditato da TreeList)
Metodo protetto | GetDirectXDeviceBackColor | (Ereditato da EditorContainer)
Metodo protetto | GetDirectXProvider | (Ereditato da EditorContainer)
Metodo protetto | GetEditableObject | (Ereditato da TreeList)
Metodo pubblico | GetEditorShowMode | (Ereditato da TreeList)
Metodo protetto | GetEditorViewInfo | (Ereditato da TreeList)
Metodo protetto | GetFilterColumn | (Ereditato da TreeList)
Metodo protetto | GetFilterColumnByTreeListColumn | (Ereditato da TreeList)
Metodo protetto | GetFilterCriteriaDisplayStyle | (Ereditato da TreeList)
Metodo protetto | GetFilterDisplayText | (Ereditato da TreeList)
Metodo protetto | GetFilterDisplayTextByColumn | (Ereditato da TreeList)
Metodo protetto | GetFilterPopupTexts | (Ereditato da TreeList)
Metodo protetto | GetFilterPopupValues(TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | GetFilterPopupValues(TreeListColumn, Boolean) | (Ereditato da TreeList)
Metodo protetto | GetFilterPopupValues(TreeListColumn, CriteriaOperator, Boolean) | (Ereditato da TreeList)
Metodo protetto | GetFilterPopupValues(TreeListColumn, Boolean, Boolean) | (Ereditato da TreeList)
Metodo protetto | GetFilterRowValue(Object) | (Ereditato da TreeList)
Metodo protetto | GetFilterRowValue(TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | GetFindMatchedRanges | (Ereditato da TreeList)
Metodo protetto | GetFindMatchedText | (Ereditato da TreeList)
Metodo protetto | GetFindToColumnsCollection | (Ereditato da TreeList)
Metodo pubblico | GetFocusedDataRow | (Ereditato da TreeList)
Metodo pubblico | GetFocusedDisplayText | (Ereditato da TreeList)
Metodo pubblico | GetFocusedRow | (Ereditato da TreeList)
Metodo pubblico | GetFocusedRowCellDisplayText(String) | (Ereditato da TreeList)
Metodo pubblico | GetFocusedRowCellDisplayText(TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetFocusedRowCellValue(String) | (Ereditato da TreeList)
Metodo pubblico | GetFocusedRowCellValue(TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetGroupSummaryValue | (Ereditato da TreeList)
Metodo protetto | GetHeaderFilterButtonShowMode | (Ereditato da TreeList)
Metodo pubblico | GetHitInfo | Obsoleto. (Ereditato da TreeList)
Metodo protetto | GetImageIndexFromDataSource | (Ereditato da TreeList)
Metodo protetto | GetMaxIndent | (Ereditato da TreeList)
Metodo protetto | GetNativePreviewText | (Ereditato da TreeList)
Metodo pubblico | GetNodeAt(Point) | (Ereditato da TreeList)
Metodo pubblico | GetNodeAt(Int32, Int32) | (Ereditato da TreeList)
Metodo pubblico | GetNodeByVisibleIndex | (Ereditato da TreeList)
Metodo protetto | GetNodeCellRepositoryItem | (Ereditato da TreeList)
Metodo protetto | GetNodeComparer(IComparerTreeListNode) | (Ereditato da TreeList)
Metodo protetto | GetNodeComparer(TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetNodeIndex | (Ereditato da TreeList)
Metodo pubblico | GetNodeList | (Ereditato da TreeList)
Metodo protetto | GetNodeValue(TreeListNode, TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | GetNodeValue(TreeListNode, Object) | (Ereditato da TreeList)
Metodo protetto | GetNodeValue(TreeListNode, String) | (Ereditato da TreeList)
Metodo protetto | GetNonFormattedCaption | (Ereditato da TreeList)
Metodo protetto | GetParentColumnFieldNameSort | (Ereditato da TreeList)
Metodo pubblico | GetRow | (Ereditato da TreeList)
Metodo pubblico | GetRowCellDisplayText(TreeListNode, TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetRowCellDisplayText(TreeListNode, String) | (Ereditato da TreeList)
Metodo pubblico | GetRowCellValue(TreeListNode, TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetRowCellValue(TreeListNode, String) | (Ereditato da TreeList)
Metodo protetto | GetRowsAsFootersCount | (Ereditato da TreeList)
Metodo pubblico | GetScrollAnnotations | (Ereditato da TreeList)
Metodo pubblico | GetSelectedCells | (Ereditato da TreeList)
Metodo pubblico | GetSelectedCells(TreeListNode) | (Ereditato da TreeList)
Metodo protetto | GetShowBandsMode | (Ereditato da TreeList)
Metodo protetto | GetShowFirstLines | (Ereditato da TreeList)
Metodo protetto | GetShowIndentAsRowStyle | (Ereditato da TreeList)
Metodo pubblico | GetSortColumn(Int32) | (Ereditato da TreeList)
Metodo protetto | GetSortColumn(TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetSummaryValue(TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetSummaryValue(TreeListColumn, Boolean) | (Ereditato da TreeList)
Metodo protetto | GetSummaryValueCore | (Ereditato da TreeList)
Metodo protetto | GetSummaryValueEx | (Ereditato da TreeList)
Metodo pubblico | GetToolTipController | (Ereditato da EditorContainer)
Metodo protetto | GetUseDirectXPaint | (Ereditato da TreeList)
Metodo pubblico | GetVisibleIndexByNode | (Ereditato da TreeList)
Metodo protetto | GetVisibleIndexByNodeCore | (Ereditato da TreeList)
Metodo protetto | GetVisibleParentNodesCount | (Ereditato da TreeList)
Metodo pubblico | HideCustomization | (Ereditato da TreeList)
Metodo pubblico | HideEditor | (Ereditato da TreeList)
Metodo protetto | HideEditorCore | (Ereditato da TreeList)
Metodo pubblico | HideFindPanel | (Ereditato da TreeList)
Metodo pubblico | HideLoadingPanel | (Ereditato da TreeList)
Metodo protetto | HookOnLoaded | (Ereditato da EditorContainer)
Metodo pubblico | ImportFromXml(Stream) | (Ereditato da TreeList)
Metodo pubblico | ImportFromXml(String) | (Ereditato da TreeList)
Metodo protetto | ImportFromXmlCore | (Ereditato da TreeList)
Metodo pubblico | IndentNodes | (Ereditato da TreeList)
Metodo protetto | InitFindPanel | (Ereditato da TreeList)
Metodo protetto | InitializeDirectXProvider | (Ereditato da EditorContainer)
Metodo protetto | InitScrollInfo | (Ereditato da TreeList)
Metodo protetto | InternalDeleteNode | (Ereditato da TreeList)
Metodo protetto | InternalDeleteNodeCore | (Ereditato da TreeList)
Metodo protetto | InternalDeleteNodes(DictionaryTreeListNodes, ListTreeListNode) | (Ereditato da TreeList)
Metodo protetto | InternalDeleteNodes(TreeListNodes) | (Ereditato da TreeList)
Metodo protetto | InternalFullCollapseNode | (Ereditato da TreeList)
Metodo protetto | InternalFullExpandNode | (Ereditato da TreeList)
Metodo protetto | InternalGetCustomNodeCellEdit | (Ereditato da TreeList)
Metodo protetto | InternalGetCustomNodeCellStyle | (Ereditato da TreeList)
Metodo pubblico | InternalGetService | (Ereditato da TreeList)
Metodo protetto | InternalNodeAdded | (Ereditato da TreeList)
Metodo protetto | InternalNodeChanged | (Ereditato da TreeList)
Metodo protetto | InternalSetTopVisibleNodePixel | (Ereditato da TreeList)
Metodo pubblico | InvalidateBand | (Ereditato da TreeList)
Metodo pubblico | InvalidateBandPanel | (Ereditato da TreeList)
Metodo pubblico | InvalidateCell | (Ereditato da TreeList)
Metodo pubblico | InvalidateColumnHeader | (Ereditato da TreeList)
Metodo pubblico | InvalidateColumnPanel | (Ereditato da TreeList)
Metodo pubblico | InvalidateFilterPanel | (Ereditato da TreeList)
Metodo pubblico | InvalidateNode | (Ereditato da TreeList)
Metodo pubblico | InvalidateNodes | (Ereditato da TreeList)
Metodo pubblico | InvalidateRow | (Ereditato da TreeList)
Metodo pubblico | InvalidateRowPreview | (Ereditato da TreeList)
Metodo protetto | InvalidateRows | (Ereditato da TreeList)
Metodo pubblico | InvalidateScrollAnnotations | (Ereditato da TreeList)
Metodo pubblico | InvalidateSummaryFooterPanel | (Ereditato da TreeList)
Metodo pubblico | InvokeMenuItemClick | (Ereditato da TreeList)
Metodo protetto | IsAllowDefaultFastBestFit | (Ereditato da TreeList)
Metodo protetto | IsAllowEditForm | (Ereditato da TreeList)
Metodo pubblico | IsAutoFilterNode | (Ereditato da TreeList)
Metodo pubblico | IsCellSelected | (Ereditato da TreeList)
Metodo protetto | IsColumnAllowAutoFilter | (Ereditato da TreeList)
Metodo protetto | IsColumnAllowFilter | (Ereditato da TreeList)
Metodo pubblico | IsColumnAllowFilterEditor | (Ereditato da TreeList)
Metodo protetto | IsColumnFieldNameSortExist | (Ereditato da TreeList)
Metodo protetto | IsColumnFiltered | (Ereditato da TreeList)
Metodo protetto | IsFilterByDisplayText | (Ereditato da TreeList)
Metodo protetto | IsFilterRow | (Ereditato da TreeList)
Metodo protetto | IsImplyNullLikeEmptyStringWhenFiltering | (Ereditato da TreeList)
Metodo protetto | IsInputChar | (Ereditato da TreeList)
Metodo protetto | IsInputKey | (Ereditato da TreeList)
Metodo pubblico | IsNewItemRow | (Ereditato da TreeList)
Metodo protetto | IsParentColumnFieldNameSortExist | (Ereditato da TreeList)
Metodo pubblico | IsRootNode | (Ereditato da TreeList)
Metodo protetto | IsRoundDateTime | (Ereditato da TreeList)
Metodo protetto | IsShowAllValuesInFilterPopup | (Ereditato da TreeList)
Metodo protetto | IsTopNewItemRow | (Ereditato da TreeList)
Metodo protetto | IsUserAutoFilterCondition | (Ereditato da TreeList)
Metodo pubblico | LayoutChanged | (Ereditato da TreeList)
Metodo protetto | LoadDataColumns | (Ereditato da TreeList)
Metodo protetto | LoadDataSource | (Ereditato da TreeList)
Metodo pubblico | LoadState | Ricarica lo stato
Metodo protetto | LockDirectXRendering | (Ereditato da TreeList)
Metodo protetto | LockFilteringUIClientFilterCriteriaBinding | (Ereditato da TreeList)
Metodo pubblico | LockReloadNodes | (Ereditato da TreeList)
Metodo pubblico | MakeColumnVisible | (Ereditato da TreeList)
Metodo protetto | MakeFocusedRowVisible | (Ereditato da TreeList)
Metodo pubblico | MakeNodeVisible | (Ereditato da TreeList)
Metodo protetto | MergeColumnFiltersCore | (Ereditato da TreeList)
Metodo pubblico | MoveFirst | (Ereditato da TreeList)
Metodo protetto | MoveFocusedCell | (Ereditato da TreeList)
Metodo pubblico | MoveLast | (Ereditato da TreeList)
Metodo pubblico | MoveLastVisible | (Ereditato da TreeList)
Metodo pubblico | MoveNext | (Ereditato da TreeList)
Metodo pubblico | MoveNextVisible | (Ereditato da TreeList)
Metodo pubblico | MoveNode(TreeListNode, TreeListNode) | (Ereditato da TreeList)
Metodo pubblico | MoveNode(TreeListNode, TreeListNode, Boolean) | (Ereditato da TreeList)
Metodo pubblico | MoveNode(TreeListNode, TreeListNode, Boolean, Int32) | (Ereditato da TreeList)
Metodo pubblico | MoveNodes | (Ereditato da TreeList)
Metodo protetto | MoveNodesCore | (Ereditato da TreeList)
Metodo pubblico | MovePrev | (Ereditato da TreeList)
Metodo pubblico | MovePrevVisible | (Ereditato da TreeList)
Metodo pubblico | MoveToNextScrollAnnotation | (Ereditato da TreeList)
Metodo pubblico | MoveToParent | (Ereditato da TreeList)
Metodo pubblico | MoveToPrevScrollAnnotation | (Ereditato da TreeList)
Metodo protetto | NormalizeVisibleBandIndices | (Ereditato da TreeList)
Metodo protetto | NormalizeVisibleColumnIndices | (Ereditato da TreeList)
Metodo protetto | OnActiveEditor_GotFocus | (Ereditato da TreeList)
Metodo protetto | OnActiveEditor_LostFocus | (Ereditato da TreeList)
Metodo protetto | OnActiveEditor_Modified | (Ereditato da TreeList)
Metodo protetto | OnActiveEditor_ValueChanged | (Ereditato da TreeList)
Metodo protetto | OnActiveEditor_ValueChanging | (Ereditato da TreeList)
Metodo protetto | OnActiveFilterChanged | (Ereditato da TreeList)
Metodo protetto | OnActiveFilterCriteriaChanged | (Ereditato da TreeList)
Metodo protetto | OnActiveFilterEnabledChanged | (Ereditato da TreeList)
Metodo protetto | OnAfterAddingNode | (Ereditato da TreeList)
Metodo protetto | OnAfterChangeCollapsed | (Ereditato da TreeList)
Metodo protetto | OnAfterChangeExpanded | (Ereditato da TreeList)
Metodo protetto | OnAfterDeletingNodes | (Ereditato da TreeList)
Metodo protetto | OnAllowBandColumnMultiRowChanged | (Ereditato da TreeList)
Metodo protetto | OnAllowSerializationProperty | (Ereditato da TreeList)
Metodo protetto | OnAppearancePrintChanged | (Ereditato da TreeList)
Metodo protetto | OnBandChanged | (Ereditato da TreeList)
Metodo protetto | OnBandCollectionChanged | (Ereditato da TreeList)
Metodo protetto | OnBandColumnCollectionChanged | (Ereditato da TreeList)
Metodo protetto | OnBandFixedChanged | (Ereditato da TreeList)
Metodo protetto | OnBandWidthChanged | (Ereditato da TreeList)
Metodo protetto | OnBeginTouchScroll | (Ereditato da TreeList)
Metodo protetto | OnBindingContextChanged | (Ereditato da TreeList)
Metodo protetto | OnCheckBoxFieldNameChanged | (Ereditato da TreeList)
Metodo protetto | OnClearNodes | (Sovrascrive TreeList.OnClearNodes(TreeListNodes))
Metodo protetto | OnClearNodesComplete | (Ereditato da TreeList)
Metodo protetto | OnClick | (Ereditato da TreeList)
Metodo protetto | OnColumnAdded | (Ereditato da TreeList)
Metodo protetto | OnColumnChanged | (Ereditato da TreeList)
Metodo protetto | OnColumnFilterModeChanged | (Ereditato da TreeList)
Metodo protetto | OnColumnFilterRestored | (Ereditato da TreeList)
Metodo protetto | OnColumnInfosPopulated | (Ereditato da TreeList)
Metodo protetto | OnColumnRemoved | (Ereditato da TreeList)
Metodo protetto | OnColumnRowIndexChanged | (Ereditato da TreeList)
Metodo protetto | OnColumnsChanged | (Ereditato da TreeList)
Metodo protetto | OnColumnUnboundChanged | (Ereditato da TreeList)
Metodo protetto | OnColumnUnboundExpressionChanged | (Ereditato da TreeList)
Metodo protetto | OnContainerEnter | (Ereditato da EditorContainer)
Metodo protetto | OnContainerLeave | (Ereditato da EditorContainer)
Metodo protetto | OnContextMenuKey | (Ereditato da TreeList)
Metodo protetto | OnCreateControl | (Ereditato da EditorContainer)
Metodo protetto | OnDataListChanged | (Ereditato da TreeList)
Metodo protetto | OnDesignerHost_LoadComplete | (Ereditato da EditorContainer)
Metodo protetto | OnDesignerHost_TransactionClosed | (Ereditato da EditorContainer)
Metodo protetto | OnDirectXPaintDisabled | (Ereditato da TreeList)
Metodo protetto | OnDoubleClick | (Ereditato da TreeList)
Metodo protetto | OnDragDrop | (Ereditato da TreeList)
Metodo protetto | OnDragEnter | (Ereditato da TreeList)
Metodo protetto | OnDragLeave | (Ereditato da TreeList)
Metodo protetto | OnDragOver | (Ereditato da TreeList)
Metodo protetto | OnEnabledChanged | (Ereditato da TreeList)
Metodo protetto | OnEndInit | (Ereditato da EditorContainer)
Metodo protetto | OnEndSerializing | (Ereditato da TreeList)
Metodo protetto | OnEndSorting | (Ereditato da TreeList)
Metodo protetto | OnEnter | (Ereditato da EditorContainer)
Metodo protetto | OnErrorInfo_Changed | (Ereditato da TreeList)
Metodo protetto | OnFilterRowValueChanging | (Ereditato da TreeList)
Metodo protetto | OnFirstInit | (Ereditato da EditorContainer)
Metodo protetto | OnFormatConditionChanged | (Ereditato da TreeList)
Metodo protetto | OnFormatRuleExpressionEditorCreated | (Ereditato da TreeList)
Metodo protetto | OnFormatRulesCollectionChanged | (Ereditato da TreeList)
Metodo protetto | OnGotCapture | (Ereditato da EditorContainer)
Metodo protetto | OnGotFocus | (Ereditato da TreeList)
Metodo protetto | OnHandleCreated | (Ereditato da TreeList)
Metodo protetto | OnHandleDestroyed | (Ereditato da TreeList)
Metodo protetto | OnHorizontalTouchScroll | (Ereditato da TreeList)
Metodo protetto | OnHScroll | (Ereditato da TreeList)
Metodo protetto | OnItemAdded | (Ereditato da TreeList)
Metodo protetto | OnItemAdding | (Ereditato da TreeList)
Metodo protetto | OnItemChanged(Int32, PropertyDescriptor) | (Ereditato da TreeList)
Metodo protetto | OnItemChanged(Int32, PropertyDescriptor, TreeListNode) | (Ereditato da TreeList)
Metodo protetto | OnItemDeleted | (Ereditato da TreeList)
Metodo protetto | OnItemMoved | (Ereditato da TreeList)
Metodo protetto | OnKeyDown | (Ereditato da TreeList)
Metodo protetto | OnKeyPress | (Ereditato da TreeList)
Metodo protetto | OnKeyUp | (Ereditato da TreeList)
Metodo protetto | OnLeave | (Ereditato da EditorContainer)
Metodo protetto | OnLoaded | (Ereditato da TreeList)
Metodo protetto | OnLoadedCore | (Ereditato da TreeList)
Metodo protetto | OnLookAndFeelChanged(LookAndFeelChangedEventArgs) | (Ereditato da TreeList)
Metodo protetto | OnLookAndFeelChanged(Object, EventArgs) | (Ereditato da EditorContainer)
Metodo protetto | OnLostCapture | (Ereditato da TreeList)
Metodo protetto | OnLostFocus | (Ereditato da TreeList)
Metodo protetto | OnMenuShowing | (Ereditato da TreeList)
Metodo protetto | OnMouseClick | (Ereditato da EditorContainer)
Metodo protetto | OnMouseDoubleClick | (Ereditato da EditorContainer)
Metodo protetto | OnMouseDown | (Ereditato da TreeList)
Metodo protetto | OnMouseEnter | (Ereditato da TreeList)
Metodo protetto | OnMouseHWheel | (Ereditato da EditorContainer)
Metodo protetto | OnMouseLeave | (Ereditato da TreeList)
Metodo protetto | OnMouseMove | (Ereditato da TreeList)
Metodo protetto | OnMouseUp | (Ereditato da TreeList)
Metodo protetto | OnMouseWheel | (Ereditato da EditorContainer)
Metodo protetto | OnMouseWheelCore | (Ereditato da TreeList)
Metodo protetto | OnNodeCheckedChanged | (Ereditato da TreeList)
Metodo protetto | OnNodeRemoved | (Ereditato da TreeList)
Metodo protetto | OnNodesLoaded | (Ereditato da TreeList)
Metodo protetto | OnNodesLoading | (Ereditato da TreeList)
Metodo protetto | OnNodesRemoved | (Ereditato da TreeList)
Metodo protetto | OnOptionsBehaviorChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsCustomizationChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsDragAndDropChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsEditFormChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsFilterChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsFindChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsHtmlChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsNavigationChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsPrintChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsScrollAnnotationsChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsSelectionChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsViewChanged | (Ereditato da TreeList)
Metodo protetto | OnPaint | ATTENZIONE! Questo override serve per proteggere dalla X rossa del controllo in apertura dei documenti nei casi in cui il DFS è attivo. Pur non essendo consigliato abbiamo optato per questa strada in quanto ci permette di avere l'icona dello stato documentale sempre aggiornata. Vedi discussione collegata nel forum devexpress T554890. (Sovrascrive TreeList.OnPaint(PaintEventArgs))
Metodo protetto | OnPaintBackground | (Ereditato da TreeList)
Metodo protetto | OnParentChanged | (Ereditato da TreeList)
Metodo protetto | OnPressedBandChanged | (Ereditato da TreeList)
Metodo protetto | OnPrintProgress | (Ereditato da TreeList)
Metodo protetto | OnPropertyChanged | (Ereditato da TreeList)
Metodo protetto | OnPropertyDescriptorChanged | (Ereditato da TreeList)
Metodo protetto | OnQueryContinueDrag | (Ereditato da TreeList)
Metodo protetto | OnRepositoryItemRefreshRequired | (Ereditato da TreeList)
Metodo protetto | OnReset | (Ereditato da TreeList)
Metodo protetto | OnResetSerializationProperties | (Ereditato da TreeList)
Metodo protetto | OnResize | (Ereditato da TreeList)
Metodo protetto | OnRightToLeftChanged | (Ereditato da TreeList)
Metodo protetto | OnRightToLeftChanged(EventArgs) | (Ereditato da EditorContainer)
Metodo protetto | OnScaleControl | (Ereditato da TreeList)
Metodo protetto | OnScaleTreeListCore | (Ereditato da TreeList)
Metodo protetto | OnSelectionChanged | (Ereditato da TreeList)
Metodo protetto | OnSetValue | (Ereditato da TreeList)
Metodo protetto | OnSortModeChanged | (Ereditato da TreeList)
Metodo protetto | OnSourceItemChanged | (Ereditato da TreeList)
Metodo protetto | OnStartSerializing | (Ereditato da TreeList)
Metodo protetto | OnStartSorting | (Ereditato da TreeList)
Metodo protetto | OnSystemColorsChanged | (Ereditato da TreeList)
Metodo protetto | OnToolTipControllerDisposed | (Ereditato da EditorContainer)
Metodo protetto | OnTouchScroll | (Ereditato da TreeList)
Metodo protetto | OnTouchZoom | (Ereditato da TreeList)
Metodo protetto | OnValidated | (Ereditato da EditorContainer)
Metodo protetto | OnValidating | (Ereditato da TreeList)
Metodo protetto | OnVerticalTouchScroll | (Ereditato da TreeList)
Metodo protetto | OnVisibleChanged | (Ereditato da TreeList)
Metodo protetto | OnVScroll | (Ereditato da TreeList)
Metodo protetto | OnVScrollCore | (Ereditato da TreeList)
Metodo pubblico | OutdentNodes | (Ereditato da TreeList)
Metodo protetto | ParseAutoFilter | (Ereditato da TreeList)
Metodo protetto | ParseAutoFilterValues | (Ereditato da TreeList)
Metodo pubblico | PasteFromClipboard | (Ereditato da TreeList)
Metodo pubblico | PopulateColumns | (Ereditato da TreeList)
Metodo pubblico | PostEditor | (Ereditato da TreeList)
Metodo protetto | PostEditor(Boolean) | (Ereditato da TreeList)
Metodo pubblico | Print | (Ereditato da TreeList)
Metodo protetto | PrintCore | (Ereditato da TreeList)
Metodo pubblico | PrintDialog | (Ereditato da TreeList)
Metodo protetto | PrintDialogCore | (Ereditato da TreeList)
Metodo protetto | ProcessControlTab | (Ereditato da TreeList)
Metodo protetto | ProcessControlTab(Boolean) | (Ereditato da TreeList)
Metodo protetto | ProcessDialogKey | (Ereditato da TreeList)
Metodo protetto | ProcessDirectXPaint | (Ereditato da TreeList)
Metodo protetto | RaiseAfterCheckNode | (Ereditato da TreeList)
Metodo protetto | RaiseAfterCollapse | (Ereditato da TreeList)
Metodo protetto | RaiseAfterDragNode | (Ereditato da TreeList)
Metodo protetto | RaiseAfterDropNode | (Ereditato da TreeList)
Metodo protetto | RaiseAfterExpand | (Ereditato da TreeList)
Metodo protetto | RaiseAfterFocusNode | (Ereditato da TreeList)
Metodo protetto | RaiseBandPositionChanged | (Ereditato da TreeList)
Metodo protetto | RaiseBandWidthChanged | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeCheckNode | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeCollapse | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeDragNode | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeDropNode | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeExpand | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeFocusNode | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeLoadLayout | (Ereditato da TreeList)
Metodo protetto | RaiseCalcNodeDragImageIndex | (Ereditato da TreeList)
Metodo protetto | RaiseCalcNodeHeight(TreeListNode, Int32) | (Ereditato da TreeList)
Metodo protetto | RaiseCalcNodeHeight(TreeListNode, RowInfo, Int32) | (Ereditato da TreeList)
Metodo protetto | RaiseCellValueChanged | (Ereditato da TreeList)
Metodo protetto | RaiseCellValueChanging | (Ereditato da TreeList)
Metodo protetto | RaiseCheckedColumnFilterPopupEvent | (Ereditato da TreeList)
Metodo protetto | RaiseClipboardNodeCopying | (Ereditato da TreeList)
Metodo protetto | RaiseClipboardNodePasting | (Ereditato da TreeList)
Metodo protetto | RaiseColumnButtonClick | (Ereditato da TreeList)
Metodo protetto | RaiseColumnChanged | (Ereditato da TreeList)
Metodo protetto | RaiseColumnFilterChanged | (Ereditato da TreeList)
Metodo protetto | RaiseColumnFilterPopupEvent | (Ereditato da TreeList)
Metodo protetto | RaiseColumnPositionChanged | (Ereditato da TreeList)
Metodo protetto | RaiseColumnUnboundExpressionChanged | (Ereditato da TreeList)
Metodo protetto | RaiseColumnWidthChanged | (Ereditato da TreeList)
Metodo protetto | RaiseCompareNodeValues | (Ereditato da TreeList)
Metodo protetto | RaiseCreateCustomNode | (Ereditato da TreeList)
Metodo protetto | RaiseCustomColumnDisplayText(CustomColumnDisplayTextEventArgs) | (Ereditato da TreeList)
Metodo protetto | RaiseCustomColumnDisplayText(TreeListNode, CellInfo) | (Ereditato da TreeList)
Metodo protetto | RaiseCustomColumnDisplayText(TreeListNode, TreeListColumn, BaseEditViewInfo) | (Ereditato da TreeList)
Metodo protetto | RaiseCustomColumnDisplayText(TreeListNode, TreeListColumn, Object, String) | (Ereditato da TreeList)
Metodo protetto | RaiseCustomColumnSort | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawBandHeader | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawColumnHeader | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawEmptyArea | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawFilterPanel | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawFooter | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawFooterCell | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodeButton | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodeCell | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodeCheckBox | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodeImages | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodeIndent | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodeIndicator | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodePreview | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawRow | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawRowFooter | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawRowFooterCell | (Ereditato da TreeList)
Metodo protetto | RaiseCustomFilterDisplayText | (Ereditato da TreeList)
Metodo protetto | RaiseCustomizationFormSearch | (Ereditato da TreeList)
Metodo protetto | RaiseCustomizeNewNodeFromOuterData | (Ereditato da TreeList)
Metodo protetto | RaiseCustomRowFilter | (Ereditato da TreeList)
Metodo protetto | RaiseCustomRowFilterEvent | (Ereditato da TreeList)
Metodo protetto | RaiseCustomUnboundColumnData | (Ereditato da TreeList)
Metodo protetto | RaiseDataSourceChanged | (Ereditato da TreeList)
Metodo protetto | RaiseDefaultPaintHelperChanged | (Ereditato da TreeList)
Metodo protetto | RaiseDragCancelNode | (Ereditato da TreeList)
Metodo protetto | RaiseDragObjectDrop | (Ereditato da TreeList)
Metodo protetto | RaiseDragObjectOver | (Ereditato da TreeList)
Metodo protetto | RaiseDragObjectStart | (Ereditato da TreeList)
Metodo protetto | RaiseEditFormHidden | (Ereditato da TreeList)
Metodo protetto | RaiseEditFormPrepared | (Ereditato da TreeList)
Metodo protetto | RaiseEditFormShowing | (Ereditato da TreeList)
Metodo protetto | RaiseEditorKeyDown | (Ereditato da TreeList)
Metodo protetto | RaiseEditorKeyPress | (Ereditato da EditorContainer)
Metodo protetto | RaiseEditorKeyUp | (Ereditato da EditorContainer)
Metodo protetto | RaiseEndSorting | (Ereditato da TreeList)
Metodo protetto | RaiseExcelColumnFilterPopupEvent | (Ereditato da TreeList)
Metodo protetto | RaiseFilterEditorCreated | (Ereditato da TreeList)
Metodo protetto | RaiseFilterExpressionEditorCreated | (Ereditato da TreeList)
Metodo protetto | RaiseFilterNodeEvent | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupDate | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelCustomizeTemplate | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelData(FilterPopupExcelDataEventArgs) | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelData(TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelData(TreeListColumn, CriteriaOperator) | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelData(TreeListColumn, TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelParseFilterCriteria | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelPrepareTemplate | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelQueryFilterCriteria | (Ereditato da TreeList)
Metodo protetto | RaiseFocusedColumnChanged | (Ereditato da TreeList)
Metodo protetto | RaiseFocusedNodeChanged | (Ereditato da TreeList)
Metodo protetto | RaiseGetCustomAnnotations | (Ereditato da TreeList)
Metodo protetto | RaiseGetCustomNodeCellEdit | (Ereditato da TreeList)
Metodo protetto | RaiseGetCustomNodeCellStyle | (Ereditato da TreeList)
Metodo protetto | RaiseGetCustomSummaryValue | (Ereditato da TreeList)
Metodo protetto | RaiseGetNodeDisplayValue | (Ereditato da TreeList)
Metodo protetto | RaiseGetPreviewText | (Ereditato da TreeList)
Metodo protetto | RaiseGetPrintCustomSummaryValue | (Ereditato da TreeList)
Metodo protetto | RaiseGetPrintPreviewText | (Ereditato da TreeList)
Metodo protetto | RaiseGetSelectImage | (Ereditato da TreeList)
Metodo protetto | RaiseGetStateImage | (Ereditato da TreeList)
Metodo protetto | RaiseHiddenEditor | (Ereditato da TreeList)
Metodo protetto | RaiseHideCustomizationForm | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementBlur | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementFocus | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseClick | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseDoubleClick | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseDown | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseMove | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseOut | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseOver | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseUp | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlSelectedTextChanged | (Ereditato da TreeList)
Metodo protetto | RaiseInitNewRow | (Ereditato da TreeList)
Metodo protetto | RaiseInvalidNodeException | (Ereditato da TreeList)
Metodo protetto | RaiseInvalidValueException | (Ereditato da TreeList)
Metodo protetto | RaiseLayoutUpdated | (Ereditato da TreeList)
Metodo protetto | RaiseLayoutUpgrade | (Ereditato da TreeList)
Metodo protetto | RaiseLeftCoordChanged | (Ereditato da TreeList)
Metodo protetto | RaiseLoad | (Ereditato da TreeList)
Metodo protetto | RaiseMeasurePreviewHeight | (Ereditato da TreeList)
Metodo protetto | RaiseNodeChanged | (Ereditato da TreeList)
Metodo protetto | RaiseNodesReloaded | (Ereditato da TreeList)
Metodo protetto | RaisePaintEx | (Ereditato da TreeList)
Metodo protetto | RaiseParseFindPanelText | (Ereditato da TreeList)
Metodo protetto | RaisePopupMenuShowing | (Ereditato da TreeList)
Metodo protetto | RaisePrintExportProgress | (Ereditato da TreeList)
Metodo protetto | RaiseQueryCustomFunctions | (Ereditato da TreeList)
Metodo protetto | RaiseRequireHideEditor | (Ereditato da EditorContainer)
Metodo protetto | RaiseRowCellClick | (Ereditato da TreeList)
Metodo protetto | RaiseRowClick | (Ereditato da TreeList)
Metodo protetto | RaiseRowSelectImageClick | (Ereditato da TreeList)
Metodo protetto | RaiseRowStateImageClick | (Ereditato da TreeList)
Metodo protetto | RaiseSelectImageClick | (Ereditato da TreeList)
Metodo protetto | RaiseSelectionChanged | (Ereditato da TreeList)
Metodo protetto | RaiseSelectionChanging | (Ereditato da TreeList)
Metodo protetto | RaiseShowCustomizationForm | (Ereditato da TreeList)
Metodo protetto | RaiseShowingEditor | (Ereditato da TreeList)
Metodo protetto | RaiseShownEditor | (Ereditato da TreeList)
Metodo protetto | RaiseShowTreeListMenu | Obsoleto. (Ereditato da TreeList)
Metodo protetto | RaiseStartSorting | (Ereditato da TreeList)
Metodo protetto | RaiseStateChanged | (Ereditato da TreeList)
Metodo protetto | RaiseStateImageClick | (Ereditato da TreeList)
Metodo protetto | RaiseSubstituteFilter | (Ereditato da TreeList)
Metodo protetto | RaiseTopVisibleNodeIndexChanged | (Ereditato da TreeList)
Metodo protetto | RaiseTreeListMenuItemClick | (Ereditato da TreeList)
Metodo protetto | RaiseUnboundExpressionEditorCreated | (Ereditato da TreeList)
Metodo protetto | RaiseValidateNode | (Ereditato da TreeList)
Metodo protetto | RaiseValidatingEditor | (Ereditato da TreeList)
Metodo protetto | RecalcSortColumns | (Ereditato da TreeList)
Metodo protetto | RecreateRowsInfoCore | (Ereditato da TreeList)
Metodo pubblico | Refresh | (Ereditato da TreeList)
Metodo pubblico | Refresh(Boolean) | (Ereditato da TreeList)
Metodo pubblico | RefreshCell | (Ereditato da TreeList)
Metodo protetto | RefreshCellCore | (Ereditato da TreeList)
Metodo protetto | RefreshColumnsInfo | (Ereditato da TreeList)
Metodo pubblico | RefreshDataSource | (Ereditato da TreeList)
Metodo pubblico | RefreshEditor | (Ereditato da TreeList)
Metodo protetto | RefreshEditorError | (Ereditato da TreeList)
Metodo protetto | RefreshHeadersInfo | (Ereditato da TreeList)
Metodo protetto | RefreshHtmlNodeCore | (Ereditato da TreeList)
Metodo pubblico | RefreshNode | (Ereditato da TreeList)
Metodo protetto | RefreshNodeCore | (Ereditato da TreeList)
Metodo protetto | RefreshRowsInfo | (Ereditato da TreeList)
Metodo protetto | RefreshRowsInfo(Boolean, Boolean) | (Ereditato da TreeList)
Metodo pubblico | RefreshScrollAnnotations(ScrollAnnotationKind) | (Ereditato da TreeList)
Metodo pubblico | RefreshScrollAnnotations(ScrollAnnotationKind, Int32) | (Ereditato da TreeList)
Metodo protetto | RefreshVirtualCellCore | (Ereditato da TreeList)
Metodo protetto | RefreshVirtualNodeCore | (Ereditato da TreeList)
Metodo protetto | RejectCurrentChanges | (Ereditato da TreeList)
Metodo protetto | RemoveFromDefaultTooltipController | (Ereditato da EditorContainer)
Metodo protetto | RemoveHookOnLoaded | (Ereditato da EditorContainer)
Metodo protetto | RemoveNodeHeight | (Ereditato da TreeList)
Metodo protetto | RequestCellEditor | (Ereditato da TreeList)
Metodo protetto | ResetAccessibility | (Ereditato da TreeList)
Metodo pubblico | ResetAutoFilterCondition | (Ereditato da TreeList)
Metodo pubblico | ResetAutoFilterConditions | (Ereditato da TreeList)
Metodo pubblico | ResetAutoFilterConditions(IEnumerableTreeListColumn) | (Ereditato da TreeList)
Metodo protetto | ResetAutoFilterConditionsCore | (Ereditato da TreeList)
Metodo protetto | ResetColumnAutoFilterConditions | (Ereditato da TreeList)
Metodo pubblico | ResetEditorsCache(RepositoryItem) | (Ereditato da EditorContainer)
Metodo pubblico | ResetEditorsCache(Type) | (Ereditato da EditorContainer)
Metodo protetto | ResetExcelFilteringProvider | (Ereditato da TreeList)
Metodo protetto | ResetLookAndFeel | (Ereditato da EditorContainer)
Metodo protetto | ResetRowCount | (Ereditato da TreeList)
Metodo protetto | ResetSortedColumns | (Ereditato da TreeList)
Metodo protetto | ResizeBand | (Ereditato da TreeList)
Metodo protetto | ResizeColumn | (Ereditato da TreeList)
Metodo protetto | ResolveAutoFilterCondition | (Ereditato da TreeList)
Metodo protetto | RestoreLayoutCore | (Ereditato da TreeList)
Metodo pubblico | RestoreLayoutFromRegistry(String) | (Ereditato da TreeList)
Metodo pubblico | RestoreLayoutFromRegistry(String, OptionsLayoutBase) | (Ereditato da TreeList)
Metodo pubblico | RestoreLayoutFromStream(Stream) | (Ereditato da TreeList)
Metodo pubblico | RestoreLayoutFromStream(Stream, OptionsLayoutBase) | (Ereditato da TreeList)
Metodo pubblico | RestoreLayoutFromXml(String) | (Ereditato da TreeList)
Metodo pubblico | RestoreLayoutFromXml(String, OptionsLayoutBase) | (Ereditato da TreeList)
Metodo protetto | RestoreNodesData | (Ereditato da TreeList)
Metodo protetto | SaveLayoutCore | (Ereditato da TreeList)
Metodo pubblico | SaveLayoutToRegistry(String) | (Ereditato da TreeList)
Metodo pubblico | SaveLayoutToRegistry(String, OptionsLayoutBase) | (Ereditato da TreeList)
Metodo pubblico | SaveLayoutToStream(Stream) | (Ereditato da TreeList)
Metodo pubblico | SaveLayoutToStream(Stream, OptionsLayoutBase) | (Ereditato da TreeList)
Metodo pubblico | SaveLayoutToXml(String) | (Ereditato da TreeList)
Metodo pubblico | SaveLayoutToXml(String, OptionsLayoutBase) | (Ereditato da TreeList)
Metodo protetto | SaveNodesData | (Ereditato da TreeList)
Metodo pubblico | SaveState | Salva lo stato
Metodo protetto | ScaleControl | (Ereditato da EditorContainer)
Metodo protetto | Scrollbar_MouseEnter | (Ereditato da TreeList)
Metodo protetto | Scrollbar_MouseLeave | (Ereditato da TreeList)
Metodo protetto | ScrollHorizontalEx | (Ereditato da TreeList)
Metodo protetto | ScrollVerticalEx | (Ereditato da TreeList)
Metodo pubblico | SelectAll | (Ereditato da TreeList)
Metodo pubblico | SelectCell | (Ereditato da TreeList)
Metodo protetto | SelectCellCore | (Ereditato da TreeList)
Metodo pubblico | SelectCells(Int32, String, Int32, String) | (Ereditato da TreeList)
Metodo pubblico | SelectCells(TreeListNode, TreeListColumn, TreeListNode, TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | SelectNode | (Ereditato da TreeList)
Metodo protetto | SelectNodeCore | (Ereditato da TreeList)
Metodo pubblico | SelectNodes(Int32, Int32) | (Ereditato da TreeList)
Metodo pubblico | SelectNodes(TreeListNode, TreeListNode) | (Ereditato da TreeList)
Metodo protetto | SelectNodesCore | (Ereditato da TreeList)
Metodo protetto | ServiceColumnChanged | (Ereditato da TreeList)
Metodo pubblico | SetAutoFilterValue | (Ereditato da TreeList)
Metodo protetto | SetCellSelection | (Ereditato da TreeList)
Metodo protetto | SetCellSelectionCore | (Ereditato da TreeList)
Metodo pubblico | SetColumnError(TreeListColumn, String) | (Ereditato da TreeList)
Metodo pubblico | SetColumnError(TreeListColumn, String, ErrorType) | (Ereditato da TreeList)
Metodo protetto | SetColumnFixedStyle | (Ereditato da TreeList)
Metodo pubblico | SetColumnPosition | (Ereditato da TreeList)
Metodo protetto | SetColumnVisibleIndex | (Ereditato da TreeList)
Metodo pubblico | SetDefaultBehaviorOptions | (Ereditato da TreeList)
Metodo pubblico | SetDefaultCustomizationOptions | (Ereditato da TreeList)
Metodo pubblico | SetDefaultNavigationOptions | (Ereditato da TreeList)
Metodo pubblico | SetDefaultOptionsView | (Ereditato da TreeList)
Metodo pubblico | SetDefaultPrintOptions | (Ereditato da TreeList)
Metodo pubblico | SetDefaultRowHeight | (Ereditato da TreeList)
Metodo pubblico | SetDefaultSelectionOptions | (Ereditato da TreeList)
Metodo protetto | SetExtraFilter | (Ereditato da TreeList)
Metodo protetto | SetFilterRowValue(Object, Object) | (Ereditato da TreeList)
Metodo protetto | SetFilterRowValue(TreeListColumn, Object) | (Ereditato da TreeList)
Metodo pubblico | SetFocusedNode | (Ereditato da TreeList)
Metodo protetto | SetFocusedNodeCore | (Ereditato da TreeList)
Metodo pubblico | SetFocusedRowCellValue(String, Object) | (Ereditato da TreeList)
Metodo pubblico | SetFocusedRowCellValue(TreeListColumn, Object) | (Ereditato da TreeList)
Metodo protetto | SetFocusedRowIndexCore | (Ereditato da TreeList)
Metodo pubblico | SetFocusedValue | (Ereditato da TreeList)
Metodo pubblico | SetNodeCheckState(TreeListNode, CheckState) | (Ereditato da TreeList)
Metodo pubblico | SetNodeCheckState(TreeListNode, CheckState, Boolean) | (Ereditato da TreeList)
Metodo pubblico | SetNodeIndex | (Ereditato da TreeList)
Metodo protetto | SetNodeIndexCore | (Ereditato da TreeList)
Metodo protetto | SetNodeValue | (Ereditato da TreeList)
Metodo pubblico | SetRowCellValue(TreeListNode, TreeListColumn, Object) | (Ereditato da TreeList)
Metodo pubblico | SetRowCellValue(TreeListNode, String, Object) | (Ereditato da TreeList)
Metodo pubblico | SetSearchControl | (Ereditato da TreeList)
Metodo pubblico | SetSelectionAnchor | (Ereditato da TreeList)
Metodo protetto | SetUseDirectXPaint | (Ereditato da TreeList)
Metodo protetto | ShouldResortNodesOnItemChanged | (Ereditato da TreeList)
Metodo protetto | ShouldSerializeLookAndFeel | (Ereditato da EditorContainer)
Metodo pubblico | ShowAutoFilterConditionsMenu | (Ereditato da TreeList)
Metodo pubblico | ShowContextMenu | (Ereditato da TreeList)
Metodo pubblico | ShowCustomization | (Ereditato da TreeList)
Metodo pubblico | ShowCustomization(Point) | (Ereditato da TreeList)
Metodo pubblico | ShowEditForm | (Ereditato da TreeList)
Metodo protetto | ShowEditFormCore | (Ereditato da TreeList)
Metodo protetto | ShowEditFormDialogCore | (Ereditato da TreeList)
Metodo pubblico | ShowEditor | (Ereditato da TreeList)
Metodo pubblico | ShowEditor(String) | (Ereditato da TreeList)
Metodo pubblico | ShowFilterEditor | (Ereditato da TreeList)
Metodo protetto | ShowFilterExpressionEditor | (Ereditato da TreeList)
Metodo pubblico | ShowFilterPopup | (Ereditato da TreeList)
Metodo pubblico | ShowFindPanel | (Ereditato da TreeList)
Metodo pubblico | ShowLoadingPanel | (Ereditato da TreeList)
Metodo protetto | ShowMenu | (Ereditato da TreeList)
Metodo protetto | ShowMRUFilterPopup | (Ereditato da TreeList)
Metodo pubblico | ShowPrintPreview | (Ereditato da TreeList)
Metodo protetto | ShowPrintPreviewCore | (Ereditato da TreeList)
Metodo protetto | ShowProgressForm | (Ereditato da TreeList)
Metodo pubblico | ShowRibbonPrintPreview | (Ereditato da TreeList)
Metodo protetto | ShowRibbonPrintPreviewCore | (Ereditato da TreeList)
Metodo pubblico | ShowUnboundExpressionEditor | (Ereditato da TreeList)
Metodo pubblico | Sort(TreeListNode, IComparerTreeListNode, Boolean) | (Ereditato da TreeList)
Metodo protetto | Sort(TreeListNodes, Boolean, Boolean) | (Ereditato da TreeList)
Metodo pubblico | Sort(TreeListNode, TreeListColumn, SortOrder, Boolean) | (Ereditato da TreeList)
Metodo pubblico | StartIncrementalSearch | (Ereditato da TreeList)
Metodo protetto | StartOfficeScrolling | (Ereditato da TreeList)
Metodo pubblico | StopIncrementalSearch | (Ereditato da TreeList)
Metodo protetto | StopOfficeScrolling | (Ereditato da TreeList)
Metodo pubblico | UncheckAll | (Ereditato da TreeList)
Metodo protetto | UnlockDirectXRendering | (Ereditato da TreeList)
Metodo pubblico | UnlockReloadNodes | (Ereditato da TreeList)
Metodo pubblico | UnselectCell | (Ereditato da TreeList)
Metodo protetto | UnselectCellCore | (Ereditato da TreeList)
Metodo pubblico | UnselectCells(Int32, String, Int32, String) | (Ereditato da TreeList)
Metodo pubblico | UnselectCells(TreeListNode, TreeListColumn, TreeListNode, TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | UnselectNode | (Ereditato da TreeList)
Metodo pubblico | UnselectNodes(Int32, Int32) | (Ereditato da TreeList)
Metodo pubblico | UnselectNodes(TreeListNode, TreeListNode) | (Ereditato da TreeList)
Metodo protetto | UpdateActiveFilterInfo | (Ereditato da TreeList)
Metodo protetto | UpdateAutoFilterRowActiveEditor | (Ereditato da TreeList)
Metodo protetto | UpdateBandColumnsIndices | (Ereditato da TreeList)
Metodo protetto | UpdateBandColumnsOrder | (Ereditato da TreeList)
Metodo protetto | UpdateColumnAutoFilter | (Ereditato da TreeList)
Metodo protetto | UpdateColumnsSortIndices | (Ereditato da TreeList)
Metodo protetto | UpdateElementsLookAndFeel | (Ereditato da TreeList)
Metodo protetto | UpdateFilter | (Ereditato da TreeList)
Metodo protetto | UpdateFilterInfo | (Ereditato da TreeList)
Metodo protetto | UpdateFindPanelFilterText | (Ereditato da TreeList)
Metodo protetto | UpdateLayout | (Ereditato da TreeList)
Metodo protetto | UpdateRootBands | (Ereditato da TreeList)
Metodo protetto | UpdateSelectCell | (Ereditato da TreeList)
Metodo protetto | UpdateSelectCell(TreeListNode, TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | UpdateSelectNode | (Ereditato da TreeList)
Metodo protetto | UpdateSelectNode(TreeListNode) | (Ereditato da TreeList)
Metodo protetto | UpdateVScrollBarCore | (Ereditato da TreeList)
Metodo protetto | ValidateAndEndCurrentEdit | (Ereditato da TreeList)
Metodo protetto | WndProc | (Ereditato da TreeList)
Metodo protetto | XtraClearColumns | (Ereditato da TreeList)
Metodo protetto | XtraCreateColumnsItem | (Ereditato da TreeList)
Metodo protetto | XtraFindColumnsItem | (Ereditato da TreeList)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | AfterCheckNode | (Ereditato da TreeList)
Evento pubblico | AfterCollapse | (Ereditato da TreeList)
Evento pubblico | AfterDragNode | (Ereditato da TreeList)
Evento pubblico | AfterDropNode | (Ereditato da TreeList)
Evento pubblico | AfterExpand | (Ereditato da TreeList)
Evento pubblico | AfterFocusNode | (Ereditato da TreeList)
Evento pubblico | BandPositionChanged | (Ereditato da TreeList)
Evento pubblico | BandWidthChanged | (Ereditato da TreeList)
Evento pubblico | BeforeCheckNode | (Ereditato da TreeList)
Evento pubblico | BeforeCollapse | (Ereditato da TreeList)
Evento pubblico | BeforeDragNode | (Ereditato da TreeList)
Evento pubblico | BeforeDropNode | (Ereditato da TreeList)
Evento pubblico | BeforeExpand | (Ereditato da TreeList)
Evento pubblico | BeforeFocusNode | (Ereditato da TreeList)
Evento pubblico | BeforeLoadLayout | (Ereditato da TreeList)
Evento pubblico | CalcNodeDragImageIndex | (Ereditato da TreeList)
Evento pubblico | CalcNodeHeight | (Ereditato da TreeList)
Evento pubblico | CellValueChanged | (Ereditato da TreeList)
Evento pubblico | CellValueChanging | (Ereditato da TreeList)
Evento pubblico | ClipboardNodeCopying | (Ereditato da TreeList)
Evento pubblico | ClipboardNodePasting | (Ereditato da TreeList)
Evento pubblico | ColumnButtonClick | (Ereditato da TreeList)
Evento pubblico | ColumnChanged | (Ereditato da TreeList)
Evento pubblico | ColumnFilterChanged | (Ereditato da TreeList)
Evento pubblico | ColumnPositionChanged | (Ereditato da TreeList)
Evento pubblico | ColumnUnboundExpressionChanged | (Ereditato da TreeList)
Evento pubblico | ColumnWidthChanged | (Ereditato da TreeList)
Evento pubblico | CompareNodeValues | (Ereditato da TreeList)
Evento pubblico | CreateCustomNode | (Ereditato da TreeList)
Evento pubblico | CustomColumnDisplayText | (Ereditato da TreeList)
Evento pubblico | CustomColumnSort | (Ereditato da TreeList)
Evento pubblico | CustomDrawBandHeader | (Ereditato da TreeList)
Evento pubblico | CustomDrawColumnHeader | (Ereditato da TreeList)
Evento pubblico | CustomDrawEmptyArea | (Ereditato da TreeList)
Evento pubblico | CustomDrawFilterPanel | (Ereditato da TreeList)
Evento pubblico | CustomDrawFooter | (Ereditato da TreeList)
Evento pubblico | CustomDrawFooterCell | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodeButton | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodeCell | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodeCheckBox | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodeImages | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodeIndent | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodeIndicator | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodePreview | (Ereditato da TreeList)
Evento pubblico | CustomDrawRow | (Ereditato da TreeList)
Evento pubblico | CustomDrawRowFooter | (Ereditato da TreeList)
Evento pubblico | CustomDrawRowFooterCell | (Ereditato da TreeList)
Evento pubblico | CustomDrawScroll | (Ereditato da TreeList)
Evento pubblico | CustomFilterDisplayText | (Ereditato da TreeList)
Evento pubblico | CustomizationFormSearch | (Ereditato da TreeList)
Evento pubblico | CustomizeNewNodeFromOuterData | (Ereditato da TreeList)
Evento pubblico | CustomizeNodeTemplate | (Ereditato da TreeList)
Evento pubblico | CustomNodeCellEdit | (Ereditato da TreeList)
Evento pubblico | CustomNodeCellEditForEditing | (Ereditato da TreeList)
Evento pubblico | CustomRowFilter | (Ereditato da TreeList)
Evento pubblico | CustomScrollAnnotation | (Ereditato da TreeList)
Evento pubblico | CustomUnboundColumnData | (Ereditato da TreeList)
Evento pubblico | DataSourceChanged | (Ereditato da TreeList)
Evento pubblico | DefaultPaintHelperChanged | (Ereditato da TreeList)
Evento pubblico | DragCancelNode | (Ereditato da TreeList)
Evento pubblico | DragObjectDrop | (Ereditato da TreeList)
Evento pubblico | DragObjectOver | (Ereditato da TreeList)
Evento pubblico | DragObjectStart | (Ereditato da TreeList)
Evento pubblico | EditFormHidden | (Ereditato da TreeList)
Evento pubblico | EditFormPrepared | (Ereditato da TreeList)
Evento pubblico | EditFormShowing | (Ereditato da TreeList)
Evento pubblico | EditorKeyDown | (Ereditato da EditorContainer)
Evento pubblico | EditorKeyPress | (Ereditato da EditorContainer)
Evento pubblico | EditorKeyUp | (Ereditato da EditorContainer)
Evento pubblico | EndSorting | (Ereditato da TreeList)
Evento pubblico | FilterEditorCreated | (Ereditato da TreeList)
Evento pubblico | FilterExpressionEditorCreated | (Ereditato da TreeList)
Evento pubblico | FilterNode | (Ereditato da TreeList)
Evento pubblico | FilterPopupExcelCustomizeTemplate | (Ereditato da TreeList)
Evento pubblico | FilterPopupExcelData | (Ereditato da TreeList)
Evento pubblico | FilterPopupExcelParseFilterCriteria | (Ereditato da TreeList)
Evento pubblico | FilterPopupExcelPrepareTemplate | (Ereditato da TreeList)
Evento pubblico | FilterPopupExcelQueryFilterCriteria | (Ereditato da TreeList)
Evento pubblico | FocusedColumnChanged | (Ereditato da TreeList)
Evento pubblico | FocusedNodeChanged | (Ereditato da TreeList)
Evento pubblico | FormatRuleExpressionEditorCreated | (Ereditato da TreeList)
Evento pubblico | GetCustomNodeCellEdit | Obsoleto. (Ereditato da TreeList)
Evento pubblico | GetCustomNodeCellStyle | Obsoleto. (Ereditato da TreeList)
Evento pubblico | GetCustomSummaryValue | (Ereditato da TreeList)
Evento pubblico | GetNodeDisplayValue | (Ereditato da TreeList)
Evento pubblico | GetPreviewText | (Ereditato da TreeList)
Evento pubblico | GetPrintCustomSummaryValue | (Ereditato da TreeList)
Evento pubblico | GetPrintPreviewText | (Ereditato da TreeList)
Evento pubblico | GetSelectImage | (Ereditato da TreeList)
Evento pubblico | GetStateImage | (Ereditato da TreeList)
Evento pubblico | HiddenEditor | (Ereditato da TreeList)
Evento pubblico | HideCustomizationForm | (Ereditato da TreeList)
Evento pubblico | HtmlElementBlur | (Ereditato da TreeList)
Evento pubblico | HtmlElementFocus | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseClick | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseDoubleClick | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseDown | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseMove | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseOut | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseOver | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseUp | (Ereditato da TreeList)
Evento pubblico | HtmlSelectedTextChanged | (Ereditato da TreeList)
Evento pubblico | HyperlinkClick | (Ereditato da TreeList)
Evento pubblico | InitNewRow | (Ereditato da TreeList)
Evento pubblico | InvalidNodeException | (Ereditato da TreeList)
Evento pubblico | InvalidValueException | (Ereditato da TreeList)
Evento pubblico | LayoutUpdated | (Ereditato da TreeList)
Evento pubblico | LayoutUpgrade | (Ereditato da TreeList)
Evento pubblico | LeftCoordChanged | (Ereditato da TreeList)
Evento pubblico | Load | (Ereditato da TreeList)
Evento pubblico | MeasurePreviewHeight | (Ereditato da TreeList)
Evento pubblico | NodeCellStyle | (Ereditato da TreeList)
Evento pubblico | NodeChanged | (Ereditato da TreeList)
Evento pubblico | NodesReloaded | (Ereditato da TreeList)
Evento pubblico | PaintEx | (Ereditato da TreeList)
Evento pubblico | ParseFindPanelText | (Ereditato da TreeList)
Evento pubblico | PopupMenuShowing | (Ereditato da TreeList)
Evento pubblico | PrintExportProgress | (Ereditato da TreeList)
Evento pubblico | PropertyDeserializing | (Ereditato da TreeList)
Evento pubblico | PropertySerializing | (Ereditato da TreeList)
Evento pubblico | QueryCustomFunctions | (Ereditato da TreeList)
Evento pubblico | QueryEmptyTreeTemplate | (Ereditato da TreeList)
Evento pubblico | QueryNodeTemplate | (Ereditato da TreeList)
Evento pubblico | RowCellClick | (Ereditato da TreeList)
Evento pubblico | RowClick | (Ereditato da TreeList)
Evento pubblico | RowSelectImageClick | (Ereditato da TreeList)
Evento pubblico | RowStateImageClick | (Ereditato da TreeList)
Evento pubblico | ScrollAnnotationsStyle | (Ereditato da TreeList)
Evento pubblico | SelectImageClick | (Ereditato da TreeList)
Evento pubblico | SelectionChanged | (Ereditato da TreeList)
Evento pubblico | SelectionChanging | (Ereditato da TreeList)
Evento pubblico | ShowCustomizationForm | (Ereditato da TreeList)
Evento pubblico | ShowFilterPopupCheckedListBox | (Ereditato da TreeList)
Evento pubblico | ShowFilterPopupDate | (Ereditato da TreeList)
Evento pubblico | ShowFilterPopupExcel | (Ereditato da TreeList)
Evento pubblico | ShowFilterPopupListBox | (Ereditato da TreeList)
Evento pubblico | ShowingEditor | (Ereditato da TreeList)
Evento pubblico | ShownEditor | (Ereditato da TreeList)
Evento pubblico | ShowTreeListMenu | Obsoleto. (Ereditato da TreeList)
Evento pubblico | StartSorting | (Ereditato da TreeList)
Evento pubblico | StateChanged | (Ereditato da TreeList)
Evento pubblico | StateImageClick | (Ereditato da TreeList)
Evento pubblico | SubstituteFilter | (Ereditato da TreeList)
Evento pubblico | TopVisibleNodeIndexChanged | (Ereditato da TreeList)
Evento pubblico | TreeListMenuItemClick | (Ereditato da TreeList)
Evento pubblico | UnboundExpressionEditorCreated | (Ereditato da TreeList)
Evento pubblico | ValidateNode | (Ereditato da TreeList)
Evento pubblico | ValidatingEditor | (Ereditato da TreeList)
Evento pubblico | VirtualTreeGetCellValue | (Ereditato da TreeList)
Evento pubblico | VirtualTreeGetChildNodes | (Ereditato da TreeList)
Evento pubblico | VirtualTreeSetCellValue | (Ereditato da TreeList)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | allowCloseEditor | (Ereditato da TreeList)
Campo pubblico | ChangeSelection | Indica d'effettuare un cambio di selezione nel load state
Campo protetto | fInitializing | (Ereditato da EditorContainer)
Campo protetto | fUpdateSize | (Ereditato da TreeList)
Campo pubblico | IsFilterActive | Indica se è attivo un filtro
Campo pubblico | searchStarted |
Campo pubblico | SelectionChangedByCode | Indica se un cambio di selezione di un nodo è avvenuto via codice
Campo protetto | SortedColumns | (Ereditato da TreeList)
Campo pubblico | state |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore TreeListSafePaint
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | TreeListSafePaint | Costruttori
Metodo protetto | TreeListSafePaint(Object) |
Torna su
Vedi anche

Documentazione

Classe TreeListSafePaint
Namespace DedNet.Controls


Costruttore TreeListSafePaint
Costruttori

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public TreeListSafePaint()
Public Sub New
public:
TreeListSafePaint()
new : unit -> TreeListSafePaint
Vedi anche

Documentazione

Classe TreeListSafePaint
Overload di TreeListSafePaint
Namespace DedNet.Controls


Costruttore TreeListSafePaint(Object)

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected TreeListSafePaint(
    Object ignore
)
Protected Sub New (
    ignore As Object
)
protected:
TreeListSafePaint(
    Object^ ignore
)
new :
        ignore : Object -> TreeListSafePaint

Parametri

ignore Object
Vedi anche

Documentazione

Classe TreeListSafePaint
Overload di TreeListSafePaint
Namespace DedNet.Controls


Proprietà di TreeListSafePaint

Il tipo TreeListSafePaint espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | ActiveEditor | (Ereditato da TreeList)
Proprietà pubblica | ActiveFilter | (Ereditato da TreeList)
Proprietà pubblica | ActiveFilterCriteria | (Ereditato da TreeList)
Proprietà pubblica | ActiveFilterEnabled | (Ereditato da TreeList)
Proprietà pubblica | ActiveFilterInfo | (Ereditato da TreeList)
Proprietà pubblica | ActiveFilterString | (Ereditato da TreeList)
Proprietà protetta | ActualAutoNodeHeight | (Ereditato da TreeList)
Proprietà protetta | ActualFilterCriteria | (Ereditato da TreeList)
Proprietà protetta | ActualShowBands | (Ereditato da TreeList)
Proprietà pubblica | AllNodesCount | (Ereditato da TreeList)
Proprietà protetta | AllowAnimatedScrolling | (Ereditato da TreeList)
Proprietà protetta | AllowAutoFilterConditionChange | (Ereditato da TreeList)
Proprietà protetta | AllowBandColumnsMultiRow | (Ereditato da TreeList)
Proprietà protetta | AllowExpandAnimation | (Ereditato da TreeList)
Proprietà protetta | AllowFiltering | (Ereditato da TreeList)
Proprietà protetta | AllowFilteringAfterLoadingData | (Ereditato da TreeList)
Proprietà protetta | AllowFilterNodes | (Ereditato da TreeList)
Proprietà protetta | AllowFindPanel | (Ereditato da TreeList)
Proprietà protetta | AllowPrintProgress | (Ereditato da TreeList)
Proprietà protetta | AllowScaleOnLoad | (Ereditato da EditorContainer)
Proprietà pubblica | AllowTouchGestures | (Ereditato da EditorContainer)
Proprietà protetta | AllowTouchScroll | (Ereditato da TreeList)
Proprietà protetta | AnnotationManager | (Ereditato da TreeList)
Proprietà pubblica | Appearance | (Ereditato da TreeList)
Proprietà pubblica | AppearancePrint | (Ereditato da TreeList)
Proprietà pubblica | AutoFillColumn | (Ereditato da TreeList)
Proprietà pubblica | AutoFillColumnName | (Ereditato da TreeList)
Proprietà pubblica | AutoFillFieldName | (Ereditato da TreeList)
Proprietà protetta | AutoFilterNode | (Ereditato da TreeList)
Proprietà pubblica | BackColor | (Ereditato da TreeList)
Proprietà pubblica | BandPanelRowHeight | (Ereditato da TreeList)
Proprietà pubblica | Bands | (Ereditato da TreeList)
Proprietà pubblica | BestFitVisibleOnly | (Ereditato da TreeList)
Proprietà pubblica | BorderStyle | (Ereditato da TreeList)
Proprietà protetta | CanExpandNodesOnIncrementalSearch | (Ereditato da TreeList)
Proprietà protetta | CanLoadNodes | (Ereditato da TreeList)
Proprietà protetta | CanShowBandsInCustomizationForm | (Ereditato da TreeList)
Proprietà pubblica | CanShowEditor | (Ereditato da TreeList)
Proprietà pubblica | CanShowRowFooterSummary | (Ereditato da TreeList)
Proprietà pubblica | Caption | (Ereditato da TreeList)
Proprietà pubblica | CaptionHeight | (Ereditato da TreeList)
Proprietà protetta | CheckBoxesStrategy | (Ereditato da TreeList)
Proprietà pubblica | CheckBoxFieldName | (Ereditato da TreeList)
Proprietà pubblica | ChildListFieldName | (Ereditato da TreeList)
Proprietà protetta | ClientHeight | (Ereditato da TreeList)
Proprietà protetta | ClientWidth | (Ereditato da TreeList)
Proprietà pubblica | ClipboardDataProvider | (Ereditato da TreeList)
Proprietà protetta | ClipboardPasteHelper | (Ereditato da TreeList)
Proprietà protetta | ClipboardPasteManager | (Ereditato da TreeList)
Proprietà protetta | CloneInfoList | (Ereditato da TreeList)
Proprietà pubblica | ColumnPanelRowHeight | (Ereditato da TreeList)
Proprietà pubblica | Columns | (Ereditato da TreeList)
Proprietà pubblica | ColumnsImageList | (Ereditato da TreeList)
Proprietà protetta | ContainerHelper | (Ereditato da TreeList)
Proprietà pubblica | ContextMenuStrip | (Ereditato da EditorContainer)
Proprietà protetta | CurrencyManager | (Ereditato da TreeList)
Proprietà pubblica | Cursor | (Ereditato da TreeList)
Proprietà pubblica | CustomizationForm | (Ereditato da TreeList)
Proprietà pubblica | CustomizationFormBounds | (Ereditato da TreeList)
Proprietà pubblica | CustomizationRowCount | Obsoleto. (Ereditato da TreeList)
Proprietà protetta | Data | (Ereditato da TreeList)
Proprietà pubblica | DataMember | (Ereditato da TreeList)
Proprietà pubblica | DataSource | (Ereditato da TreeList)
Proprietà protetta | DefaultSize | (Ereditato da TreeList)
Proprietà protetta | DirectXProvider | (Ereditato da TreeList)
Proprietà protetta | DirectXScroller | (Ereditato da TreeList)
Proprietà pubblica | DragExpandDelay | Obsoleto. (Ereditato da TreeList)
Proprietà pubblica | DragNodesMode | Obsoleto. (Ereditato da TreeList)
Proprietà protetta | DXAccessible | (Ereditato da TreeList)
Proprietà protetta | Editable | (Ereditato da TreeList)
Proprietà protetta | EditFormController | (Ereditato da TreeList)
Proprietà pubblica | EditingValue | (Ereditato da TreeList)
Proprietà protetta | EditorHelper | (Ereditato da EditorContainer)
Proprietà protetta | ElementsLookAndFeel | (Ereditato da TreeList)
Proprietà pubblica | EmptyTreeHtmlTemplate | (Ereditato da TreeList)
Proprietà protetta | EnableDirectXPaint | (Ereditato da TreeList)
Proprietà pubblica | EnableDynamicLoading | (Ereditato da TreeList)
Proprietà pubblica | EnableEnhancedScrolling | (Ereditato da TreeList)
Proprietà protetta | EnableEnhancedSorting | (Ereditato da TreeList)
Proprietà protetta | EnableFirstPaintTrigger | (Ereditato da EditorContainer)
Proprietà pubblica | EnableImprovedColumnSizing | (Ereditato da TreeList)
Proprietà protetta | ErrorInfo | (Ereditato da TreeList)
Proprietà protetta | ExcelFilteringProvider | (Ereditato da TreeList)
Proprietà protetta | ExceptionThrown | (Ereditato da TreeList)
Proprietà pubblica | ExternalRepository | (Ereditato da EditorContainer)
Proprietà protetta | ExtraFilter | (Ereditato da TreeList)
Proprietà protetta | ExtraFilterCriteria | (Ereditato da TreeList)
Proprietà protetta | ExtraFilterHightlightText | (Ereditato da TreeList)
Proprietà protetta | FilterColumnsProvider | (Ereditato da TreeList)
Proprietà protetta | FilterHelper | (Ereditato da TreeList)
Proprietà protetta | FilteringService | (Ereditato da TreeList)
Proprietà pubblica | FilterPanelText | (Ereditato da TreeList)
Proprietà protetta | FilterPopup | (Ereditato da TreeList)
Proprietà protetta | FindFilterCriteria | (Ereditato da TreeList)
Proprietà pubblica | FindFilterText | (Ereditato da TreeList)
Proprietà protetta | FindPanel | (Ereditato da TreeList)
Proprietà pubblica | FindPanelVisible | (Ereditato da TreeList)
Proprietà protetta | FireOnLoadOnPaint | (Ereditato da TreeList)
Proprietà pubblica | FixedLineWidth | Azzero lo spessore della linea di delimitazione delle colonne fisse (Sovrascrive TreeList.FixedLineWidth)
Proprietà protetta | FocusedCellIndex | (Ereditato da TreeList)
Proprietà pubblica | FocusedColumn | (Ereditato da TreeList)
Proprietà pubblica | FocusedNode | (Ereditato da TreeList)
Proprietà protetta | FocusedRow | (Ereditato da TreeList)
Proprietà protetta | FocusedRowIndex | (Ereditato da TreeList)
Proprietà pubblica | FocusedValue | (Ereditato da TreeList)
Proprietà pubblica | FooterPanelHeight | (Ereditato da TreeList)
Proprietà protetta | ForceLoadingPanel | (Ereditato da TreeList)
Proprietà pubblica | ForeColor | (Ereditato da EditorContainer)
Proprietà pubblica | FormatConditions | (Ereditato da TreeList)
Proprietà pubblica | FormatRules | (Ereditato da TreeList)
Proprietà pubblica | GroupButtonSize | Obsoleto. (Ereditato da TreeList)
Proprietà protetta | Handler | (Ereditato da TreeList)
Proprietà protetta | HasAccessible | (Ereditato da TreeList)
Proprietà protetta | HasAllColumnsFixedRight | (Ereditato da TreeList)
Proprietà protetta | HasBands | (Ereditato da TreeList)
Proprietà pubblica | HasColumnErrors | (Ereditato da TreeList)
Proprietà protetta | HasCustomNodeCellEdit | (Ereditato da TreeList)
Proprietà pubblica | HasFocus | (Ereditato da TreeList)
Proprietà protetta | HasHierarchicalColumn | (Ereditato da TreeList)
Proprietà protetta | HasTreeViewColumn | (Ereditato da TreeList)
Proprietà protetta | HeaderLayoutCalculator | (Ereditato da TreeList)
Proprietà protetta | HeaderWidthCalculator | (Ereditato da TreeList)
Proprietà pubblica | HierarchyColumn | (Ereditato da TreeList)
Proprietà pubblica | HierarchyColumnIndent | (Ereditato da TreeList)
Proprietà pubblica | HierarchyColumnName | (Ereditato da TreeList)
Proprietà pubblica | HierarchyFieldName | (Ereditato da TreeList)
Proprietà pubblica | HorzScrollStep | (Ereditato da TreeList)
Proprietà pubblica | HorzScrollVisibility | (Ereditato da TreeList)
Proprietà protetta | HtmlContext | (Ereditato da TreeList)
Proprietà pubblica | HtmlImages | (Ereditato da TreeList)
Proprietà protetta | HtmlObjectCache | (Ereditato da TreeList)
Proprietà pubblica | HtmlTemplates | (Ereditato da TreeList)
Proprietà protetta | IBasePrintableCreatesIntersectedBricks | (Ereditato da TreeList)
Proprietà pubblica | ImageIndexFieldName | (Ereditato da TreeList)
Proprietà protetta | IncrementalText | (Ereditato da TreeList)
Proprietà pubblica | IndicatorWidth | (Ereditato da TreeList)
Proprietà protetta | IsAllowBusyIndicator | (Ereditato da TreeList)
Proprietà protetta | IsAllowBusyPanel | (Ereditato da TreeList)
Proprietà protetta | IsAlt | (Ereditato da TreeList)
Proprietà protetta | IsAttachedToSearchControl | (Ereditato da TreeList)
Proprietà protetta | IsAutoWidth | (Ereditato da TreeList)
Proprietà protetta | IsCellSelect | (Ereditato da TreeList)
Proprietà protetta | IsClosingEditor | (Ereditato da TreeList)
Proprietà protetta | IsColumnHeaderAutoHeight | (Ereditato da TreeList)
Proprietà protetta | IsControl | (Ereditato da TreeList)
Proprietà protetta | IsDataReady | (Ereditato da TreeList)
Proprietà protetta | IsDeserializing | (Ereditato da TreeList)
Proprietà pubblica | IsDesignMode | (Ereditato da EditorContainer)
Proprietà protetta | IsDynamicLoadingAllowed | (Ereditato da TreeList)
Proprietà protetta | IsEditFormMode | (Ereditato da TreeList)
Proprietà protetta | IsFilterPopupActive | (Ereditato da TreeList)
Proprietà protetta | IsFindFilterActive | (Ereditato da TreeList)
Proprietà pubblica | IsFindPanelVisible | (Ereditato da TreeList)
Proprietà protetta | IsFocusedNodeChangedLocked | (Ereditato da TreeList)
Proprietà protetta | IsFocusedNodeDataModified | (Ereditato da TreeList)
Proprietà protetta | IsGroupDeleteOperation | (Ereditato da TreeList)
Proprietà protetta | IsHScrollBarVisible | (Ereditato da TreeList)
Proprietà protetta | IsInitialized | (Ereditato da EditorContainer)
Proprietà protetta | IsIniting | (Ereditato da TreeList)
Proprietà pubblica | IsLoading | (Ereditato da EditorContainer)
Proprietà protetta | IsLockDirectXRendering | (Ereditato da TreeList)
Proprietà protetta | IsLockExpandCollapse | (Ereditato da TreeList)
Proprietà protetta | IsLockUpdate | (Ereditato da TreeList)
Proprietà pubblica | IsLookUpMode | (Ereditato da TreeList)
Proprietà protetta | IsMultiSelect | (Ereditato da TreeList)
Proprietà protetta | IsNotificationInfoVisible | (Ereditato da TreeList)
Proprietà protetta | IsPainting | (Ereditato da TreeList)
Proprietà protetta | IsPixelScrolling | (Ereditato da TreeList)
Proprietà protetta | IsPopupEditFormVisible | (Ereditato da TreeList)
Proprietà pubblica | IsPrinting | (Ereditato da TreeList)
Proprietà pubblica | IsPrintingAvailable | (Ereditato da TreeList)
Proprietà protetta | IsRightToLeft | (Ereditato da TreeList)
Proprietà protetta | IsRowCountReady | (Ereditato da TreeList)
Proprietà protetta | IsScrollAnimationInProgress | (Ereditato da TreeList)
Proprietà protetta | IsSearchMode | (Ereditato da TreeList)
Proprietà protetta | IsSerializing | (Ereditato da TreeList)
Proprietà protetta | IsShift | (Ereditato da TreeList)
Proprietà protetta | IsSorted | (Ereditato da TreeList)
Proprietà protetta | IsUnboundLoad | (Ereditato da TreeList)
Proprietà pubblica | IsUnboundMode | (Ereditato da TreeList)
Proprietà protetta | IsUpdateSize | (Ereditato da TreeList)
Proprietà protetta | IsVirtualMode | (Ereditato da TreeList)
Proprietà protetta | IsVScrollBarVisible | (Ereditato da TreeList)
Proprietà pubblica | KeyFieldName | (Ereditato da TreeList)
Proprietà pubblica | LayoutVersion | Obsoleto. (Ereditato da TreeList)
Proprietà pubblica | LeftCoord | (Ereditato da TreeList)
Proprietà pubblica | LoadingPanelVisible | (Ereditato da TreeList)
Proprietà pubblica | LookAndFeel | (Ereditato da EditorContainer)
Proprietà protetta | LookAndFeelIgnoreChildren | (Ereditato da EditorContainer)
Proprietà protetta | LookUpDisplayColumn | (Ereditato da TreeList)
Proprietà protetta | LookUpOwner | (Ereditato da TreeList)
Proprietà pubblica | MenuManager | (Ereditato da EditorContainer)
Proprietà protetta | MinRowHeight | (Ereditato da TreeList)
Proprietà pubblica | MinWidth | (Ereditato da TreeList)
Proprietà protetta | MRUFilterPopup | (Ereditato da TreeList)
Proprietà pubblica | MRUFilters | (Ereditato da TreeList)
Proprietà protetta | NewItemNode | (Ereditato da TreeList)
Proprietà pubblica | NewItemRowText | (Ereditato da TreeList)
Proprietà pubblica | NodeHtmlTemplate | (Ereditato da TreeList)
Proprietà pubblica | Nodes | (Ereditato da TreeList)
Proprietà pubblica | NodesIterator | (Ereditato da TreeList)
Proprietà pubblica | NonColumnFilterCriteria | (Ereditato da TreeList)
Proprietà pubblica | NonColumnFilterString | (Ereditato da TreeList)
Proprietà protetta | NotificationInfo | (Ereditato da TreeList)
Proprietà protetta | OfficeScroller | (Ereditato da TreeList)
Proprietà pubblica | OptionsBehavior | (Ereditato da TreeList)
Proprietà pubblica | OptionsClipboard | (Ereditato da TreeList)
Proprietà pubblica | OptionsCustomization | (Ereditato da TreeList)
Proprietà pubblica | OptionsDragAndDrop | (Ereditato da TreeList)
Proprietà pubblica | OptionsEditForm | (Ereditato da TreeList)
Proprietà pubblica | OptionsFilter | (Ereditato da TreeList)
Proprietà pubblica | OptionsFind | (Ereditato da TreeList)
Proprietà pubblica | OptionsHtmlTemplate | (Ereditato da TreeList)
Proprietà pubblica | OptionsLayout | (Ereditato da TreeList)
Proprietà pubblica | OptionsMenu | (Ereditato da TreeList)
Proprietà pubblica | OptionsNavigation | (Ereditato da TreeList)
Proprietà pubblica | OptionsPrint | (Ereditato da TreeList)
Proprietà pubblica | OptionsScrollAnnotations | (Ereditato da TreeList)
Proprietà pubblica | OptionsSelection | (Ereditato da TreeList)
Proprietà pubblica | OptionsView | (Ereditato da TreeList)
Proprietà pubblica | Painter | (Ereditato da TreeList)
Proprietà pubblica | ParentFieldName | (Ereditato da TreeList)
Proprietà protetta | Position | (Ereditato da TreeList)
Proprietà protetta | PressedBand | (Ereditato da TreeList)
Proprietà protetta | PressedColumn | (Ereditato da TreeList)
Proprietà protetta | PressedNode | (Ereditato da TreeList)
Proprietà pubblica | PreviewFieldName | (Ereditato da TreeList)
Proprietà pubblica | PreviewIndent | (Ereditato da TreeList)
Proprietà pubblica | PreviewLineCount | (Ereditato da TreeList)
Proprietà protetta | Printer | (Ereditato da TreeList)
Proprietà protetta | PrinterCore | (Ereditato da TreeList)
Proprietà protetta | ProgressWindow | (Ereditato da TreeList)
Proprietà pubblica | RepositoryItems | (Ereditato da EditorContainer)
Proprietà pubblica | RootValue | (Ereditato da TreeList)
Proprietà protetta | RowCount | (Ereditato da TreeList)
Proprietà pubblica | RowHeight | (Ereditato da TreeList)
Proprietà protetta | ScaleDPI | (Ereditato da EditorContainer)
Proprietà pubblica | ScaleFactor | (Ereditato da EditorContainer)
Proprietà protetta | ScaleHelper | (Ereditato da EditorContainer)
Proprietà protetta | ScrollInfo | (Ereditato da TreeList)
Proprietà pubblica | SelectedHtmlText | (Ereditato da TreeList)
Proprietà pubblica | SelectImageList | (Ereditato da TreeList)
Proprietà pubblica | Selection | (Ereditato da TreeList)
Proprietà protetta | SelectionRange | (Ereditato da TreeList)
Proprietà pubblica | ShowButtonMode | (Ereditato da TreeList)
Proprietà protetta | ShowEditorAfterAnimatedScroll | (Ereditato da TreeList)
Proprietà protetta | ShowPreview | (Ereditato da TreeList)
Proprietà protetta | SizedBand | (Ereditato da TreeList)
Proprietà protetta | SizedColumn | (Ereditato da TreeList)
Proprietà protetta | SmartVisibility | (Ereditato da TreeList)
Proprietà pubblica | SortedColumnCount | (Ereditato da TreeList)
Proprietà pubblica | State | (Ereditato da TreeList)
Proprietà pubblica | StateImageList | (Ereditato da TreeList)
Proprietà pubblica | SyncCheckStateWithSourceOnChecking | (Ereditato da TreeList)
Proprietà pubblica | Text | (Ereditato da EditorContainer)
Proprietà pubblica | ToolTipController | (Ereditato da EditorContainer)
Proprietà protetta | TopVisibleNode | (Ereditato da TreeList)
Proprietà pubblica | TopVisibleNodeIndex | (Ereditato da TreeList)
Proprietà pubblica | TopVisibleNodePixel | (Ereditato da TreeList)
Proprietà pubblica | TreeLevelWidth | (Ereditato da TreeList)
Proprietà pubblica | TreeLineStyle | (Ereditato da TreeList)
Proprietà pubblica | TreeListDisposing | (Ereditato da TreeList)
Proprietà pubblica | TreeViewColumn | (Ereditato da TreeList)
Proprietà pubblica | TreeViewColumnName | (Ereditato da TreeList)
Proprietà pubblica | TreeViewFieldName | (Ereditato da TreeList)
Proprietà pubblica | UpdateTopVisibleNodeIndexOnCollapse | (Ereditato da TreeList)
Proprietà protetta | UseBandsAdvancedHorizontalNavigation | (Ereditato da TreeList)
Proprietà protetta | UseBandsAdvancedVerticalNavigation | (Ereditato da TreeList)
Proprietà pubblica | UseDirectXPaint | (Ereditato da TreeList)
Proprietà pubblica | UseDisabledStatePainter | (Ereditato da TreeList)
Proprietà protetta | UseStandardFilter | (Ereditato da TreeList)
Proprietà pubblica | VertScrollVisibility | (Ereditato da TreeList)
Proprietà pubblica | ViewInfo | (Ereditato da TreeList)
Proprietà pubblica | ViewStyle | (Ereditato da TreeList)
Proprietà protetta | VirtualDataHelper | (Ereditato da TreeList)
Proprietà pubblica | VisibleColumnCount | Obsoleto. (Ereditato da TreeList)
Proprietà pubblica | VisibleColumns | (Ereditato da TreeList)
Proprietà pubblica | VisibleNodesCount | (Ereditato da TreeList)
Proprietà protetta | WorkAsLookup | (Ereditato da TreeList)
Torna su
Vedi anche

Documentazione

Classe TreeListSafePaint
Namespace DedNet.Controls


Proprietà TreeListSafePaint.FixedLineWidth

Proprietà TreeListSafePaintFixedLineWidth
Azzero lo spessore della linea di delimitazione delle colonne fisse

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override int FixedLineWidth { get; set; }
Public Overrides Property FixedLineWidth As Integer
    Get
    Set
public:
virtual property int FixedLineWidth {
    int get () override;
    void set (int value) override;
}
abstract FixedLineWidth : int with get, set
override FixedLineWidth : int with get, set

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe TreeListSafePaint
Namespace DedNet.Controls


Metodi di TreeListSafePaint

Il tipo TreeListSafePaint espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AccessibleNotifyClients(AccessibleEvents, BaseAccessible) | (Ereditato da TreeList)
Metodo pubblico | AccessibleNotifyClients(AccessibleEvents, Int32, Int32) | (Ereditato da TreeList)
Metodo pubblico | AddFilter(CriteriaOperator) | (Ereditato da TreeList)
Metodo pubblico | AddFilter(String) | (Ereditato da TreeList)
Metodo protetto | AddToDefaultTooltipController | (Ereditato da EditorContainer)
Metodo protetto | AllowAutoFilterCondition | (Ereditato da TreeList)
Metodo protetto | AnimateKeyboardNavigation | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, TreeListNode) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, TreeListNode, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, TreeListNode, CheckState) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, CheckState) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, TreeListNode, CheckState, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, CheckState, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, TreeListNode, CheckState, NodeCheckBoxStyle, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, Int32, Int32, Int32) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, Int32, Int32, Int32, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, Int32, Int32, Int32, CheckState) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, Int32, Int32, Int32, CheckState, Object) | (Ereditato da TreeList)
Metodo pubblico | AppendNode(Object, Int32, Int32, Int32, Int32, CheckState, NodeCheckBoxStyle, Object) | (Ereditato da TreeList)
Metodo protetto | ApplyFilter | (Ereditato da TreeList)
Metodo pubblico | ApplyFindFilter | (Ereditato da TreeList)
Metodo protetto | BeforeShowEditForm | (Ereditato da TreeList)
Metodo pubblico | BeginDelete | (Ereditato da TreeList)
Metodo protetto | BeginDragDrop | (Ereditato da TreeList)
Metodo protetto | BeginExpandCollapse | (Ereditato da TreeList)
Metodo pubblico | BeginInit | (Ereditato da EditorContainer)
Metodo protetto | BeginLockListChanged | (Ereditato da TreeList)
Metodo pubblico | BeginSelection | (Ereditato da TreeList)
Metodo pubblico | BeginSort | (Ereditato da TreeList)
Metodo pubblico | BeginUnboundLoad | (Ereditato da TreeList)
Metodo pubblico | BeginUpdate | (Ereditato da TreeList)
Metodo pubblico | BestFitColumns | (Ereditato da TreeList)
Metodo pubblico | BestFitColumns(Boolean) | (Ereditato da TreeList)
Metodo pubblico | BindCommand(Object, String, FuncObject) | (Ereditato da TreeList)
Metodo pubblico | BindCommand(ExpressionAction, Object, String, FuncObject) | (Ereditato da TreeList)
Metodo pubblico | BindCommand``1(ExpressionActionUMP, Object, String, FuncUMP) | (Ereditato da TreeList)
Metodo protetto | CalcActiveEditorBounds | (Ereditato da TreeList)
Metodo protetto | CalcColumnBestWidth | (Ereditato da TreeList)
Metodo pubblico | CalcHitInfo | (Ereditato da TreeList)
Metodo protetto | CalcHScrollRange | (Ereditato da TreeList)
Metodo protetto | CalcNodeAutoHeight | (Ereditato da TreeList)
Metodo protetto | CalcRowCount | (Ereditato da TreeList)
Metodo protetto | CalcScrollClientRect | (Ereditato da TreeList)
Metodo protetto | CalculateScrollBars | (Ereditato da TreeList)
Metodo protetto | CalculateVisibleRowsAreaHeight | (Ereditato da TreeList)
Metodo pubblico | CancelCurrentEdit | (Ereditato da TreeList)
Metodo protetto | CancelDirectXRendering | (Ereditato da TreeList)
Metodo protetto | CancelLockListChanged | (Ereditato da TreeList)
Metodo protetto | CancelSelection | (Ereditato da TreeList)
Metodo pubblico | CancelSort | (Ereditato da TreeList)
Metodo pubblico | CancelUpdate | (Ereditato da TreeList)
Metodo protetto | CanClearAllSorting | (Ereditato da TreeList)
Metodo protetto | CanCloneChildren | (Ereditato da TreeList)
Metodo protetto | CanFilterByColumnEdit | (Ereditato da TreeList)
Metodo pubblico | CanFilterColumn | (Ereditato da TreeList)
Metodo protetto | CanFindColumn | (Ereditato da TreeList)
Metodo protetto | CanFocusNode | (Ereditato da TreeList)
Metodo protetto | CanHandleTouchGestures | (Ereditato da EditorContainer)
Metodo protetto | CanIncrementalSearch | (Ereditato da TreeList)
Metodo pubblico | CanIndentNodes | (Ereditato da TreeList)
Metodo protetto | CanMove | (Ereditato da TreeList)
Metodo protetto | CanMoveBand | (Ereditato da TreeList)
Metodo protetto | CanMoveColumn | (Ereditato da TreeList)
Metodo pubblico | CanOutdentNodes | (Ereditato da TreeList)
Metodo protetto | CanResizeBand | (Ereditato da TreeList)
Metodo protetto | CanResizeColumn | (Ereditato da TreeList)
Metodo protetto | CanShowHScrollBar | (Ereditato da TreeList)
Metodo protetto | CanShowHScrollBarCore | (Ereditato da TreeList)
Metodo protetto | CanShowVScrollBar | (Ereditato da TreeList)
Metodo protetto | CanSortByColumnEdit | (Ereditato da TreeList)
Metodo pubblico | CanSortColumn | (Ereditato da TreeList)
Metodo protetto | CanStartTouchScrolling | (Ereditato da TreeList)
Metodo protetto | ChangeLeftCoord | (Ereditato da TreeList)
Metodo pubblico | CheckAll | (Ereditato da TreeList)
Metodo protetto | CheckAllowGestures | (Ereditato da TreeList)
Metodo protetto | CheckAllowNotifications | (Ereditato da TreeList)
Metodo protetto | CheckData | (Ereditato da TreeList)
Metodo protetto | CheckIncreaseVisibleRows | (Ereditato da TreeList)
Metodo protetto | CheckModifierKeys | (Ereditato da TreeList)
Metodo protetto | CheckNeedScale | (Ereditato da EditorContainer)
Metodo protetto | CheckRightToLeft | (Ereditato da EditorContainer)
Metodo protetto | CheckSearchMode | (Ereditato da TreeList)
Metodo protetto | CheckTopVisibleNodeAfterItemAdded | (Ereditato da TreeList)
Metodo protetto | CheckTopVisibleNodePixelValue | (Ereditato da TreeList)
Metodo pubblico | ClearColumnErrors | (Ereditato da TreeList)
Metodo pubblico | ClearColumnFilter | (Ereditato da TreeList)
Metodo protetto | ClearColumnFilterCore(String) | (Ereditato da TreeList)
Metodo protetto | ClearColumnFilterCore(TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | ClearColumnsFilter | (Ereditato da TreeList)
Metodo pubblico | ClearDocument | (Ereditato da TreeList)
Metodo pubblico | ClearFindFilter | (Ereditato da TreeList)
Metodo pubblico | ClearFocusedColumn | (Ereditato da TreeList)
Metodo pubblico | ClearNodes | (Ereditato da TreeList)
Metodo pubblico | ClearSelection | (Ereditato da TreeList)
Metodo pubblico | ClearSorting | (Ereditato da TreeList)
Metodo protetto | ClearVisibleIndicesCache | (Ereditato da TreeList)
Metodo pubblico | CloseEditForm | (Ereditato da TreeList)
Metodo pubblico | CloseEditor | (Ereditato da TreeList)
Metodo protetto | CloseEditor(Boolean) | (Ereditato da TreeList)
Metodo pubblico | CollapseAll | (Ereditato da TreeList)
Metodo protetto | CollapseAllCore | (Ereditato da TreeList)
Metodo pubblico | CollapseToLevel | (Ereditato da TreeList)
Metodo pubblico | ColumnsCustomization | (Ereditato da TreeList)
Metodo pubblico | ColumnsCustomization(Point) | (Ereditato da TreeList)
Metodo protetto | ControlRowSourceSelectedChanged | (Ereditato da TreeList)
Metodo protetto | ControlRowSourceVisibleChanged | (Ereditato da TreeList)
Metodo pubblico | ConvertFormatConditionToFormatRules | (Ereditato da TreeList)
Metodo pubblico | CopyNode(TreeListNode, TreeListNode, Boolean) | (Ereditato da TreeList)
Metodo pubblico | CopyNode(TreeListNode, TreeListNode, Boolean, Boolean) | (Ereditato da TreeList)
Metodo pubblico | CopyNode(TreeListNode, TreeListNode, Boolean, Int32) | (Ereditato da TreeList)
Metodo pubblico | CopyNode(TreeListNode, TreeListNode, Boolean, Boolean, Int32) | (Ereditato da TreeList)
Metodo protetto | CopyNodeCore | (Ereditato da TreeList)
Metodo pubblico | CopyNodes(IEnumerableTreeListNode, TreeListNode, Boolean, Int32) | (Ereditato da TreeList)
Metodo pubblico | CopyNodes(IEnumerableTreeListNode, TreeListNode, Boolean, Boolean, Int32) | (Ereditato da TreeList)
Metodo pubblico | CopyToClipboard | (Ereditato da TreeList)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da TreeList)
Metodo protetto | CreateAccessibleDataRow | (Ereditato da TreeList)
Metodo protetto | CreateAccessibleInstance | (Ereditato da TreeList)
Metodo protetto | CreateAllOptions | (Ereditato da TreeList)
Metodo protetto | CreateAnnotationManager | (Ereditato da TreeList)
Metodo protetto | CreateAppearances | (Ereditato da TreeList)
Metodo protetto | CreateAutoFilterCriterion | (Ereditato da TreeList)
Metodo protetto | CreateBands | (Ereditato da TreeList)
Metodo protetto | CreateCheckBoxesStrategy | (Ereditato da TreeList)
Metodo protetto | CreateCheckedListFilterPopup | (Ereditato da TreeList)
Metodo protetto | CreateColumn | (Ereditato da TreeList)
Metodo protetto | CreateColumnEditViewInfo | (Ereditato da TreeList)
Metodo protetto | CreateColumnFilterCriteriaByValue(TreeListColumn, Object) | (Ereditato da TreeList)
Metodo protetto | CreateColumnFilterCriteriaByValue(TreeListColumn, Object, Boolean) | (Ereditato da TreeList)
Metodo protetto | CreateColumnFilterPopup | (Ereditato da TreeList)
Metodo protetto | CreateColumns | (Ereditato da TreeList)
Metodo pubblico | CreateCustomization | Obsoleto. (Ereditato da TreeList)
Metodo protetto | CreateCustomizationForm | (Ereditato da TreeList)
Metodo protetto | CreateData | (Ereditato da TreeList)
Metodo protetto | CreateDataViewData | (Ereditato da TreeList)
Metodo protetto | CreateDateFilterPopup | (Ereditato da TreeList)
Metodo protetto | CreateDragNodesProvider | (Ereditato da TreeList)
Metodo protetto | CreateEditFormController | (Ereditato da TreeList)
Metodo protetto | CreateElementsLookAndFeel | (Ereditato da TreeList)
Metodo protetto | CreateExcelFilterPopup | (Ereditato da TreeList)
Metodo protetto | CreateFilterColumnCollection | (Ereditato da TreeList)
Metodo protetto | CreateFilterColumnRuleCollection | (Ereditato da TreeList)
Metodo protetto | CreateFilterColumnsProvider | (Ereditato da TreeList)
Metodo protetto | CreateFilterCriteriaBindingTarget | (Ereditato da TreeList)
Metodo protetto | CreateFilterEditorForm | (Ereditato da TreeList)
Metodo protetto | CreateFilterHelper | (Ereditato da TreeList)
Metodo protetto | CreateFindPanel | (Ereditato da TreeList)
Metodo protetto | CreateFindPanelCore | (Ereditato da TreeList)
Metodo pubblico | CreateGraphicsCache | (Ereditato da TreeList)
Metodo protetto | CreateHandler | (Ereditato da TreeList)
Metodo protetto | CreateHeaderLayoutCalculator | (Ereditato da TreeList)
Metodo protetto | CreateHeaderWidthCalculator | (Ereditato da TreeList)
Metodo protetto | CreateHelper | (Ereditato da TreeList)
Metodo protetto | CreateHierarchicalListData | (Ereditato da TreeList)
Metodo protetto | CreateHtmlContext | (Ereditato da TreeList)
Metodo protetto | CreateHyperlinkClickEventArgs | (Ereditato da TreeList)
Metodo protetto | CreateInternalRepository | (Ereditato da EditorContainer)
Metodo protetto | CreateListColumnFilterPopup | (Ereditato da TreeList)
Metodo protetto | CreateListData | (Ereditato da TreeList)
Metodo protetto | CreateLoadingAnimator | (Ereditato da TreeList)
Metodo protetto | CreateLoadingPanel | (Ereditato da TreeList)
Metodo protetto | CreateLookAndFeel | (Ereditato da EditorContainer)
Metodo protetto | CreateNewItemNode | (Ereditato da TreeList)
Metodo protetto | CreateNode(Int32, TreeListNodes) | (Ereditato da TreeList)
Metodo protetto | CreateNode(Int32, TreeListNodes, Object) | (Ereditato da TreeList)
Metodo protetto | CreateNodes | (Ereditato da TreeList)
Metodo protetto | CreateNodesComparer | (Ereditato da TreeList)
Metodo protetto | CreateNodesIterator | (Ereditato da TreeList)
Metodo protetto | CreateNotificationInfo | (Ereditato da TreeList)
Metodo protetto | CreateOfficeScroller | (Ereditato da TreeList)
Metodo protetto | CreateOptionsBehavior | (Ereditato da TreeList)
Metodo protetto | CreateOptionsClipboard | (Ereditato da TreeList)
Metodo protetto | CreateOptionsCustomization | (Ereditato da TreeList)
Metodo protetto | CreateOptionsDragAndDrop | (Ereditato da TreeList)
Metodo protetto | CreateOptionsEditForm | (Ereditato da TreeList)
Metodo protetto | CreateOptionsFilter | (Ereditato da TreeList)
Metodo protetto | CreateOptionsFind | (Ereditato da TreeList)
Metodo protetto | CreateOptionsHtmlTemplate | (Ereditato da TreeList)
Metodo protetto | CreateOptionsLayout | (Ereditato da TreeList)
Metodo protetto | CreateOptionsMenu | (Ereditato da TreeList)
Metodo protetto | CreateOptionsNavigation | (Ereditato da TreeList)
Metodo protetto | CreateOptionsPrint | (Ereditato da TreeList)
Metodo protetto | CreateOptionsScrollAnnotations | (Ereditato da TreeList)
Metodo protetto | CreateOptionsSelection | (Ereditato da TreeList)
Metodo protetto | CreateOptionsView | (Ereditato da TreeList)
Metodo protetto | CreatePainter | (Ereditato da TreeList)
Metodo protetto | CreatePrinter | (Ereditato da TreeList)
Metodo protetto | CreateProvider | (Ereditato da TreeList)
Metodo protetto | CreateScrollInfo | (Ereditato da TreeList)
Metodo protetto | CreateSelection | (Ereditato da TreeList)
Metodo protetto | CreateUnboundData | (Ereditato da TreeList)
Metodo protetto | CreateViewInfo | (Ereditato da TreeList)
Metodo protetto | CreateVirtualData | (Ereditato da TreeList)
Metodo protetto | CreateVirtualDataHelper | (Ereditato da TreeList)
Metodo protetto | CurrencyManager_ItemChanged | (Ereditato da TreeList)
Metodo protetto | CurrencyManager_PositionChanged | (Ereditato da TreeList)
Metodo protetto | DeferredLoadChildren | (Ereditato da TreeList)
Metodo protetto | DelayedInvalidate | (Ereditato da TreeList)
Metodo pubblico | DeleteNode | (Ereditato da TreeList)
Metodo pubblico | DeleteNodes | (Ereditato da TreeList)
Metodo pubblico | DeleteSelectedNodes | (Ereditato da TreeList)
Metodo pubblico | DestroyCustomization | (Ereditato da TreeList)
Metodo protetto | DestroyDirectXProvider | (Ereditato da EditorContainer)
Metodo protetto | DestroyFindPanel | (Ereditato da TreeList)
Metodo protetto | Dispose | (Ereditato da TreeList)
Metodo protetto | DoDataSourceChanged | (Ereditato da TreeList)
Metodo protetto | DoDpiChange | (Ereditato da EditorContainer)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da TreeList)
Metodo protetto | DoDragDrop | (Ereditato da TreeList)
Metodo pubblico | DoDragDropNode | (Ereditato da TreeList)
Metodo pubblico | DoDragDropNodes | (Ereditato da TreeList)
Metodo protetto | DoFilterNode | (Ereditato da TreeList)
Metodo protetto | DoForEachBand | (Ereditato da TreeList)
Metodo pubblico | DoIncrementalSearch | (Ereditato da TreeList)
Metodo protetto | DoShowTreeListMenu(TreeListMenu, TreeListHitTest) | (Ereditato da TreeList)
Metodo protetto | DoShowTreeListMenu(TreeListMenu, Control, Point) | (Ereditato da TreeList)
Metodo protetto | DoTopVisibleNodeChanged | (Ereditato da TreeList)
Metodo pubblico | EndCurrentEdit | (Ereditato da TreeList)
Metodo pubblico | EndCurrentEdit(Boolean) | (Ereditato da TreeList)
Metodo pubblico | EndDelete | (Ereditato da TreeList)
Metodo protetto | EndDragDrop | (Ereditato da TreeList)
Metodo protetto | EndEdit | (Ereditato da TreeList)
Metodo protetto | EndExpandCollapse | (Ereditato da TreeList)
Metodo pubblico | EndInit | (Ereditato da EditorContainer)
Metodo pubblico | EndSelection | (Ereditato da TreeList)
Metodo pubblico | EndSort | (Ereditato da TreeList)
Metodo pubblico | EndUnboundLoad | (Ereditato da TreeList)
Metodo pubblico | EndUpdate | (Ereditato da TreeList)
Metodo protetto | EnsureControlRowSource | (Ereditato da TreeList)
Metodo protetto | EnsureEditFormController | (Ereditato da TreeList)
Metodo protetto | EnsureFilteringClientDataBinding | (Ereditato da TreeList)
Metodo protetto | ExecutePrinterAction | (Ereditato da TreeList)
Metodo pubblico | ExpandAll | (Ereditato da TreeList)
Metodo protetto | ExpandAllCore | (Ereditato da TreeList)
Metodo protetto | ExpandToLast | (Ereditato da TreeList)
Metodo pubblico | ExpandToLevel | (Ereditato da TreeList)
Metodo protetto | ExpandToRoot | (Ereditato da TreeList)
Metodo protetto | Export(ExportTarget, Stream) | (Ereditato da TreeList)
Metodo protetto | Export(ExportTarget, String) | (Ereditato da TreeList)
Metodo protetto | Export(ExportTarget, Stream, ExportOptionsBase) | (Ereditato da TreeList)
Metodo protetto | Export(ExportTarget, String, ExportOptionsBase) | (Ereditato da TreeList)
Metodo pubblico | ExportToCsv(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToCsv(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToCsv(Stream, CsvExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToCsv(String, CsvExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToDocx(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToDocx(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToDocx(Stream, DocxExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToDocx(String, DocxExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToHtml(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToHtml(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToHtml(Stream, HtmlExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToHtml(String, HtmlExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToMht(Stream, MhtExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToMht(String, MhtExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToMht(String, String) | Obsoleto. (Ereditato da TreeList)
Metodo pubblico | ExportToMht(Stream, String, String, Boolean) | Obsoleto. (Ereditato da TreeList)
Metodo pubblico | ExportToMht(String, String, String, Boolean) | Obsoleto. (Ereditato da TreeList)
Metodo pubblico | ExportToPdf(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToPdf(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToPdf(Stream, PdfExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToPdf(String, PdfExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToRtf(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToRtf(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToText(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToText(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToText(Stream, TextExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToText(String, TextExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToXls(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToXls(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToXls(Stream, XlsExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToXls(String, XlsExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToXlsx(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToXlsx(String) | (Ereditato da TreeList)
Metodo pubblico | ExportToXlsx(Stream, XlsxExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToXlsx(String, XlsxExportOptions) | (Ereditato da TreeList)
Metodo pubblico | ExportToXml(Stream) | (Ereditato da TreeList)
Metodo pubblico | ExportToXml(String) | (Ereditato da TreeList)
Metodo protetto | ExportToXmlCore | (Ereditato da TreeList)
Metodo protetto | ExtractTemplateRootNode | (Ereditato da TreeList)
Metodo pubblico | FilterNodes | (Sovrascrive TreeList.FilterNodes)
Metodo pubblico | FilterNodes(TreeListNodes) | (Ereditato da TreeList)
Metodo protetto | FilterNodesCore | (Ereditato da TreeList)
Metodo pubblico | FindNode | (Ereditato da TreeList)
Metodo pubblico | FindNodeByFieldValue | (Ereditato da TreeList)
Metodo pubblico | FindNodeByID | (Ereditato da TreeList)
Metodo pubblico | FindNodeByKeyID | (Ereditato da TreeList)
Metodo protetto | FindNodeByParentID | (Ereditato da TreeList)
Metodo pubblico | FindNodes | (Ereditato da TreeList)
Metodo protetto | FindPanelNext | (Ereditato da TreeList)
Metodo protetto | FindPanelPrev | (Ereditato da TreeList)
Metodo pubblico | FireChanged | (Ereditato da TreeList)
Metodo protetto | FitColumns | (Ereditato da TreeList)
Metodo pubblico | FocusNewItemNode | (Ereditato da TreeList)
Metodo protetto | ForceCalcRowCount | (Ereditato da TreeList)
Metodo pubblico | ForceInitialize | (Ereditato da TreeList)
Metodo protetto | ForceSetTopVisibleNodeIndex | (Ereditato da TreeList)
Metodo pubblico | FullCollapse | Obsoleto. (Ereditato da TreeList)
Metodo pubblico | FullExpand | Obsoleto. (Ereditato da TreeList)
Metodo pubblico | FullExpandNode | Obsoleto. (Ereditato da TreeList)
Metodo protetto | GetAccessibilityObjectById | (Ereditato da TreeList)
Metodo protetto | GetAccessibleNodeCell | (Ereditato da TreeList)
Metodo protetto | GetActiveEditorHighAppearance | (Ereditato da TreeList)
Metodo protetto | GetActualAnimationType | (Ereditato da TreeList)
Metodo protetto | GetActualTreeListFilterMode | (Ereditato da TreeList)
Metodo pubblico | GetAllCheckedNodes | (Ereditato da TreeList)
Metodo protetto | GetAllowChangeBandParent | (Ereditato da TreeList)
Metodo protetto | GetAllowColumnFilterPopup | (Ereditato da TreeList)
Metodo protetto | GetAllowFilterEditor | (Ereditato da TreeList)
Metodo protetto | GetAllowFindColumn | (Ereditato da TreeList)
Metodo protetto | GetAllowFocus | (Ereditato da TreeList)
Metodo protetto | GetAllowHighlightFindResults | (Ereditato da TreeList)
Metodo protetto | GetAllowMRUFilterList | (Ereditato da TreeList)
Metodo protetto | GetAutoFilterRowColumnEdit | (Ereditato da TreeList)
Metodo pubblico | GetAutoFilterValue | (Ereditato da TreeList)
Metodo protetto | GetAutoNodeHeight | (Ereditato da TreeList)
Metodo protetto | GetBandRows | (Ereditato da TreeList)
Metodo protetto | GetBandRowsCore | (Ereditato da TreeList)
Metodo protetto | GetBandVisibleIndex | (Ereditato da TreeList)
Metodo protetto | GetCanShowEditor | (Ereditato da TreeList)
Metodo pubblico | GetColumnByColumnHandle | (Ereditato da TreeList)
Metodo pubblico | GetColumnByVisibleIndex | (Ereditato da TreeList)
Metodo protetto | GetColumnDefaultRepositoryItem | (Ereditato da TreeList)
Metodo protetto | GetColumnDefaultRepositoryItemForEditing | (Ereditato da TreeList)
Metodo protetto | GetColumnEdit | (Ereditato da TreeList)
Metodo protetto | GetColumnEditForEditing | (Ereditato da TreeList)
Metodo pubblico | GetColumnError(TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | GetColumnError(TreeListColumn, TreeListNode) | (Ereditato da TreeList)
Metodo pubblico | GetColumnErrorType(TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | GetColumnErrorType(TreeListColumn, TreeListNode) | (Ereditato da TreeList)
Metodo protetto | GetColumnFieldNameSort | (Ereditato da TreeList)
Metodo protetto | GetColumnFilterCriteria | (Ereditato da TreeList)
Metodo protetto | GetColumnFilterMode | (Ereditato da TreeList)
Metodo pubblico | GetColumnHeaderBestWidth | (Ereditato da TreeList)
Metodo protetto | GetColumnName | (Ereditato da TreeList)
Metodo protetto | GetCurrencyManager | (Ereditato da TreeList)
Metodo protetto | GetDataColumnInfo | (Ereditato da TreeList)
Metodo pubblico | GetDataRecordByNode | (Ereditato da TreeList)
Metodo pubblico | GetDataRow | (Ereditato da TreeList)
Metodo protetto | GetDirectXDeviceBackColor | (Ereditato da EditorContainer)
Metodo protetto | GetDirectXProvider | (Ereditato da EditorContainer)
Metodo protetto | GetEditableObject | (Ereditato da TreeList)
Metodo pubblico | GetEditorShowMode | (Ereditato da TreeList)
Metodo protetto | GetEditorViewInfo | (Ereditato da TreeList)
Metodo protetto | GetFilterColumn | (Ereditato da TreeList)
Metodo protetto | GetFilterColumnByTreeListColumn | (Ereditato da TreeList)
Metodo protetto | GetFilterCriteriaDisplayStyle | (Ereditato da TreeList)
Metodo protetto | GetFilterDisplayText | (Ereditato da TreeList)
Metodo protetto | GetFilterDisplayTextByColumn | (Ereditato da TreeList)
Metodo protetto | GetFilterPopupTexts | (Ereditato da TreeList)
Metodo protetto | GetFilterPopupValues(TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | GetFilterPopupValues(TreeListColumn, Boolean) | (Ereditato da TreeList)
Metodo protetto | GetFilterPopupValues(TreeListColumn, CriteriaOperator, Boolean) | (Ereditato da TreeList)
Metodo protetto | GetFilterPopupValues(TreeListColumn, Boolean, Boolean) | (Ereditato da TreeList)
Metodo protetto | GetFilterRowValue(Object) | (Ereditato da TreeList)
Metodo protetto | GetFilterRowValue(TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | GetFindMatchedRanges | (Ereditato da TreeList)
Metodo protetto | GetFindMatchedText | (Ereditato da TreeList)
Metodo protetto | GetFindToColumnsCollection | (Ereditato da TreeList)
Metodo pubblico | GetFocusedDataRow | (Ereditato da TreeList)
Metodo pubblico | GetFocusedDisplayText | (Ereditato da TreeList)
Metodo pubblico | GetFocusedRow | (Ereditato da TreeList)
Metodo pubblico | GetFocusedRowCellDisplayText(String) | (Ereditato da TreeList)
Metodo pubblico | GetFocusedRowCellDisplayText(TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetFocusedRowCellValue(String) | (Ereditato da TreeList)
Metodo pubblico | GetFocusedRowCellValue(TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetGroupSummaryValue | (Ereditato da TreeList)
Metodo protetto | GetHeaderFilterButtonShowMode | (Ereditato da TreeList)
Metodo pubblico | GetHitInfo | Obsoleto. (Ereditato da TreeList)
Metodo protetto | GetImageIndexFromDataSource | (Ereditato da TreeList)
Metodo protetto | GetMaxIndent | (Ereditato da TreeList)
Metodo protetto | GetNativePreviewText | (Ereditato da TreeList)
Metodo pubblico | GetNodeAt(Point) | (Ereditato da TreeList)
Metodo pubblico | GetNodeAt(Int32, Int32) | (Ereditato da TreeList)
Metodo pubblico | GetNodeByVisibleIndex | (Ereditato da TreeList)
Metodo protetto | GetNodeCellRepositoryItem | (Ereditato da TreeList)
Metodo protetto | GetNodeComparer(IComparerTreeListNode) | (Ereditato da TreeList)
Metodo protetto | GetNodeComparer(TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetNodeIndex | (Ereditato da TreeList)
Metodo pubblico | GetNodeList | (Ereditato da TreeList)
Metodo protetto | GetNodeValue(TreeListNode, TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | GetNodeValue(TreeListNode, Object) | (Ereditato da TreeList)
Metodo protetto | GetNodeValue(TreeListNode, String) | (Ereditato da TreeList)
Metodo protetto | GetNonFormattedCaption | (Ereditato da TreeList)
Metodo protetto | GetParentColumnFieldNameSort | (Ereditato da TreeList)
Metodo pubblico | GetRow | (Ereditato da TreeList)
Metodo pubblico | GetRowCellDisplayText(TreeListNode, TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetRowCellDisplayText(TreeListNode, String) | (Ereditato da TreeList)
Metodo pubblico | GetRowCellValue(TreeListNode, TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetRowCellValue(TreeListNode, String) | (Ereditato da TreeList)
Metodo protetto | GetRowsAsFootersCount | (Ereditato da TreeList)
Metodo pubblico | GetScrollAnnotations | (Ereditato da TreeList)
Metodo pubblico | GetSelectedCells | (Ereditato da TreeList)
Metodo pubblico | GetSelectedCells(TreeListNode) | (Ereditato da TreeList)
Metodo protetto | GetShowBandsMode | (Ereditato da TreeList)
Metodo protetto | GetShowFirstLines | (Ereditato da TreeList)
Metodo protetto | GetShowIndentAsRowStyle | (Ereditato da TreeList)
Metodo pubblico | GetSortColumn(Int32) | (Ereditato da TreeList)
Metodo protetto | GetSortColumn(TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetSummaryValue(TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | GetSummaryValue(TreeListColumn, Boolean) | (Ereditato da TreeList)
Metodo protetto | GetSummaryValueCore | (Ereditato da TreeList)
Metodo protetto | GetSummaryValueEx | (Ereditato da TreeList)
Metodo pubblico | GetToolTipController | (Ereditato da EditorContainer)
Metodo protetto | GetUseDirectXPaint | (Ereditato da TreeList)
Metodo pubblico | GetVisibleIndexByNode | (Ereditato da TreeList)
Metodo protetto | GetVisibleIndexByNodeCore | (Ereditato da TreeList)
Metodo protetto | GetVisibleParentNodesCount | (Ereditato da TreeList)
Metodo pubblico | HideCustomization | (Ereditato da TreeList)
Metodo pubblico | HideEditor | (Ereditato da TreeList)
Metodo protetto | HideEditorCore | (Ereditato da TreeList)
Metodo pubblico | HideFindPanel | (Ereditato da TreeList)
Metodo pubblico | HideLoadingPanel | (Ereditato da TreeList)
Metodo protetto | HookOnLoaded | (Ereditato da EditorContainer)
Metodo pubblico | ImportFromXml(Stream) | (Ereditato da TreeList)
Metodo pubblico | ImportFromXml(String) | (Ereditato da TreeList)
Metodo protetto | ImportFromXmlCore | (Ereditato da TreeList)
Metodo pubblico | IndentNodes | (Ereditato da TreeList)
Metodo protetto | InitFindPanel | (Ereditato da TreeList)
Metodo protetto | InitializeDirectXProvider | (Ereditato da EditorContainer)
Metodo protetto | InitScrollInfo | (Ereditato da TreeList)
Metodo protetto | InternalDeleteNode | (Ereditato da TreeList)
Metodo protetto | InternalDeleteNodeCore | (Ereditato da TreeList)
Metodo protetto | InternalDeleteNodes(DictionaryTreeListNodes, ListTreeListNode) | (Ereditato da TreeList)
Metodo protetto | InternalDeleteNodes(TreeListNodes) | (Ereditato da TreeList)
Metodo protetto | InternalFullCollapseNode | (Ereditato da TreeList)
Metodo protetto | InternalFullExpandNode | (Ereditato da TreeList)
Metodo protetto | InternalGetCustomNodeCellEdit | (Ereditato da TreeList)
Metodo protetto | InternalGetCustomNodeCellStyle | (Ereditato da TreeList)
Metodo pubblico | InternalGetService | (Ereditato da TreeList)
Metodo protetto | InternalNodeAdded | (Ereditato da TreeList)
Metodo protetto | InternalNodeChanged | (Ereditato da TreeList)
Metodo protetto | InternalSetTopVisibleNodePixel | (Ereditato da TreeList)
Metodo pubblico | InvalidateBand | (Ereditato da TreeList)
Metodo pubblico | InvalidateBandPanel | (Ereditato da TreeList)
Metodo pubblico | InvalidateCell | (Ereditato da TreeList)
Metodo pubblico | InvalidateColumnHeader | (Ereditato da TreeList)
Metodo pubblico | InvalidateColumnPanel | (Ereditato da TreeList)
Metodo pubblico | InvalidateFilterPanel | (Ereditato da TreeList)
Metodo pubblico | InvalidateNode | (Ereditato da TreeList)
Metodo pubblico | InvalidateNodes | (Ereditato da TreeList)
Metodo pubblico | InvalidateRow | (Ereditato da TreeList)
Metodo pubblico | InvalidateRowPreview | (Ereditato da TreeList)
Metodo protetto | InvalidateRows | (Ereditato da TreeList)
Metodo pubblico | InvalidateScrollAnnotations | (Ereditato da TreeList)
Metodo pubblico | InvalidateSummaryFooterPanel | (Ereditato da TreeList)
Metodo pubblico | InvokeMenuItemClick | (Ereditato da TreeList)
Metodo protetto | IsAllowDefaultFastBestFit | (Ereditato da TreeList)
Metodo protetto | IsAllowEditForm | (Ereditato da TreeList)
Metodo pubblico | IsAutoFilterNode | (Ereditato da TreeList)
Metodo pubblico | IsCellSelected | (Ereditato da TreeList)
Metodo protetto | IsColumnAllowAutoFilter | (Ereditato da TreeList)
Metodo protetto | IsColumnAllowFilter | (Ereditato da TreeList)
Metodo pubblico | IsColumnAllowFilterEditor | (Ereditato da TreeList)
Metodo protetto | IsColumnFieldNameSortExist | (Ereditato da TreeList)
Metodo protetto | IsColumnFiltered | (Ereditato da TreeList)
Metodo protetto | IsFilterByDisplayText | (Ereditato da TreeList)
Metodo protetto | IsFilterRow | (Ereditato da TreeList)
Metodo protetto | IsImplyNullLikeEmptyStringWhenFiltering | (Ereditato da TreeList)
Metodo protetto | IsInputChar | (Ereditato da TreeList)
Metodo protetto | IsInputKey | (Ereditato da TreeList)
Metodo pubblico | IsNewItemRow | (Ereditato da TreeList)
Metodo protetto | IsParentColumnFieldNameSortExist | (Ereditato da TreeList)
Metodo pubblico | IsRootNode | (Ereditato da TreeList)
Metodo protetto | IsRoundDateTime | (Ereditato da TreeList)
Metodo protetto | IsShowAllValuesInFilterPopup | (Ereditato da TreeList)
Metodo protetto | IsTopNewItemRow | (Ereditato da TreeList)
Metodo protetto | IsUserAutoFilterCondition | (Ereditato da TreeList)
Metodo pubblico | LayoutChanged | (Ereditato da TreeList)
Metodo protetto | LoadDataColumns | (Ereditato da TreeList)
Metodo protetto | LoadDataSource | (Ereditato da TreeList)
Metodo pubblico | LoadState | Ricarica lo stato
Metodo protetto | LockDirectXRendering | (Ereditato da TreeList)
Metodo protetto | LockFilteringUIClientFilterCriteriaBinding | (Ereditato da TreeList)
Metodo pubblico | LockReloadNodes | (Ereditato da TreeList)
Metodo pubblico | MakeColumnVisible | (Ereditato da TreeList)
Metodo protetto | MakeFocusedRowVisible | (Ereditato da TreeList)
Metodo pubblico | MakeNodeVisible | (Ereditato da TreeList)
Metodo protetto | MergeColumnFiltersCore | (Ereditato da TreeList)
Metodo pubblico | MoveFirst | (Ereditato da TreeList)
Metodo protetto | MoveFocusedCell | (Ereditato da TreeList)
Metodo pubblico | MoveLast | (Ereditato da TreeList)
Metodo pubblico | MoveLastVisible | (Ereditato da TreeList)
Metodo pubblico | MoveNext | (Ereditato da TreeList)
Metodo pubblico | MoveNextVisible | (Ereditato da TreeList)
Metodo pubblico | MoveNode(TreeListNode, TreeListNode) | (Ereditato da TreeList)
Metodo pubblico | MoveNode(TreeListNode, TreeListNode, Boolean) | (Ereditato da TreeList)
Metodo pubblico | MoveNode(TreeListNode, TreeListNode, Boolean, Int32) | (Ereditato da TreeList)
Metodo pubblico | MoveNodes | (Ereditato da TreeList)
Metodo protetto | MoveNodesCore | (Ereditato da TreeList)
Metodo pubblico | MovePrev | (Ereditato da TreeList)
Metodo pubblico | MovePrevVisible | (Ereditato da TreeList)
Metodo pubblico | MoveToNextScrollAnnotation | (Ereditato da TreeList)
Metodo pubblico | MoveToParent | (Ereditato da TreeList)
Metodo pubblico | MoveToPrevScrollAnnotation | (Ereditato da TreeList)
Metodo protetto | NormalizeVisibleBandIndices | (Ereditato da TreeList)
Metodo protetto | NormalizeVisibleColumnIndices | (Ereditato da TreeList)
Metodo protetto | OnActiveEditor_GotFocus | (Ereditato da TreeList)
Metodo protetto | OnActiveEditor_LostFocus | (Ereditato da TreeList)
Metodo protetto | OnActiveEditor_Modified | (Ereditato da TreeList)
Metodo protetto | OnActiveEditor_ValueChanged | (Ereditato da TreeList)
Metodo protetto | OnActiveEditor_ValueChanging | (Ereditato da TreeList)
Metodo protetto | OnActiveFilterChanged | (Ereditato da TreeList)
Metodo protetto | OnActiveFilterCriteriaChanged | (Ereditato da TreeList)
Metodo protetto | OnActiveFilterEnabledChanged | (Ereditato da TreeList)
Metodo protetto | OnAfterAddingNode | (Ereditato da TreeList)
Metodo protetto | OnAfterChangeCollapsed | (Ereditato da TreeList)
Metodo protetto | OnAfterChangeExpanded | (Ereditato da TreeList)
Metodo protetto | OnAfterDeletingNodes | (Ereditato da TreeList)
Metodo protetto | OnAllowBandColumnMultiRowChanged | (Ereditato da TreeList)
Metodo protetto | OnAllowSerializationProperty | (Ereditato da TreeList)
Metodo protetto | OnAppearancePrintChanged | (Ereditato da TreeList)
Metodo protetto | OnBandChanged | (Ereditato da TreeList)
Metodo protetto | OnBandCollectionChanged | (Ereditato da TreeList)
Metodo protetto | OnBandColumnCollectionChanged | (Ereditato da TreeList)
Metodo protetto | OnBandFixedChanged | (Ereditato da TreeList)
Metodo protetto | OnBandWidthChanged | (Ereditato da TreeList)
Metodo protetto | OnBeginTouchScroll | (Ereditato da TreeList)
Metodo protetto | OnBindingContextChanged | (Ereditato da TreeList)
Metodo protetto | OnCheckBoxFieldNameChanged | (Ereditato da TreeList)
Metodo protetto | OnClearNodes | (Sovrascrive TreeList.OnClearNodes(TreeListNodes))
Metodo protetto | OnClearNodesComplete | (Ereditato da TreeList)
Metodo protetto | OnClick | (Ereditato da TreeList)
Metodo protetto | OnColumnAdded | (Ereditato da TreeList)
Metodo protetto | OnColumnChanged | (Ereditato da TreeList)
Metodo protetto | OnColumnFilterModeChanged | (Ereditato da TreeList)
Metodo protetto | OnColumnFilterRestored | (Ereditato da TreeList)
Metodo protetto | OnColumnInfosPopulated | (Ereditato da TreeList)
Metodo protetto | OnColumnRemoved | (Ereditato da TreeList)
Metodo protetto | OnColumnRowIndexChanged | (Ereditato da TreeList)
Metodo protetto | OnColumnsChanged | (Ereditato da TreeList)
Metodo protetto | OnColumnUnboundChanged | (Ereditato da TreeList)
Metodo protetto | OnColumnUnboundExpressionChanged | (Ereditato da TreeList)
Metodo protetto | OnContainerEnter | (Ereditato da EditorContainer)
Metodo protetto | OnContainerLeave | (Ereditato da EditorContainer)
Metodo protetto | OnContextMenuKey | (Ereditato da TreeList)
Metodo protetto | OnCreateControl | (Ereditato da EditorContainer)
Metodo protetto | OnDataListChanged | (Ereditato da TreeList)
Metodo protetto | OnDesignerHost_LoadComplete | (Ereditato da EditorContainer)
Metodo protetto | OnDesignerHost_TransactionClosed | (Ereditato da EditorContainer)
Metodo protetto | OnDirectXPaintDisabled | (Ereditato da TreeList)
Metodo protetto | OnDoubleClick | (Ereditato da TreeList)
Metodo protetto | OnDragDrop | (Ereditato da TreeList)
Metodo protetto | OnDragEnter | (Ereditato da TreeList)
Metodo protetto | OnDragLeave | (Ereditato da TreeList)
Metodo protetto | OnDragOver | (Ereditato da TreeList)
Metodo protetto | OnEnabledChanged | (Ereditato da TreeList)
Metodo protetto | OnEndInit | (Ereditato da EditorContainer)
Metodo protetto | OnEndSerializing | (Ereditato da TreeList)
Metodo protetto | OnEndSorting | (Ereditato da TreeList)
Metodo protetto | OnEnter | (Ereditato da EditorContainer)
Metodo protetto | OnErrorInfo_Changed | (Ereditato da TreeList)
Metodo protetto | OnFilterRowValueChanging | (Ereditato da TreeList)
Metodo protetto | OnFirstInit | (Ereditato da EditorContainer)
Metodo protetto | OnFormatConditionChanged | (Ereditato da TreeList)
Metodo protetto | OnFormatRuleExpressionEditorCreated | (Ereditato da TreeList)
Metodo protetto | OnFormatRulesCollectionChanged | (Ereditato da TreeList)
Metodo protetto | OnGotCapture | (Ereditato da EditorContainer)
Metodo protetto | OnGotFocus | (Ereditato da TreeList)
Metodo protetto | OnHandleCreated | (Ereditato da TreeList)
Metodo protetto | OnHandleDestroyed | (Ereditato da TreeList)
Metodo protetto | OnHorizontalTouchScroll | (Ereditato da TreeList)
Metodo protetto | OnHScroll | (Ereditato da TreeList)
Metodo protetto | OnItemAdded | (Ereditato da TreeList)
Metodo protetto | OnItemAdding | (Ereditato da TreeList)
Metodo protetto | OnItemChanged(Int32, PropertyDescriptor) | (Ereditato da TreeList)
Metodo protetto | OnItemChanged(Int32, PropertyDescriptor, TreeListNode) | (Ereditato da TreeList)
Metodo protetto | OnItemDeleted | (Ereditato da TreeList)
Metodo protetto | OnItemMoved | (Ereditato da TreeList)
Metodo protetto | OnKeyDown | (Ereditato da TreeList)
Metodo protetto | OnKeyPress | (Ereditato da TreeList)
Metodo protetto | OnKeyUp | (Ereditato da TreeList)
Metodo protetto | OnLeave | (Ereditato da EditorContainer)
Metodo protetto | OnLoaded | (Ereditato da TreeList)
Metodo protetto | OnLoadedCore | (Ereditato da TreeList)
Metodo protetto | OnLookAndFeelChanged(LookAndFeelChangedEventArgs) | (Ereditato da TreeList)
Metodo protetto | OnLookAndFeelChanged(Object, EventArgs) | (Ereditato da EditorContainer)
Metodo protetto | OnLostCapture | (Ereditato da TreeList)
Metodo protetto | OnLostFocus | (Ereditato da TreeList)
Metodo protetto | OnMenuShowing | (Ereditato da TreeList)
Metodo protetto | OnMouseClick | (Ereditato da EditorContainer)
Metodo protetto | OnMouseDoubleClick | (Ereditato da EditorContainer)
Metodo protetto | OnMouseDown | (Ereditato da TreeList)
Metodo protetto | OnMouseEnter | (Ereditato da TreeList)
Metodo protetto | OnMouseHWheel | (Ereditato da EditorContainer)
Metodo protetto | OnMouseLeave | (Ereditato da TreeList)
Metodo protetto | OnMouseMove | (Ereditato da TreeList)
Metodo protetto | OnMouseUp | (Ereditato da TreeList)
Metodo protetto | OnMouseWheel | (Ereditato da EditorContainer)
Metodo protetto | OnMouseWheelCore | (Ereditato da TreeList)
Metodo protetto | OnNodeCheckedChanged | (Ereditato da TreeList)
Metodo protetto | OnNodeRemoved | (Ereditato da TreeList)
Metodo protetto | OnNodesLoaded | (Ereditato da TreeList)
Metodo protetto | OnNodesLoading | (Ereditato da TreeList)
Metodo protetto | OnNodesRemoved | (Ereditato da TreeList)
Metodo protetto | OnOptionsBehaviorChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsCustomizationChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsDragAndDropChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsEditFormChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsFilterChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsFindChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsHtmlChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsNavigationChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsPrintChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsScrollAnnotationsChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsSelectionChanged | (Ereditato da TreeList)
Metodo protetto | OnOptionsViewChanged | (Ereditato da TreeList)
Metodo protetto | OnPaint | ATTENZIONE! Questo override serve per proteggere dalla X rossa del controllo in apertura dei documenti nei casi in cui il DFS è attivo. Pur non essendo consigliato abbiamo optato per questa strada in quanto ci permette di avere l'icona dello stato documentale sempre aggiornata. Vedi discussione collegata nel forum devexpress T554890. (Sovrascrive TreeList.OnPaint(PaintEventArgs))
Metodo protetto | OnPaintBackground | (Ereditato da TreeList)
Metodo protetto | OnParentChanged | (Ereditato da TreeList)
Metodo protetto | OnPressedBandChanged | (Ereditato da TreeList)
Metodo protetto | OnPrintProgress | (Ereditato da TreeList)
Metodo protetto | OnPropertyChanged | (Ereditato da TreeList)
Metodo protetto | OnPropertyDescriptorChanged | (Ereditato da TreeList)
Metodo protetto | OnQueryContinueDrag | (Ereditato da TreeList)
Metodo protetto | OnRepositoryItemRefreshRequired | (Ereditato da TreeList)
Metodo protetto | OnReset | (Ereditato da TreeList)
Metodo protetto | OnResetSerializationProperties | (Ereditato da TreeList)
Metodo protetto | OnResize | (Ereditato da TreeList)
Metodo protetto | OnRightToLeftChanged | (Ereditato da TreeList)
Metodo protetto | OnRightToLeftChanged(EventArgs) | (Ereditato da EditorContainer)
Metodo protetto | OnScaleControl | (Ereditato da TreeList)
Metodo protetto | OnScaleTreeListCore | (Ereditato da TreeList)
Metodo protetto | OnSelectionChanged | (Ereditato da TreeList)
Metodo protetto | OnSetValue | (Ereditato da TreeList)
Metodo protetto | OnSortModeChanged | (Ereditato da TreeList)
Metodo protetto | OnSourceItemChanged | (Ereditato da TreeList)
Metodo protetto | OnStartSerializing | (Ereditato da TreeList)
Metodo protetto | OnStartSorting | (Ereditato da TreeList)
Metodo protetto | OnSystemColorsChanged | (Ereditato da TreeList)
Metodo protetto | OnToolTipControllerDisposed | (Ereditato da EditorContainer)
Metodo protetto | OnTouchScroll | (Ereditato da TreeList)
Metodo protetto | OnTouchZoom | (Ereditato da TreeList)
Metodo protetto | OnValidated | (Ereditato da EditorContainer)
Metodo protetto | OnValidating | (Ereditato da TreeList)
Metodo protetto | OnVerticalTouchScroll | (Ereditato da TreeList)
Metodo protetto | OnVisibleChanged | (Ereditato da TreeList)
Metodo protetto | OnVScroll | (Ereditato da TreeList)
Metodo protetto | OnVScrollCore | (Ereditato da TreeList)
Metodo pubblico | OutdentNodes | (Ereditato da TreeList)
Metodo protetto | ParseAutoFilter | (Ereditato da TreeList)
Metodo protetto | ParseAutoFilterValues | (Ereditato da TreeList)
Metodo pubblico | PasteFromClipboard | (Ereditato da TreeList)
Metodo pubblico | PopulateColumns | (Ereditato da TreeList)
Metodo pubblico | PostEditor | (Ereditato da TreeList)
Metodo protetto | PostEditor(Boolean) | (Ereditato da TreeList)
Metodo pubblico | Print | (Ereditato da TreeList)
Metodo protetto | PrintCore | (Ereditato da TreeList)
Metodo pubblico | PrintDialog | (Ereditato da TreeList)
Metodo protetto | PrintDialogCore | (Ereditato da TreeList)
Metodo protetto | ProcessControlTab | (Ereditato da TreeList)
Metodo protetto | ProcessControlTab(Boolean) | (Ereditato da TreeList)
Metodo protetto | ProcessDialogKey | (Ereditato da TreeList)
Metodo protetto | ProcessDirectXPaint | (Ereditato da TreeList)
Metodo protetto | RaiseAfterCheckNode | (Ereditato da TreeList)
Metodo protetto | RaiseAfterCollapse | (Ereditato da TreeList)
Metodo protetto | RaiseAfterDragNode | (Ereditato da TreeList)
Metodo protetto | RaiseAfterDropNode | (Ereditato da TreeList)
Metodo protetto | RaiseAfterExpand | (Ereditato da TreeList)
Metodo protetto | RaiseAfterFocusNode | (Ereditato da TreeList)
Metodo protetto | RaiseBandPositionChanged | (Ereditato da TreeList)
Metodo protetto | RaiseBandWidthChanged | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeCheckNode | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeCollapse | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeDragNode | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeDropNode | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeExpand | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeFocusNode | (Ereditato da TreeList)
Metodo protetto | RaiseBeforeLoadLayout | (Ereditato da TreeList)
Metodo protetto | RaiseCalcNodeDragImageIndex | (Ereditato da TreeList)
Metodo protetto | RaiseCalcNodeHeight(TreeListNode, Int32) | (Ereditato da TreeList)
Metodo protetto | RaiseCalcNodeHeight(TreeListNode, RowInfo, Int32) | (Ereditato da TreeList)
Metodo protetto | RaiseCellValueChanged | (Ereditato da TreeList)
Metodo protetto | RaiseCellValueChanging | (Ereditato da TreeList)
Metodo protetto | RaiseCheckedColumnFilterPopupEvent | (Ereditato da TreeList)
Metodo protetto | RaiseClipboardNodeCopying | (Ereditato da TreeList)
Metodo protetto | RaiseClipboardNodePasting | (Ereditato da TreeList)
Metodo protetto | RaiseColumnButtonClick | (Ereditato da TreeList)
Metodo protetto | RaiseColumnChanged | (Ereditato da TreeList)
Metodo protetto | RaiseColumnFilterChanged | (Ereditato da TreeList)
Metodo protetto | RaiseColumnFilterPopupEvent | (Ereditato da TreeList)
Metodo protetto | RaiseColumnPositionChanged | (Ereditato da TreeList)
Metodo protetto | RaiseColumnUnboundExpressionChanged | (Ereditato da TreeList)
Metodo protetto | RaiseColumnWidthChanged | (Ereditato da TreeList)
Metodo protetto | RaiseCompareNodeValues | (Ereditato da TreeList)
Metodo protetto | RaiseCreateCustomNode | (Ereditato da TreeList)
Metodo protetto | RaiseCustomColumnDisplayText(CustomColumnDisplayTextEventArgs) | (Ereditato da TreeList)
Metodo protetto | RaiseCustomColumnDisplayText(TreeListNode, CellInfo) | (Ereditato da TreeList)
Metodo protetto | RaiseCustomColumnDisplayText(TreeListNode, TreeListColumn, BaseEditViewInfo) | (Ereditato da TreeList)
Metodo protetto | RaiseCustomColumnDisplayText(TreeListNode, TreeListColumn, Object, String) | (Ereditato da TreeList)
Metodo protetto | RaiseCustomColumnSort | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawBandHeader | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawColumnHeader | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawEmptyArea | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawFilterPanel | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawFooter | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawFooterCell | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodeButton | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodeCell | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodeCheckBox | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodeImages | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodeIndent | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodeIndicator | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawNodePreview | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawRow | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawRowFooter | (Ereditato da TreeList)
Metodo protetto | RaiseCustomDrawRowFooterCell | (Ereditato da TreeList)
Metodo protetto | RaiseCustomFilterDisplayText | (Ereditato da TreeList)
Metodo protetto | RaiseCustomizationFormSearch | (Ereditato da TreeList)
Metodo protetto | RaiseCustomizeNewNodeFromOuterData | (Ereditato da TreeList)
Metodo protetto | RaiseCustomRowFilter | (Ereditato da TreeList)
Metodo protetto | RaiseCustomRowFilterEvent | (Ereditato da TreeList)
Metodo protetto | RaiseCustomUnboundColumnData | (Ereditato da TreeList)
Metodo protetto | RaiseDataSourceChanged | (Ereditato da TreeList)
Metodo protetto | RaiseDefaultPaintHelperChanged | (Ereditato da TreeList)
Metodo protetto | RaiseDragCancelNode | (Ereditato da TreeList)
Metodo protetto | RaiseDragObjectDrop | (Ereditato da TreeList)
Metodo protetto | RaiseDragObjectOver | (Ereditato da TreeList)
Metodo protetto | RaiseDragObjectStart | (Ereditato da TreeList)
Metodo protetto | RaiseEditFormHidden | (Ereditato da TreeList)
Metodo protetto | RaiseEditFormPrepared | (Ereditato da TreeList)
Metodo protetto | RaiseEditFormShowing | (Ereditato da TreeList)
Metodo protetto | RaiseEditorKeyDown | (Ereditato da TreeList)
Metodo protetto | RaiseEditorKeyPress | (Ereditato da EditorContainer)
Metodo protetto | RaiseEditorKeyUp | (Ereditato da EditorContainer)
Metodo protetto | RaiseEndSorting | (Ereditato da TreeList)
Metodo protetto | RaiseExcelColumnFilterPopupEvent | (Ereditato da TreeList)
Metodo protetto | RaiseFilterEditorCreated | (Ereditato da TreeList)
Metodo protetto | RaiseFilterExpressionEditorCreated | (Ereditato da TreeList)
Metodo protetto | RaiseFilterNodeEvent | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupDate | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelCustomizeTemplate | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelData(FilterPopupExcelDataEventArgs) | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelData(TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelData(TreeListColumn, CriteriaOperator) | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelData(TreeListColumn, TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelParseFilterCriteria | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelPrepareTemplate | (Ereditato da TreeList)
Metodo protetto | RaiseFilterPopupExcelQueryFilterCriteria | (Ereditato da TreeList)
Metodo protetto | RaiseFocusedColumnChanged | (Ereditato da TreeList)
Metodo protetto | RaiseFocusedNodeChanged | (Ereditato da TreeList)
Metodo protetto | RaiseGetCustomAnnotations | (Ereditato da TreeList)
Metodo protetto | RaiseGetCustomNodeCellEdit | (Ereditato da TreeList)
Metodo protetto | RaiseGetCustomNodeCellStyle | (Ereditato da TreeList)
Metodo protetto | RaiseGetCustomSummaryValue | (Ereditato da TreeList)
Metodo protetto | RaiseGetNodeDisplayValue | (Ereditato da TreeList)
Metodo protetto | RaiseGetPreviewText | (Ereditato da TreeList)
Metodo protetto | RaiseGetPrintCustomSummaryValue | (Ereditato da TreeList)
Metodo protetto | RaiseGetPrintPreviewText | (Ereditato da TreeList)
Metodo protetto | RaiseGetSelectImage | (Ereditato da TreeList)
Metodo protetto | RaiseGetStateImage | (Ereditato da TreeList)
Metodo protetto | RaiseHiddenEditor | (Ereditato da TreeList)
Metodo protetto | RaiseHideCustomizationForm | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementBlur | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementFocus | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseClick | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseDoubleClick | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseDown | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseMove | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseOut | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseOver | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlElementMouseUp | (Ereditato da TreeList)
Metodo protetto | RaiseHtmlSelectedTextChanged | (Ereditato da TreeList)
Metodo protetto | RaiseInitNewRow | (Ereditato da TreeList)
Metodo protetto | RaiseInvalidNodeException | (Ereditato da TreeList)
Metodo protetto | RaiseInvalidValueException | (Ereditato da TreeList)
Metodo protetto | RaiseLayoutUpdated | (Ereditato da TreeList)
Metodo protetto | RaiseLayoutUpgrade | (Ereditato da TreeList)
Metodo protetto | RaiseLeftCoordChanged | (Ereditato da TreeList)
Metodo protetto | RaiseLoad | (Ereditato da TreeList)
Metodo protetto | RaiseMeasurePreviewHeight | (Ereditato da TreeList)
Metodo protetto | RaiseNodeChanged | (Ereditato da TreeList)
Metodo protetto | RaiseNodesReloaded | (Ereditato da TreeList)
Metodo protetto | RaisePaintEx | (Ereditato da TreeList)
Metodo protetto | RaiseParseFindPanelText | (Ereditato da TreeList)
Metodo protetto | RaisePopupMenuShowing | (Ereditato da TreeList)
Metodo protetto | RaisePrintExportProgress | (Ereditato da TreeList)
Metodo protetto | RaiseQueryCustomFunctions | (Ereditato da TreeList)
Metodo protetto | RaiseRequireHideEditor | (Ereditato da EditorContainer)
Metodo protetto | RaiseRowCellClick | (Ereditato da TreeList)
Metodo protetto | RaiseRowClick | (Ereditato da TreeList)
Metodo protetto | RaiseRowSelectImageClick | (Ereditato da TreeList)
Metodo protetto | RaiseRowStateImageClick | (Ereditato da TreeList)
Metodo protetto | RaiseSelectImageClick | (Ereditato da TreeList)
Metodo protetto | RaiseSelectionChanged | (Ereditato da TreeList)
Metodo protetto | RaiseSelectionChanging | (Ereditato da TreeList)
Metodo protetto | RaiseShowCustomizationForm | (Ereditato da TreeList)
Metodo protetto | RaiseShowingEditor | (Ereditato da TreeList)
Metodo protetto | RaiseShownEditor | (Ereditato da TreeList)
Metodo protetto | RaiseShowTreeListMenu | Obsoleto. (Ereditato da TreeList)
Metodo protetto | RaiseStartSorting | (Ereditato da TreeList)
Metodo protetto | RaiseStateChanged | (Ereditato da TreeList)
Metodo protetto | RaiseStateImageClick | (Ereditato da TreeList)
Metodo protetto | RaiseSubstituteFilter | (Ereditato da TreeList)
Metodo protetto | RaiseTopVisibleNodeIndexChanged | (Ereditato da TreeList)
Metodo protetto | RaiseTreeListMenuItemClick | (Ereditato da TreeList)
Metodo protetto | RaiseUnboundExpressionEditorCreated | (Ereditato da TreeList)
Metodo protetto | RaiseValidateNode | (Ereditato da TreeList)
Metodo protetto | RaiseValidatingEditor | (Ereditato da TreeList)
Metodo protetto | RecalcSortColumns | (Ereditato da TreeList)
Metodo protetto | RecreateRowsInfoCore | (Ereditato da TreeList)
Metodo pubblico | Refresh | (Ereditato da TreeList)
Metodo pubblico | Refresh(Boolean) | (Ereditato da TreeList)
Metodo pubblico | RefreshCell | (Ereditato da TreeList)
Metodo protetto | RefreshCellCore | (Ereditato da TreeList)
Metodo protetto | RefreshColumnsInfo | (Ereditato da TreeList)
Metodo pubblico | RefreshDataSource | (Ereditato da TreeList)
Metodo pubblico | RefreshEditor | (Ereditato da TreeList)
Metodo protetto | RefreshEditorError | (Ereditato da TreeList)
Metodo protetto | RefreshHeadersInfo | (Ereditato da TreeList)
Metodo protetto | RefreshHtmlNodeCore | (Ereditato da TreeList)
Metodo pubblico | RefreshNode | (Ereditato da TreeList)
Metodo protetto | RefreshNodeCore | (Ereditato da TreeList)
Metodo protetto | RefreshRowsInfo | (Ereditato da TreeList)
Metodo protetto | RefreshRowsInfo(Boolean, Boolean) | (Ereditato da TreeList)
Metodo pubblico | RefreshScrollAnnotations(ScrollAnnotationKind) | (Ereditato da TreeList)
Metodo pubblico | RefreshScrollAnnotations(ScrollAnnotationKind, Int32) | (Ereditato da TreeList)
Metodo protetto | RefreshVirtualCellCore | (Ereditato da TreeList)
Metodo protetto | RefreshVirtualNodeCore | (Ereditato da TreeList)
Metodo protetto | RejectCurrentChanges | (Ereditato da TreeList)
Metodo protetto | RemoveFromDefaultTooltipController | (Ereditato da EditorContainer)
Metodo protetto | RemoveHookOnLoaded | (Ereditato da EditorContainer)
Metodo protetto | RemoveNodeHeight | (Ereditato da TreeList)
Metodo protetto | RequestCellEditor | (Ereditato da TreeList)
Metodo protetto | ResetAccessibility | (Ereditato da TreeList)
Metodo pubblico | ResetAutoFilterCondition | (Ereditato da TreeList)
Metodo pubblico | ResetAutoFilterConditions | (Ereditato da TreeList)
Metodo pubblico | ResetAutoFilterConditions(IEnumerableTreeListColumn) | (Ereditato da TreeList)
Metodo protetto | ResetAutoFilterConditionsCore | (Ereditato da TreeList)
Metodo protetto | ResetColumnAutoFilterConditions | (Ereditato da TreeList)
Metodo pubblico | ResetEditorsCache(RepositoryItem) | (Ereditato da EditorContainer)
Metodo pubblico | ResetEditorsCache(Type) | (Ereditato da EditorContainer)
Metodo protetto | ResetExcelFilteringProvider | (Ereditato da TreeList)
Metodo protetto | ResetLookAndFeel | (Ereditato da EditorContainer)
Metodo protetto | ResetRowCount | (Ereditato da TreeList)
Metodo protetto | ResetSortedColumns | (Ereditato da TreeList)
Metodo protetto | ResizeBand | (Ereditato da TreeList)
Metodo protetto | ResizeColumn | (Ereditato da TreeList)
Metodo protetto | ResolveAutoFilterCondition | (Ereditato da TreeList)
Metodo protetto | RestoreLayoutCore | (Ereditato da TreeList)
Metodo pubblico | RestoreLayoutFromRegistry(String) | (Ereditato da TreeList)
Metodo pubblico | RestoreLayoutFromRegistry(String, OptionsLayoutBase) | (Ereditato da TreeList)
Metodo pubblico | RestoreLayoutFromStream(Stream) | (Ereditato da TreeList)
Metodo pubblico | RestoreLayoutFromStream(Stream, OptionsLayoutBase) | (Ereditato da TreeList)
Metodo pubblico | RestoreLayoutFromXml(String) | (Ereditato da TreeList)
Metodo pubblico | RestoreLayoutFromXml(String, OptionsLayoutBase) | (Ereditato da TreeList)
Metodo protetto | RestoreNodesData | (Ereditato da TreeList)
Metodo protetto | SaveLayoutCore | (Ereditato da TreeList)
Metodo pubblico | SaveLayoutToRegistry(String) | (Ereditato da TreeList)
Metodo pubblico | SaveLayoutToRegistry(String, OptionsLayoutBase) | (Ereditato da TreeList)
Metodo pubblico | SaveLayoutToStream(Stream) | (Ereditato da TreeList)
Metodo pubblico | SaveLayoutToStream(Stream, OptionsLayoutBase) | (Ereditato da TreeList)
Metodo pubblico | SaveLayoutToXml(String) | (Ereditato da TreeList)
Metodo pubblico | SaveLayoutToXml(String, OptionsLayoutBase) | (Ereditato da TreeList)
Metodo protetto | SaveNodesData | (Ereditato da TreeList)
Metodo pubblico | SaveState | Salva lo stato
Metodo protetto | ScaleControl | (Ereditato da EditorContainer)
Metodo protetto | Scrollbar_MouseEnter | (Ereditato da TreeList)
Metodo protetto | Scrollbar_MouseLeave | (Ereditato da TreeList)
Metodo protetto | ScrollHorizontalEx | (Ereditato da TreeList)
Metodo protetto | ScrollVerticalEx | (Ereditato da TreeList)
Metodo pubblico | SelectAll | (Ereditato da TreeList)
Metodo pubblico | SelectCell | (Ereditato da TreeList)
Metodo protetto | SelectCellCore | (Ereditato da TreeList)
Metodo pubblico | SelectCells(Int32, String, Int32, String) | (Ereditato da TreeList)
Metodo pubblico | SelectCells(TreeListNode, TreeListColumn, TreeListNode, TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | SelectNode | (Ereditato da TreeList)
Metodo protetto | SelectNodeCore | (Ereditato da TreeList)
Metodo pubblico | SelectNodes(Int32, Int32) | (Ereditato da TreeList)
Metodo pubblico | SelectNodes(TreeListNode, TreeListNode) | (Ereditato da TreeList)
Metodo protetto | SelectNodesCore | (Ereditato da TreeList)
Metodo protetto | ServiceColumnChanged | (Ereditato da TreeList)
Metodo pubblico | SetAutoFilterValue | (Ereditato da TreeList)
Metodo protetto | SetCellSelection | (Ereditato da TreeList)
Metodo protetto | SetCellSelectionCore | (Ereditato da TreeList)
Metodo pubblico | SetColumnError(TreeListColumn, String) | (Ereditato da TreeList)
Metodo pubblico | SetColumnError(TreeListColumn, String, ErrorType) | (Ereditato da TreeList)
Metodo protetto | SetColumnFixedStyle | (Ereditato da TreeList)
Metodo pubblico | SetColumnPosition | (Ereditato da TreeList)
Metodo protetto | SetColumnVisibleIndex | (Ereditato da TreeList)
Metodo pubblico | SetDefaultBehaviorOptions | (Ereditato da TreeList)
Metodo pubblico | SetDefaultCustomizationOptions | (Ereditato da TreeList)
Metodo pubblico | SetDefaultNavigationOptions | (Ereditato da TreeList)
Metodo pubblico | SetDefaultOptionsView | (Ereditato da TreeList)
Metodo pubblico | SetDefaultPrintOptions | (Ereditato da TreeList)
Metodo pubblico | SetDefaultRowHeight | (Ereditato da TreeList)
Metodo pubblico | SetDefaultSelectionOptions | (Ereditato da TreeList)
Metodo protetto | SetExtraFilter | (Ereditato da TreeList)
Metodo protetto | SetFilterRowValue(Object, Object) | (Ereditato da TreeList)
Metodo protetto | SetFilterRowValue(TreeListColumn, Object) | (Ereditato da TreeList)
Metodo pubblico | SetFocusedNode | (Ereditato da TreeList)
Metodo protetto | SetFocusedNodeCore | (Ereditato da TreeList)
Metodo pubblico | SetFocusedRowCellValue(String, Object) | (Ereditato da TreeList)
Metodo pubblico | SetFocusedRowCellValue(TreeListColumn, Object) | (Ereditato da TreeList)
Metodo protetto | SetFocusedRowIndexCore | (Ereditato da TreeList)
Metodo pubblico | SetFocusedValue | (Ereditato da TreeList)
Metodo pubblico | SetNodeCheckState(TreeListNode, CheckState) | (Ereditato da TreeList)
Metodo pubblico | SetNodeCheckState(TreeListNode, CheckState, Boolean) | (Ereditato da TreeList)
Metodo pubblico | SetNodeIndex | (Ereditato da TreeList)
Metodo protetto | SetNodeIndexCore | (Ereditato da TreeList)
Metodo protetto | SetNodeValue | (Ereditato da TreeList)
Metodo pubblico | SetRowCellValue(TreeListNode, TreeListColumn, Object) | (Ereditato da TreeList)
Metodo pubblico | SetRowCellValue(TreeListNode, String, Object) | (Ereditato da TreeList)
Metodo pubblico | SetSearchControl | (Ereditato da TreeList)
Metodo pubblico | SetSelectionAnchor | (Ereditato da TreeList)
Metodo protetto | SetUseDirectXPaint | (Ereditato da TreeList)
Metodo protetto | ShouldResortNodesOnItemChanged | (Ereditato da TreeList)
Metodo protetto | ShouldSerializeLookAndFeel | (Ereditato da EditorContainer)
Metodo pubblico | ShowAutoFilterConditionsMenu | (Ereditato da TreeList)
Metodo pubblico | ShowContextMenu | (Ereditato da TreeList)
Metodo pubblico | ShowCustomization | (Ereditato da TreeList)
Metodo pubblico | ShowCustomization(Point) | (Ereditato da TreeList)
Metodo pubblico | ShowEditForm | (Ereditato da TreeList)
Metodo protetto | ShowEditFormCore | (Ereditato da TreeList)
Metodo protetto | ShowEditFormDialogCore | (Ereditato da TreeList)
Metodo pubblico | ShowEditor | (Ereditato da TreeList)
Metodo pubblico | ShowEditor(String) | (Ereditato da TreeList)
Metodo pubblico | ShowFilterEditor | (Ereditato da TreeList)
Metodo protetto | ShowFilterExpressionEditor | (Ereditato da TreeList)
Metodo pubblico | ShowFilterPopup | (Ereditato da TreeList)
Metodo pubblico | ShowFindPanel | (Ereditato da TreeList)
Metodo pubblico | ShowLoadingPanel | (Ereditato da TreeList)
Metodo protetto | ShowMenu | (Ereditato da TreeList)
Metodo protetto | ShowMRUFilterPopup | (Ereditato da TreeList)
Metodo pubblico | ShowPrintPreview | (Ereditato da TreeList)
Metodo protetto | ShowPrintPreviewCore | (Ereditato da TreeList)
Metodo protetto | ShowProgressForm | (Ereditato da TreeList)
Metodo pubblico | ShowRibbonPrintPreview | (Ereditato da TreeList)
Metodo protetto | ShowRibbonPrintPreviewCore | (Ereditato da TreeList)
Metodo pubblico | ShowUnboundExpressionEditor | (Ereditato da TreeList)
Metodo pubblico | Sort(TreeListNode, IComparerTreeListNode, Boolean) | (Ereditato da TreeList)
Metodo protetto | Sort(TreeListNodes, Boolean, Boolean) | (Ereditato da TreeList)
Metodo pubblico | Sort(TreeListNode, TreeListColumn, SortOrder, Boolean) | (Ereditato da TreeList)
Metodo pubblico | StartIncrementalSearch | (Ereditato da TreeList)
Metodo protetto | StartOfficeScrolling | (Ereditato da TreeList)
Metodo pubblico | StopIncrementalSearch | (Ereditato da TreeList)
Metodo protetto | StopOfficeScrolling | (Ereditato da TreeList)
Metodo pubblico | UncheckAll | (Ereditato da TreeList)
Metodo protetto | UnlockDirectXRendering | (Ereditato da TreeList)
Metodo pubblico | UnlockReloadNodes | (Ereditato da TreeList)
Metodo pubblico | UnselectCell | (Ereditato da TreeList)
Metodo protetto | UnselectCellCore | (Ereditato da TreeList)
Metodo pubblico | UnselectCells(Int32, String, Int32, String) | (Ereditato da TreeList)
Metodo pubblico | UnselectCells(TreeListNode, TreeListColumn, TreeListNode, TreeListColumn) | (Ereditato da TreeList)
Metodo pubblico | UnselectNode | (Ereditato da TreeList)
Metodo pubblico | UnselectNodes(Int32, Int32) | (Ereditato da TreeList)
Metodo pubblico | UnselectNodes(TreeListNode, TreeListNode) | (Ereditato da TreeList)
Metodo protetto | UpdateActiveFilterInfo | (Ereditato da TreeList)
Metodo protetto | UpdateAutoFilterRowActiveEditor | (Ereditato da TreeList)
Metodo protetto | UpdateBandColumnsIndices | (Ereditato da TreeList)
Metodo protetto | UpdateBandColumnsOrder | (Ereditato da TreeList)
Metodo protetto | UpdateColumnAutoFilter | (Ereditato da TreeList)
Metodo protetto | UpdateColumnsSortIndices | (Ereditato da TreeList)
Metodo protetto | UpdateElementsLookAndFeel | (Ereditato da TreeList)
Metodo protetto | UpdateFilter | (Ereditato da TreeList)
Metodo protetto | UpdateFilterInfo | (Ereditato da TreeList)
Metodo protetto | UpdateFindPanelFilterText | (Ereditato da TreeList)
Metodo protetto | UpdateLayout | (Ereditato da TreeList)
Metodo protetto | UpdateRootBands | (Ereditato da TreeList)
Metodo protetto | UpdateSelectCell | (Ereditato da TreeList)
Metodo protetto | UpdateSelectCell(TreeListNode, TreeListColumn) | (Ereditato da TreeList)
Metodo protetto | UpdateSelectNode | (Ereditato da TreeList)
Metodo protetto | UpdateSelectNode(TreeListNode) | (Ereditato da TreeList)
Metodo protetto | UpdateVScrollBarCore | (Ereditato da TreeList)
Metodo protetto | ValidateAndEndCurrentEdit | (Ereditato da TreeList)
Metodo protetto | WndProc | (Ereditato da TreeList)
Metodo protetto | XtraClearColumns | (Ereditato da TreeList)
Metodo protetto | XtraCreateColumnsItem | (Ereditato da TreeList)
Metodo protetto | XtraFindColumnsItem | (Ereditato da TreeList)
Torna su
Vedi anche

Documentazione

Classe TreeListSafePaint
Namespace DedNet.Controls


Metodo TreeListSafePaint.FilterNodes

Metodo TreeListSafePaintFilterNodes
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | FilterNodes |
Metodo pubblico | FilterNodes(TreeListNodes) |
Torna su
Vedi anche

Documentazione

Classe TreeListSafePaint
Namespace DedNet.Controls


Metodo TreeListSafePaint.FilterNodes

Metodo TreeListSafePaintFilterNodes

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void FilterNodes()
Public Overrides Sub FilterNodes
public:
virtual void FilterNodes() override
abstract FilterNodes : unit -> unit
override FilterNodes : unit -> unit
Vedi anche

Documentazione

Classe TreeListSafePaint
Overload di FilterNodes
Namespace DedNet.Controls


Metodo TreeListSafePaint.LoadState

Metodo TreeListSafePaintLoadState
Ricarica lo stato

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void LoadState()
Public Sub LoadState
public:
void LoadState()
member LoadState : unit -> unit
Vedi anche

Documentazione

Classe TreeListSafePaint
Namespace DedNet.Controls


Metodo TreeListSafePaint.OnClearNodes

Metodo TreeListSafePaintOnClearNodes

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void OnClearNodes(
    TreeListNodes nodes
)
Protected Overrides Sub OnClearNodes (
    nodes As TreeListNodes
)
protected:
virtual void OnClearNodes(
    TreeListNodes^ nodes
) override
abstract OnClearNodes :
        nodes : TreeListNodes -> unit
override OnClearNodes :
        nodes : TreeListNodes -> unit

Parametri

nodes TreeListNodes
Vedi anche

Documentazione

Classe TreeListSafePaint
Namespace DedNet.Controls


Metodo TreeListSafePaint.OnPaint

Metodo TreeListSafePaintOnPaint
ATTENZIONE! Questo override serve per proteggere dalla X rossa del controllo in apertura dei documenti nei casi in cui il DFS è attivo. Pur non essendo consigliato abbiamo optato per questa strada in quanto ci permette di avere l'icona dello stato documentale sempre aggiornata. Vedi discussione collegata nel forum devexpress T554890.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void OnPaint(
    PaintEventArgs e
)
Protected Overrides Sub OnPaint (
    e As PaintEventArgs
)
protected:
virtual void OnPaint(
    PaintEventArgs^ e
) override
abstract OnPaint :
        e : PaintEventArgs -> unit
override OnPaint :
        e : PaintEventArgs -> unit

Parametri

e PaintEventArgs
Vedi anche

Documentazione

Classe TreeListSafePaint
Namespace DedNet.Controls


Metodo TreeListSafePaint.SaveState

Metodo TreeListSafePaintSaveState
Salva lo stato

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SaveState()
Public Sub SaveState
public:
void SaveState()
member SaveState : unit -> unit
Vedi anche

Documentazione

Classe TreeListSafePaint
Namespace DedNet.Controls


Eventi di TreeListSafePaint

Il tipo TreeListSafePaint espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | AfterCheckNode | (Ereditato da TreeList)
Evento pubblico | AfterCollapse | (Ereditato da TreeList)
Evento pubblico | AfterDragNode | (Ereditato da TreeList)
Evento pubblico | AfterDropNode | (Ereditato da TreeList)
Evento pubblico | AfterExpand | (Ereditato da TreeList)
Evento pubblico | AfterFocusNode | (Ereditato da TreeList)
Evento pubblico | BandPositionChanged | (Ereditato da TreeList)
Evento pubblico | BandWidthChanged | (Ereditato da TreeList)
Evento pubblico | BeforeCheckNode | (Ereditato da TreeList)
Evento pubblico | BeforeCollapse | (Ereditato da TreeList)
Evento pubblico | BeforeDragNode | (Ereditato da TreeList)
Evento pubblico | BeforeDropNode | (Ereditato da TreeList)
Evento pubblico | BeforeExpand | (Ereditato da TreeList)
Evento pubblico | BeforeFocusNode | (Ereditato da TreeList)
Evento pubblico | BeforeLoadLayout | (Ereditato da TreeList)
Evento pubblico | CalcNodeDragImageIndex | (Ereditato da TreeList)
Evento pubblico | CalcNodeHeight | (Ereditato da TreeList)
Evento pubblico | CellValueChanged | (Ereditato da TreeList)
Evento pubblico | CellValueChanging | (Ereditato da TreeList)
Evento pubblico | ClipboardNodeCopying | (Ereditato da TreeList)
Evento pubblico | ClipboardNodePasting | (Ereditato da TreeList)
Evento pubblico | ColumnButtonClick | (Ereditato da TreeList)
Evento pubblico | ColumnChanged | (Ereditato da TreeList)
Evento pubblico | ColumnFilterChanged | (Ereditato da TreeList)
Evento pubblico | ColumnPositionChanged | (Ereditato da TreeList)
Evento pubblico | ColumnUnboundExpressionChanged | (Ereditato da TreeList)
Evento pubblico | ColumnWidthChanged | (Ereditato da TreeList)
Evento pubblico | CompareNodeValues | (Ereditato da TreeList)
Evento pubblico | CreateCustomNode | (Ereditato da TreeList)
Evento pubblico | CustomColumnDisplayText | (Ereditato da TreeList)
Evento pubblico | CustomColumnSort | (Ereditato da TreeList)
Evento pubblico | CustomDrawBandHeader | (Ereditato da TreeList)
Evento pubblico | CustomDrawColumnHeader | (Ereditato da TreeList)
Evento pubblico | CustomDrawEmptyArea | (Ereditato da TreeList)
Evento pubblico | CustomDrawFilterPanel | (Ereditato da TreeList)
Evento pubblico | CustomDrawFooter | (Ereditato da TreeList)
Evento pubblico | CustomDrawFooterCell | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodeButton | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodeCell | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodeCheckBox | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodeImages | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodeIndent | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodeIndicator | (Ereditato da TreeList)
Evento pubblico | CustomDrawNodePreview | (Ereditato da TreeList)
Evento pubblico | CustomDrawRow | (Ereditato da TreeList)
Evento pubblico | CustomDrawRowFooter | (Ereditato da TreeList)
Evento pubblico | CustomDrawRowFooterCell | (Ereditato da TreeList)
Evento pubblico | CustomDrawScroll | (Ereditato da TreeList)
Evento pubblico | CustomFilterDisplayText | (Ereditato da TreeList)
Evento pubblico | CustomizationFormSearch | (Ereditato da TreeList)
Evento pubblico | CustomizeNewNodeFromOuterData | (Ereditato da TreeList)
Evento pubblico | CustomizeNodeTemplate | (Ereditato da TreeList)
Evento pubblico | CustomNodeCellEdit | (Ereditato da TreeList)
Evento pubblico | CustomNodeCellEditForEditing | (Ereditato da TreeList)
Evento pubblico | CustomRowFilter | (Ereditato da TreeList)
Evento pubblico | CustomScrollAnnotation | (Ereditato da TreeList)
Evento pubblico | CustomUnboundColumnData | (Ereditato da TreeList)
Evento pubblico | DataSourceChanged | (Ereditato da TreeList)
Evento pubblico | DefaultPaintHelperChanged | (Ereditato da TreeList)
Evento pubblico | DragCancelNode | (Ereditato da TreeList)
Evento pubblico | DragObjectDrop | (Ereditato da TreeList)
Evento pubblico | DragObjectOver | (Ereditato da TreeList)
Evento pubblico | DragObjectStart | (Ereditato da TreeList)
Evento pubblico | EditFormHidden | (Ereditato da TreeList)
Evento pubblico | EditFormPrepared | (Ereditato da TreeList)
Evento pubblico | EditFormShowing | (Ereditato da TreeList)
Evento pubblico | EditorKeyDown | (Ereditato da EditorContainer)
Evento pubblico | EditorKeyPress | (Ereditato da EditorContainer)
Evento pubblico | EditorKeyUp | (Ereditato da EditorContainer)
Evento pubblico | EndSorting | (Ereditato da TreeList)
Evento pubblico | FilterEditorCreated | (Ereditato da TreeList)
Evento pubblico | FilterExpressionEditorCreated | (Ereditato da TreeList)
Evento pubblico | FilterNode | (Ereditato da TreeList)
Evento pubblico | FilterPopupExcelCustomizeTemplate | (Ereditato da TreeList)
Evento pubblico | FilterPopupExcelData | (Ereditato da TreeList)
Evento pubblico | FilterPopupExcelParseFilterCriteria | (Ereditato da TreeList)
Evento pubblico | FilterPopupExcelPrepareTemplate | (Ereditato da TreeList)
Evento pubblico | FilterPopupExcelQueryFilterCriteria | (Ereditato da TreeList)
Evento pubblico | FocusedColumnChanged | (Ereditato da TreeList)
Evento pubblico | FocusedNodeChanged | (Ereditato da TreeList)
Evento pubblico | FormatRuleExpressionEditorCreated | (Ereditato da TreeList)
Evento pubblico | GetCustomNodeCellEdit | Obsoleto. (Ereditato da TreeList)
Evento pubblico | GetCustomNodeCellStyle | Obsoleto. (Ereditato da TreeList)
Evento pubblico | GetCustomSummaryValue | (Ereditato da TreeList)
Evento pubblico | GetNodeDisplayValue | (Ereditato da TreeList)
Evento pubblico | GetPreviewText | (Ereditato da TreeList)
Evento pubblico | GetPrintCustomSummaryValue | (Ereditato da TreeList)
Evento pubblico | GetPrintPreviewText | (Ereditato da TreeList)
Evento pubblico | GetSelectImage | (Ereditato da TreeList)
Evento pubblico | GetStateImage | (Ereditato da TreeList)
Evento pubblico | HiddenEditor | (Ereditato da TreeList)
Evento pubblico | HideCustomizationForm | (Ereditato da TreeList)
Evento pubblico | HtmlElementBlur | (Ereditato da TreeList)
Evento pubblico | HtmlElementFocus | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseClick | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseDoubleClick | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseDown | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseMove | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseOut | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseOver | (Ereditato da TreeList)
Evento pubblico | HtmlElementMouseUp | (Ereditato da TreeList)
Evento pubblico | HtmlSelectedTextChanged | (Ereditato da TreeList)
Evento pubblico | HyperlinkClick | (Ereditato da TreeList)
Evento pubblico | InitNewRow | (Ereditato da TreeList)
Evento pubblico | InvalidNodeException | (Ereditato da TreeList)
Evento pubblico | InvalidValueException | (Ereditato da TreeList)
Evento pubblico | LayoutUpdated | (Ereditato da TreeList)
Evento pubblico | LayoutUpgrade | (Ereditato da TreeList)
Evento pubblico | LeftCoordChanged | (Ereditato da TreeList)
Evento pubblico | Load | (Ereditato da TreeList)
Evento pubblico | MeasurePreviewHeight | (Ereditato da TreeList)
Evento pubblico | NodeCellStyle | (Ereditato da TreeList)
Evento pubblico | NodeChanged | (Ereditato da TreeList)
Evento pubblico | NodesReloaded | (Ereditato da TreeList)
Evento pubblico | PaintEx | (Ereditato da TreeList)
Evento pubblico | ParseFindPanelText | (Ereditato da TreeList)
Evento pubblico | PopupMenuShowing | (Ereditato da TreeList)
Evento pubblico | PrintExportProgress | (Ereditato da TreeList)
Evento pubblico | PropertyDeserializing | (Ereditato da TreeList)
Evento pubblico | PropertySerializing | (Ereditato da TreeList)
Evento pubblico | QueryCustomFunctions | (Ereditato da TreeList)
Evento pubblico | QueryEmptyTreeTemplate | (Ereditato da TreeList)
Evento pubblico | QueryNodeTemplate | (Ereditato da TreeList)
Evento pubblico | RowCellClick | (Ereditato da TreeList)
Evento pubblico | RowClick | (Ereditato da TreeList)
Evento pubblico | RowSelectImageClick | (Ereditato da TreeList)
Evento pubblico | RowStateImageClick | (Ereditato da TreeList)
Evento pubblico | ScrollAnnotationsStyle | (Ereditato da TreeList)
Evento pubblico | SelectImageClick | (Ereditato da TreeList)
Evento pubblico | SelectionChanged | (Ereditato da TreeList)
Evento pubblico | SelectionChanging | (Ereditato da TreeList)
Evento pubblico | ShowCustomizationForm | (Ereditato da TreeList)
Evento pubblico | ShowFilterPopupCheckedListBox | (Ereditato da TreeList)
Evento pubblico | ShowFilterPopupDate | (Ereditato da TreeList)
Evento pubblico | ShowFilterPopupExcel | (Ereditato da TreeList)
Evento pubblico | ShowFilterPopupListBox | (Ereditato da TreeList)
Evento pubblico | ShowingEditor | (Ereditato da TreeList)
Evento pubblico | ShownEditor | (Ereditato da TreeList)
Evento pubblico | ShowTreeListMenu | Obsoleto. (Ereditato da TreeList)
Evento pubblico | StartSorting | (Ereditato da TreeList)
Evento pubblico | StateChanged | (Ereditato da TreeList)
Evento pubblico | StateImageClick | (Ereditato da TreeList)
Evento pubblico | SubstituteFilter | (Ereditato da TreeList)
Evento pubblico | TopVisibleNodeIndexChanged | (Ereditato da TreeList)
Evento pubblico | TreeListMenuItemClick | (Ereditato da TreeList)
Evento pubblico | UnboundExpressionEditorCreated | (Ereditato da TreeList)
Evento pubblico | ValidateNode | (Ereditato da TreeList)
Evento pubblico | ValidatingEditor | (Ereditato da TreeList)
Evento pubblico | VirtualTreeGetCellValue | (Ereditato da TreeList)
Evento pubblico | VirtualTreeGetChildNodes | (Ereditato da TreeList)
Evento pubblico | VirtualTreeSetCellValue | (Ereditato da TreeList)
Torna su
Vedi anche

Documentazione

Classe TreeListSafePaint
Namespace DedNet.Controls


Campi di TreeListSafePaint

Il tipo TreeListSafePaint espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | allowCloseEditor | (Ereditato da TreeList)
Campo pubblico | ChangeSelection | Indica d'effettuare un cambio di selezione nel load state
Campo protetto | fInitializing | (Ereditato da EditorContainer)
Campo protetto | fUpdateSize | (Ereditato da TreeList)
Campo pubblico | IsFilterActive | Indica se è attivo un filtro
Campo pubblico | searchStarted |
Campo pubblico | SelectionChangedByCode | Indica se un cambio di selezione di un nodo è avvenuto via codice
Campo protetto | SortedColumns | (Ereditato da TreeList)
Campo pubblico | state |
Torna su
Vedi anche

Documentazione

Classe TreeListSafePaint
Namespace DedNet.Controls


Campo TreeListSafePaint.ChangeSelection

Campo TreeListSafePaintChangeSelection
Indica d'effettuare un cambio di selezione nel load state

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ChangeSelection
Public ChangeSelection As Boolean
public:
bool ChangeSelection
val mutable ChangeSelection: bool

Valore del campo

Boolean
Vedi anche

Documentazione

Classe TreeListSafePaint
Namespace DedNet.Controls


Campo TreeListSafePaint.IsFilterActive

Campo TreeListSafePaintIsFilterActive
Indica se è attivo un filtro

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsFilterActive
Public IsFilterActive As Boolean
public:
bool IsFilterActive
val mutable IsFilterActive: bool

Valore del campo

Boolean
Vedi anche

Documentazione

Classe TreeListSafePaint
Namespace DedNet.Controls


Campo TreeListSafePaint.searchStarted

Campo TreeListSafePaintsearchStarted

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool searchStarted
Public searchStarted As Boolean
public:
bool searchStarted
val mutable searchStarted: bool

Valore del campo

Boolean
Vedi anche

Documentazione

Classe TreeListSafePaint
Namespace DedNet.Controls


Campo TreeListSafePaint.SelectionChangedByCode

Campo TreeListSafePaintSelectionChangedByCode
Indica se un cambio di selezione di un nodo è avvenuto via codice

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool SelectionChangedByCode
Public SelectionChangedByCode As Boolean
public:
bool SelectionChangedByCode
val mutable SelectionChangedByCode: bool

Valore del campo

Boolean
Vedi anche

Documentazione

Classe TreeListSafePaint
Namespace DedNet.Controls


Campo TreeListSafePaint.state

Campo TreeListSafePaintstate

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public UtilityTreeListViewState state
Public state As UtilityTreeListViewState
public:
UtilityTreeListViewState^ state
val mutable state: UtilityTreeListViewState

Valore del campo

UtilityTreeListViewState
Vedi anche

Documentazione

Classe TreeListSafePaint
Namespace DedNet.Controls


Classe UpdateHeaderNodes
Classe che scorre tutti i nodi e se ha la stessa anagrafica di quello di riferimento ne aggiorna l'Header.
Gerarchia di ereditarietà
SystemObject
TreeListOperation
DedNet.ControlsUpdateHeaderNodes

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class UpdateHeaderNodes : TreeListOperation
Public Class UpdateHeaderNodes
    Inherits TreeListOperation
public ref class UpdateHeaderNodes : public TreeListOperation
type UpdateHeaderNodes =
    class
        inherit TreeListOperation
    end

Il tipo UpdateHeaderNodes espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | UpdateHeaderNodes | Costruttore.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | NeedsFullIteration | (Ereditato da TreeListOperation)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | CanContinueIteration | (Ereditato da TreeListOperation)
Metodo pubblico | CanExecute | (Ereditato da TreeListOperation)
Metodo pubblico | Execute | Scorre tutti i nodi dell'albero. (Sovrascrive TreeListOperation.Execute(TreeListNode))
Metodo pubblico | FinalizeOperation | (Ereditato da TreeListOperation)
Metodo protetto | HasChildren | (Ereditato da TreeListOperation)
Metodo pubblico | NeedsVisitChildren | (Ereditato da TreeListOperation)
Metodo protetto | OnAfterNodesOperation | (Ereditato da TreeListOperation)
Metodo protetto | OnNodesOperation | (Ereditato da TreeListOperation)
Metodo pubblico | ReloadHeaderNode | Metodo per aggiornare l'Header del nodo oppure ricarica i nodi figli
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore UpdateHeaderNodes
Costruttore.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public UpdateHeaderNodes(
    TreeListNode node,
    DedDistControl deddistctr,
    bool onlyRefresh
)
Public Sub New (
    node As TreeListNode,
    deddistctr As DedDistControl,
    onlyRefresh As Boolean
)
public:
UpdateHeaderNodes(
    TreeListNode^ node,
    DedDistControl^ deddistctr,
    bool onlyRefresh
)
new :
        node : TreeListNode *
        deddistctr : DedDistControl *
        onlyRefresh : bool -> UpdateHeaderNodes

Parametri

node TreeListNode
deddistctr DedDistControl
onlyRefresh Boolean
Vedi anche

Documentazione

Classe UpdateHeaderNodes
Namespace DedNet.Controls


Proprietà di UpdateHeaderNodes

Il tipo UpdateHeaderNodes espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | NeedsFullIteration | (Ereditato da TreeListOperation)
Torna su
Vedi anche

Documentazione

Classe UpdateHeaderNodes
Namespace DedNet.Controls


Metodi di UpdateHeaderNodes

Il tipo UpdateHeaderNodes espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | CanContinueIteration | (Ereditato da TreeListOperation)
Metodo pubblico | CanExecute | (Ereditato da TreeListOperation)
Metodo pubblico | Execute | Scorre tutti i nodi dell'albero. (Sovrascrive TreeListOperation.Execute(TreeListNode))
Metodo pubblico | FinalizeOperation | (Ereditato da TreeListOperation)
Metodo protetto | HasChildren | (Ereditato da TreeListOperation)
Metodo pubblico | NeedsVisitChildren | (Ereditato da TreeListOperation)
Metodo protetto | OnAfterNodesOperation | (Ereditato da TreeListOperation)
Metodo protetto | OnNodesOperation | (Ereditato da TreeListOperation)
Metodo pubblico | ReloadHeaderNode | Metodo per aggiornare l'Header del nodo oppure ricarica i nodi figli
Torna su
Vedi anche

Documentazione

Classe UpdateHeaderNodes
Namespace DedNet.Controls


Metodo UpdateHeaderNodes.Execute

Metodo UpdateHeaderNodesExecute
Scorre tutti i nodi dell'albero.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void Execute(
    TreeListNode refNode
)
Public Overrides Sub Execute (
    refNode As TreeListNode
)
public:
virtual void Execute(
    TreeListNode^ refNode
) override
abstract Execute :
        refNode : TreeListNode -> unit
override Execute :
        refNode : TreeListNode -> unit

Parametri

refNode TreeListNode
Vedi anche

Documentazione

Classe UpdateHeaderNodes
Namespace DedNet.Controls


Metodo UpdateHeaderNodes.ReloadHeaderNode

Metodo UpdateHeaderNodesReloadHeaderNode
Metodo per aggiornare l'Header del nodo oppure ricarica i nodi figli

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ReloadHeaderNode(
    TreeListNode node,
    bool onlyrefreh
)
Public Sub ReloadHeaderNode (
    node As TreeListNode,
    onlyrefreh As Boolean
)
public:
void ReloadHeaderNode(
    TreeListNode^ node,
    bool onlyrefreh
)
member ReloadHeaderNode :
        node : TreeListNode *
        onlyrefreh : bool -> unit

Parametri

node TreeListNode
Nodo da aggiornare
onlyrefreh Boolean
Indica se fare solo il refresh dell'header senza ricaricare i nodi figli
Vedi anche

Documentazione

Classe UpdateHeaderNodes
Namespace DedNet.Controls


Classe UpdateInfoNodes
Classe che scorre tutti i nodi e se ha la stessa anagrafica di quello di riferimento ne aggiorna i dati.
Gerarchia di ereditarietà
SystemObject
TreeListOperation
DedNet.ControlsUpdateInfoNodes

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class UpdateInfoNodes : TreeListOperation
Public Class UpdateInfoNodes
    Inherits TreeListOperation
public ref class UpdateInfoNodes : public TreeListOperation
type UpdateInfoNodes =
    class
        inherit TreeListOperation
    end

Il tipo UpdateInfoNodes espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | UpdateInfoNodes | Costruttore.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | NeedsFullIteration | (Ereditato da TreeListOperation)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | CanContinueIteration | (Ereditato da TreeListOperation)
Metodo pubblico | CanExecute | (Ereditato da TreeListOperation)
Metodo pubblico | Execute | Scorre tutti i nodi dell'albero. (Sovrascrive TreeListOperation.Execute(TreeListNode))
Metodo pubblico | FinalizeOperation | (Ereditato da TreeListOperation)
Metodo protetto | HasChildren | (Ereditato da TreeListOperation)
Metodo pubblico | NeedsVisitChildren | (Ereditato da TreeListOperation)
Metodo protetto | OnAfterNodesOperation | (Ereditato da TreeListOperation)
Metodo protetto | OnNodesOperation | (Ereditato da TreeListOperation)
Metodo pubblico | UpdateNodeInfo |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls


Costruttore UpdateInfoNodes
Costruttore.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public UpdateInfoNodes(
    TreeListNode node,
    DedDistControl deddistctr,
    DedAttrList attrList
)
Public Sub New (
    node As TreeListNode,
    deddistctr As DedDistControl,
    attrList As DedAttrList
)
public:
UpdateInfoNodes(
    TreeListNode^ node,
    DedDistControl^ deddistctr,
    DedAttrList^ attrList
)
new :
        node : TreeListNode *
        deddistctr : DedDistControl *
        attrList : DedAttrList -> UpdateInfoNodes

Parametri

node TreeListNode
deddistctr DedDistControl
attrList DedAttrList
Vedi anche

Documentazione

Classe UpdateInfoNodes
Namespace DedNet.Controls


Proprietà di UpdateInfoNodes

Il tipo UpdateInfoNodes espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | NeedsFullIteration | (Ereditato da TreeListOperation)
Torna su
Vedi anche

Documentazione

Classe UpdateInfoNodes
Namespace DedNet.Controls


Metodi di UpdateInfoNodes

Il tipo UpdateInfoNodes espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | CanContinueIteration | (Ereditato da TreeListOperation)
Metodo pubblico | CanExecute | (Ereditato da TreeListOperation)
Metodo pubblico | Execute | Scorre tutti i nodi dell'albero. (Sovrascrive TreeListOperation.Execute(TreeListNode))
Metodo pubblico | FinalizeOperation | (Ereditato da TreeListOperation)
Metodo protetto | HasChildren | (Ereditato da TreeListOperation)
Metodo pubblico | NeedsVisitChildren | (Ereditato da TreeListOperation)
Metodo protetto | OnAfterNodesOperation | (Ereditato da TreeListOperation)
Metodo protetto | OnNodesOperation | (Ereditato da TreeListOperation)
Metodo pubblico | UpdateNodeInfo |
Torna su
Vedi anche

Documentazione

Classe UpdateInfoNodes
Namespace DedNet.Controls


Metodo UpdateInfoNodes.Execute

Metodo UpdateInfoNodesExecute
Scorre tutti i nodi dell'albero.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void Execute(
    TreeListNode refNode
)
Public Overrides Sub Execute (
    refNode As TreeListNode
)
public:
virtual void Execute(
    TreeListNode^ refNode
) override
abstract Execute :
        refNode : TreeListNode -> unit
override Execute :
        refNode : TreeListNode -> unit

Parametri

refNode TreeListNode
Vedi anche

Documentazione

Classe UpdateInfoNodes
Namespace DedNet.Controls


Metodo UpdateInfoNodes.UpdateNodeInfo

Metodo UpdateInfoNodesUpdateNodeInfo

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void UpdateNodeInfo(
    TreeListNode node
)
Public Sub UpdateNodeInfo (
    node As TreeListNode
)
public:
void UpdateNodeInfo(
    TreeListNode^ node
)
member UpdateNodeInfo :
        node : TreeListNode -> unit

Parametri

node TreeListNode
Vedi anche

Documentazione

Classe UpdateInfoNodes
Namespace DedNet.Controls


Classe UserControlBase
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
XtraUserControl
DedNet.ControlsUserControlBase
Altro

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class UserControlBase : XtraUserControl
Public Class UserControlBase
    Inherits XtraUserControl
public ref class UserControlBase : public XtraUserControl
type UserControlBase =
    class
        inherit XtraUserControl
    end

Il tipo UserControlBase espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | UserControlBase | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Appearance | (Ereditato da XtraUserControl)
Proprietà pubblica | Application | Applicazione alla quale il controllo appartiene.
Proprietà pubblica | BackColor | (Ereditato da XtraUserControl)
Proprietà protetta | CheckDoubleScaling | (Ereditato da XtraUserControl)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraUserControl)
Proprietà protetta | DirectXContainer | (Ereditato da XtraUserControl)
Proprietà pubblica | EnableIXtraResizeableControlInterfaceProxy | (Ereditato da XtraUserControl)
Proprietà pubblica | Font | (Ereditato da XtraUserControl)
Proprietà pubblica | ForeColor | (Ereditato da XtraUserControl)
Proprietà protetta | Helper | (Ereditato da XtraUserControl)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraUserControl)
Proprietà protetta | Painter | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleChildren | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleDPI | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraUserControl)
Proprietà protetta | ShouldCheckDpiScaleFactorOnParentChanged | (Ereditato da XtraUserControl)
Proprietà pubblica | Site | (Ereditato da XtraUserControl)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | BaseWndProc | (Ereditato da XtraUserControl)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraUserControl)
Metodo protetto | CreatePainter | (Ereditato da XtraUserControl)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive XtraUserControl.Dispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraUserControl)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraUserControl)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraUserControl)
Metodo protetto | GetBackColor | (Ereditato da XtraUserControl)
Metodo protetto | GetBackgroundSkinElement | (Ereditato da XtraUserControl)
Metodo protetto | GetInnerIXtraResizableControl | (Ereditato da XtraUserControl)
Metodo protetto | IsChildControlsRequiredScalingEnabled | (Ereditato da XtraUserControl)
Metodo protetto | IsParentHandleCreatedRecursive | (Ereditato da XtraUserControl)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraUserControl)
Metodo protetto | OnBackColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnContextMenuOpening | Evento di apertura del menù contestuale.
Metodo protetto | OnControlAdded | (Ereditato da XtraUserControl)
Metodo protetto | OnControlRemoved | (Ereditato da XtraUserControl)
Metodo protetto | OnDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnFirstLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnForeColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleCreated | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraUserControl)
Metodo protetto | OnLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnMenuItemClicked | Evento di pressione di un comando del menù contestuale.
Metodo protetto | OnPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnPaintCore | (Ereditato da XtraUserControl)
Metodo protetto | OnParentChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | OnSizeChanged | (Ereditato da XtraUserControl)
Metodo protetto | RaisePaintExEvent | (Ereditato da XtraUserControl)
Metodo pubblico | ResetBackColor | (Ereditato da XtraUserControl)
Metodo pubblico | ResetForeColor | (Ereditato da XtraUserControl)
Metodo protetto | RestoreAutoScaleModeChangedByPM2 | (Ereditato da XtraUserControl)
Metodo protetto | ScaleControl | (Ereditato da XtraUserControl)
Metodo pubblico | SetCommandList | Rigenera il menu contestuale di questo controllo con la lista dei comandi passati.
Metodo protetto | SetVisibleCore | (Ereditato da XtraUserControl)
Metodo protetto | ShouldPaintTransparentBackground | (Ereditato da XtraUserControl)
Metodo protetto | ShouldUseDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | WndProc | (Ereditato da XtraUserControl)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | ContextMenuOpening | Evento su apertura del menu contestuale.
Evento pubblico | MenuItemClicked | Evento su click su un elemento del menu contestuale.
Evento pubblico | PaintEx | (Ereditato da XtraUserControl)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | _app | Applicazione alla quale il controllo appartiene.
Campo protetto | _RegistryBaseKey | Chiave nel registro di sistema di salvataggio impostazioni.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Controls
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
XtraUserControl
DedNet.ControlsUserControlBase
DedNet.ControlsDedAnagrViewControl
DedNet.ControlsDedBomExplorerControl
DedNet.ControlsDedCascadeViewControl
DedNet.ControlsDedCommAnagExplorer
DedNet.ControlsDedCommStructExplorer
DedNet.ControlsDedDependenciesControl
DedNet.ControlsDedDistControl
DedNet.ControlsDedDocControl
DedNet.ControlsDedDropDownButtonControl
DedNet.ControlsDedEcoViewControl
DedNet.ControlsDedFileExplorerControl
DedNet.ControlsDedFindCodeControl
DedNet.ControlsDedFindCommControl
DedNet.ControlsDedOkCancelControl
DedNet.ControlsDedPreviewControl
DedNet.ControlsDedRootExplorerControl
DedNet.ControlsDedSearchControl
DedNet.ControlsDedTypeTreeControl
DedNet.ControlsManageAnagrControl
DedNet.FormsControlloPermessi


Costruttore UserControlBase
Costruttore unico.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public UserControlBase()
Public Sub New
public:
UserControlBase()
new : unit -> UserControlBase
Vedi anche

Documentazione

Classe UserControlBase
Namespace DedNet.Controls


Proprietà di UserControlBase

Il tipo UserControlBase espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Appearance | (Ereditato da XtraUserControl)
Proprietà pubblica | Application | Applicazione alla quale il controllo appartiene.
Proprietà pubblica | BackColor | (Ereditato da XtraUserControl)
Proprietà protetta | CheckDoubleScaling | (Ereditato da XtraUserControl)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraUserControl)
Proprietà protetta | DirectXContainer | (Ereditato da XtraUserControl)
Proprietà pubblica | EnableIXtraResizeableControlInterfaceProxy | (Ereditato da XtraUserControl)
Proprietà pubblica | Font | (Ereditato da XtraUserControl)
Proprietà pubblica | ForeColor | (Ereditato da XtraUserControl)
Proprietà protetta | Helper | (Ereditato da XtraUserControl)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraUserControl)
Proprietà protetta | Painter | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleChildren | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleDPI | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraUserControl)
Proprietà protetta | ShouldCheckDpiScaleFactorOnParentChanged | (Ereditato da XtraUserControl)
Proprietà pubblica | Site | (Ereditato da XtraUserControl)
Torna su
Vedi anche

Documentazione

Classe UserControlBase
Namespace DedNet.Controls


Proprietà UserControlBase.Application

Proprietà UserControlBaseApplication
Applicazione alla quale il controllo appartiene.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedNetApplication Application { get; }
Public ReadOnly Property Application As DedNetApplication
    Get
public:
property DedNetApplication^ Application {
    DedNetApplication^ get ();
}
member Application : DedNetApplication with get

Valore della proprietà

DedNetApplication
Vedi anche

Documentazione

Classe UserControlBase
Namespace DedNet.Controls


Metodi di UserControlBase

Il tipo UserControlBase espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | BaseWndProc | (Ereditato da XtraUserControl)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraUserControl)
Metodo protetto | CreatePainter | (Ereditato da XtraUserControl)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive XtraUserControl.Dispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraUserControl)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraUserControl)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraUserControl)
Metodo protetto | GetBackColor | (Ereditato da XtraUserControl)
Metodo protetto | GetBackgroundSkinElement | (Ereditato da XtraUserControl)
Metodo protetto | GetInnerIXtraResizableControl | (Ereditato da XtraUserControl)
Metodo protetto | IsChildControlsRequiredScalingEnabled | (Ereditato da XtraUserControl)
Metodo protetto | IsParentHandleCreatedRecursive | (Ereditato da XtraUserControl)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraUserControl)
Metodo protetto | OnBackColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnContextMenuOpening | Evento di apertura del menù contestuale.
Metodo protetto | OnControlAdded | (Ereditato da XtraUserControl)
Metodo protetto | OnControlRemoved | (Ereditato da XtraUserControl)
Metodo protetto | OnDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnFirstLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnForeColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleCreated | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraUserControl)
Metodo protetto | OnLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnMenuItemClicked | Evento di pressione di un comando del menù contestuale.
Metodo protetto | OnPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnPaintCore | (Ereditato da XtraUserControl)
Metodo protetto | OnParentChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | OnSizeChanged | (Ereditato da XtraUserControl)
Metodo protetto | RaisePaintExEvent | (Ereditato da XtraUserControl)
Metodo pubblico | ResetBackColor | (Ereditato da XtraUserControl)
Metodo pubblico | ResetForeColor | (Ereditato da XtraUserControl)
Metodo protetto | RestoreAutoScaleModeChangedByPM2 | (Ereditato da XtraUserControl)
Metodo protetto | ScaleControl | (Ereditato da XtraUserControl)
Metodo pubblico | SetCommandList | Rigenera il menu contestuale di questo controllo con la lista dei comandi passati.
Metodo protetto | SetVisibleCore | (Ereditato da XtraUserControl)
Metodo protetto | ShouldPaintTransparentBackground | (Ereditato da XtraUserControl)
Metodo protetto | ShouldUseDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | WndProc | (Ereditato da XtraUserControl)
Torna su
Vedi anche

Documentazione

Classe UserControlBase
Namespace DedNet.Controls


Metodo UserControlBase.Dispose

Metodo UserControlBaseDispose
Clean up any resources being used.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe UserControlBase
Namespace DedNet.Controls


Metodo UserControlBase.OnContextMenuOpening

Metodo UserControlBaseOnContextMenuOpening
Evento di apertura del menù contestuale.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected virtual void OnContextMenuOpening(
    Object sender,
    CancelEventArgs e
)
Protected Overridable Sub OnContextMenuOpening (
    sender As Object,
    e As CancelEventArgs
)
protected:
virtual void OnContextMenuOpening(
    Object^ sender,
    CancelEventArgs^ e
)
abstract OnContextMenuOpening :
        sender : Object *
        e : CancelEventArgs -> unit
override OnContextMenuOpening :
        sender : Object *
        e : CancelEventArgs -> unit

Parametri

sender Object
e CancelEventArgs
Vedi anche

Documentazione

Classe UserControlBase
Namespace DedNet.Controls


Metodo UserControlBase.OnMenuItemClicked

Metodo UserControlBaseOnMenuItemClicked
Evento di pressione di un comando del menù contestuale.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected virtual void OnMenuItemClicked(
    Object sender,
    ItemClickEventArgs e
)
Protected Overridable Sub OnMenuItemClicked (
    sender As Object,
    e As ItemClickEventArgs
)
protected:
virtual void OnMenuItemClicked(
    Object^ sender,
    ItemClickEventArgs^ e
)
abstract OnMenuItemClicked :
        sender : Object *
        e : ItemClickEventArgs -> unit
override OnMenuItemClicked :
        sender : Object *
        e : ItemClickEventArgs -> unit

Parametri

sender Object
e ItemClickEventArgs
Vedi anche

Documentazione

Classe UserControlBase
Namespace DedNet.Controls


Metodo UserControlBase.SetCommandList

Metodo UserControlBaseSetCommandList
Rigenera il menu contestuale di questo controllo con la lista dei comandi passati.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual void SetCommandList(
    DedCommandList commandList,
    CommandContextEnum commandContext
)
Public Overridable Sub SetCommandList (
    commandList As DedCommandList,
    commandContext As CommandContextEnum
)
public:
virtual void SetCommandList(
    DedCommandList^ commandList,
    CommandContextEnum commandContext
)
abstract SetCommandList :
        commandList : DedCommandList *
        commandContext : CommandContextEnum -> unit
override SetCommandList :
        commandList : DedCommandList *
        commandContext : CommandContextEnum -> unit

Parametri

commandList DedCommandList
Lista completa dei comandi.
commandContext CommandContextEnum
Contesto da utilizzare per filtrare i comandi da inserire.
Note
Filtra i comandi in modo da aggiungere soltanto quelli coerenti con il contesto passato.
Vedi anche

Documentazione

Classe UserControlBase
Namespace DedNet.Controls


Eventi di UserControlBase

Il tipo UserControlBase espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | ContextMenuOpening | Evento su apertura del menu contestuale.
Evento pubblico | MenuItemClicked | Evento su click su un elemento del menu contestuale.
Evento pubblico | PaintEx | (Ereditato da XtraUserControl)
Torna su
Vedi anche

Documentazione

Classe UserControlBase
Namespace DedNet.Controls


Evento UserControlBase.ContextMenuOpening

Evento UserControlBaseContextMenuOpening
Evento su apertura del menu contestuale.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<CancelEventArgs> ContextMenuOpening
Public Event ContextMenuOpening As EventHandler(Of CancelEventArgs)
public:
 event EventHandler<CancelEventArgs^>^ ContextMenuOpening {
    void add (EventHandler<CancelEventArgs^>^ value);
    void remove (EventHandler<CancelEventArgs^>^ value);
}
member ContextMenuOpening : IEvent<EventHandler<CancelEventArgs>,
    CancelEventArgs>

Valore

EventHandler CancelEventArgs
Vedi anche

Documentazione

Classe UserControlBase
Namespace DedNet.Controls


Evento UserControlBase.MenuItemClicked

Evento UserControlBaseMenuItemClicked
Evento su click su un elemento del menu contestuale.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<ItemClickEventArgs> MenuItemClicked
Public Event MenuItemClicked As EventHandler(Of ItemClickEventArgs)
public:
 event EventHandler<ItemClickEventArgs^>^ MenuItemClicked {
    void add (EventHandler<ItemClickEventArgs^>^ value);
    void remove (EventHandler<ItemClickEventArgs^>^ value);
}
member MenuItemClicked : IEvent<EventHandler<ItemClickEventArgs>,
    ItemClickEventArgs>

Valore

EventHandler ItemClickEventArgs
Vedi anche

Documentazione

Classe UserControlBase
Namespace DedNet.Controls


Campi di UserControlBase

Il tipo UserControlBase espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | _app | Applicazione alla quale il controllo appartiene.
Campo protetto | _RegistryBaseKey | Chiave nel registro di sistema di salvataggio impostazioni.
Torna su
Vedi anche

Documentazione

Classe UserControlBase
Namespace DedNet.Controls


Campo UserControlBase._app

Campo UserControlBase_app
Applicazione alla quale il controllo appartiene.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected DedNetApplication _app
Protected _app As DedNetApplication
protected:
DedNetApplication^ _app
val mutable _app: DedNetApplication

Valore del campo

DedNetApplication
Vedi anche

Documentazione

Classe UserControlBase
Namespace DedNet.Controls


Campo UserControlBase._RegistryBaseKey

Campo UserControlBase_RegistryBaseKey
Chiave nel registro di sistema di salvataggio impostazioni.

Namespace: DedNet.Controls
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected string _RegistryBaseKey
Protected _RegistryBaseKey As String
protected:
String^ _RegistryBaseKey
val mutable _RegistryBaseKey: string

Valore del campo

String
Vedi anche

Documentazione

Classe UserControlBase
Namespace DedNet.Controls


DedNet.Core Namespace
Spazio dei nomi contenente le funzionalita di base fondamentali per l'applicazione.
Classi
 | Classe | Descrizione
Classe pubblica | Assert | Funzioni di utilità comuni condivise dalle varie classi dell'assembly.
Classe pubblica | BomItem | Rappresenta un singolo legame padre-figlio nell'ambito della distinta. Questo legame (riconducibile ad una singola riga nella tabella DED_BOM) ha una data di creazione ed una di validità che ne limitano lo spazio temporale.
Classe pubblica | BomItemCollection | Collezione di oggetti BomItem.
Classe pubblica | BomItemComparer | Gestore del confronto degli elementi di distinta
Classe pubblica | BomItemComparerClassComparBom | Classe usata per il confronto fra distinte
Classe pubblica | BomItemComparerAnag | Classe per comparare due BomItem per anagrafica
Classe pubblica | BomItemComparerImported | Classe usata per personalizzare il confronto fra distinte
Classe pubblica | CategoryComparerByPosition | Classe di compare della posizione di due attributi.
Classe pubblica | CfgOperation | Classe che rappresenta l'oggetto memorizzato nel Database nella tabella DED_DOC_CFG
Classe pubblica | CfgOperationList | Classe che rappresenta la lista delle operazioni sulle configurazioni
Classe pubblica | CfgOperations | Classse che rappresenta un dizionario chiave configurazioni con lista delle operazioni su tale chiave
Classe pubblica | CompareBomItemByRicPos | Classe utilizzata per ordinare gli elementi di distinta in base al campo RIC_POS.
Classe pubblica | ConfigDescriptor | Descrittore della configurazione
Classe pubblica | DedAlternativeDataCollection | Classe utilizzata per gestire i codici alternativi di una anagrafica. Questa classe eredita dalla classe 'HashSet' in modo tale da non permettere l'inserimento di duplicati.
Classe pubblica | DedAtt | Gestisce una lista di valori da utilizzare per la compilazione di un attributo. L'oggetto DedAtt contiene riferimenti ai vari oggetti DedAttItem descriventi una singola voce.
Classe pubblica | DedAttComparer | Classe per oridnare gli elementi in base al campo Valore in modo crescente o decrescente.
Classe pubblica | DedAttItem | Definisce un elemento della lista DedAtt.
Classe pubblica | DedAttItemList | Lista di oggetti DedAtt.
Classe pubblica | DedAttManager | Gestore delle liste DedAtt da associare agli attributi.
Classe pubblica | DedAttr | Descrive, in tutte le sue caratteristiche, un attributo delle parti Top.
Classe pubblica | DedAttrCollection | Collezione modificabile di attributi.
Classe pubblica | DedAttrDateValidator | Classe per la validazione di un attributo di tipo Data.
Classe pubblica | DedAttrDoubleValidator | Classe per la validazione di un attributo di tipo numero con virgola.
Classe pubblica | DedAttributePermList | Collezione di oggetti DedAttributePerm.
Classe pubblica | DedAttrIntegerValidator | Classe per la validazione di un attributo di tipo numero intero.
Classe pubblica | DedAttrList | Lista di oggetti DedAttr.
Classe pubblica | DedAttrPerm | Contiene il set di permessi relativi ad un solo attributo ed abbinato ad un unico utente/gruppo.
Classe pubblica | DedAttrSiNoValidator | Classe per la validazione di un attributo di tipo boolean.
Classe pubblica | DedAttrStringValidator | Classe per la validazione di un attributo di tipo stringa.
Classe pubblica | DedAttrValidatorBase | Classe base per la validazione attributo.
Classe pubblica | DedAttrValidatorFactory | Factory di oggetti DedAttrValidator.
Classe pubblica | DedBaseDbItem |
Classe pubblica | DedCascade | Classe che descrive una singola cascata.
Classe pubblica | DedCascadeDependency | Classe che descrive una dipendenza tra uno o più valori padre e un valore figlio. Corrisponde a un record della tabella DED_CASCADE del database.
Classe pubblica | DedCascadeDictionary | Dizionario di oggetti cascata.
Classe pubblica | DedCascadeList | Lista di oggetti cascata.
Classe pubblica | DedCascadeManager | Classe Manager per gestire le cascate.
Classe pubblica | DedCascadeValue | Classe che descrive un valore della cascata con la sua descrizione.
Classe pubblica | DedCascadeValueList | Lista di DedCascadeValue.
Classe pubblica | DedCateg | Classe che descrive una categoria attributo.
Classe pubblica | DedCategCollection | Collezione di categorie.
Classe pubblica | DedCategDictionary | Dizionario di categorie.
Classe pubblica | DedCategList | Lista di categorie.
Classe pubblica | DedCategManager | Classe di gestione delle categorie.
Classe pubblica | DedComm | Oggetto descrittivo di una commessa. La costruzione di questo oggetto è demandata dai metodi dell'oggetto Application. Appena si imposta una proprietà pubblica scrivibile dell'oggetto, viene subito tentato l'aggiornamento del record nel Database. Se la versione del record non risulta coerente viene sollevata un'eccezione per indicare che qualcun'altro ha già modificato la commessa.
Classe pubblica | DedCommDedCommEncodeInfo |
Classe pubblica | DedCommAnagrCollection | Collezione di anagrafiche collegate ad una commessa.
Classe pubblica | DedCommAnagrItem | Descrive un legame tra commessa ed anagrafica.
Classe pubblica | DedCommCollectionItem | Classe base per gli elementi legati alla commessa.
Classe pubblica | DedCommCollections | Classe base per le collezioni di oggetti legati alla commessa.
Classe pubblica | DedCommCommCollection | Collezione di commesse collegate ad una commessa.
Classe pubblica | DedCommCommItem | Descrive un legame tra commessa e commessa.
Classe pubblica | DedCommData |
Classe pubblica | DedCommDocCollection | Collezione di documenti collegati ad una commessa.
Classe pubblica | DedCommDocItem | Descrive un legame tra commessa e documento.
Classe pubblica | DedCommList | Lista di oggetti di tipo DedComm.
Classe pubblica | DedCommPerm | Contiene il set di permessi relativi ad una sola commessa ed abbinato ad un unico utente/gruppo.
Classe pubblica | DedCommPermList | Collezione di oggetti DedCommPerm.
Classe pubblica | DedCommType | Descrive una commessa di codifica Data and Drawings. Al suo interno sono presenti i riferimenti agli attributi specifici della commessa e alle regole di composizione. Alcune proprietà restituiscono il valore ereditato dalle commesse di livello superiore.
Classe pubblica | DedCommTypeCollection | Collezione modificabile di oggetti DedCommType.
Classe pubblica | DedCommTypeList | Lista di oggetti DedCommType.
Classe pubblica | DedCorporate | Racchiude le informazioni relative alla corporate
Classe pubblica | DedCorporates | Insieme delle corporate
Classe pubblica | DedData | Classe descrivente un oggetto di anagrafica.
Classe pubblica | DedDataDedDataEncodeInfo |
Classe pubblica | DedDataList | Lista di oggetti DedData. Viene utilizzata quando la lista di elementi debba necessariamente essere di anagrafiche presenti nel Database ed in tutti i casi per i quali una lista di anagrafiche debba essere trattata come una unica anagrafica. Per quest'ultimo motivo implementa IDedData e contiene molti membri presenti in DedData che lavorano sull'intera lista di anagrafiche.
Classe pubblica | DedDataManager | Gestisce la creazione e l'aggiornamento delle anagrafiche, nonché i legami con i documenti.
Classe pubblica | DedDataPart | Classe che implementa IDedData ed è utilizzata per manipolare la copia dell'anagrafica DedData oppure in ogni caso in cui serva un IDedData senza che l'anagrafica esista nel Database o la si voglia bloccare durante la modifica.
Classe pubblica | DedDataPartList | Lista di oggetti IDedData. Viene utilizzata quando la lista di elemnti può essere costituita da oggetti DedData o DedDataPart ed in tutti i casi per i quali una lista di anagrafiche debba essere trattata come una unica anagrafica. Per quest'ultimo motivo implementa IDedData e contiene molti membri che lavorano sull'intera lista.
Classe pubblica | DedDbCollectionBaseT | Classe base template che consente la gestione di una lista di oggetti presenti in una tabella del Database. Mantiene lo stato degli oggetti gestiti dalla collezione e riceve la notifica di avvenuta modifica.
Classe pubblica | DedDbCollectionBindableT |
Classe pubblica | DedDbItemManager | Classe che fornisce strumenti di utilità generale per operare con gli oggetti 'DedBaseDbItem'.
Classe pubblica | DedDictionary | Dizionario con le chiavi in formato stringa ed i valori in formato object che implementa il minimo indispensabile per essere passato al controllo DedEditAnagrControl.
Classe pubblica | DedDoc | Documento archiviato nel Database.
Classe pubblica | DedDocCfgManager | Classe statica usata per gestire l'aggioranmento delle tabelle durante le varie operazioni.
Classe pubblica | DedDocContext | Descrive il contesto del documento.
Classe pubblica | DedDocContextList | Lista di oggetti DedDocContext.
Classe pubblica | DedDocContextManager | Gestisce i legami tra le anagrafiche ed i documenti ed il loro contesto. Il contesto viene scritto solo quando viene creato e poi non viene più modificato, quindi esistono metodi solo per leggere, creare o eliminare ma non per aggiornare il contesto.
Classe pubblica | DedDocList | Lista di oggetti di tipo DedDoc.
Classe pubblica | DedDocManager | Gestisce la creazione e l'aggiornamento dei documenti, nonché i legami con le anagrafiche.
Classe pubblica | DedDocManagerPropertiesInfo | Classe che identifica la coppia valore - type per ogni attributo presente in DED_DOC_PROPERTIES Viene utilizzato per andare a scrivere nella griglia il valore corretto a parità di nome attributo. Possiamo avere un caso con stesso attributo e con datatype diversi, i valori dell'attributo sono presenti in colonne distinte (esempio VALUE_S e VALUE_F caso attributo LUNGHEZZA)
Classe pubblica | DedDocumentNotAlignedException | Eccezione generata durante l'eliminazione dei dati.
Classe pubblica | DedEco | Classe usata per istanziare l'oggetto DedEco.
Classe pubblica | DedEcoList | Lista di oggetti di tipo DedEco.
Classe pubblica | DedEcoManager | Classe usata per istanziare il manager degli Eco.
Classe pubblica | DedEditableObjectT | Classe utilizzata per gestire il meccanismo dello store dei dati e l'interrogazione della proprietà 'Dirty'.
Classe pubblica | DedEditableObjectCollectionT | Classe contenente l'elenco dei vari 'DedEditableObject' collegati fra loro.
Classe pubblica | DedEncodeInfo | Contiene le informazioni necessarie alla codifica. Questa struttura viene utilizzata dall'oggetto DedRuleParser e da varie funzioni per comporre una stringa di codifica.
Classe pubblica | DedFamPerm | Contiene il set di permessi relativi ad una sola famiglia ed abbinato ad un unico utente/gruppo.
Classe pubblica | DedFamPermList | Collezione di oggetti DedFamPerm.
Classe pubblica | DedFileSystemHelper |
Classe pubblica | DedFolderPerm | Contiene il set di permessi relativi ad una sola cartella ed abbinato ad un unico utente/gruppo.
Classe pubblica | DedFolderPermList | Collezione di oggetti DedFolderPerm.
Classe pubblica | DedFontInfo | Classe che descrive le informazioni sul Font utilizzato su un attributo.
Classe pubblica | DedGroup | Racchiude tutte le informazioni di un utente.
Classe pubblica | DedGroupCollection | Collezione di oggetti DedGroup.
Classe pubblica | DedList | Oggetto rappresentante la tipologia di lista
Classe pubblica | DedListCollection | Collezione delle tipologie di liste definite
Classe pubblica | DedListItem | Oggetto rappresentante un elemento della lista
Classe pubblica | DedListItemCollection | Collezione degli elementi nella lista utente
Classe pubblica | DedListManager | Classe per la gestione delle liste
Classe pubblica | DedListManagerBomInfo | Classe per gestire le informazioni delle distinte
Classe pubblica | DedListManagerBomInfoList | Lista contentente tutte le tipologie di distinte
Classe pubblica | DedListType | Lista di tipologie
Classe pubblica | DedLogManager |
Classe pubblica | DedNotifies | Gestione delle notifiche.
Classe pubblica | DedNotify |
Classe pubblica | DedOptionsCommonParents | Classe per gestire le opzioni per il comando di Trova padri comuni
Classe pubblica | DedOptionsSerializableBase | Classe per gestiore una classe di opzioni e serializzarla nel registro.
Classe pubblica | DedPerm | Racchiude le informazioni di un singolo permesso.
Classe pubblica | DedPermCollection | Collezione di permessi.
Classe pubblica | DedPermOwner | Classe descrivente un possessore di permessi. Viene utilizzata come classe base per gli utenti, i gruppi, il set di base di permessi e per i permessi legati alle famiglie.
Classe pubblica | DedProgManager |
Classe pubblica | DedPublicationCreationAvailableFormats | Formati disponibili per le operazioni di pubblicazione
Classe pubblica | DedPublicationDeletionAvailableFormats | Formati disponibili per le operazioni di eliminazione
Classe pubblica | DedPublicationManager | Classe gestione formati di pubblicazione
Classe pubblica | DedPublishingBindingList | Lista di opzioni per il binding
Classe pubblica | DedPublishingCreationConfiguration | Classe utilizzata per gestire i file di pubblicazione da CREARE quando viene rilasciata una anagrafica.
Classe pubblica | DedPublishingDeletionConfiguration | Classe contenente le opzioni per gestire i file di pubblicazione da NON CANCELLARE quando viene tolto il rilascio ad una anagrafica.
Classe pubblica | DedPublishingFileNameConfiguration | Classe utilizzata per gestire i file di pubblicazione da CREARE quando viene rilasciata una anagrafica.
Classe pubblica | DedPublishingOffice | Manager delle pubblicazioni dei file di office
Classe pubblica | DedPublishingOptionBinder | Classe che rappresenta la singola opzione per effettuare il binsding nelle source del form
Classe pubblica | DedRoot | Contiene le informazioni riguardanti una root.
Classe pubblica | DedRootInfo | Analizza le informazioni riguardanti un percorso o nome completo di file per quanto riguarda la root di appartenenza ed i corrispondenti path di Vault e Pws.
Classe pubblica | DedRoots | Gestione delle roots.
Classe pubblica | DedRule | Descrive una singola regola di autocomposizione, abbinata ad una particolare famiglia.
Classe pubblica | DedRuleApplier | Oggetto principale che data una famiglia di partenza, applica tutte le regole di autocomposizione di tale famiglia su di una parte.
Classe pubblica | DedRuleApplierItem | Oggetto che si occupa di applicare una singola regola compilando un attributo dell'anagrafica.
Classe pubblica | DedRuleCollection | Collezione modificabile di oggetti DedRule.
Classe pubblica | DedRuleList | Lista di oggetti FamilyRule.
Classe pubblica | DedRuleLuaEventArg | Contiene le informazioni per la sostituizione di un singolo token.
Classe pubblica | DedRuleParser | Classe che effettua il parser di una stringa di codifica e mette a disposizione le funzionalità di sostituzione e decodifica. {FN} - Prende il nome della famiglia di livello 'N'. {F1:2} - Prende i primi 2 caratteri della famiglia di primo livello. {F1:2,4} - Prende i 4 caratteri a partire dal secondo del nome famiglia. Es '012345':2,3 ->'123'. {F1:-3} - Prende gli ultimi 3 caratteri dal nome famiglia. Es '012345':-3 ->'345'. Al posto di 'F' ci può essere: D : Descrizione della famiglia. P : Progressivo ereditato dalla famiglia correntemente selezionata (senza la possibilità di indicazione del livello). R : Revisione (senza la possibilità di indicazione del livello). U : Tassello utente (senza la possibilità di indicazione del livello). V : Tassello variante (senza la possibilità di indicazione del livello). T : Formato di stampa (senza la possibilità di indicazione del livello). {L:MiaFunzione} : Chiama l'evento dedicato passandogli il nome della funzione 'MiaFunzione'.
Classe pubblica | DedRuleParserEventArg | Contiene le informazioni per la sostituizione di un singolo token.
Classe pubblica | DedState | Classe per gestire l'abbinamento tra nome e valore dello stato.
Classe pubblica | DedStateCategory | Classe per rappresentare le categorie degli stati.
Classe pubblica | DedStateCategoryList | Lista di oggetti di tipo DedStateCategory.
Classe pubblica | DedStateConfiguration | Classe rappresentante le configurazioni degli stati.
Classe pubblica | DedStateConfigurationList | Lista di oggetti di tipo DedStateConfiguration.
Classe pubblica | DedStateFlowTransactionDescriptor | Classe che rappresenta la descrizione della singola transazione.
Classe pubblica | DedStateFlowTransactionDescriptorList | Lista di oggetti di tipo DedStateFlowTransactionDescriptor.
Classe pubblica | DedStateFlowTransactions | Classe rappresentante i flussi dei vari stati. Dizionario contente l'id dello stato di partenza con la lista di tutti i possibili stati di arrivo.
Classe pubblica | DedStateList | Lista di oggetti di tipo DedState.
Classe pubblica | DedStateManager | Ha il compito di gestire gli stati dal Database.
Classe pubblica | DedStringPermDiz | Dizionario dei permessi specifici, indicizzato tramite stringa (tipo di oggetto), stringa (nome oggetto), Permesso. Serve per l'abbinamento dei permessi al DbPath delle famiglie.
Classe pubblica | DedTime | Classe utilizzata per gestire le temporizzazioni sui vari elementi.
Classe pubblica | DedTimedDbItem |
Classe pubblica | DedTimeList | Classe utilizzata per gestire tutte le temporizzazioni di un determinato elemento.
Classe pubblica | DedTimeManager | Classe utilizzata per gestire gli oggetti 'DedTime'.
Classe pubblica | DedTransferManager | Classe per la gestione delle richieste di trasferimento documenti.
Classe pubblica | DedTranslation | Classe utilizzata per gestire le traduzioni in lingua.
Classe pubblica | DedTranslationCollection | Collezione modificabile di traduzioni in lingua.
Classe pubblica | DedTranslationManager | Classe utilizzata per gestire gli oggetti DedTranslation. Espone alcune utilità che ne facilitano la ricerca, l'editazione, l'aggiornamento, ecc..
Classe pubblica | DedType | Descrive una famiglia di codifica Data and Drawings. Al suo interno sono presenti i riferimenti agli attributi specifici della famiglia e alle regole di composizione. Alcune proprietà restituiscono il valore ereditato dalle famiglie di livello superiore.
Classe pubblica | DedTypeBase | Classe astratta per definire oggetti che sono usati in collezioni strutturate, hanno regole di codifica, attributi e regole sugli attributi
Classe pubblica | DedTypeBaseCollectionT | Classe astratta per definire collezione modificabile di oggetti che sono usati in collezioni strutturate, hanno regole di codifica, attributi e regole sugli attributi
Classe pubblica | DedTypeBaseList | Lista di oggetti DedTypeBaseList
Classe pubblica | DedTypeCollection | Collezione modificabile di oggetti DedType.
Classe pubblica | DedTypeGenericListT | Classe DedTypeGenericList
Classe pubblica | DedTypeList | Lista di oggetti DedType.
Classe pubblica | DedTypeManager | Classe che espone alcune utilità di funzione generale per operare con le famiglie.
Classe pubblica | DedTypeProg | Classe per rappresentare un oggetto della tabella DED_TIPI_PROG.
Classe pubblica | DedTypeProgList |
Classe pubblica | DedTypeProgListSerializable |
Classe pubblica | DedUG | Collezione di utenti appartenenti ad un solo gruppo.
Classe pubblica | DedUser | Racchiude tutte le informazioni di un utente.
Classe pubblica | DedUserCollection | Collezione di oggetti DedUser.
Classe pubblica | DedUserList | Oggetto rappresentante una lista utente.
Classe pubblica | DedUserListCollection | Collezione delle liste utente
Classe pubblica | DedUsersGroups | Gestisce i legami tra gli utenti ed il gruppo di appartenenza. Ogni gruppo contiene una istanza di questa classe. Gli utenti usano i metodi della collezione presa dai gruppi di appartenenza.
Classe pubblica | DedVar | Definizione del singolo oggetto DedVar.
Classe pubblica | DedVars | Implementa la lista delle variabili DedVar.
Classe pubblica | DiscrimDistList | Lista con le informazioni sulle ingformazioni extra.
Classe pubblica | DistHeader | Descrive l'intestazione di distinta di un codice. Una intestazione rappresenta una singola revisione di distinta. Per ogni codice padre presente in distinta sono presenti n righe di intestazione quante sono le revisioni di distinta per tale codice. Tabella di riferimento DED_BOM_HEADERS.
Classe pubblica | DistHeaderCollection | Collezione di oggetti DistHeader.
Classe pubblica | DistManager | Oggetto per la gestione della distinta. Durante il caricamento mantiene una cache in base al codice padre e la data di interrogazione in modo da non ricaricare la stessa distinta.
Classe pubblica | DistSaveStructIndexDescriptor | Descrittore degli indici dei campi fondamentali per il salvataggio
Classe pubblica | DocDep | Classe descrivente la dipendenza di un singolo documento.
Classe pubblica | DocDepCollection | Collezione delle dipendenze di un Documento. Questa collezione permette di modificare la lista dei DocDep legati ad un documento. Ogni modifica effettuata non viene aggiornata nel Database fino alla successiva chiamata del metodo Save(). Tramite Refresh() viene invece reinizializzata la collection rileggendo il Database.
Classe pubblica | DocDepFile | Definisce una dipendenza specificandone il file e la tipologia. Viene utilizzata per gestire le dipendenze nei file che non ancora sono presenti nel Database. Si utilizza anche per specificare la versione del documento da inserire nel record.
Classe pubblica | DocDepFileList | Lista di oggetti DocDepFile.
Classe pubblica | DocStructFileInfos | Classe per la gestione di tutte le operazioni e le proprietà che sono relative al file e non al documento (InvDoc)
Classe pubblica | DocStructInfo | Questo elemento contiene le informazioni sullo stato e l'operazione da svolgere su di un file. Se questo sia da Creare, Importare o Spostare, e tutte le informazioni sul suo stato attuale e di destinazione. In questo oggetto si trovano anche le dipendenze di primo livello di questo documento e, a cascata, le operazioni da svolgere sui file dipendenti.
Classe pubblica | DocStructInfoCollection | Collezione di oggetti DocStructInfo contenente le collezioni di file/documenti che sono le dipendenze del documento padre.
Classe pubblica | DocStructInfoDictionary | Dizionario di oggetti docstructinfo
Classe pubblica | DocStructInfoFileDescriptor | Descrive il pacchetto dati per il DocStructInfo. Di default contiene solo il full file name ma serve per essere derivata da Inventor.
Classe pubblica | DocStructInfoList | Lista di oggetti DocStructInfo.
Classe pubblica | DocStructInfoOperationListDictionary | Dizionario di oggetti DedDoc
Classe pubblica | DriveSettings |
Classe pubblica | ExtensionMethod | Classe dedicata ai metodo estesi.
Classe pubblica | ExtraData | Dati aggiuntivi delle liste utente.
Classe pubblica | ExtraDataInfo | Oggetto contente le informazioni sui dati aggiuntivi
Classe pubblica | ExtraDataInfoList | Lista con le informazioni sulle ingformazioni extra.
Classe pubblica | ExtraDataList | Lista contenente tutte niformazioni extra di una lista utente
Classe pubblica | FileInfoSerializable |
Classe pubblica | LocalizedDescriptionAttribute | Gestione localizzazione descrizione
Classe pubblica | ModelStateRelocationInfo | Informazioni di ripuntamento del model state sulla factory già revisionata
Classe pubblica | ModelStateRelocationInfos | Lista dei descrittori di ripuntamento
Classe pubblica | OutlookDataObject | Provides a format-independant machanism for transfering data with support for outlook messages and attachments.
Classe pubblica | PermSet | Set di permessi standard.
Classe pubblica | ResultList | Lista di ResultObj
Classe pubblica | ResultObj | Oggetto che rappresenta una riga del risultato.
Classe pubblica | ResultOperationOnStructObject | Classe usata per gestire i risultati nei comandi di CheckIn Struttura, CheckOut Struttura, CheckIn Struttura con Associati e CheckOut Struttura con Associati
Classe pubblica | SparePartsUtilities | Classe utilizza che espone utilità generali per configurare gli attributi di ricambio. Non è stata esposta nella classe DedNet.Core.Utility per non sporcarla.
Classe pubblica | StatoRecord | Classe contenente le informazioni necessarie all'identificazione dello stato di un record.
Classe pubblica | TokenInfo | Racchiude le informazioni di un singolo elemento componente una stringa di codifica o comunque una stringa composta da tasselli di sostituzione.
Classe pubblica | TokenInfoList | Questa lista non è semplicemente una lista di oggetti TokenInfo. Tramite il costruttore si auto-costruisce sulla stringa di codifica in modo da essere composta da tutti i token validi trovati al suo interno.
Classe pubblica | UserPermManager | Classe per la gestione dei permessi e degli utenti/gruppi.
Classe pubblica | UserPermManagerOnProgressSavingEventArgs |
Classe pubblica | UsrPerm | Classe di definizione del singolo permesso.
Classe pubblica | UsrPermDiz | Dizionario di permessi generali, indicizzato tramite nome permesso. Serve per individuare più rapidamente il permesso in base al suo nome.
Classe pubblica | UsrPermList | Lista di oggetti UsrPerm.
Classe pubblica | UsrUser | Classe che incapsula le funzionalità di gestione dei permessi.
Classe pubblica | Utility | Classe di utilità interna.
Classe pubblica | UtilityTreeListViewState | Classe gestione stati dell'albero
Strutture
 | Struttura | Descrizione
Struttura pubblica | DedTypeProgStruct | Struttura per la gestione dei progressivi assegnati
Struttura pubblica | RelationshipItemStruct | Struttura con informazioni legame tra elemento di Sx con elemento Dx.
Interfacce
 | Interfaccia | Descrizione
Interfaccia pubblica | IDedCommData |
Interfaccia pubblica | IDedData | Definisce i membri di accesso all'oggetto singolo o multiplo di anagrafica.
Interfaccia pubblica | IDedDbCollectionBaseT | Interfaccia minima utilizzata dalla classe 'DedDbCollectionBase'.
Interfaccia pubblica | IDedDbItem | Interfaccia che deve essere implementata dagli oggetti che sono gli elementi costituenti la collezione. Attraverso questa proprietà DedDbCollectionBase si registra per la notifica dell'avvenuta modifica dell'oggetto.
Interfaccia pubblica | IDedEditable | Interfaccia minima che deve implementare un oggetto per poter essere utilizzato nel controllo DedEditAnagrControl.
Interfaccia pubblica | IDedPublishingConfigurationT | Interfaccia configurazione di pubblicazione
Interfaccia pubblica | IDedTypeEditable | Intefaccia con le informazioni sulla famiglia di archiviazione e la validità dell'oggetto
Delegate
 | Delegate | Descrizione
Delegate pubblico | DedCommCallMeForEachNode | Delegate che serve per elaborare un singola commessa.
Delegate pubblico | DedTypeBaseCallMeForEachNode | Delegate che serve per elaborare un singolo nodo dell'albero dei tipi.
Delegate pubblico | DocStructInfoProgressChangedDelegate | Delegate per la geatione dell'avanzamento nei metodi che gestiscono liste di file
Enumerazioni
 | Enumerazione | Descrizione
Enumerazione pubblica | BomCloneMode | Enumerazione per indicare il tipo di clonazione dei dati di distinta al salvataggio
Enumerazione pubblica | BomItemComparerStateEnum |
Enumerazione pubblica | BomItemManEnum | Enumerazione del campo Man degli elementi di distinta.
Enumerazione pubblica | CfgOperationCfgOpEnum | Enum con gli stati delle operazioni sulle configurazioni
Enumerazione pubblica | DedAttrEnvDestEnum | Enumera le tipologie di attributo in base alla destinazione dei dati.
Enumerazione pubblica | DedAttrListType | Enumera le tipologie di lista da visualizzare.
Enumerazione pubblica | DedAttrModEnum | Enumerazione dei tipi di modificabilità di un attributo.
Enumerazione pubblica | DedAttrRequiredEnum | Enumerazione dei tipi di modificabilità di un attributo.
Enumerazione pubblica | DedCommCommKindEnum | Elenco dei possibili stati di commessa
Enumerazione pubblica | DedCommStandardCommFields | Elenco dei campi standard.
Enumerazione pubblica | DedCommTypeDedTypeCaractEnum | Enumerazione per la compilazione delle proprietà delle commesse.
Enumerazione pubblica | DedCorporateDedCorporateEnum |
Enumerazione pubblica | DedDataStandardDataFields | Elenco dei campi standard.
Enumerazione pubblica | DedDocMovReasonEnum | Enumerazione descrivente le possibili cause dello spostamento di un documento.
Enumerazione pubblica | DedDocStandardDocFields | Elenco dei campi standard.
Enumerazione pubblica | DedDocContextEnum | Contesto di legame tra documento ed anagrafica.
Enumerazione pubblica | DedDocContextTypeEnum | Possibili tipologie di contesto documentale
Enumerazione pubblica | DedEcoEcoStateEnum | Enumerazione sui possibili stati dell'ECO.
Enumerazione pubblica | DedEcoEcoTypeEnum | Enumerazione sui possibili tipi di ECO.
Enumerazione pubblica | DedEcoStandardEcoFields | Elenco dei campi standard.
Enumerazione pubblica | DedFontInfoDedFontStyleEnum | Enum che descrive i possibili stili di font.
Enumerazione pubblica | DedListManagerTipoDati | Tipologie di dato per extra info
Enumerazione pubblica | DedNotifyNotifyEvent | Enumerazione contenente tutti i permessi standard.
Enumerazione pubblica | DedNotifyNotifySendTypeEnum |
Enumerazione pubblica | DedNotifyNotifyStateEnum |
Enumerazione pubblica | DedPubActionEnum | Enumerazione sull'azione da effettuare sui documenti
Enumerazione pubblica | DedPublicationFormat | Enumerazione dei formati disponibili in fase di creazione/eliminazione
Enumerazione pubblica | DedPublicationPlatform | Enumerazione delle piattaforme disponibili di creazione
Enumerazione pubblica | DedRootRootTypeEnum | Enumerazione descrivente il tipo di root.
Enumerazione pubblica | DedStandardPerm | Enumerazione contenente tutti i permessi standard.
Enumerazione pubblica | DedTransferManagerDedTransferManagerOnlineMode | Indica le possibili modalità di traferimento online
Enumerazione pubblica | DedTypeCompCodeEnum | Tipi di compilazione del campo DED_COD.
Enumerazione pubblica | DedTypeDedTypeCaractEnum | Enumerazione per la compilazione delle proprietà delle famiglie.
Enumerazione pubblica | DedTypeFreeFileEnum | Enumerazione per le tipologie di freefile.
Enumerazione pubblica | DocDepEnum | Tipologia di dipendenza tra documenti.
Enumerazione pubblica | DocStructInfoSavingFileType | Enumerazione che mi indica che tipo di documento mi rappresenta questo elemento, in relazione al documento in salvataggio (serve al comando di salva nel db per capire se un elemento sia stato aggiunto come file associato oppure come file referenziato oppure se si tratti proprio del documento in salvataggio).
Enumerazione pubblica | ListElaborationTypeEnum | Enumerazione con le tipologiie di oggetti gestiti dalle liste
Enumerazione pubblica | ListItemTypeEnum | Enumerazione con le tipologiie di oggetti gestiti dalle liste
Enumerazione pubblica | OverwriteBomMode | Enumerazione per indicare il comportamento da utilizzare al salva distinta
Enumerazione pubblica | RuleStateEnum | Enumerazione con lo stato di attivazione della regola
Enumerazione pubblica | StatoRecordEnum | Definisce lo stato corrente di un record.
Enumerazione pubblica | TokenTypeEnum | Enumerazione delle tipologia di tassello di codifica.
Enumerazione pubblica | TranslationDiscrimEnum | Enum utilizzato per identificare il tipo di traduzione.
Enumerazione pubblica | ValidatorOperator | Lista delle tipologie dei range di controllo.


Classe Assert
Funzioni di utilità comuni condivise dalle varie classi dell'assembly.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreAssert

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class Assert
Public Class Assert
public ref class Assert
type Assert = class end

Il tipo Assert espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AssertAllDocumentsAreCheckedInOrCheckOutByMe(DedData) | Solleva una eccezione se esistono dei documenti associati all'anagrafica che non sono in checkin o in checkout da me.
Metodo pubblico | AssertAllDocumentsAreCheckedInOrCheckOutByMe(DedDocList) | Solleva una eccezione se esistono dei documenti che non sono in checkin o in checkout da me.
Metodo pubblico | AssertAnagrNotNull | Verifica che il DedId ed il DedRev siano presenti nel Database..
Metodo pubblico | AssertCanSup | Controlla che ci sia almeno un'altra revisione nello stato Lavorazione/Rilasciato.
Metodo pubblico | AssertCfgNotUsed(DedDoc, CfgOperation) |
Metodo pubblico | AssertCfgNotUsed(DedDoc, ListString) |
Metodo pubblico | AssertCorporateIsMaster | Controlla che l'utente abbia il permesso di Amministrare in generale.
Metodo pubblico | AssertDbBomColSequence | Si assicura che le colonne della distinta in salvataggio siano nell'ordine corretto. Controlla che le prime 5 colonne siano $lev,ID,REV,ID,REV
Metodo pubblico | AssertDocHasData | Controlla che il documento non sia associato a nessuna anagrafica.
Metodo pubblico | AssertDocHasNotMoreThanOneConfigContext(DedData, Boolean) | Se i documenti dell'anagrafica sono associati tramite più configurazioni blocco!
Metodo pubblico | AssertDocHasNotMoreThanOneConfigContext(DedDoc, Boolean) | Se i documenti dell'anagrafica sono associati tramite più configurazioni blocco!
Metodo pubblico | AssertDocIsNotVital | Si assicura che il documento non sia dipendenza vitale di qualche documento. Nel caso sia dipendenza controlla che la dipendenza sia nella lista passata come secondo parametro altrimenti genera eccezione ( questo controllo viene fatto solo se la lista è diversa da null ).
Metodo pubblico | AssertDocumentNotNull | Verifica che il documento passato non sia null, altrimenti solleva una eccezione indicando che il file fileName non risulta essere registrato nel Database.
Metodo pubblico | AssertDocumentNull | Verifica che il documento passato sia null, altrimenti solleva una eccezione.
Metodo pubblico | AssertDocUsedInOneAnagr | Sis assicura che il documento sia usato solamente in un'anagrafica.
Metodo pubblico | AssertECOExistsAnagComm | Verifica l'esistenza dell'anagrafica o della commessa associata all'ECO.
Metodo pubblico | AssertECOIsCorrectlyAssigned | Verifica lo stato dell'ECO e genera una eccezione se lo stato è "Assegnato" e l'utente corrente è diverso da quello che lo ha preso in carico.
Metodo pubblico | AssertECOIsNotClosed | Verifica lo stato dell'Eco e genera una eccezione se lo stato è "Chiuso".
Metodo pubblico | AssertECOOperationOnDocument | Verifica se l'utente ha il permesso di eseguire le operazioni sui documenti associato all'ECO.
Metodo pubblico | AssertECORoot | Verifica che esista la root dedicata agli Eco.
Metodo pubblico | AssertFileCadIsNotDuplicated | Controlla che il percorso passato non coincida con il percorso di base di una delle root all'interno delle quali è proibito salvare. Tipicamente %WORK%
Metodo pubblico | AssertFileExists | Solleva l'eccezione di FileNotFoundException se il file non è presente.
Metodo pubblico | AssertFileExists2 | Solleva l'eccezione di FileNotFoundException se il file non è presente.
Metodo pubblico | AssertFileIsInRoot(DedRootInfo) | Verifica che le informazioni di un percorso sia nei percorsi validi del Database.
Metodo pubblico | AssertFileIsInRoot(String) | Verifica che il percorso passato sia nei percorsi validi del Database.
Metodo pubblico | AssertFileIsNotCreatingDirectlyInForbiddenRoots | Controlla che il percorso passato non coincida con il percorso di base di una delle root all'interno delle quali è proibito salvare. Tipicamente %WORK%
Metodo pubblico | AssertFileIsNotLocked | Verifica che il file passato non sia bloccato, altrimenti solleva una eccezione. Se il file non esiste non fa nulla.
Metodo pubblico | AssertFileNotExists | Controlla che un file NON esista, altrimenti solleva una eccezione.
Metodo pubblico | AssertGuid | Solleva l'eccezione di ArgumentNullException se il parametro passato è Guid.Empty.
Metodo pubblico | AssertHadntMovedDocuments | Controlla che l'anagrafica non puntasse a documenti che poi sono stati ricodificati
Metodo pubblico | AssertHeaderIsNotLocked | Controlla che l'header della distinta non sia bloccato.
Metodo pubblico | AssertIsAllowedStateTransaction | Controlla se il passaggio di stato è ammesso per l'utente
Metodo pubblico | AssertIsApprovedState | Controlla che l'anagrafica sia rilasciata.
Metodo pubblico | AssertIsCheckedIn | Controlla che il documento sia in Check-In.
Metodo pubblico | AssertIsCheckedInOrCheckedOutByMe | Controlla che il documento sia in Check-In oppure in Check-Out da me.
Metodo pubblico | AssertIsCheckedOut | Controlla che il documento sia in Check-Out.
Metodo pubblico | AssertIsCheckedOutByMe | Controlla che il documento sia in Check-Out da me.
Metodo pubblico | AssertIsClosed | Controlla che la commessa non sia chiusa
Metodo pubblico | AssertIsNotApprovedState | Controlla che l'anagrafica non sia in uno stato di "Approved".
Metodo pubblico | AssertIsNotInDist | Controlla che l'anagrafica non sia presente in distinta.
Metodo pubblico | AssertIsNotNewVaultFile | Si assicura che il documento, con l'area locale attiva, non sia in checkout perché nuovo e quindi non esista il file sul vault.
Metodo pubblico | AssertIsNotOutdatedState | Controlla che l'anagrafica non sia Superata.
Metodo pubblico | AssertIsNotPendingApprovalState | Controlla che l'anagrafica non sia in uno stato di "Pending Approval".
Metodo pubblico | AssertIsNotUnchengeableState | Controlla che l'anagrafica non sia Obsoleta.
Metodo pubblico | AssertIsNotWorkingState | Controlla che l'anagrafica non sia in Lavorazione.
Metodo pubblico | AssertIsNotWritableOutdatedState | Controlla che l'anagrafica non sia Superata in adattamento.
Metodo pubblico | AssertIsOutdatedState | Controlla che l'anagrafica sia Superata.
Metodo pubblico | AssertIsPendingApprovalState | Controlla che l'anagrafica sia rilasciata.
Metodo pubblico | AssertIsPwsModeActive | Controlla che sia attiva la pws.
Metodo pubblico | AssertIsUnchangeableState | Controlla che l'anagrafica sia Obsoleta.
Metodo pubblico | AssertIsUsersMode | Controlla che sia attiva la gestione degli utenti.
Metodo pubblico | AssertIsVgr |
Metodo pubblico | AssertIsWorkingState | Controlla che l'anagrafica sia in Lavorazione.
Metodo pubblico | AssertIsWritableState | Controlla che l'anagrafica sia in uno stato scrivibile.
Metodo pubblico | AssertObject | Solleva l'eccezione di ArgumentNullException se il parametro passato è null.
Metodo pubblico | AssertPathIsRooted | Solleva l'eccezione di FileNotFoundException se il file non è presente.
Metodo pubblico | AssertPathNotTooLong | Genera una eccezione se il nome di file completo contiene più di 259 caratteri o se il nome di directory contiene più di 247 caratteri. Da tenere presente che, per gestire i file .erased, ne viene calcolato l'eventuale nome prima di effettuare il controllo di validità. Questo comporta l'accodazione di 26 caratteri al path passato in ingresso.
Metodo pubblico | AssertSparePartsManagement | Controlla che la gestione dei ricambi sia attiva.
Metodo pubblico | AssertSparePartsManagement(DedData) | Controlla che la gestione dei ricambi sia attiva in base all'anagrafica specificata in ingresso.
Metodo pubblico | AssertString | Solleva l'eccezione di ArgumentNullException se il parametro passato è null.
Metodo pubblico | AssertString2 | Solleva l'eccezione di ArgumentNullException se il parametro passato è null.
Metodo pubblico | AssertUserCan(DedStandardPerm, DedTypeBase) | Controlla che l'utente abbia il permesso passato.
Metodo pubblico | AssertUserCan(DedStandardPerm, Boolean) | Controlla che l'utente abbia il permesso passato.
Metodo pubblico | AssertUserCanAdmin | Controlla che l'utente abbia il permesso di Amministrare in generale.
Metodo pubblico | AssertUserCanAdminAtt | Controlla che l'utente abbia il permesso di Amministrare gli attributi.
Metodo pubblico | AssertUserCanAdminFam | Controlla che l'utente abbia il permesso di Amministrare le famiglie.
Metodo pubblico | AssertUserCanAssignECO(DedComm) | Controlla che l'utente abbia il permesso di assegnare gli ECO.
Metodo pubblico | AssertUserCanAssignECO(DedType) | Controlla che l'utente abbia il permesso di assegnare gli ECO.
Metodo pubblico | AssertUserCanAttach(Boolean) | Controlla che l'utente abbia il permesso di allegare nei file primari.
Metodo pubblico | AssertUserCanAttach(DedType) | Controlla che l'utente abbia il permesso di Allegare sulla specifica famiglia.
Metodo pubblico | AssertUserCanAttachAnagrComm(Boolean) | Controlla che l'utente abbia il permesso di collegare anagrafiche alle commesse.
Metodo pubblico | AssertUserCanAttachAnagrComm(DedComm) | Controlla che l'utente abbia il permesso di collegare anagrafiche alle commesse.
Metodo pubblico | AssertUserCanAttachDocComm(Boolean) | Controlla che l'utente abbia il permesso di collegare documenti alle commesse.
Metodo pubblico | AssertUserCanAttachDocComm(DedComm) | Controlla che l'utente abbia il permesso di collegare documenti alle commesse.
Metodo pubblico | AssertUserCanAttachDocECO(DedComm) | Controlla che l'utente abbia il permesso di associare documenti agli ECO.
Metodo pubblico | AssertUserCanAttachDocECO(DedType) | Controlla che l'utente abbia il permesso di associare documenti agli ECO.
Metodo pubblico | AssertUserCanAttachOrManageAttach | Controlla che l'utente abbia il permesso di allegare nei file primari o allegati.
Metodo pubblico | AssertUserCanCloseComm(Boolean) | Controlla che l'utente abbia il permesso di chiudere le commesse.
Metodo pubblico | AssertUserCanCloseComm(DedComm) | Controlla che l'utente abbia il permesso di chiudere le commesse.
Metodo pubblico | AssertUserCanCreate(Boolean) | Controlla che l'utente abbia il permesso di Creazione in generale.
Metodo pubblico | AssertUserCanCreate(DedType) | Controlla che l'utente abbia il permesso di Creazione sulla specifica famiglia.
Metodo pubblico | AssertUserCanCreateComm(Boolean) | Controlla che l'utente abbia il permesso di creare le commesse.
Metodo pubblico | AssertUserCanCreateComm(DedComm) | Controlla che l'utente abbia il permesso di creare le commesse.
Metodo pubblico | AssertUserCanCreateECO(DedComm) | Controlla che l'utente abbia il permesso di creare gli ECO.
Metodo pubblico | AssertUserCanCreateECO(DedType) | Controlla che l'utente abbia il permesso di creare gli ECO.
Metodo pubblico | AssertUserCanCreateFolder(Boolean) | Controlla che l'utente abbia il permesso di creare le cartelle.
Metodo pubblico | AssertUserCanCreateFolder(String) | Controlla che l'utente abbia il permesso di creare le cartelle.
Metodo pubblico | AssertUserCanDeAttach | Controlla che l'utente abbia il permesso di Allegare sulla specifica famiglia.
Metodo pubblico | AssertUserCanDeAttachAnagrComm(Boolean) | Controlla che l'utente abbia il permesso di scollegare anagrafiche alle commesse.
Metodo pubblico | AssertUserCanDeAttachAnagrComm(DedComm) | Controlla che l'utente abbia il permesso di scollegare anagrafiche alle commesse.
Metodo pubblico | AssertUserCanDeAttachDocComm(Boolean) | Controlla che l'utente abbia il permesso di scollegare documenti alle commesse.
Metodo pubblico | AssertUserCanDeAttachDocComm(DedComm) | Controlla che l'utente abbia il permesso di scollegare documenti alle commesse.
Metodo pubblico | AssertUserCanDeleteDocECO | Controlla che l'utente abbia il permesso di eliminare i documenti dall'ECO.
Metodo pubblico | AssertUserCanDeleteDocECO(DedComm) | Controlla che l'utente abbia il permesso di eliminare i documenti dall'ECO.
Metodo pubblico | AssertUserCanDeleteDocECO(DedType) | Controlla che l'utente abbia il permesso di eliminare i documenti dall'ECO.
Metodo pubblico | AssertUserCanEditComm(Boolean) | Controlla che l'utente abbia il permesso di editare le commesse.
Metodo pubblico | AssertUserCanEditComm(DedComm) | Controlla che l'utente abbia il permesso di editare le commesse.
Metodo pubblico | AssertUserCanEditECO(DedComm) | Controlla che l'utente abbia il permesso di modificare gli ECO.
Metodo pubblico | AssertUserCanEditECO(DedType) | Controlla che l'utente abbia il permesso di modificare gli ECO.
Metodo pubblico | AssertUserCanEditFolder(Boolean) | Controlla che l'utente abbia il permesso di modificare le cartelle.
Metodo pubblico | AssertUserCanEditFolder(String) | Controlla che l'utente abbia il permesso di modificare le cartelle.
Metodo pubblico | AssertUserCanErase(Boolean) | Controlla che l'utente abbia il permesso di Eliminare in generale.
Metodo pubblico | AssertUserCanErase(DedType) | Controlla che l'utente abbia il permesso di Eliminare sulla specifica famiglia.
Metodo pubblico | AssertUserCanEraseComm(Boolean) | Controlla che l'utente abbia il permesso di eliminare le commesse.
Metodo pubblico | AssertUserCanEraseComm(DedComm) | Controlla che l'utente abbia il permesso di eliminare le commesse.
Metodo pubblico | AssertUserCanEraseFolder(Boolean) | Controlla che l'utente abbia il permesso di cancellare le cartelle.
Metodo pubblico | AssertUserCanEraseFolder(String) | Controlla che l'utente abbia il permesso di cancellare le cartelle.
Metodo pubblico | AssertUserCanExceuteCmdForced | Controlla che l'utente abbia il permesso di Amministrare le famiglie.
Metodo pubblico | AssertUserCanManageAttach(Boolean) | Controlla che l'utente abbia il permesso di gestione degli allegati.
Metodo pubblico | AssertUserCanManageAttach(DedType) | Controlla che l'utente abbia il permesso di Allegare sulla specifica famiglia.
Metodo pubblico | AssertUserCanOnComm | Controlla che l'utente abbia il permesso passato.
Metodo pubblico | AssertUserCanOnFolder | Controlla che l'utente abbia il permesso passato.
Metodo pubblico | AssertUserCanRead(Boolean) | Controlla che l'utente abbia il permesso di lettura in generale.
Metodo pubblico | AssertUserCanRead(DedType) | Controlla che l'utente abbia il permesso di lettura sulla specifica famiglia.
Metodo pubblico | AssertUserCanReadComm(Boolean) | Controlla che l'utente abbia il permesso di visualizzare le commesse.
Metodo pubblico | AssertUserCanReadComm(DedComm) | Controlla che l'utente abbia il permesso di visualizzare le commesse.
Metodo pubblico | AssertUserCanReadECO(DedComm) | Controlla che l'utente abbia il permesso di visualizzare gli ECO.
Metodo pubblico | AssertUserCanReadECO(DedType) | Controlla che l'utente abbia il permesso di visualizzare gli ECO.
Metodo pubblico | AssertUserCanReadFolder(Boolean) | Controlla che l'utente abbia il permesso di visualizzare le cartelle.
Metodo pubblico | AssertUserCanReadFolder(String) | Controlla che l'utente abbia il permesso di visualizzare le cartelle.
Metodo pubblico | AssertUserCanReOpenComm(Boolean) | Controlla che l'utente abbia il permesso di riaprire le commesse.
Metodo pubblico | AssertUserCanReOpenComm(DedComm) | Controlla che l'utente abbia il permesso di riaprire le commesse.
Metodo pubblico | AssertUserCanRev(Boolean) | Controlla che l'utente abbia il permesso di Revisionare in generale.
Metodo pubblico | AssertUserCanRev(DedType) | Controlla che l'utente abbia il permesso di Revisionare sulla specifica famiglia.
Metodo pubblico | AssertUserCanRil(Boolean) | Controlla che l'utente abbia il permesso di Rilasciare in generale.
Metodo pubblico | AssertUserCanRil(DedType) | Controlla che l'utente abbia il permesso di Rilasciare sulla specifica famiglia.
Metodo pubblico | AssertUserCanUnRil(Boolean) | Controlla che l'utente abbia il permesso di Togliere il Rilasciare in generale.
Metodo pubblico | AssertUserCanUnRil(DedType) | Controlla che l'utente abbia il permesso di Togliere il Rilasciare sulla specifica famiglia.
Metodo pubblico | AssertUserCanWrite(Boolean) | Controlla che l'utente abbia il permesso di Modifica in generale.
Metodo pubblico | AssertUserCanWrite(DedType) | Controlla che l'utente abbia il permesso di Modifica sulla specifica famiglia.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Metodi di Assert

Il tipo Assert espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AssertAllDocumentsAreCheckedInOrCheckOutByMe(DedData) | Solleva una eccezione se esistono dei documenti associati all'anagrafica che non sono in checkin o in checkout da me.
Metodo pubblico | AssertAllDocumentsAreCheckedInOrCheckOutByMe(DedDocList) | Solleva una eccezione se esistono dei documenti che non sono in checkin o in checkout da me.
Metodo pubblico | AssertAnagrNotNull | Verifica che il DedId ed il DedRev siano presenti nel Database..
Metodo pubblico | AssertCanSup | Controlla che ci sia almeno un'altra revisione nello stato Lavorazione/Rilasciato.
Metodo pubblico | AssertCfgNotUsed(DedDoc, CfgOperation) |
Metodo pubblico | AssertCfgNotUsed(DedDoc, ListString) |
Metodo pubblico | AssertCorporateIsMaster | Controlla che l'utente abbia il permesso di Amministrare in generale.
Metodo pubblico | AssertDbBomColSequence | Si assicura che le colonne della distinta in salvataggio siano nell'ordine corretto. Controlla che le prime 5 colonne siano $lev,ID,REV,ID,REV
Metodo pubblico | AssertDocHasData | Controlla che il documento non sia associato a nessuna anagrafica.
Metodo pubblico | AssertDocHasNotMoreThanOneConfigContext(DedData, Boolean) | Se i documenti dell'anagrafica sono associati tramite più configurazioni blocco!
Metodo pubblico | AssertDocHasNotMoreThanOneConfigContext(DedDoc, Boolean) | Se i documenti dell'anagrafica sono associati tramite più configurazioni blocco!
Metodo pubblico | AssertDocIsNotVital | Si assicura che il documento non sia dipendenza vitale di qualche documento. Nel caso sia dipendenza controlla che la dipendenza sia nella lista passata come secondo parametro altrimenti genera eccezione ( questo controllo viene fatto solo se la lista è diversa da null ).
Metodo pubblico | AssertDocumentNotNull | Verifica che il documento passato non sia null, altrimenti solleva una eccezione indicando che il file fileName non risulta essere registrato nel Database.
Metodo pubblico | AssertDocumentNull | Verifica che il documento passato sia null, altrimenti solleva una eccezione.
Metodo pubblico | AssertDocUsedInOneAnagr | Sis assicura che il documento sia usato solamente in un'anagrafica.
Metodo pubblico | AssertECOExistsAnagComm | Verifica l'esistenza dell'anagrafica o della commessa associata all'ECO.
Metodo pubblico | AssertECOIsCorrectlyAssigned | Verifica lo stato dell'ECO e genera una eccezione se lo stato è "Assegnato" e l'utente corrente è diverso da quello che lo ha preso in carico.
Metodo pubblico | AssertECOIsNotClosed | Verifica lo stato dell'Eco e genera una eccezione se lo stato è "Chiuso".
Metodo pubblico | AssertECOOperationOnDocument | Verifica se l'utente ha il permesso di eseguire le operazioni sui documenti associato all'ECO.
Metodo pubblico | AssertECORoot | Verifica che esista la root dedicata agli Eco.
Metodo pubblico | AssertFileCadIsNotDuplicated | Controlla che il percorso passato non coincida con il percorso di base di una delle root all'interno delle quali è proibito salvare. Tipicamente %WORK%
Metodo pubblico | AssertFileExists | Solleva l'eccezione di FileNotFoundException se il file non è presente.
Metodo pubblico | AssertFileExists2 | Solleva l'eccezione di FileNotFoundException se il file non è presente.
Metodo pubblico | AssertFileIsInRoot(DedRootInfo) | Verifica che le informazioni di un percorso sia nei percorsi validi del Database.
Metodo pubblico | AssertFileIsInRoot(String) | Verifica che il percorso passato sia nei percorsi validi del Database.
Metodo pubblico | AssertFileIsNotCreatingDirectlyInForbiddenRoots | Controlla che il percorso passato non coincida con il percorso di base di una delle root all'interno delle quali è proibito salvare. Tipicamente %WORK%
Metodo pubblico | AssertFileIsNotLocked | Verifica che il file passato non sia bloccato, altrimenti solleva una eccezione. Se il file non esiste non fa nulla.
Metodo pubblico | AssertFileNotExists | Controlla che un file NON esista, altrimenti solleva una eccezione.
Metodo pubblico | AssertGuid | Solleva l'eccezione di ArgumentNullException se il parametro passato è Guid.Empty.
Metodo pubblico | AssertHadntMovedDocuments | Controlla che l'anagrafica non puntasse a documenti che poi sono stati ricodificati
Metodo pubblico | AssertHeaderIsNotLocked | Controlla che l'header della distinta non sia bloccato.
Metodo pubblico | AssertIsAllowedStateTransaction | Controlla se il passaggio di stato è ammesso per l'utente
Metodo pubblico | AssertIsApprovedState | Controlla che l'anagrafica sia rilasciata.
Metodo pubblico | AssertIsCheckedIn | Controlla che il documento sia in Check-In.
Metodo pubblico | AssertIsCheckedInOrCheckedOutByMe | Controlla che il documento sia in Check-In oppure in Check-Out da me.
Metodo pubblico | AssertIsCheckedOut | Controlla che il documento sia in Check-Out.
Metodo pubblico | AssertIsCheckedOutByMe | Controlla che il documento sia in Check-Out da me.
Metodo pubblico | AssertIsClosed | Controlla che la commessa non sia chiusa
Metodo pubblico | AssertIsNotApprovedState | Controlla che l'anagrafica non sia in uno stato di "Approved".
Metodo pubblico | AssertIsNotInDist | Controlla che l'anagrafica non sia presente in distinta.
Metodo pubblico | AssertIsNotNewVaultFile | Si assicura che il documento, con l'area locale attiva, non sia in checkout perché nuovo e quindi non esista il file sul vault.
Metodo pubblico | AssertIsNotOutdatedState | Controlla che l'anagrafica non sia Superata.
Metodo pubblico | AssertIsNotPendingApprovalState | Controlla che l'anagrafica non sia in uno stato di "Pending Approval".
Metodo pubblico | AssertIsNotUnchengeableState | Controlla che l'anagrafica non sia Obsoleta.
Metodo pubblico | AssertIsNotWorkingState | Controlla che l'anagrafica non sia in Lavorazione.
Metodo pubblico | AssertIsNotWritableOutdatedState | Controlla che l'anagrafica non sia Superata in adattamento.
Metodo pubblico | AssertIsOutdatedState | Controlla che l'anagrafica sia Superata.
Metodo pubblico | AssertIsPendingApprovalState | Controlla che l'anagrafica sia rilasciata.
Metodo pubblico | AssertIsPwsModeActive | Controlla che sia attiva la pws.
Metodo pubblico | AssertIsUnchangeableState | Controlla che l'anagrafica sia Obsoleta.
Metodo pubblico | AssertIsUsersMode | Controlla che sia attiva la gestione degli utenti.
Metodo pubblico | AssertIsVgr |
Metodo pubblico | AssertIsWorkingState | Controlla che l'anagrafica sia in Lavorazione.
Metodo pubblico | AssertIsWritableState | Controlla che l'anagrafica sia in uno stato scrivibile.
Metodo pubblico | AssertObject | Solleva l'eccezione di ArgumentNullException se il parametro passato è null.
Metodo pubblico | AssertPathIsRooted | Solleva l'eccezione di FileNotFoundException se il file non è presente.
Metodo pubblico | AssertPathNotTooLong | Genera una eccezione se il nome di file completo contiene più di 259 caratteri o se il nome di directory contiene più di 247 caratteri. Da tenere presente che, per gestire i file .erased, ne viene calcolato l'eventuale nome prima di effettuare il controllo di validità. Questo comporta l'accodazione di 26 caratteri al path passato in ingresso.
Metodo pubblico | AssertSparePartsManagement | Controlla che la gestione dei ricambi sia attiva.
Metodo pubblico | AssertSparePartsManagement(DedData) | Controlla che la gestione dei ricambi sia attiva in base all'anagrafica specificata in ingresso.
Metodo pubblico | AssertString | Solleva l'eccezione di ArgumentNullException se il parametro passato è null.
Metodo pubblico | AssertString2 | Solleva l'eccezione di ArgumentNullException se il parametro passato è null.
Metodo pubblico | AssertUserCan(DedStandardPerm, DedTypeBase) | Controlla che l'utente abbia il permesso passato.
Metodo pubblico | AssertUserCan(DedStandardPerm, Boolean) | Controlla che l'utente abbia il permesso passato.
Metodo pubblico | AssertUserCanAdmin | Controlla che l'utente abbia il permesso di Amministrare in generale.
Metodo pubblico | AssertUserCanAdminAtt | Controlla che l'utente abbia il permesso di Amministrare gli attributi.
Metodo pubblico | AssertUserCanAdminFam | Controlla che l'utente abbia il permesso di Amministrare le famiglie.
Metodo pubblico | AssertUserCanAssignECO(DedComm) | Controlla che l'utente abbia il permesso di assegnare gli ECO.
Metodo pubblico | AssertUserCanAssignECO(DedType) | Controlla che l'utente abbia il permesso di assegnare gli ECO.
Metodo pubblico | AssertUserCanAttach(Boolean) | Controlla che l'utente abbia il permesso di allegare nei file primari.
Metodo pubblico | AssertUserCanAttach(DedType) | Controlla che l'utente abbia il permesso di Allegare sulla specifica famiglia.
Metodo pubblico | AssertUserCanAttachAnagrComm(Boolean) | Controlla che l'utente abbia il permesso di collegare anagrafiche alle commesse.
Metodo pubblico | AssertUserCanAttachAnagrComm(DedComm) | Controlla che l'utente abbia il permesso di collegare anagrafiche alle commesse.
Metodo pubblico | AssertUserCanAttachDocComm(Boolean) | Controlla che l'utente abbia il permesso di collegare documenti alle commesse.
Metodo pubblico | AssertUserCanAttachDocComm(DedComm) | Controlla che l'utente abbia il permesso di collegare documenti alle commesse.
Metodo pubblico | AssertUserCanAttachDocECO(DedComm) | Controlla che l'utente abbia il permesso di associare documenti agli ECO.
Metodo pubblico | AssertUserCanAttachDocECO(DedType) | Controlla che l'utente abbia il permesso di associare documenti agli ECO.
Metodo pubblico | AssertUserCanAttachOrManageAttach | Controlla che l'utente abbia il permesso di allegare nei file primari o allegati.
Metodo pubblico | AssertUserCanCloseComm(Boolean) | Controlla che l'utente abbia il permesso di chiudere le commesse.
Metodo pubblico | AssertUserCanCloseComm(DedComm) | Controlla che l'utente abbia il permesso di chiudere le commesse.
Metodo pubblico | AssertUserCanCreate(Boolean) | Controlla che l'utente abbia il permesso di Creazione in generale.
Metodo pubblico | AssertUserCanCreate(DedType) | Controlla che l'utente abbia il permesso di Creazione sulla specifica famiglia.
Metodo pubblico | AssertUserCanCreateComm(Boolean) | Controlla che l'utente abbia il permesso di creare le commesse.
Metodo pubblico | AssertUserCanCreateComm(DedComm) | Controlla che l'utente abbia il permesso di creare le commesse.
Metodo pubblico | AssertUserCanCreateECO(DedComm) | Controlla che l'utente abbia il permesso di creare gli ECO.
Metodo pubblico | AssertUserCanCreateECO(DedType) | Controlla che l'utente abbia il permesso di creare gli ECO.
Metodo pubblico | AssertUserCanCreateFolder(Boolean) | Controlla che l'utente abbia il permesso di creare le cartelle.
Metodo pubblico | AssertUserCanCreateFolder(String) | Controlla che l'utente abbia il permesso di creare le cartelle.
Metodo pubblico | AssertUserCanDeAttach | Controlla che l'utente abbia il permesso di Allegare sulla specifica famiglia.
Metodo pubblico | AssertUserCanDeAttachAnagrComm(Boolean) | Controlla che l'utente abbia il permesso di scollegare anagrafiche alle commesse.
Metodo pubblico | AssertUserCanDeAttachAnagrComm(DedComm) | Controlla che l'utente abbia il permesso di scollegare anagrafiche alle commesse.
Metodo pubblico | AssertUserCanDeAttachDocComm(Boolean) | Controlla che l'utente abbia il permesso di scollegare documenti alle commesse.
Metodo pubblico | AssertUserCanDeAttachDocComm(DedComm) | Controlla che l'utente abbia il permesso di scollegare documenti alle commesse.
Metodo pubblico | AssertUserCanDeleteDocECO | Controlla che l'utente abbia il permesso di eliminare i documenti dall'ECO.
Metodo pubblico | AssertUserCanDeleteDocECO(DedComm) | Controlla che l'utente abbia il permesso di eliminare i documenti dall'ECO.
Metodo pubblico | AssertUserCanDeleteDocECO(DedType) | Controlla che l'utente abbia il permesso di eliminare i documenti dall'ECO.
Metodo pubblico | AssertUserCanEditComm(Boolean) | Controlla che l'utente abbia il permesso di editare le commesse.
Metodo pubblico | AssertUserCanEditComm(DedComm) | Controlla che l'utente abbia il permesso di editare le commesse.
Metodo pubblico | AssertUserCanEditECO(DedComm) | Controlla che l'utente abbia il permesso di modificare gli ECO.
Metodo pubblico | AssertUserCanEditECO(DedType) | Controlla che l'utente abbia il permesso di modificare gli ECO.
Metodo pubblico | AssertUserCanEditFolder(Boolean) | Controlla che l'utente abbia il permesso di modificare le cartelle.
Metodo pubblico | AssertUserCanEditFolder(String) | Controlla che l'utente abbia il permesso di modificare le cartelle.
Metodo pubblico | AssertUserCanErase(Boolean) | Controlla che l'utente abbia il permesso di Eliminare in generale.
Metodo pubblico | AssertUserCanErase(DedType) | Controlla che l'utente abbia il permesso di Eliminare sulla specifica famiglia.
Metodo pubblico | AssertUserCanEraseComm(Boolean) | Controlla che l'utente abbia il permesso di eliminare le commesse.
Metodo pubblico | AssertUserCanEraseComm(DedComm) | Controlla che l'utente abbia il permesso di eliminare le commesse.
Metodo pubblico | AssertUserCanEraseFolder(Boolean) | Controlla che l'utente abbia il permesso di cancellare le cartelle.
Metodo pubblico | AssertUserCanEraseFolder(String) | Controlla che l'utente abbia il permesso di cancellare le cartelle.
Metodo pubblico | AssertUserCanExceuteCmdForced | Controlla che l'utente abbia il permesso di Amministrare le famiglie.
Metodo pubblico | AssertUserCanManageAttach(Boolean) | Controlla che l'utente abbia il permesso di gestione degli allegati.
Metodo pubblico | AssertUserCanManageAttach(DedType) | Controlla che l'utente abbia il permesso di Allegare sulla specifica famiglia.
Metodo pubblico | AssertUserCanOnComm | Controlla che l'utente abbia il permesso passato.
Metodo pubblico | AssertUserCanOnFolder | Controlla che l'utente abbia il permesso passato.
Metodo pubblico | AssertUserCanRead(Boolean) | Controlla che l'utente abbia il permesso di lettura in generale.
Metodo pubblico | AssertUserCanRead(DedType) | Controlla che l'utente abbia il permesso di lettura sulla specifica famiglia.
Metodo pubblico | AssertUserCanReadComm(Boolean) | Controlla che l'utente abbia il permesso di visualizzare le commesse.
Metodo pubblico | AssertUserCanReadComm(DedComm) | Controlla che l'utente abbia il permesso di visualizzare le commesse.
Metodo pubblico | AssertUserCanReadECO(DedComm) | Controlla che l'utente abbia il permesso di visualizzare gli ECO.
Metodo pubblico | AssertUserCanReadECO(DedType) | Controlla che l'utente abbia il permesso di visualizzare gli ECO.
Metodo pubblico | AssertUserCanReadFolder(Boolean) | Controlla che l'utente abbia il permesso di visualizzare le cartelle.
Metodo pubblico | AssertUserCanReadFolder(String) | Controlla che l'utente abbia il permesso di visualizzare le cartelle.
Metodo pubblico | AssertUserCanReOpenComm(Boolean) | Controlla che l'utente abbia il permesso di riaprire le commesse.
Metodo pubblico | AssertUserCanReOpenComm(DedComm) | Controlla che l'utente abbia il permesso di riaprire le commesse.
Metodo pubblico | AssertUserCanRev(Boolean) | Controlla che l'utente abbia il permesso di Revisionare in generale.
Metodo pubblico | AssertUserCanRev(DedType) | Controlla che l'utente abbia il permesso di Revisionare sulla specifica famiglia.
Metodo pubblico | AssertUserCanRil(Boolean) | Controlla che l'utente abbia il permesso di Rilasciare in generale.
Metodo pubblico | AssertUserCanRil(DedType) | Controlla che l'utente abbia il permesso di Rilasciare sulla specifica famiglia.
Metodo pubblico | AssertUserCanUnRil(Boolean) | Controlla che l'utente abbia il permesso di Togliere il Rilasciare in generale.
Metodo pubblico | AssertUserCanUnRil(DedType) | Controlla che l'utente abbia il permesso di Togliere il Rilasciare sulla specifica famiglia.
Metodo pubblico | AssertUserCanWrite(Boolean) | Controlla che l'utente abbia il permesso di Modifica in generale.
Metodo pubblico | AssertUserCanWrite(DedType) | Controlla che l'utente abbia il permesso di Modifica sulla specifica famiglia.
Torna su
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertAllDocumentsAreCheckedInOrCheckOutByMe

Metodo AssertAssertAllDocumentsAreCheckedInOrCheckOutByMe
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AssertAllDocumentsAreCheckedInOrCheckOutByMe(DedData) | Solleva una eccezione se esistono dei documenti associati all'anagrafica che non sono in checkin o in checkout da me.
Metodo pubblico | AssertAllDocumentsAreCheckedInOrCheckOutByMe(DedDocList) | Solleva una eccezione se esistono dei documenti che non sono in checkin o in checkout da me.
Torna su
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertAllDocumentsAreCheckedInOrCheckOutByMe(DedData)

Metodo AssertAssertAllDocumentsAreCheckedInOrCheckOutByMe(DedData)
Solleva una eccezione se esistono dei documenti associati all'anagrafica che non sono in checkin o in checkout da me.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertAllDocumentsAreCheckedInOrCheckOutByMe(
    DedData data
)
Public Sub AssertAllDocumentsAreCheckedInOrCheckOutByMe (
    data As DedData
)
public:
void AssertAllDocumentsAreCheckedInOrCheckOutByMe(
    DedData^ data
)
member AssertAllDocumentsAreCheckedInOrCheckOutByMe :
        data : DedData -> unit

Parametri

data DedData
Anagrafica da analizzare
Vedi anche

Documentazione

Classe Assert
Overload di AssertAllDocumentsAreCheckedInOrCheckOutByMe
Namespace DedNet.Core


Metodo Assert.AssertAllDocumentsAreCheckedInOrCheckOutByMe(DedDocList)

Metodo AssertAssertAllDocumentsAreCheckedInOrCheckOutByMe(DedDocList)
Solleva una eccezione se esistono dei documenti che non sono in checkin o in checkout da me.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertAllDocumentsAreCheckedInOrCheckOutByMe(
    DedDocList docList
)
Public Sub AssertAllDocumentsAreCheckedInOrCheckOutByMe (
    docList As DedDocList
)
public:
void AssertAllDocumentsAreCheckedInOrCheckOutByMe(
    DedDocList^ docList
)
member AssertAllDocumentsAreCheckedInOrCheckOutByMe :
        docList : DedDocList -> unit

Parametri

docList DedDocList
Documenti da analizzare
Vedi anche

Documentazione

Classe Assert
Overload di AssertAllDocumentsAreCheckedInOrCheckOutByMe
Namespace DedNet.Core


Metodo Assert.AssertAnagrNotNull

Metodo AssertAssertAnagrNotNull
Verifica che il DedId ed il DedRev siano presenti nel Database..

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertAnagrNotNull(
    string dedid,
    string dedrev
)
Public Sub AssertAnagrNotNull (
    dedid As String,
    dedrev As String
)
public:
void AssertAnagrNotNull(
    String^ dedid,
    String^ dedrev
)
member AssertAnagrNotNull :
        dedid : string *
        dedrev : string -> unit

Parametri

dedid String
DedId da verificare.
dedrev String
DedRev da verificare.
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertCanSup

Metodo AssertAssertCanSup
Controlla che ci sia almeno un'altra revisione nello stato Lavorazione/Rilasciato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertCanSup(
    DedData data
)
Public Sub AssertCanSup (
    data As DedData
)
public:
void AssertCanSup(
    DedData^ data
)
member AssertCanSup :
        data : DedData -> unit

Parametri

data DedData
anagrafica da controllare
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertCfgNotUsed

Metodo AssertAssertCfgNotUsed
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AssertCfgNotUsed(DedDoc, CfgOperation) |
Metodo pubblico | AssertCfgNotUsed(DedDoc, ListString) |
Torna su
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertCfgNotUsed(DedDoc, CfgOperation)

Metodo AssertAssertCfgNotUsed(DedDoc, CfgOperation)

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertCfgNotUsed(
    DedDoc dedDoc,
    CfgOperation cfgOp
)
Public Sub AssertCfgNotUsed (
    dedDoc As DedDoc,
    cfgOp As CfgOperation
)
public:
void AssertCfgNotUsed(
    DedDoc^ dedDoc,
    CfgOperation^ cfgOp
)
member AssertCfgNotUsed :
        dedDoc : DedDoc *
        cfgOp : CfgOperation -> unit

Parametri

dedDoc DedDoc
cfgOp CfgOperation
Vedi anche

Documentazione

Classe Assert
Overload di AssertCfgNotUsed
Namespace DedNet.Core


Metodo Assert.AssertCfgNotUsed(DedDoc, List<String>)

Metodo AssertAssertCfgNotUsed(DedDoc, ListString)

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertCfgNotUsed(
    DedDoc dedDoc,
    List<string> cfgNames
)
Public Sub AssertCfgNotUsed (
    dedDoc As DedDoc,
    cfgNames As List(Of String)
)
public:
void AssertCfgNotUsed(
    DedDoc^ dedDoc,
    List<String^>^ cfgNames
)
member AssertCfgNotUsed :
        dedDoc : DedDoc *
        cfgNames : List<string> -> unit

Parametri

dedDoc DedDoc
cfgNames List String
Vedi anche

Documentazione

Classe Assert
Overload di AssertCfgNotUsed
Namespace DedNet.Core


Metodo Assert.AssertCorporateIsMaster

Metodo AssertAssertCorporateIsMaster
Controlla che l'utente abbia il permesso di Amministrare in generale.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertCorporateIsMaster()
Public Sub AssertCorporateIsMaster
public:
void AssertCorporateIsMaster()
member AssertCorporateIsMaster : unit -> unit
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertDbBomColSequence

Metodo AssertAssertDbBomColSequence
Si assicura che le colonne della distinta in salvataggio siano nell'ordine corretto. Controlla che le prime 5 colonne siano $lev,ID,REV,ID,REV

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertDbBomColSequence(
    Object[] tabarray
)
Public Sub AssertDbBomColSequence (
    tabarray As Object()
)
public:
void AssertDbBomColSequence(
    array<Object^>^ tabarray
)
member AssertDbBomColSequence :
        tabarray : Object[] -> unit

Parametri

tabarray Object
Header contenente gli attributi da usare nella distinta
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertDocHasData

Metodo AssertAssertDocHasData
Controlla che il documento non sia associato a nessuna anagrafica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertDocHasData(
    DedDoc deddoc
)
Public Sub AssertDocHasData (
    deddoc As DedDoc
)
public:
void AssertDocHasData(
    DedDoc^ deddoc
)
member AssertDocHasData :
        deddoc : DedDoc -> unit

Parametri

deddoc DedDoc
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertDocHasNotMoreThanOneConfigContext

Metodo AssertAssertDocHasNotMoreThanOneConfigContext
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AssertDocHasNotMoreThanOneConfigContext(DedData, Boolean) | Se i documenti dell'anagrafica sono associati tramite più configurazioni blocco!
Metodo pubblico | AssertDocHasNotMoreThanOneConfigContext(DedDoc, Boolean) | Se i documenti dell'anagrafica sono associati tramite più configurazioni blocco!
Torna su
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertDocHasNotMoreThanOneConfigContext(DedData, Boolean)

Metodo AssertAssertDocHasNotMoreThanOneConfigContext(DedData, Boolean)
Se i documenti dell'anagrafica sono associati tramite più configurazioni blocco!

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertDocHasNotMoreThanOneConfigContext(
    DedData data,
    bool msgUseCad = true
)
Public Sub AssertDocHasNotMoreThanOneConfigContext (
    data As DedData,
    Optional msgUseCad As Boolean = true
)
public:
void AssertDocHasNotMoreThanOneConfigContext(
    DedData^ data,
    bool msgUseCad = true
)
member AssertDocHasNotMoreThanOneConfigContext :
        data : DedData *
        ?msgUseCad : bool
(* Defaults:
        let _msgUseCad = defaultArg msgUseCad true
*)
-> unit

Parametri

data DedData
Anagrafica da verificare.
msgUseCad Boolean (Optional)
Indica se visualizzare il messaggio relativo all'effetuazre l'operazione all'interno del CAD
Vedi anche

Documentazione

Classe Assert
Overload di AssertDocHasNotMoreThanOneConfigContext
Namespace DedNet.Core


Metodo Assert.AssertDocHasNotMoreThanOneConfigContext(DedDoc, Boolean)

Metodo AssertAssertDocHasNotMoreThanOneConfigContext(DedDoc, Boolean)
Se i documenti dell'anagrafica sono associati tramite più configurazioni blocco!

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertDocHasNotMoreThanOneConfigContext(
    DedDoc doc,
    bool msgUseCad = true
)
Public Sub AssertDocHasNotMoreThanOneConfigContext (
    doc As DedDoc,
    Optional msgUseCad As Boolean = true
)
public:
void AssertDocHasNotMoreThanOneConfigContext(
    DedDoc^ doc,
    bool msgUseCad = true
)
member AssertDocHasNotMoreThanOneConfigContext :
        doc : DedDoc *
        ?msgUseCad : bool
(* Defaults:
        let _msgUseCad = defaultArg msgUseCad true
*)
-> unit

Parametri

doc DedDoc
Documento da verificare.
msgUseCad Boolean (Optional)
Indica se visualizzare il messaggio relativo all'effetuazre l'operazione all'interno del CAD
Vedi anche

Documentazione

Classe Assert
Overload di AssertDocHasNotMoreThanOneConfigContext
Namespace DedNet.Core


Metodo Assert.AssertDocIsNotVital

Metodo AssertAssertDocIsNotVital
Si assicura che il documento non sia dipendenza vitale di qualche documento. Nel caso sia dipendenza controlla che la dipendenza sia nella lista passata come secondo parametro altrimenti genera eccezione ( questo controllo viene fatto solo se la lista è diversa da null ).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertDocIsNotVital(
    DedDoc doc,
    DocStructInfoList lst = null
)
Public Sub AssertDocIsNotVital (
    doc As DedDoc,
    Optional lst As DocStructInfoList = Nothing
)
public:
void AssertDocIsNotVital(
    DedDoc^ doc,
    DocStructInfoList^ lst = nullptr
)
member AssertDocIsNotVital :
        doc : DedDoc *
        ?lst : DocStructInfoList
(* Defaults:
        let _lst = defaultArg lst null
*)
-> unit

Parametri

doc DedDoc
Documento da controllare.
lst DocStructInfoList (Optional)
Lista di tutti gli elementi in eliminazione.
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertDocumentNotNull

Metodo AssertAssertDocumentNotNull
Verifica che il documento passato non sia null, altrimenti solleva una eccezione indicando che il file fileName non risulta essere registrato nel Database.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertDocumentNotNull(
    DedDoc doc,
    string fileName
)
Public Sub AssertDocumentNotNull (
    doc As DedDoc,
    fileName As String
)
public:
void AssertDocumentNotNull(
    DedDoc^ doc,
    String^ fileName
)
member AssertDocumentNotNull :
        doc : DedDoc *
        fileName : string -> unit

Parametri

doc DedDoc
Oggetto documento da verificare.
fileName String
Nome completo del documento passato (questo parametro non viene controllato).
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertDocumentNull

Metodo AssertAssertDocumentNull
Verifica che il documento passato sia null, altrimenti solleva una eccezione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertDocumentNull(
    DedDoc doc
)
Public Sub AssertDocumentNull (
    doc As DedDoc
)
public:
void AssertDocumentNull(
    DedDoc^ doc
)
member AssertDocumentNull :
        doc : DedDoc -> unit

Parametri

doc DedDoc
Oggetto documento da verificare.
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertDocUsedInOneAnagr

Metodo AssertAssertDocUsedInOneAnagr
Sis assicura che il documento sia usato solamente in un'anagrafica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertDocUsedInOneAnagr(
    DedDoc doc
)
Public Sub AssertDocUsedInOneAnagr (
    doc As DedDoc
)
public:
void AssertDocUsedInOneAnagr(
    DedDoc^ doc
)
member AssertDocUsedInOneAnagr :
        doc : DedDoc -> unit

Parametri

doc DedDoc
Documento da controllare.
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertECOExistsAnagComm

Metodo AssertAssertECOExistsAnagComm
Verifica l'esistenza dell'anagrafica o della commessa associata all'ECO.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertECOExistsAnagComm(
    DedData data,
    DedComm comm
)
Public Sub AssertECOExistsAnagComm (
    data As DedData,
    comm As DedComm
)
public:
void AssertECOExistsAnagComm(
    DedData^ data,
    DedComm^ comm
)
member AssertECOExistsAnagComm :
        data : DedData *
        comm : DedComm -> unit

Parametri

data DedData
comm DedComm
Eccezioni
Eccezione | Condizione
QsException | Eccezione che viene sollevata se l'anagrafica e la commessa non esistono.
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertECOIsCorrectlyAssigned

Metodo AssertAssertECOIsCorrectlyAssigned
Verifica lo stato dell'ECO e genera una eccezione se lo stato è "Assegnato" e l'utente corrente è diverso da quello che lo ha preso in carico.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertECOIsCorrectlyAssigned(
    DedEco eco
)
Public Sub AssertECOIsCorrectlyAssigned (
    eco As DedEco
)
public:
void AssertECOIsCorrectlyAssigned(
    DedEco^ eco
)
member AssertECOIsCorrectlyAssigned :
        eco : DedEco -> unit

Parametri

eco DedEco
Eco da verificare.
Eccezioni
Eccezione | Condizione
QsException | Eccezione che viene sollevata se l'Eco è in Lavorazione da un utente diverso da quello corrente.
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertECOIsNotClosed

Metodo AssertAssertECOIsNotClosed
Verifica lo stato dell'Eco e genera una eccezione se lo stato è "Chiuso".

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertECOIsNotClosed(
    DedEco eco
)
Public Sub AssertECOIsNotClosed (
    eco As DedEco
)
public:
void AssertECOIsNotClosed(
    DedEco^ eco
)
member AssertECOIsNotClosed :
        eco : DedEco -> unit

Parametri

eco DedEco
Eco da verificare.
Eccezioni
Eccezione | Condizione
QsException | Eccezione che viene sollevata se l'Eco è impostato come "Chiuso".
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertECOOperationOnDocument

Metodo AssertAssertECOOperationOnDocument
Verifica se l'utente ha il permesso di eseguire le operazioni sui documenti associato all'ECO.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertECOOperationOnDocument(
    DedEco eco
)
Public Sub AssertECOOperationOnDocument (
    eco As DedEco
)
public:
void AssertECOOperationOnDocument(
    DedEco^ eco
)
member AssertECOOperationOnDocument :
        eco : DedEco -> unit

Parametri

eco DedEco
Eco da verificare.
Eccezioni
Eccezione | Condizione
QsException | Eccezione che viene sollevata se l'ECO passato in ingresso è null.
QsException | Eccezione che viene sollevata se l'ECO non è registrato.
QsException | Eccezione che viene sollevata se non esiste la root dedicata agli ECO.
QsException | Eccezione che viene sollevata se l'ECO è impostato come "Chiuso".
QsException | Eccezione che viene sollevata se l'ECO è impostato come "Assegnato" ad un utente diverso da quello corrente.
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertECORoot

Metodo AssertAssertECORoot
Verifica che esista la root dedicata agli Eco.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertECORoot()
Public Sub AssertECORoot
public:
void AssertECORoot()
member AssertECORoot : unit -> unit
Eccezioni
Eccezione | Condizione
QsException | Eccezione che viene sollevata se la root associata agli Eco non esiste o ne esiste più di 1.
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertFileCadIsNotDuplicated

Metodo AssertAssertFileCadIsNotDuplicated
Controlla che il percorso passato non coincida con il percorso di base di una delle root all'interno delle quali è proibito salvare. Tipicamente %WORK%

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertFileCadIsNotDuplicated(
    DedRootInfo pathInfo
)
Public Sub AssertFileCadIsNotDuplicated (
    pathInfo As DedRootInfo
)
public:
void AssertFileCadIsNotDuplicated(
    DedRootInfo^ pathInfo
)
member AssertFileCadIsNotDuplicated :
        pathInfo : DedRootInfo -> unit

Parametri

pathInfo DedRootInfo
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertFileExists

Metodo AssertAssertFileExists
Solleva l'eccezione di FileNotFoundException se il file non è presente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertFileExists(
    string fileName
)
Public Sub AssertFileExists (
    fileName As String
)
public:
void AssertFileExists(
    String^ fileName
)
member AssertFileExists :
        fileName : string -> unit

Parametri

fileName String
Nome file completo di estensione.
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertFileExists2

Metodo AssertAssertFileExists2
Solleva l'eccezione di FileNotFoundException se il file non è presente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertFileExists2(
    string fileName
)
Public Sub AssertFileExists2 (
    fileName As String
)
public:
void AssertFileExists2(
    String^ fileName
)
member AssertFileExists2 :
        fileName : string -> unit

Parametri

fileName String
Nome file completo di estensione.
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertFileIsInRoot

Metodo AssertAssertFileIsInRoot
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AssertFileIsInRoot(DedRootInfo) | Verifica che le informazioni di un percorso sia nei percorsi validi del Database.
Metodo pubblico | AssertFileIsInRoot(String) | Verifica che il percorso passato sia nei percorsi validi del Database.
Torna su
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertFileIsInRoot(DedRootInfo)

Metodo AssertAssertFileIsInRoot(DedRootInfo)
Verifica che le informazioni di un percorso sia nei percorsi validi del Database.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertFileIsInRoot(
    DedRootInfo pathInfo
)
Public Sub AssertFileIsInRoot (
    pathInfo As DedRootInfo
)
public:
void AssertFileIsInRoot(
    DedRootInfo^ pathInfo
)
member AssertFileIsInRoot :
        pathInfo : DedRootInfo -> unit

Parametri

pathInfo DedRootInfo
Informazioni del percorso da analizzare (può trattarsi di file o cartella).
Vedi anche

Documentazione

Classe Assert
Overload di AssertFileIsInRoot
Namespace DedNet.Core


Metodo Assert.AssertFileIsInRoot(String)

Metodo AssertAssertFileIsInRoot(String)
Verifica che il percorso passato sia nei percorsi validi del Database.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertFileIsInRoot(
    string filePath
)
Public Sub AssertFileIsInRoot (
    filePath As String
)
public:
void AssertFileIsInRoot(
    String^ filePath
)
member AssertFileIsInRoot :
        filePath : string -> unit

Parametri

filePath String
Percorso da analizzare (può trattarsi di file o cartella).
Vedi anche

Documentazione

Classe Assert
Overload di AssertFileIsInRoot
Namespace DedNet.Core


Metodo Assert.AssertFileIsNotCreatingDirectlyInForbiddenRoots

Metodo AssertAssertFileIsNotCreatingDirectlyInForbiddenRoots
Controlla che il percorso passato non coincida con il percorso di base di una delle root all'interno delle quali è proibito salvare. Tipicamente %WORK%

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertFileIsNotCreatingDirectlyInForbiddenRoots(
    DedRootInfo pathInfo
)
Public Sub AssertFileIsNotCreatingDirectlyInForbiddenRoots (
    pathInfo As DedRootInfo
)
public:
void AssertFileIsNotCreatingDirectlyInForbiddenRoots(
    DedRootInfo^ pathInfo
)
member AssertFileIsNotCreatingDirectlyInForbiddenRoots :
        pathInfo : DedRootInfo -> unit

Parametri

pathInfo DedRootInfo
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertFileIsNotLocked

Metodo AssertAssertFileIsNotLocked
Verifica che il file passato non sia bloccato, altrimenti solleva una eccezione. Se il file non esiste non fa nulla.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertFileIsNotLocked(
    string fileName
)
Public Sub AssertFileIsNotLocked (
    fileName As String
)
public:
void AssertFileIsNotLocked(
    String^ fileName
)
member AssertFileIsNotLocked :
        fileName : string -> unit

Parametri

fileName String
File da verificare.
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertFileNotExists

Metodo AssertAssertFileNotExists
Controlla che un file NON esista, altrimenti solleva una eccezione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertFileNotExists(
    string fileName
)
Public Sub AssertFileNotExists (
    fileName As String
)
public:
void AssertFileNotExists(
    String^ fileName
)
member AssertFileNotExists :
        fileName : string -> unit

Parametri

fileName String
Nome file completo di estensione.
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertGuid

Metodo AssertAssertGuid
Solleva l'eccezione di ArgumentNullException se il parametro passato è Guid.Empty.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertGuid(
    Guid id,
    string paramName
)
Public Sub AssertGuid (
    id As Guid,
    paramName As String
)
public:
void AssertGuid(
    Guid id,
    String^ paramName
)
member AssertGuid :
        id : Guid *
        paramName : string -> unit

Parametri

id Guid
Valore da controllare.
paramName String
Nome del parametro.
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertHadntMovedDocuments

Metodo AssertAssertHadntMovedDocuments
Controlla che l'anagrafica non puntasse a documenti che poi sono stati ricodificati

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertHadntMovedDocuments(
    DedData data
)
Public Sub AssertHadntMovedDocuments (
    data As DedData
)
public:
void AssertHadntMovedDocuments(
    DedData^ data
)
member AssertHadntMovedDocuments :
        data : DedData -> unit

Parametri

data DedData
Anagrafica da verificare.
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertHeaderIsNotLocked

Metodo AssertAssertHeaderIsNotLocked
Controlla che l'header della distinta non sia bloccato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertHeaderIsNotLocked(
    DistHeader header
)
Public Sub AssertHeaderIsNotLocked (
    header As DistHeader
)
public:
void AssertHeaderIsNotLocked(
    DistHeader^ header
)
member AssertHeaderIsNotLocked :
        header : DistHeader -> unit

Parametri

header DistHeader
Header della distinta
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertIsAllowedStateTransaction

Metodo AssertAssertIsAllowedStateTransaction
Controlla se il passaggio di stato è ammesso per l'utente

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertIsAllowedStateTransaction(
    DedState statefrom,
    DedState stateto,
    bool ignoreCheckReserved
)
Public Sub AssertIsAllowedStateTransaction (
    statefrom As DedState,
    stateto As DedState,
    ignoreCheckReserved As Boolean
)
public:
void AssertIsAllowedStateTransaction(
    DedState^ statefrom,
    DedState^ stateto,
    bool ignoreCheckReserved
)
member AssertIsAllowedStateTransaction :
        statefrom : DedState *
        stateto : DedState *
        ignoreCheckReserved : bool -> unit

Parametri

statefrom DedState
Stato di partenza
stateto DedState
Stato di arrivo
ignoreCheckReserved Boolean
Se vero indica di ignorare di controllare se la transazione è riservata
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertIsApprovedState

Metodo AssertAssertIsApprovedState
Controlla che l'anagrafica sia rilasciata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertIsApprovedState(
    DedData data
)
Public Sub AssertIsApprovedState (
    data As DedData
)
public:
void AssertIsApprovedState(
    DedData^ data
)
member AssertIsApprovedState :
        data : DedData -> unit

Parametri

data DedData
Anagrafica da verificare.
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertIsCheckedIn

Metodo AssertAssertIsCheckedIn
Controlla che il documento sia in Check-In.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertIsCheckedIn(
    DedDoc doc
)
Public Sub AssertIsCheckedIn (
    doc As DedDoc
)
public:
void AssertIsCheckedIn(
    DedDoc^ doc
)
member AssertIsCheckedIn :
        doc : DedDoc -> unit

Parametri

doc DedDoc
Documento da verificare.
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertIsCheckedInOrCheckedOutByMe

Metodo AssertAssertIsCheckedInOrCheckedOutByMe
Controlla che il documento sia in Check-In oppure in Check-Out da me.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertIsCheckedInOrCheckedOutByMe(
    DedDoc doc
)
Public Sub AssertIsCheckedInOrCheckedOutByMe (
    doc As DedDoc
)
public:
void AssertIsCheckedInOrCheckedOutByMe(
    DedDoc^ doc
)
member AssertIsCheckedInOrCheckedOutByMe :
        doc : DedDoc -> unit

Parametri

doc DedDoc
Documento da verificare.
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertIsCheckedOut

Metodo AssertAssertIsCheckedOut
Controlla che il documento sia in Check-Out.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertIsCheckedOut(
    DedDoc doc
)
Public Sub AssertIsCheckedOut (
    doc As DedDoc
)
public:
void AssertIsCheckedOut(
    DedDoc^ doc
)
member AssertIsCheckedOut :
        doc : DedDoc -> unit

Parametri

doc DedDoc
Documento da verificare.
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertIsCheckedOutByMe

Metodo AssertAssertIsCheckedOutByMe
Controlla che il documento sia in Check-Out da me.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertIsCheckedOutByMe(
    DedDoc doc
)
Public Sub AssertIsCheckedOutByMe (
    doc As DedDoc
)
public:
void AssertIsCheckedOutByMe(
    DedDoc^ doc
)
member AssertIsCheckedOutByMe :
        doc : DedDoc -> unit

Parametri

doc DedDoc
Documento da verificare.
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertIsClosed

Metodo AssertAssertIsClosed
Controlla che la commessa non sia chiusa

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertIsClosed(
    DedComm comm
)
Public Sub AssertIsClosed (
    comm As DedComm
)
public:
void AssertIsClosed(
    DedComm^ comm
)
member AssertIsClosed :
        comm : DedComm -> unit

Parametri

comm DedComm
Commessa da verificare.
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertIsNotApprovedState

Metodo AssertAssertIsNotApprovedState
Controlla che l'anagrafica non sia in uno stato di "Approved".

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertIsNotApprovedState(
    DedData data
)
Public Sub AssertIsNotApprovedState (
    data As DedData
)
public:
void AssertIsNotApprovedState(
    DedData^ data
)
member AssertIsNotApprovedState :
        data : DedData -> unit

Parametri

data DedData
Anagrafica da verificare.
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertIsNotInDist

Metodo AssertAssertIsNotInDist
Controlla che l'anagrafica non sia presente in distinta.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertIsNotInDist(
    DedData data
)
Public Sub AssertIsNotInDist (
    data As DedData
)
public:
void AssertIsNotInDist(
    DedData^ data
)
member AssertIsNotInDist :
        data : DedData -> unit

Parametri

data DedData
Anagrafica da verificare.
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertIsNotNewVaultFile

Metodo AssertAssertIsNotNewVaultFile
Si assicura che il documento, con l'area locale attiva, non sia in checkout perché nuovo e quindi non esista il file sul vault.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertIsNotNewVaultFile(
    DedDoc doc
)
Public Sub AssertIsNotNewVaultFile (
    doc As DedDoc
)
public:
void AssertIsNotNewVaultFile(
    DedDoc^ doc
)
member AssertIsNotNewVaultFile :
        doc : DedDoc -> unit

Parametri

doc DedDoc
Documento da controllare.
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertIsNotOutdatedState

Metodo AssertAssertIsNotOutdatedState
Controlla che l'anagrafica non sia Superata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertIsNotOutdatedState(
    DedData data,
    bool considerWritableOutOfDateAsOutOfDate = true
)
Public Sub AssertIsNotOutdatedState (
    data As DedData,
    Optional considerWritableOutOfDateAsOutOfDate As Boolean = true
)
public:
void AssertIsNotOutdatedState(
    DedData^ data,
    bool considerWritableOutOfDateAsOutOfDate = true
)
member AssertIsNotOutdatedState :
        data : DedData *
        ?considerWritableOutOfDateAsOutOfDate : bool
(* Defaults:
        let _considerWritableOutOfDateAsOutOfDate = defaultArg considerWritableOutOfDateAsOutOfDate true
*)
-> unit

Parametri

data DedData
Anagrafica da verificare.
considerWritableOutOfDateAsOutOfDate Boolean (Optional)
Indica se considerare superati anche i superati in scrittura
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertIsNotPendingApprovalState

Metodo AssertAssertIsNotPendingApprovalState
Controlla che l'anagrafica non sia in uno stato di "Pending Approval".

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertIsNotPendingApprovalState(
    DedData data
)
Public Sub AssertIsNotPendingApprovalState (
    data As DedData
)
public:
void AssertIsNotPendingApprovalState(
    DedData^ data
)
member AssertIsNotPendingApprovalState :
        data : DedData -> unit

Parametri

data DedData
Anagrafica da verificare.
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertIsNotUnchengeableState

Metodo AssertAssertIsNotUnchengeableState
Controlla che l'anagrafica non sia Obsoleta.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertIsNotUnchengeableState(
    DedData data
)
Public Sub AssertIsNotUnchengeableState (
    data As DedData
)
public:
void AssertIsNotUnchengeableState(
    DedData^ data
)
member AssertIsNotUnchengeableState :
        data : DedData -> unit

Parametri

data DedData
Anagrafica da verificare.
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertIsNotWorkingState

Metodo AssertAssertIsNotWorkingState
Controlla che l'anagrafica non sia in Lavorazione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertIsNotWorkingState(
    DedData data
)
Public Sub AssertIsNotWorkingState (
    data As DedData
)
public:
void AssertIsNotWorkingState(
    DedData^ data
)
member AssertIsNotWorkingState :
        data : DedData -> unit

Parametri

data DedData
Anagrafica da verificare.
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertIsNotWritableOutdatedState

Metodo AssertAssertIsNotWritableOutdatedState
Controlla che l'anagrafica non sia Superata in adattamento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertIsNotWritableOutdatedState(
    DedData data
)
Public Sub AssertIsNotWritableOutdatedState (
    data As DedData
)
public:
void AssertIsNotWritableOutdatedState(
    DedData^ data
)
member AssertIsNotWritableOutdatedState :
        data : DedData -> unit

Parametri

data DedData
Anagrafica da verificare.
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertIsOutdatedState

Metodo AssertAssertIsOutdatedState
Controlla che l'anagrafica sia Superata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertIsOutdatedState(
    DedData data
)
Public Sub AssertIsOutdatedState (
    data As DedData
)
public:
void AssertIsOutdatedState(
    DedData^ data
)
member AssertIsOutdatedState :
        data : DedData -> unit

Parametri

data DedData
Anagrafica da verificare.
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertIsPendingApprovalState

Metodo AssertAssertIsPendingApprovalState
Controlla che l'anagrafica sia rilasciata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertIsPendingApprovalState(
    DedData data
)
Public Sub AssertIsPendingApprovalState (
    data As DedData
)
public:
void AssertIsPendingApprovalState(
    DedData^ data
)
member AssertIsPendingApprovalState :
        data : DedData -> unit

Parametri

data DedData
Anagrafica da verificare.
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertIsPwsModeActive

Metodo AssertAssertIsPwsModeActive
Controlla che sia attiva la pws.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertIsPwsModeActive()
Public Sub AssertIsPwsModeActive
public:
void AssertIsPwsModeActive()
member AssertIsPwsModeActive : unit -> unit
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertIsUnchangeableState

Metodo AssertAssertIsUnchangeableState
Controlla che l'anagrafica sia Obsoleta.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertIsUnchangeableState(
    DedData data
)
Public Sub AssertIsUnchangeableState (
    data As DedData
)
public:
void AssertIsUnchangeableState(
    DedData^ data
)
member AssertIsUnchangeableState :
        data : DedData -> unit

Parametri

data DedData
Anagrafica da verificare.
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertIsUsersMode

Metodo AssertAssertIsUsersMode
Controlla che sia attiva la gestione degli utenti.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertIsUsersMode()
Public Sub AssertIsUsersMode
public:
void AssertIsUsersMode()
member AssertIsUsersMode : unit -> unit
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertIsVgr

Metodo AssertAssertIsVgr

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertIsVgr(
    DedData data
)
Public Sub AssertIsVgr (
    data As DedData
)
public:
void AssertIsVgr(
    DedData^ data
)
member AssertIsVgr :
        data : DedData -> unit

Parametri

data DedData
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertIsWorkingState

Metodo AssertAssertIsWorkingState
Controlla che l'anagrafica sia in Lavorazione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertIsWorkingState(
    DedData data
)
Public Sub AssertIsWorkingState (
    data As DedData
)
public:
void AssertIsWorkingState(
    DedData^ data
)
member AssertIsWorkingState :
        data : DedData -> unit

Parametri

data DedData
Anagrafica da verificare.
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertIsWritableState

Metodo AssertAssertIsWritableState
Controlla che l'anagrafica sia in uno stato scrivibile.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertIsWritableState(
    DedData data
)
Public Sub AssertIsWritableState (
    data As DedData
)
public:
void AssertIsWritableState(
    DedData^ data
)
member AssertIsWritableState :
        data : DedData -> unit

Parametri

data DedData
Anagrafica da verificare.
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertObject

Metodo AssertAssertObject
Solleva l'eccezione di ArgumentNullException se il parametro passato è null.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertObject(
    Object paramValue,
    string paramName
)
Public Sub AssertObject (
    paramValue As Object,
    paramName As String
)
public:
void AssertObject(
    Object^ paramValue,
    String^ paramName
)
member AssertObject :
        paramValue : Object *
        paramName : string -> unit

Parametri

paramValue Object
Valore da controllare.
paramName String
Nome del parametro.
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertPathIsRooted

Metodo AssertAssertPathIsRooted
Solleva l'eccezione di FileNotFoundException se il file non è presente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertPathIsRooted(
    string path
)
Public Sub AssertPathIsRooted (
    path As String
)
public:
void AssertPathIsRooted(
    String^ path
)
member AssertPathIsRooted :
        path : string -> unit

Parametri

path String
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertPathNotTooLong

Metodo AssertAssertPathNotTooLong
Genera una eccezione se il nome di file completo contiene più di 259 caratteri o se il nome di directory contiene più di 247 caratteri. Da tenere presente che, per gestire i file .erased, ne viene calcolato l'eventuale nome prima di effettuare il controllo di validità. Questo comporta l'accodazione di 26 caratteri al path passato in ingresso.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertPathNotTooLong(
    string origPath
)
Public Sub AssertPathNotTooLong (
    origPath As String
)
public:
void AssertPathNotTooLong(
    String^ origPath
)
member AssertPathNotTooLong :
        origPath : string -> unit

Parametri

origPath String
Eccezioni
Eccezione | Condizione
PathTooLongException | Eccezione che viene sollevata se il percorso è troppo lungo.
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertSparePartsManagement

Metodo AssertAssertSparePartsManagement
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AssertSparePartsManagement | Controlla che la gestione dei ricambi sia attiva.
Metodo pubblico | AssertSparePartsManagement(DedData) | Controlla che la gestione dei ricambi sia attiva in base all'anagrafica specificata in ingresso.
Torna su
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertSparePartsManagement

Metodo AssertAssertSparePartsManagement
Controlla che la gestione dei ricambi sia attiva.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertSparePartsManagement()
Public Sub AssertSparePartsManagement
public:
void AssertSparePartsManagement()
member AssertSparePartsManagement : unit -> unit
Vedi anche

Documentazione

Classe Assert
Overload di AssertSparePartsManagement
Namespace DedNet.Core


Metodo Assert.AssertSparePartsManagement(DedData)

Metodo AssertAssertSparePartsManagement(DedData)
Controlla che la gestione dei ricambi sia attiva in base all'anagrafica specificata in ingresso.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertSparePartsManagement(
    DedData data
)
Public Sub AssertSparePartsManagement (
    data As DedData
)
public:
void AssertSparePartsManagement(
    DedData^ data
)
member AssertSparePartsManagement :
        data : DedData -> unit

Parametri

data DedData
Vedi anche

Documentazione

Classe Assert
Overload di AssertSparePartsManagement
Namespace DedNet.Core


Metodo Assert.AssertString

Metodo AssertAssertString
Solleva l'eccezione di ArgumentNullException se il parametro passato è null.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertString(
    string paramValue,
    string paramName
)
Public Sub AssertString (
    paramValue As String,
    paramName As String
)
public:
void AssertString(
    String^ paramValue,
    String^ paramName
)
member AssertString :
        paramValue : string *
        paramName : string -> unit

Parametri

paramValue String
Valore da controllare.
paramName String
Nome del parametro.
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertString2

Metodo AssertAssertString2
Solleva l'eccezione di ArgumentNullException se il parametro passato è null.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertString2(
    string paramValue,
    string paramName
)
Public Sub AssertString2 (
    paramValue As String,
    paramName As String
)
public:
void AssertString2(
    String^ paramValue,
    String^ paramName
)
member AssertString2 :
        paramValue : string *
        paramName : string -> unit

Parametri

paramValue String
Valore da controllare.
paramName String
Nome del parametro.
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertUserCan

Metodo AssertAssertUserCan
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AssertUserCan(DedStandardPerm, DedTypeBase) | Controlla che l'utente abbia il permesso passato.
Metodo pubblico | AssertUserCan(DedStandardPerm, Boolean) | Controlla che l'utente abbia il permesso passato.
Torna su
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertUserCan(DedStandardPerm, DedTypeBase)

Metodo AssertAssertUserCan(DedStandardPerm, DedTypeBase)
Controlla che l'utente abbia il permesso passato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCan(
    DedStandardPerm perm,
    DedTypeBase fam
)
Public Sub AssertUserCan (
    perm As DedStandardPerm,
    fam As DedTypeBase
)
public:
void AssertUserCan(
    DedStandardPerm perm,
    DedTypeBase^ fam
)
member AssertUserCan :
        perm : DedStandardPerm *
        fam : DedTypeBase -> unit

Parametri

perm DedStandardPerm
Permesso da controllare.
fam DedTypeBase
Famiglia da verificare. Può essere null ed in tal caso controlla il permesso generale.
Vedi anche

Documentazione

Classe Assert
Overload di AssertUserCan
Namespace DedNet.Core


Metodo Assert.AssertUserCan(DedStandardPerm, Boolean)

Metodo AssertAssertUserCan(DedStandardPerm, Boolean)
Controlla che l'utente abbia il permesso passato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCan(
    DedStandardPerm perm,
    bool checkOnlyGeneralPerm = false
)
Public Sub AssertUserCan (
    perm As DedStandardPerm,
    Optional checkOnlyGeneralPerm As Boolean = false
)
public:
void AssertUserCan(
    DedStandardPerm perm,
    bool checkOnlyGeneralPerm = false
)
member AssertUserCan :
        perm : DedStandardPerm *
        ?checkOnlyGeneralPerm : bool
(* Defaults:
        let _checkOnlyGeneralPerm = defaultArg checkOnlyGeneralPerm false
*)
-> unit

Parametri

perm DedStandardPerm
Permesso da controllare.
checkOnlyGeneralPerm Boolean (Optional)
Vedi anche

Documentazione

Classe Assert
Overload di AssertUserCan
Namespace DedNet.Core


Metodo Assert.AssertUserCanAdmin

Metodo AssertAssertUserCanAdmin
Controlla che l'utente abbia il permesso di Amministrare in generale.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanAdmin(
    bool checkOnlyGeneralPerm = false
)
Public Sub AssertUserCanAdmin (
    Optional checkOnlyGeneralPerm As Boolean = false
)
public:
void AssertUserCanAdmin(
    bool checkOnlyGeneralPerm = false
)
member AssertUserCanAdmin :
        ?checkOnlyGeneralPerm : bool
(* Defaults:
        let _checkOnlyGeneralPerm = defaultArg checkOnlyGeneralPerm false
*)
-> unit

Parametri

checkOnlyGeneralPerm Boolean (Optional)
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertUserCanAdminAtt

Metodo AssertAssertUserCanAdminAtt
Controlla che l'utente abbia il permesso di Amministrare gli attributi.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanAdminAtt(
    bool checkOnlyGeneralPerm = false
)
Public Sub AssertUserCanAdminAtt (
    Optional checkOnlyGeneralPerm As Boolean = false
)
public:
void AssertUserCanAdminAtt(
    bool checkOnlyGeneralPerm = false
)
member AssertUserCanAdminAtt :
        ?checkOnlyGeneralPerm : bool
(* Defaults:
        let _checkOnlyGeneralPerm = defaultArg checkOnlyGeneralPerm false
*)
-> unit

Parametri

checkOnlyGeneralPerm Boolean (Optional)
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertUserCanAdminFam

Metodo AssertAssertUserCanAdminFam
Controlla che l'utente abbia il permesso di Amministrare le famiglie.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanAdminFam(
    bool checkOnlyGeneralPerm = false
)
Public Sub AssertUserCanAdminFam (
    Optional checkOnlyGeneralPerm As Boolean = false
)
public:
void AssertUserCanAdminFam(
    bool checkOnlyGeneralPerm = false
)
member AssertUserCanAdminFam :
        ?checkOnlyGeneralPerm : bool
(* Defaults:
        let _checkOnlyGeneralPerm = defaultArg checkOnlyGeneralPerm false
*)
-> unit

Parametri

checkOnlyGeneralPerm Boolean (Optional)
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertUserCanAssignECO

Metodo AssertAssertUserCanAssignECO
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AssertUserCanAssignECO(DedComm) | Controlla che l'utente abbia il permesso di assegnare gli ECO.
Metodo pubblico | AssertUserCanAssignECO(DedType) | Controlla che l'utente abbia il permesso di assegnare gli ECO.
Torna su
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertUserCanAssignECO(DedComm)

Metodo AssertAssertUserCanAssignECO(DedComm)
Controlla che l'utente abbia il permesso di assegnare gli ECO.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanAssignECO(
    DedComm comm
)
Public Sub AssertUserCanAssignECO (
    comm As DedComm
)
public:
void AssertUserCanAssignECO(
    DedComm^ comm
)
member AssertUserCanAssignECO :
        comm : DedComm -> unit

Parametri

comm DedComm
Vedi anche

Documentazione

Classe Assert
Overload di AssertUserCanAssignECO
Namespace DedNet.Core


Metodo Assert.AssertUserCanAssignECO(DedType)

Metodo AssertAssertUserCanAssignECO(DedType)
Controlla che l'utente abbia il permesso di assegnare gli ECO.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanAssignECO(
    DedType fam
)
Public Sub AssertUserCanAssignECO (
    fam As DedType
)
public:
void AssertUserCanAssignECO(
    DedType^ fam
)
member AssertUserCanAssignECO :
        fam : DedType -> unit

Parametri

fam DedType
Vedi anche

Documentazione

Classe Assert
Overload di AssertUserCanAssignECO
Namespace DedNet.Core


Metodo Assert.AssertUserCanAttach

Metodo AssertAssertUserCanAttach
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AssertUserCanAttach(Boolean) | Controlla che l'utente abbia il permesso di allegare nei file primari.
Metodo pubblico | AssertUserCanAttach(DedType) | Controlla che l'utente abbia il permesso di Allegare sulla specifica famiglia.
Torna su
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertUserCanAttach(Boolean)

Metodo AssertAssertUserCanAttach(Boolean)
Controlla che l'utente abbia il permesso di allegare nei file primari.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanAttach(
    bool checkOnlyGeneralPerm = false
)
Public Sub AssertUserCanAttach (
    Optional checkOnlyGeneralPerm As Boolean = false
)
public:
void AssertUserCanAttach(
    bool checkOnlyGeneralPerm = false
)
member AssertUserCanAttach :
        ?checkOnlyGeneralPerm : bool
(* Defaults:
        let _checkOnlyGeneralPerm = defaultArg checkOnlyGeneralPerm false
*)
-> unit

Parametri

checkOnlyGeneralPerm Boolean (Optional)
Vedi anche

Documentazione

Classe Assert
Overload di AssertUserCanAttach
Namespace DedNet.Core


Metodo Assert.AssertUserCanAttach(DedType)

Metodo AssertAssertUserCanAttach(DedType)
Controlla che l'utente abbia il permesso di Allegare sulla specifica famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanAttach(
    DedType fam
)
Public Sub AssertUserCanAttach (
    fam As DedType
)
public:
void AssertUserCanAttach(
    DedType^ fam
)
member AssertUserCanAttach :
        fam : DedType -> unit

Parametri

fam DedType
Famiglia sulla quale controllare il permesso.
Vedi anche

Documentazione

Classe Assert
Overload di AssertUserCanAttach
Namespace DedNet.Core


Metodo Assert.AssertUserCanAttachAnagrComm

Metodo AssertAssertUserCanAttachAnagrComm
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AssertUserCanAttachAnagrComm(Boolean) | Controlla che l'utente abbia il permesso di collegare anagrafiche alle commesse.
Metodo pubblico | AssertUserCanAttachAnagrComm(DedComm) | Controlla che l'utente abbia il permesso di collegare anagrafiche alle commesse.
Torna su
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertUserCanAttachAnagrComm(Boolean)

Metodo AssertAssertUserCanAttachAnagrComm(Boolean)
Controlla che l'utente abbia il permesso di collegare anagrafiche alle commesse.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanAttachAnagrComm(
    bool checkOnlyGeneralPerm = false
)
Public Sub AssertUserCanAttachAnagrComm (
    Optional checkOnlyGeneralPerm As Boolean = false
)
public:
void AssertUserCanAttachAnagrComm(
    bool checkOnlyGeneralPerm = false
)
member AssertUserCanAttachAnagrComm :
        ?checkOnlyGeneralPerm : bool
(* Defaults:
        let _checkOnlyGeneralPerm = defaultArg checkOnlyGeneralPerm false
*)
-> unit

Parametri

checkOnlyGeneralPerm Boolean (Optional)
Vedi anche

Documentazione

Classe Assert
Overload di AssertUserCanAttachAnagrComm
Namespace DedNet.Core


Metodo Assert.AssertUserCanAttachAnagrComm(DedComm)

Metodo AssertAssertUserCanAttachAnagrComm(DedComm)
Controlla che l'utente abbia il permesso di collegare anagrafiche alle commesse.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanAttachAnagrComm(
    DedComm comm
)
Public Sub AssertUserCanAttachAnagrComm (
    comm As DedComm
)
public:
void AssertUserCanAttachAnagrComm(
    DedComm^ comm
)
member AssertUserCanAttachAnagrComm :
        comm : DedComm -> unit

Parametri

comm DedComm
Vedi anche

Documentazione

Classe Assert
Overload di AssertUserCanAttachAnagrComm
Namespace DedNet.Core


Metodo Assert.AssertUserCanAttachDocComm

Metodo AssertAssertUserCanAttachDocComm
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AssertUserCanAttachDocComm(Boolean) | Controlla che l'utente abbia il permesso di collegare documenti alle commesse.
Metodo pubblico | AssertUserCanAttachDocComm(DedComm) | Controlla che l'utente abbia il permesso di collegare documenti alle commesse.
Torna su
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertUserCanAttachDocComm(Boolean)

Metodo AssertAssertUserCanAttachDocComm(Boolean)
Controlla che l'utente abbia il permesso di collegare documenti alle commesse.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanAttachDocComm(
    bool checkOnlyGeneralPerm = false
)
Public Sub AssertUserCanAttachDocComm (
    Optional checkOnlyGeneralPerm As Boolean = false
)
public:
void AssertUserCanAttachDocComm(
    bool checkOnlyGeneralPerm = false
)
member AssertUserCanAttachDocComm :
        ?checkOnlyGeneralPerm : bool
(* Defaults:
        let _checkOnlyGeneralPerm = defaultArg checkOnlyGeneralPerm false
*)
-> unit

Parametri

checkOnlyGeneralPerm Boolean (Optional)
Vedi anche

Documentazione

Classe Assert
Overload di AssertUserCanAttachDocComm
Namespace DedNet.Core


Metodo Assert.AssertUserCanAttachDocComm(DedComm)

Metodo AssertAssertUserCanAttachDocComm(DedComm)
Controlla che l'utente abbia il permesso di collegare documenti alle commesse.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanAttachDocComm(
    DedComm comm
)
Public Sub AssertUserCanAttachDocComm (
    comm As DedComm
)
public:
void AssertUserCanAttachDocComm(
    DedComm^ comm
)
member AssertUserCanAttachDocComm :
        comm : DedComm -> unit

Parametri

comm DedComm
Vedi anche

Documentazione

Classe Assert
Overload di AssertUserCanAttachDocComm
Namespace DedNet.Core


Metodo Assert.AssertUserCanAttachDocECO

Metodo AssertAssertUserCanAttachDocECO
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AssertUserCanAttachDocECO(DedComm) | Controlla che l'utente abbia il permesso di associare documenti agli ECO.
Metodo pubblico | AssertUserCanAttachDocECO(DedType) | Controlla che l'utente abbia il permesso di associare documenti agli ECO.
Torna su
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertUserCanAttachDocECO(DedComm)

Metodo AssertAssertUserCanAttachDocECO(DedComm)
Controlla che l'utente abbia il permesso di associare documenti agli ECO.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanAttachDocECO(
    DedComm comm
)
Public Sub AssertUserCanAttachDocECO (
    comm As DedComm
)
public:
void AssertUserCanAttachDocECO(
    DedComm^ comm
)
member AssertUserCanAttachDocECO :
        comm : DedComm -> unit

Parametri

comm DedComm
Vedi anche

Documentazione

Classe Assert
Overload di AssertUserCanAttachDocECO
Namespace DedNet.Core


Metodo Assert.AssertUserCanAttachDocECO(DedType)

Metodo AssertAssertUserCanAttachDocECO(DedType)
Controlla che l'utente abbia il permesso di associare documenti agli ECO.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanAttachDocECO(
    DedType fam
)
Public Sub AssertUserCanAttachDocECO (
    fam As DedType
)
public:
void AssertUserCanAttachDocECO(
    DedType^ fam
)
member AssertUserCanAttachDocECO :
        fam : DedType -> unit

Parametri

fam DedType
Vedi anche

Documentazione

Classe Assert
Overload di AssertUserCanAttachDocECO
Namespace DedNet.Core


Metodo Assert.AssertUserCanAttachOrManageAttach

Metodo AssertAssertUserCanAttachOrManageAttach
Controlla che l'utente abbia il permesso di allegare nei file primari o allegati.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanAttachOrManageAttach(
    bool checkOnlyGeneralPerm = false
)
Public Sub AssertUserCanAttachOrManageAttach (
    Optional checkOnlyGeneralPerm As Boolean = false
)
public:
void AssertUserCanAttachOrManageAttach(
    bool checkOnlyGeneralPerm = false
)
member AssertUserCanAttachOrManageAttach :
        ?checkOnlyGeneralPerm : bool
(* Defaults:
        let _checkOnlyGeneralPerm = defaultArg checkOnlyGeneralPerm false
*)
-> unit

Parametri

checkOnlyGeneralPerm Boolean (Optional)
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertUserCanCloseComm

Metodo AssertAssertUserCanCloseComm
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AssertUserCanCloseComm(Boolean) | Controlla che l'utente abbia il permesso di chiudere le commesse.
Metodo pubblico | AssertUserCanCloseComm(DedComm) | Controlla che l'utente abbia il permesso di chiudere le commesse.
Torna su
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertUserCanCloseComm(Boolean)

Metodo AssertAssertUserCanCloseComm(Boolean)
Controlla che l'utente abbia il permesso di chiudere le commesse.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanCloseComm(
    bool checkOnlyGeneralPerm = false
)
Public Sub AssertUserCanCloseComm (
    Optional checkOnlyGeneralPerm As Boolean = false
)
public:
void AssertUserCanCloseComm(
    bool checkOnlyGeneralPerm = false
)
member AssertUserCanCloseComm :
        ?checkOnlyGeneralPerm : bool
(* Defaults:
        let _checkOnlyGeneralPerm = defaultArg checkOnlyGeneralPerm false
*)
-> unit

Parametri

checkOnlyGeneralPerm Boolean (Optional)
Vedi anche

Documentazione

Classe Assert
Overload di AssertUserCanCloseComm
Namespace DedNet.Core


Metodo Assert.AssertUserCanCloseComm(DedComm)

Metodo AssertAssertUserCanCloseComm(DedComm)
Controlla che l'utente abbia il permesso di chiudere le commesse.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanCloseComm(
    DedComm comm
)
Public Sub AssertUserCanCloseComm (
    comm As DedComm
)
public:
void AssertUserCanCloseComm(
    DedComm^ comm
)
member AssertUserCanCloseComm :
        comm : DedComm -> unit

Parametri

comm DedComm
Vedi anche

Documentazione

Classe Assert
Overload di AssertUserCanCloseComm
Namespace DedNet.Core


Metodo Assert.AssertUserCanCreate

Metodo AssertAssertUserCanCreate
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AssertUserCanCreate(Boolean) | Controlla che l'utente abbia il permesso di Creazione in generale.
Metodo pubblico | AssertUserCanCreate(DedType) | Controlla che l'utente abbia il permesso di Creazione sulla specifica famiglia.
Torna su
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertUserCanCreate(Boolean)

Metodo AssertAssertUserCanCreate(Boolean)
Controlla che l'utente abbia il permesso di Creazione in generale.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanCreate(
    bool checkOnlyGeneralPerm = false
)
Public Sub AssertUserCanCreate (
    Optional checkOnlyGeneralPerm As Boolean = false
)
public:
void AssertUserCanCreate(
    bool checkOnlyGeneralPerm = false
)
member AssertUserCanCreate :
        ?checkOnlyGeneralPerm : bool
(* Defaults:
        let _checkOnlyGeneralPerm = defaultArg checkOnlyGeneralPerm false
*)
-> unit

Parametri

checkOnlyGeneralPerm Boolean (Optional)
Vedi anche

Documentazione

Classe Assert
Overload di AssertUserCanCreate
Namespace DedNet.Core


Metodo Assert.AssertUserCanCreate(DedType)

Metodo AssertAssertUserCanCreate(DedType)
Controlla che l'utente abbia il permesso di Creazione sulla specifica famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanCreate(
    DedType fam
)
Public Sub AssertUserCanCreate (
    fam As DedType
)
public:
void AssertUserCanCreate(
    DedType^ fam
)
member AssertUserCanCreate :
        fam : DedType -> unit

Parametri

fam DedType
Famiglia sulla quale controllare il permesso.
Vedi anche

Documentazione

Classe Assert
Overload di AssertUserCanCreate
Namespace DedNet.Core


Metodo Assert.AssertUserCanCreateComm

Metodo AssertAssertUserCanCreateComm
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AssertUserCanCreateComm(Boolean) | Controlla che l'utente abbia il permesso di creare le commesse.
Metodo pubblico | AssertUserCanCreateComm(DedComm) | Controlla che l'utente abbia il permesso di creare le commesse.
Torna su
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertUserCanCreateComm(Boolean)

Metodo AssertAssertUserCanCreateComm(Boolean)
Controlla che l'utente abbia il permesso di creare le commesse.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanCreateComm(
    bool checkOnlyGeneralPerm = false
)
Public Sub AssertUserCanCreateComm (
    Optional checkOnlyGeneralPerm As Boolean = false
)
public:
void AssertUserCanCreateComm(
    bool checkOnlyGeneralPerm = false
)
member AssertUserCanCreateComm :
        ?checkOnlyGeneralPerm : bool
(* Defaults:
        let _checkOnlyGeneralPerm = defaultArg checkOnlyGeneralPerm false
*)
-> unit

Parametri

checkOnlyGeneralPerm Boolean (Optional)
Vedi anche

Documentazione

Classe Assert
Overload di AssertUserCanCreateComm
Namespace DedNet.Core


Metodo Assert.AssertUserCanCreateComm(DedComm)

Metodo AssertAssertUserCanCreateComm(DedComm)
Controlla che l'utente abbia il permesso di creare le commesse.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanCreateComm(
    DedComm comm
)
Public Sub AssertUserCanCreateComm (
    comm As DedComm
)
public:
void AssertUserCanCreateComm(
    DedComm^ comm
)
member AssertUserCanCreateComm :
        comm : DedComm -> unit

Parametri

comm DedComm
Vedi anche

Documentazione

Classe Assert
Overload di AssertUserCanCreateComm
Namespace DedNet.Core


Metodo Assert.AssertUserCanCreateECO

Metodo AssertAssertUserCanCreateECO
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AssertUserCanCreateECO(DedComm) | Controlla che l'utente abbia il permesso di creare gli ECO.
Metodo pubblico | AssertUserCanCreateECO(DedType) | Controlla che l'utente abbia il permesso di creare gli ECO.
Torna su
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertUserCanCreateECO(DedComm)

Metodo AssertAssertUserCanCreateECO(DedComm)
Controlla che l'utente abbia il permesso di creare gli ECO.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanCreateECO(
    DedComm comm
)
Public Sub AssertUserCanCreateECO (
    comm As DedComm
)
public:
void AssertUserCanCreateECO(
    DedComm^ comm
)
member AssertUserCanCreateECO :
        comm : DedComm -> unit

Parametri

comm DedComm
Vedi anche

Documentazione

Classe Assert
Overload di AssertUserCanCreateECO
Namespace DedNet.Core


Metodo Assert.AssertUserCanCreateECO(DedType)

Metodo AssertAssertUserCanCreateECO(DedType)
Controlla che l'utente abbia il permesso di creare gli ECO.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanCreateECO(
    DedType fam
)
Public Sub AssertUserCanCreateECO (
    fam As DedType
)
public:
void AssertUserCanCreateECO(
    DedType^ fam
)
member AssertUserCanCreateECO :
        fam : DedType -> unit

Parametri

fam DedType
Vedi anche

Documentazione

Classe Assert
Overload di AssertUserCanCreateECO
Namespace DedNet.Core


Metodo Assert.AssertUserCanCreateFolder

Metodo AssertAssertUserCanCreateFolder
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AssertUserCanCreateFolder(Boolean) | Controlla che l'utente abbia il permesso di creare le cartelle.
Metodo pubblico | AssertUserCanCreateFolder(String) | Controlla che l'utente abbia il permesso di creare le cartelle.
Torna su
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertUserCanCreateFolder(Boolean)

Metodo AssertAssertUserCanCreateFolder(Boolean)
Controlla che l'utente abbia il permesso di creare le cartelle.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanCreateFolder(
    bool checkOnlyGeneralPerm = false
)
Public Sub AssertUserCanCreateFolder (
    Optional checkOnlyGeneralPerm As Boolean = false
)
public:
void AssertUserCanCreateFolder(
    bool checkOnlyGeneralPerm = false
)
member AssertUserCanCreateFolder :
        ?checkOnlyGeneralPerm : bool
(* Defaults:
        let _checkOnlyGeneralPerm = defaultArg checkOnlyGeneralPerm false
*)
-> unit

Parametri

checkOnlyGeneralPerm Boolean (Optional)
Vedi anche

Documentazione

Classe Assert
Overload di AssertUserCanCreateFolder
Namespace DedNet.Core


Metodo Assert.AssertUserCanCreateFolder(String)

Metodo AssertAssertUserCanCreateFolder(String)
Controlla che l'utente abbia il permesso di creare le cartelle.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanCreateFolder(
    string path
)
Public Sub AssertUserCanCreateFolder (
    path As String
)
public:
void AssertUserCanCreateFolder(
    String^ path
)
member AssertUserCanCreateFolder :
        path : string -> unit

Parametri

path String
Vedi anche

Documentazione

Classe Assert
Overload di AssertUserCanCreateFolder
Namespace DedNet.Core


Metodo Assert.AssertUserCanDeAttach

Metodo AssertAssertUserCanDeAttach
Controlla che l'utente abbia il permesso di Allegare sulla specifica famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanDeAttach(
    DedType fam
)
Public Sub AssertUserCanDeAttach (
    fam As DedType
)
public:
void AssertUserCanDeAttach(
    DedType^ fam
)
member AssertUserCanDeAttach :
        fam : DedType -> unit

Parametri

fam DedType
Famiglia sulla quale controllare il permesso.
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertUserCanDeAttachAnagrComm

Metodo AssertAssertUserCanDeAttachAnagrComm
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AssertUserCanDeAttachAnagrComm(Boolean) | Controlla che l'utente abbia il permesso di scollegare anagrafiche alle commesse.
Metodo pubblico | AssertUserCanDeAttachAnagrComm(DedComm) | Controlla che l'utente abbia il permesso di scollegare anagrafiche alle commesse.
Torna su
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertUserCanDeAttachAnagrComm(Boolean)

Metodo AssertAssertUserCanDeAttachAnagrComm(Boolean)
Controlla che l'utente abbia il permesso di scollegare anagrafiche alle commesse.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanDeAttachAnagrComm(
    bool checkOnlyGeneralPerm = false
)
Public Sub AssertUserCanDeAttachAnagrComm (
    Optional checkOnlyGeneralPerm As Boolean = false
)
public:
void AssertUserCanDeAttachAnagrComm(
    bool checkOnlyGeneralPerm = false
)
member AssertUserCanDeAttachAnagrComm :
        ?checkOnlyGeneralPerm : bool
(* Defaults:
        let _checkOnlyGeneralPerm = defaultArg checkOnlyGeneralPerm false
*)
-> unit

Parametri

checkOnlyGeneralPerm Boolean (Optional)
Vedi anche

Documentazione

Classe Assert
Overload di AssertUserCanDeAttachAnagrComm
Namespace DedNet.Core


Metodo Assert.AssertUserCanDeAttachAnagrComm(DedComm)

Metodo AssertAssertUserCanDeAttachAnagrComm(DedComm)
Controlla che l'utente abbia il permesso di scollegare anagrafiche alle commesse.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanDeAttachAnagrComm(
    DedComm comm
)
Public Sub AssertUserCanDeAttachAnagrComm (
    comm As DedComm
)
public:
void AssertUserCanDeAttachAnagrComm(
    DedComm^ comm
)
member AssertUserCanDeAttachAnagrComm :
        comm : DedComm -> unit

Parametri

comm DedComm
Vedi anche

Documentazione

Classe Assert
Overload di AssertUserCanDeAttachAnagrComm
Namespace DedNet.Core


Metodo Assert.AssertUserCanDeAttachDocComm

Metodo AssertAssertUserCanDeAttachDocComm
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AssertUserCanDeAttachDocComm(Boolean) | Controlla che l'utente abbia il permesso di scollegare documenti alle commesse.
Metodo pubblico | AssertUserCanDeAttachDocComm(DedComm) | Controlla che l'utente abbia il permesso di scollegare documenti alle commesse.
Torna su
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertUserCanDeAttachDocComm(Boolean)

Metodo AssertAssertUserCanDeAttachDocComm(Boolean)
Controlla che l'utente abbia il permesso di scollegare documenti alle commesse.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanDeAttachDocComm(
    bool checkOnlyGeneralPerm = false
)
Public Sub AssertUserCanDeAttachDocComm (
    Optional checkOnlyGeneralPerm As Boolean = false
)
public:
void AssertUserCanDeAttachDocComm(
    bool checkOnlyGeneralPerm = false
)
member AssertUserCanDeAttachDocComm :
        ?checkOnlyGeneralPerm : bool
(* Defaults:
        let _checkOnlyGeneralPerm = defaultArg checkOnlyGeneralPerm false
*)
-> unit

Parametri

checkOnlyGeneralPerm Boolean (Optional)
Vedi anche

Documentazione

Classe Assert
Overload di AssertUserCanDeAttachDocComm
Namespace DedNet.Core


Metodo Assert.AssertUserCanDeAttachDocComm(DedComm)

Metodo AssertAssertUserCanDeAttachDocComm(DedComm)
Controlla che l'utente abbia il permesso di scollegare documenti alle commesse.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanDeAttachDocComm(
    DedComm comm
)
Public Sub AssertUserCanDeAttachDocComm (
    comm As DedComm
)
public:
void AssertUserCanDeAttachDocComm(
    DedComm^ comm
)
member AssertUserCanDeAttachDocComm :
        comm : DedComm -> unit

Parametri

comm DedComm
Vedi anche

Documentazione

Classe Assert
Overload di AssertUserCanDeAttachDocComm
Namespace DedNet.Core


Metodo Assert.AssertUserCanDeleteDocECO

Metodo AssertAssertUserCanDeleteDocECO
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AssertUserCanDeleteDocECO | Controlla che l'utente abbia il permesso di eliminare i documenti dall'ECO.
Metodo pubblico | AssertUserCanDeleteDocECO(DedComm) | Controlla che l'utente abbia il permesso di eliminare i documenti dall'ECO.
Metodo pubblico | AssertUserCanDeleteDocECO(DedType) | Controlla che l'utente abbia il permesso di eliminare i documenti dall'ECO.
Torna su
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertUserCanDeleteDocECO

Metodo AssertAssertUserCanDeleteDocECO
Controlla che l'utente abbia il permesso di eliminare i documenti dall'ECO.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanDeleteDocECO()
Public Sub AssertUserCanDeleteDocECO
public:
void AssertUserCanDeleteDocECO()
member AssertUserCanDeleteDocECO : unit -> unit
Vedi anche

Documentazione

Classe Assert
Overload di AssertUserCanDeleteDocECO
Namespace DedNet.Core


Metodo Assert.AssertUserCanDeleteDocECO(DedComm)

Metodo AssertAssertUserCanDeleteDocECO(DedComm)
Controlla che l'utente abbia il permesso di eliminare i documenti dall'ECO.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanDeleteDocECO(
    DedComm comm
)
Public Sub AssertUserCanDeleteDocECO (
    comm As DedComm
)
public:
void AssertUserCanDeleteDocECO(
    DedComm^ comm
)
member AssertUserCanDeleteDocECO :
        comm : DedComm -> unit

Parametri

comm DedComm
Vedi anche

Documentazione

Classe Assert
Overload di AssertUserCanDeleteDocECO
Namespace DedNet.Core


Metodo Assert.AssertUserCanDeleteDocECO(DedType)

Metodo AssertAssertUserCanDeleteDocECO(DedType)
Controlla che l'utente abbia il permesso di eliminare i documenti dall'ECO.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanDeleteDocECO(
    DedType fam
)
Public Sub AssertUserCanDeleteDocECO (
    fam As DedType
)
public:
void AssertUserCanDeleteDocECO(
    DedType^ fam
)
member AssertUserCanDeleteDocECO :
        fam : DedType -> unit

Parametri

fam DedType
Vedi anche

Documentazione

Classe Assert
Overload di AssertUserCanDeleteDocECO
Namespace DedNet.Core


Metodo Assert.AssertUserCanEditComm

Metodo AssertAssertUserCanEditComm
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AssertUserCanEditComm(Boolean) | Controlla che l'utente abbia il permesso di editare le commesse.
Metodo pubblico | AssertUserCanEditComm(DedComm) | Controlla che l'utente abbia il permesso di editare le commesse.
Torna su
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertUserCanEditComm(Boolean)

Metodo AssertAssertUserCanEditComm(Boolean)
Controlla che l'utente abbia il permesso di editare le commesse.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanEditComm(
    bool checkOnlyGeneralPerm = false
)
Public Sub AssertUserCanEditComm (
    Optional checkOnlyGeneralPerm As Boolean = false
)
public:
void AssertUserCanEditComm(
    bool checkOnlyGeneralPerm = false
)
member AssertUserCanEditComm :
        ?checkOnlyGeneralPerm : bool
(* Defaults:
        let _checkOnlyGeneralPerm = defaultArg checkOnlyGeneralPerm false
*)
-> unit

Parametri

checkOnlyGeneralPerm Boolean (Optional)
Vedi anche

Documentazione

Classe Assert
Overload di AssertUserCanEditComm
Namespace DedNet.Core


Metodo Assert.AssertUserCanEditComm(DedComm)

Metodo AssertAssertUserCanEditComm(DedComm)
Controlla che l'utente abbia il permesso di editare le commesse.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanEditComm(
    DedComm comm
)
Public Sub AssertUserCanEditComm (
    comm As DedComm
)
public:
void AssertUserCanEditComm(
    DedComm^ comm
)
member AssertUserCanEditComm :
        comm : DedComm -> unit

Parametri

comm DedComm
Vedi anche

Documentazione

Classe Assert
Overload di AssertUserCanEditComm
Namespace DedNet.Core


Metodo Assert.AssertUserCanEditECO

Metodo AssertAssertUserCanEditECO
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AssertUserCanEditECO(DedComm) | Controlla che l'utente abbia il permesso di modificare gli ECO.
Metodo pubblico | AssertUserCanEditECO(DedType) | Controlla che l'utente abbia il permesso di modificare gli ECO.
Torna su
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertUserCanEditECO(DedComm)

Metodo AssertAssertUserCanEditECO(DedComm)
Controlla che l'utente abbia il permesso di modificare gli ECO.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanEditECO(
    DedComm comm
)
Public Sub AssertUserCanEditECO (
    comm As DedComm
)
public:
void AssertUserCanEditECO(
    DedComm^ comm
)
member AssertUserCanEditECO :
        comm : DedComm -> unit

Parametri

comm DedComm
Vedi anche

Documentazione

Classe Assert
Overload di AssertUserCanEditECO
Namespace DedNet.Core


Metodo Assert.AssertUserCanEditECO(DedType)

Metodo AssertAssertUserCanEditECO(DedType)
Controlla che l'utente abbia il permesso di modificare gli ECO.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanEditECO(
    DedType fam
)
Public Sub AssertUserCanEditECO (
    fam As DedType
)
public:
void AssertUserCanEditECO(
    DedType^ fam
)
member AssertUserCanEditECO :
        fam : DedType -> unit

Parametri

fam DedType
Vedi anche

Documentazione

Classe Assert
Overload di AssertUserCanEditECO
Namespace DedNet.Core


Metodo Assert.AssertUserCanEditFolder

Metodo AssertAssertUserCanEditFolder
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AssertUserCanEditFolder(Boolean) | Controlla che l'utente abbia il permesso di modificare le cartelle.
Metodo pubblico | AssertUserCanEditFolder(String) | Controlla che l'utente abbia il permesso di modificare le cartelle.
Torna su
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertUserCanEditFolder(Boolean)

Metodo AssertAssertUserCanEditFolder(Boolean)
Controlla che l'utente abbia il permesso di modificare le cartelle.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanEditFolder(
    bool checkOnlyGeneralPerm = false
)
Public Sub AssertUserCanEditFolder (
    Optional checkOnlyGeneralPerm As Boolean = false
)
public:
void AssertUserCanEditFolder(
    bool checkOnlyGeneralPerm = false
)
member AssertUserCanEditFolder :
        ?checkOnlyGeneralPerm : bool
(* Defaults:
        let _checkOnlyGeneralPerm = defaultArg checkOnlyGeneralPerm false
*)
-> unit

Parametri

checkOnlyGeneralPerm Boolean (Optional)
Vedi anche

Documentazione

Classe Assert
Overload di AssertUserCanEditFolder
Namespace DedNet.Core


Metodo Assert.AssertUserCanEditFolder(String)

Metodo AssertAssertUserCanEditFolder(String)
Controlla che l'utente abbia il permesso di modificare le cartelle.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanEditFolder(
    string path
)
Public Sub AssertUserCanEditFolder (
    path As String
)
public:
void AssertUserCanEditFolder(
    String^ path
)
member AssertUserCanEditFolder :
        path : string -> unit

Parametri

path String
Vedi anche

Documentazione

Classe Assert
Overload di AssertUserCanEditFolder
Namespace DedNet.Core


Metodo Assert.AssertUserCanErase

Metodo AssertAssertUserCanErase
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AssertUserCanErase(Boolean) | Controlla che l'utente abbia il permesso di Eliminare in generale.
Metodo pubblico | AssertUserCanErase(DedType) | Controlla che l'utente abbia il permesso di Eliminare sulla specifica famiglia.
Torna su
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertUserCanErase(Boolean)

Metodo AssertAssertUserCanErase(Boolean)
Controlla che l'utente abbia il permesso di Eliminare in generale.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanErase(
    bool checkOnlyGeneralPerm = false
)
Public Sub AssertUserCanErase (
    Optional checkOnlyGeneralPerm As Boolean = false
)
public:
void AssertUserCanErase(
    bool checkOnlyGeneralPerm = false
)
member AssertUserCanErase :
        ?checkOnlyGeneralPerm : bool
(* Defaults:
        let _checkOnlyGeneralPerm = defaultArg checkOnlyGeneralPerm false
*)
-> unit

Parametri

checkOnlyGeneralPerm Boolean (Optional)
Vedi anche

Documentazione

Classe Assert
Overload di AssertUserCanErase
Namespace DedNet.Core


Metodo Assert.AssertUserCanErase(DedType)

Metodo AssertAssertUserCanErase(DedType)
Controlla che l'utente abbia il permesso di Eliminare sulla specifica famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanErase(
    DedType fam
)
Public Sub AssertUserCanErase (
    fam As DedType
)
public:
void AssertUserCanErase(
    DedType^ fam
)
member AssertUserCanErase :
        fam : DedType -> unit

Parametri

fam DedType
Famiglia sulla quale controllare il permesso.
Vedi anche

Documentazione

Classe Assert
Overload di AssertUserCanErase
Namespace DedNet.Core


Metodo Assert.AssertUserCanEraseComm

Metodo AssertAssertUserCanEraseComm
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AssertUserCanEraseComm(Boolean) | Controlla che l'utente abbia il permesso di eliminare le commesse.
Metodo pubblico | AssertUserCanEraseComm(DedComm) | Controlla che l'utente abbia il permesso di eliminare le commesse.
Torna su
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertUserCanEraseComm(Boolean)

Metodo AssertAssertUserCanEraseComm(Boolean)
Controlla che l'utente abbia il permesso di eliminare le commesse.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanEraseComm(
    bool checkOnlyGeneralPerm = false
)
Public Sub AssertUserCanEraseComm (
    Optional checkOnlyGeneralPerm As Boolean = false
)
public:
void AssertUserCanEraseComm(
    bool checkOnlyGeneralPerm = false
)
member AssertUserCanEraseComm :
        ?checkOnlyGeneralPerm : bool
(* Defaults:
        let _checkOnlyGeneralPerm = defaultArg checkOnlyGeneralPerm false
*)
-> unit

Parametri

checkOnlyGeneralPerm Boolean (Optional)
Vedi anche

Documentazione

Classe Assert
Overload di AssertUserCanEraseComm
Namespace DedNet.Core


Metodo Assert.AssertUserCanEraseComm(DedComm)

Metodo AssertAssertUserCanEraseComm(DedComm)
Controlla che l'utente abbia il permesso di eliminare le commesse.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanEraseComm(
    DedComm comm
)
Public Sub AssertUserCanEraseComm (
    comm As DedComm
)
public:
void AssertUserCanEraseComm(
    DedComm^ comm
)
member AssertUserCanEraseComm :
        comm : DedComm -> unit

Parametri

comm DedComm
Vedi anche

Documentazione

Classe Assert
Overload di AssertUserCanEraseComm
Namespace DedNet.Core


Metodo Assert.AssertUserCanEraseFolder

Metodo AssertAssertUserCanEraseFolder
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AssertUserCanEraseFolder(Boolean) | Controlla che l'utente abbia il permesso di cancellare le cartelle.
Metodo pubblico | AssertUserCanEraseFolder(String) | Controlla che l'utente abbia il permesso di cancellare le cartelle.
Torna su
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertUserCanEraseFolder(Boolean)

Metodo AssertAssertUserCanEraseFolder(Boolean)
Controlla che l'utente abbia il permesso di cancellare le cartelle.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanEraseFolder(
    bool checkOnlyGeneralPerm = false
)
Public Sub AssertUserCanEraseFolder (
    Optional checkOnlyGeneralPerm As Boolean = false
)
public:
void AssertUserCanEraseFolder(
    bool checkOnlyGeneralPerm = false
)
member AssertUserCanEraseFolder :
        ?checkOnlyGeneralPerm : bool
(* Defaults:
        let _checkOnlyGeneralPerm = defaultArg checkOnlyGeneralPerm false
*)
-> unit

Parametri

checkOnlyGeneralPerm Boolean (Optional)
Vedi anche

Documentazione

Classe Assert
Overload di AssertUserCanEraseFolder
Namespace DedNet.Core


Metodo Assert.AssertUserCanEraseFolder(String)

Metodo AssertAssertUserCanEraseFolder(String)
Controlla che l'utente abbia il permesso di cancellare le cartelle.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanEraseFolder(
    string path
)
Public Sub AssertUserCanEraseFolder (
    path As String
)
public:
void AssertUserCanEraseFolder(
    String^ path
)
member AssertUserCanEraseFolder :
        path : string -> unit

Parametri

path String
Vedi anche

Documentazione

Classe Assert
Overload di AssertUserCanEraseFolder
Namespace DedNet.Core


Metodo Assert.AssertUserCanExceuteCmdForced

Metodo AssertAssertUserCanExceuteCmdForced
Controlla che l'utente abbia il permesso di Amministrare le famiglie.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanExceuteCmdForced(
    bool checkOnlyGeneralPerm = false
)
Public Sub AssertUserCanExceuteCmdForced (
    Optional checkOnlyGeneralPerm As Boolean = false
)
public:
void AssertUserCanExceuteCmdForced(
    bool checkOnlyGeneralPerm = false
)
member AssertUserCanExceuteCmdForced :
        ?checkOnlyGeneralPerm : bool
(* Defaults:
        let _checkOnlyGeneralPerm = defaultArg checkOnlyGeneralPerm false
*)
-> unit

Parametri

checkOnlyGeneralPerm Boolean (Optional)
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertUserCanManageAttach

Metodo AssertAssertUserCanManageAttach
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AssertUserCanManageAttach(Boolean) | Controlla che l'utente abbia il permesso di gestione degli allegati.
Metodo pubblico | AssertUserCanManageAttach(DedType) | Controlla che l'utente abbia il permesso di Allegare sulla specifica famiglia.
Torna su
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertUserCanManageAttach(Boolean)

Metodo AssertAssertUserCanManageAttach(Boolean)
Controlla che l'utente abbia il permesso di gestione degli allegati.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanManageAttach(
    bool checkOnlyGeneralPerm = false
)
Public Sub AssertUserCanManageAttach (
    Optional checkOnlyGeneralPerm As Boolean = false
)
public:
void AssertUserCanManageAttach(
    bool checkOnlyGeneralPerm = false
)
member AssertUserCanManageAttach :
        ?checkOnlyGeneralPerm : bool
(* Defaults:
        let _checkOnlyGeneralPerm = defaultArg checkOnlyGeneralPerm false
*)
-> unit

Parametri

checkOnlyGeneralPerm Boolean (Optional)
Vedi anche

Documentazione

Classe Assert
Overload di AssertUserCanManageAttach
Namespace DedNet.Core


Metodo Assert.AssertUserCanManageAttach(DedType)

Metodo AssertAssertUserCanManageAttach(DedType)
Controlla che l'utente abbia il permesso di Allegare sulla specifica famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanManageAttach(
    DedType fam
)
Public Sub AssertUserCanManageAttach (
    fam As DedType
)
public:
void AssertUserCanManageAttach(
    DedType^ fam
)
member AssertUserCanManageAttach :
        fam : DedType -> unit

Parametri

fam DedType
Famiglia sulla quale controllare il permesso.
Vedi anche

Documentazione

Classe Assert
Overload di AssertUserCanManageAttach
Namespace DedNet.Core


Metodo Assert.AssertUserCanOnComm

Metodo AssertAssertUserCanOnComm
Controlla che l'utente abbia il permesso passato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanOnComm(
    DedStandardPerm perm,
    DedComm comm
)
Public Sub AssertUserCanOnComm (
    perm As DedStandardPerm,
    comm As DedComm
)
public:
void AssertUserCanOnComm(
    DedStandardPerm perm,
    DedComm^ comm
)
member AssertUserCanOnComm :
        perm : DedStandardPerm *
        comm : DedComm -> unit

Parametri

perm DedStandardPerm
Permesso da controllare.
comm DedComm
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertUserCanOnFolder

Metodo AssertAssertUserCanOnFolder
Controlla che l'utente abbia il permesso passato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanOnFolder(
    DedStandardPerm perm,
    string path
)
Public Sub AssertUserCanOnFolder (
    perm As DedStandardPerm,
    path As String
)
public:
void AssertUserCanOnFolder(
    DedStandardPerm perm,
    String^ path
)
member AssertUserCanOnFolder :
        perm : DedStandardPerm *
        path : string -> unit

Parametri

perm DedStandardPerm
Permesso da controllare.
path String
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertUserCanRead

Metodo AssertAssertUserCanRead
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AssertUserCanRead(Boolean) | Controlla che l'utente abbia il permesso di lettura in generale.
Metodo pubblico | AssertUserCanRead(DedType) | Controlla che l'utente abbia il permesso di lettura sulla specifica famiglia.
Torna su
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertUserCanRead(Boolean)

Metodo AssertAssertUserCanRead(Boolean)
Controlla che l'utente abbia il permesso di lettura in generale.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanRead(
    bool checkOnlyGeneralPerm = false
)
Public Sub AssertUserCanRead (
    Optional checkOnlyGeneralPerm As Boolean = false
)
public:
void AssertUserCanRead(
    bool checkOnlyGeneralPerm = false
)
member AssertUserCanRead :
        ?checkOnlyGeneralPerm : bool
(* Defaults:
        let _checkOnlyGeneralPerm = defaultArg checkOnlyGeneralPerm false
*)
-> unit

Parametri

checkOnlyGeneralPerm Boolean (Optional)
Vedi anche

Documentazione

Classe Assert
Overload di AssertUserCanRead
Namespace DedNet.Core


Metodo Assert.AssertUserCanRead(DedType)

Metodo AssertAssertUserCanRead(DedType)
Controlla che l'utente abbia il permesso di lettura sulla specifica famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanRead(
    DedType fam
)
Public Sub AssertUserCanRead (
    fam As DedType
)
public:
void AssertUserCanRead(
    DedType^ fam
)
member AssertUserCanRead :
        fam : DedType -> unit

Parametri

fam DedType
Famiglia sulla quale controllare il permesso.
Vedi anche

Documentazione

Classe Assert
Overload di AssertUserCanRead
Namespace DedNet.Core


Metodo Assert.AssertUserCanReadComm

Metodo AssertAssertUserCanReadComm
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AssertUserCanReadComm(Boolean) | Controlla che l'utente abbia il permesso di visualizzare le commesse.
Metodo pubblico | AssertUserCanReadComm(DedComm) | Controlla che l'utente abbia il permesso di visualizzare le commesse.
Torna su
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertUserCanReadComm(Boolean)

Metodo AssertAssertUserCanReadComm(Boolean)
Controlla che l'utente abbia il permesso di visualizzare le commesse.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanReadComm(
    bool checkOnlyGeneralPerm = false
)
Public Sub AssertUserCanReadComm (
    Optional checkOnlyGeneralPerm As Boolean = false
)
public:
void AssertUserCanReadComm(
    bool checkOnlyGeneralPerm = false
)
member AssertUserCanReadComm :
        ?checkOnlyGeneralPerm : bool
(* Defaults:
        let _checkOnlyGeneralPerm = defaultArg checkOnlyGeneralPerm false
*)
-> unit

Parametri

checkOnlyGeneralPerm Boolean (Optional)
Vedi anche

Documentazione

Classe Assert
Overload di AssertUserCanReadComm
Namespace DedNet.Core


Metodo Assert.AssertUserCanReadComm(DedComm)

Metodo AssertAssertUserCanReadComm(DedComm)
Controlla che l'utente abbia il permesso di visualizzare le commesse.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanReadComm(
    DedComm comm
)
Public Sub AssertUserCanReadComm (
    comm As DedComm
)
public:
void AssertUserCanReadComm(
    DedComm^ comm
)
member AssertUserCanReadComm :
        comm : DedComm -> unit

Parametri

comm DedComm
Vedi anche

Documentazione

Classe Assert
Overload di AssertUserCanReadComm
Namespace DedNet.Core


Metodo Assert.AssertUserCanReadECO

Metodo AssertAssertUserCanReadECO
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AssertUserCanReadECO(DedComm) | Controlla che l'utente abbia il permesso di visualizzare gli ECO.
Metodo pubblico | AssertUserCanReadECO(DedType) | Controlla che l'utente abbia il permesso di visualizzare gli ECO.
Torna su
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertUserCanReadECO(DedComm)

Metodo AssertAssertUserCanReadECO(DedComm)
Controlla che l'utente abbia il permesso di visualizzare gli ECO.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanReadECO(
    DedComm comm
)
Public Sub AssertUserCanReadECO (
    comm As DedComm
)
public:
void AssertUserCanReadECO(
    DedComm^ comm
)
member AssertUserCanReadECO :
        comm : DedComm -> unit

Parametri

comm DedComm
Vedi anche

Documentazione

Classe Assert
Overload di AssertUserCanReadECO
Namespace DedNet.Core


Metodo Assert.AssertUserCanReadECO(DedType)

Metodo AssertAssertUserCanReadECO(DedType)
Controlla che l'utente abbia il permesso di visualizzare gli ECO.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanReadECO(
    DedType fam
)
Public Sub AssertUserCanReadECO (
    fam As DedType
)
public:
void AssertUserCanReadECO(
    DedType^ fam
)
member AssertUserCanReadECO :
        fam : DedType -> unit

Parametri

fam DedType
Vedi anche

Documentazione

Classe Assert
Overload di AssertUserCanReadECO
Namespace DedNet.Core


Metodo Assert.AssertUserCanReadFolder

Metodo AssertAssertUserCanReadFolder
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AssertUserCanReadFolder(Boolean) | Controlla che l'utente abbia il permesso di visualizzare le cartelle.
Metodo pubblico | AssertUserCanReadFolder(String) | Controlla che l'utente abbia il permesso di visualizzare le cartelle.
Torna su
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertUserCanReadFolder(Boolean)

Metodo AssertAssertUserCanReadFolder(Boolean)
Controlla che l'utente abbia il permesso di visualizzare le cartelle.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanReadFolder(
    bool checkOnlyGeneralPerm = false
)
Public Sub AssertUserCanReadFolder (
    Optional checkOnlyGeneralPerm As Boolean = false
)
public:
void AssertUserCanReadFolder(
    bool checkOnlyGeneralPerm = false
)
member AssertUserCanReadFolder :
        ?checkOnlyGeneralPerm : bool
(* Defaults:
        let _checkOnlyGeneralPerm = defaultArg checkOnlyGeneralPerm false
*)
-> unit

Parametri

checkOnlyGeneralPerm Boolean (Optional)
Vedi anche

Documentazione

Classe Assert
Overload di AssertUserCanReadFolder
Namespace DedNet.Core


Metodo Assert.AssertUserCanReadFolder(String)

Metodo AssertAssertUserCanReadFolder(String)
Controlla che l'utente abbia il permesso di visualizzare le cartelle.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanReadFolder(
    string path
)
Public Sub AssertUserCanReadFolder (
    path As String
)
public:
void AssertUserCanReadFolder(
    String^ path
)
member AssertUserCanReadFolder :
        path : string -> unit

Parametri

path String
Vedi anche

Documentazione

Classe Assert
Overload di AssertUserCanReadFolder
Namespace DedNet.Core


Metodo Assert.AssertUserCanReOpenComm

Metodo AssertAssertUserCanReOpenComm
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AssertUserCanReOpenComm(Boolean) | Controlla che l'utente abbia il permesso di riaprire le commesse.
Metodo pubblico | AssertUserCanReOpenComm(DedComm) | Controlla che l'utente abbia il permesso di riaprire le commesse.
Torna su
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertUserCanReOpenComm(Boolean)

Metodo AssertAssertUserCanReOpenComm(Boolean)
Controlla che l'utente abbia il permesso di riaprire le commesse.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanReOpenComm(
    bool checkOnlyGeneralPerm = false
)
Public Sub AssertUserCanReOpenComm (
    Optional checkOnlyGeneralPerm As Boolean = false
)
public:
void AssertUserCanReOpenComm(
    bool checkOnlyGeneralPerm = false
)
member AssertUserCanReOpenComm :
        ?checkOnlyGeneralPerm : bool
(* Defaults:
        let _checkOnlyGeneralPerm = defaultArg checkOnlyGeneralPerm false
*)
-> unit

Parametri

checkOnlyGeneralPerm Boolean (Optional)
Vedi anche

Documentazione

Classe Assert
Overload di AssertUserCanReOpenComm
Namespace DedNet.Core


Metodo Assert.AssertUserCanReOpenComm(DedComm)

Metodo AssertAssertUserCanReOpenComm(DedComm)
Controlla che l'utente abbia il permesso di riaprire le commesse.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanReOpenComm(
    DedComm comm
)
Public Sub AssertUserCanReOpenComm (
    comm As DedComm
)
public:
void AssertUserCanReOpenComm(
    DedComm^ comm
)
member AssertUserCanReOpenComm :
        comm : DedComm -> unit

Parametri

comm DedComm
Vedi anche

Documentazione

Classe Assert
Overload di AssertUserCanReOpenComm
Namespace DedNet.Core


Metodo Assert.AssertUserCanRev

Metodo AssertAssertUserCanRev
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AssertUserCanRev(Boolean) | Controlla che l'utente abbia il permesso di Revisionare in generale.
Metodo pubblico | AssertUserCanRev(DedType) | Controlla che l'utente abbia il permesso di Revisionare sulla specifica famiglia.
Torna su
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertUserCanRev(Boolean)

Metodo AssertAssertUserCanRev(Boolean)
Controlla che l'utente abbia il permesso di Revisionare in generale.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanRev(
    bool checkOnlyGeneralPerm = false
)
Public Sub AssertUserCanRev (
    Optional checkOnlyGeneralPerm As Boolean = false
)
public:
void AssertUserCanRev(
    bool checkOnlyGeneralPerm = false
)
member AssertUserCanRev :
        ?checkOnlyGeneralPerm : bool
(* Defaults:
        let _checkOnlyGeneralPerm = defaultArg checkOnlyGeneralPerm false
*)
-> unit

Parametri

checkOnlyGeneralPerm Boolean (Optional)
Vedi anche

Documentazione

Classe Assert
Overload di AssertUserCanRev
Namespace DedNet.Core


Metodo Assert.AssertUserCanRev(DedType)

Metodo AssertAssertUserCanRev(DedType)
Controlla che l'utente abbia il permesso di Revisionare sulla specifica famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanRev(
    DedType fam
)
Public Sub AssertUserCanRev (
    fam As DedType
)
public:
void AssertUserCanRev(
    DedType^ fam
)
member AssertUserCanRev :
        fam : DedType -> unit

Parametri

fam DedType
Famiglia sulla quale controllare il permesso.
Vedi anche

Documentazione

Classe Assert
Overload di AssertUserCanRev
Namespace DedNet.Core


Metodo Assert.AssertUserCanRil

Metodo AssertAssertUserCanRil
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AssertUserCanRil(Boolean) | Controlla che l'utente abbia il permesso di Rilasciare in generale.
Metodo pubblico | AssertUserCanRil(DedType) | Controlla che l'utente abbia il permesso di Rilasciare sulla specifica famiglia.
Torna su
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertUserCanRil(Boolean)

Metodo AssertAssertUserCanRil(Boolean)
Controlla che l'utente abbia il permesso di Rilasciare in generale.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanRil(
    bool checkOnlyGeneralPerm = false
)
Public Sub AssertUserCanRil (
    Optional checkOnlyGeneralPerm As Boolean = false
)
public:
void AssertUserCanRil(
    bool checkOnlyGeneralPerm = false
)
member AssertUserCanRil :
        ?checkOnlyGeneralPerm : bool
(* Defaults:
        let _checkOnlyGeneralPerm = defaultArg checkOnlyGeneralPerm false
*)
-> unit

Parametri

checkOnlyGeneralPerm Boolean (Optional)
Vedi anche

Documentazione

Classe Assert
Overload di AssertUserCanRil
Namespace DedNet.Core


Metodo Assert.AssertUserCanRil(DedType)

Metodo AssertAssertUserCanRil(DedType)
Controlla che l'utente abbia il permesso di Rilasciare sulla specifica famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanRil(
    DedType fam
)
Public Sub AssertUserCanRil (
    fam As DedType
)
public:
void AssertUserCanRil(
    DedType^ fam
)
member AssertUserCanRil :
        fam : DedType -> unit

Parametri

fam DedType
Famiglia sulla quale controllare il permesso.
Vedi anche

Documentazione

Classe Assert
Overload di AssertUserCanRil
Namespace DedNet.Core


Metodo Assert.AssertUserCanUnRil

Metodo AssertAssertUserCanUnRil
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AssertUserCanUnRil(Boolean) | Controlla che l'utente abbia il permesso di Togliere il Rilasciare in generale.
Metodo pubblico | AssertUserCanUnRil(DedType) | Controlla che l'utente abbia il permesso di Togliere il Rilasciare sulla specifica famiglia.
Torna su
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertUserCanUnRil(Boolean)

Metodo AssertAssertUserCanUnRil(Boolean)
Controlla che l'utente abbia il permesso di Togliere il Rilasciare in generale.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanUnRil(
    bool checkOnlyGeneralPerm = false
)
Public Sub AssertUserCanUnRil (
    Optional checkOnlyGeneralPerm As Boolean = false
)
public:
void AssertUserCanUnRil(
    bool checkOnlyGeneralPerm = false
)
member AssertUserCanUnRil :
        ?checkOnlyGeneralPerm : bool
(* Defaults:
        let _checkOnlyGeneralPerm = defaultArg checkOnlyGeneralPerm false
*)
-> unit

Parametri

checkOnlyGeneralPerm Boolean (Optional)
Vedi anche

Documentazione

Classe Assert
Overload di AssertUserCanUnRil
Namespace DedNet.Core


Metodo Assert.AssertUserCanUnRil(DedType)

Metodo AssertAssertUserCanUnRil(DedType)
Controlla che l'utente abbia il permesso di Togliere il Rilasciare sulla specifica famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanUnRil(
    DedType fam
)
Public Sub AssertUserCanUnRil (
    fam As DedType
)
public:
void AssertUserCanUnRil(
    DedType^ fam
)
member AssertUserCanUnRil :
        fam : DedType -> unit

Parametri

fam DedType
Famiglia sulla quale controllare il permesso.
Vedi anche

Documentazione

Classe Assert
Overload di AssertUserCanUnRil
Namespace DedNet.Core


Metodo Assert.AssertUserCanWrite

Metodo AssertAssertUserCanWrite
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AssertUserCanWrite(Boolean) | Controlla che l'utente abbia il permesso di Modifica in generale.
Metodo pubblico | AssertUserCanWrite(DedType) | Controlla che l'utente abbia il permesso di Modifica sulla specifica famiglia.
Torna su
Vedi anche

Documentazione

Classe Assert
Namespace DedNet.Core


Metodo Assert.AssertUserCanWrite(Boolean)

Metodo AssertAssertUserCanWrite(Boolean)
Controlla che l'utente abbia il permesso di Modifica in generale.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanWrite(
    bool checkOnlyGeneralPerm = false
)
Public Sub AssertUserCanWrite (
    Optional checkOnlyGeneralPerm As Boolean = false
)
public:
void AssertUserCanWrite(
    bool checkOnlyGeneralPerm = false
)
member AssertUserCanWrite :
        ?checkOnlyGeneralPerm : bool
(* Defaults:
        let _checkOnlyGeneralPerm = defaultArg checkOnlyGeneralPerm false
*)
-> unit

Parametri

checkOnlyGeneralPerm Boolean (Optional)
Vedi anche

Documentazione

Classe Assert
Overload di AssertUserCanWrite
Namespace DedNet.Core


Metodo Assert.AssertUserCanWrite(DedType)

Metodo AssertAssertUserCanWrite(DedType)
Controlla che l'utente abbia il permesso di Modifica sulla specifica famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertUserCanWrite(
    DedType fam
)
Public Sub AssertUserCanWrite (
    fam As DedType
)
public:
void AssertUserCanWrite(
    DedType^ fam
)
member AssertUserCanWrite :
        fam : DedType -> unit

Parametri

fam DedType
Famiglia sulla quale controllare il permesso.
Vedi anche

Documentazione

Classe Assert
Overload di AssertUserCanWrite
Namespace DedNet.Core


Enumerazione BomCloneMode
Enumerazione per indicare il tipo di clonazione dei dati di distinta al salvataggio

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum BomCloneMode
Public Enumeration BomCloneMode
public enum class BomCloneMode
type BomCloneMode
Membri
Nome | Valore | Descrizione
No | 0 | Non clonare
All | 1 | Clona tutto
OnlyMan | 2 | Clona solo elementi aggiunti manualmente
Vedi anche

Documentazione

Namespace DedNet.Core


Classe BomItem
Rappresenta un singolo legame padre-figlio nell'ambito della distinta. Questo legame (riconducibile ad una singola riga nella tabella DED_BOM) ha una data di creazione ed una di validità che ne limitano lo spazio temporale.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreBomItem

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class BomItem : IDedDbItem
Public Class BomItem
    Implements IDedDbItem
public ref class BomItem : IDedDbItem
type BomItem =
    class
        interface IDedDbItem
    end

Il tipo BomItem espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllowEditDistValue | Indica se gli attributi di distinta sono editabili
Proprietà pubblica | Anagr | Restituisce l'anagrafica dell'elemento.
Proprietà pubblica | BomEditAdded | Indica se l'elemento è nato in un contesto di editazione della disinta
Proprietà pubblica | CommAnagr | Restituisce l'eventuale anagrafica di commessa.
Proprietà pubblica | CommParent | Restituisce l'eventuale commessa padre in cui è inserito.
Proprietà pubblica | CreationDate | Restituisce la data di creazione di questo elemento di distinta.
Proprietà pubblica | DbRevAnagr | Restituisce la reale revisione dell'anagrafica letta dal DB.
Proprietà pubblica | DedIdChild | Restituisce il DedId del codice figlio di questo elemento di distinta.
Proprietà pubblica | DedRevChild | Restituisce il DedRev del codice figlio di questo elemento di distinta.
Proprietà pubblica | DiscrimChild | Restituisce il discriminante del codice figlio di questo elemento di distinta
Proprietà pubblica | DiscrimFrom | Discriminante di provenienza se si tratta di un elemento proveniente da una editazione di distinta
Proprietà pubblica | DistId | Restituisce il DistId dell'elemento di distinta.
Proprietà pubblica | DizOrigCadValues | Dizionario contenente i valori originali, derivanti dal CAD, degli attributi modificati
Proprietà pubblica | FakeItem | Inidca se è un item Fake (in questo caso legge i suoi Item dai FakeItems
Proprietà pubblica | HashstringCompare | Utilizzato come cache dell'hashstring creato per i confronti tra bomItem. E' stato creata la proprietà perchè viene utilizzato nella classe BomItemComparer
Proprietà pubblica | HideElementIfErased | Indica se nascondere l'elemento se viene cancellato
Proprietà pubblica | HideInfo | Indica se nascondere le informazioni dell'elemento
Proprietà pubblica | InfoCmpExp | Struttura contenente le informazioni della comparazione (usato nell'esportazione della comparazione)
Proprietà pubblica | IsImpl | Restituisce se si tratti di distinta implosa.
Proprietà pubblica | IsSparePart | Ritorna True se l'oggetto corrente è un pezzo di ricambio, False altrimenti. Note: La verifica viene eseguita richiamando il metodo 'GetValue' sull'attributo 'ATTR_RCM_SPAREPART'.
Proprietà pubblica | Items | Restituisce la sotto-distinta di questo elemento. Restituisce l'insieme degli elementi trovati oppure una collezione vuota se non ce ne sono oppure null se il codice richiesto non è presente in anagrafica.
Proprietà pubblica | Man | Restituisce o imposta il contenuto del campo MAN di questo elemento.
Proprietà pubblica | Owner | Restituisce il DistManager di appartenenza.
Proprietà pubblica | Parent | Restituisce l'oggetto BomItemCollection di appartenenza.
Proprietà pubblica | Qta | Restituisce o imposta la QTA di questo elemento.
Proprietà pubblica | StatoRecord | Restituisce o imposta lo stato del record.
Proprietà pubblica | ValidDate | Restituisce o imposta la data di validità di questo elemento di distinta.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCacheHashString | Pulisco la cache utilizzata per memorizzare gli hashstring
Metodo pubblico | Clone | Restituisce il BomItem costruito con i valori originali Cad
Metodo pubblico | DbOrigCadVal | Metodo per formattare i valori originali Cad come stringa nel database
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetAncestor | Ritorna una BomItemCollection che rappresenta il nodo radice della distinta che ha creato questo BomItem.
Metodo pubblico | GetAttrsCadDiz | Restituisce il dizionario degli attributi con i valori originali Cad del BomItem
Metodo pubblico | GetAttrsDiz | Restituisce il dizionario degli attributi del BomItem
Metodo pubblico | GetBomItemCad | Restituisce il BomItem costruito con i valori originali Cad
Metodo pubblico | GetHashCode | Vengono riconosciuti uguali gli elementi che hanno tutti i campi uguali tranne QTA che non concorre come discriminante. (Sovrascrive ObjectGetHashCode)
Metodo pubblico | GetHashString |
Metodo pubblico | GetValue | Restituisce il valore dell'attributo di distinta specificato.
Metodo pubblico | SetDizOrigCadVal | Metodo per impostare nell'oggetto i valori letti dalla stringa del database. Splitta la stringa nella coppia attributo-valore e la mette nel dizionario interno.
Metodo pubblico | SetOrigCadValue | Metodo per impostare nel BomItem i vecchio valori CAD. Rende Dirty l'oggetto se necessario.
Metodo pubblico | SetValue | Imposta il valore dell'attributo di distinta specificato.
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Metodo pubblico | UpdateItemAnagr | Aggiorna l'anagrafica dell'item se non è in ultima revisione e mette a dirty la distinta
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di BomItem

Il tipo BomItem espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllowEditDistValue | Indica se gli attributi di distinta sono editabili
Proprietà pubblica | Anagr | Restituisce l'anagrafica dell'elemento.
Proprietà pubblica | BomEditAdded | Indica se l'elemento è nato in un contesto di editazione della disinta
Proprietà pubblica | CommAnagr | Restituisce l'eventuale anagrafica di commessa.
Proprietà pubblica | CommParent | Restituisce l'eventuale commessa padre in cui è inserito.
Proprietà pubblica | CreationDate | Restituisce la data di creazione di questo elemento di distinta.
Proprietà pubblica | DbRevAnagr | Restituisce la reale revisione dell'anagrafica letta dal DB.
Proprietà pubblica | DedIdChild | Restituisce il DedId del codice figlio di questo elemento di distinta.
Proprietà pubblica | DedRevChild | Restituisce il DedRev del codice figlio di questo elemento di distinta.
Proprietà pubblica | DiscrimChild | Restituisce il discriminante del codice figlio di questo elemento di distinta
Proprietà pubblica | DiscrimFrom | Discriminante di provenienza se si tratta di un elemento proveniente da una editazione di distinta
Proprietà pubblica | DistId | Restituisce il DistId dell'elemento di distinta.
Proprietà pubblica | DizOrigCadValues | Dizionario contenente i valori originali, derivanti dal CAD, degli attributi modificati
Proprietà pubblica | FakeItem | Inidca se è un item Fake (in questo caso legge i suoi Item dai FakeItems
Proprietà pubblica | HashstringCompare | Utilizzato come cache dell'hashstring creato per i confronti tra bomItem. E' stato creata la proprietà perchè viene utilizzato nella classe BomItemComparer
Proprietà pubblica | HideElementIfErased | Indica se nascondere l'elemento se viene cancellato
Proprietà pubblica | HideInfo | Indica se nascondere le informazioni dell'elemento
Proprietà pubblica | InfoCmpExp | Struttura contenente le informazioni della comparazione (usato nell'esportazione della comparazione)
Proprietà pubblica | IsImpl | Restituisce se si tratti di distinta implosa.
Proprietà pubblica | IsSparePart | Ritorna True se l'oggetto corrente è un pezzo di ricambio, False altrimenti. Note: La verifica viene eseguita richiamando il metodo 'GetValue' sull'attributo 'ATTR_RCM_SPAREPART'.
Proprietà pubblica | Items | Restituisce la sotto-distinta di questo elemento. Restituisce l'insieme degli elementi trovati oppure una collezione vuota se non ce ne sono oppure null se il codice richiesto non è presente in anagrafica.
Proprietà pubblica | Man | Restituisce o imposta il contenuto del campo MAN di questo elemento.
Proprietà pubblica | Owner | Restituisce il DistManager di appartenenza.
Proprietà pubblica | Parent | Restituisce l'oggetto BomItemCollection di appartenenza.
Proprietà pubblica | Qta | Restituisce o imposta la QTA di questo elemento.
Proprietà pubblica | StatoRecord | Restituisce o imposta lo stato del record.
Proprietà pubblica | ValidDate | Restituisce o imposta la data di validità di questo elemento di distinta.
Torna su
Vedi anche

Documentazione

Classe BomItem
Namespace DedNet.Core


Proprietà BomItem.AllowEditDistValue

Proprietà BomItemAllowEditDistValue
Indica se gli attributi di distinta sono editabili

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AllowEditDistValue { get; }
Public ReadOnly Property AllowEditDistValue As Boolean
    Get
public:
property bool AllowEditDistValue {
    bool get ();
}
member AllowEditDistValue : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe BomItem
Namespace DedNet.Core


Proprietà BomItem.Anagr

Proprietà BomItemAnagr
Restituisce l'anagrafica dell'elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Anagr { get; }
Public ReadOnly Property Anagr As DedData
    Get
public:
property DedData^ Anagr {
    DedData^ get ();
}
member Anagr : DedData with get

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe BomItem
Namespace DedNet.Core


Proprietà BomItem.BomEditAdded

Proprietà BomItemBomEditAdded
Indica se l'elemento è nato in un contesto di editazione della disinta

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool BomEditAdded { get; set; }
Public Property BomEditAdded As Boolean
    Get
    Set
public:
property bool BomEditAdded {
    bool get ();
    void set (bool value);
}
member BomEditAdded : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe BomItem
Namespace DedNet.Core


Proprietà BomItem.CommAnagr

Proprietà BomItemCommAnagr
Restituisce l'eventuale anagrafica di commessa.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommAnagrItem CommAnagr { get; set; }
Public Property CommAnagr As DedCommAnagrItem
    Get
    Set
public:
property DedCommAnagrItem^ CommAnagr {
    DedCommAnagrItem^ get ();
    void set (DedCommAnagrItem^ value);
}
member CommAnagr : DedCommAnagrItem with get, set

Valore della proprietà

DedCommAnagrItem
Vedi anche

Documentazione

Classe BomItem
Namespace DedNet.Core


Proprietà BomItem.CommParent

Proprietà BomItemCommParent
Restituisce l'eventuale commessa padre in cui è inserito.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedComm CommParent { get; set; }
Public Property CommParent As DedComm
    Get
    Set
public:
property DedComm^ CommParent {
    DedComm^ get ();
    void set (DedComm^ value);
}
member CommParent : DedComm with get, set

Valore della proprietà

DedComm
Vedi anche

Documentazione

Classe BomItem
Namespace DedNet.Core


Proprietà BomItem.CreationDate

Proprietà BomItemCreationDate
Restituisce la data di creazione di questo elemento di distinta.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DateTime? CreationDate { get; }
Public ReadOnly Property CreationDate As DateTime?
    Get
public:
property Nullable<DateTime> CreationDate {
    Nullable<DateTime> get ();
}
member CreationDate : Nullable<DateTime> with get

Valore della proprietà

Nullable DateTime
Vedi anche

Documentazione

Classe BomItem
Namespace DedNet.Core


Proprietà BomItem.DbRevAnagr

Proprietà BomItemDbRevAnagr
Restituisce la reale revisione dell'anagrafica letta dal DB.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData DbRevAnagr { get; }
Public ReadOnly Property DbRevAnagr As DedData
    Get
public:
property DedData^ DbRevAnagr {
    DedData^ get ();
}
member DbRevAnagr : DedData with get

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe BomItem
Namespace DedNet.Core


Proprietà BomItem.DedIdChild

Proprietà BomItemDedIdChild
Restituisce il DedId del codice figlio di questo elemento di distinta.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string DedIdChild { get; }
Public ReadOnly Property DedIdChild As String
    Get
public:
property String^ DedIdChild {
    String^ get ();
}
member DedIdChild : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe BomItem
Namespace DedNet.Core


Proprietà BomItem.DedRevChild

Proprietà BomItemDedRevChild
Restituisce il DedRev del codice figlio di questo elemento di distinta.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string DedRevChild { get; }
Public ReadOnly Property DedRevChild As String
    Get
public:
property String^ DedRevChild {
    String^ get ();
}
member DedRevChild : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe BomItem
Namespace DedNet.Core


Proprietà BomItem.DiscrimChild

Proprietà BomItemDiscrimChild
Restituisce il discriminante del codice figlio di questo elemento di distinta

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string DiscrimChild { get; }
Public ReadOnly Property DiscrimChild As String
    Get
public:
property String^ DiscrimChild {
    String^ get ();
}
member DiscrimChild : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe BomItem
Namespace DedNet.Core


Proprietà BomItem.DiscrimFrom

Proprietà BomItemDiscrimFrom
Discriminante di provenienza se si tratta di un elemento proveniente da una editazione di distinta

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string DiscrimFrom { get; set; }
Public Property DiscrimFrom As String
    Get
    Set
public:
property String^ DiscrimFrom {
    String^ get ();
    void set (String^ value);
}
member DiscrimFrom : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe BomItem
Namespace DedNet.Core


Proprietà BomItem.DistId

Proprietà BomItemDistId
Restituisce il DistId dell'elemento di distinta.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Guid DistId { get; }
Public ReadOnly Property DistId As Guid
    Get
public:
property Guid DistId {
    Guid get ();
}
member DistId : Guid with get

Valore della proprietà

Guid
Vedi anche

Documentazione

Classe BomItem
Namespace DedNet.Core


Proprietà BomItem.DizOrigCadValues

Proprietà BomItemDizOrigCadValues
Dizionario contenente i valori originali, derivanti dal CAD, degli attributi modificati

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<string, Object> DizOrigCadValues { get; set; }
Public Property DizOrigCadValues As Dictionary(Of String, Object)
    Get
    Set
public:
property Dictionary<String^, Object^>^ DizOrigCadValues {
    Dictionary<String^, Object^>^ get ();
    void set (Dictionary<String^, Object^>^ value);
}
member DizOrigCadValues : Dictionary<string, Object> with get, set

Valore della proprietà

Dictionary String, Object
Vedi anche

Documentazione

Classe BomItem
Namespace DedNet.Core


Proprietà BomItem.FakeItem

Proprietà BomItemFakeItem
Inidca se è un item Fake (in questo caso legge i suoi Item dai FakeItems

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool FakeItem { get; set; }
Public Property FakeItem As Boolean
    Get
    Set
public:
property bool FakeItem {
    bool get ();
    void set (bool value);
}
member FakeItem : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe BomItem
Namespace DedNet.Core


Proprietà BomItem.HashstringCompare

Proprietà BomItemHashstringCompare
Utilizzato come cache dell'hashstring creato per i confronti tra bomItem. E' stato creata la proprietà perchè viene utilizzato nella classe BomItemComparer

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string HashstringCompare { get; set; }
Public Property HashstringCompare As String
    Get
    Set
public:
property String^ HashstringCompare {
    String^ get ();
    void set (String^ value);
}
member HashstringCompare : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe BomItem
Namespace DedNet.Core


Proprietà BomItem.HideElementIfErased

Proprietà BomItemHideElementIfErased
Indica se nascondere l'elemento se viene cancellato

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HideElementIfErased { get; set; }
Public Property HideElementIfErased As Boolean
    Get
    Set
public:
property bool HideElementIfErased {
    bool get ();
    void set (bool value);
}
member HideElementIfErased : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe BomItem
Namespace DedNet.Core


Proprietà BomItem.HideInfo

Proprietà BomItemHideInfo
Indica se nascondere le informazioni dell'elemento

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HideInfo { get; set; }
Public Property HideInfo As Boolean
    Get
    Set
public:
property bool HideInfo {
    bool get ();
    void set (bool value);
}
member HideInfo : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe BomItem
Namespace DedNet.Core


Proprietà BomItem.InfoCmpExp

Proprietà BomItemInfoCmpExp
Struttura contenente le informazioni della comparazione (usato nell'esportazione della comparazione)

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public RelationshipItemStruct InfoCmpExp { get; set; }
Public Property InfoCmpExp As RelationshipItemStruct
    Get
    Set
public:
property RelationshipItemStruct InfoCmpExp {
    RelationshipItemStruct get ();
    void set (RelationshipItemStruct value);
}
member InfoCmpExp : RelationshipItemStruct with get, set

Valore della proprietà

RelationshipItemStruct
Vedi anche

Documentazione

Classe BomItem
Namespace DedNet.Core


Proprietà BomItem.IsImpl

Proprietà BomItemIsImpl
Restituisce se si tratti di distinta implosa.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsImpl { get; }
Public ReadOnly Property IsImpl As Boolean
    Get
public:
property bool IsImpl {
    bool get ();
}
member IsImpl : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe BomItem
Namespace DedNet.Core


Proprietà BomItem.IsSparePart

Proprietà BomItemIsSparePart
Ritorna True se l'oggetto corrente è un pezzo di ricambio, False altrimenti. Note: La verifica viene eseguita richiamando il metodo 'GetValue' sull'attributo 'ATTR_RCM_SPAREPART'.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsSparePart { get; }
Public ReadOnly Property IsSparePart As Boolean
    Get
public:
property bool IsSparePart {
    bool get ();
}
member IsSparePart : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe BomItem
Namespace DedNet.Core


Proprietà BomItem.Items

Proprietà BomItemItems
Restituisce la sotto-distinta di questo elemento. Restituisce l'insieme degli elementi trovati oppure una collezione vuota se non ce ne sono oppure null se il codice richiesto non è presente in anagrafica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItemCollection Items { get; set; }
Public Property Items As BomItemCollection
    Get
    Set
public:
property BomItemCollection^ Items {
    BomItemCollection^ get ();
    void set (BomItemCollection^ value);
}
member Items : BomItemCollection with get, set

Valore della proprietà

BomItemCollection
Vedi anche

Documentazione

Classe BomItem
Namespace DedNet.Core


Proprietà BomItem.Man

Proprietà BomItemMan
Restituisce o imposta il contenuto del campo MAN di questo elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItemManEnum Man { get; set; }
Public Property Man As BomItemManEnum
    Get
    Set
public:
property BomItemManEnum Man {
    BomItemManEnum get ();
    void set (BomItemManEnum value);
}
member Man : BomItemManEnum with get, set

Valore della proprietà

BomItemManEnum
Vedi anche

Documentazione

Classe BomItem
Namespace DedNet.Core


Proprietà BomItem.Owner

Proprietà BomItemOwner
Restituisce il DistManager di appartenenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DistManager Owner { get; }
Public ReadOnly Property Owner As DistManager
    Get
public:
property DistManager^ Owner {
    DistManager^ get ();
}
member Owner : DistManager with get

Valore della proprietà

DistManager
Vedi anche

Documentazione

Classe BomItem
Namespace DedNet.Core


Proprietà BomItem.Parent

Proprietà BomItemParent
Restituisce l'oggetto BomItemCollection di appartenenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItemCollection Parent { get; }
Public ReadOnly Property Parent As BomItemCollection
    Get
public:
property BomItemCollection^ Parent {
    BomItemCollection^ get ();
}
member Parent : BomItemCollection with get

Valore della proprietà

BomItemCollection
Vedi anche

Documentazione

Classe BomItem
Namespace DedNet.Core


Proprietà BomItem.Qta

Proprietà BomItemQta
Restituisce o imposta la QTA di questo elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public double Qta { get; set; }
Public Property Qta As Double
    Get
    Set
public:
property double Qta {
    double get ();
    void set (double value);
}
member Qta : float with get, set

Valore della proprietà

Double
Vedi anche

Documentazione

Classe BomItem
Namespace DedNet.Core


Proprietà BomItem.StatoRecord

Proprietà BomItemStatoRecord
Restituisce o imposta lo stato del record.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public StatoRecord StatoRecord { get; set; }
Public Property StatoRecord As StatoRecord
    Get
    Set
public:
virtual property StatoRecord^ StatoRecord {
    StatoRecord^ get () sealed;
    void set (StatoRecord^ value) sealed;
}
abstract StatoRecord : StatoRecord with get, set
override StatoRecord : StatoRecord with get, set

Valore della proprietà

StatoRecord

Implementa

IDedDbItemStatoRecord
Vedi anche

Documentazione

Classe BomItem
Namespace DedNet.Core


Proprietà BomItem.ValidDate

Proprietà BomItemValidDate
Restituisce o imposta la data di validità di questo elemento di distinta.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DateTime? ValidDate { get; set; }
Public Property ValidDate As DateTime?
    Get
    Set
public:
property Nullable<DateTime> ValidDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
member ValidDate : Nullable<DateTime> with get, set

Valore della proprietà

Nullable DateTime
Vedi anche

Documentazione

Classe BomItem
Namespace DedNet.Core


Metodi di BomItem

Il tipo BomItem espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCacheHashString | Pulisco la cache utilizzata per memorizzare gli hashstring
Metodo pubblico | Clone | Restituisce il BomItem costruito con i valori originali Cad
Metodo pubblico | DbOrigCadVal | Metodo per formattare i valori originali Cad come stringa nel database
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetAncestor | Ritorna una BomItemCollection che rappresenta il nodo radice della distinta che ha creato questo BomItem.
Metodo pubblico | GetAttrsCadDiz | Restituisce il dizionario degli attributi con i valori originali Cad del BomItem
Metodo pubblico | GetAttrsDiz | Restituisce il dizionario degli attributi del BomItem
Metodo pubblico | GetBomItemCad | Restituisce il BomItem costruito con i valori originali Cad
Metodo pubblico | GetHashCode | Vengono riconosciuti uguali gli elementi che hanno tutti i campi uguali tranne QTA che non concorre come discriminante. (Sovrascrive ObjectGetHashCode)
Metodo pubblico | GetHashString |
Metodo pubblico | GetValue | Restituisce il valore dell'attributo di distinta specificato.
Metodo pubblico | SetDizOrigCadVal | Metodo per impostare nell'oggetto i valori letti dalla stringa del database. Splitta la stringa nella coppia attributo-valore e la mette nel dizionario interno.
Metodo pubblico | SetOrigCadValue | Metodo per impostare nel BomItem i vecchio valori CAD. Rende Dirty l'oggetto se necessario.
Metodo pubblico | SetValue | Imposta il valore dell'attributo di distinta specificato.
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Metodo pubblico | UpdateItemAnagr | Aggiorna l'anagrafica dell'item se non è in ultima revisione e mette a dirty la distinta
Torna su
Vedi anche

Documentazione

Classe BomItem
Namespace DedNet.Core


Metodo BomItem.ClearCacheHashString

Metodo BomItemClearCacheHashString
Pulisco la cache utilizzata per memorizzare gli hashstring

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ClearCacheHashString()
Public Sub ClearCacheHashString
public:
void ClearCacheHashString()
member ClearCacheHashString : unit -> unit
Vedi anche

Documentazione

Classe BomItem
Namespace DedNet.Core


Metodo BomItem.Clone

Metodo BomItemClone
Restituisce il BomItem costruito con i valori originali Cad

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItem Clone()
Public Function Clone As BomItem
public:
BomItem^ Clone()
member Clone : unit -> BomItem

Valore di ritorno

BomItem
Vedi anche

Documentazione

Classe BomItem
Namespace DedNet.Core


Metodo BomItem.DbOrigCadVal

Metodo BomItemDbOrigCadVal
Metodo per formattare i valori originali Cad come stringa nel database

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string DbOrigCadVal()
Public Function DbOrigCadVal As String
public:
String^ DbOrigCadVal()
member DbOrigCadVal : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe BomItem
Namespace DedNet.Core


Metodo BomItem.Equals

Metodo BomItemEquals

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj Object

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe BomItem
Namespace DedNet.Core


Metodo BomItem.GetAncestor

Metodo BomItemGetAncestor
Ritorna una BomItemCollection che rappresenta il nodo radice della distinta che ha creato questo BomItem.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItemCollection GetAncestor()
Public Function GetAncestor As BomItemCollection
public:
BomItemCollection^ GetAncestor()
member GetAncestor : unit -> BomItemCollection

Valore di ritorno

BomItemCollection
Vedi anche

Documentazione

Classe BomItem
Namespace DedNet.Core


Metodo BomItem.GetAttrsCadDiz

Metodo BomItemGetAttrsCadDiz
Restituisce il dizionario degli attributi con i valori originali Cad del BomItem

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<string, Object> GetAttrsCadDiz()
Public Function GetAttrsCadDiz As Dictionary(Of String, Object)
public:
Dictionary<String^, Object^>^ GetAttrsCadDiz()
member GetAttrsCadDiz : unit -> Dictionary<string, Object>

Valore di ritorno

Dictionary String, Object
Vedi anche

Documentazione

Classe BomItem
Namespace DedNet.Core


Metodo BomItem.GetAttrsDiz

Metodo BomItemGetAttrsDiz
Restituisce il dizionario degli attributi del BomItem

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<string, Object> GetAttrsDiz()
Public Function GetAttrsDiz As Dictionary(Of String, Object)
public:
Dictionary<String^, Object^>^ GetAttrsDiz()
member GetAttrsDiz : unit -> Dictionary<string, Object>

Valore di ritorno

Dictionary String, Object
Vedi anche

Documentazione

Classe BomItem
Namespace DedNet.Core


Metodo BomItem.GetBomItemCad

Metodo BomItemGetBomItemCad
Restituisce il BomItem costruito con i valori originali Cad

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItem GetBomItemCad()
Public Function GetBomItemCad As BomItem
public:
BomItem^ GetBomItemCad()
member GetBomItemCad : unit -> BomItem

Valore di ritorno

BomItem
Vedi anche

Documentazione

Classe BomItem
Namespace DedNet.Core


Metodo BomItem.GetHashCode

Metodo BomItemGetHashCode
Vengono riconosciuti uguali gli elementi che hanno tutti i campi uguali tranne QTA che non concorre come discriminante.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Int32
L'hashcode di questo oggetto.
Vedi anche

Documentazione

Classe BomItem
Namespace DedNet.Core


Metodo BomItem.GetHashString

Metodo BomItemGetHashString

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string GetHashString()
Public Function GetHashString As String
public:
String^ GetHashString()
member GetHashString : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe BomItem
Namespace DedNet.Core


Metodo BomItem.GetValue

Metodo BomItemGetValue
Restituisce il valore dell'attributo di distinta specificato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object GetValue(
    string attrName
)
Public Function GetValue (
    attrName As String
) As Object
public:
Object^ GetValue(
    String^ attrName
)
member GetValue :
        attrName : string -> Object

Parametri

attrName String
Nome dell'attributo.

Valore di ritorno

Object
Restituisce il valore richisto oppure null se non lo trova.
Vedi anche

Documentazione

Classe BomItem
Namespace DedNet.Core


Metodo BomItem.SetDizOrigCadVal

Metodo BomItemSetDizOrigCadVal
Metodo per impostare nell'oggetto i valori letti dalla stringa del database. Splitta la stringa nella coppia attributo-valore e la mette nel dizionario interno.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetDizOrigCadVal(
    string str
)
Public Sub SetDizOrigCadVal (
    str As String
)
public:
void SetDizOrigCadVal(
    String^ str
)
member SetDizOrigCadVal :
        str : string -> unit

Parametri

str String
Vedi anche

Documentazione

Classe BomItem
Namespace DedNet.Core


Metodo BomItem.SetOrigCadValue

Metodo BomItemSetOrigCadValue
Metodo per impostare nel BomItem i vecchio valori CAD. Rende Dirty l'oggetto se necessario.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetOrigCadValue(
    string attrName,
    Object value
)
Public Sub SetOrigCadValue (
    attrName As String,
    value As Object
)
public:
void SetOrigCadValue(
    String^ attrName,
    Object^ value
)
member SetOrigCadValue :
        attrName : string *
        value : Object -> unit

Parametri

attrName String
Nome attributo
value Object
Vecchio valore
Vedi anche

Documentazione

Classe BomItem
Namespace DedNet.Core


Metodo BomItem.SetValue

Metodo BomItemSetValue
Imposta il valore dell'attributo di distinta specificato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool SetValue(
    string attrName,
    Object attrValue
)
Public Function SetValue (
    attrName As String,
    attrValue As Object
) As Boolean
public:
bool SetValue(
    String^ attrName,
    Object^ attrValue
)
member SetValue :
        attrName : string *
        attrValue : Object -> bool

Parametri

attrName String
Nome dell'attributo.
attrValue Object
Valore da impostare (deve essere coerente con il tipo dati dell'attributo).

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe BomItem
Namespace DedNet.Core


Metodo BomItem.ToString

Metodo BomItemToString

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe BomItem
Namespace DedNet.Core


Metodo BomItem.UpdateItemAnagr

Metodo BomItemUpdateItemAnagr
Aggiorna l'anagrafica dell'item se non è in ultima revisione e mette a dirty la distinta

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool UpdateItemAnagr()
Public Function UpdateItemAnagr As Boolean
public:
bool UpdateItemAnagr()
member UpdateItemAnagr : unit -> bool

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe BomItem
Namespace DedNet.Core


Classe BomItemCollection
Collezione di oggetti BomItem.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedDbCollectionBase BomItem
DedNet.CoreBomItemCollection

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class BomItemCollection : DedDbCollectionBase<BomItem>
Public Class BomItemCollection
    Inherits DedDbCollectionBase(Of BomItem)
public ref class BomItemCollection : public DedDbCollectionBase<BomItem^>
type BomItemCollection =
    class
        inherit DedDbCollectionBase<BomItem>
    end

Il tipo BomItemCollection espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllowEdit | Indica se la collezione è editabile
Proprietà pubblica | AllowsDuplicates | Restituisce se siano ammessi duplicati all'interno della lista. Se false viene sollevata una eccezione su tentativo di inserimento duplicati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Anagr | Restituisce l'anagrafica del codice padre della distinta.
Proprietà pubblica | Application | Restituisce l'oggetto applicazione di appartenza. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | BomItemParent | BomItem che rappresenta se stesso come figlio di distinta. Se è compilato significa che questa Collection è derivata da una collezione di livello superiore, altrimenti se è null significa che questa è la collection radice.
Proprietà pubblica | Count | Restituisce il numero di elementi presenti. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | DedIdParent | Restituisce il DedId del codice padre di questa distinta.
Proprietà pubblica | DedRevParent | Restituisce il DedRev del codice padre di questa distinta.
Proprietà pubblica | Dirty | Restituisce se la collezione o uno dei suoi elementi sia stata modificata. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | DiscrimParent | Restituisce il Discriminante del codice padre di questa distinta.
Proprietà pubblica | ErasedItems | Restitusice la lista in sola lettura degli elementi che risultano attualmente cancellati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | FakeCollection | Indica se è una collection fake
Proprietà pubblica | Header | Restituisce l'header di questa distinta. Restituisce null se si tratta di una distinta "orfana".
Proprietà pubblica | IsImpl | Restituisce se si tratti di distinta implosa.
Proprietà pubblica | LastItem | Restituisce l'ultimo elemento della collezione oppure null se non ci sono elementi. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Owner | Restituisce il DistManager di appartenenza.
Proprietà pubblica | QueryDate | Restituisce la data di creazione con la quale è stata effettuata la query per ottenere questa distinta.
Proprietà pubblica | RestoreErased | Restituisce se gli elementi cancellati devono essere ripristinati in caso vengano riaggiunti. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | UseHashStringCache | Indica se utilizzare o meno la cache per memorizzare i valori dell'hashstring per evitare di ricalcolarselo sempre
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Add(String, String, BomItemManEnum, IDedData) | Aggiunge un nuovo elemento alla collezione. Verifica se esista già un altro elemento con stesse caratteristiche, nel caso viene sollevata una eccezione. Se viene aggiunto un elemento non presente in anagrafica, al salvataggio della distinta verrà chiamato l'evento DistItemCreateData per avere informazioni sull'anagrafica da creare abbinata all'elemento. Viene anche effettuato il controllo che l'elemento non esista nei padri e che il padre non esista nei suoi figli.
Metodo pubblico | Add(String, String, BomItemManEnum, DictionaryString, Object) | Aggiunge un nuovo elemento alla collezione. Verifica se esista già un altro elemento con stesse caratteristiche, nel caso viene sollevata una eccezione. Se viene aggiunto un elemento non presente in anagrafica, al salvataggio della distinta verrà chiamato l'evento DistItemCreateData per avere informazioni sull'anagrafica da creare abbinata all'elemento. Viene anche effettuato il controllo che l'elemento non esista nei padri e che il padre non esista nei suoi figli.
Metodo pubblico | Add(String, String, BomItemManEnum, IDedData, DictionaryString, Object) | Aggiunge un nuovo elemento alla collezione. Verifica se esista già un altro elemento con stesse caratteristiche, nel caso viene sollevata una eccezione. Se viene aggiunto un elemento non presente in anagrafica, al salvataggio della distinta verrà chiamato l'evento DistItemCreateData per avere informazioni sull'anagrafica da creare abbinata all'elemento. Viene anche effettuato il controllo che l'elemento non esista nei padri e che il padre non esista nei suoi figli.
Metodo pubblico | Add(String, String, String, BomItemManEnum, DictionaryString, Object) | Aggiunge un nuovo elemento alla collezione. Verifica se esista già un altro elemento con stesse caratteristiche, nel caso viene sollevata una eccezione. Se viene aggiunto un elemento non presente in anagrafica, al salvataggio della distinta verrà chiamato l'evento DistItemCreateData per avere informazioni sull'anagrafica da creare abbinata all'elemento. Viene anche effettuato il controllo che l'elemento non esista nei padri e che il padre non esista nei suoi figli.
Metodo pubblico | Add(String, String, String, BomItemManEnum, IDedData, DictionaryString, Object) | Aggiunge un nuovo elemento alla collezione. Verifica se esista già un altro elemento con stesse caratteristiche, nel caso viene sollevata una eccezione. Se viene aggiunto un elemento non presente in anagrafica, al salvataggio della distinta verrà chiamato l'evento DistItemCreateData per avere informazioni sull'anagrafica da creare abbinata all'elemento. Viene anche effettuato il controllo che l'elemento non esista nei padri e che il padre non esista nei suoi figli.
Metodo protetto | AddForClone | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto SENZA MODIFICARNE LO STATO. Le classi derivate potranno utilizzare questo metodo per clonare la collezione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddNewElement | DI USO INTERNO. Aggiunge un elemento alla lista rendendo dirty l'oggetto. L'elemento viene aggiunto con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere un elemento alla lista. Dovranno loro stesse avere un metodo pubblico Add() che prenda i parametri necessari alla costruzione dell'oggetto. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | AddPhantom(BomItem) | Aggiunge un nuovo elemento alla collezione
Metodo pubblico | AddPhantom(String, String, String, BomItemManEnum, IDedData, DictionaryString, Object) | Aggiunge un nuovo elemento alla collezione
Metodo protetto | AddRangeNewElement | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi rendendo dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere più elementi alla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddUnModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Clear | Elimina tutti gli elementi dalla lista. (Sovrascrive DedDbCollectionBaseTClear)
Metodo pubblico | Clear(BomItemManEnum) | Elimina tutti gli elementi di una determinata tipologia.
Metodo pubblico | Clear(Boolean) | Aggiunto overload del clear che consente di ignorare lo stato nell'eventuale lock
Metodo protetto | ClearRefresh | Svuota la lista impostando Dirty = false. Di fatto permette di effettuare un refresh della lista e quindi di ricaricarla. Serve per svuotare la lista e reinizializzarla da capo. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | CompareAllWithQta | Confronto degli elementi considerando anche il campo qta
Metodo pubblico | CompareOnlyIdRev | Confronto elementi con soli dati anagrafici
Metodo pubblico | Contains | Verifica l'esistenza di un valore all'interno della lista degli elementi. Le classi derivate devono effettuarne l'override nel caso in cui l'elemento non implementi GetHashCode() per l'uso all'interno dei dizionarii. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | CopyTo | Copia un range di elementi in un array. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | CountByType | Restituisce il numero di elementi di una particolare tipologia.
Metodo protetto | CreateDeleteCommand | Crea, inizializza e restituisce il comando per l'eliminazione di un elemento. (Sovrascrive DedDbCollectionBaseTCreateDeleteCommand(T))
Metodo protetto | CreateInsertCommand | Crea, inizializza e restituisce il comando per l'inserimento di un elemento. (Sovrascrive DedDbCollectionBaseTCreateInsertCommand(T))
Metodo protetto | CreateUpdateCommand | Aggiorna la data di validità di un elemento alla data di lock dell'header di questa distinta. Di fatto lo si "fa scadere" per cancellarlo o per inserire la sua copia modificata. (Sovrascrive DedDbCollectionBaseTCreateUpdateCommand(T))
Metodo pubblico | CustomSort | Ordina la lista in base al comparatore passato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | DiscardChanges | Ricarica dal Database questa distinta scaricando eventuali modifiche effettuate e sbloccando l'header di questa distinta.
Metodo pubblico | Equals | Verifica l'uguaglianza di un oggetto con questo. (Sovrascrive ObjectEquals(Object))
Metodo protetto | ExecuteDeleteItem | Esegue l'eliminazione di un elemento. In realtà imposta la data di validità alla data attuale in modo da eliminarlo dall'ultima revisione della distinta, data che sarà utilizzata per creare il nuovo header. (Sovrascrive DedDbCollectionBaseTExecuteDeleteItem(T))
Metodo protetto | ExecuteInsertItem | Esegue l'inserimento di un elemento. Lo utilizzo per lanciare l'evento di richiesta dati di anagrafica nel caso in cui questa non sia presente nel Database. (Sovrascrive DedDbCollectionBaseTExecuteInsertItem(T))
Metodo protetto | ExecuteUpdateItem | In realtà imposta la data di validità alla data attuale in modo da eliminarlo dall'ultima revisione della distinta, e ne aggiunge un altro, nuovo con i nuovi dati modificati. (Sovrascrive DedDbCollectionBaseTExecuteUpdateItem(T))
Metodo pubblico | Find | Restituisce l'oggetto cercato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FindAll | Restitusice la lista degli elementi che corrispondono al predicato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FindByType | Restituisce gli elementi di una particolare tipologia.
Metodo protetto | GetDbIndex | Restituisce l'indice dell'elemento passato, da utilizzare nelle clausole where di aggiornamento/eliminazione. (Sovrascrive DedDbCollectionBaseTGetDbIndex(T))
Metodo pubblico | GetEnumerator | Restituisce l'enumeratore della collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | GetHashCode | Vengono riconosciuti uguali gli elementi che hanno DedIdParent, DedRevParent e QueryDate uguali. (Sovrascrive ObjectGetHashCode)
Metodo pubblico | GetItemsByIdRev | Restituisce una lista con tutti i BomItem relativi all'ID e REV passate
Metodo pubblico | IndexOf | Restituisce l'indice dell'elemento richiesto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InsertUnModified | DI USO INTERNO. Inserisce un elemento alla lista senza rendere dirty l'oggetto, all'indice specificato. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Item | Restituisce l'elemento iesimo della lista. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean) | Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean, Int32) | Sposta l'elemento dell'indice passato prima o dopo del numero di posizioni passate. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSave | Sblocca l'header salvando le modifiche. (Sovrascrive DedDbCollectionBaseTOnAfterSave(ListT, ListT, ListT))
Metodo protetto | OnAfterSaveNoChanges | Sblocca l'header. (Sovrascrive DedDbCollectionBaseTOnAfterSaveNoChanges)
Metodo protetto | OnBeforeSave | Metodo Template chiamato prima del salvataggio. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(T) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(DedEditableObjectT) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(T) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(DedEditableObjectT) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ReInitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Remove | Elimina un elemento dalla collezione. (Sovrascrive DedDbCollectionBaseTRemove(T))
Metodo pubblico | Replace(DedData, DedData, BomItemManEnum, Boolean, Boolean) | Sostituisce un elemento nella collezione con tutti quelli che hanno come anagrafica dataOrig. Come sopra, controlla i riferimenti circolari e possibili anomalie nella richiesta. Se tutti i controlli vanno a buon fine inserisce il nuovo elemento copiando dall'originale la posizione e tutti gli attributi di distinta.
Metodo pubblico | Replace(DedData, DedData, BomItemManEnum, DictionaryString, Object, Boolean, Boolean) | Sostituisce un elemento nella collezione con tutti quelli che hanno come anagrafica dataOrig e con gli attributi di distinta uguali ai valori passanti in searchDiscrimValues. Come sopra, controlla i riferimenti circolari e possibili anomalie nella richiesta. Se tutti i controlli vanno a buon fine inserisce il nuovo elemento copiando dall'originale la posizione e tutti gli attributi di distinta.
Metodo pubblico | Replace(DedData, DedData, BomItemManEnum, BomItemManEnum, DictionaryString, Object, Boolean, Boolean) | Sostituisce un elemento nella collezione con tutti quelli che hanno come anagrafica dataOrig e con gli attributi di distinta uguali ai valori passanti in searchDiscrimValues. Come sopra, controlla i riferimenti circolari e possibili anomalie nella richiesta. Se tutti i controlli vanno a buon fine inserisce il nuovo elemento copiando dall'originale la posizione e tutti gli attributi di distinta.
Metodo pubblico | Ripristina | Verifica che l'elemento sia presente negli eliminati e lo toglie da lì e lo riaggiunge in coda alla lista degli elementi validi. Solleva una eccezione se l'elemento è già presente nella lista e AllowsDuplicates = false. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Save | Salva le modifiche della collezione e dell'header corrispondente. (Sovrascrive DedDbCollectionBaseTSave)
Metodo pubblico | ToString | Restituisce una rappresentazione stringa di questo oggetto. (Sovrascrive ObjectToString)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di BomItemCollection

Il tipo BomItemCollection espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllowEdit | Indica se la collezione è editabile
Proprietà pubblica | AllowsDuplicates | Restituisce se siano ammessi duplicati all'interno della lista. Se false viene sollevata una eccezione su tentativo di inserimento duplicati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Anagr | Restituisce l'anagrafica del codice padre della distinta.
Proprietà pubblica | Application | Restituisce l'oggetto applicazione di appartenza. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | BomItemParent | BomItem che rappresenta se stesso come figlio di distinta. Se è compilato significa che questa Collection è derivata da una collezione di livello superiore, altrimenti se è null significa che questa è la collection radice.
Proprietà pubblica | Count | Restituisce il numero di elementi presenti. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | DedIdParent | Restituisce il DedId del codice padre di questa distinta.
Proprietà pubblica | DedRevParent | Restituisce il DedRev del codice padre di questa distinta.
Proprietà pubblica | Dirty | Restituisce se la collezione o uno dei suoi elementi sia stata modificata. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | DiscrimParent | Restituisce il Discriminante del codice padre di questa distinta.
Proprietà pubblica | ErasedItems | Restitusice la lista in sola lettura degli elementi che risultano attualmente cancellati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | FakeCollection | Indica se è una collection fake
Proprietà pubblica | Header | Restituisce l'header di questa distinta. Restituisce null se si tratta di una distinta "orfana".
Proprietà pubblica | IsImpl | Restituisce se si tratti di distinta implosa.
Proprietà pubblica | LastItem | Restituisce l'ultimo elemento della collezione oppure null se non ci sono elementi. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Owner | Restituisce il DistManager di appartenenza.
Proprietà pubblica | QueryDate | Restituisce la data di creazione con la quale è stata effettuata la query per ottenere questa distinta.
Proprietà pubblica | RestoreErased | Restituisce se gli elementi cancellati devono essere ripristinati in caso vengano riaggiunti. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | UseHashStringCache | Indica se utilizzare o meno la cache per memorizzare i valori dell'hashstring per evitare di ricalcolarselo sempre
Torna su
Vedi anche

Documentazione

Classe BomItemCollection
Namespace DedNet.Core


Proprietà BomItemCollection.AllowEdit

Proprietà BomItemCollectionAllowEdit
Indica se la collezione è editabile

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AllowEdit { get; }
Public ReadOnly Property AllowEdit As Boolean
    Get
public:
property bool AllowEdit {
    bool get ();
}
member AllowEdit : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe BomItemCollection
Namespace DedNet.Core


Proprietà BomItemCollection.Anagr

Proprietà BomItemCollectionAnagr
Restituisce l'anagrafica del codice padre della distinta.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Anagr { get; }
Public ReadOnly Property Anagr As DedData
    Get
public:
property DedData^ Anagr {
    DedData^ get ();
}
member Anagr : DedData with get

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe BomItemCollection
Namespace DedNet.Core


Proprietà BomItemCollection.BomItemParent

Proprietà BomItemCollectionBomItemParent
BomItem che rappresenta se stesso come figlio di distinta. Se è compilato significa che questa Collection è derivata da una collezione di livello superiore, altrimenti se è null significa che questa è la collection radice.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItem BomItemParent { get; set; }
Public Property BomItemParent As BomItem
    Get
    Set
public:
property BomItem^ BomItemParent {
    BomItem^ get ();
    void set (BomItem^ value);
}
member BomItemParent : BomItem with get, set

Valore della proprietà

BomItem
Vedi anche

Documentazione

Classe BomItemCollection
Namespace DedNet.Core


Proprietà BomItemCollection.DedIdParent

Proprietà BomItemCollectionDedIdParent
Restituisce il DedId del codice padre di questa distinta.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string DedIdParent { get; }
Public ReadOnly Property DedIdParent As String
    Get
public:
property String^ DedIdParent {
    String^ get ();
}
member DedIdParent : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe BomItemCollection
Namespace DedNet.Core


Proprietà BomItemCollection.DedRevParent

Proprietà BomItemCollectionDedRevParent
Restituisce il DedRev del codice padre di questa distinta.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string DedRevParent { get; }
Public ReadOnly Property DedRevParent As String
    Get
public:
property String^ DedRevParent {
    String^ get ();
}
member DedRevParent : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe BomItemCollection
Namespace DedNet.Core


Proprietà BomItemCollection.DiscrimParent

Proprietà BomItemCollectionDiscrimParent
Restituisce il Discriminante del codice padre di questa distinta.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string DiscrimParent { get; }
Public ReadOnly Property DiscrimParent As String
    Get
public:
property String^ DiscrimParent {
    String^ get ();
}
member DiscrimParent : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe BomItemCollection
Namespace DedNet.Core


Proprietà BomItemCollection.FakeCollection

Proprietà BomItemCollectionFakeCollection
Indica se è una collection fake

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool FakeCollection { get; set; }
Public Property FakeCollection As Boolean
    Get
    Set
public:
property bool FakeCollection {
    bool get ();
    void set (bool value);
}
member FakeCollection : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe BomItemCollection
Namespace DedNet.Core


Proprietà BomItemCollection.Header

Proprietà BomItemCollectionHeader
Restituisce l'header di questa distinta. Restituisce null se si tratta di una distinta "orfana".

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DistHeader Header { get; }
Public ReadOnly Property Header As DistHeader
    Get
public:
property DistHeader^ Header {
    DistHeader^ get ();
}
member Header : DistHeader with get

Valore della proprietà

DistHeader
Vedi anche

Documentazione

Classe BomItemCollection
Namespace DedNet.Core


Proprietà BomItemCollection.IsImpl

Proprietà BomItemCollectionIsImpl
Restituisce se si tratti di distinta implosa.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsImpl { get; }
Public ReadOnly Property IsImpl As Boolean
    Get
public:
property bool IsImpl {
    bool get ();
}
member IsImpl : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe BomItemCollection
Namespace DedNet.Core


Proprietà BomItemCollection.Owner

Proprietà BomItemCollectionOwner
Restituisce il DistManager di appartenenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DistManager Owner { get; }
Public ReadOnly Property Owner As DistManager
    Get
public:
property DistManager^ Owner {
    DistManager^ get ();
}
member Owner : DistManager with get

Valore della proprietà

DistManager
Vedi anche

Documentazione

Classe BomItemCollection
Namespace DedNet.Core


Proprietà BomItemCollection.QueryDate

Proprietà BomItemCollectionQueryDate
Restituisce la data di creazione con la quale è stata effettuata la query per ottenere questa distinta.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DateTime? QueryDate { get; }
Public ReadOnly Property QueryDate As DateTime?
    Get
public:
property Nullable<DateTime> QueryDate {
    Nullable<DateTime> get ();
}
member QueryDate : Nullable<DateTime> with get

Valore della proprietà

Nullable DateTime
Vedi anche

Documentazione

Classe BomItemCollection
Namespace DedNet.Core


Proprietà BomItemCollection.UseHashStringCache

Proprietà BomItemCollectionUseHashStringCache
Indica se utilizzare o meno la cache per memorizzare i valori dell'hashstring per evitare di ricalcolarselo sempre

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool UseHashStringCache { get; set; }
Public Property UseHashStringCache As Boolean
    Get
    Set
public:
property bool UseHashStringCache {
    bool get ();
    void set (bool value);
}
member UseHashStringCache : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe BomItemCollection
Namespace DedNet.Core


Metodi di BomItemCollection

Il tipo BomItemCollection espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Add(String, String, BomItemManEnum, IDedData) | Aggiunge un nuovo elemento alla collezione. Verifica se esista già un altro elemento con stesse caratteristiche, nel caso viene sollevata una eccezione. Se viene aggiunto un elemento non presente in anagrafica, al salvataggio della distinta verrà chiamato l'evento DistItemCreateData per avere informazioni sull'anagrafica da creare abbinata all'elemento. Viene anche effettuato il controllo che l'elemento non esista nei padri e che il padre non esista nei suoi figli.
Metodo pubblico | Add(String, String, BomItemManEnum, DictionaryString, Object) | Aggiunge un nuovo elemento alla collezione. Verifica se esista già un altro elemento con stesse caratteristiche, nel caso viene sollevata una eccezione. Se viene aggiunto un elemento non presente in anagrafica, al salvataggio della distinta verrà chiamato l'evento DistItemCreateData per avere informazioni sull'anagrafica da creare abbinata all'elemento. Viene anche effettuato il controllo che l'elemento non esista nei padri e che il padre non esista nei suoi figli.
Metodo pubblico | Add(String, String, BomItemManEnum, IDedData, DictionaryString, Object) | Aggiunge un nuovo elemento alla collezione. Verifica se esista già un altro elemento con stesse caratteristiche, nel caso viene sollevata una eccezione. Se viene aggiunto un elemento non presente in anagrafica, al salvataggio della distinta verrà chiamato l'evento DistItemCreateData per avere informazioni sull'anagrafica da creare abbinata all'elemento. Viene anche effettuato il controllo che l'elemento non esista nei padri e che il padre non esista nei suoi figli.
Metodo pubblico | Add(String, String, String, BomItemManEnum, DictionaryString, Object) | Aggiunge un nuovo elemento alla collezione. Verifica se esista già un altro elemento con stesse caratteristiche, nel caso viene sollevata una eccezione. Se viene aggiunto un elemento non presente in anagrafica, al salvataggio della distinta verrà chiamato l'evento DistItemCreateData per avere informazioni sull'anagrafica da creare abbinata all'elemento. Viene anche effettuato il controllo che l'elemento non esista nei padri e che il padre non esista nei suoi figli.
Metodo pubblico | Add(String, String, String, BomItemManEnum, IDedData, DictionaryString, Object) | Aggiunge un nuovo elemento alla collezione. Verifica se esista già un altro elemento con stesse caratteristiche, nel caso viene sollevata una eccezione. Se viene aggiunto un elemento non presente in anagrafica, al salvataggio della distinta verrà chiamato l'evento DistItemCreateData per avere informazioni sull'anagrafica da creare abbinata all'elemento. Viene anche effettuato il controllo che l'elemento non esista nei padri e che il padre non esista nei suoi figli.
Metodo protetto | AddForClone | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto SENZA MODIFICARNE LO STATO. Le classi derivate potranno utilizzare questo metodo per clonare la collezione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddNewElement | DI USO INTERNO. Aggiunge un elemento alla lista rendendo dirty l'oggetto. L'elemento viene aggiunto con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere un elemento alla lista. Dovranno loro stesse avere un metodo pubblico Add() che prenda i parametri necessari alla costruzione dell'oggetto. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | AddPhantom(BomItem) | Aggiunge un nuovo elemento alla collezione
Metodo pubblico | AddPhantom(String, String, String, BomItemManEnum, IDedData, DictionaryString, Object) | Aggiunge un nuovo elemento alla collezione
Metodo protetto | AddRangeNewElement | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi rendendo dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere più elementi alla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddUnModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Clear | Elimina tutti gli elementi dalla lista. (Sovrascrive DedDbCollectionBaseTClear)
Metodo pubblico | Clear(BomItemManEnum) | Elimina tutti gli elementi di una determinata tipologia.
Metodo pubblico | Clear(Boolean) | Aggiunto overload del clear che consente di ignorare lo stato nell'eventuale lock
Metodo protetto | ClearRefresh | Svuota la lista impostando Dirty = false. Di fatto permette di effettuare un refresh della lista e quindi di ricaricarla. Serve per svuotare la lista e reinizializzarla da capo. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | CompareAllWithQta | Confronto degli elementi considerando anche il campo qta
Metodo pubblico | CompareOnlyIdRev | Confronto elementi con soli dati anagrafici
Metodo pubblico | Contains | Verifica l'esistenza di un valore all'interno della lista degli elementi. Le classi derivate devono effettuarne l'override nel caso in cui l'elemento non implementi GetHashCode() per l'uso all'interno dei dizionarii. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | CopyTo | Copia un range di elementi in un array. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | CountByType | Restituisce il numero di elementi di una particolare tipologia.
Metodo protetto | CreateDeleteCommand | Crea, inizializza e restituisce il comando per l'eliminazione di un elemento. (Sovrascrive DedDbCollectionBaseTCreateDeleteCommand(T))
Metodo protetto | CreateInsertCommand | Crea, inizializza e restituisce il comando per l'inserimento di un elemento. (Sovrascrive DedDbCollectionBaseTCreateInsertCommand(T))
Metodo protetto | CreateUpdateCommand | Aggiorna la data di validità di un elemento alla data di lock dell'header di questa distinta. Di fatto lo si "fa scadere" per cancellarlo o per inserire la sua copia modificata. (Sovrascrive DedDbCollectionBaseTCreateUpdateCommand(T))
Metodo pubblico | CustomSort | Ordina la lista in base al comparatore passato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | DiscardChanges | Ricarica dal Database questa distinta scaricando eventuali modifiche effettuate e sbloccando l'header di questa distinta.
Metodo pubblico | Equals | Verifica l'uguaglianza di un oggetto con questo. (Sovrascrive ObjectEquals(Object))
Metodo protetto | ExecuteDeleteItem | Esegue l'eliminazione di un elemento. In realtà imposta la data di validità alla data attuale in modo da eliminarlo dall'ultima revisione della distinta, data che sarà utilizzata per creare il nuovo header. (Sovrascrive DedDbCollectionBaseTExecuteDeleteItem(T))
Metodo protetto | ExecuteInsertItem | Esegue l'inserimento di un elemento. Lo utilizzo per lanciare l'evento di richiesta dati di anagrafica nel caso in cui questa non sia presente nel Database. (Sovrascrive DedDbCollectionBaseTExecuteInsertItem(T))
Metodo protetto | ExecuteUpdateItem | In realtà imposta la data di validità alla data attuale in modo da eliminarlo dall'ultima revisione della distinta, e ne aggiunge un altro, nuovo con i nuovi dati modificati. (Sovrascrive DedDbCollectionBaseTExecuteUpdateItem(T))
Metodo pubblico | Find | Restituisce l'oggetto cercato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FindAll | Restitusice la lista degli elementi che corrispondono al predicato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FindByType | Restituisce gli elementi di una particolare tipologia.
Metodo protetto | GetDbIndex | Restituisce l'indice dell'elemento passato, da utilizzare nelle clausole where di aggiornamento/eliminazione. (Sovrascrive DedDbCollectionBaseTGetDbIndex(T))
Metodo pubblico | GetEnumerator | Restituisce l'enumeratore della collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | GetHashCode | Vengono riconosciuti uguali gli elementi che hanno DedIdParent, DedRevParent e QueryDate uguali. (Sovrascrive ObjectGetHashCode)
Metodo pubblico | GetItemsByIdRev | Restituisce una lista con tutti i BomItem relativi all'ID e REV passate
Metodo pubblico | IndexOf | Restituisce l'indice dell'elemento richiesto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InsertUnModified | DI USO INTERNO. Inserisce un elemento alla lista senza rendere dirty l'oggetto, all'indice specificato. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Item | Restituisce l'elemento iesimo della lista. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean) | Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean, Int32) | Sposta l'elemento dell'indice passato prima o dopo del numero di posizioni passate. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSave | Sblocca l'header salvando le modifiche. (Sovrascrive DedDbCollectionBaseTOnAfterSave(ListT, ListT, ListT))
Metodo protetto | OnAfterSaveNoChanges | Sblocca l'header. (Sovrascrive DedDbCollectionBaseTOnAfterSaveNoChanges)
Metodo protetto | OnBeforeSave | Metodo Template chiamato prima del salvataggio. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(T) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(DedEditableObjectT) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(T) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(DedEditableObjectT) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ReInitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Remove | Elimina un elemento dalla collezione. (Sovrascrive DedDbCollectionBaseTRemove(T))
Metodo pubblico | Replace(DedData, DedData, BomItemManEnum, Boolean, Boolean) | Sostituisce un elemento nella collezione con tutti quelli che hanno come anagrafica dataOrig. Come sopra, controlla i riferimenti circolari e possibili anomalie nella richiesta. Se tutti i controlli vanno a buon fine inserisce il nuovo elemento copiando dall'originale la posizione e tutti gli attributi di distinta.
Metodo pubblico | Replace(DedData, DedData, BomItemManEnum, DictionaryString, Object, Boolean, Boolean) | Sostituisce un elemento nella collezione con tutti quelli che hanno come anagrafica dataOrig e con gli attributi di distinta uguali ai valori passanti in searchDiscrimValues. Come sopra, controlla i riferimenti circolari e possibili anomalie nella richiesta. Se tutti i controlli vanno a buon fine inserisce il nuovo elemento copiando dall'originale la posizione e tutti gli attributi di distinta.
Metodo pubblico | Replace(DedData, DedData, BomItemManEnum, BomItemManEnum, DictionaryString, Object, Boolean, Boolean) | Sostituisce un elemento nella collezione con tutti quelli che hanno come anagrafica dataOrig e con gli attributi di distinta uguali ai valori passanti in searchDiscrimValues. Come sopra, controlla i riferimenti circolari e possibili anomalie nella richiesta. Se tutti i controlli vanno a buon fine inserisce il nuovo elemento copiando dall'originale la posizione e tutti gli attributi di distinta.
Metodo pubblico | Ripristina | Verifica che l'elemento sia presente negli eliminati e lo toglie da lì e lo riaggiunge in coda alla lista degli elementi validi. Solleva una eccezione se l'elemento è già presente nella lista e AllowsDuplicates = false. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Save | Salva le modifiche della collezione e dell'header corrispondente. (Sovrascrive DedDbCollectionBaseTSave)
Metodo pubblico | ToString | Restituisce una rappresentazione stringa di questo oggetto. (Sovrascrive ObjectToString)
Torna su
Vedi anche

Documentazione

Classe BomItemCollection
Namespace DedNet.Core


Metodo BomItemCollection.Add

Metodo BomItemCollectionAdd
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Add(String, String, BomItemManEnum, IDedData) | Aggiunge un nuovo elemento alla collezione. Verifica se esista già un altro elemento con stesse caratteristiche, nel caso viene sollevata una eccezione. Se viene aggiunto un elemento non presente in anagrafica, al salvataggio della distinta verrà chiamato l'evento DistItemCreateData per avere informazioni sull'anagrafica da creare abbinata all'elemento. Viene anche effettuato il controllo che l'elemento non esista nei padri e che il padre non esista nei suoi figli.
Metodo pubblico | Add(String, String, BomItemManEnum, DictionaryString, Object) | Aggiunge un nuovo elemento alla collezione. Verifica se esista già un altro elemento con stesse caratteristiche, nel caso viene sollevata una eccezione. Se viene aggiunto un elemento non presente in anagrafica, al salvataggio della distinta verrà chiamato l'evento DistItemCreateData per avere informazioni sull'anagrafica da creare abbinata all'elemento. Viene anche effettuato il controllo che l'elemento non esista nei padri e che il padre non esista nei suoi figli.
Metodo pubblico | Add(String, String, BomItemManEnum, IDedData, DictionaryString, Object) | Aggiunge un nuovo elemento alla collezione. Verifica se esista già un altro elemento con stesse caratteristiche, nel caso viene sollevata una eccezione. Se viene aggiunto un elemento non presente in anagrafica, al salvataggio della distinta verrà chiamato l'evento DistItemCreateData per avere informazioni sull'anagrafica da creare abbinata all'elemento. Viene anche effettuato il controllo che l'elemento non esista nei padri e che il padre non esista nei suoi figli.
Metodo pubblico | Add(String, String, String, BomItemManEnum, DictionaryString, Object) | Aggiunge un nuovo elemento alla collezione. Verifica se esista già un altro elemento con stesse caratteristiche, nel caso viene sollevata una eccezione. Se viene aggiunto un elemento non presente in anagrafica, al salvataggio della distinta verrà chiamato l'evento DistItemCreateData per avere informazioni sull'anagrafica da creare abbinata all'elemento. Viene anche effettuato il controllo che l'elemento non esista nei padri e che il padre non esista nei suoi figli.
Metodo pubblico | Add(String, String, String, BomItemManEnum, IDedData, DictionaryString, Object) | Aggiunge un nuovo elemento alla collezione. Verifica se esista già un altro elemento con stesse caratteristiche, nel caso viene sollevata una eccezione. Se viene aggiunto un elemento non presente in anagrafica, al salvataggio della distinta verrà chiamato l'evento DistItemCreateData per avere informazioni sull'anagrafica da creare abbinata all'elemento. Viene anche effettuato il controllo che l'elemento non esista nei padri e che il padre non esista nei suoi figli.
Torna su
Vedi anche

Documentazione

Classe BomItemCollection
Namespace DedNet.Core


Metodo BomItemCollection.Add(String, String, BomItemManEnum, IDedData)

Metodo BomItemCollectionAdd(String, String, BomItemManEnum, IDedData)
Aggiunge un nuovo elemento alla collezione. Verifica se esista già un altro elemento con stesse caratteristiche, nel caso viene sollevata una eccezione. Se viene aggiunto un elemento non presente in anagrafica, al salvataggio della distinta verrà chiamato l'evento DistItemCreateData per avere informazioni sull'anagrafica da creare abbinata all'elemento. Viene anche effettuato il controllo che l'elemento non esista nei padri e che il padre non esista nei suoi figli.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItem Add(
    string dedidc,
    string dedrevc,
    BomItemManEnum man,
    IDedData data
)
Public Function Add (
    dedidc As String,
    dedrevc As String,
    man As BomItemManEnum,
    data As IDedData
) As BomItem
public:
BomItem^ Add(
    String^ dedidc,
    String^ dedrevc,
    BomItemManEnum man,
    IDedData^ data
)
member Add :
        dedidc : string *
        dedrevc : string *
        man : BomItemManEnum *
        data : IDedData -> BomItem

Parametri

dedidc String
DedID dell'elemento.
dedrevc String
DedRev dell'elemento.
man BomItemManEnum
Il tipo di inserimento attuato.
data IDedData
Informazioni aggiuntive da utilizzare nel caso in cui l'elemento sia da aggiungere in anagrafica perché attualmente non presente oppure oggetto DedData se il chiamante è già in possesso dell'anagrafica dell'elemento.

Valore di ritorno

BomItem
Restitusice l'elemento appena creato ed aggiunto.
Vedi anche

Documentazione

Classe BomItemCollection
Overload di Add
Namespace DedNet.Core


Metodo BomItemCollection.Add(String, String, BomItemManEnum, Dictionary<String, Object>)

Metodo BomItemCollectionAdd(String, String, BomItemManEnum, DictionaryString, Object)
Aggiunge un nuovo elemento alla collezione. Verifica se esista già un altro elemento con stesse caratteristiche, nel caso viene sollevata una eccezione. Se viene aggiunto un elemento non presente in anagrafica, al salvataggio della distinta verrà chiamato l'evento DistItemCreateData per avere informazioni sull'anagrafica da creare abbinata all'elemento. Viene anche effettuato il controllo che l'elemento non esista nei padri e che il padre non esista nei suoi figli.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItem Add(
    string dedidc,
    string dedrevc,
    BomItemManEnum man,
    Dictionary<string, Object> distAttrs
)
Public Function Add (
    dedidc As String,
    dedrevc As String,
    man As BomItemManEnum,
    distAttrs As Dictionary(Of String, Object)
) As BomItem
public:
BomItem^ Add(
    String^ dedidc,
    String^ dedrevc,
    BomItemManEnum man,
    Dictionary<String^, Object^>^ distAttrs
)
member Add :
        dedidc : string *
        dedrevc : string *
        man : BomItemManEnum *
        distAttrs : Dictionary<string, Object> -> BomItem

Parametri

dedidc String
DedID dell'elemento.
dedrevc String
DedRev dell'elemento.
man BomItemManEnum
Il tipo di inserimento attuato.
distAttrs Dictionary String, Object
Elenco attributi di distinta da settare sull'elemento

Valore di ritorno

BomItem
Restitusice l'elemento appena creato ed aggiunto.
Vedi anche

Documentazione

Classe BomItemCollection
Overload di Add
Namespace DedNet.Core


Metodo BomItemCollection.Add(String, String, BomItemManEnum, IDedData, Dictionary<String, Object>)

Metodo BomItemCollectionAdd(String, String, BomItemManEnum, IDedData, DictionaryString, Object)
Aggiunge un nuovo elemento alla collezione. Verifica se esista già un altro elemento con stesse caratteristiche, nel caso viene sollevata una eccezione. Se viene aggiunto un elemento non presente in anagrafica, al salvataggio della distinta verrà chiamato l'evento DistItemCreateData per avere informazioni sull'anagrafica da creare abbinata all'elemento. Viene anche effettuato il controllo che l'elemento non esista nei padri e che il padre non esista nei suoi figli.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItem Add(
    string dedidc,
    string dedrevc,
    BomItemManEnum man,
    IDedData data,
    Dictionary<string, Object> distAttrs
)
Public Function Add (
    dedidc As String,
    dedrevc As String,
    man As BomItemManEnum,
    data As IDedData,
    distAttrs As Dictionary(Of String, Object)
) As BomItem
public:
BomItem^ Add(
    String^ dedidc,
    String^ dedrevc,
    BomItemManEnum man,
    IDedData^ data,
    Dictionary<String^, Object^>^ distAttrs
)
member Add :
        dedidc : string *
        dedrevc : string *
        man : BomItemManEnum *
        data : IDedData *
        distAttrs : Dictionary<string, Object> -> BomItem

Parametri

dedidc String
DedID dell'elemento.
dedrevc String
DedRev dell'elemento.
man BomItemManEnum
Il tipo di inserimento attuato.
data IDedData
Informazioni aggiuntive da utilizzare nel caso in cui l'elemento sia da aggiungere in anagrafica perché attualmente non presente oppure oggetto DedData se il chiamante è già in possesso dell'anagrafica dell'elemento.
distAttrs Dictionary String, Object
Elenco attributi di distinta da settare sull'elemento

Valore di ritorno

BomItem
Restitusice l'elemento appena creato ed aggiunto.
Vedi anche

Documentazione

Classe BomItemCollection
Overload di Add
Namespace DedNet.Core


Metodo BomItemCollection.Add(String, String, String, BomItemManEnum, Dictionary<String, Object>)

Metodo BomItemCollectionAdd(String, String, String, BomItemManEnum, DictionaryString, Object)
Aggiunge un nuovo elemento alla collezione. Verifica se esista già un altro elemento con stesse caratteristiche, nel caso viene sollevata una eccezione. Se viene aggiunto un elemento non presente in anagrafica, al salvataggio della distinta verrà chiamato l'evento DistItemCreateData per avere informazioni sull'anagrafica da creare abbinata all'elemento. Viene anche effettuato il controllo che l'elemento non esista nei padri e che il padre non esista nei suoi figli.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItem Add(
    string dedidc,
    string dedrevc,
    string discrimc,
    BomItemManEnum man,
    Dictionary<string, Object> distAttrs
)
Public Function Add (
    dedidc As String,
    dedrevc As String,
    discrimc As String,
    man As BomItemManEnum,
    distAttrs As Dictionary(Of String, Object)
) As BomItem
public:
BomItem^ Add(
    String^ dedidc,
    String^ dedrevc,
    String^ discrimc,
    BomItemManEnum man,
    Dictionary<String^, Object^>^ distAttrs
)
member Add :
        dedidc : string *
        dedrevc : string *
        discrimc : string *
        man : BomItemManEnum *
        distAttrs : Dictionary<string, Object> -> BomItem

Parametri

dedidc String
DedID dell'elemento.
dedrevc String
DedRev dell'elemento.
discrimc String
Discriminante dell'elemento
man BomItemManEnum
Il tipo di inserimento attuato.
distAttrs Dictionary String, Object
Elenco attributi di distinta da settare sull'elemento

Valore di ritorno

BomItem
Restitusice l'elemento appena creato ed aggiunto.
Vedi anche

Documentazione

Classe BomItemCollection
Overload di Add
Namespace DedNet.Core


Metodo BomItemCollection.Add(String, String, String, BomItemManEnum, IDedData, Dictionary<String, Object>)

Metodo BomItemCollectionAdd(String, String, String, BomItemManEnum, IDedData, DictionaryString, Object)
Aggiunge un nuovo elemento alla collezione. Verifica se esista già un altro elemento con stesse caratteristiche, nel caso viene sollevata una eccezione. Se viene aggiunto un elemento non presente in anagrafica, al salvataggio della distinta verrà chiamato l'evento DistItemCreateData per avere informazioni sull'anagrafica da creare abbinata all'elemento. Viene anche effettuato il controllo che l'elemento non esista nei padri e che il padre non esista nei suoi figli.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItem Add(
    string dedidc,
    string dedrevc,
    string discrimc,
    BomItemManEnum man,
    IDedData data,
    Dictionary<string, Object> distAttrs
)
Public Function Add (
    dedidc As String,
    dedrevc As String,
    discrimc As String,
    man As BomItemManEnum,
    data As IDedData,
    distAttrs As Dictionary(Of String, Object)
) As BomItem
public:
BomItem^ Add(
    String^ dedidc,
    String^ dedrevc,
    String^ discrimc,
    BomItemManEnum man,
    IDedData^ data,
    Dictionary<String^, Object^>^ distAttrs
)
member Add :
        dedidc : string *
        dedrevc : string *
        discrimc : string *
        man : BomItemManEnum *
        data : IDedData *
        distAttrs : Dictionary<string, Object> -> BomItem

Parametri

dedidc String
DedID dell'elemento.
dedrevc String
DedRev dell'elemento.
discrimc String
Discriminante dell'elemento
man BomItemManEnum
Il tipo di inserimento attuato.
data IDedData
Informazioni aggiuntive da utilizzare nel caso in cui l'elemento sia da aggiungere in anagrafica perché attualmente non presente oppure oggetto DedData se il chiamante è già in possesso dell'anagrafica dell'elemento.
distAttrs Dictionary String, Object
Elenco attributi di distinta da settare sull'elemento

Valore di ritorno

BomItem
Restitusice l'elemento appena creato ed aggiunto.
Vedi anche

Documentazione

Classe BomItemCollection
Overload di Add
Namespace DedNet.Core


Metodo BomItemCollection.AddPhantom

Metodo BomItemCollectionAddPhantom
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AddPhantom(BomItem) | Aggiunge un nuovo elemento alla collezione
Metodo pubblico | AddPhantom(String, String, String, BomItemManEnum, IDedData, DictionaryString, Object) | Aggiunge un nuovo elemento alla collezione
Torna su
Vedi anche

Documentazione

Classe BomItemCollection
Namespace DedNet.Core


Metodo BomItemCollection.AddPhantom(BomItem)

Metodo BomItemCollectionAddPhantom(BomItem)
Aggiunge un nuovo elemento alla collezione

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItem AddPhantom(
    BomItem bi
)
Public Function AddPhantom (
    bi As BomItem
) As BomItem
public:
BomItem^ AddPhantom(
    BomItem^ bi
)
member AddPhantom :
        bi : BomItem -> BomItem

Parametri

bi BomItem
BomItem da aggiungere alla collezione

Valore di ritorno

BomItem
Restitusice l'elemento appena creato ed aggiunto.
Vedi anche

Documentazione

Classe BomItemCollection
Overload di AddPhantom
Namespace DedNet.Core


Metodo BomItemCollection.AddPhantom(String, String, String, BomItemManEnum, IDedData, Dictionary<String, Object>)

Metodo BomItemCollectionAddPhantom(String, String, String, BomItemManEnum, IDedData, DictionaryString, Object)
Aggiunge un nuovo elemento alla collezione

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItem AddPhantom(
    string dedidc,
    string dedrevc,
    string discrimc,
    BomItemManEnum man,
    IDedData data,
    Dictionary<string, Object> distAttrs
)
Public Function AddPhantom (
    dedidc As String,
    dedrevc As String,
    discrimc As String,
    man As BomItemManEnum,
    data As IDedData,
    distAttrs As Dictionary(Of String, Object)
) As BomItem
public:
BomItem^ AddPhantom(
    String^ dedidc,
    String^ dedrevc,
    String^ discrimc,
    BomItemManEnum man,
    IDedData^ data,
    Dictionary<String^, Object^>^ distAttrs
)
member AddPhantom :
        dedidc : string *
        dedrevc : string *
        discrimc : string *
        man : BomItemManEnum *
        data : IDedData *
        distAttrs : Dictionary<string, Object> -> BomItem

Parametri

dedidc String
DedID dell'elemento.
dedrevc String
DedRev dell'elemento.
discrimc String
Discriminante dell'elemento
man BomItemManEnum
Il tipo di inserimento attuato.
data IDedData
Informazioni aggiuntive da utilizzare nel caso in cui l'elemento sia da aggiungere in anagrafica perché attualmente non presente oppure oggetto DedData se il chiamante è già in possesso dell'anagrafica dell'elemento.
distAttrs Dictionary String, Object
Elenco attributi di distinta da settare sull'elemento

Valore di ritorno

BomItem
Restitusice l'elemento appena creato ed aggiunto.
Vedi anche

Documentazione

Classe BomItemCollection
Overload di AddPhantom
Namespace DedNet.Core


Metodo BomItemCollection.Clear

Metodo BomItemCollectionClear
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Clear | Elimina tutti gli elementi dalla lista.
Metodo pubblico | Clear(BomItemManEnum) | Elimina tutti gli elementi di una determinata tipologia.
Metodo pubblico | Clear(Boolean) | Aggiunto overload del clear che consente di ignorare lo stato nell'eventuale lock
Torna su
Vedi anche

Documentazione

Classe BomItemCollection
Namespace DedNet.Core


Metodo BomItemCollection.Clear

Metodo BomItemCollectionClear
Elimina tutti gli elementi dalla lista.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void Clear()
Public Overrides Sub Clear
public:
virtual void Clear() override
abstract Clear : unit -> unit
override Clear : unit -> unit
Vedi anche

Documentazione

Classe BomItemCollection
Overload di Clear
Namespace DedNet.Core


Metodo BomItemCollection.Clear(BomItemManEnum)

Metodo BomItemCollectionClear(BomItemManEnum)
Elimina tutti gli elementi di una determinata tipologia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Clear(
    BomItemManEnum elemType
)
Public Sub Clear (
    elemType As BomItemManEnum
)
public:
void Clear(
    BomItemManEnum elemType
)
member Clear :
        elemType : BomItemManEnum -> unit

Parametri

elemType BomItemManEnum
Tipologia da eliminare.
Vedi anche

Documentazione

Classe BomItemCollection
Overload di Clear
Namespace DedNet.Core


Metodo BomItemCollection.Clear(Boolean)

Metodo BomItemCollectionClear(Boolean)
Aggiunto overload del clear che consente di ignorare lo stato nell'eventuale lock

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Clear(
    bool ignoreState
)
Public Sub Clear (
    ignoreState As Boolean
)
public:
void Clear(
    bool ignoreState
)
member Clear :
        ignoreState : bool -> unit

Parametri

ignoreState Boolean
Vedi anche

Documentazione

Classe BomItemCollection
Overload di Clear
Namespace DedNet.Core


Metodo BomItemCollection.CompareAllWithQta

Metodo BomItemCollectionCompareAllWithQta
Confronto degli elementi considerando anche il campo qta

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CompareAllWithQta(
    BomItem item
)
Public Function CompareAllWithQta (
    item As BomItem
) As Boolean
public:
bool CompareAllWithQta(
    BomItem^ item
)
member CompareAllWithQta :
        item : BomItem -> bool

Parametri

item BomItem

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe BomItemCollection
Namespace DedNet.Core


Metodo BomItemCollection.CompareOnlyIdRev

Metodo BomItemCollectionCompareOnlyIdRev
Confronto elementi con soli dati anagrafici

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CompareOnlyIdRev(
    BomItem item
)
Public Function CompareOnlyIdRev (
    item As BomItem
) As Boolean
public:
bool CompareOnlyIdRev(
    BomItem^ item
)
member CompareOnlyIdRev :
        item : BomItem -> bool

Parametri

item BomItem

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe BomItemCollection
Namespace DedNet.Core


Metodo BomItemCollection.CountByType

Metodo BomItemCollectionCountByType
Restituisce il numero di elementi di una particolare tipologia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int CountByType(
    BomItemManEnum elemType
)
Public Function CountByType (
    elemType As BomItemManEnum
) As Integer
public:
int CountByType(
    BomItemManEnum elemType
)
member CountByType :
        elemType : BomItemManEnum -> int

Parametri

elemType BomItemManEnum
Tipologia da contare.

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe BomItemCollection
Namespace DedNet.Core


Metodo BomItemCollection.CreateDeleteCommand

Metodo BomItemCollectionCreateDeleteCommand
Crea, inizializza e restituisce il comando per l'eliminazione di un elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSDeleteCommand CreateDeleteCommand(
    BomItem item
)
Protected Overrides Function CreateDeleteCommand (
    item As BomItem
) As QSDeleteCommand
protected:
virtual QSDeleteCommand^ CreateDeleteCommand(
    BomItem^ item
) override
abstract CreateDeleteCommand :
        item : BomItem -> QSDeleteCommand
override CreateDeleteCommand :
        item : BomItem -> QSDeleteCommand

Parametri

item BomItem
Elemento da utilizzare per inizializzare il comando.

Valore di ritorno

QSDeleteCommand
Il comando inizializzato, pronto per essere eseguito.
Vedi anche

Documentazione

Classe BomItemCollection
Namespace DedNet.Core


Metodo BomItemCollection.CreateInsertCommand

Metodo BomItemCollectionCreateInsertCommand
Crea, inizializza e restituisce il comando per l'inserimento di un elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSInsertCommand CreateInsertCommand(
    BomItem item
)
Protected Overrides Function CreateInsertCommand (
    item As BomItem
) As QSInsertCommand
protected:
virtual QSInsertCommand^ CreateInsertCommand(
    BomItem^ item
) override
abstract CreateInsertCommand :
        item : BomItem -> QSInsertCommand
override CreateInsertCommand :
        item : BomItem -> QSInsertCommand

Parametri

item BomItem
Elemento da utilizzare per inizializzare il comando.

Valore di ritorno

QSInsertCommand
Il comando inizializzato, pronto per essere eseguito.
Vedi anche

Documentazione

Classe BomItemCollection
Namespace DedNet.Core


Metodo BomItemCollection.CreateUpdateCommand

Metodo BomItemCollectionCreateUpdateCommand
Aggiorna la data di validità di un elemento alla data di lock dell'header di questa distinta. Di fatto lo si "fa scadere" per cancellarlo o per inserire la sua copia modificata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSUpdateCommand CreateUpdateCommand(
    BomItem item
)
Protected Overrides Function CreateUpdateCommand (
    item As BomItem
) As QSUpdateCommand
protected:
virtual QSUpdateCommand^ CreateUpdateCommand(
    BomItem^ item
) override
abstract CreateUpdateCommand :
        item : BomItem -> QSUpdateCommand
override CreateUpdateCommand :
        item : BomItem -> QSUpdateCommand

Parametri

item BomItem
Elemento da aggiornare.

Valore di ritorno

QSUpdateCommand
Il comando inizializzato, pronto per essere eseguito.
Vedi anche

Documentazione

Classe BomItemCollection
Namespace DedNet.Core


Metodo BomItemCollection.DiscardChanges

Metodo BomItemCollectionDiscardChanges
Ricarica dal Database questa distinta scaricando eventuali modifiche effettuate e sbloccando l'header di questa distinta.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void DiscardChanges()
Public Sub DiscardChanges
public:
void DiscardChanges()
member DiscardChanges : unit -> unit
Vedi anche

Documentazione

Classe BomItemCollection
Namespace DedNet.Core


Metodo BomItemCollection.Equals

Metodo BomItemCollectionEquals
Verifica l'uguaglianza di un oggetto con questo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj Object
Oggetto da comparare.

Valore di ritorno

Boolean
Restituisce true se l'oggetto passato è uguale a questo altrimenti false.
Vedi anche

Documentazione

Classe BomItemCollection
Namespace DedNet.Core


Metodo BomItemCollection.ExecuteDeleteItem

Metodo BomItemCollectionExecuteDeleteItem
Esegue l'eliminazione di un elemento. In realtà imposta la data di validità alla data attuale in modo da eliminarlo dall'ultima revisione della distinta, data che sarà utilizzata per creare il nuovo header.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void ExecuteDeleteItem(
    BomItem item
)
Protected Overrides Sub ExecuteDeleteItem (
    item As BomItem
)
protected:
virtual void ExecuteDeleteItem(
    BomItem^ item
) override
abstract ExecuteDeleteItem :
        item : BomItem -> unit
override ExecuteDeleteItem :
        item : BomItem -> unit

Parametri

item BomItem
Elemento da eliminare.
Vedi anche

Documentazione

Classe BomItemCollection
Namespace DedNet.Core


Metodo BomItemCollection.ExecuteInsertItem

Metodo BomItemCollectionExecuteInsertItem
Esegue l'inserimento di un elemento. Lo utilizzo per lanciare l'evento di richiesta dati di anagrafica nel caso in cui questa non sia presente nel Database.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void ExecuteInsertItem(
    BomItem item
)
Protected Overrides Sub ExecuteInsertItem (
    item As BomItem
)
protected:
virtual void ExecuteInsertItem(
    BomItem^ item
) override
abstract ExecuteInsertItem :
        item : BomItem -> unit
override ExecuteInsertItem :
        item : BomItem -> unit

Parametri

item BomItem
Elemento da aggiungere.
Vedi anche

Documentazione

Classe BomItemCollection
Namespace DedNet.Core


Metodo BomItemCollection.ExecuteUpdateItem

Metodo BomItemCollectionExecuteUpdateItem
In realtà imposta la data di validità alla data attuale in modo da eliminarlo dall'ultima revisione della distinta, e ne aggiunge un altro, nuovo con i nuovi dati modificati.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void ExecuteUpdateItem(
    BomItem item
)
Protected Overrides Sub ExecuteUpdateItem (
    item As BomItem
)
protected:
virtual void ExecuteUpdateItem(
    BomItem^ item
) override
abstract ExecuteUpdateItem :
        item : BomItem -> unit
override ExecuteUpdateItem :
        item : BomItem -> unit

Parametri

item BomItem
Elemento da eliminare.
Vedi anche

Documentazione

Classe BomItemCollection
Namespace DedNet.Core


Metodo BomItemCollection.FindByType

Metodo BomItemCollectionFindByType
Restituisce gli elementi di una particolare tipologia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<BomItem> FindByType(
    BomItemManEnum elemType
)
Public Function FindByType (
    elemType As BomItemManEnum
) As List(Of BomItem)
public:
List<BomItem^>^ FindByType(
    BomItemManEnum elemType
)
member FindByType :
        elemType : BomItemManEnum -> List<BomItem>

Parametri

elemType BomItemManEnum
Tipologia da trovare.

Valore di ritorno

List BomItem
Vedi anche

Documentazione

Classe BomItemCollection
Namespace DedNet.Core


Metodo BomItemCollection.GetDbIndex

Metodo BomItemCollectionGetDbIndex
Restituisce l'indice dell'elemento passato, da utilizzare nelle clausole where di aggiornamento/eliminazione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override Object GetDbIndex(
    BomItem item
)
Protected Overrides Function GetDbIndex (
    item As BomItem
) As Object
protected:
virtual Object^ GetDbIndex(
    BomItem^ item
) override
abstract GetDbIndex :
        item : BomItem -> Object
override GetDbIndex :
        item : BomItem -> Object

Parametri

item BomItem
Elemento del quale restituire l'indice.

Valore di ritorno

Object
Restituisce l'indice dell'elemento oppure null.
Vedi anche

Documentazione

Classe BomItemCollection
Namespace DedNet.Core


Metodo BomItemCollection.GetHashCode

Metodo BomItemCollectionGetHashCode
Vengono riconosciuti uguali gli elementi che hanno DedIdParent, DedRevParent e QueryDate uguali.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Int32
Restituisce l'hashcode di questo oggetto.
Vedi anche

Documentazione

Classe BomItemCollection
Namespace DedNet.Core


Metodo BomItemCollection.GetItemsByIdRev

Metodo BomItemCollectionGetItemsByIdRev
Restituisce una lista con tutti i BomItem relativi all'ID e REV passate

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<BomItem> GetItemsByIdRev(
    string id,
    string rev
)
Public Function GetItemsByIdRev (
    id As String,
    rev As String
) As List(Of BomItem)
public:
List<BomItem^>^ GetItemsByIdRev(
    String^ id,
    String^ rev
)
member GetItemsByIdRev :
        id : string *
        rev : string -> List<BomItem>

Parametri

id String
Id anagrafica
rev String
Rev anagrafica

Valore di ritorno

List BomItem
Vedi anche

Documentazione

Classe BomItemCollection
Namespace DedNet.Core


Metodo BomItemCollection.OnAfterSave

Metodo BomItemCollectionOnAfterSave
Sblocca l'header salvando le modifiche.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void OnAfterSave(
    List<BomItem> eliminati,
    List<BomItem> modificati,
    List<BomItem> aggiunti
)
Protected Overrides Sub OnAfterSave (
    eliminati As List(Of BomItem),
    modificati As List(Of BomItem),
    aggiunti As List(Of BomItem)
)
protected:
virtual void OnAfterSave(
    List<BomItem^>^ eliminati,
    List<BomItem^>^ modificati,
    List<BomItem^>^ aggiunti
) override
abstract OnAfterSave :
        eliminati : List<BomItem> *
        modificati : List<BomItem> *
        aggiunti : List<BomItem> -> unit
override OnAfterSave :
        eliminati : List<BomItem> *
        modificati : List<BomItem> *
        aggiunti : List<BomItem> -> unit

Parametri

eliminati List BomItem
Elementi eliminati.
modificati List BomItem
Elementi modificati.
aggiunti List BomItem
Elementi aggiunti.
Vedi anche

Documentazione

Classe BomItemCollection
Namespace DedNet.Core


Metodo BomItemCollection.OnAfterSaveNoChanges

Metodo BomItemCollectionOnAfterSaveNoChanges
Sblocca l'header.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void OnAfterSaveNoChanges()
Protected Overrides Sub OnAfterSaveNoChanges
protected:
virtual void OnAfterSaveNoChanges() override
abstract OnAfterSaveNoChanges : unit -> unit
override OnAfterSaveNoChanges : unit -> unit
Vedi anche

Documentazione

Classe BomItemCollection
Namespace DedNet.Core


Metodo BomItemCollection.Remove

Metodo BomItemCollectionRemove
Elimina un elemento dalla collezione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void Remove(
    BomItem item
)
Public Overrides Sub Remove (
    item As BomItem
)
public:
virtual void Remove(
    BomItem^ item
) override
abstract Remove :
        item : BomItem -> unit
override Remove :
        item : BomItem -> unit

Parametri

item BomItem
Elemento da eliminare.
Vedi anche

Documentazione

Classe BomItemCollection
Namespace DedNet.Core


Metodo BomItemCollection.Replace

Metodo BomItemCollectionReplace
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Replace(DedData, DedData, BomItemManEnum, Boolean, Boolean) | Sostituisce un elemento nella collezione con tutti quelli che hanno come anagrafica dataOrig. Come sopra, controlla i riferimenti circolari e possibili anomalie nella richiesta. Se tutti i controlli vanno a buon fine inserisce il nuovo elemento copiando dall'originale la posizione e tutti gli attributi di distinta.
Metodo pubblico | Replace(DedData, DedData, BomItemManEnum, DictionaryString, Object, Boolean, Boolean) | Sostituisce un elemento nella collezione con tutti quelli che hanno come anagrafica dataOrig e con gli attributi di distinta uguali ai valori passanti in searchDiscrimValues. Come sopra, controlla i riferimenti circolari e possibili anomalie nella richiesta. Se tutti i controlli vanno a buon fine inserisce il nuovo elemento copiando dall'originale la posizione e tutti gli attributi di distinta.
Metodo pubblico | Replace(DedData, DedData, BomItemManEnum, BomItemManEnum, DictionaryString, Object, Boolean, Boolean) | Sostituisce un elemento nella collezione con tutti quelli che hanno come anagrafica dataOrig e con gli attributi di distinta uguali ai valori passanti in searchDiscrimValues. Come sopra, controlla i riferimenti circolari e possibili anomalie nella richiesta. Se tutti i controlli vanno a buon fine inserisce il nuovo elemento copiando dall'originale la posizione e tutti gli attributi di distinta.
Torna su
Vedi anche

Documentazione

Classe BomItemCollection
Namespace DedNet.Core


Metodo BomItemCollection.Replace(DedData, DedData, BomItemManEnum, Boolean, Boolean)

Metodo BomItemCollectionReplace(DedData, DedData, BomItemManEnum, Boolean, Boolean)
Sostituisce un elemento nella collezione con tutti quelli che hanno come anagrafica dataOrig. Come sopra, controlla i riferimenti circolari e possibili anomalie nella richiesta. Se tutti i controlli vanno a buon fine inserisce il nuovo elemento copiando dall'originale la posizione e tutti gli attributi di distinta.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<BomItem> Replace(
    DedData dataOrig,
    DedData dataNew,
    BomItemManEnum destman,
    bool ignoreState = false,
    bool fireExcOnDuplicate = false
)
Public Function Replace (
    dataOrig As DedData,
    dataNew As DedData,
    destman As BomItemManEnum,
    Optional ignoreState As Boolean = false,
    Optional fireExcOnDuplicate As Boolean = false
) As List(Of BomItem)
public:
List<BomItem^>^ Replace(
    DedData^ dataOrig,
    DedData^ dataNew,
    BomItemManEnum destman,
    bool ignoreState = false,
    bool fireExcOnDuplicate = false
)
member Replace :
        dataOrig : DedData *
        dataNew : DedData *
        destman : BomItemManEnum *
        ?ignoreState : bool *
        ?fireExcOnDuplicate : bool
(* Defaults:
        let _ignoreState = defaultArg ignoreState false
        let _fireExcOnDuplicate = defaultArg fireExcOnDuplicate false
*)
-> List<BomItem>

Parametri

dataOrig DedData
Anagrafica da sostituire
dataNew DedData
Anagrafica in sostituzione
destman BomItemManEnum
Man da assegnare al nuovo elemento.
ignoreState Boolean (Optional)
Indica se ingorare lo stato anagrafica in fase di locking della distinta
fireExcOnDuplicate Boolean (Optional)
Indica se sollevare eccezione in caso l'elemento in sostituzione sia già presente. In caso contrario unisce i due elementi sommandone le QTA

Valore di ritorno

List BomItem
L'elemento sostitutivo creato
Vedi anche

Documentazione

Classe BomItemCollection
Overload di Replace
Namespace DedNet.Core


Metodo BomItemCollection.Replace(DedData, DedData, BomItemManEnum, Dictionary<String, Object>, Boolean, Boolean)

Metodo BomItemCollectionReplace(DedData, DedData, BomItemManEnum, DictionaryString, Object, Boolean, Boolean)
Sostituisce un elemento nella collezione con tutti quelli che hanno come anagrafica dataOrig e con gli attributi di distinta uguali ai valori passanti in searchDiscrimValues. Come sopra, controlla i riferimenti circolari e possibili anomalie nella richiesta. Se tutti i controlli vanno a buon fine inserisce il nuovo elemento copiando dall'originale la posizione e tutti gli attributi di distinta.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<BomItem> Replace(
    DedData dataOrig,
    DedData dataNew,
    BomItemManEnum destman,
    Dictionary<string, Object> searchDiscrimValues,
    bool ignoreState = false,
    bool fireExcOnDuplicate = false
)
Public Function Replace (
    dataOrig As DedData,
    dataNew As DedData,
    destman As BomItemManEnum,
    searchDiscrimValues As Dictionary(Of String, Object),
    Optional ignoreState As Boolean = false,
    Optional fireExcOnDuplicate As Boolean = false
) As List(Of BomItem)
public:
List<BomItem^>^ Replace(
    DedData^ dataOrig,
    DedData^ dataNew,
    BomItemManEnum destman,
    Dictionary<String^, Object^>^ searchDiscrimValues,
    bool ignoreState = false,
    bool fireExcOnDuplicate = false
)
member Replace :
        dataOrig : DedData *
        dataNew : DedData *
        destman : BomItemManEnum *
        searchDiscrimValues : Dictionary<string, Object> *
        ?ignoreState : bool *
        ?fireExcOnDuplicate : bool
(* Defaults:
        let _ignoreState = defaultArg ignoreState false
        let _fireExcOnDuplicate = defaultArg fireExcOnDuplicate false
*)
-> List<BomItem>

Parametri

dataOrig DedData
Anagrafica da sostituire
dataNew DedData
Anagrafica in sostituzione
destman BomItemManEnum
Man da assegnare al nuovo elemento.
searchDiscrimValues Dictionary String, Object
Valori di distinta discriminati per la sostituzione
ignoreState Boolean (Optional)
Indica se ingorare lo stato anagrafica in fase di locking della distinta
fireExcOnDuplicate Boolean (Optional)
Indica se sollevare eccezione in caso l'elemento in sostituzione sia già presente. In caso contrario unisce i due elementi sommandone le QTA

Valore di ritorno

List BomItem
L'elemento sostitutivo creato
Vedi anche

Documentazione

Classe BomItemCollection
Overload di Replace
Namespace DedNet.Core


Metodo BomItemCollection.Replace(DedData, DedData, BomItemManEnum, BomItemManEnum, Dictionary<String, Object>, Boolean, Boolean)

Metodo BomItemCollectionReplace(DedData, DedData, BomItemManEnum, BomItemManEnum, DictionaryString, Object, Boolean, Boolean)
Sostituisce un elemento nella collezione con tutti quelli che hanno come anagrafica dataOrig e con gli attributi di distinta uguali ai valori passanti in searchDiscrimValues. Come sopra, controlla i riferimenti circolari e possibili anomalie nella richiesta. Se tutti i controlli vanno a buon fine inserisce il nuovo elemento copiando dall'originale la posizione e tutti gli attributi di distinta.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<BomItem> Replace(
    DedData dataOrig,
    DedData dataNew,
    BomItemManEnum destman,
    BomItemManEnum discrimman,
    Dictionary<string, Object> searchDiscrimValues,
    bool ignoreState = false,
    bool fireExcOnDuplicate = false
)
Public Function Replace (
    dataOrig As DedData,
    dataNew As DedData,
    destman As BomItemManEnum,
    discrimman As BomItemManEnum,
    searchDiscrimValues As Dictionary(Of String, Object),
    Optional ignoreState As Boolean = false,
    Optional fireExcOnDuplicate As Boolean = false
) As List(Of BomItem)
public:
List<BomItem^>^ Replace(
    DedData^ dataOrig,
    DedData^ dataNew,
    BomItemManEnum destman,
    BomItemManEnum discrimman,
    Dictionary<String^, Object^>^ searchDiscrimValues,
    bool ignoreState = false,
    bool fireExcOnDuplicate = false
)
member Replace :
        dataOrig : DedData *
        dataNew : DedData *
        destman : BomItemManEnum *
        discrimman : BomItemManEnum *
        searchDiscrimValues : Dictionary<string, Object> *
        ?ignoreState : bool *
        ?fireExcOnDuplicate : bool
(* Defaults:
        let _ignoreState = defaultArg ignoreState false
        let _fireExcOnDuplicate = defaultArg fireExcOnDuplicate false
*)
-> List<BomItem>

Parametri

dataOrig DedData
Anagrafica da sostituire
dataNew DedData
Anagrafica in sostituzione
destman BomItemManEnum
Man da assegnare al nuovo elemento.
discrimman BomItemManEnum
Man da usare come discriminante per la sostituzione
searchDiscrimValues Dictionary String, Object
Valori di distinta discriminati per la sostituzione
ignoreState Boolean (Optional)
Indica se ignorare lo stato anagrafica in fase di locking della distinta
fireExcOnDuplicate Boolean (Optional)
Indica se sollevare eccezione in caso l'elemento in sostituzione sia già presente. In caso contrario unisce i due elementi sommandone le QTA

Valore di ritorno

List BomItem
L'elemento sostitutivo creato
Vedi anche

Documentazione

Classe BomItemCollection
Overload di Replace
Namespace DedNet.Core


Metodo BomItemCollection.Save

Metodo BomItemCollectionSave
Salva le modifiche della collezione e dell'header corrispondente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void Save()
Public Overrides Sub Save
public:
virtual void Save() override
abstract Save : unit -> unit
override Save : unit -> unit

Implementa

IDedDbCollectionBaseTSave
Vedi anche

Documentazione

Classe BomItemCollection
Namespace DedNet.Core


Metodo BomItemCollection.ToString

Metodo BomItemCollectionToString
Restituisce una rappresentazione stringa di questo oggetto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

String
Restituisce una stringa rappresentante questo oggetto.
Vedi anche

Documentazione

Classe BomItemCollection
Namespace DedNet.Core


Classe BomItemComparer
Gestore del confronto degli elementi di distinta
Gerarchia di ereditarietà
SystemObject
DedNet.CoreBomItemComparer
DedNet.CoreBomItemComparerImported

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class BomItemComparer
Public Class BomItemComparer
public ref class BomItemComparer
type BomItemComparer = class end

Il tipo BomItemComparer espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | BomItemComparer | Costruttore del gestore. Legge dal registro le impostazioni
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | CmpAnag | Indica se il confronto coinvolge l'anagrafica. E' stato esposto ma è un elemento fisso (Fixed true).
Proprietà pubblica | CmpDiscrim | Indica se il confronto coinvolge il discriminante di distinta dell'elemento (Default false).
Proprietà pubblica | CmpDistAttrs | Dizionario degli attributi di distinta con relativo valore di controllo nel confronto
Proprietà pubblica | CmpId | Indica se il confronto coinvolge l'id. E' stato esposto ma è un elemento fisso (Fixed true).
Proprietà pubblica | CmpMan | Indica se il confronto coinvolge la sorgente dell'elemento (Default true).
Proprietà pubblica | CmpQta | Indica se il confronto coinvolge la qta (Default true).
Proprietà pubblica | CmpRev | Indica se il confronto coinvolge la rev (Default true)
Proprietà pubblica | CmpRevisione | Indica se il confronto coinvolge la revisione
Proprietà pubblica | ColorAdded | Colorazione anagrafica aggiunta
Proprietà pubblica | ColorEqual | Colorazione anagrafica presente, crriteri di confronto identici
Proprietà pubblica | ColorNotEqual | Colorazione anagrafica presente, crriteri di confronto diversi
Proprietà pubblica | ColorNotPresent | Colorazione anagrafica non presente
Proprietà pubblica | DisableCmpDiscrim | Disabilita il check Discriminante
Proprietà pubblica | DisableCmpMan | Disabilita il check Man
Proprietà pubblica | DiscrimAnagAttrs | Attributi da usare nella comparazione Anagrafica ( se non viene impostato usa ID + REV )
Proprietà pubblica | RegistryBomComparerDir | Chiave principale del registro per il salvataggio delle impostazioni
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Compare | Confronta due elementi di distinta utilizzando i criteri impostati nella configurazione. Restituisce true se i due elementi risultano identici secondo i criteri impostati.
Metodo pubblico | CompareAttr | Confronta gli attributi e la qta delle due distinte e salva le differenze in un dizionario
Metodo pubblico | HasSameAnagr | Confronta i due elementi di distinta determinando se hanno la stessa anagrafica.
Metodo pubblico | ShowSettings | Metodo di scrittura delle impostazioni nel registro
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore BomItemComparer
Costruttore del gestore. Legge dal registro le impostazioni

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItemComparer(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
BomItemComparer(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> BomItemComparer

Parametri

app DedNetApplication
Vedi anche

Documentazione

Classe BomItemComparer
Namespace DedNet.Core


Proprietà di BomItemComparer

Il tipo BomItemComparer espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CmpAnag | Indica se il confronto coinvolge l'anagrafica. E' stato esposto ma è un elemento fisso (Fixed true).
Proprietà pubblica | CmpDiscrim | Indica se il confronto coinvolge il discriminante di distinta dell'elemento (Default false).
Proprietà pubblica | CmpDistAttrs | Dizionario degli attributi di distinta con relativo valore di controllo nel confronto
Proprietà pubblica | CmpId | Indica se il confronto coinvolge l'id. E' stato esposto ma è un elemento fisso (Fixed true).
Proprietà pubblica | CmpMan | Indica se il confronto coinvolge la sorgente dell'elemento (Default true).
Proprietà pubblica | CmpQta | Indica se il confronto coinvolge la qta (Default true).
Proprietà pubblica | CmpRev | Indica se il confronto coinvolge la rev (Default true)
Proprietà pubblica | CmpRevisione | Indica se il confronto coinvolge la revisione
Proprietà pubblica | ColorAdded | Colorazione anagrafica aggiunta
Proprietà pubblica | ColorEqual | Colorazione anagrafica presente, crriteri di confronto identici
Proprietà pubblica | ColorNotEqual | Colorazione anagrafica presente, crriteri di confronto diversi
Proprietà pubblica | ColorNotPresent | Colorazione anagrafica non presente
Proprietà pubblica | DisableCmpDiscrim | Disabilita il check Discriminante
Proprietà pubblica | DisableCmpMan | Disabilita il check Man
Proprietà pubblica | DiscrimAnagAttrs | Attributi da usare nella comparazione Anagrafica ( se non viene impostato usa ID + REV )
Proprietà pubblica | RegistryBomComparerDir | Chiave principale del registro per il salvataggio delle impostazioni
Torna su
Vedi anche

Documentazione

Classe BomItemComparer
Namespace DedNet.Core


Proprietà BomItemComparer.CmpAnag

Proprietà BomItemComparerCmpAnag
Indica se il confronto coinvolge l'anagrafica. E' stato esposto ma è un elemento fisso (Fixed true).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CmpAnag { get; set; }
Public Property CmpAnag As Boolean
    Get
    Set
public:
property bool CmpAnag {
    bool get ();
    void set (bool value);
}
member CmpAnag : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe BomItemComparer
Namespace DedNet.Core


Proprietà BomItemComparer.CmpDiscrim

Proprietà BomItemComparerCmpDiscrim
Indica se il confronto coinvolge il discriminante di distinta dell'elemento (Default false).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CmpDiscrim { get; set; }
Public Property CmpDiscrim As Boolean
    Get
    Set
public:
property bool CmpDiscrim {
    bool get ();
    void set (bool value);
}
member CmpDiscrim : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe BomItemComparer
Namespace DedNet.Core


Proprietà BomItemComparer.CmpDistAttrs

Proprietà BomItemComparerCmpDistAttrs
Dizionario degli attributi di distinta con relativo valore di controllo nel confronto

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<DedAttr, bool> CmpDistAttrs { get; set; }
Public Property CmpDistAttrs As Dictionary(Of DedAttr, Boolean)
    Get
    Set
public:
property Dictionary<DedAttr^, bool>^ CmpDistAttrs {
    Dictionary<DedAttr^, bool>^ get ();
    void set (Dictionary<DedAttr^, bool>^ value);
}
member CmpDistAttrs : Dictionary<DedAttr, bool> with get, set

Valore della proprietà

Dictionary DedAttr, Boolean
Vedi anche

Documentazione

Classe BomItemComparer
Namespace DedNet.Core


Proprietà BomItemComparer.CmpId

Proprietà BomItemComparerCmpId
Indica se il confronto coinvolge l'id. E' stato esposto ma è un elemento fisso (Fixed true).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CmpId { get; set; }
Public Property CmpId As Boolean
    Get
    Set
public:
property bool CmpId {
    bool get ();
    void set (bool value);
}
member CmpId : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe BomItemComparer
Namespace DedNet.Core


Proprietà BomItemComparer.CmpMan

Proprietà BomItemComparerCmpMan
Indica se il confronto coinvolge la sorgente dell'elemento (Default true).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CmpMan { get; set; }
Public Property CmpMan As Boolean
    Get
    Set
public:
property bool CmpMan {
    bool get ();
    void set (bool value);
}
member CmpMan : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe BomItemComparer
Namespace DedNet.Core


Proprietà BomItemComparer.CmpQta

Proprietà BomItemComparerCmpQta
Indica se il confronto coinvolge la qta (Default true).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CmpQta { get; set; }
Public Property CmpQta As Boolean
    Get
    Set
public:
property bool CmpQta {
    bool get ();
    void set (bool value);
}
member CmpQta : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe BomItemComparer
Namespace DedNet.Core


Proprietà BomItemComparer.CmpRev

Proprietà BomItemComparerCmpRev
Indica se il confronto coinvolge la rev (Default true)

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CmpRev { get; set; }
Public Property CmpRev As Boolean
    Get
    Set
public:
property bool CmpRev {
    bool get ();
    void set (bool value);
}
member CmpRev : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe BomItemComparer
Namespace DedNet.Core


Proprietà BomItemComparer.CmpRevisione

Proprietà BomItemComparerCmpRevisione
Indica se il confronto coinvolge la revisione

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CmpRevisione { get; set; }
Public Property CmpRevisione As Boolean
    Get
    Set
public:
property bool CmpRevisione {
    bool get ();
    void set (bool value);
}
member CmpRevisione : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe BomItemComparer
Namespace DedNet.Core


Proprietà BomItemComparer.ColorAdded

Proprietà BomItemComparerColorAdded
Colorazione anagrafica aggiunta

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Color ColorAdded { get; set; }
Public Property ColorAdded As Color
    Get
    Set
public:
property Color ColorAdded {
    Color get ();
    void set (Color value);
}
member ColorAdded : Color with get, set

Valore della proprietà

Color
Vedi anche

Documentazione

Classe BomItemComparer
Namespace DedNet.Core


Proprietà BomItemComparer.ColorEqual

Proprietà BomItemComparerColorEqual
Colorazione anagrafica presente, crriteri di confronto identici

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Color ColorEqual { get; set; }
Public Property ColorEqual As Color
    Get
    Set
public:
property Color ColorEqual {
    Color get ();
    void set (Color value);
}
member ColorEqual : Color with get, set

Valore della proprietà

Color
Vedi anche

Documentazione

Classe BomItemComparer
Namespace DedNet.Core


Proprietà BomItemComparer.ColorNotEqual

Proprietà BomItemComparerColorNotEqual
Colorazione anagrafica presente, crriteri di confronto diversi

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Color ColorNotEqual { get; set; }
Public Property ColorNotEqual As Color
    Get
    Set
public:
property Color ColorNotEqual {
    Color get ();
    void set (Color value);
}
member ColorNotEqual : Color with get, set

Valore della proprietà

Color
Vedi anche

Documentazione

Classe BomItemComparer
Namespace DedNet.Core


Proprietà BomItemComparer.ColorNotPresent

Proprietà BomItemComparerColorNotPresent
Colorazione anagrafica non presente

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Color ColorNotPresent { get; set; }
Public Property ColorNotPresent As Color
    Get
    Set
public:
property Color ColorNotPresent {
    Color get ();
    void set (Color value);
}
member ColorNotPresent : Color with get, set

Valore della proprietà

Color
Vedi anche

Documentazione

Classe BomItemComparer
Namespace DedNet.Core


Proprietà BomItemComparer.DisableCmpDiscrim

Proprietà BomItemComparerDisableCmpDiscrim
Disabilita il check Discriminante

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool DisableCmpDiscrim { get; set; }
Public Property DisableCmpDiscrim As Boolean
    Get
    Set
public:
property bool DisableCmpDiscrim {
    bool get ();
    void set (bool value);
}
member DisableCmpDiscrim : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe BomItemComparer
Namespace DedNet.Core


Proprietà BomItemComparer.DisableCmpMan

Proprietà BomItemComparerDisableCmpMan
Disabilita il check Man

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool DisableCmpMan { get; set; }
Public Property DisableCmpMan As Boolean
    Get
    Set
public:
property bool DisableCmpMan {
    bool get ();
    void set (bool value);
}
member DisableCmpMan : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe BomItemComparer
Namespace DedNet.Core


Proprietà BomItemComparer.DiscrimAnagAttrs

Proprietà BomItemComparerDiscrimAnagAttrs
Attributi da usare nella comparazione Anagrafica ( se non viene impostato usa ID + REV )

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList DiscrimAnagAttrs { get; set; }
Public Property DiscrimAnagAttrs As DedAttrList
    Get
    Set
public:
property DedAttrList^ DiscrimAnagAttrs {
    DedAttrList^ get ();
    void set (DedAttrList^ value);
}
member DiscrimAnagAttrs : DedAttrList with get, set

Valore della proprietà

DedAttrList
Vedi anche

Documentazione

Classe BomItemComparer
Namespace DedNet.Core


Proprietà BomItemComparer.RegistryBomComparerDir

Proprietà BomItemComparerRegistryBomComparerDir
Chiave principale del registro per il salvataggio delle impostazioni

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string RegistryBomComparerDir { get; }
Public ReadOnly Property RegistryBomComparerDir As String
    Get
public:
property String^ RegistryBomComparerDir {
    String^ get ();
}
member RegistryBomComparerDir : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe BomItemComparer
Namespace DedNet.Core


Metodi di BomItemComparer

Il tipo BomItemComparer espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Compare | Confronta due elementi di distinta utilizzando i criteri impostati nella configurazione. Restituisce true se i due elementi risultano identici secondo i criteri impostati.
Metodo pubblico | CompareAttr | Confronta gli attributi e la qta delle due distinte e salva le differenze in un dizionario
Metodo pubblico | HasSameAnagr | Confronta i due elementi di distinta determinando se hanno la stessa anagrafica.
Metodo pubblico | ShowSettings | Metodo di scrittura delle impostazioni nel registro
Torna su
Vedi anche

Documentazione

Classe BomItemComparer
Namespace DedNet.Core


Metodo BomItemComparer.Compare

Metodo BomItemComparerCompare
Confronta due elementi di distinta utilizzando i criteri impostati nella configurazione. Restituisce true se i due elementi risultano identici secondo i criteri impostati.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Compare(
    BomItem a,
    BomItem b
)
Public Function Compare (
    a As BomItem,
    b As BomItem
) As Boolean
public:
bool Compare(
    BomItem^ a,
    BomItem^ b
)
member Compare :
        a : BomItem *
        b : BomItem -> bool

Parametri

a BomItem
b BomItem

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe BomItemComparer
Namespace DedNet.Core


Metodo BomItemComparer.CompareAttr

Metodo BomItemComparerCompareAttr
Confronta gli attributi e la qta delle due distinte e salva le differenze in un dizionario

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<BomItemComparerClassComparBom> CompareAttr(
    BomItem a,
    BomItem b
)
Public Function CompareAttr (
    a As BomItem,
    b As BomItem
) As List(Of BomItemComparerClassComparBom)
public:
List<BomItemComparerClassComparBom^>^ CompareAttr(
    BomItem^ a,
    BomItem^ b
)
member CompareAttr :
        a : BomItem *
        b : BomItem -> List<BomItemComparerClassComparBom>

Parametri

a BomItem
b BomItem

Valore di ritorno

List BomItemComparerClassComparBom
Vedi anche

Documentazione

Classe BomItemComparer
Namespace DedNet.Core


Metodo BomItemComparer.HasSameAnagr

Metodo BomItemComparerHasSameAnagr
Confronta i due elementi di distinta determinando se hanno la stessa anagrafica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasSameAnagr(
    BomItem bi1,
    BomItem bi2
)
Public Function HasSameAnagr (
    bi1 As BomItem,
    bi2 As BomItem
) As Boolean
public:
bool HasSameAnagr(
    BomItem^ bi1,
    BomItem^ bi2
)
member HasSameAnagr :
        bi1 : BomItem *
        bi2 : BomItem -> bool

Parametri

bi1 BomItem
bi2 BomItem

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe BomItemComparer
Namespace DedNet.Core


Metodo BomItemComparer.ShowSettings

Metodo BomItemComparerShowSettings
Metodo di scrittura delle impostazioni nel registro

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ShowSettings()
Public Sub ShowSettings
public:
void ShowSettings()
member ShowSettings : unit -> unit
Vedi anche

Documentazione

Classe BomItemComparer
Namespace DedNet.Core


Classe BomItemComparer.ClassComparBom

Classe BomItemComparerClassComparBom
Classe usata per il confronto fra distinte
Gerarchia di ereditarietà
SystemObject
DedNet.CoreBomItemComparerClassComparBom

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ClassComparBom
Public Class ClassComparBom
public ref class ClassComparBom
type ClassComparBom = class end

Il tipo BomItemComparerClassComparBom espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | BomItemComparerClassComparBom | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AttrCmpName | Nome dell'attributo
Proprietà pubblica | AttrCmpValue | Per la QTA rappresente il differenziale, per gli altri attributi rappresenta il valore presente nella distinta di base (a sinistra)
Proprietà pubblica | AttrOldValue | Per la QTA il valore è a null, per gli altri attributi rappresenta il valore presente nella distinta di confronto (a destra)
Proprietà pubblica | TypeAttr | Per la QTA e per il campo Sorgente (check) il valore è a null, per gli altri attributi rappresenta il type dell'attributo
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore BomItemComparer.ClassComparBom

Costruttore BomItemComparerClassComparBom
Costruttore unico.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ClassComparBom(
    string attrCmpName,
    Object attrCmpValue,
    Object attrOldValue,
    Type typeAttr
)
Public Sub New (
    attrCmpName As String,
    attrCmpValue As Object,
    attrOldValue As Object,
    typeAttr As Type
)
public:
ClassComparBom(
    String^ attrCmpName,
    Object^ attrCmpValue,
    Object^ attrOldValue,
    Type^ typeAttr
)
new :
        attrCmpName : string *
        attrCmpValue : Object *
        attrOldValue : Object *
        typeAttr : Type -> ClassComparBom

Parametri

attrCmpName String
attrCmpValue Object
attrOldValue Object
typeAttr Type
Vedi anche

Documentazione

Classe BomItemComparerClassComparBom
Namespace DedNet.Core


Proprietà di ClassComparBom

Il tipo BomItemComparerClassComparBom espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AttrCmpName | Nome dell'attributo
Proprietà pubblica | AttrCmpValue | Per la QTA rappresente il differenziale, per gli altri attributi rappresenta il valore presente nella distinta di base (a sinistra)
Proprietà pubblica | AttrOldValue | Per la QTA il valore è a null, per gli altri attributi rappresenta il valore presente nella distinta di confronto (a destra)
Proprietà pubblica | TypeAttr | Per la QTA e per il campo Sorgente (check) il valore è a null, per gli altri attributi rappresenta il type dell'attributo
Torna su
Vedi anche

Documentazione

Classe BomItemComparerClassComparBom
Namespace DedNet.Core


Proprietà BomItemComparer.ClassComparBom.AttrCmpName

Proprietà BomItemComparerClassComparBomAttrCmpName
Nome dell'attributo

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string AttrCmpName { get; set; }
Public Property AttrCmpName As String
    Get
    Set
public:
property String^ AttrCmpName {
    String^ get ();
    void set (String^ value);
}
member AttrCmpName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe BomItemComparerClassComparBom
Namespace DedNet.Core


Proprietà BomItemComparer.ClassComparBom.AttrCmpValue

Proprietà BomItemComparerClassComparBomAttrCmpValue
Per la QTA rappresente il differenziale, per gli altri attributi rappresenta il valore presente nella distinta di base (a sinistra)

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object AttrCmpValue { get; set; }
Public Property AttrCmpValue As Object
    Get
    Set
public:
property Object^ AttrCmpValue {
    Object^ get ();
    void set (Object^ value);
}
member AttrCmpValue : Object with get, set

Valore della proprietà

Object
Vedi anche

Documentazione

Classe BomItemComparerClassComparBom
Namespace DedNet.Core


Proprietà BomItemComparer.ClassComparBom.AttrOldValue

Proprietà BomItemComparerClassComparBomAttrOldValue
Per la QTA il valore è a null, per gli altri attributi rappresenta il valore presente nella distinta di confronto (a destra)

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object AttrOldValue { get; set; }
Public Property AttrOldValue As Object
    Get
    Set
public:
property Object^ AttrOldValue {
    Object^ get ();
    void set (Object^ value);
}
member AttrOldValue : Object with get, set

Valore della proprietà

Object
Vedi anche

Documentazione

Classe BomItemComparerClassComparBom
Namespace DedNet.Core


Proprietà BomItemComparer.ClassComparBom.TypeAttr

Proprietà BomItemComparerClassComparBomTypeAttr
Per la QTA e per il campo Sorgente (check) il valore è a null, per gli altri attributi rappresenta il type dell'attributo

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Type TypeAttr { get; set; }
Public Property TypeAttr As Type
    Get
    Set
public:
property Type^ TypeAttr {
    Type^ get ();
    void set (Type^ value);
}
member TypeAttr : Type with get, set

Valore della proprietà

Type
Vedi anche

Documentazione

Classe BomItemComparerClassComparBom
Namespace DedNet.Core


Enumerazione BomItemComparer.StateEnum

Enumerazione BomItemComparerStateEnum

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum StateEnum
Public Enumeration StateEnum
public enum class StateEnum
type StateEnum
Membri
Nome | Valore | Descrizione
Equal | 0 | Uguale
NotEqual | 1 | Diverso
NotPresent | 2 | Non presente
Added | 3 | Aggiunto
Vedi anche

Documentazione

Namespace DedNet.Core


Classe BomItemComparerAnag
Classe per comparare due BomItem per anagrafica
Gerarchia di ereditarietà
SystemObject
DedNet.CoreBomItemComparerAnag

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class BomItemComparerAnag : IEqualityComparer<BomItem>
Public Class BomItemComparerAnag
    Implements IEqualityComparer(Of BomItem)
public ref class BomItemComparerAnag : IEqualityComparer<BomItem^>
type BomItemComparerAnag =
    class
        interface IEqualityComparer<BomItem>
    end

Il tipo BomItemComparerAnag espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | BomItemComparerAnag |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Equals |
Metodo pubblico | GetHashCode |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore BomItemComparerAnag

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItemComparerAnag()
Public Sub New
public:
BomItemComparerAnag()
new : unit -> BomItemComparerAnag
Vedi anche

Documentazione

Classe BomItemComparerAnag
Namespace DedNet.Core


Metodi di BomItemComparerAnag

Il tipo BomItemComparerAnag espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Equals |
Metodo pubblico | GetHashCode |
Torna su
Vedi anche

Documentazione

Classe BomItemComparerAnag
Namespace DedNet.Core


Metodo BomItemComparerAnag.Equals

Metodo BomItemComparerAnagEquals

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Equals(
    BomItem x,
    BomItem y
)
Public Function Equals (
    x As BomItem,
    y As BomItem
) As Boolean
public:
virtual bool Equals(
    BomItem^ x,
    BomItem^ y
) sealed
abstract Equals :
        x : BomItem *
        y : BomItem -> bool
override Equals :
        x : BomItem *
        y : BomItem -> bool

Parametri

x BomItem
y BomItem

Valore di ritorno

Boolean

Implementa

IEqualityComparerTEquals(T, T)
Vedi anche

Documentazione

Classe BomItemComparerAnag
Namespace DedNet.Core


Metodo BomItemComparerAnag.GetHashCode

Metodo BomItemComparerAnagGetHashCode

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int GetHashCode(
    BomItem bi
)
Public Function GetHashCode (
    bi As BomItem
) As Integer
public:
virtual int GetHashCode(
    BomItem^ bi
) sealed
abstract GetHashCode :
        bi : BomItem -> int
override GetHashCode :
        bi : BomItem -> int

Parametri

bi BomItem

Valore di ritorno

Int32

Implementa

IEqualityComparerTGetHashCode(T)
Vedi anche

Documentazione

Classe BomItemComparerAnag
Namespace DedNet.Core


Classe BomItemComparerImported
Classe usata per personalizzare il confronto fra distinte
Gerarchia di ereditarietà
SystemObject
DedNet.CoreBomItemComparer
DedNet.CoreBomItemComparerImported

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class BomItemComparerImported : BomItemComparer
Public Class BomItemComparerImported
    Inherits BomItemComparer
public ref class BomItemComparerImported : public BomItemComparer
type BomItemComparerImported =
    class
        inherit BomItemComparer
    end

Il tipo BomItemComparerImported espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | BomItemComparerImported | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | CmpAnag | Indica se il confronto coinvolge l'anagrafica. E' stato esposto ma è un elemento fisso (Fixed true). (Ereditato da BomItemComparer)
Proprietà pubblica | CmpDiscrim | Indica se il confronto coinvolge il discriminante di distinta dell'elemento (Default false). (Ereditato da BomItemComparer)
Proprietà pubblica | CmpDistAttrs | Dizionario degli attributi di distinta con relativo valore di controllo nel confronto (Ereditato da BomItemComparer)
Proprietà pubblica | CmpId | Indica se il confronto coinvolge l'id. E' stato esposto ma è un elemento fisso (Fixed true). (Ereditato da BomItemComparer)
Proprietà pubblica | CmpMan | Indica se il confronto coinvolge la sorgente dell'elemento (Default true). (Ereditato da BomItemComparer)
Proprietà pubblica | CmpQta | Indica se il confronto coinvolge la qta (Default true). (Ereditato da BomItemComparer)
Proprietà pubblica | CmpRev | Indica se il confronto coinvolge la rev (Default true) (Ereditato da BomItemComparer)
Proprietà pubblica | CmpRevisione | Indica se il confronto coinvolge la revisione (Ereditato da BomItemComparer)
Proprietà pubblica | ColorAdded | Colorazione anagrafica aggiunta (Ereditato da BomItemComparer)
Proprietà pubblica | ColorEqual | Colorazione anagrafica presente, crriteri di confronto identici (Ereditato da BomItemComparer)
Proprietà pubblica | ColorNotEqual | Colorazione anagrafica presente, crriteri di confronto diversi (Ereditato da BomItemComparer)
Proprietà pubblica | ColorNotPresent | Colorazione anagrafica non presente (Ereditato da BomItemComparer)
Proprietà pubblica | DisableCmpDiscrim | Disabilita il check Discriminante (Ereditato da BomItemComparer)
Proprietà pubblica | DisableCmpMan | Disabilita il check Man (Ereditato da BomItemComparer)
Proprietà pubblica | DiscrimAnagAttrs | Attributi da usare nella comparazione Anagrafica ( se non viene impostato usa ID + REV ) (Ereditato da BomItemComparer)
Proprietà pubblica | RegistryBomComparerDir | Chiave principale del registro per il salvataggio delle impostazioni (Ereditato da BomItemComparer)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Compare | Confronta due elementi di distinta utilizzando i criteri impostati nella configurazione. Restituisce true se i due elementi risultano identici secondo i criteri impostati. (Ereditato da BomItemComparer)
Metodo pubblico | CompareAttr | Confronta gli attributi e la qta delle due distinte e salva le differenze in un dizionario (Ereditato da BomItemComparer)
Metodo pubblico | HasSameAnagr | Confronta i due elementi di distinta determinando se hanno la stessa anagrafica. (Ereditato da BomItemComparer)
Metodo pubblico | ShowSettings | Metodo di scrittura delle impostazioni nel registro (Ereditato da BomItemComparer)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore BomItemComparerImported
Costruttore

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItemComparerImported(
    DedNetApplication app,
    DedAttrList discrimDistAttrs,
    DedAttrList discrimAnagAttrs
)
Public Sub New (
    app As DedNetApplication,
    discrimDistAttrs As DedAttrList,
    discrimAnagAttrs As DedAttrList
)
public:
BomItemComparerImported(
    DedNetApplication^ app,
    DedAttrList^ discrimDistAttrs,
    DedAttrList^ discrimAnagAttrs
)
new :
        app : DedNetApplication *
        discrimDistAttrs : DedAttrList *
        discrimAnagAttrs : DedAttrList -> BomItemComparerImported

Parametri

app DedNetApplication
discrimDistAttrs DedAttrList
discrimAnagAttrs DedAttrList
Vedi anche

Documentazione

Classe BomItemComparerImported
Namespace DedNet.Core


Proprietà di BomItemComparerImported

Il tipo BomItemComparerImported espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CmpAnag | Indica se il confronto coinvolge l'anagrafica. E' stato esposto ma è un elemento fisso (Fixed true). (Ereditato da BomItemComparer)
Proprietà pubblica | CmpDiscrim | Indica se il confronto coinvolge il discriminante di distinta dell'elemento (Default false). (Ereditato da BomItemComparer)
Proprietà pubblica | CmpDistAttrs | Dizionario degli attributi di distinta con relativo valore di controllo nel confronto (Ereditato da BomItemComparer)
Proprietà pubblica | CmpId | Indica se il confronto coinvolge l'id. E' stato esposto ma è un elemento fisso (Fixed true). (Ereditato da BomItemComparer)
Proprietà pubblica | CmpMan | Indica se il confronto coinvolge la sorgente dell'elemento (Default true). (Ereditato da BomItemComparer)
Proprietà pubblica | CmpQta | Indica se il confronto coinvolge la qta (Default true). (Ereditato da BomItemComparer)
Proprietà pubblica | CmpRev | Indica se il confronto coinvolge la rev (Default true) (Ereditato da BomItemComparer)
Proprietà pubblica | CmpRevisione | Indica se il confronto coinvolge la revisione (Ereditato da BomItemComparer)
Proprietà pubblica | ColorAdded | Colorazione anagrafica aggiunta (Ereditato da BomItemComparer)
Proprietà pubblica | ColorEqual | Colorazione anagrafica presente, crriteri di confronto identici (Ereditato da BomItemComparer)
Proprietà pubblica | ColorNotEqual | Colorazione anagrafica presente, crriteri di confronto diversi (Ereditato da BomItemComparer)
Proprietà pubblica | ColorNotPresent | Colorazione anagrafica non presente (Ereditato da BomItemComparer)
Proprietà pubblica | DisableCmpDiscrim | Disabilita il check Discriminante (Ereditato da BomItemComparer)
Proprietà pubblica | DisableCmpMan | Disabilita il check Man (Ereditato da BomItemComparer)
Proprietà pubblica | DiscrimAnagAttrs | Attributi da usare nella comparazione Anagrafica ( se non viene impostato usa ID + REV ) (Ereditato da BomItemComparer)
Proprietà pubblica | RegistryBomComparerDir | Chiave principale del registro per il salvataggio delle impostazioni (Ereditato da BomItemComparer)
Torna su
Vedi anche

Documentazione

Classe BomItemComparerImported
Namespace DedNet.Core


Metodi di BomItemComparerImported

Il tipo BomItemComparerImported espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Compare | Confronta due elementi di distinta utilizzando i criteri impostati nella configurazione. Restituisce true se i due elementi risultano identici secondo i criteri impostati. (Ereditato da BomItemComparer)
Metodo pubblico | CompareAttr | Confronta gli attributi e la qta delle due distinte e salva le differenze in un dizionario (Ereditato da BomItemComparer)
Metodo pubblico | HasSameAnagr | Confronta i due elementi di distinta determinando se hanno la stessa anagrafica. (Ereditato da BomItemComparer)
Metodo pubblico | ShowSettings | Metodo di scrittura delle impostazioni nel registro (Ereditato da BomItemComparer)
Torna su
Vedi anche

Documentazione

Classe BomItemComparerImported
Namespace DedNet.Core


Enumerazione BomItemManEnum
Enumerazione del campo Man degli elementi di distinta.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum BomItemManEnum
Public Enumeration BomItemManEnum
public enum class BomItemManEnum
type BomItemManEnum
Membri
Nome | Valore | Descrizione
None | 0 | Non specificato.
Cad | 1 | Questo elemento proviene dal salvataggio della distinta CAD.
Manual | 2 | Elemento che è stato aggiunto manualmente in distinta (DedBomEdit).
Edited | 4 | Elemento che è stato editato manualmente in distinta (DedBomEdit).
Variant | 8 | Elemento che fa parte di una variante di distinta.
Alternative | 16 | Elemento sostituito come alternativo.
Vedi anche

Documentazione

Namespace DedNet.Core


Classe CategoryComparerByPosition
Classe di compare della posizione di due attributi.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreCategoryComparerByPosition

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class CategoryComparerByPosition : IComparer<DedCateg>
Public Class CategoryComparerByPosition
    Implements IComparer(Of DedCateg)
public ref class CategoryComparerByPosition : IComparer<DedCateg^>
type CategoryComparerByPosition =
    class
        interface IComparer<DedCateg>
    end

Il tipo CategoryComparerByPosition espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | CategoryComparerByPosition |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Compare | Mette a confronto i valori di Pos degli attributi passati.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore CategoryComparerByPosition

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public CategoryComparerByPosition()
Public Sub New
public:
CategoryComparerByPosition()
new : unit -> CategoryComparerByPosition
Vedi anche

Documentazione

Classe CategoryComparerByPosition
Namespace DedNet.Core


Metodi di CategoryComparerByPosition

Il tipo CategoryComparerByPosition espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Compare | Mette a confronto i valori di Pos degli attributi passati.
Torna su
Vedi anche

Documentazione

Classe CategoryComparerByPosition
Namespace DedNet.Core


Metodo CategoryComparerByPosition.Compare

Metodo CategoryComparerByPositionCompare
Mette a confronto i valori di Pos degli attributi passati.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int Compare(
    DedCateg x,
    DedCateg y
)
Public Function Compare (
    x As DedCateg,
    y As DedCateg
) As Integer
public:
virtual int Compare(
    DedCateg^ x,
    DedCateg^ y
) sealed
abstract Compare :
        x : DedCateg *
        y : DedCateg -> int
override Compare :
        x : DedCateg *
        y : DedCateg -> int

Parametri

x DedCateg
y DedCateg

Valore di ritorno

Int32

Implementa

IComparerTCompare(T, T)
Vedi anche

Documentazione

Classe CategoryComparerByPosition
Namespace DedNet.Core


Classe CfgOperation
Classe che rappresenta l'oggetto memorizzato nel Database nella tabella DED_DOC_CFG
Gerarchia di ereditarietà
SystemObject
DedNet.CoreCfgOperation

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class CfgOperation
Public Class CfgOperation
public ref class CfgOperation
type CfgOperation = class end

Il tipo CfgOperation espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | CfgOperation | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Action | Indica l'azione che è stata effettuata
Proprietà pubblica | Cfgkey | Chiave che rappresenta la configurazione
Proprietà pubblica | Date | Indica la data in cui è stata fatta l'operazione
Proprietà pubblica | Docid | Docid del documento
Proprietà pubblica | Newname | Nuovo nome della configurazione dopo l'operazione
Proprietà pubblica | Oldname | Vecchio nome della configurazione prima dell'operazione
Proprietà pubblica | Published | Indica se l'operazione è già stat pubblicata
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore CfgOperation
Costruttore

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public CfgOperation(
    Guid docid,
    string cfgkey,
    string oldname,
    string newname,
    CfgOperationCfgOpEnum cfgOpEnum,
    bool published,
    DateTime? date
)
Public Sub New (
    docid As Guid,
    cfgkey As String,
    oldname As String,
    newname As String,
    cfgOpEnum As CfgOperationCfgOpEnum,
    published As Boolean,
    date As DateTime?
)
public:
CfgOperation(
    Guid docid,
    String^ cfgkey,
    String^ oldname,
    String^ newname,
    CfgOperationCfgOpEnum cfgOpEnum,
    bool published,
    Nullable<DateTime> date
)
new :
        docid : Guid *
        cfgkey : string *
        oldname : string *
        newname : string *
        cfgOpEnum : CfgOperationCfgOpEnum *
        published : bool *
        date : Nullable<DateTime> -> CfgOperation

Parametri

docid Guid
cfgkey String
oldname String
newname String
cfgOpEnum CfgOperationCfgOpEnum
published Boolean
date Nullable DateTime
Vedi anche

Documentazione

Classe CfgOperation
Namespace DedNet.Core


Proprietà di CfgOperation

Il tipo CfgOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Action | Indica l'azione che è stata effettuata
Proprietà pubblica | Cfgkey | Chiave che rappresenta la configurazione
Proprietà pubblica | Date | Indica la data in cui è stata fatta l'operazione
Proprietà pubblica | Docid | Docid del documento
Proprietà pubblica | Newname | Nuovo nome della configurazione dopo l'operazione
Proprietà pubblica | Oldname | Vecchio nome della configurazione prima dell'operazione
Proprietà pubblica | Published | Indica se l'operazione è già stat pubblicata
Torna su
Vedi anche

Documentazione

Classe CfgOperation
Namespace DedNet.Core


Proprietà CfgOperation.Action

Proprietà CfgOperationAction
Indica l'azione che è stata effettuata

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public CfgOperationCfgOpEnum Action { get; set; }
Public Property Action As CfgOperationCfgOpEnum
    Get
    Set
public:
property CfgOperationCfgOpEnum Action {
    CfgOperationCfgOpEnum get ();
    void set (CfgOperationCfgOpEnum value);
}
member Action : CfgOperationCfgOpEnum with get, set

Valore della proprietà

CfgOperationCfgOpEnum
Vedi anche

Documentazione

Classe CfgOperation
Namespace DedNet.Core


Proprietà CfgOperation.Cfgkey

Proprietà CfgOperationCfgkey
Chiave che rappresenta la configurazione

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Cfgkey { get; set; }
Public Property Cfgkey As String
    Get
    Set
public:
property String^ Cfgkey {
    String^ get ();
    void set (String^ value);
}
member Cfgkey : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe CfgOperation
Namespace DedNet.Core


Proprietà CfgOperation.Date

Proprietà CfgOperationDate
Indica la data in cui è stata fatta l'operazione

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DateTime? Date { get; set; }
Public Property Date As DateTime?
    Get
    Set
public:
property Nullable<DateTime> Date {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
member Date : Nullable<DateTime> with get, set

Valore della proprietà

Nullable DateTime
Vedi anche

Documentazione

Classe CfgOperation
Namespace DedNet.Core


Proprietà CfgOperation.Docid

Proprietà CfgOperationDocid
Docid del documento

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Guid Docid { get; set; }
Public Property Docid As Guid
    Get
    Set
public:
property Guid Docid {
    Guid get ();
    void set (Guid value);
}
member Docid : Guid with get, set

Valore della proprietà

Guid
Vedi anche

Documentazione

Classe CfgOperation
Namespace DedNet.Core


Proprietà CfgOperation.Newname

Proprietà CfgOperationNewname
Nuovo nome della configurazione dopo l'operazione

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Newname { get; set; }
Public Property Newname As String
    Get
    Set
public:
property String^ Newname {
    String^ get ();
    void set (String^ value);
}
member Newname : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe CfgOperation
Namespace DedNet.Core


Proprietà CfgOperation.Oldname

Proprietà CfgOperationOldname
Vecchio nome della configurazione prima dell'operazione

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Oldname { get; set; }
Public Property Oldname As String
    Get
    Set
public:
property String^ Oldname {
    String^ get ();
    void set (String^ value);
}
member Oldname : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe CfgOperation
Namespace DedNet.Core


Proprietà CfgOperation.Published

Proprietà CfgOperationPublished
Indica se l'operazione è già stat pubblicata

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Published { get; set; }
Public Property Published As Boolean
    Get
    Set
public:
property bool Published {
    bool get ();
    void set (bool value);
}
member Published : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CfgOperation
Namespace DedNet.Core


Enumerazione CfgOperation.CfgOpEnum

Enumerazione CfgOperationCfgOpEnum
Enum con gli stati delle operazioni sulle configurazioni

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum CfgOpEnum
Public Enumeration CfgOpEnum
public enum class CfgOpEnum
type CfgOpEnum
Membri
Nome | Valore | Descrizione
Add | 1 | Configurazione aggiunta
Rename | 2 | Configurazione rinominata
Delete | 3 | Configurazione cancellata
Vedi anche

Documentazione

Namespace DedNet.Core


Classe CfgOperationList
Classe che rappresenta la lista delle operazioni sulle configurazioni
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList CfgOperation
DedNet.CoreCfgOperationList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class CfgOperationList : List<CfgOperation>
Public Class CfgOperationList
    Inherits List(Of CfgOperation)
public ref class CfgOperationList : public List<CfgOperation^>
type CfgOperationList =
    class
        inherit List<CfgOperation>
    end

Il tipo CfgOperationList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | CfgOperationList |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | GetAllCfgNames | Restiruisce la lista di tutti i nomi che tale configurazione ha avuto.
Metodo pubblico | GetFirstOperationName | Restituisce il nome della configurazione nella sua prima operazione.
Metodo pubblico | IsNewCfg | Restituisce true se nella lista è presente un'operazione di Add Significa che è una configurazione nuova
Metodo pubblico | WasDeleted | Restituisce true se nella lista è presente un'operazione di Add Significa che è una configurazione nuova
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore CfgOperationList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public CfgOperationList()
Public Sub New
public:
CfgOperationList()
new : unit -> CfgOperationList
Vedi anche

Documentazione

Classe CfgOperationList
Namespace DedNet.Core


Metodi di CfgOperationList

Il tipo CfgOperationList espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | GetAllCfgNames | Restiruisce la lista di tutti i nomi che tale configurazione ha avuto.
Metodo pubblico | GetFirstOperationName | Restituisce il nome della configurazione nella sua prima operazione.
Metodo pubblico | IsNewCfg | Restituisce true se nella lista è presente un'operazione di Add Significa che è una configurazione nuova
Metodo pubblico | WasDeleted | Restituisce true se nella lista è presente un'operazione di Add Significa che è una configurazione nuova
Torna su
Vedi anche

Documentazione

Classe CfgOperationList
Namespace DedNet.Core


Metodo CfgOperationList.GetAllCfgNames

Metodo CfgOperationListGetAllCfgNames
Restiruisce la lista di tutti i nomi che tale configurazione ha avuto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> GetAllCfgNames(
    bool excludePublished = false
)
Public Function GetAllCfgNames (
    Optional excludePublished As Boolean = false
) As List(Of String)
public:
List<String^>^ GetAllCfgNames(
    bool excludePublished = false
)
member GetAllCfgNames :
        ?excludePublished : bool
(* Defaults:
        let _excludePublished = defaultArg excludePublished false
*)
-> List<string>

Parametri

excludePublished Boolean (Optional)
Indica se non cosiderare le operazioni già pubblicate

Valore di ritorno

List String
Vedi anche

Documentazione

Classe CfgOperationList
Namespace DedNet.Core


Metodo CfgOperationList.GetFirstOperationName

Metodo CfgOperationListGetFirstOperationName
Restituisce il nome della configurazione nella sua prima operazione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string GetFirstOperationName(
    bool excludePublished = false
)
Public Function GetFirstOperationName (
    Optional excludePublished As Boolean = false
) As String
public:
String^ GetFirstOperationName(
    bool excludePublished = false
)
member GetFirstOperationName :
        ?excludePublished : bool
(* Defaults:
        let _excludePublished = defaultArg excludePublished false
*)
-> string

Parametri

excludePublished Boolean (Optional)
Indica se non cosiderare le operazioni già pubblicate

Valore di ritorno

String
Vedi anche

Documentazione

Classe CfgOperationList
Namespace DedNet.Core


Metodo CfgOperationList.IsNewCfg

Metodo CfgOperationListIsNewCfg
Restituisce true se nella lista è presente un'operazione di Add Significa che è una configurazione nuova

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsNewCfg(
    bool excludePublished = false
)
Public Function IsNewCfg (
    Optional excludePublished As Boolean = false
) As Boolean
public:
bool IsNewCfg(
    bool excludePublished = false
)
member IsNewCfg :
        ?excludePublished : bool
(* Defaults:
        let _excludePublished = defaultArg excludePublished false
*)
-> bool

Parametri

excludePublished Boolean (Optional)
Indica se non cosiderare le operazioni già pubblicate

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe CfgOperationList
Namespace DedNet.Core


Metodo CfgOperationList.WasDeleted

Metodo CfgOperationListWasDeleted
Restituisce true se nella lista è presente un'operazione di Add Significa che è una configurazione nuova

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool WasDeleted(
    bool excludePublished = false
)
Public Function WasDeleted (
    Optional excludePublished As Boolean = false
) As Boolean
public:
bool WasDeleted(
    bool excludePublished = false
)
member WasDeleted :
        ?excludePublished : bool
(* Defaults:
        let _excludePublished = defaultArg excludePublished false
*)
-> bool

Parametri

excludePublished Boolean (Optional)
Indica se non cosiderare le operazioni già pubblicate

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe CfgOperationList
Namespace DedNet.Core


Classe CfgOperations
Classse che rappresenta un dizionario chiave configurazioni con lista delle operazioni su tale chiave
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericDictionary String, CfgOperationList
DedNet.CoreCfgOperations

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class CfgOperations : Dictionary<string, CfgOperationList>
Public Class CfgOperations
    Inherits Dictionary(Of String, CfgOperationList)
public ref class CfgOperations : public Dictionary<String^, CfgOperationList^>
type CfgOperations =
    class
        inherit Dictionary<string, CfgOperationList>
    end

Il tipo CfgOperations espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | CfgOperations |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AddOperation | Aggiunge l'operazione al dizionario
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore CfgOperations

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public CfgOperations()
Public Sub New
public:
CfgOperations()
new : unit -> CfgOperations
Vedi anche

Documentazione

Classe CfgOperations
Namespace DedNet.Core


Metodi di CfgOperations

Il tipo CfgOperations espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AddOperation | Aggiunge l'operazione al dizionario
Torna su
Vedi anche

Documentazione

Classe CfgOperations
Namespace DedNet.Core


Metodo CfgOperations.AddOperation

Metodo CfgOperationsAddOperation
Aggiunge l'operazione al dizionario

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddOperation(
    CfgOperation cfgop
)
Public Sub AddOperation (
    cfgop As CfgOperation
)
public:
void AddOperation(
    CfgOperation^ cfgop
)
member AddOperation :
        cfgop : CfgOperation -> unit

Parametri

cfgop CfgOperation
Operazione da aggiungere
Vedi anche

Documentazione

Classe CfgOperations
Namespace DedNet.Core


Classe CompareBomItemByRicPos
Classe utilizzata per ordinare gli elementi di distinta in base al campo RIC_POS.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreCompareBomItemByRicPos

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class CompareBomItemByRicPos : IComparer<BomItem>
Public Class CompareBomItemByRicPos
    Implements IComparer(Of BomItem)
public ref class CompareBomItemByRicPos : IComparer<BomItem^>
type CompareBomItemByRicPos =
    class
        interface IComparer<BomItem>
    end

Il tipo CompareBomItemByRicPos espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | CompareBomItemByRicPos |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Compare | Metodo per comparare due oggetti.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore CompareBomItemByRicPos

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public CompareBomItemByRicPos()
Public Sub New
public:
CompareBomItemByRicPos()
new : unit -> CompareBomItemByRicPos
Vedi anche

Documentazione

Classe CompareBomItemByRicPos
Namespace DedNet.Core


Metodi di CompareBomItemByRicPos

Il tipo CompareBomItemByRicPos espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Compare | Metodo per comparare due oggetti.
Torna su
Vedi anche

Documentazione

Classe CompareBomItemByRicPos
Namespace DedNet.Core


Metodo CompareBomItemByRicPos.Compare

Metodo CompareBomItemByRicPosCompare
Metodo per comparare due oggetti.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int Compare(
    BomItem x,
    BomItem y
)
Public Function Compare (
    x As BomItem,
    y As BomItem
) As Integer
public:
virtual int Compare(
    BomItem^ x,
    BomItem^ y
) sealed
abstract Compare :
        x : BomItem *
        y : BomItem -> int
override Compare :
        x : BomItem *
        y : BomItem -> int

Parametri

x BomItem
Oggetto x.
y BomItem
Oggetto y.

Valore di ritorno

Int32

Implementa

IComparerTCompare(T, T)
Vedi anche

Documentazione

Classe CompareBomItemByRicPos
Namespace DedNet.Core


Classe ConfigDescriptor
Descrittore della configurazione
Gerarchia di ereditarietà
SystemObject
DedNet.CoreConfigDescriptor

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ConfigDescriptor
Public Class ConfigDescriptor
public ref class ConfigDescriptor
type ConfigDescriptor = class end

Il tipo ConfigDescriptor espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ConfigDescriptor | Costruttore senza parametri
Metodo pubblico | ConfigDescriptor(String) | Costruttore con nome
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Name |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore ConfigDescriptor
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | ConfigDescriptor | Costruttore senza parametri
Metodo pubblico | ConfigDescriptor(String) | Costruttore con nome
Torna su
Vedi anche

Documentazione

Classe ConfigDescriptor
Namespace DedNet.Core


Costruttore ConfigDescriptor
Costruttore senza parametri

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ConfigDescriptor()
Public Sub New
public:
ConfigDescriptor()
new : unit -> ConfigDescriptor
Vedi anche

Documentazione

Classe ConfigDescriptor
Overload di ConfigDescriptor
Namespace DedNet.Core


Costruttore ConfigDescriptor(String)
Costruttore con nome

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ConfigDescriptor(
    string name
)
Public Sub New (
    name As String
)
public:
ConfigDescriptor(
    String^ name
)
new :
        name : string -> ConfigDescriptor

Parametri

name String
Vedi anche

Documentazione

Classe ConfigDescriptor
Overload di ConfigDescriptor
Namespace DedNet.Core


Proprietà di ConfigDescriptor

Il tipo ConfigDescriptor espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Name |
Torna su
Vedi anche

Documentazione

Classe ConfigDescriptor
Namespace DedNet.Core


Proprietà ConfigDescriptor.Name

Proprietà ConfigDescriptorName

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe ConfigDescriptor
Namespace DedNet.Core


Classe DedAlternativeDataCollection
Classe utilizzata per gestire i codici alternativi di una anagrafica. Questa classe eredita dalla classe 'HashSet' in modo tale da non permettere l'inserimento di duplicati.
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericHashSet DedData
DedNet.CoreDedAlternativeDataCollection

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedAlternativeDataCollection : HashSet<DedData>
Public Class DedAlternativeDataCollection
    Inherits HashSet(Of DedData)
public ref class DedAlternativeDataCollection : public HashSet<DedData^>
type DedAlternativeDataCollection =
    class
        inherit HashSet<DedData>
    end

Il tipo DedAlternativeDataCollection espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedAlternativeDataCollection | Crea una nuova istanza della classe 'DedAlternativeDataCollection' utilizzata per gestire i codici alternativi di una anagrafica.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Dirty | Indica se l'oggetto ha delle modifiche appese da salvare.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Add | Aggiunge l'elemento alla lista.
Metodo pubblico | AddToAll | Aggiunge l'elemento alla lista effettuando l'associazione anche tra i vari elementi che la compongono.
Metodo pubblico | Load | Legge dal db le anagrafiche alternative associate a quella corrente.
Metodo pubblico | Save | Salva eventuali modifiche appese.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedAlternativeDataCollection
Crea una nuova istanza della classe 'DedAlternativeDataCollection' utilizzata per gestire i codici alternativi di una anagrafica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAlternativeDataCollection(
    DedNetApplication app,
    DedData data
)
Public Sub New (
    app As DedNetApplication,
    data As DedData
)
public:
DedAlternativeDataCollection(
    DedNetApplication^ app,
    DedData^ data
)
new :
        app : DedNetApplication *
        data : DedData -> DedAlternativeDataCollection

Parametri

app DedNetApplication
Applicazione DedNet.
data DedData
Anagraica di cui si vogliono ottenere i codici alternativi.
Vedi anche

Documentazione

Classe DedAlternativeDataCollection
Namespace DedNet.Core


Proprietà di DedAlternativeDataCollection

Il tipo DedAlternativeDataCollection espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Dirty | Indica se l'oggetto ha delle modifiche appese da salvare.
Torna su
Vedi anche

Documentazione

Classe DedAlternativeDataCollection
Namespace DedNet.Core


Proprietà DedAlternativeDataCollection.Dirty

Proprietà DedAlternativeDataCollectionDirty
Indica se l'oggetto ha delle modifiche appese da salvare.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Dirty { get; }
Public ReadOnly Property Dirty As Boolean
    Get
public:
property bool Dirty {
    bool get ();
}
member Dirty : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAlternativeDataCollection
Namespace DedNet.Core


Metodi di DedAlternativeDataCollection

Il tipo DedAlternativeDataCollection espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Add | Aggiunge l'elemento alla lista.
Metodo pubblico | AddToAll | Aggiunge l'elemento alla lista effettuando l'associazione anche tra i vari elementi che la compongono.
Metodo pubblico | Load | Legge dal db le anagrafiche alternative associate a quella corrente.
Metodo pubblico | Save | Salva eventuali modifiche appese.
Torna su
Vedi anche

Documentazione

Classe DedAlternativeDataCollection
Namespace DedNet.Core


Metodo DedAlternativeDataCollection.Add

Metodo DedAlternativeDataCollectionAdd
Aggiunge l'elemento alla lista.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Add(
    DedData item
)
Public Function Add (
    item As DedData
) As Boolean
public:
bool Add(
    DedData^ item
)
member Add :
        item : DedData -> bool

Parametri

item DedData

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedAlternativeDataCollection
Namespace DedNet.Core


Metodo DedAlternativeDataCollection.AddToAll

Metodo DedAlternativeDataCollectionAddToAll
Aggiunge l'elemento alla lista effettuando l'associazione anche tra i vari elementi che la compongono.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddToAll(
    DedData item
)
Public Sub AddToAll (
    item As DedData
)
public:
void AddToAll(
    DedData^ item
)
member AddToAll :
        item : DedData -> unit

Parametri

item DedData
Vedi anche

Documentazione

Classe DedAlternativeDataCollection
Namespace DedNet.Core


Metodo DedAlternativeDataCollection.Load

Metodo DedAlternativeDataCollectionLoad
Legge dal db le anagrafiche alternative associate a quella corrente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Load()
Public Sub Load
public:
void Load()
member Load : unit -> unit
Vedi anche

Documentazione

Classe DedAlternativeDataCollection
Namespace DedNet.Core


Metodo DedAlternativeDataCollection.Save

Metodo DedAlternativeDataCollectionSave
Salva eventuali modifiche appese.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Save()
Public Sub Save
public:
void Save()
member Save : unit -> unit
Vedi anche

Documentazione

Classe DedAlternativeDataCollection
Namespace DedNet.Core


Classe DedAtt
Gestisce una lista di valori da utilizzare per la compilazione di un attributo. L'oggetto DedAtt contiene riferimenti ai vari oggetti DedAttItem descriventi una singola voce.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedDbCollectionBase DedAttItem
DedNet.CoreDedAtt

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedAtt : DedDbCollectionBase<DedAttItem>
Public Class DedAtt
    Inherits DedDbCollectionBase(Of DedAttItem)
public ref class DedAtt : public DedDbCollectionBase<DedAttItem^>
type DedAtt =
    class
        inherit DedDbCollectionBase<DedAttItem>
    end

Il tipo DedAtt espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedAtt | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllowsDuplicates | Restituisce se siano ammessi duplicati all'interno della lista. Se false viene sollevata una eccezione su tentativo di inserimento duplicati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Application | Restituisce l'oggetto applicazione di appartenza. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Count | Restituisce il numero di elementi presenti. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Dirty | Restituisce se la collezione o uno dei suoi elementi sia stata modificata. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | ErasedItems | Restitusice la lista in sola lettura degli elementi che risultano attualmente cancellati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | IsValid | Indica se la lista è valida (non ci sono valori uguali).
Proprietà pubblica | ItemsHasDescription | Verifica se almeno un elemento della lista abbia la descrizione compilata.
Proprietà pubblica | LastItem | Restituisce l'ultimo elemento della collezione oppure null se non ci sono elementi. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Name | Restituisce il nome della lista.
Proprietà pubblica | RestoreErased | Restituisce se gli elementi cancellati devono essere ripristinati in caso vengano riaggiunti. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | User | Restituisce l'utente della lista.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Add(DedAttItem) | Aggiunge alla collezione un elemento già esistente. Gli imposta già come padre la nuova collezione.
Metodo pubblico | Add(String, String, String) | Aggiunge un elemento accodandolo alla lista.
Metodo protetto | AddForClone | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto SENZA MODIFICARNE LO STATO. Le classi derivate potranno utilizzare questo metodo per clonare la collezione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddNewElement | DI USO INTERNO. Aggiunge un elemento alla lista rendendo dirty l'oggetto. L'elemento viene aggiunto con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere un elemento alla lista. Dovranno loro stesse avere un metodo pubblico Add() che prenda i parametri necessari alla costruzione dell'oggetto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddRangeNewElement | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi rendendo dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere più elementi alla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddUnModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Clear | Elimina tutti gli elementi dalla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ClearRefresh | Svuota la lista impostando Dirty = false. Di fatto permette di effettuare un refresh della lista e quindi di ricaricarla. Serve per svuotare la lista e reinizializzarla da capo. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Clone | Metodo per clonare la lista di attributi abbinati alle famiglie.
Metodo pubblico | Contains | Verifica l'esistenza di un valore all'interno della lista degli elementi. Le classi derivate devono effettuarne l'override nel caso in cui l'elemento non implementi GetHashCode() per l'uso all'interno dei dizionarii. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | CopyTo | Copia un range di elementi in un array. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | CreateDeleteCommand | Crea, inizializza e restituisce il comando per l'eliminazione di un elemento. (Sovrascrive DedDbCollectionBaseTCreateDeleteCommand(T))
Metodo protetto | CreateInsertCommand | Crea, inizializza e restituisce il comando per l'inserimento di un elemento. (Sovrascrive DedDbCollectionBaseTCreateInsertCommand(T))
Metodo protetto | CreateUpdateCommand | Crea, inizializza e restituisce il comando per l'aggiornamento di un elemento. (Sovrascrive DedDbCollectionBaseTCreateUpdateCommand(T))
Metodo pubblico | CustomSort | Ordina la lista e mette a posto gli indici di Ord per rendere dirty gli oggetti. (Sovrascrive DedDbCollectionBaseTCustomSort(IComparerT))
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo protetto | ExecuteDeleteItem | Esegue l'eliminazione di un elemento. Crea il comando tramite il metodo CreateDeleteCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteInsertItem | Esegue l'inserimento di un elemento. Crea il comando tramite il metodo CreateInsertCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteUpdateItem | Esegue l'aggiornamento di un elemento. Crea il comando tramite il metodo CreateUpdateCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Find | Restituisce l'oggetto cercato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FindAll | Restitusice la lista degli elementi che corrispondono al predicato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | GetAltValFromValue | Restituisce il valore alternativo del valore passato.
Metodo protetto | GetDbIndex | Restituisce l'indice dell'elemento passato: cioè il valore dell'elemento. (Sovrascrive DedDbCollectionBaseTGetDbIndex(T))
Metodo pubblico | GetDescriptionFromValue | Restituisce la descrizione del valore passato.
Metodo pubblico | GetEnumerator | Restituisce l'enumeratore della collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | IndexOf | Restituisce l'indice dell'elemento richiesto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InsertUnModified | DI USO INTERNO. Inserisce un elemento alla lista senza rendere dirty l'oggetto, all'indice specificato. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Item | Restituisce l'elemento iesimo della lista. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean) | Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi. (Sovrascrive DedDbCollectionBaseTMove(Int32, Boolean))
Metodo pubblico | Move(Int32, Boolean, Int32) | Sposta l'elemento dell'indice passato prima o dopo del numero di posizioni passate. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSave | Metodo Template chiamato dopo il salvataggio avvenuto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSaveNoChanges | Metodo Template chiamato dopo il salvataggio senza modifiche. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnBeforeSave | Metodo Template chiamato prima del salvataggio. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(T) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(DedEditableObjectT) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(T) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(DedEditableObjectT) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ReInitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Remove | Elimina un elemento dalla collezione. (Sovrascrive DedDbCollectionBaseTRemove(T))
Metodo pubblico | Ripristina | Verifica che l'elemento sia presente negli eliminati e lo toglie da lì e lo riaggiunge in coda alla lista degli elementi validi. Solleva una eccezione se l'elemento è già presente nella lista e AllowsDuplicates = false. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Save | Salva l'oggetto con tutta la sua lista, solo se questo risulta dirty. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedAtt
Costruttore unico.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAtt(
    DedNetApplication app,
    string name,
    string user
)
Public Sub New (
    app As DedNetApplication,
    name As String,
    user As String
)
public:
DedAtt(
    DedNetApplication^ app,
    String^ name,
    String^ user
)
new :
        app : DedNetApplication *
        name : string *
        user : string -> DedAtt

Parametri

app DedNetApplication
Applicazione di appartenenza.
name String
Nome della lista.
user String
Utente della lista.
Vedi anche

Documentazione

Classe DedAtt
Namespace DedNet.Core


Proprietà di DedAtt

Il tipo DedAtt espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllowsDuplicates | Restituisce se siano ammessi duplicati all'interno della lista. Se false viene sollevata una eccezione su tentativo di inserimento duplicati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Application | Restituisce l'oggetto applicazione di appartenza. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Count | Restituisce il numero di elementi presenti. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Dirty | Restituisce se la collezione o uno dei suoi elementi sia stata modificata. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | ErasedItems | Restitusice la lista in sola lettura degli elementi che risultano attualmente cancellati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | IsValid | Indica se la lista è valida (non ci sono valori uguali).
Proprietà pubblica | ItemsHasDescription | Verifica se almeno un elemento della lista abbia la descrizione compilata.
Proprietà pubblica | LastItem | Restituisce l'ultimo elemento della collezione oppure null se non ci sono elementi. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Name | Restituisce il nome della lista.
Proprietà pubblica | RestoreErased | Restituisce se gli elementi cancellati devono essere ripristinati in caso vengano riaggiunti. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | User | Restituisce l'utente della lista.
Torna su
Vedi anche

Documentazione

Classe DedAtt
Namespace DedNet.Core


Proprietà DedAtt.IsValid

Proprietà DedAttIsValid
Indica se la lista è valida (non ci sono valori uguali).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsValid { get; }
Public ReadOnly Property IsValid As Boolean
    Get
public:
property bool IsValid {
    bool get ();
}
member IsValid : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAtt
Namespace DedNet.Core


Proprietà DedAtt.ItemsHasDescription

Proprietà DedAttItemsHasDescription
Verifica se almeno un elemento della lista abbia la descrizione compilata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ItemsHasDescription { get; }
Public ReadOnly Property ItemsHasDescription As Boolean
    Get
public:
property bool ItemsHasDescription {
    bool get ();
}
member ItemsHasDescription : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAtt
Namespace DedNet.Core


Proprietà DedAtt.Name

Proprietà DedAttName
Restituisce il nome della lista.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedAtt
Namespace DedNet.Core


Proprietà DedAtt.User

Proprietà DedAttUser
Restituisce l'utente della lista.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string User { get; }
Public ReadOnly Property User As String
    Get
public:
property String^ User {
    String^ get ();
}
member User : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedAtt
Namespace DedNet.Core


Metodi di DedAtt

Il tipo DedAtt espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Add(DedAttItem) | Aggiunge alla collezione un elemento già esistente. Gli imposta già come padre la nuova collezione.
Metodo pubblico | Add(String, String, String) | Aggiunge un elemento accodandolo alla lista.
Metodo protetto | AddForClone | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto SENZA MODIFICARNE LO STATO. Le classi derivate potranno utilizzare questo metodo per clonare la collezione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddNewElement | DI USO INTERNO. Aggiunge un elemento alla lista rendendo dirty l'oggetto. L'elemento viene aggiunto con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere un elemento alla lista. Dovranno loro stesse avere un metodo pubblico Add() che prenda i parametri necessari alla costruzione dell'oggetto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddRangeNewElement | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi rendendo dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere più elementi alla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddUnModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Clear | Elimina tutti gli elementi dalla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ClearRefresh | Svuota la lista impostando Dirty = false. Di fatto permette di effettuare un refresh della lista e quindi di ricaricarla. Serve per svuotare la lista e reinizializzarla da capo. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Clone | Metodo per clonare la lista di attributi abbinati alle famiglie.
Metodo pubblico | Contains | Verifica l'esistenza di un valore all'interno della lista degli elementi. Le classi derivate devono effettuarne l'override nel caso in cui l'elemento non implementi GetHashCode() per l'uso all'interno dei dizionarii. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | CopyTo | Copia un range di elementi in un array. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | CreateDeleteCommand | Crea, inizializza e restituisce il comando per l'eliminazione di un elemento. (Sovrascrive DedDbCollectionBaseTCreateDeleteCommand(T))
Metodo protetto | CreateInsertCommand | Crea, inizializza e restituisce il comando per l'inserimento di un elemento. (Sovrascrive DedDbCollectionBaseTCreateInsertCommand(T))
Metodo protetto | CreateUpdateCommand | Crea, inizializza e restituisce il comando per l'aggiornamento di un elemento. (Sovrascrive DedDbCollectionBaseTCreateUpdateCommand(T))
Metodo pubblico | CustomSort | Ordina la lista e mette a posto gli indici di Ord per rendere dirty gli oggetti. (Sovrascrive DedDbCollectionBaseTCustomSort(IComparerT))
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo protetto | ExecuteDeleteItem | Esegue l'eliminazione di un elemento. Crea il comando tramite il metodo CreateDeleteCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteInsertItem | Esegue l'inserimento di un elemento. Crea il comando tramite il metodo CreateInsertCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteUpdateItem | Esegue l'aggiornamento di un elemento. Crea il comando tramite il metodo CreateUpdateCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Find | Restituisce l'oggetto cercato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FindAll | Restitusice la lista degli elementi che corrispondono al predicato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | GetAltValFromValue | Restituisce il valore alternativo del valore passato.
Metodo protetto | GetDbIndex | Restituisce l'indice dell'elemento passato: cioè il valore dell'elemento. (Sovrascrive DedDbCollectionBaseTGetDbIndex(T))
Metodo pubblico | GetDescriptionFromValue | Restituisce la descrizione del valore passato.
Metodo pubblico | GetEnumerator | Restituisce l'enumeratore della collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | IndexOf | Restituisce l'indice dell'elemento richiesto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InsertUnModified | DI USO INTERNO. Inserisce un elemento alla lista senza rendere dirty l'oggetto, all'indice specificato. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Item | Restituisce l'elemento iesimo della lista. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean) | Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi. (Sovrascrive DedDbCollectionBaseTMove(Int32, Boolean))
Metodo pubblico | Move(Int32, Boolean, Int32) | Sposta l'elemento dell'indice passato prima o dopo del numero di posizioni passate. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSave | Metodo Template chiamato dopo il salvataggio avvenuto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSaveNoChanges | Metodo Template chiamato dopo il salvataggio senza modifiche. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnBeforeSave | Metodo Template chiamato prima del salvataggio. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(T) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(DedEditableObjectT) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(T) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(DedEditableObjectT) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ReInitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Remove | Elimina un elemento dalla collezione. (Sovrascrive DedDbCollectionBaseTRemove(T))
Metodo pubblico | Ripristina | Verifica che l'elemento sia presente negli eliminati e lo toglie da lì e lo riaggiunge in coda alla lista degli elementi validi. Solleva una eccezione se l'elemento è già presente nella lista e AllowsDuplicates = false. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Save | Salva l'oggetto con tutta la sua lista, solo se questo risulta dirty. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Torna su
Vedi anche

Documentazione

Classe DedAtt
Namespace DedNet.Core


Metodo DedAtt.Add

Metodo DedAttAdd
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Add(DedAttItem) | Aggiunge alla collezione un elemento già esistente. Gli imposta già come padre la nuova collezione.
Metodo pubblico | Add(String, String, String) | Aggiunge un elemento accodandolo alla lista.
Torna su
Vedi anche

Documentazione

Classe DedAtt
Namespace DedNet.Core


Metodo DedAtt.Add(DedAttItem)

Metodo DedAttAdd(DedAttItem)
Aggiunge alla collezione un elemento già esistente. Gli imposta già come padre la nuova collezione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Add(
    DedAttItem att
)
Public Sub Add (
    att As DedAttItem
)
public:
void Add(
    DedAttItem^ att
)
member Add :
        att : DedAttItem -> unit

Parametri

att DedAttItem
Vedi anche

Documentazione

Classe DedAtt
Overload di Add
Namespace DedNet.Core


Metodo DedAtt.Add(String, String, String)

Metodo DedAttAdd(String, String, String)
Aggiunge un elemento accodandolo alla lista.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttItem Add(
    string val,
    string desc,
    string valoreAlt
)
Public Function Add (
    val As String,
    desc As String,
    valoreAlt As String
) As DedAttItem
public:
DedAttItem^ Add(
    String^ val,
    String^ desc,
    String^ valoreAlt
)
member Add :
        val : string *
        desc : string *
        valoreAlt : string -> DedAttItem

Parametri

val String
Valore dell'elemento.
desc String
Descrizione.
valoreAlt String
Valore alternativo.

Valore di ritorno

DedAttItem
Restituisce l'elemento appena aggiunto.
Vedi anche

Documentazione

Classe DedAtt
Overload di Add
Namespace DedNet.Core


Metodo DedAtt.Clone

Metodo DedAttClone
Metodo per clonare la lista di attributi abbinati alle famiglie.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAtt Clone()
Public Function Clone As DedAtt
public:
DedAtt^ Clone()
member Clone : unit -> DedAtt

Valore di ritorno

DedAtt
Vedi anche

Documentazione

Classe DedAtt
Namespace DedNet.Core


Metodo DedAtt.CreateDeleteCommand

Metodo DedAttCreateDeleteCommand
Crea, inizializza e restituisce il comando per l'eliminazione di un elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSDeleteCommand CreateDeleteCommand(
    DedAttItem item
)
Protected Overrides Function CreateDeleteCommand (
    item As DedAttItem
) As QSDeleteCommand
protected:
virtual QSDeleteCommand^ CreateDeleteCommand(
    DedAttItem^ item
) override
abstract CreateDeleteCommand :
        item : DedAttItem -> QSDeleteCommand
override CreateDeleteCommand :
        item : DedAttItem -> QSDeleteCommand

Parametri

item DedAttItem
Elemento da utilizzare per inizializzare il comando.

Valore di ritorno

QSDeleteCommand
Il comando inizializzato, pronto per essere eseguito.
Vedi anche

Documentazione

Classe DedAtt
Namespace DedNet.Core


Metodo DedAtt.CreateInsertCommand

Metodo DedAttCreateInsertCommand
Crea, inizializza e restituisce il comando per l'inserimento di un elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSInsertCommand CreateInsertCommand(
    DedAttItem item
)
Protected Overrides Function CreateInsertCommand (
    item As DedAttItem
) As QSInsertCommand
protected:
virtual QSInsertCommand^ CreateInsertCommand(
    DedAttItem^ item
) override
abstract CreateInsertCommand :
        item : DedAttItem -> QSInsertCommand
override CreateInsertCommand :
        item : DedAttItem -> QSInsertCommand

Parametri

item DedAttItem
Elemento da utilizzare per inizializzare il comando.

Valore di ritorno

QSInsertCommand
Il comando inizializzato, pronto per essere eseguito.
Vedi anche

Documentazione

Classe DedAtt
Namespace DedNet.Core


Metodo DedAtt.CreateUpdateCommand

Metodo DedAttCreateUpdateCommand
Crea, inizializza e restituisce il comando per l'aggiornamento di un elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSUpdateCommand CreateUpdateCommand(
    DedAttItem item
)
Protected Overrides Function CreateUpdateCommand (
    item As DedAttItem
) As QSUpdateCommand
protected:
virtual QSUpdateCommand^ CreateUpdateCommand(
    DedAttItem^ item
) override
abstract CreateUpdateCommand :
        item : DedAttItem -> QSUpdateCommand
override CreateUpdateCommand :
        item : DedAttItem -> QSUpdateCommand

Parametri

item DedAttItem
Elemento da utilizzare per inizializzare il comando.

Valore di ritorno

QSUpdateCommand
Il comando inizializzato, pronto per essere eseguito.
Vedi anche

Documentazione

Classe DedAtt
Namespace DedNet.Core


Metodo DedAtt.CustomSort

Metodo DedAttCustomSort
Ordina la lista e mette a posto gli indici di Ord per rendere dirty gli oggetti.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void CustomSort(
    IComparer<DedAttItem> comparer
)
Public Overrides Sub CustomSort (
    comparer As IComparer(Of DedAttItem)
)
public:
virtual void CustomSort(
    IComparer<DedAttItem^>^ comparer
) override
abstract CustomSort :
        comparer : IComparer<DedAttItem> -> unit
override CustomSort :
        comparer : IComparer<DedAttItem> -> unit

Parametri

comparer IComparer DedAttItem
Oggetto comparatore.
Vedi anche

Documentazione

Classe DedAtt
Namespace DedNet.Core


Metodo DedAtt.Equals

Metodo DedAttEquals

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj Object

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedAtt
Namespace DedNet.Core


Metodo DedAtt.GetAltValFromValue

Metodo DedAttGetAltValFromValue
Restituisce il valore alternativo del valore passato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object GetAltValFromValue(
    Object value
)
Public Function GetAltValFromValue (
    value As Object
) As Object
public:
Object^ GetAltValFromValue(
    Object^ value
)
member GetAltValFromValue :
        value : Object -> Object

Parametri

value Object
Valore della tendina.

Valore di ritorno

Object
Vedi anche

Documentazione

Classe DedAtt
Namespace DedNet.Core


Metodo DedAtt.GetDbIndex

Metodo DedAttGetDbIndex
Restituisce l'indice dell'elemento passato: cioè il valore dell'elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override Object GetDbIndex(
    DedAttItem item
)
Protected Overrides Function GetDbIndex (
    item As DedAttItem
) As Object
protected:
virtual Object^ GetDbIndex(
    DedAttItem^ item
) override
abstract GetDbIndex :
        item : DedAttItem -> Object
override GetDbIndex :
        item : DedAttItem -> Object

Parametri

item DedAttItem
Elemento del quale restituire l'indice.

Valore di ritorno

Object
Restituisce l'indice dell'elemento oppure null.
Vedi anche

Documentazione

Classe DedAtt
Namespace DedNet.Core


Metodo DedAtt.GetDescriptionFromValue

Metodo DedAttGetDescriptionFromValue
Restituisce la descrizione del valore passato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object GetDescriptionFromValue(
    Object value
)
Public Function GetDescriptionFromValue (
    value As Object
) As Object
public:
Object^ GetDescriptionFromValue(
    Object^ value
)
member GetDescriptionFromValue :
        value : Object -> Object

Parametri

value Object
Valore della tendina.

Valore di ritorno

Object
Vedi anche

Documentazione

Classe DedAtt
Namespace DedNet.Core


Metodo DedAtt.GetHashCode

Metodo DedAttGetHashCode

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedAtt
Namespace DedNet.Core


Metodo DedAtt.Move

Metodo DedAttMove
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Move(Int32, Boolean) | Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi.
Metodo pubblico | Move(Int32, Boolean, Int32) | Sposta l'elemento dell'indice passato prima o dopo del numero di posizioni passate. Ignora eventuali valori di indice non validi.
Torna su
Vedi anche

Documentazione

Classe DedAtt
Namespace DedNet.Core


Metodo DedAtt.Move(Int32, Boolean)

Metodo DedAttMove(Int32, Boolean)
Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void Move(
    int index,
    bool up
)
Public Overrides Sub Move (
    index As Integer,
    up As Boolean
)
public:
virtual void Move(
    int index,
    bool up
) override
abstract Move :
        index : int *
        up : bool -> unit
override Move :
        index : int *
        up : bool -> unit

Parametri

index Int32
Indice dell'elemento da spostare.
up Boolean
Se true l'elemento viene spostato in alto (nell'indice precedente) altrimenti all'indice successivo.
Vedi anche

Documentazione

Classe DedAtt
Overload di Move
Namespace DedNet.Core


Metodo DedAtt.Remove

Metodo DedAttRemove
Elimina un elemento dalla collezione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void Remove(
    DedAttItem item
)
Public Overrides Sub Remove (
    item As DedAttItem
)
public:
virtual void Remove(
    DedAttItem^ item
) override
abstract Remove :
        item : DedAttItem -> unit
override Remove :
        item : DedAttItem -> unit

Parametri

item DedAttItem
Elemento da eliminare.
Vedi anche

Documentazione

Classe DedAtt
Namespace DedNet.Core


Metodo DedAtt.ToString

Metodo DedAttToString

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedAtt
Namespace DedNet.Core


Classe DedAttComparer
Classe per oridnare gli elementi in base al campo Valore in modo crescente o decrescente.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedAttComparer

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedAttComparer : IComparer<DedAttItem>
Public Class DedAttComparer
    Implements IComparer(Of DedAttItem)
public ref class DedAttComparer : IComparer<DedAttItem^>
type DedAttComparer =
    class
        interface IComparer<DedAttItem>
    end

Il tipo DedAttComparer espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedAttComparer | Costruttore.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Compare | Metodo per comparare due oggetti.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedAttComparer
Costruttore.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttComparer(
    bool asc
)
Public Sub New (
    asc As Boolean
)
public:
DedAttComparer(
    bool asc
)
new :
        asc : bool -> DedAttComparer

Parametri

asc Boolean
Se true ordina in modo crescente altrimenti descresente
Vedi anche

Documentazione

Classe DedAttComparer
Namespace DedNet.Core


Metodi di DedAttComparer

Il tipo DedAttComparer espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Compare | Metodo per comparare due oggetti.
Torna su
Vedi anche

Documentazione

Classe DedAttComparer
Namespace DedNet.Core


Metodo DedAttComparer.Compare

Metodo DedAttComparerCompare
Metodo per comparare due oggetti.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int Compare(
    DedAttItem x,
    DedAttItem y
)
Public Function Compare (
    x As DedAttItem,
    y As DedAttItem
) As Integer
public:
virtual int Compare(
    DedAttItem^ x,
    DedAttItem^ y
) sealed
abstract Compare :
        x : DedAttItem *
        y : DedAttItem -> int
override Compare :
        x : DedAttItem *
        y : DedAttItem -> int

Parametri

x DedAttItem
Oggetto x
y DedAttItem
Oggetto y

Valore di ritorno

Int32

Implementa

IComparerTCompare(T, T)
Vedi anche

Documentazione

Classe DedAttComparer
Namespace DedNet.Core


Classe DedAttItem
Definisce un elemento della lista DedAtt.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedAttItem

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedAttItem : IDedDbItem
Public Class DedAttItem
    Implements IDedDbItem
public ref class DedAttItem : IDedDbItem
type DedAttItem =
    class
        interface IDedDbItem
    end

Il tipo DedAttItem espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedAttItem | Inizializzo l'oggetto con tutti i campi.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AltValue | Restituisce o imposta il valore alternativo dell'elemento.
Proprietà pubblica | Description | Restituisce o imposta la descrizione dell'elemento.
Proprietà pubblica | Ord | Restituisce l'indice ordinale dell'elemento (parte da 1).
Proprietà pubblica | Parent | Restituisce la collezione di appartenenza dell'elemento.
Proprietà pubblica | StatoRecord | Restituisce o imposta lo stato del record. DI USO INTERNO !!
Proprietà pubblica | Value | Restituisce o imposta il valore dell'elemento.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Clone | Metodo per clonare l'attributo.
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedAttItem
Inizializzo l'oggetto con tutti i campi.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttItem(
    DedAtt parent,
    string val,
    string desc,
    string valorealt,
    int ord
)
Public Sub New (
    parent As DedAtt,
    val As String,
    desc As String,
    valorealt As String,
    ord As Integer
)
public:
DedAttItem(
    DedAtt^ parent,
    String^ val,
    String^ desc,
    String^ valorealt,
    int ord
)
new :
        parent : DedAtt *
        val : string *
        desc : string *
        valorealt : string *
        ord : int -> DedAttItem

Parametri

parent DedAtt
Collezione di appartenenza.
val String
Valore dell'elemento.
desc String
Descrizione.
valorealt String
Valore alternativo.
ord Int32
Indice di ordinamento.
Vedi anche

Documentazione

Classe DedAttItem
Namespace DedNet.Core


Proprietà di DedAttItem

Il tipo DedAttItem espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AltValue | Restituisce o imposta il valore alternativo dell'elemento.
Proprietà pubblica | Description | Restituisce o imposta la descrizione dell'elemento.
Proprietà pubblica | Ord | Restituisce l'indice ordinale dell'elemento (parte da 1).
Proprietà pubblica | Parent | Restituisce la collezione di appartenenza dell'elemento.
Proprietà pubblica | StatoRecord | Restituisce o imposta lo stato del record. DI USO INTERNO !!
Proprietà pubblica | Value | Restituisce o imposta il valore dell'elemento.
Torna su
Vedi anche

Documentazione

Classe DedAttItem
Namespace DedNet.Core


Proprietà DedAttItem.AltValue

Proprietà DedAttItemAltValue
Restituisce o imposta il valore alternativo dell'elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string AltValue { get; set; }
Public Property AltValue As String
    Get
    Set
public:
property String^ AltValue {
    String^ get ();
    void set (String^ value);
}
member AltValue : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedAttItem
Namespace DedNet.Core


Proprietà DedAttItem.Description

Proprietà DedAttItemDescription
Restituisce o imposta la descrizione dell'elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
member Description : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedAttItem
Namespace DedNet.Core


Proprietà DedAttItem.Ord

Proprietà DedAttItemOrd
Restituisce l'indice ordinale dell'elemento (parte da 1).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int Ord { get; set; }
Public Property Ord As Integer
    Get
    Set
public:
property int Ord {
    int get ();
    void set (int value);
}
member Ord : int with get, set

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe DedAttItem
Namespace DedNet.Core


Proprietà DedAttItem.Parent

Proprietà DedAttItemParent
Restituisce la collezione di appartenenza dell'elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAtt Parent { get; }
Public ReadOnly Property Parent As DedAtt
    Get
public:
property DedAtt^ Parent {
    DedAtt^ get ();
}
member Parent : DedAtt with get

Valore della proprietà

DedAtt
Vedi anche

Documentazione

Classe DedAttItem
Namespace DedNet.Core


Proprietà DedAttItem.StatoRecord

Proprietà DedAttItemStatoRecord
Restituisce o imposta lo stato del record. DI USO INTERNO !!

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public StatoRecord StatoRecord { get; set; }
Public Property StatoRecord As StatoRecord
    Get
    Set
public:
virtual property StatoRecord^ StatoRecord {
    StatoRecord^ get () sealed;
    void set (StatoRecord^ value) sealed;
}
abstract StatoRecord : StatoRecord with get, set
override StatoRecord : StatoRecord with get, set

Valore della proprietà

StatoRecord

Implementa

IDedDbItemStatoRecord
Vedi anche

Documentazione

Classe DedAttItem
Namespace DedNet.Core


Proprietà DedAttItem.Value

Proprietà DedAttItemValue
Restituisce o imposta il valore dell'elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}
member Value : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedAttItem
Namespace DedNet.Core


Metodi di DedAttItem

Il tipo DedAttItem espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Clone | Metodo per clonare l'attributo.
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Torna su
Vedi anche

Documentazione

Classe DedAttItem
Namespace DedNet.Core


Metodo DedAttItem.Clone

Metodo DedAttItemClone
Metodo per clonare l'attributo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttItem Clone(
    DedAtt parent
)
Public Function Clone (
    parent As DedAtt
) As DedAttItem
public:
DedAttItem^ Clone(
    DedAtt^ parent
)
member Clone :
        parent : DedAtt -> DedAttItem

Parametri

parent DedAtt

Valore di ritorno

DedAttItem
Vedi anche

Documentazione

Classe DedAttItem
Namespace DedNet.Core


Metodo DedAttItem.Equals

Metodo DedAttItemEquals

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj Object

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedAttItem
Namespace DedNet.Core


Metodo DedAttItem.GetHashCode

Metodo DedAttItemGetHashCode

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedAttItem
Namespace DedNet.Core


Metodo DedAttItem.ToString

Metodo DedAttItemToString

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedAttItem
Namespace DedNet.Core


Classe DedAttItemList
Lista di oggetti DedAtt.
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList DedAttItem
DedNet.CoreDedAttItemList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedAttItemList : List<DedAttItem>
Public Class DedAttItemList
    Inherits List(Of DedAttItem)
public ref class DedAttItemList : public List<DedAttItem^>
type DedAttItemList =
    class
        inherit List<DedAttItem>
    end

Il tipo DedAttItemList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedAttItemList |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedAttItemList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttItemList()
Public Sub New
public:
DedAttItemList()
new : unit -> DedAttItemList
Vedi anche

Documentazione

Classe DedAttItemList
Namespace DedNet.Core


Classe DedAttManager
Gestore delle liste DedAtt da associare agli attributi.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedAttManager

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedAttManager
Public Class DedAttManager
public ref class DedAttManager
type DedAttManager = class end

Il tipo DedAttManager espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Dirty | Restitusice se la struttura delle liste att sia o meno da salvare.
Proprietà pubblica | IsValid | Controlla la validità di tutte le liste, ritorna False se c'è almeno una lista non valida.
Proprietà pubblica | LastException | Ritorna l'ultima eccezione che è avvenuta.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | CloneList | Rinomina la lista cancellando la vecchia e creandone una nuova.
Metodo pubblico | CloneUser | Clona un utente con tutti i suoi att associati.
Metodo pubblico | DeleteList | Elimina la lista dal dizionario.
Metodo pubblico | DeleteUserAtt | Rimuove un utente dalla lista.
Metodo pubblico | GetAttrsFromAttList | Ritorna una lista contenente tutti gli attributi che hanno come lista collegata la lista passata.
Metodo pubblico | GetKeys | Restituisce tutti i nomi delle liste presenti.
Metodo pubblico | GetKeys(Boolean) | Restituisce tutti i nomi delle liste presenti.
Metodo pubblico | GetList | Restituisce la lista att avente nome richiesto oppure ne crea una nuova, associandola al dizionario interno, e la restituisce.
Metodo pubblico | GetUsersKeys | Restituisce la lista degli utenti presenti per una specifica lista Att. Restitusice null se la lista non esiste.
Metodo pubblico | IsListValid | Ritorna se la lista passata è valida.
Metodo pubblico | IsUserListValid | Controlla se la lista passata per l'utente passato è valida.
Metodo pubblico | ListHasUser | Verifica la presenza di un utente all'interno di una particolare lista att.
Metodo pubblico | RenameList | Rinomina la lista cancellando la vecchia e creandone una nuova.
Metodo pubblico | Save | Salva tutta la struttura degli att.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di DedAttManager

Il tipo DedAttManager espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Dirty | Restitusice se la struttura delle liste att sia o meno da salvare.
Proprietà pubblica | IsValid | Controlla la validità di tutte le liste, ritorna False se c'è almeno una lista non valida.
Proprietà pubblica | LastException | Ritorna l'ultima eccezione che è avvenuta.
Torna su
Vedi anche

Documentazione

Classe DedAttManager
Namespace DedNet.Core


Proprietà DedAttManager.Dirty

Proprietà DedAttManagerDirty
Restitusice se la struttura delle liste att sia o meno da salvare.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Dirty { get; }
Public ReadOnly Property Dirty As Boolean
    Get
public:
property bool Dirty {
    bool get ();
}
member Dirty : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAttManager
Namespace DedNet.Core


Proprietà DedAttManager.IsValid

Proprietà DedAttManagerIsValid
Controlla la validità di tutte le liste, ritorna False se c'è almeno una lista non valida.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsValid { get; }
Public ReadOnly Property IsValid As Boolean
    Get
public:
property bool IsValid {
    bool get ();
}
member IsValid : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAttManager
Namespace DedNet.Core


Proprietà DedAttManager.LastException

Proprietà DedAttManagerLastException
Ritorna l'ultima eccezione che è avvenuta.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Exception LastException { get; set; }
Public Property LastException As Exception
    Get
    Set
public:
property Exception^ LastException {
    Exception^ get ();
    void set (Exception^ value);
}
member LastException : Exception with get, set

Valore della proprietà

Exception
Vedi anche

Documentazione

Classe DedAttManager
Namespace DedNet.Core


Metodi di DedAttManager

Il tipo DedAttManager espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | CloneList | Rinomina la lista cancellando la vecchia e creandone una nuova.
Metodo pubblico | CloneUser | Clona un utente con tutti i suoi att associati.
Metodo pubblico | DeleteList | Elimina la lista dal dizionario.
Metodo pubblico | DeleteUserAtt | Rimuove un utente dalla lista.
Metodo pubblico | GetAttrsFromAttList | Ritorna una lista contenente tutti gli attributi che hanno come lista collegata la lista passata.
Metodo pubblico | GetKeys | Restituisce tutti i nomi delle liste presenti.
Metodo pubblico | GetKeys(Boolean) | Restituisce tutti i nomi delle liste presenti.
Metodo pubblico | GetList | Restituisce la lista att avente nome richiesto oppure ne crea una nuova, associandola al dizionario interno, e la restituisce.
Metodo pubblico | GetUsersKeys | Restituisce la lista degli utenti presenti per una specifica lista Att. Restitusice null se la lista non esiste.
Metodo pubblico | IsListValid | Ritorna se la lista passata è valida.
Metodo pubblico | IsUserListValid | Controlla se la lista passata per l'utente passato è valida.
Metodo pubblico | ListHasUser | Verifica la presenza di un utente all'interno di una particolare lista att.
Metodo pubblico | RenameList | Rinomina la lista cancellando la vecchia e creandone una nuova.
Metodo pubblico | Save | Salva tutta la struttura degli att.
Torna su
Vedi anche

Documentazione

Classe DedAttManager
Namespace DedNet.Core


Metodo DedAttManager.CloneList

Metodo DedAttManagerCloneList
Rinomina la lista cancellando la vecchia e creandone una nuova.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CloneList(
    string listName,
    string newListName
)
Public Function CloneList (
    listName As String,
    newListName As String
) As Boolean
public:
bool CloneList(
    String^ listName,
    String^ newListName
)
member CloneList :
        listName : string *
        newListName : string -> bool

Parametri

listName String
Nome vecchia lista
newListName String
Nome nuova lista

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedAttManager
Namespace DedNet.Core


Metodo DedAttManager.CloneUser

Metodo DedAttManagerCloneUser
Clona un utente con tutti i suoi att associati.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CloneUser(
    string listName,
    string userName,
    string selectedList,
    string newUserName
)
Public Function CloneUser (
    listName As String,
    userName As String,
    selectedList As String,
    newUserName As String
) As Boolean
public:
bool CloneUser(
    String^ listName,
    String^ userName,
    String^ selectedList,
    String^ newUserName
)
member CloneUser :
        listName : string *
        userName : string *
        selectedList : string *
        newUserName : string -> bool

Parametri

listName String
Nome lista di partenza
userName String
Nome utente di partenza
selectedList String
Lista attualmente selezionata nella quale copiare l'utente
newUserName String
Nome del nuovo utente

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedAttManager
Namespace DedNet.Core


Metodo DedAttManager.DeleteList

Metodo DedAttManagerDeleteList
Elimina la lista dal dizionario.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool DeleteList(
    string listName,
    bool deleteFromRename = false
)
Public Function DeleteList (
    listName As String,
    Optional deleteFromRename As Boolean = false
) As Boolean
public:
bool DeleteList(
    String^ listName,
    bool deleteFromRename = false
)
member DeleteList :
        listName : string *
        ?deleteFromRename : bool
(* Defaults:
        let _deleteFromRename = defaultArg deleteFromRename false
*)
-> bool

Parametri

listName String
Nome della lista da rimuovere.
deleteFromRename Boolean (Optional)

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedAttManager
Namespace DedNet.Core


Metodo DedAttManager.DeleteUserAtt

Metodo DedAttManagerDeleteUserAtt
Rimuove un utente dalla lista.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool DeleteUserAtt(
    string listName,
    string userName
)
Public Function DeleteUserAtt (
    listName As String,
    userName As String
) As Boolean
public:
bool DeleteUserAtt(
    String^ listName,
    String^ userName
)
member DeleteUserAtt :
        listName : string *
        userName : string -> bool

Parametri

listName String
Nome della lista.
userName String
Nome dell'utente da eliminare dalla lista.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedAttManager
Namespace DedNet.Core


Metodo DedAttManager.GetAttrsFromAttList

Metodo DedAttManagerGetAttrsFromAttList
Ritorna una lista contenente tutti gli attributi che hanno come lista collegata la lista passata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList GetAttrsFromAttList(
    string listName
)
Public Function GetAttrsFromAttList (
    listName As String
) As DedAttrList
public:
DedAttrList^ GetAttrsFromAttList(
    String^ listName
)
member GetAttrsFromAttList :
        listName : string -> DedAttrList

Parametri

listName String
Nome della lista da controllare.

Valore di ritorno

DedAttrList
Vedi anche

Documentazione

Classe DedAttManager
Namespace DedNet.Core


Metodo DedAttManager.GetKeys

Metodo DedAttManagerGetKeys
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | GetKeys | Restituisce tutti i nomi delle liste presenti.
Metodo pubblico | GetKeys(Boolean) | Restituisce tutti i nomi delle liste presenti.
Torna su
Vedi anche

Documentazione

Classe DedAttManager
Namespace DedNet.Core


Metodo DedAttManager.GetKeys

Metodo DedAttManagerGetKeys
Restituisce tutti i nomi delle liste presenti.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string[] GetKeys()
Public Function GetKeys As String()
public:
array<String^>^ GetKeys()
member GetKeys : unit -> string[]

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedAttManager
Overload di GetKeys
Namespace DedNet.Core


Metodo DedAttManager.GetKeys(Boolean)

Metodo DedAttManagerGetKeys(Boolean)
Restituisce tutti i nomi delle liste presenti.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string[] GetKeys(
    bool ignoreEmptyDiz
)
Public Function GetKeys (
    ignoreEmptyDiz As Boolean
) As String()
public:
array<String^>^ GetKeys(
    bool ignoreEmptyDiz
)
member GetKeys :
        ignoreEmptyDiz : bool -> string[]

Parametri

ignoreEmptyDiz Boolean

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedAttManager
Overload di GetKeys
Namespace DedNet.Core


Metodo DedAttManager.GetList

Metodo DedAttManagerGetList
Restituisce la lista att avente nome richiesto oppure ne crea una nuova, associandola al dizionario interno, e la restituisce.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAtt GetList(
    string listName,
    string userName
)
Public Function GetList (
    listName As String,
    userName As String
) As DedAtt
public:
DedAtt^ GetList(
    String^ listName,
    String^ userName
)
member GetList :
        listName : string *
        userName : string -> DedAtt

Parametri

listName String
Nome della lista richiesta.
userName String
Nome dell'utente del quale avere la lista. Passare stringa vuota se si desidera la lista generale.

Valore di ritorno

DedAtt
Vedi anche

Documentazione

Classe DedAttManager
Namespace DedNet.Core


Metodo DedAttManager.GetUsersKeys

Metodo DedAttManagerGetUsersKeys
Restituisce la lista degli utenti presenti per una specifica lista Att. Restitusice null se la lista non esiste.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string[] GetUsersKeys(
    string listName
)
Public Function GetUsersKeys (
    listName As String
) As String()
public:
array<String^>^ GetUsersKeys(
    String^ listName
)
member GetUsersKeys :
        listName : string -> string[]

Parametri

listName String
Nome della lista di interesse.

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedAttManager
Namespace DedNet.Core


Metodo DedAttManager.IsListValid

Metodo DedAttManagerIsListValid
Ritorna se la lista passata è valida.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsListValid(
    string listName
)
Public Function IsListValid (
    listName As String
) As Boolean
public:
bool IsListValid(
    String^ listName
)
member IsListValid :
        listName : string -> bool

Parametri

listName String
Lista da validare.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedAttManager
Namespace DedNet.Core


Metodo DedAttManager.IsUserListValid

Metodo DedAttManagerIsUserListValid
Controlla se la lista passata per l'utente passato è valida.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsUserListValid(
    string listName,
    string userName
)
Public Function IsUserListValid (
    listName As String,
    userName As String
) As Boolean
public:
bool IsUserListValid(
    String^ listName,
    String^ userName
)
member IsUserListValid :
        listName : string *
        userName : string -> bool

Parametri

listName String
Lista da validare.
userName String
Utente della lista da validare.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedAttManager
Namespace DedNet.Core


Metodo DedAttManager.ListHasUser

Metodo DedAttManagerListHasUser
Verifica la presenza di un utente all'interno di una particolare lista att.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ListHasUser(
    string listName,
    string userName
)
Public Function ListHasUser (
    listName As String,
    userName As String
) As Boolean
public:
bool ListHasUser(
    String^ listName,
    String^ userName
)
member ListHasUser :
        listName : string *
        userName : string -> bool

Parametri

listName String
Nome della lista da verificare.
userName String
Nome dell'utente da verificare.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedAttManager
Namespace DedNet.Core


Metodo DedAttManager.RenameList

Metodo DedAttManagerRenameList
Rinomina la lista cancellando la vecchia e creandone una nuova.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool RenameList(
    string oldName,
    string newName
)
Public Function RenameList (
    oldName As String,
    newName As String
) As Boolean
public:
bool RenameList(
    String^ oldName,
    String^ newName
)
member RenameList :
        oldName : string *
        newName : string -> bool

Parametri

oldName String
Nome vecchia lista
newName String
Nome nuova lista

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedAttManager
Namespace DedNet.Core


Metodo DedAttManager.Save

Metodo DedAttManagerSave
Salva tutta la struttura degli att.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Save()
Public Sub Save
public:
void Save()
member Save : unit -> unit
Vedi anche

Documentazione

Classe DedAttManager
Namespace DedNet.Core


Classe DedAttr
Descrive, in tutte le sue caratteristiche, un attributo delle parti Top.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedAttr

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedAttr : IDedDbItem
Public Class DedAttr
    Implements IDedDbItem
public ref class DedAttr : IDedDbItem
type DedAttr =
    class
        interface IDedDbItem
    end

Il tipo DedAttr espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AttList | Restituisce l'elenco collegato dei valori. Se trova un'Att importato ma ancora non riempito, chiama l'evento di riempimento.
Proprietà pubblica | AttrListType | Restituisce se si tratti di una lista a scelta obbligatoria oppure no.
Proprietà pubblica | BackColor | Restituisce il colore di sfondo.
Proprietà pubblica | Calculated | Indica se è un attributo segnaposto e il valore dell'attributo è importato da fonti dati esterne.
Proprietà pubblica | CascadeDisabled | Restituisce o imposta se disabilitare la gestione della cascata su questo attributo.
Proprietà pubblica | Category | Restituisce la categoria a cui è collegato l'attributo.
Proprietà pubblica | ClassList | Restituisce la lista delle classi per il menu contestuale.
Proprietà pubblica | DataType | Restituisce il tipo dati.
Proprietà pubblica | DefaultValue | Restituisce il valore di default.
Proprietà pubblica | EnvDest | Restituisce il tipo di attributo in base all'ambiente dal quale proviene e nel quale deve essere aggiornato.
Proprietà pubblica | FontInfo | Oggetto che descrive le informazioni relative al font dell'attributo.
Proprietà pubblica | ForeColor | Restituisce il colore del testo.
Proprietà pubblica | FormatString | Restituisce la stringa di formato.
Proprietà pubblica | IsDocWritable | Ritorna True se l'attributo può essere scritto all'interno dei documenti.
Proprietà pubblica | IsRevisionSpecific | Indica se l'attributo è una informazione specifica della revisione
Proprietà pubblica | IsSparePart | Indica se si tratta di un attributo di ricambio o meno.
Proprietà pubblica | IsVisible | Restituisce se l'attributo sia o meno visibile.
Proprietà pubblica | ModType | Restituisce il tipo di modificabilità dell'attributo.
Proprietà pubblica | NeedAlterTable | Indica se la modifica necessita di un alter della colonna.
Proprietà pubblica | Nome | Restituisce il nome della colonna in DED_DATA o DED_BOM corrispondente all'attributo.
Proprietà pubblica | OnlyInDb | Indica se il valore dell'attributo deve essere memorizzato solo nel database o anche nel file.
Proprietà pubblica | Ord | Restituisce l'indice di ordinamento di questo oggetto.
Proprietà pubblica | OriginalEnvDest | Inidca l'ambiente originale dell'attributo (per capire l'eventuale cambio di ambiante)
Proprietà pubblica | OriginalEnvDestChanged | Indica se è stato cambiato ambiente alll'attributo.
Proprietà pubblica | OriginalPrompt | Indica il prompt originale dell'attributo (per capire l'eventuale cambio di prompt).
Proprietà pubblica | OriginalPromptChanged | Indica se è stato cambiato il prompt dell'attributo.
Proprietà pubblica | Parent | Restituisce la collezione di appartenenza dell'elemento.
Proprietà pubblica | Prompt | Restituisce il nome visualizzato all'utente.
Proprietà pubblica | Reserved | Ritorna true se l'attributo è tra quelli riservati al database. Solo informativa, è il chiamante a doverne fare buon uso.
Proprietà pubblica | StatoRecord | Restituisce o imposta lo stato del record. DI USO INTERNO !!
Proprietà pubblica | Tooltip | Restituisce il testo del Tooltip.
Proprietà pubblica | Translations | Restituisce la lista delle traduzioni abbinate a questo attributo.
Proprietà pubblica | Type | Restituisce o imposta la famiglia/commessa di cui fa parte l'attributo.
Proprietà pubblica | Upperize | Indica se l'attributo deve essere maiuscolizzato.
Proprietà pubblica | Validator | Imposta o restituisce l'oggetto validatore.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Clone | Metodo per clonare l'attributo.
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | GetPromptTranslation | Ritorna l'eventuale traduzione del prompt nella lingua impostata di default nell'applicazione. Se non c'è una traduzione ritorna il prompt dell'attributo.
Metodo pubblico | GetPromptTranslation(Boolean) | Ritorna l'eventuale traduzione del prompt nella lingua impostata di default nell'applicazione.
Metodo pubblico | GetPromptTranslation(Boolean, Boolean) | Ritorna l'eventuale traduzione del prompt nella lingua impostata di default nell'applicazione.
Metodo pubblico | GetPromptTranslation(String, Boolean, Boolean) | Ritorna l'eventuale traduzione del prompt nella lingua passata. Se chiamato con il flag forceLabel a True, ignora la variabile ShowAttributeLabelsInUI forzando la ricerca di traduzioni.
Metodo pubblico | GetProperStringValue | Restituisce la stringa con il valore, letto da DedData, sottoforma di stringa per scrittura in attributi. Restituisce stringa vuota, se non è convertibile.
Metodo pubblico | GetProperValue(String) | Trasformo il valore in stringa in un valore coerente con l'attributo
Metodo pubblico | GetProperValue(String, Boolean) | Trasformo il valore in stringa in un valore coerente con l'attributo
Metodo pubblico | HasAttList | Verifica se questo attributo ha un elenco a tendina di valori collegato.
Metodo pubblico | ObjectToString | Formatta un valore in base alle caratteristiche di formato dell'attributo.
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Metodo pubblico | Validate(Object, IDedEditable, Boolean, Boolean) | Valida il valore dell'attributo senza sollevare eccezioni.
Metodo pubblico | Validate(Object, IDedEditable, Boolean, Boolean, String) | Valida il valore dell'attributo restituendo l'eventuale errore di convalidazione.
Torna su
Campi
Nome | Descrizione
_dataTimeMin | Identifica la data
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di DedAttr

Il tipo DedAttr espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AttList | Restituisce l'elenco collegato dei valori. Se trova un'Att importato ma ancora non riempito, chiama l'evento di riempimento.
Proprietà pubblica | AttrListType | Restituisce se si tratti di una lista a scelta obbligatoria oppure no.
Proprietà pubblica | BackColor | Restituisce il colore di sfondo.
Proprietà pubblica | Calculated | Indica se è un attributo segnaposto e il valore dell'attributo è importato da fonti dati esterne.
Proprietà pubblica | CascadeDisabled | Restituisce o imposta se disabilitare la gestione della cascata su questo attributo.
Proprietà pubblica | Category | Restituisce la categoria a cui è collegato l'attributo.
Proprietà pubblica | ClassList | Restituisce la lista delle classi per il menu contestuale.
Proprietà pubblica | DataType | Restituisce il tipo dati.
Proprietà pubblica | DefaultValue | Restituisce il valore di default.
Proprietà pubblica | EnvDest | Restituisce il tipo di attributo in base all'ambiente dal quale proviene e nel quale deve essere aggiornato.
Proprietà pubblica | FontInfo | Oggetto che descrive le informazioni relative al font dell'attributo.
Proprietà pubblica | ForeColor | Restituisce il colore del testo.
Proprietà pubblica | FormatString | Restituisce la stringa di formato.
Proprietà pubblica | IsDocWritable | Ritorna True se l'attributo può essere scritto all'interno dei documenti.
Proprietà pubblica | IsRevisionSpecific | Indica se l'attributo è una informazione specifica della revisione
Proprietà pubblica | IsSparePart | Indica se si tratta di un attributo di ricambio o meno.
Proprietà pubblica | IsVisible | Restituisce se l'attributo sia o meno visibile.
Proprietà pubblica | ModType | Restituisce il tipo di modificabilità dell'attributo.
Proprietà pubblica | NeedAlterTable | Indica se la modifica necessita di un alter della colonna.
Proprietà pubblica | Nome | Restituisce il nome della colonna in DED_DATA o DED_BOM corrispondente all'attributo.
Proprietà pubblica | OnlyInDb | Indica se il valore dell'attributo deve essere memorizzato solo nel database o anche nel file.
Proprietà pubblica | Ord | Restituisce l'indice di ordinamento di questo oggetto.
Proprietà pubblica | OriginalEnvDest | Inidca l'ambiente originale dell'attributo (per capire l'eventuale cambio di ambiante)
Proprietà pubblica | OriginalEnvDestChanged | Indica se è stato cambiato ambiente alll'attributo.
Proprietà pubblica | OriginalPrompt | Indica il prompt originale dell'attributo (per capire l'eventuale cambio di prompt).
Proprietà pubblica | OriginalPromptChanged | Indica se è stato cambiato il prompt dell'attributo.
Proprietà pubblica | Parent | Restituisce la collezione di appartenenza dell'elemento.
Proprietà pubblica | Prompt | Restituisce il nome visualizzato all'utente.
Proprietà pubblica | Reserved | Ritorna true se l'attributo è tra quelli riservati al database. Solo informativa, è il chiamante a doverne fare buon uso.
Proprietà pubblica | StatoRecord | Restituisce o imposta lo stato del record. DI USO INTERNO !!
Proprietà pubblica | Tooltip | Restituisce il testo del Tooltip.
Proprietà pubblica | Translations | Restituisce la lista delle traduzioni abbinate a questo attributo.
Proprietà pubblica | Type | Restituisce o imposta la famiglia/commessa di cui fa parte l'attributo.
Proprietà pubblica | Upperize | Indica se l'attributo deve essere maiuscolizzato.
Proprietà pubblica | Validator | Imposta o restituisce l'oggetto validatore.
Torna su
Vedi anche

Documentazione

Classe DedAttr
Namespace DedNet.Core


Proprietà DedAttr.AttList

Proprietà DedAttrAttList
Restituisce l'elenco collegato dei valori. Se trova un'Att importato ma ancora non riempito, chiama l'evento di riempimento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAtt AttList { get; set; }
Public Property AttList As DedAtt
    Get
    Set
public:
property DedAtt^ AttList {
    DedAtt^ get ();
    void set (DedAtt^ value);
}
member AttList : DedAtt with get, set

Valore della proprietà

DedAtt
Vedi anche

Documentazione

Classe DedAttr
Namespace DedNet.Core


Proprietà DedAttr.AttrListType

Proprietà DedAttrAttrListType
Restituisce se si tratti di una lista a scelta obbligatoria oppure no.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrListType AttrListType { get; set; }
Public Property AttrListType As DedAttrListType
    Get
    Set
public:
property DedAttrListType AttrListType {
    DedAttrListType get ();
    void set (DedAttrListType value);
}
member AttrListType : DedAttrListType with get, set

Valore della proprietà

DedAttrListType
Vedi anche

Documentazione

Classe DedAttr
Namespace DedNet.Core


Proprietà DedAttr.BackColor

Proprietà DedAttrBackColor
Restituisce il colore di sfondo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Color BackColor { get; set; }
Public Property BackColor As Color
    Get
    Set
public:
property Color BackColor {
    Color get ();
    void set (Color value);
}
member BackColor : Color with get, set

Valore della proprietà

Color
Vedi anche

Documentazione

Classe DedAttr
Namespace DedNet.Core


Proprietà DedAttr.Calculated

Proprietà DedAttrCalculated
Indica se è un attributo segnaposto e il valore dell'attributo è importato da fonti dati esterne.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Calculated { get; set; }
Public Property Calculated As Boolean
    Get
    Set
public:
property bool Calculated {
    bool get ();
    void set (bool value);
}
member Calculated : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAttr
Namespace DedNet.Core


Proprietà DedAttr.CascadeDisabled

Proprietà DedAttrCascadeDisabled
Restituisce o imposta se disabilitare la gestione della cascata su questo attributo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CascadeDisabled { get; set; }
Public Property CascadeDisabled As Boolean
    Get
    Set
public:
property bool CascadeDisabled {
    bool get ();
    void set (bool value);
}
member CascadeDisabled : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAttr
Namespace DedNet.Core


Proprietà DedAttr.Category

Proprietà DedAttrCategory
Restituisce la categoria a cui è collegato l'attributo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCateg Category { get; set; }
Public Property Category As DedCateg
    Get
    Set
public:
property DedCateg^ Category {
    DedCateg^ get ();
    void set (DedCateg^ value);
}
member Category : DedCateg with get, set

Valore della proprietà

DedCateg
Vedi anche

Documentazione

Classe DedAttr
Namespace DedNet.Core


Proprietà DedAttr.ClassList

Proprietà DedAttrClassList
Restituisce la lista delle classi per il menu contestuale.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string[] ClassList { get; set; }
Public Property ClassList As String()
    Get
    Set
public:
property array<String^>^ ClassList {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member ClassList : string[] with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedAttr
Namespace DedNet.Core


Proprietà DedAttr.DataType

Proprietà DedAttrDataType
Restituisce il tipo dati.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Type DataType { get; set; }
Public Property DataType As Type
    Get
    Set
public:
property Type^ DataType {
    Type^ get ();
    void set (Type^ value);
}
member DataType : Type with get, set

Valore della proprietà

Type
Vedi anche

Documentazione

Classe DedAttr
Namespace DedNet.Core


Proprietà DedAttr.DefaultValue

Proprietà DedAttrDefaultValue
Restituisce il valore di default.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object DefaultValue { get; set; }
Public Property DefaultValue As Object
    Get
    Set
public:
property Object^ DefaultValue {
    Object^ get ();
    void set (Object^ value);
}
member DefaultValue : Object with get, set

Valore della proprietà

Object
Vedi anche

Documentazione

Classe DedAttr
Namespace DedNet.Core


Proprietà DedAttr.EnvDest

Proprietà DedAttrEnvDest
Restituisce il tipo di attributo in base all'ambiente dal quale proviene e nel quale deve essere aggiornato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrEnvDestEnum EnvDest { get; set; }
Public Property EnvDest As DedAttrEnvDestEnum
    Get
    Set
public:
property DedAttrEnvDestEnum EnvDest {
    DedAttrEnvDestEnum get ();
    void set (DedAttrEnvDestEnum value);
}
member EnvDest : DedAttrEnvDestEnum with get, set

Valore della proprietà

DedAttrEnvDestEnum
Vedi anche

Documentazione

Classe DedAttr
Namespace DedNet.Core


Proprietà DedAttr.FontInfo

Proprietà DedAttrFontInfo
Oggetto che descrive le informazioni relative al font dell'attributo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFontInfo FontInfo { get; set; }
Public Property FontInfo As DedFontInfo
    Get
    Set
public:
property DedFontInfo^ FontInfo {
    DedFontInfo^ get ();
    void set (DedFontInfo^ value);
}
member FontInfo : DedFontInfo with get, set

Valore della proprietà

DedFontInfo
Vedi anche

Documentazione

Classe DedAttr
Namespace DedNet.Core


Proprietà DedAttr.ForeColor

Proprietà DedAttrForeColor
Restituisce il colore del testo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Color ForeColor { get; set; }
Public Property ForeColor As Color
    Get
    Set
public:
property Color ForeColor {
    Color get ();
    void set (Color value);
}
member ForeColor : Color with get, set

Valore della proprietà

Color
Vedi anche

Documentazione

Classe DedAttr
Namespace DedNet.Core


Proprietà DedAttr.FormatString

Proprietà DedAttrFormatString
Restituisce la stringa di formato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string FormatString { get; set; }
Public Property FormatString As String
    Get
    Set
public:
property String^ FormatString {
    String^ get ();
    void set (String^ value);
}
member FormatString : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedAttr
Namespace DedNet.Core


Proprietà DedAttr.IsDocWritable

Proprietà DedAttrIsDocWritable
Ritorna True se l'attributo può essere scritto all'interno dei documenti.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsDocWritable { get; }
Public ReadOnly Property IsDocWritable As Boolean
    Get
public:
property bool IsDocWritable {
    bool get ();
}
member IsDocWritable : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAttr
Namespace DedNet.Core


Proprietà DedAttr.IsRevisionSpecific

Proprietà DedAttrIsRevisionSpecific
Indica se l'attributo è una informazione specifica della revisione

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsRevisionSpecific { get; set; }
Public Property IsRevisionSpecific As Boolean
    Get
    Set
public:
property bool IsRevisionSpecific {
    bool get ();
    void set (bool value);
}
member IsRevisionSpecific : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAttr
Namespace DedNet.Core


Proprietà DedAttr.IsSparePart

Proprietà DedAttrIsSparePart
Indica se si tratta di un attributo di ricambio o meno.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsSparePart { get; set; }
Public Property IsSparePart As Boolean
    Get
    Set
public:
property bool IsSparePart {
    bool get ();
    void set (bool value);
}
member IsSparePart : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAttr
Namespace DedNet.Core


Proprietà DedAttr.IsVisible

Proprietà DedAttrIsVisible
Restituisce se l'attributo sia o meno visibile.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsVisible { get; set; }
Public Property IsVisible As Boolean
    Get
    Set
public:
property bool IsVisible {
    bool get ();
    void set (bool value);
}
member IsVisible : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAttr
Namespace DedNet.Core


Proprietà DedAttr.ModType

Proprietà DedAttrModType
Restituisce il tipo di modificabilità dell'attributo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrModEnum ModType { get; set; }
Public Property ModType As DedAttrModEnum
    Get
    Set
public:
property DedAttrModEnum ModType {
    DedAttrModEnum get ();
    void set (DedAttrModEnum value);
}
member ModType : DedAttrModEnum with get, set

Valore della proprietà

DedAttrModEnum
Vedi anche

Documentazione

Classe DedAttr
Namespace DedNet.Core


Proprietà DedAttr.NeedAlterTable

Proprietà DedAttrNeedAlterTable
Indica se la modifica necessita di un alter della colonna.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool NeedAlterTable { get; set; }
Public Property NeedAlterTable As Boolean
    Get
    Set
public:
property bool NeedAlterTable {
    bool get ();
    void set (bool value);
}
member NeedAlterTable : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAttr
Namespace DedNet.Core


Proprietà DedAttr.Nome

Proprietà DedAttrNome
Restituisce il nome della colonna in DED_DATA o DED_BOM corrispondente all'attributo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Nome { get; set; }
Public Property Nome As String
    Get
    Set
public:
property String^ Nome {
    String^ get ();
    void set (String^ value);
}
member Nome : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedAttr
Namespace DedNet.Core


Proprietà DedAttr.OnlyInDb

Proprietà DedAttrOnlyInDb
Indica se il valore dell'attributo deve essere memorizzato solo nel database o anche nel file.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool OnlyInDb { get; set; }
Public Property OnlyInDb As Boolean
    Get
    Set
public:
property bool OnlyInDb {
    bool get ();
    void set (bool value);
}
member OnlyInDb : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAttr
Namespace DedNet.Core


Proprietà DedAttr.Ord

Proprietà DedAttrOrd
Restituisce l'indice di ordinamento di questo oggetto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int Ord { get; set; }
Public Property Ord As Integer
    Get
    Set
public:
property int Ord {
    int get ();
    void set (int value);
}
member Ord : int with get, set

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe DedAttr
Namespace DedNet.Core


Proprietà DedAttr.OriginalEnvDest

Proprietà DedAttrOriginalEnvDest
Inidca l'ambiente originale dell'attributo (per capire l'eventuale cambio di ambiante)

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrEnvDestEnum OriginalEnvDest { get; }
Public ReadOnly Property OriginalEnvDest As DedAttrEnvDestEnum
    Get
public:
property DedAttrEnvDestEnum OriginalEnvDest {
    DedAttrEnvDestEnum get ();
}
member OriginalEnvDest : DedAttrEnvDestEnum with get

Valore della proprietà

DedAttrEnvDestEnum
Vedi anche

Documentazione

Classe DedAttr
Namespace DedNet.Core


Proprietà DedAttr.OriginalEnvDestChanged

Proprietà DedAttrOriginalEnvDestChanged
Indica se è stato cambiato ambiente alll'attributo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool OriginalEnvDestChanged { get; set; }
Public Property OriginalEnvDestChanged As Boolean
    Get
    Set
public:
property bool OriginalEnvDestChanged {
    bool get ();
    void set (bool value);
}
member OriginalEnvDestChanged : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAttr
Namespace DedNet.Core


Proprietà DedAttr.OriginalPrompt

Proprietà DedAttrOriginalPrompt
Indica il prompt originale dell'attributo (per capire l'eventuale cambio di prompt).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string OriginalPrompt { get; set; }
Public Property OriginalPrompt As String
    Get
    Set
public:
property String^ OriginalPrompt {
    String^ get ();
    void set (String^ value);
}
member OriginalPrompt : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedAttr
Namespace DedNet.Core


Proprietà DedAttr.OriginalPromptChanged

Proprietà DedAttrOriginalPromptChanged
Indica se è stato cambiato il prompt dell'attributo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool OriginalPromptChanged { get; set; }
Public Property OriginalPromptChanged As Boolean
    Get
    Set
public:
property bool OriginalPromptChanged {
    bool get ();
    void set (bool value);
}
member OriginalPromptChanged : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAttr
Namespace DedNet.Core


Proprietà DedAttr.Parent

Proprietà DedAttrParent
Restituisce la collezione di appartenenza dell'elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrCollection Parent { get; }
Public ReadOnly Property Parent As DedAttrCollection
    Get
public:
property DedAttrCollection^ Parent {
    DedAttrCollection^ get ();
}
member Parent : DedAttrCollection with get

Valore della proprietà

DedAttrCollection
Vedi anche

Documentazione

Classe DedAttr
Namespace DedNet.Core


Proprietà DedAttr.Prompt

Proprietà DedAttrPrompt
Restituisce il nome visualizzato all'utente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Prompt { get; set; }
Public Property Prompt As String
    Get
    Set
public:
property String^ Prompt {
    String^ get ();
    void set (String^ value);
}
member Prompt : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedAttr
Namespace DedNet.Core


Proprietà DedAttr.Reserved

Proprietà DedAttrReserved
Ritorna true se l'attributo è tra quelli riservati al database. Solo informativa, è il chiamante a doverne fare buon uso.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Reserved { get; }
Public ReadOnly Property Reserved As Boolean
    Get
public:
property bool Reserved {
    bool get ();
}
member Reserved : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAttr
Namespace DedNet.Core


Proprietà DedAttr.StatoRecord

Proprietà DedAttrStatoRecord
Restituisce o imposta lo stato del record. DI USO INTERNO !!

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public StatoRecord StatoRecord { get; set; }
Public Property StatoRecord As StatoRecord
    Get
    Set
public:
virtual property StatoRecord^ StatoRecord {
    StatoRecord^ get () sealed;
    void set (StatoRecord^ value) sealed;
}
abstract StatoRecord : StatoRecord with get, set
override StatoRecord : StatoRecord with get, set

Valore della proprietà

StatoRecord

Implementa

IDedDbItemStatoRecord
Vedi anche

Documentazione

Classe DedAttr
Namespace DedNet.Core


Proprietà DedAttr.Tooltip

Proprietà DedAttrTooltip
Restituisce il testo del Tooltip.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Tooltip { get; set; }
Public Property Tooltip As String
    Get
    Set
public:
property String^ Tooltip {
    String^ get ();
    void set (String^ value);
}
member Tooltip : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedAttr
Namespace DedNet.Core


Proprietà DedAttr.Translations

Proprietà DedAttrTranslations
Restituisce la lista delle traduzioni abbinate a questo attributo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTranslationCollection Translations { get; }
Public ReadOnly Property Translations As DedTranslationCollection
    Get
public:
property DedTranslationCollection^ Translations {
    DedTranslationCollection^ get ();
}
member Translations : DedTranslationCollection with get

Valore della proprietà

DedTranslationCollection
Vedi anche

Documentazione

Classe DedAttr
Namespace DedNet.Core


Proprietà DedAttr.Type

Proprietà DedAttrType
Restituisce o imposta la famiglia/commessa di cui fa parte l'attributo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeBase Type { get; set; }
Public Property Type As DedTypeBase
    Get
    Set
public:
property DedTypeBase^ Type {
    DedTypeBase^ get ();
    void set (DedTypeBase^ value);
}
member Type : DedTypeBase with get, set

Valore della proprietà

DedTypeBase
Vedi anche

Documentazione

Classe DedAttr
Namespace DedNet.Core


Proprietà DedAttr.Upperize

Proprietà DedAttrUpperize
Indica se l'attributo deve essere maiuscolizzato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Upperize { get; set; }
Public Property Upperize As Boolean
    Get
    Set
public:
property bool Upperize {
    bool get ();
    void set (bool value);
}
member Upperize : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAttr
Namespace DedNet.Core


Proprietà DedAttr.Validator

Proprietà DedAttrValidator
Imposta o restituisce l'oggetto validatore.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrValidatorBase Validator { get; set; }
Public Property Validator As DedAttrValidatorBase
    Get
    Set
public:
property DedAttrValidatorBase^ Validator {
    DedAttrValidatorBase^ get ();
    void set (DedAttrValidatorBase^ value);
}
member Validator : DedAttrValidatorBase with get, set

Valore della proprietà

DedAttrValidatorBase
Vedi anche

Documentazione

Classe DedAttr
Namespace DedNet.Core


Metodi di DedAttr

Il tipo DedAttr espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Clone | Metodo per clonare l'attributo.
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | GetPromptTranslation | Ritorna l'eventuale traduzione del prompt nella lingua impostata di default nell'applicazione. Se non c'è una traduzione ritorna il prompt dell'attributo.
Metodo pubblico | GetPromptTranslation(Boolean) | Ritorna l'eventuale traduzione del prompt nella lingua impostata di default nell'applicazione.
Metodo pubblico | GetPromptTranslation(Boolean, Boolean) | Ritorna l'eventuale traduzione del prompt nella lingua impostata di default nell'applicazione.
Metodo pubblico | GetPromptTranslation(String, Boolean, Boolean) | Ritorna l'eventuale traduzione del prompt nella lingua passata. Se chiamato con il flag forceLabel a True, ignora la variabile ShowAttributeLabelsInUI forzando la ricerca di traduzioni.
Metodo pubblico | GetProperStringValue | Restituisce la stringa con il valore, letto da DedData, sottoforma di stringa per scrittura in attributi. Restituisce stringa vuota, se non è convertibile.
Metodo pubblico | GetProperValue(String) | Trasformo il valore in stringa in un valore coerente con l'attributo
Metodo pubblico | GetProperValue(String, Boolean) | Trasformo il valore in stringa in un valore coerente con l'attributo
Metodo pubblico | HasAttList | Verifica se questo attributo ha un elenco a tendina di valori collegato.
Metodo pubblico | ObjectToString | Formatta un valore in base alle caratteristiche di formato dell'attributo.
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Metodo pubblico | Validate(Object, IDedEditable, Boolean, Boolean) | Valida il valore dell'attributo senza sollevare eccezioni.
Metodo pubblico | Validate(Object, IDedEditable, Boolean, Boolean, String) | Valida il valore dell'attributo restituendo l'eventuale errore di convalidazione.
Torna su
Vedi anche

Documentazione

Classe DedAttr
Namespace DedNet.Core


Metodo DedAttr.Clone

Metodo DedAttrClone
Metodo per clonare l'attributo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttr Clone(
    DedAttrCollection parent
)
Public Function Clone (
    parent As DedAttrCollection
) As DedAttr
public:
DedAttr^ Clone(
    DedAttrCollection^ parent
)
member Clone :
        parent : DedAttrCollection -> DedAttr

Parametri

parent DedAttrCollection

Valore di ritorno

DedAttr
Vedi anche

Documentazione

Classe DedAttr
Namespace DedNet.Core


Metodo DedAttr.Equals

Metodo DedAttrEquals

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj Object

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedAttr
Namespace DedNet.Core


Metodo DedAttr.GetHashCode

Metodo DedAttrGetHashCode

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedAttr
Namespace DedNet.Core


Metodo DedAttr.GetPromptTranslation

Metodo DedAttrGetPromptTranslation
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | GetPromptTranslation | Ritorna l'eventuale traduzione del prompt nella lingua impostata di default nell'applicazione. Se non c'è una traduzione ritorna il prompt dell'attributo.
Metodo pubblico | GetPromptTranslation(Boolean) | Ritorna l'eventuale traduzione del prompt nella lingua impostata di default nell'applicazione.
Metodo pubblico | GetPromptTranslation(Boolean, Boolean) | Ritorna l'eventuale traduzione del prompt nella lingua impostata di default nell'applicazione.
Metodo pubblico | GetPromptTranslation(String, Boolean, Boolean) | Ritorna l'eventuale traduzione del prompt nella lingua passata. Se chiamato con il flag forceLabel a True, ignora la variabile ShowAttributeLabelsInUI forzando la ricerca di traduzioni.
Torna su
Vedi anche

Documentazione

Classe DedAttr
Namespace DedNet.Core


Metodo DedAttr.GetPromptTranslation

Metodo DedAttrGetPromptTranslation
Ritorna l'eventuale traduzione del prompt nella lingua impostata di default nell'applicazione. Se non c'è una traduzione ritorna il prompt dell'attributo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string GetPromptTranslation()
Public Function GetPromptTranslation As String
public:
String^ GetPromptTranslation()
member GetPromptTranslation : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedAttr
Overload di GetPromptTranslation
Namespace DedNet.Core


Metodo DedAttr.GetPromptTranslation(Boolean)

Metodo DedAttrGetPromptTranslation(Boolean)
Ritorna l'eventuale traduzione del prompt nella lingua impostata di default nell'applicazione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string GetPromptTranslation(
    bool returnPromptIfNotFound
)
Public Function GetPromptTranslation (
    returnPromptIfNotFound As Boolean
) As String
public:
String^ GetPromptTranslation(
    bool returnPromptIfNotFound
)
member GetPromptTranslation :
        returnPromptIfNotFound : bool -> string

Parametri

returnPromptIfNotFound Boolean
Indica se ritornare il prompt nel caso non venga trovata una traduzione valida. Se false ritorna stringa vuota.

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedAttr
Overload di GetPromptTranslation
Namespace DedNet.Core


Metodo DedAttr.GetPromptTranslation(Boolean, Boolean)

Metodo DedAttrGetPromptTranslation(Boolean, Boolean)
Ritorna l'eventuale traduzione del prompt nella lingua impostata di default nell'applicazione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string GetPromptTranslation(
    bool returnPromptIfNotFound,
    bool forceLabel
)
Public Function GetPromptTranslation (
    returnPromptIfNotFound As Boolean,
    forceLabel As Boolean
) As String
public:
String^ GetPromptTranslation(
    bool returnPromptIfNotFound,
    bool forceLabel
)
member GetPromptTranslation :
        returnPromptIfNotFound : bool *
        forceLabel : bool -> string

Parametri

returnPromptIfNotFound Boolean
Indica se ritornare il prompt nel caso non venga trovata una traduzione valida. Se false ritorna stringa vuota.
forceLabel Boolean
Indica se forzare la restituzione di una label, ignorando la variabile ShowAttributeLabelsInUI.

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedAttr
Overload di GetPromptTranslation
Namespace DedNet.Core


Metodo DedAttr.GetPromptTranslation(String, Boolean, Boolean)

Metodo DedAttrGetPromptTranslation(String, Boolean, Boolean)
Ritorna l'eventuale traduzione del prompt nella lingua passata. Se chiamato con il flag forceLabel a True, ignora la variabile ShowAttributeLabelsInUI forzando la ricerca di traduzioni.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string GetPromptTranslation(
    string lang,
    bool returnPromptIfNotFound,
    bool forceLabel
)
Public Function GetPromptTranslation (
    lang As String,
    returnPromptIfNotFound As Boolean,
    forceLabel As Boolean
) As String
public:
String^ GetPromptTranslation(
    String^ lang,
    bool returnPromptIfNotFound,
    bool forceLabel
)
member GetPromptTranslation :
        lang : string *
        returnPromptIfNotFound : bool *
        forceLabel : bool -> string

Parametri

lang String
Lingua di traduzione.
returnPromptIfNotFound Boolean
Indica se ritornare il prompt nel caso non venga trovata una traduzione valida. Se false ritorna stringa vuota.
forceLabel Boolean
Indica se forzare la restituzione di una label, ignorando la variabile ShowAttributeLabelsInUI.

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedAttr
Overload di GetPromptTranslation
Namespace DedNet.Core


Metodo DedAttr.GetProperStringValue

Metodo DedAttrGetProperStringValue
Restituisce la stringa con il valore, letto da DedData, sottoforma di stringa per scrittura in attributi. Restituisce stringa vuota, se non è convertibile.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string GetProperStringValue(
    Object value
)
Public Function GetProperStringValue (
    value As Object
) As String
public:
String^ GetProperStringValue(
    Object^ value
)
member GetProperStringValue :
        value : Object -> string

Parametri

value Object
Valore presente nel Database.

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedAttr
Namespace DedNet.Core


Metodo DedAttr.GetProperValue

Metodo DedAttrGetProperValue
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | GetProperValue(String) | Trasformo il valore in stringa in un valore coerente con l'attributo
Metodo pubblico | GetProperValue(String, Boolean) | Trasformo il valore in stringa in un valore coerente con l'attributo
Torna su
Vedi anche

Documentazione

Classe DedAttr
Namespace DedNet.Core


Metodo DedAttr.GetProperValue(String)

Metodo DedAttrGetProperValue(String)
Trasformo il valore in stringa in un valore coerente con l'attributo

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object GetProperValue(
    string value
)
Public Function GetProperValue (
    value As String
) As Object
public:
Object^ GetProperValue(
    String^ value
)
member GetProperValue :
        value : string -> Object

Parametri

value String

Valore di ritorno

Object
Vedi anche

Documentazione

Classe DedAttr
Overload di GetProperValue
Namespace DedNet.Core


Metodo DedAttr.GetProperValue(String, Boolean)

Metodo DedAttrGetProperValue(String, Boolean)
Trasformo il valore in stringa in un valore coerente con l'attributo

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object GetProperValue(
    string value,
    bool ignoreMaxLenght
)
Public Function GetProperValue (
    value As String,
    ignoreMaxLenght As Boolean
) As Object
public:
Object^ GetProperValue(
    String^ value,
    bool ignoreMaxLenght
)
member GetProperValue :
        value : string *
        ignoreMaxLenght : bool -> Object

Parametri

value String
ignoreMaxLenght Boolean

Valore di ritorno

Object
Vedi anche

Documentazione

Classe DedAttr
Overload di GetProperValue
Namespace DedNet.Core


Metodo DedAttr.HasAttList

Metodo DedAttrHasAttList
Verifica se questo attributo ha un elenco a tendina di valori collegato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasAttList()
Public Function HasAttList As Boolean
public:
bool HasAttList()
member HasAttList : unit -> bool

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedAttr
Namespace DedNet.Core


Metodo DedAttr.ObjectToString

Metodo DedAttrObjectToString
Formatta un valore in base alle caratteristiche di formato dell'attributo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string ObjectToString(
    Object value
)
Public Function ObjectToString (
    value As Object
) As String
public:
String^ ObjectToString(
    Object^ value
)
member ObjectToString :
        value : Object -> string

Parametri

value Object
Valore da formattare per mostrarlo all'utente.

Valore di ritorno

String
Restituisce una rappresentazione stringa dell'oggetto passato, formattata in base alle impostazioni dell'attributo.
Vedi anche

Documentazione

Classe DedAttr
Namespace DedNet.Core


Metodo DedAttr.ToString

Metodo DedAttrToString

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedAttr
Namespace DedNet.Core


Metodo DedAttr.Validate

Metodo DedAttrValidate
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Validate(Object, IDedEditable, Boolean, Boolean) | Valida il valore dell'attributo senza sollevare eccezioni.
Metodo pubblico | Validate(Object, IDedEditable, Boolean, Boolean, String) | Valida il valore dell'attributo restituendo l'eventuale errore di convalidazione.
Torna su
Vedi anche

Documentazione

Classe DedAttr
Namespace DedNet.Core


Metodo DedAttr.Validate(Object, IDedEditable, Boolean, Boolean)

Metodo DedAttrValidate(Object, IDedEditable, Boolean, Boolean)
Valida il valore dell'attributo senza sollevare eccezioni.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Validate(
    Object val,
    IDedEditable data,
    bool creating,
    bool revisioning
)
Public Function Validate (
    val As Object,
    data As IDedEditable,
    creating As Boolean,
    revisioning As Boolean
) As Boolean
public:
bool Validate(
    Object^ val,
    IDedEditable^ data,
    bool creating,
    bool revisioning
)
member Validate :
        val : Object *
        data : IDedEditable *
        creating : bool *
        revisioning : bool -> bool

Parametri

val Object
Valore da convalidare.
data IDedEditable
creating Boolean
revisioning Boolean

Valore di ritorno

Boolean
Restituisce true se il valore è convalidato altrimenti false.
Vedi anche

Documentazione

Classe DedAttr
Overload di Validate
Namespace DedNet.Core


Metodo DedAttr.Validate(Object, IDedEditable, Boolean, Boolean, String)

Metodo DedAttrValidate(Object, IDedEditable, Boolean, Boolean, String)
Valida il valore dell'attributo restituendo l'eventuale errore di convalidazione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Validate(
    Object val,
    IDedEditable data,
    bool creating,
    bool revisioning,
    out string error
)
Public Function Validate (
    val As Object,
    data As IDedEditable,
    creating As Boolean,
    revisioning As Boolean,
    <OutAttribute> ByRef error As String
) As Boolean
public:
bool Validate(
    Object^ val,
    IDedEditable^ data,
    bool creating,
    bool revisioning,
    [OutAttribute] String^% error
)
member Validate :
        val : Object *
        data : IDedEditable *
        creating : bool *
        revisioning : bool *
        error : string byref -> bool

Parametri

val Object
Valore da convalidare.
data IDedEditable
creating Boolean
revisioning Boolean
error String
Errore di validazione restituito al chiamante.

Valore di ritorno

Boolean
Restituisce true se il valore è convalidato altrimenti false.
Vedi anche

Documentazione

Classe DedAttr
Overload di Validate
Namespace DedNet.Core


Campi di DedAttr

Il tipo DedAttr espone i seguenti membri.

Campi
Nome | Descrizione
_dataTimeMin | Identifica la data
Torna su
Vedi anche

Documentazione

Classe DedAttr
Namespace DedNet.Core


Campo DedAttr._dataTimeMin

Campo DedAttr_dataTimeMin
Identifica la data

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static DateTime _dataTimeMin
Public Shared _dataTimeMin As DateTime
public:
static DateTime _dataTimeMin
static val mutable _dataTimeMin: DateTime

Valore del campo

DateTime
Vedi anche

Documentazione

Classe DedAttr
Namespace DedNet.Core


Classe DedAttrCollection
Collezione modificabile di attributi.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedDbCollectionBase DedAttr
DedNet.CoreDedAttrCollection

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedAttrCollection : DedDbCollectionBase<DedAttr>
Public Class DedAttrCollection
    Inherits DedDbCollectionBase(Of DedAttr)
public ref class DedAttrCollection : public DedDbCollectionBase<DedAttr^>
type DedAttrCollection =
    class
        inherit DedDbCollectionBase<DedAttr>
    end

Il tipo DedAttrCollection espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllowsDuplicates | Restituisce se siano ammessi duplicati all'interno della lista. Se false viene sollevata una eccezione su tentativo di inserimento duplicati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Application | Restituisce l'oggetto applicazione di appartenza. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | AttributeAnagrAlterTable | Indica se sono stati modificati gli attributi anagrafici e devono essere ricreati tramite Alter Table.
Proprietà pubblica | AttributeBomAlterTable | Indica se sono stati modificati gli attributi di distinta e devono essere ricreati tramite Alter Table.
Proprietà pubblica | AttributeCommAlterTable | Indica se sono stati modificati gli attributi delle commesse e devono essere ricreati tramite Alter Table.
Proprietà pubblica | AttributeCommAnagrAlterTable | Indica se sono stati modificati gli attributi delle anagrafiche di commessa e devono essere ricreati tramite Alter Table.
Proprietà pubblica | AttributeDocAlterTable | Indica se sono stati modificati gli attributi di documento e devono essere ricreati tramite Alter Table.
Proprietà pubblica | AttributeEcoAlterTable | Indica se sono stati modificati gli attributi di ECO e devono essere ricreati tramite Alter Table.
Proprietà pubblica | Count | Restituisce il numero di elementi presenti. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Dirty | Restituisce se la collezione o uno dei suoi elementi sia stata modificata. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | DirtyDedIdOrDedRev | Indica se sono stati modificati gli attributi DEDID o DEREV e devono essere ricreati tramite Alter Table.
Proprietà pubblica | ErasedItems | Restitusice la lista in sola lettura degli elementi che risultano attualmente cancellati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | LastItem | Restituisce l'ultimo elemento della collezione oppure null se non ci sono elementi. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | OwnedByCommType | Restituisce se questa collezione sia o meno appartenente ad una commessa.
Proprietà pubblica | OwnedByEco | Restituisce se questa collezione sia o meno appartenente ad un ECO.
Proprietà pubblica | OwnedByType | Restituisce se questa collezione sia o meno appartenente ad una famiglia.
Proprietà pubblica | Owner | Restituisce la famiglia di appartenenza.
Proprietà pubblica | RestoreErased | Restituisce se gli elementi cancellati devono essere ripristinati in caso vengano riaggiunti. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | TypeAttr | Indica a che categoria appartiene la collezione (se attributi di anagrafica, commessa, ecc..).
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Add(DedAttr) | Aggiunge alla collezione un elemento già esistente. Gli imposta già come padre la nuova collezione.
Metodo pubblico | Add(DedAttr, Boolean) | Aggiunge alla collezione un elemento già esistente. Gli imposta già come padre la nuova collezione.
Metodo pubblico | Add(String, String, Type, Boolean) | Aggiunge un nuovo elemento alla collezione e lo restituisce.
Metodo protetto | AddForClone | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto SENZA MODIFICARNE LO STATO. Le classi derivate potranno utilizzare questo metodo per clonare la collezione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddNewElement | DI USO INTERNO. Aggiunge un elemento alla lista rendendo dirty l'oggetto. L'elemento viene aggiunto con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere un elemento alla lista. Dovranno loro stesse avere un metodo pubblico Add() che prenda i parametri necessari alla costruzione dell'oggetto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddRangeNewElement | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi rendendo dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere più elementi alla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddUnModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Clear | Elimina tutti gli elementi dalla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ClearRefresh | Svuota la lista impostando Dirty = false. Di fatto permette di effettuare un refresh della lista e quindi di ricaricarla. Serve per svuotare la lista e reinizializzarla da capo. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Clone(DedType) | Metodo per clonare la lista di attributi abbinati alle famiglie.
Metodo pubblico | Clone(DedCommType, Boolean) | Metodo per clonare la lista di attributi abbinati alle commesse.
Metodo pubblico | Contains | Verifica l'esistenza di un valore all'interno della lista degli elementi. Le classi derivate devono effettuarne l'override nel caso in cui l'elemento non implementi GetHashCode() per l'uso all'interno dei dizionarii. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | CopyTo | Copia un range di elementi in un array. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | CreateDeleteCommand | Crea un comando per eliminare un elemento. (Sovrascrive DedDbCollectionBaseTCreateDeleteCommand(T))
Metodo protetto | CreateInsertCommand | Crea un comando per inserire un elemento. (Sovrascrive DedDbCollectionBaseTCreateInsertCommand(T))
Metodo protetto | CreateUpdateCommand | Crea un comando per aggiornare un elemento. (Sovrascrive DedDbCollectionBaseTCreateUpdateCommand(T))
Metodo pubblico | CustomSort | Ordina la lista in base al comparatore passato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteDeleteItem | Esegue l'eliminazione di un elemento. Crea il comando tramite il metodo CreateDeleteCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteInsertItem | Esegue l'inserimento di un elemento. Crea il comando tramite il metodo CreateInsertCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteUpdateItem | Esegue l'aggiornamento di un elemento. Crea il comando tramite il metodo CreateUpdateCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Find | Restituisce l'oggetto cercato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FindAll | Restitusice la lista degli elementi che corrispondono al predicato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FindByName | Cerca nella collezione un attributo che abbia il nome specificato.
Metodo pubblico | FindByPrompt | Cerca nella collezione un attributo che abbia il prompt specificato.
Metodo protetto | GetDbIndex | Restituisce l'indice dell'oggetto. (Sovrascrive DedDbCollectionBaseTGetDbIndex(T))
Metodo pubblico | GetEnumerator | Restituisce l'enumeratore della collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | IndexOf | Restituisce l'indice dell'elemento richiesto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Insert | Aggiunge e restituisce un un nuovo elemento alla collezione inserendolo alla posizione specificata.
Metodo pubblico | InsertRedefinedAttr | Aggiunge e restituisce un un nuovo elemento alla collezione inserendolo alla posizione calcolata in base al suo Ord.
Metodo protetto | InsertUnModified | DI USO INTERNO. Inserisce un elemento alla lista senza rendere dirty l'oggetto, all'indice specificato. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Item | Restituisce l'elemento iesimo della lista. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean) | Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi. (Sovrascrive DedDbCollectionBaseTMove(Int32, Boolean))
Metodo pubblico | Move(Int32, Boolean, Int32) | Sposta l'elemento dell'indice passato prima o dopo del numero di posizioni passate. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | NeedRebuildOrder | Controlla se la collezione passata necessità di un rebuild dell'Ord
Metodo protetto | OnAfterSave | Elimino da DED_DATA i campi che non sono più in uso. (Sovrascrive DedDbCollectionBaseTOnAfterSave(ListT, ListT, ListT))
Metodo protetto | OnAfterSaveNoChanges | Metodo Template chiamato dopo il salvataggio senza modifiche. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnBeforeSave | Metodo Template chiamato prima del salvataggio. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(T) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(DedEditableObjectT) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(T) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(DedEditableObjectT) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ReInitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Remove | Elimina un elemento dalla collezione. (Sovrascrive DedDbCollectionBaseTRemove(T))
Metodo pubblico | Ripristina | Verifica che l'elemento sia presente negli eliminati e lo toglie da lì e lo riaggiunge in coda alla lista degli elementi validi. Solleva una eccezione se l'elemento è già presente nella lista e AllowsDuplicates = false. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Save | Salva l'oggetto con tutta la sua lista, solo se questo risulta dirty. (Ereditato da DedDbCollectionBaseT)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di DedAttrCollection

Il tipo DedAttrCollection espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllowsDuplicates | Restituisce se siano ammessi duplicati all'interno della lista. Se false viene sollevata una eccezione su tentativo di inserimento duplicati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Application | Restituisce l'oggetto applicazione di appartenza. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | AttributeAnagrAlterTable | Indica se sono stati modificati gli attributi anagrafici e devono essere ricreati tramite Alter Table.
Proprietà pubblica | AttributeBomAlterTable | Indica se sono stati modificati gli attributi di distinta e devono essere ricreati tramite Alter Table.
Proprietà pubblica | AttributeCommAlterTable | Indica se sono stati modificati gli attributi delle commesse e devono essere ricreati tramite Alter Table.
Proprietà pubblica | AttributeCommAnagrAlterTable | Indica se sono stati modificati gli attributi delle anagrafiche di commessa e devono essere ricreati tramite Alter Table.
Proprietà pubblica | AttributeDocAlterTable | Indica se sono stati modificati gli attributi di documento e devono essere ricreati tramite Alter Table.
Proprietà pubblica | AttributeEcoAlterTable | Indica se sono stati modificati gli attributi di ECO e devono essere ricreati tramite Alter Table.
Proprietà pubblica | Count | Restituisce il numero di elementi presenti. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Dirty | Restituisce se la collezione o uno dei suoi elementi sia stata modificata. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | DirtyDedIdOrDedRev | Indica se sono stati modificati gli attributi DEDID o DEREV e devono essere ricreati tramite Alter Table.
Proprietà pubblica | ErasedItems | Restitusice la lista in sola lettura degli elementi che risultano attualmente cancellati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | LastItem | Restituisce l'ultimo elemento della collezione oppure null se non ci sono elementi. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | OwnedByCommType | Restituisce se questa collezione sia o meno appartenente ad una commessa.
Proprietà pubblica | OwnedByEco | Restituisce se questa collezione sia o meno appartenente ad un ECO.
Proprietà pubblica | OwnedByType | Restituisce se questa collezione sia o meno appartenente ad una famiglia.
Proprietà pubblica | Owner | Restituisce la famiglia di appartenenza.
Proprietà pubblica | RestoreErased | Restituisce se gli elementi cancellati devono essere ripristinati in caso vengano riaggiunti. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | TypeAttr | Indica a che categoria appartiene la collezione (se attributi di anagrafica, commessa, ecc..).
Torna su
Vedi anche

Documentazione

Classe DedAttrCollection
Namespace DedNet.Core


Proprietà DedAttrCollection.AttributeAnagrAlterTable

Proprietà DedAttrCollectionAttributeAnagrAlterTable
Indica se sono stati modificati gli attributi anagrafici e devono essere ricreati tramite Alter Table.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AttributeAnagrAlterTable { get; set; }
Public Property AttributeAnagrAlterTable As Boolean
    Get
    Set
public:
property bool AttributeAnagrAlterTable {
    bool get ();
    void set (bool value);
}
member AttributeAnagrAlterTable : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAttrCollection
Namespace DedNet.Core


Proprietà DedAttrCollection.AttributeBomAlterTable

Proprietà DedAttrCollectionAttributeBomAlterTable
Indica se sono stati modificati gli attributi di distinta e devono essere ricreati tramite Alter Table.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AttributeBomAlterTable { get; set; }
Public Property AttributeBomAlterTable As Boolean
    Get
    Set
public:
property bool AttributeBomAlterTable {
    bool get ();
    void set (bool value);
}
member AttributeBomAlterTable : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAttrCollection
Namespace DedNet.Core


Proprietà DedAttrCollection.AttributeCommAlterTable

Proprietà DedAttrCollectionAttributeCommAlterTable
Indica se sono stati modificati gli attributi delle commesse e devono essere ricreati tramite Alter Table.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AttributeCommAlterTable { get; set; }
Public Property AttributeCommAlterTable As Boolean
    Get
    Set
public:
property bool AttributeCommAlterTable {
    bool get ();
    void set (bool value);
}
member AttributeCommAlterTable : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAttrCollection
Namespace DedNet.Core


Proprietà DedAttrCollection.AttributeCommAnagrAlterTable

Proprietà DedAttrCollectionAttributeCommAnagrAlterTable
Indica se sono stati modificati gli attributi delle anagrafiche di commessa e devono essere ricreati tramite Alter Table.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AttributeCommAnagrAlterTable { get; set; }
Public Property AttributeCommAnagrAlterTable As Boolean
    Get
    Set
public:
property bool AttributeCommAnagrAlterTable {
    bool get ();
    void set (bool value);
}
member AttributeCommAnagrAlterTable : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAttrCollection
Namespace DedNet.Core


Proprietà DedAttrCollection.AttributeDocAlterTable

Proprietà DedAttrCollectionAttributeDocAlterTable
Indica se sono stati modificati gli attributi di documento e devono essere ricreati tramite Alter Table.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AttributeDocAlterTable { get; set; }
Public Property AttributeDocAlterTable As Boolean
    Get
    Set
public:
property bool AttributeDocAlterTable {
    bool get ();
    void set (bool value);
}
member AttributeDocAlterTable : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAttrCollection
Namespace DedNet.Core


Proprietà DedAttrCollection.AttributeEcoAlterTable

Proprietà DedAttrCollectionAttributeEcoAlterTable
Indica se sono stati modificati gli attributi di ECO e devono essere ricreati tramite Alter Table.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AttributeEcoAlterTable { get; set; }
Public Property AttributeEcoAlterTable As Boolean
    Get
    Set
public:
property bool AttributeEcoAlterTable {
    bool get ();
    void set (bool value);
}
member AttributeEcoAlterTable : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAttrCollection
Namespace DedNet.Core


Proprietà DedAttrCollection.DirtyDedIdOrDedRev

Proprietà DedAttrCollectionDirtyDedIdOrDedRev
Indica se sono stati modificati gli attributi DEDID o DEREV e devono essere ricreati tramite Alter Table.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool DirtyDedIdOrDedRev { get; set; }
Public Property DirtyDedIdOrDedRev As Boolean
    Get
    Set
public:
property bool DirtyDedIdOrDedRev {
    bool get ();
    void set (bool value);
}
member DirtyDedIdOrDedRev : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAttrCollection
Namespace DedNet.Core


Proprietà DedAttrCollection.OwnedByCommType

Proprietà DedAttrCollectionOwnedByCommType
Restituisce se questa collezione sia o meno appartenente ad una commessa.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool OwnedByCommType { get; }
Public ReadOnly Property OwnedByCommType As Boolean
    Get
public:
property bool OwnedByCommType {
    bool get ();
}
member OwnedByCommType : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAttrCollection
Namespace DedNet.Core


Proprietà DedAttrCollection.OwnedByEco

Proprietà DedAttrCollectionOwnedByEco
Restituisce se questa collezione sia o meno appartenente ad un ECO.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool OwnedByEco { get; }
Public ReadOnly Property OwnedByEco As Boolean
    Get
public:
property bool OwnedByEco {
    bool get ();
}
member OwnedByEco : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAttrCollection
Namespace DedNet.Core


Proprietà DedAttrCollection.OwnedByType

Proprietà DedAttrCollectionOwnedByType
Restituisce se questa collezione sia o meno appartenente ad una famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool OwnedByType { get; }
Public ReadOnly Property OwnedByType As Boolean
    Get
public:
property bool OwnedByType {
    bool get ();
}
member OwnedByType : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAttrCollection
Namespace DedNet.Core


Proprietà DedAttrCollection.Owner

Proprietà DedAttrCollectionOwner
Restituisce la famiglia di appartenenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object Owner { get; }
Public ReadOnly Property Owner As Object
    Get
public:
property Object^ Owner {
    Object^ get ();
}
member Owner : Object with get

Valore della proprietà

Object
Vedi anche

Documentazione

Classe DedAttrCollection
Namespace DedNet.Core


Proprietà DedAttrCollection.TypeAttr

Proprietà DedAttrCollectionTypeAttr
Indica a che categoria appartiene la collezione (se attributi di anagrafica, commessa, ecc..).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrEnvDestEnum TypeAttr { get; set; }
Public Property TypeAttr As DedAttrEnvDestEnum
    Get
    Set
public:
property DedAttrEnvDestEnum TypeAttr {
    DedAttrEnvDestEnum get ();
    void set (DedAttrEnvDestEnum value);
}
member TypeAttr : DedAttrEnvDestEnum with get, set

Valore della proprietà

DedAttrEnvDestEnum
Vedi anche

Documentazione

Classe DedAttrCollection
Namespace DedNet.Core


Metodi di DedAttrCollection

Il tipo DedAttrCollection espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Add(DedAttr) | Aggiunge alla collezione un elemento già esistente. Gli imposta già come padre la nuova collezione.
Metodo pubblico | Add(DedAttr, Boolean) | Aggiunge alla collezione un elemento già esistente. Gli imposta già come padre la nuova collezione.
Metodo pubblico | Add(String, String, Type, Boolean) | Aggiunge un nuovo elemento alla collezione e lo restituisce.
Metodo protetto | AddForClone | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto SENZA MODIFICARNE LO STATO. Le classi derivate potranno utilizzare questo metodo per clonare la collezione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddNewElement | DI USO INTERNO. Aggiunge un elemento alla lista rendendo dirty l'oggetto. L'elemento viene aggiunto con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere un elemento alla lista. Dovranno loro stesse avere un metodo pubblico Add() che prenda i parametri necessari alla costruzione dell'oggetto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddRangeNewElement | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi rendendo dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere più elementi alla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddUnModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Clear | Elimina tutti gli elementi dalla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ClearRefresh | Svuota la lista impostando Dirty = false. Di fatto permette di effettuare un refresh della lista e quindi di ricaricarla. Serve per svuotare la lista e reinizializzarla da capo. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Clone(DedType) | Metodo per clonare la lista di attributi abbinati alle famiglie.
Metodo pubblico | Clone(DedCommType, Boolean) | Metodo per clonare la lista di attributi abbinati alle commesse.
Metodo pubblico | Contains | Verifica l'esistenza di un valore all'interno della lista degli elementi. Le classi derivate devono effettuarne l'override nel caso in cui l'elemento non implementi GetHashCode() per l'uso all'interno dei dizionarii. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | CopyTo | Copia un range di elementi in un array. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | CreateDeleteCommand | Crea un comando per eliminare un elemento. (Sovrascrive DedDbCollectionBaseTCreateDeleteCommand(T))
Metodo protetto | CreateInsertCommand | Crea un comando per inserire un elemento. (Sovrascrive DedDbCollectionBaseTCreateInsertCommand(T))
Metodo protetto | CreateUpdateCommand | Crea un comando per aggiornare un elemento. (Sovrascrive DedDbCollectionBaseTCreateUpdateCommand(T))
Metodo pubblico | CustomSort | Ordina la lista in base al comparatore passato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteDeleteItem | Esegue l'eliminazione di un elemento. Crea il comando tramite il metodo CreateDeleteCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteInsertItem | Esegue l'inserimento di un elemento. Crea il comando tramite il metodo CreateInsertCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteUpdateItem | Esegue l'aggiornamento di un elemento. Crea il comando tramite il metodo CreateUpdateCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Find | Restituisce l'oggetto cercato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FindAll | Restitusice la lista degli elementi che corrispondono al predicato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FindByName | Cerca nella collezione un attributo che abbia il nome specificato.
Metodo pubblico | FindByPrompt | Cerca nella collezione un attributo che abbia il prompt specificato.
Metodo protetto | GetDbIndex | Restituisce l'indice dell'oggetto. (Sovrascrive DedDbCollectionBaseTGetDbIndex(T))
Metodo pubblico | GetEnumerator | Restituisce l'enumeratore della collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | IndexOf | Restituisce l'indice dell'elemento richiesto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Insert | Aggiunge e restituisce un un nuovo elemento alla collezione inserendolo alla posizione specificata.
Metodo pubblico | InsertRedefinedAttr | Aggiunge e restituisce un un nuovo elemento alla collezione inserendolo alla posizione calcolata in base al suo Ord.
Metodo protetto | InsertUnModified | DI USO INTERNO. Inserisce un elemento alla lista senza rendere dirty l'oggetto, all'indice specificato. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Item | Restituisce l'elemento iesimo della lista. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean) | Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi. (Sovrascrive DedDbCollectionBaseTMove(Int32, Boolean))
Metodo pubblico | Move(Int32, Boolean, Int32) | Sposta l'elemento dell'indice passato prima o dopo del numero di posizioni passate. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | NeedRebuildOrder | Controlla se la collezione passata necessità di un rebuild dell'Ord
Metodo protetto | OnAfterSave | Elimino da DED_DATA i campi che non sono più in uso. (Sovrascrive DedDbCollectionBaseTOnAfterSave(ListT, ListT, ListT))
Metodo protetto | OnAfterSaveNoChanges | Metodo Template chiamato dopo il salvataggio senza modifiche. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnBeforeSave | Metodo Template chiamato prima del salvataggio. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(T) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(DedEditableObjectT) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(T) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(DedEditableObjectT) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ReInitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Remove | Elimina un elemento dalla collezione. (Sovrascrive DedDbCollectionBaseTRemove(T))
Metodo pubblico | Ripristina | Verifica che l'elemento sia presente negli eliminati e lo toglie da lì e lo riaggiunge in coda alla lista degli elementi validi. Solleva una eccezione se l'elemento è già presente nella lista e AllowsDuplicates = false. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Save | Salva l'oggetto con tutta la sua lista, solo se questo risulta dirty. (Ereditato da DedDbCollectionBaseT)
Torna su
Vedi anche

Documentazione

Classe DedAttrCollection
Namespace DedNet.Core


Metodo DedAttrCollection.Add

Metodo DedAttrCollectionAdd
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Add(DedAttr) | Aggiunge alla collezione un elemento già esistente. Gli imposta già come padre la nuova collezione.
Metodo pubblico | Add(DedAttr, Boolean) | Aggiunge alla collezione un elemento già esistente. Gli imposta già come padre la nuova collezione.
Metodo pubblico | Add(String, String, Type, Boolean) | Aggiunge un nuovo elemento alla collezione e lo restituisce.
Torna su
Vedi anche

Documentazione

Classe DedAttrCollection
Namespace DedNet.Core


Metodo DedAttrCollection.Add(DedAttr)

Metodo DedAttrCollectionAdd(DedAttr)
Aggiunge alla collezione un elemento già esistente. Gli imposta già come padre la nuova collezione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Add(
    DedAttr attr
)
Public Sub Add (
    attr As DedAttr
)
public:
void Add(
    DedAttr^ attr
)
member Add :
        attr : DedAttr -> unit

Parametri

attr DedAttr
Attributo da aggiungere alla collezione.
Vedi anche

Documentazione

Classe DedAttrCollection
Overload di Add
Namespace DedNet.Core


Metodo DedAttrCollection.Add(DedAttr, Boolean)

Metodo DedAttrCollectionAdd(DedAttr, Boolean)
Aggiunge alla collezione un elemento già esistente. Gli imposta già come padre la nuova collezione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Add(
    DedAttr attr,
    bool keepOrd = false
)
Public Sub Add (
    attr As DedAttr,
    Optional keepOrd As Boolean = false
)
public:
void Add(
    DedAttr^ attr,
    bool keepOrd = false
)
member Add :
        attr : DedAttr *
        ?keepOrd : bool
(* Defaults:
        let _keepOrd = defaultArg keepOrd false
*)
-> unit

Parametri

attr DedAttr
Attributo da aggiungere alla collezione.
keepOrd Boolean (Optional)
Indica se ordinare gli attributi. Di default è a False (gli attributi vengono clonati)
Vedi anche

Documentazione

Classe DedAttrCollection
Overload di Add
Namespace DedNet.Core


Metodo DedAttrCollection.Add(String, String, Type, Boolean)

Metodo DedAttrCollectionAdd(String, String, Type, Boolean)
Aggiunge un nuovo elemento alla collezione e lo restituisce.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttr Add(
    string Nome,
    string Prompt,
    Type TipoDati,
    bool isSparePart
)
Public Function Add (
    Nome As String,
    Prompt As String,
    TipoDati As Type,
    isSparePart As Boolean
) As DedAttr
public:
DedAttr^ Add(
    String^ Nome,
    String^ Prompt,
    Type^ TipoDati,
    bool isSparePart
)
member Add :
        Nome : string *
        Prompt : string *
        TipoDati : Type *
        isSparePart : bool -> DedAttr

Parametri

Nome String
Nome dell'attributo.
Prompt String
Prompt dell'attributo.
TipoDati Type
Tipo dati dell'attributo.
isSparePart Boolean
Indica se è un attributo di ricambio

Valore di ritorno

DedAttr
Restituisce l'attributo aggiunto.
Vedi anche

Documentazione

Classe DedAttrCollection
Overload di Add
Namespace DedNet.Core


Metodo DedAttrCollection.Clone

Metodo DedAttrCollectionClone
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Clone(DedType) | Metodo per clonare la lista di attributi abbinati alle famiglie.
Metodo pubblico | Clone(DedCommType, Boolean) | Metodo per clonare la lista di attributi abbinati alle commesse.
Torna su
Vedi anche

Documentazione

Classe DedAttrCollection
Namespace DedNet.Core


Metodo DedAttrCollection.Clone(DedType)

Metodo DedAttrCollectionClone(DedType)
Metodo per clonare la lista di attributi abbinati alle famiglie.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrCollection Clone(
    DedType owner
)
Public Function Clone (
    owner As DedType
) As DedAttrCollection
public:
DedAttrCollection^ Clone(
    DedType^ owner
)
member Clone :
        owner : DedType -> DedAttrCollection

Parametri

owner DedType

Valore di ritorno

DedAttrCollection
Vedi anche

Documentazione

Classe DedAttrCollection
Overload di Clone
Namespace DedNet.Core


Metodo DedAttrCollection.Clone(DedCommType, Boolean)

Metodo DedAttrCollectionClone(DedCommType, Boolean)
Metodo per clonare la lista di attributi abbinati alle commesse.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrCollection Clone(
    DedCommType owner,
    bool commAttr
)
Public Function Clone (
    owner As DedCommType,
    commAttr As Boolean
) As DedAttrCollection
public:
DedAttrCollection^ Clone(
    DedCommType^ owner,
    bool commAttr
)
member Clone :
        owner : DedCommType *
        commAttr : bool -> DedAttrCollection

Parametri

owner DedCommType
commAttr Boolean

Valore di ritorno

DedAttrCollection
Vedi anche

Documentazione

Classe DedAttrCollection
Overload di Clone
Namespace DedNet.Core


Metodo DedAttrCollection.CreateDeleteCommand

Metodo DedAttrCollectionCreateDeleteCommand
Crea un comando per eliminare un elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSDeleteCommand CreateDeleteCommand(
    DedAttr item
)
Protected Overrides Function CreateDeleteCommand (
    item As DedAttr
) As QSDeleteCommand
protected:
virtual QSDeleteCommand^ CreateDeleteCommand(
    DedAttr^ item
) override
abstract CreateDeleteCommand :
        item : DedAttr -> QSDeleteCommand
override CreateDeleteCommand :
        item : DedAttr -> QSDeleteCommand

Parametri

item DedAttr
Elemento da eliminare.

Valore di ritorno

QSDeleteCommand
Vedi anche

Documentazione

Classe DedAttrCollection
Namespace DedNet.Core


Metodo DedAttrCollection.CreateInsertCommand

Metodo DedAttrCollectionCreateInsertCommand
Crea un comando per inserire un elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSInsertCommand CreateInsertCommand(
    DedAttr item
)
Protected Overrides Function CreateInsertCommand (
    item As DedAttr
) As QSInsertCommand
protected:
virtual QSInsertCommand^ CreateInsertCommand(
    DedAttr^ item
) override
abstract CreateInsertCommand :
        item : DedAttr -> QSInsertCommand
override CreateInsertCommand :
        item : DedAttr -> QSInsertCommand

Parametri

item DedAttr
Elemento da inserire.

Valore di ritorno

QSInsertCommand
Vedi anche

Documentazione

Classe DedAttrCollection
Namespace DedNet.Core


Metodo DedAttrCollection.CreateUpdateCommand

Metodo DedAttrCollectionCreateUpdateCommand
Crea un comando per aggiornare un elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSUpdateCommand CreateUpdateCommand(
    DedAttr item
)
Protected Overrides Function CreateUpdateCommand (
    item As DedAttr
) As QSUpdateCommand
protected:
virtual QSUpdateCommand^ CreateUpdateCommand(
    DedAttr^ item
) override
abstract CreateUpdateCommand :
        item : DedAttr -> QSUpdateCommand
override CreateUpdateCommand :
        item : DedAttr -> QSUpdateCommand

Parametri

item DedAttr
Elemento da aggiornare.

Valore di ritorno

QSUpdateCommand
Vedi anche

Documentazione

Classe DedAttrCollection
Namespace DedNet.Core


Metodo DedAttrCollection.FindByName

Metodo DedAttrCollectionFindByName
Cerca nella collezione un attributo che abbia il nome specificato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttr FindByName(
    string name
)
Public Function FindByName (
    name As String
) As DedAttr
public:
DedAttr^ FindByName(
    String^ name
)
member FindByName :
        name : string -> DedAttr

Parametri

name String
Nome dell'attributo da cercare.

Valore di ritorno

DedAttr
Restituisce null se non riesce a trovarlo.
Vedi anche

Documentazione

Classe DedAttrCollection
Namespace DedNet.Core


Metodo DedAttrCollection.FindByPrompt

Metodo DedAttrCollectionFindByPrompt
Cerca nella collezione un attributo che abbia il prompt specificato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttr FindByPrompt(
    string prompt
)
Public Function FindByPrompt (
    prompt As String
) As DedAttr
public:
DedAttr^ FindByPrompt(
    String^ prompt
)
member FindByPrompt :
        prompt : string -> DedAttr

Parametri

prompt String
Prompt dell'attributo da cercare.

Valore di ritorno

DedAttr
Restituisce null se non riesce a trovarlo.
Vedi anche

Documentazione

Classe DedAttrCollection
Namespace DedNet.Core


Metodo DedAttrCollection.GetDbIndex

Metodo DedAttrCollectionGetDbIndex
Restituisce l'indice dell'oggetto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override Object GetDbIndex(
    DedAttr item
)
Protected Overrides Function GetDbIndex (
    item As DedAttr
) As Object
protected:
virtual Object^ GetDbIndex(
    DedAttr^ item
) override
abstract GetDbIndex :
        item : DedAttr -> Object
override GetDbIndex :
        item : DedAttr -> Object

Parametri

item DedAttr
Elemento di cui restituire l'indice.

Valore di ritorno

Object
Vedi anche

Documentazione

Classe DedAttrCollection
Namespace DedNet.Core


Metodo DedAttrCollection.Insert

Metodo DedAttrCollectionInsert
Aggiunge e restituisce un un nuovo elemento alla collezione inserendolo alla posizione specificata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttr Insert(
    int index,
    string Nome,
    string Prompt,
    Type TipoDati,
    bool isSparePart
)
Public Function Insert (
    index As Integer,
    Nome As String,
    Prompt As String,
    TipoDati As Type,
    isSparePart As Boolean
) As DedAttr
public:
DedAttr^ Insert(
    int index,
    String^ Nome,
    String^ Prompt,
    Type^ TipoDati,
    bool isSparePart
)
member Insert :
        index : int *
        Nome : string *
        Prompt : string *
        TipoDati : Type *
        isSparePart : bool -> DedAttr

Parametri

index Int32
Indice di inserimento del nuovo elemento.
Nome String
Nome dell'attributo.
Prompt String
Prompt dell'attributo.
TipoDati Type
Tipo dati dell'attributo.
isSparePart Boolean

Valore di ritorno

DedAttr
Restituisce l'attributo aggiunto.
Vedi anche

Documentazione

Classe DedAttrCollection
Namespace DedNet.Core


Metodo DedAttrCollection.InsertRedefinedAttr

Metodo DedAttrCollectionInsertRedefinedAttr
Aggiunge e restituisce un un nuovo elemento alla collezione inserendolo alla posizione calcolata in base al suo Ord.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttr InsertRedefinedAttr(
    DedAttr rest
)
Public Function InsertRedefinedAttr (
    rest As DedAttr
) As DedAttr
public:
DedAttr^ InsertRedefinedAttr(
    DedAttr^ rest
)
member InsertRedefinedAttr :
        rest : DedAttr -> DedAttr

Parametri

rest DedAttr
Indice di inserimento del nuovo elemento.

Valore di ritorno

DedAttr
Restituisce l'attributo aggiunto.
Vedi anche

Documentazione

Classe DedAttrCollection
Namespace DedNet.Core


Metodo DedAttrCollection.Move

Metodo DedAttrCollectionMove
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Move(Int32, Boolean) | Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi.
Metodo pubblico | Move(Int32, Boolean, Int32) | Sposta l'elemento dell'indice passato prima o dopo del numero di posizioni passate. Ignora eventuali valori di indice non validi.
Torna su
Vedi anche

Documentazione

Classe DedAttrCollection
Namespace DedNet.Core


Metodo DedAttrCollection.Move(Int32, Boolean)

Metodo DedAttrCollectionMove(Int32, Boolean)
Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void Move(
    int index,
    bool up
)
Public Overrides Sub Move (
    index As Integer,
    up As Boolean
)
public:
virtual void Move(
    int index,
    bool up
) override
abstract Move :
        index : int *
        up : bool -> unit
override Move :
        index : int *
        up : bool -> unit

Parametri

index Int32
Indice dell'elemento da spostare.
up Boolean
Se true l'elemento viene spostato in alto (nell'indice precedente) altrimenti all'indice successivo.
Vedi anche

Documentazione

Classe DedAttrCollection
Overload di Move
Namespace DedNet.Core


Metodo DedAttrCollection.NeedRebuildOrder

Metodo DedAttrCollectionNeedRebuildOrder
Controlla se la collezione passata necessità di un rebuild dell'Ord

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool NeedRebuildOrder(
    DedAttrList coll
)
Public Function NeedRebuildOrder (
    coll As DedAttrList
) As Boolean
public:
bool NeedRebuildOrder(
    DedAttrList^ coll
)
member NeedRebuildOrder :
        coll : DedAttrList -> bool

Parametri

coll DedAttrList
Collection da controllare

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedAttrCollection
Namespace DedNet.Core


Metodo DedAttrCollection.OnAfterSave

Metodo DedAttrCollectionOnAfterSave
Elimino da DED_DATA i campi che non sono più in uso.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void OnAfterSave(
    List<DedAttr> eliminati,
    List<DedAttr> modificati,
    List<DedAttr> aggiunti
)
Protected Overrides Sub OnAfterSave (
    eliminati As List(Of DedAttr),
    modificati As List(Of DedAttr),
    aggiunti As List(Of DedAttr)
)
protected:
virtual void OnAfterSave(
    List<DedAttr^>^ eliminati,
    List<DedAttr^>^ modificati,
    List<DedAttr^>^ aggiunti
) override
abstract OnAfterSave :
        eliminati : List<DedAttr> *
        modificati : List<DedAttr> *
        aggiunti : List<DedAttr> -> unit
override OnAfterSave :
        eliminati : List<DedAttr> *
        modificati : List<DedAttr> *
        aggiunti : List<DedAttr> -> unit

Parametri

eliminati List DedAttr
Eliminati.
modificati List DedAttr
Modificati.
aggiunti List DedAttr
Aggiunti.
Vedi anche

Documentazione

Classe DedAttrCollection
Namespace DedNet.Core


Metodo DedAttrCollection.Remove

Metodo DedAttrCollectionRemove
Elimina un elemento dalla collezione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void Remove(
    DedAttr itemToRemove
)
Public Overrides Sub Remove (
    itemToRemove As DedAttr
)
public:
virtual void Remove(
    DedAttr^ itemToRemove
) override
abstract Remove :
        itemToRemove : DedAttr -> unit
override Remove :
        itemToRemove : DedAttr -> unit

Parametri

itemToRemove DedAttr
Elemento da eliminare.
Vedi anche

Documentazione

Classe DedAttrCollection
Namespace DedNet.Core


Classe DedAttrDateValidator
Classe per la validazione di un attributo di tipo Data.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedAttrValidatorBase
DedNet.CoreDedAttrDateValidator

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedAttrDateValidator : DedAttrValidatorBase
Public Class DedAttrDateValidator
    Inherits DedAttrValidatorBase
public ref class DedAttrDateValidator : public DedAttrValidatorBase
type DedAttrDateValidator =
    class
        inherit DedAttrValidatorBase
    end

Il tipo DedAttrDateValidator espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Attr | Restituisce l'attributo di appartenenza. (Ereditato da DedAttrValidatorBase)
Proprietà pubblica | CheckFunction | Imposta o restituisce il nome della funzione di controllo personalizzata. (Ereditato da DedAttrValidatorBase)
Proprietà pubblica | Required | Imposta o restituisce se l'attributo possa o meno essere lasciato vuoto. (Ereditato da DedAttrValidatorBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Ereditato da DedAttrValidatorBase)
Metodo pubblico | GetHashCode | (Ereditato da DedAttrValidatorBase)
Metodo pubblico | HasCheckFunction | Verifica se questo attributo ha una funzione personalizzata. (Ereditato da DedAttrValidatorBase)
Metodo pubblico | IsRequired | Restituisce true se l'attributo è obbligatorio considerando anche il contesto (creazione/revisione) (Ereditato da DedAttrValidatorBase)
Metodo pubblico | ToString | (Ereditato da DedAttrValidatorBase)
Metodo pubblico | Validate(Object, IDedEditable, Boolean, Boolean) | Valida il valore dell'attributo senza sollevare eccezioni. (Sovrascrive DedAttrValidatorBaseValidate(Object, IDedEditable, Boolean, Boolean))
Metodo pubblico | Validate(Object, IDedEditable, Boolean, Boolean, String) | Valida il valore dell'attributo restituendo l'eventuale errore di convalidazione. (Sovrascrive DedAttrValidatorBaseValidate(Object, IDedEditable, Boolean, Boolean, String))
Metodo pubblico | ValueCanNotBeErased | Controlla se il valore può essere cancellato. Ovvero se non siamo in un'operazione di crea anagrafia o crea revisione e il tipo di obbligatorietà è cerazione o revisione il valore dell'attributo non può essere cancellato. Mentre se è già vuoto non necessita di essere compilato (come avviene per un obbligatorietà 'sempre') (Ereditato da DedAttrValidatorBase)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di DedAttrDateValidator

Il tipo DedAttrDateValidator espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Attr | Restituisce l'attributo di appartenenza. (Ereditato da DedAttrValidatorBase)
Proprietà pubblica | CheckFunction | Imposta o restituisce il nome della funzione di controllo personalizzata. (Ereditato da DedAttrValidatorBase)
Proprietà pubblica | Required | Imposta o restituisce se l'attributo possa o meno essere lasciato vuoto. (Ereditato da DedAttrValidatorBase)
Torna su
Vedi anche

Documentazione

Classe DedAttrDateValidator
Namespace DedNet.Core


Metodi di DedAttrDateValidator

Il tipo DedAttrDateValidator espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Ereditato da DedAttrValidatorBase)
Metodo pubblico | GetHashCode | (Ereditato da DedAttrValidatorBase)
Metodo pubblico | HasCheckFunction | Verifica se questo attributo ha una funzione personalizzata. (Ereditato da DedAttrValidatorBase)
Metodo pubblico | IsRequired | Restituisce true se l'attributo è obbligatorio considerando anche il contesto (creazione/revisione) (Ereditato da DedAttrValidatorBase)
Metodo pubblico | ToString | (Ereditato da DedAttrValidatorBase)
Metodo pubblico | Validate(Object, IDedEditable, Boolean, Boolean) | Valida il valore dell'attributo senza sollevare eccezioni. (Sovrascrive DedAttrValidatorBaseValidate(Object, IDedEditable, Boolean, Boolean))
Metodo pubblico | Validate(Object, IDedEditable, Boolean, Boolean, String) | Valida il valore dell'attributo restituendo l'eventuale errore di convalidazione. (Sovrascrive DedAttrValidatorBaseValidate(Object, IDedEditable, Boolean, Boolean, String))
Metodo pubblico | ValueCanNotBeErased | Controlla se il valore può essere cancellato. Ovvero se non siamo in un'operazione di crea anagrafia o crea revisione e il tipo di obbligatorietà è cerazione o revisione il valore dell'attributo non può essere cancellato. Mentre se è già vuoto non necessita di essere compilato (come avviene per un obbligatorietà 'sempre') (Ereditato da DedAttrValidatorBase)
Torna su
Vedi anche

Documentazione

Classe DedAttrDateValidator
Namespace DedNet.Core


Metodo DedAttrDateValidator.Validate

Metodo DedAttrDateValidatorValidate
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Validate(Object, IDedEditable, Boolean, Boolean) | Valida il valore dell'attributo senza sollevare eccezioni.
Metodo pubblico | Validate(Object, IDedEditable, Boolean, Boolean, String) | Valida il valore dell'attributo restituendo l'eventuale errore di convalidazione.
Torna su
Vedi anche

Documentazione

Classe DedAttrDateValidator
Namespace DedNet.Core


Metodo DedAttrDateValidator.Validate(Object, IDedEditable, Boolean, Boolean)

Metodo DedAttrDateValidatorValidate(Object, IDedEditable, Boolean, Boolean)
Valida il valore dell'attributo senza sollevare eccezioni.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Validate(
    Object val,
    IDedEditable data,
    bool creating,
    bool revisioning
)
Public Overrides Function Validate (
    val As Object,
    data As IDedEditable,
    creating As Boolean,
    revisioning As Boolean
) As Boolean
public:
virtual bool Validate(
    Object^ val,
    IDedEditable^ data,
    bool creating,
    bool revisioning
) override
abstract Validate :
        val : Object *
        data : IDedEditable *
        creating : bool *
        revisioning : bool -> bool
override Validate :
        val : Object *
        data : IDedEditable *
        creating : bool *
        revisioning : bool -> bool

Parametri

val Object
Valore da convalidare.
data IDedEditable
creating Boolean
revisioning Boolean

Valore di ritorno

Boolean
Restituisce true se il valore è convalidato altrimenti false.
Vedi anche

Documentazione

Classe DedAttrDateValidator
Overload di Validate
Namespace DedNet.Core


Metodo DedAttrDateValidator.Validate(Object, IDedEditable, Boolean, Boolean, String)

Metodo DedAttrDateValidatorValidate(Object, IDedEditable, Boolean, Boolean, String)
Valida il valore dell'attributo restituendo l'eventuale errore di convalidazione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Validate(
    Object val,
    IDedEditable deddata,
    bool creating,
    bool revisioning,
    out string error
)
Public Overrides Function Validate (
    val As Object,
    deddata As IDedEditable,
    creating As Boolean,
    revisioning As Boolean,
    <OutAttribute> ByRef error As String
) As Boolean
public:
virtual bool Validate(
    Object^ val,
    IDedEditable^ deddata,
    bool creating,
    bool revisioning,
    [OutAttribute] String^% error
) override
abstract Validate :
        val : Object *
        deddata : IDedEditable *
        creating : bool *
        revisioning : bool *
        error : string byref -> bool
override Validate :
        val : Object *
        deddata : IDedEditable *
        creating : bool *
        revisioning : bool *
        error : string byref -> bool

Parametri

val Object
Valore da convalidare.
deddata IDedEditable
creating Boolean
revisioning Boolean
error String
Errore di validazione restituito al chiamante.

Valore di ritorno

Boolean
Restituisce true se il valore è convalidato altrimenti false.
Vedi anche

Documentazione

Classe DedAttrDateValidator
Overload di Validate
Namespace DedNet.Core


Classe DedAttrDoubleValidator
Classe per la validazione di un attributo di tipo numero con virgola.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedAttrValidatorBase
DedNet.CoreDedAttrDoubleValidator

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedAttrDoubleValidator : DedAttrValidatorBase
Public Class DedAttrDoubleValidator
    Inherits DedAttrValidatorBase
public ref class DedAttrDoubleValidator : public DedAttrValidatorBase
type DedAttrDoubleValidator =
    class
        inherit DedAttrValidatorBase
    end

Il tipo DedAttrDoubleValidator espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Attr | Restituisce l'attributo di appartenenza. (Ereditato da DedAttrValidatorBase)
Proprietà pubblica | CheckFunction | Imposta o restituisce il nome della funzione di controllo personalizzata. (Ereditato da DedAttrValidatorBase)
Proprietà pubblica | Operatore | Restituisce l'operatore di confronto.
Proprietà pubblica | Required | Imposta o restituisce se l'attributo possa o meno essere lasciato vuoto. (Ereditato da DedAttrValidatorBase)
Proprietà pubblica | Val1 | Primo valore di confronto.
Proprietà pubblica | Val2 | Secondo valore di confronto.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Ereditato da DedAttrValidatorBase)
Metodo pubblico | GetHashCode | (Ereditato da DedAttrValidatorBase)
Metodo pubblico | HasCheckFunction | Verifica se questo attributo ha una funzione personalizzata. (Ereditato da DedAttrValidatorBase)
Metodo pubblico | IsRequired | Restituisce true se l'attributo è obbligatorio considerando anche il contesto (creazione/revisione) (Ereditato da DedAttrValidatorBase)
Metodo pubblico | ToString | (Sovrascrive DedAttrValidatorBaseToString)
Metodo pubblico | Validate(Object, IDedEditable, Boolean, Boolean) | Valida il valore dell'attributo senza sollevare eccezioni. (Sovrascrive DedAttrValidatorBaseValidate(Object, IDedEditable, Boolean, Boolean))
Metodo pubblico | Validate(Object, IDedEditable, Boolean, Boolean, String) | Valida il valore dell'attributo restituendo l'eventuale errore di convalidazione. (Sovrascrive DedAttrValidatorBaseValidate(Object, IDedEditable, Boolean, Boolean, String))
Metodo pubblico | ValueCanNotBeErased | Controlla se il valore può essere cancellato. Ovvero se non siamo in un'operazione di crea anagrafia o crea revisione e il tipo di obbligatorietà è cerazione o revisione il valore dell'attributo non può essere cancellato. Mentre se è già vuoto non necessita di essere compilato (come avviene per un obbligatorietà 'sempre') (Ereditato da DedAttrValidatorBase)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di DedAttrDoubleValidator

Il tipo DedAttrDoubleValidator espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Attr | Restituisce l'attributo di appartenenza. (Ereditato da DedAttrValidatorBase)
Proprietà pubblica | CheckFunction | Imposta o restituisce il nome della funzione di controllo personalizzata. (Ereditato da DedAttrValidatorBase)
Proprietà pubblica | Operatore | Restituisce l'operatore di confronto.
Proprietà pubblica | Required | Imposta o restituisce se l'attributo possa o meno essere lasciato vuoto. (Ereditato da DedAttrValidatorBase)
Proprietà pubblica | Val1 | Primo valore di confronto.
Proprietà pubblica | Val2 | Secondo valore di confronto.
Torna su
Vedi anche

Documentazione

Classe DedAttrDoubleValidator
Namespace DedNet.Core


Proprietà DedAttrDoubleValidator.Operatore

Proprietà DedAttrDoubleValidatorOperatore
Restituisce l'operatore di confronto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ValidatorOperator Operatore { get; set; }
Public Property Operatore As ValidatorOperator
    Get
    Set
public:
property ValidatorOperator Operatore {
    ValidatorOperator get ();
    void set (ValidatorOperator value);
}
member Operatore : ValidatorOperator with get, set

Valore della proprietà

ValidatorOperator
Vedi anche

Documentazione

Classe DedAttrDoubleValidator
Namespace DedNet.Core


Proprietà DedAttrDoubleValidator.Val1

Proprietà DedAttrDoubleValidatorVal1
Primo valore di confronto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public double? Val1 { get; set; }
Public Property Val1 As Double?
    Get
    Set
public:
property Nullable<double> Val1 {
    Nullable<double> get ();
    void set (Nullable<double> value);
}
member Val1 : Nullable<float> with get, set

Valore della proprietà

Nullable Double
Vedi anche

Documentazione

Classe DedAttrDoubleValidator
Namespace DedNet.Core


Proprietà DedAttrDoubleValidator.Val2

Proprietà DedAttrDoubleValidatorVal2
Secondo valore di confronto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public double? Val2 { get; set; }
Public Property Val2 As Double?
    Get
    Set
public:
property Nullable<double> Val2 {
    Nullable<double> get ();
    void set (Nullable<double> value);
}
member Val2 : Nullable<float> with get, set

Valore della proprietà

Nullable Double
Vedi anche

Documentazione

Classe DedAttrDoubleValidator
Namespace DedNet.Core


Metodi di DedAttrDoubleValidator

Il tipo DedAttrDoubleValidator espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Ereditato da DedAttrValidatorBase)
Metodo pubblico | GetHashCode | (Ereditato da DedAttrValidatorBase)
Metodo pubblico | HasCheckFunction | Verifica se questo attributo ha una funzione personalizzata. (Ereditato da DedAttrValidatorBase)
Metodo pubblico | IsRequired | Restituisce true se l'attributo è obbligatorio considerando anche il contesto (creazione/revisione) (Ereditato da DedAttrValidatorBase)
Metodo pubblico | ToString | (Sovrascrive DedAttrValidatorBaseToString)
Metodo pubblico | Validate(Object, IDedEditable, Boolean, Boolean) | Valida il valore dell'attributo senza sollevare eccezioni. (Sovrascrive DedAttrValidatorBaseValidate(Object, IDedEditable, Boolean, Boolean))
Metodo pubblico | Validate(Object, IDedEditable, Boolean, Boolean, String) | Valida il valore dell'attributo restituendo l'eventuale errore di convalidazione. (Sovrascrive DedAttrValidatorBaseValidate(Object, IDedEditable, Boolean, Boolean, String))
Metodo pubblico | ValueCanNotBeErased | Controlla se il valore può essere cancellato. Ovvero se non siamo in un'operazione di crea anagrafia o crea revisione e il tipo di obbligatorietà è cerazione o revisione il valore dell'attributo non può essere cancellato. Mentre se è già vuoto non necessita di essere compilato (come avviene per un obbligatorietà 'sempre') (Ereditato da DedAttrValidatorBase)
Torna su
Vedi anche

Documentazione

Classe DedAttrDoubleValidator
Namespace DedNet.Core


Metodo DedAttrDoubleValidator.ToString

Metodo DedAttrDoubleValidatorToString

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedAttrDoubleValidator
Namespace DedNet.Core


Metodo DedAttrDoubleValidator.Validate

Metodo DedAttrDoubleValidatorValidate
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Validate(Object, IDedEditable, Boolean, Boolean) | Valida il valore dell'attributo senza sollevare eccezioni.
Metodo pubblico | Validate(Object, IDedEditable, Boolean, Boolean, String) | Valida il valore dell'attributo restituendo l'eventuale errore di convalidazione.
Torna su
Vedi anche

Documentazione

Classe DedAttrDoubleValidator
Namespace DedNet.Core


Metodo DedAttrDoubleValidator.Validate(Object, IDedEditable, Boolean, Boolean)

Metodo DedAttrDoubleValidatorValidate(Object, IDedEditable, Boolean, Boolean)
Valida il valore dell'attributo senza sollevare eccezioni.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Validate(
    Object val,
    IDedEditable data,
    bool creating,
    bool revisioning
)
Public Overrides Function Validate (
    val As Object,
    data As IDedEditable,
    creating As Boolean,
    revisioning As Boolean
) As Boolean
public:
virtual bool Validate(
    Object^ val,
    IDedEditable^ data,
    bool creating,
    bool revisioning
) override
abstract Validate :
        val : Object *
        data : IDedEditable *
        creating : bool *
        revisioning : bool -> bool
override Validate :
        val : Object *
        data : IDedEditable *
        creating : bool *
        revisioning : bool -> bool

Parametri

val Object
Valore da convalidare.
data IDedEditable
creating Boolean
revisioning Boolean

Valore di ritorno

Boolean
Restituisce true se il valore è convalidato altrimenti false.
Vedi anche

Documentazione

Classe DedAttrDoubleValidator
Overload di Validate
Namespace DedNet.Core


Metodo DedAttrDoubleValidator.Validate(Object, IDedEditable, Boolean, Boolean, String)

Metodo DedAttrDoubleValidatorValidate(Object, IDedEditable, Boolean, Boolean, String)
Valida il valore dell'attributo restituendo l'eventuale errore di convalidazione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Validate(
    Object val,
    IDedEditable data,
    bool creating,
    bool revisioning,
    out string error
)
Public Overrides Function Validate (
    val As Object,
    data As IDedEditable,
    creating As Boolean,
    revisioning As Boolean,
    <OutAttribute> ByRef error As String
) As Boolean
public:
virtual bool Validate(
    Object^ val,
    IDedEditable^ data,
    bool creating,
    bool revisioning,
    [OutAttribute] String^% error
) override
abstract Validate :
        val : Object *
        data : IDedEditable *
        creating : bool *
        revisioning : bool *
        error : string byref -> bool
override Validate :
        val : Object *
        data : IDedEditable *
        creating : bool *
        revisioning : bool *
        error : string byref -> bool

Parametri

val Object
Valore da convalidare.
data IDedEditable
creating Boolean
revisioning Boolean
error String
Errore di validazione restituito al chiamante.

Valore di ritorno

Boolean
Restituisce true se il valore è convalidato altrimenti false.
Vedi anche

Documentazione

Classe DedAttrDoubleValidator
Overload di Validate
Namespace DedNet.Core


Enumerazione DedAttrEnvDestEnum
Enumera le tipologie di attributo in base alla destinazione dei dati.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum DedAttrEnvDestEnum
Public Enumeration DedAttrEnvDestEnum
public enum class DedAttrEnvDestEnum
type DedAttrEnvDestEnum
Membri
Nome | Valore | Descrizione
Anagrafica | 0 | Attributo di anagrafica.
Distinta | 1 | Attributo di distinta.
Documento | 2 | Attributo di documento.
Commessa | 3 | Attributo di commessa.
Occorrenza | 4 | Attributo di occorenza.
AnagraficaEDistinta | 5 | Attributo di Anagrafica e distinta.
AnagraficaEDocumento | 6 | Attributo di Anagrafica e documento.
AnagraficaDiCommessa | 7 | Attributo di Anagrafica di commessa
Eco | 8 | Attributo ECO
Proprietà | 9 |
Vedi anche

Documentazione

Namespace DedNet.Core


Classe DedAttributePermList
Collezione di oggetti DedAttributePerm.
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList DedAttrPerm
DedNet.CoreDedAttributePermList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedAttributePermList : List<DedAttrPerm>
Public Class DedAttributePermList
    Inherits List(Of DedAttrPerm)
public ref class DedAttributePermList : public List<DedAttrPerm^>
type DedAttributePermList =
    class
        inherit List<DedAttrPerm>
    end

Il tipo DedAttributePermList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedAttributePermList |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedAttributePermList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttributePermList()
Public Sub New
public:
DedAttributePermList()
new : unit -> DedAttributePermList
Vedi anche

Documentazione

Classe DedAttributePermList
Namespace DedNet.Core


Classe DedAttrIntegerValidator
Classe per la validazione di un attributo di tipo numero intero.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedAttrValidatorBase
DedNet.CoreDedAttrIntegerValidator

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedAttrIntegerValidator : DedAttrValidatorBase
Public Class DedAttrIntegerValidator
    Inherits DedAttrValidatorBase
public ref class DedAttrIntegerValidator : public DedAttrValidatorBase
type DedAttrIntegerValidator =
    class
        inherit DedAttrValidatorBase
    end

Il tipo DedAttrIntegerValidator espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Attr | Restituisce l'attributo di appartenenza. (Ereditato da DedAttrValidatorBase)
Proprietà pubblica | CheckFunction | Imposta o restituisce il nome della funzione di controllo personalizzata. (Ereditato da DedAttrValidatorBase)
Proprietà pubblica | Operatore | Restituisce l'operatore di confronto.
Proprietà pubblica | Required | Imposta o restituisce se l'attributo possa o meno essere lasciato vuoto. (Ereditato da DedAttrValidatorBase)
Proprietà pubblica | Val1 | Primo valore di confronto.
Proprietà pubblica | Val2 | Secondo valore di confronto.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Ereditato da DedAttrValidatorBase)
Metodo pubblico | GetHashCode | (Ereditato da DedAttrValidatorBase)
Metodo pubblico | HasCheckFunction | Verifica se questo attributo ha una funzione personalizzata. (Ereditato da DedAttrValidatorBase)
Metodo pubblico | IsRequired | Restituisce true se l'attributo è obbligatorio considerando anche il contesto (creazione/revisione) (Ereditato da DedAttrValidatorBase)
Metodo pubblico | ToString | (Sovrascrive DedAttrValidatorBaseToString)
Metodo pubblico | Validate(Object, IDedEditable, Boolean, Boolean) | Valida il valore dell'attributo senza sollevare eccezioni. (Sovrascrive DedAttrValidatorBaseValidate(Object, IDedEditable, Boolean, Boolean))
Metodo pubblico | Validate(Object, IDedEditable, Boolean, Boolean, String) | Valida il valore dell'attributo restituendo l'eventuale errore di convalidazione. (Sovrascrive DedAttrValidatorBaseValidate(Object, IDedEditable, Boolean, Boolean, String))
Metodo pubblico | ValueCanNotBeErased | Controlla se il valore può essere cancellato. Ovvero se non siamo in un'operazione di crea anagrafia o crea revisione e il tipo di obbligatorietà è cerazione o revisione il valore dell'attributo non può essere cancellato. Mentre se è già vuoto non necessita di essere compilato (come avviene per un obbligatorietà 'sempre') (Ereditato da DedAttrValidatorBase)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di DedAttrIntegerValidator

Il tipo DedAttrIntegerValidator espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Attr | Restituisce l'attributo di appartenenza. (Ereditato da DedAttrValidatorBase)
Proprietà pubblica | CheckFunction | Imposta o restituisce il nome della funzione di controllo personalizzata. (Ereditato da DedAttrValidatorBase)
Proprietà pubblica | Operatore | Restituisce l'operatore di confronto.
Proprietà pubblica | Required | Imposta o restituisce se l'attributo possa o meno essere lasciato vuoto. (Ereditato da DedAttrValidatorBase)
Proprietà pubblica | Val1 | Primo valore di confronto.
Proprietà pubblica | Val2 | Secondo valore di confronto.
Torna su
Vedi anche

Documentazione

Classe DedAttrIntegerValidator
Namespace DedNet.Core


Proprietà DedAttrIntegerValidator.Operatore

Proprietà DedAttrIntegerValidatorOperatore
Restituisce l'operatore di confronto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ValidatorOperator Operatore { get; set; }
Public Property Operatore As ValidatorOperator
    Get
    Set
public:
property ValidatorOperator Operatore {
    ValidatorOperator get ();
    void set (ValidatorOperator value);
}
member Operatore : ValidatorOperator with get, set

Valore della proprietà

ValidatorOperator
Vedi anche

Documentazione

Classe DedAttrIntegerValidator
Namespace DedNet.Core


Proprietà DedAttrIntegerValidator.Val1

Proprietà DedAttrIntegerValidatorVal1
Primo valore di confronto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int? Val1 { get; set; }
Public Property Val1 As Integer?
    Get
    Set
public:
property Nullable<int> Val1 {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member Val1 : Nullable<int> with get, set

Valore della proprietà

Nullable Int32
Vedi anche

Documentazione

Classe DedAttrIntegerValidator
Namespace DedNet.Core


Proprietà DedAttrIntegerValidator.Val2

Proprietà DedAttrIntegerValidatorVal2
Secondo valore di confronto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int? Val2 { get; set; }
Public Property Val2 As Integer?
    Get
    Set
public:
property Nullable<int> Val2 {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member Val2 : Nullable<int> with get, set

Valore della proprietà

Nullable Int32
Vedi anche

Documentazione

Classe DedAttrIntegerValidator
Namespace DedNet.Core


Metodi di DedAttrIntegerValidator

Il tipo DedAttrIntegerValidator espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Ereditato da DedAttrValidatorBase)
Metodo pubblico | GetHashCode | (Ereditato da DedAttrValidatorBase)
Metodo pubblico | HasCheckFunction | Verifica se questo attributo ha una funzione personalizzata. (Ereditato da DedAttrValidatorBase)
Metodo pubblico | IsRequired | Restituisce true se l'attributo è obbligatorio considerando anche il contesto (creazione/revisione) (Ereditato da DedAttrValidatorBase)
Metodo pubblico | ToString | (Sovrascrive DedAttrValidatorBaseToString)
Metodo pubblico | Validate(Object, IDedEditable, Boolean, Boolean) | Valida il valore dell'attributo senza sollevare eccezioni. (Sovrascrive DedAttrValidatorBaseValidate(Object, IDedEditable, Boolean, Boolean))
Metodo pubblico | Validate(Object, IDedEditable, Boolean, Boolean, String) | Valida il valore dell'attributo restituendo l'eventuale errore di convalidazione. (Sovrascrive DedAttrValidatorBaseValidate(Object, IDedEditable, Boolean, Boolean, String))
Metodo pubblico | ValueCanNotBeErased | Controlla se il valore può essere cancellato. Ovvero se non siamo in un'operazione di crea anagrafia o crea revisione e il tipo di obbligatorietà è cerazione o revisione il valore dell'attributo non può essere cancellato. Mentre se è già vuoto non necessita di essere compilato (come avviene per un obbligatorietà 'sempre') (Ereditato da DedAttrValidatorBase)
Torna su
Vedi anche

Documentazione

Classe DedAttrIntegerValidator
Namespace DedNet.Core


Metodo DedAttrIntegerValidator.ToString

Metodo DedAttrIntegerValidatorToString

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedAttrIntegerValidator
Namespace DedNet.Core


Metodo DedAttrIntegerValidator.Validate

Metodo DedAttrIntegerValidatorValidate
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Validate(Object, IDedEditable, Boolean, Boolean) | Valida il valore dell'attributo senza sollevare eccezioni.
Metodo pubblico | Validate(Object, IDedEditable, Boolean, Boolean, String) | Valida il valore dell'attributo restituendo l'eventuale errore di convalidazione.
Torna su
Vedi anche

Documentazione

Classe DedAttrIntegerValidator
Namespace DedNet.Core


Metodo DedAttrIntegerValidator.Validate(Object, IDedEditable, Boolean, Boolean)

Metodo DedAttrIntegerValidatorValidate(Object, IDedEditable, Boolean, Boolean)
Valida il valore dell'attributo senza sollevare eccezioni.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Validate(
    Object val,
    IDedEditable data,
    bool creating,
    bool revisioning
)
Public Overrides Function Validate (
    val As Object,
    data As IDedEditable,
    creating As Boolean,
    revisioning As Boolean
) As Boolean
public:
virtual bool Validate(
    Object^ val,
    IDedEditable^ data,
    bool creating,
    bool revisioning
) override
abstract Validate :
        val : Object *
        data : IDedEditable *
        creating : bool *
        revisioning : bool -> bool
override Validate :
        val : Object *
        data : IDedEditable *
        creating : bool *
        revisioning : bool -> bool

Parametri

val Object
Valore da convalidare.
data IDedEditable
creating Boolean
revisioning Boolean

Valore di ritorno

Boolean
Restituisce true se il valore è convalidato altrimenti false.
Vedi anche

Documentazione

Classe DedAttrIntegerValidator
Overload di Validate
Namespace DedNet.Core


Metodo DedAttrIntegerValidator.Validate(Object, IDedEditable, Boolean, Boolean, String)

Metodo DedAttrIntegerValidatorValidate(Object, IDedEditable, Boolean, Boolean, String)
Valida il valore dell'attributo restituendo l'eventuale errore di convalidazione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Validate(
    Object val,
    IDedEditable data,
    bool creating,
    bool revisioning,
    out string error
)
Public Overrides Function Validate (
    val As Object,
    data As IDedEditable,
    creating As Boolean,
    revisioning As Boolean,
    <OutAttribute> ByRef error As String
) As Boolean
public:
virtual bool Validate(
    Object^ val,
    IDedEditable^ data,
    bool creating,
    bool revisioning,
    [OutAttribute] String^% error
) override
abstract Validate :
        val : Object *
        data : IDedEditable *
        creating : bool *
        revisioning : bool *
        error : string byref -> bool
override Validate :
        val : Object *
        data : IDedEditable *
        creating : bool *
        revisioning : bool *
        error : string byref -> bool

Parametri

val Object
Valore da convalidare.
data IDedEditable
creating Boolean
revisioning Boolean
error String
Errore di validazione restituito al chiamante.

Valore di ritorno

Boolean
Restituisce true se il valore è convalidato altrimenti false.
Vedi anche

Documentazione

Classe DedAttrIntegerValidator
Overload di Validate
Namespace DedNet.Core


Classe DedAttrList
Lista di oggetti DedAttr.
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList DedAttr
DedNet.CoreDedAttrList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedAttrList : List<DedAttr>
Public Class DedAttrList
    Inherits List(Of DedAttr)
public ref class DedAttrList : public List<DedAttr^>
type DedAttrList =
    class
        inherit List<DedAttr>
    end

Il tipo DedAttrList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedAttrList |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Clone | Clona la lista di attributi.
Metodo pubblico | FindByName | Cerca nella lista un attributo che abbia il nome specificato.
Metodo pubblico | FindByPrompt | Cerca nella lista un attributo che abbia il prompt specificato.
Metodo pubblico | GetAllAttrNames | Restituisce una lista contenente tutti i nomi degli attributi presenti in questa lista. Restitusice una lista inizializzata ma vuota nel caso non ce ne siano.
Metodo pubblico | GetAllAttrPrompts | Restituisce una lista contenente tutti i prompt degli attributi presenti in questa lista. Restitusice una lista inizializzata ma vuota nel caso non ce ne siano.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedAttrList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList()
Public Sub New
public:
DedAttrList()
new : unit -> DedAttrList
Vedi anche

Documentazione

Classe DedAttrList
Namespace DedNet.Core


Metodi di DedAttrList

Il tipo DedAttrList espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Clone | Clona la lista di attributi.
Metodo pubblico | FindByName | Cerca nella lista un attributo che abbia il nome specificato.
Metodo pubblico | FindByPrompt | Cerca nella lista un attributo che abbia il prompt specificato.
Metodo pubblico | GetAllAttrNames | Restituisce una lista contenente tutti i nomi degli attributi presenti in questa lista. Restitusice una lista inizializzata ma vuota nel caso non ce ne siano.
Metodo pubblico | GetAllAttrPrompts | Restituisce una lista contenente tutti i prompt degli attributi presenti in questa lista. Restitusice una lista inizializzata ma vuota nel caso non ce ne siano.
Torna su
Vedi anche

Documentazione

Classe DedAttrList
Namespace DedNet.Core


Metodo DedAttrList.Clone

Metodo DedAttrListClone
Clona la lista di attributi.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList Clone(
    bool nullParent = true
)
Public Function Clone (
    Optional nullParent As Boolean = true
) As DedAttrList
public:
DedAttrList^ Clone(
    bool nullParent = true
)
member Clone :
        ?nullParent : bool
(* Defaults:
        let _nullParent = defaultArg nullParent true
*)
-> DedAttrList

Parametri

nullParent Boolean (Optional)

Valore di ritorno

DedAttrList
Restituisce una lista clonata.
Vedi anche

Documentazione

Classe DedAttrList
Namespace DedNet.Core


Metodo DedAttrList.FindByName

Metodo DedAttrListFindByName
Cerca nella lista un attributo che abbia il nome specificato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttr FindByName(
    string name
)
Public Function FindByName (
    name As String
) As DedAttr
public:
DedAttr^ FindByName(
    String^ name
)
member FindByName :
        name : string -> DedAttr

Parametri

name String
Nome dell'attributo da cercare.

Valore di ritorno

DedAttr
Restituisce null se non riesce a trovarlo.
Vedi anche

Documentazione

Classe DedAttrList
Namespace DedNet.Core


Metodo DedAttrList.FindByPrompt

Metodo DedAttrListFindByPrompt
Cerca nella lista un attributo che abbia il prompt specificato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttr FindByPrompt(
    string prompt
)
Public Function FindByPrompt (
    prompt As String
) As DedAttr
public:
DedAttr^ FindByPrompt(
    String^ prompt
)
member FindByPrompt :
        prompt : string -> DedAttr

Parametri

prompt String
Prompt dell'attributo da cercare.

Valore di ritorno

DedAttr
Restituisce null se non riesce a trovarlo.
Vedi anche

Documentazione

Classe DedAttrList
Namespace DedNet.Core


Metodo DedAttrList.GetAllAttrNames

Metodo DedAttrListGetAllAttrNames
Restituisce una lista contenente tutti i nomi degli attributi presenti in questa lista. Restitusice una lista inizializzata ma vuota nel caso non ce ne siano.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> GetAllAttrNames()
Public Function GetAllAttrNames As List(Of String)
public:
List<String^>^ GetAllAttrNames()
member GetAllAttrNames : unit -> List<string>

Valore di ritorno

List String
Vedi anche

Documentazione

Classe DedAttrList
Namespace DedNet.Core


Metodo DedAttrList.GetAllAttrPrompts

Metodo DedAttrListGetAllAttrPrompts
Restituisce una lista contenente tutti i prompt degli attributi presenti in questa lista. Restitusice una lista inizializzata ma vuota nel caso non ce ne siano.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> GetAllAttrPrompts()
Public Function GetAllAttrPrompts As List(Of String)
public:
List<String^>^ GetAllAttrPrompts()
member GetAllAttrPrompts : unit -> List<string>

Valore di ritorno

List String
Vedi anche

Documentazione

Classe DedAttrList
Namespace DedNet.Core


Enumerazione DedAttrListType
Enumera le tipologie di lista da visualizzare.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum DedAttrListType
Public Enumeration DedAttrListType
public enum class DedAttrListType
type DedAttrListType
Membri
Nome | Valore | Descrizione
Combo | 0 |
ComboList | 1 |
MultiCheck | 2 |
Vedi anche

Documentazione

Namespace DedNet.Core


Enumerazione DedAttrModEnum
Enumerazione dei tipi di modificabilità di un attributo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum DedAttrModEnum
Public Enumeration DedAttrModEnum
public enum class DedAttrModEnum
type DedAttrModEnum
Membri
Nome | Valore | Descrizione
changeable | 0 | Sempre modificabile.
notchangeable | 1 | Sempre in sola lettura.
createonly | 2 | Modificabile solo prima o durante la creazione dell'anagrafica.
Vedi anche

Documentazione

Namespace DedNet.Core


Classe DedAttrPerm
Contiene il set di permessi relativi ad un solo attributo ed abbinato ad un unico utente/gruppo.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedPermOwner
DedNet.CoreDedAttrPerm

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedAttrPerm : DedPermOwner,
    IDedDbItem
Public Class DedAttrPerm
    Inherits DedPermOwner
    Implements IDedDbItem
public ref class DedAttrPerm : public DedPermOwner,
    IDedDbItem
type DedAttrPerm =
    class
        inherit DedPermOwner
        interface IDedDbItem
    end

Il tipo DedAttrPerm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione di appartenenza. (Ereditato da DedPermOwner)
Proprietà pubblica | Dirty | Restituisce true se è dirty la lista dei permessi appartenenti a questo oggetto altrimenti restituisce false.
Proprietà pubblica | IsGroup | Restituisce se il DedPermOwner è un gruppo. (Sovrascrive DedPermOwnerIsGroup)
Proprietà pubblica | IsUser | Restituisce se il DedPermOwner è un utente. (Sovrascrive DedPermOwnerIsUser)
Proprietà pubblica | Manager | Restituisce il Gestore dei permessi. (Ereditato da DedPermOwner)
Proprietà pubblica | Name | Restitusice il nome dell'owner. (Sovrascrive DedPermOwnerName)
Proprietà pubblica | Owner | Restituisce l'utente o il gruppo di appartenenza.
Proprietà pubblica | PermItems | Restitusice il set di permessi di questo possessore. (Ereditato da DedPermOwner)
Proprietà pubblica | StatoRecord | Di uso interno.
Proprietà protetta | TableName | Restituisce il nome della table del Database. (Ereditato da DedPermOwner)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | CreateDeleteCommand | (Sovrascrive DedPermOwnerCreateDeleteCommand(DedPerm))
Metodo protetto | CreateInsertCommand | (Sovrascrive DedPermOwnerCreateInsertCommand(DedPerm))
Metodo protetto | CreateUpdateCommand | (Sovrascrive DedPermOwnerCreateUpdateCommand(DedPerm))
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo protetto | GetDbIndex | (Sovrascrive DedPermOwnerGetDbIndex(DedPerm))
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | GetPerm | Restituisce il valore del permesso impostando la stringa descrittiva il tipo di ereditarietà del permesso.
Metodo pubblico | GetPermDescription | Restituisce la descrizione del permesso. (Ereditato da DedPermOwner)
Metodo pubblico | GetPermVal(String, String) | Restituisce il valore del permesso. (Sovrascrive DedPermOwnerGetPermVal(String, String))
Metodo pubblico | GetPermVal(String, String, String) | Restituisce il valore del permesso impostando la stringa descrittiva il tipo di ereditarietà del permesso. (Sovrascrive DedPermOwnerGetPermVal(String, String, String))
Metodo pubblico | IsPermPresent | Restituisce se il permesso è presente in modo esplicito fra i permessi di questa instanza. (Ereditato da DedPermOwner)
Metodo pubblico | Save | Salva il set di permessi.
Metodo pubblico | SetPermVal | Imposta il permesso ottenendo la stringa descrittiva del permesso. (Sovrascrive DedPermOwnerSetPermVal(String, String, Boolean))
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di DedAttrPerm

Il tipo DedAttrPerm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione di appartenenza. (Ereditato da DedPermOwner)
Proprietà pubblica | Dirty | Restituisce true se è dirty la lista dei permessi appartenenti a questo oggetto altrimenti restituisce false.
Proprietà pubblica | IsGroup | Restituisce se il DedPermOwner è un gruppo. (Sovrascrive DedPermOwnerIsGroup)
Proprietà pubblica | IsUser | Restituisce se il DedPermOwner è un utente. (Sovrascrive DedPermOwnerIsUser)
Proprietà pubblica | Manager | Restituisce il Gestore dei permessi. (Ereditato da DedPermOwner)
Proprietà pubblica | Name | Restitusice il nome dell'owner. (Sovrascrive DedPermOwnerName)
Proprietà pubblica | Owner | Restituisce l'utente o il gruppo di appartenenza.
Proprietà pubblica | PermItems | Restitusice il set di permessi di questo possessore. (Ereditato da DedPermOwner)
Proprietà pubblica | StatoRecord | Di uso interno.
Proprietà protetta | TableName | Restituisce il nome della table del Database. (Ereditato da DedPermOwner)
Torna su
Vedi anche

Documentazione

Classe DedAttrPerm
Namespace DedNet.Core


Proprietà DedAttrPerm.Dirty

Proprietà DedAttrPermDirty
Restituisce true se è dirty la lista dei permessi appartenenti a questo oggetto altrimenti restituisce false.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Dirty { get; }
Public ReadOnly Property Dirty As Boolean
    Get
public:
property bool Dirty {
    bool get ();
}
member Dirty : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAttrPerm
Namespace DedNet.Core


Proprietà DedAttrPerm.IsGroup

Proprietà DedAttrPermIsGroup
Restituisce se il DedPermOwner è un gruppo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool IsGroup { get; }
Public Overrides ReadOnly Property IsGroup As Boolean
    Get
public:
virtual property bool IsGroup {
    bool get () override;
}
abstract IsGroup : bool with get
override IsGroup : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAttrPerm
Namespace DedNet.Core


Proprietà DedAttrPerm.IsUser

Proprietà DedAttrPermIsUser
Restituisce se il DedPermOwner è un utente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool IsUser { get; }
Public Overrides ReadOnly Property IsUser As Boolean
    Get
public:
virtual property bool IsUser {
    bool get () override;
}
abstract IsUser : bool with get
override IsUser : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAttrPerm
Namespace DedNet.Core


Proprietà DedAttrPerm.Name

Proprietà DedAttrPermName
Restitusice il nome dell'owner.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string Name { get; }
Public Overrides ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () override;
}
abstract Name : string with get
override Name : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedAttrPerm
Namespace DedNet.Core


Proprietà DedAttrPerm.Owner

Proprietà DedAttrPermOwner
Restituisce l'utente o il gruppo di appartenenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedPermOwner Owner { get; }
Public ReadOnly Property Owner As DedPermOwner
    Get
public:
property DedPermOwner^ Owner {
    DedPermOwner^ get ();
}
member Owner : DedPermOwner with get

Valore della proprietà

DedPermOwner
Vedi anche

Documentazione

Classe DedAttrPerm
Namespace DedNet.Core


Proprietà DedAttrPerm.StatoRecord

Proprietà DedAttrPermStatoRecord
Di uso interno.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public StatoRecord StatoRecord { get; set; }
Public Property StatoRecord As StatoRecord
    Get
    Set
public:
virtual property StatoRecord^ StatoRecord {
    StatoRecord^ get () sealed;
    void set (StatoRecord^ value) sealed;
}
abstract StatoRecord : StatoRecord with get, set
override StatoRecord : StatoRecord with get, set

Valore della proprietà

StatoRecord

Implementa

IDedDbItemStatoRecord
Vedi anche

Documentazione

Classe DedAttrPerm
Namespace DedNet.Core


Metodi di DedAttrPerm

Il tipo DedAttrPerm espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | CreateDeleteCommand | (Sovrascrive DedPermOwnerCreateDeleteCommand(DedPerm))
Metodo protetto | CreateInsertCommand | (Sovrascrive DedPermOwnerCreateInsertCommand(DedPerm))
Metodo protetto | CreateUpdateCommand | (Sovrascrive DedPermOwnerCreateUpdateCommand(DedPerm))
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo protetto | GetDbIndex | (Sovrascrive DedPermOwnerGetDbIndex(DedPerm))
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | GetPerm | Restituisce il valore del permesso impostando la stringa descrittiva il tipo di ereditarietà del permesso.
Metodo pubblico | GetPermDescription | Restituisce la descrizione del permesso. (Ereditato da DedPermOwner)
Metodo pubblico | GetPermVal(String, String) | Restituisce il valore del permesso. (Sovrascrive DedPermOwnerGetPermVal(String, String))
Metodo pubblico | GetPermVal(String, String, String) | Restituisce il valore del permesso impostando la stringa descrittiva il tipo di ereditarietà del permesso. (Sovrascrive DedPermOwnerGetPermVal(String, String, String))
Metodo pubblico | IsPermPresent | Restituisce se il permesso è presente in modo esplicito fra i permessi di questa instanza. (Ereditato da DedPermOwner)
Metodo pubblico | Save | Salva il set di permessi.
Metodo pubblico | SetPermVal | Imposta il permesso ottenendo la stringa descrittiva del permesso. (Sovrascrive DedPermOwnerSetPermVal(String, String, Boolean))
Torna su
Vedi anche

Documentazione

Classe DedAttrPerm
Namespace DedNet.Core


Metodo DedAttrPerm.CreateDeleteCommand

Metodo DedAttrPermCreateDeleteCommand

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal override QSDeleteCommand CreateDeleteCommand(
    DedPerm item
)
Protected Friend Overrides Function CreateDeleteCommand (
    item As DedPerm
) As QSDeleteCommand
protected public:
virtual QSDeleteCommand^ CreateDeleteCommand(
    DedPerm^ item
) override
abstract CreateDeleteCommand :
        item : DedPerm -> QSDeleteCommand
override CreateDeleteCommand :
        item : DedPerm -> QSDeleteCommand

Parametri

item DedPerm

Valore di ritorno

QSDeleteCommand
Vedi anche

Documentazione

Classe DedAttrPerm
Namespace DedNet.Core


Metodo DedAttrPerm.CreateInsertCommand

Metodo DedAttrPermCreateInsertCommand

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal override QSInsertCommand CreateInsertCommand(
    DedPerm item
)
Protected Friend Overrides Function CreateInsertCommand (
    item As DedPerm
) As QSInsertCommand
protected public:
virtual QSInsertCommand^ CreateInsertCommand(
    DedPerm^ item
) override
abstract CreateInsertCommand :
        item : DedPerm -> QSInsertCommand
override CreateInsertCommand :
        item : DedPerm -> QSInsertCommand

Parametri

item DedPerm

Valore di ritorno

QSInsertCommand
Vedi anche

Documentazione

Classe DedAttrPerm
Namespace DedNet.Core


Metodo DedAttrPerm.CreateUpdateCommand

Metodo DedAttrPermCreateUpdateCommand

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal override QSUpdateCommand CreateUpdateCommand(
    DedPerm item
)
Protected Friend Overrides Function CreateUpdateCommand (
    item As DedPerm
) As QSUpdateCommand
protected public:
virtual QSUpdateCommand^ CreateUpdateCommand(
    DedPerm^ item
) override
abstract CreateUpdateCommand :
        item : DedPerm -> QSUpdateCommand
override CreateUpdateCommand :
        item : DedPerm -> QSUpdateCommand

Parametri

item DedPerm

Valore di ritorno

QSUpdateCommand
Vedi anche

Documentazione

Classe DedAttrPerm
Namespace DedNet.Core


Metodo DedAttrPerm.Equals

Metodo DedAttrPermEquals

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj Object

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedAttrPerm
Namespace DedNet.Core


Metodo DedAttrPerm.GetDbIndex

Metodo DedAttrPermGetDbIndex

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal override Object GetDbIndex(
    DedPerm item
)
Protected Friend Overrides Function GetDbIndex (
    item As DedPerm
) As Object
protected public:
virtual Object^ GetDbIndex(
    DedPerm^ item
) override
abstract GetDbIndex :
        item : DedPerm -> Object
override GetDbIndex :
        item : DedPerm -> Object

Parametri

item DedPerm

Valore di ritorno

Object
Vedi anche

Documentazione

Classe DedAttrPerm
Namespace DedNet.Core


Metodo DedAttrPerm.GetHashCode

Metodo DedAttrPermGetHashCode

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedAttrPerm
Namespace DedNet.Core


Metodo DedAttrPerm.GetPerm

Metodo DedAttrPermGetPerm
Restituisce il valore del permesso impostando la stringa descrittiva il tipo di ereditarietà del permesso.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedPerm GetPerm(
    string PermName,
    string discrim,
    out string PermDesc
)
Public Function GetPerm (
    PermName As String,
    discrim As String,
    <OutAttribute> ByRef PermDesc As String
) As DedPerm
public:
DedPerm^ GetPerm(
    String^ PermName,
    String^ discrim,
    [OutAttribute] String^% PermDesc
)
member GetPerm :
        PermName : string *
        discrim : string *
        PermDesc : string byref -> DedPerm

Parametri

PermName String
discrim String
PermDesc String

Valore di ritorno

DedPerm
Vedi anche

Documentazione

Classe DedAttrPerm
Namespace DedNet.Core


Metodo DedAttrPerm.GetPermVal

Metodo DedAttrPermGetPermVal
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | GetPermVal(String, String) | Restituisce il valore del permesso.
Metodo pubblico | GetPermVal(String, String, String) | Restituisce il valore del permesso impostando la stringa descrittiva il tipo di ereditarietà del permesso.
Torna su
Vedi anche

Documentazione

Classe DedAttrPerm
Namespace DedNet.Core


Metodo DedAttrPerm.GetPermVal(String, String)

Metodo DedAttrPermGetPermVal(String, String)
Restituisce il valore del permesso.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool GetPermVal(
    string PermName,
    string discrim
)
Public Overrides Function GetPermVal (
    PermName As String,
    discrim As String
) As Boolean
public:
virtual bool GetPermVal(
    String^ PermName,
    String^ discrim
) override
abstract GetPermVal :
        PermName : string *
        discrim : string -> bool
override GetPermVal :
        PermName : string *
        discrim : string -> bool

Parametri

PermName String
discrim String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedAttrPerm
Overload di GetPermVal
Namespace DedNet.Core


Metodo DedAttrPerm.GetPermVal(String, String, String)

Metodo DedAttrPermGetPermVal(String, String, String)
Restituisce il valore del permesso impostando la stringa descrittiva il tipo di ereditarietà del permesso.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool GetPermVal(
    string PermName,
    string discrim,
    out string PermDesc
)
Public Overrides Function GetPermVal (
    PermName As String,
    discrim As String,
    <OutAttribute> ByRef PermDesc As String
) As Boolean
public:
virtual bool GetPermVal(
    String^ PermName,
    String^ discrim,
    [OutAttribute] String^% PermDesc
) override
abstract GetPermVal :
        PermName : string *
        discrim : string *
        PermDesc : string byref -> bool
override GetPermVal :
        PermName : string *
        discrim : string *
        PermDesc : string byref -> bool

Parametri

PermName String
discrim String
PermDesc String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedAttrPerm
Overload di GetPermVal
Namespace DedNet.Core


Metodo DedAttrPerm.Save

Metodo DedAttrPermSave
Salva il set di permessi.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Save()
Public Sub Save
public:
void Save()
member Save : unit -> unit
Vedi anche

Documentazione

Classe DedAttrPerm
Namespace DedNet.Core


Metodo DedAttrPerm.SetPermVal

Metodo DedAttrPermSetPermVal
Imposta il permesso ottenendo la stringa descrittiva del permesso.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string SetPermVal(
    string PermName,
    string discrim,
    bool Valore
)
Public Overrides Function SetPermVal (
    PermName As String,
    discrim As String,
    Valore As Boolean
) As String
public:
virtual String^ SetPermVal(
    String^ PermName,
    String^ discrim,
    bool Valore
) override
abstract SetPermVal :
        PermName : string *
        discrim : string *
        Valore : bool -> string
override SetPermVal :
        PermName : string *
        discrim : string *
        Valore : bool -> string

Parametri

PermName String
discrim String
Valore Boolean

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedAttrPerm
Namespace DedNet.Core


Enumerazione DedAttrRequiredEnum
Enumerazione dei tipi di modificabilità di un attributo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum DedAttrRequiredEnum
Public Enumeration DedAttrRequiredEnum
public enum class DedAttrRequiredEnum
type DedAttrRequiredEnum
Membri
Nome | Valore | Descrizione
never | 0 | Non obbligatorio.
always | 1 | Sempre obbligatorio.
creation | 2 | Obbligatorio solo in creazione.
revision | 3 | Obbligatorio solo in revisione.
Vedi anche

Documentazione

Namespace DedNet.Core


Classe DedAttrSiNoValidator
Classe per la validazione di un attributo di tipo boolean.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedAttrValidatorBase
DedNet.CoreDedAttrSiNoValidator

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedAttrSiNoValidator : DedAttrValidatorBase
Public Class DedAttrSiNoValidator
    Inherits DedAttrValidatorBase
public ref class DedAttrSiNoValidator : public DedAttrValidatorBase
type DedAttrSiNoValidator =
    class
        inherit DedAttrValidatorBase
    end

Il tipo DedAttrSiNoValidator espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Attr | Restituisce l'attributo di appartenenza. (Ereditato da DedAttrValidatorBase)
Proprietà pubblica | CheckFunction | Imposta o restituisce il nome della funzione di controllo personalizzata. (Ereditato da DedAttrValidatorBase)
Proprietà pubblica | Required | Imposta o restituisce se l'attributo possa o meno essere lasciato vuoto. (Ereditato da DedAttrValidatorBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Ereditato da DedAttrValidatorBase)
Metodo pubblico | GetHashCode | (Ereditato da DedAttrValidatorBase)
Metodo pubblico | HasCheckFunction | Verifica se questo attributo ha una funzione personalizzata. (Ereditato da DedAttrValidatorBase)
Metodo pubblico | IsRequired | Restituisce true se l'attributo è obbligatorio considerando anche il contesto (creazione/revisione) (Ereditato da DedAttrValidatorBase)
Metodo pubblico | ToString | (Ereditato da DedAttrValidatorBase)
Metodo pubblico | Validate(Object, IDedEditable, Boolean, Boolean) | Valida il valore dell'attributo senza sollevare eccezioni. (Sovrascrive DedAttrValidatorBaseValidate(Object, IDedEditable, Boolean, Boolean))
Metodo pubblico | Validate(Object, IDedEditable, Boolean, Boolean, String) | Valida il valore dell'attributo restituendo l'eventuale errore di convalidazione. (Sovrascrive DedAttrValidatorBaseValidate(Object, IDedEditable, Boolean, Boolean, String))
Metodo pubblico | ValueCanNotBeErased | Controlla se il valore può essere cancellato. Ovvero se non siamo in un'operazione di crea anagrafia o crea revisione e il tipo di obbligatorietà è cerazione o revisione il valore dell'attributo non può essere cancellato. Mentre se è già vuoto non necessita di essere compilato (come avviene per un obbligatorietà 'sempre') (Ereditato da DedAttrValidatorBase)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di DedAttrSiNoValidator

Il tipo DedAttrSiNoValidator espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Attr | Restituisce l'attributo di appartenenza. (Ereditato da DedAttrValidatorBase)
Proprietà pubblica | CheckFunction | Imposta o restituisce il nome della funzione di controllo personalizzata. (Ereditato da DedAttrValidatorBase)
Proprietà pubblica | Required | Imposta o restituisce se l'attributo possa o meno essere lasciato vuoto. (Ereditato da DedAttrValidatorBase)
Torna su
Vedi anche

Documentazione

Classe DedAttrSiNoValidator
Namespace DedNet.Core


Metodi di DedAttrSiNoValidator

Il tipo DedAttrSiNoValidator espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Ereditato da DedAttrValidatorBase)
Metodo pubblico | GetHashCode | (Ereditato da DedAttrValidatorBase)
Metodo pubblico | HasCheckFunction | Verifica se questo attributo ha una funzione personalizzata. (Ereditato da DedAttrValidatorBase)
Metodo pubblico | IsRequired | Restituisce true se l'attributo è obbligatorio considerando anche il contesto (creazione/revisione) (Ereditato da DedAttrValidatorBase)
Metodo pubblico | ToString | (Ereditato da DedAttrValidatorBase)
Metodo pubblico | Validate(Object, IDedEditable, Boolean, Boolean) | Valida il valore dell'attributo senza sollevare eccezioni. (Sovrascrive DedAttrValidatorBaseValidate(Object, IDedEditable, Boolean, Boolean))
Metodo pubblico | Validate(Object, IDedEditable, Boolean, Boolean, String) | Valida il valore dell'attributo restituendo l'eventuale errore di convalidazione. (Sovrascrive DedAttrValidatorBaseValidate(Object, IDedEditable, Boolean, Boolean, String))
Metodo pubblico | ValueCanNotBeErased | Controlla se il valore può essere cancellato. Ovvero se non siamo in un'operazione di crea anagrafia o crea revisione e il tipo di obbligatorietà è cerazione o revisione il valore dell'attributo non può essere cancellato. Mentre se è già vuoto non necessita di essere compilato (come avviene per un obbligatorietà 'sempre') (Ereditato da DedAttrValidatorBase)
Torna su
Vedi anche

Documentazione

Classe DedAttrSiNoValidator
Namespace DedNet.Core


Metodo DedAttrSiNoValidator.Validate

Metodo DedAttrSiNoValidatorValidate
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Validate(Object, IDedEditable, Boolean, Boolean) | Valida il valore dell'attributo senza sollevare eccezioni.
Metodo pubblico | Validate(Object, IDedEditable, Boolean, Boolean, String) | Valida il valore dell'attributo restituendo l'eventuale errore di convalidazione.
Torna su
Vedi anche

Documentazione

Classe DedAttrSiNoValidator
Namespace DedNet.Core


Metodo DedAttrSiNoValidator.Validate(Object, IDedEditable, Boolean, Boolean)

Metodo DedAttrSiNoValidatorValidate(Object, IDedEditable, Boolean, Boolean)
Valida il valore dell'attributo senza sollevare eccezioni.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Validate(
    Object val,
    IDedEditable data,
    bool creating,
    bool revisioning
)
Public Overrides Function Validate (
    val As Object,
    data As IDedEditable,
    creating As Boolean,
    revisioning As Boolean
) As Boolean
public:
virtual bool Validate(
    Object^ val,
    IDedEditable^ data,
    bool creating,
    bool revisioning
) override
abstract Validate :
        val : Object *
        data : IDedEditable *
        creating : bool *
        revisioning : bool -> bool
override Validate :
        val : Object *
        data : IDedEditable *
        creating : bool *
        revisioning : bool -> bool

Parametri

val Object
Valore da convalidare.
data IDedEditable
creating Boolean
revisioning Boolean

Valore di ritorno

Boolean
Restituisce true se il valore è convalidato altrimenti false.
Vedi anche

Documentazione

Classe DedAttrSiNoValidator
Overload di Validate
Namespace DedNet.Core


Metodo DedAttrSiNoValidator.Validate(Object, IDedEditable, Boolean, Boolean, String)

Metodo DedAttrSiNoValidatorValidate(Object, IDedEditable, Boolean, Boolean, String)
Valida il valore dell'attributo restituendo l'eventuale errore di convalidazione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Validate(
    Object val,
    IDedEditable data,
    bool creating,
    bool revisioning,
    out string error
)
Public Overrides Function Validate (
    val As Object,
    data As IDedEditable,
    creating As Boolean,
    revisioning As Boolean,
    <OutAttribute> ByRef error As String
) As Boolean
public:
virtual bool Validate(
    Object^ val,
    IDedEditable^ data,
    bool creating,
    bool revisioning,
    [OutAttribute] String^% error
) override
abstract Validate :
        val : Object *
        data : IDedEditable *
        creating : bool *
        revisioning : bool *
        error : string byref -> bool
override Validate :
        val : Object *
        data : IDedEditable *
        creating : bool *
        revisioning : bool *
        error : string byref -> bool

Parametri

val Object
Valore da convalidare.
data IDedEditable
creating Boolean
revisioning Boolean
error String
Errore di validazione restituito al chiamante.

Valore di ritorno

Boolean
Restituisce true se il valore è convalidato altrimenti false.
Vedi anche

Documentazione

Classe DedAttrSiNoValidator
Overload di Validate
Namespace DedNet.Core


Classe DedAttrStringValidator
Classe per la validazione di un attributo di tipo stringa.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedAttrValidatorBase
DedNet.CoreDedAttrStringValidator

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedAttrStringValidator : DedAttrValidatorBase
Public Class DedAttrStringValidator
    Inherits DedAttrValidatorBase
public ref class DedAttrStringValidator : public DedAttrValidatorBase
type DedAttrStringValidator =
    class
        inherit DedAttrValidatorBase
    end

Il tipo DedAttrStringValidator espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcceptBlank | Restituisce o imposta se accetta uno spazio come valore valido.
Proprietà pubblica | Attr | Restituisce l'attributo di appartenenza. (Ereditato da DedAttrValidatorBase)
Proprietà pubblica | CheckFunction | Imposta o restituisce il nome della funzione di controllo personalizzata. (Ereditato da DedAttrValidatorBase)
Proprietà pubblica | IsLink | Restituisce o imposta se è un link
Proprietà pubblica | MaxLen | Restituisce o imposta la lunghezza massimo che deve avere l'attributo per essere valido.
Proprietà pubblica | MinLen | Restituisce o imposta la lunghezza minima che deve avere l'attributo per essere valido.
Proprietà pubblica | Multiline | Restituisce o imposta se è multilinea
Proprietà pubblica | Required | Imposta o restituisce se l'attributo possa o meno essere lasciato vuoto. (Ereditato da DedAttrValidatorBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Ereditato da DedAttrValidatorBase)
Metodo pubblico | GetHashCode | (Ereditato da DedAttrValidatorBase)
Metodo pubblico | HasCheckFunction | Verifica se questo attributo ha una funzione personalizzata. (Ereditato da DedAttrValidatorBase)
Metodo pubblico | IsRequired | Restituisce true se l'attributo è obbligatorio considerando anche il contesto (creazione/revisione) (Ereditato da DedAttrValidatorBase)
Metodo pubblico | ToString | (Sovrascrive DedAttrValidatorBaseToString)
Metodo pubblico | Validate(Object, IDedEditable, Boolean, Boolean) | Valida il valore dell'attributo senza sollevare eccezioni. (Sovrascrive DedAttrValidatorBaseValidate(Object, IDedEditable, Boolean, Boolean))
Metodo pubblico | Validate(Object, IDedEditable, Boolean, Boolean, String) | Valida il valore dell'attributo restituendo l'eventuale errore di convalidazione. (Sovrascrive DedAttrValidatorBaseValidate(Object, IDedEditable, Boolean, Boolean, String))
Metodo pubblico | ValueCanNotBeErased | Controlla se il valore può essere cancellato. Ovvero se non siamo in un'operazione di crea anagrafia o crea revisione e il tipo di obbligatorietà è cerazione o revisione il valore dell'attributo non può essere cancellato. Mentre se è già vuoto non necessita di essere compilato (come avviene per un obbligatorietà 'sempre') (Ereditato da DedAttrValidatorBase)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di DedAttrStringValidator

Il tipo DedAttrStringValidator espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcceptBlank | Restituisce o imposta se accetta uno spazio come valore valido.
Proprietà pubblica | Attr | Restituisce l'attributo di appartenenza. (Ereditato da DedAttrValidatorBase)
Proprietà pubblica | CheckFunction | Imposta o restituisce il nome della funzione di controllo personalizzata. (Ereditato da DedAttrValidatorBase)
Proprietà pubblica | IsLink | Restituisce o imposta se è un link
Proprietà pubblica | MaxLen | Restituisce o imposta la lunghezza massimo che deve avere l'attributo per essere valido.
Proprietà pubblica | MinLen | Restituisce o imposta la lunghezza minima che deve avere l'attributo per essere valido.
Proprietà pubblica | Multiline | Restituisce o imposta se è multilinea
Proprietà pubblica | Required | Imposta o restituisce se l'attributo possa o meno essere lasciato vuoto. (Ereditato da DedAttrValidatorBase)
Torna su
Vedi anche

Documentazione

Classe DedAttrStringValidator
Namespace DedNet.Core


Proprietà DedAttrStringValidator.AcceptBlank

Proprietà DedAttrStringValidatorAcceptBlank
Restituisce o imposta se accetta uno spazio come valore valido.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AcceptBlank { get; set; }
Public Property AcceptBlank As Boolean
    Get
    Set
public:
property bool AcceptBlank {
    bool get ();
    void set (bool value);
}
member AcceptBlank : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAttrStringValidator
Namespace DedNet.Core


Proprietà DedAttrStringValidator.IsLink

Proprietà DedAttrStringValidatorIsLink
Restituisce o imposta se è un link

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsLink { get; set; }
Public Property IsLink As Boolean
    Get
    Set
public:
property bool IsLink {
    bool get ();
    void set (bool value);
}
member IsLink : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAttrStringValidator
Namespace DedNet.Core


Proprietà DedAttrStringValidator.MaxLen

Proprietà DedAttrStringValidatorMaxLen
Restituisce o imposta la lunghezza massimo che deve avere l'attributo per essere valido.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int MaxLen { get; set; }
Public Property MaxLen As Integer
    Get
    Set
public:
property int MaxLen {
    int get ();
    void set (int value);
}
member MaxLen : int with get, set

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe DedAttrStringValidator
Namespace DedNet.Core


Proprietà DedAttrStringValidator.MinLen

Proprietà DedAttrStringValidatorMinLen
Restituisce o imposta la lunghezza minima che deve avere l'attributo per essere valido.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int MinLen { get; set; }
Public Property MinLen As Integer
    Get
    Set
public:
property int MinLen {
    int get ();
    void set (int value);
}
member MinLen : int with get, set

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe DedAttrStringValidator
Namespace DedNet.Core


Proprietà DedAttrStringValidator.Multiline

Proprietà DedAttrStringValidatorMultiline
Restituisce o imposta se è multilinea

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Multiline { get; set; }
Public Property Multiline As Boolean
    Get
    Set
public:
property bool Multiline {
    bool get ();
    void set (bool value);
}
member Multiline : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedAttrStringValidator
Namespace DedNet.Core


Metodi di DedAttrStringValidator

Il tipo DedAttrStringValidator espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Ereditato da DedAttrValidatorBase)
Metodo pubblico | GetHashCode | (Ereditato da DedAttrValidatorBase)
Metodo pubblico | HasCheckFunction | Verifica se questo attributo ha una funzione personalizzata. (Ereditato da DedAttrValidatorBase)
Metodo pubblico | IsRequired | Restituisce true se l'attributo è obbligatorio considerando anche il contesto (creazione/revisione) (Ereditato da DedAttrValidatorBase)
Metodo pubblico | ToString | (Sovrascrive DedAttrValidatorBaseToString)
Metodo pubblico | Validate(Object, IDedEditable, Boolean, Boolean) | Valida il valore dell'attributo senza sollevare eccezioni. (Sovrascrive DedAttrValidatorBaseValidate(Object, IDedEditable, Boolean, Boolean))
Metodo pubblico | Validate(Object, IDedEditable, Boolean, Boolean, String) | Valida il valore dell'attributo restituendo l'eventuale errore di convalidazione. (Sovrascrive DedAttrValidatorBaseValidate(Object, IDedEditable, Boolean, Boolean, String))
Metodo pubblico | ValueCanNotBeErased | Controlla se il valore può essere cancellato. Ovvero se non siamo in un'operazione di crea anagrafia o crea revisione e il tipo di obbligatorietà è cerazione o revisione il valore dell'attributo non può essere cancellato. Mentre se è già vuoto non necessita di essere compilato (come avviene per un obbligatorietà 'sempre') (Ereditato da DedAttrValidatorBase)
Torna su
Vedi anche

Documentazione

Classe DedAttrStringValidator
Namespace DedNet.Core


Metodo DedAttrStringValidator.ToString

Metodo DedAttrStringValidatorToString

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedAttrStringValidator
Namespace DedNet.Core


Metodo DedAttrStringValidator.Validate

Metodo DedAttrStringValidatorValidate
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Validate(Object, IDedEditable, Boolean, Boolean) | Valida il valore dell'attributo senza sollevare eccezioni.
Metodo pubblico | Validate(Object, IDedEditable, Boolean, Boolean, String) | Valida il valore dell'attributo restituendo l'eventuale errore di convalidazione.
Torna su
Vedi anche

Documentazione

Classe DedAttrStringValidator
Namespace DedNet.Core


Metodo DedAttrStringValidator.Validate(Object, IDedEditable, Boolean, Boolean)

Metodo DedAttrStringValidatorValidate(Object, IDedEditable, Boolean, Boolean)
Valida il valore dell'attributo senza sollevare eccezioni.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Validate(
    Object val,
    IDedEditable data,
    bool creating,
    bool revisioning
)
Public Overrides Function Validate (
    val As Object,
    data As IDedEditable,
    creating As Boolean,
    revisioning As Boolean
) As Boolean
public:
virtual bool Validate(
    Object^ val,
    IDedEditable^ data,
    bool creating,
    bool revisioning
) override
abstract Validate :
        val : Object *
        data : IDedEditable *
        creating : bool *
        revisioning : bool -> bool
override Validate :
        val : Object *
        data : IDedEditable *
        creating : bool *
        revisioning : bool -> bool

Parametri

val Object
Valore da convalidare.
data IDedEditable
creating Boolean
revisioning Boolean

Valore di ritorno

Boolean
Restituisce true se il valore è convalidato altrimenti false.
Vedi anche

Documentazione

Classe DedAttrStringValidator
Overload di Validate
Namespace DedNet.Core


Metodo DedAttrStringValidator.Validate(Object, IDedEditable, Boolean, Boolean, String)

Metodo DedAttrStringValidatorValidate(Object, IDedEditable, Boolean, Boolean, String)
Valida il valore dell'attributo restituendo l'eventuale errore di convalidazione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Validate(
    Object val,
    IDedEditable data,
    bool creating,
    bool revisioning,
    out string error
)
Public Overrides Function Validate (
    val As Object,
    data As IDedEditable,
    creating As Boolean,
    revisioning As Boolean,
    <OutAttribute> ByRef error As String
) As Boolean
public:
virtual bool Validate(
    Object^ val,
    IDedEditable^ data,
    bool creating,
    bool revisioning,
    [OutAttribute] String^% error
) override
abstract Validate :
        val : Object *
        data : IDedEditable *
        creating : bool *
        revisioning : bool *
        error : string byref -> bool
override Validate :
        val : Object *
        data : IDedEditable *
        creating : bool *
        revisioning : bool *
        error : string byref -> bool

Parametri

val Object
Valore da convalidare.
data IDedEditable
creating Boolean
revisioning Boolean
error String
Errore di validazione restituito al chiamante.

Valore di ritorno

Boolean
Restituisce true se il valore è convalidato altrimenti false.
Vedi anche

Documentazione

Classe DedAttrStringValidator
Overload di Validate
Namespace DedNet.Core


Classe DedAttrValidatorBase
Classe base per la validazione attributo.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedAttrValidatorBase
Altro

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public abstract class DedAttrValidatorBase
Public MustInherit Class DedAttrValidatorBase
public ref class DedAttrValidatorBase abstract
[<AbstractClassAttribute>]
type DedAttrValidatorBase = class end

Il tipo DedAttrValidatorBase espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Attr | Restituisce l'attributo di appartenenza.
Proprietà pubblica | CheckFunction | Imposta o restituisce il nome della funzione di controllo personalizzata.
Proprietà pubblica | Required | Imposta o restituisce se l'attributo possa o meno essere lasciato vuoto.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | HasCheckFunction | Verifica se questo attributo ha una funzione personalizzata.
Metodo pubblico | IsRequired | Restituisce true se l'attributo è obbligatorio considerando anche il contesto (creazione/revisione)
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Metodo pubblico | Validate(Object, IDedEditable, Boolean, Boolean) | Valida il valore dell'attributo senza sollevare eccezioni.
Metodo pubblico | Validate(Object, IDedEditable, Boolean, Boolean, String) | Valida il valore dell'attributo restituendo l'eventuale errore di convalidazione.
Metodo pubblico | ValueCanNotBeErased | Controlla se il valore può essere cancellato. Ovvero se non siamo in un'operazione di crea anagrafia o crea revisione e il tipo di obbligatorietà è cerazione o revisione il valore dell'attributo non può essere cancellato. Mentre se è già vuoto non necessita di essere compilato (come avviene per un obbligatorietà 'sempre')
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedAttrValidatorBase
DedNet.CoreDedAttrDateValidator
DedNet.CoreDedAttrDoubleValidator
DedNet.CoreDedAttrIntegerValidator
DedNet.CoreDedAttrSiNoValidator
DedNet.CoreDedAttrStringValidator


Proprietà di DedAttrValidatorBase

Il tipo DedAttrValidatorBase espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Attr | Restituisce l'attributo di appartenenza.
Proprietà pubblica | CheckFunction | Imposta o restituisce il nome della funzione di controllo personalizzata.
Proprietà pubblica | Required | Imposta o restituisce se l'attributo possa o meno essere lasciato vuoto.
Torna su
Vedi anche

Documentazione

Classe DedAttrValidatorBase
Namespace DedNet.Core


Proprietà DedAttrValidatorBase.Attr

Proprietà DedAttrValidatorBaseAttr
Restituisce l'attributo di appartenenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttr Attr { get; }
Public ReadOnly Property Attr As DedAttr
    Get
public:
property DedAttr^ Attr {
    DedAttr^ get ();
}
member Attr : DedAttr with get

Valore della proprietà

DedAttr
Vedi anche

Documentazione

Classe DedAttrValidatorBase
Namespace DedNet.Core


Proprietà DedAttrValidatorBase.CheckFunction

Proprietà DedAttrValidatorBaseCheckFunction
Imposta o restituisce il nome della funzione di controllo personalizzata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string CheckFunction { get; set; }
Public Property CheckFunction As String
    Get
    Set
public:
property String^ CheckFunction {
    String^ get ();
    void set (String^ value);
}
member CheckFunction : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedAttrValidatorBase
Namespace DedNet.Core


Proprietà DedAttrValidatorBase.Required

Proprietà DedAttrValidatorBaseRequired
Imposta o restituisce se l'attributo possa o meno essere lasciato vuoto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrRequiredEnum Required { get; set; }
Public Property Required As DedAttrRequiredEnum
    Get
    Set
public:
property DedAttrRequiredEnum Required {
    DedAttrRequiredEnum get ();
    void set (DedAttrRequiredEnum value);
}
member Required : DedAttrRequiredEnum with get, set

Valore della proprietà

DedAttrRequiredEnum
Vedi anche

Documentazione

Classe DedAttrValidatorBase
Namespace DedNet.Core


Metodi di DedAttrValidatorBase

Il tipo DedAttrValidatorBase espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | HasCheckFunction | Verifica se questo attributo ha una funzione personalizzata.
Metodo pubblico | IsRequired | Restituisce true se l'attributo è obbligatorio considerando anche il contesto (creazione/revisione)
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Metodo pubblico | Validate(Object, IDedEditable, Boolean, Boolean) | Valida il valore dell'attributo senza sollevare eccezioni.
Metodo pubblico | Validate(Object, IDedEditable, Boolean, Boolean, String) | Valida il valore dell'attributo restituendo l'eventuale errore di convalidazione.
Metodo pubblico | ValueCanNotBeErased | Controlla se il valore può essere cancellato. Ovvero se non siamo in un'operazione di crea anagrafia o crea revisione e il tipo di obbligatorietà è cerazione o revisione il valore dell'attributo non può essere cancellato. Mentre se è già vuoto non necessita di essere compilato (come avviene per un obbligatorietà 'sempre')
Torna su
Vedi anche

Documentazione

Classe DedAttrValidatorBase
Namespace DedNet.Core


Metodo DedAttrValidatorBase.Equals

Metodo DedAttrValidatorBaseEquals

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj Object

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedAttrValidatorBase
Namespace DedNet.Core


Metodo DedAttrValidatorBase.GetHashCode

Metodo DedAttrValidatorBaseGetHashCode

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedAttrValidatorBase
Namespace DedNet.Core


Metodo DedAttrValidatorBase.HasCheckFunction

Metodo DedAttrValidatorBaseHasCheckFunction
Verifica se questo attributo ha una funzione personalizzata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasCheckFunction()
Public Function HasCheckFunction As Boolean
public:
bool HasCheckFunction()
member HasCheckFunction : unit -> bool

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedAttrValidatorBase
Namespace DedNet.Core


Metodo DedAttrValidatorBase.IsRequired

Metodo DedAttrValidatorBaseIsRequired
Restituisce true se l'attributo è obbligatorio considerando anche il contesto (creazione/revisione)

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsRequired(
    bool creating,
    bool revisioning
)
Public Function IsRequired (
    creating As Boolean,
    revisioning As Boolean
) As Boolean
public:
bool IsRequired(
    bool creating,
    bool revisioning
)
member IsRequired :
        creating : bool *
        revisioning : bool -> bool

Parametri

creating Boolean
Indica se si è in una fase di creazione anagrafica
revisioning Boolean
Indica se si è in una fase di revisione anagrafica

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedAttrValidatorBase
Namespace DedNet.Core


Metodo DedAttrValidatorBase.ToString

Metodo DedAttrValidatorBaseToString

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedAttrValidatorBase
Namespace DedNet.Core


Metodo DedAttrValidatorBase.Validate

Metodo DedAttrValidatorBaseValidate
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Validate(Object, IDedEditable, Boolean, Boolean) | Valida il valore dell'attributo senza sollevare eccezioni.
Metodo pubblico | Validate(Object, IDedEditable, Boolean, Boolean, String) | Valida il valore dell'attributo restituendo l'eventuale errore di convalidazione.
Torna su
Vedi anche

Documentazione

Classe DedAttrValidatorBase
Namespace DedNet.Core


Metodo DedAttrValidatorBase.Validate(Object, IDedEditable, Boolean, Boolean)

Metodo DedAttrValidatorBaseValidate(Object, IDedEditable, Boolean, Boolean)
Valida il valore dell'attributo senza sollevare eccezioni.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public abstract bool Validate(
    Object val,
    IDedEditable data,
    bool creating,
    bool revisioning
)
Public MustOverride Function Validate (
    val As Object,
    data As IDedEditable,
    creating As Boolean,
    revisioning As Boolean
) As Boolean
public:
virtual bool Validate(
    Object^ val,
    IDedEditable^ data,
    bool creating,
    bool revisioning
) abstract
abstract Validate :
        val : Object *
        data : IDedEditable *
        creating : bool *
        revisioning : bool -> bool

Parametri

val Object
Valore da convalidare.
data IDedEditable
creating Boolean
revisioning Boolean

Valore di ritorno

Boolean
Restituisce true se il valore è convalidato altrimenti false.
Vedi anche

Documentazione

Classe DedAttrValidatorBase
Overload di Validate
Namespace DedNet.Core


Metodo DedAttrValidatorBase.Validate(Object, IDedEditable, Boolean, Boolean, String)

Metodo DedAttrValidatorBaseValidate(Object, IDedEditable, Boolean, Boolean, String)
Valida il valore dell'attributo restituendo l'eventuale errore di convalidazione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual bool Validate(
    Object val,
    IDedEditable data,
    bool creating,
    bool revisioning,
    out string error
)
Public Overridable Function Validate (
    val As Object,
    data As IDedEditable,
    creating As Boolean,
    revisioning As Boolean,
    <OutAttribute> ByRef error As String
) As Boolean
public:
virtual bool Validate(
    Object^ val,
    IDedEditable^ data,
    bool creating,
    bool revisioning,
    [OutAttribute] String^% error
)
abstract Validate :
        val : Object *
        data : IDedEditable *
        creating : bool *
        revisioning : bool *
        error : string byref -> bool
override Validate :
        val : Object *
        data : IDedEditable *
        creating : bool *
        revisioning : bool *
        error : string byref -> bool

Parametri

val Object
Valore da convalidare.
data IDedEditable
creating Boolean
revisioning Boolean
error String
Errore di validazione restituito al chiamante.

Valore di ritorno

Boolean
Restituisce true se il valore è convalidato altrimenti false.
Vedi anche

Documentazione

Classe DedAttrValidatorBase
Overload di Validate
Namespace DedNet.Core


Metodo DedAttrValidatorBase.ValueCanNotBeErased

Metodo DedAttrValidatorBaseValueCanNotBeErased
Controlla se il valore può essere cancellato. Ovvero se non siamo in un'operazione di crea anagrafia o crea revisione e il tipo di obbligatorietà è cerazione o revisione il valore dell'attributo non può essere cancellato. Mentre se è già vuoto non necessita di essere compilato (come avviene per un obbligatorietà 'sempre')

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ValueCanNotBeErased(
    Object val,
    IDedEditable data,
    bool creating,
    bool revisioning
)
Public Function ValueCanNotBeErased (
    val As Object,
    data As IDedEditable,
    creating As Boolean,
    revisioning As Boolean
) As Boolean
public:
bool ValueCanNotBeErased(
    Object^ val,
    IDedEditable^ data,
    bool creating,
    bool revisioning
)
member ValueCanNotBeErased :
        val : Object *
        data : IDedEditable *
        creating : bool *
        revisioning : bool -> bool

Parametri

val Object
Valore dell'attributo
data IDedEditable
Anagrafica in gioco
creating Boolean
Indica se si è in una fase di creazione anagrafica
revisioning Boolean
Indica se si è in una fase di revisione anagrafica

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedAttrValidatorBase
Namespace DedNet.Core


Classe DedAttrValidatorFactory
Factory di oggetti DedAttrValidator.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedAttrValidatorFactory

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static class DedAttrValidatorFactory
Public NotInheritable Class DedAttrValidatorFactory
public ref class DedAttrValidatorFactory abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DedAttrValidatorFactory = class end

Il tipo DedAttrValidatorFactory espone i seguenti membri.

Metodi
Nome | Descrizione
CreateValidator | Crea un nuovo validatore, dato l'attributo e la stringa di validazione e lo restituisce dopo averlo abbinato all'attributo.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Metodi di DedAttrValidatorFactory

Il tipo DedAttrValidatorFactory espone i seguenti membri.

Metodi
Nome | Descrizione
CreateValidator | Crea un nuovo validatore, dato l'attributo e la stringa di validazione e lo restituisce dopo averlo abbinato all'attributo.
Torna su
Vedi anche

Documentazione

Classe DedAttrValidatorFactory
Namespace DedNet.Core


Metodo DedAttrValidatorFactory.CreateValidator

Metodo DedAttrValidatorFactoryCreateValidator
Crea un nuovo validatore, dato l'attributo e la stringa di validazione e lo restituisce dopo averlo abbinato all'attributo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static DedAttrValidatorBase CreateValidator(
    DedAttr attr,
    string validstr
)
Public Shared Function CreateValidator (
    attr As DedAttr,
    validstr As String
) As DedAttrValidatorBase
public:
static DedAttrValidatorBase^ CreateValidator(
    DedAttr^ attr,
    String^ validstr
)
static member CreateValidator :
        attr : DedAttr *
        validstr : string -> DedAttrValidatorBase

Parametri

attr DedAttr
Attributo per il quale creare un validatore.
validstr String
Stringa di validazione.

Valore di ritorno

DedAttrValidatorBase
Restituisce il validatore creato ed abbinato all'attributo.
Vedi anche

Documentazione

Classe DedAttrValidatorFactory
Namespace DedNet.Core


Classe DedBaseDbItem
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedBaseDbItem
DedNet.CoreDedEditableObjectT
DedNet.CoreDedTimedDbItem

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public abstract class DedBaseDbItem
Public MustInherit Class DedBaseDbItem
public ref class DedBaseDbItem abstract
[<AbstractClassAttribute>]
type DedBaseDbItem = class end

Il tipo DedBaseDbItem espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo protetto | DedBaseDbItem |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | DbIndex | GUID, in formato stringa, che identifica in modo univoco l'elemento corrente.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | GetDescription | Restiruisce la descrizione dell'elemento corrente
Metodo pubblico | GetName | Restituisce il nome dell'elemento corrente
Metodo pubblico | GetObjectType | Indica la tipologia dell'elemento corrente (Anagrafica, commessa, ECO, ecc..)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedBaseDbItem

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected DedBaseDbItem()
Protected Sub New
protected:
DedBaseDbItem()
new : unit -> DedBaseDbItem
Vedi anche

Documentazione

Classe DedBaseDbItem
Namespace DedNet.Core


Proprietà di DedBaseDbItem

Il tipo DedBaseDbItem espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | DbIndex | GUID, in formato stringa, che identifica in modo univoco l'elemento corrente.
Torna su
Vedi anche

Documentazione

Classe DedBaseDbItem
Namespace DedNet.Core


Proprietà DedBaseDbItem.DbIndex

Proprietà DedBaseDbItemDbIndex
GUID, in formato stringa, che identifica in modo univoco l'elemento corrente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public abstract string DbIndex { get; }
Public MustOverride ReadOnly Property DbIndex As String
    Get
public:
virtual property String^ DbIndex {
    String^ get () abstract;
}
abstract DbIndex : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedBaseDbItem
Namespace DedNet.Core


Metodi di DedBaseDbItem

Il tipo DedBaseDbItem espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | GetDescription | Restiruisce la descrizione dell'elemento corrente
Metodo pubblico | GetName | Restituisce il nome dell'elemento corrente
Metodo pubblico | GetObjectType | Indica la tipologia dell'elemento corrente (Anagrafica, commessa, ECO, ecc..)
Torna su
Vedi anche

Documentazione

Classe DedBaseDbItem
Namespace DedNet.Core


Metodo DedBaseDbItem.GetDescription

Metodo DedBaseDbItemGetDescription
Restiruisce la descrizione dell'elemento corrente

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual string GetDescription()
Public Overridable Function GetDescription As String
public:
virtual String^ GetDescription()
abstract GetDescription : unit -> string
override GetDescription : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedBaseDbItem
Namespace DedNet.Core


Metodo DedBaseDbItem.GetName

Metodo DedBaseDbItemGetName
Restituisce il nome dell'elemento corrente

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual string GetName()
Public Overridable Function GetName As String
public:
virtual String^ GetName()
abstract GetName : unit -> string
override GetName : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedBaseDbItem
Namespace DedNet.Core


Metodo DedBaseDbItem.GetObjectType

Metodo DedBaseDbItemGetObjectType
Indica la tipologia dell'elemento corrente (Anagrafica, commessa, ECO, ecc..)

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public abstract DedDbItemType GetObjectType()
Public MustOverride Function GetObjectType As DedDbItemType
public:
virtual DedDbItemType GetObjectType() abstract
abstract GetObjectType : unit -> DedDbItemType

Valore di ritorno

DedDbItemType
Vedi anche

Documentazione

Classe DedBaseDbItem
Namespace DedNet.Core


Classe DedCascade
Classe che descrive una singola cascata.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedDbCollectionBase DedCascadeDependency
DedNet.CoreDedCascade

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedCascade : DedDbCollectionBase<DedCascadeDependency>
Public Class DedCascade
    Inherits DedDbCollectionBase(Of DedCascadeDependency)
public ref class DedCascade : public DedDbCollectionBase<DedCascadeDependency^>
type DedCascade =
    class
        inherit DedDbCollectionBase<DedCascadeDependency>
    end

Il tipo DedCascade espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedCascade(DedNetApplication, ListString, String, String) | Costruttore unico.
Metodo pubblico | DedCascade(DedNetApplication, ListString, String, String, DedCascade) | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllowsDuplicates | Restituisce se siano ammessi duplicati all'interno della lista. Se false viene sollevata una eccezione su tentativo di inserimento duplicati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Application | Restituisce l'oggetto applicazione di appartenza. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Count | Restituisce il numero di elementi presenti. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | DbPath | Restituisce o imposta il percorso del DB.
Proprietà pubblica | Dirty | Restituisce se la collezione o uno dei suoi elementi sia stata modificata. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | ErasedItems | Restitusice la lista in sola lettura degli elementi che risultano attualmente cancellati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Figlio | Restituisce o imposta il nome dell'attributo figlio.
Proprietà pubblica | LastItem | Restituisce l'ultimo elemento della collezione oppure null se non ci sono elementi. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Padri | Restituisce la lista dei nomi di tutti gli attributi padre (in ordine).
Proprietà pubblica | Parent | Restituisce o imposta la cascata padre, nel caso di cascate di primo livello è null.
Proprietà pubblica | RestoreErased | Restituisce se gli elementi cancellati devono essere ripristinati in caso vengano riaggiunti. (Ereditato da DedDbCollectionBaseT)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Add(DedCascadeDependency) | Aggiunge alla collezione un elemento già esistente. Gli imposta già come padre la nuova collezione.
Metodo pubblico | Add(Object, DedCascadeValue) | Aggiunge un elemento accodandolo alla lista.
Metodo protetto | AddForClone | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto SENZA MODIFICARNE LO STATO. Le classi derivate potranno utilizzare questo metodo per clonare la collezione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddNewElement | DI USO INTERNO. Aggiunge un elemento alla lista rendendo dirty l'oggetto. L'elemento viene aggiunto con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere un elemento alla lista. Dovranno loro stesse avere un metodo pubblico Add() che prenda i parametri necessari alla costruzione dell'oggetto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddRangeNewElement | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi rendendo dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere più elementi alla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddUnModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Clear | Elimina tutti gli elementi dalla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ClearRefresh | Svuota la lista impostando Dirty = false. Di fatto permette di effettuare un refresh della lista e quindi di ricaricarla. Serve per svuotare la lista e reinizializzarla da capo. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Clone | Metodo per clonare la lista di cascate.
Metodo pubblico | Contains | Verifica l'esistenza di un valore all'interno della lista degli elementi. Le classi derivate devono effettuarne l'override nel caso in cui l'elemento non implementi GetHashCode() per l'uso all'interno dei dizionarii. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | CopyTo | Copia un range di elementi in un array. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | CreateDeleteCommand | Crea, inizializza e restituisce il comando per l'eliminazione di un elemento. (Sovrascrive DedDbCollectionBaseTCreateDeleteCommand(T))
Metodo protetto | CreateInsertCommand | Crea, inizializza e restituisce il comando per l'inserimento di un elemento. (Sovrascrive DedDbCollectionBaseTCreateInsertCommand(T))
Metodo protetto | CreateUpdateCommand | Crea, inizializza e restituisce il comando per l'aggiornamento di un elemento. (Sovrascrive DedDbCollectionBaseTCreateUpdateCommand(T))
Metodo pubblico | CustomSort | Ordina la lista in base al comparatore passato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo protetto | ExecuteDeleteItem | Esegue l'eliminazione di un elemento. Crea il comando tramite il metodo CreateDeleteCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteInsertItem | Esegue l'inserimento di un elemento. Crea il comando tramite il metodo CreateInsertCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteUpdateItem | Esegue l'aggiornamento di un elemento. Crea il comando tramite il metodo CreateUpdateCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Find | Restituisce l'oggetto cercato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FindAll | Restitusice la lista degli elementi che corrispondono al predicato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | GetDbIndex | Restituisce l'indice dell'elemento passato: cioè il suo guid. (Sovrascrive DedDbCollectionBaseTGetDbIndex(T))
Metodo pubblico | GetDependencies | Restituisce la lista di dipendenze corrispondenti al valore padre passato.
Metodo pubblico | GetDependency(DictionaryString, String) | Ritorna la dipendenza corrispondente al dizionaroi passato. Il dizionario deve essere costruito in modo da avere tutte le accoppiate NOMEPADRE-VALOREPADRE e l'accoppiata NOMEFIGLIO-VALOREFIGLIO della dipendenza da trovare.
Metodo pubblico | GetDependency(Object, DedCascadeValue) | Restituisce la dipendenza corrispondente al valore padre e il valore figlio passati.
Metodo pubblico | GetEnumerator | Restituisce l'enumeratore della collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | IndexOf | Restituisce l'indice dell'elemento richiesto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InsertUnModified | DI USO INTERNO. Inserisce un elemento alla lista senza rendere dirty l'oggetto, all'indice specificato. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Item | Restituisce l'elemento iesimo della lista. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean) | Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi. (Sovrascrive DedDbCollectionBaseTMove(Int32, Boolean))
Metodo pubblico | Move(Int32, Boolean, Int32) | Sposta l'elemento dell'indice passato prima o dopo del numero di posizioni passate. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSave | Metodo Template chiamato dopo il salvataggio avvenuto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSaveNoChanges | Metodo Template chiamato dopo il salvataggio senza modifiche. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnBeforeSave | Metodo chiamato prima del salvataggio. Crea le colonne degli attributi padre nel caso in cui non esistano già all'interno della tabella DED_CASCADE. (Sovrascrive DedDbCollectionBaseTOnBeforeSave(ListT, ListT, ListT))
Metodo pubblico | PropertyChanged(T) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(DedEditableObjectT) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(T) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(DedEditableObjectT) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ReInitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Remove | Elimina un elemento dalla collezione. (Sovrascrive DedDbCollectionBaseTRemove(T))
Metodo pubblico | Ripristina | Verifica che l'elemento sia presente negli eliminati e lo toglie da lì e lo riaggiunge in coda alla lista degli elementi validi. Solleva una eccezione se l'elemento è già presente nella lista e AllowsDuplicates = false. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Save | Salva l'oggetto con tutta la sua lista, solo se questo risulta dirty. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | SetDirty | Imposta come Dirty l'item passato.
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedCascade
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | DedCascade(DedNetApplication, ListString, String, String) | Costruttore unico.
Metodo pubblico | DedCascade(DedNetApplication, ListString, String, String, DedCascade) | Costruttore unico.
Torna su
Vedi anche

Documentazione

Classe DedCascade
Namespace DedNet.Core


Costruttore DedCascade(DedNetApplication, List<String>, String, String)

Costruttore DedCascade(DedNetApplication, ListString, String, String)
Costruttore unico.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCascade(
    DedNetApplication app,
    List<string> padri,
    string figlio,
    string dbpath
)
Public Sub New (
    app As DedNetApplication,
    padri As List(Of String),
    figlio As String,
    dbpath As String
)
public:
DedCascade(
    DedNetApplication^ app,
    List<String^>^ padri,
    String^ figlio,
    String^ dbpath
)
new :
        app : DedNetApplication *
        padri : List<string> *
        figlio : string *
        dbpath : string -> DedCascade

Parametri

app DedNetApplication
Applicazione DedNet.
padri List String
Lista dei nomi dei padri.
figlio String
Nome del figlio.
dbpath String
Percorso del db.
Vedi anche

Documentazione

Classe DedCascade
Overload di DedCascade
Namespace DedNet.Core


Costruttore DedCascade(DedNetApplication, List<String>, String, String, DedCascade)

Costruttore DedCascade(DedNetApplication, ListString, String, String, DedCascade)
Costruttore unico.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCascade(
    DedNetApplication app,
    List<string> padri,
    string figlio,
    string dbpath,
    DedCascade parent
)
Public Sub New (
    app As DedNetApplication,
    padri As List(Of String),
    figlio As String,
    dbpath As String,
    parent As DedCascade
)
public:
DedCascade(
    DedNetApplication^ app,
    List<String^>^ padri,
    String^ figlio,
    String^ dbpath,
    DedCascade^ parent
)
new :
        app : DedNetApplication *
        padri : List<string> *
        figlio : string *
        dbpath : string *
        parent : DedCascade -> DedCascade

Parametri

app DedNetApplication
Applicazione DedNet.
padri List String
Lista dei nomi dei padri.
figlio String
Nome del figlio.
dbpath String
Percorso del db.
parent DedCascade
Cascata padre.
Vedi anche

Documentazione

Classe DedCascade
Overload di DedCascade
Namespace DedNet.Core


Proprietà di DedCascade

Il tipo DedCascade espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllowsDuplicates | Restituisce se siano ammessi duplicati all'interno della lista. Se false viene sollevata una eccezione su tentativo di inserimento duplicati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Application | Restituisce l'oggetto applicazione di appartenza. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Count | Restituisce il numero di elementi presenti. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | DbPath | Restituisce o imposta il percorso del DB.
Proprietà pubblica | Dirty | Restituisce se la collezione o uno dei suoi elementi sia stata modificata. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | ErasedItems | Restitusice la lista in sola lettura degli elementi che risultano attualmente cancellati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Figlio | Restituisce o imposta il nome dell'attributo figlio.
Proprietà pubblica | LastItem | Restituisce l'ultimo elemento della collezione oppure null se non ci sono elementi. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Padri | Restituisce la lista dei nomi di tutti gli attributi padre (in ordine).
Proprietà pubblica | Parent | Restituisce o imposta la cascata padre, nel caso di cascate di primo livello è null.
Proprietà pubblica | RestoreErased | Restituisce se gli elementi cancellati devono essere ripristinati in caso vengano riaggiunti. (Ereditato da DedDbCollectionBaseT)
Torna su
Vedi anche

Documentazione

Classe DedCascade
Namespace DedNet.Core


Proprietà DedCascade.DbPath

Proprietà DedCascadeDbPath
Restituisce o imposta il percorso del DB.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string DbPath { get; set; }
Public Property DbPath As String
    Get
    Set
public:
property String^ DbPath {
    String^ get ();
    void set (String^ value);
}
member DbPath : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedCascade
Namespace DedNet.Core


Proprietà DedCascade.Figlio

Proprietà DedCascadeFiglio
Restituisce o imposta il nome dell'attributo figlio.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Figlio { get; set; }
Public Property Figlio As String
    Get
    Set
public:
property String^ Figlio {
    String^ get ();
    void set (String^ value);
}
member Figlio : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedCascade
Namespace DedNet.Core


Proprietà DedCascade.Padri

Proprietà DedCascadePadri
Restituisce la lista dei nomi di tutti gli attributi padre (in ordine).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> Padri { get; }
Public ReadOnly Property Padri As List(Of String)
    Get
public:
property List<String^>^ Padri {
    List<String^>^ get ();
}
member Padri : List<string> with get

Valore della proprietà

List String
Vedi anche

Documentazione

Classe DedCascade
Namespace DedNet.Core


Proprietà DedCascade.Parent

Proprietà DedCascadeParent
Restituisce o imposta la cascata padre, nel caso di cascate di primo livello è null.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCascade Parent { get; set; }
Public Property Parent As DedCascade
    Get
    Set
public:
property DedCascade^ Parent {
    DedCascade^ get ();
    void set (DedCascade^ value);
}
member Parent : DedCascade with get, set

Valore della proprietà

DedCascade
Vedi anche

Documentazione

Classe DedCascade
Namespace DedNet.Core


Metodi di DedCascade

Il tipo DedCascade espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Add(DedCascadeDependency) | Aggiunge alla collezione un elemento già esistente. Gli imposta già come padre la nuova collezione.
Metodo pubblico | Add(Object, DedCascadeValue) | Aggiunge un elemento accodandolo alla lista.
Metodo protetto | AddForClone | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto SENZA MODIFICARNE LO STATO. Le classi derivate potranno utilizzare questo metodo per clonare la collezione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddNewElement | DI USO INTERNO. Aggiunge un elemento alla lista rendendo dirty l'oggetto. L'elemento viene aggiunto con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere un elemento alla lista. Dovranno loro stesse avere un metodo pubblico Add() che prenda i parametri necessari alla costruzione dell'oggetto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddRangeNewElement | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi rendendo dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere più elementi alla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddUnModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Clear | Elimina tutti gli elementi dalla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ClearRefresh | Svuota la lista impostando Dirty = false. Di fatto permette di effettuare un refresh della lista e quindi di ricaricarla. Serve per svuotare la lista e reinizializzarla da capo. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Clone | Metodo per clonare la lista di cascate.
Metodo pubblico | Contains | Verifica l'esistenza di un valore all'interno della lista degli elementi. Le classi derivate devono effettuarne l'override nel caso in cui l'elemento non implementi GetHashCode() per l'uso all'interno dei dizionarii. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | CopyTo | Copia un range di elementi in un array. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | CreateDeleteCommand | Crea, inizializza e restituisce il comando per l'eliminazione di un elemento. (Sovrascrive DedDbCollectionBaseTCreateDeleteCommand(T))
Metodo protetto | CreateInsertCommand | Crea, inizializza e restituisce il comando per l'inserimento di un elemento. (Sovrascrive DedDbCollectionBaseTCreateInsertCommand(T))
Metodo protetto | CreateUpdateCommand | Crea, inizializza e restituisce il comando per l'aggiornamento di un elemento. (Sovrascrive DedDbCollectionBaseTCreateUpdateCommand(T))
Metodo pubblico | CustomSort | Ordina la lista in base al comparatore passato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo protetto | ExecuteDeleteItem | Esegue l'eliminazione di un elemento. Crea il comando tramite il metodo CreateDeleteCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteInsertItem | Esegue l'inserimento di un elemento. Crea il comando tramite il metodo CreateInsertCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteUpdateItem | Esegue l'aggiornamento di un elemento. Crea il comando tramite il metodo CreateUpdateCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Find | Restituisce l'oggetto cercato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FindAll | Restitusice la lista degli elementi che corrispondono al predicato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | GetDbIndex | Restituisce l'indice dell'elemento passato: cioè il suo guid. (Sovrascrive DedDbCollectionBaseTGetDbIndex(T))
Metodo pubblico | GetDependencies | Restituisce la lista di dipendenze corrispondenti al valore padre passato.
Metodo pubblico | GetDependency(DictionaryString, String) | Ritorna la dipendenza corrispondente al dizionaroi passato. Il dizionario deve essere costruito in modo da avere tutte le accoppiate NOMEPADRE-VALOREPADRE e l'accoppiata NOMEFIGLIO-VALOREFIGLIO della dipendenza da trovare.
Metodo pubblico | GetDependency(Object, DedCascadeValue) | Restituisce la dipendenza corrispondente al valore padre e il valore figlio passati.
Metodo pubblico | GetEnumerator | Restituisce l'enumeratore della collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | IndexOf | Restituisce l'indice dell'elemento richiesto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InsertUnModified | DI USO INTERNO. Inserisce un elemento alla lista senza rendere dirty l'oggetto, all'indice specificato. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Item | Restituisce l'elemento iesimo della lista. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean) | Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi. (Sovrascrive DedDbCollectionBaseTMove(Int32, Boolean))
Metodo pubblico | Move(Int32, Boolean, Int32) | Sposta l'elemento dell'indice passato prima o dopo del numero di posizioni passate. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSave | Metodo Template chiamato dopo il salvataggio avvenuto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSaveNoChanges | Metodo Template chiamato dopo il salvataggio senza modifiche. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnBeforeSave | Metodo chiamato prima del salvataggio. Crea le colonne degli attributi padre nel caso in cui non esistano già all'interno della tabella DED_CASCADE. (Sovrascrive DedDbCollectionBaseTOnBeforeSave(ListT, ListT, ListT))
Metodo pubblico | PropertyChanged(T) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(DedEditableObjectT) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(T) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(DedEditableObjectT) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ReInitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Remove | Elimina un elemento dalla collezione. (Sovrascrive DedDbCollectionBaseTRemove(T))
Metodo pubblico | Ripristina | Verifica che l'elemento sia presente negli eliminati e lo toglie da lì e lo riaggiunge in coda alla lista degli elementi validi. Solleva una eccezione se l'elemento è già presente nella lista e AllowsDuplicates = false. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Save | Salva l'oggetto con tutta la sua lista, solo se questo risulta dirty. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | SetDirty | Imposta come Dirty l'item passato.
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Torna su
Vedi anche

Documentazione

Classe DedCascade
Namespace DedNet.Core


Metodo DedCascade.Add

Metodo DedCascadeAdd
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Add(DedCascadeDependency) | Aggiunge alla collezione un elemento già esistente. Gli imposta già come padre la nuova collezione.
Metodo pubblico | Add(Object, DedCascadeValue) | Aggiunge un elemento accodandolo alla lista.
Torna su
Vedi anche

Documentazione

Classe DedCascade
Namespace DedNet.Core


Metodo DedCascade.Add(DedCascadeDependency)

Metodo DedCascadeAdd(DedCascadeDependency)
Aggiunge alla collezione un elemento già esistente. Gli imposta già come padre la nuova collezione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Add(
    DedCascadeDependency dep
)
Public Sub Add (
    dep As DedCascadeDependency
)
public:
void Add(
    DedCascadeDependency^ dep
)
member Add :
        dep : DedCascadeDependency -> unit

Parametri

dep DedCascadeDependency
Elemento da aggiungere alla collezione.
Vedi anche

Documentazione

Classe DedCascade
Overload di Add
Namespace DedNet.Core


Metodo DedCascade.Add(Object, DedCascadeValue)

Metodo DedCascadeAdd(Object, DedCascadeValue)
Aggiunge un elemento accodandolo alla lista.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCascadeDependency Add(
    Object valpadre,
    DedCascadeValue valfiglio
)
Public Function Add (
    valpadre As Object,
    valfiglio As DedCascadeValue
) As DedCascadeDependency
public:
DedCascadeDependency^ Add(
    Object^ valpadre,
    DedCascadeValue^ valfiglio
)
member Add :
        valpadre : Object *
        valfiglio : DedCascadeValue -> DedCascadeDependency

Parametri

valpadre Object
Valore (o combinazione di valori) del padre.
valfiglio DedCascadeValue
Valore del figlio.

Valore di ritorno

DedCascadeDependency
Restituisce l'elemento appena aggiunto.
Vedi anche

Documentazione

Classe DedCascade
Overload di Add
Namespace DedNet.Core


Metodo DedCascade.Clone

Metodo DedCascadeClone
Metodo per clonare la lista di cascate.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCascade Clone()
Public Function Clone As DedCascade
public:
DedCascade^ Clone()
member Clone : unit -> DedCascade

Valore di ritorno

DedCascade
Vedi anche

Documentazione

Classe DedCascade
Namespace DedNet.Core


Metodo DedCascade.CreateDeleteCommand

Metodo DedCascadeCreateDeleteCommand
Crea, inizializza e restituisce il comando per l'eliminazione di un elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSDeleteCommand CreateDeleteCommand(
    DedCascadeDependency item
)
Protected Overrides Function CreateDeleteCommand (
    item As DedCascadeDependency
) As QSDeleteCommand
protected:
virtual QSDeleteCommand^ CreateDeleteCommand(
    DedCascadeDependency^ item
) override
abstract CreateDeleteCommand :
        item : DedCascadeDependency -> QSDeleteCommand
override CreateDeleteCommand :
        item : DedCascadeDependency -> QSDeleteCommand

Parametri

item DedCascadeDependency
Elemento da utilizzare per inizializzare il comando.

Valore di ritorno

QSDeleteCommand
Il comando inizializzato, pronto per essere eseguito.
Vedi anche

Documentazione

Classe DedCascade
Namespace DedNet.Core


Metodo DedCascade.CreateInsertCommand

Metodo DedCascadeCreateInsertCommand
Crea, inizializza e restituisce il comando per l'inserimento di un elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSInsertCommand CreateInsertCommand(
    DedCascadeDependency item
)
Protected Overrides Function CreateInsertCommand (
    item As DedCascadeDependency
) As QSInsertCommand
protected:
virtual QSInsertCommand^ CreateInsertCommand(
    DedCascadeDependency^ item
) override
abstract CreateInsertCommand :
        item : DedCascadeDependency -> QSInsertCommand
override CreateInsertCommand :
        item : DedCascadeDependency -> QSInsertCommand

Parametri

item DedCascadeDependency
Elemento da utilizzare per inizializzare il comando.

Valore di ritorno

QSInsertCommand
Il comando inizializzato, pronto per essere eseguito.
Vedi anche

Documentazione

Classe DedCascade
Namespace DedNet.Core


Metodo DedCascade.CreateUpdateCommand

Metodo DedCascadeCreateUpdateCommand
Crea, inizializza e restituisce il comando per l'aggiornamento di un elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSUpdateCommand CreateUpdateCommand(
    DedCascadeDependency item
)
Protected Overrides Function CreateUpdateCommand (
    item As DedCascadeDependency
) As QSUpdateCommand
protected:
virtual QSUpdateCommand^ CreateUpdateCommand(
    DedCascadeDependency^ item
) override
abstract CreateUpdateCommand :
        item : DedCascadeDependency -> QSUpdateCommand
override CreateUpdateCommand :
        item : DedCascadeDependency -> QSUpdateCommand

Parametri

item DedCascadeDependency
Elemento da utilizzare per inizializzare il comando.

Valore di ritorno

QSUpdateCommand
Il comando inizializzato, pronto per essere eseguito.
Vedi anche

Documentazione

Classe DedCascade
Namespace DedNet.Core


Metodo DedCascade.Equals

Metodo DedCascadeEquals

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj Object

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedCascade
Namespace DedNet.Core


Metodo DedCascade.GetDbIndex

Metodo DedCascadeGetDbIndex
Restituisce l'indice dell'elemento passato: cioè il suo guid.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override Object GetDbIndex(
    DedCascadeDependency item
)
Protected Overrides Function GetDbIndex (
    item As DedCascadeDependency
) As Object
protected:
virtual Object^ GetDbIndex(
    DedCascadeDependency^ item
) override
abstract GetDbIndex :
        item : DedCascadeDependency -> Object
override GetDbIndex :
        item : DedCascadeDependency -> Object

Parametri

item DedCascadeDependency
Elemento del quale restituire l'indice.

Valore di ritorno

Object
Restituisce l'indice dell'elemento oppure null.
Vedi anche

Documentazione

Classe DedCascade
Namespace DedNet.Core


Metodo DedCascade.GetDependencies

Metodo DedCascadeGetDependencies
Restituisce la lista di dipendenze corrispondenti al valore padre passato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<DedCascadeDependency> GetDependencies(
    Object valPadre
)
Public Function GetDependencies (
    valPadre As Object
) As List(Of DedCascadeDependency)
public:
List<DedCascadeDependency^>^ GetDependencies(
    Object^ valPadre
)
member GetDependencies :
        valPadre : Object -> List<DedCascadeDependency>

Parametri

valPadre Object
Valore del padre.

Valore di ritorno

List DedCascadeDependency
Vedi anche

Documentazione

Classe DedCascade
Namespace DedNet.Core


Metodo DedCascade.GetDependency

Metodo DedCascadeGetDependency
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | GetDependency(DictionaryString, String) | Ritorna la dipendenza corrispondente al dizionaroi passato. Il dizionario deve essere costruito in modo da avere tutte le accoppiate NOMEPADRE-VALOREPADRE e l'accoppiata NOMEFIGLIO-VALOREFIGLIO della dipendenza da trovare.
Metodo pubblico | GetDependency(Object, DedCascadeValue) | Restituisce la dipendenza corrispondente al valore padre e il valore figlio passati.
Torna su
Vedi anche

Documentazione

Classe DedCascade
Namespace DedNet.Core


Metodo DedCascade.GetDependency(Dictionary<String, String>)

Metodo DedCascadeGetDependency(DictionaryString, String)
Ritorna la dipendenza corrispondente al dizionaroi passato. Il dizionario deve essere costruito in modo da avere tutte le accoppiate NOMEPADRE-VALOREPADRE e l'accoppiata NOMEFIGLIO-VALOREFIGLIO della dipendenza da trovare.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCascadeDependency GetDependency(
    Dictionary<string, string> values
)
Public Function GetDependency (
    values As Dictionary(Of String, String)
) As DedCascadeDependency
public:
DedCascadeDependency^ GetDependency(
    Dictionary<String^, String^>^ values
)
member GetDependency :
        values : Dictionary<string, string> -> DedCascadeDependency

Parametri

values Dictionary String, String
Dizionario dei valori dei padri.

Valore di ritorno

DedCascadeDependency
Vedi anche

Documentazione

Classe DedCascade
Overload di GetDependency
Namespace DedNet.Core


Metodo DedCascade.GetDependency(Object, DedCascadeValue)

Metodo DedCascadeGetDependency(Object, DedCascadeValue)
Restituisce la dipendenza corrispondente al valore padre e il valore figlio passati.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCascadeDependency GetDependency(
    Object valPadre,
    DedCascadeValue valFiglio
)
Public Function GetDependency (
    valPadre As Object,
    valFiglio As DedCascadeValue
) As DedCascadeDependency
public:
DedCascadeDependency^ GetDependency(
    Object^ valPadre,
    DedCascadeValue^ valFiglio
)
member GetDependency :
        valPadre : Object *
        valFiglio : DedCascadeValue -> DedCascadeDependency

Parametri

valPadre Object
Valore del padre.
valFiglio DedCascadeValue
Valore del figlio.

Valore di ritorno

DedCascadeDependency
Vedi anche

Documentazione

Classe DedCascade
Overload di GetDependency
Namespace DedNet.Core


Metodo DedCascade.GetHashCode

Metodo DedCascadeGetHashCode

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedCascade
Namespace DedNet.Core


Metodo DedCascade.Move

Metodo DedCascadeMove
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Move(Int32, Boolean) | Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi.
Metodo pubblico | Move(Int32, Boolean, Int32) | Sposta l'elemento dell'indice passato prima o dopo del numero di posizioni passate. Ignora eventuali valori di indice non validi.
Torna su
Vedi anche

Documentazione

Classe DedCascade
Namespace DedNet.Core


Metodo DedCascade.Move(Int32, Boolean)

Metodo DedCascadeMove(Int32, Boolean)
Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void Move(
    int index,
    bool up
)
Public Overrides Sub Move (
    index As Integer,
    up As Boolean
)
public:
virtual void Move(
    int index,
    bool up
) override
abstract Move :
        index : int *
        up : bool -> unit
override Move :
        index : int *
        up : bool -> unit

Parametri

index Int32
Indice dell'elemento da spostare.
up Boolean
Se true l'elemento viene spostato in alto (nell'indice precedente) altrimenti all'indice successivo.
Vedi anche

Documentazione

Classe DedCascade
Overload di Move
Namespace DedNet.Core


Metodo DedCascade.OnBeforeSave

Metodo DedCascadeOnBeforeSave
Metodo chiamato prima del salvataggio. Crea le colonne degli attributi padre nel caso in cui non esistano già all'interno della tabella DED_CASCADE.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void OnBeforeSave(
    List<DedCascadeDependency> eliminati,
    List<DedCascadeDependency> modificati,
    List<DedCascadeDependency> aggiunti
)
Protected Overrides Sub OnBeforeSave (
    eliminati As List(Of DedCascadeDependency),
    modificati As List(Of DedCascadeDependency),
    aggiunti As List(Of DedCascadeDependency)
)
protected:
virtual void OnBeforeSave(
    List<DedCascadeDependency^>^ eliminati,
    List<DedCascadeDependency^>^ modificati,
    List<DedCascadeDependency^>^ aggiunti
) override
abstract OnBeforeSave :
        eliminati : List<DedCascadeDependency> *
        modificati : List<DedCascadeDependency> *
        aggiunti : List<DedCascadeDependency> -> unit
override OnBeforeSave :
        eliminati : List<DedCascadeDependency> *
        modificati : List<DedCascadeDependency> *
        aggiunti : List<DedCascadeDependency> -> unit

Parametri

eliminati List DedCascadeDependency
modificati List DedCascadeDependency
aggiunti List DedCascadeDependency
Vedi anche

Documentazione

Classe DedCascade
Namespace DedNet.Core


Metodo DedCascade.Remove

Metodo DedCascadeRemove
Elimina un elemento dalla collezione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void Remove(
    DedCascadeDependency item
)
Public Overrides Sub Remove (
    item As DedCascadeDependency
)
public:
virtual void Remove(
    DedCascadeDependency^ item
) override
abstract Remove :
        item : DedCascadeDependency -> unit
override Remove :
        item : DedCascadeDependency -> unit

Parametri

item DedCascadeDependency
Elemento da eliminare.
Vedi anche

Documentazione

Classe DedCascade
Namespace DedNet.Core


Metodo DedCascade.SetDirty

Metodo DedCascadeSetDirty
Imposta come Dirty l'item passato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetDirty(
    DedCascadeDependency item
)
Public Sub SetDirty (
    item As DedCascadeDependency
)
public:
void SetDirty(
    DedCascadeDependency^ item
)
member SetDirty :
        item : DedCascadeDependency -> unit

Parametri

item DedCascadeDependency
Vedi anche

Documentazione

Classe DedCascade
Namespace DedNet.Core


Metodo DedCascade.ToString

Metodo DedCascadeToString

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedCascade
Namespace DedNet.Core


Classe DedCascadeDependency
Classe che descrive una dipendenza tra uno o più valori padre e un valore figlio. Corrisponde a un record della tabella DED_CASCADE del database.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedCascadeDependency

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedCascadeDependency : IDedDbItem
Public Class DedCascadeDependency
    Implements IDedDbItem
public ref class DedCascadeDependency : IDedDbItem
type DedCascadeDependency =
    class
        interface IDedDbItem
    end

Il tipo DedCascadeDependency espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedCascadeDependency(DedCascade, Object, DedCascadeValue) | Costruttore unico.
Metodo pubblico | DedCascadeDependency(DedCascade, Guid, Object, DedCascadeValue, Int32) | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | ID | Restituisce il Guid del record nel database.
Proprietà pubblica | Multival | Indica se la combinazione di padri si tratta di un multivalore.
Proprietà pubblica | Ord | Posizione ordinata della dipendenza.
Proprietà pubblica | Parent | Retituisce la cascata di appartenenza.
Proprietà pubblica | StatoRecord | Restituisce o imposta lo stato del record. DI USO INTERNO !!
Proprietà pubblica | ValFiglio | Restituisce o imposta l'oggetto che contiene il valore del figlio e la sua descrizione.
Proprietà pubblica | ValPadre | Restituisce o imposta l'oggetto del valore padre. Può essere un valore (string) in caso di cascata di primo livello, oppure un'altra DedCascadeDependency in caso di cascate figlie.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | BeginIgnoreDirty | Attiva l'ignoramento della notifica di Dirty.
Metodo pubblico | Clone | Metodo per clonare la dipendenza.
Metodo pubblico | EndIgnoreDirty | Disattiva l'ignoramento della notifica di Dirty.
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedCascadeDependency
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | DedCascadeDependency(DedCascade, Object, DedCascadeValue) | Costruttore unico.
Metodo pubblico | DedCascadeDependency(DedCascade, Guid, Object, DedCascadeValue, Int32) | Costruttore unico.
Torna su
Vedi anche

Documentazione

Classe DedCascadeDependency
Namespace DedNet.Core


Costruttore DedCascadeDependency(DedCascade, Object, DedCascadeValue)
Costruttore unico.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCascadeDependency(
    DedCascade parent,
    Object valpadre,
    DedCascadeValue valfiglio
)
Public Sub New (
    parent As DedCascade,
    valpadre As Object,
    valfiglio As DedCascadeValue
)
public:
DedCascadeDependency(
    DedCascade^ parent,
    Object^ valpadre,
    DedCascadeValue^ valfiglio
)
new :
        parent : DedCascade *
        valpadre : Object *
        valfiglio : DedCascadeValue -> DedCascadeDependency

Parametri

parent DedCascade
Cascata di appartenenza.
valpadre Object
Valore del padre.
valfiglio DedCascadeValue
Valore del figlio.
Vedi anche

Documentazione

Classe DedCascadeDependency
Overload di DedCascadeDependency
Namespace DedNet.Core


Costruttore DedCascadeDependency(DedCascade, Guid, Object, DedCascadeValue, Int32)
Costruttore unico.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCascadeDependency(
    DedCascade parent,
    Guid id,
    Object valpadre,
    DedCascadeValue valfiglio,
    int ord
)
Public Sub New (
    parent As DedCascade,
    id As Guid,
    valpadre As Object,
    valfiglio As DedCascadeValue,
    ord As Integer
)
public:
DedCascadeDependency(
    DedCascade^ parent,
    Guid id,
    Object^ valpadre,
    DedCascadeValue^ valfiglio,
    int ord
)
new :
        parent : DedCascade *
        id : Guid *
        valpadre : Object *
        valfiglio : DedCascadeValue *
        ord : int -> DedCascadeDependency

Parametri

parent DedCascade
Cascata di appartenenza
id Guid
Guid del record nel db.
valpadre Object
Valore del padre.
valfiglio DedCascadeValue
Valore del figlio.
ord Int32
Posizione ordinata del valore nella cascata.
Vedi anche

Documentazione

Classe DedCascadeDependency
Overload di DedCascadeDependency
Namespace DedNet.Core


Proprietà di DedCascadeDependency

Il tipo DedCascadeDependency espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | ID | Restituisce il Guid del record nel database.
Proprietà pubblica | Multival | Indica se la combinazione di padri si tratta di un multivalore.
Proprietà pubblica | Ord | Posizione ordinata della dipendenza.
Proprietà pubblica | Parent | Retituisce la cascata di appartenenza.
Proprietà pubblica | StatoRecord | Restituisce o imposta lo stato del record. DI USO INTERNO !!
Proprietà pubblica | ValFiglio | Restituisce o imposta l'oggetto che contiene il valore del figlio e la sua descrizione.
Proprietà pubblica | ValPadre | Restituisce o imposta l'oggetto del valore padre. Può essere un valore (string) in caso di cascata di primo livello, oppure un'altra DedCascadeDependency in caso di cascate figlie.
Torna su
Vedi anche

Documentazione

Classe DedCascadeDependency
Namespace DedNet.Core


Proprietà DedCascadeDependency.ID

Proprietà DedCascadeDependencyID
Restituisce il Guid del record nel database.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Guid ID { get; }
Public ReadOnly Property ID As Guid
    Get
public:
property Guid ID {
    Guid get ();
}
member ID : Guid with get

Valore della proprietà

Guid
Vedi anche

Documentazione

Classe DedCascadeDependency
Namespace DedNet.Core


Proprietà DedCascadeDependency.Multival

Proprietà DedCascadeDependencyMultival
Indica se la combinazione di padri si tratta di un multivalore.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Multival { get; }
Public ReadOnly Property Multival As Boolean
    Get
public:
property bool Multival {
    bool get ();
}
member Multival : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedCascadeDependency
Namespace DedNet.Core


Proprietà DedCascadeDependency.Ord

Proprietà DedCascadeDependencyOrd
Posizione ordinata della dipendenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int Ord { get; }
Public ReadOnly Property Ord As Integer
    Get
public:
property int Ord {
    int get ();
}
member Ord : int with get

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe DedCascadeDependency
Namespace DedNet.Core


Proprietà DedCascadeDependency.Parent

Proprietà DedCascadeDependencyParent
Retituisce la cascata di appartenenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCascade Parent { get; }
Public ReadOnly Property Parent As DedCascade
    Get
public:
property DedCascade^ Parent {
    DedCascade^ get ();
}
member Parent : DedCascade with get

Valore della proprietà

DedCascade
Vedi anche

Documentazione

Classe DedCascadeDependency
Namespace DedNet.Core


Proprietà DedCascadeDependency.StatoRecord

Proprietà DedCascadeDependencyStatoRecord
Restituisce o imposta lo stato del record. DI USO INTERNO !!

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public StatoRecord StatoRecord { get; set; }
Public Property StatoRecord As StatoRecord
    Get
    Set
public:
virtual property StatoRecord^ StatoRecord {
    StatoRecord^ get () sealed;
    void set (StatoRecord^ value) sealed;
}
abstract StatoRecord : StatoRecord with get, set
override StatoRecord : StatoRecord with get, set

Valore della proprietà

StatoRecord

Implementa

IDedDbItemStatoRecord
Vedi anche

Documentazione

Classe DedCascadeDependency
Namespace DedNet.Core


Proprietà DedCascadeDependency.ValFiglio

Proprietà DedCascadeDependencyValFiglio
Restituisce o imposta l'oggetto che contiene il valore del figlio e la sua descrizione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCascadeValue ValFiglio { get; set; }
Public Property ValFiglio As DedCascadeValue
    Get
    Set
public:
property DedCascadeValue^ ValFiglio {
    DedCascadeValue^ get ();
    void set (DedCascadeValue^ value);
}
member ValFiglio : DedCascadeValue with get, set

Valore della proprietà

DedCascadeValue
Vedi anche

Documentazione

Classe DedCascadeDependency
Namespace DedNet.Core


Proprietà DedCascadeDependency.ValPadre

Proprietà DedCascadeDependencyValPadre
Restituisce o imposta l'oggetto del valore padre. Può essere un valore (string) in caso di cascata di primo livello, oppure un'altra DedCascadeDependency in caso di cascate figlie.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object ValPadre { get; set; }
Public Property ValPadre As Object
    Get
    Set
public:
property Object^ ValPadre {
    Object^ get ();
    void set (Object^ value);
}
member ValPadre : Object with get, set

Valore della proprietà

Object
Vedi anche

Documentazione

Classe DedCascadeDependency
Namespace DedNet.Core


Metodi di DedCascadeDependency

Il tipo DedCascadeDependency espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | BeginIgnoreDirty | Attiva l'ignoramento della notifica di Dirty.
Metodo pubblico | Clone | Metodo per clonare la dipendenza.
Metodo pubblico | EndIgnoreDirty | Disattiva l'ignoramento della notifica di Dirty.
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Torna su
Vedi anche

Documentazione

Classe DedCascadeDependency
Namespace DedNet.Core


Metodo DedCascadeDependency.BeginIgnoreDirty

Metodo DedCascadeDependencyBeginIgnoreDirty
Attiva l'ignoramento della notifica di Dirty.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void BeginIgnoreDirty()
Public Sub BeginIgnoreDirty
public:
void BeginIgnoreDirty()
member BeginIgnoreDirty : unit -> unit
Vedi anche

Documentazione

Classe DedCascadeDependency
Namespace DedNet.Core


Metodo DedCascadeDependency.Clone

Metodo DedCascadeDependencyClone
Metodo per clonare la dipendenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCascadeDependency Clone(
    DedCascade parent
)
Public Function Clone (
    parent As DedCascade
) As DedCascadeDependency
public:
DedCascadeDependency^ Clone(
    DedCascade^ parent
)
member Clone :
        parent : DedCascade -> DedCascadeDependency

Parametri

parent DedCascade

Valore di ritorno

DedCascadeDependency
Vedi anche

Documentazione

Classe DedCascadeDependency
Namespace DedNet.Core


Metodo DedCascadeDependency.EndIgnoreDirty

Metodo DedCascadeDependencyEndIgnoreDirty
Disattiva l'ignoramento della notifica di Dirty.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void EndIgnoreDirty()
Public Sub EndIgnoreDirty
public:
void EndIgnoreDirty()
member EndIgnoreDirty : unit -> unit
Vedi anche

Documentazione

Classe DedCascadeDependency
Namespace DedNet.Core


Metodo DedCascadeDependency.Equals

Metodo DedCascadeDependencyEquals

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj Object

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedCascadeDependency
Namespace DedNet.Core


Metodo DedCascadeDependency.GetHashCode

Metodo DedCascadeDependencyGetHashCode

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedCascadeDependency
Namespace DedNet.Core


Metodo DedCascadeDependency.ToString

Metodo DedCascadeDependencyToString

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedCascadeDependency
Namespace DedNet.Core


Classe DedCascadeDictionary
Dizionario di oggetti cascata.
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericDictionary String, DedCascade
DedNet.CoreDedCascadeDictionary

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedCascadeDictionary : Dictionary<string, DedCascade>
Public Class DedCascadeDictionary
    Inherits Dictionary(Of String, DedCascade)
public ref class DedCascadeDictionary : public Dictionary<String^, DedCascade^>
type DedCascadeDictionary =
    class
        inherit Dictionary<string, DedCascade>
    end

Il tipo DedCascadeDictionary espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedCascadeDictionary |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Dirty | Indica se almeno una delle cascate nel dizionario è dirty.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Clone | Metodo che clona il dizionario.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedCascadeDictionary

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCascadeDictionary()
Public Sub New
public:
DedCascadeDictionary()
new : unit -> DedCascadeDictionary
Vedi anche

Documentazione

Classe DedCascadeDictionary
Namespace DedNet.Core


Proprietà di DedCascadeDictionary

Il tipo DedCascadeDictionary espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Dirty | Indica se almeno una delle cascate nel dizionario è dirty.
Torna su
Vedi anche

Documentazione

Classe DedCascadeDictionary
Namespace DedNet.Core


Proprietà DedCascadeDictionary.Dirty

Proprietà DedCascadeDictionaryDirty
Indica se almeno una delle cascate nel dizionario è dirty.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Dirty { get; }
Public ReadOnly Property Dirty As Boolean
    Get
public:
property bool Dirty {
    bool get ();
}
member Dirty : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedCascadeDictionary
Namespace DedNet.Core


Metodi di DedCascadeDictionary

Il tipo DedCascadeDictionary espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Clone | Metodo che clona il dizionario.
Torna su
Vedi anche

Documentazione

Classe DedCascadeDictionary
Namespace DedNet.Core


Metodo DedCascadeDictionary.Clone

Metodo DedCascadeDictionaryClone
Metodo che clona il dizionario.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCascadeDictionary Clone()
Public Function Clone As DedCascadeDictionary
public:
DedCascadeDictionary^ Clone()
member Clone : unit -> DedCascadeDictionary

Valore di ritorno

DedCascadeDictionary
Vedi anche

Documentazione

Classe DedCascadeDictionary
Namespace DedNet.Core


Classe DedCascadeList
Lista di oggetti cascata.
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList DedCascade
DedNet.CoreDedCascadeList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedCascadeList : List<DedCascade>
Public Class DedCascadeList
    Inherits List(Of DedCascade)
public ref class DedCascadeList : public List<DedCascade^>
type DedCascadeList =
    class
        inherit List<DedCascade>
    end

Il tipo DedCascadeList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedCascadeList |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | GetCascadeFromName | Ritorna la cascata che ha come figlio il nome passato.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedCascadeList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCascadeList()
Public Sub New
public:
DedCascadeList()
new : unit -> DedCascadeList
Vedi anche

Documentazione

Classe DedCascadeList
Namespace DedNet.Core


Metodi di DedCascadeList

Il tipo DedCascadeList espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | GetCascadeFromName | Ritorna la cascata che ha come figlio il nome passato.
Torna su
Vedi anche

Documentazione

Classe DedCascadeList
Namespace DedNet.Core


Metodo DedCascadeList.GetCascadeFromName

Metodo DedCascadeListGetCascadeFromName
Ritorna la cascata che ha come figlio il nome passato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCascade GetCascadeFromName(
    string nome
)
Public Function GetCascadeFromName (
    nome As String
) As DedCascade
public:
DedCascade^ GetCascadeFromName(
    String^ nome
)
member GetCascadeFromName :
        nome : string -> DedCascade

Parametri

nome String

Valore di ritorno

DedCascade
Vedi anche

Documentazione

Classe DedCascadeList
Namespace DedNet.Core


Classe DedCascadeManager
Classe Manager per gestire le cascate.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedCascadeManager

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedCascadeManager
Public Class DedCascadeManager
public ref class DedCascadeManager
type DedCascadeManager = class end

Il tipo DedCascadeManager espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Dirty | Restitusice se la struttura delle liste att sia o meno da salvare.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AddCascadeToDictionary | Aggiunge la cascata passata al dizionario.
Metodo pubblico | DeleteCascade | Elimina la cascata passata dal dizionario (se presente).
Metodo pubblico | DeleteCascadeFiglie | Elimina le cascate figlie.
Metodo pubblico | GetAllDbPaths | Ritorna la lista di tutti i dbpath contenuti nel dizionario.
Metodo pubblico | GetAllPadri | Ritorna la lista di tutti i padri.
Metodo pubblico | GetCascade | Ritorna la cascata corrispondente ai valori passati. Se la cascata non esiste, viene creata e poi ritornata. Se si passa una lista di padri null, non la crea.
Metodo pubblico | GetCascadeFiglie | Ritorna tutte le cascate che hanno come parent la cascata passata.
Metodo pubblico | GetDbPathDictionary | Ritorna il dizionario corrispondente al DbPath passato.
Metodo pubblico | GetEveryCascadeInDbPath | Ritorna una lista contenente tutte le cascate presenti nel DbPath selezionato.
Metodo pubblico | GetFigliFromDbPath | Ritorna tutti i figli contenuti nel dbpath passato.
Metodo pubblico | GetPadriFromDbPath | Restituisce la lista di tutti i padri unici presenti nel dbpath passato.
Metodo pubblico | Save | Salva tutta la struttura delle cascate.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di DedCascadeManager

Il tipo DedCascadeManager espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Dirty | Restitusice se la struttura delle liste att sia o meno da salvare.
Torna su
Vedi anche

Documentazione

Classe DedCascadeManager
Namespace DedNet.Core


Proprietà DedCascadeManager.Dirty

Proprietà DedCascadeManagerDirty
Restitusice se la struttura delle liste att sia o meno da salvare.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Dirty { get; }
Public ReadOnly Property Dirty As Boolean
    Get
public:
property bool Dirty {
    bool get ();
}
member Dirty : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedCascadeManager
Namespace DedNet.Core


Metodi di DedCascadeManager

Il tipo DedCascadeManager espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AddCascadeToDictionary | Aggiunge la cascata passata al dizionario.
Metodo pubblico | DeleteCascade | Elimina la cascata passata dal dizionario (se presente).
Metodo pubblico | DeleteCascadeFiglie | Elimina le cascate figlie.
Metodo pubblico | GetAllDbPaths | Ritorna la lista di tutti i dbpath contenuti nel dizionario.
Metodo pubblico | GetAllPadri | Ritorna la lista di tutti i padri.
Metodo pubblico | GetCascade | Ritorna la cascata corrispondente ai valori passati. Se la cascata non esiste, viene creata e poi ritornata. Se si passa una lista di padri null, non la crea.
Metodo pubblico | GetCascadeFiglie | Ritorna tutte le cascate che hanno come parent la cascata passata.
Metodo pubblico | GetDbPathDictionary | Ritorna il dizionario corrispondente al DbPath passato.
Metodo pubblico | GetEveryCascadeInDbPath | Ritorna una lista contenente tutte le cascate presenti nel DbPath selezionato.
Metodo pubblico | GetFigliFromDbPath | Ritorna tutti i figli contenuti nel dbpath passato.
Metodo pubblico | GetPadriFromDbPath | Restituisce la lista di tutti i padri unici presenti nel dbpath passato.
Metodo pubblico | Save | Salva tutta la struttura delle cascate.
Torna su
Vedi anche

Documentazione

Classe DedCascadeManager
Namespace DedNet.Core


Metodo DedCascadeManager.AddCascadeToDictionary

Metodo DedCascadeManagerAddCascadeToDictionary
Aggiunge la cascata passata al dizionario.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddCascadeToDictionary(
    DedCascade cascade
)
Public Sub AddCascadeToDictionary (
    cascade As DedCascade
)
public:
void AddCascadeToDictionary(
    DedCascade^ cascade
)
member AddCascadeToDictionary :
        cascade : DedCascade -> unit

Parametri

cascade DedCascade
Cascata da aggiungere.
Vedi anche

Documentazione

Classe DedCascadeManager
Namespace DedNet.Core


Metodo DedCascadeManager.DeleteCascade

Metodo DedCascadeManagerDeleteCascade
Elimina la cascata passata dal dizionario (se presente).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool DeleteCascade(
    DedCascade toRemove,
    bool removeFiglie = true,
    DedType type = null
)
Public Function DeleteCascade (
    toRemove As DedCascade,
    Optional removeFiglie As Boolean = true,
    Optional type As DedType = Nothing
) As Boolean
public:
bool DeleteCascade(
    DedCascade^ toRemove,
    bool removeFiglie = true,
    DedType^ type = nullptr
)
member DeleteCascade :
        toRemove : DedCascade *
        ?removeFiglie : bool *
        ?type : DedType
(* Defaults:
        let _removeFiglie = defaultArg removeFiglie true
        let _type = defaultArg type null
*)
-> bool

Parametri

toRemove DedCascade
Cascata da eliminare.
removeFiglie Boolean (Optional)
Indica se rimuovere eventuali cascate figlie.
type DedType (Optional)
Se passato, rimuove la cascate anche dalla famiglia.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedCascadeManager
Namespace DedNet.Core


Metodo DedCascadeManager.DeleteCascadeFiglie

Metodo DedCascadeManagerDeleteCascadeFiglie
Elimina le cascate figlie.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void DeleteCascadeFiglie(
    DedCascade padre,
    bool remove = true,
    DedType type = null
)
Public Sub DeleteCascadeFiglie (
    padre As DedCascade,
    Optional remove As Boolean = true,
    Optional type As DedType = Nothing
)
public:
void DeleteCascadeFiglie(
    DedCascade^ padre,
    bool remove = true,
    DedType^ type = nullptr
)
member DeleteCascadeFiglie :
        padre : DedCascade *
        ?remove : bool *
        ?type : DedType
(* Defaults:
        let _remove = defaultArg remove true
        let _type = defaultArg type null
*)
-> unit

Parametri

padre DedCascade
Cascata padre.
remove Boolean (Optional)
Indica se rimuovere l'intera cascata o solo aggiornare le dipendenze.
type DedType (Optional)
Famiglia di appartenenza.
Vedi anche

Documentazione

Classe DedCascadeManager
Namespace DedNet.Core


Metodo DedCascadeManager.GetAllDbPaths

Metodo DedCascadeManagerGetAllDbPaths
Ritorna la lista di tutti i dbpath contenuti nel dizionario.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string[] GetAllDbPaths()
Public Function GetAllDbPaths As String()
public:
array<String^>^ GetAllDbPaths()
member GetAllDbPaths : unit -> string[]

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedCascadeManager
Namespace DedNet.Core


Metodo DedCascadeManager.GetAllPadri

Metodo DedCascadeManagerGetAllPadri
Ritorna la lista di tutti i padri.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string[] GetAllPadri()
Public Function GetAllPadri As String()
public:
array<String^>^ GetAllPadri()
member GetAllPadri : unit -> string[]

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedCascadeManager
Namespace DedNet.Core


Metodo DedCascadeManager.GetCascade

Metodo DedCascadeManagerGetCascade
Ritorna la cascata corrispondente ai valori passati. Se la cascata non esiste, viene creata e poi ritornata. Se si passa una lista di padri null, non la crea.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCascade GetCascade(
    string dbPath,
    string nomeFiglio,
    List<string> nomiPadri
)
Public Function GetCascade (
    dbPath As String,
    nomeFiglio As String,
    nomiPadri As List(Of String)
) As DedCascade
public:
DedCascade^ GetCascade(
    String^ dbPath,
    String^ nomeFiglio,
    List<String^>^ nomiPadri
)
member GetCascade :
        dbPath : string *
        nomeFiglio : string *
        nomiPadri : List<string> -> DedCascade

Parametri

dbPath String
nomeFiglio String
nomiPadri List String

Valore di ritorno

DedCascade
Vedi anche

Documentazione

Classe DedCascadeManager
Namespace DedNet.Core


Metodo DedCascadeManager.GetCascadeFiglie

Metodo DedCascadeManagerGetCascadeFiglie
Ritorna tutte le cascate che hanno come parent la cascata passata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCascadeList GetCascadeFiglie(
    DedCascade parent
)
Public Function GetCascadeFiglie (
    parent As DedCascade
) As DedCascadeList
public:
DedCascadeList^ GetCascadeFiglie(
    DedCascade^ parent
)
member GetCascadeFiglie :
        parent : DedCascade -> DedCascadeList

Parametri

parent DedCascade
Cascata parent.

Valore di ritorno

DedCascadeList
Vedi anche

Documentazione

Classe DedCascadeManager
Namespace DedNet.Core


Metodo DedCascadeManager.GetDbPathDictionary

Metodo DedCascadeManagerGetDbPathDictionary
Ritorna il dizionario corrispondente al DbPath passato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCascadeDictionary GetDbPathDictionary(
    string dbPath
)
Public Function GetDbPathDictionary (
    dbPath As String
) As DedCascadeDictionary
public:
DedCascadeDictionary^ GetDbPathDictionary(
    String^ dbPath
)
member GetDbPathDictionary :
        dbPath : string -> DedCascadeDictionary

Parametri

dbPath String
DbPath.

Valore di ritorno

DedCascadeDictionary
Vedi anche

Documentazione

Classe DedCascadeManager
Namespace DedNet.Core


Metodo DedCascadeManager.GetEveryCascadeInDbPath

Metodo DedCascadeManagerGetEveryCascadeInDbPath
Ritorna una lista contenente tutte le cascate presenti nel DbPath selezionato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCascadeList GetEveryCascadeInDbPath(
    string dbPath
)
Public Function GetEveryCascadeInDbPath (
    dbPath As String
) As DedCascadeList
public:
DedCascadeList^ GetEveryCascadeInDbPath(
    String^ dbPath
)
member GetEveryCascadeInDbPath :
        dbPath : string -> DedCascadeList

Parametri

dbPath String
DbPath.

Valore di ritorno

DedCascadeList
Vedi anche

Documentazione

Classe DedCascadeManager
Namespace DedNet.Core


Metodo DedCascadeManager.GetFigliFromDbPath

Metodo DedCascadeManagerGetFigliFromDbPath
Ritorna tutti i figli contenuti nel dbpath passato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string[] GetFigliFromDbPath(
    string dbPath
)
Public Function GetFigliFromDbPath (
    dbPath As String
) As String()
public:
array<String^>^ GetFigliFromDbPath(
    String^ dbPath
)
member GetFigliFromDbPath :
        dbPath : string -> string[]

Parametri

dbPath String
DbPath di cui cercare i figli.

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedCascadeManager
Namespace DedNet.Core


Metodo DedCascadeManager.GetPadriFromDbPath

Metodo DedCascadeManagerGetPadriFromDbPath
Restituisce la lista di tutti i padri unici presenti nel dbpath passato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string[] GetPadriFromDbPath(
    string dbPath
)
Public Function GetPadriFromDbPath (
    dbPath As String
) As String()
public:
array<String^>^ GetPadriFromDbPath(
    String^ dbPath
)
member GetPadriFromDbPath :
        dbPath : string -> string[]

Parametri

dbPath String
DbPath di cui cercare i padri.

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedCascadeManager
Namespace DedNet.Core


Metodo DedCascadeManager.Save

Metodo DedCascadeManagerSave
Salva tutta la struttura delle cascate.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Save()
Public Sub Save
public:
void Save()
member Save : unit -> unit
Vedi anche

Documentazione

Classe DedCascadeManager
Namespace DedNet.Core


Classe DedCascadeValue
Classe che descrive un valore della cascata con la sua descrizione.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedCascadeValue

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class DedCascadeValue
<SerializableAttribute>
Public Class DedCascadeValue
[SerializableAttribute]
public ref class DedCascadeValue
[<SerializableAttribute>]
type DedCascadeValue = class end

Il tipo DedCascadeValue espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedCascadeValue(DedCascadeDependency, Object) | Costruttore unico.
Metodo pubblico | DedCascadeValue(DedCascadeDependency, Object, String) | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Descrizione | Restituisce o imposta la descrizione del valore.
Proprietà pubblica | Parent | Restituisce la dipendenza di cui fa parte il valore.
Proprietà pubblica | Valore | Restituisce o imposta il valore.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Clone | Metodo che clona il DedCascadeValue.
Metodo pubblico | CopyToClipboard | Metodo che copia nella clipboard il DedCascadeValue.
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
 | GetFromClipboard | Metodo che ritorna il DedCascadeValue salvato nella clipboard.
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedCascadeValue
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | DedCascadeValue(DedCascadeDependency, Object) | Costruttore unico.
Metodo pubblico | DedCascadeValue(DedCascadeDependency, Object, String) | Costruttore unico.
Torna su
Vedi anche

Documentazione

Classe DedCascadeValue
Namespace DedNet.Core


Costruttore DedCascadeValue(DedCascadeDependency, Object)
Costruttore unico.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCascadeValue(
    DedCascadeDependency parent,
    Object value
)
Public Sub New (
    parent As DedCascadeDependency,
    value As Object
)
public:
DedCascadeValue(
    DedCascadeDependency^ parent,
    Object^ value
)
new :
        parent : DedCascadeDependency *
        value : Object -> DedCascadeValue

Parametri

parent DedCascadeDependency
Dipendenza di appartenenza.
value Object
Valore.
Vedi anche

Documentazione

Classe DedCascadeValue
Overload di DedCascadeValue
Namespace DedNet.Core


Costruttore DedCascadeValue(DedCascadeDependency, Object, String)
Costruttore unico.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCascadeValue(
    DedCascadeDependency parent,
    Object value,
    string description
)
Public Sub New (
    parent As DedCascadeDependency,
    value As Object,
    description As String
)
public:
DedCascadeValue(
    DedCascadeDependency^ parent,
    Object^ value,
    String^ description
)
new :
        parent : DedCascadeDependency *
        value : Object *
        description : string -> DedCascadeValue

Parametri

parent DedCascadeDependency
Dipendenza di appartenenza.
value Object
Valore.
description String
Descrizione del valore.
Vedi anche

Documentazione

Classe DedCascadeValue
Overload di DedCascadeValue
Namespace DedNet.Core


Proprietà di DedCascadeValue

Il tipo DedCascadeValue espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Descrizione | Restituisce o imposta la descrizione del valore.
Proprietà pubblica | Parent | Restituisce la dipendenza di cui fa parte il valore.
Proprietà pubblica | Valore | Restituisce o imposta il valore.
Torna su
Vedi anche

Documentazione

Classe DedCascadeValue
Namespace DedNet.Core


Proprietà DedCascadeValue.Descrizione

Proprietà DedCascadeValueDescrizione
Restituisce o imposta la descrizione del valore.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Descrizione { get; set; }
Public Property Descrizione As String
    Get
    Set
public:
property String^ Descrizione {
    String^ get ();
    void set (String^ value);
}
member Descrizione : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedCascadeValue
Namespace DedNet.Core


Proprietà DedCascadeValue.Parent

Proprietà DedCascadeValueParent
Restituisce la dipendenza di cui fa parte il valore.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCascadeDependency Parent { get; }
Public ReadOnly Property Parent As DedCascadeDependency
    Get
public:
property DedCascadeDependency^ Parent {
    DedCascadeDependency^ get ();
}
member Parent : DedCascadeDependency with get

Valore della proprietà

DedCascadeDependency
Vedi anche

Documentazione

Classe DedCascadeValue
Namespace DedNet.Core


Proprietà DedCascadeValue.Valore

Proprietà DedCascadeValueValore
Restituisce o imposta il valore.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object Valore { get; set; }
Public Property Valore As Object
    Get
    Set
public:
property Object^ Valore {
    Object^ get ();
    void set (Object^ value);
}
member Valore : Object with get, set

Valore della proprietà

Object
Vedi anche

Documentazione

Classe DedCascadeValue
Namespace DedNet.Core


Metodi di DedCascadeValue

Il tipo DedCascadeValue espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Clone | Metodo che clona il DedCascadeValue.
Metodo pubblico | CopyToClipboard | Metodo che copia nella clipboard il DedCascadeValue.
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
 | GetFromClipboard | Metodo che ritorna il DedCascadeValue salvato nella clipboard.
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Torna su
Vedi anche

Documentazione

Classe DedCascadeValue
Namespace DedNet.Core


Metodo DedCascadeValue.Clone

Metodo DedCascadeValueClone
Metodo che clona il DedCascadeValue.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCascadeValue Clone()
Public Function Clone As DedCascadeValue
public:
DedCascadeValue^ Clone()
member Clone : unit -> DedCascadeValue

Valore di ritorno

DedCascadeValue
Vedi anche

Documentazione

Classe DedCascadeValue
Namespace DedNet.Core


Metodo DedCascadeValue.CopyToClipboard

Metodo DedCascadeValueCopyToClipboard
Metodo che copia nella clipboard il DedCascadeValue.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void CopyToClipboard()
Public Sub CopyToClipboard
public:
void CopyToClipboard()
member CopyToClipboard : unit -> unit
Vedi anche

Documentazione

Classe DedCascadeValue
Namespace DedNet.Core


Metodo DedCascadeValue.Equals

Metodo DedCascadeValueEquals

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj Object

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedCascadeValue
Namespace DedNet.Core


Metodo DedCascadeValue.GetFromClipboard

Metodo DedCascadeValueGetFromClipboard
Metodo che ritorna il DedCascadeValue salvato nella clipboard.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static DedCascadeValue GetFromClipboard()
Public Shared Function GetFromClipboard As DedCascadeValue
public:
static DedCascadeValue^ GetFromClipboard()
static member GetFromClipboard : unit -> DedCascadeValue

Valore di ritorno

DedCascadeValue
Vedi anche

Documentazione

Classe DedCascadeValue
Namespace DedNet.Core


Metodo DedCascadeValue.GetHashCode

Metodo DedCascadeValueGetHashCode

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedCascadeValue
Namespace DedNet.Core


Metodo DedCascadeValue.ToString

Metodo DedCascadeValueToString

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedCascadeValue
Namespace DedNet.Core


Classe DedCascadeValueList
Lista di DedCascadeValue.
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList DedCascadeValue
DedNet.CoreDedCascadeValueList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class DedCascadeValueList : List<DedCascadeValue>
<SerializableAttribute>
Public Class DedCascadeValueList
    Inherits List(Of DedCascadeValue)
[SerializableAttribute]
public ref class DedCascadeValueList : public List<DedCascadeValue^>
[<SerializableAttribute>]
type DedCascadeValueList =
    class
        inherit List<DedCascadeValue>
    end

Il tipo DedCascadeValueList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedCascadeValueList |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | CopyToClipboard | Metodo che copia nella clipboard la lista di valori.
 | GetFromClipboard | Metodo che restituisce la lista di valori copiata nella clipboard.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedCascadeValueList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCascadeValueList()
Public Sub New
public:
DedCascadeValueList()
new : unit -> DedCascadeValueList
Vedi anche

Documentazione

Classe DedCascadeValueList
Namespace DedNet.Core


Metodi di DedCascadeValueList

Il tipo DedCascadeValueList espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | CopyToClipboard | Metodo che copia nella clipboard la lista di valori.
 | GetFromClipboard | Metodo che restituisce la lista di valori copiata nella clipboard.
Torna su
Vedi anche

Documentazione

Classe DedCascadeValueList
Namespace DedNet.Core


Metodo DedCascadeValueList.CopyToClipboard

Metodo DedCascadeValueListCopyToClipboard
Metodo che copia nella clipboard la lista di valori.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void CopyToClipboard()
Public Sub CopyToClipboard
public:
void CopyToClipboard()
member CopyToClipboard : unit -> unit
Vedi anche

Documentazione

Classe DedCascadeValueList
Namespace DedNet.Core


Metodo DedCascadeValueList.GetFromClipboard

Metodo DedCascadeValueListGetFromClipboard
Metodo che restituisce la lista di valori copiata nella clipboard.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static DedCascadeValueList GetFromClipboard()
Public Shared Function GetFromClipboard As DedCascadeValueList
public:
static DedCascadeValueList^ GetFromClipboard()
static member GetFromClipboard : unit -> DedCascadeValueList

Valore di ritorno

DedCascadeValueList
Vedi anche

Documentazione

Classe DedCascadeValueList
Namespace DedNet.Core


Classe DedCateg
Classe che descrive una categoria attributo.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedCateg

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedCateg : IDedDbItem
Public Class DedCateg
    Implements IDedDbItem
public ref class DedCateg : IDedDbItem
type DedCateg =
    class
        interface IDedDbItem
    end

Il tipo DedCateg espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedCateg | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Descrizione | Descrizione della categoria.
Proprietà pubblica | ID | GUID della categoria.
Proprietà pubblica | Nome | Nome della categoria.
Proprietà pubblica | Parent | Collezione a cui appartiene la categoria.
Proprietà pubblica | Pos | Posizione della categoria.
Proprietà pubblica | StatoRecord | Restituisce o imposta lo stato del record. DI USO INTERNO !!
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Clone | Metodo per clonare l'attributo.
Metodo pubblico | Clone(DedCategCollection) | Metodo per clonare l'attributo.
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedCateg
Costruttore unico.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCateg(
    DedCategCollection parent,
    Guid id,
    string nome,
    string desc,
    int pos
)
Public Sub New (
    parent As DedCategCollection,
    id As Guid,
    nome As String,
    desc As String,
    pos As Integer
)
public:
DedCateg(
    DedCategCollection^ parent,
    Guid id,
    String^ nome,
    String^ desc,
    int pos
)
new :
        parent : DedCategCollection *
        id : Guid *
        nome : string *
        desc : string *
        pos : int -> DedCateg

Parametri

parent DedCategCollection
Collezione a cui appartiene la categoria.
id Guid
GUID della categoria.
nome String
Nome della categoria.
desc String
Descrizione della categoria.
pos Int32
Posizione della categoria.
Vedi anche

Documentazione

Classe DedCateg
Namespace DedNet.Core


Proprietà di DedCateg

Il tipo DedCateg espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Descrizione | Descrizione della categoria.
Proprietà pubblica | ID | GUID della categoria.
Proprietà pubblica | Nome | Nome della categoria.
Proprietà pubblica | Parent | Collezione a cui appartiene la categoria.
Proprietà pubblica | Pos | Posizione della categoria.
Proprietà pubblica | StatoRecord | Restituisce o imposta lo stato del record. DI USO INTERNO !!
Torna su
Vedi anche

Documentazione

Classe DedCateg
Namespace DedNet.Core


Proprietà DedCateg.Descrizione

Proprietà DedCategDescrizione
Descrizione della categoria.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Descrizione { get; set; }
Public Property Descrizione As String
    Get
    Set
public:
property String^ Descrizione {
    String^ get ();
    void set (String^ value);
}
member Descrizione : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedCateg
Namespace DedNet.Core


Proprietà DedCateg.ID

Proprietà DedCategID
GUID della categoria.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Guid ID { get; set; }
Public Property ID As Guid
    Get
    Set
public:
property Guid ID {
    Guid get ();
    void set (Guid value);
}
member ID : Guid with get, set

Valore della proprietà

Guid
Vedi anche

Documentazione

Classe DedCateg
Namespace DedNet.Core


Proprietà DedCateg.Nome

Proprietà DedCategNome
Nome della categoria.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Nome { get; set; }
Public Property Nome As String
    Get
    Set
public:
property String^ Nome {
    String^ get ();
    void set (String^ value);
}
member Nome : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedCateg
Namespace DedNet.Core


Proprietà DedCateg.Parent

Proprietà DedCategParent
Collezione a cui appartiene la categoria.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCategCollection Parent { get; }
Public ReadOnly Property Parent As DedCategCollection
    Get
public:
property DedCategCollection^ Parent {
    DedCategCollection^ get ();
}
member Parent : DedCategCollection with get

Valore della proprietà

DedCategCollection
Vedi anche

Documentazione

Classe DedCateg
Namespace DedNet.Core


Proprietà DedCateg.Pos

Proprietà DedCategPos
Posizione della categoria.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int Pos { get; set; }
Public Property Pos As Integer
    Get
    Set
public:
property int Pos {
    int get ();
    void set (int value);
}
member Pos : int with get, set

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe DedCateg
Namespace DedNet.Core


Proprietà DedCateg.StatoRecord

Proprietà DedCategStatoRecord
Restituisce o imposta lo stato del record. DI USO INTERNO !!

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public StatoRecord StatoRecord { get; set; }
Public Property StatoRecord As StatoRecord
    Get
    Set
public:
virtual property StatoRecord^ StatoRecord {
    StatoRecord^ get () sealed;
    void set (StatoRecord^ value) sealed;
}
abstract StatoRecord : StatoRecord with get, set
override StatoRecord : StatoRecord with get, set

Valore della proprietà

StatoRecord

Implementa

IDedDbItemStatoRecord
Vedi anche

Documentazione

Classe DedCateg
Namespace DedNet.Core


Metodi di DedCateg

Il tipo DedCateg espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Clone | Metodo per clonare l'attributo.
Metodo pubblico | Clone(DedCategCollection) | Metodo per clonare l'attributo.
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Torna su
Vedi anche

Documentazione

Classe DedCateg
Namespace DedNet.Core


Metodo DedCateg.Clone

Metodo DedCategClone
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Clone | Metodo per clonare l'attributo.
Metodo pubblico | Clone(DedCategCollection) | Metodo per clonare l'attributo.
Torna su
Vedi anche

Documentazione

Classe DedCateg
Namespace DedNet.Core


Metodo DedCateg.Clone

Metodo DedCategClone
Metodo per clonare l'attributo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCateg Clone()
Public Function Clone As DedCateg
public:
DedCateg^ Clone()
member Clone : unit -> DedCateg

Valore di ritorno

DedCateg
Vedi anche

Documentazione

Classe DedCateg
Overload di Clone
Namespace DedNet.Core


Metodo DedCateg.Clone(DedCategCollection)

Metodo DedCategClone(DedCategCollection)
Metodo per clonare l'attributo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCateg Clone(
    DedCategCollection parent
)
Public Function Clone (
    parent As DedCategCollection
) As DedCateg
public:
DedCateg^ Clone(
    DedCategCollection^ parent
)
member Clone :
        parent : DedCategCollection -> DedCateg

Parametri

parent DedCategCollection

Valore di ritorno

DedCateg
Vedi anche

Documentazione

Classe DedCateg
Overload di Clone
Namespace DedNet.Core


Metodo DedCateg.Equals

Metodo DedCategEquals

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj Object

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedCateg
Namespace DedNet.Core


Metodo DedCateg.GetHashCode

Metodo DedCategGetHashCode

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedCateg
Namespace DedNet.Core


Metodo DedCateg.ToString

Metodo DedCategToString

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedCateg
Namespace DedNet.Core


Classe DedCategCollection
Collezione di categorie.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedDbCollectionBase DedCateg
DedNet.CoreDedCategCollection

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedCategCollection : DedDbCollectionBase<DedCateg>
Public Class DedCategCollection
    Inherits DedDbCollectionBase(Of DedCateg)
public ref class DedCategCollection : public DedDbCollectionBase<DedCateg^>
type DedCategCollection =
    class
        inherit DedDbCollectionBase<DedCateg>
    end

Il tipo DedCategCollection espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedCategCollection | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllowsDuplicates | Restituisce se siano ammessi duplicati all'interno della lista. Se false viene sollevata una eccezione su tentativo di inserimento duplicati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Application | Restituisce l'oggetto applicazione di appartenza. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Count | Restituisce il numero di elementi presenti. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Dirty | Restituisce se la collezione o uno dei suoi elementi sia stata modificata. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | ErasedItems | Restitusice la lista in sola lettura degli elementi che risultano attualmente cancellati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | LastItem | Restituisce l'ultimo elemento della collezione oppure null se non ci sono elementi. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | RestoreErased | Restituisce se gli elementi cancellati devono essere ripristinati in caso vengano riaggiunti. (Ereditato da DedDbCollectionBaseT)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Add(DedCateg) | Aggiunge alla collezione un elemento già esistente. Gli imposta già come padre la nuova collezione.
Metodo pubblico | Add(Guid, String, String) | Aggiunge un elemento accodandolo alla collezione.
Metodo protetto | AddForClone | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto SENZA MODIFICARNE LO STATO. Le classi derivate potranno utilizzare questo metodo per clonare la collezione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddNewElement | DI USO INTERNO. Aggiunge un elemento alla lista rendendo dirty l'oggetto. L'elemento viene aggiunto con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere un elemento alla lista. Dovranno loro stesse avere un metodo pubblico Add() che prenda i parametri necessari alla costruzione dell'oggetto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddRangeNewElement | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi rendendo dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere più elementi alla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddUnModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Clear | Elimina tutti gli elementi dalla lista. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | ClearRefresh | Svuota la lista impostando Dirty = false. Di fatto permette di effettuare un refresh della lista e quindi di ricaricarla. Serve per svuotare la lista e reinizializzarla da capo.
Metodo pubblico | Clone | Metodo per clonare la collezione di categorie.
Metodo pubblico | Contains | Verifica l'esistenza di un valore all'interno della lista degli elementi. Le classi derivate devono effettuarne l'override nel caso in cui l'elemento non implementi GetHashCode() per l'uso all'interno dei dizionarii. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | CopyTo | Copia un range di elementi in un array. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | CreateDeleteCommand | Crea, inizializza e restituisce il comando per l'eliminazione di un elemento. (Sovrascrive DedDbCollectionBaseTCreateDeleteCommand(T))
Metodo protetto | CreateInsertCommand | Crea, inizializza e restituisce il comando per l'inserimento di un elemento. (Sovrascrive DedDbCollectionBaseTCreateInsertCommand(T))
Metodo protetto | CreateUpdateCommand | Crea, inizializza e restituisce il comando per l'aggiornamento di un elemento. (Sovrascrive DedDbCollectionBaseTCreateUpdateCommand(T))
Metodo pubblico | CustomSort | Ordina la lista e mette a posto gli indici di Pos per rendere dirty gli oggetti. (Sovrascrive DedDbCollectionBaseTCustomSort(IComparerT))
Metodo protetto | ExecuteDeleteItem | Esegue l'eliminazione di un elemento. Crea il comando tramite il metodo CreateDeleteCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteInsertItem | Esegue l'inserimento di un elemento. Crea il comando tramite il metodo CreateInsertCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteUpdateItem | Esegue l'aggiornamento di un elemento. Crea il comando tramite il metodo CreateUpdateCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Find | Restituisce l'oggetto cercato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FindAll | Restitusice la lista degli elementi che corrispondono al predicato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | GetDbIndex | Restituisce l'indice dell'elemento passato: cioè il GUID della categoria. (Sovrascrive DedDbCollectionBaseTGetDbIndex(T))
Metodo pubblico | GetEnumerator | Restituisce l'enumeratore della collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | IndexOf | Restituisce l'indice dell'elemento richiesto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InsertUnModified | DI USO INTERNO. Inserisce un elemento alla lista senza rendere dirty l'oggetto, all'indice specificato. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Item | Restituisce l'elemento iesimo della lista. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean) | Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi. (Sovrascrive DedDbCollectionBaseTMove(Int32, Boolean))
Metodo pubblico | Move(Int32, Boolean, Int32) | Sposta l'elemento dell'indice passato prima o dopo del numero di posizioni passate. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSave | Metodo Template chiamato dopo il salvataggio avvenuto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSaveNoChanges | Metodo Template chiamato dopo il salvataggio senza modifiche. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnBeforeSave | Metodo Template chiamato prima del salvataggio. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(T) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(DedEditableObjectT) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(T) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(DedEditableObjectT) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ReInitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Remove | Elimina un elemento dalla collezione. (Sovrascrive DedDbCollectionBaseTRemove(T))
Metodo pubblico | Ripristina | Verifica che l'elemento sia presente negli eliminati e lo toglie da lì e lo riaggiunge in coda alla lista degli elementi validi. Solleva una eccezione se l'elemento è già presente nella lista e AllowsDuplicates = false. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Save | Salva l'oggetto con tutta la sua lista, solo se questo risulta dirty. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | SilentSort | Ordina la lista senza modificare il valore di Pos, quindi non rendendo l'oggetto dirty.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedCategCollection
Costruttore unico.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCategCollection(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedCategCollection(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedCategCollection

Parametri

app DedNetApplication
Applicazione DedNet.
Vedi anche

Documentazione

Classe DedCategCollection
Namespace DedNet.Core


Proprietà di DedCategCollection

Il tipo DedCategCollection espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllowsDuplicates | Restituisce se siano ammessi duplicati all'interno della lista. Se false viene sollevata una eccezione su tentativo di inserimento duplicati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Application | Restituisce l'oggetto applicazione di appartenza. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Count | Restituisce il numero di elementi presenti. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Dirty | Restituisce se la collezione o uno dei suoi elementi sia stata modificata. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | ErasedItems | Restitusice la lista in sola lettura degli elementi che risultano attualmente cancellati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | LastItem | Restituisce l'ultimo elemento della collezione oppure null se non ci sono elementi. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | RestoreErased | Restituisce se gli elementi cancellati devono essere ripristinati in caso vengano riaggiunti. (Ereditato da DedDbCollectionBaseT)
Torna su
Vedi anche

Documentazione

Classe DedCategCollection
Namespace DedNet.Core


Metodi di DedCategCollection

Il tipo DedCategCollection espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Add(DedCateg) | Aggiunge alla collezione un elemento già esistente. Gli imposta già come padre la nuova collezione.
Metodo pubblico | Add(Guid, String, String) | Aggiunge un elemento accodandolo alla collezione.
Metodo protetto | AddForClone | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto SENZA MODIFICARNE LO STATO. Le classi derivate potranno utilizzare questo metodo per clonare la collezione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddNewElement | DI USO INTERNO. Aggiunge un elemento alla lista rendendo dirty l'oggetto. L'elemento viene aggiunto con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere un elemento alla lista. Dovranno loro stesse avere un metodo pubblico Add() che prenda i parametri necessari alla costruzione dell'oggetto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddRangeNewElement | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi rendendo dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere più elementi alla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddUnModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Clear | Elimina tutti gli elementi dalla lista. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | ClearRefresh | Svuota la lista impostando Dirty = false. Di fatto permette di effettuare un refresh della lista e quindi di ricaricarla. Serve per svuotare la lista e reinizializzarla da capo.
Metodo pubblico | Clone | Metodo per clonare la collezione di categorie.
Metodo pubblico | Contains | Verifica l'esistenza di un valore all'interno della lista degli elementi. Le classi derivate devono effettuarne l'override nel caso in cui l'elemento non implementi GetHashCode() per l'uso all'interno dei dizionarii. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | CopyTo | Copia un range di elementi in un array. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | CreateDeleteCommand | Crea, inizializza e restituisce il comando per l'eliminazione di un elemento. (Sovrascrive DedDbCollectionBaseTCreateDeleteCommand(T))
Metodo protetto | CreateInsertCommand | Crea, inizializza e restituisce il comando per l'inserimento di un elemento. (Sovrascrive DedDbCollectionBaseTCreateInsertCommand(T))
Metodo protetto | CreateUpdateCommand | Crea, inizializza e restituisce il comando per l'aggiornamento di un elemento. (Sovrascrive DedDbCollectionBaseTCreateUpdateCommand(T))
Metodo pubblico | CustomSort | Ordina la lista e mette a posto gli indici di Pos per rendere dirty gli oggetti. (Sovrascrive DedDbCollectionBaseTCustomSort(IComparerT))
Metodo protetto | ExecuteDeleteItem | Esegue l'eliminazione di un elemento. Crea il comando tramite il metodo CreateDeleteCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteInsertItem | Esegue l'inserimento di un elemento. Crea il comando tramite il metodo CreateInsertCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteUpdateItem | Esegue l'aggiornamento di un elemento. Crea il comando tramite il metodo CreateUpdateCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Find | Restituisce l'oggetto cercato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FindAll | Restitusice la lista degli elementi che corrispondono al predicato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | GetDbIndex | Restituisce l'indice dell'elemento passato: cioè il GUID della categoria. (Sovrascrive DedDbCollectionBaseTGetDbIndex(T))
Metodo pubblico | GetEnumerator | Restituisce l'enumeratore della collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | IndexOf | Restituisce l'indice dell'elemento richiesto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InsertUnModified | DI USO INTERNO. Inserisce un elemento alla lista senza rendere dirty l'oggetto, all'indice specificato. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Item | Restituisce l'elemento iesimo della lista. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean) | Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi. (Sovrascrive DedDbCollectionBaseTMove(Int32, Boolean))
Metodo pubblico | Move(Int32, Boolean, Int32) | Sposta l'elemento dell'indice passato prima o dopo del numero di posizioni passate. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSave | Metodo Template chiamato dopo il salvataggio avvenuto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSaveNoChanges | Metodo Template chiamato dopo il salvataggio senza modifiche. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnBeforeSave | Metodo Template chiamato prima del salvataggio. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(T) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(DedEditableObjectT) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(T) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(DedEditableObjectT) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ReInitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Remove | Elimina un elemento dalla collezione. (Sovrascrive DedDbCollectionBaseTRemove(T))
Metodo pubblico | Ripristina | Verifica che l'elemento sia presente negli eliminati e lo toglie da lì e lo riaggiunge in coda alla lista degli elementi validi. Solleva una eccezione se l'elemento è già presente nella lista e AllowsDuplicates = false. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Save | Salva l'oggetto con tutta la sua lista, solo se questo risulta dirty. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | SilentSort | Ordina la lista senza modificare il valore di Pos, quindi non rendendo l'oggetto dirty.
Torna su
Vedi anche

Documentazione

Classe DedCategCollection
Namespace DedNet.Core


Metodo DedCategCollection.Add

Metodo DedCategCollectionAdd
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Add(DedCateg) | Aggiunge alla collezione un elemento già esistente. Gli imposta già come padre la nuova collezione.
Metodo pubblico | Add(Guid, String, String) | Aggiunge un elemento accodandolo alla collezione.
Torna su
Vedi anche

Documentazione

Classe DedCategCollection
Namespace DedNet.Core


Metodo DedCategCollection.Add(DedCateg)

Metodo DedCategCollectionAdd(DedCateg)
Aggiunge alla collezione un elemento già esistente. Gli imposta già come padre la nuova collezione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Add(
    DedCateg categ
)
Public Sub Add (
    categ As DedCateg
)
public:
void Add(
    DedCateg^ categ
)
member Add :
        categ : DedCateg -> unit

Parametri

categ DedCateg
Attributo da aggiungere alla collezione.
Vedi anche

Documentazione

Classe DedCategCollection
Overload di Add
Namespace DedNet.Core


Metodo DedCategCollection.Add(Guid, String, String)

Metodo DedCategCollectionAdd(Guid, String, String)
Aggiunge un elemento accodandolo alla collezione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCateg Add(
    Guid id,
    string nome,
    string desc
)
Public Function Add (
    id As Guid,
    nome As String,
    desc As String
) As DedCateg
public:
DedCateg^ Add(
    Guid id,
    String^ nome,
    String^ desc
)
member Add :
        id : Guid *
        nome : string *
        desc : string -> DedCateg

Parametri

id Guid
GUID.
nome String
Valore dell'elemento.
desc String
Valore alternativo.

Valore di ritorno

DedCateg
Restituisce l'elemento appena aggiunto.
Vedi anche

Documentazione

Classe DedCategCollection
Overload di Add
Namespace DedNet.Core


Metodo DedCategCollection.ClearRefresh

Metodo DedCategCollectionClearRefresh
Svuota la lista impostando Dirty = false. Di fatto permette di effettuare un refresh della lista e quindi di ricaricarla. Serve per svuotare la lista e reinizializzarla da capo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ClearRefresh()
Public Sub ClearRefresh
public:
void ClearRefresh()
member ClearRefresh : unit -> unit
Vedi anche

Documentazione

Classe DedCategCollection
Namespace DedNet.Core


Metodo DedCategCollection.Clone

Metodo DedCategCollectionClone
Metodo per clonare la collezione di categorie.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCategCollection Clone()
Public Function Clone As DedCategCollection
public:
DedCategCollection^ Clone()
member Clone : unit -> DedCategCollection

Valore di ritorno

DedCategCollection
Vedi anche

Documentazione

Classe DedCategCollection
Namespace DedNet.Core


Metodo DedCategCollection.CreateDeleteCommand

Metodo DedCategCollectionCreateDeleteCommand
Crea, inizializza e restituisce il comando per l'eliminazione di un elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSDeleteCommand CreateDeleteCommand(
    DedCateg item
)
Protected Overrides Function CreateDeleteCommand (
    item As DedCateg
) As QSDeleteCommand
protected:
virtual QSDeleteCommand^ CreateDeleteCommand(
    DedCateg^ item
) override
abstract CreateDeleteCommand :
        item : DedCateg -> QSDeleteCommand
override CreateDeleteCommand :
        item : DedCateg -> QSDeleteCommand

Parametri

item DedCateg
Elemento da utilizzare per inizializzare il comando.

Valore di ritorno

QSDeleteCommand
Il comando inizializzato, pronto per essere eseguito.
Vedi anche

Documentazione

Classe DedCategCollection
Namespace DedNet.Core


Metodo DedCategCollection.CreateInsertCommand

Metodo DedCategCollectionCreateInsertCommand
Crea, inizializza e restituisce il comando per l'inserimento di un elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSInsertCommand CreateInsertCommand(
    DedCateg item
)
Protected Overrides Function CreateInsertCommand (
    item As DedCateg
) As QSInsertCommand
protected:
virtual QSInsertCommand^ CreateInsertCommand(
    DedCateg^ item
) override
abstract CreateInsertCommand :
        item : DedCateg -> QSInsertCommand
override CreateInsertCommand :
        item : DedCateg -> QSInsertCommand

Parametri

item DedCateg
Elemento da utilizzare per inizializzare il comando.

Valore di ritorno

QSInsertCommand
Il comando inizializzato, pronto per essere eseguito.
Vedi anche

Documentazione

Classe DedCategCollection
Namespace DedNet.Core


Metodo DedCategCollection.CreateUpdateCommand

Metodo DedCategCollectionCreateUpdateCommand
Crea, inizializza e restituisce il comando per l'aggiornamento di un elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSUpdateCommand CreateUpdateCommand(
    DedCateg item
)
Protected Overrides Function CreateUpdateCommand (
    item As DedCateg
) As QSUpdateCommand
protected:
virtual QSUpdateCommand^ CreateUpdateCommand(
    DedCateg^ item
) override
abstract CreateUpdateCommand :
        item : DedCateg -> QSUpdateCommand
override CreateUpdateCommand :
        item : DedCateg -> QSUpdateCommand

Parametri

item DedCateg
Elemento da utilizzare per inizializzare il comando.

Valore di ritorno

QSUpdateCommand
Il comando inizializzato, pronto per essere eseguito.
Vedi anche

Documentazione

Classe DedCategCollection
Namespace DedNet.Core


Metodo DedCategCollection.CustomSort

Metodo DedCategCollectionCustomSort
Ordina la lista e mette a posto gli indici di Pos per rendere dirty gli oggetti.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void CustomSort(
    IComparer<DedCateg> comparer
)
Public Overrides Sub CustomSort (
    comparer As IComparer(Of DedCateg)
)
public:
virtual void CustomSort(
    IComparer<DedCateg^>^ comparer
) override
abstract CustomSort :
        comparer : IComparer<DedCateg> -> unit
override CustomSort :
        comparer : IComparer<DedCateg> -> unit

Parametri

comparer IComparer DedCateg
Oggetto comparatore.
Vedi anche

Documentazione

Classe DedCategCollection
Namespace DedNet.Core


Metodo DedCategCollection.GetDbIndex

Metodo DedCategCollectionGetDbIndex
Restituisce l'indice dell'elemento passato: cioè il GUID della categoria.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override Object GetDbIndex(
    DedCateg item
)
Protected Overrides Function GetDbIndex (
    item As DedCateg
) As Object
protected:
virtual Object^ GetDbIndex(
    DedCateg^ item
) override
abstract GetDbIndex :
        item : DedCateg -> Object
override GetDbIndex :
        item : DedCateg -> Object

Parametri

item DedCateg
Elemento del quale restituire l'indice.

Valore di ritorno

Object
Restituisce l'indice dell'elemento oppure null.
Vedi anche

Documentazione

Classe DedCategCollection
Namespace DedNet.Core


Metodo DedCategCollection.Move

Metodo DedCategCollectionMove
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Move(Int32, Boolean) | Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi.
Metodo pubblico | Move(Int32, Boolean, Int32) | Sposta l'elemento dell'indice passato prima o dopo del numero di posizioni passate. Ignora eventuali valori di indice non validi.
Torna su
Vedi anche

Documentazione

Classe DedCategCollection
Namespace DedNet.Core


Metodo DedCategCollection.Move(Int32, Boolean)

Metodo DedCategCollectionMove(Int32, Boolean)
Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void Move(
    int index,
    bool up
)
Public Overrides Sub Move (
    index As Integer,
    up As Boolean
)
public:
virtual void Move(
    int index,
    bool up
) override
abstract Move :
        index : int *
        up : bool -> unit
override Move :
        index : int *
        up : bool -> unit

Parametri

index Int32
Indice dell'elemento da spostare.
up Boolean
Se true l'elemento viene spostato in alto (nell'indice precedente) altrimenti all'indice successivo.
Vedi anche

Documentazione

Classe DedCategCollection
Overload di Move
Namespace DedNet.Core


Metodo DedCategCollection.Remove

Metodo DedCategCollectionRemove
Elimina un elemento dalla collezione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void Remove(
    DedCateg item
)
Public Overrides Sub Remove (
    item As DedCateg
)
public:
virtual void Remove(
    DedCateg^ item
) override
abstract Remove :
        item : DedCateg -> unit
override Remove :
        item : DedCateg -> unit

Parametri

item DedCateg
Elemento da eliminare.
Vedi anche

Documentazione

Classe DedCategCollection
Namespace DedNet.Core


Metodo DedCategCollection.SilentSort

Metodo DedCategCollectionSilentSort
Ordina la lista senza modificare il valore di Pos, quindi non rendendo l'oggetto dirty.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SilentSort(
    IComparer<DedCateg> comparer
)
Public Sub SilentSort (
    comparer As IComparer(Of DedCateg)
)
public:
void SilentSort(
    IComparer<DedCateg^>^ comparer
)
member SilentSort :
        comparer : IComparer<DedCateg> -> unit

Parametri

comparer IComparer DedCateg
Vedi anche

Documentazione

Classe DedCategCollection
Namespace DedNet.Core


Classe DedCategDictionary
Dizionario di categorie.
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericDictionary String, DedCateg
DedNet.CoreDedCategDictionary

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedCategDictionary : Dictionary<string, DedCateg>
Public Class DedCategDictionary
    Inherits Dictionary(Of String, DedCateg)
public ref class DedCategDictionary : public Dictionary<String^, DedCateg^>
type DedCategDictionary =
    class
        inherit Dictionary<string, DedCateg>
    end

Il tipo DedCategDictionary espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedCategDictionary |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedCategDictionary

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCategDictionary()
Public Sub New
public:
DedCategDictionary()
new : unit -> DedCategDictionary
Vedi anche

Documentazione

Classe DedCategDictionary
Namespace DedNet.Core


Classe DedCategList
Lista di categorie.
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList DedCateg
DedNet.CoreDedCategList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedCategList : List<DedCateg>
Public Class DedCategList
    Inherits List(Of DedCateg)
public ref class DedCategList : public List<DedCateg^>
type DedCategList =
    class
        inherit List<DedCateg>
    end

Il tipo DedCategList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedCategList |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedCategList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCategList()
Public Sub New
public:
DedCategList()
new : unit -> DedCategList
Vedi anche

Documentazione

Classe DedCategList
Namespace DedNet.Core


Classe DedCategManager
Classe di gestione delle categorie.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedCategManager

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedCategManager
Public Class DedCategManager
public ref class DedCategManager
type DedCategManager = class end

Il tipo DedCategManager espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Dirty | Restitusice se la struttura delle categorie sia o meno da salvare.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | CategHasAttrs(DedCateg) | Ritorna True se la categoria passata ha ALMENO UN attributo associato.
Metodo pubblico | CategHasAttrs(String) | Ritorna True se la categoria passata ha ALMENO UN attributo associato.
Metodo pubblico | DeleteCategory | Elimina una categoria dalla collezione.
Metodo pubblico | GetAssociatedAttrs(DedCateg) | Ritorna una lista di tutti gli attributi associati alla categoria passata.
Metodo pubblico | GetAssociatedAttrs(String) | Ritorna una lista di tutti gli attributi associati alla categoria passata.
Metodo pubblico | GetCategoryFromGuid | Restituisce la categoria che corrisponde al nome passato o null se non la trova.
Metodo pubblico | GetCategoryFromName | Restituisce la categoria che corrisponde al nome passato o null se non la trova.
Metodo pubblico | GetCollection | Restituisce l'intera collezione.
Metodo pubblico | GetDefaultCategory | Restituisce la categoria di Default (la prima della collezione escludendo l'eventuale categoria passata).
Metodo pubblico | GetNames | Restituisce tutti i nomi delle liste presenti.
Metodo pubblico | HasOnlyOneCategory | Restituisce se è presente solo 1 categoria.
Metodo pubblico | RenameCategory | Rinomina la categoria passata.
Metodo pubblico | Save | Salva tutta la struttura delle categorie.
Metodo pubblico | SortCollectionByPos | Riordina la lista in base al valore di POSIZIONE.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di DedCategManager

Il tipo DedCategManager espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Dirty | Restitusice se la struttura delle categorie sia o meno da salvare.
Torna su
Vedi anche

Documentazione

Classe DedCategManager
Namespace DedNet.Core


Proprietà DedCategManager.Dirty

Proprietà DedCategManagerDirty
Restitusice se la struttura delle categorie sia o meno da salvare.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Dirty { get; }
Public ReadOnly Property Dirty As Boolean
    Get
public:
property bool Dirty {
    bool get ();
}
member Dirty : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedCategManager
Namespace DedNet.Core


Metodi di DedCategManager

Il tipo DedCategManager espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | CategHasAttrs(DedCateg) | Ritorna True se la categoria passata ha ALMENO UN attributo associato.
Metodo pubblico | CategHasAttrs(String) | Ritorna True se la categoria passata ha ALMENO UN attributo associato.
Metodo pubblico | DeleteCategory | Elimina una categoria dalla collezione.
Metodo pubblico | GetAssociatedAttrs(DedCateg) | Ritorna una lista di tutti gli attributi associati alla categoria passata.
Metodo pubblico | GetAssociatedAttrs(String) | Ritorna una lista di tutti gli attributi associati alla categoria passata.
Metodo pubblico | GetCategoryFromGuid | Restituisce la categoria che corrisponde al nome passato o null se non la trova.
Metodo pubblico | GetCategoryFromName | Restituisce la categoria che corrisponde al nome passato o null se non la trova.
Metodo pubblico | GetCollection | Restituisce l'intera collezione.
Metodo pubblico | GetDefaultCategory | Restituisce la categoria di Default (la prima della collezione escludendo l'eventuale categoria passata).
Metodo pubblico | GetNames | Restituisce tutti i nomi delle liste presenti.
Metodo pubblico | HasOnlyOneCategory | Restituisce se è presente solo 1 categoria.
Metodo pubblico | RenameCategory | Rinomina la categoria passata.
Metodo pubblico | Save | Salva tutta la struttura delle categorie.
Metodo pubblico | SortCollectionByPos | Riordina la lista in base al valore di POSIZIONE.
Torna su
Vedi anche

Documentazione

Classe DedCategManager
Namespace DedNet.Core


Metodo DedCategManager.CategHasAttrs

Metodo DedCategManagerCategHasAttrs
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | CategHasAttrs(DedCateg) | Ritorna True se la categoria passata ha ALMENO UN attributo associato.
Metodo pubblico | CategHasAttrs(String) | Ritorna True se la categoria passata ha ALMENO UN attributo associato.
Torna su
Vedi anche

Documentazione

Classe DedCategManager
Namespace DedNet.Core


Metodo DedCategManager.CategHasAttrs(DedCateg)

Metodo DedCategManagerCategHasAttrs(DedCateg)
Ritorna True se la categoria passata ha ALMENO UN attributo associato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CategHasAttrs(
    DedCateg category
)
Public Function CategHasAttrs (
    category As DedCateg
) As Boolean
public:
bool CategHasAttrs(
    DedCateg^ category
)
member CategHasAttrs :
        category : DedCateg -> bool

Parametri

category DedCateg
Categoria interessata.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedCategManager
Overload di CategHasAttrs
Namespace DedNet.Core


Metodo DedCategManager.CategHasAttrs(String)

Metodo DedCategManagerCategHasAttrs(String)
Ritorna True se la categoria passata ha ALMENO UN attributo associato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CategHasAttrs(
    string name
)
Public Function CategHasAttrs (
    name As String
) As Boolean
public:
bool CategHasAttrs(
    String^ name
)
member CategHasAttrs :
        name : string -> bool

Parametri

name String
Nome della categoria.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedCategManager
Overload di CategHasAttrs
Namespace DedNet.Core


Metodo DedCategManager.DeleteCategory

Metodo DedCategManagerDeleteCategory
Elimina una categoria dalla collezione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool DeleteCategory(
    string categName,
    bool deleteFromRename = false
)
Public Function DeleteCategory (
    categName As String,
    Optional deleteFromRename As Boolean = false
) As Boolean
public:
bool DeleteCategory(
    String^ categName,
    bool deleteFromRename = false
)
member DeleteCategory :
        categName : string *
        ?deleteFromRename : bool
(* Defaults:
        let _deleteFromRename = defaultArg deleteFromRename false
*)
-> bool

Parametri

categName String
Nome della categoria da rimuovere.
deleteFromRename Boolean (Optional)

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedCategManager
Namespace DedNet.Core


Metodo DedCategManager.GetAssociatedAttrs

Metodo DedCategManagerGetAssociatedAttrs
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | GetAssociatedAttrs(DedCateg) | Ritorna una lista di tutti gli attributi associati alla categoria passata.
Metodo pubblico | GetAssociatedAttrs(String) | Ritorna una lista di tutti gli attributi associati alla categoria passata.
Torna su
Vedi anche

Documentazione

Classe DedCategManager
Namespace DedNet.Core


Metodo DedCategManager.GetAssociatedAttrs(DedCateg)

Metodo DedCategManagerGetAssociatedAttrs(DedCateg)
Ritorna una lista di tutti gli attributi associati alla categoria passata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<DedAttr> GetAssociatedAttrs(
    DedCateg category
)
Public Function GetAssociatedAttrs (
    category As DedCateg
) As List(Of DedAttr)
public:
List<DedAttr^>^ GetAssociatedAttrs(
    DedCateg^ category
)
member GetAssociatedAttrs :
        category : DedCateg -> List<DedAttr>

Parametri

category DedCateg
Categoria interessata.

Valore di ritorno

List DedAttr
Vedi anche

Documentazione

Classe DedCategManager
Overload di GetAssociatedAttrs
Namespace DedNet.Core


Metodo DedCategManager.GetAssociatedAttrs(String)

Metodo DedCategManagerGetAssociatedAttrs(String)
Ritorna una lista di tutti gli attributi associati alla categoria passata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<DedAttr> GetAssociatedAttrs(
    string name
)
Public Function GetAssociatedAttrs (
    name As String
) As List(Of DedAttr)
public:
List<DedAttr^>^ GetAssociatedAttrs(
    String^ name
)
member GetAssociatedAttrs :
        name : string -> List<DedAttr>

Parametri

name String
Nome della categoria.

Valore di ritorno

List DedAttr
Vedi anche

Documentazione

Classe DedCategManager
Overload di GetAssociatedAttrs
Namespace DedNet.Core


Metodo DedCategManager.GetCategoryFromGuid

Metodo DedCategManagerGetCategoryFromGuid
Restituisce la categoria che corrisponde al nome passato o null se non la trova.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCateg GetCategoryFromGuid(
    Guid id
)
Public Function GetCategoryFromGuid (
    id As Guid
) As DedCateg
public:
DedCateg^ GetCategoryFromGuid(
    Guid id
)
member GetCategoryFromGuid :
        id : Guid -> DedCateg

Parametri

id Guid

Valore di ritorno

DedCateg
Vedi anche

Documentazione

Classe DedCategManager
Namespace DedNet.Core


Metodo DedCategManager.GetCategoryFromName

Metodo DedCategManagerGetCategoryFromName
Restituisce la categoria che corrisponde al nome passato o null se non la trova.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCateg GetCategoryFromName(
    string name
)
Public Function GetCategoryFromName (
    name As String
) As DedCateg
public:
DedCateg^ GetCategoryFromName(
    String^ name
)
member GetCategoryFromName :
        name : string -> DedCateg

Parametri

name String

Valore di ritorno

DedCateg
Vedi anche

Documentazione

Classe DedCategManager
Namespace DedNet.Core


Metodo DedCategManager.GetCollection

Metodo DedCategManagerGetCollection
Restituisce l'intera collezione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCategCollection GetCollection()
Public Function GetCollection As DedCategCollection
public:
DedCategCollection^ GetCollection()
member GetCollection : unit -> DedCategCollection

Valore di ritorno

DedCategCollection
Vedi anche

Documentazione

Classe DedCategManager
Namespace DedNet.Core


Metodo DedCategManager.GetDefaultCategory

Metodo DedCategManagerGetDefaultCategory
Restituisce la categoria di Default (la prima della collezione escludendo l'eventuale categoria passata).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCateg GetDefaultCategory(
    DedCateg categToIgnore = null
)
Public Function GetDefaultCategory (
    Optional categToIgnore As DedCateg = Nothing
) As DedCateg
public:
DedCateg^ GetDefaultCategory(
    DedCateg^ categToIgnore = nullptr
)
member GetDefaultCategory :
        ?categToIgnore : DedCateg
(* Defaults:
        let _categToIgnore = defaultArg categToIgnore null
*)
-> DedCateg

Parametri

categToIgnore DedCateg (Optional)

Valore di ritorno

DedCateg
Vedi anche

Documentazione

Classe DedCategManager
Namespace DedNet.Core


Metodo DedCategManager.GetNames

Metodo DedCategManagerGetNames
Restituisce tutti i nomi delle liste presenti.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string[] GetNames()
Public Function GetNames As String()
public:
array<String^>^ GetNames()
member GetNames : unit -> string[]

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedCategManager
Namespace DedNet.Core


Metodo DedCategManager.HasOnlyOneCategory

Metodo DedCategManagerHasOnlyOneCategory
Restituisce se è presente solo 1 categoria.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasOnlyOneCategory()
Public Function HasOnlyOneCategory As Boolean
public:
bool HasOnlyOneCategory()
member HasOnlyOneCategory : unit -> bool

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedCategManager
Namespace DedNet.Core


Metodo DedCategManager.RenameCategory

Metodo DedCategManagerRenameCategory
Rinomina la categoria passata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool RenameCategory(
    string oldName,
    string newName
)
Public Function RenameCategory (
    oldName As String,
    newName As String
) As Boolean
public:
bool RenameCategory(
    String^ oldName,
    String^ newName
)
member RenameCategory :
        oldName : string *
        newName : string -> bool

Parametri

oldName String
Vecchio nome della categoria.
newName String
Nuovo nome della categoria.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedCategManager
Namespace DedNet.Core


Metodo DedCategManager.Save

Metodo DedCategManagerSave
Salva tutta la struttura delle categorie.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Save()
Public Sub Save
public:
void Save()
member Save : unit -> unit
Vedi anche

Documentazione

Classe DedCategManager
Namespace DedNet.Core


Metodo DedCategManager.SortCollectionByPos

Metodo DedCategManagerSortCollectionByPos
Riordina la lista in base al valore di POSIZIONE.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SortCollectionByPos()
Public Sub SortCollectionByPos
public:
void SortCollectionByPos()
member SortCollectionByPos : unit -> unit
Vedi anche

Documentazione

Classe DedCategManager
Namespace DedNet.Core


Classe DedComm
Oggetto descrittivo di una commessa. La costruzione di questo oggetto è demandata dai metodi dell'oggetto Application. Appena si imposta una proprietà pubblica scrivibile dell'oggetto, viene subito tentato l'aggiornamento del record nel Database. Se la versione del record non risulta coerente viene sollevata un'eccezione per indicare che qualcun'altro ha già modificato la commessa.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedBaseDbItem
DedNet.CoreDedTimedDbItem
DedNet.CoreDedComm

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedComm : DedTimedDbItem, IDedTypeEditable,
    IDedEditable
Public Class DedComm
    Inherits DedTimedDbItem
    Implements IDedTypeEditable, IDedEditable
public ref class DedComm : public DedTimedDbItem,
    IDedTypeEditable, IDedEditable
type DedComm =
    class
        inherit DedTimedDbItem
        interface IDedTypeEditable
        interface IDedEditable
    end

Il tipo DedComm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Anagrafiche | Restituisce le anagrafiche collegate a questa commessa.
Proprietà pubblica | Application | Restituisce l'applicazione di appartenenza.
Proprietà pubblica | ClosureDate | Restituisce la data di chiusura della commessa.
Proprietà pubblica | ClosureUser | Restituisce l'utente che ha chiuso la commessa.
Proprietà pubblica | Commesse | Restituisce le commesse collegate a questa commessa.
Proprietà pubblica | CommId | Restituisce l'ID di questa commessa.
Proprietà pubblica | CommKind | Indentifica il tipo specifico della commessa
Proprietà pubblica | CommType | Restituisce la categoria di appartenenza.
Proprietà pubblica | CreationDate | Restituisce o imposta la data di creazione di questa commessa. Impostando questa proprietà si ottiene l'immediato aggiornamento della commessa nel Database.
Proprietà pubblica | CreationUser | Restituisce o imposta l'utente che ha creato questa commessa. Impostando questa proprietà si ottiene l'immediato aggiornamento della commessa nel Database.
Proprietà pubblica | Customer | Restituisce i imposta il cliente della commessa. Impostando questa proprietà si ottiene l'immediato aggiornamento della commessa nel Database.
Proprietà pubblica | DbIndex | (Sovrascrive DedBaseDbItemDbIndex)
Proprietà pubblica | DedTypeBase |
Proprietà pubblica | Description | Restituisce o imposta la descrizione della commessa. Impostando questa proprietà si ottiene l'immediato aggiornamento della commessa nel Database.
Proprietà pubblica | DirPath | Restituisce il percorso di archiviazione (pws se area locale attiva altrimenti vault) dei documenti di questa commessa.
Proprietà pubblica | Documenti | Restituisce i documenti collegati a questa commessa.
Proprietà pubblica | EncodeCommInfo | Classe contenente le info di codifica.
Proprietà pubblica | EncodedId | Codifica utilizzate per creare ID.
Proprietà pubblica | EncodeInfo | Restituisce le informazioni di codifica per questa anagrafica. Se l'anagrafica è stata codificata in una famiglia normale ricava le informazioni dal DedID aggiungendo la propria revisione, se invece è stata codificata in una famiglia FreeCode o FreeFile cerca di ricavarle dal Ded_File o dal DedId. Se è sia FreeCode che FreeFile restituisce le informazioni con la famiglia e l'anagrafica soltanto.
Proprietà pubblica | FirstLevVisible | Restituisce o imposta se questa commessa sia o meno visibile al primo livello. Di default è true.
Proprietà pubblica | FreeCode | Indica se è una anagrafica FreeCode
Proprietà pubblica | IsClosed | Restituisce se la commessa sia o meno chiusa. Controlla l'utente di chiusura: se compilato vuol dire che è chiusa.
Proprietà pubblica | IsFree | Ritorna true se la commessa non ha alcun proprietario assegnato
Proprietà pubblica | IsSubComm | Restituisce true se questa è una sotto-commessa altrimenti restituisce false.
Proprietà pubblica | IsValid |
Proprietà pubblica | ModDate | Restituisce la data di ultima modifica della commessa.
Proprietà pubblica | ModUser | Restituisce l'utente che ha fatto l'ultima modifica alla commessa.
Proprietà pubblica | Name | Restituisce il nome univoco della commessa.
Proprietà pubblica | NameCommType | Restituisce la descrizione della categoria di appartenenza.
Proprietà pubblica | Note | Restituisce o imposta le note della commessa. Impostando questa proprietà si ottiene l'immediato aggiornamento della commessa nel Database.
Proprietà pubblica | OldCommPath | Nel caso di cambio nome si salva il nome originale per la gestione dei permessi.
Proprietà pubblica | OldVaultCommPath | Nel caso di cambio nome si salva il path di vault originale per la copia delle cartelle vuote.
Proprietà pubblica | OwnerUser | Restituisce o imposta l'utente che ha in carico la commessa
Proprietà pubblica | OwningDate | Restituisce la data di presa in carico della commessa
Proprietà pubblica | Parent | Restitusice la prima commessa genitore di questa commessa, se si tratta di una sotto-commessa, altrimenti restituisce null.
Proprietà pubblica | Parents | Restituisce la lista dei genitori di questa commessa, se si tratta di una sotto-commessa, altrimenti restituisce una lista vuota.
Proprietà pubblica | Root |
Proprietà pubblica | RowVer | Restituisce la versione di questa commessa. NOTA: La proprietà è impostabile internamente ma non scatena l'aggiornamento nel Database della commessa.
Proprietà pubblica | TimeList | Ritorna l'elenco delle temporizzazioni associate a questo elemento. (Ereditato da DedTimedDbItem)
Proprietà pubblica | VaultPath | Restituisce il percorso di Vault di archiviazione dei documenti di questa commessa.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AddToCommEncode | Aggiunge questa commessa alla tabella DED_COMM_ENCODE.
Metodo pubblico | AddToErased | Aggiunge la commessa alla tabella degli eliminati. Una volta che la commessa è stata aggiunta alla tabella, verranno aggiornati i relativi campi in modo tale che sembrerà essere stata prima liberata e poi chiusa.
Metodo pubblico | AttributeDictionary | Restituisce un dizionario con le accoppiate attributo-valore per l'edita attributi.
Metodo pubblico | Charge | Prende in carico la commessa con l'utente e la data corrente.
Metodo pubblico | ClearPerm | Elimina tutti i permessi specifici sulla commessa.
Metodo pubblico | CloneStructure | Crea la struttura della cartelle e file dal master passato
Metodo pubblico | Close | Chiude la commessa impostando l'utente e la data di chiusura.
Metodo pubblico | Delete | Elimina la commessa dalla tabella principale e dalle tabelle di collegamento.
Metodo pubblico | Equals | Override della definizione di equals. (Sovrascrive ObjectEquals(Object))
Metodo pubblico | ForEachChild | Questo metodo chiama un delegate passandogli in sequenza il nodo corrente (opzionalmente) e tutti i suoi nodi figli.
Metodo pubblico | ForOneChild | Questo metodo chiama un delegate passandogli in sequenza il nodo corrente (opzionalmente) e tutti i suoi nodi figli.
Metodo pubblico | GetDescription | (Sovrascrive DedBaseDbItemGetDescription)
Metodo pubblico | GetEcoList | Metodo che ritorna tutti gli Eco associati alla commessa
Metodo pubblico | GetHashCode | Restituisce l'hashcode dell'oggetto. (Sovrascrive ObjectGetHashCode)
Metodo pubblico | GetName | (Sovrascrive DedBaseDbItemGetName)
Metodo pubblico | GetObjectType | (Sovrascrive DedBaseDbItemGetObjectType)
Metodo pubblico | GetProgr | Restituisce il progressivo dell'anagrafica. Letto da DED_DATA_ENCODE se compilato altrimenti lo ricalcola.
Metodo pubblico | GetValue(DedCommStandardCommFields) | Restituisce il contenuto di uno dei campi standard oppure null se non è presente.
Metodo pubblico | GetValue(DedDataStandardDataFields) |
Metodo pubblico | GetValue(String) | Restituisce il contenuto di un campo personalizzato oppure null se non esiste.
Metodo pubblico | IsAncestor | Controlla se l'id di commessa passato è presente nella concatenazione dei padri
Metodo pubblico | Liberate | Elimina le informazioni di ownership dalla commessa.
Metodo pubblico | Open | Riapre la commessa annullando utente e data di chiusura
Metodo pubblico | Requery | Aggiorna tutte le proprietà della commessa passata rileggendole dal Database. Se la commessa non esiste più solleva un'eccezione.
Metodo pubblico | SetValue(DedCommStandardCommFields, Object) | Imposta un campo standard con un nuovo valore. Se il campo non è compilato lo crea nel dizionario interno.
Metodo pubblico | SetValue(DedDataStandardDataFields, Object) |
Metodo pubblico | SetValue(String, Object) | Imposta un campo personalizzato con un nuovo valore. Se il campo non è compilato lo crea nel dizionario interno.
Metodo pubblico | ToString | Rappresentazione stringa dell'oggetto. (Sovrascrive ObjectToString)
Metodo pubblico | UnlinkParent | Elimina la commessa dalle collezioni dei padri
Metodo pubblico | UnlinkParents | Elimina la commessa dalle collezioni dei padri
Metodo pubblico | UpdateLastRevAnag | Aggiorna le anagrafiche di commessa all'ultima revisione salvata
Metodo pubblico | UserCan(DedStandardPerm) | Verifica se l'utente corrente ha un determinato permesso su questa commessa.
Metodo pubblico | UserCan(String) | Verifica se l'utente corrente ha un determinato permesso su questa commessa.
Metodo pubblico | Validate | Restituisce se i valori presenti validano gli attributi della famiglia di appartenenza.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di DedComm

Il tipo DedComm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Anagrafiche | Restituisce le anagrafiche collegate a questa commessa.
Proprietà pubblica | Application | Restituisce l'applicazione di appartenenza.
Proprietà pubblica | ClosureDate | Restituisce la data di chiusura della commessa.
Proprietà pubblica | ClosureUser | Restituisce l'utente che ha chiuso la commessa.
Proprietà pubblica | Commesse | Restituisce le commesse collegate a questa commessa.
Proprietà pubblica | CommId | Restituisce l'ID di questa commessa.
Proprietà pubblica | CommKind | Indentifica il tipo specifico della commessa
Proprietà pubblica | CommType | Restituisce la categoria di appartenenza.
Proprietà pubblica | CreationDate | Restituisce o imposta la data di creazione di questa commessa. Impostando questa proprietà si ottiene l'immediato aggiornamento della commessa nel Database.
Proprietà pubblica | CreationUser | Restituisce o imposta l'utente che ha creato questa commessa. Impostando questa proprietà si ottiene l'immediato aggiornamento della commessa nel Database.
Proprietà pubblica | Customer | Restituisce i imposta il cliente della commessa. Impostando questa proprietà si ottiene l'immediato aggiornamento della commessa nel Database.
Proprietà pubblica | DbIndex | (Sovrascrive DedBaseDbItemDbIndex)
Proprietà pubblica | DedTypeBase |
Proprietà pubblica | Description | Restituisce o imposta la descrizione della commessa. Impostando questa proprietà si ottiene l'immediato aggiornamento della commessa nel Database.
Proprietà pubblica | DirPath | Restituisce il percorso di archiviazione (pws se area locale attiva altrimenti vault) dei documenti di questa commessa.
Proprietà pubblica | Documenti | Restituisce i documenti collegati a questa commessa.
Proprietà pubblica | EncodeCommInfo | Classe contenente le info di codifica.
Proprietà pubblica | EncodedId | Codifica utilizzate per creare ID.
Proprietà pubblica | EncodeInfo | Restituisce le informazioni di codifica per questa anagrafica. Se l'anagrafica è stata codificata in una famiglia normale ricava le informazioni dal DedID aggiungendo la propria revisione, se invece è stata codificata in una famiglia FreeCode o FreeFile cerca di ricavarle dal Ded_File o dal DedId. Se è sia FreeCode che FreeFile restituisce le informazioni con la famiglia e l'anagrafica soltanto.
Proprietà pubblica | FirstLevVisible | Restituisce o imposta se questa commessa sia o meno visibile al primo livello. Di default è true.
Proprietà pubblica | FreeCode | Indica se è una anagrafica FreeCode
Proprietà pubblica | IsClosed | Restituisce se la commessa sia o meno chiusa. Controlla l'utente di chiusura: se compilato vuol dire che è chiusa.
Proprietà pubblica | IsFree | Ritorna true se la commessa non ha alcun proprietario assegnato
Proprietà pubblica | IsSubComm | Restituisce true se questa è una sotto-commessa altrimenti restituisce false.
Proprietà pubblica | IsValid |
Proprietà pubblica | ModDate | Restituisce la data di ultima modifica della commessa.
Proprietà pubblica | ModUser | Restituisce l'utente che ha fatto l'ultima modifica alla commessa.
Proprietà pubblica | Name | Restituisce il nome univoco della commessa.
Proprietà pubblica | NameCommType | Restituisce la descrizione della categoria di appartenenza.
Proprietà pubblica | Note | Restituisce o imposta le note della commessa. Impostando questa proprietà si ottiene l'immediato aggiornamento della commessa nel Database.
Proprietà pubblica | OldCommPath | Nel caso di cambio nome si salva il nome originale per la gestione dei permessi.
Proprietà pubblica | OldVaultCommPath | Nel caso di cambio nome si salva il path di vault originale per la copia delle cartelle vuote.
Proprietà pubblica | OwnerUser | Restituisce o imposta l'utente che ha in carico la commessa
Proprietà pubblica | OwningDate | Restituisce la data di presa in carico della commessa
Proprietà pubblica | Parent | Restitusice la prima commessa genitore di questa commessa, se si tratta di una sotto-commessa, altrimenti restituisce null.
Proprietà pubblica | Parents | Restituisce la lista dei genitori di questa commessa, se si tratta di una sotto-commessa, altrimenti restituisce una lista vuota.
Proprietà pubblica | Root |
Proprietà pubblica | RowVer | Restituisce la versione di questa commessa. NOTA: La proprietà è impostabile internamente ma non scatena l'aggiornamento nel Database della commessa.
Proprietà pubblica | TimeList | Ritorna l'elenco delle temporizzazioni associate a questo elemento. (Ereditato da DedTimedDbItem)
Proprietà pubblica | VaultPath | Restituisce il percorso di Vault di archiviazione dei documenti di questa commessa.
Torna su
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Proprietà DedComm.Anagrafiche

Proprietà DedCommAnagrafiche
Restituisce le anagrafiche collegate a questa commessa.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommAnagrCollection Anagrafiche { get; }
Public ReadOnly Property Anagrafiche As DedCommAnagrCollection
    Get
public:
property DedCommAnagrCollection^ Anagrafiche {
    DedCommAnagrCollection^ get ();
}
member Anagrafiche : DedCommAnagrCollection with get

Valore della proprietà

DedCommAnagrCollection
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Proprietà DedComm.Application

Proprietà DedCommApplication
Restituisce l'applicazione di appartenenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedNetApplication Application { get; }
Public ReadOnly Property Application As DedNetApplication
    Get
public:
property DedNetApplication^ Application {
    DedNetApplication^ get ();
}
member Application : DedNetApplication with get

Valore della proprietà

DedNetApplication
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Proprietà DedComm.ClosureDate

Proprietà DedCommClosureDate
Restituisce la data di chiusura della commessa.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DateTime? ClosureDate { get; }
Public ReadOnly Property ClosureDate As DateTime?
    Get
public:
property Nullable<DateTime> ClosureDate {
    Nullable<DateTime> get ();
}
member ClosureDate : Nullable<DateTime> with get

Valore della proprietà

Nullable DateTime
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Proprietà DedComm.ClosureUser

Proprietà DedCommClosureUser
Restituisce l'utente che ha chiuso la commessa.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string ClosureUser { get; }
Public ReadOnly Property ClosureUser As String
    Get
public:
property String^ ClosureUser {
    String^ get ();
}
member ClosureUser : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Proprietà DedComm.Commesse

Proprietà DedCommCommesse
Restituisce le commesse collegate a questa commessa.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommCommCollection Commesse { get; }
Public ReadOnly Property Commesse As DedCommCommCollection
    Get
public:
property DedCommCommCollection^ Commesse {
    DedCommCommCollection^ get ();
}
member Commesse : DedCommCommCollection with get

Valore della proprietà

DedCommCommCollection
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Proprietà DedComm.CommId

Proprietà DedCommCommId
Restituisce l'ID di questa commessa.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Guid CommId { get; }
Public ReadOnly Property CommId As Guid
    Get
public:
property Guid CommId {
    Guid get ();
}
member CommId : Guid with get

Valore della proprietà

Guid
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Proprietà DedComm.CommKind

Proprietà DedCommCommKind
Indentifica il tipo specifico della commessa

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommCommKindEnum CommKind { get; set; }
Public Property CommKind As DedCommCommKindEnum
    Get
    Set
public:
property DedCommCommKindEnum CommKind {
    DedCommCommKindEnum get ();
    void set (DedCommCommKindEnum value);
}
member CommKind : DedCommCommKindEnum with get, set

Valore della proprietà

DedCommCommKindEnum
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Proprietà DedComm.CommType

Proprietà DedCommCommType
Restituisce la categoria di appartenenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommType CommType { get; set; }
Public Property CommType As DedCommType
    Get
    Set
public:
property DedCommType^ CommType {
    DedCommType^ get ();
    void set (DedCommType^ value);
}
member CommType : DedCommType with get, set

Valore della proprietà

DedCommType
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Proprietà DedComm.CreationDate

Proprietà DedCommCreationDate
Restituisce o imposta la data di creazione di questa commessa. Impostando questa proprietà si ottiene l'immediato aggiornamento della commessa nel Database.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DateTime? CreationDate { get; set; }
Public Property CreationDate As DateTime?
    Get
    Set
public:
property Nullable<DateTime> CreationDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
member CreationDate : Nullable<DateTime> with get, set

Valore della proprietà

Nullable DateTime
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Proprietà DedComm.CreationUser

Proprietà DedCommCreationUser
Restituisce o imposta l'utente che ha creato questa commessa. Impostando questa proprietà si ottiene l'immediato aggiornamento della commessa nel Database.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string CreationUser { get; set; }
Public Property CreationUser As String
    Get
    Set
public:
property String^ CreationUser {
    String^ get ();
    void set (String^ value);
}
member CreationUser : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Proprietà DedComm.Customer

Proprietà DedCommCustomer
Restituisce i imposta il cliente della commessa. Impostando questa proprietà si ottiene l'immediato aggiornamento della commessa nel Database.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Customer { get; set; }
Public Property Customer As String
    Get
    Set
public:
property String^ Customer {
    String^ get ();
    void set (String^ value);
}
member Customer : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Proprietà DedComm.DbIndex

Proprietà DedCommDbIndex

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string DbIndex { get; }
Public Overrides ReadOnly Property DbIndex As String
    Get
public:
virtual property String^ DbIndex {
    String^ get () override;
}
abstract DbIndex : string with get
override DbIndex : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Proprietà DedComm.DedTypeBase

Proprietà DedCommDedTypeBase

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeBase DedTypeBase { get; }
Public ReadOnly Property DedTypeBase As DedTypeBase
    Get
public:
virtual property DedTypeBase^ DedTypeBase {
    DedTypeBase^ get () sealed;
}
abstract DedTypeBase : DedTypeBase with get
override DedTypeBase : DedTypeBase with get

Valore della proprietà

DedTypeBase

Implementa

IDedTypeEditableDedTypeBase
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Proprietà DedComm.Description

Proprietà DedCommDescription
Restituisce o imposta la descrizione della commessa. Impostando questa proprietà si ottiene l'immediato aggiornamento della commessa nel Database.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
member Description : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Proprietà DedComm.DirPath

Proprietà DedCommDirPath
Restituisce il percorso di archiviazione (pws se area locale attiva altrimenti vault) dei documenti di questa commessa.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string DirPath { get; }
Public ReadOnly Property DirPath As String
    Get
public:
property String^ DirPath {
    String^ get ();
}
member DirPath : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Proprietà DedComm.Documenti

Proprietà DedCommDocumenti
Restituisce i documenti collegati a questa commessa.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommDocCollection Documenti { get; }
Public ReadOnly Property Documenti As DedCommDocCollection
    Get
public:
property DedCommDocCollection^ Documenti {
    DedCommDocCollection^ get ();
}
member Documenti : DedCommDocCollection with get

Valore della proprietà

DedCommDocCollection
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Proprietà DedComm.EncodeCommInfo

Proprietà DedCommEncodeCommInfo
Classe contenente le info di codifica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommDedCommEncodeInfo EncodeCommInfo { get; }
Public ReadOnly Property EncodeCommInfo As DedCommDedCommEncodeInfo
    Get
public:
property DedCommDedCommEncodeInfo^ EncodeCommInfo {
    DedCommDedCommEncodeInfo^ get ();
}
member EncodeCommInfo : DedCommDedCommEncodeInfo with get

Valore della proprietà

DedCommDedCommEncodeInfo
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Proprietà DedComm.EncodedId

Proprietà DedCommEncodedId
Codifica utilizzate per creare ID.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string EncodedId { get; }
Public ReadOnly Property EncodedId As String
    Get
public:
property String^ EncodedId {
    String^ get ();
}
member EncodedId : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Proprietà DedComm.EncodeInfo

Proprietà DedCommEncodeInfo
Restituisce le informazioni di codifica per questa anagrafica. Se l'anagrafica è stata codificata in una famiglia normale ricava le informazioni dal DedID aggiungendo la propria revisione, se invece è stata codificata in una famiglia FreeCode o FreeFile cerca di ricavarle dal Ded_File o dal DedId. Se è sia FreeCode che FreeFile restituisce le informazioni con la famiglia e l'anagrafica soltanto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEncodeInfo EncodeInfo { get; }
Public ReadOnly Property EncodeInfo As DedEncodeInfo
    Get
public:
property DedEncodeInfo^ EncodeInfo {
    DedEncodeInfo^ get ();
}
member EncodeInfo : DedEncodeInfo with get

Valore della proprietà

DedEncodeInfo
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Proprietà DedComm.FirstLevVisible

Proprietà DedCommFirstLevVisible
Restituisce o imposta se questa commessa sia o meno visibile al primo livello. Di default è true.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool FirstLevVisible { get; set; }
Public Property FirstLevVisible As Boolean
    Get
    Set
public:
property bool FirstLevVisible {
    bool get ();
    void set (bool value);
}
member FirstLevVisible : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Proprietà DedComm.FreeCode

Proprietà DedCommFreeCode
Indica se è una anagrafica FreeCode

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool FreeCode { get; }
Public ReadOnly Property FreeCode As Boolean
    Get
public:
property bool FreeCode {
    bool get ();
}
member FreeCode : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Proprietà DedComm.IsClosed

Proprietà DedCommIsClosed
Restituisce se la commessa sia o meno chiusa. Controlla l'utente di chiusura: se compilato vuol dire che è chiusa.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsClosed { get; }
Public ReadOnly Property IsClosed As Boolean
    Get
public:
property bool IsClosed {
    bool get ();
}
member IsClosed : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Proprietà DedComm.IsFree

Proprietà DedCommIsFree
Ritorna true se la commessa non ha alcun proprietario assegnato

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsFree { get; }
Public ReadOnly Property IsFree As Boolean
    Get
public:
property bool IsFree {
    bool get ();
}
member IsFree : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Proprietà DedComm.IsSubComm

Proprietà DedCommIsSubComm
Restituisce true se questa è una sotto-commessa altrimenti restituisce false.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsSubComm { get; }
Public ReadOnly Property IsSubComm As Boolean
    Get
public:
property bool IsSubComm {
    bool get ();
}
member IsSubComm : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Proprietà DedComm.IsValid

Proprietà DedCommIsValid

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsValid { get; }
Public ReadOnly Property IsValid As Boolean
    Get
public:
virtual property bool IsValid {
    bool get () sealed;
}
abstract IsValid : bool with get
override IsValid : bool with get

Valore della proprietà

Boolean

Implementa

IDedTypeEditableIsValid
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Proprietà DedComm.ModDate

Proprietà DedCommModDate
Restituisce la data di ultima modifica della commessa.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DateTime? ModDate { get; }
Public ReadOnly Property ModDate As DateTime?
    Get
public:
property Nullable<DateTime> ModDate {
    Nullable<DateTime> get ();
}
member ModDate : Nullable<DateTime> with get

Valore della proprietà

Nullable DateTime
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Proprietà DedComm.ModUser

Proprietà DedCommModUser
Restituisce l'utente che ha fatto l'ultima modifica alla commessa.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string ModUser { get; }
Public ReadOnly Property ModUser As String
    Get
public:
property String^ ModUser {
    String^ get ();
}
member ModUser : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Proprietà DedComm.Name

Proprietà DedCommName
Restituisce il nome univoco della commessa.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Proprietà DedComm.NameCommType

Proprietà DedCommNameCommType
Restituisce la descrizione della categoria di appartenenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string NameCommType { get; }
Public ReadOnly Property NameCommType As String
    Get
public:
property String^ NameCommType {
    String^ get ();
}
member NameCommType : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Proprietà DedComm.Note

Proprietà DedCommNote
Restituisce o imposta le note della commessa. Impostando questa proprietà si ottiene l'immediato aggiornamento della commessa nel Database.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Note { get; set; }
Public Property Note As String
    Get
    Set
public:
property String^ Note {
    String^ get ();
    void set (String^ value);
}
member Note : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Proprietà DedComm.OldCommPath

Proprietà DedCommOldCommPath
Nel caso di cambio nome si salva il nome originale per la gestione dei permessi.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string OldCommPath { get; set; }
Public Property OldCommPath As String
    Get
    Set
public:
property String^ OldCommPath {
    String^ get ();
    void set (String^ value);
}
member OldCommPath : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Proprietà DedComm.OldVaultCommPath

Proprietà DedCommOldVaultCommPath
Nel caso di cambio nome si salva il path di vault originale per la copia delle cartelle vuote.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string OldVaultCommPath { get; set; }
Public Property OldVaultCommPath As String
    Get
    Set
public:
property String^ OldVaultCommPath {
    String^ get ();
    void set (String^ value);
}
member OldVaultCommPath : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Proprietà DedComm.OwnerUser

Proprietà DedCommOwnerUser
Restituisce o imposta l'utente che ha in carico la commessa

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string OwnerUser { get; set; }
Public Property OwnerUser As String
    Get
    Set
public:
property String^ OwnerUser {
    String^ get ();
    void set (String^ value);
}
member OwnerUser : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Proprietà DedComm.OwningDate

Proprietà DedCommOwningDate
Restituisce la data di presa in carico della commessa

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DateTime? OwningDate { get; set; }
Public Property OwningDate As DateTime?
    Get
    Set
public:
property Nullable<DateTime> OwningDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
member OwningDate : Nullable<DateTime> with get, set

Valore della proprietà

Nullable DateTime
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Proprietà DedComm.Parent

Proprietà DedCommParent
Restitusice la prima commessa genitore di questa commessa, se si tratta di una sotto-commessa, altrimenti restituisce null.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedComm Parent { get; }
Public ReadOnly Property Parent As DedComm
    Get
public:
property DedComm^ Parent {
    DedComm^ get ();
}
member Parent : DedComm with get

Valore della proprietà

DedComm
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Proprietà DedComm.Parents

Proprietà DedCommParents
Restituisce la lista dei genitori di questa commessa, se si tratta di una sotto-commessa, altrimenti restituisce una lista vuota.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommList Parents { get; }
Public ReadOnly Property Parents As DedCommList
    Get
public:
property DedCommList^ Parents {
    DedCommList^ get ();
}
member Parents : DedCommList with get

Valore della proprietà

DedCommList
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Proprietà DedComm.Root

Proprietà DedCommRoot

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeBase Root { get; }
Public ReadOnly Property Root As DedTypeBase
    Get
public:
virtual property DedTypeBase^ Root {
    DedTypeBase^ get () sealed;
}
abstract Root : DedTypeBase with get
override Root : DedTypeBase with get

Valore della proprietà

DedTypeBase

Implementa

IDedTypeEditableRoot
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Proprietà DedComm.RowVer

Proprietà DedCommRowVer
Restituisce la versione di questa commessa. NOTA: La proprietà è impostabile internamente ma non scatena l'aggiornamento nel Database della commessa.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Guid RowVer { get; }
Public ReadOnly Property RowVer As Guid
    Get
public:
property Guid RowVer {
    Guid get ();
}
member RowVer : Guid with get

Valore della proprietà

Guid
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Proprietà DedComm.VaultPath

Proprietà DedCommVaultPath
Restituisce il percorso di Vault di archiviazione dei documenti di questa commessa.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string VaultPath { get; }
Public ReadOnly Property VaultPath As String
    Get
public:
property String^ VaultPath {
    String^ get ();
}
member VaultPath : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Metodi di DedComm

Il tipo DedComm espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AddToCommEncode | Aggiunge questa commessa alla tabella DED_COMM_ENCODE.
Metodo pubblico | AddToErased | Aggiunge la commessa alla tabella degli eliminati. Una volta che la commessa è stata aggiunta alla tabella, verranno aggiornati i relativi campi in modo tale che sembrerà essere stata prima liberata e poi chiusa.
Metodo pubblico | AttributeDictionary | Restituisce un dizionario con le accoppiate attributo-valore per l'edita attributi.
Metodo pubblico | Charge | Prende in carico la commessa con l'utente e la data corrente.
Metodo pubblico | ClearPerm | Elimina tutti i permessi specifici sulla commessa.
Metodo pubblico | CloneStructure | Crea la struttura della cartelle e file dal master passato
Metodo pubblico | Close | Chiude la commessa impostando l'utente e la data di chiusura.
Metodo pubblico | Delete | Elimina la commessa dalla tabella principale e dalle tabelle di collegamento.
Metodo pubblico | Equals | Override della definizione di equals. (Sovrascrive ObjectEquals(Object))
Metodo pubblico | ForEachChild | Questo metodo chiama un delegate passandogli in sequenza il nodo corrente (opzionalmente) e tutti i suoi nodi figli.
Metodo pubblico | ForOneChild | Questo metodo chiama un delegate passandogli in sequenza il nodo corrente (opzionalmente) e tutti i suoi nodi figli.
Metodo pubblico | GetDescription | (Sovrascrive DedBaseDbItemGetDescription)
Metodo pubblico | GetEcoList | Metodo che ritorna tutti gli Eco associati alla commessa
Metodo pubblico | GetHashCode | Restituisce l'hashcode dell'oggetto. (Sovrascrive ObjectGetHashCode)
Metodo pubblico | GetName | (Sovrascrive DedBaseDbItemGetName)
Metodo pubblico | GetObjectType | (Sovrascrive DedBaseDbItemGetObjectType)
Metodo pubblico | GetProgr | Restituisce il progressivo dell'anagrafica. Letto da DED_DATA_ENCODE se compilato altrimenti lo ricalcola.
Metodo pubblico | GetValue(DedCommStandardCommFields) | Restituisce il contenuto di uno dei campi standard oppure null se non è presente.
Metodo pubblico | GetValue(DedDataStandardDataFields) |
Metodo pubblico | GetValue(String) | Restituisce il contenuto di un campo personalizzato oppure null se non esiste.
Metodo pubblico | IsAncestor | Controlla se l'id di commessa passato è presente nella concatenazione dei padri
Metodo pubblico | Liberate | Elimina le informazioni di ownership dalla commessa.
Metodo pubblico | Open | Riapre la commessa annullando utente e data di chiusura
Metodo pubblico | Requery | Aggiorna tutte le proprietà della commessa passata rileggendole dal Database. Se la commessa non esiste più solleva un'eccezione.
Metodo pubblico | SetValue(DedCommStandardCommFields, Object) | Imposta un campo standard con un nuovo valore. Se il campo non è compilato lo crea nel dizionario interno.
Metodo pubblico | SetValue(DedDataStandardDataFields, Object) |
Metodo pubblico | SetValue(String, Object) | Imposta un campo personalizzato con un nuovo valore. Se il campo non è compilato lo crea nel dizionario interno.
Metodo pubblico | ToString | Rappresentazione stringa dell'oggetto. (Sovrascrive ObjectToString)
Metodo pubblico | UnlinkParent | Elimina la commessa dalle collezioni dei padri
Metodo pubblico | UnlinkParents | Elimina la commessa dalle collezioni dei padri
Metodo pubblico | UpdateLastRevAnag | Aggiorna le anagrafiche di commessa all'ultima revisione salvata
Metodo pubblico | UserCan(DedStandardPerm) | Verifica se l'utente corrente ha un determinato permesso su questa commessa.
Metodo pubblico | UserCan(String) | Verifica se l'utente corrente ha un determinato permesso su questa commessa.
Metodo pubblico | Validate | Restituisce se i valori presenti validano gli attributi della famiglia di appartenenza.
Torna su
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Metodo DedComm.AddToCommEncode

Metodo DedCommAddToCommEncode
Aggiunge questa commessa alla tabella DED_COMM_ENCODE.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddToCommEncode(
    bool isAddOperation = true
)
Public Sub AddToCommEncode (
    Optional isAddOperation As Boolean = true
)
public:
void AddToCommEncode(
    bool isAddOperation = true
)
member AddToCommEncode :
        ?isAddOperation : bool
(* Defaults:
        let _isAddOperation = defaultArg isAddOperation true
*)
-> unit

Parametri

isAddOperation Boolean (Optional)
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Metodo DedComm.AddToErased

Metodo DedCommAddToErased
Aggiunge la commessa alla tabella degli eliminati. Una volta che la commessa è stata aggiunta alla tabella, verranno aggiornati i relativi campi in modo tale che sembrerà essere stata prima liberata e poi chiusa.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AddToErased()
Public Function AddToErased As Boolean
public:
bool AddToErased()
member AddToErased : unit -> bool

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Metodo DedComm.AttributeDictionary

Metodo DedCommAttributeDictionary
Restituisce un dizionario con le accoppiate attributo-valore per l'edita attributi.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDictionary AttributeDictionary()
Public Function AttributeDictionary As DedDictionary
public:
DedDictionary^ AttributeDictionary()
member AttributeDictionary : unit -> DedDictionary

Valore di ritorno

DedDictionary
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Metodo DedComm.Charge

Metodo DedCommCharge
Prende in carico la commessa con l'utente e la data corrente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Charge()
Public Sub Charge
public:
void Charge()
member Charge : unit -> unit
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Metodo DedComm.ClearPerm

Metodo DedCommClearPerm
Elimina tutti i permessi specifici sulla commessa.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ClearPerm()
Public Sub ClearPerm
public:
void ClearPerm()
member ClearPerm : unit -> unit
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Metodo DedComm.CloneStructure

Metodo DedCommCloneStructure
Crea la struttura della cartelle e file dal master passato

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void CloneStructure(
    DedComm master,
    string basePath = null
)
Public Sub CloneStructure (
    master As DedComm,
    Optional basePath As String = Nothing
)
public:
void CloneStructure(
    DedComm^ master,
    String^ basePath = nullptr
)
member CloneStructure :
        master : DedComm *
        ?basePath : string
(* Defaults:
        let _basePath = defaultArg basePath null
*)
-> unit

Parametri

master DedComm
Commessa master dalla quale copiare la struttura
basePath String (Optional)
Usato per la ricorsione (passare null alla prima chiamata)
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Metodo DedComm.Close

Metodo DedCommClose
Chiude la commessa impostando l'utente e la data di chiusura.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Close()
Public Sub Close
public:
void Close()
member Close : unit -> unit
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Metodo DedComm.Delete

Metodo DedCommDelete
Elimina la commessa dalla tabella principale e dalle tabelle di collegamento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Delete()
Public Sub Delete
public:
void Delete()
member Delete : unit -> unit
Eccezioni
Eccezione | Condizione
ArgumentNullException | Parametro mancante.
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Metodo DedComm.Equals

Metodo DedCommEquals
Override della definizione di equals.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj Object
Oggetto da confrontare.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Metodo DedComm.ForEachChild

Metodo DedCommForEachChild
Questo metodo chiama un delegate passandogli in sequenza il nodo corrente (opzionalmente) e tutti i suoi nodi figli.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ForEachChild(
    DedCommCallMeForEachNode deleg,
    bool IncludeCurrentNode,
    bool bOrizzontal
)
Public Function ForEachChild (
    deleg As DedCommCallMeForEachNode,
    IncludeCurrentNode As Boolean,
    bOrizzontal As Boolean
) As Boolean
public:
bool ForEachChild(
    DedCommCallMeForEachNode^ deleg,
    bool IncludeCurrentNode,
    bool bOrizzontal
)
member ForEachChild :
        deleg : DedCommCallMeForEachNode *
        IncludeCurrentNode : bool *
        bOrizzontal : bool -> bool

Parametri

deleg DedCommCallMeForEachNode
Delegate di tipo CallMeForEachNode da chiamare per ogni commessa.
IncludeCurrentNode Boolean
Se chiamare il delegate anche per il nodo corrente (del quale si stà invocando il metodo).
bOrizzontal Boolean
Indica al metodo di applicare la navigazione orizzontale invece di quella verticale.

Valore di ritorno

Boolean
Restituisce quello che è stato restituito dal delegate ovvero se il ciclo è stato svolto completamente o se è stato interrotto perché il delegate ha restituito false.
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Metodo DedComm.ForOneChild

Metodo DedCommForOneChild
Questo metodo chiama un delegate passandogli in sequenza il nodo corrente (opzionalmente) e tutti i suoi nodi figli.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ForOneChild(
    DedCommCallMeForEachNode deleg,
    bool IncludeCurrentNode,
    bool bOrizzontal
)
Public Function ForOneChild (
    deleg As DedCommCallMeForEachNode,
    IncludeCurrentNode As Boolean,
    bOrizzontal As Boolean
) As Boolean
public:
bool ForOneChild(
    DedCommCallMeForEachNode^ deleg,
    bool IncludeCurrentNode,
    bool bOrizzontal
)
member ForOneChild :
        deleg : DedCommCallMeForEachNode *
        IncludeCurrentNode : bool *
        bOrizzontal : bool -> bool

Parametri

deleg DedCommCallMeForEachNode
Delegate di tipo CallMeForEachNode da chiamare per ogni nodo, finchè non ne trova una che soddisfa il delegate.
IncludeCurrentNode Boolean
Se chiamare il delegate anche per il nodo corrente (del quale si stà invocando il metodo).
bOrizzontal Boolean
Indica al metodo di applicare la navigazione orizzontale invece di quella verticale.

Valore di ritorno

Boolean
Restituisce quello che è stato restituito dal delegate ovvero se il è presente almeno un nodo che lo soddisfa.
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Metodo DedComm.GetDescription

Metodo DedCommGetDescription

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string GetDescription()
Public Overrides Function GetDescription As String
public:
virtual String^ GetDescription() override
abstract GetDescription : unit -> string
override GetDescription : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Metodo DedComm.GetEcoList

Metodo DedCommGetEcoList
Metodo che ritorna tutti gli Eco associati alla commessa

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEcoList GetEcoList()
Public Function GetEcoList As DedEcoList
public:
DedEcoList^ GetEcoList()
member GetEcoList : unit -> DedEcoList

Valore di ritorno

DedEcoList
Lista di Eco collegati alla commessa.
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Metodo DedComm.GetHashCode

Metodo DedCommGetHashCode
Restituisce l'hashcode dell'oggetto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Metodo DedComm.GetName

Metodo DedCommGetName

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string GetName()
Public Overrides Function GetName As String
public:
virtual String^ GetName() override
abstract GetName : unit -> string
override GetName : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Metodo DedComm.GetObjectType

Metodo DedCommGetObjectType

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override DedDbItemType GetObjectType()
Public Overrides Function GetObjectType As DedDbItemType
public:
virtual DedDbItemType GetObjectType() override
abstract GetObjectType : unit -> DedDbItemType
override GetObjectType : unit -> DedDbItemType

Valore di ritorno

DedDbItemType
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Metodo DedComm.GetProgr

Metodo DedCommGetProgr
Restituisce il progressivo dell'anagrafica. Letto da DED_DATA_ENCODE se compilato altrimenti lo ricalcola.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string GetProgr()
Public Function GetProgr As String
public:
String^ GetProgr()
member GetProgr : unit -> string

Valore di ritorno

String
Restituisce il progressivo letto dall'anagrafica.
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Metodo DedComm.GetValue

Metodo DedCommGetValue
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | GetValue(DedCommStandardCommFields) | Restituisce il contenuto di uno dei campi standard oppure null se non è presente.
Metodo pubblico | GetValue(DedDataStandardDataFields) |
Metodo pubblico | GetValue(String) | Restituisce il contenuto di un campo personalizzato oppure null se non esiste.
Torna su
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Metodo DedComm.GetValue(DedComm.StandardCommFields)

Metodo DedCommGetValue(DedCommStandardCommFields)
Restituisce il contenuto di uno dei campi standard oppure null se non è presente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object GetValue(
    DedCommStandardCommFields stdfield
)
Public Function GetValue (
    stdfield As DedCommStandardCommFields
) As Object
public:
Object^ GetValue(
    DedCommStandardCommFields stdfield
)
member GetValue :
        stdfield : DedCommStandardCommFields -> Object

Parametri

stdfield DedCommStandardCommFields
Campo standard del quale avere il contenuto.

Valore di ritorno

Object
Vedi anche

Documentazione

Classe DedComm
Overload di GetValue
Namespace DedNet.Core


Metodo DedComm.GetValue(DedData.StandardDataFields)

Metodo DedCommGetValue(DedDataStandardDataFields)

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object GetValue(
    DedDataStandardDataFields stdfield
)
Public Function GetValue (
    stdfield As DedDataStandardDataFields
) As Object
public:
virtual Object^ GetValue(
    DedDataStandardDataFields stdfield
) sealed
abstract GetValue :
        stdfield : DedDataStandardDataFields -> Object
override GetValue :
        stdfield : DedDataStandardDataFields -> Object

Parametri

stdfield DedDataStandardDataFields

Valore di ritorno

Object

Implementa

IDedTypeEditableGetValue(DedDataStandardDataFields)
Vedi anche

Documentazione

Classe DedComm
Overload di GetValue
Namespace DedNet.Core


Metodo DedComm.GetValue(String)

Metodo DedCommGetValue(String)
Restituisce il contenuto di un campo personalizzato oppure null se non esiste.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object GetValue(
    string persfield
)
Public Function GetValue (
    persfield As String
) As Object
public:
virtual Object^ GetValue(
    String^ persfield
) sealed
abstract GetValue :
        persfield : string -> Object
override GetValue :
        persfield : string -> Object

Parametri

persfield String
Nome del campo personalizzato del quale avere il contenuto.

Valore di ritorno

Object

Implementa

IDedEditableGetValue(String)
Vedi anche

Documentazione

Classe DedComm
Overload di GetValue
Namespace DedNet.Core


Metodo DedComm.IsAncestor

Metodo DedCommIsAncestor
Controlla se l'id di commessa passato è presente nella concatenazione dei padri

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsAncestor(
    Guid commId
)
Public Function IsAncestor (
    commId As Guid
) As Boolean
public:
bool IsAncestor(
    Guid commId
)
member IsAncestor :
        commId : Guid -> bool

Parametri

commId Guid

Valore di ritorno

Boolean
Ritorna true se l'ID passato è un antenato
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Metodo DedComm.Liberate

Metodo DedCommLiberate
Elimina le informazioni di ownership dalla commessa.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Liberate(
    bool updatedb
)
Public Sub Liberate (
    updatedb As Boolean
)
public:
void Liberate(
    bool updatedb
)
member Liberate :
        updatedb : bool -> unit

Parametri

updatedb Boolean
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Metodo DedComm.Open

Metodo DedCommOpen
Riapre la commessa annullando utente e data di chiusura

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Open()
Public Sub Open
public:
void Open()
member Open : unit -> unit
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Metodo DedComm.Requery

Metodo DedCommRequery
Aggiorna tutte le proprietà della commessa passata rileggendole dal Database. Se la commessa non esiste più solleva un'eccezione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Requery()
Public Sub Requery
public:
void Requery()
member Requery : unit -> unit
Eccezioni
Eccezione | Condizione
ArgumentNullException | Parametro mancante.
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Metodo DedComm.SetValue

Metodo DedCommSetValue
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | SetValue(DedCommStandardCommFields, Object) | Imposta un campo standard con un nuovo valore. Se il campo non è compilato lo crea nel dizionario interno.
Metodo pubblico | SetValue(DedDataStandardDataFields, Object) |
Metodo pubblico | SetValue(String, Object) | Imposta un campo personalizzato con un nuovo valore. Se il campo non è compilato lo crea nel dizionario interno.
Torna su
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Metodo DedComm.SetValue(DedComm.StandardCommFields, Object)

Metodo DedCommSetValue(DedCommStandardCommFields, Object)
Imposta un campo standard con un nuovo valore. Se il campo non è compilato lo crea nel dizionario interno.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetValue(
    DedCommStandardCommFields stdfield,
    Object Value
)
Public Sub SetValue (
    stdfield As DedCommStandardCommFields,
    Value As Object
)
public:
void SetValue(
    DedCommStandardCommFields stdfield,
    Object^ Value
)
member SetValue :
        stdfield : DedCommStandardCommFields *
        Value : Object -> unit

Parametri

stdfield DedCommStandardCommFields
Campo standard da impostare.
Value Object
Valore da impostare.
Vedi anche

Documentazione

Classe DedComm
Overload di SetValue
Namespace DedNet.Core


Metodo DedComm.SetValue(DedData.StandardDataFields, Object)

Metodo DedCommSetValue(DedDataStandardDataFields, Object)

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetValue(
    DedDataStandardDataFields stdfield,
    Object Value
)
Public Sub SetValue (
    stdfield As DedDataStandardDataFields,
    Value As Object
)
public:
virtual void SetValue(
    DedDataStandardDataFields stdfield,
    Object^ Value
) sealed
abstract SetValue :
        stdfield : DedDataStandardDataFields *
        Value : Object -> unit
override SetValue :
        stdfield : DedDataStandardDataFields *
        Value : Object -> unit

Parametri

stdfield DedDataStandardDataFields
Value Object

Implementa

IDedTypeEditableSetValue(DedDataStandardDataFields, Object)
Vedi anche

Documentazione

Classe DedComm
Overload di SetValue
Namespace DedNet.Core


Metodo DedComm.SetValue(String, Object)

Metodo DedCommSetValue(String, Object)
Imposta un campo personalizzato con un nuovo valore. Se il campo non è compilato lo crea nel dizionario interno.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetValue(
    string persfield,
    Object value
)
Public Sub SetValue (
    persfield As String,
    value As Object
)
public:
virtual void SetValue(
    String^ persfield,
    Object^ value
) sealed
abstract SetValue :
        persfield : string *
        value : Object -> unit
override SetValue :
        persfield : string *
        value : Object -> unit

Parametri

persfield String
Nome del campo personalizzato da impostare.
value Object
Valore da impostare.

Implementa

IDedEditableSetValue(String, Object)
Vedi anche

Documentazione

Classe DedComm
Overload di SetValue
Namespace DedNet.Core


Metodo DedComm.ToString

Metodo DedCommToString
Rappresentazione stringa dell'oggetto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Metodo DedComm.UnlinkParent

Metodo DedCommUnlinkParent
Elimina la commessa dalle collezioni dei padri

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void UnlinkParent(
    DedComm commParent
)
Public Sub UnlinkParent (
    commParent As DedComm
)
public:
void UnlinkParent(
    DedComm^ commParent
)
member UnlinkParent :
        commParent : DedComm -> unit

Parametri

commParent DedComm
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Metodo DedComm.UnlinkParents

Metodo DedCommUnlinkParents
Elimina la commessa dalle collezioni dei padri

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void UnlinkParents()
Public Sub UnlinkParents
public:
void UnlinkParents()
member UnlinkParents : unit -> unit
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Metodo DedComm.UpdateLastRevAnag

Metodo DedCommUpdateLastRevAnag
Aggiorna le anagrafiche di commessa all'ultima revisione salvata

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void UpdateLastRevAnag()
Public Sub UpdateLastRevAnag
public:
void UpdateLastRevAnag()
member UpdateLastRevAnag : unit -> unit
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Metodo DedComm.UserCan

Metodo DedCommUserCan
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | UserCan(DedStandardPerm) | Verifica se l'utente corrente ha un determinato permesso su questa commessa.
Metodo pubblico | UserCan(String) | Verifica se l'utente corrente ha un determinato permesso su questa commessa.
Torna su
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Metodo DedComm.UserCan(DedStandardPerm)

Metodo DedCommUserCan(DedStandardPerm)
Verifica se l'utente corrente ha un determinato permesso su questa commessa.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool UserCan(
    DedStandardPerm perm
)
Public Function UserCan (
    perm As DedStandardPerm
) As Boolean
public:
bool UserCan(
    DedStandardPerm perm
)
member UserCan :
        perm : DedStandardPerm -> bool

Parametri

perm DedStandardPerm
Permesso standard da verificare.

Valore di ritorno

Boolean
Restituisce true se il permesso è concesso altrimenti false.
Vedi anche

Documentazione

Classe DedComm
Overload di UserCan
Namespace DedNet.Core


Metodo DedComm.UserCan(String)

Metodo DedCommUserCan(String)
Verifica se l'utente corrente ha un determinato permesso su questa commessa.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool UserCan(
    string permname
)
Public Function UserCan (
    permname As String
) As Boolean
public:
bool UserCan(
    String^ permname
)
member UserCan :
        permname : string -> bool

Parametri

permname String
Nome del permesso da verificare.

Valore di ritorno

Boolean
Restituisce true se il permesso è concesso altrimenti false.
Vedi anche

Documentazione

Classe DedComm
Overload di UserCan
Namespace DedNet.Core


Metodo DedComm.Validate

Metodo DedCommValidate
Restituisce se i valori presenti validano gli attributi della famiglia di appartenenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Validate(
    bool creating,
    bool revisioning,
    out string error
)
Public Function Validate (
    creating As Boolean,
    revisioning As Boolean,
    <OutAttribute> ByRef error As String
) As Boolean
public:
virtual bool Validate(
    bool creating,
    bool revisioning,
    [OutAttribute] String^% error
) sealed
abstract Validate :
        creating : bool *
        revisioning : bool *
        error : string byref -> bool
override Validate :
        creating : bool *
        revisioning : bool *
        error : string byref -> bool

Parametri

creating Boolean
revisioning Boolean
error String

Valore di ritorno

Boolean

Implementa

IDedTypeEditableValidate(Boolean, Boolean, String)
Vedi anche

Documentazione

Classe DedComm
Namespace DedNet.Core


Delegate DedComm.CallMeForEachNode

Delegate DedCommCallMeForEachNode
Delegate che serve per elaborare un singola commessa.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public delegate bool CallMeForEachNode(
    DedComm comm
)
Public Delegate Function CallMeForEachNode (
    comm As DedComm
) As Boolean
public delegate bool CallMeForEachNode(
    DedComm^ comm
)
type CallMeForEachNode =
    delegate of
        comm : DedComm -> bool

Parametri

comm DedComm
Commessa in elaborazione.

Valore di ritorno

Boolean
Restituisce true se il ciclo può continuare, false se deve essere interrotto.
Vedi anche

Documentazione

Namespace DedNet.Core


Enumerazione DedComm.CommKindEnum

Enumerazione DedCommCommKindEnum
Elenco dei possibili stati di commessa

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum CommKindEnum
Public Enumeration CommKindEnum
public enum class CommKindEnum
type CommKindEnum
Membri
Nome | Valore | Descrizione
Normal | 0 | Identifica una commmessa che NON è master
Master | 1 | Identifica una commmessa che è master
All | 100 | Tutti i tipi
Vedi anche

Documentazione

Namespace DedNet.Core


Classe DedComm.DedCommEncodeInfo

Classe DedCommDedCommEncodeInfo
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedCommDedCommEncodeInfo

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedCommEncodeInfo
Public Class DedCommEncodeInfo
public ref class DedCommEncodeInfo
type DedCommEncodeInfo = class end

Il tipo DedCommDedCommEncodeInfo espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedCommDedCommEncodeInfo | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | EncodedId | Codifica utilizzate per creare ID.
Proprietà pubblica | FreeCode |
Proprietà pubblica | ObjectCompleted |
Proprietà pubblica | Prog | Valore del tassello del progressivo
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | SetEncodedId | Aggiorna il campo interno senza aggiornare il DB
Metodo pubblico | SetFreeCode | Aggiorna il campo interno senza aggiornare il DB
Metodo pubblico | SetProg | Aggiorna il campo interno senza aggiornare il DB
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedComm.DedCommEncodeInfo

Costruttore DedCommDedCommEncodeInfo
Costruttore unico.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommEncodeInfo(
    DedNetApplication app,
    DedComm comm
)
Public Sub New (
    app As DedNetApplication,
    comm As DedComm
)
public:
DedCommEncodeInfo(
    DedNetApplication^ app,
    DedComm^ comm
)
new :
        app : DedNetApplication *
        comm : DedComm -> DedCommEncodeInfo

Parametri

app DedNetApplication
Applicazione DedNet.
comm DedComm
Vedi anche

Documentazione

Classe DedCommDedCommEncodeInfo
Namespace DedNet.Core


Proprietà di DedCommEncodeInfo

Il tipo DedCommDedCommEncodeInfo espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | EncodedId | Codifica utilizzate per creare ID.
Proprietà pubblica | FreeCode |
Proprietà pubblica | ObjectCompleted |
Proprietà pubblica | Prog | Valore del tassello del progressivo
Torna su
Vedi anche

Documentazione

Classe DedCommDedCommEncodeInfo
Namespace DedNet.Core


Proprietà DedComm.DedCommEncodeInfo.EncodedId

Proprietà DedCommDedCommEncodeInfoEncodedId
Codifica utilizzate per creare ID.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string EncodedId { get; set; }
Public Property EncodedId As String
    Get
    Set
public:
property String^ EncodedId {
    String^ get ();
    void set (String^ value);
}
member EncodedId : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedCommDedCommEncodeInfo
Namespace DedNet.Core


Proprietà DedComm.DedCommEncodeInfo.FreeCode

Proprietà DedCommDedCommEncodeInfoFreeCode

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool FreeCode { get; set; }
Public Property FreeCode As Boolean
    Get
    Set
public:
property bool FreeCode {
    bool get ();
    void set (bool value);
}
member FreeCode : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedCommDedCommEncodeInfo
Namespace DedNet.Core


Proprietà DedComm.DedCommEncodeInfo.ObjectCompleted

Proprietà DedCommDedCommEncodeInfoObjectCompleted

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ObjectCompleted { get; set; }
Public Property ObjectCompleted As Boolean
    Get
    Set
public:
property bool ObjectCompleted {
    bool get ();
    void set (bool value);
}
member ObjectCompleted : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedCommDedCommEncodeInfo
Namespace DedNet.Core


Proprietà DedComm.DedCommEncodeInfo.Prog

Proprietà DedCommDedCommEncodeInfoProg
Valore del tassello del progressivo

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Prog { get; set; }
Public Property Prog As String
    Get
    Set
public:
property String^ Prog {
    String^ get ();
    void set (String^ value);
}
member Prog : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedCommDedCommEncodeInfo
Namespace DedNet.Core


Metodi di DedCommEncodeInfo

Il tipo DedCommDedCommEncodeInfo espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | SetEncodedId | Aggiorna il campo interno senza aggiornare il DB
Metodo pubblico | SetFreeCode | Aggiorna il campo interno senza aggiornare il DB
Metodo pubblico | SetProg | Aggiorna il campo interno senza aggiornare il DB
Torna su
Vedi anche

Documentazione

Classe DedCommDedCommEncodeInfo
Namespace DedNet.Core


Metodo DedComm.DedCommEncodeInfo.SetEncodedId

Metodo DedCommDedCommEncodeInfoSetEncodedId
Aggiorna il campo interno senza aggiornare il DB

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetEncodedId(
    string encodeId
)
Public Sub SetEncodedId (
    encodeId As String
)
public:
void SetEncodedId(
    String^ encodeId
)
member SetEncodedId :
        encodeId : string -> unit

Parametri

encodeId String
Vedi anche

Documentazione

Classe DedCommDedCommEncodeInfo
Namespace DedNet.Core


Metodo DedComm.DedCommEncodeInfo.SetFreeCode

Metodo DedCommDedCommEncodeInfoSetFreeCode
Aggiorna il campo interno senza aggiornare il DB

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetFreeCode(
    bool fcode
)
Public Sub SetFreeCode (
    fcode As Boolean
)
public:
void SetFreeCode(
    bool fcode
)
member SetFreeCode :
        fcode : bool -> unit

Parametri

fcode Boolean
Vedi anche

Documentazione

Classe DedCommDedCommEncodeInfo
Namespace DedNet.Core


Metodo DedComm.DedCommEncodeInfo.SetProg

Metodo DedCommDedCommEncodeInfoSetProg
Aggiorna il campo interno senza aggiornare il DB

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetProg(
    string prog
)
Public Sub SetProg (
    prog As String
)
public:
void SetProg(
    String^ prog
)
member SetProg :
        prog : string -> unit

Parametri

prog String
Vedi anche

Documentazione

Classe DedCommDedCommEncodeInfo
Namespace DedNet.Core


Enumerazione DedComm.StandardCommFields

Enumerazione DedCommStandardCommFields
Elenco dei campi standard.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum StandardCommFields
Public Enumeration StandardCommFields
public enum class StandardCommFields
type StandardCommFields
Membri
Nome | Valore | Descrizione
DBPATH | 0 | DBPATH della commessa.
COMMID | 1 | ID della commessa.
COMMNAME | 2 | Nome della commessa.
COMMDESC | 3 | Descrizione della commessa.
CUSTOMER | 4 | Cliente per la quale è stata creata la commessa.
CREATIONDATE | 5 | Data di creazione della commessa.
CREATIONUSER | 6 | Utente che ha creato la commessa.
CLOSUREDATE | 7 | Data di chiusura della commessa.
CLOSUREUSER | 8 | Utente che ha chiuso la commessa.
MODDATE | 9 | Data di ultima modifica della commessa.
MODUSER | 10 | Utente che ha fatto l'ultima modificato alla commessa.
ROWVER | 11 | Versione del record.
FIRSTLEVVIS | 12 | Visibile a primo livello.
COMMNOTE | 13 |
OWNERUSER | 14 | Utente che ha preso in carico la commessa.
OWNINGDATE | 15 | Data di presa in carico della commessa.
COMMKIND | 16 | Indentifica il tipo specifico della commessa
Vedi anche

Documentazione

Namespace DedNet.Core


Classe DedCommAnagrCollection
Collezione di anagrafiche collegate ad una commessa.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedCommCollections
DedNet.CoreDedCommAnagrCollection

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedCommAnagrCollection : DedCommCollections
Public Class DedCommAnagrCollection
    Inherits DedCommCollections
public ref class DedCommAnagrCollection : public DedCommCollections
type DedCommAnagrCollection =
    class
        inherit DedCommCollections
    end

Il tipo DedCommAnagrCollection espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Count | Restituisce il numero di elementi presenti nella collezione. (Ereditato da DedCommCollections)
Proprietà protetta | FieldList | Restituisce la lista di tutti i campi presenti nella tabella. (Sovrascrive DedCommCollectionsFieldList)
Proprietà pubblica | Parent | Restituisce la commessa alla quale appartiene questa collection. (Ereditato da DedCommCollections)
Proprietà protetta | TableName | Restituisce il nome della tabella. (Sovrascrive DedCommCollectionsTableName)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Add(String, String) | Aggiunge un nuovo elemento alla collection.
Metodo pubblico | Add(String, String, Double, DictionaryString, Object) | Aggiunge un nuovo elemento alla collection.
Metodo pubblico | Clear | Elimina tutti gli elementi della collezione. (Ereditato da DedCommCollections)
Metodo pubblico | Contains | Restituisce true se contiene l'elemento richiesto altrimenti false. (Ereditato da DedCommCollections)
Metodo pubblico | ContainsFileName | Restituisce true se contiene l'elemento richiesto altrimenti false. (Ereditato da DedCommCollections)
Metodo pubblico | CopyTo | Copia gli elementi in un array. (Ereditato da DedCommCollections)
Metodo pubblico | Find(String) | Cerca l'elemento nella collection per dedid. Non controlla la revisione perchè nella commessa è un concetto labile.
Metodo pubblico | Find(String, String, DictionaryString, Object) | Cerca l'elemento nella collection per dedid.
Metodo pubblico | FindListAnagr(String) | Cerca l'elemento nella collection per dedid. Non controlla la revisione perchè nella commessa è un concetto labile.
Metodo pubblico | FindListAnagr(String, String) | Cerca l'elemento nella collection per dedid e per dedrev
Metodo pubblico | GetEnumerator | Restituisce l'enumeratore. (Ereditato da DedCommCollections)
Metodo pubblico | IndexOf | Restituisce l'indice di un elemento oppure -1 se non è presente. (Ereditato da DedCommCollections)
Metodo pubblico | Items | Restituisce l'elemento iesimo. (Ereditato da DedCommCollections)
Metodo protetto | MakeItem | Crea e restituisce un nuovo oggetto, utilizzando le informazioni correnti del DbDataReader passato. (Sovrascrive DedCommCollectionsMakeItem(DbDataReader))
Metodo pubblico | Reload | Rilegge l'intero contenuto della collezione dal Database. (Ereditato da DedCommCollections)
Metodo protetto | SetItemFields | Imposta tutti i campi dell'oggetto leggendoli dal DbDataReader. (Sovrascrive DedCommCollectionsSetItemFields(DbDataReader, DedCommCollectionItem))
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di DedCommAnagrCollection

Il tipo DedCommAnagrCollection espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Count | Restituisce il numero di elementi presenti nella collezione. (Ereditato da DedCommCollections)
Proprietà protetta | FieldList | Restituisce la lista di tutti i campi presenti nella tabella. (Sovrascrive DedCommCollectionsFieldList)
Proprietà pubblica | Parent | Restituisce la commessa alla quale appartiene questa collection. (Ereditato da DedCommCollections)
Proprietà protetta | TableName | Restituisce il nome della tabella. (Sovrascrive DedCommCollectionsTableName)
Torna su
Vedi anche

Documentazione

Classe DedCommAnagrCollection
Namespace DedNet.Core


Proprietà DedCommAnagrCollection.FieldList

Proprietà DedCommAnagrCollectionFieldList
Restituisce la lista di tutti i campi presenti nella tabella.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal override string[] FieldList { get; }
Protected Friend Overrides ReadOnly Property FieldList As String()
    Get
protected public:
virtual property array<String^>^ FieldList {
    array<String^>^ get () override;
}
abstract FieldList : string[] with get
override FieldList : string[] with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedCommAnagrCollection
Namespace DedNet.Core


Proprietà DedCommAnagrCollection.TableName

Proprietà DedCommAnagrCollectionTableName
Restituisce il nome della tabella.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal override string TableName { get; }
Protected Friend Overrides ReadOnly Property TableName As String
    Get
protected public:
virtual property String^ TableName {
    String^ get () override;
}
abstract TableName : string with get
override TableName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedCommAnagrCollection
Namespace DedNet.Core


Metodi di DedCommAnagrCollection

Il tipo DedCommAnagrCollection espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Add(String, String) | Aggiunge un nuovo elemento alla collection.
Metodo pubblico | Add(String, String, Double, DictionaryString, Object) | Aggiunge un nuovo elemento alla collection.
Metodo pubblico | Clear | Elimina tutti gli elementi della collezione. (Ereditato da DedCommCollections)
Metodo pubblico | Contains | Restituisce true se contiene l'elemento richiesto altrimenti false. (Ereditato da DedCommCollections)
Metodo pubblico | ContainsFileName | Restituisce true se contiene l'elemento richiesto altrimenti false. (Ereditato da DedCommCollections)
Metodo pubblico | CopyTo | Copia gli elementi in un array. (Ereditato da DedCommCollections)
Metodo pubblico | Find(String) | Cerca l'elemento nella collection per dedid. Non controlla la revisione perchè nella commessa è un concetto labile.
Metodo pubblico | Find(String, String, DictionaryString, Object) | Cerca l'elemento nella collection per dedid.
Metodo pubblico | FindListAnagr(String) | Cerca l'elemento nella collection per dedid. Non controlla la revisione perchè nella commessa è un concetto labile.
Metodo pubblico | FindListAnagr(String, String) | Cerca l'elemento nella collection per dedid e per dedrev
Metodo pubblico | GetEnumerator | Restituisce l'enumeratore. (Ereditato da DedCommCollections)
Metodo pubblico | IndexOf | Restituisce l'indice di un elemento oppure -1 se non è presente. (Ereditato da DedCommCollections)
Metodo pubblico | Items | Restituisce l'elemento iesimo. (Ereditato da DedCommCollections)
Metodo protetto | MakeItem | Crea e restituisce un nuovo oggetto, utilizzando le informazioni correnti del DbDataReader passato. (Sovrascrive DedCommCollectionsMakeItem(DbDataReader))
Metodo pubblico | Reload | Rilegge l'intero contenuto della collezione dal Database. (Ereditato da DedCommCollections)
Metodo protetto | SetItemFields | Imposta tutti i campi dell'oggetto leggendoli dal DbDataReader. (Sovrascrive DedCommCollectionsSetItemFields(DbDataReader, DedCommCollectionItem))
Torna su
Vedi anche

Documentazione

Classe DedCommAnagrCollection
Namespace DedNet.Core


Metodo DedCommAnagrCollection.Add

Metodo DedCommAnagrCollectionAdd
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Add(String, String) | Aggiunge un nuovo elemento alla collection.
Metodo pubblico | Add(String, String, Double, DictionaryString, Object) | Aggiunge un nuovo elemento alla collection.
Torna su
Vedi anche

Documentazione

Classe DedCommAnagrCollection
Namespace DedNet.Core


Metodo DedCommAnagrCollection.Add(String, String)

Metodo DedCommAnagrCollectionAdd(String, String)
Aggiunge un nuovo elemento alla collection.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommAnagrItem Add(
    string dedid,
    string dedrev
)
Public Function Add (
    dedid As String,
    dedrev As String
) As DedCommAnagrItem
public:
DedCommAnagrItem^ Add(
    String^ dedid,
    String^ dedrev
)
member Add :
        dedid : string *
        dedrev : string -> DedCommAnagrItem

Parametri

dedid String
DedId dell'anagrafica da collegare.
dedrev String
DedRev dell'anagrafica da collegare.

Valore di ritorno

DedCommAnagrItem
Eccezioni
Eccezione | Condizione
ArgumentNullException | Parametro mancante.
QsException | Errore avvenuto durante l'istruzione d'inserimento.
Vedi anche

Documentazione

Classe DedCommAnagrCollection
Overload di Add
Namespace DedNet.Core


Metodo DedCommAnagrCollection.Add(String, String, Double, Dictionary<String, Object>)

Metodo DedCommAnagrCollectionAdd(String, String, Double, DictionaryString, Object)
Aggiunge un nuovo elemento alla collection.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommAnagrItem Add(
    string dedid,
    string dedrev,
    double qta,
    Dictionary<string, Object> commAnagAttrs
)
Public Function Add (
    dedid As String,
    dedrev As String,
    qta As Double,
    commAnagAttrs As Dictionary(Of String, Object)
) As DedCommAnagrItem
public:
DedCommAnagrItem^ Add(
    String^ dedid,
    String^ dedrev,
    double qta,
    Dictionary<String^, Object^>^ commAnagAttrs
)
member Add :
        dedid : string *
        dedrev : string *
        qta : float *
        commAnagAttrs : Dictionary<string, Object> -> DedCommAnagrItem

Parametri

dedid String
DedId dell'anagrafica da collegare.
dedrev String
DedRev dell'anagrafica da collegare.
qta Double
Qta dell'anagrafica da collegare
commAnagAttrs Dictionary String, Object
Attributi di anagrafica di commessa

Valore di ritorno

DedCommAnagrItem
Eccezioni
Eccezione | Condizione
ArgumentNullException | Parametro mancante.
QsException | Errore avvenuto durante l'istruzione d'inserimento.
Vedi anche

Documentazione

Classe DedCommAnagrCollection
Overload di Add
Namespace DedNet.Core


Metodo DedCommAnagrCollection.Find

Metodo DedCommAnagrCollectionFind
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Find(String) | Cerca l'elemento nella collection per dedid. Non controlla la revisione perchè nella commessa è un concetto labile.
Metodo pubblico | Find(String, String, DictionaryString, Object) | Cerca l'elemento nella collection per dedid.
Torna su
Vedi anche

Documentazione

Classe DedCommAnagrCollection
Namespace DedNet.Core


Metodo DedCommAnagrCollection.Find(String)

Metodo DedCommAnagrCollectionFind(String)
Cerca l'elemento nella collection per dedid. Non controlla la revisione perchè nella commessa è un concetto labile.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommAnagrItem Find(
    string dedid
)
Public Function Find (
    dedid As String
) As DedCommAnagrItem
public:
DedCommAnagrItem^ Find(
    String^ dedid
)
member Find :
        dedid : string -> DedCommAnagrItem

Parametri

dedid String
ID dell'anagrafica da cercare.

Valore di ritorno

DedCommAnagrItem
Ritorna l'elemento specifico o null se fallisce.
Vedi anche

Documentazione

Classe DedCommAnagrCollection
Overload di Find
Namespace DedNet.Core


Metodo DedCommAnagrCollection.Find(String, String, Dictionary<String, Object>)

Metodo DedCommAnagrCollectionFind(String, String, DictionaryString, Object)
Cerca l'elemento nella collection per dedid.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommAnagrItem Find(
    string dedid,
    string dedrev,
    Dictionary<string, Object> searchDiscrimValues
)
Public Function Find (
    dedid As String,
    dedrev As String,
    searchDiscrimValues As Dictionary(Of String, Object)
) As DedCommAnagrItem
public:
DedCommAnagrItem^ Find(
    String^ dedid,
    String^ dedrev,
    Dictionary<String^, Object^>^ searchDiscrimValues
)
member Find :
        dedid : string *
        dedrev : string *
        searchDiscrimValues : Dictionary<string, Object> -> DedCommAnagrItem

Parametri

dedid String
ID dell'anagrafica da cercare.
dedrev String
ID dell'anagrafica da cercare.
searchDiscrimValues Dictionary String, Object
Dizionario con i valori discriminanti da cercare

Valore di ritorno

DedCommAnagrItem
Ritorna l'elemento specifico o null se fallisce.
Vedi anche

Documentazione

Classe DedCommAnagrCollection
Overload di Find
Namespace DedNet.Core


Metodo DedCommAnagrCollection.FindListAnagr

Metodo DedCommAnagrCollectionFindListAnagr
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | FindListAnagr(String) | Cerca l'elemento nella collection per dedid. Non controlla la revisione perchè nella commessa è un concetto labile.
Metodo pubblico | FindListAnagr(String, String) | Cerca l'elemento nella collection per dedid e per dedrev
Torna su
Vedi anche

Documentazione

Classe DedCommAnagrCollection
Namespace DedNet.Core


Metodo DedCommAnagrCollection.FindListAnagr(String)

Metodo DedCommAnagrCollectionFindListAnagr(String)
Cerca l'elemento nella collection per dedid. Non controlla la revisione perchè nella commessa è un concetto labile.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<DedCommAnagrItem> FindListAnagr(
    string dedid
)
Public Function FindListAnagr (
    dedid As String
) As List(Of DedCommAnagrItem)
public:
List<DedCommAnagrItem^>^ FindListAnagr(
    String^ dedid
)
member FindListAnagr :
        dedid : string -> List<DedCommAnagrItem>

Parametri

dedid String
ID dell'anagrafica da cercare.

Valore di ritorno

List DedCommAnagrItem
Ritorna l'elemento specifico o null se fallisce.
Vedi anche

Documentazione

Classe DedCommAnagrCollection
Overload di FindListAnagr
Namespace DedNet.Core


Metodo DedCommAnagrCollection.FindListAnagr(String, String)

Metodo DedCommAnagrCollectionFindListAnagr(String, String)
Cerca l'elemento nella collection per dedid e per dedrev

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<DedCommAnagrItem> FindListAnagr(
    string dedid,
    string dedrev
)
Public Function FindListAnagr (
    dedid As String,
    dedrev As String
) As List(Of DedCommAnagrItem)
public:
List<DedCommAnagrItem^>^ FindListAnagr(
    String^ dedid,
    String^ dedrev
)
member FindListAnagr :
        dedid : string *
        dedrev : string -> List<DedCommAnagrItem>

Parametri

dedid String
ID dell'anagrafica da cercare.
dedrev String
ID dell'anagrafica da cercare.

Valore di ritorno

List DedCommAnagrItem
Ritorna l'elemento specifico o null se fallisce.
Vedi anche

Documentazione

Classe DedCommAnagrCollection
Overload di FindListAnagr
Namespace DedNet.Core


Metodo DedCommAnagrCollection.MakeItem

Metodo DedCommAnagrCollectionMakeItem
Crea e restituisce un nuovo oggetto, utilizzando le informazioni correnti del DbDataReader passato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCommCollectionItem MakeItem(
    DbDataReader dr
)
Protected Overrides Function MakeItem (
    dr As DbDataReader
) As DedCommCollectionItem
protected:
virtual DedCommCollectionItem^ MakeItem(
    DbDataReader^ dr
) override
abstract MakeItem :
        dr : DbDataReader -> DedCommCollectionItem
override MakeItem :
        dr : DbDataReader -> DedCommCollectionItem

Parametri

dr DbDataReader
Oggetto DbDataReader inizializzato e puntante al record di interesse.

Valore di ritorno

DedCommCollectionItem
Vedi anche

Documentazione

Classe DedCommAnagrCollection
Namespace DedNet.Core


Metodo DedCommAnagrCollection.SetItemFields

Metodo DedCommAnagrCollectionSetItemFields
Imposta tutti i campi dell'oggetto leggendoli dal DbDataReader.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal override void SetItemFields(
    DbDataReader dr,
    DedCommCollectionItem dedCommCollectionItem
)
Protected Friend Overrides Sub SetItemFields (
    dr As DbDataReader,
    dedCommCollectionItem As DedCommCollectionItem
)
protected public:
virtual void SetItemFields(
    DbDataReader^ dr,
    DedCommCollectionItem^ dedCommCollectionItem
) override
abstract SetItemFields :
        dr : DbDataReader *
        dedCommCollectionItem : DedCommCollectionItem -> unit
override SetItemFields :
        dr : DbDataReader *
        dedCommCollectionItem : DedCommCollectionItem -> unit

Parametri

dr DbDataReader
Oggetto DbDataReader inizializzato e puntante al record di interesse.
dedCommCollectionItem DedCommCollectionItem
Oggetto da aggiornare.
Vedi anche

Documentazione

Classe DedCommAnagrCollection
Namespace DedNet.Core


Classe DedCommAnagrItem
Descrive un legame tra commessa ed anagrafica.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedCommCollectionItem
DedNet.CoreDedCommAnagrItem

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedCommAnagrItem : DedCommCollectionItem
Public Class DedCommAnagrItem
    Inherits DedCommCollectionItem
public ref class DedCommAnagrItem : public DedCommCollectionItem
type DedCommAnagrItem =
    class
        inherit DedCommCollectionItem
    end

Il tipo DedCommAnagrItem espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Anagr | Restituisce l'anagrafica riferita a questo oggetto oppure null se non è presente nel Database. Se la commessa contenente il riferimento è chiusa restituisce l'esatta anagrafica corrispondente al DedID e DedRev di questo elemento, se invece è in lavorazione restituisce l'ultima revisione, dando precedenza alla eventuale revisione rilasciata presente, per il codice.
Proprietà pubblica | AnagrCommAttrs | Dizionario contenente i valori degli attributi di anagrafica di commessa.
Proprietà pubblica | AssocDate | Restituisce o imposta la data di associazione. Impostando questa proprietà si ottiene l'immediato aggiornamento nel Database. (Ereditato da DedCommCollectionItem)
Proprietà pubblica | AssocUser | Restituisce o imposta l'utente che ha effettuato l'associazione. Impostando questa proprietà si ottiene l'immediato aggiornamento nel Database. (Ereditato da DedCommCollectionItem)
Proprietà pubblica | DedId | Restituisce o imposta il DedId dell'anagrafica collegata. Impostando questa proprietà si ottiene l'immediato aggiornamento nel Database.
Proprietà pubblica | DedRev | Restituisce o imposta il DedRev dell'anagrafica collegata. Impostando questa proprietà si ottiene l'immediato aggiornamento nel Database.
Proprietà protetta | IgnoreDirty | Restituisce se ignorare le modifiche. (Ereditato da DedCommCollectionItem)
Proprietà pubblica | ModDate | Restituisce la data di ultima modifica. Impostando questa proprietà si ottiene l'immediato aggiornamento nel Database. (Ereditato da DedCommCollectionItem)
Proprietà pubblica | ModUser | Restituisce l'utente dell'ultima modifica. Impostando questa proprietà si ottiene l'immediato aggiornamento nel Database. (Ereditato da DedCommCollectionItem)
Proprietà pubblica | Owner | Restituisce la collezione di appartenenza. (Ereditato da DedCommCollectionItem)
Proprietà pubblica | Qta | Restituisce o imposta la Qta di questo elemento. Impostando questa proprietà si ottiene l'immediato aggiornamento nel Database.
Proprietà pubblica | RowVer | Restituisce la versione del record. (Ereditato da DedCommCollectionItem)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | AddFieldsValues | Aggiunge i valori dei campi da aggiornare escluso il ROWVER, MODDATE e MODUSER, ASSOCDATE e ASSOCUSER che vengono impostati dalla classe base. (Sovrascrive DedCommCollectionItemAddFieldsValues(QSUpdateCommand))
Metodo protetto | AddWhereItemStatement | Aggiunge la calusola where per l'elemento escluso il COMMID che viene impostato nella classe base. (Sovrascrive DedCommCollectionItemAddWhereItemStatement(QSCommandBase))
Metodo protetto | AddWhereStatement | Aggiunge al comando la clausola where senza l'inclusione del ROWVER. (Ereditato da DedCommCollectionItem)
Metodo pubblico | CloneForCheckDuplicate | Clona l'oggetto e gli imposta gli attributi passati
Metodo pubblico | Delete | Elimina questo elemento dalla collezione di appartenenza. (Ereditato da DedCommCollectionItem)
Metodo protetto | EndUpdate | Chiamato alla fine dell'update. (Sovrascrive DedCommCollectionItemEndUpdate)
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | GetValue | Restituisce il valore dell'attributo
Metodo pubblico | Requery | Rilegge tutte le informazioni dal Database. (Ereditato da DedCommCollectionItem)
Metodo pubblico | SetValue | Imposta il valore nell'attributo
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Metodo protetto | Update | Aggiorna l'oggetto nel Database. (Ereditato da DedCommCollectionItem)
Metodo pubblico | UpdateData | Esegue un aggiornamento dei dati nel DB.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di DedCommAnagrItem

Il tipo DedCommAnagrItem espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Anagr | Restituisce l'anagrafica riferita a questo oggetto oppure null se non è presente nel Database. Se la commessa contenente il riferimento è chiusa restituisce l'esatta anagrafica corrispondente al DedID e DedRev di questo elemento, se invece è in lavorazione restituisce l'ultima revisione, dando precedenza alla eventuale revisione rilasciata presente, per il codice.
Proprietà pubblica | AnagrCommAttrs | Dizionario contenente i valori degli attributi di anagrafica di commessa.
Proprietà pubblica | AssocDate | Restituisce o imposta la data di associazione. Impostando questa proprietà si ottiene l'immediato aggiornamento nel Database. (Ereditato da DedCommCollectionItem)
Proprietà pubblica | AssocUser | Restituisce o imposta l'utente che ha effettuato l'associazione. Impostando questa proprietà si ottiene l'immediato aggiornamento nel Database. (Ereditato da DedCommCollectionItem)
Proprietà pubblica | DedId | Restituisce o imposta il DedId dell'anagrafica collegata. Impostando questa proprietà si ottiene l'immediato aggiornamento nel Database.
Proprietà pubblica | DedRev | Restituisce o imposta il DedRev dell'anagrafica collegata. Impostando questa proprietà si ottiene l'immediato aggiornamento nel Database.
Proprietà protetta | IgnoreDirty | Restituisce se ignorare le modifiche. (Ereditato da DedCommCollectionItem)
Proprietà pubblica | ModDate | Restituisce la data di ultima modifica. Impostando questa proprietà si ottiene l'immediato aggiornamento nel Database. (Ereditato da DedCommCollectionItem)
Proprietà pubblica | ModUser | Restituisce l'utente dell'ultima modifica. Impostando questa proprietà si ottiene l'immediato aggiornamento nel Database. (Ereditato da DedCommCollectionItem)
Proprietà pubblica | Owner | Restituisce la collezione di appartenenza. (Ereditato da DedCommCollectionItem)
Proprietà pubblica | Qta | Restituisce o imposta la Qta di questo elemento. Impostando questa proprietà si ottiene l'immediato aggiornamento nel Database.
Proprietà pubblica | RowVer | Restituisce la versione del record. (Ereditato da DedCommCollectionItem)
Torna su
Vedi anche

Documentazione

Classe DedCommAnagrItem
Namespace DedNet.Core


Proprietà DedCommAnagrItem.Anagr

Proprietà DedCommAnagrItemAnagr
Restituisce l'anagrafica riferita a questo oggetto oppure null se non è presente nel Database. Se la commessa contenente il riferimento è chiusa restituisce l'esatta anagrafica corrispondente al DedID e DedRev di questo elemento, se invece è in lavorazione restituisce l'ultima revisione, dando precedenza alla eventuale revisione rilasciata presente, per il codice.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Anagr { get; }
Public ReadOnly Property Anagr As DedData
    Get
public:
property DedData^ Anagr {
    DedData^ get ();
}
member Anagr : DedData with get

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe DedCommAnagrItem
Namespace DedNet.Core


Proprietà DedCommAnagrItem.AnagrCommAttrs

Proprietà DedCommAnagrItemAnagrCommAttrs
Dizionario contenente i valori degli attributi di anagrafica di commessa.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<string, Object> AnagrCommAttrs { get; }
Public ReadOnly Property AnagrCommAttrs As Dictionary(Of String, Object)
    Get
public:
property Dictionary<String^, Object^>^ AnagrCommAttrs {
    Dictionary<String^, Object^>^ get ();
}
member AnagrCommAttrs : Dictionary<string, Object> with get

Valore della proprietà

Dictionary String, Object
Vedi anche

Documentazione

Classe DedCommAnagrItem
Namespace DedNet.Core


Proprietà DedCommAnagrItem.DedId

Proprietà DedCommAnagrItemDedId
Restituisce o imposta il DedId dell'anagrafica collegata. Impostando questa proprietà si ottiene l'immediato aggiornamento nel Database.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string DedId { get; set; }
Public Property DedId As String
    Get
    Set
public:
property String^ DedId {
    String^ get ();
    void set (String^ value);
}
member DedId : string with get, set

Valore della proprietà

String
Eccezioni
Eccezione | Condizione
QsException | Record non trovato con id e versione dell'oggetto.
QsException | Viene sollevata in caso di errore nell'istruzione di aggiornamento dati.
Vedi anche

Documentazione

Classe DedCommAnagrItem
Namespace DedNet.Core


Proprietà DedCommAnagrItem.DedRev

Proprietà DedCommAnagrItemDedRev
Restituisce o imposta il DedRev dell'anagrafica collegata. Impostando questa proprietà si ottiene l'immediato aggiornamento nel Database.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string DedRev { get; set; }
Public Property DedRev As String
    Get
    Set
public:
property String^ DedRev {
    String^ get ();
    void set (String^ value);
}
member DedRev : string with get, set

Valore della proprietà

String
Eccezioni
Eccezione | Condizione
QsException | Record non trovato con id e versione dell'oggetto.
QsException | Viene sollevata in caso di errore nell'istruzione di aggiornamento dati.
Vedi anche

Documentazione

Classe DedCommAnagrItem
Namespace DedNet.Core


Proprietà DedCommAnagrItem.Qta

Proprietà DedCommAnagrItemQta
Restituisce o imposta la Qta di questo elemento. Impostando questa proprietà si ottiene l'immediato aggiornamento nel Database.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public double Qta { get; set; }
Public Property Qta As Double
    Get
    Set
public:
property double Qta {
    double get ();
    void set (double value);
}
member Qta : float with get, set

Valore della proprietà

Double
Eccezioni
Eccezione | Condizione
QsException | Record non trovato con id e versione dell'oggetto.
QsException | Viene sollevata in caso di errore nell'istruzione di aggiornamento dati.
Vedi anche

Documentazione

Classe DedCommAnagrItem
Namespace DedNet.Core


Metodi di DedCommAnagrItem

Il tipo DedCommAnagrItem espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | AddFieldsValues | Aggiunge i valori dei campi da aggiornare escluso il ROWVER, MODDATE e MODUSER, ASSOCDATE e ASSOCUSER che vengono impostati dalla classe base. (Sovrascrive DedCommCollectionItemAddFieldsValues(QSUpdateCommand))
Metodo protetto | AddWhereItemStatement | Aggiunge la calusola where per l'elemento escluso il COMMID che viene impostato nella classe base. (Sovrascrive DedCommCollectionItemAddWhereItemStatement(QSCommandBase))
Metodo protetto | AddWhereStatement | Aggiunge al comando la clausola where senza l'inclusione del ROWVER. (Ereditato da DedCommCollectionItem)
Metodo pubblico | CloneForCheckDuplicate | Clona l'oggetto e gli imposta gli attributi passati
Metodo pubblico | Delete | Elimina questo elemento dalla collezione di appartenenza. (Ereditato da DedCommCollectionItem)
Metodo protetto | EndUpdate | Chiamato alla fine dell'update. (Sovrascrive DedCommCollectionItemEndUpdate)
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | GetValue | Restituisce il valore dell'attributo
Metodo pubblico | Requery | Rilegge tutte le informazioni dal Database. (Ereditato da DedCommCollectionItem)
Metodo pubblico | SetValue | Imposta il valore nell'attributo
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Metodo protetto | Update | Aggiorna l'oggetto nel Database. (Ereditato da DedCommCollectionItem)
Metodo pubblico | UpdateData | Esegue un aggiornamento dei dati nel DB.
Torna su
Vedi anche

Documentazione

Classe DedCommAnagrItem
Namespace DedNet.Core


Metodo DedCommAnagrItem.AddFieldsValues

Metodo DedCommAnagrItemAddFieldsValues
Aggiunge i valori dei campi da aggiornare escluso il ROWVER, MODDATE e MODUSER, ASSOCDATE e ASSOCUSER che vengono impostati dalla classe base.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void AddFieldsValues(
    QSUpdateCommand cmd
)
Protected Overrides Sub AddFieldsValues (
    cmd As QSUpdateCommand
)
protected:
virtual void AddFieldsValues(
    QSUpdateCommand^ cmd
) override
abstract AddFieldsValues :
        cmd : QSUpdateCommand -> unit
override AddFieldsValues :
        cmd : QSUpdateCommand -> unit

Parametri

cmd QSUpdateCommand
Comando di update nel quale impostare i valori dei campi.
Vedi anche

Documentazione

Classe DedCommAnagrItem
Namespace DedNet.Core


Metodo DedCommAnagrItem.AddWhereItemStatement

Metodo DedCommAnagrItemAddWhereItemStatement
Aggiunge la calusola where per l'elemento escluso il COMMID che viene impostato nella classe base.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void AddWhereItemStatement(
    QSCommandBase cmd
)
Protected Overrides Sub AddWhereItemStatement (
    cmd As QSCommandBase
)
protected:
virtual void AddWhereItemStatement(
    QSCommandBase^ cmd
) override
abstract AddWhereItemStatement :
        cmd : QSCommandBase -> unit
override AddWhereItemStatement :
        cmd : QSCommandBase -> unit

Parametri

cmd QSCommandBase
Comando nel quale impostare la clausola where.
Vedi anche

Documentazione

Classe DedCommAnagrItem
Namespace DedNet.Core


Metodo DedCommAnagrItem.CloneForCheckDuplicate

Metodo DedCommAnagrItemCloneForCheckDuplicate
Clona l'oggetto e gli imposta gli attributi passati

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommAnagrItem CloneForCheckDuplicate(
    Dictionary<string, Object> attrs
)
Public Function CloneForCheckDuplicate (
    attrs As Dictionary(Of String, Object)
) As DedCommAnagrItem
public:
DedCommAnagrItem^ CloneForCheckDuplicate(
    Dictionary<String^, Object^>^ attrs
)
member CloneForCheckDuplicate :
        attrs : Dictionary<string, Object> -> DedCommAnagrItem

Parametri

attrs Dictionary String, Object
attributi da impostare

Valore di ritorno

DedCommAnagrItem
Vedi anche

Documentazione

Classe DedCommAnagrItem
Namespace DedNet.Core


Metodo DedCommAnagrItem.EndUpdate

Metodo DedCommAnagrItemEndUpdate
Chiamato alla fine dell'update.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void EndUpdate()
Protected Overrides Sub EndUpdate
protected:
virtual void EndUpdate() override
abstract EndUpdate : unit -> unit
override EndUpdate : unit -> unit
Vedi anche

Documentazione

Classe DedCommAnagrItem
Namespace DedNet.Core


Metodo DedCommAnagrItem.Equals

Metodo DedCommAnagrItemEquals

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj Object

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedCommAnagrItem
Namespace DedNet.Core


Metodo DedCommAnagrItem.GetHashCode

Metodo DedCommAnagrItemGetHashCode

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedCommAnagrItem
Namespace DedNet.Core


Metodo DedCommAnagrItem.GetValue

Metodo DedCommAnagrItemGetValue
Restituisce il valore dell'attributo

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object GetValue(
    string nome
)
Public Function GetValue (
    nome As String
) As Object
public:
Object^ GetValue(
    String^ nome
)
member GetValue :
        nome : string -> Object

Parametri

nome String
Nome dell'attributo

Valore di ritorno

Object
Vedi anche

Documentazione

Classe DedCommAnagrItem
Namespace DedNet.Core


Metodo DedCommAnagrItem.SetValue

Metodo DedCommAnagrItemSetValue
Imposta il valore nell'attributo

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetValue(
    string nome,
    Object val
)
Public Sub SetValue (
    nome As String,
    val As Object
)
public:
void SetValue(
    String^ nome,
    Object^ val
)
member SetValue :
        nome : string *
        val : Object -> unit

Parametri

nome String
Nome dell'attributo
val Object
Valore da impostare
Vedi anche

Documentazione

Classe DedCommAnagrItem
Namespace DedNet.Core


Metodo DedCommAnagrItem.ToString

Metodo DedCommAnagrItemToString

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedCommAnagrItem
Namespace DedNet.Core


Metodo DedCommAnagrItem.UpdateData

Metodo DedCommAnagrItemUpdateData
Esegue un aggiornamento dei dati nel DB.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void UpdateData()
Public Sub UpdateData
public:
void UpdateData()
member UpdateData : unit -> unit
Vedi anche

Documentazione

Classe DedCommAnagrItem
Namespace DedNet.Core


Classe DedCommCollectionItem
Classe base per gli elementi legati alla commessa.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedCommCollectionItem
DedNet.CoreDedCommAnagrItem
DedNet.CoreDedCommCommItem
DedNet.CoreDedCommDocItem

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public abstract class DedCommCollectionItem
Public MustInherit Class DedCommCollectionItem
public ref class DedCommCollectionItem abstract
[<AbstractClassAttribute>]
type DedCommCollectionItem = class end

Il tipo DedCommCollectionItem espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AssocDate | Restituisce o imposta la data di associazione. Impostando questa proprietà si ottiene l'immediato aggiornamento nel Database.
Proprietà pubblica | AssocUser | Restituisce o imposta l'utente che ha effettuato l'associazione. Impostando questa proprietà si ottiene l'immediato aggiornamento nel Database.
Proprietà protetta | IgnoreDirty | Restituisce se ignorare le modifiche.
Proprietà pubblica | ModDate | Restituisce la data di ultima modifica. Impostando questa proprietà si ottiene l'immediato aggiornamento nel Database.
Proprietà pubblica | ModUser | Restituisce l'utente dell'ultima modifica. Impostando questa proprietà si ottiene l'immediato aggiornamento nel Database.
Proprietà pubblica | Owner | Restituisce la collezione di appartenenza.
Proprietà pubblica | RowVer | Restituisce la versione del record.
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | AddFieldsValues |
Metodo protetto | AddWhereItemStatement |
Metodo protetto | AddWhereStatement | Aggiunge al comando la clausola where senza l'inclusione del ROWVER.
Metodo pubblico | Delete | Elimina questo elemento dalla collezione di appartenenza.
Metodo protetto | EndUpdate |
Metodo pubblico | Requery | Rilegge tutte le informazioni dal Database.
Metodo protetto | Update | Aggiorna l'oggetto nel Database.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di DedCommCollectionItem

Il tipo DedCommCollectionItem espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AssocDate | Restituisce o imposta la data di associazione. Impostando questa proprietà si ottiene l'immediato aggiornamento nel Database.
Proprietà pubblica | AssocUser | Restituisce o imposta l'utente che ha effettuato l'associazione. Impostando questa proprietà si ottiene l'immediato aggiornamento nel Database.
Proprietà protetta | IgnoreDirty | Restituisce se ignorare le modifiche.
Proprietà pubblica | ModDate | Restituisce la data di ultima modifica. Impostando questa proprietà si ottiene l'immediato aggiornamento nel Database.
Proprietà pubblica | ModUser | Restituisce l'utente dell'ultima modifica. Impostando questa proprietà si ottiene l'immediato aggiornamento nel Database.
Proprietà pubblica | Owner | Restituisce la collezione di appartenenza.
Proprietà pubblica | RowVer | Restituisce la versione del record.
Torna su
Vedi anche

Documentazione

Classe DedCommCollectionItem
Namespace DedNet.Core


Proprietà DedCommCollectionItem.AssocDate

Proprietà DedCommCollectionItemAssocDate
Restituisce o imposta la data di associazione. Impostando questa proprietà si ottiene l'immediato aggiornamento nel Database.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DateTime? AssocDate { get; set; }
Public Property AssocDate As DateTime?
    Get
    Set
public:
property Nullable<DateTime> AssocDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
member AssocDate : Nullable<DateTime> with get, set

Valore della proprietà

Nullable DateTime
Eccezioni
Eccezione | Condizione
QsException | Record non trovato con id e versione dell'oggetto.
QsException | Viene sollevata in caso di errore nell'istruzione di aggiornamento dati.
Vedi anche

Documentazione

Classe DedCommCollectionItem
Namespace DedNet.Core


Proprietà DedCommCollectionItem.AssocUser

Proprietà DedCommCollectionItemAssocUser
Restituisce o imposta l'utente che ha effettuato l'associazione. Impostando questa proprietà si ottiene l'immediato aggiornamento nel Database.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string AssocUser { get; set; }
Public Property AssocUser As String
    Get
    Set
public:
property String^ AssocUser {
    String^ get ();
    void set (String^ value);
}
member AssocUser : string with get, set

Valore della proprietà

String
Eccezioni
Eccezione | Condizione
QsException | Record non trovato con id e versione dell'oggetto.
QsException | Viene sollevata in caso di errore nell'istruzione di aggiornamento dati.
Vedi anche

Documentazione

Classe DedCommCollectionItem
Namespace DedNet.Core


Proprietà DedCommCollectionItem.IgnoreDirty

Proprietà DedCommCollectionItemIgnoreDirty
Restituisce se ignorare le modifiche.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected bool IgnoreDirty { get; }
Protected ReadOnly Property IgnoreDirty As Boolean
    Get
protected:
property bool IgnoreDirty {
    bool get ();
}
member IgnoreDirty : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedCommCollectionItem
Namespace DedNet.Core


Proprietà DedCommCollectionItem.ModDate

Proprietà DedCommCollectionItemModDate
Restituisce la data di ultima modifica. Impostando questa proprietà si ottiene l'immediato aggiornamento nel Database.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DateTime? ModDate { get; set; }
Public Property ModDate As DateTime?
    Get
    Set
public:
property Nullable<DateTime> ModDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
member ModDate : Nullable<DateTime> with get, set

Valore della proprietà

Nullable DateTime
Eccezioni
Eccezione | Condizione
QsException | Record non trovato con id e versione dell'oggetto.
QsException | Viene sollevata in caso di errore nell'istruzione di aggiornamento dati.
Vedi anche

Documentazione

Classe DedCommCollectionItem
Namespace DedNet.Core


Proprietà DedCommCollectionItem.ModUser

Proprietà DedCommCollectionItemModUser
Restituisce l'utente dell'ultima modifica. Impostando questa proprietà si ottiene l'immediato aggiornamento nel Database.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string ModUser { get; set; }
Public Property ModUser As String
    Get
    Set
public:
property String^ ModUser {
    String^ get ();
    void set (String^ value);
}
member ModUser : string with get, set

Valore della proprietà

String
Eccezioni
Eccezione | Condizione
QsException | Record non trovato con id e versione dell'oggetto.
QsException | Viene sollevata in caso di errore nell'istruzione di aggiornamento dati.
Vedi anche

Documentazione

Classe DedCommCollectionItem
Namespace DedNet.Core


Proprietà DedCommCollectionItem.Owner

Proprietà DedCommCollectionItemOwner
Restituisce la collezione di appartenenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommCollections Owner { get; }
Public ReadOnly Property Owner As DedCommCollections
    Get
public:
property DedCommCollections^ Owner {
    DedCommCollections^ get ();
}
member Owner : DedCommCollections with get

Valore della proprietà

DedCommCollections
Vedi anche

Documentazione

Classe DedCommCollectionItem
Namespace DedNet.Core


Proprietà DedCommCollectionItem.RowVer

Proprietà DedCommCollectionItemRowVer
Restituisce la versione del record.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Guid RowVer { get; protected internal set; }
Public Property RowVer As Guid
    Get
    Protected Friend Set
public:
property Guid RowVer {
    Guid get ();
    protected public: void set (Guid value);
}
member RowVer : Guid with get, set

Valore della proprietà

Guid
Vedi anche

Documentazione

Classe DedCommCollectionItem
Namespace DedNet.Core


Metodi di DedCommCollectionItem

Il tipo DedCommCollectionItem espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | AddFieldsValues |
Metodo protetto | AddWhereItemStatement |
Metodo protetto | AddWhereStatement | Aggiunge al comando la clausola where senza l'inclusione del ROWVER.
Metodo pubblico | Delete | Elimina questo elemento dalla collezione di appartenenza.
Metodo protetto | EndUpdate |
Metodo pubblico | Requery | Rilegge tutte le informazioni dal Database.
Metodo protetto | Update | Aggiorna l'oggetto nel Database.
Torna su
Vedi anche

Documentazione

Classe DedCommCollectionItem
Namespace DedNet.Core


Metodo DedCommCollectionItem.AddFieldsValues

Metodo DedCommCollectionItemAddFieldsValues

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected abstract void AddFieldsValues(
    QSUpdateCommand cmd
)
Protected MustOverride Sub AddFieldsValues (
    cmd As QSUpdateCommand
)
protected:
virtual void AddFieldsValues(
    QSUpdateCommand^ cmd
) abstract
abstract AddFieldsValues :
        cmd : QSUpdateCommand -> unit

Parametri

cmd QSUpdateCommand
Vedi anche

Documentazione

Classe DedCommCollectionItem
Namespace DedNet.Core


Metodo DedCommCollectionItem.AddWhereItemStatement

Metodo DedCommCollectionItemAddWhereItemStatement

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected abstract void AddWhereItemStatement(
    QSCommandBase cmd
)
Protected MustOverride Sub AddWhereItemStatement (
    cmd As QSCommandBase
)
protected:
virtual void AddWhereItemStatement(
    QSCommandBase^ cmd
) abstract
abstract AddWhereItemStatement :
        cmd : QSCommandBase -> unit

Parametri

cmd QSCommandBase
Vedi anche

Documentazione

Classe DedCommCollectionItem
Namespace DedNet.Core


Metodo DedCommCollectionItem.AddWhereStatement

Metodo DedCommCollectionItemAddWhereStatement
Aggiunge al comando la clausola where senza l'inclusione del ROWVER.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected virtual void AddWhereStatement(
    QSCommandBase cmd
)
Protected Overridable Sub AddWhereStatement (
    cmd As QSCommandBase
)
protected:
virtual void AddWhereStatement(
    QSCommandBase^ cmd
)
abstract AddWhereStatement :
        cmd : QSCommandBase -> unit
override AddWhereStatement :
        cmd : QSCommandBase -> unit

Parametri

cmd QSCommandBase
Comando al quale aggiungere la clausola.
Vedi anche

Documentazione

Classe DedCommCollectionItem
Namespace DedNet.Core


Metodo DedCommCollectionItem.Delete

Metodo DedCommCollectionItemDelete
Elimina questo elemento dalla collezione di appartenenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual void Delete()
Public Overridable Sub Delete
public:
virtual void Delete()
abstract Delete : unit -> unit
override Delete : unit -> unit
Vedi anche

Documentazione

Classe DedCommCollectionItem
Namespace DedNet.Core


Metodo DedCommCollectionItem.EndUpdate

Metodo DedCommCollectionItemEndUpdate

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected virtual void EndUpdate()
Protected Overridable Sub EndUpdate
protected:
virtual void EndUpdate()
abstract EndUpdate : unit -> unit
override EndUpdate : unit -> unit
Vedi anche

Documentazione

Classe DedCommCollectionItem
Namespace DedNet.Core


Metodo DedCommCollectionItem.Requery

Metodo DedCommCollectionItemRequery
Rilegge tutte le informazioni dal Database.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual void Requery()
Public Overridable Sub Requery
public:
virtual void Requery()
abstract Requery : unit -> unit
override Requery : unit -> unit
Eccezioni
Eccezione | Condizione
QsException | Record non trovato con id e versione dell'oggetto.
QsException | Errore avvenuto durante l'istruzione di select.
Vedi anche

Documentazione

Classe DedCommCollectionItem
Namespace DedNet.Core


Metodo DedCommCollectionItem.Update

Metodo DedCommCollectionItemUpdate
Aggiorna l'oggetto nel Database.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal virtual void Update()
Protected Friend Overridable Sub Update
protected public:
virtual void Update()
abstract Update : unit -> unit
override Update : unit -> unit
Vedi anche

Documentazione

Classe DedCommCollectionItem
Namespace DedNet.Core


Classe DedCommCollections
Classe base per le collezioni di oggetti legati alla commessa.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedCommCollections
DedNet.CoreDedCommAnagrCollection
DedNet.CoreDedCommCommCollection
DedNet.CoreDedCommDocCollection

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public abstract class DedCommCollections : IEnumerable<DedCommCollectionItem>,
    IEnumerable
Public MustInherit Class DedCommCollections
    Implements IEnumerable(Of DedCommCollectionItem), IEnumerable
public ref class DedCommCollections abstract : IEnumerable<DedCommCollectionItem^>,
    IEnumerable
[<AbstractClassAttribute>]
type DedCommCollections =
    class
        interface IEnumerable<DedCommCollectionItem>
        interface IEnumerable
    end

Il tipo DedCommCollections espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Count | Restituisce il numero di elementi presenti nella collezione.
Proprietà protetta | FieldList |
Proprietà pubblica | Parent | Restituisce la commessa alla quale appartiene questa collection.
Proprietà protetta | TableName |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Clear | Elimina tutti gli elementi della collezione.
Metodo pubblico | Contains | Restituisce true se contiene l'elemento richiesto altrimenti false.
Metodo pubblico | ContainsFileName | Restituisce true se contiene l'elemento richiesto altrimenti false.
Metodo pubblico | CopyTo | Copia gli elementi in un array.
Metodo pubblico | GetEnumerator | Restituisce l'enumeratore.
Metodo pubblico | IndexOf | Restituisce l'indice di un elemento oppure -1 se non è presente.
Metodo pubblico | Items | Restituisce l'elemento iesimo.
Metodo protetto | MakeItem |
Metodo pubblico | Reload | Rilegge l'intero contenuto della collezione dal Database.
Metodo protetto | SetItemFields |
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | IEnumerableGetEnumerator | Restituisce l'enumeratore.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di DedCommCollections

Il tipo DedCommCollections espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Count | Restituisce il numero di elementi presenti nella collezione.
Proprietà protetta | FieldList |
Proprietà pubblica | Parent | Restituisce la commessa alla quale appartiene questa collection.
Proprietà protetta | TableName |
Torna su
Vedi anche

Documentazione

Classe DedCommCollections
Namespace DedNet.Core


Proprietà DedCommCollections.Count

Proprietà DedCommCollectionsCount
Restituisce il numero di elementi presenti nella collezione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
public:
property int Count {
    int get ();
}
member Count : int with get

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe DedCommCollections
Namespace DedNet.Core


Proprietà DedCommCollections.FieldList

Proprietà DedCommCollectionsFieldList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal abstract string[] FieldList { get; }
Protected Friend MustOverride ReadOnly Property FieldList As String()
    Get
protected public:
virtual property array<String^>^ FieldList {
    array<String^>^ get () abstract;
}
abstract FieldList : string[] with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedCommCollections
Namespace DedNet.Core


Proprietà DedCommCollections.Parent

Proprietà DedCommCollectionsParent
Restituisce la commessa alla quale appartiene questa collection.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedComm Parent { get; }
Public ReadOnly Property Parent As DedComm
    Get
public:
property DedComm^ Parent {
    DedComm^ get ();
}
member Parent : DedComm with get

Valore della proprietà

DedComm
Vedi anche

Documentazione

Classe DedCommCollections
Namespace DedNet.Core


Proprietà DedCommCollections.TableName

Proprietà DedCommCollectionsTableName

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal abstract string TableName { get; }
Protected Friend MustOverride ReadOnly Property TableName As String
    Get
protected public:
virtual property String^ TableName {
    String^ get () abstract;
}
abstract TableName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedCommCollections
Namespace DedNet.Core


Metodi di DedCommCollections

Il tipo DedCommCollections espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Clear | Elimina tutti gli elementi della collezione.
Metodo pubblico | Contains | Restituisce true se contiene l'elemento richiesto altrimenti false.
Metodo pubblico | ContainsFileName | Restituisce true se contiene l'elemento richiesto altrimenti false.
Metodo pubblico | CopyTo | Copia gli elementi in un array.
Metodo pubblico | GetEnumerator | Restituisce l'enumeratore.
Metodo pubblico | IndexOf | Restituisce l'indice di un elemento oppure -1 se non è presente.
Metodo pubblico | Items | Restituisce l'elemento iesimo.
Metodo protetto | MakeItem |
Metodo pubblico | Reload | Rilegge l'intero contenuto della collezione dal Database.
Metodo protetto | SetItemFields |
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | IEnumerableGetEnumerator | Restituisce l'enumeratore.
Torna su
Vedi anche

Documentazione

Classe DedCommCollections
Namespace DedNet.Core


Metodo DedCommCollections.Clear

Metodo DedCommCollectionsClear
Elimina tutti gli elementi della collezione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
Vedi anche

Documentazione

Classe DedCommCollections
Namespace DedNet.Core


Metodo DedCommCollections.Contains

Metodo DedCommCollectionsContains
Restituisce true se contiene l'elemento richiesto altrimenti false.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Contains(
    DedCommCollectionItem item
)
Public Function Contains (
    item As DedCommCollectionItem
) As Boolean
public:
bool Contains(
    DedCommCollectionItem^ item
)
member Contains :
        item : DedCommCollectionItem -> bool

Parametri

item DedCommCollectionItem
Elemento da verificare.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedCommCollections
Namespace DedNet.Core


Metodo DedCommCollections.ContainsFileName

Metodo DedCommCollectionsContainsFileName
Restituisce true se contiene l'elemento richiesto altrimenti false.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ContainsFileName(
    string fileName
)
Public Function ContainsFileName (
    fileName As String
) As Boolean
public:
bool ContainsFileName(
    String^ fileName
)
member ContainsFileName :
        fileName : string -> bool

Parametri

fileName String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedCommCollections
Namespace DedNet.Core


Metodo DedCommCollections.CopyTo

Metodo DedCommCollectionsCopyTo
Copia gli elementi in un array.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void CopyTo(
    DedCommCollectionItem[] array,
    int arrayIndex
)
Public Sub CopyTo (
    array As DedCommCollectionItem(),
    arrayIndex As Integer
)
public:
void CopyTo(
    array<DedCommCollectionItem^>^ array,
    int arrayIndex
)
member CopyTo :
        array : DedCommCollectionItem[] *
        arrayIndex : int -> unit

Parametri

array DedCommCollectionItem
Array nel quale copiare gli elementi.
arrayIndex Int32
Indice di partenza per la copia.
Vedi anche

Documentazione

Classe DedCommCollections
Namespace DedNet.Core


Metodo DedCommCollections.GetEnumerator

Metodo DedCommCollectionsGetEnumerator
Restituisce l'enumeratore.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public IEnumerator<DedCommCollectionItem> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of DedCommCollectionItem)
public:
virtual IEnumerator<DedCommCollectionItem^>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<DedCommCollectionItem>
override GetEnumerator : unit -> IEnumerator<DedCommCollectionItem>

Valore di ritorno

IEnumerator DedCommCollectionItem

Implementa

IEnumerableTGetEnumerator
Vedi anche

Documentazione

Classe DedCommCollections
Namespace DedNet.Core


Metodo DedCommCollections.IEnumerable.GetEnumerator

Metodo DedCommCollectionsIEnumerableGetEnumerator
Restituisce l'enumeratore.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
IEnumerator IEnumerable.GetEnumerator()
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator

Valore di ritorno

IEnumerator

Implementa

IEnumerableGetEnumerator
Vedi anche

Documentazione

Classe DedCommCollections
Namespace DedNet.Core


Metodo DedCommCollections.IndexOf

Metodo DedCommCollectionsIndexOf
Restituisce l'indice di un elemento oppure -1 se non è presente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int IndexOf(
    DedCommCollectionItem item
)
Public Function IndexOf (
    item As DedCommCollectionItem
) As Integer
public:
int IndexOf(
    DedCommCollectionItem^ item
)
member IndexOf :
        item : DedCommCollectionItem -> int

Parametri

item DedCommCollectionItem
Elemento da verificare.

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedCommCollections
Namespace DedNet.Core


Metodo DedCommCollections.Items

Metodo DedCommCollectionsItems
Restituisce l'elemento iesimo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommCollectionItem Items(
    int index
)
Public Function Items (
    index As Integer
) As DedCommCollectionItem
public:
DedCommCollectionItem^ Items(
    int index
)
member Items :
        index : int -> DedCommCollectionItem

Parametri

index Int32
Indice dell'elemento da restituire.

Valore di ritorno

DedCommCollectionItem
Vedi anche

Documentazione

Classe DedCommCollections
Namespace DedNet.Core


Metodo DedCommCollections.MakeItem

Metodo DedCommCollectionsMakeItem

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected abstract DedCommCollectionItem MakeItem(
    DbDataReader dr
)
Protected MustOverride Function MakeItem (
    dr As DbDataReader
) As DedCommCollectionItem
protected:
virtual DedCommCollectionItem^ MakeItem(
    DbDataReader^ dr
) abstract
abstract MakeItem :
        dr : DbDataReader -> DedCommCollectionItem

Parametri

dr DbDataReader

Valore di ritorno

DedCommCollectionItem
Vedi anche

Documentazione

Classe DedCommCollections
Namespace DedNet.Core


Metodo DedCommCollections.Reload

Metodo DedCommCollectionsReload
Rilegge l'intero contenuto della collezione dal Database.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Reload()
Public Sub Reload
public:
void Reload()
member Reload : unit -> unit
Vedi anche

Documentazione

Classe DedCommCollections
Namespace DedNet.Core


Metodo DedCommCollections.SetItemFields

Metodo DedCommCollectionsSetItemFields

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal abstract void SetItemFields(
    DbDataReader dbDataReader,
    DedCommCollectionItem dedCommCollectionItem
)
Protected Friend MustOverride Sub SetItemFields (
    dbDataReader As DbDataReader,
    dedCommCollectionItem As DedCommCollectionItem
)
protected public:
virtual void SetItemFields(
    DbDataReader^ dbDataReader,
    DedCommCollectionItem^ dedCommCollectionItem
) abstract
abstract SetItemFields :
        dbDataReader : DbDataReader *
        dedCommCollectionItem : DedCommCollectionItem -> unit

Parametri

dbDataReader DbDataReader
dedCommCollectionItem DedCommCollectionItem
Vedi anche

Documentazione

Classe DedCommCollections
Namespace DedNet.Core


Classe DedCommCommCollection
Collezione di commesse collegate ad una commessa.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedCommCollections
DedNet.CoreDedCommCommCollection

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedCommCommCollection : DedCommCollections
Public Class DedCommCommCollection
    Inherits DedCommCollections
public ref class DedCommCommCollection : public DedCommCollections
type DedCommCommCollection =
    class
        inherit DedCommCollections
    end

Il tipo DedCommCommCollection espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Count | Restituisce il numero di elementi presenti nella collezione. (Ereditato da DedCommCollections)
Proprietà protetta | FieldList | Restituisce la lista di tutti i campi presenti nella tabella. (Sovrascrive DedCommCollectionsFieldList)
Proprietà pubblica | Parent | Restituisce la commessa alla quale appartiene questa collection. (Ereditato da DedCommCollections)
Proprietà protetta | TableName | Restituisce il nome della tabella. (Sovrascrive DedCommCollectionsTableName)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Add | Aggiunge un nuovo elemento alla collection.
Metodo pubblico | Clear | Elimina tutti gli elementi della collezione. (Ereditato da DedCommCollections)
Metodo pubblico | Contains | Restituisce true se contiene l'elemento richiesto altrimenti false. (Ereditato da DedCommCollections)
Metodo pubblico | ContainsFileName | Restituisce true se contiene l'elemento richiesto altrimenti false. (Ereditato da DedCommCollections)
Metodo pubblico | CopyTo | Copia gli elementi in un array. (Ereditato da DedCommCollections)
Metodo pubblico | Find | Cerca l'elemento nella collection per commid.
Metodo pubblico | GetEnumerator | Restituisce l'enumeratore. (Ereditato da DedCommCollections)
Metodo pubblico | IndexOf | Restituisce l'indice di un elemento oppure -1 se non è presente. (Ereditato da DedCommCollections)
Metodo pubblico | Items | Restituisce l'elemento iesimo. (Ereditato da DedCommCollections)
Metodo protetto | MakeItem | Crea e restituisce un nuovo oggetto, utilizzando le informazioni correnti del DbDataReader passato. (Sovrascrive DedCommCollectionsMakeItem(DbDataReader))
Metodo pubblico | Reload | Rilegge l'intero contenuto della collezione dal Database. (Ereditato da DedCommCollections)
Metodo protetto | SetItemFields | Imposta tutti i campi dell'oggetto leggendoli dal DbDataReader. (Sovrascrive DedCommCollectionsSetItemFields(DbDataReader, DedCommCollectionItem))
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di DedCommCommCollection

Il tipo DedCommCommCollection espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Count | Restituisce il numero di elementi presenti nella collezione. (Ereditato da DedCommCollections)
Proprietà protetta | FieldList | Restituisce la lista di tutti i campi presenti nella tabella. (Sovrascrive DedCommCollectionsFieldList)
Proprietà pubblica | Parent | Restituisce la commessa alla quale appartiene questa collection. (Ereditato da DedCommCollections)
Proprietà protetta | TableName | Restituisce il nome della tabella. (Sovrascrive DedCommCollectionsTableName)
Torna su
Vedi anche

Documentazione

Classe DedCommCommCollection
Namespace DedNet.Core


Proprietà DedCommCommCollection.FieldList

Proprietà DedCommCommCollectionFieldList
Restituisce la lista di tutti i campi presenti nella tabella.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal override string[] FieldList { get; }
Protected Friend Overrides ReadOnly Property FieldList As String()
    Get
protected public:
virtual property array<String^>^ FieldList {
    array<String^>^ get () override;
}
abstract FieldList : string[] with get
override FieldList : string[] with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedCommCommCollection
Namespace DedNet.Core


Proprietà DedCommCommCollection.TableName

Proprietà DedCommCommCollectionTableName
Restituisce il nome della tabella.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal override string TableName { get; }
Protected Friend Overrides ReadOnly Property TableName As String
    Get
protected public:
virtual property String^ TableName {
    String^ get () override;
}
abstract TableName : string with get
override TableName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedCommCommCollection
Namespace DedNet.Core


Metodi di DedCommCommCollection

Il tipo DedCommCommCollection espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Add | Aggiunge un nuovo elemento alla collection.
Metodo pubblico | Clear | Elimina tutti gli elementi della collezione. (Ereditato da DedCommCollections)
Metodo pubblico | Contains | Restituisce true se contiene l'elemento richiesto altrimenti false. (Ereditato da DedCommCollections)
Metodo pubblico | ContainsFileName | Restituisce true se contiene l'elemento richiesto altrimenti false. (Ereditato da DedCommCollections)
Metodo pubblico | CopyTo | Copia gli elementi in un array. (Ereditato da DedCommCollections)
Metodo pubblico | Find | Cerca l'elemento nella collection per commid.
Metodo pubblico | GetEnumerator | Restituisce l'enumeratore. (Ereditato da DedCommCollections)
Metodo pubblico | IndexOf | Restituisce l'indice di un elemento oppure -1 se non è presente. (Ereditato da DedCommCollections)
Metodo pubblico | Items | Restituisce l'elemento iesimo. (Ereditato da DedCommCollections)
Metodo protetto | MakeItem | Crea e restituisce un nuovo oggetto, utilizzando le informazioni correnti del DbDataReader passato. (Sovrascrive DedCommCollectionsMakeItem(DbDataReader))
Metodo pubblico | Reload | Rilegge l'intero contenuto della collezione dal Database. (Ereditato da DedCommCollections)
Metodo protetto | SetItemFields | Imposta tutti i campi dell'oggetto leggendoli dal DbDataReader. (Sovrascrive DedCommCollectionsSetItemFields(DbDataReader, DedCommCollectionItem))
Torna su
Vedi anche

Documentazione

Classe DedCommCommCollection
Namespace DedNet.Core


Metodo DedCommCommCollection.Add

Metodo DedCommCommCollectionAdd
Aggiunge un nuovo elemento alla collection.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommCommItem Add(
    Guid commid,
    int context
)
Public Function Add (
    commid As Guid,
    context As Integer
) As DedCommCommItem
public:
DedCommCommItem^ Add(
    Guid commid,
    int context
)
member Add :
        commid : Guid *
        context : int -> DedCommCommItem

Parametri

commid Guid
ID della commessa da collegare.
context Int32
Contesto di associazione.

Valore di ritorno

DedCommCommItem
Eccezioni
Eccezione | Condizione
ArgumentNullException | Parametro mancante.
QsException | Errore avvenuto durante l'istruzione d'inserimento.
Vedi anche

Documentazione

Classe DedCommCommCollection
Namespace DedNet.Core


Metodo DedCommCommCollection.Find

Metodo DedCommCommCollectionFind
Cerca l'elemento nella collection per commid.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommCommItem Find(
    Guid commid
)
Public Function Find (
    commid As Guid
) As DedCommCommItem
public:
DedCommCommItem^ Find(
    Guid commid
)
member Find :
        commid : Guid -> DedCommCommItem

Parametri

commid Guid
ID della commessa da cercare.

Valore di ritorno

DedCommCommItem
Ritorna l'elemento specifico o null se fallisce.
Vedi anche

Documentazione

Classe DedCommCommCollection
Namespace DedNet.Core


Metodo DedCommCommCollection.MakeItem

Metodo DedCommCommCollectionMakeItem
Crea e restituisce un nuovo oggetto, utilizzando le informazioni correnti del DbDataReader passato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCommCollectionItem MakeItem(
    DbDataReader dr
)
Protected Overrides Function MakeItem (
    dr As DbDataReader
) As DedCommCollectionItem
protected:
virtual DedCommCollectionItem^ MakeItem(
    DbDataReader^ dr
) override
abstract MakeItem :
        dr : DbDataReader -> DedCommCollectionItem
override MakeItem :
        dr : DbDataReader -> DedCommCollectionItem

Parametri

dr DbDataReader
Oggetto DbDataReader inizializzato e puntante al record di interesse.

Valore di ritorno

DedCommCollectionItem
Vedi anche

Documentazione

Classe DedCommCommCollection
Namespace DedNet.Core


Metodo DedCommCommCollection.SetItemFields

Metodo DedCommCommCollectionSetItemFields
Imposta tutti i campi dell'oggetto leggendoli dal DbDataReader.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal override void SetItemFields(
    DbDataReader dr,
    DedCommCollectionItem dedCommCollectionItem
)
Protected Friend Overrides Sub SetItemFields (
    dr As DbDataReader,
    dedCommCollectionItem As DedCommCollectionItem
)
protected public:
virtual void SetItemFields(
    DbDataReader^ dr,
    DedCommCollectionItem^ dedCommCollectionItem
) override
abstract SetItemFields :
        dr : DbDataReader *
        dedCommCollectionItem : DedCommCollectionItem -> unit
override SetItemFields :
        dr : DbDataReader *
        dedCommCollectionItem : DedCommCollectionItem -> unit

Parametri

dr DbDataReader
Oggetto DbDataReader inizializzato e puntante al record di interesse.
dedCommCollectionItem DedCommCollectionItem
Oggetto da aggiornare.
Vedi anche

Documentazione

Classe DedCommCommCollection
Namespace DedNet.Core


Classe DedCommCommItem
Descrive un legame tra commessa e commessa.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedCommCollectionItem
DedNet.CoreDedCommCommItem

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedCommCommItem : DedCommCollectionItem
Public Class DedCommCommItem
    Inherits DedCommCollectionItem
public ref class DedCommCommItem : public DedCommCollectionItem
type DedCommCommItem =
    class
        inherit DedCommCollectionItem
    end

Il tipo DedCommCommItem espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AssocDate | Restituisce o imposta la data di associazione. Impostando questa proprietà si ottiene l'immediato aggiornamento nel Database. (Ereditato da DedCommCollectionItem)
Proprietà pubblica | AssocUser | Restituisce o imposta l'utente che ha effettuato l'associazione. Impostando questa proprietà si ottiene l'immediato aggiornamento nel Database. (Ereditato da DedCommCollectionItem)
Proprietà pubblica | Commessa | Restituisce la commessa riferita a questo oggetto oppure null se non è presente nel Database.
Proprietà pubblica | CommID | Restituisce o imposta il CommId della commessa collegata. Impostando questa proprietà si ottiene l'immediato aggiornamento nel Database.
Proprietà pubblica | Context | Restituisce o imposta il contesto di associazione. Impostando questa proprietà si ottiene l'immediato aggiornamento nel Database.
Proprietà protetta | IgnoreDirty | Restituisce se ignorare le modifiche. (Ereditato da DedCommCollectionItem)
Proprietà pubblica | ModDate | Restituisce la data di ultima modifica. Impostando questa proprietà si ottiene l'immediato aggiornamento nel Database. (Ereditato da DedCommCollectionItem)
Proprietà pubblica | ModUser | Restituisce l'utente dell'ultima modifica. Impostando questa proprietà si ottiene l'immediato aggiornamento nel Database. (Ereditato da DedCommCollectionItem)
Proprietà pubblica | Owner | Restituisce la collezione di appartenenza. (Ereditato da DedCommCollectionItem)
Proprietà pubblica | RowVer | Restituisce la versione del record. (Ereditato da DedCommCollectionItem)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | AddFieldsValues | Aggiunge i valori dei campi da aggiornare escluso il ROWVER, MODDATE e MODUSER che vengono impostati dalla classe base. (Sovrascrive DedCommCollectionItemAddFieldsValues(QSUpdateCommand))
Metodo protetto | AddWhereItemStatement | Aggiunge la calusola where per l'elemento escluso il COMMID che viene impostato nella classe base. (Sovrascrive DedCommCollectionItemAddWhereItemStatement(QSCommandBase))
Metodo protetto | AddWhereStatement | Aggiunge al comando la clausola where senza l'inclusione del ROWVER. (Ereditato da DedCommCollectionItem)
Metodo pubblico | Delete | Elimina questo elemento dalla collezione di appartenenza. (Ereditato da DedCommCollectionItem)
Metodo protetto | EndUpdate | (Ereditato da DedCommCollectionItem)
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | Requery | Rilegge tutte le informazioni dal Database. (Ereditato da DedCommCollectionItem)
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Metodo protetto | Update | Aggiorna l'oggetto nel Database. (Ereditato da DedCommCollectionItem)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di DedCommCommItem

Il tipo DedCommCommItem espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AssocDate | Restituisce o imposta la data di associazione. Impostando questa proprietà si ottiene l'immediato aggiornamento nel Database. (Ereditato da DedCommCollectionItem)
Proprietà pubblica | AssocUser | Restituisce o imposta l'utente che ha effettuato l'associazione. Impostando questa proprietà si ottiene l'immediato aggiornamento nel Database. (Ereditato da DedCommCollectionItem)
Proprietà pubblica | Commessa | Restituisce la commessa riferita a questo oggetto oppure null se non è presente nel Database.
Proprietà pubblica | CommID | Restituisce o imposta il CommId della commessa collegata. Impostando questa proprietà si ottiene l'immediato aggiornamento nel Database.
Proprietà pubblica | Context | Restituisce o imposta il contesto di associazione. Impostando questa proprietà si ottiene l'immediato aggiornamento nel Database.
Proprietà protetta | IgnoreDirty | Restituisce se ignorare le modifiche. (Ereditato da DedCommCollectionItem)
Proprietà pubblica | ModDate | Restituisce la data di ultima modifica. Impostando questa proprietà si ottiene l'immediato aggiornamento nel Database. (Ereditato da DedCommCollectionItem)
Proprietà pubblica | ModUser | Restituisce l'utente dell'ultima modifica. Impostando questa proprietà si ottiene l'immediato aggiornamento nel Database. (Ereditato da DedCommCollectionItem)
Proprietà pubblica | Owner | Restituisce la collezione di appartenenza. (Ereditato da DedCommCollectionItem)
Proprietà pubblica | RowVer | Restituisce la versione del record. (Ereditato da DedCommCollectionItem)
Torna su
Vedi anche

Documentazione

Classe DedCommCommItem
Namespace DedNet.Core


Proprietà DedCommCommItem.Commessa

Proprietà DedCommCommItemCommessa
Restituisce la commessa riferita a questo oggetto oppure null se non è presente nel Database.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedComm Commessa { get; }
Public ReadOnly Property Commessa As DedComm
    Get
public:
property DedComm^ Commessa {
    DedComm^ get ();
}
member Commessa : DedComm with get

Valore della proprietà

DedComm
Vedi anche

Documentazione

Classe DedCommCommItem
Namespace DedNet.Core


Proprietà DedCommCommItem.CommID

Proprietà DedCommCommItemCommID
Restituisce o imposta il CommId della commessa collegata. Impostando questa proprietà si ottiene l'immediato aggiornamento nel Database.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Guid CommID { get; set; }
Public Property CommID As Guid
    Get
    Set
public:
property Guid CommID {
    Guid get ();
    void set (Guid value);
}
member CommID : Guid with get, set

Valore della proprietà

Guid
Eccezioni
Eccezione | Condizione
QsException | Record non trovato con id e versione dell'oggetto.
QsException | Viene sollevata in caso di errore nell'istruzione di aggiornamento dati.
Vedi anche

Documentazione

Classe DedCommCommItem
Namespace DedNet.Core


Proprietà DedCommCommItem.Context

Proprietà DedCommCommItemContext
Restituisce o imposta il contesto di associazione. Impostando questa proprietà si ottiene l'immediato aggiornamento nel Database.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int Context { get; set; }
Public Property Context As Integer
    Get
    Set
public:
property int Context {
    int get ();
    void set (int value);
}
member Context : int with get, set

Valore della proprietà

Int32
Eccezioni
Eccezione | Condizione
QsException | Record non trovato con id e versione dell'oggetto.
QsException | Viene sollevata in caso di errore nell'istruzione di aggiornamento dati.
Vedi anche

Documentazione

Classe DedCommCommItem
Namespace DedNet.Core


Metodi di DedCommCommItem

Il tipo DedCommCommItem espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | AddFieldsValues | Aggiunge i valori dei campi da aggiornare escluso il ROWVER, MODDATE e MODUSER che vengono impostati dalla classe base. (Sovrascrive DedCommCollectionItemAddFieldsValues(QSUpdateCommand))
Metodo protetto | AddWhereItemStatement | Aggiunge la calusola where per l'elemento escluso il COMMID che viene impostato nella classe base. (Sovrascrive DedCommCollectionItemAddWhereItemStatement(QSCommandBase))
Metodo protetto | AddWhereStatement | Aggiunge al comando la clausola where senza l'inclusione del ROWVER. (Ereditato da DedCommCollectionItem)
Metodo pubblico | Delete | Elimina questo elemento dalla collezione di appartenenza. (Ereditato da DedCommCollectionItem)
Metodo protetto | EndUpdate | (Ereditato da DedCommCollectionItem)
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | Requery | Rilegge tutte le informazioni dal Database. (Ereditato da DedCommCollectionItem)
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Metodo protetto | Update | Aggiorna l'oggetto nel Database. (Ereditato da DedCommCollectionItem)
Torna su
Vedi anche

Documentazione

Classe DedCommCommItem
Namespace DedNet.Core


Metodo DedCommCommItem.AddFieldsValues

Metodo DedCommCommItemAddFieldsValues
Aggiunge i valori dei campi da aggiornare escluso il ROWVER, MODDATE e MODUSER che vengono impostati dalla classe base.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void AddFieldsValues(
    QSUpdateCommand cmd
)
Protected Overrides Sub AddFieldsValues (
    cmd As QSUpdateCommand
)
protected:
virtual void AddFieldsValues(
    QSUpdateCommand^ cmd
) override
abstract AddFieldsValues :
        cmd : QSUpdateCommand -> unit
override AddFieldsValues :
        cmd : QSUpdateCommand -> unit

Parametri

cmd QSUpdateCommand
Comando di update nel quale impostare i valori dei campi.
Vedi anche

Documentazione

Classe DedCommCommItem
Namespace DedNet.Core


Metodo DedCommCommItem.AddWhereItemStatement

Metodo DedCommCommItemAddWhereItemStatement
Aggiunge la calusola where per l'elemento escluso il COMMID che viene impostato nella classe base.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void AddWhereItemStatement(
    QSCommandBase cmd
)
Protected Overrides Sub AddWhereItemStatement (
    cmd As QSCommandBase
)
protected:
virtual void AddWhereItemStatement(
    QSCommandBase^ cmd
) override
abstract AddWhereItemStatement :
        cmd : QSCommandBase -> unit
override AddWhereItemStatement :
        cmd : QSCommandBase -> unit

Parametri

cmd QSCommandBase
Comando nel quale impostare la clausola where.
Vedi anche

Documentazione

Classe DedCommCommItem
Namespace DedNet.Core


Metodo DedCommCommItem.Equals

Metodo DedCommCommItemEquals

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj Object

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedCommCommItem
Namespace DedNet.Core


Metodo DedCommCommItem.GetHashCode

Metodo DedCommCommItemGetHashCode

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedCommCommItem
Namespace DedNet.Core


Metodo DedCommCommItem.ToString

Metodo DedCommCommItemToString

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedCommCommItem
Namespace DedNet.Core


Classe DedCommData
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericDictionary String, Object
DedNet.CoreDedDictionary
DedNet.CoreDedCommData

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedCommData : DedDictionary,
    IDedTypeEditable, IDedEditable
Public Class DedCommData
    Inherits DedDictionary
    Implements IDedTypeEditable, IDedEditable
public ref class DedCommData : public DedDictionary,
    IDedTypeEditable, IDedEditable
type DedCommData =
    class
        inherit DedDictionary
        interface IDedTypeEditable
        interface IDedEditable
    end

Il tipo DedCommData espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedCommData | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | DedCommType | Restituisce la famiglia nella quale è stato archiviata questa commessa. Può restituire null se non appartiene ad alcuna famiglia.
Proprietà pubblica | DedTypeBase | Restituisce la famiglia nella quale è stato archiviata questa commessa. Può restituire null se non appartiene ad alcuna famiglia.
Proprietà pubblica | IsValid | Restituisce se i valori presenti validano gli attributi della famiglia di appartenenza.
Proprietà pubblica | Root | Restituisce la famiglia nella quale è stato archiviata questa commessa. Può restituire null se non appartiene ad alcuna famiglia.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | GetAttributes | Restituisce la lista degli attributi di anagrafica visti dalla famiglia alla quale appartiene questo oggetto. Restituisce sempre una lista inizializata anche se l'anagrafica non appartiene ad alcuna famiglia: In questo caso restituisce gli attributi della root.
Metodo pubblico | GetValue(DedDataStandardDataFields) | Restituisce il contenuto di un campo standard oppure null se non esiste. Se i valori contenuti all'interno delle anagrafiche sono differenti viene restituita la stringa "*DIV*". (Ereditato da DedDictionary)
Metodo pubblico | GetValue(String) | Restituisce il valore oppure null. (Ereditato da DedDictionary)
Metodo pubblico | SetValue(DedDataStandardDataFields, Object) | (Ereditato da DedDictionary)
Metodo pubblico | SetValue(String, Object) | Imposta il valore corrispondente alla chiave passata oppure crea il campo se non esiste. (Ereditato da DedDictionary)
Metodo pubblico | Validate | Restituisce se i valori presenti validano gli attributi della famiglia di appartenenza.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedCommData
Costruttore unico.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommData(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedCommData(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedCommData

Parametri

app DedNetApplication
Oggetto applicazione di appartenenza.
Vedi anche

Documentazione

Classe DedCommData
Namespace DedNet.Core


Proprietà di DedCommData

Il tipo DedCommData espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | DedCommType | Restituisce la famiglia nella quale è stato archiviata questa commessa. Può restituire null se non appartiene ad alcuna famiglia.
Proprietà pubblica | DedTypeBase | Restituisce la famiglia nella quale è stato archiviata questa commessa. Può restituire null se non appartiene ad alcuna famiglia.
Proprietà pubblica | IsValid | Restituisce se i valori presenti validano gli attributi della famiglia di appartenenza.
Proprietà pubblica | Root | Restituisce la famiglia nella quale è stato archiviata questa commessa. Può restituire null se non appartiene ad alcuna famiglia.
Torna su
Vedi anche

Documentazione

Classe DedCommData
Namespace DedNet.Core


Proprietà DedCommData.DedCommType

Proprietà DedCommDataDedCommType
Restituisce la famiglia nella quale è stato archiviata questa commessa. Può restituire null se non appartiene ad alcuna famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommType DedCommType { get; }
Public ReadOnly Property DedCommType As DedCommType
    Get
public:
property DedCommType^ DedCommType {
    DedCommType^ get ();
}
member DedCommType : DedCommType with get

Valore della proprietà

DedCommType
Vedi anche

Documentazione

Classe DedCommData
Namespace DedNet.Core


Proprietà DedCommData.DedTypeBase

Proprietà DedCommDataDedTypeBase
Restituisce la famiglia nella quale è stato archiviata questa commessa. Può restituire null se non appartiene ad alcuna famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeBase DedTypeBase { get; }
Public ReadOnly Property DedTypeBase As DedTypeBase
    Get
public:
virtual property DedTypeBase^ DedTypeBase {
    DedTypeBase^ get () sealed;
}
abstract DedTypeBase : DedTypeBase with get
override DedTypeBase : DedTypeBase with get

Valore della proprietà

DedTypeBase

Implementa

IDedTypeEditableDedTypeBase
Vedi anche

Documentazione

Classe DedCommData
Namespace DedNet.Core


Proprietà DedCommData.IsValid

Proprietà DedCommDataIsValid
Restituisce se i valori presenti validano gli attributi della famiglia di appartenenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsValid { get; }
Public ReadOnly Property IsValid As Boolean
    Get
public:
virtual property bool IsValid {
    bool get () sealed;
}
abstract IsValid : bool with get
override IsValid : bool with get

Valore della proprietà

Boolean

Implementa

IDedTypeEditableIsValid
Vedi anche

Documentazione

Classe DedCommData
Namespace DedNet.Core


Proprietà DedCommData.Root

Proprietà DedCommDataRoot
Restituisce la famiglia nella quale è stato archiviata questa commessa. Può restituire null se non appartiene ad alcuna famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeBase Root { get; }
Public ReadOnly Property Root As DedTypeBase
    Get
public:
virtual property DedTypeBase^ Root {
    DedTypeBase^ get () sealed;
}
abstract Root : DedTypeBase with get
override Root : DedTypeBase with get

Valore della proprietà

DedTypeBase

Implementa

IDedTypeEditableRoot
Vedi anche

Documentazione

Classe DedCommData
Namespace DedNet.Core


Metodi di DedCommData

Il tipo DedCommData espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | GetAttributes | Restituisce la lista degli attributi di anagrafica visti dalla famiglia alla quale appartiene questo oggetto. Restituisce sempre una lista inizializata anche se l'anagrafica non appartiene ad alcuna famiglia: In questo caso restituisce gli attributi della root.
Metodo pubblico | GetValue(DedDataStandardDataFields) | Restituisce il contenuto di un campo standard oppure null se non esiste. Se i valori contenuti all'interno delle anagrafiche sono differenti viene restituita la stringa "*DIV*". (Ereditato da DedDictionary)
Metodo pubblico | GetValue(String) | Restituisce il valore oppure null. (Ereditato da DedDictionary)
Metodo pubblico | SetValue(DedDataStandardDataFields, Object) | (Ereditato da DedDictionary)
Metodo pubblico | SetValue(String, Object) | Imposta il valore corrispondente alla chiave passata oppure crea il campo se non esiste. (Ereditato da DedDictionary)
Metodo pubblico | Validate | Restituisce se i valori presenti validano gli attributi della famiglia di appartenenza.
Torna su
Vedi anche

Documentazione

Classe DedCommData
Namespace DedNet.Core


Metodo DedCommData.GetAttributes

Metodo DedCommDataGetAttributes
Restituisce la lista degli attributi di anagrafica visti dalla famiglia alla quale appartiene questo oggetto. Restituisce sempre una lista inizializata anche se l'anagrafica non appartiene ad alcuna famiglia: In questo caso restituisce gli attributi della root.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList GetAttributes()
Public Function GetAttributes As DedAttrList
public:
DedAttrList^ GetAttributes()
member GetAttributes : unit -> DedAttrList

Valore di ritorno

DedAttrList
Vedi anche

Documentazione

Classe DedCommData
Namespace DedNet.Core


Metodo DedCommData.Validate

Metodo DedCommDataValidate
Restituisce se i valori presenti validano gli attributi della famiglia di appartenenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Validate(
    bool creating,
    bool revisioning,
    out string error
)
Public Function Validate (
    creating As Boolean,
    revisioning As Boolean,
    <OutAttribute> ByRef error As String
) As Boolean
public:
virtual bool Validate(
    bool creating,
    bool revisioning,
    [OutAttribute] String^% error
) sealed
abstract Validate :
        creating : bool *
        revisioning : bool *
        error : string byref -> bool
override Validate :
        creating : bool *
        revisioning : bool *
        error : string byref -> bool

Parametri

creating Boolean
revisioning Boolean
error String

Valore di ritorno

Boolean

Implementa

IDedTypeEditableValidate(Boolean, Boolean, String)
Vedi anche

Documentazione

Classe DedCommData
Namespace DedNet.Core


Classe DedCommDocCollection
Collezione di documenti collegati ad una commessa.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedCommCollections
DedNet.CoreDedCommDocCollection

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedCommDocCollection : DedCommCollections
Public Class DedCommDocCollection
    Inherits DedCommCollections
public ref class DedCommDocCollection : public DedCommCollections
type DedCommDocCollection =
    class
        inherit DedCommCollections
    end

Il tipo DedCommDocCollection espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Count | Restituisce il numero di elementi presenti nella collezione. (Ereditato da DedCommCollections)
Proprietà protetta | FieldList | Restituisce la lista di tutti i campi presenti nella tabella. (Sovrascrive DedCommCollectionsFieldList)
Proprietà pubblica | Parent | Restituisce la commessa alla quale appartiene questa collection. (Ereditato da DedCommCollections)
Proprietà protetta | TableName | Restituisce il nome della tabella. (Sovrascrive DedCommCollectionsTableName)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Add | Aggiunge un nuovo elemento alla collection.
Metodo pubblico | Clear | Elimina tutti gli elementi della collezione. (Ereditato da DedCommCollections)
Metodo pubblico | Contains | Restituisce true se contiene l'elemento richiesto altrimenti false. (Ereditato da DedCommCollections)
Metodo pubblico | ContainsFileName | Restituisce true se contiene l'elemento richiesto altrimenti false. (Ereditato da DedCommCollections)
Metodo pubblico | CopyTo | Copia gli elementi in un array. (Ereditato da DedCommCollections)
Metodo pubblico | Find | Cerca l'elemento nella collection per docic.
Metodo pubblico | GetEnumerator | Restituisce l'enumeratore. (Ereditato da DedCommCollections)
Metodo pubblico | GetFiles | Restituisce un array contenente tutti i file presenti nell'oggetto.
Metodo pubblico | IndexOf | Restituisce l'indice di un elemento oppure -1 se non è presente. (Ereditato da DedCommCollections)
Metodo pubblico | Items | Restituisce l'elemento iesimo. (Ereditato da DedCommCollections)
Metodo protetto | MakeItem | Crea e restituisce un nuovo oggetto, utilizzando le informazioni correnti del DbDataReader passato. (Sovrascrive DedCommCollectionsMakeItem(DbDataReader))
Metodo pubblico | Reload | Rilegge l'intero contenuto della collezione dal Database. (Ereditato da DedCommCollections)
Metodo protetto | SetItemFields | Imposta tutti i campi dell'oggetto leggendoli dal DbDataReader. (Sovrascrive DedCommCollectionsSetItemFields(DbDataReader, DedCommCollectionItem))
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di DedCommDocCollection

Il tipo DedCommDocCollection espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Count | Restituisce il numero di elementi presenti nella collezione. (Ereditato da DedCommCollections)
Proprietà protetta | FieldList | Restituisce la lista di tutti i campi presenti nella tabella. (Sovrascrive DedCommCollectionsFieldList)
Proprietà pubblica | Parent | Restituisce la commessa alla quale appartiene questa collection. (Ereditato da DedCommCollections)
Proprietà protetta | TableName | Restituisce il nome della tabella. (Sovrascrive DedCommCollectionsTableName)
Torna su
Vedi anche

Documentazione

Classe DedCommDocCollection
Namespace DedNet.Core


Proprietà DedCommDocCollection.FieldList

Proprietà DedCommDocCollectionFieldList
Restituisce la lista di tutti i campi presenti nella tabella.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal override string[] FieldList { get; }
Protected Friend Overrides ReadOnly Property FieldList As String()
    Get
protected public:
virtual property array<String^>^ FieldList {
    array<String^>^ get () override;
}
abstract FieldList : string[] with get
override FieldList : string[] with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedCommDocCollection
Namespace DedNet.Core


Proprietà DedCommDocCollection.TableName

Proprietà DedCommDocCollectionTableName
Restituisce il nome della tabella.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal override string TableName { get; }
Protected Friend Overrides ReadOnly Property TableName As String
    Get
protected public:
virtual property String^ TableName {
    String^ get () override;
}
abstract TableName : string with get
override TableName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedCommDocCollection
Namespace DedNet.Core


Metodi di DedCommDocCollection

Il tipo DedCommDocCollection espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Add | Aggiunge un nuovo elemento alla collection.
Metodo pubblico | Clear | Elimina tutti gli elementi della collezione. (Ereditato da DedCommCollections)
Metodo pubblico | Contains | Restituisce true se contiene l'elemento richiesto altrimenti false. (Ereditato da DedCommCollections)
Metodo pubblico | ContainsFileName | Restituisce true se contiene l'elemento richiesto altrimenti false. (Ereditato da DedCommCollections)
Metodo pubblico | CopyTo | Copia gli elementi in un array. (Ereditato da DedCommCollections)
Metodo pubblico | Find | Cerca l'elemento nella collection per docic.
Metodo pubblico | GetEnumerator | Restituisce l'enumeratore. (Ereditato da DedCommCollections)
Metodo pubblico | GetFiles | Restituisce un array contenente tutti i file presenti nell'oggetto.
Metodo pubblico | IndexOf | Restituisce l'indice di un elemento oppure -1 se non è presente. (Ereditato da DedCommCollections)
Metodo pubblico | Items | Restituisce l'elemento iesimo. (Ereditato da DedCommCollections)
Metodo protetto | MakeItem | Crea e restituisce un nuovo oggetto, utilizzando le informazioni correnti del DbDataReader passato. (Sovrascrive DedCommCollectionsMakeItem(DbDataReader))
Metodo pubblico | Reload | Rilegge l'intero contenuto della collezione dal Database. (Ereditato da DedCommCollections)
Metodo protetto | SetItemFields | Imposta tutti i campi dell'oggetto leggendoli dal DbDataReader. (Sovrascrive DedCommCollectionsSetItemFields(DbDataReader, DedCommCollectionItem))
Torna su
Vedi anche

Documentazione

Classe DedCommDocCollection
Namespace DedNet.Core


Metodo DedCommDocCollection.Add

Metodo DedCommDocCollectionAdd
Aggiunge un nuovo elemento alla collection.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommDocItem Add(
    Guid docid,
    DedDocContextEnum context
)
Public Function Add (
    docid As Guid,
    context As DedDocContextEnum
) As DedCommDocItem
public:
DedCommDocItem^ Add(
    Guid docid,
    DedDocContextEnum context
)
member Add :
        docid : Guid *
        context : DedDocContextEnum -> DedCommDocItem

Parametri

docid Guid
ID del documento da collegare.
context DedDocContextEnum
Contesto di associazione.

Valore di ritorno

DedCommDocItem
Eccezioni
Eccezione | Condizione
ArgumentNullException | Parametro mancante.
QsException | Errore avvenuto durante l'istruzione d'inserimento.
Vedi anche

Documentazione

Classe DedCommDocCollection
Namespace DedNet.Core


Metodo DedCommDocCollection.Find

Metodo DedCommDocCollectionFind
Cerca l'elemento nella collection per docic.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommDocItem Find(
    Guid docid
)
Public Function Find (
    docid As Guid
) As DedCommDocItem
public:
DedCommDocItem^ Find(
    Guid docid
)
member Find :
        docid : Guid -> DedCommDocItem

Parametri

docid Guid
ID del documento da cercare.

Valore di ritorno

DedCommDocItem
Ritorna l'elemento specifico o null se fallisce.
Vedi anche

Documentazione

Classe DedCommDocCollection
Namespace DedNet.Core


Metodo DedCommDocCollection.GetFiles

Metodo DedCommDocCollectionGetFiles
Restituisce un array contenente tutti i file presenti nell'oggetto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string[] GetFiles()
Public Function GetFiles As String()
public:
array<String^>^ GetFiles()
member GetFiles : unit -> string[]

Valore di ritorno

String
Restituisce un array contenente tutti i file presenti nell'oggetto.
Vedi anche

Documentazione

Classe DedCommDocCollection
Namespace DedNet.Core


Metodo DedCommDocCollection.MakeItem

Metodo DedCommDocCollectionMakeItem
Crea e restituisce un nuovo oggetto, utilizzando le informazioni correnti del DbDataReader passato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DedCommCollectionItem MakeItem(
    DbDataReader dr
)
Protected Overrides Function MakeItem (
    dr As DbDataReader
) As DedCommCollectionItem
protected:
virtual DedCommCollectionItem^ MakeItem(
    DbDataReader^ dr
) override
abstract MakeItem :
        dr : DbDataReader -> DedCommCollectionItem
override MakeItem :
        dr : DbDataReader -> DedCommCollectionItem

Parametri

dr DbDataReader
Oggetto DbDataReader inizializzato e puntante al record di interesse.

Valore di ritorno

DedCommCollectionItem
Vedi anche

Documentazione

Classe DedCommDocCollection
Namespace DedNet.Core


Metodo DedCommDocCollection.SetItemFields

Metodo DedCommDocCollectionSetItemFields
Imposta tutti i campi dell'oggetto leggendoli dal DbDataReader.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal override void SetItemFields(
    DbDataReader dr,
    DedCommCollectionItem dedCommCollectionItem
)
Protected Friend Overrides Sub SetItemFields (
    dr As DbDataReader,
    dedCommCollectionItem As DedCommCollectionItem
)
protected public:
virtual void SetItemFields(
    DbDataReader^ dr,
    DedCommCollectionItem^ dedCommCollectionItem
) override
abstract SetItemFields :
        dr : DbDataReader *
        dedCommCollectionItem : DedCommCollectionItem -> unit
override SetItemFields :
        dr : DbDataReader *
        dedCommCollectionItem : DedCommCollectionItem -> unit

Parametri

dr DbDataReader
Oggetto DbDataReader inizializzato e puntante al record di interesse.
dedCommCollectionItem DedCommCollectionItem
Oggetto da aggiornare.
Vedi anche

Documentazione

Classe DedCommDocCollection
Namespace DedNet.Core


Classe DedCommDocItem
Descrive un legame tra commessa e documento.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedCommCollectionItem
DedNet.CoreDedCommDocItem

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedCommDocItem : DedCommCollectionItem
Public Class DedCommDocItem
    Inherits DedCommCollectionItem
public ref class DedCommDocItem : public DedCommCollectionItem
type DedCommDocItem =
    class
        inherit DedCommCollectionItem
    end

Il tipo DedCommDocItem espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AssocDate | Restituisce o imposta la data di associazione. Impostando questa proprietà si ottiene l'immediato aggiornamento nel Database. (Ereditato da DedCommCollectionItem)
Proprietà pubblica | AssocUser | Restituisce o imposta l'utente che ha effettuato l'associazione. Impostando questa proprietà si ottiene l'immediato aggiornamento nel Database. (Ereditato da DedCommCollectionItem)
Proprietà pubblica | Context | Restituisce o imposta il contesto di associazione. Impostando questa proprietà si ottiene l'immediato aggiornamento nel Database.
Proprietà pubblica | DocID | Restituisce o imposta il DocId del documento collegato. Impostando questa proprietà si ottiene l'immediato aggiornamento nel Database.
Proprietà pubblica | Document | Restituisce il documento riferito a questo oggetto oppure null se non è presente nel Database.
Proprietà protetta | IgnoreDirty | Restituisce se ignorare le modifiche. (Ereditato da DedCommCollectionItem)
Proprietà pubblica | ModDate | Restituisce la data di ultima modifica. Impostando questa proprietà si ottiene l'immediato aggiornamento nel Database. (Ereditato da DedCommCollectionItem)
Proprietà pubblica | ModUser | Restituisce l'utente dell'ultima modifica. Impostando questa proprietà si ottiene l'immediato aggiornamento nel Database. (Ereditato da DedCommCollectionItem)
Proprietà pubblica | Owner | Restituisce la collezione di appartenenza. (Ereditato da DedCommCollectionItem)
Proprietà pubblica | RowVer | Restituisce la versione del record. (Ereditato da DedCommCollectionItem)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | AddFieldsValues | Aggiunge i valori dei campi da aggiornare escluso il ROWVER, MODDATE e MODUSER, ASSOCDATE e ASSOCUSER che vengono impostati dalla classe base. (Sovrascrive DedCommCollectionItemAddFieldsValues(QSUpdateCommand))
Metodo protetto | AddWhereItemStatement | Aggiunge la calusola where per l'elemento escluso il COMMID che viene impostato nella classe base. (Sovrascrive DedCommCollectionItemAddWhereItemStatement(QSCommandBase))
Metodo protetto | AddWhereStatement | Aggiunge al comando la clausola where senza l'inclusione del ROWVER. (Ereditato da DedCommCollectionItem)
Metodo pubblico | Delete | Elimina questo elemento dalla collezione di appartenenza. (Ereditato da DedCommCollectionItem)
Metodo protetto | EndUpdate | (Ereditato da DedCommCollectionItem)
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | Requery | Rilegge tutte le informazioni dal Database. (Ereditato da DedCommCollectionItem)
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Metodo protetto | Update | Aggiorna l'oggetto nel Database. (Ereditato da DedCommCollectionItem)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di DedCommDocItem

Il tipo DedCommDocItem espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AssocDate | Restituisce o imposta la data di associazione. Impostando questa proprietà si ottiene l'immediato aggiornamento nel Database. (Ereditato da DedCommCollectionItem)
Proprietà pubblica | AssocUser | Restituisce o imposta l'utente che ha effettuato l'associazione. Impostando questa proprietà si ottiene l'immediato aggiornamento nel Database. (Ereditato da DedCommCollectionItem)
Proprietà pubblica | Context | Restituisce o imposta il contesto di associazione. Impostando questa proprietà si ottiene l'immediato aggiornamento nel Database.
Proprietà pubblica | DocID | Restituisce o imposta il DocId del documento collegato. Impostando questa proprietà si ottiene l'immediato aggiornamento nel Database.
Proprietà pubblica | Document | Restituisce il documento riferito a questo oggetto oppure null se non è presente nel Database.
Proprietà protetta | IgnoreDirty | Restituisce se ignorare le modifiche. (Ereditato da DedCommCollectionItem)
Proprietà pubblica | ModDate | Restituisce la data di ultima modifica. Impostando questa proprietà si ottiene l'immediato aggiornamento nel Database. (Ereditato da DedCommCollectionItem)
Proprietà pubblica | ModUser | Restituisce l'utente dell'ultima modifica. Impostando questa proprietà si ottiene l'immediato aggiornamento nel Database. (Ereditato da DedCommCollectionItem)
Proprietà pubblica | Owner | Restituisce la collezione di appartenenza. (Ereditato da DedCommCollectionItem)
Proprietà pubblica | RowVer | Restituisce la versione del record. (Ereditato da DedCommCollectionItem)
Torna su
Vedi anche

Documentazione

Classe DedCommDocItem
Namespace DedNet.Core


Proprietà DedCommDocItem.Context

Proprietà DedCommDocItemContext
Restituisce o imposta il contesto di associazione. Impostando questa proprietà si ottiene l'immediato aggiornamento nel Database.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocContextEnum Context { get; set; }
Public Property Context As DedDocContextEnum
    Get
    Set
public:
property DedDocContextEnum Context {
    DedDocContextEnum get ();
    void set (DedDocContextEnum value);
}
member Context : DedDocContextEnum with get, set

Valore della proprietà

DedDocContextEnum
Eccezioni
Eccezione | Condizione
QsException | Record non trovato con id e versione dell'oggetto.
QsException | Viene sollevata in caso di errore nell'istruzione di aggiornamento dati.
Vedi anche

Documentazione

Classe DedCommDocItem
Namespace DedNet.Core


Proprietà DedCommDocItem.DocID

Proprietà DedCommDocItemDocID
Restituisce o imposta il DocId del documento collegato. Impostando questa proprietà si ottiene l'immediato aggiornamento nel Database.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Guid DocID { get; set; }
Public Property DocID As Guid
    Get
    Set
public:
property Guid DocID {
    Guid get ();
    void set (Guid value);
}
member DocID : Guid with get, set

Valore della proprietà

Guid
Eccezioni
Eccezione | Condizione
QsException | Record non trovato con id e versione dell'oggetto.
QsException | Viene sollevata in caso di errore nell'istruzione di aggiornamento dati.
Vedi anche

Documentazione

Classe DedCommDocItem
Namespace DedNet.Core


Proprietà DedCommDocItem.Document

Proprietà DedCommDocItemDocument
Restituisce il documento riferito a questo oggetto oppure null se non è presente nel Database.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDoc Document { get; }
Public ReadOnly Property Document As DedDoc
    Get
public:
property DedDoc^ Document {
    DedDoc^ get ();
}
member Document : DedDoc with get

Valore della proprietà

DedDoc
Vedi anche

Documentazione

Classe DedCommDocItem
Namespace DedNet.Core


Metodi di DedCommDocItem

Il tipo DedCommDocItem espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | AddFieldsValues | Aggiunge i valori dei campi da aggiornare escluso il ROWVER, MODDATE e MODUSER, ASSOCDATE e ASSOCUSER che vengono impostati dalla classe base. (Sovrascrive DedCommCollectionItemAddFieldsValues(QSUpdateCommand))
Metodo protetto | AddWhereItemStatement | Aggiunge la calusola where per l'elemento escluso il COMMID che viene impostato nella classe base. (Sovrascrive DedCommCollectionItemAddWhereItemStatement(QSCommandBase))
Metodo protetto | AddWhereStatement | Aggiunge al comando la clausola where senza l'inclusione del ROWVER. (Ereditato da DedCommCollectionItem)
Metodo pubblico | Delete | Elimina questo elemento dalla collezione di appartenenza. (Ereditato da DedCommCollectionItem)
Metodo protetto | EndUpdate | (Ereditato da DedCommCollectionItem)
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | Requery | Rilegge tutte le informazioni dal Database. (Ereditato da DedCommCollectionItem)
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Metodo protetto | Update | Aggiorna l'oggetto nel Database. (Ereditato da DedCommCollectionItem)
Torna su
Vedi anche

Documentazione

Classe DedCommDocItem
Namespace DedNet.Core


Metodo DedCommDocItem.AddFieldsValues

Metodo DedCommDocItemAddFieldsValues
Aggiunge i valori dei campi da aggiornare escluso il ROWVER, MODDATE e MODUSER, ASSOCDATE e ASSOCUSER che vengono impostati dalla classe base.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void AddFieldsValues(
    QSUpdateCommand cmd
)
Protected Overrides Sub AddFieldsValues (
    cmd As QSUpdateCommand
)
protected:
virtual void AddFieldsValues(
    QSUpdateCommand^ cmd
) override
abstract AddFieldsValues :
        cmd : QSUpdateCommand -> unit
override AddFieldsValues :
        cmd : QSUpdateCommand -> unit

Parametri

cmd QSUpdateCommand
Comando di update nel quale impostare i valori dei campi.
Vedi anche

Documentazione

Classe DedCommDocItem
Namespace DedNet.Core


Metodo DedCommDocItem.AddWhereItemStatement

Metodo DedCommDocItemAddWhereItemStatement
Aggiunge la calusola where per l'elemento escluso il COMMID che viene impostato nella classe base.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void AddWhereItemStatement(
    QSCommandBase cmd
)
Protected Overrides Sub AddWhereItemStatement (
    cmd As QSCommandBase
)
protected:
virtual void AddWhereItemStatement(
    QSCommandBase^ cmd
) override
abstract AddWhereItemStatement :
        cmd : QSCommandBase -> unit
override AddWhereItemStatement :
        cmd : QSCommandBase -> unit

Parametri

cmd QSCommandBase
Comando nel quale impostare la clausola where.
Vedi anche

Documentazione

Classe DedCommDocItem
Namespace DedNet.Core


Metodo DedCommDocItem.Equals

Metodo DedCommDocItemEquals

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj Object

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedCommDocItem
Namespace DedNet.Core


Metodo DedCommDocItem.GetHashCode

Metodo DedCommDocItemGetHashCode

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedCommDocItem
Namespace DedNet.Core


Metodo DedCommDocItem.ToString

Metodo DedCommDocItemToString

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedCommDocItem
Namespace DedNet.Core


Classe DedCommList
Lista di oggetti di tipo DedComm.
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList DedComm
DedNet.CoreDedCommList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedCommList : List<DedComm>
Public Class DedCommList
    Inherits List(Of DedComm)
public ref class DedCommList : public List<DedComm^>
type DedCommList =
    class
        inherit List<DedComm>
    end

Il tipo DedCommList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedCommList |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedCommList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommList()
Public Sub New
public:
DedCommList()
new : unit -> DedCommList
Vedi anche

Documentazione

Classe DedCommList
Namespace DedNet.Core


Classe DedCommPerm
Contiene il set di permessi relativi ad una sola commessa ed abbinato ad un unico utente/gruppo.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedPermOwner
DedNet.CoreDedCommPerm

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedCommPerm : DedPermOwner,
    IDedDbItem
Public Class DedCommPerm
    Inherits DedPermOwner
    Implements IDedDbItem
public ref class DedCommPerm : public DedPermOwner,
    IDedDbItem
type DedCommPerm =
    class
        inherit DedPermOwner
        interface IDedDbItem
    end

Il tipo DedCommPerm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione di appartenenza. (Ereditato da DedPermOwner)
Proprietà pubblica | CommId | Restituisce il guid della commessa di appartenenza.
Proprietà pubblica | Dirty | Restituisce true se è dirty la lista dei permessi appartenenti a questo oggetto altrimenti restituisce false.
Proprietà pubblica | IsGroup | Restituisce se il DedPermOwner è un gruppo. (Sovrascrive DedPermOwnerIsGroup)
Proprietà pubblica | IsUser | Restituisce se il DedPermOwner è un utente. (Sovrascrive DedPermOwnerIsUser)
Proprietà pubblica | Manager | Restituisce il Gestore dei permessi. (Ereditato da DedPermOwner)
Proprietà pubblica | Name | Restitusice il nome dell'owner. (Sovrascrive DedPermOwnerName)
Proprietà pubblica | Owner | Restituisce l'utente o il gruppo di appartenenza.
Proprietà pubblica | PermItems | Restitusice il set di permessi di questo possessore. (Ereditato da DedPermOwner)
Proprietà pubblica | StatoRecord | Di uso interno.
Proprietà protetta | TableName | Restituisce il nome della table del Database. (Ereditato da DedPermOwner)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | CreateDeleteCommand | (Sovrascrive DedPermOwnerCreateDeleteCommand(DedPerm))
Metodo protetto | CreateInsertCommand | (Sovrascrive DedPermOwnerCreateInsertCommand(DedPerm))
Metodo protetto | CreateUpdateCommand | (Sovrascrive DedPermOwnerCreateUpdateCommand(DedPerm))
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo protetto | GetDbIndex | (Sovrascrive DedPermOwnerGetDbIndex(DedPerm))
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | GetPermDescription | Restituisce la descrizione del permesso. (Ereditato da DedPermOwner)
Metodo pubblico | GetPermVal(String, String) | Restituisce il valore del permesso. (Sovrascrive DedPermOwnerGetPermVal(String, String))
Metodo pubblico | GetPermVal(String, String, String) | Restituisce il valore del permesso impostando la stringa descrittiva il tipo di ereditarietà del permesso. (Sovrascrive DedPermOwnerGetPermVal(String, String, String))
Metodo pubblico | IsPermPresent | Restituisce se il permesso è presente in modo esplicito fra i permessi di questa instanza. (Ereditato da DedPermOwner)
Metodo pubblico | Save | Salva il set di permessi.
Metodo pubblico | SetPermVal | Imposta il permesso ottenendo la stringa descrittiva del permesso. (Sovrascrive DedPermOwnerSetPermVal(String, String, Boolean))
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di DedCommPerm

Il tipo DedCommPerm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione di appartenenza. (Ereditato da DedPermOwner)
Proprietà pubblica | CommId | Restituisce il guid della commessa di appartenenza.
Proprietà pubblica | Dirty | Restituisce true se è dirty la lista dei permessi appartenenti a questo oggetto altrimenti restituisce false.
Proprietà pubblica | IsGroup | Restituisce se il DedPermOwner è un gruppo. (Sovrascrive DedPermOwnerIsGroup)
Proprietà pubblica | IsUser | Restituisce se il DedPermOwner è un utente. (Sovrascrive DedPermOwnerIsUser)
Proprietà pubblica | Manager | Restituisce il Gestore dei permessi. (Ereditato da DedPermOwner)
Proprietà pubblica | Name | Restitusice il nome dell'owner. (Sovrascrive DedPermOwnerName)
Proprietà pubblica | Owner | Restituisce l'utente o il gruppo di appartenenza.
Proprietà pubblica | PermItems | Restitusice il set di permessi di questo possessore. (Ereditato da DedPermOwner)
Proprietà pubblica | StatoRecord | Di uso interno.
Proprietà protetta | TableName | Restituisce il nome della table del Database. (Ereditato da DedPermOwner)
Torna su
Vedi anche

Documentazione

Classe DedCommPerm
Namespace DedNet.Core


Proprietà DedCommPerm.CommId

Proprietà DedCommPermCommId
Restituisce il guid della commessa di appartenenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Guid CommId { get; set; }
Public Property CommId As Guid
    Get
    Set
public:
property Guid CommId {
    Guid get ();
    void set (Guid value);
}
member CommId : Guid with get, set

Valore della proprietà

Guid
Vedi anche

Documentazione

Classe DedCommPerm
Namespace DedNet.Core


Proprietà DedCommPerm.Dirty

Proprietà DedCommPermDirty
Restituisce true se è dirty la lista dei permessi appartenenti a questo oggetto altrimenti restituisce false.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Dirty { get; }
Public ReadOnly Property Dirty As Boolean
    Get
public:
property bool Dirty {
    bool get ();
}
member Dirty : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedCommPerm
Namespace DedNet.Core


Proprietà DedCommPerm.IsGroup

Proprietà DedCommPermIsGroup
Restituisce se il DedPermOwner è un gruppo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool IsGroup { get; }
Public Overrides ReadOnly Property IsGroup As Boolean
    Get
public:
virtual property bool IsGroup {
    bool get () override;
}
abstract IsGroup : bool with get
override IsGroup : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedCommPerm
Namespace DedNet.Core


Proprietà DedCommPerm.IsUser

Proprietà DedCommPermIsUser
Restituisce se il DedPermOwner è un utente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool IsUser { get; }
Public Overrides ReadOnly Property IsUser As Boolean
    Get
public:
virtual property bool IsUser {
    bool get () override;
}
abstract IsUser : bool with get
override IsUser : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedCommPerm
Namespace DedNet.Core


Proprietà DedCommPerm.Name

Proprietà DedCommPermName
Restitusice il nome dell'owner.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string Name { get; }
Public Overrides ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () override;
}
abstract Name : string with get
override Name : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedCommPerm
Namespace DedNet.Core


Proprietà DedCommPerm.Owner

Proprietà DedCommPermOwner
Restituisce l'utente o il gruppo di appartenenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedPermOwner Owner { get; }
Public ReadOnly Property Owner As DedPermOwner
    Get
public:
property DedPermOwner^ Owner {
    DedPermOwner^ get ();
}
member Owner : DedPermOwner with get

Valore della proprietà

DedPermOwner
Vedi anche

Documentazione

Classe DedCommPerm
Namespace DedNet.Core


Proprietà DedCommPerm.StatoRecord

Proprietà DedCommPermStatoRecord
Di uso interno.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public StatoRecord StatoRecord { get; set; }
Public Property StatoRecord As StatoRecord
    Get
    Set
public:
virtual property StatoRecord^ StatoRecord {
    StatoRecord^ get () sealed;
    void set (StatoRecord^ value) sealed;
}
abstract StatoRecord : StatoRecord with get, set
override StatoRecord : StatoRecord with get, set

Valore della proprietà

StatoRecord

Implementa

IDedDbItemStatoRecord
Vedi anche

Documentazione

Classe DedCommPerm
Namespace DedNet.Core


Metodi di DedCommPerm

Il tipo DedCommPerm espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | CreateDeleteCommand | (Sovrascrive DedPermOwnerCreateDeleteCommand(DedPerm))
Metodo protetto | CreateInsertCommand | (Sovrascrive DedPermOwnerCreateInsertCommand(DedPerm))
Metodo protetto | CreateUpdateCommand | (Sovrascrive DedPermOwnerCreateUpdateCommand(DedPerm))
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo protetto | GetDbIndex | (Sovrascrive DedPermOwnerGetDbIndex(DedPerm))
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | GetPermDescription | Restituisce la descrizione del permesso. (Ereditato da DedPermOwner)
Metodo pubblico | GetPermVal(String, String) | Restituisce il valore del permesso. (Sovrascrive DedPermOwnerGetPermVal(String, String))
Metodo pubblico | GetPermVal(String, String, String) | Restituisce il valore del permesso impostando la stringa descrittiva il tipo di ereditarietà del permesso. (Sovrascrive DedPermOwnerGetPermVal(String, String, String))
Metodo pubblico | IsPermPresent | Restituisce se il permesso è presente in modo esplicito fra i permessi di questa instanza. (Ereditato da DedPermOwner)
Metodo pubblico | Save | Salva il set di permessi.
Metodo pubblico | SetPermVal | Imposta il permesso ottenendo la stringa descrittiva del permesso. (Sovrascrive DedPermOwnerSetPermVal(String, String, Boolean))
Torna su
Vedi anche

Documentazione

Classe DedCommPerm
Namespace DedNet.Core


Metodo DedCommPerm.CreateDeleteCommand

Metodo DedCommPermCreateDeleteCommand

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal override QSDeleteCommand CreateDeleteCommand(
    DedPerm item
)
Protected Friend Overrides Function CreateDeleteCommand (
    item As DedPerm
) As QSDeleteCommand
protected public:
virtual QSDeleteCommand^ CreateDeleteCommand(
    DedPerm^ item
) override
abstract CreateDeleteCommand :
        item : DedPerm -> QSDeleteCommand
override CreateDeleteCommand :
        item : DedPerm -> QSDeleteCommand

Parametri

item DedPerm

Valore di ritorno

QSDeleteCommand
Vedi anche

Documentazione

Classe DedCommPerm
Namespace DedNet.Core


Metodo DedCommPerm.CreateInsertCommand

Metodo DedCommPermCreateInsertCommand

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal override QSInsertCommand CreateInsertCommand(
    DedPerm item
)
Protected Friend Overrides Function CreateInsertCommand (
    item As DedPerm
) As QSInsertCommand
protected public:
virtual QSInsertCommand^ CreateInsertCommand(
    DedPerm^ item
) override
abstract CreateInsertCommand :
        item : DedPerm -> QSInsertCommand
override CreateInsertCommand :
        item : DedPerm -> QSInsertCommand

Parametri

item DedPerm

Valore di ritorno

QSInsertCommand
Vedi anche

Documentazione

Classe DedCommPerm
Namespace DedNet.Core


Metodo DedCommPerm.CreateUpdateCommand

Metodo DedCommPermCreateUpdateCommand

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal override QSUpdateCommand CreateUpdateCommand(
    DedPerm item
)
Protected Friend Overrides Function CreateUpdateCommand (
    item As DedPerm
) As QSUpdateCommand
protected public:
virtual QSUpdateCommand^ CreateUpdateCommand(
    DedPerm^ item
) override
abstract CreateUpdateCommand :
        item : DedPerm -> QSUpdateCommand
override CreateUpdateCommand :
        item : DedPerm -> QSUpdateCommand

Parametri

item DedPerm

Valore di ritorno

QSUpdateCommand
Vedi anche

Documentazione

Classe DedCommPerm
Namespace DedNet.Core


Metodo DedCommPerm.Equals

Metodo DedCommPermEquals

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj Object

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedCommPerm
Namespace DedNet.Core


Metodo DedCommPerm.GetDbIndex

Metodo DedCommPermGetDbIndex

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal override Object GetDbIndex(
    DedPerm item
)
Protected Friend Overrides Function GetDbIndex (
    item As DedPerm
) As Object
protected public:
virtual Object^ GetDbIndex(
    DedPerm^ item
) override
abstract GetDbIndex :
        item : DedPerm -> Object
override GetDbIndex :
        item : DedPerm -> Object

Parametri

item DedPerm

Valore di ritorno

Object
Vedi anche

Documentazione

Classe DedCommPerm
Namespace DedNet.Core


Metodo DedCommPerm.GetHashCode

Metodo DedCommPermGetHashCode

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedCommPerm
Namespace DedNet.Core


Metodo DedCommPerm.GetPermVal

Metodo DedCommPermGetPermVal
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | GetPermVal(String, String) | Restituisce il valore del permesso.
Metodo pubblico | GetPermVal(String, String, String) | Restituisce il valore del permesso impostando la stringa descrittiva il tipo di ereditarietà del permesso.
Torna su
Vedi anche

Documentazione

Classe DedCommPerm
Namespace DedNet.Core


Metodo DedCommPerm.GetPermVal(String, String)

Metodo DedCommPermGetPermVal(String, String)
Restituisce il valore del permesso.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool GetPermVal(
    string PermName,
    string discrim
)
Public Overrides Function GetPermVal (
    PermName As String,
    discrim As String
) As Boolean
public:
virtual bool GetPermVal(
    String^ PermName,
    String^ discrim
) override
abstract GetPermVal :
        PermName : string *
        discrim : string -> bool
override GetPermVal :
        PermName : string *
        discrim : string -> bool

Parametri

PermName String
discrim String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedCommPerm
Overload di GetPermVal
Namespace DedNet.Core


Metodo DedCommPerm.GetPermVal(String, String, String)

Metodo DedCommPermGetPermVal(String, String, String)
Restituisce il valore del permesso impostando la stringa descrittiva il tipo di ereditarietà del permesso.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool GetPermVal(
    string PermName,
    string discrim,
    out string PermDesc
)
Public Overrides Function GetPermVal (
    PermName As String,
    discrim As String,
    <OutAttribute> ByRef PermDesc As String
) As Boolean
public:
virtual bool GetPermVal(
    String^ PermName,
    String^ discrim,
    [OutAttribute] String^% PermDesc
) override
abstract GetPermVal :
        PermName : string *
        discrim : string *
        PermDesc : string byref -> bool
override GetPermVal :
        PermName : string *
        discrim : string *
        PermDesc : string byref -> bool

Parametri

PermName String
discrim String
PermDesc String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedCommPerm
Overload di GetPermVal
Namespace DedNet.Core


Metodo DedCommPerm.Save

Metodo DedCommPermSave
Salva il set di permessi.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Save()
Public Sub Save
public:
void Save()
member Save : unit -> unit
Vedi anche

Documentazione

Classe DedCommPerm
Namespace DedNet.Core


Metodo DedCommPerm.SetPermVal

Metodo DedCommPermSetPermVal
Imposta il permesso ottenendo la stringa descrittiva del permesso.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string SetPermVal(
    string PermName,
    string discrim,
    bool Valore
)
Public Overrides Function SetPermVal (
    PermName As String,
    discrim As String,
    Valore As Boolean
) As String
public:
virtual String^ SetPermVal(
    String^ PermName,
    String^ discrim,
    bool Valore
) override
abstract SetPermVal :
        PermName : string *
        discrim : string *
        Valore : bool -> string
override SetPermVal :
        PermName : string *
        discrim : string *
        Valore : bool -> string

Parametri

PermName String
discrim String
Valore Boolean

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedCommPerm
Namespace DedNet.Core


Classe DedCommPermList
Collezione di oggetti DedCommPerm.
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList DedCommPerm
DedNet.CoreDedCommPermList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedCommPermList : List<DedCommPerm>
Public Class DedCommPermList
    Inherits List(Of DedCommPerm)
public ref class DedCommPermList : public List<DedCommPerm^>
type DedCommPermList =
    class
        inherit List<DedCommPerm>
    end

Il tipo DedCommPermList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedCommPermList |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedCommPermList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommPermList()
Public Sub New
public:
DedCommPermList()
new : unit -> DedCommPermList
Vedi anche

Documentazione

Classe DedCommPermList
Namespace DedNet.Core


Classe DedCommType
Descrive una commessa di codifica Data and Drawings. Al suo interno sono presenti i riferimenti agli attributi specifici della commessa e alle regole di composizione. Alcune proprietà restituiscono il valore ereditato dalle commesse di livello superiore.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedTypeBase
DedNet.CoreDedCommType

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedCommType : DedTypeBase
Public Class DedCommType
    Inherits DedTypeBase
public ref class DedCommType : public DedTypeBase
type DedCommType =
    class
        inherit DedTypeBase
    end

Il tipo DedCommType espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione di appartenenza. (Ereditato da DedTypeBase)
Proprietà pubblica | AttributeCommAlterTable | Indica se sono stati modificati gli attributi delle commesse e devono essere ricreati tramite Alter Table.
Proprietà pubblica | AttributeCommAnagrAlterTable | Indica se sono stati modificati gli attributi delle anagrafiche di commessa e devono essere ricreati tramite Alter Table.
Proprietà pubblica | AttributeDirty | Restituisce se sono state modificati gli attributi.
Proprietà pubblica | Attributes | Restituisce la lista di attributi visibili da questa commessa. Se non ce ne sono viene restituita una lista inizializzata ma vuota. Attenzione! Viene istanziato un nuovo DedAttrList ogni volta che si accede a questa proprietà. (Sovrascrive DedTypeBaseAttributes)
Proprietà pubblica | AttributesAnagrComm | Restituisce la lista di attributi di anagrafica di commessa visibili da questa commessa. Se non ce ne sono viene restituita una lista inizializzata ma vuota.
Proprietà pubblica | AttributesComm |
Proprietà pubblica | BackColor | Restituisce il colore di sfondo. (Ereditato da DedTypeBase)
Proprietà pubblica | CalculatedAttrs | Lista che contiene quali attributi sono considerati 'importati'. (Ereditato da DedTypeBase)
Proprietà pubblica | ClonedFrom | Indica se la famiglia è stata clonata e da quale (Ereditato da DedTypeBase)
Proprietà pubblica | Cod_Id | Restituisce la maschera di codifica per DED_ID, eventualmente ereditata. (Ereditato da DedTypeBase)
Proprietà pubblica | DbPath | Restituisce il DbPath della famiglia. (Ereditato da DedTypeBase)
Proprietà pubblica | Descriz | Restituisce/Imposta la descrizione della famiglia. (Ereditato da DedTypeBase)
Proprietà pubblica | Dirty | Restituisce se l'oggetto sia stato modificato oppure se sia stata modificata una delle sue collezioni. (Sovrascrive DedTypeBaseDirty)
Proprietà pubblica | DirtyName | Indica se è stato modificato il nome della famiglia. (Ereditato da DedTypeBase)
Proprietà pubblica | FamFirstLev | Restituisce la famiglia a 1° livello. (Ereditato da DedTypeBase)
Proprietà pubblica | ForeColor | Restituisce il colore del testo. (Ereditato da DedTypeBase)
Proprietà pubblica | FreeCode | Restituisce/Imposta se la famiglia è a codifica libera. (Ereditato da DedTypeBase)
Proprietà pubblica | FreeFile | Restituisce/Imposta se la famiglia è a codifica file libera. (Ereditato da DedTypeBase)
Proprietà pubblica | FreeFileAsDedId | Restituisce/Imposta se il file debba essere compilato come l'id. (Ereditato da DedTypeBase)
Proprietà pubblica | FreeFileSameFileRev | Restituisce/Imposta se il file debba rimanere uguale anche nelle revisioni. (Ereditato da DedTypeBase)
Proprietà pubblica | HasAttributes | Restituisce se sono presenti attributi (di commessa o di anagrafica di commessa) specifici della commessa. (Sovrascrive DedTypeBaseHasAttributes)
Proprietà pubblica | HasAttributesAnagrComm | Restituisce se sono presenti attributi di anagrafica di commessa specifici della commessa.
Proprietà pubblica | HasAttributesComm | Restituisce se sono presenti attributi di commessa specifici della commessa.
Proprietà pubblica | HasClonedPerm | Indica se sono stati clonati anche dei permessi.
Proprietà pubblica | HasCod_Id | Restituisce se è presente la codifica del DEDID. (Ereditato da DedTypeBase)
Proprietà pubblica | HasInfoUser | Restiutuisce se la famiglia ha il tassello utente o la variante automatica nell'id. (Ereditato da DedTypeBase)
Proprietà pubblica | HasMaster | Restituisce se è presente il master (Ereditato da DedTypeBase)
Proprietà pubblica | HasParent | Restituisce se è presente un oggetto genitore. (Ereditato da DedTypeBase)
Proprietà pubblica | HasProgr | Restituisce se la famiglia ha il progressivo locale impostato e non lo eredita (MyProgr> -1). (Ereditato da DedTypeBase)
Proprietà pubblica | HasProgrAlphabet | Restituisce se è presente l'alfabeto del progressivo. (Ereditato da DedTypeBase)
Proprietà pubblica | HasRevisionAlphabet | Restituisce se è presente l'alfabeto della revisione. (Ereditato da DedTypeBase)
Proprietà pubblica | HasRules | Restituisce se sono presenti regole di autocomposizione specifiche della famiglia. (Ereditato da DedTypeBase)
Proprietà pubblica | HasSubTypes | Restituisce se sono presenti sottotipi della famiglia. (Ereditato da DedTypeBase)
Proprietà pubblica | HasVar | Restiutuisce se la famiglia ha la variante automatica nell'id. (Ereditato da DedTypeBase)
Proprietà pubblica | HasVarAlphabet | Restituisce se è presente l'alfabeto del progressivo. (Ereditato da DedTypeBase)
Proprietà pubblica | IsCompleted | Restituisce se la commessa è completa ovvero può essere utilizzata come commessa terminale di codifica. (Sovrascrive DedTypeBaseIsCompleted)
Proprietà pubblica | IsPrj | Restituisce se si tratti di una famiglia di tipo progetto (eventualmente ereditato). (Ereditato da DedTypeBase)
Proprietà pubblica | IsRoot | Restituisce se si tratta della root dell'albero dei tipi. (Ereditato da DedTypeBase)
Proprietà pubblica | Level | Restituisce il livello di questa famiglia, partendo da 0 per la famiglia root. (Ereditato da DedTypeBase)
Proprietà pubblica | Master | Identifica il master collegato alla tipologia (Ereditato da DedTypeBase)
Proprietà pubblica | MyAttributes | Restituisce la lista di attributi abbinati a questa commessa. Se non ce ne sono viene restituita una lista inizializzata ma vuota. (Sovrascrive DedTypeBaseMyAttributes)
Proprietà pubblica | MyAttributesAnagrComm | Restituisce la lista di attributi di anagrafica di commessa abbinati a questa commessa. Se non ce ne sono viene restituita una lista inizializzata ma vuota.
Proprietà pubblica | MyAttributesComm | Restituisce la lista di attributi di commessa abbinati a questa commessa. Se non ce ne sono viene restituita una lista inizializzata ma vuota.
Proprietà pubblica | MyCod_Id | Restituisce/Imposta la maschera di codifica per DED_ID di questa famiglia. (Ereditato da DedTypeBase)
Proprietà pubblica | MyIsPrj | Restituisce/Imposta se si tratti di una famiglia di tipo progetto (questa famiglia). (Ereditato da DedTypeBase)
Proprietà pubblica | MyMaster | Identifica il master collegato alla tipologia (Ereditato da DedTypeBase)
Proprietà pubblica | MyProgr | Restituisce/Imposta il valore del progressivo strettamente di questa famiglia. Non interroga il Database ma restituisce il valore della cache. (Ereditato da DedTypeBase)
Proprietà pubblica | MyProgrAlphabet | Restituisce/Imposta l'alfabeto per il progressivo di questa famiglia. (Ereditato da DedTypeBase)
Proprietà pubblica | MyRevisionAlphabet | Restituisce/Imposta l'alfabeto per il progressivo di questa famiglia. (Ereditato da DedTypeBase)
Proprietà pubblica | MyRules | Restituisce la lista delle regole di autocomposizione di questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota. (Ereditato da DedTypeBase)
Proprietà pubblica | MyVarAlphabet | Restituisce/Imposta l'alfabeto per la variante di questa famiglia. (Ereditato da DedTypeBase)
Proprietà pubblica | Nome | Restituisce/Imposta il nome della famiglia. (Ereditato da DedTypeBase)
Proprietà pubblica | Parent | Restituisce la collezione di appartenenza. (Ereditato da DedTypeBase)
Proprietà pubblica | Progr | Restituisce il progressivo eventualmente ereditato, se non presente in questa famiglia. (Ereditato da DedTypeBase)
Proprietà pubblica | ProgrAlphabet | Restituisce l'alfabeto per la variante di questa famiglia. Restitusice l'alfabeto ereditato se non è impostato per questa famiglia. (Ereditato da DedTypeBase)
Proprietà pubblica | ReservedProgTableName | Tabella relativa ai progressivi riservati (Sovrascrive DedTypeBaseReservedProgTableName)
Proprietà pubblica | RevisionAlphabet | Restituisce l'alfabeto per il progressivo di questa famiglia. Restitusice l'alfabeto ereditato se non è impostato per questa famiglia. (Ereditato da DedTypeBase)
Proprietà pubblica | Root | Restituisce la Root della collezione (Sovrascrive DedTypeBaseRoot)
Proprietà pubblica | RuleDirty | Restituisce se sono state modificate le regole. (Ereditato da DedTypeBase)
Proprietà pubblica | Rules | Restituisce la lista delle regole di autocomposizione visibili da questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota. (Ereditato da DedTypeBase)
Proprietà pubblica | RuleTableName | Tabella relativa alle regole dell'oggetto (Sovrascrive DedTypeBaseRuleTableName)
Proprietà pubblica | StatoRecord | Restituisce o imposta lo stato del record. DI USO INTERNO !! (Ereditato da DedTypeBase)
Proprietà pubblica | SubTypes | Restituisce la lista delle sottocommesse di questa commessa. Se non ce ne sono viene restituita una lista inizializzata ma vuota. (Sovrascrive DedTypeBaseSubTypes)
Proprietà pubblica | TableName | Tabella relativa all'oggetto (Sovrascrive DedTypeBaseTableName)
Proprietà pubblica | TypeDirty | Restituisce se sono state modificate le famiglie. (Ereditato da DedTypeBase)
Proprietà pubblica | VarAlphabet | Restituisce l'alfabeto per il progressivo di questa famiglia. Restitusice l'alfabeto ereditato se non è impostato per questa famiglia. (Ereditato da DedTypeBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Clone | Metodo per clonare la commessa.
Metodo pubblico | DecodeDedId(String) | Decodifica una stinga come DEDID appartenente a questa commessa, restituendo un oggetto descrittivo della codifica. (Sovrascrive DedTypeBaseDecodeDedId(String))
Metodo pubblico | DecodeDedId(String, String) | Decodifica una stinga come DEDID appartenente a questa commessa, restituendo un oggetto descrittivo della codifica. (Sovrascrive DedTypeBaseDecodeDedId(String, String))
Metodo pubblico | EncodeDedId | Inserisce nelle info passate questa stessa commessa e poi crea e restituisce il DEDID corrispondente alla maschera di codifica presente o ereditata da questa commessa. (Sovrascrive DedTypeBaseEncodeDedId(DedEncodeInfo))
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | FindAttrByName | Cerca un attributo con un determinato nome tra gli attributi visibili da questa commessa. Restitusice null se non lo trova. (Sovrascrive DedTypeBaseFindAttrByName(String))
Metodo pubblico | FindAttrByPrompt | Cerca un attributo con un determinato prompt tra gli attributi visibili da questa commessa. Restitusice null se non lo trova. (Sovrascrive DedTypeBaseFindAttrByPrompt(String))
Metodo pubblico | FindBusyProgrRecursive | Scorre ricorsivamente tutte le commesse per conoscere tutti i progressivi utilizzati. (Sovrascrive DedTypeBaseFindBusyProgrRecursive(DedTypeBase, DictionaryString, String, String, DataTable))
Metodo pubblico | FindByDbPath | Cerca il tipo corrispondente al dbpath passato in tutto l'albero partendo dalla radice. (Sovrascrive DedTypeBaseFindByDbPath(String))
Metodo pubblico | ForEachChild | Questo metodo chiama un delegate passandogli in sequenza il nodo corrente (opzionalmente) e tutti i suoi nodi figli. (Ereditato da DedTypeBase)
Metodo pubblico | ForEachParent | Questo metodo chiama un delegate passandogli in sequenza il nodo root e giù fino al nodo corrente (opzionalmente) Lo scorrimento avviene quindi in modo discendente dal padre di tutti verso l'oggetto corrente. (Ereditato da DedTypeBase)
Metodo pubblico | FormatDedRev | Data una stringa di revisione restituisce il valore correttamente formattato e della giusta dimensione per questa famiglia. Es: "1" -> "01" (con rev. di 2 caratteri); "12" -> "012" (con rev. di 3 caratteri); "05" -> "5" (con rev. di 1 carattere); (Ereditato da DedTypeBase)
Metodo pubblico | FormatProgr | Data una stringa di progressivo restituisce il valore correttamente formattato e della giusta dimensione per questa famiglia. Es: "1" -> "001" (progr. di 3 caratteri); "12" -> "012" (progr. di 3 caratteri); "05" -> "5" (progr. di 1 carattere); (Ereditato da DedTypeBase)
Metodo pubblico | FormatVar | Data una stringa della variante restituisce il valore correttamente formattato e della giusta dimensione per questa famiglia. Es: "1" -> "001" (progr. di 3 caratteri); "12" -> "012" (progr. di 3 caratteri); "05" -> "5" (progr. di 1 carattere); (Ereditato da DedTypeBase)
Metodo pubblico | ForOneChild | Questo metodo chiama un delegate passandogli in sequenza il nodo corrente (opzionalmente) e tutti i suoi nodi figli. (Ereditato da DedTypeBase)
Metodo pubblico | GetAttrNameFromPrompt | Restituisce il nome di un attributo visibile da questa famiglia dato il suo prompt. (Ereditato da DedTypeBase)
Metodo pubblico | GetAttrsFromCategory(DedCateg) | Ritorna la lista di attributi visibili dalla famiglia che appartengono alla categoria passata. (Ereditato da DedTypeBase)
Metodo pubblico | GetAttrsFromCategory(String) | Ritorna la lista di attributi visibili dalla famiglia che appartengono alla categoria passata. (Ereditato da DedTypeBase)
Metodo pubblico | GetBusyProgr | Restituisce un dizionario con tutti i progressivi utilizzati. (Ereditato da DedTypeBase)
Metodo pubblico | GetFamSpecificLevel | Restituisce la famiglia a n° livello. (Ereditato da DedTypeBase)
Metodo pubblico | GetFamSpecificNegativeLevel | Restituisce la famiglia a n° livello negativo. (Ereditato da DedTypeBase)
Metodo pubblico | GetFieldsCod | Restituisce la lista delle stringhe nella queli cercare i tasselli. (Ereditato da DedTypeBase)
Metodo pubblico | GetFirstParentHasProg | Restituisce la prima famiglia genitore che ha il progressivo locale.Considera anche il nodo corrente per avere la sicurezza che se viene chiamato su una famiglia con con progressivo impostato non lo calcoli sul padre ma su se stesso. (Ereditato da DedTypeBase)
Metodo pubblico | GetFreeProgr | Restituisce una lista sempre inizializzata e ordinata con tutti i progressivi liberi per questa famiglia. (Ereditato da DedTypeBase)
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | GetLastProgr | Restituisce l'ultimo progressivo possibile per questa famiglia. (Ereditato da DedTypeBase)
Metodo pubblico | GetMaxTokenNum | Restituisce il massimo numero di caratteri usati per il TokenTypeEnum passato. Verifica nella maschera di codifica Cod_Id, Cod_Fil e Cod_Dis in modo da prendere il numero massimo di caratteri utilizzati. (Ereditato da DedTypeBase)
Metodo pubblico | GetParentAttributes | Restituisce la lista degli attributi dei miei genitori.
Metodo pubblico | GetParentTypes | Restituisce una lista dei DedTypeList genitori, compresa l'istanza stessa se specificato. (Sovrascrive DedTypeBaseGetParentTypes(Boolean))
Metodo pubblico | GetProgr(Boolean) | Restituisce il progressivo della famiglia che ha invocato il metodo oppure il progressivo della prima famiglia genitore che lo possiede. Lavora sull'utente attualmente connesso ( se deve lavorare in DED_TIPI_PROG ). (Ereditato da DedTypeBase)
Metodo pubblico | GetProgr(Boolean, String) | Restituisce il progressivo della famiglia che ha invocato il metodo oppure il progressivo della prima famiglia genitore che lo possiede (Ereditato da DedTypeBase)
Metodo pubblico | GetProgrTokenNum | Restituisce il numero di caratteri da utilizzare per creare la stringa del progressivo per questa famiglia. Li calcola cercando il tassello del progressivo nella codifica del Cod_Id. Se non è presente restituisce 0. (Ereditato da DedTypeBase)
Metodo pubblico | GetRightMask | Restituisce il TokenInfo cercato nella prima maschera di codifica trovata, da utilizzare poi per calcolare il numero di tasselli per un particolare token. Restituisce null se non la trova. (Ereditato da DedTypeBase)
Metodo pubblico | InternalSave | Save chiamato dalla commessa padre per salvare le modifiche di questa commessa. NON UTILIZZARE DIRETTAMENTE!
Metodo pubblico | MakeAttrsDictionary | Riempie il dizionario _dizfields. (Ereditato da DedTypeBase)
Metodo pubblico | NotifyDirty | In base al fatto che si tratti della root o meno notifica al parent corretto l'avvenuta modifica della proprietà. (Sovrascrive DedTypeBaseNotifyDirty)
Metodo pubblico | Save | Salva tutta la struttura discendente (da questa in giù) delle commesse. (Sovrascrive DedTypeBaseSave)
Metodo pubblico | SetProgr(String, String, Boolean) | Imposta il progressivo di questa famiglia o della famiglia dalla quale questa eredita il progressivo. Lavora sull'utente attualmente connesso ( se deve lavorare in DED_TIPI_PROG ). (Ereditato da DedTypeBase)
Metodo pubblico | SetProgr(String, String, Boolean, String) | Imposta il progressivo di questa famiglia o della famiglia dalla quale questa eredita il progressivo. (Ereditato da DedTypeBase)
Metodo pubblico | SetProgr(String, String, Boolean, String, Boolean) | Imposta il progressivo di questa famiglia o della famiglia dalla quale questa eredita il progressivo. (Ereditato da DedTypeBase)
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Metodo pubblico | WaitForUpdate | Esegue una query con WITH (XLOCK) in modo da aspettare finchè altri utenti non hanno commitato. (Ereditato da DedTypeBase)
Torna su
Campi
 | Nome | Descrizione
Campo pubblico | _analyzedTypes | (Ereditato da DedTypeBase)
Campo pubblico | _app | (Ereditato da DedTypeBase)
Campo pubblico | _attributes | (Ereditato da DedTypeBase)
Campo pubblico | _backcolor | (Ereditato da DedTypeBase)
Campo pubblico | _calculatedAttrs | (Ereditato da DedTypeBase)
Campo pubblico | _clonedFrom | (Ereditato da DedTypeBase)
Campo pubblico | _cod_id | (Ereditato da DedTypeBase)
Campo pubblico | _dbPath | (Ereditato da DedTypeBase)
Campo pubblico | _dbPathLoaded | (Ereditato da DedTypeBase)
Campo pubblico | _descriz | (Ereditato da DedTypeBase)
Campo pubblico | _dirtyname | (Ereditato da DedTypeBase)
Campo pubblico | _dwgpath | (Ereditato da DedTypeBase)
Campo pubblico | _forecolor | (Ereditato da DedTypeBase)
Campo pubblico | _freecode | (Ereditato da DedTypeBase)
Campo pubblico | _isprj | (Ereditato da DedTypeBase)
Campo pubblico | _isRoot | Indica se questa famiglia sia o meno la root. (Ereditato da DedTypeBase)
Campo pubblico | _master | (Ereditato da DedTypeBase)
Campo pubblico | _name | (Ereditato da DedTypeBase)
Campo pubblico | _oldDwgPath | (Ereditato da DedTypeBase)
Campo pubblico | _parent | Collezione di appartenenza. (Ereditato da DedTypeBase)
Campo pubblico | _progr | (Ereditato da DedTypeBase)
Campo pubblico | _progrAlphabet | (Ereditato da DedTypeBase)
Campo pubblico | _revisionAlphabet | (Ereditato da DedTypeBase)
Campo pubblico | _rootCollection | Collezione dedicata al salvataggio della root. (Ereditato da DedTypeBase)
Campo pubblico | _rules | (Ereditato da DedTypeBase)
Campo pubblico | _subtypes | (Ereditato da DedTypeBase)
Campo pubblico | _varAlphabet | (Ereditato da DedTypeBase)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di DedCommType

Il tipo DedCommType espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione di appartenenza. (Ereditato da DedTypeBase)
Proprietà pubblica | AttributeCommAlterTable | Indica se sono stati modificati gli attributi delle commesse e devono essere ricreati tramite Alter Table.
Proprietà pubblica | AttributeCommAnagrAlterTable | Indica se sono stati modificati gli attributi delle anagrafiche di commessa e devono essere ricreati tramite Alter Table.
Proprietà pubblica | AttributeDirty | Restituisce se sono state modificati gli attributi.
Proprietà pubblica | Attributes | Restituisce la lista di attributi visibili da questa commessa. Se non ce ne sono viene restituita una lista inizializzata ma vuota. Attenzione! Viene istanziato un nuovo DedAttrList ogni volta che si accede a questa proprietà. (Sovrascrive DedTypeBaseAttributes)
Proprietà pubblica | AttributesAnagrComm | Restituisce la lista di attributi di anagrafica di commessa visibili da questa commessa. Se non ce ne sono viene restituita una lista inizializzata ma vuota.
Proprietà pubblica | AttributesComm |
Proprietà pubblica | BackColor | Restituisce il colore di sfondo. (Ereditato da DedTypeBase)
Proprietà pubblica | CalculatedAttrs | Lista che contiene quali attributi sono considerati 'importati'. (Ereditato da DedTypeBase)
Proprietà pubblica | ClonedFrom | Indica se la famiglia è stata clonata e da quale (Ereditato da DedTypeBase)
Proprietà pubblica | Cod_Id | Restituisce la maschera di codifica per DED_ID, eventualmente ereditata. (Ereditato da DedTypeBase)
Proprietà pubblica | DbPath | Restituisce il DbPath della famiglia. (Ereditato da DedTypeBase)
Proprietà pubblica | Descriz | Restituisce/Imposta la descrizione della famiglia. (Ereditato da DedTypeBase)
Proprietà pubblica | Dirty | Restituisce se l'oggetto sia stato modificato oppure se sia stata modificata una delle sue collezioni. (Sovrascrive DedTypeBaseDirty)
Proprietà pubblica | DirtyName | Indica se è stato modificato il nome della famiglia. (Ereditato da DedTypeBase)
Proprietà pubblica | FamFirstLev | Restituisce la famiglia a 1° livello. (Ereditato da DedTypeBase)
Proprietà pubblica | ForeColor | Restituisce il colore del testo. (Ereditato da DedTypeBase)
Proprietà pubblica | FreeCode | Restituisce/Imposta se la famiglia è a codifica libera. (Ereditato da DedTypeBase)
Proprietà pubblica | FreeFile | Restituisce/Imposta se la famiglia è a codifica file libera. (Ereditato da DedTypeBase)
Proprietà pubblica | FreeFileAsDedId | Restituisce/Imposta se il file debba essere compilato come l'id. (Ereditato da DedTypeBase)
Proprietà pubblica | FreeFileSameFileRev | Restituisce/Imposta se il file debba rimanere uguale anche nelle revisioni. (Ereditato da DedTypeBase)
Proprietà pubblica | HasAttributes | Restituisce se sono presenti attributi (di commessa o di anagrafica di commessa) specifici della commessa. (Sovrascrive DedTypeBaseHasAttributes)
Proprietà pubblica | HasAttributesAnagrComm | Restituisce se sono presenti attributi di anagrafica di commessa specifici della commessa.
Proprietà pubblica | HasAttributesComm | Restituisce se sono presenti attributi di commessa specifici della commessa.
Proprietà pubblica | HasClonedPerm | Indica se sono stati clonati anche dei permessi.
Proprietà pubblica | HasCod_Id | Restituisce se è presente la codifica del DEDID. (Ereditato da DedTypeBase)
Proprietà pubblica | HasInfoUser | Restiutuisce se la famiglia ha il tassello utente o la variante automatica nell'id. (Ereditato da DedTypeBase)
Proprietà pubblica | HasMaster | Restituisce se è presente il master (Ereditato da DedTypeBase)
Proprietà pubblica | HasParent | Restituisce se è presente un oggetto genitore. (Ereditato da DedTypeBase)
Proprietà pubblica | HasProgr | Restituisce se la famiglia ha il progressivo locale impostato e non lo eredita (MyProgr> -1). (Ereditato da DedTypeBase)
Proprietà pubblica | HasProgrAlphabet | Restituisce se è presente l'alfabeto del progressivo. (Ereditato da DedTypeBase)
Proprietà pubblica | HasRevisionAlphabet | Restituisce se è presente l'alfabeto della revisione. (Ereditato da DedTypeBase)
Proprietà pubblica | HasRules | Restituisce se sono presenti regole di autocomposizione specifiche della famiglia. (Ereditato da DedTypeBase)
Proprietà pubblica | HasSubTypes | Restituisce se sono presenti sottotipi della famiglia. (Ereditato da DedTypeBase)
Proprietà pubblica | HasVar | Restiutuisce se la famiglia ha la variante automatica nell'id. (Ereditato da DedTypeBase)
Proprietà pubblica | HasVarAlphabet | Restituisce se è presente l'alfabeto del progressivo. (Ereditato da DedTypeBase)
Proprietà pubblica | IsCompleted | Restituisce se la commessa è completa ovvero può essere utilizzata come commessa terminale di codifica. (Sovrascrive DedTypeBaseIsCompleted)
Proprietà pubblica | IsPrj | Restituisce se si tratti di una famiglia di tipo progetto (eventualmente ereditato). (Ereditato da DedTypeBase)
Proprietà pubblica | IsRoot | Restituisce se si tratta della root dell'albero dei tipi. (Ereditato da DedTypeBase)
Proprietà pubblica | Level | Restituisce il livello di questa famiglia, partendo da 0 per la famiglia root. (Ereditato da DedTypeBase)
Proprietà pubblica | Master | Identifica il master collegato alla tipologia (Ereditato da DedTypeBase)
Proprietà pubblica | MyAttributes | Restituisce la lista di attributi abbinati a questa commessa. Se non ce ne sono viene restituita una lista inizializzata ma vuota. (Sovrascrive DedTypeBaseMyAttributes)
Proprietà pubblica | MyAttributesAnagrComm | Restituisce la lista di attributi di anagrafica di commessa abbinati a questa commessa. Se non ce ne sono viene restituita una lista inizializzata ma vuota.
Proprietà pubblica | MyAttributesComm | Restituisce la lista di attributi di commessa abbinati a questa commessa. Se non ce ne sono viene restituita una lista inizializzata ma vuota.
Proprietà pubblica | MyCod_Id | Restituisce/Imposta la maschera di codifica per DED_ID di questa famiglia. (Ereditato da DedTypeBase)
Proprietà pubblica | MyIsPrj | Restituisce/Imposta se si tratti di una famiglia di tipo progetto (questa famiglia). (Ereditato da DedTypeBase)
Proprietà pubblica | MyMaster | Identifica il master collegato alla tipologia (Ereditato da DedTypeBase)
Proprietà pubblica | MyProgr | Restituisce/Imposta il valore del progressivo strettamente di questa famiglia. Non interroga il Database ma restituisce il valore della cache. (Ereditato da DedTypeBase)
Proprietà pubblica | MyProgrAlphabet | Restituisce/Imposta l'alfabeto per il progressivo di questa famiglia. (Ereditato da DedTypeBase)
Proprietà pubblica | MyRevisionAlphabet | Restituisce/Imposta l'alfabeto per il progressivo di questa famiglia. (Ereditato da DedTypeBase)
Proprietà pubblica | MyRules | Restituisce la lista delle regole di autocomposizione di questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota. (Ereditato da DedTypeBase)
Proprietà pubblica | MyVarAlphabet | Restituisce/Imposta l'alfabeto per la variante di questa famiglia. (Ereditato da DedTypeBase)
Proprietà pubblica | Nome | Restituisce/Imposta il nome della famiglia. (Ereditato da DedTypeBase)
Proprietà pubblica | Parent | Restituisce la collezione di appartenenza. (Ereditato da DedTypeBase)
Proprietà pubblica | Progr | Restituisce il progressivo eventualmente ereditato, se non presente in questa famiglia. (Ereditato da DedTypeBase)
Proprietà pubblica | ProgrAlphabet | Restituisce l'alfabeto per la variante di questa famiglia. Restitusice l'alfabeto ereditato se non è impostato per questa famiglia. (Ereditato da DedTypeBase)
Proprietà pubblica | ReservedProgTableName | Tabella relativa ai progressivi riservati (Sovrascrive DedTypeBaseReservedProgTableName)
Proprietà pubblica | RevisionAlphabet | Restituisce l'alfabeto per il progressivo di questa famiglia. Restitusice l'alfabeto ereditato se non è impostato per questa famiglia. (Ereditato da DedTypeBase)
Proprietà pubblica | Root | Restituisce la Root della collezione (Sovrascrive DedTypeBaseRoot)
Proprietà pubblica | RuleDirty | Restituisce se sono state modificate le regole. (Ereditato da DedTypeBase)
Proprietà pubblica | Rules | Restituisce la lista delle regole di autocomposizione visibili da questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota. (Ereditato da DedTypeBase)
Proprietà pubblica | RuleTableName | Tabella relativa alle regole dell'oggetto (Sovrascrive DedTypeBaseRuleTableName)
Proprietà pubblica | StatoRecord | Restituisce o imposta lo stato del record. DI USO INTERNO !! (Ereditato da DedTypeBase)
Proprietà pubblica | SubTypes | Restituisce la lista delle sottocommesse di questa commessa. Se non ce ne sono viene restituita una lista inizializzata ma vuota. (Sovrascrive DedTypeBaseSubTypes)
Proprietà pubblica | TableName | Tabella relativa all'oggetto (Sovrascrive DedTypeBaseTableName)
Proprietà pubblica | TypeDirty | Restituisce se sono state modificate le famiglie. (Ereditato da DedTypeBase)
Proprietà pubblica | VarAlphabet | Restituisce l'alfabeto per il progressivo di questa famiglia. Restitusice l'alfabeto ereditato se non è impostato per questa famiglia. (Ereditato da DedTypeBase)
Torna su
Vedi anche

Documentazione

Classe DedCommType
Namespace DedNet.Core


Proprietà DedCommType.AttributeCommAlterTable

Proprietà DedCommTypeAttributeCommAlterTable
Indica se sono stati modificati gli attributi delle commesse e devono essere ricreati tramite Alter Table.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AttributeCommAlterTable { get; }
Public ReadOnly Property AttributeCommAlterTable As Boolean
    Get
public:
property bool AttributeCommAlterTable {
    bool get ();
}
member AttributeCommAlterTable : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedCommType
Namespace DedNet.Core


Proprietà DedCommType.AttributeCommAnagrAlterTable

Proprietà DedCommTypeAttributeCommAnagrAlterTable
Indica se sono stati modificati gli attributi delle anagrafiche di commessa e devono essere ricreati tramite Alter Table.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AttributeCommAnagrAlterTable { get; }
Public ReadOnly Property AttributeCommAnagrAlterTable As Boolean
    Get
public:
property bool AttributeCommAnagrAlterTable {
    bool get ();
}
member AttributeCommAnagrAlterTable : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedCommType
Namespace DedNet.Core


Proprietà DedCommType.AttributeDirty

Proprietà DedCommTypeAttributeDirty
Restituisce se sono state modificati gli attributi.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AttributeDirty { get; }
Public ReadOnly Property AttributeDirty As Boolean
    Get
public:
property bool AttributeDirty {
    bool get ();
}
member AttributeDirty : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedCommType
Namespace DedNet.Core


Proprietà DedCommType.Attributes

Proprietà DedCommTypeAttributes
Restituisce la lista di attributi visibili da questa commessa. Se non ce ne sono viene restituita una lista inizializzata ma vuota. Attenzione! Viene istanziato un nuovo DedAttrList ogni volta che si accede a questa proprietà.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override DedAttrList Attributes { get; }
Public Overrides ReadOnly Property Attributes As DedAttrList
    Get
public:
virtual property DedAttrList^ Attributes {
    DedAttrList^ get () override;
}
abstract Attributes : DedAttrList with get
override Attributes : DedAttrList with get

Valore della proprietà

DedAttrList
Vedi anche

Documentazione

Classe DedCommType
Namespace DedNet.Core


Proprietà DedCommType.AttributesAnagrComm

Proprietà DedCommTypeAttributesAnagrComm
Restituisce la lista di attributi di anagrafica di commessa visibili da questa commessa. Se non ce ne sono viene restituita una lista inizializzata ma vuota.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList AttributesAnagrComm { get; }
Public ReadOnly Property AttributesAnagrComm As DedAttrList
    Get
public:
property DedAttrList^ AttributesAnagrComm {
    DedAttrList^ get ();
}
member AttributesAnagrComm : DedAttrList with get

Valore della proprietà

DedAttrList
Vedi anche

Documentazione

Classe DedCommType
Namespace DedNet.Core


Proprietà DedCommType.AttributesComm

Proprietà DedCommTypeAttributesComm

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList AttributesComm { get; }
Public ReadOnly Property AttributesComm As DedAttrList
    Get
public:
property DedAttrList^ AttributesComm {
    DedAttrList^ get ();
}
member AttributesComm : DedAttrList with get

Valore della proprietà

DedAttrList
Vedi anche

Documentazione

Classe DedCommType
Namespace DedNet.Core


Proprietà DedCommType.Dirty

Proprietà DedCommTypeDirty
Restituisce se l'oggetto sia stato modificato oppure se sia stata modificata una delle sue collezioni.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Dirty { get; }
Public Overrides ReadOnly Property Dirty As Boolean
    Get
public:
virtual property bool Dirty {
    bool get () override;
}
abstract Dirty : bool with get
override Dirty : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedCommType
Namespace DedNet.Core


Proprietà DedCommType.HasAttributes

Proprietà DedCommTypeHasAttributes
Restituisce se sono presenti attributi (di commessa o di anagrafica di commessa) specifici della commessa.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool HasAttributes { get; }
Public Overrides ReadOnly Property HasAttributes As Boolean
    Get
public:
virtual property bool HasAttributes {
    bool get () override;
}
abstract HasAttributes : bool with get
override HasAttributes : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedCommType
Namespace DedNet.Core


Proprietà DedCommType.HasAttributesAnagrComm

Proprietà DedCommTypeHasAttributesAnagrComm
Restituisce se sono presenti attributi di anagrafica di commessa specifici della commessa.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasAttributesAnagrComm { get; }
Public ReadOnly Property HasAttributesAnagrComm As Boolean
    Get
public:
property bool HasAttributesAnagrComm {
    bool get ();
}
member HasAttributesAnagrComm : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedCommType
Namespace DedNet.Core


Proprietà DedCommType.HasAttributesComm

Proprietà DedCommTypeHasAttributesComm
Restituisce se sono presenti attributi di commessa specifici della commessa.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasAttributesComm { get; }
Public ReadOnly Property HasAttributesComm As Boolean
    Get
public:
property bool HasAttributesComm {
    bool get ();
}
member HasAttributesComm : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedCommType
Namespace DedNet.Core


Proprietà DedCommType.HasClonedPerm

Proprietà DedCommTypeHasClonedPerm
Indica se sono stati clonati anche dei permessi.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasClonedPerm { get; }
Public ReadOnly Property HasClonedPerm As Boolean
    Get
public:
property bool HasClonedPerm {
    bool get ();
}
member HasClonedPerm : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedCommType
Namespace DedNet.Core


Proprietà DedCommType.IsCompleted

Proprietà DedCommTypeIsCompleted
Restituisce se la commessa è completa ovvero può essere utilizzata come commessa terminale di codifica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool IsCompleted { get; }
Public Overrides ReadOnly Property IsCompleted As Boolean
    Get
public:
virtual property bool IsCompleted {
    bool get () override;
}
abstract IsCompleted : bool with get
override IsCompleted : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedCommType
Namespace DedNet.Core


Proprietà DedCommType.MyAttributes

Proprietà DedCommTypeMyAttributes
Restituisce la lista di attributi abbinati a questa commessa. Se non ce ne sono viene restituita una lista inizializzata ma vuota.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override DedAttrList MyAttributes { get; }
Public Overrides ReadOnly Property MyAttributes As DedAttrList
    Get
public:
virtual property DedAttrList^ MyAttributes {
    DedAttrList^ get () override;
}
abstract MyAttributes : DedAttrList with get
override MyAttributes : DedAttrList with get

Valore della proprietà

DedAttrList
Vedi anche

Documentazione

Classe DedCommType
Namespace DedNet.Core


Proprietà DedCommType.MyAttributesAnagrComm

Proprietà DedCommTypeMyAttributesAnagrComm
Restituisce la lista di attributi di anagrafica di commessa abbinati a questa commessa. Se non ce ne sono viene restituita una lista inizializzata ma vuota.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrCollection MyAttributesAnagrComm { get; }
Public ReadOnly Property MyAttributesAnagrComm As DedAttrCollection
    Get
public:
property DedAttrCollection^ MyAttributesAnagrComm {
    DedAttrCollection^ get ();
}
member MyAttributesAnagrComm : DedAttrCollection with get

Valore della proprietà

DedAttrCollection
Vedi anche

Documentazione

Classe DedCommType
Namespace DedNet.Core


Proprietà DedCommType.MyAttributesComm

Proprietà DedCommTypeMyAttributesComm
Restituisce la lista di attributi di commessa abbinati a questa commessa. Se non ce ne sono viene restituita una lista inizializzata ma vuota.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrCollection MyAttributesComm { get; }
Public ReadOnly Property MyAttributesComm As DedAttrCollection
    Get
public:
property DedAttrCollection^ MyAttributesComm {
    DedAttrCollection^ get ();
}
member MyAttributesComm : DedAttrCollection with get

Valore della proprietà

DedAttrCollection
Vedi anche

Documentazione

Classe DedCommType
Namespace DedNet.Core


Proprietà DedCommType.ReservedProgTableName

Proprietà DedCommTypeReservedProgTableName
Tabella relativa ai progressivi riservati

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string ReservedProgTableName { get; }
Public Overrides ReadOnly Property ReservedProgTableName As String
    Get
public:
virtual property String^ ReservedProgTableName {
    String^ get () override;
}
abstract ReservedProgTableName : string with get
override ReservedProgTableName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedCommType
Namespace DedNet.Core


Proprietà DedCommType.Root

Proprietà DedCommTypeRoot
Restituisce la Root della collezione

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override DedTypeBase Root { get; }
Public Overrides ReadOnly Property Root As DedTypeBase
    Get
public:
virtual property DedTypeBase^ Root {
    DedTypeBase^ get () override;
}
abstract Root : DedTypeBase with get
override Root : DedTypeBase with get

Valore della proprietà

DedTypeBase
Vedi anche

Documentazione

Classe DedCommType
Namespace DedNet.Core


Proprietà DedCommType.RuleTableName

Proprietà DedCommTypeRuleTableName
Tabella relativa alle regole dell'oggetto

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string RuleTableName { get; }
Public Overrides ReadOnly Property RuleTableName As String
    Get
public:
virtual property String^ RuleTableName {
    String^ get () override;
}
abstract RuleTableName : string with get
override RuleTableName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedCommType
Namespace DedNet.Core


Proprietà DedCommType.SubTypes

Proprietà DedCommTypeSubTypes
Restituisce la lista delle sottocommesse di questa commessa. Se non ce ne sono viene restituita una lista inizializzata ma vuota.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override Object SubTypes { get; }
Public Overrides ReadOnly Property SubTypes As Object
    Get
public:
virtual property Object^ SubTypes {
    Object^ get () override;
}
abstract SubTypes : Object with get
override SubTypes : Object with get

Valore della proprietà

Object
Vedi anche

Documentazione

Classe DedCommType
Namespace DedNet.Core


Proprietà DedCommType.TableName

Proprietà DedCommTypeTableName
Tabella relativa all'oggetto

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string TableName { get; }
Public Overrides ReadOnly Property TableName As String
    Get
public:
virtual property String^ TableName {
    String^ get () override;
}
abstract TableName : string with get
override TableName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedCommType
Namespace DedNet.Core


Metodi di DedCommType

Il tipo DedCommType espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Clone | Metodo per clonare la commessa.
Metodo pubblico | DecodeDedId(String) | Decodifica una stinga come DEDID appartenente a questa commessa, restituendo un oggetto descrittivo della codifica. (Sovrascrive DedTypeBaseDecodeDedId(String))
Metodo pubblico | DecodeDedId(String, String) | Decodifica una stinga come DEDID appartenente a questa commessa, restituendo un oggetto descrittivo della codifica. (Sovrascrive DedTypeBaseDecodeDedId(String, String))
Metodo pubblico | EncodeDedId | Inserisce nelle info passate questa stessa commessa e poi crea e restituisce il DEDID corrispondente alla maschera di codifica presente o ereditata da questa commessa. (Sovrascrive DedTypeBaseEncodeDedId(DedEncodeInfo))
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | FindAttrByName | Cerca un attributo con un determinato nome tra gli attributi visibili da questa commessa. Restitusice null se non lo trova. (Sovrascrive DedTypeBaseFindAttrByName(String))
Metodo pubblico | FindAttrByPrompt | Cerca un attributo con un determinato prompt tra gli attributi visibili da questa commessa. Restitusice null se non lo trova. (Sovrascrive DedTypeBaseFindAttrByPrompt(String))
Metodo pubblico | FindBusyProgrRecursive | Scorre ricorsivamente tutte le commesse per conoscere tutti i progressivi utilizzati. (Sovrascrive DedTypeBaseFindBusyProgrRecursive(DedTypeBase, DictionaryString, String, String, DataTable))
Metodo pubblico | FindByDbPath | Cerca il tipo corrispondente al dbpath passato in tutto l'albero partendo dalla radice. (Sovrascrive DedTypeBaseFindByDbPath(String))
Metodo pubblico | ForEachChild | Questo metodo chiama un delegate passandogli in sequenza il nodo corrente (opzionalmente) e tutti i suoi nodi figli. (Ereditato da DedTypeBase)
Metodo pubblico | ForEachParent | Questo metodo chiama un delegate passandogli in sequenza il nodo root e giù fino al nodo corrente (opzionalmente) Lo scorrimento avviene quindi in modo discendente dal padre di tutti verso l'oggetto corrente. (Ereditato da DedTypeBase)
Metodo pubblico | FormatDedRev | Data una stringa di revisione restituisce il valore correttamente formattato e della giusta dimensione per questa famiglia. Es: "1" -> "01" (con rev. di 2 caratteri); "12" -> "012" (con rev. di 3 caratteri); "05" -> "5" (con rev. di 1 carattere); (Ereditato da DedTypeBase)
Metodo pubblico | FormatProgr | Data una stringa di progressivo restituisce il valore correttamente formattato e della giusta dimensione per questa famiglia. Es: "1" -> "001" (progr. di 3 caratteri); "12" -> "012" (progr. di 3 caratteri); "05" -> "5" (progr. di 1 carattere); (Ereditato da DedTypeBase)
Metodo pubblico | FormatVar | Data una stringa della variante restituisce il valore correttamente formattato e della giusta dimensione per questa famiglia. Es: "1" -> "001" (progr. di 3 caratteri); "12" -> "012" (progr. di 3 caratteri); "05" -> "5" (progr. di 1 carattere); (Ereditato da DedTypeBase)
Metodo pubblico | ForOneChild | Questo metodo chiama un delegate passandogli in sequenza il nodo corrente (opzionalmente) e tutti i suoi nodi figli. (Ereditato da DedTypeBase)
Metodo pubblico | GetAttrNameFromPrompt | Restituisce il nome di un attributo visibile da questa famiglia dato il suo prompt. (Ereditato da DedTypeBase)
Metodo pubblico | GetAttrsFromCategory(DedCateg) | Ritorna la lista di attributi visibili dalla famiglia che appartengono alla categoria passata. (Ereditato da DedTypeBase)
Metodo pubblico | GetAttrsFromCategory(String) | Ritorna la lista di attributi visibili dalla famiglia che appartengono alla categoria passata. (Ereditato da DedTypeBase)
Metodo pubblico | GetBusyProgr | Restituisce un dizionario con tutti i progressivi utilizzati. (Ereditato da DedTypeBase)
Metodo pubblico | GetFamSpecificLevel | Restituisce la famiglia a n° livello. (Ereditato da DedTypeBase)
Metodo pubblico | GetFamSpecificNegativeLevel | Restituisce la famiglia a n° livello negativo. (Ereditato da DedTypeBase)
Metodo pubblico | GetFieldsCod | Restituisce la lista delle stringhe nella queli cercare i tasselli. (Ereditato da DedTypeBase)
Metodo pubblico | GetFirstParentHasProg | Restituisce la prima famiglia genitore che ha il progressivo locale.Considera anche il nodo corrente per avere la sicurezza che se viene chiamato su una famiglia con con progressivo impostato non lo calcoli sul padre ma su se stesso. (Ereditato da DedTypeBase)
Metodo pubblico | GetFreeProgr | Restituisce una lista sempre inizializzata e ordinata con tutti i progressivi liberi per questa famiglia. (Ereditato da DedTypeBase)
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | GetLastProgr | Restituisce l'ultimo progressivo possibile per questa famiglia. (Ereditato da DedTypeBase)
Metodo pubblico | GetMaxTokenNum | Restituisce il massimo numero di caratteri usati per il TokenTypeEnum passato. Verifica nella maschera di codifica Cod_Id, Cod_Fil e Cod_Dis in modo da prendere il numero massimo di caratteri utilizzati. (Ereditato da DedTypeBase)
Metodo pubblico | GetParentAttributes | Restituisce la lista degli attributi dei miei genitori.
Metodo pubblico | GetParentTypes | Restituisce una lista dei DedTypeList genitori, compresa l'istanza stessa se specificato. (Sovrascrive DedTypeBaseGetParentTypes(Boolean))
Metodo pubblico | GetProgr(Boolean) | Restituisce il progressivo della famiglia che ha invocato il metodo oppure il progressivo della prima famiglia genitore che lo possiede. Lavora sull'utente attualmente connesso ( se deve lavorare in DED_TIPI_PROG ). (Ereditato da DedTypeBase)
Metodo pubblico | GetProgr(Boolean, String) | Restituisce il progressivo della famiglia che ha invocato il metodo oppure il progressivo della prima famiglia genitore che lo possiede (Ereditato da DedTypeBase)
Metodo pubblico | GetProgrTokenNum | Restituisce il numero di caratteri da utilizzare per creare la stringa del progressivo per questa famiglia. Li calcola cercando il tassello del progressivo nella codifica del Cod_Id. Se non è presente restituisce 0. (Ereditato da DedTypeBase)
Metodo pubblico | GetRightMask | Restituisce il TokenInfo cercato nella prima maschera di codifica trovata, da utilizzare poi per calcolare il numero di tasselli per un particolare token. Restituisce null se non la trova. (Ereditato da DedTypeBase)
Metodo pubblico | InternalSave | Save chiamato dalla commessa padre per salvare le modifiche di questa commessa. NON UTILIZZARE DIRETTAMENTE!
Metodo pubblico | MakeAttrsDictionary | Riempie il dizionario _dizfields. (Ereditato da DedTypeBase)
Metodo pubblico | NotifyDirty | In base al fatto che si tratti della root o meno notifica al parent corretto l'avvenuta modifica della proprietà. (Sovrascrive DedTypeBaseNotifyDirty)
Metodo pubblico | Save | Salva tutta la struttura discendente (da questa in giù) delle commesse. (Sovrascrive DedTypeBaseSave)
Metodo pubblico | SetProgr(String, String, Boolean) | Imposta il progressivo di questa famiglia o della famiglia dalla quale questa eredita il progressivo. Lavora sull'utente attualmente connesso ( se deve lavorare in DED_TIPI_PROG ). (Ereditato da DedTypeBase)
Metodo pubblico | SetProgr(String, String, Boolean, String) | Imposta il progressivo di questa famiglia o della famiglia dalla quale questa eredita il progressivo. (Ereditato da DedTypeBase)
Metodo pubblico | SetProgr(String, String, Boolean, String, Boolean) | Imposta il progressivo di questa famiglia o della famiglia dalla quale questa eredita il progressivo. (Ereditato da DedTypeBase)
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Metodo pubblico | WaitForUpdate | Esegue una query con WITH (XLOCK) in modo da aspettare finchè altri utenti non hanno commitato. (Ereditato da DedTypeBase)
Torna su
Vedi anche

Documentazione

Classe DedCommType
Namespace DedNet.Core


Metodo DedCommType.Clone

Metodo DedCommTypeClone
Metodo per clonare la commessa.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommType Clone(
    DedCommTypeCollection parent
)
Public Function Clone (
    parent As DedCommTypeCollection
) As DedCommType
public:
DedCommType^ Clone(
    DedCommTypeCollection^ parent
)
member Clone :
        parent : DedCommTypeCollection -> DedCommType

Parametri

parent DedCommTypeCollection

Valore di ritorno

DedCommType
Vedi anche

Documentazione

Classe DedCommType
Namespace DedNet.Core


Metodo DedCommType.DecodeDedId

Metodo DedCommTypeDecodeDedId
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | DecodeDedId(String) | Decodifica una stinga come DEDID appartenente a questa commessa, restituendo un oggetto descrittivo della codifica.
Metodo pubblico | DecodeDedId(String, String) | Decodifica una stinga come DEDID appartenente a questa commessa, restituendo un oggetto descrittivo della codifica.
Torna su
Vedi anche

Documentazione

Classe DedCommType
Namespace DedNet.Core


Metodo DedCommType.DecodeDedId(String)

Metodo DedCommTypeDecodeDedId(String)
Decodifica una stinga come DEDID appartenente a questa commessa, restituendo un oggetto descrittivo della codifica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override DedEncodeInfo DecodeDedId(
    string stringToDecode
)
Public Overrides Function DecodeDedId (
    stringToDecode As String
) As DedEncodeInfo
public:
virtual DedEncodeInfo^ DecodeDedId(
    String^ stringToDecode
) override
abstract DecodeDedId :
        stringToDecode : string -> DedEncodeInfo
override DecodeDedId :
        stringToDecode : string -> DedEncodeInfo

Parametri

stringToDecode String
Stringa da decodificare. Es: 'P500123456'.

Valore di ritorno

DedEncodeInfo
Restituisce un DedEncodeInfo contenente tutte le informazioni sui tasselli trovati.
Vedi anche

Documentazione

Classe DedCommType
Overload di DecodeDedId
Namespace DedNet.Core


Metodo DedCommType.DecodeDedId(String, String)

Metodo DedCommTypeDecodeDedId(String, String)
Decodifica una stinga come DEDID appartenente a questa commessa, restituendo un oggetto descrittivo della codifica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override DedEncodeInfo DecodeDedId(
    string stringToDecode,
    string cod_id
)
Public Overrides Function DecodeDedId (
    stringToDecode As String,
    cod_id As String
) As DedEncodeInfo
public:
virtual DedEncodeInfo^ DecodeDedId(
    String^ stringToDecode,
    String^ cod_id
) override
abstract DecodeDedId :
        stringToDecode : string *
        cod_id : string -> DedEncodeInfo
override DecodeDedId :
        stringToDecode : string *
        cod_id : string -> DedEncodeInfo

Parametri

stringToDecode String
Stringa da decodificare. Es: 'P500123456'.
cod_id String
Stringa di decodifica"

Valore di ritorno

DedEncodeInfo
Restituisce un DedEncodeInfo contenente tutte le informazioni sui tasselli trovati.
Vedi anche

Documentazione

Classe DedCommType
Overload di DecodeDedId
Namespace DedNet.Core


Metodo DedCommType.EncodeDedId

Metodo DedCommTypeEncodeDedId
Inserisce nelle info passate questa stessa commessa e poi crea e restituisce il DEDID corrispondente alla maschera di codifica presente o ereditata da questa commessa.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string EncodeDedId(
    DedEncodeInfo info
)
Public Overrides Function EncodeDedId (
    info As DedEncodeInfo
) As String
public:
virtual String^ EncodeDedId(
    DedEncodeInfo^ info
) override
abstract EncodeDedId :
        info : DedEncodeInfo -> string
override EncodeDedId :
        info : DedEncodeInfo -> string

Parametri

info DedEncodeInfo
Informazioni dalle quali ricavare la codifica (il campo commessa viene sovrascritto con questa stessa commessa).

Valore di ritorno

String
Restituisce il DEDID codificato.
Vedi anche

Documentazione

Classe DedCommType
Namespace DedNet.Core


Metodo DedCommType.Equals

Metodo DedCommTypeEquals

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj Object

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedCommType
Namespace DedNet.Core


Metodo DedCommType.FindAttrByName

Metodo DedCommTypeFindAttrByName
Cerca un attributo con un determinato nome tra gli attributi visibili da questa commessa. Restitusice null se non lo trova.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override DedAttr FindAttrByName(
    string name
)
Public Overrides Function FindAttrByName (
    name As String
) As DedAttr
public:
virtual DedAttr^ FindAttrByName(
    String^ name
) override
abstract FindAttrByName :
        name : string -> DedAttr
override FindAttrByName :
        name : string -> DedAttr

Parametri

name String
Nome dell'attributo da cercare.

Valore di ritorno

DedAttr
Vedi anche

Documentazione

Classe DedCommType
Namespace DedNet.Core


Metodo DedCommType.FindAttrByPrompt

Metodo DedCommTypeFindAttrByPrompt
Cerca un attributo con un determinato prompt tra gli attributi visibili da questa commessa. Restitusice null se non lo trova.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override DedAttr FindAttrByPrompt(
    string prompt
)
Public Overrides Function FindAttrByPrompt (
    prompt As String
) As DedAttr
public:
virtual DedAttr^ FindAttrByPrompt(
    String^ prompt
) override
abstract FindAttrByPrompt :
        prompt : string -> DedAttr
override FindAttrByPrompt :
        prompt : string -> DedAttr

Parametri

prompt String
Prompt dell'attributo da cercare.

Valore di ritorno

DedAttr
Vedi anche

Documentazione

Classe DedCommType
Namespace DedNet.Core


Metodo DedCommType.FindBusyProgrRecursive

Metodo DedCommTypeFindBusyProgrRecursive
Scorre ricorsivamente tutte le commesse per conoscere tutti i progressivi utilizzati.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void FindBusyProgrRecursive(
    DedTypeBase tipo,
    Dictionary<string, string> progrBusy,
    string username = "",
    DataTable dt = null
)
Public Overrides Sub FindBusyProgrRecursive (
    tipo As DedTypeBase,
    progrBusy As Dictionary(Of String, String),
    Optional username As String = "",
    Optional dt As DataTable = Nothing
)
public:
virtual void FindBusyProgrRecursive(
    DedTypeBase^ tipo,
    Dictionary<String^, String^>^ progrBusy,
    String^ username = L"",
    DataTable^ dt = nullptr
) override
abstract FindBusyProgrRecursive :
        tipo : DedTypeBase *
        progrBusy : Dictionary<string, string> *
        ?username : string *
        ?dt : DataTable
(* Defaults:
        let _username = defaultArg username ""
        let _dt = defaultArg dt null
*)
-> unit
override FindBusyProgrRecursive :
        tipo : DedTypeBase *
        progrBusy : Dictionary<string, string> *
        ?username : string *
        ?dt : DataTable
(* Defaults:
        let _username = defaultArg username ""
        let _dt = defaultArg dt null
*)
-> unit

Parametri

tipo DedTypeBase
Commessa da valutare.
progrBusy Dictionary String, String
Lista che viene riempita con i progressivi attualmente usati.
username String (Optional)
dt DataTable (Optional)
Vedi anche

Documentazione

Classe DedCommType
Namespace DedNet.Core


Metodo DedCommType.FindByDbPath

Metodo DedCommTypeFindByDbPath
Cerca il tipo corrispondente al dbpath passato in tutto l'albero partendo dalla radice.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override DedTypeBase FindByDbPath(
    string dbpath
)
Public Overrides Function FindByDbPath (
    dbpath As String
) As DedTypeBase
public:
virtual DedTypeBase^ FindByDbPath(
    String^ dbpath
) override
abstract FindByDbPath :
        dbpath : string -> DedTypeBase
override FindByDbPath :
        dbpath : string -> DedTypeBase

Parametri

dbpath String
DbPath da cercare nell'albero dei tipi.

Valore di ritorno

DedTypeBase
Restituisce il DedTypeBase avente il DbPath specificato oppure null se la ricerca non ha avuto esito.
Vedi anche

Documentazione

Classe DedCommType
Namespace DedNet.Core


Metodo DedCommType.GetHashCode

Metodo DedCommTypeGetHashCode

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedCommType
Namespace DedNet.Core


Metodo DedCommType.GetParentAttributes

Metodo DedCommTypeGetParentAttributes
Restituisce la lista degli attributi dei miei genitori.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList GetParentAttributes(
    bool attrAnagrComm,
    bool removeMyAttrRedefined
)
Public Function GetParentAttributes (
    attrAnagrComm As Boolean,
    removeMyAttrRedefined As Boolean
) As DedAttrList
public:
DedAttrList^ GetParentAttributes(
    bool attrAnagrComm,
    bool removeMyAttrRedefined
)
member GetParentAttributes :
        attrAnagrComm : bool *
        removeMyAttrRedefined : bool -> DedAttrList

Parametri

attrAnagrComm Boolean
Indica se gestire la lista degli attributi di anagrafica di commessa o quelli di commessa
removeMyAttrRedefined Boolean
Indica se rimuovere dalla lista eventuali attributi ridefiniti nella commessa attuale

Valore di ritorno

DedAttrList
Vedi anche

Documentazione

Classe DedCommType
Namespace DedNet.Core


Metodo DedCommType.GetParentTypes

Metodo DedCommTypeGetParentTypes
Restituisce una lista dei DedTypeList genitori, compresa l'istanza stessa se specificato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override DedTypeList GetParentTypes(
    bool bCurrent
)
Public Overrides Function GetParentTypes (
    bCurrent As Boolean
) As DedTypeList
public:
virtual DedTypeList^ GetParentTypes(
    bool bCurrent
) override
abstract GetParentTypes :
        bCurrent : bool -> DedTypeList
override GetParentTypes :
        bCurrent : bool -> DedTypeList

Parametri

bCurrent Boolean
Specifica se includere l'istanza di questo oggetto sul quale è stato chiamato il metodo, nella lista restituita.

Valore di ritorno

DedTypeList
Restituisce la lista dei DedTypeList genitori oppure null.
Vedi anche

Documentazione

Classe DedCommType
Namespace DedNet.Core


Metodo DedCommType.InternalSave

Metodo DedCommTypeInternalSave
Save chiamato dalla commessa padre per salvare le modifiche di questa commessa. NON UTILIZZARE DIRETTAMENTE!

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void InternalSave()
Public Sub InternalSave
public:
void InternalSave()
member InternalSave : unit -> unit
Vedi anche

Documentazione

Classe DedCommType
Namespace DedNet.Core


Metodo DedCommType.NotifyDirty

Metodo DedCommTypeNotifyDirty
In base al fatto che si tratti della root o meno notifica al parent corretto l'avvenuta modifica della proprietà.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void NotifyDirty()
Public Overrides Sub NotifyDirty
public:
virtual void NotifyDirty() override
abstract NotifyDirty : unit -> unit
override NotifyDirty : unit -> unit
Vedi anche

Documentazione

Classe DedCommType
Namespace DedNet.Core


Metodo DedCommType.Save

Metodo DedCommTypeSave
Salva tutta la struttura discendente (da questa in giù) delle commesse.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void Save()
Public Overrides Sub Save
public:
virtual void Save() override
abstract Save : unit -> unit
override Save : unit -> unit
Vedi anche

Documentazione

Classe DedCommType
Namespace DedNet.Core


Metodo DedCommType.ToString

Metodo DedCommTypeToString

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedCommType
Namespace DedNet.Core


Campi di DedCommType

Il tipo DedCommType espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | _analyzedTypes | (Ereditato da DedTypeBase)
Campo pubblico | _app | (Ereditato da DedTypeBase)
Campo pubblico | _attributes | (Ereditato da DedTypeBase)
Campo pubblico | _backcolor | (Ereditato da DedTypeBase)
Campo pubblico | _calculatedAttrs | (Ereditato da DedTypeBase)
Campo pubblico | _clonedFrom | (Ereditato da DedTypeBase)
Campo pubblico | _cod_id | (Ereditato da DedTypeBase)
Campo pubblico | _dbPath | (Ereditato da DedTypeBase)
Campo pubblico | _dbPathLoaded | (Ereditato da DedTypeBase)
Campo pubblico | _descriz | (Ereditato da DedTypeBase)
Campo pubblico | _dirtyname | (Ereditato da DedTypeBase)
Campo pubblico | _dwgpath | (Ereditato da DedTypeBase)
Campo pubblico | _forecolor | (Ereditato da DedTypeBase)
Campo pubblico | _freecode | (Ereditato da DedTypeBase)
Campo pubblico | _isprj | (Ereditato da DedTypeBase)
Campo pubblico | _isRoot | Indica se questa famiglia sia o meno la root. (Ereditato da DedTypeBase)
Campo pubblico | _master | (Ereditato da DedTypeBase)
Campo pubblico | _name | (Ereditato da DedTypeBase)
Campo pubblico | _oldDwgPath | (Ereditato da DedTypeBase)
Campo pubblico | _parent | Collezione di appartenenza. (Ereditato da DedTypeBase)
Campo pubblico | _progr | (Ereditato da DedTypeBase)
Campo pubblico | _progrAlphabet | (Ereditato da DedTypeBase)
Campo pubblico | _revisionAlphabet | (Ereditato da DedTypeBase)
Campo pubblico | _rootCollection | Collezione dedicata al salvataggio della root. (Ereditato da DedTypeBase)
Campo pubblico | _rules | (Ereditato da DedTypeBase)
Campo pubblico | _subtypes | (Ereditato da DedTypeBase)
Campo pubblico | _varAlphabet | (Ereditato da DedTypeBase)
Torna su
Vedi anche

Documentazione

Classe DedCommType
Namespace DedNet.Core


Enumerazione DedCommType.DedTypeCaractEnum

Enumerazione DedCommTypeDedTypeCaractEnum
Enumerazione per la compilazione delle proprietà delle commesse.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum DedTypeCaractEnum
Public Enumeration DedTypeCaractEnum
public enum class DedTypeCaractEnum
type DedTypeCaractEnum
Membri
Nome | Valore | Descrizione
Nome | 0 |
Descrizione | 1 |
Progressivo | 2 |
Vedi anche

Documentazione

Namespace DedNet.Core


Classe DedCommTypeCollection
Collezione modificabile di oggetti DedCommType.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedDbCollectionBase DedCommType
DedNet.CoreDedTypeBaseCollection DedCommType
DedNet.CoreDedCommTypeCollection

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedCommTypeCollection : DedTypeBaseCollection<DedCommType>
Public Class DedCommTypeCollection
    Inherits DedTypeBaseCollection(Of DedCommType)
public ref class DedCommTypeCollection : public DedTypeBaseCollection<DedCommType^>
type DedCommTypeCollection =
    class
        inherit DedTypeBaseCollection<DedCommType>
    end

Il tipo DedCommTypeCollection espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllowsDuplicates | Restituisce se siano ammessi duplicati all'interno della lista. Se false viene sollevata una eccezione su tentativo di inserimento duplicati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Application | Restituisce l'oggetto applicazione di appartenza. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Count | Restituisce il numero di elementi presenti. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Dirty | Restituisce se la collezione o uno dei suoi elementi sia stata modificata. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | ErasedItems | Restitusice la lista in sola lettura degli elementi che risultano attualmente cancellati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | LastItem | Restituisce l'ultimo elemento della collezione oppure null se non ci sono elementi. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Owner | Restituisce l'oggetto DedTypeBase di appartenenza. (Ereditato da DedTypeBaseCollectionT)
Proprietà pubblica | RestoreErased | Restituisce se gli elementi cancellati devono essere ripristinati in caso vengano riaggiunti. (Ereditato da DedDbCollectionBaseT)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Add(T) | Aggiunge alla collezione un elemento già esistente come nuovo elemento. Gli imposta già come padre la nuova collezione. (Ereditato da DedTypeBaseCollectionT)
Metodo pubblico | Add(String, String, String, String, Boolean, Boolean, Guid) | Costruttore con inizializzazione di tutti i campi.
Metodo pubblico | Add(String, String, String, String, Boolean, Boolean, String, Guid) | Costruttore con inizializzazione di tutti i campi.
Metodo protetto | AddForClone | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto SENZA MODIFICARNE LO STATO. Le classi derivate potranno utilizzare questo metodo per clonare la collezione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddNewElement | DI USO INTERNO. Aggiunge un elemento alla lista rendendo dirty l'oggetto. L'elemento viene aggiunto con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere un elemento alla lista. Dovranno loro stesse avere un metodo pubblico Add() che prenda i parametri necessari alla costruzione dell'oggetto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddRangeNewElement | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi rendendo dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere più elementi alla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddUnModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Clear | Elimina tutti gli elementi dalla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ClearRefresh | Svuota la lista impostando Dirty = false. Di fatto permette di effettuare un refresh della lista e quindi di ricaricarla. Serve per svuotare la lista e reinizializzarla da capo. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Clone | Metodo per clonare la collezione di commesse.
Metodo pubblico | Contains | Verifica l'esistenza di un valore all'interno della lista degli elementi. Le classi derivate devono effettuarne l'override nel caso in cui l'elemento non implementi GetHashCode() per l'uso all'interno dei dizionarii. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | CopyTo | Copia un range di elementi in un array. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | CreateDeleteCommand | Crea un comando per eliminare un elemento. (Ereditato da DedTypeBaseCollectionT)
Metodo protetto | CreateInsertCommand | Crea un comando per inserire un elemento (Sovrascrive DedDbCollectionBaseTCreateInsertCommand(T))
Metodo protetto | CreateUpdateCommand | Crea un comando per aggiornare un elemento. (Sovrascrive DedDbCollectionBaseTCreateUpdateCommand(T))
Metodo pubblico | CustomSort | Ordina la lista in base al comparatore passato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteDeleteItem | Esegue l'eliminazione di un elemento. Crea il comando tramite il metodo CreateDeleteCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteInsertItem | Esegue l'inserimento di un elemento. Crea il comando tramite il metodo CreateInsertCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteUpdateItem | Esegue l'aggiornamento di un elemento. Crea il comando tramite il metodo CreateUpdateCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Find | Restituisce l'oggetto cercato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FindAll | Restitusice la lista degli elementi che corrispondono al predicato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | GetDbIndex | Restituisce l'indice dell'elemento passato (Ereditato da DedTypeBaseCollectionT)
Metodo pubblico | GetEnumerator | Restituisce l'enumeratore della collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | IndexOf | Restituisce l'indice dell'elemento richiesto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InsertUnModified | DI USO INTERNO. Inserisce un elemento alla lista senza rendere dirty l'oggetto, all'indice specificato. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Item | Restituisce l'elemento iesimo della lista. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean) | Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean, Int32) | Sposta l'elemento dell'indice passato prima o dopo del numero di posizioni passate. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSave | Utilizzata per eliminare gli attributi e le regole eliminate nelle sottocommesse delle commesse eliminate. Se sono attivi i permessi aggiunge nella tabella DED_COMM_USER_PERM tutte le associazioni dei permessi di lettura di tutti gli utenti per le commesse aggiunte e li rimuove per le commesse eliminate. (Sovrascrive DedDbCollectionBaseTOnAfterSave(ListT, ListT, ListT))
Metodo protetto | OnAfterSaveNoChanges | Metodo Template chiamato dopo il salvataggio senza modifiche. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnBeforeSave | Metodo Template chiamato prima del salvataggio. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(T) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(DedEditableObjectT) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(T) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(DedEditableObjectT) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ReInitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Remove | Elimina un elemento dalla collezione. (Sovrascrive DedTypeBaseCollectionTRemove(T))
Metodo pubblico | Ripristina | Verifica che l'elemento sia presente negli eliminati e lo toglie da lì e lo riaggiunge in coda alla lista degli elementi validi. Solleva una eccezione se l'elemento è già presente nella lista e AllowsDuplicates = false. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Save | Salva l'oggetto con tutta la sua lista, solo se questo risulta dirty. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | ToArray | Restituisce un array di questi oggetti. (Ereditato da DedTypeBaseCollectionT)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di DedCommTypeCollection

Il tipo DedCommTypeCollection espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllowsDuplicates | Restituisce se siano ammessi duplicati all'interno della lista. Se false viene sollevata una eccezione su tentativo di inserimento duplicati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Application | Restituisce l'oggetto applicazione di appartenza. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Count | Restituisce il numero di elementi presenti. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Dirty | Restituisce se la collezione o uno dei suoi elementi sia stata modificata. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | ErasedItems | Restitusice la lista in sola lettura degli elementi che risultano attualmente cancellati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | LastItem | Restituisce l'ultimo elemento della collezione oppure null se non ci sono elementi. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Owner | Restituisce l'oggetto DedTypeBase di appartenenza. (Ereditato da DedTypeBaseCollectionT)
Proprietà pubblica | RestoreErased | Restituisce se gli elementi cancellati devono essere ripristinati in caso vengano riaggiunti. (Ereditato da DedDbCollectionBaseT)
Torna su
Vedi anche

Documentazione

Classe DedCommTypeCollection
Namespace DedNet.Core


Metodi di DedCommTypeCollection

Il tipo DedCommTypeCollection espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Add(T) | Aggiunge alla collezione un elemento già esistente come nuovo elemento. Gli imposta già come padre la nuova collezione. (Ereditato da DedTypeBaseCollectionT)
Metodo pubblico | Add(String, String, String, String, Boolean, Boolean, Guid) | Costruttore con inizializzazione di tutti i campi.
Metodo pubblico | Add(String, String, String, String, Boolean, Boolean, String, Guid) | Costruttore con inizializzazione di tutti i campi.
Metodo protetto | AddForClone | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto SENZA MODIFICARNE LO STATO. Le classi derivate potranno utilizzare questo metodo per clonare la collezione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddNewElement | DI USO INTERNO. Aggiunge un elemento alla lista rendendo dirty l'oggetto. L'elemento viene aggiunto con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere un elemento alla lista. Dovranno loro stesse avere un metodo pubblico Add() che prenda i parametri necessari alla costruzione dell'oggetto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddRangeNewElement | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi rendendo dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere più elementi alla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddUnModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Clear | Elimina tutti gli elementi dalla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ClearRefresh | Svuota la lista impostando Dirty = false. Di fatto permette di effettuare un refresh della lista e quindi di ricaricarla. Serve per svuotare la lista e reinizializzarla da capo. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Clone | Metodo per clonare la collezione di commesse.
Metodo pubblico | Contains | Verifica l'esistenza di un valore all'interno della lista degli elementi. Le classi derivate devono effettuarne l'override nel caso in cui l'elemento non implementi GetHashCode() per l'uso all'interno dei dizionarii. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | CopyTo | Copia un range di elementi in un array. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | CreateDeleteCommand | Crea un comando per eliminare un elemento. (Ereditato da DedTypeBaseCollectionT)
Metodo protetto | CreateInsertCommand | Crea un comando per inserire un elemento (Sovrascrive DedDbCollectionBaseTCreateInsertCommand(T))
Metodo protetto | CreateUpdateCommand | Crea un comando per aggiornare un elemento. (Sovrascrive DedDbCollectionBaseTCreateUpdateCommand(T))
Metodo pubblico | CustomSort | Ordina la lista in base al comparatore passato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteDeleteItem | Esegue l'eliminazione di un elemento. Crea il comando tramite il metodo CreateDeleteCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteInsertItem | Esegue l'inserimento di un elemento. Crea il comando tramite il metodo CreateInsertCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteUpdateItem | Esegue l'aggiornamento di un elemento. Crea il comando tramite il metodo CreateUpdateCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Find | Restituisce l'oggetto cercato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FindAll | Restitusice la lista degli elementi che corrispondono al predicato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | GetDbIndex | Restituisce l'indice dell'elemento passato (Ereditato da DedTypeBaseCollectionT)
Metodo pubblico | GetEnumerator | Restituisce l'enumeratore della collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | IndexOf | Restituisce l'indice dell'elemento richiesto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InsertUnModified | DI USO INTERNO. Inserisce un elemento alla lista senza rendere dirty l'oggetto, all'indice specificato. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Item | Restituisce l'elemento iesimo della lista. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean) | Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean, Int32) | Sposta l'elemento dell'indice passato prima o dopo del numero di posizioni passate. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSave | Utilizzata per eliminare gli attributi e le regole eliminate nelle sottocommesse delle commesse eliminate. Se sono attivi i permessi aggiunge nella tabella DED_COMM_USER_PERM tutte le associazioni dei permessi di lettura di tutti gli utenti per le commesse aggiunte e li rimuove per le commesse eliminate. (Sovrascrive DedDbCollectionBaseTOnAfterSave(ListT, ListT, ListT))
Metodo protetto | OnAfterSaveNoChanges | Metodo Template chiamato dopo il salvataggio senza modifiche. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnBeforeSave | Metodo Template chiamato prima del salvataggio. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(T) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(DedEditableObjectT) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(T) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(DedEditableObjectT) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ReInitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Remove | Elimina un elemento dalla collezione. (Sovrascrive DedTypeBaseCollectionTRemove(T))
Metodo pubblico | Ripristina | Verifica che l'elemento sia presente negli eliminati e lo toglie da lì e lo riaggiunge in coda alla lista degli elementi validi. Solleva una eccezione se l'elemento è già presente nella lista e AllowsDuplicates = false. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Save | Salva l'oggetto con tutta la sua lista, solo se questo risulta dirty. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | ToArray | Restituisce un array di questi oggetti. (Ereditato da DedTypeBaseCollectionT)
Torna su
Vedi anche

Documentazione

Classe DedCommTypeCollection
Namespace DedNet.Core


Metodo DedCommTypeCollection.Add

Metodo DedCommTypeCollectionAdd
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Add(T) | Aggiunge alla collezione un elemento già esistente come nuovo elemento. Gli imposta già come padre la nuova collezione.
Metodo pubblico | Add(String, String, String, String, Boolean, Boolean, Guid) | Costruttore con inizializzazione di tutti i campi.
Metodo pubblico | Add(String, String, String, String, Boolean, Boolean, String, Guid) | Costruttore con inizializzazione di tutti i campi.
Torna su
Vedi anche

Documentazione

Classe DedCommTypeCollection
Namespace DedNet.Core


Metodo DedCommTypeCollection.Add(String, String, String, String, Boolean, Boolean, Guid)

Metodo DedCommTypeCollectionAdd(String, String, String, String, Boolean, Boolean, Guid)
Costruttore con inizializzazione di tutti i campi.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommType Add(
    string name,
    string Descriz,
    string Progr,
    string Cod_id,
    bool IsPrj,
    bool IsFreeCode,
    Guid master
)
Public Function Add (
    name As String,
    Descriz As String,
    Progr As String,
    Cod_id As String,
    IsPrj As Boolean,
    IsFreeCode As Boolean,
    master As Guid
) As DedCommType
public:
DedCommType^ Add(
    String^ name,
    String^ Descriz,
    String^ Progr,
    String^ Cod_id,
    bool IsPrj,
    bool IsFreeCode,
    Guid master
)
member Add :
        name : string *
        Descriz : string *
        Progr : string *
        Cod_id : string *
        IsPrj : bool *
        IsFreeCode : bool *
        master : Guid -> DedCommType

Parametri

name String
Nome della commessa.
Descriz String
Descrizione tipo-commessa.
Progr String
Progressivo tipo-commessa.
Cod_id String
Maschera di codifica DEDID.
IsPrj Boolean
Specifica se si tratta di tipo-commessa progetto.
IsFreeCode Boolean
Specifica se si tratta di tipo-commessa a codifica libera.
master Guid
Master collegato alla tipologia

Valore di ritorno

DedCommType
Vedi anche

Documentazione

Classe DedCommTypeCollection
Overload di Add
Namespace DedNet.Core


Metodo DedCommTypeCollection.Add(String, String, String, String, Boolean, Boolean, String, Guid)

Metodo DedCommTypeCollectionAdd(String, String, String, String, Boolean, Boolean, String, Guid)
Costruttore con inizializzazione di tutti i campi.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommType Add(
    string name,
    string Descriz,
    string Progr,
    string Cod_id,
    bool IsPrj,
    bool IsFreeCode,
    string ProgrAlphabet,
    Guid master
)
Public Function Add (
    name As String,
    Descriz As String,
    Progr As String,
    Cod_id As String,
    IsPrj As Boolean,
    IsFreeCode As Boolean,
    ProgrAlphabet As String,
    master As Guid
) As DedCommType
public:
DedCommType^ Add(
    String^ name,
    String^ Descriz,
    String^ Progr,
    String^ Cod_id,
    bool IsPrj,
    bool IsFreeCode,
    String^ ProgrAlphabet,
    Guid master
)
member Add :
        name : string *
        Descriz : string *
        Progr : string *
        Cod_id : string *
        IsPrj : bool *
        IsFreeCode : bool *
        ProgrAlphabet : string *
        master : Guid -> DedCommType

Parametri

name String
Nome della commessa.
Descriz String
Descrizione tipo-commessa.
Progr String
Progressivo tipo-commessa.
Cod_id String
Maschera di codifica DEDID.
IsPrj Boolean
Specifica se si tratta di tipo-commessa progetto.
IsFreeCode Boolean
Specifica se si tratta di tipo-commessa a codifica libera.
ProgrAlphabet String
Alfabeto del progressivo
master Guid
Master collegato alla tipologia

Valore di ritorno

DedCommType
Vedi anche

Documentazione

Classe DedCommTypeCollection
Overload di Add
Namespace DedNet.Core


Metodo DedCommTypeCollection.Clone

Metodo DedCommTypeCollectionClone
Metodo per clonare la collezione di commesse.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommTypeCollection Clone(
    DedCommType owner
)
Public Function Clone (
    owner As DedCommType
) As DedCommTypeCollection
public:
DedCommTypeCollection^ Clone(
    DedCommType^ owner
)
member Clone :
        owner : DedCommType -> DedCommTypeCollection

Parametri

owner DedCommType

Valore di ritorno

DedCommTypeCollection
Vedi anche

Documentazione

Classe DedCommTypeCollection
Namespace DedNet.Core


Metodo DedCommTypeCollection.CreateInsertCommand

Metodo DedCommTypeCollectionCreateInsertCommand
Crea un comando per inserire un elemento

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSInsertCommand CreateInsertCommand(
    DedCommType item
)
Protected Overrides Function CreateInsertCommand (
    item As DedCommType
) As QSInsertCommand
protected:
virtual QSInsertCommand^ CreateInsertCommand(
    DedCommType^ item
) override
abstract CreateInsertCommand :
        item : DedCommType -> QSInsertCommand
override CreateInsertCommand :
        item : DedCommType -> QSInsertCommand

Parametri

item DedCommType
Elemento da inserire

Valore di ritorno

QSInsertCommand
Vedi anche

Documentazione

Classe DedCommTypeCollection
Namespace DedNet.Core


Metodo DedCommTypeCollection.CreateUpdateCommand

Metodo DedCommTypeCollectionCreateUpdateCommand
Crea un comando per aggiornare un elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSUpdateCommand CreateUpdateCommand(
    DedCommType item
)
Protected Overrides Function CreateUpdateCommand (
    item As DedCommType
) As QSUpdateCommand
protected:
virtual QSUpdateCommand^ CreateUpdateCommand(
    DedCommType^ item
) override
abstract CreateUpdateCommand :
        item : DedCommType -> QSUpdateCommand
override CreateUpdateCommand :
        item : DedCommType -> QSUpdateCommand

Parametri

item DedCommType
Elemento da aggiornare

Valore di ritorno

QSUpdateCommand
Vedi anche

Documentazione

Classe DedCommTypeCollection
Namespace DedNet.Core


Metodo DedCommTypeCollection.OnAfterSave

Metodo DedCommTypeCollectionOnAfterSave
Utilizzata per eliminare gli attributi e le regole eliminate nelle sottocommesse delle commesse eliminate. Se sono attivi i permessi aggiunge nella tabella DED_COMM_USER_PERM tutte le associazioni dei permessi di lettura di tutti gli utenti per le commesse aggiunte e li rimuove per le commesse eliminate.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void OnAfterSave(
    List<DedCommType> eliminati,
    List<DedCommType> modificati,
    List<DedCommType> aggiunti
)
Protected Overrides Sub OnAfterSave (
    eliminati As List(Of DedCommType),
    modificati As List(Of DedCommType),
    aggiunti As List(Of DedCommType)
)
protected:
virtual void OnAfterSave(
    List<DedCommType^>^ eliminati,
    List<DedCommType^>^ modificati,
    List<DedCommType^>^ aggiunti
) override
abstract OnAfterSave :
        eliminati : List<DedCommType> *
        modificati : List<DedCommType> *
        aggiunti : List<DedCommType> -> unit
override OnAfterSave :
        eliminati : List<DedCommType> *
        modificati : List<DedCommType> *
        aggiunti : List<DedCommType> -> unit

Parametri

eliminati List DedCommType
modificati List DedCommType
aggiunti List DedCommType
Vedi anche

Documentazione

Classe DedCommTypeCollection
Namespace DedNet.Core


Metodo DedCommTypeCollection.Remove

Metodo DedCommTypeCollectionRemove
Elimina un elemento dalla collezione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void Remove(
    DedCommType item
)
Public Overrides Sub Remove (
    item As DedCommType
)
public:
virtual void Remove(
    DedCommType^ item
) override
abstract Remove :
        item : DedCommType -> unit
override Remove :
        item : DedCommType -> unit

Parametri

item DedCommType
Elemento da eliminare.
Vedi anche

Documentazione

Classe DedCommTypeCollection
Namespace DedNet.Core


Classe DedCommTypeList
Lista di oggetti DedCommType.
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList DedTypeBase
DedNet.CoreDedTypeGenericList DedTypeBase
DedNet.CoreDedTypeBaseList
DedNet.CoreDedCommTypeList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedCommTypeList : DedTypeBaseList
Public Class DedCommTypeList
    Inherits DedTypeBaseList
public ref class DedCommTypeList : public DedTypeBaseList
type DedCommTypeList =
    class
        inherit DedTypeBaseList
    end

Il tipo DedCommTypeList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedCommTypeList | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione di appartenenza. (Ereditato da DedTypeGenericListT)
Proprietà pubblica | CommonDedType | Restituisce la commessa genitore comune a tutte le commesse presenti. (Sovrascrive DedTypeGenericListTCommonDedType)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedCommTypeList
Costruttore unico.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommTypeList(
    DedNetApplication application
)
Public Sub New (
    application As DedNetApplication
)
public:
DedCommTypeList(
    DedNetApplication^ application
)
new :
        application : DedNetApplication -> DedCommTypeList

Parametri

application DedNetApplication
Oggetto applicazione di appartenenza.
Vedi anche

Documentazione

Classe DedCommTypeList
Namespace DedNet.Core


Proprietà di DedCommTypeList

Il tipo DedCommTypeList espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione di appartenenza. (Ereditato da DedTypeGenericListT)
Proprietà pubblica | CommonDedType | Restituisce la commessa genitore comune a tutte le commesse presenti. (Sovrascrive DedTypeGenericListTCommonDedType)
Torna su
Vedi anche

Documentazione

Classe DedCommTypeList
Namespace DedNet.Core


Proprietà DedCommTypeList.CommonDedType

Proprietà DedCommTypeListCommonDedType
Restituisce la commessa genitore comune a tutte le commesse presenti.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override Object CommonDedType { get; }
Public Overrides ReadOnly Property CommonDedType As Object
    Get
public:
virtual property Object^ CommonDedType {
    Object^ get () override;
}
abstract CommonDedType : Object with get
override CommonDedType : Object with get

Valore della proprietà

Object
Vedi anche

Documentazione

Classe DedCommTypeList
Namespace DedNet.Core


Classe DedCorporate
Racchiude le informazioni relative alla corporate
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedCorporate

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedCorporate : IDedDbItem
Public Class DedCorporate
    Implements IDedDbItem
public ref class DedCorporate : IDedDbItem
type DedCorporate =
    class
        interface IDedDbItem
    end

Il tipo DedCorporate espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CorporateType | Indica se la corporate è quella master
Proprietà pubblica | Description | Descrizione
Proprietà pubblica | Id | Identificativo
Proprietà pubblica | IsMaster | REstituisce se è la corporate Master
Proprietà pubblica | Name | Nome
Proprietà pubblica | Parent | Collezione di appartenenza
Proprietà pubblica | Snapshotted | Indica se sulla corporate è stato fatto lo snapshot
Proprietà pubblica | StatoRecord | Restituisce o imposta lo stato del record.
Proprietà pubblica | Users | Nome utente associato per la gestione delle notifiche
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | GetUserNames | Restituisce la lista degli utenti che appartengono alla comporate.
Metodo pubblico | GetUsers | Restituisce la lista degli utenti che appartengono alla comporate.
Metodo pubblico | ToString | Esegue l'override della conversione a stringa (Sovrascrive ObjectToString)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di DedCorporate

Il tipo DedCorporate espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CorporateType | Indica se la corporate è quella master
Proprietà pubblica | Description | Descrizione
Proprietà pubblica | Id | Identificativo
Proprietà pubblica | IsMaster | REstituisce se è la corporate Master
Proprietà pubblica | Name | Nome
Proprietà pubblica | Parent | Collezione di appartenenza
Proprietà pubblica | Snapshotted | Indica se sulla corporate è stato fatto lo snapshot
Proprietà pubblica | StatoRecord | Restituisce o imposta lo stato del record.
Proprietà pubblica | Users | Nome utente associato per la gestione delle notifiche
Torna su
Vedi anche

Documentazione

Classe DedCorporate
Namespace DedNet.Core


Proprietà DedCorporate.CorporateType

Proprietà DedCorporateCorporateType
Indica se la corporate è quella master

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCorporateDedCorporateEnum CorporateType { get; set; }
Public Property CorporateType As DedCorporateDedCorporateEnum
    Get
    Set
public:
property DedCorporateDedCorporateEnum CorporateType {
    DedCorporateDedCorporateEnum get ();
    void set (DedCorporateDedCorporateEnum value);
}
member CorporateType : DedCorporateDedCorporateEnum with get, set

Valore della proprietà

DedCorporateDedCorporateEnum
Vedi anche

Documentazione

Classe DedCorporate
Namespace DedNet.Core


Proprietà DedCorporate.Description

Proprietà DedCorporateDescription
Descrizione

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
member Description : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedCorporate
Namespace DedNet.Core


Proprietà DedCorporate.Id

Proprietà DedCorporateId
Identificativo

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Guid Id { get; }
Public ReadOnly Property Id As Guid
    Get
public:
property Guid Id {
    Guid get ();
}
member Id : Guid with get

Valore della proprietà

Guid
Vedi anche

Documentazione

Classe DedCorporate
Namespace DedNet.Core


Proprietà DedCorporate.IsMaster

Proprietà DedCorporateIsMaster
REstituisce se è la corporate Master

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsMaster { get; }
Public ReadOnly Property IsMaster As Boolean
    Get
public:
property bool IsMaster {
    bool get ();
}
member IsMaster : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedCorporate
Namespace DedNet.Core


Proprietà DedCorporate.Name

Proprietà DedCorporateName
Nome

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedCorporate
Namespace DedNet.Core


Proprietà DedCorporate.Parent

Proprietà DedCorporateParent
Collezione di appartenenza

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCorporates Parent { get; set; }
Public Property Parent As DedCorporates
    Get
    Set
public:
property DedCorporates^ Parent {
    DedCorporates^ get ();
    void set (DedCorporates^ value);
}
member Parent : DedCorporates with get, set

Valore della proprietà

DedCorporates
Vedi anche

Documentazione

Classe DedCorporate
Namespace DedNet.Core


Proprietà DedCorporate.Snapshotted

Proprietà DedCorporateSnapshotted
Indica se sulla corporate è stato fatto lo snapshot

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Snapshotted { get; set; }
Public Property Snapshotted As Boolean
    Get
    Set
public:
property bool Snapshotted {
    bool get ();
    void set (bool value);
}
member Snapshotted : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedCorporate
Namespace DedNet.Core


Proprietà DedCorporate.StatoRecord

Proprietà DedCorporateStatoRecord
Restituisce o imposta lo stato del record.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public StatoRecord StatoRecord { get; set; }
Public Property StatoRecord As StatoRecord
    Get
    Set
public:
virtual property StatoRecord^ StatoRecord {
    StatoRecord^ get () sealed;
    void set (StatoRecord^ value) sealed;
}
abstract StatoRecord : StatoRecord with get, set
override StatoRecord : StatoRecord with get, set

Valore della proprietà

StatoRecord

Implementa

IDedDbItemStatoRecord
Vedi anche

Documentazione

Classe DedCorporate
Namespace DedNet.Core


Proprietà DedCorporate.Users

Proprietà DedCorporateUsers
Nome utente associato per la gestione delle notifiche

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Users { get; set; }
Public Property Users As String
    Get
    Set
public:
property String^ Users {
    String^ get ();
    void set (String^ value);
}
member Users : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedCorporate
Namespace DedNet.Core


Metodi di DedCorporate

Il tipo DedCorporate espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | GetUserNames | Restituisce la lista degli utenti che appartengono alla comporate.
Metodo pubblico | GetUsers | Restituisce la lista degli utenti che appartengono alla comporate.
Metodo pubblico | ToString | Esegue l'override della conversione a stringa (Sovrascrive ObjectToString)
Torna su
Vedi anche

Documentazione

Classe DedCorporate
Namespace DedNet.Core


Metodo DedCorporate.GetUserNames

Metodo DedCorporateGetUserNames
Restituisce la lista degli utenti che appartengono alla comporate.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> GetUserNames()
Public Function GetUserNames As List(Of String)
public:
List<String^>^ GetUserNames()
member GetUserNames : unit -> List<string>

Valore di ritorno

List String
Vedi anche

Documentazione

Classe DedCorporate
Namespace DedNet.Core


Metodo DedCorporate.GetUsers

Metodo DedCorporateGetUsers
Restituisce la lista degli utenti che appartengono alla comporate.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<DedUser> GetUsers()
Public Function GetUsers As List(Of DedUser)
public:
List<DedUser^>^ GetUsers()
member GetUsers : unit -> List<DedUser>

Valore di ritorno

List DedUser
Vedi anche

Documentazione

Classe DedCorporate
Namespace DedNet.Core


Metodo DedCorporate.ToString

Metodo DedCorporateToString
Esegue l'override della conversione a stringa

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedCorporate
Namespace DedNet.Core


Enumerazione DedCorporate.DedCorporateEnum

Enumerazione DedCorporateDedCorporateEnum

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum DedCorporateEnum
Public Enumeration DedCorporateEnum
public enum class DedCorporateEnum
type DedCorporateEnum
Membri
Nome | Valore | Descrizione
Master | 0 |
Slave | 1 |
SlaveEquivalente | 2 |
Vedi anche

Documentazione

Namespace DedNet.Core


Classe DedCorporates
Insieme delle corporate
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedDbCollectionBase DedCorporate
DedNet.CoreDedCorporates

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedCorporates : DedDbCollectionBase<DedCorporate>
Public Class DedCorporates
    Inherits DedDbCollectionBase(Of DedCorporate)
public ref class DedCorporates : public DedDbCollectionBase<DedCorporate^>
type DedCorporates =
    class
        inherit DedDbCollectionBase<DedCorporate>
    end

Il tipo DedCorporates espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedCorporates | Costruttore unico
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllowsDuplicates | Restituisce se siano ammessi duplicati all'interno della lista. Se false viene sollevata una eccezione su tentativo di inserimento duplicati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Application | Restituisce l'oggetto applicazione di appartenza. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Count | Restituisce il numero di elementi presenti. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Dirty | Restituisce se la collezione o uno dei suoi elementi sia stata modificata. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | ErasedItems | Restitusice la lista in sola lettura degli elementi che risultano attualmente cancellati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | LastItem | Restituisce l'ultimo elemento della collezione oppure null se non ci sono elementi. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | RestoreErased | Restituisce se gli elementi cancellati devono essere ripristinati in caso vengano riaggiunti. (Ereditato da DedDbCollectionBaseT)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Add | Aggiunge un nuovo elemento alla collezione e lo restituisce.
Metodo protetto | AddForClone | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto SENZA MODIFICARNE LO STATO. Le classi derivate potranno utilizzare questo metodo per clonare la collezione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddNewElement | DI USO INTERNO. Aggiunge un elemento alla lista rendendo dirty l'oggetto. L'elemento viene aggiunto con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere un elemento alla lista. Dovranno loro stesse avere un metodo pubblico Add() che prenda i parametri necessari alla costruzione dell'oggetto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddRangeNewElement | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi rendendo dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere più elementi alla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddUnModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Clear | Elimina tutti gli elementi dalla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ClearRefresh | Svuota la lista impostando Dirty = false. Di fatto permette di effettuare un refresh della lista e quindi di ricaricarla. Serve per svuotare la lista e reinizializzarla da capo. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Contains | Verifica l'esistenza di un valore all'interno della lista degli elementi. Le classi derivate devono effettuarne l'override nel caso in cui l'elemento non implementi GetHashCode() per l'uso all'interno dei dizionarii. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | CopyTo | Copia un range di elementi in un array. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | CreateDeleteCommand | Crea il comando di delete per un elemento. (Sovrascrive DedDbCollectionBaseTCreateDeleteCommand(T))
Metodo protetto | CreateInsertCommand | Crea il comando di insert per un elemento. (Sovrascrive DedDbCollectionBaseTCreateInsertCommand(T))
Metodo protetto | CreateUpdateCommand | Crea il comando di update per un elemento. (Sovrascrive DedDbCollectionBaseTCreateUpdateCommand(T))
Metodo pubblico | CustomSort | Ordina la lista in base al comparatore passato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteDeleteItem | Esegue l'eliminazione di un elemento. Crea il comando tramite il metodo CreateDeleteCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteInsertItem | Esegue l'inserimento di un elemento. Crea il comando tramite il metodo CreateInsertCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteUpdateItem | Esegue l'aggiornamento di un elemento. Crea il comando tramite il metodo CreateUpdateCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Find | Restituisce l'oggetto cercato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FindAll | Restitusice la lista degli elementi che corrispondono al predicato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FindByCorporateId | Restituisce la corporate con l'id passato.
Metodo pubblico | FindByCorporateName | Restituisce la corporate con il nome passato.
Metodo pubblico | GetAllCorporateName | Restituisce la lista di tutti i nomi delle corporate presenti. La prima della lista è la master.
Metodo protetto | GetDbIndex | Restitusice l'indice di un elemento (Sovrascrive DedDbCollectionBaseTGetDbIndex(T))
Metodo pubblico | GetEnumerator | Restituisce l'enumeratore della collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | GetMaster | Restituisce la corporate Master dall'elenco a disposizione
Metodo pubblico | IndexOf | Restituisce l'indice dell'elemento richiesto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InsertUnModified | DI USO INTERNO. Inserisce un elemento alla lista senza rendere dirty l'oggetto, all'indice specificato. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Item | Restituisce l'elemento iesimo della lista. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean) | Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean, Int32) | Sposta l'elemento dell'indice passato prima o dopo del numero di posizioni passate. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSave | Elimina i record in DED_DOC_DETACHED in fase di cancellazione della corporate. (Sovrascrive DedDbCollectionBaseTOnAfterSave(ListT, ListT, ListT))
Metodo protetto | OnAfterSaveNoChanges | Metodo Template chiamato dopo il salvataggio senza modifiche. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnBeforeSave | Metodo Template chiamato prima del salvataggio. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(T) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(DedEditableObjectT) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(T) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(DedEditableObjectT) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ReInitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Remove | Elimina un elemento dalla collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Ripristina | Verifica che l'elemento sia presente negli eliminati e lo toglie da lì e lo riaggiunge in coda alla lista degli elementi validi. Solleva una eccezione se l'elemento è già presente nella lista e AllowsDuplicates = false. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Save | Salva l'oggetto con tutta la sua lista, solo se questo risulta dirty. (Ereditato da DedDbCollectionBaseT)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedCorporates
Costruttore unico

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCorporates(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedCorporates(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedCorporates

Parametri

app DedNetApplication
Vedi anche

Documentazione

Classe DedCorporates
Namespace DedNet.Core


Proprietà di DedCorporates

Il tipo DedCorporates espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllowsDuplicates | Restituisce se siano ammessi duplicati all'interno della lista. Se false viene sollevata una eccezione su tentativo di inserimento duplicati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Application | Restituisce l'oggetto applicazione di appartenza. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Count | Restituisce il numero di elementi presenti. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Dirty | Restituisce se la collezione o uno dei suoi elementi sia stata modificata. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | ErasedItems | Restitusice la lista in sola lettura degli elementi che risultano attualmente cancellati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | LastItem | Restituisce l'ultimo elemento della collezione oppure null se non ci sono elementi. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | RestoreErased | Restituisce se gli elementi cancellati devono essere ripristinati in caso vengano riaggiunti. (Ereditato da DedDbCollectionBaseT)
Torna su
Vedi anche

Documentazione

Classe DedCorporates
Namespace DedNet.Core


Metodi di DedCorporates

Il tipo DedCorporates espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Add | Aggiunge un nuovo elemento alla collezione e lo restituisce.
Metodo protetto | AddForClone | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto SENZA MODIFICARNE LO STATO. Le classi derivate potranno utilizzare questo metodo per clonare la collezione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddNewElement | DI USO INTERNO. Aggiunge un elemento alla lista rendendo dirty l'oggetto. L'elemento viene aggiunto con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere un elemento alla lista. Dovranno loro stesse avere un metodo pubblico Add() che prenda i parametri necessari alla costruzione dell'oggetto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddRangeNewElement | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi rendendo dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere più elementi alla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddUnModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Clear | Elimina tutti gli elementi dalla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ClearRefresh | Svuota la lista impostando Dirty = false. Di fatto permette di effettuare un refresh della lista e quindi di ricaricarla. Serve per svuotare la lista e reinizializzarla da capo. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Contains | Verifica l'esistenza di un valore all'interno della lista degli elementi. Le classi derivate devono effettuarne l'override nel caso in cui l'elemento non implementi GetHashCode() per l'uso all'interno dei dizionarii. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | CopyTo | Copia un range di elementi in un array. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | CreateDeleteCommand | Crea il comando di delete per un elemento. (Sovrascrive DedDbCollectionBaseTCreateDeleteCommand(T))
Metodo protetto | CreateInsertCommand | Crea il comando di insert per un elemento. (Sovrascrive DedDbCollectionBaseTCreateInsertCommand(T))
Metodo protetto | CreateUpdateCommand | Crea il comando di update per un elemento. (Sovrascrive DedDbCollectionBaseTCreateUpdateCommand(T))
Metodo pubblico | CustomSort | Ordina la lista in base al comparatore passato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteDeleteItem | Esegue l'eliminazione di un elemento. Crea il comando tramite il metodo CreateDeleteCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteInsertItem | Esegue l'inserimento di un elemento. Crea il comando tramite il metodo CreateInsertCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteUpdateItem | Esegue l'aggiornamento di un elemento. Crea il comando tramite il metodo CreateUpdateCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Find | Restituisce l'oggetto cercato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FindAll | Restitusice la lista degli elementi che corrispondono al predicato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FindByCorporateId | Restituisce la corporate con l'id passato.
Metodo pubblico | FindByCorporateName | Restituisce la corporate con il nome passato.
Metodo pubblico | GetAllCorporateName | Restituisce la lista di tutti i nomi delle corporate presenti. La prima della lista è la master.
Metodo protetto | GetDbIndex | Restitusice l'indice di un elemento (Sovrascrive DedDbCollectionBaseTGetDbIndex(T))
Metodo pubblico | GetEnumerator | Restituisce l'enumeratore della collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | GetMaster | Restituisce la corporate Master dall'elenco a disposizione
Metodo pubblico | IndexOf | Restituisce l'indice dell'elemento richiesto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InsertUnModified | DI USO INTERNO. Inserisce un elemento alla lista senza rendere dirty l'oggetto, all'indice specificato. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Item | Restituisce l'elemento iesimo della lista. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean) | Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean, Int32) | Sposta l'elemento dell'indice passato prima o dopo del numero di posizioni passate. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSave | Elimina i record in DED_DOC_DETACHED in fase di cancellazione della corporate. (Sovrascrive DedDbCollectionBaseTOnAfterSave(ListT, ListT, ListT))
Metodo protetto | OnAfterSaveNoChanges | Metodo Template chiamato dopo il salvataggio senza modifiche. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnBeforeSave | Metodo Template chiamato prima del salvataggio. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(T) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(DedEditableObjectT) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(T) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(DedEditableObjectT) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ReInitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Remove | Elimina un elemento dalla collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Ripristina | Verifica che l'elemento sia presente negli eliminati e lo toglie da lì e lo riaggiunge in coda alla lista degli elementi validi. Solleva una eccezione se l'elemento è già presente nella lista e AllowsDuplicates = false. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Save | Salva l'oggetto con tutta la sua lista, solo se questo risulta dirty. (Ereditato da DedDbCollectionBaseT)
Torna su
Vedi anche

Documentazione

Classe DedCorporates
Namespace DedNet.Core


Metodo DedCorporates.Add

Metodo DedCorporatesAdd
Aggiunge un nuovo elemento alla collezione e lo restituisce.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCorporate Add(
    Guid id,
    string nome,
    string desc,
    string users,
    DedCorporateDedCorporateEnum corporateType,
    bool snapshotted
)
Public Function Add (
    id As Guid,
    nome As String,
    desc As String,
    users As String,
    corporateType As DedCorporateDedCorporateEnum,
    snapshotted As Boolean
) As DedCorporate
public:
DedCorporate^ Add(
    Guid id,
    String^ nome,
    String^ desc,
    String^ users,
    DedCorporateDedCorporateEnum corporateType,
    bool snapshotted
)
member Add :
        id : Guid *
        nome : string *
        desc : string *
        users : string *
        corporateType : DedCorporateDedCorporateEnum *
        snapshotted : bool -> DedCorporate

Parametri

id Guid
Identificativo della corporate
nome String
Nome della corporate.
desc String
Descrizione della corporate.
users String
Nome utente o gruppo di riferimento
corporateType DedCorporateDedCorporateEnum
snapshotted Boolean
Indica se sulla corporate è stato fatto lo snapshot

Valore di ritorno

DedCorporate
Vedi anche

Documentazione

Classe DedCorporates
Namespace DedNet.Core


Metodo DedCorporates.CreateDeleteCommand

Metodo DedCorporatesCreateDeleteCommand
Crea il comando di delete per un elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSDeleteCommand CreateDeleteCommand(
    DedCorporate item
)
Protected Overrides Function CreateDeleteCommand (
    item As DedCorporate
) As QSDeleteCommand
protected:
virtual QSDeleteCommand^ CreateDeleteCommand(
    DedCorporate^ item
) override
abstract CreateDeleteCommand :
        item : DedCorporate -> QSDeleteCommand
override CreateDeleteCommand :
        item : DedCorporate -> QSDeleteCommand

Parametri

item DedCorporate
Elemento per il quale creare il comando.

Valore di ritorno

QSDeleteCommand
Vedi anche

Documentazione

Classe DedCorporates
Namespace DedNet.Core


Metodo DedCorporates.CreateInsertCommand

Metodo DedCorporatesCreateInsertCommand
Crea il comando di insert per un elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSInsertCommand CreateInsertCommand(
    DedCorporate item
)
Protected Overrides Function CreateInsertCommand (
    item As DedCorporate
) As QSInsertCommand
protected:
virtual QSInsertCommand^ CreateInsertCommand(
    DedCorporate^ item
) override
abstract CreateInsertCommand :
        item : DedCorporate -> QSInsertCommand
override CreateInsertCommand :
        item : DedCorporate -> QSInsertCommand

Parametri

item DedCorporate
Elemento per il quale creare il comando.

Valore di ritorno

QSInsertCommand
Vedi anche

Documentazione

Classe DedCorporates
Namespace DedNet.Core


Metodo DedCorporates.CreateUpdateCommand

Metodo DedCorporatesCreateUpdateCommand
Crea il comando di update per un elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSUpdateCommand CreateUpdateCommand(
    DedCorporate item
)
Protected Overrides Function CreateUpdateCommand (
    item As DedCorporate
) As QSUpdateCommand
protected:
virtual QSUpdateCommand^ CreateUpdateCommand(
    DedCorporate^ item
) override
abstract CreateUpdateCommand :
        item : DedCorporate -> QSUpdateCommand
override CreateUpdateCommand :
        item : DedCorporate -> QSUpdateCommand

Parametri

item DedCorporate
Elemento per il quale creare il comando.

Valore di ritorno

QSUpdateCommand
Vedi anche

Documentazione

Classe DedCorporates
Namespace DedNet.Core


Metodo DedCorporates.FindByCorporateId

Metodo DedCorporatesFindByCorporateId
Restituisce la corporate con l'id passato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCorporate FindByCorporateId(
    Guid id
)
Public Function FindByCorporateId (
    id As Guid
) As DedCorporate
public:
DedCorporate^ FindByCorporateId(
    Guid id
)
member FindByCorporateId :
        id : Guid -> DedCorporate

Parametri

id Guid

Valore di ritorno

DedCorporate
Vedi anche

Documentazione

Classe DedCorporates
Namespace DedNet.Core


Metodo DedCorporates.FindByCorporateName

Metodo DedCorporatesFindByCorporateName
Restituisce la corporate con il nome passato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCorporate FindByCorporateName(
    string name
)
Public Function FindByCorporateName (
    name As String
) As DedCorporate
public:
DedCorporate^ FindByCorporateName(
    String^ name
)
member FindByCorporateName :
        name : string -> DedCorporate

Parametri

name String

Valore di ritorno

DedCorporate
Vedi anche

Documentazione

Classe DedCorporates
Namespace DedNet.Core


Metodo DedCorporates.GetAllCorporateName

Metodo DedCorporatesGetAllCorporateName
Restituisce la lista di tutti i nomi delle corporate presenti. La prima della lista è la master.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> GetAllCorporateName()
Public Function GetAllCorporateName As List(Of String)
public:
List<String^>^ GetAllCorporateName()
member GetAllCorporateName : unit -> List<string>

Valore di ritorno

List String
Vedi anche

Documentazione

Classe DedCorporates
Namespace DedNet.Core


Metodo DedCorporates.GetDbIndex

Metodo DedCorporatesGetDbIndex
Restitusice l'indice di un elemento

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override Object GetDbIndex(
    DedCorporate item
)
Protected Overrides Function GetDbIndex (
    item As DedCorporate
) As Object
protected:
virtual Object^ GetDbIndex(
    DedCorporate^ item
) override
abstract GetDbIndex :
        item : DedCorporate -> Object
override GetDbIndex :
        item : DedCorporate -> Object

Parametri

item DedCorporate

Valore di ritorno

Object
Vedi anche

Documentazione

Classe DedCorporates
Namespace DedNet.Core


Metodo DedCorporates.GetMaster

Metodo DedCorporatesGetMaster
Restituisce la corporate Master dall'elenco a disposizione

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCorporate GetMaster()
Public Function GetMaster As DedCorporate
public:
DedCorporate^ GetMaster()
member GetMaster : unit -> DedCorporate

Valore di ritorno

DedCorporate
Vedi anche

Documentazione

Classe DedCorporates
Namespace DedNet.Core


Metodo DedCorporates.OnAfterSave

Metodo DedCorporatesOnAfterSave
Elimina i record in DED_DOC_DETACHED in fase di cancellazione della corporate.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void OnAfterSave(
    List<DedCorporate> eliminati,
    List<DedCorporate> modificati,
    List<DedCorporate> aggiunti
)
Protected Overrides Sub OnAfterSave (
    eliminati As List(Of DedCorporate),
    modificati As List(Of DedCorporate),
    aggiunti As List(Of DedCorporate)
)
protected:
virtual void OnAfterSave(
    List<DedCorporate^>^ eliminati,
    List<DedCorporate^>^ modificati,
    List<DedCorporate^>^ aggiunti
) override
abstract OnAfterSave :
        eliminati : List<DedCorporate> *
        modificati : List<DedCorporate> *
        aggiunti : List<DedCorporate> -> unit
override OnAfterSave :
        eliminati : List<DedCorporate> *
        modificati : List<DedCorporate> *
        aggiunti : List<DedCorporate> -> unit

Parametri

eliminati List DedCorporate
modificati List DedCorporate
aggiunti List DedCorporate
Vedi anche

Documentazione

Classe DedCorporates
Namespace DedNet.Core


Classe DedData
Classe descrivente un oggetto di anagrafica.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedBaseDbItem
DedNet.CoreDedTimedDbItem
DedNet.CoreDedData

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedData : DedTimedDbItem, IDedData,
    IDedTypeEditable, IDedEditable
Public Class DedData
    Inherits DedTimedDbItem
    Implements IDedData, IDedTypeEditable, IDedEditable
public ref class DedData : public DedTimedDbItem,
    IDedData, IDedTypeEditable, IDedEditable
type DedData =
    class
        inherit DedTimedDbItem
        interface IDedData
        interface IDedTypeEditable
        interface IDedEditable
    end

Il tipo DedData espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedData | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AlternativeData | Ritorna la lista contenente l'elenco dei codici sostitutivi a questa anagrafica.
Proprietà pubblica | Application | Restituisce l'applicazione di appartenenza.
Proprietà pubblica | Context | Restituisce il contesto dell'anagrafica per la quale il documento è stato richiesto oppure null nel caso in cui non sia stata creata in un ambito di anagrafica.
Proprietà pubblica | Count | Restituisce il numero di elementi interessati (restituisce sempre 1).
Proprietà pubblica | DbIndex | Restiruisce il guid dell'anagrafica. Nel caso venga settato viene anche automaticamente aggiornato nel Database. NB : Il set non deve essere mai usato se non internamente. (Sovrascrive DedBaseDbItemDbIndex)
Proprietà pubblica | DBPATH | Restituisce il DBPATH di questa anagrafica.
Proprietà pubblica | DED_COD | Restituisce il DED_COD (codice aziendale di questa anagrafica (normalmente DED_COD = DEDID)).
Proprietà pubblica | DED_DIS | Restituisce il DED_DIS (numero di disegno completo di revisione, vecchio indice che continua ad essere presente con duplicati ammessi o non ammessi).
Proprietà pubblica | DED_FILE | Restituisce il DED_FILE (nome del file da utilizzare per i file primari collegati a questa anagrafica).
Proprietà pubblica | DEDDATE | Restituisce il DEDDATE (la data di creazione di questa anagrafica).
Proprietà pubblica | DEDDESC | Restituisce il DEDDESC (la descrizione) di questa anagrafica.
Proprietà pubblica | DEDID | Restituisce il DEDID di questa anagrafica.
Proprietà pubblica | DedIdAndDedRevAsString | Restituisce una rappresentazione stringa dell'anagrafica tramite DEDID e DEDREV.
Proprietà pubblica | DEDLOCK | Restituisce il DEDLOCK di questa anagrafica oppure null se non è presente.
Proprietà pubblica | DEDMODDATE | Restituisce il DEDMODDATE (la data di ultima modifica dell'anagrafica).
Proprietà pubblica | DEDMODUSER | Restituisce il DEDMODUSER (l'utente che ha fatto l'ultima modificato all'anagrafica).
Proprietà pubblica | DEDREV | Restituisce il DEDREV di questa anagrafica.
Proprietà pubblica | DEDREVDATE | Restituisce il DEDREVDATE (la data di creazione di questa revisione).
Proprietà pubblica | DEDREVDESC | Restituisce il DEDREVDESC (la descrizione delle modifiche apportate in a questa revisione).
Proprietà pubblica | DEDREVUSER | Restituisce il DEDREVUSER (l'utente che ha creato questa revisione).
Proprietà pubblica | DEDROWVER | Restituisce la versione corrente del record.
Proprietà pubblica | DEDSTATEDATE | Restituisce il DEDSTATEDATE (data nella quale è stato messo nello stato corrente questa anagrafica).
Proprietà pubblica | DEDSTATEID | Restituisce il DEDSTATEID (ID dello stato di questo record). Utilizzare preferenzialmente la proprietà State in quanto restituisce un valore dell'enumerazione ed un valore di default nel caso di null.
Proprietà pubblica | DEDSTATENOTE | Restituisce il DEDSTATENOTE (note sul cambio di stato).
Proprietà pubblica | DEDSTATEUSER | Restituisce il DEDSTATEUSER (utente che ha messo nello stato corrente questa anagrafica.).
Proprietà pubblica | DedType | Restituisce la famiglia nella quale è stato archiviata questa anagrafica. Può restituire null se non appartiene ad alcuna famiglia.
Proprietà pubblica | DedTypeBase | Restituisce la famiglia nella quale è stato archiviata questa anagrafica. Può restituire null se non appartiene ad alcuna famiglia.
Proprietà pubblica | DEDUSER | Restituisce il DEDUSER (l'utente che ha creato questa anagrafica).
Proprietà pubblica | Dirty | Restituisce se questa anagrafica sia stata modificata dopo la creazione.
Proprietà pubblica | DwgPath | Codifica utilizzate per creare DED_FILE.
Proprietà pubblica | EncodeDataInfo | Classe contenente le info di codifica.
Proprietà pubblica | EncodedCod | Codifica utilizzate per creare DED_COD.
Proprietà pubblica | EncodedDis | Codifica utilizzate per creare DED_DIS.
Proprietà pubblica | EncodedFil | Codifica utilizzate per creare DED_FILE.
Proprietà pubblica | EncodedId | Codifica utilizzate per creare ID.
Proprietà pubblica | EncodeInfo | Restituisce le informazioni di codifica per questa anagrafica. Se l'anagrafica è stata codificata in una famiglia normale ricava le informazioni dal DedID aggiungendo la propria revisione, se invece è stata codificata in una famiglia FreeCode o FreeFile cerca di ricavarle dal Ded_File o dal DedId. Se è sia FreeCode che FreeFile restituisce le informazioni con la famiglia e l'anagrafica soltanto.
Proprietà pubblica | Erased | Ritorna true se l'anagrafica è eliminata
Proprietà pubblica | FreeCode | Indica se è una anagrafica FreeCode
Proprietà pubblica | FreeFile | Indica se è una anagrafica FreeFile
Proprietà pubblica | FreeFileAsDedId | Restituisce/Imposta se il file debba essere compilato come l'id.
Proprietà pubblica | FreeFileSameFileRev | Restituisce/Imposta se il file debba rimanere uguale anche nelle revisioni.
Proprietà pubblica | FreeFileType | Indica il tipo di FreeFile dell'anagrafica
Proprietà pubblica | HasInfoUser | Resttuisce se l'anagrafica presenta l'infouser
Proprietà pubblica | IsLastRev | Restituisce se questa anagrafica sia o meno l'ultima. Controlla di essere l'ultima in assoluto senza considerare le revisioni rilasciate.
Proprietà pubblica | IsLocked | Restituisce se il record sia bloccato (dall'utente corrente o da un altro). Non legge dal Database, controlla solo se è compilato il campo DEDLOCK.
Proprietà pubblica | IsLockedByMe | Restituisce se il record sia bloccato dall'utente corrente. Non legge dal Database, controlla solo se è il campo DEDLOCK è compilato con il nome utente corrente.
Proprietà pubblica | IsLockedByOther | Restituisce se il record sia bloccato da un utente differente dall'utente corrente. Non legge dal Database, controlla solo se è il campo DEDLOCK è compilato e se lo è in modo diverso dall'utente corrente.
Proprietà pubblica | IsRevNewType | Restituisce true se questa famiglia non ha il tassello della revisione nel nome file oppure se è FreeFile. Negli altri casi restituisce false.
Proprietà pubblica | IsRevZero | Restituisce se questa anagrafica sia o meno la revisione Zero. Controlla di essere la prima anagrafica.
Proprietà pubblica | IsSparePart | Indica se l'anagrafica è in realtà un pezzo di ricambio o meno.
Proprietà pubblica | IsValid | Restituisce se i valori presenti validano gli attributi della famiglia di appartenenza. Non cosidera attributi se siamo in fase di creazione anagrafica/revisione per validazioni specifiche usare metodo Validate.
Proprietà pubblica | Item | Restituisce il contenuto di un campo personalizzato oppure null se non esiste.
Proprietà pubblica | Keys | Restituisce la lista delle chiavi presenti nell'anagrafica.
Proprietà pubblica | LockVer | Restituisce il Guid utilizzato per il blocco del record. Se l'anagrafica non è bloccata dall'utente corrente viene restituito Guid.Empty.
Proprietà pubblica | Root | Restituisce la famiglia nella quale è stato archiviata questa anagrafica. Può restituire null se non appartiene ad alcuna famiglia.
Proprietà pubblica | State | Restituisce o imposta lo stato dell'anagrafica. Non effettua controlli sulla coerenza del dato impostato rispetto al valore precedente. Se il valore dello stato è null restituisce Lavorazione. Imposta eventualmente a dirty l'anagrafica.
Proprietà pubblica | TimeList | Ritorna l'elenco delle temporizzazioni associate a questo elemento. (Ereditato da DedTimedDbItem)
Proprietà pubblica | Translations | Restituisce la lista delle traduzioni abbinati a questa anagrafica.
Proprietà pubblica | UpdateRowVer | Restituisce se aggiornare il ROWVER dell'anagrafica
Proprietà pubblica | Values | Restituisce la lista dei valori presenti nell'anagrafica.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AddDoc(DedDoc, DedDocContextEnum) | Associa un documento esistente e lo restituisce con il contesto aggiornato.
Metodo pubblico | AddDoc(String, DedDocContextEnum) | Se il documento esiste già lo inizializza altrimenti lo crea; in tutti i casi lo associa e lo restituisce con il contesto aggiornato.
Metodo pubblico | AddDoc(DedDoc, DedDocContextEnum, DedData) | Associa un documento esistente e lo restituisce con il contesto aggiornato.
Metodo pubblico | AddDoc(DedDoc, DedDocContextEnum, DedData, ConfigDescriptor) | Associa un documento esistente e lo restituisce con il contesto aggiornato.
Metodo pubblico | AddDoc(String, DedDocContextEnum, Guid, String) | Se il documento esiste già lo inizializza altrimenti lo crea; in tutti i casi lo associa e lo restituisce con il contesto aggiornato.
Metodo pubblico | AddDocs | Associa una lista di documenti ad una anagrafica impostando un particolare contesto. Se i documenti non esistono vengono prima creati. Restituisce sempre una lista inizializzata.
Metodo pubblico | AddToDataEncode | Aggiunge questa anagrafica dalla tabella DED_DATA_ENCODE.
Metodo pubblico | AddToErased | Aggiunge l'anagrafica alla tabella degli eliminati
 | AsHashString | Metodo statico che ritorno id e rev ricevuti dall'esterno sottoforma di hashstring compatibile per confronto
Metodo pubblico | CanLock | Indica se un anagrafica può essere bloccata.
Metodo pubblico | Delete | Elimina l'anagrafica dalla tabella DED_DATA. Non la elimina dalla tabella di collegamento con i documenti.
Metodo pubblico | Equals | Ridefinizione di uguaglianza. (Sovrascrive ObjectEquals(Object))
Metodo pubblico | FormatDedRev | Funzione per formattare la revisione.
Metodo pubblico | GetAllAttachDocuments | Restituisce la lista dei documenti allegati a questa anagrafica. Restituisce sempre una lista inizializzata.
Metodo pubblico | GetAllPrimaryDocuments | Restituisce la lista dei documenti collegati a questa anagrafica come Modello, Rappresentazione o Pubblicazione. Restituisce sempre una lista inizializzata.
Metodo pubblico | GetAllPrimaryNotLinkedDocuments | Restituisce la lista dei documenti collegati a questa anagrafica come Modello, Rappresentazione o Pubblicazione. Restituisce sempre una lista inizializzata.
Metodo pubblico | GetAllSparePartsDocuments | Restituisce la lista dei documenti allegati a questa anagrafica. Restituisce sempre una lista inizializzata.
Metodo pubblico | GetAlternativeAttrValue | Restituisce il valore dell'attributo che rappresenta il codice alternativo
Metodo pubblico | GetAttributes | Restituisce la lista degli attributi di anagrafica visti dalla famiglia alla quale appartiene questo oggetto. Restituisce sempre una lista inizializata anche se l'anagrafica non appartiene ad alcuna famiglia: In questo caso restituisce gli attributi della root.
Metodo pubblico | GetAttrsFromCategory(DedCateg) | Ritorna la lista di attributi visibili dalla famiglia che appartengono alla categoria passata.
Metodo pubblico | GetAttrsFromCategory(String) | Ritorna la lista di attributi visibili dalla famiglia che appartengono alla categoria passata.
Metodo pubblico | GetCommCount | Restituisce il numero di commesse collegate a questa anagrafica
Metodo pubblico | GetComms | Restituisce la lista di commesse collegate a questa anagrafica
Metodo pubblico | GetDefaultAttachDir | Restituisce il nome completo della cartella principale nella quale inserire gli allegati di questa anagrafica. Restituisce null se l'anagrafica non appartiene ad alcuna famiglia di archiviazione.
Metodo pubblico | GetDefaultPrimaryFullFileName | Restituisce il nome completo, senza estensione, del file che dovrebbe avere un file primario appartenente a questa anagrafica. Restituisce null se l'anagrafica non appartiene ad alcuna famiglia di archiviazione.
Metodo pubblico | GetDescription | (Sovrascrive DedBaseDbItemGetDescription)
Metodo pubblico | GetDocuments | Restituisce tutti i documenti collegati all'anagrafica. Restituisce una lista inizializzata ma vuota se non ne esistono.
Metodo pubblico | GetDocuments(DedDocContextEnum) | Restituisce tutti i file collegati all'anagrafica aventi un determinato contesto. Restituisce una lista inizializzata ma vuota se non ne esistono.
Metodo pubblico | GetDocuments(FuncDedDocContext, Boolean) | Restituisce tutti i file collegati all'anagrafica che soddisfano il criterio del delegate passato Restituisce una lista inizializzata ma vuota se non ne esistono.
Metodo pubblico | GetDocuments(ListString) | Restituisce tutti i file collegati all'anagrafica aventi una determinata estensione. Restituisce una lista inizializzata ma vuota se non ne esistono.
Metodo pubblico | GetDocuments(DedDocContextEnum, String) | Restituisce tutti i file collegati all'anagrafica aventi un determinato contesto e una determinata estensione. Restituisce una lista inizializzata ma vuota se non ne esistono.
Metodo pubblico | GetDocumentsCount | Restituisce il numero dei file collegati all'anagrafica.
Metodo pubblico | GetEcoList | Restituisce la lista di Eco collegati a questa anagrafica.
Metodo pubblico | GetHashCode | Restituisce l'HashCode di questo oggetto. (Sovrascrive ObjectGetHashCode)
Metodo pubblico | GetLastGoodHistoryState | Restituisce l'ultimo stato buono (lavorazione/rilasciato/rilasciato in adattamento) nella tabella DED_STATE_HISTORY in cui si trovava l'anagrafica
Metodo pubblico | GetMaxTokenNum | Restituisce il massimo numero di caratteri usati per il TokenTypeEnum passato. Verifica nella maschera di codifica Cod_Id, Cod_Fil e Cod_Dis in modo da prendere il numero massimo di caratteri utilizzati.
Metodo pubblico | GetName | (Sovrascrive DedBaseDbItemGetName)
Metodo pubblico | GetObjectType | (Sovrascrive DedBaseDbItemGetObjectType)
Metodo pubblico | GetProgr | Restituisce il progressivo dell'anagrafica. Letto da DED_DATA_ENCODE se compilato altrimenti lo ricalcola.
Metodo pubblico | GetProgrTokenNum | Restituisce il numero di caratteri da utilizzare per creare la stringa del progressivo per questa famiglia. Li calcola cercando il tassello del progressivo nella codifica del Cod_Id. Se non è presente restituisce 0.
Metodo pubblico | GetRevDedDisTokenNum | Restituisce il numero di caratteri dedicati alla revisione, presenti nel DED_DIS.
Metodo pubblico | GetRevFileTokenNum | Restituisce il numero di caratteri dedicati alla revisione, presenti nel nome del file COD_FIL. Se si tratta di una famiglia NGR (nuova gestione delle revisioni), restituisce 0, altrimenti il numero di caratteri presenti.
Metodo pubblico | GetStrictPrimaryDocuments | Restituisce la lista dei documenti collegati a questa anagrafica come Modello, Rappresentazione o Pubblicazione. Restituisce sempre una lista inizializzata.
Metodo pubblico | GetValue(DedDataStandardDataFields) | Restituisce il contenuto di uno dei campi standard oppure null se non è presente.
Metodo pubblico | GetValue(String) | Restituisce il contenuto di un campo personalizzato oppure null se non esiste.
Metodo pubblico | GetVar | Restituisce il tassello di variante automatico dell'anagrafica.
Metodo pubblico | Lock | Esegue il blocco dell'anagrafica impostando il campo DEDLOCK con il nome dell'utente corrente. Utilizza il campo DEDROWVER attuale per effettuare il blocco in modo da non riuscire in caso di anagrafica già modificata. Questo metodo non rende dirty l'anagrafica ma bisogna poi sbloccarla attraverso UnLock() oppure con Update().
Metodo pubblico | MakeBackupFilePath | Restitusice il percorso completo del file come revisione nel caso di famiglia con NGR. Il percorso viene calcolato in base all'anagrafica mentre il nome file viene preso dal fileName passato e viene aggiunta la revisione di questo record.
Metodo pubblico | MakeClonePart | Restituisce un oggetto di tipo DedDataPart il quale implementa IDedData costruito tramite il dizionario interno di questa anagrafica. Da utilizzare per passare i dati dell'anagrafica, per esempio alla finestra di codifica, ed evitare che venga modificata l'anagrafica originale.
Metodo pubblico | MakeDefaultBackupPath | Restituisce la cartella nella quale un file revisionato, in presenza di famiglia NGR, dovrebbe essere copiato, se associato a questa anagrafica come primario.
Metodo pubblico | MakeDefaultFullFileName(DedDocContextEnum, String, String) | Costruisce e restituisce l'oggetto descrittivo DedRootInfo del percorso di default che dovrebbe avere un file associato a questa anagrafica con un particolare contesto. Se la richiesta riguarda un file primario viene restituito il nome completo prendendo l'estensione dal nome file passato ma con il giusto nome (calcolato dalla codifica della famiglia). Se si richiede di un allegato viene restitituito il nome del file passato così com'é, concatenato della cartella root di archiviazione allegati. Se la richiesta è di una rappresentazione viene fornito un nome composto con nome file primario più nome random del quale però si deve verificare la non esistenza prima dell'utilizzo.
Metodo pubblico | MakeDefaultFullFileName(DedDocContextEnum, String, String, Boolean) |
Metodo pubblico | MakeDefaultPrimaryFileName | Restituisce il nome che un file primario dovrebbe avere se associato a questa anagrafica. Se l'anagrafica presenta compilato il DED_FILE restituisce il suo valore, altrimenti lo calcola dalla famiglia di appartenenza e dai dati presenti.
Metodo pubblico | MakeDefaultPrimaryPath | Restituisce il percorso che un file primario dovrebbe avere se associato a questa anagrafica.
Metodo pubblico | RebuildPrimaryFullFileNameFromBackup(DedDoc) | Restituisce il nome completo del file originale, partendo dal nome di backup (usato nella NGR).
Metodo pubblico | RebuildPrimaryFullFileNameFromBackup(String) | Restituisce il nome completo del file originale, partendo dal nome di backup (usato nella NGR).
Metodo pubblico | Refresh | Aggiorna questo oggetto rileggendo le informazioni presenti nel Database. Effettua l'aggiornamento anche se l'anagrafica è dirty (la imposta a false dopo l'aggiornamento). Aggiorna tutti i campi quindi anche il DEDROWVERSION.
Metodo pubblico | ReloadInfoUser | Ricalcola modificando solo il tassello utente e la revisione tutto il resto rimane inalterato (usato per crea variante)
Metodo pubblico | ReloadRev | Ricalcola modificando solo il tassello utente tutto il resto rimane inalterato (usato per crea revisione)
Metodo pubblico | RemoveDoc | Scollega dall'anagrafica uno specifico documento, eliminando dal DB il legame.
Metodo pubblico | RemoveDocs | Scollega dall'anagrafica tutti i documenti, eliminandone dal DB il legame.
Metodo pubblico | RemoveDocs(ListGuid) | Scollega dall'anagrafica una lista di documenti, eliminandone dal DB il legame.
Metodo pubblico | RemoveFromErased | Rimuove l'anagrafica alla tabella degli eliminati
Metodo pubblico | SetState | Permette di cambiare lo stato di un'anagrafica.
Metodo pubblico | SetValue(DedDataStandardDataFields, Object) |
Metodo pubblico | SetValue(String, Object) | Imposta un campo personalizzato con un nuovo valore. Se il campo non esiste lo crea. La chiamata a questo metodo può causare la messa a Dirty dell'anagrafica, quando il campo da impostare è già presente nel dizionario interno ed il valore da impostare è differente da quello precedente oppure se è da creare. Oltre a porre l'anagrafica come Dirty viene anche tentato il lock dell'anagrafica fino alla successiva chiamata del metodo Update() che imposta l'anagrafica come sbloccata e non Dirty oppure UnLock() che annulla le modifiche.
Metodo pubblico | ToString | Restituisce una rappresentazione stringa di questo oggetto. (Sovrascrive ObjectToString)
Metodo pubblico | UnLock | Sblocca l'anagrafica solo se questa era bloccata. Opzionalmente, se questa è dirty, la aggiorna. Questo metodo la sblocca reimpostando il DEDROWVER alla versione precedente il bloccaggio ed effettua un Refresh() per riallineare i valori dell'anagrafica con il Database se l'anagrafica era Dirty.
Metodo pubblico | Update | Aggiorna l'anagrafica nel Database solo se questa è Dirty e quindi, in contemporanea, la sblocca. Poi imposta il dirty a false. Vengono aggiornati solo gli attributi che sono riconosciuti come d'anagrafica e non quelli di documento e di distinta. Oltre a questi vengono aggiornati anche i campi non presenti in DED_ATTR come : DEDROWVER, DEDMODUSER, DEDMODDATE e DEDLOCK, ecc.
Metodo pubblico | UpdateState | Scrive il cambio di stato nell'anagrafica e nella tabella DED_STATE_HISTORY.
Metodo pubblico | Validate | Restituisce se i valori presenti validano gli attributi della famiglia di appartenenza.
Torna su
Operatori
Nome | Descrizione
Equality(DedData, DedData) | Ridefinizione dell'operatore ==.
Inequality(DedData, DedData) | Ridefinizione dell'operatore !=.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedData
Costruttore unico.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedData(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedData

Parametri

app DedNetApplication
Oggetto applicazione di appartenenza.
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Proprietà di DedData

Il tipo DedData espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AlternativeData | Ritorna la lista contenente l'elenco dei codici sostitutivi a questa anagrafica.
Proprietà pubblica | Application | Restituisce l'applicazione di appartenenza.
Proprietà pubblica | Context | Restituisce il contesto dell'anagrafica per la quale il documento è stato richiesto oppure null nel caso in cui non sia stata creata in un ambito di anagrafica.
Proprietà pubblica | Count | Restituisce il numero di elementi interessati (restituisce sempre 1).
Proprietà pubblica | DbIndex | Restiruisce il guid dell'anagrafica. Nel caso venga settato viene anche automaticamente aggiornato nel Database. NB : Il set non deve essere mai usato se non internamente. (Sovrascrive DedBaseDbItemDbIndex)
Proprietà pubblica | DBPATH | Restituisce il DBPATH di questa anagrafica.
Proprietà pubblica | DED_COD | Restituisce il DED_COD (codice aziendale di questa anagrafica (normalmente DED_COD = DEDID)).
Proprietà pubblica | DED_DIS | Restituisce il DED_DIS (numero di disegno completo di revisione, vecchio indice che continua ad essere presente con duplicati ammessi o non ammessi).
Proprietà pubblica | DED_FILE | Restituisce il DED_FILE (nome del file da utilizzare per i file primari collegati a questa anagrafica).
Proprietà pubblica | DEDDATE | Restituisce il DEDDATE (la data di creazione di questa anagrafica).
Proprietà pubblica | DEDDESC | Restituisce il DEDDESC (la descrizione) di questa anagrafica.
Proprietà pubblica | DEDID | Restituisce il DEDID di questa anagrafica.
Proprietà pubblica | DedIdAndDedRevAsString | Restituisce una rappresentazione stringa dell'anagrafica tramite DEDID e DEDREV.
Proprietà pubblica | DEDLOCK | Restituisce il DEDLOCK di questa anagrafica oppure null se non è presente.
Proprietà pubblica | DEDMODDATE | Restituisce il DEDMODDATE (la data di ultima modifica dell'anagrafica).
Proprietà pubblica | DEDMODUSER | Restituisce il DEDMODUSER (l'utente che ha fatto l'ultima modificato all'anagrafica).
Proprietà pubblica | DEDREV | Restituisce il DEDREV di questa anagrafica.
Proprietà pubblica | DEDREVDATE | Restituisce il DEDREVDATE (la data di creazione di questa revisione).
Proprietà pubblica | DEDREVDESC | Restituisce il DEDREVDESC (la descrizione delle modifiche apportate in a questa revisione).
Proprietà pubblica | DEDREVUSER | Restituisce il DEDREVUSER (l'utente che ha creato questa revisione).
Proprietà pubblica | DEDROWVER | Restituisce la versione corrente del record.
Proprietà pubblica | DEDSTATEDATE | Restituisce il DEDSTATEDATE (data nella quale è stato messo nello stato corrente questa anagrafica).
Proprietà pubblica | DEDSTATEID | Restituisce il DEDSTATEID (ID dello stato di questo record). Utilizzare preferenzialmente la proprietà State in quanto restituisce un valore dell'enumerazione ed un valore di default nel caso di null.
Proprietà pubblica | DEDSTATENOTE | Restituisce il DEDSTATENOTE (note sul cambio di stato).
Proprietà pubblica | DEDSTATEUSER | Restituisce il DEDSTATEUSER (utente che ha messo nello stato corrente questa anagrafica.).
Proprietà pubblica | DedType | Restituisce la famiglia nella quale è stato archiviata questa anagrafica. Può restituire null se non appartiene ad alcuna famiglia.
Proprietà pubblica | DedTypeBase | Restituisce la famiglia nella quale è stato archiviata questa anagrafica. Può restituire null se non appartiene ad alcuna famiglia.
Proprietà pubblica | DEDUSER | Restituisce il DEDUSER (l'utente che ha creato questa anagrafica).
Proprietà pubblica | Dirty | Restituisce se questa anagrafica sia stata modificata dopo la creazione.
Proprietà pubblica | DwgPath | Codifica utilizzate per creare DED_FILE.
Proprietà pubblica | EncodeDataInfo | Classe contenente le info di codifica.
Proprietà pubblica | EncodedCod | Codifica utilizzate per creare DED_COD.
Proprietà pubblica | EncodedDis | Codifica utilizzate per creare DED_DIS.
Proprietà pubblica | EncodedFil | Codifica utilizzate per creare DED_FILE.
Proprietà pubblica | EncodedId | Codifica utilizzate per creare ID.
Proprietà pubblica | EncodeInfo | Restituisce le informazioni di codifica per questa anagrafica. Se l'anagrafica è stata codificata in una famiglia normale ricava le informazioni dal DedID aggiungendo la propria revisione, se invece è stata codificata in una famiglia FreeCode o FreeFile cerca di ricavarle dal Ded_File o dal DedId. Se è sia FreeCode che FreeFile restituisce le informazioni con la famiglia e l'anagrafica soltanto.
Proprietà pubblica | Erased | Ritorna true se l'anagrafica è eliminata
Proprietà pubblica | FreeCode | Indica se è una anagrafica FreeCode
Proprietà pubblica | FreeFile | Indica se è una anagrafica FreeFile
Proprietà pubblica | FreeFileAsDedId | Restituisce/Imposta se il file debba essere compilato come l'id.
Proprietà pubblica | FreeFileSameFileRev | Restituisce/Imposta se il file debba rimanere uguale anche nelle revisioni.
Proprietà pubblica | FreeFileType | Indica il tipo di FreeFile dell'anagrafica
Proprietà pubblica | HasInfoUser | Resttuisce se l'anagrafica presenta l'infouser
Proprietà pubblica | IsLastRev | Restituisce se questa anagrafica sia o meno l'ultima. Controlla di essere l'ultima in assoluto senza considerare le revisioni rilasciate.
Proprietà pubblica | IsLocked | Restituisce se il record sia bloccato (dall'utente corrente o da un altro). Non legge dal Database, controlla solo se è compilato il campo DEDLOCK.
Proprietà pubblica | IsLockedByMe | Restituisce se il record sia bloccato dall'utente corrente. Non legge dal Database, controlla solo se è il campo DEDLOCK è compilato con il nome utente corrente.
Proprietà pubblica | IsLockedByOther | Restituisce se il record sia bloccato da un utente differente dall'utente corrente. Non legge dal Database, controlla solo se è il campo DEDLOCK è compilato e se lo è in modo diverso dall'utente corrente.
Proprietà pubblica | IsRevNewType | Restituisce true se questa famiglia non ha il tassello della revisione nel nome file oppure se è FreeFile. Negli altri casi restituisce false.
Proprietà pubblica | IsRevZero | Restituisce se questa anagrafica sia o meno la revisione Zero. Controlla di essere la prima anagrafica.
Proprietà pubblica | IsSparePart | Indica se l'anagrafica è in realtà un pezzo di ricambio o meno.
Proprietà pubblica | IsValid | Restituisce se i valori presenti validano gli attributi della famiglia di appartenenza. Non cosidera attributi se siamo in fase di creazione anagrafica/revisione per validazioni specifiche usare metodo Validate.
Proprietà pubblica | Item | Restituisce il contenuto di un campo personalizzato oppure null se non esiste.
Proprietà pubblica | Keys | Restituisce la lista delle chiavi presenti nell'anagrafica.
Proprietà pubblica | LockVer | Restituisce il Guid utilizzato per il blocco del record. Se l'anagrafica non è bloccata dall'utente corrente viene restituito Guid.Empty.
Proprietà pubblica | Root | Restituisce la famiglia nella quale è stato archiviata questa anagrafica. Può restituire null se non appartiene ad alcuna famiglia.
Proprietà pubblica | State | Restituisce o imposta lo stato dell'anagrafica. Non effettua controlli sulla coerenza del dato impostato rispetto al valore precedente. Se il valore dello stato è null restituisce Lavorazione. Imposta eventualmente a dirty l'anagrafica.
Proprietà pubblica | TimeList | Ritorna l'elenco delle temporizzazioni associate a questo elemento. (Ereditato da DedTimedDbItem)
Proprietà pubblica | Translations | Restituisce la lista delle traduzioni abbinati a questa anagrafica.
Proprietà pubblica | UpdateRowVer | Restituisce se aggiornare il ROWVER dell'anagrafica
Proprietà pubblica | Values | Restituisce la lista dei valori presenti nell'anagrafica.
Torna su
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Proprietà DedData.AlternativeData

Proprietà DedDataAlternativeData
Ritorna la lista contenente l'elenco dei codici sostitutivi a questa anagrafica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAlternativeDataCollection AlternativeData { get; }
Public ReadOnly Property AlternativeData As DedAlternativeDataCollection
    Get
public:
property DedAlternativeDataCollection^ AlternativeData {
    DedAlternativeDataCollection^ get ();
}
member AlternativeData : DedAlternativeDataCollection with get

Valore della proprietà

DedAlternativeDataCollection
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Proprietà DedData.Application

Proprietà DedDataApplication
Restituisce l'applicazione di appartenenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedNetApplication Application { get; }
Public ReadOnly Property Application As DedNetApplication
    Get
public:
property DedNetApplication^ Application {
    DedNetApplication^ get ();
}
member Application : DedNetApplication with get

Valore della proprietà

DedNetApplication
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Proprietà DedData.Context

Proprietà DedDataContext
Restituisce il contesto dell'anagrafica per la quale il documento è stato richiesto oppure null nel caso in cui non sia stata creata in un ambito di anagrafica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocContext Context { get; }
Public ReadOnly Property Context As DedDocContext
    Get
public:
property DedDocContext^ Context {
    DedDocContext^ get ();
}
member Context : DedDocContext with get

Valore della proprietà

DedDocContext
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Proprietà DedData.Count

Proprietà DedDataCount
Restituisce il numero di elementi interessati (restituisce sempre 1).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get () sealed;
}
abstract Count : int with get
override Count : int with get

Valore della proprietà

Int32

Implementa

IDedDataCount
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Proprietà DedData.DbIndex

Proprietà DedDataDbIndex
Restiruisce il guid dell'anagrafica. Nel caso venga settato viene anche automaticamente aggiornato nel Database. NB : Il set non deve essere mai usato se non internamente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string DbIndex { get; }
Public Overrides ReadOnly Property DbIndex As String
    Get
public:
virtual property String^ DbIndex {
    String^ get () override;
}
abstract DbIndex : string with get
override DbIndex : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Proprietà DedData.DBPATH

Proprietà DedDataDBPATH
Restituisce il DBPATH di questa anagrafica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string DBPATH { get; set; }
Public Property DBPATH As String
    Get
    Set
public:
property String^ DBPATH {
    String^ get ();
    void set (String^ value);
}
member DBPATH : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Proprietà DedData.DED_COD

Proprietà DedDataDED_COD
Restituisce il DED_COD (codice aziendale di questa anagrafica (normalmente DED_COD = DEDID)).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string DED_COD { get; set; }
Public Property DED_COD As String
    Get
    Set
public:
property String^ DED_COD {
    String^ get ();
    void set (String^ value);
}
member DED_COD : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Proprietà DedData.DED_DIS

Proprietà DedDataDED_DIS
Restituisce il DED_DIS (numero di disegno completo di revisione, vecchio indice che continua ad essere presente con duplicati ammessi o non ammessi).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string DED_DIS { get; set; }
Public Property DED_DIS As String
    Get
    Set
public:
property String^ DED_DIS {
    String^ get ();
    void set (String^ value);
}
member DED_DIS : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Proprietà DedData.DED_FILE

Proprietà DedDataDED_FILE
Restituisce il DED_FILE (nome del file da utilizzare per i file primari collegati a questa anagrafica).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string DED_FILE { get; set; }
Public Property DED_FILE As String
    Get
    Set
public:
property String^ DED_FILE {
    String^ get ();
    void set (String^ value);
}
member DED_FILE : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Proprietà DedData.DEDDATE

Proprietà DedDataDEDDATE
Restituisce il DEDDATE (la data di creazione di questa anagrafica).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DateTime? DEDDATE { get; set; }
Public Property DEDDATE As DateTime?
    Get
    Set
public:
property Nullable<DateTime> DEDDATE {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
member DEDDATE : Nullable<DateTime> with get, set

Valore della proprietà

Nullable DateTime
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Proprietà DedData.DEDDESC

Proprietà DedDataDEDDESC
Restituisce il DEDDESC (la descrizione) di questa anagrafica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string DEDDESC { get; set; }
Public Property DEDDESC As String
    Get
    Set
public:
property String^ DEDDESC {
    String^ get ();
    void set (String^ value);
}
member DEDDESC : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Proprietà DedData.DEDID

Proprietà DedDataDEDID
Restituisce il DEDID di questa anagrafica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string DEDID { get; set; }
Public Property DEDID As String
    Get
    Set
public:
property String^ DEDID {
    String^ get ();
    void set (String^ value);
}
member DEDID : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Proprietà DedData.DedIdAndDedRevAsString

Proprietà DedDataDedIdAndDedRevAsString
Restituisce una rappresentazione stringa dell'anagrafica tramite DEDID e DEDREV.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string DedIdAndDedRevAsString { get; }
Public ReadOnly Property DedIdAndDedRevAsString As String
    Get
public:
property String^ DedIdAndDedRevAsString {
    String^ get ();
}
member DedIdAndDedRevAsString : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Proprietà DedData.DEDLOCK

Proprietà DedDataDEDLOCK
Restituisce il DEDLOCK di questa anagrafica oppure null se non è presente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string DEDLOCK { get; set; }
Public Property DEDLOCK As String
    Get
    Set
public:
property String^ DEDLOCK {
    String^ get ();
    void set (String^ value);
}
member DEDLOCK : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Proprietà DedData.DEDMODDATE

Proprietà DedDataDEDMODDATE
Restituisce il DEDMODDATE (la data di ultima modifica dell'anagrafica).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DateTime? DEDMODDATE { get; set; }
Public Property DEDMODDATE As DateTime?
    Get
    Set
public:
property Nullable<DateTime> DEDMODDATE {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
member DEDMODDATE : Nullable<DateTime> with get, set

Valore della proprietà

Nullable DateTime
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Proprietà DedData.DEDMODUSER

Proprietà DedDataDEDMODUSER
Restituisce il DEDMODUSER (l'utente che ha fatto l'ultima modificato all'anagrafica).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string DEDMODUSER { get; set; }
Public Property DEDMODUSER As String
    Get
    Set
public:
property String^ DEDMODUSER {
    String^ get ();
    void set (String^ value);
}
member DEDMODUSER : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Proprietà DedData.DEDREV

Proprietà DedDataDEDREV
Restituisce il DEDREV di questa anagrafica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string DEDREV { get; set; }
Public Property DEDREV As String
    Get
    Set
public:
property String^ DEDREV {
    String^ get ();
    void set (String^ value);
}
member DEDREV : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Proprietà DedData.DEDREVDATE

Proprietà DedDataDEDREVDATE
Restituisce il DEDREVDATE (la data di creazione di questa revisione).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DateTime? DEDREVDATE { get; set; }
Public Property DEDREVDATE As DateTime?
    Get
    Set
public:
property Nullable<DateTime> DEDREVDATE {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
member DEDREVDATE : Nullable<DateTime> with get, set

Valore della proprietà

Nullable DateTime
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Proprietà DedData.DEDREVDESC

Proprietà DedDataDEDREVDESC
Restituisce il DEDREVDESC (la descrizione delle modifiche apportate in a questa revisione).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string DEDREVDESC { get; set; }
Public Property DEDREVDESC As String
    Get
    Set
public:
property String^ DEDREVDESC {
    String^ get ();
    void set (String^ value);
}
member DEDREVDESC : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Proprietà DedData.DEDREVUSER

Proprietà DedDataDEDREVUSER
Restituisce il DEDREVUSER (l'utente che ha creato questa revisione).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string DEDREVUSER { get; set; }
Public Property DEDREVUSER As String
    Get
    Set
public:
property String^ DEDREVUSER {
    String^ get ();
    void set (String^ value);
}
member DEDREVUSER : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Proprietà DedData.DEDROWVER

Proprietà DedDataDEDROWVER
Restituisce la versione corrente del record.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Guid DEDROWVER { get; set; }
Public Property DEDROWVER As Guid
    Get
    Set
public:
property Guid DEDROWVER {
    Guid get ();
    void set (Guid value);
}
member DEDROWVER : Guid with get, set

Valore della proprietà

Guid
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Proprietà DedData.DEDSTATEDATE

Proprietà DedDataDEDSTATEDATE
Restituisce il DEDSTATEDATE (data nella quale è stato messo nello stato corrente questa anagrafica).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DateTime? DEDSTATEDATE { get; set; }
Public Property DEDSTATEDATE As DateTime?
    Get
    Set
public:
property Nullable<DateTime> DEDSTATEDATE {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
member DEDSTATEDATE : Nullable<DateTime> with get, set

Valore della proprietà

Nullable DateTime
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Proprietà DedData.DEDSTATEID

Proprietà DedDataDEDSTATEID
Restituisce il DEDSTATEID (ID dello stato di questo record). Utilizzare preferenzialmente la proprietà State in quanto restituisce un valore dell'enumerazione ed un valore di default nel caso di null.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int? DEDSTATEID { get; set; }
Public Property DEDSTATEID As Integer?
    Get
    Set
public:
property Nullable<int> DEDSTATEID {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member DEDSTATEID : Nullable<int> with get, set

Valore della proprietà

Nullable Int32
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Proprietà DedData.DEDSTATENOTE

Proprietà DedDataDEDSTATENOTE
Restituisce il DEDSTATENOTE (note sul cambio di stato).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string DEDSTATENOTE { get; set; }
Public Property DEDSTATENOTE As String
    Get
    Set
public:
property String^ DEDSTATENOTE {
    String^ get ();
    void set (String^ value);
}
member DEDSTATENOTE : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Proprietà DedData.DEDSTATEUSER

Proprietà DedDataDEDSTATEUSER
Restituisce il DEDSTATEUSER (utente che ha messo nello stato corrente questa anagrafica.).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string DEDSTATEUSER { get; set; }
Public Property DEDSTATEUSER As String
    Get
    Set
public:
property String^ DEDSTATEUSER {
    String^ get ();
    void set (String^ value);
}
member DEDSTATEUSER : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Proprietà DedData.DedType

Proprietà DedDataDedType
Restituisce la famiglia nella quale è stato archiviata questa anagrafica. Può restituire null se non appartiene ad alcuna famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedType DedType { get; }
Public ReadOnly Property DedType As DedType
    Get
public:
virtual property DedType^ DedType {
    DedType^ get () sealed;
}
abstract DedType : DedType with get
override DedType : DedType with get

Valore della proprietà

DedType

Implementa

IDedDataDedType
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Proprietà DedData.DedTypeBase

Proprietà DedDataDedTypeBase
Restituisce la famiglia nella quale è stato archiviata questa anagrafica. Può restituire null se non appartiene ad alcuna famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeBase DedTypeBase { get; }
Public ReadOnly Property DedTypeBase As DedTypeBase
    Get
public:
virtual property DedTypeBase^ DedTypeBase {
    DedTypeBase^ get () sealed;
}
abstract DedTypeBase : DedTypeBase with get
override DedTypeBase : DedTypeBase with get

Valore della proprietà

DedTypeBase

Implementa

IDedTypeEditableDedTypeBase
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Proprietà DedData.DEDUSER

Proprietà DedDataDEDUSER
Restituisce il DEDUSER (l'utente che ha creato questa anagrafica).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string DEDUSER { get; set; }
Public Property DEDUSER As String
    Get
    Set
public:
property String^ DEDUSER {
    String^ get ();
    void set (String^ value);
}
member DEDUSER : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Proprietà DedData.Dirty

Proprietà DedDataDirty
Restituisce se questa anagrafica sia stata modificata dopo la creazione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Dirty { get; }
Public ReadOnly Property Dirty As Boolean
    Get
public:
virtual property bool Dirty {
    bool get () sealed;
}
abstract Dirty : bool with get
override Dirty : bool with get

Valore della proprietà

Boolean

Implementa

IDedDataDirty
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Proprietà DedData.DwgPath

Proprietà DedDataDwgPath
Codifica utilizzate per creare DED_FILE.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string DwgPath { get; }
Public ReadOnly Property DwgPath As String
    Get
public:
property String^ DwgPath {
    String^ get ();
}
member DwgPath : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Proprietà DedData.EncodeDataInfo

Proprietà DedDataEncodeDataInfo
Classe contenente le info di codifica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataDedDataEncodeInfo EncodeDataInfo { get; }
Public ReadOnly Property EncodeDataInfo As DedDataDedDataEncodeInfo
    Get
public:
property DedDataDedDataEncodeInfo^ EncodeDataInfo {
    DedDataDedDataEncodeInfo^ get ();
}
member EncodeDataInfo : DedDataDedDataEncodeInfo with get

Valore della proprietà

DedDataDedDataEncodeInfo
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Proprietà DedData.EncodedCod

Proprietà DedDataEncodedCod
Codifica utilizzate per creare DED_COD.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeCompCodeEnum EncodedCod { get; }
Public ReadOnly Property EncodedCod As DedTypeCompCodeEnum
    Get
public:
property DedTypeCompCodeEnum EncodedCod {
    DedTypeCompCodeEnum get ();
}
member EncodedCod : DedTypeCompCodeEnum with get

Valore della proprietà

DedTypeCompCodeEnum
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Proprietà DedData.EncodedDis

Proprietà DedDataEncodedDis
Codifica utilizzate per creare DED_DIS.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string EncodedDis { get; }
Public ReadOnly Property EncodedDis As String
    Get
public:
property String^ EncodedDis {
    String^ get ();
}
member EncodedDis : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Proprietà DedData.EncodedFil

Proprietà DedDataEncodedFil
Codifica utilizzate per creare DED_FILE.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string EncodedFil { get; }
Public ReadOnly Property EncodedFil As String
    Get
public:
property String^ EncodedFil {
    String^ get ();
}
member EncodedFil : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Proprietà DedData.EncodedId

Proprietà DedDataEncodedId
Codifica utilizzate per creare ID.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string EncodedId { get; }
Public ReadOnly Property EncodedId As String
    Get
public:
property String^ EncodedId {
    String^ get ();
}
member EncodedId : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Proprietà DedData.EncodeInfo

Proprietà DedDataEncodeInfo
Restituisce le informazioni di codifica per questa anagrafica. Se l'anagrafica è stata codificata in una famiglia normale ricava le informazioni dal DedID aggiungendo la propria revisione, se invece è stata codificata in una famiglia FreeCode o FreeFile cerca di ricavarle dal Ded_File o dal DedId. Se è sia FreeCode che FreeFile restituisce le informazioni con la famiglia e l'anagrafica soltanto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEncodeInfo EncodeInfo { get; }
Public ReadOnly Property EncodeInfo As DedEncodeInfo
    Get
public:
property DedEncodeInfo^ EncodeInfo {
    DedEncodeInfo^ get ();
}
member EncodeInfo : DedEncodeInfo with get

Valore della proprietà

DedEncodeInfo
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Proprietà DedData.Erased

Proprietà DedDataErased
Ritorna true se l'anagrafica è eliminata

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Erased { get; }
Public ReadOnly Property Erased As Boolean
    Get
public:
property bool Erased {
    bool get ();
}
member Erased : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Proprietà DedData.FreeCode

Proprietà DedDataFreeCode
Indica se è una anagrafica FreeCode

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool FreeCode { get; }
Public ReadOnly Property FreeCode As Boolean
    Get
public:
property bool FreeCode {
    bool get ();
}
member FreeCode : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Proprietà DedData.FreeFile

Proprietà DedDataFreeFile
Indica se è una anagrafica FreeFile

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool FreeFile { get; }
Public ReadOnly Property FreeFile As Boolean
    Get
public:
property bool FreeFile {
    bool get ();
}
member FreeFile : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Proprietà DedData.FreeFileAsDedId

Proprietà DedDataFreeFileAsDedId
Restituisce/Imposta se il file debba essere compilato come l'id.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool FreeFileAsDedId { get; }
Public ReadOnly Property FreeFileAsDedId As Boolean
    Get
public:
property bool FreeFileAsDedId {
    bool get ();
}
member FreeFileAsDedId : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Proprietà DedData.FreeFileSameFileRev

Proprietà DedDataFreeFileSameFileRev
Restituisce/Imposta se il file debba rimanere uguale anche nelle revisioni.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool FreeFileSameFileRev { get; }
Public ReadOnly Property FreeFileSameFileRev As Boolean
    Get
public:
property bool FreeFileSameFileRev {
    bool get ();
}
member FreeFileSameFileRev : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Proprietà DedData.FreeFileType

Proprietà DedDataFreeFileType
Indica il tipo di FreeFile dell'anagrafica

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeFreeFileEnum FreeFileType { get; }
Public ReadOnly Property FreeFileType As DedTypeFreeFileEnum
    Get
public:
property DedTypeFreeFileEnum FreeFileType {
    DedTypeFreeFileEnum get ();
}
member FreeFileType : DedTypeFreeFileEnum with get

Valore della proprietà

DedTypeFreeFileEnum
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Proprietà DedData.HasInfoUser

Proprietà DedDataHasInfoUser
Resttuisce se l'anagrafica presenta l'infouser

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasInfoUser { get; }
Public ReadOnly Property HasInfoUser As Boolean
    Get
public:
property bool HasInfoUser {
    bool get ();
}
member HasInfoUser : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Proprietà DedData.IsLastRev

Proprietà DedDataIsLastRev
Restituisce se questa anagrafica sia o meno l'ultima. Controlla di essere l'ultima in assoluto senza considerare le revisioni rilasciate.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsLastRev { get; }
Public ReadOnly Property IsLastRev As Boolean
    Get
public:
property bool IsLastRev {
    bool get ();
}
member IsLastRev : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Proprietà DedData.IsLocked

Proprietà DedDataIsLocked
Restituisce se il record sia bloccato (dall'utente corrente o da un altro). Non legge dal Database, controlla solo se è compilato il campo DEDLOCK.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsLocked { get; }
Public ReadOnly Property IsLocked As Boolean
    Get
public:
virtual property bool IsLocked {
    bool get () sealed;
}
abstract IsLocked : bool with get
override IsLocked : bool with get

Valore della proprietà

Boolean

Implementa

IDedDataIsLocked
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Proprietà DedData.IsLockedByMe

Proprietà DedDataIsLockedByMe
Restituisce se il record sia bloccato dall'utente corrente. Non legge dal Database, controlla solo se è il campo DEDLOCK è compilato con il nome utente corrente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsLockedByMe { get; }
Public ReadOnly Property IsLockedByMe As Boolean
    Get
public:
property bool IsLockedByMe {
    bool get ();
}
member IsLockedByMe : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Proprietà DedData.IsLockedByOther

Proprietà DedDataIsLockedByOther
Restituisce se il record sia bloccato da un utente differente dall'utente corrente. Non legge dal Database, controlla solo se è il campo DEDLOCK è compilato e se lo è in modo diverso dall'utente corrente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsLockedByOther { get; }
Public ReadOnly Property IsLockedByOther As Boolean
    Get
public:
property bool IsLockedByOther {
    bool get ();
}
member IsLockedByOther : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Proprietà DedData.IsRevNewType

Proprietà DedDataIsRevNewType
Restituisce true se questa famiglia non ha il tassello della revisione nel nome file oppure se è FreeFile. Negli altri casi restituisce false.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsRevNewType { get; }
Public ReadOnly Property IsRevNewType As Boolean
    Get
public:
property bool IsRevNewType {
    bool get ();
}
member IsRevNewType : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Proprietà DedData.IsRevZero

Proprietà DedDataIsRevZero
Restituisce se questa anagrafica sia o meno la revisione Zero. Controlla di essere la prima anagrafica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsRevZero { get; }
Public ReadOnly Property IsRevZero As Boolean
    Get
public:
property bool IsRevZero {
    bool get ();
}
member IsRevZero : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Proprietà DedData.IsSparePart

Proprietà DedDataIsSparePart
Indica se l'anagrafica è in realtà un pezzo di ricambio o meno.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsSparePart { get; }
Public ReadOnly Property IsSparePart As Boolean
    Get
public:
property bool IsSparePart {
    bool get ();
}
member IsSparePart : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Proprietà DedData.IsValid

Proprietà DedDataIsValid
Restituisce se i valori presenti validano gli attributi della famiglia di appartenenza. Non cosidera attributi se siamo in fase di creazione anagrafica/revisione per validazioni specifiche usare metodo Validate.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsValid { get; }
Public ReadOnly Property IsValid As Boolean
    Get
public:
virtual property bool IsValid {
    bool get () sealed;
}
abstract IsValid : bool with get
override IsValid : bool with get

Valore della proprietà

Boolean

Implementa

IDedTypeEditableIsValid
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Proprietà DedData.Item

Proprietà DedDataItem
Restituisce il contenuto di un campo personalizzato oppure null se non esiste.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object this[
    string persfield
] { get; set; }
Public Default Property Item (
    persfield As String
) As Object
    Get
    Set
public:
property Object^ default[String^ persfield] {
    Object^ get (String^ persfield);
    void set (String^ persfield, Object^ value);
}
member Item : Object with get, set

Parametri

persfield String
Nome del campo personalizzato del quale avere il contenuto.

Valore della proprietà

Object
Eccezioni
Eccezione | Condizione
QsException | Il record risulta bloccato da un altro utente.
QsException | Questa eccezione viene lanciata se l'anagrafica è stata cancellata.
ArgumentNullException | Parametro mancante.
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Proprietà DedData.Keys

Proprietà DedDataKeys
Restituisce la lista delle chiavi presenti nell'anagrafica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string[] Keys { get; }
Public ReadOnly Property Keys As String()
    Get
public:
property array<String^>^ Keys {
    array<String^>^ get ();
}
member Keys : string[] with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Proprietà DedData.LockVer

Proprietà DedDataLockVer
Restituisce il Guid utilizzato per il blocco del record. Se l'anagrafica non è bloccata dall'utente corrente viene restituito Guid.Empty.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Guid LockVer { get; }
Public ReadOnly Property LockVer As Guid
    Get
public:
property Guid LockVer {
    Guid get ();
}
member LockVer : Guid with get

Valore della proprietà

Guid
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Proprietà DedData.Root

Proprietà DedDataRoot
Restituisce la famiglia nella quale è stato archiviata questa anagrafica. Può restituire null se non appartiene ad alcuna famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeBase Root { get; }
Public ReadOnly Property Root As DedTypeBase
    Get
public:
virtual property DedTypeBase^ Root {
    DedTypeBase^ get () sealed;
}
abstract Root : DedTypeBase with get
override Root : DedTypeBase with get

Valore della proprietà

DedTypeBase

Implementa

IDedTypeEditableRoot
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Proprietà DedData.State

Proprietà DedDataState
Restituisce o imposta lo stato dell'anagrafica. Non effettua controlli sulla coerenza del dato impostato rispetto al valore precedente. Se il valore dello stato è null restituisce Lavorazione. Imposta eventualmente a dirty l'anagrafica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedState State { get; }
Public ReadOnly Property State As DedState
    Get
public:
property DedState^ State {
    DedState^ get ();
}
member State : DedState with get

Valore della proprietà

DedState
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Proprietà DedData.Translations

Proprietà DedDataTranslations
Restituisce la lista delle traduzioni abbinati a questa anagrafica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTranslationCollection Translations { get; }
Public ReadOnly Property Translations As DedTranslationCollection
    Get
public:
property DedTranslationCollection^ Translations {
    DedTranslationCollection^ get ();
}
member Translations : DedTranslationCollection with get

Valore della proprietà

DedTranslationCollection
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Proprietà DedData.UpdateRowVer

Proprietà DedDataUpdateRowVer
Restituisce se aggiornare il ROWVER dell'anagrafica

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool UpdateRowVer { get; set; }
Public Property UpdateRowVer As Boolean
    Get
    Set
public:
virtual property bool UpdateRowVer {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract UpdateRowVer : bool with get, set
override UpdateRowVer : bool with get, set

Valore della proprietà

Boolean

Implementa

IDedDataUpdateRowVer
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Proprietà DedData.Values

Proprietà DedDataValues
Restituisce la lista dei valori presenti nell'anagrafica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object[] Values { get; }
Public ReadOnly Property Values As Object()
    Get
public:
property array<Object^>^ Values {
    array<Object^>^ get ();
}
member Values : Object[] with get

Valore della proprietà

Object
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Metodi di DedData

Il tipo DedData espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AddDoc(DedDoc, DedDocContextEnum) | Associa un documento esistente e lo restituisce con il contesto aggiornato.
Metodo pubblico | AddDoc(String, DedDocContextEnum) | Se il documento esiste già lo inizializza altrimenti lo crea; in tutti i casi lo associa e lo restituisce con il contesto aggiornato.
Metodo pubblico | AddDoc(DedDoc, DedDocContextEnum, DedData) | Associa un documento esistente e lo restituisce con il contesto aggiornato.
Metodo pubblico | AddDoc(DedDoc, DedDocContextEnum, DedData, ConfigDescriptor) | Associa un documento esistente e lo restituisce con il contesto aggiornato.
Metodo pubblico | AddDoc(String, DedDocContextEnum, Guid, String) | Se il documento esiste già lo inizializza altrimenti lo crea; in tutti i casi lo associa e lo restituisce con il contesto aggiornato.
Metodo pubblico | AddDocs | Associa una lista di documenti ad una anagrafica impostando un particolare contesto. Se i documenti non esistono vengono prima creati. Restituisce sempre una lista inizializzata.
Metodo pubblico | AddToDataEncode | Aggiunge questa anagrafica dalla tabella DED_DATA_ENCODE.
Metodo pubblico | AddToErased | Aggiunge l'anagrafica alla tabella degli eliminati
 | AsHashString | Metodo statico che ritorno id e rev ricevuti dall'esterno sottoforma di hashstring compatibile per confronto
Metodo pubblico | CanLock | Indica se un anagrafica può essere bloccata.
Metodo pubblico | Delete | Elimina l'anagrafica dalla tabella DED_DATA. Non la elimina dalla tabella di collegamento con i documenti.
Metodo pubblico | Equals | Ridefinizione di uguaglianza. (Sovrascrive ObjectEquals(Object))
Metodo pubblico | FormatDedRev | Funzione per formattare la revisione.
Metodo pubblico | GetAllAttachDocuments | Restituisce la lista dei documenti allegati a questa anagrafica. Restituisce sempre una lista inizializzata.
Metodo pubblico | GetAllPrimaryDocuments | Restituisce la lista dei documenti collegati a questa anagrafica come Modello, Rappresentazione o Pubblicazione. Restituisce sempre una lista inizializzata.
Metodo pubblico | GetAllPrimaryNotLinkedDocuments | Restituisce la lista dei documenti collegati a questa anagrafica come Modello, Rappresentazione o Pubblicazione. Restituisce sempre una lista inizializzata.
Metodo pubblico | GetAllSparePartsDocuments | Restituisce la lista dei documenti allegati a questa anagrafica. Restituisce sempre una lista inizializzata.
Metodo pubblico | GetAlternativeAttrValue | Restituisce il valore dell'attributo che rappresenta il codice alternativo
Metodo pubblico | GetAttributes | Restituisce la lista degli attributi di anagrafica visti dalla famiglia alla quale appartiene questo oggetto. Restituisce sempre una lista inizializata anche se l'anagrafica non appartiene ad alcuna famiglia: In questo caso restituisce gli attributi della root.
Metodo pubblico | GetAttrsFromCategory(DedCateg) | Ritorna la lista di attributi visibili dalla famiglia che appartengono alla categoria passata.
Metodo pubblico | GetAttrsFromCategory(String) | Ritorna la lista di attributi visibili dalla famiglia che appartengono alla categoria passata.
Metodo pubblico | GetCommCount | Restituisce il numero di commesse collegate a questa anagrafica
Metodo pubblico | GetComms | Restituisce la lista di commesse collegate a questa anagrafica
Metodo pubblico | GetDefaultAttachDir | Restituisce il nome completo della cartella principale nella quale inserire gli allegati di questa anagrafica. Restituisce null se l'anagrafica non appartiene ad alcuna famiglia di archiviazione.
Metodo pubblico | GetDefaultPrimaryFullFileName | Restituisce il nome completo, senza estensione, del file che dovrebbe avere un file primario appartenente a questa anagrafica. Restituisce null se l'anagrafica non appartiene ad alcuna famiglia di archiviazione.
Metodo pubblico | GetDescription | (Sovrascrive DedBaseDbItemGetDescription)
Metodo pubblico | GetDocuments | Restituisce tutti i documenti collegati all'anagrafica. Restituisce una lista inizializzata ma vuota se non ne esistono.
Metodo pubblico | GetDocuments(DedDocContextEnum) | Restituisce tutti i file collegati all'anagrafica aventi un determinato contesto. Restituisce una lista inizializzata ma vuota se non ne esistono.
Metodo pubblico | GetDocuments(FuncDedDocContext, Boolean) | Restituisce tutti i file collegati all'anagrafica che soddisfano il criterio del delegate passato Restituisce una lista inizializzata ma vuota se non ne esistono.
Metodo pubblico | GetDocuments(ListString) | Restituisce tutti i file collegati all'anagrafica aventi una determinata estensione. Restituisce una lista inizializzata ma vuota se non ne esistono.
Metodo pubblico | GetDocuments(DedDocContextEnum, String) | Restituisce tutti i file collegati all'anagrafica aventi un determinato contesto e una determinata estensione. Restituisce una lista inizializzata ma vuota se non ne esistono.
Metodo pubblico | GetDocumentsCount | Restituisce il numero dei file collegati all'anagrafica.
Metodo pubblico | GetEcoList | Restituisce la lista di Eco collegati a questa anagrafica.
Metodo pubblico | GetHashCode | Restituisce l'HashCode di questo oggetto. (Sovrascrive ObjectGetHashCode)
Metodo pubblico | GetLastGoodHistoryState | Restituisce l'ultimo stato buono (lavorazione/rilasciato/rilasciato in adattamento) nella tabella DED_STATE_HISTORY in cui si trovava l'anagrafica
Metodo pubblico | GetMaxTokenNum | Restituisce il massimo numero di caratteri usati per il TokenTypeEnum passato. Verifica nella maschera di codifica Cod_Id, Cod_Fil e Cod_Dis in modo da prendere il numero massimo di caratteri utilizzati.
Metodo pubblico | GetName | (Sovrascrive DedBaseDbItemGetName)
Metodo pubblico | GetObjectType | (Sovrascrive DedBaseDbItemGetObjectType)
Metodo pubblico | GetProgr | Restituisce il progressivo dell'anagrafica. Letto da DED_DATA_ENCODE se compilato altrimenti lo ricalcola.
Metodo pubblico | GetProgrTokenNum | Restituisce il numero di caratteri da utilizzare per creare la stringa del progressivo per questa famiglia. Li calcola cercando il tassello del progressivo nella codifica del Cod_Id. Se non è presente restituisce 0.
Metodo pubblico | GetRevDedDisTokenNum | Restituisce il numero di caratteri dedicati alla revisione, presenti nel DED_DIS.
Metodo pubblico | GetRevFileTokenNum | Restituisce il numero di caratteri dedicati alla revisione, presenti nel nome del file COD_FIL. Se si tratta di una famiglia NGR (nuova gestione delle revisioni), restituisce 0, altrimenti il numero di caratteri presenti.
Metodo pubblico | GetStrictPrimaryDocuments | Restituisce la lista dei documenti collegati a questa anagrafica come Modello, Rappresentazione o Pubblicazione. Restituisce sempre una lista inizializzata.
Metodo pubblico | GetValue(DedDataStandardDataFields) | Restituisce il contenuto di uno dei campi standard oppure null se non è presente.
Metodo pubblico | GetValue(String) | Restituisce il contenuto di un campo personalizzato oppure null se non esiste.
Metodo pubblico | GetVar | Restituisce il tassello di variante automatico dell'anagrafica.
Metodo pubblico | Lock | Esegue il blocco dell'anagrafica impostando il campo DEDLOCK con il nome dell'utente corrente. Utilizza il campo DEDROWVER attuale per effettuare il blocco in modo da non riuscire in caso di anagrafica già modificata. Questo metodo non rende dirty l'anagrafica ma bisogna poi sbloccarla attraverso UnLock() oppure con Update().
Metodo pubblico | MakeBackupFilePath | Restitusice il percorso completo del file come revisione nel caso di famiglia con NGR. Il percorso viene calcolato in base all'anagrafica mentre il nome file viene preso dal fileName passato e viene aggiunta la revisione di questo record.
Metodo pubblico | MakeClonePart | Restituisce un oggetto di tipo DedDataPart il quale implementa IDedData costruito tramite il dizionario interno di questa anagrafica. Da utilizzare per passare i dati dell'anagrafica, per esempio alla finestra di codifica, ed evitare che venga modificata l'anagrafica originale.
Metodo pubblico | MakeDefaultBackupPath | Restituisce la cartella nella quale un file revisionato, in presenza di famiglia NGR, dovrebbe essere copiato, se associato a questa anagrafica come primario.
Metodo pubblico | MakeDefaultFullFileName(DedDocContextEnum, String, String) | Costruisce e restituisce l'oggetto descrittivo DedRootInfo del percorso di default che dovrebbe avere un file associato a questa anagrafica con un particolare contesto. Se la richiesta riguarda un file primario viene restituito il nome completo prendendo l'estensione dal nome file passato ma con il giusto nome (calcolato dalla codifica della famiglia). Se si richiede di un allegato viene restitituito il nome del file passato così com'é, concatenato della cartella root di archiviazione allegati. Se la richiesta è di una rappresentazione viene fornito un nome composto con nome file primario più nome random del quale però si deve verificare la non esistenza prima dell'utilizzo.
Metodo pubblico | MakeDefaultFullFileName(DedDocContextEnum, String, String, Boolean) |
Metodo pubblico | MakeDefaultPrimaryFileName | Restituisce il nome che un file primario dovrebbe avere se associato a questa anagrafica. Se l'anagrafica presenta compilato il DED_FILE restituisce il suo valore, altrimenti lo calcola dalla famiglia di appartenenza e dai dati presenti.
Metodo pubblico | MakeDefaultPrimaryPath | Restituisce il percorso che un file primario dovrebbe avere se associato a questa anagrafica.
Metodo pubblico | RebuildPrimaryFullFileNameFromBackup(DedDoc) | Restituisce il nome completo del file originale, partendo dal nome di backup (usato nella NGR).
Metodo pubblico | RebuildPrimaryFullFileNameFromBackup(String) | Restituisce il nome completo del file originale, partendo dal nome di backup (usato nella NGR).
Metodo pubblico | Refresh | Aggiorna questo oggetto rileggendo le informazioni presenti nel Database. Effettua l'aggiornamento anche se l'anagrafica è dirty (la imposta a false dopo l'aggiornamento). Aggiorna tutti i campi quindi anche il DEDROWVERSION.
Metodo pubblico | ReloadInfoUser | Ricalcola modificando solo il tassello utente e la revisione tutto il resto rimane inalterato (usato per crea variante)
Metodo pubblico | ReloadRev | Ricalcola modificando solo il tassello utente tutto il resto rimane inalterato (usato per crea revisione)
Metodo pubblico | RemoveDoc | Scollega dall'anagrafica uno specifico documento, eliminando dal DB il legame.
Metodo pubblico | RemoveDocs | Scollega dall'anagrafica tutti i documenti, eliminandone dal DB il legame.
Metodo pubblico | RemoveDocs(ListGuid) | Scollega dall'anagrafica una lista di documenti, eliminandone dal DB il legame.
Metodo pubblico | RemoveFromErased | Rimuove l'anagrafica alla tabella degli eliminati
Metodo pubblico | SetState | Permette di cambiare lo stato di un'anagrafica.
Metodo pubblico | SetValue(DedDataStandardDataFields, Object) |
Metodo pubblico | SetValue(String, Object) | Imposta un campo personalizzato con un nuovo valore. Se il campo non esiste lo crea. La chiamata a questo metodo può causare la messa a Dirty dell'anagrafica, quando il campo da impostare è già presente nel dizionario interno ed il valore da impostare è differente da quello precedente oppure se è da creare. Oltre a porre l'anagrafica come Dirty viene anche tentato il lock dell'anagrafica fino alla successiva chiamata del metodo Update() che imposta l'anagrafica come sbloccata e non Dirty oppure UnLock() che annulla le modifiche.
Metodo pubblico | ToString | Restituisce una rappresentazione stringa di questo oggetto. (Sovrascrive ObjectToString)
Metodo pubblico | UnLock | Sblocca l'anagrafica solo se questa era bloccata. Opzionalmente, se questa è dirty, la aggiorna. Questo metodo la sblocca reimpostando il DEDROWVER alla versione precedente il bloccaggio ed effettua un Refresh() per riallineare i valori dell'anagrafica con il Database se l'anagrafica era Dirty.
Metodo pubblico | Update | Aggiorna l'anagrafica nel Database solo se questa è Dirty e quindi, in contemporanea, la sblocca. Poi imposta il dirty a false. Vengono aggiornati solo gli attributi che sono riconosciuti come d'anagrafica e non quelli di documento e di distinta. Oltre a questi vengono aggiornati anche i campi non presenti in DED_ATTR come : DEDROWVER, DEDMODUSER, DEDMODDATE e DEDLOCK, ecc.
Metodo pubblico | UpdateState | Scrive il cambio di stato nell'anagrafica e nella tabella DED_STATE_HISTORY.
Metodo pubblico | Validate | Restituisce se i valori presenti validano gli attributi della famiglia di appartenenza.
Torna su
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Metodo DedData.AddDoc

Metodo DedDataAddDoc
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AddDoc(DedDoc, DedDocContextEnum) | Associa un documento esistente e lo restituisce con il contesto aggiornato.
Metodo pubblico | AddDoc(String, DedDocContextEnum) | Se il documento esiste già lo inizializza altrimenti lo crea; in tutti i casi lo associa e lo restituisce con il contesto aggiornato.
Metodo pubblico | AddDoc(DedDoc, DedDocContextEnum, DedData) | Associa un documento esistente e lo restituisce con il contesto aggiornato.
Metodo pubblico | AddDoc(DedDoc, DedDocContextEnum, DedData, ConfigDescriptor) | Associa un documento esistente e lo restituisce con il contesto aggiornato.
Metodo pubblico | AddDoc(String, DedDocContextEnum, Guid, String) | Se il documento esiste già lo inizializza altrimenti lo crea; in tutti i casi lo associa e lo restituisce con il contesto aggiornato.
Torna su
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Metodo DedData.AddDoc(DedDoc, DedDocContextEnum)

Metodo DedDataAddDoc(DedDoc, DedDocContextEnum)
Associa un documento esistente e lo restituisce con il contesto aggiornato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDoc AddDoc(
    DedDoc doc,
    DedDocContextEnum context
)
Public Function AddDoc (
    doc As DedDoc,
    context As DedDocContextEnum
) As DedDoc
public:
DedDoc^ AddDoc(
    DedDoc^ doc,
    DedDocContextEnum context
)
member AddDoc :
        doc : DedDoc *
        context : DedDocContextEnum -> DedDoc

Parametri

doc DedDoc
Documento da associare.
context DedDocContextEnum
Contesto col quale collegare il documento.

Valore di ritorno

DedDoc
Eccezioni
Eccezione | Condizione
QsException | Errore verificatosi durante la verifica dell'esistenza anagrafica oppure durante la creazione del contesto del documento.
QsException | Viene sollevata in caso di errore nell'istruzione di inserimento dati.
QsException | Viene sollevata nel caso in cui esista già un collegamento tra il documento e questa anagrafica.
ArgumentNullException | Parametro mancante.
Vedi anche

Documentazione

Classe DedData
Overload di AddDoc
Namespace DedNet.Core


Metodo DedData.AddDoc(String, DedDocContextEnum)

Metodo DedDataAddDoc(String, DedDocContextEnum)
Se il documento esiste già lo inizializza altrimenti lo crea; in tutti i casi lo associa e lo restituisce con il contesto aggiornato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDoc AddDoc(
    string fullName,
    DedDocContextEnum context
)
Public Function AddDoc (
    fullName As String,
    context As DedDocContextEnum
) As DedDoc
public:
DedDoc^ AddDoc(
    String^ fullName,
    DedDocContextEnum context
)
member AddDoc :
        fullName : string *
        context : DedDocContextEnum -> DedDoc

Parametri

fullName String
Nome completo del documento da collegare.
context DedDocContextEnum
Contesto col quale collegare il documento.

Valore di ritorno

DedDoc
Eccezioni
Eccezione | Condizione
QsException | Errore verificatosi durante la verifica dell'esistenza anagrafica oppure durante la creazione del contesto del documento.
QsException | Viene sollevata in caso di errore nell'istruzione di inserimento dati.
QsException | Viene sollevata nel caso in cui esista già un collegamento tra il documento e questa anagrafica.
ArgumentNullException | Parametro mancante.
Vedi anche

Documentazione

Classe DedData
Overload di AddDoc
Namespace DedNet.Core


Metodo DedData.AddDoc(DedDoc, DedDocContextEnum, DedData)

Metodo DedDataAddDoc(DedDoc, DedDocContextEnum, DedData)
Associa un documento esistente e lo restituisce con il contesto aggiornato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDoc AddDoc(
    DedDoc doc,
    DedDocContextEnum context,
    DedData linkingData
)
Public Function AddDoc (
    doc As DedDoc,
    context As DedDocContextEnum,
    linkingData As DedData
) As DedDoc
public:
DedDoc^ AddDoc(
    DedDoc^ doc,
    DedDocContextEnum context,
    DedData^ linkingData
)
member AddDoc :
        doc : DedDoc *
        context : DedDocContextEnum *
        linkingData : DedData -> DedDoc

Parametri

doc DedDoc
Documento da associare.
context DedDocContextEnum
Contesto col quale collegare il documento.
linkingData DedData
Anagrafica dalla quale viene linkato il documento.

Valore di ritorno

DedDoc
Eccezioni
Eccezione | Condizione
QsException | Errore verificatosi durante la verifica dell'esistenza anagrafica oppure durante la creazione del contesto del documento.
QsException | Viene sollevata in caso di errore nell'istruzione di inserimento dati.
QsException | Viene sollevata nel caso in cui esista già un collegamento tra il documento e questa anagrafica.
ArgumentNullException | Parametro mancante.
Vedi anche

Documentazione

Classe DedData
Overload di AddDoc
Namespace DedNet.Core


Metodo DedData.AddDoc(DedDoc, DedDocContextEnum, DedData, ConfigDescriptor)

Metodo DedDataAddDoc(DedDoc, DedDocContextEnum, DedData, ConfigDescriptor)
Associa un documento esistente e lo restituisce con il contesto aggiornato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDoc AddDoc(
    DedDoc doc,
    DedDocContextEnum context,
    DedData linkingData,
    ConfigDescriptor cfgDescr
)
Public Function AddDoc (
    doc As DedDoc,
    context As DedDocContextEnum,
    linkingData As DedData,
    cfgDescr As ConfigDescriptor
) As DedDoc
public:
DedDoc^ AddDoc(
    DedDoc^ doc,
    DedDocContextEnum context,
    DedData^ linkingData,
    ConfigDescriptor^ cfgDescr
)
member AddDoc :
        doc : DedDoc *
        context : DedDocContextEnum *
        linkingData : DedData *
        cfgDescr : ConfigDescriptor -> DedDoc

Parametri

doc DedDoc
Documento da associare.
context DedDocContextEnum
Contesto col quale collegare il documento.
linkingData DedData
Anagrafica dalla quale viene linkato il documento.
cfgDescr ConfigDescriptor

Valore di ritorno

DedDoc
Eccezioni
Eccezione | Condizione
QsException | Errore verificatosi durante la verifica dell'esistenza anagrafica oppure durante la creazione del contesto del documento.
QsException | Viene sollevata in caso di errore nell'istruzione di inserimento dati.
QsException | Viene sollevata nel caso in cui esista già un collegamento tra il documento e questa anagrafica.
ArgumentNullException | Parametro mancante.
Vedi anche

Documentazione

Classe DedData
Overload di AddDoc
Namespace DedNet.Core


Metodo DedData.AddDoc(String, DedDocContextEnum, Guid, String)

Metodo DedDataAddDoc(String, DedDocContextEnum, Guid, String)
Se il documento esiste già lo inizializza altrimenti lo crea; in tutti i casi lo associa e lo restituisce con il contesto aggiornato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDoc AddDoc(
    string fullName,
    DedDocContextEnum context,
    Guid rowver,
    string oldFile
)
Public Function AddDoc (
    fullName As String,
    context As DedDocContextEnum,
    rowver As Guid,
    oldFile As String
) As DedDoc
public:
DedDoc^ AddDoc(
    String^ fullName,
    DedDocContextEnum context,
    Guid rowver,
    String^ oldFile
)
member AddDoc :
        fullName : string *
        context : DedDocContextEnum *
        rowver : Guid *
        oldFile : string -> DedDoc

Parametri

fullName String
Nome completo del documento da collegare.
context DedDocContextEnum
Contesto col quale collegare il documento.
rowver Guid
Versione del documento da utilizzare per la creazione del record.
oldFile String
Nome completo del file prima di essere creato.

Valore di ritorno

DedDoc
Eccezioni
Eccezione | Condizione
QsException | Errore verificatosi durante la verifica dell'esistenza anagrafica oppure durante la creazione del contesto del documento.
QsException | Viene sollevata in caso di errore nell'istruzione di inserimento dati.
QsException | Viene sollevata nel caso in cui esista già un collegamento tra il documento e questa anagrafica.
ArgumentNullException | Parametro mancante.
Vedi anche

Documentazione

Classe DedData
Overload di AddDoc
Namespace DedNet.Core


Metodo DedData.AddDocs

Metodo DedDataAddDocs
Associa una lista di documenti ad una anagrafica impostando un particolare contesto. Se i documenti non esistono vengono prima creati. Restituisce sempre una lista inizializzata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocList AddDocs(
    string[] filelist,
    DedDocContextEnum context
)
Public Function AddDocs (
    filelist As String(),
    context As DedDocContextEnum
) As DedDocList
public:
DedDocList^ AddDocs(
    array<String^>^ filelist,
    DedDocContextEnum context
)
member AddDocs :
        filelist : string[] *
        context : DedDocContextEnum -> DedDocList

Parametri

filelist String
Lista dei file da associare.
context DedDocContextEnum
Contesto col quale collegare i documenti.

Valore di ritorno

DedDocList
Eccezioni
Eccezione | Condizione
[!:DedRecordExceptionList] | Viene sollevata in caso di uno o più errori di inserimento dati.
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Metodo DedData.AddToDataEncode

Metodo DedDataAddToDataEncode
Aggiunge questa anagrafica dalla tabella DED_DATA_ENCODE.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddToDataEncode(
    DedData startingData,
    bool isAddOperation = true
)
Public Sub AddToDataEncode (
    startingData As DedData,
    Optional isAddOperation As Boolean = true
)
public:
void AddToDataEncode(
    DedData^ startingData,
    bool isAddOperation = true
)
member AddToDataEncode :
        startingData : DedData *
        ?isAddOperation : bool
(* Defaults:
        let _isAddOperation = defaultArg isAddOperation true
*)
-> unit

Parametri

startingData DedData
isAddOperation Boolean (Optional)
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Metodo DedData.AddToErased

Metodo DedDataAddToErased
Aggiunge l'anagrafica alla tabella degli eliminati

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AddToErased(
    DedState erasedState
)
Public Function AddToErased (
    erasedState As DedState
) As Boolean
public:
bool AddToErased(
    DedState^ erasedState
)
member AddToErased :
        erasedState : DedState -> bool

Parametri

erasedState DedState

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Metodo DedData.AsHashString

Metodo DedDataAsHashString
Metodo statico che ritorno id e rev ricevuti dall'esterno sottoforma di hashstring compatibile per confronto

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string AsHashString(
    string dedid,
    string dedrev
)
Public Shared Function AsHashString (
    dedid As String,
    dedrev As String
) As String
public:
static String^ AsHashString(
    String^ dedid,
    String^ dedrev
)
static member AsHashString :
        dedid : string *
        dedrev : string -> string

Parametri

dedid String
dedrev String

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Metodo DedData.CanLock

Metodo DedDataCanLock
Indica se un anagrafica può essere bloccata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CanLock(
    ref string msgError,
    bool ignoreState = false,
    bool ignoreDocStatus = false
)
Public Function CanLock (
    ByRef msgError As String,
    Optional ignoreState As Boolean = false,
    Optional ignoreDocStatus As Boolean = false
) As Boolean
public:
bool CanLock(
    String^% msgError,
    bool ignoreState = false,
    bool ignoreDocStatus = false
)
member CanLock :
        msgError : string byref *
        ?ignoreState : bool *
        ?ignoreDocStatus : bool
(* Defaults:
        let _ignoreState = defaultArg ignoreState false
        let _ignoreDocStatus = defaultArg ignoreDocStatus false
*)
-> bool

Parametri

msgError String
ignoreState Boolean (Optional)
Indica se non cosiderare lo stato dell'anagrafica.
ignoreDocStatus Boolean (Optional)

Valore di ritorno

Boolean
Restituisce true se può essere bloccata altrimentifalse con il messaggio di errore.
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Metodo DedData.Delete

Metodo DedDataDelete
Elimina l'anagrafica dalla tabella DED_DATA. Non la elimina dalla tabella di collegamento con i documenti.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Delete()
Public Sub Delete
public:
void Delete()
member Delete : unit -> unit
Eccezioni
Eccezione | Condizione
QsException | Solleva questa eccezione se non riesce ad eliminare i dati.
ArgumentNullException | Parametro mancante.
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Metodo DedData.Equals

Metodo DedDataEquals
Ridefinizione di uguaglianza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj Object
Oggetto da confrontare.

Valore di ritorno

Boolean
Restituisce true se l'oggetto è uguale a questo.
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Metodo DedData.FormatDedRev

Metodo DedDataFormatDedRev
Funzione per formattare la revisione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string FormatDedRev(
    string rev
)
Public Function FormatDedRev (
    rev As String
) As String
public:
String^ FormatDedRev(
    String^ rev
)
member FormatDedRev :
        rev : string -> string

Parametri

rev String
Revisione da formattare.

Valore di ritorno

String
Revisione formattata.
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Metodo DedData.GetAllAttachDocuments

Metodo DedDataGetAllAttachDocuments
Restituisce la lista dei documenti allegati a questa anagrafica. Restituisce sempre una lista inizializzata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocList GetAllAttachDocuments()
Public Function GetAllAttachDocuments As DedDocList
public:
DedDocList^ GetAllAttachDocuments()
member GetAllAttachDocuments : unit -> DedDocList

Valore di ritorno

DedDocList
Restituisce una lista dei documenti trovati.
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Metodo DedData.GetAllPrimaryDocuments

Metodo DedDataGetAllPrimaryDocuments
Restituisce la lista dei documenti collegati a questa anagrafica come Modello, Rappresentazione o Pubblicazione. Restituisce sempre una lista inizializzata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocList GetAllPrimaryDocuments()
Public Function GetAllPrimaryDocuments As DedDocList
public:
DedDocList^ GetAllPrimaryDocuments()
member GetAllPrimaryDocuments : unit -> DedDocList

Valore di ritorno

DedDocList
Restituisce una lista dei documenti trovati.
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Metodo DedData.GetAllPrimaryNotLinkedDocuments

Metodo DedDataGetAllPrimaryNotLinkedDocuments
Restituisce la lista dei documenti collegati a questa anagrafica come Modello, Rappresentazione o Pubblicazione. Restituisce sempre una lista inizializzata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocList GetAllPrimaryNotLinkedDocuments()
Public Function GetAllPrimaryNotLinkedDocuments As DedDocList
public:
DedDocList^ GetAllPrimaryNotLinkedDocuments()
member GetAllPrimaryNotLinkedDocuments : unit -> DedDocList

Valore di ritorno

DedDocList
Restituisce una lista dei documenti trovati.
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Metodo DedData.GetAllSparePartsDocuments

Metodo DedDataGetAllSparePartsDocuments
Restituisce la lista dei documenti allegati a questa anagrafica. Restituisce sempre una lista inizializzata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocList GetAllSparePartsDocuments()
Public Function GetAllSparePartsDocuments As DedDocList
public:
DedDocList^ GetAllSparePartsDocuments()
member GetAllSparePartsDocuments : unit -> DedDocList

Valore di ritorno

DedDocList
Restituisce una lista dei documenti trovati.
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Metodo DedData.GetAlternativeAttrValue

Metodo DedDataGetAlternativeAttrValue
Restituisce il valore dell'attributo che rappresenta il codice alternativo

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string GetAlternativeAttrValue()
Public Function GetAlternativeAttrValue As String
public:
String^ GetAlternativeAttrValue()
member GetAlternativeAttrValue : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Metodo DedData.GetAttributes

Metodo DedDataGetAttributes
Restituisce la lista degli attributi di anagrafica visti dalla famiglia alla quale appartiene questo oggetto. Restituisce sempre una lista inizializata anche se l'anagrafica non appartiene ad alcuna famiglia: In questo caso restituisce gli attributi della root.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList GetAttributes()
Public Function GetAttributes As DedAttrList
public:
DedAttrList^ GetAttributes()
member GetAttributes : unit -> DedAttrList

Valore di ritorno

DedAttrList
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Metodo DedData.GetAttrsFromCategory

Metodo DedDataGetAttrsFromCategory
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | GetAttrsFromCategory(DedCateg) | Ritorna la lista di attributi visibili dalla famiglia che appartengono alla categoria passata.
Metodo pubblico | GetAttrsFromCategory(String) | Ritorna la lista di attributi visibili dalla famiglia che appartengono alla categoria passata.
Torna su
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Metodo DedData.GetAttrsFromCategory(DedCateg)

Metodo DedDataGetAttrsFromCategory(DedCateg)
Ritorna la lista di attributi visibili dalla famiglia che appartengono alla categoria passata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList GetAttrsFromCategory(
    DedCateg category
)
Public Function GetAttrsFromCategory (
    category As DedCateg
) As DedAttrList
public:
DedAttrList^ GetAttrsFromCategory(
    DedCateg^ category
)
member GetAttrsFromCategory :
        category : DedCateg -> DedAttrList

Parametri

category DedCateg
Categoria.

Valore di ritorno

DedAttrList
Vedi anche

Documentazione

Classe DedData
Overload di GetAttrsFromCategory
Namespace DedNet.Core


Metodo DedData.GetAttrsFromCategory(String)

Metodo DedDataGetAttrsFromCategory(String)
Ritorna la lista di attributi visibili dalla famiglia che appartengono alla categoria passata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList GetAttrsFromCategory(
    string category
)
Public Function GetAttrsFromCategory (
    category As String
) As DedAttrList
public:
DedAttrList^ GetAttrsFromCategory(
    String^ category
)
member GetAttrsFromCategory :
        category : string -> DedAttrList

Parametri

category String
Nome della categoria.

Valore di ritorno

DedAttrList
Vedi anche

Documentazione

Classe DedData
Overload di GetAttrsFromCategory
Namespace DedNet.Core


Metodo DedData.GetCommCount

Metodo DedDataGetCommCount
Restituisce il numero di commesse collegate a questa anagrafica

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int GetCommCount()
Public Function GetCommCount As Integer
public:
int GetCommCount()
member GetCommCount : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Metodo DedData.GetComms

Metodo DedDataGetComms
Restituisce la lista di commesse collegate a questa anagrafica

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommList GetComms()
Public Function GetComms As DedCommList
public:
DedCommList^ GetComms()
member GetComms : unit -> DedCommList

Valore di ritorno

DedCommList
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Metodo DedData.GetDefaultAttachDir

Metodo DedDataGetDefaultAttachDir
Restituisce il nome completo della cartella principale nella quale inserire gli allegati di questa anagrafica. Restituisce null se l'anagrafica non appartiene ad alcuna famiglia di archiviazione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string GetDefaultAttachDir()
Public Function GetDefaultAttachDir As String
public:
String^ GetDefaultAttachDir()
member GetDefaultAttachDir : unit -> string

Valore di ritorno

String
Restituisce il nome completo della cartella degli allegati.
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Metodo DedData.GetDefaultPrimaryFullFileName

Metodo DedDataGetDefaultPrimaryFullFileName
Restituisce il nome completo, senza estensione, del file che dovrebbe avere un file primario appartenente a questa anagrafica. Restituisce null se l'anagrafica non appartiene ad alcuna famiglia di archiviazione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string GetDefaultPrimaryFullFileName()
Public Function GetDefaultPrimaryFullFileName As String
public:
String^ GetDefaultPrimaryFullFileName()
member GetDefaultPrimaryFullFileName : unit -> string

Valore di ritorno

String
Restituisce il nome completo senza estensione del file primario di questa anagrafica.
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Metodo DedData.GetDescription

Metodo DedDataGetDescription

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string GetDescription()
Public Overrides Function GetDescription As String
public:
virtual String^ GetDescription() override
abstract GetDescription : unit -> string
override GetDescription : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Metodo DedData.GetDocuments

Metodo DedDataGetDocuments
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | GetDocuments | Restituisce tutti i documenti collegati all'anagrafica. Restituisce una lista inizializzata ma vuota se non ne esistono.
Metodo pubblico | GetDocuments(DedDocContextEnum) | Restituisce tutti i file collegati all'anagrafica aventi un determinato contesto. Restituisce una lista inizializzata ma vuota se non ne esistono.
Metodo pubblico | GetDocuments(FuncDedDocContext, Boolean) | Restituisce tutti i file collegati all'anagrafica che soddisfano il criterio del delegate passato Restituisce una lista inizializzata ma vuota se non ne esistono.
Metodo pubblico | GetDocuments(ListString) | Restituisce tutti i file collegati all'anagrafica aventi una determinata estensione. Restituisce una lista inizializzata ma vuota se non ne esistono.
Metodo pubblico | GetDocuments(DedDocContextEnum, String) | Restituisce tutti i file collegati all'anagrafica aventi un determinato contesto e una determinata estensione. Restituisce una lista inizializzata ma vuota se non ne esistono.
Torna su
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Metodo DedData.GetDocuments

Metodo DedDataGetDocuments
Restituisce tutti i documenti collegati all'anagrafica. Restituisce una lista inizializzata ma vuota se non ne esistono.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocList GetDocuments()
Public Function GetDocuments As DedDocList
public:
DedDocList^ GetDocuments()
member GetDocuments : unit -> DedDocList

Valore di ritorno

DedDocList
Eccezioni
Eccezione | Condizione
QsException | Errore nella lettura del Database.
ArgumentNullException | Parametro mancante.
Vedi anche

Documentazione

Classe DedData
Overload di GetDocuments
Namespace DedNet.Core


Metodo DedData.GetDocuments(DedDocContextEnum)

Metodo DedDataGetDocuments(DedDocContextEnum)
Restituisce tutti i file collegati all'anagrafica aventi un determinato contesto. Restituisce una lista inizializzata ma vuota se non ne esistono.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocList GetDocuments(
    DedDocContextEnum context
)
Public Function GetDocuments (
    context As DedDocContextEnum
) As DedDocList
public:
DedDocList^ GetDocuments(
    DedDocContextEnum context
)
member GetDocuments :
        context : DedDocContextEnum -> DedDocList

Parametri

context DedDocContextEnum
Contesto dei file che si desidera avere restituiti.

Valore di ritorno

DedDocList
Eccezioni
Eccezione | Condizione
QsException | Errore nella lettura del Database.
ArgumentNullException | Parametro mancante.
Vedi anche

Documentazione

Classe DedData
Overload di GetDocuments
Namespace DedNet.Core


Metodo DedData.GetDocuments(Func<DedDocContext, Boolean>)

Metodo DedDataGetDocuments(FuncDedDocContext, Boolean)
Restituisce tutti i file collegati all'anagrafica che soddisfano il criterio del delegate passato Restituisce una lista inizializzata ma vuota se non ne esistono.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocList GetDocuments(
    Func<DedDocContext, bool> contextChecker
)
Public Function GetDocuments (
    contextChecker As Func(Of DedDocContext, Boolean)
) As DedDocList
public:
DedDocList^ GetDocuments(
    Func<DedDocContext^, bool>^ contextChecker
)
member GetDocuments :
        contextChecker : Func<DedDocContext, bool> -> DedDocList

Parametri

contextChecker Func DedDocContext, Boolean
Controllore dei contesti

Valore di ritorno

DedDocList
Eccezioni
Eccezione | Condizione
QsException | Errore nella lettura del Database.
ArgumentNullException | Parametro mancante.
Vedi anche

Documentazione

Classe DedData
Overload di GetDocuments
Namespace DedNet.Core


Metodo DedData.GetDocuments(List<String>)

Metodo DedDataGetDocuments(ListString)
Restituisce tutti i file collegati all'anagrafica aventi una determinata estensione. Restituisce una lista inizializzata ma vuota se non ne esistono.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocList GetDocuments(
    List<string> listExt
)
Public Function GetDocuments (
    listExt As List(Of String)
) As DedDocList
public:
DedDocList^ GetDocuments(
    List<String^>^ listExt
)
member GetDocuments :
        listExt : List<string> -> DedDocList

Parametri

listExt List String
Estensione del file senza il carattere '.'

Valore di ritorno

DedDocList
Eccezioni
Eccezione | Condizione
QsException | Errore nella lettura del Database.
ArgumentNullException | Parametro mancante.
Vedi anche

Documentazione

Classe DedData
Overload di GetDocuments
Namespace DedNet.Core


Metodo DedData.GetDocuments(DedDocContextEnum, String)

Metodo DedDataGetDocuments(DedDocContextEnum, String)
Restituisce tutti i file collegati all'anagrafica aventi un determinato contesto e una determinata estensione. Restituisce una lista inizializzata ma vuota se non ne esistono.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocList GetDocuments(
    DedDocContextEnum context,
    string ext
)
Public Function GetDocuments (
    context As DedDocContextEnum,
    ext As String
) As DedDocList
public:
DedDocList^ GetDocuments(
    DedDocContextEnum context,
    String^ ext
)
member GetDocuments :
        context : DedDocContextEnum *
        ext : string -> DedDocList

Parametri

context DedDocContextEnum
Contesto dei file che si desidera avere restituiti.
ext String
Estensione del file senza .

Valore di ritorno

DedDocList
Eccezioni
Eccezione | Condizione
QsException | Errore nella lettura del Database.
ArgumentNullException | Parametro mancante.
Vedi anche

Documentazione

Classe DedData
Overload di GetDocuments
Namespace DedNet.Core


Metodo DedData.GetDocumentsCount

Metodo DedDataGetDocumentsCount
Restituisce il numero dei file collegati all'anagrafica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int GetDocumentsCount()
Public Function GetDocumentsCount As Integer
public:
int GetDocumentsCount()
member GetDocumentsCount : unit -> int

Valore di ritorno

Int32
Eccezioni
Eccezione | Condizione
ArgumentNullException | Parametro mancante.
QsException | Errore nella lettura del Database.
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Metodo DedData.GetEcoList

Metodo DedDataGetEcoList
Restituisce la lista di Eco collegati a questa anagrafica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEcoList GetEcoList()
Public Function GetEcoList As DedEcoList
public:
DedEcoList^ GetEcoList()
member GetEcoList : unit -> DedEcoList

Valore di ritorno

DedEcoList
Lista di Eco collegati all'anagrafica.
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Metodo DedData.GetHashCode

Metodo DedDataGetHashCode
Restituisce l'HashCode di questo oggetto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Metodo DedData.GetLastGoodHistoryState

Metodo DedDataGetLastGoodHistoryState
Restituisce l'ultimo stato buono (lavorazione/rilasciato/rilasciato in adattamento) nella tabella DED_STATE_HISTORY in cui si trovava l'anagrafica

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedState GetLastGoodHistoryState()
Public Function GetLastGoodHistoryState As DedState
public:
DedState^ GetLastGoodHistoryState()
member GetLastGoodHistoryState : unit -> DedState

Valore di ritorno

DedState
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Metodo DedData.GetMaxTokenNum

Metodo DedDataGetMaxTokenNum
Restituisce il massimo numero di caratteri usati per il TokenTypeEnum passato. Verifica nella maschera di codifica Cod_Id, Cod_Fil e Cod_Dis in modo da prendere il numero massimo di caratteri utilizzati.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int GetMaxTokenNum(
    TokenTypeEnum type
)
Public Function GetMaxTokenNum (
    type As TokenTypeEnum
) As Integer
public:
int GetMaxTokenNum(
    TokenTypeEnum type
)
member GetMaxTokenNum :
        type : TokenTypeEnum -> int

Parametri

type TokenTypeEnum
Token di interesse.

Valore di ritorno

Int32
Restiruisce il numero di caratteri.
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Metodo DedData.GetName

Metodo DedDataGetName

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string GetName()
Public Overrides Function GetName As String
public:
virtual String^ GetName() override
abstract GetName : unit -> string
override GetName : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Metodo DedData.GetObjectType

Metodo DedDataGetObjectType

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override DedDbItemType GetObjectType()
Public Overrides Function GetObjectType As DedDbItemType
public:
virtual DedDbItemType GetObjectType() override
abstract GetObjectType : unit -> DedDbItemType
override GetObjectType : unit -> DedDbItemType

Valore di ritorno

DedDbItemType
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Metodo DedData.GetProgr

Metodo DedDataGetProgr
Restituisce il progressivo dell'anagrafica. Letto da DED_DATA_ENCODE se compilato altrimenti lo ricalcola.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string GetProgr()
Public Function GetProgr As String
public:
String^ GetProgr()
member GetProgr : unit -> string

Valore di ritorno

String
Restituisce il progressivo letto dall'anagrafica.
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Metodo DedData.GetProgrTokenNum

Metodo DedDataGetProgrTokenNum
Restituisce il numero di caratteri da utilizzare per creare la stringa del progressivo per questa famiglia. Li calcola cercando il tassello del progressivo nella codifica del Cod_Id. Se non è presente restituisce 0.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int GetProgrTokenNum()
Public Function GetProgrTokenNum As Integer
public:
int GetProgrTokenNum()
member GetProgrTokenNum : unit -> int

Valore di ritorno

Int32
Restituisce il numero di caratteri del progressivo per questa famiglia.
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Metodo DedData.GetRevDedDisTokenNum

Metodo DedDataGetRevDedDisTokenNum
Restituisce il numero di caratteri dedicati alla revisione, presenti nel DED_DIS.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int GetRevDedDisTokenNum()
Public Function GetRevDedDisTokenNum As Integer
public:
int GetRevDedDisTokenNum()
member GetRevDedDisTokenNum : unit -> int

Valore di ritorno

Int32
Restituisce il numero di caratteri della revsione presenti nel DED_DIS di questa famiglia.
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Metodo DedData.GetRevFileTokenNum

Metodo DedDataGetRevFileTokenNum
Restituisce il numero di caratteri dedicati alla revisione, presenti nel nome del file COD_FIL. Se si tratta di una famiglia NGR (nuova gestione delle revisioni), restituisce 0, altrimenti il numero di caratteri presenti.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int GetRevFileTokenNum()
Public Function GetRevFileTokenNum As Integer
public:
int GetRevFileTokenNum()
member GetRevFileTokenNum : unit -> int

Valore di ritorno

Int32
Restituisce il numero di caratteri della revsione presenti nel file di questa famiglia.
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Metodo DedData.GetStrictPrimaryDocuments

Metodo DedDataGetStrictPrimaryDocuments
Restituisce la lista dei documenti collegati a questa anagrafica come Modello, Rappresentazione o Pubblicazione. Restituisce sempre una lista inizializzata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocList GetStrictPrimaryDocuments()
Public Function GetStrictPrimaryDocuments As DedDocList
public:
DedDocList^ GetStrictPrimaryDocuments()
member GetStrictPrimaryDocuments : unit -> DedDocList

Valore di ritorno

DedDocList
Restituisce una lista dei documenti trovati.
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Metodo DedData.GetValue

Metodo DedDataGetValue
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | GetValue(DedDataStandardDataFields) | Restituisce il contenuto di uno dei campi standard oppure null se non è presente.
Metodo pubblico | GetValue(String) | Restituisce il contenuto di un campo personalizzato oppure null se non esiste.
Torna su
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Metodo DedData.GetValue(DedData.StandardDataFields)

Metodo DedDataGetValue(DedDataStandardDataFields)
Restituisce il contenuto di uno dei campi standard oppure null se non è presente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object GetValue(
    DedDataStandardDataFields stdfield
)
Public Function GetValue (
    stdfield As DedDataStandardDataFields
) As Object
public:
virtual Object^ GetValue(
    DedDataStandardDataFields stdfield
) sealed
abstract GetValue :
        stdfield : DedDataStandardDataFields -> Object
override GetValue :
        stdfield : DedDataStandardDataFields -> Object

Parametri

stdfield DedDataStandardDataFields
Campo standard del quale avere il contenuto.

Valore di ritorno

Object

Implementa

IDedTypeEditableGetValue(DedDataStandardDataFields)
Vedi anche

Documentazione

Classe DedData
Overload di GetValue
Namespace DedNet.Core


Metodo DedData.GetValue(String)

Metodo DedDataGetValue(String)
Restituisce il contenuto di un campo personalizzato oppure null se non esiste.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object GetValue(
    string persfield
)
Public Function GetValue (
    persfield As String
) As Object
public:
virtual Object^ GetValue(
    String^ persfield
) sealed
abstract GetValue :
        persfield : string -> Object
override GetValue :
        persfield : string -> Object

Parametri

persfield String
Nome del campo personalizzato del quale avere il contenuto.

Valore di ritorno

Object

Implementa

IDedEditableGetValue(String)
Vedi anche

Documentazione

Classe DedData
Overload di GetValue
Namespace DedNet.Core


Metodo DedData.GetVar

Metodo DedDataGetVar
Restituisce il tassello di variante automatico dell'anagrafica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string GetVar()
Public Function GetVar As String
public:
String^ GetVar()
member GetVar : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Metodo DedData.Lock

Metodo DedDataLock
Esegue il blocco dell'anagrafica impostando il campo DEDLOCK con il nome dell'utente corrente. Utilizza il campo DEDROWVER attuale per effettuare il blocco in modo da non riuscire in caso di anagrafica già modificata. Questo metodo non rende dirty l'anagrafica ma bisogna poi sbloccarla attraverso UnLock() oppure con Update().

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Lock(
    bool ignoreState = false,
    bool ignoreDocStatus = false
)
Public Sub Lock (
    Optional ignoreState As Boolean = false,
    Optional ignoreDocStatus As Boolean = false
)
public:
virtual void Lock(
    bool ignoreState = false,
    bool ignoreDocStatus = false
) sealed
abstract Lock :
        ?ignoreState : bool *
        ?ignoreDocStatus : bool
(* Defaults:
        let _ignoreState = defaultArg ignoreState false
        let _ignoreDocStatus = defaultArg ignoreDocStatus false
*)
-> unit
override Lock :
        ?ignoreState : bool *
        ?ignoreDocStatus : bool
(* Defaults:
        let _ignoreState = defaultArg ignoreState false
        let _ignoreDocStatus = defaultArg ignoreDocStatus false
*)
-> unit

Parametri

ignoreState Boolean (Optional)
ignoreDocStatus Boolean (Optional)

Implementa

IDedDataLock(Boolean, Boolean)
Eccezioni
Eccezione | Condizione
QsException | Il record risulta bloccato da un altro utente.
QsException | Errore verificatosi nell'esecuzione dell'istruzione Update.
ArgumentNullException | Parametro mancante.
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Metodo DedData.MakeBackupFilePath

Metodo DedDataMakeBackupFilePath
Restitusice il percorso completo del file come revisione nel caso di famiglia con NGR. Il percorso viene calcolato in base all'anagrafica mentre il nome file viene preso dal fileName passato e viene aggiunta la revisione di questo record.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedRootInfo MakeBackupFilePath(
    string fileName
)
Public Function MakeBackupFilePath (
    fileName As String
) As DedRootInfo
public:
DedRootInfo^ MakeBackupFilePath(
    String^ fileName
)
member MakeBackupFilePath :
        fileName : string -> DedRootInfo

Parametri

fileName String

Valore di ritorno

DedRootInfo
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Metodo DedData.MakeClonePart

Metodo DedDataMakeClonePart
Restituisce un oggetto di tipo DedDataPart il quale implementa IDedData costruito tramite il dizionario interno di questa anagrafica. Da utilizzare per passare i dati dell'anagrafica, per esempio alla finestra di codifica, ed evitare che venga modificata l'anagrafica originale.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public IDedData MakeClonePart()
Public Function MakeClonePart As IDedData
public:
IDedData^ MakeClonePart()
member MakeClonePart : unit -> IDedData

Valore di ritorno

IDedData
Restituisce un oggetto di tipo DedDataPart inizializzato con i dati presenti nell'anagrafica.
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Metodo DedData.MakeDefaultBackupPath

Metodo DedDataMakeDefaultBackupPath
Restituisce la cartella nella quale un file revisionato, in presenza di famiglia NGR, dovrebbe essere copiato, se associato a questa anagrafica come primario.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string MakeDefaultBackupPath()
Public Function MakeDefaultBackupPath As String
public:
String^ MakeDefaultBackupPath()
member MakeDefaultBackupPath : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Metodo DedData.MakeDefaultFullFileName

Metodo DedDataMakeDefaultFullFileName
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | MakeDefaultFullFileName(DedDocContextEnum, String, String) | Costruisce e restituisce l'oggetto descrittivo DedRootInfo del percorso di default che dovrebbe avere un file associato a questa anagrafica con un particolare contesto. Se la richiesta riguarda un file primario viene restituito il nome completo prendendo l'estensione dal nome file passato ma con il giusto nome (calcolato dalla codifica della famiglia). Se si richiede di un allegato viene restitituito il nome del file passato così com'é, concatenato della cartella root di archiviazione allegati. Se la richiesta è di una rappresentazione viene fornito un nome composto con nome file primario più nome random del quale però si deve verificare la non esistenza prima dell'utilizzo.
Metodo pubblico | MakeDefaultFullFileName(DedDocContextEnum, String, String, Boolean) |
Torna su
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Metodo DedData.MakeDefaultFullFileName(DedDocContextEnum, String, String)

Metodo DedDataMakeDefaultFullFileName(DedDocContextEnum, String, String)
Costruisce e restituisce l'oggetto descrittivo DedRootInfo del percorso di default che dovrebbe avere un file associato a questa anagrafica con un particolare contesto. Se la richiesta riguarda un file primario viene restituito il nome completo prendendo l'estensione dal nome file passato ma con il giusto nome (calcolato dalla codifica della famiglia). Se si richiede di un allegato viene restitituito il nome del file passato così com'é, concatenato della cartella root di archiviazione allegati. Se la richiesta è di una rappresentazione viene fornito un nome composto con nome file primario più nome random del quale però si deve verificare la non esistenza prima dell'utilizzo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedRootInfo MakeDefaultFullFileName(
    DedDocContextEnum context,
    string fileName,
    string rapIdx = null
)
Public Function MakeDefaultFullFileName (
    context As DedDocContextEnum,
    fileName As String,
    Optional rapIdx As String = Nothing
) As DedRootInfo
public:
DedRootInfo^ MakeDefaultFullFileName(
    DedDocContextEnum context,
    String^ fileName,
    String^ rapIdx = nullptr
)
member MakeDefaultFullFileName :
        context : DedDocContextEnum *
        fileName : string *
        ?rapIdx : string
(* Defaults:
        let _rapIdx = defaultArg rapIdx null
*)
-> DedRootInfo

Parametri

context DedDocContextEnum
Contesto per il quale si desidera il nome del file.
fileName String
Nome del file, senza percorso ma con l'estensione, che si desidera associare all'anagrafica.
rapIdx String (Optional)

Valore di ritorno

DedRootInfo
Restituisce le informazioni sul percorso richiesto.
Vedi anche

Documentazione

Classe DedData
Overload di MakeDefaultFullFileName
Namespace DedNet.Core


Metodo DedData.MakeDefaultFullFileName(DedDocContextEnum, String, String, Boolean)

Metodo DedDataMakeDefaultFullFileName(DedDocContextEnum, String, String, Boolean)

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedRootInfo MakeDefaultFullFileName(
    DedDocContextEnum context,
    string fileName,
    string rapIdx,
    bool sparePartsPublishing
)
Public Function MakeDefaultFullFileName (
    context As DedDocContextEnum,
    fileName As String,
    rapIdx As String,
    sparePartsPublishing As Boolean
) As DedRootInfo
public:
DedRootInfo^ MakeDefaultFullFileName(
    DedDocContextEnum context,
    String^ fileName,
    String^ rapIdx,
    bool sparePartsPublishing
)
member MakeDefaultFullFileName :
        context : DedDocContextEnum *
        fileName : string *
        rapIdx : string *
        sparePartsPublishing : bool -> DedRootInfo

Parametri

context DedDocContextEnum
fileName String
rapIdx String
sparePartsPublishing Boolean

Valore di ritorno

DedRootInfo
Vedi anche

Documentazione

Classe DedData
Overload di MakeDefaultFullFileName
Namespace DedNet.Core


Metodo DedData.MakeDefaultPrimaryFileName

Metodo DedDataMakeDefaultPrimaryFileName
Restituisce il nome che un file primario dovrebbe avere se associato a questa anagrafica. Se l'anagrafica presenta compilato il DED_FILE restituisce il suo valore, altrimenti lo calcola dalla famiglia di appartenenza e dai dati presenti.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string MakeDefaultPrimaryFileName()
Public Function MakeDefaultPrimaryFileName As String
public:
String^ MakeDefaultPrimaryFileName()
member MakeDefaultPrimaryFileName : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Metodo DedData.MakeDefaultPrimaryPath

Metodo DedDataMakeDefaultPrimaryPath
Restituisce il percorso che un file primario dovrebbe avere se associato a questa anagrafica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string MakeDefaultPrimaryPath()
Public Function MakeDefaultPrimaryPath As String
public:
String^ MakeDefaultPrimaryPath()
member MakeDefaultPrimaryPath : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Metodo DedData.RebuildPrimaryFullFileNameFromBackup

Metodo DedDataRebuildPrimaryFullFileNameFromBackup
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | RebuildPrimaryFullFileNameFromBackup(DedDoc) | Restituisce il nome completo del file originale, partendo dal nome di backup (usato nella NGR).
Metodo pubblico | RebuildPrimaryFullFileNameFromBackup(String) | Restituisce il nome completo del file originale, partendo dal nome di backup (usato nella NGR).
Torna su
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Metodo DedData.RebuildPrimaryFullFileNameFromBackup(DedDoc)

Metodo DedDataRebuildPrimaryFullFileNameFromBackup(DedDoc)
Restituisce il nome completo del file originale, partendo dal nome di backup (usato nella NGR).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string RebuildPrimaryFullFileNameFromBackup(
    DedDoc bckDoc
)
Public Function RebuildPrimaryFullFileNameFromBackup (
    bckDoc As DedDoc
) As String
public:
String^ RebuildPrimaryFullFileNameFromBackup(
    DedDoc^ bckDoc
)
member RebuildPrimaryFullFileNameFromBackup :
        bckDoc : DedDoc -> string

Parametri

bckDoc DedDoc
Documento di riferimento per l'estrazione del path

Valore di ritorno

String
Restituisce il nome del file.
Vedi anche

Documentazione

Classe DedData
Overload di RebuildPrimaryFullFileNameFromBackup
Namespace DedNet.Core


Metodo DedData.RebuildPrimaryFullFileNameFromBackup(String)

Metodo DedDataRebuildPrimaryFullFileNameFromBackup(String)
Restituisce il nome completo del file originale, partendo dal nome di backup (usato nella NGR).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string RebuildPrimaryFullFileNameFromBackup(
    string bckDocFullFileName
)
Public Function RebuildPrimaryFullFileNameFromBackup (
    bckDocFullFileName As String
) As String
public:
String^ RebuildPrimaryFullFileNameFromBackup(
    String^ bckDocFullFileName
)
member RebuildPrimaryFullFileNameFromBackup :
        bckDocFullFileName : string -> string

Parametri

bckDocFullFileName String
Nome del file backuppato, senza percorso, con estensione.

Valore di ritorno

String
Restituisce il nome del file.
Vedi anche

Documentazione

Classe DedData
Overload di RebuildPrimaryFullFileNameFromBackup
Namespace DedNet.Core


Metodo DedData.Refresh

Metodo DedDataRefresh
Aggiorna questo oggetto rileggendo le informazioni presenti nel Database. Effettua l'aggiornamento anche se l'anagrafica è dirty (la imposta a false dopo l'aggiornamento). Aggiorna tutti i campi quindi anche il DEDROWVERSION.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Refresh()
Public Sub Refresh
public:
void Refresh()
member Refresh : unit -> unit
Eccezioni
Eccezione | Condizione
QsException | Sollevata nel caso di errore nella interrogazione del record corrispondente all'anagrafica.
ArgumentNullException | Parametro mancante.
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Metodo DedData.ReloadInfoUser

Metodo DedDataReloadInfoUser
Ricalcola modificando solo il tassello utente e la revisione tutto il resto rimane inalterato (usato per crea variante)

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string ReloadInfoUser(
    DedEncodeInfo _info,
    string code,
    string encode
)
Public Function ReloadInfoUser (
    _info As DedEncodeInfo,
    code As String,
    encode As String
) As String
public:
String^ ReloadInfoUser(
    DedEncodeInfo^ _info,
    String^ code,
    String^ encode
)
member ReloadInfoUser :
        _info : DedEncodeInfo *
        code : string *
        encode : string -> string

Parametri

_info DedEncodeInfo
Oggetto EncodeInfo
code String
Codice decodificato
encode String
Codice codificato (usato per la codifica)

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Metodo DedData.ReloadRev

Metodo DedDataReloadRev
Ricalcola modificando solo il tassello utente tutto il resto rimane inalterato (usato per crea revisione)

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string ReloadRev(
    DedEncodeInfo _info,
    string code,
    string encode
)
Public Function ReloadRev (
    _info As DedEncodeInfo,
    code As String,
    encode As String
) As String
public:
String^ ReloadRev(
    DedEncodeInfo^ _info,
    String^ code,
    String^ encode
)
member ReloadRev :
        _info : DedEncodeInfo *
        code : string *
        encode : string -> string

Parametri

_info DedEncodeInfo
Oggetto EncodeInfo
code String
Codice decodificato
encode String
Codice codificato (usato per la codifica)

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Metodo DedData.RemoveDoc

Metodo DedDataRemoveDoc
Scollega dall'anagrafica uno specifico documento, eliminando dal DB il legame.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void RemoveDoc(
    Guid docid
)
Public Sub RemoveDoc (
    docid As Guid
)
public:
void RemoveDoc(
    Guid docid
)
member RemoveDoc :
        docid : Guid -> unit

Parametri

docid Guid
DocID del documento da eliminare.
Eccezioni
Eccezione | Condizione
QsException | Solleva questa eccezione se non riesce ad eliminare i dati.
ArgumentNullException | Parametro mancante.
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Metodo DedData.RemoveDocs

Metodo DedDataRemoveDocs
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | RemoveDocs | Scollega dall'anagrafica tutti i documenti, eliminandone dal DB il legame.
Metodo pubblico | RemoveDocs(ListGuid) | Scollega dall'anagrafica una lista di documenti, eliminandone dal DB il legame.
Torna su
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Metodo DedData.RemoveDocs

Metodo DedDataRemoveDocs
Scollega dall'anagrafica tutti i documenti, eliminandone dal DB il legame.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void RemoveDocs()
Public Sub RemoveDocs
public:
void RemoveDocs()
member RemoveDocs : unit -> unit
Eccezioni
Eccezione | Condizione
[!:DedRecordExceptionList] | Viene sollevata in caso di uno o più errori di inserimento dati.
Vedi anche

Documentazione

Classe DedData
Overload di RemoveDocs
Namespace DedNet.Core


Metodo DedData.RemoveDocs(List<Guid>)

Metodo DedDataRemoveDocs(ListGuid)
Scollega dall'anagrafica una lista di documenti, eliminandone dal DB il legame.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void RemoveDocs(
    List<Guid> docidlist
)
Public Sub RemoveDocs (
    docidlist As List(Of Guid)
)
public:
void RemoveDocs(
    List<Guid>^ docidlist
)
member RemoveDocs :
        docidlist : List<Guid> -> unit

Parametri

docidlist List Guid
Lista dei DocID da scollegare dall'anagrafica.
Eccezioni
Eccezione | Condizione
[!:DedRecordExceptionList] | Viene sollevata in caso di uno o più errori di inserimento dati.
Vedi anche

Documentazione

Classe DedData
Overload di RemoveDocs
Namespace DedNet.Core


Metodo DedData.RemoveFromErased

Metodo DedDataRemoveFromErased
Rimuove l'anagrafica alla tabella degli eliminati

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool RemoveFromErased()
Public Function RemoveFromErased As Boolean
public:
bool RemoveFromErased()
member RemoveFromErased : unit -> bool

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Metodo DedData.SetState

Metodo DedDataSetState
Permette di cambiare lo stato di un'anagrafica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetState(
    DedState state,
    string changeStateNote = ""
)
Public Sub SetState (
    state As DedState,
    Optional changeStateNote As String = ""
)
public:
void SetState(
    DedState^ state,
    String^ changeStateNote = L""
)
member SetState :
        state : DedState *
        ?changeStateNote : string
(* Defaults:
        let _changeStateNote = defaultArg changeStateNote ""
*)
-> unit

Parametri

state DedState
Nuovo stato da impostare.
changeStateNote String (Optional)

Valore di ritorno

Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Metodo DedData.SetValue

Metodo DedDataSetValue
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | SetValue(DedDataStandardDataFields, Object) |
Metodo pubblico | SetValue(String, Object) | Imposta un campo personalizzato con un nuovo valore. Se il campo non esiste lo crea. La chiamata a questo metodo può causare la messa a Dirty dell'anagrafica, quando il campo da impostare è già presente nel dizionario interno ed il valore da impostare è differente da quello precedente oppure se è da creare. Oltre a porre l'anagrafica come Dirty viene anche tentato il lock dell'anagrafica fino alla successiva chiamata del metodo Update() che imposta l'anagrafica come sbloccata e non Dirty oppure UnLock() che annulla le modifiche.
Torna su
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Metodo DedData.SetValue(DedData.StandardDataFields, Object)

Metodo DedDataSetValue(DedDataStandardDataFields, Object)

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetValue(
    DedDataStandardDataFields stdfield,
    Object Value
)
Public Sub SetValue (
    stdfield As DedDataStandardDataFields,
    Value As Object
)
public:
virtual void SetValue(
    DedDataStandardDataFields stdfield,
    Object^ Value
) sealed
abstract SetValue :
        stdfield : DedDataStandardDataFields *
        Value : Object -> unit
override SetValue :
        stdfield : DedDataStandardDataFields *
        Value : Object -> unit

Parametri

stdfield DedDataStandardDataFields
Value Object

Implementa

IDedTypeEditableSetValue(DedDataStandardDataFields, Object)
Vedi anche

Documentazione

Classe DedData
Overload di SetValue
Namespace DedNet.Core


Metodo DedData.SetValue(String, Object)

Metodo DedDataSetValue(String, Object)
Imposta un campo personalizzato con un nuovo valore. Se il campo non esiste lo crea. La chiamata a questo metodo può causare la messa a Dirty dell'anagrafica, quando il campo da impostare è già presente nel dizionario interno ed il valore da impostare è differente da quello precedente oppure se è da creare. Oltre a porre l'anagrafica come Dirty viene anche tentato il lock dell'anagrafica fino alla successiva chiamata del metodo Update() che imposta l'anagrafica come sbloccata e non Dirty oppure UnLock() che annulla le modifiche.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetValue(
    string persfield,
    Object Value
)
Public Sub SetValue (
    persfield As String,
    Value As Object
)
public:
virtual void SetValue(
    String^ persfield,
    Object^ Value
) sealed
abstract SetValue :
        persfield : string *
        Value : Object -> unit
override SetValue :
        persfield : string *
        Value : Object -> unit

Parametri

persfield String
Nome del campo personalizzato da impostare.
Value Object
Valore da impostare.

Implementa

IDedEditableSetValue(String, Object)
Eccezioni
Eccezione | Condizione
QsException | Il record risulta bloccato da un altro utente.
QsException | Questa eccezione viene lanciata se l'anagrafica è stata cancellata.
ArgumentNullException | Parametro mancante.
Vedi anche

Documentazione

Classe DedData
Overload di SetValue
Namespace DedNet.Core


Metodo DedData.ToString

Metodo DedDataToString
Restituisce una rappresentazione stringa di questo oggetto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

String
Restituisce una stringa rappresentante questo oggetto.
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Metodo DedData.UnLock

Metodo DedDataUnLock
Sblocca l'anagrafica solo se questa era bloccata. Opzionalmente, se questa è dirty, la aggiorna. Questo metodo la sblocca reimpostando il DEDROWVER alla versione precedente il bloccaggio ed effettua un Refresh() per riallineare i valori dell'anagrafica con il Database se l'anagrafica era Dirty.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void UnLock(
    bool DiscardChanges
)
Public Sub UnLock (
    DiscardChanges As Boolean
)
public:
virtual void UnLock(
    bool DiscardChanges
) sealed
abstract UnLock :
        DiscardChanges : bool -> unit
override UnLock :
        DiscardChanges : bool -> unit

Parametri

DiscardChanges Boolean
Indica se salvare le modifiche apportate nel caso in cui l'anagrafica sia dirty.

Implementa

IDedDataUnLock(Boolean)
Eccezioni
Eccezione | Condizione
QsException | Errore verificatosi nell'esecuzione dell'istruzione Update.
ArgumentNullException | Parametro mancante.
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Metodo DedData.Update

Metodo DedDataUpdate
Aggiorna l'anagrafica nel Database solo se questa è Dirty e quindi, in contemporanea, la sblocca. Poi imposta il dirty a false. Vengono aggiornati solo gli attributi che sono riconosciuti come d'anagrafica e non quelli di documento e di distinta. Oltre a questi vengono aggiornati anche i campi non presenti in DED_ATTR come : DEDROWVER, DEDMODUSER, DEDMODDATE e DEDLOCK, ecc.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Update(
    bool light = false
)
Public Sub Update (
    Optional light As Boolean = false
)
public:
void Update(
    bool light = false
)
member Update :
        ?light : bool
(* Defaults:
        let _light = defaultArg light false
*)
-> unit

Parametri

light Boolean (Optional)
Se a true effettua un aggiornamento senza cambiare il RowVer dell'anagrafica.
Eccezioni
Eccezione | Condizione
QsException | Viene sollevata in caso di errore nell'istruzione di aggiornamento dati.
ArgumentNullException | Parametro mancante.
InvalidOperationException | Anagrafica non bloccata dall'utente corrente.
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Metodo DedData.UpdateState

Metodo DedDataUpdateState
Scrive il cambio di stato nell'anagrafica e nella tabella DED_STATE_HISTORY.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void UpdateState(
    DedState state,
    string changeStateNote
)
Public Sub UpdateState (
    state As DedState,
    changeStateNote As String
)
public:
void UpdateState(
    DedState^ state,
    String^ changeStateNote
)
member UpdateState :
        state : DedState *
        changeStateNote : string -> unit

Parametri

state DedState
Nuovo Stato
changeStateNote String
Note di cambio stato
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Metodo DedData.Validate

Metodo DedDataValidate
Restituisce se i valori presenti validano gli attributi della famiglia di appartenenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Validate(
    bool creating,
    bool revisioning,
    out string error
)
Public Function Validate (
    creating As Boolean,
    revisioning As Boolean,
    <OutAttribute> ByRef error As String
) As Boolean
public:
virtual bool Validate(
    bool creating,
    bool revisioning,
    [OutAttribute] String^% error
) sealed
abstract Validate :
        creating : bool *
        revisioning : bool *
        error : string byref -> bool
override Validate :
        creating : bool *
        revisioning : bool *
        error : string byref -> bool

Parametri

creating Boolean
revisioning Boolean
error String

Valore di ritorno

Boolean

Implementa

IDedTypeEditableValidate(Boolean, Boolean, String)
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


DedData Operators

Il tipo DedData espone i seguenti membri.

Operatori
Nome | Descrizione
Equality(DedData, DedData) | Ridefinizione dell'operatore ==.
Inequality(DedData, DedData) | Ridefinizione dell'operatore !=.
Torna su
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


DedData.Equality Operatore

DedDataEquality Operatore
Ridefinizione dell'operatore ==.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool operator ==(
    DedData a,
    DedData b
)
Public Shared Operator = (
    a As DedData,
    b As DedData
) As Boolean
public:
static bool operator ==(
    DedData^ a,
    DedData^ b
)
static let inline (=)
        a : DedData *
        b : DedData  : bool

Parametri

a DedData
b DedData

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


DedData.Inequality Operatore

DedDataInequality Operatore
Ridefinizione dell'operatore !=.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool operator !=(
    DedData a,
    DedData b
)
Public Shared Operator <> (
    a As DedData,
    b As DedData
) As Boolean
public:
static bool operator !=(
    DedData^ a,
    DedData^ b
)
static let inline (<>)
        a : DedData *
        b : DedData  : bool

Parametri

a DedData
b DedData

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedData
Namespace DedNet.Core


Classe DedData.DedDataEncodeInfo

Classe DedDataDedDataEncodeInfo
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedDataDedDataEncodeInfo

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedDataEncodeInfo
Public Class DedDataEncodeInfo
public ref class DedDataEncodeInfo
type DedDataEncodeInfo = class end

Il tipo DedDataDedDataEncodeInfo espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedDataDedDataEncodeInfo | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | DwgPath | Codifica utilizzate per creare DED_FILE.
Proprietà pubblica | EncodedCod | Codifica utilizzate per creare DED_COD.
Proprietà pubblica | EncodedDis | Codifica utilizzate per creare DED_DIS.
Proprietà pubblica | EncodedFil | Codifica utilizzate per creare DED_FILE.
Proprietà pubblica | EncodedId | Codifica utilizzate per creare ID.
Proprietà pubblica | FreeCode |
Proprietà pubblica | FreeCodeCompiled | Indica se nella tabella DED_DATA_ENCODE è compilato il campo FreeCode
Proprietà pubblica | FreeFile |
Proprietà pubblica | FreeFileAsDedId | Restituisce/Imposta se il file debba essere compilato come l'id.
Proprietà pubblica | FreeFileCompiled | Indica se nella tabella DED_DATA_ENCODE è compilato il campo FreeFile
Proprietà pubblica | FreeFileSameFileRev | Restituisce/Imposta se il file debba rimanere uguale anche nelle revisioni.
Proprietà pubblica | FreeFileType | Restituisce la tipologia di freefile di questa famiglia.
Proprietà pubblica | ObjectCompleted |
Proprietà pubblica | Prog | Valore del tassello del progressivo
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | SetDwgPath | Aggiorna il campo interno senza aggiornare il DB
Metodo pubblico | SetEncodedCod | Aggiorna il campo interno senza aggiornare il DB
Metodo pubblico | SetEncodedDis | Aggiorna il campo interno senza aggiornare il DB
Metodo pubblico | SetEncodedFil | Aggiorna il campo interno senza aggiornare il DB
Metodo pubblico | SetEncodedId | Aggiorna il campo interno senza aggiornare il DB
Metodo pubblico | SetFreeCode | Aggiorna il campo interno senza aggiornare il DB
Metodo pubblico | SetFreeFile | Aggiorna il campo interno senza aggiornare il DB
Metodo pubblico | SetProg | Aggiorna il campo interno senza aggiornare il DB
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedData.DedDataEncodeInfo

Costruttore DedDataDedDataEncodeInfo
Costruttore unico.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataEncodeInfo(
    DedNetApplication app,
    DedData data
)
Public Sub New (
    app As DedNetApplication,
    data As DedData
)
public:
DedDataEncodeInfo(
    DedNetApplication^ app,
    DedData^ data
)
new :
        app : DedNetApplication *
        data : DedData -> DedDataEncodeInfo

Parametri

app DedNetApplication
Applicazione DedNet.
data DedData
Anagrafica della quale reperire i dati di codifica.
Vedi anche

Documentazione

Classe DedDataDedDataEncodeInfo
Namespace DedNet.Core


Proprietà di DedDataEncodeInfo

Il tipo DedDataDedDataEncodeInfo espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | DwgPath | Codifica utilizzate per creare DED_FILE.
Proprietà pubblica | EncodedCod | Codifica utilizzate per creare DED_COD.
Proprietà pubblica | EncodedDis | Codifica utilizzate per creare DED_DIS.
Proprietà pubblica | EncodedFil | Codifica utilizzate per creare DED_FILE.
Proprietà pubblica | EncodedId | Codifica utilizzate per creare ID.
Proprietà pubblica | FreeCode |
Proprietà pubblica | FreeCodeCompiled | Indica se nella tabella DED_DATA_ENCODE è compilato il campo FreeCode
Proprietà pubblica | FreeFile |
Proprietà pubblica | FreeFileAsDedId | Restituisce/Imposta se il file debba essere compilato come l'id.
Proprietà pubblica | FreeFileCompiled | Indica se nella tabella DED_DATA_ENCODE è compilato il campo FreeFile
Proprietà pubblica | FreeFileSameFileRev | Restituisce/Imposta se il file debba rimanere uguale anche nelle revisioni.
Proprietà pubblica | FreeFileType | Restituisce la tipologia di freefile di questa famiglia.
Proprietà pubblica | ObjectCompleted |
Proprietà pubblica | Prog | Valore del tassello del progressivo
Torna su
Vedi anche

Documentazione

Classe DedDataDedDataEncodeInfo
Namespace DedNet.Core


Proprietà DedData.DedDataEncodeInfo.DwgPath

Proprietà DedDataDedDataEncodeInfoDwgPath
Codifica utilizzate per creare DED_FILE.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string DwgPath { get; set; }
Public Property DwgPath As String
    Get
    Set
public:
property String^ DwgPath {
    String^ get ();
    void set (String^ value);
}
member DwgPath : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedDataDedDataEncodeInfo
Namespace DedNet.Core


Proprietà DedData.DedDataEncodeInfo.EncodedCod

Proprietà DedDataDedDataEncodeInfoEncodedCod
Codifica utilizzate per creare DED_COD.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeCompCodeEnum EncodedCod { get; set; }
Public Property EncodedCod As DedTypeCompCodeEnum
    Get
    Set
public:
property DedTypeCompCodeEnum EncodedCod {
    DedTypeCompCodeEnum get ();
    void set (DedTypeCompCodeEnum value);
}
member EncodedCod : DedTypeCompCodeEnum with get, set

Valore della proprietà

DedTypeCompCodeEnum
Vedi anche

Documentazione

Classe DedDataDedDataEncodeInfo
Namespace DedNet.Core


Proprietà DedData.DedDataEncodeInfo.EncodedDis

Proprietà DedDataDedDataEncodeInfoEncodedDis
Codifica utilizzate per creare DED_DIS.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string EncodedDis { get; set; }
Public Property EncodedDis As String
    Get
    Set
public:
property String^ EncodedDis {
    String^ get ();
    void set (String^ value);
}
member EncodedDis : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedDataDedDataEncodeInfo
Namespace DedNet.Core


Proprietà DedData.DedDataEncodeInfo.EncodedFil

Proprietà DedDataDedDataEncodeInfoEncodedFil
Codifica utilizzate per creare DED_FILE.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string EncodedFil { get; set; }
Public Property EncodedFil As String
    Get
    Set
public:
property String^ EncodedFil {
    String^ get ();
    void set (String^ value);
}
member EncodedFil : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedDataDedDataEncodeInfo
Namespace DedNet.Core


Proprietà DedData.DedDataEncodeInfo.EncodedId

Proprietà DedDataDedDataEncodeInfoEncodedId
Codifica utilizzate per creare ID.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string EncodedId { get; set; }
Public Property EncodedId As String
    Get
    Set
public:
property String^ EncodedId {
    String^ get ();
    void set (String^ value);
}
member EncodedId : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedDataDedDataEncodeInfo
Namespace DedNet.Core


Proprietà DedData.DedDataEncodeInfo.FreeCode

Proprietà DedDataDedDataEncodeInfoFreeCode

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool FreeCode { get; set; }
Public Property FreeCode As Boolean
    Get
    Set
public:
property bool FreeCode {
    bool get ();
    void set (bool value);
}
member FreeCode : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDataDedDataEncodeInfo
Namespace DedNet.Core


Proprietà DedData.DedDataEncodeInfo.FreeCodeCompiled

Proprietà DedDataDedDataEncodeInfoFreeCodeCompiled
Indica se nella tabella DED_DATA_ENCODE è compilato il campo FreeCode

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool FreeCodeCompiled { get; }
Public ReadOnly Property FreeCodeCompiled As Boolean
    Get
public:
property bool FreeCodeCompiled {
    bool get ();
}
member FreeCodeCompiled : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDataDedDataEncodeInfo
Namespace DedNet.Core


Proprietà DedData.DedDataEncodeInfo.FreeFile

Proprietà DedDataDedDataEncodeInfoFreeFile

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool FreeFile { get; set; }
Public Property FreeFile As Boolean
    Get
    Set
public:
property bool FreeFile {
    bool get ();
    void set (bool value);
}
member FreeFile : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDataDedDataEncodeInfo
Namespace DedNet.Core


Proprietà DedData.DedDataEncodeInfo.FreeFileAsDedId

Proprietà DedDataDedDataEncodeInfoFreeFileAsDedId
Restituisce/Imposta se il file debba essere compilato come l'id.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool FreeFileAsDedId { get; }
Public ReadOnly Property FreeFileAsDedId As Boolean
    Get
public:
property bool FreeFileAsDedId {
    bool get ();
}
member FreeFileAsDedId : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDataDedDataEncodeInfo
Namespace DedNet.Core


Proprietà DedData.DedDataEncodeInfo.FreeFileCompiled

Proprietà DedDataDedDataEncodeInfoFreeFileCompiled
Indica se nella tabella DED_DATA_ENCODE è compilato il campo FreeFile

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool FreeFileCompiled { get; }
Public ReadOnly Property FreeFileCompiled As Boolean
    Get
public:
property bool FreeFileCompiled {
    bool get ();
}
member FreeFileCompiled : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDataDedDataEncodeInfo
Namespace DedNet.Core


Proprietà DedData.DedDataEncodeInfo.FreeFileSameFileRev

Proprietà DedDataDedDataEncodeInfoFreeFileSameFileRev
Restituisce/Imposta se il file debba rimanere uguale anche nelle revisioni.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool FreeFileSameFileRev { get; }
Public ReadOnly Property FreeFileSameFileRev As Boolean
    Get
public:
property bool FreeFileSameFileRev {
    bool get ();
}
member FreeFileSameFileRev : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDataDedDataEncodeInfo
Namespace DedNet.Core


Proprietà DedData.DedDataEncodeInfo.FreeFileType

Proprietà DedDataDedDataEncodeInfoFreeFileType
Restituisce la tipologia di freefile di questa famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeFreeFileEnum FreeFileType { get; set; }
Public Property FreeFileType As DedTypeFreeFileEnum
    Get
    Set
public:
property DedTypeFreeFileEnum FreeFileType {
    DedTypeFreeFileEnum get ();
    void set (DedTypeFreeFileEnum value);
}
member FreeFileType : DedTypeFreeFileEnum with get, set

Valore della proprietà

DedTypeFreeFileEnum
Vedi anche

Documentazione

Classe DedDataDedDataEncodeInfo
Namespace DedNet.Core


Proprietà DedData.DedDataEncodeInfo.ObjectCompleted

Proprietà DedDataDedDataEncodeInfoObjectCompleted

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ObjectCompleted { get; set; }
Public Property ObjectCompleted As Boolean
    Get
    Set
public:
property bool ObjectCompleted {
    bool get ();
    void set (bool value);
}
member ObjectCompleted : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDataDedDataEncodeInfo
Namespace DedNet.Core


Proprietà DedData.DedDataEncodeInfo.Prog

Proprietà DedDataDedDataEncodeInfoProg
Valore del tassello del progressivo

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Prog { get; set; }
Public Property Prog As String
    Get
    Set
public:
property String^ Prog {
    String^ get ();
    void set (String^ value);
}
member Prog : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedDataDedDataEncodeInfo
Namespace DedNet.Core


Metodi di DedDataEncodeInfo

Il tipo DedDataDedDataEncodeInfo espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | SetDwgPath | Aggiorna il campo interno senza aggiornare il DB
Metodo pubblico | SetEncodedCod | Aggiorna il campo interno senza aggiornare il DB
Metodo pubblico | SetEncodedDis | Aggiorna il campo interno senza aggiornare il DB
Metodo pubblico | SetEncodedFil | Aggiorna il campo interno senza aggiornare il DB
Metodo pubblico | SetEncodedId | Aggiorna il campo interno senza aggiornare il DB
Metodo pubblico | SetFreeCode | Aggiorna il campo interno senza aggiornare il DB
Metodo pubblico | SetFreeFile | Aggiorna il campo interno senza aggiornare il DB
Metodo pubblico | SetProg | Aggiorna il campo interno senza aggiornare il DB
Torna su
Vedi anche

Documentazione

Classe DedDataDedDataEncodeInfo
Namespace DedNet.Core


Metodo DedData.DedDataEncodeInfo.SetDwgPath

Metodo DedDataDedDataEncodeInfoSetDwgPath
Aggiorna il campo interno senza aggiornare il DB

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetDwgPath(
    string dwgPath
)
Public Sub SetDwgPath (
    dwgPath As String
)
public:
void SetDwgPath(
    String^ dwgPath
)
member SetDwgPath :
        dwgPath : string -> unit

Parametri

dwgPath String
Vedi anche

Documentazione

Classe DedDataDedDataEncodeInfo
Namespace DedNet.Core


Metodo DedData.DedDataEncodeInfo.SetEncodedCod

Metodo DedDataDedDataEncodeInfoSetEncodedCod
Aggiorna il campo interno senza aggiornare il DB

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetEncodedCod(
    DedTypeCompCodeEnum encodedCod
)
Public Sub SetEncodedCod (
    encodedCod As DedTypeCompCodeEnum
)
public:
void SetEncodedCod(
    DedTypeCompCodeEnum encodedCod
)
member SetEncodedCod :
        encodedCod : DedTypeCompCodeEnum -> unit

Parametri

encodedCod DedTypeCompCodeEnum
Vedi anche

Documentazione

Classe DedDataDedDataEncodeInfo
Namespace DedNet.Core


Metodo DedData.DedDataEncodeInfo.SetEncodedDis

Metodo DedDataDedDataEncodeInfoSetEncodedDis
Aggiorna il campo interno senza aggiornare il DB

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetEncodedDis(
    string encodeDis
)
Public Sub SetEncodedDis (
    encodeDis As String
)
public:
void SetEncodedDis(
    String^ encodeDis
)
member SetEncodedDis :
        encodeDis : string -> unit

Parametri

encodeDis String
Vedi anche

Documentazione

Classe DedDataDedDataEncodeInfo
Namespace DedNet.Core


Metodo DedData.DedDataEncodeInfo.SetEncodedFil

Metodo DedDataDedDataEncodeInfoSetEncodedFil
Aggiorna il campo interno senza aggiornare il DB

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetEncodedFil(
    string encodeFil
)
Public Sub SetEncodedFil (
    encodeFil As String
)
public:
void SetEncodedFil(
    String^ encodeFil
)
member SetEncodedFil :
        encodeFil : string -> unit

Parametri

encodeFil String
Vedi anche

Documentazione

Classe DedDataDedDataEncodeInfo
Namespace DedNet.Core


Metodo DedData.DedDataEncodeInfo.SetEncodedId

Metodo DedDataDedDataEncodeInfoSetEncodedId
Aggiorna il campo interno senza aggiornare il DB

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetEncodedId(
    string encodeId
)
Public Sub SetEncodedId (
    encodeId As String
)
public:
void SetEncodedId(
    String^ encodeId
)
member SetEncodedId :
        encodeId : string -> unit

Parametri

encodeId String
Vedi anche

Documentazione

Classe DedDataDedDataEncodeInfo
Namespace DedNet.Core


Metodo DedData.DedDataEncodeInfo.SetFreeCode

Metodo DedDataDedDataEncodeInfoSetFreeCode
Aggiorna il campo interno senza aggiornare il DB

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetFreeCode(
    bool fcode
)
Public Sub SetFreeCode (
    fcode As Boolean
)
public:
void SetFreeCode(
    bool fcode
)
member SetFreeCode :
        fcode : bool -> unit

Parametri

fcode Boolean
Vedi anche

Documentazione

Classe DedDataDedDataEncodeInfo
Namespace DedNet.Core


Metodo DedData.DedDataEncodeInfo.SetFreeFile

Metodo DedDataDedDataEncodeInfoSetFreeFile
Aggiorna il campo interno senza aggiornare il DB

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetFreeFile(
    bool ffile
)
Public Sub SetFreeFile (
    ffile As Boolean
)
public:
void SetFreeFile(
    bool ffile
)
member SetFreeFile :
        ffile : bool -> unit

Parametri

ffile Boolean
Vedi anche

Documentazione

Classe DedDataDedDataEncodeInfo
Namespace DedNet.Core


Metodo DedData.DedDataEncodeInfo.SetProg

Metodo DedDataDedDataEncodeInfoSetProg
Aggiorna il campo interno senza aggiornare il DB

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetProg(
    string prog
)
Public Sub SetProg (
    prog As String
)
public:
void SetProg(
    String^ prog
)
member SetProg :
        prog : string -> unit

Parametri

prog String
Vedi anche

Documentazione

Classe DedDataDedDataEncodeInfo
Namespace DedNet.Core


Enumerazione DedData.StandardDataFields

Enumerazione DedDataStandardDataFields
Elenco dei campi standard.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum StandardDataFields
Public Enumeration StandardDataFields
public enum class StandardDataFields
type StandardDataFields
Membri
Nome | Valore | Descrizione
DBPATH | 0 | Dbpath della famiglia nella quale il codice è archiviato.
DEDID | 1 | Codice identificativo dell'anagrafica senza la parte della revisione. Ottenuto dalla codifica della famiglia alla creazione dell'anagrafica
DEDREV | 2 | Indice di revisione di una stessa anagrafica (a parità di DEDID).
DEDROWVER | 3 | Contiene il GUID che indica la versione del record.
DEDDESC | 4 | Descrizione dell'anagrafica.
DEDUSER | 5 | Utente che ha creato l'anagrafica.
DEDDATE | 6 | Data di creazione dell'anagrafica.
DEDMODUSER | 7 | Utente che ha fatto l'ultima modificato all'anagrafica.
DEDMODDATE | 8 | Data di ultima modifica dell'anagrafica.
DEDREVDESC | 9 | Descrizione delle modifiche apportate in a questa revisione.
DEDREVUSER | 10 | Utente che ha creato questa revisione.
DEDREVDATE | 11 | Data di creazione di questa revisione.
DED_COD | 12 | Codice aziendale di questa anagrafica (normalmente DED_COD = DEDID). Impostato in fase di creazione anagrafica secondo le regole specificate nella famiglia oppure personalizzato dalla procedura di archiviazione.
DED_DIS | 13 | Numero di disegno completo di revisione (vecchio indice che continua ad essere presente con duplicati ammessi o non ammessi). Ottenuto dalla codifica della famiglia alla creazione dell'anagrafica
DED_FILE | 14 | Nome del file da utilizzare per l'importazione di documenti primari. Ottenuto dalla codifica della famiglia alla creazione dell'anagrafica
DEDSTATEUSER | 15 | Utente che ha messo nello stato corrente questa anagrafica.
DEDSTATEDATE | 16 | Data nella quale è stato messo nello stato corrente questa anagrafica.
DEDSTATEID | 17 | ID dello stato di questo record.
DEDSTATENOTE | 18 | Note sul cambio di stato anagrafica.
DEDLOCK | 19 | Contiene il nome utente che ha bloccato l'anagrafica.
DBINDEX | 20 | Guid, in formato stringa, dell'anagrafica.
Vedi anche

Documentazione

Namespace DedNet.Core


Classe DedDataList
Lista di oggetti DedData. Viene utilizzata quando la lista di elementi debba necessariamente essere di anagrafiche presenti nel Database ed in tutti i casi per i quali una lista di anagrafiche debba essere trattata come una unica anagrafica. Per quest'ultimo motivo implementa IDedData e contiene molti membri presenti in DedData che lavorano sull'intera lista di anagrafiche.
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList DedData
DedNet.CoreDedDataList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedDataList : List<DedData>,
    IDedData, IDedTypeEditable, IDedEditable
Public Class DedDataList
    Inherits List(Of DedData)
    Implements IDedData, IDedTypeEditable, IDedEditable
public ref class DedDataList : public List<DedData^>,
    IDedData, IDedTypeEditable, IDedEditable
type DedDataList =
    class
        inherit List<DedData>
        interface IDedData
        interface IDedTypeEditable
        interface IDedEditable
    end

Il tipo DedDataList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedDataList | Inizializza la lista con all'interno l'applicazione di appartenenza.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione di appartenenza.
Proprietà pubblica | DedType | Restituisce la famiglia genitore comune a tutte le anagrafiche presenti.
Proprietà pubblica | DedTypeBase | Restituisce la famiglia nella quale è stato archiviata questa anagrafica. Può restituire null se non appartiene ad alcuna famiglia.
Proprietà pubblica | Dirty | Restituisce true se anche solo una anagrafica è Dirty altrimenti false.
Proprietà pubblica | IsLocked | Restituisce se il record sia bloccato (dall'utente corrente o da un altro). Non legge dal Database, controlla solo se è compilato il campo DEDLOCK. Restituisce true se anche solo un'anagrafica risulta bloccata.
Proprietà pubblica | IsValid | Restituisce se i valori presenti validano gli attributi della famiglia di appartenenza.
Proprietà pubblica | Root | Restituisce la famiglia nella quale è stato archiviata questa anagrafica. Può restituire null se non appartiene ad alcuna famiglia.
Proprietà pubblica | UpdateRowVer | Restituisce true se anche solo una anagrafica è UpdateRowVer altrimenti false.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AllowRemoveFileReadOnly | Controlla che tutte le anagrafiche abbiano le categorie impostate in modo corretto per rimuovere il readOnly ai file.
Metodo pubblico | AllStateEquals | Controlla che tutte le anagrafiche siano nello stesso stato.
Metodo pubblico | GetAllAttachmentsDocuments | Ritorna una nuova lista contenente i documenti primari delle anagrafiche.
Metodo pubblico | GetAllPrimaryDocuments | Ritorna una nuova lista contenente tutti i documenti primari delle anagrafiche.
Metodo pubblico | GetAllSparePartsDocuments | Ritorna una nuova lista contenente i documenti di ricambio delle anagrafiche.
Metodo pubblico | GetDocuments(DedDocContextEnum) | Restituisce la lista dei documenti comuni a tutte le anagrafiche presenti. Restituisce sempre una lista inizializzata.
Metodo pubblico | GetDocuments(FuncDedDocContext, Boolean) | Restituisce la lista dei documenti comuni a tutte le anagrafiche presenti che soddisfano il controllo del criterio passato Restituisce sempre una lista inizializzata.
Metodo pubblico | GetStrictPrimaryDocuments | Ritorna una nuova lista contenente tutti i documenti primari senza ricambi delle anagrafiche.
Metodo pubblico | GetValue(DedDataStandardDataFields) | Restituisce il contenuto di un campo standard oppure null se non esiste. Se i valori contenuti all'interno delle anagrafiche sono differenti viene restituita la stringa "*DIV*".
Metodo pubblico | GetValue(String) | Restituisce il contenuto di un campo personalizzato oppure null se non esiste. Se i valori contenuti all'interno delle anagrafiche sono differenti viene restituita la stringa "*DIV*".
Metodo pubblico | Lock | Esegue il blocco di tutte le anagrafiche impostando il campo DEDLOCK con il nome dell'utente corrente. Utilizza il campo DEDROWVER attuale per effettuare il blocco in modo da non riuscire in caso di anagrafica già modificata. Questo metodo non rende dirty le anagrafiche ma bisogna poi sbloccarle attraverso UnLock() oppure con Update(). Se avviene un errore quelle precedentemente bloccate vengono ri-sbloccate.
Metodo pubblico | Refresh | Aggiorna le anagrafiche rileggendo le informazioni presenti nel Database. Effettua l'aggiornamento anche nelle anagrafiche dirty (imposta Dirty = false dopo l'aggiornamento). Aggiorna tutti i campi quindi anche il DEDROWVERSION.
Metodo pubblico | SetValue(DedDataStandardDataFields, Object) | Imposta un campo standard con un nuovo valore. Se il campo non esiste lo crea. La chiamata a questo metodo può causare la messa a Dirty delle anagrafiche, quando il campo da impostare è già presente nel dizionario interno ed il valore da impostare è differente da quello precedente oppure se è da creare. Oltre a porre le anagrafiche come Dirty viene anche tentato il lock delle anagrafiche modificate fino alla successiva chiamata del metodo Update() che imposta le anagrafiche come sbloccate e non Dirty oppure UnLock() che annulla le modifiche.
Metodo pubblico | SetValue(String, Object) | Imposta un campo personalizzato con un nuovo valore. Se il campo non esiste lo crea. La chiamata a questo metodo può causare la messa a Dirty delle anagrafiche, quando il campo da impostare è già presente nel dizionario interno ed il valore da impostare è differente da quello precedente oppure se è da creare. Oltre a porre le anagrafiche come Dirty viene anche tentato il lock delle anagrafiche modificate fino alla successiva chiamata del metodo Update() che imposta le anagrafiche come sbloccate e non Dirty oppure UnLock() che annulla le modifiche.
Metodo pubblico | SortByRevAlphabet | Ordina la lista secondo il revisionalalphabet.
Metodo pubblico | SortByVarAlphabet | Ordina la lista secondo VarAlphabet.
Metodo pubblico | UnLock | Sblocca tutte le anagrafiche solo se queste sono bloccate. Opzionalmente, se queste sono dirty, le aggiorna. Questo metodo la sblocca reimpostando il DEDROWVER alla versione precedente il bloccaggio ed effettua un Refresh() per riallineare i valori dell'anagrafica con il Database se l'anagrafica era Dirty.
Metodo pubblico | Validate | Restituisce se i valori presenti validano gli attributi della famiglia di appartenenza.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedDataList
Inizializza la lista con all'interno l'applicazione di appartenenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataList(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedDataList(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedDataList

Parametri

app DedNetApplication
Applicazione di appartenenza.
Vedi anche

Documentazione

Classe DedDataList
Namespace DedNet.Core


Proprietà di DedDataList

Il tipo DedDataList espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione di appartenenza.
Proprietà pubblica | DedType | Restituisce la famiglia genitore comune a tutte le anagrafiche presenti.
Proprietà pubblica | DedTypeBase | Restituisce la famiglia nella quale è stato archiviata questa anagrafica. Può restituire null se non appartiene ad alcuna famiglia.
Proprietà pubblica | Dirty | Restituisce true se anche solo una anagrafica è Dirty altrimenti false.
Proprietà pubblica | IsLocked | Restituisce se il record sia bloccato (dall'utente corrente o da un altro). Non legge dal Database, controlla solo se è compilato il campo DEDLOCK. Restituisce true se anche solo un'anagrafica risulta bloccata.
Proprietà pubblica | IsValid | Restituisce se i valori presenti validano gli attributi della famiglia di appartenenza.
Proprietà pubblica | Root | Restituisce la famiglia nella quale è stato archiviata questa anagrafica. Può restituire null se non appartiene ad alcuna famiglia.
Proprietà pubblica | UpdateRowVer | Restituisce true se anche solo una anagrafica è UpdateRowVer altrimenti false.
Torna su
Vedi anche

Documentazione

Classe DedDataList
Namespace DedNet.Core


Proprietà DedDataList.Application

Proprietà DedDataListApplication
Restituisce l'applicazione di appartenenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedNetApplication Application { get; }
Public ReadOnly Property Application As DedNetApplication
    Get
public:
property DedNetApplication^ Application {
    DedNetApplication^ get ();
}
member Application : DedNetApplication with get

Valore della proprietà

DedNetApplication
Vedi anche

Documentazione

Classe DedDataList
Namespace DedNet.Core


Proprietà DedDataList.DedType

Proprietà DedDataListDedType
Restituisce la famiglia genitore comune a tutte le anagrafiche presenti.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedType DedType { get; }
Public ReadOnly Property DedType As DedType
    Get
public:
virtual property DedType^ DedType {
    DedType^ get () sealed;
}
abstract DedType : DedType with get
override DedType : DedType with get

Valore della proprietà

DedType

Implementa

IDedDataDedType
Vedi anche

Documentazione

Classe DedDataList
Namespace DedNet.Core


Proprietà DedDataList.DedTypeBase

Proprietà DedDataListDedTypeBase
Restituisce la famiglia nella quale è stato archiviata questa anagrafica. Può restituire null se non appartiene ad alcuna famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeBase DedTypeBase { get; }
Public ReadOnly Property DedTypeBase As DedTypeBase
    Get
public:
virtual property DedTypeBase^ DedTypeBase {
    DedTypeBase^ get () sealed;
}
abstract DedTypeBase : DedTypeBase with get
override DedTypeBase : DedTypeBase with get

Valore della proprietà

DedTypeBase

Implementa

IDedTypeEditableDedTypeBase
Vedi anche

Documentazione

Classe DedDataList
Namespace DedNet.Core


Proprietà DedDataList.Dirty

Proprietà DedDataListDirty
Restituisce true se anche solo una anagrafica è Dirty altrimenti false.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Dirty { get; }
Public ReadOnly Property Dirty As Boolean
    Get
public:
virtual property bool Dirty {
    bool get () sealed;
}
abstract Dirty : bool with get
override Dirty : bool with get

Valore della proprietà

Boolean

Implementa

IDedDataDirty
Vedi anche

Documentazione

Classe DedDataList
Namespace DedNet.Core


Proprietà DedDataList.IsLocked

Proprietà DedDataListIsLocked
Restituisce se il record sia bloccato (dall'utente corrente o da un altro). Non legge dal Database, controlla solo se è compilato il campo DEDLOCK. Restituisce true se anche solo un'anagrafica risulta bloccata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsLocked { get; }
Public ReadOnly Property IsLocked As Boolean
    Get
public:
virtual property bool IsLocked {
    bool get () sealed;
}
abstract IsLocked : bool with get
override IsLocked : bool with get

Valore della proprietà

Boolean

Implementa

IDedDataIsLocked
Vedi anche

Documentazione

Classe DedDataList
Namespace DedNet.Core


Proprietà DedDataList.IsValid

Proprietà DedDataListIsValid
Restituisce se i valori presenti validano gli attributi della famiglia di appartenenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsValid { get; }
Public ReadOnly Property IsValid As Boolean
    Get
public:
virtual property bool IsValid {
    bool get () sealed;
}
abstract IsValid : bool with get
override IsValid : bool with get

Valore della proprietà

Boolean

Implementa

IDedTypeEditableIsValid
Vedi anche

Documentazione

Classe DedDataList
Namespace DedNet.Core


Proprietà DedDataList.Root

Proprietà DedDataListRoot
Restituisce la famiglia nella quale è stato archiviata questa anagrafica. Può restituire null se non appartiene ad alcuna famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeBase Root { get; }
Public ReadOnly Property Root As DedTypeBase
    Get
public:
virtual property DedTypeBase^ Root {
    DedTypeBase^ get () sealed;
}
abstract Root : DedTypeBase with get
override Root : DedTypeBase with get

Valore della proprietà

DedTypeBase

Implementa

IDedTypeEditableRoot
Vedi anche

Documentazione

Classe DedDataList
Namespace DedNet.Core


Proprietà DedDataList.UpdateRowVer

Proprietà DedDataListUpdateRowVer
Restituisce true se anche solo una anagrafica è UpdateRowVer altrimenti false.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool UpdateRowVer { get; set; }
Public Property UpdateRowVer As Boolean
    Get
    Set
public:
virtual property bool UpdateRowVer {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract UpdateRowVer : bool with get, set
override UpdateRowVer : bool with get, set

Valore della proprietà

Boolean

Implementa

IDedDataUpdateRowVer
Vedi anche

Documentazione

Classe DedDataList
Namespace DedNet.Core


Metodi di DedDataList

Il tipo DedDataList espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AllowRemoveFileReadOnly | Controlla che tutte le anagrafiche abbiano le categorie impostate in modo corretto per rimuovere il readOnly ai file.
Metodo pubblico | AllStateEquals | Controlla che tutte le anagrafiche siano nello stesso stato.
Metodo pubblico | GetAllAttachmentsDocuments | Ritorna una nuova lista contenente i documenti primari delle anagrafiche.
Metodo pubblico | GetAllPrimaryDocuments | Ritorna una nuova lista contenente tutti i documenti primari delle anagrafiche.
Metodo pubblico | GetAllSparePartsDocuments | Ritorna una nuova lista contenente i documenti di ricambio delle anagrafiche.
Metodo pubblico | GetDocuments(DedDocContextEnum) | Restituisce la lista dei documenti comuni a tutte le anagrafiche presenti. Restituisce sempre una lista inizializzata.
Metodo pubblico | GetDocuments(FuncDedDocContext, Boolean) | Restituisce la lista dei documenti comuni a tutte le anagrafiche presenti che soddisfano il controllo del criterio passato Restituisce sempre una lista inizializzata.
Metodo pubblico | GetStrictPrimaryDocuments | Ritorna una nuova lista contenente tutti i documenti primari senza ricambi delle anagrafiche.
Metodo pubblico | GetValue(DedDataStandardDataFields) | Restituisce il contenuto di un campo standard oppure null se non esiste. Se i valori contenuti all'interno delle anagrafiche sono differenti viene restituita la stringa "*DIV*".
Metodo pubblico | GetValue(String) | Restituisce il contenuto di un campo personalizzato oppure null se non esiste. Se i valori contenuti all'interno delle anagrafiche sono differenti viene restituita la stringa "*DIV*".
Metodo pubblico | Lock | Esegue il blocco di tutte le anagrafiche impostando il campo DEDLOCK con il nome dell'utente corrente. Utilizza il campo DEDROWVER attuale per effettuare il blocco in modo da non riuscire in caso di anagrafica già modificata. Questo metodo non rende dirty le anagrafiche ma bisogna poi sbloccarle attraverso UnLock() oppure con Update(). Se avviene un errore quelle precedentemente bloccate vengono ri-sbloccate.
Metodo pubblico | Refresh | Aggiorna le anagrafiche rileggendo le informazioni presenti nel Database. Effettua l'aggiornamento anche nelle anagrafiche dirty (imposta Dirty = false dopo l'aggiornamento). Aggiorna tutti i campi quindi anche il DEDROWVERSION.
Metodo pubblico | SetValue(DedDataStandardDataFields, Object) | Imposta un campo standard con un nuovo valore. Se il campo non esiste lo crea. La chiamata a questo metodo può causare la messa a Dirty delle anagrafiche, quando il campo da impostare è già presente nel dizionario interno ed il valore da impostare è differente da quello precedente oppure se è da creare. Oltre a porre le anagrafiche come Dirty viene anche tentato il lock delle anagrafiche modificate fino alla successiva chiamata del metodo Update() che imposta le anagrafiche come sbloccate e non Dirty oppure UnLock() che annulla le modifiche.
Metodo pubblico | SetValue(String, Object) | Imposta un campo personalizzato con un nuovo valore. Se il campo non esiste lo crea. La chiamata a questo metodo può causare la messa a Dirty delle anagrafiche, quando il campo da impostare è già presente nel dizionario interno ed il valore da impostare è differente da quello precedente oppure se è da creare. Oltre a porre le anagrafiche come Dirty viene anche tentato il lock delle anagrafiche modificate fino alla successiva chiamata del metodo Update() che imposta le anagrafiche come sbloccate e non Dirty oppure UnLock() che annulla le modifiche.
Metodo pubblico | SortByRevAlphabet | Ordina la lista secondo il revisionalalphabet.
Metodo pubblico | SortByVarAlphabet | Ordina la lista secondo VarAlphabet.
Metodo pubblico | UnLock | Sblocca tutte le anagrafiche solo se queste sono bloccate. Opzionalmente, se queste sono dirty, le aggiorna. Questo metodo la sblocca reimpostando il DEDROWVER alla versione precedente il bloccaggio ed effettua un Refresh() per riallineare i valori dell'anagrafica con il Database se l'anagrafica era Dirty.
Metodo pubblico | Validate | Restituisce se i valori presenti validano gli attributi della famiglia di appartenenza.
Torna su
Vedi anche

Documentazione

Classe DedDataList
Namespace DedNet.Core


Metodo DedDataList.AllowRemoveFileReadOnly

Metodo DedDataListAllowRemoveFileReadOnly
Controlla che tutte le anagrafiche abbiano le categorie impostate in modo corretto per rimuovere il readOnly ai file.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AllowRemoveFileReadOnly(
    DedData curData
)
Public Function AllowRemoveFileReadOnly (
    curData As DedData
) As Boolean
public:
bool AllowRemoveFileReadOnly(
    DedData^ curData
)
member AllowRemoveFileReadOnly :
        curData : DedData -> bool

Parametri

curData DedData
Anagrafica da non considerare

Valore di ritorno

Boolean
True se tutte le anagrafiche vanno bene altrimenti False.
Vedi anche

Documentazione

Classe DedDataList
Namespace DedNet.Core


Metodo DedDataList.AllStateEquals

Metodo DedDataListAllStateEquals
Controlla che tutte le anagrafiche siano nello stesso stato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AllStateEquals()
Public Function AllStateEquals As Boolean
public:
bool AllStateEquals()
member AllStateEquals : unit -> bool

Valore di ritorno

Boolean
True se tutte le anagrafiche sono nello stesso stato altrimenti false.
Vedi anche

Documentazione

Classe DedDataList
Namespace DedNet.Core


Metodo DedDataList.GetAllAttachmentsDocuments

Metodo DedDataListGetAllAttachmentsDocuments
Ritorna una nuova lista contenente i documenti primari delle anagrafiche.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocList GetAllAttachmentsDocuments()
Public Function GetAllAttachmentsDocuments As DedDocList
public:
DedDocList^ GetAllAttachmentsDocuments()
member GetAllAttachmentsDocuments : unit -> DedDocList

Valore di ritorno

DedDocList
Vedi anche

Documentazione

Classe DedDataList
Namespace DedNet.Core


Metodo DedDataList.GetAllPrimaryDocuments

Metodo DedDataListGetAllPrimaryDocuments
Ritorna una nuova lista contenente tutti i documenti primari delle anagrafiche.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocList GetAllPrimaryDocuments()
Public Function GetAllPrimaryDocuments As DedDocList
public:
DedDocList^ GetAllPrimaryDocuments()
member GetAllPrimaryDocuments : unit -> DedDocList

Valore di ritorno

DedDocList
Vedi anche

Documentazione

Classe DedDataList
Namespace DedNet.Core


Metodo DedDataList.GetAllSparePartsDocuments

Metodo DedDataListGetAllSparePartsDocuments
Ritorna una nuova lista contenente i documenti di ricambio delle anagrafiche.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocList GetAllSparePartsDocuments()
Public Function GetAllSparePartsDocuments As DedDocList
public:
DedDocList^ GetAllSparePartsDocuments()
member GetAllSparePartsDocuments : unit -> DedDocList

Valore di ritorno

DedDocList
Vedi anche

Documentazione

Classe DedDataList
Namespace DedNet.Core


Metodo DedDataList.GetDocuments

Metodo DedDataListGetDocuments
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | GetDocuments(DedDocContextEnum) | Restituisce la lista dei documenti comuni a tutte le anagrafiche presenti. Restituisce sempre una lista inizializzata.
Metodo pubblico | GetDocuments(FuncDedDocContext, Boolean) | Restituisce la lista dei documenti comuni a tutte le anagrafiche presenti che soddisfano il controllo del criterio passato Restituisce sempre una lista inizializzata.
Torna su
Vedi anche

Documentazione

Classe DedDataList
Namespace DedNet.Core


Metodo DedDataList.GetDocuments(DedDocContextEnum)

Metodo DedDataListGetDocuments(DedDocContextEnum)
Restituisce la lista dei documenti comuni a tutte le anagrafiche presenti. Restituisce sempre una lista inizializzata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocList GetDocuments(
    DedDocContextEnum ctx
)
Public Function GetDocuments (
    ctx As DedDocContextEnum
) As DedDocList
public:
DedDocList^ GetDocuments(
    DedDocContextEnum ctx
)
member GetDocuments :
        ctx : DedDocContextEnum -> DedDocList

Parametri

ctx DedDocContextEnum
Contesto del documento.

Valore di ritorno

DedDocList
Restituisce la lista di documenti comuni.
Eccezioni
Eccezione | Condizione
[!:DedRecordExceptionList] | Viene sollevata in caso di uno o più errori di inserimento dati.
Vedi anche

Documentazione

Classe DedDataList
Overload di GetDocuments
Namespace DedNet.Core


Metodo DedDataList.GetDocuments(Func<DedDocContext, Boolean>)

Metodo DedDataListGetDocuments(FuncDedDocContext, Boolean)
Restituisce la lista dei documenti comuni a tutte le anagrafiche presenti che soddisfano il controllo del criterio passato Restituisce sempre una lista inizializzata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocList GetDocuments(
    Func<DedDocContext, bool> contextChecker
)
Public Function GetDocuments (
    contextChecker As Func(Of DedDocContext, Boolean)
) As DedDocList
public:
DedDocList^ GetDocuments(
    Func<DedDocContext^, bool>^ contextChecker
)
member GetDocuments :
        contextChecker : Func<DedDocContext, bool> -> DedDocList

Parametri

contextChecker Func DedDocContext, Boolean
Delegate controller del contesto del documento.

Valore di ritorno

DedDocList
Restituisce la lista di documenti comuni.
Eccezioni
Eccezione | Condizione
[!:DedRecordExceptionList] | Viene sollevata in caso di uno o più errori di inserimento dati.
Vedi anche

Documentazione

Classe DedDataList
Overload di GetDocuments
Namespace DedNet.Core


Metodo DedDataList.GetStrictPrimaryDocuments

Metodo DedDataListGetStrictPrimaryDocuments
Ritorna una nuova lista contenente tutti i documenti primari senza ricambi delle anagrafiche.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocList GetStrictPrimaryDocuments()
Public Function GetStrictPrimaryDocuments As DedDocList
public:
DedDocList^ GetStrictPrimaryDocuments()
member GetStrictPrimaryDocuments : unit -> DedDocList

Valore di ritorno

DedDocList
Vedi anche

Documentazione

Classe DedDataList
Namespace DedNet.Core


Metodo DedDataList.GetValue

Metodo DedDataListGetValue
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | GetValue(DedDataStandardDataFields) | Restituisce il contenuto di un campo standard oppure null se non esiste. Se i valori contenuti all'interno delle anagrafiche sono differenti viene restituita la stringa "*DIV*".
Metodo pubblico | GetValue(String) | Restituisce il contenuto di un campo personalizzato oppure null se non esiste. Se i valori contenuti all'interno delle anagrafiche sono differenti viene restituita la stringa "*DIV*".
Torna su
Vedi anche

Documentazione

Classe DedDataList
Namespace DedNet.Core


Metodo DedDataList.GetValue(DedData.StandardDataFields)

Metodo DedDataListGetValue(DedDataStandardDataFields)
Restituisce il contenuto di un campo standard oppure null se non esiste. Se i valori contenuti all'interno delle anagrafiche sono differenti viene restituita la stringa "*DIV*".

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object GetValue(
    DedDataStandardDataFields stdfield
)
Public Function GetValue (
    stdfield As DedDataStandardDataFields
) As Object
public:
virtual Object^ GetValue(
    DedDataStandardDataFields stdfield
) sealed
abstract GetValue :
        stdfield : DedDataStandardDataFields -> Object
override GetValue :
        stdfield : DedDataStandardDataFields -> Object

Parametri

stdfield DedDataStandardDataFields
Campo standard del quale avere il contenuto.

Valore di ritorno

Object

Implementa

IDedTypeEditableGetValue(DedDataStandardDataFields)
Vedi anche

Documentazione

Classe DedDataList
Overload di GetValue
Namespace DedNet.Core


Metodo DedDataList.GetValue(String)

Metodo DedDataListGetValue(String)
Restituisce il contenuto di un campo personalizzato oppure null se non esiste. Se i valori contenuti all'interno delle anagrafiche sono differenti viene restituita la stringa "*DIV*".

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object GetValue(
    string persfield
)
Public Function GetValue (
    persfield As String
) As Object
public:
virtual Object^ GetValue(
    String^ persfield
) sealed
abstract GetValue :
        persfield : string -> Object
override GetValue :
        persfield : string -> Object

Parametri

persfield String
Nome del campo personalizzato del quale avere il contenuto.

Valore di ritorno

Object

Implementa

IDedEditableGetValue(String)
Vedi anche

Documentazione

Classe DedDataList
Overload di GetValue
Namespace DedNet.Core


Metodo DedDataList.Lock

Metodo DedDataListLock
Esegue il blocco di tutte le anagrafiche impostando il campo DEDLOCK con il nome dell'utente corrente. Utilizza il campo DEDROWVER attuale per effettuare il blocco in modo da non riuscire in caso di anagrafica già modificata. Questo metodo non rende dirty le anagrafiche ma bisogna poi sbloccarle attraverso UnLock() oppure con Update(). Se avviene un errore quelle precedentemente bloccate vengono ri-sbloccate.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Lock(
    bool ignoreState = false,
    bool ignoreDocStatus = false
)
Public Sub Lock (
    Optional ignoreState As Boolean = false,
    Optional ignoreDocStatus As Boolean = false
)
public:
virtual void Lock(
    bool ignoreState = false,
    bool ignoreDocStatus = false
) sealed
abstract Lock :
        ?ignoreState : bool *
        ?ignoreDocStatus : bool
(* Defaults:
        let _ignoreState = defaultArg ignoreState false
        let _ignoreDocStatus = defaultArg ignoreDocStatus false
*)
-> unit
override Lock :
        ?ignoreState : bool *
        ?ignoreDocStatus : bool
(* Defaults:
        let _ignoreState = defaultArg ignoreState false
        let _ignoreDocStatus = defaultArg ignoreDocStatus false
*)
-> unit

Parametri

ignoreState Boolean (Optional)
ignoreDocStatus Boolean (Optional)

Implementa

IDedDataLock(Boolean, Boolean)
Eccezioni
Eccezione | Condizione
QsException | Il record risulta bloccato da un altro utente.
QsException | Errore verificatosi nell'esecuzione dell'istruzione Update.
ArgumentNullException | Parametro mancante.
Vedi anche

Documentazione

Classe DedDataList
Namespace DedNet.Core


Metodo DedDataList.Refresh

Metodo DedDataListRefresh
Aggiorna le anagrafiche rileggendo le informazioni presenti nel Database. Effettua l'aggiornamento anche nelle anagrafiche dirty (imposta Dirty = false dopo l'aggiornamento). Aggiorna tutti i campi quindi anche il DEDROWVERSION.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Refresh()
Public Sub Refresh
public:
void Refresh()
member Refresh : unit -> unit
Eccezioni
Eccezione | Condizione
[!:DedRecordExceptionList] | Viene sollevata in caso di uno o più errori di aggiornamento.
Vedi anche

Documentazione

Classe DedDataList
Namespace DedNet.Core


Metodo DedDataList.SetValue

Metodo DedDataListSetValue
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | SetValue(DedDataStandardDataFields, Object) | Imposta un campo standard con un nuovo valore. Se il campo non esiste lo crea. La chiamata a questo metodo può causare la messa a Dirty delle anagrafiche, quando il campo da impostare è già presente nel dizionario interno ed il valore da impostare è differente da quello precedente oppure se è da creare. Oltre a porre le anagrafiche come Dirty viene anche tentato il lock delle anagrafiche modificate fino alla successiva chiamata del metodo Update() che imposta le anagrafiche come sbloccate e non Dirty oppure UnLock() che annulla le modifiche.
Metodo pubblico | SetValue(String, Object) | Imposta un campo personalizzato con un nuovo valore. Se il campo non esiste lo crea. La chiamata a questo metodo può causare la messa a Dirty delle anagrafiche, quando il campo da impostare è già presente nel dizionario interno ed il valore da impostare è differente da quello precedente oppure se è da creare. Oltre a porre le anagrafiche come Dirty viene anche tentato il lock delle anagrafiche modificate fino alla successiva chiamata del metodo Update() che imposta le anagrafiche come sbloccate e non Dirty oppure UnLock() che annulla le modifiche.
Torna su
Vedi anche

Documentazione

Classe DedDataList
Namespace DedNet.Core


Metodo DedDataList.SetValue(DedData.StandardDataFields, Object)

Metodo DedDataListSetValue(DedDataStandardDataFields, Object)
Imposta un campo standard con un nuovo valore. Se il campo non esiste lo crea. La chiamata a questo metodo può causare la messa a Dirty delle anagrafiche, quando il campo da impostare è già presente nel dizionario interno ed il valore da impostare è differente da quello precedente oppure se è da creare. Oltre a porre le anagrafiche come Dirty viene anche tentato il lock delle anagrafiche modificate fino alla successiva chiamata del metodo Update() che imposta le anagrafiche come sbloccate e non Dirty oppure UnLock() che annulla le modifiche.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetValue(
    DedDataStandardDataFields stdfield,
    Object Value
)
Public Sub SetValue (
    stdfield As DedDataStandardDataFields,
    Value As Object
)
public:
virtual void SetValue(
    DedDataStandardDataFields stdfield,
    Object^ Value
) sealed
abstract SetValue :
        stdfield : DedDataStandardDataFields *
        Value : Object -> unit
override SetValue :
        stdfield : DedDataStandardDataFields *
        Value : Object -> unit

Parametri

stdfield DedDataStandardDataFields
Campo standard da impostare.
Value Object
Valore da impostare.

Implementa

IDedTypeEditableSetValue(DedDataStandardDataFields, Object)
Eccezioni
Eccezione | Condizione
QsException | Il record risulta bloccato da un altro utente.
QsException | Questa eccezione viene lanciata se l'anagrafica è stata cancellata.
ArgumentNullException | Parametro mancante.
Vedi anche

Documentazione

Classe DedDataList
Overload di SetValue
Namespace DedNet.Core


Metodo DedDataList.SetValue(String, Object)

Metodo DedDataListSetValue(String, Object)
Imposta un campo personalizzato con un nuovo valore. Se il campo non esiste lo crea. La chiamata a questo metodo può causare la messa a Dirty delle anagrafiche, quando il campo da impostare è già presente nel dizionario interno ed il valore da impostare è differente da quello precedente oppure se è da creare. Oltre a porre le anagrafiche come Dirty viene anche tentato il lock delle anagrafiche modificate fino alla successiva chiamata del metodo Update() che imposta le anagrafiche come sbloccate e non Dirty oppure UnLock() che annulla le modifiche.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetValue(
    string persfield,
    Object Value
)
Public Sub SetValue (
    persfield As String,
    Value As Object
)
public:
virtual void SetValue(
    String^ persfield,
    Object^ Value
) sealed
abstract SetValue :
        persfield : string *
        Value : Object -> unit
override SetValue :
        persfield : string *
        Value : Object -> unit

Parametri

persfield String
Nome del campo personalizzato da impostare.
Value Object
Valore da impostare.

Implementa

IDedEditableSetValue(String, Object)
Eccezioni
Eccezione | Condizione
QsException | Il record risulta bloccato da un altro utente.
QsException | Questa eccezione viene lanciata se l'anagrafica è stata cancellata.
ArgumentNullException | Parametro mancante.
Vedi anche

Documentazione

Classe DedDataList
Overload di SetValue
Namespace DedNet.Core


Metodo DedDataList.SortByRevAlphabet

Metodo DedDataListSortByRevAlphabet
Ordina la lista secondo il revisionalalphabet.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SortByRevAlphabet()
Public Sub SortByRevAlphabet
public:
void SortByRevAlphabet()
member SortByRevAlphabet : unit -> unit
Vedi anche

Documentazione

Classe DedDataList
Namespace DedNet.Core


Metodo DedDataList.SortByVarAlphabet

Metodo DedDataListSortByVarAlphabet
Ordina la lista secondo VarAlphabet.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SortByVarAlphabet()
Public Sub SortByVarAlphabet
public:
void SortByVarAlphabet()
member SortByVarAlphabet : unit -> unit
Vedi anche

Documentazione

Classe DedDataList
Namespace DedNet.Core


Metodo DedDataList.UnLock

Metodo DedDataListUnLock
Sblocca tutte le anagrafiche solo se queste sono bloccate. Opzionalmente, se queste sono dirty, le aggiorna. Questo metodo la sblocca reimpostando il DEDROWVER alla versione precedente il bloccaggio ed effettua un Refresh() per riallineare i valori dell'anagrafica con il Database se l'anagrafica era Dirty.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void UnLock(
    bool DiscardChanges
)
Public Sub UnLock (
    DiscardChanges As Boolean
)
public:
virtual void UnLock(
    bool DiscardChanges
) sealed
abstract UnLock :
        DiscardChanges : bool -> unit
override UnLock :
        DiscardChanges : bool -> unit

Parametri

DiscardChanges Boolean

Implementa

IDedDataUnLock(Boolean)
Eccezioni
Eccezione | Condizione
[!:DedRecordExceptionList] | Viene sollevata in caso di uno o più errori.
Vedi anche

Documentazione

Classe DedDataList
Namespace DedNet.Core


Metodo DedDataList.Validate

Metodo DedDataListValidate
Restituisce se i valori presenti validano gli attributi della famiglia di appartenenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Validate(
    bool creating,
    bool revisioning,
    out string error
)
Public Function Validate (
    creating As Boolean,
    revisioning As Boolean,
    <OutAttribute> ByRef error As String
) As Boolean
public:
virtual bool Validate(
    bool creating,
    bool revisioning,
    [OutAttribute] String^% error
) sealed
abstract Validate :
        creating : bool *
        revisioning : bool *
        error : string byref -> bool
override Validate :
        creating : bool *
        revisioning : bool *
        error : string byref -> bool

Parametri

creating Boolean
revisioning Boolean
error String

Valore di ritorno

Boolean

Implementa

IDedTypeEditableValidate(Boolean, Boolean, String)
Vedi anche

Documentazione

Classe DedDataList
Namespace DedNet.Core


Classe DedDataManager
Gestisce la creazione e l'aggiornamento delle anagrafiche, nonché i legami con i documenti.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedDataManager

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedDataManager
Public Class DedDataManager
public ref class DedDataManager
type DedDataManager = class end

Il tipo DedDataManager espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ApplyRules(IDedEditable) | Applicare le regole sul'anagrafica passata.
Metodo pubblico | ApplyRules(IDedEditable, Boolean, DedTypeBase) | Applicare le regole sul'anagrafica passata.
Metodo pubblico | CreateData(String, DictionaryString, Object) | Crea una nuova anagrafica e la ritorna.
Metodo pubblico | CreateData(String, String, String, String, String, DictionaryString, Object, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean) | Crea una nuova anagrafica e la ritorna.
Metodo pubblico | CreateData(String, String, String, String, String, DictionaryString, Object, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, String) | Crea una nuova anagrafica e la ritorna.
Metodo pubblico | FindByDbIndex | Restituisce l'anagrafica con il GUID richiesto. Restituisce null se non trova alcun record nel Database.
Metodo pubblico | GetAlternativeData | Ritorna l'elenco delle anagrafiche alternative a quella specificata in ingresso.
Metodo pubblico | RemoveAlternativeData(DedData) | Rimuove tutti i legami di codici alternativi che utilizzano questa anagrafica.
Metodo pubblico | RemoveAlternativeData(DedData, DedData) | Associa, all'anagrafica specificata in ingresso , i codici alternativi che può assumere.
Metodo pubblico | SetAlternativeData | Associa come codici alternativi le 2 anagrafiche specificate in ingresso.
Metodo pubblico | UpdataDataAttrs | Aggiorna gli attributi di anagrafica. La funzione filtra l'eventuale settaggio di dedid, dedrev. In caso di qualsiasi errore non appporta modifiche all'anagrafica
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Metodi di DedDataManager

Il tipo DedDataManager espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ApplyRules(IDedEditable) | Applicare le regole sul'anagrafica passata.
Metodo pubblico | ApplyRules(IDedEditable, Boolean, DedTypeBase) | Applicare le regole sul'anagrafica passata.
Metodo pubblico | CreateData(String, DictionaryString, Object) | Crea una nuova anagrafica e la ritorna.
Metodo pubblico | CreateData(String, String, String, String, String, DictionaryString, Object, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean) | Crea una nuova anagrafica e la ritorna.
Metodo pubblico | CreateData(String, String, String, String, String, DictionaryString, Object, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, String) | Crea una nuova anagrafica e la ritorna.
Metodo pubblico | FindByDbIndex | Restituisce l'anagrafica con il GUID richiesto. Restituisce null se non trova alcun record nel Database.
Metodo pubblico | GetAlternativeData | Ritorna l'elenco delle anagrafiche alternative a quella specificata in ingresso.
Metodo pubblico | RemoveAlternativeData(DedData) | Rimuove tutti i legami di codici alternativi che utilizzano questa anagrafica.
Metodo pubblico | RemoveAlternativeData(DedData, DedData) | Associa, all'anagrafica specificata in ingresso , i codici alternativi che può assumere.
Metodo pubblico | SetAlternativeData | Associa come codici alternativi le 2 anagrafiche specificate in ingresso.
Metodo pubblico | UpdataDataAttrs | Aggiorna gli attributi di anagrafica. La funzione filtra l'eventuale settaggio di dedid, dedrev. In caso di qualsiasi errore non appporta modifiche all'anagrafica
Torna su
Vedi anche

Documentazione

Classe DedDataManager
Namespace DedNet.Core


Metodo DedDataManager.ApplyRules

Metodo DedDataManagerApplyRules
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | ApplyRules(IDedEditable) | Applicare le regole sul'anagrafica passata.
Metodo pubblico | ApplyRules(IDedEditable, Boolean, DedTypeBase) | Applicare le regole sul'anagrafica passata.
Torna su
Vedi anche

Documentazione

Classe DedDataManager
Namespace DedNet.Core


Metodo DedDataManager.ApplyRules(IDedEditable)

Metodo DedDataManagerApplyRules(IDedEditable)
Applicare le regole sul'anagrafica passata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ApplyRules(
    IDedEditable idata
)
Public Sub ApplyRules (
    idata As IDedEditable
)
public:
void ApplyRules(
    IDedEditable^ idata
)
member ApplyRules :
        idata : IDedEditable -> unit

Parametri

idata IDedEditable
Anagrafica sulla quale applicare le regole.
Vedi anche

Documentazione

Classe DedDataManager
Overload di ApplyRules
Namespace DedNet.Core


Metodo DedDataManager.ApplyRules(IDedEditable, Boolean, DedTypeBase)

Metodo DedDataManagerApplyRules(IDedEditable, Boolean, DedTypeBase)
Applicare le regole sul'anagrafica passata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ApplyRules(
    IDedEditable idata,
    bool asInDb,
    DedTypeBase dedtype = null
)
Public Sub ApplyRules (
    idata As IDedEditable,
    asInDb As Boolean,
    Optional dedtype As DedTypeBase = Nothing
)
public:
void ApplyRules(
    IDedEditable^ idata,
    bool asInDb,
    DedTypeBase^ dedtype = nullptr
)
member ApplyRules :
        idata : IDedEditable *
        asInDb : bool *
        ?dedtype : DedTypeBase
(* Defaults:
        let _dedtype = defaultArg dedtype null
*)
-> unit

Parametri

idata IDedEditable
Anagrafica sulla quale applicare le regole.
asInDb Boolean
Indica se considerare l'anagrafica come nel database in fase di applicazione delle regole
dedtype DedTypeBase (Optional)
Eventuale famiglia dalla quale prelevare le regole (usata se non si riesce a leggerla dall'anagrafica)
Vedi anche

Documentazione

Classe DedDataManager
Overload di ApplyRules
Namespace DedNet.Core


Metodo DedDataManager.CreateData

Metodo DedDataManagerCreateData
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | CreateData(String, DictionaryString, Object) | Crea una nuova anagrafica e la ritorna.
Metodo pubblico | CreateData(String, String, String, String, String, DictionaryString, Object, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean) | Crea una nuova anagrafica e la ritorna.
Metodo pubblico | CreateData(String, String, String, String, String, DictionaryString, Object, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, String) | Crea una nuova anagrafica e la ritorna.
Torna su
Vedi anche

Documentazione

Classe DedDataManager
Namespace DedNet.Core


Metodo DedDataManager.CreateData(String, Dictionary<String, Object>)

Metodo DedDataManagerCreateData(String, DictionaryString, Object)
Crea una nuova anagrafica e la ritorna.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData CreateData(
    string dbPath,
    Dictionary<string, Object> attributes
)
Public Function CreateData (
    dbPath As String,
    attributes As Dictionary(Of String, Object)
) As DedData
public:
DedData^ CreateData(
    String^ dbPath,
    Dictionary<String^, Object^>^ attributes
)
member CreateData :
        dbPath : string *
        attributes : Dictionary<string, Object> -> DedData

Parametri

dbPath String
Path di salvataggio dell'anagrafica (obbligatorio).
attributes Dictionary String, Object
Dizionario contentente gli attributi da impostare.

Valore di ritorno

DedData
Vedi anche

Documentazione

Classe DedDataManager
Overload di CreateData
Namespace DedNet.Core


Metodo DedDataManager.CreateData(String, String, String, String, String, Dictionary<String, Object>, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean)

Metodo DedDataManagerCreateData(String, String, String, String, String, DictionaryString, Object, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean)
Crea una nuova anagrafica e la ritorna.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData CreateData(
    string dbPath,
    string progr,
    string infoUser,
    string format,
    string dedrev,
    Dictionary<string, Object> attributes,
    bool forcedata,
    bool useui,
    bool silent,
    bool isVar,
    bool notIncreaseProgr,
    bool validateAttrs
)
Public Function CreateData (
    dbPath As String,
    progr As String,
    infoUser As String,
    format As String,
    dedrev As String,
    attributes As Dictionary(Of String, Object),
    forcedata As Boolean,
    useui As Boolean,
    silent As Boolean,
    isVar As Boolean,
    notIncreaseProgr As Boolean,
    validateAttrs As Boolean
) As DedData
public:
DedData^ CreateData(
    String^ dbPath,
    String^ progr,
    String^ infoUser,
    String^ format,
    String^ dedrev,
    Dictionary<String^, Object^>^ attributes,
    bool forcedata,
    bool useui,
    bool silent,
    bool isVar,
    bool notIncreaseProgr,
    bool validateAttrs
)
member CreateData :
        dbPath : string *
        progr : string *
        infoUser : string *
        format : string *
        dedrev : string *
        attributes : Dictionary<string, Object> *
        forcedata : bool *
        useui : bool *
        silent : bool *
        isVar : bool *
        notIncreaseProgr : bool *
        validateAttrs : bool -> DedData

Parametri

dbPath String
Path di salvataggio dell'anagrafica (obbligatorio).
progr String
Progressivo.
infoUser String
Eventuale tassello utente.
format String
Informazione sul formato.
dedrev String
Revisione dell'anagrafica.
attributes Dictionary String, Object
Dizionario contentente gli attributi da impostare.
forcedata Boolean
Indica se utilizzare gli attributi passati invece di calcolarli.
useui Boolean
Comando lanciato con interfaccia grafica.
silent Boolean
Comando lanciato silent.
isVar Boolean
Indica se è un salva variante.
notIncreaseProgr Boolean
Indica di non incrementare il progressivo.
validateAttrs Boolean
Indica se validare gli attributi.

Valore di ritorno

DedData
Vedi anche

Documentazione

Classe DedDataManager
Overload di CreateData
Namespace DedNet.Core


Metodo DedDataManager.CreateData(String, String, String, String, String, Dictionary<String, Object>, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, String)

Metodo DedDataManagerCreateData(String, String, String, String, String, DictionaryString, Object, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, String)
Crea una nuova anagrafica e la ritorna.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData CreateData(
    string dbPath,
    string progr,
    string infoUser,
    string format,
    string dedrev,
    Dictionary<string, Object> attributes,
    bool forcedata,
    bool useui,
    bool silent,
    bool isVar,
    bool notIncreaseProgr,
    bool validateAttrs,
    string var
)
Public Function CreateData (
    dbPath As String,
    progr As String,
    infoUser As String,
    format As String,
    dedrev As String,
    attributes As Dictionary(Of String, Object),
    forcedata As Boolean,
    useui As Boolean,
    silent As Boolean,
    isVar As Boolean,
    notIncreaseProgr As Boolean,
    validateAttrs As Boolean,
    var As String
) As DedData
public:
DedData^ CreateData(
    String^ dbPath,
    String^ progr,
    String^ infoUser,
    String^ format,
    String^ dedrev,
    Dictionary<String^, Object^>^ attributes,
    bool forcedata,
    bool useui,
    bool silent,
    bool isVar,
    bool notIncreaseProgr,
    bool validateAttrs,
    String^ var
)
member CreateData :
        dbPath : string *
        progr : string *
        infoUser : string *
        format : string *
        dedrev : string *
        attributes : Dictionary<string, Object> *
        forcedata : bool *
        useui : bool *
        silent : bool *
        isVar : bool *
        notIncreaseProgr : bool *
        validateAttrs : bool *
        var : string -> DedData

Parametri

dbPath String
Path di salvataggio dell'anagrafica (obbligatorio).
progr String
Progressivo.
infoUser String
Eventuale tassello utente.
format String
Informazione sul formato.
dedrev String
Revisione dell'anagrafica.
attributes Dictionary String, Object
Dizionario contentente gli attributi da impostare.
forcedata Boolean
Indica se utilizzare gli attributi passati invece di calcolarli.
useui Boolean
Comando lanciato con interfaccia grafica.
silent Boolean
Comando lanciato silent.
isVar Boolean
Indica se è un salva variante.
notIncreaseProgr Boolean
Indica di non incrementare il progressivo.
validateAttrs Boolean
Indica se validare gli attributi.
var String
Valore del campo variante automatica

Valore di ritorno

DedData
Vedi anche

Documentazione

Classe DedDataManager
Overload di CreateData
Namespace DedNet.Core


Metodo DedDataManager.FindByDbIndex

Metodo DedDataManagerFindByDbIndex
Restituisce l'anagrafica con il GUID richiesto. Restituisce null se non trova alcun record nel Database.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData FindByDbIndex(
    string dbindex
)
Public Function FindByDbIndex (
    dbindex As String
) As DedData
public:
DedData^ FindByDbIndex(
    String^ dbindex
)
member FindByDbIndex :
        dbindex : string -> DedData

Parametri

dbindex String
GUID per il quale reperire le anagrafiche.

Valore di ritorno

DedData
Eccezioni
Eccezione | Condizione
QsException | Errore verificatosi durante la lettura del record.
ArgumentNullException | Parametro mancante.
Vedi anche

Documentazione

Classe DedDataManager
Namespace DedNet.Core


Metodo DedDataManager.GetAlternativeData

Metodo DedDataManagerGetAlternativeData
Ritorna l'elenco delle anagrafiche alternative a quella specificata in ingresso.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataList GetAlternativeData(
    DedData data
)
Public Function GetAlternativeData (
    data As DedData
) As DedDataList
public:
DedDataList^ GetAlternativeData(
    DedData^ data
)
member GetAlternativeData :
        data : DedData -> DedDataList

Parametri

data DedData

Valore di ritorno

DedDataList
Vedi anche

Documentazione

Classe DedDataManager
Namespace DedNet.Core


Metodo DedDataManager.RemoveAlternativeData

Metodo DedDataManagerRemoveAlternativeData
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | RemoveAlternativeData(DedData) | Rimuove tutti i legami di codici alternativi che utilizzano questa anagrafica.
Metodo pubblico | RemoveAlternativeData(DedData, DedData) | Associa, all'anagrafica specificata in ingresso , i codici alternativi che può assumere.
Torna su
Vedi anche

Documentazione

Classe DedDataManager
Namespace DedNet.Core


Metodo DedDataManager.RemoveAlternativeData(DedData)

Metodo DedDataManagerRemoveAlternativeData(DedData)
Rimuove tutti i legami di codici alternativi che utilizzano questa anagrafica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void RemoveAlternativeData(
    DedData data
)
Public Sub RemoveAlternativeData (
    data As DedData
)
public:
void RemoveAlternativeData(
    DedData^ data
)
member RemoveAlternativeData :
        data : DedData -> unit

Parametri

data DedData
Vedi anche

Documentazione

Classe DedDataManager
Overload di RemoveAlternativeData
Namespace DedNet.Core


Metodo DedDataManager.RemoveAlternativeData(DedData, DedData)

Metodo DedDataManagerRemoveAlternativeData(DedData, DedData)
Associa, all'anagrafica specificata in ingresso , i codici alternativi che può assumere.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void RemoveAlternativeData(
    DedData data1,
    DedData data2
)
Public Sub RemoveAlternativeData (
    data1 As DedData,
    data2 As DedData
)
public:
void RemoveAlternativeData(
    DedData^ data1,
    DedData^ data2
)
member RemoveAlternativeData :
        data1 : DedData *
        data2 : DedData -> unit

Parametri

data1 DedData
Anagrafica di partenza.
data2 DedData
Anagrafica che si vuole associare a quella di partenza.
Vedi anche

Documentazione

Classe DedDataManager
Overload di RemoveAlternativeData
Namespace DedNet.Core


Metodo DedDataManager.SetAlternativeData

Metodo DedDataManagerSetAlternativeData
Associa come codici alternativi le 2 anagrafiche specificate in ingresso.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetAlternativeData(
    DedData data1,
    DedData data2
)
Public Sub SetAlternativeData (
    data1 As DedData,
    data2 As DedData
)
public:
void SetAlternativeData(
    DedData^ data1,
    DedData^ data2
)
member SetAlternativeData :
        data1 : DedData *
        data2 : DedData -> unit

Parametri

data1 DedData
data2 DedData
Vedi anche

Documentazione

Classe DedDataManager
Namespace DedNet.Core


Metodo DedDataManager.UpdataDataAttrs

Metodo DedDataManagerUpdataDataAttrs
Aggiorna gli attributi di anagrafica. La funzione filtra l'eventuale settaggio di dedid, dedrev. In caso di qualsiasi errore non appporta modifiche all'anagrafica

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void UpdataDataAttrs(
    DedData data,
    Dictionary<string, Object> attrs,
    bool ignoreState,
    bool ignoreDocStatus,
    bool updateLight,
    bool applyRule
)
Public Sub UpdataDataAttrs (
    data As DedData,
    attrs As Dictionary(Of String, Object),
    ignoreState As Boolean,
    ignoreDocStatus As Boolean,
    updateLight As Boolean,
    applyRule As Boolean
)
public:
void UpdataDataAttrs(
    DedData^ data,
    Dictionary<String^, Object^>^ attrs,
    bool ignoreState,
    bool ignoreDocStatus,
    bool updateLight,
    bool applyRule
)
member UpdataDataAttrs :
        data : DedData *
        attrs : Dictionary<string, Object> *
        ignoreState : bool *
        ignoreDocStatus : bool *
        updateLight : bool *
        applyRule : bool -> unit

Parametri

data DedData
Anagrafica da aggiornare
attrs Dictionary String, Object
LuaTable contenente prompt e valori degli attributi
ignoreState Boolean
ignoreDocStatus Boolean
updateLight Boolean
applyRule Boolean

Valore di ritorno

Ritorna true se riesce. In caso contrario imposta il LastException.
Vedi anche

Documentazione

Classe DedDataManager
Namespace DedNet.Core


Classe DedDataPart
Classe che implementa IDedData ed è utilizzata per manipolare la copia dell'anagrafica DedData oppure in ogni caso in cui serva un IDedData senza che l'anagrafica esista nel Database o la si voglia bloccare durante la modifica.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedDataPart

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedDataPart : IDedData,
    IDedTypeEditable, IDedEditable, ICloneable
Public Class DedDataPart
    Implements IDedData, IDedTypeEditable, IDedEditable, ICloneable
public ref class DedDataPart : IDedData,
    IDedTypeEditable, IDedEditable, ICloneable
type DedDataPart =
    class
        interface IDedData
        interface IDedTypeEditable
        interface IDedEditable
        interface ICloneable
    end

Il tipo DedDataPart espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedDataPart(DedNetApplication) | Costruttore che inizializza soltanto il dizionario interno.
Metodo pubblico | DedDataPart(DedNetApplication, DictionaryString, Object) | Costruttore che inizializza il dizionario interno copiando i valori dal dizionario passato come argomento.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione di appartenenza.
Proprietà pubblica | Attributes | Attributi contenuti nel DedDataPart
Proprietà pubblica | Count | Restituisce sempre 1 cioè il numero di anagrafiche rappresentate da questo oggetto.
Proprietà pubblica | DedType | Cerca di ricavare la famiglia alla quale può appartenere l'oggetto, cercando all'interno un campo DBPATH oppure interrogando il Datbase tramite DedId e DedRev.
Proprietà pubblica | DedTypeBase | Restituisce la famiglia nella quale è stato archiviata questa anagrafica. Può restituire null se non appartiene ad alcuna famiglia.
Proprietà pubblica | Dirty | Restituisce se l'oggetto sia stato modificato dopo l'inizializzazione.
Proprietà pubblica | IsLocked | Restituisce se sia stato bloccato l'oggetto: Internamente viene solo memorizzato lo stato ma il blocco viene ignorato.
Proprietà pubblica | IsValid | Restituisce se i valori presenti validano gli attributi della famiglia di appartenenza.
Proprietà pubblica | Item | Restituisce o imposta il valore tramite la chiave corrispondente.
Proprietà pubblica | Root | Restituisce la famiglia nella quale è stato archiviata questa anagrafica. Può restituire null se non appartiene ad alcuna famiglia.
Proprietà pubblica | UpdateRowVer | Restituisce se aggiornare il ROWVER dell'anagrafica
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | BeginIgnoreDirty | Indica all'oggetto di non diventare Dirty fino alla successiva chiamata del metodo EndIgnoreDirty(), da utilizzare in coppia a questo.
Metodo pubblico | Clone | Clona l'oggetto (copiando anche il dizionario interno) e lo restituisce.
Metodo pubblico | EndIgnoreDirty | Indica all'oggetto di tornare ad impostare a Dirty l'anagrafica. Da utilizzare in coppia con BeginIgnoreDirty().
Metodo pubblico | GetAttrsFromCategory(DedCateg) | Ritorna la lista di attributi visibili dalla famiglia che appartengono alla categoria passata.
Metodo pubblico | GetAttrsFromCategory(String) | Ritorna la lista di attributi visibili dalla famiglia che appartengono alla categoria passata.
Metodo pubblico | GetValue(DedDataStandardDataFields) | Restituisce il contenuto di uno dei campi standard oppure null se non è presente.
Metodo pubblico | GetValue(String) | Restituisce il contenuto di un campo personalizzato oppure null se non esiste.
Metodo pubblico | Lock | Imposta come bloccato l'oggetto: Memorizza lo stato ma non effettua alcun blocco.
Metodo pubblico | SetValue(DedDataStandardDataFields, Object) | Imposta un campo standard con un nuovo valore.
Metodo pubblico | SetValue(String, Object) | Imposta un campo personalizzato con un nuovo valore.
Metodo pubblico | UnLock | Sblocca l'oggetto o meglio lo imposta come sbloccato visto che non viene effettuata alcuna operazione sul Database. Il parametro viene ignorato.
Metodo pubblico | Validate | Restituisce se i valori presenti validano gli attributi della famiglia di appartenenza.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedDataPart
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | DedDataPart(DedNetApplication) | Costruttore che inizializza soltanto il dizionario interno.
Metodo pubblico | DedDataPart(DedNetApplication, DictionaryString, Object) | Costruttore che inizializza il dizionario interno copiando i valori dal dizionario passato come argomento.
Torna su
Vedi anche

Documentazione

Classe DedDataPart
Namespace DedNet.Core


Costruttore DedDataPart(DedNetApplication)
Costruttore che inizializza soltanto il dizionario interno.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataPart(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedDataPart(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedDataPart

Parametri

app DedNetApplication
Applicazione di appartenenza.
Vedi anche

Documentazione

Classe DedDataPart
Overload di DedDataPart
Namespace DedNet.Core


Costruttore DedDataPart(DedNetApplication, Dictionary<String, Object>)

Costruttore DedDataPart(DedNetApplication, DictionaryString, Object)
Costruttore che inizializza il dizionario interno copiando i valori dal dizionario passato come argomento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataPart(
    DedNetApplication app,
    Dictionary<string, Object> args
)
Public Sub New (
    app As DedNetApplication,
    args As Dictionary(Of String, Object)
)
public:
DedDataPart(
    DedNetApplication^ app,
    Dictionary<String^, Object^>^ args
)
new :
        app : DedNetApplication *
        args : Dictionary<string, Object> -> DedDataPart

Parametri

app DedNetApplication
Applicazione di appartenenza.
args Dictionary String, Object
Dizionario da utilizzare per inizializzare l'oggetto.
Vedi anche

Documentazione

Classe DedDataPart
Overload di DedDataPart
Namespace DedNet.Core


Proprietà di DedDataPart

Il tipo DedDataPart espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione di appartenenza.
Proprietà pubblica | Attributes | Attributi contenuti nel DedDataPart
Proprietà pubblica | Count | Restituisce sempre 1 cioè il numero di anagrafiche rappresentate da questo oggetto.
Proprietà pubblica | DedType | Cerca di ricavare la famiglia alla quale può appartenere l'oggetto, cercando all'interno un campo DBPATH oppure interrogando il Datbase tramite DedId e DedRev.
Proprietà pubblica | DedTypeBase | Restituisce la famiglia nella quale è stato archiviata questa anagrafica. Può restituire null se non appartiene ad alcuna famiglia.
Proprietà pubblica | Dirty | Restituisce se l'oggetto sia stato modificato dopo l'inizializzazione.
Proprietà pubblica | IsLocked | Restituisce se sia stato bloccato l'oggetto: Internamente viene solo memorizzato lo stato ma il blocco viene ignorato.
Proprietà pubblica | IsValid | Restituisce se i valori presenti validano gli attributi della famiglia di appartenenza.
Proprietà pubblica | Item | Restituisce o imposta il valore tramite la chiave corrispondente.
Proprietà pubblica | Root | Restituisce la famiglia nella quale è stato archiviata questa anagrafica. Può restituire null se non appartiene ad alcuna famiglia.
Proprietà pubblica | UpdateRowVer | Restituisce se aggiornare il ROWVER dell'anagrafica
Torna su
Vedi anche

Documentazione

Classe DedDataPart
Namespace DedNet.Core


Proprietà DedDataPart.Application

Proprietà DedDataPartApplication
Restituisce l'applicazione di appartenenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedNetApplication Application { get; }
Public ReadOnly Property Application As DedNetApplication
    Get
public:
property DedNetApplication^ Application {
    DedNetApplication^ get ();
}
member Application : DedNetApplication with get

Valore della proprietà

DedNetApplication
Vedi anche

Documentazione

Classe DedDataPart
Namespace DedNet.Core


Proprietà DedDataPart.Attributes

Proprietà DedDataPartAttributes
Attributi contenuti nel DedDataPart

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<string, Object> Attributes { get; }
Public ReadOnly Property Attributes As Dictionary(Of String, Object)
    Get
public:
property Dictionary<String^, Object^>^ Attributes {
    Dictionary<String^, Object^>^ get ();
}
member Attributes : Dictionary<string, Object> with get

Valore della proprietà

Dictionary String, Object
Vedi anche

Documentazione

Classe DedDataPart
Namespace DedNet.Core


Proprietà DedDataPart.Count

Proprietà DedDataPartCount
Restituisce sempre 1 cioè il numero di anagrafiche rappresentate da questo oggetto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get () sealed;
}
abstract Count : int with get
override Count : int with get

Valore della proprietà

Int32

Implementa

IDedDataCount
Vedi anche

Documentazione

Classe DedDataPart
Namespace DedNet.Core


Proprietà DedDataPart.DedType

Proprietà DedDataPartDedType
Cerca di ricavare la famiglia alla quale può appartenere l'oggetto, cercando all'interno un campo DBPATH oppure interrogando il Datbase tramite DedId e DedRev.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedType DedType { get; }
Public ReadOnly Property DedType As DedType
    Get
public:
virtual property DedType^ DedType {
    DedType^ get () sealed;
}
abstract DedType : DedType with get
override DedType : DedType with get

Valore della proprietà

DedType

Implementa

IDedDataDedType
Vedi anche

Documentazione

Classe DedDataPart
Namespace DedNet.Core


Proprietà DedDataPart.DedTypeBase

Proprietà DedDataPartDedTypeBase
Restituisce la famiglia nella quale è stato archiviata questa anagrafica. Può restituire null se non appartiene ad alcuna famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeBase DedTypeBase { get; }
Public ReadOnly Property DedTypeBase As DedTypeBase
    Get
public:
virtual property DedTypeBase^ DedTypeBase {
    DedTypeBase^ get () sealed;
}
abstract DedTypeBase : DedTypeBase with get
override DedTypeBase : DedTypeBase with get

Valore della proprietà

DedTypeBase

Implementa

IDedTypeEditableDedTypeBase
Vedi anche

Documentazione

Classe DedDataPart
Namespace DedNet.Core


Proprietà DedDataPart.Dirty

Proprietà DedDataPartDirty
Restituisce se l'oggetto sia stato modificato dopo l'inizializzazione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Dirty { get; }
Public ReadOnly Property Dirty As Boolean
    Get
public:
virtual property bool Dirty {
    bool get () sealed;
}
abstract Dirty : bool with get
override Dirty : bool with get

Valore della proprietà

Boolean

Implementa

IDedDataDirty
Vedi anche

Documentazione

Classe DedDataPart
Namespace DedNet.Core


Proprietà DedDataPart.IsLocked

Proprietà DedDataPartIsLocked
Restituisce se sia stato bloccato l'oggetto: Internamente viene solo memorizzato lo stato ma il blocco viene ignorato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsLocked { get; }
Public ReadOnly Property IsLocked As Boolean
    Get
public:
virtual property bool IsLocked {
    bool get () sealed;
}
abstract IsLocked : bool with get
override IsLocked : bool with get

Valore della proprietà

Boolean

Implementa

IDedDataIsLocked
Vedi anche

Documentazione

Classe DedDataPart
Namespace DedNet.Core


Proprietà DedDataPart.IsValid

Proprietà DedDataPartIsValid
Restituisce se i valori presenti validano gli attributi della famiglia di appartenenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsValid { get; }
Public ReadOnly Property IsValid As Boolean
    Get
public:
virtual property bool IsValid {
    bool get () sealed;
}
abstract IsValid : bool with get
override IsValid : bool with get

Valore della proprietà

Boolean

Implementa

IDedTypeEditableIsValid
Vedi anche

Documentazione

Classe DedDataPart
Namespace DedNet.Core


Proprietà DedDataPart.Item

Proprietà DedDataPartItem
Restituisce o imposta il valore tramite la chiave corrispondente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object this[
    string attr
] { get; set; }
Public Default Property Item (
    attr As String
) As Object
    Get
    Set
public:
property Object^ default[String^ attr] {
    Object^ get (String^ attr);
    void set (String^ attr, Object^ value);
}
member Item : Object with get, set

Parametri

attr String
Nome della chiave da impostare o restitiuire.

Valore di ritorno

Object
Restituisce il valore corrispondente alla chiave specificata oppure null se non esiste.
Vedi anche

Documentazione

Classe DedDataPart
Namespace DedNet.Core


Proprietà DedDataPart.Root

Proprietà DedDataPartRoot
Restituisce la famiglia nella quale è stato archiviata questa anagrafica. Può restituire null se non appartiene ad alcuna famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeBase Root { get; }
Public ReadOnly Property Root As DedTypeBase
    Get
public:
virtual property DedTypeBase^ Root {
    DedTypeBase^ get () sealed;
}
abstract Root : DedTypeBase with get
override Root : DedTypeBase with get

Valore della proprietà

DedTypeBase

Implementa

IDedTypeEditableRoot
Vedi anche

Documentazione

Classe DedDataPart
Namespace DedNet.Core


Proprietà DedDataPart.UpdateRowVer

Proprietà DedDataPartUpdateRowVer
Restituisce se aggiornare il ROWVER dell'anagrafica

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool UpdateRowVer { get; set; }
Public Property UpdateRowVer As Boolean
    Get
    Set
public:
virtual property bool UpdateRowVer {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract UpdateRowVer : bool with get, set
override UpdateRowVer : bool with get, set

Valore della proprietà

Boolean

Implementa

IDedDataUpdateRowVer
Vedi anche

Documentazione

Classe DedDataPart
Namespace DedNet.Core


Metodi di DedDataPart

Il tipo DedDataPart espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | BeginIgnoreDirty | Indica all'oggetto di non diventare Dirty fino alla successiva chiamata del metodo EndIgnoreDirty(), da utilizzare in coppia a questo.
Metodo pubblico | Clone | Clona l'oggetto (copiando anche il dizionario interno) e lo restituisce.
Metodo pubblico | EndIgnoreDirty | Indica all'oggetto di tornare ad impostare a Dirty l'anagrafica. Da utilizzare in coppia con BeginIgnoreDirty().
Metodo pubblico | GetAttrsFromCategory(DedCateg) | Ritorna la lista di attributi visibili dalla famiglia che appartengono alla categoria passata.
Metodo pubblico | GetAttrsFromCategory(String) | Ritorna la lista di attributi visibili dalla famiglia che appartengono alla categoria passata.
Metodo pubblico | GetValue(DedDataStandardDataFields) | Restituisce il contenuto di uno dei campi standard oppure null se non è presente.
Metodo pubblico | GetValue(String) | Restituisce il contenuto di un campo personalizzato oppure null se non esiste.
Metodo pubblico | Lock | Imposta come bloccato l'oggetto: Memorizza lo stato ma non effettua alcun blocco.
Metodo pubblico | SetValue(DedDataStandardDataFields, Object) | Imposta un campo standard con un nuovo valore.
Metodo pubblico | SetValue(String, Object) | Imposta un campo personalizzato con un nuovo valore.
Metodo pubblico | UnLock | Sblocca l'oggetto o meglio lo imposta come sbloccato visto che non viene effettuata alcuna operazione sul Database. Il parametro viene ignorato.
Metodo pubblico | Validate | Restituisce se i valori presenti validano gli attributi della famiglia di appartenenza.
Torna su
Vedi anche

Documentazione

Classe DedDataPart
Namespace DedNet.Core


Metodo DedDataPart.BeginIgnoreDirty

Metodo DedDataPartBeginIgnoreDirty
Indica all'oggetto di non diventare Dirty fino alla successiva chiamata del metodo EndIgnoreDirty(), da utilizzare in coppia a questo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void BeginIgnoreDirty()
Public Sub BeginIgnoreDirty
public:
void BeginIgnoreDirty()
member BeginIgnoreDirty : unit -> unit
Vedi anche

Documentazione

Classe DedDataPart
Namespace DedNet.Core


Metodo DedDataPart.Clone

Metodo DedDataPartClone
Clona l'oggetto (copiando anche il dizionario interno) e lo restituisce.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
abstract Clone : unit -> Object
override Clone : unit -> Object

Valore di ritorno

Object
Restitusce una copia dell'oggetto.

Implementa

ICloneableClone
Vedi anche

Documentazione

Classe DedDataPart
Namespace DedNet.Core


Metodo DedDataPart.EndIgnoreDirty

Metodo DedDataPartEndIgnoreDirty
Indica all'oggetto di tornare ad impostare a Dirty l'anagrafica. Da utilizzare in coppia con BeginIgnoreDirty().

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void EndIgnoreDirty()
Public Sub EndIgnoreDirty
public:
void EndIgnoreDirty()
member EndIgnoreDirty : unit -> unit
Vedi anche

Documentazione

Classe DedDataPart
Namespace DedNet.Core


Metodo DedDataPart.GetAttrsFromCategory

Metodo DedDataPartGetAttrsFromCategory
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | GetAttrsFromCategory(DedCateg) | Ritorna la lista di attributi visibili dalla famiglia che appartengono alla categoria passata.
Metodo pubblico | GetAttrsFromCategory(String) | Ritorna la lista di attributi visibili dalla famiglia che appartengono alla categoria passata.
Torna su
Vedi anche

Documentazione

Classe DedDataPart
Namespace DedNet.Core


Metodo DedDataPart.GetAttrsFromCategory(DedCateg)

Metodo DedDataPartGetAttrsFromCategory(DedCateg)
Ritorna la lista di attributi visibili dalla famiglia che appartengono alla categoria passata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList GetAttrsFromCategory(
    DedCateg category
)
Public Function GetAttrsFromCategory (
    category As DedCateg
) As DedAttrList
public:
DedAttrList^ GetAttrsFromCategory(
    DedCateg^ category
)
member GetAttrsFromCategory :
        category : DedCateg -> DedAttrList

Parametri

category DedCateg
Categoria.

Valore di ritorno

DedAttrList
Vedi anche

Documentazione

Classe DedDataPart
Overload di GetAttrsFromCategory
Namespace DedNet.Core


Metodo DedDataPart.GetAttrsFromCategory(String)

Metodo DedDataPartGetAttrsFromCategory(String)
Ritorna la lista di attributi visibili dalla famiglia che appartengono alla categoria passata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList GetAttrsFromCategory(
    string category
)
Public Function GetAttrsFromCategory (
    category As String
) As DedAttrList
public:
DedAttrList^ GetAttrsFromCategory(
    String^ category
)
member GetAttrsFromCategory :
        category : string -> DedAttrList

Parametri

category String
Nome della categoria.

Valore di ritorno

DedAttrList
Vedi anche

Documentazione

Classe DedDataPart
Overload di GetAttrsFromCategory
Namespace DedNet.Core


Metodo DedDataPart.GetValue

Metodo DedDataPartGetValue
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | GetValue(DedDataStandardDataFields) | Restituisce il contenuto di uno dei campi standard oppure null se non è presente.
Metodo pubblico | GetValue(String) | Restituisce il contenuto di un campo personalizzato oppure null se non esiste.
Torna su
Vedi anche

Documentazione

Classe DedDataPart
Namespace DedNet.Core


Metodo DedDataPart.GetValue(DedData.StandardDataFields)

Metodo DedDataPartGetValue(DedDataStandardDataFields)
Restituisce il contenuto di uno dei campi standard oppure null se non è presente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object GetValue(
    DedDataStandardDataFields stdfield
)
Public Function GetValue (
    stdfield As DedDataStandardDataFields
) As Object
public:
virtual Object^ GetValue(
    DedDataStandardDataFields stdfield
) sealed
abstract GetValue :
        stdfield : DedDataStandardDataFields -> Object
override GetValue :
        stdfield : DedDataStandardDataFields -> Object

Parametri

stdfield DedDataStandardDataFields
Campo standard del quale restituire il contenuto.

Valore di ritorno

Object
Restituisce il valore se presente oppure null.

Implementa

IDedTypeEditableGetValue(DedDataStandardDataFields)
Vedi anche

Documentazione

Classe DedDataPart
Overload di GetValue
Namespace DedNet.Core


Metodo DedDataPart.GetValue(String)

Metodo DedDataPartGetValue(String)
Restituisce il contenuto di un campo personalizzato oppure null se non esiste.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object GetValue(
    string persfield
)
Public Function GetValue (
    persfield As String
) As Object
public:
virtual Object^ GetValue(
    String^ persfield
) sealed
abstract GetValue :
        persfield : string -> Object
override GetValue :
        persfield : string -> Object

Parametri

persfield String
Nome del campo personalizzato del quale restituire il contenuto.

Valore di ritorno

Object
Restituisce il valore se presente oppure null.

Implementa

IDedEditableGetValue(String)
Vedi anche

Documentazione

Classe DedDataPart
Overload di GetValue
Namespace DedNet.Core


Metodo DedDataPart.Lock

Metodo DedDataPartLock
Imposta come bloccato l'oggetto: Memorizza lo stato ma non effettua alcun blocco.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Lock(
    bool ignoreState = false,
    bool ignoreDocStatus = false
)
Public Sub Lock (
    Optional ignoreState As Boolean = false,
    Optional ignoreDocStatus As Boolean = false
)
public:
virtual void Lock(
    bool ignoreState = false,
    bool ignoreDocStatus = false
) sealed
abstract Lock :
        ?ignoreState : bool *
        ?ignoreDocStatus : bool
(* Defaults:
        let _ignoreState = defaultArg ignoreState false
        let _ignoreDocStatus = defaultArg ignoreDocStatus false
*)
-> unit
override Lock :
        ?ignoreState : bool *
        ?ignoreDocStatus : bool
(* Defaults:
        let _ignoreState = defaultArg ignoreState false
        let _ignoreDocStatus = defaultArg ignoreDocStatus false
*)
-> unit

Parametri

ignoreState Boolean (Optional)
ignoreDocStatus Boolean (Optional)

Implementa

IDedDataLock(Boolean, Boolean)
Vedi anche

Documentazione

Classe DedDataPart
Namespace DedNet.Core


Metodo DedDataPart.SetValue

Metodo DedDataPartSetValue
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | SetValue(DedDataStandardDataFields, Object) | Imposta un campo standard con un nuovo valore.
Metodo pubblico | SetValue(String, Object) | Imposta un campo personalizzato con un nuovo valore.
Torna su
Vedi anche

Documentazione

Classe DedDataPart
Namespace DedNet.Core


Metodo DedDataPart.SetValue(DedData.StandardDataFields, Object)

Metodo DedDataPartSetValue(DedDataStandardDataFields, Object)
Imposta un campo standard con un nuovo valore.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetValue(
    DedDataStandardDataFields stdfield,
    Object Value
)
Public Sub SetValue (
    stdfield As DedDataStandardDataFields,
    Value As Object
)
public:
virtual void SetValue(
    DedDataStandardDataFields stdfield,
    Object^ Value
) sealed
abstract SetValue :
        stdfield : DedDataStandardDataFields *
        Value : Object -> unit
override SetValue :
        stdfield : DedDataStandardDataFields *
        Value : Object -> unit

Parametri

stdfield DedDataStandardDataFields
Campo standard da impostare.
Value Object
Valore da impostare.

Implementa

IDedTypeEditableSetValue(DedDataStandardDataFields, Object)
Vedi anche

Documentazione

Classe DedDataPart
Overload di SetValue
Namespace DedNet.Core


Metodo DedDataPart.SetValue(String, Object)

Metodo DedDataPartSetValue(String, Object)
Imposta un campo personalizzato con un nuovo valore.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetValue(
    string persfield,
    Object Value
)
Public Sub SetValue (
    persfield As String,
    Value As Object
)
public:
virtual void SetValue(
    String^ persfield,
    Object^ Value
) sealed
abstract SetValue :
        persfield : string *
        Value : Object -> unit
override SetValue :
        persfield : string *
        Value : Object -> unit

Parametri

persfield String
Nome del campo personalizzato da impostare.
Value Object
Valore da impostare.

Implementa

IDedEditableSetValue(String, Object)
Vedi anche

Documentazione

Classe DedDataPart
Overload di SetValue
Namespace DedNet.Core


Metodo DedDataPart.UnLock

Metodo DedDataPartUnLock
Sblocca l'oggetto o meglio lo imposta come sbloccato visto che non viene effettuata alcuna operazione sul Database. Il parametro viene ignorato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void UnLock(
    bool DiscardChanges
)
Public Sub UnLock (
    DiscardChanges As Boolean
)
public:
virtual void UnLock(
    bool DiscardChanges
) sealed
abstract UnLock :
        DiscardChanges : bool -> unit
override UnLock :
        DiscardChanges : bool -> unit

Parametri

DiscardChanges Boolean
Parametro ignorato poiché non viene effettuato alcun blocco.

Implementa

IDedDataUnLock(Boolean)
Vedi anche

Documentazione

Classe DedDataPart
Namespace DedNet.Core


Metodo DedDataPart.Validate

Metodo DedDataPartValidate
Restituisce se i valori presenti validano gli attributi della famiglia di appartenenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Validate(
    bool creating,
    bool revisioning,
    out string error
)
Public Function Validate (
    creating As Boolean,
    revisioning As Boolean,
    <OutAttribute> ByRef error As String
) As Boolean
public:
virtual bool Validate(
    bool creating,
    bool revisioning,
    [OutAttribute] String^% error
) sealed
abstract Validate :
        creating : bool *
        revisioning : bool *
        error : string byref -> bool
override Validate :
        creating : bool *
        revisioning : bool *
        error : string byref -> bool

Parametri

creating Boolean
revisioning Boolean
error String

Valore di ritorno

Boolean

Implementa

IDedTypeEditableValidate(Boolean, Boolean, String)
Vedi anche

Documentazione

Classe DedDataPart
Namespace DedNet.Core


Classe DedDataPartList
Lista di oggetti IDedData. Viene utilizzata quando la lista di elemnti può essere costituita da oggetti DedData o DedDataPart ed in tutti i casi per i quali una lista di anagrafiche debba essere trattata come una unica anagrafica. Per quest'ultimo motivo implementa IDedData e contiene molti membri che lavorano sull'intera lista.
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList IDedData
DedNet.CoreDedDataPartList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedDataPartList : List<IDedData>,
    IDedData, IDedTypeEditable, IDedEditable
Public Class DedDataPartList
    Inherits List(Of IDedData)
    Implements IDedData, IDedTypeEditable, IDedEditable
public ref class DedDataPartList : public List<IDedData^>,
    IDedData, IDedTypeEditable, IDedEditable
type DedDataPartList =
    class
        inherit List<IDedData>
        interface IDedData
        interface IDedTypeEditable
        interface IDedEditable
    end

Il tipo DedDataPartList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedDataPartList | Inizializza la lista con all'interno l'applicazione di appartenenza.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione di appartenenza.
Proprietà pubblica | DedType | Restituisce la famiglia genitore comune a tutte le anagrafiche presenti.
Proprietà pubblica | DedTypeBase | Restituisce la famiglia nella quale è stato archiviata questa anagrafica. Può restituire null se non appartiene ad alcuna famiglia.
Proprietà pubblica | Dirty | Restituisce true se anche solo una anagrafica è Dirty altrimenti false.
Proprietà pubblica | IsLocked | Restituisce se il record sia bloccato (dall'utente corrente o da un altro). Non legge dal Database, controlla solo se è compilato il campo DEDLOCK. Restituisce true se anche solo una anagrafica risulta bloccata.
Proprietà pubblica | IsValid | Restituisce se i valori presenti validano gli attributi della famiglia di appartenenza.
Proprietà pubblica | Root | Restituisce la famiglia nella quale è stato archiviata questa anagrafica. Può restituire null se non appartiene ad alcuna famiglia.
Proprietà pubblica | UpdateRowVer | Restituisce true se anche solo una anagrafica è UpdateRowVer altrimenti false.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | GetValue(DedDataStandardDataFields) | Restituisce il contenuto di un campo standard oppure null se non esiste. Se i valori contenuti all'interno delle anagrafiche sono differenti viene restituita la stringa "*DIV*".
Metodo pubblico | GetValue(String) | Restituisce il contenuto di un campo personalizzato oppure null se non esiste. Se i valori contenuti all'interno delle anagrafiche sono differenti viene restituita la stringa "*DIV*".
Metodo pubblico | Lock | Esegue il blocco di tutte le anagrafiche impostando il campo DEDLOCK con il nome dell'utente corrente. Utilizza il campo DEDROWVER attuale per effettuare il blocco in modo da non riuscire in caso di anagrafica già modificata. Questo metodo non rende dirty le anagrafiche ma bisogna poi sbloccarle attraverso UnLock() oppure con Update(). Se avviene un errore quelle precedentemente bloccate vengono sbloccate.
Metodo pubblico | SetValue(DedDataStandardDataFields, Object) | Imposta un campo standard con un nuovo valore. Se il campo non esiste lo crea. La chiamata a questo metodo può causare la messa a Dirty delle anagrafiche, quando il campo da impostare è già presente nel dizionario interno ed il valore da impostare è differente da quello precedente oppure se è da creare.
Metodo pubblico | SetValue(String, Object) | Imposta un campo personalizzato con un nuovo valore. Se il campo non esiste lo crea. La chiamata a questo metodo può causare la messa a Dirty delle anagrafiche, quando il campo da impostare è già presente nel dizionario interno ed il valore da impostare è differente da quello precedente oppure se è da creare.
Metodo pubblico | UnLock | Sblocca tutte le anagrafiche solo se queste sono bloccate. Opzionalmente, se queste sono dirty, le aggiorna. Questo metodo la sblocca reimpostando il DEDROWVER alla versione precedente il bloccaggio ed effettua un Refresh() per riallineare i valori dell'anagrafica con il Database se l'anagrafica era Dirty.
Metodo pubblico | Validate | Restituisce se i valori presenti validano gli attributi della famiglia di appartenenza.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedDataPartList
Inizializza la lista con all'interno l'applicazione di appartenenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataPartList(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedDataPartList(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedDataPartList

Parametri

app DedNetApplication
Applicazione di appartenenza.
Vedi anche

Documentazione

Classe DedDataPartList
Namespace DedNet.Core


Proprietà di DedDataPartList

Il tipo DedDataPartList espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione di appartenenza.
Proprietà pubblica | DedType | Restituisce la famiglia genitore comune a tutte le anagrafiche presenti.
Proprietà pubblica | DedTypeBase | Restituisce la famiglia nella quale è stato archiviata questa anagrafica. Può restituire null se non appartiene ad alcuna famiglia.
Proprietà pubblica | Dirty | Restituisce true se anche solo una anagrafica è Dirty altrimenti false.
Proprietà pubblica | IsLocked | Restituisce se il record sia bloccato (dall'utente corrente o da un altro). Non legge dal Database, controlla solo se è compilato il campo DEDLOCK. Restituisce true se anche solo una anagrafica risulta bloccata.
Proprietà pubblica | IsValid | Restituisce se i valori presenti validano gli attributi della famiglia di appartenenza.
Proprietà pubblica | Root | Restituisce la famiglia nella quale è stato archiviata questa anagrafica. Può restituire null se non appartiene ad alcuna famiglia.
Proprietà pubblica | UpdateRowVer | Restituisce true se anche solo una anagrafica è UpdateRowVer altrimenti false.
Torna su
Vedi anche

Documentazione

Classe DedDataPartList
Namespace DedNet.Core


Proprietà DedDataPartList.Application

Proprietà DedDataPartListApplication
Restituisce l'applicazione di appartenenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedNetApplication Application { get; }
Public ReadOnly Property Application As DedNetApplication
    Get
public:
property DedNetApplication^ Application {
    DedNetApplication^ get ();
}
member Application : DedNetApplication with get

Valore della proprietà

DedNetApplication
Vedi anche

Documentazione

Classe DedDataPartList
Namespace DedNet.Core


Proprietà DedDataPartList.DedType

Proprietà DedDataPartListDedType
Restituisce la famiglia genitore comune a tutte le anagrafiche presenti.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedType DedType { get; }
Public ReadOnly Property DedType As DedType
    Get
public:
virtual property DedType^ DedType {
    DedType^ get () sealed;
}
abstract DedType : DedType with get
override DedType : DedType with get

Valore della proprietà

DedType

Implementa

IDedDataDedType
Vedi anche

Documentazione

Classe DedDataPartList
Namespace DedNet.Core


Proprietà DedDataPartList.DedTypeBase

Proprietà DedDataPartListDedTypeBase
Restituisce la famiglia nella quale è stato archiviata questa anagrafica. Può restituire null se non appartiene ad alcuna famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeBase DedTypeBase { get; }
Public ReadOnly Property DedTypeBase As DedTypeBase
    Get
public:
virtual property DedTypeBase^ DedTypeBase {
    DedTypeBase^ get () sealed;
}
abstract DedTypeBase : DedTypeBase with get
override DedTypeBase : DedTypeBase with get

Valore della proprietà

DedTypeBase

Implementa

IDedTypeEditableDedTypeBase
Vedi anche

Documentazione

Classe DedDataPartList
Namespace DedNet.Core


Proprietà DedDataPartList.Dirty

Proprietà DedDataPartListDirty
Restituisce true se anche solo una anagrafica è Dirty altrimenti false.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Dirty { get; }
Public ReadOnly Property Dirty As Boolean
    Get
public:
virtual property bool Dirty {
    bool get () sealed;
}
abstract Dirty : bool with get
override Dirty : bool with get

Valore della proprietà

Boolean

Implementa

IDedDataDirty
Vedi anche

Documentazione

Classe DedDataPartList
Namespace DedNet.Core


Proprietà DedDataPartList.IsLocked

Proprietà DedDataPartListIsLocked
Restituisce se il record sia bloccato (dall'utente corrente o da un altro). Non legge dal Database, controlla solo se è compilato il campo DEDLOCK. Restituisce true se anche solo una anagrafica risulta bloccata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsLocked { get; }
Public ReadOnly Property IsLocked As Boolean
    Get
public:
virtual property bool IsLocked {
    bool get () sealed;
}
abstract IsLocked : bool with get
override IsLocked : bool with get

Valore della proprietà

Boolean

Implementa

IDedDataIsLocked
Vedi anche

Documentazione

Classe DedDataPartList
Namespace DedNet.Core


Proprietà DedDataPartList.IsValid

Proprietà DedDataPartListIsValid
Restituisce se i valori presenti validano gli attributi della famiglia di appartenenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsValid { get; }
Public ReadOnly Property IsValid As Boolean
    Get
public:
virtual property bool IsValid {
    bool get () sealed;
}
abstract IsValid : bool with get
override IsValid : bool with get

Valore della proprietà

Boolean

Implementa

IDedTypeEditableIsValid
Vedi anche

Documentazione

Classe DedDataPartList
Namespace DedNet.Core


Proprietà DedDataPartList.Root

Proprietà DedDataPartListRoot
Restituisce la famiglia nella quale è stato archiviata questa anagrafica. Può restituire null se non appartiene ad alcuna famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeBase Root { get; }
Public ReadOnly Property Root As DedTypeBase
    Get
public:
virtual property DedTypeBase^ Root {
    DedTypeBase^ get () sealed;
}
abstract Root : DedTypeBase with get
override Root : DedTypeBase with get

Valore della proprietà

DedTypeBase

Implementa

IDedTypeEditableRoot
Vedi anche

Documentazione

Classe DedDataPartList
Namespace DedNet.Core


Proprietà DedDataPartList.UpdateRowVer

Proprietà DedDataPartListUpdateRowVer
Restituisce true se anche solo una anagrafica è UpdateRowVer altrimenti false.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool UpdateRowVer { get; set; }
Public Property UpdateRowVer As Boolean
    Get
    Set
public:
virtual property bool UpdateRowVer {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract UpdateRowVer : bool with get, set
override UpdateRowVer : bool with get, set

Valore della proprietà

Boolean

Implementa

IDedDataUpdateRowVer
Vedi anche

Documentazione

Classe DedDataPartList
Namespace DedNet.Core


Metodi di DedDataPartList

Il tipo DedDataPartList espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | GetValue(DedDataStandardDataFields) | Restituisce il contenuto di un campo standard oppure null se non esiste. Se i valori contenuti all'interno delle anagrafiche sono differenti viene restituita la stringa "*DIV*".
Metodo pubblico | GetValue(String) | Restituisce il contenuto di un campo personalizzato oppure null se non esiste. Se i valori contenuti all'interno delle anagrafiche sono differenti viene restituita la stringa "*DIV*".
Metodo pubblico | Lock | Esegue il blocco di tutte le anagrafiche impostando il campo DEDLOCK con il nome dell'utente corrente. Utilizza il campo DEDROWVER attuale per effettuare il blocco in modo da non riuscire in caso di anagrafica già modificata. Questo metodo non rende dirty le anagrafiche ma bisogna poi sbloccarle attraverso UnLock() oppure con Update(). Se avviene un errore quelle precedentemente bloccate vengono sbloccate.
Metodo pubblico | SetValue(DedDataStandardDataFields, Object) | Imposta un campo standard con un nuovo valore. Se il campo non esiste lo crea. La chiamata a questo metodo può causare la messa a Dirty delle anagrafiche, quando il campo da impostare è già presente nel dizionario interno ed il valore da impostare è differente da quello precedente oppure se è da creare.
Metodo pubblico | SetValue(String, Object) | Imposta un campo personalizzato con un nuovo valore. Se il campo non esiste lo crea. La chiamata a questo metodo può causare la messa a Dirty delle anagrafiche, quando il campo da impostare è già presente nel dizionario interno ed il valore da impostare è differente da quello precedente oppure se è da creare.
Metodo pubblico | UnLock | Sblocca tutte le anagrafiche solo se queste sono bloccate. Opzionalmente, se queste sono dirty, le aggiorna. Questo metodo la sblocca reimpostando il DEDROWVER alla versione precedente il bloccaggio ed effettua un Refresh() per riallineare i valori dell'anagrafica con il Database se l'anagrafica era Dirty.
Metodo pubblico | Validate | Restituisce se i valori presenti validano gli attributi della famiglia di appartenenza.
Torna su
Vedi anche

Documentazione

Classe DedDataPartList
Namespace DedNet.Core


Metodo DedDataPartList.GetValue

Metodo DedDataPartListGetValue
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | GetValue(DedDataStandardDataFields) | Restituisce il contenuto di un campo standard oppure null se non esiste. Se i valori contenuti all'interno delle anagrafiche sono differenti viene restituita la stringa "*DIV*".
Metodo pubblico | GetValue(String) | Restituisce il contenuto di un campo personalizzato oppure null se non esiste. Se i valori contenuti all'interno delle anagrafiche sono differenti viene restituita la stringa "*DIV*".
Torna su
Vedi anche

Documentazione

Classe DedDataPartList
Namespace DedNet.Core


Metodo DedDataPartList.GetValue(DedData.StandardDataFields)

Metodo DedDataPartListGetValue(DedDataStandardDataFields)
Restituisce il contenuto di un campo standard oppure null se non esiste. Se i valori contenuti all'interno delle anagrafiche sono differenti viene restituita la stringa "*DIV*".

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object GetValue(
    DedDataStandardDataFields stdfield
)
Public Function GetValue (
    stdfield As DedDataStandardDataFields
) As Object
public:
virtual Object^ GetValue(
    DedDataStandardDataFields stdfield
) sealed
abstract GetValue :
        stdfield : DedDataStandardDataFields -> Object
override GetValue :
        stdfield : DedDataStandardDataFields -> Object

Parametri

stdfield DedDataStandardDataFields
Campo standard del quale avere il contenuto.

Valore di ritorno

Object

Implementa

IDedTypeEditableGetValue(DedDataStandardDataFields)
Vedi anche

Documentazione

Classe DedDataPartList
Overload di GetValue
Namespace DedNet.Core


Metodo DedDataPartList.GetValue(String)

Metodo DedDataPartListGetValue(String)
Restituisce il contenuto di un campo personalizzato oppure null se non esiste. Se i valori contenuti all'interno delle anagrafiche sono differenti viene restituita la stringa "*DIV*".

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object GetValue(
    string persfield
)
Public Function GetValue (
    persfield As String
) As Object
public:
virtual Object^ GetValue(
    String^ persfield
) sealed
abstract GetValue :
        persfield : string -> Object
override GetValue :
        persfield : string -> Object

Parametri

persfield String
Nome del campo personalizzato del quale avere il contenuto.

Valore di ritorno

Object

Implementa

IDedEditableGetValue(String)
Vedi anche

Documentazione

Classe DedDataPartList
Overload di GetValue
Namespace DedNet.Core


Metodo DedDataPartList.Lock

Metodo DedDataPartListLock
Esegue il blocco di tutte le anagrafiche impostando il campo DEDLOCK con il nome dell'utente corrente. Utilizza il campo DEDROWVER attuale per effettuare il blocco in modo da non riuscire in caso di anagrafica già modificata. Questo metodo non rende dirty le anagrafiche ma bisogna poi sbloccarle attraverso UnLock() oppure con Update(). Se avviene un errore quelle precedentemente bloccate vengono sbloccate.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Lock(
    bool ignoreState = false,
    bool ignoreDocStatus = false
)
Public Sub Lock (
    Optional ignoreState As Boolean = false,
    Optional ignoreDocStatus As Boolean = false
)
public:
virtual void Lock(
    bool ignoreState = false,
    bool ignoreDocStatus = false
) sealed
abstract Lock :
        ?ignoreState : bool *
        ?ignoreDocStatus : bool
(* Defaults:
        let _ignoreState = defaultArg ignoreState false
        let _ignoreDocStatus = defaultArg ignoreDocStatus false
*)
-> unit
override Lock :
        ?ignoreState : bool *
        ?ignoreDocStatus : bool
(* Defaults:
        let _ignoreState = defaultArg ignoreState false
        let _ignoreDocStatus = defaultArg ignoreDocStatus false
*)
-> unit

Parametri

ignoreState Boolean (Optional)
ignoreDocStatus Boolean (Optional)

Implementa

IDedDataLock(Boolean, Boolean)
Vedi anche

Documentazione

Classe DedDataPartList
Namespace DedNet.Core


Metodo DedDataPartList.SetValue

Metodo DedDataPartListSetValue
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | SetValue(DedDataStandardDataFields, Object) | Imposta un campo standard con un nuovo valore. Se il campo non esiste lo crea. La chiamata a questo metodo può causare la messa a Dirty delle anagrafiche, quando il campo da impostare è già presente nel dizionario interno ed il valore da impostare è differente da quello precedente oppure se è da creare.
Metodo pubblico | SetValue(String, Object) | Imposta un campo personalizzato con un nuovo valore. Se il campo non esiste lo crea. La chiamata a questo metodo può causare la messa a Dirty delle anagrafiche, quando il campo da impostare è già presente nel dizionario interno ed il valore da impostare è differente da quello precedente oppure se è da creare.
Torna su
Vedi anche

Documentazione

Classe DedDataPartList
Namespace DedNet.Core


Metodo DedDataPartList.SetValue(DedData.StandardDataFields, Object)

Metodo DedDataPartListSetValue(DedDataStandardDataFields, Object)
Imposta un campo standard con un nuovo valore. Se il campo non esiste lo crea. La chiamata a questo metodo può causare la messa a Dirty delle anagrafiche, quando il campo da impostare è già presente nel dizionario interno ed il valore da impostare è differente da quello precedente oppure se è da creare.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetValue(
    DedDataStandardDataFields stdfield,
    Object Value
)
Public Sub SetValue (
    stdfield As DedDataStandardDataFields,
    Value As Object
)
public:
virtual void SetValue(
    DedDataStandardDataFields stdfield,
    Object^ Value
) sealed
abstract SetValue :
        stdfield : DedDataStandardDataFields *
        Value : Object -> unit
override SetValue :
        stdfield : DedDataStandardDataFields *
        Value : Object -> unit

Parametri

stdfield DedDataStandardDataFields
Campo standard da impostare.
Value Object
Valore da impostare.

Implementa

IDedTypeEditableSetValue(DedDataStandardDataFields, Object)
Vedi anche

Documentazione

Classe DedDataPartList
Overload di SetValue
Namespace DedNet.Core


Metodo DedDataPartList.SetValue(String, Object)

Metodo DedDataPartListSetValue(String, Object)
Imposta un campo personalizzato con un nuovo valore. Se il campo non esiste lo crea. La chiamata a questo metodo può causare la messa a Dirty delle anagrafiche, quando il campo da impostare è già presente nel dizionario interno ed il valore da impostare è differente da quello precedente oppure se è da creare.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetValue(
    string persfield,
    Object Value
)
Public Sub SetValue (
    persfield As String,
    Value As Object
)
public:
virtual void SetValue(
    String^ persfield,
    Object^ Value
) sealed
abstract SetValue :
        persfield : string *
        Value : Object -> unit
override SetValue :
        persfield : string *
        Value : Object -> unit

Parametri

persfield String
Nome del campo personalizzato da impostare.
Value Object
Valore da impostare.

Implementa

IDedEditableSetValue(String, Object)
Vedi anche

Documentazione

Classe DedDataPartList
Overload di SetValue
Namespace DedNet.Core


Metodo DedDataPartList.UnLock

Metodo DedDataPartListUnLock
Sblocca tutte le anagrafiche solo se queste sono bloccate. Opzionalmente, se queste sono dirty, le aggiorna. Questo metodo la sblocca reimpostando il DEDROWVER alla versione precedente il bloccaggio ed effettua un Refresh() per riallineare i valori dell'anagrafica con il Database se l'anagrafica era Dirty.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void UnLock(
    bool DiscardChanges
)
Public Sub UnLock (
    DiscardChanges As Boolean
)
public:
virtual void UnLock(
    bool DiscardChanges
) sealed
abstract UnLock :
        DiscardChanges : bool -> unit
override UnLock :
        DiscardChanges : bool -> unit

Parametri

DiscardChanges Boolean

Implementa

IDedDataUnLock(Boolean)
Vedi anche

Documentazione

Classe DedDataPartList
Namespace DedNet.Core


Metodo DedDataPartList.Validate

Metodo DedDataPartListValidate
Restituisce se i valori presenti validano gli attributi della famiglia di appartenenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Validate(
    bool creating,
    bool revisioning,
    out string error
)
Public Function Validate (
    creating As Boolean,
    revisioning As Boolean,
    <OutAttribute> ByRef error As String
) As Boolean
public:
virtual bool Validate(
    bool creating,
    bool revisioning,
    [OutAttribute] String^% error
) sealed
abstract Validate :
        creating : bool *
        revisioning : bool *
        error : string byref -> bool
override Validate :
        creating : bool *
        revisioning : bool *
        error : string byref -> bool

Parametri

creating Boolean
revisioning Boolean
error String

Valore di ritorno

Boolean

Implementa

IDedTypeEditableValidate(Boolean, Boolean, String)
Vedi anche

Documentazione

Classe DedDataPartList
Namespace DedNet.Core


Classe DedDbCollectionBase<T>

Classe DedDbCollectionBaseT
Classe base template che consente la gestione di una lista di oggetti presenti in una tabella del Database. Mantiene lo stato degli oggetti gestiti dalla collezione e riceve la notifica di avvenuta modifica.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedDbCollectionBaseT
Altro

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public abstract class DedDbCollectionBase<T> : IDedDbCollectionBase<T>,
    IEnumerable<T>, IEnumerable
where T : IDedDbItem

Public MustInherit Class DedDbCollectionBase(Of T As IDedDbItem)
    Implements IDedDbCollectionBase(Of T), IEnumerable(Of T),
    IEnumerable
generic<typename T>
where T : IDedDbItem
public ref class DedDbCollectionBase abstract : IDedDbCollectionBase<T>,
    IEnumerable<T>, IEnumerable
[<AbstractClassAttribute>]
type DedDbCollectionBase<'T when 'T : IDedDbItem> =
    class
        interface IDedDbCollectionBase<'T>
        interface IEnumerable<'T>
        interface IEnumerable
    end

Parametri di tipo

T

Il tipo DedDbCollectionBaseT espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedDbCollectionBaseT | Inizializza la lista ed il dizionario interni.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllowsDuplicates | Restituisce se siano ammessi duplicati all'interno della lista. Se false viene sollevata una eccezione su tentativo di inserimento duplicati.
Proprietà pubblica | Application | Restituisce l'oggetto applicazione di appartenza.
Proprietà pubblica | Count | Restituisce il numero di elementi presenti.
Proprietà pubblica | Dirty | Restituisce se la collezione o uno dei suoi elementi sia stata modificata.
Proprietà pubblica | ErasedItems | Restitusice la lista in sola lettura degli elementi che risultano attualmente cancellati.
Proprietà pubblica | LastItem | Restituisce l'ultimo elemento della collezione oppure null se non ci sono elementi.
Proprietà pubblica | RestoreErased | Restituisce se gli elementi cancellati devono essere ripristinati in caso vengano riaggiunti.
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | AddForClone | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto SENZA MODIFICARNE LO STATO. Le classi derivate potranno utilizzare questo metodo per clonare la collezione.
Metodo protetto | AddModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione.
Metodo protetto | AddNewElement | DI USO INTERNO. Aggiunge un elemento alla lista rendendo dirty l'oggetto. L'elemento viene aggiunto con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere un elemento alla lista. Dovranno loro stesse avere un metodo pubblico Add() che prenda i parametri necessari alla costruzione dell'oggetto.
Metodo protetto | AddRangeNewElement | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi rendendo dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere più elementi alla lista.
Metodo protetto | AddUnModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione.
Metodo pubblico | Clear | Elimina tutti gli elementi dalla lista.
Metodo protetto | ClearRefresh | Svuota la lista impostando Dirty = false. Di fatto permette di effettuare un refresh della lista e quindi di ricaricarla. Serve per svuotare la lista e reinizializzarla da capo.
Metodo pubblico | Contains | Verifica l'esistenza di un valore all'interno della lista degli elementi. Le classi derivate devono effettuarne l'override nel caso in cui l'elemento non implementi GetHashCode() per l'uso all'interno dei dizionarii.
Metodo pubblico | CopyTo | Copia un range di elementi in un array.
Metodo protetto | CreateDeleteCommand | Crea, inizializza e restituisce il comando per l'eliminazione di un elemento.
Metodo protetto | CreateInsertCommand | Crea, inizializza e restituisce il comando per l'inserimento di un elemento.
Metodo protetto | CreateUpdateCommand | Crea, inizializza e restituisce il comando per l'aggiornamento di un elemento.
Metodo pubblico | CustomSort | Ordina la lista in base al comparatore passato.
Metodo protetto | ExecuteDeleteItem | Esegue l'eliminazione di un elemento. Crea il comando tramite il metodo CreateDeleteCommand() e lo esegue.
Metodo protetto | ExecuteInsertItem | Esegue l'inserimento di un elemento. Crea il comando tramite il metodo CreateInsertCommand() e lo esegue.
Metodo protetto | ExecuteUpdateItem | Esegue l'aggiornamento di un elemento. Crea il comando tramite il metodo CreateUpdateCommand() e lo esegue.
Metodo pubblico | Find | Restituisce l'oggetto cercato.
Metodo pubblico | FindAll | Restitusice la lista degli elementi che corrispondono al predicato.
Metodo protetto | GetDbIndex | Restituisce l'indice dell'elemento passato, da utilizzare nelle clausole where di aggiornamento/eliminazione. Le classi derivate devono effettuarne l'override nel caso in cui sia possibile modificare l'indice dell'elemento via API.
Metodo pubblico | GetEnumerator | Restituisce l'enumeratore della collezione.
Metodo pubblico | IndexOf | Restituisce l'indice dell'elemento richiesto.
Metodo protetto | InitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione.
Metodo protetto | InsertUnModified | DI USO INTERNO. Inserisce un elemento alla lista senza rendere dirty l'oggetto, all'indice specificato. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione.
Metodo pubblico | Item | Restituisce l'elemento iesimo della lista.
Metodo pubblico | Move(Int32, Boolean) | Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi.
Metodo pubblico | Move(Int32, Boolean, Int32) | Sposta l'elemento dell'indice passato prima o dopo del numero di posizioni passate. Ignora eventuali valori di indice non validi.
Metodo protetto | OnAfterSave | Metodo Template chiamato dopo il salvataggio avvenuto.
Metodo protetto | OnAfterSaveNoChanges | Metodo Template chiamato dopo il salvataggio senza modifiche.
Metodo protetto | OnBeforeSave | Metodo Template chiamato prima del salvataggio.
Metodo pubblico | PropertyChanged(T) | Imposta come modificato lo stato dell'elemento.
Metodo pubblico | PropertyChanged(DedEditableObjectT) | Imposta come modificato lo stato dell'elemento.
Metodo pubblico | PropertyChangedAsNewElement(T) | Imposta come nuovo elemento lo stato dell'elemento.
Metodo pubblico | PropertyChangedAsNewElement(DedEditableObjectT) | Imposta come nuovo elemento lo stato dell'elemento.
Metodo protetto | ReInitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione.
Metodo pubblico | Remove | Elimina un elemento dalla collezione.
Metodo pubblico | Ripristina | Verifica che l'elemento sia presente negli eliminati e lo toglie da lì e lo riaggiunge in coda alla lista degli elementi validi. Solleva una eccezione se l'elemento è già presente nella lista e AllowsDuplicates = false.
Metodo pubblico | Save | Salva l'oggetto con tutta la sua lista, solo se questo risulta dirty.
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | IEnumerableGetEnumerator | Restituisce l'enumeratore della collezione.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedDbCollectionBaseT
DedNet.CoreBomItemCollection
DedNet.CoreDedAtt
DedNet.CoreDedAttrCollection
DedNet.CoreDedCascade
DedNet.CoreDedCategCollection
DedNet.CoreDedCorporates
DedNet.CoreDedEditableObjectCollectionT
DedNet.CoreDedGroupCollection
DedNet.CoreDedListCollection
DedNet.CoreDedListItemCollection
DedNet.CoreDedNotifies
DedNet.CoreDedPermCollection
DedNet.CoreDedRoots
DedNet.CoreDedRuleCollection
DedNet.CoreDedTranslationCollection
DedNet.CoreDedTypeBaseCollectionT
DedNet.CoreDedUserCollection
DedNet.CoreDedUserListCollection
DedNet.CoreDedUsersGroups
DedNet.CoreDedVars
DedNet.CoreDocDepCollection


Costruttore DedDbCollectionBase<T>

Costruttore DedDbCollectionBaseT
Inizializza la lista ed il dizionario interni.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDbCollectionBase(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedDbCollectionBase(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedDbCollectionBase

Parametri

app DedNetApplication
Applicazione di appartenenza.
Vedi anche

Documentazione

Classe DedDbCollectionBaseT
Namespace DedNet.Core


Proprietà di DedDbCollectionBase<T>

Proprietà di DedDbCollectionBaseT

Il tipo DedDbCollectionBaseT espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllowsDuplicates | Restituisce se siano ammessi duplicati all'interno della lista. Se false viene sollevata una eccezione su tentativo di inserimento duplicati.
Proprietà pubblica | Application | Restituisce l'oggetto applicazione di appartenza.
Proprietà pubblica | Count | Restituisce il numero di elementi presenti.
Proprietà pubblica | Dirty | Restituisce se la collezione o uno dei suoi elementi sia stata modificata.
Proprietà pubblica | ErasedItems | Restitusice la lista in sola lettura degli elementi che risultano attualmente cancellati.
Proprietà pubblica | LastItem | Restituisce l'ultimo elemento della collezione oppure null se non ci sono elementi.
Proprietà pubblica | RestoreErased | Restituisce se gli elementi cancellati devono essere ripristinati in caso vengano riaggiunti.
Torna su
Vedi anche

Documentazione

Classe DedDbCollectionBaseT
Namespace DedNet.Core


Proprietà DedDbCollectionBase<T>.AllowsDuplicates

Proprietà DedDbCollectionBaseTAllowsDuplicates
Restituisce se siano ammessi duplicati all'interno della lista. Se false viene sollevata una eccezione su tentativo di inserimento duplicati.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AllowsDuplicates { get; }
Public ReadOnly Property AllowsDuplicates As Boolean
    Get
public:
property bool AllowsDuplicates {
    bool get ();
}
member AllowsDuplicates : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDbCollectionBaseT
Namespace DedNet.Core


Proprietà DedDbCollectionBase<T>.Application

Proprietà DedDbCollectionBaseTApplication
Restituisce l'oggetto applicazione di appartenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedNetApplication Application { get; }
Public ReadOnly Property Application As DedNetApplication
    Get
public:
property DedNetApplication^ Application {
    DedNetApplication^ get ();
}
member Application : DedNetApplication with get

Valore della proprietà

DedNetApplication
Vedi anche

Documentazione

Classe DedDbCollectionBaseT
Namespace DedNet.Core


Proprietà DedDbCollectionBase<T>.Count

Proprietà DedDbCollectionBaseTCount
Restituisce il numero di elementi presenti.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get ();
}
abstract Count : int with get
override Count : int with get

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe DedDbCollectionBaseT
Namespace DedNet.Core


Proprietà DedDbCollectionBase<T>.Dirty

Proprietà DedDbCollectionBaseTDirty
Restituisce se la collezione o uno dei suoi elementi sia stata modificata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Dirty { get; }
Public ReadOnly Property Dirty As Boolean
    Get
public:
property bool Dirty {
    bool get ();
}
member Dirty : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDbCollectionBaseT
Namespace DedNet.Core


Proprietà DedDbCollectionBase<T>.ErasedItems

Proprietà DedDbCollectionBaseTErasedItems
Restitusice la lista in sola lettura degli elementi che risultano attualmente cancellati.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ReadOnlyCollection<T> ErasedItems { get; }
Public ReadOnly Property ErasedItems As ReadOnlyCollection(Of T)
    Get
public:
property ReadOnlyCollection<T>^ ErasedItems {
    ReadOnlyCollection<T>^ get ();
}
member ErasedItems : ReadOnlyCollection<'T> with get

Valore della proprietà

ReadOnlyCollection T
Vedi anche

Documentazione

Classe DedDbCollectionBaseT
Namespace DedNet.Core


Proprietà DedDbCollectionBase<T>.LastItem

Proprietà DedDbCollectionBaseTLastItem
Restituisce l'ultimo elemento della collezione oppure null se non ci sono elementi.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public T LastItem { get; }
Public ReadOnly Property LastItem As T
    Get
public:
property T LastItem {
    T get ();
}
member LastItem : 'T with get

Valore della proprietà

T
Vedi anche

Documentazione

Classe DedDbCollectionBaseT
Namespace DedNet.Core


Proprietà DedDbCollectionBase<T>.RestoreErased

Proprietà DedDbCollectionBaseTRestoreErased
Restituisce se gli elementi cancellati devono essere ripristinati in caso vengano riaggiunti.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool RestoreErased { get; }
Public ReadOnly Property RestoreErased As Boolean
    Get
public:
property bool RestoreErased {
    bool get ();
}
member RestoreErased : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDbCollectionBaseT
Namespace DedNet.Core


Metodi di DedDbCollectionBase<T>

Metodi di DedDbCollectionBaseT

Il tipo DedDbCollectionBaseT espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | AddForClone | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto SENZA MODIFICARNE LO STATO. Le classi derivate potranno utilizzare questo metodo per clonare la collezione.
Metodo protetto | AddModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione.
Metodo protetto | AddNewElement | DI USO INTERNO. Aggiunge un elemento alla lista rendendo dirty l'oggetto. L'elemento viene aggiunto con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere un elemento alla lista. Dovranno loro stesse avere un metodo pubblico Add() che prenda i parametri necessari alla costruzione dell'oggetto.
Metodo protetto | AddRangeNewElement | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi rendendo dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere più elementi alla lista.
Metodo protetto | AddUnModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione.
Metodo pubblico | Clear | Elimina tutti gli elementi dalla lista.
Metodo protetto | ClearRefresh | Svuota la lista impostando Dirty = false. Di fatto permette di effettuare un refresh della lista e quindi di ricaricarla. Serve per svuotare la lista e reinizializzarla da capo.
Metodo pubblico | Contains | Verifica l'esistenza di un valore all'interno della lista degli elementi. Le classi derivate devono effettuarne l'override nel caso in cui l'elemento non implementi GetHashCode() per l'uso all'interno dei dizionarii.
Metodo pubblico | CopyTo | Copia un range di elementi in un array.
Metodo protetto | CreateDeleteCommand | Crea, inizializza e restituisce il comando per l'eliminazione di un elemento.
Metodo protetto | CreateInsertCommand | Crea, inizializza e restituisce il comando per l'inserimento di un elemento.
Metodo protetto | CreateUpdateCommand | Crea, inizializza e restituisce il comando per l'aggiornamento di un elemento.
Metodo pubblico | CustomSort | Ordina la lista in base al comparatore passato.
Metodo protetto | ExecuteDeleteItem | Esegue l'eliminazione di un elemento. Crea il comando tramite il metodo CreateDeleteCommand() e lo esegue.
Metodo protetto | ExecuteInsertItem | Esegue l'inserimento di un elemento. Crea il comando tramite il metodo CreateInsertCommand() e lo esegue.
Metodo protetto | ExecuteUpdateItem | Esegue l'aggiornamento di un elemento. Crea il comando tramite il metodo CreateUpdateCommand() e lo esegue.
Metodo pubblico | Find | Restituisce l'oggetto cercato.
Metodo pubblico | FindAll | Restitusice la lista degli elementi che corrispondono al predicato.
Metodo protetto | GetDbIndex | Restituisce l'indice dell'elemento passato, da utilizzare nelle clausole where di aggiornamento/eliminazione. Le classi derivate devono effettuarne l'override nel caso in cui sia possibile modificare l'indice dell'elemento via API.
Metodo pubblico | GetEnumerator | Restituisce l'enumeratore della collezione.
Metodo pubblico | IndexOf | Restituisce l'indice dell'elemento richiesto.
Metodo protetto | InitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione.
Metodo protetto | InsertUnModified | DI USO INTERNO. Inserisce un elemento alla lista senza rendere dirty l'oggetto, all'indice specificato. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione.
Metodo pubblico | Item | Restituisce l'elemento iesimo della lista.
Metodo pubblico | Move(Int32, Boolean) | Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi.
Metodo pubblico | Move(Int32, Boolean, Int32) | Sposta l'elemento dell'indice passato prima o dopo del numero di posizioni passate. Ignora eventuali valori di indice non validi.
Metodo protetto | OnAfterSave | Metodo Template chiamato dopo il salvataggio avvenuto.
Metodo protetto | OnAfterSaveNoChanges | Metodo Template chiamato dopo il salvataggio senza modifiche.
Metodo protetto | OnBeforeSave | Metodo Template chiamato prima del salvataggio.
Metodo pubblico | PropertyChanged(T) | Imposta come modificato lo stato dell'elemento.
Metodo pubblico | PropertyChanged(DedEditableObjectT) | Imposta come modificato lo stato dell'elemento.
Metodo pubblico | PropertyChangedAsNewElement(T) | Imposta come nuovo elemento lo stato dell'elemento.
Metodo pubblico | PropertyChangedAsNewElement(DedEditableObjectT) | Imposta come nuovo elemento lo stato dell'elemento.
Metodo protetto | ReInitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione.
Metodo pubblico | Remove | Elimina un elemento dalla collezione.
Metodo pubblico | Ripristina | Verifica che l'elemento sia presente negli eliminati e lo toglie da lì e lo riaggiunge in coda alla lista degli elementi validi. Solleva una eccezione se l'elemento è già presente nella lista e AllowsDuplicates = false.
Metodo pubblico | Save | Salva l'oggetto con tutta la sua lista, solo se questo risulta dirty.
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | IEnumerableGetEnumerator | Restituisce l'enumeratore della collezione.
Torna su
Vedi anche

Documentazione

Classe DedDbCollectionBaseT
Namespace DedNet.Core


Metodo DedDbCollectionBase<T>.AddForClone

Metodo DedDbCollectionBaseTAddForClone
DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto SENZA MODIFICARNE LO STATO. Le classi derivate potranno utilizzare questo metodo per clonare la collezione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void AddForClone(
    T item
)
Protected Friend Sub AddForClone (
    item As T
)
protected public:
void AddForClone(
    T item
)
member AddForClone :
        item : 'T -> unit

Parametri

item T
Elemento da aggiungere.
Vedi anche

Documentazione

Classe DedDbCollectionBaseT
Namespace DedNet.Core


Metodo DedDbCollectionBase<T>.AddModified

Metodo DedDbCollectionBaseTAddModified
DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal virtual void AddModified(
    T item
)
Protected Friend Overridable Sub AddModified (
    item As T
)
protected public:
virtual void AddModified(
    T item
)
abstract AddModified :
        item : 'T -> unit
override AddModified :
        item : 'T -> unit

Parametri

item T
Elemento da aggiungere.
Vedi anche

Documentazione

Classe DedDbCollectionBaseT
Namespace DedNet.Core


Metodo DedDbCollectionBase<T>.AddNewElement

Metodo DedDbCollectionBaseTAddNewElement
DI USO INTERNO. Aggiunge un elemento alla lista rendendo dirty l'oggetto. L'elemento viene aggiunto con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere un elemento alla lista. Dovranno loro stesse avere un metodo pubblico Add() che prenda i parametri necessari alla costruzione dell'oggetto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal virtual T AddNewElement(
    T item
)
Protected Friend Overridable Function AddNewElement (
    item As T
) As T
protected public:
virtual T AddNewElement(
    T item
)
abstract AddNewElement :
        item : 'T -> 'T
override AddNewElement :
        item : 'T -> 'T

Parametri

item T
Elemento da aggiungere.

Valore di ritorno

T
Vedi anche

Documentazione

Classe DedDbCollectionBaseT
Namespace DedNet.Core


Metodo DedDbCollectionBase<T>.AddRangeNewElement

Metodo DedDbCollectionBaseTAddRangeNewElement
DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi rendendo dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere più elementi alla lista.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal virtual void AddRangeNewElement(
    List<T> list
)
Protected Friend Overridable Sub AddRangeNewElement (
    list As List(Of T)
)
protected public:
virtual void AddRangeNewElement(
    List<T>^ list
)
abstract AddRangeNewElement :
        list : List<'T> -> unit
override AddRangeNewElement :
        list : List<'T> -> unit

Parametri

list List T
Lista con la quale inizializzare l'oggetto.
Vedi anche

Documentazione

Classe DedDbCollectionBaseT
Namespace DedNet.Core


Metodo DedDbCollectionBase<T>.AddUnModified

Metodo DedDbCollectionBaseTAddUnModified
DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal virtual void AddUnModified(
    T item
)
Protected Friend Overridable Sub AddUnModified (
    item As T
)
protected public:
virtual void AddUnModified(
    T item
)
abstract AddUnModified :
        item : 'T -> unit
override AddUnModified :
        item : 'T -> unit

Parametri

item T
Elemento da aggiungere.
Vedi anche

Documentazione

Classe DedDbCollectionBaseT
Namespace DedNet.Core


Metodo DedDbCollectionBase<T>.Clear

Metodo DedDbCollectionBaseTClear
Elimina tutti gli elementi dalla lista.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit
Vedi anche

Documentazione

Classe DedDbCollectionBaseT
Namespace DedNet.Core


Metodo DedDbCollectionBase<T>.ClearRefresh

Metodo DedDbCollectionBaseTClearRefresh
Svuota la lista impostando Dirty = false. Di fatto permette di effettuare un refresh della lista e quindi di ricaricarla. Serve per svuotare la lista e reinizializzarla da capo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected void ClearRefresh()
Protected Sub ClearRefresh
protected:
void ClearRefresh()
member ClearRefresh : unit -> unit
Vedi anche

Documentazione

Classe DedDbCollectionBaseT
Namespace DedNet.Core


Metodo DedDbCollectionBase<T>.Contains

Metodo DedDbCollectionBaseTContains
Verifica l'esistenza di un valore all'interno della lista degli elementi. Le classi derivate devono effettuarne l'override nel caso in cui l'elemento non implementi GetHashCode() per l'uso all'interno dei dizionarii.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual bool Contains(
    T val
)
Public Overridable Function Contains (
    val As T
) As Boolean
public:
virtual bool Contains(
    T val
)
abstract Contains :
        val : 'T -> bool
override Contains :
        val : 'T -> bool

Parametri

val T
Valore del quale verificare l'esistenza.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedDbCollectionBaseT
Namespace DedNet.Core


Metodo DedDbCollectionBase<T>.CopyTo

Metodo DedDbCollectionBaseTCopyTo
Copia un range di elementi in un array.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual void CopyTo(
    T[] array,
    int arrayIndex
)
Public Overridable Sub CopyTo (
    array As T(),
    arrayIndex As Integer
)
public:
virtual void CopyTo(
    array<T>^ array,
    int arrayIndex
)
abstract CopyTo :
        array : 'T[] *
        arrayIndex : int -> unit
override CopyTo :
        array : 'T[] *
        arrayIndex : int -> unit

Parametri

array T
Array nel quale copiare gli elementi.
arrayIndex Int32
Indice di partenza della copia.
Vedi anche

Documentazione

Classe DedDbCollectionBaseT
Namespace DedNet.Core


Metodo DedDbCollectionBase<T>.CreateDeleteCommand

Metodo DedDbCollectionBaseTCreateDeleteCommand
Crea, inizializza e restituisce il comando per l'eliminazione di un elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected abstract QSDeleteCommand CreateDeleteCommand(
    T item
)
Protected MustOverride Function CreateDeleteCommand (
    item As T
) As QSDeleteCommand
protected:
virtual QSDeleteCommand^ CreateDeleteCommand(
    T item
) abstract
abstract CreateDeleteCommand :
        item : 'T -> QSDeleteCommand

Parametri

item T
Elemento da utilizzare per inizializzare il comando.

Valore di ritorno

QSDeleteCommand
Il comando inizializzato, pronto per essere eseguito.
Vedi anche

Documentazione

Classe DedDbCollectionBaseT
Namespace DedNet.Core


Metodo DedDbCollectionBase<T>.CreateInsertCommand

Metodo DedDbCollectionBaseTCreateInsertCommand
Crea, inizializza e restituisce il comando per l'inserimento di un elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected abstract QSInsertCommand CreateInsertCommand(
    T item
)
Protected MustOverride Function CreateInsertCommand (
    item As T
) As QSInsertCommand
protected:
virtual QSInsertCommand^ CreateInsertCommand(
    T item
) abstract
abstract CreateInsertCommand :
        item : 'T -> QSInsertCommand

Parametri

item T
Elemento da utilizzare per inizializzare il comando.

Valore di ritorno

QSInsertCommand
Il comando inizializzato, pronto per essere eseguito.
Vedi anche

Documentazione

Classe DedDbCollectionBaseT
Namespace DedNet.Core


Metodo DedDbCollectionBase<T>.CreateUpdateCommand

Metodo DedDbCollectionBaseTCreateUpdateCommand
Crea, inizializza e restituisce il comando per l'aggiornamento di un elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected abstract QSUpdateCommand CreateUpdateCommand(
    T item
)
Protected MustOverride Function CreateUpdateCommand (
    item As T
) As QSUpdateCommand
protected:
virtual QSUpdateCommand^ CreateUpdateCommand(
    T item
) abstract
abstract CreateUpdateCommand :
        item : 'T -> QSUpdateCommand

Parametri

item T
Elemento da utilizzare per inizializzare il comando.

Valore di ritorno

QSUpdateCommand
Il comando inizializzato, pronto per essere eseguito.
Vedi anche

Documentazione

Classe DedDbCollectionBaseT
Namespace DedNet.Core


Metodo DedDbCollectionBase<T>.CustomSort

Metodo DedDbCollectionBaseTCustomSort
Ordina la lista in base al comparatore passato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual void CustomSort(
    IComparer<T> comparer
)
Public Overridable Sub CustomSort (
    comparer As IComparer(Of T)
)
public:
virtual void CustomSort(
    IComparer<T>^ comparer
)
abstract CustomSort :
        comparer : IComparer<'T> -> unit
override CustomSort :
        comparer : IComparer<'T> -> unit

Parametri

comparer IComparer T
Oggetto comparatore.
Vedi anche

Documentazione

Classe DedDbCollectionBaseT
Namespace DedNet.Core


Metodo DedDbCollectionBase<T>.ExecuteDeleteItem

Metodo DedDbCollectionBaseTExecuteDeleteItem
Esegue l'eliminazione di un elemento. Crea il comando tramite il metodo CreateDeleteCommand() e lo esegue.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected virtual void ExecuteDeleteItem(
    T item
)
Protected Overridable Sub ExecuteDeleteItem (
    item As T
)
protected:
virtual void ExecuteDeleteItem(
    T item
)
abstract ExecuteDeleteItem :
        item : 'T -> unit
override ExecuteDeleteItem :
        item : 'T -> unit

Parametri

item T
Elemento da eliminare.
Vedi anche

Documentazione

Classe DedDbCollectionBaseT
Namespace DedNet.Core


Metodo DedDbCollectionBase<T>.ExecuteInsertItem

Metodo DedDbCollectionBaseTExecuteInsertItem
Esegue l'inserimento di un elemento. Crea il comando tramite il metodo CreateInsertCommand() e lo esegue.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected virtual void ExecuteInsertItem(
    T item
)
Protected Overridable Sub ExecuteInsertItem (
    item As T
)
protected:
virtual void ExecuteInsertItem(
    T item
)
abstract ExecuteInsertItem :
        item : 'T -> unit
override ExecuteInsertItem :
        item : 'T -> unit

Parametri

item T
Elemento da aggiungere.
Vedi anche

Documentazione

Classe DedDbCollectionBaseT
Namespace DedNet.Core


Metodo DedDbCollectionBase<T>.ExecuteUpdateItem

Metodo DedDbCollectionBaseTExecuteUpdateItem
Esegue l'aggiornamento di un elemento. Crea il comando tramite il metodo CreateUpdateCommand() e lo esegue.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected virtual void ExecuteUpdateItem(
    T item
)
Protected Overridable Sub ExecuteUpdateItem (
    item As T
)
protected:
virtual void ExecuteUpdateItem(
    T item
)
abstract ExecuteUpdateItem :
        item : 'T -> unit
override ExecuteUpdateItem :
        item : 'T -> unit

Parametri

item T
Elemento da aggiornare.
Vedi anche

Documentazione

Classe DedDbCollectionBaseT
Namespace DedNet.Core


Metodo DedDbCollectionBase<T>.Find

Metodo DedDbCollectionBaseTFind
Restituisce l'oggetto cercato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public T Find(
    Predicate<T> match
)
Public Function Find (
    match As Predicate(Of T)
) As T
public:
T Find(
    Predicate<T>^ match
)
member Find :
        match : Predicate<'T> -> 'T

Parametri

match Predicate T
Predicato di ricerca.

Valore di ritorno

T
Vedi anche

Documentazione

Classe DedDbCollectionBaseT
Namespace DedNet.Core


Metodo DedDbCollectionBase<T>.FindAll

Metodo DedDbCollectionBaseTFindAll
Restitusice la lista degli elementi che corrispondono al predicato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<T> FindAll(
    Predicate<T> match
)
Public Function FindAll (
    match As Predicate(Of T)
) As List(Of T)
public:
List<T>^ FindAll(
    Predicate<T>^ match
)
member FindAll :
        match : Predicate<'T> -> List<'T>

Parametri

match Predicate T
Predicato di ricerca.

Valore di ritorno

List T
Vedi anche

Documentazione

Classe DedDbCollectionBaseT
Namespace DedNet.Core


Metodo DedDbCollectionBase<T>.GetDbIndex

Metodo DedDbCollectionBaseTGetDbIndex
Restituisce l'indice dell'elemento passato, da utilizzare nelle clausole where di aggiornamento/eliminazione. Le classi derivate devono effettuarne l'override nel caso in cui sia possibile modificare l'indice dell'elemento via API.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected virtual Object GetDbIndex(
    T item
)
Protected Overridable Function GetDbIndex (
    item As T
) As Object
protected:
virtual Object^ GetDbIndex(
    T item
)
abstract GetDbIndex :
        item : 'T -> Object
override GetDbIndex :
        item : 'T -> Object

Parametri

item T
Elemento del quale restituire l'indice.

Valore di ritorno

Object
Restituisce l'indice dell'elemento oppure null.
Vedi anche

Documentazione

Classe DedDbCollectionBaseT
Namespace DedNet.Core


Metodo DedDbCollectionBase<T>.GetEnumerator

Metodo DedDbCollectionBaseTGetEnumerator
Restituisce l'enumeratore della collezione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public IEnumerator<T> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of T)
public:
virtual IEnumerator<T>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<'T>
override GetEnumerator : unit -> IEnumerator<'T>

Valore di ritorno

IEnumerator T

Implementa

IEnumerableTGetEnumerator
Vedi anche

Documentazione

Classe DedDbCollectionBaseT
Namespace DedNet.Core


Metodo DedDbCollectionBase<T>.IEnumerable.GetEnumerator

Metodo DedDbCollectionBaseTIEnumerableGetEnumerator
Restituisce l'enumeratore della collezione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
IEnumerator IEnumerable.GetEnumerator()
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator

Valore di ritorno

IEnumerator

Implementa

IEnumerableGetEnumerator
Vedi anche

Documentazione

Classe DedDbCollectionBaseT
Namespace DedNet.Core


Metodo DedDbCollectionBase<T>.IndexOf

Metodo DedDbCollectionBaseTIndexOf
Restituisce l'indice dell'elemento richiesto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int IndexOf(
    T item
)
Public Function IndexOf (
    item As T
) As Integer
public:
int IndexOf(
    T item
)
member IndexOf :
        item : 'T -> int

Parametri

item T
Elemento del quale cercare l'indice.

Valore di ritorno

Int32
Restituisce l'indice oppure -1 se l'elemento non è presente.
Vedi anche

Documentazione

Classe DedDbCollectionBaseT
Namespace DedNet.Core


Metodo DedDbCollectionBase<T>.InitListUnModified

Metodo DedDbCollectionBaseTInitListUnModified
DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void InitListUnModified(
    List<T> list
)
Protected Friend Sub InitListUnModified (
    list As List(Of T)
)
protected public:
void InitListUnModified(
    List<T>^ list
)
member InitListUnModified :
        list : List<'T> -> unit

Parametri

list List T
Lista con la quale inizializzare l'oggetto.
Vedi anche

Documentazione

Classe DedDbCollectionBaseT
Namespace DedNet.Core


Metodo DedDbCollectionBase<T>.InsertUnModified

Metodo DedDbCollectionBaseTInsertUnModified
DI USO INTERNO. Inserisce un elemento alla lista senza rendere dirty l'oggetto, all'indice specificato. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected void InsertUnModified(
    int index,
    T item
)
Protected Sub InsertUnModified (
    index As Integer,
    item As T
)
protected:
void InsertUnModified(
    int index,
    T item
)
member InsertUnModified :
        index : int *
        item : 'T -> unit

Parametri

index Int32
Indice (parte da zero) della posizione nella quale inserire il nuovo elemento.
item T
Elemento da inserire.

Valore di ritorno

Restituisce l'elemento appena inserito.
Vedi anche

Documentazione

Classe DedDbCollectionBaseT
Namespace DedNet.Core


Metodo DedDbCollectionBase<T>.Item

Metodo DedDbCollectionBaseTItem
Restituisce l'elemento iesimo della lista.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public T Item(
    int index
)
Public Function Item (
    index As Integer
) As T
public:
T Item(
    int index
)
member Item :
        index : int -> 'T

Parametri

index Int32
Indice dell'elemento da restituire.

Valore di ritorno

T
Restituisce l'elemento all'indice richiesto.
Vedi anche

Documentazione

Classe DedDbCollectionBaseT
Namespace DedNet.Core


Metodo DedDbCollectionBase<T>.Move

Metodo DedDbCollectionBaseTMove
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Move(Int32, Boolean) | Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi.
Metodo pubblico | Move(Int32, Boolean, Int32) | Sposta l'elemento dell'indice passato prima o dopo del numero di posizioni passate. Ignora eventuali valori di indice non validi.
Torna su
Vedi anche

Documentazione

Classe DedDbCollectionBaseT
Namespace DedNet.Core


Metodo DedDbCollectionBase<T>.Move(Int32, Boolean)

Metodo DedDbCollectionBaseTMove(Int32, Boolean)
Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual void Move(
    int index,
    bool up
)
Public Overridable Sub Move (
    index As Integer,
    up As Boolean
)
public:
virtual void Move(
    int index,
    bool up
)
abstract Move :
        index : int *
        up : bool -> unit
override Move :
        index : int *
        up : bool -> unit

Parametri

index Int32
Indice dell'elemento da spostare.
up Boolean
Se true l'elemento viene spostato in alto (nell'indice precedente) altrimenti all'indice successivo.
Vedi anche

Documentazione

Classe DedDbCollectionBaseT
Overload di Move
Namespace DedNet.Core


Metodo DedDbCollectionBase<T>.Move(Int32, Boolean, Int32)

Metodo DedDbCollectionBaseTMove(Int32, Boolean, Int32)
Sposta l'elemento dell'indice passato prima o dopo del numero di posizioni passate. Ignora eventuali valori di indice non validi.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual void Move(
    int index,
    bool up,
    int positions
)
Public Overridable Sub Move (
    index As Integer,
    up As Boolean,
    positions As Integer
)
public:
virtual void Move(
    int index,
    bool up,
    int positions
)
abstract Move :
        index : int *
        up : bool *
        positions : int -> unit
override Move :
        index : int *
        up : bool *
        positions : int -> unit

Parametri

index Int32
Indice dell'elemento da spostare.
up Boolean
Se true l'elemento viene spostato in alto (nell'indice precedente) altrimenti all'indice successivo.
positions Int32
Numero di posizioni di quanto spostare l'elemento.
Vedi anche

Documentazione

Classe DedDbCollectionBaseT
Overload di Move
Namespace DedNet.Core


Metodo DedDbCollectionBase<T>.OnAfterSave

Metodo DedDbCollectionBaseTOnAfterSave
Metodo Template chiamato dopo il salvataggio avvenuto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected virtual void OnAfterSave(
    List<T> eliminati,
    List<T> modificati,
    List<T> aggiunti
)
Protected Overridable Sub OnAfterSave (
    eliminati As List(Of T),
    modificati As List(Of T),
    aggiunti As List(Of T)
)
protected:
virtual void OnAfterSave(
    List<T>^ eliminati,
    List<T>^ modificati,
    List<T>^ aggiunti
)
abstract OnAfterSave :
        eliminati : List<'T> *
        modificati : List<'T> *
        aggiunti : List<'T> -> unit
override OnAfterSave :
        eliminati : List<'T> *
        modificati : List<'T> *
        aggiunti : List<'T> -> unit

Parametri

eliminati List T
Elementi eliminati.
modificati List T
Elementi modificati.
aggiunti List T
Elementi aggiunti.
Vedi anche

Documentazione

Classe DedDbCollectionBaseT
Namespace DedNet.Core


Metodo DedDbCollectionBase<T>.OnAfterSaveNoChanges

Metodo DedDbCollectionBaseTOnAfterSaveNoChanges
Metodo Template chiamato dopo il salvataggio senza modifiche.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected virtual void OnAfterSaveNoChanges()
Protected Overridable Sub OnAfterSaveNoChanges
protected:
virtual void OnAfterSaveNoChanges()
abstract OnAfterSaveNoChanges : unit -> unit
override OnAfterSaveNoChanges : unit -> unit
Vedi anche

Documentazione

Classe DedDbCollectionBaseT
Namespace DedNet.Core


Metodo DedDbCollectionBase<T>.OnBeforeSave

Metodo DedDbCollectionBaseTOnBeforeSave
Metodo Template chiamato prima del salvataggio.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected virtual void OnBeforeSave(
    List<T> eliminati,
    List<T> modificati,
    List<T> aggiunti
)
Protected Overridable Sub OnBeforeSave (
    eliminati As List(Of T),
    modificati As List(Of T),
    aggiunti As List(Of T)
)
protected:
virtual void OnBeforeSave(
    List<T>^ eliminati,
    List<T>^ modificati,
    List<T>^ aggiunti
)
abstract OnBeforeSave :
        eliminati : List<'T> *
        modificati : List<'T> *
        aggiunti : List<'T> -> unit
override OnBeforeSave :
        eliminati : List<'T> *
        modificati : List<'T> *
        aggiunti : List<'T> -> unit

Parametri

eliminati List T
Elementi da eliminare.
modificati List T
Elementi da modificare.
aggiunti List T
Elementi da aggiungere.
Vedi anche

Documentazione

Classe DedDbCollectionBaseT
Namespace DedNet.Core


Metodo DedDbCollectionBase<T>.PropertyChanged

Metodo DedDbCollectionBaseTPropertyChanged
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | PropertyChanged(T) | Imposta come modificato lo stato dell'elemento.
Metodo pubblico | PropertyChanged(DedEditableObjectT) | Imposta come modificato lo stato dell'elemento.
Torna su
Vedi anche

Documentazione

Classe DedDbCollectionBaseT
Namespace DedNet.Core


Metodo DedDbCollectionBase<T>.PropertyChanged(T)

Metodo DedDbCollectionBaseTPropertyChanged(T)
Imposta come modificato lo stato dell'elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void PropertyChanged(
    T item
)
Public Sub PropertyChanged (
    item As T
)
public:
void PropertyChanged(
    T item
)
member PropertyChanged :
        item : 'T -> unit

Parametri

item T
Oggetto T modificato.
Vedi anche

Documentazione

Classe DedDbCollectionBaseT
Overload di PropertyChanged
Namespace DedNet.Core


Metodo DedDbCollectionBase<T>.PropertyChanged(DedEditableObject<T>)

Metodo DedDbCollectionBaseTPropertyChanged(DedEditableObjectT)
Imposta come modificato lo stato dell'elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void PropertyChanged(
    DedEditableObject<T> item
)
Public Sub PropertyChanged (
    item As DedEditableObject(Of T)
)
public:
virtual void PropertyChanged(
    DedEditableObject<T>^ item
) sealed
abstract PropertyChanged :
        item : DedEditableObject<'T> -> unit
override PropertyChanged :
        item : DedEditableObject<'T> -> unit

Parametri

item DedEditableObject T
Oggetto T modificato.

Implementa

IDedDbCollectionBaseTPropertyChanged(DedEditableObjectT)
Vedi anche

Documentazione

Classe DedDbCollectionBaseT
Overload di PropertyChanged
Namespace DedNet.Core


Metodo DedDbCollectionBase<T>.PropertyChangedAsNewElement

Metodo DedDbCollectionBaseTPropertyChangedAsNewElement
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | PropertyChangedAsNewElement(T) | Imposta come nuovo elemento lo stato dell'elemento.
Metodo pubblico | PropertyChangedAsNewElement(DedEditableObjectT) | Imposta come nuovo elemento lo stato dell'elemento.
Torna su
Vedi anche

Documentazione

Classe DedDbCollectionBaseT
Namespace DedNet.Core


Metodo DedDbCollectionBase<T>.PropertyChangedAsNewElement(T)

Metodo DedDbCollectionBaseTPropertyChangedAsNewElement(T)
Imposta come nuovo elemento lo stato dell'elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void PropertyChangedAsNewElement(
    T item
)
Public Sub PropertyChangedAsNewElement (
    item As T
)
public:
void PropertyChangedAsNewElement(
    T item
)
member PropertyChangedAsNewElement :
        item : 'T -> unit

Parametri

item T
Oggetto T modificato.
Vedi anche

Documentazione

Classe DedDbCollectionBaseT
Overload di PropertyChangedAsNewElement
Namespace DedNet.Core


Metodo DedDbCollectionBase<T>.PropertyChangedAsNewElement(DedEditableObject<T>)

Metodo DedDbCollectionBaseTPropertyChangedAsNewElement(DedEditableObjectT)
Imposta come nuovo elemento lo stato dell'elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void PropertyChangedAsNewElement(
    DedEditableObject<T> item
)
Public Sub PropertyChangedAsNewElement (
    item As DedEditableObject(Of T)
)
public:
virtual void PropertyChangedAsNewElement(
    DedEditableObject<T>^ item
) sealed
abstract PropertyChangedAsNewElement :
        item : DedEditableObject<'T> -> unit
override PropertyChangedAsNewElement :
        item : DedEditableObject<'T> -> unit

Parametri

item DedEditableObject T
Oggetto T modificato.

Implementa

IDedDbCollectionBaseTPropertyChangedAsNewElement(DedEditableObjectT)
Vedi anche

Documentazione

Classe DedDbCollectionBaseT
Overload di PropertyChangedAsNewElement
Namespace DedNet.Core


Metodo DedDbCollectionBase<T>.ReInitListUnModified

Metodo DedDbCollectionBaseTReInitListUnModified
DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void ReInitListUnModified()
Protected Friend Sub ReInitListUnModified
protected public:
void ReInitListUnModified()
member ReInitListUnModified : unit -> unit
Vedi anche

Documentazione

Classe DedDbCollectionBaseT
Namespace DedNet.Core


Metodo DedDbCollectionBase<T>.Remove

Metodo DedDbCollectionBaseTRemove
Elimina un elemento dalla collezione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual void Remove(
    T item
)
Public Overridable Sub Remove (
    item As T
)
public:
virtual void Remove(
    T item
)
abstract Remove :
        item : 'T -> unit
override Remove :
        item : 'T -> unit

Parametri

item T
Elemento da eliminare.
Vedi anche

Documentazione

Classe DedDbCollectionBaseT
Namespace DedNet.Core


Metodo DedDbCollectionBase<T>.Ripristina

Metodo DedDbCollectionBaseTRipristina
Verifica che l'elemento sia presente negli eliminati e lo toglie da lì e lo riaggiunge in coda alla lista degli elementi validi. Solleva una eccezione se l'elemento è già presente nella lista e AllowsDuplicates = false.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Ripristina(
    T item
)
Public Sub Ripristina (
    item As T
)
public:
void Ripristina(
    T item
)
member Ripristina :
        item : 'T -> unit

Parametri

item T
Elemento da ripristinare.
Vedi anche

Documentazione

Classe DedDbCollectionBaseT
Namespace DedNet.Core


Metodo DedDbCollectionBase<T>.Save

Metodo DedDbCollectionBaseTSave
Salva l'oggetto con tutta la sua lista, solo se questo risulta dirty.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual void Save()
Public Overridable Sub Save
public:
virtual void Save()
abstract Save : unit -> unit
override Save : unit -> unit

Implementa

IDedDbCollectionBaseTSave
Vedi anche

Documentazione

Classe DedDbCollectionBaseT
Namespace DedNet.Core


Classe DedDbCollectionBindable<T>

Classe DedDbCollectionBindableT
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList T
DedNet.CoreDedDbCollectionBindableT

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedDbCollectionBindable<T> : List<T>
where T : IDedDbItem

Public Class DedDbCollectionBindable(Of T As IDedDbItem)
    Inherits List(Of T)
generic<typename T>
where T : IDedDbItem
public ref class DedDbCollectionBindable : public List<T>
type DedDbCollectionBindable<'T when 'T : IDedDbItem> =
    class
        inherit List<'T>
    end

Parametri di tipo

T

Il tipo DedDbCollectionBindableT espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedDbCollectionBindableT |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Add | Aggiunge un elemento dalla collezione.
Metodo pubblico | CustomSort | Ordina gli elementi in base al comparatore passato.
Metodo pubblico | Insert | Aggiunge un elemento dalla collezione.
Metodo pubblico | Move | Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi.
Metodo pubblico | Remove | Elimina un elemento dalla collezione.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedDbCollectionBindable<T>

Costruttore DedDbCollectionBindableT

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDbCollectionBindable()
Public Sub New
public:
DedDbCollectionBindable()
new : unit -> DedDbCollectionBindable
Vedi anche

Documentazione

Classe DedDbCollectionBindableT
Namespace DedNet.Core


Metodi di DedDbCollectionBindable<T>

Metodi di DedDbCollectionBindableT

Il tipo DedDbCollectionBindableT espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Add | Aggiunge un elemento dalla collezione.
Metodo pubblico | CustomSort | Ordina gli elementi in base al comparatore passato.
Metodo pubblico | Insert | Aggiunge un elemento dalla collezione.
Metodo pubblico | Move | Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi.
Metodo pubblico | Remove | Elimina un elemento dalla collezione.
Torna su
Vedi anche

Documentazione

Classe DedDbCollectionBindableT
Namespace DedNet.Core


Metodo DedDbCollectionBindable<T>.Add

Metodo DedDbCollectionBindableTAdd
Aggiunge un elemento dalla collezione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual void Add(
    T item,
    DedDbCollectionBase<T> parent
)
Public Overridable Sub Add (
    item As T,
    parent As DedDbCollectionBase(Of T)
)
public:
virtual void Add(
    T item,
    DedDbCollectionBase<T>^ parent
)
abstract Add :
        item : 'T *
        parent : DedDbCollectionBase<'T> -> unit
override Add :
        item : 'T *
        parent : DedDbCollectionBase<'T> -> unit

Parametri

item T
Elemento da eliminare.
parent DedDbCollectionBase T
Collezione utilizzata per l'inizializzazione di questa lista bindata.
Vedi anche

Documentazione

Classe DedDbCollectionBindableT
Namespace DedNet.Core


Metodo DedDbCollectionBindable<T>.CustomSort

Metodo DedDbCollectionBindableTCustomSort
Ordina gli elementi in base al comparatore passato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void CustomSort(
    IComparer<T> comparer,
    DedDbCollectionBase<T> parent
)
Public Sub CustomSort (
    comparer As IComparer(Of T),
    parent As DedDbCollectionBase(Of T)
)
public:
void CustomSort(
    IComparer<T>^ comparer,
    DedDbCollectionBase<T>^ parent
)
member CustomSort :
        comparer : IComparer<'T> *
        parent : DedDbCollectionBase<'T> -> unit

Parametri

comparer IComparer T
Oggetto comparatore.
parent DedDbCollectionBase T
Collezione utilizzata per l'inizializzazione di questa lista bindata.
Vedi anche

Documentazione

Classe DedDbCollectionBindableT
Namespace DedNet.Core


Metodo DedDbCollectionBindable<T>.Insert

Metodo DedDbCollectionBindableTInsert
Aggiunge un elemento dalla collezione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual void Insert(
    int index,
    T item,
    DedDbCollectionBase<T> parent
)
Public Overridable Sub Insert (
    index As Integer,
    item As T,
    parent As DedDbCollectionBase(Of T)
)
public:
virtual void Insert(
    int index,
    T item,
    DedDbCollectionBase<T>^ parent
)
abstract Insert :
        index : int *
        item : 'T *
        parent : DedDbCollectionBase<'T> -> unit
override Insert :
        index : int *
        item : 'T *
        parent : DedDbCollectionBase<'T> -> unit

Parametri

index Int32
item T
Elemento da eliminare.
parent DedDbCollectionBase T
Collezione utilizzata per l'inizializzazione di questa lista bindata.
Vedi anche

Documentazione

Classe DedDbCollectionBindableT
Namespace DedNet.Core


Metodo DedDbCollectionBindable<T>.Move

Metodo DedDbCollectionBindableTMove
Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Move(
    int index,
    bool up,
    DedDbCollectionBase<T> parent
)
Public Sub Move (
    index As Integer,
    up As Boolean,
    parent As DedDbCollectionBase(Of T)
)
public:
void Move(
    int index,
    bool up,
    DedDbCollectionBase<T>^ parent
)
member Move :
        index : int *
        up : bool *
        parent : DedDbCollectionBase<'T> -> unit

Parametri

index Int32
Indice dell'elemento da spostare.
up Boolean
Se true l'elemento viene spostato in alto (nell'indice precedente) altrimenti all'indice successivo.
parent DedDbCollectionBase T
Collezione utilizzata per l'inizializzazione di questa lista bindata.
Vedi anche

Documentazione

Classe DedDbCollectionBindableT
Namespace DedNet.Core


Metodo DedDbCollectionBindable<T>.Remove

Metodo DedDbCollectionBindableTRemove
Elimina un elemento dalla collezione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual void Remove(
    T item,
    DedDbCollectionBase<T> parent
)
Public Overridable Sub Remove (
    item As T,
    parent As DedDbCollectionBase(Of T)
)
public:
virtual void Remove(
    T item,
    DedDbCollectionBase<T>^ parent
)
abstract Remove :
        item : 'T *
        parent : DedDbCollectionBase<'T> -> unit
override Remove :
        item : 'T *
        parent : DedDbCollectionBase<'T> -> unit

Parametri

item T
Elemento da eliminare.
parent DedDbCollectionBase T
Collezione utilizzata per l'inizializzazione di questa lista bindata.
Vedi anche

Documentazione

Classe DedDbCollectionBindableT
Namespace DedNet.Core


Classe DedDbItemManager
Classe che fornisce strumenti di utilità generale per operare con gli oggetti 'DedBaseDbItem'.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedDbItemManager

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static class DedDbItemManager
Public NotInheritable Class DedDbItemManager
public ref class DedDbItemManager abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DedDbItemManager = class end

Il tipo DedDbItemManager espone i seguenti membri.

Metodi
Nome | Descrizione
FindByDbIndex | Ritorna un'oggetto 'DedBaseDbItem' in base al tipo e al dbindex specificato.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Metodi di DedDbItemManager

Il tipo DedDbItemManager espone i seguenti membri.

Metodi
Nome | Descrizione
FindByDbIndex | Ritorna un'oggetto 'DedBaseDbItem' in base al tipo e al dbindex specificato.
Torna su
Vedi anche

Documentazione

Classe DedDbItemManager
Namespace DedNet.Core


Metodo DedDbItemManager.FindByDbIndex

Metodo DedDbItemManagerFindByDbIndex
Ritorna un'oggetto 'DedBaseDbItem' in base al tipo e al dbindex specificato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static DedBaseDbItem FindByDbIndex(
    DedDbItemType type,
    string dbindex
)
Public Shared Function FindByDbIndex (
    type As DedDbItemType,
    dbindex As String
) As DedBaseDbItem
public:
static DedBaseDbItem^ FindByDbIndex(
    DedDbItemType type,
    String^ dbindex
)
static member FindByDbIndex :
        type : DedDbItemType *
        dbindex : string -> DedBaseDbItem

Parametri

type DedDbItemType
dbindex String

Valore di ritorno

DedBaseDbItem
Vedi anche

Documentazione

Classe DedDbItemManager
Namespace DedNet.Core


Classe DedDictionary
Dizionario con le chiavi in formato stringa ed i valori in formato object che implementa il minimo indispensabile per essere passato al controllo DedEditAnagrControl.
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericDictionary String, Object
DedNet.CoreDedDictionary
DedNet.CoreDedCommData

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedDictionary : Dictionary<string, Object>,
    IDedEditable
Public Class DedDictionary
    Inherits Dictionary(Of String, Object)
    Implements IDedEditable
public ref class DedDictionary : public Dictionary<String^, Object^>,
    IDedEditable
type DedDictionary =
    class
        inherit Dictionary<string, Object>
        interface IDedEditable
    end

Il tipo DedDictionary espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedDictionary |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | GetValue(DedDataStandardDataFields) | Restituisce il contenuto di un campo standard oppure null se non esiste. Se i valori contenuti all'interno delle anagrafiche sono differenti viene restituita la stringa "*DIV*".
Metodo pubblico | GetValue(String) | Restituisce il valore oppure null.
Metodo pubblico | SetValue(DedDataStandardDataFields, Object) |
Metodo pubblico | SetValue(String, Object) | Imposta il valore corrispondente alla chiave passata oppure crea il campo se non esiste.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedDictionary

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDictionary()
Public Sub New
public:
DedDictionary()
new : unit -> DedDictionary
Vedi anche

Documentazione

Classe DedDictionary
Namespace DedNet.Core


Metodi di DedDictionary

Il tipo DedDictionary espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | GetValue(DedDataStandardDataFields) | Restituisce il contenuto di un campo standard oppure null se non esiste. Se i valori contenuti all'interno delle anagrafiche sono differenti viene restituita la stringa "*DIV*".
Metodo pubblico | GetValue(String) | Restituisce il valore oppure null.
Metodo pubblico | SetValue(DedDataStandardDataFields, Object) |
Metodo pubblico | SetValue(String, Object) | Imposta il valore corrispondente alla chiave passata oppure crea il campo se non esiste.
Torna su
Vedi anche

Documentazione

Classe DedDictionary
Namespace DedNet.Core


Metodo DedDictionary.GetValue

Metodo DedDictionaryGetValue
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | GetValue(DedDataStandardDataFields) | Restituisce il contenuto di un campo standard oppure null se non esiste. Se i valori contenuti all'interno delle anagrafiche sono differenti viene restituita la stringa "*DIV*".
Metodo pubblico | GetValue(String) | Restituisce il valore oppure null.
Torna su
Vedi anche

Documentazione

Classe DedDictionary
Namespace DedNet.Core


Metodo DedDictionary.GetValue(DedData.StandardDataFields)

Metodo DedDictionaryGetValue(DedDataStandardDataFields)
Restituisce il contenuto di un campo standard oppure null se non esiste. Se i valori contenuti all'interno delle anagrafiche sono differenti viene restituita la stringa "*DIV*".

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object GetValue(
    DedDataStandardDataFields stdfield
)
Public Function GetValue (
    stdfield As DedDataStandardDataFields
) As Object
public:
virtual Object^ GetValue(
    DedDataStandardDataFields stdfield
) sealed
abstract GetValue :
        stdfield : DedDataStandardDataFields -> Object
override GetValue :
        stdfield : DedDataStandardDataFields -> Object

Parametri

stdfield DedDataStandardDataFields
Campo standard del quale avere il contenuto.

Valore di ritorno

Object
Vedi anche

Documentazione

Classe DedDictionary
Overload di GetValue
Namespace DedNet.Core


Metodo DedDictionary.GetValue(String)

Metodo DedDictionaryGetValue(String)
Restituisce il valore oppure null.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object GetValue(
    string persfield
)
Public Function GetValue (
    persfield As String
) As Object
public:
virtual Object^ GetValue(
    String^ persfield
) sealed
abstract GetValue :
        persfield : string -> Object
override GetValue :
        persfield : string -> Object

Parametri

persfield String
Chiave del campo da leggere.

Valore di ritorno

Object

Implementa

IDedEditableGetValue(String)
Vedi anche

Documentazione

Classe DedDictionary
Overload di GetValue
Namespace DedNet.Core


Metodo DedDictionary.SetValue

Metodo DedDictionarySetValue
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | SetValue(DedDataStandardDataFields, Object) |
Metodo pubblico | SetValue(String, Object) | Imposta il valore corrispondente alla chiave passata oppure crea il campo se non esiste.
Torna su
Vedi anche

Documentazione

Classe DedDictionary
Namespace DedNet.Core


Metodo DedDictionary.SetValue(DedData.StandardDataFields, Object)

Metodo DedDictionarySetValue(DedDataStandardDataFields, Object)

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetValue(
    DedDataStandardDataFields stdfield,
    Object Value
)
Public Sub SetValue (
    stdfield As DedDataStandardDataFields,
    Value As Object
)
public:
virtual void SetValue(
    DedDataStandardDataFields stdfield,
    Object^ Value
) sealed
abstract SetValue :
        stdfield : DedDataStandardDataFields *
        Value : Object -> unit
override SetValue :
        stdfield : DedDataStandardDataFields *
        Value : Object -> unit

Parametri

stdfield DedDataStandardDataFields
Value Object
Vedi anche

Documentazione

Classe DedDictionary
Overload di SetValue
Namespace DedNet.Core


Metodo DedDictionary.SetValue(String, Object)

Metodo DedDictionarySetValue(String, Object)
Imposta il valore corrispondente alla chiave passata oppure crea il campo se non esiste.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetValue(
    string persfield,
    Object Value
)
Public Sub SetValue (
    persfield As String,
    Value As Object
)
public:
virtual void SetValue(
    String^ persfield,
    Object^ Value
) sealed
abstract SetValue :
        persfield : string *
        Value : Object -> unit
override SetValue :
        persfield : string *
        Value : Object -> unit

Parametri

persfield String
Chiave del campo da impostare.
Value Object
Valore da impostare.

Implementa

IDedEditableSetValue(String, Object)
Vedi anche

Documentazione

Classe DedDictionary
Overload di SetValue
Namespace DedNet.Core


Classe DedDoc
Documento archiviato nel Database.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedDoc

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedDoc
Public Class DedDoc
public ref class DedDoc
type DedDoc = class end

Il tipo DedDoc espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione di appartenenza.
Proprietà pubblica | Attributi | Restituisce gli attributi del file.
Proprietà pubblica | Attrs | Restituisce la lista degli attributi con i rispettivi valori.
Proprietà pubblica | CheckoutData | Restituisce la data dell'ultima modifica del campo CheckoutUser oppure la data di creazione del record.
Proprietà pubblica | CheckoutEstensione | Restituisce l'estensione del file nel caso in cui si trovi in check-out, senza il punto iniziale.
Proprietà pubblica | CheckoutHost | Restituisce il nome della macchina dalla quale l'utente ha posto in checkout questo documento, oppure stringa vuota se è in check-in.
Proprietà pubblica | CheckOutNameWithExtension | Restituisce il nome del file compreso di estensione ma senza percorso, del file in check-out oppure stringa vuota se è in check-in. Viene utilizzato il nome di pws.
Proprietà pubblica | CheckoutNome | Restituisce il nome del file nel caso in cui si trovi in check-out.
Proprietà pubblica | CheckoutPercorso | Restituisce il percorso del file nel caso in cui si trovi in check-out.
Proprietà pubblica | CheckoutUser | Restituisce il nome dell'utente che ha posto in checkout questo documento, oppure stringa vuota se è in check-in.
Proprietà pubblica | Context | Restituisce il contesto dell'anagrafica per la quale il documento è stato richiesto oppure null nel caso in cui non sia stata creata in un ambito di anagrafica.
Proprietà pubblica | CurrentFullFileName | Restituisce il percorso completo del documento che l'applicazione può e deve utilizzare per leggere le informazioni del documento nel metodo RefreshInfoFile. Infatti restituisce il valore della proprietà FullFileName o FullCheckOutFileName in base al fatto che il documento sia in check-in o in check-out.
Proprietà pubblica | DataCreazione | Restituisce la data di creazione del file
Proprietà pubblica | DataCreazioneRecord | Restituisce la data di creazione del record.
Proprietà pubblica | DataModifica | Restituisce la data di ultima modifica del file
Proprietà pubblica | Dimensione | Restituisce la dimensione del file
Proprietà pubblica | Dirty | Restituisce se il documento sia da aggiornare nel Database.
Proprietà pubblica | DocDependences | Restituisce la collezione delle dipendenze di questo documento leggendole dal Database.
Proprietà pubblica | DocID | Restituisce l'ID di questa commessa.
Proprietà pubblica | DocIdAsString | Restituisce la rappresentazione stringa del DocId di questo documento.
Proprietà pubblica | Erased | Restituisce se il record del file sia stato cancellato dal Database.
Proprietà pubblica | Estensione | Restituisce l'estensione del file senza il punto iniziale.
Proprietà pubblica | FileExists | Restituisce se il file è presente su disco (nel vault o nella pws se è attiva l'area locale).
Proprietà pubblica | FileMarked | Restituisce il rowver del file.
Proprietà pubblica | FullCheckOutFileName | Restituisce il nome completo del file in check-out oppure stringa vuota se è in check-in. Permette anche di impostare i valori di CheckoutNome, CheckoutPercorso e CheckoutEstensione impostando un nome completo.
Proprietà pubblica | FullFileName | Restituisce il nome completo del file nel Database. Permette anche di impostare i valori di Nome, Percorso ed Estensione impostando un nome completo.
Proprietà pubblica | HasComms | Restituisce se il documento è associato ad almeno una commessa
Proprietà pubblica | HasData | Restituisce se il documento è associato ad almeno una anagrafica
Proprietà pubblica | HasNewVaultFileVersion |
Proprietà pubblica | HideInfo | Indica se nascondere le informazioni dell'elemento
Proprietà pubblica | InternalName | Restituisce l'internalName del file
Proprietà pubblica | IsCheckedIn | Restituisce se il documento è in check-in.
Proprietà pubblica | IsCheckedOutByMe | Restituisce se il record sia in CheckOut dall'utente corrente.
Proprietà pubblica | IsCheckedOutByMeOnOtherHost | Restituisce se il record sia in CheckOut dall'utente corrente ma su un altra macchina. E' un controllo specifico. Per il sistema è comunque in checkout da altro utente
Proprietà pubblica | IsCheckedOutByOther | Restituisce se il record sia in CheckOut da un utente differente dall'utente corrente.
Proprietà pubblica | IsNewVaultFile | Restituisce se, con attiva l'area locale, il documento sia nuovo ed in checkout ma non sia ancora stato pubblicato sul server.
Proprietà pubblica | Keys | Restituisce la lista delle chiavi presenti nell'anagrafica.
Proprietà pubblica | NameWithExtension | Restituisce il nome del file compreso di estensione ma senza percorso. Viene utilizzato il nome di vault.
Proprietà pubblica | Nome | Restituisce il nome del file senza estensione.
Proprietà pubblica | OldFile | Restituisce il nome completo del file prima che venisse archiviato.
Proprietà pubblica | ParentDocuments | Restituisce la collezione dei documenti genitore di questo documento.
Proprietà pubblica | ParoleChiave | Restituisce le parole chiave del documento.
Proprietà pubblica | Percorso | Restituisce il percorso del file.
Proprietà pubblica | PercorsoRooted | Ritorna il percorso rooted del documento. E' il valore effettivamente contenuto
Proprietà pubblica | PwsFileBackupName | Restituisce il nome da utilizzare come file di backup sul server, in occazione del checkout.
Proprietà pubblica | PwsFullPath | Restituisce il nome completo di questo documento se dovesse essere copiato nell'area locale. Questo valore viene impostato nelle proprietà di Checkout per impostare in Checkout il documento. Se non è attiva l'area locale viene restituito il percorso completo di vault.
Proprietà pubblica | RowVer | Restituisce il rowver del file.
Proprietà pubblica | Scala | Restitusice la Scala del documento (1:2, 1:10, ecc.).
Proprietà pubblica | SimilarDocuments | Restituisce la collezione dei documenti genitore di questo documento.
Proprietà pubblica | State | Ritorna lo stato attuale del documento.
Proprietà pubblica | UniqueDocDependences | Restituisce la collezione delle dipendenze di questo documento leggendole dal Database.
Proprietà pubblica | UniqueParentDocuments | Restituisce la collezione delle dipendenze di questo documento leggendole dal Database.
Proprietà pubblica | UtenteCreazioneRecord | Restituisce l'utente che ha creato questo documento.
Proprietà pubblica | Values | Restituisce la lista dei valori presenti nell'anagrafica.
Proprietà pubblica | VaultFileBackupName | Restituisce il nome da utilizzare come file di backup sul server, in occazione del checkout.
Proprietà pubblica | Versione | Restituisce il numero di versione di questo documento.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AddDocStateHistory | Aggiunge un record in DED_DOC_STATE_HISTORY relativo all'operazione e all'utente corrente.
Metodo pubblico | AddPublishInfo | Aggiunte le informazioni del documento tra i descrittori di pubblicazione
Metodo pubblico | AddToDetachedForAllCorporates | Aggiunge nella tabella DED_DOC_DETACHED il record.
Metodo pubblico | AddToDetachedForCorporate | Aggiunge nella tabella DED_DOC_DETACHED il record.
Metodo pubblico | AddToTranferHistory | Aggiunge nella tabella DED_TRANSFER_DOCS il record.
Metodo pubblico | AddUserDoc | Aggiunge o aggiorna il record in DED_DOC_USER relativo a questo documento per l'utente corrente.
Metodo pubblico | ClearParentDocuments | Pulisce la struttura dei padri forzando la lettura al successivo accesso alla proprietà
Metodo pubblico | CurVer | Restuituisce la versione del documento presente nel Vault. Restituisce Guid.Empty se non è riuscito a trovarlo.
Metodo pubblico | Delete | Elimina il documento dalla tabella dei documenti. Non lo elimina dalla tabella di collegamento con le anagrafiche ma elimina tutte le sue dipendenze figlie e dei documenti padri.
Metodo pubblico | DeleteBackup | Elimina il backup di un documento, effettuato in fase di checkout.
Metodo pubblico | DeleteBackup(Boolean) | Elimina il backup di un documento, effettuato in fase di checkout.
Metodo pubblico | DeleteBackupCfg | Elimina il backup di un documento, effettuato in fase di checkout.
Metodo pubblico | DeleteDocFromUserDoc | Elimina il record in DED_DOC_USER relativo a questo documento.
Metodo pubblico | DeleteUserDoc | Elimina il record in DED_DOC_USER relativo a questo utente ed a questo documento.
Metodo pubblico | Equals | Ridefinizione di uguaglianza. (Sovrascrive ObjectEquals(Object))
Metodo pubblico | ErasePublishInfo | Elimina le informazioni del documento dai descrittori di pubblicazione
Metodo pubblico | ForceDirty | Forza il documento a diventare dirty per far si che si aggiorni nel Database. Utilizzato dai client che devono aggiornare il documento (magari solo il rowver) ma che di fatto non gli hanno modificato niente rispetto a prima.
Metodo pubblico | ForceMarkerAlignment | Forza il valore del ROWVER presente nel Database all'interno del documento sul server.
Metodo pubblico | ForzaCheckIn | Imposta il documento in CheckIn anche se non è in CheckOut dall'utente corrente.
Metodo pubblico | GetAddInVersion | Legge ADDINVERSION per il documento. Utilizzato ad esempio nella migrazione massiva per il controllo dell'elaborazione dei file.
Metodo pubblico | GetAllAttachData | Restituisce la lista di tutte le anagrafiche nelle quali questo documento è collegato come allegato. Se non ce ne sono restituisce comunque una lista inizializzata.
Metodo pubblico | GetAllMovingFileNames | Restituisce una lista contenente tutti i FileName avuti da questo documento (compreso quello attuale).
Metodo pubblico | GetAllMovingFileNames(Boolean) | Restituisce una lista contenente tutti i FileName avuti da questo documento.
Metodo pubblico | GetAllPrimaryData | Restituisce la lista di tutte le anagrafiche nelle quali questo documento è collegato come file primario. Se non ce ne sono restituisce comunque una lista inizializzata.
Metodo pubblico | GetAllPrimaryData(String) | Restituisce la lista di tutte le anagrafiche nelle quali questo documento è collegato come file primario nella configurazione passata
Metodo pubblico | GetAllPrimaryDataNotLinked | Restituisce la lista di tutte le anagrafiche nelle quali questo documento è collegato come file primario ma non linkato. Se non ce ne sono restituisce comunque una lista inizializzata.
Metodo pubblico | GetAllSparePartsData | Restituisce la lista di tutte le anagrafiche nelle quali questo documento è collegato come ricambio
Metodo pubblico | GetAllSparePartsData(String) | Restituisce la lista di tutte le anagrafiche nelle quali questo documento è collegato come ricambio nella configurazione passata Se non ce ne sono restituisce comunque una lista inizializzata.
Metodo pubblico | GetCheckOutLightRowVer | Restituisce il guid presente nel campo del check-out-light.
Metodo pubblico | GetCommCount | Restituisce il numero di commesse collegate a questo elemento
Metodo pubblico | GetComms | Restituisce la lista di commesse collegate a questo documento
Metodo pubblico | GetData | Restituisce la lista di anagrafiche collegate a questo documento. Se non ce ne sono restituisce comunque una lista inizializzata.
Metodo pubblico | GetData(DedDocContextEnum) | Restituisce la lista di anagrafiche collegate a questo documento in base ad un particolare contesto. Se non ce ne sono restituisce comunque una lista inizializzata.
Metodo pubblico | GetData(String, FuncDedDocContext, Boolean) | Funzione generica che cicla le anagrafiche ed in base alle lambda passate discrimina la lista in uscita
Metodo pubblico | GetDataCount | Restituisce il numero di anagrafiche collegate a questo documento.
Metodo pubblico | GetDataNotLinked | Restituisce la lista di anagrafiche collegate a questo documento che NON SONO in un contesto di link. Se non ce ne sono restituisce comunque una lista inizializzata.
Metodo pubblico | GetDataNotLinked(String) | Restituisce la lista di anagrafiche collegate a questo documento che NON SONO in un contesto di link. Se non ce ne sono restituisce comunque una lista inizializzata.
Metodo pubblico | GetDocVersionFromStateHistory | Data l'operazione e il rowver del documento, ritrova la versione
Metodo pubblico | GetHashCode | Restituisce l'HashCode di questo oggetto. (Sovrascrive ObjectGetHashCode)
Metodo pubblico | GetRootInfo | Restitiusce le informazioni di root dei path attuali per questo documento.
Metodo pubblico | GetStrictPrimaryData | Restituisce la lista di tutte le anagrafiche nelle quali questo documento è collegato come strettamente primario
Metodo pubblico | GetStrictPrimaryData(String) | Restituisce la lista di tutte le anagrafiche nelle quali questo documento è collegato come strettamente primario nella configurazione passata
Metodo pubblico | GetStrictPrimaryDataNotLinked | Restituisce la lista di tutte le anagrafiche nelle quali questo documento è collegato come strettamente primario ma non linkato
Metodo pubblico | GetValue(DedDocStandardDocFields) | Restituisce il contenuto di uno dei campi standard oppure null se non è presente.
Metodo pubblico | GetValue(String) | Metodo che restituisce i valori del documento.
Metodo pubblico | HasAtLeastOneLinkingContext | Retituisce true se il documento ha almeno un contesto di linking nei confronti di una anagrafica
Metodo pubblico | HasMoreThanOneConfigContext | Ritorna true se il documento è associato a più anagrafiche con diverse configurazioni
Metodo pubblico | HasOperationInStateHistory | Ritorna true se nella storia delle operazioni del documento ne esiste almeno una di questo tipo
Metodo pubblico | IsDetachedForCorporate | Ritorna vero se il documento è effettivamente segnalato come disallineato per la corporate passata
Metodo pubblico | IsDetachedForMyCorporate | Ritorna vero se il documento è efffettivamente segnalato come disallineato per la corporate corrente
Metodo pubblico | IsMovingDestination | Indica se il documento deriva da un moving di un altro documento.
Metodo pubblico | IsMyPwsDocEqualsToVaultDoc | Verifica se la versione del documento in locale è uguale a quella nel vault.
Metodo pubblico | IsVaultDocUpToDate | Verifica se la versione del file su vault coincide con la versione del database. In caso di modalità non detached torna sempre true.
Metodo pubblico | MoveTo(String) | Imposta il nome, estensione e percorso file in base al nuovo percorso passato, anche nei campi di checkout se non risultano vuoti. Non effettua alcuna verifica sul fatto che la nuova posizione sia nei percorsi di root.
Metodo pubblico | MoveTo(String, DedDocMovReasonEnum) | Imposta il nome, estensione e percorso file in base al nuovo percorso passato, anche nei campi di checkout se non risultano vuoti. Non effettua alcuna verifica sul fatto che la nuova posizione sia nei percorsi di root. Per rendere effettive le modifiche apportate al documento chiamando questo metodo, chiamare uno degli overload del metodo Update().
Metodo pubblico | MyPwsVer | Restuituisce la versione del documento che è stato scaricato l'ultima volta nell'area locale. Restituisce Guid.Empty se non è mai stato scaricato.
Metodo pubblico | ReadAllProperties | Scrive le proprietà passate nel database.
Metodo pubblico | ReadMasterRevisionId | Legge il MASTERREVISIONID del documento ( usato nelll'import PackAndGo lato slave DedRemote)
Metodo pubblico | Refresh | Aggiorna questo oggetto rileggendo le informazioni presenti nel Database e dal file fisico. Effettua l'aggiornamento anche se l'oggetto è dirty: imposta dirty a false dopo l'aggiornamento.
Metodo pubblico | RefreshData | Aggiorna il contenuto del documento solo per quanto riguarda le informazioni presenti nel Database. Effettua l'aggiornamento anche se l'oggetto è dirty: imposta dirty a false dopo l'aggiornamento.
Metodo pubblico | RefreshInfoFile | Aggiorna i campi del documento leggendo solo le informazioni dal file fisico. Se il file non esiste non effettua alcuna operazione.
Metodo pubblico | RemoveCopyOfVaultFile | Rimuove la copia del file presente sul vault.
Metodo pubblico | RemoveDocStateHistory | Rimuove il record da DED_DOC_STATE_HISTORY.
Metodo pubblico | RemoveFromDetachedForAllCorporaets | Elimina il record dai detached per tutte le corporate
Metodo pubblico | RemoveFromDetachedForCorporate | Elimina il record dai detached per la corporate passata
Metodo pubblico | RemoveFromDetachedForMyCorporate | Elimina il record dai detached per la corporate corrente
Metodo pubblico | RestoreBackup | Reimposta nella tabella ded_data il record presente nella tabella di backup.
Metodo pubblico | RestoreBackupCfg | Reimposta nella tabella DED_DOC_CFG il record presente nella tabella di backup.
Metodo pubblico | RestoreCopyOfVaultFile | Rispristina la situazione presente nel vault prima del checkOut.
Metodo pubblico | SaveCopyOfVaultFile | Salva una copia del file sul vault (in modo che se viene fatto un annulla checkOut si possa ripristinare la vecchia situazione).
Metodo pubblico | SetAddInVersion | Imposta ADDINVERSION per il documento. Utilizzato ad esempio nella migrazione massiva per il controllo dell'elaborazione dei file.
Metodo pubblico | SetCheckIn | Imposta in CheckIn il documento. Effettua l'operazione aggiornando solo il campo CheckOut nel Database ponendo come vincolo che il documento sia in CheckOut dall'utente corrente.
Metodo pubblico | SetCheckIn(Boolean) | Imposta in CheckIn il documento. Effettua l'operazione aggiornando solo il campo CheckOut nel Database ponendo come vincolo che il documento sia in CheckOut dall'utente corrente. Se il parametro è true mette in check-in anche i documenti che risultano dipendendi Generici (.prt).
Metodo pubblico | SetCheckOutByMe | Imposta in CheckOut il documento dall'utente corrente. Effettua l'operazione aggiornando solo il campo CheckOut nel Database ponendo come vincolo che sia in CheckIn.
Metodo pubblico | SetCheckOutByMe(Boolean) | Imposta in CheckOut il documento dall'utente corrente. Effettua l'operazione aggiornando solo il campo CheckOut nel Database ponendo come vincolo che sia in CheckIn. Se il parametro è true mette in check-out anche i documenti che risultano dipendendi Generici (.prt).
Metodo pubblico | SetCheckOutLightRowVer | Imposta il guid nel campo del check-out-light.
Metodo pubblico | SetInternalName | Imposta l'INTERNALNAME del documento
Metodo pubblico | SetValue(DedAttr, Object) | Metodo per impostare i valori al documento. Se l'attributo passato in ingresso è marchiato con l'opzione "Solo Db" oppure "Calcolato", il settaggio NON verrà effettuato.
Metodo pubblico | SetValue(DedDocStandardDocFields, Object) | Imposta un campo standard con un nuovo valore. Se il campo non è compilato lo crea nel dizionario interno.
Metodo pubblico | SetValue(String, Object) | Metodo per impostare i valori al documento.
Metodo pubblico | Update | Aggiorna l'oggetto nel Database solo se questo è Dirty, poi imposta Dirty a false. La versione del record viene incrementata di 1 già la prima volta che si è modificato l'oggetto e resti dirty. Aggiorna il suo RowVer con uno nuovo.
Metodo pubblico | Update(Guid) | Aggiorna l'oggetto nel Database solo se questo è Dirty, poi imposta Dirty a false. La versione del record viene incrementata di 1 già la prima volta che si è modificato l'oggetto e resti dirty. Lo aggiorna usando il RowVer passato come argomento.
Metodo pubblico | UpdateSameRowVer | Aggiorna il documento senza modificare il suo RowVer (utilizzato per il move del documento).
Metodo pubblico | WasGeneratedFrom | Determina se il documento di pubblicazione è stato generato dal documento passato in quella versione
Metodo pubblico | WriteMasterRevisionId | Imposta il MASTERREVISIONID del documento ( usato nelll'import PackAndGo lato slave DedRemote)
Metodo pubblico | WritePropertiesInDb | Scrive le proprietà passate nel database.
Torna su
Operatori
Nome | Descrizione
Equality(DedDoc, DedDoc) | Ridefinizione dell'operatore ==.
Inequality(DedDoc, DedDoc) | Ridefinizione dell'operatore !=.
Torna su
Campi
 | Nome | Descrizione
Campo pubblico | _docID |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di DedDoc

Il tipo DedDoc espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione di appartenenza.
Proprietà pubblica | Attributi | Restituisce gli attributi del file.
Proprietà pubblica | Attrs | Restituisce la lista degli attributi con i rispettivi valori.
Proprietà pubblica | CheckoutData | Restituisce la data dell'ultima modifica del campo CheckoutUser oppure la data di creazione del record.
Proprietà pubblica | CheckoutEstensione | Restituisce l'estensione del file nel caso in cui si trovi in check-out, senza il punto iniziale.
Proprietà pubblica | CheckoutHost | Restituisce il nome della macchina dalla quale l'utente ha posto in checkout questo documento, oppure stringa vuota se è in check-in.
Proprietà pubblica | CheckOutNameWithExtension | Restituisce il nome del file compreso di estensione ma senza percorso, del file in check-out oppure stringa vuota se è in check-in. Viene utilizzato il nome di pws.
Proprietà pubblica | CheckoutNome | Restituisce il nome del file nel caso in cui si trovi in check-out.
Proprietà pubblica | CheckoutPercorso | Restituisce il percorso del file nel caso in cui si trovi in check-out.
Proprietà pubblica | CheckoutUser | Restituisce il nome dell'utente che ha posto in checkout questo documento, oppure stringa vuota se è in check-in.
Proprietà pubblica | Context | Restituisce il contesto dell'anagrafica per la quale il documento è stato richiesto oppure null nel caso in cui non sia stata creata in un ambito di anagrafica.
Proprietà pubblica | CurrentFullFileName | Restituisce il percorso completo del documento che l'applicazione può e deve utilizzare per leggere le informazioni del documento nel metodo RefreshInfoFile. Infatti restituisce il valore della proprietà FullFileName o FullCheckOutFileName in base al fatto che il documento sia in check-in o in check-out.
Proprietà pubblica | DataCreazione | Restituisce la data di creazione del file
Proprietà pubblica | DataCreazioneRecord | Restituisce la data di creazione del record.
Proprietà pubblica | DataModifica | Restituisce la data di ultima modifica del file
Proprietà pubblica | Dimensione | Restituisce la dimensione del file
Proprietà pubblica | Dirty | Restituisce se il documento sia da aggiornare nel Database.
Proprietà pubblica | DocDependences | Restituisce la collezione delle dipendenze di questo documento leggendole dal Database.
Proprietà pubblica | DocID | Restituisce l'ID di questa commessa.
Proprietà pubblica | DocIdAsString | Restituisce la rappresentazione stringa del DocId di questo documento.
Proprietà pubblica | Erased | Restituisce se il record del file sia stato cancellato dal Database.
Proprietà pubblica | Estensione | Restituisce l'estensione del file senza il punto iniziale.
Proprietà pubblica | FileExists | Restituisce se il file è presente su disco (nel vault o nella pws se è attiva l'area locale).
Proprietà pubblica | FileMarked | Restituisce il rowver del file.
Proprietà pubblica | FullCheckOutFileName | Restituisce il nome completo del file in check-out oppure stringa vuota se è in check-in. Permette anche di impostare i valori di CheckoutNome, CheckoutPercorso e CheckoutEstensione impostando un nome completo.
Proprietà pubblica | FullFileName | Restituisce il nome completo del file nel Database. Permette anche di impostare i valori di Nome, Percorso ed Estensione impostando un nome completo.
Proprietà pubblica | HasComms | Restituisce se il documento è associato ad almeno una commessa
Proprietà pubblica | HasData | Restituisce se il documento è associato ad almeno una anagrafica
Proprietà pubblica | HasNewVaultFileVersion |
Proprietà pubblica | HideInfo | Indica se nascondere le informazioni dell'elemento
Proprietà pubblica | InternalName | Restituisce l'internalName del file
Proprietà pubblica | IsCheckedIn | Restituisce se il documento è in check-in.
Proprietà pubblica | IsCheckedOutByMe | Restituisce se il record sia in CheckOut dall'utente corrente.
Proprietà pubblica | IsCheckedOutByMeOnOtherHost | Restituisce se il record sia in CheckOut dall'utente corrente ma su un altra macchina. E' un controllo specifico. Per il sistema è comunque in checkout da altro utente
Proprietà pubblica | IsCheckedOutByOther | Restituisce se il record sia in CheckOut da un utente differente dall'utente corrente.
Proprietà pubblica | IsNewVaultFile | Restituisce se, con attiva l'area locale, il documento sia nuovo ed in checkout ma non sia ancora stato pubblicato sul server.
Proprietà pubblica | Keys | Restituisce la lista delle chiavi presenti nell'anagrafica.
Proprietà pubblica | NameWithExtension | Restituisce il nome del file compreso di estensione ma senza percorso. Viene utilizzato il nome di vault.
Proprietà pubblica | Nome | Restituisce il nome del file senza estensione.
Proprietà pubblica | OldFile | Restituisce il nome completo del file prima che venisse archiviato.
Proprietà pubblica | ParentDocuments | Restituisce la collezione dei documenti genitore di questo documento.
Proprietà pubblica | ParoleChiave | Restituisce le parole chiave del documento.
Proprietà pubblica | Percorso | Restituisce il percorso del file.
Proprietà pubblica | PercorsoRooted | Ritorna il percorso rooted del documento. E' il valore effettivamente contenuto
Proprietà pubblica | PwsFileBackupName | Restituisce il nome da utilizzare come file di backup sul server, in occazione del checkout.
Proprietà pubblica | PwsFullPath | Restituisce il nome completo di questo documento se dovesse essere copiato nell'area locale. Questo valore viene impostato nelle proprietà di Checkout per impostare in Checkout il documento. Se non è attiva l'area locale viene restituito il percorso completo di vault.
Proprietà pubblica | RowVer | Restituisce il rowver del file.
Proprietà pubblica | Scala | Restitusice la Scala del documento (1:2, 1:10, ecc.).
Proprietà pubblica | SimilarDocuments | Restituisce la collezione dei documenti genitore di questo documento.
Proprietà pubblica | State | Ritorna lo stato attuale del documento.
Proprietà pubblica | UniqueDocDependences | Restituisce la collezione delle dipendenze di questo documento leggendole dal Database.
Proprietà pubblica | UniqueParentDocuments | Restituisce la collezione delle dipendenze di questo documento leggendole dal Database.
Proprietà pubblica | UtenteCreazioneRecord | Restituisce l'utente che ha creato questo documento.
Proprietà pubblica | Values | Restituisce la lista dei valori presenti nell'anagrafica.
Proprietà pubblica | VaultFileBackupName | Restituisce il nome da utilizzare come file di backup sul server, in occazione del checkout.
Proprietà pubblica | Versione | Restituisce il numero di versione di questo documento.
Torna su
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Proprietà DedDoc.Application

Proprietà DedDocApplication
Restituisce l'applicazione di appartenenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedNetApplication Application { get; }
Public ReadOnly Property Application As DedNetApplication
    Get
public:
property DedNetApplication^ Application {
    DedNetApplication^ get ();
}
member Application : DedNetApplication with get

Valore della proprietà

DedNetApplication
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Proprietà DedDoc.Attributi

Proprietà DedDocAttributi
Restituisce gli attributi del file.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public FileAttributes Attributi { get; }
Public ReadOnly Property Attributi As FileAttributes
    Get
public:
property FileAttributes Attributi {
    FileAttributes get ();
}
member Attributi : FileAttributes with get

Valore della proprietà

FileAttributes
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Proprietà DedDoc.Attrs

Proprietà DedDocAttrs
Restituisce la lista degli attributi con i rispettivi valori.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<string, Object> Attrs { get; }
Public ReadOnly Property Attrs As Dictionary(Of String, Object)
    Get
public:
property Dictionary<String^, Object^>^ Attrs {
    Dictionary<String^, Object^>^ get ();
}
member Attrs : Dictionary<string, Object> with get

Valore della proprietà

Dictionary String, Object
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Proprietà DedDoc.CheckoutData

Proprietà DedDocCheckoutData
Restituisce la data dell'ultima modifica del campo CheckoutUser oppure la data di creazione del record.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DateTime? CheckoutData { get; set; }
Public Property CheckoutData As DateTime?
    Get
    Set
public:
property Nullable<DateTime> CheckoutData {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
member CheckoutData : Nullable<DateTime> with get, set

Valore della proprietà

Nullable DateTime
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Proprietà DedDoc.CheckoutEstensione

Proprietà DedDocCheckoutEstensione
Restituisce l'estensione del file nel caso in cui si trovi in check-out, senza il punto iniziale.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string CheckoutEstensione { get; set; }
Public Property CheckoutEstensione As String
    Get
    Set
public:
property String^ CheckoutEstensione {
    String^ get ();
    void set (String^ value);
}
member CheckoutEstensione : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Proprietà DedDoc.CheckoutHost

Proprietà DedDocCheckoutHost
Restituisce il nome della macchina dalla quale l'utente ha posto in checkout questo documento, oppure stringa vuota se è in check-in.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string CheckoutHost { get; set; }
Public Property CheckoutHost As String
    Get
    Set
public:
property String^ CheckoutHost {
    String^ get ();
    void set (String^ value);
}
member CheckoutHost : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Proprietà DedDoc.CheckOutNameWithExtension

Proprietà DedDocCheckOutNameWithExtension
Restituisce il nome del file compreso di estensione ma senza percorso, del file in check-out oppure stringa vuota se è in check-in. Viene utilizzato il nome di pws.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string CheckOutNameWithExtension { get; }
Public ReadOnly Property CheckOutNameWithExtension As String
    Get
public:
property String^ CheckOutNameWithExtension {
    String^ get ();
}
member CheckOutNameWithExtension : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Proprietà DedDoc.CheckoutNome

Proprietà DedDocCheckoutNome
Restituisce il nome del file nel caso in cui si trovi in check-out.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string CheckoutNome { get; set; }
Public Property CheckoutNome As String
    Get
    Set
public:
property String^ CheckoutNome {
    String^ get ();
    void set (String^ value);
}
member CheckoutNome : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Proprietà DedDoc.CheckoutPercorso

Proprietà DedDocCheckoutPercorso
Restituisce il percorso del file nel caso in cui si trovi in check-out.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string CheckoutPercorso { get; set; }
Public Property CheckoutPercorso As String
    Get
    Set
public:
property String^ CheckoutPercorso {
    String^ get ();
    void set (String^ value);
}
member CheckoutPercorso : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Proprietà DedDoc.CheckoutUser

Proprietà DedDocCheckoutUser
Restituisce il nome dell'utente che ha posto in checkout questo documento, oppure stringa vuota se è in check-in.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string CheckoutUser { get; set; }
Public Property CheckoutUser As String
    Get
    Set
public:
property String^ CheckoutUser {
    String^ get ();
    void set (String^ value);
}
member CheckoutUser : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Proprietà DedDoc.Context

Proprietà DedDocContext
Restituisce il contesto dell'anagrafica per la quale il documento è stato richiesto oppure null nel caso in cui non sia stata creata in un ambito di anagrafica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocContext Context { get; }
Public ReadOnly Property Context As DedDocContext
    Get
public:
property DedDocContext^ Context {
    DedDocContext^ get ();
}
member Context : DedDocContext with get

Valore della proprietà

DedDocContext
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Proprietà DedDoc.CurrentFullFileName

Proprietà DedDocCurrentFullFileName
Restituisce il percorso completo del documento che l'applicazione può e deve utilizzare per leggere le informazioni del documento nel metodo RefreshInfoFile. Infatti restituisce il valore della proprietà FullFileName o FullCheckOutFileName in base al fatto che il documento sia in check-in o in check-out.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string CurrentFullFileName { get; }
Public ReadOnly Property CurrentFullFileName As String
    Get
public:
property String^ CurrentFullFileName {
    String^ get ();
}
member CurrentFullFileName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Proprietà DedDoc.DataCreazione

Proprietà DedDocDataCreazione
Restituisce la data di creazione del file

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DateTime DataCreazione { get; }
Public ReadOnly Property DataCreazione As DateTime
    Get
public:
property DateTime DataCreazione {
    DateTime get ();
}
member DataCreazione : DateTime with get

Valore della proprietà

DateTime
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Proprietà DedDoc.DataCreazioneRecord

Proprietà DedDocDataCreazioneRecord
Restituisce la data di creazione del record.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DateTime? DataCreazioneRecord { get; set; }
Public Property DataCreazioneRecord As DateTime?
    Get
    Set
public:
property Nullable<DateTime> DataCreazioneRecord {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
member DataCreazioneRecord : Nullable<DateTime> with get, set

Valore della proprietà

Nullable DateTime
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Proprietà DedDoc.DataModifica

Proprietà DedDocDataModifica
Restituisce la data di ultima modifica del file

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DateTime DataModifica { get; }
Public ReadOnly Property DataModifica As DateTime
    Get
public:
property DateTime DataModifica {
    DateTime get ();
}
member DataModifica : DateTime with get

Valore della proprietà

DateTime
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Proprietà DedDoc.Dimensione

Proprietà DedDocDimensione
Restituisce la dimensione del file

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public long Dimensione { get; }
Public ReadOnly Property Dimensione As Long
    Get
public:
property long long Dimensione {
    long long get ();
}
member Dimensione : int64 with get

Valore della proprietà

Int64
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Proprietà DedDoc.Dirty

Proprietà DedDocDirty
Restituisce se il documento sia da aggiornare nel Database.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Dirty { get; }
Public ReadOnly Property Dirty As Boolean
    Get
public:
property bool Dirty {
    bool get ();
}
member Dirty : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Proprietà DedDoc.DocDependences

Proprietà DedDocDocDependences
Restituisce la collezione delle dipendenze di questo documento leggendole dal Database.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocDepCollection DocDependences { get; }
Public ReadOnly Property DocDependences As DocDepCollection
    Get
public:
property DocDepCollection^ DocDependences {
    DocDepCollection^ get ();
}
member DocDependences : DocDepCollection with get

Valore della proprietà

DocDepCollection
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Proprietà DedDoc.DocID

Proprietà DedDocDocID
Restituisce l'ID di questa commessa.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Guid DocID { get; }
Public ReadOnly Property DocID As Guid
    Get
public:
property Guid DocID {
    Guid get ();
}
member DocID : Guid with get

Valore della proprietà

Guid
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Proprietà DedDoc.DocIdAsString

Proprietà DedDocDocIdAsString
Restituisce la rappresentazione stringa del DocId di questo documento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string DocIdAsString { get; }
Public ReadOnly Property DocIdAsString As String
    Get
public:
property String^ DocIdAsString {
    String^ get ();
}
member DocIdAsString : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Proprietà DedDoc.Erased

Proprietà DedDocErased
Restituisce se il record del file sia stato cancellato dal Database.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Erased { get; }
Public ReadOnly Property Erased As Boolean
    Get
public:
property bool Erased {
    bool get ();
}
member Erased : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Proprietà DedDoc.Estensione

Proprietà DedDocEstensione
Restituisce l'estensione del file senza il punto iniziale.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Estensione { get; set; }
Public Property Estensione As String
    Get
    Set
public:
property String^ Estensione {
    String^ get ();
    void set (String^ value);
}
member Estensione : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Proprietà DedDoc.FileExists

Proprietà DedDocFileExists
Restituisce se il file è presente su disco (nel vault o nella pws se è attiva l'area locale).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool FileExists { get; }
Public ReadOnly Property FileExists As Boolean
    Get
public:
property bool FileExists {
    bool get ();
}
member FileExists : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Proprietà DedDoc.FileMarked

Proprietà DedDocFileMarked
Restituisce il rowver del file.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool FileMarked { get; }
Public ReadOnly Property FileMarked As Boolean
    Get
public:
property bool FileMarked {
    bool get ();
}
member FileMarked : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Proprietà DedDoc.FullCheckOutFileName

Proprietà DedDocFullCheckOutFileName
Restituisce il nome completo del file in check-out oppure stringa vuota se è in check-in. Permette anche di impostare i valori di CheckoutNome, CheckoutPercorso e CheckoutEstensione impostando un nome completo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string FullCheckOutFileName { get; }
Public ReadOnly Property FullCheckOutFileName As String
    Get
public:
property String^ FullCheckOutFileName {
    String^ get ();
}
member FullCheckOutFileName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Proprietà DedDoc.FullFileName

Proprietà DedDocFullFileName
Restituisce il nome completo del file nel Database. Permette anche di impostare i valori di Nome, Percorso ed Estensione impostando un nome completo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string FullFileName { get; }
Public ReadOnly Property FullFileName As String
    Get
public:
property String^ FullFileName {
    String^ get ();
}
member FullFileName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Proprietà DedDoc.HasComms

Proprietà DedDocHasComms
Restituisce se il documento è associato ad almeno una commessa

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasComms { get; }
Public ReadOnly Property HasComms As Boolean
    Get
public:
property bool HasComms {
    bool get ();
}
member HasComms : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Proprietà DedDoc.HasData

Proprietà DedDocHasData
Restituisce se il documento è associato ad almeno una anagrafica

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasData { get; }
Public ReadOnly Property HasData As Boolean
    Get
public:
property bool HasData {
    bool get ();
}
member HasData : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Proprietà DedDoc.HasNewVaultFileVersion

Proprietà DedDocHasNewVaultFileVersion

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasNewVaultFileVersion { get; }
Public ReadOnly Property HasNewVaultFileVersion As Boolean
    Get
public:
property bool HasNewVaultFileVersion {
    bool get ();
}
member HasNewVaultFileVersion : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Proprietà DedDoc.HideInfo

Proprietà DedDocHideInfo
Indica se nascondere le informazioni dell'elemento

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HideInfo { get; set; }
Public Property HideInfo As Boolean
    Get
    Set
public:
property bool HideInfo {
    bool get ();
    void set (bool value);
}
member HideInfo : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Proprietà DedDoc.InternalName

Proprietà DedDocInternalName
Restituisce l'internalName del file

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string InternalName { get; }
Public ReadOnly Property InternalName As String
    Get
public:
property String^ InternalName {
    String^ get ();
}
member InternalName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Proprietà DedDoc.IsCheckedIn

Proprietà DedDocIsCheckedIn
Restituisce se il documento è in check-in.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsCheckedIn { get; }
Public ReadOnly Property IsCheckedIn As Boolean
    Get
public:
property bool IsCheckedIn {
    bool get ();
}
member IsCheckedIn : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Proprietà DedDoc.IsCheckedOutByMe

Proprietà DedDocIsCheckedOutByMe
Restituisce se il record sia in CheckOut dall'utente corrente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsCheckedOutByMe { get; }
Public ReadOnly Property IsCheckedOutByMe As Boolean
    Get
public:
property bool IsCheckedOutByMe {
    bool get ();
}
member IsCheckedOutByMe : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Proprietà DedDoc.IsCheckedOutByMeOnOtherHost

Proprietà DedDocIsCheckedOutByMeOnOtherHost
Restituisce se il record sia in CheckOut dall'utente corrente ma su un altra macchina. E' un controllo specifico. Per il sistema è comunque in checkout da altro utente

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsCheckedOutByMeOnOtherHost { get; }
Public ReadOnly Property IsCheckedOutByMeOnOtherHost As Boolean
    Get
public:
property bool IsCheckedOutByMeOnOtherHost {
    bool get ();
}
member IsCheckedOutByMeOnOtherHost : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Proprietà DedDoc.IsCheckedOutByOther

Proprietà DedDocIsCheckedOutByOther
Restituisce se il record sia in CheckOut da un utente differente dall'utente corrente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsCheckedOutByOther { get; }
Public ReadOnly Property IsCheckedOutByOther As Boolean
    Get
public:
property bool IsCheckedOutByOther {
    bool get ();
}
member IsCheckedOutByOther : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Proprietà DedDoc.IsNewVaultFile

Proprietà DedDocIsNewVaultFile
Restituisce se, con attiva l'area locale, il documento sia nuovo ed in checkout ma non sia ancora stato pubblicato sul server.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsNewVaultFile { get; }
Public ReadOnly Property IsNewVaultFile As Boolean
    Get
public:
property bool IsNewVaultFile {
    bool get ();
}
member IsNewVaultFile : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Proprietà DedDoc.Keys

Proprietà DedDocKeys
Restituisce la lista delle chiavi presenti nell'anagrafica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string[] Keys { get; }
Public ReadOnly Property Keys As String()
    Get
public:
property array<String^>^ Keys {
    array<String^>^ get ();
}
member Keys : string[] with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Proprietà DedDoc.NameWithExtension

Proprietà DedDocNameWithExtension
Restituisce il nome del file compreso di estensione ma senza percorso. Viene utilizzato il nome di vault.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string NameWithExtension { get; }
Public ReadOnly Property NameWithExtension As String
    Get
public:
property String^ NameWithExtension {
    String^ get ();
}
member NameWithExtension : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Proprietà DedDoc.Nome

Proprietà DedDocNome
Restituisce il nome del file senza estensione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Nome { get; set; }
Public Property Nome As String
    Get
    Set
public:
property String^ Nome {
    String^ get ();
    void set (String^ value);
}
member Nome : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Proprietà DedDoc.OldFile

Proprietà DedDocOldFile
Restituisce il nome completo del file prima che venisse archiviato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string OldFile { get; set; }
Public Property OldFile As String
    Get
    Set
public:
property String^ OldFile {
    String^ get ();
    void set (String^ value);
}
member OldFile : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Proprietà DedDoc.ParentDocuments

Proprietà DedDocParentDocuments
Restituisce la collezione dei documenti genitore di questo documento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocDepCollection ParentDocuments { get; }
Public ReadOnly Property ParentDocuments As DocDepCollection
    Get
public:
property DocDepCollection^ ParentDocuments {
    DocDepCollection^ get ();
}
member ParentDocuments : DocDepCollection with get

Valore della proprietà

DocDepCollection
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Proprietà DedDoc.ParoleChiave

Proprietà DedDocParoleChiave
Restituisce le parole chiave del documento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string ParoleChiave { get; set; }
Public Property ParoleChiave As String
    Get
    Set
public:
property String^ ParoleChiave {
    String^ get ();
    void set (String^ value);
}
member ParoleChiave : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Proprietà DedDoc.Percorso

Proprietà DedDocPercorso
Restituisce il percorso del file.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Percorso { get; set; }
Public Property Percorso As String
    Get
    Set
public:
property String^ Percorso {
    String^ get ();
    void set (String^ value);
}
member Percorso : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Proprietà DedDoc.PercorsoRooted

Proprietà DedDocPercorsoRooted
Ritorna il percorso rooted del documento. E' il valore effettivamente contenuto

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string PercorsoRooted { get; set; }
Public Property PercorsoRooted As String
    Get
    Set
public:
property String^ PercorsoRooted {
    String^ get ();
    void set (String^ value);
}
member PercorsoRooted : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Proprietà DedDoc.PwsFileBackupName

Proprietà DedDocPwsFileBackupName
Restituisce il nome da utilizzare come file di backup sul server, in occazione del checkout.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string PwsFileBackupName { get; }
Public ReadOnly Property PwsFileBackupName As String
    Get
public:
property String^ PwsFileBackupName {
    String^ get ();
}
member PwsFileBackupName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Proprietà DedDoc.PwsFullPath

Proprietà DedDocPwsFullPath
Restituisce il nome completo di questo documento se dovesse essere copiato nell'area locale. Questo valore viene impostato nelle proprietà di Checkout per impostare in Checkout il documento. Se non è attiva l'area locale viene restituito il percorso completo di vault.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string PwsFullPath { get; }
Public ReadOnly Property PwsFullPath As String
    Get
public:
property String^ PwsFullPath {
    String^ get ();
}
member PwsFullPath : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Proprietà DedDoc.RowVer

Proprietà DedDocRowVer
Restituisce il rowver del file.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Guid RowVer { get; }
Public ReadOnly Property RowVer As Guid
    Get
public:
property Guid RowVer {
    Guid get ();
}
member RowVer : Guid with get

Valore della proprietà

Guid
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Proprietà DedDoc.Scala

Proprietà DedDocScala
Restitusice la Scala del documento (1:2, 1:10, ecc.).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Scala { get; set; }
Public Property Scala As String
    Get
    Set
public:
property String^ Scala {
    String^ get ();
    void set (String^ value);
}
member Scala : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Proprietà DedDoc.SimilarDocuments

Proprietà DedDocSimilarDocuments
Restituisce la collezione dei documenti genitore di questo documento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocList SimilarDocuments { get; }
Public ReadOnly Property SimilarDocuments As DedDocList
    Get
public:
property DedDocList^ SimilarDocuments {
    DedDocList^ get ();
}
member SimilarDocuments : DedDocList with get

Valore della proprietà

DedDocList
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Proprietà DedDoc.State

Proprietà DedDocState
Ritorna lo stato attuale del documento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocumentStateEnum State { get; }
Public ReadOnly Property State As DocumentStateEnum
    Get
public:
property DocumentStateEnum State {
    DocumentStateEnum get ();
}
member State : DocumentStateEnum with get

Valore della proprietà

DocumentStateEnum
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Proprietà DedDoc.UniqueDocDependences

Proprietà DedDocUniqueDocDependences
Restituisce la collezione delle dipendenze di questo documento leggendole dal Database.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocDepCollection UniqueDocDependences { get; }
Public ReadOnly Property UniqueDocDependences As DocDepCollection
    Get
public:
property DocDepCollection^ UniqueDocDependences {
    DocDepCollection^ get ();
}
member UniqueDocDependences : DocDepCollection with get

Valore della proprietà

DocDepCollection
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Proprietà DedDoc.UniqueParentDocuments

Proprietà DedDocUniqueParentDocuments
Restituisce la collezione delle dipendenze di questo documento leggendole dal Database.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocDepCollection UniqueParentDocuments { get; }
Public ReadOnly Property UniqueParentDocuments As DocDepCollection
    Get
public:
property DocDepCollection^ UniqueParentDocuments {
    DocDepCollection^ get ();
}
member UniqueParentDocuments : DocDepCollection with get

Valore della proprietà

DocDepCollection
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Proprietà DedDoc.UtenteCreazioneRecord

Proprietà DedDocUtenteCreazioneRecord
Restituisce l'utente che ha creato questo documento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string UtenteCreazioneRecord { get; set; }
Public Property UtenteCreazioneRecord As String
    Get
    Set
public:
property String^ UtenteCreazioneRecord {
    String^ get ();
    void set (String^ value);
}
member UtenteCreazioneRecord : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Proprietà DedDoc.Values

Proprietà DedDocValues
Restituisce la lista dei valori presenti nell'anagrafica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object[] Values { get; }
Public ReadOnly Property Values As Object()
    Get
public:
property array<Object^>^ Values {
    array<Object^>^ get ();
}
member Values : Object[] with get

Valore della proprietà

Object
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Proprietà DedDoc.VaultFileBackupName

Proprietà DedDocVaultFileBackupName
Restituisce il nome da utilizzare come file di backup sul server, in occazione del checkout.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string VaultFileBackupName { get; }
Public ReadOnly Property VaultFileBackupName As String
    Get
public:
property String^ VaultFileBackupName {
    String^ get ();
}
member VaultFileBackupName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Proprietà DedDoc.Versione

Proprietà DedDocVersione
Restituisce il numero di versione di questo documento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int Versione { get; set; }
Public Property Versione As Integer
    Get
    Set
public:
property int Versione {
    int get ();
    void set (int value);
}
member Versione : int with get, set

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodi di DedDoc

Il tipo DedDoc espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AddDocStateHistory | Aggiunge un record in DED_DOC_STATE_HISTORY relativo all'operazione e all'utente corrente.
Metodo pubblico | AddPublishInfo | Aggiunte le informazioni del documento tra i descrittori di pubblicazione
Metodo pubblico | AddToDetachedForAllCorporates | Aggiunge nella tabella DED_DOC_DETACHED il record.
Metodo pubblico | AddToDetachedForCorporate | Aggiunge nella tabella DED_DOC_DETACHED il record.
Metodo pubblico | AddToTranferHistory | Aggiunge nella tabella DED_TRANSFER_DOCS il record.
Metodo pubblico | AddUserDoc | Aggiunge o aggiorna il record in DED_DOC_USER relativo a questo documento per l'utente corrente.
Metodo pubblico | ClearParentDocuments | Pulisce la struttura dei padri forzando la lettura al successivo accesso alla proprietà
Metodo pubblico | CurVer | Restuituisce la versione del documento presente nel Vault. Restituisce Guid.Empty se non è riuscito a trovarlo.
Metodo pubblico | Delete | Elimina il documento dalla tabella dei documenti. Non lo elimina dalla tabella di collegamento con le anagrafiche ma elimina tutte le sue dipendenze figlie e dei documenti padri.
Metodo pubblico | DeleteBackup | Elimina il backup di un documento, effettuato in fase di checkout.
Metodo pubblico | DeleteBackup(Boolean) | Elimina il backup di un documento, effettuato in fase di checkout.
Metodo pubblico | DeleteBackupCfg | Elimina il backup di un documento, effettuato in fase di checkout.
Metodo pubblico | DeleteDocFromUserDoc | Elimina il record in DED_DOC_USER relativo a questo documento.
Metodo pubblico | DeleteUserDoc | Elimina il record in DED_DOC_USER relativo a questo utente ed a questo documento.
Metodo pubblico | Equals | Ridefinizione di uguaglianza. (Sovrascrive ObjectEquals(Object))
Metodo pubblico | ErasePublishInfo | Elimina le informazioni del documento dai descrittori di pubblicazione
Metodo pubblico | ForceDirty | Forza il documento a diventare dirty per far si che si aggiorni nel Database. Utilizzato dai client che devono aggiornare il documento (magari solo il rowver) ma che di fatto non gli hanno modificato niente rispetto a prima.
Metodo pubblico | ForceMarkerAlignment | Forza il valore del ROWVER presente nel Database all'interno del documento sul server.
Metodo pubblico | ForzaCheckIn | Imposta il documento in CheckIn anche se non è in CheckOut dall'utente corrente.
Metodo pubblico | GetAddInVersion | Legge ADDINVERSION per il documento. Utilizzato ad esempio nella migrazione massiva per il controllo dell'elaborazione dei file.
Metodo pubblico | GetAllAttachData | Restituisce la lista di tutte le anagrafiche nelle quali questo documento è collegato come allegato. Se non ce ne sono restituisce comunque una lista inizializzata.
Metodo pubblico | GetAllMovingFileNames | Restituisce una lista contenente tutti i FileName avuti da questo documento (compreso quello attuale).
Metodo pubblico | GetAllMovingFileNames(Boolean) | Restituisce una lista contenente tutti i FileName avuti da questo documento.
Metodo pubblico | GetAllPrimaryData | Restituisce la lista di tutte le anagrafiche nelle quali questo documento è collegato come file primario. Se non ce ne sono restituisce comunque una lista inizializzata.
Metodo pubblico | GetAllPrimaryData(String) | Restituisce la lista di tutte le anagrafiche nelle quali questo documento è collegato come file primario nella configurazione passata
Metodo pubblico | GetAllPrimaryDataNotLinked | Restituisce la lista di tutte le anagrafiche nelle quali questo documento è collegato come file primario ma non linkato. Se non ce ne sono restituisce comunque una lista inizializzata.
Metodo pubblico | GetAllSparePartsData | Restituisce la lista di tutte le anagrafiche nelle quali questo documento è collegato come ricambio
Metodo pubblico | GetAllSparePartsData(String) | Restituisce la lista di tutte le anagrafiche nelle quali questo documento è collegato come ricambio nella configurazione passata Se non ce ne sono restituisce comunque una lista inizializzata.
Metodo pubblico | GetCheckOutLightRowVer | Restituisce il guid presente nel campo del check-out-light.
Metodo pubblico | GetCommCount | Restituisce il numero di commesse collegate a questo elemento
Metodo pubblico | GetComms | Restituisce la lista di commesse collegate a questo documento
Metodo pubblico | GetData | Restituisce la lista di anagrafiche collegate a questo documento. Se non ce ne sono restituisce comunque una lista inizializzata.
Metodo pubblico | GetData(DedDocContextEnum) | Restituisce la lista di anagrafiche collegate a questo documento in base ad un particolare contesto. Se non ce ne sono restituisce comunque una lista inizializzata.
Metodo pubblico | GetData(String, FuncDedDocContext, Boolean) | Funzione generica che cicla le anagrafiche ed in base alle lambda passate discrimina la lista in uscita
Metodo pubblico | GetDataCount | Restituisce il numero di anagrafiche collegate a questo documento.
Metodo pubblico | GetDataNotLinked | Restituisce la lista di anagrafiche collegate a questo documento che NON SONO in un contesto di link. Se non ce ne sono restituisce comunque una lista inizializzata.
Metodo pubblico | GetDataNotLinked(String) | Restituisce la lista di anagrafiche collegate a questo documento che NON SONO in un contesto di link. Se non ce ne sono restituisce comunque una lista inizializzata.
Metodo pubblico | GetDocVersionFromStateHistory | Data l'operazione e il rowver del documento, ritrova la versione
Metodo pubblico | GetHashCode | Restituisce l'HashCode di questo oggetto. (Sovrascrive ObjectGetHashCode)
Metodo pubblico | GetRootInfo | Restitiusce le informazioni di root dei path attuali per questo documento.
Metodo pubblico | GetStrictPrimaryData | Restituisce la lista di tutte le anagrafiche nelle quali questo documento è collegato come strettamente primario
Metodo pubblico | GetStrictPrimaryData(String) | Restituisce la lista di tutte le anagrafiche nelle quali questo documento è collegato come strettamente primario nella configurazione passata
Metodo pubblico | GetStrictPrimaryDataNotLinked | Restituisce la lista di tutte le anagrafiche nelle quali questo documento è collegato come strettamente primario ma non linkato
Metodo pubblico | GetValue(DedDocStandardDocFields) | Restituisce il contenuto di uno dei campi standard oppure null se non è presente.
Metodo pubblico | GetValue(String) | Metodo che restituisce i valori del documento.
Metodo pubblico | HasAtLeastOneLinkingContext | Retituisce true se il documento ha almeno un contesto di linking nei confronti di una anagrafica
Metodo pubblico | HasMoreThanOneConfigContext | Ritorna true se il documento è associato a più anagrafiche con diverse configurazioni
Metodo pubblico | HasOperationInStateHistory | Ritorna true se nella storia delle operazioni del documento ne esiste almeno una di questo tipo
Metodo pubblico | IsDetachedForCorporate | Ritorna vero se il documento è effettivamente segnalato come disallineato per la corporate passata
Metodo pubblico | IsDetachedForMyCorporate | Ritorna vero se il documento è efffettivamente segnalato come disallineato per la corporate corrente
Metodo pubblico | IsMovingDestination | Indica se il documento deriva da un moving di un altro documento.
Metodo pubblico | IsMyPwsDocEqualsToVaultDoc | Verifica se la versione del documento in locale è uguale a quella nel vault.
Metodo pubblico | IsVaultDocUpToDate | Verifica se la versione del file su vault coincide con la versione del database. In caso di modalità non detached torna sempre true.
Metodo pubblico | MoveTo(String) | Imposta il nome, estensione e percorso file in base al nuovo percorso passato, anche nei campi di checkout se non risultano vuoti. Non effettua alcuna verifica sul fatto che la nuova posizione sia nei percorsi di root.
Metodo pubblico | MoveTo(String, DedDocMovReasonEnum) | Imposta il nome, estensione e percorso file in base al nuovo percorso passato, anche nei campi di checkout se non risultano vuoti. Non effettua alcuna verifica sul fatto che la nuova posizione sia nei percorsi di root. Per rendere effettive le modifiche apportate al documento chiamando questo metodo, chiamare uno degli overload del metodo Update().
Metodo pubblico | MyPwsVer | Restuituisce la versione del documento che è stato scaricato l'ultima volta nell'area locale. Restituisce Guid.Empty se non è mai stato scaricato.
Metodo pubblico | ReadAllProperties | Scrive le proprietà passate nel database.
Metodo pubblico | ReadMasterRevisionId | Legge il MASTERREVISIONID del documento ( usato nelll'import PackAndGo lato slave DedRemote)
Metodo pubblico | Refresh | Aggiorna questo oggetto rileggendo le informazioni presenti nel Database e dal file fisico. Effettua l'aggiornamento anche se l'oggetto è dirty: imposta dirty a false dopo l'aggiornamento.
Metodo pubblico | RefreshData | Aggiorna il contenuto del documento solo per quanto riguarda le informazioni presenti nel Database. Effettua l'aggiornamento anche se l'oggetto è dirty: imposta dirty a false dopo l'aggiornamento.
Metodo pubblico | RefreshInfoFile | Aggiorna i campi del documento leggendo solo le informazioni dal file fisico. Se il file non esiste non effettua alcuna operazione.
Metodo pubblico | RemoveCopyOfVaultFile | Rimuove la copia del file presente sul vault.
Metodo pubblico | RemoveDocStateHistory | Rimuove il record da DED_DOC_STATE_HISTORY.
Metodo pubblico | RemoveFromDetachedForAllCorporaets | Elimina il record dai detached per tutte le corporate
Metodo pubblico | RemoveFromDetachedForCorporate | Elimina il record dai detached per la corporate passata
Metodo pubblico | RemoveFromDetachedForMyCorporate | Elimina il record dai detached per la corporate corrente
Metodo pubblico | RestoreBackup | Reimposta nella tabella ded_data il record presente nella tabella di backup.
Metodo pubblico | RestoreBackupCfg | Reimposta nella tabella DED_DOC_CFG il record presente nella tabella di backup.
Metodo pubblico | RestoreCopyOfVaultFile | Rispristina la situazione presente nel vault prima del checkOut.
Metodo pubblico | SaveCopyOfVaultFile | Salva una copia del file sul vault (in modo che se viene fatto un annulla checkOut si possa ripristinare la vecchia situazione).
Metodo pubblico | SetAddInVersion | Imposta ADDINVERSION per il documento. Utilizzato ad esempio nella migrazione massiva per il controllo dell'elaborazione dei file.
Metodo pubblico | SetCheckIn | Imposta in CheckIn il documento. Effettua l'operazione aggiornando solo il campo CheckOut nel Database ponendo come vincolo che il documento sia in CheckOut dall'utente corrente.
Metodo pubblico | SetCheckIn(Boolean) | Imposta in CheckIn il documento. Effettua l'operazione aggiornando solo il campo CheckOut nel Database ponendo come vincolo che il documento sia in CheckOut dall'utente corrente. Se il parametro è true mette in check-in anche i documenti che risultano dipendendi Generici (.prt).
Metodo pubblico | SetCheckOutByMe | Imposta in CheckOut il documento dall'utente corrente. Effettua l'operazione aggiornando solo il campo CheckOut nel Database ponendo come vincolo che sia in CheckIn.
Metodo pubblico | SetCheckOutByMe(Boolean) | Imposta in CheckOut il documento dall'utente corrente. Effettua l'operazione aggiornando solo il campo CheckOut nel Database ponendo come vincolo che sia in CheckIn. Se il parametro è true mette in check-out anche i documenti che risultano dipendendi Generici (.prt).
Metodo pubblico | SetCheckOutLightRowVer | Imposta il guid nel campo del check-out-light.
Metodo pubblico | SetInternalName | Imposta l'INTERNALNAME del documento
Metodo pubblico | SetValue(DedAttr, Object) | Metodo per impostare i valori al documento. Se l'attributo passato in ingresso è marchiato con l'opzione "Solo Db" oppure "Calcolato", il settaggio NON verrà effettuato.
Metodo pubblico | SetValue(DedDocStandardDocFields, Object) | Imposta un campo standard con un nuovo valore. Se il campo non è compilato lo crea nel dizionario interno.
Metodo pubblico | SetValue(String, Object) | Metodo per impostare i valori al documento.
Metodo pubblico | Update | Aggiorna l'oggetto nel Database solo se questo è Dirty, poi imposta Dirty a false. La versione del record viene incrementata di 1 già la prima volta che si è modificato l'oggetto e resti dirty. Aggiorna il suo RowVer con uno nuovo.
Metodo pubblico | Update(Guid) | Aggiorna l'oggetto nel Database solo se questo è Dirty, poi imposta Dirty a false. La versione del record viene incrementata di 1 già la prima volta che si è modificato l'oggetto e resti dirty. Lo aggiorna usando il RowVer passato come argomento.
Metodo pubblico | UpdateSameRowVer | Aggiorna il documento senza modificare il suo RowVer (utilizzato per il move del documento).
Metodo pubblico | WasGeneratedFrom | Determina se il documento di pubblicazione è stato generato dal documento passato in quella versione
Metodo pubblico | WriteMasterRevisionId | Imposta il MASTERREVISIONID del documento ( usato nelll'import PackAndGo lato slave DedRemote)
Metodo pubblico | WritePropertiesInDb | Scrive le proprietà passate nel database.
Torna su
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.AddDocStateHistory

Metodo DedDocAddDocStateHistory
Aggiunge un record in DED_DOC_STATE_HISTORY relativo all'operazione e all'utente corrente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddDocStateHistory(
    string operation
)
Public Sub AddDocStateHistory (
    operation As String
)
public:
void AddDocStateHistory(
    String^ operation
)
member AddDocStateHistory :
        operation : string -> unit

Parametri

operation String
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.AddPublishInfo

Metodo DedDocAddPublishInfo
Aggiunte le informazioni del documento tra i descrittori di pubblicazione

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AddPublishInfo(
    DedDoc srcDoc
)
Public Function AddPublishInfo (
    srcDoc As DedDoc
) As Boolean
public:
bool AddPublishInfo(
    DedDoc^ srcDoc
)
member AddPublishInfo :
        srcDoc : DedDoc -> bool

Parametri

srcDoc DedDoc
Documento sorgente di pubblicazione

Valore di ritorno

Boolean
Ritorna l'esito dell'operazione
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.AddToDetachedForAllCorporates

Metodo DedDocAddToDetachedForAllCorporates
Aggiunge nella tabella DED_DOC_DETACHED il record.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AddToDetachedForAllCorporates()
Public Function AddToDetachedForAllCorporates As Boolean
public:
bool AddToDetachedForAllCorporates()
member AddToDetachedForAllCorporates : unit -> bool

Valore di ritorno

Boolean
Restituisce se l'operazione è andata a buon fine.
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.AddToDetachedForCorporate

Metodo DedDocAddToDetachedForCorporate
Aggiunge nella tabella DED_DOC_DETACHED il record.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AddToDetachedForCorporate(
    DedCorporate corporate
)
Public Function AddToDetachedForCorporate (
    corporate As DedCorporate
) As Boolean
public:
bool AddToDetachedForCorporate(
    DedCorporate^ corporate
)
member AddToDetachedForCorporate :
        corporate : DedCorporate -> bool

Parametri

corporate DedCorporate

Valore di ritorno

Boolean
Restituisce se l'operazione è andata a buon fine.
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.AddToTranferHistory

Metodo DedDocAddToTranferHistory
Aggiunge nella tabella DED_TRANSFER_DOCS il record.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AddToTranferHistory(
    DedCorporate corporateFrom,
    Guid transDocRowVer,
    Guid transferId
)
Public Function AddToTranferHistory (
    corporateFrom As DedCorporate,
    transDocRowVer As Guid,
    transferId As Guid
) As Boolean
public:
bool AddToTranferHistory(
    DedCorporate^ corporateFrom,
    Guid transDocRowVer,
    Guid transferId
)
member AddToTranferHistory :
        corporateFrom : DedCorporate *
        transDocRowVer : Guid *
        transferId : Guid -> bool

Parametri

corporateFrom DedCorporate
transDocRowVer Guid
transferId Guid

Valore di ritorno

Boolean
Restituisce se l'operazione è andata a buon fine.
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.AddUserDoc

Metodo DedDocAddUserDoc
Aggiunge o aggiorna il record in DED_DOC_USER relativo a questo documento per l'utente corrente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AddUserDoc()
Public Function AddUserDoc As Boolean
public:
bool AddUserDoc()
member AddUserDoc : unit -> bool

Valore di ritorno

Boolean
Restituisce se l'operazione è andata a buon fine.
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.ClearParentDocuments

Metodo DedDocClearParentDocuments
Pulisce la struttura dei padri forzando la lettura al successivo accesso alla proprietà

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ClearParentDocuments()
Public Sub ClearParentDocuments
public:
void ClearParentDocuments()
member ClearParentDocuments : unit -> unit
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.CurVer

Metodo DedDocCurVer
Restuituisce la versione del documento presente nel Vault. Restituisce Guid.Empty se non è riuscito a trovarlo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Guid CurVer()
Public Function CurVer As Guid
public:
Guid CurVer()
member CurVer : unit -> Guid

Valore di ritorno

Guid
La versione del documento presente nel Vault.
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.Delete

Metodo DedDocDelete
Elimina il documento dalla tabella dei documenti. Non lo elimina dalla tabella di collegamento con le anagrafiche ma elimina tutte le sue dipendenze figlie e dei documenti padri.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Delete(
    bool _skipDeletionTracking
)
Public Sub Delete (
    _skipDeletionTracking As Boolean
)
public:
void Delete(
    bool _skipDeletionTracking
)
member Delete :
        _skipDeletionTracking : bool -> unit

Parametri

_skipDeletionTracking Boolean
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.DeleteBackup

Metodo DedDocDeleteBackup
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | DeleteBackup | Elimina il backup di un documento, effettuato in fase di checkout.
Metodo pubblico | DeleteBackup(Boolean) | Elimina il backup di un documento, effettuato in fase di checkout.
Torna su
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.DeleteBackup

Metodo DedDocDeleteBackup
Elimina il backup di un documento, effettuato in fase di checkout.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool DeleteBackup()
Public Function DeleteBackup As Boolean
public:
bool DeleteBackup()
member DeleteBackup : unit -> bool

Valore di ritorno

Boolean
Restituisce se l'operazione è andata a buon fine.
Vedi anche

Documentazione

Classe DedDoc
Overload di DeleteBackup
Namespace DedNet.Core


Metodo DedDoc.DeleteBackup(Boolean)

Metodo DedDocDeleteBackup(Boolean)
Elimina il backup di un documento, effettuato in fase di checkout.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool DeleteBackup(
    bool dependences
)
Public Function DeleteBackup (
    dependences As Boolean
) As Boolean
public:
bool DeleteBackup(
    bool dependences
)
member DeleteBackup :
        dependences : bool -> bool

Parametri

dependences Boolean

Valore di ritorno

Boolean
Restituisce se l'operazione è andata a buon fine.
Vedi anche

Documentazione

Classe DedDoc
Overload di DeleteBackup
Namespace DedNet.Core


Metodo DedDoc.DeleteBackupCfg

Metodo DedDocDeleteBackupCfg
Elimina il backup di un documento, effettuato in fase di checkout.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool DeleteBackupCfg()
Public Function DeleteBackupCfg As Boolean
public:
bool DeleteBackupCfg()
member DeleteBackupCfg : unit -> bool

Valore di ritorno

Boolean
Restituisce se l'operazione è andata a buon fine.
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.DeleteDocFromUserDoc

Metodo DedDocDeleteDocFromUserDoc
Elimina il record in DED_DOC_USER relativo a questo documento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool DeleteDocFromUserDoc()
Public Function DeleteDocFromUserDoc As Boolean
public:
bool DeleteDocFromUserDoc()
member DeleteDocFromUserDoc : unit -> bool

Valore di ritorno

Boolean
Restituisce se l'operazione è andata a buon fine.
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.DeleteUserDoc

Metodo DedDocDeleteUserDoc
Elimina il record in DED_DOC_USER relativo a questo utente ed a questo documento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool DeleteUserDoc()
Public Function DeleteUserDoc As Boolean
public:
bool DeleteUserDoc()
member DeleteUserDoc : unit -> bool

Valore di ritorno

Boolean
Restituisce se l'operazione è andata a buon fine.
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.Equals

Metodo DedDocEquals
Ridefinizione di uguaglianza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj Object
Oggetto da confrontare.

Valore di ritorno

Boolean
Restituisce true se l'oggetto è uguale a questo.
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.ErasePublishInfo

Metodo DedDocErasePublishInfo
Elimina le informazioni del documento dai descrittori di pubblicazione

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ErasePublishInfo()
Public Function ErasePublishInfo As Boolean
public:
bool ErasePublishInfo()
member ErasePublishInfo : unit -> bool

Valore di ritorno

Boolean
Ritorna l'esito dell'operazione
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.ForceDirty

Metodo DedDocForceDirty
Forza il documento a diventare dirty per far si che si aggiorni nel Database. Utilizzato dai client che devono aggiornare il documento (magari solo il rowver) ma che di fatto non gli hanno modificato niente rispetto a prima.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ForceDirty()
Public Sub ForceDirty
public:
void ForceDirty()
member ForceDirty : unit -> unit
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.ForceMarkerAlignment

Metodo DedDocForceMarkerAlignment
Forza il valore del ROWVER presente nel Database all'interno del documento sul server.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ForceMarkerAlignment()
Public Sub ForceMarkerAlignment
public:
void ForceMarkerAlignment()
member ForceMarkerAlignment : unit -> unit
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.ForzaCheckIn

Metodo DedDocForzaCheckIn
Imposta il documento in CheckIn anche se non è in CheckOut dall'utente corrente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ForzaCheckIn()
Public Sub ForzaCheckIn
public:
void ForzaCheckIn()
member ForzaCheckIn : unit -> unit
Eccezioni
Eccezione | Condizione
QsException | Viene sollevata in caso di errore nell'istruzione di aggiornamento dati.
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.GetAddInVersion

Metodo DedDocGetAddInVersion
Legge ADDINVERSION per il documento. Utilizzato ad esempio nella migrazione massiva per il controllo dell'elaborazione dei file.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public long GetAddInVersion()
Public Function GetAddInVersion As Long
public:
long long GetAddInVersion()
member GetAddInVersion : unit -> int64

Valore di ritorno

Int64
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.GetAllAttachData

Metodo DedDocGetAllAttachData
Restituisce la lista di tutte le anagrafiche nelle quali questo documento è collegato come allegato. Se non ce ne sono restituisce comunque una lista inizializzata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataList GetAllAttachData()
Public Function GetAllAttachData As DedDataList
public:
DedDataList^ GetAllAttachData()
member GetAllAttachData : unit -> DedDataList

Valore di ritorno

DedDataList
Eccezioni
Eccezione | Condizione
QsException | Errore verificatosi durante la lettura del record.
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.GetAllMovingFileNames

Metodo DedDocGetAllMovingFileNames
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | GetAllMovingFileNames | Restituisce una lista contenente tutti i FileName avuti da questo documento (compreso quello attuale).
Metodo pubblico | GetAllMovingFileNames(Boolean) | Restituisce una lista contenente tutti i FileName avuti da questo documento.
Torna su
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.GetAllMovingFileNames

Metodo DedDocGetAllMovingFileNames
Restituisce una lista contenente tutti i FileName avuti da questo documento (compreso quello attuale).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> GetAllMovingFileNames()
Public Function GetAllMovingFileNames As List(Of String)
public:
List<String^>^ GetAllMovingFileNames()
member GetAllMovingFileNames : unit -> List<string>

Valore di ritorno

List String
Vedi anche

Documentazione

Classe DedDoc
Overload di GetAllMovingFileNames
Namespace DedNet.Core


Metodo DedDoc.GetAllMovingFileNames(Boolean)

Metodo DedDocGetAllMovingFileNames(Boolean)
Restituisce una lista contenente tutti i FileName avuti da questo documento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> GetAllMovingFileNames(
    bool includeCurrentFileName
)
Public Function GetAllMovingFileNames (
    includeCurrentFileName As Boolean
) As List(Of String)
public:
List<String^>^ GetAllMovingFileNames(
    bool includeCurrentFileName
)
member GetAllMovingFileNames :
        includeCurrentFileName : bool -> List<string>

Parametri

includeCurrentFileName Boolean
Indica se includere nella lista anche il FileName attuale.

Valore di ritorno

List String
Vedi anche

Documentazione

Classe DedDoc
Overload di GetAllMovingFileNames
Namespace DedNet.Core


Metodo DedDoc.GetAllPrimaryData

Metodo DedDocGetAllPrimaryData
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | GetAllPrimaryData | Restituisce la lista di tutte le anagrafiche nelle quali questo documento è collegato come file primario. Se non ce ne sono restituisce comunque una lista inizializzata.
Metodo pubblico | GetAllPrimaryData(String) | Restituisce la lista di tutte le anagrafiche nelle quali questo documento è collegato come file primario nella configurazione passata
Torna su
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.GetAllPrimaryData

Metodo DedDocGetAllPrimaryData
Restituisce la lista di tutte le anagrafiche nelle quali questo documento è collegato come file primario. Se non ce ne sono restituisce comunque una lista inizializzata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataList GetAllPrimaryData()
Public Function GetAllPrimaryData As DedDataList
public:
DedDataList^ GetAllPrimaryData()
member GetAllPrimaryData : unit -> DedDataList

Valore di ritorno

DedDataList
Eccezioni
Eccezione | Condizione
QsException | Errore verificatosi durante la lettura del record.
Vedi anche

Documentazione

Classe DedDoc
Overload di GetAllPrimaryData
Namespace DedNet.Core


Metodo DedDoc.GetAllPrimaryData(String)

Metodo DedDocGetAllPrimaryData(String)
Restituisce la lista di tutte le anagrafiche nelle quali questo documento è collegato come file primario nella configurazione passata

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataList GetAllPrimaryData(
    string config
)
Public Function GetAllPrimaryData (
    config As String
) As DedDataList
public:
DedDataList^ GetAllPrimaryData(
    String^ config
)
member GetAllPrimaryData :
        config : string -> DedDataList

Parametri

config String
Configurazione di riferimento

Valore di ritorno

DedDataList
Vedi anche

Documentazione

Classe DedDoc
Overload di GetAllPrimaryData
Namespace DedNet.Core


Metodo DedDoc.GetAllPrimaryDataNotLinked

Metodo DedDocGetAllPrimaryDataNotLinked
Restituisce la lista di tutte le anagrafiche nelle quali questo documento è collegato come file primario ma non linkato. Se non ce ne sono restituisce comunque una lista inizializzata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataList GetAllPrimaryDataNotLinked()
Public Function GetAllPrimaryDataNotLinked As DedDataList
public:
DedDataList^ GetAllPrimaryDataNotLinked()
member GetAllPrimaryDataNotLinked : unit -> DedDataList

Valore di ritorno

DedDataList
Eccezioni
Eccezione | Condizione
QsException | Errore verificatosi durante la lettura del record.
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.GetAllSparePartsData

Metodo DedDocGetAllSparePartsData
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | GetAllSparePartsData | Restituisce la lista di tutte le anagrafiche nelle quali questo documento è collegato come ricambio
Metodo pubblico | GetAllSparePartsData(String) | Restituisce la lista di tutte le anagrafiche nelle quali questo documento è collegato come ricambio nella configurazione passata Se non ce ne sono restituisce comunque una lista inizializzata.
Torna su
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.GetAllSparePartsData

Metodo DedDocGetAllSparePartsData
Restituisce la lista di tutte le anagrafiche nelle quali questo documento è collegato come ricambio

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataList GetAllSparePartsData()
Public Function GetAllSparePartsData As DedDataList
public:
DedDataList^ GetAllSparePartsData()
member GetAllSparePartsData : unit -> DedDataList

Valore di ritorno

DedDataList
Vedi anche

Documentazione

Classe DedDoc
Overload di GetAllSparePartsData
Namespace DedNet.Core


Metodo DedDoc.GetAllSparePartsData(String)

Metodo DedDocGetAllSparePartsData(String)
Restituisce la lista di tutte le anagrafiche nelle quali questo documento è collegato come ricambio nella configurazione passata Se non ce ne sono restituisce comunque una lista inizializzata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataList GetAllSparePartsData(
    string config
)
Public Function GetAllSparePartsData (
    config As String
) As DedDataList
public:
DedDataList^ GetAllSparePartsData(
    String^ config
)
member GetAllSparePartsData :
        config : string -> DedDataList

Parametri

config String

Valore di ritorno

DedDataList
Eccezioni
Eccezione | Condizione
QsException | Errore verificatosi durante la lettura del record.
Vedi anche

Documentazione

Classe DedDoc
Overload di GetAllSparePartsData
Namespace DedNet.Core


Metodo DedDoc.GetCheckOutLightRowVer

Metodo DedDocGetCheckOutLightRowVer
Restituisce il guid presente nel campo del check-out-light.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Guid GetCheckOutLightRowVer()
Public Function GetCheckOutLightRowVer As Guid
public:
Guid GetCheckOutLightRowVer()
member GetCheckOutLightRowVer : unit -> Guid

Valore di ritorno

Guid
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.GetCommCount

Metodo DedDocGetCommCount
Restituisce il numero di commesse collegate a questo elemento

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int GetCommCount()
Public Function GetCommCount As Integer
public:
int GetCommCount()
member GetCommCount : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.GetComms

Metodo DedDocGetComms
Restituisce la lista di commesse collegate a questo documento

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommList GetComms()
Public Function GetComms As DedCommList
public:
DedCommList^ GetComms()
member GetComms : unit -> DedCommList

Valore di ritorno

DedCommList
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.GetData

Metodo DedDocGetData
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | GetData | Restituisce la lista di anagrafiche collegate a questo documento. Se non ce ne sono restituisce comunque una lista inizializzata.
Metodo pubblico | GetData(DedDocContextEnum) | Restituisce la lista di anagrafiche collegate a questo documento in base ad un particolare contesto. Se non ce ne sono restituisce comunque una lista inizializzata.
Metodo pubblico | GetData(String, FuncDedDocContext, Boolean) | Funzione generica che cicla le anagrafiche ed in base alle lambda passate discrimina la lista in uscita
Torna su
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.GetData

Metodo DedDocGetData
Restituisce la lista di anagrafiche collegate a questo documento. Se non ce ne sono restituisce comunque una lista inizializzata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataList GetData()
Public Function GetData As DedDataList
public:
DedDataList^ GetData()
member GetData : unit -> DedDataList

Valore di ritorno

DedDataList
Eccezioni
Eccezione | Condizione
QsException | Errore verificatosi durante la lettura del record.
ArgumentNullException | Parametro mancante.
Vedi anche

Documentazione

Classe DedDoc
Overload di GetData
Namespace DedNet.Core


Metodo DedDoc.GetData(DedDocContextEnum)

Metodo DedDocGetData(DedDocContextEnum)
Restituisce la lista di anagrafiche collegate a questo documento in base ad un particolare contesto. Se non ce ne sono restituisce comunque una lista inizializzata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataList GetData(
    DedDocContextEnum context
)
Public Function GetData (
    context As DedDocContextEnum
) As DedDataList
public:
DedDataList^ GetData(
    DedDocContextEnum context
)
member GetData :
        context : DedDocContextEnum -> DedDataList

Parametri

context DedDocContextEnum
Contesto da utilizzare per cercare le anagrafiche.

Valore di ritorno

DedDataList
Eccezioni
Eccezione | Condizione
QsException | Errore verificatosi durante la lettura del record.
ArgumentNullException | Parametro mancante.
Vedi anche

Documentazione

Classe DedDoc
Overload di GetData
Namespace DedNet.Core


Metodo DedDoc.GetData(String, Func<DedDocContext, Boolean>)

Metodo DedDocGetData(String, FuncDedDocContext, Boolean)
Funzione generica che cicla le anagrafiche ed in base alle lambda passate discrimina la lista in uscita

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataList GetData(
    string config,
    Func<DedDocContext, bool> contextChecker
)
Public Function GetData (
    config As String,
    contextChecker As Func(Of DedDocContext, Boolean)
) As DedDataList
public:
DedDataList^ GetData(
    String^ config,
    Func<DedDocContext^, bool>^ contextChecker
)
member GetData :
        config : string *
        contextChecker : Func<DedDocContext, bool> -> DedDataList

Parametri

config String
Configurazione attiva
contextChecker Func DedDocContext, Boolean
Controllo contesti

Valore di ritorno

DedDataList
Vedi anche

Documentazione

Classe DedDoc
Overload di GetData
Namespace DedNet.Core


Metodo DedDoc.GetDataCount

Metodo DedDocGetDataCount
Restituisce il numero di anagrafiche collegate a questo documento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int GetDataCount()
Public Function GetDataCount As Integer
public:
int GetDataCount()
member GetDataCount : unit -> int

Valore di ritorno

Int32
Eccezioni
Eccezione | Condizione
QsException | Errore nella lettura del Database.
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.GetDataNotLinked

Metodo DedDocGetDataNotLinked
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | GetDataNotLinked | Restituisce la lista di anagrafiche collegate a questo documento che NON SONO in un contesto di link. Se non ce ne sono restituisce comunque una lista inizializzata.
Metodo pubblico | GetDataNotLinked(String) | Restituisce la lista di anagrafiche collegate a questo documento che NON SONO in un contesto di link. Se non ce ne sono restituisce comunque una lista inizializzata.
Torna su
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.GetDataNotLinked

Metodo DedDocGetDataNotLinked
Restituisce la lista di anagrafiche collegate a questo documento che NON SONO in un contesto di link. Se non ce ne sono restituisce comunque una lista inizializzata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataList GetDataNotLinked()
Public Function GetDataNotLinked As DedDataList
public:
DedDataList^ GetDataNotLinked()
member GetDataNotLinked : unit -> DedDataList

Valore di ritorno

DedDataList
Eccezioni
Eccezione | Condizione
QsException | Errore verificatosi durante la lettura del record.
ArgumentNullException | Parametro mancante.
Vedi anche

Documentazione

Classe DedDoc
Overload di GetDataNotLinked
Namespace DedNet.Core


Metodo DedDoc.GetDataNotLinked(String)

Metodo DedDocGetDataNotLinked(String)
Restituisce la lista di anagrafiche collegate a questo documento che NON SONO in un contesto di link. Se non ce ne sono restituisce comunque una lista inizializzata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataList GetDataNotLinked(
    string config
)
Public Function GetDataNotLinked (
    config As String
) As DedDataList
public:
DedDataList^ GetDataNotLinked(
    String^ config
)
member GetDataNotLinked :
        config : string -> DedDataList

Parametri

config String

Valore di ritorno

DedDataList
Eccezioni
Eccezione | Condizione
QsException | Errore verificatosi durante la lettura del record.
ArgumentNullException | Parametro mancante.
Vedi anche

Documentazione

Classe DedDoc
Overload di GetDataNotLinked
Namespace DedNet.Core


Metodo DedDoc.GetDocVersionFromStateHistory

Metodo DedDocGetDocVersionFromStateHistory
Data l'operazione e il rowver del documento, ritrova la versione

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int GetDocVersionFromStateHistory(
    Guid rowver
)
Public Function GetDocVersionFromStateHistory (
    rowver As Guid
) As Integer
public:
int GetDocVersionFromStateHistory(
    Guid rowver
)
member GetDocVersionFromStateHistory :
        rowver : Guid -> int

Parametri

rowver Guid
Rowver dal quale ottenere la versione

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.GetHashCode

Metodo DedDocGetHashCode
Restituisce l'HashCode di questo oggetto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.GetRootInfo

Metodo DedDocGetRootInfo
Restitiusce le informazioni di root dei path attuali per questo documento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedRootInfo GetRootInfo()
Public Function GetRootInfo As DedRootInfo
public:
DedRootInfo^ GetRootInfo()
member GetRootInfo : unit -> DedRootInfo

Valore di ritorno

DedRootInfo
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.GetStrictPrimaryData

Metodo DedDocGetStrictPrimaryData
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | GetStrictPrimaryData | Restituisce la lista di tutte le anagrafiche nelle quali questo documento è collegato come strettamente primario
Metodo pubblico | GetStrictPrimaryData(String) | Restituisce la lista di tutte le anagrafiche nelle quali questo documento è collegato come strettamente primario nella configurazione passata
Torna su
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.GetStrictPrimaryData

Metodo DedDocGetStrictPrimaryData
Restituisce la lista di tutte le anagrafiche nelle quali questo documento è collegato come strettamente primario

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataList GetStrictPrimaryData()
Public Function GetStrictPrimaryData As DedDataList
public:
DedDataList^ GetStrictPrimaryData()
member GetStrictPrimaryData : unit -> DedDataList

Valore di ritorno

DedDataList
Vedi anche

Documentazione

Classe DedDoc
Overload di GetStrictPrimaryData
Namespace DedNet.Core


Metodo DedDoc.GetStrictPrimaryData(String)

Metodo DedDocGetStrictPrimaryData(String)
Restituisce la lista di tutte le anagrafiche nelle quali questo documento è collegato come strettamente primario nella configurazione passata

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataList GetStrictPrimaryData(
    string config
)
Public Function GetStrictPrimaryData (
    config As String
) As DedDataList
public:
DedDataList^ GetStrictPrimaryData(
    String^ config
)
member GetStrictPrimaryData :
        config : string -> DedDataList

Parametri

config String

Valore di ritorno

DedDataList
Vedi anche

Documentazione

Classe DedDoc
Overload di GetStrictPrimaryData
Namespace DedNet.Core


Metodo DedDoc.GetStrictPrimaryDataNotLinked

Metodo DedDocGetStrictPrimaryDataNotLinked
Restituisce la lista di tutte le anagrafiche nelle quali questo documento è collegato come strettamente primario ma non linkato

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataList GetStrictPrimaryDataNotLinked()
Public Function GetStrictPrimaryDataNotLinked As DedDataList
public:
DedDataList^ GetStrictPrimaryDataNotLinked()
member GetStrictPrimaryDataNotLinked : unit -> DedDataList

Valore di ritorno

DedDataList
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.GetValue

Metodo DedDocGetValue
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | GetValue(DedDocStandardDocFields) | Restituisce il contenuto di uno dei campi standard oppure null se non è presente.
Metodo pubblico | GetValue(String) | Metodo che restituisce i valori del documento.
Torna su
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.GetValue(DedDoc.StandardDocFields)

Metodo DedDocGetValue(DedDocStandardDocFields)
Restituisce il contenuto di uno dei campi standard oppure null se non è presente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object GetValue(
    DedDocStandardDocFields stdfield
)
Public Function GetValue (
    stdfield As DedDocStandardDocFields
) As Object
public:
Object^ GetValue(
    DedDocStandardDocFields stdfield
)
member GetValue :
        stdfield : DedDocStandardDocFields -> Object

Parametri

stdfield DedDocStandardDocFields
Campo standard del quale avere il contenuto.

Valore di ritorno

Object
Vedi anche

Documentazione

Classe DedDoc
Overload di GetValue
Namespace DedNet.Core


Metodo DedDoc.GetValue(String)

Metodo DedDocGetValue(String)
Metodo che restituisce i valori del documento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object GetValue(
    string persfield
)
Public Function GetValue (
    persfield As String
) As Object
public:
Object^ GetValue(
    String^ persfield
)
member GetValue :
        persfield : string -> Object

Parametri

persfield String
Nome dell'attributo.

Valore di ritorno

Object
Vedi anche

Documentazione

Classe DedDoc
Overload di GetValue
Namespace DedNet.Core


Metodo DedDoc.HasAtLeastOneLinkingContext

Metodo DedDocHasAtLeastOneLinkingContext
Retituisce true se il documento ha almeno un contesto di linking nei confronti di una anagrafica

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasAtLeastOneLinkingContext()
Public Function HasAtLeastOneLinkingContext As Boolean
public:
bool HasAtLeastOneLinkingContext()
member HasAtLeastOneLinkingContext : unit -> bool

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.HasMoreThanOneConfigContext

Metodo DedDocHasMoreThanOneConfigContext
Ritorna true se il documento è associato a più anagrafiche con diverse configurazioni

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasMoreThanOneConfigContext()
Public Function HasMoreThanOneConfigContext As Boolean
public:
bool HasMoreThanOneConfigContext()
member HasMoreThanOneConfigContext : unit -> bool

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.HasOperationInStateHistory

Metodo DedDocHasOperationInStateHistory
Ritorna true se nella storia delle operazioni del documento ne esiste almeno una di questo tipo

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasOperationInStateHistory(
    string operation
)
Public Function HasOperationInStateHistory (
    operation As String
) As Boolean
public:
bool HasOperationInStateHistory(
    String^ operation
)
member HasOperationInStateHistory :
        operation : string -> bool

Parametri

operation String
Identificativo dell'operazione

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.IsDetachedForCorporate

Metodo DedDocIsDetachedForCorporate
Ritorna vero se il documento è effettivamente segnalato come disallineato per la corporate passata

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsDetachedForCorporate(
    DedCorporate corporate
)
Public Function IsDetachedForCorporate (
    corporate As DedCorporate
) As Boolean
public:
bool IsDetachedForCorporate(
    DedCorporate^ corporate
)
member IsDetachedForCorporate :
        corporate : DedCorporate -> bool

Parametri

corporate DedCorporate

Valore di ritorno

Boolean
Restituisce se l'operazione è andata a buon fine.
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.IsDetachedForMyCorporate

Metodo DedDocIsDetachedForMyCorporate
Ritorna vero se il documento è efffettivamente segnalato come disallineato per la corporate corrente

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsDetachedForMyCorporate()
Public Function IsDetachedForMyCorporate As Boolean
public:
bool IsDetachedForMyCorporate()
member IsDetachedForMyCorporate : unit -> bool

Valore di ritorno

Boolean
Restituisce se l'operazione è andata a buon fine.
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.IsMovingDestination

Metodo DedDocIsMovingDestination
Indica se il documento deriva da un moving di un altro documento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsMovingDestination()
Public Function IsMovingDestination As Boolean
public:
bool IsMovingDestination()
member IsMovingDestination : unit -> bool

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.IsMyPwsDocEqualsToVaultDoc

Metodo DedDocIsMyPwsDocEqualsToVaultDoc
Verifica se la versione del documento in locale è uguale a quella nel vault.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsMyPwsDocEqualsToVaultDoc()
Public Function IsMyPwsDocEqualsToVaultDoc As Boolean
public:
bool IsMyPwsDocEqualsToVaultDoc()
member IsMyPwsDocEqualsToVaultDoc : unit -> bool

Valore di ritorno

Boolean
Restituisce true se le versioni sono uguali atrimenti false.
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.IsVaultDocUpToDate

Metodo DedDocIsVaultDocUpToDate
Verifica se la versione del file su vault coincide con la versione del database. In caso di modalità non detached torna sempre true.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsVaultDocUpToDate(
    bool usesCurDocRowVer = false
)
Public Function IsVaultDocUpToDate (
    Optional usesCurDocRowVer As Boolean = false
) As Boolean
public:
bool IsVaultDocUpToDate(
    bool usesCurDocRowVer = false
)
member IsVaultDocUpToDate :
        ?usesCurDocRowVer : bool
(* Defaults:
        let _usesCurDocRowVer = defaultArg usesCurDocRowVer false
*)
-> bool

Parametri

usesCurDocRowVer Boolean (Optional)

Valore di ritorno

Boolean
Restituisce true se le versioni sono uguali
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.MoveTo

Metodo DedDocMoveTo
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | MoveTo(String) | Imposta il nome, estensione e percorso file in base al nuovo percorso passato, anche nei campi di checkout se non risultano vuoti. Non effettua alcuna verifica sul fatto che la nuova posizione sia nei percorsi di root.
Metodo pubblico | MoveTo(String, DedDocMovReasonEnum) | Imposta il nome, estensione e percorso file in base al nuovo percorso passato, anche nei campi di checkout se non risultano vuoti. Non effettua alcuna verifica sul fatto che la nuova posizione sia nei percorsi di root. Per rendere effettive le modifiche apportate al documento chiamando questo metodo, chiamare uno degli overload del metodo Update().
Torna su
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.MoveTo(String)

Metodo DedDocMoveTo(String)
Imposta il nome, estensione e percorso file in base al nuovo percorso passato, anche nei campi di checkout se non risultano vuoti. Non effettua alcuna verifica sul fatto che la nuova posizione sia nei percorsi di root.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void MoveTo(
    string fullFileName
)
Public Sub MoveTo (
    fullFileName As String
)
public:
void MoveTo(
    String^ fullFileName
)
member MoveTo :
        fullFileName : string -> unit

Parametri

fullFileName String
Nuova posizione del documento da impostare nel Database. Il percorso può riferirsi al Vault oppure all'area locale, indifferentemente.
Vedi anche

Documentazione

Classe DedDoc
Overload di MoveTo
Namespace DedNet.Core


Metodo DedDoc.MoveTo(String, DedDoc.MovReasonEnum)

Metodo DedDocMoveTo(String, DedDocMovReasonEnum)
Imposta il nome, estensione e percorso file in base al nuovo percorso passato, anche nei campi di checkout se non risultano vuoti. Non effettua alcuna verifica sul fatto che la nuova posizione sia nei percorsi di root. Per rendere effettive le modifiche apportate al documento chiamando questo metodo, chiamare uno degli overload del metodo Update().

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void MoveTo(
    string fullFileName,
    DedDocMovReasonEnum reason
)
Public Sub MoveTo (
    fullFileName As String,
    reason As DedDocMovReasonEnum
)
public:
void MoveTo(
    String^ fullFileName,
    DedDocMovReasonEnum reason
)
member MoveTo :
        fullFileName : string *
        reason : DedDocMovReasonEnum -> unit

Parametri

fullFileName String
Nuova posizione del documento da impostare nel Database. Il percorso può riferirsi al Vault oppure all'area locale, indifferentemente.
reason DedDocMovReasonEnum
Causa dello spostamento del documento.
Vedi anche

Documentazione

Classe DedDoc
Overload di MoveTo
Namespace DedNet.Core


Metodo DedDoc.MyPwsVer

Metodo DedDocMyPwsVer
Restuituisce la versione del documento che è stato scaricato l'ultima volta nell'area locale. Restituisce Guid.Empty se non è mai stato scaricato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Guid MyPwsVer()
Public Function MyPwsVer As Guid
public:
Guid MyPwsVer()
member MyPwsVer : unit -> Guid

Valore di ritorno

Guid
La versione del documento che dovrebbe essere presente nell'area locale.
Note
Se la versione coincide con quella principale, non è detto che il documento sia presente nell'area locale.
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.ReadAllProperties

Metodo DedDocReadAllProperties
Scrive le proprietà passate nel database.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<string, Object> ReadAllProperties(
    bool nameTraslated = false
)
Public Function ReadAllProperties (
    Optional nameTraslated As Boolean = false
) As Dictionary(Of String, Object)
public:
Dictionary<String^, Object^>^ ReadAllProperties(
    bool nameTraslated = false
)
member ReadAllProperties :
        ?nameTraslated : bool
(* Defaults:
        let _nameTraslated = defaultArg nameTraslated false
*)
-> Dictionary<string, Object>

Parametri

nameTraslated Boolean (Optional)

Valore di ritorno

Dictionary String, Object
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.ReadMasterRevisionId

Metodo DedDocReadMasterRevisionId
Legge il MASTERREVISIONID del documento ( usato nelll'import PackAndGo lato slave DedRemote)

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Guid ReadMasterRevisionId()
Public Function ReadMasterRevisionId As Guid
public:
Guid ReadMasterRevisionId()
member ReadMasterRevisionId : unit -> Guid

Valore di ritorno

Guid
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.Refresh

Metodo DedDocRefresh
Aggiorna questo oggetto rileggendo le informazioni presenti nel Database e dal file fisico. Effettua l'aggiornamento anche se l'oggetto è dirty: imposta dirty a false dopo l'aggiornamento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Refresh()
Public Sub Refresh
public:
void Refresh()
member Refresh : unit -> unit
Eccezioni
Eccezione | Condizione
QsException | Solleva questa eccezione nel caso in cui il documento non sia stato trovato.
QsException | Sollevata nel caso di errore nella lettura del record o connessione al Database.
ArgumentNullException | Parametro mancante.
QsException | Errore di accesso al file.
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.RefreshData

Metodo DedDocRefreshData
Aggiorna il contenuto del documento solo per quanto riguarda le informazioni presenti nel Database. Effettua l'aggiornamento anche se l'oggetto è dirty: imposta dirty a false dopo l'aggiornamento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void RefreshData()
Public Sub RefreshData
public:
void RefreshData()
member RefreshData : unit -> unit
Eccezioni
Eccezione | Condizione
QsException | Solleva questa eccezione nel caso in cui il documento non sia stato trovato.
QsException | Sollevata nel caso di errore nella lettura del record o connessione al Database.
ArgumentNullException | Parametro mancante.
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.RefreshInfoFile

Metodo DedDocRefreshInfoFile
Aggiorna i campi del documento leggendo solo le informazioni dal file fisico. Se il file non esiste non effettua alcuna operazione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void RefreshInfoFile()
Public Sub RefreshInfoFile
public:
void RefreshInfoFile()
member RefreshInfoFile : unit -> unit
Eccezioni
Eccezione | Condizione
QsException | Errore di accesso al file.
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.RemoveCopyOfVaultFile

Metodo DedDocRemoveCopyOfVaultFile
Rimuove la copia del file presente sul vault.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void RemoveCopyOfVaultFile(
    FileTransaction ft
)
Public Sub RemoveCopyOfVaultFile (
    ft As FileTransaction
)
public:
void RemoveCopyOfVaultFile(
    FileTransaction^ ft
)
member RemoveCopyOfVaultFile :
        ft : FileTransaction -> unit

Parametri

ft FileTransaction
Transazione di file valida.
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.RemoveDocStateHistory

Metodo DedDocRemoveDocStateHistory
Rimuove il record da DED_DOC_STATE_HISTORY.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void RemoveDocStateHistory()
Public Sub RemoveDocStateHistory
public:
void RemoveDocStateHistory()
member RemoveDocStateHistory : unit -> unit
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.RemoveFromDetachedForAllCorporaets

Metodo DedDocRemoveFromDetachedForAllCorporaets
Elimina il record dai detached per tutte le corporate

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void RemoveFromDetachedForAllCorporaets()
Public Sub RemoveFromDetachedForAllCorporaets
public:
void RemoveFromDetachedForAllCorporaets()
member RemoveFromDetachedForAllCorporaets : unit -> unit

Valore di ritorno

Restituisce se l'operazione è andata a buon fine.
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.RemoveFromDetachedForCorporate

Metodo DedDocRemoveFromDetachedForCorporate
Elimina il record dai detached per la corporate passata

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void RemoveFromDetachedForCorporate(
    DedCorporate corporate
)
Public Sub RemoveFromDetachedForCorporate (
    corporate As DedCorporate
)
public:
void RemoveFromDetachedForCorporate(
    DedCorporate^ corporate
)
member RemoveFromDetachedForCorporate :
        corporate : DedCorporate -> unit

Parametri

corporate DedCorporate

Valore di ritorno

Restituisce se l'operazione è andata a buon fine.
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.RemoveFromDetachedForMyCorporate

Metodo DedDocRemoveFromDetachedForMyCorporate
Elimina il record dai detached per la corporate corrente

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void RemoveFromDetachedForMyCorporate()
Public Sub RemoveFromDetachedForMyCorporate
public:
void RemoveFromDetachedForMyCorporate()
member RemoveFromDetachedForMyCorporate : unit -> unit

Valore di ritorno

Restituisce se l'operazione è andata a buon fine.
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.RestoreBackup

Metodo DedDocRestoreBackup
Reimposta nella tabella ded_data il record presente nella tabella di backup.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool RestoreBackup()
Public Function RestoreBackup As Boolean
public:
bool RestoreBackup()
member RestoreBackup : unit -> bool

Valore di ritorno

Boolean
Restituisce se l'operazione è andata a buon fine.
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.RestoreBackupCfg

Metodo DedDocRestoreBackupCfg
Reimposta nella tabella DED_DOC_CFG il record presente nella tabella di backup.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool RestoreBackupCfg()
Public Function RestoreBackupCfg As Boolean
public:
bool RestoreBackupCfg()
member RestoreBackupCfg : unit -> bool

Valore di ritorno

Boolean
Restituisce se l'operazione è andata a buon fine.
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.RestoreCopyOfVaultFile

Metodo DedDocRestoreCopyOfVaultFile
Rispristina la situazione presente nel vault prima del checkOut.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void RestoreCopyOfVaultFile(
    FileTransaction ft
)
Public Sub RestoreCopyOfVaultFile (
    ft As FileTransaction
)
public:
void RestoreCopyOfVaultFile(
    FileTransaction^ ft
)
member RestoreCopyOfVaultFile :
        ft : FileTransaction -> unit

Parametri

ft FileTransaction
Transazione di file valida.
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.SaveCopyOfVaultFile

Metodo DedDocSaveCopyOfVaultFile
Salva una copia del file sul vault (in modo che se viene fatto un annulla checkOut si possa ripristinare la vecchia situazione).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SaveCopyOfVaultFile(
    FileTransaction ft
)
Public Sub SaveCopyOfVaultFile (
    ft As FileTransaction
)
public:
void SaveCopyOfVaultFile(
    FileTransaction^ ft
)
member SaveCopyOfVaultFile :
        ft : FileTransaction -> unit

Parametri

ft FileTransaction
Transazione di file valida.
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.SetAddInVersion

Metodo DedDocSetAddInVersion
Imposta ADDINVERSION per il documento. Utilizzato ad esempio nella migrazione massiva per il controllo dell'elaborazione dei file.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetAddInVersion(
    long addinver
)
Public Sub SetAddInVersion (
    addinver As Long
)
public:
void SetAddInVersion(
    long long addinver
)
member SetAddInVersion :
        addinver : int64 -> unit

Parametri

addinver Int64
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.SetCheckIn

Metodo DedDocSetCheckIn
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | SetCheckIn | Imposta in CheckIn il documento. Effettua l'operazione aggiornando solo il campo CheckOut nel Database ponendo come vincolo che il documento sia in CheckOut dall'utente corrente.
Metodo pubblico | SetCheckIn(Boolean) | Imposta in CheckIn il documento. Effettua l'operazione aggiornando solo il campo CheckOut nel Database ponendo come vincolo che il documento sia in CheckOut dall'utente corrente. Se il parametro è true mette in check-in anche i documenti che risultano dipendendi Generici (.prt).
Torna su
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.SetCheckIn

Metodo DedDocSetCheckIn
Imposta in CheckIn il documento. Effettua l'operazione aggiornando solo il campo CheckOut nel Database ponendo come vincolo che il documento sia in CheckOut dall'utente corrente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetCheckIn()
Public Sub SetCheckIn
public:
void SetCheckIn()
member SetCheckIn : unit -> unit
Eccezioni
Eccezione | Condizione
QsException | Viene sollevata in caso di errore nell'istruzione di aggiornamento dati.
Vedi anche

Documentazione

Classe DedDoc
Overload di SetCheckIn
Namespace DedNet.Core


Metodo DedDoc.SetCheckIn(Boolean)

Metodo DedDocSetCheckIn(Boolean)
Imposta in CheckIn il documento. Effettua l'operazione aggiornando solo il campo CheckOut nel Database ponendo come vincolo che il documento sia in CheckOut dall'utente corrente. Se il parametro è true mette in check-in anche i documenti che risultano dipendendi Generici (.prt).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetCheckIn(
    bool dependences
)
Public Sub SetCheckIn (
    dependences As Boolean
)
public:
void SetCheckIn(
    bool dependences
)
member SetCheckIn :
        dependences : bool -> unit

Parametri

dependences Boolean
Indica di mettere in check-in anche le dipendenze generiche.
Eccezioni
Eccezione | Condizione
QsException | Viene sollevata in caso di errore nell'istruzione di aggiornamento dati.
Vedi anche

Documentazione

Classe DedDoc
Overload di SetCheckIn
Namespace DedNet.Core


Metodo DedDoc.SetCheckOutByMe

Metodo DedDocSetCheckOutByMe
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | SetCheckOutByMe | Imposta in CheckOut il documento dall'utente corrente. Effettua l'operazione aggiornando solo il campo CheckOut nel Database ponendo come vincolo che sia in CheckIn.
Metodo pubblico | SetCheckOutByMe(Boolean) | Imposta in CheckOut il documento dall'utente corrente. Effettua l'operazione aggiornando solo il campo CheckOut nel Database ponendo come vincolo che sia in CheckIn. Se il parametro è true mette in check-out anche i documenti che risultano dipendendi Generici (.prt).
Torna su
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.SetCheckOutByMe

Metodo DedDocSetCheckOutByMe
Imposta in CheckOut il documento dall'utente corrente. Effettua l'operazione aggiornando solo il campo CheckOut nel Database ponendo come vincolo che sia in CheckIn.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetCheckOutByMe()
Public Sub SetCheckOutByMe
public:
void SetCheckOutByMe()
member SetCheckOutByMe : unit -> unit
Eccezioni
Eccezione | Condizione
QsException | Viene sollevata in caso di errore nell'istruzione di aggiornamento dati.
Vedi anche

Documentazione

Classe DedDoc
Overload di SetCheckOutByMe
Namespace DedNet.Core


Metodo DedDoc.SetCheckOutByMe(Boolean)

Metodo DedDocSetCheckOutByMe(Boolean)
Imposta in CheckOut il documento dall'utente corrente. Effettua l'operazione aggiornando solo il campo CheckOut nel Database ponendo come vincolo che sia in CheckIn. Se il parametro è true mette in check-out anche i documenti che risultano dipendendi Generici (.prt).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetCheckOutByMe(
    bool dependences
)
Public Sub SetCheckOutByMe (
    dependences As Boolean
)
public:
void SetCheckOutByMe(
    bool dependences
)
member SetCheckOutByMe :
        dependences : bool -> unit

Parametri

dependences Boolean
Indica di mettere in check-out anche le dipendenze generiche.
Eccezioni
Eccezione | Condizione
QsException | Viene sollevata in caso di errore nell'istruzione di aggiornamento dati.
Vedi anche

Documentazione

Classe DedDoc
Overload di SetCheckOutByMe
Namespace DedNet.Core


Metodo DedDoc.SetCheckOutLightRowVer

Metodo DedDocSetCheckOutLightRowVer
Imposta il guid nel campo del check-out-light.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetCheckOutLightRowVer(
    Guid ckRowVer
)
Public Sub SetCheckOutLightRowVer (
    ckRowVer As Guid
)
public:
void SetCheckOutLightRowVer(
    Guid ckRowVer
)
member SetCheckOutLightRowVer :
        ckRowVer : Guid -> unit

Parametri

ckRowVer Guid
Valore da impostare.
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.SetInternalName

Metodo DedDocSetInternalName
Imposta l'INTERNALNAME del documento

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetInternalName(
    string internalName
)
Public Sub SetInternalName (
    internalName As String
)
public:
void SetInternalName(
    String^ internalName
)
member SetInternalName :
        internalName : string -> unit

Parametri

internalName String
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.SetValue

Metodo DedDocSetValue
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | SetValue(DedAttr, Object) | Metodo per impostare i valori al documento. Se l'attributo passato in ingresso è marchiato con l'opzione "Solo Db" oppure "Calcolato", il settaggio NON verrà effettuato.
Metodo pubblico | SetValue(DedDocStandardDocFields, Object) | Imposta un campo standard con un nuovo valore. Se il campo non è compilato lo crea nel dizionario interno.
Metodo pubblico | SetValue(String, Object) | Metodo per impostare i valori al documento.
Torna su
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.SetValue(DedAttr, Object)

Metodo DedDocSetValue(DedAttr, Object)
Metodo per impostare i valori al documento. Se l'attributo passato in ingresso è marchiato con l'opzione "Solo Db" oppure "Calcolato", il settaggio NON verrà effettuato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetValue(
    DedAttr attr,
    Object Value
)
Public Sub SetValue (
    attr As DedAttr,
    Value As Object
)
public:
void SetValue(
    DedAttr^ attr,
    Object^ Value
)
member SetValue :
        attr : DedAttr *
        Value : Object -> unit

Parametri

attr DedAttr
Attributo da settare (utilizza l'internalname).
Value Object
Valore dell'attributo.
Vedi anche

Documentazione

Classe DedDoc
Overload di SetValue
Namespace DedNet.Core


Metodo DedDoc.SetValue(DedDoc.StandardDocFields, Object)

Metodo DedDocSetValue(DedDocStandardDocFields, Object)
Imposta un campo standard con un nuovo valore. Se il campo non è compilato lo crea nel dizionario interno.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetValue(
    DedDocStandardDocFields stdfield,
    Object Value
)
Public Sub SetValue (
    stdfield As DedDocStandardDocFields,
    Value As Object
)
public:
void SetValue(
    DedDocStandardDocFields stdfield,
    Object^ Value
)
member SetValue :
        stdfield : DedDocStandardDocFields *
        Value : Object -> unit

Parametri

stdfield DedDocStandardDocFields
Campo standard da impostare.
Value Object
Valore da impostare.
Vedi anche

Documentazione

Classe DedDoc
Overload di SetValue
Namespace DedNet.Core


Metodo DedDoc.SetValue(String, Object)

Metodo DedDocSetValue(String, Object)
Metodo per impostare i valori al documento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetValue(
    string persfield,
    Object Value
)
Public Sub SetValue (
    persfield As String,
    Value As Object
)
public:
void SetValue(
    String^ persfield,
    Object^ Value
)
member SetValue :
        persfield : string *
        Value : Object -> unit

Parametri

persfield String
Nome dell'attributo da modificare.
Value Object
Valore dell'attributo.
Vedi anche

Documentazione

Classe DedDoc
Overload di SetValue
Namespace DedNet.Core


Metodo DedDoc.Update

Metodo DedDocUpdate
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Update | Aggiorna l'oggetto nel Database solo se questo è Dirty, poi imposta Dirty a false. La versione del record viene incrementata di 1 già la prima volta che si è modificato l'oggetto e resti dirty. Aggiorna il suo RowVer con uno nuovo.
Metodo pubblico | Update(Guid) | Aggiorna l'oggetto nel Database solo se questo è Dirty, poi imposta Dirty a false. La versione del record viene incrementata di 1 già la prima volta che si è modificato l'oggetto e resti dirty. Lo aggiorna usando il RowVer passato come argomento.
Torna su
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.Update

Metodo DedDocUpdate
Aggiorna l'oggetto nel Database solo se questo è Dirty, poi imposta Dirty a false. La versione del record viene incrementata di 1 già la prima volta che si è modificato l'oggetto e resti dirty. Aggiorna il suo RowVer con uno nuovo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Update()
Public Sub Update
public:
void Update()
member Update : unit -> unit
Eccezioni
Eccezione | Condizione
QsException | Viene sollevata in caso di errore nell'istruzione di aggiornamento dati.
Vedi anche

Documentazione

Classe DedDoc
Overload di Update
Namespace DedNet.Core


Metodo DedDoc.Update(Guid)

Metodo DedDocUpdate(Guid)
Aggiorna l'oggetto nel Database solo se questo è Dirty, poi imposta Dirty a false. La versione del record viene incrementata di 1 già la prima volta che si è modificato l'oggetto e resti dirty. Lo aggiorna usando il RowVer passato come argomento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Update(
    Guid rowver
)
Public Sub Update (
    rowver As Guid
)
public:
void Update(
    Guid rowver
)
member Update :
        rowver : Guid -> unit

Parametri

rowver Guid
Versione del documento da utilizzare per l'aggiornamento del record.
Eccezioni
Eccezione | Condizione
QsException | Viene sollevata in caso di errore nell'istruzione di aggiornamento dati.
Vedi anche

Documentazione

Classe DedDoc
Overload di Update
Namespace DedNet.Core


Metodo DedDoc.UpdateSameRowVer

Metodo DedDocUpdateSameRowVer
Aggiorna il documento senza modificare il suo RowVer (utilizzato per il move del documento).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void UpdateSameRowVer()
Public Sub UpdateSameRowVer
public:
void UpdateSameRowVer()
member UpdateSameRowVer : unit -> unit
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.WasGeneratedFrom

Metodo DedDocWasGeneratedFrom
Determina se il documento di pubblicazione è stato generato dal documento passato in quella versione

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool WasGeneratedFrom(
    DedDoc srcDoc
)
Public Function WasGeneratedFrom (
    srcDoc As DedDoc
) As Boolean
public:
bool WasGeneratedFrom(
    DedDoc^ srcDoc
)
member WasGeneratedFrom :
        srcDoc : DedDoc -> bool

Parametri

srcDoc DedDoc
Documento sorgente

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.WriteMasterRevisionId

Metodo DedDocWriteMasterRevisionId
Imposta il MASTERREVISIONID del documento ( usato nelll'import PackAndGo lato slave DedRemote)

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void WriteMasterRevisionId(
    Guid docRowVer
)
Public Sub WriteMasterRevisionId (
    docRowVer As Guid
)
public:
void WriteMasterRevisionId(
    Guid docRowVer
)
member WriteMasterRevisionId :
        docRowVer : Guid -> unit

Parametri

docRowVer Guid
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Metodo DedDoc.WritePropertiesInDb

Metodo DedDocWritePropertiesInDb
Scrive le proprietà passate nel database.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void WritePropertiesInDb(
    Dictionary<string, Object> docProps
)
Public Sub WritePropertiesInDb (
    docProps As Dictionary(Of String, Object)
)
public:
void WritePropertiesInDb(
    Dictionary<String^, Object^>^ docProps
)
member WritePropertiesInDb :
        docProps : Dictionary<string, Object> -> unit

Parametri

docProps Dictionary String, Object
Dizionario nome valore
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


DedDoc Operators

Il tipo DedDoc espone i seguenti membri.

Operatori
Nome | Descrizione
Equality(DedDoc, DedDoc) | Ridefinizione dell'operatore ==.
Inequality(DedDoc, DedDoc) | Ridefinizione dell'operatore !=.
Torna su
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


DedDoc.Equality Operatore

DedDocEquality Operatore
Ridefinizione dell'operatore ==.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool operator ==(
    DedDoc a,
    DedDoc b
)
Public Shared Operator = (
    a As DedDoc,
    b As DedDoc
) As Boolean
public:
static bool operator ==(
    DedDoc^ a,
    DedDoc^ b
)
static let inline (=)
        a : DedDoc *
        b : DedDoc  : bool

Parametri

a DedDoc
b DedDoc

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


DedDoc.Inequality Operatore

DedDocInequality Operatore
Ridefinizione dell'operatore !=.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool operator !=(
    DedDoc a,
    DedDoc b
)
Public Shared Operator <> (
    a As DedDoc,
    b As DedDoc
) As Boolean
public:
static bool operator !=(
    DedDoc^ a,
    DedDoc^ b
)
static let inline (<>)
        a : DedDoc *
        b : DedDoc  : bool

Parametri

a DedDoc
b DedDoc

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Campi di DedDoc

Il tipo DedDoc espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | _docID |
Torna su
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Campo DedDoc._docID

Campo DedDoc_docID

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public readonly Guid _docID
Public ReadOnly _docID As Guid
public:
initonly Guid _docID
val _docID: Guid

Valore del campo

Guid
Vedi anche

Documentazione

Classe DedDoc
Namespace DedNet.Core


Enumerazione DedDoc.MovReasonEnum

Enumerazione DedDocMovReasonEnum
Enumerazione descrivente le possibili cause dello spostamento di un documento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum MovReasonEnum
Public Enumeration MovReasonEnum
public enum class MovReasonEnum
type MovReasonEnum
Membri
Nome | Valore | Descrizione
Unknown | 0 | Motivo sconosciuto.
ParentMoved | 1 | Spostamento causato dallo spostamento di un documento padre.
FirstDbSave | 2 | Primo salvataggio di un documento già presente nel Database ma non associato ad una anagrafica.
UserCommand | 3 | Comando esplicito dell'utente.
BackupRev | 4 | Comando di backup su salva nuova revisione.
RipristinoRev | 5 | Ripristino di una revisione NGR da superata in lavorazione.
Archivia | 6 | Archiviazione documeento
RelocateConfigBackupRev | 7 | Ripuntamento del backup della revisione del master model state
Vedi anche

Documentazione

Namespace DedNet.Core


Enumerazione DedDoc.StandardDocFields

Enumerazione DedDocStandardDocFields
Elenco dei campi standard.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum StandardDocFields
Public Enumeration StandardDocFields
public enum class StandardDocFields
type StandardDocFields
Membri
Nome | Valore | Descrizione
DOCID | 0 | ID del documento
NOME | 1 | Nome del documento
PERCORSO | 2 | Percorso di vault del documento
ESTENSIONE | 3 | Estenzione del documento
CHECKOUTNOME | 4 | Nome del documento il checkout
CHECKOUTPERCORSO | 5 | Percorso di Pws del documento
CHECKOUTESTENSIONE | 6 | Estenzione del documento
CHECKOUTHOST | 7 | Utente che ha in checkout il documento
CHECKOUTUSER | 8 | Utente che ha in checkout il documento
CHECKOUTDATA | 9 | Data in cui il documento è stato messo in checkout
DATACREAZIONE | 10 | Data di creazione del documento
UTENTECREAZIONE | 11 | Utente che ha creato il documento
VERSIONE | 12 | Versione del documento
OLDFILE | 13 | File originale
ROWVER | 14 | Versione del record
PAROLECHIAVE | 15 | Eventuali parole chiave di ricerca ( non usato )
SCALA | 16 | Scala del documento
FILEMARKED | 17 | Indica se il file è stato marchiato in modalità detached_filesystems
INTERNALNAME | 18 | Nome interno del documento per verifica condivisione origine
Vedi anche

Documentazione

Namespace DedNet.Core


Classe DedDocCfgManager
Classe statica usata per gestire l'aggioranmento delle tabelle durante le varie operazioni.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedDocCfgManager

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static class DedDocCfgManager
Public NotInheritable Class DedDocCfgManager
public ref class DedDocCfgManager abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DedDocCfgManager = class end

Il tipo DedDocCfgManager espone i seguenti membri.

Metodi
Nome | Descrizione
AddCfgOperation | Aggiunge l'operazione passata alla tabella DED_DOC_CFG
CfgModifiedByOther | Controlla se altro utente ha modificato le configurazioni (caso no PWS)
ClearCfgOperation | Pulisce la tabella DED_DOC_CFG del documento
ConfirmCfgOperation | Conferma tutte le modifche fatte alle configurazioni, nel caso ci siano delle incongruenze genera eccezione.
GetAllCfgNameFromKey | Restituisce tutti i nomi che ha avuto la configurazione dalla chiave passata
LoadCfgOperation | Legge la struttura delle operazioni che sono state effettuate sulle configurazioni.
RevertCfgOperation | Effettua il revert delle modifiche salvate in DED_DOC_CFG
SetCfgOperationPublished | Imposta tutte le operazioni come pubblicate
UpdateCfgNameTables | Aggiorna le tabelle DED_DOC_DEDP e DED_DATA_DOC con i nomi corretti
UpdateCfgOperation | Aggiorna la tabella DED_DOC_CFG in base alle differenze tra i dizionari passati.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Metodi di DedDocCfgManager

Il tipo DedDocCfgManager espone i seguenti membri.

Metodi
Nome | Descrizione
AddCfgOperation | Aggiunge l'operazione passata alla tabella DED_DOC_CFG
CfgModifiedByOther | Controlla se altro utente ha modificato le configurazioni (caso no PWS)
ClearCfgOperation | Pulisce la tabella DED_DOC_CFG del documento
ConfirmCfgOperation | Conferma tutte le modifche fatte alle configurazioni, nel caso ci siano delle incongruenze genera eccezione.
GetAllCfgNameFromKey | Restituisce tutti i nomi che ha avuto la configurazione dalla chiave passata
LoadCfgOperation | Legge la struttura delle operazioni che sono state effettuate sulle configurazioni.
RevertCfgOperation | Effettua il revert delle modifiche salvate in DED_DOC_CFG
SetCfgOperationPublished | Imposta tutte le operazioni come pubblicate
UpdateCfgNameTables | Aggiorna le tabelle DED_DOC_DEDP e DED_DATA_DOC con i nomi corretti
UpdateCfgOperation | Aggiorna la tabella DED_DOC_CFG in base alle differenze tra i dizionari passati.
Torna su
Vedi anche

Documentazione

Classe DedDocCfgManager
Namespace DedNet.Core


Metodo DedDocCfgManager.AddCfgOperation

Metodo DedDocCfgManagerAddCfgOperation
Aggiunge l'operazione passata alla tabella DED_DOC_CFG

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool AddCfgOperation(
    DedDoc doc,
    string cfgkey,
    string oldname,
    string newname,
    CfgOperationCfgOpEnum action
)
Public Shared Function AddCfgOperation (
    doc As DedDoc,
    cfgkey As String,
    oldname As String,
    newname As String,
    action As CfgOperationCfgOpEnum
) As Boolean
public:
static bool AddCfgOperation(
    DedDoc^ doc,
    String^ cfgkey,
    String^ oldname,
    String^ newname,
    CfgOperationCfgOpEnum action
)
static member AddCfgOperation :
        doc : DedDoc *
        cfgkey : string *
        oldname : string *
        newname : string *
        action : CfgOperationCfgOpEnum -> bool

Parametri

doc DedDoc
Documento di interesse
cfgkey String
Chiave della configurazione
oldname String
Vecchio nome
newname String
Nuovo nome
action CfgOperationCfgOpEnum
Tipo di azione

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedDocCfgManager
Namespace DedNet.Core


Metodo DedDocCfgManager.CfgModifiedByOther

Metodo DedDocCfgManagerCfgModifiedByOther
Controlla se altro utente ha modificato le configurazioni (caso no PWS)

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool CfgModifiedByOther(
    DedDoc doc
)
Public Shared Function CfgModifiedByOther (
    doc As DedDoc
) As Boolean
public:
static bool CfgModifiedByOther(
    DedDoc^ doc
)
static member CfgModifiedByOther :
        doc : DedDoc -> bool

Parametri

doc DedDoc
Documento di interesse

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedDocCfgManager
Namespace DedNet.Core


Metodo DedDocCfgManager.ClearCfgOperation

Metodo DedDocCfgManagerClearCfgOperation
Pulisce la tabella DED_DOC_CFG del documento

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool ClearCfgOperation(
    DedDoc doc
)
Public Shared Function ClearCfgOperation (
    doc As DedDoc
) As Boolean
public:
static bool ClearCfgOperation(
    DedDoc^ doc
)
static member ClearCfgOperation :
        doc : DedDoc -> bool

Parametri

doc DedDoc
Documento di interesse

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedDocCfgManager
Namespace DedNet.Core


Metodo DedDocCfgManager.ConfirmCfgOperation

Metodo DedDocCfgManagerConfirmCfgOperation
Conferma tutte le modifche fatte alle configurazioni, nel caso ci siano delle incongruenze genera eccezione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void ConfirmCfgOperation(
    DedDoc doc,
    Dictionary<string, string> actualkeynamestructure,
    bool clearAfterConfirm
)
Public Shared Sub ConfirmCfgOperation (
    doc As DedDoc,
    actualkeynamestructure As Dictionary(Of String, String),
    clearAfterConfirm As Boolean
)
public:
static void ConfirmCfgOperation(
    DedDoc^ doc,
    Dictionary<String^, String^>^ actualkeynamestructure,
    bool clearAfterConfirm
)
static member ConfirmCfgOperation :
        doc : DedDoc *
        actualkeynamestructure : Dictionary<string, string> *
        clearAfterConfirm : bool -> unit

Parametri

doc DedDoc
Documento di interesse
actualkeynamestructure Dictionary String, String
Attuale dizionario con chiavi e nomi delle configurazioni
clearAfterConfirm Boolean
Indica se pulire la tabella dopo la conferma (True-Checkin;False-Pubblica)
Vedi anche

Documentazione

Classe DedDocCfgManager
Namespace DedNet.Core


Metodo DedDocCfgManager.GetAllCfgNameFromKey

Metodo DedDocCfgManagerGetAllCfgNameFromKey
Restituisce tutti i nomi che ha avuto la configurazione dalla chiave passata

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static List<string> GetAllCfgNameFromKey(
    DedDoc doc,
    string key
)
Public Shared Function GetAllCfgNameFromKey (
    doc As DedDoc,
    key As String
) As List(Of String)
public:
static List<String^>^ GetAllCfgNameFromKey(
    DedDoc^ doc,
    String^ key
)
static member GetAllCfgNameFromKey :
        doc : DedDoc *
        key : string -> List<string>

Parametri

doc DedDoc
Documento di interesse
key String
Chiave della configurazione

Valore di ritorno

List String
Vedi anche

Documentazione

Classe DedDocCfgManager
Namespace DedNet.Core


Metodo DedDocCfgManager.LoadCfgOperation

Metodo DedDocCfgManagerLoadCfgOperation
Legge la struttura delle operazioni che sono state effettuate sulle configurazioni.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static CfgOperations LoadCfgOperation(
    DedDoc doc,
    bool excludePublished = false
)
Public Shared Function LoadCfgOperation (
    doc As DedDoc,
    Optional excludePublished As Boolean = false
) As CfgOperations
public:
static CfgOperations^ LoadCfgOperation(
    DedDoc^ doc,
    bool excludePublished = false
)
static member LoadCfgOperation :
        doc : DedDoc *
        ?excludePublished : bool
(* Defaults:
        let _excludePublished = defaultArg excludePublished false
*)
-> CfgOperations

Parametri

doc DedDoc
Documento di interesse
excludePublished Boolean (Optional)
Indica di non considerare le operazioni già pubblicate

Valore di ritorno

CfgOperations
Vedi anche

Documentazione

Classe DedDocCfgManager
Namespace DedNet.Core


Metodo DedDocCfgManager.RevertCfgOperation

Metodo DedDocCfgManagerRevertCfgOperation
Effettua il revert delle modifiche salvate in DED_DOC_CFG

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void RevertCfgOperation(
    DedDoc doc,
    bool excludePublished
)
Public Shared Sub RevertCfgOperation (
    doc As DedDoc,
    excludePublished As Boolean
)
public:
static void RevertCfgOperation(
    DedDoc^ doc,
    bool excludePublished
)
static member RevertCfgOperation :
        doc : DedDoc *
        excludePublished : bool -> unit

Parametri

doc DedDoc
Docuemnto di interesse
excludePublished Boolean
Indica di non considerare le operazioni già pubblicate
Vedi anche

Documentazione

Classe DedDocCfgManager
Namespace DedNet.Core


Metodo DedDocCfgManager.SetCfgOperationPublished

Metodo DedDocCfgManagerSetCfgOperationPublished
Imposta tutte le operazioni come pubblicate

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool SetCfgOperationPublished(
    DedDoc doc
)
Public Shared Function SetCfgOperationPublished (
    doc As DedDoc
) As Boolean
public:
static bool SetCfgOperationPublished(
    DedDoc^ doc
)
static member SetCfgOperationPublished :
        doc : DedDoc -> bool

Parametri

doc DedDoc
Documento di interesse

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedDocCfgManager
Namespace DedNet.Core


Metodo DedDocCfgManager.UpdateCfgNameTables

Metodo DedDocCfgManagerUpdateCfgNameTables
Aggiorna le tabelle DED_DOC_DEDP e DED_DATA_DOC con i nomi corretti

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool UpdateCfgNameTables(
    DedDoc doc,
    List<string> oldnames,
    string newname
)
Public Shared Function UpdateCfgNameTables (
    doc As DedDoc,
    oldnames As List(Of String),
    newname As String
) As Boolean
public:
static bool UpdateCfgNameTables(
    DedDoc^ doc,
    List<String^>^ oldnames,
    String^ newname
)
static member UpdateCfgNameTables :
        doc : DedDoc *
        oldnames : List<string> *
        newname : string -> bool

Parametri

doc DedDoc
Documento di interesse
oldnames List String
Tutti i nomi da modificare
newname String
Nuovo nome da usare

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedDocCfgManager
Namespace DedNet.Core


Metodo DedDocCfgManager.UpdateCfgOperation

Metodo DedDocCfgManagerUpdateCfgOperation
Aggiorna la tabella DED_DOC_CFG in base alle differenze tra i dizionari passati.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void UpdateCfgOperation(
    DedDoc doc,
    Dictionary<string, string> beforeStruct,
    Dictionary<string, string> afterStruct
)
Public Shared Sub UpdateCfgOperation (
    doc As DedDoc,
    beforeStruct As Dictionary(Of String, String),
    afterStruct As Dictionary(Of String, String)
)
public:
static void UpdateCfgOperation(
    DedDoc^ doc,
    Dictionary<String^, String^>^ beforeStruct,
    Dictionary<String^, String^>^ afterStruct
)
static member UpdateCfgOperation :
        doc : DedDoc *
        beforeStruct : Dictionary<string, string> *
        afterStruct : Dictionary<string, string> -> unit

Parametri

doc DedDoc
Docuemnto di interesse
beforeStruct Dictionary String, String
Dizionario chiave-nome configurazionie prima della modifica
afterStruct Dictionary String, String
Dizionario chiave-nome configurazionie dopo la modifica
Vedi anche

Documentazione

Classe DedDocCfgManager
Namespace DedNet.Core


Classe DedDocContext
Descrive il contesto del documento.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedDocContext

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedDocContext
Public Class DedDocContext
public ref class DedDocContext
type DedDocContext = class end

Il tipo DedDocContext espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | IsLinking | Restituisce se si tratta di un documento linkato.
Proprietà pubblica | IsMainConfig | Restituisce se è configurazione Master/Default
Proprietà pubblica | IsSparePartContext | Restituisce se il contesto è di tipo ricambio
Torna su
Campi
 | Nome | Descrizione
Campo pubblico | CfgDescr | Identificatifo della configurazione/model state associtato (* corrisponde a nessuna configurazione specifica)
Campo pubblico | Config | Identificatifo della configurazione/model state associtato (* corrisponde a nessuna configurazione specifica)
Campo pubblico | Context | Identificativo di contesto.
Campo pubblico | DataAssociazione | Data in cui è stato associato il documento all'anagrafica.
Campo pubblico | DedID | DEDID dell'anagrafica.
Campo pubblico | DedIDLink | DEDID dell'anagrafica di collegamento (se esiste).
Campo pubblico | DedRev | DEDREV dell'anagrafica.
Campo pubblico | DedRevLink | DEDREV dell'anagrafica di collegamento (se esiste).
Campo pubblico | DocId | DocId del documento collegato.
Campo pubblico | UtenteAssociazione | Utente che ha associato il documento all'anagrafica.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di DedDocContext

Il tipo DedDocContext espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | IsLinking | Restituisce se si tratta di un documento linkato.
Proprietà pubblica | IsMainConfig | Restituisce se è configurazione Master/Default
Proprietà pubblica | IsSparePartContext | Restituisce se il contesto è di tipo ricambio
Torna su
Vedi anche

Documentazione

Classe DedDocContext
Namespace DedNet.Core


Proprietà DedDocContext.IsLinking

Proprietà DedDocContextIsLinking
Restituisce se si tratta di un documento linkato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsLinking { get; }
Public ReadOnly Property IsLinking As Boolean
    Get
public:
property bool IsLinking {
    bool get ();
}
member IsLinking : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDocContext
Namespace DedNet.Core


Proprietà DedDocContext.IsMainConfig

Proprietà DedDocContextIsMainConfig
Restituisce se è configurazione Master/Default

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsMainConfig { get; }
Public ReadOnly Property IsMainConfig As Boolean
    Get
public:
property bool IsMainConfig {
    bool get ();
}
member IsMainConfig : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDocContext
Namespace DedNet.Core


Proprietà DedDocContext.IsSparePartContext

Proprietà DedDocContextIsSparePartContext
Restituisce se il contesto è di tipo ricambio

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsSparePartContext { get; }
Public ReadOnly Property IsSparePartContext As Boolean
    Get
public:
property bool IsSparePartContext {
    bool get ();
}
member IsSparePartContext : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDocContext
Namespace DedNet.Core


Campi di DedDocContext

Il tipo DedDocContext espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | CfgDescr | Identificatifo della configurazione/model state associtato (* corrisponde a nessuna configurazione specifica)
Campo pubblico | Config | Identificatifo della configurazione/model state associtato (* corrisponde a nessuna configurazione specifica)
Campo pubblico | Context | Identificativo di contesto.
Campo pubblico | DataAssociazione | Data in cui è stato associato il documento all'anagrafica.
Campo pubblico | DedID | DEDID dell'anagrafica.
Campo pubblico | DedIDLink | DEDID dell'anagrafica di collegamento (se esiste).
Campo pubblico | DedRev | DEDREV dell'anagrafica.
Campo pubblico | DedRevLink | DEDREV dell'anagrafica di collegamento (se esiste).
Campo pubblico | DocId | DocId del documento collegato.
Campo pubblico | UtenteAssociazione | Utente che ha associato il documento all'anagrafica.
Torna su
Vedi anche

Documentazione

Classe DedDocContext
Namespace DedNet.Core


Campo DedDocContext.CfgDescr

Campo DedDocContextCfgDescr
Identificatifo della configurazione/model state associtato (* corrisponde a nessuna configurazione specifica)

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public readonly ConfigDescriptor CfgDescr
Public ReadOnly CfgDescr As ConfigDescriptor
public:
initonly ConfigDescriptor^ CfgDescr
val CfgDescr: ConfigDescriptor

Valore del campo

ConfigDescriptor
Vedi anche

Documentazione

Classe DedDocContext
Namespace DedNet.Core


Campo DedDocContext.Config

Campo DedDocContextConfig
Identificatifo della configurazione/model state associtato (* corrisponde a nessuna configurazione specifica)

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public readonly string Config
Public ReadOnly Config As String
public:
initonly String^ Config
val Config: string

Valore del campo

String
Vedi anche

Documentazione

Classe DedDocContext
Namespace DedNet.Core


Campo DedDocContext.Context

Campo DedDocContextContext
Identificativo di contesto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public readonly DedDocContextEnum Context
Public ReadOnly Context As DedDocContextEnum
public:
initonly DedDocContextEnum Context
val Context: DedDocContextEnum

Valore del campo

DedDocContextEnum
Vedi anche

Documentazione

Classe DedDocContext
Namespace DedNet.Core


Campo DedDocContext.DataAssociazione

Campo DedDocContextDataAssociazione
Data in cui è stato associato il documento all'anagrafica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public readonly DateTime? DataAssociazione
Public ReadOnly DataAssociazione As DateTime?
public:
initonly Nullable<DateTime> DataAssociazione
val DataAssociazione: Nullable<DateTime>

Valore del campo

Nullable DateTime
Vedi anche

Documentazione

Classe DedDocContext
Namespace DedNet.Core


Campo DedDocContext.DedID

Campo DedDocContextDedID
DEDID dell'anagrafica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public readonly string DedID
Public ReadOnly DedID As String
public:
initonly String^ DedID
val DedID: string

Valore del campo

String
Vedi anche

Documentazione

Classe DedDocContext
Namespace DedNet.Core


Campo DedDocContext.DedIDLink

Campo DedDocContextDedIDLink
DEDID dell'anagrafica di collegamento (se esiste).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public readonly string DedIDLink
Public ReadOnly DedIDLink As String
public:
initonly String^ DedIDLink
val DedIDLink: string

Valore del campo

String
Vedi anche

Documentazione

Classe DedDocContext
Namespace DedNet.Core


Campo DedDocContext.DedRev

Campo DedDocContextDedRev
DEDREV dell'anagrafica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public readonly string DedRev
Public ReadOnly DedRev As String
public:
initonly String^ DedRev
val DedRev: string

Valore del campo

String
Vedi anche

Documentazione

Classe DedDocContext
Namespace DedNet.Core


Campo DedDocContext.DedRevLink

Campo DedDocContextDedRevLink
DEDREV dell'anagrafica di collegamento (se esiste).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public readonly string DedRevLink
Public ReadOnly DedRevLink As String
public:
initonly String^ DedRevLink
val DedRevLink: string

Valore del campo

String
Vedi anche

Documentazione

Classe DedDocContext
Namespace DedNet.Core


Campo DedDocContext.DocId

Campo DedDocContextDocId
DocId del documento collegato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public readonly Guid DocId
Public ReadOnly DocId As Guid
public:
initonly Guid DocId
val DocId: Guid

Valore del campo

Guid
Vedi anche

Documentazione

Classe DedDocContext
Namespace DedNet.Core


Campo DedDocContext.UtenteAssociazione

Campo DedDocContextUtenteAssociazione
Utente che ha associato il documento all'anagrafica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public readonly string UtenteAssociazione
Public ReadOnly UtenteAssociazione As String
public:
initonly String^ UtenteAssociazione
val UtenteAssociazione: string

Valore del campo

String
Vedi anche

Documentazione

Classe DedDocContext
Namespace DedNet.Core


Enumerazione DedDocContextEnum
Contesto di legame tra documento ed anagrafica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum DedDocContextEnum
Public Enumeration DedDocContextEnum
public enum class DedDocContextEnum
type DedDocContextEnum
Membri
Nome | Valore | Descrizione
None | 0 | Non assegnato o non inizializzato.
Modello | 1 | Documento primario.
Rappresentazione | 10 | Rappresentazione alternativa di un documento primario.
Allegato | 50 | Documento secondario.
Pubblicazione | 100 | Documento di presentazione.
TavolaRicambio | 200 | Documento di presentazione da inserire nel manuale ricambi.
PubblicazioneRicambio | 210 | Documento di presentazione da inserire nel manuale ricambi.
Vedi anche

Documentazione

Namespace DedNet.Core


Classe DedDocContextList
Lista di oggetti DedDocContext.
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList DedDocContext
DedNet.CoreDedDocContextList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedDocContextList : List<DedDocContext>
Public Class DedDocContextList
    Inherits List(Of DedDocContext)
public ref class DedDocContextList : public List<DedDocContext^>
type DedDocContextList =
    class
        inherit List<DedDocContext>
    end

Il tipo DedDocContextList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedDocContextList |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedDocContextList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocContextList()
Public Sub New
public:
DedDocContextList()
new : unit -> DedDocContextList
Vedi anche

Documentazione

Classe DedDocContextList
Namespace DedNet.Core


Classe DedDocContextManager
Gestisce i legami tra le anagrafiche ed i documenti ed il loro contesto. Il contesto viene scritto solo quando viene creato e poi non viene più modificato, quindi esistono metodi solo per leggere, creare o eliminare ma non per aggiornare il contesto.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedDocContextManager

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedDocContextManager
Public Class DedDocContextManager
public ref class DedDocContextManager
type DedDocContextManager = class end

Il tipo DedDocContextManager espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Find | Restituisce il Contesto di legame tra anagrafica e documento, date le sue caratteristiche univoche. Se lo trova lo restituisce altrimenti restituisce null.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Metodi di DedDocContextManager

Il tipo DedDocContextManager espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Find | Restituisce il Contesto di legame tra anagrafica e documento, date le sue caratteristiche univoche. Se lo trova lo restituisce altrimenti restituisce null.
Torna su
Vedi anche

Documentazione

Classe DedDocContextManager
Namespace DedNet.Core


Metodo DedDocContextManager.Find

Metodo DedDocContextManagerFind
Restituisce il Contesto di legame tra anagrafica e documento, date le sue caratteristiche univoche. Se lo trova lo restituisce altrimenti restituisce null.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocContext Find(
    string dedid,
    string dedrev,
    Guid docid
)
Public Function Find (
    dedid As String,
    dedrev As String,
    docid As Guid
) As DedDocContext
public:
DedDocContext^ Find(
    String^ dedid,
    String^ dedrev,
    Guid docid
)
member Find :
        dedid : string *
        dedrev : string *
        docid : Guid -> DedDocContext

Parametri

dedid String
DEDID dell'anagrafica.
dedrev String
DEDREV dell'anagrafica.
docid Guid
DocID del documento.

Valore di ritorno

DedDocContext
Eccezioni
Eccezione | Condizione
QsException | Errore nella lettura del Database.
ArgumentNullException | Parametro mancante.
Vedi anche

Documentazione

Classe DedDocContextManager
Namespace DedNet.Core


Enumerazione DedDocContextTypeEnum
Possibili tipologie di contesto documentale

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum DedDocContextTypeEnum
Public Enumeration DedDocContextTypeEnum
public enum class DedDocContextTypeEnum
type DedDocContextTypeEnum
Membri
Nome | Valore | Descrizione
None | 0 |
Primario | 1 |
Allegato | 2 |
Ricambio | 3 |
Vedi anche

Documentazione

Namespace DedNet.Core


Classe DedDocList
Lista di oggetti di tipo DedDoc.
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList DedDoc
DedNet.CoreDedDocList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedDocList : List<DedDoc>
Public Class DedDocList
    Inherits List(Of DedDoc)
public ref class DedDocList : public List<DedDoc^>
type DedDocList =
    class
        inherit List<DedDoc>
    end

Il tipo DedDocList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedDocList |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | IsCheckedIn | Restituisce true se tutti i documenti sono in CheckIn.
Proprietà pubblica | IsCheckedOut | Restituisce true se tutti i documenti sono in CheckOut ( indipendentemente dall'utente ).
Proprietà pubblica | IsCheckedOutByMe | Restituisce true se tutti i docuemnti sono in CheckOut da me.
Proprietà pubblica | IsCheckedOutByOther | Restituisce se almeno uno dei documenti sia in CheckOut da un utente differente dall'utente corrente.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearParentDocuments | Pulisce la struttura dei padri forzando la lettura al successivo accesso alla proprietà
Metodo pubblico | ContainsExt(String) | Restituisce se nella lista sia o meno presente un documento con l'estensione specificata.
Metodo pubblico | ContainsExt(String, DedDocContextEnum) | Restituisce se nella lista sia o meno presente un documento con l'estensione specificata ed avente il contesto richiesto.
Metodo pubblico | ContainsFile | Restituisce se nella lista sia o meno presente un documento con il nome e estensione passata.
Metodo pubblico | ContainsFileName | Restituisce true se contiene l'elemento richiesto altrimenti false.
Metodo pubblico | GetAllSpecificExtDocuments | Restituisce una lista di documenti che hanno una specifica estensione.
Metodo pubblico | GetCommonPath | Restituisce il percorso comune a tutti i documenti presenti nella lista.
Metodo pubblico | GetExt | Restituisce se nella lista sia o meno presente un documento con l'estensione specificata ed avente il contesto richiesto.
Metodo pubblico | GetFiles | Restituisce un array contenente tutti i file presenti nell'oggetto.
Metodo pubblico | GetFirstDocFromExtList(ListString) | Restituisce il primo documento modello avente estensione uguale alla prima trovata nella lista.
Metodo pubblico | GetFirstDocFromExtList(ListString, DedDocContextEnum) | Restituisce il primo documento avente estensione uguale alla prima trovata nella lista, che corrisponda al tipo di contesto specificato (vengono ignorati i documenti che non corrispondono a tale contesto).
Metodo pubblico | GetQsaOrCommonPath | Restiutisce il percorso del QSA se comune a tutti altrimenti il percorso comune a tutti i file.
Metodo pubblico | Refresh | Aggiorna i documenti rileggendo le informazioni presenti nel Database.
Metodo pubblico | SortByContext | Ordina gli elementi in base al contesto : MODELLO - RAPPRENSENTAZIONE - PUBBLICAZIONE - TAVOLA RICAMBIO - PUBBLICAZIONE RICAMBIO - ALLEGATO - NONE
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedDocList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocList()
Public Sub New
public:
DedDocList()
new : unit -> DedDocList
Vedi anche

Documentazione

Classe DedDocList
Namespace DedNet.Core


Proprietà di DedDocList

Il tipo DedDocList espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | IsCheckedIn | Restituisce true se tutti i documenti sono in CheckIn.
Proprietà pubblica | IsCheckedOut | Restituisce true se tutti i documenti sono in CheckOut ( indipendentemente dall'utente ).
Proprietà pubblica | IsCheckedOutByMe | Restituisce true se tutti i docuemnti sono in CheckOut da me.
Proprietà pubblica | IsCheckedOutByOther | Restituisce se almeno uno dei documenti sia in CheckOut da un utente differente dall'utente corrente.
Torna su
Vedi anche

Documentazione

Classe DedDocList
Namespace DedNet.Core


Proprietà DedDocList.IsCheckedIn

Proprietà DedDocListIsCheckedIn
Restituisce true se tutti i documenti sono in CheckIn.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsCheckedIn { get; }
Public ReadOnly Property IsCheckedIn As Boolean
    Get
public:
property bool IsCheckedIn {
    bool get ();
}
member IsCheckedIn : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDocList
Namespace DedNet.Core


Proprietà DedDocList.IsCheckedOut

Proprietà DedDocListIsCheckedOut
Restituisce true se tutti i documenti sono in CheckOut ( indipendentemente dall'utente ).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsCheckedOut { get; }
Public ReadOnly Property IsCheckedOut As Boolean
    Get
public:
property bool IsCheckedOut {
    bool get ();
}
member IsCheckedOut : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDocList
Namespace DedNet.Core


Proprietà DedDocList.IsCheckedOutByMe

Proprietà DedDocListIsCheckedOutByMe
Restituisce true se tutti i docuemnti sono in CheckOut da me.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsCheckedOutByMe { get; }
Public ReadOnly Property IsCheckedOutByMe As Boolean
    Get
public:
property bool IsCheckedOutByMe {
    bool get ();
}
member IsCheckedOutByMe : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDocList
Namespace DedNet.Core


Proprietà DedDocList.IsCheckedOutByOther

Proprietà DedDocListIsCheckedOutByOther
Restituisce se almeno uno dei documenti sia in CheckOut da un utente differente dall'utente corrente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsCheckedOutByOther { get; }
Public ReadOnly Property IsCheckedOutByOther As Boolean
    Get
public:
property bool IsCheckedOutByOther {
    bool get ();
}
member IsCheckedOutByOther : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedDocList
Namespace DedNet.Core


Metodi di DedDocList

Il tipo DedDocList espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearParentDocuments | Pulisce la struttura dei padri forzando la lettura al successivo accesso alla proprietà
Metodo pubblico | ContainsExt(String) | Restituisce se nella lista sia o meno presente un documento con l'estensione specificata.
Metodo pubblico | ContainsExt(String, DedDocContextEnum) | Restituisce se nella lista sia o meno presente un documento con l'estensione specificata ed avente il contesto richiesto.
Metodo pubblico | ContainsFile | Restituisce se nella lista sia o meno presente un documento con il nome e estensione passata.
Metodo pubblico | ContainsFileName | Restituisce true se contiene l'elemento richiesto altrimenti false.
Metodo pubblico | GetAllSpecificExtDocuments | Restituisce una lista di documenti che hanno una specifica estensione.
Metodo pubblico | GetCommonPath | Restituisce il percorso comune a tutti i documenti presenti nella lista.
Metodo pubblico | GetExt | Restituisce se nella lista sia o meno presente un documento con l'estensione specificata ed avente il contesto richiesto.
Metodo pubblico | GetFiles | Restituisce un array contenente tutti i file presenti nell'oggetto.
Metodo pubblico | GetFirstDocFromExtList(ListString) | Restituisce il primo documento modello avente estensione uguale alla prima trovata nella lista.
Metodo pubblico | GetFirstDocFromExtList(ListString, DedDocContextEnum) | Restituisce il primo documento avente estensione uguale alla prima trovata nella lista, che corrisponda al tipo di contesto specificato (vengono ignorati i documenti che non corrispondono a tale contesto).
Metodo pubblico | GetQsaOrCommonPath | Restiutisce il percorso del QSA se comune a tutti altrimenti il percorso comune a tutti i file.
Metodo pubblico | Refresh | Aggiorna i documenti rileggendo le informazioni presenti nel Database.
Metodo pubblico | SortByContext | Ordina gli elementi in base al contesto : MODELLO - RAPPRENSENTAZIONE - PUBBLICAZIONE - TAVOLA RICAMBIO - PUBBLICAZIONE RICAMBIO - ALLEGATO - NONE
Torna su
Vedi anche

Documentazione

Classe DedDocList
Namespace DedNet.Core


Metodo DedDocList.ClearParentDocuments

Metodo DedDocListClearParentDocuments
Pulisce la struttura dei padri forzando la lettura al successivo accesso alla proprietà

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ClearParentDocuments()
Public Sub ClearParentDocuments
public:
void ClearParentDocuments()
member ClearParentDocuments : unit -> unit
Vedi anche

Documentazione

Classe DedDocList
Namespace DedNet.Core


Metodo DedDocList.ContainsExt

Metodo DedDocListContainsExt
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | ContainsExt(String) | Restituisce se nella lista sia o meno presente un documento con l'estensione specificata.
Metodo pubblico | ContainsExt(String, DedDocContextEnum) | Restituisce se nella lista sia o meno presente un documento con l'estensione specificata ed avente il contesto richiesto.
Torna su
Vedi anche

Documentazione

Classe DedDocList
Namespace DedNet.Core


Metodo DedDocList.ContainsExt(String)

Metodo DedDocListContainsExt(String)
Restituisce se nella lista sia o meno presente un documento con l'estensione specificata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ContainsExt(
    string ext
)
Public Function ContainsExt (
    ext As String
) As Boolean
public:
bool ContainsExt(
    String^ ext
)
member ContainsExt :
        ext : string -> bool

Parametri

ext String
Estensione senza il punto.

Valore di ritorno

Boolean
Restituisce true se trova il documento con l'estensione specificata oppure false.
Vedi anche

Documentazione

Classe DedDocList
Overload di ContainsExt
Namespace DedNet.Core


Metodo DedDocList.ContainsExt(String, DedDocContextEnum)

Metodo DedDocListContainsExt(String, DedDocContextEnum)
Restituisce se nella lista sia o meno presente un documento con l'estensione specificata ed avente il contesto richiesto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ContainsExt(
    string ext,
    DedDocContextEnum context
)
Public Function ContainsExt (
    ext As String,
    context As DedDocContextEnum
) As Boolean
public:
bool ContainsExt(
    String^ ext,
    DedDocContextEnum context
)
member ContainsExt :
        ext : string *
        context : DedDocContextEnum -> bool

Parametri

ext String
Estensione senza il punto.
context DedDocContextEnum
Contesto dei documenti da analizzare.

Valore di ritorno

Boolean
Restituisce true se trova il documento con l'estensione specificata oppure false.
Vedi anche

Documentazione

Classe DedDocList
Overload di ContainsExt
Namespace DedNet.Core


Metodo DedDocList.ContainsFile

Metodo DedDocListContainsFile
Restituisce se nella lista sia o meno presente un documento con il nome e estensione passata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ContainsFile(
    string filename
)
Public Function ContainsFile (
    filename As String
) As Boolean
public:
bool ContainsFile(
    String^ filename
)
member ContainsFile :
        filename : string -> bool

Parametri

filename String
Nome del file con estensione.

Valore di ritorno

Boolean
Restituisce true se trova il documento con l'estensione specificata oppure false.
Vedi anche

Documentazione

Classe DedDocList
Namespace DedNet.Core


Metodo DedDocList.ContainsFileName

Metodo DedDocListContainsFileName
Restituisce true se contiene l'elemento richiesto altrimenti false.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ContainsFileName(
    string fileName
)
Public Function ContainsFileName (
    fileName As String
) As Boolean
public:
bool ContainsFileName(
    String^ fileName
)
member ContainsFileName :
        fileName : string -> bool

Parametri

fileName String
Elemento da verificare.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedDocList
Namespace DedNet.Core


Metodo DedDocList.GetAllSpecificExtDocuments

Metodo DedDocListGetAllSpecificExtDocuments
Restituisce una lista di documenti che hanno una specifica estensione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocList GetAllSpecificExtDocuments(
    string ext
)
Public Function GetAllSpecificExtDocuments (
    ext As String
) As DedDocList
public:
DedDocList^ GetAllSpecificExtDocuments(
    String^ ext
)
member GetAllSpecificExtDocuments :
        ext : string -> DedDocList

Parametri

ext String
Estensione dei documenti da cercare.

Valore di ritorno

DedDocList
Restituisce una lista di documenti, se non trova nessun documento restituisce una lista inizializzata.
Vedi anche

Documentazione

Classe DedDocList
Namespace DedNet.Core


Metodo DedDocList.GetCommonPath

Metodo DedDocListGetCommonPath
Restituisce il percorso comune a tutti i documenti presenti nella lista.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string GetCommonPath()
Public Function GetCommonPath As String
public:
String^ GetCommonPath()
member GetCommonPath : unit -> string

Valore di ritorno

String
Restituisce il percorso comune oppure stringa vuota "" se non c'è un percorso comune.
Vedi anche

Documentazione

Classe DedDocList
Namespace DedNet.Core


Metodo DedDocList.GetExt

Metodo DedDocListGetExt
Restituisce se nella lista sia o meno presente un documento con l'estensione specificata ed avente il contesto richiesto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDoc GetExt(
    string ext,
    DedDocContextEnum context
)
Public Function GetExt (
    ext As String,
    context As DedDocContextEnum
) As DedDoc
public:
DedDoc^ GetExt(
    String^ ext,
    DedDocContextEnum context
)
member GetExt :
        ext : string *
        context : DedDocContextEnum -> DedDoc

Parametri

ext String
Estensione senza il punto.
context DedDocContextEnum
Contesto dei documenti da analizzare.

Valore di ritorno

DedDoc
Restituisce true se trova il documento con l'estensione specificata oppure false.
Vedi anche

Documentazione

Classe DedDocList
Namespace DedNet.Core


Metodo DedDocList.GetFiles

Metodo DedDocListGetFiles
Restituisce un array contenente tutti i file presenti nell'oggetto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string[] GetFiles()
Public Function GetFiles As String()
public:
array<String^>^ GetFiles()
member GetFiles : unit -> string[]

Valore di ritorno

String
Restituisce un array contenente tutti i file presenti nell'oggetto.
Vedi anche

Documentazione

Classe DedDocList
Namespace DedNet.Core


Metodo DedDocList.GetFirstDocFromExtList

Metodo DedDocListGetFirstDocFromExtList
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | GetFirstDocFromExtList(ListString) | Restituisce il primo documento modello avente estensione uguale alla prima trovata nella lista.
Metodo pubblico | GetFirstDocFromExtList(ListString, DedDocContextEnum) | Restituisce il primo documento avente estensione uguale alla prima trovata nella lista, che corrisponda al tipo di contesto specificato (vengono ignorati i documenti che non corrispondono a tale contesto).
Torna su
Vedi anche

Documentazione

Classe DedDocList
Namespace DedNet.Core


Metodo DedDocList.GetFirstDocFromExtList(List<String>)

Metodo DedDocListGetFirstDocFromExtList(ListString)
Restituisce il primo documento modello avente estensione uguale alla prima trovata nella lista.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDoc GetFirstDocFromExtList(
    List<string> extList
)
Public Function GetFirstDocFromExtList (
    extList As List(Of String)
) As DedDoc
public:
DedDoc^ GetFirstDocFromExtList(
    List<String^>^ extList
)
member GetFirstDocFromExtList :
        extList : List<string> -> DedDoc

Parametri

extList List String
Lista di estensioni nella quale cercare.

Valore di ritorno

DedDoc
Restituisce il primo documento modello trovato oppure null se non trova nessun documento che corrisponda alle estensioni.
Vedi anche

Documentazione

Classe DedDocList
Overload di GetFirstDocFromExtList
Namespace DedNet.Core


Metodo DedDocList.GetFirstDocFromExtList(List<String>, DedDocContextEnum)

Metodo DedDocListGetFirstDocFromExtList(ListString, DedDocContextEnum)
Restituisce il primo documento avente estensione uguale alla prima trovata nella lista, che corrisponda al tipo di contesto specificato (vengono ignorati i documenti che non corrispondono a tale contesto).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDoc GetFirstDocFromExtList(
    List<string> extList,
    DedDocContextEnum context
)
Public Function GetFirstDocFromExtList (
    extList As List(Of String),
    context As DedDocContextEnum
) As DedDoc
public:
DedDoc^ GetFirstDocFromExtList(
    List<String^>^ extList,
    DedDocContextEnum context
)
member GetFirstDocFromExtList :
        extList : List<string> *
        context : DedDocContextEnum -> DedDoc

Parametri

extList List String
Lista di estensioni nella quale cercare.
context DedDocContextEnum
Contesto dei documenti da analizzare.

Valore di ritorno

DedDoc
Restituisce il primo documento trovato oppure null se non trova nessun documento che corrisponda alle estensioni ed al contesto.
Vedi anche

Documentazione

Classe DedDocList
Overload di GetFirstDocFromExtList
Namespace DedNet.Core


Metodo DedDocList.GetQsaOrCommonPath

Metodo DedDocListGetQsaOrCommonPath
Restiutisce il percorso del QSA se comune a tutti altrimenti il percorso comune a tutti i file.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string GetQsaOrCommonPath()
Public Function GetQsaOrCommonPath As String
public:
String^ GetQsaOrCommonPath()
member GetQsaOrCommonPath : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedDocList
Namespace DedNet.Core


Metodo DedDocList.Refresh

Metodo DedDocListRefresh
Aggiorna i documenti rileggendo le informazioni presenti nel Database.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Refresh()
Public Sub Refresh
public:
void Refresh()
member Refresh : unit -> unit
Eccezioni
Eccezione | Condizione
[!:DedRecordExceptionList] | Viene sollevata in caso di uno o più errori di aggiornamento.
Vedi anche

Documentazione

Classe DedDocList
Namespace DedNet.Core


Metodo DedDocList.SortByContext

Metodo DedDocListSortByContext
Ordina gli elementi in base al contesto : MODELLO - RAPPRENSENTAZIONE - PUBBLICAZIONE - TAVOLA RICAMBIO - PUBBLICAZIONE RICAMBIO - ALLEGATO - NONE

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SortByContext()
Public Sub SortByContext
public:
void SortByContext()
member SortByContext : unit -> unit
Vedi anche

Documentazione

Classe DedDocList
Namespace DedNet.Core


Classe DedDocManager
Gestisce la creazione e l'aggiornamento dei documenti, nonché i legami con le anagrafiche.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedDocManager

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedDocManager
Public Class DedDocManager
public ref class DedDocManager
type DedDocManager = class end

Il tipo DedDocManager espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Find(Guid) | Restituisce il documento presente nel DB, se esiste, altimenti restituisce null.
Metodo pubblico | Find(String) | Restituisce il documento presente nel DB, se esiste, altimenti restituisce null. Se è attiva l'area locale cerca anche nei percorsi di checkout.
Metodo pubblico | GetAllMovingFileNames | Restituisce una lista contenente tutti i FileName avuti da questo documento (compreso quello attuale).
Metodo pubblico | IsMovingDestination | Dato il nome file ritorna se il documento è frutto di un moving di un altro documento.
Metodo pubblico | IsSparePartContext | Ritorna True se il documento è associato all'anagrafica con uno dei contesti Ricambio, False altrimenti.
Metodo pubblico | ReadAllProperties(DedDoc, Boolean) | Legge tutte le proprietà del documento dalla tabella DED_DOC_PROPERTIES e le restituisce sotto forma di dizionario nome valore
Metodo pubblico | ReadAllProperties(String, Boolean) | Legge tutte le proprietà del documento dalla tabella DED_DOC_PROPERTIES e le restituisce sotto forma di dizionario nome valore
Metodo pubblico | ReadAllValueAndTypesProperties | Legge tutte le proprietà del documento dalla tabella DED_DOC_PROPERTIES e le restituisce sotto forma di dizionario nome - classe PropertiesInfo
Metodo pubblico | WritePropertiesInDb | Scrive le proprietà del documento nella tabella DED_DOC_PROPERTIES
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Metodi di DedDocManager

Il tipo DedDocManager espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Find(Guid) | Restituisce il documento presente nel DB, se esiste, altimenti restituisce null.
Metodo pubblico | Find(String) | Restituisce il documento presente nel DB, se esiste, altimenti restituisce null. Se è attiva l'area locale cerca anche nei percorsi di checkout.
Metodo pubblico | GetAllMovingFileNames | Restituisce una lista contenente tutti i FileName avuti da questo documento (compreso quello attuale).
Metodo pubblico | IsMovingDestination | Dato il nome file ritorna se il documento è frutto di un moving di un altro documento.
Metodo pubblico | IsSparePartContext | Ritorna True se il documento è associato all'anagrafica con uno dei contesti Ricambio, False altrimenti.
Metodo pubblico | ReadAllProperties(DedDoc, Boolean) | Legge tutte le proprietà del documento dalla tabella DED_DOC_PROPERTIES e le restituisce sotto forma di dizionario nome valore
Metodo pubblico | ReadAllProperties(String, Boolean) | Legge tutte le proprietà del documento dalla tabella DED_DOC_PROPERTIES e le restituisce sotto forma di dizionario nome valore
Metodo pubblico | ReadAllValueAndTypesProperties | Legge tutte le proprietà del documento dalla tabella DED_DOC_PROPERTIES e le restituisce sotto forma di dizionario nome - classe PropertiesInfo
Metodo pubblico | WritePropertiesInDb | Scrive le proprietà del documento nella tabella DED_DOC_PROPERTIES
Torna su
Vedi anche

Documentazione

Classe DedDocManager
Namespace DedNet.Core


Metodo DedDocManager.Find

Metodo DedDocManagerFind
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Find(Guid) | Restituisce il documento presente nel DB, se esiste, altimenti restituisce null.
Metodo pubblico | Find(String) | Restituisce il documento presente nel DB, se esiste, altimenti restituisce null. Se è attiva l'area locale cerca anche nei percorsi di checkout.
Torna su
Vedi anche

Documentazione

Classe DedDocManager
Namespace DedNet.Core


Metodo DedDocManager.Find(Guid)

Metodo DedDocManagerFind(Guid)
Restituisce il documento presente nel DB, se esiste, altimenti restituisce null.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDoc Find(
    Guid DocId
)
Public Function Find (
    DocId As Guid
) As DedDoc
public:
DedDoc^ Find(
    Guid DocId
)
member Find :
        DocId : Guid -> DedDoc

Parametri

DocId Guid
DocID del documento da reperire.

Valore di ritorno

DedDoc
Eccezioni
Eccezione | Condizione
QsException | Errore verificatosi durante la lettura del record.
Vedi anche

Documentazione

Classe DedDocManager
Overload di Find
Namespace DedNet.Core


Metodo DedDocManager.Find(String)

Metodo DedDocManagerFind(String)
Restituisce il documento presente nel DB, se esiste, altimenti restituisce null. Se è attiva l'area locale cerca anche nei percorsi di checkout.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDoc Find(
    string fullname
)
Public Function Find (
    fullname As String
) As DedDoc
public:
DedDoc^ Find(
    String^ fullname
)
member Find :
        fullname : string -> DedDoc

Parametri

fullname String
Fullname del documento da cercare.

Valore di ritorno

DedDoc
Eccezioni
Eccezione | Condizione
QsException | Errore verificatosi durante la lettura del record.
ArgumentNullException | Parametro mancante.
Vedi anche

Documentazione

Classe DedDocManager
Overload di Find
Namespace DedNet.Core


Metodo DedDocManager.GetAllMovingFileNames

Metodo DedDocManagerGetAllMovingFileNames
Restituisce una lista contenente tutti i FileName avuti da questo documento (compreso quello attuale).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> GetAllMovingFileNames(
    DedDoc document,
    bool includeCurrentFileName
)
Public Function GetAllMovingFileNames (
    document As DedDoc,
    includeCurrentFileName As Boolean
) As List(Of String)
public:
List<String^>^ GetAllMovingFileNames(
    DedDoc^ document,
    bool includeCurrentFileName
)
member GetAllMovingFileNames :
        document : DedDoc *
        includeCurrentFileName : bool -> List<string>

Parametri

document DedDoc
Documento del quale cercare la storia dei move.
includeCurrentFileName Boolean
Indica se includere nella lista anche il FileName attuale.

Valore di ritorno

List String
Vedi anche

Documentazione

Classe DedDocManager
Namespace DedNet.Core


Metodo DedDocManager.IsMovingDestination

Metodo DedDocManagerIsMovingDestination
Dato il nome file ritorna se il documento è frutto di un moving di un altro documento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsMovingDestination(
    string fullFileName
)
Public Function IsMovingDestination (
    fullFileName As String
) As Boolean
public:
bool IsMovingDestination(
    String^ fullFileName
)
member IsMovingDestination :
        fullFileName : string -> bool

Parametri

fullFileName String
Nome completo del file originale

Valore di ritorno

Boolean
Documento "moved" corrispondente
Vedi anche

Documentazione

Classe DedDocManager
Namespace DedNet.Core


Metodo DedDocManager.IsSparePartContext

Metodo DedDocManagerIsSparePartContext
Ritorna True se il documento è associato all'anagrafica con uno dei contesti Ricambio, False altrimenti.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsSparePartContext(
    DedDoc document
)
Public Function IsSparePartContext (
    document As DedDoc
) As Boolean
public:
bool IsSparePartContext(
    DedDoc^ document
)
member IsSparePartContext :
        document : DedDoc -> bool

Parametri

document DedDoc
Documento da controllare.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedDocManager
Namespace DedNet.Core


Metodo DedDocManager.ReadAllProperties

Metodo DedDocManagerReadAllProperties
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | ReadAllProperties(DedDoc, Boolean) | Legge tutte le proprietà del documento dalla tabella DED_DOC_PROPERTIES e le restituisce sotto forma di dizionario nome valore
Metodo pubblico | ReadAllProperties(String, Boolean) | Legge tutte le proprietà del documento dalla tabella DED_DOC_PROPERTIES e le restituisce sotto forma di dizionario nome valore
Torna su
Vedi anche

Documentazione

Classe DedDocManager
Namespace DedNet.Core


Metodo DedDocManager.ReadAllProperties(DedDoc, Boolean)

Metodo DedDocManagerReadAllProperties(DedDoc, Boolean)
Legge tutte le proprietà del documento dalla tabella DED_DOC_PROPERTIES e le restituisce sotto forma di dizionario nome valore

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<string, Object> ReadAllProperties(
    DedDoc doc,
    bool nameTraslated = false
)
Public Function ReadAllProperties (
    doc As DedDoc,
    Optional nameTraslated As Boolean = false
) As Dictionary(Of String, Object)
public:
Dictionary<String^, Object^>^ ReadAllProperties(
    DedDoc^ doc,
    bool nameTraslated = false
)
member ReadAllProperties :
        doc : DedDoc *
        ?nameTraslated : bool
(* Defaults:
        let _nameTraslated = defaultArg nameTraslated false
*)
-> Dictionary<string, Object>

Parametri

doc DedDoc
nameTraslated Boolean (Optional)

Valore di ritorno

Dictionary String, Object
Vedi anche

Documentazione

Classe DedDocManager
Overload di ReadAllProperties
Namespace DedNet.Core


Metodo DedDocManager.ReadAllProperties(String, Boolean)

Metodo DedDocManagerReadAllProperties(String, Boolean)
Legge tutte le proprietà del documento dalla tabella DED_DOC_PROPERTIES e le restituisce sotto forma di dizionario nome valore

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<string, Object> ReadAllProperties(
    string docId,
    bool nameTraslated = false
)
Public Function ReadAllProperties (
    docId As String,
    Optional nameTraslated As Boolean = false
) As Dictionary(Of String, Object)
public:
Dictionary<String^, Object^>^ ReadAllProperties(
    String^ docId,
    bool nameTraslated = false
)
member ReadAllProperties :
        docId : string *
        ?nameTraslated : bool
(* Defaults:
        let _nameTraslated = defaultArg nameTraslated false
*)
-> Dictionary<string, Object>

Parametri

docId String
nameTraslated Boolean (Optional)

Valore di ritorno

Dictionary String, Object
Vedi anche

Documentazione

Classe DedDocManager
Overload di ReadAllProperties
Namespace DedNet.Core


Metodo DedDocManager.ReadAllValueAndTypesProperties

Metodo DedDocManagerReadAllValueAndTypesProperties
Legge tutte le proprietà del documento dalla tabella DED_DOC_PROPERTIES e le restituisce sotto forma di dizionario nome - classe PropertiesInfo

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<string, DedDocManagerPropertiesInfo> ReadAllValueAndTypesProperties(
    string docId,
    bool nameTraslated = false
)
Public Function ReadAllValueAndTypesProperties (
    docId As String,
    Optional nameTraslated As Boolean = false
) As Dictionary(Of String, DedDocManagerPropertiesInfo)
public:
Dictionary<String^, DedDocManagerPropertiesInfo^>^ ReadAllValueAndTypesProperties(
    String^ docId,
    bool nameTraslated = false
)
member ReadAllValueAndTypesProperties :
        docId : string *
        ?nameTraslated : bool
(* Defaults:
        let _nameTraslated = defaultArg nameTraslated false
*)
-> Dictionary<string, DedDocManagerPropertiesInfo>

Parametri

docId String
nameTraslated Boolean (Optional)

Valore di ritorno

Dictionary String, DedDocManagerPropertiesInfo
Vedi anche

Documentazione

Classe DedDocManager
Namespace DedNet.Core


Metodo DedDocManager.WritePropertiesInDb

Metodo DedDocManagerWritePropertiesInDb
Scrive le proprietà del documento nella tabella DED_DOC_PROPERTIES

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void WritePropertiesInDb(
    DedDoc doc,
    Dictionary<string, Object> docProps
)
Public Sub WritePropertiesInDb (
    doc As DedDoc,
    docProps As Dictionary(Of String, Object)
)
public:
void WritePropertiesInDb(
    DedDoc^ doc,
    Dictionary<String^, Object^>^ docProps
)
member WritePropertiesInDb :
        doc : DedDoc *
        docProps : Dictionary<string, Object> -> unit

Parametri

doc DedDoc
docProps Dictionary String, Object
Lista delle proprietà da scrivere
Vedi anche

Documentazione

Classe DedDocManager
Namespace DedNet.Core


Classe DedDocManager.PropertiesInfo

Classe DedDocManagerPropertiesInfo
Classe che identifica la coppia valore - type per ogni attributo presente in DED_DOC_PROPERTIES Viene utilizzato per andare a scrivere nella griglia il valore corretto a parità di nome attributo. Possiamo avere un caso con stesso attributo e con datatype diversi, i valori dell'attributo sono presenti in colonne distinte (esempio VALUE_S e VALUE_F caso attributo LUNGHEZZA)
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedDocManagerPropertiesInfo

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class PropertiesInfo
Public Class PropertiesInfo
public ref class PropertiesInfo
type PropertiesInfo = class end

Il tipo DedDocManagerPropertiesInfo espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedDocManagerPropertiesInfo |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Type | Type letto da DB
Proprietà pubblica | Value | Valore letto da DB
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedDocManager.PropertiesInfo

Costruttore DedDocManagerPropertiesInfo

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public PropertiesInfo()
Public Sub New
public:
PropertiesInfo()
new : unit -> PropertiesInfo
Vedi anche

Documentazione

Classe DedDocManagerPropertiesInfo
Namespace DedNet.Core


Proprietà di PropertiesInfo

Il tipo DedDocManagerPropertiesInfo espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Type | Type letto da DB
Proprietà pubblica | Value | Valore letto da DB
Torna su
Vedi anche

Documentazione

Classe DedDocManagerPropertiesInfo
Namespace DedNet.Core


Proprietà DedDocManager.PropertiesInfo.Type

Proprietà DedDocManagerPropertiesInfoType
Type letto da DB

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Type Type { get; set; }
Public Property Type As Type
    Get
    Set
public:
property Type^ Type {
    Type^ get ();
    void set (Type^ value);
}
member Type : Type with get, set

Valore della proprietà

Type
Vedi anche

Documentazione

Classe DedDocManagerPropertiesInfo
Namespace DedNet.Core


Proprietà DedDocManager.PropertiesInfo.Value

Proprietà DedDocManagerPropertiesInfoValue
Valore letto da DB

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object Value { get; set; }
Public Property Value As Object
    Get
    Set
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}
member Value : Object with get, set

Valore della proprietà

Object
Vedi anche

Documentazione

Classe DedDocManagerPropertiesInfo
Namespace DedNet.Core


Classe DedDocumentNotAlignedException
Eccezione generata durante l'eliminazione dei dati.
Gerarchia di ereditarietà
SystemObject
SystemException
SystemApplicationException
QsException
DedNet.CoreDedDocumentNotAlignedException

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedDocumentNotAlignedException : QsException
Public Class DedDocumentNotAlignedException
    Inherits QsException
public ref class DedDocumentNotAlignedException : public QsException
type DedDocumentNotAlignedException =
    class
        inherit QsException
    end
Vedi anche

Documentazione

Namespace DedNet.Core


Classe DedEco
Classe usata per istanziare l'oggetto DedEco.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedBaseDbItem
DedNet.CoreDedTimedDbItem
DedNet.CoreDedEco

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedEco : DedTimedDbItem, IDedEditable
Public Class DedEco
    Inherits DedTimedDbItem
    Implements IDedEditable
public ref class DedEco : public DedTimedDbItem,
    IDedEditable
type DedEco =
    class
        inherit DedTimedDbItem
        interface IDedEditable
    end

Il tipo DedEco espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedEco(DedNetApplication, DedComm) | Costruttore per istanziare un nuovo oggetto DedEco con valori di default.
Metodo pubblico | DedEco(DedNetApplication, DedData) | Costruttore per istanziare un nuovo oggetto DedEco con valori di default.
Metodo pubblico | DedEco(DedNetApplication, DbDataReader) |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | ClosureNote | Note finali dell'Eco.
Proprietà pubblica | Comm | Commessa associata all'Eco.
Proprietà pubblica | Creator | Utene che ha creato l'ECO. Corrisponde all'internalname dell'oggetto DedUser.
Proprietà pubblica | Data | Anagrafica associata all'Eco.
Proprietà pubblica | DateClose | Data di creazione dell'Eco.
Proprietà pubblica | DateOpen | Data di creazione dell'Eco.
Proprietà pubblica | DbIndex | (Sovrascrive DedBaseDbItemDbIndex)
Proprietà pubblica | Descr | Descrizione associata all'Eco.
Proprietà pubblica | DocList | Lista di documenti associati all'Eco (effettua una query nel database).
Proprietà pubblica | ID | ID (in formato stringa) associata all'Eco.
Proprietà pubblica | LocalDirPath | Restituisce il percorso di archiviazione (pws se area locale attiva altrimenti vault) dei documenti di questo Eco.
Proprietà pubblica | Name | Nome dell'Eco.
Proprietà pubblica | Note | Descrizione associata all'Eco.
Proprietà pubblica | NotifyCreator | Indica se notificare il creatore dell'ECO ogni volta che questo cambia stato.
Proprietà pubblica | Owner | Utene a cui è assegnato l'ECO. Corrisponde all'internalname dell'oggetto DedUser.
Proprietà pubblica | State | Stato dell'Eco (aperto, in carico da, chiuso).
Proprietà pubblica | TimeList | Ritorna l'elenco delle temporizzazioni associate a questo elemento. (Ereditato da DedTimedDbItem)
Proprietà pubblica | Type | Indica il tipo di ECO (ECO, ECR, ecc..).
Proprietà pubblica | VaultDirPath | Restituisce il percorso di archiviazione (vault) dei documenti di questo Eco.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AssociateDocument | Metodo che registra il legame tra l'ECO e il documento passato in ingresso (effettua una query nel database).
Metodo pubblico | BeginIgnoreDirty | Indica all'oggetto di ignorare il set delle proprietà, in modo che non si effettui l'aggiornamento nel Database.
Metodo pubblico | DisconnectDocument | Metodo che elimina (nel database) il legame tra Eco e il documento passato in ingresso. Il file fisico non viene cancellato.
Metodo pubblico | EndIgnoreDirty | Ripristina la situazione di normalità per quanto riguarda l'aggiornamento nel Database su modifica delle proprietà dell'oggetto.
Metodo pubblico | GetDescription | (Sovrascrive DedBaseDbItemGetDescription)
Metodo pubblico | GetName | (Sovrascrive DedBaseDbItemGetName)
Metodo pubblico | GetObjectType | (Sovrascrive DedBaseDbItemGetObjectType)
Metodo pubblico | GetValue(DedEcoStandardEcoFields) | Restituisce il contenuto di uno dei campi standard oppure null se non è presente.
Metodo pubblico | GetValue(String) | Restituisce il contenuto di un campo personalizzato oppure null se non esiste.
Metodo pubblico | SetValue(DedEcoStandardEcoFields, Object) | Imposta un campo standard con un nuovo valore. Se il campo non è compilato lo crea nel dizionario interno.
Metodo pubblico | SetValue(String, Object) | Imposta un campo personalizzato con un nuovo valore. Se il campo non è compilato lo crea nel dizionario interno.
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Metodo pubblico | Update | Aggiorna l'ECO nel database con le modifiche che attualmente sono "appese".
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedEco
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | DedEco(DedNetApplication, DedComm) | Costruttore per istanziare un nuovo oggetto DedEco con valori di default.
Metodo pubblico | DedEco(DedNetApplication, DedData) | Costruttore per istanziare un nuovo oggetto DedEco con valori di default.
Metodo pubblico | DedEco(DedNetApplication, DbDataReader) |
Torna su
Vedi anche

Documentazione

Classe DedEco
Namespace DedNet.Core


Costruttore DedEco(DedNetApplication, DedComm)
Costruttore per istanziare un nuovo oggetto DedEco con valori di default.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEco(
    DedNetApplication app,
    DedComm comm
)
Public Sub New (
    app As DedNetApplication,
    comm As DedComm
)
public:
DedEco(
    DedNetApplication^ app,
    DedComm^ comm
)
new :
        app : DedNetApplication *
        comm : DedComm -> DedEco

Parametri

app DedNetApplication
Applicazione DedNet.
comm DedComm
Commessa associata all'Eco.
Vedi anche

Documentazione

Classe DedEco
Overload di DedEco
Namespace DedNet.Core


Costruttore DedEco(DedNetApplication, DedData)
Costruttore per istanziare un nuovo oggetto DedEco con valori di default.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEco(
    DedNetApplication app,
    DedData data
)
Public Sub New (
    app As DedNetApplication,
    data As DedData
)
public:
DedEco(
    DedNetApplication^ app,
    DedData^ data
)
new :
        app : DedNetApplication *
        data : DedData -> DedEco

Parametri

app DedNetApplication
Applicazione DedNet.
data DedData
Anagrafica associata all'Eco.
Vedi anche

Documentazione

Classe DedEco
Overload di DedEco
Namespace DedNet.Core


Costruttore DedEco(DedNetApplication, DbDataReader)

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEco(
    DedNetApplication app,
    DbDataReader row
)
Public Sub New (
    app As DedNetApplication,
    row As DbDataReader
)
public:
DedEco(
    DedNetApplication^ app,
    DbDataReader^ row
)
new :
        app : DedNetApplication *
        row : DbDataReader -> DedEco

Parametri

app DedNetApplication
row DbDataReader
Vedi anche

Documentazione

Classe DedEco
Overload di DedEco
Namespace DedNet.Core


Proprietà di DedEco

Il tipo DedEco espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | ClosureNote | Note finali dell'Eco.
Proprietà pubblica | Comm | Commessa associata all'Eco.
Proprietà pubblica | Creator | Utene che ha creato l'ECO. Corrisponde all'internalname dell'oggetto DedUser.
Proprietà pubblica | Data | Anagrafica associata all'Eco.
Proprietà pubblica | DateClose | Data di creazione dell'Eco.
Proprietà pubblica | DateOpen | Data di creazione dell'Eco.
Proprietà pubblica | DbIndex | (Sovrascrive DedBaseDbItemDbIndex)
Proprietà pubblica | Descr | Descrizione associata all'Eco.
Proprietà pubblica | DocList | Lista di documenti associati all'Eco (effettua una query nel database).
Proprietà pubblica | ID | ID (in formato stringa) associata all'Eco.
Proprietà pubblica | LocalDirPath | Restituisce il percorso di archiviazione (pws se area locale attiva altrimenti vault) dei documenti di questo Eco.
Proprietà pubblica | Name | Nome dell'Eco.
Proprietà pubblica | Note | Descrizione associata all'Eco.
Proprietà pubblica | NotifyCreator | Indica se notificare il creatore dell'ECO ogni volta che questo cambia stato.
Proprietà pubblica | Owner | Utene a cui è assegnato l'ECO. Corrisponde all'internalname dell'oggetto DedUser.
Proprietà pubblica | State | Stato dell'Eco (aperto, in carico da, chiuso).
Proprietà pubblica | TimeList | Ritorna l'elenco delle temporizzazioni associate a questo elemento. (Ereditato da DedTimedDbItem)
Proprietà pubblica | Type | Indica il tipo di ECO (ECO, ECR, ecc..).
Proprietà pubblica | VaultDirPath | Restituisce il percorso di archiviazione (vault) dei documenti di questo Eco.
Torna su
Vedi anche

Documentazione

Classe DedEco
Namespace DedNet.Core


Proprietà DedEco.ClosureNote

Proprietà DedEcoClosureNote
Note finali dell'Eco.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string ClosureNote { get; set; }
Public Property ClosureNote As String
    Get
    Set
public:
property String^ ClosureNote {
    String^ get ();
    void set (String^ value);
}
member ClosureNote : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedEco
Namespace DedNet.Core


Proprietà DedEco.Comm

Proprietà DedEcoComm
Commessa associata all'Eco.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedComm Comm { get; }
Public ReadOnly Property Comm As DedComm
    Get
public:
property DedComm^ Comm {
    DedComm^ get ();
}
member Comm : DedComm with get

Valore della proprietà

DedComm
Vedi anche

Documentazione

Classe DedEco
Namespace DedNet.Core


Proprietà DedEco.Creator

Proprietà DedEcoCreator
Utene che ha creato l'ECO. Corrisponde all'internalname dell'oggetto DedUser.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Creator { get; set; }
Public Property Creator As String
    Get
    Set
public:
property String^ Creator {
    String^ get ();
    void set (String^ value);
}
member Creator : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedEco
Namespace DedNet.Core


Proprietà DedEco.Data

Proprietà DedEcoData
Anagrafica associata all'Eco.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; }
Public ReadOnly Property Data As DedData
    Get
public:
property DedData^ Data {
    DedData^ get ();
}
member Data : DedData with get

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe DedEco
Namespace DedNet.Core


Proprietà DedEco.DateClose

Proprietà DedEcoDateClose
Data di creazione dell'Eco.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DateTime? DateClose { get; set; }
Public Property DateClose As DateTime?
    Get
    Set
public:
property Nullable<DateTime> DateClose {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
member DateClose : Nullable<DateTime> with get, set

Valore della proprietà

Nullable DateTime
Vedi anche

Documentazione

Classe DedEco
Namespace DedNet.Core


Proprietà DedEco.DateOpen

Proprietà DedEcoDateOpen
Data di creazione dell'Eco.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DateTime? DateOpen { get; set; }
Public Property DateOpen As DateTime?
    Get
    Set
public:
property Nullable<DateTime> DateOpen {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
member DateOpen : Nullable<DateTime> with get, set

Valore della proprietà

Nullable DateTime
Vedi anche

Documentazione

Classe DedEco
Namespace DedNet.Core


Proprietà DedEco.DbIndex

Proprietà DedEcoDbIndex

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string DbIndex { get; }
Public Overrides ReadOnly Property DbIndex As String
    Get
public:
virtual property String^ DbIndex {
    String^ get () override;
}
abstract DbIndex : string with get
override DbIndex : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedEco
Namespace DedNet.Core


Proprietà DedEco.Descr

Proprietà DedEcoDescr
Descrizione associata all'Eco.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Descr { get; set; }
Public Property Descr As String
    Get
    Set
public:
property String^ Descr {
    String^ get ();
    void set (String^ value);
}
member Descr : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedEco
Namespace DedNet.Core


Proprietà DedEco.DocList

Proprietà DedEcoDocList
Lista di documenti associati all'Eco (effettua una query nel database).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocList DocList { get; }
Public ReadOnly Property DocList As DedDocList
    Get
public:
property DedDocList^ DocList {
    DedDocList^ get ();
}
member DocList : DedDocList with get

Valore della proprietà

DedDocList
Vedi anche

Documentazione

Classe DedEco
Namespace DedNet.Core


Proprietà DedEco.ID

Proprietà DedEcoID
ID (in formato stringa) associata all'Eco.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string ID { get; }
Public ReadOnly Property ID As String
    Get
public:
property String^ ID {
    String^ get ();
}
member ID : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedEco
Namespace DedNet.Core


Proprietà DedEco.LocalDirPath

Proprietà DedEcoLocalDirPath
Restituisce il percorso di archiviazione (pws se area locale attiva altrimenti vault) dei documenti di questo Eco.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string LocalDirPath { get; }
Public ReadOnly Property LocalDirPath As String
    Get
public:
property String^ LocalDirPath {
    String^ get ();
}
member LocalDirPath : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedEco
Namespace DedNet.Core


Proprietà DedEco.Name

Proprietà DedEcoName
Nome dell'Eco.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedEco
Namespace DedNet.Core


Proprietà DedEco.Note

Proprietà DedEcoNote
Descrizione associata all'Eco.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Note { get; set; }
Public Property Note As String
    Get
    Set
public:
property String^ Note {
    String^ get ();
    void set (String^ value);
}
member Note : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedEco
Namespace DedNet.Core


Proprietà DedEco.NotifyCreator

Proprietà DedEcoNotifyCreator
Indica se notificare il creatore dell'ECO ogni volta che questo cambia stato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool NotifyCreator { get; set; }
Public Property NotifyCreator As Boolean
    Get
    Set
public:
property bool NotifyCreator {
    bool get ();
    void set (bool value);
}
member NotifyCreator : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedEco
Namespace DedNet.Core


Proprietà DedEco.Owner

Proprietà DedEcoOwner
Utene a cui è assegnato l'ECO. Corrisponde all'internalname dell'oggetto DedUser.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Owner { get; set; }
Public Property Owner As String
    Get
    Set
public:
property String^ Owner {
    String^ get ();
    void set (String^ value);
}
member Owner : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedEco
Namespace DedNet.Core


Proprietà DedEco.State

Proprietà DedEcoState
Stato dell'Eco (aperto, in carico da, chiuso).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEcoEcoStateEnum State { get; set; }
Public Property State As DedEcoEcoStateEnum
    Get
    Set
public:
property DedEcoEcoStateEnum State {
    DedEcoEcoStateEnum get ();
    void set (DedEcoEcoStateEnum value);
}
member State : DedEcoEcoStateEnum with get, set

Valore della proprietà

DedEcoEcoStateEnum
Vedi anche

Documentazione

Classe DedEco
Namespace DedNet.Core


Proprietà DedEco.Type

Proprietà DedEcoType
Indica il tipo di ECO (ECO, ECR, ecc..).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEcoEcoTypeEnum Type { get; set; }
Public Property Type As DedEcoEcoTypeEnum
    Get
    Set
public:
property DedEcoEcoTypeEnum Type {
    DedEcoEcoTypeEnum get ();
    void set (DedEcoEcoTypeEnum value);
}
member Type : DedEcoEcoTypeEnum with get, set

Valore della proprietà

DedEcoEcoTypeEnum
Vedi anche

Documentazione

Classe DedEco
Namespace DedNet.Core


Proprietà DedEco.VaultDirPath

Proprietà DedEcoVaultDirPath
Restituisce il percorso di archiviazione (vault) dei documenti di questo Eco.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string VaultDirPath { get; }
Public ReadOnly Property VaultDirPath As String
    Get
public:
property String^ VaultDirPath {
    String^ get ();
}
member VaultDirPath : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedEco
Namespace DedNet.Core


Metodi di DedEco

Il tipo DedEco espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AssociateDocument | Metodo che registra il legame tra l'ECO e il documento passato in ingresso (effettua una query nel database).
Metodo pubblico | BeginIgnoreDirty | Indica all'oggetto di ignorare il set delle proprietà, in modo che non si effettui l'aggiornamento nel Database.
Metodo pubblico | DisconnectDocument | Metodo che elimina (nel database) il legame tra Eco e il documento passato in ingresso. Il file fisico non viene cancellato.
Metodo pubblico | EndIgnoreDirty | Ripristina la situazione di normalità per quanto riguarda l'aggiornamento nel Database su modifica delle proprietà dell'oggetto.
Metodo pubblico | GetDescription | (Sovrascrive DedBaseDbItemGetDescription)
Metodo pubblico | GetName | (Sovrascrive DedBaseDbItemGetName)
Metodo pubblico | GetObjectType | (Sovrascrive DedBaseDbItemGetObjectType)
Metodo pubblico | GetValue(DedEcoStandardEcoFields) | Restituisce il contenuto di uno dei campi standard oppure null se non è presente.
Metodo pubblico | GetValue(String) | Restituisce il contenuto di un campo personalizzato oppure null se non esiste.
Metodo pubblico | SetValue(DedEcoStandardEcoFields, Object) | Imposta un campo standard con un nuovo valore. Se il campo non è compilato lo crea nel dizionario interno.
Metodo pubblico | SetValue(String, Object) | Imposta un campo personalizzato con un nuovo valore. Se il campo non è compilato lo crea nel dizionario interno.
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Metodo pubblico | Update | Aggiorna l'ECO nel database con le modifiche che attualmente sono "appese".
Torna su
Vedi anche

Documentazione

Classe DedEco
Namespace DedNet.Core


Metodo DedEco.AssociateDocument

Metodo DedEcoAssociateDocument
Metodo che registra il legame tra l'ECO e il documento passato in ingresso (effettua una query nel database).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssociateDocument(
    DedDoc doc
)
Public Sub AssociateDocument (
    doc As DedDoc
)
public:
void AssociateDocument(
    DedDoc^ doc
)
member AssociateDocument :
        doc : DedDoc -> unit

Parametri

doc DedDoc
Documento da associare all'ECO.
Eccezioni
Eccezione | Condizione
QsException | Solleva questa eccezione se non riesce a registrare il legame.
Vedi anche

Documentazione

Classe DedEco
Namespace DedNet.Core


Metodo DedEco.BeginIgnoreDirty

Metodo DedEcoBeginIgnoreDirty
Indica all'oggetto di ignorare il set delle proprietà, in modo che non si effettui l'aggiornamento nel Database.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void BeginIgnoreDirty()
Public Sub BeginIgnoreDirty
public:
void BeginIgnoreDirty()
member BeginIgnoreDirty : unit -> unit
Vedi anche

Documentazione

Classe DedEco
Namespace DedNet.Core


Metodo DedEco.DisconnectDocument

Metodo DedEcoDisconnectDocument
Metodo che elimina (nel database) il legame tra Eco e il documento passato in ingresso. Il file fisico non viene cancellato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void DisconnectDocument(
    DedDoc doc
)
Public Sub DisconnectDocument (
    doc As DedDoc
)
public:
void DisconnectDocument(
    DedDoc^ doc
)
member DisconnectDocument :
        doc : DedDoc -> unit

Parametri

doc DedDoc
Documento da eliminare.
Vedi anche

Documentazione

Classe DedEco
Namespace DedNet.Core


Metodo DedEco.EndIgnoreDirty

Metodo DedEcoEndIgnoreDirty
Ripristina la situazione di normalità per quanto riguarda l'aggiornamento nel Database su modifica delle proprietà dell'oggetto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void EndIgnoreDirty()
Public Sub EndIgnoreDirty
public:
void EndIgnoreDirty()
member EndIgnoreDirty : unit -> unit
Vedi anche

Documentazione

Classe DedEco
Namespace DedNet.Core


Metodo DedEco.GetDescription

Metodo DedEcoGetDescription

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string GetDescription()
Public Overrides Function GetDescription As String
public:
virtual String^ GetDescription() override
abstract GetDescription : unit -> string
override GetDescription : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedEco
Namespace DedNet.Core


Metodo DedEco.GetName

Metodo DedEcoGetName

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string GetName()
Public Overrides Function GetName As String
public:
virtual String^ GetName() override
abstract GetName : unit -> string
override GetName : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedEco
Namespace DedNet.Core


Metodo DedEco.GetObjectType

Metodo DedEcoGetObjectType

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override DedDbItemType GetObjectType()
Public Overrides Function GetObjectType As DedDbItemType
public:
virtual DedDbItemType GetObjectType() override
abstract GetObjectType : unit -> DedDbItemType
override GetObjectType : unit -> DedDbItemType

Valore di ritorno

DedDbItemType
Vedi anche

Documentazione

Classe DedEco
Namespace DedNet.Core


Metodo DedEco.GetValue

Metodo DedEcoGetValue
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | GetValue(DedEcoStandardEcoFields) | Restituisce il contenuto di uno dei campi standard oppure null se non è presente.
Metodo pubblico | GetValue(String) | Restituisce il contenuto di un campo personalizzato oppure null se non esiste.
Torna su
Vedi anche

Documentazione

Classe DedEco
Namespace DedNet.Core


Metodo DedEco.GetValue(DedEco.StandardEcoFields)

Metodo DedEcoGetValue(DedEcoStandardEcoFields)
Restituisce il contenuto di uno dei campi standard oppure null se non è presente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object GetValue(
    DedEcoStandardEcoFields stdfield
)
Public Function GetValue (
    stdfield As DedEcoStandardEcoFields
) As Object
public:
Object^ GetValue(
    DedEcoStandardEcoFields stdfield
)
member GetValue :
        stdfield : DedEcoStandardEcoFields -> Object

Parametri

stdfield DedEcoStandardEcoFields
Campo standard del quale avere il contenuto.

Valore di ritorno

Object
Vedi anche

Documentazione

Classe DedEco
Overload di GetValue
Namespace DedNet.Core


Metodo DedEco.GetValue(String)

Metodo DedEcoGetValue(String)
Restituisce il contenuto di un campo personalizzato oppure null se non esiste.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object GetValue(
    string persfield
)
Public Function GetValue (
    persfield As String
) As Object
public:
virtual Object^ GetValue(
    String^ persfield
) sealed
abstract GetValue :
        persfield : string -> Object
override GetValue :
        persfield : string -> Object

Parametri

persfield String
Nome del campo personalizzato del quale avere il contenuto.

Valore di ritorno

Object

Implementa

IDedEditableGetValue(String)
Vedi anche

Documentazione

Classe DedEco
Overload di GetValue
Namespace DedNet.Core


Metodo DedEco.SetValue

Metodo DedEcoSetValue
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | SetValue(DedEcoStandardEcoFields, Object) | Imposta un campo standard con un nuovo valore. Se il campo non è compilato lo crea nel dizionario interno.
Metodo pubblico | SetValue(String, Object) | Imposta un campo personalizzato con un nuovo valore. Se il campo non è compilato lo crea nel dizionario interno.
Torna su
Vedi anche

Documentazione

Classe DedEco
Namespace DedNet.Core


Metodo DedEco.SetValue(DedEco.StandardEcoFields, Object)

Metodo DedEcoSetValue(DedEcoStandardEcoFields, Object)
Imposta un campo standard con un nuovo valore. Se il campo non è compilato lo crea nel dizionario interno.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetValue(
    DedEcoStandardEcoFields stdfield,
    Object Value
)
Public Sub SetValue (
    stdfield As DedEcoStandardEcoFields,
    Value As Object
)
public:
void SetValue(
    DedEcoStandardEcoFields stdfield,
    Object^ Value
)
member SetValue :
        stdfield : DedEcoStandardEcoFields *
        Value : Object -> unit

Parametri

stdfield DedEcoStandardEcoFields
Campo standard da impostare.
Value Object
Valore da impostare.
Vedi anche

Documentazione

Classe DedEco
Overload di SetValue
Namespace DedNet.Core


Metodo DedEco.SetValue(String, Object)

Metodo DedEcoSetValue(String, Object)
Imposta un campo personalizzato con un nuovo valore. Se il campo non è compilato lo crea nel dizionario interno.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetValue(
    string persfield,
    Object value
)
Public Sub SetValue (
    persfield As String,
    value As Object
)
public:
virtual void SetValue(
    String^ persfield,
    Object^ value
) sealed
abstract SetValue :
        persfield : string *
        value : Object -> unit
override SetValue :
        persfield : string *
        value : Object -> unit

Parametri

persfield String
Nome del campo personalizzato da impostare.
value Object
Valore da impostare.

Implementa

IDedEditableSetValue(String, Object)
Vedi anche

Documentazione

Classe DedEco
Overload di SetValue
Namespace DedNet.Core


Metodo DedEco.ToString

Metodo DedEcoToString

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedEco
Namespace DedNet.Core


Metodo DedEco.Update

Metodo DedEcoUpdate
Aggiorna l'ECO nel database con le modifiche che attualmente sono "appese".

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Update()
Public Sub Update
public:
void Update()
member Update : unit -> unit
Vedi anche

Documentazione

Classe DedEco
Namespace DedNet.Core


Enumerazione DedEco.EcoStateEnum

Enumerazione DedEcoEcoStateEnum
Enumerazione sui possibili stati dell'ECO.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum EcoStateEnum
Public Enumeration EcoStateEnum
public enum class EcoStateEnum
type EcoStateEnum
Membri
Nome | Valore | Descrizione
Aperto | 0 | Eco aperto.
Assegnato | 1 | Eco assegnato.
Chiuso | 2 | Eco chiuso.
Vedi anche

Documentazione

Namespace DedNet.Core


Enumerazione DedEco.EcoTypeEnum

Enumerazione DedEcoEcoTypeEnum
Enumerazione sui possibili tipi di ECO.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum EcoTypeEnum
Public Enumeration EcoTypeEnum
public enum class EcoTypeEnum
type EcoTypeEnum
Membri
Nome | Valore | Descrizione
ECO | 0 | ECO bloccante che necessita di essere chiuso prima di procedere con l'esecuzione di determinate operazioni.
ECR | 1 | ECO non bloccante che non necessita di essere chiuso prima di procedere con l'esecuzione di determinate operazioni.
Vedi anche

Documentazione

Namespace DedNet.Core


Enumerazione DedEco.StandardEcoFields

Enumerazione DedEcoStandardEcoFields
Elenco dei campi standard.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum StandardEcoFields
Public Enumeration StandardEcoFields
public enum class StandardEcoFields
type StandardEcoFields
Membri
Nome | Valore | Descrizione
ECOID | 0 | ID dell'ECO.
ECOANAG | 1 | Anagrafica associata all'ECO.
ECOCOMM | 2 | Commessa associata all'ECO.
NAME | 3 | Nome dell'ECO.
DESCR | 4 | Descrizione dell'ECO.
NOTE | 5 | Note dell'ECO.
CLOSURENOTE | 6 | Note di cambio stato dell'ECO.
OWNER | 7 | Utente che ha preso in carico l'ECO.
CREATOR | 8 | Utente che ha creato l'ECO.
DATEOPEN | 9 | Data di creazione dell'ECO.
DATECLOSE | 10 | Data di chiusura dell'ECO.
STATE | 11 | Stato dell'ECO.
TYPE | 12 | Indica il tipo di ECO (ECO, ECR, ecc..)
NOTIFYCREATOR | 13 | Indica se notificare il creatore dell'ECO ogni volta che questo cambia stato.
Vedi anche

Documentazione

Namespace DedNet.Core


Classe DedEcoList
Lista di oggetti di tipo DedEco.
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList DedEco
DedNet.CoreDedEcoList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedEcoList : List<DedEco>
Public Class DedEcoList
    Inherits List(Of DedEco)
public ref class DedEcoList : public List<DedEco^>
type DedEcoList =
    class
        inherit List<DedEco>
    end

Il tipo DedEcoList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedEcoList |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedEcoList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEcoList()
Public Sub New
public:
DedEcoList()
new : unit -> DedEcoList
Vedi anche

Documentazione

Classe DedEcoList
Namespace DedNet.Core


Classe DedEcoManager
Classe usata per istanziare il manager degli Eco.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedEcoManager

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedEcoManager
Public Class DedEcoManager
public ref class DedEcoManager
type DedEcoManager = class end

Il tipo DedEcoManager espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedEcoManager | Costruttore unico.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Add | Metodo che inserisce l'Eco nel database.
Metodo pubblico | AddEcoHistory | Aggiunge un record in DED_ECO_HISTORY relativo all'operazione, all'utente che ha causato l'operazione e gli utenti notificati via mail.
Metodo pubblico | AssociateDocumentToEco | Metodo che registra (nel database) il legame Eco e il documento passato in ingresso.
Metodo pubblico | CountAllEco(DedComm, Boolean) | Ritorna il numero di ECO (indipendentemente dal tipo) associati alla commessa.
Metodo pubblico | CountAllEco(DedData, Boolean, Boolean) | Ritorna il numero di ECO (indipendentemente dal tipo) associati all'anagrafica.
Metodo pubblico | CountAllNotClosedEco | Ritorna il numero di ECO, con uno stato diverso da 'CHIUSO', associati a TUTTE le anagrafiche con un determinato ID.
Metodo pubblico | CountNotClosedEco(DedComm) | Ritorna il numero di Eco, con uno stato diverso da 'CHIUSO', associati alla commessa.
Metodo pubblico | CountNotClosedEco(DedData) | Ritorna il numero di Eco, con uno stato diverso da 'CHIUSO', associati all'anagrafica.
Metodo pubblico | CountNotClosedEcoEcr | Compila il numero di Eco e di Ecr, con uno stato diverso da 'CHIUSO', associati alla commessa.
Metodo pubblico | CountNotClosedEcr(DedComm) | Ritorna il numero di Eco, con uno stato diverso da 'CHIUSO', associati alla commessa.
Metodo pubblico | CountNotClosedEcr(DedData) | Ritorna il numero di Ecr, con uno stato diverso da 'CHIUSO', associati all'anagrafica.
Metodo pubblico | Delete | Metodo che elimina l'Eco dal database. Elimina anche eventuali documenti ad esso collegati.
Metodo pubblico | DisconnectDocumenteFromEco | Metodo che registra (nel database) il legame tra ECO e documento.
Metodo pubblico | FindByAnagr | Metodo che in base all'anagrafica passata in ingresso, ritorna tutti gli Eco ad essa associati.
Metodo pubblico | FindByComm | Metodo che in base alla commessa passata in ingresso, ritorna tutti gli Eco ad essa associati.
Metodo pubblico | FindByDoc | Metodo che ritorna una lista di Eco ai quali il documento è associato.
Metodo pubblico | FindByID | Metodo che ritorna un oggetto DedEco in base all'ID passato in ingresso.
Metodo pubblico | GetFormattedName | Metodo usato per formattare il nome dell'ECO.
Metodo pubblico | GetFormattedNameWithoutPrefix | Metodo usato per formattare il nome dell'ECO senza il prefisso "ECO.".
Metodo pubblico | Update | Metodo che aggiorna l'Eco nel database. Non aggiorna i campi "ID", "NAME", "DATEOPEN" e "CREATOR".
Metodo pubblico | UpdateHistory | Metodo che aggiorna la nota di chiusura nella tabella DED_ECO_HISTORY.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedEcoManager
Costruttore unico.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEcoManager(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedEcoManager(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedEcoManager

Parametri

app DedNetApplication
Vedi anche

Documentazione

Classe DedEcoManager
Namespace DedNet.Core


Metodi di DedEcoManager

Il tipo DedEcoManager espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Add | Metodo che inserisce l'Eco nel database.
Metodo pubblico | AddEcoHistory | Aggiunge un record in DED_ECO_HISTORY relativo all'operazione, all'utente che ha causato l'operazione e gli utenti notificati via mail.
Metodo pubblico | AssociateDocumentToEco | Metodo che registra (nel database) il legame Eco e il documento passato in ingresso.
Metodo pubblico | CountAllEco(DedComm, Boolean) | Ritorna il numero di ECO (indipendentemente dal tipo) associati alla commessa.
Metodo pubblico | CountAllEco(DedData, Boolean, Boolean) | Ritorna il numero di ECO (indipendentemente dal tipo) associati all'anagrafica.
Metodo pubblico | CountAllNotClosedEco | Ritorna il numero di ECO, con uno stato diverso da 'CHIUSO', associati a TUTTE le anagrafiche con un determinato ID.
Metodo pubblico | CountNotClosedEco(DedComm) | Ritorna il numero di Eco, con uno stato diverso da 'CHIUSO', associati alla commessa.
Metodo pubblico | CountNotClosedEco(DedData) | Ritorna il numero di Eco, con uno stato diverso da 'CHIUSO', associati all'anagrafica.
Metodo pubblico | CountNotClosedEcoEcr | Compila il numero di Eco e di Ecr, con uno stato diverso da 'CHIUSO', associati alla commessa.
Metodo pubblico | CountNotClosedEcr(DedComm) | Ritorna il numero di Eco, con uno stato diverso da 'CHIUSO', associati alla commessa.
Metodo pubblico | CountNotClosedEcr(DedData) | Ritorna il numero di Ecr, con uno stato diverso da 'CHIUSO', associati all'anagrafica.
Metodo pubblico | Delete | Metodo che elimina l'Eco dal database. Elimina anche eventuali documenti ad esso collegati.
Metodo pubblico | DisconnectDocumenteFromEco | Metodo che registra (nel database) il legame tra ECO e documento.
Metodo pubblico | FindByAnagr | Metodo che in base all'anagrafica passata in ingresso, ritorna tutti gli Eco ad essa associati.
Metodo pubblico | FindByComm | Metodo che in base alla commessa passata in ingresso, ritorna tutti gli Eco ad essa associati.
Metodo pubblico | FindByDoc | Metodo che ritorna una lista di Eco ai quali il documento è associato.
Metodo pubblico | FindByID | Metodo che ritorna un oggetto DedEco in base all'ID passato in ingresso.
Metodo pubblico | GetFormattedName | Metodo usato per formattare il nome dell'ECO.
Metodo pubblico | GetFormattedNameWithoutPrefix | Metodo usato per formattare il nome dell'ECO senza il prefisso "ECO.".
Metodo pubblico | Update | Metodo che aggiorna l'Eco nel database. Non aggiorna i campi "ID", "NAME", "DATEOPEN" e "CREATOR".
Metodo pubblico | UpdateHistory | Metodo che aggiorna la nota di chiusura nella tabella DED_ECO_HISTORY.
Torna su
Vedi anche

Documentazione

Classe DedEcoManager
Namespace DedNet.Core


Metodo DedEcoManager.Add

Metodo DedEcoManagerAdd
Metodo che inserisce l'Eco nel database.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Add(
    DedEco eco
)
Public Sub Add (
    eco As DedEco
)
public:
void Add(
    DedEco^ eco
)
member Add :
        eco : DedEco -> unit

Parametri

eco DedEco
Eccezioni
Eccezione | Condizione
ArgumentNullException | Parametro mancante.
QsException | Solleva questa eccezione se non riesce a registrare l'Eco.
Vedi anche

Documentazione

Classe DedEcoManager
Namespace DedNet.Core


Metodo DedEcoManager.AddEcoHistory

Metodo DedEcoManagerAddEcoHistory
Aggiunge un record in DED_ECO_HISTORY relativo all'operazione, all'utente che ha causato l'operazione e gli utenti notificati via mail.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddEcoHistory(
    DedEco eco,
    string note,
    List<DedUser> users
)
Public Sub AddEcoHistory (
    eco As DedEco,
    note As String,
    users As List(Of DedUser)
)
public:
void AddEcoHistory(
    DedEco^ eco,
    String^ note,
    List<DedUser^>^ users
)
member AddEcoHistory :
        eco : DedEco *
        note : string *
        users : List<DedUser> -> unit

Parametri

eco DedEco
ECO soggetto all'operazione.
note String
Eventuali note da allegare.
users List DedUser
Utenti che sono stati notificati via mail.
Vedi anche

Documentazione

Classe DedEcoManager
Namespace DedNet.Core


Metodo DedEcoManager.AssociateDocumentToEco

Metodo DedEcoManagerAssociateDocumentToEco
Metodo che registra (nel database) il legame Eco e il documento passato in ingresso.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssociateDocumentToEco(
    DedEco eco,
    DedDoc doc
)
Public Sub AssociateDocumentToEco (
    eco As DedEco,
    doc As DedDoc
)
public:
void AssociateDocumentToEco(
    DedEco^ eco,
    DedDoc^ doc
)
member AssociateDocumentToEco :
        eco : DedEco *
        doc : DedDoc -> unit

Parametri

eco DedEco
ECO di riferimento.
doc DedDoc
Documento da associare all'ECO.
Eccezioni
Eccezione | Condizione
QsException | Solleva questa eccezione se non riesce a registrare il legame.
Vedi anche

Documentazione

Classe DedEcoManager
Namespace DedNet.Core


Metodo DedEcoManager.CountAllEco

Metodo DedEcoManagerCountAllEco
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | CountAllEco(DedComm, Boolean) | Ritorna il numero di ECO (indipendentemente dal tipo) associati alla commessa.
Metodo pubblico | CountAllEco(DedData, Boolean, Boolean) | Ritorna il numero di ECO (indipendentemente dal tipo) associati all'anagrafica.
Torna su
Vedi anche

Documentazione

Classe DedEcoManager
Namespace DedNet.Core


Metodo DedEcoManager.CountAllEco(DedComm, Boolean)

Metodo DedEcoManagerCountAllEco(DedComm, Boolean)
Ritorna il numero di ECO (indipendentemente dal tipo) associati alla commessa.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int CountAllEco(
    DedComm comm,
    bool skipIfClose
)
Public Function CountAllEco (
    comm As DedComm,
    skipIfClose As Boolean
) As Integer
public:
int CountAllEco(
    DedComm^ comm,
    bool skipIfClose
)
member CountAllEco :
        comm : DedComm *
        skipIfClose : bool -> int

Parametri

comm DedComm
skipIfClose Boolean

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedEcoManager
Overload di CountAllEco
Namespace DedNet.Core


Metodo DedEcoManager.CountAllEco(DedData, Boolean, Boolean)

Metodo DedEcoManagerCountAllEco(DedData, Boolean, Boolean)
Ritorna il numero di ECO (indipendentemente dal tipo) associati all'anagrafica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int CountAllEco(
    DedData data,
    bool checkRev,
    bool skipIfClose
)
Public Function CountAllEco (
    data As DedData,
    checkRev As Boolean,
    skipIfClose As Boolean
) As Integer
public:
int CountAllEco(
    DedData^ data,
    bool checkRev,
    bool skipIfClose
)
member CountAllEco :
        data : DedData *
        checkRev : bool *
        skipIfClose : bool -> int

Parametri

data DedData
Anagrafica di cui verificare la presenza di ECO.
checkRev Boolean
Indica se tenere conto delle revisioni e ricercare gli ECO solo per ID.
skipIfClose Boolean
Indica se tenere conto degli ECO impostati come chiusi.

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedEcoManager
Overload di CountAllEco
Namespace DedNet.Core


Metodo DedEcoManager.CountAllNotClosedEco

Metodo DedEcoManagerCountAllNotClosedEco
Ritorna il numero di ECO, con uno stato diverso da 'CHIUSO', associati a TUTTE le anagrafiche con un determinato ID.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int CountAllNotClosedEco(
    DedData data
)
Public Function CountAllNotClosedEco (
    data As DedData
) As Integer
public:
int CountAllNotClosedEco(
    DedData^ data
)
member CountAllNotClosedEco :
        data : DedData -> int

Parametri

data DedData

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedEcoManager
Namespace DedNet.Core


Metodo DedEcoManager.CountNotClosedEco

Metodo DedEcoManagerCountNotClosedEco
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | CountNotClosedEco(DedComm) | Ritorna il numero di Eco, con uno stato diverso da 'CHIUSO', associati alla commessa.
Metodo pubblico | CountNotClosedEco(DedData) | Ritorna il numero di Eco, con uno stato diverso da 'CHIUSO', associati all'anagrafica.
Torna su
Vedi anche

Documentazione

Classe DedEcoManager
Namespace DedNet.Core


Metodo DedEcoManager.CountNotClosedEco(DedComm)

Metodo DedEcoManagerCountNotClosedEco(DedComm)
Ritorna il numero di Eco, con uno stato diverso da 'CHIUSO', associati alla commessa.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int CountNotClosedEco(
    DedComm comm
)
Public Function CountNotClosedEco (
    comm As DedComm
) As Integer
public:
int CountNotClosedEco(
    DedComm^ comm
)
member CountNotClosedEco :
        comm : DedComm -> int

Parametri

comm DedComm

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedEcoManager
Overload di CountNotClosedEco
Namespace DedNet.Core


Metodo DedEcoManager.CountNotClosedEco(DedData)

Metodo DedEcoManagerCountNotClosedEco(DedData)
Ritorna il numero di Eco, con uno stato diverso da 'CHIUSO', associati all'anagrafica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int CountNotClosedEco(
    DedData data
)
Public Function CountNotClosedEco (
    data As DedData
) As Integer
public:
int CountNotClosedEco(
    DedData^ data
)
member CountNotClosedEco :
        data : DedData -> int

Parametri

data DedData

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedEcoManager
Overload di CountNotClosedEco
Namespace DedNet.Core


Metodo DedEcoManager.CountNotClosedEcoEcr

Metodo DedEcoManagerCountNotClosedEcoEcr
Compila il numero di Eco e di Ecr, con uno stato diverso da 'CHIUSO', associati alla commessa.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void CountNotClosedEcoEcr(
    DedComm comm,
    out int ecoNumber,
    out int ecrNumber
)
Public Sub CountNotClosedEcoEcr (
    comm As DedComm,
    <OutAttribute> ByRef ecoNumber As Integer,
    <OutAttribute> ByRef ecrNumber As Integer
)
public:
void CountNotClosedEcoEcr(
    DedComm^ comm,
    [OutAttribute] int% ecoNumber,
    [OutAttribute] int% ecrNumber
)
member CountNotClosedEcoEcr :
        comm : DedComm *
        ecoNumber : int byref *
        ecrNumber : int byref -> unit

Parametri

comm DedComm
ecoNumber Int32
ecrNumber Int32
Vedi anche

Documentazione

Classe DedEcoManager
Namespace DedNet.Core


Metodo DedEcoManager.CountNotClosedEcr

Metodo DedEcoManagerCountNotClosedEcr
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | CountNotClosedEcr(DedComm) | Ritorna il numero di Eco, con uno stato diverso da 'CHIUSO', associati alla commessa.
Metodo pubblico | CountNotClosedEcr(DedData) | Ritorna il numero di Ecr, con uno stato diverso da 'CHIUSO', associati all'anagrafica.
Torna su
Vedi anche

Documentazione

Classe DedEcoManager
Namespace DedNet.Core


Metodo DedEcoManager.CountNotClosedEcr(DedComm)

Metodo DedEcoManagerCountNotClosedEcr(DedComm)
Ritorna il numero di Eco, con uno stato diverso da 'CHIUSO', associati alla commessa.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int CountNotClosedEcr(
    DedComm comm
)
Public Function CountNotClosedEcr (
    comm As DedComm
) As Integer
public:
int CountNotClosedEcr(
    DedComm^ comm
)
member CountNotClosedEcr :
        comm : DedComm -> int

Parametri

comm DedComm

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedEcoManager
Overload di CountNotClosedEcr
Namespace DedNet.Core


Metodo DedEcoManager.CountNotClosedEcr(DedData)

Metodo DedEcoManagerCountNotClosedEcr(DedData)
Ritorna il numero di Ecr, con uno stato diverso da 'CHIUSO', associati all'anagrafica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int CountNotClosedEcr(
    DedData data
)
Public Function CountNotClosedEcr (
    data As DedData
) As Integer
public:
int CountNotClosedEcr(
    DedData^ data
)
member CountNotClosedEcr :
        data : DedData -> int

Parametri

data DedData

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedEcoManager
Overload di CountNotClosedEcr
Namespace DedNet.Core


Metodo DedEcoManager.Delete

Metodo DedEcoManagerDelete
Metodo che elimina l'Eco dal database. Elimina anche eventuali documenti ad esso collegati.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Delete(
    DedEco eco
)
Public Sub Delete (
    eco As DedEco
)
public:
void Delete(
    DedEco^ eco
)
member Delete :
        eco : DedEco -> unit

Parametri

eco DedEco
Eco da aliminare.
Eccezioni
Eccezione | Condizione
ArgumentNullException | Parametro mancante.
QsException | Eco non registrato all'interno del database.
QsException | Commessa non trovata con id e versione dell'oggetto.
QsException | Solleva questa eccezione se non riesce ad eliminare l'Eco.
Vedi anche

Documentazione

Classe DedEcoManager
Namespace DedNet.Core


Metodo DedEcoManager.DisconnectDocumenteFromEco

Metodo DedEcoManagerDisconnectDocumenteFromEco
Metodo che registra (nel database) il legame tra ECO e documento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void DisconnectDocumenteFromEco(
    DedEco eco,
    DedDoc doc
)
Public Sub DisconnectDocumenteFromEco (
    eco As DedEco,
    doc As DedDoc
)
public:
void DisconnectDocumenteFromEco(
    DedEco^ eco,
    DedDoc^ doc
)
member DisconnectDocumenteFromEco :
        eco : DedEco *
        doc : DedDoc -> unit

Parametri

eco DedEco
doc DedDoc
Eccezioni
Eccezione | Condizione
QsException | Solleva questa eccezione se non riesce a registrare il legame.
Vedi anche

Documentazione

Classe DedEcoManager
Namespace DedNet.Core


Metodo DedEcoManager.FindByAnagr

Metodo DedEcoManagerFindByAnagr
Metodo che in base all'anagrafica passata in ingresso, ritorna tutti gli Eco ad essa associati.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEcoList FindByAnagr(
    DedData data
)
Public Function FindByAnagr (
    data As DedData
) As DedEcoList
public:
DedEcoList^ FindByAnagr(
    DedData^ data
)
member FindByAnagr :
        data : DedData -> DedEcoList

Parametri

data DedData

Valore di ritorno

DedEcoList
Vedi anche

Documentazione

Classe DedEcoManager
Namespace DedNet.Core


Metodo DedEcoManager.FindByComm

Metodo DedEcoManagerFindByComm
Metodo che in base alla commessa passata in ingresso, ritorna tutti gli Eco ad essa associati.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEcoList FindByComm(
    DedComm comm
)
Public Function FindByComm (
    comm As DedComm
) As DedEcoList
public:
DedEcoList^ FindByComm(
    DedComm^ comm
)
member FindByComm :
        comm : DedComm -> DedEcoList

Parametri

comm DedComm

Valore di ritorno

DedEcoList
Vedi anche

Documentazione

Classe DedEcoManager
Namespace DedNet.Core


Metodo DedEcoManager.FindByDoc

Metodo DedEcoManagerFindByDoc
Metodo che ritorna una lista di Eco ai quali il documento è associato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEcoList FindByDoc(
    DedDoc doc
)
Public Function FindByDoc (
    doc As DedDoc
) As DedEcoList
public:
DedEcoList^ FindByDoc(
    DedDoc^ doc
)
member FindByDoc :
        doc : DedDoc -> DedEcoList

Parametri

doc DedDoc
Documento associato all'Eco.

Valore di ritorno

DedEcoList
Lista DedEco trovati.
Vedi anche

Documentazione

Classe DedEcoManager
Namespace DedNet.Core


Metodo DedEcoManager.FindByID

Metodo DedEcoManagerFindByID
Metodo che ritorna un oggetto DedEco in base all'ID passato in ingresso.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEco FindByID(
    string id
)
Public Function FindByID (
    id As String
) As DedEco
public:
DedEco^ FindByID(
    String^ id
)
member FindByID :
        id : string -> DedEco

Parametri

id String
Id univoco dell'Eco. Viene letto dalla colonna "ECOID".

Valore di ritorno

DedEco
Oggetto DedEco se viene trovato, altrimenti null.
Vedi anche

Documentazione

Classe DedEcoManager
Namespace DedNet.Core


Metodo DedEcoManager.GetFormattedName

Metodo DedEcoManagerGetFormattedName
Metodo usato per formattare il nome dell'ECO.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string GetFormattedName(
    string dbName
)
Public Function GetFormattedName (
    dbName As String
) As String
public:
String^ GetFormattedName(
    String^ dbName
)
member GetFormattedName :
        dbName : string -> string

Parametri

dbName String

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedEcoManager
Namespace DedNet.Core


Metodo DedEcoManager.GetFormattedNameWithoutPrefix

Metodo DedEcoManagerGetFormattedNameWithoutPrefix
Metodo usato per formattare il nome dell'ECO senza il prefisso "ECO.".

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string GetFormattedNameWithoutPrefix(
    DedEco eco
)
Public Function GetFormattedNameWithoutPrefix (
    eco As DedEco
) As String
public:
String^ GetFormattedNameWithoutPrefix(
    DedEco^ eco
)
member GetFormattedNameWithoutPrefix :
        eco : DedEco -> string

Parametri

eco DedEco

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedEcoManager
Namespace DedNet.Core


Metodo DedEcoManager.Update

Metodo DedEcoManagerUpdate
Metodo che aggiorna l'Eco nel database. Non aggiorna i campi "ID", "NAME", "DATEOPEN" e "CREATOR".

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Update(
    DedEco eco
)
Public Sub Update (
    eco As DedEco
)
public:
void Update(
    DedEco^ eco
)
member Update :
        eco : DedEco -> unit

Parametri

eco DedEco
Eccezioni
Eccezione | Condizione
ArgumentNullException | Parametro mancante.
QsException | Eco non registrato all'interno del database.
QsException | Commessa non trovata con id e versione dell'oggetto.
QsException | Solleva questa eccezione se non riesce ad aggiornare l'Eco.
Vedi anche

Documentazione

Classe DedEcoManager
Namespace DedNet.Core


Metodo DedEcoManager.UpdateHistory

Metodo DedEcoManagerUpdateHistory
Metodo che aggiorna la nota di chiusura nella tabella DED_ECO_HISTORY.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void UpdateHistory(
    DedEco eco
)
Public Sub UpdateHistory (
    eco As DedEco
)
public:
void UpdateHistory(
    DedEco^ eco
)
member UpdateHistory :
        eco : DedEco -> unit

Parametri

eco DedEco
Eccezioni
Eccezione | Condizione
ArgumentNullException | Parametro mancante.
QsException | Eco non registrato all'interno del database.
QsException | Commessa non trovata con id e versione dell'oggetto.
QsException | Solleva questa eccezione se non riesce ad aggiornare.
Vedi anche

Documentazione

Classe DedEcoManager
Namespace DedNet.Core


Classe DedEditableObject<T>

Classe DedEditableObjectT
Classe utilizzata per gestire il meccanismo dello store dei dati e l'interrogazione della proprietà 'Dirty'.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedBaseDbItem
DedNet.CoreDedEditableObjectT
DedNet.CoreDedTime

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public abstract class DedEditableObject<T> : DedBaseDbItem,
    IDedDbItem

Public MustInherit Class DedEditableObject(Of T)
    Inherits DedBaseDbItem
    Implements IDedDbItem
generic<typename T>
public ref class DedEditableObject abstract : public DedBaseDbItem,
    IDedDbItem
[<AbstractClassAttribute>]
type DedEditableObject<'T> =
    class
        inherit DedBaseDbItem
        interface IDedDbItem
    end

Parametri di tipo

T

Il tipo DedEditableObjectT espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedEditableObjectT(IDedDbCollectionBaseT) | Costruttore
Metodo pubblico | DedEditableObjectT(IDedDbCollectionBaseT, DbDataReader) | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Applicazione DedNet.
Proprietà pubblica | DbIndex | GUID, in formato stringa, che identifica in modo univoco l'elemento corrente. (Sovrascrive DedBaseDbItemDbIndex)
Proprietà protetta | Ignoredirty | Dice al metodo SetValue() di non impostare a dirty l'oggetto.
Proprietà pubblica | Parent | Lista a cui appartiene l'elemento corrente.
Proprietà pubblica | StatoRecord | Restituisce o imposta lo stato del record.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | GetDescription | Restiruisce la descrizione dell'elemento corrente (Ereditato da DedBaseDbItem)
Metodo pubblico | GetName | Restituisce il nome dell'elemento corrente (Ereditato da DedBaseDbItem)
Metodo pubblico | GetObjectType | Indica la tipologia dell'elemento corrente (Anagrafica, commessa, ECO, ecc..) (Ereditato da DedBaseDbItem)
Metodo protetto | GetValue | Restituisce il contenuto di uno dei campi oppure null se non è presente.
Metodo protetto | ReadData | Imposta i dati nel dizionario dei valori leggendoli dal 'DbDataReader' specificato.
Metodo protetto | SetValue | Imposta il contenuto di uno dei campi.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedEditableObject<T>

Costruttore DedEditableObjectT
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | DedEditableObjectT(IDedDbCollectionBaseT) | Costruttore
Metodo pubblico | DedEditableObjectT(IDedDbCollectionBaseT, DbDataReader) | Costruttore
Torna su
Vedi anche

Documentazione

Classe DedEditableObjectT
Namespace DedNet.Core


Costruttore DedEditableObject<T>(IDedDbCollectionBase<T>)

Costruttore DedEditableObjectT(IDedDbCollectionBaseT)
Costruttore

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEditableObject(
    IDedDbCollectionBase<T> parent
)
Public Sub New (
    parent As IDedDbCollectionBase(Of T)
)
public:
DedEditableObject(
    IDedDbCollectionBase<T>^ parent
)
new :
        parent : IDedDbCollectionBase<'T> -> DedEditableObject

Parametri

parent IDedDbCollectionBase T
Collezione di appartenenza
Vedi anche

Documentazione

Classe DedEditableObjectT
Overload di DedEditableObjectT
Namespace DedNet.Core


Costruttore DedEditableObject<T>(IDedDbCollectionBase<T>, DbDataReader)

Costruttore DedEditableObjectT(IDedDbCollectionBaseT, DbDataReader)
Costruttore

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEditableObject(
    IDedDbCollectionBase<T> parent,
    DbDataReader reader
)
Public Sub New (
    parent As IDedDbCollectionBase(Of T),
    reader As DbDataReader
)
public:
DedEditableObject(
    IDedDbCollectionBase<T>^ parent,
    DbDataReader^ reader
)
new :
        parent : IDedDbCollectionBase<'T> *
        reader : DbDataReader -> DedEditableObject

Parametri

parent IDedDbCollectionBase T
Collezione di appartenenza
reader DbDataReader
Readre dal quel leggere le informazioni
Vedi anche

Documentazione

Classe DedEditableObjectT
Overload di DedEditableObjectT
Namespace DedNet.Core


Proprietà di DedEditableObject<T>

Proprietà di DedEditableObjectT

Il tipo DedEditableObjectT espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Applicazione DedNet.
Proprietà pubblica | DbIndex | GUID, in formato stringa, che identifica in modo univoco l'elemento corrente. (Sovrascrive DedBaseDbItemDbIndex)
Proprietà protetta | Ignoredirty | Dice al metodo SetValue() di non impostare a dirty l'oggetto.
Proprietà pubblica | Parent | Lista a cui appartiene l'elemento corrente.
Proprietà pubblica | StatoRecord | Restituisce o imposta lo stato del record.
Torna su
Vedi anche

Documentazione

Classe DedEditableObjectT
Namespace DedNet.Core


Proprietà DedEditableObject<T>.Application

Proprietà DedEditableObjectTApplication
Applicazione DedNet.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedNetApplication Application { get; }
Public ReadOnly Property Application As DedNetApplication
    Get
public:
property DedNetApplication^ Application {
    DedNetApplication^ get ();
}
member Application : DedNetApplication with get

Valore della proprietà

DedNetApplication
Vedi anche

Documentazione

Classe DedEditableObjectT
Namespace DedNet.Core


Proprietà DedEditableObject<T>.DbIndex

Proprietà DedEditableObjectTDbIndex
GUID, in formato stringa, che identifica in modo univoco l'elemento corrente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string DbIndex { get; }
Public Overrides ReadOnly Property DbIndex As String
    Get
public:
virtual property String^ DbIndex {
    String^ get () override;
}
abstract DbIndex : string with get
override DbIndex : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedEditableObjectT
Namespace DedNet.Core


Proprietà DedEditableObject<T>.Ignoredirty

Proprietà DedEditableObjectTIgnoredirty
Dice al metodo SetValue() di non impostare a dirty l'oggetto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected bool Ignoredirty { get; set; }
Protected Property Ignoredirty As Boolean
    Get
    Set
protected:
property bool Ignoredirty {
    bool get ();
    void set (bool value);
}
member Ignoredirty : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedEditableObjectT
Namespace DedNet.Core


Proprietà DedEditableObject<T>.Parent

Proprietà DedEditableObjectTParent
Lista a cui appartiene l'elemento corrente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public IDedDbCollectionBase<T> Parent { get; }
Public ReadOnly Property Parent As IDedDbCollectionBase(Of T)
    Get
public:
property IDedDbCollectionBase<T>^ Parent {
    IDedDbCollectionBase<T>^ get ();
}
member Parent : IDedDbCollectionBase<'T> with get

Valore della proprietà

IDedDbCollectionBase T
Vedi anche

Documentazione

Classe DedEditableObjectT
Namespace DedNet.Core


Proprietà DedEditableObject<T>.StatoRecord

Proprietà DedEditableObjectTStatoRecord
Restituisce o imposta lo stato del record.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public StatoRecord StatoRecord { get; set; }
Public Property StatoRecord As StatoRecord
    Get
    Set
public:
virtual property StatoRecord^ StatoRecord {
    StatoRecord^ get () sealed;
    void set (StatoRecord^ value) sealed;
}
abstract StatoRecord : StatoRecord with get, set
override StatoRecord : StatoRecord with get, set

Valore della proprietà

StatoRecord

Implementa

IDedDbItemStatoRecord
Vedi anche

Documentazione

Classe DedEditableObjectT
Namespace DedNet.Core


Metodi di DedEditableObject<T>

Metodi di DedEditableObjectT

Il tipo DedEditableObjectT espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | GetDescription | Restiruisce la descrizione dell'elemento corrente (Ereditato da DedBaseDbItem)
Metodo pubblico | GetName | Restituisce il nome dell'elemento corrente (Ereditato da DedBaseDbItem)
Metodo pubblico | GetObjectType | Indica la tipologia dell'elemento corrente (Anagrafica, commessa, ECO, ecc..) (Ereditato da DedBaseDbItem)
Metodo protetto | GetValue | Restituisce il contenuto di uno dei campi oppure null se non è presente.
Metodo protetto | ReadData | Imposta i dati nel dizionario dei valori leggendoli dal 'DbDataReader' specificato.
Metodo protetto | SetValue | Imposta il contenuto di uno dei campi.
Torna su
Vedi anche

Documentazione

Classe DedEditableObjectT
Namespace DedNet.Core


Metodo DedEditableObject<T>.GetValue

Metodo DedEditableObjectTGetValue
Restituisce il contenuto di uno dei campi oppure null se non è presente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected Object GetValue(
    string property
)
Protected Function GetValue (
    property As String
) As Object
protected:
Object^ GetValue(
    String^ property
)
member GetValue :
        property : string -> Object

Parametri

property String

Valore di ritorno

Object
Vedi anche

Documentazione

Classe DedEditableObjectT
Namespace DedNet.Core


Metodo DedEditableObject<T>.ReadData

Metodo DedEditableObjectTReadData
Imposta i dati nel dizionario dei valori leggendoli dal 'DbDataReader' specificato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected virtual void ReadData(
    DbDataReader reader
)
Protected Overridable Sub ReadData (
    reader As DbDataReader
)
protected:
virtual void ReadData(
    DbDataReader^ reader
)
abstract ReadData :
        reader : DbDataReader -> unit
override ReadData :
        reader : DbDataReader -> unit

Parametri

reader DbDataReader
Vedi anche

Documentazione

Classe DedEditableObjectT
Namespace DedNet.Core


Metodo DedEditableObject<T>.SetValue

Metodo DedEditableObjectTSetValue
Imposta il contenuto di uno dei campi.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected void SetValue(
    string property,
    Object newVal
)
Protected Sub SetValue (
    property As String,
    newVal As Object
)
protected:
void SetValue(
    String^ property,
    Object^ newVal
)
member SetValue :
        property : string *
        newVal : Object -> unit

Parametri

property String
newVal Object
Vedi anche

Documentazione

Classe DedEditableObjectT
Namespace DedNet.Core


Classe DedEditableObjectCollection<T>

Classe DedEditableObjectCollectionT
Classe contenente l'elenco dei vari 'DedEditableObject' collegati fra loro.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedDbCollectionBase T
DedNet.CoreDedEditableObjectCollectionT
DedNet.CoreDedTimeList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public abstract class DedEditableObjectCollection<T> : DedDbCollectionBase<T>
where T : DedEditableObject<T>

Public MustInherit Class DedEditableObjectCollection(Of T As DedEditableObject(Of T))
    Inherits DedDbCollectionBase(Of T)
generic<typename T>
where T : DedEditableObject<T>
public ref class DedEditableObjectCollection abstract : public DedDbCollectionBase<T>
[<AbstractClassAttribute>]
type DedEditableObjectCollection<'T when 'T : DedEditableObject<'T>> =
    class
        inherit DedDbCollectionBase<'T>
    end

Parametri di tipo

T

Il tipo DedEditableObjectCollectionT espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedEditableObjectCollectionT | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllowsDuplicates | Restituisce se siano ammessi duplicati all'interno della lista. Se false viene sollevata una eccezione su tentativo di inserimento duplicati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Application | Restituisce l'oggetto applicazione di appartenza. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Count | Restituisce il numero di elementi presenti. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Dirty | Restituisce se la collezione o uno dei suoi elementi sia stata modificata. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | ErasedItems | Restitusice la lista in sola lettura degli elementi che risultano attualmente cancellati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | LastItem | Restituisce l'ultimo elemento della collezione oppure null se non ci sono elementi. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Parent | Oggetto di cui si vogliono gestire le temporizzazioni.
Proprietà pubblica | RestoreErased | Restituisce se gli elementi cancellati devono essere ripristinati in caso vengano riaggiunti. (Ereditato da DedDbCollectionBaseT)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | AddForClone | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto SENZA MODIFICARNE LO STATO. Le classi derivate potranno utilizzare questo metodo per clonare la collezione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddNewElement | DI USO INTERNO. Aggiunge un elemento alla lista rendendo dirty l'oggetto. L'elemento viene aggiunto con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere un elemento alla lista. Dovranno loro stesse avere un metodo pubblico Add() che prenda i parametri necessari alla costruzione dell'oggetto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddRangeNewElement | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi rendendo dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere più elementi alla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddUnModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Clear | Elimina tutti gli elementi dalla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ClearRefresh | Svuota la lista impostando Dirty = false. Di fatto permette di effettuare un refresh della lista e quindi di ricaricarla. Serve per svuotare la lista e reinizializzarla da capo. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Contains | Verifica l'esistenza di un valore all'interno della lista degli elementi. Le classi derivate devono effettuarne l'override nel caso in cui l'elemento non implementi GetHashCode() per l'uso all'interno dei dizionarii. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | CopyTo | Copia un range di elementi in un array. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | CreateDeleteCommand | Crea, inizializza e restituisce il comando per l'eliminazione di un elemento. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | CreateInsertCommand | Crea, inizializza e restituisce il comando per l'inserimento di un elemento. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | CreateUpdateCommand | Crea, inizializza e restituisce il comando per l'aggiornamento di un elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | CustomSort | Ordina la lista in base al comparatore passato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteDeleteItem | Esegue l'eliminazione di un elemento. Crea il comando tramite il metodo CreateDeleteCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteInsertItem | Esegue l'inserimento di un elemento. Crea il comando tramite il metodo CreateInsertCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteUpdateItem | Esegue l'aggiornamento di un elemento. Crea il comando tramite il metodo CreateUpdateCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Find | Restituisce l'oggetto cercato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FindAll | Restitusice la lista degli elementi che corrispondono al predicato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | GetDbIndex | Restituisce l'indice dell'elemento passato, da utilizzare nelle clausole where di aggiornamento/eliminazione. (Sovrascrive DedDbCollectionBaseTGetDbIndex(T))
Metodo pubblico | GetEnumerator | Restituisce l'enumeratore della collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | IndexOf | Restituisce l'indice dell'elemento richiesto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InsertUnModified | DI USO INTERNO. Inserisce un elemento alla lista senza rendere dirty l'oggetto, all'indice specificato. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Item | Restituisce l'elemento iesimo della lista. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Load | Ripulisce la lista corrente e rilegge i dati.
Metodo pubblico | LoadItems | Metodo astratto da implementare che ritorna l'elenco degli elementi da aggiungere alla lista corrente.
Metodo pubblico | Move(Int32, Boolean) | Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean, Int32) | Sposta l'elemento dell'indice passato prima o dopo del numero di posizioni passate. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSave | Metodo Template chiamato dopo il salvataggio avvenuto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSaveNoChanges | Metodo Template chiamato dopo il salvataggio senza modifiche. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnBeforeSave | Metodo Template chiamato prima del salvataggio. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(T) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(DedEditableObjectT) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(T) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(DedEditableObjectT) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ReInitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Remove | Elimina un elemento dalla collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Ripristina | Verifica che l'elemento sia presente negli eliminati e lo toglie da lì e lo riaggiunge in coda alla lista degli elementi validi. Solleva una eccezione se l'elemento è già presente nella lista e AllowsDuplicates = false. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Save | Salva l'oggetto con tutta la sua lista, solo se questo risulta dirty. (Ereditato da DedDbCollectionBaseT)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedEditableObjectCollection<T>

Costruttore DedEditableObjectCollectionT
Costruttore

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEditableObjectCollection(
    DedBaseDbItem parent
)
Public Sub New (
    parent As DedBaseDbItem
)
public:
DedEditableObjectCollection(
    DedBaseDbItem^ parent
)
new :
        parent : DedBaseDbItem -> DedEditableObjectCollection

Parametri

parent DedBaseDbItem
Collezione di appartenenza
Vedi anche

Documentazione

Classe DedEditableObjectCollectionT
Namespace DedNet.Core


Proprietà di DedEditableObjectCollection<T>

Proprietà di DedEditableObjectCollectionT

Il tipo DedEditableObjectCollectionT espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllowsDuplicates | Restituisce se siano ammessi duplicati all'interno della lista. Se false viene sollevata una eccezione su tentativo di inserimento duplicati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Application | Restituisce l'oggetto applicazione di appartenza. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Count | Restituisce il numero di elementi presenti. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Dirty | Restituisce se la collezione o uno dei suoi elementi sia stata modificata. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | ErasedItems | Restitusice la lista in sola lettura degli elementi che risultano attualmente cancellati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | LastItem | Restituisce l'ultimo elemento della collezione oppure null se non ci sono elementi. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Parent | Oggetto di cui si vogliono gestire le temporizzazioni.
Proprietà pubblica | RestoreErased | Restituisce se gli elementi cancellati devono essere ripristinati in caso vengano riaggiunti. (Ereditato da DedDbCollectionBaseT)
Torna su
Vedi anche

Documentazione

Classe DedEditableObjectCollectionT
Namespace DedNet.Core


Proprietà DedEditableObjectCollection<T>.Parent

Proprietà DedEditableObjectCollectionTParent
Oggetto di cui si vogliono gestire le temporizzazioni.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedBaseDbItem Parent { get; set; }
Public Property Parent As DedBaseDbItem
    Get
    Set
public:
property DedBaseDbItem^ Parent {
    DedBaseDbItem^ get ();
    void set (DedBaseDbItem^ value);
}
member Parent : DedBaseDbItem with get, set

Valore della proprietà

DedBaseDbItem
Vedi anche

Documentazione

Classe DedEditableObjectCollectionT
Namespace DedNet.Core


Metodi di DedEditableObjectCollection<T>

Metodi di DedEditableObjectCollectionT

Il tipo DedEditableObjectCollectionT espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | AddForClone | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto SENZA MODIFICARNE LO STATO. Le classi derivate potranno utilizzare questo metodo per clonare la collezione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddNewElement | DI USO INTERNO. Aggiunge un elemento alla lista rendendo dirty l'oggetto. L'elemento viene aggiunto con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere un elemento alla lista. Dovranno loro stesse avere un metodo pubblico Add() che prenda i parametri necessari alla costruzione dell'oggetto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddRangeNewElement | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi rendendo dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere più elementi alla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddUnModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Clear | Elimina tutti gli elementi dalla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ClearRefresh | Svuota la lista impostando Dirty = false. Di fatto permette di effettuare un refresh della lista e quindi di ricaricarla. Serve per svuotare la lista e reinizializzarla da capo. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Contains | Verifica l'esistenza di un valore all'interno della lista degli elementi. Le classi derivate devono effettuarne l'override nel caso in cui l'elemento non implementi GetHashCode() per l'uso all'interno dei dizionarii. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | CopyTo | Copia un range di elementi in un array. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | CreateDeleteCommand | Crea, inizializza e restituisce il comando per l'eliminazione di un elemento. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | CreateInsertCommand | Crea, inizializza e restituisce il comando per l'inserimento di un elemento. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | CreateUpdateCommand | Crea, inizializza e restituisce il comando per l'aggiornamento di un elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | CustomSort | Ordina la lista in base al comparatore passato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteDeleteItem | Esegue l'eliminazione di un elemento. Crea il comando tramite il metodo CreateDeleteCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteInsertItem | Esegue l'inserimento di un elemento. Crea il comando tramite il metodo CreateInsertCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteUpdateItem | Esegue l'aggiornamento di un elemento. Crea il comando tramite il metodo CreateUpdateCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Find | Restituisce l'oggetto cercato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FindAll | Restitusice la lista degli elementi che corrispondono al predicato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | GetDbIndex | Restituisce l'indice dell'elemento passato, da utilizzare nelle clausole where di aggiornamento/eliminazione. (Sovrascrive DedDbCollectionBaseTGetDbIndex(T))
Metodo pubblico | GetEnumerator | Restituisce l'enumeratore della collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | IndexOf | Restituisce l'indice dell'elemento richiesto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InsertUnModified | DI USO INTERNO. Inserisce un elemento alla lista senza rendere dirty l'oggetto, all'indice specificato. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Item | Restituisce l'elemento iesimo della lista. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Load | Ripulisce la lista corrente e rilegge i dati.
Metodo pubblico | LoadItems | Metodo astratto da implementare che ritorna l'elenco degli elementi da aggiungere alla lista corrente.
Metodo pubblico | Move(Int32, Boolean) | Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean, Int32) | Sposta l'elemento dell'indice passato prima o dopo del numero di posizioni passate. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSave | Metodo Template chiamato dopo il salvataggio avvenuto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSaveNoChanges | Metodo Template chiamato dopo il salvataggio senza modifiche. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnBeforeSave | Metodo Template chiamato prima del salvataggio. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(T) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(DedEditableObjectT) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(T) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(DedEditableObjectT) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ReInitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Remove | Elimina un elemento dalla collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Ripristina | Verifica che l'elemento sia presente negli eliminati e lo toglie da lì e lo riaggiunge in coda alla lista degli elementi validi. Solleva una eccezione se l'elemento è già presente nella lista e AllowsDuplicates = false. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Save | Salva l'oggetto con tutta la sua lista, solo se questo risulta dirty. (Ereditato da DedDbCollectionBaseT)
Torna su
Vedi anche

Documentazione

Classe DedEditableObjectCollectionT
Namespace DedNet.Core


Metodo DedEditableObjectCollection<T>.GetDbIndex

Metodo DedEditableObjectCollectionTGetDbIndex
Restituisce l'indice dell'elemento passato, da utilizzare nelle clausole where di aggiornamento/eliminazione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override Object GetDbIndex(
    T item
)
Protected Overrides Function GetDbIndex (
    item As T
) As Object
protected:
virtual Object^ GetDbIndex(
    T item
) override
abstract GetDbIndex :
        item : 'T -> Object
override GetDbIndex :
        item : 'T -> Object

Parametri

item T
Elemento del quale restituire l'indice.

Valore di ritorno

Object
Restituisce l'indice dell'elemento oppure null.
Vedi anche

Documentazione

Classe DedEditableObjectCollectionT
Namespace DedNet.Core


Metodo DedEditableObjectCollection<T>.Load

Metodo DedEditableObjectCollectionTLoad
Ripulisce la lista corrente e rilegge i dati.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Load()
Public Sub Load
public:
void Load()
member Load : unit -> unit
Vedi anche

Documentazione

Classe DedEditableObjectCollectionT
Namespace DedNet.Core


Metodo DedEditableObjectCollection<T>.LoadItems

Metodo DedEditableObjectCollectionTLoadItems
Metodo astratto da implementare che ritorna l'elenco degli elementi da aggiungere alla lista corrente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public abstract List<T> LoadItems()
Public MustOverride Function LoadItems As List(Of T)
public:
virtual List<T>^ LoadItems() abstract
abstract LoadItems : unit -> List<'T>

Valore di ritorno

List T
Vedi anche

Documentazione

Classe DedEditableObjectCollectionT
Namespace DedNet.Core


Classe DedEncodeInfo
Contiene le informazioni necessarie alla codifica. Questa struttura viene utilizzata dall'oggetto DedRuleParser e da varie funzioni per comporre una stringa di codifica.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedEncodeInfo

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedEncodeInfo
Public Class DedEncodeInfo
public ref class DedEncodeInfo
type DedEncodeInfo = class end

Il tipo DedEncodeInfo espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedEncodeInfo |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Data | Restituisce o imposta l'anagrafica da utilizzare per la codifica.
Proprietà pubblica | Fam | Restituisce o imposta la famiglia da utilizzare per la codifica.
Proprietà pubblica | Format | Restituisce o imposta il formato da utilizzare per la codifica.
Proprietà pubblica | Progr | Restituisce o imposta il progressivo da utilizzare per la codifica.
Proprietà pubblica | Rev | Restituisce o imposta la revisione da utilizzare per la codifica.
Proprietà pubblica | TokenInfoList | Lista con tutti i token.
Proprietà pubblica | User | Restituisce o imposta il tassello utente da utilizzare per la decodifica.
Proprietà pubblica | Var | Restituisce o imposta il tassello variante da utilizzare per la decodifica.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | FillByTokenInfoList | Compila i campi di questo oggetto leggendo le informazioni passate.
Metodo pubblico | InitProgrByType | Inizializza il progressivo con la famiglia presente nell'oggetto (se presente).
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedEncodeInfo

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEncodeInfo()
Public Sub New
public:
DedEncodeInfo()
new : unit -> DedEncodeInfo
Vedi anche

Documentazione

Classe DedEncodeInfo
Namespace DedNet.Core


Proprietà di DedEncodeInfo

Il tipo DedEncodeInfo espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Data | Restituisce o imposta l'anagrafica da utilizzare per la codifica.
Proprietà pubblica | Fam | Restituisce o imposta la famiglia da utilizzare per la codifica.
Proprietà pubblica | Format | Restituisce o imposta il formato da utilizzare per la codifica.
Proprietà pubblica | Progr | Restituisce o imposta il progressivo da utilizzare per la codifica.
Proprietà pubblica | Rev | Restituisce o imposta la revisione da utilizzare per la codifica.
Proprietà pubblica | TokenInfoList | Lista con tutti i token.
Proprietà pubblica | User | Restituisce o imposta il tassello utente da utilizzare per la decodifica.
Proprietà pubblica | Var | Restituisce o imposta il tassello variante da utilizzare per la decodifica.
Torna su
Vedi anche

Documentazione

Classe DedEncodeInfo
Namespace DedNet.Core


Proprietà DedEncodeInfo.Data

Proprietà DedEncodeInfoData
Restituisce o imposta l'anagrafica da utilizzare per la codifica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public IDedTypeEditable Data { get; set; }
Public Property Data As IDedTypeEditable
    Get
    Set
public:
property IDedTypeEditable^ Data {
    IDedTypeEditable^ get ();
    void set (IDedTypeEditable^ value);
}
member Data : IDedTypeEditable with get, set

Valore della proprietà

IDedTypeEditable
Vedi anche

Documentazione

Classe DedEncodeInfo
Namespace DedNet.Core


Proprietà DedEncodeInfo.Fam

Proprietà DedEncodeInfoFam
Restituisce o imposta la famiglia da utilizzare per la codifica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeBase Fam { get; set; }
Public Property Fam As DedTypeBase
    Get
    Set
public:
property DedTypeBase^ Fam {
    DedTypeBase^ get ();
    void set (DedTypeBase^ value);
}
member Fam : DedTypeBase with get, set

Valore della proprietà

DedTypeBase
Vedi anche

Documentazione

Classe DedEncodeInfo
Namespace DedNet.Core


Proprietà DedEncodeInfo.Format

Proprietà DedEncodeInfoFormat
Restituisce o imposta il formato da utilizzare per la codifica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set
public:
property String^ Format {
    String^ get ();
    void set (String^ value);
}
member Format : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedEncodeInfo
Namespace DedNet.Core


Proprietà DedEncodeInfo.Progr

Proprietà DedEncodeInfoProgr
Restituisce o imposta il progressivo da utilizzare per la codifica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Progr { get; set; }
Public Property Progr As String
    Get
    Set
public:
property String^ Progr {
    String^ get ();
    void set (String^ value);
}
member Progr : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedEncodeInfo
Namespace DedNet.Core


Proprietà DedEncodeInfo.Rev

Proprietà DedEncodeInfoRev
Restituisce o imposta la revisione da utilizzare per la codifica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Rev { get; set; }
Public Property Rev As String
    Get
    Set
public:
property String^ Rev {
    String^ get ();
    void set (String^ value);
}
member Rev : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedEncodeInfo
Namespace DedNet.Core


Proprietà DedEncodeInfo.TokenInfoList

Proprietà DedEncodeInfoTokenInfoList
Lista con tutti i token.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public TokenInfoList TokenInfoList { get; }
Public ReadOnly Property TokenInfoList As TokenInfoList
    Get
public:
property TokenInfoList^ TokenInfoList {
    TokenInfoList^ get ();
}
member TokenInfoList : TokenInfoList with get

Valore della proprietà

TokenInfoList
Vedi anche

Documentazione

Classe DedEncodeInfo
Namespace DedNet.Core


Proprietà DedEncodeInfo.User

Proprietà DedEncodeInfoUser
Restituisce o imposta il tassello utente da utilizzare per la decodifica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string User { get; set; }
Public Property User As String
    Get
    Set
public:
property String^ User {
    String^ get ();
    void set (String^ value);
}
member User : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedEncodeInfo
Namespace DedNet.Core


Proprietà DedEncodeInfo.Var

Proprietà DedEncodeInfoVar
Restituisce o imposta il tassello variante da utilizzare per la decodifica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Var { get; set; }
Public Property Var As String
    Get
    Set
public:
property String^ Var {
    String^ get ();
    void set (String^ value);
}
member Var : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedEncodeInfo
Namespace DedNet.Core


Metodi di DedEncodeInfo

Il tipo DedEncodeInfo espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | FillByTokenInfoList | Compila i campi di questo oggetto leggendo le informazioni passate.
Metodo pubblico | InitProgrByType | Inizializza il progressivo con la famiglia presente nell'oggetto (se presente).
Torna su
Vedi anche

Documentazione

Classe DedEncodeInfo
Namespace DedNet.Core


Metodo DedEncodeInfo.FillByTokenInfoList

Metodo DedEncodeInfoFillByTokenInfoList
Compila i campi di questo oggetto leggendo le informazioni passate.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void FillByTokenInfoList(
    TokenInfoList tokenInfo
)
Public Sub FillByTokenInfoList (
    tokenInfo As TokenInfoList
)
public:
void FillByTokenInfoList(
    TokenInfoList^ tokenInfo
)
member FillByTokenInfoList :
        tokenInfo : TokenInfoList -> unit

Parametri

tokenInfo TokenInfoList
Info da utilizzare per compilare i campi.
Vedi anche

Documentazione

Classe DedEncodeInfo
Namespace DedNet.Core


Metodo DedEncodeInfo.InitProgrByType

Metodo DedEncodeInfoInitProgrByType
Inizializza il progressivo con la famiglia presente nell'oggetto (se presente).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void InitProgrByType()
Public Sub InitProgrByType
public:
void InitProgrByType()
member InitProgrByType : unit -> unit
Vedi anche

Documentazione

Classe DedEncodeInfo
Namespace DedNet.Core


Classe DedFamPerm
Contiene il set di permessi relativi ad una sola famiglia ed abbinato ad un unico utente/gruppo.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedPermOwner
DedNet.CoreDedFamPerm

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFamPerm : DedPermOwner, IDedDbItem
Public Class DedFamPerm
    Inherits DedPermOwner
    Implements IDedDbItem
public ref class DedFamPerm : public DedPermOwner,
    IDedDbItem
type DedFamPerm =
    class
        inherit DedPermOwner
        interface IDedDbItem
    end

Il tipo DedFamPerm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione di appartenenza. (Ereditato da DedPermOwner)
Proprietà pubblica | DbPath | Restituisce il dbpath della famiglia di appartenenza.
Proprietà pubblica | Dirty | Restituisce true se è dirty la lista dei permessi appartenenti a questo oggetto altrimenti restituisce false.
Proprietà pubblica | IsGroup | Restituisce se il DedPermOwner è un gruppo. (Sovrascrive DedPermOwnerIsGroup)
Proprietà pubblica | IsUser | Restituisce se il DedPermOwner è un utente. (Sovrascrive DedPermOwnerIsUser)
Proprietà pubblica | Manager | Restituisce il Gestore dei permessi. (Ereditato da DedPermOwner)
Proprietà pubblica | Name | Restitusice il nome dell'owner. (Sovrascrive DedPermOwnerName)
Proprietà pubblica | Owner | Restituisce l'utente o il gruppo di appartenenza.
Proprietà pubblica | PermItems | Restitusice il set di permessi di questo possessore. (Ereditato da DedPermOwner)
Proprietà pubblica | StatoRecord | Di uso interno.
Proprietà protetta | TableName | Restituisce il nome della table del Database. (Ereditato da DedPermOwner)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | CreateDeleteCommand | (Sovrascrive DedPermOwnerCreateDeleteCommand(DedPerm))
Metodo protetto | CreateInsertCommand | (Sovrascrive DedPermOwnerCreateInsertCommand(DedPerm))
Metodo protetto | CreateUpdateCommand | (Sovrascrive DedPermOwnerCreateUpdateCommand(DedPerm))
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo protetto | GetDbIndex | (Sovrascrive DedPermOwnerGetDbIndex(DedPerm))
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | GetPerm | Restituisce il permesso impostando la stringa descrittiva il tipo di ereditarietà del permesso.
Metodo pubblico | GetPermDescription | Restituisce la descrizione del permesso. (Ereditato da DedPermOwner)
Metodo pubblico | GetPermVal(String, String) | Restituisce il valore del permesso. (Sovrascrive DedPermOwnerGetPermVal(String, String))
Metodo pubblico | GetPermVal(String, String, String) | Restituisce il valore del permesso impostando la stringa descrittiva il tipo di ereditarietà del permesso. (Sovrascrive DedPermOwnerGetPermVal(String, String, String))
Metodo pubblico | IsPermPresent | Restituisce se il permesso è presente in modo esplicito fra i permessi di questa instanza. (Ereditato da DedPermOwner)
Metodo pubblico | Save | Salva il set di permessi.
Metodo pubblico | SetPermVal | Imposta il permesso ottenendo la stringa descrittiva del permesso. (Sovrascrive DedPermOwnerSetPermVal(String, String, Boolean))
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di DedFamPerm

Il tipo DedFamPerm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione di appartenenza. (Ereditato da DedPermOwner)
Proprietà pubblica | DbPath | Restituisce il dbpath della famiglia di appartenenza.
Proprietà pubblica | Dirty | Restituisce true se è dirty la lista dei permessi appartenenti a questo oggetto altrimenti restituisce false.
Proprietà pubblica | IsGroup | Restituisce se il DedPermOwner è un gruppo. (Sovrascrive DedPermOwnerIsGroup)
Proprietà pubblica | IsUser | Restituisce se il DedPermOwner è un utente. (Sovrascrive DedPermOwnerIsUser)
Proprietà pubblica | Manager | Restituisce il Gestore dei permessi. (Ereditato da DedPermOwner)
Proprietà pubblica | Name | Restitusice il nome dell'owner. (Sovrascrive DedPermOwnerName)
Proprietà pubblica | Owner | Restituisce l'utente o il gruppo di appartenenza.
Proprietà pubblica | PermItems | Restitusice il set di permessi di questo possessore. (Ereditato da DedPermOwner)
Proprietà pubblica | StatoRecord | Di uso interno.
Proprietà protetta | TableName | Restituisce il nome della table del Database. (Ereditato da DedPermOwner)
Torna su
Vedi anche

Documentazione

Classe DedFamPerm
Namespace DedNet.Core


Proprietà DedFamPerm.DbPath

Proprietà DedFamPermDbPath
Restituisce il dbpath della famiglia di appartenenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string DbPath { get; set; }
Public Property DbPath As String
    Get
    Set
public:
property String^ DbPath {
    String^ get ();
    void set (String^ value);
}
member DbPath : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedFamPerm
Namespace DedNet.Core


Proprietà DedFamPerm.Dirty

Proprietà DedFamPermDirty
Restituisce true se è dirty la lista dei permessi appartenenti a questo oggetto altrimenti restituisce false.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Dirty { get; }
Public ReadOnly Property Dirty As Boolean
    Get
public:
property bool Dirty {
    bool get ();
}
member Dirty : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFamPerm
Namespace DedNet.Core


Proprietà DedFamPerm.IsGroup

Proprietà DedFamPermIsGroup
Restituisce se il DedPermOwner è un gruppo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool IsGroup { get; }
Public Overrides ReadOnly Property IsGroup As Boolean
    Get
public:
virtual property bool IsGroup {
    bool get () override;
}
abstract IsGroup : bool with get
override IsGroup : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFamPerm
Namespace DedNet.Core


Proprietà DedFamPerm.IsUser

Proprietà DedFamPermIsUser
Restituisce se il DedPermOwner è un utente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool IsUser { get; }
Public Overrides ReadOnly Property IsUser As Boolean
    Get
public:
virtual property bool IsUser {
    bool get () override;
}
abstract IsUser : bool with get
override IsUser : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFamPerm
Namespace DedNet.Core


Proprietà DedFamPerm.Name

Proprietà DedFamPermName
Restitusice il nome dell'owner.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string Name { get; }
Public Overrides ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () override;
}
abstract Name : string with get
override Name : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedFamPerm
Namespace DedNet.Core


Proprietà DedFamPerm.Owner

Proprietà DedFamPermOwner
Restituisce l'utente o il gruppo di appartenenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedPermOwner Owner { get; }
Public ReadOnly Property Owner As DedPermOwner
    Get
public:
property DedPermOwner^ Owner {
    DedPermOwner^ get ();
}
member Owner : DedPermOwner with get

Valore della proprietà

DedPermOwner
Vedi anche

Documentazione

Classe DedFamPerm
Namespace DedNet.Core


Proprietà DedFamPerm.StatoRecord

Proprietà DedFamPermStatoRecord
Di uso interno.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public StatoRecord StatoRecord { get; set; }
Public Property StatoRecord As StatoRecord
    Get
    Set
public:
virtual property StatoRecord^ StatoRecord {
    StatoRecord^ get () sealed;
    void set (StatoRecord^ value) sealed;
}
abstract StatoRecord : StatoRecord with get, set
override StatoRecord : StatoRecord with get, set

Valore della proprietà

StatoRecord

Implementa

IDedDbItemStatoRecord
Vedi anche

Documentazione

Classe DedFamPerm
Namespace DedNet.Core


Metodi di DedFamPerm

Il tipo DedFamPerm espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | CreateDeleteCommand | (Sovrascrive DedPermOwnerCreateDeleteCommand(DedPerm))
Metodo protetto | CreateInsertCommand | (Sovrascrive DedPermOwnerCreateInsertCommand(DedPerm))
Metodo protetto | CreateUpdateCommand | (Sovrascrive DedPermOwnerCreateUpdateCommand(DedPerm))
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo protetto | GetDbIndex | (Sovrascrive DedPermOwnerGetDbIndex(DedPerm))
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | GetPerm | Restituisce il permesso impostando la stringa descrittiva il tipo di ereditarietà del permesso.
Metodo pubblico | GetPermDescription | Restituisce la descrizione del permesso. (Ereditato da DedPermOwner)
Metodo pubblico | GetPermVal(String, String) | Restituisce il valore del permesso. (Sovrascrive DedPermOwnerGetPermVal(String, String))
Metodo pubblico | GetPermVal(String, String, String) | Restituisce il valore del permesso impostando la stringa descrittiva il tipo di ereditarietà del permesso. (Sovrascrive DedPermOwnerGetPermVal(String, String, String))
Metodo pubblico | IsPermPresent | Restituisce se il permesso è presente in modo esplicito fra i permessi di questa instanza. (Ereditato da DedPermOwner)
Metodo pubblico | Save | Salva il set di permessi.
Metodo pubblico | SetPermVal | Imposta il permesso ottenendo la stringa descrittiva del permesso. (Sovrascrive DedPermOwnerSetPermVal(String, String, Boolean))
Torna su
Vedi anche

Documentazione

Classe DedFamPerm
Namespace DedNet.Core


Metodo DedFamPerm.CreateDeleteCommand

Metodo DedFamPermCreateDeleteCommand

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal override QSDeleteCommand CreateDeleteCommand(
    DedPerm item
)
Protected Friend Overrides Function CreateDeleteCommand (
    item As DedPerm
) As QSDeleteCommand
protected public:
virtual QSDeleteCommand^ CreateDeleteCommand(
    DedPerm^ item
) override
abstract CreateDeleteCommand :
        item : DedPerm -> QSDeleteCommand
override CreateDeleteCommand :
        item : DedPerm -> QSDeleteCommand

Parametri

item DedPerm

Valore di ritorno

QSDeleteCommand
Vedi anche

Documentazione

Classe DedFamPerm
Namespace DedNet.Core


Metodo DedFamPerm.CreateInsertCommand

Metodo DedFamPermCreateInsertCommand

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal override QSInsertCommand CreateInsertCommand(
    DedPerm item
)
Protected Friend Overrides Function CreateInsertCommand (
    item As DedPerm
) As QSInsertCommand
protected public:
virtual QSInsertCommand^ CreateInsertCommand(
    DedPerm^ item
) override
abstract CreateInsertCommand :
        item : DedPerm -> QSInsertCommand
override CreateInsertCommand :
        item : DedPerm -> QSInsertCommand

Parametri

item DedPerm

Valore di ritorno

QSInsertCommand
Vedi anche

Documentazione

Classe DedFamPerm
Namespace DedNet.Core


Metodo DedFamPerm.CreateUpdateCommand

Metodo DedFamPermCreateUpdateCommand

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal override QSUpdateCommand CreateUpdateCommand(
    DedPerm item
)
Protected Friend Overrides Function CreateUpdateCommand (
    item As DedPerm
) As QSUpdateCommand
protected public:
virtual QSUpdateCommand^ CreateUpdateCommand(
    DedPerm^ item
) override
abstract CreateUpdateCommand :
        item : DedPerm -> QSUpdateCommand
override CreateUpdateCommand :
        item : DedPerm -> QSUpdateCommand

Parametri

item DedPerm

Valore di ritorno

QSUpdateCommand
Vedi anche

Documentazione

Classe DedFamPerm
Namespace DedNet.Core


Metodo DedFamPerm.Equals

Metodo DedFamPermEquals

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj Object

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedFamPerm
Namespace DedNet.Core


Metodo DedFamPerm.GetDbIndex

Metodo DedFamPermGetDbIndex

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal override Object GetDbIndex(
    DedPerm item
)
Protected Friend Overrides Function GetDbIndex (
    item As DedPerm
) As Object
protected public:
virtual Object^ GetDbIndex(
    DedPerm^ item
) override
abstract GetDbIndex :
        item : DedPerm -> Object
override GetDbIndex :
        item : DedPerm -> Object

Parametri

item DedPerm

Valore di ritorno

Object
Vedi anche

Documentazione

Classe DedFamPerm
Namespace DedNet.Core


Metodo DedFamPerm.GetHashCode

Metodo DedFamPermGetHashCode

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedFamPerm
Namespace DedNet.Core


Metodo DedFamPerm.GetPerm

Metodo DedFamPermGetPerm
Restituisce il permesso impostando la stringa descrittiva il tipo di ereditarietà del permesso.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedPerm GetPerm(
    string PermName,
    string discrim,
    out string PermDesc
)
Public Function GetPerm (
    PermName As String,
    discrim As String,
    <OutAttribute> ByRef PermDesc As String
) As DedPerm
public:
DedPerm^ GetPerm(
    String^ PermName,
    String^ discrim,
    [OutAttribute] String^% PermDesc
)
member GetPerm :
        PermName : string *
        discrim : string *
        PermDesc : string byref -> DedPerm

Parametri

PermName String
discrim String
PermDesc String

Valore di ritorno

DedPerm
Vedi anche

Documentazione

Classe DedFamPerm
Namespace DedNet.Core


Metodo DedFamPerm.GetPermVal

Metodo DedFamPermGetPermVal
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | GetPermVal(String, String) | Restituisce il valore del permesso.
Metodo pubblico | GetPermVal(String, String, String) | Restituisce il valore del permesso impostando la stringa descrittiva il tipo di ereditarietà del permesso.
Torna su
Vedi anche

Documentazione

Classe DedFamPerm
Namespace DedNet.Core


Metodo DedFamPerm.GetPermVal(String, String)

Metodo DedFamPermGetPermVal(String, String)
Restituisce il valore del permesso.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool GetPermVal(
    string PermName,
    string discrim
)
Public Overrides Function GetPermVal (
    PermName As String,
    discrim As String
) As Boolean
public:
virtual bool GetPermVal(
    String^ PermName,
    String^ discrim
) override
abstract GetPermVal :
        PermName : string *
        discrim : string -> bool
override GetPermVal :
        PermName : string *
        discrim : string -> bool

Parametri

PermName String
discrim String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedFamPerm
Overload di GetPermVal
Namespace DedNet.Core


Metodo DedFamPerm.GetPermVal(String, String, String)

Metodo DedFamPermGetPermVal(String, String, String)
Restituisce il valore del permesso impostando la stringa descrittiva il tipo di ereditarietà del permesso.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool GetPermVal(
    string PermName,
    string discrim,
    out string PermDesc
)
Public Overrides Function GetPermVal (
    PermName As String,
    discrim As String,
    <OutAttribute> ByRef PermDesc As String
) As Boolean
public:
virtual bool GetPermVal(
    String^ PermName,
    String^ discrim,
    [OutAttribute] String^% PermDesc
) override
abstract GetPermVal :
        PermName : string *
        discrim : string *
        PermDesc : string byref -> bool
override GetPermVal :
        PermName : string *
        discrim : string *
        PermDesc : string byref -> bool

Parametri

PermName String
discrim String
PermDesc String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedFamPerm
Overload di GetPermVal
Namespace DedNet.Core


Metodo DedFamPerm.Save

Metodo DedFamPermSave
Salva il set di permessi.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Save()
Public Sub Save
public:
void Save()
member Save : unit -> unit
Vedi anche

Documentazione

Classe DedFamPerm
Namespace DedNet.Core


Metodo DedFamPerm.SetPermVal

Metodo DedFamPermSetPermVal
Imposta il permesso ottenendo la stringa descrittiva del permesso.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string SetPermVal(
    string PermName,
    string discrim,
    bool Valore
)
Public Overrides Function SetPermVal (
    PermName As String,
    discrim As String,
    Valore As Boolean
) As String
public:
virtual String^ SetPermVal(
    String^ PermName,
    String^ discrim,
    bool Valore
) override
abstract SetPermVal :
        PermName : string *
        discrim : string *
        Valore : bool -> string
override SetPermVal :
        PermName : string *
        discrim : string *
        Valore : bool -> string

Parametri

PermName String
discrim String
Valore Boolean

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedFamPerm
Namespace DedNet.Core


Classe DedFamPermList
Collezione di oggetti DedFamPerm.
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList DedFamPerm
DedNet.CoreDedFamPermList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFamPermList : List<DedFamPerm>
Public Class DedFamPermList
    Inherits List(Of DedFamPerm)
public ref class DedFamPermList : public List<DedFamPerm^>
type DedFamPermList =
    class
        inherit List<DedFamPerm>
    end

Il tipo DedFamPermList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFamPermList |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedFamPermList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFamPermList()
Public Sub New
public:
DedFamPermList()
new : unit -> DedFamPermList
Vedi anche

Documentazione

Classe DedFamPermList
Namespace DedNet.Core


Classe DedFileSystemHelper
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedFileSystemHelper

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFileSystemHelper
Public Class DedFileSystemHelper
public ref class DedFileSystemHelper
type DedFileSystemHelper = class end

Il tipo DedFileSystemHelper espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFileSystemHelper |
Torna su
Metodi
Nome | Descrizione
GetFileEntry |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedFileSystemHelper

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFileSystemHelper()
Public Sub New
public:
DedFileSystemHelper()
new : unit -> DedFileSystemHelper
Vedi anche

Documentazione

Classe DedFileSystemHelper
Namespace DedNet.Core


Metodi di DedFileSystemHelper

Il tipo DedFileSystemHelper espone i seguenti membri.

Metodi
Nome | Descrizione
GetFileEntry |
Torna su
Vedi anche

Documentazione

Classe DedFileSystemHelper
Namespace DedNet.Core


Metodo DedFileSystemHelper.GetFileEntry

Metodo DedFileSystemHelperGetFileEntry

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static FileEntry GetFileEntry(
    string path,
    IconSizeType sizeType,
    Size itemSize
)
Public Shared Function GetFileEntry (
    path As String,
    sizeType As IconSizeType,
    itemSize As Size
) As FileEntry
public:
static FileEntry^ GetFileEntry(
    String^ path,
    IconSizeType^ sizeType,
    Size itemSize
)
static member GetFileEntry :
        path : string *
        sizeType : IconSizeType *
        itemSize : Size -> FileEntry

Parametri

path String
sizeType IconSizeType
itemSize Size

Valore di ritorno

FileEntry
Vedi anche

Documentazione

Classe DedFileSystemHelper
Namespace DedNet.Core


Classe DedFolderPerm
Contiene il set di permessi relativi ad una sola cartella ed abbinato ad un unico utente/gruppo.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedPermOwner
DedNet.CoreDedFolderPerm

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFolderPerm : DedPermOwner,
    IDedDbItem
Public Class DedFolderPerm
    Inherits DedPermOwner
    Implements IDedDbItem
public ref class DedFolderPerm : public DedPermOwner,
    IDedDbItem
type DedFolderPerm =
    class
        inherit DedPermOwner
        interface IDedDbItem
    end

Il tipo DedFolderPerm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione di appartenenza. (Ereditato da DedPermOwner)
Proprietà pubblica | Dirty | Restituisce true se è dirty la lista dei permessi appartenenti a questo oggetto altrimenti restituisce false.
Proprietà pubblica | Folder | Restituisce percorso della cartella di appartenenza.
Proprietà pubblica | IsGroup | Restituisce se il DedPermOwner è un gruppo. (Sovrascrive DedPermOwnerIsGroup)
Proprietà pubblica | IsUser | Restituisce se il DedPermOwner è un utente. (Sovrascrive DedPermOwnerIsUser)
Proprietà pubblica | Manager | Restituisce il Gestore dei permessi. (Ereditato da DedPermOwner)
Proprietà pubblica | Name | Restitusice il nome dell'owner. (Sovrascrive DedPermOwnerName)
Proprietà pubblica | Owner | Restituisce l'utente o il gruppo di appartenenza.
Proprietà pubblica | PermItems | Restitusice il set di permessi di questo possessore. (Ereditato da DedPermOwner)
Proprietà pubblica | StatoRecord | Di uso interno.
Proprietà protetta | TableName | Restituisce il nome della table del Database. (Ereditato da DedPermOwner)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AddPerm | Aggiunge un permesso e se c'è già lo modifica. NOTA : Utilizzato solo per aggiornare i permessi delle FOLDER in caso di modifica permessi FAMIGLIE/COMMESSE
Metodo protetto | CreateDeleteCommand | (Sovrascrive DedPermOwnerCreateDeleteCommand(DedPerm))
Metodo protetto | CreateInsertCommand | (Sovrascrive DedPermOwnerCreateInsertCommand(DedPerm))
Metodo protetto | CreateUpdateCommand | (Sovrascrive DedPermOwnerCreateUpdateCommand(DedPerm))
Metodo pubblico | DeletePerm | Cancella un permesso. NOTA : Utilizzato solo per aggiornare i permessi delle FOLDER in caso di modifica permessi FAMIGLIE/COMMESSE
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo protetto | GetDbIndex | (Sovrascrive DedPermOwnerGetDbIndex(DedPerm))
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | GetPerm | Restituisce il valore del permesso impostando la stringa descrittiva il tipo di ereditarietà del permesso.
Metodo pubblico | GetPermDescription | Restituisce la descrizione del permesso. (Ereditato da DedPermOwner)
Metodo pubblico | GetPermVal(String, String) | Restituisce il valore del permesso. (Sovrascrive DedPermOwnerGetPermVal(String, String))
Metodo pubblico | GetPermVal(String, String, String) | Restituisce il valore del permesso impostando la stringa descrittiva il tipo di ereditarietà del permesso. (Sovrascrive DedPermOwnerGetPermVal(String, String, String))
Metodo pubblico | IsPermPresent | Restituisce se il permesso è presente in modo esplicito fra i permessi di questa instanza. (Ereditato da DedPermOwner)
Metodo pubblico | Save | Salva il set di permessi.
Metodo pubblico | SetPermVal | Imposta il permesso ottenendo la stringa descrittiva del permesso. (Sovrascrive DedPermOwnerSetPermVal(String, String, Boolean))
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di DedFolderPerm

Il tipo DedFolderPerm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione di appartenenza. (Ereditato da DedPermOwner)
Proprietà pubblica | Dirty | Restituisce true se è dirty la lista dei permessi appartenenti a questo oggetto altrimenti restituisce false.
Proprietà pubblica | Folder | Restituisce percorso della cartella di appartenenza.
Proprietà pubblica | IsGroup | Restituisce se il DedPermOwner è un gruppo. (Sovrascrive DedPermOwnerIsGroup)
Proprietà pubblica | IsUser | Restituisce se il DedPermOwner è un utente. (Sovrascrive DedPermOwnerIsUser)
Proprietà pubblica | Manager | Restituisce il Gestore dei permessi. (Ereditato da DedPermOwner)
Proprietà pubblica | Name | Restitusice il nome dell'owner. (Sovrascrive DedPermOwnerName)
Proprietà pubblica | Owner | Restituisce l'utente o il gruppo di appartenenza.
Proprietà pubblica | PermItems | Restitusice il set di permessi di questo possessore. (Ereditato da DedPermOwner)
Proprietà pubblica | StatoRecord | Di uso interno.
Proprietà protetta | TableName | Restituisce il nome della table del Database. (Ereditato da DedPermOwner)
Torna su
Vedi anche

Documentazione

Classe DedFolderPerm
Namespace DedNet.Core


Proprietà DedFolderPerm.Dirty

Proprietà DedFolderPermDirty
Restituisce true se è dirty la lista dei permessi appartenenti a questo oggetto altrimenti restituisce false.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Dirty { get; }
Public ReadOnly Property Dirty As Boolean
    Get
public:
property bool Dirty {
    bool get ();
}
member Dirty : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFolderPerm
Namespace DedNet.Core


Proprietà DedFolderPerm.Folder

Proprietà DedFolderPermFolder
Restituisce percorso della cartella di appartenenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Folder { get; set; }
Public Property Folder As String
    Get
    Set
public:
property String^ Folder {
    String^ get ();
    void set (String^ value);
}
member Folder : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedFolderPerm
Namespace DedNet.Core


Proprietà DedFolderPerm.IsGroup

Proprietà DedFolderPermIsGroup
Restituisce se il DedPermOwner è un gruppo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool IsGroup { get; }
Public Overrides ReadOnly Property IsGroup As Boolean
    Get
public:
virtual property bool IsGroup {
    bool get () override;
}
abstract IsGroup : bool with get
override IsGroup : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFolderPerm
Namespace DedNet.Core


Proprietà DedFolderPerm.IsUser

Proprietà DedFolderPermIsUser
Restituisce se il DedPermOwner è un utente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool IsUser { get; }
Public Overrides ReadOnly Property IsUser As Boolean
    Get
public:
virtual property bool IsUser {
    bool get () override;
}
abstract IsUser : bool with get
override IsUser : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFolderPerm
Namespace DedNet.Core


Proprietà DedFolderPerm.Name

Proprietà DedFolderPermName
Restitusice il nome dell'owner.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string Name { get; }
Public Overrides ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () override;
}
abstract Name : string with get
override Name : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedFolderPerm
Namespace DedNet.Core


Proprietà DedFolderPerm.Owner

Proprietà DedFolderPermOwner
Restituisce l'utente o il gruppo di appartenenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedPermOwner Owner { get; }
Public ReadOnly Property Owner As DedPermOwner
    Get
public:
property DedPermOwner^ Owner {
    DedPermOwner^ get ();
}
member Owner : DedPermOwner with get

Valore della proprietà

DedPermOwner
Vedi anche

Documentazione

Classe DedFolderPerm
Namespace DedNet.Core


Proprietà DedFolderPerm.StatoRecord

Proprietà DedFolderPermStatoRecord
Di uso interno.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public StatoRecord StatoRecord { get; set; }
Public Property StatoRecord As StatoRecord
    Get
    Set
public:
virtual property StatoRecord^ StatoRecord {
    StatoRecord^ get () sealed;
    void set (StatoRecord^ value) sealed;
}
abstract StatoRecord : StatoRecord with get, set
override StatoRecord : StatoRecord with get, set

Valore della proprietà

StatoRecord

Implementa

IDedDbItemStatoRecord
Vedi anche

Documentazione

Classe DedFolderPerm
Namespace DedNet.Core


Metodi di DedFolderPerm

Il tipo DedFolderPerm espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AddPerm | Aggiunge un permesso e se c'è già lo modifica. NOTA : Utilizzato solo per aggiornare i permessi delle FOLDER in caso di modifica permessi FAMIGLIE/COMMESSE
Metodo protetto | CreateDeleteCommand | (Sovrascrive DedPermOwnerCreateDeleteCommand(DedPerm))
Metodo protetto | CreateInsertCommand | (Sovrascrive DedPermOwnerCreateInsertCommand(DedPerm))
Metodo protetto | CreateUpdateCommand | (Sovrascrive DedPermOwnerCreateUpdateCommand(DedPerm))
Metodo pubblico | DeletePerm | Cancella un permesso. NOTA : Utilizzato solo per aggiornare i permessi delle FOLDER in caso di modifica permessi FAMIGLIE/COMMESSE
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo protetto | GetDbIndex | (Sovrascrive DedPermOwnerGetDbIndex(DedPerm))
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | GetPerm | Restituisce il valore del permesso impostando la stringa descrittiva il tipo di ereditarietà del permesso.
Metodo pubblico | GetPermDescription | Restituisce la descrizione del permesso. (Ereditato da DedPermOwner)
Metodo pubblico | GetPermVal(String, String) | Restituisce il valore del permesso. (Sovrascrive DedPermOwnerGetPermVal(String, String))
Metodo pubblico | GetPermVal(String, String, String) | Restituisce il valore del permesso impostando la stringa descrittiva il tipo di ereditarietà del permesso. (Sovrascrive DedPermOwnerGetPermVal(String, String, String))
Metodo pubblico | IsPermPresent | Restituisce se il permesso è presente in modo esplicito fra i permessi di questa instanza. (Ereditato da DedPermOwner)
Metodo pubblico | Save | Salva il set di permessi.
Metodo pubblico | SetPermVal | Imposta il permesso ottenendo la stringa descrittiva del permesso. (Sovrascrive DedPermOwnerSetPermVal(String, String, Boolean))
Torna su
Vedi anche

Documentazione

Classe DedFolderPerm
Namespace DedNet.Core


Metodo DedFolderPerm.AddPerm

Metodo DedFolderPermAddPerm
Aggiunge un permesso e se c'è già lo modifica. NOTA : Utilizzato solo per aggiornare i permessi delle FOLDER in caso di modifica permessi FAMIGLIE/COMMESSE

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddPerm(
    string PermName,
    string discrim,
    bool Valore
)
Public Sub AddPerm (
    PermName As String,
    discrim As String,
    Valore As Boolean
)
public:
void AddPerm(
    String^ PermName,
    String^ discrim,
    bool Valore
)
member AddPerm :
        PermName : string *
        discrim : string *
        Valore : bool -> unit

Parametri

PermName String
discrim String
Valore Boolean
Vedi anche

Documentazione

Classe DedFolderPerm
Namespace DedNet.Core


Metodo DedFolderPerm.CreateDeleteCommand

Metodo DedFolderPermCreateDeleteCommand

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal override QSDeleteCommand CreateDeleteCommand(
    DedPerm item
)
Protected Friend Overrides Function CreateDeleteCommand (
    item As DedPerm
) As QSDeleteCommand
protected public:
virtual QSDeleteCommand^ CreateDeleteCommand(
    DedPerm^ item
) override
abstract CreateDeleteCommand :
        item : DedPerm -> QSDeleteCommand
override CreateDeleteCommand :
        item : DedPerm -> QSDeleteCommand

Parametri

item DedPerm

Valore di ritorno

QSDeleteCommand
Vedi anche

Documentazione

Classe DedFolderPerm
Namespace DedNet.Core


Metodo DedFolderPerm.CreateInsertCommand

Metodo DedFolderPermCreateInsertCommand

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal override QSInsertCommand CreateInsertCommand(
    DedPerm item
)
Protected Friend Overrides Function CreateInsertCommand (
    item As DedPerm
) As QSInsertCommand
protected public:
virtual QSInsertCommand^ CreateInsertCommand(
    DedPerm^ item
) override
abstract CreateInsertCommand :
        item : DedPerm -> QSInsertCommand
override CreateInsertCommand :
        item : DedPerm -> QSInsertCommand

Parametri

item DedPerm

Valore di ritorno

QSInsertCommand
Vedi anche

Documentazione

Classe DedFolderPerm
Namespace DedNet.Core


Metodo DedFolderPerm.CreateUpdateCommand

Metodo DedFolderPermCreateUpdateCommand

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal override QSUpdateCommand CreateUpdateCommand(
    DedPerm item
)
Protected Friend Overrides Function CreateUpdateCommand (
    item As DedPerm
) As QSUpdateCommand
protected public:
virtual QSUpdateCommand^ CreateUpdateCommand(
    DedPerm^ item
) override
abstract CreateUpdateCommand :
        item : DedPerm -> QSUpdateCommand
override CreateUpdateCommand :
        item : DedPerm -> QSUpdateCommand

Parametri

item DedPerm

Valore di ritorno

QSUpdateCommand
Vedi anche

Documentazione

Classe DedFolderPerm
Namespace DedNet.Core


Metodo DedFolderPerm.DeletePerm

Metodo DedFolderPermDeletePerm
Cancella un permesso. NOTA : Utilizzato solo per aggiornare i permessi delle FOLDER in caso di modifica permessi FAMIGLIE/COMMESSE

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void DeletePerm(
    string PermName,
    string discrim
)
Public Sub DeletePerm (
    PermName As String,
    discrim As String
)
public:
void DeletePerm(
    String^ PermName,
    String^ discrim
)
member DeletePerm :
        PermName : string *
        discrim : string -> unit

Parametri

PermName String
discrim String
Vedi anche

Documentazione

Classe DedFolderPerm
Namespace DedNet.Core


Metodo DedFolderPerm.Equals

Metodo DedFolderPermEquals

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj Object

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedFolderPerm
Namespace DedNet.Core


Metodo DedFolderPerm.GetDbIndex

Metodo DedFolderPermGetDbIndex

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal override Object GetDbIndex(
    DedPerm item
)
Protected Friend Overrides Function GetDbIndex (
    item As DedPerm
) As Object
protected public:
virtual Object^ GetDbIndex(
    DedPerm^ item
) override
abstract GetDbIndex :
        item : DedPerm -> Object
override GetDbIndex :
        item : DedPerm -> Object

Parametri

item DedPerm

Valore di ritorno

Object
Vedi anche

Documentazione

Classe DedFolderPerm
Namespace DedNet.Core


Metodo DedFolderPerm.GetHashCode

Metodo DedFolderPermGetHashCode

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedFolderPerm
Namespace DedNet.Core


Metodo DedFolderPerm.GetPerm

Metodo DedFolderPermGetPerm
Restituisce il valore del permesso impostando la stringa descrittiva il tipo di ereditarietà del permesso.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedPerm GetPerm(
    string PermName,
    string discrim,
    out string PermDesc
)
Public Function GetPerm (
    PermName As String,
    discrim As String,
    <OutAttribute> ByRef PermDesc As String
) As DedPerm
public:
DedPerm^ GetPerm(
    String^ PermName,
    String^ discrim,
    [OutAttribute] String^% PermDesc
)
member GetPerm :
        PermName : string *
        discrim : string *
        PermDesc : string byref -> DedPerm

Parametri

PermName String
discrim String
PermDesc String

Valore di ritorno

DedPerm
Vedi anche

Documentazione

Classe DedFolderPerm
Namespace DedNet.Core


Metodo DedFolderPerm.GetPermVal

Metodo DedFolderPermGetPermVal
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | GetPermVal(String, String) | Restituisce il valore del permesso.
Metodo pubblico | GetPermVal(String, String, String) | Restituisce il valore del permesso impostando la stringa descrittiva il tipo di ereditarietà del permesso.
Torna su
Vedi anche

Documentazione

Classe DedFolderPerm
Namespace DedNet.Core


Metodo DedFolderPerm.GetPermVal(String, String)

Metodo DedFolderPermGetPermVal(String, String)
Restituisce il valore del permesso.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool GetPermVal(
    string PermName,
    string discrim
)
Public Overrides Function GetPermVal (
    PermName As String,
    discrim As String
) As Boolean
public:
virtual bool GetPermVal(
    String^ PermName,
    String^ discrim
) override
abstract GetPermVal :
        PermName : string *
        discrim : string -> bool
override GetPermVal :
        PermName : string *
        discrim : string -> bool

Parametri

PermName String
discrim String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedFolderPerm
Overload di GetPermVal
Namespace DedNet.Core


Metodo DedFolderPerm.GetPermVal(String, String, String)

Metodo DedFolderPermGetPermVal(String, String, String)
Restituisce il valore del permesso impostando la stringa descrittiva il tipo di ereditarietà del permesso.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool GetPermVal(
    string PermName,
    string discrim,
    out string PermDesc
)
Public Overrides Function GetPermVal (
    PermName As String,
    discrim As String,
    <OutAttribute> ByRef PermDesc As String
) As Boolean
public:
virtual bool GetPermVal(
    String^ PermName,
    String^ discrim,
    [OutAttribute] String^% PermDesc
) override
abstract GetPermVal :
        PermName : string *
        discrim : string *
        PermDesc : string byref -> bool
override GetPermVal :
        PermName : string *
        discrim : string *
        PermDesc : string byref -> bool

Parametri

PermName String
discrim String
PermDesc String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedFolderPerm
Overload di GetPermVal
Namespace DedNet.Core


Metodo DedFolderPerm.Save

Metodo DedFolderPermSave
Salva il set di permessi.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Save()
Public Sub Save
public:
void Save()
member Save : unit -> unit
Vedi anche

Documentazione

Classe DedFolderPerm
Namespace DedNet.Core


Metodo DedFolderPerm.SetPermVal

Metodo DedFolderPermSetPermVal
Imposta il permesso ottenendo la stringa descrittiva del permesso.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string SetPermVal(
    string PermName,
    string discrim,
    bool Valore
)
Public Overrides Function SetPermVal (
    PermName As String,
    discrim As String,
    Valore As Boolean
) As String
public:
virtual String^ SetPermVal(
    String^ PermName,
    String^ discrim,
    bool Valore
) override
abstract SetPermVal :
        PermName : string *
        discrim : string *
        Valore : bool -> string
override SetPermVal :
        PermName : string *
        discrim : string *
        Valore : bool -> string

Parametri

PermName String
discrim String
Valore Boolean

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedFolderPerm
Namespace DedNet.Core


Classe DedFolderPermList
Collezione di oggetti DedFolderPerm.
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList DedFolderPerm
DedNet.CoreDedFolderPermList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFolderPermList : List<DedFolderPerm>
Public Class DedFolderPermList
    Inherits List(Of DedFolderPerm)
public ref class DedFolderPermList : public List<DedFolderPerm^>
type DedFolderPermList =
    class
        inherit List<DedFolderPerm>
    end

Il tipo DedFolderPermList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFolderPermList |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedFolderPermList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFolderPermList()
Public Sub New
public:
DedFolderPermList()
new : unit -> DedFolderPermList
Vedi anche

Documentazione

Classe DedFolderPermList
Namespace DedNet.Core


Classe DedFontInfo
Classe che descrive le informazioni sul Font utilizzato su un attributo.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedFontInfo

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFontInfo
Public Class DedFontInfo
public ref class DedFontInfo
type DedFontInfo = class end

Il tipo DedFontInfo espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFontInfo(DedAttr) | Costruttore.
Metodo pubblico | DedFontInfo(DedAttr, String, DedFontInfoDedFontStyleEnum, Single, Boolean, Boolean) | Costruttore.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Font | Ritorna un oggetto Font utilizzando le informazioni settate nei campi.
Proprietà pubblica | IsBold | Ritorna True se il testo è in grassetto.
Proprietà pubblica | IsItalic | Ritorna True se il testo è in corsivo.
Proprietà pubblica | Name | Nome del font.
Proprietà pubblica | Parent | Attributo padre.
Proprietà pubblica | Size | Dimensioni del font.
Proprietà pubblica | Strikethrough | Indica se il testo è barrato.
Proprietà pubblica | Style | Stile del font.
Proprietà pubblica | Underline | Indica se il testo è sottolineato.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
 | GetFontInfoFromString | A partire dalla stringa che descrive un font, ritorna un oggetto DedFontInfo inizializzato con i campi impostati.
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
 | GetStringFromFontInfo | Costruisce la stringa che descrive l'oggetto DedFontInfo passato.
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedFontInfo
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | DedFontInfo(DedAttr) | Costruttore.
Metodo pubblico | DedFontInfo(DedAttr, String, DedFontInfoDedFontStyleEnum, Single, Boolean, Boolean) | Costruttore.
Torna su
Vedi anche

Documentazione

Classe DedFontInfo
Namespace DedNet.Core


Costruttore DedFontInfo(DedAttr)
Costruttore.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFontInfo(
    DedAttr parent
)
Public Sub New (
    parent As DedAttr
)
public:
DedFontInfo(
    DedAttr^ parent
)
new :
        parent : DedAttr -> DedFontInfo

Parametri

parent DedAttr
Vedi anche

Documentazione

Classe DedFontInfo
Overload di DedFontInfo
Namespace DedNet.Core


Costruttore DedFontInfo(DedAttr, String, DedFontInfo.DedFontStyleEnum, Single, Boolean, Boolean)

Costruttore DedFontInfo(DedAttr, String, DedFontInfoDedFontStyleEnum, Single, Boolean, Boolean)
Costruttore.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFontInfo(
    DedAttr parent,
    string name,
    DedFontInfoDedFontStyleEnum style,
    float size,
    bool strikethrough,
    bool underline
)
Public Sub New (
    parent As DedAttr,
    name As String,
    style As DedFontInfoDedFontStyleEnum,
    size As Single,
    strikethrough As Boolean,
    underline As Boolean
)
public:
DedFontInfo(
    DedAttr^ parent,
    String^ name,
    DedFontInfoDedFontStyleEnum style,
    float size,
    bool strikethrough,
    bool underline
)
new :
        parent : DedAttr *
        name : string *
        style : DedFontInfoDedFontStyleEnum *
        size : float32 *
        strikethrough : bool *
        underline : bool -> DedFontInfo

Parametri

parent DedAttr
name String
style DedFontInfoDedFontStyleEnum
size Single
strikethrough Boolean
underline Boolean
Vedi anche

Documentazione

Classe DedFontInfo
Overload di DedFontInfo
Namespace DedNet.Core


Proprietà di DedFontInfo

Il tipo DedFontInfo espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Font | Ritorna un oggetto Font utilizzando le informazioni settate nei campi.
Proprietà pubblica | IsBold | Ritorna True se il testo è in grassetto.
Proprietà pubblica | IsItalic | Ritorna True se il testo è in corsivo.
Proprietà pubblica | Name | Nome del font.
Proprietà pubblica | Parent | Attributo padre.
Proprietà pubblica | Size | Dimensioni del font.
Proprietà pubblica | Strikethrough | Indica se il testo è barrato.
Proprietà pubblica | Style | Stile del font.
Proprietà pubblica | Underline | Indica se il testo è sottolineato.
Torna su
Vedi anche

Documentazione

Classe DedFontInfo
Namespace DedNet.Core


Proprietà DedFontInfo.Font

Proprietà DedFontInfoFont
Ritorna un oggetto Font utilizzando le informazioni settate nei campi.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Font Font { get; }
Public ReadOnly Property Font As Font
    Get
public:
property Font^ Font {
    Font^ get ();
}
member Font : Font with get

Valore della proprietà

Font
Vedi anche

Documentazione

Classe DedFontInfo
Namespace DedNet.Core


Proprietà DedFontInfo.IsBold

Proprietà DedFontInfoIsBold
Ritorna True se il testo è in grassetto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsBold { get; }
Public ReadOnly Property IsBold As Boolean
    Get
public:
property bool IsBold {
    bool get ();
}
member IsBold : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFontInfo
Namespace DedNet.Core


Proprietà DedFontInfo.IsItalic

Proprietà DedFontInfoIsItalic
Ritorna True se il testo è in corsivo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsItalic { get; }
Public ReadOnly Property IsItalic As Boolean
    Get
public:
property bool IsItalic {
    bool get ();
}
member IsItalic : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFontInfo
Namespace DedNet.Core


Proprietà DedFontInfo.Name

Proprietà DedFontInfoName
Nome del font.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedFontInfo
Namespace DedNet.Core


Proprietà DedFontInfo.Parent

Proprietà DedFontInfoParent
Attributo padre.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttr Parent { get; set; }
Public Property Parent As DedAttr
    Get
    Set
public:
property DedAttr^ Parent {
    DedAttr^ get ();
    void set (DedAttr^ value);
}
member Parent : DedAttr with get, set

Valore della proprietà

DedAttr
Vedi anche

Documentazione

Classe DedFontInfo
Namespace DedNet.Core


Proprietà DedFontInfo.Size

Proprietà DedFontInfoSize
Dimensioni del font.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public float Size { get; set; }
Public Property Size As Single
    Get
    Set
public:
property float Size {
    float get ();
    void set (float value);
}
member Size : float32 with get, set

Valore della proprietà

Single
Vedi anche

Documentazione

Classe DedFontInfo
Namespace DedNet.Core


Proprietà DedFontInfo.Strikethrough

Proprietà DedFontInfoStrikethrough
Indica se il testo è barrato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Strikethrough { get; set; }
Public Property Strikethrough As Boolean
    Get
    Set
public:
property bool Strikethrough {
    bool get ();
    void set (bool value);
}
member Strikethrough : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFontInfo
Namespace DedNet.Core


Proprietà DedFontInfo.Style

Proprietà DedFontInfoStyle
Stile del font.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFontInfoDedFontStyleEnum Style { get; set; }
Public Property Style As DedFontInfoDedFontStyleEnum
    Get
    Set
public:
property DedFontInfoDedFontStyleEnum Style {
    DedFontInfoDedFontStyleEnum get ();
    void set (DedFontInfoDedFontStyleEnum value);
}
member Style : DedFontInfoDedFontStyleEnum with get, set

Valore della proprietà

DedFontInfoDedFontStyleEnum
Vedi anche

Documentazione

Classe DedFontInfo
Namespace DedNet.Core


Proprietà DedFontInfo.Underline

Proprietà DedFontInfoUnderline
Indica se il testo è sottolineato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Underline { get; set; }
Public Property Underline As Boolean
    Get
    Set
public:
property bool Underline {
    bool get ();
    void set (bool value);
}
member Underline : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFontInfo
Namespace DedNet.Core


Metodi di DedFontInfo

Il tipo DedFontInfo espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
 | GetFontInfoFromString | A partire dalla stringa che descrive un font, ritorna un oggetto DedFontInfo inizializzato con i campi impostati.
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
 | GetStringFromFontInfo | Costruisce la stringa che descrive l'oggetto DedFontInfo passato.
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Torna su
Vedi anche

Documentazione

Classe DedFontInfo
Namespace DedNet.Core


Metodo DedFontInfo.Equals

Metodo DedFontInfoEquals

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj Object

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedFontInfo
Namespace DedNet.Core


Metodo DedFontInfo.GetFontInfoFromString

Metodo DedFontInfoGetFontInfoFromString
A partire dalla stringa che descrive un font, ritorna un oggetto DedFontInfo inizializzato con i campi impostati.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static DedFontInfo GetFontInfoFromString(
    string fontInfoStr
)
Public Shared Function GetFontInfoFromString (
    fontInfoStr As String
) As DedFontInfo
public:
static DedFontInfo^ GetFontInfoFromString(
    String^ fontInfoStr
)
static member GetFontInfoFromString :
        fontInfoStr : string -> DedFontInfo

Parametri

fontInfoStr String
Stringa di analisi.

Valore di ritorno

DedFontInfo
Vedi anche

Documentazione

Classe DedFontInfo
Namespace DedNet.Core


Metodo DedFontInfo.GetHashCode

Metodo DedFontInfoGetHashCode

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedFontInfo
Namespace DedNet.Core


Metodo DedFontInfo.GetStringFromFontInfo

Metodo DedFontInfoGetStringFromFontInfo
Costruisce la stringa che descrive l'oggetto DedFontInfo passato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string GetStringFromFontInfo(
    DedFontInfo fontInfo
)
Public Shared Function GetStringFromFontInfo (
    fontInfo As DedFontInfo
) As String
public:
static String^ GetStringFromFontInfo(
    DedFontInfo^ fontInfo
)
static member GetStringFromFontInfo :
        fontInfo : DedFontInfo -> string

Parametri

fontInfo DedFontInfo
Oggetto DedFontInfo.

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedFontInfo
Namespace DedNet.Core


Metodo DedFontInfo.ToString

Metodo DedFontInfoToString

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedFontInfo
Namespace DedNet.Core


Enumerazione DedFontInfo.DedFontStyleEnum

Enumerazione DedFontInfoDedFontStyleEnum
Enum che descrive i possibili stili di font.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum DedFontStyleEnum
Public Enumeration DedFontStyleEnum
public enum class DedFontStyleEnum
type DedFontStyleEnum
Membri
Nome | Valore | Descrizione
Regular | 0 | Stile normale.
Italic | 1 | Stile corsivo.
Bold | 2 | Stile grassetto.
BoldItalic | 4 | Stile grassetto corsivo.
Vedi anche

Documentazione

Namespace DedNet.Core


Classe DedGroup
Racchiude tutte le informazioni di un utente.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedPermOwner
DedNet.CoreDedGroup

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedGroup : DedPermOwner, IDedDbItem
Public Class DedGroup
    Inherits DedPermOwner
    Implements IDedDbItem
public ref class DedGroup : public DedPermOwner,
    IDedDbItem
type DedGroup =
    class
        inherit DedPermOwner
        interface IDedDbItem
    end

Il tipo DedGroup espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione di appartenenza. (Ereditato da DedPermOwner)
Proprietà pubblica | Descr | Restituisce o imposta la descrizione dell'utente.
Proprietà pubblica | Dirty | Restituisce se il gruppo sia stato modificato nei suoi permessi oppure negli utenti contenuti.
Proprietà pubblica | Email | Restituisce o imposta l'email del gruppo-
Proprietà pubblica | IsGroup | Restituisce se si tratti di un gruppo (sempre false tranne nel caso di un gruppo). (Ereditato da DedPermOwner)
Proprietà pubblica | IsUser | Restituisce se si tratti di un utente (sempre false tranne nel caso di un utente). (Ereditato da DedPermOwner)
Proprietà pubblica | Manager | Restituisce il Gestore dei permessi. (Ereditato da DedPermOwner)
Proprietà pubblica | Name | Restituisce o imposta il nome dell'utente. (Sovrascrive DedPermOwnerName)
Proprietà pubblica | PermItems | Restitusice il set di permessi di questo possessore. (Ereditato da DedPermOwner)
Proprietà pubblica | StatoRecord | Di uso interno.
Proprietà protetta | TableName | Restituisce il nome della table del Database. (Ereditato da DedPermOwner)
Proprietà pubblica | Users | Restituisce la collezione degli utenti appartenenti a questo gruppo.
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | CreateDeleteCommand | (Sovrascrive DedPermOwnerCreateDeleteCommand(DedPerm))
Metodo protetto | CreateInsertCommand | (Sovrascrive DedPermOwnerCreateInsertCommand(DedPerm))
Metodo protetto | CreateUpdateCommand | (Sovrascrive DedPermOwnerCreateUpdateCommand(DedPerm))
Metodo protetto | GetDbIndex | (Sovrascrive DedPermOwnerGetDbIndex(DedPerm))
Metodo pubblico | GetPermDescription | Restituisce la descrizione del permesso. (Ereditato da DedPermOwner)
Metodo pubblico | GetPermVal(String, String) | Restituisce il valore del permesso. (Sovrascrive DedPermOwnerGetPermVal(String, String))
Metodo pubblico | GetPermVal(String, String, String) | Restituisce il valore del permesso impostando la stringa descrittiva il tipo di ereditarietà del permesso. (Sovrascrive DedPermOwnerGetPermVal(String, String, String))
Metodo pubblico | IsPermPresent | Restituisce se il permesso è presente in modo esplicito fra i permessi di questa instanza. (Ereditato da DedPermOwner)
Metodo pubblico | SetPermVal(String, Boolean, String) | Imposta il permesso ottenendo la stringa descrittiva del permesso.
Metodo pubblico | SetPermVal(String, String, Boolean) | Imposta il permesso ottenendo la stringa descrittiva del permesso. (Sovrascrive DedPermOwnerSetPermVal(String, String, Boolean))
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di DedGroup

Il tipo DedGroup espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione di appartenenza. (Ereditato da DedPermOwner)
Proprietà pubblica | Descr | Restituisce o imposta la descrizione dell'utente.
Proprietà pubblica | Dirty | Restituisce se il gruppo sia stato modificato nei suoi permessi oppure negli utenti contenuti.
Proprietà pubblica | Email | Restituisce o imposta l'email del gruppo-
Proprietà pubblica | IsGroup | Restituisce se si tratti di un gruppo (sempre false tranne nel caso di un gruppo). (Ereditato da DedPermOwner)
Proprietà pubblica | IsUser | Restituisce se si tratti di un utente (sempre false tranne nel caso di un utente). (Ereditato da DedPermOwner)
Proprietà pubblica | Manager | Restituisce il Gestore dei permessi. (Ereditato da DedPermOwner)
Proprietà pubblica | Name | Restituisce o imposta il nome dell'utente. (Sovrascrive DedPermOwnerName)
Proprietà pubblica | PermItems | Restitusice il set di permessi di questo possessore. (Ereditato da DedPermOwner)
Proprietà pubblica | StatoRecord | Di uso interno.
Proprietà protetta | TableName | Restituisce il nome della table del Database. (Ereditato da DedPermOwner)
Proprietà pubblica | Users | Restituisce la collezione degli utenti appartenenti a questo gruppo.
Torna su
Vedi anche

Documentazione

Classe DedGroup
Namespace DedNet.Core


Proprietà DedGroup.Descr

Proprietà DedGroupDescr
Restituisce o imposta la descrizione dell'utente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Descr { get; set; }
Public Property Descr As String
    Get
    Set
public:
property String^ Descr {
    String^ get ();
    void set (String^ value);
}
member Descr : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedGroup
Namespace DedNet.Core


Proprietà DedGroup.Dirty

Proprietà DedGroupDirty
Restituisce se il gruppo sia stato modificato nei suoi permessi oppure negli utenti contenuti.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Dirty { get; }
Public ReadOnly Property Dirty As Boolean
    Get
public:
property bool Dirty {
    bool get ();
}
member Dirty : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedGroup
Namespace DedNet.Core


Proprietà DedGroup.Email

Proprietà DedGroupEmail
Restituisce o imposta l'email del gruppo-

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Email { get; set; }
Public Property Email As String
    Get
    Set
public:
property String^ Email {
    String^ get ();
    void set (String^ value);
}
member Email : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedGroup
Namespace DedNet.Core


Proprietà DedGroup.Name

Proprietà DedGroupName
Restituisce o imposta il nome dell'utente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string Name { get; set; }
Public Overrides Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get () override;
    void set (String^ value) override;
}
abstract Name : string with get, set
override Name : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedGroup
Namespace DedNet.Core


Proprietà DedGroup.StatoRecord

Proprietà DedGroupStatoRecord
Di uso interno.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public StatoRecord StatoRecord { get; set; }
Public Property StatoRecord As StatoRecord
    Get
    Set
public:
virtual property StatoRecord^ StatoRecord {
    StatoRecord^ get () sealed;
    void set (StatoRecord^ value) sealed;
}
abstract StatoRecord : StatoRecord with get, set
override StatoRecord : StatoRecord with get, set

Valore della proprietà

StatoRecord

Implementa

IDedDbItemStatoRecord
Vedi anche

Documentazione

Classe DedGroup
Namespace DedNet.Core


Proprietà DedGroup.Users

Proprietà DedGroupUsers
Restituisce la collezione degli utenti appartenenti a questo gruppo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedUsersGroups Users { get; }
Public ReadOnly Property Users As DedUsersGroups
    Get
public:
property DedUsersGroups^ Users {
    DedUsersGroups^ get ();
}
member Users : DedUsersGroups with get

Valore della proprietà

DedUsersGroups
Vedi anche

Documentazione

Classe DedGroup
Namespace DedNet.Core


Metodi di DedGroup

Il tipo DedGroup espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | CreateDeleteCommand | (Sovrascrive DedPermOwnerCreateDeleteCommand(DedPerm))
Metodo protetto | CreateInsertCommand | (Sovrascrive DedPermOwnerCreateInsertCommand(DedPerm))
Metodo protetto | CreateUpdateCommand | (Sovrascrive DedPermOwnerCreateUpdateCommand(DedPerm))
Metodo protetto | GetDbIndex | (Sovrascrive DedPermOwnerGetDbIndex(DedPerm))
Metodo pubblico | GetPermDescription | Restituisce la descrizione del permesso. (Ereditato da DedPermOwner)
Metodo pubblico | GetPermVal(String, String) | Restituisce il valore del permesso. (Sovrascrive DedPermOwnerGetPermVal(String, String))
Metodo pubblico | GetPermVal(String, String, String) | Restituisce il valore del permesso impostando la stringa descrittiva il tipo di ereditarietà del permesso. (Sovrascrive DedPermOwnerGetPermVal(String, String, String))
Metodo pubblico | IsPermPresent | Restituisce se il permesso è presente in modo esplicito fra i permessi di questa instanza. (Ereditato da DedPermOwner)
Metodo pubblico | SetPermVal(String, Boolean, String) | Imposta il permesso ottenendo la stringa descrittiva del permesso.
Metodo pubblico | SetPermVal(String, String, Boolean) | Imposta il permesso ottenendo la stringa descrittiva del permesso. (Sovrascrive DedPermOwnerSetPermVal(String, String, Boolean))
Torna su
Vedi anche

Documentazione

Classe DedGroup
Namespace DedNet.Core


Metodo DedGroup.CreateDeleteCommand

Metodo DedGroupCreateDeleteCommand

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal override QSDeleteCommand CreateDeleteCommand(
    DedPerm item
)
Protected Friend Overrides Function CreateDeleteCommand (
    item As DedPerm
) As QSDeleteCommand
protected public:
virtual QSDeleteCommand^ CreateDeleteCommand(
    DedPerm^ item
) override
abstract CreateDeleteCommand :
        item : DedPerm -> QSDeleteCommand
override CreateDeleteCommand :
        item : DedPerm -> QSDeleteCommand

Parametri

item DedPerm

Valore di ritorno

QSDeleteCommand
Vedi anche

Documentazione

Classe DedGroup
Namespace DedNet.Core


Metodo DedGroup.CreateInsertCommand

Metodo DedGroupCreateInsertCommand

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal override QSInsertCommand CreateInsertCommand(
    DedPerm item
)
Protected Friend Overrides Function CreateInsertCommand (
    item As DedPerm
) As QSInsertCommand
protected public:
virtual QSInsertCommand^ CreateInsertCommand(
    DedPerm^ item
) override
abstract CreateInsertCommand :
        item : DedPerm -> QSInsertCommand
override CreateInsertCommand :
        item : DedPerm -> QSInsertCommand

Parametri

item DedPerm

Valore di ritorno

QSInsertCommand
Vedi anche

Documentazione

Classe DedGroup
Namespace DedNet.Core


Metodo DedGroup.CreateUpdateCommand

Metodo DedGroupCreateUpdateCommand

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal override QSUpdateCommand CreateUpdateCommand(
    DedPerm item
)
Protected Friend Overrides Function CreateUpdateCommand (
    item As DedPerm
) As QSUpdateCommand
protected public:
virtual QSUpdateCommand^ CreateUpdateCommand(
    DedPerm^ item
) override
abstract CreateUpdateCommand :
        item : DedPerm -> QSUpdateCommand
override CreateUpdateCommand :
        item : DedPerm -> QSUpdateCommand

Parametri

item DedPerm

Valore di ritorno

QSUpdateCommand
Vedi anche

Documentazione

Classe DedGroup
Namespace DedNet.Core


Metodo DedGroup.GetDbIndex

Metodo DedGroupGetDbIndex

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal override Object GetDbIndex(
    DedPerm item
)
Protected Friend Overrides Function GetDbIndex (
    item As DedPerm
) As Object
protected public:
virtual Object^ GetDbIndex(
    DedPerm^ item
) override
abstract GetDbIndex :
        item : DedPerm -> Object
override GetDbIndex :
        item : DedPerm -> Object

Parametri

item DedPerm

Valore di ritorno

Object
Vedi anche

Documentazione

Classe DedGroup
Namespace DedNet.Core


Metodo DedGroup.GetPermVal

Metodo DedGroupGetPermVal
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | GetPermVal(String, String) | Restituisce il valore del permesso.
Metodo pubblico | GetPermVal(String, String, String) | Restituisce il valore del permesso impostando la stringa descrittiva il tipo di ereditarietà del permesso.
Torna su
Vedi anche

Documentazione

Classe DedGroup
Namespace DedNet.Core


Metodo DedGroup.GetPermVal(String, String)

Metodo DedGroupGetPermVal(String, String)
Restituisce il valore del permesso.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool GetPermVal(
    string permName,
    string discrim
)
Public Overrides Function GetPermVal (
    permName As String,
    discrim As String
) As Boolean
public:
virtual bool GetPermVal(
    String^ permName,
    String^ discrim
) override
abstract GetPermVal :
        permName : string *
        discrim : string -> bool
override GetPermVal :
        permName : string *
        discrim : string -> bool

Parametri

permName String
discrim String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedGroup
Overload di GetPermVal
Namespace DedNet.Core


Metodo DedGroup.GetPermVal(String, String, String)

Metodo DedGroupGetPermVal(String, String, String)
Restituisce il valore del permesso impostando la stringa descrittiva il tipo di ereditarietà del permesso.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool GetPermVal(
    string PermName,
    string discrim,
    out string PermDesc
)
Public Overrides Function GetPermVal (
    PermName As String,
    discrim As String,
    <OutAttribute> ByRef PermDesc As String
) As Boolean
public:
virtual bool GetPermVal(
    String^ PermName,
    String^ discrim,
    [OutAttribute] String^% PermDesc
) override
abstract GetPermVal :
        PermName : string *
        discrim : string *
        PermDesc : string byref -> bool
override GetPermVal :
        PermName : string *
        discrim : string *
        PermDesc : string byref -> bool

Parametri

PermName String
discrim String
PermDesc String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedGroup
Overload di GetPermVal
Namespace DedNet.Core


Metodo DedGroup.SetPermVal

Metodo DedGroupSetPermVal
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | SetPermVal(String, Boolean, String) | Imposta il permesso ottenendo la stringa descrittiva del permesso.
Metodo pubblico | SetPermVal(String, String, Boolean) | Imposta il permesso ottenendo la stringa descrittiva del permesso.
Torna su
Vedi anche

Documentazione

Classe DedGroup
Namespace DedNet.Core


Metodo DedGroup.SetPermVal(String, Boolean, String)

Metodo DedGroupSetPermVal(String, Boolean, String)
Imposta il permesso ottenendo la stringa descrittiva del permesso.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string SetPermVal(
    string PermName,
    bool Valore,
    string discrim
)
Public Function SetPermVal (
    PermName As String,
    Valore As Boolean,
    discrim As String
) As String
public:
String^ SetPermVal(
    String^ PermName,
    bool Valore,
    String^ discrim
)
member SetPermVal :
        PermName : string *
        Valore : bool *
        discrim : string -> string

Parametri

PermName String
Valore Boolean
discrim String

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedGroup
Overload di SetPermVal
Namespace DedNet.Core


Metodo DedGroup.SetPermVal(String, String, Boolean)

Metodo DedGroupSetPermVal(String, String, Boolean)
Imposta il permesso ottenendo la stringa descrittiva del permesso.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string SetPermVal(
    string PermName,
    string discrim,
    bool Valore
)
Public Overrides Function SetPermVal (
    PermName As String,
    discrim As String,
    Valore As Boolean
) As String
public:
virtual String^ SetPermVal(
    String^ PermName,
    String^ discrim,
    bool Valore
) override
abstract SetPermVal :
        PermName : string *
        discrim : string *
        Valore : bool -> string
override SetPermVal :
        PermName : string *
        discrim : string *
        Valore : bool -> string

Parametri

PermName String
discrim String
Valore Boolean

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedGroup
Overload di SetPermVal
Namespace DedNet.Core


Classe DedGroupCollection
Collezione di oggetti DedGroup.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedDbCollectionBase DedGroup
DedNet.CoreDedGroupCollection

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedGroupCollection : DedDbCollectionBase<DedGroup>
Public Class DedGroupCollection
    Inherits DedDbCollectionBase(Of DedGroup)
public ref class DedGroupCollection : public DedDbCollectionBase<DedGroup^>
type DedGroupCollection =
    class
        inherit DedDbCollectionBase<DedGroup>
    end

Il tipo DedGroupCollection espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllowsDuplicates | Restituisce se siano ammessi duplicati all'interno della lista. Se false viene sollevata una eccezione su tentativo di inserimento duplicati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Application | Restituisce l'oggetto applicazione di appartenza. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Count | Restituisce il numero di elementi presenti. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Dirty | Restituisce se la collezione o uno dei suoi elementi sia stata modificata. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | ErasedItems | Restitusice la lista in sola lettura degli elementi che risultano attualmente cancellati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | GroupNames |
Proprietà pubblica | LastItem | Restituisce l'ultimo elemento della collezione oppure null se non ci sono elementi. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | RestoreErased | Restituisce se gli elementi cancellati devono essere ripristinati in caso vengano riaggiunti. (Ereditato da DedDbCollectionBaseT)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Add | Aggiunge un elemento accodandolo alla lista.
Metodo protetto | AddForClone | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto SENZA MODIFICARNE LO STATO. Le classi derivate potranno utilizzare questo metodo per clonare la collezione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddNewElement | DI USO INTERNO. Aggiunge un elemento alla lista rendendo dirty l'oggetto. L'elemento viene aggiunto con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere un elemento alla lista. Dovranno loro stesse avere un metodo pubblico Add() che prenda i parametri necessari alla costruzione dell'oggetto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddRangeNewElement | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi rendendo dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere più elementi alla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddUnModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Clear | Elimina tutti gli elementi dalla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ClearRefresh | Svuota la lista impostando Dirty = false. Di fatto permette di effettuare un refresh della lista e quindi di ricaricarla. Serve per svuotare la lista e reinizializzarla da capo. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Contains | Verifica l'esistenza di un valore all'interno della lista degli elementi. Le classi derivate devono effettuarne l'override nel caso in cui l'elemento non implementi GetHashCode() per l'uso all'interno dei dizionarii. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | CopyTo | Copia un range di elementi in un array. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | CreateDeleteCommand | (Sovrascrive DedDbCollectionBaseTCreateDeleteCommand(T))
Metodo protetto | CreateInsertCommand | (Sovrascrive DedDbCollectionBaseTCreateInsertCommand(T))
Metodo protetto | CreateUpdateCommand | (Sovrascrive DedDbCollectionBaseTCreateUpdateCommand(T))
Metodo pubblico | CustomSort | Ordina la lista in base al comparatore passato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteDeleteItem | Esegue l'eliminazione di un elemento. Crea il comando tramite il metodo CreateDeleteCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteInsertItem | Esegue l'inserimento di un elemento. Crea il comando tramite il metodo CreateInsertCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteUpdateItem | Esegue l'aggiornamento di un elemento. Crea il comando tramite il metodo CreateUpdateCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Find | Restituisce l'oggetto cercato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FindAll | Restitusice la lista degli elementi che corrispondono al predicato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FindByName | Restituisce il gruppo tramite il nome. Restituisce null se il gruppo non è presente.
Metodo protetto | GetDbIndex | (Sovrascrive DedDbCollectionBaseTGetDbIndex(T))
Metodo pubblico | GetEnumerator | Restituisce l'enumeratore della collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | IndexOf | Restituisce l'indice dell'elemento richiesto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InsertUnModified | DI USO INTERNO. Inserisce un elemento alla lista senza rendere dirty l'oggetto, all'indice specificato. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Item | Restituisce l'elemento iesimo della lista. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean) | Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean, Int32) | Sposta l'elemento dell'indice passato prima o dopo del numero di posizioni passate. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSave | (Sovrascrive DedDbCollectionBaseTOnAfterSave(ListT, ListT, ListT))
Metodo protetto | OnAfterSaveNoChanges | Metodo Template chiamato dopo il salvataggio senza modifiche. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnBeforeSave | Metodo Template chiamato prima del salvataggio. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(T) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(DedEditableObjectT) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(T) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(DedEditableObjectT) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ReInitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Remove | Elimina un gruppo dalla collezione. (Sovrascrive DedDbCollectionBaseTRemove(T))
Metodo pubblico | Ripristina | Verifica che l'elemento sia presente negli eliminati e lo toglie da lì e lo riaggiunge in coda alla lista degli elementi validi. Solleva una eccezione se l'elemento è già presente nella lista e AllowsDuplicates = false. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Save | Salva l'oggetto con tutta la sua lista, solo se questo risulta dirty. (Ereditato da DedDbCollectionBaseT)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di DedGroupCollection

Il tipo DedGroupCollection espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllowsDuplicates | Restituisce se siano ammessi duplicati all'interno della lista. Se false viene sollevata una eccezione su tentativo di inserimento duplicati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Application | Restituisce l'oggetto applicazione di appartenza. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Count | Restituisce il numero di elementi presenti. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Dirty | Restituisce se la collezione o uno dei suoi elementi sia stata modificata. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | ErasedItems | Restitusice la lista in sola lettura degli elementi che risultano attualmente cancellati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | GroupNames |
Proprietà pubblica | LastItem | Restituisce l'ultimo elemento della collezione oppure null se non ci sono elementi. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | RestoreErased | Restituisce se gli elementi cancellati devono essere ripristinati in caso vengano riaggiunti. (Ereditato da DedDbCollectionBaseT)
Torna su
Vedi anche

Documentazione

Classe DedGroupCollection
Namespace DedNet.Core


Proprietà DedGroupCollection.GroupNames

Proprietà DedGroupCollectionGroupNames

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> GroupNames { get; }
Public ReadOnly Property GroupNames As List(Of String)
    Get
public:
property List<String^>^ GroupNames {
    List<String^>^ get ();
}
member GroupNames : List<string> with get

Valore della proprietà

List String
Vedi anche

Documentazione

Classe DedGroupCollection
Namespace DedNet.Core


Metodi di DedGroupCollection

Il tipo DedGroupCollection espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Add | Aggiunge un elemento accodandolo alla lista.
Metodo protetto | AddForClone | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto SENZA MODIFICARNE LO STATO. Le classi derivate potranno utilizzare questo metodo per clonare la collezione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddNewElement | DI USO INTERNO. Aggiunge un elemento alla lista rendendo dirty l'oggetto. L'elemento viene aggiunto con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere un elemento alla lista. Dovranno loro stesse avere un metodo pubblico Add() che prenda i parametri necessari alla costruzione dell'oggetto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddRangeNewElement | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi rendendo dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere più elementi alla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddUnModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Clear | Elimina tutti gli elementi dalla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ClearRefresh | Svuota la lista impostando Dirty = false. Di fatto permette di effettuare un refresh della lista e quindi di ricaricarla. Serve per svuotare la lista e reinizializzarla da capo. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Contains | Verifica l'esistenza di un valore all'interno della lista degli elementi. Le classi derivate devono effettuarne l'override nel caso in cui l'elemento non implementi GetHashCode() per l'uso all'interno dei dizionarii. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | CopyTo | Copia un range di elementi in un array. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | CreateDeleteCommand | (Sovrascrive DedDbCollectionBaseTCreateDeleteCommand(T))
Metodo protetto | CreateInsertCommand | (Sovrascrive DedDbCollectionBaseTCreateInsertCommand(T))
Metodo protetto | CreateUpdateCommand | (Sovrascrive DedDbCollectionBaseTCreateUpdateCommand(T))
Metodo pubblico | CustomSort | Ordina la lista in base al comparatore passato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteDeleteItem | Esegue l'eliminazione di un elemento. Crea il comando tramite il metodo CreateDeleteCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteInsertItem | Esegue l'inserimento di un elemento. Crea il comando tramite il metodo CreateInsertCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteUpdateItem | Esegue l'aggiornamento di un elemento. Crea il comando tramite il metodo CreateUpdateCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Find | Restituisce l'oggetto cercato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FindAll | Restitusice la lista degli elementi che corrispondono al predicato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FindByName | Restituisce il gruppo tramite il nome. Restituisce null se il gruppo non è presente.
Metodo protetto | GetDbIndex | (Sovrascrive DedDbCollectionBaseTGetDbIndex(T))
Metodo pubblico | GetEnumerator | Restituisce l'enumeratore della collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | IndexOf | Restituisce l'indice dell'elemento richiesto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InsertUnModified | DI USO INTERNO. Inserisce un elemento alla lista senza rendere dirty l'oggetto, all'indice specificato. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Item | Restituisce l'elemento iesimo della lista. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean) | Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean, Int32) | Sposta l'elemento dell'indice passato prima o dopo del numero di posizioni passate. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSave | (Sovrascrive DedDbCollectionBaseTOnAfterSave(ListT, ListT, ListT))
Metodo protetto | OnAfterSaveNoChanges | Metodo Template chiamato dopo il salvataggio senza modifiche. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnBeforeSave | Metodo Template chiamato prima del salvataggio. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(T) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(DedEditableObjectT) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(T) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(DedEditableObjectT) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ReInitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Remove | Elimina un gruppo dalla collezione. (Sovrascrive DedDbCollectionBaseTRemove(T))
Metodo pubblico | Ripristina | Verifica che l'elemento sia presente negli eliminati e lo toglie da lì e lo riaggiunge in coda alla lista degli elementi validi. Solleva una eccezione se l'elemento è già presente nella lista e AllowsDuplicates = false. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Save | Salva l'oggetto con tutta la sua lista, solo se questo risulta dirty. (Ereditato da DedDbCollectionBaseT)
Torna su
Vedi anche

Documentazione

Classe DedGroupCollection
Namespace DedNet.Core


Metodo DedGroupCollection.Add

Metodo DedGroupCollectionAdd
Aggiunge un elemento accodandolo alla lista.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedGroup Add(
    string name,
    string discrim,
    string descr,
    string email
)
Public Function Add (
    name As String,
    discrim As String,
    descr As String,
    email As String
) As DedGroup
public:
DedGroup^ Add(
    String^ name,
    String^ discrim,
    String^ descr,
    String^ email
)
member Add :
        name : string *
        discrim : string *
        descr : string *
        email : string -> DedGroup

Parametri

name String
Nome del permesso.
discrim String
descr String
Descrizione.
email String

Valore di ritorno

DedGroup
Restituisce l'elemento appena aggiunto.
Vedi anche

Documentazione

Classe DedGroupCollection
Namespace DedNet.Core


Metodo DedGroupCollection.CreateDeleteCommand

Metodo DedGroupCollectionCreateDeleteCommand

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSDeleteCommand CreateDeleteCommand(
    DedGroup item
)
Protected Overrides Function CreateDeleteCommand (
    item As DedGroup
) As QSDeleteCommand
protected:
virtual QSDeleteCommand^ CreateDeleteCommand(
    DedGroup^ item
) override
abstract CreateDeleteCommand :
        item : DedGroup -> QSDeleteCommand
override CreateDeleteCommand :
        item : DedGroup -> QSDeleteCommand

Parametri

item DedGroup

Valore di ritorno

QSDeleteCommand
Vedi anche

Documentazione

Classe DedGroupCollection
Namespace DedNet.Core


Metodo DedGroupCollection.CreateInsertCommand

Metodo DedGroupCollectionCreateInsertCommand

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSInsertCommand CreateInsertCommand(
    DedGroup item
)
Protected Overrides Function CreateInsertCommand (
    item As DedGroup
) As QSInsertCommand
protected:
virtual QSInsertCommand^ CreateInsertCommand(
    DedGroup^ item
) override
abstract CreateInsertCommand :
        item : DedGroup -> QSInsertCommand
override CreateInsertCommand :
        item : DedGroup -> QSInsertCommand

Parametri

item DedGroup

Valore di ritorno

QSInsertCommand
Vedi anche

Documentazione

Classe DedGroupCollection
Namespace DedNet.Core


Metodo DedGroupCollection.CreateUpdateCommand

Metodo DedGroupCollectionCreateUpdateCommand

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSUpdateCommand CreateUpdateCommand(
    DedGroup item
)
Protected Overrides Function CreateUpdateCommand (
    item As DedGroup
) As QSUpdateCommand
protected:
virtual QSUpdateCommand^ CreateUpdateCommand(
    DedGroup^ item
) override
abstract CreateUpdateCommand :
        item : DedGroup -> QSUpdateCommand
override CreateUpdateCommand :
        item : DedGroup -> QSUpdateCommand

Parametri

item DedGroup

Valore di ritorno

QSUpdateCommand
Vedi anche

Documentazione

Classe DedGroupCollection
Namespace DedNet.Core


Metodo DedGroupCollection.FindByName

Metodo DedGroupCollectionFindByName
Restituisce il gruppo tramite il nome. Restituisce null se il gruppo non è presente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedGroup FindByName(
    string name
)
Public Function FindByName (
    name As String
) As DedGroup
public:
DedGroup^ FindByName(
    String^ name
)
member FindByName :
        name : string -> DedGroup

Parametri

name String
Nome del gruppo da cercare.

Valore di ritorno

DedGroup
Vedi anche

Documentazione

Classe DedGroupCollection
Namespace DedNet.Core


Metodo DedGroupCollection.GetDbIndex

Metodo DedGroupCollectionGetDbIndex

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override Object GetDbIndex(
    DedGroup item
)
Protected Overrides Function GetDbIndex (
    item As DedGroup
) As Object
protected:
virtual Object^ GetDbIndex(
    DedGroup^ item
) override
abstract GetDbIndex :
        item : DedGroup -> Object
override GetDbIndex :
        item : DedGroup -> Object

Parametri

item DedGroup

Valore di ritorno

Object
Vedi anche

Documentazione

Classe DedGroupCollection
Namespace DedNet.Core


Metodo DedGroupCollection.OnAfterSave

Metodo DedGroupCollectionOnAfterSave

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void OnAfterSave(
    List<DedGroup> eliminati,
    List<DedGroup> modificati,
    List<DedGroup> aggiunti
)
Protected Overrides Sub OnAfterSave (
    eliminati As List(Of DedGroup),
    modificati As List(Of DedGroup),
    aggiunti As List(Of DedGroup)
)
protected:
virtual void OnAfterSave(
    List<DedGroup^>^ eliminati,
    List<DedGroup^>^ modificati,
    List<DedGroup^>^ aggiunti
) override
abstract OnAfterSave :
        eliminati : List<DedGroup> *
        modificati : List<DedGroup> *
        aggiunti : List<DedGroup> -> unit
override OnAfterSave :
        eliminati : List<DedGroup> *
        modificati : List<DedGroup> *
        aggiunti : List<DedGroup> -> unit

Parametri

eliminati List DedGroup
modificati List DedGroup
aggiunti List DedGroup
Vedi anche

Documentazione

Classe DedGroupCollection
Namespace DedNet.Core


Metodo DedGroupCollection.Remove

Metodo DedGroupCollectionRemove
Elimina un gruppo dalla collezione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void Remove(
    DedGroup item
)
Public Overrides Sub Remove (
    item As DedGroup
)
public:
virtual void Remove(
    DedGroup^ item
) override
abstract Remove :
        item : DedGroup -> unit
override Remove :
        item : DedGroup -> unit

Parametri

item DedGroup
Gruppo da eliminare.
Vedi anche

Documentazione

Classe DedGroupCollection
Namespace DedNet.Core


Classe DedList
Oggetto rappresentante la tipologia di lista
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedList : IDedDbItem
Public Class DedList
    Implements IDedDbItem
public ref class DedList : IDedDbItem
type DedList =
    class
        interface IDedDbItem
    end

Il tipo DedList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedList | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | DiscrimDist | Lista contentente le informazioni extra sulla tipologia. Esempio : QTA=Int;MACCHINA=String;
Proprietà pubblica | ExtraDataInfo | Lista contentente le informazioni extra sulla tipologia. Esempio : QTA=Int;MACCHINA=String;
Proprietà pubblica | FilterDist | REstituisce il tipo di filtro di distinta.
Proprietà pubblica | GroupDist | Lista contentente le informazioni extra sulla tipologia. Esempio : QTA=Int;MACCHINA=String;
Proprietà pubblica | HasPersFilter | Resituisce se la lista usa un filtro di distinta
Proprietà pubblica | HasTipoDist | Restituisce se la lista usa un tipo di distinta
Proprietà pubblica | Id | Codice identificativo univoco
Proprietà pubblica | ItemType | Tipologie di oggetti gestiti dalla lista
Proprietà pubblica | ListType | Tipologia di lista
Proprietà pubblica | LoadLastRev | Indica se è caricare ultima revisione dell'anagrafica
Proprietà pubblica | Name | Descrizione della tipologia di lista
Proprietà pubblica | Parent | Restituisce la collezione di appartenenza dell'elemento.
Proprietà pubblica | Reserved | Indica se è una tipologia riservata (quindi non cancellabile)
Proprietà pubblica | StatoRecord | Restituisce o imposta lo stato del record. DI USO INTERNO !!
Proprietà pubblica | TipoDist | Restituisce il tipo di distinta
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | GetFuncDist | Restituisce la stringa formattata in modo corretto per il campo FUNCDIST.
Metodo pubblico | NotifyDirty | Notifica l'avvenuta modifica di una proprietà.
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Metodo pubblico | Validate | Restituisce True se la lista è compilata in modo corretto altrimenti False.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedList
Costruttore

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedList(
    DedListCollection parent,
    Guid id,
    DedListType listType,
    string name,
    bool reserved,
    bool loadlastrev,
    string extraDataInfo,
    string discrimdist,
    string groupdist,
    string funcdist
)
Public Sub New (
    parent As DedListCollection,
    id As Guid,
    listType As DedListType,
    name As String,
    reserved As Boolean,
    loadlastrev As Boolean,
    extraDataInfo As String,
    discrimdist As String,
    groupdist As String,
    funcdist As String
)
public:
DedList(
    DedListCollection^ parent,
    Guid id,
    DedListType^ listType,
    String^ name,
    bool reserved,
    bool loadlastrev,
    String^ extraDataInfo,
    String^ discrimdist,
    String^ groupdist,
    String^ funcdist
)
new :
        parent : DedListCollection *
        id : Guid *
        listType : DedListType *
        name : string *
        reserved : bool *
        loadlastrev : bool *
        extraDataInfo : string *
        discrimdist : string *
        groupdist : string *
        funcdist : string -> DedList

Parametri

parent DedListCollection
Lista di appartenenza
id Guid
Identificativo della lista
listType DedListType
Tipologia di lista
name String
Nome della lista
reserved Boolean
Indica se è una lista riservata
loadlastrev Boolean
extraDataInfo String
Informazioni aggiuntive
discrimdist String
groupdist String
funcdist String
FUNC=Distinta esportazione;FILTER=Tutte le parti
Vedi anche

Documentazione

Classe DedList
Namespace DedNet.Core


Proprietà di DedList

Il tipo DedList espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | DiscrimDist | Lista contentente le informazioni extra sulla tipologia. Esempio : QTA=Int;MACCHINA=String;
Proprietà pubblica | ExtraDataInfo | Lista contentente le informazioni extra sulla tipologia. Esempio : QTA=Int;MACCHINA=String;
Proprietà pubblica | FilterDist | REstituisce il tipo di filtro di distinta.
Proprietà pubblica | GroupDist | Lista contentente le informazioni extra sulla tipologia. Esempio : QTA=Int;MACCHINA=String;
Proprietà pubblica | HasPersFilter | Resituisce se la lista usa un filtro di distinta
Proprietà pubblica | HasTipoDist | Restituisce se la lista usa un tipo di distinta
Proprietà pubblica | Id | Codice identificativo univoco
Proprietà pubblica | ItemType | Tipologie di oggetti gestiti dalla lista
Proprietà pubblica | ListType | Tipologia di lista
Proprietà pubblica | LoadLastRev | Indica se è caricare ultima revisione dell'anagrafica
Proprietà pubblica | Name | Descrizione della tipologia di lista
Proprietà pubblica | Parent | Restituisce la collezione di appartenenza dell'elemento.
Proprietà pubblica | Reserved | Indica se è una tipologia riservata (quindi non cancellabile)
Proprietà pubblica | StatoRecord | Restituisce o imposta lo stato del record. DI USO INTERNO !!
Proprietà pubblica | TipoDist | Restituisce il tipo di distinta
Torna su
Vedi anche

Documentazione

Classe DedList
Namespace DedNet.Core


Proprietà DedList.DiscrimDist

Proprietà DedListDiscrimDist
Lista contentente le informazioni extra sulla tipologia. Esempio : QTA=Int;MACCHINA=String;

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DiscrimDistList DiscrimDist { get; set; }
Public Property DiscrimDist As DiscrimDistList
    Get
    Set
public:
property DiscrimDistList^ DiscrimDist {
    DiscrimDistList^ get ();
    void set (DiscrimDistList^ value);
}
member DiscrimDist : DiscrimDistList with get, set

Valore della proprietà

DiscrimDistList
Vedi anche

Documentazione

Classe DedList
Namespace DedNet.Core


Proprietà DedList.ExtraDataInfo

Proprietà DedListExtraDataInfo
Lista contentente le informazioni extra sulla tipologia. Esempio : QTA=Int;MACCHINA=String;

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ExtraDataInfoList ExtraDataInfo { get; set; }
Public Property ExtraDataInfo As ExtraDataInfoList
    Get
    Set
public:
property ExtraDataInfoList^ ExtraDataInfo {
    ExtraDataInfoList^ get ();
    void set (ExtraDataInfoList^ value);
}
member ExtraDataInfo : ExtraDataInfoList with get, set

Valore della proprietà

ExtraDataInfoList
Vedi anche

Documentazione

Classe DedList
Namespace DedNet.Core


Proprietà DedList.FilterDist

Proprietà DedListFilterDist
REstituisce il tipo di filtro di distinta.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string FilterDist { get; set; }
Public Property FilterDist As String
    Get
    Set
public:
property String^ FilterDist {
    String^ get ();
    void set (String^ value);
}
member FilterDist : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedList
Namespace DedNet.Core


Proprietà DedList.GroupDist

Proprietà DedListGroupDist
Lista contentente le informazioni extra sulla tipologia. Esempio : QTA=Int;MACCHINA=String;

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DiscrimDistList GroupDist { get; set; }
Public Property GroupDist As DiscrimDistList
    Get
    Set
public:
property DiscrimDistList^ GroupDist {
    DiscrimDistList^ get ();
    void set (DiscrimDistList^ value);
}
member GroupDist : DiscrimDistList with get, set

Valore della proprietà

DiscrimDistList
Vedi anche

Documentazione

Classe DedList
Namespace DedNet.Core


Proprietà DedList.HasPersFilter

Proprietà DedListHasPersFilter
Resituisce se la lista usa un filtro di distinta

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasPersFilter { get; }
Public ReadOnly Property HasPersFilter As Boolean
    Get
public:
property bool HasPersFilter {
    bool get ();
}
member HasPersFilter : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedList
Namespace DedNet.Core


Proprietà DedList.HasTipoDist

Proprietà DedListHasTipoDist
Restituisce se la lista usa un tipo di distinta

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasTipoDist { get; }
Public ReadOnly Property HasTipoDist As Boolean
    Get
public:
property bool HasTipoDist {
    bool get ();
}
member HasTipoDist : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedList
Namespace DedNet.Core


Proprietà DedList.Id

Proprietà DedListId
Codice identificativo univoco

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Guid Id { get; set; }
Public Property Id As Guid
    Get
    Set
public:
property Guid Id {
    Guid get ();
    void set (Guid value);
}
member Id : Guid with get, set

Valore della proprietà

Guid
Vedi anche

Documentazione

Classe DedList
Namespace DedNet.Core


Proprietà DedList.ItemType

Proprietà DedListItemType
Tipologie di oggetti gestiti dalla lista

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ListItemTypeEnum ItemType { get; }
Public ReadOnly Property ItemType As ListItemTypeEnum
    Get
public:
property ListItemTypeEnum ItemType {
    ListItemTypeEnum get ();
}
member ItemType : ListItemTypeEnum with get

Valore della proprietà

ListItemTypeEnum
Vedi anche

Documentazione

Classe DedList
Namespace DedNet.Core


Proprietà DedList.ListType

Proprietà DedListListType
Tipologia di lista

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedListType ListType { get; set; }
Public Property ListType As DedListType
    Get
    Set
public:
property DedListType^ ListType {
    DedListType^ get ();
    void set (DedListType^ value);
}
member ListType : DedListType with get, set

Valore della proprietà

DedListType
Vedi anche

Documentazione

Classe DedList
Namespace DedNet.Core


Proprietà DedList.LoadLastRev

Proprietà DedListLoadLastRev
Indica se è caricare ultima revisione dell'anagrafica

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool LoadLastRev { get; set; }
Public Property LoadLastRev As Boolean
    Get
    Set
public:
property bool LoadLastRev {
    bool get ();
    void set (bool value);
}
member LoadLastRev : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedList
Namespace DedNet.Core


Proprietà DedList.Name

Proprietà DedListName
Descrizione della tipologia di lista

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedList
Namespace DedNet.Core


Proprietà DedList.Parent

Proprietà DedListParent
Restituisce la collezione di appartenenza dell'elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedListCollection Parent { get; set; }
Public Property Parent As DedListCollection
    Get
    Set
public:
property DedListCollection^ Parent {
    DedListCollection^ get ();
    void set (DedListCollection^ value);
}
member Parent : DedListCollection with get, set

Valore della proprietà

DedListCollection
Vedi anche

Documentazione

Classe DedList
Namespace DedNet.Core


Proprietà DedList.Reserved

Proprietà DedListReserved
Indica se è una tipologia riservata (quindi non cancellabile)

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Reserved { get; set; }
Public Property Reserved As Boolean
    Get
    Set
public:
property bool Reserved {
    bool get ();
    void set (bool value);
}
member Reserved : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedList
Namespace DedNet.Core


Proprietà DedList.StatoRecord

Proprietà DedListStatoRecord
Restituisce o imposta lo stato del record. DI USO INTERNO !!

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public StatoRecord StatoRecord { get; set; }
Public Property StatoRecord As StatoRecord
    Get
    Set
public:
virtual property StatoRecord^ StatoRecord {
    StatoRecord^ get () sealed;
    void set (StatoRecord^ value) sealed;
}
abstract StatoRecord : StatoRecord with get, set
override StatoRecord : StatoRecord with get, set

Valore della proprietà

StatoRecord

Implementa

IDedDbItemStatoRecord
Vedi anche

Documentazione

Classe DedList
Namespace DedNet.Core


Proprietà DedList.TipoDist

Proprietà DedListTipoDist
Restituisce il tipo di distinta

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string TipoDist { get; set; }
Public Property TipoDist As String
    Get
    Set
public:
property String^ TipoDist {
    String^ get ();
    void set (String^ value);
}
member TipoDist : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedList
Namespace DedNet.Core


Metodi di DedList

Il tipo DedList espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | GetFuncDist | Restituisce la stringa formattata in modo corretto per il campo FUNCDIST.
Metodo pubblico | NotifyDirty | Notifica l'avvenuta modifica di una proprietà.
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Metodo pubblico | Validate | Restituisce True se la lista è compilata in modo corretto altrimenti False.
Torna su
Vedi anche

Documentazione

Classe DedList
Namespace DedNet.Core


Metodo DedList.GetFuncDist

Metodo DedListGetFuncDist
Restituisce la stringa formattata in modo corretto per il campo FUNCDIST.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string GetFuncDist()
Public Function GetFuncDist As String
public:
String^ GetFuncDist()
member GetFuncDist : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedList
Namespace DedNet.Core


Metodo DedList.NotifyDirty

Metodo DedListNotifyDirty
Notifica l'avvenuta modifica di una proprietà.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void NotifyDirty()
Public Sub NotifyDirty
public:
void NotifyDirty()
member NotifyDirty : unit -> unit
Vedi anche

Documentazione

Classe DedList
Namespace DedNet.Core


Metodo DedList.ToString

Metodo DedListToString

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedList
Namespace DedNet.Core


Metodo DedList.Validate

Metodo DedListValidate
Restituisce True se la lista è compilata in modo corretto altrimenti False.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Validate()
Public Function Validate As Boolean
public:
bool Validate()
member Validate : unit -> bool

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedList
Namespace DedNet.Core


Classe DedListCollection
Collezione delle tipologie di liste definite
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedDbCollectionBase DedList
DedNet.CoreDedListCollection

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedListCollection : DedDbCollectionBase<DedList>
Public Class DedListCollection
    Inherits DedDbCollectionBase(Of DedList)
public ref class DedListCollection : public DedDbCollectionBase<DedList^>
type DedListCollection =
    class
        inherit DedDbCollectionBase<DedList>
    end

Il tipo DedListCollection espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllowsDuplicates | Restituisce se siano ammessi duplicati all'interno della lista. Se false viene sollevata una eccezione su tentativo di inserimento duplicati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Application | Restituisce l'oggetto applicazione di appartenza. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Count | Restituisce il numero di elementi presenti. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Dirty | Restituisce se la collezione o uno dei suoi elementi sia stata modificata. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | ErasedItems | Restitusice la lista in sola lettura degli elementi che risultano attualmente cancellati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | LastItem | Restituisce l'ultimo elemento della collezione oppure null se non ci sono elementi. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | RestoreErased | Restituisce se gli elementi cancellati devono essere ripristinati in caso vengano riaggiunti. (Ereditato da DedDbCollectionBaseT)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | AddForClone | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto SENZA MODIFICARNE LO STATO. Le classi derivate potranno utilizzare questo metodo per clonare la collezione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddNewElement | DI USO INTERNO. Aggiunge un elemento alla lista rendendo dirty l'oggetto. L'elemento viene aggiunto con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere un elemento alla lista. Dovranno loro stesse avere un metodo pubblico Add() che prenda i parametri necessari alla costruzione dell'oggetto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddRangeNewElement | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi rendendo dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere più elementi alla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddUnModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Clear | Elimina tutti gli elementi dalla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ClearRefresh | Svuota la lista impostando Dirty = false. Di fatto permette di effettuare un refresh della lista e quindi di ricaricarla. Serve per svuotare la lista e reinizializzarla da capo. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Contains | Verifica l'esistenza di un valore all'interno della lista degli elementi. Le classi derivate devono effettuarne l'override nel caso in cui l'elemento non implementi GetHashCode() per l'uso all'interno dei dizionarii. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | CopyTo | Copia un range di elementi in un array. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | CreateDeleteCommand | Crea il comando di delete per un elemento. (Sovrascrive DedDbCollectionBaseTCreateDeleteCommand(T))
Metodo protetto | CreateInsertCommand | Crea il comando di insert per un elemento. (Sovrascrive DedDbCollectionBaseTCreateInsertCommand(T))
Metodo protetto | CreateUpdateCommand | Crea il comando di update per un elemento. (Sovrascrive DedDbCollectionBaseTCreateUpdateCommand(T))
Metodo pubblico | CustomSort | Ordina la lista in base al comparatore passato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteDeleteItem | Esegue l'eliminazione di un elemento. Crea il comando tramite il metodo CreateDeleteCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteInsertItem | Esegue l'inserimento di un elemento. Crea il comando tramite il metodo CreateInsertCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteUpdateItem | Esegue l'aggiornamento di un elemento. Crea il comando tramite il metodo CreateUpdateCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Find | Restituisce l'oggetto cercato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FindAll | Restitusice la lista degli elementi che corrispondono al predicato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | GetDbIndex | Restitusice l'indice di un elemento. (Sovrascrive DedDbCollectionBaseTGetDbIndex(T))
Metodo pubblico | GetEnumerator | Restituisce l'enumeratore della collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | IndexOf | Restituisce l'indice dell'elemento richiesto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InsertUnModified | DI USO INTERNO. Inserisce un elemento alla lista senza rendere dirty l'oggetto, all'indice specificato. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Item | Restituisce l'elemento iesimo della lista. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean) | Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean, Int32) | Sposta l'elemento dell'indice passato prima o dopo del numero di posizioni passate. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSave | Metodo Template chiamato dopo il salvataggio avvenuto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSaveNoChanges | Metodo Template chiamato dopo il salvataggio senza modifiche. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnBeforeSave | Metodo Template chiamato prima del salvataggio. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(T) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(DedEditableObjectT) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(T) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(DedEditableObjectT) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ReInitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Remove | Elimina un elemento dalla collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Ripristina | Verifica che l'elemento sia presente negli eliminati e lo toglie da lì e lo riaggiunge in coda alla lista degli elementi validi. Solleva una eccezione se l'elemento è già presente nella lista e AllowsDuplicates = false. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Save | Salva l'oggetto con tutta la sua lista, solo se questo risulta dirty. (Ereditato da DedDbCollectionBaseT)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di DedListCollection

Il tipo DedListCollection espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllowsDuplicates | Restituisce se siano ammessi duplicati all'interno della lista. Se false viene sollevata una eccezione su tentativo di inserimento duplicati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Application | Restituisce l'oggetto applicazione di appartenza. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Count | Restituisce il numero di elementi presenti. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Dirty | Restituisce se la collezione o uno dei suoi elementi sia stata modificata. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | ErasedItems | Restitusice la lista in sola lettura degli elementi che risultano attualmente cancellati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | LastItem | Restituisce l'ultimo elemento della collezione oppure null se non ci sono elementi. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | RestoreErased | Restituisce se gli elementi cancellati devono essere ripristinati in caso vengano riaggiunti. (Ereditato da DedDbCollectionBaseT)
Torna su
Vedi anche

Documentazione

Classe DedListCollection
Namespace DedNet.Core


Metodi di DedListCollection

Il tipo DedListCollection espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | AddForClone | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto SENZA MODIFICARNE LO STATO. Le classi derivate potranno utilizzare questo metodo per clonare la collezione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddNewElement | DI USO INTERNO. Aggiunge un elemento alla lista rendendo dirty l'oggetto. L'elemento viene aggiunto con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere un elemento alla lista. Dovranno loro stesse avere un metodo pubblico Add() che prenda i parametri necessari alla costruzione dell'oggetto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddRangeNewElement | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi rendendo dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere più elementi alla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddUnModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Clear | Elimina tutti gli elementi dalla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ClearRefresh | Svuota la lista impostando Dirty = false. Di fatto permette di effettuare un refresh della lista e quindi di ricaricarla. Serve per svuotare la lista e reinizializzarla da capo. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Contains | Verifica l'esistenza di un valore all'interno della lista degli elementi. Le classi derivate devono effettuarne l'override nel caso in cui l'elemento non implementi GetHashCode() per l'uso all'interno dei dizionarii. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | CopyTo | Copia un range di elementi in un array. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | CreateDeleteCommand | Crea il comando di delete per un elemento. (Sovrascrive DedDbCollectionBaseTCreateDeleteCommand(T))
Metodo protetto | CreateInsertCommand | Crea il comando di insert per un elemento. (Sovrascrive DedDbCollectionBaseTCreateInsertCommand(T))
Metodo protetto | CreateUpdateCommand | Crea il comando di update per un elemento. (Sovrascrive DedDbCollectionBaseTCreateUpdateCommand(T))
Metodo pubblico | CustomSort | Ordina la lista in base al comparatore passato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteDeleteItem | Esegue l'eliminazione di un elemento. Crea il comando tramite il metodo CreateDeleteCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteInsertItem | Esegue l'inserimento di un elemento. Crea il comando tramite il metodo CreateInsertCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteUpdateItem | Esegue l'aggiornamento di un elemento. Crea il comando tramite il metodo CreateUpdateCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Find | Restituisce l'oggetto cercato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FindAll | Restitusice la lista degli elementi che corrispondono al predicato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | GetDbIndex | Restitusice l'indice di un elemento. (Sovrascrive DedDbCollectionBaseTGetDbIndex(T))
Metodo pubblico | GetEnumerator | Restituisce l'enumeratore della collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | IndexOf | Restituisce l'indice dell'elemento richiesto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InsertUnModified | DI USO INTERNO. Inserisce un elemento alla lista senza rendere dirty l'oggetto, all'indice specificato. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Item | Restituisce l'elemento iesimo della lista. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean) | Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean, Int32) | Sposta l'elemento dell'indice passato prima o dopo del numero di posizioni passate. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSave | Metodo Template chiamato dopo il salvataggio avvenuto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSaveNoChanges | Metodo Template chiamato dopo il salvataggio senza modifiche. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnBeforeSave | Metodo Template chiamato prima del salvataggio. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(T) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(DedEditableObjectT) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(T) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(DedEditableObjectT) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ReInitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Remove | Elimina un elemento dalla collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Ripristina | Verifica che l'elemento sia presente negli eliminati e lo toglie da lì e lo riaggiunge in coda alla lista degli elementi validi. Solleva una eccezione se l'elemento è già presente nella lista e AllowsDuplicates = false. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Save | Salva l'oggetto con tutta la sua lista, solo se questo risulta dirty. (Ereditato da DedDbCollectionBaseT)
Torna su
Vedi anche

Documentazione

Classe DedListCollection
Namespace DedNet.Core


Metodo DedListCollection.CreateDeleteCommand

Metodo DedListCollectionCreateDeleteCommand
Crea il comando di delete per un elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSDeleteCommand CreateDeleteCommand(
    DedList item
)
Protected Overrides Function CreateDeleteCommand (
    item As DedList
) As QSDeleteCommand
protected:
virtual QSDeleteCommand^ CreateDeleteCommand(
    DedList^ item
) override
abstract CreateDeleteCommand :
        item : DedList -> QSDeleteCommand
override CreateDeleteCommand :
        item : DedList -> QSDeleteCommand

Parametri

item DedList
Elemento per il quale creare il comando.

Valore di ritorno

QSDeleteCommand
Vedi anche

Documentazione

Classe DedListCollection
Namespace DedNet.Core


Metodo DedListCollection.CreateInsertCommand

Metodo DedListCollectionCreateInsertCommand
Crea il comando di insert per un elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSInsertCommand CreateInsertCommand(
    DedList item
)
Protected Overrides Function CreateInsertCommand (
    item As DedList
) As QSInsertCommand
protected:
virtual QSInsertCommand^ CreateInsertCommand(
    DedList^ item
) override
abstract CreateInsertCommand :
        item : DedList -> QSInsertCommand
override CreateInsertCommand :
        item : DedList -> QSInsertCommand

Parametri

item DedList
Elemento per il quale creare il comando.

Valore di ritorno

QSInsertCommand
Vedi anche

Documentazione

Classe DedListCollection
Namespace DedNet.Core


Metodo DedListCollection.CreateUpdateCommand

Metodo DedListCollectionCreateUpdateCommand
Crea il comando di update per un elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSUpdateCommand CreateUpdateCommand(
    DedList item
)
Protected Overrides Function CreateUpdateCommand (
    item As DedList
) As QSUpdateCommand
protected:
virtual QSUpdateCommand^ CreateUpdateCommand(
    DedList^ item
) override
abstract CreateUpdateCommand :
        item : DedList -> QSUpdateCommand
override CreateUpdateCommand :
        item : DedList -> QSUpdateCommand

Parametri

item DedList
Elemento per il quale creare il comando.

Valore di ritorno

QSUpdateCommand
Vedi anche

Documentazione

Classe DedListCollection
Namespace DedNet.Core


Metodo DedListCollection.GetDbIndex

Metodo DedListCollectionGetDbIndex
Restitusice l'indice di un elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override Object GetDbIndex(
    DedList item
)
Protected Overrides Function GetDbIndex (
    item As DedList
) As Object
protected:
virtual Object^ GetDbIndex(
    DedList^ item
) override
abstract GetDbIndex :
        item : DedList -> Object
override GetDbIndex :
        item : DedList -> Object

Parametri

item DedList
Elemento per il quale restituire l'indice.

Valore di ritorno

Object
Vedi anche

Documentazione

Classe DedListCollection
Namespace DedNet.Core


Classe DedListItem
Oggetto rappresentante un elemento della lista
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedListItem

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedListItem : IDedDbItem
Public Class DedListItem
    Implements IDedDbItem
public ref class DedListItem : IDedDbItem
type DedListItem =
    class
        interface IDedDbItem
    end

Il tipo DedListItem espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedListItem | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Dbindex | Campo dbindex
Proprietà pubblica | ElaborationType | Indica il tipo di elaborazione da effettuare sull'elemento
Proprietà pubblica | Id | Identificativo univoco
Proprietà pubblica | IncludeSubComm | Indica se includere le sottocommesse
Proprietà pubblica | ItemType | Restituisce la tipologia di elemento
Proprietà pubblica | Parent | Collezione di appartenenza
Proprietà pubblica | Qta | Valore della qta
Proprietà pubblica | StatoRecord | Stato del record
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedListItem
Costruttore

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedListItem(
    DedListItemCollection parent,
    Guid id,
    string dbindex,
    DedDbItemType itemType,
    ListElaborationTypeEnum elaborationType,
    double qta,
    bool includeSubComm
)
Public Sub New (
    parent As DedListItemCollection,
    id As Guid,
    dbindex As String,
    itemType As DedDbItemType,
    elaborationType As ListElaborationTypeEnum,
    qta As Double,
    includeSubComm As Boolean
)
public:
DedListItem(
    DedListItemCollection^ parent,
    Guid id,
    String^ dbindex,
    DedDbItemType itemType,
    ListElaborationTypeEnum elaborationType,
    double qta,
    bool includeSubComm
)
new :
        parent : DedListItemCollection *
        id : Guid *
        dbindex : string *
        itemType : DedDbItemType *
        elaborationType : ListElaborationTypeEnum *
        qta : float *
        includeSubComm : bool -> DedListItem

Parametri

parent DedListItemCollection
Collezione di appartenenza
id Guid
Identificativo univoco
dbindex String
DbIndex
itemType DedDbItemType
Tipologia di elemento
elaborationType ListElaborationTypeEnum
Tipo di elaborazione
qta Double
Quantità
includeSubComm Boolean
Indica se includere le sottocommesse
Vedi anche

Documentazione

Classe DedListItem
Namespace DedNet.Core


Proprietà di DedListItem

Il tipo DedListItem espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Dbindex | Campo dbindex
Proprietà pubblica | ElaborationType | Indica il tipo di elaborazione da effettuare sull'elemento
Proprietà pubblica | Id | Identificativo univoco
Proprietà pubblica | IncludeSubComm | Indica se includere le sottocommesse
Proprietà pubblica | ItemType | Restituisce la tipologia di elemento
Proprietà pubblica | Parent | Collezione di appartenenza
Proprietà pubblica | Qta | Valore della qta
Proprietà pubblica | StatoRecord | Stato del record
Torna su
Vedi anche

Documentazione

Classe DedListItem
Namespace DedNet.Core


Proprietà DedListItem.Dbindex

Proprietà DedListItemDbindex
Campo dbindex

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Dbindex { get; set; }
Public Property Dbindex As String
    Get
    Set
public:
property String^ Dbindex {
    String^ get ();
    void set (String^ value);
}
member Dbindex : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedListItem
Namespace DedNet.Core


Proprietà DedListItem.ElaborationType

Proprietà DedListItemElaborationType
Indica il tipo di elaborazione da effettuare sull'elemento

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ListElaborationTypeEnum ElaborationType { get; set; }
Public Property ElaborationType As ListElaborationTypeEnum
    Get
    Set
public:
property ListElaborationTypeEnum ElaborationType {
    ListElaborationTypeEnum get ();
    void set (ListElaborationTypeEnum value);
}
member ElaborationType : ListElaborationTypeEnum with get, set

Valore della proprietà

ListElaborationTypeEnum
Vedi anche

Documentazione

Classe DedListItem
Namespace DedNet.Core


Proprietà DedListItem.Id

Proprietà DedListItemId
Identificativo univoco

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Guid Id { get; set; }
Public Property Id As Guid
    Get
    Set
public:
property Guid Id {
    Guid get ();
    void set (Guid value);
}
member Id : Guid with get, set

Valore della proprietà

Guid
Vedi anche

Documentazione

Classe DedListItem
Namespace DedNet.Core


Proprietà DedListItem.IncludeSubComm

Proprietà DedListItemIncludeSubComm
Indica se includere le sottocommesse

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IncludeSubComm { get; set; }
Public Property IncludeSubComm As Boolean
    Get
    Set
public:
property bool IncludeSubComm {
    bool get ();
    void set (bool value);
}
member IncludeSubComm : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedListItem
Namespace DedNet.Core


Proprietà DedListItem.ItemType

Proprietà DedListItemItemType
Restituisce la tipologia di elemento

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDbItemType ItemType { get; }
Public ReadOnly Property ItemType As DedDbItemType
    Get
public:
property DedDbItemType ItemType {
    DedDbItemType get ();
}
member ItemType : DedDbItemType with get

Valore della proprietà

DedDbItemType
Vedi anche

Documentazione

Classe DedListItem
Namespace DedNet.Core


Proprietà DedListItem.Parent

Proprietà DedListItemParent
Collezione di appartenenza

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedListItemCollection Parent { get; set; }
Public Property Parent As DedListItemCollection
    Get
    Set
public:
property DedListItemCollection^ Parent {
    DedListItemCollection^ get ();
    void set (DedListItemCollection^ value);
}
member Parent : DedListItemCollection with get, set

Valore della proprietà

DedListItemCollection
Vedi anche

Documentazione

Classe DedListItem
Namespace DedNet.Core


Proprietà DedListItem.Qta

Proprietà DedListItemQta
Valore della qta

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public double Qta { get; set; }
Public Property Qta As Double
    Get
    Set
public:
property double Qta {
    double get ();
    void set (double value);
}
member Qta : float with get, set

Valore della proprietà

Double
Vedi anche

Documentazione

Classe DedListItem
Namespace DedNet.Core


Proprietà DedListItem.StatoRecord

Proprietà DedListItemStatoRecord
Stato del record

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public StatoRecord StatoRecord { get; set; }
Public Property StatoRecord As StatoRecord
    Get
    Set
public:
virtual property StatoRecord^ StatoRecord {
    StatoRecord^ get () sealed;
    void set (StatoRecord^ value) sealed;
}
abstract StatoRecord : StatoRecord with get, set
override StatoRecord : StatoRecord with get, set

Valore della proprietà

StatoRecord

Implementa

IDedDbItemStatoRecord
Vedi anche

Documentazione

Classe DedListItem
Namespace DedNet.Core


Classe DedListItemCollection
Collezione degli elementi nella lista utente
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedDbCollectionBase DedListItem
DedNet.CoreDedListItemCollection

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedListItemCollection : DedDbCollectionBase<DedListItem>
Public Class DedListItemCollection
    Inherits DedDbCollectionBase(Of DedListItem)
public ref class DedListItemCollection : public DedDbCollectionBase<DedListItem^>
type DedListItemCollection =
    class
        inherit DedDbCollectionBase<DedListItem>
    end

Il tipo DedListItemCollection espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllowsDuplicates | Restituisce se siano ammessi duplicati all'interno della lista. Se false viene sollevata una eccezione su tentativo di inserimento duplicati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Application | Restituisce l'oggetto applicazione di appartenza. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Count | Restituisce il numero di elementi presenti. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Dirty | Restituisce se la collezione o uno dei suoi elementi sia stata modificata. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | ErasedItems | Restitusice la lista in sola lettura degli elementi che risultano attualmente cancellati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | LastItem | Restituisce l'ultimo elemento della collezione oppure null se non ci sono elementi. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | RestoreErased | Restituisce se gli elementi cancellati devono essere ripristinati in caso vengano riaggiunti. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | UserList | Lista utente di appartenenza
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AddComm | Aggiunge la commessa alla collezione
Metodo pubblico | AddData | Aggiunge l'anagrafica alla collezione
Metodo protetto | AddForClone | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto SENZA MODIFICARNE LO STATO. Le classi derivate potranno utilizzare questo metodo per clonare la collezione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddNewElement | DI USO INTERNO. Aggiunge un elemento alla lista rendendo dirty l'oggetto. L'elemento viene aggiunto con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere un elemento alla lista. Dovranno loro stesse avere un metodo pubblico Add() che prenda i parametri necessari alla costruzione dell'oggetto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddRangeNewElement | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi rendendo dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere più elementi alla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddUnModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Clear | Elimina tutti gli elementi dalla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ClearRefresh | Svuota la lista impostando Dirty = false. Di fatto permette di effettuare un refresh della lista e quindi di ricaricarla. Serve per svuotare la lista e reinizializzarla da capo. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Contains | Verifica l'esistenza di un valore all'interno della lista degli elementi. Le classi derivate devono effettuarne l'override nel caso in cui l'elemento non implementi GetHashCode() per l'uso all'interno dei dizionarii. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | CopyTo | Copia un range di elementi in un array. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | CreateDeleteCommand | Crea il comando di delete per un elemento. (Sovrascrive DedDbCollectionBaseTCreateDeleteCommand(T))
Metodo protetto | CreateInsertCommand | Crea il comando di insert per un elemento. (Sovrascrive DedDbCollectionBaseTCreateInsertCommand(T))
Metodo protetto | CreateUpdateCommand | Crea il comando di update per un elemento. (Sovrascrive DedDbCollectionBaseTCreateUpdateCommand(T))
Metodo pubblico | CustomSort | Ordina la lista in base al comparatore passato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Delete | Rimuove un elemento dalla collezione
Metodo protetto | ExecuteDeleteItem | Esegue l'eliminazione di un elemento. Crea il comando tramite il metodo CreateDeleteCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteInsertItem | Esegue l'inserimento di un elemento. Crea il comando tramite il metodo CreateInsertCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteUpdateItem | Esegue l'aggiornamento di un elemento. Crea il comando tramite il metodo CreateUpdateCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Find(DedListItem) | Restituisce l'oggetto con lo specifico dbindex
Metodo pubblico | Find(PredicateT) | Restituisce l'oggetto cercato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FindAll | Restitusice la lista degli elementi che corrispondono al predicato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | GetDbIndex | Restitusice l'indice di un elemento. (Sovrascrive DedDbCollectionBaseTGetDbIndex(T))
Metodo pubblico | GetEnumerator | Restituisce l'enumeratore della collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | IndexOf | Restituisce l'indice dell'elemento richiesto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InsertUnModified | DI USO INTERNO. Inserisce un elemento alla lista senza rendere dirty l'oggetto, all'indice specificato. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Item | Restituisce l'elemento iesimo della lista. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean) | Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean, Int32) | Sposta l'elemento dell'indice passato prima o dopo del numero di posizioni passate. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSave | Metodo Template chiamato dopo il salvataggio avvenuto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSaveNoChanges | Metodo Template chiamato dopo il salvataggio senza modifiche. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnBeforeSave | Metodo Template chiamato prima del salvataggio. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(T) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(DedEditableObjectT) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(T) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(DedEditableObjectT) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ReInitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Remove | Elimina un elemento dalla collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Ripristina | Verifica che l'elemento sia presente negli eliminati e lo toglie da lì e lo riaggiunge in coda alla lista degli elementi validi. Solleva una eccezione se l'elemento è già presente nella lista e AllowsDuplicates = false. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Save | Salva l'oggetto con tutta la sua lista, solo se questo risulta dirty. (Ereditato da DedDbCollectionBaseT)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di DedListItemCollection

Il tipo DedListItemCollection espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllowsDuplicates | Restituisce se siano ammessi duplicati all'interno della lista. Se false viene sollevata una eccezione su tentativo di inserimento duplicati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Application | Restituisce l'oggetto applicazione di appartenza. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Count | Restituisce il numero di elementi presenti. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Dirty | Restituisce se la collezione o uno dei suoi elementi sia stata modificata. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | ErasedItems | Restitusice la lista in sola lettura degli elementi che risultano attualmente cancellati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | LastItem | Restituisce l'ultimo elemento della collezione oppure null se non ci sono elementi. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | RestoreErased | Restituisce se gli elementi cancellati devono essere ripristinati in caso vengano riaggiunti. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | UserList | Lista utente di appartenenza
Torna su
Vedi anche

Documentazione

Classe DedListItemCollection
Namespace DedNet.Core


Proprietà DedListItemCollection.UserList

Proprietà DedListItemCollectionUserList
Lista utente di appartenenza

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedUserList UserList { get; set; }
Public Property UserList As DedUserList
    Get
    Set
public:
property DedUserList^ UserList {
    DedUserList^ get ();
    void set (DedUserList^ value);
}
member UserList : DedUserList with get, set

Valore della proprietà

DedUserList
Vedi anche

Documentazione

Classe DedListItemCollection
Namespace DedNet.Core


Metodi di DedListItemCollection

Il tipo DedListItemCollection espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AddComm | Aggiunge la commessa alla collezione
Metodo pubblico | AddData | Aggiunge l'anagrafica alla collezione
Metodo protetto | AddForClone | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto SENZA MODIFICARNE LO STATO. Le classi derivate potranno utilizzare questo metodo per clonare la collezione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddNewElement | DI USO INTERNO. Aggiunge un elemento alla lista rendendo dirty l'oggetto. L'elemento viene aggiunto con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere un elemento alla lista. Dovranno loro stesse avere un metodo pubblico Add() che prenda i parametri necessari alla costruzione dell'oggetto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddRangeNewElement | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi rendendo dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere più elementi alla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddUnModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Clear | Elimina tutti gli elementi dalla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ClearRefresh | Svuota la lista impostando Dirty = false. Di fatto permette di effettuare un refresh della lista e quindi di ricaricarla. Serve per svuotare la lista e reinizializzarla da capo. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Contains | Verifica l'esistenza di un valore all'interno della lista degli elementi. Le classi derivate devono effettuarne l'override nel caso in cui l'elemento non implementi GetHashCode() per l'uso all'interno dei dizionarii. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | CopyTo | Copia un range di elementi in un array. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | CreateDeleteCommand | Crea il comando di delete per un elemento. (Sovrascrive DedDbCollectionBaseTCreateDeleteCommand(T))
Metodo protetto | CreateInsertCommand | Crea il comando di insert per un elemento. (Sovrascrive DedDbCollectionBaseTCreateInsertCommand(T))
Metodo protetto | CreateUpdateCommand | Crea il comando di update per un elemento. (Sovrascrive DedDbCollectionBaseTCreateUpdateCommand(T))
Metodo pubblico | CustomSort | Ordina la lista in base al comparatore passato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Delete | Rimuove un elemento dalla collezione
Metodo protetto | ExecuteDeleteItem | Esegue l'eliminazione di un elemento. Crea il comando tramite il metodo CreateDeleteCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteInsertItem | Esegue l'inserimento di un elemento. Crea il comando tramite il metodo CreateInsertCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteUpdateItem | Esegue l'aggiornamento di un elemento. Crea il comando tramite il metodo CreateUpdateCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Find(DedListItem) | Restituisce l'oggetto con lo specifico dbindex
Metodo pubblico | Find(PredicateT) | Restituisce l'oggetto cercato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FindAll | Restitusice la lista degli elementi che corrispondono al predicato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | GetDbIndex | Restitusice l'indice di un elemento. (Sovrascrive DedDbCollectionBaseTGetDbIndex(T))
Metodo pubblico | GetEnumerator | Restituisce l'enumeratore della collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | IndexOf | Restituisce l'indice dell'elemento richiesto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InsertUnModified | DI USO INTERNO. Inserisce un elemento alla lista senza rendere dirty l'oggetto, all'indice specificato. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Item | Restituisce l'elemento iesimo della lista. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean) | Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean, Int32) | Sposta l'elemento dell'indice passato prima o dopo del numero di posizioni passate. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSave | Metodo Template chiamato dopo il salvataggio avvenuto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSaveNoChanges | Metodo Template chiamato dopo il salvataggio senza modifiche. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnBeforeSave | Metodo Template chiamato prima del salvataggio. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(T) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(DedEditableObjectT) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(T) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(DedEditableObjectT) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ReInitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Remove | Elimina un elemento dalla collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Ripristina | Verifica che l'elemento sia presente negli eliminati e lo toglie da lì e lo riaggiunge in coda alla lista degli elementi validi. Solleva una eccezione se l'elemento è già presente nella lista e AllowsDuplicates = false. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Save | Salva l'oggetto con tutta la sua lista, solo se questo risulta dirty. (Ereditato da DedDbCollectionBaseT)
Torna su
Vedi anche

Documentazione

Classe DedListItemCollection
Namespace DedNet.Core


Metodo DedListItemCollection.AddComm

Metodo DedListItemCollectionAddComm
Aggiunge la commessa alla collezione

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedListItem AddComm(
    DedComm comm,
    ListElaborationTypeEnum elaborationType,
    double qta,
    bool includeSubComm
)
Public Function AddComm (
    comm As DedComm,
    elaborationType As ListElaborationTypeEnum,
    qta As Double,
    includeSubComm As Boolean
) As DedListItem
public:
DedListItem^ AddComm(
    DedComm^ comm,
    ListElaborationTypeEnum elaborationType,
    double qta,
    bool includeSubComm
)
member AddComm :
        comm : DedComm *
        elaborationType : ListElaborationTypeEnum *
        qta : float *
        includeSubComm : bool -> DedListItem

Parametri

comm DedComm
Commessa da aggiungere
elaborationType ListElaborationTypeEnum
Tipo di elaborazione
qta Double
Quantità
includeSubComm Boolean
Indica se includere le sottocommesse

Valore di ritorno

DedListItem
Vedi anche

Documentazione

Classe DedListItemCollection
Namespace DedNet.Core


Metodo DedListItemCollection.AddData

Metodo DedListItemCollectionAddData
Aggiunge l'anagrafica alla collezione

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedListItem AddData(
    DedData data,
    ListElaborationTypeEnum elaborationType,
    double qta
)
Public Function AddData (
    data As DedData,
    elaborationType As ListElaborationTypeEnum,
    qta As Double
) As DedListItem
public:
DedListItem^ AddData(
    DedData^ data,
    ListElaborationTypeEnum elaborationType,
    double qta
)
member AddData :
        data : DedData *
        elaborationType : ListElaborationTypeEnum *
        qta : float -> DedListItem

Parametri

data DedData
Anagrafica da aggiungere
elaborationType ListElaborationTypeEnum
Tipologia di elaborazione
qta Double
Quantità

Valore di ritorno

DedListItem
Vedi anche

Documentazione

Classe DedListItemCollection
Namespace DedNet.Core


Metodo DedListItemCollection.CreateDeleteCommand

Metodo DedListItemCollectionCreateDeleteCommand
Crea il comando di delete per un elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSDeleteCommand CreateDeleteCommand(
    DedListItem item
)
Protected Overrides Function CreateDeleteCommand (
    item As DedListItem
) As QSDeleteCommand
protected:
virtual QSDeleteCommand^ CreateDeleteCommand(
    DedListItem^ item
) override
abstract CreateDeleteCommand :
        item : DedListItem -> QSDeleteCommand
override CreateDeleteCommand :
        item : DedListItem -> QSDeleteCommand

Parametri

item DedListItem
Elemento per il quale creare il comando.

Valore di ritorno

QSDeleteCommand
Vedi anche

Documentazione

Classe DedListItemCollection
Namespace DedNet.Core


Metodo DedListItemCollection.CreateInsertCommand

Metodo DedListItemCollectionCreateInsertCommand
Crea il comando di insert per un elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSInsertCommand CreateInsertCommand(
    DedListItem item
)
Protected Overrides Function CreateInsertCommand (
    item As DedListItem
) As QSInsertCommand
protected:
virtual QSInsertCommand^ CreateInsertCommand(
    DedListItem^ item
) override
abstract CreateInsertCommand :
        item : DedListItem -> QSInsertCommand
override CreateInsertCommand :
        item : DedListItem -> QSInsertCommand

Parametri

item DedListItem
Elemento per il quale creare il comando.

Valore di ritorno

QSInsertCommand
Vedi anche

Documentazione

Classe DedListItemCollection
Namespace DedNet.Core


Metodo DedListItemCollection.CreateUpdateCommand

Metodo DedListItemCollectionCreateUpdateCommand
Crea il comando di update per un elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSUpdateCommand CreateUpdateCommand(
    DedListItem item
)
Protected Overrides Function CreateUpdateCommand (
    item As DedListItem
) As QSUpdateCommand
protected:
virtual QSUpdateCommand^ CreateUpdateCommand(
    DedListItem^ item
) override
abstract CreateUpdateCommand :
        item : DedListItem -> QSUpdateCommand
override CreateUpdateCommand :
        item : DedListItem -> QSUpdateCommand

Parametri

item DedListItem
Elemento per il quale creare il comando.

Valore di ritorno

QSUpdateCommand
Vedi anche

Documentazione

Classe DedListItemCollection
Namespace DedNet.Core


Metodo DedListItemCollection.Delete

Metodo DedListItemCollectionDelete
Rimuove un elemento dalla collezione

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Delete(
    DedListItem item
)
Public Sub Delete (
    item As DedListItem
)
public:
void Delete(
    DedListItem^ item
)
member Delete :
        item : DedListItem -> unit

Parametri

item DedListItem
Elemento da rimuovere

Valore di ritorno

Vedi anche

Documentazione

Classe DedListItemCollection
Namespace DedNet.Core


Metodo DedListItemCollection.Find

Metodo DedListItemCollectionFind
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Find(DedListItem) | Restituisce l'oggetto con lo specifico dbindex
Metodo pubblico | Find(PredicateT) | Restituisce l'oggetto cercato.
Torna su
Vedi anche

Documentazione

Classe DedListItemCollection
Namespace DedNet.Core


Metodo DedListItemCollection.Find(DedListItem)

Metodo DedListItemCollectionFind(DedListItem)
Restituisce l'oggetto con lo specifico dbindex

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedListItem Find(
    DedListItem item
)
Public Function Find (
    item As DedListItem
) As DedListItem
public:
DedListItem^ Find(
    DedListItem^ item
)
member Find :
        item : DedListItem -> DedListItem

Parametri

item DedListItem

Valore di ritorno

DedListItem
Vedi anche

Documentazione

Classe DedListItemCollection
Overload di Find
Namespace DedNet.Core


Metodo DedListItemCollection.GetDbIndex

Metodo DedListItemCollectionGetDbIndex
Restitusice l'indice di un elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override Object GetDbIndex(
    DedListItem item
)
Protected Overrides Function GetDbIndex (
    item As DedListItem
) As Object
protected:
virtual Object^ GetDbIndex(
    DedListItem^ item
) override
abstract GetDbIndex :
        item : DedListItem -> Object
override GetDbIndex :
        item : DedListItem -> Object

Parametri

item DedListItem
Elemento per il quale restituire l'indice.

Valore di ritorno

Object
Vedi anche

Documentazione

Classe DedListItemCollection
Namespace DedNet.Core


Classe DedListManager
Classe per la gestione delle liste
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedListManager

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedListManager
Public Class DedListManager
public ref class DedListManager
type DedListManager = class end

Il tipo DedListManager espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedListManager | Istanzia una nuova classe 'DedListManager' utilizzata per gestire le liste.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BomsInfo | Collezione delle tipologie di distinta
Proprietà pubblica | DedLists | Collezione delle lista
Proprietà pubblica | DedListType | Tipologie di liste
Proprietà pubblica | InternalBomPrompt | Prompt della distinta di uso interno.
Proprietà pubblica | UserLists | Collezione delle liste utente
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | FindDedListTypeByName | Ricerca una tipologia di lista dal nome
Metodo pubblico | FindListById | Ricerca una lista in base al guid
Metodo pubblico | FindUserListByID | Ricerca una lista utente dal giud
Metodo pubblico | FindUserListByList | Restituisce tutte le liste utente appartenenti ad una determinata lista.
Metodo pubblico | GetElaborationTypeFromString | Ritorna il valore corrispondente alla stringa passata in ListElaborationTypeEnum. Se non la trova ritorna Anagrafica di default.
Metodo pubblico | LoadDedLists | Carica le liste
Metodo pubblico | LoadDedUserLists | Carica le liste dell'utente collegato
Metodo pubblico | ReadBomDefinitions | Metodo per leggere le varie tipologie di distinta
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedListManager
Istanzia una nuova classe 'DedListManager' utilizzata per gestire le liste.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedListManager(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedListManager(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedListManager

Parametri

app DedNetApplication
Vedi anche

Documentazione

Classe DedListManager
Namespace DedNet.Core


Proprietà di DedListManager

Il tipo DedListManager espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BomsInfo | Collezione delle tipologie di distinta
Proprietà pubblica | DedLists | Collezione delle lista
Proprietà pubblica | DedListType | Tipologie di liste
Proprietà pubblica | InternalBomPrompt | Prompt della distinta di uso interno.
Proprietà pubblica | UserLists | Collezione delle liste utente
Torna su
Vedi anche

Documentazione

Classe DedListManager
Namespace DedNet.Core


Proprietà DedListManager.BomsInfo

Proprietà DedListManagerBomsInfo
Collezione delle tipologie di distinta

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedListManagerBomInfoList BomsInfo { get; set; }
Public Property BomsInfo As DedListManagerBomInfoList
    Get
    Set
public:
property DedListManagerBomInfoList^ BomsInfo {
    DedListManagerBomInfoList^ get ();
    void set (DedListManagerBomInfoList^ value);
}
member BomsInfo : DedListManagerBomInfoList with get, set

Valore della proprietà

DedListManagerBomInfoList
Vedi anche

Documentazione

Classe DedListManager
Namespace DedNet.Core


Proprietà DedListManager.DedLists

Proprietà DedListManagerDedLists
Collezione delle lista

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedListCollection DedLists { get; set; }
Public Property DedLists As DedListCollection
    Get
    Set
public:
property DedListCollection^ DedLists {
    DedListCollection^ get ();
    void set (DedListCollection^ value);
}
member DedLists : DedListCollection with get, set

Valore della proprietà

DedListCollection
Vedi anche

Documentazione

Classe DedListManager
Namespace DedNet.Core


Proprietà DedListManager.DedListType

Proprietà DedListManagerDedListType
Tipologie di liste

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<DedListType> DedListType { get; set; }
Public Property DedListType As List(Of DedListType)
    Get
    Set
public:
property List<DedListType^>^ DedListType {
    List<DedListType^>^ get ();
    void set (List<DedListType^>^ value);
}
member DedListType : List<DedListType> with get, set

Valore della proprietà

List DedListType
Vedi anche

Documentazione

Classe DedListManager
Namespace DedNet.Core


Proprietà DedListManager.InternalBomPrompt

Proprietà DedListManagerInternalBomPrompt
Prompt della distinta di uso interno.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string InternalBomPrompt { get; set; }
Public Property InternalBomPrompt As String
    Get
    Set
public:
property String^ InternalBomPrompt {
    String^ get ();
    void set (String^ value);
}
member InternalBomPrompt : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedListManager
Namespace DedNet.Core


Proprietà DedListManager.UserLists

Proprietà DedListManagerUserLists
Collezione delle liste utente

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedUserListCollection UserLists { get; set; }
Public Property UserLists As DedUserListCollection
    Get
    Set
public:
property DedUserListCollection^ UserLists {
    DedUserListCollection^ get ();
    void set (DedUserListCollection^ value);
}
member UserLists : DedUserListCollection with get, set

Valore della proprietà

DedUserListCollection
Vedi anche

Documentazione

Classe DedListManager
Namespace DedNet.Core


Metodi di DedListManager

Il tipo DedListManager espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | FindDedListTypeByName | Ricerca una tipologia di lista dal nome
Metodo pubblico | FindListById | Ricerca una lista in base al guid
Metodo pubblico | FindUserListByID | Ricerca una lista utente dal giud
Metodo pubblico | FindUserListByList | Restituisce tutte le liste utente appartenenti ad una determinata lista.
Metodo pubblico | GetElaborationTypeFromString | Ritorna il valore corrispondente alla stringa passata in ListElaborationTypeEnum. Se non la trova ritorna Anagrafica di default.
Metodo pubblico | LoadDedLists | Carica le liste
Metodo pubblico | LoadDedUserLists | Carica le liste dell'utente collegato
Metodo pubblico | ReadBomDefinitions | Metodo per leggere le varie tipologie di distinta
Torna su
Vedi anche

Documentazione

Classe DedListManager
Namespace DedNet.Core


Metodo DedListManager.FindDedListTypeByName

Metodo DedListManagerFindDedListTypeByName
Ricerca una tipologia di lista dal nome

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedListType FindDedListTypeByName(
    string name
)
Public Function FindDedListTypeByName (
    name As String
) As DedListType
public:
DedListType^ FindDedListTypeByName(
    String^ name
)
member FindDedListTypeByName :
        name : string -> DedListType

Parametri

name String
Nome tipologia di lista

Valore di ritorno

DedListType
Vedi anche

Documentazione

Classe DedListManager
Namespace DedNet.Core


Metodo DedListManager.FindListById

Metodo DedListManagerFindListById
Ricerca una lista in base al guid

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedList FindListById(
    Guid id
)
Public Function FindListById (
    id As Guid
) As DedList
public:
DedList^ FindListById(
    Guid id
)
member FindListById :
        id : Guid -> DedList

Parametri

id Guid
Identificativo

Valore di ritorno

DedList
Vedi anche

Documentazione

Classe DedListManager
Namespace DedNet.Core


Metodo DedListManager.FindUserListByID

Metodo DedListManagerFindUserListByID
Ricerca una lista utente dal giud

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedUserList FindUserListByID(
    Guid id
)
Public Function FindUserListByID (
    id As Guid
) As DedUserList
public:
DedUserList^ FindUserListByID(
    Guid id
)
member FindUserListByID :
        id : Guid -> DedUserList

Parametri

id Guid
Identificativo

Valore di ritorno

DedUserList
Vedi anche

Documentazione

Classe DedListManager
Namespace DedNet.Core


Metodo DedListManager.FindUserListByList

Metodo DedListManagerFindUserListByList
Restituisce tutte le liste utente appartenenti ad una determinata lista.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<DedUserList> FindUserListByList(
    DedList list
)
Public Function FindUserListByList (
    list As DedList
) As List(Of DedUserList)
public:
List<DedUserList^>^ FindUserListByList(
    DedList^ list
)
member FindUserListByList :
        list : DedList -> List<DedUserList>

Parametri

list DedList
Lista

Valore di ritorno

List DedUserList
Vedi anche

Documentazione

Classe DedListManager
Namespace DedNet.Core


Metodo DedListManager.GetElaborationTypeFromString

Metodo DedListManagerGetElaborationTypeFromString
Ritorna il valore corrispondente alla stringa passata in ListElaborationTypeEnum. Se non la trova ritorna Anagrafica di default.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ListElaborationTypeEnum GetElaborationTypeFromString(
    string str
)
Public Function GetElaborationTypeFromString (
    str As String
) As ListElaborationTypeEnum
public:
ListElaborationTypeEnum GetElaborationTypeFromString(
    String^ str
)
member GetElaborationTypeFromString :
        str : string -> ListElaborationTypeEnum

Parametri

str String
Stringa da convertire.

Valore di ritorno

ListElaborationTypeEnum
Vedi anche

Documentazione

Classe DedListManager
Namespace DedNet.Core


Metodo DedListManager.LoadDedLists

Metodo DedListManagerLoadDedLists
Carica le liste

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void LoadDedLists()
Public Sub LoadDedLists
public:
void LoadDedLists()
member LoadDedLists : unit -> unit
Vedi anche

Documentazione

Classe DedListManager
Namespace DedNet.Core


Metodo DedListManager.LoadDedUserLists

Metodo DedListManagerLoadDedUserLists
Carica le liste dell'utente collegato

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void LoadDedUserLists()
Public Sub LoadDedUserLists
public:
void LoadDedUserLists()
member LoadDedUserLists : unit -> unit
Vedi anche

Documentazione

Classe DedListManager
Namespace DedNet.Core


Metodo DedListManager.ReadBomDefinitions

Metodo DedListManagerReadBomDefinitions
Metodo per leggere le varie tipologie di distinta

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ReadBomDefinitions()
Public Sub ReadBomDefinitions
public:
void ReadBomDefinitions()
member ReadBomDefinitions : unit -> unit
Vedi anche

Documentazione

Classe DedListManager
Namespace DedNet.Core


Classe DedListManager.BomInfo

Classe DedListManagerBomInfo
Classe per gestire le informazioni delle distinte
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedListManagerBomInfo

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class BomInfo
Public Class BomInfo
public ref class BomInfo
type BomInfo = class end

Il tipo DedListManagerBomInfo espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedListManagerBomInfo | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AttribIdx | Dizionario con attributo e relativa posizione
Proprietà pubblica | Name | Nome interno
Proprietà pubblica | Prompt | Promot
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedListManager.BomInfo

Costruttore DedListManagerBomInfo
Costruttore

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomInfo(
    string name,
    string prompt
)
Public Sub New (
    name As String,
    prompt As String
)
public:
BomInfo(
    String^ name,
    String^ prompt
)
new :
        name : string *
        prompt : string -> BomInfo

Parametri

name String
Nome interno
prompt String
Prompt
Vedi anche

Documentazione

Classe DedListManagerBomInfo
Namespace DedNet.Core


Proprietà di BomInfo

Il tipo DedListManagerBomInfo espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AttribIdx | Dizionario con attributo e relativa posizione
Proprietà pubblica | Name | Nome interno
Proprietà pubblica | Prompt | Promot
Torna su
Vedi anche

Documentazione

Classe DedListManagerBomInfo
Namespace DedNet.Core


Proprietà DedListManager.BomInfo.AttribIdx

Proprietà DedListManagerBomInfoAttribIdx
Dizionario con attributo e relativa posizione

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<string, int> AttribIdx { get; set; }
Public Property AttribIdx As Dictionary(Of String, Integer)
    Get
    Set
public:
property Dictionary<String^, int>^ AttribIdx {
    Dictionary<String^, int>^ get ();
    void set (Dictionary<String^, int>^ value);
}
member AttribIdx : Dictionary<string, int> with get, set

Valore della proprietà

Dictionary String, Int32
Vedi anche

Documentazione

Classe DedListManagerBomInfo
Namespace DedNet.Core


Proprietà DedListManager.BomInfo.Name

Proprietà DedListManagerBomInfoName
Nome interno

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedListManagerBomInfo
Namespace DedNet.Core


Proprietà DedListManager.BomInfo.Prompt

Proprietà DedListManagerBomInfoPrompt
Promot

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Prompt { get; set; }
Public Property Prompt As String
    Get
    Set
public:
property String^ Prompt {
    String^ get ();
    void set (String^ value);
}
member Prompt : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedListManagerBomInfo
Namespace DedNet.Core


Classe DedListManager.BomInfoList

Classe DedListManagerBomInfoList
Lista contentente tutte le tipologie di distinte
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList DedListManagerBomInfo
DedNet.CoreDedListManagerBomInfoList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class BomInfoList : List<DedListManagerBomInfo>
Public Class BomInfoList
    Inherits List(Of DedListManagerBomInfo)
public ref class BomInfoList : public List<DedListManagerBomInfo^>
type BomInfoList =
    class
        inherit List<DedListManagerBomInfo>
    end

Il tipo DedListManagerBomInfoList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedListManagerBomInfoList |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | FindBomByName |
Metodo pubblico | FindBomByPrompt |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedListManager.BomInfoList

Costruttore DedListManagerBomInfoList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomInfoList()
Public Sub New
public:
BomInfoList()
new : unit -> BomInfoList
Vedi anche

Documentazione

Classe DedListManagerBomInfoList
Namespace DedNet.Core


Metodi di BomInfoList

Il tipo DedListManagerBomInfoList espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | FindBomByName |
Metodo pubblico | FindBomByPrompt |
Torna su
Vedi anche

Documentazione

Classe DedListManagerBomInfoList
Namespace DedNet.Core


Metodo DedListManager.BomInfoList.FindBomByName

Metodo DedListManagerBomInfoListFindBomByName

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedListManagerBomInfo FindBomByName(
    string name
)
Public Function FindBomByName (
    name As String
) As DedListManagerBomInfo
public:
DedListManagerBomInfo^ FindBomByName(
    String^ name
)
member FindBomByName :
        name : string -> DedListManagerBomInfo

Parametri

name String

Valore di ritorno

DedListManagerBomInfo
Vedi anche

Documentazione

Classe DedListManagerBomInfoList
Namespace DedNet.Core


Metodo DedListManager.BomInfoList.FindBomByPrompt

Metodo DedListManagerBomInfoListFindBomByPrompt

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedListManagerBomInfo FindBomByPrompt(
    string prompt
)
Public Function FindBomByPrompt (
    prompt As String
) As DedListManagerBomInfo
public:
DedListManagerBomInfo^ FindBomByPrompt(
    String^ prompt
)
member FindBomByPrompt :
        prompt : string -> DedListManagerBomInfo

Parametri

prompt String

Valore di ritorno

DedListManagerBomInfo
Vedi anche

Documentazione

Classe DedListManagerBomInfoList
Namespace DedNet.Core


Enumerazione DedListManager.TipoDati

Enumerazione DedListManagerTipoDati
Tipologie di dato per extra info

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum TipoDati
Public Enumeration TipoDati
public enum class TipoDati
type TipoDati
Membri
Nome | Valore | Descrizione
String | 0 |
Int | 1 |
Double | 2 |
Boolean | 3 |
DateTime | 4 |
Vedi anche

Documentazione

Namespace DedNet.Core


Classe DedListType
Lista di tipologie
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedListType

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedListType
Public Class DedListType
public ref class DedListType
type DedListType = class end

Il tipo DedListType espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedListType | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | DbIndexField | Restituisce il campo usato come DbIndex in base alla tipologia
Proprietà pubblica | ItemType | Tipologia oggetti elaborati (DedData)
Proprietà pubblica | Nome | Nome della tipologia
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedListType
Costruttore

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedListType(
    string nome,
    ListItemTypeEnum itemtype
)
Public Sub New (
    nome As String,
    itemtype As ListItemTypeEnum
)
public:
DedListType(
    String^ nome,
    ListItemTypeEnum itemtype
)
new :
        nome : string *
        itemtype : ListItemTypeEnum -> DedListType

Parametri

nome String
Nome della tipologia
itemtype ListItemTypeEnum
Tipologia di elementi
Vedi anche

Documentazione

Classe DedListType
Namespace DedNet.Core


Proprietà di DedListType

Il tipo DedListType espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | DbIndexField | Restituisce il campo usato come DbIndex in base alla tipologia
Proprietà pubblica | ItemType | Tipologia oggetti elaborati (DedData)
Proprietà pubblica | Nome | Nome della tipologia
Torna su
Vedi anche

Documentazione

Classe DedListType
Namespace DedNet.Core


Proprietà DedListType.DbIndexField

Proprietà DedListTypeDbIndexField
Restituisce il campo usato come DbIndex in base alla tipologia

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string DbIndexField { get; }
Public ReadOnly Property DbIndexField As String
    Get
public:
property String^ DbIndexField {
    String^ get ();
}
member DbIndexField : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedListType
Namespace DedNet.Core


Proprietà DedListType.ItemType

Proprietà DedListTypeItemType
Tipologia oggetti elaborati (DedData)

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ListItemTypeEnum ItemType { get; set; }
Public Property ItemType As ListItemTypeEnum
    Get
    Set
public:
property ListItemTypeEnum ItemType {
    ListItemTypeEnum get ();
    void set (ListItemTypeEnum value);
}
member ItemType : ListItemTypeEnum with get, set

Valore della proprietà

ListItemTypeEnum
Vedi anche

Documentazione

Classe DedListType
Namespace DedNet.Core


Proprietà DedListType.Nome

Proprietà DedListTypeNome
Nome della tipologia

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Nome { get; set; }
Public Property Nome As String
    Get
    Set
public:
property String^ Nome {
    String^ get ();
    void set (String^ value);
}
member Nome : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedListType
Namespace DedNet.Core


Classe DedLogManager
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedLogManager

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedLogManager
Public Class DedLogManager
public ref class DedLogManager
type DedLogManager = class end

Il tipo DedLogManager espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedLogManager | Crea una nuova istanza della classe 'DedLogManager'.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | TableName | Ritorna il nome della tabella nel db.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Read | Legge dalla tabella DED_LOG tutte le loggate che si riferiscono al modulo passato. Se quest'ultimo è vuoto, legge e ritorna tutte le loggate nella tabella.
Metodo pubblico | Write(String, LogMessageTypeEnum) | Ritorna tutte le traduzioni associate all'anagrafica specificata in ingresso.
Metodo pubblico | Write(String, String, LogMessageTypeEnum) | Ritorna tutte le traduzioni associate all'anagrafica specificata in ingresso.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedLogManager
Crea una nuova istanza della classe 'DedLogManager'.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedLogManager(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedLogManager(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedLogManager

Parametri

app DedNetApplication
Applicazione DedNet.
Vedi anche

Documentazione

Classe DedLogManager
Namespace DedNet.Core


Proprietà di DedLogManager

Il tipo DedLogManager espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | TableName | Ritorna il nome della tabella nel db.
Torna su
Vedi anche

Documentazione

Classe DedLogManager
Namespace DedNet.Core


Proprietà DedLogManager.TableName

Proprietà DedLogManagerTableName
Ritorna il nome della tabella nel db.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string TableName { get; }
Public ReadOnly Property TableName As String
    Get
public:
property String^ TableName {
    String^ get ();
}
member TableName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedLogManager
Namespace DedNet.Core


Metodi di DedLogManager

Il tipo DedLogManager espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Read | Legge dalla tabella DED_LOG tutte le loggate che si riferiscono al modulo passato. Se quest'ultimo è vuoto, legge e ritorna tutte le loggate nella tabella.
Metodo pubblico | Write(String, LogMessageTypeEnum) | Ritorna tutte le traduzioni associate all'anagrafica specificata in ingresso.
Metodo pubblico | Write(String, String, LogMessageTypeEnum) | Ritorna tutte le traduzioni associate all'anagrafica specificata in ingresso.
Torna su
Vedi anche

Documentazione

Classe DedLogManager
Namespace DedNet.Core


Metodo DedLogManager.Read

Metodo DedLogManagerRead
Legge dalla tabella DED_LOG tutte le loggate che si riferiscono al modulo passato. Se quest'ultimo è vuoto, legge e ritorna tutte le loggate nella tabella.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DataTable Read(
    string module = ""
)
Public Function Read (
    Optional module As String = ""
) As DataTable
public:
DataTable^ Read(
    String^ module = L""
)
member Read :
        ?module : string
(* Defaults:
        let _module = defaultArg module ""
*)
-> DataTable

Parametri

module String (Optional)

Valore di ritorno

DataTable
Vedi anche

Documentazione

Classe DedLogManager
Namespace DedNet.Core


Metodo DedLogManager.Write

Metodo DedLogManagerWrite
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Write(String, LogMessageTypeEnum) | Ritorna tutte le traduzioni associate all'anagrafica specificata in ingresso.
Metodo pubblico | Write(String, String, LogMessageTypeEnum) | Ritorna tutte le traduzioni associate all'anagrafica specificata in ingresso.
Torna su
Vedi anche

Documentazione

Classe DedLogManager
Namespace DedNet.Core


Metodo DedLogManager.Write(String, LogMessageTypeEnum)

Metodo DedLogManagerWrite(String, LogMessageTypeEnum)
Ritorna tutte le traduzioni associate all'anagrafica specificata in ingresso.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Write(
    string msg,
    LogMessageTypeEnum severity
)
Public Sub Write (
    msg As String,
    severity As LogMessageTypeEnum
)
public:
void Write(
    String^ msg,
    LogMessageTypeEnum severity
)
member Write :
        msg : string *
        severity : LogMessageTypeEnum -> unit

Parametri

msg String
severity LogMessageTypeEnum
Vedi anche

Documentazione

Classe DedLogManager
Overload di Write
Namespace DedNet.Core


Metodo DedLogManager.Write(String, String, LogMessageTypeEnum)

Metodo DedLogManagerWrite(String, String, LogMessageTypeEnum)
Ritorna tutte le traduzioni associate all'anagrafica specificata in ingresso.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Write(
    string msg,
    string module,
    LogMessageTypeEnum severity
)
Public Sub Write (
    msg As String,
    module As String,
    severity As LogMessageTypeEnum
)
public:
void Write(
    String^ msg,
    String^ module,
    LogMessageTypeEnum severity
)
member Write :
        msg : string *
        module : string *
        severity : LogMessageTypeEnum -> unit

Parametri

msg String
module String
severity LogMessageTypeEnum
Vedi anche

Documentazione

Classe DedLogManager
Overload di Write
Namespace DedNet.Core


Classe DedNotifies
Gestione delle notifiche.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedDbCollectionBase DedNotify
DedNet.CoreDedNotifies

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedNotifies : DedDbCollectionBase<DedNotify>
Public Class DedNotifies
    Inherits DedDbCollectionBase(Of DedNotify)
public ref class DedNotifies : public DedDbCollectionBase<DedNotify^>
type DedNotifies =
    class
        inherit DedDbCollectionBase<DedNotify>
    end

Il tipo DedNotifies espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllowsDuplicates | Restituisce se siano ammessi duplicati all'interno della lista. Se false viene sollevata una eccezione su tentativo di inserimento duplicati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Application | Restituisce l'oggetto applicazione di appartenza. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Count | Restituisce il numero di elementi presenti. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Dirty | Restituisce se la collezione o uno dei suoi elementi sia stata modificata. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | ErasedItems | Restitusice la lista in sola lettura degli elementi che risultano attualmente cancellati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | LastItem | Restituisce l'ultimo elemento della collezione oppure null se non ci sono elementi. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | NotifyEnabled | Restituisce la lista delle notifiche abilitate
Proprietà pubblica | RestoreErased | Restituisce se gli elementi cancellati devono essere ripristinati in caso vengano riaggiunti. (Ereditato da DedDbCollectionBaseT)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Add(String, DedNotifyNotifyEvent, String, String, String, String) | Aggiunge un nuovo elemento alla collezione e lo restituisce.
Metodo pubblico | Add(String, DedNotifyNotifyEvent, String, String, String, String, DedNotifyNotifyStateEnum) | Aggiunge un nuovo elemento alla collezione e lo restituisce.
Metodo protetto | AddForClone | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto SENZA MODIFICARNE LO STATO. Le classi derivate potranno utilizzare questo metodo per clonare la collezione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddNewElement | DI USO INTERNO. Aggiunge un elemento alla lista rendendo dirty l'oggetto. L'elemento viene aggiunto con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere un elemento alla lista. Dovranno loro stesse avere un metodo pubblico Add() che prenda i parametri necessari alla costruzione dell'oggetto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddRangeNewElement | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi rendendo dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere più elementi alla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddUnModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Clear | Elimina tutti gli elementi dalla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ClearRefresh | Svuota la lista impostando Dirty = false. Di fatto permette di effettuare un refresh della lista e quindi di ricaricarla. Serve per svuotare la lista e reinizializzarla da capo. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Contains | Verifica l'esistenza di un valore all'interno della lista degli elementi. Le classi derivate devono effettuarne l'override nel caso in cui l'elemento non implementi GetHashCode() per l'uso all'interno dei dizionarii. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | CopyTo | Copia un range di elementi in un array. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | CreateDeleteCommand | Crea il comando di delete per un elemento. (Sovrascrive DedDbCollectionBaseTCreateDeleteCommand(T))
Metodo protetto | CreateInsertCommand | Crea il comando di insert per un elemento. (Sovrascrive DedDbCollectionBaseTCreateInsertCommand(T))
Metodo protetto | CreateUpdateCommand | Crea il comando di update per un elemento. (Sovrascrive DedDbCollectionBaseTCreateUpdateCommand(T))
Metodo pubblico | CustomSort | Ordina la lista in base al comparatore passato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteDeleteItem | Esegue l'eliminazione di un elemento. Crea il comando tramite il metodo CreateDeleteCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteInsertItem | Esegue l'inserimento di un elemento. Crea il comando tramite il metodo CreateInsertCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteUpdateItem | Esegue l'aggiornamento di un elemento. Crea il comando tramite il metodo CreateUpdateCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | ExistsNotify | Metodo che ritorna True se esiste una notifica associata all'evento passato in ingresso, False altrimenti.
Metodo pubblico | Find | Restituisce l'oggetto cercato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FindAll | Restitusice la lista degli elementi che corrispondono al predicato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | GetDbIndex | Restitusice l'indice di un elemento. (Sovrascrive DedDbCollectionBaseTGetDbIndex(T))
Metodo pubblico | GetEnumerator | Restituisce l'enumeratore della collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | IndexOf | Restituisce l'indice dell'elemento richiesto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InsertUnModified | DI USO INTERNO. Inserisce un elemento alla lista senza rendere dirty l'oggetto, all'indice specificato. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Item | Restituisce l'elemento iesimo della lista. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean) | Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean, Int32) | Sposta l'elemento dell'indice passato prima o dopo del numero di posizioni passate. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSave | Metodo Template chiamato dopo il salvataggio avvenuto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSaveNoChanges | Metodo Template chiamato dopo il salvataggio senza modifiche. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnBeforeSave | Metodo Template chiamato prima del salvataggio. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(T) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(DedEditableObjectT) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(T) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(DedEditableObjectT) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ReInitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Remove | Elimina un elemento dalla collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Ripristina | Verifica che l'elemento sia presente negli eliminati e lo toglie da lì e lo riaggiunge in coda alla lista degli elementi validi. Solleva una eccezione se l'elemento è già presente nella lista e AllowsDuplicates = false. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Save | Salva l'oggetto con tutta la sua lista, solo se questo risulta dirty. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | SendCustomMailWithSmtpSettings(String, ListDedUser, String, String, ListString) | Permette di inviare un'email con le credenziali presenti nelle impostazioni SMTP del Gestore notifiche.
Metodo pubblico | SendCustomMailWithSmtpSettings(String, String, String, String, String, ListString, Boolean) | Permette di inviare un'email con le credenziali presenti nelle impostazioni SMTP del Gestore notifiche.
Metodo pubblico | SendMail(DedNotifyNotifyEvent, DedEco, ListDedUser) | Controlla se è presente una notifica per l'evento passato e nel caso la invia.
Metodo pubblico | SendMail(DedNotifyNotifyEvent, DedDataList, DedCommList, ListDedUser) | Controlla se è presente una notifica per l'evento passato e nel caso la invia.
Metodo pubblico | SendMailCustomizedEvent | Controlla se è presente una notifica personalizzata con il nome passato e nel caso la invia.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di DedNotifies

Il tipo DedNotifies espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllowsDuplicates | Restituisce se siano ammessi duplicati all'interno della lista. Se false viene sollevata una eccezione su tentativo di inserimento duplicati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Application | Restituisce l'oggetto applicazione di appartenza. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Count | Restituisce il numero di elementi presenti. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Dirty | Restituisce se la collezione o uno dei suoi elementi sia stata modificata. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | ErasedItems | Restitusice la lista in sola lettura degli elementi che risultano attualmente cancellati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | LastItem | Restituisce l'ultimo elemento della collezione oppure null se non ci sono elementi. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | NotifyEnabled | Restituisce la lista delle notifiche abilitate
Proprietà pubblica | RestoreErased | Restituisce se gli elementi cancellati devono essere ripristinati in caso vengano riaggiunti. (Ereditato da DedDbCollectionBaseT)
Torna su
Vedi anche

Documentazione

Classe DedNotifies
Namespace DedNet.Core


Proprietà DedNotifies.NotifyEnabled

Proprietà DedNotifiesNotifyEnabled
Restituisce la lista delle notifiche abilitate

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public IEnumerable<DedNotify> NotifyEnabled { get; }
Public ReadOnly Property NotifyEnabled As IEnumerable(Of DedNotify)
    Get
public:
property IEnumerable<DedNotify^>^ NotifyEnabled {
    IEnumerable<DedNotify^>^ get ();
}
member NotifyEnabled : IEnumerable<DedNotify> with get

Valore della proprietà

IEnumerable DedNotify
Vedi anche

Documentazione

Classe DedNotifies
Namespace DedNet.Core


Metodi di DedNotifies

Il tipo DedNotifies espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Add(String, DedNotifyNotifyEvent, String, String, String, String) | Aggiunge un nuovo elemento alla collezione e lo restituisce.
Metodo pubblico | Add(String, DedNotifyNotifyEvent, String, String, String, String, DedNotifyNotifyStateEnum) | Aggiunge un nuovo elemento alla collezione e lo restituisce.
Metodo protetto | AddForClone | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto SENZA MODIFICARNE LO STATO. Le classi derivate potranno utilizzare questo metodo per clonare la collezione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddNewElement | DI USO INTERNO. Aggiunge un elemento alla lista rendendo dirty l'oggetto. L'elemento viene aggiunto con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere un elemento alla lista. Dovranno loro stesse avere un metodo pubblico Add() che prenda i parametri necessari alla costruzione dell'oggetto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddRangeNewElement | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi rendendo dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere più elementi alla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddUnModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Clear | Elimina tutti gli elementi dalla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ClearRefresh | Svuota la lista impostando Dirty = false. Di fatto permette di effettuare un refresh della lista e quindi di ricaricarla. Serve per svuotare la lista e reinizializzarla da capo. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Contains | Verifica l'esistenza di un valore all'interno della lista degli elementi. Le classi derivate devono effettuarne l'override nel caso in cui l'elemento non implementi GetHashCode() per l'uso all'interno dei dizionarii. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | CopyTo | Copia un range di elementi in un array. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | CreateDeleteCommand | Crea il comando di delete per un elemento. (Sovrascrive DedDbCollectionBaseTCreateDeleteCommand(T))
Metodo protetto | CreateInsertCommand | Crea il comando di insert per un elemento. (Sovrascrive DedDbCollectionBaseTCreateInsertCommand(T))
Metodo protetto | CreateUpdateCommand | Crea il comando di update per un elemento. (Sovrascrive DedDbCollectionBaseTCreateUpdateCommand(T))
Metodo pubblico | CustomSort | Ordina la lista in base al comparatore passato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteDeleteItem | Esegue l'eliminazione di un elemento. Crea il comando tramite il metodo CreateDeleteCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteInsertItem | Esegue l'inserimento di un elemento. Crea il comando tramite il metodo CreateInsertCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteUpdateItem | Esegue l'aggiornamento di un elemento. Crea il comando tramite il metodo CreateUpdateCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | ExistsNotify | Metodo che ritorna True se esiste una notifica associata all'evento passato in ingresso, False altrimenti.
Metodo pubblico | Find | Restituisce l'oggetto cercato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FindAll | Restitusice la lista degli elementi che corrispondono al predicato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | GetDbIndex | Restitusice l'indice di un elemento. (Sovrascrive DedDbCollectionBaseTGetDbIndex(T))
Metodo pubblico | GetEnumerator | Restituisce l'enumeratore della collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | IndexOf | Restituisce l'indice dell'elemento richiesto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InsertUnModified | DI USO INTERNO. Inserisce un elemento alla lista senza rendere dirty l'oggetto, all'indice specificato. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Item | Restituisce l'elemento iesimo della lista. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean) | Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean, Int32) | Sposta l'elemento dell'indice passato prima o dopo del numero di posizioni passate. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSave | Metodo Template chiamato dopo il salvataggio avvenuto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSaveNoChanges | Metodo Template chiamato dopo il salvataggio senza modifiche. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnBeforeSave | Metodo Template chiamato prima del salvataggio. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(T) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(DedEditableObjectT) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(T) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(DedEditableObjectT) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ReInitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Remove | Elimina un elemento dalla collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Ripristina | Verifica che l'elemento sia presente negli eliminati e lo toglie da lì e lo riaggiunge in coda alla lista degli elementi validi. Solleva una eccezione se l'elemento è già presente nella lista e AllowsDuplicates = false. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Save | Salva l'oggetto con tutta la sua lista, solo se questo risulta dirty. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | SendCustomMailWithSmtpSettings(String, ListDedUser, String, String, ListString) | Permette di inviare un'email con le credenziali presenti nelle impostazioni SMTP del Gestore notifiche.
Metodo pubblico | SendCustomMailWithSmtpSettings(String, String, String, String, String, ListString, Boolean) | Permette di inviare un'email con le credenziali presenti nelle impostazioni SMTP del Gestore notifiche.
Metodo pubblico | SendMail(DedNotifyNotifyEvent, DedEco, ListDedUser) | Controlla se è presente una notifica per l'evento passato e nel caso la invia.
Metodo pubblico | SendMail(DedNotifyNotifyEvent, DedDataList, DedCommList, ListDedUser) | Controlla se è presente una notifica per l'evento passato e nel caso la invia.
Metodo pubblico | SendMailCustomizedEvent | Controlla se è presente una notifica personalizzata con il nome passato e nel caso la invia.
Torna su
Vedi anche

Documentazione

Classe DedNotifies
Namespace DedNet.Core


Metodo DedNotifies.Add

Metodo DedNotifiesAdd
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Add(String, DedNotifyNotifyEvent, String, String, String, String) | Aggiunge un nuovo elemento alla collezione e lo restituisce.
Metodo pubblico | Add(String, DedNotifyNotifyEvent, String, String, String, String, DedNotifyNotifyStateEnum) | Aggiunge un nuovo elemento alla collezione e lo restituisce.
Torna su
Vedi anche

Documentazione

Classe DedNotifies
Namespace DedNet.Core


Metodo DedNotifies.Add(String, DedNotify.NotifyEvent, String, String, String, String)

Metodo DedNotifiesAdd(String, DedNotifyNotifyEvent, String, String, String, String)
Aggiunge un nuovo elemento alla collezione e lo restituisce.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedNotify Add(
    string name,
    DedNotifyNotifyEvent ev,
    string to,
    string obj,
    string body,
    string attachments
)
Public Function Add (
    name As String,
    ev As DedNotifyNotifyEvent,
    to As String,
    obj As String,
    body As String,
    attachments As String
) As DedNotify
public:
DedNotify^ Add(
    String^ name,
    DedNotifyNotifyEvent ev,
    String^ to,
    String^ obj,
    String^ body,
    String^ attachments
)
member Add :
        name : string *
        ev : DedNotifyNotifyEvent *
        to : string *
        obj : string *
        body : string *
        attachments : string -> DedNotify

Parametri

name String
Nome.
ev DedNotifyNotifyEvent
Evento.
to String
Destinatari.
obj String
Oggetto della mail.
body String
Corpo della mail.
attachments String
Eventuali allegati

Valore di ritorno

DedNotify
Vedi anche

Documentazione

Classe DedNotifies
Overload di Add
Namespace DedNet.Core


Metodo DedNotifies.Add(String, DedNotify.NotifyEvent, String, String, String, String, DedNotify.NotifyStateEnum)

Metodo DedNotifiesAdd(String, DedNotifyNotifyEvent, String, String, String, String, DedNotifyNotifyStateEnum)
Aggiunge un nuovo elemento alla collezione e lo restituisce.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedNotify Add(
    string name,
    DedNotifyNotifyEvent ev,
    string to,
    string obj,
    string body,
    string attachments,
    DedNotifyNotifyStateEnum state
)
Public Function Add (
    name As String,
    ev As DedNotifyNotifyEvent,
    to As String,
    obj As String,
    body As String,
    attachments As String,
    state As DedNotifyNotifyStateEnum
) As DedNotify
public:
DedNotify^ Add(
    String^ name,
    DedNotifyNotifyEvent ev,
    String^ to,
    String^ obj,
    String^ body,
    String^ attachments,
    DedNotifyNotifyStateEnum state
)
member Add :
        name : string *
        ev : DedNotifyNotifyEvent *
        to : string *
        obj : string *
        body : string *
        attachments : string *
        state : DedNotifyNotifyStateEnum -> DedNotify

Parametri

name String
Nome.
ev DedNotifyNotifyEvent
Evento.
to String
Destinatari.
obj String
Oggetto della mail.
body String
Corpo della mail.
attachments String
Eventuali allegati
state DedNotifyNotifyStateEnum
Stato della notifica

Valore di ritorno

DedNotify
Vedi anche

Documentazione

Classe DedNotifies
Overload di Add
Namespace DedNet.Core


Metodo DedNotifies.CreateDeleteCommand

Metodo DedNotifiesCreateDeleteCommand
Crea il comando di delete per un elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSDeleteCommand CreateDeleteCommand(
    DedNotify item
)
Protected Overrides Function CreateDeleteCommand (
    item As DedNotify
) As QSDeleteCommand
protected:
virtual QSDeleteCommand^ CreateDeleteCommand(
    DedNotify^ item
) override
abstract CreateDeleteCommand :
        item : DedNotify -> QSDeleteCommand
override CreateDeleteCommand :
        item : DedNotify -> QSDeleteCommand

Parametri

item DedNotify
Elemento per il quale creare il comando.

Valore di ritorno

QSDeleteCommand
Vedi anche

Documentazione

Classe DedNotifies
Namespace DedNet.Core


Metodo DedNotifies.CreateInsertCommand

Metodo DedNotifiesCreateInsertCommand
Crea il comando di insert per un elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSInsertCommand CreateInsertCommand(
    DedNotify item
)
Protected Overrides Function CreateInsertCommand (
    item As DedNotify
) As QSInsertCommand
protected:
virtual QSInsertCommand^ CreateInsertCommand(
    DedNotify^ item
) override
abstract CreateInsertCommand :
        item : DedNotify -> QSInsertCommand
override CreateInsertCommand :
        item : DedNotify -> QSInsertCommand

Parametri

item DedNotify
Elemento per il quale creare il comando.

Valore di ritorno

QSInsertCommand
Vedi anche

Documentazione

Classe DedNotifies
Namespace DedNet.Core


Metodo DedNotifies.CreateUpdateCommand

Metodo DedNotifiesCreateUpdateCommand
Crea il comando di update per un elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSUpdateCommand CreateUpdateCommand(
    DedNotify item
)
Protected Overrides Function CreateUpdateCommand (
    item As DedNotify
) As QSUpdateCommand
protected:
virtual QSUpdateCommand^ CreateUpdateCommand(
    DedNotify^ item
) override
abstract CreateUpdateCommand :
        item : DedNotify -> QSUpdateCommand
override CreateUpdateCommand :
        item : DedNotify -> QSUpdateCommand

Parametri

item DedNotify
Elemento per il quale creare il comando.

Valore di ritorno

QSUpdateCommand
Vedi anche

Documentazione

Classe DedNotifies
Namespace DedNet.Core


Metodo DedNotifies.ExistsNotify

Metodo DedNotifiesExistsNotify
Metodo che ritorna True se esiste una notifica associata all'evento passato in ingresso, False altrimenti.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ExistsNotify(
    DedNotifyNotifyEvent eventToSend
)
Public Function ExistsNotify (
    eventToSend As DedNotifyNotifyEvent
) As Boolean
public:
bool ExistsNotify(
    DedNotifyNotifyEvent eventToSend
)
member ExistsNotify :
        eventToSend : DedNotifyNotifyEvent -> bool

Parametri

eventToSend DedNotifyNotifyEvent
Evento da controllare.

Valore di ritorno

Boolean
True: esiste una notifica associata; False: non esiste nessuna notifica associata.
Vedi anche

Documentazione

Classe DedNotifies
Namespace DedNet.Core


Metodo DedNotifies.GetDbIndex

Metodo DedNotifiesGetDbIndex
Restitusice l'indice di un elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override Object GetDbIndex(
    DedNotify item
)
Protected Overrides Function GetDbIndex (
    item As DedNotify
) As Object
protected:
virtual Object^ GetDbIndex(
    DedNotify^ item
) override
abstract GetDbIndex :
        item : DedNotify -> Object
override GetDbIndex :
        item : DedNotify -> Object

Parametri

item DedNotify
Elemento per il quale restituire l'indice.

Valore di ritorno

Object
Vedi anche

Documentazione

Classe DedNotifies
Namespace DedNet.Core


Metodo DedNotifies.SendCustomMailWithSmtpSettings

Metodo DedNotifiesSendCustomMailWithSmtpSettings
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | SendCustomMailWithSmtpSettings(String, ListDedUser, String, String, ListString) | Permette di inviare un'email con le credenziali presenti nelle impostazioni SMTP del Gestore notifiche.
Metodo pubblico | SendCustomMailWithSmtpSettings(String, String, String, String, String, ListString, Boolean) | Permette di inviare un'email con le credenziali presenti nelle impostazioni SMTP del Gestore notifiche.
Torna su
Vedi anche

Documentazione

Classe DedNotifies
Namespace DedNet.Core


Metodo DedNotifies.SendCustomMailWithSmtpSettings(String, List<DedUser>, String, String, List<String>)

Metodo DedNotifiesSendCustomMailWithSmtpSettings(String, ListDedUser, String, String, ListString)
Permette di inviare un'email con le credenziali presenti nelle impostazioni SMTP del Gestore notifiche.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SendCustomMailWithSmtpSettings(
    string rawto,
    List<DedUser> users,
    string obj,
    string body,
    List<string> files
)
Public Sub SendCustomMailWithSmtpSettings (
    rawto As String,
    users As List(Of DedUser),
    obj As String,
    body As String,
    files As List(Of String)
)
public:
void SendCustomMailWithSmtpSettings(
    String^ rawto,
    List<DedUser^>^ users,
    String^ obj,
    String^ body,
    List<String^>^ files
)
member SendCustomMailWithSmtpSettings :
        rawto : string *
        users : List<DedUser> *
        obj : string *
        body : string *
        files : List<string> -> unit

Parametri

rawto String
Lista di placeholder $USER$ oppure email
users List DedUser
Lista di utenti aggiuntivi da notificare
obj String
Oggetto del messaggio
body String
Corpo del messagggio
files List String
Lista dei file da inviare
Vedi anche

Documentazione

Classe DedNotifies
Overload di SendCustomMailWithSmtpSettings
Namespace DedNet.Core


Metodo DedNotifies.SendCustomMailWithSmtpSettings(String, String, String, String, String, List<String>, Boolean)

Metodo DedNotifiesSendCustomMailWithSmtpSettings(String, String, String, String, String, ListString, Boolean)
Permette di inviare un'email con le credenziali presenti nelle impostazioni SMTP del Gestore notifiche.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool SendCustomMailWithSmtpSettings(
    string to,
    string cc,
    string ccn,
    string obj,
    string body,
    List<string> files,
    bool async = false
)
Public Function SendCustomMailWithSmtpSettings (
    to As String,
    cc As String,
    ccn As String,
    obj As String,
    body As String,
    files As List(Of String),
    Optional async As Boolean = false
) As Boolean
public:
bool SendCustomMailWithSmtpSettings(
    String^ to,
    String^ cc,
    String^ ccn,
    String^ obj,
    String^ body,
    List<String^>^ files,
    bool async = false
)
member SendCustomMailWithSmtpSettings :
        to : string *
        cc : string *
        ccn : string *
        obj : string *
        body : string *
        files : List<string> *
        ?async : bool
(* Defaults:
        let _async = defaultArg async false
*)
-> bool

Parametri

to String
Destinatari separati da ,
cc String
Destinatari separati da ,
ccn String
Destinatari separati da ,
obj String
Oggetto del messaggio
body String
Corpo del messagggio
files List String
Lista dei file da inviare
async Boolean (Optional)

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedNotifies
Overload di SendCustomMailWithSmtpSettings
Namespace DedNet.Core


Metodo DedNotifies.SendMail

Metodo DedNotifiesSendMail
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | SendMail(DedNotifyNotifyEvent, DedEco, ListDedUser) | Controlla se è presente una notifica per l'evento passato e nel caso la invia.
Metodo pubblico | SendMail(DedNotifyNotifyEvent, DedDataList, DedCommList, ListDedUser) | Controlla se è presente una notifica per l'evento passato e nel caso la invia.
Torna su
Vedi anche

Documentazione

Classe DedNotifies
Namespace DedNet.Core


Metodo DedNotifies.SendMail(DedNotify.NotifyEvent, DedEco, List<DedUser>)

Metodo DedNotifiesSendMail(DedNotifyNotifyEvent, DedEco, ListDedUser)
Controlla se è presente una notifica per l'evento passato e nel caso la invia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SendMail(
    DedNotifyNotifyEvent eventToSend,
    DedEco eco,
    List<DedUser> users
)
Public Sub SendMail (
    eventToSend As DedNotifyNotifyEvent,
    eco As DedEco,
    users As List(Of DedUser)
)
public:
void SendMail(
    DedNotifyNotifyEvent eventToSend,
    DedEco^ eco,
    List<DedUser^>^ users
)
member SendMail :
        eventToSend : DedNotifyNotifyEvent *
        eco : DedEco *
        users : List<DedUser> -> unit

Parametri

eventToSend DedNotifyNotifyEvent
Evento da controllare.
eco DedEco
Eco in gioco (da usare per sostituire i valori).
users List DedUser
Lista degli utenti da aggiungere all'elenco dei notificati.
Vedi anche

Documentazione

Classe DedNotifies
Overload di SendMail
Namespace DedNet.Core


Metodo DedNotifies.SendMail(DedNotify.NotifyEvent, DedDataList, DedCommList, List<DedUser>)

Metodo DedNotifiesSendMail(DedNotifyNotifyEvent, DedDataList, DedCommList, ListDedUser)
Controlla se è presente una notifica per l'evento passato e nel caso la invia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SendMail(
    DedNotifyNotifyEvent eventToSend,
    DedDataList datas,
    DedCommList comms,
    List<DedUser> users
)
Public Sub SendMail (
    eventToSend As DedNotifyNotifyEvent,
    datas As DedDataList,
    comms As DedCommList,
    users As List(Of DedUser)
)
public:
void SendMail(
    DedNotifyNotifyEvent eventToSend,
    DedDataList^ datas,
    DedCommList^ comms,
    List<DedUser^>^ users
)
member SendMail :
        eventToSend : DedNotifyNotifyEvent *
        datas : DedDataList *
        comms : DedCommList *
        users : List<DedUser> -> unit

Parametri

eventToSend DedNotifyNotifyEvent
Evento da controllare.
datas DedDataList
Anagrafiche in gioco (da usare per sostituire i valori).
comms DedCommList
Commesse in gioco (da usare per sostituire i valori).
users List DedUser
Lista degli utenti da aggiungere all'elenco dei notificati.
Vedi anche

Documentazione

Classe DedNotifies
Overload di SendMail
Namespace DedNet.Core


Metodo DedNotifies.SendMailCustomizedEvent

Metodo DedNotifiesSendMailCustomizedEvent
Controlla se è presente una notifica personalizzata con il nome passato e nel caso la invia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SendMailCustomizedEvent(
    string notifyName,
    DedDataList datas,
    DedCommList comms,
    List<DedUser> users
)
Public Sub SendMailCustomizedEvent (
    notifyName As String,
    datas As DedDataList,
    comms As DedCommList,
    users As List(Of DedUser)
)
public:
void SendMailCustomizedEvent(
    String^ notifyName,
    DedDataList^ datas,
    DedCommList^ comms,
    List<DedUser^>^ users
)
member SendMailCustomizedEvent :
        notifyName : string *
        datas : DedDataList *
        comms : DedCommList *
        users : List<DedUser> -> unit

Parametri

notifyName String
Nome della notifica da controllare.
datas DedDataList
Anagrafiche in gioco (da usare per sostituire i valori).
comms DedCommList
Commesse in gioco (da usare per sostituire i valori).
users List DedUser
Lista degli utenti da aggiungere all'elenco dei notificati.
Vedi anche

Documentazione

Classe DedNotifies
Namespace DedNet.Core


Classe DedNotify
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedNotify

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedNotify : IDedDbItem
Public Class DedNotify
    Implements IDedDbItem
public ref class DedNotify : IDedDbItem
type DedNotify =
    class
        interface IDedDbItem
    end

Il tipo DedNotify espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Attachments | Restituisce o imposta il le estensioni da allegare.
Proprietà pubblica | Body | Restituisce o imposta il contenuto della notifica.
Proprietà pubblica | Event | Restituisce o imposta l'evento di notifica.
Proprietà pubblica | Nome | Restituisce il nome dell'evento di notifica.
Proprietà pubblica | Object | Restituisce o imposta l'oggetto della notifica.
Proprietà pubblica | Parent | Restituisce la collezione di appartenenza dell'elemento.
Proprietà pubblica | State | Restituisce lo stato della notifica.
Proprietà pubblica | StatoRecord | Restituisce o imposta lo stato del record. DI USO INTERNO !!
Proprietà pubblica | To | Restituisce o imposta i destinatari della notifica.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Torna su
Campi
Nome | Descrizione
DESCRIPTIONTILE | Tassello utilizzato per indicare di utilizzare la descrizione invece che il nome.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di DedNotify

Il tipo DedNotify espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Attachments | Restituisce o imposta il le estensioni da allegare.
Proprietà pubblica | Body | Restituisce o imposta il contenuto della notifica.
Proprietà pubblica | Event | Restituisce o imposta l'evento di notifica.
Proprietà pubblica | Nome | Restituisce il nome dell'evento di notifica.
Proprietà pubblica | Object | Restituisce o imposta l'oggetto della notifica.
Proprietà pubblica | Parent | Restituisce la collezione di appartenenza dell'elemento.
Proprietà pubblica | State | Restituisce lo stato della notifica.
Proprietà pubblica | StatoRecord | Restituisce o imposta lo stato del record. DI USO INTERNO !!
Proprietà pubblica | To | Restituisce o imposta i destinatari della notifica.
Torna su
Vedi anche

Documentazione

Classe DedNotify
Namespace DedNet.Core


Proprietà DedNotify.Attachments

Proprietà DedNotifyAttachments
Restituisce o imposta il le estensioni da allegare.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Attachments { get; set; }
Public Property Attachments As String
    Get
    Set
public:
property String^ Attachments {
    String^ get ();
    void set (String^ value);
}
member Attachments : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNotify
Namespace DedNet.Core


Proprietà DedNotify.Body

Proprietà DedNotifyBody
Restituisce o imposta il contenuto della notifica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Body { get; set; }
Public Property Body As String
    Get
    Set
public:
property String^ Body {
    String^ get ();
    void set (String^ value);
}
member Body : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNotify
Namespace DedNet.Core


Proprietà DedNotify.Event

Proprietà DedNotifyEvent
Restituisce o imposta l'evento di notifica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedNotifyNotifyEvent Event { get; set; }
Public Property Event As DedNotifyNotifyEvent
    Get
    Set
public:
property DedNotifyNotifyEvent Event {
    DedNotifyNotifyEvent get ();
    void set (DedNotifyNotifyEvent value);
}
member Event : DedNotifyNotifyEvent with get, set

Valore della proprietà

DedNotifyNotifyEvent
Vedi anche

Documentazione

Classe DedNotify
Namespace DedNet.Core


Proprietà DedNotify.Nome

Proprietà DedNotifyNome
Restituisce il nome dell'evento di notifica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Nome { get; set; }
Public Property Nome As String
    Get
    Set
public:
property String^ Nome {
    String^ get ();
    void set (String^ value);
}
member Nome : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNotify
Namespace DedNet.Core


Proprietà DedNotify.Object

Proprietà DedNotifyObject
Restituisce o imposta l'oggetto della notifica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Object { get; set; }
Public Property Object As String
    Get
    Set
public:
property String^ Object {
    String^ get ();
    void set (String^ value);
}
member Object : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNotify
Namespace DedNet.Core


Proprietà DedNotify.Parent

Proprietà DedNotifyParent
Restituisce la collezione di appartenenza dell'elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedNotifies Parent { get; set; }
Public Property Parent As DedNotifies
    Get
    Set
public:
property DedNotifies^ Parent {
    DedNotifies^ get ();
    void set (DedNotifies^ value);
}
member Parent : DedNotifies with get, set

Valore della proprietà

DedNotifies
Vedi anche

Documentazione

Classe DedNotify
Namespace DedNet.Core


Proprietà DedNotify.State

Proprietà DedNotifyState
Restituisce lo stato della notifica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedNotifyNotifyStateEnum State { get; set; }
Public Property State As DedNotifyNotifyStateEnum
    Get
    Set
public:
property DedNotifyNotifyStateEnum State {
    DedNotifyNotifyStateEnum get ();
    void set (DedNotifyNotifyStateEnum value);
}
member State : DedNotifyNotifyStateEnum with get, set

Valore della proprietà

DedNotifyNotifyStateEnum
Vedi anche

Documentazione

Classe DedNotify
Namespace DedNet.Core


Proprietà DedNotify.StatoRecord

Proprietà DedNotifyStatoRecord
Restituisce o imposta lo stato del record. DI USO INTERNO !!

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public StatoRecord StatoRecord { get; set; }
Public Property StatoRecord As StatoRecord
    Get
    Set
public:
virtual property StatoRecord^ StatoRecord {
    StatoRecord^ get () sealed;
    void set (StatoRecord^ value) sealed;
}
abstract StatoRecord : StatoRecord with get, set
override StatoRecord : StatoRecord with get, set

Valore della proprietà

StatoRecord

Implementa

IDedDbItemStatoRecord
Vedi anche

Documentazione

Classe DedNotify
Namespace DedNet.Core


Proprietà DedNotify.To

Proprietà DedNotifyTo
Restituisce o imposta i destinatari della notifica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string To { get; set; }
Public Property To As String
    Get
    Set
public:
property String^ To {
    String^ get ();
    void set (String^ value);
}
member To : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedNotify
Namespace DedNet.Core


Metodi di DedNotify

Il tipo DedNotify espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Torna su
Vedi anche

Documentazione

Classe DedNotify
Namespace DedNet.Core


Metodo DedNotify.Equals

Metodo DedNotifyEquals

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj Object

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedNotify
Namespace DedNet.Core


Metodo DedNotify.GetHashCode

Metodo DedNotifyGetHashCode

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedNotify
Namespace DedNet.Core


Metodo DedNotify.ToString

Metodo DedNotifyToString

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedNotify
Namespace DedNet.Core


Campi di DedNotify

Il tipo DedNotify espone i seguenti membri.

Campi
Nome | Descrizione
DESCRIPTIONTILE | Tassello utilizzato per indicare di utilizzare la descrizione invece che il nome.
Torna su
Vedi anche

Documentazione

Classe DedNotify
Namespace DedNet.Core


Campo DedNotify.DESCRIPTIONTILE

Campo DedNotifyDESCRIPTIONTILE
Tassello utilizzato per indicare di utilizzare la descrizione invece che il nome.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string DESCRIPTIONTILE
Public Shared DESCRIPTIONTILE As String
public:
static String^ DESCRIPTIONTILE
static val mutable DESCRIPTIONTILE: string

Valore del campo

String
Vedi anche

Documentazione

Classe DedNotify
Namespace DedNet.Core


Enumerazione DedNotify.NotifyEvent

Enumerazione DedNotifyNotifyEvent
Enumerazione contenente tutti i permessi standard.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum NotifyEvent
Public Enumeration NotifyEvent
public enum class NotifyEvent
type NotifyEvent
Membri
Nome | Valore | Descrizione
Personalizzato | 0 |
Salva | 1 |
SalvaRev | 2 |
EliminazioneAnagrafica | 3 |
SalvaDistinta | 4 |
EditaDistinta | 5 |
ChiusuraCommessa | 6 |
AperturaCommessa | 7 |
CreazioneCommessa | 8 |
EliminazioneCommessa | 9 |
Approved | 10 |
Unchangeable | 11 |
OutOfDate | 12 |
Working | 13 |
PendingApproval | 14 |
CreazioneEco | 15 |
EcoAperto | 16 |
EcoAssegnato | 17 |
EcoChiuso | 18 |
ModifyingOutOfDate | 19 |
EcoAssegnatoA | 20 |
EcoCambioStato | 21 |
Vedi anche

Documentazione

Namespace DedNet.Core


Enumerazione DedNotify.NotifySendTypeEnum

Enumerazione DedNotifyNotifySendTypeEnum

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum NotifySendTypeEnum
Public Enumeration NotifySendTypeEnum
public enum class NotifySendTypeEnum
type NotifySendTypeEnum
Membri
Nome | Valore | Descrizione
Smpt | 0 |
Outlook | 1 |
Vedi anche

Documentazione

Namespace DedNet.Core


Enumerazione DedNotify.NotifyStateEnum

Enumerazione DedNotifyNotifyStateEnum

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum NotifyStateEnum
Public Enumeration NotifyStateEnum
public enum class NotifyStateEnum
type NotifyStateEnum
Membri
Nome | Valore | Descrizione
Disabled | 0 |
Enabled | 1 |
Vedi anche

Documentazione

Namespace DedNet.Core


Classe DedOptionsCommonParents
Classe per gestire le opzioni per il comando di Trova padri comuni
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedOptionsSerializableBase
DedNet.CoreDedOptionsCommonParents

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedOptionsCommonParents : DedOptionsSerializableBase
Public Class DedOptionsCommonParents
    Inherits DedOptionsSerializableBase
public ref class DedOptionsCommonParents : public DedOptionsSerializableBase
type DedOptionsCommonParents =
    class
        inherit DedOptionsSerializableBase
    end

Il tipo DedOptionsCommonParents espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedOptionsCommonParents | Costruttore vuoto
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Multiliv | Indica
Proprietà pubblica | RegKeyName | Nome della chiave dove serializzare la classe. (Sovrascrive DedOptionsSerializableBaseRegKeyName)
Proprietà pubblica | SearchOnlyId | Indica
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | DeSerialize | Metodo per deserializzare nel registro la classe (se presente ritorna la classe deserializzata altrimenti ritorna se stessa). (Ereditato da DedOptionsSerializableBase)
Metodo pubblico | GetObjectData | Usata per la serializzazione (Sovrascrive DedOptionsSerializableBaseGetObjectData(SerializationInfo, StreamingContext))
Metodo pubblico | Serialize | Metodo per serializzare nel registro la classe. (Ereditato da DedOptionsSerializableBase)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedOptionsCommonParents
Costruttore vuoto

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedOptionsCommonParents()
Public Sub New
public:
DedOptionsCommonParents()
new : unit -> DedOptionsCommonParents
Vedi anche

Documentazione

Classe DedOptionsCommonParents
Namespace DedNet.Core


Proprietà di DedOptionsCommonParents

Il tipo DedOptionsCommonParents espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Multiliv | Indica
Proprietà pubblica | RegKeyName | Nome della chiave dove serializzare la classe. (Sovrascrive DedOptionsSerializableBaseRegKeyName)
Proprietà pubblica | SearchOnlyId | Indica
Torna su
Vedi anche

Documentazione

Classe DedOptionsCommonParents
Namespace DedNet.Core


Proprietà DedOptionsCommonParents.Multiliv

Proprietà DedOptionsCommonParentsMultiliv
Indica

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Multiliv { get; set; }
Public Property Multiliv As Boolean
    Get
    Set
public:
property bool Multiliv {
    bool get ();
    void set (bool value);
}
member Multiliv : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedOptionsCommonParents
Namespace DedNet.Core


Proprietà DedOptionsCommonParents.RegKeyName

Proprietà DedOptionsCommonParentsRegKeyName
Nome della chiave dove serializzare la classe.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string RegKeyName { get; }
Public Overrides ReadOnly Property RegKeyName As String
    Get
public:
virtual property String^ RegKeyName {
    String^ get () override;
}
abstract RegKeyName : string with get
override RegKeyName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedOptionsCommonParents
Namespace DedNet.Core


Proprietà DedOptionsCommonParents.SearchOnlyId

Proprietà DedOptionsCommonParentsSearchOnlyId
Indica

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool SearchOnlyId { get; set; }
Public Property SearchOnlyId As Boolean
    Get
    Set
public:
property bool SearchOnlyId {
    bool get ();
    void set (bool value);
}
member SearchOnlyId : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedOptionsCommonParents
Namespace DedNet.Core


Metodi di DedOptionsCommonParents

Il tipo DedOptionsCommonParents espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | DeSerialize | Metodo per deserializzare nel registro la classe (se presente ritorna la classe deserializzata altrimenti ritorna se stessa). (Ereditato da DedOptionsSerializableBase)
Metodo pubblico | GetObjectData | Usata per la serializzazione (Sovrascrive DedOptionsSerializableBaseGetObjectData(SerializationInfo, StreamingContext))
Metodo pubblico | Serialize | Metodo per serializzare nel registro la classe. (Ereditato da DedOptionsSerializableBase)
Torna su
Vedi anche

Documentazione

Classe DedOptionsCommonParents
Namespace DedNet.Core


Metodo DedOptionsCommonParents.GetObjectData

Metodo DedOptionsCommonParentsGetObjectData
Usata per la serializzazione

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parametri

info SerializationInfo
context StreamingContext

Implementa

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Vedi anche

Documentazione

Classe DedOptionsCommonParents
Namespace DedNet.Core


Classe DedOptionsSerializableBase
Classe per gestiore una classe di opzioni e serializzarla nel registro.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedOptionsSerializableBase
DedNet.CoreDedOptionsCommonParents

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public abstract class DedOptionsSerializableBase : ISerializable
Public MustInherit Class DedOptionsSerializableBase
    Implements ISerializable
public ref class DedOptionsSerializableBase abstract : ISerializable
[<AbstractClassAttribute>]
type DedOptionsSerializableBase =
    class
        interface ISerializable
    end

Il tipo DedOptionsSerializableBase espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo protetto | DedOptionsSerializableBase |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | RegKeyName | Nome della chiave del registro ( il percorso è definito da RegistryBaseDir del DedNetApplication)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | DeSerialize | Metodo per deserializzare nel registro la classe (se presente ritorna la classe deserializzata altrimenti ritorna se stessa).
Metodo pubblico | GetObjectData |
Metodo pubblico | Serialize | Metodo per serializzare nel registro la classe.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedOptionsSerializableBase

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected DedOptionsSerializableBase()
Protected Sub New
protected:
DedOptionsSerializableBase()
new : unit -> DedOptionsSerializableBase
Vedi anche

Documentazione

Classe DedOptionsSerializableBase
Namespace DedNet.Core


Proprietà di DedOptionsSerializableBase

Il tipo DedOptionsSerializableBase espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | RegKeyName | Nome della chiave del registro ( il percorso è definito da RegistryBaseDir del DedNetApplication)
Torna su
Vedi anche

Documentazione

Classe DedOptionsSerializableBase
Namespace DedNet.Core


Proprietà DedOptionsSerializableBase.RegKeyName

Proprietà DedOptionsSerializableBaseRegKeyName
Nome della chiave del registro ( il percorso è definito da RegistryBaseDir del DedNetApplication)

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public abstract string RegKeyName { get; }
Public MustOverride ReadOnly Property RegKeyName As String
    Get
public:
virtual property String^ RegKeyName {
    String^ get () abstract;
}
abstract RegKeyName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedOptionsSerializableBase
Namespace DedNet.Core


Metodi di DedOptionsSerializableBase

Il tipo DedOptionsSerializableBase espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | DeSerialize | Metodo per deserializzare nel registro la classe (se presente ritorna la classe deserializzata altrimenti ritorna se stessa).
Metodo pubblico | GetObjectData |
Metodo pubblico | Serialize | Metodo per serializzare nel registro la classe.
Torna su
Vedi anche

Documentazione

Classe DedOptionsSerializableBase
Namespace DedNet.Core


Metodo DedOptionsSerializableBase.DeSerialize

Metodo DedOptionsSerializableBaseDeSerialize
Metodo per deserializzare nel registro la classe (se presente ritorna la classe deserializzata altrimenti ritorna se stessa).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedOptionsSerializableBase DeSerialize(
    DedNetApplication app
)
Public Function DeSerialize (
    app As DedNetApplication
) As DedOptionsSerializableBase
public:
DedOptionsSerializableBase^ DeSerialize(
    DedNetApplication^ app
)
member DeSerialize :
        app : DedNetApplication -> DedOptionsSerializableBase

Parametri

app DedNetApplication
DedNetApplication usato per avere la chiave di registro

Valore di ritorno

DedOptionsSerializableBase
Vedi anche

Documentazione

Classe DedOptionsSerializableBase
Namespace DedNet.Core


Metodo DedOptionsSerializableBase.GetObjectData

Metodo DedOptionsSerializableBaseGetObjectData

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public abstract void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public MustOverride Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) abstract
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parametri

info SerializationInfo
context StreamingContext

Implementa

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Vedi anche

Documentazione

Classe DedOptionsSerializableBase
Namespace DedNet.Core


Metodo DedOptionsSerializableBase.Serialize

Metodo DedOptionsSerializableBaseSerialize
Metodo per serializzare nel registro la classe.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Serialize(
    DedNetApplication app
)
Public Sub Serialize (
    app As DedNetApplication
)
public:
void Serialize(
    DedNetApplication^ app
)
member Serialize :
        app : DedNetApplication -> unit

Parametri

app DedNetApplication
DedNetApplication usato per avere la chiave di registro
Vedi anche

Documentazione

Classe DedOptionsSerializableBase
Namespace DedNet.Core


Classe DedPerm
Racchiude le informazioni di un singolo permesso.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedPerm

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedPerm : IDedDbItem
Public Class DedPerm
    Implements IDedDbItem
public ref class DedPerm : IDedDbItem
type DedPerm =
    class
        interface IDedDbItem
    end

Il tipo DedPerm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Descr | Restituisce o imposta la descrizione del permesso.
Proprietà pubblica | Discrim | Discriminante del permesso. Di norma viene compilato con l'estensione di un file indicante se l'utente può o non può vedere quel determinato tipo di file. Di default è però compilato con il "*" indicante che il discriminante non deve essere preso in considerazione.
Proprietà pubblica | IsStandard | Restituisce se si questo sia o meno un permesso standard.
Proprietà pubblica | Name | Restituisce o imposta il nome del permesso.
Proprietà pubblica | StatoRecord | Di uso interno.
Proprietà pubblica | UserName |
Proprietà pubblica | Val | Restituisce o imposta il valore del permesso.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di DedPerm

Il tipo DedPerm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Descr | Restituisce o imposta la descrizione del permesso.
Proprietà pubblica | Discrim | Discriminante del permesso. Di norma viene compilato con l'estensione di un file indicante se l'utente può o non può vedere quel determinato tipo di file. Di default è però compilato con il "*" indicante che il discriminante non deve essere preso in considerazione.
Proprietà pubblica | IsStandard | Restituisce se si questo sia o meno un permesso standard.
Proprietà pubblica | Name | Restituisce o imposta il nome del permesso.
Proprietà pubblica | StatoRecord | Di uso interno.
Proprietà pubblica | UserName |
Proprietà pubblica | Val | Restituisce o imposta il valore del permesso.
Torna su
Vedi anche

Documentazione

Classe DedPerm
Namespace DedNet.Core


Proprietà DedPerm.Descr

Proprietà DedPermDescr
Restituisce o imposta la descrizione del permesso.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Descr { get; set; }
Public Property Descr As String
    Get
    Set
public:
property String^ Descr {
    String^ get ();
    void set (String^ value);
}
member Descr : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedPerm
Namespace DedNet.Core


Proprietà DedPerm.Discrim

Proprietà DedPermDiscrim
Discriminante del permesso. Di norma viene compilato con l'estensione di un file indicante se l'utente può o non può vedere quel determinato tipo di file. Di default è però compilato con il "*" indicante che il discriminante non deve essere preso in considerazione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Discrim { get; set; }
Public Property Discrim As String
    Get
    Set
public:
property String^ Discrim {
    String^ get ();
    void set (String^ value);
}
member Discrim : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedPerm
Namespace DedNet.Core


Proprietà DedPerm.IsStandard

Proprietà DedPermIsStandard
Restituisce se si questo sia o meno un permesso standard.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsStandard { get; }
Public ReadOnly Property IsStandard As Boolean
    Get
public:
property bool IsStandard {
    bool get ();
}
member IsStandard : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedPerm
Namespace DedNet.Core


Proprietà DedPerm.Name

Proprietà DedPermName
Restituisce o imposta il nome del permesso.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedPerm
Namespace DedNet.Core


Proprietà DedPerm.StatoRecord

Proprietà DedPermStatoRecord
Di uso interno.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public StatoRecord StatoRecord { get; set; }
Public Property StatoRecord As StatoRecord
    Get
    Set
public:
virtual property StatoRecord^ StatoRecord {
    StatoRecord^ get () sealed;
    void set (StatoRecord^ value) sealed;
}
abstract StatoRecord : StatoRecord with get, set
override StatoRecord : StatoRecord with get, set

Valore della proprietà

StatoRecord

Implementa

IDedDbItemStatoRecord
Vedi anche

Documentazione

Classe DedPerm
Namespace DedNet.Core


Proprietà DedPerm.UserName

Proprietà DedPermUserName

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string UserName { get; set; }
Public Property UserName As String
    Get
    Set
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}
member UserName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedPerm
Namespace DedNet.Core


Proprietà DedPerm.Val

Proprietà DedPermVal
Restituisce o imposta il valore del permesso.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Val { get; set; }
Public Property Val As Boolean
    Get
    Set
public:
property bool Val {
    bool get ();
    void set (bool value);
}
member Val : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedPerm
Namespace DedNet.Core


Classe DedPermCollection
Collezione di permessi.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedDbCollectionBase DedPerm
DedNet.CoreDedPermCollection

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedPermCollection : DedDbCollectionBase<DedPerm>
Public Class DedPermCollection
    Inherits DedDbCollectionBase(Of DedPerm)
public ref class DedPermCollection : public DedDbCollectionBase<DedPerm^>
type DedPermCollection =
    class
        inherit DedDbCollectionBase<DedPerm>
    end

Il tipo DedPermCollection espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllowsDuplicates | Restituisce se siano ammessi duplicati all'interno della lista. Se false viene sollevata una eccezione su tentativo di inserimento duplicati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Application | Restituisce l'oggetto applicazione di appartenza. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Count | Restituisce il numero di elementi presenti. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Dirty | Restituisce se la collezione o uno dei suoi elementi sia stata modificata. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | ErasedItems | Restitusice la lista in sola lettura degli elementi che risultano attualmente cancellati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | LastItem | Restituisce l'ultimo elemento della collezione oppure null se non ci sono elementi. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | RestoreErased | Restituisce se gli elementi cancellati devono essere ripristinati in caso vengano riaggiunti. (Ereditato da DedDbCollectionBaseT)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Add | Aggiunge un elemento accodandolo alla lista.
Metodo protetto | AddForClone | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto SENZA MODIFICARNE LO STATO. Le classi derivate potranno utilizzare questo metodo per clonare la collezione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddNewElement | DI USO INTERNO. Aggiunge un elemento alla lista rendendo dirty l'oggetto. L'elemento viene aggiunto con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere un elemento alla lista. Dovranno loro stesse avere un metodo pubblico Add() che prenda i parametri necessari alla costruzione dell'oggetto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddRangeNewElement | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi rendendo dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere più elementi alla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddUnModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Clear | Elimina tutti gli elementi dalla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ClearRefresh | Svuota la lista impostando Dirty = false. Di fatto permette di effettuare un refresh della lista e quindi di ricaricarla. Serve per svuotare la lista e reinizializzarla da capo. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Contains | Verifica l'esistenza di un valore all'interno della lista degli elementi. Le classi derivate devono effettuarne l'override nel caso in cui l'elemento non implementi GetHashCode() per l'uso all'interno dei dizionarii. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | CopyTo | Copia un range di elementi in un array. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | CreateDeleteCommand | (Sovrascrive DedDbCollectionBaseTCreateDeleteCommand(T))
Metodo protetto | CreateInsertCommand | (Sovrascrive DedDbCollectionBaseTCreateInsertCommand(T))
Metodo protetto | CreateUpdateCommand | (Sovrascrive DedDbCollectionBaseTCreateUpdateCommand(T))
Metodo pubblico | CustomSort | Ordina la lista in base al comparatore passato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteDeleteItem | Esegue l'eliminazione di un elemento. Crea il comando tramite il metodo CreateDeleteCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteInsertItem | Esegue l'inserimento di un elemento. Crea il comando tramite il metodo CreateInsertCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteUpdateItem | Esegue l'aggiornamento di un elemento. Crea il comando tramite il metodo CreateUpdateCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Find | Restituisce l'oggetto cercato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FindAll | Restitusice la lista degli elementi che corrispondono al predicato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | GetByNameAndDiscrim | Restituisce il permesso tramite il suo nome oppure restituisce null se non è presente nella collezione.
Metodo protetto | GetDbIndex | (Sovrascrive DedDbCollectionBaseTGetDbIndex(T))
Metodo pubblico | GetEnumerator | Restituisce l'enumeratore della collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | IndexOf | Restituisce l'indice dell'elemento richiesto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InsertUnModified | DI USO INTERNO. Inserisce un elemento alla lista senza rendere dirty l'oggetto, all'indice specificato. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Item | Restituisce l'elemento iesimo della lista. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean) | Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean, Int32) | Sposta l'elemento dell'indice passato prima o dopo del numero di posizioni passate. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSave | Metodo Template chiamato dopo il salvataggio avvenuto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSaveNoChanges | Metodo Template chiamato dopo il salvataggio senza modifiche. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnBeforeSave | Metodo Template chiamato prima del salvataggio. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(T) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(DedEditableObjectT) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(T) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(DedEditableObjectT) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ReInitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Remove | Elimina un elemento dalla collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Ripristina | Verifica che l'elemento sia presente negli eliminati e lo toglie da lì e lo riaggiunge in coda alla lista degli elementi validi. Solleva una eccezione se l'elemento è già presente nella lista e AllowsDuplicates = false. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Save | Salva l'oggetto con tutta la sua lista, solo se questo risulta dirty. (Ereditato da DedDbCollectionBaseT)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di DedPermCollection

Il tipo DedPermCollection espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllowsDuplicates | Restituisce se siano ammessi duplicati all'interno della lista. Se false viene sollevata una eccezione su tentativo di inserimento duplicati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Application | Restituisce l'oggetto applicazione di appartenza. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Count | Restituisce il numero di elementi presenti. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Dirty | Restituisce se la collezione o uno dei suoi elementi sia stata modificata. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | ErasedItems | Restitusice la lista in sola lettura degli elementi che risultano attualmente cancellati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | LastItem | Restituisce l'ultimo elemento della collezione oppure null se non ci sono elementi. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | RestoreErased | Restituisce se gli elementi cancellati devono essere ripristinati in caso vengano riaggiunti. (Ereditato da DedDbCollectionBaseT)
Torna su
Vedi anche

Documentazione

Classe DedPermCollection
Namespace DedNet.Core


Metodi di DedPermCollection

Il tipo DedPermCollection espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Add | Aggiunge un elemento accodandolo alla lista.
Metodo protetto | AddForClone | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto SENZA MODIFICARNE LO STATO. Le classi derivate potranno utilizzare questo metodo per clonare la collezione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddNewElement | DI USO INTERNO. Aggiunge un elemento alla lista rendendo dirty l'oggetto. L'elemento viene aggiunto con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere un elemento alla lista. Dovranno loro stesse avere un metodo pubblico Add() che prenda i parametri necessari alla costruzione dell'oggetto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddRangeNewElement | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi rendendo dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere più elementi alla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddUnModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Clear | Elimina tutti gli elementi dalla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ClearRefresh | Svuota la lista impostando Dirty = false. Di fatto permette di effettuare un refresh della lista e quindi di ricaricarla. Serve per svuotare la lista e reinizializzarla da capo. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Contains | Verifica l'esistenza di un valore all'interno della lista degli elementi. Le classi derivate devono effettuarne l'override nel caso in cui l'elemento non implementi GetHashCode() per l'uso all'interno dei dizionarii. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | CopyTo | Copia un range di elementi in un array. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | CreateDeleteCommand | (Sovrascrive DedDbCollectionBaseTCreateDeleteCommand(T))
Metodo protetto | CreateInsertCommand | (Sovrascrive DedDbCollectionBaseTCreateInsertCommand(T))
Metodo protetto | CreateUpdateCommand | (Sovrascrive DedDbCollectionBaseTCreateUpdateCommand(T))
Metodo pubblico | CustomSort | Ordina la lista in base al comparatore passato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteDeleteItem | Esegue l'eliminazione di un elemento. Crea il comando tramite il metodo CreateDeleteCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteInsertItem | Esegue l'inserimento di un elemento. Crea il comando tramite il metodo CreateInsertCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteUpdateItem | Esegue l'aggiornamento di un elemento. Crea il comando tramite il metodo CreateUpdateCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Find | Restituisce l'oggetto cercato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FindAll | Restitusice la lista degli elementi che corrispondono al predicato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | GetByNameAndDiscrim | Restituisce il permesso tramite il suo nome oppure restituisce null se non è presente nella collezione.
Metodo protetto | GetDbIndex | (Sovrascrive DedDbCollectionBaseTGetDbIndex(T))
Metodo pubblico | GetEnumerator | Restituisce l'enumeratore della collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | IndexOf | Restituisce l'indice dell'elemento richiesto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InsertUnModified | DI USO INTERNO. Inserisce un elemento alla lista senza rendere dirty l'oggetto, all'indice specificato. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Item | Restituisce l'elemento iesimo della lista. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean) | Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean, Int32) | Sposta l'elemento dell'indice passato prima o dopo del numero di posizioni passate. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSave | Metodo Template chiamato dopo il salvataggio avvenuto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSaveNoChanges | Metodo Template chiamato dopo il salvataggio senza modifiche. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnBeforeSave | Metodo Template chiamato prima del salvataggio. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(T) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(DedEditableObjectT) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(T) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(DedEditableObjectT) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ReInitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Remove | Elimina un elemento dalla collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Ripristina | Verifica che l'elemento sia presente negli eliminati e lo toglie da lì e lo riaggiunge in coda alla lista degli elementi validi. Solleva una eccezione se l'elemento è già presente nella lista e AllowsDuplicates = false. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Save | Salva l'oggetto con tutta la sua lista, solo se questo risulta dirty. (Ereditato da DedDbCollectionBaseT)
Torna su
Vedi anche

Documentazione

Classe DedPermCollection
Namespace DedNet.Core


Metodo DedPermCollection.Add

Metodo DedPermCollectionAdd
Aggiunge un elemento accodandolo alla lista.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedPerm Add(
    string name,
    string descr,
    bool val,
    string discrim
)
Public Function Add (
    name As String,
    descr As String,
    val As Boolean,
    discrim As String
) As DedPerm
public:
DedPerm^ Add(
    String^ name,
    String^ descr,
    bool val,
    String^ discrim
)
member Add :
        name : string *
        descr : string *
        val : bool *
        discrim : string -> DedPerm

Parametri

name String
Nome del permesso.
descr String
Descrizione.
val Boolean
Valore
discrim String
Discriminante del permesso.

Valore di ritorno

DedPerm
Restituisce l'elemento appena aggiunto.
Vedi anche

Documentazione

Classe DedPermCollection
Namespace DedNet.Core


Metodo DedPermCollection.CreateDeleteCommand

Metodo DedPermCollectionCreateDeleteCommand

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSDeleteCommand CreateDeleteCommand(
    DedPerm item
)
Protected Overrides Function CreateDeleteCommand (
    item As DedPerm
) As QSDeleteCommand
protected:
virtual QSDeleteCommand^ CreateDeleteCommand(
    DedPerm^ item
) override
abstract CreateDeleteCommand :
        item : DedPerm -> QSDeleteCommand
override CreateDeleteCommand :
        item : DedPerm -> QSDeleteCommand

Parametri

item DedPerm

Valore di ritorno

QSDeleteCommand
Vedi anche

Documentazione

Classe DedPermCollection
Namespace DedNet.Core


Metodo DedPermCollection.CreateInsertCommand

Metodo DedPermCollectionCreateInsertCommand

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSInsertCommand CreateInsertCommand(
    DedPerm item
)
Protected Overrides Function CreateInsertCommand (
    item As DedPerm
) As QSInsertCommand
protected:
virtual QSInsertCommand^ CreateInsertCommand(
    DedPerm^ item
) override
abstract CreateInsertCommand :
        item : DedPerm -> QSInsertCommand
override CreateInsertCommand :
        item : DedPerm -> QSInsertCommand

Parametri

item DedPerm

Valore di ritorno

QSInsertCommand
Vedi anche

Documentazione

Classe DedPermCollection
Namespace DedNet.Core


Metodo DedPermCollection.CreateUpdateCommand

Metodo DedPermCollectionCreateUpdateCommand

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSUpdateCommand CreateUpdateCommand(
    DedPerm item
)
Protected Overrides Function CreateUpdateCommand (
    item As DedPerm
) As QSUpdateCommand
protected:
virtual QSUpdateCommand^ CreateUpdateCommand(
    DedPerm^ item
) override
abstract CreateUpdateCommand :
        item : DedPerm -> QSUpdateCommand
override CreateUpdateCommand :
        item : DedPerm -> QSUpdateCommand

Parametri

item DedPerm

Valore di ritorno

QSUpdateCommand
Vedi anche

Documentazione

Classe DedPermCollection
Namespace DedNet.Core


Metodo DedPermCollection.GetByNameAndDiscrim

Metodo DedPermCollectionGetByNameAndDiscrim
Restituisce il permesso tramite il suo nome oppure restituisce null se non è presente nella collezione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedPerm GetByNameAndDiscrim(
    string permName,
    string discrim
)
Public Function GetByNameAndDiscrim (
    permName As String,
    discrim As String
) As DedPerm
public:
DedPerm^ GetByNameAndDiscrim(
    String^ permName,
    String^ discrim
)
member GetByNameAndDiscrim :
        permName : string *
        discrim : string -> DedPerm

Parametri

permName String
Nome del permesso da cercare.
discrim String
Discriminante del permesso.

Valore di ritorno

DedPerm
Vedi anche

Documentazione

Classe DedPermCollection
Namespace DedNet.Core


Metodo DedPermCollection.GetDbIndex

Metodo DedPermCollectionGetDbIndex

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override Object GetDbIndex(
    DedPerm item
)
Protected Overrides Function GetDbIndex (
    item As DedPerm
) As Object
protected:
virtual Object^ GetDbIndex(
    DedPerm^ item
) override
abstract GetDbIndex :
        item : DedPerm -> Object
override GetDbIndex :
        item : DedPerm -> Object

Parametri

item DedPerm

Valore di ritorno

Object
Vedi anche

Documentazione

Classe DedPermCollection
Namespace DedNet.Core


Classe DedPermOwner
Classe descrivente un possessore di permessi. Viene utilizzata come classe base per gli utenti, i gruppi, il set di base di permessi e per i permessi legati alle famiglie.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedPermOwner
Altro

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public abstract class DedPermOwner
Public MustInherit Class DedPermOwner
public ref class DedPermOwner abstract
[<AbstractClassAttribute>]
type DedPermOwner = class end

Il tipo DedPermOwner espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione di appartenenza.
Proprietà pubblica | IsGroup | Restituisce se si tratti di un gruppo (sempre false tranne nel caso di un gruppo).
Proprietà pubblica | IsUser | Restituisce se si tratti di un utente (sempre false tranne nel caso di un utente).
Proprietà pubblica | Manager | Restituisce il Gestore dei permessi.
Proprietà pubblica | Name |
Proprietà pubblica | PermItems | Restitusice il set di permessi di questo possessore.
Proprietà protetta | TableName | Restituisce il nome della table del Database.
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | CreateDeleteCommand |
Metodo protetto | CreateInsertCommand |
Metodo protetto | CreateUpdateCommand |
Metodo protetto | GetDbIndex |
Metodo pubblico | GetPermDescription | Restituisce la descrizione del permesso.
Metodo pubblico | GetPermVal(String, String) | Restituisce il valore del permesso.
Metodo pubblico | GetPermVal(String, String, String) | Restituisce il valore del permesso impostando la stringa descrittiva il tipo di ereditarietà del permesso.
Metodo pubblico | IsPermPresent | Restituisce se il permesso è presente in modo esplicito fra i permessi di questa instanza.
Metodo pubblico | SetPermVal | Imposta il permesso ottenendo la stringa descrittiva del permesso.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedPermOwner
DedNet.CoreDedAttrPerm
DedNet.CoreDedCommPerm
DedNet.CoreDedFamPerm
DedNet.CoreDedFolderPerm
DedNet.CoreDedGroup
DedNet.CoreDedUser
DedNet.CorePermSet


Proprietà di DedPermOwner

Il tipo DedPermOwner espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione di appartenenza.
Proprietà pubblica | IsGroup | Restituisce se si tratti di un gruppo (sempre false tranne nel caso di un gruppo).
Proprietà pubblica | IsUser | Restituisce se si tratti di un utente (sempre false tranne nel caso di un utente).
Proprietà pubblica | Manager | Restituisce il Gestore dei permessi.
Proprietà pubblica | Name |
Proprietà pubblica | PermItems | Restitusice il set di permessi di questo possessore.
Proprietà protetta | TableName | Restituisce il nome della table del Database.
Torna su
Vedi anche

Documentazione

Classe DedPermOwner
Namespace DedNet.Core


Proprietà DedPermOwner.Application

Proprietà DedPermOwnerApplication
Restituisce l'applicazione di appartenenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedNetApplication Application { get; }
Public ReadOnly Property Application As DedNetApplication
    Get
public:
property DedNetApplication^ Application {
    DedNetApplication^ get ();
}
member Application : DedNetApplication with get

Valore della proprietà

DedNetApplication
Vedi anche

Documentazione

Classe DedPermOwner
Namespace DedNet.Core


Proprietà DedPermOwner.IsGroup

Proprietà DedPermOwnerIsGroup
Restituisce se si tratti di un gruppo (sempre false tranne nel caso di un gruppo).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual bool IsGroup { get; }
Public Overridable ReadOnly Property IsGroup As Boolean
    Get
public:
virtual property bool IsGroup {
    bool get ();
}
abstract IsGroup : bool with get
override IsGroup : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedPermOwner
Namespace DedNet.Core


Proprietà DedPermOwner.IsUser

Proprietà DedPermOwnerIsUser
Restituisce se si tratti di un utente (sempre false tranne nel caso di un utente).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual bool IsUser { get; }
Public Overridable ReadOnly Property IsUser As Boolean
    Get
public:
virtual property bool IsUser {
    bool get ();
}
abstract IsUser : bool with get
override IsUser : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedPermOwner
Namespace DedNet.Core


Proprietà DedPermOwner.Manager

Proprietà DedPermOwnerManager
Restituisce il Gestore dei permessi.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public UserPermManager Manager { get; }
Public ReadOnly Property Manager As UserPermManager
    Get
public:
property UserPermManager^ Manager {
    UserPermManager^ get ();
}
member Manager : UserPermManager with get

Valore della proprietà

UserPermManager
Vedi anche

Documentazione

Classe DedPermOwner
Namespace DedNet.Core


Proprietà DedPermOwner.Name

Proprietà DedPermOwnerName

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual string Name { get; set; }
Public Overridable Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set
override Name : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedPermOwner
Namespace DedNet.Core


Proprietà DedPermOwner.PermItems

Proprietà DedPermOwnerPermItems
Restitusice il set di permessi di questo possessore.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedPermCollection PermItems { get; }
Public ReadOnly Property PermItems As DedPermCollection
    Get
public:
property DedPermCollection^ PermItems {
    DedPermCollection^ get ();
}
member PermItems : DedPermCollection with get

Valore della proprietà

DedPermCollection
Vedi anche

Documentazione

Classe DedPermOwner
Namespace DedNet.Core


Proprietà DedPermOwner.TableName

Proprietà DedPermOwnerTableName
Restituisce il nome della table del Database.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal string TableName { get; protected set; }
Protected Friend Property TableName As String
    Get
    Protected Set
protected public:
property String^ TableName {
    String^ get ();
    protected: void set (String^ value);
}
member TableName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedPermOwner
Namespace DedNet.Core


Metodi di DedPermOwner

Il tipo DedPermOwner espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | CreateDeleteCommand |
Metodo protetto | CreateInsertCommand |
Metodo protetto | CreateUpdateCommand |
Metodo protetto | GetDbIndex |
Metodo pubblico | GetPermDescription | Restituisce la descrizione del permesso.
Metodo pubblico | GetPermVal(String, String) | Restituisce il valore del permesso.
Metodo pubblico | GetPermVal(String, String, String) | Restituisce il valore del permesso impostando la stringa descrittiva il tipo di ereditarietà del permesso.
Metodo pubblico | IsPermPresent | Restituisce se il permesso è presente in modo esplicito fra i permessi di questa instanza.
Metodo pubblico | SetPermVal | Imposta il permesso ottenendo la stringa descrittiva del permesso.
Torna su
Vedi anche

Documentazione

Classe DedPermOwner
Namespace DedNet.Core


Metodo DedPermOwner.CreateDeleteCommand

Metodo DedPermOwnerCreateDeleteCommand

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal virtual QSDeleteCommand CreateDeleteCommand(
    DedPerm item
)
Protected Friend Overridable Function CreateDeleteCommand (
    item As DedPerm
) As QSDeleteCommand
protected public:
virtual QSDeleteCommand^ CreateDeleteCommand(
    DedPerm^ item
)
abstract CreateDeleteCommand :
        item : DedPerm -> QSDeleteCommand
override CreateDeleteCommand :
        item : DedPerm -> QSDeleteCommand

Parametri

item DedPerm

Valore di ritorno

QSDeleteCommand
Vedi anche

Documentazione

Classe DedPermOwner
Namespace DedNet.Core


Metodo DedPermOwner.CreateInsertCommand

Metodo DedPermOwnerCreateInsertCommand

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal virtual QSInsertCommand CreateInsertCommand(
    DedPerm item
)
Protected Friend Overridable Function CreateInsertCommand (
    item As DedPerm
) As QSInsertCommand
protected public:
virtual QSInsertCommand^ CreateInsertCommand(
    DedPerm^ item
)
abstract CreateInsertCommand :
        item : DedPerm -> QSInsertCommand
override CreateInsertCommand :
        item : DedPerm -> QSInsertCommand

Parametri

item DedPerm

Valore di ritorno

QSInsertCommand
Vedi anche

Documentazione

Classe DedPermOwner
Namespace DedNet.Core


Metodo DedPermOwner.CreateUpdateCommand

Metodo DedPermOwnerCreateUpdateCommand

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal virtual QSUpdateCommand CreateUpdateCommand(
    DedPerm item
)
Protected Friend Overridable Function CreateUpdateCommand (
    item As DedPerm
) As QSUpdateCommand
protected public:
virtual QSUpdateCommand^ CreateUpdateCommand(
    DedPerm^ item
)
abstract CreateUpdateCommand :
        item : DedPerm -> QSUpdateCommand
override CreateUpdateCommand :
        item : DedPerm -> QSUpdateCommand

Parametri

item DedPerm

Valore di ritorno

QSUpdateCommand
Vedi anche

Documentazione

Classe DedPermOwner
Namespace DedNet.Core


Metodo DedPermOwner.GetDbIndex

Metodo DedPermOwnerGetDbIndex

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal virtual Object GetDbIndex(
    DedPerm item
)
Protected Friend Overridable Function GetDbIndex (
    item As DedPerm
) As Object
protected public:
virtual Object^ GetDbIndex(
    DedPerm^ item
)
abstract GetDbIndex :
        item : DedPerm -> Object
override GetDbIndex :
        item : DedPerm -> Object

Parametri

item DedPerm

Valore di ritorno

Object
Vedi anche

Documentazione

Classe DedPermOwner
Namespace DedNet.Core


Metodo DedPermOwner.GetPermDescription

Metodo DedPermOwnerGetPermDescription
Restituisce la descrizione del permesso.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual string GetPermDescription(
    string permName,
    string discrim
)
Public Overridable Function GetPermDescription (
    permName As String,
    discrim As String
) As String
public:
virtual String^ GetPermDescription(
    String^ permName,
    String^ discrim
)
abstract GetPermDescription :
        permName : string *
        discrim : string -> string
override GetPermDescription :
        permName : string *
        discrim : string -> string

Parametri

permName String
discrim String

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedPermOwner
Namespace DedNet.Core


Metodo DedPermOwner.GetPermVal

Metodo DedPermOwnerGetPermVal
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | GetPermVal(String, String) | Restituisce il valore del permesso.
Metodo pubblico | GetPermVal(String, String, String) | Restituisce il valore del permesso impostando la stringa descrittiva il tipo di ereditarietà del permesso.
Torna su
Vedi anche

Documentazione

Classe DedPermOwner
Namespace DedNet.Core


Metodo DedPermOwner.GetPermVal(String, String)

Metodo DedPermOwnerGetPermVal(String, String)
Restituisce il valore del permesso.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual bool GetPermVal(
    string permName,
    string discrim
)
Public Overridable Function GetPermVal (
    permName As String,
    discrim As String
) As Boolean
public:
virtual bool GetPermVal(
    String^ permName,
    String^ discrim
)
abstract GetPermVal :
        permName : string *
        discrim : string -> bool
override GetPermVal :
        permName : string *
        discrim : string -> bool

Parametri

permName String
discrim String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedPermOwner
Overload di GetPermVal
Namespace DedNet.Core


Metodo DedPermOwner.GetPermVal(String, String, String)

Metodo DedPermOwnerGetPermVal(String, String, String)
Restituisce il valore del permesso impostando la stringa descrittiva il tipo di ereditarietà del permesso.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual bool GetPermVal(
    string permName,
    string discrim,
    out string PermDesc
)
Public Overridable Function GetPermVal (
    permName As String,
    discrim As String,
    <OutAttribute> ByRef PermDesc As String
) As Boolean
public:
virtual bool GetPermVal(
    String^ permName,
    String^ discrim,
    [OutAttribute] String^% PermDesc
)
abstract GetPermVal :
        permName : string *
        discrim : string *
        PermDesc : string byref -> bool
override GetPermVal :
        permName : string *
        discrim : string *
        PermDesc : string byref -> bool

Parametri

permName String
discrim String
PermDesc String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedPermOwner
Overload di GetPermVal
Namespace DedNet.Core


Metodo DedPermOwner.IsPermPresent

Metodo DedPermOwnerIsPermPresent
Restituisce se il permesso è presente in modo esplicito fra i permessi di questa instanza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual bool IsPermPresent(
    string PermName,
    string discrim
)
Public Overridable Function IsPermPresent (
    PermName As String,
    discrim As String
) As Boolean
public:
virtual bool IsPermPresent(
    String^ PermName,
    String^ discrim
)
abstract IsPermPresent :
        PermName : string *
        discrim : string -> bool
override IsPermPresent :
        PermName : string *
        discrim : string -> bool

Parametri

PermName String
discrim String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedPermOwner
Namespace DedNet.Core


Metodo DedPermOwner.SetPermVal

Metodo DedPermOwnerSetPermVal
Imposta il permesso ottenendo la stringa descrittiva del permesso.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual string SetPermVal(
    string permName,
    string discrim,
    bool Valore
)
Public Overridable Function SetPermVal (
    permName As String,
    discrim As String,
    Valore As Boolean
) As String
public:
virtual String^ SetPermVal(
    String^ permName,
    String^ discrim,
    bool Valore
)
abstract SetPermVal :
        permName : string *
        discrim : string *
        Valore : bool -> string
override SetPermVal :
        permName : string *
        discrim : string *
        Valore : bool -> string

Parametri

permName String
discrim String
Valore Boolean

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedPermOwner
Namespace DedNet.Core


Classe DedProgManager
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedProgManager

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static class DedProgManager
Public NotInheritable Class DedProgManager
public ref class DedProgManager abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DedProgManager = class end

Il tipo DedProgManager espone i seguenti membri.

Metodi
Nome | Descrizione
EraseReservedProg | Elimina i progressivi assegnati all'utente passato per la specifica famiglia.
GetByFam |
GetByFamAndUser | Restituisce un oggetto rappresentante la situazione dei progressivi assegnati ad un determinato utente su una specifica famiglia ( nella tabella DED_TIPI_PROG ).
GetByFamNotUser |
GetByFamUser |
GetByUser | Restituisce un dizionario contenente la situazione dei progressivi assegnati ad un determinato utente su tutte le famiglie ( nella tabella DED_TIPI_PROG ). Il dizionario è indicizzato per DBPATH.
GetNearMinProg |
IsProgReserved | Restituisce se il progressivo da settare è già riservato a qualche utente. Internamente effettua una operazione RICORSIVA sui genitori della famiglia passata. In questo modo se la famiglia corrente ha un progressivo ereditato, il controllo viene effettuato su quella di livello superiore.
ReserveProg |
ReserveProgForSerializzation | Assegna nella tabella DED_TIPI_PROG un insieme di progressivi in base al DedTypeProgList passato.
UpdateReservedProg | Aggiorna la riga in DED_TIPI_PROG
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Metodi di DedProgManager

Il tipo DedProgManager espone i seguenti membri.

Metodi
Nome | Descrizione
EraseReservedProg | Elimina i progressivi assegnati all'utente passato per la specifica famiglia.
GetByFam |
GetByFamAndUser | Restituisce un oggetto rappresentante la situazione dei progressivi assegnati ad un determinato utente su una specifica famiglia ( nella tabella DED_TIPI_PROG ).
GetByFamNotUser |
GetByFamUser |
GetByUser | Restituisce un dizionario contenente la situazione dei progressivi assegnati ad un determinato utente su tutte le famiglie ( nella tabella DED_TIPI_PROG ). Il dizionario è indicizzato per DBPATH.
GetNearMinProg |
IsProgReserved | Restituisce se il progressivo da settare è già riservato a qualche utente. Internamente effettua una operazione RICORSIVA sui genitori della famiglia passata. In questo modo se la famiglia corrente ha un progressivo ereditato, il controllo viene effettuato su quella di livello superiore.
ReserveProg |
ReserveProgForSerializzation | Assegna nella tabella DED_TIPI_PROG un insieme di progressivi in base al DedTypeProgList passato.
UpdateReservedProg | Aggiorna la riga in DED_TIPI_PROG
Torna su
Vedi anche

Documentazione

Classe DedProgManager
Namespace DedNet.Core


Metodo DedProgManager.EraseReservedProg

Metodo DedProgManagerEraseReservedProg
Elimina i progressivi assegnati all'utente passato per la specifica famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool EraseReservedProg(
    DedNetApplication app,
    string guid
)
Public Shared Function EraseReservedProg (
    app As DedNetApplication,
    guid As String
) As Boolean
public:
static bool EraseReservedProg(
    DedNetApplication^ app,
    String^ guid
)
static member EraseReservedProg :
        app : DedNetApplication *
        guid : string -> bool

Parametri

app DedNetApplication
Applicazione di appartenenza.
guid String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedProgManager
Namespace DedNet.Core


Metodo DedProgManager.GetByFam

Metodo DedProgManagerGetByFam

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static DedTypeProgList GetByFam(
    DedNetApplication app,
    string dbpath
)
Public Shared Function GetByFam (
    app As DedNetApplication,
    dbpath As String
) As DedTypeProgList
public:
static DedTypeProgList^ GetByFam(
    DedNetApplication^ app,
    String^ dbpath
)
static member GetByFam :
        app : DedNetApplication *
        dbpath : string -> DedTypeProgList

Parametri

app DedNetApplication
dbpath String

Valore di ritorno

DedTypeProgList
Vedi anche

Documentazione

Classe DedProgManager
Namespace DedNet.Core


Metodo DedProgManager.GetByFamAndUser

Metodo DedProgManagerGetByFamAndUser
Restituisce un oggetto rappresentante la situazione dei progressivi assegnati ad un determinato utente su una specifica famiglia ( nella tabella DED_TIPI_PROG ).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static DedTypeProgList GetByFamAndUser(
    DedNetApplication app,
    DedTypeBase type,
    string username
)
Public Shared Function GetByFamAndUser (
    app As DedNetApplication,
    type As DedTypeBase,
    username As String
) As DedTypeProgList
public:
static DedTypeProgList^ GetByFamAndUser(
    DedNetApplication^ app,
    DedTypeBase^ type,
    String^ username
)
static member GetByFamAndUser :
        app : DedNetApplication *
        type : DedTypeBase *
        username : string -> DedTypeProgList

Parametri

app DedNetApplication
Applicazione di appartenenza.
type DedTypeBase
username String
Utente di interesse.

Valore di ritorno

DedTypeProgList
Vedi anche

Documentazione

Classe DedProgManager
Namespace DedNet.Core


Metodo DedProgManager.GetByFamNotUser

Metodo DedProgManagerGetByFamNotUser

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static DedTypeProgList GetByFamNotUser(
    DedNetApplication app,
    string dbpath,
    string userName
)
Public Shared Function GetByFamNotUser (
    app As DedNetApplication,
    dbpath As String,
    userName As String
) As DedTypeProgList
public:
static DedTypeProgList^ GetByFamNotUser(
    DedNetApplication^ app,
    String^ dbpath,
    String^ userName
)
static member GetByFamNotUser :
        app : DedNetApplication *
        dbpath : string *
        userName : string -> DedTypeProgList

Parametri

app DedNetApplication
dbpath String
userName String

Valore di ritorno

DedTypeProgList
Vedi anche

Documentazione

Classe DedProgManager
Namespace DedNet.Core


Metodo DedProgManager.GetByFamUser

Metodo DedProgManagerGetByFamUser

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static DedTypeProgList GetByFamUser(
    DedNetApplication app,
    string dbpath,
    string userName
)
Public Shared Function GetByFamUser (
    app As DedNetApplication,
    dbpath As String,
    userName As String
) As DedTypeProgList
public:
static DedTypeProgList^ GetByFamUser(
    DedNetApplication^ app,
    String^ dbpath,
    String^ userName
)
static member GetByFamUser :
        app : DedNetApplication *
        dbpath : string *
        userName : string -> DedTypeProgList

Parametri

app DedNetApplication
dbpath String
userName String

Valore di ritorno

DedTypeProgList
Vedi anche

Documentazione

Classe DedProgManager
Namespace DedNet.Core


Metodo DedProgManager.GetByUser

Metodo DedProgManagerGetByUser
Restituisce un dizionario contenente la situazione dei progressivi assegnati ad un determinato utente su tutte le famiglie ( nella tabella DED_TIPI_PROG ). Il dizionario è indicizzato per DBPATH.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static Dictionary<string, DedTypeProgList> GetByUser(
    DedNetApplication app,
    string username
)
Public Shared Function GetByUser (
    app As DedNetApplication,
    username As String
) As Dictionary(Of String, DedTypeProgList)
public:
static Dictionary<String^, DedTypeProgList^>^ GetByUser(
    DedNetApplication^ app,
    String^ username
)
static member GetByUser :
        app : DedNetApplication *
        username : string -> Dictionary<string, DedTypeProgList>

Parametri

app DedNetApplication
Applicazione di appartenenza.
username String
Utente di interesse.

Valore di ritorno

Dictionary String, DedTypeProgList
Vedi anche

Documentazione

Classe DedProgManager
Namespace DedNet.Core


Metodo DedProgManager.GetNearMinProg

Metodo DedProgManagerGetNearMinProg

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string GetNearMinProg(
    DedNetApplication app,
    string progMin,
    string dbpath
)
Public Shared Function GetNearMinProg (
    app As DedNetApplication,
    progMin As String,
    dbpath As String
) As String
public:
static String^ GetNearMinProg(
    DedNetApplication^ app,
    String^ progMin,
    String^ dbpath
)
static member GetNearMinProg :
        app : DedNetApplication *
        progMin : string *
        dbpath : string -> string

Parametri

app DedNetApplication
progMin String
dbpath String

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedProgManager
Namespace DedNet.Core


Metodo DedProgManager.IsProgReserved

Metodo DedProgManagerIsProgReserved
Restituisce se il progressivo da settare è già riservato a qualche utente. Internamente effettua una operazione RICORSIVA sui genitori della famiglia passata. In questo modo se la famiglia corrente ha un progressivo ereditato, il controllo viene effettuato su quella di livello superiore.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool IsProgReserved(
    DedTypeBase fam,
    string newValue
)
Public Shared Function IsProgReserved (
    fam As DedTypeBase,
    newValue As String
) As Boolean
public:
static bool IsProgReserved(
    DedTypeBase^ fam,
    String^ newValue
)
static member IsProgReserved :
        fam : DedTypeBase *
        newValue : string -> bool

Parametri

fam DedTypeBase
Famiglia sulla quale verificare il progressivo.
newValue String
Valore del progressivo da impostare.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedProgManager
Namespace DedNet.Core


Metodo DedProgManager.ReserveProg

Metodo DedProgManagerReserveProg

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool ReserveProg(
    DedNetApplication app,
    string guid,
    string dbpath,
    string username,
    string startProg,
    string endProg
)
Public Shared Function ReserveProg (
    app As DedNetApplication,
    guid As String,
    dbpath As String,
    username As String,
    startProg As String,
    endProg As String
) As Boolean
public:
static bool ReserveProg(
    DedNetApplication^ app,
    String^ guid,
    String^ dbpath,
    String^ username,
    String^ startProg,
    String^ endProg
)
static member ReserveProg :
        app : DedNetApplication *
        guid : string *
        dbpath : string *
        username : string *
        startProg : string *
        endProg : string -> bool

Parametri

app DedNetApplication
guid String
dbpath String
username String
startProg String
endProg String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedProgManager
Namespace DedNet.Core


Metodo DedProgManager.ReserveProgForSerializzation

Metodo DedProgManagerReserveProgForSerializzation
Assegna nella tabella DED_TIPI_PROG un insieme di progressivi in base al DedTypeProgList passato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool ReserveProgForSerializzation(
    DedNetApplication app,
    DedTypeProgListSerializable list
)
Public Shared Function ReserveProgForSerializzation (
    app As DedNetApplication,
    list As DedTypeProgListSerializable
) As Boolean
public:
static bool ReserveProgForSerializzation(
    DedNetApplication^ app,
    DedTypeProgListSerializable^ list
)
static member ReserveProgForSerializzation :
        app : DedNetApplication *
        list : DedTypeProgListSerializable -> bool

Parametri

app DedNetApplication
Applicazione di appartenenza.
list DedTypeProgListSerializable
Lista di oggetti DedTypeProg.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedProgManager
Namespace DedNet.Core


Metodo DedProgManager.UpdateReservedProg

Metodo DedProgManagerUpdateReservedProg
Aggiorna la riga in DED_TIPI_PROG

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool UpdateReservedProg(
    DedNetApplication app,
    DedTypeProg tipiProg
)
Public Shared Function UpdateReservedProg (
    app As DedNetApplication,
    tipiProg As DedTypeProg
) As Boolean
public:
static bool UpdateReservedProg(
    DedNetApplication^ app,
    DedTypeProg^ tipiProg
)
static member UpdateReservedProg :
        app : DedNetApplication *
        tipiProg : DedTypeProg -> bool

Parametri

app DedNetApplication
Applicazione di appartenenza.
tipiProg DedTypeProg

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedProgManager
Namespace DedNet.Core


Enumerazione DedPubActionEnum
Enumerazione sull'azione da effettuare sui documenti

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum DedPubActionEnum
Public Enumeration DedPubActionEnum
public enum class DedPubActionEnum
type DedPubActionEnum
Membri
Nome | Valore | Descrizione
None | 0 |
Crea | 1 |
Elimina | 2 |
Vedi anche

Documentazione

Namespace DedNet.Core


Classe DedPublicationCreationAvailableFormats
Formati disponibili per le operazioni di pubblicazione
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedPublicationCreationAvailableFormats

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedPublicationCreationAvailableFormats
Public Class DedPublicationCreationAvailableFormats
public ref class DedPublicationCreationAvailableFormats
type DedPublicationCreationAvailableFormats = class end

Il tipo DedPublicationCreationAvailableFormats espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedPublicationCreationAvailableFormats |
Torna su
Proprietà
Nome | Descrizione
Acad | Formati Autocad
Inventor | Formati Inventor
Office | Formati Office
SolidEdge | Formati Solidedge
Solidworks | Formati Solidworks
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedPublicationCreationAvailableFormats

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedPublicationCreationAvailableFormats()
Public Sub New
public:
DedPublicationCreationAvailableFormats()
new : unit -> DedPublicationCreationAvailableFormats
Vedi anche

Documentazione

Classe DedPublicationCreationAvailableFormats
Namespace DedNet.Core


Proprietà di DedPublicationCreationAvailableFormats

Il tipo DedPublicationCreationAvailableFormats espone i seguenti membri.

Proprietà
Nome | Descrizione
Acad | Formati Autocad
Inventor | Formati Inventor
Office | Formati Office
SolidEdge | Formati Solidedge
Solidworks | Formati Solidworks
Torna su
Vedi anche

Documentazione

Classe DedPublicationCreationAvailableFormats
Namespace DedNet.Core


Proprietà DedPublicationCreationAvailableFormats.Acad

Proprietà DedPublicationCreationAvailableFormatsAcad
Formati Autocad

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static List<DedPublicationFormat> Acad { get; }
Public Shared ReadOnly Property Acad As List(Of DedPublicationFormat)
    Get
public:
static property List<DedPublicationFormat>^ Acad {
    List<DedPublicationFormat>^ get ();
}
static member Acad : List<DedPublicationFormat> with get

Valore della proprietà

List DedPublicationFormat
Vedi anche

Documentazione

Classe DedPublicationCreationAvailableFormats
Namespace DedNet.Core


Proprietà DedPublicationCreationAvailableFormats.Inventor

Proprietà DedPublicationCreationAvailableFormatsInventor
Formati Inventor

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static List<DedPublicationFormat> Inventor { get; }
Public Shared ReadOnly Property Inventor As List(Of DedPublicationFormat)
    Get
public:
static property List<DedPublicationFormat>^ Inventor {
    List<DedPublicationFormat>^ get ();
}
static member Inventor : List<DedPublicationFormat> with get

Valore della proprietà

List DedPublicationFormat
Vedi anche

Documentazione

Classe DedPublicationCreationAvailableFormats
Namespace DedNet.Core


Proprietà DedPublicationCreationAvailableFormats.Office

Proprietà DedPublicationCreationAvailableFormatsOffice
Formati Office

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static List<DedPublicationFormat> Office { get; }
Public Shared ReadOnly Property Office As List(Of DedPublicationFormat)
    Get
public:
static property List<DedPublicationFormat>^ Office {
    List<DedPublicationFormat>^ get ();
}
static member Office : List<DedPublicationFormat> with get

Valore della proprietà

List DedPublicationFormat
Vedi anche

Documentazione

Classe DedPublicationCreationAvailableFormats
Namespace DedNet.Core


Proprietà DedPublicationCreationAvailableFormats.SolidEdge

Proprietà DedPublicationCreationAvailableFormatsSolidEdge
Formati Solidedge

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static List<DedPublicationFormat> SolidEdge { get; }
Public Shared ReadOnly Property SolidEdge As List(Of DedPublicationFormat)
    Get
public:
static property List<DedPublicationFormat>^ SolidEdge {
    List<DedPublicationFormat>^ get ();
}
static member SolidEdge : List<DedPublicationFormat> with get

Valore della proprietà

List DedPublicationFormat
Vedi anche

Documentazione

Classe DedPublicationCreationAvailableFormats
Namespace DedNet.Core


Proprietà DedPublicationCreationAvailableFormats.Solidworks

Proprietà DedPublicationCreationAvailableFormatsSolidworks
Formati Solidworks

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static List<DedPublicationFormat> Solidworks { get; }
Public Shared ReadOnly Property Solidworks As List(Of DedPublicationFormat)
    Get
public:
static property List<DedPublicationFormat>^ Solidworks {
    List<DedPublicationFormat>^ get ();
}
static member Solidworks : List<DedPublicationFormat> with get

Valore della proprietà

List DedPublicationFormat
Vedi anche

Documentazione

Classe DedPublicationCreationAvailableFormats
Namespace DedNet.Core


Classe DedPublicationDeletionAvailableFormats
Formati disponibili per le operazioni di eliminazione
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedPublicationDeletionAvailableFormats

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedPublicationDeletionAvailableFormats
Public Class DedPublicationDeletionAvailableFormats
public ref class DedPublicationDeletionAvailableFormats
type DedPublicationDeletionAvailableFormats = class end

Il tipo DedPublicationDeletionAvailableFormats espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedPublicationDeletionAvailableFormats |
Torna su
Proprietà
Nome | Descrizione
AllPlatforms | Tutti i formati
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedPublicationDeletionAvailableFormats

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedPublicationDeletionAvailableFormats()
Public Sub New
public:
DedPublicationDeletionAvailableFormats()
new : unit -> DedPublicationDeletionAvailableFormats
Vedi anche

Documentazione

Classe DedPublicationDeletionAvailableFormats
Namespace DedNet.Core


Proprietà di DedPublicationDeletionAvailableFormats

Il tipo DedPublicationDeletionAvailableFormats espone i seguenti membri.

Proprietà
Nome | Descrizione
AllPlatforms | Tutti i formati
Torna su
Vedi anche

Documentazione

Classe DedPublicationDeletionAvailableFormats
Namespace DedNet.Core


Proprietà DedPublicationDeletionAvailableFormats.AllPlatforms

Proprietà DedPublicationDeletionAvailableFormatsAllPlatforms
Tutti i formati

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static List<DedPublicationFormat> AllPlatforms { get; }
Public Shared ReadOnly Property AllPlatforms As List(Of DedPublicationFormat)
    Get
public:
static property List<DedPublicationFormat>^ AllPlatforms {
    List<DedPublicationFormat>^ get ();
}
static member AllPlatforms : List<DedPublicationFormat> with get

Valore della proprietà

List DedPublicationFormat
Vedi anche

Documentazione

Classe DedPublicationDeletionAvailableFormats
Namespace DedNet.Core


Enumerazione DedPublicationFormat
Enumerazione dei formati disponibili in fase di creazione/eliminazione

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum DedPublicationFormat
Public Enumeration DedPublicationFormat
public enum class DedPublicationFormat
type DedPublicationFormat
Membri
Nome | Valore | Descrizione
Undefined | 0 |
Dwf | 1 |
Dwg | 2 |
Dxf | 3 |
Iges | 4 |
Pdf | 5 |
Step | 6 |
Stl | 7 |
Dwf2D | 8 |
Dwf3D | 9 |
DwfEsploso | 10 |
DwgTop | 11 |
Dxf2D | 12 |
Dxf3D | 13 |
Pdf3D | 14 |
Wmf | 15 |
PdfExcel | 16 |
PdfWord | 17 |
Edrw | 18 |
Eprt | 19 |
Easm | 20 |
Vedi anche

Documentazione

Namespace DedNet.Core


Classe DedPublicationManager
Classe gestione formati di pubblicazione
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedPublicationManager

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedPublicationManager
Public Class DedPublicationManager
public ref class DedPublicationManager
type DedPublicationManager = class end

Il tipo DedPublicationManager espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedPublicationManager | Crea una nuova istanza della classe DedPublicationManager utilizzata per gestire le opzioni legate ai file di pubblicazione.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | CreationConfiguration | Oggetto contenente le opzioni per gestire i file di pubblicazione da CREARE quando viene rilasciata una anagrafica.
Proprietà pubblica | DeletionConfiguration | Oggetto contenente le opzioni per gestire i file di pubblicazione da NON CANCELLARE quando viene tolto il rilascio ad una anagrafica.
Proprietà pubblica | Dirty | Indica se l'oggetto ha delle modifiche appese NON ancora salvate.
Proprietà pubblica | FileNameConfiguration | Oggetto contenente le opzioni per gestire i file di pubblicazione con nomi dei formati
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Save | Salve le modifiche appese.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedPublicationManager
Crea una nuova istanza della classe DedPublicationManager utilizzata per gestire le opzioni legate ai file di pubblicazione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedPublicationManager(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedPublicationManager(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedPublicationManager

Parametri

app DedNetApplication
Applicazione DedNet.
Vedi anche

Documentazione

Classe DedPublicationManager
Namespace DedNet.Core


Proprietà di DedPublicationManager

Il tipo DedPublicationManager espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CreationConfiguration | Oggetto contenente le opzioni per gestire i file di pubblicazione da CREARE quando viene rilasciata una anagrafica.
Proprietà pubblica | DeletionConfiguration | Oggetto contenente le opzioni per gestire i file di pubblicazione da NON CANCELLARE quando viene tolto il rilascio ad una anagrafica.
Proprietà pubblica | Dirty | Indica se l'oggetto ha delle modifiche appese NON ancora salvate.
Proprietà pubblica | FileNameConfiguration | Oggetto contenente le opzioni per gestire i file di pubblicazione con nomi dei formati
Torna su
Vedi anche

Documentazione

Classe DedPublicationManager
Namespace DedNet.Core


Proprietà DedPublicationManager.CreationConfiguration

Proprietà DedPublicationManagerCreationConfiguration
Oggetto contenente le opzioni per gestire i file di pubblicazione da CREARE quando viene rilasciata una anagrafica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedPublishingCreationConfiguration CreationConfiguration { get; set; }
Public Property CreationConfiguration As DedPublishingCreationConfiguration
    Get
    Set
public:
property DedPublishingCreationConfiguration^ CreationConfiguration {
    DedPublishingCreationConfiguration^ get ();
    void set (DedPublishingCreationConfiguration^ value);
}
member CreationConfiguration : DedPublishingCreationConfiguration with get, set

Valore della proprietà

DedPublishingCreationConfiguration
Vedi anche

Documentazione

Classe DedPublicationManager
Namespace DedNet.Core


Proprietà DedPublicationManager.DeletionConfiguration

Proprietà DedPublicationManagerDeletionConfiguration
Oggetto contenente le opzioni per gestire i file di pubblicazione da NON CANCELLARE quando viene tolto il rilascio ad una anagrafica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedPublishingDeletionConfiguration DeletionConfiguration { get; set; }
Public Property DeletionConfiguration As DedPublishingDeletionConfiguration
    Get
    Set
public:
property DedPublishingDeletionConfiguration^ DeletionConfiguration {
    DedPublishingDeletionConfiguration^ get ();
    void set (DedPublishingDeletionConfiguration^ value);
}
member DeletionConfiguration : DedPublishingDeletionConfiguration with get, set

Valore della proprietà

DedPublishingDeletionConfiguration
Vedi anche

Documentazione

Classe DedPublicationManager
Namespace DedNet.Core


Proprietà DedPublicationManager.Dirty

Proprietà DedPublicationManagerDirty
Indica se l'oggetto ha delle modifiche appese NON ancora salvate.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Dirty { get; }
Public ReadOnly Property Dirty As Boolean
    Get
public:
property bool Dirty {
    bool get ();
}
member Dirty : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedPublicationManager
Namespace DedNet.Core


Proprietà DedPublicationManager.FileNameConfiguration

Proprietà DedPublicationManagerFileNameConfiguration
Oggetto contenente le opzioni per gestire i file di pubblicazione con nomi dei formati

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedPublishingFileNameConfiguration FileNameConfiguration { get; set; }
Public Property FileNameConfiguration As DedPublishingFileNameConfiguration
    Get
    Set
public:
property DedPublishingFileNameConfiguration^ FileNameConfiguration {
    DedPublishingFileNameConfiguration^ get ();
    void set (DedPublishingFileNameConfiguration^ value);
}
member FileNameConfiguration : DedPublishingFileNameConfiguration with get, set

Valore della proprietà

DedPublishingFileNameConfiguration
Vedi anche

Documentazione

Classe DedPublicationManager
Namespace DedNet.Core


Metodi di DedPublicationManager

Il tipo DedPublicationManager espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Save | Salve le modifiche appese.
Torna su
Vedi anche

Documentazione

Classe DedPublicationManager
Namespace DedNet.Core


Metodo DedPublicationManager.Save

Metodo DedPublicationManagerSave
Salve le modifiche appese.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Save()
Public Sub Save
public:
void Save()
member Save : unit -> unit
Vedi anche

Documentazione

Classe DedPublicationManager
Namespace DedNet.Core


Enumerazione DedPublicationPlatform
Enumerazione delle piattaforme disponibili di creazione

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum DedPublicationPlatform
Public Enumeration DedPublicationPlatform
public enum class DedPublicationPlatform
type DedPublicationPlatform
Membri
Nome | Valore | Descrizione
Undefined | 0 |
AutoCad | 1 |
Inventor | 2 |
SolidWorks | 3 |
Office | 4 |
SolidEdge | 5 |
Vedi anche

Documentazione

Namespace DedNet.Core


Classe DedPublishingBindingList
Lista di opzioni per il binding
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList DedPublishingOptionBinder
DedNet.CoreDedPublishingBindingList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedPublishingBindingList : List<DedPublishingOptionBinder>
Public Class DedPublishingBindingList
    Inherits List(Of DedPublishingOptionBinder)
public ref class DedPublishingBindingList : public List<DedPublishingOptionBinder^>
type DedPublishingBindingList =
    class
        inherit List<DedPublishingOptionBinder>
    end

Il tipo DedPublishingBindingList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedPublishingBindingList |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedPublishingBindingList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedPublishingBindingList()
Public Sub New
public:
DedPublishingBindingList()
new : unit -> DedPublishingBindingList
Vedi anche

Documentazione

Classe DedPublishingBindingList
Namespace DedNet.Core


Classe DedPublishingCreationConfiguration
Classe utilizzata per gestire i file di pubblicazione da CREARE quando viene rilasciata una anagrafica.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedPublishingCreationConfiguration

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedPublishingCreationConfiguration : IDedPublishingConfiguration<bool>
Public Class DedPublishingCreationConfiguration
    Implements IDedPublishingConfiguration(Of Boolean)
public ref class DedPublishingCreationConfiguration : IDedPublishingConfiguration<bool>
type DedPublishingCreationConfiguration =
    class
        interface IDedPublishingConfiguration<bool>
    end

Il tipo DedPublishingCreationConfiguration espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedPublishingCreationConfiguration | Classe utilizzata per gestire i file di pubblicazione da CREARE quando viene rilasciata una anagrafica.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Dirty | Indica se l'oggetto ha delle modifiche appese NON ancora salvate.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | GetAllOptions | Ritorna un dizionario contenente tutte le opzioni di pubblicazione. Il dizionario di ritorno è un clone di quello interno in modo tale che non sia possibile settare le proprietà interne se non passando dal metodo 'SetValue'.
Metodo pubblico | GetValue | Ritorna il valore di una proprietà.
Metodo pubblico | Save | Se l'oggetto è dirty, salva le modifiche appese.
Metodo pubblico | SetValue | Modifica il valore di una proprietà.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedPublishingCreationConfiguration
Classe utilizzata per gestire i file di pubblicazione da CREARE quando viene rilasciata una anagrafica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedPublishingCreationConfiguration(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedPublishingCreationConfiguration(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedPublishingCreationConfiguration

Parametri

app DedNetApplication
Applicazione DedNet.
Vedi anche

Documentazione

Classe DedPublishingCreationConfiguration
Namespace DedNet.Core


Proprietà di DedPublishingCreationConfiguration

Il tipo DedPublishingCreationConfiguration espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Dirty | Indica se l'oggetto ha delle modifiche appese NON ancora salvate.
Torna su
Vedi anche

Documentazione

Classe DedPublishingCreationConfiguration
Namespace DedNet.Core


Proprietà DedPublishingCreationConfiguration.Dirty

Proprietà DedPublishingCreationConfigurationDirty
Indica se l'oggetto ha delle modifiche appese NON ancora salvate.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Dirty { get; }
Public ReadOnly Property Dirty As Boolean
    Get
public:
virtual property bool Dirty {
    bool get () sealed;
}
abstract Dirty : bool with get
override Dirty : bool with get

Valore della proprietà

Boolean

Implementa

IDedPublishingConfigurationTDirty
Vedi anche

Documentazione

Classe DedPublishingCreationConfiguration
Namespace DedNet.Core


Metodi di DedPublishingCreationConfiguration

Il tipo DedPublishingCreationConfiguration espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | GetAllOptions | Ritorna un dizionario contenente tutte le opzioni di pubblicazione. Il dizionario di ritorno è un clone di quello interno in modo tale che non sia possibile settare le proprietà interne se non passando dal metodo 'SetValue'.
Metodo pubblico | GetValue | Ritorna il valore di una proprietà.
Metodo pubblico | Save | Se l'oggetto è dirty, salva le modifiche appese.
Metodo pubblico | SetValue | Modifica il valore di una proprietà.
Torna su
Vedi anche

Documentazione

Classe DedPublishingCreationConfiguration
Namespace DedNet.Core


Metodo DedPublishingCreationConfiguration.GetAllOptions

Metodo DedPublishingCreationConfigurationGetAllOptions
Ritorna un dizionario contenente tutte le opzioni di pubblicazione. Il dizionario di ritorno è un clone di quello interno in modo tale che non sia possibile settare le proprietà interne se non passando dal metodo 'SetValue'.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<DedPublicationPlatform, Dictionary<DedPublicationFormat, bool>> GetAllOptions()
Public Function GetAllOptions As Dictionary(Of DedPublicationPlatform, Dictionary(Of DedPublicationFormat, Boolean))
public:
Dictionary<DedPublicationPlatform, Dictionary<DedPublicationFormat, bool>^>^ GetAllOptions()
member GetAllOptions : unit -> Dictionary<DedPublicationPlatform, Dictionary<DedPublicationFormat, bool>>

Valore di ritorno

Dictionary DedPublicationPlatform, Dictionary DedPublicationFormat, Boolean
Vedi anche

Documentazione

Classe DedPublishingCreationConfiguration
Namespace DedNet.Core


Metodo DedPublishingCreationConfiguration.GetValue

Metodo DedPublishingCreationConfigurationGetValue
Ritorna il valore di una proprietà.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool GetValue(
    DedPublicationPlatform platform,
    DedPublicationFormat fmt
)
Public Function GetValue (
    platform As DedPublicationPlatform,
    fmt As DedPublicationFormat
) As Boolean
public:
virtual bool GetValue(
    DedPublicationPlatform platform,
    DedPublicationFormat fmt
) sealed
abstract GetValue :
        platform : DedPublicationPlatform *
        fmt : DedPublicationFormat -> bool
override GetValue :
        platform : DedPublicationPlatform *
        fmt : DedPublicationFormat -> bool

Parametri

platform DedPublicationPlatform
Stringa rappresentante il CAD a cui è associata l'opzione.
fmt DedPublicationFormat
Estensione di cui si vuole modificare il valore.

Valore di ritorno

Boolean

Implementa

IDedPublishingConfigurationTGetValue(DedPublicationPlatform, DedPublicationFormat)
Vedi anche

Documentazione

Classe DedPublishingCreationConfiguration
Namespace DedNet.Core


Metodo DedPublishingCreationConfiguration.Save

Metodo DedPublishingCreationConfigurationSave
Se l'oggetto è dirty, salva le modifiche appese.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Save()
Public Sub Save
public:
virtual void Save() sealed
abstract Save : unit -> unit
override Save : unit -> unit

Implementa

IDedPublishingConfigurationTSave
Vedi anche

Documentazione

Classe DedPublishingCreationConfiguration
Namespace DedNet.Core


Metodo DedPublishingCreationConfiguration.SetValue

Metodo DedPublishingCreationConfigurationSetValue
Modifica il valore di una proprietà.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetValue(
    DedPublicationPlatform platform,
    DedPublicationFormat fmt,
    bool newValue
)
Public Sub SetValue (
    platform As DedPublicationPlatform,
    fmt As DedPublicationFormat,
    newValue As Boolean
)
public:
virtual void SetValue(
    DedPublicationPlatform platform,
    DedPublicationFormat fmt,
    bool newValue
) sealed
abstract SetValue :
        platform : DedPublicationPlatform *
        fmt : DedPublicationFormat *
        newValue : bool -> unit
override SetValue :
        platform : DedPublicationPlatform *
        fmt : DedPublicationFormat *
        newValue : bool -> unit

Parametri

platform DedPublicationPlatform
Stringa rappresentante il CAD a cui è associata l'opzione.
fmt DedPublicationFormat
Estensione che di cui si vuole modificare il valore.
newValue Boolean
Nuovo valore.

Implementa

IDedPublishingConfigurationTSetValue(DedPublicationPlatform, DedPublicationFormat, T)
Vedi anche

Documentazione

Classe DedPublishingCreationConfiguration
Namespace DedNet.Core


Classe DedPublishingDeletionConfiguration
Classe contenente le opzioni per gestire i file di pubblicazione da NON CANCELLARE quando viene tolto il rilascio ad una anagrafica.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedPublishingDeletionConfiguration

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedPublishingDeletionConfiguration : IDedPublishingConfiguration<bool>
Public Class DedPublishingDeletionConfiguration
    Implements IDedPublishingConfiguration(Of Boolean)
public ref class DedPublishingDeletionConfiguration : IDedPublishingConfiguration<bool>
type DedPublishingDeletionConfiguration =
    class
        interface IDedPublishingConfiguration<bool>
    end

Il tipo DedPublishingDeletionConfiguration espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedPublishingDeletionConfiguration | Classe contenente le opzioni per gestire i file di pubblicazione da NON CANCELLARE quando viene tolto il rilascio ad una anagrafica.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Dirty | Indica se l'oggetto ha delle modifiche appese NON ancora salvate.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | GetAllOptions | Ritorna un dizionario contenente tutte le opzioni di pubblicazione. Il dizionario di ritorno è un clone di quello interno in modo tale che non sia possibile settare le proprietà interne se non passando dal metodo 'SetValue'.
Metodo pubblico | GetValue | Ritorna il valore di una proprietà.
Metodo pubblico | Save | Se l'oggetto è dirty, salva le modifiche appese.
Metodo pubblico | SetValue | Modifica il valore di una proprietà.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedPublishingDeletionConfiguration
Classe contenente le opzioni per gestire i file di pubblicazione da NON CANCELLARE quando viene tolto il rilascio ad una anagrafica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedPublishingDeletionConfiguration(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedPublishingDeletionConfiguration(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedPublishingDeletionConfiguration

Parametri

app DedNetApplication
Vedi anche

Documentazione

Classe DedPublishingDeletionConfiguration
Namespace DedNet.Core


Proprietà di DedPublishingDeletionConfiguration

Il tipo DedPublishingDeletionConfiguration espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Dirty | Indica se l'oggetto ha delle modifiche appese NON ancora salvate.
Torna su
Vedi anche

Documentazione

Classe DedPublishingDeletionConfiguration
Namespace DedNet.Core


Proprietà DedPublishingDeletionConfiguration.Dirty

Proprietà DedPublishingDeletionConfigurationDirty
Indica se l'oggetto ha delle modifiche appese NON ancora salvate.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Dirty { get; }
Public ReadOnly Property Dirty As Boolean
    Get
public:
virtual property bool Dirty {
    bool get () sealed;
}
abstract Dirty : bool with get
override Dirty : bool with get

Valore della proprietà

Boolean

Implementa

IDedPublishingConfigurationTDirty
Vedi anche

Documentazione

Classe DedPublishingDeletionConfiguration
Namespace DedNet.Core


Metodi di DedPublishingDeletionConfiguration

Il tipo DedPublishingDeletionConfiguration espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | GetAllOptions | Ritorna un dizionario contenente tutte le opzioni di pubblicazione. Il dizionario di ritorno è un clone di quello interno in modo tale che non sia possibile settare le proprietà interne se non passando dal metodo 'SetValue'.
Metodo pubblico | GetValue | Ritorna il valore di una proprietà.
Metodo pubblico | Save | Se l'oggetto è dirty, salva le modifiche appese.
Metodo pubblico | SetValue | Modifica il valore di una proprietà.
Torna su
Vedi anche

Documentazione

Classe DedPublishingDeletionConfiguration
Namespace DedNet.Core


Metodo DedPublishingDeletionConfiguration.GetAllOptions

Metodo DedPublishingDeletionConfigurationGetAllOptions
Ritorna un dizionario contenente tutte le opzioni di pubblicazione. Il dizionario di ritorno è un clone di quello interno in modo tale che non sia possibile settare le proprietà interne se non passando dal metodo 'SetValue'.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<DedPublicationFormat, bool> GetAllOptions()
Public Function GetAllOptions As Dictionary(Of DedPublicationFormat, Boolean)
public:
Dictionary<DedPublicationFormat, bool>^ GetAllOptions()
member GetAllOptions : unit -> Dictionary<DedPublicationFormat, bool>

Valore di ritorno

Dictionary DedPublicationFormat, Boolean
Vedi anche

Documentazione

Classe DedPublishingDeletionConfiguration
Namespace DedNet.Core


Metodo DedPublishingDeletionConfiguration.GetValue

Metodo DedPublishingDeletionConfigurationGetValue
Ritorna il valore di una proprietà.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool GetValue(
    DedPublicationPlatform platform,
    DedPublicationFormat fmt
)
Public Function GetValue (
    platform As DedPublicationPlatform,
    fmt As DedPublicationFormat
) As Boolean
public:
virtual bool GetValue(
    DedPublicationPlatform platform,
    DedPublicationFormat fmt
) sealed
abstract GetValue :
        platform : DedPublicationPlatform *
        fmt : DedPublicationFormat -> bool
override GetValue :
        platform : DedPublicationPlatform *
        fmt : DedPublicationFormat -> bool

Parametri

platform DedPublicationPlatform
Cad di riferimento. Ignorato
fmt DedPublicationFormat
Estensione di cui si vuole modificare il valore.

Valore di ritorno

Boolean

Implementa

IDedPublishingConfigurationTGetValue(DedPublicationPlatform, DedPublicationFormat)
Vedi anche

Documentazione

Classe DedPublishingDeletionConfiguration
Namespace DedNet.Core


Metodo DedPublishingDeletionConfiguration.Save

Metodo DedPublishingDeletionConfigurationSave
Se l'oggetto è dirty, salva le modifiche appese.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Save()
Public Sub Save
public:
virtual void Save() sealed
abstract Save : unit -> unit
override Save : unit -> unit

Implementa

IDedPublishingConfigurationTSave
Vedi anche

Documentazione

Classe DedPublishingDeletionConfiguration
Namespace DedNet.Core


Metodo DedPublishingDeletionConfiguration.SetValue

Metodo DedPublishingDeletionConfigurationSetValue
Modifica il valore di una proprietà.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetValue(
    DedPublicationPlatform platform,
    DedPublicationFormat fmt,
    bool newValue
)
Public Sub SetValue (
    platform As DedPublicationPlatform,
    fmt As DedPublicationFormat,
    newValue As Boolean
)
public:
virtual void SetValue(
    DedPublicationPlatform platform,
    DedPublicationFormat fmt,
    bool newValue
) sealed
abstract SetValue :
        platform : DedPublicationPlatform *
        fmt : DedPublicationFormat *
        newValue : bool -> unit
override SetValue :
        platform : DedPublicationPlatform *
        fmt : DedPublicationFormat *
        newValue : bool -> unit

Parametri

platform DedPublicationPlatform
Cad di riferimento. Ignorato
fmt DedPublicationFormat
Estensione che di cui si vuole modificare il valore.
newValue Boolean
Nuovo valore.

Implementa

IDedPublishingConfigurationTSetValue(DedPublicationPlatform, DedPublicationFormat, T)
Vedi anche

Documentazione

Classe DedPublishingDeletionConfiguration
Namespace DedNet.Core


Classe DedPublishingFileNameConfiguration
Classe utilizzata per gestire i file di pubblicazione da CREARE quando viene rilasciata una anagrafica.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedPublishingFileNameConfiguration

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedPublishingFileNameConfiguration : IDedPublishingConfiguration<string>
Public Class DedPublishingFileNameConfiguration
    Implements IDedPublishingConfiguration(Of String)
public ref class DedPublishingFileNameConfiguration : IDedPublishingConfiguration<String^>
type DedPublishingFileNameConfiguration =
    class
        interface IDedPublishingConfiguration<string>
    end

Il tipo DedPublishingFileNameConfiguration espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedPublishingFileNameConfiguration | Classe utilizzata per gestire i file di pubblicazione da CREARE quando viene rilasciata una anagrafica.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | DictAcadExt | Dizionario con i formati di default di AutoCAD
Proprietà pubblica | DictInventorExt | Dizionario con i formati di default di Inventor
Proprietà pubblica | DictOfficeExt | Dizionario con i formati di default di Office
Proprietà pubblica | DictSolidedgeExt | Dizionario con i formati di default di SolidEdge
Proprietà pubblica | DictSolidworksExt | Dizionario con i formati di default di SolidWorks
Proprietà pubblica | Dirty | Indica se l'oggetto ha delle modifiche appese NON ancora salvate.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | GetAllOptions | Ritorna un dizionario contenente tutte le opzioni di pubblicazione. Il dizionario di ritorno è un clone di quello interno in modo tale che non sia possibile settare le proprietà interne se non passando dal metodo 'SetValue'.
Metodo pubblico | GetValue | Ritorna il valore di un formato
Metodo pubblico | Save | Se l'oggetto è dirty, salva le modifiche appese.
Metodo pubblico | SetValue | Modifica il valore del formato
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedPublishingFileNameConfiguration
Classe utilizzata per gestire i file di pubblicazione da CREARE quando viene rilasciata una anagrafica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedPublishingFileNameConfiguration(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedPublishingFileNameConfiguration(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedPublishingFileNameConfiguration

Parametri

app DedNetApplication
Applicazione DedNet.
Vedi anche

Documentazione

Classe DedPublishingFileNameConfiguration
Namespace DedNet.Core


Proprietà di DedPublishingFileNameConfiguration

Il tipo DedPublishingFileNameConfiguration espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | DictAcadExt | Dizionario con i formati di default di AutoCAD
Proprietà pubblica | DictInventorExt | Dizionario con i formati di default di Inventor
Proprietà pubblica | DictOfficeExt | Dizionario con i formati di default di Office
Proprietà pubblica | DictSolidedgeExt | Dizionario con i formati di default di SolidEdge
Proprietà pubblica | DictSolidworksExt | Dizionario con i formati di default di SolidWorks
Proprietà pubblica | Dirty | Indica se l'oggetto ha delle modifiche appese NON ancora salvate.
Torna su
Vedi anche

Documentazione

Classe DedPublishingFileNameConfiguration
Namespace DedNet.Core


Proprietà DedPublishingFileNameConfiguration.DictAcadExt

Proprietà DedPublishingFileNameConfigurationDictAcadExt
Dizionario con i formati di default di AutoCAD

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<DedPublicationFormat, string> DictAcadExt { get; }
Public ReadOnly Property DictAcadExt As Dictionary(Of DedPublicationFormat, String)
    Get
public:
property Dictionary<DedPublicationFormat, String^>^ DictAcadExt {
    Dictionary<DedPublicationFormat, String^>^ get ();
}
member DictAcadExt : Dictionary<DedPublicationFormat, string> with get

Valore della proprietà

Dictionary DedPublicationFormat, String
Vedi anche

Documentazione

Classe DedPublishingFileNameConfiguration
Namespace DedNet.Core


Proprietà DedPublishingFileNameConfiguration.DictInventorExt

Proprietà DedPublishingFileNameConfigurationDictInventorExt
Dizionario con i formati di default di Inventor

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<DedPublicationFormat, string> DictInventorExt { get; }
Public ReadOnly Property DictInventorExt As Dictionary(Of DedPublicationFormat, String)
    Get
public:
property Dictionary<DedPublicationFormat, String^>^ DictInventorExt {
    Dictionary<DedPublicationFormat, String^>^ get ();
}
member DictInventorExt : Dictionary<DedPublicationFormat, string> with get

Valore della proprietà

Dictionary DedPublicationFormat, String
Vedi anche

Documentazione

Classe DedPublishingFileNameConfiguration
Namespace DedNet.Core


Proprietà DedPublishingFileNameConfiguration.DictOfficeExt

Proprietà DedPublishingFileNameConfigurationDictOfficeExt
Dizionario con i formati di default di Office

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<DedPublicationFormat, string> DictOfficeExt { get; }
Public ReadOnly Property DictOfficeExt As Dictionary(Of DedPublicationFormat, String)
    Get
public:
property Dictionary<DedPublicationFormat, String^>^ DictOfficeExt {
    Dictionary<DedPublicationFormat, String^>^ get ();
}
member DictOfficeExt : Dictionary<DedPublicationFormat, string> with get

Valore della proprietà

Dictionary DedPublicationFormat, String
Vedi anche

Documentazione

Classe DedPublishingFileNameConfiguration
Namespace DedNet.Core


Proprietà DedPublishingFileNameConfiguration.DictSolidedgeExt

Proprietà DedPublishingFileNameConfigurationDictSolidedgeExt
Dizionario con i formati di default di SolidEdge

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<DedPublicationFormat, string> DictSolidedgeExt { get; }
Public ReadOnly Property DictSolidedgeExt As Dictionary(Of DedPublicationFormat, String)
    Get
public:
property Dictionary<DedPublicationFormat, String^>^ DictSolidedgeExt {
    Dictionary<DedPublicationFormat, String^>^ get ();
}
member DictSolidedgeExt : Dictionary<DedPublicationFormat, string> with get

Valore della proprietà

Dictionary DedPublicationFormat, String
Vedi anche

Documentazione

Classe DedPublishingFileNameConfiguration
Namespace DedNet.Core


Proprietà DedPublishingFileNameConfiguration.DictSolidworksExt

Proprietà DedPublishingFileNameConfigurationDictSolidworksExt
Dizionario con i formati di default di SolidWorks

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<DedPublicationFormat, string> DictSolidworksExt { get; }
Public ReadOnly Property DictSolidworksExt As Dictionary(Of DedPublicationFormat, String)
    Get
public:
property Dictionary<DedPublicationFormat, String^>^ DictSolidworksExt {
    Dictionary<DedPublicationFormat, String^>^ get ();
}
member DictSolidworksExt : Dictionary<DedPublicationFormat, string> with get

Valore della proprietà

Dictionary DedPublicationFormat, String
Vedi anche

Documentazione

Classe DedPublishingFileNameConfiguration
Namespace DedNet.Core


Proprietà DedPublishingFileNameConfiguration.Dirty

Proprietà DedPublishingFileNameConfigurationDirty
Indica se l'oggetto ha delle modifiche appese NON ancora salvate.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Dirty { get; }
Public ReadOnly Property Dirty As Boolean
    Get
public:
virtual property bool Dirty {
    bool get () sealed;
}
abstract Dirty : bool with get
override Dirty : bool with get

Valore della proprietà

Boolean

Implementa

IDedPublishingConfigurationTDirty
Vedi anche

Documentazione

Classe DedPublishingFileNameConfiguration
Namespace DedNet.Core


Metodi di DedPublishingFileNameConfiguration

Il tipo DedPublishingFileNameConfiguration espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | GetAllOptions | Ritorna un dizionario contenente tutte le opzioni di pubblicazione. Il dizionario di ritorno è un clone di quello interno in modo tale che non sia possibile settare le proprietà interne se non passando dal metodo 'SetValue'.
Metodo pubblico | GetValue | Ritorna il valore di un formato
Metodo pubblico | Save | Se l'oggetto è dirty, salva le modifiche appese.
Metodo pubblico | SetValue | Modifica il valore del formato
Torna su
Vedi anche

Documentazione

Classe DedPublishingFileNameConfiguration
Namespace DedNet.Core


Metodo DedPublishingFileNameConfiguration.GetAllOptions

Metodo DedPublishingFileNameConfigurationGetAllOptions
Ritorna un dizionario contenente tutte le opzioni di pubblicazione. Il dizionario di ritorno è un clone di quello interno in modo tale che non sia possibile settare le proprietà interne se non passando dal metodo 'SetValue'.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<DedPublicationPlatform, Dictionary<DedPublicationFormat, string>> GetAllOptions()
Public Function GetAllOptions As Dictionary(Of DedPublicationPlatform, Dictionary(Of DedPublicationFormat, String))
public:
Dictionary<DedPublicationPlatform, Dictionary<DedPublicationFormat, String^>^>^ GetAllOptions()
member GetAllOptions : unit -> Dictionary<DedPublicationPlatform, Dictionary<DedPublicationFormat, string>>

Valore di ritorno

Dictionary DedPublicationPlatform, Dictionary DedPublicationFormat, String
Vedi anche

Documentazione

Classe DedPublishingFileNameConfiguration
Namespace DedNet.Core


Metodo DedPublishingFileNameConfiguration.GetValue

Metodo DedPublishingFileNameConfigurationGetValue
Ritorna il valore di un formato

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string GetValue(
    DedPublicationPlatform platform,
    DedPublicationFormat fmt
)
Public Function GetValue (
    platform As DedPublicationPlatform,
    fmt As DedPublicationFormat
) As String
public:
virtual String^ GetValue(
    DedPublicationPlatform platform,
    DedPublicationFormat fmt
) sealed
abstract GetValue :
        platform : DedPublicationPlatform *
        fmt : DedPublicationFormat -> string
override GetValue :
        platform : DedPublicationPlatform *
        fmt : DedPublicationFormat -> string

Parametri

platform DedPublicationPlatform
Stringa rappresentante il CAD a cui è associata l'opzione.
fmt DedPublicationFormat
Estensione di cui si vuole modificare il valore.

Valore di ritorno

String

Implementa

IDedPublishingConfigurationTGetValue(DedPublicationPlatform, DedPublicationFormat)
Vedi anche

Documentazione

Classe DedPublishingFileNameConfiguration
Namespace DedNet.Core


Metodo DedPublishingFileNameConfiguration.Save

Metodo DedPublishingFileNameConfigurationSave
Se l'oggetto è dirty, salva le modifiche appese.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Save()
Public Sub Save
public:
virtual void Save() sealed
abstract Save : unit -> unit
override Save : unit -> unit

Implementa

IDedPublishingConfigurationTSave
Vedi anche

Documentazione

Classe DedPublishingFileNameConfiguration
Namespace DedNet.Core


Metodo DedPublishingFileNameConfiguration.SetValue

Metodo DedPublishingFileNameConfigurationSetValue
Modifica il valore del formato

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetValue(
    DedPublicationPlatform platform,
    DedPublicationFormat fmt,
    string newValue
)
Public Sub SetValue (
    platform As DedPublicationPlatform,
    fmt As DedPublicationFormat,
    newValue As String
)
public:
virtual void SetValue(
    DedPublicationPlatform platform,
    DedPublicationFormat fmt,
    String^ newValue
) sealed
abstract SetValue :
        platform : DedPublicationPlatform *
        fmt : DedPublicationFormat *
        newValue : string -> unit
override SetValue :
        platform : DedPublicationPlatform *
        fmt : DedPublicationFormat *
        newValue : string -> unit

Parametri

platform DedPublicationPlatform
Stringa rappresentante il CAD a cui è associata l'opzione.
fmt DedPublicationFormat
Estensione che di cui si vuole modificare il valore.
newValue String
Nuovo valore.

Implementa

IDedPublishingConfigurationTSetValue(DedPublicationPlatform, DedPublicationFormat, T)
Vedi anche

Documentazione

Classe DedPublishingFileNameConfiguration
Namespace DedNet.Core


Classe DedPublishingOffice
Manager delle pubblicazioni dei file di office
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedPublishingOffice

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedPublishingOffice
Public Class DedPublishingOffice
public ref class DedPublishingOffice
type DedPublishingOffice = class end

Il tipo DedPublishingOffice espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedPublishingOffice |
Torna su
Metodi
Nome | Descrizione
AddPublishStateHandler | Aggancia l'evento per la pubblicazione office
app_StateCommandOfficeDocPublishEvent | Evento per la creazione dei documenti di Office, aggiunge #XLSX/#DOCX.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedPublishingOffice

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedPublishingOffice()
Public Sub New
public:
DedPublishingOffice()
new : unit -> DedPublishingOffice
Vedi anche

Documentazione

Classe DedPublishingOffice
Namespace DedNet.Core


Metodi di DedPublishingOffice

Il tipo DedPublishingOffice espone i seguenti membri.

Metodi
Nome | Descrizione
AddPublishStateHandler | Aggancia l'evento per la pubblicazione office
app_StateCommandOfficeDocPublishEvent | Evento per la creazione dei documenti di Office, aggiunge #XLSX/#DOCX.
Torna su
Vedi anche

Documentazione

Classe DedPublishingOffice
Namespace DedNet.Core


Metodo DedPublishingOffice.AddPublishStateHandler

Metodo DedPublishingOfficeAddPublishStateHandler
Aggancia l'evento per la pubblicazione office

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void AddPublishStateHandler(
    DedNetApplication app
)
Public Shared Sub AddPublishStateHandler (
    app As DedNetApplication
)
public:
static void AddPublishStateHandler(
    DedNetApplication^ app
)
static member AddPublishStateHandler :
        app : DedNetApplication -> unit

Parametri

app DedNetApplication
Vedi anche

Documentazione

Classe DedPublishingOffice
Namespace DedNet.Core


Metodo DedPublishingOffice.app_StateCommandOfficeDocPublishEvent

Metodo DedPublishingOfficeapp_StateCommandOfficeDocPublishEvent
Evento per la creazione dei documenti di Office, aggiunge #XLSX/#DOCX.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void app_StateCommandOfficeDocPublishEvent(
    Object sender,
    StateCommandEventArgs ev
)
Public Shared Sub app_StateCommandOfficeDocPublishEvent (
    sender As Object,
    ev As StateCommandEventArgs
)
public:
static void app_StateCommandOfficeDocPublishEvent(
    Object^ sender,
    StateCommandEventArgs^ ev
)
static member app_StateCommandOfficeDocPublishEvent :
        sender : Object *
        ev : StateCommandEventArgs -> unit

Parametri

sender Object
ev StateCommandEventArgs
Vedi anche

Documentazione

Classe DedPublishingOffice
Namespace DedNet.Core


Classe DedPublishingOptionBinder
Classe che rappresenta la singola opzione per effettuare il binsding nelle source del form
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedPublishingOptionBinder

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedPublishingOptionBinder
Public Class DedPublishingOptionBinder
public ref class DedPublishingOptionBinder
type DedPublishingOptionBinder = class end

Il tipo DedPublishingOptionBinder espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedPublishingOptionBinder(DedPublicationFormat, Boolean, IDedPublishingConfigurationBoolean) | Costrutt
Metodo pubblico | DedPublishingOptionBinder(DedPublicationPlatform, DedPublicationFormat, Boolean, String, IDedPublishingConfigurationBoolean) | Crea una nuova istanza della classe di binding della singola opzione.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | CAD | Stringa rappresentate il CAD a cui l'opzione è legata.
Proprietà pubblica | Estensione | Stringa rappresentate l'estensione del file di pubblicazione.
Proprietà pubblica | Nome_Formato | Stringa usata per definire il nuovo formato
Proprietà pubblica | Valore | Valore dell'opzione.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedPublishingOptionBinder
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | DedPublishingOptionBinder(DedPublicationFormat, Boolean, IDedPublishingConfigurationBoolean) | Costrutt
Metodo pubblico | DedPublishingOptionBinder(DedPublicationPlatform, DedPublicationFormat, Boolean, String, IDedPublishingConfigurationBoolean) | Crea una nuova istanza della classe di binding della singola opzione.
Torna su
Vedi anche

Documentazione

Classe DedPublishingOptionBinder
Namespace DedNet.Core


Costruttore DedPublishingOptionBinder(DedPublicationFormat, Boolean, IDedPublishingConfiguration<Boolean>)

Costruttore DedPublishingOptionBinder(DedPublicationFormat, Boolean, IDedPublishingConfigurationBoolean)
Costrutt

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedPublishingOptionBinder(
    DedPublicationFormat ext,
    bool val,
    IDedPublishingConfiguration<bool> optValCfg
)
Public Sub New (
    ext As DedPublicationFormat,
    val As Boolean,
    optValCfg As IDedPublishingConfiguration(Of Boolean)
)
public:
DedPublishingOptionBinder(
    DedPublicationFormat ext,
    bool val,
    IDedPublishingConfiguration<bool>^ optValCfg
)
new :
        ext : DedPublicationFormat *
        val : bool *
        optValCfg : IDedPublishingConfiguration<bool> -> DedPublishingOptionBinder

Parametri

ext DedPublicationFormat
val Boolean
optValCfg IDedPublishingConfiguration Boolean
Oggetto contenente tutte le opzioni di eliminazione
Vedi anche

Documentazione

Classe DedPublishingOptionBinder
Overload di DedPublishingOptionBinder
Namespace DedNet.Core


Costruttore DedPublishingOptionBinder(DedPublicationPlatform, DedPublicationFormat, Boolean, String, IDedPublishingConfiguration<Boolean>)

Costruttore DedPublishingOptionBinder(DedPublicationPlatform, DedPublicationFormat, Boolean, String, IDedPublishingConfigurationBoolean)
Crea una nuova istanza della classe di binding della singola opzione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedPublishingOptionBinder(
    DedPublicationPlatform cad,
    DedPublicationFormat ext,
    bool val,
    string formatName,
    IDedPublishingConfiguration<bool> optValCfg
)
Public Sub New (
    cad As DedPublicationPlatform,
    ext As DedPublicationFormat,
    val As Boolean,
    formatName As String,
    optValCfg As IDedPublishingConfiguration(Of Boolean)
)
public:
DedPublishingOptionBinder(
    DedPublicationPlatform cad,
    DedPublicationFormat ext,
    bool val,
    String^ formatName,
    IDedPublishingConfiguration<bool>^ optValCfg
)
new :
        cad : DedPublicationPlatform *
        ext : DedPublicationFormat *
        val : bool *
        formatName : string *
        optValCfg : IDedPublishingConfiguration<bool> -> DedPublishingOptionBinder

Parametri

cad DedPublicationPlatform
Stringa rappresentate il CAD a cui l'opzione è legata.
ext DedPublicationFormat
Stringa rappresentate l'estensione del file di pubblicazione.
val Boolean
Valore dell'opzione.
formatName String
optValCfg IDedPublishingConfiguration Boolean
Oggetto contenente tutte le opzioni di creazione
Vedi anche

Documentazione

Classe DedPublishingOptionBinder
Overload di DedPublishingOptionBinder
Namespace DedNet.Core


Proprietà di DedPublishingOptionBinder

Il tipo DedPublishingOptionBinder espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CAD | Stringa rappresentate il CAD a cui l'opzione è legata.
Proprietà pubblica | Estensione | Stringa rappresentate l'estensione del file di pubblicazione.
Proprietà pubblica | Nome_Formato | Stringa usata per definire il nuovo formato
Proprietà pubblica | Valore | Valore dell'opzione.
Torna su
Vedi anche

Documentazione

Classe DedPublishingOptionBinder
Namespace DedNet.Core


Proprietà DedPublishingOptionBinder.CAD

Proprietà DedPublishingOptionBinderCAD
Stringa rappresentate il CAD a cui l'opzione è legata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedPublicationPlatform CAD { get; }
Public ReadOnly Property CAD As DedPublicationPlatform
    Get
public:
property DedPublicationPlatform CAD {
    DedPublicationPlatform get ();
}
member CAD : DedPublicationPlatform with get

Valore della proprietà

DedPublicationPlatform
Vedi anche

Documentazione

Classe DedPublishingOptionBinder
Namespace DedNet.Core


Proprietà DedPublishingOptionBinder.Estensione

Proprietà DedPublishingOptionBinderEstensione
Stringa rappresentate l'estensione del file di pubblicazione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedPublicationFormat Estensione { get; }
Public ReadOnly Property Estensione As DedPublicationFormat
    Get
public:
property DedPublicationFormat Estensione {
    DedPublicationFormat get ();
}
member Estensione : DedPublicationFormat with get

Valore della proprietà

DedPublicationFormat
Vedi anche

Documentazione

Classe DedPublishingOptionBinder
Namespace DedNet.Core


Proprietà DedPublishingOptionBinder.Nome_Formato

Proprietà DedPublishingOptionBinderNome_Formato
Stringa usata per definire il nuovo formato

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Nome_Formato { get; set; }
Public Property Nome_Formato As String
    Get
    Set
public:
property String^ Nome_Formato {
    String^ get ();
    void set (String^ value);
}
member Nome_Formato : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedPublishingOptionBinder
Namespace DedNet.Core


Proprietà DedPublishingOptionBinder.Valore

Proprietà DedPublishingOptionBinderValore
Valore dell'opzione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Valore { get; set; }
Public Property Valore As Boolean
    Get
    Set
public:
property bool Valore {
    bool get ();
    void set (bool value);
}
member Valore : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedPublishingOptionBinder
Namespace DedNet.Core


Classe DedRoot
Contiene le informazioni riguardanti una root.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedRoot

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedRoot : IDedDbItem
Public Class DedRoot
    Implements IDedDbItem
public ref class DedRoot : IDedDbItem
type DedRoot =
    class
        interface IDedDbItem
    end

Il tipo DedRoot espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Desc | Restituisce o imposta la descrizione.
Proprietà pubblica | Name | Restituisce il nome della root.
Proprietà pubblica | NameWithPercent | Restituisce il nome della root con i % avanti e dietro.
Proprietà pubblica | NormalizedPathDb | Restituisce o imposta il percorso di database normalizzato.
Proprietà pubblica | NormalizedPathLocal | Restituisce o imposta il percorso di database normalizzato.
Proprietà pubblica | Parent | Restituisce la collezione di appartenenza dell'elemento.
Proprietà pubblica | PathDb | Restituisce il percorso di database. Per settarlo usare UnRootedPathDb.
Proprietà pubblica | PathLocal | Restituisce o imposta il percorso locale.
Proprietà pubblica | RadixPath | Restituisce o imposta il percorso locale.
Proprietà pubblica | RelativePathLocal | Restituisce o imposta il percorso locale.
Proprietà pubblica | RootDocOpType | Restituisce o imposta il tipo di operazione da fare sui documenti.
Proprietà pubblica | RootType | Restituisce o imposta il tipo di Root.
Proprietà pubblica | StatoRecord | Restituisce o imposta lo stato del record. DI USO INTERNO !!
Proprietà pubblica | UnRootedPathDb | Restituisce o imposta il percorso di database.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di DedRoot

Il tipo DedRoot espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Desc | Restituisce o imposta la descrizione.
Proprietà pubblica | Name | Restituisce il nome della root.
Proprietà pubblica | NameWithPercent | Restituisce il nome della root con i % avanti e dietro.
Proprietà pubblica | NormalizedPathDb | Restituisce o imposta il percorso di database normalizzato.
Proprietà pubblica | NormalizedPathLocal | Restituisce o imposta il percorso di database normalizzato.
Proprietà pubblica | Parent | Restituisce la collezione di appartenenza dell'elemento.
Proprietà pubblica | PathDb | Restituisce il percorso di database. Per settarlo usare UnRootedPathDb.
Proprietà pubblica | PathLocal | Restituisce o imposta il percorso locale.
Proprietà pubblica | RadixPath | Restituisce o imposta il percorso locale.
Proprietà pubblica | RelativePathLocal | Restituisce o imposta il percorso locale.
Proprietà pubblica | RootDocOpType | Restituisce o imposta il tipo di operazione da fare sui documenti.
Proprietà pubblica | RootType | Restituisce o imposta il tipo di Root.
Proprietà pubblica | StatoRecord | Restituisce o imposta lo stato del record. DI USO INTERNO !!
Proprietà pubblica | UnRootedPathDb | Restituisce o imposta il percorso di database.
Torna su
Vedi anche

Documentazione

Classe DedRoot
Namespace DedNet.Core


Proprietà DedRoot.Desc

Proprietà DedRootDesc
Restituisce o imposta la descrizione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Desc { get; set; }
Public Property Desc As String
    Get
    Set
public:
property String^ Desc {
    String^ get ();
    void set (String^ value);
}
member Desc : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedRoot
Namespace DedNet.Core


Proprietà DedRoot.Name

Proprietà DedRootName
Restituisce il nome della root.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedRoot
Namespace DedNet.Core


Proprietà DedRoot.NameWithPercent

Proprietà DedRootNameWithPercent
Restituisce il nome della root con i % avanti e dietro.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string NameWithPercent { get; }
Public ReadOnly Property NameWithPercent As String
    Get
public:
property String^ NameWithPercent {
    String^ get ();
}
member NameWithPercent : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedRoot
Namespace DedNet.Core


Proprietà DedRoot.NormalizedPathDb

Proprietà DedRootNormalizedPathDb
Restituisce o imposta il percorso di database normalizzato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string NormalizedPathDb { get; }
Public ReadOnly Property NormalizedPathDb As String
    Get
public:
property String^ NormalizedPathDb {
    String^ get ();
}
member NormalizedPathDb : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedRoot
Namespace DedNet.Core


Proprietà DedRoot.NormalizedPathLocal

Proprietà DedRootNormalizedPathLocal
Restituisce o imposta il percorso di database normalizzato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string NormalizedPathLocal { get; }
Public ReadOnly Property NormalizedPathLocal As String
    Get
public:
property String^ NormalizedPathLocal {
    String^ get ();
}
member NormalizedPathLocal : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedRoot
Namespace DedNet.Core


Proprietà DedRoot.Parent

Proprietà DedRootParent
Restituisce la collezione di appartenenza dell'elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedRoots Parent { get; set; }
Public Property Parent As DedRoots
    Get
    Set
public:
property DedRoots^ Parent {
    DedRoots^ get ();
    void set (DedRoots^ value);
}
member Parent : DedRoots with get, set

Valore della proprietà

DedRoots
Vedi anche

Documentazione

Classe DedRoot
Namespace DedNet.Core


Proprietà DedRoot.PathDb

Proprietà DedRootPathDb
Restituisce il percorso di database. Per settarlo usare UnRootedPathDb.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string PathDb { get; }
Public ReadOnly Property PathDb As String
    Get
public:
property String^ PathDb {
    String^ get ();
}
member PathDb : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedRoot
Namespace DedNet.Core


Proprietà DedRoot.PathLocal

Proprietà DedRootPathLocal
Restituisce o imposta il percorso locale.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string PathLocal { get; set; }
Public Property PathLocal As String
    Get
    Set
public:
property String^ PathLocal {
    String^ get ();
    void set (String^ value);
}
member PathLocal : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedRoot
Namespace DedNet.Core


Proprietà DedRoot.RadixPath

Proprietà DedRootRadixPath
Restituisce o imposta il percorso locale.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string RadixPath { get; set; }
Public Property RadixPath As String
    Get
    Set
public:
property String^ RadixPath {
    String^ get ();
    void set (String^ value);
}
member RadixPath : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedRoot
Namespace DedNet.Core


Proprietà DedRoot.RelativePathLocal

Proprietà DedRootRelativePathLocal
Restituisce o imposta il percorso locale.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string RelativePathLocal { get; set; }
Public Property RelativePathLocal As String
    Get
    Set
public:
property String^ RelativePathLocal {
    String^ get ();
    void set (String^ value);
}
member RelativePathLocal : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedRoot
Namespace DedNet.Core


Proprietà DedRoot.RootDocOpType

Proprietà DedRootRootDocOpType
Restituisce o imposta il tipo di operazione da fare sui documenti.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocumentOperationEnum RootDocOpType { get; set; }
Public Property RootDocOpType As DocumentOperationEnum
    Get
    Set
public:
property DocumentOperationEnum RootDocOpType {
    DocumentOperationEnum get ();
    void set (DocumentOperationEnum value);
}
member RootDocOpType : DocumentOperationEnum with get, set

Valore della proprietà

DocumentOperationEnum
Vedi anche

Documentazione

Classe DedRoot
Namespace DedNet.Core


Proprietà DedRoot.RootType

Proprietà DedRootRootType
Restituisce o imposta il tipo di Root.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedRootRootTypeEnum RootType { get; set; }
Public Property RootType As DedRootRootTypeEnum
    Get
    Set
public:
property DedRootRootTypeEnum RootType {
    DedRootRootTypeEnum get ();
    void set (DedRootRootTypeEnum value);
}
member RootType : DedRootRootTypeEnum with get, set

Valore della proprietà

DedRootRootTypeEnum
Vedi anche

Documentazione

Classe DedRoot
Namespace DedNet.Core


Proprietà DedRoot.StatoRecord

Proprietà DedRootStatoRecord
Restituisce o imposta lo stato del record. DI USO INTERNO !!

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public StatoRecord StatoRecord { get; set; }
Public Property StatoRecord As StatoRecord
    Get
    Set
public:
virtual property StatoRecord^ StatoRecord {
    StatoRecord^ get () sealed;
    void set (StatoRecord^ value) sealed;
}
abstract StatoRecord : StatoRecord with get, set
override StatoRecord : StatoRecord with get, set

Valore della proprietà

StatoRecord

Implementa

IDedDbItemStatoRecord
Vedi anche

Documentazione

Classe DedRoot
Namespace DedNet.Core


Proprietà DedRoot.UnRootedPathDb

Proprietà DedRootUnRootedPathDb
Restituisce o imposta il percorso di database.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string UnRootedPathDb { get; set; }
Public Property UnRootedPathDb As String
    Get
    Set
public:
property String^ UnRootedPathDb {
    String^ get ();
    void set (String^ value);
}
member UnRootedPathDb : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedRoot
Namespace DedNet.Core


Metodi di DedRoot

Il tipo DedRoot espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Torna su
Vedi anche

Documentazione

Classe DedRoot
Namespace DedNet.Core


Metodo DedRoot.Equals

Metodo DedRootEquals

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj Object

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedRoot
Namespace DedNet.Core


Metodo DedRoot.GetHashCode

Metodo DedRootGetHashCode

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedRoot
Namespace DedNet.Core


Metodo DedRoot.ToString

Metodo DedRootToString

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedRoot
Namespace DedNet.Core


Enumerazione DedRoot.RootTypeEnum

Enumerazione DedRootRootTypeEnum
Enumerazione descrivente il tipo di root.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum RootTypeEnum
Public Enumeration RootTypeEnum
public enum class RootTypeEnum
type RootTypeEnum
Membri
Nome | Valore | Descrizione
Ricerca | 0 | Percorso di ricerca.
Libreria | 1 | Percorso di libreria
Progetto | 2 | File di progetto.
Commessa | 3 | Percorso commesse.
Eco | 4 | Percorso Eco.
Vedi anche

Documentazione

Namespace DedNet.Core


Classe DedRootInfo
Analizza le informazioni riguardanti un percorso o nome completo di file per quanto riguarda la root di appartenenza ed i corrispondenti path di Vault e Pws.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedRootInfo

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedRootInfo
Public Class DedRootInfo
public ref class DedRootInfo
type DedRootInfo = class end

Il tipo DedRootInfo espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CurrentUserPath | Restituisce il percorso, non rooted, di interesse all'utente, ovvero il percorso di accesso al file, in base al fatto che sia o meno attiva l'area locale. NOTA: Non verifica se esista un documento corrispondente al file e se qusto sia o meno in check-out dall'utente corrente, valuta solo in base al fatto se sia attiva o meno la pws!
Proprietà pubblica | IsInRoot | Restituisce se il percorso analizzato sia compreso all'interno di una root e quindi sia un percorso valido.
Proprietà pubblica | IsRooted | Restituisce se il percorso analizzato contenga il nome di una root.
Proprietà pubblica | IsVault | Restituisce se il percorso analizzato sia un percorso di Vault. Nel caso il percorso sia rooted restituisce sempre false perché non è possibile individuare se si riferisca al vault o meno perché contenente la root nel nome. Anche se non è stata trovata la root di appartenenza questa proprietà restituisce sempre false.
Proprietà pubblica | Path | Restituisce il percorso originale analizzato.
Proprietà pubblica | PwsPath | Restituisce il percorso corrispondente nella Pws senza root (non rooted).
Proprietà pubblica | Root | Restituisce la Root alla quale appartiene il percorso analizzato oppure null se non corrisponde ad alcuna root.
Proprietà pubblica | RootedPath | Restituisce il percorso corrispondente contenente la root (o il medesimo se quello da analizzare era rooted).
Proprietà pubblica | VaultPath | Restituisce il percorso corrispondente nel Vault senza root (non rooted).
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ToString | Restituisce una rappresentazione stringa dell'oggetto. (Sovrascrive ObjectToString)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di DedRootInfo

Il tipo DedRootInfo espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CurrentUserPath | Restituisce il percorso, non rooted, di interesse all'utente, ovvero il percorso di accesso al file, in base al fatto che sia o meno attiva l'area locale. NOTA: Non verifica se esista un documento corrispondente al file e se qusto sia o meno in check-out dall'utente corrente, valuta solo in base al fatto se sia attiva o meno la pws!
Proprietà pubblica | IsInRoot | Restituisce se il percorso analizzato sia compreso all'interno di una root e quindi sia un percorso valido.
Proprietà pubblica | IsRooted | Restituisce se il percorso analizzato contenga il nome di una root.
Proprietà pubblica | IsVault | Restituisce se il percorso analizzato sia un percorso di Vault. Nel caso il percorso sia rooted restituisce sempre false perché non è possibile individuare se si riferisca al vault o meno perché contenente la root nel nome. Anche se non è stata trovata la root di appartenenza questa proprietà restituisce sempre false.
Proprietà pubblica | Path | Restituisce il percorso originale analizzato.
Proprietà pubblica | PwsPath | Restituisce il percorso corrispondente nella Pws senza root (non rooted).
Proprietà pubblica | Root | Restituisce la Root alla quale appartiene il percorso analizzato oppure null se non corrisponde ad alcuna root.
Proprietà pubblica | RootedPath | Restituisce il percorso corrispondente contenente la root (o il medesimo se quello da analizzare era rooted).
Proprietà pubblica | VaultPath | Restituisce il percorso corrispondente nel Vault senza root (non rooted).
Torna su
Vedi anche

Documentazione

Classe DedRootInfo
Namespace DedNet.Core


Proprietà DedRootInfo.CurrentUserPath

Proprietà DedRootInfoCurrentUserPath
Restituisce il percorso, non rooted, di interesse all'utente, ovvero il percorso di accesso al file, in base al fatto che sia o meno attiva l'area locale. NOTA: Non verifica se esista un documento corrispondente al file e se qusto sia o meno in check-out dall'utente corrente, valuta solo in base al fatto se sia attiva o meno la pws!

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string CurrentUserPath { get; }
Public ReadOnly Property CurrentUserPath As String
    Get
public:
property String^ CurrentUserPath {
    String^ get ();
}
member CurrentUserPath : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedRootInfo
Namespace DedNet.Core


Proprietà DedRootInfo.IsInRoot

Proprietà DedRootInfoIsInRoot
Restituisce se il percorso analizzato sia compreso all'interno di una root e quindi sia un percorso valido.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsInRoot { get; }
Public ReadOnly Property IsInRoot As Boolean
    Get
public:
property bool IsInRoot {
    bool get ();
}
member IsInRoot : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedRootInfo
Namespace DedNet.Core


Proprietà DedRootInfo.IsRooted

Proprietà DedRootInfoIsRooted
Restituisce se il percorso analizzato contenga il nome di una root.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsRooted { get; }
Public ReadOnly Property IsRooted As Boolean
    Get
public:
property bool IsRooted {
    bool get ();
}
member IsRooted : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedRootInfo
Namespace DedNet.Core


Proprietà DedRootInfo.IsVault

Proprietà DedRootInfoIsVault
Restituisce se il percorso analizzato sia un percorso di Vault. Nel caso il percorso sia rooted restituisce sempre false perché non è possibile individuare se si riferisca al vault o meno perché contenente la root nel nome. Anche se non è stata trovata la root di appartenenza questa proprietà restituisce sempre false.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsVault { get; }
Public ReadOnly Property IsVault As Boolean
    Get
public:
property bool IsVault {
    bool get ();
}
member IsVault : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedRootInfo
Namespace DedNet.Core


Proprietà DedRootInfo.Path

Proprietà DedRootInfoPath
Restituisce il percorso originale analizzato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Path { get; }
Public ReadOnly Property Path As String
    Get
public:
property String^ Path {
    String^ get ();
}
member Path : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedRootInfo
Namespace DedNet.Core


Proprietà DedRootInfo.PwsPath

Proprietà DedRootInfoPwsPath
Restituisce il percorso corrispondente nella Pws senza root (non rooted).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string PwsPath { get; }
Public ReadOnly Property PwsPath As String
    Get
public:
property String^ PwsPath {
    String^ get ();
}
member PwsPath : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedRootInfo
Namespace DedNet.Core


Proprietà DedRootInfo.Root

Proprietà DedRootInfoRoot
Restituisce la Root alla quale appartiene il percorso analizzato oppure null se non corrisponde ad alcuna root.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedRoot Root { get; }
Public ReadOnly Property Root As DedRoot
    Get
public:
property DedRoot^ Root {
    DedRoot^ get ();
}
member Root : DedRoot with get

Valore della proprietà

DedRoot
Vedi anche

Documentazione

Classe DedRootInfo
Namespace DedNet.Core


Proprietà DedRootInfo.RootedPath

Proprietà DedRootInfoRootedPath
Restituisce il percorso corrispondente contenente la root (o il medesimo se quello da analizzare era rooted).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string RootedPath { get; }
Public ReadOnly Property RootedPath As String
    Get
public:
property String^ RootedPath {
    String^ get ();
}
member RootedPath : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedRootInfo
Namespace DedNet.Core


Proprietà DedRootInfo.VaultPath

Proprietà DedRootInfoVaultPath
Restituisce il percorso corrispondente nel Vault senza root (non rooted).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string VaultPath { get; }
Public ReadOnly Property VaultPath As String
    Get
public:
property String^ VaultPath {
    String^ get ();
}
member VaultPath : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedRootInfo
Namespace DedNet.Core


Metodi di DedRootInfo

Il tipo DedRootInfo espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ToString | Restituisce una rappresentazione stringa dell'oggetto. (Sovrascrive ObjectToString)
Torna su
Vedi anche

Documentazione

Classe DedRootInfo
Namespace DedNet.Core


Metodo DedRootInfo.ToString

Metodo DedRootInfoToString
Restituisce una rappresentazione stringa dell'oggetto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

String
Restituisce una stringa rappresentante l'oggetto.
Vedi anche

Documentazione

Classe DedRootInfo
Namespace DedNet.Core


Classe DedRoots
Gestione delle roots.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedDbCollectionBase DedRoot
DedNet.CoreDedRoots

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedRoots : DedDbCollectionBase<DedRoot>
Public Class DedRoots
    Inherits DedDbCollectionBase(Of DedRoot)
public ref class DedRoots : public DedDbCollectionBase<DedRoot^>
type DedRoots =
    class
        inherit DedDbCollectionBase<DedRoot>
    end

Il tipo DedRoots espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllowsDuplicates | Restituisce se siano ammessi duplicati all'interno della lista. Se false viene sollevata una eccezione su tentativo di inserimento duplicati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Application | Restituisce l'oggetto applicazione di appartenza. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Count | Restituisce il numero di elementi presenti. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Dirty | Restituisce se la collezione o uno dei suoi elementi sia stata modificata. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | ErasedItems | Restitusice la lista in sola lettura degli elementi che risultano attualmente cancellati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Item | Restituisce la root corrispondente avente un particolare nome. Restituisce null se non viene trovata (non solleva eccezioni).
Proprietà pubblica | LastItem | Restituisce l'ultimo elemento della collezione oppure null se non ci sono elementi. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | RestoreErased | Restituisce se gli elementi cancellati devono essere ripristinati in caso vengano riaggiunti. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | RootNames | Restituisce la lista dei nomi delle root presenti escluse quelle di progetto.
Proprietà pubblica | RootPaths | Restituisce la lista dei path o di vault o di pws, in base alla variabile PwsMode di tutte le root presenti escluse quelle di progetto.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Add(String, String, String, String, Int32) | Aggiunge un nuovo elemento alla collezione e lo restituisce.
Metodo pubblico | Add(String, String, String, String, Int32, Int32) | Aggiunge un nuovo elemento alla collezione e lo restituisce.
Metodo protetto | AddForClone | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto SENZA MODIFICARNE LO STATO. Le classi derivate potranno utilizzare questo metodo per clonare la collezione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddNewElement | DI USO INTERNO. Aggiunge un elemento alla lista rendendo dirty l'oggetto. L'elemento viene aggiunto con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere un elemento alla lista. Dovranno loro stesse avere un metodo pubblico Add() che prenda i parametri necessari alla costruzione dell'oggetto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddRangeNewElement | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi rendendo dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere più elementi alla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddUnModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Clear | Elimina tutti gli elementi dalla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ClearRefresh | Svuota la lista impostando Dirty = false. Di fatto permette di effettuare un refresh della lista e quindi di ricaricarla. Serve per svuotare la lista e reinizializzarla da capo. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Contains | Verifica l'esistenza di un valore all'interno della lista degli elementi. Le classi derivate devono effettuarne l'override nel caso in cui l'elemento non implementi GetHashCode() per l'uso all'interno dei dizionarii. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | CopyTo | Copia un range di elementi in un array. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | CreateDeleteCommand | Crea il comando di delete per un elemento. (Sovrascrive DedDbCollectionBaseTCreateDeleteCommand(T))
Metodo protetto | CreateInsertCommand | Crea il comando di insert per un elemento. (Sovrascrive DedDbCollectionBaseTCreateInsertCommand(T))
Metodo protetto | CreateUpdateCommand | Crea il comando di update per un elemento. (Sovrascrive DedDbCollectionBaseTCreateUpdateCommand(T))
Metodo pubblico | CustomSort | Ordina la lista in base al comparatore passato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteDeleteItem | Esegue l'eliminazione di un elemento. Crea il comando tramite il metodo CreateDeleteCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteInsertItem | Esegue l'inserimento di un elemento. Crea il comando tramite il metodo CreateInsertCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteUpdateItem | Esegue l'aggiornamento di un elemento. Crea il comando tramite il metodo CreateUpdateCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Find | Restituisce l'oggetto cercato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FindAll | Restitusice la lista degli elementi che corrispondono al predicato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | GetDbIndex | Restitusice l'indice di un elemento. (Sovrascrive DedDbCollectionBaseTGetDbIndex(T))
Metodo pubblico | GetEnumerator | Restituisce l'enumeratore della collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | GetInfo | Crea e restituisce un oggetto che racchiude tutte le informazioni inerenti il percorso passato ed i vari percorsi di root (vault e pws).
Metodo pubblico | GetPrjRoot | Dato un nome (può essere rooted) cerca la corrispondenza tra le root di progetto. Se la trova la ritorna, altrimenti null.
Metodo pubblico | GetRootsByType | Restituisce una lista di oggetti Root che corrispondono al tipo passato. Restituisce sempre una lista inizializzata.
Metodo pubblico | IndexOf | Restituisce l'indice dell'elemento richiesto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InsertUnModified | DI USO INTERNO. Inserisce un elemento alla lista senza rendere dirty l'oggetto, all'indice specificato. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Item | Restituisce l'elemento iesimo della lista. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean) | Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean, Int32) | Sposta l'elemento dell'indice passato prima o dopo del numero di posizioni passate. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSave | Metodo Template chiamato dopo il salvataggio avvenuto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSaveNoChanges | Metodo Template chiamato dopo il salvataggio senza modifiche. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnBeforeSave | Metodo Template chiamato prima del salvataggio. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(T) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(DedEditableObjectT) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(T) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(DedEditableObjectT) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ReInitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Remove | Elimina un elemento dalla collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Ripristina | Verifica che l'elemento sia presente negli eliminati e lo toglie da lì e lo riaggiunge in coda alla lista degli elementi validi. Solleva una eccezione se l'elemento è già presente nella lista e AllowsDuplicates = false. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Save | Salva l'oggetto con tutta la sua lista, solo se questo risulta dirty. (Ereditato da DedDbCollectionBaseT)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di DedRoots

Il tipo DedRoots espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllowsDuplicates | Restituisce se siano ammessi duplicati all'interno della lista. Se false viene sollevata una eccezione su tentativo di inserimento duplicati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Application | Restituisce l'oggetto applicazione di appartenza. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Count | Restituisce il numero di elementi presenti. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Dirty | Restituisce se la collezione o uno dei suoi elementi sia stata modificata. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | ErasedItems | Restitusice la lista in sola lettura degli elementi che risultano attualmente cancellati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Item | Restituisce la root corrispondente avente un particolare nome. Restituisce null se non viene trovata (non solleva eccezioni).
Proprietà pubblica | LastItem | Restituisce l'ultimo elemento della collezione oppure null se non ci sono elementi. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | RestoreErased | Restituisce se gli elementi cancellati devono essere ripristinati in caso vengano riaggiunti. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | RootNames | Restituisce la lista dei nomi delle root presenti escluse quelle di progetto.
Proprietà pubblica | RootPaths | Restituisce la lista dei path o di vault o di pws, in base alla variabile PwsMode di tutte le root presenti escluse quelle di progetto.
Torna su
Vedi anche

Documentazione

Classe DedRoots
Namespace DedNet.Core


Proprietà DedRoots.Item

Proprietà DedRootsItem
Restituisce la root corrispondente avente un particolare nome. Restituisce null se non viene trovata (non solleva eccezioni).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedRoot this[
    string rootName
] { get; }
Public ReadOnly Default Property Item (
    rootName As String
) As DedRoot
    Get
public:
property DedRoot^ default[String^ rootName] {
    DedRoot^ get (String^ rootName);
}
member Item : DedRoot with get

Parametri

rootName String
Nome della root da ottenere.

Valore di ritorno

DedRoot
Restituisce la root oppure null se non è presente.
Vedi anche

Documentazione

Classe DedRoots
Namespace DedNet.Core


Proprietà DedRoots.RootNames

Proprietà DedRootsRootNames
Restituisce la lista dei nomi delle root presenti escluse quelle di progetto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string[] RootNames { get; }
Public ReadOnly Property RootNames As String()
    Get
public:
property array<String^>^ RootNames {
    array<String^>^ get ();
}
member RootNames : string[] with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedRoots
Namespace DedNet.Core


Proprietà DedRoots.RootPaths

Proprietà DedRootsRootPaths
Restituisce la lista dei path o di vault o di pws, in base alla variabile PwsMode di tutte le root presenti escluse quelle di progetto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string[] RootPaths { get; }
Public ReadOnly Property RootPaths As String()
    Get
public:
property array<String^>^ RootPaths {
    array<String^>^ get ();
}
member RootPaths : string[] with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedRoots
Namespace DedNet.Core


Metodi di DedRoots

Il tipo DedRoots espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Add(String, String, String, String, Int32) | Aggiunge un nuovo elemento alla collezione e lo restituisce.
Metodo pubblico | Add(String, String, String, String, Int32, Int32) | Aggiunge un nuovo elemento alla collezione e lo restituisce.
Metodo protetto | AddForClone | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto SENZA MODIFICARNE LO STATO. Le classi derivate potranno utilizzare questo metodo per clonare la collezione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddNewElement | DI USO INTERNO. Aggiunge un elemento alla lista rendendo dirty l'oggetto. L'elemento viene aggiunto con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere un elemento alla lista. Dovranno loro stesse avere un metodo pubblico Add() che prenda i parametri necessari alla costruzione dell'oggetto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddRangeNewElement | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi rendendo dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere più elementi alla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddUnModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Clear | Elimina tutti gli elementi dalla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ClearRefresh | Svuota la lista impostando Dirty = false. Di fatto permette di effettuare un refresh della lista e quindi di ricaricarla. Serve per svuotare la lista e reinizializzarla da capo. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Contains | Verifica l'esistenza di un valore all'interno della lista degli elementi. Le classi derivate devono effettuarne l'override nel caso in cui l'elemento non implementi GetHashCode() per l'uso all'interno dei dizionarii. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | CopyTo | Copia un range di elementi in un array. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | CreateDeleteCommand | Crea il comando di delete per un elemento. (Sovrascrive DedDbCollectionBaseTCreateDeleteCommand(T))
Metodo protetto | CreateInsertCommand | Crea il comando di insert per un elemento. (Sovrascrive DedDbCollectionBaseTCreateInsertCommand(T))
Metodo protetto | CreateUpdateCommand | Crea il comando di update per un elemento. (Sovrascrive DedDbCollectionBaseTCreateUpdateCommand(T))
Metodo pubblico | CustomSort | Ordina la lista in base al comparatore passato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteDeleteItem | Esegue l'eliminazione di un elemento. Crea il comando tramite il metodo CreateDeleteCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteInsertItem | Esegue l'inserimento di un elemento. Crea il comando tramite il metodo CreateInsertCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteUpdateItem | Esegue l'aggiornamento di un elemento. Crea il comando tramite il metodo CreateUpdateCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Find | Restituisce l'oggetto cercato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FindAll | Restitusice la lista degli elementi che corrispondono al predicato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | GetDbIndex | Restitusice l'indice di un elemento. (Sovrascrive DedDbCollectionBaseTGetDbIndex(T))
Metodo pubblico | GetEnumerator | Restituisce l'enumeratore della collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | GetInfo | Crea e restituisce un oggetto che racchiude tutte le informazioni inerenti il percorso passato ed i vari percorsi di root (vault e pws).
Metodo pubblico | GetPrjRoot | Dato un nome (può essere rooted) cerca la corrispondenza tra le root di progetto. Se la trova la ritorna, altrimenti null.
Metodo pubblico | GetRootsByType | Restituisce una lista di oggetti Root che corrispondono al tipo passato. Restituisce sempre una lista inizializzata.
Metodo pubblico | IndexOf | Restituisce l'indice dell'elemento richiesto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InsertUnModified | DI USO INTERNO. Inserisce un elemento alla lista senza rendere dirty l'oggetto, all'indice specificato. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Item | Restituisce l'elemento iesimo della lista. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean) | Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean, Int32) | Sposta l'elemento dell'indice passato prima o dopo del numero di posizioni passate. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSave | Metodo Template chiamato dopo il salvataggio avvenuto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSaveNoChanges | Metodo Template chiamato dopo il salvataggio senza modifiche. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnBeforeSave | Metodo Template chiamato prima del salvataggio. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(T) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(DedEditableObjectT) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(T) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(DedEditableObjectT) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ReInitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Remove | Elimina un elemento dalla collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Ripristina | Verifica che l'elemento sia presente negli eliminati e lo toglie da lì e lo riaggiunge in coda alla lista degli elementi validi. Solleva una eccezione se l'elemento è già presente nella lista e AllowsDuplicates = false. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Save | Salva l'oggetto con tutta la sua lista, solo se questo risulta dirty. (Ereditato da DedDbCollectionBaseT)
Torna su
Vedi anche

Documentazione

Classe DedRoots
Namespace DedNet.Core


Metodo DedRoots.Add

Metodo DedRootsAdd
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Add(String, String, String, String, Int32) | Aggiunge un nuovo elemento alla collezione e lo restituisce.
Metodo pubblico | Add(String, String, String, String, Int32, Int32) | Aggiunge un nuovo elemento alla collezione e lo restituisce.
Torna su
Vedi anche

Documentazione

Classe DedRoots
Namespace DedNet.Core


Metodo DedRoots.Add(String, String, String, String, Int32)

Metodo DedRootsAdd(String, String, String, String, Int32)
Aggiunge un nuovo elemento alla collezione e lo restituisce.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedRoot Add(
    string nome,
    string desc,
    string vaultPath,
    string localPath,
    int rootType
)
Public Function Add (
    nome As String,
    desc As String,
    vaultPath As String,
    localPath As String,
    rootType As Integer
) As DedRoot
public:
DedRoot^ Add(
    String^ nome,
    String^ desc,
    String^ vaultPath,
    String^ localPath,
    int rootType
)
member Add :
        nome : string *
        desc : string *
        vaultPath : string *
        localPath : string *
        rootType : int -> DedRoot

Parametri

nome String
Nome della root.
desc String
Descrizione della root.
vaultPath String
Percorso Database.
localPath String
Percorso locale.
rootType Int32
Tipo di root.

Valore di ritorno

DedRoot
Vedi anche

Documentazione

Classe DedRoots
Overload di Add
Namespace DedNet.Core


Metodo DedRoots.Add(String, String, String, String, Int32, Int32)

Metodo DedRootsAdd(String, String, String, String, Int32, Int32)
Aggiunge un nuovo elemento alla collezione e lo restituisce.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedRoot Add(
    string nome,
    string desc,
    string vaultPath,
    string localPath,
    int rootType,
    int docOpType
)
Public Function Add (
    nome As String,
    desc As String,
    vaultPath As String,
    localPath As String,
    rootType As Integer,
    docOpType As Integer
) As DedRoot
public:
DedRoot^ Add(
    String^ nome,
    String^ desc,
    String^ vaultPath,
    String^ localPath,
    int rootType,
    int docOpType
)
member Add :
        nome : string *
        desc : string *
        vaultPath : string *
        localPath : string *
        rootType : int *
        docOpType : int -> DedRoot

Parametri

nome String
Nome della root.
desc String
Descrizione della root.
vaultPath String
Percorso Database.
localPath String
Percorso locale.
rootType Int32
Tipo di root.
docOpType Int32

Valore di ritorno

DedRoot
Vedi anche

Documentazione

Classe DedRoots
Overload di Add
Namespace DedNet.Core


Metodo DedRoots.CreateDeleteCommand

Metodo DedRootsCreateDeleteCommand
Crea il comando di delete per un elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSDeleteCommand CreateDeleteCommand(
    DedRoot item
)
Protected Overrides Function CreateDeleteCommand (
    item As DedRoot
) As QSDeleteCommand
protected:
virtual QSDeleteCommand^ CreateDeleteCommand(
    DedRoot^ item
) override
abstract CreateDeleteCommand :
        item : DedRoot -> QSDeleteCommand
override CreateDeleteCommand :
        item : DedRoot -> QSDeleteCommand

Parametri

item DedRoot
Elemento per il quale creare il comando.

Valore di ritorno

QSDeleteCommand
Vedi anche

Documentazione

Classe DedRoots
Namespace DedNet.Core


Metodo DedRoots.CreateInsertCommand

Metodo DedRootsCreateInsertCommand
Crea il comando di insert per un elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSInsertCommand CreateInsertCommand(
    DedRoot item
)
Protected Overrides Function CreateInsertCommand (
    item As DedRoot
) As QSInsertCommand
protected:
virtual QSInsertCommand^ CreateInsertCommand(
    DedRoot^ item
) override
abstract CreateInsertCommand :
        item : DedRoot -> QSInsertCommand
override CreateInsertCommand :
        item : DedRoot -> QSInsertCommand

Parametri

item DedRoot
Elemento per il quale creare il comando.

Valore di ritorno

QSInsertCommand
Vedi anche

Documentazione

Classe DedRoots
Namespace DedNet.Core


Metodo DedRoots.CreateUpdateCommand

Metodo DedRootsCreateUpdateCommand
Crea il comando di update per un elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSUpdateCommand CreateUpdateCommand(
    DedRoot item
)
Protected Overrides Function CreateUpdateCommand (
    item As DedRoot
) As QSUpdateCommand
protected:
virtual QSUpdateCommand^ CreateUpdateCommand(
    DedRoot^ item
) override
abstract CreateUpdateCommand :
        item : DedRoot -> QSUpdateCommand
override CreateUpdateCommand :
        item : DedRoot -> QSUpdateCommand

Parametri

item DedRoot
Elemento per il quale creare il comando.

Valore di ritorno

QSUpdateCommand
Vedi anche

Documentazione

Classe DedRoots
Namespace DedNet.Core


Metodo DedRoots.GetDbIndex

Metodo DedRootsGetDbIndex
Restitusice l'indice di un elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override Object GetDbIndex(
    DedRoot item
)
Protected Overrides Function GetDbIndex (
    item As DedRoot
) As Object
protected:
virtual Object^ GetDbIndex(
    DedRoot^ item
) override
abstract GetDbIndex :
        item : DedRoot -> Object
override GetDbIndex :
        item : DedRoot -> Object

Parametri

item DedRoot
Elemento per il quale restituire l'indice.

Valore di ritorno

Object
Vedi anche

Documentazione

Classe DedRoots
Namespace DedNet.Core


Metodo DedRoots.GetInfo

Metodo DedRootsGetInfo
Crea e restituisce un oggetto che racchiude tutte le informazioni inerenti il percorso passato ed i vari percorsi di root (vault e pws).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedRootInfo GetInfo(
    string path
)
Public Function GetInfo (
    path As String
) As DedRootInfo
public:
DedRootInfo^ GetInfo(
    String^ path
)
member GetInfo :
        path : string -> DedRootInfo

Parametri

path String
Percorso da analizzare.

Valore di ritorno

DedRootInfo
Restituisce un oggetto inizializzato con il path passato.
Vedi anche

Documentazione

Classe DedRoots
Namespace DedNet.Core


Metodo DedRoots.GetPrjRoot

Metodo DedRootsGetPrjRoot
Dato un nome (può essere rooted) cerca la corrispondenza tra le root di progetto. Se la trova la ritorna, altrimenti null.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedRoot GetPrjRoot(
    string rootedName
)
Public Function GetPrjRoot (
    rootedName As String
) As DedRoot
public:
DedRoot^ GetPrjRoot(
    String^ rootedName
)
member GetPrjRoot :
        rootedName : string -> DedRoot

Parametri

rootedName String
Nome da ricercare. Può essere wrappato tra %.

Valore di ritorno

DedRoot
Vedi anche

Documentazione

Classe DedRoots
Namespace DedNet.Core


Metodo DedRoots.GetRootsByType

Metodo DedRootsGetRootsByType
Restituisce una lista di oggetti Root che corrispondono al tipo passato. Restituisce sempre una lista inizializzata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<DedRoot> GetRootsByType(
    DedRootRootTypeEnum type
)
Public Function GetRootsByType (
    type As DedRootRootTypeEnum
) As List(Of DedRoot)
public:
List<DedRoot^>^ GetRootsByType(
    DedRootRootTypeEnum type
)
member GetRootsByType :
        type : DedRootRootTypeEnum -> List<DedRoot>

Parametri

type DedRootRootTypeEnum
Tipo di root da cercare.

Valore di ritorno

List DedRoot
Vedi anche

Documentazione

Classe DedRoots
Namespace DedNet.Core


Classe DedRule
Descrive una singola regola di autocomposizione, abbinata ad una particolare famiglia.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedRule

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedRule : IDedDbItem
Public Class DedRule
    Implements IDedDbItem
public ref class DedRule : IDedDbItem
type DedRule =
    class
        interface IDedDbItem
    end

Il tipo DedRule espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AttrName | Restituisce l'attributo destinatario della compilazione.
Proprietà pubblica | DbOnly | Restituisce se la regola deve essere applicata solo su componenti codificati nel database.
Proprietà pubblica | Ord | Restituisce l'indice di ordinamento di questo oggetto.
Proprietà pubblica | Parent | Restituisce la collezione di appartenenza dell'elemento.
Proprietà pubblica | RuleDesc | Restituisce il contenuto della regola di autocomposizione.
Proprietà pubblica | State | Restituisce lo stato della regola.
Proprietà pubblica | StatoRecord | Restituisce o imposta lo stato del record. DI USO INTERNO !!
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Clone | Metodo per clonare la regola.
Metodo pubblico | Equals | Ridefinisce l'uguaglianza tra due oggetti DedRule. Confronta il dbpath e l'attributo di destinazione. (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | ToString | Restituisce una rappresentazione stringa dell'oggetto. (Sovrascrive ObjectToString)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di DedRule

Il tipo DedRule espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AttrName | Restituisce l'attributo destinatario della compilazione.
Proprietà pubblica | DbOnly | Restituisce se la regola deve essere applicata solo su componenti codificati nel database.
Proprietà pubblica | Ord | Restituisce l'indice di ordinamento di questo oggetto.
Proprietà pubblica | Parent | Restituisce la collezione di appartenenza dell'elemento.
Proprietà pubblica | RuleDesc | Restituisce il contenuto della regola di autocomposizione.
Proprietà pubblica | State | Restituisce lo stato della regola.
Proprietà pubblica | StatoRecord | Restituisce o imposta lo stato del record. DI USO INTERNO !!
Torna su
Vedi anche

Documentazione

Classe DedRule
Namespace DedNet.Core


Proprietà DedRule.AttrName

Proprietà DedRuleAttrName
Restituisce l'attributo destinatario della compilazione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string AttrName { get; set; }
Public Property AttrName As String
    Get
    Set
public:
property String^ AttrName {
    String^ get ();
    void set (String^ value);
}
member AttrName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedRule
Namespace DedNet.Core


Proprietà DedRule.DbOnly

Proprietà DedRuleDbOnly
Restituisce se la regola deve essere applicata solo su componenti codificati nel database.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool DbOnly { get; set; }
Public Property DbOnly As Boolean
    Get
    Set
public:
property bool DbOnly {
    bool get ();
    void set (bool value);
}
member DbOnly : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedRule
Namespace DedNet.Core


Proprietà DedRule.Ord

Proprietà DedRuleOrd
Restituisce l'indice di ordinamento di questo oggetto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int Ord { get; set; }
Public Property Ord As Integer
    Get
    Set
public:
property int Ord {
    int get ();
    void set (int value);
}
member Ord : int with get, set

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe DedRule
Namespace DedNet.Core


Proprietà DedRule.Parent

Proprietà DedRuleParent
Restituisce la collezione di appartenenza dell'elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedRuleCollection Parent { get; }
Public ReadOnly Property Parent As DedRuleCollection
    Get
public:
property DedRuleCollection^ Parent {
    DedRuleCollection^ get ();
}
member Parent : DedRuleCollection with get

Valore della proprietà

DedRuleCollection
Vedi anche

Documentazione

Classe DedRule
Namespace DedNet.Core


Proprietà DedRule.RuleDesc

Proprietà DedRuleRuleDesc
Restituisce il contenuto della regola di autocomposizione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string RuleDesc { get; set; }
Public Property RuleDesc As String
    Get
    Set
public:
property String^ RuleDesc {
    String^ get ();
    void set (String^ value);
}
member RuleDesc : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedRule
Namespace DedNet.Core


Proprietà DedRule.State

Proprietà DedRuleState
Restituisce lo stato della regola.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public RuleStateEnum State { get; set; }
Public Property State As RuleStateEnum
    Get
    Set
public:
property RuleStateEnum State {
    RuleStateEnum get ();
    void set (RuleStateEnum value);
}
member State : RuleStateEnum with get, set

Valore della proprietà

RuleStateEnum
Vedi anche

Documentazione

Classe DedRule
Namespace DedNet.Core


Proprietà DedRule.StatoRecord

Proprietà DedRuleStatoRecord
Restituisce o imposta lo stato del record. DI USO INTERNO !!

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public StatoRecord StatoRecord { get; set; }
Public Property StatoRecord As StatoRecord
    Get
    Set
public:
virtual property StatoRecord^ StatoRecord {
    StatoRecord^ get () sealed;
    void set (StatoRecord^ value) sealed;
}
abstract StatoRecord : StatoRecord with get, set
override StatoRecord : StatoRecord with get, set

Valore della proprietà

StatoRecord

Implementa

IDedDbItemStatoRecord
Vedi anche

Documentazione

Classe DedRule
Namespace DedNet.Core


Metodi di DedRule

Il tipo DedRule espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Clone | Metodo per clonare la regola.
Metodo pubblico | Equals | Ridefinisce l'uguaglianza tra due oggetti DedRule. Confronta il dbpath e l'attributo di destinazione. (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | ToString | Restituisce una rappresentazione stringa dell'oggetto. (Sovrascrive ObjectToString)
Torna su
Vedi anche

Documentazione

Classe DedRule
Namespace DedNet.Core


Metodo DedRule.Clone

Metodo DedRuleClone
Metodo per clonare la regola.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedRule Clone(
    DedRuleCollection parent
)
Public Function Clone (
    parent As DedRuleCollection
) As DedRule
public:
DedRule^ Clone(
    DedRuleCollection^ parent
)
member Clone :
        parent : DedRuleCollection -> DedRule

Parametri

parent DedRuleCollection

Valore di ritorno

DedRule
Vedi anche

Documentazione

Classe DedRule
Namespace DedNet.Core


Metodo DedRule.Equals

Metodo DedRuleEquals
Ridefinisce l'uguaglianza tra due oggetti DedRule. Confronta il dbpath e l'attributo di destinazione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj Object
Oggetto da comparere con this.

Valore di ritorno

Boolean
Se risultano uguali.
Vedi anche

Documentazione

Classe DedRule
Namespace DedNet.Core


Metodo DedRule.GetHashCode

Metodo DedRuleGetHashCode

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedRule
Namespace DedNet.Core


Metodo DedRule.ToString

Metodo DedRuleToString
Restituisce una rappresentazione stringa dell'oggetto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedRule
Namespace DedNet.Core


Classe DedRuleApplier
Oggetto principale che data una famiglia di partenza, applica tutte le regole di autocomposizione di tale famiglia su di una parte.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedRuleApplier

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedRuleApplier
Public Class DedRuleApplier
public ref class DedRuleApplier
type DedRuleApplier = class end

Il tipo DedRuleApplier espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AlsoIfEmpty | Restituisce o imposta se si deve effettuare la scrittura del valore di regole che sono prive di valori sostitutivi ovvero se si consente di svuotare un attributo.
Proprietà pubblica | Application | Restituisce l'applicazione di appartenenza.
Proprietà pubblica | AsInDb | Restituisce o imposta se considerare, durante l'applicazione della regola, come se il codice fosse nel DB: si usa per fare in modo che le regole da attuare solo su codici presenti nel Db funzionino anche in fase di salvataggio quando il codice non è ancora effettivamente presente nel Database.
Proprietà pubblica | Fam | Restituisce la famiglia dalla quale leggere le regole di autocomposizione.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ApplyRules(IDedTypeEditable, DedEncodeInfo) | Applica le regole di autocomposizione della famiglia sulla parte passata.
Metodo pubblico | ApplyRules(IDedTypeEditable, DedEncodeInfo, Boolean) | Applica le regole di autocomposizione della famiglia sulla parte passata.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di DedRuleApplier

Il tipo DedRuleApplier espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AlsoIfEmpty | Restituisce o imposta se si deve effettuare la scrittura del valore di regole che sono prive di valori sostitutivi ovvero se si consente di svuotare un attributo.
Proprietà pubblica | Application | Restituisce l'applicazione di appartenenza.
Proprietà pubblica | AsInDb | Restituisce o imposta se considerare, durante l'applicazione della regola, come se il codice fosse nel DB: si usa per fare in modo che le regole da attuare solo su codici presenti nel Db funzionino anche in fase di salvataggio quando il codice non è ancora effettivamente presente nel Database.
Proprietà pubblica | Fam | Restituisce la famiglia dalla quale leggere le regole di autocomposizione.
Torna su
Vedi anche

Documentazione

Classe DedRuleApplier
Namespace DedNet.Core


Proprietà DedRuleApplier.AlsoIfEmpty

Proprietà DedRuleApplierAlsoIfEmpty
Restituisce o imposta se si deve effettuare la scrittura del valore di regole che sono prive di valori sostitutivi ovvero se si consente di svuotare un attributo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AlsoIfEmpty { get; set; }
Public Property AlsoIfEmpty As Boolean
    Get
    Set
public:
property bool AlsoIfEmpty {
    bool get ();
    void set (bool value);
}
member AlsoIfEmpty : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedRuleApplier
Namespace DedNet.Core


Proprietà DedRuleApplier.Application

Proprietà DedRuleApplierApplication
Restituisce l'applicazione di appartenenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedNetApplication Application { get; }
Public ReadOnly Property Application As DedNetApplication
    Get
public:
property DedNetApplication^ Application {
    DedNetApplication^ get ();
}
member Application : DedNetApplication with get

Valore della proprietà

DedNetApplication
Vedi anche

Documentazione

Classe DedRuleApplier
Namespace DedNet.Core


Proprietà DedRuleApplier.AsInDb

Proprietà DedRuleApplierAsInDb
Restituisce o imposta se considerare, durante l'applicazione della regola, come se il codice fosse nel DB: si usa per fare in modo che le regole da attuare solo su codici presenti nel Db funzionino anche in fase di salvataggio quando il codice non è ancora effettivamente presente nel Database.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AsInDb { get; set; }
Public Property AsInDb As Boolean
    Get
    Set
public:
property bool AsInDb {
    bool get ();
    void set (bool value);
}
member AsInDb : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedRuleApplier
Namespace DedNet.Core


Proprietà DedRuleApplier.Fam

Proprietà DedRuleApplierFam
Restituisce la famiglia dalla quale leggere le regole di autocomposizione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeBase Fam { get; }
Public ReadOnly Property Fam As DedTypeBase
    Get
public:
property DedTypeBase^ Fam {
    DedTypeBase^ get ();
}
member Fam : DedTypeBase with get

Valore della proprietà

DedTypeBase
Vedi anche

Documentazione

Classe DedRuleApplier
Namespace DedNet.Core


Metodi di DedRuleApplier

Il tipo DedRuleApplier espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ApplyRules(IDedTypeEditable, DedEncodeInfo) | Applica le regole di autocomposizione della famiglia sulla parte passata.
Metodo pubblico | ApplyRules(IDedTypeEditable, DedEncodeInfo, Boolean) | Applica le regole di autocomposizione della famiglia sulla parte passata.
Torna su
Vedi anche

Documentazione

Classe DedRuleApplier
Namespace DedNet.Core


Metodo DedRuleApplier.ApplyRules

Metodo DedRuleApplierApplyRules
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | ApplyRules(IDedTypeEditable, DedEncodeInfo) | Applica le regole di autocomposizione della famiglia sulla parte passata.
Metodo pubblico | ApplyRules(IDedTypeEditable, DedEncodeInfo, Boolean) | Applica le regole di autocomposizione della famiglia sulla parte passata.
Torna su
Vedi anche

Documentazione

Classe DedRuleApplier
Namespace DedNet.Core


Metodo DedRuleApplier.ApplyRules(IDedTypeEditable, DedEncodeInfo)

Metodo DedRuleApplierApplyRules(IDedTypeEditable, DedEncodeInfo)
Applica le regole di autocomposizione della famiglia sulla parte passata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ApplyRules(
    IDedTypeEditable prt,
    DedEncodeInfo info = null
)
Public Sub ApplyRules (
    prt As IDedTypeEditable,
    Optional info As DedEncodeInfo = Nothing
)
public:
void ApplyRules(
    IDedTypeEditable^ prt,
    DedEncodeInfo^ info = nullptr
)
member ApplyRules :
        prt : IDedTypeEditable *
        ?info : DedEncodeInfo
(* Defaults:
        let _info = defaultArg info null
*)
-> unit

Parametri

prt IDedTypeEditable
Oggetto sul quale applicare le regole.
info DedEncodeInfo (Optional)
Oggetto con le informazioni di codifica
Vedi anche

Documentazione

Classe DedRuleApplier
Overload di ApplyRules
Namespace DedNet.Core


Metodo DedRuleApplier.ApplyRules(IDedTypeEditable, DedEncodeInfo, Boolean)

Metodo DedRuleApplierApplyRules(IDedTypeEditable, DedEncodeInfo, Boolean)
Applica le regole di autocomposizione della famiglia sulla parte passata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ApplyRules(
    IDedTypeEditable prt,
    DedEncodeInfo info,
    bool checkState
)
Public Sub ApplyRules (
    prt As IDedTypeEditable,
    info As DedEncodeInfo,
    checkState As Boolean
)
public:
void ApplyRules(
    IDedTypeEditable^ prt,
    DedEncodeInfo^ info,
    bool checkState
)
member ApplyRules :
        prt : IDedTypeEditable *
        info : DedEncodeInfo *
        checkState : bool -> unit

Parametri

prt IDedTypeEditable
Oggetto sul quale applicare le regole.
info DedEncodeInfo
Oggetto con le informazioni di codifica
checkState Boolean
Indica se controllare lo stato anagrafico per eplcare le regole (in fase di creazioen viene
Vedi anche

Documentazione

Classe DedRuleApplier
Overload di ApplyRules
Namespace DedNet.Core


Classe DedRuleApplierItem
Oggetto che si occupa di applicare una singola regola compilando un attributo dell'anagrafica.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedRuleApplierItem

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedRuleApplierItem
Public Class DedRuleApplierItem
public ref class DedRuleApplierItem
type DedRuleApplierItem = class end

Il tipo DedRuleApplierItem espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AlsoIfEmpty | Restituisce se si deve effettuare la scrittura del valore di regole che sono prive di valori sostitutivi ovvero se si consente di svuotare un attributo.
Proprietà pubblica | Application | Restituisce l'applicazione di appartenenza.
Proprietà pubblica | AsInDb | Restituisce se considerare, durante l'applicazione della regola, come se il codice fosse nel DB: si usa per fare in modo che le regole da attuare solo su codici presenti nel Db funzionino anche in fase di salvataggio quando il codice non è ancora effettivamente presente nel Database.
Proprietà pubblica | Prt | Restituisce la parte sulla quale applicare la regola.
Proprietà pubblica | Rule | Restituisce la regola di autocomposizione che questo oggetto deve applicare.
Proprietà pubblica | Value | Restituisce o imposta il valore calcolato della regola che verrà impostato nell'attributo.
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | OnRowSetAttrPost | Chiama l'evento RowSetAttrPost.
Metodo protetto | OnSetAttrPost | Chiama l'evento SetAttrPost.
Metodo protetto | OnSetAttrPre | Chiama l'evento SetAttrPre.
Metodo protetto | OnSingleSetAttrPre | Chiama l'evento SingleSetAttrPre.
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | RowSetAttrPost | Evento chiamato subito dopo la sostituzione di tutta la stringa.
Evento pubblico | SetAttrPost | Evento chiamato subito dopo aver settato il valore della regola sull'attributo.
Evento pubblico | SetAttrPre | Evento chiamato prima di settare il valore della regola sull'attributo.
Evento pubblico | SingleSetAttrPre | Evento chiamato prima della sostituzione di un singolo token della stringa.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di DedRuleApplierItem

Il tipo DedRuleApplierItem espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AlsoIfEmpty | Restituisce se si deve effettuare la scrittura del valore di regole che sono prive di valori sostitutivi ovvero se si consente di svuotare un attributo.
Proprietà pubblica | Application | Restituisce l'applicazione di appartenenza.
Proprietà pubblica | AsInDb | Restituisce se considerare, durante l'applicazione della regola, come se il codice fosse nel DB: si usa per fare in modo che le regole da attuare solo su codici presenti nel Db funzionino anche in fase di salvataggio quando il codice non è ancora effettivamente presente nel Database.
Proprietà pubblica | Prt | Restituisce la parte sulla quale applicare la regola.
Proprietà pubblica | Rule | Restituisce la regola di autocomposizione che questo oggetto deve applicare.
Proprietà pubblica | Value | Restituisce o imposta il valore calcolato della regola che verrà impostato nell'attributo.
Torna su
Vedi anche

Documentazione

Classe DedRuleApplierItem
Namespace DedNet.Core


Proprietà DedRuleApplierItem.AlsoIfEmpty

Proprietà DedRuleApplierItemAlsoIfEmpty
Restituisce se si deve effettuare la scrittura del valore di regole che sono prive di valori sostitutivi ovvero se si consente di svuotare un attributo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AlsoIfEmpty { get; }
Public ReadOnly Property AlsoIfEmpty As Boolean
    Get
public:
property bool AlsoIfEmpty {
    bool get ();
}
member AlsoIfEmpty : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedRuleApplierItem
Namespace DedNet.Core


Proprietà DedRuleApplierItem.Application

Proprietà DedRuleApplierItemApplication
Restituisce l'applicazione di appartenenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedNetApplication Application { get; }
Public ReadOnly Property Application As DedNetApplication
    Get
public:
property DedNetApplication^ Application {
    DedNetApplication^ get ();
}
member Application : DedNetApplication with get

Valore della proprietà

DedNetApplication
Vedi anche

Documentazione

Classe DedRuleApplierItem
Namespace DedNet.Core


Proprietà DedRuleApplierItem.AsInDb

Proprietà DedRuleApplierItemAsInDb
Restituisce se considerare, durante l'applicazione della regola, come se il codice fosse nel DB: si usa per fare in modo che le regole da attuare solo su codici presenti nel Db funzionino anche in fase di salvataggio quando il codice non è ancora effettivamente presente nel Database.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AsInDb { get; }
Public ReadOnly Property AsInDb As Boolean
    Get
public:
property bool AsInDb {
    bool get ();
}
member AsInDb : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedRuleApplierItem
Namespace DedNet.Core


Proprietà DedRuleApplierItem.Prt

Proprietà DedRuleApplierItemPrt
Restituisce la parte sulla quale applicare la regola.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public IDedTypeEditable Prt { get; }
Public ReadOnly Property Prt As IDedTypeEditable
    Get
public:
property IDedTypeEditable^ Prt {
    IDedTypeEditable^ get ();
}
member Prt : IDedTypeEditable with get

Valore della proprietà

IDedTypeEditable
Vedi anche

Documentazione

Classe DedRuleApplierItem
Namespace DedNet.Core


Proprietà DedRuleApplierItem.Rule

Proprietà DedRuleApplierItemRule
Restituisce la regola di autocomposizione che questo oggetto deve applicare.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedRule Rule { get; }
Public ReadOnly Property Rule As DedRule
    Get
public:
property DedRule^ Rule {
    DedRule^ get ();
}
member Rule : DedRule with get

Valore della proprietà

DedRule
Vedi anche

Documentazione

Classe DedRuleApplierItem
Namespace DedNet.Core


Proprietà DedRuleApplierItem.Value

Proprietà DedRuleApplierItemValue
Restituisce o imposta il valore calcolato della regola che verrà impostato nell'attributo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}
member Value : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedRuleApplierItem
Namespace DedNet.Core


Metodi di DedRuleApplierItem

Il tipo DedRuleApplierItem espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | OnRowSetAttrPost | Chiama l'evento RowSetAttrPost.
Metodo protetto | OnSetAttrPost | Chiama l'evento SetAttrPost.
Metodo protetto | OnSetAttrPre | Chiama l'evento SetAttrPre.
Metodo protetto | OnSingleSetAttrPre | Chiama l'evento SingleSetAttrPre.
Torna su
Vedi anche

Documentazione

Classe DedRuleApplierItem
Namespace DedNet.Core


Metodo DedRuleApplierItem.OnRowSetAttrPost

Metodo DedRuleApplierItemOnRowSetAttrPost
Chiama l'evento RowSetAttrPost.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected void OnRowSetAttrPost(
    DedRuleParserEventArg e
)
Protected Sub OnRowSetAttrPost (
    e As DedRuleParserEventArg
)
protected:
void OnRowSetAttrPost(
    DedRuleParserEventArg^ e
)
member OnRowSetAttrPost :
        e : DedRuleParserEventArg -> unit

Parametri

e DedRuleParserEventArg
Oggetto DedRuleParserEventArg.
Vedi anche

Documentazione

Classe DedRuleApplierItem
Namespace DedNet.Core


Metodo DedRuleApplierItem.OnSetAttrPost

Metodo DedRuleApplierItemOnSetAttrPost
Chiama l'evento SetAttrPost.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected void OnSetAttrPost()
Protected Sub OnSetAttrPost
protected:
void OnSetAttrPost()
member OnSetAttrPost : unit -> unit
Vedi anche

Documentazione

Classe DedRuleApplierItem
Namespace DedNet.Core


Metodo DedRuleApplierItem.OnSetAttrPre

Metodo DedRuleApplierItemOnSetAttrPre
Chiama l'evento SetAttrPre.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected void OnSetAttrPre()
Protected Sub OnSetAttrPre
protected:
void OnSetAttrPre()
member OnSetAttrPre : unit -> unit
Vedi anche

Documentazione

Classe DedRuleApplierItem
Namespace DedNet.Core


Metodo DedRuleApplierItem.OnSingleSetAttrPre

Metodo DedRuleApplierItemOnSingleSetAttrPre
Chiama l'evento SingleSetAttrPre.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected void OnSingleSetAttrPre(
    DedRuleParserEventArg e
)
Protected Sub OnSingleSetAttrPre (
    e As DedRuleParserEventArg
)
protected:
void OnSingleSetAttrPre(
    DedRuleParserEventArg^ e
)
member OnSingleSetAttrPre :
        e : DedRuleParserEventArg -> unit

Parametri

e DedRuleParserEventArg
Oggetto DedRuleParserEventArg.
Vedi anche

Documentazione

Classe DedRuleApplierItem
Namespace DedNet.Core


Eventi di DedRuleApplierItem

Il tipo DedRuleApplierItem espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | RowSetAttrPost | Evento chiamato subito dopo la sostituzione di tutta la stringa.
Evento pubblico | SetAttrPost | Evento chiamato subito dopo aver settato il valore della regola sull'attributo.
Evento pubblico | SetAttrPre | Evento chiamato prima di settare il valore della regola sull'attributo.
Evento pubblico | SingleSetAttrPre | Evento chiamato prima della sostituzione di un singolo token della stringa.
Torna su
Vedi anche

Documentazione

Classe DedRuleApplierItem
Namespace DedNet.Core


Evento DedRuleApplierItem.RowSetAttrPost

Evento DedRuleApplierItemRowSetAttrPost
Evento chiamato subito dopo la sostituzione di tutta la stringa.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DedRuleParserEventArg> RowSetAttrPost
Public Event RowSetAttrPost As EventHandler(Of DedRuleParserEventArg)
public:
 event EventHandler<DedRuleParserEventArg^>^ RowSetAttrPost {
    void add (EventHandler<DedRuleParserEventArg^>^ value);
    void remove (EventHandler<DedRuleParserEventArg^>^ value);
}
member RowSetAttrPost : IEvent<EventHandler<DedRuleParserEventArg>,
    DedRuleParserEventArg>

Valore

EventHandler DedRuleParserEventArg
Vedi anche

Documentazione

Classe DedRuleApplierItem
Namespace DedNet.Core


Evento DedRuleApplierItem.SetAttrPost

Evento DedRuleApplierItemSetAttrPost
Evento chiamato subito dopo aver settato il valore della regola sull'attributo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler SetAttrPost
Public Event SetAttrPost As EventHandler
public:
 event EventHandler^ SetAttrPost {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member SetAttrPost : IEvent<EventHandler,
    EventArgs>

Valore

EventHandler
Vedi anche

Documentazione

Classe DedRuleApplierItem
Namespace DedNet.Core


Evento DedRuleApplierItem.SetAttrPre

Evento DedRuleApplierItemSetAttrPre
Evento chiamato prima di settare il valore della regola sull'attributo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler SetAttrPre
Public Event SetAttrPre As EventHandler
public:
 event EventHandler^ SetAttrPre {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member SetAttrPre : IEvent<EventHandler,
    EventArgs>

Valore

EventHandler
Vedi anche

Documentazione

Classe DedRuleApplierItem
Namespace DedNet.Core


Evento DedRuleApplierItem.SingleSetAttrPre

Evento DedRuleApplierItemSingleSetAttrPre
Evento chiamato prima della sostituzione di un singolo token della stringa.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DedRuleParserEventArg> SingleSetAttrPre
Public Event SingleSetAttrPre As EventHandler(Of DedRuleParserEventArg)
public:
 event EventHandler<DedRuleParserEventArg^>^ SingleSetAttrPre {
    void add (EventHandler<DedRuleParserEventArg^>^ value);
    void remove (EventHandler<DedRuleParserEventArg^>^ value);
}
member SingleSetAttrPre : IEvent<EventHandler<DedRuleParserEventArg>,
    DedRuleParserEventArg>

Valore

EventHandler DedRuleParserEventArg
Vedi anche

Documentazione

Classe DedRuleApplierItem
Namespace DedNet.Core


Classe DedRuleCollection
Collezione modificabile di oggetti DedRule.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedDbCollectionBase DedRule
DedNet.CoreDedRuleCollection

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedRuleCollection : DedDbCollectionBase<DedRule>
Public Class DedRuleCollection
    Inherits DedDbCollectionBase(Of DedRule)
public ref class DedRuleCollection : public DedDbCollectionBase<DedRule^>
type DedRuleCollection =
    class
        inherit DedDbCollectionBase<DedRule>
    end

Il tipo DedRuleCollection espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllowsDuplicates | Restituisce se siano ammessi duplicati all'interno della lista. Se false viene sollevata una eccezione su tentativo di inserimento duplicati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Application | Restituisce l'oggetto applicazione di appartenza. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Count | Restituisce il numero di elementi presenti. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Dirty | Restituisce se la collezione o uno dei suoi elementi sia stata modificata. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | ErasedItems | Restitusice la lista in sola lettura degli elementi che risultano attualmente cancellati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | LastItem | Restituisce l'ultimo elemento della collezione oppure null se non ci sono elementi. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Owner | Restituisce la famiglia di appartenenza.
Proprietà pubblica | RestoreErased | Restituisce se gli elementi cancellati devono essere ripristinati in caso vengano riaggiunti. (Ereditato da DedDbCollectionBaseT)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Add(DedRule) | Aggiunge alla collezione un elemento già esistente. Gli imposta già come padre la nuova collezione.
Metodo pubblico | Add(String, String, Boolean, RuleStateEnum) | Aggiunge un nuovo elemento alla collezione e lo restituisce.
Metodo protetto | AddForClone | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto SENZA MODIFICARNE LO STATO. Le classi derivate potranno utilizzare questo metodo per clonare la collezione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddNewElement | DI USO INTERNO. Aggiunge un elemento alla lista rendendo dirty l'oggetto. L'elemento viene aggiunto con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere un elemento alla lista. Dovranno loro stesse avere un metodo pubblico Add() che prenda i parametri necessari alla costruzione dell'oggetto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddRangeNewElement | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi rendendo dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere più elementi alla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddUnModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Clear | Elimina tutti gli elementi dalla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ClearRefresh | Svuota la lista impostando Dirty = false. Di fatto permette di effettuare un refresh della lista e quindi di ricaricarla. Serve per svuotare la lista e reinizializzarla da capo. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Clone | Metodo per clonare la collezione di regole.
Metodo pubblico | Contains | Verifica l'esistenza di un valore all'interno della lista degli elementi. Le classi derivate devono effettuarne l'override nel caso in cui l'elemento non implementi GetHashCode() per l'uso all'interno dei dizionarii. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | CopyTo | Copia un range di elementi in un array. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | CreateDeleteCommand | (Sovrascrive DedDbCollectionBaseTCreateDeleteCommand(T))
Metodo protetto | CreateInsertCommand | (Sovrascrive DedDbCollectionBaseTCreateInsertCommand(T))
Metodo protetto | CreateUpdateCommand | (Sovrascrive DedDbCollectionBaseTCreateUpdateCommand(T))
Metodo pubblico | CustomSort | Ordina la lista in base al comparatore passato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteDeleteItem | Esegue l'eliminazione di un elemento. Crea il comando tramite il metodo CreateDeleteCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteInsertItem | Esegue l'inserimento di un elemento. Crea il comando tramite il metodo CreateInsertCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteUpdateItem | Esegue l'aggiornamento di un elemento. Crea il comando tramite il metodo CreateUpdateCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Find | Restituisce l'oggetto cercato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FindAll | Restitusice la lista degli elementi che corrispondono al predicato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | GetDbIndex | (Sovrascrive DedDbCollectionBaseTGetDbIndex(T))
Metodo pubblico | GetEnumerator | Restituisce l'enumeratore della collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | IndexOf | Restituisce l'indice dell'elemento richiesto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InsertUnModified | DI USO INTERNO. Inserisce un elemento alla lista senza rendere dirty l'oggetto, all'indice specificato. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Item | Restituisce l'elemento iesimo della lista. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean) | Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi. (Sovrascrive DedDbCollectionBaseTMove(Int32, Boolean))
Metodo pubblico | Move(Int32, Boolean, Int32) | Sposta l'elemento dell'indice passato prima o dopo del numero di posizioni passate. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSave | Metodo Template chiamato dopo il salvataggio avvenuto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSaveNoChanges | Metodo Template chiamato dopo il salvataggio senza modifiche. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnBeforeSave | Metodo Template chiamato prima del salvataggio. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(T) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(DedEditableObjectT) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(T) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(DedEditableObjectT) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ReInitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Remove | Elimina un elemento dalla collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Ripristina | Verifica che l'elemento sia presente negli eliminati e lo toglie da lì e lo riaggiunge in coda alla lista degli elementi validi. Solleva una eccezione se l'elemento è già presente nella lista e AllowsDuplicates = false. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Save | Salva l'oggetto con tutta la sua lista, solo se questo risulta dirty. (Ereditato da DedDbCollectionBaseT)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di DedRuleCollection

Il tipo DedRuleCollection espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllowsDuplicates | Restituisce se siano ammessi duplicati all'interno della lista. Se false viene sollevata una eccezione su tentativo di inserimento duplicati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Application | Restituisce l'oggetto applicazione di appartenza. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Count | Restituisce il numero di elementi presenti. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Dirty | Restituisce se la collezione o uno dei suoi elementi sia stata modificata. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | ErasedItems | Restitusice la lista in sola lettura degli elementi che risultano attualmente cancellati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | LastItem | Restituisce l'ultimo elemento della collezione oppure null se non ci sono elementi. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Owner | Restituisce la famiglia di appartenenza.
Proprietà pubblica | RestoreErased | Restituisce se gli elementi cancellati devono essere ripristinati in caso vengano riaggiunti. (Ereditato da DedDbCollectionBaseT)
Torna su
Vedi anche

Documentazione

Classe DedRuleCollection
Namespace DedNet.Core


Proprietà DedRuleCollection.Owner

Proprietà DedRuleCollectionOwner
Restituisce la famiglia di appartenenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeBase Owner { get; }
Public ReadOnly Property Owner As DedTypeBase
    Get
public:
property DedTypeBase^ Owner {
    DedTypeBase^ get ();
}
member Owner : DedTypeBase with get

Valore della proprietà

DedTypeBase
Vedi anche

Documentazione

Classe DedRuleCollection
Namespace DedNet.Core


Metodi di DedRuleCollection

Il tipo DedRuleCollection espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Add(DedRule) | Aggiunge alla collezione un elemento già esistente. Gli imposta già come padre la nuova collezione.
Metodo pubblico | Add(String, String, Boolean, RuleStateEnum) | Aggiunge un nuovo elemento alla collezione e lo restituisce.
Metodo protetto | AddForClone | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto SENZA MODIFICARNE LO STATO. Le classi derivate potranno utilizzare questo metodo per clonare la collezione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddNewElement | DI USO INTERNO. Aggiunge un elemento alla lista rendendo dirty l'oggetto. L'elemento viene aggiunto con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere un elemento alla lista. Dovranno loro stesse avere un metodo pubblico Add() che prenda i parametri necessari alla costruzione dell'oggetto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddRangeNewElement | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi rendendo dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere più elementi alla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddUnModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Clear | Elimina tutti gli elementi dalla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ClearRefresh | Svuota la lista impostando Dirty = false. Di fatto permette di effettuare un refresh della lista e quindi di ricaricarla. Serve per svuotare la lista e reinizializzarla da capo. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Clone | Metodo per clonare la collezione di regole.
Metodo pubblico | Contains | Verifica l'esistenza di un valore all'interno della lista degli elementi. Le classi derivate devono effettuarne l'override nel caso in cui l'elemento non implementi GetHashCode() per l'uso all'interno dei dizionarii. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | CopyTo | Copia un range di elementi in un array. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | CreateDeleteCommand | (Sovrascrive DedDbCollectionBaseTCreateDeleteCommand(T))
Metodo protetto | CreateInsertCommand | (Sovrascrive DedDbCollectionBaseTCreateInsertCommand(T))
Metodo protetto | CreateUpdateCommand | (Sovrascrive DedDbCollectionBaseTCreateUpdateCommand(T))
Metodo pubblico | CustomSort | Ordina la lista in base al comparatore passato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteDeleteItem | Esegue l'eliminazione di un elemento. Crea il comando tramite il metodo CreateDeleteCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteInsertItem | Esegue l'inserimento di un elemento. Crea il comando tramite il metodo CreateInsertCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteUpdateItem | Esegue l'aggiornamento di un elemento. Crea il comando tramite il metodo CreateUpdateCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Find | Restituisce l'oggetto cercato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FindAll | Restitusice la lista degli elementi che corrispondono al predicato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | GetDbIndex | (Sovrascrive DedDbCollectionBaseTGetDbIndex(T))
Metodo pubblico | GetEnumerator | Restituisce l'enumeratore della collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | IndexOf | Restituisce l'indice dell'elemento richiesto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InsertUnModified | DI USO INTERNO. Inserisce un elemento alla lista senza rendere dirty l'oggetto, all'indice specificato. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Item | Restituisce l'elemento iesimo della lista. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean) | Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi. (Sovrascrive DedDbCollectionBaseTMove(Int32, Boolean))
Metodo pubblico | Move(Int32, Boolean, Int32) | Sposta l'elemento dell'indice passato prima o dopo del numero di posizioni passate. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSave | Metodo Template chiamato dopo il salvataggio avvenuto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSaveNoChanges | Metodo Template chiamato dopo il salvataggio senza modifiche. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnBeforeSave | Metodo Template chiamato prima del salvataggio. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(T) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(DedEditableObjectT) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(T) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(DedEditableObjectT) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ReInitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Remove | Elimina un elemento dalla collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Ripristina | Verifica che l'elemento sia presente negli eliminati e lo toglie da lì e lo riaggiunge in coda alla lista degli elementi validi. Solleva una eccezione se l'elemento è già presente nella lista e AllowsDuplicates = false. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Save | Salva l'oggetto con tutta la sua lista, solo se questo risulta dirty. (Ereditato da DedDbCollectionBaseT)
Torna su
Vedi anche

Documentazione

Classe DedRuleCollection
Namespace DedNet.Core


Metodo DedRuleCollection.Add

Metodo DedRuleCollectionAdd
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Add(DedRule) | Aggiunge alla collezione un elemento già esistente. Gli imposta già come padre la nuova collezione.
Metodo pubblico | Add(String, String, Boolean, RuleStateEnum) | Aggiunge un nuovo elemento alla collezione e lo restituisce.
Torna su
Vedi anche

Documentazione

Classe DedRuleCollection
Namespace DedNet.Core


Metodo DedRuleCollection.Add(DedRule)

Metodo DedRuleCollectionAdd(DedRule)
Aggiunge alla collezione un elemento già esistente. Gli imposta già come padre la nuova collezione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Add(
    DedRule rule
)
Public Sub Add (
    rule As DedRule
)
public:
void Add(
    DedRule^ rule
)
member Add :
        rule : DedRule -> unit

Parametri

rule DedRule
Regola da aggiungere alla collezione.
Vedi anche

Documentazione

Classe DedRuleCollection
Overload di Add
Namespace DedNet.Core


Metodo DedRuleCollection.Add(String, String, Boolean, RuleStateEnum)

Metodo DedRuleCollectionAdd(String, String, Boolean, RuleStateEnum)
Aggiunge un nuovo elemento alla collezione e lo restituisce.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedRule Add(
    string AttrName,
    string RuleDesc,
    bool DbOnly,
    RuleStateEnum State
)
Public Function Add (
    AttrName As String,
    RuleDesc As String,
    DbOnly As Boolean,
    State As RuleStateEnum
) As DedRule
public:
DedRule^ Add(
    String^ AttrName,
    String^ RuleDesc,
    bool DbOnly,
    RuleStateEnum State
)
member Add :
        AttrName : string *
        RuleDesc : string *
        DbOnly : bool *
        State : RuleStateEnum -> DedRule

Parametri

AttrName String
Nome dell'attributo destinatario della compilazione.
RuleDesc String
Regola di composizione.
DbOnly Boolean
Se applicare solo su componenti codificati.
State RuleStateEnum

Valore di ritorno

DedRule
Restituisce la regola aggiunta.
Vedi anche

Documentazione

Classe DedRuleCollection
Overload di Add
Namespace DedNet.Core


Metodo DedRuleCollection.Clone

Metodo DedRuleCollectionClone
Metodo per clonare la collezione di regole.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedRuleCollection Clone(
    DedTypeBase owner
)
Public Function Clone (
    owner As DedTypeBase
) As DedRuleCollection
public:
DedRuleCollection^ Clone(
    DedTypeBase^ owner
)
member Clone :
        owner : DedTypeBase -> DedRuleCollection

Parametri

owner DedTypeBase

Valore di ritorno

DedRuleCollection
Vedi anche

Documentazione

Classe DedRuleCollection
Namespace DedNet.Core


Metodo DedRuleCollection.CreateDeleteCommand

Metodo DedRuleCollectionCreateDeleteCommand

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSDeleteCommand CreateDeleteCommand(
    DedRule item
)
Protected Overrides Function CreateDeleteCommand (
    item As DedRule
) As QSDeleteCommand
protected:
virtual QSDeleteCommand^ CreateDeleteCommand(
    DedRule^ item
) override
abstract CreateDeleteCommand :
        item : DedRule -> QSDeleteCommand
override CreateDeleteCommand :
        item : DedRule -> QSDeleteCommand

Parametri

item DedRule

Valore di ritorno

QSDeleteCommand
Vedi anche

Documentazione

Classe DedRuleCollection
Namespace DedNet.Core


Metodo DedRuleCollection.CreateInsertCommand

Metodo DedRuleCollectionCreateInsertCommand

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSInsertCommand CreateInsertCommand(
    DedRule item
)
Protected Overrides Function CreateInsertCommand (
    item As DedRule
) As QSInsertCommand
protected:
virtual QSInsertCommand^ CreateInsertCommand(
    DedRule^ item
) override
abstract CreateInsertCommand :
        item : DedRule -> QSInsertCommand
override CreateInsertCommand :
        item : DedRule -> QSInsertCommand

Parametri

item DedRule

Valore di ritorno

QSInsertCommand
Vedi anche

Documentazione

Classe DedRuleCollection
Namespace DedNet.Core


Metodo DedRuleCollection.CreateUpdateCommand

Metodo DedRuleCollectionCreateUpdateCommand

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSUpdateCommand CreateUpdateCommand(
    DedRule item
)
Protected Overrides Function CreateUpdateCommand (
    item As DedRule
) As QSUpdateCommand
protected:
virtual QSUpdateCommand^ CreateUpdateCommand(
    DedRule^ item
) override
abstract CreateUpdateCommand :
        item : DedRule -> QSUpdateCommand
override CreateUpdateCommand :
        item : DedRule -> QSUpdateCommand

Parametri

item DedRule

Valore di ritorno

QSUpdateCommand
Vedi anche

Documentazione

Classe DedRuleCollection
Namespace DedNet.Core


Metodo DedRuleCollection.GetDbIndex

Metodo DedRuleCollectionGetDbIndex

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override Object GetDbIndex(
    DedRule item
)
Protected Overrides Function GetDbIndex (
    item As DedRule
) As Object
protected:
virtual Object^ GetDbIndex(
    DedRule^ item
) override
abstract GetDbIndex :
        item : DedRule -> Object
override GetDbIndex :
        item : DedRule -> Object

Parametri

item DedRule

Valore di ritorno

Object
Vedi anche

Documentazione

Classe DedRuleCollection
Namespace DedNet.Core


Metodo DedRuleCollection.Move

Metodo DedRuleCollectionMove
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Move(Int32, Boolean) | Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi.
Metodo pubblico | Move(Int32, Boolean, Int32) | Sposta l'elemento dell'indice passato prima o dopo del numero di posizioni passate. Ignora eventuali valori di indice non validi.
Torna su
Vedi anche

Documentazione

Classe DedRuleCollection
Namespace DedNet.Core


Metodo DedRuleCollection.Move(Int32, Boolean)

Metodo DedRuleCollectionMove(Int32, Boolean)
Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void Move(
    int index,
    bool up
)
Public Overrides Sub Move (
    index As Integer,
    up As Boolean
)
public:
virtual void Move(
    int index,
    bool up
) override
abstract Move :
        index : int *
        up : bool -> unit
override Move :
        index : int *
        up : bool -> unit

Parametri

index Int32
Indice dell'elemento da spostare.
up Boolean
Se true l'elemento viene spostato in alto (nell'indice precedente) altrimenti all'indice successivo.
Vedi anche

Documentazione

Classe DedRuleCollection
Overload di Move
Namespace DedNet.Core


Classe DedRuleList
Lista di oggetti FamilyRule.
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList DedRule
DedNet.CoreDedRuleList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedRuleList : List<DedRule>
Public Class DedRuleList
    Inherits List(Of DedRule)
public ref class DedRuleList : public List<DedRule^>
type DedRuleList =
    class
        inherit List<DedRule>
    end

Il tipo DedRuleList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedRuleList |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | FindRuleByAttrPrompt | Restituisce la regola se esiste per l'attributo cercato altrimenti ritorna null.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedRuleList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedRuleList()
Public Sub New
public:
DedRuleList()
new : unit -> DedRuleList
Vedi anche

Documentazione

Classe DedRuleList
Namespace DedNet.Core


Metodi di DedRuleList

Il tipo DedRuleList espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | FindRuleByAttrPrompt | Restituisce la regola se esiste per l'attributo cercato altrimenti ritorna null.
Torna su
Vedi anche

Documentazione

Classe DedRuleList
Namespace DedNet.Core


Metodo DedRuleList.FindRuleByAttrPrompt

Metodo DedRuleListFindRuleByAttrPrompt
Restituisce la regola se esiste per l'attributo cercato altrimenti ritorna null.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedRule FindRuleByAttrPrompt(
    string attrPrompt
)
Public Function FindRuleByAttrPrompt (
    attrPrompt As String
) As DedRule
public:
DedRule^ FindRuleByAttrPrompt(
    String^ attrPrompt
)
member FindRuleByAttrPrompt :
        attrPrompt : string -> DedRule

Parametri

attrPrompt String
Attributo del quale controllare l'estitenza della regola

Valore di ritorno

DedRule
Vedi anche

Documentazione

Classe DedRuleList
Namespace DedNet.Core


Classe DedRuleLuaEventArg
Contiene le informazioni per la sostituizione di un singolo token.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNet.CoreDedRuleLuaEventArg

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedRuleLuaEventArg : EventArgs
Public Class DedRuleLuaEventArg
    Inherits EventArgs
public ref class DedRuleLuaEventArg : public EventArgs
type DedRuleLuaEventArg =
    class
        inherit EventArgs
    end

Il tipo DedRuleLuaEventArg espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AttrName | Restituisce o imposta l'attributo interessato alla modifica.
Proprietà pubblica | Data | Restituisce l'anagrafica utilizzata.
Proprietà pubblica | DedType | Restituisce la famiglia utilizzata.
Proprietà pubblica | LuaId | Restituisce l'identificatico della funzione lua chiamata.
Proprietà pubblica | NewValue | Restituisce o imposta il valore che verrà utilizzato per la sostituzione.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di DedRuleLuaEventArg

Il tipo DedRuleLuaEventArg espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AttrName | Restituisce o imposta l'attributo interessato alla modifica.
Proprietà pubblica | Data | Restituisce l'anagrafica utilizzata.
Proprietà pubblica | DedType | Restituisce la famiglia utilizzata.
Proprietà pubblica | LuaId | Restituisce l'identificatico della funzione lua chiamata.
Proprietà pubblica | NewValue | Restituisce o imposta il valore che verrà utilizzato per la sostituzione.
Torna su
Vedi anche

Documentazione

Classe DedRuleLuaEventArg
Namespace DedNet.Core


Proprietà DedRuleLuaEventArg.AttrName

Proprietà DedRuleLuaEventArgAttrName
Restituisce o imposta l'attributo interessato alla modifica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string AttrName { get; set; }
Public Property AttrName As String
    Get
    Set
public:
property String^ AttrName {
    String^ get ();
    void set (String^ value);
}
member AttrName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedRuleLuaEventArg
Namespace DedNet.Core


Proprietà DedRuleLuaEventArg.Data

Proprietà DedRuleLuaEventArgData
Restituisce l'anagrafica utilizzata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public IDedTypeEditable Data { get; }
Public ReadOnly Property Data As IDedTypeEditable
    Get
public:
property IDedTypeEditable^ Data {
    IDedTypeEditable^ get ();
}
member Data : IDedTypeEditable with get

Valore della proprietà

IDedTypeEditable
Vedi anche

Documentazione

Classe DedRuleLuaEventArg
Namespace DedNet.Core


Proprietà DedRuleLuaEventArg.DedType

Proprietà DedRuleLuaEventArgDedType
Restituisce la famiglia utilizzata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeBase DedType { get; }
Public ReadOnly Property DedType As DedTypeBase
    Get
public:
property DedTypeBase^ DedType {
    DedTypeBase^ get ();
}
member DedType : DedTypeBase with get

Valore della proprietà

DedTypeBase
Vedi anche

Documentazione

Classe DedRuleLuaEventArg
Namespace DedNet.Core


Proprietà DedRuleLuaEventArg.LuaId

Proprietà DedRuleLuaEventArgLuaId
Restituisce l'identificatico della funzione lua chiamata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string LuaId { get; }
Public ReadOnly Property LuaId As String
    Get
public:
property String^ LuaId {
    String^ get ();
}
member LuaId : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedRuleLuaEventArg
Namespace DedNet.Core


Proprietà DedRuleLuaEventArg.NewValue

Proprietà DedRuleLuaEventArgNewValue
Restituisce o imposta il valore che verrà utilizzato per la sostituzione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string NewValue { get; set; }
Public Property NewValue As String
    Get
    Set
public:
property String^ NewValue {
    String^ get ();
    void set (String^ value);
}
member NewValue : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedRuleLuaEventArg
Namespace DedNet.Core


Classe DedRuleParser
Classe che effettua il parser di una stringa di codifica e mette a disposizione le funzionalità di sostituzione e decodifica. {FN} - Prende il nome della famiglia di livello 'N'. {F1:2} - Prende i primi 2 caratteri della famiglia di primo livello. {F1:2,4} - Prende i 4 caratteri a partire dal secondo del nome famiglia. Es '012345':2,3 ->'123'. {F1:-3} - Prende gli ultimi 3 caratteri dal nome famiglia. Es '012345':-3 ->'345'. Al posto di 'F' ci può essere: D : Descrizione della famiglia. P : Progressivo ereditato dalla famiglia correntemente selezionata (senza la possibilità di indicazione del livello). R : Revisione (senza la possibilità di indicazione del livello). U : Tassello utente (senza la possibilità di indicazione del livello). V : Tassello variante (senza la possibilità di indicazione del livello). T : Formato di stampa (senza la possibilità di indicazione del livello). {L:MiaFunzione} : Chiama l'evento dedicato passandogli il nome della funzione 'MiaFunzione'.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedRuleParser

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedRuleParser
Public Class DedRuleParser
public ref class DedRuleParser
type DedRuleParser = class end

Il tipo DedRuleParser espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedRuleParser | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Anagr | Anagrafica associata alle regole
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene.
Proprietà pubblica | Fam | Famiglia associata alle regole
Proprietà pubblica | Format | Formato da impostare
Proprietà pubblica | Progr | Progressivo da impostare
Proprietà pubblica | Rev | Revisione da impostare
Proprietà pubblica | SubsChar | Carattere da utilizzare nel caso non ci siamo caratteri sufficienti
Proprietà pubblica | User | Tassello utente da impostare
Proprietà pubblica | Var | Tassello variante da impostare
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | DecodeString | Effettua la decodifica della stringa contenuta all'interno dell'oggetto utilizzando il valore passato. Restituisce sempre una lista inizializzata ma vuota nel caso non ci fossere corrispondenze.
Metodo pubblico | EncodeString(Boolean) | Effettua il parsing dei vari token presenti nell'espressione e restituisce la stringa sostituita.
Metodo pubblico | EncodeString(DedEncodeInfo, Boolean) | Effettua il parsing dei vari token presenti nell'espressione e restituisce la stringa sostituita.
Metodo pubblico | GetTokenCount | Restituisce il numero di tasselli presenti nella stringa aventi un particolare nome.
Metodo protetto | OnRowSetAttrPost | Chiama l'evento RowSetAttrPost.
Metodo protetto | OnSingleSetAttrPre | Chiama l'evento SingleSetAttrPre.
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | RowSetAttrPost | Evento chiamato subito dopo la sostituzione di tutta la stringa.
Evento pubblico | SingleSetAttrPre | Evento chiamato prima della sostituzione di un singolo token della stringa.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedRuleParser
Costruttore

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedRuleParser(
    DedNetApplication app,
    string strCode,
    string attrName
)
Public Sub New (
    app As DedNetApplication,
    strCode As String,
    attrName As String
)
public:
DedRuleParser(
    DedNetApplication^ app,
    String^ strCode,
    String^ attrName
)
new :
        app : DedNetApplication *
        strCode : string *
        attrName : string -> DedRuleParser

Parametri

app DedNetApplication
Applicazione di appartenenza.
strCode String
stringa sulla quale effettuare il parser
attrName String
Vedi anche

Documentazione

Classe DedRuleParser
Namespace DedNet.Core


Proprietà di DedRuleParser

Il tipo DedRuleParser espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Anagr | Anagrafica associata alle regole
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene.
Proprietà pubblica | Fam | Famiglia associata alle regole
Proprietà pubblica | Format | Formato da impostare
Proprietà pubblica | Progr | Progressivo da impostare
Proprietà pubblica | Rev | Revisione da impostare
Proprietà pubblica | SubsChar | Carattere da utilizzare nel caso non ci siamo caratteri sufficienti
Proprietà pubblica | User | Tassello utente da impostare
Proprietà pubblica | Var | Tassello variante da impostare
Torna su
Vedi anche

Documentazione

Classe DedRuleParser
Namespace DedNet.Core


Proprietà DedRuleParser.Anagr

Proprietà DedRuleParserAnagr
Anagrafica associata alle regole

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public IDedTypeEditable Anagr { get; set; }
Public Property Anagr As IDedTypeEditable
    Get
    Set
public:
property IDedTypeEditable^ Anagr {
    IDedTypeEditable^ get ();
    void set (IDedTypeEditable^ value);
}
member Anagr : IDedTypeEditable with get, set

Valore della proprietà

IDedTypeEditable
Vedi anche

Documentazione

Classe DedRuleParser
Namespace DedNet.Core


Proprietà DedRuleParser.Application

Proprietà DedRuleParserApplication
Restituisce l'applicazione alla quale questo oggetto appartiene.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedNetApplication Application { get; }
Public ReadOnly Property Application As DedNetApplication
    Get
public:
property DedNetApplication^ Application {
    DedNetApplication^ get ();
}
member Application : DedNetApplication with get

Valore della proprietà

DedNetApplication
Vedi anche

Documentazione

Classe DedRuleParser
Namespace DedNet.Core


Proprietà DedRuleParser.Fam

Proprietà DedRuleParserFam
Famiglia associata alle regole

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeBase Fam { get; set; }
Public Property Fam As DedTypeBase
    Get
    Set
public:
property DedTypeBase^ Fam {
    DedTypeBase^ get ();
    void set (DedTypeBase^ value);
}
member Fam : DedTypeBase with get, set

Valore della proprietà

DedTypeBase
Vedi anche

Documentazione

Classe DedRuleParser
Namespace DedNet.Core


Proprietà DedRuleParser.Format

Proprietà DedRuleParserFormat
Formato da impostare

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set
public:
property String^ Format {
    String^ get ();
    void set (String^ value);
}
member Format : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedRuleParser
Namespace DedNet.Core


Proprietà DedRuleParser.Progr

Proprietà DedRuleParserProgr
Progressivo da impostare

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Progr { get; set; }
Public Property Progr As String
    Get
    Set
public:
property String^ Progr {
    String^ get ();
    void set (String^ value);
}
member Progr : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedRuleParser
Namespace DedNet.Core


Proprietà DedRuleParser.Rev

Proprietà DedRuleParserRev
Revisione da impostare

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Rev { get; set; }
Public Property Rev As String
    Get
    Set
public:
property String^ Rev {
    String^ get ();
    void set (String^ value);
}
member Rev : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedRuleParser
Namespace DedNet.Core


Proprietà DedRuleParser.SubsChar

Proprietà DedRuleParserSubsChar
Carattere da utilizzare nel caso non ci siamo caratteri sufficienti

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public char SubsChar { get; set; }
Public Property SubsChar As Char
    Get
    Set
public:
property wchar_t SubsChar {
    wchar_t get ();
    void set (wchar_t value);
}
member SubsChar : char with get, set

Valore della proprietà

Char
Vedi anche

Documentazione

Classe DedRuleParser
Namespace DedNet.Core


Proprietà DedRuleParser.User

Proprietà DedRuleParserUser
Tassello utente da impostare

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string User { get; set; }
Public Property User As String
    Get
    Set
public:
property String^ User {
    String^ get ();
    void set (String^ value);
}
member User : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedRuleParser
Namespace DedNet.Core


Proprietà DedRuleParser.Var

Proprietà DedRuleParserVar
Tassello variante da impostare

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Var { get; set; }
Public Property Var As String
    Get
    Set
public:
property String^ Var {
    String^ get ();
    void set (String^ value);
}
member Var : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedRuleParser
Namespace DedNet.Core


Metodi di DedRuleParser

Il tipo DedRuleParser espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | DecodeString | Effettua la decodifica della stringa contenuta all'interno dell'oggetto utilizzando il valore passato. Restituisce sempre una lista inizializzata ma vuota nel caso non ci fossere corrispondenze.
Metodo pubblico | EncodeString(Boolean) | Effettua il parsing dei vari token presenti nell'espressione e restituisce la stringa sostituita.
Metodo pubblico | EncodeString(DedEncodeInfo, Boolean) | Effettua il parsing dei vari token presenti nell'espressione e restituisce la stringa sostituita.
Metodo pubblico | GetTokenCount | Restituisce il numero di tasselli presenti nella stringa aventi un particolare nome.
Metodo protetto | OnRowSetAttrPost | Chiama l'evento RowSetAttrPost.
Metodo protetto | OnSingleSetAttrPre | Chiama l'evento SingleSetAttrPre.
Torna su
Vedi anche

Documentazione

Classe DedRuleParser
Namespace DedNet.Core


Metodo DedRuleParser.DecodeString

Metodo DedRuleParserDecodeString
Effettua la decodifica della stringa contenuta all'interno dell'oggetto utilizzando il valore passato. Restituisce sempre una lista inizializzata ma vuota nel caso non ci fossere corrispondenze.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public TokenInfoList DecodeString(
    string valString
)
Public Function DecodeString (
    valString As String
) As TokenInfoList
public:
TokenInfoList^ DecodeString(
    String^ valString
)
member DecodeString :
        valString : string -> TokenInfoList

Parametri

valString String
Valore dal quale ricavare le informazioni di decodifica.

Valore di ritorno

TokenInfoList
Restituisce una lista di oggetti descrittori della decodifica. Restituisce sempre una lista inizializzata ma vuota nel caso non ci fossere corrispondenze.
Vedi anche

Documentazione

Classe DedRuleParser
Namespace DedNet.Core


Metodo DedRuleParser.EncodeString

Metodo DedRuleParserEncodeString
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | EncodeString(Boolean) | Effettua il parsing dei vari token presenti nell'espressione e restituisce la stringa sostituita.
Metodo pubblico | EncodeString(DedEncodeInfo, Boolean) | Effettua il parsing dei vari token presenti nell'espressione e restituisce la stringa sostituita.
Torna su
Vedi anche

Documentazione

Classe DedRuleParser
Namespace DedNet.Core


Metodo DedRuleParser.EncodeString(Boolean)

Metodo DedRuleParserEncodeString(Boolean)
Effettua il parsing dei vari token presenti nell'espressione e restituisce la stringa sostituita.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string EncodeString(
    bool handleNullValue
)
Public Function EncodeString (
    handleNullValue As Boolean
) As String
public:
String^ EncodeString(
    bool handleNullValue
)
member EncodeString :
        handleNullValue : bool -> string

Parametri

handleNullValue Boolean
Indica se gestire i valori compresi tra ( ) in modo che se sono vuoti non vengano scritti nell'attributo.

Valore di ritorno

String
Restituisce la stringa di sostituzione calcolata.
Vedi anche

Documentazione

Classe DedRuleParser
Overload di EncodeString
Namespace DedNet.Core


Metodo DedRuleParser.EncodeString(DedEncodeInfo, Boolean)

Metodo DedRuleParserEncodeString(DedEncodeInfo, Boolean)
Effettua il parsing dei vari token presenti nell'espressione e restituisce la stringa sostituita.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string EncodeString(
    DedEncodeInfo info,
    bool handleNullValue
)
Public Function EncodeString (
    info As DedEncodeInfo,
    handleNullValue As Boolean
) As String
public:
String^ EncodeString(
    DedEncodeInfo^ info,
    bool handleNullValue
)
member EncodeString :
        info : DedEncodeInfo *
        handleNullValue : bool -> string

Parametri

info DedEncodeInfo
Informazioni di codifica da utilizzare ed impostare in questo oggetto.
handleNullValue Boolean
Indica se gestire i valori compresi tra ( ) in modo che se sono vuoti non vengano scritti nell'attributo.

Valore di ritorno

String
Restituisce la stringa di sostituzione calcolata.
Vedi anche

Documentazione

Classe DedRuleParser
Overload di EncodeString
Namespace DedNet.Core


Metodo DedRuleParser.GetTokenCount

Metodo DedRuleParserGetTokenCount
Restituisce il numero di tasselli presenti nella stringa aventi un particolare nome.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int GetTokenCount(
    string nomeTassello
)
Public Function GetTokenCount (
    nomeTassello As String
) As Integer
public:
int GetTokenCount(
    String^ nomeTassello
)
member GetTokenCount :
        nomeTassello : string -> int

Parametri

nomeTassello String
Nome del tassello da contare. Esempio : "R","P","U", ecc.

Valore di ritorno

Int32
Restituisce il numero di tasselli trovati.
Vedi anche

Documentazione

Classe DedRuleParser
Namespace DedNet.Core


Metodo DedRuleParser.OnRowSetAttrPost

Metodo DedRuleParserOnRowSetAttrPost
Chiama l'evento RowSetAttrPost.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected void OnRowSetAttrPost(
    DedRuleParserEventArg e
)
Protected Sub OnRowSetAttrPost (
    e As DedRuleParserEventArg
)
protected:
void OnRowSetAttrPost(
    DedRuleParserEventArg^ e
)
member OnRowSetAttrPost :
        e : DedRuleParserEventArg -> unit

Parametri

e DedRuleParserEventArg
Oggetto DedRuleParserEventArg.
Vedi anche

Documentazione

Classe DedRuleParser
Namespace DedNet.Core


Metodo DedRuleParser.OnSingleSetAttrPre

Metodo DedRuleParserOnSingleSetAttrPre
Chiama l'evento SingleSetAttrPre.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected void OnSingleSetAttrPre(
    DedRuleParserEventArg e
)
Protected Sub OnSingleSetAttrPre (
    e As DedRuleParserEventArg
)
protected:
void OnSingleSetAttrPre(
    DedRuleParserEventArg^ e
)
member OnSingleSetAttrPre :
        e : DedRuleParserEventArg -> unit

Parametri

e DedRuleParserEventArg
Oggetto DedRuleParserEventArg.
Vedi anche

Documentazione

Classe DedRuleParser
Namespace DedNet.Core


Eventi di DedRuleParser

Il tipo DedRuleParser espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | RowSetAttrPost | Evento chiamato subito dopo la sostituzione di tutta la stringa.
Evento pubblico | SingleSetAttrPre | Evento chiamato prima della sostituzione di un singolo token della stringa.
Torna su
Vedi anche

Documentazione

Classe DedRuleParser
Namespace DedNet.Core


Evento DedRuleParser.RowSetAttrPost

Evento DedRuleParserRowSetAttrPost
Evento chiamato subito dopo la sostituzione di tutta la stringa.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DedRuleParserEventArg> RowSetAttrPost
Public Event RowSetAttrPost As EventHandler(Of DedRuleParserEventArg)
public:
 event EventHandler<DedRuleParserEventArg^>^ RowSetAttrPost {
    void add (EventHandler<DedRuleParserEventArg^>^ value);
    void remove (EventHandler<DedRuleParserEventArg^>^ value);
}
member RowSetAttrPost : IEvent<EventHandler<DedRuleParserEventArg>,
    DedRuleParserEventArg>

Valore

EventHandler DedRuleParserEventArg
Vedi anche

Documentazione

Classe DedRuleParser
Namespace DedNet.Core


Evento DedRuleParser.SingleSetAttrPre

Evento DedRuleParserSingleSetAttrPre
Evento chiamato prima della sostituzione di un singolo token della stringa.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DedRuleParserEventArg> SingleSetAttrPre
Public Event SingleSetAttrPre As EventHandler(Of DedRuleParserEventArg)
public:
 event EventHandler<DedRuleParserEventArg^>^ SingleSetAttrPre {
    void add (EventHandler<DedRuleParserEventArg^>^ value);
    void remove (EventHandler<DedRuleParserEventArg^>^ value);
}
member SingleSetAttrPre : IEvent<EventHandler<DedRuleParserEventArg>,
    DedRuleParserEventArg>

Valore

EventHandler DedRuleParserEventArg
Vedi anche

Documentazione

Classe DedRuleParser
Namespace DedNet.Core


Classe DedRuleParserEventArg
Contiene le informazioni per la sostituizione di un singolo token.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNet.CoreDedRuleParserEventArg

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedRuleParserEventArg : EventArgs
Public Class DedRuleParserEventArg
    Inherits EventArgs
public ref class DedRuleParserEventArg : public EventArgs
type DedRuleParserEventArg =
    class
        inherit EventArgs
    end

Il tipo DedRuleParserEventArg espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Token | Restituisce il Token che è in elaborazione.
Proprietà pubblica | Value | Restituisce o imposta il valore del token che è in elaborazione e che verrà utilizzato per la sostituzione.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di DedRuleParserEventArg

Il tipo DedRuleParserEventArg espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Token | Restituisce il Token che è in elaborazione.
Proprietà pubblica | Value | Restituisce o imposta il valore del token che è in elaborazione e che verrà utilizzato per la sostituzione.
Torna su
Vedi anche

Documentazione

Classe DedRuleParserEventArg
Namespace DedNet.Core


Proprietà DedRuleParserEventArg.Token

Proprietà DedRuleParserEventArgToken
Restituisce il Token che è in elaborazione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Token { get; }
Public ReadOnly Property Token As String
    Get
public:
property String^ Token {
    String^ get ();
}
member Token : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedRuleParserEventArg
Namespace DedNet.Core


Proprietà DedRuleParserEventArg.Value

Proprietà DedRuleParserEventArgValue
Restituisce o imposta il valore del token che è in elaborazione e che verrà utilizzato per la sostituzione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}
member Value : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedRuleParserEventArg
Namespace DedNet.Core


Enumerazione DedStandardPerm
Enumerazione contenente tutti i permessi standard.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum DedStandardPerm
Public Enumeration DedStandardPerm
public enum class DedStandardPerm
type DedStandardPerm
Membri
Nome | Valore | Descrizione
NONE | 0 |
READ | 1 |
ATTACH | 2 |
WRITE | 3 |
RIL | 4 |
UNRIL | 5 |
REV | 6 |
ERASE | 7 |
CREATE | 8 |
ADMIN | 9 |
ADMINFAM | 10 |
ADMINATT | 11 |
ADMINCMD | 12 |
MANAGEATTACH | 13 |
ATTACHANAGCOMM | 14 |
DEATTACHANAGCOMM | 15 |
ATTACHDOCCOMM | 16 |
DEATTACHDOCCOMM | 17 |
CLOSECOMM | 18 |
CREATECOMM | 19 |
EDITCOMM | 20 |
ERASECOMM | 21 |
READCOMM | 22 |
REOPENCOMM | 23 |
CREATEFOLDER | 24 |
DEATTACH | 25 |
EDITFOLDER | 26 |
ERASEFOLDER | 27 |
READFOLDER | 28 |
READECO | 29 |
CREATEECO | 30 |
EDITECO | 31 |
ASSIGNECO | 32 |
ATTACHDOCECO | 33 |
DELETEDOCECO | 34 |
READATTRIBUTES | 35 |
EDITATTRIBUTES | 36 |
Vedi anche

Documentazione

Namespace DedNet.Core


Classe DedState
Classe per gestire l'abbinamento tra nome e valore dello stato.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedState

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedState
Public Class DedState
public ref class DedState
type DedState = class end

Il tipo DedState espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedState | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Categ | Restiruisce la categoria di appartenenza.
Proprietà pubblica | Descr | Nome dello stato.
Proprietà pubblica | Icon16 | Icona 16x16.
Proprietà pubblica | Icon32 | Icona 32x32.
Proprietà pubblica | Id | Id dello stato.
Proprietà pubblica | Nome | Nome dello stato.
Proprietà pubblica | NomeIt | Nome dello stato.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Torna su
Operatori
Nome | Descrizione
Equality(DedState, DedState) | Ridefinizione dell'operatore ==.
Inequality(DedState, DedState) | Ridefinizione dell'operatore !=.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedState
Costruttore unico.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedState(
    int id,
    string nome,
    string nome_it,
    string descr,
    DedStateCategory categ,
    Image icon16,
    Image icon32
)
Public Sub New (
    id As Integer,
    nome As String,
    nome_it As String,
    descr As String,
    categ As DedStateCategory,
    icon16 As Image,
    icon32 As Image
)
public:
DedState(
    int id,
    String^ nome,
    String^ nome_it,
    String^ descr,
    DedStateCategory^ categ,
    Image^ icon16,
    Image^ icon32
)
new :
        id : int *
        nome : string *
        nome_it : string *
        descr : string *
        categ : DedStateCategory *
        icon16 : Image *
        icon32 : Image -> DedState

Parametri

id Int32
Id dello stato
nome String
Nome dello stato
nome_it String
descr String
Descrizione dello stato
categ DedStateCategory
Categoria di appartenenza
icon16 Image
Icona 16x16
icon32 Image
Icona 32x32
Vedi anche

Documentazione

Classe DedState
Namespace DedNet.Core


Proprietà di DedState

Il tipo DedState espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Categ | Restiruisce la categoria di appartenenza.
Proprietà pubblica | Descr | Nome dello stato.
Proprietà pubblica | Icon16 | Icona 16x16.
Proprietà pubblica | Icon32 | Icona 32x32.
Proprietà pubblica | Id | Id dello stato.
Proprietà pubblica | Nome | Nome dello stato.
Proprietà pubblica | NomeIt | Nome dello stato.
Torna su
Vedi anche

Documentazione

Classe DedState
Namespace DedNet.Core


Proprietà DedState.Categ

Proprietà DedStateCateg
Restiruisce la categoria di appartenenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedStateCategory Categ { get; }
Public ReadOnly Property Categ As DedStateCategory
    Get
public:
property DedStateCategory^ Categ {
    DedStateCategory^ get ();
}
member Categ : DedStateCategory with get

Valore della proprietà

DedStateCategory
Vedi anche

Documentazione

Classe DedState
Namespace DedNet.Core


Proprietà DedState.Descr

Proprietà DedStateDescr
Nome dello stato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Descr { get; }
Public ReadOnly Property Descr As String
    Get
public:
property String^ Descr {
    String^ get ();
}
member Descr : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedState
Namespace DedNet.Core


Proprietà DedState.Icon16

Proprietà DedStateIcon16
Icona 16x16.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Image Icon16 { get; }
Public ReadOnly Property Icon16 As Image
    Get
public:
property Image^ Icon16 {
    Image^ get ();
}
member Icon16 : Image with get

Valore della proprietà

Image
Vedi anche

Documentazione

Classe DedState
Namespace DedNet.Core


Proprietà DedState.Icon32

Proprietà DedStateIcon32
Icona 32x32.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Image Icon32 { get; }
Public ReadOnly Property Icon32 As Image
    Get
public:
property Image^ Icon32 {
    Image^ get ();
}
member Icon32 : Image with get

Valore della proprietà

Image
Vedi anche

Documentazione

Classe DedState
Namespace DedNet.Core


Proprietà DedState.Id

Proprietà DedStateId
Id dello stato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int Id { get; }
Public ReadOnly Property Id As Integer
    Get
public:
property int Id {
    int get ();
}
member Id : int with get

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe DedState
Namespace DedNet.Core


Proprietà DedState.Nome

Proprietà DedStateNome
Nome dello stato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Nome { get; }
Public ReadOnly Property Nome As String
    Get
public:
property String^ Nome {
    String^ get ();
}
member Nome : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedState
Namespace DedNet.Core


Proprietà DedState.NomeIt

Proprietà DedStateNomeIt
Nome dello stato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string NomeIt { get; }
Public ReadOnly Property NomeIt As String
    Get
public:
property String^ NomeIt {
    String^ get ();
}
member NomeIt : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedState
Namespace DedNet.Core


Metodi di DedState

Il tipo DedState espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Torna su
Vedi anche

Documentazione

Classe DedState
Namespace DedNet.Core


Metodo DedState.Equals

Metodo DedStateEquals

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj Object

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedState
Namespace DedNet.Core


Metodo DedState.GetHashCode

Metodo DedStateGetHashCode

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedState
Namespace DedNet.Core


Metodo DedState.ToString

Metodo DedStateToString

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedState
Namespace DedNet.Core


DedState Operators

Il tipo DedState espone i seguenti membri.

Operatori
Nome | Descrizione
Equality(DedState, DedState) | Ridefinizione dell'operatore ==.
Inequality(DedState, DedState) | Ridefinizione dell'operatore !=.
Torna su
Vedi anche

Documentazione

Classe DedState
Namespace DedNet.Core


DedState.Equality Operatore

DedStateEquality Operatore
Ridefinizione dell'operatore ==.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool operator ==(
    DedState a,
    DedState b
)
Public Shared Operator = (
    a As DedState,
    b As DedState
) As Boolean
public:
static bool operator ==(
    DedState^ a,
    DedState^ b
)
static let inline (=)
        a : DedState *
        b : DedState  : bool

Parametri

a DedState
b DedState

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedState
Namespace DedNet.Core


DedState.Inequality Operatore

DedStateInequality Operatore
Ridefinizione dell'operatore !=.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool operator !=(
    DedState a,
    DedState b
)
Public Shared Operator <> (
    a As DedState,
    b As DedState
) As Boolean
public:
static bool operator !=(
    DedState^ a,
    DedState^ b
)
static let inline (<>)
        a : DedState *
        b : DedState  : bool

Parametri

a DedState
b DedState

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedState
Namespace DedNet.Core


Classe DedStateCategory
Classe per rappresentare le categorie degli stati.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedStateCategory

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedStateCategory
Public Class DedStateCategory
public ref class DedStateCategory
type DedStateCategory = class end

Il tipo DedStateCategory espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedStateCategory | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Descr | Descrizione della categoria
Proprietà pubblica | Id | Id della categoria
Proprietà pubblica | Nome | Nome della categoria
Proprietà pubblica | ReadOnly | Indica se è una categoria di sola lettura.
Proprietà pubblica | Requested | Indica se è una categoria obbligatoria
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Torna su
Operatori
Nome | Descrizione
Equality(DedStateCategory, DedStateCategory) | Ridefinizione dell'operatore ==.
Inequality(DedStateCategory, DedStateCategory) | Ridefinizione dell'operatore !=.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedStateCategory
Costruttore unico.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedStateCategory(
    int id,
    string nome,
    string descr,
    bool readonlystate,
    bool requested
)
Public Sub New (
    id As Integer,
    nome As String,
    descr As String,
    readonlystate As Boolean,
    requested As Boolean
)
public:
DedStateCategory(
    int id,
    String^ nome,
    String^ descr,
    bool readonlystate,
    bool requested
)
new :
        id : int *
        nome : string *
        descr : string *
        readonlystate : bool *
        requested : bool -> DedStateCategory

Parametri

id Int32
Id categoria
nome String
Nome categoria
descr String
Descrizione categoria
readonlystate Boolean
Indica se è una categoria di sola lettura
requested Boolean
Categoria richiesta dal sistema
Vedi anche

Documentazione

Classe DedStateCategory
Namespace DedNet.Core


Proprietà di DedStateCategory

Il tipo DedStateCategory espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Descr | Descrizione della categoria
Proprietà pubblica | Id | Id della categoria
Proprietà pubblica | Nome | Nome della categoria
Proprietà pubblica | ReadOnly | Indica se è una categoria di sola lettura.
Proprietà pubblica | Requested | Indica se è una categoria obbligatoria
Torna su
Vedi anche

Documentazione

Classe DedStateCategory
Namespace DedNet.Core


Proprietà DedStateCategory.Descr

Proprietà DedStateCategoryDescr
Descrizione della categoria

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Descr { get; }
Public ReadOnly Property Descr As String
    Get
public:
property String^ Descr {
    String^ get ();
}
member Descr : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedStateCategory
Namespace DedNet.Core


Proprietà DedStateCategory.Id

Proprietà DedStateCategoryId
Id della categoria

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int Id { get; }
Public ReadOnly Property Id As Integer
    Get
public:
property int Id {
    int get ();
}
member Id : int with get

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe DedStateCategory
Namespace DedNet.Core


Proprietà DedStateCategory.Nome

Proprietà DedStateCategoryNome
Nome della categoria

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Nome { get; }
Public ReadOnly Property Nome As String
    Get
public:
property String^ Nome {
    String^ get ();
}
member Nome : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedStateCategory
Namespace DedNet.Core


Proprietà DedStateCategory.ReadOnly

Proprietà DedStateCategoryReadOnly
Indica se è una categoria di sola lettura.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ReadOnly { get; }
Public ReadOnly Property ReadOnly As Boolean
    Get
public:
property bool ReadOnly {
    bool get ();
}
member ReadOnly : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedStateCategory
Namespace DedNet.Core


Proprietà DedStateCategory.Requested

Proprietà DedStateCategoryRequested
Indica se è una categoria obbligatoria

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Requested { get; }
Public ReadOnly Property Requested As Boolean
    Get
public:
property bool Requested {
    bool get ();
}
member Requested : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedStateCategory
Namespace DedNet.Core


Metodi di DedStateCategory

Il tipo DedStateCategory espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Torna su
Vedi anche

Documentazione

Classe DedStateCategory
Namespace DedNet.Core


Metodo DedStateCategory.Equals

Metodo DedStateCategoryEquals

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj Object

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedStateCategory
Namespace DedNet.Core


Metodo DedStateCategory.GetHashCode

Metodo DedStateCategoryGetHashCode

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedStateCategory
Namespace DedNet.Core


Metodo DedStateCategory.ToString

Metodo DedStateCategoryToString

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedStateCategory
Namespace DedNet.Core


DedStateCategory Operators

Il tipo DedStateCategory espone i seguenti membri.

Operatori
Nome | Descrizione
Equality(DedStateCategory, DedStateCategory) | Ridefinizione dell'operatore ==.
Inequality(DedStateCategory, DedStateCategory) | Ridefinizione dell'operatore !=.
Torna su
Vedi anche

Documentazione

Classe DedStateCategory
Namespace DedNet.Core


DedStateCategory.Equality Operatore

DedStateCategoryEquality Operatore
Ridefinizione dell'operatore ==.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool operator ==(
    DedStateCategory a,
    DedStateCategory b
)
Public Shared Operator = (
    a As DedStateCategory,
    b As DedStateCategory
) As Boolean
public:
static bool operator ==(
    DedStateCategory^ a,
    DedStateCategory^ b
)
static let inline (=)
        a : DedStateCategory *
        b : DedStateCategory  : bool

Parametri

a DedStateCategory
b DedStateCategory

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedStateCategory
Namespace DedNet.Core


DedStateCategory.Inequality Operatore

DedStateCategoryInequality Operatore
Ridefinizione dell'operatore !=.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool operator !=(
    DedStateCategory a,
    DedStateCategory b
)
Public Shared Operator <> (
    a As DedStateCategory,
    b As DedStateCategory
) As Boolean
public:
static bool operator !=(
    DedStateCategory^ a,
    DedStateCategory^ b
)
static let inline (<>)
        a : DedStateCategory *
        b : DedStateCategory  : bool

Parametri

a DedStateCategory
b DedStateCategory

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedStateCategory
Namespace DedNet.Core


Classe DedStateCategoryList
Lista di oggetti di tipo DedStateCategory.
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList DedStateCategory
DedNet.CoreDedStateCategoryList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedStateCategoryList : List<DedStateCategory>
Public Class DedStateCategoryList
    Inherits List(Of DedStateCategory)
public ref class DedStateCategoryList : public List<DedStateCategory^>
type DedStateCategoryList =
    class
        inherit List<DedStateCategory>
    end

Il tipo DedStateCategoryList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedStateCategoryList |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | FindById | Restituisce la categoria con id passato. Restiruisce null se non esiste.
Metodo pubblico | FindByName | Restituisce la categoria con nome passato. Restiruisce null se non esiste.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedStateCategoryList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedStateCategoryList()
Public Sub New
public:
DedStateCategoryList()
new : unit -> DedStateCategoryList
Vedi anche

Documentazione

Classe DedStateCategoryList
Namespace DedNet.Core


Metodi di DedStateCategoryList

Il tipo DedStateCategoryList espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | FindById | Restituisce la categoria con id passato. Restiruisce null se non esiste.
Metodo pubblico | FindByName | Restituisce la categoria con nome passato. Restiruisce null se non esiste.
Torna su
Vedi anche

Documentazione

Classe DedStateCategoryList
Namespace DedNet.Core


Metodo DedStateCategoryList.FindById

Metodo DedStateCategoryListFindById
Restituisce la categoria con id passato. Restiruisce null se non esiste.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedStateCategory FindById(
    int id
)
Public Function FindById (
    id As Integer
) As DedStateCategory
public:
DedStateCategory^ FindById(
    int id
)
member FindById :
        id : int -> DedStateCategory

Parametri

id Int32
Id categoria da ricercare

Valore di ritorno

DedStateCategory
Vedi anche

Documentazione

Classe DedStateCategoryList
Namespace DedNet.Core


Metodo DedStateCategoryList.FindByName

Metodo DedStateCategoryListFindByName
Restituisce la categoria con nome passato. Restiruisce null se non esiste.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedStateCategory FindByName(
    string nome
)
Public Function FindByName (
    nome As String
) As DedStateCategory
public:
DedStateCategory^ FindByName(
    String^ nome
)
member FindByName :
        nome : string -> DedStateCategory

Parametri

nome String

Valore di ritorno

DedStateCategory
Vedi anche

Documentazione

Classe DedStateCategoryList
Namespace DedNet.Core


Classe DedStateConfiguration
Classe rappresentante le configurazioni degli stati.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedStateConfiguration

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedStateConfiguration
Public Class DedStateConfiguration
public ref class DedStateConfiguration
type DedStateConfiguration = class end

Il tipo DedStateConfiguration espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedStateConfiguration | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Descr | Descrizione della configurazione
Proprietà pubblica | Id | Id della configurazione
Proprietà pubblica | Nome | Nome della configurazione
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedStateConfiguration
Costruttore unico.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedStateConfiguration(
    int id,
    string nome,
    string descr
)
Public Sub New (
    id As Integer,
    nome As String,
    descr As String
)
public:
DedStateConfiguration(
    int id,
    String^ nome,
    String^ descr
)
new :
        id : int *
        nome : string *
        descr : string -> DedStateConfiguration

Parametri

id Int32
Id della configurazione
nome String
Nome della configurazione
descr String
Descrizione della configurazione
Vedi anche

Documentazione

Classe DedStateConfiguration
Namespace DedNet.Core


Proprietà di DedStateConfiguration

Il tipo DedStateConfiguration espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Descr | Descrizione della configurazione
Proprietà pubblica | Id | Id della configurazione
Proprietà pubblica | Nome | Nome della configurazione
Torna su
Vedi anche

Documentazione

Classe DedStateConfiguration
Namespace DedNet.Core


Proprietà DedStateConfiguration.Descr

Proprietà DedStateConfigurationDescr
Descrizione della configurazione

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Descr { get; }
Public ReadOnly Property Descr As String
    Get
public:
property String^ Descr {
    String^ get ();
}
member Descr : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedStateConfiguration
Namespace DedNet.Core


Proprietà DedStateConfiguration.Id

Proprietà DedStateConfigurationId
Id della configurazione

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int Id { get; }
Public ReadOnly Property Id As Integer
    Get
public:
property int Id {
    int get ();
}
member Id : int with get

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe DedStateConfiguration
Namespace DedNet.Core


Proprietà DedStateConfiguration.Nome

Proprietà DedStateConfigurationNome
Nome della configurazione

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Nome { get; }
Public ReadOnly Property Nome As String
    Get
public:
property String^ Nome {
    String^ get ();
}
member Nome : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedStateConfiguration
Namespace DedNet.Core


Classe DedStateConfigurationList
Lista di oggetti di tipo DedStateConfiguration.
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList DedStateConfiguration
DedNet.CoreDedStateConfigurationList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedStateConfigurationList : List<DedStateConfiguration>
Public Class DedStateConfigurationList
    Inherits List(Of DedStateConfiguration)
public ref class DedStateConfigurationList : public List<DedStateConfiguration^>
type DedStateConfigurationList =
    class
        inherit List<DedStateConfiguration>
    end

Il tipo DedStateConfigurationList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedStateConfigurationList |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | FindById | Restituisce la configurazione con id passato. Restiruisce null se non esiste.
Metodo pubblico | FindByName | Restituisce la configurazione con nome passato. Restiruisce null se non esiste.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedStateConfigurationList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedStateConfigurationList()
Public Sub New
public:
DedStateConfigurationList()
new : unit -> DedStateConfigurationList
Vedi anche

Documentazione

Classe DedStateConfigurationList
Namespace DedNet.Core


Metodi di DedStateConfigurationList

Il tipo DedStateConfigurationList espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | FindById | Restituisce la configurazione con id passato. Restiruisce null se non esiste.
Metodo pubblico | FindByName | Restituisce la configurazione con nome passato. Restiruisce null se non esiste.
Torna su
Vedi anche

Documentazione

Classe DedStateConfigurationList
Namespace DedNet.Core


Metodo DedStateConfigurationList.FindById

Metodo DedStateConfigurationListFindById
Restituisce la configurazione con id passato. Restiruisce null se non esiste.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedStateConfiguration FindById(
    int id
)
Public Function FindById (
    id As Integer
) As DedStateConfiguration
public:
DedStateConfiguration^ FindById(
    int id
)
member FindById :
        id : int -> DedStateConfiguration

Parametri

id Int32
Id configurazione da ricercare

Valore di ritorno

DedStateConfiguration
Vedi anche

Documentazione

Classe DedStateConfigurationList
Namespace DedNet.Core


Metodo DedStateConfigurationList.FindByName

Metodo DedStateConfigurationListFindByName
Restituisce la configurazione con nome passato. Restiruisce null se non esiste.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedStateConfiguration FindByName(
    string nome
)
Public Function FindByName (
    nome As String
) As DedStateConfiguration
public:
DedStateConfiguration^ FindByName(
    String^ nome
)
member FindByName :
        nome : string -> DedStateConfiguration

Parametri

nome String

Valore di ritorno

DedStateConfiguration
Vedi anche

Documentazione

Classe DedStateConfigurationList
Namespace DedNet.Core


Classe DedStateFlowTransactionDescriptor
Classe che rappresenta la descrizione della singola transazione.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedStateFlowTransactionDescriptor

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedStateFlowTransactionDescriptor
Public Class DedStateFlowTransactionDescriptor
public ref class DedStateFlowTransactionDescriptor
type DedStateFlowTransactionDescriptor = class end

Il tipo DedStateFlowTransactionDescriptor espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedStateFlowTransactionDescriptor | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | DefaultCheckStatusOnMultipleOpearations | Indica se nelle operazioni multiple la transazione deve essere preselezionata
Proprietà pubblica | NeedChildrenCheck | Indica se è necessario controllare lo stato dei figli
Proprietà pubblica | PubAction | Azione da compiere sui documneti di pubblicazione.
Proprietà pubblica | Reserved | Indica se è un passaggio di stato riservato.
Proprietà pubblica | StateFrom | Stato di partenza.
Proprietà pubblica | StateTo | Stato di arrivo.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedStateFlowTransactionDescriptor
Costruttore unico.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedStateFlowTransactionDescriptor(
    DedState stateFrom,
    DedState stateTo,
    DedPubActionEnum pubAction,
    bool reserved,
    bool needChildrenCheck,
    bool defaultCheckStatusOnMultipleOpearations
)
Public Sub New (
    stateFrom As DedState,
    stateTo As DedState,
    pubAction As DedPubActionEnum,
    reserved As Boolean,
    needChildrenCheck As Boolean,
    defaultCheckStatusOnMultipleOpearations As Boolean
)
public:
DedStateFlowTransactionDescriptor(
    DedState^ stateFrom,
    DedState^ stateTo,
    DedPubActionEnum pubAction,
    bool reserved,
    bool needChildrenCheck,
    bool defaultCheckStatusOnMultipleOpearations
)
new :
        stateFrom : DedState *
        stateTo : DedState *
        pubAction : DedPubActionEnum *
        reserved : bool *
        needChildrenCheck : bool *
        defaultCheckStatusOnMultipleOpearations : bool -> DedStateFlowTransactionDescriptor

Parametri

stateFrom DedState
Stato di partenza
stateTo DedState
Stato di arrivo
pubAction DedPubActionEnum
Azione da compiere sui documneti di pubblicazione
reserved Boolean
needChildrenCheck Boolean
defaultCheckStatusOnMultipleOpearations Boolean
Vedi anche

Documentazione

Classe DedStateFlowTransactionDescriptor
Namespace DedNet.Core


Proprietà di DedStateFlowTransactionDescriptor

Il tipo DedStateFlowTransactionDescriptor espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | DefaultCheckStatusOnMultipleOpearations | Indica se nelle operazioni multiple la transazione deve essere preselezionata
Proprietà pubblica | NeedChildrenCheck | Indica se è necessario controllare lo stato dei figli
Proprietà pubblica | PubAction | Azione da compiere sui documneti di pubblicazione.
Proprietà pubblica | Reserved | Indica se è un passaggio di stato riservato.
Proprietà pubblica | StateFrom | Stato di partenza.
Proprietà pubblica | StateTo | Stato di arrivo.
Torna su
Vedi anche

Documentazione

Classe DedStateFlowTransactionDescriptor
Namespace DedNet.Core


Proprietà DedStateFlowTransactionDescriptor.DefaultCheckStatusOnMultipleOpearations

Proprietà DedStateFlowTransactionDescriptorDefaultCheckStatusOnMultipleOpearations
Indica se nelle operazioni multiple la transazione deve essere preselezionata

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool DefaultCheckStatusOnMultipleOpearations { get; }
Public ReadOnly Property DefaultCheckStatusOnMultipleOpearations As Boolean
    Get
public:
property bool DefaultCheckStatusOnMultipleOpearations {
    bool get ();
}
member DefaultCheckStatusOnMultipleOpearations : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedStateFlowTransactionDescriptor
Namespace DedNet.Core


Proprietà DedStateFlowTransactionDescriptor.NeedChildrenCheck

Proprietà DedStateFlowTransactionDescriptorNeedChildrenCheck
Indica se è necessario controllare lo stato dei figli

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool NeedChildrenCheck { get; }
Public ReadOnly Property NeedChildrenCheck As Boolean
    Get
public:
property bool NeedChildrenCheck {
    bool get ();
}
member NeedChildrenCheck : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedStateFlowTransactionDescriptor
Namespace DedNet.Core


Proprietà DedStateFlowTransactionDescriptor.PubAction

Proprietà DedStateFlowTransactionDescriptorPubAction
Azione da compiere sui documneti di pubblicazione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedPubActionEnum PubAction { get; }
Public ReadOnly Property PubAction As DedPubActionEnum
    Get
public:
property DedPubActionEnum PubAction {
    DedPubActionEnum get ();
}
member PubAction : DedPubActionEnum with get

Valore della proprietà

DedPubActionEnum
Vedi anche

Documentazione

Classe DedStateFlowTransactionDescriptor
Namespace DedNet.Core


Proprietà DedStateFlowTransactionDescriptor.Reserved

Proprietà DedStateFlowTransactionDescriptorReserved
Indica se è un passaggio di stato riservato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Reserved { get; }
Public ReadOnly Property Reserved As Boolean
    Get
public:
property bool Reserved {
    bool get ();
}
member Reserved : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedStateFlowTransactionDescriptor
Namespace DedNet.Core


Proprietà DedStateFlowTransactionDescriptor.StateFrom

Proprietà DedStateFlowTransactionDescriptorStateFrom
Stato di partenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedState StateFrom { get; }
Public ReadOnly Property StateFrom As DedState
    Get
public:
property DedState^ StateFrom {
    DedState^ get ();
}
member StateFrom : DedState with get

Valore della proprietà

DedState
Vedi anche

Documentazione

Classe DedStateFlowTransactionDescriptor
Namespace DedNet.Core


Proprietà DedStateFlowTransactionDescriptor.StateTo

Proprietà DedStateFlowTransactionDescriptorStateTo
Stato di arrivo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedState StateTo { get; }
Public ReadOnly Property StateTo As DedState
    Get
public:
property DedState^ StateTo {
    DedState^ get ();
}
member StateTo : DedState with get

Valore della proprietà

DedState
Vedi anche

Documentazione

Classe DedStateFlowTransactionDescriptor
Namespace DedNet.Core


Classe DedStateFlowTransactionDescriptorList
Lista di oggetti di tipo DedStateFlowTransactionDescriptor.
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList DedStateFlowTransactionDescriptor
DedNet.CoreDedStateFlowTransactionDescriptorList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedStateFlowTransactionDescriptorList : List<DedStateFlowTransactionDescriptor>
Public Class DedStateFlowTransactionDescriptorList
    Inherits List(Of DedStateFlowTransactionDescriptor)
public ref class DedStateFlowTransactionDescriptorList : public List<DedStateFlowTransactionDescriptor^>
type DedStateFlowTransactionDescriptorList =
    class
        inherit List<DedStateFlowTransactionDescriptor>
    end

Il tipo DedStateFlowTransactionDescriptorList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedStateFlowTransactionDescriptorList |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedStateFlowTransactionDescriptorList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedStateFlowTransactionDescriptorList()
Public Sub New
public:
DedStateFlowTransactionDescriptorList()
new : unit -> DedStateFlowTransactionDescriptorList
Vedi anche

Documentazione

Classe DedStateFlowTransactionDescriptorList
Namespace DedNet.Core


Classe DedStateFlowTransactions
Classe rappresentante i flussi dei vari stati. Dizionario contente l'id dello stato di partenza con la lista di tutti i possibili stati di arrivo.
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericDictionary Int32, DedStateFlowTransactionDescriptorList
DedNet.CoreDedStateFlowTransactions

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedStateFlowTransactions : Dictionary<int, DedStateFlowTransactionDescriptorList>
Public Class DedStateFlowTransactions
    Inherits Dictionary(Of Integer, DedStateFlowTransactionDescriptorList)
public ref class DedStateFlowTransactions : public Dictionary<int, DedStateFlowTransactionDescriptorList^>
type DedStateFlowTransactions =
    class
        inherit Dictionary<int, DedStateFlowTransactionDescriptorList>
    end

Il tipo DedStateFlowTransactions espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedStateFlowTransactions |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Add | Metodo per aggiungere un flusso nel dizionario.
Metodo pubblico | DefaultCheckStatusOnMultipleOpearations | Restituisce vero se il passaggio di stato richiede il controllo dello stato dei figli
Metodo pubblico | GetAllInvolvedStates | Restituisce la lista di tutti gli stati coinvolti nelle transazione della configurazione corrente.
Metodo pubblico | GetAllInvolvedStates(Int32) | Restituisce la lista di tutti gli stati coinvolti nelle transazione della configurazione corrente.
Metodo pubblico | GetAllowedStates | Restiutuisce la lista di tutti gli stati possibili a partire da quello passato.
Metodo pubblico | GetAllUserDestinationStates | Restituisce la lista di tutti gli stati possbili di destinazione della configurazione corrente impostabili dall'utente.
Metodo pubblico | GetPublishAction | Restituisce l'azione da compiere sui documenti nel passaggio di stato richiesto.
Metodo pubblico | IsAllowed | Restituisce true se il passaggio di stato è ammesso. Altrimenti false.
Metodo pubblico | IsReserved | Restituisce true se il passaggio di stato è riservato. Altrimenti false.
Metodo pubblico | IsUserAllowed | Restituisce true se il passaggio di stato è ammesso se azionato da un comando utente. Altrimenti false.
Metodo pubblico | NeedChildrenCheck | Restituisce vero se il passaggio di stato richiede il controllo dello stato dei figli
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedStateFlowTransactions

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedStateFlowTransactions()
Public Sub New
public:
DedStateFlowTransactions()
new : unit -> DedStateFlowTransactions
Vedi anche

Documentazione

Classe DedStateFlowTransactions
Namespace DedNet.Core


Metodi di DedStateFlowTransactions

Il tipo DedStateFlowTransactions espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Add | Metodo per aggiungere un flusso nel dizionario.
Metodo pubblico | DefaultCheckStatusOnMultipleOpearations | Restituisce vero se il passaggio di stato richiede il controllo dello stato dei figli
Metodo pubblico | GetAllInvolvedStates | Restituisce la lista di tutti gli stati coinvolti nelle transazione della configurazione corrente.
Metodo pubblico | GetAllInvolvedStates(Int32) | Restituisce la lista di tutti gli stati coinvolti nelle transazione della configurazione corrente.
Metodo pubblico | GetAllowedStates | Restiutuisce la lista di tutti gli stati possibili a partire da quello passato.
Metodo pubblico | GetAllUserDestinationStates | Restituisce la lista di tutti gli stati possbili di destinazione della configurazione corrente impostabili dall'utente.
Metodo pubblico | GetPublishAction | Restituisce l'azione da compiere sui documenti nel passaggio di stato richiesto.
Metodo pubblico | IsAllowed | Restituisce true se il passaggio di stato è ammesso. Altrimenti false.
Metodo pubblico | IsReserved | Restituisce true se il passaggio di stato è riservato. Altrimenti false.
Metodo pubblico | IsUserAllowed | Restituisce true se il passaggio di stato è ammesso se azionato da un comando utente. Altrimenti false.
Metodo pubblico | NeedChildrenCheck | Restituisce vero se il passaggio di stato richiede il controllo dello stato dei figli
Torna su
Vedi anche

Documentazione

Classe DedStateFlowTransactions
Namespace DedNet.Core


Metodo DedStateFlowTransactions.Add

Metodo DedStateFlowTransactionsAdd
Metodo per aggiungere un flusso nel dizionario.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Add(
    DedState stateFrom,
    DedState stateTo,
    DedPubActionEnum pubAction,
    bool reserved,
    bool needChildrenCheck,
    bool defaultCheckStatusOnMultipleOpearations
)
Public Sub Add (
    stateFrom As DedState,
    stateTo As DedState,
    pubAction As DedPubActionEnum,
    reserved As Boolean,
    needChildrenCheck As Boolean,
    defaultCheckStatusOnMultipleOpearations As Boolean
)
public:
void Add(
    DedState^ stateFrom,
    DedState^ stateTo,
    DedPubActionEnum pubAction,
    bool reserved,
    bool needChildrenCheck,
    bool defaultCheckStatusOnMultipleOpearations
)
member Add :
        stateFrom : DedState *
        stateTo : DedState *
        pubAction : DedPubActionEnum *
        reserved : bool *
        needChildrenCheck : bool *
        defaultCheckStatusOnMultipleOpearations : bool -> unit

Parametri

stateFrom DedState
Stato di partenza.
stateTo DedState
Stato di arrivo.
pubAction DedPubActionEnum
Enum per difinire l'azione sui documenti in pubblicazione.
reserved Boolean
Indica se il passaggio di stato è riservato
needChildrenCheck Boolean
Indica se è necessario un controllo sui filgi
defaultCheckStatusOnMultipleOpearations Boolean
Indica lo stato di default del check nelle operazioni multiple
Vedi anche

Documentazione

Classe DedStateFlowTransactions
Namespace DedNet.Core


Metodo DedStateFlowTransactions.DefaultCheckStatusOnMultipleOpearations

Metodo DedStateFlowTransactionsDefaultCheckStatusOnMultipleOpearations
Restituisce vero se il passaggio di stato richiede il controllo dello stato dei figli

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool DefaultCheckStatusOnMultipleOpearations(
    DedState stateFrom,
    DedState stateTo
)
Public Function DefaultCheckStatusOnMultipleOpearations (
    stateFrom As DedState,
    stateTo As DedState
) As Boolean
public:
bool DefaultCheckStatusOnMultipleOpearations(
    DedState^ stateFrom,
    DedState^ stateTo
)
member DefaultCheckStatusOnMultipleOpearations :
        stateFrom : DedState *
        stateTo : DedState -> bool

Parametri

stateFrom DedState
Stato di patenza.
stateTo DedState
Stato di arrivo.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedStateFlowTransactions
Namespace DedNet.Core


Metodo DedStateFlowTransactions.GetAllInvolvedStates

Metodo DedStateFlowTransactionsGetAllInvolvedStates
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | GetAllInvolvedStates | Restituisce la lista di tutti gli stati coinvolti nelle transazione della configurazione corrente.
Metodo pubblico | GetAllInvolvedStates(Int32) | Restituisce la lista di tutti gli stati coinvolti nelle transazione della configurazione corrente.
Torna su
Vedi anche

Documentazione

Classe DedStateFlowTransactions
Namespace DedNet.Core


Metodo DedStateFlowTransactions.GetAllInvolvedStates

Metodo DedStateFlowTransactionsGetAllInvolvedStates
Restituisce la lista di tutti gli stati coinvolti nelle transazione della configurazione corrente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedStateList GetAllInvolvedStates()
Public Function GetAllInvolvedStates As DedStateList
public:
DedStateList^ GetAllInvolvedStates()
member GetAllInvolvedStates : unit -> DedStateList

Valore di ritorno

DedStateList
Vedi anche

Documentazione

Classe DedStateFlowTransactions
Overload di GetAllInvolvedStates
Namespace DedNet.Core


Metodo DedStateFlowTransactions.GetAllInvolvedStates(Int32)

Metodo DedStateFlowTransactionsGetAllInvolvedStates(Int32)
Restituisce la lista di tutti gli stati coinvolti nelle transazione della configurazione corrente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedStateList GetAllInvolvedStates(
    int categoryId
)
Public Function GetAllInvolvedStates (
    categoryId As Integer
) As DedStateList
public:
DedStateList^ GetAllInvolvedStates(
    int categoryId
)
member GetAllInvolvedStates :
        categoryId : int -> DedStateList

Parametri

categoryId Int32

Valore di ritorno

DedStateList
Vedi anche

Documentazione

Classe DedStateFlowTransactions
Overload di GetAllInvolvedStates
Namespace DedNet.Core


Metodo DedStateFlowTransactions.GetAllowedStates

Metodo DedStateFlowTransactionsGetAllowedStates
Restiutuisce la lista di tutti gli stati possibili a partire da quello passato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedStateList GetAllowedStates(
    DedState stateFrom,
    bool includeReserved = true
)
Public Function GetAllowedStates (
    stateFrom As DedState,
    Optional includeReserved As Boolean = true
) As DedStateList
public:
DedStateList^ GetAllowedStates(
    DedState^ stateFrom,
    bool includeReserved = true
)
member GetAllowedStates :
        stateFrom : DedState *
        ?includeReserved : bool
(* Defaults:
        let _includeReserved = defaultArg includeReserved true
*)
-> DedStateList

Parametri

stateFrom DedState
Stato di partenza.
includeReserved Boolean (Optional)

Valore di ritorno

DedStateList
Vedi anche

Documentazione

Classe DedStateFlowTransactions
Namespace DedNet.Core


Metodo DedStateFlowTransactions.GetAllUserDestinationStates

Metodo DedStateFlowTransactionsGetAllUserDestinationStates
Restituisce la lista di tutti gli stati possbili di destinazione della configurazione corrente impostabili dall'utente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedStateList GetAllUserDestinationStates()
Public Function GetAllUserDestinationStates As DedStateList
public:
DedStateList^ GetAllUserDestinationStates()
member GetAllUserDestinationStates : unit -> DedStateList

Valore di ritorno

DedStateList
Vedi anche

Documentazione

Classe DedStateFlowTransactions
Namespace DedNet.Core


Metodo DedStateFlowTransactions.GetPublishAction

Metodo DedStateFlowTransactionsGetPublishAction
Restituisce l'azione da compiere sui documenti nel passaggio di stato richiesto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedPubActionEnum GetPublishAction(
    DedState stateFrom,
    DedState stateTo
)
Public Function GetPublishAction (
    stateFrom As DedState,
    stateTo As DedState
) As DedPubActionEnum
public:
DedPubActionEnum GetPublishAction(
    DedState^ stateFrom,
    DedState^ stateTo
)
member GetPublishAction :
        stateFrom : DedState *
        stateTo : DedState -> DedPubActionEnum

Parametri

stateFrom DedState
Stato di patenza.
stateTo DedState
Stato di arrivo.

Valore di ritorno

DedPubActionEnum
Vedi anche

Documentazione

Classe DedStateFlowTransactions
Namespace DedNet.Core


Metodo DedStateFlowTransactions.IsAllowed

Metodo DedStateFlowTransactionsIsAllowed
Restituisce true se il passaggio di stato è ammesso. Altrimenti false.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsAllowed(
    DedState stateFrom,
    DedState stateTo
)
Public Function IsAllowed (
    stateFrom As DedState,
    stateTo As DedState
) As Boolean
public:
bool IsAllowed(
    DedState^ stateFrom,
    DedState^ stateTo
)
member IsAllowed :
        stateFrom : DedState *
        stateTo : DedState -> bool

Parametri

stateFrom DedState
Stato di partenza.
stateTo DedState
Stato di arrivo.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedStateFlowTransactions
Namespace DedNet.Core


Metodo DedStateFlowTransactions.IsReserved

Metodo DedStateFlowTransactionsIsReserved
Restituisce true se il passaggio di stato è riservato. Altrimenti false.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsReserved(
    DedState stateFrom,
    DedState stateTo
)
Public Function IsReserved (
    stateFrom As DedState,
    stateTo As DedState
) As Boolean
public:
bool IsReserved(
    DedState^ stateFrom,
    DedState^ stateTo
)
member IsReserved :
        stateFrom : DedState *
        stateTo : DedState -> bool

Parametri

stateFrom DedState
Stato di partenza.
stateTo DedState
Stato di arrivo.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedStateFlowTransactions
Namespace DedNet.Core


Metodo DedStateFlowTransactions.IsUserAllowed

Metodo DedStateFlowTransactionsIsUserAllowed
Restituisce true se il passaggio di stato è ammesso se azionato da un comando utente. Altrimenti false.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsUserAllowed(
    DedState stateFrom,
    DedState stateTo
)
Public Function IsUserAllowed (
    stateFrom As DedState,
    stateTo As DedState
) As Boolean
public:
bool IsUserAllowed(
    DedState^ stateFrom,
    DedState^ stateTo
)
member IsUserAllowed :
        stateFrom : DedState *
        stateTo : DedState -> bool

Parametri

stateFrom DedState
Stato di partenza.
stateTo DedState
Stato di arrivo.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedStateFlowTransactions
Namespace DedNet.Core


Metodo DedStateFlowTransactions.NeedChildrenCheck

Metodo DedStateFlowTransactionsNeedChildrenCheck
Restituisce vero se il passaggio di stato richiede il controllo dello stato dei figli

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool NeedChildrenCheck(
    DedState stateFrom,
    DedState stateTo
)
Public Function NeedChildrenCheck (
    stateFrom As DedState,
    stateTo As DedState
) As Boolean
public:
bool NeedChildrenCheck(
    DedState^ stateFrom,
    DedState^ stateTo
)
member NeedChildrenCheck :
        stateFrom : DedState *
        stateTo : DedState -> bool

Parametri

stateFrom DedState
Stato di patenza.
stateTo DedState
Stato di arrivo.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedStateFlowTransactions
Namespace DedNet.Core


Classe DedStateList
Lista di oggetti di tipo DedState.
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList DedState
DedNet.CoreDedStateList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedStateList : List<DedState>
Public Class DedStateList
    Inherits List(Of DedState)
public ref class DedStateList : public List<DedState^>
type DedStateList =
    class
        inherit List<DedState>
    end

Il tipo DedStateList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedStateList |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | FindById | Restituisce lo stato con id passato. Restiruisce null se non esiste.
Metodo pubblico | FindByName | Restituisce lo stato con nome passato. Restiruisce null se non esiste.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedStateList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedStateList()
Public Sub New
public:
DedStateList()
new : unit -> DedStateList
Vedi anche

Documentazione

Classe DedStateList
Namespace DedNet.Core


Metodi di DedStateList

Il tipo DedStateList espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | FindById | Restituisce lo stato con id passato. Restiruisce null se non esiste.
Metodo pubblico | FindByName | Restituisce lo stato con nome passato. Restiruisce null se non esiste.
Torna su
Vedi anche

Documentazione

Classe DedStateList
Namespace DedNet.Core


Metodo DedStateList.FindById

Metodo DedStateListFindById
Restituisce lo stato con id passato. Restiruisce null se non esiste.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedState FindById(
    int id
)
Public Function FindById (
    id As Integer
) As DedState
public:
DedState^ FindById(
    int id
)
member FindById :
        id : int -> DedState

Parametri

id Int32
Id stato da ricercare

Valore di ritorno

DedState
Vedi anche

Documentazione

Classe DedStateList
Namespace DedNet.Core


Metodo DedStateList.FindByName

Metodo DedStateListFindByName
Restituisce lo stato con nome passato. Restiruisce null se non esiste.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedState FindByName(
    string nome
)
Public Function FindByName (
    nome As String
) As DedState
public:
DedState^ FindByName(
    String^ nome
)
member FindByName :
        nome : string -> DedState

Parametri

nome String

Valore di ritorno

DedState
Vedi anche

Documentazione

Classe DedStateList
Namespace DedNet.Core


Classe DedStateManager
Ha il compito di gestire gli stati dal Database.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedStateManager

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedStateManager
Public Class DedStateManager
public ref class DedStateManager
type DedStateManager = class end

Il tipo DedStateManager espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | InvolvedNameStates |
Proprietà pubblica | IsActiveStandardConfig | Restituisce true se la confuigurazione attiva è quella standard.
Proprietà pubblica | StateCategList | Lista delle categorie
Proprietà pubblica | StateConfList | Lista delle configurazioni
Proprietà pubblica | StateFlowTrans | Oggetto per la gestione del flusso degli stati della configurazione attiva.
Proprietà pubblica | StateList | Lista degli stati
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | GetDefaultUnchangeableState | Restituisce lo stato unchangeable di default (tipicamente OBSOLETO).
Metodo pubblico | GetErasedState | Restituisce lo stato univoco associato alla categoria ERASED. Consideriamo lo stato appartenente a questa categoria sempre come univoco.
Metodo pubblico | GetOutOfDateState | Restituisce lo stato univoco associato alla categoria OUTOFDATE. Consideriamo lo stato appartenente a questa categoria sempre come univoco.
Metodo pubblico | GetStartingState | Restiutuisce lo stato iniziale per una nuova anagrafica.
Metodo pubblico | GetStatesByCategory | Restituisce gli stati della categoria passata
Metodo pubblico | GetWorkingState | Restituisce lo stato di destinazione in lavorazione raggiungibile dallo stato passato. Se non è raggiungibile restituisce null.
Metodo pubblico | GetWritableOutOfDateState | Restituisce lo stato univoco associato alla categoria WRITABLE OUTOFDATE. Consideriamo lo stato appartenente a questa categoria sempre come univoco.
Metodo pubblico | IsApprovedOrPendingApprovalState | Restituisce true se lo stato è di categoria PENDING_APPROVAL o APPROVED
Metodo pubblico | IsApprovedState | Restituisce true se lo stato è di categoria APPROVED
Metodo pubblico | IsErasedState | Restituisce true se lo stato è di categoria ERASED
Metodo pubblico | IsModifyingOutOfDateState | Restituisce true se lo stato è di categoria UNDER_CORRECTION
Metodo pubblico | IsOutOfDateState | Restituisce true se lo stato è di categoria OUTOFDATE Consideriamo lo stato appartenente a questa categoria sempre come univoco.
Metodo pubblico | IsOutOfDateStateOrWritableOutOfDateState | Restituisce true se lo stato è di categoria OUTOFDATE o MODIFYING OUTOFDATE Consideriamo lo stato appartenente a questa categoria sempre come univoco.
Metodo pubblico | IsPendingApprovalState | Restituisce true se lo stato è di categoria PENDING_APPROVAL
Metodo pubblico | IsReadOnlyState | Restiutuisce se lo stato è in sola lettura.
Metodo pubblico | IsUnchangeableState | Restituisce true se lo stato è di categoria UNCHANGEABLE
Metodo pubblico | IsWorkingState | Restituisce true se lo stato è di categoria WORKING
Metodo pubblico | IsWritableOutOfDateState | Restituisce true se lo stato è di categoria WRITABLE OUTOFDATE Consideriamo lo stato appartenente a questa categoria sempre come univoco.
Metodo pubblico | IsWritableState | Restiutuisce se lo stato è scrivibile.
Torna su
Campi
Nome | Descrizione
CATEGORY_APPROVED |
CATEGORY_ERASED |
CATEGORY_MODIFYING_OUTOFDATE |
CATEGORY_OUTOFDATE |
CATEGORY_PENDING_APPROVAL |
CATEGORY_UNCHANGEABLE |
CATEGORY_WORKING |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di DedStateManager

Il tipo DedStateManager espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | InvolvedNameStates |
Proprietà pubblica | IsActiveStandardConfig | Restituisce true se la confuigurazione attiva è quella standard.
Proprietà pubblica | StateCategList | Lista delle categorie
Proprietà pubblica | StateConfList | Lista delle configurazioni
Proprietà pubblica | StateFlowTrans | Oggetto per la gestione del flusso degli stati della configurazione attiva.
Proprietà pubblica | StateList | Lista degli stati
Torna su
Vedi anche

Documentazione

Classe DedStateManager
Namespace DedNet.Core


Proprietà DedStateManager.InvolvedNameStates

Proprietà DedStateManagerInvolvedNameStates

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> InvolvedNameStates { get; }
Public ReadOnly Property InvolvedNameStates As List(Of String)
    Get
public:
property List<String^>^ InvolvedNameStates {
    List<String^>^ get ();
}
member InvolvedNameStates : List<string> with get

Valore della proprietà

List String
Vedi anche

Documentazione

Classe DedStateManager
Namespace DedNet.Core


Proprietà DedStateManager.IsActiveStandardConfig

Proprietà DedStateManagerIsActiveStandardConfig
Restituisce true se la confuigurazione attiva è quella standard.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsActiveStandardConfig { get; }
Public ReadOnly Property IsActiveStandardConfig As Boolean
    Get
public:
property bool IsActiveStandardConfig {
    bool get ();
}
member IsActiveStandardConfig : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedStateManager
Namespace DedNet.Core


Proprietà DedStateManager.StateCategList

Proprietà DedStateManagerStateCategList
Lista delle categorie

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedStateCategoryList StateCategList { get; }
Public ReadOnly Property StateCategList As DedStateCategoryList
    Get
public:
property DedStateCategoryList^ StateCategList {
    DedStateCategoryList^ get ();
}
member StateCategList : DedStateCategoryList with get

Valore della proprietà

DedStateCategoryList
Vedi anche

Documentazione

Classe DedStateManager
Namespace DedNet.Core


Proprietà DedStateManager.StateConfList

Proprietà DedStateManagerStateConfList
Lista delle configurazioni

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedStateConfigurationList StateConfList { get; }
Public ReadOnly Property StateConfList As DedStateConfigurationList
    Get
public:
property DedStateConfigurationList^ StateConfList {
    DedStateConfigurationList^ get ();
}
member StateConfList : DedStateConfigurationList with get

Valore della proprietà

DedStateConfigurationList
Vedi anche

Documentazione

Classe DedStateManager
Namespace DedNet.Core


Proprietà DedStateManager.StateFlowTrans

Proprietà DedStateManagerStateFlowTrans
Oggetto per la gestione del flusso degli stati della configurazione attiva.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedStateFlowTransactions StateFlowTrans { get; }
Public ReadOnly Property StateFlowTrans As DedStateFlowTransactions
    Get
public:
property DedStateFlowTransactions^ StateFlowTrans {
    DedStateFlowTransactions^ get ();
}
member StateFlowTrans : DedStateFlowTransactions with get

Valore della proprietà

DedStateFlowTransactions
Vedi anche

Documentazione

Classe DedStateManager
Namespace DedNet.Core


Proprietà DedStateManager.StateList

Proprietà DedStateManagerStateList
Lista degli stati

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedStateList StateList { get; }
Public ReadOnly Property StateList As DedStateList
    Get
public:
property DedStateList^ StateList {
    DedStateList^ get ();
}
member StateList : DedStateList with get

Valore della proprietà

DedStateList
Vedi anche

Documentazione

Classe DedStateManager
Namespace DedNet.Core


Metodi di DedStateManager

Il tipo DedStateManager espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | GetDefaultUnchangeableState | Restituisce lo stato unchangeable di default (tipicamente OBSOLETO).
Metodo pubblico | GetErasedState | Restituisce lo stato univoco associato alla categoria ERASED. Consideriamo lo stato appartenente a questa categoria sempre come univoco.
Metodo pubblico | GetOutOfDateState | Restituisce lo stato univoco associato alla categoria OUTOFDATE. Consideriamo lo stato appartenente a questa categoria sempre come univoco.
Metodo pubblico | GetStartingState | Restiutuisce lo stato iniziale per una nuova anagrafica.
Metodo pubblico | GetStatesByCategory | Restituisce gli stati della categoria passata
Metodo pubblico | GetWorkingState | Restituisce lo stato di destinazione in lavorazione raggiungibile dallo stato passato. Se non è raggiungibile restituisce null.
Metodo pubblico | GetWritableOutOfDateState | Restituisce lo stato univoco associato alla categoria WRITABLE OUTOFDATE. Consideriamo lo stato appartenente a questa categoria sempre come univoco.
Metodo pubblico | IsApprovedOrPendingApprovalState | Restituisce true se lo stato è di categoria PENDING_APPROVAL o APPROVED
Metodo pubblico | IsApprovedState | Restituisce true se lo stato è di categoria APPROVED
Metodo pubblico | IsErasedState | Restituisce true se lo stato è di categoria ERASED
Metodo pubblico | IsModifyingOutOfDateState | Restituisce true se lo stato è di categoria UNDER_CORRECTION
Metodo pubblico | IsOutOfDateState | Restituisce true se lo stato è di categoria OUTOFDATE Consideriamo lo stato appartenente a questa categoria sempre come univoco.
Metodo pubblico | IsOutOfDateStateOrWritableOutOfDateState | Restituisce true se lo stato è di categoria OUTOFDATE o MODIFYING OUTOFDATE Consideriamo lo stato appartenente a questa categoria sempre come univoco.
Metodo pubblico | IsPendingApprovalState | Restituisce true se lo stato è di categoria PENDING_APPROVAL
Metodo pubblico | IsReadOnlyState | Restiutuisce se lo stato è in sola lettura.
Metodo pubblico | IsUnchangeableState | Restituisce true se lo stato è di categoria UNCHANGEABLE
Metodo pubblico | IsWorkingState | Restituisce true se lo stato è di categoria WORKING
Metodo pubblico | IsWritableOutOfDateState | Restituisce true se lo stato è di categoria WRITABLE OUTOFDATE Consideriamo lo stato appartenente a questa categoria sempre come univoco.
Metodo pubblico | IsWritableState | Restiutuisce se lo stato è scrivibile.
Torna su
Vedi anche

Documentazione

Classe DedStateManager
Namespace DedNet.Core


Metodo DedStateManager.GetDefaultUnchangeableState

Metodo DedStateManagerGetDefaultUnchangeableState
Restituisce lo stato unchangeable di default (tipicamente OBSOLETO).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedState GetDefaultUnchangeableState()
Public Function GetDefaultUnchangeableState As DedState
public:
DedState^ GetDefaultUnchangeableState()
member GetDefaultUnchangeableState : unit -> DedState

Valore di ritorno

DedState
Vedi anche

Documentazione

Classe DedStateManager
Namespace DedNet.Core


Metodo DedStateManager.GetErasedState

Metodo DedStateManagerGetErasedState
Restituisce lo stato univoco associato alla categoria ERASED. Consideriamo lo stato appartenente a questa categoria sempre come univoco.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedState GetErasedState()
Public Function GetErasedState As DedState
public:
DedState^ GetErasedState()
member GetErasedState : unit -> DedState

Valore di ritorno

DedState
Vedi anche

Documentazione

Classe DedStateManager
Namespace DedNet.Core


Metodo DedStateManager.GetOutOfDateState

Metodo DedStateManagerGetOutOfDateState
Restituisce lo stato univoco associato alla categoria OUTOFDATE. Consideriamo lo stato appartenente a questa categoria sempre come univoco.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedState GetOutOfDateState()
Public Function GetOutOfDateState As DedState
public:
DedState^ GetOutOfDateState()
member GetOutOfDateState : unit -> DedState

Valore di ritorno

DedState
Vedi anche

Documentazione

Classe DedStateManager
Namespace DedNet.Core


Metodo DedStateManager.GetStartingState

Metodo DedStateManagerGetStartingState
Restiutuisce lo stato iniziale per una nuova anagrafica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedState GetStartingState()
Public Function GetStartingState As DedState
public:
DedState^ GetStartingState()
member GetStartingState : unit -> DedState

Valore di ritorno

DedState
Vedi anche

Documentazione

Classe DedStateManager
Namespace DedNet.Core


Metodo DedStateManager.GetStatesByCategory

Metodo DedStateManagerGetStatesByCategory
Restituisce gli stati della categoria passata

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedStateList GetStatesByCategory(
    string categoryName
)
Public Function GetStatesByCategory (
    categoryName As String
) As DedStateList
public:
DedStateList^ GetStatesByCategory(
    String^ categoryName
)
member GetStatesByCategory :
        categoryName : string -> DedStateList

Parametri

categoryName String
Categoria da ricercare.

Valore di ritorno

DedStateList
Vedi anche

Documentazione

Classe DedStateManager
Namespace DedNet.Core


Metodo DedStateManager.GetWorkingState

Metodo DedStateManagerGetWorkingState
Restituisce lo stato di destinazione in lavorazione raggiungibile dallo stato passato. Se non è raggiungibile restituisce null.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedState GetWorkingState(
    DedState startState
)
Public Function GetWorkingState (
    startState As DedState
) As DedState
public:
DedState^ GetWorkingState(
    DedState^ startState
)
member GetWorkingState :
        startState : DedState -> DedState

Parametri

startState DedState
Stato di partenza

Valore di ritorno

DedState
Vedi anche

Documentazione

Classe DedStateManager
Namespace DedNet.Core


Metodo DedStateManager.GetWritableOutOfDateState

Metodo DedStateManagerGetWritableOutOfDateState
Restituisce lo stato univoco associato alla categoria WRITABLE OUTOFDATE. Consideriamo lo stato appartenente a questa categoria sempre come univoco.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedState GetWritableOutOfDateState()
Public Function GetWritableOutOfDateState As DedState
public:
DedState^ GetWritableOutOfDateState()
member GetWritableOutOfDateState : unit -> DedState

Valore di ritorno

DedState
Vedi anche

Documentazione

Classe DedStateManager
Namespace DedNet.Core


Metodo DedStateManager.IsApprovedOrPendingApprovalState

Metodo DedStateManagerIsApprovedOrPendingApprovalState
Restituisce true se lo stato è di categoria PENDING_APPROVAL o APPROVED

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsApprovedOrPendingApprovalState(
    DedState state
)
Public Function IsApprovedOrPendingApprovalState (
    state As DedState
) As Boolean
public:
bool IsApprovedOrPendingApprovalState(
    DedState^ state
)
member IsApprovedOrPendingApprovalState :
        state : DedState -> bool

Parametri

state DedState

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedStateManager
Namespace DedNet.Core


Metodo DedStateManager.IsApprovedState

Metodo DedStateManagerIsApprovedState
Restituisce true se lo stato è di categoria APPROVED

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsApprovedState(
    DedState state
)
Public Function IsApprovedState (
    state As DedState
) As Boolean
public:
bool IsApprovedState(
    DedState^ state
)
member IsApprovedState :
        state : DedState -> bool

Parametri

state DedState

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedStateManager
Namespace DedNet.Core


Metodo DedStateManager.IsErasedState

Metodo DedStateManagerIsErasedState
Restituisce true se lo stato è di categoria ERASED

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsErasedState(
    DedState state
)
Public Function IsErasedState (
    state As DedState
) As Boolean
public:
bool IsErasedState(
    DedState^ state
)
member IsErasedState :
        state : DedState -> bool

Parametri

state DedState

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedStateManager
Namespace DedNet.Core


Metodo DedStateManager.IsModifyingOutOfDateState

Metodo DedStateManagerIsModifyingOutOfDateState
Restituisce true se lo stato è di categoria UNDER_CORRECTION

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsModifyingOutOfDateState(
    DedState state
)
Public Function IsModifyingOutOfDateState (
    state As DedState
) As Boolean
public:
bool IsModifyingOutOfDateState(
    DedState^ state
)
member IsModifyingOutOfDateState :
        state : DedState -> bool

Parametri

state DedState

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedStateManager
Namespace DedNet.Core


Metodo DedStateManager.IsOutOfDateState

Metodo DedStateManagerIsOutOfDateState
Restituisce true se lo stato è di categoria OUTOFDATE Consideriamo lo stato appartenente a questa categoria sempre come univoco.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsOutOfDateState(
    DedState state
)
Public Function IsOutOfDateState (
    state As DedState
) As Boolean
public:
bool IsOutOfDateState(
    DedState^ state
)
member IsOutOfDateState :
        state : DedState -> bool

Parametri

state DedState

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedStateManager
Namespace DedNet.Core


Metodo DedStateManager.IsOutOfDateStateOrWritableOutOfDateState

Metodo DedStateManagerIsOutOfDateStateOrWritableOutOfDateState
Restituisce true se lo stato è di categoria OUTOFDATE o MODIFYING OUTOFDATE Consideriamo lo stato appartenente a questa categoria sempre come univoco.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsOutOfDateStateOrWritableOutOfDateState(
    DedState state
)
Public Function IsOutOfDateStateOrWritableOutOfDateState (
    state As DedState
) As Boolean
public:
bool IsOutOfDateStateOrWritableOutOfDateState(
    DedState^ state
)
member IsOutOfDateStateOrWritableOutOfDateState :
        state : DedState -> bool

Parametri

state DedState

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedStateManager
Namespace DedNet.Core


Metodo DedStateManager.IsPendingApprovalState

Metodo DedStateManagerIsPendingApprovalState
Restituisce true se lo stato è di categoria PENDING_APPROVAL

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsPendingApprovalState(
    DedState state
)
Public Function IsPendingApprovalState (
    state As DedState
) As Boolean
public:
bool IsPendingApprovalState(
    DedState^ state
)
member IsPendingApprovalState :
        state : DedState -> bool

Parametri

state DedState

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedStateManager
Namespace DedNet.Core


Metodo DedStateManager.IsReadOnlyState

Metodo DedStateManagerIsReadOnlyState
Restiutuisce se lo stato è in sola lettura.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsReadOnlyState(
    DedState state
)
Public Function IsReadOnlyState (
    state As DedState
) As Boolean
public:
bool IsReadOnlyState(
    DedState^ state
)
member IsReadOnlyState :
        state : DedState -> bool

Parametri

state DedState

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedStateManager
Namespace DedNet.Core


Metodo DedStateManager.IsUnchangeableState

Metodo DedStateManagerIsUnchangeableState
Restituisce true se lo stato è di categoria UNCHANGEABLE

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsUnchangeableState(
    DedState state
)
Public Function IsUnchangeableState (
    state As DedState
) As Boolean
public:
bool IsUnchangeableState(
    DedState^ state
)
member IsUnchangeableState :
        state : DedState -> bool

Parametri

state DedState

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedStateManager
Namespace DedNet.Core


Metodo DedStateManager.IsWorkingState

Metodo DedStateManagerIsWorkingState
Restituisce true se lo stato è di categoria WORKING

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsWorkingState(
    DedState state
)
Public Function IsWorkingState (
    state As DedState
) As Boolean
public:
bool IsWorkingState(
    DedState^ state
)
member IsWorkingState :
        state : DedState -> bool

Parametri

state DedState

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedStateManager
Namespace DedNet.Core


Metodo DedStateManager.IsWritableOutOfDateState

Metodo DedStateManagerIsWritableOutOfDateState
Restituisce true se lo stato è di categoria WRITABLE OUTOFDATE Consideriamo lo stato appartenente a questa categoria sempre come univoco.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsWritableOutOfDateState(
    DedState state
)
Public Function IsWritableOutOfDateState (
    state As DedState
) As Boolean
public:
bool IsWritableOutOfDateState(
    DedState^ state
)
member IsWritableOutOfDateState :
        state : DedState -> bool

Parametri

state DedState

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedStateManager
Namespace DedNet.Core


Metodo DedStateManager.IsWritableState

Metodo DedStateManagerIsWritableState
Restiutuisce se lo stato è scrivibile.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsWritableState(
    DedState state
)
Public Function IsWritableState (
    state As DedState
) As Boolean
public:
bool IsWritableState(
    DedState^ state
)
member IsWritableState :
        state : DedState -> bool

Parametri

state DedState

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedStateManager
Namespace DedNet.Core


Campi di DedStateManager

Il tipo DedStateManager espone i seguenti membri.

Campi
Nome | Descrizione
CATEGORY_APPROVED |
CATEGORY_ERASED |
CATEGORY_MODIFYING_OUTOFDATE |
CATEGORY_OUTOFDATE |
CATEGORY_PENDING_APPROVAL |
CATEGORY_UNCHANGEABLE |
CATEGORY_WORKING |
Torna su
Vedi anche

Documentazione

Classe DedStateManager
Namespace DedNet.Core


Campo DedStateManager.CATEGORY_APPROVED

Campo DedStateManagerCATEGORY_APPROVED

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string CATEGORY_APPROVED = "APPROVED"
Public Const CATEGORY_APPROVED As String = "APPROVED"
public:
literal String^ CATEGORY_APPROVED = "APPROVED"
static val mutable CATEGORY_APPROVED: string

Valore del campo

String
Vedi anche

Documentazione

Classe DedStateManager
Namespace DedNet.Core


Campo DedStateManager.CATEGORY_ERASED

Campo DedStateManagerCATEGORY_ERASED

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string CATEGORY_ERASED = "ERASED"
Public Const CATEGORY_ERASED As String = "ERASED"
public:
literal String^ CATEGORY_ERASED = "ERASED"
static val mutable CATEGORY_ERASED: string

Valore del campo

String
Vedi anche

Documentazione

Classe DedStateManager
Namespace DedNet.Core


Campo DedStateManager.CATEGORY_MODIFYING_OUTOFDATE

Campo DedStateManagerCATEGORY_MODIFYING_OUTOFDATE

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string CATEGORY_MODIFYING_OUTOFDATE = "MODIFYING OUTOFDATE"
Public Const CATEGORY_MODIFYING_OUTOFDATE As String = "MODIFYING OUTOFDATE"
public:
literal String^ CATEGORY_MODIFYING_OUTOFDATE = "MODIFYING OUTOFDATE"
static val mutable CATEGORY_MODIFYING_OUTOFDATE: string

Valore del campo

String
Vedi anche

Documentazione

Classe DedStateManager
Namespace DedNet.Core


Campo DedStateManager.CATEGORY_OUTOFDATE

Campo DedStateManagerCATEGORY_OUTOFDATE

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string CATEGORY_OUTOFDATE = "OUTOFDATE"
Public Const CATEGORY_OUTOFDATE As String = "OUTOFDATE"
public:
literal String^ CATEGORY_OUTOFDATE = "OUTOFDATE"
static val mutable CATEGORY_OUTOFDATE: string

Valore del campo

String
Vedi anche

Documentazione

Classe DedStateManager
Namespace DedNet.Core


Campo DedStateManager.CATEGORY_PENDING_APPROVAL

Campo DedStateManagerCATEGORY_PENDING_APPROVAL

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string CATEGORY_PENDING_APPROVAL = "PENDING APPROVAL"
Public Const CATEGORY_PENDING_APPROVAL As String = "PENDING APPROVAL"
public:
literal String^ CATEGORY_PENDING_APPROVAL = "PENDING APPROVAL"
static val mutable CATEGORY_PENDING_APPROVAL: string

Valore del campo

String
Vedi anche

Documentazione

Classe DedStateManager
Namespace DedNet.Core


Campo DedStateManager.CATEGORY_UNCHANGEABLE

Campo DedStateManagerCATEGORY_UNCHANGEABLE

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string CATEGORY_UNCHANGEABLE = "UNCHANGEABLE"
Public Const CATEGORY_UNCHANGEABLE As String = "UNCHANGEABLE"
public:
literal String^ CATEGORY_UNCHANGEABLE = "UNCHANGEABLE"
static val mutable CATEGORY_UNCHANGEABLE: string

Valore del campo

String
Vedi anche

Documentazione

Classe DedStateManager
Namespace DedNet.Core


Campo DedStateManager.CATEGORY_WORKING

Campo DedStateManagerCATEGORY_WORKING

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string CATEGORY_WORKING = "WORKING"
Public Const CATEGORY_WORKING As String = "WORKING"
public:
literal String^ CATEGORY_WORKING = "WORKING"
static val mutable CATEGORY_WORKING: string

Valore del campo

String
Vedi anche

Documentazione

Classe DedStateManager
Namespace DedNet.Core


Classe DedStringPermDiz
Dizionario dei permessi specifici, indicizzato tramite stringa (tipo di oggetto), stringa (nome oggetto), Permesso. Serve per l'abbinamento dei permessi al DbPath delle famiglie.
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericDictionary String, Dictionary String, UsrPermDiz
DedNet.CoreDedStringPermDiz

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedStringPermDiz : Dictionary<string, Dictionary<string, UsrPermDiz>>
Public Class DedStringPermDiz
    Inherits Dictionary(Of String, Dictionary(Of String, UsrPermDiz))
public ref class DedStringPermDiz : public Dictionary<String^, Dictionary<String^, UsrPermDiz^>^>
type DedStringPermDiz =
    class
        inherit Dictionary<string, Dictionary<string, UsrPermDiz>>
    end

Il tipo DedStringPermDiz espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedStringPermDiz |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedStringPermDiz

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedStringPermDiz()
Public Sub New
public:
DedStringPermDiz()
new : unit -> DedStringPermDiz
Vedi anche

Documentazione

Classe DedStringPermDiz
Namespace DedNet.Core


Classe DedTime
Classe utilizzata per gestire le temporizzazioni sui vari elementi.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedBaseDbItem
DedNet.CoreDedEditableObject DedTime
DedNet.CoreDedTime

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedTime : DedEditableObject<DedTime>
Public Class DedTime
    Inherits DedEditableObject(Of DedTime)
public ref class DedTime : public DedEditableObject<DedTime^>
type DedTime =
    class
        inherit DedEditableObject<DedTime>
    end

Il tipo DedTime espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedTime(DedTimeList, DbDataReader) | Crea una nuova istanza della classe 'DedTime' utilizzata per gestire le temporizzazioni sui vari elementi.
Metodo pubblico | DedTime(DedTimeList, DateTime) | Crea una nuova istanza della classe 'DedTime' utilizzata per gestire le temporizzazioni sui vari elementi.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Applicazione DedNet. (Ereditato da DedEditableObjectT)
Proprietà pubblica | DbIndex | GUID, in formato stringa, che identifica in modo univoco l'elemento corrente. (Ereditato da DedEditableObjectT)
Proprietà pubblica | EndTiming | Valore di fine temporizzazione.
Proprietà protetta | Ignoredirty | Dice al metodo SetValue() di non impostare a dirty l'oggetto. (Ereditato da DedEditableObjectT)
Proprietà pubblica | Parent | Lista a cui appartiene l'elemento corrente. (Ereditato da DedEditableObjectT)
Proprietà pubblica | StartTiming | Valore di inizio temporizzazione.
Proprietà pubblica | StatoRecord | Restituisce o imposta lo stato del record. (Ereditato da DedEditableObjectT)
Proprietà pubblica | TimingIsEnded | Ritorna True se la temporizzazione è terminata.
Proprietà pubblica | TimingIsStarted | Ritorna True se la temporizzazione è stata avviata, ma non acora terminata.
Proprietà pubblica | TimingLength | Durata della temporizzazione espressa in ore.
Proprietà pubblica | User | Ritorna il nome interno dell'utente che ha avviato la temporizzazione.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | GetDescription | Restiruisce la descrizione dell'elemento corrente (Ereditato da DedBaseDbItem)
Metodo pubblico | GetName | Restituisce il nome dell'elemento corrente (Ereditato da DedBaseDbItem)
Metodo pubblico | GetObjectType | (Sovrascrive DedBaseDbItemGetObjectType)
Metodo protetto | GetValue | Restituisce il contenuto di uno dei campi oppure null se non è presente. (Ereditato da DedEditableObjectT)
Metodo protetto | ReadData | Imposta i dati nel dizionario dei valori leggendoli dal 'DbDataReader' specificato. (Ereditato da DedEditableObjectT)
Metodo protetto | SetValue | Imposta il contenuto di uno dei campi. (Ereditato da DedEditableObjectT)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedTime
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | DedTime(DedTimeList, DbDataReader) | Crea una nuova istanza della classe 'DedTime' utilizzata per gestire le temporizzazioni sui vari elementi.
Metodo pubblico | DedTime(DedTimeList, DateTime) | Crea una nuova istanza della classe 'DedTime' utilizzata per gestire le temporizzazioni sui vari elementi.
Torna su
Vedi anche

Documentazione

Classe DedTime
Namespace DedNet.Core


Costruttore DedTime(DedTimeList, DbDataReader)
Crea una nuova istanza della classe 'DedTime' utilizzata per gestire le temporizzazioni sui vari elementi.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTime(
    DedTimeList parent,
    DbDataReader reader
)
Public Sub New (
    parent As DedTimeList,
    reader As DbDataReader
)
public:
DedTime(
    DedTimeList^ parent,
    DbDataReader^ reader
)
new :
        parent : DedTimeList *
        reader : DbDataReader -> DedTime

Parametri

parent DedTimeList
reader DbDataReader
Vedi anche

Documentazione

Classe DedTime
Overload di DedTime
Namespace DedNet.Core


Costruttore DedTime(DedTimeList, DateTime)
Crea una nuova istanza della classe 'DedTime' utilizzata per gestire le temporizzazioni sui vari elementi.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTime(
    DedTimeList parent,
    DateTime start
)
Public Sub New (
    parent As DedTimeList,
    start As DateTime
)
public:
DedTime(
    DedTimeList^ parent,
    DateTime start
)
new :
        parent : DedTimeList *
        start : DateTime -> DedTime

Parametri

parent DedTimeList
start DateTime
Vedi anche

Documentazione

Classe DedTime
Overload di DedTime
Namespace DedNet.Core


Proprietà di DedTime

Il tipo DedTime espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Applicazione DedNet. (Ereditato da DedEditableObjectT)
Proprietà pubblica | DbIndex | GUID, in formato stringa, che identifica in modo univoco l'elemento corrente. (Ereditato da DedEditableObjectT)
Proprietà pubblica | EndTiming | Valore di fine temporizzazione.
Proprietà protetta | Ignoredirty | Dice al metodo SetValue() di non impostare a dirty l'oggetto. (Ereditato da DedEditableObjectT)
Proprietà pubblica | Parent | Lista a cui appartiene l'elemento corrente. (Ereditato da DedEditableObjectT)
Proprietà pubblica | StartTiming | Valore di inizio temporizzazione.
Proprietà pubblica | StatoRecord | Restituisce o imposta lo stato del record. (Ereditato da DedEditableObjectT)
Proprietà pubblica | TimingIsEnded | Ritorna True se la temporizzazione è terminata.
Proprietà pubblica | TimingIsStarted | Ritorna True se la temporizzazione è stata avviata, ma non acora terminata.
Proprietà pubblica | TimingLength | Durata della temporizzazione espressa in ore.
Proprietà pubblica | User | Ritorna il nome interno dell'utente che ha avviato la temporizzazione.
Torna su
Vedi anche

Documentazione

Classe DedTime
Namespace DedNet.Core


Proprietà DedTime.EndTiming

Proprietà DedTimeEndTiming
Valore di fine temporizzazione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DateTime EndTiming { get; set; }
Public Property EndTiming As DateTime
    Get
    Set
public:
property DateTime EndTiming {
    DateTime get ();
    void set (DateTime value);
}
member EndTiming : DateTime with get, set

Valore della proprietà

DateTime
Vedi anche

Documentazione

Classe DedTime
Namespace DedNet.Core


Proprietà DedTime.StartTiming

Proprietà DedTimeStartTiming
Valore di inizio temporizzazione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DateTime StartTiming { get; set; }
Public Property StartTiming As DateTime
    Get
    Set
public:
property DateTime StartTiming {
    DateTime get ();
    void set (DateTime value);
}
member StartTiming : DateTime with get, set

Valore della proprietà

DateTime
Vedi anche

Documentazione

Classe DedTime
Namespace DedNet.Core


Proprietà DedTime.TimingIsEnded

Proprietà DedTimeTimingIsEnded
Ritorna True se la temporizzazione è terminata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool TimingIsEnded { get; }
Public ReadOnly Property TimingIsEnded As Boolean
    Get
public:
property bool TimingIsEnded {
    bool get ();
}
member TimingIsEnded : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedTime
Namespace DedNet.Core


Proprietà DedTime.TimingIsStarted

Proprietà DedTimeTimingIsStarted
Ritorna True se la temporizzazione è stata avviata, ma non acora terminata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool TimingIsStarted { get; }
Public ReadOnly Property TimingIsStarted As Boolean
    Get
public:
property bool TimingIsStarted {
    bool get ();
}
member TimingIsStarted : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedTime
Namespace DedNet.Core


Proprietà DedTime.TimingLength

Proprietà DedTimeTimingLength
Durata della temporizzazione espressa in ore.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public double TimingLength { get; }
Public ReadOnly Property TimingLength As Double
    Get
public:
property double TimingLength {
    double get ();
}
member TimingLength : float with get

Valore della proprietà

Double
Vedi anche

Documentazione

Classe DedTime
Namespace DedNet.Core


Proprietà DedTime.User

Proprietà DedTimeUser
Ritorna il nome interno dell'utente che ha avviato la temporizzazione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string User { get; }
Public ReadOnly Property User As String
    Get
public:
property String^ User {
    String^ get ();
}
member User : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedTime
Namespace DedNet.Core


Metodi di DedTime

Il tipo DedTime espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | GetDescription | Restiruisce la descrizione dell'elemento corrente (Ereditato da DedBaseDbItem)
Metodo pubblico | GetName | Restituisce il nome dell'elemento corrente (Ereditato da DedBaseDbItem)
Metodo pubblico | GetObjectType | (Sovrascrive DedBaseDbItemGetObjectType)
Metodo protetto | GetValue | Restituisce il contenuto di uno dei campi oppure null se non è presente. (Ereditato da DedEditableObjectT)
Metodo protetto | ReadData | Imposta i dati nel dizionario dei valori leggendoli dal 'DbDataReader' specificato. (Ereditato da DedEditableObjectT)
Metodo protetto | SetValue | Imposta il contenuto di uno dei campi. (Ereditato da DedEditableObjectT)
Torna su
Vedi anche

Documentazione

Classe DedTime
Namespace DedNet.Core


Metodo DedTime.GetObjectType

Metodo DedTimeGetObjectType

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override DedDbItemType GetObjectType()
Public Overrides Function GetObjectType As DedDbItemType
public:
virtual DedDbItemType GetObjectType() override
abstract GetObjectType : unit -> DedDbItemType
override GetObjectType : unit -> DedDbItemType

Valore di ritorno

DedDbItemType
Vedi anche

Documentazione

Classe DedTime
Namespace DedNet.Core


Classe DedTimedDbItem
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedBaseDbItem
DedNet.CoreDedTimedDbItem
DedNet.CoreDedComm
DedNet.CoreDedData
DedNet.CoreDedEco

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public abstract class DedTimedDbItem : DedBaseDbItem
Public MustInherit Class DedTimedDbItem
    Inherits DedBaseDbItem
public ref class DedTimedDbItem abstract : public DedBaseDbItem
[<AbstractClassAttribute>]
type DedTimedDbItem =
    class
        inherit DedBaseDbItem
    end

Il tipo DedTimedDbItem espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo protetto | DedTimedDbItem |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | DbIndex | GUID, in formato stringa, che identifica in modo univoco l'elemento corrente. (Ereditato da DedBaseDbItem)
Proprietà pubblica | TimeList | Ritorna l'elenco delle temporizzazioni associate a questo elemento.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | GetDescription | Restiruisce la descrizione dell'elemento corrente (Ereditato da DedBaseDbItem)
Metodo pubblico | GetName | Restituisce il nome dell'elemento corrente (Ereditato da DedBaseDbItem)
Metodo pubblico | GetObjectType | Indica la tipologia dell'elemento corrente (Anagrafica, commessa, ECO, ecc..) (Ereditato da DedBaseDbItem)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedTimedDbItem

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected DedTimedDbItem()
Protected Sub New
protected:
DedTimedDbItem()
new : unit -> DedTimedDbItem
Vedi anche

Documentazione

Classe DedTimedDbItem
Namespace DedNet.Core


Proprietà di DedTimedDbItem

Il tipo DedTimedDbItem espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | DbIndex | GUID, in formato stringa, che identifica in modo univoco l'elemento corrente. (Ereditato da DedBaseDbItem)
Proprietà pubblica | TimeList | Ritorna l'elenco delle temporizzazioni associate a questo elemento.
Torna su
Vedi anche

Documentazione

Classe DedTimedDbItem
Namespace DedNet.Core


Proprietà DedTimedDbItem.TimeList

Proprietà DedTimedDbItemTimeList
Ritorna l'elenco delle temporizzazioni associate a questo elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTimeList TimeList { get; }
Public ReadOnly Property TimeList As DedTimeList
    Get
public:
property DedTimeList^ TimeList {
    DedTimeList^ get ();
}
member TimeList : DedTimeList with get

Valore della proprietà

DedTimeList
Vedi anche

Documentazione

Classe DedTimedDbItem
Namespace DedNet.Core


Metodi di DedTimedDbItem

Il tipo DedTimedDbItem espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | GetDescription | Restiruisce la descrizione dell'elemento corrente (Ereditato da DedBaseDbItem)
Metodo pubblico | GetName | Restituisce il nome dell'elemento corrente (Ereditato da DedBaseDbItem)
Metodo pubblico | GetObjectType | Indica la tipologia dell'elemento corrente (Anagrafica, commessa, ECO, ecc..) (Ereditato da DedBaseDbItem)
Torna su
Vedi anche

Documentazione

Classe DedTimedDbItem
Namespace DedNet.Core


Classe DedTimeList
Classe utilizzata per gestire tutte le temporizzazioni di un determinato elemento.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedDbCollectionBase DedTime
DedNet.CoreDedEditableObjectCollection DedTime
DedNet.CoreDedTimeList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedTimeList : DedEditableObjectCollection<DedTime>
Public Class DedTimeList
    Inherits DedEditableObjectCollection(Of DedTime)
public ref class DedTimeList : public DedEditableObjectCollection<DedTime^>
type DedTimeList =
    class
        inherit DedEditableObjectCollection<DedTime>
    end

Il tipo DedTimeList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedTimeList |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllowsDuplicates | Restituisce se siano ammessi duplicati all'interno della lista. Se false viene sollevata una eccezione su tentativo di inserimento duplicati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Application | Restituisce l'oggetto applicazione di appartenza. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Count | Restituisce il numero di elementi presenti. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Dirty | Restituisce se la collezione o uno dei suoi elementi sia stata modificata. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | ErasedItems | Restitusice la lista in sola lettura degli elementi che risultano attualmente cancellati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | LastItem | Restituisce l'ultimo elemento della collezione oppure null se non ci sono elementi. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Parent | Oggetto di cui si vogliono gestire le temporizzazioni. (Ereditato da DedEditableObjectCollectionT)
Proprietà pubblica | RestoreErased | Restituisce se gli elementi cancellati devono essere ripristinati in caso vengano riaggiunti. (Ereditato da DedDbCollectionBaseT)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AddEmpty | Aggiunge una temporizzazione all'elenco. I valori di inizio e fine saranno identici e corrispondono alla data minima possibile fornita dal sistema.
Metodo protetto | AddForClone | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto SENZA MODIFICARNE LO STATO. Le classi derivate potranno utilizzare questo metodo per clonare la collezione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddNewElement | DI USO INTERNO. Aggiunge un elemento alla lista rendendo dirty l'oggetto. L'elemento viene aggiunto con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere un elemento alla lista. Dovranno loro stesse avere un metodo pubblico Add() che prenda i parametri necessari alla costruzione dell'oggetto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddRangeNewElement | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi rendendo dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere più elementi alla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddUnModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Clear | Elimina tutti gli elementi dalla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ClearRefresh | Svuota la lista impostando Dirty = false. Di fatto permette di effettuare un refresh della lista e quindi di ricaricarla. Serve per svuotare la lista e reinizializzarla da capo. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Contains | Verifica l'esistenza di un valore all'interno della lista degli elementi. Le classi derivate devono effettuarne l'override nel caso in cui l'elemento non implementi GetHashCode() per l'uso all'interno dei dizionarii. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | CopyTo | Copia un range di elementi in un array. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | CreateDeleteCommand | (Sovrascrive DedDbCollectionBaseTCreateDeleteCommand(T))
Metodo protetto | CreateInsertCommand | (Sovrascrive DedDbCollectionBaseTCreateInsertCommand(T))
Metodo protetto | CreateUpdateCommand | (Sovrascrive DedDbCollectionBaseTCreateUpdateCommand(T))
Metodo pubblico | CustomSort | Ordina la lista in base al comparatore passato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteDeleteItem | Esegue l'eliminazione di un elemento. Crea il comando tramite il metodo CreateDeleteCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteInsertItem | Esegue l'inserimento di un elemento. Crea il comando tramite il metodo CreateInsertCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteUpdateItem | Esegue l'aggiornamento di un elemento. Crea il comando tramite il metodo CreateUpdateCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Find | Restituisce l'oggetto cercato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FindAll | Restitusice la lista degli elementi che corrispondono al predicato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | GetDbIndex | Restituisce l'indice dell'elemento passato, da utilizzare nelle clausole where di aggiornamento/eliminazione. (Ereditato da DedEditableObjectCollectionT)
Metodo pubblico | GetEnumerator | Restituisce l'enumeratore della collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | IndexOf | Restituisce l'indice dell'elemento richiesto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InsertUnModified | DI USO INTERNO. Inserisce un elemento alla lista senza rendere dirty l'oggetto, all'indice specificato. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Item | Restituisce l'elemento iesimo della lista. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Load | Ripulisce la lista corrente e rilegge i dati. (Ereditato da DedEditableObjectCollectionT)
Metodo pubblico | LoadItems | Legge dal database l'elenco delle temporizzazioni associate all'oggetto corrente. (Sovrascrive DedEditableObjectCollectionTLoadItems)
Metodo pubblico | Move(Int32, Boolean) | Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean, Int32) | Sposta l'elemento dell'indice passato prima o dopo del numero di posizioni passate. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSave | Metodo Template chiamato dopo il salvataggio avvenuto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSaveNoChanges | Metodo Template chiamato dopo il salvataggio senza modifiche. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnBeforeSave | Metodo Template chiamato prima del salvataggio. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(T) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(DedEditableObjectT) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(T) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(DedEditableObjectT) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ReInitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Remove | Elimina un elemento dalla collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Ripristina | Verifica che l'elemento sia presente negli eliminati e lo toglie da lì e lo riaggiunge in coda alla lista degli elementi validi. Solleva una eccezione se l'elemento è già presente nella lista e AllowsDuplicates = false. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Save | Salva l'oggetto con tutta la sua lista, solo se questo risulta dirty. (Ereditato da DedDbCollectionBaseT)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedTimeList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTimeList(
    DedBaseDbItem parent
)
Public Sub New (
    parent As DedBaseDbItem
)
public:
DedTimeList(
    DedBaseDbItem^ parent
)
new :
        parent : DedBaseDbItem -> DedTimeList

Parametri

parent DedBaseDbItem
Vedi anche

Documentazione

Classe DedTimeList
Namespace DedNet.Core


Proprietà di DedTimeList

Il tipo DedTimeList espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllowsDuplicates | Restituisce se siano ammessi duplicati all'interno della lista. Se false viene sollevata una eccezione su tentativo di inserimento duplicati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Application | Restituisce l'oggetto applicazione di appartenza. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Count | Restituisce il numero di elementi presenti. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Dirty | Restituisce se la collezione o uno dei suoi elementi sia stata modificata. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | ErasedItems | Restitusice la lista in sola lettura degli elementi che risultano attualmente cancellati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | LastItem | Restituisce l'ultimo elemento della collezione oppure null se non ci sono elementi. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Parent | Oggetto di cui si vogliono gestire le temporizzazioni. (Ereditato da DedEditableObjectCollectionT)
Proprietà pubblica | RestoreErased | Restituisce se gli elementi cancellati devono essere ripristinati in caso vengano riaggiunti. (Ereditato da DedDbCollectionBaseT)
Torna su
Vedi anche

Documentazione

Classe DedTimeList
Namespace DedNet.Core


Metodi di DedTimeList

Il tipo DedTimeList espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AddEmpty | Aggiunge una temporizzazione all'elenco. I valori di inizio e fine saranno identici e corrispondono alla data minima possibile fornita dal sistema.
Metodo protetto | AddForClone | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto SENZA MODIFICARNE LO STATO. Le classi derivate potranno utilizzare questo metodo per clonare la collezione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddNewElement | DI USO INTERNO. Aggiunge un elemento alla lista rendendo dirty l'oggetto. L'elemento viene aggiunto con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere un elemento alla lista. Dovranno loro stesse avere un metodo pubblico Add() che prenda i parametri necessari alla costruzione dell'oggetto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddRangeNewElement | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi rendendo dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere più elementi alla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddUnModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Clear | Elimina tutti gli elementi dalla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ClearRefresh | Svuota la lista impostando Dirty = false. Di fatto permette di effettuare un refresh della lista e quindi di ricaricarla. Serve per svuotare la lista e reinizializzarla da capo. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Contains | Verifica l'esistenza di un valore all'interno della lista degli elementi. Le classi derivate devono effettuarne l'override nel caso in cui l'elemento non implementi GetHashCode() per l'uso all'interno dei dizionarii. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | CopyTo | Copia un range di elementi in un array. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | CreateDeleteCommand | (Sovrascrive DedDbCollectionBaseTCreateDeleteCommand(T))
Metodo protetto | CreateInsertCommand | (Sovrascrive DedDbCollectionBaseTCreateInsertCommand(T))
Metodo protetto | CreateUpdateCommand | (Sovrascrive DedDbCollectionBaseTCreateUpdateCommand(T))
Metodo pubblico | CustomSort | Ordina la lista in base al comparatore passato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteDeleteItem | Esegue l'eliminazione di un elemento. Crea il comando tramite il metodo CreateDeleteCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteInsertItem | Esegue l'inserimento di un elemento. Crea il comando tramite il metodo CreateInsertCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteUpdateItem | Esegue l'aggiornamento di un elemento. Crea il comando tramite il metodo CreateUpdateCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Find | Restituisce l'oggetto cercato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FindAll | Restitusice la lista degli elementi che corrispondono al predicato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | GetDbIndex | Restituisce l'indice dell'elemento passato, da utilizzare nelle clausole where di aggiornamento/eliminazione. (Ereditato da DedEditableObjectCollectionT)
Metodo pubblico | GetEnumerator | Restituisce l'enumeratore della collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | IndexOf | Restituisce l'indice dell'elemento richiesto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InsertUnModified | DI USO INTERNO. Inserisce un elemento alla lista senza rendere dirty l'oggetto, all'indice specificato. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Item | Restituisce l'elemento iesimo della lista. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Load | Ripulisce la lista corrente e rilegge i dati. (Ereditato da DedEditableObjectCollectionT)
Metodo pubblico | LoadItems | Legge dal database l'elenco delle temporizzazioni associate all'oggetto corrente. (Sovrascrive DedEditableObjectCollectionTLoadItems)
Metodo pubblico | Move(Int32, Boolean) | Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean, Int32) | Sposta l'elemento dell'indice passato prima o dopo del numero di posizioni passate. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSave | Metodo Template chiamato dopo il salvataggio avvenuto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSaveNoChanges | Metodo Template chiamato dopo il salvataggio senza modifiche. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnBeforeSave | Metodo Template chiamato prima del salvataggio. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(T) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(DedEditableObjectT) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(T) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(DedEditableObjectT) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ReInitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Remove | Elimina un elemento dalla collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Ripristina | Verifica che l'elemento sia presente negli eliminati e lo toglie da lì e lo riaggiunge in coda alla lista degli elementi validi. Solleva una eccezione se l'elemento è già presente nella lista e AllowsDuplicates = false. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Save | Salva l'oggetto con tutta la sua lista, solo se questo risulta dirty. (Ereditato da DedDbCollectionBaseT)
Torna su
Vedi anche

Documentazione

Classe DedTimeList
Namespace DedNet.Core


Metodo DedTimeList.AddEmpty

Metodo DedTimeListAddEmpty
Aggiunge una temporizzazione all'elenco. I valori di inizio e fine saranno identici e corrispondono alla data minima possibile fornita dal sistema.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTime AddEmpty()
Public Function AddEmpty As DedTime
public:
DedTime^ AddEmpty()
member AddEmpty : unit -> DedTime

Valore di ritorno

DedTime
Vedi anche

Documentazione

Classe DedTimeList
Namespace DedNet.Core


Metodo DedTimeList.CreateDeleteCommand

Metodo DedTimeListCreateDeleteCommand

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSDeleteCommand CreateDeleteCommand(
    DedTime item
)
Protected Overrides Function CreateDeleteCommand (
    item As DedTime
) As QSDeleteCommand
protected:
virtual QSDeleteCommand^ CreateDeleteCommand(
    DedTime^ item
) override
abstract CreateDeleteCommand :
        item : DedTime -> QSDeleteCommand
override CreateDeleteCommand :
        item : DedTime -> QSDeleteCommand

Parametri

item DedTime

Valore di ritorno

QSDeleteCommand
Vedi anche

Documentazione

Classe DedTimeList
Namespace DedNet.Core


Metodo DedTimeList.CreateInsertCommand

Metodo DedTimeListCreateInsertCommand

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSInsertCommand CreateInsertCommand(
    DedTime item
)
Protected Overrides Function CreateInsertCommand (
    item As DedTime
) As QSInsertCommand
protected:
virtual QSInsertCommand^ CreateInsertCommand(
    DedTime^ item
) override
abstract CreateInsertCommand :
        item : DedTime -> QSInsertCommand
override CreateInsertCommand :
        item : DedTime -> QSInsertCommand

Parametri

item DedTime

Valore di ritorno

QSInsertCommand
Vedi anche

Documentazione

Classe DedTimeList
Namespace DedNet.Core


Metodo DedTimeList.CreateUpdateCommand

Metodo DedTimeListCreateUpdateCommand

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSUpdateCommand CreateUpdateCommand(
    DedTime item
)
Protected Overrides Function CreateUpdateCommand (
    item As DedTime
) As QSUpdateCommand
protected:
virtual QSUpdateCommand^ CreateUpdateCommand(
    DedTime^ item
) override
abstract CreateUpdateCommand :
        item : DedTime -> QSUpdateCommand
override CreateUpdateCommand :
        item : DedTime -> QSUpdateCommand

Parametri

item DedTime

Valore di ritorno

QSUpdateCommand
Vedi anche

Documentazione

Classe DedTimeList
Namespace DedNet.Core


Metodo DedTimeList.LoadItems

Metodo DedTimeListLoadItems
Legge dal database l'elenco delle temporizzazioni associate all'oggetto corrente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override List<DedTime> LoadItems()
Public Overrides Function LoadItems As List(Of DedTime)
public:
virtual List<DedTime^>^ LoadItems() override
abstract LoadItems : unit -> List<DedTime>
override LoadItems : unit -> List<DedTime>

Valore di ritorno

List DedTime
Vedi anche

Documentazione

Classe DedTimeList
Namespace DedNet.Core


Classe DedTimeManager
Classe utilizzata per gestire gli oggetti 'DedTime'.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedTimeManager

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedTimeManager
Public Class DedTimeManager
public ref class DedTimeManager
type DedTimeManager = class end

Il tipo DedTimeManager espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedTimeManager | Istanzia una nuova classe 'DedTimeManager' utilizzata per gestire gli oggetti 'DedTime'.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Find | Ritorna la lista delle temporizzazioni associate all'oggetto specificato.
Metodo pubblico | FindByuser | Ritorna la lista delle temporizzazioni associate all'utente specificato.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedTimeManager
Istanzia una nuova classe 'DedTimeManager' utilizzata per gestire gli oggetti 'DedTime'.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTimeManager(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedTimeManager(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedTimeManager

Parametri

app DedNetApplication
Vedi anche

Documentazione

Classe DedTimeManager
Namespace DedNet.Core


Metodi di DedTimeManager

Il tipo DedTimeManager espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Find | Ritorna la lista delle temporizzazioni associate all'oggetto specificato.
Metodo pubblico | FindByuser | Ritorna la lista delle temporizzazioni associate all'utente specificato.
Torna su
Vedi anche

Documentazione

Classe DedTimeManager
Namespace DedNet.Core


Metodo DedTimeManager.Find

Metodo DedTimeManagerFind
Ritorna la lista delle temporizzazioni associate all'oggetto specificato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<DedTime> Find(
    DedTimeList parentList
)
Public Function Find (
    parentList As DedTimeList
) As List(Of DedTime)
public:
List<DedTime^>^ Find(
    DedTimeList^ parentList
)
member Find :
        parentList : DedTimeList -> List<DedTime>

Parametri

parentList DedTimeList

Valore di ritorno

List DedTime
Vedi anche

Documentazione

Classe DedTimeManager
Namespace DedNet.Core


Metodo DedTimeManager.FindByuser

Metodo DedTimeManagerFindByuser
Ritorna la lista delle temporizzazioni associate all'utente specificato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<DedTime> FindByuser(
    string user
)
Public Function FindByuser (
    user As String
) As List(Of DedTime)
public:
List<DedTime^>^ FindByuser(
    String^ user
)
member FindByuser :
        user : string -> List<DedTime>

Parametri

user String
Nome interno dell'utente.

Valore di ritorno

List DedTime
Vedi anche

Documentazione

Classe DedTimeManager
Namespace DedNet.Core


Classe DedTransferManager
Classe per la gestione delle richieste di trasferimento documenti.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedTransferManager

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedTransferManager
Public Class DedTransferManager
public ref class DedTransferManager
type DedTransferManager = class end

Il tipo DedTransferManager espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedTransferManager | Costruttore unico.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | CreateSnapshot | Compila la tabella DED_DOC_DETACHED con lo snapshot dello stato attuale della corporate.
Metodo pubblico | CreateTransferPacket | Aggiunge un nuovo record alla tabella DED_TRANSFER_PACKET
Metodo pubblico | GetAllDetachedDescriptor | Restituisce una lista di descrittori che rapprensentare documenti da inviare alla sede passata. Vengono considerati i documenti disallineati nel vault del destinatario e allineati nel mio vault.
Metodo pubblico | GetDetachedDocs | Restituisce una lista di documenti che devono essere inviati alla sede passata. Vengono considerati i documenti disallineati nel vault del destinatario e allineati nel mio vault.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedTransferManager
Costruttore unico.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTransferManager(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedTransferManager(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedTransferManager

Parametri

app DedNetApplication
Vedi anche

Documentazione

Classe DedTransferManager
Namespace DedNet.Core


Metodi di DedTransferManager

Il tipo DedTransferManager espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | CreateSnapshot | Compila la tabella DED_DOC_DETACHED con lo snapshot dello stato attuale della corporate.
Metodo pubblico | CreateTransferPacket | Aggiunge un nuovo record alla tabella DED_TRANSFER_PACKET
Metodo pubblico | GetAllDetachedDescriptor | Restituisce una lista di descrittori che rapprensentare documenti da inviare alla sede passata. Vengono considerati i documenti disallineati nel vault del destinatario e allineati nel mio vault.
Metodo pubblico | GetDetachedDocs | Restituisce una lista di documenti che devono essere inviati alla sede passata. Vengono considerati i documenti disallineati nel vault del destinatario e allineati nel mio vault.
Torna su
Vedi anche

Documentazione

Classe DedTransferManager
Namespace DedNet.Core


Metodo DedTransferManager.CreateSnapshot

Metodo DedTransferManagerCreateSnapshot
Compila la tabella DED_DOC_DETACHED con lo snapshot dello stato attuale della corporate.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void CreateSnapshot()
Public Sub CreateSnapshot
public:
void CreateSnapshot()
member CreateSnapshot : unit -> unit
Vedi anche

Documentazione

Classe DedTransferManager
Namespace DedNet.Core


Metodo DedTransferManager.CreateTransferPacket

Metodo DedTransferManagerCreateTransferPacket
Aggiunge un nuovo record alla tabella DED_TRANSFER_PACKET

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Guid CreateTransferPacket(
    DedCorporate corporateFrom,
    string note
)
Public Function CreateTransferPacket (
    corporateFrom As DedCorporate,
    note As String
) As Guid
public:
Guid CreateTransferPacket(
    DedCorporate^ corporateFrom,
    String^ note
)
member CreateTransferPacket :
        corporateFrom : DedCorporate *
        note : string -> Guid

Parametri

corporateFrom DedCorporate
Corporate dalla quale si sta importando.
note String
Nota che potrebbe essere stata aggiunta al transfer

Valore di ritorno

Guid
Vedi anche

Documentazione

Classe DedTransferManager
Namespace DedNet.Core


Metodo DedTransferManager.GetAllDetachedDescriptor

Metodo DedTransferManagerGetAllDetachedDescriptor
Restituisce una lista di descrittori che rapprensentare documenti da inviare alla sede passata. Vengono considerati i documenti disallineati nel vault del destinatario e allineati nel mio vault.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<Guid, Object> GetAllDetachedDescriptor(
    DedCorporate corporate
)
Public Function GetAllDetachedDescriptor (
    corporate As DedCorporate
) As Dictionary(Of Guid, Object)
public:
Dictionary<Guid, Object^>^ GetAllDetachedDescriptor(
    DedCorporate^ corporate
)
member GetAllDetachedDescriptor :
        corporate : DedCorporate -> Dictionary<Guid, Object>

Parametri

corporate DedCorporate
Corporate per il filtraggio dei descrittori (Generalmente lo slave).

Valore di ritorno

Dictionary Guid, Object
Vedi anche

Documentazione

Classe DedTransferManager
Namespace DedNet.Core


Metodo DedTransferManager.GetDetachedDocs

Metodo DedTransferManagerGetDetachedDocs
Restituisce una lista di documenti che devono essere inviati alla sede passata. Vengono considerati i documenti disallineati nel vault del destinatario e allineati nel mio vault.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocList GetDetachedDocs(
    DedCorporate corporate
)
Public Function GetDetachedDocs (
    corporate As DedCorporate
) As DedDocList
public:
DedDocList^ GetDetachedDocs(
    DedCorporate^ corporate
)
member GetDetachedDocs :
        corporate : DedCorporate -> DedDocList

Parametri

corporate DedCorporate
Corporate alla quale inviare i documenti (Generalmente il master).

Valore di ritorno

DedDocList
Vedi anche

Documentazione

Classe DedTransferManager
Namespace DedNet.Core


Enumerazione DedTransferManager.DedTransferManagerOnlineMode

Enumerazione DedTransferManagerDedTransferManagerOnlineMode
Indica le possibili modalità di traferimento online

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum DedTransferManagerOnlineMode
Public Enumeration DedTransferManagerOnlineMode
public enum class DedTransferManagerOnlineMode
type DedTransferManagerOnlineMode
Membri
Nome | Valore | Descrizione
Cloud | 0 |
Ftp | 1 |
Vedi anche

Documentazione

Namespace DedNet.Core


Classe DedTranslation
Classe utilizzata per gestire le traduzioni in lingua.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedTranslation

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedTranslation : IDedDbItem
Public Class DedTranslation
    Implements IDedDbItem
public ref class DedTranslation : IDedDbItem
type DedTranslation =
    class
        interface IDedDbItem
    end

Il tipo DedTranslation espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedTranslation | Crea una nuova istanza della classe DedTranslation utilizzata per gestire le traduzioni in lingua.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Code | Codice che identifica l'oggetto da tradurre (generalmente l'internalname dell'attributo).
Proprietà pubblica | DefaultMissing | Indica se si tratta di una traduzione di defualt che non è mai stata compilata.
Proprietà pubblica | Dirty | Indica se l'oggetto DedTranslation ha delle modifiche appese che necessitano di essere salvate.
Proprietà pubblica | Discrim | Discriminante che identifica a quale tipologia di oggetto è associata la traduzione.
Proprietà pubblica | Neutral | Valore neutrale della traduzione (generalmente il valore dell'attributo).
Proprietà pubblica | Parent | Collezione a cui appartiene il DedTranslation.
Proprietà pubblica | StatoRecord | Restituisce o imposta lo stato del record. DI USO INTERNO !!
Proprietà pubblica | Translations | Dizionario contenente tutte le traduzioni in lingua. La chiave corrisponde al codice ISO della lingua.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Clone | Crea una nuova istanza dell'oggetto DedTranslation copiando i dati attualmente impostati. Attenzione! La proprietà "Parent" non è viene impostata!
Metodo pubblico | CopyFrom(DedTranslation) | Compila le traduzioni leggendo i valori dalla collection specificata in ingresso. Attenzione! Verranno copiate solo le traduzioni, le altre proprietà (per esempio NEUTRAL) rimaranno invariate.
Metodo pubblico | CopyFrom(DedTranslation, Boolean) | Compila le traduzioni leggendo i valori dalla collection specificata in ingresso. Attenzione! Verranno copiate solo le traduzioni, le altre proprietà (per esempio NEUTRAL) rimaranno invariate.
Metodo pubblico | GetValue | Ritorna il valore della traduzione.
Metodo pubblico | SetValue | Imposta il valore della traduzione.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedTranslation
Crea una nuova istanza della classe DedTranslation utilizzata per gestire le traduzioni in lingua.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTranslation(
    DedNetApplication app,
    DedTranslationCollection parent,
    string code,
    TranslationDiscrimEnum discrim
)
Public Sub New (
    app As DedNetApplication,
    parent As DedTranslationCollection,
    code As String,
    discrim As TranslationDiscrimEnum
)
public:
DedTranslation(
    DedNetApplication^ app,
    DedTranslationCollection^ parent,
    String^ code,
    TranslationDiscrimEnum discrim
)
new :
        app : DedNetApplication *
        parent : DedTranslationCollection *
        code : string *
        discrim : TranslationDiscrimEnum -> DedTranslation

Parametri

app DedNetApplication
Applicazione DedNet.
parent DedTranslationCollection
Collezione a cui appartiene il DedTranslation.
code String
Codice che identifica l'oggetto da tradurre (generalmente l'internalname dell'attributo).
discrim TranslationDiscrimEnum
Discriminante che identifica a quale tipologia di oggetto è associata la traduzione.
Vedi anche

Documentazione

Classe DedTranslation
Namespace DedNet.Core


Proprietà di DedTranslation

Il tipo DedTranslation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Code | Codice che identifica l'oggetto da tradurre (generalmente l'internalname dell'attributo).
Proprietà pubblica | DefaultMissing | Indica se si tratta di una traduzione di defualt che non è mai stata compilata.
Proprietà pubblica | Dirty | Indica se l'oggetto DedTranslation ha delle modifiche appese che necessitano di essere salvate.
Proprietà pubblica | Discrim | Discriminante che identifica a quale tipologia di oggetto è associata la traduzione.
Proprietà pubblica | Neutral | Valore neutrale della traduzione (generalmente il valore dell'attributo).
Proprietà pubblica | Parent | Collezione a cui appartiene il DedTranslation.
Proprietà pubblica | StatoRecord | Restituisce o imposta lo stato del record. DI USO INTERNO !!
Proprietà pubblica | Translations | Dizionario contenente tutte le traduzioni in lingua. La chiave corrisponde al codice ISO della lingua.
Torna su
Vedi anche

Documentazione

Classe DedTranslation
Namespace DedNet.Core


Proprietà DedTranslation.Code

Proprietà DedTranslationCode
Codice che identifica l'oggetto da tradurre (generalmente l'internalname dell'attributo).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Code { get; set; }
Public Property Code As String
    Get
    Set
public:
property String^ Code {
    String^ get ();
    void set (String^ value);
}
member Code : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedTranslation
Namespace DedNet.Core


Proprietà DedTranslation.DefaultMissing

Proprietà DedTranslationDefaultMissing
Indica se si tratta di una traduzione di defualt che non è mai stata compilata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool DefaultMissing { get; set; }
Public Property DefaultMissing As Boolean
    Get
    Set
public:
property bool DefaultMissing {
    bool get ();
    void set (bool value);
}
member DefaultMissing : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedTranslation
Namespace DedNet.Core


Proprietà DedTranslation.Dirty

Proprietà DedTranslationDirty
Indica se l'oggetto DedTranslation ha delle modifiche appese che necessitano di essere salvate.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Dirty { get; set; }
Public Property Dirty As Boolean
    Get
    Set
public:
property bool Dirty {
    bool get ();
    void set (bool value);
}
member Dirty : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedTranslation
Namespace DedNet.Core


Proprietà DedTranslation.Discrim

Proprietà DedTranslationDiscrim
Discriminante che identifica a quale tipologia di oggetto è associata la traduzione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public TranslationDiscrimEnum Discrim { get; }
Public ReadOnly Property Discrim As TranslationDiscrimEnum
    Get
public:
property TranslationDiscrimEnum Discrim {
    TranslationDiscrimEnum get ();
}
member Discrim : TranslationDiscrimEnum with get

Valore della proprietà

TranslationDiscrimEnum
Vedi anche

Documentazione

Classe DedTranslation
Namespace DedNet.Core


Proprietà DedTranslation.Neutral

Proprietà DedTranslationNeutral
Valore neutrale della traduzione (generalmente il valore dell'attributo).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Neutral { get; set; }
Public Property Neutral As String
    Get
    Set
public:
property String^ Neutral {
    String^ get ();
    void set (String^ value);
}
member Neutral : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedTranslation
Namespace DedNet.Core


Proprietà DedTranslation.Parent

Proprietà DedTranslationParent
Collezione a cui appartiene il DedTranslation.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTranslationCollection Parent { get; set; }
Public Property Parent As DedTranslationCollection
    Get
    Set
public:
property DedTranslationCollection^ Parent {
    DedTranslationCollection^ get ();
    void set (DedTranslationCollection^ value);
}
member Parent : DedTranslationCollection with get, set

Valore della proprietà

DedTranslationCollection
Vedi anche

Documentazione

Classe DedTranslation
Namespace DedNet.Core


Proprietà DedTranslation.StatoRecord

Proprietà DedTranslationStatoRecord
Restituisce o imposta lo stato del record. DI USO INTERNO !!

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public StatoRecord StatoRecord { get; set; }
Public Property StatoRecord As StatoRecord
    Get
    Set
public:
virtual property StatoRecord^ StatoRecord {
    StatoRecord^ get () sealed;
    void set (StatoRecord^ value) sealed;
}
abstract StatoRecord : StatoRecord with get, set
override StatoRecord : StatoRecord with get, set

Valore della proprietà

StatoRecord

Implementa

IDedDbItemStatoRecord
Vedi anche

Documentazione

Classe DedTranslation
Namespace DedNet.Core


Proprietà DedTranslation.Translations

Proprietà DedTranslationTranslations
Dizionario contenente tutte le traduzioni in lingua. La chiave corrisponde al codice ISO della lingua.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<string, string> Translations { get; }
Public ReadOnly Property Translations As Dictionary(Of String, String)
    Get
public:
property Dictionary<String^, String^>^ Translations {
    Dictionary<String^, String^>^ get ();
}
member Translations : Dictionary<string, string> with get

Valore della proprietà

Dictionary String, String
Vedi anche

Documentazione

Classe DedTranslation
Namespace DedNet.Core


Metodi di DedTranslation

Il tipo DedTranslation espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Clone | Crea una nuova istanza dell'oggetto DedTranslation copiando i dati attualmente impostati. Attenzione! La proprietà "Parent" non è viene impostata!
Metodo pubblico | CopyFrom(DedTranslation) | Compila le traduzioni leggendo i valori dalla collection specificata in ingresso. Attenzione! Verranno copiate solo le traduzioni, le altre proprietà (per esempio NEUTRAL) rimaranno invariate.
Metodo pubblico | CopyFrom(DedTranslation, Boolean) | Compila le traduzioni leggendo i valori dalla collection specificata in ingresso. Attenzione! Verranno copiate solo le traduzioni, le altre proprietà (per esempio NEUTRAL) rimaranno invariate.
Metodo pubblico | GetValue | Ritorna il valore della traduzione.
Metodo pubblico | SetValue | Imposta il valore della traduzione.
Torna su
Vedi anche

Documentazione

Classe DedTranslation
Namespace DedNet.Core


Metodo DedTranslation.Clone

Metodo DedTranslationClone
Crea una nuova istanza dell'oggetto DedTranslation copiando i dati attualmente impostati. Attenzione! La proprietà "Parent" non è viene impostata!

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTranslation Clone()
Public Function Clone As DedTranslation
public:
DedTranslation^ Clone()
member Clone : unit -> DedTranslation

Valore di ritorno

DedTranslation
Vedi anche

Documentazione

Classe DedTranslation
Namespace DedNet.Core


Metodo DedTranslation.CopyFrom

Metodo DedTranslationCopyFrom
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | CopyFrom(DedTranslation) | Compila le traduzioni leggendo i valori dalla collection specificata in ingresso. Attenzione! Verranno copiate solo le traduzioni, le altre proprietà (per esempio NEUTRAL) rimaranno invariate.
Metodo pubblico | CopyFrom(DedTranslation, Boolean) | Compila le traduzioni leggendo i valori dalla collection specificata in ingresso. Attenzione! Verranno copiate solo le traduzioni, le altre proprietà (per esempio NEUTRAL) rimaranno invariate.
Torna su
Vedi anche

Documentazione

Classe DedTranslation
Namespace DedNet.Core


Metodo DedTranslation.CopyFrom(DedTranslation)

Metodo DedTranslationCopyFrom(DedTranslation)
Compila le traduzioni leggendo i valori dalla collection specificata in ingresso. Attenzione! Verranno copiate solo le traduzioni, le altre proprietà (per esempio NEUTRAL) rimaranno invariate.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void CopyFrom(
    DedTranslation from
)
Public Sub CopyFrom (
    from As DedTranslation
)
public:
void CopyFrom(
    DedTranslation^ from
)
member CopyFrom :
        from : DedTranslation -> unit

Parametri

from DedTranslation
Item da cui leggere le traduzioni.
Vedi anche

Documentazione

Classe DedTranslation
Overload di CopyFrom
Namespace DedNet.Core


Metodo DedTranslation.CopyFrom(DedTranslation, Boolean)

Metodo DedTranslationCopyFrom(DedTranslation, Boolean)
Compila le traduzioni leggendo i valori dalla collection specificata in ingresso. Attenzione! Verranno copiate solo le traduzioni, le altre proprietà (per esempio NEUTRAL) rimaranno invariate.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void CopyFrom(
    DedTranslation from,
    bool clearBeforeCopy
)
Public Sub CopyFrom (
    from As DedTranslation,
    clearBeforeCopy As Boolean
)
public:
void CopyFrom(
    DedTranslation^ from,
    bool clearBeforeCopy
)
member CopyFrom :
        from : DedTranslation *
        clearBeforeCopy : bool -> unit

Parametri

from DedTranslation
Item da cui leggere le traduzioni.
clearBeforeCopy Boolean
Indica se cancellare le traduzioni presenti PRIMA di copiare quelle nuove dall'oggetto passato in ingresso.
Vedi anche

Documentazione

Classe DedTranslation
Overload di CopyFrom
Namespace DedNet.Core


Metodo DedTranslation.GetValue

Metodo DedTranslationGetValue
Ritorna il valore della traduzione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string GetValue(
    string code
)
Public Function GetValue (
    code As String
) As String
public:
String^ GetValue(
    String^ code
)
member GetValue :
        code : string -> string

Parametri

code String
Codice ISO della lingua.

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedTranslation
Namespace DedNet.Core


Metodo DedTranslation.SetValue

Metodo DedTranslationSetValue
Imposta il valore della traduzione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetValue(
    string code,
    string newValue
)
Public Sub SetValue (
    code As String,
    newValue As String
)
public:
void SetValue(
    String^ code,
    String^ newValue
)
member SetValue :
        code : string *
        newValue : string -> unit

Parametri

code String
Codice ISO della lingua.
newValue String
Nuovo valore da impostare.
Vedi anche

Documentazione

Classe DedTranslation
Namespace DedNet.Core


Classe DedTranslationCollection
Collezione modificabile di traduzioni in lingua.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedDbCollectionBase DedTranslation
DedNet.CoreDedTranslationCollection

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedTranslationCollection : DedDbCollectionBase<DedTranslation>
Public Class DedTranslationCollection
    Inherits DedDbCollectionBase(Of DedTranslation)
public ref class DedTranslationCollection : public DedDbCollectionBase<DedTranslation^>
type DedTranslationCollection =
    class
        inherit DedDbCollectionBase<DedTranslation>
    end

Il tipo DedTranslationCollection espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllowsDuplicates | Restituisce se siano ammessi duplicati all'interno della lista. Se false viene sollevata una eccezione su tentativo di inserimento duplicati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Application | Restituisce l'oggetto applicazione di appartenza. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Count | Restituisce il numero di elementi presenti. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Dirty | Restituisce se la collezione o uno dei suoi elementi sia stata modificata. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | ErasedItems | Restitusice la lista in sola lettura degli elementi che risultano attualmente cancellati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | ItemDedAttr | Ritorna l'oggetto DedTranslation associato all'attributo specificato.
Proprietà pubblica | ItemInt32 | Ritorna l'oggetto DedTranslation in base all'indice specificato.
Proprietà pubblica | ItemString | Ritorna l'oggetto DedTranslation associato che ha il campo codice uguale alla stringa passata. Nel caso OwnedByData strVal sarà il nome interno dell'attributo. Mentre nel caso NoOwner corrisponde alla stringa da tradurre.
Proprietà pubblica | LastItem | Restituisce l'ultimo elemento della collezione oppure null se non ci sono elementi. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | NoOwned | Restituisce se questa collezione non ha un owner impostato e quindi rappresenta una traduzione Custom.
Proprietà pubblica | OwnedByAttr | Restituisce se questa collezione sia o meno appartenente ad un attributo.
Proprietà pubblica | OwnedByData | Restituisce se questa collezione sia o meno appartenente ad una anagrafica.
Proprietà pubblica | Owner | Restituisce l'owner di appartenenza.
Proprietà pubblica | RestoreErased | Restituisce se gli elementi cancellati devono essere ripristinati in caso vengano riaggiunti. (Ereditato da DedDbCollectionBaseT)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Add | Aggiunge l'elemento specificato in ingresso alla collezione.
Metodo protetto | AddForClone | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto SENZA MODIFICARNE LO STATO. Le classi derivate potranno utilizzare questo metodo per clonare la collezione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddNewElement | DI USO INTERNO. Aggiunge un elemento alla lista rendendo dirty l'oggetto. L'elemento viene aggiunto con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere un elemento alla lista. Dovranno loro stesse avere un metodo pubblico Add() che prenda i parametri necessari alla costruzione dell'oggetto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddRangeNewElement | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi rendendo dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere più elementi alla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddUnModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Clear | Elimina tutti gli elementi dalla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ClearRefresh | Svuota la lista impostando Dirty = false. Di fatto permette di effettuare un refresh della lista e quindi di ricaricarla. Serve per svuotare la lista e reinizializzarla da capo. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Contains | Verifica l'esistenza di un valore all'interno della lista degli elementi. Le classi derivate devono effettuarne l'override nel caso in cui l'elemento non implementi GetHashCode() per l'uso all'interno dei dizionarii. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | CopyFrom | Compila le traduzioni leggendo i valori dalla collection specificata in ingresso. Attenzione! Verranno copiate solo le traduzioni, le altre proprietà (per esempio NEUTRAL) rimaranno invariate.
Metodo pubblico | CopyTo | Copia un range di elementi in un array. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | CreateDeleteCommand | (Sovrascrive DedDbCollectionBaseTCreateDeleteCommand(T))
Metodo protetto | CreateInsertCommand | (Sovrascrive DedDbCollectionBaseTCreateInsertCommand(T))
Metodo protetto | CreateUpdateCommand | (Sovrascrive DedDbCollectionBaseTCreateUpdateCommand(T))
Metodo pubblico | CustomSort | Ordina la lista in base al comparatore passato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteDeleteItem | Esegue l'eliminazione di un elemento. Crea il comando tramite il metodo CreateDeleteCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteInsertItem | Esegue l'inserimento di un elemento. Crea il comando tramite il metodo CreateInsertCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteUpdateItem | Esegue l'aggiornamento di un elemento. Crea il comando tramite il metodo CreateUpdateCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FillWithDefaultTranslation | Aggiunge alla collection le traduzioni mancanti associate agli attributi di default. Un attributo è considerato di default se è un attributo di ricambio, di tipo string e non ha una lista collegata.
Metodo pubblico | Find | Restituisce l'oggetto cercato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FindAll | Restitusice la lista degli elementi che corrispondono al predicato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | GetDbIndex | Restituisce l'indice dell'oggetto. (Sovrascrive DedDbCollectionBaseTGetDbIndex(T))
Metodo pubblico | GetEnumerator | Restituisce l'enumeratore della collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | IndexOf | Restituisce l'indice dell'elemento richiesto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InsertUnModified | DI USO INTERNO. Inserisce un elemento alla lista senza rendere dirty l'oggetto, all'indice specificato. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Item | Restituisce l'elemento iesimo della lista. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean) | Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean, Int32) | Sposta l'elemento dell'indice passato prima o dopo del numero di posizioni passate. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSave | (Sovrascrive DedDbCollectionBaseTOnAfterSave(ListT, ListT, ListT))
Metodo protetto | OnAfterSaveNoChanges | Metodo Template chiamato dopo il salvataggio senza modifiche. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnBeforeSave | Metodo Template chiamato prima del salvataggio. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(T) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(DedEditableObjectT) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(T) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(DedEditableObjectT) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ReInitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Reload | Svuota la lista e la ricarica rileggendo i dati dal database.
Metodo pubblico | Remove | Elimina un elemento dalla collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Ripristina | Verifica che l'elemento sia presente negli eliminati e lo toglie da lì e lo riaggiunge in coda alla lista degli elementi validi. Solleva una eccezione se l'elemento è già presente nella lista e AllowsDuplicates = false. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Save | Salva l'oggetto con tutta la sua lista, solo se questo risulta dirty. (Ereditato da DedDbCollectionBaseT)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di DedTranslationCollection

Il tipo DedTranslationCollection espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllowsDuplicates | Restituisce se siano ammessi duplicati all'interno della lista. Se false viene sollevata una eccezione su tentativo di inserimento duplicati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Application | Restituisce l'oggetto applicazione di appartenza. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Count | Restituisce il numero di elementi presenti. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Dirty | Restituisce se la collezione o uno dei suoi elementi sia stata modificata. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | ErasedItems | Restitusice la lista in sola lettura degli elementi che risultano attualmente cancellati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | ItemDedAttr | Ritorna l'oggetto DedTranslation associato all'attributo specificato.
Proprietà pubblica | ItemInt32 | Ritorna l'oggetto DedTranslation in base all'indice specificato.
Proprietà pubblica | ItemString | Ritorna l'oggetto DedTranslation associato che ha il campo codice uguale alla stringa passata. Nel caso OwnedByData strVal sarà il nome interno dell'attributo. Mentre nel caso NoOwner corrisponde alla stringa da tradurre.
Proprietà pubblica | LastItem | Restituisce l'ultimo elemento della collezione oppure null se non ci sono elementi. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | NoOwned | Restituisce se questa collezione non ha un owner impostato e quindi rappresenta una traduzione Custom.
Proprietà pubblica | OwnedByAttr | Restituisce se questa collezione sia o meno appartenente ad un attributo.
Proprietà pubblica | OwnedByData | Restituisce se questa collezione sia o meno appartenente ad una anagrafica.
Proprietà pubblica | Owner | Restituisce l'owner di appartenenza.
Proprietà pubblica | RestoreErased | Restituisce se gli elementi cancellati devono essere ripristinati in caso vengano riaggiunti. (Ereditato da DedDbCollectionBaseT)
Torna su
Vedi anche

Documentazione

Classe DedTranslationCollection
Namespace DedNet.Core


Proprietà DedTranslationCollection.Item

Proprietà DedTranslationCollectionItem
Lista degli overload
 | Nome | Descrizione
Proprietà pubblica | ItemDedAttr | Ritorna l'oggetto DedTranslation associato all'attributo specificato.
Proprietà pubblica | ItemInt32 | Ritorna l'oggetto DedTranslation in base all'indice specificato.
Proprietà pubblica | ItemString | Ritorna l'oggetto DedTranslation associato che ha il campo codice uguale alla stringa passata. Nel caso OwnedByData strVal sarà il nome interno dell'attributo. Mentre nel caso NoOwner corrisponde alla stringa da tradurre.
Torna su
Vedi anche

Documentazione

Classe DedTranslationCollection
Namespace DedNet.Core


Proprietà DedTranslationCollection.Item(DedAttr)

Proprietà DedTranslationCollectionItem(DedAttr)
Ritorna l'oggetto DedTranslation associato all'attributo specificato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTranslation this[
    DedAttr attr
] { get; }
Public ReadOnly Default Property Item (
    attr As DedAttr
) As DedTranslation
    Get
public:
property DedTranslation^ default[DedAttr^ attr] {
    DedTranslation^ get (DedAttr^ attr);
}
member Item : DedTranslation with get

Parametri

attr DedAttr
Attributo di cui si vogliono prelevare le traduzioni.

Valore della proprietà

DedTranslation
Vedi anche

Documentazione

Classe DedTranslationCollection
Overload di Item
Namespace DedNet.Core


Proprietà DedTranslationCollection.Item(Int32)

Proprietà DedTranslationCollectionItem(Int32)
Ritorna l'oggetto DedTranslation in base all'indice specificato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTranslation this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As DedTranslation
    Get
public:
property DedTranslation^ default[int index] {
    DedTranslation^ get (int index);
}
member Item : DedTranslation with get

Parametri

index Int32
Posizione all'interno della lista.

Valore della proprietà

DedTranslation
Vedi anche

Documentazione

Classe DedTranslationCollection
Overload di Item
Namespace DedNet.Core


Proprietà DedTranslationCollection.Item(String)

Proprietà DedTranslationCollectionItem(String)
Ritorna l'oggetto DedTranslation associato che ha il campo codice uguale alla stringa passata. Nel caso OwnedByData strVal sarà il nome interno dell'attributo. Mentre nel caso NoOwner corrisponde alla stringa da tradurre.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTranslation this[
    string strVal
] { get; }
Public ReadOnly Default Property Item (
    strVal As String
) As DedTranslation
    Get
public:
property DedTranslation^ default[String^ strVal] {
    DedTranslation^ get (String^ strVal);
}
member Item : DedTranslation with get

Parametri

strVal String
Valore da ricercare.

Valore della proprietà

DedTranslation
Vedi anche

Documentazione

Classe DedTranslationCollection
Overload di Item
Namespace DedNet.Core


Proprietà DedTranslationCollection.NoOwned

Proprietà DedTranslationCollectionNoOwned
Restituisce se questa collezione non ha un owner impostato e quindi rappresenta una traduzione Custom.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool NoOwned { get; }
Public ReadOnly Property NoOwned As Boolean
    Get
public:
property bool NoOwned {
    bool get ();
}
member NoOwned : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedTranslationCollection
Namespace DedNet.Core


Proprietà DedTranslationCollection.OwnedByAttr

Proprietà DedTranslationCollectionOwnedByAttr
Restituisce se questa collezione sia o meno appartenente ad un attributo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool OwnedByAttr { get; }
Public ReadOnly Property OwnedByAttr As Boolean
    Get
public:
property bool OwnedByAttr {
    bool get ();
}
member OwnedByAttr : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedTranslationCollection
Namespace DedNet.Core


Proprietà DedTranslationCollection.OwnedByData

Proprietà DedTranslationCollectionOwnedByData
Restituisce se questa collezione sia o meno appartenente ad una anagrafica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool OwnedByData { get; }
Public ReadOnly Property OwnedByData As Boolean
    Get
public:
property bool OwnedByData {
    bool get ();
}
member OwnedByData : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedTranslationCollection
Namespace DedNet.Core


Proprietà DedTranslationCollection.Owner

Proprietà DedTranslationCollectionOwner
Restituisce l'owner di appartenenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object Owner { get; }
Public ReadOnly Property Owner As Object
    Get
public:
property Object^ Owner {
    Object^ get ();
}
member Owner : Object with get

Valore della proprietà

Object
Vedi anche

Documentazione

Classe DedTranslationCollection
Namespace DedNet.Core


Metodi di DedTranslationCollection

Il tipo DedTranslationCollection espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Add | Aggiunge l'elemento specificato in ingresso alla collezione.
Metodo protetto | AddForClone | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto SENZA MODIFICARNE LO STATO. Le classi derivate potranno utilizzare questo metodo per clonare la collezione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddNewElement | DI USO INTERNO. Aggiunge un elemento alla lista rendendo dirty l'oggetto. L'elemento viene aggiunto con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere un elemento alla lista. Dovranno loro stesse avere un metodo pubblico Add() che prenda i parametri necessari alla costruzione dell'oggetto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddRangeNewElement | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi rendendo dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere più elementi alla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddUnModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Clear | Elimina tutti gli elementi dalla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ClearRefresh | Svuota la lista impostando Dirty = false. Di fatto permette di effettuare un refresh della lista e quindi di ricaricarla. Serve per svuotare la lista e reinizializzarla da capo. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Contains | Verifica l'esistenza di un valore all'interno della lista degli elementi. Le classi derivate devono effettuarne l'override nel caso in cui l'elemento non implementi GetHashCode() per l'uso all'interno dei dizionarii. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | CopyFrom | Compila le traduzioni leggendo i valori dalla collection specificata in ingresso. Attenzione! Verranno copiate solo le traduzioni, le altre proprietà (per esempio NEUTRAL) rimaranno invariate.
Metodo pubblico | CopyTo | Copia un range di elementi in un array. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | CreateDeleteCommand | (Sovrascrive DedDbCollectionBaseTCreateDeleteCommand(T))
Metodo protetto | CreateInsertCommand | (Sovrascrive DedDbCollectionBaseTCreateInsertCommand(T))
Metodo protetto | CreateUpdateCommand | (Sovrascrive DedDbCollectionBaseTCreateUpdateCommand(T))
Metodo pubblico | CustomSort | Ordina la lista in base al comparatore passato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteDeleteItem | Esegue l'eliminazione di un elemento. Crea il comando tramite il metodo CreateDeleteCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteInsertItem | Esegue l'inserimento di un elemento. Crea il comando tramite il metodo CreateInsertCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteUpdateItem | Esegue l'aggiornamento di un elemento. Crea il comando tramite il metodo CreateUpdateCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FillWithDefaultTranslation | Aggiunge alla collection le traduzioni mancanti associate agli attributi di default. Un attributo è considerato di default se è un attributo di ricambio, di tipo string e non ha una lista collegata.
Metodo pubblico | Find | Restituisce l'oggetto cercato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FindAll | Restitusice la lista degli elementi che corrispondono al predicato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | GetDbIndex | Restituisce l'indice dell'oggetto. (Sovrascrive DedDbCollectionBaseTGetDbIndex(T))
Metodo pubblico | GetEnumerator | Restituisce l'enumeratore della collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | IndexOf | Restituisce l'indice dell'elemento richiesto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InsertUnModified | DI USO INTERNO. Inserisce un elemento alla lista senza rendere dirty l'oggetto, all'indice specificato. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Item | Restituisce l'elemento iesimo della lista. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean) | Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean, Int32) | Sposta l'elemento dell'indice passato prima o dopo del numero di posizioni passate. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSave | (Sovrascrive DedDbCollectionBaseTOnAfterSave(ListT, ListT, ListT))
Metodo protetto | OnAfterSaveNoChanges | Metodo Template chiamato dopo il salvataggio senza modifiche. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnBeforeSave | Metodo Template chiamato prima del salvataggio. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(T) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(DedEditableObjectT) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(T) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(DedEditableObjectT) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ReInitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Reload | Svuota la lista e la ricarica rileggendo i dati dal database.
Metodo pubblico | Remove | Elimina un elemento dalla collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Ripristina | Verifica che l'elemento sia presente negli eliminati e lo toglie da lì e lo riaggiunge in coda alla lista degli elementi validi. Solleva una eccezione se l'elemento è già presente nella lista e AllowsDuplicates = false. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Save | Salva l'oggetto con tutta la sua lista, solo se questo risulta dirty. (Ereditato da DedDbCollectionBaseT)
Torna su
Vedi anche

Documentazione

Classe DedTranslationCollection
Namespace DedNet.Core


Metodo DedTranslationCollection.Add

Metodo DedTranslationCollectionAdd
Aggiunge l'elemento specificato in ingresso alla collezione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Add(
    DedTranslation item
)
Public Sub Add (
    item As DedTranslation
)
public:
void Add(
    DedTranslation^ item
)
member Add :
        item : DedTranslation -> unit

Parametri

item DedTranslation
Item da aggiungere.
Vedi anche

Documentazione

Classe DedTranslationCollection
Namespace DedNet.Core


Metodo DedTranslationCollection.CopyFrom

Metodo DedTranslationCollectionCopyFrom
Compila le traduzioni leggendo i valori dalla collection specificata in ingresso. Attenzione! Verranno copiate solo le traduzioni, le altre proprietà (per esempio NEUTRAL) rimaranno invariate.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void CopyFrom(
    DedTranslationCollection from
)
Public Sub CopyFrom (
    from As DedTranslationCollection
)
public:
void CopyFrom(
    DedTranslationCollection^ from
)
member CopyFrom :
        from : DedTranslationCollection -> unit

Parametri

from DedTranslationCollection
Collection da cui leggere le traduzioni.
Vedi anche

Documentazione

Classe DedTranslationCollection
Namespace DedNet.Core


Metodo DedTranslationCollection.CreateDeleteCommand

Metodo DedTranslationCollectionCreateDeleteCommand

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSDeleteCommand CreateDeleteCommand(
    DedTranslation item
)
Protected Overrides Function CreateDeleteCommand (
    item As DedTranslation
) As QSDeleteCommand
protected:
virtual QSDeleteCommand^ CreateDeleteCommand(
    DedTranslation^ item
) override
abstract CreateDeleteCommand :
        item : DedTranslation -> QSDeleteCommand
override CreateDeleteCommand :
        item : DedTranslation -> QSDeleteCommand

Parametri

item DedTranslation

Valore di ritorno

QSDeleteCommand
Vedi anche

Documentazione

Classe DedTranslationCollection
Namespace DedNet.Core


Metodo DedTranslationCollection.CreateInsertCommand

Metodo DedTranslationCollectionCreateInsertCommand

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSInsertCommand CreateInsertCommand(
    DedTranslation item
)
Protected Overrides Function CreateInsertCommand (
    item As DedTranslation
) As QSInsertCommand
protected:
virtual QSInsertCommand^ CreateInsertCommand(
    DedTranslation^ item
) override
abstract CreateInsertCommand :
        item : DedTranslation -> QSInsertCommand
override CreateInsertCommand :
        item : DedTranslation -> QSInsertCommand

Parametri

item DedTranslation

Valore di ritorno

QSInsertCommand
Vedi anche

Documentazione

Classe DedTranslationCollection
Namespace DedNet.Core


Metodo DedTranslationCollection.CreateUpdateCommand

Metodo DedTranslationCollectionCreateUpdateCommand

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSUpdateCommand CreateUpdateCommand(
    DedTranslation item
)
Protected Overrides Function CreateUpdateCommand (
    item As DedTranslation
) As QSUpdateCommand
protected:
virtual QSUpdateCommand^ CreateUpdateCommand(
    DedTranslation^ item
) override
abstract CreateUpdateCommand :
        item : DedTranslation -> QSUpdateCommand
override CreateUpdateCommand :
        item : DedTranslation -> QSUpdateCommand

Parametri

item DedTranslation

Valore di ritorno

QSUpdateCommand
Vedi anche

Documentazione

Classe DedTranslationCollection
Namespace DedNet.Core


Metodo DedTranslationCollection.FillWithDefaultTranslation

Metodo DedTranslationCollectionFillWithDefaultTranslation
Aggiunge alla collection le traduzioni mancanti associate agli attributi di default. Un attributo è considerato di default se è un attributo di ricambio, di tipo string e non ha una lista collegata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void FillWithDefaultTranslation()
Public Sub FillWithDefaultTranslation
public:
void FillWithDefaultTranslation()
member FillWithDefaultTranslation : unit -> unit
Vedi anche

Documentazione

Classe DedTranslationCollection
Namespace DedNet.Core


Metodo DedTranslationCollection.GetDbIndex

Metodo DedTranslationCollectionGetDbIndex
Restituisce l'indice dell'oggetto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override Object GetDbIndex(
    DedTranslation item
)
Protected Overrides Function GetDbIndex (
    item As DedTranslation
) As Object
protected:
virtual Object^ GetDbIndex(
    DedTranslation^ item
) override
abstract GetDbIndex :
        item : DedTranslation -> Object
override GetDbIndex :
        item : DedTranslation -> Object

Parametri

item DedTranslation
Elemento di cui restituire l'indice.

Valore di ritorno

Object
Vedi anche

Documentazione

Classe DedTranslationCollection
Namespace DedNet.Core


Metodo DedTranslationCollection.OnAfterSave

Metodo DedTranslationCollectionOnAfterSave

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void OnAfterSave(
    List<DedTranslation> eliminati,
    List<DedTranslation> modificati,
    List<DedTranslation> aggiunti
)
Protected Overrides Sub OnAfterSave (
    eliminati As List(Of DedTranslation),
    modificati As List(Of DedTranslation),
    aggiunti As List(Of DedTranslation)
)
protected:
virtual void OnAfterSave(
    List<DedTranslation^>^ eliminati,
    List<DedTranslation^>^ modificati,
    List<DedTranslation^>^ aggiunti
) override
abstract OnAfterSave :
        eliminati : List<DedTranslation> *
        modificati : List<DedTranslation> *
        aggiunti : List<DedTranslation> -> unit
override OnAfterSave :
        eliminati : List<DedTranslation> *
        modificati : List<DedTranslation> *
        aggiunti : List<DedTranslation> -> unit

Parametri

eliminati List DedTranslation
modificati List DedTranslation
aggiunti List DedTranslation
Vedi anche

Documentazione

Classe DedTranslationCollection
Namespace DedNet.Core


Metodo DedTranslationCollection.Reload

Metodo DedTranslationCollectionReload
Svuota la lista e la ricarica rileggendo i dati dal database.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Reload()
Public Sub Reload
public:
void Reload()
member Reload : unit -> unit
Vedi anche

Documentazione

Classe DedTranslationCollection
Namespace DedNet.Core


Classe DedTranslationManager
Classe utilizzata per gestire gli oggetti DedTranslation. Espone alcune utilità che ne facilitano la ricerca, l'editazione, l'aggiornamento, ecc..
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedTranslationManager

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedTranslationManager
Public Class DedTranslationManager
public ref class DedTranslationManager
type DedTranslationManager = class end

Il tipo DedTranslationManager espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedTranslationManager | Crea una nuova istanza della classe 'DedTranslationManager'.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AddLanguages | Aggiunge al database le lingue specificate.
Metodo pubblico | ExistsTranslation | Verifica se l'attributo specificato in ingresso ha delle traduzioni in lingua.
Metodo pubblico | FindByAnagr | Ritorna tutte le traduzioni associate all'anagrafica specificata in ingresso.
Metodo pubblico | GetUsedLanguages | Ritorna una lista con l'elenco dei codici ISO delle lingue utilizzate per le traduzioni.
Metodo pubblico | RemoveLanguages | Rimuove dal database le lingue specificate.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedTranslationManager
Crea una nuova istanza della classe 'DedTranslationManager'.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTranslationManager(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedTranslationManager(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedTranslationManager

Parametri

app DedNetApplication
Applicazione DedNet.
Vedi anche

Documentazione

Classe DedTranslationManager
Namespace DedNet.Core


Metodi di DedTranslationManager

Il tipo DedTranslationManager espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AddLanguages | Aggiunge al database le lingue specificate.
Metodo pubblico | ExistsTranslation | Verifica se l'attributo specificato in ingresso ha delle traduzioni in lingua.
Metodo pubblico | FindByAnagr | Ritorna tutte le traduzioni associate all'anagrafica specificata in ingresso.
Metodo pubblico | GetUsedLanguages | Ritorna una lista con l'elenco dei codici ISO delle lingue utilizzate per le traduzioni.
Metodo pubblico | RemoveLanguages | Rimuove dal database le lingue specificate.
Torna su
Vedi anche

Documentazione

Classe DedTranslationManager
Namespace DedNet.Core


Metodo DedTranslationManager.AddLanguages

Metodo DedTranslationManagerAddLanguages
Aggiunge al database le lingue specificate.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddLanguages(
    IEnumerable<string> languages
)
Public Sub AddLanguages (
    languages As IEnumerable(Of String)
)
public:
void AddLanguages(
    IEnumerable<String^>^ languages
)
member AddLanguages :
        languages : IEnumerable<string> -> unit

Parametri

languages IEnumerable String
Lista delle lingue da aggiungere (vuole il codice ISO della lingua).
Vedi anche

Documentazione

Classe DedTranslationManager
Namespace DedNet.Core


Metodo DedTranslationManager.ExistsTranslation

Metodo DedTranslationManagerExistsTranslation
Verifica se l'attributo specificato in ingresso ha delle traduzioni in lingua.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ExistsTranslation(
    DedAttr attr,
    TranslationDiscrimEnum discrim
)
Public Function ExistsTranslation (
    attr As DedAttr,
    discrim As TranslationDiscrimEnum
) As Boolean
public:
bool ExistsTranslation(
    DedAttr^ attr,
    TranslationDiscrimEnum discrim
)
member ExistsTranslation :
        attr : DedAttr *
        discrim : TranslationDiscrimEnum -> bool

Parametri

attr DedAttr
Attributo da verificare.
discrim TranslationDiscrimEnum
Discriminante che identifica il tipo di attributo.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedTranslationManager
Namespace DedNet.Core


Metodo DedTranslationManager.FindByAnagr

Metodo DedTranslationManagerFindByAnagr
Ritorna tutte le traduzioni associate all'anagrafica specificata in ingresso.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTranslationCollection FindByAnagr(
    IDedEditable data
)
Public Function FindByAnagr (
    data As IDedEditable
) As DedTranslationCollection
public:
DedTranslationCollection^ FindByAnagr(
    IDedEditable^ data
)
member FindByAnagr :
        data : IDedEditable -> DedTranslationCollection

Parametri

data IDedEditable
Anagrafica di cui si vogliono prelevare le traduzioni.

Valore di ritorno

DedTranslationCollection
Vedi anche

Documentazione

Classe DedTranslationManager
Namespace DedNet.Core


Metodo DedTranslationManager.GetUsedLanguages

Metodo DedTranslationManagerGetUsedLanguages
Ritorna una lista con l'elenco dei codici ISO delle lingue utilizzate per le traduzioni.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> GetUsedLanguages()
Public Function GetUsedLanguages As List(Of String)
public:
List<String^>^ GetUsedLanguages()
member GetUsedLanguages : unit -> List<string>

Valore di ritorno

List String
Vedi anche

Documentazione

Classe DedTranslationManager
Namespace DedNet.Core


Metodo DedTranslationManager.RemoveLanguages

Metodo DedTranslationManagerRemoveLanguages
Rimuove dal database le lingue specificate.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void RemoveLanguages(
    IEnumerable<string> languages
)
Public Sub RemoveLanguages (
    languages As IEnumerable(Of String)
)
public:
void RemoveLanguages(
    IEnumerable<String^>^ languages
)
member RemoveLanguages :
        languages : IEnumerable<string> -> unit

Parametri

languages IEnumerable String
Lista delle lingue da eliminare (vuole il codice ISO della lingua).
Vedi anche

Documentazione

Classe DedTranslationManager
Namespace DedNet.Core


Classe DedType
Descrive una famiglia di codifica Data and Drawings. Al suo interno sono presenti i riferimenti agli attributi specifici della famiglia e alle regole di composizione. Alcune proprietà restituiscono il valore ereditato dalle famiglie di livello superiore.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedTypeBase
DedNet.CoreDedType

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedType : DedTypeBase
Public Class DedType
    Inherits DedTypeBase
public ref class DedType : public DedTypeBase
type DedType =
    class
        inherit DedTypeBase
    end

Il tipo DedType espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione di appartenenza. (Ereditato da DedTypeBase)
Proprietà pubblica | AttributeAnagrAlterTable | Restituisce se sono state modificati gli attributi di anagrafica e necessitano alter table.
Proprietà pubblica | AttributeBomAlterTable | Restituisce se sono state modificati gli attributi di distinta e necessitano alter table.
Proprietà pubblica | AttributeCommAlterTable | Restituisce se sono state modificati gli attributi di commessa e necessitano alter table.
Proprietà pubblica | AttributeCommAnagrAlterTable | Restituisce se sono state modificati gli attributi di anagrafica di commessa e necessitano alter table.
Proprietà pubblica | AttributeDedIdOrDedRevDirty | Restituisce se sono state modificati gli attributi DEDID o DEDREV.
Proprietà pubblica | AttributeDirty | Restituisce se sono state modificati gli attributi.
Proprietà pubblica | AttributeDocAlterTable | Restituisce se sono state modificati gli attributi di documento e necessitano alter table.
Proprietà pubblica | AttributeEcoAlterTable | Restituisce se sono state modificati gli attributi di ECO e necessitano alter table.
Proprietà pubblica | Attributes | Restituisce la lista di attributi di ricambio visibili da questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota. Attenzione! Viene istanziato un nuovo DedAttrList ogni volta che si accede a questa proprietà. (Sovrascrive DedTypeBaseAttributes)
Proprietà pubblica | AttributesAnagrafica | Restituisce la lista di attributi di anagrafica visibili da questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota.
Proprietà pubblica | AttributesAnagraficaOccorrenza | Restituisce la lista di attributi di anagrafica e occorrenza visibili da questa famiglia. Nel caso di attributi con stesso nome vengono considerati buoni quelli di occorrenza. Se non ce ne sono viene restituita una lista inizializzata ma vuota.
Proprietà pubblica | AttributesAnagraficaWithChild | Restituisce la lista di attributi di anagrafica visibili da questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota.
Proprietà pubblica | AttributesAnagrDist | Restituisce la lista di attributi di anagrafica e di distinta visibili da questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota.
Proprietà pubblica | AttributesAnagrDistOcc | Restituisce la lista di attributi di anagrafica, distinta e occorrenza visibili da questa famiglia. Nel caso di attributi con stesso nome vengono considerati buoni quelli di occorrenza. Se non ce ne sono viene restituita una lista inizializzata ma vuota.
Proprietà pubblica | AttributesAnagrDoc | Restituisce la lista di attributi di anagrafica e di documento visibili da questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota.
Proprietà pubblica | AttributesAnagrDocOcc | Restituisce la lista di attributi di anagrafica, documento e occorrenza visibili da questa famiglia. Nel caso di attributi con stesso nome vengono considerati buoni quelli di occorrenza. Se non ce ne sono viene restituita una lista inizializzata ma vuota.
Proprietà pubblica | AttributesDistinta | Restituisce la lista di attributi di distinta visibili da questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota.
Proprietà pubblica | AttributesDistintaOccorrenza | Restituisce la lista di attributi di distinta e occorrenza visibili da questa famiglia. Nel caso di attributi con stesso nome vengono considerati buoni quelli di occorrenza. Se non ce ne sono viene restituita una lista inizializzata ma vuota.
Proprietà pubblica | AttributesDocumento | Restituisce la lista di attributi di documento visibili da questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota.
Proprietà pubblica | AttributesDocumentoOccorrenza | Restituisce la lista di attributi di documento e occorrenza visibili da questa famiglia. Nel caso di attributi con stesso nome vengono considerati buoni quelli di occorrenza. Se non ce ne sono viene restituita una lista inizializzata ma vuota.
Proprietà pubblica | AttributesOccorrenza | Restituisce la lista di attributi di occorrenza visibili da questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota.
Proprietà pubblica | AttributesRequired | Restituisce la lista di attributi obbligatori di questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota.
Proprietà pubblica | AttributesSparePart | Restituisce la lista di attributi visibili da questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota.
Proprietà pubblica | AttributesWithOccurrence | Restituisce la lista di attributi visibili da questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota.
Proprietà pubblica | AttributesWithoutSparePart | Restituisce la lista di attributi visibili da questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota.
Proprietà pubblica | BackColor | Restituisce il colore di sfondo. (Ereditato da DedTypeBase)
Proprietà pubblica | CalculatedAttrs | Lista che contiene quali attributi sono considerati 'importati'. (Ereditato da DedTypeBase)
Proprietà pubblica | Cascade | Restituisce la lista di cascate della famiglia e di quelle ereditate dalle famiglie superiori. Se non ce ne sono viene restituita una lista inizializzata ma vuota.
Proprietà pubblica | CascadeDizDirty | Ritorna true se il dizionario delle cascate è dirty.
Proprietà pubblica | ClonedFrom | Indica se la famiglia è stata clonata e da quale (Ereditato da DedTypeBase)
Proprietà pubblica | Cod_Dis | Restituisce la maschera di codifica per DED_DIS, eventualmente ereditata.
Proprietà pubblica | Cod_Fil | Restituisce la maschera di codifica per DED_FILE, eventualmente ereditata.
Proprietà pubblica | Cod_Id | Restituisce la maschera di codifica per DED_ID, eventualmente ereditata. (Ereditato da DedTypeBase)
Proprietà pubblica | CompCode | Restituisce la modalità di compilazione del DED_COD, eventualmente ereditata.
Proprietà pubblica | DbPath | Restituisce il DbPath della famiglia. (Ereditato da DedTypeBase)
Proprietà pubblica | DefaultDwgPath | Restitusice il percorso di salvataggio calcolato in base alla famiglia padre.
Proprietà pubblica | Descriz | Restituisce/Imposta la descrizione della famiglia. (Ereditato da DedTypeBase)
Proprietà pubblica | Dirty | Restituisce se l'oggetto sia stato modificato oppure se sia stata modificata una delle sue collezioni. (Sovrascrive DedTypeBaseDirty)
Proprietà pubblica | DirtyName | Indica se è stato modificato il nome della famiglia. (Ereditato da DedTypeBase)
Proprietà pubblica | DwgPath | Restituisce la directory di salvataggio di questa famiglia. Restitusice il percorso ereditato se non è impostato per questa famiglia.
Proprietà pubblica | FamFirstLev | Restituisce la famiglia a 1° livello. (Ereditato da DedTypeBase)
Proprietà pubblica | ForeColor | Restituisce il colore del testo. (Ereditato da DedTypeBase)
Proprietà pubblica | FreeCode | Restituisce/Imposta se la famiglia è a codifica libera. (Ereditato da DedTypeBase)
Proprietà pubblica | FreeFile | Restituisce/Imposta se la famiglia è a codifica file libera. (Sovrascrive DedTypeBaseFreeFile)
Proprietà pubblica | FreeFileAsDedId | Restituisce/Imposta se il file debba essere compilato come l'id. (Sovrascrive DedTypeBaseFreeFileAsDedId)
Proprietà pubblica | FreeFileSameFileRev | Restituisce/Imposta se il file debba rimanere uguale anche nelle revisioni. (Sovrascrive DedTypeBaseFreeFileSameFileRev)
Proprietà pubblica | FreeFileType | Restituisce la tipologia di freefile di questa famiglia.
Proprietà pubblica | HasAttributes | Restituisce se sono presenti attributi (ricambio e non ) specifici della famiglia. (Sovrascrive DedTypeBaseHasAttributes)
Proprietà pubblica | HasAttributesSparePart | Restituisce se sono presenti attributi di ricambio specifici della famiglia.
Proprietà pubblica | HasAttributesWithoutSparePart | Restituisce se sono presenti attributi non di ricambio specifici della famiglia.
Proprietà pubblica | HasCascades | Restituisce se sono presenti cascate nella famiglia.
Proprietà pubblica | HasCod_Dis | Restituisce se è presente la codifica del DED_DIS.
Proprietà pubblica | HasCod_File | Restituisce se è presente la codifica del FILE.
Proprietà pubblica | HasCod_Id | Restituisce se è presente la codifica del DEDID. (Ereditato da DedTypeBase)
Proprietà pubblica | HasCompCod | Restituisce se è presente la codifica del CODICE.
Proprietà pubblica | HasDwgPath | Restituisce se è il percorso di archiviazione.
Proprietà pubblica | HasInfoUser | Restiutuisce se la famiglia ha il tassello utente o la variante automatica nell'id. (Ereditato da DedTypeBase)
Proprietà pubblica | HasMaster | Restituisce se è presente il master (Ereditato da DedTypeBase)
Proprietà pubblica | HasParent | Restituisce se è presente un oggetto genitore. (Ereditato da DedTypeBase)
Proprietà pubblica | HasPerm | Restituisce se sono presenti attributi specifici della famiglia.
Proprietà pubblica | HasProgr | Restituisce se la famiglia ha il progressivo locale impostato e non lo eredita (MyProgr> -1). (Ereditato da DedTypeBase)
Proprietà pubblica | HasProgrAlphabet | Restituisce se è presente l'alfabeto del progressivo. (Ereditato da DedTypeBase)
Proprietà pubblica | HasRevisionAlphabet | Restituisce se è presente l'alfabeto della revisione. (Ereditato da DedTypeBase)
Proprietà pubblica | HasRules | Restituisce se sono presenti regole di autocomposizione specifiche della famiglia. (Ereditato da DedTypeBase)
Proprietà pubblica | HasSubTypes | Restituisce se sono presenti sottotipi della famiglia. (Ereditato da DedTypeBase)
Proprietà pubblica | HasVar | Restiutuisce se la famiglia ha la variante automatica nell'id. (Ereditato da DedTypeBase)
Proprietà pubblica | HasVarAlphabet | Restituisce se è presente l'alfabeto del progressivo. (Ereditato da DedTypeBase)
Proprietà pubblica | IsCompleted | Restituisce se la famiglia è completa ovvero può essere utilizzata come famiglia terminale di codifica. (Sovrascrive DedTypeBaseIsCompleted)
Proprietà pubblica | IsPrj | Restituisce se si tratti di una famiglia di tipo progetto (eventualmente ereditato). (Ereditato da DedTypeBase)
Proprietà pubblica | IsRevNewType | Restituisce true se questa famiglia non ha il tassello della revisione nel nome file oppure se è FreeFile. Negli altri casi restituisce false.
Proprietà pubblica | IsRoot | Restituisce se si tratta della root dell'albero dei tipi. (Ereditato da DedTypeBase)
Proprietà pubblica | Level | Restituisce il livello di questa famiglia, partendo da 0 per la famiglia root. (Ereditato da DedTypeBase)
Proprietà pubblica | Master | Identifica il master collegato alla tipologia (Ereditato da DedTypeBase)
Proprietà pubblica | MyAttributes | Restituisce la lista di attributi abbinati a questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota. (Sovrascrive DedTypeBaseMyAttributes)
Proprietà pubblica | MyAttributesSparePart | Restituisce la lista di attributi abbinati a questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota.
Proprietà pubblica | MyAttributesWithoutSparePart | Restituisce la lista di attributi abbinati a questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota.
Proprietà pubblica | MyCascade | Restituisce il dizionario di cascate della famiglia. Se non ce ne sono viene restituito un dizionario inizializzato ma vuoto.
Proprietà pubblica | MyCod_Dis | Restituisce/Imposta la maschera di codifica per DED_DIS di questa famiglia.
Proprietà pubblica | MyCod_Fil | Restituisce/Imposta la maschera di codifica per DED_FILE di questa famiglia.
Proprietà pubblica | MyCod_Id | Restituisce/Imposta la maschera di codifica per DED_ID di questa famiglia. (Ereditato da DedTypeBase)
Proprietà pubblica | MyCompCode | Restituisce/Imposta la modalità di compilazione del DED_COD di questa famiglia.
Proprietà pubblica | MyDwgPath | Restituisce/Imposta il percorso di salvataggio di questa famiglia.
Proprietà pubblica | MyIsPrj | Restituisce/Imposta se si tratti di una famiglia di tipo progetto (questa famiglia). (Ereditato da DedTypeBase)
Proprietà pubblica | MyMaster | Identifica il master collegato alla tipologia (Ereditato da DedTypeBase)
Proprietà pubblica | MyProgr | Restituisce/Imposta il valore del progressivo strettamente di questa famiglia. Non interroga il Database ma restituisce il valore della cache. (Ereditato da DedTypeBase)
Proprietà pubblica | MyProgrAlphabet | Restituisce/Imposta l'alfabeto per il progressivo di questa famiglia. (Ereditato da DedTypeBase)
Proprietà pubblica | MyRevisionAlphabet | Restituisce/Imposta l'alfabeto per il progressivo di questa famiglia. (Ereditato da DedTypeBase)
Proprietà pubblica | MyRules | Restituisce la lista delle regole di autocomposizione di questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota. (Ereditato da DedTypeBase)
Proprietà pubblica | MyVarAlphabet | Restituisce/Imposta l'alfabeto per la variante di questa famiglia. (Ereditato da DedTypeBase)
Proprietà pubblica | Nome | Restituisce/Imposta il nome della famiglia. (Ereditato da DedTypeBase)
Proprietà pubblica | OldDwgPath | Restituisce la directory di salvataggio originaria di questa famiglia. Nel caso di cambio nome si salva il percorso originale per la gestione dei permessi.
Proprietà pubblica | Parent | Restituisce la collezione di appartenenza. (Ereditato da DedTypeBase)
Proprietà pubblica | Progr | Restituisce il progressivo eventualmente ereditato, se non presente in questa famiglia. (Ereditato da DedTypeBase)
Proprietà pubblica | ProgrAlphabet | Restituisce l'alfabeto per la variante di questa famiglia. Restitusice l'alfabeto ereditato se non è impostato per questa famiglia. (Ereditato da DedTypeBase)
Proprietà pubblica | ReservedProgTableName | Tabella relativa ai progressivi riservati (Sovrascrive DedTypeBaseReservedProgTableName)
Proprietà pubblica | RevisionAlphabet | Restituisce l'alfabeto per il progressivo di questa famiglia. Restitusice l'alfabeto ereditato se non è impostato per questa famiglia. (Ereditato da DedTypeBase)
Proprietà pubblica | Root | Restituisce la famiglia Root della collezione (Sovrascrive DedTypeBaseRoot)
Proprietà pubblica | RuleDirty | Restituisce se sono state modificate le regole. (Ereditato da DedTypeBase)
Proprietà pubblica | Rules | Restituisce la lista delle regole di autocomposizione visibili da questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota. (Ereditato da DedTypeBase)
Proprietà pubblica | RuleTableName | Tabella relativa alle regole dell'oggetto (Sovrascrive DedTypeBaseRuleTableName)
Proprietà pubblica | StatoRecord | Restituisce o imposta lo stato del record. DI USO INTERNO !! (Ereditato da DedTypeBase)
Proprietà pubblica | SubTypes | Restituisce la lista delle sottofamiglie di questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota. (Sovrascrive DedTypeBaseSubTypes)
Proprietà pubblica | TableName | Tabella relativa all'oggetto (Sovrascrive DedTypeBaseTableName)
Proprietà pubblica | TypeDirty | Restituisce se sono state modificate le famiglie. (Ereditato da DedTypeBase)
Proprietà pubblica | VarAlphabet | Restituisce l'alfabeto per il progressivo di questa famiglia. Restitusice l'alfabeto ereditato se non è impostato per questa famiglia. (Ereditato da DedTypeBase)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AddOccurenceAttrs | Aggiunge i documenti di occorrenza a quelli passati, sostituendoli nel caso di Nome corriposndente.
Metodo pubblico | Clone | Metodo per clonare la famiglia.
Metodo pubblico | CreateData(String, String, String, String) | Crea una nuova anagrafica associata a questa famiglia e la restituisce. Il chiamante deve successivamente inserire tutti i valori rimanenti all'interno dell'anagrafica ed aggiornarla nel Database tramite un Update(). Oltre ai campi che vengono passati come argomento, vengono precompilati anche: DEDLOCK, DEDROWVER, DEDUSER, DEDDATE, DEDMODUSER, DEDMODDATE, DEDSTATEUSER, DEDSTATEDATE e DEDSTATEID. Restituisce l'anagrafica già loccata dall'utente corrente e che necessita di un Update(), oppure solleva un'eccezione se avvengono degli errori.
Metodo pubblico | CreateData(String, String, String, String, Boolean) | Crea una nuova anagrafica associata a questa famiglia e la restituisce. Il chiamante deve successivamente inserire tutti i valori rimanenti all'interno dell'anagrafica ed aggiornarla nel Database tramite un Update(). Oltre ai campi che vengono passati come argomento, vengono precompilati anche: DEDLOCK, DEDROWVER, DEDUSER, DEDDATE, DEDMODUSER, DEDMODDATE, DEDSTATEUSER, DEDSTATEDATE e DEDSTATEID. Restituisce l'anagrafica già loccata dall'utente corrente e che necessita di un Update(), oppure solleva un'eccezione se avvengono degli errori.
Metodo pubblico | DecodeDedDis | Decodifica una stinga come DED_DIS appartenente a questa famiglia, restituendo un oggetto descrittivo della codifica.
Metodo pubblico | DecodeDedFile | Decodifica una stinga come file di default per i file primari di questa famiglia, restituendo un oggetto descrittivo della codifica.
Metodo pubblico | DecodeDedId(String) | Decodifica una stinga come DEDID appartenente a questa famiglia, restituendo un oggetto descrittivo della codifica. (Sovrascrive DedTypeBaseDecodeDedId(String))
Metodo pubblico | DecodeDedId(String, String) | Decodifica una stinga come DEDID appartenente a questa famiglia, restituendo un oggetto descrittivo della codifica. (Sovrascrive DedTypeBaseDecodeDedId(String, String))
Metodo pubblico | EncodeDedDis | Inserisce nelle info passate questa stessa famiglia e poi crea e restituisce il DED_DIS corrispondente alla maschera di codifica presente o ereditata da questa famiglia.
Metodo pubblico | EncodeDedFile | Inserisce nelle info passate questa stessa famiglia e poi crea e restituisce il nome file di default per i file primari, corrispondente alla maschera di codifica presente o ereditata da questa famiglia.
Metodo pubblico | EncodeDedId(DedEncodeInfo) | Inserisce nelle info passate questa stessa famiglia e poi crea e restituisce il DEDID corrispondente alla maschera di codifica presente o ereditata da questa famiglia. (Sovrascrive DedTypeBaseEncodeDedId(DedEncodeInfo))
Metodo pubblico | EncodeDedId(DedEncodeInfo, DedData) | Inserisce nelle info passate questa stessa famiglia e poi crea e restituisce il DEDID corrispondente alla maschera di codifica presente o ereditata da questa famiglia.
Metodo pubblico | EncodePath | Inserisce nelle info passate questa stessa famiglia e poi crea e restituisce il percorso di archiviazione di default presente o ereditato da questa famiglia.
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | FindAttrByName | Cerca un attributo con un determinato nome tra gli attributi visibili da questa famiglia. Restitusice null se non lo trova. (Sovrascrive DedTypeBaseFindAttrByName(String))
Metodo pubblico | FindAttrByPrompt | Cerca un attributo con un determinato prompt tra gli attributi visibili da questa famiglia. Restitusice null se non lo trova. (Sovrascrive DedTypeBaseFindAttrByPrompt(String))
Metodo pubblico | FindBusyProgrRecursive | Scorre ricorsivamente tutte le famiglie per conoscere tutti i progressivi utilizzati. (Sovrascrive DedTypeBaseFindBusyProgrRecursive(DedTypeBase, DictionaryString, String, String, DataTable))
Metodo pubblico | FindByDbPath | Cerca il tipo corrispondente al dbpath passato in tutto l'albero partendo dalla radice. (Sovrascrive DedTypeBaseFindByDbPath(String))
Metodo pubblico | FindByDwgPath | Cerca il tipo corrispondente al dbpath passato in tutto l'albero partendo dalla radice.
 | FindCommonDbPath | Restituisce il DbPath comune a tutte le famiglie contenute nella lista di DbPath passata. Restituisce "!" nel caso in cui la lista sia vuota.
Metodo pubblico | ForEachChild | Questo metodo chiama un delegate passandogli in sequenza il nodo corrente (opzionalmente) e tutti i suoi nodi figli. (Ereditato da DedTypeBase)
Metodo pubblico | ForEachParent | Questo metodo chiama un delegate passandogli in sequenza il nodo root e giù fino al nodo corrente (opzionalmente) Lo scorrimento avviene quindi in modo discendente dal padre di tutti verso l'oggetto corrente. (Ereditato da DedTypeBase)
Metodo pubblico | FormatDedRev | Data una stringa di revisione restituisce il valore correttamente formattato e della giusta dimensione per questa famiglia. Es: "1" -> "01" (con rev. di 2 caratteri); "12" -> "012" (con rev. di 3 caratteri); "05" -> "5" (con rev. di 1 carattere); (Ereditato da DedTypeBase)
Metodo pubblico | FormatProgr | Data una stringa di progressivo restituisce il valore correttamente formattato e della giusta dimensione per questa famiglia. Es: "1" -> "001" (progr. di 3 caratteri); "12" -> "012" (progr. di 3 caratteri); "05" -> "5" (progr. di 1 carattere); (Ereditato da DedTypeBase)
Metodo pubblico | FormatVar | Data una stringa della variante restituisce il valore correttamente formattato e della giusta dimensione per questa famiglia. Es: "1" -> "001" (progr. di 3 caratteri); "12" -> "012" (progr. di 3 caratteri); "05" -> "5" (progr. di 1 carattere); (Ereditato da DedTypeBase)
Metodo pubblico | ForOneChild | Questo metodo chiama un delegate passandogli in sequenza il nodo corrente (opzionalmente) e tutti i suoi nodi figli. (Ereditato da DedTypeBase)
Metodo pubblico | GetAllAttrNames | Restituisce la lista di tutti i nomi degli attributi visibili da questa famiglia.
Metodo pubblico | GetAllAttrPrompts | Restituisce la lista di tutti i prompt degli attributi visibili da questa famiglia.
Metodo pubblico | GetAttrNameFromPrompt | Restituisce il nome di un attributo visibile da questa famiglia dato il suo prompt. (Ereditato da DedTypeBase)
Metodo pubblico | GetAttrPromptFromName | Restituisce il prompt di un attributo visibile da questa famiglia dato il suo nome. Restituisce null se non viene trovato.
Metodo pubblico | GetAttrsFromCategory(DedCateg) | Ritorna la lista di attributi visibili dalla famiglia che appartengono alla categoria passata. (Ereditato da DedTypeBase)
Metodo pubblico | GetAttrsFromCategory(String) | Ritorna la lista di attributi visibili dalla famiglia che appartengono alla categoria passata. (Ereditato da DedTypeBase)
Metodo pubblico | GetBusyProgr | Restituisce un dizionario con tutti i progressivi utilizzati. (Ereditato da DedTypeBase)
Metodo pubblico | GetCascadeFromName | Ritorna la cascata che ha come Figlio il nome passato.
Metodo pubblico | GetFamSpecificLevel | Restituisce la famiglia a n° livello. (Ereditato da DedTypeBase)
Metodo pubblico | GetFamSpecificNegativeLevel | Restituisce la famiglia a n° livello negativo. (Ereditato da DedTypeBase)
Metodo pubblico | GetFieldsCod | Restituisce la lista delle stringhe nelle quali cercare i tasselli. (Sovrascrive DedTypeBaseGetFieldsCod)
Metodo pubblico | GetFirstParentHasProg | Restituisce la prima famiglia genitore che ha il progressivo locale.Considera anche il nodo corrente per avere la sicurezza che se viene chiamato su una famiglia con con progressivo impostato non lo calcoli sul padre ma su se stesso. (Ereditato da DedTypeBase)
Metodo pubblico | GetFreeProgr | Restituisce una lista sempre inizializzata e ordinata con tutti i progressivi liberi per questa famiglia. (Ereditato da DedTypeBase)
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | GetLastProgr | Restituisce l'ultimo progressivo possibile per questa famiglia. (Ereditato da DedTypeBase)
Metodo pubblico | GetMaxTokenNum | Restituisce il massimo numero di caratteri usati per il TokenTypeEnum passato. Verifica nella maschera di codifica Cod_Id, Cod_Fil e Cod_Dis in modo da prendere il numero massimo di caratteri utilizzati. (Ereditato da DedTypeBase)
Metodo pubblico | GetNextVar | Calcola il prossimo tassello di variante automatica.
Metodo pubblico | GetParentAttributes | Restituisce la lista degli attributi dei miei genitori.
Metodo pubblico | GetParentTypes | Restituisce una lista dei FamilyType genitori, compresa l'istanza stessa se specificato. (Sovrascrive DedTypeBaseGetParentTypes(Boolean))
Metodo pubblico | GetProgr(Boolean) | Restituisce il progressivo della famiglia che ha invocato il metodo oppure il progressivo della prima famiglia genitore che lo possiede. Lavora sull'utente attualmente connesso ( se deve lavorare in DED_TIPI_PROG ). (Ereditato da DedTypeBase)
Metodo pubblico | GetProgr(Boolean, String) | Restituisce il progressivo della famiglia che ha invocato il metodo oppure il progressivo della prima famiglia genitore che lo possiede (Ereditato da DedTypeBase)
Metodo pubblico | GetProgrTokenNum | Restituisce il numero di caratteri da utilizzare per creare la stringa del progressivo per questa famiglia. Li calcola cercando il tassello del progressivo nella codifica del Cod_Id. Se non è presente restituisce 0. (Ereditato da DedTypeBase)
Metodo pubblico | GetRevDedDisTokenNum | Restituisce il numero di caratteri dedicati alla revisione, presenti nel DED_DIS.
Metodo pubblico | GetRevFileTokenNum | Restituisce il numero di caratteri dedicati alla revisione, presenti nel nome del file COD_FIL. Se si tratta di una famiglia NGR (nuova gestione delle revisioni), restituisce 0, altrimenti il numero di caratteri presenti.
Metodo pubblico | GetRevTokenNum | Restituisce il numero di caratteri da utilizzare per creare la stringa di revisione per questa famiglia. Li calcola cercando il tassello della revisione nella codifica del DED_DIS. Se non è presente qui restituisce il valore presente nella variabile globale del DED
Metodo pubblico | GetRightMask | Restituisce il TokenInfo cercato nella prima maschera di codifica trovata, da utilizzare poi per calcolare il numero di tasselli per un particolare token. Restituisce null se non la trova. (Ereditato da DedTypeBase)
Metodo pubblico | MakeAttrsDictionary | Riempie il dizionario _dizfields. (Ereditato da DedTypeBase)
Metodo pubblico | NotifyDirty | In base al fatto che si tratti della root o meno notifica al parent corretto l'avvenuta modifica della proprietà. (Sovrascrive DedTypeBaseNotifyDirty)
Metodo pubblico | Save | Salva tutta la struttura discendente (da questa in giù) delle famiglie. (Sovrascrive DedTypeBaseSave)
Metodo pubblico | SetProgr(String, String, Boolean) | Imposta il progressivo di questa famiglia o della famiglia dalla quale questa eredita il progressivo. Lavora sull'utente attualmente connesso ( se deve lavorare in DED_TIPI_PROG ). (Ereditato da DedTypeBase)
Metodo pubblico | SetProgr(String, String, Boolean, String) | Imposta il progressivo di questa famiglia o della famiglia dalla quale questa eredita il progressivo. (Ereditato da DedTypeBase)
Metodo pubblico | SetProgr(String, String, Boolean, String, Boolean) | Imposta il progressivo di questa famiglia o della famiglia dalla quale questa eredita il progressivo. (Ereditato da DedTypeBase)
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Metodo pubblico | UserCan(DedStandardPerm) | Verifica se l'utente corrente ha un determinato permesso su questa famiglia.
Metodo pubblico | UserCan(String) | Verifica se l'utente corrente ha un determinato permesso su questa famiglia.
Metodo pubblico | WaitForUpdate | Esegue una query con WITH (XLOCK) in modo da aspettare finchè altri utenti non hanno commitato. (Ereditato da DedTypeBase)
Torna su
Campi
 | Nome | Descrizione
Campo pubblico | _analyzedTypes | (Ereditato da DedTypeBase)
Campo pubblico | _app | (Ereditato da DedTypeBase)
Campo pubblico | _attributes | (Ereditato da DedTypeBase)
Campo pubblico | _backcolor | (Ereditato da DedTypeBase)
Campo pubblico | _calculatedAttrs | (Ereditato da DedTypeBase)
Campo pubblico | _clonedFrom | (Ereditato da DedTypeBase)
Campo pubblico | _cod_id | (Ereditato da DedTypeBase)
Campo pubblico | _dbPath | (Ereditato da DedTypeBase)
Campo pubblico | _dbPathLoaded | (Ereditato da DedTypeBase)
Campo pubblico | _descriz | (Ereditato da DedTypeBase)
Campo pubblico | _dirtyname | (Ereditato da DedTypeBase)
Campo pubblico | _dwgpath | (Ereditato da DedTypeBase)
Campo pubblico | _forecolor | (Ereditato da DedTypeBase)
Campo pubblico | _freecode | (Ereditato da DedTypeBase)
Campo pubblico | _isprj | (Ereditato da DedTypeBase)
Campo pubblico | _isRoot | Indica se questa famiglia sia o meno la root. (Ereditato da DedTypeBase)
Campo pubblico | _master | (Ereditato da DedTypeBase)
Campo pubblico | _name | (Ereditato da DedTypeBase)
Campo pubblico | _oldDwgPath | (Ereditato da DedTypeBase)
Campo pubblico | _parent | Collezione di appartenenza. (Ereditato da DedTypeBase)
Campo pubblico | _progr | (Ereditato da DedTypeBase)
Campo pubblico | _progrAlphabet | (Ereditato da DedTypeBase)
Campo pubblico | _revisionAlphabet | (Ereditato da DedTypeBase)
Campo pubblico | _rootCollection | Collezione dedicata al salvataggio della root. (Ereditato da DedTypeBase)
Campo pubblico | _rules | (Ereditato da DedTypeBase)
Campo pubblico | _subtypes | (Ereditato da DedTypeBase)
Campo pubblico | _varAlphabet | (Ereditato da DedTypeBase)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di DedType

Il tipo DedType espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione di appartenenza. (Ereditato da DedTypeBase)
Proprietà pubblica | AttributeAnagrAlterTable | Restituisce se sono state modificati gli attributi di anagrafica e necessitano alter table.
Proprietà pubblica | AttributeBomAlterTable | Restituisce se sono state modificati gli attributi di distinta e necessitano alter table.
Proprietà pubblica | AttributeCommAlterTable | Restituisce se sono state modificati gli attributi di commessa e necessitano alter table.
Proprietà pubblica | AttributeCommAnagrAlterTable | Restituisce se sono state modificati gli attributi di anagrafica di commessa e necessitano alter table.
Proprietà pubblica | AttributeDedIdOrDedRevDirty | Restituisce se sono state modificati gli attributi DEDID o DEDREV.
Proprietà pubblica | AttributeDirty | Restituisce se sono state modificati gli attributi.
Proprietà pubblica | AttributeDocAlterTable | Restituisce se sono state modificati gli attributi di documento e necessitano alter table.
Proprietà pubblica | AttributeEcoAlterTable | Restituisce se sono state modificati gli attributi di ECO e necessitano alter table.
Proprietà pubblica | Attributes | Restituisce la lista di attributi di ricambio visibili da questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota. Attenzione! Viene istanziato un nuovo DedAttrList ogni volta che si accede a questa proprietà. (Sovrascrive DedTypeBaseAttributes)
Proprietà pubblica | AttributesAnagrafica | Restituisce la lista di attributi di anagrafica visibili da questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota.
Proprietà pubblica | AttributesAnagraficaOccorrenza | Restituisce la lista di attributi di anagrafica e occorrenza visibili da questa famiglia. Nel caso di attributi con stesso nome vengono considerati buoni quelli di occorrenza. Se non ce ne sono viene restituita una lista inizializzata ma vuota.
Proprietà pubblica | AttributesAnagraficaWithChild | Restituisce la lista di attributi di anagrafica visibili da questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota.
Proprietà pubblica | AttributesAnagrDist | Restituisce la lista di attributi di anagrafica e di distinta visibili da questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota.
Proprietà pubblica | AttributesAnagrDistOcc | Restituisce la lista di attributi di anagrafica, distinta e occorrenza visibili da questa famiglia. Nel caso di attributi con stesso nome vengono considerati buoni quelli di occorrenza. Se non ce ne sono viene restituita una lista inizializzata ma vuota.
Proprietà pubblica | AttributesAnagrDoc | Restituisce la lista di attributi di anagrafica e di documento visibili da questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota.
Proprietà pubblica | AttributesAnagrDocOcc | Restituisce la lista di attributi di anagrafica, documento e occorrenza visibili da questa famiglia. Nel caso di attributi con stesso nome vengono considerati buoni quelli di occorrenza. Se non ce ne sono viene restituita una lista inizializzata ma vuota.
Proprietà pubblica | AttributesDistinta | Restituisce la lista di attributi di distinta visibili da questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota.
Proprietà pubblica | AttributesDistintaOccorrenza | Restituisce la lista di attributi di distinta e occorrenza visibili da questa famiglia. Nel caso di attributi con stesso nome vengono considerati buoni quelli di occorrenza. Se non ce ne sono viene restituita una lista inizializzata ma vuota.
Proprietà pubblica | AttributesDocumento | Restituisce la lista di attributi di documento visibili da questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota.
Proprietà pubblica | AttributesDocumentoOccorrenza | Restituisce la lista di attributi di documento e occorrenza visibili da questa famiglia. Nel caso di attributi con stesso nome vengono considerati buoni quelli di occorrenza. Se non ce ne sono viene restituita una lista inizializzata ma vuota.
Proprietà pubblica | AttributesOccorrenza | Restituisce la lista di attributi di occorrenza visibili da questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota.
Proprietà pubblica | AttributesRequired | Restituisce la lista di attributi obbligatori di questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota.
Proprietà pubblica | AttributesSparePart | Restituisce la lista di attributi visibili da questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota.
Proprietà pubblica | AttributesWithOccurrence | Restituisce la lista di attributi visibili da questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota.
Proprietà pubblica | AttributesWithoutSparePart | Restituisce la lista di attributi visibili da questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota.
Proprietà pubblica | BackColor | Restituisce il colore di sfondo. (Ereditato da DedTypeBase)
Proprietà pubblica | CalculatedAttrs | Lista che contiene quali attributi sono considerati 'importati'. (Ereditato da DedTypeBase)
Proprietà pubblica | Cascade | Restituisce la lista di cascate della famiglia e di quelle ereditate dalle famiglie superiori. Se non ce ne sono viene restituita una lista inizializzata ma vuota.
Proprietà pubblica | CascadeDizDirty | Ritorna true se il dizionario delle cascate è dirty.
Proprietà pubblica | ClonedFrom | Indica se la famiglia è stata clonata e da quale (Ereditato da DedTypeBase)
Proprietà pubblica | Cod_Dis | Restituisce la maschera di codifica per DED_DIS, eventualmente ereditata.
Proprietà pubblica | Cod_Fil | Restituisce la maschera di codifica per DED_FILE, eventualmente ereditata.
Proprietà pubblica | Cod_Id | Restituisce la maschera di codifica per DED_ID, eventualmente ereditata. (Ereditato da DedTypeBase)
Proprietà pubblica | CompCode | Restituisce la modalità di compilazione del DED_COD, eventualmente ereditata.
Proprietà pubblica | DbPath | Restituisce il DbPath della famiglia. (Ereditato da DedTypeBase)
Proprietà pubblica | DefaultDwgPath | Restitusice il percorso di salvataggio calcolato in base alla famiglia padre.
Proprietà pubblica | Descriz | Restituisce/Imposta la descrizione della famiglia. (Ereditato da DedTypeBase)
Proprietà pubblica | Dirty | Restituisce se l'oggetto sia stato modificato oppure se sia stata modificata una delle sue collezioni. (Sovrascrive DedTypeBaseDirty)
Proprietà pubblica | DirtyName | Indica se è stato modificato il nome della famiglia. (Ereditato da DedTypeBase)
Proprietà pubblica | DwgPath | Restituisce la directory di salvataggio di questa famiglia. Restitusice il percorso ereditato se non è impostato per questa famiglia.
Proprietà pubblica | FamFirstLev | Restituisce la famiglia a 1° livello. (Ereditato da DedTypeBase)
Proprietà pubblica | ForeColor | Restituisce il colore del testo. (Ereditato da DedTypeBase)
Proprietà pubblica | FreeCode | Restituisce/Imposta se la famiglia è a codifica libera. (Ereditato da DedTypeBase)
Proprietà pubblica | FreeFile | Restituisce/Imposta se la famiglia è a codifica file libera. (Sovrascrive DedTypeBaseFreeFile)
Proprietà pubblica | FreeFileAsDedId | Restituisce/Imposta se il file debba essere compilato come l'id. (Sovrascrive DedTypeBaseFreeFileAsDedId)
Proprietà pubblica | FreeFileSameFileRev | Restituisce/Imposta se il file debba rimanere uguale anche nelle revisioni. (Sovrascrive DedTypeBaseFreeFileSameFileRev)
Proprietà pubblica | FreeFileType | Restituisce la tipologia di freefile di questa famiglia.
Proprietà pubblica | HasAttributes | Restituisce se sono presenti attributi (ricambio e non ) specifici della famiglia. (Sovrascrive DedTypeBaseHasAttributes)
Proprietà pubblica | HasAttributesSparePart | Restituisce se sono presenti attributi di ricambio specifici della famiglia.
Proprietà pubblica | HasAttributesWithoutSparePart | Restituisce se sono presenti attributi non di ricambio specifici della famiglia.
Proprietà pubblica | HasCascades | Restituisce se sono presenti cascate nella famiglia.
Proprietà pubblica | HasCod_Dis | Restituisce se è presente la codifica del DED_DIS.
Proprietà pubblica | HasCod_File | Restituisce se è presente la codifica del FILE.
Proprietà pubblica | HasCod_Id | Restituisce se è presente la codifica del DEDID. (Ereditato da DedTypeBase)
Proprietà pubblica | HasCompCod | Restituisce se è presente la codifica del CODICE.
Proprietà pubblica | HasDwgPath | Restituisce se è il percorso di archiviazione.
Proprietà pubblica | HasInfoUser | Restiutuisce se la famiglia ha il tassello utente o la variante automatica nell'id. (Ereditato da DedTypeBase)
Proprietà pubblica | HasMaster | Restituisce se è presente il master (Ereditato da DedTypeBase)
Proprietà pubblica | HasParent | Restituisce se è presente un oggetto genitore. (Ereditato da DedTypeBase)
Proprietà pubblica | HasPerm | Restituisce se sono presenti attributi specifici della famiglia.
Proprietà pubblica | HasProgr | Restituisce se la famiglia ha il progressivo locale impostato e non lo eredita (MyProgr> -1). (Ereditato da DedTypeBase)
Proprietà pubblica | HasProgrAlphabet | Restituisce se è presente l'alfabeto del progressivo. (Ereditato da DedTypeBase)
Proprietà pubblica | HasRevisionAlphabet | Restituisce se è presente l'alfabeto della revisione. (Ereditato da DedTypeBase)
Proprietà pubblica | HasRules | Restituisce se sono presenti regole di autocomposizione specifiche della famiglia. (Ereditato da DedTypeBase)
Proprietà pubblica | HasSubTypes | Restituisce se sono presenti sottotipi della famiglia. (Ereditato da DedTypeBase)
Proprietà pubblica | HasVar | Restiutuisce se la famiglia ha la variante automatica nell'id. (Ereditato da DedTypeBase)
Proprietà pubblica | HasVarAlphabet | Restituisce se è presente l'alfabeto del progressivo. (Ereditato da DedTypeBase)
Proprietà pubblica | IsCompleted | Restituisce se la famiglia è completa ovvero può essere utilizzata come famiglia terminale di codifica. (Sovrascrive DedTypeBaseIsCompleted)
Proprietà pubblica | IsPrj | Restituisce se si tratti di una famiglia di tipo progetto (eventualmente ereditato). (Ereditato da DedTypeBase)
Proprietà pubblica | IsRevNewType | Restituisce true se questa famiglia non ha il tassello della revisione nel nome file oppure se è FreeFile. Negli altri casi restituisce false.
Proprietà pubblica | IsRoot | Restituisce se si tratta della root dell'albero dei tipi. (Ereditato da DedTypeBase)
Proprietà pubblica | Level | Restituisce il livello di questa famiglia, partendo da 0 per la famiglia root. (Ereditato da DedTypeBase)
Proprietà pubblica | Master | Identifica il master collegato alla tipologia (Ereditato da DedTypeBase)
Proprietà pubblica | MyAttributes | Restituisce la lista di attributi abbinati a questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota. (Sovrascrive DedTypeBaseMyAttributes)
Proprietà pubblica | MyAttributesSparePart | Restituisce la lista di attributi abbinati a questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota.
Proprietà pubblica | MyAttributesWithoutSparePart | Restituisce la lista di attributi abbinati a questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota.
Proprietà pubblica | MyCascade | Restituisce il dizionario di cascate della famiglia. Se non ce ne sono viene restituito un dizionario inizializzato ma vuoto.
Proprietà pubblica | MyCod_Dis | Restituisce/Imposta la maschera di codifica per DED_DIS di questa famiglia.
Proprietà pubblica | MyCod_Fil | Restituisce/Imposta la maschera di codifica per DED_FILE di questa famiglia.
Proprietà pubblica | MyCod_Id | Restituisce/Imposta la maschera di codifica per DED_ID di questa famiglia. (Ereditato da DedTypeBase)
Proprietà pubblica | MyCompCode | Restituisce/Imposta la modalità di compilazione del DED_COD di questa famiglia.
Proprietà pubblica | MyDwgPath | Restituisce/Imposta il percorso di salvataggio di questa famiglia.
Proprietà pubblica | MyIsPrj | Restituisce/Imposta se si tratti di una famiglia di tipo progetto (questa famiglia). (Ereditato da DedTypeBase)
Proprietà pubblica | MyMaster | Identifica il master collegato alla tipologia (Ereditato da DedTypeBase)
Proprietà pubblica | MyProgr | Restituisce/Imposta il valore del progressivo strettamente di questa famiglia. Non interroga il Database ma restituisce il valore della cache. (Ereditato da DedTypeBase)
Proprietà pubblica | MyProgrAlphabet | Restituisce/Imposta l'alfabeto per il progressivo di questa famiglia. (Ereditato da DedTypeBase)
Proprietà pubblica | MyRevisionAlphabet | Restituisce/Imposta l'alfabeto per il progressivo di questa famiglia. (Ereditato da DedTypeBase)
Proprietà pubblica | MyRules | Restituisce la lista delle regole di autocomposizione di questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota. (Ereditato da DedTypeBase)
Proprietà pubblica | MyVarAlphabet | Restituisce/Imposta l'alfabeto per la variante di questa famiglia. (Ereditato da DedTypeBase)
Proprietà pubblica | Nome | Restituisce/Imposta il nome della famiglia. (Ereditato da DedTypeBase)
Proprietà pubblica | OldDwgPath | Restituisce la directory di salvataggio originaria di questa famiglia. Nel caso di cambio nome si salva il percorso originale per la gestione dei permessi.
Proprietà pubblica | Parent | Restituisce la collezione di appartenenza. (Ereditato da DedTypeBase)
Proprietà pubblica | Progr | Restituisce il progressivo eventualmente ereditato, se non presente in questa famiglia. (Ereditato da DedTypeBase)
Proprietà pubblica | ProgrAlphabet | Restituisce l'alfabeto per la variante di questa famiglia. Restitusice l'alfabeto ereditato se non è impostato per questa famiglia. (Ereditato da DedTypeBase)
Proprietà pubblica | ReservedProgTableName | Tabella relativa ai progressivi riservati (Sovrascrive DedTypeBaseReservedProgTableName)
Proprietà pubblica | RevisionAlphabet | Restituisce l'alfabeto per il progressivo di questa famiglia. Restitusice l'alfabeto ereditato se non è impostato per questa famiglia. (Ereditato da DedTypeBase)
Proprietà pubblica | Root | Restituisce la famiglia Root della collezione (Sovrascrive DedTypeBaseRoot)
Proprietà pubblica | RuleDirty | Restituisce se sono state modificate le regole. (Ereditato da DedTypeBase)
Proprietà pubblica | Rules | Restituisce la lista delle regole di autocomposizione visibili da questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota. (Ereditato da DedTypeBase)
Proprietà pubblica | RuleTableName | Tabella relativa alle regole dell'oggetto (Sovrascrive DedTypeBaseRuleTableName)
Proprietà pubblica | StatoRecord | Restituisce o imposta lo stato del record. DI USO INTERNO !! (Ereditato da DedTypeBase)
Proprietà pubblica | SubTypes | Restituisce la lista delle sottofamiglie di questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota. (Sovrascrive DedTypeBaseSubTypes)
Proprietà pubblica | TableName | Tabella relativa all'oggetto (Sovrascrive DedTypeBaseTableName)
Proprietà pubblica | TypeDirty | Restituisce se sono state modificate le famiglie. (Ereditato da DedTypeBase)
Proprietà pubblica | VarAlphabet | Restituisce l'alfabeto per il progressivo di questa famiglia. Restitusice l'alfabeto ereditato se non è impostato per questa famiglia. (Ereditato da DedTypeBase)
Torna su
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Proprietà DedType.AttributeAnagrAlterTable

Proprietà DedTypeAttributeAnagrAlterTable
Restituisce se sono state modificati gli attributi di anagrafica e necessitano alter table.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AttributeAnagrAlterTable { get; }
Public ReadOnly Property AttributeAnagrAlterTable As Boolean
    Get
public:
property bool AttributeAnagrAlterTable {
    bool get ();
}
member AttributeAnagrAlterTable : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Proprietà DedType.AttributeBomAlterTable

Proprietà DedTypeAttributeBomAlterTable
Restituisce se sono state modificati gli attributi di distinta e necessitano alter table.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AttributeBomAlterTable { get; }
Public ReadOnly Property AttributeBomAlterTable As Boolean
    Get
public:
property bool AttributeBomAlterTable {
    bool get ();
}
member AttributeBomAlterTable : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Proprietà DedType.AttributeCommAlterTable

Proprietà DedTypeAttributeCommAlterTable
Restituisce se sono state modificati gli attributi di commessa e necessitano alter table.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AttributeCommAlterTable { get; }
Public ReadOnly Property AttributeCommAlterTable As Boolean
    Get
public:
property bool AttributeCommAlterTable {
    bool get ();
}
member AttributeCommAlterTable : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Proprietà DedType.AttributeCommAnagrAlterTable

Proprietà DedTypeAttributeCommAnagrAlterTable
Restituisce se sono state modificati gli attributi di anagrafica di commessa e necessitano alter table.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AttributeCommAnagrAlterTable { get; }
Public ReadOnly Property AttributeCommAnagrAlterTable As Boolean
    Get
public:
property bool AttributeCommAnagrAlterTable {
    bool get ();
}
member AttributeCommAnagrAlterTable : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Proprietà DedType.AttributeDedIdOrDedRevDirty

Proprietà DedTypeAttributeDedIdOrDedRevDirty
Restituisce se sono state modificati gli attributi DEDID o DEDREV.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AttributeDedIdOrDedRevDirty { get; }
Public ReadOnly Property AttributeDedIdOrDedRevDirty As Boolean
    Get
public:
property bool AttributeDedIdOrDedRevDirty {
    bool get ();
}
member AttributeDedIdOrDedRevDirty : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Proprietà DedType.AttributeDirty

Proprietà DedTypeAttributeDirty
Restituisce se sono state modificati gli attributi.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AttributeDirty { get; }
Public ReadOnly Property AttributeDirty As Boolean
    Get
public:
property bool AttributeDirty {
    bool get ();
}
member AttributeDirty : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Proprietà DedType.AttributeDocAlterTable

Proprietà DedTypeAttributeDocAlterTable
Restituisce se sono state modificati gli attributi di documento e necessitano alter table.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AttributeDocAlterTable { get; }
Public ReadOnly Property AttributeDocAlterTable As Boolean
    Get
public:
property bool AttributeDocAlterTable {
    bool get ();
}
member AttributeDocAlterTable : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Proprietà DedType.AttributeEcoAlterTable

Proprietà DedTypeAttributeEcoAlterTable
Restituisce se sono state modificati gli attributi di ECO e necessitano alter table.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AttributeEcoAlterTable { get; }
Public ReadOnly Property AttributeEcoAlterTable As Boolean
    Get
public:
property bool AttributeEcoAlterTable {
    bool get ();
}
member AttributeEcoAlterTable : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Proprietà DedType.Attributes

Proprietà DedTypeAttributes
Restituisce la lista di attributi di ricambio visibili da questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota. Attenzione! Viene istanziato un nuovo DedAttrList ogni volta che si accede a questa proprietà.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override DedAttrList Attributes { get; }
Public Overrides ReadOnly Property Attributes As DedAttrList
    Get
public:
virtual property DedAttrList^ Attributes {
    DedAttrList^ get () override;
}
abstract Attributes : DedAttrList with get
override Attributes : DedAttrList with get

Valore della proprietà

DedAttrList
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Proprietà DedType.AttributesAnagrafica

Proprietà DedTypeAttributesAnagrafica
Restituisce la lista di attributi di anagrafica visibili da questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList AttributesAnagrafica { get; }
Public ReadOnly Property AttributesAnagrafica As DedAttrList
    Get
public:
property DedAttrList^ AttributesAnagrafica {
    DedAttrList^ get ();
}
member AttributesAnagrafica : DedAttrList with get

Valore della proprietà

DedAttrList
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Proprietà DedType.AttributesAnagraficaOccorrenza

Proprietà DedTypeAttributesAnagraficaOccorrenza
Restituisce la lista di attributi di anagrafica e occorrenza visibili da questa famiglia. Nel caso di attributi con stesso nome vengono considerati buoni quelli di occorrenza. Se non ce ne sono viene restituita una lista inizializzata ma vuota.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList AttributesAnagraficaOccorrenza { get; }
Public ReadOnly Property AttributesAnagraficaOccorrenza As DedAttrList
    Get
public:
property DedAttrList^ AttributesAnagraficaOccorrenza {
    DedAttrList^ get ();
}
member AttributesAnagraficaOccorrenza : DedAttrList with get

Valore della proprietà

DedAttrList
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Proprietà DedType.AttributesAnagraficaWithChild

Proprietà DedTypeAttributesAnagraficaWithChild
Restituisce la lista di attributi di anagrafica visibili da questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList AttributesAnagraficaWithChild { get; }
Public ReadOnly Property AttributesAnagraficaWithChild As DedAttrList
    Get
public:
property DedAttrList^ AttributesAnagraficaWithChild {
    DedAttrList^ get ();
}
member AttributesAnagraficaWithChild : DedAttrList with get

Valore della proprietà

DedAttrList
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Proprietà DedType.AttributesAnagrDist

Proprietà DedTypeAttributesAnagrDist
Restituisce la lista di attributi di anagrafica e di distinta visibili da questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList AttributesAnagrDist { get; }
Public ReadOnly Property AttributesAnagrDist As DedAttrList
    Get
public:
property DedAttrList^ AttributesAnagrDist {
    DedAttrList^ get ();
}
member AttributesAnagrDist : DedAttrList with get

Valore della proprietà

DedAttrList
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Proprietà DedType.AttributesAnagrDistOcc

Proprietà DedTypeAttributesAnagrDistOcc
Restituisce la lista di attributi di anagrafica, distinta e occorrenza visibili da questa famiglia. Nel caso di attributi con stesso nome vengono considerati buoni quelli di occorrenza. Se non ce ne sono viene restituita una lista inizializzata ma vuota.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList AttributesAnagrDistOcc { get; }
Public ReadOnly Property AttributesAnagrDistOcc As DedAttrList
    Get
public:
property DedAttrList^ AttributesAnagrDistOcc {
    DedAttrList^ get ();
}
member AttributesAnagrDistOcc : DedAttrList with get

Valore della proprietà

DedAttrList
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Proprietà DedType.AttributesAnagrDoc

Proprietà DedTypeAttributesAnagrDoc
Restituisce la lista di attributi di anagrafica e di documento visibili da questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList AttributesAnagrDoc { get; }
Public ReadOnly Property AttributesAnagrDoc As DedAttrList
    Get
public:
property DedAttrList^ AttributesAnagrDoc {
    DedAttrList^ get ();
}
member AttributesAnagrDoc : DedAttrList with get

Valore della proprietà

DedAttrList
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Proprietà DedType.AttributesAnagrDocOcc

Proprietà DedTypeAttributesAnagrDocOcc
Restituisce la lista di attributi di anagrafica, documento e occorrenza visibili da questa famiglia. Nel caso di attributi con stesso nome vengono considerati buoni quelli di occorrenza. Se non ce ne sono viene restituita una lista inizializzata ma vuota.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList AttributesAnagrDocOcc { get; }
Public ReadOnly Property AttributesAnagrDocOcc As DedAttrList
    Get
public:
property DedAttrList^ AttributesAnagrDocOcc {
    DedAttrList^ get ();
}
member AttributesAnagrDocOcc : DedAttrList with get

Valore della proprietà

DedAttrList
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Proprietà DedType.AttributesDistinta

Proprietà DedTypeAttributesDistinta
Restituisce la lista di attributi di distinta visibili da questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList AttributesDistinta { get; }
Public ReadOnly Property AttributesDistinta As DedAttrList
    Get
public:
property DedAttrList^ AttributesDistinta {
    DedAttrList^ get ();
}
member AttributesDistinta : DedAttrList with get

Valore della proprietà

DedAttrList
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Proprietà DedType.AttributesDistintaOccorrenza

Proprietà DedTypeAttributesDistintaOccorrenza
Restituisce la lista di attributi di distinta e occorrenza visibili da questa famiglia. Nel caso di attributi con stesso nome vengono considerati buoni quelli di occorrenza. Se non ce ne sono viene restituita una lista inizializzata ma vuota.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList AttributesDistintaOccorrenza { get; }
Public ReadOnly Property AttributesDistintaOccorrenza As DedAttrList
    Get
public:
property DedAttrList^ AttributesDistintaOccorrenza {
    DedAttrList^ get ();
}
member AttributesDistintaOccorrenza : DedAttrList with get

Valore della proprietà

DedAttrList
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Proprietà DedType.AttributesDocumento

Proprietà DedTypeAttributesDocumento
Restituisce la lista di attributi di documento visibili da questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList AttributesDocumento { get; }
Public ReadOnly Property AttributesDocumento As DedAttrList
    Get
public:
property DedAttrList^ AttributesDocumento {
    DedAttrList^ get ();
}
member AttributesDocumento : DedAttrList with get

Valore della proprietà

DedAttrList
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Proprietà DedType.AttributesDocumentoOccorrenza

Proprietà DedTypeAttributesDocumentoOccorrenza
Restituisce la lista di attributi di documento e occorrenza visibili da questa famiglia. Nel caso di attributi con stesso nome vengono considerati buoni quelli di occorrenza. Se non ce ne sono viene restituita una lista inizializzata ma vuota.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList AttributesDocumentoOccorrenza { get; }
Public ReadOnly Property AttributesDocumentoOccorrenza As DedAttrList
    Get
public:
property DedAttrList^ AttributesDocumentoOccorrenza {
    DedAttrList^ get ();
}
member AttributesDocumentoOccorrenza : DedAttrList with get

Valore della proprietà

DedAttrList
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Proprietà DedType.AttributesOccorrenza

Proprietà DedTypeAttributesOccorrenza
Restituisce la lista di attributi di occorrenza visibili da questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList AttributesOccorrenza { get; }
Public ReadOnly Property AttributesOccorrenza As DedAttrList
    Get
public:
property DedAttrList^ AttributesOccorrenza {
    DedAttrList^ get ();
}
member AttributesOccorrenza : DedAttrList with get

Valore della proprietà

DedAttrList
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Proprietà DedType.AttributesRequired

Proprietà DedTypeAttributesRequired
Restituisce la lista di attributi obbligatori di questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList AttributesRequired { get; }
Public ReadOnly Property AttributesRequired As DedAttrList
    Get
public:
property DedAttrList^ AttributesRequired {
    DedAttrList^ get ();
}
member AttributesRequired : DedAttrList with get

Valore della proprietà

DedAttrList
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Proprietà DedType.AttributesSparePart

Proprietà DedTypeAttributesSparePart
Restituisce la lista di attributi visibili da questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList AttributesSparePart { get; }
Public ReadOnly Property AttributesSparePart As DedAttrList
    Get
public:
property DedAttrList^ AttributesSparePart {
    DedAttrList^ get ();
}
member AttributesSparePart : DedAttrList with get

Valore della proprietà

DedAttrList
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Proprietà DedType.AttributesWithOccurrence

Proprietà DedTypeAttributesWithOccurrence
Restituisce la lista di attributi visibili da questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList AttributesWithOccurrence { get; }
Public ReadOnly Property AttributesWithOccurrence As DedAttrList
    Get
public:
property DedAttrList^ AttributesWithOccurrence {
    DedAttrList^ get ();
}
member AttributesWithOccurrence : DedAttrList with get

Valore della proprietà

DedAttrList
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Proprietà DedType.AttributesWithoutSparePart

Proprietà DedTypeAttributesWithoutSparePart
Restituisce la lista di attributi visibili da questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList AttributesWithoutSparePart { get; }
Public ReadOnly Property AttributesWithoutSparePart As DedAttrList
    Get
public:
property DedAttrList^ AttributesWithoutSparePart {
    DedAttrList^ get ();
}
member AttributesWithoutSparePart : DedAttrList with get

Valore della proprietà

DedAttrList
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Proprietà DedType.Cascade

Proprietà DedTypeCascade
Restituisce la lista di cascate della famiglia e di quelle ereditate dalle famiglie superiori. Se non ce ne sono viene restituita una lista inizializzata ma vuota.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCascadeList Cascade { get; }
Public ReadOnly Property Cascade As DedCascadeList
    Get
public:
property DedCascadeList^ Cascade {
    DedCascadeList^ get ();
}
member Cascade : DedCascadeList with get

Valore della proprietà

DedCascadeList
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Proprietà DedType.CascadeDizDirty

Proprietà DedTypeCascadeDizDirty
Ritorna true se il dizionario delle cascate è dirty.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CascadeDizDirty { get; }
Public ReadOnly Property CascadeDizDirty As Boolean
    Get
public:
property bool CascadeDizDirty {
    bool get ();
}
member CascadeDizDirty : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Proprietà DedType.Cod_Dis

Proprietà DedTypeCod_Dis
Restituisce la maschera di codifica per DED_DIS, eventualmente ereditata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Cod_Dis { get; }
Public ReadOnly Property Cod_Dis As String
    Get
public:
property String^ Cod_Dis {
    String^ get ();
}
member Cod_Dis : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Proprietà DedType.Cod_Fil

Proprietà DedTypeCod_Fil
Restituisce la maschera di codifica per DED_FILE, eventualmente ereditata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Cod_Fil { get; }
Public ReadOnly Property Cod_Fil As String
    Get
public:
property String^ Cod_Fil {
    String^ get ();
}
member Cod_Fil : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Proprietà DedType.CompCode

Proprietà DedTypeCompCode
Restituisce la modalità di compilazione del DED_COD, eventualmente ereditata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeCompCodeEnum CompCode { get; }
Public ReadOnly Property CompCode As DedTypeCompCodeEnum
    Get
public:
property DedTypeCompCodeEnum CompCode {
    DedTypeCompCodeEnum get ();
}
member CompCode : DedTypeCompCodeEnum with get

Valore della proprietà

DedTypeCompCodeEnum
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Proprietà DedType.DefaultDwgPath

Proprietà DedTypeDefaultDwgPath
Restitusice il percorso di salvataggio calcolato in base alla famiglia padre.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string DefaultDwgPath { get; }
Public ReadOnly Property DefaultDwgPath As String
    Get
public:
property String^ DefaultDwgPath {
    String^ get ();
}
member DefaultDwgPath : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Proprietà DedType.Dirty

Proprietà DedTypeDirty
Restituisce se l'oggetto sia stato modificato oppure se sia stata modificata una delle sue collezioni.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Dirty { get; }
Public Overrides ReadOnly Property Dirty As Boolean
    Get
public:
virtual property bool Dirty {
    bool get () override;
}
abstract Dirty : bool with get
override Dirty : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Proprietà DedType.DwgPath

Proprietà DedTypeDwgPath
Restituisce la directory di salvataggio di questa famiglia. Restitusice il percorso ereditato se non è impostato per questa famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string DwgPath { get; }
Public ReadOnly Property DwgPath As String
    Get
public:
property String^ DwgPath {
    String^ get ();
}
member DwgPath : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Proprietà DedType.FreeFile

Proprietà DedTypeFreeFile
Restituisce/Imposta se la famiglia è a codifica file libera.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool FreeFile { get; set; }
Public Overrides Property FreeFile As Boolean
    Get
    Set
public:
virtual property bool FreeFile {
    bool get () override;
    void set (bool value) override;
}
abstract FreeFile : bool with get, set
override FreeFile : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Proprietà DedType.FreeFileAsDedId

Proprietà DedTypeFreeFileAsDedId
Restituisce/Imposta se il file debba essere compilato come l'id.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool FreeFileAsDedId { get; set; }
Public Overrides Property FreeFileAsDedId As Boolean
    Get
    Set
public:
virtual property bool FreeFileAsDedId {
    bool get () override;
    void set (bool value) override;
}
abstract FreeFileAsDedId : bool with get, set
override FreeFileAsDedId : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Proprietà DedType.FreeFileSameFileRev

Proprietà DedTypeFreeFileSameFileRev
Restituisce/Imposta se il file debba rimanere uguale anche nelle revisioni.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool FreeFileSameFileRev { get; set; }
Public Overrides Property FreeFileSameFileRev As Boolean
    Get
    Set
public:
virtual property bool FreeFileSameFileRev {
    bool get () override;
    void set (bool value) override;
}
abstract FreeFileSameFileRev : bool with get, set
override FreeFileSameFileRev : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Proprietà DedType.FreeFileType

Proprietà DedTypeFreeFileType
Restituisce la tipologia di freefile di questa famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeFreeFileEnum FreeFileType { get; }
Public ReadOnly Property FreeFileType As DedTypeFreeFileEnum
    Get
public:
property DedTypeFreeFileEnum FreeFileType {
    DedTypeFreeFileEnum get ();
}
member FreeFileType : DedTypeFreeFileEnum with get

Valore della proprietà

DedTypeFreeFileEnum
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Proprietà DedType.HasAttributes

Proprietà DedTypeHasAttributes
Restituisce se sono presenti attributi (ricambio e non ) specifici della famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool HasAttributes { get; }
Public Overrides ReadOnly Property HasAttributes As Boolean
    Get
public:
virtual property bool HasAttributes {
    bool get () override;
}
abstract HasAttributes : bool with get
override HasAttributes : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Proprietà DedType.HasAttributesSparePart

Proprietà DedTypeHasAttributesSparePart
Restituisce se sono presenti attributi di ricambio specifici della famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasAttributesSparePart { get; }
Public ReadOnly Property HasAttributesSparePart As Boolean
    Get
public:
property bool HasAttributesSparePart {
    bool get ();
}
member HasAttributesSparePart : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Proprietà DedType.HasAttributesWithoutSparePart

Proprietà DedTypeHasAttributesWithoutSparePart
Restituisce se sono presenti attributi non di ricambio specifici della famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasAttributesWithoutSparePart { get; }
Public ReadOnly Property HasAttributesWithoutSparePart As Boolean
    Get
public:
property bool HasAttributesWithoutSparePart {
    bool get ();
}
member HasAttributesWithoutSparePart : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Proprietà DedType.HasCascades

Proprietà DedTypeHasCascades
Restituisce se sono presenti cascate nella famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasCascades { get; }
Public ReadOnly Property HasCascades As Boolean
    Get
public:
property bool HasCascades {
    bool get ();
}
member HasCascades : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Proprietà DedType.HasCod_Dis

Proprietà DedTypeHasCod_Dis
Restituisce se è presente la codifica del DED_DIS.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasCod_Dis { get; }
Public ReadOnly Property HasCod_Dis As Boolean
    Get
public:
property bool HasCod_Dis {
    bool get ();
}
member HasCod_Dis : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Proprietà DedType.HasCod_File

Proprietà DedTypeHasCod_File
Restituisce se è presente la codifica del FILE.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasCod_File { get; }
Public ReadOnly Property HasCod_File As Boolean
    Get
public:
property bool HasCod_File {
    bool get ();
}
member HasCod_File : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Proprietà DedType.HasCompCod

Proprietà DedTypeHasCompCod
Restituisce se è presente la codifica del CODICE.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasCompCod { get; }
Public ReadOnly Property HasCompCod As Boolean
    Get
public:
property bool HasCompCod {
    bool get ();
}
member HasCompCod : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Proprietà DedType.HasDwgPath

Proprietà DedTypeHasDwgPath
Restituisce se è il percorso di archiviazione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasDwgPath { get; }
Public ReadOnly Property HasDwgPath As Boolean
    Get
public:
property bool HasDwgPath {
    bool get ();
}
member HasDwgPath : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Proprietà DedType.HasPerm

Proprietà DedTypeHasPerm
Restituisce se sono presenti attributi specifici della famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasPerm { get; }
Public ReadOnly Property HasPerm As Boolean
    Get
public:
property bool HasPerm {
    bool get ();
}
member HasPerm : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Proprietà DedType.IsCompleted

Proprietà DedTypeIsCompleted
Restituisce se la famiglia è completa ovvero può essere utilizzata come famiglia terminale di codifica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool IsCompleted { get; }
Public Overrides ReadOnly Property IsCompleted As Boolean
    Get
public:
virtual property bool IsCompleted {
    bool get () override;
}
abstract IsCompleted : bool with get
override IsCompleted : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Proprietà DedType.IsRevNewType

Proprietà DedTypeIsRevNewType
Restituisce true se questa famiglia non ha il tassello della revisione nel nome file oppure se è FreeFile. Negli altri casi restituisce false.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsRevNewType { get; }
Public ReadOnly Property IsRevNewType As Boolean
    Get
public:
property bool IsRevNewType {
    bool get ();
}
member IsRevNewType : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Proprietà DedType.MyAttributes

Proprietà DedTypeMyAttributes
Restituisce la lista di attributi abbinati a questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override DedAttrList MyAttributes { get; }
Public Overrides ReadOnly Property MyAttributes As DedAttrList
    Get
public:
virtual property DedAttrList^ MyAttributes {
    DedAttrList^ get () override;
}
abstract MyAttributes : DedAttrList with get
override MyAttributes : DedAttrList with get

Valore della proprietà

DedAttrList
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Proprietà DedType.MyAttributesSparePart

Proprietà DedTypeMyAttributesSparePart
Restituisce la lista di attributi abbinati a questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrCollection MyAttributesSparePart { get; }
Public ReadOnly Property MyAttributesSparePart As DedAttrCollection
    Get
public:
property DedAttrCollection^ MyAttributesSparePart {
    DedAttrCollection^ get ();
}
member MyAttributesSparePart : DedAttrCollection with get

Valore della proprietà

DedAttrCollection
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Proprietà DedType.MyAttributesWithoutSparePart

Proprietà DedTypeMyAttributesWithoutSparePart
Restituisce la lista di attributi abbinati a questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrCollection MyAttributesWithoutSparePart { get; }
Public ReadOnly Property MyAttributesWithoutSparePart As DedAttrCollection
    Get
public:
property DedAttrCollection^ MyAttributesWithoutSparePart {
    DedAttrCollection^ get ();
}
member MyAttributesWithoutSparePart : DedAttrCollection with get

Valore della proprietà

DedAttrCollection
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Proprietà DedType.MyCascade

Proprietà DedTypeMyCascade
Restituisce il dizionario di cascate della famiglia. Se non ce ne sono viene restituito un dizionario inizializzato ma vuoto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCascadeDictionary MyCascade { get; }
Public ReadOnly Property MyCascade As DedCascadeDictionary
    Get
public:
property DedCascadeDictionary^ MyCascade {
    DedCascadeDictionary^ get ();
}
member MyCascade : DedCascadeDictionary with get

Valore della proprietà

DedCascadeDictionary
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Proprietà DedType.MyCod_Dis

Proprietà DedTypeMyCod_Dis
Restituisce/Imposta la maschera di codifica per DED_DIS di questa famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string MyCod_Dis { get; set; }
Public Property MyCod_Dis As String
    Get
    Set
public:
property String^ MyCod_Dis {
    String^ get ();
    void set (String^ value);
}
member MyCod_Dis : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Proprietà DedType.MyCod_Fil

Proprietà DedTypeMyCod_Fil
Restituisce/Imposta la maschera di codifica per DED_FILE di questa famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string MyCod_Fil { get; set; }
Public Property MyCod_Fil As String
    Get
    Set
public:
property String^ MyCod_Fil {
    String^ get ();
    void set (String^ value);
}
member MyCod_Fil : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Proprietà DedType.MyCompCode

Proprietà DedTypeMyCompCode
Restituisce/Imposta la modalità di compilazione del DED_COD di questa famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeCompCodeEnum MyCompCode { get; set; }
Public Property MyCompCode As DedTypeCompCodeEnum
    Get
    Set
public:
property DedTypeCompCodeEnum MyCompCode {
    DedTypeCompCodeEnum get ();
    void set (DedTypeCompCodeEnum value);
}
member MyCompCode : DedTypeCompCodeEnum with get, set

Valore della proprietà

DedTypeCompCodeEnum
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Proprietà DedType.MyDwgPath

Proprietà DedTypeMyDwgPath
Restituisce/Imposta il percorso di salvataggio di questa famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string MyDwgPath { get; set; }
Public Property MyDwgPath As String
    Get
    Set
public:
property String^ MyDwgPath {
    String^ get ();
    void set (String^ value);
}
member MyDwgPath : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Proprietà DedType.OldDwgPath

Proprietà DedTypeOldDwgPath
Restituisce la directory di salvataggio originaria di questa famiglia. Nel caso di cambio nome si salva il percorso originale per la gestione dei permessi.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string OldDwgPath { get; set; }
Public Property OldDwgPath As String
    Get
    Set
public:
property String^ OldDwgPath {
    String^ get ();
    void set (String^ value);
}
member OldDwgPath : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Proprietà DedType.ReservedProgTableName

Proprietà DedTypeReservedProgTableName
Tabella relativa ai progressivi riservati

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string ReservedProgTableName { get; }
Public Overrides ReadOnly Property ReservedProgTableName As String
    Get
public:
virtual property String^ ReservedProgTableName {
    String^ get () override;
}
abstract ReservedProgTableName : string with get
override ReservedProgTableName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Proprietà DedType.Root

Proprietà DedTypeRoot
Restituisce la famiglia Root della collezione

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override DedTypeBase Root { get; }
Public Overrides ReadOnly Property Root As DedTypeBase
    Get
public:
virtual property DedTypeBase^ Root {
    DedTypeBase^ get () override;
}
abstract Root : DedTypeBase with get
override Root : DedTypeBase with get

Valore della proprietà

DedTypeBase
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Proprietà DedType.RuleTableName

Proprietà DedTypeRuleTableName
Tabella relativa alle regole dell'oggetto

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string RuleTableName { get; }
Public Overrides ReadOnly Property RuleTableName As String
    Get
public:
virtual property String^ RuleTableName {
    String^ get () override;
}
abstract RuleTableName : string with get
override RuleTableName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Proprietà DedType.SubTypes

Proprietà DedTypeSubTypes
Restituisce la lista delle sottofamiglie di questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override Object SubTypes { get; }
Public Overrides ReadOnly Property SubTypes As Object
    Get
public:
virtual property Object^ SubTypes {
    Object^ get () override;
}
abstract SubTypes : Object with get
override SubTypes : Object with get

Valore della proprietà

Object
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Proprietà DedType.TableName

Proprietà DedTypeTableName
Tabella relativa all'oggetto

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string TableName { get; }
Public Overrides ReadOnly Property TableName As String
    Get
public:
virtual property String^ TableName {
    String^ get () override;
}
abstract TableName : string with get
override TableName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Metodi di DedType

Il tipo DedType espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AddOccurenceAttrs | Aggiunge i documenti di occorrenza a quelli passati, sostituendoli nel caso di Nome corriposndente.
Metodo pubblico | Clone | Metodo per clonare la famiglia.
Metodo pubblico | CreateData(String, String, String, String) | Crea una nuova anagrafica associata a questa famiglia e la restituisce. Il chiamante deve successivamente inserire tutti i valori rimanenti all'interno dell'anagrafica ed aggiornarla nel Database tramite un Update(). Oltre ai campi che vengono passati come argomento, vengono precompilati anche: DEDLOCK, DEDROWVER, DEDUSER, DEDDATE, DEDMODUSER, DEDMODDATE, DEDSTATEUSER, DEDSTATEDATE e DEDSTATEID. Restituisce l'anagrafica già loccata dall'utente corrente e che necessita di un Update(), oppure solleva un'eccezione se avvengono degli errori.
Metodo pubblico | CreateData(String, String, String, String, Boolean) | Crea una nuova anagrafica associata a questa famiglia e la restituisce. Il chiamante deve successivamente inserire tutti i valori rimanenti all'interno dell'anagrafica ed aggiornarla nel Database tramite un Update(). Oltre ai campi che vengono passati come argomento, vengono precompilati anche: DEDLOCK, DEDROWVER, DEDUSER, DEDDATE, DEDMODUSER, DEDMODDATE, DEDSTATEUSER, DEDSTATEDATE e DEDSTATEID. Restituisce l'anagrafica già loccata dall'utente corrente e che necessita di un Update(), oppure solleva un'eccezione se avvengono degli errori.
Metodo pubblico | DecodeDedDis | Decodifica una stinga come DED_DIS appartenente a questa famiglia, restituendo un oggetto descrittivo della codifica.
Metodo pubblico | DecodeDedFile | Decodifica una stinga come file di default per i file primari di questa famiglia, restituendo un oggetto descrittivo della codifica.
Metodo pubblico | DecodeDedId(String) | Decodifica una stinga come DEDID appartenente a questa famiglia, restituendo un oggetto descrittivo della codifica. (Sovrascrive DedTypeBaseDecodeDedId(String))
Metodo pubblico | DecodeDedId(String, String) | Decodifica una stinga come DEDID appartenente a questa famiglia, restituendo un oggetto descrittivo della codifica. (Sovrascrive DedTypeBaseDecodeDedId(String, String))
Metodo pubblico | EncodeDedDis | Inserisce nelle info passate questa stessa famiglia e poi crea e restituisce il DED_DIS corrispondente alla maschera di codifica presente o ereditata da questa famiglia.
Metodo pubblico | EncodeDedFile | Inserisce nelle info passate questa stessa famiglia e poi crea e restituisce il nome file di default per i file primari, corrispondente alla maschera di codifica presente o ereditata da questa famiglia.
Metodo pubblico | EncodeDedId(DedEncodeInfo) | Inserisce nelle info passate questa stessa famiglia e poi crea e restituisce il DEDID corrispondente alla maschera di codifica presente o ereditata da questa famiglia. (Sovrascrive DedTypeBaseEncodeDedId(DedEncodeInfo))
Metodo pubblico | EncodeDedId(DedEncodeInfo, DedData) | Inserisce nelle info passate questa stessa famiglia e poi crea e restituisce il DEDID corrispondente alla maschera di codifica presente o ereditata da questa famiglia.
Metodo pubblico | EncodePath | Inserisce nelle info passate questa stessa famiglia e poi crea e restituisce il percorso di archiviazione di default presente o ereditato da questa famiglia.
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | FindAttrByName | Cerca un attributo con un determinato nome tra gli attributi visibili da questa famiglia. Restitusice null se non lo trova. (Sovrascrive DedTypeBaseFindAttrByName(String))
Metodo pubblico | FindAttrByPrompt | Cerca un attributo con un determinato prompt tra gli attributi visibili da questa famiglia. Restitusice null se non lo trova. (Sovrascrive DedTypeBaseFindAttrByPrompt(String))
Metodo pubblico | FindBusyProgrRecursive | Scorre ricorsivamente tutte le famiglie per conoscere tutti i progressivi utilizzati. (Sovrascrive DedTypeBaseFindBusyProgrRecursive(DedTypeBase, DictionaryString, String, String, DataTable))
Metodo pubblico | FindByDbPath | Cerca il tipo corrispondente al dbpath passato in tutto l'albero partendo dalla radice. (Sovrascrive DedTypeBaseFindByDbPath(String))
Metodo pubblico | FindByDwgPath | Cerca il tipo corrispondente al dbpath passato in tutto l'albero partendo dalla radice.
 | FindCommonDbPath | Restituisce il DbPath comune a tutte le famiglie contenute nella lista di DbPath passata. Restituisce "!" nel caso in cui la lista sia vuota.
Metodo pubblico | ForEachChild | Questo metodo chiama un delegate passandogli in sequenza il nodo corrente (opzionalmente) e tutti i suoi nodi figli. (Ereditato da DedTypeBase)
Metodo pubblico | ForEachParent | Questo metodo chiama un delegate passandogli in sequenza il nodo root e giù fino al nodo corrente (opzionalmente) Lo scorrimento avviene quindi in modo discendente dal padre di tutti verso l'oggetto corrente. (Ereditato da DedTypeBase)
Metodo pubblico | FormatDedRev | Data una stringa di revisione restituisce il valore correttamente formattato e della giusta dimensione per questa famiglia. Es: "1" -> "01" (con rev. di 2 caratteri); "12" -> "012" (con rev. di 3 caratteri); "05" -> "5" (con rev. di 1 carattere); (Ereditato da DedTypeBase)
Metodo pubblico | FormatProgr | Data una stringa di progressivo restituisce il valore correttamente formattato e della giusta dimensione per questa famiglia. Es: "1" -> "001" (progr. di 3 caratteri); "12" -> "012" (progr. di 3 caratteri); "05" -> "5" (progr. di 1 carattere); (Ereditato da DedTypeBase)
Metodo pubblico | FormatVar | Data una stringa della variante restituisce il valore correttamente formattato e della giusta dimensione per questa famiglia. Es: "1" -> "001" (progr. di 3 caratteri); "12" -> "012" (progr. di 3 caratteri); "05" -> "5" (progr. di 1 carattere); (Ereditato da DedTypeBase)
Metodo pubblico | ForOneChild | Questo metodo chiama un delegate passandogli in sequenza il nodo corrente (opzionalmente) e tutti i suoi nodi figli. (Ereditato da DedTypeBase)
Metodo pubblico | GetAllAttrNames | Restituisce la lista di tutti i nomi degli attributi visibili da questa famiglia.
Metodo pubblico | GetAllAttrPrompts | Restituisce la lista di tutti i prompt degli attributi visibili da questa famiglia.
Metodo pubblico | GetAttrNameFromPrompt | Restituisce il nome di un attributo visibile da questa famiglia dato il suo prompt. (Ereditato da DedTypeBase)
Metodo pubblico | GetAttrPromptFromName | Restituisce il prompt di un attributo visibile da questa famiglia dato il suo nome. Restituisce null se non viene trovato.
Metodo pubblico | GetAttrsFromCategory(DedCateg) | Ritorna la lista di attributi visibili dalla famiglia che appartengono alla categoria passata. (Ereditato da DedTypeBase)
Metodo pubblico | GetAttrsFromCategory(String) | Ritorna la lista di attributi visibili dalla famiglia che appartengono alla categoria passata. (Ereditato da DedTypeBase)
Metodo pubblico | GetBusyProgr | Restituisce un dizionario con tutti i progressivi utilizzati. (Ereditato da DedTypeBase)
Metodo pubblico | GetCascadeFromName | Ritorna la cascata che ha come Figlio il nome passato.
Metodo pubblico | GetFamSpecificLevel | Restituisce la famiglia a n° livello. (Ereditato da DedTypeBase)
Metodo pubblico | GetFamSpecificNegativeLevel | Restituisce la famiglia a n° livello negativo. (Ereditato da DedTypeBase)
Metodo pubblico | GetFieldsCod | Restituisce la lista delle stringhe nelle quali cercare i tasselli. (Sovrascrive DedTypeBaseGetFieldsCod)
Metodo pubblico | GetFirstParentHasProg | Restituisce la prima famiglia genitore che ha il progressivo locale.Considera anche il nodo corrente per avere la sicurezza che se viene chiamato su una famiglia con con progressivo impostato non lo calcoli sul padre ma su se stesso. (Ereditato da DedTypeBase)
Metodo pubblico | GetFreeProgr | Restituisce una lista sempre inizializzata e ordinata con tutti i progressivi liberi per questa famiglia. (Ereditato da DedTypeBase)
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | GetLastProgr | Restituisce l'ultimo progressivo possibile per questa famiglia. (Ereditato da DedTypeBase)
Metodo pubblico | GetMaxTokenNum | Restituisce il massimo numero di caratteri usati per il TokenTypeEnum passato. Verifica nella maschera di codifica Cod_Id, Cod_Fil e Cod_Dis in modo da prendere il numero massimo di caratteri utilizzati. (Ereditato da DedTypeBase)
Metodo pubblico | GetNextVar | Calcola il prossimo tassello di variante automatica.
Metodo pubblico | GetParentAttributes | Restituisce la lista degli attributi dei miei genitori.
Metodo pubblico | GetParentTypes | Restituisce una lista dei FamilyType genitori, compresa l'istanza stessa se specificato. (Sovrascrive DedTypeBaseGetParentTypes(Boolean))
Metodo pubblico | GetProgr(Boolean) | Restituisce il progressivo della famiglia che ha invocato il metodo oppure il progressivo della prima famiglia genitore che lo possiede. Lavora sull'utente attualmente connesso ( se deve lavorare in DED_TIPI_PROG ). (Ereditato da DedTypeBase)
Metodo pubblico | GetProgr(Boolean, String) | Restituisce il progressivo della famiglia che ha invocato il metodo oppure il progressivo della prima famiglia genitore che lo possiede (Ereditato da DedTypeBase)
Metodo pubblico | GetProgrTokenNum | Restituisce il numero di caratteri da utilizzare per creare la stringa del progressivo per questa famiglia. Li calcola cercando il tassello del progressivo nella codifica del Cod_Id. Se non è presente restituisce 0. (Ereditato da DedTypeBase)
Metodo pubblico | GetRevDedDisTokenNum | Restituisce il numero di caratteri dedicati alla revisione, presenti nel DED_DIS.
Metodo pubblico | GetRevFileTokenNum | Restituisce il numero di caratteri dedicati alla revisione, presenti nel nome del file COD_FIL. Se si tratta di una famiglia NGR (nuova gestione delle revisioni), restituisce 0, altrimenti il numero di caratteri presenti.
Metodo pubblico | GetRevTokenNum | Restituisce il numero di caratteri da utilizzare per creare la stringa di revisione per questa famiglia. Li calcola cercando il tassello della revisione nella codifica del DED_DIS. Se non è presente qui restituisce il valore presente nella variabile globale del DED
Metodo pubblico | GetRightMask | Restituisce il TokenInfo cercato nella prima maschera di codifica trovata, da utilizzare poi per calcolare il numero di tasselli per un particolare token. Restituisce null se non la trova. (Ereditato da DedTypeBase)
Metodo pubblico | MakeAttrsDictionary | Riempie il dizionario _dizfields. (Ereditato da DedTypeBase)
Metodo pubblico | NotifyDirty | In base al fatto che si tratti della root o meno notifica al parent corretto l'avvenuta modifica della proprietà. (Sovrascrive DedTypeBaseNotifyDirty)
Metodo pubblico | Save | Salva tutta la struttura discendente (da questa in giù) delle famiglie. (Sovrascrive DedTypeBaseSave)
Metodo pubblico | SetProgr(String, String, Boolean) | Imposta il progressivo di questa famiglia o della famiglia dalla quale questa eredita il progressivo. Lavora sull'utente attualmente connesso ( se deve lavorare in DED_TIPI_PROG ). (Ereditato da DedTypeBase)
Metodo pubblico | SetProgr(String, String, Boolean, String) | Imposta il progressivo di questa famiglia o della famiglia dalla quale questa eredita il progressivo. (Ereditato da DedTypeBase)
Metodo pubblico | SetProgr(String, String, Boolean, String, Boolean) | Imposta il progressivo di questa famiglia o della famiglia dalla quale questa eredita il progressivo. (Ereditato da DedTypeBase)
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Metodo pubblico | UserCan(DedStandardPerm) | Verifica se l'utente corrente ha un determinato permesso su questa famiglia.
Metodo pubblico | UserCan(String) | Verifica se l'utente corrente ha un determinato permesso su questa famiglia.
Metodo pubblico | WaitForUpdate | Esegue una query con WITH (XLOCK) in modo da aspettare finchè altri utenti non hanno commitato. (Ereditato da DedTypeBase)
Torna su
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Metodo DedType.AddOccurenceAttrs

Metodo DedTypeAddOccurenceAttrs
Aggiunge i documenti di occorrenza a quelli passati, sostituendoli nel caso di Nome corriposndente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddOccurenceAttrs(
    ref DedAttrList attrlist
)
Public Sub AddOccurenceAttrs (
    ByRef attrlist As DedAttrList
)
public:
void AddOccurenceAttrs(
    DedAttrList^% attrlist
)
member AddOccurenceAttrs :
        attrlist : DedAttrList byref -> unit

Parametri

attrlist DedAttrList
Lista di attributi.
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Metodo DedType.Clone

Metodo DedTypeClone
Metodo per clonare la famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedType Clone(
    DedTypeCollection parent
)
Public Function Clone (
    parent As DedTypeCollection
) As DedType
public:
DedType^ Clone(
    DedTypeCollection^ parent
)
member Clone :
        parent : DedTypeCollection -> DedType

Parametri

parent DedTypeCollection

Valore di ritorno

DedType
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Metodo DedType.CreateData

Metodo DedTypeCreateData
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | CreateData(String, String, String, String) | Crea una nuova anagrafica associata a questa famiglia e la restituisce. Il chiamante deve successivamente inserire tutti i valori rimanenti all'interno dell'anagrafica ed aggiornarla nel Database tramite un Update(). Oltre ai campi che vengono passati come argomento, vengono precompilati anche: DEDLOCK, DEDROWVER, DEDUSER, DEDDATE, DEDMODUSER, DEDMODDATE, DEDSTATEUSER, DEDSTATEDATE e DEDSTATEID. Restituisce l'anagrafica già loccata dall'utente corrente e che necessita di un Update(), oppure solleva un'eccezione se avvengono degli errori.
Metodo pubblico | CreateData(String, String, String, String, Boolean) | Crea una nuova anagrafica associata a questa famiglia e la restituisce. Il chiamante deve successivamente inserire tutti i valori rimanenti all'interno dell'anagrafica ed aggiornarla nel Database tramite un Update(). Oltre ai campi che vengono passati come argomento, vengono precompilati anche: DEDLOCK, DEDROWVER, DEDUSER, DEDDATE, DEDMODUSER, DEDMODDATE, DEDSTATEUSER, DEDSTATEDATE e DEDSTATEID. Restituisce l'anagrafica già loccata dall'utente corrente e che necessita di un Update(), oppure solleva un'eccezione se avvengono degli errori.
Torna su
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Metodo DedType.CreateData(String, String, String, String)

Metodo DedTypeCreateData(String, String, String, String)
Crea una nuova anagrafica associata a questa famiglia e la restituisce. Il chiamante deve successivamente inserire tutti i valori rimanenti all'interno dell'anagrafica ed aggiornarla nel Database tramite un Update(). Oltre ai campi che vengono passati come argomento, vengono precompilati anche: DEDLOCK, DEDROWVER, DEDUSER, DEDDATE, DEDMODUSER, DEDMODDATE, DEDSTATEUSER, DEDSTATEDATE e DEDSTATEID. Restituisce l'anagrafica già loccata dall'utente corrente e che necessita di un Update(), oppure solleva un'eccezione se avvengono degli errori.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData CreateData(
    string dedid,
    string dedrev,
    string ded_dis,
    string ded_file
)
Public Function CreateData (
    dedid As String,
    dedrev As String,
    ded_dis As String,
    ded_file As String
) As DedData
public:
DedData^ CreateData(
    String^ dedid,
    String^ dedrev,
    String^ ded_dis,
    String^ ded_file
)
member CreateData :
        dedid : string *
        dedrev : string *
        ded_dis : string *
        ded_file : string -> DedData

Parametri

dedid String
DEDID indice della nuova anagrafica.
dedrev String
DEDREV indice della nuova anagrafica.
ded_dis String
DED_DIS della nuova anagrafica.
ded_file String
DED_FILE della nuova anagrafica.

Valore di ritorno

DedData
Restituisce l'anagrafica creata e bloccata dall'utente corrente.
Eccezioni
Eccezione | Condizione
[!:QsException] | Viene sollevata in caso di presenza pregressa dell'anagrafica.
[!:QsException] | Viene sollevata in caso di errore nell'istruzione di inserimento dati.
[!:QsException] | Errore verificatosi durante la lettura del record.
ArgumentNullException | Parametro mancante.
Vedi anche

Documentazione

Classe DedType
Overload di CreateData
Namespace DedNet.Core


Metodo DedType.CreateData(String, String, String, String, Boolean)

Metodo DedTypeCreateData(String, String, String, String, Boolean)
Crea una nuova anagrafica associata a questa famiglia e la restituisce. Il chiamante deve successivamente inserire tutti i valori rimanenti all'interno dell'anagrafica ed aggiornarla nel Database tramite un Update(). Oltre ai campi che vengono passati come argomento, vengono precompilati anche: DEDLOCK, DEDROWVER, DEDUSER, DEDDATE, DEDMODUSER, DEDMODDATE, DEDSTATEUSER, DEDSTATEDATE e DEDSTATEID. Restituisce l'anagrafica già loccata dall'utente corrente e che necessita di un Update(), oppure solleva un'eccezione se avvengono degli errori.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData CreateData(
    string dedid,
    string dedrev,
    string ded_dis,
    string ded_file,
    bool isRev
)
Public Function CreateData (
    dedid As String,
    dedrev As String,
    ded_dis As String,
    ded_file As String,
    isRev As Boolean
) As DedData
public:
DedData^ CreateData(
    String^ dedid,
    String^ dedrev,
    String^ ded_dis,
    String^ ded_file,
    bool isRev
)
member CreateData :
        dedid : string *
        dedrev : string *
        ded_dis : string *
        ded_file : string *
        isRev : bool -> DedData

Parametri

dedid String
DEDID indice della nuova anagrafica.
dedrev String
DEDREV indice della nuova anagrafica.
ded_dis String
DED_DIS della nuova anagrafica.
ded_file String
DED_FILE della nuova anagrafica.
isRev Boolean
Indica se questo metodo è chiamato in fase di revisione anagrafica.

Valore di ritorno

DedData
Restituisce l'anagrafica creata e bloccata dall'utente corrente.
Eccezioni
Eccezione | Condizione
[!:QsException] | Viene sollevata in caso di presenza pregressa dell'anagrafica.
[!:QsException] | Viene sollevata in caso di errore nell'istruzione di inserimento dati.
[!:QsException] | Errore verificatosi durante la lettura del record.
ArgumentNullException | Parametro mancante.
Vedi anche

Documentazione

Classe DedType
Overload di CreateData
Namespace DedNet.Core


Metodo DedType.DecodeDedDis

Metodo DedTypeDecodeDedDis
Decodifica una stinga come DED_DIS appartenente a questa famiglia, restituendo un oggetto descrittivo della codifica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEncodeInfo DecodeDedDis(
    string stringToDecode
)
Public Function DecodeDedDis (
    stringToDecode As String
) As DedEncodeInfo
public:
DedEncodeInfo^ DecodeDedDis(
    String^ stringToDecode
)
member DecodeDedDis :
        stringToDecode : string -> DedEncodeInfo

Parametri

stringToDecode String
Stringa da decodificare. Es: 'P500123456-00'.

Valore di ritorno

DedEncodeInfo
Restituisce un DedEncodeInfo contenente tutte le informazioni sui tasselli trovati.
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Metodo DedType.DecodeDedFile

Metodo DedTypeDecodeDedFile
Decodifica una stinga come file di default per i file primari di questa famiglia, restituendo un oggetto descrittivo della codifica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEncodeInfo DecodeDedFile(
    string stringToDecode
)
Public Function DecodeDedFile (
    stringToDecode As String
) As DedEncodeInfo
public:
DedEncodeInfo^ DecodeDedFile(
    String^ stringToDecode
)
member DecodeDedFile :
        stringToDecode : string -> DedEncodeInfo

Parametri

stringToDecode String
Stringa da decodificare. Es: 'P500123456-00'.

Valore di ritorno

DedEncodeInfo
Restituisce un DedEncodeInfo contenente tutte le informazioni sui tasselli trovati.
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Metodo DedType.DecodeDedId

Metodo DedTypeDecodeDedId
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | DecodeDedId(String) | Decodifica una stinga come DEDID appartenente a questa famiglia, restituendo un oggetto descrittivo della codifica.
Metodo pubblico | DecodeDedId(String, String) | Decodifica una stinga come DEDID appartenente a questa famiglia, restituendo un oggetto descrittivo della codifica.
Torna su
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Metodo DedType.DecodeDedId(String)

Metodo DedTypeDecodeDedId(String)
Decodifica una stinga come DEDID appartenente a questa famiglia, restituendo un oggetto descrittivo della codifica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override DedEncodeInfo DecodeDedId(
    string stringToDecode
)
Public Overrides Function DecodeDedId (
    stringToDecode As String
) As DedEncodeInfo
public:
virtual DedEncodeInfo^ DecodeDedId(
    String^ stringToDecode
) override
abstract DecodeDedId :
        stringToDecode : string -> DedEncodeInfo
override DecodeDedId :
        stringToDecode : string -> DedEncodeInfo

Parametri

stringToDecode String
Stringa da decodificare. Es: 'P500123456'.

Valore di ritorno

DedEncodeInfo
Restituisce un DedEncodeInfo contenente tutte le informazioni sui tasselli trovati.
Vedi anche

Documentazione

Classe DedType
Overload di DecodeDedId
Namespace DedNet.Core


Metodo DedType.DecodeDedId(String, String)

Metodo DedTypeDecodeDedId(String, String)
Decodifica una stinga come DEDID appartenente a questa famiglia, restituendo un oggetto descrittivo della codifica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override DedEncodeInfo DecodeDedId(
    string stringToDecode,
    string cod_id
)
Public Overrides Function DecodeDedId (
    stringToDecode As String,
    cod_id As String
) As DedEncodeInfo
public:
virtual DedEncodeInfo^ DecodeDedId(
    String^ stringToDecode,
    String^ cod_id
) override
abstract DecodeDedId :
        stringToDecode : string *
        cod_id : string -> DedEncodeInfo
override DecodeDedId :
        stringToDecode : string *
        cod_id : string -> DedEncodeInfo

Parametri

stringToDecode String
Stringa da decodificare. Es: 'P500123456'.
cod_id String
Stringa di decodifica"

Valore di ritorno

DedEncodeInfo
Restituisce un DedEncodeInfo contenente tutte le informazioni sui tasselli trovati.
Vedi anche

Documentazione

Classe DedType
Overload di DecodeDedId
Namespace DedNet.Core


Metodo DedType.EncodeDedDis

Metodo DedTypeEncodeDedDis
Inserisce nelle info passate questa stessa famiglia e poi crea e restituisce il DED_DIS corrispondente alla maschera di codifica presente o ereditata da questa famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string EncodeDedDis(
    DedEncodeInfo info,
    DedData data = null
)
Public Function EncodeDedDis (
    info As DedEncodeInfo,
    Optional data As DedData = Nothing
) As String
public:
String^ EncodeDedDis(
    DedEncodeInfo^ info,
    DedData^ data = nullptr
)
member EncodeDedDis :
        info : DedEncodeInfo *
        ?data : DedData
(* Defaults:
        let _data = defaultArg data null
*)
-> string

Parametri

info DedEncodeInfo
Informazioni dalle quali ricavare la codifica (il campo famiglia viene sovrascritto con questa stessa famiglia).
data DedData (Optional)
Eventuale anagrafica dalla quale preveleare i dati di encode

Valore di ritorno

String
Restituisce il DED_DIS codificato.
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Metodo DedType.EncodeDedFile

Metodo DedTypeEncodeDedFile
Inserisce nelle info passate questa stessa famiglia e poi crea e restituisce il nome file di default per i file primari, corrispondente alla maschera di codifica presente o ereditata da questa famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string EncodeDedFile(
    DedEncodeInfo info,
    DedData data = null
)
Public Function EncodeDedFile (
    info As DedEncodeInfo,
    Optional data As DedData = Nothing
) As String
public:
String^ EncodeDedFile(
    DedEncodeInfo^ info,
    DedData^ data = nullptr
)
member EncodeDedFile :
        info : DedEncodeInfo *
        ?data : DedData
(* Defaults:
        let _data = defaultArg data null
*)
-> string

Parametri

info DedEncodeInfo
Informazioni dalle quali ricavare la codifica (il campo famiglia viene sovrascritto con questa stessa famiglia).
data DedData (Optional)
Eventuale anagrafica dalla quale preveleare i dati di encode

Valore di ritorno

String
Restituisce il nome file codificato.
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Metodo DedType.EncodeDedId

Metodo DedTypeEncodeDedId
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | EncodeDedId(DedEncodeInfo) | Inserisce nelle info passate questa stessa famiglia e poi crea e restituisce il DEDID corrispondente alla maschera di codifica presente o ereditata da questa famiglia.
Metodo pubblico | EncodeDedId(DedEncodeInfo, DedData) | Inserisce nelle info passate questa stessa famiglia e poi crea e restituisce il DEDID corrispondente alla maschera di codifica presente o ereditata da questa famiglia.
Torna su
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Metodo DedType.EncodeDedId(DedEncodeInfo)

Metodo DedTypeEncodeDedId(DedEncodeInfo)
Inserisce nelle info passate questa stessa famiglia e poi crea e restituisce il DEDID corrispondente alla maschera di codifica presente o ereditata da questa famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string EncodeDedId(
    DedEncodeInfo info
)
Public Overrides Function EncodeDedId (
    info As DedEncodeInfo
) As String
public:
virtual String^ EncodeDedId(
    DedEncodeInfo^ info
) override
abstract EncodeDedId :
        info : DedEncodeInfo -> string
override EncodeDedId :
        info : DedEncodeInfo -> string

Parametri

info DedEncodeInfo
Informazioni dalle quali ricavare la codifica (il campo famiglia viene sovrascritto con questa stessa famiglia).

Valore di ritorno

String
Restituisce il DEDID codificato.
Vedi anche

Documentazione

Classe DedType
Overload di EncodeDedId
Namespace DedNet.Core


Metodo DedType.EncodeDedId(DedEncodeInfo, DedData)

Metodo DedTypeEncodeDedId(DedEncodeInfo, DedData)
Inserisce nelle info passate questa stessa famiglia e poi crea e restituisce il DEDID corrispondente alla maschera di codifica presente o ereditata da questa famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string EncodeDedId(
    DedEncodeInfo info,
    DedData data = null
)
Public Function EncodeDedId (
    info As DedEncodeInfo,
    Optional data As DedData = Nothing
) As String
public:
String^ EncodeDedId(
    DedEncodeInfo^ info,
    DedData^ data = nullptr
)
member EncodeDedId :
        info : DedEncodeInfo *
        ?data : DedData
(* Defaults:
        let _data = defaultArg data null
*)
-> string

Parametri

info DedEncodeInfo
Informazioni dalle quali ricavare la codifica (il campo famiglia viene sovrascritto con questa stessa famiglia).
data DedData (Optional)
Eventuale anagrafica dalla quale preveleare i dati di encode

Valore di ritorno

String
Restituisce il DEDID codificato.
Vedi anche

Documentazione

Classe DedType
Overload di EncodeDedId
Namespace DedNet.Core


Metodo DedType.EncodePath

Metodo DedTypeEncodePath
Inserisce nelle info passate questa stessa famiglia e poi crea e restituisce il percorso di archiviazione di default presente o ereditato da questa famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string EncodePath(
    DedEncodeInfo info,
    DedData data = null
)
Public Function EncodePath (
    info As DedEncodeInfo,
    Optional data As DedData = Nothing
) As String
public:
String^ EncodePath(
    DedEncodeInfo^ info,
    DedData^ data = nullptr
)
member EncodePath :
        info : DedEncodeInfo *
        ?data : DedData
(* Defaults:
        let _data = defaultArg data null
*)
-> string

Parametri

info DedEncodeInfo
Informazioni dalle quali ricavare la codifica (il campo famiglia viene sovrascritto con questa stessa famiglia).
data DedData (Optional)

Valore di ritorno

String
Restituisce il percorso di archiviazione codificato.
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Metodo DedType.Equals

Metodo DedTypeEquals

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj Object

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Metodo DedType.FindAttrByName

Metodo DedTypeFindAttrByName
Cerca un attributo con un determinato nome tra gli attributi visibili da questa famiglia. Restitusice null se non lo trova.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override DedAttr FindAttrByName(
    string name
)
Public Overrides Function FindAttrByName (
    name As String
) As DedAttr
public:
virtual DedAttr^ FindAttrByName(
    String^ name
) override
abstract FindAttrByName :
        name : string -> DedAttr
override FindAttrByName :
        name : string -> DedAttr

Parametri

name String
Nome dell'attributo da cercare.

Valore di ritorno

DedAttr
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Metodo DedType.FindAttrByPrompt

Metodo DedTypeFindAttrByPrompt
Cerca un attributo con un determinato prompt tra gli attributi visibili da questa famiglia. Restitusice null se non lo trova.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override DedAttr FindAttrByPrompt(
    string prompt
)
Public Overrides Function FindAttrByPrompt (
    prompt As String
) As DedAttr
public:
virtual DedAttr^ FindAttrByPrompt(
    String^ prompt
) override
abstract FindAttrByPrompt :
        prompt : string -> DedAttr
override FindAttrByPrompt :
        prompt : string -> DedAttr

Parametri

prompt String
Prompt dell'attributo da cercare.

Valore di ritorno

DedAttr
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Metodo DedType.FindBusyProgrRecursive

Metodo DedTypeFindBusyProgrRecursive
Scorre ricorsivamente tutte le famiglie per conoscere tutti i progressivi utilizzati.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void FindBusyProgrRecursive(
    DedTypeBase tipo,
    Dictionary<string, string> progrBusy,
    string username = "",
    DataTable dt = null
)
Public Overrides Sub FindBusyProgrRecursive (
    tipo As DedTypeBase,
    progrBusy As Dictionary(Of String, String),
    Optional username As String = "",
    Optional dt As DataTable = Nothing
)
public:
virtual void FindBusyProgrRecursive(
    DedTypeBase^ tipo,
    Dictionary<String^, String^>^ progrBusy,
    String^ username = L"",
    DataTable^ dt = nullptr
) override
abstract FindBusyProgrRecursive :
        tipo : DedTypeBase *
        progrBusy : Dictionary<string, string> *
        ?username : string *
        ?dt : DataTable
(* Defaults:
        let _username = defaultArg username ""
        let _dt = defaultArg dt null
*)
-> unit
override FindBusyProgrRecursive :
        tipo : DedTypeBase *
        progrBusy : Dictionary<string, string> *
        ?username : string *
        ?dt : DataTable
(* Defaults:
        let _username = defaultArg username ""
        let _dt = defaultArg dt null
*)
-> unit

Parametri

tipo DedTypeBase
Famiglia da valutare.
progrBusy Dictionary String, String
Lista che viene riempita con i progressivi attualmente usati.
username String (Optional)
dt DataTable (Optional)
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Metodo DedType.FindByDbPath

Metodo DedTypeFindByDbPath
Cerca il tipo corrispondente al dbpath passato in tutto l'albero partendo dalla radice.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override DedTypeBase FindByDbPath(
    string dbpath
)
Public Overrides Function FindByDbPath (
    dbpath As String
) As DedTypeBase
public:
virtual DedTypeBase^ FindByDbPath(
    String^ dbpath
) override
abstract FindByDbPath :
        dbpath : string -> DedTypeBase
override FindByDbPath :
        dbpath : string -> DedTypeBase

Parametri

dbpath String
DbPath da cercare nell'albero dei tipi.

Valore di ritorno

DedTypeBase
Restituisce il FamilyType avente il DbPath specificato oppure null se la ricerca non ha avuto esito.
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Metodo DedType.FindByDwgPath

Metodo DedTypeFindByDwgPath
Cerca il tipo corrispondente al dbpath passato in tutto l'albero partendo dalla radice.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedType FindByDwgPath(
    string dwgpath
)
Public Function FindByDwgPath (
    dwgpath As String
) As DedType
public:
DedType^ FindByDwgPath(
    String^ dwgpath
)
member FindByDwgPath :
        dwgpath : string -> DedType

Parametri

dwgpath String
dwgpath da cercare nell'albero dei tipi.

Valore di ritorno

DedType
Restituisce il FamilyType avente il dwgpath specificato oppure null se la ricerca non ha avuto esito.
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Metodo DedType.FindCommonDbPath

Metodo DedTypeFindCommonDbPath
Restituisce il DbPath comune a tutte le famiglie contenute nella lista di DbPath passata. Restituisce "!" nel caso in cui la lista sia vuota.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string FindCommonDbPath(
    List<string> dbPathList
)
Public Shared Function FindCommonDbPath (
    dbPathList As List(Of String)
) As String
public:
static String^ FindCommonDbPath(
    List<String^>^ dbPathList
)
static member FindCommonDbPath :
        dbPathList : List<string> -> string

Parametri

dbPathList List String
Lista di stringhe sulle quali trovare il DbPath comune.

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Metodo DedType.GetAllAttrNames

Metodo DedTypeGetAllAttrNames
Restituisce la lista di tutti i nomi degli attributi visibili da questa famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> GetAllAttrNames()
Public Function GetAllAttrNames As List(Of String)
public:
List<String^>^ GetAllAttrNames()
member GetAllAttrNames : unit -> List<string>

Valore di ritorno

List String
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Metodo DedType.GetAllAttrPrompts

Metodo DedTypeGetAllAttrPrompts
Restituisce la lista di tutti i prompt degli attributi visibili da questa famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> GetAllAttrPrompts()
Public Function GetAllAttrPrompts As List(Of String)
public:
List<String^>^ GetAllAttrPrompts()
member GetAllAttrPrompts : unit -> List<string>

Valore di ritorno

List String
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Metodo DedType.GetAttrPromptFromName

Metodo DedTypeGetAttrPromptFromName
Restituisce il prompt di un attributo visibile da questa famiglia dato il suo nome. Restituisce null se non viene trovato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string GetAttrPromptFromName(
    string name
)
Public Function GetAttrPromptFromName (
    name As String
) As String
public:
String^ GetAttrPromptFromName(
    String^ name
)
member GetAttrPromptFromName :
        name : string -> string

Parametri

name String
Nome dell'attributo da cercare.

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Metodo DedType.GetCascadeFromName

Metodo DedTypeGetCascadeFromName
Ritorna la cascata che ha come Figlio il nome passato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCascade GetCascadeFromName(
    string name
)
Public Function GetCascadeFromName (
    name As String
) As DedCascade
public:
DedCascade^ GetCascadeFromName(
    String^ name
)
member GetCascadeFromName :
        name : string -> DedCascade

Parametri

name String
Nome del figlio.

Valore di ritorno

DedCascade
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Metodo DedType.GetFieldsCod

Metodo DedTypeGetFieldsCod
Restituisce la lista delle stringhe nelle quali cercare i tasselli.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string[] GetFieldsCod()
Public Overrides Function GetFieldsCod As String()
public:
virtual array<String^>^ GetFieldsCod() override
abstract GetFieldsCod : unit -> string[]
override GetFieldsCod : unit -> string[]

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Metodo DedType.GetHashCode

Metodo DedTypeGetHashCode

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Metodo DedType.GetNextVar

Metodo DedTypeGetNextVar
Calcola il prossimo tassello di variante automatica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string GetNextVar(
    DedEncodeInfo info,
    DedData startingData
)
Public Function GetNextVar (
    info As DedEncodeInfo,
    startingData As DedData
) As String
public:
String^ GetNextVar(
    DedEncodeInfo^ info,
    DedData^ startingData
)
member GetNextVar :
        info : DedEncodeInfo *
        startingData : DedData -> string

Parametri

info DedEncodeInfo
startingData DedData

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Metodo DedType.GetParentAttributes

Metodo DedTypeGetParentAttributes
Restituisce la lista degli attributi dei miei genitori.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList GetParentAttributes(
    bool sparePart,
    bool removeMyAttrRedefined
)
Public Function GetParentAttributes (
    sparePart As Boolean,
    removeMyAttrRedefined As Boolean
) As DedAttrList
public:
DedAttrList^ GetParentAttributes(
    bool sparePart,
    bool removeMyAttrRedefined
)
member GetParentAttributes :
        sparePart : bool *
        removeMyAttrRedefined : bool -> DedAttrList

Parametri

sparePart Boolean
Indica se gestire la lista degli attributi di ricambio o quelli normali
removeMyAttrRedefined Boolean
Indica se rimuovere dalla lista eventuali attributi ridefiniti nella famiglia attuale

Valore di ritorno

DedAttrList
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Metodo DedType.GetParentTypes

Metodo DedTypeGetParentTypes
Restituisce una lista dei FamilyType genitori, compresa l'istanza stessa se specificato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override DedTypeList GetParentTypes(
    bool bCurrent
)
Public Overrides Function GetParentTypes (
    bCurrent As Boolean
) As DedTypeList
public:
virtual DedTypeList^ GetParentTypes(
    bool bCurrent
) override
abstract GetParentTypes :
        bCurrent : bool -> DedTypeList
override GetParentTypes :
        bCurrent : bool -> DedTypeList

Parametri

bCurrent Boolean
Specifica se includere l'istanza di questo oggetto sul quale è stato chiamato il metodo, nella lista restituita.

Valore di ritorno

DedTypeList
Restituisce la lista dei FamilyType genitori oppure null.
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Metodo DedType.GetRevDedDisTokenNum

Metodo DedTypeGetRevDedDisTokenNum
Restituisce il numero di caratteri dedicati alla revisione, presenti nel DED_DIS.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int GetRevDedDisTokenNum()
Public Function GetRevDedDisTokenNum As Integer
public:
int GetRevDedDisTokenNum()
member GetRevDedDisTokenNum : unit -> int

Valore di ritorno

Int32
Restituisce il numero di caratteri della revsione presenti nel DED_DIS di questa famiglia.
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Metodo DedType.GetRevFileTokenNum

Metodo DedTypeGetRevFileTokenNum
Restituisce il numero di caratteri dedicati alla revisione, presenti nel nome del file COD_FIL. Se si tratta di una famiglia NGR (nuova gestione delle revisioni), restituisce 0, altrimenti il numero di caratteri presenti.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int GetRevFileTokenNum()
Public Function GetRevFileTokenNum As Integer
public:
int GetRevFileTokenNum()
member GetRevFileTokenNum : unit -> int

Valore di ritorno

Int32
Restituisce il numero di caratteri della revsione presenti nel file di questa famiglia.
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Metodo DedType.GetRevTokenNum

Metodo DedTypeGetRevTokenNum
Restituisce il numero di caratteri da utilizzare per creare la stringa di revisione per questa famiglia. Li calcola cercando il tassello della revisione nella codifica del DED_DIS. Se non è presente qui restituisce il valore presente nella variabile globale del DED

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int GetRevTokenNum()
Public Function GetRevTokenNum As Integer
public:
int GetRevTokenNum()
member GetRevTokenNum : unit -> int

Valore di ritorno

Int32
Restituisce il numero di caratteri della revsione per questa famiglia.
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Metodo DedType.NotifyDirty

Metodo DedTypeNotifyDirty
In base al fatto che si tratti della root o meno notifica al parent corretto l'avvenuta modifica della proprietà.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void NotifyDirty()
Public Overrides Sub NotifyDirty
public:
virtual void NotifyDirty() override
abstract NotifyDirty : unit -> unit
override NotifyDirty : unit -> unit
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Metodo DedType.Save

Metodo DedTypeSave
Salva tutta la struttura discendente (da questa in giù) delle famiglie.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void Save()
Public Overrides Sub Save
public:
virtual void Save() override
abstract Save : unit -> unit
override Save : unit -> unit
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Metodo DedType.ToString

Metodo DedTypeToString

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Metodo DedType.UserCan

Metodo DedTypeUserCan
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | UserCan(DedStandardPerm) | Verifica se l'utente corrente ha un determinato permesso su questa famiglia.
Metodo pubblico | UserCan(String) | Verifica se l'utente corrente ha un determinato permesso su questa famiglia.
Torna su
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Metodo DedType.UserCan(DedStandardPerm)

Metodo DedTypeUserCan(DedStandardPerm)
Verifica se l'utente corrente ha un determinato permesso su questa famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool UserCan(
    DedStandardPerm perm
)
Public Function UserCan (
    perm As DedStandardPerm
) As Boolean
public:
bool UserCan(
    DedStandardPerm perm
)
member UserCan :
        perm : DedStandardPerm -> bool

Parametri

perm DedStandardPerm
Permesso standard da verificare.

Valore di ritorno

Boolean
Restituisce true se il permesso è concesso altrimenti false.
Vedi anche

Documentazione

Classe DedType
Overload di UserCan
Namespace DedNet.Core


Metodo DedType.UserCan(String)

Metodo DedTypeUserCan(String)
Verifica se l'utente corrente ha un determinato permesso su questa famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool UserCan(
    string permname
)
Public Function UserCan (
    permname As String
) As Boolean
public:
bool UserCan(
    String^ permname
)
member UserCan :
        permname : string -> bool

Parametri

permname String
Nome del permesso da verificare.

Valore di ritorno

Boolean
Restituisce true se il permesso è concesso altrimenti false.
Vedi anche

Documentazione

Classe DedType
Overload di UserCan
Namespace DedNet.Core


Campi di DedType

Il tipo DedType espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | _analyzedTypes | (Ereditato da DedTypeBase)
Campo pubblico | _app | (Ereditato da DedTypeBase)
Campo pubblico | _attributes | (Ereditato da DedTypeBase)
Campo pubblico | _backcolor | (Ereditato da DedTypeBase)
Campo pubblico | _calculatedAttrs | (Ereditato da DedTypeBase)
Campo pubblico | _clonedFrom | (Ereditato da DedTypeBase)
Campo pubblico | _cod_id | (Ereditato da DedTypeBase)
Campo pubblico | _dbPath | (Ereditato da DedTypeBase)
Campo pubblico | _dbPathLoaded | (Ereditato da DedTypeBase)
Campo pubblico | _descriz | (Ereditato da DedTypeBase)
Campo pubblico | _dirtyname | (Ereditato da DedTypeBase)
Campo pubblico | _dwgpath | (Ereditato da DedTypeBase)
Campo pubblico | _forecolor | (Ereditato da DedTypeBase)
Campo pubblico | _freecode | (Ereditato da DedTypeBase)
Campo pubblico | _isprj | (Ereditato da DedTypeBase)
Campo pubblico | _isRoot | Indica se questa famiglia sia o meno la root. (Ereditato da DedTypeBase)
Campo pubblico | _master | (Ereditato da DedTypeBase)
Campo pubblico | _name | (Ereditato da DedTypeBase)
Campo pubblico | _oldDwgPath | (Ereditato da DedTypeBase)
Campo pubblico | _parent | Collezione di appartenenza. (Ereditato da DedTypeBase)
Campo pubblico | _progr | (Ereditato da DedTypeBase)
Campo pubblico | _progrAlphabet | (Ereditato da DedTypeBase)
Campo pubblico | _revisionAlphabet | (Ereditato da DedTypeBase)
Campo pubblico | _rootCollection | Collezione dedicata al salvataggio della root. (Ereditato da DedTypeBase)
Campo pubblico | _rules | (Ereditato da DedTypeBase)
Campo pubblico | _subtypes | (Ereditato da DedTypeBase)
Campo pubblico | _varAlphabet | (Ereditato da DedTypeBase)
Torna su
Vedi anche

Documentazione

Classe DedType
Namespace DedNet.Core


Enumerazione DedType.CompCodeEnum

Enumerazione DedTypeCompCodeEnum
Tipi di compilazione del campo DED_COD.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum CompCodeEnum
Public Enumeration CompCodeEnum
public enum class CompCodeEnum
type CompCodeEnum
Membri
Nome | Valore | Descrizione
None | 0 | Non Specificato.
No | 1 | Non viene compilato.
Si | 2 | Sì (uguale a DED_DIS cioè con revisione).
SiNoRev | 3 | Sì (uguale a DEDID cioè senza revisione).
Custom | 4 | In modo personalizzato.
SiFile | 5 | Sì (uguale a DED_FILE).
Vedi anche

Documentazione

Namespace DedNet.Core


Enumerazione DedType.DedTypeCaractEnum

Enumerazione DedTypeDedTypeCaractEnum
Enumerazione per la compilazione delle proprietà delle famiglie.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum DedTypeCaractEnum
Public Enumeration DedTypeCaractEnum
public enum class DedTypeCaractEnum
type DedTypeCaractEnum
Membri
Nome | Valore | Descrizione
Nome | 0 |
Descrizione | 1 |
Revisione | 2 |
Progressivo | 3 |
Utente | 4 |
Variante | 5 |
Formato | 6 |
Vedi anche

Documentazione

Namespace DedNet.Core


Enumerazione DedType.FreeFileEnum

Enumerazione DedTypeFreeFileEnum
Enumerazione per le tipologie di freefile.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum FreeFileEnum
<FlagsAttribute>
Public Enumeration FreeFileEnum
[FlagsAttribute]
public enum class FreeFileEnum
[<FlagsAttribute>]
type FreeFileEnum
Membri
Nome | Valore | Descrizione
None | 0 | La famiglia non è free file.
FreeFile | 1 | La famiglia è free file.
AsDedID | 2 | Il free file è uguale al DedID.
SameFileRev | 4 | Il nome file non cambia durante la revisione.
Vedi anche

Documentazione

Namespace DedNet.Core


Struttura DedType.ProgStruct

Struttura DedTypeProgStruct
Struttura per la gestione dei progressivi assegnati
Gerarchia di ereditarietà
SystemObject
SystemValueType
DedNet.CoreDedTypeProgStruct

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public struct ProgStruct
Public Structure ProgStruct
public value class ProgStruct
[<SealedAttribute>]
type ProgStruct =
    struct
        inherit ValueType
    end

Il tipo DedTypeProgStruct espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | IsReserved | Indica se il progressivo è riservato ( preso dalla tabella DED_TIPI_PROG ).
Proprietà pubblica | ProgList | Indica i valori dei progressivi ammessi.
Proprietà pubblica | Progr | Indica il progressivo attuale.
Proprietà pubblica | Type | Indica la famiglia di appartenenza.
Proprietà pubblica | User | Utente/Gruppo al quale sono riservati
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di ProgStruct

Il tipo DedTypeProgStruct espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | IsReserved | Indica se il progressivo è riservato ( preso dalla tabella DED_TIPI_PROG ).
Proprietà pubblica | ProgList | Indica i valori dei progressivi ammessi.
Proprietà pubblica | Progr | Indica il progressivo attuale.
Proprietà pubblica | Type | Indica la famiglia di appartenenza.
Proprietà pubblica | User | Utente/Gruppo al quale sono riservati
Torna su
Vedi anche

Documentazione

Struttura DedTypeProgStruct
Namespace DedNet.Core


Proprietà DedType.ProgStruct.IsReserved

Proprietà DedTypeProgStructIsReserved
Indica se il progressivo è riservato ( preso dalla tabella DED_TIPI_PROG ).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsReserved { get; set; }
Public Property IsReserved As Boolean
    Get
    Set
public:
property bool IsReserved {
    bool get ();
    void set (bool value);
}
member IsReserved : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Struttura DedTypeProgStruct
Namespace DedNet.Core


Proprietà DedType.ProgStruct.ProgList

Proprietà DedTypeProgStructProgList
Indica i valori dei progressivi ammessi.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeProgList ProgList { get; set; }
Public Property ProgList As DedTypeProgList
    Get
    Set
public:
property DedTypeProgList^ ProgList {
    DedTypeProgList^ get ();
    void set (DedTypeProgList^ value);
}
member ProgList : DedTypeProgList with get, set

Valore della proprietà

DedTypeProgList
Vedi anche

Documentazione

Struttura DedTypeProgStruct
Namespace DedNet.Core


Proprietà DedType.ProgStruct.Progr

Proprietà DedTypeProgStructProgr
Indica il progressivo attuale.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Progr { get; set; }
Public Property Progr As String
    Get
    Set
public:
property String^ Progr {
    String^ get ();
    void set (String^ value);
}
member Progr : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Struttura DedTypeProgStruct
Namespace DedNet.Core


Proprietà DedType.ProgStruct.Type

Proprietà DedTypeProgStructType
Indica la famiglia di appartenenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeBase Type { get; set; }
Public Property Type As DedTypeBase
    Get
    Set
public:
property DedTypeBase^ Type {
    DedTypeBase^ get ();
    void set (DedTypeBase^ value);
}
member Type : DedTypeBase with get, set

Valore della proprietà

DedTypeBase
Vedi anche

Documentazione

Struttura DedTypeProgStruct
Namespace DedNet.Core


Proprietà DedType.ProgStruct.User

Proprietà DedTypeProgStructUser
Utente/Gruppo al quale sono riservati

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string User { get; set; }
Public Property User As String
    Get
    Set
public:
property String^ User {
    String^ get ();
    void set (String^ value);
}
member User : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Struttura DedTypeProgStruct
Namespace DedNet.Core


Classe DedTypeBase
Classe astratta per definire oggetti che sono usati in collezioni strutturate, hanno regole di codifica, attributi e regole sugli attributi
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedTypeBase
DedNet.CoreDedCommType
DedNet.CoreDedType

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public abstract class DedTypeBase : IDedDbItem
Public MustInherit Class DedTypeBase
    Implements IDedDbItem
public ref class DedTypeBase abstract : IDedDbItem
[<AbstractClassAttribute>]
type DedTypeBase =
    class
        interface IDedDbItem
    end

Il tipo DedTypeBase espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo protetto | DedTypeBase |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione di appartenenza.
Proprietà pubblica | Attributes | Lista degli attributi
Proprietà pubblica | BackColor | Restituisce il colore di sfondo.
Proprietà pubblica | CalculatedAttrs | Lista che contiene quali attributi sono considerati 'importati'.
Proprietà pubblica | ClonedFrom | Indica se la famiglia è stata clonata e da quale
Proprietà pubblica | Cod_Id | Restituisce la maschera di codifica per DED_ID, eventualmente ereditata.
Proprietà pubblica | DbPath | Restituisce il DbPath della famiglia.
Proprietà pubblica | Descriz | Restituisce/Imposta la descrizione della famiglia.
Proprietà pubblica | Dirty | Indica se è stato modificato
Proprietà pubblica | DirtyName | Indica se è stato modificato il nome della famiglia.
Proprietà pubblica | FamFirstLev | Restituisce la famiglia a 1° livello.
Proprietà pubblica | ForeColor | Restituisce il colore del testo.
Proprietà pubblica | FreeCode | Restituisce/Imposta se la famiglia è a codifica libera.
Proprietà pubblica | FreeFile | Restituisce/Imposta se la famiglia è a codifica file libera.
Proprietà pubblica | FreeFileAsDedId | Restituisce/Imposta se il file debba essere compilato come l'id.
Proprietà pubblica | FreeFileSameFileRev | Restituisce/Imposta se il file debba rimanere uguale anche nelle revisioni.
Proprietà pubblica | HasAttributes |
Proprietà pubblica | HasCod_Id | Restituisce se è presente la codifica del DEDID.
Proprietà pubblica | HasInfoUser | Restiutuisce se la famiglia ha il tassello utente o la variante automatica nell'id.
Proprietà pubblica | HasMaster | Restituisce se è presente il master
Proprietà pubblica | HasParent | Restituisce se è presente un oggetto genitore.
Proprietà pubblica | HasProgr | Restituisce se la famiglia ha il progressivo locale impostato e non lo eredita (MyProgr> -1).
Proprietà pubblica | HasProgrAlphabet | Restituisce se è presente l'alfabeto del progressivo.
Proprietà pubblica | HasRevisionAlphabet | Restituisce se è presente l'alfabeto della revisione.
Proprietà pubblica | HasRules | Restituisce se sono presenti regole di autocomposizione specifiche della famiglia.
Proprietà pubblica | HasSubTypes | Restituisce se sono presenti sottotipi della famiglia.
Proprietà pubblica | HasVar | Restiutuisce se la famiglia ha la variante automatica nell'id.
Proprietà pubblica | HasVarAlphabet | Restituisce se è presente l'alfabeto del progressivo.
Proprietà pubblica | IsCompleted | Restituisce se la famiglia è completa ovvero può essere utilizzata come famiglia terminale di codifica.
Proprietà pubblica | IsPrj | Restituisce se si tratti di una famiglia di tipo progetto (eventualmente ereditato).
Proprietà pubblica | IsRoot | Restituisce se si tratta della root dell'albero dei tipi.
Proprietà pubblica | Level | Restituisce il livello di questa famiglia, partendo da 0 per la famiglia root.
Proprietà pubblica | Master | Identifica il master collegato alla tipologia
Proprietà pubblica | MyAttributes | Restituisce la lista di attributi
Proprietà pubblica | MyCod_Id | Restituisce/Imposta la maschera di codifica per DED_ID di questa famiglia.
Proprietà pubblica | MyIsPrj | Restituisce/Imposta se si tratti di una famiglia di tipo progetto (questa famiglia).
Proprietà pubblica | MyMaster | Identifica il master collegato alla tipologia
Proprietà pubblica | MyProgr | Restituisce/Imposta il valore del progressivo strettamente di questa famiglia. Non interroga il Database ma restituisce il valore della cache.
Proprietà pubblica | MyProgrAlphabet | Restituisce/Imposta l'alfabeto per il progressivo di questa famiglia.
Proprietà pubblica | MyRevisionAlphabet | Restituisce/Imposta l'alfabeto per il progressivo di questa famiglia.
Proprietà pubblica | MyRules | Restituisce la lista delle regole di autocomposizione di questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota.
Proprietà pubblica | MyVarAlphabet | Restituisce/Imposta l'alfabeto per la variante di questa famiglia.
Proprietà pubblica | Nome | Restituisce/Imposta il nome della famiglia.
Proprietà pubblica | Parent | Restituisce la collezione di appartenenza.
Proprietà pubblica | Progr | Restituisce il progressivo eventualmente ereditato, se non presente in questa famiglia.
Proprietà pubblica | ProgrAlphabet | Restituisce l'alfabeto per la variante di questa famiglia. Restitusice l'alfabeto ereditato se non è impostato per questa famiglia.
Proprietà pubblica | ReservedProgTableName | Nome della tabella del DB dove sono gestiti i progressivi assegnati
Proprietà pubblica | RevisionAlphabet | Restituisce l'alfabeto per il progressivo di questa famiglia. Restitusice l'alfabeto ereditato se non è impostato per questa famiglia.
Proprietà pubblica | Root | Restituisce la root di questi oggetti
Proprietà pubblica | RuleDirty | Restituisce se sono state modificate le regole.
Proprietà pubblica | Rules | Restituisce la lista delle regole di autocomposizione visibili da questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota.
Proprietà pubblica | RuleTableName | Nome della tabella del DB con le regole
Proprietà pubblica | StatoRecord | Restituisce o imposta lo stato del record. DI USO INTERNO !!
Proprietà pubblica | SubTypes | Restituisce la lista delle sottofamiglie di questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota.
Proprietà pubblica | TableName | Nome della tabella del DB con i suoi oggetti
Proprietà pubblica | TypeDirty | Restituisce se sono state modificate le famiglie.
Proprietà pubblica | VarAlphabet | Restituisce l'alfabeto per il progressivo di questa famiglia. Restitusice l'alfabeto ereditato se non è impostato per questa famiglia.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | DecodeDedId(String) |
Metodo pubblico | DecodeDedId(String, String) |
Metodo pubblico | EncodeDedId |
Metodo pubblico | FindAttrByName | Restituisce l'attriibuto dal name passato
Metodo pubblico | FindAttrByPrompt | Restituisce l'attriibuto dal prompt passato
Metodo pubblico | FindBusyProgrRecursive | Metodo per cercare i progressivi attualmente in uso
Metodo pubblico | FindByDbPath | Cerca il tipo corrispondente al dbpath passato in tutto l'albero partendo dalla radice.
Metodo pubblico | ForEachChild | Questo metodo chiama un delegate passandogli in sequenza il nodo corrente (opzionalmente) e tutti i suoi nodi figli.
Metodo pubblico | ForEachParent | Questo metodo chiama un delegate passandogli in sequenza il nodo root e giù fino al nodo corrente (opzionalmente) Lo scorrimento avviene quindi in modo discendente dal padre di tutti verso l'oggetto corrente.
Metodo pubblico | FormatDedRev | Data una stringa di revisione restituisce il valore correttamente formattato e della giusta dimensione per questa famiglia. Es: "1" -> "01" (con rev. di 2 caratteri); "12" -> "012" (con rev. di 3 caratteri); "05" -> "5" (con rev. di 1 carattere);
Metodo pubblico | FormatProgr | Data una stringa di progressivo restituisce il valore correttamente formattato e della giusta dimensione per questa famiglia. Es: "1" -> "001" (progr. di 3 caratteri); "12" -> "012" (progr. di 3 caratteri); "05" -> "5" (progr. di 1 carattere);
Metodo pubblico | FormatVar | Data una stringa della variante restituisce il valore correttamente formattato e della giusta dimensione per questa famiglia. Es: "1" -> "001" (progr. di 3 caratteri); "12" -> "012" (progr. di 3 caratteri); "05" -> "5" (progr. di 1 carattere);
Metodo pubblico | ForOneChild | Questo metodo chiama un delegate passandogli in sequenza il nodo corrente (opzionalmente) e tutti i suoi nodi figli.
Metodo pubblico | GetAttrNameFromPrompt | Restituisce il nome di un attributo visibile da questa famiglia dato il suo prompt.
Metodo pubblico | GetAttrsFromCategory(DedCateg) | Ritorna la lista di attributi visibili dalla famiglia che appartengono alla categoria passata.
Metodo pubblico | GetAttrsFromCategory(String) | Ritorna la lista di attributi visibili dalla famiglia che appartengono alla categoria passata.
Metodo pubblico | GetBusyProgr | Restituisce un dizionario con tutti i progressivi utilizzati.
Metodo pubblico | GetFamSpecificLevel | Restituisce la famiglia a n° livello.
Metodo pubblico | GetFamSpecificNegativeLevel | Restituisce la famiglia a n° livello negativo.
Metodo pubblico | GetFieldsCod | Restituisce la lista delle stringhe nella queli cercare i tasselli.
Metodo pubblico | GetFirstParentHasProg | Restituisce la prima famiglia genitore che ha il progressivo locale.Considera anche il nodo corrente per avere la sicurezza che se viene chiamato su una famiglia con con progressivo impostato non lo calcoli sul padre ma su se stesso.
Metodo pubblico | GetFreeProgr | Restituisce una lista sempre inizializzata e ordinata con tutti i progressivi liberi per questa famiglia.
Metodo pubblico | GetLastProgr | Restituisce l'ultimo progressivo possibile per questa famiglia.
Metodo pubblico | GetMaxTokenNum | Restituisce il massimo numero di caratteri usati per il TokenTypeEnum passato. Verifica nella maschera di codifica Cod_Id, Cod_Fil e Cod_Dis in modo da prendere il numero massimo di caratteri utilizzati.
Metodo pubblico | GetParentTypes | Restituisce una lista dei FamilyType genitori, compresa l'istanza stessa se specificato.
Metodo pubblico | GetProgr(Boolean) | Restituisce il progressivo della famiglia che ha invocato il metodo oppure il progressivo della prima famiglia genitore che lo possiede. Lavora sull'utente attualmente connesso ( se deve lavorare in DED_TIPI_PROG ).
Metodo pubblico | GetProgr(Boolean, String) | Restituisce il progressivo della famiglia che ha invocato il metodo oppure il progressivo della prima famiglia genitore che lo possiede
Metodo pubblico | GetProgrTokenNum | Restituisce il numero di caratteri da utilizzare per creare la stringa del progressivo per questa famiglia. Li calcola cercando il tassello del progressivo nella codifica del Cod_Id. Se non è presente restituisce 0.
Metodo pubblico | GetRightMask | Restituisce il TokenInfo cercato nella prima maschera di codifica trovata, da utilizzare poi per calcolare il numero di tasselli per un particolare token. Restituisce null se non la trova.
Metodo pubblico | MakeAttrsDictionary | Riempie il dizionario _dizfields.
Metodo pubblico | NotifyDirty | In base al fatto che si tratti della root o meno notifica al parent corretto l'avvenuta modifica della proprietà.
Metodo pubblico | Save | Metodo per il salvataggio delle modifiche.
Metodo pubblico | SetProgr(String, String, Boolean) | Imposta il progressivo di questa famiglia o della famiglia dalla quale questa eredita il progressivo. Lavora sull'utente attualmente connesso ( se deve lavorare in DED_TIPI_PROG ).
Metodo pubblico | SetProgr(String, String, Boolean, String) | Imposta il progressivo di questa famiglia o della famiglia dalla quale questa eredita il progressivo.
Metodo pubblico | SetProgr(String, String, Boolean, String, Boolean) | Imposta il progressivo di questa famiglia o della famiglia dalla quale questa eredita il progressivo.
Metodo pubblico | WaitForUpdate | Esegue una query con WITH (XLOCK) in modo da aspettare finchè altri utenti non hanno commitato.
Torna su
Campi
 | Nome | Descrizione
Campo pubblico | _analyzedTypes |
Campo pubblico | _app |
Campo pubblico | _attributes |
Campo pubblico | _backcolor |
Campo pubblico | _calculatedAttrs |
Campo pubblico | _clonedFrom |
Campo pubblico | _cod_id |
Campo pubblico | _dbPath |
Campo pubblico | _dbPathLoaded |
Campo pubblico | _descriz |
Campo pubblico | _dirtyname |
Campo pubblico | _dwgpath |
Campo pubblico | _forecolor |
Campo pubblico | _freecode |
Campo pubblico | _isprj |
Campo pubblico | _isRoot | Indica se questa famiglia sia o meno la root.
Campo pubblico | _master |
Campo pubblico | _name |
Campo pubblico | _oldDwgPath |
Campo pubblico | _parent | Collezione di appartenenza.
Campo pubblico | _progr |
Campo pubblico | _progrAlphabet |
Campo pubblico | _revisionAlphabet |
Campo pubblico | _rootCollection | Collezione dedicata al salvataggio della root.
Campo pubblico | _rules |
Campo pubblico | _subtypes |
Campo pubblico | _varAlphabet |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedTypeBase

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected DedTypeBase()
Protected Sub New
protected:
DedTypeBase()
new : unit -> DedTypeBase
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Proprietà di DedTypeBase

Il tipo DedTypeBase espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione di appartenenza.
Proprietà pubblica | Attributes | Lista degli attributi
Proprietà pubblica | BackColor | Restituisce il colore di sfondo.
Proprietà pubblica | CalculatedAttrs | Lista che contiene quali attributi sono considerati 'importati'.
Proprietà pubblica | ClonedFrom | Indica se la famiglia è stata clonata e da quale
Proprietà pubblica | Cod_Id | Restituisce la maschera di codifica per DED_ID, eventualmente ereditata.
Proprietà pubblica | DbPath | Restituisce il DbPath della famiglia.
Proprietà pubblica | Descriz | Restituisce/Imposta la descrizione della famiglia.
Proprietà pubblica | Dirty | Indica se è stato modificato
Proprietà pubblica | DirtyName | Indica se è stato modificato il nome della famiglia.
Proprietà pubblica | FamFirstLev | Restituisce la famiglia a 1° livello.
Proprietà pubblica | ForeColor | Restituisce il colore del testo.
Proprietà pubblica | FreeCode | Restituisce/Imposta se la famiglia è a codifica libera.
Proprietà pubblica | FreeFile | Restituisce/Imposta se la famiglia è a codifica file libera.
Proprietà pubblica | FreeFileAsDedId | Restituisce/Imposta se il file debba essere compilato come l'id.
Proprietà pubblica | FreeFileSameFileRev | Restituisce/Imposta se il file debba rimanere uguale anche nelle revisioni.
Proprietà pubblica | HasAttributes |
Proprietà pubblica | HasCod_Id | Restituisce se è presente la codifica del DEDID.
Proprietà pubblica | HasInfoUser | Restiutuisce se la famiglia ha il tassello utente o la variante automatica nell'id.
Proprietà pubblica | HasMaster | Restituisce se è presente il master
Proprietà pubblica | HasParent | Restituisce se è presente un oggetto genitore.
Proprietà pubblica | HasProgr | Restituisce se la famiglia ha il progressivo locale impostato e non lo eredita (MyProgr> -1).
Proprietà pubblica | HasProgrAlphabet | Restituisce se è presente l'alfabeto del progressivo.
Proprietà pubblica | HasRevisionAlphabet | Restituisce se è presente l'alfabeto della revisione.
Proprietà pubblica | HasRules | Restituisce se sono presenti regole di autocomposizione specifiche della famiglia.
Proprietà pubblica | HasSubTypes | Restituisce se sono presenti sottotipi della famiglia.
Proprietà pubblica | HasVar | Restiutuisce se la famiglia ha la variante automatica nell'id.
Proprietà pubblica | HasVarAlphabet | Restituisce se è presente l'alfabeto del progressivo.
Proprietà pubblica | IsCompleted | Restituisce se la famiglia è completa ovvero può essere utilizzata come famiglia terminale di codifica.
Proprietà pubblica | IsPrj | Restituisce se si tratti di una famiglia di tipo progetto (eventualmente ereditato).
Proprietà pubblica | IsRoot | Restituisce se si tratta della root dell'albero dei tipi.
Proprietà pubblica | Level | Restituisce il livello di questa famiglia, partendo da 0 per la famiglia root.
Proprietà pubblica | Master | Identifica il master collegato alla tipologia
Proprietà pubblica | MyAttributes | Restituisce la lista di attributi
Proprietà pubblica | MyCod_Id | Restituisce/Imposta la maschera di codifica per DED_ID di questa famiglia.
Proprietà pubblica | MyIsPrj | Restituisce/Imposta se si tratti di una famiglia di tipo progetto (questa famiglia).
Proprietà pubblica | MyMaster | Identifica il master collegato alla tipologia
Proprietà pubblica | MyProgr | Restituisce/Imposta il valore del progressivo strettamente di questa famiglia. Non interroga il Database ma restituisce il valore della cache.
Proprietà pubblica | MyProgrAlphabet | Restituisce/Imposta l'alfabeto per il progressivo di questa famiglia.
Proprietà pubblica | MyRevisionAlphabet | Restituisce/Imposta l'alfabeto per il progressivo di questa famiglia.
Proprietà pubblica | MyRules | Restituisce la lista delle regole di autocomposizione di questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota.
Proprietà pubblica | MyVarAlphabet | Restituisce/Imposta l'alfabeto per la variante di questa famiglia.
Proprietà pubblica | Nome | Restituisce/Imposta il nome della famiglia.
Proprietà pubblica | Parent | Restituisce la collezione di appartenenza.
Proprietà pubblica | Progr | Restituisce il progressivo eventualmente ereditato, se non presente in questa famiglia.
Proprietà pubblica | ProgrAlphabet | Restituisce l'alfabeto per la variante di questa famiglia. Restitusice l'alfabeto ereditato se non è impostato per questa famiglia.
Proprietà pubblica | ReservedProgTableName | Nome della tabella del DB dove sono gestiti i progressivi assegnati
Proprietà pubblica | RevisionAlphabet | Restituisce l'alfabeto per il progressivo di questa famiglia. Restitusice l'alfabeto ereditato se non è impostato per questa famiglia.
Proprietà pubblica | Root | Restituisce la root di questi oggetti
Proprietà pubblica | RuleDirty | Restituisce se sono state modificate le regole.
Proprietà pubblica | Rules | Restituisce la lista delle regole di autocomposizione visibili da questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota.
Proprietà pubblica | RuleTableName | Nome della tabella del DB con le regole
Proprietà pubblica | StatoRecord | Restituisce o imposta lo stato del record. DI USO INTERNO !!
Proprietà pubblica | SubTypes | Restituisce la lista delle sottofamiglie di questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota.
Proprietà pubblica | TableName | Nome della tabella del DB con i suoi oggetti
Proprietà pubblica | TypeDirty | Restituisce se sono state modificate le famiglie.
Proprietà pubblica | VarAlphabet | Restituisce l'alfabeto per il progressivo di questa famiglia. Restitusice l'alfabeto ereditato se non è impostato per questa famiglia.
Torna su
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Proprietà DedTypeBase.Application

Proprietà DedTypeBaseApplication
Restituisce l'applicazione di appartenenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedNetApplication Application { get; }
Public ReadOnly Property Application As DedNetApplication
    Get
public:
property DedNetApplication^ Application {
    DedNetApplication^ get ();
}
member Application : DedNetApplication with get

Valore della proprietà

DedNetApplication
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Proprietà DedTypeBase.Attributes

Proprietà DedTypeBaseAttributes
Lista degli attributi

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public abstract DedAttrList Attributes { get; }
Public MustOverride ReadOnly Property Attributes As DedAttrList
    Get
public:
virtual property DedAttrList^ Attributes {
    DedAttrList^ get () abstract;
}
abstract Attributes : DedAttrList with get

Valore della proprietà

DedAttrList
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Proprietà DedTypeBase.BackColor

Proprietà DedTypeBaseBackColor
Restituisce il colore di sfondo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Color BackColor { get; set; }
Public Property BackColor As Color
    Get
    Set
public:
property Color BackColor {
    Color get ();
    void set (Color value);
}
member BackColor : Color with get, set

Valore della proprietà

Color
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Proprietà DedTypeBase.CalculatedAttrs

Proprietà DedTypeBaseCalculatedAttrs
Lista che contiene quali attributi sono considerati 'importati'.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList CalculatedAttrs { get; }
Public ReadOnly Property CalculatedAttrs As DedAttrList
    Get
public:
property DedAttrList^ CalculatedAttrs {
    DedAttrList^ get ();
}
member CalculatedAttrs : DedAttrList with get

Valore della proprietà

DedAttrList
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Proprietà DedTypeBase.ClonedFrom

Proprietà DedTypeBaseClonedFrom
Indica se la famiglia è stata clonata e da quale

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeBase ClonedFrom { get; set; }
Public Property ClonedFrom As DedTypeBase
    Get
    Set
public:
property DedTypeBase^ ClonedFrom {
    DedTypeBase^ get ();
    void set (DedTypeBase^ value);
}
member ClonedFrom : DedTypeBase with get, set

Valore della proprietà

DedTypeBase
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Proprietà DedTypeBase.Cod_Id

Proprietà DedTypeBaseCod_Id
Restituisce la maschera di codifica per DED_ID, eventualmente ereditata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Cod_Id { get; }
Public ReadOnly Property Cod_Id As String
    Get
public:
property String^ Cod_Id {
    String^ get ();
}
member Cod_Id : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Proprietà DedTypeBase.DbPath

Proprietà DedTypeBaseDbPath
Restituisce il DbPath della famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string DbPath { get; }
Public ReadOnly Property DbPath As String
    Get
public:
property String^ DbPath {
    String^ get ();
}
member DbPath : string with get

Valore della proprietà

String
Note
Si tratta di una caratteristica calcolata dinamicamente in base alla posizione dell'oggetto nel'albero. Viene usato il Name di tutti i genitori della gerarchia per calcolare il DbPath.
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Proprietà DedTypeBase.Descriz

Proprietà DedTypeBaseDescriz
Restituisce/Imposta la descrizione della famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Descriz { get; set; }
Public Property Descriz As String
    Get
    Set
public:
property String^ Descriz {
    String^ get ();
    void set (String^ value);
}
member Descriz : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Proprietà DedTypeBase.Dirty

Proprietà DedTypeBaseDirty
Indica se è stato modificato

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public abstract bool Dirty { get; }
Public MustOverride ReadOnly Property Dirty As Boolean
    Get
public:
virtual property bool Dirty {
    bool get () abstract;
}
abstract Dirty : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Proprietà DedTypeBase.DirtyName

Proprietà DedTypeBaseDirtyName
Indica se è stato modificato il nome della famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool DirtyName { get; set; }
Public Property DirtyName As Boolean
    Get
    Set
public:
property bool DirtyName {
    bool get ();
    void set (bool value);
}
member DirtyName : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Proprietà DedTypeBase.FamFirstLev

Proprietà DedTypeBaseFamFirstLev
Restituisce la famiglia a 1° livello.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeBase FamFirstLev { get; }
Public ReadOnly Property FamFirstLev As DedTypeBase
    Get
public:
property DedTypeBase^ FamFirstLev {
    DedTypeBase^ get ();
}
member FamFirstLev : DedTypeBase with get

Valore di ritorno

DedTypeBase
Restituisce la famiglia a primo livello oppure null se è la Root.
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Proprietà DedTypeBase.ForeColor

Proprietà DedTypeBaseForeColor
Restituisce il colore del testo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Color ForeColor { get; set; }
Public Property ForeColor As Color
    Get
    Set
public:
property Color ForeColor {
    Color get ();
    void set (Color value);
}
member ForeColor : Color with get, set

Valore della proprietà

Color
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Proprietà DedTypeBase.FreeCode

Proprietà DedTypeBaseFreeCode
Restituisce/Imposta se la famiglia è a codifica libera.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool FreeCode { get; set; }
Public Property FreeCode As Boolean
    Get
    Set
public:
property bool FreeCode {
    bool get ();
    void set (bool value);
}
member FreeCode : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Proprietà DedTypeBase.FreeFile

Proprietà DedTypeBaseFreeFile
Restituisce/Imposta se la famiglia è a codifica file libera.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual bool FreeFile { get; set; }
Public Overridable Property FreeFile As Boolean
    Get
    Set
public:
virtual property bool FreeFile {
    bool get ();
    void set (bool value);
}
abstract FreeFile : bool with get, set
override FreeFile : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Proprietà DedTypeBase.FreeFileAsDedId

Proprietà DedTypeBaseFreeFileAsDedId
Restituisce/Imposta se il file debba essere compilato come l'id.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual bool FreeFileAsDedId { get; set; }
Public Overridable Property FreeFileAsDedId As Boolean
    Get
    Set
public:
virtual property bool FreeFileAsDedId {
    bool get ();
    void set (bool value);
}
abstract FreeFileAsDedId : bool with get, set
override FreeFileAsDedId : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Proprietà DedTypeBase.FreeFileSameFileRev

Proprietà DedTypeBaseFreeFileSameFileRev
Restituisce/Imposta se il file debba rimanere uguale anche nelle revisioni.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual bool FreeFileSameFileRev { get; set; }
Public Overridable Property FreeFileSameFileRev As Boolean
    Get
    Set
public:
virtual property bool FreeFileSameFileRev {
    bool get ();
    void set (bool value);
}
abstract FreeFileSameFileRev : bool with get, set
override FreeFileSameFileRev : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Proprietà DedTypeBase.HasAttributes

Proprietà DedTypeBaseHasAttributes

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public abstract bool HasAttributes { get; }
Public MustOverride ReadOnly Property HasAttributes As Boolean
    Get
public:
virtual property bool HasAttributes {
    bool get () abstract;
}
abstract HasAttributes : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Proprietà DedTypeBase.HasCod_Id

Proprietà DedTypeBaseHasCod_Id
Restituisce se è presente la codifica del DEDID.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasCod_Id { get; }
Public ReadOnly Property HasCod_Id As Boolean
    Get
public:
property bool HasCod_Id {
    bool get ();
}
member HasCod_Id : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Proprietà DedTypeBase.HasInfoUser

Proprietà DedTypeBaseHasInfoUser
Restiutuisce se la famiglia ha il tassello utente o la variante automatica nell'id.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasInfoUser { get; }
Public ReadOnly Property HasInfoUser As Boolean
    Get
public:
property bool HasInfoUser {
    bool get ();
}
member HasInfoUser : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Proprietà DedTypeBase.HasMaster

Proprietà DedTypeBaseHasMaster
Restituisce se è presente il master

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasMaster { get; }
Public ReadOnly Property HasMaster As Boolean
    Get
public:
property bool HasMaster {
    bool get ();
}
member HasMaster : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Proprietà DedTypeBase.HasParent

Proprietà DedTypeBaseHasParent
Restituisce se è presente un oggetto genitore.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasParent { get; }
Public ReadOnly Property HasParent As Boolean
    Get
public:
property bool HasParent {
    bool get ();
}
member HasParent : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Proprietà DedTypeBase.HasProgr

Proprietà DedTypeBaseHasProgr
Restituisce se la famiglia ha il progressivo locale impostato e non lo eredita (MyProgr> -1).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasProgr { get; }
Public ReadOnly Property HasProgr As Boolean
    Get
public:
property bool HasProgr {
    bool get ();
}
member HasProgr : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Proprietà DedTypeBase.HasProgrAlphabet

Proprietà DedTypeBaseHasProgrAlphabet
Restituisce se è presente l'alfabeto del progressivo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasProgrAlphabet { get; }
Public ReadOnly Property HasProgrAlphabet As Boolean
    Get
public:
property bool HasProgrAlphabet {
    bool get ();
}
member HasProgrAlphabet : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Proprietà DedTypeBase.HasRevisionAlphabet

Proprietà DedTypeBaseHasRevisionAlphabet
Restituisce se è presente l'alfabeto della revisione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasRevisionAlphabet { get; }
Public ReadOnly Property HasRevisionAlphabet As Boolean
    Get
public:
property bool HasRevisionAlphabet {
    bool get ();
}
member HasRevisionAlphabet : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Proprietà DedTypeBase.HasRules

Proprietà DedTypeBaseHasRules
Restituisce se sono presenti regole di autocomposizione specifiche della famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasRules { get; }
Public ReadOnly Property HasRules As Boolean
    Get
public:
property bool HasRules {
    bool get ();
}
member HasRules : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Proprietà DedTypeBase.HasSubTypes

Proprietà DedTypeBaseHasSubTypes
Restituisce se sono presenti sottotipi della famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasSubTypes { get; }
Public ReadOnly Property HasSubTypes As Boolean
    Get
public:
property bool HasSubTypes {
    bool get ();
}
member HasSubTypes : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Proprietà DedTypeBase.HasVar

Proprietà DedTypeBaseHasVar
Restiutuisce se la famiglia ha la variante automatica nell'id.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasVar { get; }
Public ReadOnly Property HasVar As Boolean
    Get
public:
property bool HasVar {
    bool get ();
}
member HasVar : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Proprietà DedTypeBase.HasVarAlphabet

Proprietà DedTypeBaseHasVarAlphabet
Restituisce se è presente l'alfabeto del progressivo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasVarAlphabet { get; }
Public ReadOnly Property HasVarAlphabet As Boolean
    Get
public:
property bool HasVarAlphabet {
    bool get ();
}
member HasVarAlphabet : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Proprietà DedTypeBase.IsCompleted

Proprietà DedTypeBaseIsCompleted
Restituisce se la famiglia è completa ovvero può essere utilizzata come famiglia terminale di codifica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public abstract bool IsCompleted { get; }
Public MustOverride ReadOnly Property IsCompleted As Boolean
    Get
public:
virtual property bool IsCompleted {
    bool get () abstract;
}
abstract IsCompleted : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Proprietà DedTypeBase.IsPrj

Proprietà DedTypeBaseIsPrj
Restituisce se si tratti di una famiglia di tipo progetto (eventualmente ereditato).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsPrj { get; }
Public ReadOnly Property IsPrj As Boolean
    Get
public:
property bool IsPrj {
    bool get ();
}
member IsPrj : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Proprietà DedTypeBase.IsRoot

Proprietà DedTypeBaseIsRoot
Restituisce se si tratta della root dell'albero dei tipi.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsRoot { get; }
Public ReadOnly Property IsRoot As Boolean
    Get
public:
property bool IsRoot {
    bool get ();
}
member IsRoot : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Proprietà DedTypeBase.Level

Proprietà DedTypeBaseLevel
Restituisce il livello di questa famiglia, partendo da 0 per la famiglia root.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int Level { get; }
Public ReadOnly Property Level As Integer
    Get
public:
property int Level {
    int get ();
}
member Level : int with get

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Proprietà DedTypeBase.Master

Proprietà DedTypeBaseMaster
Identifica il master collegato alla tipologia

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Guid Master { get; }
Public ReadOnly Property Master As Guid
    Get
public:
property Guid Master {
    Guid get ();
}
member Master : Guid with get

Valore della proprietà

Guid
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Proprietà DedTypeBase.MyAttributes

Proprietà DedTypeBaseMyAttributes
Restituisce la lista di attributi

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual DedAttrList MyAttributes { get; }
Public Overridable ReadOnly Property MyAttributes As DedAttrList
    Get
public:
virtual property DedAttrList^ MyAttributes {
    DedAttrList^ get ();
}
abstract MyAttributes : DedAttrList with get
override MyAttributes : DedAttrList with get

Valore della proprietà

DedAttrList
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Proprietà DedTypeBase.MyCod_Id

Proprietà DedTypeBaseMyCod_Id
Restituisce/Imposta la maschera di codifica per DED_ID di questa famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string MyCod_Id { get; set; }
Public Property MyCod_Id As String
    Get
    Set
public:
property String^ MyCod_Id {
    String^ get ();
    void set (String^ value);
}
member MyCod_Id : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Proprietà DedTypeBase.MyIsPrj

Proprietà DedTypeBaseMyIsPrj
Restituisce/Imposta se si tratti di una famiglia di tipo progetto (questa famiglia).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool MyIsPrj { get; set; }
Public Property MyIsPrj As Boolean
    Get
    Set
public:
property bool MyIsPrj {
    bool get ();
    void set (bool value);
}
member MyIsPrj : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Proprietà DedTypeBase.MyMaster

Proprietà DedTypeBaseMyMaster
Identifica il master collegato alla tipologia

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Guid MyMaster { get; set; }
Public Property MyMaster As Guid
    Get
    Set
public:
property Guid MyMaster {
    Guid get ();
    void set (Guid value);
}
member MyMaster : Guid with get, set

Valore della proprietà

Guid
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Proprietà DedTypeBase.MyProgr

Proprietà DedTypeBaseMyProgr
Restituisce/Imposta il valore del progressivo strettamente di questa famiglia. Non interroga il Database ma restituisce il valore della cache.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string MyProgr { get; set; }
Public Property MyProgr As String
    Get
    Set
public:
property String^ MyProgr {
    String^ get ();
    void set (String^ value);
}
member MyProgr : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Proprietà DedTypeBase.MyProgrAlphabet

Proprietà DedTypeBaseMyProgrAlphabet
Restituisce/Imposta l'alfabeto per il progressivo di questa famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string MyProgrAlphabet { get; set; }
Public Property MyProgrAlphabet As String
    Get
    Set
public:
property String^ MyProgrAlphabet {
    String^ get ();
    void set (String^ value);
}
member MyProgrAlphabet : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Proprietà DedTypeBase.MyRevisionAlphabet

Proprietà DedTypeBaseMyRevisionAlphabet
Restituisce/Imposta l'alfabeto per il progressivo di questa famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string MyRevisionAlphabet { get; set; }
Public Property MyRevisionAlphabet As String
    Get
    Set
public:
property String^ MyRevisionAlphabet {
    String^ get ();
    void set (String^ value);
}
member MyRevisionAlphabet : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Proprietà DedTypeBase.MyRules

Proprietà DedTypeBaseMyRules
Restituisce la lista delle regole di autocomposizione di questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedRuleCollection MyRules { get; }
Public ReadOnly Property MyRules As DedRuleCollection
    Get
public:
property DedRuleCollection^ MyRules {
    DedRuleCollection^ get ();
}
member MyRules : DedRuleCollection with get

Valore della proprietà

DedRuleCollection
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Proprietà DedTypeBase.MyVarAlphabet

Proprietà DedTypeBaseMyVarAlphabet
Restituisce/Imposta l'alfabeto per la variante di questa famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string MyVarAlphabet { get; set; }
Public Property MyVarAlphabet As String
    Get
    Set
public:
property String^ MyVarAlphabet {
    String^ get ();
    void set (String^ value);
}
member MyVarAlphabet : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Proprietà DedTypeBase.Nome

Proprietà DedTypeBaseNome
Restituisce/Imposta il nome della famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Nome { get; set; }
Public Property Nome As String
    Get
    Set
public:
property String^ Nome {
    String^ get ();
    void set (String^ value);
}
member Nome : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Proprietà DedTypeBase.Parent

Proprietà DedTypeBaseParent
Restituisce la collezione di appartenenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object Parent { get; }
Public ReadOnly Property Parent As Object
    Get
public:
property Object^ Parent {
    Object^ get ();
}
member Parent : Object with get

Valore della proprietà

Object
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Proprietà DedTypeBase.Progr

Proprietà DedTypeBaseProgr
Restituisce il progressivo eventualmente ereditato, se non presente in questa famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Progr { get; }
Public ReadOnly Property Progr As String
    Get
public:
property String^ Progr {
    String^ get ();
}
member Progr : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Proprietà DedTypeBase.ProgrAlphabet

Proprietà DedTypeBaseProgrAlphabet
Restituisce l'alfabeto per la variante di questa famiglia. Restitusice l'alfabeto ereditato se non è impostato per questa famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string ProgrAlphabet { get; }
Public ReadOnly Property ProgrAlphabet As String
    Get
public:
property String^ ProgrAlphabet {
    String^ get ();
}
member ProgrAlphabet : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Proprietà DedTypeBase.ReservedProgTableName

Proprietà DedTypeBaseReservedProgTableName
Nome della tabella del DB dove sono gestiti i progressivi assegnati

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public abstract string ReservedProgTableName { get; }
Public MustOverride ReadOnly Property ReservedProgTableName As String
    Get
public:
virtual property String^ ReservedProgTableName {
    String^ get () abstract;
}
abstract ReservedProgTableName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Proprietà DedTypeBase.RevisionAlphabet

Proprietà DedTypeBaseRevisionAlphabet
Restituisce l'alfabeto per il progressivo di questa famiglia. Restitusice l'alfabeto ereditato se non è impostato per questa famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string RevisionAlphabet { get; }
Public ReadOnly Property RevisionAlphabet As String
    Get
public:
property String^ RevisionAlphabet {
    String^ get ();
}
member RevisionAlphabet : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Proprietà DedTypeBase.Root

Proprietà DedTypeBaseRoot
Restituisce la root di questi oggetti

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public abstract DedTypeBase Root { get; }
Public MustOverride ReadOnly Property Root As DedTypeBase
    Get
public:
virtual property DedTypeBase^ Root {
    DedTypeBase^ get () abstract;
}
abstract Root : DedTypeBase with get

Valore della proprietà

DedTypeBase
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Proprietà DedTypeBase.RuleDirty

Proprietà DedTypeBaseRuleDirty
Restituisce se sono state modificate le regole.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool RuleDirty { get; }
Public ReadOnly Property RuleDirty As Boolean
    Get
public:
property bool RuleDirty {
    bool get ();
}
member RuleDirty : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Proprietà DedTypeBase.Rules

Proprietà DedTypeBaseRules
Restituisce la lista delle regole di autocomposizione visibili da questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedRuleList Rules { get; }
Public ReadOnly Property Rules As DedRuleList
    Get
public:
property DedRuleList^ Rules {
    DedRuleList^ get ();
}
member Rules : DedRuleList with get

Valore della proprietà

DedRuleList
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Proprietà DedTypeBase.RuleTableName

Proprietà DedTypeBaseRuleTableName
Nome della tabella del DB con le regole

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public abstract string RuleTableName { get; }
Public MustOverride ReadOnly Property RuleTableName As String
    Get
public:
virtual property String^ RuleTableName {
    String^ get () abstract;
}
abstract RuleTableName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Proprietà DedTypeBase.StatoRecord

Proprietà DedTypeBaseStatoRecord
Restituisce o imposta lo stato del record. DI USO INTERNO !!

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public StatoRecord StatoRecord { get; set; }
Public Property StatoRecord As StatoRecord
    Get
    Set
public:
virtual property StatoRecord^ StatoRecord {
    StatoRecord^ get () sealed;
    void set (StatoRecord^ value) sealed;
}
abstract StatoRecord : StatoRecord with get, set
override StatoRecord : StatoRecord with get, set

Valore della proprietà

StatoRecord

Implementa

IDedDbItemStatoRecord
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Proprietà DedTypeBase.SubTypes

Proprietà DedTypeBaseSubTypes
Restituisce la lista delle sottofamiglie di questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public abstract Object SubTypes { get; }
Public MustOverride ReadOnly Property SubTypes As Object
    Get
public:
virtual property Object^ SubTypes {
    Object^ get () abstract;
}
abstract SubTypes : Object with get

Valore della proprietà

Object
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Proprietà DedTypeBase.TableName

Proprietà DedTypeBaseTableName
Nome della tabella del DB con i suoi oggetti

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public abstract string TableName { get; }
Public MustOverride ReadOnly Property TableName As String
    Get
public:
virtual property String^ TableName {
    String^ get () abstract;
}
abstract TableName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Proprietà DedTypeBase.TypeDirty

Proprietà DedTypeBaseTypeDirty
Restituisce se sono state modificate le famiglie.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool TypeDirty { get; }
Public ReadOnly Property TypeDirty As Boolean
    Get
public:
property bool TypeDirty {
    bool get ();
}
member TypeDirty : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Proprietà DedTypeBase.VarAlphabet

Proprietà DedTypeBaseVarAlphabet
Restituisce l'alfabeto per il progressivo di questa famiglia. Restitusice l'alfabeto ereditato se non è impostato per questa famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string VarAlphabet { get; }
Public ReadOnly Property VarAlphabet As String
    Get
public:
property String^ VarAlphabet {
    String^ get ();
}
member VarAlphabet : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Metodi di DedTypeBase

Il tipo DedTypeBase espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | DecodeDedId(String) |
Metodo pubblico | DecodeDedId(String, String) |
Metodo pubblico | EncodeDedId |
Metodo pubblico | FindAttrByName | Restituisce l'attriibuto dal name passato
Metodo pubblico | FindAttrByPrompt | Restituisce l'attriibuto dal prompt passato
Metodo pubblico | FindBusyProgrRecursive | Metodo per cercare i progressivi attualmente in uso
Metodo pubblico | FindByDbPath | Cerca il tipo corrispondente al dbpath passato in tutto l'albero partendo dalla radice.
Metodo pubblico | ForEachChild | Questo metodo chiama un delegate passandogli in sequenza il nodo corrente (opzionalmente) e tutti i suoi nodi figli.
Metodo pubblico | ForEachParent | Questo metodo chiama un delegate passandogli in sequenza il nodo root e giù fino al nodo corrente (opzionalmente) Lo scorrimento avviene quindi in modo discendente dal padre di tutti verso l'oggetto corrente.
Metodo pubblico | FormatDedRev | Data una stringa di revisione restituisce il valore correttamente formattato e della giusta dimensione per questa famiglia. Es: "1" -> "01" (con rev. di 2 caratteri); "12" -> "012" (con rev. di 3 caratteri); "05" -> "5" (con rev. di 1 carattere);
Metodo pubblico | FormatProgr | Data una stringa di progressivo restituisce il valore correttamente formattato e della giusta dimensione per questa famiglia. Es: "1" -> "001" (progr. di 3 caratteri); "12" -> "012" (progr. di 3 caratteri); "05" -> "5" (progr. di 1 carattere);
Metodo pubblico | FormatVar | Data una stringa della variante restituisce il valore correttamente formattato e della giusta dimensione per questa famiglia. Es: "1" -> "001" (progr. di 3 caratteri); "12" -> "012" (progr. di 3 caratteri); "05" -> "5" (progr. di 1 carattere);
Metodo pubblico | ForOneChild | Questo metodo chiama un delegate passandogli in sequenza il nodo corrente (opzionalmente) e tutti i suoi nodi figli.
Metodo pubblico | GetAttrNameFromPrompt | Restituisce il nome di un attributo visibile da questa famiglia dato il suo prompt.
Metodo pubblico | GetAttrsFromCategory(DedCateg) | Ritorna la lista di attributi visibili dalla famiglia che appartengono alla categoria passata.
Metodo pubblico | GetAttrsFromCategory(String) | Ritorna la lista di attributi visibili dalla famiglia che appartengono alla categoria passata.
Metodo pubblico | GetBusyProgr | Restituisce un dizionario con tutti i progressivi utilizzati.
Metodo pubblico | GetFamSpecificLevel | Restituisce la famiglia a n° livello.
Metodo pubblico | GetFamSpecificNegativeLevel | Restituisce la famiglia a n° livello negativo.
Metodo pubblico | GetFieldsCod | Restituisce la lista delle stringhe nella queli cercare i tasselli.
Metodo pubblico | GetFirstParentHasProg | Restituisce la prima famiglia genitore che ha il progressivo locale.Considera anche il nodo corrente per avere la sicurezza che se viene chiamato su una famiglia con con progressivo impostato non lo calcoli sul padre ma su se stesso.
Metodo pubblico | GetFreeProgr | Restituisce una lista sempre inizializzata e ordinata con tutti i progressivi liberi per questa famiglia.
Metodo pubblico | GetLastProgr | Restituisce l'ultimo progressivo possibile per questa famiglia.
Metodo pubblico | GetMaxTokenNum | Restituisce il massimo numero di caratteri usati per il TokenTypeEnum passato. Verifica nella maschera di codifica Cod_Id, Cod_Fil e Cod_Dis in modo da prendere il numero massimo di caratteri utilizzati.
Metodo pubblico | GetParentTypes | Restituisce una lista dei FamilyType genitori, compresa l'istanza stessa se specificato.
Metodo pubblico | GetProgr(Boolean) | Restituisce il progressivo della famiglia che ha invocato il metodo oppure il progressivo della prima famiglia genitore che lo possiede. Lavora sull'utente attualmente connesso ( se deve lavorare in DED_TIPI_PROG ).
Metodo pubblico | GetProgr(Boolean, String) | Restituisce il progressivo della famiglia che ha invocato il metodo oppure il progressivo della prima famiglia genitore che lo possiede
Metodo pubblico | GetProgrTokenNum | Restituisce il numero di caratteri da utilizzare per creare la stringa del progressivo per questa famiglia. Li calcola cercando il tassello del progressivo nella codifica del Cod_Id. Se non è presente restituisce 0.
Metodo pubblico | GetRightMask | Restituisce il TokenInfo cercato nella prima maschera di codifica trovata, da utilizzare poi per calcolare il numero di tasselli per un particolare token. Restituisce null se non la trova.
Metodo pubblico | MakeAttrsDictionary | Riempie il dizionario _dizfields.
Metodo pubblico | NotifyDirty | In base al fatto che si tratti della root o meno notifica al parent corretto l'avvenuta modifica della proprietà.
Metodo pubblico | Save | Metodo per il salvataggio delle modifiche.
Metodo pubblico | SetProgr(String, String, Boolean) | Imposta il progressivo di questa famiglia o della famiglia dalla quale questa eredita il progressivo. Lavora sull'utente attualmente connesso ( se deve lavorare in DED_TIPI_PROG ).
Metodo pubblico | SetProgr(String, String, Boolean, String) | Imposta il progressivo di questa famiglia o della famiglia dalla quale questa eredita il progressivo.
Metodo pubblico | SetProgr(String, String, Boolean, String, Boolean) | Imposta il progressivo di questa famiglia o della famiglia dalla quale questa eredita il progressivo.
Metodo pubblico | WaitForUpdate | Esegue una query con WITH (XLOCK) in modo da aspettare finchè altri utenti non hanno commitato.
Torna su
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Metodo DedTypeBase.DecodeDedId

Metodo DedTypeBaseDecodeDedId
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | DecodeDedId(String) |
Metodo pubblico | DecodeDedId(String, String) |
Torna su
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Metodo DedTypeBase.DecodeDedId(String)

Metodo DedTypeBaseDecodeDedId(String)

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public abstract DedEncodeInfo DecodeDedId(
    string stringToDecode
)
Public MustOverride Function DecodeDedId (
    stringToDecode As String
) As DedEncodeInfo
public:
virtual DedEncodeInfo^ DecodeDedId(
    String^ stringToDecode
) abstract
abstract DecodeDedId :
        stringToDecode : string -> DedEncodeInfo

Parametri

stringToDecode String

Valore di ritorno

DedEncodeInfo
Vedi anche

Documentazione

Classe DedTypeBase
Overload di DecodeDedId
Namespace DedNet.Core


Metodo DedTypeBase.DecodeDedId(String, String)

Metodo DedTypeBaseDecodeDedId(String, String)

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public abstract DedEncodeInfo DecodeDedId(
    string stringToDecode,
    string cod_id
)
Public MustOverride Function DecodeDedId (
    stringToDecode As String,
    cod_id As String
) As DedEncodeInfo
public:
virtual DedEncodeInfo^ DecodeDedId(
    String^ stringToDecode,
    String^ cod_id
) abstract
abstract DecodeDedId :
        stringToDecode : string *
        cod_id : string -> DedEncodeInfo

Parametri

stringToDecode String
cod_id String

Valore di ritorno

DedEncodeInfo
Vedi anche

Documentazione

Classe DedTypeBase
Overload di DecodeDedId
Namespace DedNet.Core


Metodo DedTypeBase.EncodeDedId

Metodo DedTypeBaseEncodeDedId

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public abstract string EncodeDedId(
    DedEncodeInfo info
)
Public MustOverride Function EncodeDedId (
    info As DedEncodeInfo
) As String
public:
virtual String^ EncodeDedId(
    DedEncodeInfo^ info
) abstract
abstract EncodeDedId :
        info : DedEncodeInfo -> string

Parametri

info DedEncodeInfo

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Metodo DedTypeBase.FindAttrByName

Metodo DedTypeBaseFindAttrByName
Restituisce l'attriibuto dal name passato

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public abstract DedAttr FindAttrByName(
    string prompt
)
Public MustOverride Function FindAttrByName (
    prompt As String
) As DedAttr
public:
virtual DedAttr^ FindAttrByName(
    String^ prompt
) abstract
abstract FindAttrByName :
        prompt : string -> DedAttr

Parametri

prompt String
Nome dell'attributo

Valore di ritorno

DedAttr
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Metodo DedTypeBase.FindAttrByPrompt

Metodo DedTypeBaseFindAttrByPrompt
Restituisce l'attriibuto dal prompt passato

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public abstract DedAttr FindAttrByPrompt(
    string prompt
)
Public MustOverride Function FindAttrByPrompt (
    prompt As String
) As DedAttr
public:
virtual DedAttr^ FindAttrByPrompt(
    String^ prompt
) abstract
abstract FindAttrByPrompt :
        prompt : string -> DedAttr

Parametri

prompt String
Prompt dell'attributo da cercare

Valore di ritorno

DedAttr
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Metodo DedTypeBase.FindBusyProgrRecursive

Metodo DedTypeBaseFindBusyProgrRecursive
Metodo per cercare i progressivi attualmente in uso

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public abstract void FindBusyProgrRecursive(
    DedTypeBase tipo,
    Dictionary<string, string> progrBusy,
    string username = "",
    DataTable dt = null
)
Public MustOverride Sub FindBusyProgrRecursive (
    tipo As DedTypeBase,
    progrBusy As Dictionary(Of String, String),
    Optional username As String = "",
    Optional dt As DataTable = Nothing
)
public:
virtual void FindBusyProgrRecursive(
    DedTypeBase^ tipo,
    Dictionary<String^, String^>^ progrBusy,
    String^ username = L"",
    DataTable^ dt = nullptr
) abstract
abstract FindBusyProgrRecursive :
        tipo : DedTypeBase *
        progrBusy : Dictionary<string, string> *
        ?username : string *
        ?dt : DataTable
(* Defaults:
        let _username = defaultArg username ""
        let _dt = defaultArg dt null
*)
-> unit

Parametri

tipo DedTypeBase
progrBusy Dictionary String, String
username String (Optional)
dt DataTable (Optional)
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Metodo DedTypeBase.FindByDbPath

Metodo DedTypeBaseFindByDbPath
Cerca il tipo corrispondente al dbpath passato in tutto l'albero partendo dalla radice.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public abstract DedTypeBase FindByDbPath(
    string dbpath
)
Public MustOverride Function FindByDbPath (
    dbpath As String
) As DedTypeBase
public:
virtual DedTypeBase^ FindByDbPath(
    String^ dbpath
) abstract
abstract FindByDbPath :
        dbpath : string -> DedTypeBase

Parametri

dbpath String
DbPath da cercare nell'albero dei tipi.

Valore di ritorno

DedTypeBase
Restituisce il FamilyType avente il DbPath specificato oppure null se la ricerca non ha avuto esito.
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Metodo DedTypeBase.ForEachChild

Metodo DedTypeBaseForEachChild
Questo metodo chiama un delegate passandogli in sequenza il nodo corrente (opzionalmente) e tutti i suoi nodi figli.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ForEachChild(
    DedTypeBaseCallMeForEachNode deleg,
    bool IncludeCurrentNode,
    bool bOrizzontal
)
Public Function ForEachChild (
    deleg As DedTypeBaseCallMeForEachNode,
    IncludeCurrentNode As Boolean,
    bOrizzontal As Boolean
) As Boolean
public:
bool ForEachChild(
    DedTypeBaseCallMeForEachNode^ deleg,
    bool IncludeCurrentNode,
    bool bOrizzontal
)
member ForEachChild :
        deleg : DedTypeBaseCallMeForEachNode *
        IncludeCurrentNode : bool *
        bOrizzontal : bool -> bool

Parametri

deleg DedTypeBaseCallMeForEachNode
Delegate di tipo CallMeForEachNode da chiamare per ogni nodo.
IncludeCurrentNode Boolean
Se chiamare il delegate anche per il nodo corrente (del quale si stà invocando il metodo).
bOrizzontal Boolean
Indica al metodo di applicare la navigazione orizzontale invece di quella verticale.

Valore di ritorno

Boolean
Restituisce quello che è stato restituito dal delegate ovvero se il ciclo è stato svolto completamente o se è stato interrotto perché il delegate ha restituito false.
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Metodo DedTypeBase.ForEachParent

Metodo DedTypeBaseForEachParent
Questo metodo chiama un delegate passandogli in sequenza il nodo root e giù fino al nodo corrente (opzionalmente) Lo scorrimento avviene quindi in modo discendente dal padre di tutti verso l'oggetto corrente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ForEachParent(
    DedTypeBaseCallMeForEachNode deleg,
    bool IncludeCurrentNode
)
Public Function ForEachParent (
    deleg As DedTypeBaseCallMeForEachNode,
    IncludeCurrentNode As Boolean
) As Boolean
public:
bool ForEachParent(
    DedTypeBaseCallMeForEachNode^ deleg,
    bool IncludeCurrentNode
)
member ForEachParent :
        deleg : DedTypeBaseCallMeForEachNode *
        IncludeCurrentNode : bool -> bool

Parametri

deleg DedTypeBaseCallMeForEachNode
Delegate da chiamare per ogni nodo.
IncludeCurrentNode Boolean
Se chiamare il delegate anche per il nodo corrente (del quale si stà invocando il metodo).

Valore di ritorno

Boolean
Restituisce quello che è stato restituito dal delegate ovvero se il ciclo è stato svolto completamente o se è stato interrotto perché il delegate ha restituito false. Lo scorrimento avviene in modo discendente dal padre di tutti verso l'oggetto corrente.
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Metodo DedTypeBase.FormatDedRev

Metodo DedTypeBaseFormatDedRev
Data una stringa di revisione restituisce il valore correttamente formattato e della giusta dimensione per questa famiglia. Es: "1" -> "01" (con rev. di 2 caratteri); "12" -> "012" (con rev. di 3 caratteri); "05" -> "5" (con rev. di 1 carattere);

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string FormatDedRev(
    string rev
)
Public Function FormatDedRev (
    rev As String
) As String
public:
String^ FormatDedRev(
    String^ rev
)
member FormatDedRev :
        rev : string -> string

Parametri

rev String
Valore della revisione da sistemare.

Valore di ritorno

String
Restituisce il DEDREV corretto.
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Metodo DedTypeBase.FormatProgr

Metodo DedTypeBaseFormatProgr
Data una stringa di progressivo restituisce il valore correttamente formattato e della giusta dimensione per questa famiglia. Es: "1" -> "001" (progr. di 3 caratteri); "12" -> "012" (progr. di 3 caratteri); "05" -> "5" (progr. di 1 carattere);

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string FormatProgr(
    string progr,
    int? maxTokenNum = null
)
Public Function FormatProgr (
    progr As String,
    Optional maxTokenNum As Integer? = Nothing
) As String
public:
String^ FormatProgr(
    String^ progr,
    Nullable<int> maxTokenNum = nullptr
)
member FormatProgr :
        progr : string *
        ?maxTokenNum : Nullable<int>
(* Defaults:
        let _maxTokenNum = defaultArg maxTokenNum null
*)
-> string

Parametri

progr String
Valore del progressivo da sistemare.
maxTokenNum Nullable Int32 (Optional)

Valore di ritorno

String
Restituisce il progressivo corretto.
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Metodo DedTypeBase.FormatVar

Metodo DedTypeBaseFormatVar
Data una stringa della variante restituisce il valore correttamente formattato e della giusta dimensione per questa famiglia. Es: "1" -> "001" (progr. di 3 caratteri); "12" -> "012" (progr. di 3 caratteri); "05" -> "5" (progr. di 1 carattere);

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string FormatVar(
    string var,
    int? maxTokenNum = null
)
Public Function FormatVar (
    var As String,
    Optional maxTokenNum As Integer? = Nothing
) As String
public:
String^ FormatVar(
    String^ var,
    Nullable<int> maxTokenNum = nullptr
)
member FormatVar :
        var : string *
        ?maxTokenNum : Nullable<int>
(* Defaults:
        let _maxTokenNum = defaultArg maxTokenNum null
*)
-> string

Parametri

var String
maxTokenNum Nullable Int32 (Optional)

Valore di ritorno

String
Restituisce il progressivo corretto.
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Metodo DedTypeBase.ForOneChild

Metodo DedTypeBaseForOneChild
Questo metodo chiama un delegate passandogli in sequenza il nodo corrente (opzionalmente) e tutti i suoi nodi figli.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ForOneChild(
    DedTypeBaseCallMeForEachNode deleg,
    bool IncludeCurrentNode,
    bool bOrizzontal
)
Public Function ForOneChild (
    deleg As DedTypeBaseCallMeForEachNode,
    IncludeCurrentNode As Boolean,
    bOrizzontal As Boolean
) As Boolean
public:
bool ForOneChild(
    DedTypeBaseCallMeForEachNode^ deleg,
    bool IncludeCurrentNode,
    bool bOrizzontal
)
member ForOneChild :
        deleg : DedTypeBaseCallMeForEachNode *
        IncludeCurrentNode : bool *
        bOrizzontal : bool -> bool

Parametri

deleg DedTypeBaseCallMeForEachNode
Delegate di tipo CallMeForEachNode da chiamare per ogni nodo, finchè non ne trova una che soddisfa il delegate.
IncludeCurrentNode Boolean
Se chiamare il delegate anche per il nodo corrente (del quale si stà invocando il metodo).
bOrizzontal Boolean
Indica al metodo di applicare la navigazione orizzontale invece di quella verticale.

Valore di ritorno

Boolean
Restituisce quello che è stato restituito dal delegate ovvero se il è presente almeno un nodo che lo soddisfa.
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Metodo DedTypeBase.GetAttrNameFromPrompt

Metodo DedTypeBaseGetAttrNameFromPrompt
Restituisce il nome di un attributo visibile da questa famiglia dato il suo prompt.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string GetAttrNameFromPrompt(
    string prompt
)
Public Function GetAttrNameFromPrompt (
    prompt As String
) As String
public:
String^ GetAttrNameFromPrompt(
    String^ prompt
)
member GetAttrNameFromPrompt :
        prompt : string -> string

Parametri

prompt String
Prompt dell'attributo da cercare.

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Metodo DedTypeBase.GetAttrsFromCategory

Metodo DedTypeBaseGetAttrsFromCategory
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | GetAttrsFromCategory(DedCateg) | Ritorna la lista di attributi visibili dalla famiglia che appartengono alla categoria passata.
Metodo pubblico | GetAttrsFromCategory(String) | Ritorna la lista di attributi visibili dalla famiglia che appartengono alla categoria passata.
Torna su
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Metodo DedTypeBase.GetAttrsFromCategory(DedCateg)

Metodo DedTypeBaseGetAttrsFromCategory(DedCateg)
Ritorna la lista di attributi visibili dalla famiglia che appartengono alla categoria passata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList GetAttrsFromCategory(
    DedCateg category
)
Public Function GetAttrsFromCategory (
    category As DedCateg
) As DedAttrList
public:
DedAttrList^ GetAttrsFromCategory(
    DedCateg^ category
)
member GetAttrsFromCategory :
        category : DedCateg -> DedAttrList

Parametri

category DedCateg
Categoria.

Valore di ritorno

DedAttrList
Vedi anche

Documentazione

Classe DedTypeBase
Overload di GetAttrsFromCategory
Namespace DedNet.Core


Metodo DedTypeBase.GetAttrsFromCategory(String)

Metodo DedTypeBaseGetAttrsFromCategory(String)
Ritorna la lista di attributi visibili dalla famiglia che appartengono alla categoria passata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList GetAttrsFromCategory(
    string category
)
Public Function GetAttrsFromCategory (
    category As String
) As DedAttrList
public:
DedAttrList^ GetAttrsFromCategory(
    String^ category
)
member GetAttrsFromCategory :
        category : string -> DedAttrList

Parametri

category String
Nome della categoria.

Valore di ritorno

DedAttrList
Vedi anche

Documentazione

Classe DedTypeBase
Overload di GetAttrsFromCategory
Namespace DedNet.Core


Metodo DedTypeBase.GetBusyProgr

Metodo DedTypeBaseGetBusyProgr
Restituisce un dizionario con tutti i progressivi utilizzati.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<string, string> GetBusyProgr(
    string username = ""
)
Public Function GetBusyProgr (
    Optional username As String = ""
) As Dictionary(Of String, String)
public:
Dictionary<String^, String^>^ GetBusyProgr(
    String^ username = L""
)
member GetBusyProgr :
        ?username : string
(* Defaults:
        let _username = defaultArg username ""
*)
-> Dictionary<string, string>

Parametri

username String (Optional)

Valore di ritorno

Dictionary String, String
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Metodo DedTypeBase.GetFamSpecificLevel

Metodo DedTypeBaseGetFamSpecificLevel
Restituisce la famiglia a n° livello.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeBase GetFamSpecificLevel(
    int level
)
Public Function GetFamSpecificLevel (
    level As Integer
) As DedTypeBase
public:
DedTypeBase^ GetFamSpecificLevel(
    int level
)
member GetFamSpecificLevel :
        level : int -> DedTypeBase

Parametri

level Int32

Valore di ritorno

DedTypeBase
Restituisce la famiglia a oppure null se non presente.
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Metodo DedTypeBase.GetFamSpecificNegativeLevel

Metodo DedTypeBaseGetFamSpecificNegativeLevel
Restituisce la famiglia a n° livello negativo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeBase GetFamSpecificNegativeLevel(
    int level
)
Public Function GetFamSpecificNegativeLevel (
    level As Integer
) As DedTypeBase
public:
DedTypeBase^ GetFamSpecificNegativeLevel(
    int level
)
member GetFamSpecificNegativeLevel :
        level : int -> DedTypeBase

Parametri

level Int32

Valore di ritorno

DedTypeBase
Restituisce la famiglia a oppure null se non presente.
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Metodo DedTypeBase.GetFieldsCod

Metodo DedTypeBaseGetFieldsCod
Restituisce la lista delle stringhe nella queli cercare i tasselli.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual string[] GetFieldsCod()
Public Overridable Function GetFieldsCod As String()
public:
virtual array<String^>^ GetFieldsCod()
abstract GetFieldsCod : unit -> string[]
override GetFieldsCod : unit -> string[]

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Metodo DedTypeBase.GetFirstParentHasProg

Metodo DedTypeBaseGetFirstParentHasProg
Restituisce la prima famiglia genitore che ha il progressivo locale.Considera anche il nodo corrente per avere la sicurezza che se viene chiamato su una famiglia con con progressivo impostato non lo calcoli sul padre ma su se stesso.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeBase GetFirstParentHasProg()
Public Function GetFirstParentHasProg As DedTypeBase
public:
DedTypeBase^ GetFirstParentHasProg()
member GetFirstParentHasProg : unit -> DedTypeBase

Valore di ritorno

DedTypeBase
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Metodo DedTypeBase.GetFreeProgr

Metodo DedTypeBaseGetFreeProgr
Restituisce una lista sempre inizializzata e ordinata con tutti i progressivi liberi per questa famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<string, string> GetFreeProgr(
    bool considerLastProgr = false
)
Public Function GetFreeProgr (
    Optional considerLastProgr As Boolean = false
) As Dictionary(Of String, String)
public:
Dictionary<String^, String^>^ GetFreeProgr(
    bool considerLastProgr = false
)
member GetFreeProgr :
        ?considerLastProgr : bool
(* Defaults:
        let _considerLastProgr = defaultArg considerLastProgr false
*)
-> Dictionary<string, string>

Parametri

considerLastProgr Boolean (Optional)

Valore di ritorno

Dictionary String, String
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Metodo DedTypeBase.GetLastProgr

Metodo DedTypeBaseGetLastProgr
Restituisce l'ultimo progressivo possibile per questa famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string GetLastProgr()
Public Function GetLastProgr As String
public:
String^ GetLastProgr()
member GetLastProgr : unit -> string

Valore di ritorno

String
Restituisce l'ultimo progressivo possibile per questa famiglia.
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Metodo DedTypeBase.GetMaxTokenNum

Metodo DedTypeBaseGetMaxTokenNum
Restituisce il massimo numero di caratteri usati per il TokenTypeEnum passato. Verifica nella maschera di codifica Cod_Id, Cod_Fil e Cod_Dis in modo da prendere il numero massimo di caratteri utilizzati.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int GetMaxTokenNum(
    TokenTypeEnum type
)
Public Function GetMaxTokenNum (
    type As TokenTypeEnum
) As Integer
public:
int GetMaxTokenNum(
    TokenTypeEnum type
)
member GetMaxTokenNum :
        type : TokenTypeEnum -> int

Parametri

type TokenTypeEnum
Token di interesse.

Valore di ritorno

Int32
Restiruisce il numero di caratteri.
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Metodo DedTypeBase.GetParentTypes

Metodo DedTypeBaseGetParentTypes
Restituisce una lista dei FamilyType genitori, compresa l'istanza stessa se specificato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public abstract DedTypeList GetParentTypes(
    bool bCurrent
)
Public MustOverride Function GetParentTypes (
    bCurrent As Boolean
) As DedTypeList
public:
virtual DedTypeList^ GetParentTypes(
    bool bCurrent
) abstract
abstract GetParentTypes :
        bCurrent : bool -> DedTypeList

Parametri

bCurrent Boolean
Specifica se includere l'istanza di questo oggetto sul quale è stato chiamato il metodo, nella lista restituita.

Valore di ritorno

DedTypeList
Restituisce la lista dei FamilyType genitori oppure null.
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Metodo DedTypeBase.GetProgr

Metodo DedTypeBaseGetProgr
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | GetProgr(Boolean) | Restituisce il progressivo della famiglia che ha invocato il metodo oppure il progressivo della prima famiglia genitore che lo possiede. Lavora sull'utente attualmente connesso ( se deve lavorare in DED_TIPI_PROG ).
Metodo pubblico | GetProgr(Boolean, String) | Restituisce il progressivo della famiglia che ha invocato il metodo oppure il progressivo della prima famiglia genitore che lo possiede
Torna su
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Metodo DedTypeBase.GetProgr(Boolean)

Metodo DedTypeBaseGetProgr(Boolean)
Restituisce il progressivo della famiglia che ha invocato il metodo oppure il progressivo della prima famiglia genitore che lo possiede. Lavora sull'utente attualmente connesso ( se deve lavorare in DED_TIPI_PROG ).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string GetProgr(
    bool recursive
)
Public Function GetProgr (
    recursive As Boolean
) As String
public:
String^ GetProgr(
    bool recursive
)
member GetProgr :
        recursive : bool -> string

Parametri

recursive Boolean
false, ottiene il progressivo della famiglia che ha invocato il metodo. true, ottiene il progressivo della prima famiglia genitore che lo possiede.

Valore di ritorno

String
Il valore del progressivo.
Vedi anche

Documentazione

Classe DedTypeBase
Overload di GetProgr
Namespace DedNet.Core


Metodo DedTypeBase.GetProgr(Boolean, String)

Metodo DedTypeBaseGetProgr(Boolean, String)
Restituisce il progressivo della famiglia che ha invocato il metodo oppure il progressivo della prima famiglia genitore che lo possiede

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string GetProgr(
    bool recursive,
    string userName
)
Public Function GetProgr (
    recursive As Boolean,
    userName As String
) As String
public:
String^ GetProgr(
    bool recursive,
    String^ userName
)
member GetProgr :
        recursive : bool *
        userName : string -> string

Parametri

recursive Boolean
false, ottiene il progressivo della famiglia che ha invocato il metodo. true, ottiene il progressivo della prima famiglia genitore che lo possiede.
userName String
Utente associato. (Se NULL lavaora solo su DED_TIPI)

Valore di ritorno

String
Il valore del progressivo.
Vedi anche

Documentazione

Classe DedTypeBase
Overload di GetProgr
Namespace DedNet.Core


Metodo DedTypeBase.GetProgrTokenNum

Metodo DedTypeBaseGetProgrTokenNum
Restituisce il numero di caratteri da utilizzare per creare la stringa del progressivo per questa famiglia. Li calcola cercando il tassello del progressivo nella codifica del Cod_Id. Se non è presente restituisce 0.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int GetProgrTokenNum()
Public Function GetProgrTokenNum As Integer
public:
int GetProgrTokenNum()
member GetProgrTokenNum : unit -> int

Valore di ritorno

Int32
Restituisce il numero di caratteri del progressivo per questa famiglia.
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Metodo DedTypeBase.GetRightMask

Metodo DedTypeBaseGetRightMask
Restituisce il TokenInfo cercato nella prima maschera di codifica trovata, da utilizzare poi per calcolare il numero di tasselli per un particolare token. Restituisce null se non la trova.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public TokenInfo GetRightMask(
    TokenTypeEnum tokenType
)
Public Function GetRightMask (
    tokenType As TokenTypeEnum
) As TokenInfo
public:
TokenInfo^ GetRightMask(
    TokenTypeEnum tokenType
)
member GetRightMask :
        tokenType : TokenTypeEnum -> TokenInfo

Parametri

tokenType TokenTypeEnum
Tipo di elemento da cercare nelle maschere di codifica.

Valore di ritorno

TokenInfo
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Metodo DedTypeBase.MakeAttrsDictionary

Metodo DedTypeBaseMakeAttrsDictionary
Riempie il dizionario _dizfields.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void MakeAttrsDictionary()
Public Sub MakeAttrsDictionary
public:
void MakeAttrsDictionary()
member MakeAttrsDictionary : unit -> unit
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Metodo DedTypeBase.NotifyDirty

Metodo DedTypeBaseNotifyDirty
In base al fatto che si tratti della root o meno notifica al parent corretto l'avvenuta modifica della proprietà.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public abstract void NotifyDirty()
Public MustOverride Sub NotifyDirty
public:
virtual void NotifyDirty() abstract
abstract NotifyDirty : unit -> unit
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Metodo DedTypeBase.Save

Metodo DedTypeBaseSave
Metodo per il salvataggio delle modifiche.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public abstract void Save()
Public MustOverride Sub Save
public:
virtual void Save() abstract
abstract Save : unit -> unit
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Metodo DedTypeBase.SetProgr

Metodo DedTypeBaseSetProgr
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | SetProgr(String, String, Boolean) | Imposta il progressivo di questa famiglia o della famiglia dalla quale questa eredita il progressivo. Lavora sull'utente attualmente connesso ( se deve lavorare in DED_TIPI_PROG ).
Metodo pubblico | SetProgr(String, String, Boolean, String) | Imposta il progressivo di questa famiglia o della famiglia dalla quale questa eredita il progressivo.
Metodo pubblico | SetProgr(String, String, Boolean, String, Boolean) | Imposta il progressivo di questa famiglia o della famiglia dalla quale questa eredita il progressivo.
Torna su
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Metodo DedTypeBase.SetProgr(String, String, Boolean)

Metodo DedTypeBaseSetProgr(String, String, Boolean)
Imposta il progressivo di questa famiglia o della famiglia dalla quale questa eredita il progressivo. Lavora sull'utente attualmente connesso ( se deve lavorare in DED_TIPI_PROG ).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool SetProgr(
    string oldValue,
    string newValue,
    bool recursive
)
Public Function SetProgr (
    oldValue As String,
    newValue As String,
    recursive As Boolean
) As Boolean
public:
bool SetProgr(
    String^ oldValue,
    String^ newValue,
    bool recursive
)
member SetProgr :
        oldValue : string *
        newValue : string *
        recursive : bool -> bool

Parametri

oldValue String
Valore del vecchio progressivo
newValue String
Valore del nuovo progressivo
recursive Boolean
false, imposta il progressivo della famiglia che ha invocato il metodo. true, imposta il progressivo della prima famiglia genitore che lo possiede.

Valore di ritorno

Boolean
Restituisce true se riesce altrimenti false.
Vedi anche

Documentazione

Classe DedTypeBase
Overload di SetProgr
Namespace DedNet.Core


Metodo DedTypeBase.SetProgr(String, String, Boolean, String)

Metodo DedTypeBaseSetProgr(String, String, Boolean, String)
Imposta il progressivo di questa famiglia o della famiglia dalla quale questa eredita il progressivo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool SetProgr(
    string oldValue,
    string newValue,
    bool recursive,
    string userName
)
Public Function SetProgr (
    oldValue As String,
    newValue As String,
    recursive As Boolean,
    userName As String
) As Boolean
public:
bool SetProgr(
    String^ oldValue,
    String^ newValue,
    bool recursive,
    String^ userName
)
member SetProgr :
        oldValue : string *
        newValue : string *
        recursive : bool *
        userName : string -> bool

Parametri

oldValue String
Valore del vecchio progressivo
newValue String
Valore del nuovo progressivo
recursive Boolean
false, imposta il progressivo della famiglia che ha invocato il metodo. Utente associato. (Se NULL lavora solo su DED_TIPI) true, imposta il progressivo della prima famiglia genitore che lo possiede.
userName String

Valore di ritorno

Boolean
Restituisce true se riesce altrimenti false.
Vedi anche

Documentazione

Classe DedTypeBase
Overload di SetProgr
Namespace DedNet.Core


Metodo DedTypeBase.SetProgr(String, String, Boolean, String, Boolean)

Metodo DedTypeBaseSetProgr(String, String, Boolean, String, Boolean)
Imposta il progressivo di questa famiglia o della famiglia dalla quale questa eredita il progressivo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool SetProgr(
    string oldValue,
    string newValue,
    bool recursive,
    string userName,
    bool ignoreRange
)
Public Function SetProgr (
    oldValue As String,
    newValue As String,
    recursive As Boolean,
    userName As String,
    ignoreRange As Boolean
) As Boolean
public:
bool SetProgr(
    String^ oldValue,
    String^ newValue,
    bool recursive,
    String^ userName,
    bool ignoreRange
)
member SetProgr :
        oldValue : string *
        newValue : string *
        recursive : bool *
        userName : string *
        ignoreRange : bool -> bool

Parametri

oldValue String
Valore del vecchio progressivo
newValue String
Valore del nuovo progressivo
recursive Boolean
false, imposta il progressivo della famiglia che ha invocato il metodo. Utente associato. (Se NULL lavora solo su DED_TIPI)Indica se ignorare i controlli sui range di assegnazione /// Indica se ignorare i controlli sui range di assegnazione true, imposta il progressivo della prima famiglia genitore che lo possiede.
userName String
ignoreRange Boolean

Valore di ritorno

Boolean
Restituisce true se riesce altrimenti false.
Vedi anche

Documentazione

Classe DedTypeBase
Overload di SetProgr
Namespace DedNet.Core


Metodo DedTypeBase.WaitForUpdate

Metodo DedTypeBaseWaitForUpdate
Esegue una query con WITH (XLOCK) in modo da aspettare finchè altri utenti non hanno commitato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void WaitForUpdate()
Public Sub WaitForUpdate
public:
void WaitForUpdate()
member WaitForUpdate : unit -> unit
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Campi di DedTypeBase

Il tipo DedTypeBase espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | _analyzedTypes |
Campo pubblico | _app |
Campo pubblico | _attributes |
Campo pubblico | _backcolor |
Campo pubblico | _calculatedAttrs |
Campo pubblico | _clonedFrom |
Campo pubblico | _cod_id |
Campo pubblico | _dbPath |
Campo pubblico | _dbPathLoaded |
Campo pubblico | _descriz |
Campo pubblico | _dirtyname |
Campo pubblico | _dwgpath |
Campo pubblico | _forecolor |
Campo pubblico | _freecode |
Campo pubblico | _isprj |
Campo pubblico | _isRoot | Indica se questa famiglia sia o meno la root.
Campo pubblico | _master |
Campo pubblico | _name |
Campo pubblico | _oldDwgPath |
Campo pubblico | _parent | Collezione di appartenenza.
Campo pubblico | _progr |
Campo pubblico | _progrAlphabet |
Campo pubblico | _revisionAlphabet |
Campo pubblico | _rootCollection | Collezione dedicata al salvataggio della root.
Campo pubblico | _rules |
Campo pubblico | _subtypes |
Campo pubblico | _varAlphabet |
Torna su
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Campo DedTypeBase._analyzedTypes

Campo DedTypeBase_analyzedTypes

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<string, bool> _analyzedTypes
Public _analyzedTypes As Dictionary(Of String, Boolean)
public:
Dictionary<String^, bool>^ _analyzedTypes
val mutable _analyzedTypes: Dictionary<string, bool>

Valore del campo

Dictionary String, Boolean
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Campo DedTypeBase._app

Campo DedTypeBase_app

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedNetApplication _app
Public _app As DedNetApplication
public:
DedNetApplication^ _app
val mutable _app: DedNetApplication

Valore del campo

DedNetApplication
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Campo DedTypeBase._attributes

Campo DedTypeBase_attributes

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrCollection _attributes
Public _attributes As DedAttrCollection
public:
DedAttrCollection^ _attributes
val mutable _attributes: DedAttrCollection

Valore del campo

DedAttrCollection
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Campo DedTypeBase._backcolor

Campo DedTypeBase_backcolor

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Color _backcolor
Public _backcolor As Color
public:
Color _backcolor
val mutable _backcolor: Color

Valore del campo

Color
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Campo DedTypeBase._calculatedAttrs

Campo DedTypeBase_calculatedAttrs

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList _calculatedAttrs
Public _calculatedAttrs As DedAttrList
public:
DedAttrList^ _calculatedAttrs
val mutable _calculatedAttrs: DedAttrList

Valore del campo

DedAttrList
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Campo DedTypeBase._clonedFrom

Campo DedTypeBase_clonedFrom

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeBase _clonedFrom
Public _clonedFrom As DedTypeBase
public:
DedTypeBase^ _clonedFrom
val mutable _clonedFrom: DedTypeBase

Valore del campo

DedTypeBase
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Campo DedTypeBase._cod_id

Campo DedTypeBase_cod_id

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string _cod_id
Public _cod_id As String
public:
String^ _cod_id
val mutable _cod_id: string

Valore del campo

String
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Campo DedTypeBase._dbPath

Campo DedTypeBase_dbPath

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string _dbPath
Public _dbPath As String
public:
String^ _dbPath
val mutable _dbPath: string

Valore del campo

String
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Campo DedTypeBase._dbPathLoaded

Campo DedTypeBase_dbPathLoaded

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool _dbPathLoaded
Public _dbPathLoaded As Boolean
public:
bool _dbPathLoaded
val mutable _dbPathLoaded: bool

Valore del campo

Boolean
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Campo DedTypeBase._descriz

Campo DedTypeBase_descriz

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string _descriz
Public _descriz As String
public:
String^ _descriz
val mutable _descriz: string

Valore del campo

String
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Campo DedTypeBase._dirtyname

Campo DedTypeBase_dirtyname

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool _dirtyname
Public _dirtyname As Boolean
public:
bool _dirtyname
val mutable _dirtyname: bool

Valore del campo

Boolean
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Campo DedTypeBase._dwgpath

Campo DedTypeBase_dwgpath

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string _dwgpath
Public _dwgpath As String
public:
String^ _dwgpath
val mutable _dwgpath: string

Valore del campo

String
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Campo DedTypeBase._forecolor

Campo DedTypeBase_forecolor

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Color _forecolor
Public _forecolor As Color
public:
Color _forecolor
val mutable _forecolor: Color

Valore del campo

Color
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Campo DedTypeBase._freecode

Campo DedTypeBase_freecode

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool _freecode
Public _freecode As Boolean
public:
bool _freecode
val mutable _freecode: bool

Valore del campo

Boolean
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Campo DedTypeBase._isprj

Campo DedTypeBase_isprj

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool _isprj
Public _isprj As Boolean
public:
bool _isprj
val mutable _isprj: bool

Valore del campo

Boolean
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Campo DedTypeBase._isRoot

Campo DedTypeBase_isRoot
Indica se questa famiglia sia o meno la root.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool _isRoot
Public _isRoot As Boolean
public:
bool _isRoot
val mutable _isRoot: bool

Valore del campo

Boolean
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Campo DedTypeBase._master

Campo DedTypeBase_master

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Guid _master
Public _master As Guid
public:
Guid _master
val mutable _master: Guid

Valore del campo

Guid
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Campo DedTypeBase._name

Campo DedTypeBase_name

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string _name
Public _name As String
public:
String^ _name
val mutable _name: string

Valore del campo

String
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Campo DedTypeBase._oldDwgPath

Campo DedTypeBase_oldDwgPath

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string _oldDwgPath
Public _oldDwgPath As String
public:
String^ _oldDwgPath
val mutable _oldDwgPath: string

Valore del campo

String
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Campo DedTypeBase._parent

Campo DedTypeBase_parent
Collezione di appartenenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object _parent
Public _parent As Object
public:
Object^ _parent
val mutable _parent: Object

Valore del campo

Object
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Campo DedTypeBase._progr

Campo DedTypeBase_progr

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string _progr
Public _progr As String
public:
String^ _progr
val mutable _progr: string

Valore del campo

String
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Campo DedTypeBase._progrAlphabet

Campo DedTypeBase_progrAlphabet

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string _progrAlphabet
Public _progrAlphabet As String
public:
String^ _progrAlphabet
val mutable _progrAlphabet: string

Valore del campo

String
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Campo DedTypeBase._revisionAlphabet

Campo DedTypeBase_revisionAlphabet

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string _revisionAlphabet
Public _revisionAlphabet As String
public:
String^ _revisionAlphabet
val mutable _revisionAlphabet: string

Valore del campo

String
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Campo DedTypeBase._rootCollection

Campo DedTypeBase_rootCollection
Collezione dedicata al salvataggio della root.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object _rootCollection
Public _rootCollection As Object
public:
Object^ _rootCollection
val mutable _rootCollection: Object

Valore del campo

Object
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Campo DedTypeBase._rules

Campo DedTypeBase_rules

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedRuleCollection _rules
Public _rules As DedRuleCollection
public:
DedRuleCollection^ _rules
val mutable _rules: DedRuleCollection

Valore del campo

DedRuleCollection
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Campo DedTypeBase._subtypes

Campo DedTypeBase_subtypes

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object _subtypes
Public _subtypes As Object
public:
Object^ _subtypes
val mutable _subtypes: Object

Valore del campo

Object
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Campo DedTypeBase._varAlphabet

Campo DedTypeBase_varAlphabet

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string _varAlphabet
Public _varAlphabet As String
public:
String^ _varAlphabet
val mutable _varAlphabet: string

Valore del campo

String
Vedi anche

Documentazione

Classe DedTypeBase
Namespace DedNet.Core


Delegate DedTypeBase.CallMeForEachNode

Delegate DedTypeBaseCallMeForEachNode
Delegate che serve per elaborare un singolo nodo dell'albero dei tipi.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public delegate bool CallMeForEachNode(
    DedTypeBase type_node
)
Public Delegate Function CallMeForEachNode (
    type_node As DedTypeBase
) As Boolean
public delegate bool CallMeForEachNode(
    DedTypeBase^ type_node
)
type CallMeForEachNode =
    delegate of
        type_node : DedTypeBase -> bool

Parametri

type_node DedTypeBase
Nodo corrente in elaborazione.

Valore di ritorno

Boolean
Restituisce true se il ciclo può continuare, false se deve essere interrotto.
Vedi anche

Documentazione

Namespace DedNet.Core


Classe DedTypeBaseCollection<T>

Classe DedTypeBaseCollectionT
Classe astratta per definire collezione modificabile di oggetti che sono usati in collezioni strutturate, hanno regole di codifica, attributi e regole sugli attributi
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedDbCollectionBase T
DedNet.CoreDedTypeBaseCollectionT
DedNet.CoreDedCommTypeCollection
DedNet.CoreDedTypeCollection

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public abstract class DedTypeBaseCollection<T> : DedDbCollectionBase<T>
where T : DedTypeBase

Public MustInherit Class DedTypeBaseCollection(Of T As DedTypeBase)
    Inherits DedDbCollectionBase(Of T)
generic<typename T>
where T : DedTypeBase
public ref class DedTypeBaseCollection abstract : public DedDbCollectionBase<T>
[<AbstractClassAttribute>]
type DedTypeBaseCollection<'T when 'T : DedTypeBase> =
    class
        inherit DedDbCollectionBase<'T>
    end

Parametri di tipo

T

Il tipo DedTypeBaseCollectionT espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllowsDuplicates | Restituisce se siano ammessi duplicati all'interno della lista. Se false viene sollevata una eccezione su tentativo di inserimento duplicati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Application | Restituisce l'oggetto applicazione di appartenza. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Count | Restituisce il numero di elementi presenti. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Dirty | Restituisce se la collezione o uno dei suoi elementi sia stata modificata. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | ErasedItems | Restitusice la lista in sola lettura degli elementi che risultano attualmente cancellati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | LastItem | Restituisce l'ultimo elemento della collezione oppure null se non ci sono elementi. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Owner | Restituisce l'oggetto DedTypeBase di appartenenza.
Proprietà pubblica | RestoreErased | Restituisce se gli elementi cancellati devono essere ripristinati in caso vengano riaggiunti. (Ereditato da DedDbCollectionBaseT)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Add | Aggiunge alla collezione un elemento già esistente come nuovo elemento. Gli imposta già come padre la nuova collezione.
Metodo protetto | AddForClone | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto SENZA MODIFICARNE LO STATO. Le classi derivate potranno utilizzare questo metodo per clonare la collezione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddNewElement | DI USO INTERNO. Aggiunge un elemento alla lista rendendo dirty l'oggetto. L'elemento viene aggiunto con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere un elemento alla lista. Dovranno loro stesse avere un metodo pubblico Add() che prenda i parametri necessari alla costruzione dell'oggetto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddRangeNewElement | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi rendendo dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere più elementi alla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddUnModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Clear | Elimina tutti gli elementi dalla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ClearRefresh | Svuota la lista impostando Dirty = false. Di fatto permette di effettuare un refresh della lista e quindi di ricaricarla. Serve per svuotare la lista e reinizializzarla da capo. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Contains | Verifica l'esistenza di un valore all'interno della lista degli elementi. Le classi derivate devono effettuarne l'override nel caso in cui l'elemento non implementi GetHashCode() per l'uso all'interno dei dizionarii. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | CopyTo | Copia un range di elementi in un array. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | CreateDeleteCommand | Crea un comando per eliminare un elemento. (Sovrascrive DedDbCollectionBaseTCreateDeleteCommand(T))
Metodo protetto | CreateInsertCommand | Crea, inizializza e restituisce il comando per l'inserimento di un elemento. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | CreateUpdateCommand | Crea, inizializza e restituisce il comando per l'aggiornamento di un elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | CustomSort | Ordina la lista in base al comparatore passato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteDeleteItem | Esegue l'eliminazione di un elemento. Crea il comando tramite il metodo CreateDeleteCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteInsertItem | Esegue l'inserimento di un elemento. Crea il comando tramite il metodo CreateInsertCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteUpdateItem | Esegue l'aggiornamento di un elemento. Crea il comando tramite il metodo CreateUpdateCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Find | Restituisce l'oggetto cercato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FindAll | Restitusice la lista degli elementi che corrispondono al predicato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | GetDbIndex | Restituisce l'indice dell'elemento passato (Sovrascrive DedDbCollectionBaseTGetDbIndex(T))
Metodo pubblico | GetEnumerator | Restituisce l'enumeratore della collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | IndexOf | Restituisce l'indice dell'elemento richiesto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InsertUnModified | DI USO INTERNO. Inserisce un elemento alla lista senza rendere dirty l'oggetto, all'indice specificato. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Item | Restituisce l'elemento iesimo della lista. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean) | Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean, Int32) | Sposta l'elemento dell'indice passato prima o dopo del numero di posizioni passate. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSave | Metodo Template chiamato dopo il salvataggio avvenuto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSaveNoChanges | Metodo Template chiamato dopo il salvataggio senza modifiche. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnBeforeSave | Metodo Template chiamato prima del salvataggio. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(T) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(DedEditableObjectT) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(T) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(DedEditableObjectT) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ReInitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Remove | Elimina un elemento dalla collezione. (Sovrascrive DedDbCollectionBaseTRemove(T))
Metodo pubblico | Ripristina | Verifica che l'elemento sia presente negli eliminati e lo toglie da lì e lo riaggiunge in coda alla lista degli elementi validi. Solleva una eccezione se l'elemento è già presente nella lista e AllowsDuplicates = false. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Save | Salva l'oggetto con tutta la sua lista, solo se questo risulta dirty. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | ToArray | Restituisce un array di questi oggetti.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di DedTypeBaseCollection<T>

Proprietà di DedTypeBaseCollectionT

Il tipo DedTypeBaseCollectionT espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllowsDuplicates | Restituisce se siano ammessi duplicati all'interno della lista. Se false viene sollevata una eccezione su tentativo di inserimento duplicati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Application | Restituisce l'oggetto applicazione di appartenza. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Count | Restituisce il numero di elementi presenti. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Dirty | Restituisce se la collezione o uno dei suoi elementi sia stata modificata. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | ErasedItems | Restitusice la lista in sola lettura degli elementi che risultano attualmente cancellati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | LastItem | Restituisce l'ultimo elemento della collezione oppure null se non ci sono elementi. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Owner | Restituisce l'oggetto DedTypeBase di appartenenza.
Proprietà pubblica | RestoreErased | Restituisce se gli elementi cancellati devono essere ripristinati in caso vengano riaggiunti. (Ereditato da DedDbCollectionBaseT)
Torna su
Vedi anche

Documentazione

Classe DedTypeBaseCollectionT
Namespace DedNet.Core


Proprietà DedTypeBaseCollection<T>.Owner

Proprietà DedTypeBaseCollectionTOwner
Restituisce l'oggetto DedTypeBase di appartenenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public T Owner { get; }
Public ReadOnly Property Owner As T
    Get
public:
property T Owner {
    T get ();
}
member Owner : 'T with get

Valore della proprietà

T
Vedi anche

Documentazione

Classe DedTypeBaseCollectionT
Namespace DedNet.Core


Metodi di DedTypeBaseCollection<T>

Metodi di DedTypeBaseCollectionT

Il tipo DedTypeBaseCollectionT espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Add | Aggiunge alla collezione un elemento già esistente come nuovo elemento. Gli imposta già come padre la nuova collezione.
Metodo protetto | AddForClone | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto SENZA MODIFICARNE LO STATO. Le classi derivate potranno utilizzare questo metodo per clonare la collezione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddNewElement | DI USO INTERNO. Aggiunge un elemento alla lista rendendo dirty l'oggetto. L'elemento viene aggiunto con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere un elemento alla lista. Dovranno loro stesse avere un metodo pubblico Add() che prenda i parametri necessari alla costruzione dell'oggetto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddRangeNewElement | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi rendendo dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere più elementi alla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddUnModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Clear | Elimina tutti gli elementi dalla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ClearRefresh | Svuota la lista impostando Dirty = false. Di fatto permette di effettuare un refresh della lista e quindi di ricaricarla. Serve per svuotare la lista e reinizializzarla da capo. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Contains | Verifica l'esistenza di un valore all'interno della lista degli elementi. Le classi derivate devono effettuarne l'override nel caso in cui l'elemento non implementi GetHashCode() per l'uso all'interno dei dizionarii. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | CopyTo | Copia un range di elementi in un array. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | CreateDeleteCommand | Crea un comando per eliminare un elemento. (Sovrascrive DedDbCollectionBaseTCreateDeleteCommand(T))
Metodo protetto | CreateInsertCommand | Crea, inizializza e restituisce il comando per l'inserimento di un elemento. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | CreateUpdateCommand | Crea, inizializza e restituisce il comando per l'aggiornamento di un elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | CustomSort | Ordina la lista in base al comparatore passato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteDeleteItem | Esegue l'eliminazione di un elemento. Crea il comando tramite il metodo CreateDeleteCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteInsertItem | Esegue l'inserimento di un elemento. Crea il comando tramite il metodo CreateInsertCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteUpdateItem | Esegue l'aggiornamento di un elemento. Crea il comando tramite il metodo CreateUpdateCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Find | Restituisce l'oggetto cercato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FindAll | Restitusice la lista degli elementi che corrispondono al predicato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | GetDbIndex | Restituisce l'indice dell'elemento passato (Sovrascrive DedDbCollectionBaseTGetDbIndex(T))
Metodo pubblico | GetEnumerator | Restituisce l'enumeratore della collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | IndexOf | Restituisce l'indice dell'elemento richiesto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InsertUnModified | DI USO INTERNO. Inserisce un elemento alla lista senza rendere dirty l'oggetto, all'indice specificato. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Item | Restituisce l'elemento iesimo della lista. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean) | Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean, Int32) | Sposta l'elemento dell'indice passato prima o dopo del numero di posizioni passate. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSave | Metodo Template chiamato dopo il salvataggio avvenuto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSaveNoChanges | Metodo Template chiamato dopo il salvataggio senza modifiche. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnBeforeSave | Metodo Template chiamato prima del salvataggio. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(T) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(DedEditableObjectT) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(T) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(DedEditableObjectT) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ReInitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Remove | Elimina un elemento dalla collezione. (Sovrascrive DedDbCollectionBaseTRemove(T))
Metodo pubblico | Ripristina | Verifica che l'elemento sia presente negli eliminati e lo toglie da lì e lo riaggiunge in coda alla lista degli elementi validi. Solleva una eccezione se l'elemento è già presente nella lista e AllowsDuplicates = false. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Save | Salva l'oggetto con tutta la sua lista, solo se questo risulta dirty. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | ToArray | Restituisce un array di questi oggetti.
Torna su
Vedi anche

Documentazione

Classe DedTypeBaseCollectionT
Namespace DedNet.Core


Metodo DedTypeBaseCollection<T>.Add

Metodo DedTypeBaseCollectionTAdd
Aggiunge alla collezione un elemento già esistente come nuovo elemento. Gli imposta già come padre la nuova collezione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Add(
    T type
)
Public Sub Add (
    type As T
)
public:
void Add(
    T type
)
member Add :
        type : 'T -> unit

Parametri

type T
DedTypeBase da aggiungere alla collezione.
Vedi anche

Documentazione

Classe DedTypeBaseCollectionT
Namespace DedNet.Core


Metodo DedTypeBaseCollection<T>.CreateDeleteCommand

Metodo DedTypeBaseCollectionTCreateDeleteCommand
Crea un comando per eliminare un elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSDeleteCommand CreateDeleteCommand(
    T item
)
Protected Overrides Function CreateDeleteCommand (
    item As T
) As QSDeleteCommand
protected:
virtual QSDeleteCommand^ CreateDeleteCommand(
    T item
) override
abstract CreateDeleteCommand :
        item : 'T -> QSDeleteCommand
override CreateDeleteCommand :
        item : 'T -> QSDeleteCommand

Parametri

item T
Elemento da eliminare.

Valore di ritorno

QSDeleteCommand
Vedi anche

Documentazione

Classe DedTypeBaseCollectionT
Namespace DedNet.Core


Metodo DedTypeBaseCollection<T>.GetDbIndex

Metodo DedTypeBaseCollectionTGetDbIndex
Restituisce l'indice dell'elemento passato

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override Object GetDbIndex(
    T item
)
Protected Overrides Function GetDbIndex (
    item As T
) As Object
protected:
virtual Object^ GetDbIndex(
    T item
) override
abstract GetDbIndex :
        item : 'T -> Object
override GetDbIndex :
        item : 'T -> Object

Parametri

item T
Elemento del quale restituire l'indice.

Valore di ritorno

Object
Restituisce l'indice dell'elemento oppure null.
Vedi anche

Documentazione

Classe DedTypeBaseCollectionT
Namespace DedNet.Core


Metodo DedTypeBaseCollection<T>.Remove

Metodo DedTypeBaseCollectionTRemove
Elimina un elemento dalla collezione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void Remove(
    T item
)
Public Overrides Sub Remove (
    item As T
)
public:
virtual void Remove(
    T item
) override
abstract Remove :
        item : 'T -> unit
override Remove :
        item : 'T -> unit

Parametri

item T
Elemento da eliminare.
Vedi anche

Documentazione

Classe DedTypeBaseCollectionT
Namespace DedNet.Core


Metodo DedTypeBaseCollection<T>.ToArray

Metodo DedTypeBaseCollectionTToArray
Restituisce un array di questi oggetti.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public IList ToArray()
Public Function ToArray As IList
public:
IList^ ToArray()
member ToArray : unit -> IList

Valore di ritorno

IList
Vedi anche

Documentazione

Classe DedTypeBaseCollectionT
Namespace DedNet.Core


Classe DedTypeBaseList
Lista di oggetti DedTypeBaseList
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList DedTypeBase
DedNet.CoreDedTypeGenericList DedTypeBase
DedNet.CoreDedTypeBaseList
DedNet.CoreDedCommTypeList
DedNet.CoreDedTypeList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedTypeBaseList : DedTypeGenericList<DedTypeBase>
Public Class DedTypeBaseList
    Inherits DedTypeGenericList(Of DedTypeBase)
public ref class DedTypeBaseList : public DedTypeGenericList<DedTypeBase^>
type DedTypeBaseList =
    class
        inherit DedTypeGenericList<DedTypeBase>
    end

Il tipo DedTypeBaseList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedTypeBaseList | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione di appartenenza. (Ereditato da DedTypeGenericListT)
Proprietà pubblica | CommonDedType | Restituisce l'oggetto DedTypeBase comune (Ereditato da DedTypeGenericListT)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedTypeBaseList
Costruttore unico.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeBaseList(
    DedNetApplication application
)
Public Sub New (
    application As DedNetApplication
)
public:
DedTypeBaseList(
    DedNetApplication^ application
)
new :
        application : DedNetApplication -> DedTypeBaseList

Parametri

application DedNetApplication
Oggetto applicazione di appartenenza.
Vedi anche

Documentazione

Classe DedTypeBaseList
Namespace DedNet.Core


Proprietà di DedTypeBaseList

Il tipo DedTypeBaseList espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione di appartenenza. (Ereditato da DedTypeGenericListT)
Proprietà pubblica | CommonDedType | Restituisce l'oggetto DedTypeBase comune (Ereditato da DedTypeGenericListT)
Torna su
Vedi anche

Documentazione

Classe DedTypeBaseList
Namespace DedNet.Core


Classe DedTypeCollection
Collezione modificabile di oggetti DedType.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedDbCollectionBase DedType
DedNet.CoreDedTypeBaseCollection DedType
DedNet.CoreDedTypeCollection

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedTypeCollection : DedTypeBaseCollection<DedType>
Public Class DedTypeCollection
    Inherits DedTypeBaseCollection(Of DedType)
public ref class DedTypeCollection : public DedTypeBaseCollection<DedType^>
type DedTypeCollection =
    class
        inherit DedTypeBaseCollection<DedType>
    end

Il tipo DedTypeCollection espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllowsDuplicates | Restituisce se siano ammessi duplicati all'interno della lista. Se false viene sollevata una eccezione su tentativo di inserimento duplicati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Application | Restituisce l'oggetto applicazione di appartenza. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Count | Restituisce il numero di elementi presenti. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Dirty | Restituisce se la collezione o uno dei suoi elementi sia stata modificata. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | ErasedItems | Restitusice la lista in sola lettura degli elementi che risultano attualmente cancellati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | LastItem | Restituisce l'ultimo elemento della collezione oppure null se non ci sono elementi. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Owner | Restituisce l'oggetto DedTypeBase di appartenenza. (Ereditato da DedTypeBaseCollectionT)
Proprietà pubblica | RestoreErased | Restituisce se gli elementi cancellati devono essere ripristinati in caso vengano riaggiunti. (Ereditato da DedDbCollectionBaseT)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Add(T) | Aggiunge alla collezione un elemento già esistente come nuovo elemento. Gli imposta già come padre la nuova collezione. (Ereditato da DedTypeBaseCollectionT)
Metodo pubblico | Add(String, String, String, String, String, String, String, Boolean, Boolean, DedTypeFreeFileEnum, DedTypeCompCodeEnum) | Costruttore con inizializzazione di tutti i campi.
Metodo pubblico | Add(String, String, String, String, String, String, String, Boolean, Boolean, DedTypeFreeFileEnum, DedTypeCompCodeEnum, String) | Costruttore con inizializzazione di tutti i campi.
Metodo pubblico | Add(String, String, String, String, String, String, String, Boolean, Boolean, DedTypeFreeFileEnum, DedTypeCompCodeEnum, String, String) | Costruttore con inizializzazione di tutti i campi.
Metodo protetto | AddForClone | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto SENZA MODIFICARNE LO STATO. Le classi derivate potranno utilizzare questo metodo per clonare la collezione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddNewElement | DI USO INTERNO. Aggiunge un elemento alla lista rendendo dirty l'oggetto. L'elemento viene aggiunto con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere un elemento alla lista. Dovranno loro stesse avere un metodo pubblico Add() che prenda i parametri necessari alla costruzione dell'oggetto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddRangeNewElement | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi rendendo dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere più elementi alla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddUnModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Clear | Elimina tutti gli elementi dalla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ClearRefresh | Svuota la lista impostando Dirty = false. Di fatto permette di effettuare un refresh della lista e quindi di ricaricarla. Serve per svuotare la lista e reinizializzarla da capo. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Clone | Metodo per clonare la collezione di famiglie.
Metodo pubblico | Contains | Verifica l'esistenza di un valore all'interno della lista degli elementi. Le classi derivate devono effettuarne l'override nel caso in cui l'elemento non implementi GetHashCode() per l'uso all'interno dei dizionarii. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | CopyTo | Copia un range di elementi in un array. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | CreateDeleteCommand | Crea un comando per eliminare un elemento. (Ereditato da DedTypeBaseCollectionT)
Metodo protetto | CreateInsertCommand | Crea un comando per inserire un elemento. (Sovrascrive DedDbCollectionBaseTCreateInsertCommand(T))
Metodo protetto | CreateUpdateCommand | Crea un comando per aggiornare un elemento. (Sovrascrive DedDbCollectionBaseTCreateUpdateCommand(T))
Metodo pubblico | CustomSort | Ordina la lista in base al comparatore passato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteDeleteItem | Esegue l'eliminazione di un elemento. Crea il comando tramite il metodo CreateDeleteCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteInsertItem | Esegue l'inserimento di un elemento. Crea il comando tramite il metodo CreateInsertCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteUpdateItem | Esegue l'aggiornamento di un elemento. Crea il comando tramite il metodo CreateUpdateCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Find | Restituisce l'oggetto cercato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FindAll | Restitusice la lista degli elementi che corrispondono al predicato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | GetDbIndex | Restituisce l'indice dell'elemento passato (Ereditato da DedTypeBaseCollectionT)
Metodo pubblico | GetEnumerator | Restituisce l'enumeratore della collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | IndexOf | Restituisce l'indice dell'elemento richiesto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InsertUnModified | DI USO INTERNO. Inserisce un elemento alla lista senza rendere dirty l'oggetto, all'indice specificato. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Item | Restituisce l'elemento iesimo della lista. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean) | Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean, Int32) | Sposta l'elemento dell'indice passato prima o dopo del numero di posizioni passate. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSave | Utilizzata per eliminare gli attributi e le regole eliminate nelle sottofamiglie delle famiglie eliminate. Se sono attivi i permessi aggiunge nella tabella DED_FAM_USER_PERM tutte le associazioni dei permessi di lettura di tutti gli utenti per le famiglie aggiunte e li rimuove per le famiglie eliminate. (Sovrascrive DedDbCollectionBaseTOnAfterSave(ListT, ListT, ListT))
Metodo protetto | OnAfterSaveNoChanges | Metodo Template chiamato dopo il salvataggio senza modifiche. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnBeforeSave | Metodo Template chiamato prima del salvataggio. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(T) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(DedEditableObjectT) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(T) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(DedEditableObjectT) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ReInitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Remove | Elimina un elemento dalla collezione. (Sovrascrive DedTypeBaseCollectionTRemove(T))
Metodo pubblico | Ripristina | Verifica che l'elemento sia presente negli eliminati e lo toglie da lì e lo riaggiunge in coda alla lista degli elementi validi. Solleva una eccezione se l'elemento è già presente nella lista e AllowsDuplicates = false. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Save | Salva l'oggetto con tutta la sua lista, solo se questo risulta dirty. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | ToArray | Restituisce un array di questi oggetti. (Ereditato da DedTypeBaseCollectionT)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di DedTypeCollection

Il tipo DedTypeCollection espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllowsDuplicates | Restituisce se siano ammessi duplicati all'interno della lista. Se false viene sollevata una eccezione su tentativo di inserimento duplicati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Application | Restituisce l'oggetto applicazione di appartenza. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Count | Restituisce il numero di elementi presenti. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Dirty | Restituisce se la collezione o uno dei suoi elementi sia stata modificata. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | ErasedItems | Restitusice la lista in sola lettura degli elementi che risultano attualmente cancellati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | LastItem | Restituisce l'ultimo elemento della collezione oppure null se non ci sono elementi. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Owner | Restituisce l'oggetto DedTypeBase di appartenenza. (Ereditato da DedTypeBaseCollectionT)
Proprietà pubblica | RestoreErased | Restituisce se gli elementi cancellati devono essere ripristinati in caso vengano riaggiunti. (Ereditato da DedDbCollectionBaseT)
Torna su
Vedi anche

Documentazione

Classe DedTypeCollection
Namespace DedNet.Core


Metodi di DedTypeCollection

Il tipo DedTypeCollection espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Add(T) | Aggiunge alla collezione un elemento già esistente come nuovo elemento. Gli imposta già come padre la nuova collezione. (Ereditato da DedTypeBaseCollectionT)
Metodo pubblico | Add(String, String, String, String, String, String, String, Boolean, Boolean, DedTypeFreeFileEnum, DedTypeCompCodeEnum) | Costruttore con inizializzazione di tutti i campi.
Metodo pubblico | Add(String, String, String, String, String, String, String, Boolean, Boolean, DedTypeFreeFileEnum, DedTypeCompCodeEnum, String) | Costruttore con inizializzazione di tutti i campi.
Metodo pubblico | Add(String, String, String, String, String, String, String, Boolean, Boolean, DedTypeFreeFileEnum, DedTypeCompCodeEnum, String, String) | Costruttore con inizializzazione di tutti i campi.
Metodo protetto | AddForClone | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto SENZA MODIFICARNE LO STATO. Le classi derivate potranno utilizzare questo metodo per clonare la collezione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddNewElement | DI USO INTERNO. Aggiunge un elemento alla lista rendendo dirty l'oggetto. L'elemento viene aggiunto con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere un elemento alla lista. Dovranno loro stesse avere un metodo pubblico Add() che prenda i parametri necessari alla costruzione dell'oggetto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddRangeNewElement | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi rendendo dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere più elementi alla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddUnModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Clear | Elimina tutti gli elementi dalla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ClearRefresh | Svuota la lista impostando Dirty = false. Di fatto permette di effettuare un refresh della lista e quindi di ricaricarla. Serve per svuotare la lista e reinizializzarla da capo. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Clone | Metodo per clonare la collezione di famiglie.
Metodo pubblico | Contains | Verifica l'esistenza di un valore all'interno della lista degli elementi. Le classi derivate devono effettuarne l'override nel caso in cui l'elemento non implementi GetHashCode() per l'uso all'interno dei dizionarii. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | CopyTo | Copia un range di elementi in un array. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | CreateDeleteCommand | Crea un comando per eliminare un elemento. (Ereditato da DedTypeBaseCollectionT)
Metodo protetto | CreateInsertCommand | Crea un comando per inserire un elemento. (Sovrascrive DedDbCollectionBaseTCreateInsertCommand(T))
Metodo protetto | CreateUpdateCommand | Crea un comando per aggiornare un elemento. (Sovrascrive DedDbCollectionBaseTCreateUpdateCommand(T))
Metodo pubblico | CustomSort | Ordina la lista in base al comparatore passato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteDeleteItem | Esegue l'eliminazione di un elemento. Crea il comando tramite il metodo CreateDeleteCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteInsertItem | Esegue l'inserimento di un elemento. Crea il comando tramite il metodo CreateInsertCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteUpdateItem | Esegue l'aggiornamento di un elemento. Crea il comando tramite il metodo CreateUpdateCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Find | Restituisce l'oggetto cercato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FindAll | Restitusice la lista degli elementi che corrispondono al predicato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | GetDbIndex | Restituisce l'indice dell'elemento passato (Ereditato da DedTypeBaseCollectionT)
Metodo pubblico | GetEnumerator | Restituisce l'enumeratore della collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | IndexOf | Restituisce l'indice dell'elemento richiesto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InsertUnModified | DI USO INTERNO. Inserisce un elemento alla lista senza rendere dirty l'oggetto, all'indice specificato. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Item | Restituisce l'elemento iesimo della lista. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean) | Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean, Int32) | Sposta l'elemento dell'indice passato prima o dopo del numero di posizioni passate. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSave | Utilizzata per eliminare gli attributi e le regole eliminate nelle sottofamiglie delle famiglie eliminate. Se sono attivi i permessi aggiunge nella tabella DED_FAM_USER_PERM tutte le associazioni dei permessi di lettura di tutti gli utenti per le famiglie aggiunte e li rimuove per le famiglie eliminate. (Sovrascrive DedDbCollectionBaseTOnAfterSave(ListT, ListT, ListT))
Metodo protetto | OnAfterSaveNoChanges | Metodo Template chiamato dopo il salvataggio senza modifiche. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnBeforeSave | Metodo Template chiamato prima del salvataggio. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(T) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(DedEditableObjectT) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(T) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(DedEditableObjectT) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ReInitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Remove | Elimina un elemento dalla collezione. (Sovrascrive DedTypeBaseCollectionTRemove(T))
Metodo pubblico | Ripristina | Verifica che l'elemento sia presente negli eliminati e lo toglie da lì e lo riaggiunge in coda alla lista degli elementi validi. Solleva una eccezione se l'elemento è già presente nella lista e AllowsDuplicates = false. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Save | Salva l'oggetto con tutta la sua lista, solo se questo risulta dirty. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | ToArray | Restituisce un array di questi oggetti. (Ereditato da DedTypeBaseCollectionT)
Torna su
Vedi anche

Documentazione

Classe DedTypeCollection
Namespace DedNet.Core


Metodo DedTypeCollection.Add

Metodo DedTypeCollectionAdd
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Add(T) | Aggiunge alla collezione un elemento già esistente come nuovo elemento. Gli imposta già come padre la nuova collezione.
Metodo pubblico | Add(String, String, String, String, String, String, String, Boolean, Boolean, DedTypeFreeFileEnum, DedTypeCompCodeEnum) | Costruttore con inizializzazione di tutti i campi.
Metodo pubblico | Add(String, String, String, String, String, String, String, Boolean, Boolean, DedTypeFreeFileEnum, DedTypeCompCodeEnum, String) | Costruttore con inizializzazione di tutti i campi.
Metodo pubblico | Add(String, String, String, String, String, String, String, Boolean, Boolean, DedTypeFreeFileEnum, DedTypeCompCodeEnum, String, String) | Costruttore con inizializzazione di tutti i campi.
Torna su
Vedi anche

Documentazione

Classe DedTypeCollection
Namespace DedNet.Core


Metodo DedTypeCollection.Add(String, String, String, String, String, String, String, Boolean, Boolean, DedType.FreeFileEnum, DedType.CompCodeEnum)

Metodo DedTypeCollectionAdd(String, String, String, String, String, String, String, Boolean, Boolean, DedTypeFreeFileEnum, DedTypeCompCodeEnum)
Costruttore con inizializzazione di tutti i campi.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedType Add(
    string name,
    string Descriz,
    string DwgPath,
    string Progr,
    string Cod_dis,
    string Cod_fil,
    string Cod_id,
    bool IsPrj,
    bool IsFreeCode,
    DedTypeFreeFileEnum freeFile,
    DedTypeCompCodeEnum CompCode
)
Public Function Add (
    name As String,
    Descriz As String,
    DwgPath As String,
    Progr As String,
    Cod_dis As String,
    Cod_fil As String,
    Cod_id As String,
    IsPrj As Boolean,
    IsFreeCode As Boolean,
    freeFile As DedTypeFreeFileEnum,
    CompCode As DedTypeCompCodeEnum
) As DedType
public:
DedType^ Add(
    String^ name,
    String^ Descriz,
    String^ DwgPath,
    String^ Progr,
    String^ Cod_dis,
    String^ Cod_fil,
    String^ Cod_id,
    bool IsPrj,
    bool IsFreeCode,
    DedTypeFreeFileEnum freeFile,
    DedTypeCompCodeEnum CompCode
)
member Add :
        name : string *
        Descriz : string *
        DwgPath : string *
        Progr : string *
        Cod_dis : string *
        Cod_fil : string *
        Cod_id : string *
        IsPrj : bool *
        IsFreeCode : bool *
        freeFile : DedTypeFreeFileEnum *
        CompCode : DedTypeCompCodeEnum -> DedType

Parametri

name String
Nome della famiglia.
Descriz String
Descrizione tipo-famiglia.
DwgPath String
Directory di salvataggio tipo-famiglia.
Progr String
Progressivo tipo-famiglia.
Cod_dis String
Maschera di codifica DED_DIS.
Cod_fil String
Maschera di codifica per il nome file di default per i file primari di questa famiglia.
Cod_id String
Maschera di codifica DEDID.
IsPrj Boolean
Specifica se si tratta di tipo-famiglia progetto.
IsFreeCode Boolean
Specifica se si tratta di tipo-famiglia a codifica libera.
freeFile DedTypeFreeFileEnum
Specifica se si tratta di tipo-famiglia a codifica file libera.
CompCode DedTypeCompCodeEnum
Tipo di compilazione del campo DED_COD.

Valore di ritorno

DedType
Vedi anche

Documentazione

Classe DedTypeCollection
Overload di Add
Namespace DedNet.Core


Metodo DedTypeCollection.Add(String, String, String, String, String, String, String, Boolean, Boolean, DedType.FreeFileEnum, DedType.CompCodeEnum, String)

Metodo DedTypeCollectionAdd(String, String, String, String, String, String, String, Boolean, Boolean, DedTypeFreeFileEnum, DedTypeCompCodeEnum, String)
Costruttore con inizializzazione di tutti i campi.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedType Add(
    string name,
    string Descriz,
    string DwgPath,
    string Progr,
    string Cod_dis,
    string Cod_fil,
    string Cod_id,
    bool IsPrj,
    bool IsFreeCode,
    DedTypeFreeFileEnum freeFile,
    DedTypeCompCodeEnum CompCode,
    string ProgrAlphabet
)
Public Function Add (
    name As String,
    Descriz As String,
    DwgPath As String,
    Progr As String,
    Cod_dis As String,
    Cod_fil As String,
    Cod_id As String,
    IsPrj As Boolean,
    IsFreeCode As Boolean,
    freeFile As DedTypeFreeFileEnum,
    CompCode As DedTypeCompCodeEnum,
    ProgrAlphabet As String
) As DedType
public:
DedType^ Add(
    String^ name,
    String^ Descriz,
    String^ DwgPath,
    String^ Progr,
    String^ Cod_dis,
    String^ Cod_fil,
    String^ Cod_id,
    bool IsPrj,
    bool IsFreeCode,
    DedTypeFreeFileEnum freeFile,
    DedTypeCompCodeEnum CompCode,
    String^ ProgrAlphabet
)
member Add :
        name : string *
        Descriz : string *
        DwgPath : string *
        Progr : string *
        Cod_dis : string *
        Cod_fil : string *
        Cod_id : string *
        IsPrj : bool *
        IsFreeCode : bool *
        freeFile : DedTypeFreeFileEnum *
        CompCode : DedTypeCompCodeEnum *
        ProgrAlphabet : string -> DedType

Parametri

name String
Nome della famiglia.
Descriz String
Descrizione tipo-famiglia.
DwgPath String
Directory di salvataggio tipo-famiglia.
Progr String
Progressivo tipo-famiglia.
Cod_dis String
Maschera di codifica DED_DIS.
Cod_fil String
Maschera di codifica per il nome file di default per i file primari di questa famiglia.
Cod_id String
Maschera di codifica DEDID.
IsPrj Boolean
Specifica se si tratta di tipo-famiglia progetto.
IsFreeCode Boolean
Specifica se si tratta di tipo-famiglia a codifica libera.
freeFile DedTypeFreeFileEnum
Specifica se si tratta di tipo-famiglia a codifica file libera.
CompCode DedTypeCompCodeEnum
Tipo di compilazione del campo DED_COD.
ProgrAlphabet String

Valore di ritorno

DedType
Vedi anche

Documentazione

Classe DedTypeCollection
Overload di Add
Namespace DedNet.Core


Metodo DedTypeCollection.Add(String, String, String, String, String, String, String, Boolean, Boolean, DedType.FreeFileEnum, DedType.CompCodeEnum, String, String)

Metodo DedTypeCollectionAdd(String, String, String, String, String, String, String, Boolean, Boolean, DedTypeFreeFileEnum, DedTypeCompCodeEnum, String, String)
Costruttore con inizializzazione di tutti i campi.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedType Add(
    string name,
    string Descriz,
    string DwgPath,
    string Progr,
    string Cod_dis,
    string Cod_fil,
    string Cod_id,
    bool IsPrj,
    bool IsFreeCode,
    DedTypeFreeFileEnum freeFile,
    DedTypeCompCodeEnum CompCode,
    string ProgrAlphabet,
    string RevisionAlphabet
)
Public Function Add (
    name As String,
    Descriz As String,
    DwgPath As String,
    Progr As String,
    Cod_dis As String,
    Cod_fil As String,
    Cod_id As String,
    IsPrj As Boolean,
    IsFreeCode As Boolean,
    freeFile As DedTypeFreeFileEnum,
    CompCode As DedTypeCompCodeEnum,
    ProgrAlphabet As String,
    RevisionAlphabet As String
) As DedType
public:
DedType^ Add(
    String^ name,
    String^ Descriz,
    String^ DwgPath,
    String^ Progr,
    String^ Cod_dis,
    String^ Cod_fil,
    String^ Cod_id,
    bool IsPrj,
    bool IsFreeCode,
    DedTypeFreeFileEnum freeFile,
    DedTypeCompCodeEnum CompCode,
    String^ ProgrAlphabet,
    String^ RevisionAlphabet
)
member Add :
        name : string *
        Descriz : string *
        DwgPath : string *
        Progr : string *
        Cod_dis : string *
        Cod_fil : string *
        Cod_id : string *
        IsPrj : bool *
        IsFreeCode : bool *
        freeFile : DedTypeFreeFileEnum *
        CompCode : DedTypeCompCodeEnum *
        ProgrAlphabet : string *
        RevisionAlphabet : string -> DedType

Parametri

name String
Nome della famiglia.
Descriz String
Descrizione tipo-famiglia.
DwgPath String
Directory di salvataggio tipo-famiglia.
Progr String
Progressivo tipo-famiglia.
Cod_dis String
Maschera di codifica DED_DIS.
Cod_fil String
Maschera di codifica per il nome file di default per i file primari di questa famiglia.
Cod_id String
Maschera di codifica DEDID.
IsPrj Boolean
Specifica se si tratta di tipo-famiglia progetto.
IsFreeCode Boolean
Specifica se si tratta di tipo-famiglia a codifica libera.
freeFile DedTypeFreeFileEnum
Specifica se si tratta di tipo-famiglia a codifica file libera.
CompCode DedTypeCompCodeEnum
Tipo di compilazione del campo DED_COD.
ProgrAlphabet String
RevisionAlphabet String

Valore di ritorno

DedType
Vedi anche

Documentazione

Classe DedTypeCollection
Overload di Add
Namespace DedNet.Core


Metodo DedTypeCollection.Clone

Metodo DedTypeCollectionClone
Metodo per clonare la collezione di famiglie.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeCollection Clone(
    DedType owner
)
Public Function Clone (
    owner As DedType
) As DedTypeCollection
public:
DedTypeCollection^ Clone(
    DedType^ owner
)
member Clone :
        owner : DedType -> DedTypeCollection

Parametri

owner DedType

Valore di ritorno

DedTypeCollection
Vedi anche

Documentazione

Classe DedTypeCollection
Namespace DedNet.Core


Metodo DedTypeCollection.CreateInsertCommand

Metodo DedTypeCollectionCreateInsertCommand
Crea un comando per inserire un elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSInsertCommand CreateInsertCommand(
    DedType item
)
Protected Overrides Function CreateInsertCommand (
    item As DedType
) As QSInsertCommand
protected:
virtual QSInsertCommand^ CreateInsertCommand(
    DedType^ item
) override
abstract CreateInsertCommand :
        item : DedType -> QSInsertCommand
override CreateInsertCommand :
        item : DedType -> QSInsertCommand

Parametri

item DedType
Elemento da inserire.

Valore di ritorno

QSInsertCommand
Vedi anche

Documentazione

Classe DedTypeCollection
Namespace DedNet.Core


Metodo DedTypeCollection.CreateUpdateCommand

Metodo DedTypeCollectionCreateUpdateCommand
Crea un comando per aggiornare un elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSUpdateCommand CreateUpdateCommand(
    DedType item
)
Protected Overrides Function CreateUpdateCommand (
    item As DedType
) As QSUpdateCommand
protected:
virtual QSUpdateCommand^ CreateUpdateCommand(
    DedType^ item
) override
abstract CreateUpdateCommand :
        item : DedType -> QSUpdateCommand
override CreateUpdateCommand :
        item : DedType -> QSUpdateCommand

Parametri

item DedType
Elemento da aggiornare.

Valore di ritorno

QSUpdateCommand
Vedi anche

Documentazione

Classe DedTypeCollection
Namespace DedNet.Core


Metodo DedTypeCollection.OnAfterSave

Metodo DedTypeCollectionOnAfterSave
Utilizzata per eliminare gli attributi e le regole eliminate nelle sottofamiglie delle famiglie eliminate. Se sono attivi i permessi aggiunge nella tabella DED_FAM_USER_PERM tutte le associazioni dei permessi di lettura di tutti gli utenti per le famiglie aggiunte e li rimuove per le famiglie eliminate.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void OnAfterSave(
    List<DedType> eliminati,
    List<DedType> modificati,
    List<DedType> aggiunti
)
Protected Overrides Sub OnAfterSave (
    eliminati As List(Of DedType),
    modificati As List(Of DedType),
    aggiunti As List(Of DedType)
)
protected:
virtual void OnAfterSave(
    List<DedType^>^ eliminati,
    List<DedType^>^ modificati,
    List<DedType^>^ aggiunti
) override
abstract OnAfterSave :
        eliminati : List<DedType> *
        modificati : List<DedType> *
        aggiunti : List<DedType> -> unit
override OnAfterSave :
        eliminati : List<DedType> *
        modificati : List<DedType> *
        aggiunti : List<DedType> -> unit

Parametri

eliminati List DedType
modificati List DedType
aggiunti List DedType
Vedi anche

Documentazione

Classe DedTypeCollection
Namespace DedNet.Core


Metodo DedTypeCollection.Remove

Metodo DedTypeCollectionRemove
Elimina un elemento dalla collezione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void Remove(
    DedType item
)
Public Overrides Sub Remove (
    item As DedType
)
public:
virtual void Remove(
    DedType^ item
) override
abstract Remove :
        item : DedType -> unit
override Remove :
        item : DedType -> unit

Parametri

item DedType
Elemento da eliminare.
Vedi anche

Documentazione

Classe DedTypeCollection
Namespace DedNet.Core


Classe DedTypeGenericList<T>

Classe DedTypeGenericListT
Classe DedTypeGenericList
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList T
DedNet.CoreDedTypeGenericListT
DedNet.CoreDedTypeBaseList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedTypeGenericList<T> : List<T>

Public Class DedTypeGenericList(Of T)
    Inherits List(Of T)
generic<typename T>
public ref class DedTypeGenericList : public List<T>
type DedTypeGenericList<'T> =
    class
        inherit List<'T>
    end

Parametri di tipo

T

Il tipo DedTypeGenericListT espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedTypeGenericListT | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione di appartenenza.
Proprietà pubblica | CommonDedType | Restituisce l'oggetto DedTypeBase comune
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedTypeGenericList<T>

Costruttore DedTypeGenericListT
Costruttore unico.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeGenericList(
    DedNetApplication application
)
Public Sub New (
    application As DedNetApplication
)
public:
DedTypeGenericList(
    DedNetApplication^ application
)
new :
        application : DedNetApplication -> DedTypeGenericList

Parametri

application DedNetApplication
Oggetto applicazione di appartenenza.
Vedi anche

Documentazione

Classe DedTypeGenericListT
Namespace DedNet.Core


Proprietà di DedTypeGenericList<T>

Proprietà di DedTypeGenericListT

Il tipo DedTypeGenericListT espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione di appartenenza.
Proprietà pubblica | CommonDedType | Restituisce l'oggetto DedTypeBase comune
Torna su
Vedi anche

Documentazione

Classe DedTypeGenericListT
Namespace DedNet.Core


Proprietà DedTypeGenericList<T>.Application

Proprietà DedTypeGenericListTApplication
Restituisce l'applicazione di appartenenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedNetApplication Application { get; }
Public ReadOnly Property Application As DedNetApplication
    Get
public:
property DedNetApplication^ Application {
    DedNetApplication^ get ();
}
member Application : DedNetApplication with get

Valore della proprietà

DedNetApplication
Vedi anche

Documentazione

Classe DedTypeGenericListT
Namespace DedNet.Core


Proprietà DedTypeGenericList<T>.CommonDedType

Proprietà DedTypeGenericListTCommonDedType
Restituisce l'oggetto DedTypeBase comune

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual Object CommonDedType { get; }
Public Overridable ReadOnly Property CommonDedType As Object
    Get
public:
virtual property Object^ CommonDedType {
    Object^ get ();
}
abstract CommonDedType : Object with get
override CommonDedType : Object with get

Valore della proprietà

Object
Vedi anche

Documentazione

Classe DedTypeGenericListT
Namespace DedNet.Core


Classe DedTypeList
Lista di oggetti DedType.
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList DedTypeBase
DedNet.CoreDedTypeGenericList DedTypeBase
DedNet.CoreDedTypeBaseList
DedNet.CoreDedTypeList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedTypeList : DedTypeBaseList
Public Class DedTypeList
    Inherits DedTypeBaseList
public ref class DedTypeList : public DedTypeBaseList
type DedTypeList =
    class
        inherit DedTypeBaseList
    end

Il tipo DedTypeList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedTypeList | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione di appartenenza. (Ereditato da DedTypeGenericListT)
Proprietà pubblica | AttributesAnagraficaWithChild | Restituisce la lista di attributi di anagrafica visibili da questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota.
Proprietà pubblica | CommonDedType | Restituisce la famiglia genitore comune a tutte le famiglie presenti. (Sovrascrive DedTypeGenericListTCommonDedType)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedTypeList
Costruttore unico.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeList(
    DedNetApplication application
)
Public Sub New (
    application As DedNetApplication
)
public:
DedTypeList(
    DedNetApplication^ application
)
new :
        application : DedNetApplication -> DedTypeList

Parametri

application DedNetApplication
Oggetto applicazione di appartenenza.
Vedi anche

Documentazione

Classe DedTypeList
Namespace DedNet.Core


Proprietà di DedTypeList

Il tipo DedTypeList espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione di appartenenza. (Ereditato da DedTypeGenericListT)
Proprietà pubblica | AttributesAnagraficaWithChild | Restituisce la lista di attributi di anagrafica visibili da questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota.
Proprietà pubblica | CommonDedType | Restituisce la famiglia genitore comune a tutte le famiglie presenti. (Sovrascrive DedTypeGenericListTCommonDedType)
Torna su
Vedi anche

Documentazione

Classe DedTypeList
Namespace DedNet.Core


Proprietà DedTypeList.AttributesAnagraficaWithChild

Proprietà DedTypeListAttributesAnagraficaWithChild
Restituisce la lista di attributi di anagrafica visibili da questa famiglia. Se non ce ne sono viene restituita una lista inizializzata ma vuota.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList AttributesAnagraficaWithChild { get; }
Public ReadOnly Property AttributesAnagraficaWithChild As DedAttrList
    Get
public:
property DedAttrList^ AttributesAnagraficaWithChild {
    DedAttrList^ get ();
}
member AttributesAnagraficaWithChild : DedAttrList with get

Valore della proprietà

DedAttrList
Vedi anche

Documentazione

Classe DedTypeList
Namespace DedNet.Core


Proprietà DedTypeList.CommonDedType

Proprietà DedTypeListCommonDedType
Restituisce la famiglia genitore comune a tutte le famiglie presenti.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override Object CommonDedType { get; }
Public Overrides ReadOnly Property CommonDedType As Object
    Get
public:
virtual property Object^ CommonDedType {
    Object^ get () override;
}
abstract CommonDedType : Object with get
override CommonDedType : Object with get

Valore della proprietà

Object
Vedi anche

Documentazione

Classe DedTypeList
Namespace DedNet.Core


Classe DedTypeManager
Classe che espone alcune utilità di funzione generale per operare con le famiglie.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedTypeManager

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedTypeManager
Public Class DedTypeManager
public ref class DedTypeManager
type DedTypeManager = class end

Il tipo DedTypeManager espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedTypeManager | Crea una nuova istanza della classe 'DedTypeManager' utilizzata per operare con le famiglie.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | TypeNeedDisablePlaceHolder(DedData) | Ritorna True nel caso in cui l'anagrafica specificata in ingresso necessita di disabilitare la gestione dei segnaposto (.moved e .del) per i file ad essa collegati.
Metodo pubblico | TypeNeedDisablePlaceHolder(DedTypeBase) | Ritorna True nel caso in cui l'anagrafica specificata in ingresso necessita di disabilitare la gestione dei segnaposto (.moved e .del) per i file ad essa collegati.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedTypeManager
Crea una nuova istanza della classe 'DedTypeManager' utilizzata per operare con le famiglie.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeManager(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedTypeManager(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedTypeManager

Parametri

app DedNetApplication
Applicazione DedNet.
Vedi anche

Documentazione

Classe DedTypeManager
Namespace DedNet.Core


Metodi di DedTypeManager

Il tipo DedTypeManager espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | TypeNeedDisablePlaceHolder(DedData) | Ritorna True nel caso in cui l'anagrafica specificata in ingresso necessita di disabilitare la gestione dei segnaposto (.moved e .del) per i file ad essa collegati.
Metodo pubblico | TypeNeedDisablePlaceHolder(DedTypeBase) | Ritorna True nel caso in cui l'anagrafica specificata in ingresso necessita di disabilitare la gestione dei segnaposto (.moved e .del) per i file ad essa collegati.
Torna su
Vedi anche

Documentazione

Classe DedTypeManager
Namespace DedNet.Core


Metodo DedTypeManager.TypeNeedDisablePlaceHolder

Metodo DedTypeManagerTypeNeedDisablePlaceHolder
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | TypeNeedDisablePlaceHolder(DedData) | Ritorna True nel caso in cui l'anagrafica specificata in ingresso necessita di disabilitare la gestione dei segnaposto (.moved e .del) per i file ad essa collegati.
Metodo pubblico | TypeNeedDisablePlaceHolder(DedTypeBase) | Ritorna True nel caso in cui l'anagrafica specificata in ingresso necessita di disabilitare la gestione dei segnaposto (.moved e .del) per i file ad essa collegati.
Torna su
Vedi anche

Documentazione

Classe DedTypeManager
Namespace DedNet.Core


Metodo DedTypeManager.TypeNeedDisablePlaceHolder(DedData)

Metodo DedTypeManagerTypeNeedDisablePlaceHolder(DedData)
Ritorna True nel caso in cui l'anagrafica specificata in ingresso necessita di disabilitare la gestione dei segnaposto (.moved e .del) per i file ad essa collegati.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool TypeNeedDisablePlaceHolder(
    DedData data
)
Public Function TypeNeedDisablePlaceHolder (
    data As DedData
) As Boolean
public:
bool TypeNeedDisablePlaceHolder(
    DedData^ data
)
member TypeNeedDisablePlaceHolder :
        data : DedData -> bool

Parametri

data DedData
Anagrafica da cui prelevare le famiglie genitori.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedTypeManager
Overload di TypeNeedDisablePlaceHolder
Namespace DedNet.Core


Metodo DedTypeManager.TypeNeedDisablePlaceHolder(DedTypeBase)

Metodo DedTypeManagerTypeNeedDisablePlaceHolder(DedTypeBase)
Ritorna True nel caso in cui l'anagrafica specificata in ingresso necessita di disabilitare la gestione dei segnaposto (.moved e .del) per i file ad essa collegati.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool TypeNeedDisablePlaceHolder(
    DedTypeBase fam
)
Public Function TypeNeedDisablePlaceHolder (
    fam As DedTypeBase
) As Boolean
public:
bool TypeNeedDisablePlaceHolder(
    DedTypeBase^ fam
)
member TypeNeedDisablePlaceHolder :
        fam : DedTypeBase -> bool

Parametri

fam DedTypeBase

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedTypeManager
Overload di TypeNeedDisablePlaceHolder
Namespace DedNet.Core


Classe DedTypeProg
Classe per rappresentare un oggetto della tabella DED_TIPI_PROG.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedTypeProg

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedTypeProg
Public Class DedTypeProg
public ref class DedTypeProg
type DedTypeProg = class end

Il tipo DedTypeProg espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedTypeProg | costruttore senza parametri.
Metodo pubblico | DedTypeProg(String, String, String, String, String, String) | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | DbPath | DbPath della famiglia a cui sono assegnati i progressivi.
Proprietà pubblica | Guid | Guid univoco della riga.
Proprietà pubblica | ProgCur | Valore attuale del progressivo.
Proprietà pubblica | ProgMax | Valore massimo del progressivo.
Proprietà pubblica | ProgMin | Valore minimo del progressivo.
Proprietà pubblica | UserName | Utente a cui sono assegnati i progressivi.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedTypeProg
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | DedTypeProg | costruttore senza parametri.
Metodo pubblico | DedTypeProg(String, String, String, String, String, String) | Costruttore unico.
Torna su
Vedi anche

Documentazione

Classe DedTypeProg
Namespace DedNet.Core


Costruttore DedTypeProg
costruttore senza parametri.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeProg()
Public Sub New
public:
DedTypeProg()
new : unit -> DedTypeProg
Vedi anche

Documentazione

Classe DedTypeProg
Overload di DedTypeProg
Namespace DedNet.Core


Costruttore DedTypeProg(String, String, String, String, String, String)
Costruttore unico.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeProg(
    string guid,
    string dbpath,
    string username,
    string progcur,
    string progmin,
    string progmax
)
Public Sub New (
    guid As String,
    dbpath As String,
    username As String,
    progcur As String,
    progmin As String,
    progmax As String
)
public:
DedTypeProg(
    String^ guid,
    String^ dbpath,
    String^ username,
    String^ progcur,
    String^ progmin,
    String^ progmax
)
new :
        guid : string *
        dbpath : string *
        username : string *
        progcur : string *
        progmin : string *
        progmax : string -> DedTypeProg

Parametri

guid String
dbpath String
DBPATH della famiglia a cui sono riservati i progressivi.
username String
Utente a cui sono riservati i progressivi.
progcur String
Valore attuale del progressivo.
progmin String
Valore minimo del progressivo.
progmax String
Valore massimo del progressivo.
Vedi anche

Documentazione

Classe DedTypeProg
Overload di DedTypeProg
Namespace DedNet.Core


Proprietà di DedTypeProg

Il tipo DedTypeProg espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | DbPath | DbPath della famiglia a cui sono assegnati i progressivi.
Proprietà pubblica | Guid | Guid univoco della riga.
Proprietà pubblica | ProgCur | Valore attuale del progressivo.
Proprietà pubblica | ProgMax | Valore massimo del progressivo.
Proprietà pubblica | ProgMin | Valore minimo del progressivo.
Proprietà pubblica | UserName | Utente a cui sono assegnati i progressivi.
Torna su
Vedi anche

Documentazione

Classe DedTypeProg
Namespace DedNet.Core


Proprietà DedTypeProg.DbPath

Proprietà DedTypeProgDbPath
DbPath della famiglia a cui sono assegnati i progressivi.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string DbPath { get; set; }
Public Property DbPath As String
    Get
    Set
public:
property String^ DbPath {
    String^ get ();
    void set (String^ value);
}
member DbPath : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedTypeProg
Namespace DedNet.Core


Proprietà DedTypeProg.Guid

Proprietà DedTypeProgGuid
Guid univoco della riga.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Guid { get; set; }
Public Property Guid As String
    Get
    Set
public:
property String^ Guid {
    String^ get ();
    void set (String^ value);
}
member Guid : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedTypeProg
Namespace DedNet.Core


Proprietà DedTypeProg.ProgCur

Proprietà DedTypeProgProgCur
Valore attuale del progressivo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string ProgCur { get; set; }
Public Property ProgCur As String
    Get
    Set
public:
property String^ ProgCur {
    String^ get ();
    void set (String^ value);
}
member ProgCur : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedTypeProg
Namespace DedNet.Core


Proprietà DedTypeProg.ProgMax

Proprietà DedTypeProgProgMax
Valore massimo del progressivo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string ProgMax { get; set; }
Public Property ProgMax As String
    Get
    Set
public:
property String^ ProgMax {
    String^ get ();
    void set (String^ value);
}
member ProgMax : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedTypeProg
Namespace DedNet.Core


Proprietà DedTypeProg.ProgMin

Proprietà DedTypeProgProgMin
Valore minimo del progressivo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string ProgMin { get; set; }
Public Property ProgMin As String
    Get
    Set
public:
property String^ ProgMin {
    String^ get ();
    void set (String^ value);
}
member ProgMin : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedTypeProg
Namespace DedNet.Core


Proprietà DedTypeProg.UserName

Proprietà DedTypeProgUserName
Utente a cui sono assegnati i progressivi.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string UserName { get; set; }
Public Property UserName As String
    Get
    Set
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}
member UserName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedTypeProg
Namespace DedNet.Core


Metodi di DedTypeProg

Il tipo DedTypeProg espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Torna su
Vedi anche

Documentazione

Classe DedTypeProg
Namespace DedNet.Core


Metodo DedTypeProg.Equals

Metodo DedTypeProgEquals

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj Object

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedTypeProg
Namespace DedNet.Core


Metodo DedTypeProg.GetHashCode

Metodo DedTypeProgGetHashCode

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedTypeProg
Namespace DedNet.Core


Metodo DedTypeProg.ToString

Metodo DedTypeProgToString

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedTypeProg
Namespace DedNet.Core


Classe DedTypeProgList
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList DedTypeProg
DedNet.CoreDedTypeProgList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedTypeProgList : List<DedTypeProg>
Public Class DedTypeProgList
    Inherits List(Of DedTypeProg)
public ref class DedTypeProgList : public List<DedTypeProg^>
type DedTypeProgList =
    class
        inherit List<DedTypeProg>
    end

Il tipo DedTypeProgList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedTypeProgList |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedTypeProgList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeProgList()
Public Sub New
public:
DedTypeProgList()
new : unit -> DedTypeProgList
Vedi anche

Documentazione

Classe DedTypeProgList
Namespace DedNet.Core


Classe DedTypeProgListSerializable
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedTypeProgListSerializable

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class DedTypeProgListSerializable
<SerializableAttribute>
Public Class DedTypeProgListSerializable
[SerializableAttribute]
public ref class DedTypeProgListSerializable
[<SerializableAttribute>]
type DedTypeProgListSerializable = class end

Il tipo DedTypeProgListSerializable espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedTypeProgListSerializable | Costruttore classe
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | elencoProg |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedTypeProgListSerializable
Costruttore classe

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeProgListSerializable()
Public Sub New
public:
DedTypeProgListSerializable()
new : unit -> DedTypeProgListSerializable
Vedi anche

Documentazione

Classe DedTypeProgListSerializable
Namespace DedNet.Core


Proprietà di DedTypeProgListSerializable

Il tipo DedTypeProgListSerializable espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | elencoProg |
Torna su
Vedi anche

Documentazione

Classe DedTypeProgListSerializable
Namespace DedNet.Core


Proprietà DedTypeProgListSerializable.elencoProg

Proprietà DedTypeProgListSerializableelencoProg

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<DedTypeProg> elencoProg { get; set; }
Public Property elencoProg As List(Of DedTypeProg)
    Get
    Set
public:
property List<DedTypeProg^>^ elencoProg {
    List<DedTypeProg^>^ get ();
    void set (List<DedTypeProg^>^ value);
}
member elencoProg : List<DedTypeProg> with get, set

Valore della proprietà

List DedTypeProg
Vedi anche

Documentazione

Classe DedTypeProgListSerializable
Namespace DedNet.Core


Classe DedUG
Collezione di utenti appartenenti ad un solo gruppo.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedUG

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedUG : IDedDbItem
Public Class DedUG
    Implements IDedDbItem
public ref class DedUG : IDedDbItem
type DedUG =
    class
        interface IDedDbItem
    end

Il tipo DedUG espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Group | Restituisce o imposta il gruppo al quale appartiene l'utente.
Proprietà pubblica | StatoRecord | Di uso interno.
Proprietà pubblica | User | Restituisce o imposta l'utente abbinato al gruppo.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di DedUG

Il tipo DedUG espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Group | Restituisce o imposta il gruppo al quale appartiene l'utente.
Proprietà pubblica | StatoRecord | Di uso interno.
Proprietà pubblica | User | Restituisce o imposta l'utente abbinato al gruppo.
Torna su
Vedi anche

Documentazione

Classe DedUG
Namespace DedNet.Core


Proprietà DedUG.Group

Proprietà DedUGGroup
Restituisce o imposta il gruppo al quale appartiene l'utente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedGroup Group { get; set; }
Public Property Group As DedGroup
    Get
    Set
public:
property DedGroup^ Group {
    DedGroup^ get ();
    void set (DedGroup^ value);
}
member Group : DedGroup with get, set

Valore della proprietà

DedGroup
Vedi anche

Documentazione

Classe DedUG
Namespace DedNet.Core


Proprietà DedUG.StatoRecord

Proprietà DedUGStatoRecord
Di uso interno.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public StatoRecord StatoRecord { get; set; }
Public Property StatoRecord As StatoRecord
    Get
    Set
public:
virtual property StatoRecord^ StatoRecord {
    StatoRecord^ get () sealed;
    void set (StatoRecord^ value) sealed;
}
abstract StatoRecord : StatoRecord with get, set
override StatoRecord : StatoRecord with get, set

Valore della proprietà

StatoRecord

Implementa

IDedDbItemStatoRecord
Vedi anche

Documentazione

Classe DedUG
Namespace DedNet.Core


Proprietà DedUG.User

Proprietà DedUGUser
Restituisce o imposta l'utente abbinato al gruppo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedUser User { get; set; }
Public Property User As DedUser
    Get
    Set
public:
property DedUser^ User {
    DedUser^ get ();
    void set (DedUser^ value);
}
member User : DedUser with get, set

Valore della proprietà

DedUser
Vedi anche

Documentazione

Classe DedUG
Namespace DedNet.Core


Metodi di DedUG

Il tipo DedUG espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Torna su
Vedi anche

Documentazione

Classe DedUG
Namespace DedNet.Core


Metodo DedUG.Equals

Metodo DedUGEquals

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj Object

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedUG
Namespace DedNet.Core


Metodo DedUG.GetHashCode

Metodo DedUGGetHashCode

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DedUG
Namespace DedNet.Core


Metodo DedUG.ToString

Metodo DedUGToString

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedUG
Namespace DedNet.Core


Classe DedUser
Racchiude tutte le informazioni di un utente.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedPermOwner
DedNet.CoreDedUser

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedUser : DedPermOwner, IDedDbItem
Public Class DedUser
    Inherits DedPermOwner
    Implements IDedDbItem
public ref class DedUser : public DedPermOwner,
    IDedDbItem
type DedUser =
    class
        inherit DedPermOwner
        interface IDedDbItem
    end

Il tipo DedUser espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione di appartenenza. (Ereditato da DedPermOwner)
Proprietà pubblica | Corporate | Restituisce o imposta la corporate dell'utente.
Proprietà pubblica | Descr | Restituisce o imposta la descrizione dell'utente.
Proprietà pubblica | Dirty | Restituisce se l'utente sia stato modificato nei suoi permessi.
Proprietà pubblica | Email | Restituisce o imposta l'indirizzo email dell'utente.
Proprietà pubblica | Groups | Restituisce una lista in sola lettura dei gruppi ai quali questo utente appartiene. Restituisce sempre una lista inizializzata.
Proprietà pubblica | GruppiAppartenenza | Restituisce l'elenco dei gruppo ai quali questo utente appartiene in formato stringa
Proprietà pubblica | IsGroup | Restituisce se si tratti di un gruppo (sempre false tranne nel caso di un gruppo). (Ereditato da DedPermOwner)
Proprietà pubblica | IsUser | Restituisce se si tratti di un utente (sempre false tranne nel caso di un utente). (Ereditato da DedPermOwner)
Proprietà pubblica | Manager | Restituisce il Gestore dei permessi. (Ereditato da DedPermOwner)
Proprietà pubblica | Name | Restituisce o imposta il nome dell'utente. (Sovrascrive DedPermOwnerName)
Proprietà pubblica | NameVis | Restituisce o imposta il nome visualizzato dell'utente.
Proprietà pubblica | PermItems | Restitusice il set di permessi di questo possessore. (Ereditato da DedPermOwner)
Proprietà pubblica | Pwd | Restituisce o imposta la password dell'utente.
Proprietà pubblica | Pws | Restituisce o imposta l'override della radice di root legato all'utente.
Proprietà pubblica | StatoRecord | Di uso interno.
Proprietà protetta | TableName | Restituisce il nome della table del Database. (Ereditato da DedPermOwner)
Proprietà pubblica | UseWin | Restituisce o imposta se utilizzare l'autenticazione di windows.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AddGroup(DedGroup) | Aggiunge questo utente al gruppo passato.
Metodo pubblico | AddGroup(String) | Aggiunge questo utente al gruppo passato.
Metodo protetto | CreateDeleteCommand | (Sovrascrive DedPermOwnerCreateDeleteCommand(DedPerm))
Metodo protetto | CreateInsertCommand | (Sovrascrive DedPermOwnerCreateInsertCommand(DedPerm))
Metodo protetto | CreateUpdateCommand | (Sovrascrive DedPermOwnerCreateUpdateCommand(DedPerm))
Metodo protetto | GetDbIndex | (Sovrascrive DedPermOwnerGetDbIndex(DedPerm))
Metodo pubblico | GetPermDescription | Restituisce la descrizione del permesso. (Ereditato da DedPermOwner)
Metodo pubblico | GetPermVal(String, String) | Restituisce il valore del permesso. (Sovrascrive DedPermOwnerGetPermVal(String, String))
Metodo pubblico | GetPermVal(String, String, String) | Restituisce il valore del permesso impostando la stringa descrittiva il tipo di ereditarietà del permesso. (Sovrascrive DedPermOwnerGetPermVal(String, String, String))
Metodo pubblico | IsPermPresent | Restituisce se il permesso è presente in modo esplicito fra i permessi di questa instanza. (Ereditato da DedPermOwner)
Metodo pubblico | RemoveGroup(DedGroup) | Rimuove questo utente al gruppo passato.
Metodo pubblico | RemoveGroup(String) | Rimuove questo utente al gruppo passato.
Metodo pubblico | ResetGruppiAppartenenza | Azzero i gruppi di appartenenza così lo ricalcolo
Metodo pubblico | SetPermVal | Imposta il permesso ottenendo la stringa descrittiva del permesso. (Sovrascrive DedPermOwnerSetPermVal(String, String, Boolean))
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di DedUser

Il tipo DedUser espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione di appartenenza. (Ereditato da DedPermOwner)
Proprietà pubblica | Corporate | Restituisce o imposta la corporate dell'utente.
Proprietà pubblica | Descr | Restituisce o imposta la descrizione dell'utente.
Proprietà pubblica | Dirty | Restituisce se l'utente sia stato modificato nei suoi permessi.
Proprietà pubblica | Email | Restituisce o imposta l'indirizzo email dell'utente.
Proprietà pubblica | Groups | Restituisce una lista in sola lettura dei gruppi ai quali questo utente appartiene. Restituisce sempre una lista inizializzata.
Proprietà pubblica | GruppiAppartenenza | Restituisce l'elenco dei gruppo ai quali questo utente appartiene in formato stringa
Proprietà pubblica | IsGroup | Restituisce se si tratti di un gruppo (sempre false tranne nel caso di un gruppo). (Ereditato da DedPermOwner)
Proprietà pubblica | IsUser | Restituisce se si tratti di un utente (sempre false tranne nel caso di un utente). (Ereditato da DedPermOwner)
Proprietà pubblica | Manager | Restituisce il Gestore dei permessi. (Ereditato da DedPermOwner)
Proprietà pubblica | Name | Restituisce o imposta il nome dell'utente. (Sovrascrive DedPermOwnerName)
Proprietà pubblica | NameVis | Restituisce o imposta il nome visualizzato dell'utente.
Proprietà pubblica | PermItems | Restitusice il set di permessi di questo possessore. (Ereditato da DedPermOwner)
Proprietà pubblica | Pwd | Restituisce o imposta la password dell'utente.
Proprietà pubblica | Pws | Restituisce o imposta l'override della radice di root legato all'utente.
Proprietà pubblica | StatoRecord | Di uso interno.
Proprietà protetta | TableName | Restituisce il nome della table del Database. (Ereditato da DedPermOwner)
Proprietà pubblica | UseWin | Restituisce o imposta se utilizzare l'autenticazione di windows.
Torna su
Vedi anche

Documentazione

Classe DedUser
Namespace DedNet.Core


Proprietà DedUser.Corporate

Proprietà DedUserCorporate
Restituisce o imposta la corporate dell'utente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCorporate Corporate { get; set; }
Public Property Corporate As DedCorporate
    Get
    Set
public:
property DedCorporate^ Corporate {
    DedCorporate^ get ();
    void set (DedCorporate^ value);
}
member Corporate : DedCorporate with get, set

Valore della proprietà

DedCorporate
Vedi anche

Documentazione

Classe DedUser
Namespace DedNet.Core


Proprietà DedUser.Descr

Proprietà DedUserDescr
Restituisce o imposta la descrizione dell'utente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Descr { get; set; }
Public Property Descr As String
    Get
    Set
public:
property String^ Descr {
    String^ get ();
    void set (String^ value);
}
member Descr : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedUser
Namespace DedNet.Core


Proprietà DedUser.Dirty

Proprietà DedUserDirty
Restituisce se l'utente sia stato modificato nei suoi permessi.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Dirty { get; }
Public ReadOnly Property Dirty As Boolean
    Get
public:
property bool Dirty {
    bool get ();
}
member Dirty : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedUser
Namespace DedNet.Core


Proprietà DedUser.Email

Proprietà DedUserEmail
Restituisce o imposta l'indirizzo email dell'utente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Email { get; set; }
Public Property Email As String
    Get
    Set
public:
property String^ Email {
    String^ get ();
    void set (String^ value);
}
member Email : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedUser
Namespace DedNet.Core


Proprietà DedUser.Groups

Proprietà DedUserGroups
Restituisce una lista in sola lettura dei gruppi ai quali questo utente appartiene. Restituisce sempre una lista inizializzata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ReadOnlyCollection<DedGroup> Groups { get; }
Public ReadOnly Property Groups As ReadOnlyCollection(Of DedGroup)
    Get
public:
property ReadOnlyCollection<DedGroup^>^ Groups {
    ReadOnlyCollection<DedGroup^>^ get ();
}
member Groups : ReadOnlyCollection<DedGroup> with get

Valore della proprietà

ReadOnlyCollection DedGroup
Vedi anche

Documentazione

Classe DedUser
Namespace DedNet.Core


Proprietà DedUser.GruppiAppartenenza

Proprietà DedUserGruppiAppartenenza
Restituisce l'elenco dei gruppo ai quali questo utente appartiene in formato stringa

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string GruppiAppartenenza { get; }
Public ReadOnly Property GruppiAppartenenza As String
    Get
public:
property String^ GruppiAppartenenza {
    String^ get ();
}
member GruppiAppartenenza : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedUser
Namespace DedNet.Core


Proprietà DedUser.Name

Proprietà DedUserName
Restituisce o imposta il nome dell'utente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string Name { get; set; }
Public Overrides Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get () override;
    void set (String^ value) override;
}
abstract Name : string with get, set
override Name : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedUser
Namespace DedNet.Core


Proprietà DedUser.NameVis

Proprietà DedUserNameVis
Restituisce o imposta il nome visualizzato dell'utente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string NameVis { get; set; }
Public Property NameVis As String
    Get
    Set
public:
property String^ NameVis {
    String^ get ();
    void set (String^ value);
}
member NameVis : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedUser
Namespace DedNet.Core


Proprietà DedUser.Pwd

Proprietà DedUserPwd
Restituisce o imposta la password dell'utente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Pwd { get; set; }
Public Property Pwd As String
    Get
    Set
public:
property String^ Pwd {
    String^ get ();
    void set (String^ value);
}
member Pwd : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedUser
Namespace DedNet.Core


Proprietà DedUser.Pws

Proprietà DedUserPws
Restituisce o imposta l'override della radice di root legato all'utente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Pws { get; set; }
Public Property Pws As String
    Get
    Set
public:
property String^ Pws {
    String^ get ();
    void set (String^ value);
}
member Pws : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedUser
Namespace DedNet.Core


Proprietà DedUser.StatoRecord

Proprietà DedUserStatoRecord
Di uso interno.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public StatoRecord StatoRecord { get; set; }
Public Property StatoRecord As StatoRecord
    Get
    Set
public:
virtual property StatoRecord^ StatoRecord {
    StatoRecord^ get () sealed;
    void set (StatoRecord^ value) sealed;
}
abstract StatoRecord : StatoRecord with get, set
override StatoRecord : StatoRecord with get, set

Valore della proprietà

StatoRecord

Implementa

IDedDbItemStatoRecord
Vedi anche

Documentazione

Classe DedUser
Namespace DedNet.Core


Proprietà DedUser.UseWin

Proprietà DedUserUseWin
Restituisce o imposta se utilizzare l'autenticazione di windows.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool UseWin { get; set; }
Public Property UseWin As Boolean
    Get
    Set
public:
property bool UseWin {
    bool get ();
    void set (bool value);
}
member UseWin : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedUser
Namespace DedNet.Core


Metodi di DedUser

Il tipo DedUser espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AddGroup(DedGroup) | Aggiunge questo utente al gruppo passato.
Metodo pubblico | AddGroup(String) | Aggiunge questo utente al gruppo passato.
Metodo protetto | CreateDeleteCommand | (Sovrascrive DedPermOwnerCreateDeleteCommand(DedPerm))
Metodo protetto | CreateInsertCommand | (Sovrascrive DedPermOwnerCreateInsertCommand(DedPerm))
Metodo protetto | CreateUpdateCommand | (Sovrascrive DedPermOwnerCreateUpdateCommand(DedPerm))
Metodo protetto | GetDbIndex | (Sovrascrive DedPermOwnerGetDbIndex(DedPerm))
Metodo pubblico | GetPermDescription | Restituisce la descrizione del permesso. (Ereditato da DedPermOwner)
Metodo pubblico | GetPermVal(String, String) | Restituisce il valore del permesso. (Sovrascrive DedPermOwnerGetPermVal(String, String))
Metodo pubblico | GetPermVal(String, String, String) | Restituisce il valore del permesso impostando la stringa descrittiva il tipo di ereditarietà del permesso. (Sovrascrive DedPermOwnerGetPermVal(String, String, String))
Metodo pubblico | IsPermPresent | Restituisce se il permesso è presente in modo esplicito fra i permessi di questa instanza. (Ereditato da DedPermOwner)
Metodo pubblico | RemoveGroup(DedGroup) | Rimuove questo utente al gruppo passato.
Metodo pubblico | RemoveGroup(String) | Rimuove questo utente al gruppo passato.
Metodo pubblico | ResetGruppiAppartenenza | Azzero i gruppi di appartenenza così lo ricalcolo
Metodo pubblico | SetPermVal | Imposta il permesso ottenendo la stringa descrittiva del permesso. (Sovrascrive DedPermOwnerSetPermVal(String, String, Boolean))
Torna su
Vedi anche

Documentazione

Classe DedUser
Namespace DedNet.Core


Metodo DedUser.AddGroup

Metodo DedUserAddGroup
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AddGroup(DedGroup) | Aggiunge questo utente al gruppo passato.
Metodo pubblico | AddGroup(String) | Aggiunge questo utente al gruppo passato.
Torna su
Vedi anche

Documentazione

Classe DedUser
Namespace DedNet.Core


Metodo DedUser.AddGroup(DedGroup)

Metodo DedUserAddGroup(DedGroup)
Aggiunge questo utente al gruppo passato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddGroup(
    DedGroup gruppo
)
Public Sub AddGroup (
    gruppo As DedGroup
)
public:
void AddGroup(
    DedGroup^ gruppo
)
member AddGroup :
        gruppo : DedGroup -> unit

Parametri

gruppo DedGroup
Gruppo nel quale aggiungere la collezione.
Vedi anche

Documentazione

Classe DedUser
Overload di AddGroup
Namespace DedNet.Core


Metodo DedUser.AddGroup(String)

Metodo DedUserAddGroup(String)
Aggiunge questo utente al gruppo passato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddGroup(
    string groupName
)
Public Sub AddGroup (
    groupName As String
)
public:
void AddGroup(
    String^ groupName
)
member AddGroup :
        groupName : string -> unit

Parametri

groupName String
Gruppo nel quale aggiungere la collezione.
Vedi anche

Documentazione

Classe DedUser
Overload di AddGroup
Namespace DedNet.Core


Metodo DedUser.CreateDeleteCommand

Metodo DedUserCreateDeleteCommand

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal override QSDeleteCommand CreateDeleteCommand(
    DedPerm item
)
Protected Friend Overrides Function CreateDeleteCommand (
    item As DedPerm
) As QSDeleteCommand
protected public:
virtual QSDeleteCommand^ CreateDeleteCommand(
    DedPerm^ item
) override
abstract CreateDeleteCommand :
        item : DedPerm -> QSDeleteCommand
override CreateDeleteCommand :
        item : DedPerm -> QSDeleteCommand

Parametri

item DedPerm

Valore di ritorno

QSDeleteCommand
Vedi anche

Documentazione

Classe DedUser
Namespace DedNet.Core


Metodo DedUser.CreateInsertCommand

Metodo DedUserCreateInsertCommand

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal override QSInsertCommand CreateInsertCommand(
    DedPerm item
)
Protected Friend Overrides Function CreateInsertCommand (
    item As DedPerm
) As QSInsertCommand
protected public:
virtual QSInsertCommand^ CreateInsertCommand(
    DedPerm^ item
) override
abstract CreateInsertCommand :
        item : DedPerm -> QSInsertCommand
override CreateInsertCommand :
        item : DedPerm -> QSInsertCommand

Parametri

item DedPerm

Valore di ritorno

QSInsertCommand
Vedi anche

Documentazione

Classe DedUser
Namespace DedNet.Core


Metodo DedUser.CreateUpdateCommand

Metodo DedUserCreateUpdateCommand

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal override QSUpdateCommand CreateUpdateCommand(
    DedPerm item
)
Protected Friend Overrides Function CreateUpdateCommand (
    item As DedPerm
) As QSUpdateCommand
protected public:
virtual QSUpdateCommand^ CreateUpdateCommand(
    DedPerm^ item
) override
abstract CreateUpdateCommand :
        item : DedPerm -> QSUpdateCommand
override CreateUpdateCommand :
        item : DedPerm -> QSUpdateCommand

Parametri

item DedPerm

Valore di ritorno

QSUpdateCommand
Vedi anche

Documentazione

Classe DedUser
Namespace DedNet.Core


Metodo DedUser.GetDbIndex

Metodo DedUserGetDbIndex

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal override Object GetDbIndex(
    DedPerm item
)
Protected Friend Overrides Function GetDbIndex (
    item As DedPerm
) As Object
protected public:
virtual Object^ GetDbIndex(
    DedPerm^ item
) override
abstract GetDbIndex :
        item : DedPerm -> Object
override GetDbIndex :
        item : DedPerm -> Object

Parametri

item DedPerm

Valore di ritorno

Object
Vedi anche

Documentazione

Classe DedUser
Namespace DedNet.Core


Metodo DedUser.GetPermVal

Metodo DedUserGetPermVal
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | GetPermVal(String, String) | Restituisce il valore del permesso.
Metodo pubblico | GetPermVal(String, String, String) | Restituisce il valore del permesso impostando la stringa descrittiva il tipo di ereditarietà del permesso.
Torna su
Vedi anche

Documentazione

Classe DedUser
Namespace DedNet.Core


Metodo DedUser.GetPermVal(String, String)

Metodo DedUserGetPermVal(String, String)
Restituisce il valore del permesso.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool GetPermVal(
    string PermName,
    string discrim
)
Public Overrides Function GetPermVal (
    PermName As String,
    discrim As String
) As Boolean
public:
virtual bool GetPermVal(
    String^ PermName,
    String^ discrim
) override
abstract GetPermVal :
        PermName : string *
        discrim : string -> bool
override GetPermVal :
        PermName : string *
        discrim : string -> bool

Parametri

PermName String
discrim String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedUser
Overload di GetPermVal
Namespace DedNet.Core


Metodo DedUser.GetPermVal(String, String, String)

Metodo DedUserGetPermVal(String, String, String)
Restituisce il valore del permesso impostando la stringa descrittiva il tipo di ereditarietà del permesso.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool GetPermVal(
    string PermName,
    string discrim,
    out string PermDesc
)
Public Overrides Function GetPermVal (
    PermName As String,
    discrim As String,
    <OutAttribute> ByRef PermDesc As String
) As Boolean
public:
virtual bool GetPermVal(
    String^ PermName,
    String^ discrim,
    [OutAttribute] String^% PermDesc
) override
abstract GetPermVal :
        PermName : string *
        discrim : string *
        PermDesc : string byref -> bool
override GetPermVal :
        PermName : string *
        discrim : string *
        PermDesc : string byref -> bool

Parametri

PermName String
discrim String
PermDesc String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedUser
Overload di GetPermVal
Namespace DedNet.Core


Metodo DedUser.RemoveGroup

Metodo DedUserRemoveGroup
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | RemoveGroup(DedGroup) | Rimuove questo utente al gruppo passato.
Metodo pubblico | RemoveGroup(String) | Rimuove questo utente al gruppo passato.
Torna su
Vedi anche

Documentazione

Classe DedUser
Namespace DedNet.Core


Metodo DedUser.RemoveGroup(DedGroup)

Metodo DedUserRemoveGroup(DedGroup)
Rimuove questo utente al gruppo passato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void RemoveGroup(
    DedGroup gruppo
)
Public Sub RemoveGroup (
    gruppo As DedGroup
)
public:
void RemoveGroup(
    DedGroup^ gruppo
)
member RemoveGroup :
        gruppo : DedGroup -> unit

Parametri

gruppo DedGroup
Gruppo dal quale rimuovere la collezione.
Vedi anche

Documentazione

Classe DedUser
Overload di RemoveGroup
Namespace DedNet.Core


Metodo DedUser.RemoveGroup(String)

Metodo DedUserRemoveGroup(String)
Rimuove questo utente al gruppo passato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void RemoveGroup(
    string groupName
)
Public Sub RemoveGroup (
    groupName As String
)
public:
void RemoveGroup(
    String^ groupName
)
member RemoveGroup :
        groupName : string -> unit

Parametri

groupName String
Gruppo dal quale rimuovere la collezione.
Vedi anche

Documentazione

Classe DedUser
Overload di RemoveGroup
Namespace DedNet.Core


Metodo DedUser.ResetGruppiAppartenenza

Metodo DedUserResetGruppiAppartenenza
Azzero i gruppi di appartenenza così lo ricalcolo

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ResetGruppiAppartenenza()
Public Sub ResetGruppiAppartenenza
public:
void ResetGruppiAppartenenza()
member ResetGruppiAppartenenza : unit -> unit
Vedi anche

Documentazione

Classe DedUser
Namespace DedNet.Core


Metodo DedUser.SetPermVal

Metodo DedUserSetPermVal
Imposta il permesso ottenendo la stringa descrittiva del permesso.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string SetPermVal(
    string PermName,
    string discrim,
    bool Valore
)
Public Overrides Function SetPermVal (
    PermName As String,
    discrim As String,
    Valore As Boolean
) As String
public:
virtual String^ SetPermVal(
    String^ PermName,
    String^ discrim,
    bool Valore
) override
abstract SetPermVal :
        PermName : string *
        discrim : string *
        Valore : bool -> string
override SetPermVal :
        PermName : string *
        discrim : string *
        Valore : bool -> string

Parametri

PermName String
discrim String
Valore Boolean

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedUser
Namespace DedNet.Core


Classe DedUserCollection
Collezione di oggetti DedUser.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedDbCollectionBase DedUser
DedNet.CoreDedUserCollection

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedUserCollection : DedDbCollectionBase<DedUser>
Public Class DedUserCollection
    Inherits DedDbCollectionBase(Of DedUser)
public ref class DedUserCollection : public DedDbCollectionBase<DedUser^>
type DedUserCollection =
    class
        inherit DedDbCollectionBase<DedUser>
    end

Il tipo DedUserCollection espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllowsDuplicates | Restituisce se siano ammessi duplicati all'interno della lista. Se false viene sollevata una eccezione su tentativo di inserimento duplicati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Application | Restituisce l'oggetto applicazione di appartenza. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Count | Restituisce il numero di elementi presenti. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Dirty | Restituisce se la collezione o uno dei suoi elementi sia stata modificata. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | ErasedItems | Restitusice la lista in sola lettura degli elementi che risultano attualmente cancellati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | LastItem | Restituisce l'ultimo elemento della collezione oppure null se non ci sono elementi. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | RestoreErased | Restituisce se gli elementi cancellati devono essere ripristinati in caso vengano riaggiunti. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | UserNames |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Add | Aggiunge un elemento accodandolo alla lista.
Metodo protetto | AddForClone | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto SENZA MODIFICARNE LO STATO. Le classi derivate potranno utilizzare questo metodo per clonare la collezione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddNewElement | DI USO INTERNO. Aggiunge un elemento alla lista rendendo dirty l'oggetto. L'elemento viene aggiunto con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere un elemento alla lista. Dovranno loro stesse avere un metodo pubblico Add() che prenda i parametri necessari alla costruzione dell'oggetto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddRangeNewElement | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi rendendo dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere più elementi alla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddUnModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Clear | Elimina tutti gli elementi dalla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ClearRefresh | Svuota la lista impostando Dirty = false. Di fatto permette di effettuare un refresh della lista e quindi di ricaricarla. Serve per svuotare la lista e reinizializzarla da capo. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Contains | Verifica l'esistenza di un valore all'interno della lista degli elementi. Le classi derivate devono effettuarne l'override nel caso in cui l'elemento non implementi GetHashCode() per l'uso all'interno dei dizionarii. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | CopyTo | Copia un range di elementi in un array. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | CreateDeleteCommand | (Sovrascrive DedDbCollectionBaseTCreateDeleteCommand(T))
Metodo protetto | CreateInsertCommand | (Sovrascrive DedDbCollectionBaseTCreateInsertCommand(T))
Metodo protetto | CreateUpdateCommand | (Sovrascrive DedDbCollectionBaseTCreateUpdateCommand(T))
Metodo pubblico | CustomSort | Ordina la lista in base al comparatore passato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteDeleteItem | Esegue l'eliminazione di un elemento. Crea il comando tramite il metodo CreateDeleteCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteInsertItem | Esegue l'inserimento di un elemento. Crea il comando tramite il metodo CreateInsertCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteUpdateItem | Esegue l'aggiornamento di un elemento. Crea il comando tramite il metodo CreateUpdateCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Find | Restituisce l'oggetto cercato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FindAll | Restitusice la lista degli elementi che corrispondono al predicato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FindByEmail | Restituisce l'utente tramite l'email. Restituisce null se l'utente non è presente.
Metodo pubblico | FindByName | Restituisce l'utente tramite il nome interno. Restituisce null se l'utente non è presente.
Metodo pubblico | FindByNameVis | Restituisce l'utente tramite il nome visualizzato. Restituisce null se l'utente non è presente.
Metodo protetto | GetDbIndex | (Sovrascrive DedDbCollectionBaseTGetDbIndex(T))
Metodo pubblico | GetEnumerator | Restituisce l'enumeratore della collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | IndexOf | Restituisce l'indice dell'elemento richiesto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InsertUnModified | DI USO INTERNO. Inserisce un elemento alla lista senza rendere dirty l'oggetto, all'indice specificato. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Item | Restituisce l'elemento iesimo della lista. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean) | Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean, Int32) | Sposta l'elemento dell'indice passato prima o dopo del numero di posizioni passate. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSave | (Sovrascrive DedDbCollectionBaseTOnAfterSave(ListT, ListT, ListT))
Metodo protetto | OnAfterSaveNoChanges | Metodo Template chiamato dopo il salvataggio senza modifiche. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnBeforeSave | Metodo Template chiamato prima del salvataggio. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(T) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(DedEditableObjectT) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(T) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(DedEditableObjectT) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ReInitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Remove | Elimina un utente dalla collezione. (Sovrascrive DedDbCollectionBaseTRemove(T))
Metodo pubblico | Ripristina | Verifica che l'elemento sia presente negli eliminati e lo toglie da lì e lo riaggiunge in coda alla lista degli elementi validi. Solleva una eccezione se l'elemento è già presente nella lista e AllowsDuplicates = false. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Save | Salva l'oggetto con tutta la sua lista, solo se questo risulta dirty. (Ereditato da DedDbCollectionBaseT)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di DedUserCollection

Il tipo DedUserCollection espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllowsDuplicates | Restituisce se siano ammessi duplicati all'interno della lista. Se false viene sollevata una eccezione su tentativo di inserimento duplicati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Application | Restituisce l'oggetto applicazione di appartenza. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Count | Restituisce il numero di elementi presenti. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Dirty | Restituisce se la collezione o uno dei suoi elementi sia stata modificata. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | ErasedItems | Restitusice la lista in sola lettura degli elementi che risultano attualmente cancellati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | LastItem | Restituisce l'ultimo elemento della collezione oppure null se non ci sono elementi. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | RestoreErased | Restituisce se gli elementi cancellati devono essere ripristinati in caso vengano riaggiunti. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | UserNames |
Torna su
Vedi anche

Documentazione

Classe DedUserCollection
Namespace DedNet.Core


Proprietà DedUserCollection.UserNames

Proprietà DedUserCollectionUserNames

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> UserNames { get; }
Public ReadOnly Property UserNames As List(Of String)
    Get
public:
property List<String^>^ UserNames {
    List<String^>^ get ();
}
member UserNames : List<string> with get

Valore della proprietà

List String
Vedi anche

Documentazione

Classe DedUserCollection
Namespace DedNet.Core


Metodi di DedUserCollection

Il tipo DedUserCollection espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Add | Aggiunge un elemento accodandolo alla lista.
Metodo protetto | AddForClone | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto SENZA MODIFICARNE LO STATO. Le classi derivate potranno utilizzare questo metodo per clonare la collezione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddNewElement | DI USO INTERNO. Aggiunge un elemento alla lista rendendo dirty l'oggetto. L'elemento viene aggiunto con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere un elemento alla lista. Dovranno loro stesse avere un metodo pubblico Add() che prenda i parametri necessari alla costruzione dell'oggetto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddRangeNewElement | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi rendendo dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere più elementi alla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddUnModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Clear | Elimina tutti gli elementi dalla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ClearRefresh | Svuota la lista impostando Dirty = false. Di fatto permette di effettuare un refresh della lista e quindi di ricaricarla. Serve per svuotare la lista e reinizializzarla da capo. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Contains | Verifica l'esistenza di un valore all'interno della lista degli elementi. Le classi derivate devono effettuarne l'override nel caso in cui l'elemento non implementi GetHashCode() per l'uso all'interno dei dizionarii. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | CopyTo | Copia un range di elementi in un array. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | CreateDeleteCommand | (Sovrascrive DedDbCollectionBaseTCreateDeleteCommand(T))
Metodo protetto | CreateInsertCommand | (Sovrascrive DedDbCollectionBaseTCreateInsertCommand(T))
Metodo protetto | CreateUpdateCommand | (Sovrascrive DedDbCollectionBaseTCreateUpdateCommand(T))
Metodo pubblico | CustomSort | Ordina la lista in base al comparatore passato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteDeleteItem | Esegue l'eliminazione di un elemento. Crea il comando tramite il metodo CreateDeleteCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteInsertItem | Esegue l'inserimento di un elemento. Crea il comando tramite il metodo CreateInsertCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteUpdateItem | Esegue l'aggiornamento di un elemento. Crea il comando tramite il metodo CreateUpdateCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Find | Restituisce l'oggetto cercato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FindAll | Restitusice la lista degli elementi che corrispondono al predicato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FindByEmail | Restituisce l'utente tramite l'email. Restituisce null se l'utente non è presente.
Metodo pubblico | FindByName | Restituisce l'utente tramite il nome interno. Restituisce null se l'utente non è presente.
Metodo pubblico | FindByNameVis | Restituisce l'utente tramite il nome visualizzato. Restituisce null se l'utente non è presente.
Metodo protetto | GetDbIndex | (Sovrascrive DedDbCollectionBaseTGetDbIndex(T))
Metodo pubblico | GetEnumerator | Restituisce l'enumeratore della collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | IndexOf | Restituisce l'indice dell'elemento richiesto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InsertUnModified | DI USO INTERNO. Inserisce un elemento alla lista senza rendere dirty l'oggetto, all'indice specificato. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Item | Restituisce l'elemento iesimo della lista. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean) | Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean, Int32) | Sposta l'elemento dell'indice passato prima o dopo del numero di posizioni passate. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSave | (Sovrascrive DedDbCollectionBaseTOnAfterSave(ListT, ListT, ListT))
Metodo protetto | OnAfterSaveNoChanges | Metodo Template chiamato dopo il salvataggio senza modifiche. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnBeforeSave | Metodo Template chiamato prima del salvataggio. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(T) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(DedEditableObjectT) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(T) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(DedEditableObjectT) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ReInitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Remove | Elimina un utente dalla collezione. (Sovrascrive DedDbCollectionBaseTRemove(T))
Metodo pubblico | Ripristina | Verifica che l'elemento sia presente negli eliminati e lo toglie da lì e lo riaggiunge in coda alla lista degli elementi validi. Solleva una eccezione se l'elemento è già presente nella lista e AllowsDuplicates = false. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Save | Salva l'oggetto con tutta la sua lista, solo se questo risulta dirty. (Ereditato da DedDbCollectionBaseT)
Torna su
Vedi anche

Documentazione

Classe DedUserCollection
Namespace DedNet.Core


Metodo DedUserCollection.Add

Metodo DedUserCollectionAdd
Aggiunge un elemento accodandolo alla lista.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedUser Add(
    string name,
    string descr,
    string pwd,
    string nameVis,
    bool useWin,
    DedCorporate corporate,
    string email,
    string pws
)
Public Function Add (
    name As String,
    descr As String,
    pwd As String,
    nameVis As String,
    useWin As Boolean,
    corporate As DedCorporate,
    email As String,
    pws As String
) As DedUser
public:
DedUser^ Add(
    String^ name,
    String^ descr,
    String^ pwd,
    String^ nameVis,
    bool useWin,
    DedCorporate^ corporate,
    String^ email,
    String^ pws
)
member Add :
        name : string *
        descr : string *
        pwd : string *
        nameVis : string *
        useWin : bool *
        corporate : DedCorporate *
        email : string *
        pws : string -> DedUser

Parametri

name String
Nome.
descr String
Descrizione.
pwd String
Password.
nameVis String
Nome visualizzato.
useWin Boolean
Se usare i permessi di Windows.
corporate DedCorporate
Nome della corporate dell'utente.
email String
Indirizzo e-mail.
pws String
Override della radice di pws

Valore di ritorno

DedUser
Restituisce l'elemento appena aggiunto.
Vedi anche

Documentazione

Classe DedUserCollection
Namespace DedNet.Core


Metodo DedUserCollection.CreateDeleteCommand

Metodo DedUserCollectionCreateDeleteCommand

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSDeleteCommand CreateDeleteCommand(
    DedUser item
)
Protected Overrides Function CreateDeleteCommand (
    item As DedUser
) As QSDeleteCommand
protected:
virtual QSDeleteCommand^ CreateDeleteCommand(
    DedUser^ item
) override
abstract CreateDeleteCommand :
        item : DedUser -> QSDeleteCommand
override CreateDeleteCommand :
        item : DedUser -> QSDeleteCommand

Parametri

item DedUser

Valore di ritorno

QSDeleteCommand
Vedi anche

Documentazione

Classe DedUserCollection
Namespace DedNet.Core


Metodo DedUserCollection.CreateInsertCommand

Metodo DedUserCollectionCreateInsertCommand

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSInsertCommand CreateInsertCommand(
    DedUser item
)
Protected Overrides Function CreateInsertCommand (
    item As DedUser
) As QSInsertCommand
protected:
virtual QSInsertCommand^ CreateInsertCommand(
    DedUser^ item
) override
abstract CreateInsertCommand :
        item : DedUser -> QSInsertCommand
override CreateInsertCommand :
        item : DedUser -> QSInsertCommand

Parametri

item DedUser

Valore di ritorno

QSInsertCommand
Vedi anche

Documentazione

Classe DedUserCollection
Namespace DedNet.Core


Metodo DedUserCollection.CreateUpdateCommand

Metodo DedUserCollectionCreateUpdateCommand

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSUpdateCommand CreateUpdateCommand(
    DedUser item
)
Protected Overrides Function CreateUpdateCommand (
    item As DedUser
) As QSUpdateCommand
protected:
virtual QSUpdateCommand^ CreateUpdateCommand(
    DedUser^ item
) override
abstract CreateUpdateCommand :
        item : DedUser -> QSUpdateCommand
override CreateUpdateCommand :
        item : DedUser -> QSUpdateCommand

Parametri

item DedUser

Valore di ritorno

QSUpdateCommand
Vedi anche

Documentazione

Classe DedUserCollection
Namespace DedNet.Core


Metodo DedUserCollection.FindByEmail

Metodo DedUserCollectionFindByEmail
Restituisce l'utente tramite l'email. Restituisce null se l'utente non è presente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedUser FindByEmail(
    string email
)
Public Function FindByEmail (
    email As String
) As DedUser
public:
DedUser^ FindByEmail(
    String^ email
)
member FindByEmail :
        email : string -> DedUser

Parametri

email String
Email dell'utente da cercare.

Valore di ritorno

DedUser
Vedi anche

Documentazione

Classe DedUserCollection
Namespace DedNet.Core


Metodo DedUserCollection.FindByName

Metodo DedUserCollectionFindByName
Restituisce l'utente tramite il nome interno. Restituisce null se l'utente non è presente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedUser FindByName(
    string name
)
Public Function FindByName (
    name As String
) As DedUser
public:
DedUser^ FindByName(
    String^ name
)
member FindByName :
        name : string -> DedUser

Parametri

name String
Nome interno dell'utente da cercare.

Valore di ritorno

DedUser
Vedi anche

Documentazione

Classe DedUserCollection
Namespace DedNet.Core


Metodo DedUserCollection.FindByNameVis

Metodo DedUserCollectionFindByNameVis
Restituisce l'utente tramite il nome visualizzato. Restituisce null se l'utente non è presente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedUser FindByNameVis(
    string nameVis
)
Public Function FindByNameVis (
    nameVis As String
) As DedUser
public:
DedUser^ FindByNameVis(
    String^ nameVis
)
member FindByNameVis :
        nameVis : string -> DedUser

Parametri

nameVis String
Nome visualizzato dell'utente da cercare.

Valore di ritorno

DedUser
Vedi anche

Documentazione

Classe DedUserCollection
Namespace DedNet.Core


Metodo DedUserCollection.GetDbIndex

Metodo DedUserCollectionGetDbIndex

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override Object GetDbIndex(
    DedUser item
)
Protected Overrides Function GetDbIndex (
    item As DedUser
) As Object
protected:
virtual Object^ GetDbIndex(
    DedUser^ item
) override
abstract GetDbIndex :
        item : DedUser -> Object
override GetDbIndex :
        item : DedUser -> Object

Parametri

item DedUser

Valore di ritorno

Object
Vedi anche

Documentazione

Classe DedUserCollection
Namespace DedNet.Core


Metodo DedUserCollection.OnAfterSave

Metodo DedUserCollectionOnAfterSave

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void OnAfterSave(
    List<DedUser> eliminati,
    List<DedUser> modificati,
    List<DedUser> aggiunti
)
Protected Overrides Sub OnAfterSave (
    eliminati As List(Of DedUser),
    modificati As List(Of DedUser),
    aggiunti As List(Of DedUser)
)
protected:
virtual void OnAfterSave(
    List<DedUser^>^ eliminati,
    List<DedUser^>^ modificati,
    List<DedUser^>^ aggiunti
) override
abstract OnAfterSave :
        eliminati : List<DedUser> *
        modificati : List<DedUser> *
        aggiunti : List<DedUser> -> unit
override OnAfterSave :
        eliminati : List<DedUser> *
        modificati : List<DedUser> *
        aggiunti : List<DedUser> -> unit

Parametri

eliminati List DedUser
modificati List DedUser
aggiunti List DedUser
Vedi anche

Documentazione

Classe DedUserCollection
Namespace DedNet.Core


Metodo DedUserCollection.Remove

Metodo DedUserCollectionRemove
Elimina un utente dalla collezione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void Remove(
    DedUser item
)
Public Overrides Sub Remove (
    item As DedUser
)
public:
virtual void Remove(
    DedUser^ item
) override
abstract Remove :
        item : DedUser -> unit
override Remove :
        item : DedUser -> unit

Parametri

item DedUser
Utente da eliminare.
Vedi anche

Documentazione

Classe DedUserCollection
Namespace DedNet.Core


Classe DedUserList
Oggetto rappresentante una lista utente.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedUserList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedUserList : IDedDbItem
Public Class DedUserList
    Implements IDedDbItem
public ref class DedUserList : IDedDbItem
type DedUserList =
    class
        interface IDedDbItem
    end

Il tipo DedUserList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedUserList | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | ElaborationDate | Data di elaborazione
Proprietà pubblica | ElaborationUser | Utente di elaborazione
Proprietà pubblica | ExtraData | Dati aggiuntivi della lista
Proprietà pubblica | Id | Identificativo univoco
Proprietà pubblica | ItemCollection | Elementi della lista
Proprietà pubblica | List | Tipologia di lista
Proprietà pubblica | Name | Nome della lista
Proprietà pubblica | Parent | Restituisce la collezione di appartenenza dell'elemento.
Proprietà pubblica | StatoRecord | Stato del record
Proprietà pubblica | User | Utente
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Calculate | Effettua i calcoli di tutti gli elementi presenti il lista.
Metodo pubblico | NotifyDirty | Notifica l'avvenuta modifica di una proprietà.
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedUserList
Costruttore

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedUserList(
    DedUserListCollection parent,
    Guid id,
    string name,
    string user,
    DedList list,
    string extraData,
    DateTime? elaborationDate,
    string elaborationUser
)
Public Sub New (
    parent As DedUserListCollection,
    id As Guid,
    name As String,
    user As String,
    list As DedList,
    extraData As String,
    elaborationDate As DateTime?,
    elaborationUser As String
)
public:
DedUserList(
    DedUserListCollection^ parent,
    Guid id,
    String^ name,
    String^ user,
    DedList^ list,
    String^ extraData,
    Nullable<DateTime> elaborationDate,
    String^ elaborationUser
)
new :
        parent : DedUserListCollection *
        id : Guid *
        name : string *
        user : string *
        list : DedList *
        extraData : string *
        elaborationDate : Nullable<DateTime> *
        elaborationUser : string -> DedUserList

Parametri

parent DedUserListCollection
Lista di appartenenza
id Guid
Identificativo univico
name String
Nome della lista
user String
Utente
list DedList
Lista
extraData String
Dati aggiuntivi
elaborationDate Nullable DateTime
Data di elaborazione
elaborationUser String
Utente di elaborazione
Vedi anche

Documentazione

Classe DedUserList
Namespace DedNet.Core


Proprietà di DedUserList

Il tipo DedUserList espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | ElaborationDate | Data di elaborazione
Proprietà pubblica | ElaborationUser | Utente di elaborazione
Proprietà pubblica | ExtraData | Dati aggiuntivi della lista
Proprietà pubblica | Id | Identificativo univoco
Proprietà pubblica | ItemCollection | Elementi della lista
Proprietà pubblica | List | Tipologia di lista
Proprietà pubblica | Name | Nome della lista
Proprietà pubblica | Parent | Restituisce la collezione di appartenenza dell'elemento.
Proprietà pubblica | StatoRecord | Stato del record
Proprietà pubblica | User | Utente
Torna su
Vedi anche

Documentazione

Classe DedUserList
Namespace DedNet.Core


Proprietà DedUserList.ElaborationDate

Proprietà DedUserListElaborationDate
Data di elaborazione

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DateTime? ElaborationDate { get; set; }
Public Property ElaborationDate As DateTime?
    Get
    Set
public:
property Nullable<DateTime> ElaborationDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
member ElaborationDate : Nullable<DateTime> with get, set

Valore della proprietà

Nullable DateTime
Vedi anche

Documentazione

Classe DedUserList
Namespace DedNet.Core


Proprietà DedUserList.ElaborationUser

Proprietà DedUserListElaborationUser
Utente di elaborazione

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string ElaborationUser { get; set; }
Public Property ElaborationUser As String
    Get
    Set
public:
property String^ ElaborationUser {
    String^ get ();
    void set (String^ value);
}
member ElaborationUser : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedUserList
Namespace DedNet.Core


Proprietà DedUserList.ExtraData

Proprietà DedUserListExtraData
Dati aggiuntivi della lista

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ExtraDataList ExtraData { get; set; }
Public Property ExtraData As ExtraDataList
    Get
    Set
public:
property ExtraDataList^ ExtraData {
    ExtraDataList^ get ();
    void set (ExtraDataList^ value);
}
member ExtraData : ExtraDataList with get, set

Valore della proprietà

ExtraDataList
Vedi anche

Documentazione

Classe DedUserList
Namespace DedNet.Core


Proprietà DedUserList.Id

Proprietà DedUserListId
Identificativo univoco

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Guid Id { get; set; }
Public Property Id As Guid
    Get
    Set
public:
property Guid Id {
    Guid get ();
    void set (Guid value);
}
member Id : Guid with get, set

Valore della proprietà

Guid
Vedi anche

Documentazione

Classe DedUserList
Namespace DedNet.Core


Proprietà DedUserList.ItemCollection

Proprietà DedUserListItemCollection
Elementi della lista

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedListItemCollection ItemCollection { get; set; }
Public Property ItemCollection As DedListItemCollection
    Get
    Set
public:
property DedListItemCollection^ ItemCollection {
    DedListItemCollection^ get ();
    void set (DedListItemCollection^ value);
}
member ItemCollection : DedListItemCollection with get, set

Valore della proprietà

DedListItemCollection
Vedi anche

Documentazione

Classe DedUserList
Namespace DedNet.Core


Proprietà DedUserList.List

Proprietà DedUserListList
Tipologia di lista

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedList List { get; set; }
Public Property List As DedList
    Get
    Set
public:
property DedList^ List {
    DedList^ get ();
    void set (DedList^ value);
}
member List : DedList with get, set

Valore della proprietà

DedList
Vedi anche

Documentazione

Classe DedUserList
Namespace DedNet.Core


Proprietà DedUserList.Name

Proprietà DedUserListName
Nome della lista

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedUserList
Namespace DedNet.Core


Proprietà DedUserList.Parent

Proprietà DedUserListParent
Restituisce la collezione di appartenenza dell'elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedUserListCollection Parent { get; set; }
Public Property Parent As DedUserListCollection
    Get
    Set
public:
property DedUserListCollection^ Parent {
    DedUserListCollection^ get ();
    void set (DedUserListCollection^ value);
}
member Parent : DedUserListCollection with get, set

Valore della proprietà

DedUserListCollection
Vedi anche

Documentazione

Classe DedUserList
Namespace DedNet.Core


Proprietà DedUserList.StatoRecord

Proprietà DedUserListStatoRecord
Stato del record

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public StatoRecord StatoRecord { get; set; }
Public Property StatoRecord As StatoRecord
    Get
    Set
public:
virtual property StatoRecord^ StatoRecord {
    StatoRecord^ get () sealed;
    void set (StatoRecord^ value) sealed;
}
abstract StatoRecord : StatoRecord with get, set
override StatoRecord : StatoRecord with get, set

Valore della proprietà

StatoRecord

Implementa

IDedDbItemStatoRecord
Vedi anche

Documentazione

Classe DedUserList
Namespace DedNet.Core


Proprietà DedUserList.User

Proprietà DedUserListUser
Utente

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string User { get; set; }
Public Property User As String
    Get
    Set
public:
property String^ User {
    String^ get ();
    void set (String^ value);
}
member User : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedUserList
Namespace DedNet.Core


Metodi di DedUserList

Il tipo DedUserList espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Calculate | Effettua i calcoli di tutti gli elementi presenti il lista.
Metodo pubblico | NotifyDirty | Notifica l'avvenuta modifica di una proprietà.
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Torna su
Vedi anche

Documentazione

Classe DedUserList
Namespace DedNet.Core


Metodo DedUserList.Calculate

Metodo DedUserListCalculate
Effettua i calcoli di tutti gli elementi presenti il lista.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ResultList Calculate()
Public Function Calculate As ResultList
public:
ResultList^ Calculate()
member Calculate : unit -> ResultList

Valore di ritorno

ResultList
Vedi anche

Documentazione

Classe DedUserList
Namespace DedNet.Core


Metodo DedUserList.NotifyDirty

Metodo DedUserListNotifyDirty
Notifica l'avvenuta modifica di una proprietà.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void NotifyDirty()
Public Sub NotifyDirty
public:
void NotifyDirty()
member NotifyDirty : unit -> unit
Vedi anche

Documentazione

Classe DedUserList
Namespace DedNet.Core


Metodo DedUserList.ToString

Metodo DedUserListToString

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedUserList
Namespace DedNet.Core


Classe DedUserListCollection
Collezione delle liste utente
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedDbCollectionBase DedUserList
DedNet.CoreDedUserListCollection

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedUserListCollection : DedDbCollectionBase<DedUserList>
Public Class DedUserListCollection
    Inherits DedDbCollectionBase(Of DedUserList)
public ref class DedUserListCollection : public DedDbCollectionBase<DedUserList^>
type DedUserListCollection =
    class
        inherit DedDbCollectionBase<DedUserList>
    end

Il tipo DedUserListCollection espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllowsDuplicates | Restituisce se siano ammessi duplicati all'interno della lista. Se false viene sollevata una eccezione su tentativo di inserimento duplicati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Application | Restituisce l'oggetto applicazione di appartenza. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Count | Restituisce il numero di elementi presenti. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Dirty | Restituisce se la collezione o uno dei suoi elementi sia stata modificata. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | ErasedItems | Restitusice la lista in sola lettura degli elementi che risultano attualmente cancellati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | LastItem | Restituisce l'ultimo elemento della collezione oppure null se non ci sono elementi. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | RestoreErased | Restituisce se gli elementi cancellati devono essere ripristinati in caso vengano riaggiunti. (Ereditato da DedDbCollectionBaseT)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | AddForClone | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto SENZA MODIFICARNE LO STATO. Le classi derivate potranno utilizzare questo metodo per clonare la collezione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddNewElement | DI USO INTERNO. Aggiunge un elemento alla lista rendendo dirty l'oggetto. L'elemento viene aggiunto con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere un elemento alla lista. Dovranno loro stesse avere un metodo pubblico Add() che prenda i parametri necessari alla costruzione dell'oggetto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddRangeNewElement | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi rendendo dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere più elementi alla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddUnModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Clear | Elimina tutti gli elementi dalla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ClearRefresh | Svuota la lista impostando Dirty = false. Di fatto permette di effettuare un refresh della lista e quindi di ricaricarla. Serve per svuotare la lista e reinizializzarla da capo. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Contains | Verifica l'esistenza di un valore all'interno della lista degli elementi. Le classi derivate devono effettuarne l'override nel caso in cui l'elemento non implementi GetHashCode() per l'uso all'interno dei dizionarii. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | CopyTo | Copia un range di elementi in un array. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | CreateDeleteCommand | Crea il comando di delete per un elemento. (Sovrascrive DedDbCollectionBaseTCreateDeleteCommand(T))
Metodo protetto | CreateInsertCommand | Crea il comando di insert per un elemento. (Sovrascrive DedDbCollectionBaseTCreateInsertCommand(T))
Metodo protetto | CreateUpdateCommand | Crea il comando di update per un elemento. (Sovrascrive DedDbCollectionBaseTCreateUpdateCommand(T))
Metodo pubblico | CustomSort | Ordina la lista in base al comparatore passato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteDeleteItem | Esegue l'eliminazione di un elemento. Crea il comando tramite il metodo CreateDeleteCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteInsertItem | Esegue l'inserimento di un elemento. Crea il comando tramite il metodo CreateInsertCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteUpdateItem | Esegue l'aggiornamento di un elemento. Crea il comando tramite il metodo CreateUpdateCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Find | Restituisce l'oggetto cercato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FindAll | Restitusice la lista degli elementi che corrispondono al predicato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | GetDbIndex | Restitusice l'indice di un elemento. (Sovrascrive DedDbCollectionBaseTGetDbIndex(T))
Metodo pubblico | GetEnumerator | Restituisce l'enumeratore della collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | IndexOf | Restituisce l'indice dell'elemento richiesto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InsertUnModified | DI USO INTERNO. Inserisce un elemento alla lista senza rendere dirty l'oggetto, all'indice specificato. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Item | Restituisce l'elemento iesimo della lista. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean) | Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean, Int32) | Sposta l'elemento dell'indice passato prima o dopo del numero di posizioni passate. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSave | (Sovrascrive DedDbCollectionBaseTOnAfterSave(ListT, ListT, ListT))
Metodo protetto | OnAfterSaveNoChanges | Metodo Template chiamato dopo il salvataggio senza modifiche. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnBeforeSave | Metodo Template chiamato prima del salvataggio. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(T) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(DedEditableObjectT) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(T) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(DedEditableObjectT) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ReInitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Remove | (Sovrascrive DedDbCollectionBaseTRemove(T))
Metodo pubblico | Ripristina | Verifica che l'elemento sia presente negli eliminati e lo toglie da lì e lo riaggiunge in coda alla lista degli elementi validi. Solleva una eccezione se l'elemento è già presente nella lista e AllowsDuplicates = false. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Save | Salva l'oggetto con tutta la sua lista, solo se questo risulta dirty. (Ereditato da DedDbCollectionBaseT)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di DedUserListCollection

Il tipo DedUserListCollection espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllowsDuplicates | Restituisce se siano ammessi duplicati all'interno della lista. Se false viene sollevata una eccezione su tentativo di inserimento duplicati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Application | Restituisce l'oggetto applicazione di appartenza. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Count | Restituisce il numero di elementi presenti. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Dirty | Restituisce se la collezione o uno dei suoi elementi sia stata modificata. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | ErasedItems | Restitusice la lista in sola lettura degli elementi che risultano attualmente cancellati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | LastItem | Restituisce l'ultimo elemento della collezione oppure null se non ci sono elementi. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | RestoreErased | Restituisce se gli elementi cancellati devono essere ripristinati in caso vengano riaggiunti. (Ereditato da DedDbCollectionBaseT)
Torna su
Vedi anche

Documentazione

Classe DedUserListCollection
Namespace DedNet.Core


Metodi di DedUserListCollection

Il tipo DedUserListCollection espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | AddForClone | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto SENZA MODIFICARNE LO STATO. Le classi derivate potranno utilizzare questo metodo per clonare la collezione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddNewElement | DI USO INTERNO. Aggiunge un elemento alla lista rendendo dirty l'oggetto. L'elemento viene aggiunto con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere un elemento alla lista. Dovranno loro stesse avere un metodo pubblico Add() che prenda i parametri necessari alla costruzione dell'oggetto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddRangeNewElement | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi rendendo dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere più elementi alla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddUnModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Clear | Elimina tutti gli elementi dalla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ClearRefresh | Svuota la lista impostando Dirty = false. Di fatto permette di effettuare un refresh della lista e quindi di ricaricarla. Serve per svuotare la lista e reinizializzarla da capo. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Contains | Verifica l'esistenza di un valore all'interno della lista degli elementi. Le classi derivate devono effettuarne l'override nel caso in cui l'elemento non implementi GetHashCode() per l'uso all'interno dei dizionarii. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | CopyTo | Copia un range di elementi in un array. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | CreateDeleteCommand | Crea il comando di delete per un elemento. (Sovrascrive DedDbCollectionBaseTCreateDeleteCommand(T))
Metodo protetto | CreateInsertCommand | Crea il comando di insert per un elemento. (Sovrascrive DedDbCollectionBaseTCreateInsertCommand(T))
Metodo protetto | CreateUpdateCommand | Crea il comando di update per un elemento. (Sovrascrive DedDbCollectionBaseTCreateUpdateCommand(T))
Metodo pubblico | CustomSort | Ordina la lista in base al comparatore passato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteDeleteItem | Esegue l'eliminazione di un elemento. Crea il comando tramite il metodo CreateDeleteCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteInsertItem | Esegue l'inserimento di un elemento. Crea il comando tramite il metodo CreateInsertCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteUpdateItem | Esegue l'aggiornamento di un elemento. Crea il comando tramite il metodo CreateUpdateCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Find | Restituisce l'oggetto cercato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FindAll | Restitusice la lista degli elementi che corrispondono al predicato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | GetDbIndex | Restitusice l'indice di un elemento. (Sovrascrive DedDbCollectionBaseTGetDbIndex(T))
Metodo pubblico | GetEnumerator | Restituisce l'enumeratore della collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | IndexOf | Restituisce l'indice dell'elemento richiesto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InsertUnModified | DI USO INTERNO. Inserisce un elemento alla lista senza rendere dirty l'oggetto, all'indice specificato. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Item | Restituisce l'elemento iesimo della lista. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean) | Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean, Int32) | Sposta l'elemento dell'indice passato prima o dopo del numero di posizioni passate. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSave | (Sovrascrive DedDbCollectionBaseTOnAfterSave(ListT, ListT, ListT))
Metodo protetto | OnAfterSaveNoChanges | Metodo Template chiamato dopo il salvataggio senza modifiche. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnBeforeSave | Metodo Template chiamato prima del salvataggio. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(T) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(DedEditableObjectT) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(T) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(DedEditableObjectT) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ReInitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Remove | (Sovrascrive DedDbCollectionBaseTRemove(T))
Metodo pubblico | Ripristina | Verifica che l'elemento sia presente negli eliminati e lo toglie da lì e lo riaggiunge in coda alla lista degli elementi validi. Solleva una eccezione se l'elemento è già presente nella lista e AllowsDuplicates = false. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Save | Salva l'oggetto con tutta la sua lista, solo se questo risulta dirty. (Ereditato da DedDbCollectionBaseT)
Torna su
Vedi anche

Documentazione

Classe DedUserListCollection
Namespace DedNet.Core


Metodo DedUserListCollection.CreateDeleteCommand

Metodo DedUserListCollectionCreateDeleteCommand
Crea il comando di delete per un elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSDeleteCommand CreateDeleteCommand(
    DedUserList item
)
Protected Overrides Function CreateDeleteCommand (
    item As DedUserList
) As QSDeleteCommand
protected:
virtual QSDeleteCommand^ CreateDeleteCommand(
    DedUserList^ item
) override
abstract CreateDeleteCommand :
        item : DedUserList -> QSDeleteCommand
override CreateDeleteCommand :
        item : DedUserList -> QSDeleteCommand

Parametri

item DedUserList
Elemento per il quale creare il comando.

Valore di ritorno

QSDeleteCommand
Vedi anche

Documentazione

Classe DedUserListCollection
Namespace DedNet.Core


Metodo DedUserListCollection.CreateInsertCommand

Metodo DedUserListCollectionCreateInsertCommand
Crea il comando di insert per un elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSInsertCommand CreateInsertCommand(
    DedUserList item
)
Protected Overrides Function CreateInsertCommand (
    item As DedUserList
) As QSInsertCommand
protected:
virtual QSInsertCommand^ CreateInsertCommand(
    DedUserList^ item
) override
abstract CreateInsertCommand :
        item : DedUserList -> QSInsertCommand
override CreateInsertCommand :
        item : DedUserList -> QSInsertCommand

Parametri

item DedUserList
Elemento per il quale creare il comando.

Valore di ritorno

QSInsertCommand
Vedi anche

Documentazione

Classe DedUserListCollection
Namespace DedNet.Core


Metodo DedUserListCollection.CreateUpdateCommand

Metodo DedUserListCollectionCreateUpdateCommand
Crea il comando di update per un elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSUpdateCommand CreateUpdateCommand(
    DedUserList item
)
Protected Overrides Function CreateUpdateCommand (
    item As DedUserList
) As QSUpdateCommand
protected:
virtual QSUpdateCommand^ CreateUpdateCommand(
    DedUserList^ item
) override
abstract CreateUpdateCommand :
        item : DedUserList -> QSUpdateCommand
override CreateUpdateCommand :
        item : DedUserList -> QSUpdateCommand

Parametri

item DedUserList
Elemento per il quale creare il comando.

Valore di ritorno

QSUpdateCommand
Vedi anche

Documentazione

Classe DedUserListCollection
Namespace DedNet.Core


Metodo DedUserListCollection.GetDbIndex

Metodo DedUserListCollectionGetDbIndex
Restitusice l'indice di un elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override Object GetDbIndex(
    DedUserList item
)
Protected Overrides Function GetDbIndex (
    item As DedUserList
) As Object
protected:
virtual Object^ GetDbIndex(
    DedUserList^ item
) override
abstract GetDbIndex :
        item : DedUserList -> Object
override GetDbIndex :
        item : DedUserList -> Object

Parametri

item DedUserList
Elemento per il quale restituire l'indice.

Valore di ritorno

Object
Vedi anche

Documentazione

Classe DedUserListCollection
Namespace DedNet.Core


Metodo DedUserListCollection.OnAfterSave

Metodo DedUserListCollectionOnAfterSave

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void OnAfterSave(
    List<DedUserList> eliminati,
    List<DedUserList> modificati,
    List<DedUserList> aggiunti
)
Protected Overrides Sub OnAfterSave (
    eliminati As List(Of DedUserList),
    modificati As List(Of DedUserList),
    aggiunti As List(Of DedUserList)
)
protected:
virtual void OnAfterSave(
    List<DedUserList^>^ eliminati,
    List<DedUserList^>^ modificati,
    List<DedUserList^>^ aggiunti
) override
abstract OnAfterSave :
        eliminati : List<DedUserList> *
        modificati : List<DedUserList> *
        aggiunti : List<DedUserList> -> unit
override OnAfterSave :
        eliminati : List<DedUserList> *
        modificati : List<DedUserList> *
        aggiunti : List<DedUserList> -> unit

Parametri

eliminati List DedUserList
modificati List DedUserList
aggiunti List DedUserList
Vedi anche

Documentazione

Classe DedUserListCollection
Namespace DedNet.Core


Metodo DedUserListCollection.Remove

Metodo DedUserListCollectionRemove

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void Remove(
    DedUserList list
)
Public Overrides Sub Remove (
    list As DedUserList
)
public:
virtual void Remove(
    DedUserList^ list
) override
abstract Remove :
        list : DedUserList -> unit
override Remove :
        list : DedUserList -> unit

Parametri

list DedUserList
Vedi anche

Documentazione

Classe DedUserListCollection
Namespace DedNet.Core


Classe DedUsersGroups
Gestisce i legami tra gli utenti ed il gruppo di appartenenza. Ogni gruppo contiene una istanza di questa classe. Gli utenti usano i metodi della collezione presa dai gruppi di appartenenza.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedDbCollectionBase DedUG
DedNet.CoreDedUsersGroups

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedUsersGroups : DedDbCollectionBase<DedUG>
Public Class DedUsersGroups
    Inherits DedDbCollectionBase(Of DedUG)
public ref class DedUsersGroups : public DedDbCollectionBase<DedUG^>
type DedUsersGroups =
    class
        inherit DedDbCollectionBase<DedUG>
    end

Il tipo DedUsersGroups espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllowsDuplicates | Restituisce se siano ammessi duplicati all'interno della lista. Se false viene sollevata una eccezione su tentativo di inserimento duplicati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Application | Restituisce l'oggetto applicazione di appartenza. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Count | Restituisce il numero di elementi presenti. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Dirty | Restituisce se la collezione o uno dei suoi elementi sia stata modificata. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | ErasedItems | Restitusice la lista in sola lettura degli elementi che risultano attualmente cancellati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | LastItem | Restituisce l'ultimo elemento della collezione oppure null se non ci sono elementi. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | RestoreErased | Restituisce se gli elementi cancellati devono essere ripristinati in caso vengano riaggiunti. (Ereditato da DedDbCollectionBaseT)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Add(DedUser) | Aggiunge e restituisce un nuovo legame utente-gruppo.
Metodo pubblico | Add(String) | Aggiunge e restituisce un nuovo legame utente-gruppo.
Metodo protetto | AddForClone | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto SENZA MODIFICARNE LO STATO. Le classi derivate potranno utilizzare questo metodo per clonare la collezione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddNewElement | DI USO INTERNO. Aggiunge un elemento alla lista rendendo dirty l'oggetto. L'elemento viene aggiunto con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere un elemento alla lista. Dovranno loro stesse avere un metodo pubblico Add() che prenda i parametri necessari alla costruzione dell'oggetto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddRangeNewElement | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi rendendo dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere più elementi alla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddUnModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Clear | Elimina tutti gli elementi dalla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ClearRefresh | Svuota la lista impostando Dirty = false. Di fatto permette di effettuare un refresh della lista e quindi di ricaricarla. Serve per svuotare la lista e reinizializzarla da capo. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Contains | Verifica l'esistenza di un valore all'interno della lista degli elementi. Le classi derivate devono effettuarne l'override nel caso in cui l'elemento non implementi GetHashCode() per l'uso all'interno dei dizionarii. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | CopyTo | Copia un range di elementi in un array. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | CreateDeleteCommand | (Sovrascrive DedDbCollectionBaseTCreateDeleteCommand(T))
Metodo protetto | CreateInsertCommand | (Sovrascrive DedDbCollectionBaseTCreateInsertCommand(T))
Metodo protetto | CreateUpdateCommand | (Sovrascrive DedDbCollectionBaseTCreateUpdateCommand(T))
Metodo pubblico | CustomSort | Ordina la lista in base al comparatore passato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteDeleteItem | Esegue l'eliminazione di un elemento. Crea il comando tramite il metodo CreateDeleteCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteInsertItem | Esegue l'inserimento di un elemento. Crea il comando tramite il metodo CreateInsertCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteUpdateItem | Esegue l'aggiornamento di un elemento. Crea il comando tramite il metodo CreateUpdateCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Find | Restituisce l'oggetto cercato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FindAll | Restitusice la lista degli elementi che corrispondono al predicato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FindByUser | Restituisce l'elemento in base all'utente.
Metodo pubblico | FindByUserName | Restituisce l'elemento in base al nome utente.
Metodo protetto | GetDbIndex | (Sovrascrive DedDbCollectionBaseTGetDbIndex(T))
Metodo pubblico | GetEnumerator | Restituisce l'enumeratore della collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | IndexOf | Restituisce l'indice dell'elemento richiesto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InsertUnModified | DI USO INTERNO. Inserisce un elemento alla lista senza rendere dirty l'oggetto, all'indice specificato. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Item | Restituisce l'elemento iesimo della lista. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean) | Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean, Int32) | Sposta l'elemento dell'indice passato prima o dopo del numero di posizioni passate. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSave | Metodo Template chiamato dopo il salvataggio avvenuto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSaveNoChanges | Metodo Template chiamato dopo il salvataggio senza modifiche. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnBeforeSave | Metodo Template chiamato prima del salvataggio. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(T) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(DedEditableObjectT) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(T) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(DedEditableObjectT) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ReInitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Remove | Elimina un elemento dalla collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Ripristina | Verifica che l'elemento sia presente negli eliminati e lo toglie da lì e lo riaggiunge in coda alla lista degli elementi validi. Solleva una eccezione se l'elemento è già presente nella lista e AllowsDuplicates = false. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Save | Salva l'oggetto con tutta la sua lista, solo se questo risulta dirty. (Ereditato da DedDbCollectionBaseT)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di DedUsersGroups

Il tipo DedUsersGroups espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllowsDuplicates | Restituisce se siano ammessi duplicati all'interno della lista. Se false viene sollevata una eccezione su tentativo di inserimento duplicati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Application | Restituisce l'oggetto applicazione di appartenza. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Count | Restituisce il numero di elementi presenti. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Dirty | Restituisce se la collezione o uno dei suoi elementi sia stata modificata. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | ErasedItems | Restitusice la lista in sola lettura degli elementi che risultano attualmente cancellati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | LastItem | Restituisce l'ultimo elemento della collezione oppure null se non ci sono elementi. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | RestoreErased | Restituisce se gli elementi cancellati devono essere ripristinati in caso vengano riaggiunti. (Ereditato da DedDbCollectionBaseT)
Torna su
Vedi anche

Documentazione

Classe DedUsersGroups
Namespace DedNet.Core


Metodi di DedUsersGroups

Il tipo DedUsersGroups espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Add(DedUser) | Aggiunge e restituisce un nuovo legame utente-gruppo.
Metodo pubblico | Add(String) | Aggiunge e restituisce un nuovo legame utente-gruppo.
Metodo protetto | AddForClone | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto SENZA MODIFICARNE LO STATO. Le classi derivate potranno utilizzare questo metodo per clonare la collezione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddNewElement | DI USO INTERNO. Aggiunge un elemento alla lista rendendo dirty l'oggetto. L'elemento viene aggiunto con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere un elemento alla lista. Dovranno loro stesse avere un metodo pubblico Add() che prenda i parametri necessari alla costruzione dell'oggetto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddRangeNewElement | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi rendendo dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere più elementi alla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddUnModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Clear | Elimina tutti gli elementi dalla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ClearRefresh | Svuota la lista impostando Dirty = false. Di fatto permette di effettuare un refresh della lista e quindi di ricaricarla. Serve per svuotare la lista e reinizializzarla da capo. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Contains | Verifica l'esistenza di un valore all'interno della lista degli elementi. Le classi derivate devono effettuarne l'override nel caso in cui l'elemento non implementi GetHashCode() per l'uso all'interno dei dizionarii. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | CopyTo | Copia un range di elementi in un array. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | CreateDeleteCommand | (Sovrascrive DedDbCollectionBaseTCreateDeleteCommand(T))
Metodo protetto | CreateInsertCommand | (Sovrascrive DedDbCollectionBaseTCreateInsertCommand(T))
Metodo protetto | CreateUpdateCommand | (Sovrascrive DedDbCollectionBaseTCreateUpdateCommand(T))
Metodo pubblico | CustomSort | Ordina la lista in base al comparatore passato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteDeleteItem | Esegue l'eliminazione di un elemento. Crea il comando tramite il metodo CreateDeleteCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteInsertItem | Esegue l'inserimento di un elemento. Crea il comando tramite il metodo CreateInsertCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteUpdateItem | Esegue l'aggiornamento di un elemento. Crea il comando tramite il metodo CreateUpdateCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Find | Restituisce l'oggetto cercato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FindAll | Restitusice la lista degli elementi che corrispondono al predicato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FindByUser | Restituisce l'elemento in base all'utente.
Metodo pubblico | FindByUserName | Restituisce l'elemento in base al nome utente.
Metodo protetto | GetDbIndex | (Sovrascrive DedDbCollectionBaseTGetDbIndex(T))
Metodo pubblico | GetEnumerator | Restituisce l'enumeratore della collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | IndexOf | Restituisce l'indice dell'elemento richiesto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InsertUnModified | DI USO INTERNO. Inserisce un elemento alla lista senza rendere dirty l'oggetto, all'indice specificato. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Item | Restituisce l'elemento iesimo della lista. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean) | Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean, Int32) | Sposta l'elemento dell'indice passato prima o dopo del numero di posizioni passate. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSave | Metodo Template chiamato dopo il salvataggio avvenuto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSaveNoChanges | Metodo Template chiamato dopo il salvataggio senza modifiche. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnBeforeSave | Metodo Template chiamato prima del salvataggio. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(T) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(DedEditableObjectT) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(T) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(DedEditableObjectT) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ReInitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Remove | Elimina un elemento dalla collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Ripristina | Verifica che l'elemento sia presente negli eliminati e lo toglie da lì e lo riaggiunge in coda alla lista degli elementi validi. Solleva una eccezione se l'elemento è già presente nella lista e AllowsDuplicates = false. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Save | Salva l'oggetto con tutta la sua lista, solo se questo risulta dirty. (Ereditato da DedDbCollectionBaseT)
Torna su
Vedi anche

Documentazione

Classe DedUsersGroups
Namespace DedNet.Core


Metodo DedUsersGroups.Add

Metodo DedUsersGroupsAdd
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Add(DedUser) | Aggiunge e restituisce un nuovo legame utente-gruppo.
Metodo pubblico | Add(String) | Aggiunge e restituisce un nuovo legame utente-gruppo.
Torna su
Vedi anche

Documentazione

Classe DedUsersGroups
Namespace DedNet.Core


Metodo DedUsersGroups.Add(DedUser)

Metodo DedUsersGroupsAdd(DedUser)
Aggiunge e restituisce un nuovo legame utente-gruppo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedUG Add(
    DedUser user
)
Public Function Add (
    user As DedUser
) As DedUG
public:
DedUG^ Add(
    DedUser^ user
)
member Add :
        user : DedUser -> DedUG

Parametri

user DedUser
Utente da aggiungere.

Valore di ritorno

DedUG
Vedi anche

Documentazione

Classe DedUsersGroups
Overload di Add
Namespace DedNet.Core


Metodo DedUsersGroups.Add(String)

Metodo DedUsersGroupsAdd(String)
Aggiunge e restituisce un nuovo legame utente-gruppo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedUG Add(
    string userName
)
Public Function Add (
    userName As String
) As DedUG
public:
DedUG^ Add(
    String^ userName
)
member Add :
        userName : string -> DedUG

Parametri

userName String
Nome dell'utente.

Valore di ritorno

DedUG
Vedi anche

Documentazione

Classe DedUsersGroups
Overload di Add
Namespace DedNet.Core


Metodo DedUsersGroups.CreateDeleteCommand

Metodo DedUsersGroupsCreateDeleteCommand

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSDeleteCommand CreateDeleteCommand(
    DedUG item
)
Protected Overrides Function CreateDeleteCommand (
    item As DedUG
) As QSDeleteCommand
protected:
virtual QSDeleteCommand^ CreateDeleteCommand(
    DedUG^ item
) override
abstract CreateDeleteCommand :
        item : DedUG -> QSDeleteCommand
override CreateDeleteCommand :
        item : DedUG -> QSDeleteCommand

Parametri

item DedUG

Valore di ritorno

QSDeleteCommand
Vedi anche

Documentazione

Classe DedUsersGroups
Namespace DedNet.Core


Metodo DedUsersGroups.CreateInsertCommand

Metodo DedUsersGroupsCreateInsertCommand

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSInsertCommand CreateInsertCommand(
    DedUG item
)
Protected Overrides Function CreateInsertCommand (
    item As DedUG
) As QSInsertCommand
protected:
virtual QSInsertCommand^ CreateInsertCommand(
    DedUG^ item
) override
abstract CreateInsertCommand :
        item : DedUG -> QSInsertCommand
override CreateInsertCommand :
        item : DedUG -> QSInsertCommand

Parametri

item DedUG

Valore di ritorno

QSInsertCommand
Vedi anche

Documentazione

Classe DedUsersGroups
Namespace DedNet.Core


Metodo DedUsersGroups.CreateUpdateCommand

Metodo DedUsersGroupsCreateUpdateCommand

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSUpdateCommand CreateUpdateCommand(
    DedUG item
)
Protected Overrides Function CreateUpdateCommand (
    item As DedUG
) As QSUpdateCommand
protected:
virtual QSUpdateCommand^ CreateUpdateCommand(
    DedUG^ item
) override
abstract CreateUpdateCommand :
        item : DedUG -> QSUpdateCommand
override CreateUpdateCommand :
        item : DedUG -> QSUpdateCommand

Parametri

item DedUG

Valore di ritorno

QSUpdateCommand
Vedi anche

Documentazione

Classe DedUsersGroups
Namespace DedNet.Core


Metodo DedUsersGroups.FindByUser

Metodo DedUsersGroupsFindByUser
Restituisce l'elemento in base all'utente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedUG FindByUser(
    DedUser user
)
Public Function FindByUser (
    user As DedUser
) As DedUG
public:
DedUG^ FindByUser(
    DedUser^ user
)
member FindByUser :
        user : DedUser -> DedUG

Parametri

user DedUser
Utente.

Valore di ritorno

DedUG
Restituisce l'elemento trovato oppure null.
Vedi anche

Documentazione

Classe DedUsersGroups
Namespace DedNet.Core


Metodo DedUsersGroups.FindByUserName

Metodo DedUsersGroupsFindByUserName
Restituisce l'elemento in base al nome utente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedUG FindByUserName(
    string userName
)
Public Function FindByUserName (
    userName As String
) As DedUG
public:
DedUG^ FindByUserName(
    String^ userName
)
member FindByUserName :
        userName : string -> DedUG

Parametri

userName String
Nome utente.

Valore di ritorno

DedUG
Restituisce l'elemento trovato oppure null.
Vedi anche

Documentazione

Classe DedUsersGroups
Namespace DedNet.Core


Metodo DedUsersGroups.GetDbIndex

Metodo DedUsersGroupsGetDbIndex

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override Object GetDbIndex(
    DedUG item
)
Protected Overrides Function GetDbIndex (
    item As DedUG
) As Object
protected:
virtual Object^ GetDbIndex(
    DedUG^ item
) override
abstract GetDbIndex :
        item : DedUG -> Object
override GetDbIndex :
        item : DedUG -> Object

Parametri

item DedUG

Valore di ritorno

Object
Vedi anche

Documentazione

Classe DedUsersGroups
Namespace DedNet.Core


Classe DedVar
Definizione del singolo oggetto DedVar.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedVar

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedVar : IDedDbItem
Public Class DedVar
    Implements IDedDbItem
public ref class DedVar : IDedDbItem
type DedVar =
    class
        interface IDedDbItem
    end

Il tipo DedVar espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Descrizione |
Proprietà pubblica | Gruppo |
Proprietà pubblica | Hidden |
Proprietà pubblica | Modificabile |
Proprietà pubblica | Nome |
Proprietà pubblica | StatoRecord | Restituisce o imposta lo stato del record.
Proprietà pubblica | Tipodato |
Proprietà pubblica | Valore |
Torna su
Metodi
 | Nome | Descrizione
 | AppClient2Name | Restituisce la stringa rappresentativa dell'applicazione client.
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetHashCode | Vengono riconosciuti uguali gli elementi che appartengono allo stesso gruppo e nome. (Sovrascrive ObjectGetHashCode)
 | Name2AppClient | Restituisce l'elemento dell'enumerazione rappresentativo dell'applicazione client.
 | TipoDatiToValue | In base alla rappresentazione stringa del tipo dati elabora il valore e lo restituisce nel tipo dati correntto.
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
 | ValueToString | In base alla rappresentazione stringa del tipo dati elabora il valore e lo restituisce nel tipo dati correntto.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di DedVar

Il tipo DedVar espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Descrizione |
Proprietà pubblica | Gruppo |
Proprietà pubblica | Hidden |
Proprietà pubblica | Modificabile |
Proprietà pubblica | Nome |
Proprietà pubblica | StatoRecord | Restituisce o imposta lo stato del record.
Proprietà pubblica | Tipodato |
Proprietà pubblica | Valore |
Torna su
Vedi anche

Documentazione

Classe DedVar
Namespace DedNet.Core


Proprietà DedVar.Descrizione

Proprietà DedVarDescrizione

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Descrizione { get; set; }
Public Property Descrizione As String
    Get
    Set
public:
property String^ Descrizione {
    String^ get ();
    void set (String^ value);
}
member Descrizione : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedVar
Namespace DedNet.Core


Proprietà DedVar.Gruppo

Proprietà DedVarGruppo

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ClientApplicationEnum Gruppo { get; set; }
Public Property Gruppo As ClientApplicationEnum
    Get
    Set
public:
property ClientApplicationEnum Gruppo {
    ClientApplicationEnum get ();
    void set (ClientApplicationEnum value);
}
member Gruppo : ClientApplicationEnum with get, set

Valore della proprietà

ClientApplicationEnum
Vedi anche

Documentazione

Classe DedVar
Namespace DedNet.Core


Proprietà DedVar.Hidden

Proprietà DedVarHidden

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Hidden { get; set; }
Public Property Hidden As Boolean
    Get
    Set
public:
property bool Hidden {
    bool get ();
    void set (bool value);
}
member Hidden : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedVar
Namespace DedNet.Core


Proprietà DedVar.Modificabile

Proprietà DedVarModificabile

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Modificabile { get; set; }
Public Property Modificabile As Boolean
    Get
    Set
public:
property bool Modificabile {
    bool get ();
    void set (bool value);
}
member Modificabile : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedVar
Namespace DedNet.Core


Proprietà DedVar.Nome

Proprietà DedVarNome

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Nome { get; set; }
Public Property Nome As String
    Get
    Set
public:
property String^ Nome {
    String^ get ();
    void set (String^ value);
}
member Nome : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedVar
Namespace DedNet.Core


Proprietà DedVar.StatoRecord

Proprietà DedVarStatoRecord
Restituisce o imposta lo stato del record.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public StatoRecord StatoRecord { get; set; }
Public Property StatoRecord As StatoRecord
    Get
    Set
public:
virtual property StatoRecord^ StatoRecord {
    StatoRecord^ get () sealed;
    void set (StatoRecord^ value) sealed;
}
abstract StatoRecord : StatoRecord with get, set
override StatoRecord : StatoRecord with get, set

Valore della proprietà

StatoRecord

Implementa

IDedDbItemStatoRecord
Vedi anche

Documentazione

Classe DedVar
Namespace DedNet.Core


Proprietà DedVar.Tipodato

Proprietà DedVarTipodato

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Tipodato { get; set; }
Public Property Tipodato As String
    Get
    Set
public:
property String^ Tipodato {
    String^ get ();
    void set (String^ value);
}
member Tipodato : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedVar
Namespace DedNet.Core


Proprietà DedVar.Valore

Proprietà DedVarValore

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object Valore { get; set; }
Public Property Valore As Object
    Get
    Set
public:
property Object^ Valore {
    Object^ get ();
    void set (Object^ value);
}
member Valore : Object with get, set

Valore della proprietà

Object
Vedi anche

Documentazione

Classe DedVar
Namespace DedNet.Core


Metodi di DedVar

Il tipo DedVar espone i seguenti membri.

Metodi
 | Nome | Descrizione
 | AppClient2Name | Restituisce la stringa rappresentativa dell'applicazione client.
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetHashCode | Vengono riconosciuti uguali gli elementi che appartengono allo stesso gruppo e nome. (Sovrascrive ObjectGetHashCode)
 | Name2AppClient | Restituisce l'elemento dell'enumerazione rappresentativo dell'applicazione client.
 | TipoDatiToValue | In base alla rappresentazione stringa del tipo dati elabora il valore e lo restituisce nel tipo dati correntto.
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
 | ValueToString | In base alla rappresentazione stringa del tipo dati elabora il valore e lo restituisce nel tipo dati correntto.
Torna su
Vedi anche

Documentazione

Classe DedVar
Namespace DedNet.Core


Metodo DedVar.AppClient2Name

Metodo DedVarAppClient2Name
Restituisce la stringa rappresentativa dell'applicazione client.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string AppClient2Name(
    ClientApplicationEnum client
)
Public Shared Function AppClient2Name (
    client As ClientApplicationEnum
) As String
public:
static String^ AppClient2Name(
    ClientApplicationEnum client
)
static member AppClient2Name :
        client : ClientApplicationEnum -> string

Parametri

client ClientApplicationEnum
Applicazione collegata.

Valore di ritorno

String
Stringa rappresentativa.
Vedi anche

Documentazione

Classe DedVar
Namespace DedNet.Core


Metodo DedVar.Equals

Metodo DedVarEquals

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj Object

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedVar
Namespace DedNet.Core


Metodo DedVar.GetHashCode

Metodo DedVarGetHashCode
Vengono riconosciuti uguali gli elementi che appartengono allo stesso gruppo e nome.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Int32
L'hashcode di questo oggetto.
Vedi anche

Documentazione

Classe DedVar
Namespace DedNet.Core


Metodo DedVar.Name2AppClient

Metodo DedVarName2AppClient
Restituisce l'elemento dell'enumerazione rappresentativo dell'applicazione client.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static ClientApplicationEnum Name2AppClient(
    string client
)
Public Shared Function Name2AppClient (
    client As String
) As ClientApplicationEnum
public:
static ClientApplicationEnum Name2AppClient(
    String^ client
)
static member Name2AppClient :
        client : string -> ClientApplicationEnum

Parametri

client String
Applicazione collegata.

Valore di ritorno

ClientApplicationEnum
Elemento dell'enumerazione.
Vedi anche

Documentazione

Classe DedVar
Namespace DedNet.Core


Metodo DedVar.TipoDatiToValue

Metodo DedVarTipoDatiToValue
In base alla rappresentazione stringa del tipo dati elabora il valore e lo restituisce nel tipo dati correntto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static Object TipoDatiToValue(
    string tipodati,
    string val
)
Public Shared Function TipoDatiToValue (
    tipodati As String,
    val As String
) As Object
public:
static Object^ TipoDatiToValue(
    String^ tipodati,
    String^ val
)
static member TipoDatiToValue :
        tipodati : string *
        val : string -> Object

Parametri

tipodati String
Rappresentazione stringa del tipo dati. Valori validi: bool (1/0), string (stringa semplice), string[] (array di stringhe ottenute da una singola stringa separata da ';').
val String
Valore dal quale ottenere il corretto valore in base al tipo dati.

Valore di ritorno

Object
Vedi anche

Documentazione

Classe DedVar
Namespace DedNet.Core


Metodo DedVar.ToString

Metodo DedVarToString

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedVar
Namespace DedNet.Core


Metodo DedVar.ValueToString

Metodo DedVarValueToString
In base alla rappresentazione stringa del tipo dati elabora il valore e lo restituisce nel tipo dati correntto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string ValueToString(
    string tipodati,
    Object val
)
Public Shared Function ValueToString (
    tipodati As String,
    val As Object
) As String
public:
static String^ ValueToString(
    String^ tipodati,
    Object^ val
)
static member ValueToString :
        tipodati : string *
        val : Object -> string

Parametri

tipodati String
Rappresentazione stringa del tipo dati. Valori validi: bool (1/0), string (stringa semplice), string[] (array di stringhe ottenute da una singola stringa separata da ';').
val Object
Valore dal quale ottenere il corretto valore in base al tipo dati.

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedVar
Namespace DedNet.Core


Classe DedVars
Implementa la lista delle variabili DedVar.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedDbCollectionBase DedVar
DedNet.CoreDedVars

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedVars : DedDbCollectionBase<DedVar>
Public Class DedVars
    Inherits DedDbCollectionBase(Of DedVar)
public ref class DedVars : public DedDbCollectionBase<DedVar^>
type DedVars =
    class
        inherit DedDbCollectionBase<DedVar>
    end

Il tipo DedVars espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedVars | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | ActiveStateConfiguration | Restituisce l'ID della configurazione degli stati attiva.
Proprietà pubblica | AdvancedBomInsert | Restituisce l'ID della configurazione degli stati attiva.
Proprietà pubblica | AllowEditBomMultilev | Restituisce se è permesso editare le distinta multilivello
Proprietà pubblica | AllowsDuplicates | Restituisce se siano ammessi duplicati all'interno della lista. Se false viene sollevata una eccezione su tentativo di inserimento duplicati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | AlternativeRefAttrName | Restituisce il nome dell'attributo da usare per la gestione dei codici alternativi.
Proprietà pubblica | Application | Restituisce l'oggetto applicazione di appartenza. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | ArchiviaInChiusura | Restituisce se archiviare un documento in chiusura, quando attivo un progetto di tipo condiviso. Di default è false.
Proprietà pubblica | AutoCheckInOnClose | Indica se deve essere effettuato il checkin in chiusura dei documenti all'interno di Office. Di default è false.
Proprietà pubblica | AutoUpdateAnagrComm | Restituisce se aggiornare in automatico le anagrafiche delle commesse all'ultima revisione (se la commessa è aperta). Di default è true.
Proprietà pubblica | BomDirtyOnForceLastRevOnBomEdit | Indica se si deve mettere a Dirty la distinta in editazione in caso di elementi non aggiornati all'ultima revisione Viene preso in considerazione solo se la vars ForceLastRevOnBomEdit è attiva (True) Default false.
Proprietà pubblica | CheckCadDuplicatesOnCreatingDocument | Restituisce se leggere i documenti di root in caricamento del form di ricerca documentale.
Proprietà pubblica | CheckInheritProgCollision | Restituisce se controllare i conflitti sul progressivo nel caso la famiglia lo erediti. Di default è false.
Proprietà pubblica | CheckIsInventroDwg | Restituisce se controllare o no se si tratta di un dwg di inventor. Di default è false.
Proprietà pubblica | CheckoutStructureBreakOnNotLavDocument | Restituisce true se il checkout struttura deve proseguire anche sui figli dei documenti associati ad anagrafiche non in lavorazione.
Proprietà pubblica | CheckPwsFileVer | Restituisce se è controllare o meno la versione fisica del file. Di default è false.
Proprietà pubblica | CloneBomOnSaveData | Restituisce se è attiva l'opzione che stabilisce se clonare la distinta durante l'esecuzione del comando 'Duplica anagrafica'. Di default è True.
Proprietà pubblica | Count | Restituisce il numero di elementi presenti. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | CreaAnagrInSalvaDist | Restituisce il valore della variabile CreaAnagrInSalvaDist in base alla piattaforma (è in Top e TopInv). Di default è true per consentire la creazione delle anagrafiche al volo durante il salvataggio della distinta.
Proprietà pubblica | CreateOfficePublishDocOnStateChange | Restituisce se è fare la pubblicazione dei documenti di Office. Di default è false.
Proprietà pubblica | DbMaster | Restituisce se solo il database è master o no. Di default è true.
Proprietà pubblica | DbVersion | Restituisce la versione del DB oppure 0.
Proprietà pubblica | DedRootRadixPath | Restituisce il valore del percorso radice delle root. Viene utilizzato in caso di path relativi.
Proprietà pubblica | DedTypesPlaceHolderDisabled | Lista dei tipi nei quali il segnaposto sulla anagrafica di destinazione non deve mai essere creato
Proprietà pubblica | DedTypesPlaceHolderEnforced | Lista dei tipi nei quali il segnaposto sull'anagrafica di partenza deve sempre essere creato
Proprietà pubblica | DedTypesSkippedOnCheckOutStructure | Lista dei tipi per i quali il c/o deve essere skippato
Proprietà pubblica | DedTypesTemporaryData | Lista delle famiglie dei temporanei.
Proprietà pubblica | DedTypesUnrilMultiDisabled | Lista dei tipi per i quali durante il comando multiplo non deve essere tolto il rilascio.
Proprietà pubblica | DefCommType | Restituisce la famiglia di default nella quale archiviare i record da creare (ex $COMM) durante la creazione di una distinta. Di default restituisce la famiglia root ('!', tutti i tipi).
Proprietà pubblica | DefRevTokenNum | Restituisce il numero di caratteri di default da utilizzare per creare il numero di revisione durante la codifica di un nuovo record, quando la famiglia di archiviazione non abbia la revisione nel DED_DIS.
Proprietà pubblica | DetachedFileSystemsMode | Restituisce se è attiva la modalità a file system separati e sincronizzati. Di default è false.
Proprietà pubblica | Dirty | Restituisce se la collezione o uno dei suoi elementi sia stata modificata. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | DisableAutoSearchOnModalForm | Indica se disabilitare la ricerca automatica nei form di selezione
Proprietà pubblica | DisableBomEditRil | Restituisce se forzare disabilitare o meno l'editazione della distinta dei codici rilasciati. Di default è false.
Proprietà pubblica | DisableBomSaveOnRepresentation | Restituisce se invalidare il salvataggio della distinta su un documento di rappresentazione.
Proprietà pubblica | DisableExportDocumentOnForbiddenState | Restituisce se invalidare l'esportazione dei documenti se la sua anagrafica si torva in uno stato interdetto (superato/obsoleto).
Proprietà pubblica | DisableManageAttachNotWorking | Restituisce se è disabilitata la gestione degli allegati per le anagrafiche non in lavorazione. Di default è false.
Proprietà pubblica | DisableUpdateBomOnRevision | Indica se disabilitare l'aggiornamento delle revisioni delle anagrafiche presenti in distinta quando abbiamo la codifica in NGR Di Defaul è False
Proprietà pubblica | DocPropertiesToInclude | Indica, se definita, la lista di proprietà esclusive da includere al salvataggio nel Database.
Proprietà pubblica | DocPropertyRootsToExclude | Indica, se definita, la lista di root di cui deve far parte il documento perché NON vengano salvate le sue proprietà nel Database.
Proprietà pubblica | DocPropertyRootsToInclude | Indica, se definita, la lista di root di cui deve far parte il documento perché vengano salvate le sue proprietà nel Database.
Proprietà pubblica | EditAttrUpperize | Restituisce se forzare in maiuscolo i caratteri digitati nell'edita attributi. Di default è false.
Proprietà pubblica | EnableListExtension | Restituisce se è abilitata la gestione delle estensioni delle liste. Abilita la stampa tramite qsplot.
Proprietà pubblica | EnforceShowLastRev | Restituisce se visualizzare sempre l'ultima revisione ( nasconde le superate )
Proprietà pubblica | ErasedItems | Restitusice la lista in sola lettura degli elementi che risultano attualmente cancellati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | EsclAttrUpdFromDbTab | Restituisce la lista degli attributi che non devono essere aggiornati dal Database all'apertura di un disegno.
Proprietà pubblica | EseguiTopEditAttrPostEvent | Restituisce il valore della variabile DedEseguiTopEditAttrPostEvent in base alla piattaforma. Di default è true.
Proprietà pubblica | ExportOnlyActiveSheet | Indica se deve essere effettuato il checkin in chiusura dei documenti all'interno di Office. Di default è false.
Proprietà pubblica | ForceLastRevOnBomEdit | Restituisce se forzare sempre tutto all'ultima revisione in editazione/clonazione della distinta. Default True.
Proprietà pubblica | HandleReferenceUpdate | Indica se gestire l'aggiornamento dei riferimenti fisici dei file dopo il comando di Sostituisci in distinta.
Proprietà pubblica | IgnoreEsclAttrUpdOnFirstSave | Restituisce
Proprietà pubblica | IgnoreMissingRef | Specifica se ignorare eventuali Xref mancanti. Di default è false.
Proprietà pubblica | InfoUserPromptName | Restituisce il nome dell'attributo utilizzato per la compilazione del tassello user in fase di salvataggio nel Database. Restituisce 'INFOUSER' di default oppure il valore impostato nelle variabili.
Proprietà pubblica | InvalidateStateCmdOnModelOutOfCad | Restituisce se invalidare il rilascio da fuori il cad in presenza di documenti di modello.
Proprietà pubblica | InvalidateStateCommandsOnPublishErrors | Restituisce/Imposta se invalidare o meno il rilascio in caso di errori in pubblicazione.
Proprietà pubblica | Language | Ritorna il codice ISO della lingua base utilizzata dall'utente.
Proprietà pubblica | LastItem | Restituisce l'ultimo elemento della collezione oppure null se non ci sono elementi. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | LibraryUsesPlaceHolder | Restituisce true se anche i file di libreria devono creare .del o .moved quando vengono salvati
Proprietà pubblica | ManageDocumentProperties | Restituisce se gestire le proprietà dei documenti.
Proprietà pubblica | ManageDwgRef | Specifica se gestire i riferimenti esterni ( Xref / Immagini / Etc.. ). Di default è false.
Proprietà pubblica | MechanicalSaveFormat | Specifica il formato di salvataggio nel caso di Mechanical. Di default è vuoto.
Proprietà pubblica | MopReferenceAttribute | Restituisce il prompt dell'attributo di riferimento del MOP. Di default non è impostato
Proprietà pubblica | NotifySendType | Restituisce la modalità di invio delle notifiche
Proprietà pubblica | NumBckToConserve | Restituisce il valore di tabelle di backup da mantenere per ogni tabella. minore uguale di 0 significa di non cancellare nulla.
Proprietà pubblica | OnlyOwnerCommCanErase | Restituisce se solo il proprietario della commessa la può eliminare. Di default è true.
Proprietà pubblica | OverwriteBomMode | Indica se mantenere o ignorare le modifiche al salvataggio della distinta Di default è Overwrite.
Proprietà pubblica | PlaceHolderMode | Restituisce true se in salvataggio è necessario creare i file .del o .moved
Proprietà pubblica | PrtDwgRead | Specifica se leggere le parti dal prt. Di default è true.
Proprietà pubblica | PrtDwgSave | Specifica sse scrivere le parti nel dwg. Di default è true.
Proprietà pubblica | PrtPrtSave | Specifica se scrivere il file prt. Di default è false.
Proprietà pubblica | PubExtList | Restituisce la lista delle estensioni da considerare come pubblicazione. Di default è "dwf", "pdf","tif".
Proprietà pubblica | PwsBackupNum | Restituisce il numero massimo di documenti da mantenere nell'area locale come backup.
Proprietà pubblica | PwsMode | Restituisce se è attivo il CheckIn, Checkout. Di default è false.
Proprietà pubblica | ReadRootDocumentsOnDocSearchLoad | Restituisce se leggere i documenti di root in caricamento del form di ricerca documentale.
Proprietà pubblica | RenameNgrFileOnExport | Restituisce se rinominare i file ngr aggiungendo la revisione in fase di esportazione.
Proprietà pubblica | RestoreErased | Restituisce se gli elementi cancellati devono essere ripristinati in caso vengano riaggiunti. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | RootsForbiddenForDirectSaving | Lista di root nelle quali non è possibile registrare direttamente un documento nel percorso di base
Proprietà pubblica | RootSkippedOnCheckOutStructure | Lista dei tipi nei quali il segnaposto sulla anagrafica di destinazione non deve mai essere creato
Proprietà pubblica | RootsRecognizedOnDbSave | Lista di root sulle quali effettuare il riconosci invece di un import in fase di salvataggio.
Proprietà pubblica | RootTypeSkippedOnCheckOutStructure | Lista dei tipi nei quali il segnaposto sulla anagrafica di destinazione non deve mai essere creato
Proprietà pubblica | SalvaDistMultiLiv | Restituisce il valore della variabile SalvaDistMultiLiv in base alla piattaforma (è in Top e TopInv). Di default è true per consentire il salvataggio monolivello.
Proprietà pubblica | SilentUpdateDedDisOnOpen | Restituisce se non visualizzare il messaggio di avvertimento all'apertura di un file nel quale viene aggiornato il DED_DIS perché incoerente con la sua posizione ed il suo nome. Di default è false.
Proprietà pubblica | SkipUpdateAttribList | Restituisce la lista degli attributi che non devono essere aggiornati nel Database al salvataggio di un disegno.
Proprietà pubblica | SmtpAlias | Restituisce il valore di default per la mail del mittente Smtp.
Proprietà pubblica | SmtpEmail | Restituisce il valore di default per l'alias Smtp.
Proprietà pubblica | SmtpEnableSsl | Restituisce il valore di default per l'abilitazione SSL in Smtp.
Proprietà pubblica | SmtpHost | Restituisce il valore di default per la host Smtp.
Proprietà pubblica | SmtpPort | Restituisce il valore di default per la porta Smtp.
Proprietà pubblica | SmtpPwd | Restituisce il valore di default per la password Smtp.
Proprietà pubblica | SmtpUser | Restituisce il valore di default per l'utente Smtp.
Proprietà pubblica | SparePartManagementActive | Restituisce se è attiva la gestione dei ricambi.
Proprietà pubblica | TopTabRevActive |
Proprietà pubblica | TopTabRevDrawingCurrent | Restituisce il valore della variabile TopTabRevDrawingCurrent indicante se disegnare, nella tabella delle revisioni, anche la revisione corrente. Di default è true.
Proprietà pubblica | TopTabRevIncludeFirstRevIfNotRevDefZero | Restituisce il valore della variabile TopTabRevIncludeFirstRevIfNotRevDefZero indicante se disegnare, nella tabella delle revisioni, anche la prima anagrafica se la sua revisione è diversa dalla revisione di default. Di default è false.
Proprietà pubblica | TopTabRevNumMaxToShow | Restituisce il valore della variabile TopTabRevNumMaxToShow indicante il numero di revisione massime da mostrare nella tabella. Di default è 0 (ovvero senza limite)
Proprietà pubblica | TransferManagerFtpBasePath | Nelle impostazioni FTP del transfer manager rappresenta il percorso di base per i trasferimenti
Proprietà pubblica | TransferManagerFtpHost | Nelle impostazioni FTP del transfer manager rappresenta l'host name
Proprietà pubblica | TransferManagerFtpPassword | Nelle impostazioni FTP del transfer manager rappresenta la password
Proprietà pubblica | TransferManagerFtpPort | Nelle impostazioni FTP del transfer manager rappresenta la porta
Proprietà pubblica | TransferManagerFtpUser | Nelle impostazioni FTP del transfer manager rappresenta l'utente
Proprietà pubblica | TransferManagerOnlineMode | Restituisce o imposta la modalità di connessione online attiva del transfer manager
Proprietà pubblica | UsersMode | Restituisce se è attiva la gestione degli utenti. Di default è false.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Add | Aggiunge un nuovo elemento alla collezione. Non verifica se esista già un altro elemento con stesse caratteristiche.
Metodo protetto | AddForClone | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto SENZA MODIFICARNE LO STATO. Le classi derivate potranno utilizzare questo metodo per clonare la collezione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddNewElement | DI USO INTERNO. Aggiunge un elemento alla lista rendendo dirty l'oggetto. L'elemento viene aggiunto con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere un elemento alla lista. Dovranno loro stesse avere un metodo pubblico Add() che prenda i parametri necessari alla costruzione dell'oggetto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddRangeNewElement | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi rendendo dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere più elementi alla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddUnModified | Ovverride per la gestione della cache delle variabili (Sovrascrive DedDbCollectionBaseTAddUnModified(T))
Metodo pubblico | Clear | Elimina tutti gli elementi dalla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ClearRefresh | Svuota la lista impostando Dirty = false. Di fatto permette di effettuare un refresh della lista e quindi di ricaricarla. Serve per svuotare la lista e reinizializzarla da capo. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Contains(T) | Verifica l'esistenza di un valore all'interno della lista degli elementi. Le classi derivate devono effettuarne l'override nel caso in cui l'elemento non implementi GetHashCode() per l'uso all'interno dei dizionarii. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Contains(String, ClientApplicationEnum) | Implementa la funzione Contains.
Metodo pubblico | CopyTo | Copia un range di elementi in un array. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | CreateDeleteCommand | Crea, inizializza e restituisce il comando per l'eliminazione di un elemento. (Sovrascrive DedDbCollectionBaseTCreateDeleteCommand(T))
Metodo protetto | CreateInsertCommand | Crea, inizializza e restituisce il comando per l'inserimento di un elemento. (Sovrascrive DedDbCollectionBaseTCreateInsertCommand(T))
Metodo protetto | CreateUpdateCommand | Aggiorna le informazioni di un elemento. (Sovrascrive DedDbCollectionBaseTCreateUpdateCommand(T))
Metodo pubblico | CustomSort | Ordina la lista in base al comparatore passato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteDeleteItem | Esegue l'eliminazione di un elemento. Crea il comando tramite il metodo CreateDeleteCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteInsertItem | Esegue l'inserimento di un elemento. Crea il comando tramite il metodo CreateInsertCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteUpdateItem | Esegue l'aggiornamento di un elemento. Crea il comando tramite il metodo CreateUpdateCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Find | Restituisce l'oggetto cercato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FindAll | Restitusice la lista degli elementi che corrispondono al predicato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | GetDbIndex | Restituisce l'indice dell'elemento passato, da utilizzare nelle clausole where di aggiornamento/eliminazione. (Sovrascrive DedDbCollectionBaseTGetDbIndex(T))
Metodo pubblico | GetEnumerator | Restituisce l'enumeratore della collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | GetVal(String) | Restituisce il valore della variabile individuata dal nome e nel gruppo General. Restituisce null se la variabile non viene trovata o se questa ha valore null.
Metodo pubblico | GetVal(String, ClientApplicationEnum) | Restituisce il valore della variabile individuata dal nome e dal gruppo di appartenenza. Restituisce null se la variabile non viene trovata o se questa ha valore null.
Metodo pubblico | GetVal(String, Object) | Restituisce il valore della variabile individuata dal nome e nel gruppo General. Restituisce null se la variabile non viene trovata o se questa ha valore null.
Metodo pubblico | GetVal(String, ClientApplicationEnum, Object) | Restituisce il valore della variabile individuata dal nome e dal gruppo di appartenenza. Restituisce null se la variabile non viene trovata o se questa ha valore null.
Metodo pubblico | GetVar(String) | Restituisce l'oggetto DedVar individuandolo tramite il nome appartenente al gruppo General. Restituisce null se non esiste.
Metodo pubblico | GetVar(String, ClientApplicationEnum) | Restituisce l'oggetto DedVar individuandolo tramite il nome ed il gruppo di appartenenza. Restituisce null se non esiste.
Metodo pubblico | IndexOf(T) | Restituisce l'indice dell'elemento richiesto. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | IndexOf(String, ClientApplicationEnum) | Implementa la funzione IndexOf.
Metodo pubblico | IndexOf(DedVar, String, ClientApplicationEnum) | Restuitisce l'indice della variabile all'interno della lista se non sono me stesso.
Metodo protetto | InitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InsertUnModified | DI USO INTERNO. Inserisce un elemento alla lista senza rendere dirty l'oggetto, all'indice specificato. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Item(Int32) | Restituisce l'elemento iesimo della lista. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Item(String, ClientApplicationEnum) | Implementa la funzione Item.
Metodo pubblico | Move(Int32, Boolean) | Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean, Int32) | Sposta l'elemento dell'indice passato prima o dopo del numero di posizioni passate. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSave | Metodo Template chiamato dopo il salvataggio avvenuto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSaveNoChanges | Metodo Template chiamato dopo il salvataggio senza modifiche. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnBeforeSave | Metodo Template chiamato prima del salvataggio. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(T) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(DedEditableObjectT) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(T) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(DedEditableObjectT) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ReInitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Remove | Elimina un elemento dalla collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Ripristina | Verifica che l'elemento sia presente negli eliminati e lo toglie da lì e lo riaggiunge in coda alla lista degli elementi validi. Solleva una eccezione se l'elemento è già presente nella lista e AllowsDuplicates = false. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Save | Salva l'oggetto con tutta la sua lista, solo se questo risulta dirty. (Ereditato da DedDbCollectionBaseT)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DedVars
Costruttore unico.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedVars(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedVars(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedVars

Parametri

app DedNetApplication
Oggetto applicazione di appartenenza.
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà di DedVars

Il tipo DedVars espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | ActiveStateConfiguration | Restituisce l'ID della configurazione degli stati attiva.
Proprietà pubblica | AdvancedBomInsert | Restituisce l'ID della configurazione degli stati attiva.
Proprietà pubblica | AllowEditBomMultilev | Restituisce se è permesso editare le distinta multilivello
Proprietà pubblica | AllowsDuplicates | Restituisce se siano ammessi duplicati all'interno della lista. Se false viene sollevata una eccezione su tentativo di inserimento duplicati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | AlternativeRefAttrName | Restituisce il nome dell'attributo da usare per la gestione dei codici alternativi.
Proprietà pubblica | Application | Restituisce l'oggetto applicazione di appartenza. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | ArchiviaInChiusura | Restituisce se archiviare un documento in chiusura, quando attivo un progetto di tipo condiviso. Di default è false.
Proprietà pubblica | AutoCheckInOnClose | Indica se deve essere effettuato il checkin in chiusura dei documenti all'interno di Office. Di default è false.
Proprietà pubblica | AutoUpdateAnagrComm | Restituisce se aggiornare in automatico le anagrafiche delle commesse all'ultima revisione (se la commessa è aperta). Di default è true.
Proprietà pubblica | BomDirtyOnForceLastRevOnBomEdit | Indica se si deve mettere a Dirty la distinta in editazione in caso di elementi non aggiornati all'ultima revisione Viene preso in considerazione solo se la vars ForceLastRevOnBomEdit è attiva (True) Default false.
Proprietà pubblica | CheckCadDuplicatesOnCreatingDocument | Restituisce se leggere i documenti di root in caricamento del form di ricerca documentale.
Proprietà pubblica | CheckInheritProgCollision | Restituisce se controllare i conflitti sul progressivo nel caso la famiglia lo erediti. Di default è false.
Proprietà pubblica | CheckIsInventroDwg | Restituisce se controllare o no se si tratta di un dwg di inventor. Di default è false.
Proprietà pubblica | CheckoutStructureBreakOnNotLavDocument | Restituisce true se il checkout struttura deve proseguire anche sui figli dei documenti associati ad anagrafiche non in lavorazione.
Proprietà pubblica | CheckPwsFileVer | Restituisce se è controllare o meno la versione fisica del file. Di default è false.
Proprietà pubblica | CloneBomOnSaveData | Restituisce se è attiva l'opzione che stabilisce se clonare la distinta durante l'esecuzione del comando 'Duplica anagrafica'. Di default è True.
Proprietà pubblica | Count | Restituisce il numero di elementi presenti. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | CreaAnagrInSalvaDist | Restituisce il valore della variabile CreaAnagrInSalvaDist in base alla piattaforma (è in Top e TopInv). Di default è true per consentire la creazione delle anagrafiche al volo durante il salvataggio della distinta.
Proprietà pubblica | CreateOfficePublishDocOnStateChange | Restituisce se è fare la pubblicazione dei documenti di Office. Di default è false.
Proprietà pubblica | DbMaster | Restituisce se solo il database è master o no. Di default è true.
Proprietà pubblica | DbVersion | Restituisce la versione del DB oppure 0.
Proprietà pubblica | DedRootRadixPath | Restituisce il valore del percorso radice delle root. Viene utilizzato in caso di path relativi.
Proprietà pubblica | DedTypesPlaceHolderDisabled | Lista dei tipi nei quali il segnaposto sulla anagrafica di destinazione non deve mai essere creato
Proprietà pubblica | DedTypesPlaceHolderEnforced | Lista dei tipi nei quali il segnaposto sull'anagrafica di partenza deve sempre essere creato
Proprietà pubblica | DedTypesSkippedOnCheckOutStructure | Lista dei tipi per i quali il c/o deve essere skippato
Proprietà pubblica | DedTypesTemporaryData | Lista delle famiglie dei temporanei.
Proprietà pubblica | DedTypesUnrilMultiDisabled | Lista dei tipi per i quali durante il comando multiplo non deve essere tolto il rilascio.
Proprietà pubblica | DefCommType | Restituisce la famiglia di default nella quale archiviare i record da creare (ex $COMM) durante la creazione di una distinta. Di default restituisce la famiglia root ('!', tutti i tipi).
Proprietà pubblica | DefRevTokenNum | Restituisce il numero di caratteri di default da utilizzare per creare il numero di revisione durante la codifica di un nuovo record, quando la famiglia di archiviazione non abbia la revisione nel DED_DIS.
Proprietà pubblica | DetachedFileSystemsMode | Restituisce se è attiva la modalità a file system separati e sincronizzati. Di default è false.
Proprietà pubblica | Dirty | Restituisce se la collezione o uno dei suoi elementi sia stata modificata. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | DisableAutoSearchOnModalForm | Indica se disabilitare la ricerca automatica nei form di selezione
Proprietà pubblica | DisableBomEditRil | Restituisce se forzare disabilitare o meno l'editazione della distinta dei codici rilasciati. Di default è false.
Proprietà pubblica | DisableBomSaveOnRepresentation | Restituisce se invalidare il salvataggio della distinta su un documento di rappresentazione.
Proprietà pubblica | DisableExportDocumentOnForbiddenState | Restituisce se invalidare l'esportazione dei documenti se la sua anagrafica si torva in uno stato interdetto (superato/obsoleto).
Proprietà pubblica | DisableManageAttachNotWorking | Restituisce se è disabilitata la gestione degli allegati per le anagrafiche non in lavorazione. Di default è false.
Proprietà pubblica | DisableUpdateBomOnRevision | Indica se disabilitare l'aggiornamento delle revisioni delle anagrafiche presenti in distinta quando abbiamo la codifica in NGR Di Defaul è False
Proprietà pubblica | DocPropertiesToInclude | Indica, se definita, la lista di proprietà esclusive da includere al salvataggio nel Database.
Proprietà pubblica | DocPropertyRootsToExclude | Indica, se definita, la lista di root di cui deve far parte il documento perché NON vengano salvate le sue proprietà nel Database.
Proprietà pubblica | DocPropertyRootsToInclude | Indica, se definita, la lista di root di cui deve far parte il documento perché vengano salvate le sue proprietà nel Database.
Proprietà pubblica | EditAttrUpperize | Restituisce se forzare in maiuscolo i caratteri digitati nell'edita attributi. Di default è false.
Proprietà pubblica | EnableListExtension | Restituisce se è abilitata la gestione delle estensioni delle liste. Abilita la stampa tramite qsplot.
Proprietà pubblica | EnforceShowLastRev | Restituisce se visualizzare sempre l'ultima revisione ( nasconde le superate )
Proprietà pubblica | ErasedItems | Restitusice la lista in sola lettura degli elementi che risultano attualmente cancellati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | EsclAttrUpdFromDbTab | Restituisce la lista degli attributi che non devono essere aggiornati dal Database all'apertura di un disegno.
Proprietà pubblica | EseguiTopEditAttrPostEvent | Restituisce il valore della variabile DedEseguiTopEditAttrPostEvent in base alla piattaforma. Di default è true.
Proprietà pubblica | ExportOnlyActiveSheet | Indica se deve essere effettuato il checkin in chiusura dei documenti all'interno di Office. Di default è false.
Proprietà pubblica | ForceLastRevOnBomEdit | Restituisce se forzare sempre tutto all'ultima revisione in editazione/clonazione della distinta. Default True.
Proprietà pubblica | HandleReferenceUpdate | Indica se gestire l'aggiornamento dei riferimenti fisici dei file dopo il comando di Sostituisci in distinta.
Proprietà pubblica | IgnoreEsclAttrUpdOnFirstSave | Restituisce
Proprietà pubblica | IgnoreMissingRef | Specifica se ignorare eventuali Xref mancanti. Di default è false.
Proprietà pubblica | InfoUserPromptName | Restituisce il nome dell'attributo utilizzato per la compilazione del tassello user in fase di salvataggio nel Database. Restituisce 'INFOUSER' di default oppure il valore impostato nelle variabili.
Proprietà pubblica | InvalidateStateCmdOnModelOutOfCad | Restituisce se invalidare il rilascio da fuori il cad in presenza di documenti di modello.
Proprietà pubblica | InvalidateStateCommandsOnPublishErrors | Restituisce/Imposta se invalidare o meno il rilascio in caso di errori in pubblicazione.
Proprietà pubblica | Language | Ritorna il codice ISO della lingua base utilizzata dall'utente.
Proprietà pubblica | LastItem | Restituisce l'ultimo elemento della collezione oppure null se non ci sono elementi. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | LibraryUsesPlaceHolder | Restituisce true se anche i file di libreria devono creare .del o .moved quando vengono salvati
Proprietà pubblica | ManageDocumentProperties | Restituisce se gestire le proprietà dei documenti.
Proprietà pubblica | ManageDwgRef | Specifica se gestire i riferimenti esterni ( Xref / Immagini / Etc.. ). Di default è false.
Proprietà pubblica | MechanicalSaveFormat | Specifica il formato di salvataggio nel caso di Mechanical. Di default è vuoto.
Proprietà pubblica | MopReferenceAttribute | Restituisce il prompt dell'attributo di riferimento del MOP. Di default non è impostato
Proprietà pubblica | NotifySendType | Restituisce la modalità di invio delle notifiche
Proprietà pubblica | NumBckToConserve | Restituisce il valore di tabelle di backup da mantenere per ogni tabella. minore uguale di 0 significa di non cancellare nulla.
Proprietà pubblica | OnlyOwnerCommCanErase | Restituisce se solo il proprietario della commessa la può eliminare. Di default è true.
Proprietà pubblica | OverwriteBomMode | Indica se mantenere o ignorare le modifiche al salvataggio della distinta Di default è Overwrite.
Proprietà pubblica | PlaceHolderMode | Restituisce true se in salvataggio è necessario creare i file .del o .moved
Proprietà pubblica | PrtDwgRead | Specifica se leggere le parti dal prt. Di default è true.
Proprietà pubblica | PrtDwgSave | Specifica sse scrivere le parti nel dwg. Di default è true.
Proprietà pubblica | PrtPrtSave | Specifica se scrivere il file prt. Di default è false.
Proprietà pubblica | PubExtList | Restituisce la lista delle estensioni da considerare come pubblicazione. Di default è "dwf", "pdf","tif".
Proprietà pubblica | PwsBackupNum | Restituisce il numero massimo di documenti da mantenere nell'area locale come backup.
Proprietà pubblica | PwsMode | Restituisce se è attivo il CheckIn, Checkout. Di default è false.
Proprietà pubblica | ReadRootDocumentsOnDocSearchLoad | Restituisce se leggere i documenti di root in caricamento del form di ricerca documentale.
Proprietà pubblica | RenameNgrFileOnExport | Restituisce se rinominare i file ngr aggiungendo la revisione in fase di esportazione.
Proprietà pubblica | RestoreErased | Restituisce se gli elementi cancellati devono essere ripristinati in caso vengano riaggiunti. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | RootsForbiddenForDirectSaving | Lista di root nelle quali non è possibile registrare direttamente un documento nel percorso di base
Proprietà pubblica | RootSkippedOnCheckOutStructure | Lista dei tipi nei quali il segnaposto sulla anagrafica di destinazione non deve mai essere creato
Proprietà pubblica | RootsRecognizedOnDbSave | Lista di root sulle quali effettuare il riconosci invece di un import in fase di salvataggio.
Proprietà pubblica | RootTypeSkippedOnCheckOutStructure | Lista dei tipi nei quali il segnaposto sulla anagrafica di destinazione non deve mai essere creato
Proprietà pubblica | SalvaDistMultiLiv | Restituisce il valore della variabile SalvaDistMultiLiv in base alla piattaforma (è in Top e TopInv). Di default è true per consentire il salvataggio monolivello.
Proprietà pubblica | SilentUpdateDedDisOnOpen | Restituisce se non visualizzare il messaggio di avvertimento all'apertura di un file nel quale viene aggiornato il DED_DIS perché incoerente con la sua posizione ed il suo nome. Di default è false.
Proprietà pubblica | SkipUpdateAttribList | Restituisce la lista degli attributi che non devono essere aggiornati nel Database al salvataggio di un disegno.
Proprietà pubblica | SmtpAlias | Restituisce il valore di default per la mail del mittente Smtp.
Proprietà pubblica | SmtpEmail | Restituisce il valore di default per l'alias Smtp.
Proprietà pubblica | SmtpEnableSsl | Restituisce il valore di default per l'abilitazione SSL in Smtp.
Proprietà pubblica | SmtpHost | Restituisce il valore di default per la host Smtp.
Proprietà pubblica | SmtpPort | Restituisce il valore di default per la porta Smtp.
Proprietà pubblica | SmtpPwd | Restituisce il valore di default per la password Smtp.
Proprietà pubblica | SmtpUser | Restituisce il valore di default per l'utente Smtp.
Proprietà pubblica | SparePartManagementActive | Restituisce se è attiva la gestione dei ricambi.
Proprietà pubblica | TopTabRevActive |
Proprietà pubblica | TopTabRevDrawingCurrent | Restituisce il valore della variabile TopTabRevDrawingCurrent indicante se disegnare, nella tabella delle revisioni, anche la revisione corrente. Di default è true.
Proprietà pubblica | TopTabRevIncludeFirstRevIfNotRevDefZero | Restituisce il valore della variabile TopTabRevIncludeFirstRevIfNotRevDefZero indicante se disegnare, nella tabella delle revisioni, anche la prima anagrafica se la sua revisione è diversa dalla revisione di default. Di default è false.
Proprietà pubblica | TopTabRevNumMaxToShow | Restituisce il valore della variabile TopTabRevNumMaxToShow indicante il numero di revisione massime da mostrare nella tabella. Di default è 0 (ovvero senza limite)
Proprietà pubblica | TransferManagerFtpBasePath | Nelle impostazioni FTP del transfer manager rappresenta il percorso di base per i trasferimenti
Proprietà pubblica | TransferManagerFtpHost | Nelle impostazioni FTP del transfer manager rappresenta l'host name
Proprietà pubblica | TransferManagerFtpPassword | Nelle impostazioni FTP del transfer manager rappresenta la password
Proprietà pubblica | TransferManagerFtpPort | Nelle impostazioni FTP del transfer manager rappresenta la porta
Proprietà pubblica | TransferManagerFtpUser | Nelle impostazioni FTP del transfer manager rappresenta l'utente
Proprietà pubblica | TransferManagerOnlineMode | Restituisce o imposta la modalità di connessione online attiva del transfer manager
Proprietà pubblica | UsersMode | Restituisce se è attiva la gestione degli utenti. Di default è false.
Torna su
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.ActiveStateConfiguration

Proprietà DedVarsActiveStateConfiguration
Restituisce l'ID della configurazione degli stati attiva.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int ActiveStateConfiguration { get; set; }
Public Property ActiveStateConfiguration As Integer
    Get
    Set
public:
property int ActiveStateConfiguration {
    int get ();
    void set (int value);
}
member ActiveStateConfiguration : int with get, set

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.AdvancedBomInsert

Proprietà DedVarsAdvancedBomInsert
Restituisce l'ID della configurazione degli stati attiva.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AdvancedBomInsert { get; }
Public ReadOnly Property AdvancedBomInsert As Boolean
    Get
public:
property bool AdvancedBomInsert {
    bool get ();
}
member AdvancedBomInsert : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.AllowEditBomMultilev

Proprietà DedVarsAllowEditBomMultilev
Restituisce se è permesso editare le distinta multilivello

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AllowEditBomMultilev { get; }
Public ReadOnly Property AllowEditBomMultilev As Boolean
    Get
public:
property bool AllowEditBomMultilev {
    bool get ();
}
member AllowEditBomMultilev : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.AlternativeRefAttrName

Proprietà DedVarsAlternativeRefAttrName
Restituisce il nome dell'attributo da usare per la gestione dei codici alternativi.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string AlternativeRefAttrName { get; }
Public ReadOnly Property AlternativeRefAttrName As String
    Get
public:
property String^ AlternativeRefAttrName {
    String^ get ();
}
member AlternativeRefAttrName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.ArchiviaInChiusura

Proprietà DedVarsArchiviaInChiusura
Restituisce se archiviare un documento in chiusura, quando attivo un progetto di tipo condiviso. Di default è false.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ArchiviaInChiusura { get; }
Public ReadOnly Property ArchiviaInChiusura As Boolean
    Get
public:
property bool ArchiviaInChiusura {
    bool get ();
}
member ArchiviaInChiusura : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.AutoCheckInOnClose

Proprietà DedVarsAutoCheckInOnClose
Indica se deve essere effettuato il checkin in chiusura dei documenti all'interno di Office. Di default è false.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AutoCheckInOnClose { get; }
Public ReadOnly Property AutoCheckInOnClose As Boolean
    Get
public:
property bool AutoCheckInOnClose {
    bool get ();
}
member AutoCheckInOnClose : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.AutoUpdateAnagrComm

Proprietà DedVarsAutoUpdateAnagrComm
Restituisce se aggiornare in automatico le anagrafiche delle commesse all'ultima revisione (se la commessa è aperta). Di default è true.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AutoUpdateAnagrComm { get; }
Public ReadOnly Property AutoUpdateAnagrComm As Boolean
    Get
public:
property bool AutoUpdateAnagrComm {
    bool get ();
}
member AutoUpdateAnagrComm : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.BomDirtyOnForceLastRevOnBomEdit

Proprietà DedVarsBomDirtyOnForceLastRevOnBomEdit
Indica se si deve mettere a Dirty la distinta in editazione in caso di elementi non aggiornati all'ultima revisione Viene preso in considerazione solo se la vars ForceLastRevOnBomEdit è attiva (True) Default false.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool BomDirtyOnForceLastRevOnBomEdit { get; }
Public ReadOnly Property BomDirtyOnForceLastRevOnBomEdit As Boolean
    Get
public:
property bool BomDirtyOnForceLastRevOnBomEdit {
    bool get ();
}
member BomDirtyOnForceLastRevOnBomEdit : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.CheckCadDuplicatesOnCreatingDocument

Proprietà DedVarsCheckCadDuplicatesOnCreatingDocument
Restituisce se leggere i documenti di root in caricamento del form di ricerca documentale.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CheckCadDuplicatesOnCreatingDocument { get; }
Public ReadOnly Property CheckCadDuplicatesOnCreatingDocument As Boolean
    Get
public:
property bool CheckCadDuplicatesOnCreatingDocument {
    bool get ();
}
member CheckCadDuplicatesOnCreatingDocument : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.CheckInheritProgCollision

Proprietà DedVarsCheckInheritProgCollision
Restituisce se controllare i conflitti sul progressivo nel caso la famiglia lo erediti. Di default è false.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CheckInheritProgCollision { get; }
Public ReadOnly Property CheckInheritProgCollision As Boolean
    Get
public:
property bool CheckInheritProgCollision {
    bool get ();
}
member CheckInheritProgCollision : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.CheckIsInventroDwg

Proprietà DedVarsCheckIsInventroDwg
Restituisce se controllare o no se si tratta di un dwg di inventor. Di default è false.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CheckIsInventroDwg { get; }
Public ReadOnly Property CheckIsInventroDwg As Boolean
    Get
public:
property bool CheckIsInventroDwg {
    bool get ();
}
member CheckIsInventroDwg : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.CheckoutStructureBreakOnNotLavDocument

Proprietà DedVarsCheckoutStructureBreakOnNotLavDocument
Restituisce true se il checkout struttura deve proseguire anche sui figli dei documenti associati ad anagrafiche non in lavorazione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CheckoutStructureBreakOnNotLavDocument { get; }
Public ReadOnly Property CheckoutStructureBreakOnNotLavDocument As Boolean
    Get
public:
property bool CheckoutStructureBreakOnNotLavDocument {
    bool get ();
}
member CheckoutStructureBreakOnNotLavDocument : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.CheckPwsFileVer

Proprietà DedVarsCheckPwsFileVer
Restituisce se è controllare o meno la versione fisica del file. Di default è false.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CheckPwsFileVer { get; }
Public ReadOnly Property CheckPwsFileVer As Boolean
    Get
public:
property bool CheckPwsFileVer {
    bool get ();
}
member CheckPwsFileVer : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.CloneBomOnSaveData

Proprietà DedVarsCloneBomOnSaveData
Restituisce se è attiva l'opzione che stabilisce se clonare la distinta durante l'esecuzione del comando 'Duplica anagrafica'. Di default è True.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomCloneMode CloneBomOnSaveData { get; }
Public ReadOnly Property CloneBomOnSaveData As BomCloneMode
    Get
public:
property BomCloneMode CloneBomOnSaveData {
    BomCloneMode get ();
}
member CloneBomOnSaveData : BomCloneMode with get

Valore della proprietà

BomCloneMode
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.CreaAnagrInSalvaDist

Proprietà DedVarsCreaAnagrInSalvaDist
Restituisce il valore della variabile CreaAnagrInSalvaDist in base alla piattaforma (è in Top e TopInv). Di default è true per consentire la creazione delle anagrafiche al volo durante il salvataggio della distinta.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CreaAnagrInSalvaDist { get; }
Public ReadOnly Property CreaAnagrInSalvaDist As Boolean
    Get
public:
property bool CreaAnagrInSalvaDist {
    bool get ();
}
member CreaAnagrInSalvaDist : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.CreateOfficePublishDocOnStateChange

Proprietà DedVarsCreateOfficePublishDocOnStateChange
Restituisce se è fare la pubblicazione dei documenti di Office. Di default è false.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CreateOfficePublishDocOnStateChange { get; }
Public ReadOnly Property CreateOfficePublishDocOnStateChange As Boolean
    Get
public:
property bool CreateOfficePublishDocOnStateChange {
    bool get ();
}
member CreateOfficePublishDocOnStateChange : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.DbMaster

Proprietà DedVarsDbMaster
Restituisce se solo il database è master o no. Di default è true.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool DbMaster { get; }
Public ReadOnly Property DbMaster As Boolean
    Get
public:
property bool DbMaster {
    bool get ();
}
member DbMaster : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.DbVersion

Proprietà DedVarsDbVersion
Restituisce la versione del DB oppure 0.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public VersionInfo DbVersion { get; }
Public ReadOnly Property DbVersion As VersionInfo
    Get
public:
property VersionInfo DbVersion {
    VersionInfo get ();
}
member DbVersion : VersionInfo with get

Valore della proprietà

VersionInfo
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.DedRootRadixPath

Proprietà DedVarsDedRootRadixPath
Restituisce il valore del percorso radice delle root. Viene utilizzato in caso di path relativi.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string DedRootRadixPath { get; set; }
Public Property DedRootRadixPath As String
    Get
    Set
public:
property String^ DedRootRadixPath {
    String^ get ();
    void set (String^ value);
}
member DedRootRadixPath : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.DedTypesPlaceHolderDisabled

Proprietà DedVarsDedTypesPlaceHolderDisabled
Lista dei tipi nei quali il segnaposto sulla anagrafica di destinazione non deve mai essere creato

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeList DedTypesPlaceHolderDisabled { get; }
Public ReadOnly Property DedTypesPlaceHolderDisabled As DedTypeList
    Get
public:
property DedTypeList^ DedTypesPlaceHolderDisabled {
    DedTypeList^ get ();
}
member DedTypesPlaceHolderDisabled : DedTypeList with get

Valore della proprietà

DedTypeList
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.DedTypesPlaceHolderEnforced

Proprietà DedVarsDedTypesPlaceHolderEnforced
Lista dei tipi nei quali il segnaposto sull'anagrafica di partenza deve sempre essere creato

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeList DedTypesPlaceHolderEnforced { get; }
Public ReadOnly Property DedTypesPlaceHolderEnforced As DedTypeList
    Get
public:
property DedTypeList^ DedTypesPlaceHolderEnforced {
    DedTypeList^ get ();
}
member DedTypesPlaceHolderEnforced : DedTypeList with get

Valore della proprietà

DedTypeList
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.DedTypesSkippedOnCheckOutStructure

Proprietà DedVarsDedTypesSkippedOnCheckOutStructure
Lista dei tipi per i quali il c/o deve essere skippato

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeList DedTypesSkippedOnCheckOutStructure { get; }
Public ReadOnly Property DedTypesSkippedOnCheckOutStructure As DedTypeList
    Get
public:
property DedTypeList^ DedTypesSkippedOnCheckOutStructure {
    DedTypeList^ get ();
}
member DedTypesSkippedOnCheckOutStructure : DedTypeList with get

Valore della proprietà

DedTypeList
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.DedTypesTemporaryData

Proprietà DedVarsDedTypesTemporaryData
Lista delle famiglie dei temporanei.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeList DedTypesTemporaryData { get; }
Public ReadOnly Property DedTypesTemporaryData As DedTypeList
    Get
public:
property DedTypeList^ DedTypesTemporaryData {
    DedTypeList^ get ();
}
member DedTypesTemporaryData : DedTypeList with get

Valore della proprietà

DedTypeList
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.DedTypesUnrilMultiDisabled

Proprietà DedVarsDedTypesUnrilMultiDisabled
Lista dei tipi per i quali durante il comando multiplo non deve essere tolto il rilascio.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeList DedTypesUnrilMultiDisabled { get; }
Public ReadOnly Property DedTypesUnrilMultiDisabled As DedTypeList
    Get
public:
property DedTypeList^ DedTypesUnrilMultiDisabled {
    DedTypeList^ get ();
}
member DedTypesUnrilMultiDisabled : DedTypeList with get

Valore della proprietà

DedTypeList
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.DefCommType

Proprietà DedVarsDefCommType
Restituisce la famiglia di default nella quale archiviare i record da creare (ex $COMM) durante la creazione di una distinta. Di default restituisce la famiglia root ('!', tutti i tipi).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedType DefCommType { get; }
Public ReadOnly Property DefCommType As DedType
    Get
public:
property DedType^ DefCommType {
    DedType^ get ();
}
member DefCommType : DedType with get

Valore della proprietà

DedType
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.DefRevTokenNum

Proprietà DedVarsDefRevTokenNum
Restituisce il numero di caratteri di default da utilizzare per creare il numero di revisione durante la codifica di un nuovo record, quando la famiglia di archiviazione non abbia la revisione nel DED_DIS.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int DefRevTokenNum { get; }
Public ReadOnly Property DefRevTokenNum As Integer
    Get
public:
property int DefRevTokenNum {
    int get ();
}
member DefRevTokenNum : int with get

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.DetachedFileSystemsMode

Proprietà DedVarsDetachedFileSystemsMode
Restituisce se è attiva la modalità a file system separati e sincronizzati. Di default è false.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool DetachedFileSystemsMode { get; }
Public ReadOnly Property DetachedFileSystemsMode As Boolean
    Get
public:
property bool DetachedFileSystemsMode {
    bool get ();
}
member DetachedFileSystemsMode : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.DisableAutoSearchOnModalForm

Proprietà DedVarsDisableAutoSearchOnModalForm
Indica se disabilitare la ricerca automatica nei form di selezione

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool DisableAutoSearchOnModalForm { get; }
Public ReadOnly Property DisableAutoSearchOnModalForm As Boolean
    Get
public:
property bool DisableAutoSearchOnModalForm {
    bool get ();
}
member DisableAutoSearchOnModalForm : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.DisableBomEditRil

Proprietà DedVarsDisableBomEditRil
Restituisce se forzare disabilitare o meno l'editazione della distinta dei codici rilasciati. Di default è false.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool DisableBomEditRil { get; }
Public ReadOnly Property DisableBomEditRil As Boolean
    Get
public:
property bool DisableBomEditRil {
    bool get ();
}
member DisableBomEditRil : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.DisableBomSaveOnRepresentation

Proprietà DedVarsDisableBomSaveOnRepresentation
Restituisce se invalidare il salvataggio della distinta su un documento di rappresentazione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool DisableBomSaveOnRepresentation { get; }
Public ReadOnly Property DisableBomSaveOnRepresentation As Boolean
    Get
public:
property bool DisableBomSaveOnRepresentation {
    bool get ();
}
member DisableBomSaveOnRepresentation : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.DisableExportDocumentOnForbiddenState

Proprietà DedVarsDisableExportDocumentOnForbiddenState
Restituisce se invalidare l'esportazione dei documenti se la sua anagrafica si torva in uno stato interdetto (superato/obsoleto).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool DisableExportDocumentOnForbiddenState { get; }
Public ReadOnly Property DisableExportDocumentOnForbiddenState As Boolean
    Get
public:
property bool DisableExportDocumentOnForbiddenState {
    bool get ();
}
member DisableExportDocumentOnForbiddenState : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.DisableManageAttachNotWorking

Proprietà DedVarsDisableManageAttachNotWorking
Restituisce se è disabilitata la gestione degli allegati per le anagrafiche non in lavorazione. Di default è false.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool DisableManageAttachNotWorking { get; }
Public ReadOnly Property DisableManageAttachNotWorking As Boolean
    Get
public:
property bool DisableManageAttachNotWorking {
    bool get ();
}
member DisableManageAttachNotWorking : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.DisableUpdateBomOnRevision

Proprietà DedVarsDisableUpdateBomOnRevision
Indica se disabilitare l'aggiornamento delle revisioni delle anagrafiche presenti in distinta quando abbiamo la codifica in NGR Di Defaul è False

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool DisableUpdateBomOnRevision { get; }
Public ReadOnly Property DisableUpdateBomOnRevision As Boolean
    Get
public:
property bool DisableUpdateBomOnRevision {
    bool get ();
}
member DisableUpdateBomOnRevision : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.DocPropertiesToInclude

Proprietà DedVarsDocPropertiesToInclude
Indica, se definita, la lista di proprietà esclusive da includere al salvataggio nel Database.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> DocPropertiesToInclude { get; }
Public ReadOnly Property DocPropertiesToInclude As List(Of String)
    Get
public:
property List<String^>^ DocPropertiesToInclude {
    List<String^>^ get ();
}
member DocPropertiesToInclude : List<string> with get

Valore della proprietà

List String
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.DocPropertyRootsToExclude

Proprietà DedVarsDocPropertyRootsToExclude
Indica, se definita, la lista di root di cui deve far parte il documento perché NON vengano salvate le sue proprietà nel Database.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> DocPropertyRootsToExclude { get; }
Public ReadOnly Property DocPropertyRootsToExclude As List(Of String)
    Get
public:
property List<String^>^ DocPropertyRootsToExclude {
    List<String^>^ get ();
}
member DocPropertyRootsToExclude : List<string> with get

Valore della proprietà

List String
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.DocPropertyRootsToInclude

Proprietà DedVarsDocPropertyRootsToInclude
Indica, se definita, la lista di root di cui deve far parte il documento perché vengano salvate le sue proprietà nel Database.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> DocPropertyRootsToInclude { get; }
Public ReadOnly Property DocPropertyRootsToInclude As List(Of String)
    Get
public:
property List<String^>^ DocPropertyRootsToInclude {
    List<String^>^ get ();
}
member DocPropertyRootsToInclude : List<string> with get

Valore della proprietà

List String
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.EditAttrUpperize

Proprietà DedVarsEditAttrUpperize
Restituisce se forzare in maiuscolo i caratteri digitati nell'edita attributi. Di default è false.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool EditAttrUpperize { get; }
Public ReadOnly Property EditAttrUpperize As Boolean
    Get
public:
property bool EditAttrUpperize {
    bool get ();
}
member EditAttrUpperize : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.EnableListExtension

Proprietà DedVarsEnableListExtension
Restituisce se è abilitata la gestione delle estensioni delle liste. Abilita la stampa tramite qsplot.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool EnableListExtension { get; }
Public ReadOnly Property EnableListExtension As Boolean
    Get
public:
property bool EnableListExtension {
    bool get ();
}
member EnableListExtension : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.EnforceShowLastRev

Proprietà DedVarsEnforceShowLastRev
Restituisce se visualizzare sempre l'ultima revisione ( nasconde le superate )

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool EnforceShowLastRev { get; set; }
Public Property EnforceShowLastRev As Boolean
    Get
    Set
public:
property bool EnforceShowLastRev {
    bool get ();
    void set (bool value);
}
member EnforceShowLastRev : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.EsclAttrUpdFromDbTab

Proprietà DedVarsEsclAttrUpdFromDbTab
Restituisce la lista degli attributi che non devono essere aggiornati dal Database all'apertura di un disegno.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> EsclAttrUpdFromDbTab { get; }
Public ReadOnly Property EsclAttrUpdFromDbTab As List(Of String)
    Get
public:
property List<String^>^ EsclAttrUpdFromDbTab {
    List<String^>^ get ();
}
member EsclAttrUpdFromDbTab : List<string> with get

Valore della proprietà

List String
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.EseguiTopEditAttrPostEvent

Proprietà DedVarsEseguiTopEditAttrPostEvent
Restituisce il valore della variabile DedEseguiTopEditAttrPostEvent in base alla piattaforma. Di default è true.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool EseguiTopEditAttrPostEvent { get; }
Public ReadOnly Property EseguiTopEditAttrPostEvent As Boolean
    Get
public:
property bool EseguiTopEditAttrPostEvent {
    bool get ();
}
member EseguiTopEditAttrPostEvent : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.ExportOnlyActiveSheet

Proprietà DedVarsExportOnlyActiveSheet
Indica se deve essere effettuato il checkin in chiusura dei documenti all'interno di Office. Di default è false.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ExportOnlyActiveSheet { get; }
Public ReadOnly Property ExportOnlyActiveSheet As Boolean
    Get
public:
property bool ExportOnlyActiveSheet {
    bool get ();
}
member ExportOnlyActiveSheet : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.ForceLastRevOnBomEdit

Proprietà DedVarsForceLastRevOnBomEdit
Restituisce se forzare sempre tutto all'ultima revisione in editazione/clonazione della distinta. Default True.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ForceLastRevOnBomEdit { get; }
Public ReadOnly Property ForceLastRevOnBomEdit As Boolean
    Get
public:
property bool ForceLastRevOnBomEdit {
    bool get ();
}
member ForceLastRevOnBomEdit : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.HandleReferenceUpdate

Proprietà DedVarsHandleReferenceUpdate
Indica se gestire l'aggiornamento dei riferimenti fisici dei file dopo il comando di Sostituisci in distinta.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ReferenceUpdateEnum HandleReferenceUpdate { get; }
Public ReadOnly Property HandleReferenceUpdate As ReferenceUpdateEnum
    Get
public:
property ReferenceUpdateEnum HandleReferenceUpdate {
    ReferenceUpdateEnum get ();
}
member HandleReferenceUpdate : ReferenceUpdateEnum with get

Valore della proprietà

ReferenceUpdateEnum
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.IgnoreEsclAttrUpdOnFirstSave

Proprietà DedVarsIgnoreEsclAttrUpdOnFirstSave
Restituisce

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IgnoreEsclAttrUpdOnFirstSave { get; }
Public ReadOnly Property IgnoreEsclAttrUpdOnFirstSave As Boolean
    Get
public:
property bool IgnoreEsclAttrUpdOnFirstSave {
    bool get ();
}
member IgnoreEsclAttrUpdOnFirstSave : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.IgnoreMissingRef

Proprietà DedVarsIgnoreMissingRef
Specifica se ignorare eventuali Xref mancanti. Di default è false.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IgnoreMissingRef { get; }
Public ReadOnly Property IgnoreMissingRef As Boolean
    Get
public:
property bool IgnoreMissingRef {
    bool get ();
}
member IgnoreMissingRef : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.InfoUserPromptName

Proprietà DedVarsInfoUserPromptName
Restituisce il nome dell'attributo utilizzato per la compilazione del tassello user in fase di salvataggio nel Database. Restituisce 'INFOUSER' di default oppure il valore impostato nelle variabili.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string InfoUserPromptName { get; }
Public ReadOnly Property InfoUserPromptName As String
    Get
public:
property String^ InfoUserPromptName {
    String^ get ();
}
member InfoUserPromptName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.InvalidateStateCmdOnModelOutOfCad

Proprietà DedVarsInvalidateStateCmdOnModelOutOfCad
Restituisce se invalidare il rilascio da fuori il cad in presenza di documenti di modello.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool InvalidateStateCmdOnModelOutOfCad { get; }
Public ReadOnly Property InvalidateStateCmdOnModelOutOfCad As Boolean
    Get
public:
property bool InvalidateStateCmdOnModelOutOfCad {
    bool get ();
}
member InvalidateStateCmdOnModelOutOfCad : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.InvalidateStateCommandsOnPublishErrors

Proprietà DedVarsInvalidateStateCommandsOnPublishErrors
Restituisce/Imposta se invalidare o meno il rilascio in caso di errori in pubblicazione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool InvalidateStateCommandsOnPublishErrors { get; set; }
Public Property InvalidateStateCommandsOnPublishErrors As Boolean
    Get
    Set
public:
property bool InvalidateStateCommandsOnPublishErrors {
    bool get ();
    void set (bool value);
}
member InvalidateStateCommandsOnPublishErrors : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.Language

Proprietà DedVarsLanguage
Ritorna il codice ISO della lingua base utilizzata dall'utente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Language { get; }
Public ReadOnly Property Language As String
    Get
public:
property String^ Language {
    String^ get ();
}
member Language : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.LibraryUsesPlaceHolder

Proprietà DedVarsLibraryUsesPlaceHolder
Restituisce true se anche i file di libreria devono creare .del o .moved quando vengono salvati

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool LibraryUsesPlaceHolder { get; }
Public ReadOnly Property LibraryUsesPlaceHolder As Boolean
    Get
public:
property bool LibraryUsesPlaceHolder {
    bool get ();
}
member LibraryUsesPlaceHolder : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.ManageDocumentProperties

Proprietà DedVarsManageDocumentProperties
Restituisce se gestire le proprietà dei documenti.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ManageDocumentProperties { get; }
Public ReadOnly Property ManageDocumentProperties As Boolean
    Get
public:
property bool ManageDocumentProperties {
    bool get ();
}
member ManageDocumentProperties : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.ManageDwgRef

Proprietà DedVarsManageDwgRef
Specifica se gestire i riferimenti esterni ( Xref / Immagini / Etc.. ). Di default è false.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ManageDwgRef { get; }
Public ReadOnly Property ManageDwgRef As Boolean
    Get
public:
property bool ManageDwgRef {
    bool get ();
}
member ManageDwgRef : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.MechanicalSaveFormat

Proprietà DedVarsMechanicalSaveFormat
Specifica il formato di salvataggio nel caso di Mechanical. Di default è vuoto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string MechanicalSaveFormat { get; }
Public ReadOnly Property MechanicalSaveFormat As String
    Get
public:
property String^ MechanicalSaveFormat {
    String^ get ();
}
member MechanicalSaveFormat : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.MopReferenceAttribute

Proprietà DedVarsMopReferenceAttribute
Restituisce il prompt dell'attributo di riferimento del MOP. Di default non è impostato

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string MopReferenceAttribute { get; }
Public ReadOnly Property MopReferenceAttribute As String
    Get
public:
property String^ MopReferenceAttribute {
    String^ get ();
}
member MopReferenceAttribute : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.NotifySendType

Proprietà DedVarsNotifySendType
Restituisce la modalità di invio delle notifiche

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedNotifyNotifySendTypeEnum NotifySendType { get; }
Public ReadOnly Property NotifySendType As DedNotifyNotifySendTypeEnum
    Get
public:
property DedNotifyNotifySendTypeEnum NotifySendType {
    DedNotifyNotifySendTypeEnum get ();
}
member NotifySendType : DedNotifyNotifySendTypeEnum with get

Valore della proprietà

DedNotifyNotifySendTypeEnum
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.NumBckToConserve

Proprietà DedVarsNumBckToConserve
Restituisce il valore di tabelle di backup da mantenere per ogni tabella. minore uguale di 0 significa di non cancellare nulla.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int NumBckToConserve { get; }
Public ReadOnly Property NumBckToConserve As Integer
    Get
public:
property int NumBckToConserve {
    int get ();
}
member NumBckToConserve : int with get

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.OnlyOwnerCommCanErase

Proprietà DedVarsOnlyOwnerCommCanErase
Restituisce se solo il proprietario della commessa la può eliminare. Di default è true.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool OnlyOwnerCommCanErase { get; }
Public ReadOnly Property OnlyOwnerCommCanErase As Boolean
    Get
public:
property bool OnlyOwnerCommCanErase {
    bool get ();
}
member OnlyOwnerCommCanErase : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.OverwriteBomMode

Proprietà DedVarsOverwriteBomMode
Indica se mantenere o ignorare le modifiche al salvataggio della distinta Di default è Overwrite.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public OverwriteBomMode OverwriteBomMode { get; }
Public ReadOnly Property OverwriteBomMode As OverwriteBomMode
    Get
public:
property OverwriteBomMode OverwriteBomMode {
    OverwriteBomMode get ();
}
member OverwriteBomMode : OverwriteBomMode with get

Valore della proprietà

OverwriteBomMode
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.PlaceHolderMode

Proprietà DedVarsPlaceHolderMode
Restituisce true se in salvataggio è necessario creare i file .del o .moved

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool PlaceHolderMode { get; }
Public ReadOnly Property PlaceHolderMode As Boolean
    Get
public:
property bool PlaceHolderMode {
    bool get ();
}
member PlaceHolderMode : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.PrtDwgRead

Proprietà DedVarsPrtDwgRead
Specifica se leggere le parti dal prt. Di default è true.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool PrtDwgRead { get; }
Public ReadOnly Property PrtDwgRead As Boolean
    Get
public:
property bool PrtDwgRead {
    bool get ();
}
member PrtDwgRead : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.PrtDwgSave

Proprietà DedVarsPrtDwgSave
Specifica sse scrivere le parti nel dwg. Di default è true.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool PrtDwgSave { get; }
Public ReadOnly Property PrtDwgSave As Boolean
    Get
public:
property bool PrtDwgSave {
    bool get ();
}
member PrtDwgSave : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.PrtPrtSave

Proprietà DedVarsPrtPrtSave
Specifica se scrivere il file prt. Di default è false.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool PrtPrtSave { get; }
Public ReadOnly Property PrtPrtSave As Boolean
    Get
public:
property bool PrtPrtSave {
    bool get ();
}
member PrtPrtSave : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.PubExtList

Proprietà DedVarsPubExtList
Restituisce la lista delle estensioni da considerare come pubblicazione. Di default è "dwf", "pdf","tif".

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string[] PubExtList { get; }
Public ReadOnly Property PubExtList As String()
    Get
public:
property array<String^>^ PubExtList {
    array<String^>^ get ();
}
member PubExtList : string[] with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.PwsBackupNum

Proprietà DedVarsPwsBackupNum
Restituisce il numero massimo di documenti da mantenere nell'area locale come backup.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int PwsBackupNum { get; }
Public ReadOnly Property PwsBackupNum As Integer
    Get
public:
property int PwsBackupNum {
    int get ();
}
member PwsBackupNum : int with get

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.PwsMode

Proprietà DedVarsPwsMode
Restituisce se è attivo il CheckIn, Checkout. Di default è false.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool PwsMode { get; }
Public ReadOnly Property PwsMode As Boolean
    Get
public:
property bool PwsMode {
    bool get ();
}
member PwsMode : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.ReadRootDocumentsOnDocSearchLoad

Proprietà DedVarsReadRootDocumentsOnDocSearchLoad
Restituisce se leggere i documenti di root in caricamento del form di ricerca documentale.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ReadRootDocumentsOnDocSearchLoad { get; }
Public ReadOnly Property ReadRootDocumentsOnDocSearchLoad As Boolean
    Get
public:
property bool ReadRootDocumentsOnDocSearchLoad {
    bool get ();
}
member ReadRootDocumentsOnDocSearchLoad : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.RenameNgrFileOnExport

Proprietà DedVarsRenameNgrFileOnExport
Restituisce se rinominare i file ngr aggiungendo la revisione in fase di esportazione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool RenameNgrFileOnExport { get; }
Public ReadOnly Property RenameNgrFileOnExport As Boolean
    Get
public:
property bool RenameNgrFileOnExport {
    bool get ();
}
member RenameNgrFileOnExport : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.RootsForbiddenForDirectSaving

Proprietà DedVarsRootsForbiddenForDirectSaving
Lista di root nelle quali non è possibile registrare direttamente un documento nel percorso di base

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<DedRoot> RootsForbiddenForDirectSaving { get; }
Public ReadOnly Property RootsForbiddenForDirectSaving As List(Of DedRoot)
    Get
public:
property List<DedRoot^>^ RootsForbiddenForDirectSaving {
    List<DedRoot^>^ get ();
}
member RootsForbiddenForDirectSaving : List<DedRoot> with get

Valore della proprietà

List DedRoot
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.RootSkippedOnCheckOutStructure

Proprietà DedVarsRootSkippedOnCheckOutStructure
Lista dei tipi nei quali il segnaposto sulla anagrafica di destinazione non deve mai essere creato

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<DedRoot> RootSkippedOnCheckOutStructure { get; }
Public ReadOnly Property RootSkippedOnCheckOutStructure As List(Of DedRoot)
    Get
public:
property List<DedRoot^>^ RootSkippedOnCheckOutStructure {
    List<DedRoot^>^ get ();
}
member RootSkippedOnCheckOutStructure : List<DedRoot> with get

Valore della proprietà

List DedRoot
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.RootsRecognizedOnDbSave

Proprietà DedVarsRootsRecognizedOnDbSave
Lista di root sulle quali effettuare il riconosci invece di un import in fase di salvataggio.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<DedRoot> RootsRecognizedOnDbSave { get; }
Public ReadOnly Property RootsRecognizedOnDbSave As List(Of DedRoot)
    Get
public:
property List<DedRoot^>^ RootsRecognizedOnDbSave {
    List<DedRoot^>^ get ();
}
member RootsRecognizedOnDbSave : List<DedRoot> with get

Valore della proprietà

List DedRoot
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.RootTypeSkippedOnCheckOutStructure

Proprietà DedVarsRootTypeSkippedOnCheckOutStructure
Lista dei tipi nei quali il segnaposto sulla anagrafica di destinazione non deve mai essere creato

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<DedRootRootTypeEnum> RootTypeSkippedOnCheckOutStructure { get; }
Public ReadOnly Property RootTypeSkippedOnCheckOutStructure As List(Of DedRootRootTypeEnum)
    Get
public:
property List<DedRootRootTypeEnum>^ RootTypeSkippedOnCheckOutStructure {
    List<DedRootRootTypeEnum>^ get ();
}
member RootTypeSkippedOnCheckOutStructure : List<DedRootRootTypeEnum> with get

Valore della proprietà

List DedRootRootTypeEnum
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.SalvaDistMultiLiv

Proprietà DedVarsSalvaDistMultiLiv
Restituisce il valore della variabile SalvaDistMultiLiv in base alla piattaforma (è in Top e TopInv). Di default è true per consentire il salvataggio monolivello.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool SalvaDistMultiLiv { get; }
Public ReadOnly Property SalvaDistMultiLiv As Boolean
    Get
public:
property bool SalvaDistMultiLiv {
    bool get ();
}
member SalvaDistMultiLiv : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.SilentUpdateDedDisOnOpen

Proprietà DedVarsSilentUpdateDedDisOnOpen
Restituisce se non visualizzare il messaggio di avvertimento all'apertura di un file nel quale viene aggiornato il DED_DIS perché incoerente con la sua posizione ed il suo nome. Di default è false.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool SilentUpdateDedDisOnOpen { get; }
Public ReadOnly Property SilentUpdateDedDisOnOpen As Boolean
    Get
public:
property bool SilentUpdateDedDisOnOpen {
    bool get ();
}
member SilentUpdateDedDisOnOpen : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.SkipUpdateAttribList

Proprietà DedVarsSkipUpdateAttribList
Restituisce la lista degli attributi che non devono essere aggiornati nel Database al salvataggio di un disegno.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> SkipUpdateAttribList { get; }
Public ReadOnly Property SkipUpdateAttribList As List(Of String)
    Get
public:
property List<String^>^ SkipUpdateAttribList {
    List<String^>^ get ();
}
member SkipUpdateAttribList : List<string> with get

Valore della proprietà

List String
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.SmtpAlias

Proprietà DedVarsSmtpAlias
Restituisce il valore di default per la mail del mittente Smtp.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string SmtpAlias { get; }
Public ReadOnly Property SmtpAlias As String
    Get
public:
property String^ SmtpAlias {
    String^ get ();
}
member SmtpAlias : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.SmtpEmail

Proprietà DedVarsSmtpEmail
Restituisce il valore di default per l'alias Smtp.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string SmtpEmail { get; }
Public ReadOnly Property SmtpEmail As String
    Get
public:
property String^ SmtpEmail {
    String^ get ();
}
member SmtpEmail : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.SmtpEnableSsl

Proprietà DedVarsSmtpEnableSsl
Restituisce il valore di default per l'abilitazione SSL in Smtp.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool SmtpEnableSsl { get; }
Public ReadOnly Property SmtpEnableSsl As Boolean
    Get
public:
property bool SmtpEnableSsl {
    bool get ();
}
member SmtpEnableSsl : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.SmtpHost

Proprietà DedVarsSmtpHost
Restituisce il valore di default per la host Smtp.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string SmtpHost { get; }
Public ReadOnly Property SmtpHost As String
    Get
public:
property String^ SmtpHost {
    String^ get ();
}
member SmtpHost : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.SmtpPort

Proprietà DedVarsSmtpPort
Restituisce il valore di default per la porta Smtp.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int SmtpPort { get; }
Public ReadOnly Property SmtpPort As Integer
    Get
public:
property int SmtpPort {
    int get ();
}
member SmtpPort : int with get

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.SmtpPwd

Proprietà DedVarsSmtpPwd
Restituisce il valore di default per la password Smtp.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string SmtpPwd { get; }
Public ReadOnly Property SmtpPwd As String
    Get
public:
property String^ SmtpPwd {
    String^ get ();
}
member SmtpPwd : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.SmtpUser

Proprietà DedVarsSmtpUser
Restituisce il valore di default per l'utente Smtp.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string SmtpUser { get; }
Public ReadOnly Property SmtpUser As String
    Get
public:
property String^ SmtpUser {
    String^ get ();
}
member SmtpUser : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.SparePartManagementActive

Proprietà DedVarsSparePartManagementActive
Restituisce se è attiva la gestione dei ricambi.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool SparePartManagementActive { get; }
Public ReadOnly Property SparePartManagementActive As Boolean
    Get
public:
property bool SparePartManagementActive {
    bool get ();
}
member SparePartManagementActive : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.TopTabRevActive

Proprietà DedVarsTopTabRevActive

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool TopTabRevActive { get; }
Public ReadOnly Property TopTabRevActive As Boolean
    Get
public:
property bool TopTabRevActive {
    bool get ();
}
member TopTabRevActive : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.TopTabRevDrawingCurrent

Proprietà DedVarsTopTabRevDrawingCurrent
Restituisce il valore della variabile TopTabRevDrawingCurrent indicante se disegnare, nella tabella delle revisioni, anche la revisione corrente. Di default è true.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool TopTabRevDrawingCurrent { get; }
Public ReadOnly Property TopTabRevDrawingCurrent As Boolean
    Get
public:
property bool TopTabRevDrawingCurrent {
    bool get ();
}
member TopTabRevDrawingCurrent : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.TopTabRevIncludeFirstRevIfNotRevDefZero

Proprietà DedVarsTopTabRevIncludeFirstRevIfNotRevDefZero
Restituisce il valore della variabile TopTabRevIncludeFirstRevIfNotRevDefZero indicante se disegnare, nella tabella delle revisioni, anche la prima anagrafica se la sua revisione è diversa dalla revisione di default. Di default è false.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool TopTabRevIncludeFirstRevIfNotRevDefZero { get; }
Public ReadOnly Property TopTabRevIncludeFirstRevIfNotRevDefZero As Boolean
    Get
public:
property bool TopTabRevIncludeFirstRevIfNotRevDefZero {
    bool get ();
}
member TopTabRevIncludeFirstRevIfNotRevDefZero : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.TopTabRevNumMaxToShow

Proprietà DedVarsTopTabRevNumMaxToShow
Restituisce il valore della variabile TopTabRevNumMaxToShow indicante il numero di revisione massime da mostrare nella tabella. Di default è 0 (ovvero senza limite)

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int TopTabRevNumMaxToShow { get; }
Public ReadOnly Property TopTabRevNumMaxToShow As Integer
    Get
public:
property int TopTabRevNumMaxToShow {
    int get ();
}
member TopTabRevNumMaxToShow : int with get

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.TransferManagerFtpBasePath

Proprietà DedVarsTransferManagerFtpBasePath
Nelle impostazioni FTP del transfer manager rappresenta il percorso di base per i trasferimenti

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string TransferManagerFtpBasePath { get; set; }
Public Property TransferManagerFtpBasePath As String
    Get
    Set
public:
property String^ TransferManagerFtpBasePath {
    String^ get ();
    void set (String^ value);
}
member TransferManagerFtpBasePath : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.TransferManagerFtpHost

Proprietà DedVarsTransferManagerFtpHost
Nelle impostazioni FTP del transfer manager rappresenta l'host name

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string TransferManagerFtpHost { get; set; }
Public Property TransferManagerFtpHost As String
    Get
    Set
public:
property String^ TransferManagerFtpHost {
    String^ get ();
    void set (String^ value);
}
member TransferManagerFtpHost : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.TransferManagerFtpPassword

Proprietà DedVarsTransferManagerFtpPassword
Nelle impostazioni FTP del transfer manager rappresenta la password

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string TransferManagerFtpPassword { get; set; }
Public Property TransferManagerFtpPassword As String
    Get
    Set
public:
property String^ TransferManagerFtpPassword {
    String^ get ();
    void set (String^ value);
}
member TransferManagerFtpPassword : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.TransferManagerFtpPort

Proprietà DedVarsTransferManagerFtpPort
Nelle impostazioni FTP del transfer manager rappresenta la porta

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string TransferManagerFtpPort { get; set; }
Public Property TransferManagerFtpPort As String
    Get
    Set
public:
property String^ TransferManagerFtpPort {
    String^ get ();
    void set (String^ value);
}
member TransferManagerFtpPort : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.TransferManagerFtpUser

Proprietà DedVarsTransferManagerFtpUser
Nelle impostazioni FTP del transfer manager rappresenta l'utente

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string TransferManagerFtpUser { get; set; }
Public Property TransferManagerFtpUser As String
    Get
    Set
public:
property String^ TransferManagerFtpUser {
    String^ get ();
    void set (String^ value);
}
member TransferManagerFtpUser : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.TransferManagerOnlineMode

Proprietà DedVarsTransferManagerOnlineMode
Restituisce o imposta la modalità di connessione online attiva del transfer manager

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTransferManagerDedTransferManagerOnlineMode TransferManagerOnlineMode { get; set; }
Public Property TransferManagerOnlineMode As DedTransferManagerDedTransferManagerOnlineMode
    Get
    Set
public:
property DedTransferManagerDedTransferManagerOnlineMode TransferManagerOnlineMode {
    DedTransferManagerDedTransferManagerOnlineMode get ();
    void set (DedTransferManagerDedTransferManagerOnlineMode value);
}
member TransferManagerOnlineMode : DedTransferManagerDedTransferManagerOnlineMode with get, set

Valore della proprietà

DedTransferManagerDedTransferManagerOnlineMode
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Proprietà DedVars.UsersMode

Proprietà DedVarsUsersMode
Restituisce se è attiva la gestione degli utenti. Di default è false.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool UsersMode { get; }
Public ReadOnly Property UsersMode As Boolean
    Get
public:
property bool UsersMode {
    bool get ();
}
member UsersMode : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Metodi di DedVars

Il tipo DedVars espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Add | Aggiunge un nuovo elemento alla collezione. Non verifica se esista già un altro elemento con stesse caratteristiche.
Metodo protetto | AddForClone | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto SENZA MODIFICARNE LO STATO. Le classi derivate potranno utilizzare questo metodo per clonare la collezione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddNewElement | DI USO INTERNO. Aggiunge un elemento alla lista rendendo dirty l'oggetto. L'elemento viene aggiunto con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere un elemento alla lista. Dovranno loro stesse avere un metodo pubblico Add() che prenda i parametri necessari alla costruzione dell'oggetto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddRangeNewElement | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi rendendo dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere più elementi alla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddUnModified | Ovverride per la gestione della cache delle variabili (Sovrascrive DedDbCollectionBaseTAddUnModified(T))
Metodo pubblico | Clear | Elimina tutti gli elementi dalla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ClearRefresh | Svuota la lista impostando Dirty = false. Di fatto permette di effettuare un refresh della lista e quindi di ricaricarla. Serve per svuotare la lista e reinizializzarla da capo. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Contains(T) | Verifica l'esistenza di un valore all'interno della lista degli elementi. Le classi derivate devono effettuarne l'override nel caso in cui l'elemento non implementi GetHashCode() per l'uso all'interno dei dizionarii. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Contains(String, ClientApplicationEnum) | Implementa la funzione Contains.
Metodo pubblico | CopyTo | Copia un range di elementi in un array. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | CreateDeleteCommand | Crea, inizializza e restituisce il comando per l'eliminazione di un elemento. (Sovrascrive DedDbCollectionBaseTCreateDeleteCommand(T))
Metodo protetto | CreateInsertCommand | Crea, inizializza e restituisce il comando per l'inserimento di un elemento. (Sovrascrive DedDbCollectionBaseTCreateInsertCommand(T))
Metodo protetto | CreateUpdateCommand | Aggiorna le informazioni di un elemento. (Sovrascrive DedDbCollectionBaseTCreateUpdateCommand(T))
Metodo pubblico | CustomSort | Ordina la lista in base al comparatore passato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteDeleteItem | Esegue l'eliminazione di un elemento. Crea il comando tramite il metodo CreateDeleteCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteInsertItem | Esegue l'inserimento di un elemento. Crea il comando tramite il metodo CreateInsertCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteUpdateItem | Esegue l'aggiornamento di un elemento. Crea il comando tramite il metodo CreateUpdateCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Find | Restituisce l'oggetto cercato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FindAll | Restitusice la lista degli elementi che corrispondono al predicato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | GetDbIndex | Restituisce l'indice dell'elemento passato, da utilizzare nelle clausole where di aggiornamento/eliminazione. (Sovrascrive DedDbCollectionBaseTGetDbIndex(T))
Metodo pubblico | GetEnumerator | Restituisce l'enumeratore della collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | GetVal(String) | Restituisce il valore della variabile individuata dal nome e nel gruppo General. Restituisce null se la variabile non viene trovata o se questa ha valore null.
Metodo pubblico | GetVal(String, ClientApplicationEnum) | Restituisce il valore della variabile individuata dal nome e dal gruppo di appartenenza. Restituisce null se la variabile non viene trovata o se questa ha valore null.
Metodo pubblico | GetVal(String, Object) | Restituisce il valore della variabile individuata dal nome e nel gruppo General. Restituisce null se la variabile non viene trovata o se questa ha valore null.
Metodo pubblico | GetVal(String, ClientApplicationEnum, Object) | Restituisce il valore della variabile individuata dal nome e dal gruppo di appartenenza. Restituisce null se la variabile non viene trovata o se questa ha valore null.
Metodo pubblico | GetVar(String) | Restituisce l'oggetto DedVar individuandolo tramite il nome appartenente al gruppo General. Restituisce null se non esiste.
Metodo pubblico | GetVar(String, ClientApplicationEnum) | Restituisce l'oggetto DedVar individuandolo tramite il nome ed il gruppo di appartenenza. Restituisce null se non esiste.
Metodo pubblico | IndexOf(T) | Restituisce l'indice dell'elemento richiesto. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | IndexOf(String, ClientApplicationEnum) | Implementa la funzione IndexOf.
Metodo pubblico | IndexOf(DedVar, String, ClientApplicationEnum) | Restuitisce l'indice della variabile all'interno della lista se non sono me stesso.
Metodo protetto | InitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InsertUnModified | DI USO INTERNO. Inserisce un elemento alla lista senza rendere dirty l'oggetto, all'indice specificato. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Item(Int32) | Restituisce l'elemento iesimo della lista. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Item(String, ClientApplicationEnum) | Implementa la funzione Item.
Metodo pubblico | Move(Int32, Boolean) | Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean, Int32) | Sposta l'elemento dell'indice passato prima o dopo del numero di posizioni passate. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSave | Metodo Template chiamato dopo il salvataggio avvenuto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSaveNoChanges | Metodo Template chiamato dopo il salvataggio senza modifiche. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnBeforeSave | Metodo Template chiamato prima del salvataggio. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(T) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(DedEditableObjectT) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(T) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(DedEditableObjectT) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ReInitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Remove | Elimina un elemento dalla collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Ripristina | Verifica che l'elemento sia presente negli eliminati e lo toglie da lì e lo riaggiunge in coda alla lista degli elementi validi. Solleva una eccezione se l'elemento è già presente nella lista e AllowsDuplicates = false. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Save | Salva l'oggetto con tutta la sua lista, solo se questo risulta dirty. (Ereditato da DedDbCollectionBaseT)
Torna su
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Metodo DedVars.Add

Metodo DedVarsAdd
Aggiunge un nuovo elemento alla collezione. Non verifica se esista già un altro elemento con stesse caratteristiche.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedVar Add(
    ClientApplicationEnum gruppo,
    string nome,
    Object valore,
    string descrizione,
    bool modificabile,
    string tipodato,
    bool hidden
)
Public Function Add (
    gruppo As ClientApplicationEnum,
    nome As String,
    valore As Object,
    descrizione As String,
    modificabile As Boolean,
    tipodato As String,
    hidden As Boolean
) As DedVar
public:
DedVar^ Add(
    ClientApplicationEnum gruppo,
    String^ nome,
    Object^ valore,
    String^ descrizione,
    bool modificabile,
    String^ tipodato,
    bool hidden
)
member Add :
        gruppo : ClientApplicationEnum *
        nome : string *
        valore : Object *
        descrizione : string *
        modificabile : bool *
        tipodato : string *
        hidden : bool -> DedVar

Parametri

gruppo ClientApplicationEnum
Gruppo di appartenenza della variabile.
nome String
Nome della variabile.
valore Object
Valore della variabile.
descrizione String
Descrizione della variabile.
modificabile Boolean
Modificabilità della variabile.
tipodato String
Tipo dato della variabile.
hidden Boolean

Valore di ritorno

DedVar
Restitusice l'elemento appena creato ed aggiunto.
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Metodo DedVars.AddUnModified

Metodo DedVarsAddUnModified
Ovverride per la gestione della cache delle variabili

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal override void AddUnModified(
    DedVar item
)
Protected Friend Overrides Sub AddUnModified (
    item As DedVar
)
protected public:
virtual void AddUnModified(
    DedVar^ item
) override
abstract AddUnModified :
        item : DedVar -> unit
override AddUnModified :
        item : DedVar -> unit

Parametri

item DedVar
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Metodo DedVars.Contains

Metodo DedVarsContains
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Contains(T) | Verifica l'esistenza di un valore all'interno della lista degli elementi. Le classi derivate devono effettuarne l'override nel caso in cui l'elemento non implementi GetHashCode() per l'uso all'interno dei dizionarii.
Metodo pubblico | Contains(String, ClientApplicationEnum) | Implementa la funzione Contains.
Torna su
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Metodo DedVars.Contains(String, ClientApplicationEnum)

Metodo DedVarsContains(String, ClientApplicationEnum)
Implementa la funzione Contains.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Contains(
    string nome,
    ClientApplicationEnum gruppo
)
Public Function Contains (
    nome As String,
    gruppo As ClientApplicationEnum
) As Boolean
public:
bool Contains(
    String^ nome,
    ClientApplicationEnum gruppo
)
member Contains :
        nome : string *
        gruppo : ClientApplicationEnum -> bool

Parametri

nome String
Nome della variabile.
gruppo ClientApplicationEnum
Gruppo al quale appartiene la variabile.

Valore di ritorno

Boolean
Se la variabile è all'interno della lista.
Vedi anche

Documentazione

Classe DedVars
Overload di Contains
Namespace DedNet.Core


Metodo DedVars.CreateDeleteCommand

Metodo DedVarsCreateDeleteCommand
Crea, inizializza e restituisce il comando per l'eliminazione di un elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSDeleteCommand CreateDeleteCommand(
    DedVar item
)
Protected Overrides Function CreateDeleteCommand (
    item As DedVar
) As QSDeleteCommand
protected:
virtual QSDeleteCommand^ CreateDeleteCommand(
    DedVar^ item
) override
abstract CreateDeleteCommand :
        item : DedVar -> QSDeleteCommand
override CreateDeleteCommand :
        item : DedVar -> QSDeleteCommand

Parametri

item DedVar
Elemento da utilizzare per inizializzare il comando.

Valore di ritorno

QSDeleteCommand
Il comando inizializzato, pronto per essere eseguito.
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Metodo DedVars.CreateInsertCommand

Metodo DedVarsCreateInsertCommand
Crea, inizializza e restituisce il comando per l'inserimento di un elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSInsertCommand CreateInsertCommand(
    DedVar item
)
Protected Overrides Function CreateInsertCommand (
    item As DedVar
) As QSInsertCommand
protected:
virtual QSInsertCommand^ CreateInsertCommand(
    DedVar^ item
) override
abstract CreateInsertCommand :
        item : DedVar -> QSInsertCommand
override CreateInsertCommand :
        item : DedVar -> QSInsertCommand

Parametri

item DedVar
Elemento da utilizzare per inizializzare il comando.

Valore di ritorno

QSInsertCommand
Il comando inizializzato, pronto per essere eseguito.
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Metodo DedVars.CreateUpdateCommand

Metodo DedVarsCreateUpdateCommand
Aggiorna le informazioni di un elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSUpdateCommand CreateUpdateCommand(
    DedVar item
)
Protected Overrides Function CreateUpdateCommand (
    item As DedVar
) As QSUpdateCommand
protected:
virtual QSUpdateCommand^ CreateUpdateCommand(
    DedVar^ item
) override
abstract CreateUpdateCommand :
        item : DedVar -> QSUpdateCommand
override CreateUpdateCommand :
        item : DedVar -> QSUpdateCommand

Parametri

item DedVar
Elemento da aggiornare.

Valore di ritorno

QSUpdateCommand
Il comando inizializzato, pronto per essere eseguito.
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Metodo DedVars.GetDbIndex

Metodo DedVarsGetDbIndex
Restituisce l'indice dell'elemento passato, da utilizzare nelle clausole where di aggiornamento/eliminazione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override Object GetDbIndex(
    DedVar item
)
Protected Overrides Function GetDbIndex (
    item As DedVar
) As Object
protected:
virtual Object^ GetDbIndex(
    DedVar^ item
) override
abstract GetDbIndex :
        item : DedVar -> Object
override GetDbIndex :
        item : DedVar -> Object

Parametri

item DedVar
Elemento del quale restituire l'indice.

Valore di ritorno

Object
Restituisce l'indice dell'elemento oppure null.
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Metodo DedVars.GetVal

Metodo DedVarsGetVal
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | GetVal(String) | Restituisce il valore della variabile individuata dal nome e nel gruppo General. Restituisce null se la variabile non viene trovata o se questa ha valore null.
Metodo pubblico | GetVal(String, ClientApplicationEnum) | Restituisce il valore della variabile individuata dal nome e dal gruppo di appartenenza. Restituisce null se la variabile non viene trovata o se questa ha valore null.
Metodo pubblico | GetVal(String, Object) | Restituisce il valore della variabile individuata dal nome e nel gruppo General. Restituisce null se la variabile non viene trovata o se questa ha valore null.
Metodo pubblico | GetVal(String, ClientApplicationEnum, Object) | Restituisce il valore della variabile individuata dal nome e dal gruppo di appartenenza. Restituisce null se la variabile non viene trovata o se questa ha valore null.
Torna su
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Metodo DedVars.GetVal(String)

Metodo DedVarsGetVal(String)
Restituisce il valore della variabile individuata dal nome e nel gruppo General. Restituisce null se la variabile non viene trovata o se questa ha valore null.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object GetVal(
    string nome
)
Public Function GetVal (
    nome As String
) As Object
public:
Object^ GetVal(
    String^ nome
)
member GetVal :
        nome : string -> Object

Parametri

nome String
Nome della variabile.

Valore di ritorno

Object
Valore della variabile.
Vedi anche

Documentazione

Classe DedVars
Overload di GetVal
Namespace DedNet.Core


Metodo DedVars.GetVal(String, ClientApplicationEnum)

Metodo DedVarsGetVal(String, ClientApplicationEnum)
Restituisce il valore della variabile individuata dal nome e dal gruppo di appartenenza. Restituisce null se la variabile non viene trovata o se questa ha valore null.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object GetVal(
    string nome,
    ClientApplicationEnum gruppo
)
Public Function GetVal (
    nome As String,
    gruppo As ClientApplicationEnum
) As Object
public:
Object^ GetVal(
    String^ nome,
    ClientApplicationEnum gruppo
)
member GetVal :
        nome : string *
        gruppo : ClientApplicationEnum -> Object

Parametri

nome String
Nome della variabile.
gruppo ClientApplicationEnum
Gruppo di appartenenza.

Valore di ritorno

Object
Valore della variabile.
Vedi anche

Documentazione

Classe DedVars
Overload di GetVal
Namespace DedNet.Core


Metodo DedVars.GetVal(String, Object)

Metodo DedVarsGetVal(String, Object)
Restituisce il valore della variabile individuata dal nome e nel gruppo General. Restituisce null se la variabile non viene trovata o se questa ha valore null.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object GetVal(
    string nome,
    Object defval
)
Public Function GetVal (
    nome As String,
    defval As Object
) As Object
public:
Object^ GetVal(
    String^ nome,
    Object^ defval
)
member GetVal :
        nome : string *
        defval : Object -> Object

Parametri

nome String
Nome della variabile.
defval Object
Valore di default da restituire in caso di assenza variabile.

Valore di ritorno

Object
Valore della variabile.
Vedi anche

Documentazione

Classe DedVars
Overload di GetVal
Namespace DedNet.Core


Metodo DedVars.GetVal(String, ClientApplicationEnum, Object)

Metodo DedVarsGetVal(String, ClientApplicationEnum, Object)
Restituisce il valore della variabile individuata dal nome e dal gruppo di appartenenza. Restituisce null se la variabile non viene trovata o se questa ha valore null.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object GetVal(
    string nome,
    ClientApplicationEnum gruppo,
    Object defval
)
Public Function GetVal (
    nome As String,
    gruppo As ClientApplicationEnum,
    defval As Object
) As Object
public:
Object^ GetVal(
    String^ nome,
    ClientApplicationEnum gruppo,
    Object^ defval
)
member GetVal :
        nome : string *
        gruppo : ClientApplicationEnum *
        defval : Object -> Object

Parametri

nome String
Nome della variabile.
gruppo ClientApplicationEnum
Gruppo di appartenenza.
defval Object
Valore di default da restituire in caso di assenza variabile.

Valore di ritorno

Object
Valore della variabile.
Vedi anche

Documentazione

Classe DedVars
Overload di GetVal
Namespace DedNet.Core


Metodo DedVars.GetVar

Metodo DedVarsGetVar
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | GetVar(String) | Restituisce l'oggetto DedVar individuandolo tramite il nome appartenente al gruppo General. Restituisce null se non esiste.
Metodo pubblico | GetVar(String, ClientApplicationEnum) | Restituisce l'oggetto DedVar individuandolo tramite il nome ed il gruppo di appartenenza. Restituisce null se non esiste.
Torna su
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Metodo DedVars.GetVar(String)

Metodo DedVarsGetVar(String)
Restituisce l'oggetto DedVar individuandolo tramite il nome appartenente al gruppo General. Restituisce null se non esiste.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedVar GetVar(
    string nome
)
Public Function GetVar (
    nome As String
) As DedVar
public:
DedVar^ GetVar(
    String^ nome
)
member GetVar :
        nome : string -> DedVar

Parametri

nome String
Nome della variabile.

Valore di ritorno

DedVar
Restituisce null se non esiste.
Vedi anche

Documentazione

Classe DedVars
Overload di GetVar
Namespace DedNet.Core


Metodo DedVars.GetVar(String, ClientApplicationEnum)

Metodo DedVarsGetVar(String, ClientApplicationEnum)
Restituisce l'oggetto DedVar individuandolo tramite il nome ed il gruppo di appartenenza. Restituisce null se non esiste.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedVar GetVar(
    string nome,
    ClientApplicationEnum gruppo
)
Public Function GetVar (
    nome As String,
    gruppo As ClientApplicationEnum
) As DedVar
public:
DedVar^ GetVar(
    String^ nome,
    ClientApplicationEnum gruppo
)
member GetVar :
        nome : string *
        gruppo : ClientApplicationEnum -> DedVar

Parametri

nome String
Nome della variabile.
gruppo ClientApplicationEnum
Gruppo di appartenenza della variabile.

Valore di ritorno

DedVar
Restituisce null se non esiste.
Vedi anche

Documentazione

Classe DedVars
Overload di GetVar
Namespace DedNet.Core


Metodo DedVars.IndexOf

Metodo DedVarsIndexOf
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | IndexOf(T) | Restituisce l'indice dell'elemento richiesto.
Metodo pubblico | IndexOf(String, ClientApplicationEnum) | Implementa la funzione IndexOf.
Metodo pubblico | IndexOf(DedVar, String, ClientApplicationEnum) | Restuitisce l'indice della variabile all'interno della lista se non sono me stesso.
Torna su
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Metodo DedVars.IndexOf(String, ClientApplicationEnum)

Metodo DedVarsIndexOf(String, ClientApplicationEnum)
Implementa la funzione IndexOf.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int IndexOf(
    string nome,
    ClientApplicationEnum gruppo
)
Public Function IndexOf (
    nome As String,
    gruppo As ClientApplicationEnum
) As Integer
public:
int IndexOf(
    String^ nome,
    ClientApplicationEnum gruppo
)
member IndexOf :
        nome : string *
        gruppo : ClientApplicationEnum -> int

Parametri

nome String
Nome della variabile.
gruppo ClientApplicationEnum
Gruppo al quale appartiene la variabile.

Valore di ritorno

Int32
Indice della variabile all'interno della lista.
Vedi anche

Documentazione

Classe DedVars
Overload di IndexOf
Namespace DedNet.Core


Metodo DedVars.IndexOf(DedVar, String, ClientApplicationEnum)

Metodo DedVarsIndexOf(DedVar, String, ClientApplicationEnum)
Restuitisce l'indice della variabile all'interno della lista se non sono me stesso.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int IndexOf(
    DedVar var,
    string nome,
    ClientApplicationEnum gruppo
)
Public Function IndexOf (
    var As DedVar,
    nome As String,
    gruppo As ClientApplicationEnum
) As Integer
public:
int IndexOf(
    DedVar^ var,
    String^ nome,
    ClientApplicationEnum gruppo
)
member IndexOf :
        var : DedVar *
        nome : string *
        gruppo : ClientApplicationEnum -> int

Parametri

var DedVar
Variabile in esame.
nome String
Nome della variabile.
gruppo ClientApplicationEnum
Gruppo al quale appartiene la variabile.

Valore di ritorno

Int32
Indice della variabile all'interno della lista.
Vedi anche

Documentazione

Classe DedVars
Overload di IndexOf
Namespace DedNet.Core


Metodo DedVars.Item

Metodo DedVarsItem
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Item(Int32) | Restituisce l'elemento iesimo della lista.
Metodo pubblico | Item(String, ClientApplicationEnum) | Implementa la funzione Item.
Torna su
Vedi anche

Documentazione

Classe DedVars
Namespace DedNet.Core


Metodo DedVars.Item(String, ClientApplicationEnum)

Metodo DedVarsItem(String, ClientApplicationEnum)
Implementa la funzione Item.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedVar Item(
    string nome,
    ClientApplicationEnum gruppo
)
Public Function Item (
    nome As String,
    gruppo As ClientApplicationEnum
) As DedVar
public:
DedVar^ Item(
    String^ nome,
    ClientApplicationEnum gruppo
)
member Item :
        nome : string *
        gruppo : ClientApplicationEnum -> DedVar

Parametri

nome String
Nome della variabile.
gruppo ClientApplicationEnum
Gruppo al quale appartiene la variabile.

Valore di ritorno

DedVar
La variabile ricercata.
Vedi anche

Documentazione

Classe DedVars
Overload di Item
Namespace DedNet.Core


Classe DiscrimDistList
Lista con le informazioni sulle ingformazioni extra.
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList String
DedNet.CoreDiscrimDistList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DiscrimDistList : List<string>
Public Class DiscrimDistList
    Inherits List(Of String)
public ref class DiscrimDistList : public List<String^>
type DiscrimDistList =
    class
        inherit List<string>
    end

Il tipo DiscrimDistList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DiscrimDistList | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Parent | Lista di appartenenza
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Add | Aggiunge un elemento alla lista e notifica la lista di appartenenza
Metodo pubblico | Contains | Ritorna l'oggetto con il nome specificato
Metodo pubblico | GetDiscrimDist | Restituisce la stringa dai valori presenti nella lista.
Metodo pubblico | ParseDiscrimDist | Converte la stringa con i dati in una lista di oggetti.
Metodo pubblico | Remove | Rimuove un elemento e notifica la lista di appartenenza
Torna su
Metodi di estensione
 | Nome | Descrizione
Metodo di estensione pubblico | Contains | Verifica se nella lista è presente l'elemento specificato, considerdanso lo StringComparison indicato. (Definito da ExtensionMethod)
Metodo di estensione pubblico | IndexOf | Ritorna l'indice dell'elemento nella lista, considerdanso lo StringComparison indicato. (Definito da ExtensionMethod)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DiscrimDistList
Costruttore

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DiscrimDistList(
    DedList parent
)
Public Sub New (
    parent As DedList
)
public:
DiscrimDistList(
    DedList^ parent
)
new :
        parent : DedList -> DiscrimDistList

Parametri

parent DedList
Vedi anche

Documentazione

Classe DiscrimDistList
Namespace DedNet.Core


Proprietà di DiscrimDistList

Il tipo DiscrimDistList espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Parent | Lista di appartenenza
Torna su
Vedi anche

Documentazione

Classe DiscrimDistList
Namespace DedNet.Core


Proprietà DiscrimDistList.Parent

Proprietà DiscrimDistListParent
Lista di appartenenza

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedList Parent { get; set; }
Public Property Parent As DedList
    Get
    Set
public:
property DedList^ Parent {
    DedList^ get ();
    void set (DedList^ value);
}
member Parent : DedList with get, set

Valore della proprietà

DedList
Vedi anche

Documentazione

Classe DiscrimDistList
Namespace DedNet.Core


Metodi di DiscrimDistList

Il tipo DiscrimDistList espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Add | Aggiunge un elemento alla lista e notifica la lista di appartenenza
Metodo pubblico | Contains | Ritorna l'oggetto con il nome specificato
Metodo pubblico | GetDiscrimDist | Restituisce la stringa dai valori presenti nella lista.
Metodo pubblico | ParseDiscrimDist | Converte la stringa con i dati in una lista di oggetti.
Metodo pubblico | Remove | Rimuove un elemento e notifica la lista di appartenenza
Torna su
Metodi di estensione
 | Nome | Descrizione
Metodo di estensione pubblico | Contains | Verifica se nella lista è presente l'elemento specificato, considerdanso lo StringComparison indicato. (Definito da ExtensionMethod)
Metodo di estensione pubblico | IndexOf | Ritorna l'indice dell'elemento nella lista, considerdanso lo StringComparison indicato. (Definito da ExtensionMethod)
Torna su
Vedi anche

Documentazione

Classe DiscrimDistList
Namespace DedNet.Core


Metodo DiscrimDistList.Add

Metodo DiscrimDistListAdd
Aggiunge un elemento alla lista e notifica la lista di appartenenza

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Add(
    string item
)
Public Sub Add (
    item As String
)
public:
void Add(
    String^ item
)
member Add :
        item : string -> unit

Parametri

item String
Elemento da aggiungere
Vedi anche

Documentazione

Classe DiscrimDistList
Namespace DedNet.Core


Metodo DiscrimDistList.Contains

Metodo DiscrimDistListContains
Ritorna l'oggetto con il nome specificato

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Contains(
    string name
)
Public Function Contains (
    name As String
) As Boolean
public:
bool Contains(
    String^ name
)
member Contains :
        name : string -> bool

Parametri

name String
Nome dell'elemento da cercare

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DiscrimDistList
Namespace DedNet.Core


Metodo DiscrimDistList.GetDiscrimDist

Metodo DiscrimDistListGetDiscrimDist
Restituisce la stringa dai valori presenti nella lista.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string GetDiscrimDist()
Public Function GetDiscrimDist As String
public:
String^ GetDiscrimDist()
member GetDiscrimDist : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DiscrimDistList
Namespace DedNet.Core


Metodo DiscrimDistList.ParseDiscrimDist

Metodo DiscrimDistListParseDiscrimDist
Converte la stringa con i dati in una lista di oggetti.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ParseDiscrimDist(
    string discrimDistStr
)
Public Sub ParseDiscrimDist (
    discrimDistStr As String
)
public:
void ParseDiscrimDist(
    String^ discrimDistStr
)
member ParseDiscrimDist :
        discrimDistStr : string -> unit

Parametri

discrimDistStr String
Stringa da parsare
Vedi anche

Documentazione

Classe DiscrimDistList
Namespace DedNet.Core


Metodo DiscrimDistList.Remove

Metodo DiscrimDistListRemove
Rimuove un elemento e notifica la lista di appartenenza

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Remove(
    string item
)
Public Sub Remove (
    item As String
)
public:
void Remove(
    String^ item
)
member Remove :
        item : string -> unit

Parametri

item String
Elemento da rimuovere
Vedi anche

Documentazione

Classe DiscrimDistList
Namespace DedNet.Core


Classe DistHeader
Descrive l'intestazione di distinta di un codice. Una intestazione rappresenta una singola revisione di distinta. Per ogni codice padre presente in distinta sono presenti n righe di intestazione quante sono le revisioni di distinta per tale codice. Tabella di riferimento DED_BOM_HEADERS.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDistHeader

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DistHeader
Public Class DistHeader
public ref class DistHeader
type DistHeader = class end

Il tipo DistHeader espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Anagr | Restituisce l'anagrafica di questa intestazione.
Proprietà pubblica | CreationDate | Restituisce la data di creazione di questa revisione di distinta.
Proprietà pubblica | CreationUser | Restituisce l'utente che ha creato questa revisione di distinta.
Proprietà pubblica | DedId | Restituisce il DedId del padre della distinta.
Proprietà pubblica | DedRev | Restituisce il DedRev del padre della distinta.
Proprietà pubblica | Discrim | Restituisce il campo discriminante del padre della distinta.
Proprietà pubblica | DistLock | Restituisce il valore del campo utilizzato per bloccare la distinta in fase di modifica.
Proprietà pubblica | DistRev | Restituisce l'indice di revisione della distinta.
Proprietà pubblica | FakeHeader | Indica se si tratta di un header Fake (legge i suoi Items da FakeItems)
Proprietà pubblica | IsLastRev | Restituisce se si tratti o meno dell'ultima revisione.
Proprietà pubblica | IsLocked | Restituisce se il record sia bloccato (dall'utente corrente o da un altro). Non legge dal Database, controlla solo se è compilato il campo USERLOCK.
Proprietà pubblica | IsLockedByMe | Restituisce se il record sia bloccato dall'utente corrente. Non legge dal Database, controlla solo se è il campo USERLOCK è compilato con il nome utente corrente.
Proprietà pubblica | IsLockedByOther | Restituisce se il record sia bloccato da un utente differente dall'utente corrente. Non legge dal Database, controlla solo se è il campo USERLOCK è compilato e se lo è in modo diverso dall'utente corrente.
Proprietà pubblica | IsNew | Restitusice se l'intestazione sia di nuova creazione.
Proprietà pubblica | Items | Restituisce la distinta di questa intestazione. Restituisce l'insieme degli elementi trovati oppure una collezione vuota se non ce ne sono oppure null se il codice richiesto non è presente in anagrafica.
Proprietà pubblica | LockDate | Restituisce la data nella quale è avvenuto il lock. Se la distinta non è bloccata restitiusce il valore di default della data.
Proprietà pubblica | LockVer | Restituisce il Guid utilizzato per il blocco del record. Se la distinta non è bloccata dall'utente corrente viene restituito Guid.Empty.
Proprietà pubblica | Owner | Restituisce il DistManager di appartenenza.
Proprietà pubblica | QueryDate | Restituisce la data da usare per interrogare il DB
Proprietà pubblica | UserLock | Restituisce il nome dell'utente che ha effettuato il blocco del record.
Proprietà pubblica | ValidDate | Restituisce la data di validità di questa revisione di distinta.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | FreeBom | Rilascia l'uso esclusivo della distinta attualmente caricata.
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | Lock | Esegue il blocco della distinta impostando il campo USERLOCK con il nome dell'utente corrente. Se l'header è nuovo lo crea bloccato, altrimenti blocca quello esistente. Utilizza il campo DISTLOCK attuale per effettuare il blocco in modo da non riuscire in caso di distinta già modificata. Questo metodo non rende dirty l'anagrafica ma bisogna poi sbloccarla attraverso UnLock() oppure con Update().
Metodo pubblico | Refresh | Effettua il Refresh dell'Header
Metodo pubblico | ReserveBom | Metodo che riserva la distinta che si vuole aprire ad uso esclusivo in modo tale da non potera aprire in editazione in un altro dialogo "Editor distinte".
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Metodo pubblico | UnLock | Sblocca la distinta solo se questa era bloccata dall'utente corrente. La sblocca reimpostando il DISTLOCK alla versione precedente il bloccaggio.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di DistHeader

Il tipo DistHeader espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Anagr | Restituisce l'anagrafica di questa intestazione.
Proprietà pubblica | CreationDate | Restituisce la data di creazione di questa revisione di distinta.
Proprietà pubblica | CreationUser | Restituisce l'utente che ha creato questa revisione di distinta.
Proprietà pubblica | DedId | Restituisce il DedId del padre della distinta.
Proprietà pubblica | DedRev | Restituisce il DedRev del padre della distinta.
Proprietà pubblica | Discrim | Restituisce il campo discriminante del padre della distinta.
Proprietà pubblica | DistLock | Restituisce il valore del campo utilizzato per bloccare la distinta in fase di modifica.
Proprietà pubblica | DistRev | Restituisce l'indice di revisione della distinta.
Proprietà pubblica | FakeHeader | Indica se si tratta di un header Fake (legge i suoi Items da FakeItems)
Proprietà pubblica | IsLastRev | Restituisce se si tratti o meno dell'ultima revisione.
Proprietà pubblica | IsLocked | Restituisce se il record sia bloccato (dall'utente corrente o da un altro). Non legge dal Database, controlla solo se è compilato il campo USERLOCK.
Proprietà pubblica | IsLockedByMe | Restituisce se il record sia bloccato dall'utente corrente. Non legge dal Database, controlla solo se è il campo USERLOCK è compilato con il nome utente corrente.
Proprietà pubblica | IsLockedByOther | Restituisce se il record sia bloccato da un utente differente dall'utente corrente. Non legge dal Database, controlla solo se è il campo USERLOCK è compilato e se lo è in modo diverso dall'utente corrente.
Proprietà pubblica | IsNew | Restitusice se l'intestazione sia di nuova creazione.
Proprietà pubblica | Items | Restituisce la distinta di questa intestazione. Restituisce l'insieme degli elementi trovati oppure una collezione vuota se non ce ne sono oppure null se il codice richiesto non è presente in anagrafica.
Proprietà pubblica | LockDate | Restituisce la data nella quale è avvenuto il lock. Se la distinta non è bloccata restitiusce il valore di default della data.
Proprietà pubblica | LockVer | Restituisce il Guid utilizzato per il blocco del record. Se la distinta non è bloccata dall'utente corrente viene restituito Guid.Empty.
Proprietà pubblica | Owner | Restituisce il DistManager di appartenenza.
Proprietà pubblica | QueryDate | Restituisce la data da usare per interrogare il DB
Proprietà pubblica | UserLock | Restituisce il nome dell'utente che ha effettuato il blocco del record.
Proprietà pubblica | ValidDate | Restituisce la data di validità di questa revisione di distinta.
Torna su
Vedi anche

Documentazione

Classe DistHeader
Namespace DedNet.Core


Proprietà DistHeader.Anagr

Proprietà DistHeaderAnagr
Restituisce l'anagrafica di questa intestazione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Anagr { get; }
Public ReadOnly Property Anagr As DedData
    Get
public:
property DedData^ Anagr {
    DedData^ get ();
}
member Anagr : DedData with get

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe DistHeader
Namespace DedNet.Core


Proprietà DistHeader.CreationDate

Proprietà DistHeaderCreationDate
Restituisce la data di creazione di questa revisione di distinta.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DateTime? CreationDate { get; }
Public ReadOnly Property CreationDate As DateTime?
    Get
public:
property Nullable<DateTime> CreationDate {
    Nullable<DateTime> get ();
}
member CreationDate : Nullable<DateTime> with get

Valore della proprietà

Nullable DateTime
Vedi anche

Documentazione

Classe DistHeader
Namespace DedNet.Core


Proprietà DistHeader.CreationUser

Proprietà DistHeaderCreationUser
Restituisce l'utente che ha creato questa revisione di distinta.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string CreationUser { get; }
Public ReadOnly Property CreationUser As String
    Get
public:
property String^ CreationUser {
    String^ get ();
}
member CreationUser : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DistHeader
Namespace DedNet.Core


Proprietà DistHeader.DedId

Proprietà DistHeaderDedId
Restituisce il DedId del padre della distinta.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string DedId { get; }
Public ReadOnly Property DedId As String
    Get
public:
property String^ DedId {
    String^ get ();
}
member DedId : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DistHeader
Namespace DedNet.Core


Proprietà DistHeader.DedRev

Proprietà DistHeaderDedRev
Restituisce il DedRev del padre della distinta.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string DedRev { get; }
Public ReadOnly Property DedRev As String
    Get
public:
property String^ DedRev {
    String^ get ();
}
member DedRev : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DistHeader
Namespace DedNet.Core


Proprietà DistHeader.Discrim

Proprietà DistHeaderDiscrim
Restituisce il campo discriminante del padre della distinta.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Discrim { get; }
Public ReadOnly Property Discrim As String
    Get
public:
property String^ Discrim {
    String^ get ();
}
member Discrim : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DistHeader
Namespace DedNet.Core


Proprietà DistHeader.DistLock

Proprietà DistHeaderDistLock
Restituisce il valore del campo utilizzato per bloccare la distinta in fase di modifica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Guid DistLock { get; }
Public ReadOnly Property DistLock As Guid
    Get
public:
property Guid DistLock {
    Guid get ();
}
member DistLock : Guid with get

Valore della proprietà

Guid
Vedi anche

Documentazione

Classe DistHeader
Namespace DedNet.Core


Proprietà DistHeader.DistRev

Proprietà DistHeaderDistRev
Restituisce l'indice di revisione della distinta.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int DistRev { get; }
Public ReadOnly Property DistRev As Integer
    Get
public:
property int DistRev {
    int get ();
}
member DistRev : int with get

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe DistHeader
Namespace DedNet.Core


Proprietà DistHeader.FakeHeader

Proprietà DistHeaderFakeHeader
Indica se si tratta di un header Fake (legge i suoi Items da FakeItems)

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool FakeHeader { get; set; }
Public Property FakeHeader As Boolean
    Get
    Set
public:
property bool FakeHeader {
    bool get ();
    void set (bool value);
}
member FakeHeader : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DistHeader
Namespace DedNet.Core


Proprietà DistHeader.IsLastRev

Proprietà DistHeaderIsLastRev
Restituisce se si tratti o meno dell'ultima revisione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsLastRev { get; }
Public ReadOnly Property IsLastRev As Boolean
    Get
public:
property bool IsLastRev {
    bool get ();
}
member IsLastRev : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DistHeader
Namespace DedNet.Core


Proprietà DistHeader.IsLocked

Proprietà DistHeaderIsLocked
Restituisce se il record sia bloccato (dall'utente corrente o da un altro). Non legge dal Database, controlla solo se è compilato il campo USERLOCK.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsLocked { get; }
Public ReadOnly Property IsLocked As Boolean
    Get
public:
property bool IsLocked {
    bool get ();
}
member IsLocked : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DistHeader
Namespace DedNet.Core


Proprietà DistHeader.IsLockedByMe

Proprietà DistHeaderIsLockedByMe
Restituisce se il record sia bloccato dall'utente corrente. Non legge dal Database, controlla solo se è il campo USERLOCK è compilato con il nome utente corrente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsLockedByMe { get; }
Public ReadOnly Property IsLockedByMe As Boolean
    Get
public:
property bool IsLockedByMe {
    bool get ();
}
member IsLockedByMe : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DistHeader
Namespace DedNet.Core


Proprietà DistHeader.IsLockedByOther

Proprietà DistHeaderIsLockedByOther
Restituisce se il record sia bloccato da un utente differente dall'utente corrente. Non legge dal Database, controlla solo se è il campo USERLOCK è compilato e se lo è in modo diverso dall'utente corrente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsLockedByOther { get; }
Public ReadOnly Property IsLockedByOther As Boolean
    Get
public:
property bool IsLockedByOther {
    bool get ();
}
member IsLockedByOther : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DistHeader
Namespace DedNet.Core


Proprietà DistHeader.IsNew

Proprietà DistHeaderIsNew
Restitusice se l'intestazione sia di nuova creazione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsNew { get; }
Public ReadOnly Property IsNew As Boolean
    Get
public:
property bool IsNew {
    bool get ();
}
member IsNew : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DistHeader
Namespace DedNet.Core


Proprietà DistHeader.Items

Proprietà DistHeaderItems
Restituisce la distinta di questa intestazione. Restituisce l'insieme degli elementi trovati oppure una collezione vuota se non ce ne sono oppure null se il codice richiesto non è presente in anagrafica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItemCollection Items { get; set; }
Public Property Items As BomItemCollection
    Get
    Set
public:
property BomItemCollection^ Items {
    BomItemCollection^ get ();
    void set (BomItemCollection^ value);
}
member Items : BomItemCollection with get, set

Valore della proprietà

BomItemCollection
Vedi anche

Documentazione

Classe DistHeader
Namespace DedNet.Core


Proprietà DistHeader.LockDate

Proprietà DistHeaderLockDate
Restituisce la data nella quale è avvenuto il lock. Se la distinta non è bloccata restitiusce il valore di default della data.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DateTime? LockDate { get; }
Public ReadOnly Property LockDate As DateTime?
    Get
public:
property Nullable<DateTime> LockDate {
    Nullable<DateTime> get ();
}
member LockDate : Nullable<DateTime> with get

Valore della proprietà

Nullable DateTime
Vedi anche

Documentazione

Classe DistHeader
Namespace DedNet.Core


Proprietà DistHeader.LockVer

Proprietà DistHeaderLockVer
Restituisce il Guid utilizzato per il blocco del record. Se la distinta non è bloccata dall'utente corrente viene restituito Guid.Empty.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Guid LockVer { get; }
Public ReadOnly Property LockVer As Guid
    Get
public:
property Guid LockVer {
    Guid get ();
}
member LockVer : Guid with get

Valore della proprietà

Guid
Vedi anche

Documentazione

Classe DistHeader
Namespace DedNet.Core


Proprietà DistHeader.Owner

Proprietà DistHeaderOwner
Restituisce il DistManager di appartenenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DistManager Owner { get; }
Public ReadOnly Property Owner As DistManager
    Get
public:
property DistManager^ Owner {
    DistManager^ get ();
}
member Owner : DistManager with get

Valore della proprietà

DistManager
Vedi anche

Documentazione

Classe DistHeader
Namespace DedNet.Core


Proprietà DistHeader.QueryDate

Proprietà DistHeaderQueryDate
Restituisce la data da usare per interrogare il DB

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DateTime? QueryDate { get; set; }
Public Property QueryDate As DateTime?
    Get
    Set
public:
property Nullable<DateTime> QueryDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
member QueryDate : Nullable<DateTime> with get, set

Valore della proprietà

Nullable DateTime
Vedi anche

Documentazione

Classe DistHeader
Namespace DedNet.Core


Proprietà DistHeader.UserLock

Proprietà DistHeaderUserLock
Restituisce il nome dell'utente che ha effettuato il blocco del record.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string UserLock { get; }
Public ReadOnly Property UserLock As String
    Get
public:
property String^ UserLock {
    String^ get ();
}
member UserLock : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DistHeader
Namespace DedNet.Core


Proprietà DistHeader.ValidDate

Proprietà DistHeaderValidDate
Restituisce la data di validità di questa revisione di distinta.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DateTime? ValidDate { get; }
Public ReadOnly Property ValidDate As DateTime?
    Get
public:
property Nullable<DateTime> ValidDate {
    Nullable<DateTime> get ();
}
member ValidDate : Nullable<DateTime> with get

Valore della proprietà

Nullable DateTime
Vedi anche

Documentazione

Classe DistHeader
Namespace DedNet.Core


Metodi di DistHeader

Il tipo DistHeader espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | FreeBom | Rilascia l'uso esclusivo della distinta attualmente caricata.
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | Lock | Esegue il blocco della distinta impostando il campo USERLOCK con il nome dell'utente corrente. Se l'header è nuovo lo crea bloccato, altrimenti blocca quello esistente. Utilizza il campo DISTLOCK attuale per effettuare il blocco in modo da non riuscire in caso di distinta già modificata. Questo metodo non rende dirty l'anagrafica ma bisogna poi sbloccarla attraverso UnLock() oppure con Update().
Metodo pubblico | Refresh | Effettua il Refresh dell'Header
Metodo pubblico | ReserveBom | Metodo che riserva la distinta che si vuole aprire ad uso esclusivo in modo tale da non potera aprire in editazione in un altro dialogo "Editor distinte".
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Metodo pubblico | UnLock | Sblocca la distinta solo se questa era bloccata dall'utente corrente. La sblocca reimpostando il DISTLOCK alla versione precedente il bloccaggio.
Torna su
Vedi anche

Documentazione

Classe DistHeader
Namespace DedNet.Core


Metodo DistHeader.Equals

Metodo DistHeaderEquals

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj Object

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DistHeader
Namespace DedNet.Core


Metodo DistHeader.FreeBom

Metodo DistHeaderFreeBom
Rilascia l'uso esclusivo della distinta attualmente caricata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void FreeBom()
Public Sub FreeBom
public:
void FreeBom()
member FreeBom : unit -> unit
Vedi anche

Documentazione

Classe DistHeader
Namespace DedNet.Core


Metodo DistHeader.GetHashCode

Metodo DistHeaderGetHashCode

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DistHeader
Namespace DedNet.Core


Metodo DistHeader.Lock

Metodo DistHeaderLock
Esegue il blocco della distinta impostando il campo USERLOCK con il nome dell'utente corrente. Se l'header è nuovo lo crea bloccato, altrimenti blocca quello esistente. Utilizza il campo DISTLOCK attuale per effettuare il blocco in modo da non riuscire in caso di distinta già modificata. Questo metodo non rende dirty l'anagrafica ma bisogna poi sbloccarla attraverso UnLock() oppure con Update().

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Lock(
    bool ignoreState = false
)
Public Sub Lock (
    Optional ignoreState As Boolean = false
)
public:
void Lock(
    bool ignoreState = false
)
member Lock :
        ?ignoreState : bool
(* Defaults:
        let _ignoreState = defaultArg ignoreState false
*)
-> unit

Parametri

ignoreState Boolean (Optional)
Eccezioni
Eccezione | Condizione
QsException | Il record risulta bloccato da un altro utente.
QsException | Errore verificatosi nell'esecuzione dell'istruzione Insert.
QsException | Errore verificatosi nell'esecuzione dell'istruzione Update.
QsException | Update non riuscito.
Vedi anche

Documentazione

Classe DistHeader
Namespace DedNet.Core


Metodo DistHeader.Refresh

Metodo DistHeaderRefresh
Effettua il Refresh dell'Header

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Refresh()
Public Sub Refresh
public:
void Refresh()
member Refresh : unit -> unit
Vedi anche

Documentazione

Classe DistHeader
Namespace DedNet.Core


Metodo DistHeader.ReserveBom

Metodo DistHeaderReserveBom
Metodo che riserva la distinta che si vuole aprire ad uso esclusivo in modo tale da non potera aprire in editazione in un altro dialogo "Editor distinte".

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ReserveBom(
    DedData data,
    string discrim
)
Public Sub ReserveBom (
    data As DedData,
    discrim As String
)
public:
void ReserveBom(
    DedData^ data,
    String^ discrim
)
member ReserveBom :
        data : DedData *
        discrim : string -> unit

Parametri

data DedData
Anagrafica associata alla distinta che si vuole aprire.
discrim String
Discriminate da usare come tassello nel nome del file
Vedi anche

Documentazione

Classe DistHeader
Namespace DedNet.Core


Metodo DistHeader.ToString

Metodo DistHeaderToString

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DistHeader
Namespace DedNet.Core


Metodo DistHeader.UnLock

Metodo DistHeaderUnLock
Sblocca la distinta solo se questa era bloccata dall'utente corrente. La sblocca reimpostando il DISTLOCK alla versione precedente il bloccaggio.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void UnLock()
Public Sub UnLock
public:
void UnLock()
member UnLock : unit -> unit
Eccezioni
Eccezione | Condizione
QsException | Errore verificatosi nell'esecuzione dell'istruzione di Update.
QsException | Update non riuscito.
Vedi anche

Documentazione

Classe DistHeader
Namespace DedNet.Core


Classe DistHeaderCollection
Collezione di oggetti DistHeader.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDistHeaderCollection

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DistHeaderCollection : ICollection<DistHeader>,
    IEnumerable<DistHeader>, IEnumerable
Public Class DistHeaderCollection
    Implements ICollection(Of DistHeader), IEnumerable(Of DistHeader),
    IEnumerable
public ref class DistHeaderCollection : ICollection<DistHeader^>,
    IEnumerable<DistHeader^>, IEnumerable
type DistHeaderCollection =
    class
        interface ICollection<DistHeader>
        interface IEnumerable<DistHeader>
        interface IEnumerable
    end

Il tipo DistHeaderCollection espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Count | Restituisce il numero di elementi presenti.
Proprietà pubblica | IsReadOnly | Restituisce sempre false.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Add | Aggiunge un elemento alla collezione.
Metodo pubblico | Clear | Svuota la collezione.
Metodo pubblico | Contains | Verifica la presenza di un elemento.
Metodo pubblico | CopyTo | Copia il contenuto in un array.
Metodo pubblico | GetEnumerator | Restituisce l'enumeratore di questa collezione.
Metodo pubblico | Item | Restituisce il DistHeader della posizione richiesta.
Metodo pubblico | Remove | Elimina un elemento dalla collezione.
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | IEnumerableGetEnumerator | Restituisce l'enumeratore di questa collezione.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di DistHeaderCollection

Il tipo DistHeaderCollection espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Count | Restituisce il numero di elementi presenti.
Proprietà pubblica | IsReadOnly | Restituisce sempre false.
Torna su
Vedi anche

Documentazione

Classe DistHeaderCollection
Namespace DedNet.Core


Proprietà DistHeaderCollection.Count

Proprietà DistHeaderCollectionCount
Restituisce il numero di elementi presenti.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
public:
virtual property int Count {
    int get () sealed;
}
abstract Count : int with get
override Count : int with get

Valore della proprietà

Int32

Implementa

ICollectionTCount
Vedi anche

Documentazione

Classe DistHeaderCollection
Namespace DedNet.Core


Proprietà DistHeaderCollection.IsReadOnly

Proprietà DistHeaderCollectionIsReadOnly
Restituisce sempre false.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}
abstract IsReadOnly : bool with get
override IsReadOnly : bool with get

Valore della proprietà

Boolean

Implementa

ICollectionTIsReadOnly
Vedi anche

Documentazione

Classe DistHeaderCollection
Namespace DedNet.Core


Metodi di DistHeaderCollection

Il tipo DistHeaderCollection espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Add | Aggiunge un elemento alla collezione.
Metodo pubblico | Clear | Svuota la collezione.
Metodo pubblico | Contains | Verifica la presenza di un elemento.
Metodo pubblico | CopyTo | Copia il contenuto in un array.
Metodo pubblico | GetEnumerator | Restituisce l'enumeratore di questa collezione.
Metodo pubblico | Item | Restituisce il DistHeader della posizione richiesta.
Metodo pubblico | Remove | Elimina un elemento dalla collezione.
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | IEnumerableGetEnumerator | Restituisce l'enumeratore di questa collezione.
Torna su
Vedi anche

Documentazione

Classe DistHeaderCollection
Namespace DedNet.Core


Metodo DistHeaderCollection.Add

Metodo DistHeaderCollectionAdd
Aggiunge un elemento alla collezione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Add(
    DistHeader item
)
Public Sub Add (
    item As DistHeader
)
public:
virtual void Add(
    DistHeader^ item
) sealed
abstract Add :
        item : DistHeader -> unit
override Add :
        item : DistHeader -> unit

Parametri

item DistHeader
Elemento da aggiungere.

Implementa

ICollectionTAdd(T)
Vedi anche

Documentazione

Classe DistHeaderCollection
Namespace DedNet.Core


Metodo DistHeaderCollection.Clear

Metodo DistHeaderCollectionClear
Svuota la collezione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
virtual void Clear() sealed
abstract Clear : unit -> unit
override Clear : unit -> unit

Implementa

ICollectionTClear
Vedi anche

Documentazione

Classe DistHeaderCollection
Namespace DedNet.Core


Metodo DistHeaderCollection.Contains

Metodo DistHeaderCollectionContains
Verifica la presenza di un elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Contains(
    DistHeader item
)
Public Function Contains (
    item As DistHeader
) As Boolean
public:
virtual bool Contains(
    DistHeader^ item
) sealed
abstract Contains :
        item : DistHeader -> bool
override Contains :
        item : DistHeader -> bool

Parametri

item DistHeader
Elemento da verificare.

Valore di ritorno

Boolean
Restituisce true se l'elemento è presente altrimenti false.

Implementa

ICollectionTContains(T)
Vedi anche

Documentazione

Classe DistHeaderCollection
Namespace DedNet.Core


Metodo DistHeaderCollection.CopyTo

Metodo DistHeaderCollectionCopyTo
Copia il contenuto in un array.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void CopyTo(
    DistHeader[] array,
    int arrayIndex
)
Public Sub CopyTo (
    array As DistHeader(),
    arrayIndex As Integer
)
public:
virtual void CopyTo(
    array<DistHeader^>^ array,
    int arrayIndex
) sealed
abstract CopyTo :
        array : DistHeader[] *
        arrayIndex : int -> unit
override CopyTo :
        array : DistHeader[] *
        arrayIndex : int -> unit

Parametri

array DistHeader
Array nel quale copiare il contenuto.
arrayIndex Int32
Indice di partenza della copia.

Implementa

ICollectionTCopyTo(T, Int32)
Vedi anche

Documentazione

Classe DistHeaderCollection
Namespace DedNet.Core


Metodo DistHeaderCollection.GetEnumerator

Metodo DistHeaderCollectionGetEnumerator
Restituisce l'enumeratore di questa collezione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public IEnumerator<DistHeader> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of DistHeader)
public:
virtual IEnumerator<DistHeader^>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<DistHeader>
override GetEnumerator : unit -> IEnumerator<DistHeader>

Valore di ritorno

IEnumerator DistHeader
Restituisce l'oggetto enumeratore di questa collezione.

Implementa

IEnumerableTGetEnumerator
Vedi anche

Documentazione

Classe DistHeaderCollection
Namespace DedNet.Core


Metodo DistHeaderCollection.IEnumerable.GetEnumerator

Metodo DistHeaderCollectionIEnumerableGetEnumerator
Restituisce l'enumeratore di questa collezione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
IEnumerator IEnumerable.GetEnumerator()
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator

Valore di ritorno

IEnumerator
Restituisce l'oggetto enumeratore di questa collezione.

Implementa

IEnumerableGetEnumerator
Vedi anche

Documentazione

Classe DistHeaderCollection
Namespace DedNet.Core


Metodo DistHeaderCollection.Item

Metodo DistHeaderCollectionItem
Restituisce il DistHeader della posizione richiesta.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DistHeader Item(
    int index
)
Public Function Item (
    index As Integer
) As DistHeader
public:
DistHeader^ Item(
    int index
)
member Item :
        index : int -> DistHeader

Parametri

index Int32
Inidce.

Valore di ritorno

DistHeader
Vedi anche

Documentazione

Classe DistHeaderCollection
Namespace DedNet.Core


Metodo DistHeaderCollection.Remove

Metodo DistHeaderCollectionRemove
Elimina un elemento dalla collezione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Remove(
    DistHeader item
)
Public Function Remove (
    item As DistHeader
) As Boolean
public:
virtual bool Remove(
    DistHeader^ item
) sealed
abstract Remove :
        item : DistHeader -> bool
override Remove :
        item : DistHeader -> bool

Parametri

item DistHeader
Elemento da eliminare.

Valore di ritorno

Boolean
Restituisce true se l'elemento era presente.

Implementa

ICollectionTRemove(T)
Vedi anche

Documentazione

Classe DistHeaderCollection
Namespace DedNet.Core


Classe DistManager
Oggetto per la gestione della distinta. Durante il caricamento mantiene una cache in base al codice padre e la data di interrogazione in modo da non ricaricare la stessa distinta.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDistManager

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DistManager : IDisposable
Public Class DistManager
    Implements IDisposable
public ref class DistManager : IDisposable
type DistManager =
    class
        interface IDisposable
    end

Il tipo DistManager espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'oggetto applicazione di appartenza.
Proprietà pubblica | DirtyBomList | Restituisce la lista delle distinte dirty.
Proprietà pubblica | DistAttrs | Restituisce la lista degli attributi di distinta senza il campo QTA.
Proprietà pubblica | LoadLastAnagrRev | Restituisce o imposta se le distinte richieste siano o meno riferite all'ultima revisione di anagrafica (di default è true).
Proprietà pubblica | LoadLastParent | Indica se raggruppare i padri e visualizzare solo i legami realmente esistenti
Torna su
Metodi
 | Nome | Descrizione
 | CloneDist(DedNetApplication, DedData, DedData, Object, Exception) | Copia la distinta dell'anagrafica di partenza in quella di destinazione. Chiama l'evento DistCloneData nella quale è possibile cambiare i dati e annullare l'inserimento.
 | CloneDist(DedNetApplication, DedData, DedData, Object, Exception, BomCloneMode) | Copia la distinta dell'anagrafica di partenza in quella di destinazione. Chiama l'evento DistCloneData nella quale è possibile cambiare i dati e annullare l'inserimento.
 | CloneDist(DedNetApplication, DedData, DedData, Object, Exception, BomCloneMode, String) | Copia la distinta dell'anagrafica di partenza in quella di destinazione con possibilità di indicare il tipo di distinta da clonare Chiama l'evento DistCloneData nella quale è possibile cambiare i dati e annullare l'inserimento.
Metodo pubblico | CreateHeader(String, String) | Crea e restituisce una nuova distinta, non bloccata. Non occorre specificare il parametro discriminante. Se la distinta esiste già solleva un'eccezione altrimenti ne crea una nuova e la restituisce. La distinta creata esiste solo in memoria, quando si blocca esplicitamente o modificando i suoi figli, viene scritta nel Database e bloccata.
Metodo pubblico | CreateHeader(String, String, String) | Crea e restituisce una nuova distinta, non bloccata. Se la distinta esiste già solleva un'eccezione altrimenti ne crea una nuova e la restituisce. La distinta creata esiste solo in memoria, quando si blocca esplicitamente o modificando i suoi figli, viene scritta nel Database e bloccata.
Metodo pubblico | Dispose | Effettua il dispose dell'oggetto.
Metodo protetto | Dispose(Boolean) | Effettua la liberazione delle risorese gestite e non.
Metodo protetto | Finalize | Distruttore dell'oggetto. (Sovrascrive ObjectFinalize)
Metodo pubblico | FindFirstHeader | Restituisce la prima revisione di distinta presente per il codice specificato.
Metodo pubblico | FindHeader(String) | Restituisce tutte le intestazioni presenti dato l'id passato.
Metodo pubblico | FindHeader(String, String) | Restituisce tutte le intestazioni presenti aventi le caratteristiche specificate ovvero tutte le revisioni di distinta del dato codice.
Metodo pubblico | FindHeader(String, String, Int32) | Restituisce l'intestazione avente le caratteristiche specificate.
Metodo pubblico | FindHeader(String, String, NullableDateTime) | Restituisce l'intestazione di un codice che abbia data di validità maggiore di una certa data, ovvero che risulti valido ad una specifica data.
Metodo pubblico | FindHeader(String, String, String) | Restituisce le intestazioni aventi le caratteristiche specificate.
Metodo pubblico | FindHeader(String, String, Int32, String) | Restituisce l'intestazione avente le caratteristiche specificate.
Metodo pubblico | FindHeader(String, String, NullableDateTime, String) | Restituisce l'intestazione di un codice che abbia data di validità maggiore di una certa data, ovvero che risulti valido ad una specifica data.
Metodo pubblico | FindLastHeader(String, String) | Restituisce l'ultima revisione di distinta presente per il codice specificato. Considera la sola disinta CAD.
Metodo pubblico | FindLastHeader(String, String, String) | Restituisce l'ultima revisione di distinta presente per il codice specificato.
Metodo pubblico | GetAllDistParent |
Metodo pubblico | GetAnagr(String) | Cerca nella cache se è già stata caricata l'ultima revisione dell'anagrafica dell'elemento passato, se la trova la restituisce altrimenti la cerca e la restituisce. Se non la trova restituisce null.
Metodo pubblico | GetAnagr(String, String) | Cerca nella cache se è già stata caricata l'anagrafica dell'elemento passato, se la trova la restituisce altrimenti la cerca e la restituisce. Se non la trova restituisce null.
Metodo pubblico | GetDedRevList | Restituisce la lista delle revisioni (DedRev) del codice specificato per le quali sono presenti delle distinte.
Metodo pubblico | GetDiscrimList | Restituisce la lista dei discriminanti di distinta presenti dato un particolare codice.
Metodo pubblico | GetDistRevList(String, String) | Restituisce la lista delle revisioni di distinta presenti dato un particolare codice.
Metodo pubblico | GetDistRevList(String, String, String) | Restituisce la lista delle revisioni di distinta presenti dato un particolare codice e discriminante.
Metodo pubblico | GetLastAnagWithDist | Restituisce l'ultima revisione di anagrafica con distinta salvata.
Metodo pubblico | GetParentDiscrimList | Restituisce la lista dei discriminanti dei padri dell'elemento.
Metodo pubblico | HasDistImpl(String) | Controlla se il codice passato ha una distinta implosa.
Metodo pubblico | HasDistImpl(String, String) | Controlla se il codice passato ha una distinta implosa.
Metodo pubblico | HasDistImpl(String, String, Boolean) | Controlla se il codice passato ha una distinta implosa.
Metodo pubblico | HasHeader | Restituisce se l'anagrafica ha un header.
Metodo pubblico | ReadDistImpl(String, String) | Legge dal Database la distinta implosa di uno specifico codice all'ultima data di validità, ponendola in cache. Se la distinta è già presente nella cache la restituisce direttamente.
Metodo pubblico | ReadDistImpl(String, String, DateTime) | Legge dal Database la distinta implosa di uno specifico codice valido alla data specificata, ponendola in cache. Se la distinta è già presente nella cache la restituisce direttamente.
Metodo pubblico | ReadDistImpl(String, String, String) | Legge la distinta implosa data l'anagrafica ed il discriminante del tipo distinta.
Metodo pubblico | ReadDistImpl(String, String, String, DateTime) | Legge dal Database la distinta implosa di uno specifico codice valido e relativo tipo distinta alla data specificata, ponendola in cache. Se la distinta è già presente nella cache la restituisce direttamente.
Metodo pubblico | RemoveAllDist | Elimina dal Database tutte le distinte presenti di un determinato padre.
Metodo pubblico | ResetCache | Resetta la cache delle distinte presenti nell'oggetto.
Torna su
Campi
 | Nome | Descrizione
Campo pubblico | MaxQueryDate | Data da utilizzare per la data di validità dei nuovi elementi di distinta.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di DistManager

Il tipo DistManager espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'oggetto applicazione di appartenza.
Proprietà pubblica | DirtyBomList | Restituisce la lista delle distinte dirty.
Proprietà pubblica | DistAttrs | Restituisce la lista degli attributi di distinta senza il campo QTA.
Proprietà pubblica | LoadLastAnagrRev | Restituisce o imposta se le distinte richieste siano o meno riferite all'ultima revisione di anagrafica (di default è true).
Proprietà pubblica | LoadLastParent | Indica se raggruppare i padri e visualizzare solo i legami realmente esistenti
Torna su
Vedi anche

Documentazione

Classe DistManager
Namespace DedNet.Core


Proprietà DistManager.Application

Proprietà DistManagerApplication
Restituisce l'oggetto applicazione di appartenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedNetApplication Application { get; }
Public ReadOnly Property Application As DedNetApplication
    Get
public:
property DedNetApplication^ Application {
    DedNetApplication^ get ();
}
member Application : DedNetApplication with get

Valore della proprietà

DedNetApplication
Vedi anche

Documentazione

Classe DistManager
Namespace DedNet.Core


Proprietà DistManager.DirtyBomList

Proprietà DistManagerDirtyBomList
Restituisce la lista delle distinte dirty.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItemCollection[] DirtyBomList { get; }
Public ReadOnly Property DirtyBomList As BomItemCollection()
    Get
public:
property array<BomItemCollection^>^ DirtyBomList {
    array<BomItemCollection^>^ get ();
}
member DirtyBomList : BomItemCollection[] with get

Valore di ritorno

BomItemCollection
Array delle distinte dirty.
Vedi anche

Documentazione

Classe DistManager
Namespace DedNet.Core


Proprietà DistManager.DistAttrs

Proprietà DistManagerDistAttrs
Restituisce la lista degli attributi di distinta senza il campo QTA.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttr[] DistAttrs { get; }
Public ReadOnly Property DistAttrs As DedAttr()
    Get
public:
property array<DedAttr^>^ DistAttrs {
    array<DedAttr^>^ get ();
}
member DistAttrs : DedAttr[] with get

Valore della proprietà

DedAttr
Vedi anche

Documentazione

Classe DistManager
Namespace DedNet.Core


Proprietà DistManager.LoadLastAnagrRev

Proprietà DistManagerLoadLastAnagrRev
Restituisce o imposta se le distinte richieste siano o meno riferite all'ultima revisione di anagrafica (di default è true).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool LoadLastAnagrRev { get; set; }
Public Property LoadLastAnagrRev As Boolean
    Get
    Set
public:
property bool LoadLastAnagrRev {
    bool get ();
    void set (bool value);
}
member LoadLastAnagrRev : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DistManager
Namespace DedNet.Core


Proprietà DistManager.LoadLastParent

Proprietà DistManagerLoadLastParent
Indica se raggruppare i padri e visualizzare solo i legami realmente esistenti

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool LoadLastParent { get; set; }
Public Property LoadLastParent As Boolean
    Get
    Set
public:
property bool LoadLastParent {
    bool get ();
    void set (bool value);
}
member LoadLastParent : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DistManager
Namespace DedNet.Core


Metodi di DistManager

Il tipo DistManager espone i seguenti membri.

Metodi
 | Nome | Descrizione
 | CloneDist(DedNetApplication, DedData, DedData, Object, Exception) | Copia la distinta dell'anagrafica di partenza in quella di destinazione. Chiama l'evento DistCloneData nella quale è possibile cambiare i dati e annullare l'inserimento.
 | CloneDist(DedNetApplication, DedData, DedData, Object, Exception, BomCloneMode) | Copia la distinta dell'anagrafica di partenza in quella di destinazione. Chiama l'evento DistCloneData nella quale è possibile cambiare i dati e annullare l'inserimento.
 | CloneDist(DedNetApplication, DedData, DedData, Object, Exception, BomCloneMode, String) | Copia la distinta dell'anagrafica di partenza in quella di destinazione con possibilità di indicare il tipo di distinta da clonare Chiama l'evento DistCloneData nella quale è possibile cambiare i dati e annullare l'inserimento.
Metodo pubblico | CreateHeader(String, String) | Crea e restituisce una nuova distinta, non bloccata. Non occorre specificare il parametro discriminante. Se la distinta esiste già solleva un'eccezione altrimenti ne crea una nuova e la restituisce. La distinta creata esiste solo in memoria, quando si blocca esplicitamente o modificando i suoi figli, viene scritta nel Database e bloccata.
Metodo pubblico | CreateHeader(String, String, String) | Crea e restituisce una nuova distinta, non bloccata. Se la distinta esiste già solleva un'eccezione altrimenti ne crea una nuova e la restituisce. La distinta creata esiste solo in memoria, quando si blocca esplicitamente o modificando i suoi figli, viene scritta nel Database e bloccata.
Metodo pubblico | Dispose | Effettua il dispose dell'oggetto.
Metodo protetto | Dispose(Boolean) | Effettua la liberazione delle risorese gestite e non.
Metodo protetto | Finalize | Distruttore dell'oggetto. (Sovrascrive ObjectFinalize)
Metodo pubblico | FindFirstHeader | Restituisce la prima revisione di distinta presente per il codice specificato.
Metodo pubblico | FindHeader(String) | Restituisce tutte le intestazioni presenti dato l'id passato.
Metodo pubblico | FindHeader(String, String) | Restituisce tutte le intestazioni presenti aventi le caratteristiche specificate ovvero tutte le revisioni di distinta del dato codice.
Metodo pubblico | FindHeader(String, String, Int32) | Restituisce l'intestazione avente le caratteristiche specificate.
Metodo pubblico | FindHeader(String, String, NullableDateTime) | Restituisce l'intestazione di un codice che abbia data di validità maggiore di una certa data, ovvero che risulti valido ad una specifica data.
Metodo pubblico | FindHeader(String, String, String) | Restituisce le intestazioni aventi le caratteristiche specificate.
Metodo pubblico | FindHeader(String, String, Int32, String) | Restituisce l'intestazione avente le caratteristiche specificate.
Metodo pubblico | FindHeader(String, String, NullableDateTime, String) | Restituisce l'intestazione di un codice che abbia data di validità maggiore di una certa data, ovvero che risulti valido ad una specifica data.
Metodo pubblico | FindLastHeader(String, String) | Restituisce l'ultima revisione di distinta presente per il codice specificato. Considera la sola disinta CAD.
Metodo pubblico | FindLastHeader(String, String, String) | Restituisce l'ultima revisione di distinta presente per il codice specificato.
Metodo pubblico | GetAllDistParent |
Metodo pubblico | GetAnagr(String) | Cerca nella cache se è già stata caricata l'ultima revisione dell'anagrafica dell'elemento passato, se la trova la restituisce altrimenti la cerca e la restituisce. Se non la trova restituisce null.
Metodo pubblico | GetAnagr(String, String) | Cerca nella cache se è già stata caricata l'anagrafica dell'elemento passato, se la trova la restituisce altrimenti la cerca e la restituisce. Se non la trova restituisce null.
Metodo pubblico | GetDedRevList | Restituisce la lista delle revisioni (DedRev) del codice specificato per le quali sono presenti delle distinte.
Metodo pubblico | GetDiscrimList | Restituisce la lista dei discriminanti di distinta presenti dato un particolare codice.
Metodo pubblico | GetDistRevList(String, String) | Restituisce la lista delle revisioni di distinta presenti dato un particolare codice.
Metodo pubblico | GetDistRevList(String, String, String) | Restituisce la lista delle revisioni di distinta presenti dato un particolare codice e discriminante.
Metodo pubblico | GetLastAnagWithDist | Restituisce l'ultima revisione di anagrafica con distinta salvata.
Metodo pubblico | GetParentDiscrimList | Restituisce la lista dei discriminanti dei padri dell'elemento.
Metodo pubblico | HasDistImpl(String) | Controlla se il codice passato ha una distinta implosa.
Metodo pubblico | HasDistImpl(String, String) | Controlla se il codice passato ha una distinta implosa.
Metodo pubblico | HasDistImpl(String, String, Boolean) | Controlla se il codice passato ha una distinta implosa.
Metodo pubblico | HasHeader | Restituisce se l'anagrafica ha un header.
Metodo pubblico | ReadDistImpl(String, String) | Legge dal Database la distinta implosa di uno specifico codice all'ultima data di validità, ponendola in cache. Se la distinta è già presente nella cache la restituisce direttamente.
Metodo pubblico | ReadDistImpl(String, String, DateTime) | Legge dal Database la distinta implosa di uno specifico codice valido alla data specificata, ponendola in cache. Se la distinta è già presente nella cache la restituisce direttamente.
Metodo pubblico | ReadDistImpl(String, String, String) | Legge la distinta implosa data l'anagrafica ed il discriminante del tipo distinta.
Metodo pubblico | ReadDistImpl(String, String, String, DateTime) | Legge dal Database la distinta implosa di uno specifico codice valido e relativo tipo distinta alla data specificata, ponendola in cache. Se la distinta è già presente nella cache la restituisce direttamente.
Metodo pubblico | RemoveAllDist | Elimina dal Database tutte le distinte presenti di un determinato padre.
Metodo pubblico | ResetCache | Resetta la cache delle distinte presenti nell'oggetto.
Torna su
Vedi anche

Documentazione

Classe DistManager
Namespace DedNet.Core


Metodo DistManager.CloneDist

Metodo DistManagerCloneDist
Lista degli overload
Nome | Descrizione
CloneDist(DedNetApplication, DedData, DedData, Object, Exception) | Copia la distinta dell'anagrafica di partenza in quella di destinazione. Chiama l'evento DistCloneData nella quale è possibile cambiare i dati e annullare l'inserimento.
CloneDist(DedNetApplication, DedData, DedData, Object, Exception, BomCloneMode) | Copia la distinta dell'anagrafica di partenza in quella di destinazione. Chiama l'evento DistCloneData nella quale è possibile cambiare i dati e annullare l'inserimento.
CloneDist(DedNetApplication, DedData, DedData, Object, Exception, BomCloneMode, String) | Copia la distinta dell'anagrafica di partenza in quella di destinazione con possibilità di indicare il tipo di distinta da clonare Chiama l'evento DistCloneData nella quale è possibile cambiare i dati e annullare l'inserimento.
Torna su
Vedi anche

Documentazione

Classe DistManager
Namespace DedNet.Core


Metodo DistManager.CloneDist(DedNetApplication, DedData, DedData, Object, Exception)

Metodo DistManagerCloneDist(DedNetApplication, DedData, DedData, Object, Exception)
Copia la distinta dell'anagrafica di partenza in quella di destinazione. Chiama l'evento DistCloneData nella quale è possibile cambiare i dati e annullare l'inserimento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool CloneDist(
    DedNetApplication app,
    DedData dataFrom,
    DedData dataTo,
    Object sender,
    ref Exception excp
)
Public Shared Function CloneDist (
    app As DedNetApplication,
    dataFrom As DedData,
    dataTo As DedData,
    sender As Object,
    ByRef excp As Exception
) As Boolean
public:
static bool CloneDist(
    DedNetApplication^ app,
    DedData^ dataFrom,
    DedData^ dataTo,
    Object^ sender,
    Exception^% excp
)
static member CloneDist :
        app : DedNetApplication *
        dataFrom : DedData *
        dataTo : DedData *
        sender : Object *
        excp : Exception byref -> bool

Parametri

app DedNetApplication
Applicazione DedNet.
dataFrom DedData
Anagrafica di partenza
dataTo DedData
Anagrafica di destinazione
sender Object
Oggetto usato per l'evento DistCloneData.
excp Exception
Eccezione che viene impostata nel caso si verifichi qualche anomalia.

Valore di ritorno

Boolean
True se riesce altrimenti False
Vedi anche

Documentazione

Classe DistManager
Overload di CloneDist
Namespace DedNet.Core


Metodo DistManager.CloneDist(DedNetApplication, DedData, DedData, Object, Exception, BomCloneMode)

Metodo DistManagerCloneDist(DedNetApplication, DedData, DedData, Object, Exception, BomCloneMode)
Copia la distinta dell'anagrafica di partenza in quella di destinazione. Chiama l'evento DistCloneData nella quale è possibile cambiare i dati e annullare l'inserimento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool CloneDist(
    DedNetApplication app,
    DedData dataFrom,
    DedData dataTo,
    Object sender,
    ref Exception excp,
    BomCloneMode mode
)
Public Shared Function CloneDist (
    app As DedNetApplication,
    dataFrom As DedData,
    dataTo As DedData,
    sender As Object,
    ByRef excp As Exception,
    mode As BomCloneMode
) As Boolean
public:
static bool CloneDist(
    DedNetApplication^ app,
    DedData^ dataFrom,
    DedData^ dataTo,
    Object^ sender,
    Exception^% excp,
    BomCloneMode mode
)
static member CloneDist :
        app : DedNetApplication *
        dataFrom : DedData *
        dataTo : DedData *
        sender : Object *
        excp : Exception byref *
        mode : BomCloneMode -> bool

Parametri

app DedNetApplication
Applicazione DedNet.
dataFrom DedData
Anagrafica di partenza
dataTo DedData
Anagrafica di destinazione
sender Object
Oggetto usato per l'evento DistCloneData.
excp Exception
Eccezione che viene impostata nel caso si verifichi qualche anomalia.
mode BomCloneMode
Tipo di clonazione dei dati di distinta.

Valore di ritorno

Boolean
True se riesce altrimenti False
Vedi anche

Documentazione

Classe DistManager
Overload di CloneDist
Namespace DedNet.Core


Metodo DistManager.CloneDist(DedNetApplication, DedData, DedData, Object, Exception, BomCloneMode, String)

Metodo DistManagerCloneDist(DedNetApplication, DedData, DedData, Object, Exception, BomCloneMode, String)
Copia la distinta dell'anagrafica di partenza in quella di destinazione con possibilità di indicare il tipo di distinta da clonare Chiama l'evento DistCloneData nella quale è possibile cambiare i dati e annullare l'inserimento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool CloneDist(
    DedNetApplication app,
    DedData dataFrom,
    DedData dataTo,
    Object sender,
    ref Exception excp,
    BomCloneMode mode,
    string discr
)
Public Shared Function CloneDist (
    app As DedNetApplication,
    dataFrom As DedData,
    dataTo As DedData,
    sender As Object,
    ByRef excp As Exception,
    mode As BomCloneMode,
    discr As String
) As Boolean
public:
static bool CloneDist(
    DedNetApplication^ app,
    DedData^ dataFrom,
    DedData^ dataTo,
    Object^ sender,
    Exception^% excp,
    BomCloneMode mode,
    String^ discr
)
static member CloneDist :
        app : DedNetApplication *
        dataFrom : DedData *
        dataTo : DedData *
        sender : Object *
        excp : Exception byref *
        mode : BomCloneMode *
        discr : string -> bool

Parametri

app DedNetApplication
Applicazione DedNet.
dataFrom DedData
Anagrafica di partenza
dataTo DedData
Anagrafica di destinazione
sender Object
Oggetto usato per l'evento DistCloneData.
excp Exception
Eccezione che viene impostata nel caso si verifichi qualche anomalia.
mode BomCloneMode
Tipo di clonazione dei dati di distinta.
discr String
Discriminante di distinta

Valore di ritorno

Boolean
True se riesce altrimenti False
Vedi anche

Documentazione

Classe DistManager
Overload di CloneDist
Namespace DedNet.Core


Metodo DistManager.CreateHeader

Metodo DistManagerCreateHeader
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | CreateHeader(String, String) | Crea e restituisce una nuova distinta, non bloccata. Non occorre specificare il parametro discriminante. Se la distinta esiste già solleva un'eccezione altrimenti ne crea una nuova e la restituisce. La distinta creata esiste solo in memoria, quando si blocca esplicitamente o modificando i suoi figli, viene scritta nel Database e bloccata.
Metodo pubblico | CreateHeader(String, String, String) | Crea e restituisce una nuova distinta, non bloccata. Se la distinta esiste già solleva un'eccezione altrimenti ne crea una nuova e la restituisce. La distinta creata esiste solo in memoria, quando si blocca esplicitamente o modificando i suoi figli, viene scritta nel Database e bloccata.
Torna su
Vedi anche

Documentazione

Classe DistManager
Namespace DedNet.Core


Metodo DistManager.CreateHeader(String, String)

Metodo DistManagerCreateHeader(String, String)
Crea e restituisce una nuova distinta, non bloccata. Non occorre specificare il parametro discriminante. Se la distinta esiste già solleva un'eccezione altrimenti ne crea una nuova e la restituisce. La distinta creata esiste solo in memoria, quando si blocca esplicitamente o modificando i suoi figli, viene scritta nel Database e bloccata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DistHeader CreateHeader(
    string dedid,
    string dedrev
)
Public Function CreateHeader (
    dedid As String,
    dedrev As String
) As DistHeader
public:
DistHeader^ CreateHeader(
    String^ dedid,
    String^ dedrev
)
member CreateHeader :
        dedid : string *
        dedrev : string -> DistHeader

Parametri

dedid String
DedId del padre della distinta.
dedrev String
DedRev del padre della distinta.

Valore di ritorno

DistHeader
Distinta creata.
Vedi anche

Documentazione

Classe DistManager
Overload di CreateHeader
Namespace DedNet.Core


Metodo DistManager.CreateHeader(String, String, String)

Metodo DistManagerCreateHeader(String, String, String)
Crea e restituisce una nuova distinta, non bloccata. Se la distinta esiste già solleva un'eccezione altrimenti ne crea una nuova e la restituisce. La distinta creata esiste solo in memoria, quando si blocca esplicitamente o modificando i suoi figli, viene scritta nel Database e bloccata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DistHeader CreateHeader(
    string dedid,
    string dedrev,
    string discrim
)
Public Function CreateHeader (
    dedid As String,
    dedrev As String,
    discrim As String
) As DistHeader
public:
DistHeader^ CreateHeader(
    String^ dedid,
    String^ dedrev,
    String^ discrim
)
member CreateHeader :
        dedid : string *
        dedrev : string *
        discrim : string -> DistHeader

Parametri

dedid String
DedId del padre della distinta.
dedrev String
DedRev del padre della distinta.
discrim String
Parametro discriminante della distinta della distinta.

Valore di ritorno

DistHeader
Distinta creata.
Vedi anche

Documentazione

Classe DistManager
Overload di CreateHeader
Namespace DedNet.Core


Metodo DistManager.Dispose

Metodo DistManagerDispose
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Dispose | Effettua il dispose dell'oggetto.
Metodo protetto | Dispose(Boolean) | Effettua la liberazione delle risorese gestite e non.
Torna su
Vedi anche

Documentazione

Classe DistManager
Namespace DedNet.Core


Metodo DistManager.Dispose

Metodo DistManagerDispose
Effettua il dispose dell'oggetto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implementa

IDisposableDispose
Vedi anche

Documentazione

Classe DistManager
Overload di Dispose
Namespace DedNet.Core


Metodo DistManager.Dispose(Boolean)

Metodo DistManagerDispose(Boolean)
Effettua la liberazione delle risorese gestite e non.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
Indica se viene chiamto dal dispose oppure dal distruttore.
Vedi anche

Documentazione

Classe DistManager
Overload di Dispose
Namespace DedNet.Core


Metodo DistManager.Finalize

Metodo DistManagerFinalize
Distruttore dell'oggetto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
~Finalize()
Protected Overrides Sub Finalize
!Finalize()
abstract Finalize : unit -> unit
override Finalize : unit -> unit
Vedi anche

Documentazione

Classe DistManager
Namespace DedNet.Core


Metodo DistManager.FindFirstHeader

Metodo DistManagerFindFirstHeader
Restituisce la prima revisione di distinta presente per il codice specificato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DistHeader FindFirstHeader(
    string dedid,
    string dedrev,
    string discrim
)
Public Function FindFirstHeader (
    dedid As String,
    dedrev As String,
    discrim As String
) As DistHeader
public:
DistHeader^ FindFirstHeader(
    String^ dedid,
    String^ dedrev,
    String^ discrim
)
member FindFirstHeader :
        dedid : string *
        dedrev : string *
        discrim : string -> DistHeader

Parametri

dedid String
DedId del quale cercare l'intestazione.
dedrev String
DedRev del quale cercare l'intestazione.
discrim String
Paramentro discriminante aggiuntivo di distinta

Valore di ritorno

DistHeader
Restituisce l'intestazione dell'ultima revisione oppure null.
Vedi anche

Documentazione

Classe DistManager
Namespace DedNet.Core


Metodo DistManager.FindHeader

Metodo DistManagerFindHeader
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | FindHeader(String) | Restituisce tutte le intestazioni presenti dato l'id passato.
Metodo pubblico | FindHeader(String, String) | Restituisce tutte le intestazioni presenti aventi le caratteristiche specificate ovvero tutte le revisioni di distinta del dato codice.
Metodo pubblico | FindHeader(String, String, Int32) | Restituisce l'intestazione avente le caratteristiche specificate.
Metodo pubblico | FindHeader(String, String, NullableDateTime) | Restituisce l'intestazione di un codice che abbia data di validità maggiore di una certa data, ovvero che risulti valido ad una specifica data.
Metodo pubblico | FindHeader(String, String, String) | Restituisce le intestazioni aventi le caratteristiche specificate.
Metodo pubblico | FindHeader(String, String, Int32, String) | Restituisce l'intestazione avente le caratteristiche specificate.
Metodo pubblico | FindHeader(String, String, NullableDateTime, String) | Restituisce l'intestazione di un codice che abbia data di validità maggiore di una certa data, ovvero che risulti valido ad una specifica data.
Torna su
Vedi anche

Documentazione

Classe DistManager
Namespace DedNet.Core


Metodo DistManager.FindHeader(String)

Metodo DistManagerFindHeader(String)
Restituisce tutte le intestazioni presenti dato l'id passato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DistHeaderCollection FindHeader(
    string dedid
)
Public Function FindHeader (
    dedid As String
) As DistHeaderCollection
public:
DistHeaderCollection^ FindHeader(
    String^ dedid
)
member FindHeader :
        dedid : string -> DistHeaderCollection

Parametri

dedid String
DedId del quale cercare le intestazioni.

Valore di ritorno

DistHeaderCollection
Restituisce una collezione vuota se non trova intestazioni.
Vedi anche

Documentazione

Classe DistManager
Overload di FindHeader
Namespace DedNet.Core


Metodo DistManager.FindHeader(String, String)

Metodo DistManagerFindHeader(String, String)
Restituisce tutte le intestazioni presenti aventi le caratteristiche specificate ovvero tutte le revisioni di distinta del dato codice.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DistHeaderCollection FindHeader(
    string dedid,
    string dedrev
)
Public Function FindHeader (
    dedid As String,
    dedrev As String
) As DistHeaderCollection
public:
DistHeaderCollection^ FindHeader(
    String^ dedid,
    String^ dedrev
)
member FindHeader :
        dedid : string *
        dedrev : string -> DistHeaderCollection

Parametri

dedid String
DedId del quale cercare le intestazioni.
dedrev String
DedRev del quale cercare le intestazioni.

Valore di ritorno

DistHeaderCollection
Restituisce una collezione vuota se non trova intestazioni.
Vedi anche

Documentazione

Classe DistManager
Overload di FindHeader
Namespace DedNet.Core


Metodo DistManager.FindHeader(String, String, Int32)

Metodo DistManagerFindHeader(String, String, Int32)
Restituisce l'intestazione avente le caratteristiche specificate.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DistHeader FindHeader(
    string dedid,
    string dedrev,
    int distrev
)
Public Function FindHeader (
    dedid As String,
    dedrev As String,
    distrev As Integer
) As DistHeader
public:
DistHeader^ FindHeader(
    String^ dedid,
    String^ dedrev,
    int distrev
)
member FindHeader :
        dedid : string *
        dedrev : string *
        distrev : int -> DistHeader

Parametri

dedid String
DedId del quale cercare l'intestazione.
dedrev String
DedRev del quale cercare l'intestazione.
distrev Int32
DistRev del quale cercare l'intestazione.

Valore di ritorno

DistHeader
Restituisce l'intestazione trovata oppure null.
Vedi anche

Documentazione

Classe DistManager
Overload di FindHeader
Namespace DedNet.Core


Metodo DistManager.FindHeader(String, String, Nullable<DateTime>)

Metodo DistManagerFindHeader(String, String, NullableDateTime)
Restituisce l'intestazione di un codice che abbia data di validità maggiore di una certa data, ovvero che risulti valido ad una specifica data.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DistHeader FindHeader(
    string dedid,
    string dedrev,
    DateTime? queryDate
)
Public Function FindHeader (
    dedid As String,
    dedrev As String,
    queryDate As DateTime?
) As DistHeader
public:
DistHeader^ FindHeader(
    String^ dedid,
    String^ dedrev,
    Nullable<DateTime> queryDate
)
member FindHeader :
        dedid : string *
        dedrev : string *
        queryDate : Nullable<DateTime> -> DistHeader

Parametri

dedid String
DedId del quale cercare l'intestazione.
dedrev String
DedRev del quale cercare l'intestazione.
queryDate Nullable DateTime
Data di interrogazione.

Valore di ritorno

DistHeader
Restituisce l'intestazione trovata oppure null.
Vedi anche

Documentazione

Classe DistManager
Overload di FindHeader
Namespace DedNet.Core


Metodo DistManager.FindHeader(String, String, String)

Metodo DistManagerFindHeader(String, String, String)
Restituisce le intestazioni aventi le caratteristiche specificate.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DistHeaderCollection FindHeader(
    string dedid,
    string dedrev,
    string discrim
)
Public Function FindHeader (
    dedid As String,
    dedrev As String,
    discrim As String
) As DistHeaderCollection
public:
DistHeaderCollection^ FindHeader(
    String^ dedid,
    String^ dedrev,
    String^ discrim
)
member FindHeader :
        dedid : string *
        dedrev : string *
        discrim : string -> DistHeaderCollection

Parametri

dedid String
DedId del quale cercare l'intestazione.
dedrev String
DedRev del quale cercare l'intestazione.
discrim String
Discriminante di distinta del quale cercare l'intestazione.

Valore di ritorno

DistHeaderCollection
Restituisce le intestazioni trovate oppure null.
Vedi anche

Documentazione

Classe DistManager
Overload di FindHeader
Namespace DedNet.Core


Metodo DistManager.FindHeader(String, String, Int32, String)

Metodo DistManagerFindHeader(String, String, Int32, String)
Restituisce l'intestazione avente le caratteristiche specificate.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DistHeader FindHeader(
    string dedid,
    string dedrev,
    int distrev,
    string discrim
)
Public Function FindHeader (
    dedid As String,
    dedrev As String,
    distrev As Integer,
    discrim As String
) As DistHeader
public:
DistHeader^ FindHeader(
    String^ dedid,
    String^ dedrev,
    int distrev,
    String^ discrim
)
member FindHeader :
        dedid : string *
        dedrev : string *
        distrev : int *
        discrim : string -> DistHeader

Parametri

dedid String
DedId del quale cercare l'intestazione.
dedrev String
DedRev del quale cercare l'intestazione.
distrev Int32
DistRev del quale cercare l'intestazione.
discrim String
Discriminante di distinta del quale cercare l'intestazione.

Valore di ritorno

DistHeader
Restituisce l'intestazione trovata oppure null.
Vedi anche

Documentazione

Classe DistManager
Overload di FindHeader
Namespace DedNet.Core


Metodo DistManager.FindHeader(String, String, Nullable<DateTime>, String)

Metodo DistManagerFindHeader(String, String, NullableDateTime, String)
Restituisce l'intestazione di un codice che abbia data di validità maggiore di una certa data, ovvero che risulti valido ad una specifica data.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DistHeader FindHeader(
    string dedid,
    string dedrev,
    DateTime? queryDate,
    string discrim
)
Public Function FindHeader (
    dedid As String,
    dedrev As String,
    queryDate As DateTime?,
    discrim As String
) As DistHeader
public:
DistHeader^ FindHeader(
    String^ dedid,
    String^ dedrev,
    Nullable<DateTime> queryDate,
    String^ discrim
)
member FindHeader :
        dedid : string *
        dedrev : string *
        queryDate : Nullable<DateTime> *
        discrim : string -> DistHeader

Parametri

dedid String
DedId del quale cercare l'intestazione.
dedrev String
DedRev del quale cercare l'intestazione.
queryDate Nullable DateTime
Data di interrogazione.
discrim String
Discriminante di distinta del quale cercare l'intestazione.

Valore di ritorno

DistHeader
Restituisce l'intestazione trovata oppure null.
Vedi anche

Documentazione

Classe DistManager
Overload di FindHeader
Namespace DedNet.Core


Metodo DistManager.FindLastHeader

Metodo DistManagerFindLastHeader
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | FindLastHeader(String, String) | Restituisce l'ultima revisione di distinta presente per il codice specificato. Considera la sola disinta CAD.
Metodo pubblico | FindLastHeader(String, String, String) | Restituisce l'ultima revisione di distinta presente per il codice specificato.
Torna su
Vedi anche

Documentazione

Classe DistManager
Namespace DedNet.Core


Metodo DistManager.FindLastHeader(String, String)

Metodo DistManagerFindLastHeader(String, String)
Restituisce l'ultima revisione di distinta presente per il codice specificato. Considera la sola disinta CAD.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DistHeader FindLastHeader(
    string dedid,
    string dedrev
)
Public Function FindLastHeader (
    dedid As String,
    dedrev As String
) As DistHeader
public:
DistHeader^ FindLastHeader(
    String^ dedid,
    String^ dedrev
)
member FindLastHeader :
        dedid : string *
        dedrev : string -> DistHeader

Parametri

dedid String
DedId del quale cercare l'intestazione.
dedrev String
DedRev del quale cercare l'intestazione.

Valore di ritorno

DistHeader
Restituisce l'intestazione dell'ultima revisione oppure null.
Vedi anche

Documentazione

Classe DistManager
Overload di FindLastHeader
Namespace DedNet.Core


Metodo DistManager.FindLastHeader(String, String, String)

Metodo DistManagerFindLastHeader(String, String, String)
Restituisce l'ultima revisione di distinta presente per il codice specificato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DistHeader FindLastHeader(
    string dedid,
    string dedrev,
    string discrim
)
Public Function FindLastHeader (
    dedid As String,
    dedrev As String,
    discrim As String
) As DistHeader
public:
DistHeader^ FindLastHeader(
    String^ dedid,
    String^ dedrev,
    String^ discrim
)
member FindLastHeader :
        dedid : string *
        dedrev : string *
        discrim : string -> DistHeader

Parametri

dedid String
DedId del quale cercare l'intestazione.
dedrev String
DedRev del quale cercare l'intestazione.
discrim String
Paramentro discriminante aggiuntivo di distinta

Valore di ritorno

DistHeader
Restituisce l'intestazione dell'ultima revisione oppure null.
Vedi anche

Documentazione

Classe DistManager
Overload di FindLastHeader
Namespace DedNet.Core


Metodo DistManager.GetAllDistParent

Metodo DistManagerGetAllDistParent

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<BomItem> GetAllDistParent(
    string dedidChild,
    string dedrevChild,
    DateTime queryDate
)
Public Function GetAllDistParent (
    dedidChild As String,
    dedrevChild As String,
    queryDate As DateTime
) As List(Of BomItem)
public:
List<BomItem^>^ GetAllDistParent(
    String^ dedidChild,
    String^ dedrevChild,
    DateTime queryDate
)
member GetAllDistParent :
        dedidChild : string *
        dedrevChild : string *
        queryDate : DateTime -> List<BomItem>

Parametri

dedidChild String
dedrevChild String
queryDate DateTime

Valore di ritorno

List BomItem
Vedi anche

Documentazione

Classe DistManager
Namespace DedNet.Core


Metodo DistManager.GetAnagr

Metodo DistManagerGetAnagr
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | GetAnagr(String) | Cerca nella cache se è già stata caricata l'ultima revisione dell'anagrafica dell'elemento passato, se la trova la restituisce altrimenti la cerca e la restituisce. Se non la trova restituisce null.
Metodo pubblico | GetAnagr(String, String) | Cerca nella cache se è già stata caricata l'anagrafica dell'elemento passato, se la trova la restituisce altrimenti la cerca e la restituisce. Se non la trova restituisce null.
Torna su
Vedi anche

Documentazione

Classe DistManager
Namespace DedNet.Core


Metodo DistManager.GetAnagr(String)

Metodo DistManagerGetAnagr(String)
Cerca nella cache se è già stata caricata l'ultima revisione dell'anagrafica dell'elemento passato, se la trova la restituisce altrimenti la cerca e la restituisce. Se non la trova restituisce null.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData GetAnagr(
    string dedid
)
Public Function GetAnagr (
    dedid As String
) As DedData
public:
DedData^ GetAnagr(
    String^ dedid
)
member GetAnagr :
        dedid : string -> DedData

Parametri

dedid String
DedId del quale cercare l'ultima revisione di anagrafica.

Valore di ritorno

DedData
L'anagrafica richiesta oppure null se non è presente.
Vedi anche

Documentazione

Classe DistManager
Overload di GetAnagr
Namespace DedNet.Core


Metodo DistManager.GetAnagr(String, String)

Metodo DistManagerGetAnagr(String, String)
Cerca nella cache se è già stata caricata l'anagrafica dell'elemento passato, se la trova la restituisce altrimenti la cerca e la restituisce. Se non la trova restituisce null.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData GetAnagr(
    string dedid,
    string dedrev
)
Public Function GetAnagr (
    dedid As String,
    dedrev As String
) As DedData
public:
DedData^ GetAnagr(
    String^ dedid,
    String^ dedrev
)
member GetAnagr :
        dedid : string *
        dedrev : string -> DedData

Parametri

dedid String
DedId del quale cercare l'anagrafica.
dedrev String
DedRev del quale cercare l'anagrafica.

Valore di ritorno

DedData
L'anagrafica richiesta oppure null se non è presente.
Vedi anche

Documentazione

Classe DistManager
Overload di GetAnagr
Namespace DedNet.Core


Metodo DistManager.GetDedRevList

Metodo DistManagerGetDedRevList
Restituisce la lista delle revisioni (DedRev) del codice specificato per le quali sono presenti delle distinte.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string[] GetDedRevList(
    string dedid
)
Public Function GetDedRevList (
    dedid As String
) As String()
public:
array<String^>^ GetDedRevList(
    String^ dedid
)
member GetDedRevList :
        dedid : string -> string[]

Parametri

dedid String
DedId del quale cercare le revisioni.

Valore di ritorno

String
Restituisce una array vuoto se non trova intestazioni.
Vedi anche

Documentazione

Classe DistManager
Namespace DedNet.Core


Metodo DistManager.GetDiscrimList

Metodo DistManagerGetDiscrimList
Restituisce la lista dei discriminanti di distinta presenti dato un particolare codice.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string[] GetDiscrimList(
    string dedid,
    string dedrev
)
Public Function GetDiscrimList (
    dedid As String,
    dedrev As String
) As String()
public:
array<String^>^ GetDiscrimList(
    String^ dedid,
    String^ dedrev
)
member GetDiscrimList :
        dedid : string *
        dedrev : string -> string[]

Parametri

dedid String
DedId del quale cercare le revisioni di distinta.
dedrev String
DedRev del quale cercare le revisioni di distinta.

Valore di ritorno

String
Restituisce una array vuoto se non trova intestazioni.
Vedi anche

Documentazione

Classe DistManager
Namespace DedNet.Core


Metodo DistManager.GetDistRevList

Metodo DistManagerGetDistRevList
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | GetDistRevList(String, String) | Restituisce la lista delle revisioni di distinta presenti dato un particolare codice.
Metodo pubblico | GetDistRevList(String, String, String) | Restituisce la lista delle revisioni di distinta presenti dato un particolare codice e discriminante.
Torna su
Vedi anche

Documentazione

Classe DistManager
Namespace DedNet.Core


Metodo DistManager.GetDistRevList(String, String)

Metodo DistManagerGetDistRevList(String, String)
Restituisce la lista delle revisioni di distinta presenti dato un particolare codice.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int[] GetDistRevList(
    string dedid,
    string dedrev
)
Public Function GetDistRevList (
    dedid As String,
    dedrev As String
) As Integer()
public:
array<int>^ GetDistRevList(
    String^ dedid,
    String^ dedrev
)
member GetDistRevList :
        dedid : string *
        dedrev : string -> int[]

Parametri

dedid String
DedId del quale cercare le revisioni di distinta.
dedrev String
DedRev del quale cercare le revisioni di distinta.

Valore di ritorno

Int32
Restituisce una array vuoto se non trova intestazioni.
Vedi anche

Documentazione

Classe DistManager
Overload di GetDistRevList
Namespace DedNet.Core


Metodo DistManager.GetDistRevList(String, String, String)

Metodo DistManagerGetDistRevList(String, String, String)
Restituisce la lista delle revisioni di distinta presenti dato un particolare codice e discriminante.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int[] GetDistRevList(
    string dedid,
    string dedrev,
    string discrim
)
Public Function GetDistRevList (
    dedid As String,
    dedrev As String,
    discrim As String
) As Integer()
public:
array<int>^ GetDistRevList(
    String^ dedid,
    String^ dedrev,
    String^ discrim
)
member GetDistRevList :
        dedid : string *
        dedrev : string *
        discrim : string -> int[]

Parametri

dedid String
DedId del quale cercare le revisioni di distinta.
dedrev String
DedRev del quale cercare le revisioni di distinta.
discrim String
Discriminante del quale cercare le revisioni di distinta

Valore di ritorno

Int32
Restituisce una array vuoto se non trova intestazioni.
Vedi anche

Documentazione

Classe DistManager
Overload di GetDistRevList
Namespace DedNet.Core


Metodo DistManager.GetLastAnagWithDist

Metodo DistManagerGetLastAnagWithDist
Restituisce l'ultima revisione di anagrafica con distinta salvata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string GetLastAnagWithDist(
    DedData data,
    string discrim
)
Public Function GetLastAnagWithDist (
    data As DedData,
    discrim As String
) As String
public:
String^ GetLastAnagWithDist(
    DedData^ data,
    String^ discrim
)
member GetLastAnagWithDist :
        data : DedData *
        discrim : string -> string

Parametri

data DedData
Anagrafica.
discrim String
Paramentro discriminante aggiuntivo di distinta

Valore di ritorno

String
Vedi anche

Documentazione

Classe DistManager
Namespace DedNet.Core


Metodo DistManager.GetParentDiscrimList

Metodo DistManagerGetParentDiscrimList
Restituisce la lista dei discriminanti dei padri dell'elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string[] GetParentDiscrimList(
    string dedid,
    string dedrev
)
Public Function GetParentDiscrimList (
    dedid As String,
    dedrev As String
) As String()
public:
array<String^>^ GetParentDiscrimList(
    String^ dedid,
    String^ dedrev
)
member GetParentDiscrimList :
        dedid : string *
        dedrev : string -> string[]

Parametri

dedid String
DedId dell'elemento.
dedrev String
DedRev dell'elememtp.

Valore di ritorno

String
Restituisce una lista vuota se l'elemento non è contenuto in nessuna ditinta.
Vedi anche

Documentazione

Classe DistManager
Namespace DedNet.Core


Metodo DistManager.HasDistImpl

Metodo DistManagerHasDistImpl
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | HasDistImpl(String) | Controlla se il codice passato ha una distinta implosa.
Metodo pubblico | HasDistImpl(String, String) | Controlla se il codice passato ha una distinta implosa.
Metodo pubblico | HasDistImpl(String, String, Boolean) | Controlla se il codice passato ha una distinta implosa.
Torna su
Vedi anche

Documentazione

Classe DistManager
Namespace DedNet.Core


Metodo DistManager.HasDistImpl(String)

Metodo DistManagerHasDistImpl(String)
Controlla se il codice passato ha una distinta implosa.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasDistImpl(
    string dedidChild
)
Public Function HasDistImpl (
    dedidChild As String
) As Boolean
public:
bool HasDistImpl(
    String^ dedidChild
)
member HasDistImpl :
        dedidChild : string -> bool

Parametri

dedidChild String
DedId del codice padre.

Valore di ritorno

Boolean
Restituisce se il codice ha una distinta implosa.
Vedi anche

Documentazione

Classe DistManager
Overload di HasDistImpl
Namespace DedNet.Core


Metodo DistManager.HasDistImpl(String, String)

Metodo DistManagerHasDistImpl(String, String)
Controlla se il codice passato ha una distinta implosa.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasDistImpl(
    string dedidChild,
    string dedrevChild
)
Public Function HasDistImpl (
    dedidChild As String,
    dedrevChild As String
) As Boolean
public:
bool HasDistImpl(
    String^ dedidChild,
    String^ dedrevChild
)
member HasDistImpl :
        dedidChild : string *
        dedrevChild : string -> bool

Parametri

dedidChild String
DedId del codice padre.
dedrevChild String
DedRev del codice padre.

Valore di ritorno

Boolean
Restituisce se il codice ha una distinta implosa.
Vedi anche

Documentazione

Classe DistManager
Overload di HasDistImpl
Namespace DedNet.Core


Metodo DistManager.HasDistImpl(String, String, Boolean)

Metodo DistManagerHasDistImpl(String, String, Boolean)
Controlla se il codice passato ha una distinta implosa.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasDistImpl(
    string dedidChild,
    string dedrevChild,
    bool lastDistRev
)
Public Function HasDistImpl (
    dedidChild As String,
    dedrevChild As String,
    lastDistRev As Boolean
) As Boolean
public:
bool HasDistImpl(
    String^ dedidChild,
    String^ dedrevChild,
    bool lastDistRev
)
member HasDistImpl :
        dedidChild : string *
        dedrevChild : string *
        lastDistRev : bool -> bool

Parametri

dedidChild String
DedId del codice padre.
dedrevChild String
DedRev del codice padre.
lastDistRev Boolean
Indica se controllare solo le ultime revisioni di distinta

Valore di ritorno

Boolean
Restituisce se il codice ha una distinta implosa.
Vedi anche

Documentazione

Classe DistManager
Overload di HasDistImpl
Namespace DedNet.Core


Metodo DistManager.HasHeader

Metodo DistManagerHasHeader
Restituisce se l'anagrafica ha un header.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasHeader(
    string dedid,
    string dedrev,
    string discrim
)
Public Function HasHeader (
    dedid As String,
    dedrev As String,
    discrim As String
) As Boolean
public:
bool HasHeader(
    String^ dedid,
    String^ dedrev,
    String^ discrim
)
member HasHeader :
        dedid : string *
        dedrev : string *
        discrim : string -> bool

Parametri

dedid String
DedId del quale cercare l'intestazione.
dedrev String
DedRev del quale cercare l'intestazione.
discrim String
Discriminante di distinta del quale cercare l'intestazione.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DistManager
Namespace DedNet.Core


Metodo DistManager.ReadDistImpl

Metodo DistManagerReadDistImpl
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | ReadDistImpl(String, String) | Legge dal Database la distinta implosa di uno specifico codice all'ultima data di validità, ponendola in cache. Se la distinta è già presente nella cache la restituisce direttamente.
Metodo pubblico | ReadDistImpl(String, String, DateTime) | Legge dal Database la distinta implosa di uno specifico codice valido alla data specificata, ponendola in cache. Se la distinta è già presente nella cache la restituisce direttamente.
Metodo pubblico | ReadDistImpl(String, String, String) | Legge la distinta implosa data l'anagrafica ed il discriminante del tipo distinta.
Metodo pubblico | ReadDistImpl(String, String, String, DateTime) | Legge dal Database la distinta implosa di uno specifico codice valido e relativo tipo distinta alla data specificata, ponendola in cache. Se la distinta è già presente nella cache la restituisce direttamente.
Torna su
Vedi anche

Documentazione

Classe DistManager
Namespace DedNet.Core


Metodo DistManager.ReadDistImpl(String, String)

Metodo DistManagerReadDistImpl(String, String)
Legge dal Database la distinta implosa di uno specifico codice all'ultima data di validità, ponendola in cache. Se la distinta è già presente nella cache la restituisce direttamente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItemCollection ReadDistImpl(
    string dedidChild,
    string dedrevChild
)
Public Function ReadDistImpl (
    dedidChild As String,
    dedrevChild As String
) As BomItemCollection
public:
BomItemCollection^ ReadDistImpl(
    String^ dedidChild,
    String^ dedrevChild
)
member ReadDistImpl :
        dedidChild : string *
        dedrevChild : string -> BomItemCollection

Parametri

dedidChild String
DedId del codice padre.
dedrevChild String
DedRev del codice padre.

Valore di ritorno

BomItemCollection
Restituisce l'insieme degli elementi trovati oppure una collezione vuota se non ce ne sono oppure null se il codice richiesto non è presente in anagrafica.
Vedi anche

Documentazione

Classe DistManager
Overload di ReadDistImpl
Namespace DedNet.Core


Metodo DistManager.ReadDistImpl(String, String, DateTime)

Metodo DistManagerReadDistImpl(String, String, DateTime)
Legge dal Database la distinta implosa di uno specifico codice valido alla data specificata, ponendola in cache. Se la distinta è già presente nella cache la restituisce direttamente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItemCollection ReadDistImpl(
    string dedidChild,
    string dedrevChild,
    DateTime queryDate
)
Public Function ReadDistImpl (
    dedidChild As String,
    dedrevChild As String,
    queryDate As DateTime
) As BomItemCollection
public:
BomItemCollection^ ReadDistImpl(
    String^ dedidChild,
    String^ dedrevChild,
    DateTime queryDate
)
member ReadDistImpl :
        dedidChild : string *
        dedrevChild : string *
        queryDate : DateTime -> BomItemCollection

Parametri

dedidChild String
DedId del codice padre.
dedrevChild String
DedRev del codice padre.
queryDate DateTime
Data di interrogazione.

Valore di ritorno

BomItemCollection
Restituisce l'insieme degli elementi trovati oppure una collezione vuota se non ce ne sono oppure null se il codice richiesto non è presente in anagrafica.
Vedi anche

Documentazione

Classe DistManager
Overload di ReadDistImpl
Namespace DedNet.Core


Metodo DistManager.ReadDistImpl(String, String, String)

Metodo DistManagerReadDistImpl(String, String, String)
Legge la distinta implosa data l'anagrafica ed il discriminante del tipo distinta.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItemCollection ReadDistImpl(
    string dedidChild,
    string dedrevChild,
    string discrimChild
)
Public Function ReadDistImpl (
    dedidChild As String,
    dedrevChild As String,
    discrimChild As String
) As BomItemCollection
public:
BomItemCollection^ ReadDistImpl(
    String^ dedidChild,
    String^ dedrevChild,
    String^ discrimChild
)
member ReadDistImpl :
        dedidChild : string *
        dedrevChild : string *
        discrimChild : string -> BomItemCollection

Parametri

dedidChild String
Id dell'elemento
dedrevChild String
Rev dell'elemento
discrimChild String
Discriminante che identifica la tipologia di distinta richiesta per l'elemento

Valore di ritorno

BomItemCollection
Restituisce l'insieme degli elementi trovati oppure una collezione vuota se non ce ne sono oppure null se il codice richiesto non è presente in anagrafica.
Vedi anche

Documentazione

Classe DistManager
Overload di ReadDistImpl
Namespace DedNet.Core


Metodo DistManager.ReadDistImpl(String, String, String, DateTime)

Metodo DistManagerReadDistImpl(String, String, String, DateTime)
Legge dal Database la distinta implosa di uno specifico codice valido e relativo tipo distinta alla data specificata, ponendola in cache. Se la distinta è già presente nella cache la restituisce direttamente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItemCollection ReadDistImpl(
    string dedidChild,
    string dedrevChild,
    string discrimChild,
    DateTime queryDate
)
Public Function ReadDistImpl (
    dedidChild As String,
    dedrevChild As String,
    discrimChild As String,
    queryDate As DateTime
) As BomItemCollection
public:
BomItemCollection^ ReadDistImpl(
    String^ dedidChild,
    String^ dedrevChild,
    String^ discrimChild,
    DateTime queryDate
)
member ReadDistImpl :
        dedidChild : string *
        dedrevChild : string *
        discrimChild : string *
        queryDate : DateTime -> BomItemCollection

Parametri

dedidChild String
DedId del codice padre.
dedrevChild String
DedRev del codice padre (con * gestisce tutte le revisioni).
discrimChild String
Discriminante sul quale calcolare la distinta implosa
queryDate DateTime
Data di interrogazione.

Valore di ritorno

BomItemCollection
Restituisce l'insieme degli elementi trovati oppure una collezione vuota se non ce ne sono oppure null se il codice richiesto non è presente in anagrafica.
Vedi anche

Documentazione

Classe DistManager
Overload di ReadDistImpl
Namespace DedNet.Core


Metodo DistManager.RemoveAllDist

Metodo DistManagerRemoveAllDist
Elimina dal Database tutte le distinte presenti di un determinato padre.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void RemoveAllDist(
    string dedid,
    string dedrev
)
Public Sub RemoveAllDist (
    dedid As String,
    dedrev As String
)
public:
void RemoveAllDist(
    String^ dedid,
    String^ dedrev
)
member RemoveAllDist :
        dedid : string *
        dedrev : string -> unit

Parametri

dedid String
DedId del codice padre delle distinte da eliminare.
dedrev String
DedRev del codice padre delle distinte da eliminare.
Vedi anche

Documentazione

Classe DistManager
Namespace DedNet.Core


Metodo DistManager.ResetCache

Metodo DistManagerResetCache
Resetta la cache delle distinte presenti nell'oggetto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ResetCache()
Public Sub ResetCache
public:
void ResetCache()
member ResetCache : unit -> unit
Vedi anche

Documentazione

Classe DistManager
Namespace DedNet.Core


Campi di DistManager

Il tipo DistManager espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | MaxQueryDate | Data da utilizzare per la data di validità dei nuovi elementi di distinta.
Torna su
Vedi anche

Documentazione

Classe DistManager
Namespace DedNet.Core


Campo DistManager.MaxQueryDate

Campo DistManagerMaxQueryDate
Data da utilizzare per la data di validità dei nuovi elementi di distinta.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public readonly DateTime MaxQueryDate
Public ReadOnly MaxQueryDate As DateTime
public:
initonly DateTime MaxQueryDate
val MaxQueryDate: DateTime

Valore del campo

DateTime
Vedi anche

Documentazione

Classe DistManager
Namespace DedNet.Core


Classe DistSaveStructIndexDescriptor
Descrittore degli indici dei campi fondamentali per il salvataggio
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDistSaveStructIndexDescriptor

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DistSaveStructIndexDescriptor
Public Class DistSaveStructIndexDescriptor
public ref class DistSaveStructIndexDescriptor
type DistSaveStructIndexDescriptor = class end

Il tipo DistSaveStructIndexDescriptor espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DistSaveStructIndexDescriptor |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | IdcIdx |
Proprietà pubblica | IdParentIdx |
Proprietà pubblica | LivIdx |
Proprietà pubblica | RevcIdx |
Proprietà pubblica | RevParentIdx |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DistSaveStructIndexDescriptor

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DistSaveStructIndexDescriptor(
    LuaTable distSaveStruct
)
Public Sub New (
    distSaveStruct As LuaTable
)
public:
DistSaveStructIndexDescriptor(
    LuaTable^ distSaveStruct
)
new :
        distSaveStruct : LuaTable -> DistSaveStructIndexDescriptor

Parametri

distSaveStruct LuaTable
Vedi anche

Documentazione

Classe DistSaveStructIndexDescriptor
Namespace DedNet.Core


Proprietà di DistSaveStructIndexDescriptor

Il tipo DistSaveStructIndexDescriptor espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | IdcIdx |
Proprietà pubblica | IdParentIdx |
Proprietà pubblica | LivIdx |
Proprietà pubblica | RevcIdx |
Proprietà pubblica | RevParentIdx |
Torna su
Vedi anche

Documentazione

Classe DistSaveStructIndexDescriptor
Namespace DedNet.Core


Proprietà DistSaveStructIndexDescriptor.IdcIdx

Proprietà DistSaveStructIndexDescriptorIdcIdx

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int IdcIdx { get; }
Public ReadOnly Property IdcIdx As Integer
    Get
public:
property int IdcIdx {
    int get ();
}
member IdcIdx : int with get

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe DistSaveStructIndexDescriptor
Namespace DedNet.Core


Proprietà DistSaveStructIndexDescriptor.IdParentIdx

Proprietà DistSaveStructIndexDescriptorIdParentIdx

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int IdParentIdx { get; }
Public ReadOnly Property IdParentIdx As Integer
    Get
public:
property int IdParentIdx {
    int get ();
}
member IdParentIdx : int with get

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe DistSaveStructIndexDescriptor
Namespace DedNet.Core


Proprietà DistSaveStructIndexDescriptor.LivIdx

Proprietà DistSaveStructIndexDescriptorLivIdx

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int LivIdx { get; }
Public ReadOnly Property LivIdx As Integer
    Get
public:
property int LivIdx {
    int get ();
}
member LivIdx : int with get

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe DistSaveStructIndexDescriptor
Namespace DedNet.Core


Proprietà DistSaveStructIndexDescriptor.RevcIdx

Proprietà DistSaveStructIndexDescriptorRevcIdx

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int RevcIdx { get; }
Public ReadOnly Property RevcIdx As Integer
    Get
public:
property int RevcIdx {
    int get ();
}
member RevcIdx : int with get

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe DistSaveStructIndexDescriptor
Namespace DedNet.Core


Proprietà DistSaveStructIndexDescriptor.RevParentIdx

Proprietà DistSaveStructIndexDescriptorRevParentIdx

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int RevParentIdx { get; }
Public ReadOnly Property RevParentIdx As Integer
    Get
public:
property int RevParentIdx {
    int get ();
}
member RevParentIdx : int with get

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe DistSaveStructIndexDescriptor
Namespace DedNet.Core


Classe DocDep
Classe descrivente la dipendenza di un singolo documento.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDocDep

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DocDep : IDedDbItem
Public Class DocDep
    Implements IDedDbItem
public ref class DocDep : IDedDbItem
type DocDep =
    class
        interface IDedDbItem
    end

Il tipo DocDep espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CfgDescr | Restituisce la configurazione/modelstate della dipendenza.
Proprietà pubblica | DepType | Restituisce il tipo di dipendenza del documento.
Proprietà pubblica | DocId | Restituisce il documento che è dipendente del documento principale.
Proprietà pubblica | IsImpl | Restituisce se l'elemento faccia parte di una collezione di dipendenze esplosa o implosa.
Proprietà pubblica | Parent | Restituisce la collezione alla quale questo elemento appartiene.
Proprietà pubblica | StatoRecord | Restituisce o imposta lo stato del record.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di DocDep

Il tipo DocDep espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CfgDescr | Restituisce la configurazione/modelstate della dipendenza.
Proprietà pubblica | DepType | Restituisce il tipo di dipendenza del documento.
Proprietà pubblica | DocId | Restituisce il documento che è dipendente del documento principale.
Proprietà pubblica | IsImpl | Restituisce se l'elemento faccia parte di una collezione di dipendenze esplosa o implosa.
Proprietà pubblica | Parent | Restituisce la collezione alla quale questo elemento appartiene.
Proprietà pubblica | StatoRecord | Restituisce o imposta lo stato del record.
Torna su
Vedi anche

Documentazione

Classe DocDep
Namespace DedNet.Core


Proprietà DocDep.CfgDescr

Proprietà DocDepCfgDescr
Restituisce la configurazione/modelstate della dipendenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ConfigDescriptor CfgDescr { get; }
Public ReadOnly Property CfgDescr As ConfigDescriptor
    Get
public:
property ConfigDescriptor^ CfgDescr {
    ConfigDescriptor^ get ();
}
member CfgDescr : ConfigDescriptor with get

Valore della proprietà

ConfigDescriptor
Vedi anche

Documentazione

Classe DocDep
Namespace DedNet.Core


Proprietà DocDep.DepType

Proprietà DocDepDepType
Restituisce il tipo di dipendenza del documento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocDepEnum DepType { get; }
Public ReadOnly Property DepType As DocDepEnum
    Get
public:
property DocDepEnum DepType {
    DocDepEnum get ();
}
member DepType : DocDepEnum with get

Valore della proprietà

DocDepEnum
Vedi anche

Documentazione

Classe DocDep
Namespace DedNet.Core


Proprietà DocDep.DocId

Proprietà DocDepDocId
Restituisce il documento che è dipendente del documento principale.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Guid DocId { get; }
Public ReadOnly Property DocId As Guid
    Get
public:
property Guid DocId {
    Guid get ();
}
member DocId : Guid with get

Valore della proprietà

Guid
Vedi anche

Documentazione

Classe DocDep
Namespace DedNet.Core


Proprietà DocDep.IsImpl

Proprietà DocDepIsImpl
Restituisce se l'elemento faccia parte di una collezione di dipendenze esplosa o implosa.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsImpl { get; }
Public ReadOnly Property IsImpl As Boolean
    Get
public:
property bool IsImpl {
    bool get ();
}
member IsImpl : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocDep
Namespace DedNet.Core


Proprietà DocDep.Parent

Proprietà DocDepParent
Restituisce la collezione alla quale questo elemento appartiene.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocDepCollection Parent { get; }
Public ReadOnly Property Parent As DocDepCollection
    Get
public:
property DocDepCollection^ Parent {
    DocDepCollection^ get ();
}
member Parent : DocDepCollection with get

Valore della proprietà

DocDepCollection
Vedi anche

Documentazione

Classe DocDep
Namespace DedNet.Core


Proprietà DocDep.StatoRecord

Proprietà DocDepStatoRecord
Restituisce o imposta lo stato del record.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public StatoRecord StatoRecord { get; set; }
Public Property StatoRecord As StatoRecord
    Get
    Set
public:
virtual property StatoRecord^ StatoRecord {
    StatoRecord^ get () sealed;
    void set (StatoRecord^ value) sealed;
}
abstract StatoRecord : StatoRecord with get, set
override StatoRecord : StatoRecord with get, set

Valore della proprietà

StatoRecord

Implementa

IDedDbItemStatoRecord
Vedi anche

Documentazione

Classe DocDep
Namespace DedNet.Core


Metodi di DocDep

Il tipo DocDep espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Torna su
Vedi anche

Documentazione

Classe DocDep
Namespace DedNet.Core


Metodo DocDep.Equals

Metodo DocDepEquals

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj Object

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DocDep
Namespace DedNet.Core


Metodo DocDep.GetHashCode

Metodo DocDepGetHashCode

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DocDep
Namespace DedNet.Core


Metodo DocDep.ToString

Metodo DocDepToString

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DocDep
Namespace DedNet.Core


Classe DocDepCollection
Collezione delle dipendenze di un Documento. Questa collezione permette di modificare la lista dei DocDep legati ad un documento. Ogni modifica effettuata non viene aggiornata nel Database fino alla successiva chiamata del metodo Save(). Tramite Refresh() viene invece reinizializzata la collection rileggendo il Database.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedDbCollectionBase DocDep
DedNet.CoreDocDepCollection

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DocDepCollection : DedDbCollectionBase<DocDep>
Public Class DocDepCollection
    Inherits DedDbCollectionBase(Of DocDep)
public ref class DocDepCollection : public DedDbCollectionBase<DocDep^>
type DocDepCollection =
    class
        inherit DedDbCollectionBase<DocDep>
    end

Il tipo DocDepCollection espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllowsDuplicates | Restituisce se siano ammessi duplicati all'interno della lista. Se false viene sollevata una eccezione su tentativo di inserimento duplicati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Application | Restituisce l'oggetto applicazione di appartenza. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Count | Restituisce il numero di elementi presenti. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Dirty | Restituisce se la collezione o uno dei suoi elementi sia stata modificata. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | ErasedItems | Restitusice la lista in sola lettura degli elementi che risultano attualmente cancellati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | IsImpl | Restituisce se si tratti di una collezione di dipendenze esplosa o implosa.
Proprietà pubblica | LastItem | Restituisce l'ultimo elemento della collezione oppure null se non ci sono elementi. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | ParentDocument | Restituisce il documento al quale questa collection appartiene.
Proprietà pubblica | RestoreErased | Restituisce se gli elementi cancellati devono essere ripristinati in caso vengano riaggiunti. (Ereditato da DedDbCollectionBaseT)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Add(Guid, DocDepEnum) | Aggiunge una nuova dipendenza alla collezione, se questa non esiste altrimenti restituisce quella già esistente.
Metodo pubblico | Add(String, DocDepEnum) | Aggiunge una nuova dipendenza alla collezione, se questa non esiste altrimenti restituisce quella già esistente. Dal filename passato viene prima creato il documento che verrà aggiunto in dipendenza.
Metodo pubblico | Add(Guid, DocDepEnum, ConfigDescriptor) | Aggiunge una nuova dipendenza alla collezione, se questa non esiste altrimenti restituisce quella già esistente.
Metodo pubblico | Add(String, DocDepEnum, ConfigDescriptor) | Aggiunge una nuova dipendenza alla collezione, se questa non esiste altrimenti restituisce quella già esistente. Dal filename passato viene prima creato il documento che verrà aggiunto in dipendenza.
Metodo protetto | AddForClone | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto SENZA MODIFICARNE LO STATO. Le classi derivate potranno utilizzare questo metodo per clonare la collezione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddNewElement | DI USO INTERNO. Aggiunge un elemento alla lista rendendo dirty l'oggetto. L'elemento viene aggiunto con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere un elemento alla lista. Dovranno loro stesse avere un metodo pubblico Add() che prenda i parametri necessari alla costruzione dell'oggetto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddRangeNewElement | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi rendendo dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere più elementi alla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddUnModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Clear | Elimina tutti gli elementi dalla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ClearRefresh | Svuota la lista impostando Dirty = false. Di fatto permette di effettuare un refresh della lista e quindi di ricaricarla. Serve per svuotare la lista e reinizializzarla da capo. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Contains(T) | Verifica l'esistenza di un valore all'interno della lista degli elementi. Le classi derivate devono effettuarne l'override nel caso in cui l'elemento non implementi GetHashCode() per l'uso all'interno dei dizionarii. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Contains(Guid, DocDepEnum, String) | Restituisce se nella collezione è presente un elemento corrispondente alle caratteristiche specificate
Metodo pubblico | ContainsDocId | Restituisce se nella collezione è presente un elemento corrispondente alle caratteristiche specificate
Metodo pubblico | CopyTo | Copia un range di elementi in un array. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | CreateDeleteCommand | Crea, inizializza e restituisce il comando per l'eliminazione di un elemento. (Sovrascrive DedDbCollectionBaseTCreateDeleteCommand(T))
Metodo protetto | CreateInsertCommand | Crea, inizializza e restituisce il comando per l'inserimento di un elemento. (Sovrascrive DedDbCollectionBaseTCreateInsertCommand(T))
Metodo protetto | CreateUpdateCommand | Crea, inizializza e restituisce il comando per l'aggiornamento di un elemento. (Sovrascrive DedDbCollectionBaseTCreateUpdateCommand(T))
Metodo pubblico | CustomSort | Ordina la lista in base al comparatore passato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteDeleteItem | Esegue l'eliminazione di un elemento. Crea il comando tramite il metodo CreateDeleteCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteInsertItem | Esegue l'inserimento di un elemento. Crea il comando tramite il metodo CreateInsertCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteUpdateItem | Esegue l'aggiornamento di un elemento. Crea il comando tramite il metodo CreateUpdateCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FilterByDepType | Restituisce la lista delle dipendenze contenute in questa collezione che sono di un particolare tipo.
Metodo pubblico | Find | Restituisce l'oggetto cercato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FindAll | Restitusice la lista degli elementi che corrispondono al predicato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | GetDbIndex | Restituisce l'indice dell'elemento passato, da utilizzare nelle clausole where di aggiornamento/eliminazione. Le classi derivate devono effettuarne l'override nel caso in cui sia possibile modificare l'indice dell'elemento via API. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | GetEnumerator | Restituisce l'enumeratore della collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | HasAnyElementOf | Verifica l'esistenza di almeno un elemento di tipologia specificata.
Metodo pubblico | IndexOf(T) | Restituisce l'indice dell'elemento richiesto. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | IndexOf(Guid, DocDepEnum, String) | Restituisce l'indice dell'elemento corrispondente alle caratteristiche specificate oppure -1 se non esiste.
Metodo protetto | InitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InsertUnModified | DI USO INTERNO. Inserisce un elemento alla lista senza rendere dirty l'oggetto, all'indice specificato. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Item | Restituisce l'elemento iesimo della lista. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean) | Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean, Int32) | Sposta l'elemento dell'indice passato prima o dopo del numero di posizioni passate. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSave | Metodo Template chiamato dopo il salvataggio avvenuto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSaveNoChanges | Metodo Template chiamato dopo il salvataggio senza modifiche. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnBeforeSave | Metodo Template chiamato prima del salvataggio. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(T) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(DedEditableObjectT) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(T) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(DedEditableObjectT) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Refresh | Ricarica tutte le dipendenze dal Database ignorando le eventuali modifiche effettuate precedentemente. L'oggetto ritorna quindi non dirty se lo era prima di chiamare questo metodo.
Metodo protetto | ReInitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Remove | Elimina un elemento dalla collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Ripristina | Verifica che l'elemento sia presente negli eliminati e lo toglie da lì e lo riaggiunge in coda alla lista degli elementi validi. Solleva una eccezione se l'elemento è già presente nella lista e AllowsDuplicates = false. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Save | Salva l'oggetto con tutta la sua lista, solo se questo risulta dirty. (Ereditato da DedDbCollectionBaseT)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di DocDepCollection

Il tipo DocDepCollection espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllowsDuplicates | Restituisce se siano ammessi duplicati all'interno della lista. Se false viene sollevata una eccezione su tentativo di inserimento duplicati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Application | Restituisce l'oggetto applicazione di appartenza. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Count | Restituisce il numero di elementi presenti. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | Dirty | Restituisce se la collezione o uno dei suoi elementi sia stata modificata. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | ErasedItems | Restitusice la lista in sola lettura degli elementi che risultano attualmente cancellati. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | IsImpl | Restituisce se si tratti di una collezione di dipendenze esplosa o implosa.
Proprietà pubblica | LastItem | Restituisce l'ultimo elemento della collezione oppure null se non ci sono elementi. (Ereditato da DedDbCollectionBaseT)
Proprietà pubblica | ParentDocument | Restituisce il documento al quale questa collection appartiene.
Proprietà pubblica | RestoreErased | Restituisce se gli elementi cancellati devono essere ripristinati in caso vengano riaggiunti. (Ereditato da DedDbCollectionBaseT)
Torna su
Vedi anche

Documentazione

Classe DocDepCollection
Namespace DedNet.Core


Proprietà DocDepCollection.IsImpl

Proprietà DocDepCollectionIsImpl
Restituisce se si tratti di una collezione di dipendenze esplosa o implosa.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsImpl { get; }
Public ReadOnly Property IsImpl As Boolean
    Get
public:
property bool IsImpl {
    bool get ();
}
member IsImpl : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocDepCollection
Namespace DedNet.Core


Proprietà DocDepCollection.ParentDocument

Proprietà DocDepCollectionParentDocument
Restituisce il documento al quale questa collection appartiene.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDoc ParentDocument { get; }
Public ReadOnly Property ParentDocument As DedDoc
    Get
public:
property DedDoc^ ParentDocument {
    DedDoc^ get ();
}
member ParentDocument : DedDoc with get

Valore della proprietà

DedDoc
Vedi anche

Documentazione

Classe DocDepCollection
Namespace DedNet.Core


Metodi di DocDepCollection

Il tipo DocDepCollection espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Add(Guid, DocDepEnum) | Aggiunge una nuova dipendenza alla collezione, se questa non esiste altrimenti restituisce quella già esistente.
Metodo pubblico | Add(String, DocDepEnum) | Aggiunge una nuova dipendenza alla collezione, se questa non esiste altrimenti restituisce quella già esistente. Dal filename passato viene prima creato il documento che verrà aggiunto in dipendenza.
Metodo pubblico | Add(Guid, DocDepEnum, ConfigDescriptor) | Aggiunge una nuova dipendenza alla collezione, se questa non esiste altrimenti restituisce quella già esistente.
Metodo pubblico | Add(String, DocDepEnum, ConfigDescriptor) | Aggiunge una nuova dipendenza alla collezione, se questa non esiste altrimenti restituisce quella già esistente. Dal filename passato viene prima creato il documento che verrà aggiunto in dipendenza.
Metodo protetto | AddForClone | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto SENZA MODIFICARNE LO STATO. Le classi derivate potranno utilizzare questo metodo per clonare la collezione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddNewElement | DI USO INTERNO. Aggiunge un elemento alla lista rendendo dirty l'oggetto. L'elemento viene aggiunto con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere un elemento alla lista. Dovranno loro stesse avere un metodo pubblico Add() che prenda i parametri necessari alla costruzione dell'oggetto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddRangeNewElement | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi rendendo dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di NewElement. Utilizzare questo metodo nelle classe derivate per aggiungere più elementi alla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | AddUnModified | DI USO INTERNO. Aggiunge un elemento alla lista senza rendere dirty l'oggetto. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Clear | Elimina tutti gli elementi dalla lista. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ClearRefresh | Svuota la lista impostando Dirty = false. Di fatto permette di effettuare un refresh della lista e quindi di ricaricarla. Serve per svuotare la lista e reinizializzarla da capo. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Contains(T) | Verifica l'esistenza di un valore all'interno della lista degli elementi. Le classi derivate devono effettuarne l'override nel caso in cui l'elemento non implementi GetHashCode() per l'uso all'interno dei dizionarii. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Contains(Guid, DocDepEnum, String) | Restituisce se nella collezione è presente un elemento corrispondente alle caratteristiche specificate
Metodo pubblico | ContainsDocId | Restituisce se nella collezione è presente un elemento corrispondente alle caratteristiche specificate
Metodo pubblico | CopyTo | Copia un range di elementi in un array. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | CreateDeleteCommand | Crea, inizializza e restituisce il comando per l'eliminazione di un elemento. (Sovrascrive DedDbCollectionBaseTCreateDeleteCommand(T))
Metodo protetto | CreateInsertCommand | Crea, inizializza e restituisce il comando per l'inserimento di un elemento. (Sovrascrive DedDbCollectionBaseTCreateInsertCommand(T))
Metodo protetto | CreateUpdateCommand | Crea, inizializza e restituisce il comando per l'aggiornamento di un elemento. (Sovrascrive DedDbCollectionBaseTCreateUpdateCommand(T))
Metodo pubblico | CustomSort | Ordina la lista in base al comparatore passato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteDeleteItem | Esegue l'eliminazione di un elemento. Crea il comando tramite il metodo CreateDeleteCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteInsertItem | Esegue l'inserimento di un elemento. Crea il comando tramite il metodo CreateInsertCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | ExecuteUpdateItem | Esegue l'aggiornamento di un elemento. Crea il comando tramite il metodo CreateUpdateCommand() e lo esegue. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FilterByDepType | Restituisce la lista delle dipendenze contenute in questa collezione che sono di un particolare tipo.
Metodo pubblico | Find | Restituisce l'oggetto cercato. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | FindAll | Restitusice la lista degli elementi che corrispondono al predicato. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | GetDbIndex | Restituisce l'indice dell'elemento passato, da utilizzare nelle clausole where di aggiornamento/eliminazione. Le classi derivate devono effettuarne l'override nel caso in cui sia possibile modificare l'indice dell'elemento via API. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | GetEnumerator | Restituisce l'enumeratore della collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | HasAnyElementOf | Verifica l'esistenza di almeno un elemento di tipologia specificata.
Metodo pubblico | IndexOf(T) | Restituisce l'indice dell'elemento richiesto. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | IndexOf(Guid, DocDepEnum, String) | Restituisce l'indice dell'elemento corrispondente alle caratteristiche specificate oppure -1 se non esiste.
Metodo protetto | InitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | InsertUnModified | DI USO INTERNO. Inserisce un elemento alla lista senza rendere dirty l'oggetto, all'indice specificato. L'elemento viene aggiunto con lo stato di UnModified. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Item | Restituisce l'elemento iesimo della lista. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean) | Sposta l'elemento dell'indice passato ad una posizione precedente o successiva. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Move(Int32, Boolean, Int32) | Sposta l'elemento dell'indice passato prima o dopo del numero di posizioni passate. Ignora eventuali valori di indice non validi. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSave | Metodo Template chiamato dopo il salvataggio avvenuto. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnAfterSaveNoChanges | Metodo Template chiamato dopo il salvataggio senza modifiche. (Ereditato da DedDbCollectionBaseT)
Metodo protetto | OnBeforeSave | Metodo Template chiamato prima del salvataggio. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(T) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChanged(DedEditableObjectT) | Imposta come modificato lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(T) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | PropertyChangedAsNewElement(DedEditableObjectT) | Imposta come nuovo elemento lo stato dell'elemento. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Refresh | Ricarica tutte le dipendenze dal Database ignorando le eventuali modifiche effettuate precedentemente. L'oggetto ritorna quindi non dirty se lo era prima di chiamare questo metodo.
Metodo protetto | ReInitListUnModified | DI USO INTERNO. Utilizzare questo metodo per inizializzare la lista di elementi senza rendere dirty l'oggetto. Gli elementi vengono aggiunti con lo stato di UnModified dopo avere azzerato la lista interna. Le classi derivate dovranno utilizzare questo metodo durante la fase di creazione/inizializzazione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Remove | Elimina un elemento dalla collezione. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Ripristina | Verifica che l'elemento sia presente negli eliminati e lo toglie da lì e lo riaggiunge in coda alla lista degli elementi validi. Solleva una eccezione se l'elemento è già presente nella lista e AllowsDuplicates = false. (Ereditato da DedDbCollectionBaseT)
Metodo pubblico | Save | Salva l'oggetto con tutta la sua lista, solo se questo risulta dirty. (Ereditato da DedDbCollectionBaseT)
Torna su
Vedi anche

Documentazione

Classe DocDepCollection
Namespace DedNet.Core


Metodo DocDepCollection.Add

Metodo DocDepCollectionAdd
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Add(Guid, DocDepEnum) | Aggiunge una nuova dipendenza alla collezione, se questa non esiste altrimenti restituisce quella già esistente.
Metodo pubblico | Add(String, DocDepEnum) | Aggiunge una nuova dipendenza alla collezione, se questa non esiste altrimenti restituisce quella già esistente. Dal filename passato viene prima creato il documento che verrà aggiunto in dipendenza.
Metodo pubblico | Add(Guid, DocDepEnum, ConfigDescriptor) | Aggiunge una nuova dipendenza alla collezione, se questa non esiste altrimenti restituisce quella già esistente.
Metodo pubblico | Add(String, DocDepEnum, ConfigDescriptor) | Aggiunge una nuova dipendenza alla collezione, se questa non esiste altrimenti restituisce quella già esistente. Dal filename passato viene prima creato il documento che verrà aggiunto in dipendenza.
Torna su
Vedi anche

Documentazione

Classe DocDepCollection
Namespace DedNet.Core


Metodo DocDepCollection.Add(Guid, DocDepEnum)

Metodo DocDepCollectionAdd(Guid, DocDepEnum)
Aggiunge una nuova dipendenza alla collezione, se questa non esiste altrimenti restituisce quella già esistente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocDep Add(
    Guid docid,
    DocDepEnum depType
)
Public Function Add (
    docid As Guid,
    depType As DocDepEnum
) As DocDep
public:
DocDep^ Add(
    Guid docid,
    DocDepEnum depType
)
member Add :
        docid : Guid *
        depType : DocDepEnum -> DocDep

Parametri

docid Guid
DocId della dipendenza da aggiungere.
depType DocDepEnum
Tipo di dipendenza da aggiungere.

Valore di ritorno

DocDep
Restituisce l'oggetto dipendenza appena creato ed aggiungo alla collezione.
Vedi anche

Documentazione

Classe DocDepCollection
Overload di Add
Namespace DedNet.Core


Metodo DocDepCollection.Add(String, DocDepEnum)

Metodo DocDepCollectionAdd(String, DocDepEnum)
Aggiunge una nuova dipendenza alla collezione, se questa non esiste altrimenti restituisce quella già esistente. Dal filename passato viene prima creato il documento che verrà aggiunto in dipendenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocDep Add(
    string fileName,
    DocDepEnum depType
)
Public Function Add (
    fileName As String,
    depType As DocDepEnum
) As DocDep
public:
DocDep^ Add(
    String^ fileName,
    DocDepEnum depType
)
member Add :
        fileName : string *
        depType : DocDepEnum -> DocDep

Parametri

fileName String
Percorso del doc da creare ed aggiungere.
depType DocDepEnum
Tipo di dipendenza da aggiungere.

Valore di ritorno

DocDep
Restituisce l'oggetto dipendenza appena creato ed aggiungo alla collezione.
Vedi anche

Documentazione

Classe DocDepCollection
Overload di Add
Namespace DedNet.Core


Metodo DocDepCollection.Add(Guid, DocDepEnum, ConfigDescriptor)

Metodo DocDepCollectionAdd(Guid, DocDepEnum, ConfigDescriptor)
Aggiunge una nuova dipendenza alla collezione, se questa non esiste altrimenti restituisce quella già esistente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocDep Add(
    Guid docid,
    DocDepEnum depType,
    ConfigDescriptor cfgDescr
)
Public Function Add (
    docid As Guid,
    depType As DocDepEnum,
    cfgDescr As ConfigDescriptor
) As DocDep
public:
DocDep^ Add(
    Guid docid,
    DocDepEnum depType,
    ConfigDescriptor^ cfgDescr
)
member Add :
        docid : Guid *
        depType : DocDepEnum *
        cfgDescr : ConfigDescriptor -> DocDep

Parametri

docid Guid
DocId della dipendenza da aggiungere.
depType DocDepEnum
Tipo di dipendenza da aggiungere.
cfgDescr ConfigDescriptor

Valore di ritorno

DocDep
Restituisce l'oggetto dipendenza appena creato ed aggiungo alla collezione.
Vedi anche

Documentazione

Classe DocDepCollection
Overload di Add
Namespace DedNet.Core


Metodo DocDepCollection.Add(String, DocDepEnum, ConfigDescriptor)

Metodo DocDepCollectionAdd(String, DocDepEnum, ConfigDescriptor)
Aggiunge una nuova dipendenza alla collezione, se questa non esiste altrimenti restituisce quella già esistente. Dal filename passato viene prima creato il documento che verrà aggiunto in dipendenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocDep Add(
    string fileName,
    DocDepEnum depType,
    ConfigDescriptor cfgDescr
)
Public Function Add (
    fileName As String,
    depType As DocDepEnum,
    cfgDescr As ConfigDescriptor
) As DocDep
public:
DocDep^ Add(
    String^ fileName,
    DocDepEnum depType,
    ConfigDescriptor^ cfgDescr
)
member Add :
        fileName : string *
        depType : DocDepEnum *
        cfgDescr : ConfigDescriptor -> DocDep

Parametri

fileName String
Percorso del doc da creare ed aggiungere.
depType DocDepEnum
Tipo di dipendenza da aggiungere.
cfgDescr ConfigDescriptor

Valore di ritorno

DocDep
Restituisce l'oggetto dipendenza appena creato ed aggiungo alla collezione.
Vedi anche

Documentazione

Classe DocDepCollection
Overload di Add
Namespace DedNet.Core


Metodo DocDepCollection.Contains

Metodo DocDepCollectionContains
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Contains(T) | Verifica l'esistenza di un valore all'interno della lista degli elementi. Le classi derivate devono effettuarne l'override nel caso in cui l'elemento non implementi GetHashCode() per l'uso all'interno dei dizionarii.
Metodo pubblico | Contains(Guid, DocDepEnum, String) | Restituisce se nella collezione è presente un elemento corrispondente alle caratteristiche specificate
Torna su
Vedi anche

Documentazione

Classe DocDepCollection
Namespace DedNet.Core


Metodo DocDepCollection.Contains(Guid, DocDepEnum, String)

Metodo DocDepCollectionContains(Guid, DocDepEnum, String)
Restituisce se nella collezione è presente un elemento corrispondente alle caratteristiche specificate

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Contains(
    Guid docid,
    DocDepEnum depType,
    string cfgName = "*"
)
Public Function Contains (
    docid As Guid,
    depType As DocDepEnum,
    Optional cfgName As String = "*"
) As Boolean
public:
bool Contains(
    Guid docid,
    DocDepEnum depType,
    String^ cfgName = L"*"
)
member Contains :
        docid : Guid *
        depType : DocDepEnum *
        ?cfgName : string
(* Defaults:
        let _cfgName = defaultArg cfgName "*"
*)
-> bool

Parametri

docid Guid
DocId del documento.
depType DocDepEnum
Tipo di legame.
cfgName String (Optional)
Configurazione del legame

Valore di ritorno

Boolean
Restituisce se l'elemento esiste.
Vedi anche

Documentazione

Classe DocDepCollection
Overload di Contains
Namespace DedNet.Core


Metodo DocDepCollection.ContainsDocId

Metodo DocDepCollectionContainsDocId
Restituisce se nella collezione è presente un elemento corrispondente alle caratteristiche specificate

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ContainsDocId(
    Guid docid
)
Public Function ContainsDocId (
    docid As Guid
) As Boolean
public:
bool ContainsDocId(
    Guid docid
)
member ContainsDocId :
        docid : Guid -> bool

Parametri

docid Guid
DocId del documento.

Valore di ritorno

Boolean
Restituisce se l'elemento esiste.
Vedi anche

Documentazione

Classe DocDepCollection
Namespace DedNet.Core


Metodo DocDepCollection.CreateDeleteCommand

Metodo DocDepCollectionCreateDeleteCommand
Crea, inizializza e restituisce il comando per l'eliminazione di un elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSDeleteCommand CreateDeleteCommand(
    DocDep item
)
Protected Overrides Function CreateDeleteCommand (
    item As DocDep
) As QSDeleteCommand
protected:
virtual QSDeleteCommand^ CreateDeleteCommand(
    DocDep^ item
) override
abstract CreateDeleteCommand :
        item : DocDep -> QSDeleteCommand
override CreateDeleteCommand :
        item : DocDep -> QSDeleteCommand

Parametri

item DocDep
Elemento da utilizzare per inizializzare il comando.

Valore di ritorno

QSDeleteCommand
Il comando inizializzato, pronto per essere eseguito.
Vedi anche

Documentazione

Classe DocDepCollection
Namespace DedNet.Core


Metodo DocDepCollection.CreateInsertCommand

Metodo DocDepCollectionCreateInsertCommand
Crea, inizializza e restituisce il comando per l'inserimento di un elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSInsertCommand CreateInsertCommand(
    DocDep item
)
Protected Overrides Function CreateInsertCommand (
    item As DocDep
) As QSInsertCommand
protected:
virtual QSInsertCommand^ CreateInsertCommand(
    DocDep^ item
) override
abstract CreateInsertCommand :
        item : DocDep -> QSInsertCommand
override CreateInsertCommand :
        item : DocDep -> QSInsertCommand

Parametri

item DocDep
Elemento da utilizzare per inizializzare il comando.

Valore di ritorno

QSInsertCommand
Il comando inizializzato, pronto per essere eseguito.
Vedi anche

Documentazione

Classe DocDepCollection
Namespace DedNet.Core


Metodo DocDepCollection.CreateUpdateCommand

Metodo DocDepCollectionCreateUpdateCommand
Crea, inizializza e restituisce il comando per l'aggiornamento di un elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override QSUpdateCommand CreateUpdateCommand(
    DocDep item
)
Protected Overrides Function CreateUpdateCommand (
    item As DocDep
) As QSUpdateCommand
protected:
virtual QSUpdateCommand^ CreateUpdateCommand(
    DocDep^ item
) override
abstract CreateUpdateCommand :
        item : DocDep -> QSUpdateCommand
override CreateUpdateCommand :
        item : DocDep -> QSUpdateCommand

Parametri

item DocDep
Elemento da utilizzare per inizializzare il comando.

Valore di ritorno

QSUpdateCommand
Il comando inizializzato, pronto per essere eseguito.
Vedi anche

Documentazione

Classe DocDepCollection
Namespace DedNet.Core


Metodo DocDepCollection.FilterByDepType

Metodo DocDepCollectionFilterByDepType
Restituisce la lista delle dipendenze contenute in questa collezione che sono di un particolare tipo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<DocDep> FilterByDepType(
    DocDepEnum depType
)
Public Function FilterByDepType (
    depType As DocDepEnum
) As List(Of DocDep)
public:
List<DocDep^>^ FilterByDepType(
    DocDepEnum depType
)
member FilterByDepType :
        depType : DocDepEnum -> List<DocDep>

Parametri

depType DocDepEnum
Tipologia di dipendenze che si desidera avere restituita.

Valore di ritorno

List DocDep
Restiuisce sempre una lista inizializzata.
Vedi anche

Documentazione

Classe DocDepCollection
Namespace DedNet.Core


Metodo DocDepCollection.HasAnyElementOf

Metodo DocDepCollectionHasAnyElementOf
Verifica l'esistenza di almeno un elemento di tipologia specificata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasAnyElementOf(
    DocDepEnum depType
)
Public Function HasAnyElementOf (
    depType As DocDepEnum
) As Boolean
public:
bool HasAnyElementOf(
    DocDepEnum depType
)
member HasAnyElementOf :
        depType : DocDepEnum -> bool

Parametri

depType DocDepEnum
Tipologia di legame da verificare.

Valore di ritorno

Boolean
Restituisce true se nella collezione è presente almeno un elemento con la tipologia di legame specificata.
Vedi anche

Documentazione

Classe DocDepCollection
Namespace DedNet.Core


Metodo DocDepCollection.IndexOf

Metodo DocDepCollectionIndexOf
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | IndexOf(T) | Restituisce l'indice dell'elemento richiesto.
Metodo pubblico | IndexOf(Guid, DocDepEnum, String) | Restituisce l'indice dell'elemento corrispondente alle caratteristiche specificate oppure -1 se non esiste.
Torna su
Vedi anche

Documentazione

Classe DocDepCollection
Namespace DedNet.Core


Metodo DocDepCollection.IndexOf(Guid, DocDepEnum, String)

Metodo DocDepCollectionIndexOf(Guid, DocDepEnum, String)
Restituisce l'indice dell'elemento corrispondente alle caratteristiche specificate oppure -1 se non esiste.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int IndexOf(
    Guid docid,
    DocDepEnum depType,
    string cfgName = "*"
)
Public Function IndexOf (
    docid As Guid,
    depType As DocDepEnum,
    Optional cfgName As String = "*"
) As Integer
public:
int IndexOf(
    Guid docid,
    DocDepEnum depType,
    String^ cfgName = L"*"
)
member IndexOf :
        docid : Guid *
        depType : DocDepEnum *
        ?cfgName : string
(* Defaults:
        let _cfgName = defaultArg cfgName "*"
*)
-> int

Parametri

docid Guid
DocId del documento.
depType DocDepEnum
Tipo di legame.
cfgName String (Optional)
Configurazione del legame

Valore di ritorno

Int32
Restituisce l'indice dell'elemento.
Vedi anche

Documentazione

Classe DocDepCollection
Overload di IndexOf
Namespace DedNet.Core


Metodo DocDepCollection.Refresh

Metodo DocDepCollectionRefresh
Ricarica tutte le dipendenze dal Database ignorando le eventuali modifiche effettuate precedentemente. L'oggetto ritorna quindi non dirty se lo era prima di chiamare questo metodo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Refresh()
Public Sub Refresh
public:
void Refresh()
member Refresh : unit -> unit
Vedi anche

Documentazione

Classe DocDepCollection
Namespace DedNet.Core


Enumerazione DocDepEnum
Tipologia di dipendenza tra documenti.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum DocDepEnum
Public Enumeration DocDepEnum
public enum class DocDepEnum
type DocDepEnum
Membri
Nome | Valore | Descrizione
Generic | 0 | Dipendenza generica non specificata: il documento dipendente viene spostato insieme al documento principale ma non viene visualizzato nella lista delle dipendenze (esempio dwg - prt).
DirectVital | 10 | Dipendenza diretta e vitale visualizzata nella lista delle dipendenze (esempio iam - ipt).
TemporaryTransparent | 20 | Dipendenza temporanea e trasparente. Deve essere invisibile come una generica, deve seguire lo stato del padre diretto senza essere però duplicata se viene duplicato il padre (esempio dipendenze nastran incad).
Vedi anche

Documentazione

Namespace DedNet.Core


Classe DocDepFile
Definisce una dipendenza specificandone il file e la tipologia. Viene utilizzata per gestire le dipendenze nei file che non ancora sono presenti nel Database. Si utilizza anche per specificare la versione del documento da inserire nel record.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDocDepFile

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DocDepFile
Public Class DocDepFile
public ref class DocDepFile
type DocDepFile = class end

Il tipo DocDepFile espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DocDepFile | Costruttore dell'oggetto.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | DepType | Restituisce la tipologia di dipendenza.
Proprietà pubblica | FileName | Restituisce il nome completo del file dipendente.
Proprietà pubblica | RowVer | Restituisce o imposta la versione del record da abbinare al documento dipendente, qualora questo sia da inserire nel Database come nuovo documento dipendente.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DocDepFile
Costruttore dell'oggetto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocDepFile(
    string fileName,
    DocDepEnum depType
)
Public Sub New (
    fileName As String,
    depType As DocDepEnum
)
public:
DocDepFile(
    String^ fileName,
    DocDepEnum depType
)
new :
        fileName : string *
        depType : DocDepEnum -> DocDepFile

Parametri

fileName String
File dipendente.
depType DocDepEnum
Tipo di dipendenza.
Vedi anche

Documentazione

Classe DocDepFile
Namespace DedNet.Core


Proprietà di DocDepFile

Il tipo DocDepFile espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | DepType | Restituisce la tipologia di dipendenza.
Proprietà pubblica | FileName | Restituisce il nome completo del file dipendente.
Proprietà pubblica | RowVer | Restituisce o imposta la versione del record da abbinare al documento dipendente, qualora questo sia da inserire nel Database come nuovo documento dipendente.
Torna su
Vedi anche

Documentazione

Classe DocDepFile
Namespace DedNet.Core


Proprietà DocDepFile.DepType

Proprietà DocDepFileDepType
Restituisce la tipologia di dipendenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocDepEnum DepType { get; }
Public ReadOnly Property DepType As DocDepEnum
    Get
public:
property DocDepEnum DepType {
    DocDepEnum get ();
}
member DepType : DocDepEnum with get

Valore della proprietà

DocDepEnum
Vedi anche

Documentazione

Classe DocDepFile
Namespace DedNet.Core


Proprietà DocDepFile.FileName

Proprietà DocDepFileFileName
Restituisce il nome completo del file dipendente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string FileName { get; }
Public ReadOnly Property FileName As String
    Get
public:
property String^ FileName {
    String^ get ();
}
member FileName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DocDepFile
Namespace DedNet.Core


Proprietà DocDepFile.RowVer

Proprietà DocDepFileRowVer
Restituisce o imposta la versione del record da abbinare al documento dipendente, qualora questo sia da inserire nel Database come nuovo documento dipendente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Guid RowVer { get; set; }
Public Property RowVer As Guid
    Get
    Set
public:
property Guid RowVer {
    Guid get ();
    void set (Guid value);
}
member RowVer : Guid with get, set

Valore della proprietà

Guid
Vedi anche

Documentazione

Classe DocDepFile
Namespace DedNet.Core


Classe DocDepFileList
Lista di oggetti DocDepFile.
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList DocDepFile
DedNet.CoreDocDepFileList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DocDepFileList : List<DocDepFile>
Public Class DocDepFileList
    Inherits List(Of DocDepFile)
public ref class DocDepFileList : public List<DocDepFile^>
type DocDepFileList =
    class
        inherit List<DocDepFile>
    end

Il tipo DocDepFileList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DocDepFileList |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ContainsFile | Restituisce true se nella lista è presente un particolare file.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DocDepFileList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocDepFileList()
Public Sub New
public:
DocDepFileList()
new : unit -> DocDepFileList
Vedi anche

Documentazione

Classe DocDepFileList
Namespace DedNet.Core


Metodi di DocDepFileList

Il tipo DocDepFileList espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ContainsFile | Restituisce true se nella lista è presente un particolare file.
Torna su
Vedi anche

Documentazione

Classe DocDepFileList
Namespace DedNet.Core


Metodo DocDepFileList.ContainsFile

Metodo DocDepFileListContainsFile
Restituisce true se nella lista è presente un particolare file.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ContainsFile(
    string fileName
)
Public Function ContainsFile (
    fileName As String
) As Boolean
public:
bool ContainsFile(
    String^ fileName
)
member ContainsFile :
        fileName : string -> bool

Parametri

fileName String
Nome del file da cercare.

Valore di ritorno

Boolean
Restituisce true se trova il file altrimenti false.
Vedi anche

Documentazione

Classe DocDepFileList
Namespace DedNet.Core


Classe DocStructFileInfos
Classe per la gestione di tutte le operazioni e le proprietà che sono relative al file e non al documento (InvDoc)
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDocStructFileInfos

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DocStructFileInfos
Public Class DocStructFileInfos
public ref class DocStructFileInfos
type DocStructFileInfos = class end

Il tipo DocStructFileInfos espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DocStructFileInfos | Costruttore unico
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | OpList | Lista delle operazioni in ordine di esecuzione
Proprietà pubblica | OpListHierarchy | Lista delle operazioni in ordine di aggiunta
Proprietà pubblica | ReferenceUpdated | Indica se l'aggiornamento dei riferimenti è stato eseguito.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DocStructFileInfos
Costruttore unico

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructFileInfos()
Public Sub New
public:
DocStructFileInfos()
new : unit -> DocStructFileInfos
Vedi anche

Documentazione

Classe DocStructFileInfos
Namespace DedNet.Core


Proprietà di DocStructFileInfos

Il tipo DocStructFileInfos espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | OpList | Lista delle operazioni in ordine di esecuzione
Proprietà pubblica | OpListHierarchy | Lista delle operazioni in ordine di aggiunta
Proprietà pubblica | ReferenceUpdated | Indica se l'aggiornamento dei riferimenti è stato eseguito.
Torna su
Vedi anche

Documentazione

Classe DocStructFileInfos
Namespace DedNet.Core


Proprietà DocStructFileInfos.OpList

Proprietà DocStructFileInfosOpList
Lista delle operazioni in ordine di esecuzione

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructOperationBaseList OpList { get; set; }
Public Property OpList As DocStructOperationBaseList
    Get
    Set
public:
property DocStructOperationBaseList^ OpList {
    DocStructOperationBaseList^ get ();
    void set (DocStructOperationBaseList^ value);
}
member OpList : DocStructOperationBaseList with get, set

Valore della proprietà

DocStructOperationBaseList
Vedi anche

Documentazione

Classe DocStructFileInfos
Namespace DedNet.Core


Proprietà DocStructFileInfos.OpListHierarchy

Proprietà DocStructFileInfosOpListHierarchy
Lista delle operazioni in ordine di aggiunta

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructOperationBaseList OpListHierarchy { get; set; }
Public Property OpListHierarchy As DocStructOperationBaseList
    Get
    Set
public:
property DocStructOperationBaseList^ OpListHierarchy {
    DocStructOperationBaseList^ get ();
    void set (DocStructOperationBaseList^ value);
}
member OpListHierarchy : DocStructOperationBaseList with get, set

Valore della proprietà

DocStructOperationBaseList
Vedi anche

Documentazione

Classe DocStructFileInfos
Namespace DedNet.Core


Proprietà DocStructFileInfos.ReferenceUpdated

Proprietà DocStructFileInfosReferenceUpdated
Indica se l'aggiornamento dei riferimenti è stato eseguito.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ReferenceUpdated { get; set; }
Public Property ReferenceUpdated As Boolean
    Get
    Set
public:
property bool ReferenceUpdated {
    bool get ();
    void set (bool value);
}
member ReferenceUpdated : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructFileInfos
Namespace DedNet.Core


Classe DocStructInfo
Questo elemento contiene le informazioni sullo stato e l'operazione da svolgere su di un file. Se questo sia da Creare, Importare o Spostare, e tutte le informazioni sul suo stato attuale e di destinazione. In questo oggetto si trovano anche le dipendenze di primo livello di questo documento e, a cascata, le operazioni da svolgere sui file dipendenti.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDocStructInfo

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DocStructInfo
Public Class DocStructInfo
public ref class DocStructInfo
type DocStructInfo = class end

Il tipo DocStructInfo espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo protetto | DocStructInfo | Inizializza l'oggetto con i dati fondamentali.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione di appartenenza.
Proprietà pubblica | CfgDescr | Restitusice o imposta la configurazione dell'elemento. Utile per la gestione delle configurazioni/modelstate.
Proprietà pubblica | ChildrenMade | Restituisce o imposta se il calcolo delle dipendenza sia già stato eseguito per questo elemento. Viene impostato dalla procedura di calcolo dei figli (quella automatica o quella fatta dal client elaborando i documenti in memoria) per evitare di rielaborare lo stesso elemento più di una volta.
Proprietà pubblica | CloneFullName | Restitsuice il percorso completo di destinazione qualora l'elemento sia da clonare (ToClone = true).
Proprietà pubblica | Config | Restitusice o imposta la configurazione dell'elemento. Utile per la gestione delle configurazioni/modelstate.
Proprietà pubblica | DataUpdated | Restituisce o imposta se l'aggiornamento del riferimento fisico del file sia o meno avvenuta.
Proprietà pubblica | DelToMake | Indica che si deve creare il .del del file di partenza.
Proprietà pubblica | DepType | Restituisce la tipologia di dipendenza.
Proprietà pubblica | Description | Restitusice o imposta una descrizione libera dell'elemento. Utile soprattutto nei nuovi elementi che sono presenti solo in memoria del client.
Proprietà pubblica | DocRowVer | Restituisce il DocRowVer calcolato tramite Md5.
Proprietà pubblica | DoNotMoveOrDelete | Restituisce o imposta se dell'oggetto associato non si deve creare il .moved o il .del. Permette di eseguire l'override del comportamento standard
Proprietà pubblica | FileDescriptor | Restituisce il file descriptor utilizzato alla creazione dell'oggetto
Proprietà pubblica | FileOperationExecuted | Restitusice le operazioni su file di tutte le operazioni presenti nella lista siano state eseguite.
Proprietà pubblica | FirstOperation | Restituisce la prima operazione presente nella lista delle operazioni di questo elemento.
Proprietà pubblica | Folder | Cartella nella quale spostare il file (usata nell'importazione di cartelle)
Proprietà pubblica | FullFileName | Restituisce o imposta l'internalname dell'elemento
Proprietà pubblica | HasChildren | Restitusice se questo elemento ha delle dipendenze.
Proprietà pubblica | HasParent |
Proprietà pubblica | HasSubstitutes | Restituisce se l'elemento abbia o meno sostituti di livello di dettaglio.
Proprietà pubblica | InternalName | Restituisce o imposta l'internalname dell'elemento
Proprietà pubblica | IsElaborated | Restituisce se l'ultima operazione sia o meno stata effettuata.
Proprietà pubblica | IsiModelMember | Restituisce se l'elemento sia o meno un elemento di layout
Proprietà pubblica | IsInRootCopy | Indica se appartiene ad una root su cui fare il Copy. Se non appartiene a nessuna Root restituisce False
Proprietà pubblica | IsLayoutAsset | Restituisce se l'elemento sia o meno un elemento di layout
Proprietà pubblica | IsParentSubstitute | Restituisce se l'elemento sia o meno un sostituto di livello di dettaglio dell'assieme padre in salvataggio.
Proprietà pubblica | IsSpecialStructContainer | Restituisce se l'elemento sia contenitore o meno di strutture speciali
Proprietà pubblica | IsSpecialStructElement | Restituisce se l'elemento rappresenti un componente di struttura speciale
Proprietà pubblica | IsSubstitute | Restituisce se l'elemento sia o meno un parte rappresentante un sostituto di livello di dettaglio
Proprietà pubblica | LastOperation | Restituisce l'ultima operazione presente nella lista delle operazioni di questo elemento.
Proprietà pubblica | LastOperationEnum | Restituisce l'ultima operazione eseguita.
Proprietà pubblica | MakeChildrenOutOfMemory | Impone di creare i figli senza utilizzare eventuali informazioni in memoria del client
Proprietà pubblica | MoveInsteadOfCopy | Restituisce se il documento debba essere spostato invece di importato.
Proprietà pubblica | OperationList | Restituisce la lista in sola lettura, presenti per questo elemento.
Proprietà pubblica | OpListHierarchy | Restituisce la lista in sola lettura, presenti per questo elemento.
Proprietà pubblica | Parent | Restituisce la collezione alla quale appartiene questo elemento. Restituisce null se si tratta della root.
Proprietà pubblica | ReferenceUpdated | Restituisce o imposta se l'aggiornamento del riferimento fisico del file sia o meno avvenuta.
Proprietà pubblica | RelocateInfo | Restituisce o imposta il percorso completo dell'elemento che deve essere ripuntato anzichè elaborato
Proprietà pubblica | SavingTypeDoc | Restituisce o imposta che tipo di relazione abbia questo elemento, in relazione al documento in salvataggio. Serve al comando di salva nel db per capire se un elemento sia stato aggiunto come file associato oppure come file referenziato oppure se si tratti proprio del documento in salvataggio.
Proprietà pubblica | SkipReferenceUpdate | Restituisce se l'ultima operazione deve evitare l'aggiornamento delle reference
Proprietà pubblica | Ties | Restituisce la collezione delle dipendenze.
Proprietà pubblica | ToClone | Restitusice se l'elemento sia o meno da clonare. Leggere in CloneFullName il percorso completo di destinazione.
Proprietà pubblica | UserData | Restituisce o imposta i dati utente abbinati a questo oggetto.
Proprietà pubblica | WasInDb | Restituisce se il file risultasse già registrato nel Database in partenza.
Proprietà pubblica | WasInLibraryPath | Restituisce o imposta se il file di partenza sia o meno in un percorso di libreria (di Inventor).
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AddAnnullaCheckOutOperation | Annulla il check-out di un documento.
Metodo pubblico | AddCheckInOperation | Imposta in checkin un documento.
Metodo pubblico | AddCheckInStrutturaOperation(Boolean) | Imposta in checkin una struttura di documenti.
Metodo pubblico | AddCheckInStrutturaOperation(Boolean, DictionaryDedDoc, ResultOperationOnStructObject) | Imposta in checkin una struttura di documenti.
Metodo pubblico | AddCheckInStrutturaOperation(Boolean, Boolean, DictionaryDedDoc, ResultOperationOnStructObject) | Imposta in checkin una struttura di documenti.
Metodo pubblico | AddCheckOutOperation(PredicateDedDoc) | Imposta in checkout un documento e si assicura che anche tutte le sue dipendenze siano copiane nella pws.
Metodo pubblico | AddCheckOutOperation(PredicateDedDoc, Boolean) | Imposta in checkout un documento e si assicura che anche tutte le sue dipendenze siano copiane nella pws.
Metodo pubblico | AddCheckOutOperation(PredicateDedDoc, Boolean, Boolean) | Imposta in checkout un documento e si assicura che anche tutte le sue dipendenze siano copiane nella pws.
Metodo pubblico | AddCheckOutOperation(PredicateDedDoc, Boolean, Boolean, Boolean) | Imposta in checkout un documento e si assicura che anche tutte le sue dipendenze siano copiane nella pws.
Metodo pubblico | AddCheckOutOperation(PredicateDedDoc, Boolean, Boolean, Boolean, Boolean) | Imposta in checkout un documento e si assicura che anche tutte le sue dipendenze siano copiane nella pws.
Metodo pubblico | AddCheckOutOperation(PredicateDedDoc, Boolean, Boolean, Boolean, DictionaryDedDoc, ResultOperationOnStructObject) | Imposta in checkout un documento e si assicura che anche tutte le sue dipendenze siano copiane nella pws.
Metodo pubblico | AddCheckOutStrutturaOperation(PredicateDedDoc) | Imposta in checkout un documento e tutte le sue dipendenze. Delegate per la notifica del documento in pws più vecchio rispetto a quello nel vault.
Metodo pubblico | AddCheckOutStrutturaOperation(PredicateDedDoc, Boolean) | Imposta in checkout un documento e tutte le sue dipendenze. Delegate per la notifica del documento in pws più vecchio rispetto a quello nel vault.Indica se l'operazione sia stata aggiunta come sotto-operazione di un CheckOutStruttura.
Metodo pubblico | AddCheckOutStrutturaOperation(PredicateDedDoc, Boolean, Boolean) | Imposta in checkout un documento e tutte le sue dipendenze. Delegate per la notifica del documento in pws più vecchio rispetto a quello nel vault.Indica se l'operazione sia stata aggiunta come sotto-operazione di un CheckOutStruttura.Indica se ignorare il blocco legato allo stato dell'anagrafica.
Metodo pubblico | AddCheckOutStrutturaOperation(PredicateDedDoc, Boolean, Boolean, Boolean, DictionaryDedDoc, ResultOperationOnStructObject) | Imposta in checkout un documento e tutte le sue dipendenze. Delegate per la notifica del documento in pws più vecchio rispetto a quello nel vault.Indica se l'operazione sia stata aggiunta come sotto-operazione di un CheckOutStruttura.Indica se ignorare il blocco legato allo stato dell'anagrafica.Dizionario contenente i risultati dei comandi sui singoli documenti
Metodo pubblico | AddCopyingOperation(String) | Copia un documento da una posizione ad un'altra accettando che il file di partenza non sia presente nel Database. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che non esista il documento sul file di destinazione. Aggiunge anche un'operazione di creazione prima di sé stessa, per creare il documento di destinazione della copia. Rimane da operare la copia fisica da parte del comando chiamante oppure del client.
Metodo pubblico | AddCopyingOperation(String, Boolean) | Copia un documento da una posizione ad un'altra accettando che il file di partenza non sia presente nel Database. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che non esista il documento sul file di destinazione. Aggiunge anche un'operazione di creazione prima di sé stessa, per creare il documento di destinazione della copia. Rimane da operare la copia fisica da parte del comando chiamante oppure del client.
Metodo pubblico | AddCreatingOperation | Valuta le informazioni presenti nell'ultima operazione disponibile e, se il documento non è presente, lo crea con il file impostato nell'operazione. Se il documento esiste già non fa nulla se non verificare che non si tratti di un nuovo documento (in questo caso solleva una eccezione) ed imposta l'operazione come effettuata. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, non controlla nemmeno l'esistenza del file. L'operazione da effettuare successivamente, se il file non esiste già, è di crearlo nella posizione di destinazione.
Metodo pubblico | AddCreatingOperation(String) | Crea un nuovo documento leggendo le informazioni presenti nell'ultima operazione disponibile ma utilizzando il percorso di file passato come argomento. Se il documento esiste già non fa nulla se non verificare che non si tratti di un nuovo documento (in questo caso solleva una eccezione) ed imposta l'operazione come effettuata. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, non controlla nemmeno l'esistenza del file. L'operazione da effettuare successivamente, se il file non esiste già, è di crearlo nella posizione di destinazione.
Metodo pubblico | AddDisconnectingOperation(DedComm) | Scollega il documento presente nell'ultima operazione, da una commessa. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che il documento da scollegare sia effettivamente collegato alla commessa.
Metodo pubblico | AddDisconnectingOperation(DedData) | Scollega il documento presente nell'ultima operazione, da un'anagrafica. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che il documento da scollegare sia effettivamente collegato all'anagrafica.
Metodo pubblico | AddEnsureLocalOperation(PredicateDedDoc, Boolean) | Copia il file dal vault all'area locale. Non effettua controlli sui permessi. Copia anche tutti i file dipendenti, necessari al documento principale.
Metodo pubblico | AddEnsureLocalOperation(PredicateDedDoc, Boolean, Boolean) | Copia il file dal vault all'area locale. Non effettua controlli sui permessi. Copia anche tutti i file dipendenti, necessari al documento principale.
Metodo pubblico | AddEnsureLocalOperation(PredicateDedDoc, Boolean, ListException) | Copia il file dal vault all'area locale. Non effettua controlli sui permessi. Copia anche tutti i file dipendenti, necessari al documento principale.
Metodo pubblico | AddEnsureLocalOperation(PredicateDedDoc, Boolean, Boolean, Boolean) | Copia il file dal vault all'area locale. Non effettua controlli sui permessi. Copia anche tutti i file dipendenti, necessari al documento principale.
Metodo pubblico | AddEnsureLocalOperation(PredicateDedDoc, Boolean, ListException, Boolean) | Copia il file dal vault all'area locale. Non effettua controlli sui permessi. Copia anche tutti i file dipendenti, necessari al documento principale.
Metodo pubblico | AddExportingOperation(Boolean, String, String) | Operazione di esportazione del documento
Metodo pubblico | AddExportingOperation(Boolean, String, String, Boolean) | Operazione di esportazione del documento
Metodo pubblico | AddExportingStrutturaOperation | Operazione di esportazione del documento (struttura)
Metodo pubblico | AddForzaCheckInOperation | Forza in checkin un documento.
Metodo pubblico | AddForzaCheckInStrutturaOperation | Imposta in checkin una struttura di documenti.
Metodo pubblico | AddForzaCheckInStrutturaOperation(Boolean) | Imposta in checkin una struttura di documenti.
Metodo pubblico | AddImportingOperation(DedComm, OperationChoiceEnum) | Copia il documentodi partenza, proveniente da qualsiasi origine, nella posizione corrette per associarlo alla commessa. Le logiche sono le stesse dell'importazione legata all'anagrafica.
Metodo pubblico | AddImportingOperation(DedData, DedDocContextEnum) | Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica.
Metodo pubblico | AddImportingOperation(DedData, Boolean) | Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica.
Metodo pubblico | AddImportingOperation(DedEco, OperationChoiceEnum) | Copia il documento di partenza, proveniente da qualsiasi origine, nella posizione corrette per associarlo all'Eco. Le logiche sono le stesse dell'importazione legata alla commessa.
Metodo pubblico | AddImportingOperation(DedData, DedDocContextEnum, Boolean) | Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica.
Metodo pubblico | AddImportingOperation(DedData, Boolean, Boolean) | Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica.
Metodo pubblico | AddImportingOperation(DedData, Boolean, String) | Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica.
Metodo pubblico | AddImportingOperation(DedData, DedDocContextEnum, Boolean, String) |
Metodo pubblico | AddImportingOperation(DedData, Boolean, Boolean, String) | Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica.
Metodo pubblico | AddImportingOperation(DedData, Boolean, String, String) | Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica.
Metodo pubblico | AddImportingOperation(DedData, Boolean, Boolean, String, OperationChoiceEnum) | Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica.
Metodo pubblico | AddImportingOperation(DedData, Boolean, Boolean, String, Boolean) |
Metodo pubblico | AddImportingOperation(DedData, Boolean, Boolean, String, Boolean, Boolean) | Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica.
Metodo pubblico | AddImportingOperation(DedData, Boolean, Boolean, String, Boolean, String) |
Metodo pubblico | AddLinkingOperation(DedComm) | Collega il documento ad una commessa
Metodo pubblico | AddLinkingOperation(DedEco) | Collega il documento ad un Eco
Metodo pubblico | AddLinkingOperation(DedData, DedDocContextEnum) | Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido.
Metodo pubblico | AddLinkingOperation(DedData, Boolean) | Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido.
Metodo pubblico | AddLinkingOperation(DedData, DedDocContextEnum, DedData) | Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido.
Metodo pubblico | AddLinkingOperation(DedData, Boolean, DedData) | Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido.
Metodo pubblico | AddLinkingOperation(DedData, DedDocContextEnum, DedData, ConfigDescriptor) | Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido.
Metodo pubblico | AddLinkingOperation(DedData, Boolean, DedData, ConfigDescriptor) | Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido.
Metodo pubblico | AddLinkingOperation(DedData, DedDocContextEnum, DedData, ConfigDescriptor, Boolean) | Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido.
Metodo pubblico | AddLinkingOperation(DedData, Boolean, DedData, ConfigDescriptor, Boolean) | Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido.
Metodo pubblico | AddLinkingOperation(DedData, Boolean, DedData, ConfigDescriptor, Boolean, DictionaryString, DedDocContext) | Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido.
Metodo pubblico | AddMovingOperation(String, DedDocMovReasonEnum) | Sposta un documento da una posizione ad un'altra utilizzando lo stesso ID documento. Il guid del documento rimane lo stesso di partenza perché si presume che si stia lavorando su disco e non in memoria (non è considerato il caso di lavorare in memoria per rinominare un file). Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che non esista il documento sul file di destinazione. Rimane da operare lo spostamento fisico da parte del comando chiamante oppure del client.
Metodo pubblico | AddMovingOperation(String, DedDocMovReasonEnum, Boolean) | Sposta un documento da una posizione ad un'altra utilizzando lo stesso ID documento. Il guid del documento rimane lo stesso di partenza perché si presume che si stia lavorando su disco e non in memoria (non è considerato il caso di lavorare in memoria per rinominare un file). Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che non esista il documento sul file di destinazione. Rimane da operare lo spostamento fisico da parte del comando chiamante oppure del client.
Metodo pubblico | AddMovingOperation(String, DedDocMovReasonEnum, Boolean, Boolean) | Sposta un documento da una posizione ad un'altra utilizzando lo stesso ID documento. Il guid del documento rimane lo stesso di partenza perché si presume che si stia lavorando su disco e non in memoria (non è considerato il caso di lavorare in memoria per rinominare un file). Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che non esista il documento sul file di destinazione. Rimane da operare lo spostamento fisico da parte del comando chiamante oppure del client.
Metodo pubblico | AddPubblicaOperation | Aggiunge una operazione di pubblicazione.
Metodo pubblico | AddPubblicaStrutturaOperation | Aggiunge una operazione di pubblicazione.
Metodo pubblico | AddRecogniseOperation(DedComm) | Associa un file ad una commessa creando il documento se non esiste già, lasciando il file col nome originale. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di crea(se necessrio) + link, per creare il documento e collegarlo all'anagrafica.
Metodo pubblico | AddRecogniseOperation(DedData, Boolean) | Associa un file ad un'anagrafica creando il documento se non esiste già, lasciando il file col nome originale. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di crea(se necessrio) + link, per creare il documento e collegarlo all'anagrafica.
Metodo pubblico | AddRecogniseOperation(DedData, Boolean, ConfigDescriptor) | Associa un file ad un'anagrafica creando il documento se non esiste già, lasciando il file col nome originale. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di crea(se necessrio) + link, per creare il documento e collegarlo all'anagrafica.
Metodo pubblico | AddRecogniseOperation(DedData, Boolean, ConfigDescriptor, Boolean) | Associa un file ad un'anagrafica creando il documento se non esiste già, lasciando il file col nome originale. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di crea(se necessrio) + link, per creare il documento e collegarlo all'anagrafica.
Metodo pubblico | AddRecogniseOperation(DedData, Boolean, ConfigDescriptor, Boolean, DictionaryString, DedDocContext) | Associa un file ad un'anagrafica creando il documento se non esiste già, lasciando il file col nome originale. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di crea(se necessrio) + link, per creare il documento e collegarlo all'anagrafica.
Metodo pubblico | AddRelocateOperation(DedDoc, Boolean) | Operazione di rilocazione di un file esterno su un documento interno. Permette di "puntare" semplicemente il documento interno ma anche di eseguire l'overwrite fisico come nel caso del replace.
Metodo pubblico | AddRelocateOperation(DedDoc, Boolean, Boolean) | Operazione di rilocazione di un file esterno su un documento interno. Permette di "puntare" semplicemente il documento interno ma anche di eseguire l'overwrite fisico come nel caso del replace.
Metodo pubblico | AddRemovingOperation | Elimina il documento presente nell'ultima operazione. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che il documento da eliminare esista.
Metodo pubblico | AddReplaceOperation(DocStructInfo) | Copia un file sul file fisico di un altro documento sostituendolo. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che esista il documento di destinazione. Aggiunge anche un'operazione di creazione per le dipendenze, per essere sicuri di avere nel Db tutti documenti dipendenti e di aggiornamento per il documento in sostituzione. Rimane da operare la copia fisica da parte del comando chiamante oppure del client.
Metodo pubblico | AddReplaceOperation(String) | Copia un file sul file fisico di un altro documento sostituendolo. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che esista il documento di destinazione. Aggiunge anche un'operazione di creazione per le dipendenze, per essere sicuri di avere nel Db tutti documenti dipendenti e di aggiornamento per il documento in sostituzione. Rimane da operare la copia fisica da parte del comando chiamante oppure del client.
Metodo pubblico | AddSbloccaOperation | Sblocca un documento.
Metodo pubblico | AddUpdatingOperation | Effettua l'operazione di aggiornamento del documento nel Database leggendo l'ultima operazione disponibile ed imposta con Updating l'operazione. Verifica che il documento esista già e poi aggiorna il documento nel Database con le sue dipendenze. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, non controlla nemmeno l'esistenza del file. L'operazione da effettuare successivamente, se il file non esiste già, è di crearlo nella posizione di destinazione.
Metodo pubblico | BottomUpCall | Chiama tutti gli elementi, compreso l'elemento corrente, ma per ultimo, partendo dal basso (ultimi nodi) e procedendo verso l'alto.
Metodo pubblico | CreateDocStructInfo(DocStructInfoFileDescriptor) | Crea e restituisce un nuovo oggetto evitando i duplicati, infatti cerca prima negli elementi interni e se lo trova restituisce l'elemento trovato, altrimenti crea un nuovo oggetto che comunque condivide gli elementi di questo oggetto. È indispensabile chiamare questo metodo per creare un oggetto dopo la chiamata all'omonimo metodo statico per la creazione del primo elemento. NOTA: Non crea la sotto struttura!! Chiamare MakeChildrenAuto() per ottenerla tramite apprentice.
Metodo pubblico | CreateDocStructInfo(String) | Crea e restituisce un nuovo oggetto evitando i duplicati, infatti cerca prima negli elementi interni e se lo trova restituisce l'elemento trovato, altrimenti crea un nuovo oggetto che comunque condivide gli elementi di questo oggetto. È indispensabile chiamare questo metodo per creare un oggetto dopo la chiamata all'omonimo metodo statico per la creazione del primo elemento. NOTA: Non crea la sotto struttura!! Chiamare MakeChildrenAuto() per ottenerla tramite apprentice.
 | CreateDocStructInfo(DedNetApplication, DocStructInfoFileDescriptor) | Crea e restituisce un nuovo oggetto DocStructInfo. Questo metodo è da utilizzare per la creazione del primo elemento, dopo si deve utilizzare la versione omonima d'istanza per creare gli oggetti successivi, in modo da evitare duplicati nella struttura dei documenti.
 | CreateDocStructInfo(DedNetApplication, String) | Crea e restituisce un nuovo oggetto DocStructInfo. Questo metodo è da utilizzare per la creazione del primo elemento, dopo si deve utilizzare la versione omonima d'istanza per creare gli oggetti successivi, in modo da evitare duplicati nella struttura dei documenti.
Metodo pubblico | CreateDocStructInfo(DocStructInfoFileDescriptor, DocStructInfo) | Crea e restituisce un nuovo oggetto evitando i duplicati, infatti cerca prima negli elementi interni e se lo trova restituisce l'elemento trovato, altrimenti crea un nuovo oggetto che comunque condivide gli elementi di questo oggetto. È indispensabile chiamare questo metodo per creare un oggetto dopo la chiamata all'omonimo metodo statico per la creazione del primo elemento. Il nuovo elemento viene impostato come figlio di questa istanza. NOTA: Non crea la sotto struttura!! Chiamare MakeChildrenAuto() per ottenerla tramite apprentice.
Metodo pubblico | CreateDocStructInfo(String, ConfigDescriptor) | Crea e restituisce un nuovo oggetto evitando i duplicati, infatti cerca prima negli elementi interni e se lo trova restituisce l'elemento trovato, altrimenti crea un nuovo oggetto che comunque condivide gli elementi di questo oggetto. È indispensabile chiamare questo metodo per creare un oggetto dopo la chiamata all'omonimo metodo statico per la creazione del primo elemento. NOTA: Non crea la sotto struttura!! Chiamare MakeChildrenAuto() per ottenerla tramite apprentice.
 | CreateDocStructInfo(DedNetApplication, String, ConfigDescriptor) | Crea e restituisce un nuovo oggetto DocStructInfo. Questo metodo è da utilizzare per la creazione del primo elemento, dopo si deve utilizzare la versione omonima d'istanza per creare gli oggetti successivi, in modo da evitare duplicati nella struttura dei documenti.
Metodo pubblico | EnforcedMakeChildrenAuto | Nella classe base la forzatura diviene in gestibile pertanto equiparo la chiamata ad un makeChildrenAuto normale per leggere le docdep salvate.
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | FileNameAreEquals |
Metodo pubblico | FindAllLevels |
Metodo pubblico | GetAllSpecialChildren | Ritorna tutti i figli dell'elemento che sono elementi della struttura speciale
Metodo pubblico | GetFileNameHashString |
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | GetHashString |
Metodo pubblico | GetLastQueuedOperation | Ritorna l'ultima operazione presente in lista appartenenete al tipo specificato. Se l'operazione non esiste ritorna null.
Metodo pubblico | GetOperation | Se esiste ritorna l'operazione corrispondente al tipo passato altrimenti null.
Metodo pubblico | GetOperationHierarchy | Se esiste ritorna l'operazione corrispondente al tipo passato altrimenti null.
Metodo pubblico | HasOperation | Ritorna vero se nella lista delle operazioni è presente quella corrispondente al tipo passato
Metodo pubblico | HasOperationHierarchy | Ritorna vero se nella lista delle operazioni è presente quella corrispondente al tipo passato
 | IsInParentCollection | Controlla se l'oggetto passato non sia lo stesso di quello corrente o che non sia nell'elenco dei padri
Metodo pubblico | MakeChildrenAuto | Se la collezione di elementi figli è vuota crea automaticamente le dipendenze sfruttando l'apprentice o le deduzioni sul dwg/prt. Viene utilizzata dai comandi quando i file non sono elaborati dal client. Tipicamente i client di Inventor e AutoCAD faranno l'override di questo metodo per costruire le singole dipendenze dei documenti in memoria che si stanno elaborando.
Metodo pubblico | MakeChildrenAuto(DocStructInfoList) | Metodo virtuale per la creazione della struttura ovverridato da client. Se il client non specifica il metodo utilizza comunque le dipendenze salvate nel database.
Metodo pubblico | MakeChildrenAutoByDocDep | Crea la struttura utilizzando esclusivamente le dipendenze nel database. E' necessaria quando si devono indagare documenti che sono già salvati nel db come ad esempio nelle operazioni di apertura.
 | MakeFromDocDocStructInfo | Crea e restituisce una lista di struttura documento clonata da una esistente. Questa funzione si preoccupa di non duplicare elementi nella lista resitituita.
 | MakeFromDocList | Crea e restituisce una lista di struttura documento data una lista di documenti, auto-creando i figli. Questa funzione si preoccupa di non duplicare elementi nella lista resitituita.
 | MakeFromFileList(DedNetApplication, String, Boolean) | Crea e restituisce una lista di struttura documento, data una lista di file, auto-creando i figli. Questa funzione si preoccupa di non duplicare elementi nella lista resitituita.
 | MakeFromFileList(DedNetApplication, String, Boolean, DocStructInfoProgressChangedDelegate) | Crea e restituisce una lista di struttura documento, data una lista di file, auto-creando i figli. Questa funzione si preoccupa di non duplicare elementi nella lista resitituita.
Metodo pubblico | PerformFileOperation |
Metodo pubblico | Rebuild | Solo nel caso l'elemento non sia stato elaborato ed abbia nella lista la sola DocStructOperationBase, la ricrea con il file name già presente. Viene usata per ricreare il documento se questo è cambiato pur non cambiando il suo percorso file.
Metodo pubblico | Reinit | Reinizializza il DocStructInfo riportandolo allo stato originale. Svuota la lista delle operazioni.
Metodo pubblico | SetNotToClone | Imposta questo elemento come Non da Clonare (ToClone = false e CloneFullName = null).
Metodo pubblico | SetToClone | Imposta questo elemento come da Clonare (ToClone = true) e CloneFullName = destFullName).
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Metodo pubblico | UpdateData | Aggiorna le anagrafiche collegate sugli oggetti elaborati. Nella classebase non fa niente.
Metodo pubblico | UpdateDocumentData | Aggiorna tutti il documento dell'oggetto e di tutti i figli
Metodo pubblico | UpdateParentReferences | Aggiorna i riferimenti fisici dei file genitori, di primo livello, per questo elemento. Nella classe base non fa niente.
Metodo pubblico | UpdateReferences | Aggiorna i riferimenti fisici dei file di primo livello per questo elemento e poi chiama l'aggiornamento sui figli. Nella classebase non fa niente.
Torna su
Campi
 | Nome | Descrizione
Campo protetto | Elements | Elementi già presenti nella struttura, utilizzata per evitare duplicati a parità di file.
Campo pubblico | IgnoreCheckParentCollection | Indica se ignorare il controllo sulla ricorsione dei padri.
Campo protetto | Operations | Elementi già presenti nella struttura, utilizzata per evitare duplicati a parità di file.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DocStructInfo
Inizializza l'oggetto con i dati fondamentali.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected DocStructInfo(
    DedNetApplication app,
    DocStructInfoCollection parent,
    DocStructInfoDictionary elements,
    DocStructInfoOperationListDictionary operations,
    DocStructInfoFileDescriptor fileDescr,
    DocDepEnum depType
)
Protected Sub New (
    app As DedNetApplication,
    parent As DocStructInfoCollection,
    elements As DocStructInfoDictionary,
    operations As DocStructInfoOperationListDictionary,
    fileDescr As DocStructInfoFileDescriptor,
    depType As DocDepEnum
)
protected:
DocStructInfo(
    DedNetApplication^ app,
    DocStructInfoCollection^ parent,
    DocStructInfoDictionary^ elements,
    DocStructInfoOperationListDictionary^ operations,
    DocStructInfoFileDescriptor^ fileDescr,
    DocDepEnum depType
)
new :
        app : DedNetApplication *
        parent : DocStructInfoCollection *
        elements : DocStructInfoDictionary *
        operations : DocStructInfoOperationListDictionary *
        fileDescr : DocStructInfoFileDescriptor *
        depType : DocDepEnum -> DocStructInfo

Parametri

app DedNetApplication
Applicazione di appartenenza.
parent DocStructInfoCollection
Collezione di appartenenza (null per il primo oggetto della lista o dell'albero).
elements DocStructInfoDictionary
Lista contenente tutti gli elementi della struttura. Passare null per il primo elemento dell'albero.
operations DocStructInfoOperationListDictionary
fileDescr DocStructInfoFileDescriptor
File del quale ricavare le informazioni.
depType DocDepEnum
Tipo di dipendenza dell'elemento rispetto il padre (indifferente per il primo elemento).
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Proprietà di DocStructInfo

Il tipo DocStructInfo espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione di appartenenza.
Proprietà pubblica | CfgDescr | Restitusice o imposta la configurazione dell'elemento. Utile per la gestione delle configurazioni/modelstate.
Proprietà pubblica | ChildrenMade | Restituisce o imposta se il calcolo delle dipendenza sia già stato eseguito per questo elemento. Viene impostato dalla procedura di calcolo dei figli (quella automatica o quella fatta dal client elaborando i documenti in memoria) per evitare di rielaborare lo stesso elemento più di una volta.
Proprietà pubblica | CloneFullName | Restitsuice il percorso completo di destinazione qualora l'elemento sia da clonare (ToClone = true).
Proprietà pubblica | Config | Restitusice o imposta la configurazione dell'elemento. Utile per la gestione delle configurazioni/modelstate.
Proprietà pubblica | DataUpdated | Restituisce o imposta se l'aggiornamento del riferimento fisico del file sia o meno avvenuta.
Proprietà pubblica | DelToMake | Indica che si deve creare il .del del file di partenza.
Proprietà pubblica | DepType | Restituisce la tipologia di dipendenza.
Proprietà pubblica | Description | Restitusice o imposta una descrizione libera dell'elemento. Utile soprattutto nei nuovi elementi che sono presenti solo in memoria del client.
Proprietà pubblica | DocRowVer | Restituisce il DocRowVer calcolato tramite Md5.
Proprietà pubblica | DoNotMoveOrDelete | Restituisce o imposta se dell'oggetto associato non si deve creare il .moved o il .del. Permette di eseguire l'override del comportamento standard
Proprietà pubblica | FileDescriptor | Restituisce il file descriptor utilizzato alla creazione dell'oggetto
Proprietà pubblica | FileOperationExecuted | Restitusice le operazioni su file di tutte le operazioni presenti nella lista siano state eseguite.
Proprietà pubblica | FirstOperation | Restituisce la prima operazione presente nella lista delle operazioni di questo elemento.
Proprietà pubblica | Folder | Cartella nella quale spostare il file (usata nell'importazione di cartelle)
Proprietà pubblica | FullFileName | Restituisce o imposta l'internalname dell'elemento
Proprietà pubblica | HasChildren | Restitusice se questo elemento ha delle dipendenze.
Proprietà pubblica | HasParent |
Proprietà pubblica | HasSubstitutes | Restituisce se l'elemento abbia o meno sostituti di livello di dettaglio.
Proprietà pubblica | InternalName | Restituisce o imposta l'internalname dell'elemento
Proprietà pubblica | IsElaborated | Restituisce se l'ultima operazione sia o meno stata effettuata.
Proprietà pubblica | IsiModelMember | Restituisce se l'elemento sia o meno un elemento di layout
Proprietà pubblica | IsInRootCopy | Indica se appartiene ad una root su cui fare il Copy. Se non appartiene a nessuna Root restituisce False
Proprietà pubblica | IsLayoutAsset | Restituisce se l'elemento sia o meno un elemento di layout
Proprietà pubblica | IsParentSubstitute | Restituisce se l'elemento sia o meno un sostituto di livello di dettaglio dell'assieme padre in salvataggio.
Proprietà pubblica | IsSpecialStructContainer | Restituisce se l'elemento sia contenitore o meno di strutture speciali
Proprietà pubblica | IsSpecialStructElement | Restituisce se l'elemento rappresenti un componente di struttura speciale
Proprietà pubblica | IsSubstitute | Restituisce se l'elemento sia o meno un parte rappresentante un sostituto di livello di dettaglio
Proprietà pubblica | LastOperation | Restituisce l'ultima operazione presente nella lista delle operazioni di questo elemento.
Proprietà pubblica | LastOperationEnum | Restituisce l'ultima operazione eseguita.
Proprietà pubblica | MakeChildrenOutOfMemory | Impone di creare i figli senza utilizzare eventuali informazioni in memoria del client
Proprietà pubblica | MoveInsteadOfCopy | Restituisce se il documento debba essere spostato invece di importato.
Proprietà pubblica | OperationList | Restituisce la lista in sola lettura, presenti per questo elemento.
Proprietà pubblica | OpListHierarchy | Restituisce la lista in sola lettura, presenti per questo elemento.
Proprietà pubblica | Parent | Restituisce la collezione alla quale appartiene questo elemento. Restituisce null se si tratta della root.
Proprietà pubblica | ReferenceUpdated | Restituisce o imposta se l'aggiornamento del riferimento fisico del file sia o meno avvenuta.
Proprietà pubblica | RelocateInfo | Restituisce o imposta il percorso completo dell'elemento che deve essere ripuntato anzichè elaborato
Proprietà pubblica | SavingTypeDoc | Restituisce o imposta che tipo di relazione abbia questo elemento, in relazione al documento in salvataggio. Serve al comando di salva nel db per capire se un elemento sia stato aggiunto come file associato oppure come file referenziato oppure se si tratti proprio del documento in salvataggio.
Proprietà pubblica | SkipReferenceUpdate | Restituisce se l'ultima operazione deve evitare l'aggiornamento delle reference
Proprietà pubblica | Ties | Restituisce la collezione delle dipendenze.
Proprietà pubblica | ToClone | Restitusice se l'elemento sia o meno da clonare. Leggere in CloneFullName il percorso completo di destinazione.
Proprietà pubblica | UserData | Restituisce o imposta i dati utente abbinati a questo oggetto.
Proprietà pubblica | WasInDb | Restituisce se il file risultasse già registrato nel Database in partenza.
Proprietà pubblica | WasInLibraryPath | Restituisce o imposta se il file di partenza sia o meno in un percorso di libreria (di Inventor).
Torna su
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Proprietà DocStructInfo.Application

Proprietà DocStructInfoApplication
Restituisce l'applicazione di appartenenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedNetApplication Application { get; }
Public ReadOnly Property Application As DedNetApplication
    Get
public:
property DedNetApplication^ Application {
    DedNetApplication^ get ();
}
member Application : DedNetApplication with get

Valore della proprietà

DedNetApplication
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Proprietà DocStructInfo.CfgDescr

Proprietà DocStructInfoCfgDescr
Restitusice o imposta la configurazione dell'elemento. Utile per la gestione delle configurazioni/modelstate.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual ConfigDescriptor CfgDescr { get; }
Public Overridable ReadOnly Property CfgDescr As ConfigDescriptor
    Get
public:
virtual property ConfigDescriptor^ CfgDescr {
    ConfigDescriptor^ get ();
}
abstract CfgDescr : ConfigDescriptor with get
override CfgDescr : ConfigDescriptor with get

Valore della proprietà

ConfigDescriptor
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Proprietà DocStructInfo.ChildrenMade

Proprietà DocStructInfoChildrenMade
Restituisce o imposta se il calcolo delle dipendenza sia già stato eseguito per questo elemento. Viene impostato dalla procedura di calcolo dei figli (quella automatica o quella fatta dal client elaborando i documenti in memoria) per evitare di rielaborare lo stesso elemento più di una volta.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ChildrenMade { get; set; }
Public Property ChildrenMade As Boolean
    Get
    Set
public:
property bool ChildrenMade {
    bool get ();
    void set (bool value);
}
member ChildrenMade : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Proprietà DocStructInfo.CloneFullName

Proprietà DocStructInfoCloneFullName
Restitsuice il percorso completo di destinazione qualora l'elemento sia da clonare (ToClone = true).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string CloneFullName { get; }
Public ReadOnly Property CloneFullName As String
    Get
public:
property String^ CloneFullName {
    String^ get ();
}
member CloneFullName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Proprietà DocStructInfo.Config

Proprietà DocStructInfoConfig
Restitusice o imposta la configurazione dell'elemento. Utile per la gestione delle configurazioni/modelstate.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual string Config { get; }
Public Overridable ReadOnly Property Config As String
    Get
public:
virtual property String^ Config {
    String^ get ();
}
abstract Config : string with get
override Config : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Proprietà DocStructInfo.DataUpdated

Proprietà DocStructInfoDataUpdated
Restituisce o imposta se l'aggiornamento del riferimento fisico del file sia o meno avvenuta.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool DataUpdated { get; set; }
Public Property DataUpdated As Boolean
    Get
    Set
public:
property bool DataUpdated {
    bool get ();
    void set (bool value);
}
member DataUpdated : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Proprietà DocStructInfo.DelToMake

Proprietà DocStructInfoDelToMake
Indica che si deve creare il .del del file di partenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool DelToMake { get; set; }
Public Property DelToMake As Boolean
    Get
    Set
public:
property bool DelToMake {
    bool get ();
    void set (bool value);
}
member DelToMake : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Proprietà DocStructInfo.DepType

Proprietà DocStructInfoDepType
Restituisce la tipologia di dipendenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocDepEnum DepType { get; set; }
Public Property DepType As DocDepEnum
    Get
    Set
public:
property DocDepEnum DepType {
    DocDepEnum get ();
    void set (DocDepEnum value);
}
member DepType : DocDepEnum with get, set

Valore della proprietà

DocDepEnum
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Proprietà DocStructInfo.Description

Proprietà DocStructInfoDescription
Restitusice o imposta una descrizione libera dell'elemento. Utile soprattutto nei nuovi elementi che sono presenti solo in memoria del client.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
member Description : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Proprietà DocStructInfo.DocRowVer

Proprietà DocStructInfoDocRowVer
Restituisce il DocRowVer calcolato tramite Md5.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Guid DocRowVer { get; }
Public ReadOnly Property DocRowVer As Guid
    Get
public:
property Guid DocRowVer {
    Guid get ();
}
member DocRowVer : Guid with get

Valore della proprietà

Guid
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Proprietà DocStructInfo.DoNotMoveOrDelete

Proprietà DocStructInfoDoNotMoveOrDelete
Restituisce o imposta se dell'oggetto associato non si deve creare il .moved o il .del. Permette di eseguire l'override del comportamento standard

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool DoNotMoveOrDelete { get; set; }
Public Property DoNotMoveOrDelete As Boolean
    Get
    Set
public:
property bool DoNotMoveOrDelete {
    bool get ();
    void set (bool value);
}
member DoNotMoveOrDelete : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Proprietà DocStructInfo.FileDescriptor

Proprietà DocStructInfoFileDescriptor
Restituisce il file descriptor utilizzato alla creazione dell'oggetto

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfoFileDescriptor FileDescriptor { get; }
Public ReadOnly Property FileDescriptor As DocStructInfoFileDescriptor
    Get
public:
property DocStructInfoFileDescriptor^ FileDescriptor {
    DocStructInfoFileDescriptor^ get ();
}
member FileDescriptor : DocStructInfoFileDescriptor with get

Valore della proprietà

DocStructInfoFileDescriptor
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Proprietà DocStructInfo.FileOperationExecuted

Proprietà DocStructInfoFileOperationExecuted
Restitusice le operazioni su file di tutte le operazioni presenti nella lista siano state eseguite.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool FileOperationExecuted { get; }
Public ReadOnly Property FileOperationExecuted As Boolean
    Get
public:
property bool FileOperationExecuted {
    bool get ();
}
member FileOperationExecuted : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Proprietà DocStructInfo.FirstOperation

Proprietà DocStructInfoFirstOperation
Restituisce la prima operazione presente nella lista delle operazioni di questo elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructOperationBase FirstOperation { get; }
Public ReadOnly Property FirstOperation As DocStructOperationBase
    Get
public:
property DocStructOperationBase^ FirstOperation {
    DocStructOperationBase^ get ();
}
member FirstOperation : DocStructOperationBase with get

Valore della proprietà

DocStructOperationBase
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Proprietà DocStructInfo.Folder

Proprietà DocStructInfoFolder
Cartella nella quale spostare il file (usata nell'importazione di cartelle)

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Folder { get; set; }
Public Property Folder As String
    Get
    Set
public:
property String^ Folder {
    String^ get ();
    void set (String^ value);
}
member Folder : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Proprietà DocStructInfo.FullFileName

Proprietà DocStructInfoFullFileName
Restituisce o imposta l'internalname dell'elemento

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual string FullFileName { get; }
Public Overridable ReadOnly Property FullFileName As String
    Get
public:
virtual property String^ FullFileName {
    String^ get ();
}
abstract FullFileName : string with get
override FullFileName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Proprietà DocStructInfo.HasChildren

Proprietà DocStructInfoHasChildren
Restitusice se questo elemento ha delle dipendenze.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasChildren { get; }
Public ReadOnly Property HasChildren As Boolean
    Get
public:
property bool HasChildren {
    bool get ();
}
member HasChildren : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Proprietà DocStructInfo.HasParent

Proprietà DocStructInfoHasParent

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasParent { get; }
Public ReadOnly Property HasParent As Boolean
    Get
public:
property bool HasParent {
    bool get ();
}
member HasParent : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Proprietà DocStructInfo.HasSubstitutes

Proprietà DocStructInfoHasSubstitutes
Restituisce se l'elemento abbia o meno sostituti di livello di dettaglio.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual bool HasSubstitutes { get; set; }
Public Overridable Property HasSubstitutes As Boolean
    Get
    Set
public:
virtual property bool HasSubstitutes {
    bool get ();
    void set (bool value);
}
abstract HasSubstitutes : bool with get, set
override HasSubstitutes : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Proprietà DocStructInfo.InternalName

Proprietà DocStructInfoInternalName
Restituisce o imposta l'internalname dell'elemento

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual string InternalName { get; set; }
Public Overridable Property InternalName As String
    Get
    Set
public:
virtual property String^ InternalName {
    String^ get ();
    void set (String^ value);
}
abstract InternalName : string with get, set
override InternalName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Proprietà DocStructInfo.IsElaborated

Proprietà DocStructInfoIsElaborated
Restituisce se l'ultima operazione sia o meno stata effettuata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsElaborated { get; }
Public ReadOnly Property IsElaborated As Boolean
    Get
public:
property bool IsElaborated {
    bool get ();
}
member IsElaborated : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Proprietà DocStructInfo.IsiModelMember

Proprietà DocStructInfoIsiModelMember
Restituisce se l'elemento sia o meno un elemento di layout

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual bool IsiModelMember { get; }
Public Overridable ReadOnly Property IsiModelMember As Boolean
    Get
public:
virtual property bool IsiModelMember {
    bool get ();
}
abstract IsiModelMember : bool with get
override IsiModelMember : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Proprietà DocStructInfo.IsInRootCopy

Proprietà DocStructInfoIsInRootCopy
Indica se appartiene ad una root su cui fare il Copy. Se non appartiene a nessuna Root restituisce False

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsInRootCopy { get; }
Public ReadOnly Property IsInRootCopy As Boolean
    Get
public:
property bool IsInRootCopy {
    bool get ();
}
member IsInRootCopy : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Proprietà DocStructInfo.IsLayoutAsset

Proprietà DocStructInfoIsLayoutAsset
Restituisce se l'elemento sia o meno un elemento di layout

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual bool IsLayoutAsset { get; }
Public Overridable ReadOnly Property IsLayoutAsset As Boolean
    Get
public:
virtual property bool IsLayoutAsset {
    bool get ();
}
abstract IsLayoutAsset : bool with get
override IsLayoutAsset : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Proprietà DocStructInfo.IsParentSubstitute

Proprietà DocStructInfoIsParentSubstitute
Restituisce se l'elemento sia o meno un sostituto di livello di dettaglio dell'assieme padre in salvataggio.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual bool IsParentSubstitute { get; set; }
Public Overridable Property IsParentSubstitute As Boolean
    Get
    Set
public:
virtual property bool IsParentSubstitute {
    bool get ();
    void set (bool value);
}
abstract IsParentSubstitute : bool with get, set
override IsParentSubstitute : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Proprietà DocStructInfo.IsSpecialStructContainer

Proprietà DocStructInfoIsSpecialStructContainer
Restituisce se l'elemento sia contenitore o meno di strutture speciali

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual bool IsSpecialStructContainer { get; }
Public Overridable ReadOnly Property IsSpecialStructContainer As Boolean
    Get
public:
virtual property bool IsSpecialStructContainer {
    bool get ();
}
abstract IsSpecialStructContainer : bool with get
override IsSpecialStructContainer : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Proprietà DocStructInfo.IsSpecialStructElement

Proprietà DocStructInfoIsSpecialStructElement
Restituisce se l'elemento rappresenti un componente di struttura speciale

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual bool IsSpecialStructElement { get; }
Public Overridable ReadOnly Property IsSpecialStructElement As Boolean
    Get
public:
virtual property bool IsSpecialStructElement {
    bool get ();
}
abstract IsSpecialStructElement : bool with get
override IsSpecialStructElement : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Proprietà DocStructInfo.IsSubstitute

Proprietà DocStructInfoIsSubstitute
Restituisce se l'elemento sia o meno un parte rappresentante un sostituto di livello di dettaglio

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual bool IsSubstitute { get; set; }
Public Overridable Property IsSubstitute As Boolean
    Get
    Set
public:
virtual property bool IsSubstitute {
    bool get ();
    void set (bool value);
}
abstract IsSubstitute : bool with get, set
override IsSubstitute : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Proprietà DocStructInfo.LastOperation

Proprietà DocStructInfoLastOperation
Restituisce l'ultima operazione presente nella lista delle operazioni di questo elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructOperationBase LastOperation { get; }
Public ReadOnly Property LastOperation As DocStructOperationBase
    Get
public:
property DocStructOperationBase^ LastOperation {
    DocStructOperationBase^ get ();
}
member LastOperation : DocStructOperationBase with get

Valore della proprietà

DocStructOperationBase
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Proprietà DocStructInfo.LastOperationEnum

Proprietà DocStructInfoLastOperationEnum
Restituisce l'ultima operazione eseguita.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructOperationEnum LastOperationEnum { get; }
Public ReadOnly Property LastOperationEnum As DocStructOperationEnum
    Get
public:
property DocStructOperationEnum LastOperationEnum {
    DocStructOperationEnum get ();
}
member LastOperationEnum : DocStructOperationEnum with get

Valore della proprietà

DocStructOperationEnum
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Proprietà DocStructInfo.MakeChildrenOutOfMemory

Proprietà DocStructInfoMakeChildrenOutOfMemory
Impone di creare i figli senza utilizzare eventuali informazioni in memoria del client

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool MakeChildrenOutOfMemory { get; set; }
Public Property MakeChildrenOutOfMemory As Boolean
    Get
    Set
public:
property bool MakeChildrenOutOfMemory {
    bool get ();
    void set (bool value);
}
member MakeChildrenOutOfMemory : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Proprietà DocStructInfo.MoveInsteadOfCopy

Proprietà DocStructInfoMoveInsteadOfCopy
Restituisce se il documento debba essere spostato invece di importato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool MoveInsteadOfCopy { get; set; }
Public Property MoveInsteadOfCopy As Boolean
    Get
    Set
public:
property bool MoveInsteadOfCopy {
    bool get ();
    void set (bool value);
}
member MoveInsteadOfCopy : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Proprietà DocStructInfo.OperationList

Proprietà DocStructInfoOperationList
Restituisce la lista in sola lettura, presenti per questo elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructOperationBaseList OperationList { get; }
Public ReadOnly Property OperationList As DocStructOperationBaseList
    Get
public:
property DocStructOperationBaseList^ OperationList {
    DocStructOperationBaseList^ get ();
}
member OperationList : DocStructOperationBaseList with get

Valore della proprietà

DocStructOperationBaseList
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Proprietà DocStructInfo.OpListHierarchy

Proprietà DocStructInfoOpListHierarchy
Restituisce la lista in sola lettura, presenti per questo elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructOperationBaseList OpListHierarchy { get; }
Public ReadOnly Property OpListHierarchy As DocStructOperationBaseList
    Get
public:
property DocStructOperationBaseList^ OpListHierarchy {
    DocStructOperationBaseList^ get ();
}
member OpListHierarchy : DocStructOperationBaseList with get

Valore della proprietà

DocStructOperationBaseList
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Proprietà DocStructInfo.Parent

Proprietà DocStructInfoParent
Restituisce la collezione alla quale appartiene questo elemento. Restituisce null se si tratta della root.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfoCollection Parent { get; }
Public ReadOnly Property Parent As DocStructInfoCollection
    Get
public:
property DocStructInfoCollection^ Parent {
    DocStructInfoCollection^ get ();
}
member Parent : DocStructInfoCollection with get

Valore della proprietà

DocStructInfoCollection
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Proprietà DocStructInfo.ReferenceUpdated

Proprietà DocStructInfoReferenceUpdated
Restituisce o imposta se l'aggiornamento del riferimento fisico del file sia o meno avvenuta.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ReferenceUpdated { get; set; }
Public Property ReferenceUpdated As Boolean
    Get
    Set
public:
property bool ReferenceUpdated {
    bool get ();
    void set (bool value);
}
member ReferenceUpdated : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Proprietà DocStructInfo.RelocateInfo

Proprietà DocStructInfoRelocateInfo
Restituisce o imposta il percorso completo dell'elemento che deve essere ripuntato anzichè elaborato

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ModelStateRelocationInfo RelocateInfo { get; set; }
Public Property RelocateInfo As ModelStateRelocationInfo
    Get
    Set
public:
property ModelStateRelocationInfo^ RelocateInfo {
    ModelStateRelocationInfo^ get ();
    void set (ModelStateRelocationInfo^ value);
}
member RelocateInfo : ModelStateRelocationInfo with get, set

Valore della proprietà

ModelStateRelocationInfo
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Proprietà DocStructInfo.SavingTypeDoc

Proprietà DocStructInfoSavingTypeDoc
Restituisce o imposta che tipo di relazione abbia questo elemento, in relazione al documento in salvataggio. Serve al comando di salva nel db per capire se un elemento sia stato aggiunto come file associato oppure come file referenziato oppure se si tratti proprio del documento in salvataggio.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfoSavingFileType SavingTypeDoc { get; set; }
Public Property SavingTypeDoc As DocStructInfoSavingFileType
    Get
    Set
public:
property DocStructInfoSavingFileType SavingTypeDoc {
    DocStructInfoSavingFileType get ();
    void set (DocStructInfoSavingFileType value);
}
member SavingTypeDoc : DocStructInfoSavingFileType with get, set

Valore della proprietà

DocStructInfoSavingFileType
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Proprietà DocStructInfo.SkipReferenceUpdate

Proprietà DocStructInfoSkipReferenceUpdate
Restituisce se l'ultima operazione deve evitare l'aggiornamento delle reference

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool SkipReferenceUpdate { get; }
Public ReadOnly Property SkipReferenceUpdate As Boolean
    Get
public:
property bool SkipReferenceUpdate {
    bool get ();
}
member SkipReferenceUpdate : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Proprietà DocStructInfo.Ties

Proprietà DocStructInfoTies
Restituisce la collezione delle dipendenze.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfoCollection Ties { get; }
Public ReadOnly Property Ties As DocStructInfoCollection
    Get
public:
property DocStructInfoCollection^ Ties {
    DocStructInfoCollection^ get ();
}
member Ties : DocStructInfoCollection with get

Valore della proprietà

DocStructInfoCollection
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Proprietà DocStructInfo.ToClone

Proprietà DocStructInfoToClone
Restitusice se l'elemento sia o meno da clonare. Leggere in CloneFullName il percorso completo di destinazione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ToClone { get; }
Public ReadOnly Property ToClone As Boolean
    Get
public:
property bool ToClone {
    bool get ();
}
member ToClone : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Proprietà DocStructInfo.UserData

Proprietà DocStructInfoUserData
Restituisce o imposta i dati utente abbinati a questo oggetto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object UserData { get; set; }
Public Property UserData As Object
    Get
    Set
public:
property Object^ UserData {
    Object^ get ();
    void set (Object^ value);
}
member UserData : Object with get, set

Valore della proprietà

Object
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Proprietà DocStructInfo.WasInDb

Proprietà DocStructInfoWasInDb
Restituisce se il file risultasse già registrato nel Database in partenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool WasInDb { get; }
Public ReadOnly Property WasInDb As Boolean
    Get
public:
property bool WasInDb {
    bool get ();
}
member WasInDb : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Proprietà DocStructInfo.WasInLibraryPath

Proprietà DocStructInfoWasInLibraryPath
Restituisce o imposta se il file di partenza sia o meno in un percorso di libreria (di Inventor).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool WasInLibraryPath { get; set; }
Public Property WasInLibraryPath As Boolean
    Get
    Set
public:
property bool WasInLibraryPath {
    bool get ();
    void set (bool value);
}
member WasInLibraryPath : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Metodi di DocStructInfo

Il tipo DocStructInfo espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AddAnnullaCheckOutOperation | Annulla il check-out di un documento.
Metodo pubblico | AddCheckInOperation | Imposta in checkin un documento.
Metodo pubblico | AddCheckInStrutturaOperation(Boolean) | Imposta in checkin una struttura di documenti.
Metodo pubblico | AddCheckInStrutturaOperation(Boolean, DictionaryDedDoc, ResultOperationOnStructObject) | Imposta in checkin una struttura di documenti.
Metodo pubblico | AddCheckInStrutturaOperation(Boolean, Boolean, DictionaryDedDoc, ResultOperationOnStructObject) | Imposta in checkin una struttura di documenti.
Metodo pubblico | AddCheckOutOperation(PredicateDedDoc) | Imposta in checkout un documento e si assicura che anche tutte le sue dipendenze siano copiane nella pws.
Metodo pubblico | AddCheckOutOperation(PredicateDedDoc, Boolean) | Imposta in checkout un documento e si assicura che anche tutte le sue dipendenze siano copiane nella pws.
Metodo pubblico | AddCheckOutOperation(PredicateDedDoc, Boolean, Boolean) | Imposta in checkout un documento e si assicura che anche tutte le sue dipendenze siano copiane nella pws.
Metodo pubblico | AddCheckOutOperation(PredicateDedDoc, Boolean, Boolean, Boolean) | Imposta in checkout un documento e si assicura che anche tutte le sue dipendenze siano copiane nella pws.
Metodo pubblico | AddCheckOutOperation(PredicateDedDoc, Boolean, Boolean, Boolean, Boolean) | Imposta in checkout un documento e si assicura che anche tutte le sue dipendenze siano copiane nella pws.
Metodo pubblico | AddCheckOutOperation(PredicateDedDoc, Boolean, Boolean, Boolean, DictionaryDedDoc, ResultOperationOnStructObject) | Imposta in checkout un documento e si assicura che anche tutte le sue dipendenze siano copiane nella pws.
Metodo pubblico | AddCheckOutStrutturaOperation(PredicateDedDoc) | Imposta in checkout un documento e tutte le sue dipendenze. Delegate per la notifica del documento in pws più vecchio rispetto a quello nel vault.
Metodo pubblico | AddCheckOutStrutturaOperation(PredicateDedDoc, Boolean) | Imposta in checkout un documento e tutte le sue dipendenze. Delegate per la notifica del documento in pws più vecchio rispetto a quello nel vault.Indica se l'operazione sia stata aggiunta come sotto-operazione di un CheckOutStruttura.
Metodo pubblico | AddCheckOutStrutturaOperation(PredicateDedDoc, Boolean, Boolean) | Imposta in checkout un documento e tutte le sue dipendenze. Delegate per la notifica del documento in pws più vecchio rispetto a quello nel vault.Indica se l'operazione sia stata aggiunta come sotto-operazione di un CheckOutStruttura.Indica se ignorare il blocco legato allo stato dell'anagrafica.
Metodo pubblico | AddCheckOutStrutturaOperation(PredicateDedDoc, Boolean, Boolean, Boolean, DictionaryDedDoc, ResultOperationOnStructObject) | Imposta in checkout un documento e tutte le sue dipendenze. Delegate per la notifica del documento in pws più vecchio rispetto a quello nel vault.Indica se l'operazione sia stata aggiunta come sotto-operazione di un CheckOutStruttura.Indica se ignorare il blocco legato allo stato dell'anagrafica.Dizionario contenente i risultati dei comandi sui singoli documenti
Metodo pubblico | AddCopyingOperation(String) | Copia un documento da una posizione ad un'altra accettando che il file di partenza non sia presente nel Database. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che non esista il documento sul file di destinazione. Aggiunge anche un'operazione di creazione prima di sé stessa, per creare il documento di destinazione della copia. Rimane da operare la copia fisica da parte del comando chiamante oppure del client.
Metodo pubblico | AddCopyingOperation(String, Boolean) | Copia un documento da una posizione ad un'altra accettando che il file di partenza non sia presente nel Database. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che non esista il documento sul file di destinazione. Aggiunge anche un'operazione di creazione prima di sé stessa, per creare il documento di destinazione della copia. Rimane da operare la copia fisica da parte del comando chiamante oppure del client.
Metodo pubblico | AddCreatingOperation | Valuta le informazioni presenti nell'ultima operazione disponibile e, se il documento non è presente, lo crea con il file impostato nell'operazione. Se il documento esiste già non fa nulla se non verificare che non si tratti di un nuovo documento (in questo caso solleva una eccezione) ed imposta l'operazione come effettuata. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, non controlla nemmeno l'esistenza del file. L'operazione da effettuare successivamente, se il file non esiste già, è di crearlo nella posizione di destinazione.
Metodo pubblico | AddCreatingOperation(String) | Crea un nuovo documento leggendo le informazioni presenti nell'ultima operazione disponibile ma utilizzando il percorso di file passato come argomento. Se il documento esiste già non fa nulla se non verificare che non si tratti di un nuovo documento (in questo caso solleva una eccezione) ed imposta l'operazione come effettuata. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, non controlla nemmeno l'esistenza del file. L'operazione da effettuare successivamente, se il file non esiste già, è di crearlo nella posizione di destinazione.
Metodo pubblico | AddDisconnectingOperation(DedComm) | Scollega il documento presente nell'ultima operazione, da una commessa. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che il documento da scollegare sia effettivamente collegato alla commessa.
Metodo pubblico | AddDisconnectingOperation(DedData) | Scollega il documento presente nell'ultima operazione, da un'anagrafica. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che il documento da scollegare sia effettivamente collegato all'anagrafica.
Metodo pubblico | AddEnsureLocalOperation(PredicateDedDoc, Boolean) | Copia il file dal vault all'area locale. Non effettua controlli sui permessi. Copia anche tutti i file dipendenti, necessari al documento principale.
Metodo pubblico | AddEnsureLocalOperation(PredicateDedDoc, Boolean, Boolean) | Copia il file dal vault all'area locale. Non effettua controlli sui permessi. Copia anche tutti i file dipendenti, necessari al documento principale.
Metodo pubblico | AddEnsureLocalOperation(PredicateDedDoc, Boolean, ListException) | Copia il file dal vault all'area locale. Non effettua controlli sui permessi. Copia anche tutti i file dipendenti, necessari al documento principale.
Metodo pubblico | AddEnsureLocalOperation(PredicateDedDoc, Boolean, Boolean, Boolean) | Copia il file dal vault all'area locale. Non effettua controlli sui permessi. Copia anche tutti i file dipendenti, necessari al documento principale.
Metodo pubblico | AddEnsureLocalOperation(PredicateDedDoc, Boolean, ListException, Boolean) | Copia il file dal vault all'area locale. Non effettua controlli sui permessi. Copia anche tutti i file dipendenti, necessari al documento principale.
Metodo pubblico | AddExportingOperation(Boolean, String, String) | Operazione di esportazione del documento
Metodo pubblico | AddExportingOperation(Boolean, String, String, Boolean) | Operazione di esportazione del documento
Metodo pubblico | AddExportingStrutturaOperation | Operazione di esportazione del documento (struttura)
Metodo pubblico | AddForzaCheckInOperation | Forza in checkin un documento.
Metodo pubblico | AddForzaCheckInStrutturaOperation | Imposta in checkin una struttura di documenti.
Metodo pubblico | AddForzaCheckInStrutturaOperation(Boolean) | Imposta in checkin una struttura di documenti.
Metodo pubblico | AddImportingOperation(DedComm, OperationChoiceEnum) | Copia il documentodi partenza, proveniente da qualsiasi origine, nella posizione corrette per associarlo alla commessa. Le logiche sono le stesse dell'importazione legata all'anagrafica.
Metodo pubblico | AddImportingOperation(DedData, DedDocContextEnum) | Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica.
Metodo pubblico | AddImportingOperation(DedData, Boolean) | Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica.
Metodo pubblico | AddImportingOperation(DedEco, OperationChoiceEnum) | Copia il documento di partenza, proveniente da qualsiasi origine, nella posizione corrette per associarlo all'Eco. Le logiche sono le stesse dell'importazione legata alla commessa.
Metodo pubblico | AddImportingOperation(DedData, DedDocContextEnum, Boolean) | Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica.
Metodo pubblico | AddImportingOperation(DedData, Boolean, Boolean) | Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica.
Metodo pubblico | AddImportingOperation(DedData, Boolean, String) | Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica.
Metodo pubblico | AddImportingOperation(DedData, DedDocContextEnum, Boolean, String) |
Metodo pubblico | AddImportingOperation(DedData, Boolean, Boolean, String) | Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica.
Metodo pubblico | AddImportingOperation(DedData, Boolean, String, String) | Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica.
Metodo pubblico | AddImportingOperation(DedData, Boolean, Boolean, String, OperationChoiceEnum) | Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica.
Metodo pubblico | AddImportingOperation(DedData, Boolean, Boolean, String, Boolean) |
Metodo pubblico | AddImportingOperation(DedData, Boolean, Boolean, String, Boolean, Boolean) | Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica.
Metodo pubblico | AddImportingOperation(DedData, Boolean, Boolean, String, Boolean, String) |
Metodo pubblico | AddLinkingOperation(DedComm) | Collega il documento ad una commessa
Metodo pubblico | AddLinkingOperation(DedEco) | Collega il documento ad un Eco
Metodo pubblico | AddLinkingOperation(DedData, DedDocContextEnum) | Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido.
Metodo pubblico | AddLinkingOperation(DedData, Boolean) | Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido.
Metodo pubblico | AddLinkingOperation(DedData, DedDocContextEnum, DedData) | Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido.
Metodo pubblico | AddLinkingOperation(DedData, Boolean, DedData) | Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido.
Metodo pubblico | AddLinkingOperation(DedData, DedDocContextEnum, DedData, ConfigDescriptor) | Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido.
Metodo pubblico | AddLinkingOperation(DedData, Boolean, DedData, ConfigDescriptor) | Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido.
Metodo pubblico | AddLinkingOperation(DedData, DedDocContextEnum, DedData, ConfigDescriptor, Boolean) | Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido.
Metodo pubblico | AddLinkingOperation(DedData, Boolean, DedData, ConfigDescriptor, Boolean) | Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido.
Metodo pubblico | AddLinkingOperation(DedData, Boolean, DedData, ConfigDescriptor, Boolean, DictionaryString, DedDocContext) | Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido.
Metodo pubblico | AddMovingOperation(String, DedDocMovReasonEnum) | Sposta un documento da una posizione ad un'altra utilizzando lo stesso ID documento. Il guid del documento rimane lo stesso di partenza perché si presume che si stia lavorando su disco e non in memoria (non è considerato il caso di lavorare in memoria per rinominare un file). Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che non esista il documento sul file di destinazione. Rimane da operare lo spostamento fisico da parte del comando chiamante oppure del client.
Metodo pubblico | AddMovingOperation(String, DedDocMovReasonEnum, Boolean) | Sposta un documento da una posizione ad un'altra utilizzando lo stesso ID documento. Il guid del documento rimane lo stesso di partenza perché si presume che si stia lavorando su disco e non in memoria (non è considerato il caso di lavorare in memoria per rinominare un file). Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che non esista il documento sul file di destinazione. Rimane da operare lo spostamento fisico da parte del comando chiamante oppure del client.
Metodo pubblico | AddMovingOperation(String, DedDocMovReasonEnum, Boolean, Boolean) | Sposta un documento da una posizione ad un'altra utilizzando lo stesso ID documento. Il guid del documento rimane lo stesso di partenza perché si presume che si stia lavorando su disco e non in memoria (non è considerato il caso di lavorare in memoria per rinominare un file). Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che non esista il documento sul file di destinazione. Rimane da operare lo spostamento fisico da parte del comando chiamante oppure del client.
Metodo pubblico | AddPubblicaOperation | Aggiunge una operazione di pubblicazione.
Metodo pubblico | AddPubblicaStrutturaOperation | Aggiunge una operazione di pubblicazione.
Metodo pubblico | AddRecogniseOperation(DedComm) | Associa un file ad una commessa creando il documento se non esiste già, lasciando il file col nome originale. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di crea(se necessrio) + link, per creare il documento e collegarlo all'anagrafica.
Metodo pubblico | AddRecogniseOperation(DedData, Boolean) | Associa un file ad un'anagrafica creando il documento se non esiste già, lasciando il file col nome originale. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di crea(se necessrio) + link, per creare il documento e collegarlo all'anagrafica.
Metodo pubblico | AddRecogniseOperation(DedData, Boolean, ConfigDescriptor) | Associa un file ad un'anagrafica creando il documento se non esiste già, lasciando il file col nome originale. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di crea(se necessrio) + link, per creare il documento e collegarlo all'anagrafica.
Metodo pubblico | AddRecogniseOperation(DedData, Boolean, ConfigDescriptor, Boolean) | Associa un file ad un'anagrafica creando il documento se non esiste già, lasciando il file col nome originale. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di crea(se necessrio) + link, per creare il documento e collegarlo all'anagrafica.
Metodo pubblico | AddRecogniseOperation(DedData, Boolean, ConfigDescriptor, Boolean, DictionaryString, DedDocContext) | Associa un file ad un'anagrafica creando il documento se non esiste già, lasciando il file col nome originale. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di crea(se necessrio) + link, per creare il documento e collegarlo all'anagrafica.
Metodo pubblico | AddRelocateOperation(DedDoc, Boolean) | Operazione di rilocazione di un file esterno su un documento interno. Permette di "puntare" semplicemente il documento interno ma anche di eseguire l'overwrite fisico come nel caso del replace.
Metodo pubblico | AddRelocateOperation(DedDoc, Boolean, Boolean) | Operazione di rilocazione di un file esterno su un documento interno. Permette di "puntare" semplicemente il documento interno ma anche di eseguire l'overwrite fisico come nel caso del replace.
Metodo pubblico | AddRemovingOperation | Elimina il documento presente nell'ultima operazione. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che il documento da eliminare esista.
Metodo pubblico | AddReplaceOperation(DocStructInfo) | Copia un file sul file fisico di un altro documento sostituendolo. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che esista il documento di destinazione. Aggiunge anche un'operazione di creazione per le dipendenze, per essere sicuri di avere nel Db tutti documenti dipendenti e di aggiornamento per il documento in sostituzione. Rimane da operare la copia fisica da parte del comando chiamante oppure del client.
Metodo pubblico | AddReplaceOperation(String) | Copia un file sul file fisico di un altro documento sostituendolo. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che esista il documento di destinazione. Aggiunge anche un'operazione di creazione per le dipendenze, per essere sicuri di avere nel Db tutti documenti dipendenti e di aggiornamento per il documento in sostituzione. Rimane da operare la copia fisica da parte del comando chiamante oppure del client.
Metodo pubblico | AddSbloccaOperation | Sblocca un documento.
Metodo pubblico | AddUpdatingOperation | Effettua l'operazione di aggiornamento del documento nel Database leggendo l'ultima operazione disponibile ed imposta con Updating l'operazione. Verifica che il documento esista già e poi aggiorna il documento nel Database con le sue dipendenze. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, non controlla nemmeno l'esistenza del file. L'operazione da effettuare successivamente, se il file non esiste già, è di crearlo nella posizione di destinazione.
Metodo pubblico | BottomUpCall | Chiama tutti gli elementi, compreso l'elemento corrente, ma per ultimo, partendo dal basso (ultimi nodi) e procedendo verso l'alto.
Metodo pubblico | CreateDocStructInfo(DocStructInfoFileDescriptor) | Crea e restituisce un nuovo oggetto evitando i duplicati, infatti cerca prima negli elementi interni e se lo trova restituisce l'elemento trovato, altrimenti crea un nuovo oggetto che comunque condivide gli elementi di questo oggetto. È indispensabile chiamare questo metodo per creare un oggetto dopo la chiamata all'omonimo metodo statico per la creazione del primo elemento. NOTA: Non crea la sotto struttura!! Chiamare MakeChildrenAuto() per ottenerla tramite apprentice.
Metodo pubblico | CreateDocStructInfo(String) | Crea e restituisce un nuovo oggetto evitando i duplicati, infatti cerca prima negli elementi interni e se lo trova restituisce l'elemento trovato, altrimenti crea un nuovo oggetto che comunque condivide gli elementi di questo oggetto. È indispensabile chiamare questo metodo per creare un oggetto dopo la chiamata all'omonimo metodo statico per la creazione del primo elemento. NOTA: Non crea la sotto struttura!! Chiamare MakeChildrenAuto() per ottenerla tramite apprentice.
 | CreateDocStructInfo(DedNetApplication, DocStructInfoFileDescriptor) | Crea e restituisce un nuovo oggetto DocStructInfo. Questo metodo è da utilizzare per la creazione del primo elemento, dopo si deve utilizzare la versione omonima d'istanza per creare gli oggetti successivi, in modo da evitare duplicati nella struttura dei documenti.
 | CreateDocStructInfo(DedNetApplication, String) | Crea e restituisce un nuovo oggetto DocStructInfo. Questo metodo è da utilizzare per la creazione del primo elemento, dopo si deve utilizzare la versione omonima d'istanza per creare gli oggetti successivi, in modo da evitare duplicati nella struttura dei documenti.
Metodo pubblico | CreateDocStructInfo(DocStructInfoFileDescriptor, DocStructInfo) | Crea e restituisce un nuovo oggetto evitando i duplicati, infatti cerca prima negli elementi interni e se lo trova restituisce l'elemento trovato, altrimenti crea un nuovo oggetto che comunque condivide gli elementi di questo oggetto. È indispensabile chiamare questo metodo per creare un oggetto dopo la chiamata all'omonimo metodo statico per la creazione del primo elemento. Il nuovo elemento viene impostato come figlio di questa istanza. NOTA: Non crea la sotto struttura!! Chiamare MakeChildrenAuto() per ottenerla tramite apprentice.
Metodo pubblico | CreateDocStructInfo(String, ConfigDescriptor) | Crea e restituisce un nuovo oggetto evitando i duplicati, infatti cerca prima negli elementi interni e se lo trova restituisce l'elemento trovato, altrimenti crea un nuovo oggetto che comunque condivide gli elementi di questo oggetto. È indispensabile chiamare questo metodo per creare un oggetto dopo la chiamata all'omonimo metodo statico per la creazione del primo elemento. NOTA: Non crea la sotto struttura!! Chiamare MakeChildrenAuto() per ottenerla tramite apprentice.
 | CreateDocStructInfo(DedNetApplication, String, ConfigDescriptor) | Crea e restituisce un nuovo oggetto DocStructInfo. Questo metodo è da utilizzare per la creazione del primo elemento, dopo si deve utilizzare la versione omonima d'istanza per creare gli oggetti successivi, in modo da evitare duplicati nella struttura dei documenti.
Metodo pubblico | EnforcedMakeChildrenAuto | Nella classe base la forzatura diviene in gestibile pertanto equiparo la chiamata ad un makeChildrenAuto normale per leggere le docdep salvate.
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | FileNameAreEquals |
Metodo pubblico | FindAllLevels |
Metodo pubblico | GetAllSpecialChildren | Ritorna tutti i figli dell'elemento che sono elementi della struttura speciale
Metodo pubblico | GetFileNameHashString |
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | GetHashString |
Metodo pubblico | GetLastQueuedOperation | Ritorna l'ultima operazione presente in lista appartenenete al tipo specificato. Se l'operazione non esiste ritorna null.
Metodo pubblico | GetOperation | Se esiste ritorna l'operazione corrispondente al tipo passato altrimenti null.
Metodo pubblico | GetOperationHierarchy | Se esiste ritorna l'operazione corrispondente al tipo passato altrimenti null.
Metodo pubblico | HasOperation | Ritorna vero se nella lista delle operazioni è presente quella corrispondente al tipo passato
Metodo pubblico | HasOperationHierarchy | Ritorna vero se nella lista delle operazioni è presente quella corrispondente al tipo passato
 | IsInParentCollection | Controlla se l'oggetto passato non sia lo stesso di quello corrente o che non sia nell'elenco dei padri
Metodo pubblico | MakeChildrenAuto | Se la collezione di elementi figli è vuota crea automaticamente le dipendenze sfruttando l'apprentice o le deduzioni sul dwg/prt. Viene utilizzata dai comandi quando i file non sono elaborati dal client. Tipicamente i client di Inventor e AutoCAD faranno l'override di questo metodo per costruire le singole dipendenze dei documenti in memoria che si stanno elaborando.
Metodo pubblico | MakeChildrenAuto(DocStructInfoList) | Metodo virtuale per la creazione della struttura ovverridato da client. Se il client non specifica il metodo utilizza comunque le dipendenze salvate nel database.
Metodo pubblico | MakeChildrenAutoByDocDep | Crea la struttura utilizzando esclusivamente le dipendenze nel database. E' necessaria quando si devono indagare documenti che sono già salvati nel db come ad esempio nelle operazioni di apertura.
 | MakeFromDocDocStructInfo | Crea e restituisce una lista di struttura documento clonata da una esistente. Questa funzione si preoccupa di non duplicare elementi nella lista resitituita.
 | MakeFromDocList | Crea e restituisce una lista di struttura documento data una lista di documenti, auto-creando i figli. Questa funzione si preoccupa di non duplicare elementi nella lista resitituita.
 | MakeFromFileList(DedNetApplication, String, Boolean) | Crea e restituisce una lista di struttura documento, data una lista di file, auto-creando i figli. Questa funzione si preoccupa di non duplicare elementi nella lista resitituita.
 | MakeFromFileList(DedNetApplication, String, Boolean, DocStructInfoProgressChangedDelegate) | Crea e restituisce una lista di struttura documento, data una lista di file, auto-creando i figli. Questa funzione si preoccupa di non duplicare elementi nella lista resitituita.
Metodo pubblico | PerformFileOperation |
Metodo pubblico | Rebuild | Solo nel caso l'elemento non sia stato elaborato ed abbia nella lista la sola DocStructOperationBase, la ricrea con il file name già presente. Viene usata per ricreare il documento se questo è cambiato pur non cambiando il suo percorso file.
Metodo pubblico | Reinit | Reinizializza il DocStructInfo riportandolo allo stato originale. Svuota la lista delle operazioni.
Metodo pubblico | SetNotToClone | Imposta questo elemento come Non da Clonare (ToClone = false e CloneFullName = null).
Metodo pubblico | SetToClone | Imposta questo elemento come da Clonare (ToClone = true) e CloneFullName = destFullName).
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Metodo pubblico | UpdateData | Aggiorna le anagrafiche collegate sugli oggetti elaborati. Nella classebase non fa niente.
Metodo pubblico | UpdateDocumentData | Aggiorna tutti il documento dell'oggetto e di tutti i figli
Metodo pubblico | UpdateParentReferences | Aggiorna i riferimenti fisici dei file genitori, di primo livello, per questo elemento. Nella classe base non fa niente.
Metodo pubblico | UpdateReferences | Aggiorna i riferimenti fisici dei file di primo livello per questo elemento e poi chiama l'aggiornamento sui figli. Nella classebase non fa niente.
Torna su
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Metodo DocStructInfo.AddAnnullaCheckOutOperation

Metodo DocStructInfoAddAnnullaCheckOutOperation
Annulla il check-out di un documento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddAnnullaCheckOutOperation(
    bool deletingPwsFile
)
Public Sub AddAnnullaCheckOutOperation (
    deletingPwsFile As Boolean
)
public:
void AddAnnullaCheckOutOperation(
    bool deletingPwsFile
)
member AddAnnullaCheckOutOperation :
        deletingPwsFile : bool -> unit

Parametri

deletingPwsFile Boolean
Indica se il comando eliminerà o meno il documento in locale.
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Metodo DocStructInfo.AddCheckInOperation

Metodo DocStructInfoAddCheckInOperation
Imposta in checkin un documento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddCheckInOperation(
    bool deletingPwsFile
)
Public Sub AddCheckInOperation (
    deletingPwsFile As Boolean
)
public:
void AddCheckInOperation(
    bool deletingPwsFile
)
member AddCheckInOperation :
        deletingPwsFile : bool -> unit

Parametri

deletingPwsFile Boolean
Indica se il comando di Check-in eliminerà o meno il documento in locale. Questo serve per indicare di eliminare il record in DED_DOC_USER nel caso di variabile a true.
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Metodo DocStructInfo.AddCheckInStrutturaOperation

Metodo DocStructInfoAddCheckInStrutturaOperation
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AddCheckInStrutturaOperation(Boolean) | Imposta in checkin una struttura di documenti.
Metodo pubblico | AddCheckInStrutturaOperation(Boolean, DictionaryDedDoc, ResultOperationOnStructObject) | Imposta in checkin una struttura di documenti.
Metodo pubblico | AddCheckInStrutturaOperation(Boolean, Boolean, DictionaryDedDoc, ResultOperationOnStructObject) | Imposta in checkin una struttura di documenti.
Torna su
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Metodo DocStructInfo.AddCheckInStrutturaOperation(Boolean)

Metodo DocStructInfoAddCheckInStrutturaOperation(Boolean)
Imposta in checkin una struttura di documenti.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddCheckInStrutturaOperation(
    bool deletingPwsFile
)
Public Sub AddCheckInStrutturaOperation (
    deletingPwsFile As Boolean
)
public:
void AddCheckInStrutturaOperation(
    bool deletingPwsFile
)
member AddCheckInStrutturaOperation :
        deletingPwsFile : bool -> unit

Parametri

deletingPwsFile Boolean
Indica se il comando di Check-in eliminerà o meno il documento in locale. Questo serve per indicare di eliminare il record in DED_DOC_USER nel caso di variabile a true.
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddCheckInStrutturaOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddCheckInStrutturaOperation(Boolean, Dictionary<DedDoc, ResultOperationOnStructObject>)

Metodo DocStructInfoAddCheckInStrutturaOperation(Boolean, DictionaryDedDoc, ResultOperationOnStructObject)
Imposta in checkin una struttura di documenti.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddCheckInStrutturaOperation(
    bool deletingPwsFile,
    Dictionary<DedDoc, ResultOperationOnStructObject> resultOperation
)
Public Sub AddCheckInStrutturaOperation (
    deletingPwsFile As Boolean,
    resultOperation As Dictionary(Of DedDoc, ResultOperationOnStructObject)
)
public:
void AddCheckInStrutturaOperation(
    bool deletingPwsFile,
    Dictionary<DedDoc^, ResultOperationOnStructObject^>^ resultOperation
)
member AddCheckInStrutturaOperation :
        deletingPwsFile : bool *
        resultOperation : Dictionary<DedDoc, ResultOperationOnStructObject> -> unit

Parametri

deletingPwsFile Boolean
Indica se il comando di Check-in eliminerà o meno il documento in locale. Questo serve per indicare di eliminare il record in DED_DOC_USER nel caso di variabile a true.
resultOperation Dictionary DedDoc, ResultOperationOnStructObject
Dizionario contenente i risultati dei comandi sui singoli documenti
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddCheckInStrutturaOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddCheckInStrutturaOperation(Boolean, Boolean, Dictionary<DedDoc, ResultOperationOnStructObject>)

Metodo DocStructInfoAddCheckInStrutturaOperation(Boolean, Boolean, DictionaryDedDoc, ResultOperationOnStructObject)
Imposta in checkin una struttura di documenti.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddCheckInStrutturaOperation(
    bool deletingPwsFile,
    bool isChildOperation,
    Dictionary<DedDoc, ResultOperationOnStructObject> resultOperation
)
Public Sub AddCheckInStrutturaOperation (
    deletingPwsFile As Boolean,
    isChildOperation As Boolean,
    resultOperation As Dictionary(Of DedDoc, ResultOperationOnStructObject)
)
public:
void AddCheckInStrutturaOperation(
    bool deletingPwsFile,
    bool isChildOperation,
    Dictionary<DedDoc^, ResultOperationOnStructObject^>^ resultOperation
)
member AddCheckInStrutturaOperation :
        deletingPwsFile : bool *
        isChildOperation : bool *
        resultOperation : Dictionary<DedDoc, ResultOperationOnStructObject> -> unit

Parametri

deletingPwsFile Boolean
Indica se il comando di Check-in eliminerà o meno il documento in locale. Questo serve per indicare di eliminare il record in DED_DOC_USER nel caso di variabile a true.
isChildOperation Boolean
Indica se l'operazione sia stata aggiunta come sotto-operazione di un CheckInStruttura.
resultOperation Dictionary DedDoc, ResultOperationOnStructObject
Dizionario contenente i risultati dei comandi sui singoli documenti
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddCheckInStrutturaOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddCheckOutOperation

Metodo DocStructInfoAddCheckOutOperation
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AddCheckOutOperation(PredicateDedDoc) | Imposta in checkout un documento e si assicura che anche tutte le sue dipendenze siano copiane nella pws.
Metodo pubblico | AddCheckOutOperation(PredicateDedDoc, Boolean) | Imposta in checkout un documento e si assicura che anche tutte le sue dipendenze siano copiane nella pws.
Metodo pubblico | AddCheckOutOperation(PredicateDedDoc, Boolean, Boolean) | Imposta in checkout un documento e si assicura che anche tutte le sue dipendenze siano copiane nella pws.
Metodo pubblico | AddCheckOutOperation(PredicateDedDoc, Boolean, Boolean, Boolean) | Imposta in checkout un documento e si assicura che anche tutte le sue dipendenze siano copiane nella pws.
Metodo pubblico | AddCheckOutOperation(PredicateDedDoc, Boolean, Boolean, Boolean, Boolean) | Imposta in checkout un documento e si assicura che anche tutte le sue dipendenze siano copiane nella pws.
Metodo pubblico | AddCheckOutOperation(PredicateDedDoc, Boolean, Boolean, Boolean, DictionaryDedDoc, ResultOperationOnStructObject) | Imposta in checkout un documento e si assicura che anche tutte le sue dipendenze siano copiane nella pws.
Torna su
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Metodo DocStructInfo.AddCheckOutOperation(Predicate<DedDoc>)

Metodo DocStructInfoAddCheckOutOperation(PredicateDedDoc)
Imposta in checkout un documento e si assicura che anche tutte le sue dipendenze siano copiane nella pws.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddCheckOutOperation(
    Predicate<DedDoc> localIsOlderNotifier
)
Public Sub AddCheckOutOperation (
    localIsOlderNotifier As Predicate(Of DedDoc)
)
public:
void AddCheckOutOperation(
    Predicate<DedDoc^>^ localIsOlderNotifier
)
member AddCheckOutOperation :
        localIsOlderNotifier : Predicate<DedDoc> -> unit

Parametri

localIsOlderNotifier Predicate DedDoc
Delegate per la notifica del documento in pws più vecchio rispetto a quello nel vault.
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddCheckOutOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddCheckOutOperation(Predicate<DedDoc>, Boolean)

Metodo DocStructInfoAddCheckOutOperation(PredicateDedDoc, Boolean)
Imposta in checkout un documento e si assicura che anche tutte le sue dipendenze siano copiane nella pws.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddCheckOutOperation(
    Predicate<DedDoc> localIsOlderNotifier,
    bool isChildrenOperation
)
Public Sub AddCheckOutOperation (
    localIsOlderNotifier As Predicate(Of DedDoc),
    isChildrenOperation As Boolean
)
public:
void AddCheckOutOperation(
    Predicate<DedDoc^>^ localIsOlderNotifier,
    bool isChildrenOperation
)
member AddCheckOutOperation :
        localIsOlderNotifier : Predicate<DedDoc> *
        isChildrenOperation : bool -> unit

Parametri

localIsOlderNotifier Predicate DedDoc
Delegate per la notifica del documento in pws più vecchio rispetto a quello nel vault.
isChildrenOperation Boolean
Indica se si tratta di una operazione su un figlio.
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddCheckOutOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddCheckOutOperation(Predicate<DedDoc>, Boolean, Boolean)

Metodo DocStructInfoAddCheckOutOperation(PredicateDedDoc, Boolean, Boolean)
Imposta in checkout un documento e si assicura che anche tutte le sue dipendenze siano copiane nella pws.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddCheckOutOperation(
    Predicate<DedDoc> localIsOlderNotifier,
    bool isChildrenOperation,
    bool ignoreDataLockState
)
Public Sub AddCheckOutOperation (
    localIsOlderNotifier As Predicate(Of DedDoc),
    isChildrenOperation As Boolean,
    ignoreDataLockState As Boolean
)
public:
void AddCheckOutOperation(
    Predicate<DedDoc^>^ localIsOlderNotifier,
    bool isChildrenOperation,
    bool ignoreDataLockState
)
member AddCheckOutOperation :
        localIsOlderNotifier : Predicate<DedDoc> *
        isChildrenOperation : bool *
        ignoreDataLockState : bool -> unit

Parametri

localIsOlderNotifier Predicate DedDoc
Delegate per la notifica del documento in pws più vecchio rispetto a quello nel vault.
isChildrenOperation Boolean
Indica se si tratta di una operazione su un figlio.
ignoreDataLockState Boolean
Indica se ignorare il blocco legato allo stato dell'anagrafica.
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddCheckOutOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddCheckOutOperation(Predicate<DedDoc>, Boolean, Boolean, Boolean)

Metodo DocStructInfoAddCheckOutOperation(PredicateDedDoc, Boolean, Boolean, Boolean)
Imposta in checkout un documento e si assicura che anche tutte le sue dipendenze siano copiane nella pws.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddCheckOutOperation(
    Predicate<DedDoc> localIsOlderNotifier,
    bool isChildrenOperation,
    bool ignoreDataLockState,
    bool ignoreFileExistingEnsureLocal
)
Public Sub AddCheckOutOperation (
    localIsOlderNotifier As Predicate(Of DedDoc),
    isChildrenOperation As Boolean,
    ignoreDataLockState As Boolean,
    ignoreFileExistingEnsureLocal As Boolean
)
public:
void AddCheckOutOperation(
    Predicate<DedDoc^>^ localIsOlderNotifier,
    bool isChildrenOperation,
    bool ignoreDataLockState,
    bool ignoreFileExistingEnsureLocal
)
member AddCheckOutOperation :
        localIsOlderNotifier : Predicate<DedDoc> *
        isChildrenOperation : bool *
        ignoreDataLockState : bool *
        ignoreFileExistingEnsureLocal : bool -> unit

Parametri

localIsOlderNotifier Predicate DedDoc
Delegate per la notifica del documento in pws più vecchio rispetto a quello nel vault.
isChildrenOperation Boolean
Indica se si tratta di una operazione su un figlio.
ignoreDataLockState Boolean
Indica se ignorare il blocco legato allo stato dell'anagrafica.
ignoreFileExistingEnsureLocal Boolean
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddCheckOutOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddCheckOutOperation(Predicate<DedDoc>, Boolean, Boolean, Boolean, Boolean)

Metodo DocStructInfoAddCheckOutOperation(PredicateDedDoc, Boolean, Boolean, Boolean, Boolean)
Imposta in checkout un documento e si assicura che anche tutte le sue dipendenze siano copiane nella pws.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddCheckOutOperation(
    Predicate<DedDoc> localIsOlderNotifier,
    bool isChildrenOperation,
    bool ignoreDataLockState,
    bool ignoreFileExistingEnsureLocal,
    bool ignoreCopyIfFileExistsEnsureLocal
)
Public Sub AddCheckOutOperation (
    localIsOlderNotifier As Predicate(Of DedDoc),
    isChildrenOperation As Boolean,
    ignoreDataLockState As Boolean,
    ignoreFileExistingEnsureLocal As Boolean,
    ignoreCopyIfFileExistsEnsureLocal As Boolean
)
public:
void AddCheckOutOperation(
    Predicate<DedDoc^>^ localIsOlderNotifier,
    bool isChildrenOperation,
    bool ignoreDataLockState,
    bool ignoreFileExistingEnsureLocal,
    bool ignoreCopyIfFileExistsEnsureLocal
)
member AddCheckOutOperation :
        localIsOlderNotifier : Predicate<DedDoc> *
        isChildrenOperation : bool *
        ignoreDataLockState : bool *
        ignoreFileExistingEnsureLocal : bool *
        ignoreCopyIfFileExistsEnsureLocal : bool -> unit

Parametri

localIsOlderNotifier Predicate DedDoc
Delegate per la notifica del documento in pws più vecchio rispetto a quello nel vault.
isChildrenOperation Boolean
Indica se si tratta di una operazione su un figlio.
ignoreDataLockState Boolean
Indica se ignorare il blocco legato allo stato dell'anagrafica.
ignoreFileExistingEnsureLocal Boolean
ignoreCopyIfFileExistsEnsureLocal Boolean
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddCheckOutOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddCheckOutOperation(Predicate<DedDoc>, Boolean, Boolean, Boolean, Dictionary<DedDoc, ResultOperationOnStructObject>)

Metodo DocStructInfoAddCheckOutOperation(PredicateDedDoc, Boolean, Boolean, Boolean, DictionaryDedDoc, ResultOperationOnStructObject)
Imposta in checkout un documento e si assicura che anche tutte le sue dipendenze siano copiane nella pws.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddCheckOutOperation(
    Predicate<DedDoc> localIsOlderNotifier,
    bool isChildrenOperation,
    bool ignoreDataLockState,
    bool ignoreFileExistingEnsureLocal,
    Dictionary<DedDoc, ResultOperationOnStructObject> resultOperation
)
Public Sub AddCheckOutOperation (
    localIsOlderNotifier As Predicate(Of DedDoc),
    isChildrenOperation As Boolean,
    ignoreDataLockState As Boolean,
    ignoreFileExistingEnsureLocal As Boolean,
    resultOperation As Dictionary(Of DedDoc, ResultOperationOnStructObject)
)
public:
void AddCheckOutOperation(
    Predicate<DedDoc^>^ localIsOlderNotifier,
    bool isChildrenOperation,
    bool ignoreDataLockState,
    bool ignoreFileExistingEnsureLocal,
    Dictionary<DedDoc^, ResultOperationOnStructObject^>^ resultOperation
)
member AddCheckOutOperation :
        localIsOlderNotifier : Predicate<DedDoc> *
        isChildrenOperation : bool *
        ignoreDataLockState : bool *
        ignoreFileExistingEnsureLocal : bool *
        resultOperation : Dictionary<DedDoc, ResultOperationOnStructObject> -> unit

Parametri

localIsOlderNotifier Predicate DedDoc
Delegate per la notifica del documento in pws più vecchio rispetto a quello nel vault.
isChildrenOperation Boolean
Indica se si tratta di una operazione su un figlio.
ignoreDataLockState Boolean
Indica se ignorare il blocco legato allo stato dell'anagrafica.
ignoreFileExistingEnsureLocal Boolean
resultOperation Dictionary DedDoc, ResultOperationOnStructObject
Dizionario contenente i risultati dei comandi sui singoli documenti
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddCheckOutOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddCheckOutStrutturaOperation

Metodo DocStructInfoAddCheckOutStrutturaOperation
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AddCheckOutStrutturaOperation(PredicateDedDoc) | Imposta in checkout un documento e tutte le sue dipendenze. Delegate per la notifica del documento in pws più vecchio rispetto a quello nel vault.
Metodo pubblico | AddCheckOutStrutturaOperation(PredicateDedDoc, Boolean) | Imposta in checkout un documento e tutte le sue dipendenze. Delegate per la notifica del documento in pws più vecchio rispetto a quello nel vault.Indica se l'operazione sia stata aggiunta come sotto-operazione di un CheckOutStruttura.
Metodo pubblico | AddCheckOutStrutturaOperation(PredicateDedDoc, Boolean, Boolean) | Imposta in checkout un documento e tutte le sue dipendenze. Delegate per la notifica del documento in pws più vecchio rispetto a quello nel vault.Indica se l'operazione sia stata aggiunta come sotto-operazione di un CheckOutStruttura.Indica se ignorare il blocco legato allo stato dell'anagrafica.
Metodo pubblico | AddCheckOutStrutturaOperation(PredicateDedDoc, Boolean, Boolean, Boolean, DictionaryDedDoc, ResultOperationOnStructObject) | Imposta in checkout un documento e tutte le sue dipendenze. Delegate per la notifica del documento in pws più vecchio rispetto a quello nel vault.Indica se l'operazione sia stata aggiunta come sotto-operazione di un CheckOutStruttura.Indica se ignorare il blocco legato allo stato dell'anagrafica.Dizionario contenente i risultati dei comandi sui singoli documenti
Torna su
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Metodo DocStructInfo.AddCheckOutStrutturaOperation(Predicate<DedDoc>)

Metodo DocStructInfoAddCheckOutStrutturaOperation(PredicateDedDoc)
Imposta in checkout un documento e tutte le sue dipendenze. Delegate per la notifica del documento in pws più vecchio rispetto a quello nel vault.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddCheckOutStrutturaOperation(
    Predicate<DedDoc> localIsOlderNotifier
)
Public Sub AddCheckOutStrutturaOperation (
    localIsOlderNotifier As Predicate(Of DedDoc)
)
public:
void AddCheckOutStrutturaOperation(
    Predicate<DedDoc^>^ localIsOlderNotifier
)
member AddCheckOutStrutturaOperation :
        localIsOlderNotifier : Predicate<DedDoc> -> unit

Parametri

localIsOlderNotifier Predicate DedDoc
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddCheckOutStrutturaOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddCheckOutStrutturaOperation(Predicate<DedDoc>, Boolean)

Metodo DocStructInfoAddCheckOutStrutturaOperation(PredicateDedDoc, Boolean)
Imposta in checkout un documento e tutte le sue dipendenze. Delegate per la notifica del documento in pws più vecchio rispetto a quello nel vault.Indica se l'operazione sia stata aggiunta come sotto-operazione di un CheckOutStruttura.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddCheckOutStrutturaOperation(
    Predicate<DedDoc> localIsOlderNotifier,
    bool isChildOperation
)
Public Sub AddCheckOutStrutturaOperation (
    localIsOlderNotifier As Predicate(Of DedDoc),
    isChildOperation As Boolean
)
public:
void AddCheckOutStrutturaOperation(
    Predicate<DedDoc^>^ localIsOlderNotifier,
    bool isChildOperation
)
member AddCheckOutStrutturaOperation :
        localIsOlderNotifier : Predicate<DedDoc> *
        isChildOperation : bool -> unit

Parametri

localIsOlderNotifier Predicate DedDoc
isChildOperation Boolean
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddCheckOutStrutturaOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddCheckOutStrutturaOperation(Predicate<DedDoc>, Boolean, Boolean)

Metodo DocStructInfoAddCheckOutStrutturaOperation(PredicateDedDoc, Boolean, Boolean)
Imposta in checkout un documento e tutte le sue dipendenze. Delegate per la notifica del documento in pws più vecchio rispetto a quello nel vault.Indica se l'operazione sia stata aggiunta come sotto-operazione di un CheckOutStruttura.Indica se ignorare il blocco legato allo stato dell'anagrafica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddCheckOutStrutturaOperation(
    Predicate<DedDoc> localIsOlderNotifier,
    bool isChildOperation,
    bool ignoreDataLockState
)
Public Sub AddCheckOutStrutturaOperation (
    localIsOlderNotifier As Predicate(Of DedDoc),
    isChildOperation As Boolean,
    ignoreDataLockState As Boolean
)
public:
void AddCheckOutStrutturaOperation(
    Predicate<DedDoc^>^ localIsOlderNotifier,
    bool isChildOperation,
    bool ignoreDataLockState
)
member AddCheckOutStrutturaOperation :
        localIsOlderNotifier : Predicate<DedDoc> *
        isChildOperation : bool *
        ignoreDataLockState : bool -> unit

Parametri

localIsOlderNotifier Predicate DedDoc
isChildOperation Boolean
ignoreDataLockState Boolean
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddCheckOutStrutturaOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddCheckOutStrutturaOperation(Predicate<DedDoc>, Boolean, Boolean, Boolean, Dictionary<DedDoc, ResultOperationOnStructObject>)

Metodo DocStructInfoAddCheckOutStrutturaOperation(PredicateDedDoc, Boolean, Boolean, Boolean, DictionaryDedDoc, ResultOperationOnStructObject)
Imposta in checkout un documento e tutte le sue dipendenze. Delegate per la notifica del documento in pws più vecchio rispetto a quello nel vault.Indica se l'operazione sia stata aggiunta come sotto-operazione di un CheckOutStruttura.Indica se ignorare il blocco legato allo stato dell'anagrafica.Dizionario contenente i risultati dei comandi sui singoli documenti

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddCheckOutStrutturaOperation(
    Predicate<DedDoc> localIsOlderNotifier,
    bool isChildOperation,
    bool ignoreDataLockState,
    bool ignoreFileExistingEnsureLocal,
    Dictionary<DedDoc, ResultOperationOnStructObject> resultOperation
)
Public Sub AddCheckOutStrutturaOperation (
    localIsOlderNotifier As Predicate(Of DedDoc),
    isChildOperation As Boolean,
    ignoreDataLockState As Boolean,
    ignoreFileExistingEnsureLocal As Boolean,
    resultOperation As Dictionary(Of DedDoc, ResultOperationOnStructObject)
)
public:
void AddCheckOutStrutturaOperation(
    Predicate<DedDoc^>^ localIsOlderNotifier,
    bool isChildOperation,
    bool ignoreDataLockState,
    bool ignoreFileExistingEnsureLocal,
    Dictionary<DedDoc^, ResultOperationOnStructObject^>^ resultOperation
)
member AddCheckOutStrutturaOperation :
        localIsOlderNotifier : Predicate<DedDoc> *
        isChildOperation : bool *
        ignoreDataLockState : bool *
        ignoreFileExistingEnsureLocal : bool *
        resultOperation : Dictionary<DedDoc, ResultOperationOnStructObject> -> unit

Parametri

localIsOlderNotifier Predicate DedDoc
isChildOperation Boolean
ignoreDataLockState Boolean
ignoreFileExistingEnsureLocal Boolean
resultOperation Dictionary DedDoc, ResultOperationOnStructObject
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddCheckOutStrutturaOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddCopyingOperation

Metodo DocStructInfoAddCopyingOperation
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AddCopyingOperation(String) | Copia un documento da una posizione ad un'altra accettando che il file di partenza non sia presente nel Database. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che non esista il documento sul file di destinazione. Aggiunge anche un'operazione di creazione prima di sé stessa, per creare il documento di destinazione della copia. Rimane da operare la copia fisica da parte del comando chiamante oppure del client.
Metodo pubblico | AddCopyingOperation(String, Boolean) | Copia un documento da una posizione ad un'altra accettando che il file di partenza non sia presente nel Database. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che non esista il documento sul file di destinazione. Aggiunge anche un'operazione di creazione prima di sé stessa, per creare il documento di destinazione della copia. Rimane da operare la copia fisica da parte del comando chiamante oppure del client.
Torna su
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Metodo DocStructInfo.AddCopyingOperation(String)

Metodo DocStructInfoAddCopyingOperation(String)
Copia un documento da una posizione ad un'altra accettando che il file di partenza non sia presente nel Database. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che non esista il documento sul file di destinazione. Aggiunge anche un'operazione di creazione prima di sé stessa, per creare il documento di destinazione della copia. Rimane da operare la copia fisica da parte del comando chiamante oppure del client.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddCopyingOperation(
    string newFileName
)
Public Sub AddCopyingOperation (
    newFileName As String
)
public:
void AddCopyingOperation(
    String^ newFileName
)
member AddCopyingOperation :
        newFileName : string -> unit

Parametri

newFileName String
File di destinazione del documento.
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddCopyingOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddCopyingOperation(String, Boolean)

Metodo DocStructInfoAddCopyingOperation(String, Boolean)
Copia un documento da una posizione ad un'altra accettando che il file di partenza non sia presente nel Database. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che non esista il documento sul file di destinazione. Aggiunge anche un'operazione di creazione prima di sé stessa, per creare il documento di destinazione della copia. Rimane da operare la copia fisica da parte del comando chiamante oppure del client.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddCopyingOperation(
    string newFileName,
    bool enforcedFileOperation
)
Public Sub AddCopyingOperation (
    newFileName As String,
    enforcedFileOperation As Boolean
)
public:
void AddCopyingOperation(
    String^ newFileName,
    bool enforcedFileOperation
)
member AddCopyingOperation :
        newFileName : string *
        enforcedFileOperation : bool -> unit

Parametri

newFileName String
File di destinazione del documento.
enforcedFileOperation Boolean
Permette di forzare l'operazioni sui file senza utilizzare le deduzioni dell'operation base
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddCopyingOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddCreatingOperation

Metodo DocStructInfoAddCreatingOperation
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AddCreatingOperation | Valuta le informazioni presenti nell'ultima operazione disponibile e, se il documento non è presente, lo crea con il file impostato nell'operazione. Se il documento esiste già non fa nulla se non verificare che non si tratti di un nuovo documento (in questo caso solleva una eccezione) ed imposta l'operazione come effettuata. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, non controlla nemmeno l'esistenza del file. L'operazione da effettuare successivamente, se il file non esiste già, è di crearlo nella posizione di destinazione.
Metodo pubblico | AddCreatingOperation(String) | Crea un nuovo documento leggendo le informazioni presenti nell'ultima operazione disponibile ma utilizzando il percorso di file passato come argomento. Se il documento esiste già non fa nulla se non verificare che non si tratti di un nuovo documento (in questo caso solleva una eccezione) ed imposta l'operazione come effettuata. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, non controlla nemmeno l'esistenza del file. L'operazione da effettuare successivamente, se il file non esiste già, è di crearlo nella posizione di destinazione.
Torna su
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Metodo DocStructInfo.AddCreatingOperation

Metodo DocStructInfoAddCreatingOperation
Valuta le informazioni presenti nell'ultima operazione disponibile e, se il documento non è presente, lo crea con il file impostato nell'operazione. Se il documento esiste già non fa nulla se non verificare che non si tratti di un nuovo documento (in questo caso solleva una eccezione) ed imposta l'operazione come effettuata. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, non controlla nemmeno l'esistenza del file. L'operazione da effettuare successivamente, se il file non esiste già, è di crearlo nella posizione di destinazione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddCreatingOperation()
Public Sub AddCreatingOperation
public:
void AddCreatingOperation()
member AddCreatingOperation : unit -> unit
Note
È responsabilità del comando o del chiamante, compilare correttamente i dati di input nella struttura.
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddCreatingOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddCreatingOperation(String)

Metodo DocStructInfoAddCreatingOperation(String)
Crea un nuovo documento leggendo le informazioni presenti nell'ultima operazione disponibile ma utilizzando il percorso di file passato come argomento. Se il documento esiste già non fa nulla se non verificare che non si tratti di un nuovo documento (in questo caso solleva una eccezione) ed imposta l'operazione come effettuata. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, non controlla nemmeno l'esistenza del file. L'operazione da effettuare successivamente, se il file non esiste già, è di crearlo nella posizione di destinazione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddCreatingOperation(
    string newFileName
)
Public Sub AddCreatingOperation (
    newFileName As String
)
public:
void AddCreatingOperation(
    String^ newFileName
)
member AddCreatingOperation :
        newFileName : string -> unit

Parametri

newFileName String
Percorso file con il quale creare il nuovo documento, prendendo i dati però dall'operazione precedente.
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddCreatingOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddDisconnectingOperation

Metodo DocStructInfoAddDisconnectingOperation
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AddDisconnectingOperation(DedComm) | Scollega il documento presente nell'ultima operazione, da una commessa. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che il documento da scollegare sia effettivamente collegato alla commessa.
Metodo pubblico | AddDisconnectingOperation(DedData) | Scollega il documento presente nell'ultima operazione, da un'anagrafica. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che il documento da scollegare sia effettivamente collegato all'anagrafica.
Torna su
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Metodo DocStructInfo.AddDisconnectingOperation(DedComm)

Metodo DocStructInfoAddDisconnectingOperation(DedComm)
Scollega il documento presente nell'ultima operazione, da una commessa. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che il documento da scollegare sia effettivamente collegato alla commessa.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddDisconnectingOperation(
    DedComm comm
)
Public Sub AddDisconnectingOperation (
    comm As DedComm
)
public:
void AddDisconnectingOperation(
    DedComm^ comm
)
member AddDisconnectingOperation :
        comm : DedComm -> unit

Parametri

comm DedComm
Commessa dalla quale scollegare il documento.
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddDisconnectingOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddDisconnectingOperation(DedData)

Metodo DocStructInfoAddDisconnectingOperation(DedData)
Scollega il documento presente nell'ultima operazione, da un'anagrafica. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che il documento da scollegare sia effettivamente collegato all'anagrafica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddDisconnectingOperation(
    DedData data
)
Public Sub AddDisconnectingOperation (
    data As DedData
)
public:
void AddDisconnectingOperation(
    DedData^ data
)
member AddDisconnectingOperation :
        data : DedData -> unit

Parametri

data DedData
Anagrafica dalla quale scollegare il documento.
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddDisconnectingOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddEnsureLocalOperation

Metodo DocStructInfoAddEnsureLocalOperation
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AddEnsureLocalOperation(PredicateDedDoc, Boolean) | Copia il file dal vault all'area locale. Non effettua controlli sui permessi. Copia anche tutti i file dipendenti, necessari al documento principale.
Metodo pubblico | AddEnsureLocalOperation(PredicateDedDoc, Boolean, Boolean) | Copia il file dal vault all'area locale. Non effettua controlli sui permessi. Copia anche tutti i file dipendenti, necessari al documento principale.
Metodo pubblico | AddEnsureLocalOperation(PredicateDedDoc, Boolean, ListException) | Copia il file dal vault all'area locale. Non effettua controlli sui permessi. Copia anche tutti i file dipendenti, necessari al documento principale.
Metodo pubblico | AddEnsureLocalOperation(PredicateDedDoc, Boolean, Boolean, Boolean) | Copia il file dal vault all'area locale. Non effettua controlli sui permessi. Copia anche tutti i file dipendenti, necessari al documento principale.
Metodo pubblico | AddEnsureLocalOperation(PredicateDedDoc, Boolean, ListException, Boolean) | Copia il file dal vault all'area locale. Non effettua controlli sui permessi. Copia anche tutti i file dipendenti, necessari al documento principale.
Torna su
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Metodo DocStructInfo.AddEnsureLocalOperation(Predicate<DedDoc>, Boolean)

Metodo DocStructInfoAddEnsureLocalOperation(PredicateDedDoc, Boolean)
Copia il file dal vault all'area locale. Non effettua controlli sui permessi. Copia anche tutti i file dipendenti, necessari al documento principale.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddEnsureLocalOperation(
    Predicate<DedDoc> localIsOlderNotifier,
    bool enforceFileCopy
)
Public Sub AddEnsureLocalOperation (
    localIsOlderNotifier As Predicate(Of DedDoc),
    enforceFileCopy As Boolean
)
public:
void AddEnsureLocalOperation(
    Predicate<DedDoc^>^ localIsOlderNotifier,
    bool enforceFileCopy
)
member AddEnsureLocalOperation :
        localIsOlderNotifier : Predicate<DedDoc> *
        enforceFileCopy : bool -> unit

Parametri

localIsOlderNotifier Predicate DedDoc
Delegate per la notifica del documento in pws più vecchio rispetto a quello nel vault.
enforceFileCopy Boolean
Indica se il file deve essere copiato nell'area locale indipendentemente dal controllo ROWVER.
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddEnsureLocalOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddEnsureLocalOperation(Predicate<DedDoc>, Boolean, Boolean)

Metodo DocStructInfoAddEnsureLocalOperation(PredicateDedDoc, Boolean, Boolean)
Copia il file dal vault all'area locale. Non effettua controlli sui permessi. Copia anche tutti i file dipendenti, necessari al documento principale.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddEnsureLocalOperation(
    Predicate<DedDoc> localIsOlderNotifier,
    bool enforceFileCopy,
    bool ignoreFileExistingEnsureLocal
)
Public Sub AddEnsureLocalOperation (
    localIsOlderNotifier As Predicate(Of DedDoc),
    enforceFileCopy As Boolean,
    ignoreFileExistingEnsureLocal As Boolean
)
public:
void AddEnsureLocalOperation(
    Predicate<DedDoc^>^ localIsOlderNotifier,
    bool enforceFileCopy,
    bool ignoreFileExistingEnsureLocal
)
member AddEnsureLocalOperation :
        localIsOlderNotifier : Predicate<DedDoc> *
        enforceFileCopy : bool *
        ignoreFileExistingEnsureLocal : bool -> unit

Parametri

localIsOlderNotifier Predicate DedDoc
Delegate per la notifica del documento in pws più vecchio rispetto a quello nel vault.
enforceFileCopy Boolean
Indica se il file deve essere copiato nell'area locale indipendentemente dal controllo ROWVER.
ignoreFileExistingEnsureLocal Boolean
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddEnsureLocalOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddEnsureLocalOperation(Predicate<DedDoc>, Boolean, List<Exception>)

Metodo DocStructInfoAddEnsureLocalOperation(PredicateDedDoc, Boolean, ListException)
Copia il file dal vault all'area locale. Non effettua controlli sui permessi. Copia anche tutti i file dipendenti, necessari al documento principale.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddEnsureLocalOperation(
    Predicate<DedDoc> localIsOlderNotifier,
    bool enforceFileCopy,
    List<Exception> refNotFoundExList
)
Public Sub AddEnsureLocalOperation (
    localIsOlderNotifier As Predicate(Of DedDoc),
    enforceFileCopy As Boolean,
    refNotFoundExList As List(Of Exception)
)
public:
void AddEnsureLocalOperation(
    Predicate<DedDoc^>^ localIsOlderNotifier,
    bool enforceFileCopy,
    List<Exception^>^ refNotFoundExList
)
member AddEnsureLocalOperation :
        localIsOlderNotifier : Predicate<DedDoc> *
        enforceFileCopy : bool *
        refNotFoundExList : List<Exception> -> unit

Parametri

localIsOlderNotifier Predicate DedDoc
Delegate per la notifica del documento in pws più vecchio rispetto a quello nel vault.
enforceFileCopy Boolean
Indica se il file deve essere copiato nell'area locale indipendentemente dal controllo ROWVER.
refNotFoundExList List Exception
Lista eccezioni per riferimenti mancanti. Se viene passata, le eccezioni sono raccolte senza essere sollevate.
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddEnsureLocalOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddEnsureLocalOperation(Predicate<DedDoc>, Boolean, Boolean, Boolean)

Metodo DocStructInfoAddEnsureLocalOperation(PredicateDedDoc, Boolean, Boolean, Boolean)
Copia il file dal vault all'area locale. Non effettua controlli sui permessi. Copia anche tutti i file dipendenti, necessari al documento principale.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddEnsureLocalOperation(
    Predicate<DedDoc> localIsOlderNotifier,
    bool enforceFileCopy,
    bool ignoreFileExistingEnsureLocal,
    bool ignoreCopyIfFileExists
)
Public Sub AddEnsureLocalOperation (
    localIsOlderNotifier As Predicate(Of DedDoc),
    enforceFileCopy As Boolean,
    ignoreFileExistingEnsureLocal As Boolean,
    ignoreCopyIfFileExists As Boolean
)
public:
void AddEnsureLocalOperation(
    Predicate<DedDoc^>^ localIsOlderNotifier,
    bool enforceFileCopy,
    bool ignoreFileExistingEnsureLocal,
    bool ignoreCopyIfFileExists
)
member AddEnsureLocalOperation :
        localIsOlderNotifier : Predicate<DedDoc> *
        enforceFileCopy : bool *
        ignoreFileExistingEnsureLocal : bool *
        ignoreCopyIfFileExists : bool -> unit

Parametri

localIsOlderNotifier Predicate DedDoc
Delegate per la notifica del documento in pws più vecchio rispetto a quello nel vault.
enforceFileCopy Boolean
Indica se il file deve essere copiato nell'area locale indipendentemente dal controllo ROWVER.
ignoreFileExistingEnsureLocal Boolean
ignoreCopyIfFileExists Boolean
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddEnsureLocalOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddEnsureLocalOperation(Predicate<DedDoc>, Boolean, List<Exception>, Boolean)

Metodo DocStructInfoAddEnsureLocalOperation(PredicateDedDoc, Boolean, ListException, Boolean)
Copia il file dal vault all'area locale. Non effettua controlli sui permessi. Copia anche tutti i file dipendenti, necessari al documento principale.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddEnsureLocalOperation(
    Predicate<DedDoc> localIsOlderNotifier,
    bool enforceFileCopy,
    List<Exception> refNotFoundExList,
    bool ignoreFileExistingEnsureLocal
)
Public Sub AddEnsureLocalOperation (
    localIsOlderNotifier As Predicate(Of DedDoc),
    enforceFileCopy As Boolean,
    refNotFoundExList As List(Of Exception),
    ignoreFileExistingEnsureLocal As Boolean
)
public:
void AddEnsureLocalOperation(
    Predicate<DedDoc^>^ localIsOlderNotifier,
    bool enforceFileCopy,
    List<Exception^>^ refNotFoundExList,
    bool ignoreFileExistingEnsureLocal
)
member AddEnsureLocalOperation :
        localIsOlderNotifier : Predicate<DedDoc> *
        enforceFileCopy : bool *
        refNotFoundExList : List<Exception> *
        ignoreFileExistingEnsureLocal : bool -> unit

Parametri

localIsOlderNotifier Predicate DedDoc
Delegate per la notifica del documento in pws più vecchio rispetto a quello nel vault.
enforceFileCopy Boolean
Indica se il file deve essere copiato nell'area locale indipendentemente dal controllo ROWVER.
refNotFoundExList List Exception
Lista eccezioni per riferimenti mancanti. Se viene passata, le eccezioni sono raccolte senza essere sollevate.
ignoreFileExistingEnsureLocal Boolean
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddEnsureLocalOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddExportingOperation

Metodo DocStructInfoAddExportingOperation
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AddExportingOperation(Boolean, String, String) | Operazione di esportazione del documento
Metodo pubblico | AddExportingOperation(Boolean, String, String, Boolean) | Operazione di esportazione del documento
Torna su
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Metodo DocStructInfo.AddExportingOperation(Boolean, String, String)

Metodo DocStructInfoAddExportingOperation(Boolean, String, String)
Operazione di esportazione del documento

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddExportingOperation(
    bool checkOutOnExport,
    string checkOutUser,
    string rootDestPath
)
Public Sub AddExportingOperation (
    checkOutOnExport As Boolean,
    checkOutUser As String,
    rootDestPath As String
)
public:
void AddExportingOperation(
    bool checkOutOnExport,
    String^ checkOutUser,
    String^ rootDestPath
)
member AddExportingOperation :
        checkOutOnExport : bool *
        checkOutUser : string *
        rootDestPath : string -> unit

Parametri

checkOutOnExport Boolean
Indica se il comando porrà il documento in checkOut prima dell'esportazione.
checkOutUser String
Nome dell'utente associato all'operazione di checkOut.
rootDestPath String
Percorso principale di esportazione.
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddExportingOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddExportingOperation(Boolean, String, String, Boolean)

Metodo DocStructInfoAddExportingOperation(Boolean, String, String, Boolean)
Operazione di esportazione del documento

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddExportingOperation(
    bool checkOutOnExport,
    string checkOutUser,
    string rootDestPath,
    bool createFolderStructure
)
Public Sub AddExportingOperation (
    checkOutOnExport As Boolean,
    checkOutUser As String,
    rootDestPath As String,
    createFolderStructure As Boolean
)
public:
void AddExportingOperation(
    bool checkOutOnExport,
    String^ checkOutUser,
    String^ rootDestPath,
    bool createFolderStructure
)
member AddExportingOperation :
        checkOutOnExport : bool *
        checkOutUser : string *
        rootDestPath : string *
        createFolderStructure : bool -> unit

Parametri

checkOutOnExport Boolean
Indica se il comando porrà il documento in checkOut prima dell'esportazione.
checkOutUser String
Nome dell'utente associato all'operazione di checkOut.
rootDestPath String
Percorso principale di esportazione.
createFolderStructure Boolean
Indica se mantenere la struttura di cartelle.
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddExportingOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddExportingStrutturaOperation

Metodo DocStructInfoAddExportingStrutturaOperation
Operazione di esportazione del documento (struttura)

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddExportingStrutturaOperation(
    bool checkOutOnExport,
    string checkOutUser,
    string rootDestPath
)
Public Sub AddExportingStrutturaOperation (
    checkOutOnExport As Boolean,
    checkOutUser As String,
    rootDestPath As String
)
public:
void AddExportingStrutturaOperation(
    bool checkOutOnExport,
    String^ checkOutUser,
    String^ rootDestPath
)
member AddExportingStrutturaOperation :
        checkOutOnExport : bool *
        checkOutUser : string *
        rootDestPath : string -> unit

Parametri

checkOutOnExport Boolean
Indica se il comando porrà il documento in checkOut prima dell'esportazione.
checkOutUser String
Nome dell'utente associato all'operazione di checkOut.
rootDestPath String
Percorso principale di esportazione.
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Metodo DocStructInfo.AddForzaCheckInOperation

Metodo DocStructInfoAddForzaCheckInOperation
Forza in checkin un documento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddForzaCheckInOperation()
Public Sub AddForzaCheckInOperation
public:
void AddForzaCheckInOperation()
member AddForzaCheckInOperation : unit -> unit
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Metodo DocStructInfo.AddForzaCheckInStrutturaOperation

Metodo DocStructInfoAddForzaCheckInStrutturaOperation
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AddForzaCheckInStrutturaOperation | Imposta in checkin una struttura di documenti.
Metodo pubblico | AddForzaCheckInStrutturaOperation(Boolean) | Imposta in checkin una struttura di documenti.
Torna su
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Metodo DocStructInfo.AddForzaCheckInStrutturaOperation

Metodo DocStructInfoAddForzaCheckInStrutturaOperation
Imposta in checkin una struttura di documenti.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddForzaCheckInStrutturaOperation()
Public Sub AddForzaCheckInStrutturaOperation
public:
void AddForzaCheckInStrutturaOperation()
member AddForzaCheckInStrutturaOperation : unit -> unit
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddForzaCheckInStrutturaOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddForzaCheckInStrutturaOperation(Boolean)

Metodo DocStructInfoAddForzaCheckInStrutturaOperation(Boolean)
Imposta in checkin una struttura di documenti.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddForzaCheckInStrutturaOperation(
    bool isChildOperation
)
Public Sub AddForzaCheckInStrutturaOperation (
    isChildOperation As Boolean
)
public:
void AddForzaCheckInStrutturaOperation(
    bool isChildOperation
)
member AddForzaCheckInStrutturaOperation :
        isChildOperation : bool -> unit

Parametri

isChildOperation Boolean
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddForzaCheckInStrutturaOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddImportingOperation

Metodo DocStructInfoAddImportingOperation
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AddImportingOperation(DedComm, OperationChoiceEnum) | Copia il documentodi partenza, proveniente da qualsiasi origine, nella posizione corrette per associarlo alla commessa. Le logiche sono le stesse dell'importazione legata all'anagrafica.
Metodo pubblico | AddImportingOperation(DedData, DedDocContextEnum) | Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica.
Metodo pubblico | AddImportingOperation(DedData, Boolean) | Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica.
Metodo pubblico | AddImportingOperation(DedEco, OperationChoiceEnum) | Copia il documento di partenza, proveniente da qualsiasi origine, nella posizione corrette per associarlo all'Eco. Le logiche sono le stesse dell'importazione legata alla commessa.
Metodo pubblico | AddImportingOperation(DedData, DedDocContextEnum, Boolean) | Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica.
Metodo pubblico | AddImportingOperation(DedData, Boolean, Boolean) | Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica.
Metodo pubblico | AddImportingOperation(DedData, Boolean, String) | Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica.
Metodo pubblico | AddImportingOperation(DedData, DedDocContextEnum, Boolean, String) |
Metodo pubblico | AddImportingOperation(DedData, Boolean, Boolean, String) | Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica.
Metodo pubblico | AddImportingOperation(DedData, Boolean, String, String) | Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica.
Metodo pubblico | AddImportingOperation(DedData, Boolean, Boolean, String, OperationChoiceEnum) | Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica.
Metodo pubblico | AddImportingOperation(DedData, Boolean, Boolean, String, Boolean) |
Metodo pubblico | AddImportingOperation(DedData, Boolean, Boolean, String, Boolean, Boolean) | Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica.
Metodo pubblico | AddImportingOperation(DedData, Boolean, Boolean, String, Boolean, String) |
Torna su
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Metodo DocStructInfo.AddImportingOperation(DedComm, OperationChoice.OperationChoiceEnum)

Metodo DocStructInfoAddImportingOperation(DedComm, OperationChoiceOperationChoiceEnum)
Copia il documentodi partenza, proveniente da qualsiasi origine, nella posizione corrette per associarlo alla commessa. Le logiche sono le stesse dell'importazione legata all'anagrafica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddImportingOperation(
    DedComm comm,
    OperationChoiceEnum operationChoice
)
Public Sub AddImportingOperation (
    comm As DedComm,
    operationChoice As OperationChoiceEnum
)
public:
void AddImportingOperation(
    DedComm^ comm,
    OperationChoiceEnum operationChoice
)
member AddImportingOperation :
        comm : DedComm *
        operationChoice : OperationChoiceEnum -> unit

Parametri

comm DedComm
Commmessa di riferimento per l'operazione
operationChoice OperationChoiceEnum
Operazione scelta
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddImportingOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddImportingOperation(DedData, DedDocContextEnum)

Metodo DocStructInfoAddImportingOperation(DedData, DedDocContextEnum)
Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddImportingOperation(
    DedData data,
    DedDocContextEnum context
)
Public Sub AddImportingOperation (
    data As DedData,
    context As DedDocContextEnum
)
public:
void AddImportingOperation(
    DedData^ data,
    DedDocContextEnum context
)
member AddImportingOperation :
        data : DedData *
        context : DedDocContextEnum -> unit

Parametri

data DedData
Anagrafica nella quale importare il documento.
context DedDocContextEnum
Contesto con il quale effettuare l'importazione.
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddImportingOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddImportingOperation(DedData, Boolean)

Metodo DocStructInfoAddImportingOperation(DedData, Boolean)
Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddImportingOperation(
    DedData data,
    bool primaryContext
)
Public Sub AddImportingOperation (
    data As DedData,
    primaryContext As Boolean
)
public:
void AddImportingOperation(
    DedData^ data,
    bool primaryContext
)
member AddImportingOperation :
        data : DedData *
        primaryContext : bool -> unit

Parametri

data DedData
Anagrafica nella quale importare il documento.
primaryContext Boolean
Contesto con il quale effettuare l'importazione.
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddImportingOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddImportingOperation(DedEco, OperationChoice.OperationChoiceEnum)

Metodo DocStructInfoAddImportingOperation(DedEco, OperationChoiceOperationChoiceEnum)
Copia il documento di partenza, proveniente da qualsiasi origine, nella posizione corrette per associarlo all'Eco. Le logiche sono le stesse dell'importazione legata alla commessa.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddImportingOperation(
    DedEco eco,
    OperationChoiceEnum operationChoice
)
Public Sub AddImportingOperation (
    eco As DedEco,
    operationChoice As OperationChoiceEnum
)
public:
void AddImportingOperation(
    DedEco^ eco,
    OperationChoiceEnum operationChoice
)
member AddImportingOperation :
        eco : DedEco *
        operationChoice : OperationChoiceEnum -> unit

Parametri

eco DedEco
Eco di riferimento per l'operazione
operationChoice OperationChoiceEnum
Operazione scelta
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddImportingOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddImportingOperation(DedData, DedDocContextEnum, Boolean)

Metodo DocStructInfoAddImportingOperation(DedData, DedDocContextEnum, Boolean)
Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddImportingOperation(
    DedData data,
    DedDocContextEnum context,
    bool useOriginalSparePartsFileName
)
Public Sub AddImportingOperation (
    data As DedData,
    context As DedDocContextEnum,
    useOriginalSparePartsFileName As Boolean
)
public:
void AddImportingOperation(
    DedData^ data,
    DedDocContextEnum context,
    bool useOriginalSparePartsFileName
)
member AddImportingOperation :
        data : DedData *
        context : DedDocContextEnum *
        useOriginalSparePartsFileName : bool -> unit

Parametri

data DedData
Anagrafica nella quale importare il documento.
context DedDocContextEnum
Contesto con il quale effettuare l'importazione.
useOriginalSparePartsFileName Boolean
Contesto con il quale effettuare l'importazione.
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddImportingOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddImportingOperation(DedData, Boolean, Boolean)

Metodo DocStructInfoAddImportingOperation(DedData, Boolean, Boolean)
Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddImportingOperation(
    DedData data,
    bool primaryContext,
    bool moveInsteadOfCopy
)
Public Sub AddImportingOperation (
    data As DedData,
    primaryContext As Boolean,
    moveInsteadOfCopy As Boolean
)
public:
void AddImportingOperation(
    DedData^ data,
    bool primaryContext,
    bool moveInsteadOfCopy
)
member AddImportingOperation :
        data : DedData *
        primaryContext : bool *
        moveInsteadOfCopy : bool -> unit

Parametri

data DedData
Anagrafica nella quale importare il documento.
primaryContext Boolean
Contesto con il quale effettuare l'importazione.
moveInsteadOfCopy Boolean
Spostare il documento invece di copiarlo.
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddImportingOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddImportingOperation(DedData, Boolean, String)

Metodo DocStructInfoAddImportingOperation(DedData, Boolean, String)
Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddImportingOperation(
    DedData data,
    bool primaryContext,
    string fileNameForNewAttach
)
Public Sub AddImportingOperation (
    data As DedData,
    primaryContext As Boolean,
    fileNameForNewAttach As String
)
public:
void AddImportingOperation(
    DedData^ data,
    bool primaryContext,
    String^ fileNameForNewAttach
)
member AddImportingOperation :
        data : DedData *
        primaryContext : bool *
        fileNameForNewAttach : string -> unit

Parametri

data DedData
Anagrafica nella quale importare il documento.
primaryContext Boolean
Contesto con il quale effettuare l'importazione.
fileNameForNewAttach String
Nome file da utilizzare nel caso di un nuovo documento (solo in memoria) che sia da importare come allegato.
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddImportingOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddImportingOperation(DedData, DedDocContextEnum, Boolean, String)

Metodo DocStructInfoAddImportingOperation(DedData, DedDocContextEnum, Boolean, String)

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddImportingOperation(
    DedData data,
    DedDocContextEnum context,
    bool moveInsteadOfCopy,
    string rapIdx
)
Public Sub AddImportingOperation (
    data As DedData,
    context As DedDocContextEnum,
    moveInsteadOfCopy As Boolean,
    rapIdx As String
)
public:
void AddImportingOperation(
    DedData^ data,
    DedDocContextEnum context,
    bool moveInsteadOfCopy,
    String^ rapIdx
)
member AddImportingOperation :
        data : DedData *
        context : DedDocContextEnum *
        moveInsteadOfCopy : bool *
        rapIdx : string -> unit

Parametri

data DedData
context DedDocContextEnum
moveInsteadOfCopy Boolean
rapIdx String
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddImportingOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddImportingOperation(DedData, Boolean, Boolean, String)

Metodo DocStructInfoAddImportingOperation(DedData, Boolean, Boolean, String)
Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddImportingOperation(
    DedData data,
    bool primaryContext,
    bool moveInsteadOfCopy,
    string rapIdx
)
Public Sub AddImportingOperation (
    data As DedData,
    primaryContext As Boolean,
    moveInsteadOfCopy As Boolean,
    rapIdx As String
)
public:
void AddImportingOperation(
    DedData^ data,
    bool primaryContext,
    bool moveInsteadOfCopy,
    String^ rapIdx
)
member AddImportingOperation :
        data : DedData *
        primaryContext : bool *
        moveInsteadOfCopy : bool *
        rapIdx : string -> unit

Parametri

data DedData
Anagrafica nella quale importare il documento.
primaryContext Boolean
Contesto con il quale effettuare l'importazione.
moveInsteadOfCopy Boolean
Spostare il documento invece di copiarlo.
rapIdx String
Indice da usare nell'eventuale creazione della rappresentazione. che sia da importare come allegato.
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddImportingOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddImportingOperation(DedData, Boolean, String, String)

Metodo DocStructInfoAddImportingOperation(DedData, Boolean, String, String)
Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddImportingOperation(
    DedData data,
    bool primaryContext,
    string fileNameForNewAttach,
    string destFileName
)
Public Sub AddImportingOperation (
    data As DedData,
    primaryContext As Boolean,
    fileNameForNewAttach As String,
    destFileName As String
)
public:
void AddImportingOperation(
    DedData^ data,
    bool primaryContext,
    String^ fileNameForNewAttach,
    String^ destFileName
)
member AddImportingOperation :
        data : DedData *
        primaryContext : bool *
        fileNameForNewAttach : string *
        destFileName : string -> unit

Parametri

data DedData
Anagrafica nella quale importare il documento.
primaryContext Boolean
Contesto con il quale effettuare l'importazione.
fileNameForNewAttach String
Nome file da utilizzare nel caso di un nuovo documento (solo in memoria) che sia da importare come allegato.
destFileName String
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddImportingOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddImportingOperation(DedData, Boolean, Boolean, String, OperationChoice.OperationChoiceEnum)

Metodo DocStructInfoAddImportingOperation(DedData, Boolean, Boolean, String, OperationChoiceOperationChoiceEnum)
Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddImportingOperation(
    DedData data,
    bool primaryContext,
    bool moveInsteadOfCopy,
    string rapIdx,
    OperationChoiceEnum operationChoice
)
Public Sub AddImportingOperation (
    data As DedData,
    primaryContext As Boolean,
    moveInsteadOfCopy As Boolean,
    rapIdx As String,
    operationChoice As OperationChoiceEnum
)
public:
void AddImportingOperation(
    DedData^ data,
    bool primaryContext,
    bool moveInsteadOfCopy,
    String^ rapIdx,
    OperationChoiceEnum operationChoice
)
member AddImportingOperation :
        data : DedData *
        primaryContext : bool *
        moveInsteadOfCopy : bool *
        rapIdx : string *
        operationChoice : OperationChoiceEnum -> unit

Parametri

data DedData
Anagrafica nella quale importare il documento.
primaryContext Boolean
Contesto con il quale effettuare l'importazione.
moveInsteadOfCopy Boolean
Spostare il documento invece di copiarlo.
rapIdx String
Indice da usare nell'eventuale creazione della rappresentazione. che sia da importare come allegato.
operationChoice OperationChoiceEnum
Operazione scelta
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddImportingOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddImportingOperation(DedData, Boolean, Boolean, String, Boolean)

Metodo DocStructInfoAddImportingOperation(DedData, Boolean, Boolean, String, Boolean)

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddImportingOperation(
    DedData data,
    bool primaryContext,
    bool moveInsteadOfCopy,
    string rapIdx,
    bool overwriteMode
)
Public Sub AddImportingOperation (
    data As DedData,
    primaryContext As Boolean,
    moveInsteadOfCopy As Boolean,
    rapIdx As String,
    overwriteMode As Boolean
)
public:
void AddImportingOperation(
    DedData^ data,
    bool primaryContext,
    bool moveInsteadOfCopy,
    String^ rapIdx,
    bool overwriteMode
)
member AddImportingOperation :
        data : DedData *
        primaryContext : bool *
        moveInsteadOfCopy : bool *
        rapIdx : string *
        overwriteMode : bool -> unit

Parametri

data DedData
primaryContext Boolean
moveInsteadOfCopy Boolean
rapIdx String
overwriteMode Boolean
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddImportingOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddImportingOperation(DedData, Boolean, Boolean, String, Boolean, Boolean)

Metodo DocStructInfoAddImportingOperation(DedData, Boolean, Boolean, String, Boolean, Boolean)
Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddImportingOperation(
    DedData data,
    bool primaryContext,
    bool moveInsteadOfCopy,
    string rapIdx,
    bool overwriteMode,
    bool enforceRepresentation
)
Public Sub AddImportingOperation (
    data As DedData,
    primaryContext As Boolean,
    moveInsteadOfCopy As Boolean,
    rapIdx As String,
    overwriteMode As Boolean,
    enforceRepresentation As Boolean
)
public:
void AddImportingOperation(
    DedData^ data,
    bool primaryContext,
    bool moveInsteadOfCopy,
    String^ rapIdx,
    bool overwriteMode,
    bool enforceRepresentation
)
member AddImportingOperation :
        data : DedData *
        primaryContext : bool *
        moveInsteadOfCopy : bool *
        rapIdx : string *
        overwriteMode : bool *
        enforceRepresentation : bool -> unit

Parametri

data DedData
Anagrafica nella quale importare il documento.
primaryContext Boolean
Contesto con il quale effettuare l'importazione.
moveInsteadOfCopy Boolean
Spostare il documento invece di copiarlo.
rapIdx String
Indice da usare nell'eventuale creazione della rappresentazione.
overwriteMode Boolean
Indica nel caso di conflitti se sovrascrivere o no
enforceRepresentation Boolean
Indica se forzare la creazione di una rappresentazione
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddImportingOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddImportingOperation(DedData, Boolean, Boolean, String, Boolean, String)

Metodo DocStructInfoAddImportingOperation(DedData, Boolean, Boolean, String, Boolean, String)

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddImportingOperation(
    DedData data,
    bool primaryContext,
    bool moveInsteadOfCopy,
    string rapIdx,
    bool overwriteMode,
    string destFileName
)
Public Sub AddImportingOperation (
    data As DedData,
    primaryContext As Boolean,
    moveInsteadOfCopy As Boolean,
    rapIdx As String,
    overwriteMode As Boolean,
    destFileName As String
)
public:
void AddImportingOperation(
    DedData^ data,
    bool primaryContext,
    bool moveInsteadOfCopy,
    String^ rapIdx,
    bool overwriteMode,
    String^ destFileName
)
member AddImportingOperation :
        data : DedData *
        primaryContext : bool *
        moveInsteadOfCopy : bool *
        rapIdx : string *
        overwriteMode : bool *
        destFileName : string -> unit

Parametri

data DedData
primaryContext Boolean
moveInsteadOfCopy Boolean
rapIdx String
overwriteMode Boolean
destFileName String
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddImportingOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddLinkingOperation

Metodo DocStructInfoAddLinkingOperation
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AddLinkingOperation(DedComm) | Collega il documento ad una commessa
Metodo pubblico | AddLinkingOperation(DedEco) | Collega il documento ad un Eco
Metodo pubblico | AddLinkingOperation(DedData, DedDocContextEnum) | Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido.
Metodo pubblico | AddLinkingOperation(DedData, Boolean) | Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido.
Metodo pubblico | AddLinkingOperation(DedData, DedDocContextEnum, DedData) | Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido.
Metodo pubblico | AddLinkingOperation(DedData, Boolean, DedData) | Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido.
Metodo pubblico | AddLinkingOperation(DedData, DedDocContextEnum, DedData, ConfigDescriptor) | Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido.
Metodo pubblico | AddLinkingOperation(DedData, Boolean, DedData, ConfigDescriptor) | Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido.
Metodo pubblico | AddLinkingOperation(DedData, DedDocContextEnum, DedData, ConfigDescriptor, Boolean) | Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido.
Metodo pubblico | AddLinkingOperation(DedData, Boolean, DedData, ConfigDescriptor, Boolean) | Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido.
Metodo pubblico | AddLinkingOperation(DedData, Boolean, DedData, ConfigDescriptor, Boolean, DictionaryString, DedDocContext) | Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido.
Torna su
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Metodo DocStructInfo.AddLinkingOperation(DedComm)

Metodo DocStructInfoAddLinkingOperation(DedComm)
Collega il documento ad una commessa

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddLinkingOperation(
    DedComm comm
)
Public Sub AddLinkingOperation (
    comm As DedComm
)
public:
void AddLinkingOperation(
    DedComm^ comm
)
member AddLinkingOperation :
        comm : DedComm -> unit

Parametri

comm DedComm
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddLinkingOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddLinkingOperation(DedEco)

Metodo DocStructInfoAddLinkingOperation(DedEco)
Collega il documento ad un Eco

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddLinkingOperation(
    DedEco eco
)
Public Sub AddLinkingOperation (
    eco As DedEco
)
public:
void AddLinkingOperation(
    DedEco^ eco
)
member AddLinkingOperation :
        eco : DedEco -> unit

Parametri

eco DedEco
Eco al quale associare il documento
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddLinkingOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddLinkingOperation(DedData, DedDocContextEnum)

Metodo DocStructInfoAddLinkingOperation(DedData, DedDocContextEnum)
Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddLinkingOperation(
    DedData data,
    DedDocContextEnum context
)
Public Sub AddLinkingOperation (
    data As DedData,
    context As DedDocContextEnum
)
public:
void AddLinkingOperation(
    DedData^ data,
    DedDocContextEnum context
)
member AddLinkingOperation :
        data : DedData *
        context : DedDocContextEnum -> unit

Parametri

data DedData
Anagrafica alla quale collegare il documento.
context DedDocContextEnum
Contesto specifico con il quale effettuare il collegamento.
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddLinkingOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddLinkingOperation(DedData, Boolean)

Metodo DocStructInfoAddLinkingOperation(DedData, Boolean)
Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddLinkingOperation(
    DedData data,
    bool primaryContext
)
Public Sub AddLinkingOperation (
    data As DedData,
    primaryContext As Boolean
)
public:
void AddLinkingOperation(
    DedData^ data,
    bool primaryContext
)
member AddLinkingOperation :
        data : DedData *
        primaryContext : bool -> unit

Parametri

data DedData
Anagrafica alla quale collegare il documento.
primaryContext Boolean
Contesto con il quale effettuare il collegamento.
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddLinkingOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddLinkingOperation(DedData, DedDocContextEnum, DedData)

Metodo DocStructInfoAddLinkingOperation(DedData, DedDocContextEnum, DedData)
Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddLinkingOperation(
    DedData data,
    DedDocContextEnum context,
    DedData linkingData
)
Public Sub AddLinkingOperation (
    data As DedData,
    context As DedDocContextEnum,
    linkingData As DedData
)
public:
void AddLinkingOperation(
    DedData^ data,
    DedDocContextEnum context,
    DedData^ linkingData
)
member AddLinkingOperation :
        data : DedData *
        context : DedDocContextEnum *
        linkingData : DedData -> unit

Parametri

data DedData
Anagrafica alla quale collegare il documento.
context DedDocContextEnum
Contesto specifico con il quale effettuare il collegamento.
linkingData DedData
Anagrafica dalla quale viene linkato il documento.
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddLinkingOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddLinkingOperation(DedData, Boolean, DedData)

Metodo DocStructInfoAddLinkingOperation(DedData, Boolean, DedData)
Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddLinkingOperation(
    DedData data,
    bool primaryContext,
    DedData linkingData
)
Public Sub AddLinkingOperation (
    data As DedData,
    primaryContext As Boolean,
    linkingData As DedData
)
public:
void AddLinkingOperation(
    DedData^ data,
    bool primaryContext,
    DedData^ linkingData
)
member AddLinkingOperation :
        data : DedData *
        primaryContext : bool *
        linkingData : DedData -> unit

Parametri

data DedData
Anagrafica alla quale collegare il documento.
primaryContext Boolean
Contesto con il quale effettuare il collegamento.
linkingData DedData
Anagrafica dalla quale viene linkato il documento.
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddLinkingOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddLinkingOperation(DedData, DedDocContextEnum, DedData, ConfigDescriptor)

Metodo DocStructInfoAddLinkingOperation(DedData, DedDocContextEnum, DedData, ConfigDescriptor)
Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddLinkingOperation(
    DedData data,
    DedDocContextEnum context,
    DedData linkingData,
    ConfigDescriptor cfgDescr
)
Public Sub AddLinkingOperation (
    data As DedData,
    context As DedDocContextEnum,
    linkingData As DedData,
    cfgDescr As ConfigDescriptor
)
public:
void AddLinkingOperation(
    DedData^ data,
    DedDocContextEnum context,
    DedData^ linkingData,
    ConfigDescriptor^ cfgDescr
)
member AddLinkingOperation :
        data : DedData *
        context : DedDocContextEnum *
        linkingData : DedData *
        cfgDescr : ConfigDescriptor -> unit

Parametri

data DedData
Anagrafica alla quale collegare il documento.
context DedDocContextEnum
Contesto specifico con il quale effettuare il collegamento.
linkingData DedData
Anagrafica dalla quale viene linkato il documento.
cfgDescr ConfigDescriptor
Descrittore di configurazione
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddLinkingOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddLinkingOperation(DedData, Boolean, DedData, ConfigDescriptor)

Metodo DocStructInfoAddLinkingOperation(DedData, Boolean, DedData, ConfigDescriptor)
Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddLinkingOperation(
    DedData data,
    bool primaryContext,
    DedData linkingData,
    ConfigDescriptor cfgDescr
)
Public Sub AddLinkingOperation (
    data As DedData,
    primaryContext As Boolean,
    linkingData As DedData,
    cfgDescr As ConfigDescriptor
)
public:
void AddLinkingOperation(
    DedData^ data,
    bool primaryContext,
    DedData^ linkingData,
    ConfigDescriptor^ cfgDescr
)
member AddLinkingOperation :
        data : DedData *
        primaryContext : bool *
        linkingData : DedData *
        cfgDescr : ConfigDescriptor -> unit

Parametri

data DedData
Anagrafica alla quale collegare il documento.
primaryContext Boolean
Contesto con il quale effettuare il collegamento.
linkingData DedData
Anagrafica dalla quale viene linkato il documento.
cfgDescr ConfigDescriptor
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddLinkingOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddLinkingOperation(DedData, DedDocContextEnum, DedData, ConfigDescriptor, Boolean)

Metodo DocStructInfoAddLinkingOperation(DedData, DedDocContextEnum, DedData, ConfigDescriptor, Boolean)
Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddLinkingOperation(
    DedData data,
    DedDocContextEnum context,
    DedData linkingData,
    ConfigDescriptor cfgDescr,
    bool ignoreExistingConfigAssociations
)
Public Sub AddLinkingOperation (
    data As DedData,
    context As DedDocContextEnum,
    linkingData As DedData,
    cfgDescr As ConfigDescriptor,
    ignoreExistingConfigAssociations As Boolean
)
public:
void AddLinkingOperation(
    DedData^ data,
    DedDocContextEnum context,
    DedData^ linkingData,
    ConfigDescriptor^ cfgDescr,
    bool ignoreExistingConfigAssociations
)
member AddLinkingOperation :
        data : DedData *
        context : DedDocContextEnum *
        linkingData : DedData *
        cfgDescr : ConfigDescriptor *
        ignoreExistingConfigAssociations : bool -> unit

Parametri

data DedData
Anagrafica alla quale collegare il documento.
context DedDocContextEnum
Contesto specifico con il quale effettuare il collegamento.
linkingData DedData
Anagrafica dalla quale viene linkato il documento.
cfgDescr ConfigDescriptor
Descrittore di configurazione
ignoreExistingConfigAssociations Boolean
Ignora i controlli sui contesti esistenti associati alla configurazione
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddLinkingOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddLinkingOperation(DedData, Boolean, DedData, ConfigDescriptor, Boolean)

Metodo DocStructInfoAddLinkingOperation(DedData, Boolean, DedData, ConfigDescriptor, Boolean)
Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddLinkingOperation(
    DedData data,
    bool primaryContext,
    DedData linkingData,
    ConfigDescriptor cfgDescr,
    bool ignoreExistingConfigAssociations
)
Public Sub AddLinkingOperation (
    data As DedData,
    primaryContext As Boolean,
    linkingData As DedData,
    cfgDescr As ConfigDescriptor,
    ignoreExistingConfigAssociations As Boolean
)
public:
void AddLinkingOperation(
    DedData^ data,
    bool primaryContext,
    DedData^ linkingData,
    ConfigDescriptor^ cfgDescr,
    bool ignoreExistingConfigAssociations
)
member AddLinkingOperation :
        data : DedData *
        primaryContext : bool *
        linkingData : DedData *
        cfgDescr : ConfigDescriptor *
        ignoreExistingConfigAssociations : bool -> unit

Parametri

data DedData
Anagrafica alla quale collegare il documento.
primaryContext Boolean
Contesto con il quale effettuare il collegamento.
linkingData DedData
Anagrafica dalla quale viene linkato il documento.
cfgDescr ConfigDescriptor
Descrittore di configurazione
ignoreExistingConfigAssociations Boolean
Ignora i controlli sui contesti esistenti associati alla configurazione
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddLinkingOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddLinkingOperation(DedData, Boolean, DedData, ConfigDescriptor, Boolean, Dictionary<String, DedDocContext>)

Metodo DocStructInfoAddLinkingOperation(DedData, Boolean, DedData, ConfigDescriptor, Boolean, DictionaryString, DedDocContext)
Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddLinkingOperation(
    DedData data,
    bool primaryContext,
    DedData linkingData,
    ConfigDescriptor cfgDescr,
    bool ignoreExistingConfigAssociations,
    Dictionary<string, DedDocContext> overwriteContext
)
Public Sub AddLinkingOperation (
    data As DedData,
    primaryContext As Boolean,
    linkingData As DedData,
    cfgDescr As ConfigDescriptor,
    ignoreExistingConfigAssociations As Boolean,
    overwriteContext As Dictionary(Of String, DedDocContext)
)
public:
void AddLinkingOperation(
    DedData^ data,
    bool primaryContext,
    DedData^ linkingData,
    ConfigDescriptor^ cfgDescr,
    bool ignoreExistingConfigAssociations,
    Dictionary<String^, DedDocContext^>^ overwriteContext
)
member AddLinkingOperation :
        data : DedData *
        primaryContext : bool *
        linkingData : DedData *
        cfgDescr : ConfigDescriptor *
        ignoreExistingConfigAssociations : bool *
        overwriteContext : Dictionary<string, DedDocContext> -> unit

Parametri

data DedData
Anagrafica alla quale collegare il documento.
primaryContext Boolean
Contesto con il quale effettuare il collegamento.
linkingData DedData
Anagrafica dalla quale viene linkato il documento.
cfgDescr ConfigDescriptor
Descrittore di configurazione
ignoreExistingConfigAssociations Boolean
Ignora i controlli sui contesti esistenti associati alla configurazione
overwriteContext Dictionary String, DedDocContext
Indica i contesti da mantenere
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddLinkingOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddMovingOperation

Metodo DocStructInfoAddMovingOperation
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AddMovingOperation(String, DedDocMovReasonEnum) | Sposta un documento da una posizione ad un'altra utilizzando lo stesso ID documento. Il guid del documento rimane lo stesso di partenza perché si presume che si stia lavorando su disco e non in memoria (non è considerato il caso di lavorare in memoria per rinominare un file). Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che non esista il documento sul file di destinazione. Rimane da operare lo spostamento fisico da parte del comando chiamante oppure del client.
Metodo pubblico | AddMovingOperation(String, DedDocMovReasonEnum, Boolean) | Sposta un documento da una posizione ad un'altra utilizzando lo stesso ID documento. Il guid del documento rimane lo stesso di partenza perché si presume che si stia lavorando su disco e non in memoria (non è considerato il caso di lavorare in memoria per rinominare un file). Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che non esista il documento sul file di destinazione. Rimane da operare lo spostamento fisico da parte del comando chiamante oppure del client.
Metodo pubblico | AddMovingOperation(String, DedDocMovReasonEnum, Boolean, Boolean) | Sposta un documento da una posizione ad un'altra utilizzando lo stesso ID documento. Il guid del documento rimane lo stesso di partenza perché si presume che si stia lavorando su disco e non in memoria (non è considerato il caso di lavorare in memoria per rinominare un file). Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che non esista il documento sul file di destinazione. Rimane da operare lo spostamento fisico da parte del comando chiamante oppure del client.
Torna su
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Metodo DocStructInfo.AddMovingOperation(String, DedDoc.MovReasonEnum)

Metodo DocStructInfoAddMovingOperation(String, DedDocMovReasonEnum)
Sposta un documento da una posizione ad un'altra utilizzando lo stesso ID documento. Il guid del documento rimane lo stesso di partenza perché si presume che si stia lavorando su disco e non in memoria (non è considerato il caso di lavorare in memoria per rinominare un file). Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che non esista il documento sul file di destinazione. Rimane da operare lo spostamento fisico da parte del comando chiamante oppure del client.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddMovingOperation(
    string newFileName,
    DedDocMovReasonEnum reason
)
Public Sub AddMovingOperation (
    newFileName As String,
    reason As DedDocMovReasonEnum
)
public:
void AddMovingOperation(
    String^ newFileName,
    DedDocMovReasonEnum reason
)
member AddMovingOperation :
        newFileName : string *
        reason : DedDocMovReasonEnum -> unit

Parametri

newFileName String
File di destinazione del documento.
reason DedDocMovReasonEnum
Ragione dello spostamento.
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddMovingOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddMovingOperation(String, DedDoc.MovReasonEnum, Boolean)

Metodo DocStructInfoAddMovingOperation(String, DedDocMovReasonEnum, Boolean)
Sposta un documento da una posizione ad un'altra utilizzando lo stesso ID documento. Il guid del documento rimane lo stesso di partenza perché si presume che si stia lavorando su disco e non in memoria (non è considerato il caso di lavorare in memoria per rinominare un file). Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che non esista il documento sul file di destinazione. Rimane da operare lo spostamento fisico da parte del comando chiamante oppure del client.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddMovingOperation(
    string newFileName,
    DedDocMovReasonEnum reason,
    bool notEraseFromFile
)
Public Sub AddMovingOperation (
    newFileName As String,
    reason As DedDocMovReasonEnum,
    notEraseFromFile As Boolean
)
public:
void AddMovingOperation(
    String^ newFileName,
    DedDocMovReasonEnum reason,
    bool notEraseFromFile
)
member AddMovingOperation :
        newFileName : string *
        reason : DedDocMovReasonEnum *
        notEraseFromFile : bool -> unit

Parametri

newFileName String
File di destinazione del documento.
reason DedDocMovReasonEnum
Ragione dello spostamento.
notEraseFromFile Boolean
Se impostato a true indica di non cancellare il file fisico di partenza.
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddMovingOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddMovingOperation(String, DedDoc.MovReasonEnum, Boolean, Boolean)

Metodo DocStructInfoAddMovingOperation(String, DedDocMovReasonEnum, Boolean, Boolean)
Sposta un documento da una posizione ad un'altra utilizzando lo stesso ID documento. Il guid del documento rimane lo stesso di partenza perché si presume che si stia lavorando su disco e non in memoria (non è considerato il caso di lavorare in memoria per rinominare un file). Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che non esista il documento sul file di destinazione. Rimane da operare lo spostamento fisico da parte del comando chiamante oppure del client.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddMovingOperation(
    string newFileName,
    DedDocMovReasonEnum reason,
    bool notEraseFromFile,
    bool addMoveMarker
)
Public Sub AddMovingOperation (
    newFileName As String,
    reason As DedDocMovReasonEnum,
    notEraseFromFile As Boolean,
    addMoveMarker As Boolean
)
public:
void AddMovingOperation(
    String^ newFileName,
    DedDocMovReasonEnum reason,
    bool notEraseFromFile,
    bool addMoveMarker
)
member AddMovingOperation :
        newFileName : string *
        reason : DedDocMovReasonEnum *
        notEraseFromFile : bool *
        addMoveMarker : bool -> unit

Parametri

newFileName String
File di destinazione del documento.
reason DedDocMovReasonEnum
Ragione dello spostamento.
notEraseFromFile Boolean
Se impostato a true indica di non cancellare il file fisico di partenza.
addMoveMarker Boolean
Indica se creare il file .moved o no
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddMovingOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddPubblicaOperation

Metodo DocStructInfoAddPubblicaOperation
Aggiunge una operazione di pubblicazione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddPubblicaOperation()
Public Sub AddPubblicaOperation
public:
void AddPubblicaOperation()
member AddPubblicaOperation : unit -> unit
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Metodo DocStructInfo.AddPubblicaStrutturaOperation

Metodo DocStructInfoAddPubblicaStrutturaOperation
Aggiunge una operazione di pubblicazione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddPubblicaStrutturaOperation()
Public Sub AddPubblicaStrutturaOperation
public:
void AddPubblicaStrutturaOperation()
member AddPubblicaStrutturaOperation : unit -> unit
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Metodo DocStructInfo.AddRecogniseOperation

Metodo DocStructInfoAddRecogniseOperation
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AddRecogniseOperation(DedComm) | Associa un file ad una commessa creando il documento se non esiste già, lasciando il file col nome originale. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di crea(se necessrio) + link, per creare il documento e collegarlo all'anagrafica.
Metodo pubblico | AddRecogniseOperation(DedData, Boolean) | Associa un file ad un'anagrafica creando il documento se non esiste già, lasciando il file col nome originale. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di crea(se necessrio) + link, per creare il documento e collegarlo all'anagrafica.
Metodo pubblico | AddRecogniseOperation(DedData, Boolean, ConfigDescriptor) | Associa un file ad un'anagrafica creando il documento se non esiste già, lasciando il file col nome originale. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di crea(se necessrio) + link, per creare il documento e collegarlo all'anagrafica.
Metodo pubblico | AddRecogniseOperation(DedData, Boolean, ConfigDescriptor, Boolean) | Associa un file ad un'anagrafica creando il documento se non esiste già, lasciando il file col nome originale. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di crea(se necessrio) + link, per creare il documento e collegarlo all'anagrafica.
Metodo pubblico | AddRecogniseOperation(DedData, Boolean, ConfigDescriptor, Boolean, DictionaryString, DedDocContext) | Associa un file ad un'anagrafica creando il documento se non esiste già, lasciando il file col nome originale. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di crea(se necessrio) + link, per creare il documento e collegarlo all'anagrafica.
Torna su
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Metodo DocStructInfo.AddRecogniseOperation(DedComm)

Metodo DocStructInfoAddRecogniseOperation(DedComm)
Associa un file ad una commessa creando il documento se non esiste già, lasciando il file col nome originale. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di crea(se necessrio) + link, per creare il documento e collegarlo all'anagrafica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddRecogniseOperation(
    DedComm comm
)
Public Sub AddRecogniseOperation (
    comm As DedComm
)
public:
void AddRecogniseOperation(
    DedComm^ comm
)
member AddRecogniseOperation :
        comm : DedComm -> unit

Parametri

comm DedComm
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddRecogniseOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddRecogniseOperation(DedData, Boolean)

Metodo DocStructInfoAddRecogniseOperation(DedData, Boolean)
Associa un file ad un'anagrafica creando il documento se non esiste già, lasciando il file col nome originale. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di crea(se necessrio) + link, per creare il documento e collegarlo all'anagrafica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddRecogniseOperation(
    DedData data,
    bool primaryContext
)
Public Sub AddRecogniseOperation (
    data As DedData,
    primaryContext As Boolean
)
public:
void AddRecogniseOperation(
    DedData^ data,
    bool primaryContext
)
member AddRecogniseOperation :
        data : DedData *
        primaryContext : bool -> unit

Parametri

data DedData
Anagrafica alla quale collegare il documento.
primaryContext Boolean
Contesto con il quale effettuare il collegamento.
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddRecogniseOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddRecogniseOperation(DedData, Boolean, ConfigDescriptor)

Metodo DocStructInfoAddRecogniseOperation(DedData, Boolean, ConfigDescriptor)
Associa un file ad un'anagrafica creando il documento se non esiste già, lasciando il file col nome originale. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di crea(se necessrio) + link, per creare il documento e collegarlo all'anagrafica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddRecogniseOperation(
    DedData data,
    bool primaryContext,
    ConfigDescriptor cfgDescr
)
Public Sub AddRecogniseOperation (
    data As DedData,
    primaryContext As Boolean,
    cfgDescr As ConfigDescriptor
)
public:
void AddRecogniseOperation(
    DedData^ data,
    bool primaryContext,
    ConfigDescriptor^ cfgDescr
)
member AddRecogniseOperation :
        data : DedData *
        primaryContext : bool *
        cfgDescr : ConfigDescriptor -> unit

Parametri

data DedData
Anagrafica alla quale collegare il documento.
primaryContext Boolean
Contesto con il quale effettuare il collegamento.
cfgDescr ConfigDescriptor
Descrittore di configurazione
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddRecogniseOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddRecogniseOperation(DedData, Boolean, ConfigDescriptor, Boolean)

Metodo DocStructInfoAddRecogniseOperation(DedData, Boolean, ConfigDescriptor, Boolean)
Associa un file ad un'anagrafica creando il documento se non esiste già, lasciando il file col nome originale. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di crea(se necessrio) + link, per creare il documento e collegarlo all'anagrafica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddRecogniseOperation(
    DedData data,
    bool primaryContext,
    ConfigDescriptor cfgDescr,
    bool ignoreExistingConfigAssociations
)
Public Sub AddRecogniseOperation (
    data As DedData,
    primaryContext As Boolean,
    cfgDescr As ConfigDescriptor,
    ignoreExistingConfigAssociations As Boolean
)
public:
void AddRecogniseOperation(
    DedData^ data,
    bool primaryContext,
    ConfigDescriptor^ cfgDescr,
    bool ignoreExistingConfigAssociations
)
member AddRecogniseOperation :
        data : DedData *
        primaryContext : bool *
        cfgDescr : ConfigDescriptor *
        ignoreExistingConfigAssociations : bool -> unit

Parametri

data DedData
Anagrafica alla quale collegare il documento.
primaryContext Boolean
Contesto con il quale effettuare il collegamento.
cfgDescr ConfigDescriptor
Descrittore di configurazione
ignoreExistingConfigAssociations Boolean
Flag di servizio che permette di ignorare eventuali associazioni esistenti sulla configurazione
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddRecogniseOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddRecogniseOperation(DedData, Boolean, ConfigDescriptor, Boolean, Dictionary<String, DedDocContext>)

Metodo DocStructInfoAddRecogniseOperation(DedData, Boolean, ConfigDescriptor, Boolean, DictionaryString, DedDocContext)
Associa un file ad un'anagrafica creando il documento se non esiste già, lasciando il file col nome originale. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di crea(se necessrio) + link, per creare il documento e collegarlo all'anagrafica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddRecogniseOperation(
    DedData data,
    bool primaryContext,
    ConfigDescriptor cfgDescr,
    bool ignoreExistingConfigAssociations,
    Dictionary<string, DedDocContext> overwriteContext
)
Public Sub AddRecogniseOperation (
    data As DedData,
    primaryContext As Boolean,
    cfgDescr As ConfigDescriptor,
    ignoreExistingConfigAssociations As Boolean,
    overwriteContext As Dictionary(Of String, DedDocContext)
)
public:
void AddRecogniseOperation(
    DedData^ data,
    bool primaryContext,
    ConfigDescriptor^ cfgDescr,
    bool ignoreExistingConfigAssociations,
    Dictionary<String^, DedDocContext^>^ overwriteContext
)
member AddRecogniseOperation :
        data : DedData *
        primaryContext : bool *
        cfgDescr : ConfigDescriptor *
        ignoreExistingConfigAssociations : bool *
        overwriteContext : Dictionary<string, DedDocContext> -> unit

Parametri

data DedData
Anagrafica alla quale collegare il documento.
primaryContext Boolean
Contesto con il quale effettuare il collegamento.
cfgDescr ConfigDescriptor
Descrittore di configurazione
ignoreExistingConfigAssociations Boolean
Flag di servizio che permette di ignorare eventuali associazioni esistenti sulla configurazione
overwriteContext Dictionary String, DedDocContext
Indica i contesti da mantenere
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddRecogniseOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddRelocateOperation

Metodo DocStructInfoAddRelocateOperation
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AddRelocateOperation(DedDoc, Boolean) | Operazione di rilocazione di un file esterno su un documento interno. Permette di "puntare" semplicemente il documento interno ma anche di eseguire l'overwrite fisico come nel caso del replace.
Metodo pubblico | AddRelocateOperation(DedDoc, Boolean, Boolean) | Operazione di rilocazione di un file esterno su un documento interno. Permette di "puntare" semplicemente il documento interno ma anche di eseguire l'overwrite fisico come nel caso del replace.
Torna su
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Metodo DocStructInfo.AddRelocateOperation(DedDoc, Boolean)

Metodo DocStructInfoAddRelocateOperation(DedDoc, Boolean)
Operazione di rilocazione di un file esterno su un documento interno. Permette di "puntare" semplicemente il documento interno ma anche di eseguire l'overwrite fisico come nel caso del replace.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddRelocateOperation(
    DedDoc refDoc,
    bool overwriteMode
)
Public Sub AddRelocateOperation (
    refDoc As DedDoc,
    overwriteMode As Boolean
)
public:
void AddRelocateOperation(
    DedDoc^ refDoc,
    bool overwriteMode
)
member AddRelocateOperation :
        refDoc : DedDoc *
        overwriteMode : bool -> unit

Parametri

refDoc DedDoc
Documento di destinazione
overwriteMode Boolean
Modalità di sovrascrittura
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddRelocateOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddRelocateOperation(DedDoc, Boolean, Boolean)

Metodo DocStructInfoAddRelocateOperation(DedDoc, Boolean, Boolean)
Operazione di rilocazione di un file esterno su un documento interno. Permette di "puntare" semplicemente il documento interno ma anche di eseguire l'overwrite fisico come nel caso del replace.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddRelocateOperation(
    DedDoc refDoc,
    bool overwriteMode,
    bool lazyMode
)
Public Sub AddRelocateOperation (
    refDoc As DedDoc,
    overwriteMode As Boolean,
    lazyMode As Boolean
)
public:
void AddRelocateOperation(
    DedDoc^ refDoc,
    bool overwriteMode,
    bool lazyMode
)
member AddRelocateOperation :
        refDoc : DedDoc *
        overwriteMode : bool *
        lazyMode : bool -> unit

Parametri

refDoc DedDoc
Documento di destinazione
overwriteMode Boolean
Modalità di sovrascrittura
lazyMode Boolean
Inidica se è attiva la modalità a basso numero di controlli.
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddRelocateOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddRemovingOperation

Metodo DocStructInfoAddRemovingOperation
Elimina il documento presente nell'ultima operazione. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che il documento da eliminare esista.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddRemovingOperation(
    bool _skipDeletionTracking
)
Public Sub AddRemovingOperation (
    _skipDeletionTracking As Boolean
)
public:
void AddRemovingOperation(
    bool _skipDeletionTracking
)
member AddRemovingOperation :
        _skipDeletionTracking : bool -> unit

Parametri

_skipDeletionTracking Boolean
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Metodo DocStructInfo.AddReplaceOperation

Metodo DocStructInfoAddReplaceOperation
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AddReplaceOperation(DocStructInfo) | Copia un file sul file fisico di un altro documento sostituendolo. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che esista il documento di destinazione. Aggiunge anche un'operazione di creazione per le dipendenze, per essere sicuri di avere nel Db tutti documenti dipendenti e di aggiornamento per il documento in sostituzione. Rimane da operare la copia fisica da parte del comando chiamante oppure del client.
Metodo pubblico | AddReplaceOperation(String) | Copia un file sul file fisico di un altro documento sostituendolo. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che esista il documento di destinazione. Aggiunge anche un'operazione di creazione per le dipendenze, per essere sicuri di avere nel Db tutti documenti dipendenti e di aggiornamento per il documento in sostituzione. Rimane da operare la copia fisica da parte del comando chiamante oppure del client.
Torna su
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Metodo DocStructInfo.AddReplaceOperation(DocStructInfo)

Metodo DocStructInfoAddReplaceOperation(DocStructInfo)
Copia un file sul file fisico di un altro documento sostituendolo. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che esista il documento di destinazione. Aggiunge anche un'operazione di creazione per le dipendenze, per essere sicuri di avere nel Db tutti documenti dipendenti e di aggiornamento per il documento in sostituzione. Rimane da operare la copia fisica da parte del comando chiamante oppure del client.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddReplaceOperation(
    DocStructInfo replaceDsInfo
)
Public Sub AddReplaceOperation (
    replaceDsInfo As DocStructInfo
)
public:
void AddReplaceOperation(
    DocStructInfo^ replaceDsInfo
)
member AddReplaceOperation :
        replaceDsInfo : DocStructInfo -> unit

Parametri

replaceDsInfo DocStructInfo
Struttura con la quale attuare la sostituzione.
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddReplaceOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddReplaceOperation(String)

Metodo DocStructInfoAddReplaceOperation(String)
Copia un file sul file fisico di un altro documento sostituendolo. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che esista il documento di destinazione. Aggiunge anche un'operazione di creazione per le dipendenze, per essere sicuri di avere nel Db tutti documenti dipendenti e di aggiornamento per il documento in sostituzione. Rimane da operare la copia fisica da parte del comando chiamante oppure del client.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddReplaceOperation(
    string replaceFile
)
Public Sub AddReplaceOperation (
    replaceFile As String
)
public:
void AddReplaceOperation(
    String^ replaceFile
)
member AddReplaceOperation :
        replaceFile : string -> unit

Parametri

replaceFile String
File con il quale attuare la sostituzione.
Vedi anche

Documentazione

Classe DocStructInfo
Overload di AddReplaceOperation
Namespace DedNet.Core


Metodo DocStructInfo.AddSbloccaOperation

Metodo DocStructInfoAddSbloccaOperation
Sblocca un documento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddSbloccaOperation(
    bool deletingPwsFile
)
Public Sub AddSbloccaOperation (
    deletingPwsFile As Boolean
)
public:
void AddSbloccaOperation(
    bool deletingPwsFile
)
member AddSbloccaOperation :
        deletingPwsFile : bool -> unit

Parametri

deletingPwsFile Boolean
Indica se il comando eliminerà o meno il documento in locale.
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Metodo DocStructInfo.AddUpdatingOperation

Metodo DocStructInfoAddUpdatingOperation
Effettua l'operazione di aggiornamento del documento nel Database leggendo l'ultima operazione disponibile ed imposta con Updating l'operazione. Verifica che il documento esista già e poi aggiorna il documento nel Database con le sue dipendenze. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, non controlla nemmeno l'esistenza del file. L'operazione da effettuare successivamente, se il file non esiste già, è di crearlo nella posizione di destinazione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddUpdatingOperation()
Public Sub AddUpdatingOperation
public:
void AddUpdatingOperation()
member AddUpdatingOperation : unit -> unit
Note
È responsabilità del comando o del chiamante, compilare correttamente i dati di input nella struttura.
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Metodo DocStructInfo.BottomUpCall

Metodo DocStructInfoBottomUpCall
Chiama tutti gli elementi, compreso l'elemento corrente, ma per ultimo, partendo dal basso (ultimi nodi) e procedendo verso l'alto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void BottomUpCall(
    Predicate<DocStructInfo> pred
)
Public Sub BottomUpCall (
    pred As Predicate(Of DocStructInfo)
)
public:
void BottomUpCall(
    Predicate<DocStructInfo^>^ pred
)
member BottomUpCall :
        pred : Predicate<DocStructInfo> -> unit

Parametri

pred Predicate DocStructInfo
Predicato che riceve ogni singolo nodo.
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Metodo DocStructInfo.CreateDocStructInfo

Metodo DocStructInfoCreateDocStructInfo
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | CreateDocStructInfo(DocStructInfoFileDescriptor) | Crea e restituisce un nuovo oggetto evitando i duplicati, infatti cerca prima negli elementi interni e se lo trova restituisce l'elemento trovato, altrimenti crea un nuovo oggetto che comunque condivide gli elementi di questo oggetto. È indispensabile chiamare questo metodo per creare un oggetto dopo la chiamata all'omonimo metodo statico per la creazione del primo elemento. NOTA: Non crea la sotto struttura!! Chiamare MakeChildrenAuto() per ottenerla tramite apprentice.
Metodo pubblico | CreateDocStructInfo(String) | Crea e restituisce un nuovo oggetto evitando i duplicati, infatti cerca prima negli elementi interni e se lo trova restituisce l'elemento trovato, altrimenti crea un nuovo oggetto che comunque condivide gli elementi di questo oggetto. È indispensabile chiamare questo metodo per creare un oggetto dopo la chiamata all'omonimo metodo statico per la creazione del primo elemento. NOTA: Non crea la sotto struttura!! Chiamare MakeChildrenAuto() per ottenerla tramite apprentice.
 | CreateDocStructInfo(DedNetApplication, DocStructInfoFileDescriptor) | Crea e restituisce un nuovo oggetto DocStructInfo. Questo metodo è da utilizzare per la creazione del primo elemento, dopo si deve utilizzare la versione omonima d'istanza per creare gli oggetti successivi, in modo da evitare duplicati nella struttura dei documenti.
 | CreateDocStructInfo(DedNetApplication, String) | Crea e restituisce un nuovo oggetto DocStructInfo. Questo metodo è da utilizzare per la creazione del primo elemento, dopo si deve utilizzare la versione omonima d'istanza per creare gli oggetti successivi, in modo da evitare duplicati nella struttura dei documenti.
Metodo pubblico | CreateDocStructInfo(DocStructInfoFileDescriptor, DocStructInfo) | Crea e restituisce un nuovo oggetto evitando i duplicati, infatti cerca prima negli elementi interni e se lo trova restituisce l'elemento trovato, altrimenti crea un nuovo oggetto che comunque condivide gli elementi di questo oggetto. È indispensabile chiamare questo metodo per creare un oggetto dopo la chiamata all'omonimo metodo statico per la creazione del primo elemento. Il nuovo elemento viene impostato come figlio di questa istanza. NOTA: Non crea la sotto struttura!! Chiamare MakeChildrenAuto() per ottenerla tramite apprentice.
Metodo pubblico | CreateDocStructInfo(String, ConfigDescriptor) | Crea e restituisce un nuovo oggetto evitando i duplicati, infatti cerca prima negli elementi interni e se lo trova restituisce l'elemento trovato, altrimenti crea un nuovo oggetto che comunque condivide gli elementi di questo oggetto. È indispensabile chiamare questo metodo per creare un oggetto dopo la chiamata all'omonimo metodo statico per la creazione del primo elemento. NOTA: Non crea la sotto struttura!! Chiamare MakeChildrenAuto() per ottenerla tramite apprentice.
 | CreateDocStructInfo(DedNetApplication, String, ConfigDescriptor) | Crea e restituisce un nuovo oggetto DocStructInfo. Questo metodo è da utilizzare per la creazione del primo elemento, dopo si deve utilizzare la versione omonima d'istanza per creare gli oggetti successivi, in modo da evitare duplicati nella struttura dei documenti.
Torna su
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Metodo DocStructInfo.CreateDocStructInfo(DocStructInfoFileDescriptor)

Metodo DocStructInfoCreateDocStructInfo(DocStructInfoFileDescriptor)
Crea e restituisce un nuovo oggetto evitando i duplicati, infatti cerca prima negli elementi interni e se lo trova restituisce l'elemento trovato, altrimenti crea un nuovo oggetto che comunque condivide gli elementi di questo oggetto. È indispensabile chiamare questo metodo per creare un oggetto dopo la chiamata all'omonimo metodo statico per la creazione del primo elemento. NOTA: Non crea la sotto struttura!! Chiamare MakeChildrenAuto() per ottenerla tramite apprentice.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual DocStructInfo CreateDocStructInfo(
    DocStructInfoFileDescriptor fileDescr
)
Public Overridable Function CreateDocStructInfo (
    fileDescr As DocStructInfoFileDescriptor
) As DocStructInfo
public:
virtual DocStructInfo^ CreateDocStructInfo(
    DocStructInfoFileDescriptor^ fileDescr
)
abstract CreateDocStructInfo :
        fileDescr : DocStructInfoFileDescriptor -> DocStructInfo
override CreateDocStructInfo :
        fileDescr : DocStructInfoFileDescriptor -> DocStructInfo

Parametri

fileDescr DocStructInfoFileDescriptor
File del quale ricavere le informazioni

Valore di ritorno

DocStructInfo
Restituisce un nuovo oggetto inizializzato.
Vedi anche

Documentazione

Classe DocStructInfo
Overload di CreateDocStructInfo
Namespace DedNet.Core


Metodo DocStructInfo.CreateDocStructInfo(String)

Metodo DocStructInfoCreateDocStructInfo(String)
Crea e restituisce un nuovo oggetto evitando i duplicati, infatti cerca prima negli elementi interni e se lo trova restituisce l'elemento trovato, altrimenti crea un nuovo oggetto che comunque condivide gli elementi di questo oggetto. È indispensabile chiamare questo metodo per creare un oggetto dopo la chiamata all'omonimo metodo statico per la creazione del primo elemento. NOTA: Non crea la sotto struttura!! Chiamare MakeChildrenAuto() per ottenerla tramite apprentice.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual DocStructInfo CreateDocStructInfo(
    string fileName
)
Public Overridable Function CreateDocStructInfo (
    fileName As String
) As DocStructInfo
public:
virtual DocStructInfo^ CreateDocStructInfo(
    String^ fileName
)
abstract CreateDocStructInfo :
        fileName : string -> DocStructInfo
override CreateDocStructInfo :
        fileName : string -> DocStructInfo

Parametri

fileName String
File del quale ricavere le informazioni

Valore di ritorno

DocStructInfo
Restituisce un nuovo oggetto inizializzato.
Vedi anche

Documentazione

Classe DocStructInfo
Overload di CreateDocStructInfo
Namespace DedNet.Core


Metodo DocStructInfo.CreateDocStructInfo(DedNetApplication, DocStructInfoFileDescriptor)

Metodo DocStructInfoCreateDocStructInfo(DedNetApplication, DocStructInfoFileDescriptor)
Crea e restituisce un nuovo oggetto DocStructInfo. Questo metodo è da utilizzare per la creazione del primo elemento, dopo si deve utilizzare la versione omonima d'istanza per creare gli oggetti successivi, in modo da evitare duplicati nella struttura dei documenti.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static DocStructInfo CreateDocStructInfo(
    DedNetApplication app,
    DocStructInfoFileDescriptor fileDescr
)
Public Shared Function CreateDocStructInfo (
    app As DedNetApplication,
    fileDescr As DocStructInfoFileDescriptor
) As DocStructInfo
public:
static DocStructInfo^ CreateDocStructInfo(
    DedNetApplication^ app,
    DocStructInfoFileDescriptor^ fileDescr
)
static member CreateDocStructInfo :
        app : DedNetApplication *
        fileDescr : DocStructInfoFileDescriptor -> DocStructInfo

Parametri

app DedNetApplication
Applicazione di appartenenza.
fileDescr DocStructInfoFileDescriptor
File del quale ricavere le informazioni.

Valore di ritorno

DocStructInfo
Restituisce un nuovo oggetto inizializzato.
Vedi anche

Documentazione

Classe DocStructInfo
Overload di CreateDocStructInfo
Namespace DedNet.Core


Metodo DocStructInfo.CreateDocStructInfo(DedNetApplication, String)

Metodo DocStructInfoCreateDocStructInfo(DedNetApplication, String)
Crea e restituisce un nuovo oggetto DocStructInfo. Questo metodo è da utilizzare per la creazione del primo elemento, dopo si deve utilizzare la versione omonima d'istanza per creare gli oggetti successivi, in modo da evitare duplicati nella struttura dei documenti.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static DocStructInfo CreateDocStructInfo(
    DedNetApplication app,
    string fileName
)
Public Shared Function CreateDocStructInfo (
    app As DedNetApplication,
    fileName As String
) As DocStructInfo
public:
static DocStructInfo^ CreateDocStructInfo(
    DedNetApplication^ app,
    String^ fileName
)
static member CreateDocStructInfo :
        app : DedNetApplication *
        fileName : string -> DocStructInfo

Parametri

app DedNetApplication
Applicazione di appartenenza.
fileName String
File del quale ricavere le informazioni.

Valore di ritorno

DocStructInfo
Restituisce un nuovo oggetto inizializzato.
Vedi anche

Documentazione

Classe DocStructInfo
Overload di CreateDocStructInfo
Namespace DedNet.Core


Metodo DocStructInfo.CreateDocStructInfo(DocStructInfoFileDescriptor, DocStructInfo)

Metodo DocStructInfoCreateDocStructInfo(DocStructInfoFileDescriptor, DocStructInfo)
Crea e restituisce un nuovo oggetto evitando i duplicati, infatti cerca prima negli elementi interni e se lo trova restituisce l'elemento trovato, altrimenti crea un nuovo oggetto che comunque condivide gli elementi di questo oggetto. È indispensabile chiamare questo metodo per creare un oggetto dopo la chiamata all'omonimo metodo statico per la creazione del primo elemento. Il nuovo elemento viene impostato come figlio di questa istanza. NOTA: Non crea la sotto struttura!! Chiamare MakeChildrenAuto() per ottenerla tramite apprentice.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual DocStructInfo CreateDocStructInfo(
    DocStructInfoFileDescriptor fileDescr,
    DocStructInfo parent
)
Public Overridable Function CreateDocStructInfo (
    fileDescr As DocStructInfoFileDescriptor,
    parent As DocStructInfo
) As DocStructInfo
public:
virtual DocStructInfo^ CreateDocStructInfo(
    DocStructInfoFileDescriptor^ fileDescr,
    DocStructInfo^ parent
)
abstract CreateDocStructInfo :
        fileDescr : DocStructInfoFileDescriptor *
        parent : DocStructInfo -> DocStructInfo
override CreateDocStructInfo :
        fileDescr : DocStructInfoFileDescriptor *
        parent : DocStructInfo -> DocStructInfo

Parametri

fileDescr DocStructInfoFileDescriptor
File del quale ricavere le informazioni
parent DocStructInfo
Padre dell'elemento.

Valore di ritorno

DocStructInfo
Restituisce un nuovo oggetto inizializzato.
Vedi anche

Documentazione

Classe DocStructInfo
Overload di CreateDocStructInfo
Namespace DedNet.Core


Metodo DocStructInfo.CreateDocStructInfo(String, ConfigDescriptor)

Metodo DocStructInfoCreateDocStructInfo(String, ConfigDescriptor)
Crea e restituisce un nuovo oggetto evitando i duplicati, infatti cerca prima negli elementi interni e se lo trova restituisce l'elemento trovato, altrimenti crea un nuovo oggetto che comunque condivide gli elementi di questo oggetto. È indispensabile chiamare questo metodo per creare un oggetto dopo la chiamata all'omonimo metodo statico per la creazione del primo elemento. NOTA: Non crea la sotto struttura!! Chiamare MakeChildrenAuto() per ottenerla tramite apprentice.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual DocStructInfo CreateDocStructInfo(
    string fileName,
    ConfigDescriptor cfgDescr
)
Public Overridable Function CreateDocStructInfo (
    fileName As String,
    cfgDescr As ConfigDescriptor
) As DocStructInfo
public:
virtual DocStructInfo^ CreateDocStructInfo(
    String^ fileName,
    ConfigDescriptor^ cfgDescr
)
abstract CreateDocStructInfo :
        fileName : string *
        cfgDescr : ConfigDescriptor -> DocStructInfo
override CreateDocStructInfo :
        fileName : string *
        cfgDescr : ConfigDescriptor -> DocStructInfo

Parametri

fileName String
File del quale ricavere le informazioni
cfgDescr ConfigDescriptor

Valore di ritorno

DocStructInfo
Restituisce un nuovo oggetto inizializzato.
Vedi anche

Documentazione

Classe DocStructInfo
Overload di CreateDocStructInfo
Namespace DedNet.Core


Metodo DocStructInfo.CreateDocStructInfo(DedNetApplication, String, ConfigDescriptor)

Metodo DocStructInfoCreateDocStructInfo(DedNetApplication, String, ConfigDescriptor)
Crea e restituisce un nuovo oggetto DocStructInfo. Questo metodo è da utilizzare per la creazione del primo elemento, dopo si deve utilizzare la versione omonima d'istanza per creare gli oggetti successivi, in modo da evitare duplicati nella struttura dei documenti.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static DocStructInfo CreateDocStructInfo(
    DedNetApplication app,
    string fileName,
    ConfigDescriptor cfgDescr
)
Public Shared Function CreateDocStructInfo (
    app As DedNetApplication,
    fileName As String,
    cfgDescr As ConfigDescriptor
) As DocStructInfo
public:
static DocStructInfo^ CreateDocStructInfo(
    DedNetApplication^ app,
    String^ fileName,
    ConfigDescriptor^ cfgDescr
)
static member CreateDocStructInfo :
        app : DedNetApplication *
        fileName : string *
        cfgDescr : ConfigDescriptor -> DocStructInfo

Parametri

app DedNetApplication
Applicazione di appartenenza.
fileName String
File del quale ricavere le informazioni.
cfgDescr ConfigDescriptor

Valore di ritorno

DocStructInfo
Restituisce un nuovo oggetto inizializzato.
Vedi anche

Documentazione

Classe DocStructInfo
Overload di CreateDocStructInfo
Namespace DedNet.Core


Metodo DocStructInfo.EnforcedMakeChildrenAuto

Metodo DocStructInfoEnforcedMakeChildrenAuto
Nella classe base la forzatura diviene in gestibile pertanto equiparo la chiamata ad un makeChildrenAuto normale per leggere le docdep salvate.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual void EnforcedMakeChildrenAuto(
    string enforcedTiesSourceFileName
)
Public Overridable Sub EnforcedMakeChildrenAuto (
    enforcedTiesSourceFileName As String
)
public:
virtual void EnforcedMakeChildrenAuto(
    String^ enforcedTiesSourceFileName
)
abstract EnforcedMakeChildrenAuto :
        enforcedTiesSourceFileName : string -> unit
override EnforcedMakeChildrenAuto :
        enforcedTiesSourceFileName : string -> unit

Parametri

enforcedTiesSourceFileName String
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Metodo DocStructInfo.Equals

Metodo DocStructInfoEquals

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj Object

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Metodo DocStructInfo.FileNameAreEquals

Metodo DocStructInfoFileNameAreEquals

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool FileNameAreEquals(
    Object obj
)
Public Function FileNameAreEquals (
    obj As Object
) As Boolean
public:
bool FileNameAreEquals(
    Object^ obj
)
member FileNameAreEquals :
        obj : Object -> bool

Parametri

obj Object

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Metodo DocStructInfo.FindAllLevels

Metodo DocStructInfoFindAllLevels

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfo FindAllLevels(
    string filename,
    string cfg = "*"
)
Public Function FindAllLevels (
    filename As String,
    Optional cfg As String = "*"
) As DocStructInfo
public:
DocStructInfo^ FindAllLevels(
    String^ filename,
    String^ cfg = L"*"
)
member FindAllLevels :
        filename : string *
        ?cfg : string
(* Defaults:
        let _cfg = defaultArg cfg "*"
*)
-> DocStructInfo

Parametri

filename String
cfg String (Optional)

Valore di ritorno

DocStructInfo
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Metodo DocStructInfo.GetAllSpecialChildren

Metodo DocStructInfoGetAllSpecialChildren
Ritorna tutti i figli dell'elemento che sono elementi della struttura speciale

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void GetAllSpecialChildren(
    DocStructInfoList dsil
)
Public Sub GetAllSpecialChildren (
    dsil As DocStructInfoList
)
public:
void GetAllSpecialChildren(
    DocStructInfoList^ dsil
)
member GetAllSpecialChildren :
        dsil : DocStructInfoList -> unit

Parametri

dsil DocStructInfoList

Valore di ritorno

Lista degli elementi appartenenti alla struttura speciale
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Metodo DocStructInfo.GetFileNameHashString

Metodo DocStructInfoGetFileNameHashString

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual string GetFileNameHashString()
Public Overridable Function GetFileNameHashString As String
public:
virtual String^ GetFileNameHashString()
abstract GetFileNameHashString : unit -> string
override GetFileNameHashString : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Metodo DocStructInfo.GetHashCode

Metodo DocStructInfoGetHashCode

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Metodo DocStructInfo.GetHashString

Metodo DocStructInfoGetHashString

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual string GetHashString()
Public Overridable Function GetHashString As String
public:
virtual String^ GetHashString()
abstract GetHashString : unit -> string
override GetHashString : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Metodo DocStructInfo.GetLastQueuedOperation

Metodo DocStructInfoGetLastQueuedOperation
Ritorna l'ultima operazione presente in lista appartenenete al tipo specificato. Se l'operazione non esiste ritorna null.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructOperationBase GetLastQueuedOperation(
    DocStructOperationEnum opType
)
Public Function GetLastQueuedOperation (
    opType As DocStructOperationEnum
) As DocStructOperationBase
public:
DocStructOperationBase^ GetLastQueuedOperation(
    DocStructOperationEnum opType
)
member GetLastQueuedOperation :
        opType : DocStructOperationEnum -> DocStructOperationBase

Parametri

opType DocStructOperationEnum
Tipo di operazione da controllare

Valore di ritorno

DocStructOperationBase
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Metodo DocStructInfo.GetOperation

Metodo DocStructInfoGetOperation
Se esiste ritorna l'operazione corrispondente al tipo passato altrimenti null.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructOperationBase GetOperation(
    DocStructOperationEnum opType
)
Public Function GetOperation (
    opType As DocStructOperationEnum
) As DocStructOperationBase
public:
DocStructOperationBase^ GetOperation(
    DocStructOperationEnum opType
)
member GetOperation :
        opType : DocStructOperationEnum -> DocStructOperationBase

Parametri

opType DocStructOperationEnum
Tipo di operazione da controllare

Valore di ritorno

DocStructOperationBase
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Metodo DocStructInfo.GetOperationHierarchy

Metodo DocStructInfoGetOperationHierarchy
Se esiste ritorna l'operazione corrispondente al tipo passato altrimenti null.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructOperationBase GetOperationHierarchy(
    DocStructOperationEnum opType
)
Public Function GetOperationHierarchy (
    opType As DocStructOperationEnum
) As DocStructOperationBase
public:
DocStructOperationBase^ GetOperationHierarchy(
    DocStructOperationEnum opType
)
member GetOperationHierarchy :
        opType : DocStructOperationEnum -> DocStructOperationBase

Parametri

opType DocStructOperationEnum
Tipo di operazione da controllare

Valore di ritorno

DocStructOperationBase
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Metodo DocStructInfo.HasOperation

Metodo DocStructInfoHasOperation
Ritorna vero se nella lista delle operazioni è presente quella corrispondente al tipo passato

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasOperation(
    DocStructOperationEnum opType
)
Public Function HasOperation (
    opType As DocStructOperationEnum
) As Boolean
public:
bool HasOperation(
    DocStructOperationEnum opType
)
member HasOperation :
        opType : DocStructOperationEnum -> bool

Parametri

opType DocStructOperationEnum
Tipo di operazione da controllare

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Metodo DocStructInfo.HasOperationHierarchy

Metodo DocStructInfoHasOperationHierarchy
Ritorna vero se nella lista delle operazioni è presente quella corrispondente al tipo passato

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasOperationHierarchy(
    DocStructOperationEnum opType
)
Public Function HasOperationHierarchy (
    opType As DocStructOperationEnum
) As Boolean
public:
bool HasOperationHierarchy(
    DocStructOperationEnum opType
)
member HasOperationHierarchy :
        opType : DocStructOperationEnum -> bool

Parametri

opType DocStructOperationEnum
Tipo di operazione da controllare

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Metodo DocStructInfo.IsInParentCollection

Metodo DocStructInfoIsInParentCollection
Controlla se l'oggetto passato non sia lo stesso di quello corrente o che non sia nell'elenco dei padri

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool IsInParentCollection(
    DocStructInfo refDs,
    DocStructInfo ds
)
Public Shared Function IsInParentCollection (
    refDs As DocStructInfo,
    ds As DocStructInfo
) As Boolean
public:
static bool IsInParentCollection(
    DocStructInfo^ refDs,
    DocStructInfo^ ds
)
static member IsInParentCollection :
        refDs : DocStructInfo *
        ds : DocStructInfo -> bool

Parametri

refDs DocStructInfo
ds DocStructInfo

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Metodo DocStructInfo.MakeChildrenAuto

Metodo DocStructInfoMakeChildrenAuto
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | MakeChildrenAuto | Se la collezione di elementi figli è vuota crea automaticamente le dipendenze sfruttando l'apprentice o le deduzioni sul dwg/prt. Viene utilizzata dai comandi quando i file non sono elaborati dal client. Tipicamente i client di Inventor e AutoCAD faranno l'override di questo metodo per costruire le singole dipendenze dei documenti in memoria che si stanno elaborando.
Metodo pubblico | MakeChildrenAuto(DocStructInfoList) | Metodo virtuale per la creazione della struttura ovverridato da client. Se il client non specifica il metodo utilizza comunque le dipendenze salvate nel database.
Torna su
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Metodo DocStructInfo.MakeChildrenAuto

Metodo DocStructInfoMakeChildrenAuto
Se la collezione di elementi figli è vuota crea automaticamente le dipendenze sfruttando l'apprentice o le deduzioni sul dwg/prt. Viene utilizzata dai comandi quando i file non sono elaborati dal client. Tipicamente i client di Inventor e AutoCAD faranno l'override di questo metodo per costruire le singole dipendenze dei documenti in memoria che si stanno elaborando.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual void MakeChildrenAuto()
Public Overridable Sub MakeChildrenAuto
public:
virtual void MakeChildrenAuto()
abstract MakeChildrenAuto : unit -> unit
override MakeChildrenAuto : unit -> unit
Vedi anche

Documentazione

Classe DocStructInfo
Overload di MakeChildrenAuto
Namespace DedNet.Core


Metodo DocStructInfo.MakeChildrenAuto(DocStructInfoList)

Metodo DocStructInfoMakeChildrenAuto(DocStructInfoList)
Metodo virtuale per la creazione della struttura ovverridato da client. Se il client non specifica il metodo utilizza comunque le dipendenze salvate nel database.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual void MakeChildrenAuto(
    DocStructInfoList clientDocs
)
Public Overridable Sub MakeChildrenAuto (
    clientDocs As DocStructInfoList
)
public:
virtual void MakeChildrenAuto(
    DocStructInfoList^ clientDocs
)
abstract MakeChildrenAuto :
        clientDocs : DocStructInfoList -> unit
override MakeChildrenAuto :
        clientDocs : DocStructInfoList -> unit

Parametri

clientDocs DocStructInfoList
Lista da utilizzare nel caso un riferimento sia presente nei documenti client.
Vedi anche

Documentazione

Classe DocStructInfo
Overload di MakeChildrenAuto
Namespace DedNet.Core


Metodo DocStructInfo.MakeChildrenAutoByDocDep

Metodo DocStructInfoMakeChildrenAutoByDocDep
Crea la struttura utilizzando esclusivamente le dipendenze nel database. E' necessaria quando si devono indagare documenti che sono già salvati nel db come ad esempio nelle operazioni di apertura.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void MakeChildrenAutoByDocDep(
    DocStructInfoList clientDocs = null
)
Public Sub MakeChildrenAutoByDocDep (
    Optional clientDocs As DocStructInfoList = Nothing
)
public:
void MakeChildrenAutoByDocDep(
    DocStructInfoList^ clientDocs = nullptr
)
member MakeChildrenAutoByDocDep :
        ?clientDocs : DocStructInfoList
(* Defaults:
        let _clientDocs = defaultArg clientDocs null
*)
-> unit

Parametri

clientDocs DocStructInfoList (Optional)
Lista da utilizzare nel caso un riferimento sia presente nei documenti client.
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Metodo DocStructInfo.MakeFromDocDocStructInfo

Metodo DocStructInfoMakeFromDocDocStructInfo
Crea e restituisce una lista di struttura documento clonata da una esistente. Questa funzione si preoccupa di non duplicare elementi nella lista resitituita.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static DocStructInfoList MakeFromDocDocStructInfo(
    DedNetApplication app,
    DocStructInfoList docList
)
Public Shared Function MakeFromDocDocStructInfo (
    app As DedNetApplication,
    docList As DocStructInfoList
) As DocStructInfoList
public:
static DocStructInfoList^ MakeFromDocDocStructInfo(
    DedNetApplication^ app,
    DocStructInfoList^ docList
)
static member MakeFromDocDocStructInfo :
        app : DedNetApplication *
        docList : DocStructInfoList -> DocStructInfoList

Parametri

app DedNetApplication
Applicazione di appartenenza.
docList DocStructInfoList
Lista di documenti da elaborare.

Valore di ritorno

DocStructInfoList
Restituisce sempre una lista inizializzata.
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Metodo DocStructInfo.MakeFromDocList

Metodo DocStructInfoMakeFromDocList
Crea e restituisce una lista di struttura documento data una lista di documenti, auto-creando i figli. Questa funzione si preoccupa di non duplicare elementi nella lista resitituita.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static DocStructInfoList MakeFromDocList(
    DedNetApplication app,
    DedDocList docList
)
Public Shared Function MakeFromDocList (
    app As DedNetApplication,
    docList As DedDocList
) As DocStructInfoList
public:
static DocStructInfoList^ MakeFromDocList(
    DedNetApplication^ app,
    DedDocList^ docList
)
static member MakeFromDocList :
        app : DedNetApplication *
        docList : DedDocList -> DocStructInfoList

Parametri

app DedNetApplication
Applicazione di appartenenza.
docList DedDocList
Lista di documenti da elaborare.

Valore di ritorno

DocStructInfoList
Restituisce sempre una lista inizializzata.
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Metodo DocStructInfo.MakeFromFileList

Metodo DocStructInfoMakeFromFileList
Lista degli overload
Nome | Descrizione
MakeFromFileList(DedNetApplication, String, Boolean) | Crea e restituisce una lista di struttura documento, data una lista di file, auto-creando i figli. Questa funzione si preoccupa di non duplicare elementi nella lista resitituita.
MakeFromFileList(DedNetApplication, String, Boolean, DocStructInfoProgressChangedDelegate) | Crea e restituisce una lista di struttura documento, data una lista di file, auto-creando i figli. Questa funzione si preoccupa di non duplicare elementi nella lista resitituita.
Torna su
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Metodo DocStructInfo.MakeFromFileList(DedNetApplication, String[], Boolean)

Metodo DocStructInfoMakeFromFileList(DedNetApplication, String, Boolean)
Crea e restituisce una lista di struttura documento, data una lista di file, auto-creando i figli. Questa funzione si preoccupa di non duplicare elementi nella lista resitituita.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static DocStructInfoList MakeFromFileList(
    DedNetApplication app,
    string[] fileList,
    bool lazyMode = false
)
Public Shared Function MakeFromFileList (
    app As DedNetApplication,
    fileList As String(),
    Optional lazyMode As Boolean = false
) As DocStructInfoList
public:
static DocStructInfoList^ MakeFromFileList(
    DedNetApplication^ app,
    array<String^>^ fileList,
    bool lazyMode = false
)
static member MakeFromFileList :
        app : DedNetApplication *
        fileList : string[] *
        ?lazyMode : bool
(* Defaults:
        let _lazyMode = defaultArg lazyMode false
*)
-> DocStructInfoList

Parametri

app DedNetApplication
Applicazione di appartenenza.
fileList String
Lista di file da elaborare.
lazyMode Boolean (Optional)
Se vero attiva la modalità che non invalida tutta la struttuta in caso di errori, tutte le eccezioni vengono salvate in una lista appartenente al DocStructInofList

Valore di ritorno

DocStructInfoList
Restituisce sempre una lista inizializzata.
Vedi anche

Documentazione

Classe DocStructInfo
Overload di MakeFromFileList
Namespace DedNet.Core


Metodo DocStructInfo.MakeFromFileList(DedNetApplication, String[], Boolean, DocStructInfo.ProgressChangedDelegate)

Metodo DocStructInfoMakeFromFileList(DedNetApplication, String, Boolean, DocStructInfoProgressChangedDelegate)
Crea e restituisce una lista di struttura documento, data una lista di file, auto-creando i figli. Questa funzione si preoccupa di non duplicare elementi nella lista resitituita.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static DocStructInfoList MakeFromFileList(
    DedNetApplication app,
    string[] fileList,
    bool lazyMode,
    DocStructInfoProgressChangedDelegate pcd
)
Public Shared Function MakeFromFileList (
    app As DedNetApplication,
    fileList As String(),
    lazyMode As Boolean,
    pcd As DocStructInfoProgressChangedDelegate
) As DocStructInfoList
public:
static DocStructInfoList^ MakeFromFileList(
    DedNetApplication^ app,
    array<String^>^ fileList,
    bool lazyMode,
    DocStructInfoProgressChangedDelegate^ pcd
)
static member MakeFromFileList :
        app : DedNetApplication *
        fileList : string[] *
        lazyMode : bool *
        pcd : DocStructInfoProgressChangedDelegate -> DocStructInfoList

Parametri

app DedNetApplication
Applicazione di appartenenza.
fileList String
Lista di file da elaborare.
lazyMode Boolean
Se vero attiva la modalità che non invalida tutta la struttuta in caso di errori, tutte le eccezioni vengono salvate in una lista appartenente al DocStructInofList
pcd DocStructInfoProgressChangedDelegate

Valore di ritorno

DocStructInfoList
Restituisce sempre una lista inizializzata.
Vedi anche

Documentazione

Classe DocStructInfo
Overload di MakeFromFileList
Namespace DedNet.Core


Metodo DocStructInfo.PerformFileOperation

Metodo DocStructInfoPerformFileOperation

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void PerformFileOperation(
    FileTransaction fileTrans
)
Public Sub PerformFileOperation (
    fileTrans As FileTransaction
)
public:
void PerformFileOperation(
    FileTransaction^ fileTrans
)
member PerformFileOperation :
        fileTrans : FileTransaction -> unit

Parametri

fileTrans FileTransaction
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Metodo DocStructInfo.Rebuild

Metodo DocStructInfoRebuild
Solo nel caso l'elemento non sia stato elaborato ed abbia nella lista la sola DocStructOperationBase, la ricrea con il file name già presente. Viene usata per ricreare il documento se questo è cambiato pur non cambiando il suo percorso file.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Rebuild(
    bool throughAll
)
Public Sub Rebuild (
    throughAll As Boolean
)
public:
void Rebuild(
    bool throughAll
)
member Rebuild :
        throughAll : bool -> unit

Parametri

throughAll Boolean
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Metodo DocStructInfo.Reinit

Metodo DocStructInfoReinit
Reinizializza il DocStructInfo riportandolo allo stato originale. Svuota la lista delle operazioni.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Reinit(
    bool throughAll
)
Public Sub Reinit (
    throughAll As Boolean
)
public:
void Reinit(
    bool throughAll
)
member Reinit :
        throughAll : bool -> unit

Parametri

throughAll Boolean
Indica se reinizializzare anche i figli.
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Metodo DocStructInfo.SetNotToClone

Metodo DocStructInfoSetNotToClone
Imposta questo elemento come Non da Clonare (ToClone = false e CloneFullName = null).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetNotToClone()
Public Sub SetNotToClone
public:
void SetNotToClone()
member SetNotToClone : unit -> unit
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Metodo DocStructInfo.SetToClone

Metodo DocStructInfoSetToClone
Imposta questo elemento come da Clonare (ToClone = true) e CloneFullName = destFullName).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetToClone(
    string destFullName
)
Public Sub SetToClone (
    destFullName As String
)
public:
void SetToClone(
    String^ destFullName
)
member SetToClone :
        destFullName : string -> unit

Parametri

destFullName String
Destinazione di clonazione dell'elemento.
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Metodo DocStructInfo.ToString

Metodo DocStructInfoToString

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Metodo DocStructInfo.UpdateData

Metodo DocStructInfoUpdateData
Aggiorna le anagrafiche collegate sugli oggetti elaborati. Nella classebase non fa niente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual void UpdateData(
    bool updateRowVer = true
)
Public Overridable Sub UpdateData (
    Optional updateRowVer As Boolean = true
)
public:
virtual void UpdateData(
    bool updateRowVer = true
)
abstract UpdateData :
        ?updateRowVer : bool
(* Defaults:
        let _updateRowVer = defaultArg updateRowVer true
*)
-> unit
override UpdateData :
        ?updateRowVer : bool
(* Defaults:
        let _updateRowVer = defaultArg updateRowVer true
*)
-> unit

Parametri

updateRowVer Boolean (Optional)
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Metodo DocStructInfo.UpdateDocumentData

Metodo DocStructInfoUpdateDocumentData
Aggiorna tutti il documento dell'oggetto e di tutti i figli

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual void UpdateDocumentData()
Public Overridable Sub UpdateDocumentData
public:
virtual void UpdateDocumentData()
abstract UpdateDocumentData : unit -> unit
override UpdateDocumentData : unit -> unit
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Metodo DocStructInfo.UpdateParentReferences

Metodo DocStructInfoUpdateParentReferences
Aggiorna i riferimenti fisici dei file genitori, di primo livello, per questo elemento. Nella classe base non fa niente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual void UpdateParentReferences()
Public Overridable Sub UpdateParentReferences
public:
virtual void UpdateParentReferences()
abstract UpdateParentReferences : unit -> unit
override UpdateParentReferences : unit -> unit
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Metodo DocStructInfo.UpdateReferences

Metodo DocStructInfoUpdateReferences
Aggiorna i riferimenti fisici dei file di primo livello per questo elemento e poi chiama l'aggiornamento sui figli. Nella classebase non fa niente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual void UpdateReferences()
Public Overridable Sub UpdateReferences
public:
virtual void UpdateReferences()
abstract UpdateReferences : unit -> unit
override UpdateReferences : unit -> unit
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Campi di DocStructInfo

Il tipo DocStructInfo espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | Elements | Elementi già presenti nella struttura, utilizzata per evitare duplicati a parità di file.
Campo pubblico | IgnoreCheckParentCollection | Indica se ignorare il controllo sulla ricorsione dei padri.
Campo protetto | Operations | Elementi già presenti nella struttura, utilizzata per evitare duplicati a parità di file.
Torna su
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Campo DocStructInfo.Elements

Campo DocStructInfoElements
Elementi già presenti nella struttura, utilizzata per evitare duplicati a parità di file.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal readonly DocStructInfoDictionary Elements
Protected Friend ReadOnly Elements As DocStructInfoDictionary
protected public:
initonly DocStructInfoDictionary^ Elements
val Elements: DocStructInfoDictionary

Valore del campo

DocStructInfoDictionary
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Campo DocStructInfo.IgnoreCheckParentCollection

Campo DocStructInfoIgnoreCheckParentCollection
Indica se ignorare il controllo sulla ricorsione dei padri.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IgnoreCheckParentCollection
Public IgnoreCheckParentCollection As Boolean
public:
bool IgnoreCheckParentCollection
val mutable IgnoreCheckParentCollection: bool

Valore del campo

Boolean
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Campo DocStructInfo.Operations

Campo DocStructInfoOperations
Elementi già presenti nella struttura, utilizzata per evitare duplicati a parità di file.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal readonly DocStructInfoOperationListDictionary Operations
Protected Friend ReadOnly Operations As DocStructInfoOperationListDictionary
protected public:
initonly DocStructInfoOperationListDictionary^ Operations
val Operations: DocStructInfoOperationListDictionary

Valore del campo

DocStructInfoOperationListDictionary
Vedi anche

Documentazione

Classe DocStructInfo
Namespace DedNet.Core


Delegate DocStructInfo.ProgressChangedDelegate

Delegate DocStructInfoProgressChangedDelegate
Delegate per la geatione dell'avanzamento nei metodi che gestiscono liste di file

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public delegate void ProgressChangedDelegate(
    long curIndex,
    long total,
    string curFileName
)
Public Delegate Sub ProgressChangedDelegate (
    curIndex As Long,
    total As Long,
    curFileName As String
)
public delegate void ProgressChangedDelegate(
    long long curIndex,
    long long total,
    String^ curFileName
)
type ProgressChangedDelegate =
    delegate of
        curIndex : int64 *
        total : int64 *
        curFileName : string -> unit

Parametri

curIndex Int64
total Int64
curFileName String
Vedi anche

Documentazione

Namespace DedNet.Core


Enumerazione DocStructInfo.SavingFileType

Enumerazione DocStructInfoSavingFileType
Enumerazione che mi indica che tipo di documento mi rappresenta questo elemento, in relazione al documento in salvataggio (serve al comando di salva nel db per capire se un elemento sia stato aggiunto come file associato oppure come file referenziato oppure se si tratti proprio del documento in salvataggio).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum SavingFileType
Public Enumeration SavingFileType
public enum class SavingFileType
type SavingFileType
Membri
Nome | Valore | Descrizione
None | 0 |
MainDocument | 1 | Documento in salvataggio.
ReferencedDocument | 2 | Documento referenziato da quello in salvataggio.
ReferencingDocument | 3 | Documento che referenzia quello in salvataggio.
AssociatedDocument | 4 | Documento con stesso nome ma diversa estensione di quello in salvataggio.
Vedi anche

Documentazione

Namespace DedNet.Core


Classe DocStructInfoCollection
Collezione di oggetti DocStructInfo contenente le collezioni di file/documenti che sono le dipendenze del documento padre.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDocStructInfoCollection

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DocStructInfoCollection : IEnumerable
Public Class DocStructInfoCollection
    Implements IEnumerable
public ref class DocStructInfoCollection : IEnumerable
type DocStructInfoCollection =
    class
        interface IEnumerable
    end

Il tipo DocStructInfoCollection espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo protetto | DocStructInfoCollection | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Count | Restituisce il numero di elementi presenti.
Proprietà pubblica | Owner | Restituisce il possessore della collezione.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Add(DocStructInfo) | Aggiunge l'elemento passato alla lista senza effettuare controlli ulteriori
Metodo pubblico | Add(DocStructInfoFileDescriptor, DocDepEnum) | Aggiunge e restituisce un nuovo elemento alla collezione.
Metodo pubblico | Add(String, DocDepEnum) | Aggiunge e restituisce un nuovo elemento alla collezione.
Metodo pubblico | Add(String, ConfigDescriptor, DocDepEnum) | Aggiunge e restituisce un nuovo elemento alla collezione.
Metodo pubblico | AsList | Restituisce la collection sottoforma di lista
Metodo pubblico | Clear | Elimina tutti gli elementi.
Metodo pubblico | Contains(DocStructInfo) | Restituisce se contiene o meno l'elemento.
Metodo pubblico | Contains(DocStructInfoFileDescriptor) | Restituisce se contiene o meno l'elemento.
Metodo pubblico | Contains(String) | Restituisce se contiene o meno l'elemento.
Metodo pubblico | Contains(String, ConfigDescriptor) | Restituisce se contiene o meno l'elemento.
Metodo pubblico | Find(DocStructInfoFileDescriptor) | Restituisce l'elemento o null.
Metodo pubblico | Find(String) | Restituisce l'elemento o null.
Metodo pubblico | Find(String, ConfigDescriptor) | Restituisce l'elemento o null.
Metodo pubblico | GetEnumerator | Restitusice l'enumeratore della collezione.
Metodo pubblico | Remove | Elimina un elemento dalla collezione.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DocStructInfoCollection
Costruttore unico.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal DocStructInfoCollection(
    DocStructInfo owner
)
Protected Friend Sub New (
    owner As DocStructInfo
)
protected public:
DocStructInfoCollection(
    DocStructInfo^ owner
)
new :
        owner : DocStructInfo -> DocStructInfoCollection

Parametri

owner DocStructInfo
Possessore della collezione.
Vedi anche

Documentazione

Classe DocStructInfoCollection
Namespace DedNet.Core


Proprietà di DocStructInfoCollection

Il tipo DocStructInfoCollection espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Count | Restituisce il numero di elementi presenti.
Proprietà pubblica | Owner | Restituisce il possessore della collezione.
Torna su
Vedi anche

Documentazione

Classe DocStructInfoCollection
Namespace DedNet.Core


Proprietà DocStructInfoCollection.Count

Proprietà DocStructInfoCollectionCount
Restituisce il numero di elementi presenti.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
public:
property int Count {
    int get ();
}
member Count : int with get

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe DocStructInfoCollection
Namespace DedNet.Core


Proprietà DocStructInfoCollection.Owner

Proprietà DocStructInfoCollectionOwner
Restituisce il possessore della collezione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfo Owner { get; }
Public ReadOnly Property Owner As DocStructInfo
    Get
public:
property DocStructInfo^ Owner {
    DocStructInfo^ get ();
}
member Owner : DocStructInfo with get

Valore della proprietà

DocStructInfo
Vedi anche

Documentazione

Classe DocStructInfoCollection
Namespace DedNet.Core


Metodi di DocStructInfoCollection

Il tipo DocStructInfoCollection espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Add(DocStructInfo) | Aggiunge l'elemento passato alla lista senza effettuare controlli ulteriori
Metodo pubblico | Add(DocStructInfoFileDescriptor, DocDepEnum) | Aggiunge e restituisce un nuovo elemento alla collezione.
Metodo pubblico | Add(String, DocDepEnum) | Aggiunge e restituisce un nuovo elemento alla collezione.
Metodo pubblico | Add(String, ConfigDescriptor, DocDepEnum) | Aggiunge e restituisce un nuovo elemento alla collezione.
Metodo pubblico | AsList | Restituisce la collection sottoforma di lista
Metodo pubblico | Clear | Elimina tutti gli elementi.
Metodo pubblico | Contains(DocStructInfo) | Restituisce se contiene o meno l'elemento.
Metodo pubblico | Contains(DocStructInfoFileDescriptor) | Restituisce se contiene o meno l'elemento.
Metodo pubblico | Contains(String) | Restituisce se contiene o meno l'elemento.
Metodo pubblico | Contains(String, ConfigDescriptor) | Restituisce se contiene o meno l'elemento.
Metodo pubblico | Find(DocStructInfoFileDescriptor) | Restituisce l'elemento o null.
Metodo pubblico | Find(String) | Restituisce l'elemento o null.
Metodo pubblico | Find(String, ConfigDescriptor) | Restituisce l'elemento o null.
Metodo pubblico | GetEnumerator | Restitusice l'enumeratore della collezione.
Metodo pubblico | Remove | Elimina un elemento dalla collezione.
Torna su
Vedi anche

Documentazione

Classe DocStructInfoCollection
Namespace DedNet.Core


Metodo DocStructInfoCollection.Add

Metodo DocStructInfoCollectionAdd
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Add(DocStructInfo) | Aggiunge l'elemento passato alla lista senza effettuare controlli ulteriori
Metodo pubblico | Add(DocStructInfoFileDescriptor, DocDepEnum) | Aggiunge e restituisce un nuovo elemento alla collezione.
Metodo pubblico | Add(String, DocDepEnum) | Aggiunge e restituisce un nuovo elemento alla collezione.
Metodo pubblico | Add(String, ConfigDescriptor, DocDepEnum) | Aggiunge e restituisce un nuovo elemento alla collezione.
Torna su
Vedi anche

Documentazione

Classe DocStructInfoCollection
Namespace DedNet.Core


Metodo DocStructInfoCollection.Add(DocStructInfo)

Metodo DocStructInfoCollectionAdd(DocStructInfo)
Aggiunge l'elemento passato alla lista senza effettuare controlli ulteriori

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual DocStructInfo Add(
    DocStructInfo item
)
Public Overridable Function Add (
    item As DocStructInfo
) As DocStructInfo
public:
virtual DocStructInfo^ Add(
    DocStructInfo^ item
)
abstract Add :
        item : DocStructInfo -> DocStructInfo
override Add :
        item : DocStructInfo -> DocStructInfo

Parametri

item DocStructInfo
Elemento da aggiungere.

Valore di ritorno

DocStructInfo
Vedi anche

Documentazione

Classe DocStructInfoCollection
Overload di Add
Namespace DedNet.Core


Metodo DocStructInfoCollection.Add(DocStructInfoFileDescriptor, DocDepEnum)

Metodo DocStructInfoCollectionAdd(DocStructInfoFileDescriptor, DocDepEnum)
Aggiunge e restituisce un nuovo elemento alla collezione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual DocStructInfo Add(
    DocStructInfoFileDescriptor fileDescr,
    DocDepEnum depType
)
Public Overridable Function Add (
    fileDescr As DocStructInfoFileDescriptor,
    depType As DocDepEnum
) As DocStructInfo
public:
virtual DocStructInfo^ Add(
    DocStructInfoFileDescriptor^ fileDescr,
    DocDepEnum depType
)
abstract Add :
        fileDescr : DocStructInfoFileDescriptor *
        depType : DocDepEnum -> DocStructInfo
override Add :
        fileDescr : DocStructInfoFileDescriptor *
        depType : DocDepEnum -> DocStructInfo

Parametri

fileDescr DocStructInfoFileDescriptor
File del quale ricavare le informazioni.
depType DocDepEnum
Tipo di dipendenza con il padre.

Valore di ritorno

DocStructInfo
Vedi anche

Documentazione

Classe DocStructInfoCollection
Overload di Add
Namespace DedNet.Core


Metodo DocStructInfoCollection.Add(String, DocDepEnum)

Metodo DocStructInfoCollectionAdd(String, DocDepEnum)
Aggiunge e restituisce un nuovo elemento alla collezione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual DocStructInfo Add(
    string fileName,
    DocDepEnum depType
)
Public Overridable Function Add (
    fileName As String,
    depType As DocDepEnum
) As DocStructInfo
public:
virtual DocStructInfo^ Add(
    String^ fileName,
    DocDepEnum depType
)
abstract Add :
        fileName : string *
        depType : DocDepEnum -> DocStructInfo
override Add :
        fileName : string *
        depType : DocDepEnum -> DocStructInfo

Parametri

fileName String
File del quale ricavare le informazioni.
depType DocDepEnum
Tipo di dipendenza con il padre.

Valore di ritorno

DocStructInfo
Vedi anche

Documentazione

Classe DocStructInfoCollection
Overload di Add
Namespace DedNet.Core


Metodo DocStructInfoCollection.Add(String, ConfigDescriptor, DocDepEnum)

Metodo DocStructInfoCollectionAdd(String, ConfigDescriptor, DocDepEnum)
Aggiunge e restituisce un nuovo elemento alla collezione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual DocStructInfo Add(
    string fileName,
    ConfigDescriptor cfgDescr,
    DocDepEnum depType
)
Public Overridable Function Add (
    fileName As String,
    cfgDescr As ConfigDescriptor,
    depType As DocDepEnum
) As DocStructInfo
public:
virtual DocStructInfo^ Add(
    String^ fileName,
    ConfigDescriptor^ cfgDescr,
    DocDepEnum depType
)
abstract Add :
        fileName : string *
        cfgDescr : ConfigDescriptor *
        depType : DocDepEnum -> DocStructInfo
override Add :
        fileName : string *
        cfgDescr : ConfigDescriptor *
        depType : DocDepEnum -> DocStructInfo

Parametri

fileName String
File del quale ricavare le informazioni.
cfgDescr ConfigDescriptor
depType DocDepEnum
Tipo di dipendenza con il padre.

Valore di ritorno

DocStructInfo
Vedi anche

Documentazione

Classe DocStructInfoCollection
Overload di Add
Namespace DedNet.Core


Metodo DocStructInfoCollection.AsList

Metodo DocStructInfoCollectionAsList
Restituisce la collection sottoforma di lista

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfoList AsList()
Public Function AsList As DocStructInfoList
public:
DocStructInfoList^ AsList()
member AsList : unit -> DocStructInfoList

Valore di ritorno

DocStructInfoList
Vedi anche

Documentazione

Classe DocStructInfoCollection
Namespace DedNet.Core


Metodo DocStructInfoCollection.Clear

Metodo DocStructInfoCollectionClear
Elimina tutti gli elementi.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
Vedi anche

Documentazione

Classe DocStructInfoCollection
Namespace DedNet.Core


Metodo DocStructInfoCollection.Contains

Metodo DocStructInfoCollectionContains
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Contains(DocStructInfo) | Restituisce se contiene o meno l'elemento.
Metodo pubblico | Contains(DocStructInfoFileDescriptor) | Restituisce se contiene o meno l'elemento.
Metodo pubblico | Contains(String) | Restituisce se contiene o meno l'elemento.
Metodo pubblico | Contains(String, ConfigDescriptor) | Restituisce se contiene o meno l'elemento.
Torna su
Vedi anche

Documentazione

Classe DocStructInfoCollection
Namespace DedNet.Core


Metodo DocStructInfoCollection.Contains(DocStructInfo)

Metodo DocStructInfoCollectionContains(DocStructInfo)
Restituisce se contiene o meno l'elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Contains(
    DocStructInfo item
)
Public Function Contains (
    item As DocStructInfo
) As Boolean
public:
bool Contains(
    DocStructInfo^ item
)
member Contains :
        item : DocStructInfo -> bool

Parametri

item DocStructInfo
Elemento da verificare.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DocStructInfoCollection
Overload di Contains
Namespace DedNet.Core


Metodo DocStructInfoCollection.Contains(DocStructInfoFileDescriptor)

Metodo DocStructInfoCollectionContains(DocStructInfoFileDescriptor)
Restituisce se contiene o meno l'elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Contains(
    DocStructInfoFileDescriptor fDescr
)
Public Function Contains (
    fDescr As DocStructInfoFileDescriptor
) As Boolean
public:
bool Contains(
    DocStructInfoFileDescriptor^ fDescr
)
member Contains :
        fDescr : DocStructInfoFileDescriptor -> bool

Parametri

fDescr DocStructInfoFileDescriptor
Elemento da verificare

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DocStructInfoCollection
Overload di Contains
Namespace DedNet.Core


Metodo DocStructInfoCollection.Contains(String)

Metodo DocStructInfoCollectionContains(String)
Restituisce se contiene o meno l'elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Contains(
    string fileName
)
Public Function Contains (
    fileName As String
) As Boolean
public:
bool Contains(
    String^ fileName
)
member Contains :
        fileName : string -> bool

Parametri

fileName String
Nome file completo.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DocStructInfoCollection
Overload di Contains
Namespace DedNet.Core


Metodo DocStructInfoCollection.Contains(String, ConfigDescriptor)

Metodo DocStructInfoCollectionContains(String, ConfigDescriptor)
Restituisce se contiene o meno l'elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Contains(
    string fileName,
    ConfigDescriptor cfgDescr
)
Public Function Contains (
    fileName As String,
    cfgDescr As ConfigDescriptor
) As Boolean
public:
bool Contains(
    String^ fileName,
    ConfigDescriptor^ cfgDescr
)
member Contains :
        fileName : string *
        cfgDescr : ConfigDescriptor -> bool

Parametri

fileName String
Nome file completo.
cfgDescr ConfigDescriptor
DEscrittore della configurazione

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DocStructInfoCollection
Overload di Contains
Namespace DedNet.Core


Metodo DocStructInfoCollection.Find

Metodo DocStructInfoCollectionFind
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Find(DocStructInfoFileDescriptor) | Restituisce l'elemento o null.
Metodo pubblico | Find(String) | Restituisce l'elemento o null.
Metodo pubblico | Find(String, ConfigDescriptor) | Restituisce l'elemento o null.
Torna su
Vedi anche

Documentazione

Classe DocStructInfoCollection
Namespace DedNet.Core


Metodo DocStructInfoCollection.Find(DocStructInfoFileDescriptor)

Metodo DocStructInfoCollectionFind(DocStructInfoFileDescriptor)
Restituisce l'elemento o null.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfo Find(
    DocStructInfoFileDescriptor fDescr
)
Public Function Find (
    fDescr As DocStructInfoFileDescriptor
) As DocStructInfo
public:
DocStructInfo^ Find(
    DocStructInfoFileDescriptor^ fDescr
)
member Find :
        fDescr : DocStructInfoFileDescriptor -> DocStructInfo

Parametri

fDescr DocStructInfoFileDescriptor
Elemento da verificare

Valore di ritorno

DocStructInfo
Vedi anche

Documentazione

Classe DocStructInfoCollection
Overload di Find
Namespace DedNet.Core


Metodo DocStructInfoCollection.Find(String)

Metodo DocStructInfoCollectionFind(String)
Restituisce l'elemento o null.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfo Find(
    string fileName
)
Public Function Find (
    fileName As String
) As DocStructInfo
public:
DocStructInfo^ Find(
    String^ fileName
)
member Find :
        fileName : string -> DocStructInfo

Parametri

fileName String
Nome file completo.

Valore di ritorno

DocStructInfo
Vedi anche

Documentazione

Classe DocStructInfoCollection
Overload di Find
Namespace DedNet.Core


Metodo DocStructInfoCollection.Find(String, ConfigDescriptor)

Metodo DocStructInfoCollectionFind(String, ConfigDescriptor)
Restituisce l'elemento o null.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfo Find(
    string fileName,
    ConfigDescriptor cfgDescr
)
Public Function Find (
    fileName As String,
    cfgDescr As ConfigDescriptor
) As DocStructInfo
public:
DocStructInfo^ Find(
    String^ fileName,
    ConfigDescriptor^ cfgDescr
)
member Find :
        fileName : string *
        cfgDescr : ConfigDescriptor -> DocStructInfo

Parametri

fileName String
Nome file completo.
cfgDescr ConfigDescriptor
Descrittore della configurazione

Valore di ritorno

DocStructInfo
Vedi anche

Documentazione

Classe DocStructInfoCollection
Overload di Find
Namespace DedNet.Core


Metodo DocStructInfoCollection.GetEnumerator

Metodo DocStructInfoCollectionGetEnumerator
Restitusice l'enumeratore della collezione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator
override GetEnumerator : unit -> IEnumerator

Valore di ritorno

IEnumerator

Implementa

IEnumerableGetEnumerator
Vedi anche

Documentazione

Classe DocStructInfoCollection
Namespace DedNet.Core


Metodo DocStructInfoCollection.Remove

Metodo DocStructInfoCollectionRemove
Elimina un elemento dalla collezione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual void Remove(
    DocStructInfo item
)
Public Overridable Sub Remove (
    item As DocStructInfo
)
public:
virtual void Remove(
    DocStructInfo^ item
)
abstract Remove :
        item : DocStructInfo -> unit
override Remove :
        item : DocStructInfo -> unit

Parametri

item DocStructInfo
Elemento da eliminare.
Vedi anche

Documentazione

Classe DocStructInfoCollection
Namespace DedNet.Core


Classe DocStructInfoDictionary
Dizionario di oggetti docstructinfo
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericDictionary DocStructInfoFileDescriptor, DocStructInfo
DedNet.CoreDocStructInfoDictionary

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DocStructInfoDictionary : Dictionary<DocStructInfoFileDescriptor, DocStructInfo>
Public Class DocStructInfoDictionary
    Inherits Dictionary(Of DocStructInfoFileDescriptor, DocStructInfo)
public ref class DocStructInfoDictionary : public Dictionary<DocStructInfoFileDescriptor^, DocStructInfo^>
type DocStructInfoDictionary =
    class
        inherit Dictionary<DocStructInfoFileDescriptor, DocStructInfo>
    end

Il tipo DocStructInfoDictionary espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DocStructInfoDictionary |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AddAllElements | Aggiunge tutti gli elementi del dizionario sorgente
Metodo pubblico | AddElements | Aggiunge solo gli elementi necessari
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DocStructInfoDictionary

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfoDictionary()
Public Sub New
public:
DocStructInfoDictionary()
new : unit -> DocStructInfoDictionary
Vedi anche

Documentazione

Classe DocStructInfoDictionary
Namespace DedNet.Core


Metodi di DocStructInfoDictionary

Il tipo DocStructInfoDictionary espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AddAllElements | Aggiunge tutti gli elementi del dizionario sorgente
Metodo pubblico | AddElements | Aggiunge solo gli elementi necessari
Torna su
Vedi anche

Documentazione

Classe DocStructInfoDictionary
Namespace DedNet.Core


Metodo DocStructInfoDictionary.AddAllElements

Metodo DocStructInfoDictionaryAddAllElements
Aggiunge tutti gli elementi del dizionario sorgente

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddAllElements(
    DocStructInfoDictionary source
)
Public Sub AddAllElements (
    source As DocStructInfoDictionary
)
public:
void AddAllElements(
    DocStructInfoDictionary^ source
)
member AddAllElements :
        source : DocStructInfoDictionary -> unit

Parametri

source DocStructInfoDictionary
Vedi anche

Documentazione

Classe DocStructInfoDictionary
Namespace DedNet.Core


Metodo DocStructInfoDictionary.AddElements

Metodo DocStructInfoDictionaryAddElements
Aggiunge solo gli elementi necessari

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddElements(
    DocStructInfoDictionary source
)
Public Sub AddElements (
    source As DocStructInfoDictionary
)
public:
void AddElements(
    DocStructInfoDictionary^ source
)
member AddElements :
        source : DocStructInfoDictionary -> unit

Parametri

source DocStructInfoDictionary
Vedi anche

Documentazione

Classe DocStructInfoDictionary
Namespace DedNet.Core


Classe DocStructInfoFileDescriptor
Descrive il pacchetto dati per il DocStructInfo. Di default contiene solo il full file name ma serve per essere derivata da Inventor.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDocStructInfoFileDescriptor

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DocStructInfoFileDescriptor
Public Class DocStructInfoFileDescriptor
public ref class DocStructInfoFileDescriptor
type DocStructInfoFileDescriptor = class end

Il tipo DocStructInfoFileDescriptor espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DocStructInfoFileDescriptor(String) | Costruttore di default.
Metodo pubblico | DocStructInfoFileDescriptor(String, ConfigDescriptor) | Costruttore di default.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | CfgDecr | Restituisce il nome della configurazione sottesa a questo elemento.
Proprietà pubblica | Config | Restituisce il nome della configurazione sottesa a questo elemento.
Proprietà pubblica | FileName | Restituisce il file name sotteso a questo elemento.
Proprietà pubblica | VaultPath | Restituisce il path di vault dato il descrittore creato
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetFileNameHashString |
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | GetHashString |
Metodo pubblico | GetSimpleHashString |
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DocStructInfoFileDescriptor
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | DocStructInfoFileDescriptor(String) | Costruttore di default.
Metodo pubblico | DocStructInfoFileDescriptor(String, ConfigDescriptor) | Costruttore di default.
Torna su
Vedi anche

Documentazione

Classe DocStructInfoFileDescriptor
Namespace DedNet.Core


Costruttore DocStructInfoFileDescriptor(String)
Costruttore di default.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfoFileDescriptor(
    string fileName
)
Public Sub New (
    fileName As String
)
public:
DocStructInfoFileDescriptor(
    String^ fileName
)
new :
        fileName : string -> DocStructInfoFileDescriptor

Parametri

fileName String
File name.
Vedi anche

Documentazione

Classe DocStructInfoFileDescriptor
Overload di DocStructInfoFileDescriptor
Namespace DedNet.Core


Costruttore DocStructInfoFileDescriptor(String, ConfigDescriptor)
Costruttore di default.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfoFileDescriptor(
    string fileName,
    ConfigDescriptor cfgDescr
)
Public Sub New (
    fileName As String,
    cfgDescr As ConfigDescriptor
)
public:
DocStructInfoFileDescriptor(
    String^ fileName,
    ConfigDescriptor^ cfgDescr
)
new :
        fileName : string *
        cfgDescr : ConfigDescriptor -> DocStructInfoFileDescriptor

Parametri

fileName String
File name.
cfgDescr ConfigDescriptor
Vedi anche

Documentazione

Classe DocStructInfoFileDescriptor
Overload di DocStructInfoFileDescriptor
Namespace DedNet.Core


Proprietà di DocStructInfoFileDescriptor

Il tipo DocStructInfoFileDescriptor espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CfgDecr | Restituisce il nome della configurazione sottesa a questo elemento.
Proprietà pubblica | Config | Restituisce il nome della configurazione sottesa a questo elemento.
Proprietà pubblica | FileName | Restituisce il file name sotteso a questo elemento.
Proprietà pubblica | VaultPath | Restituisce il path di vault dato il descrittore creato
Torna su
Vedi anche

Documentazione

Classe DocStructInfoFileDescriptor
Namespace DedNet.Core


Proprietà DocStructInfoFileDescriptor.CfgDecr

Proprietà DocStructInfoFileDescriptorCfgDecr
Restituisce il nome della configurazione sottesa a questo elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ConfigDescriptor CfgDecr { get; }
Public ReadOnly Property CfgDecr As ConfigDescriptor
    Get
public:
property ConfigDescriptor^ CfgDecr {
    ConfigDescriptor^ get ();
}
member CfgDecr : ConfigDescriptor with get

Valore della proprietà

ConfigDescriptor
Vedi anche

Documentazione

Classe DocStructInfoFileDescriptor
Namespace DedNet.Core


Proprietà DocStructInfoFileDescriptor.Config

Proprietà DocStructInfoFileDescriptorConfig
Restituisce il nome della configurazione sottesa a questo elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Config { get; }
Public ReadOnly Property Config As String
    Get
public:
property String^ Config {
    String^ get ();
}
member Config : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DocStructInfoFileDescriptor
Namespace DedNet.Core


Proprietà DocStructInfoFileDescriptor.FileName

Proprietà DocStructInfoFileDescriptorFileName
Restituisce il file name sotteso a questo elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string FileName { get; }
Public ReadOnly Property FileName As String
    Get
public:
property String^ FileName {
    String^ get ();
}
member FileName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DocStructInfoFileDescriptor
Namespace DedNet.Core


Proprietà DocStructInfoFileDescriptor.VaultPath

Proprietà DocStructInfoFileDescriptorVaultPath
Restituisce il path di vault dato il descrittore creato

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string VaultPath { get; }
Public ReadOnly Property VaultPath As String
    Get
public:
property String^ VaultPath {
    String^ get ();
}
member VaultPath : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DocStructInfoFileDescriptor
Namespace DedNet.Core


Metodi di DocStructInfoFileDescriptor

Il tipo DocStructInfoFileDescriptor espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetFileNameHashString |
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | GetHashString |
Metodo pubblico | GetSimpleHashString |
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Torna su
Vedi anche

Documentazione

Classe DocStructInfoFileDescriptor
Namespace DedNet.Core


Metodo DocStructInfoFileDescriptor.Equals

Metodo DocStructInfoFileDescriptorEquals

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj Object

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DocStructInfoFileDescriptor
Namespace DedNet.Core


Metodo DocStructInfoFileDescriptor.GetFileNameHashString

Metodo DocStructInfoFileDescriptorGetFileNameHashString

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string GetFileNameHashString()
Public Function GetFileNameHashString As String
public:
String^ GetFileNameHashString()
member GetFileNameHashString : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DocStructInfoFileDescriptor
Namespace DedNet.Core


Metodo DocStructInfoFileDescriptor.GetHashCode

Metodo DocStructInfoFileDescriptorGetHashCode

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DocStructInfoFileDescriptor
Namespace DedNet.Core


Metodo DocStructInfoFileDescriptor.GetHashString

Metodo DocStructInfoFileDescriptorGetHashString

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public virtual string GetHashString()
Public Overridable Function GetHashString As String
public:
virtual String^ GetHashString()
abstract GetHashString : unit -> string
override GetHashString : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DocStructInfoFileDescriptor
Namespace DedNet.Core


Metodo DocStructInfoFileDescriptor.GetSimpleHashString

Metodo DocStructInfoFileDescriptorGetSimpleHashString

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string GetSimpleHashString()
Public Function GetSimpleHashString As String
public:
String^ GetSimpleHashString()
member GetSimpleHashString : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DocStructInfoFileDescriptor
Namespace DedNet.Core


Metodo DocStructInfoFileDescriptor.ToString

Metodo DocStructInfoFileDescriptorToString

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DocStructInfoFileDescriptor
Namespace DedNet.Core


Classe DocStructInfoList
Lista di oggetti DocStructInfo.
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList DocStructInfo
DedNet.CoreDocStructInfoList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DocStructInfoList : List<DocStructInfo>
Public Class DocStructInfoList
    Inherits List(Of DocStructInfo)
public ref class DocStructInfoList : public List<DocStructInfo^>
type DocStructInfoList =
    class
        inherit List<DocStructInfo>
    end

Il tipo DocStructInfoList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DocStructInfoList |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Exceptions | Lista eventuali eccezione nella DocStructInfoList
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ContainsFile | Ovverride del metodo contains della lista. Non controlla la presenza dell'oggetto specifico ma considera uguali quegli oggetti che condividono la lista delle operazioni
Metodo pubblico | FindByDedDoc | Restituisce l'elemento con DedDoc corrispondente oppure null.
Metodo pubblico | FindByExtension | Restituisce l'elemento con l'estensione corrispondente oppure null.
Metodo pubblico | FindByFileName | Restituisce l'elemento con il nome file corrispondente oppure null.
Metodo pubblico | FindByGuid | Restituisce l'elemento con Guid corrispondente oppure null.
Metodo pubblico | GetDocList | Restituisce la lista dei documenti presenti in tutti gli elementi. Se il DocStructInfo non ha il DedDoc viene saltato. Vengono esaminati solo gli elementi della lista e non i figli.
Metodo pubblico | Reinit | Reinizializza tutta la lista facendo la reinizializzazione di tutti i DocStructInfo contenuti nella lista.
Metodo pubblico | SortByContext | Eseguo l'ordinamento in base al contesto del documento. Se la la tipologia è la stessa da la precedenza al modello.
Metodo pubblico | SortByDependences | Ordina gli oggetti di questa lista in modo che gli elementi più in basso nell'albero vengano prima di quelli a livello superiore. Se desc = true ordina al contrario In questo modo saranno elaborati prima quelli che non hanno dipendenze e poi quelli che hanno delle dipendenze con la certezza che le dipendenze siano già state elaborate.
Metodo pubblico | SortByDependences(Boolean) | Ordina gli oggetti di questa lista in base al parametro passato. Se True prima figli poi padri, Se False prima padri e poi figli
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DocStructInfoList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfoList()
Public Sub New
public:
DocStructInfoList()
new : unit -> DocStructInfoList
Vedi anche

Documentazione

Classe DocStructInfoList
Namespace DedNet.Core


Proprietà di DocStructInfoList

Il tipo DocStructInfoList espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Exceptions | Lista eventuali eccezione nella DocStructInfoList
Torna su
Vedi anche

Documentazione

Classe DocStructInfoList
Namespace DedNet.Core


Proprietà DocStructInfoList.Exceptions

Proprietà DocStructInfoListExceptions
Lista eventuali eccezione nella DocStructInfoList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<Exception> Exceptions { get; set; }
Public Property Exceptions As List(Of Exception)
    Get
    Set
public:
property List<Exception^>^ Exceptions {
    List<Exception^>^ get ();
    void set (List<Exception^>^ value);
}
member Exceptions : List<Exception> with get, set

Valore della proprietà

List Exception
Vedi anche

Documentazione

Classe DocStructInfoList
Namespace DedNet.Core


Metodi di DocStructInfoList

Il tipo DocStructInfoList espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ContainsFile | Ovverride del metodo contains della lista. Non controlla la presenza dell'oggetto specifico ma considera uguali quegli oggetti che condividono la lista delle operazioni
Metodo pubblico | FindByDedDoc | Restituisce l'elemento con DedDoc corrispondente oppure null.
Metodo pubblico | FindByExtension | Restituisce l'elemento con l'estensione corrispondente oppure null.
Metodo pubblico | FindByFileName | Restituisce l'elemento con il nome file corrispondente oppure null.
Metodo pubblico | FindByGuid | Restituisce l'elemento con Guid corrispondente oppure null.
Metodo pubblico | GetDocList | Restituisce la lista dei documenti presenti in tutti gli elementi. Se il DocStructInfo non ha il DedDoc viene saltato. Vengono esaminati solo gli elementi della lista e non i figli.
Metodo pubblico | Reinit | Reinizializza tutta la lista facendo la reinizializzazione di tutti i DocStructInfo contenuti nella lista.
Metodo pubblico | SortByContext | Eseguo l'ordinamento in base al contesto del documento. Se la la tipologia è la stessa da la precedenza al modello.
Metodo pubblico | SortByDependences | Ordina gli oggetti di questa lista in modo che gli elementi più in basso nell'albero vengano prima di quelli a livello superiore. Se desc = true ordina al contrario In questo modo saranno elaborati prima quelli che non hanno dipendenze e poi quelli che hanno delle dipendenze con la certezza che le dipendenze siano già state elaborate.
Metodo pubblico | SortByDependences(Boolean) | Ordina gli oggetti di questa lista in base al parametro passato. Se True prima figli poi padri, Se False prima padri e poi figli
Torna su
Vedi anche

Documentazione

Classe DocStructInfoList
Namespace DedNet.Core


Metodo DocStructInfoList.ContainsFile

Metodo DocStructInfoListContainsFile
Ovverride del metodo contains della lista. Non controlla la presenza dell'oggetto specifico ma considera uguali quegli oggetti che condividono la lista delle operazioni

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ContainsFile(
    DocStructInfo item
)
Public Function ContainsFile (
    item As DocStructInfo
) As Boolean
public:
bool ContainsFile(
    DocStructInfo^ item
)
member ContainsFile :
        item : DocStructInfo -> bool

Parametri

item DocStructInfo
Elemento da cercare in lista

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DocStructInfoList
Namespace DedNet.Core


Metodo DocStructInfoList.FindByDedDoc

Metodo DocStructInfoListFindByDedDoc
Restituisce l'elemento con DedDoc corrispondente oppure null.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfo FindByDedDoc(
    DedDoc doc
)
Public Function FindByDedDoc (
    doc As DedDoc
) As DocStructInfo
public:
DocStructInfo^ FindByDedDoc(
    DedDoc^ doc
)
member FindByDedDoc :
        doc : DedDoc -> DocStructInfo

Parametri

doc DedDoc
DedDoc da utilizzare per la ricerca.

Valore di ritorno

DocStructInfo
Vedi anche

Documentazione

Classe DocStructInfoList
Namespace DedNet.Core


Metodo DocStructInfoList.FindByExtension

Metodo DocStructInfoListFindByExtension
Restituisce l'elemento con l'estensione corrispondente oppure null.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfo FindByExtension(
    string ext
)
Public Function FindByExtension (
    ext As String
) As DocStructInfo
public:
DocStructInfo^ FindByExtension(
    String^ ext
)
member FindByExtension :
        ext : string -> DocStructInfo

Parametri

ext String

Valore di ritorno

DocStructInfo
Vedi anche

Documentazione

Classe DocStructInfoList
Namespace DedNet.Core


Metodo DocStructInfoList.FindByFileName

Metodo DocStructInfoListFindByFileName
Restituisce l'elemento con il nome file corrispondente oppure null.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfo FindByFileName(
    string fileName
)
Public Function FindByFileName (
    fileName As String
) As DocStructInfo
public:
DocStructInfo^ FindByFileName(
    String^ fileName
)
member FindByFileName :
        fileName : string -> DocStructInfo

Parametri

fileName String
Nome file da utilizzare per la ricerca.

Valore di ritorno

DocStructInfo
Vedi anche

Documentazione

Classe DocStructInfoList
Namespace DedNet.Core


Metodo DocStructInfoList.FindByGuid

Metodo DocStructInfoListFindByGuid
Restituisce l'elemento con Guid corrispondente oppure null.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfo FindByGuid(
    Guid guid
)
Public Function FindByGuid (
    guid As Guid
) As DocStructInfo
public:
DocStructInfo^ FindByGuid(
    Guid guid
)
member FindByGuid :
        guid : Guid -> DocStructInfo

Parametri

guid Guid
Guid da utilizzare per la ricerca.

Valore di ritorno

DocStructInfo
Vedi anche

Documentazione

Classe DocStructInfoList
Namespace DedNet.Core


Metodo DocStructInfoList.GetDocList

Metodo DocStructInfoListGetDocList
Restituisce la lista dei documenti presenti in tutti gli elementi. Se il DocStructInfo non ha il DedDoc viene saltato. Vengono esaminati solo gli elementi della lista e non i figli.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocList GetDocList()
Public Function GetDocList As DedDocList
public:
DedDocList^ GetDocList()
member GetDocList : unit -> DedDocList

Valore di ritorno

DedDocList
Vedi anche

Documentazione

Classe DocStructInfoList
Namespace DedNet.Core


Metodo DocStructInfoList.Reinit

Metodo DocStructInfoListReinit
Reinizializza tutta la lista facendo la reinizializzazione di tutti i DocStructInfo contenuti nella lista.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Reinit(
    bool throughAll
)
Public Sub Reinit (
    throughAll As Boolean
)
public:
void Reinit(
    bool throughAll
)
member Reinit :
        throughAll : bool -> unit

Parametri

throughAll Boolean
Indica se reinizializzare anche i figli.
Vedi anche

Documentazione

Classe DocStructInfoList
Namespace DedNet.Core


Metodo DocStructInfoList.SortByContext

Metodo DocStructInfoListSortByContext
Eseguo l'ordinamento in base al contesto del documento. Se la la tipologia è la stessa da la precedenza al modello.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SortByContext(
    DedNetApplication app,
    DedData sortingData
)
Public Sub SortByContext (
    app As DedNetApplication,
    sortingData As DedData
)
public:
void SortByContext(
    DedNetApplication^ app,
    DedData^ sortingData
)
member SortByContext :
        app : DedNetApplication *
        sortingData : DedData -> unit

Parametri

app DedNetApplication
Applicazione
sortingData DedData
Oggetto DedData per la ricerca dei contesti
Vedi anche

Documentazione

Classe DocStructInfoList
Namespace DedNet.Core


Metodo DocStructInfoList.SortByDependences

Metodo DocStructInfoListSortByDependences
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | SortByDependences | Ordina gli oggetti di questa lista in modo che gli elementi più in basso nell'albero vengano prima di quelli a livello superiore. Se desc = true ordina al contrario In questo modo saranno elaborati prima quelli che non hanno dipendenze e poi quelli che hanno delle dipendenze con la certezza che le dipendenze siano già state elaborate.
Metodo pubblico | SortByDependences(Boolean) | Ordina gli oggetti di questa lista in base al parametro passato. Se True prima figli poi padri, Se False prima padri e poi figli
Torna su
Vedi anche

Documentazione

Classe DocStructInfoList
Namespace DedNet.Core


Metodo DocStructInfoList.SortByDependences

Metodo DocStructInfoListSortByDependences
Ordina gli oggetti di questa lista in modo che gli elementi più in basso nell'albero vengano prima di quelli a livello superiore. Se desc = true ordina al contrario In questo modo saranno elaborati prima quelli che non hanno dipendenze e poi quelli che hanno delle dipendenze con la certezza che le dipendenze siano già state elaborate.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SortByDependences()
Public Sub SortByDependences
public:
void SortByDependences()
member SortByDependences : unit -> unit
Vedi anche

Documentazione

Classe DocStructInfoList
Overload di SortByDependences
Namespace DedNet.Core


Metodo DocStructInfoList.SortByDependences(Boolean)

Metodo DocStructInfoListSortByDependences(Boolean)
Ordina gli oggetti di questa lista in base al parametro passato. Se True prima figli poi padri, Se False prima padri e poi figli

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SortByDependences(
    bool asc
)
Public Sub SortByDependences (
    asc As Boolean
)
public:
void SortByDependences(
    bool asc
)
member SortByDependences :
        asc : bool -> unit

Parametri

asc Boolean
Vedi anche

Documentazione

Classe DocStructInfoList
Overload di SortByDependences
Namespace DedNet.Core


Classe DocStructInfoOperationListDictionary
Dizionario di oggetti DedDoc
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericDictionary String, DocStructFileInfos
DedNet.CoreDocStructInfoOperationListDictionary

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DocStructInfoOperationListDictionary : Dictionary<string, DocStructFileInfos>
Public Class DocStructInfoOperationListDictionary
    Inherits Dictionary(Of String, DocStructFileInfos)
public ref class DocStructInfoOperationListDictionary : public Dictionary<String^, DocStructFileInfos^>
type DocStructInfoOperationListDictionary =
    class
        inherit Dictionary<string, DocStructFileInfos>
    end

Il tipo DocStructInfoOperationListDictionary espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DocStructInfoOperationListDictionary |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AddAllElements | Aggiunge tutti gli elementi del dizionario sorgente
Metodo pubblico | AddElements | Aggiunge solo gli elementi necessari del dizionario sorgente
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DocStructInfoOperationListDictionary

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfoOperationListDictionary()
Public Sub New
public:
DocStructInfoOperationListDictionary()
new : unit -> DocStructInfoOperationListDictionary
Vedi anche

Documentazione

Classe DocStructInfoOperationListDictionary
Namespace DedNet.Core


Metodi di DocStructInfoOperationListDictionary

Il tipo DocStructInfoOperationListDictionary espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AddAllElements | Aggiunge tutti gli elementi del dizionario sorgente
Metodo pubblico | AddElements | Aggiunge solo gli elementi necessari del dizionario sorgente
Torna su
Vedi anche

Documentazione

Classe DocStructInfoOperationListDictionary
Namespace DedNet.Core


Metodo DocStructInfoOperationListDictionary.AddAllElements

Metodo DocStructInfoOperationListDictionaryAddAllElements
Aggiunge tutti gli elementi del dizionario sorgente

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddAllElements(
    DocStructInfoOperationListDictionary source
)
Public Sub AddAllElements (
    source As DocStructInfoOperationListDictionary
)
public:
void AddAllElements(
    DocStructInfoOperationListDictionary^ source
)
member AddAllElements :
        source : DocStructInfoOperationListDictionary -> unit

Parametri

source DocStructInfoOperationListDictionary
Vedi anche

Documentazione

Classe DocStructInfoOperationListDictionary
Namespace DedNet.Core


Metodo DocStructInfoOperationListDictionary.AddElements

Metodo DocStructInfoOperationListDictionaryAddElements
Aggiunge solo gli elementi necessari del dizionario sorgente

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddElements(
    DocStructInfoOperationListDictionary source
)
Public Sub AddElements (
    source As DocStructInfoOperationListDictionary
)
public:
void AddElements(
    DocStructInfoOperationListDictionary^ source
)
member AddElements :
        source : DocStructInfoOperationListDictionary -> unit

Parametri

source DocStructInfoOperationListDictionary
Vedi anche

Documentazione

Classe DocStructInfoOperationListDictionary
Namespace DedNet.Core


Classe DriveSettings
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDriveSettings

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DriveSettings
Public Class DriveSettings
public ref class DriveSettings
type DriveSettings = class end

Il tipo DriveSettings espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DriveSettings |
Torna su
Metodi
Nome | Descrizione
DisconnectNetworkDrive |
IsDriveMapped |
MapNetworkDrive |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore DriveSettings

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DriveSettings()
Public Sub New
public:
DriveSettings()
new : unit -> DriveSettings
Vedi anche

Documentazione

Classe DriveSettings
Namespace DedNet.Core


Metodi di DriveSettings

Il tipo DriveSettings espone i seguenti membri.

Metodi
Nome | Descrizione
DisconnectNetworkDrive |
IsDriveMapped |
MapNetworkDrive |
Torna su
Vedi anche

Documentazione

Classe DriveSettings
Namespace DedNet.Core


Metodo DriveSettings.DisconnectNetworkDrive

Metodo DriveSettingsDisconnectNetworkDrive

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static int DisconnectNetworkDrive(
    string sDriveLetter,
    bool bForceDisconnect
)
Public Shared Function DisconnectNetworkDrive (
    sDriveLetter As String,
    bForceDisconnect As Boolean
) As Integer
public:
static int DisconnectNetworkDrive(
    String^ sDriveLetter,
    bool bForceDisconnect
)
static member DisconnectNetworkDrive :
        sDriveLetter : string *
        bForceDisconnect : bool -> int

Parametri

sDriveLetter String
bForceDisconnect Boolean

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe DriveSettings
Namespace DedNet.Core


Metodo DriveSettings.IsDriveMapped

Metodo DriveSettingsIsDriveMapped

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool IsDriveMapped(
    string sDriveLetter
)
Public Shared Function IsDriveMapped (
    sDriveLetter As String
) As Boolean
public:
static bool IsDriveMapped(
    String^ sDriveLetter
)
static member IsDriveMapped :
        sDriveLetter : string -> bool

Parametri

sDriveLetter String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DriveSettings
Namespace DedNet.Core


Metodo DriveSettings.MapNetworkDrive

Metodo DriveSettingsMapNetworkDrive

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void MapNetworkDrive(
    string sDriveLetter,
    string sNetworkPath
)
Public Shared Sub MapNetworkDrive (
    sDriveLetter As String,
    sNetworkPath As String
)
public:
static void MapNetworkDrive(
    String^ sDriveLetter,
    String^ sNetworkPath
)
static member MapNetworkDrive :
        sDriveLetter : string *
        sNetworkPath : string -> unit

Parametri

sDriveLetter String
sNetworkPath String
Vedi anche

Documentazione

Classe DriveSettings
Namespace DedNet.Core


Classe ExtensionMethod
Classe dedicata ai metodo estesi.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreExtensionMethod

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static class ExtensionMethod
<ExtensionAttribute>
Public NotInheritable Class ExtensionMethod
[ExtensionAttribute]
public ref class ExtensionMethod abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type ExtensionMethod = class end

Il tipo ExtensionMethod espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo di estensione pubblico | Contains(ListString, String, StringComparison) | Verifica se nella lista è presente l'elemento specificato, considerdanso lo StringComparison indicato.
Metodo di estensione pubblico | Contains(String, String, StringComparison) | Verifica se nella stringa è presente la sotto-stringa specificata, considerdanso lo StringComparison indicato.
Metodo di estensione pubblico | FirstCharToUpper | Mette il primo carattere uppercase della stringa
Metodo di estensione pubblico | IndexOf | Ritorna l'indice dell'elemento nella lista, considerdanso lo StringComparison indicato.
Metodo di estensione pubblico | IsNullOrEmpty | Metodo che ritorna True se la stringa è null o vuota, False altrimenti.
Metodo di estensione pubblico | ReplaceFirst | Sostituiesce la prima occorrenza trovata del valore 'search' nel testo 'text' con il valore passato 'replace'
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Metodi di ExtensionMethod

Il tipo ExtensionMethod espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo di estensione pubblico | Contains(ListString, String, StringComparison) | Verifica se nella lista è presente l'elemento specificato, considerdanso lo StringComparison indicato.
Metodo di estensione pubblico | Contains(String, String, StringComparison) | Verifica se nella stringa è presente la sotto-stringa specificata, considerdanso lo StringComparison indicato.
Metodo di estensione pubblico | FirstCharToUpper | Mette il primo carattere uppercase della stringa
Metodo di estensione pubblico | IndexOf | Ritorna l'indice dell'elemento nella lista, considerdanso lo StringComparison indicato.
Metodo di estensione pubblico | IsNullOrEmpty | Metodo che ritorna True se la stringa è null o vuota, False altrimenti.
Metodo di estensione pubblico | ReplaceFirst | Sostituiesce la prima occorrenza trovata del valore 'search' nel testo 'text' con il valore passato 'replace'
Torna su
Vedi anche

Documentazione

Classe ExtensionMethod
Namespace DedNet.Core


Metodo ExtensionMethod.Contains

Metodo ExtensionMethodContains
Lista degli overload
 | Nome | Descrizione
Metodo di estensione pubblico | Contains(ListString, String, StringComparison) | Verifica se nella lista è presente l'elemento specificato, considerdanso lo StringComparison indicato.
Metodo di estensione pubblico | Contains(String, String, StringComparison) | Verifica se nella stringa è presente la sotto-stringa specificata, considerdanso lo StringComparison indicato.
Torna su
Vedi anche

Documentazione

Classe ExtensionMethod
Namespace DedNet.Core


Metodo ExtensionMethod.Contains(List<String>, String, StringComparison)

Metodo ExtensionMethodContains(ListString, String, StringComparison)
Verifica se nella lista è presente l'elemento specificato, considerdanso lo StringComparison indicato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool Contains(
    this List<string> lst,
    string valueToFind,
    StringComparison comparer
)
<ExtensionAttribute>
Public Shared Function Contains (
    lst As List(Of String),
    valueToFind As String,
    comparer As StringComparison
) As Boolean
public:
[ExtensionAttribute]
static bool Contains(
    List<String^>^ lst,
    String^ valueToFind,
    StringComparison comparer
)
[<ExtensionAttribute>]
static member Contains :
        lst : List<string> *
        valueToFind : string *
        comparer : StringComparison -> bool

Parametri

lst List String
Lista da esaminare.
valueToFind String
Valore da ricercare.
comparer StringComparison
Tipo di comparatore da utilizzare.

Valore di ritorno

Boolean
True: elemento presente; False: elemento non trovato.

Nota d'uso

In Visual Basic e C# puoi chiamare questo metodo come metodo di istanza su qualunque oggetto di tipo List String . Quando usi la sintassi del metodo di istanza, devi omettere il primo parametro. Per maggiori informazioni, vedi Metodi di estensione (Visual Basic) o Metodi di estensione (C# Programming Guide).
Vedi anche

Documentazione

Classe ExtensionMethod
Overload di Contains
Namespace DedNet.Core


Metodo ExtensionMethod.Contains(String, String, StringComparison)

Metodo ExtensionMethodContains(String, String, StringComparison)
Verifica se nella stringa è presente la sotto-stringa specificata, considerdanso lo StringComparison indicato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool Contains(
    this string str,
    string valueToFind,
    StringComparison comparer
)
<ExtensionAttribute>
Public Shared Function Contains (
    str As String,
    valueToFind As String,
    comparer As StringComparison
) As Boolean
public:
[ExtensionAttribute]
static bool Contains(
    String^ str,
    String^ valueToFind,
    StringComparison comparer
)
[<ExtensionAttribute>]
static member Contains :
        str : string *
        valueToFind : string *
        comparer : StringComparison -> bool

Parametri

str String
Stringa da controllare.
valueToFind String
Valore da ricercare.
comparer StringComparison
Tipo di comparatore da utilizzare.

Valore di ritorno

Boolean
True: sotto-stringa presente; False: sotto-stringa non trovata.

Nota d'uso

In Visual Basic e C# puoi chiamare questo metodo come metodo di istanza su qualunque oggetto di tipo String. Quando usi la sintassi del metodo di istanza, devi omettere il primo parametro. Per maggiori informazioni, vedi Metodi di estensione (Visual Basic) o Metodi di estensione (C# Programming Guide).
Vedi anche

Documentazione

Classe ExtensionMethod
Overload di Contains
Namespace DedNet.Core


Metodo ExtensionMethod.FirstCharToUpper

Metodo ExtensionMethodFirstCharToUpper
Mette il primo carattere uppercase della stringa

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string FirstCharToUpper(
    this string input
)
<ExtensionAttribute>
Public Shared Function FirstCharToUpper (
    input As String
) As String
public:
[ExtensionAttribute]
static String^ FirstCharToUpper(
    String^ input
)
[<ExtensionAttribute>]
static member FirstCharToUpper :
        input : string -> string

Parametri

input String

Valore di ritorno

String

Nota d'uso

In Visual Basic e C# puoi chiamare questo metodo come metodo di istanza su qualunque oggetto di tipo String. Quando usi la sintassi del metodo di istanza, devi omettere il primo parametro. Per maggiori informazioni, vedi Metodi di estensione (Visual Basic) o Metodi di estensione (C# Programming Guide).
Vedi anche

Documentazione

Classe ExtensionMethod
Namespace DedNet.Core


Metodo ExtensionMethod.IndexOf

Metodo ExtensionMethodIndexOf
Ritorna l'indice dell'elemento nella lista, considerdanso lo StringComparison indicato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static int IndexOf(
    this List<string> lst,
    string valueToFind,
    StringComparison comparer
)
<ExtensionAttribute>
Public Shared Function IndexOf (
    lst As List(Of String),
    valueToFind As String,
    comparer As StringComparison
) As Integer
public:
[ExtensionAttribute]
static int IndexOf(
    List<String^>^ lst,
    String^ valueToFind,
    StringComparison comparer
)
[<ExtensionAttribute>]
static member IndexOf :
        lst : List<string> *
        valueToFind : string *
        comparer : StringComparison -> int

Parametri

lst List String
Lista da esaminare.
valueToFind String
Valore da ricercare.
comparer StringComparison
Tipo di comparatore da utilizzare.

Valore di ritorno

Int32
Int: indice dell'elemento nella lista.

Nota d'uso

In Visual Basic e C# puoi chiamare questo metodo come metodo di istanza su qualunque oggetto di tipo List String . Quando usi la sintassi del metodo di istanza, devi omettere il primo parametro. Per maggiori informazioni, vedi Metodi di estensione (Visual Basic) o Metodi di estensione (C# Programming Guide).
Vedi anche

Documentazione

Classe ExtensionMethod
Namespace DedNet.Core


Metodo ExtensionMethod.IsNullOrEmpty

Metodo ExtensionMethodIsNullOrEmpty
Metodo che ritorna True se la stringa è null o vuota, False altrimenti.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool IsNullOrEmpty(
    this string str
)
<ExtensionAttribute>
Public Shared Function IsNullOrEmpty (
    str As String
) As Boolean
public:
[ExtensionAttribute]
static bool IsNullOrEmpty(
    String^ str
)
[<ExtensionAttribute>]
static member IsNullOrEmpty :
        str : string -> bool

Parametri

str String
Stringa da controllare.

Valore di ritorno

Boolean
Ritorna True se la stringa è null o vuota, False altrimenti

Nota d'uso

In Visual Basic e C# puoi chiamare questo metodo come metodo di istanza su qualunque oggetto di tipo String. Quando usi la sintassi del metodo di istanza, devi omettere il primo parametro. Per maggiori informazioni, vedi Metodi di estensione (Visual Basic) o Metodi di estensione (C# Programming Guide).
Vedi anche

Documentazione

Classe ExtensionMethod
Namespace DedNet.Core


Metodo ExtensionMethod.ReplaceFirst

Metodo ExtensionMethodReplaceFirst
Sostituiesce la prima occorrenza trovata del valore 'search' nel testo 'text' con il valore passato 'replace'

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string ReplaceFirst(
    this string text,
    string search,
    string replace
)
<ExtensionAttribute>
Public Shared Function ReplaceFirst (
    text As String,
    search As String,
    replace As String
) As String
public:
[ExtensionAttribute]
static String^ ReplaceFirst(
    String^ text,
    String^ search,
    String^ replace
)
[<ExtensionAttribute>]
static member ReplaceFirst :
        text : string *
        search : string *
        replace : string -> string

Parametri

text String
Testo da modficare
search String
Testo da cercare
replace String
Testo da usare come sostituzione

Valore di ritorno

String

Nota d'uso

In Visual Basic e C# puoi chiamare questo metodo come metodo di istanza su qualunque oggetto di tipo String. Quando usi la sintassi del metodo di istanza, devi omettere il primo parametro. Per maggiori informazioni, vedi Metodi di estensione (Visual Basic) o Metodi di estensione (C# Programming Guide).
Vedi anche

Documentazione

Classe ExtensionMethod
Namespace DedNet.Core


Classe ExtraData
Dati aggiuntivi delle liste utente.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreExtraData

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ExtraData
Public Class ExtraData
public ref class ExtraData
type ExtraData = class end

Il tipo ExtraData espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ExtraData | Costruttore unico
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | ExtraDataInfo | Oggetto che contiene le informazioni sul dato aggiuntivo
Proprietà pubblica | Name | Nome del dato aggiuntivo (preso dal ExtraDataInfo)
Proprietà pubblica | Parent | Lista di appartenenza
Proprietà pubblica | Type | Tipo del dato aggiuntivo (preso dal ExtraDataInfo)
Proprietà pubblica | Value | Valore del dato
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore ExtraData
Costruttore unico

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ExtraData(
    ExtraDataInfo dataInfo,
    Object value
)
Public Sub New (
    dataInfo As ExtraDataInfo,
    value As Object
)
public:
ExtraData(
    ExtraDataInfo^ dataInfo,
    Object^ value
)
new :
        dataInfo : ExtraDataInfo *
        value : Object -> ExtraData

Parametri

dataInfo ExtraDataInfo
Informazioni sul dato aggiuntivo
value Object
Valore del dato
Vedi anche

Documentazione

Classe ExtraData
Namespace DedNet.Core


Proprietà di ExtraData

Il tipo ExtraData espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | ExtraDataInfo | Oggetto che contiene le informazioni sul dato aggiuntivo
Proprietà pubblica | Name | Nome del dato aggiuntivo (preso dal ExtraDataInfo)
Proprietà pubblica | Parent | Lista di appartenenza
Proprietà pubblica | Type | Tipo del dato aggiuntivo (preso dal ExtraDataInfo)
Proprietà pubblica | Value | Valore del dato
Torna su
Vedi anche

Documentazione

Classe ExtraData
Namespace DedNet.Core


Proprietà ExtraData.ExtraDataInfo

Proprietà ExtraDataExtraDataInfo
Oggetto che contiene le informazioni sul dato aggiuntivo

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ExtraDataInfo ExtraDataInfo { get; }
Public ReadOnly Property ExtraDataInfo As ExtraDataInfo
    Get
public:
property ExtraDataInfo^ ExtraDataInfo {
    ExtraDataInfo^ get ();
}
member ExtraDataInfo : ExtraDataInfo with get

Valore della proprietà

ExtraDataInfo
Vedi anche

Documentazione

Classe ExtraData
Namespace DedNet.Core


Proprietà ExtraData.Name

Proprietà ExtraDataName
Nome del dato aggiuntivo (preso dal ExtraDataInfo)

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe ExtraData
Namespace DedNet.Core


Proprietà ExtraData.Parent

Proprietà ExtraDataParent
Lista di appartenenza

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ExtraDataList Parent { set; }
Public WriteOnly Property Parent As ExtraDataList
    Set
public:
property ExtraDataList^ Parent {
    void set (ExtraDataList^ value);
}
member Parent : ExtraDataList with set

Valore della proprietà

ExtraDataList
Vedi anche

Documentazione

Classe ExtraData
Namespace DedNet.Core


Proprietà ExtraData.Type

Proprietà ExtraDataType
Tipo del dato aggiuntivo (preso dal ExtraDataInfo)

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedListManagerTipoDati Type { get; }
Public ReadOnly Property Type As DedListManagerTipoDati
    Get
public:
property DedListManagerTipoDati Type {
    DedListManagerTipoDati get ();
}
member Type : DedListManagerTipoDati with get

Valore della proprietà

DedListManagerTipoDati
Vedi anche

Documentazione

Classe ExtraData
Namespace DedNet.Core


Proprietà ExtraData.Value

Proprietà ExtraDataValue
Valore del dato

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object Value { get; set; }
Public Property Value As Object
    Get
    Set
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}
member Value : Object with get, set

Valore della proprietà

Object
Vedi anche

Documentazione

Classe ExtraData
Namespace DedNet.Core


Classe ExtraDataInfo
Oggetto contente le informazioni sui dati aggiuntivi
Gerarchia di ereditarietà
SystemObject
DedNet.CoreExtraDataInfo

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ExtraDataInfo
Public Class ExtraDataInfo
public ref class ExtraDataInfo
type ExtraDataInfo = class end

Il tipo ExtraDataInfo espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ExtraDataInfo | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Name | Nome dell'elemento
Proprietà pubblica | Parent | Lista di appartenenza
Proprietà pubblica | Type | Tipo di dato (int,string,etc...)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore ExtraDataInfo
Costruttore

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ExtraDataInfo(
    string name,
    DedListManagerTipoDati type
)
Public Sub New (
    name As String,
    type As DedListManagerTipoDati
)
public:
ExtraDataInfo(
    String^ name,
    DedListManagerTipoDati type
)
new :
        name : string *
        type : DedListManagerTipoDati -> ExtraDataInfo

Parametri

name String
Nome dell'elemento
type DedListManagerTipoDati
Tipo di dato
Vedi anche

Documentazione

Classe ExtraDataInfo
Namespace DedNet.Core


Proprietà di ExtraDataInfo

Il tipo ExtraDataInfo espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Name | Nome dell'elemento
Proprietà pubblica | Parent | Lista di appartenenza
Proprietà pubblica | Type | Tipo di dato (int,string,etc...)
Torna su
Vedi anche

Documentazione

Classe ExtraDataInfo
Namespace DedNet.Core


Proprietà ExtraDataInfo.Name

Proprietà ExtraDataInfoName
Nome dell'elemento

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe ExtraDataInfo
Namespace DedNet.Core


Proprietà ExtraDataInfo.Parent

Proprietà ExtraDataInfoParent
Lista di appartenenza

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ExtraDataInfoList Parent { set; }
Public WriteOnly Property Parent As ExtraDataInfoList
    Set
public:
property ExtraDataInfoList^ Parent {
    void set (ExtraDataInfoList^ value);
}
member Parent : ExtraDataInfoList with set

Valore della proprietà

ExtraDataInfoList
Vedi anche

Documentazione

Classe ExtraDataInfo
Namespace DedNet.Core


Proprietà ExtraDataInfo.Type

Proprietà ExtraDataInfoType
Tipo di dato (int,string,etc...)

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedListManagerTipoDati Type { get; set; }
Public Property Type As DedListManagerTipoDati
    Get
    Set
public:
property DedListManagerTipoDati Type {
    DedListManagerTipoDati get ();
    void set (DedListManagerTipoDati value);
}
member Type : DedListManagerTipoDati with get, set

Valore della proprietà

DedListManagerTipoDati
Vedi anche

Documentazione

Classe ExtraDataInfo
Namespace DedNet.Core


Classe ExtraDataInfoList
Lista con le informazioni sulle ingformazioni extra.
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList ExtraDataInfo
DedNet.CoreExtraDataInfoList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ExtraDataInfoList : List<ExtraDataInfo>
Public Class ExtraDataInfoList
    Inherits List(Of ExtraDataInfo)
public ref class ExtraDataInfoList : public List<ExtraDataInfo^>
type ExtraDataInfoList =
    class
        inherit List<ExtraDataInfo>
    end

Il tipo ExtraDataInfoList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ExtraDataInfoList | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Parent | Lista di appartenenza
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Add | Aggiunge un elemento alla lista e notifica la lista di appartenenza
Metodo pubblico | FindByName | Ritorna l'oggetto con il nome specificato
Metodo pubblico | GetStringExtraDataInfo | Restituisce la stringa dai valori presenti nella lista.
Metodo pubblico | ParseExtraDataInfo | Converte la stringa con i dati in una lista di oggetti.
Metodo pubblico | Remove | Rimuove un elemento e notifica la lista di appartenenza
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore ExtraDataInfoList
Costruttore

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ExtraDataInfoList(
    DedList parent
)
Public Sub New (
    parent As DedList
)
public:
ExtraDataInfoList(
    DedList^ parent
)
new :
        parent : DedList -> ExtraDataInfoList

Parametri

parent DedList
Vedi anche

Documentazione

Classe ExtraDataInfoList
Namespace DedNet.Core


Proprietà di ExtraDataInfoList

Il tipo ExtraDataInfoList espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Parent | Lista di appartenenza
Torna su
Vedi anche

Documentazione

Classe ExtraDataInfoList
Namespace DedNet.Core


Proprietà ExtraDataInfoList.Parent

Proprietà ExtraDataInfoListParent
Lista di appartenenza

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedList Parent { get; set; }
Public Property Parent As DedList
    Get
    Set
public:
property DedList^ Parent {
    DedList^ get ();
    void set (DedList^ value);
}
member Parent : DedList with get, set

Valore della proprietà

DedList
Vedi anche

Documentazione

Classe ExtraDataInfoList
Namespace DedNet.Core


Metodi di ExtraDataInfoList

Il tipo ExtraDataInfoList espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Add | Aggiunge un elemento alla lista e notifica la lista di appartenenza
Metodo pubblico | FindByName | Ritorna l'oggetto con il nome specificato
Metodo pubblico | GetStringExtraDataInfo | Restituisce la stringa dai valori presenti nella lista.
Metodo pubblico | ParseExtraDataInfo | Converte la stringa con i dati in una lista di oggetti.
Metodo pubblico | Remove | Rimuove un elemento e notifica la lista di appartenenza
Torna su
Vedi anche

Documentazione

Classe ExtraDataInfoList
Namespace DedNet.Core


Metodo ExtraDataInfoList.Add

Metodo ExtraDataInfoListAdd
Aggiunge un elemento alla lista e notifica la lista di appartenenza

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Add(
    ExtraDataInfo item
)
Public Sub Add (
    item As ExtraDataInfo
)
public:
void Add(
    ExtraDataInfo^ item
)
member Add :
        item : ExtraDataInfo -> unit

Parametri

item ExtraDataInfo
Elemento da aggiungere
Vedi anche

Documentazione

Classe ExtraDataInfoList
Namespace DedNet.Core


Metodo ExtraDataInfoList.FindByName

Metodo ExtraDataInfoListFindByName
Ritorna l'oggetto con il nome specificato

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ExtraDataInfo FindByName(
    string name
)
Public Function FindByName (
    name As String
) As ExtraDataInfo
public:
ExtraDataInfo^ FindByName(
    String^ name
)
member FindByName :
        name : string -> ExtraDataInfo

Parametri

name String
Nome dell'elemento da cercare

Valore di ritorno

ExtraDataInfo
Vedi anche

Documentazione

Classe ExtraDataInfoList
Namespace DedNet.Core


Metodo ExtraDataInfoList.GetStringExtraDataInfo

Metodo ExtraDataInfoListGetStringExtraDataInfo
Restituisce la stringa dai valori presenti nella lista.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string GetStringExtraDataInfo()
Public Function GetStringExtraDataInfo As String
public:
String^ GetStringExtraDataInfo()
member GetStringExtraDataInfo : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe ExtraDataInfoList
Namespace DedNet.Core


Metodo ExtraDataInfoList.ParseExtraDataInfo

Metodo ExtraDataInfoListParseExtraDataInfo
Converte la stringa con i dati in una lista di oggetti.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ParseExtraDataInfo(
    string extraDataInfoStr
)
Public Sub ParseExtraDataInfo (
    extraDataInfoStr As String
)
public:
void ParseExtraDataInfo(
    String^ extraDataInfoStr
)
member ParseExtraDataInfo :
        extraDataInfoStr : string -> unit

Parametri

extraDataInfoStr String
Stringa da parsare
Vedi anche

Documentazione

Classe ExtraDataInfoList
Namespace DedNet.Core


Metodo ExtraDataInfoList.Remove

Metodo ExtraDataInfoListRemove
Rimuove un elemento e notifica la lista di appartenenza

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Remove(
    ExtraDataInfo item
)
Public Sub Remove (
    item As ExtraDataInfo
)
public:
void Remove(
    ExtraDataInfo^ item
)
member Remove :
        item : ExtraDataInfo -> unit

Parametri

item ExtraDataInfo
Elemento da rimuovere
Vedi anche

Documentazione

Classe ExtraDataInfoList
Namespace DedNet.Core


Classe ExtraDataList
Lista contenente tutte niformazioni extra di una lista utente
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList ExtraData
DedNet.CoreExtraDataList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ExtraDataList : List<ExtraData>
Public Class ExtraDataList
    Inherits List(Of ExtraData)
public ref class ExtraDataList : public List<ExtraData^>
type ExtraDataList =
    class
        inherit List<ExtraData>
    end

Il tipo ExtraDataList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ExtraDataList | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Parent | Lista di appartenenza
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Add | Aggiunge un elemento alla lista e notifica la lista di appartenenza
Metodo pubblico | FindByName | Restituisce l'elemento con il nome specificato.
Metodo pubblico | GetStringExtraData | Restituisce la stringa dai valori presenti nella lista.
Metodo pubblico | ParseExtraData | Converte la stringa con i dati in una lista di oggetti.
Metodo pubblico | Remove | Rimuove un elemento e notifica la lista di appartenenza
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore ExtraDataList
Costruttore

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ExtraDataList(
    DedUserList parent
)
Public Sub New (
    parent As DedUserList
)
public:
ExtraDataList(
    DedUserList^ parent
)
new :
        parent : DedUserList -> ExtraDataList

Parametri

parent DedUserList
Lista di appartenenza
Vedi anche

Documentazione

Classe ExtraDataList
Namespace DedNet.Core


Proprietà di ExtraDataList

Il tipo ExtraDataList espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Parent | Lista di appartenenza
Torna su
Vedi anche

Documentazione

Classe ExtraDataList
Namespace DedNet.Core


Proprietà ExtraDataList.Parent

Proprietà ExtraDataListParent
Lista di appartenenza

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedUserList Parent { get; set; }
Public Property Parent As DedUserList
    Get
    Set
public:
property DedUserList^ Parent {
    DedUserList^ get ();
    void set (DedUserList^ value);
}
member Parent : DedUserList with get, set

Valore della proprietà

DedUserList
Vedi anche

Documentazione

Classe ExtraDataList
Namespace DedNet.Core


Metodi di ExtraDataList

Il tipo ExtraDataList espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Add | Aggiunge un elemento alla lista e notifica la lista di appartenenza
Metodo pubblico | FindByName | Restituisce l'elemento con il nome specificato.
Metodo pubblico | GetStringExtraData | Restituisce la stringa dai valori presenti nella lista.
Metodo pubblico | ParseExtraData | Converte la stringa con i dati in una lista di oggetti.
Metodo pubblico | Remove | Rimuove un elemento e notifica la lista di appartenenza
Torna su
Vedi anche

Documentazione

Classe ExtraDataList
Namespace DedNet.Core


Metodo ExtraDataList.Add

Metodo ExtraDataListAdd
Aggiunge un elemento alla lista e notifica la lista di appartenenza

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Add(
    ExtraData item
)
Public Sub Add (
    item As ExtraData
)
public:
void Add(
    ExtraData^ item
)
member Add :
        item : ExtraData -> unit

Parametri

item ExtraData
Elemento da aggiungere
Vedi anche

Documentazione

Classe ExtraDataList
Namespace DedNet.Core


Metodo ExtraDataList.FindByName

Metodo ExtraDataListFindByName
Restituisce l'elemento con il nome specificato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ExtraData FindByName(
    string name
)
Public Function FindByName (
    name As String
) As ExtraData
public:
ExtraData^ FindByName(
    String^ name
)
member FindByName :
        name : string -> ExtraData

Parametri

name String
Nome da ricercare

Valore di ritorno

ExtraData
Vedi anche

Documentazione

Classe ExtraDataList
Namespace DedNet.Core


Metodo ExtraDataList.GetStringExtraData

Metodo ExtraDataListGetStringExtraData
Restituisce la stringa dai valori presenti nella lista.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string GetStringExtraData()
Public Function GetStringExtraData As String
public:
String^ GetStringExtraData()
member GetStringExtraData : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe ExtraDataList
Namespace DedNet.Core


Metodo ExtraDataList.ParseExtraData

Metodo ExtraDataListParseExtraData
Converte la stringa con i dati in una lista di oggetti.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ParseExtraData(
    string extraDataStr
)
Public Sub ParseExtraData (
    extraDataStr As String
)
public:
void ParseExtraData(
    String^ extraDataStr
)
member ParseExtraData :
        extraDataStr : string -> unit

Parametri

extraDataStr String
Stringa da parsare
Vedi anche

Documentazione

Classe ExtraDataList
Namespace DedNet.Core


Metodo ExtraDataList.Remove

Metodo ExtraDataListRemove
Rimuove un elemento e notifica la lista di appartenenza

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Remove(
    ExtraData item
)
Public Sub Remove (
    item As ExtraData
)
public:
void Remove(
    ExtraData^ item
)
member Remove :
        item : ExtraData -> unit

Parametri

item ExtraData
Elemento da rimuovere
Vedi anche

Documentazione

Classe ExtraDataList
Namespace DedNet.Core


Classe FileInfoSerializable
Gerarchia di ereditarietà
SystemObject
DedNet.CoreFileInfoSerializable

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class FileInfoSerializable
<SerializableAttribute>
Public Class FileInfoSerializable
[SerializableAttribute]
public ref class FileInfoSerializable
[<SerializableAttribute>]
type FileInfoSerializable = class end

Il tipo FileInfoSerializable espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | FileInfoSerializable |
Metodo pubblico | FileInfoSerializable(FileInfo) |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Attributes |
Proprietà pubblica | CreationTime |
Proprietà pubblica | Exists |
Proprietà pubblica | Extension |
Proprietà pubblica | IsReadOnly |
Proprietà pubblica | LastWriteTime |
Proprietà pubblica | LastWriteTimeUtc |
Proprietà pubblica | Length |
Proprietà pubblica | Name |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore FileInfoSerializable
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | FileInfoSerializable |
Metodo pubblico | FileInfoSerializable(FileInfo) |
Torna su
Vedi anche

Documentazione

Classe FileInfoSerializable
Namespace DedNet.Core


Costruttore FileInfoSerializable

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public FileInfoSerializable()
Public Sub New
public:
FileInfoSerializable()
new : unit -> FileInfoSerializable
Vedi anche

Documentazione

Classe FileInfoSerializable
Overload di FileInfoSerializable
Namespace DedNet.Core


Costruttore FileInfoSerializable(FileInfo)

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public FileInfoSerializable(
    FileInfo fileinfo
)
Public Sub New (
    fileinfo As FileInfo
)
public:
FileInfoSerializable(
    FileInfo^ fileinfo
)
new :
        fileinfo : FileInfo -> FileInfoSerializable

Parametri

fileinfo FileInfo
Vedi anche

Documentazione

Classe FileInfoSerializable
Overload di FileInfoSerializable
Namespace DedNet.Core


Proprietà di FileInfoSerializable

Il tipo FileInfoSerializable espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Attributes |
Proprietà pubblica | CreationTime |
Proprietà pubblica | Exists |
Proprietà pubblica | Extension |
Proprietà pubblica | IsReadOnly |
Proprietà pubblica | LastWriteTime |
Proprietà pubblica | LastWriteTimeUtc |
Proprietà pubblica | Length |
Proprietà pubblica | Name |
Torna su
Vedi anche

Documentazione

Classe FileInfoSerializable
Namespace DedNet.Core


Proprietà FileInfoSerializable.Attributes

Proprietà FileInfoSerializableAttributes

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public FileAttributes Attributes { get; set; }
Public Property Attributes As FileAttributes
    Get
    Set
public:
property FileAttributes Attributes {
    FileAttributes get ();
    void set (FileAttributes value);
}
member Attributes : FileAttributes with get, set

Valore della proprietà

FileAttributes
Vedi anche

Documentazione

Classe FileInfoSerializable
Namespace DedNet.Core


Proprietà FileInfoSerializable.CreationTime

Proprietà FileInfoSerializableCreationTime

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DateTime CreationTime { get; set; }
Public Property CreationTime As DateTime
    Get
    Set
public:
property DateTime CreationTime {
    DateTime get ();
    void set (DateTime value);
}
member CreationTime : DateTime with get, set

Valore della proprietà

DateTime
Vedi anche

Documentazione

Classe FileInfoSerializable
Namespace DedNet.Core


Proprietà FileInfoSerializable.Exists

Proprietà FileInfoSerializableExists

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Exists { get; set; }
Public Property Exists As Boolean
    Get
    Set
public:
property bool Exists {
    bool get ();
    void set (bool value);
}
member Exists : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe FileInfoSerializable
Namespace DedNet.Core


Proprietà FileInfoSerializable.Extension

Proprietà FileInfoSerializableExtension

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Extension { get; set; }
Public Property Extension As String
    Get
    Set
public:
property String^ Extension {
    String^ get ();
    void set (String^ value);
}
member Extension : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe FileInfoSerializable
Namespace DedNet.Core


Proprietà FileInfoSerializable.IsReadOnly

Proprietà FileInfoSerializableIsReadOnly

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsReadOnly { get; set; }
Public Property IsReadOnly As Boolean
    Get
    Set
public:
property bool IsReadOnly {
    bool get ();
    void set (bool value);
}
member IsReadOnly : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe FileInfoSerializable
Namespace DedNet.Core


Proprietà FileInfoSerializable.LastWriteTime

Proprietà FileInfoSerializableLastWriteTime

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DateTime LastWriteTime { get; set; }
Public Property LastWriteTime As DateTime
    Get
    Set
public:
property DateTime LastWriteTime {
    DateTime get ();
    void set (DateTime value);
}
member LastWriteTime : DateTime with get, set

Valore della proprietà

DateTime
Vedi anche

Documentazione

Classe FileInfoSerializable
Namespace DedNet.Core


Proprietà FileInfoSerializable.LastWriteTimeUtc

Proprietà FileInfoSerializableLastWriteTimeUtc

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DateTime LastWriteTimeUtc { get; set; }
Public Property LastWriteTimeUtc As DateTime
    Get
    Set
public:
property DateTime LastWriteTimeUtc {
    DateTime get ();
    void set (DateTime value);
}
member LastWriteTimeUtc : DateTime with get, set

Valore della proprietà

DateTime
Vedi anche

Documentazione

Classe FileInfoSerializable
Namespace DedNet.Core


Proprietà FileInfoSerializable.Length

Proprietà FileInfoSerializableLength

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public long Length { get; set; }
Public Property Length As Long
    Get
    Set
public:
property long long Length {
    long long get ();
    void set (long long value);
}
member Length : int64 with get, set

Valore della proprietà

Int64
Vedi anche

Documentazione

Classe FileInfoSerializable
Namespace DedNet.Core


Proprietà FileInfoSerializable.Name

Proprietà FileInfoSerializableName

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe FileInfoSerializable
Namespace DedNet.Core


Interfaccia IDedCommData

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public interface IDedCommData : IDedTypeEditable,
    IDedEditable
Public Interface IDedCommData
    Inherits IDedTypeEditable, IDedEditable
public interface class IDedCommData : IDedTypeEditable,
    IDedEditable
type IDedCommData =
    interface
        interface IDedTypeEditable
        interface IDedEditable
    end

Il tipo IDedCommData espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | DedCommType | Restituisce la famiglia nella quale è stata archiviata questa anagrafica. Può restituire null se non appartiene ad alcuna famiglia.
Proprietà pubblica | DedTypeBase | Restituisce la famiglia nella quale è stata archiviata questo oggetto. Può restituire null se non appartiene ad alcuna famiglia. (Ereditato da IDedTypeEditable)
Proprietà pubblica | IsValid | Restituisce se i valori presenti validano gli attributi della famiglia di appartenenza. (Ereditato da IDedTypeEditable)
Proprietà pubblica | Root | REstiruisce la Root di appartenneza di questo oggetto (Ereditato da IDedTypeEditable)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | GetValue(DedDataStandardDataFields) | Restituisce il contenuto di uno dei campi standard oppure null se non è presente. (Ereditato da IDedTypeEditable)
Metodo pubblico | GetValue(String) | Restituisce il contenuto di un campo personalizzato oppure null se non esiste. (Ereditato da IDedEditable)
Metodo pubblico | SetValue(DedDataStandardDataFields, Object) | Imposta un campo standard con un nuovo valore. (Ereditato da IDedTypeEditable)
Metodo pubblico | SetValue(String, Object) | Imposta un campo personalizzato con un nuovo valore. (Ereditato da IDedEditable)
Metodo pubblico | Validate | Valida i dati anagrafici (Ereditato da IDedTypeEditable)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di IDedCommData

Il tipo IDedCommData espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | DedCommType | Restituisce la famiglia nella quale è stata archiviata questa anagrafica. Può restituire null se non appartiene ad alcuna famiglia.
Proprietà pubblica | DedTypeBase | Restituisce la famiglia nella quale è stata archiviata questo oggetto. Può restituire null se non appartiene ad alcuna famiglia. (Ereditato da IDedTypeEditable)
Proprietà pubblica | IsValid | Restituisce se i valori presenti validano gli attributi della famiglia di appartenenza. (Ereditato da IDedTypeEditable)
Proprietà pubblica | Root | REstiruisce la Root di appartenneza di questo oggetto (Ereditato da IDedTypeEditable)
Torna su
Vedi anche

Documentazione

Interfaccia IDedCommData
Namespace DedNet.Core


Proprietà IDedCommData.DedCommType

Proprietà IDedCommDataDedCommType
Restituisce la famiglia nella quale è stata archiviata questa anagrafica. Può restituire null se non appartiene ad alcuna famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
DedCommType DedCommType { get; }
ReadOnly Property DedCommType As DedCommType
    Get
property DedCommType^ DedCommType {
    DedCommType^ get ();
}
abstract DedCommType : DedCommType with get

Valore della proprietà

DedCommType
Vedi anche

Documentazione

Interfaccia IDedCommData
Namespace DedNet.Core


Metodi di IDedCommData

Il tipo IDedCommData espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | GetValue(DedDataStandardDataFields) | Restituisce il contenuto di uno dei campi standard oppure null se non è presente. (Ereditato da IDedTypeEditable)
Metodo pubblico | GetValue(String) | Restituisce il contenuto di un campo personalizzato oppure null se non esiste. (Ereditato da IDedEditable)
Metodo pubblico | SetValue(DedDataStandardDataFields, Object) | Imposta un campo standard con un nuovo valore. (Ereditato da IDedTypeEditable)
Metodo pubblico | SetValue(String, Object) | Imposta un campo personalizzato con un nuovo valore. (Ereditato da IDedEditable)
Metodo pubblico | Validate | Valida i dati anagrafici (Ereditato da IDedTypeEditable)
Torna su
Vedi anche

Documentazione

Interfaccia IDedCommData
Namespace DedNet.Core


Interfaccia IDedData
Definisce i membri di accesso all'oggetto singolo o multiplo di anagrafica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public interface IDedData : IDedTypeEditable,
    IDedEditable
Public Interface IDedData
    Inherits IDedTypeEditable, IDedEditable
public interface class IDedData : IDedTypeEditable,
    IDedEditable
type IDedData =
    interface
        interface IDedTypeEditable
        interface IDedEditable
    end

Il tipo IDedData espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Count | Restituisce il numero di elementi interessati ovvero il numero di anagrafiche sottese all'oggetto che implementa l'interfaccia.
Proprietà pubblica | DedType | Restituisce la famiglia nella quale è stata archiviata questa anagrafica. Può restituire null se non appartiene ad alcuna famiglia.
Proprietà pubblica | DedTypeBase | Restituisce la famiglia nella quale è stata archiviata questo oggetto. Può restituire null se non appartiene ad alcuna famiglia. (Ereditato da IDedTypeEditable)
Proprietà pubblica | Dirty | Restituisce se uno o più campi siano stati modificati dopo la creazione dell'oggetto.
Proprietà pubblica | IsLocked | Restituisce se il record sia bloccato (dall'utente corrente o da un altro). Non legge dal Database, controlla solo se è compilato il campo DEDLOCK. Restituisce true se anche solo una anagrafica risulta bloccata.
Proprietà pubblica | IsValid | Restituisce se i valori presenti validano gli attributi della famiglia di appartenenza. (Ereditato da IDedTypeEditable)
Proprietà pubblica | Root | REstiruisce la Root di appartenneza di questo oggetto (Ereditato da IDedTypeEditable)
Proprietà pubblica | UpdateRowVer | Indica se si necessita di aggiornare il ROWVER in fase di aggiornamento anagrafica. Nel caso vengano modificati solamente attributi solo DB non dovrebbe essere modificato il ROWVER.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | GetValue(DedDataStandardDataFields) | Restituisce il contenuto di uno dei campi standard oppure null se non è presente. (Ereditato da IDedTypeEditable)
Metodo pubblico | GetValue(String) | Restituisce il contenuto di un campo personalizzato oppure null se non esiste. (Ereditato da IDedEditable)
Metodo pubblico | Lock | Esegue il blocco di tutte le anagrafiche impostando il campo DEDLOCK con il nome dell'utente corrente. Utilizza il campo DEDROWVER attuale per effettuare il blocco in modo da non riuscire in caso di anagrafica già modificata. Questo metodo non rende dirty le anagrafiche ma bisogna poi sbloccarle attraverso UnLock() oppure con Update(). Se avviene un errore quelle precedentemente bloccate vengono sbloccate.
Metodo pubblico | SetValue(DedDataStandardDataFields, Object) | Imposta un campo standard con un nuovo valore. (Ereditato da IDedTypeEditable)
Metodo pubblico | SetValue(String, Object) | Imposta un campo personalizzato con un nuovo valore. (Ereditato da IDedEditable)
Metodo pubblico | UnLock | Sblocca tutte le anagrafiche solo se queste sono bloccate. Opzionalmente, se queste sono dirty, le aggiorna. Questo metodo la sblocca reimpostando il DEDROWVER alla versione precedente il bloccaggio ed effettua un Refresh() per riallineare i valori dell'anagrafica con il Database se l'anagrafica era Dirty.
Metodo pubblico | Validate | Valida i dati anagrafici (Ereditato da IDedTypeEditable)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di IDedData

Il tipo IDedData espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Count | Restituisce il numero di elementi interessati ovvero il numero di anagrafiche sottese all'oggetto che implementa l'interfaccia.
Proprietà pubblica | DedType | Restituisce la famiglia nella quale è stata archiviata questa anagrafica. Può restituire null se non appartiene ad alcuna famiglia.
Proprietà pubblica | DedTypeBase | Restituisce la famiglia nella quale è stata archiviata questo oggetto. Può restituire null se non appartiene ad alcuna famiglia. (Ereditato da IDedTypeEditable)
Proprietà pubblica | Dirty | Restituisce se uno o più campi siano stati modificati dopo la creazione dell'oggetto.
Proprietà pubblica | IsLocked | Restituisce se il record sia bloccato (dall'utente corrente o da un altro). Non legge dal Database, controlla solo se è compilato il campo DEDLOCK. Restituisce true se anche solo una anagrafica risulta bloccata.
Proprietà pubblica | IsValid | Restituisce se i valori presenti validano gli attributi della famiglia di appartenenza. (Ereditato da IDedTypeEditable)
Proprietà pubblica | Root | REstiruisce la Root di appartenneza di questo oggetto (Ereditato da IDedTypeEditable)
Proprietà pubblica | UpdateRowVer | Indica se si necessita di aggiornare il ROWVER in fase di aggiornamento anagrafica. Nel caso vengano modificati solamente attributi solo DB non dovrebbe essere modificato il ROWVER.
Torna su
Vedi anche

Documentazione

Interfaccia IDedData
Namespace DedNet.Core


Proprietà IDedData.Count

Proprietà IDedDataCount
Restituisce il numero di elementi interessati ovvero il numero di anagrafiche sottese all'oggetto che implementa l'interfaccia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get
property int Count {
    int get ();
}
abstract Count : int with get

Valore della proprietà

Int32
Vedi anche

Documentazione

Interfaccia IDedData
Namespace DedNet.Core


Proprietà IDedData.DedType

Proprietà IDedDataDedType
Restituisce la famiglia nella quale è stata archiviata questa anagrafica. Può restituire null se non appartiene ad alcuna famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
DedType DedType { get; }
ReadOnly Property DedType As DedType
    Get
property DedType^ DedType {
    DedType^ get ();
}
abstract DedType : DedType with get

Valore della proprietà

DedType
Vedi anche

Documentazione

Interfaccia IDedData
Namespace DedNet.Core


Proprietà IDedData.Dirty

Proprietà IDedDataDirty
Restituisce se uno o più campi siano stati modificati dopo la creazione dell'oggetto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
bool Dirty { get; }
ReadOnly Property Dirty As Boolean
    Get
property bool Dirty {
    bool get ();
}
abstract Dirty : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Interfaccia IDedData
Namespace DedNet.Core


Proprietà IDedData.IsLocked

Proprietà IDedDataIsLocked
Restituisce se il record sia bloccato (dall'utente corrente o da un altro). Non legge dal Database, controlla solo se è compilato il campo DEDLOCK. Restituisce true se anche solo una anagrafica risulta bloccata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
bool IsLocked { get; }
ReadOnly Property IsLocked As Boolean
    Get
property bool IsLocked {
    bool get ();
}
abstract IsLocked : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Interfaccia IDedData
Namespace DedNet.Core


Proprietà IDedData.UpdateRowVer

Proprietà IDedDataUpdateRowVer
Indica se si necessita di aggiornare il ROWVER in fase di aggiornamento anagrafica. Nel caso vengano modificati solamente attributi solo DB non dovrebbe essere modificato il ROWVER.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
bool UpdateRowVer { get; set; }
Property UpdateRowVer As Boolean
    Get
    Set
property bool UpdateRowVer {
    bool get ();
    void set (bool value);
}
abstract UpdateRowVer : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Interfaccia IDedData
Namespace DedNet.Core


Metodi di IDedData

Il tipo IDedData espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | GetValue(DedDataStandardDataFields) | Restituisce il contenuto di uno dei campi standard oppure null se non è presente. (Ereditato da IDedTypeEditable)
Metodo pubblico | GetValue(String) | Restituisce il contenuto di un campo personalizzato oppure null se non esiste. (Ereditato da IDedEditable)
Metodo pubblico | Lock | Esegue il blocco di tutte le anagrafiche impostando il campo DEDLOCK con il nome dell'utente corrente. Utilizza il campo DEDROWVER attuale per effettuare il blocco in modo da non riuscire in caso di anagrafica già modificata. Questo metodo non rende dirty le anagrafiche ma bisogna poi sbloccarle attraverso UnLock() oppure con Update(). Se avviene un errore quelle precedentemente bloccate vengono sbloccate.
Metodo pubblico | SetValue(DedDataStandardDataFields, Object) | Imposta un campo standard con un nuovo valore. (Ereditato da IDedTypeEditable)
Metodo pubblico | SetValue(String, Object) | Imposta un campo personalizzato con un nuovo valore. (Ereditato da IDedEditable)
Metodo pubblico | UnLock | Sblocca tutte le anagrafiche solo se queste sono bloccate. Opzionalmente, se queste sono dirty, le aggiorna. Questo metodo la sblocca reimpostando il DEDROWVER alla versione precedente il bloccaggio ed effettua un Refresh() per riallineare i valori dell'anagrafica con il Database se l'anagrafica era Dirty.
Metodo pubblico | Validate | Valida i dati anagrafici (Ereditato da IDedTypeEditable)
Torna su
Vedi anche

Documentazione

Interfaccia IDedData
Namespace DedNet.Core


Metodo IDedData.Lock

Metodo IDedDataLock
Esegue il blocco di tutte le anagrafiche impostando il campo DEDLOCK con il nome dell'utente corrente. Utilizza il campo DEDROWVER attuale per effettuare il blocco in modo da non riuscire in caso di anagrafica già modificata. Questo metodo non rende dirty le anagrafiche ma bisogna poi sbloccarle attraverso UnLock() oppure con Update(). Se avviene un errore quelle precedentemente bloccate vengono sbloccate.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
void Lock(
    bool IgnoreState = false,
    bool ignoreDocStatus = false
)
Sub Lock (
    Optional IgnoreState As Boolean = false,
    Optional ignoreDocStatus As Boolean = false
)
void Lock(
    bool IgnoreState = false,
    bool ignoreDocStatus = false
)
abstract Lock :
        ?IgnoreState : bool *
        ?ignoreDocStatus : bool
(* Defaults:
        let _IgnoreState = defaultArg IgnoreState false
        let _ignoreDocStatus = defaultArg ignoreDocStatus false
*)
-> unit

Parametri

IgnoreState Boolean (Optional)
ignoreDocStatus Boolean (Optional)
Vedi anche

Documentazione

Interfaccia IDedData
Namespace DedNet.Core


Metodo IDedData.UnLock

Metodo IDedDataUnLock
Sblocca tutte le anagrafiche solo se queste sono bloccate. Opzionalmente, se queste sono dirty, le aggiorna. Questo metodo la sblocca reimpostando il DEDROWVER alla versione precedente il bloccaggio ed effettua un Refresh() per riallineare i valori dell'anagrafica con il Database se l'anagrafica era Dirty.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
void UnLock(
    bool DiscardChanges
)
Sub UnLock (
    DiscardChanges As Boolean
)
void UnLock(
    bool DiscardChanges
)
abstract UnLock :
        DiscardChanges : bool -> unit

Parametri

DiscardChanges Boolean
Indica se salvare le modifiche apportate nel caso in cui l'anagrafica sia dirty.
Vedi anche

Documentazione

Interfaccia IDedData
Namespace DedNet.Core


Interfaccia IDedDbCollectionBase<T>

Interfaccia IDedDbCollectionBaseT
Interfaccia minima utilizzata dalla classe 'DedDbCollectionBase'.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public interface IDedDbCollectionBase<T>

Public Interface IDedDbCollectionBase(Of T)
generic<typename T>
public interface class IDedDbCollectionBase
type IDedDbCollectionBase<'T> = interface end

Parametri di tipo

T

Il tipo IDedDbCollectionBaseT espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | PropertyChanged |
Metodo pubblico | PropertyChangedAsNewElement |
Metodo pubblico | Save |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Metodi di IDedDbCollectionBase<T>

Metodi di IDedDbCollectionBaseT

Il tipo IDedDbCollectionBaseT espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | PropertyChanged |
Metodo pubblico | PropertyChangedAsNewElement |
Metodo pubblico | Save |
Torna su
Vedi anche

Documentazione

Interfaccia IDedDbCollectionBaseT
Namespace DedNet.Core


Metodo IDedDbCollectionBase<T>.PropertyChanged

Metodo IDedDbCollectionBaseTPropertyChanged

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
void PropertyChanged(
    DedEditableObject<T> t
)
Sub PropertyChanged (
    t As DedEditableObject(Of T)
)
void PropertyChanged(
    DedEditableObject<T>^ t
)
abstract PropertyChanged :
        t : DedEditableObject<'T> -> unit

Parametri

t DedEditableObject T
Vedi anche

Documentazione

Interfaccia IDedDbCollectionBaseT
Namespace DedNet.Core


Metodo IDedDbCollectionBase<T>.PropertyChangedAsNewElement

Metodo IDedDbCollectionBaseTPropertyChangedAsNewElement

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
void PropertyChangedAsNewElement(
    DedEditableObject<T> t
)
Sub PropertyChangedAsNewElement (
    t As DedEditableObject(Of T)
)
void PropertyChangedAsNewElement(
    DedEditableObject<T>^ t
)
abstract PropertyChangedAsNewElement :
        t : DedEditableObject<'T> -> unit

Parametri

t DedEditableObject T
Vedi anche

Documentazione

Interfaccia IDedDbCollectionBaseT
Namespace DedNet.Core


Metodo IDedDbCollectionBase<T>.Save

Metodo IDedDbCollectionBaseTSave

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
void Save()
Sub Save
void Save()
abstract Save : unit -> unit
Vedi anche

Documentazione

Interfaccia IDedDbCollectionBaseT
Namespace DedNet.Core


Interfaccia IDedDbItem
Interfaccia che deve essere implementata dagli oggetti che sono gli elementi costituenti la collezione. Attraverso questa proprietà DedDbCollectionBase si registra per la notifica dell'avvenuta modifica dell'oggetto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public interface IDedDbItem
Public Interface IDedDbItem
public interface class IDedDbItem
type IDedDbItem = interface end

Il tipo IDedDbItem espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | StatoRecord |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di IDedDbItem

Il tipo IDedDbItem espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | StatoRecord |
Torna su
Vedi anche

Documentazione

Interfaccia IDedDbItem
Namespace DedNet.Core


Proprietà IDedDbItem.StatoRecord

Proprietà IDedDbItemStatoRecord

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
StatoRecord StatoRecord { get; set; }
Property StatoRecord As StatoRecord
    Get
    Set
property StatoRecord^ StatoRecord {
    StatoRecord^ get ();
    void set (StatoRecord^ value);
}
abstract StatoRecord : StatoRecord with get, set

Valore della proprietà

StatoRecord
Vedi anche

Documentazione

Interfaccia IDedDbItem
Namespace DedNet.Core


Interfaccia IDedEditable
Interfaccia minima che deve implementare un oggetto per poter essere utilizzato nel controllo DedEditAnagrControl.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public interface IDedEditable
Public Interface IDedEditable
public interface class IDedEditable
type IDedEditable = interface end

Il tipo IDedEditable espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | GetValue | Restituisce il contenuto di un campo personalizzato oppure null se non esiste.
Metodo pubblico | SetValue | Imposta un campo personalizzato con un nuovo valore.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Metodi di IDedEditable

Il tipo IDedEditable espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | GetValue | Restituisce il contenuto di un campo personalizzato oppure null se non esiste.
Metodo pubblico | SetValue | Imposta un campo personalizzato con un nuovo valore.
Torna su
Vedi anche

Documentazione

Interfaccia IDedEditable
Namespace DedNet.Core


Metodo IDedEditable.GetValue

Metodo IDedEditableGetValue
Restituisce il contenuto di un campo personalizzato oppure null se non esiste.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
Object GetValue(
    string persfield
)
Function GetValue (
    persfield As String
) As Object
Object^ GetValue(
    String^ persfield
)
abstract GetValue :
        persfield : string -> Object

Parametri

persfield String
Nome del campo personalizzato del quale restituire il contenuto.

Valore di ritorno

Object
Restituisce il valore se presente oppure null.
Vedi anche

Documentazione

Interfaccia IDedEditable
Namespace DedNet.Core


Metodo IDedEditable.SetValue

Metodo IDedEditableSetValue
Imposta un campo personalizzato con un nuovo valore.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
void SetValue(
    string persfield,
    Object Value
)
Sub SetValue (
    persfield As String,
    Value As Object
)
void SetValue(
    String^ persfield,
    Object^ Value
)
abstract SetValue :
        persfield : string *
        Value : Object -> unit

Parametri

persfield String
Nome del campo personalizzato da impostare.
Value Object
Valore da impostare.
Vedi anche

Documentazione

Interfaccia IDedEditable
Namespace DedNet.Core


Interfaccia IDedPublishingConfiguration<T>

Interfaccia IDedPublishingConfigurationT
Interfaccia configurazione di pubblicazione

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public interface IDedPublishingConfiguration<T>

Public Interface IDedPublishingConfiguration(Of T)
generic<typename T>
public interface class IDedPublishingConfiguration
type IDedPublishingConfiguration<'T> = interface end

Parametri di tipo

T

Il tipo IDedPublishingConfigurationT espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Dirty | Indica se la configurazione ha subito modifiche
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | GetValue | Metodo di prelevamento del valore
Metodo pubblico | Save | Salvataggio delle modifiche
Metodo pubblico | SetValue | Metodo di settaggio del valore dell'opzione
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di IDedPublishingConfiguration<T>

Proprietà di IDedPublishingConfigurationT

Il tipo IDedPublishingConfigurationT espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Dirty | Indica se la configurazione ha subito modifiche
Torna su
Vedi anche

Documentazione

Interfaccia IDedPublishingConfigurationT
Namespace DedNet.Core


Proprietà IDedPublishingConfiguration<T>.Dirty

Proprietà IDedPublishingConfigurationTDirty
Indica se la configurazione ha subito modifiche

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
bool Dirty { get; }
ReadOnly Property Dirty As Boolean
    Get
property bool Dirty {
    bool get ();
}
abstract Dirty : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Interfaccia IDedPublishingConfigurationT
Namespace DedNet.Core


Metodi di IDedPublishingConfiguration<T>

Metodi di IDedPublishingConfigurationT

Il tipo IDedPublishingConfigurationT espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | GetValue | Metodo di prelevamento del valore
Metodo pubblico | Save | Salvataggio delle modifiche
Metodo pubblico | SetValue | Metodo di settaggio del valore dell'opzione
Torna su
Vedi anche

Documentazione

Interfaccia IDedPublishingConfigurationT
Namespace DedNet.Core


Metodo IDedPublishingConfiguration<T>.GetValue

Metodo IDedPublishingConfigurationTGetValue
Metodo di prelevamento del valore

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
T GetValue(
    DedPublicationPlatform platform,
    DedPublicationFormat fmt
)
Function GetValue (
    platform As DedPublicationPlatform,
    fmt As DedPublicationFormat
) As T
T GetValue(
    DedPublicationPlatform platform,
    DedPublicationFormat fmt
)
abstract GetValue :
        platform : DedPublicationPlatform *
        fmt : DedPublicationFormat -> 'T

Parametri

platform DedPublicationPlatform
fmt DedPublicationFormat

Valore di ritorno

T
Vedi anche

Documentazione

Interfaccia IDedPublishingConfigurationT
Namespace DedNet.Core


Metodo IDedPublishingConfiguration<T>.Save

Metodo IDedPublishingConfigurationTSave
Salvataggio delle modifiche

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
void Save()
Sub Save
void Save()
abstract Save : unit -> unit
Vedi anche

Documentazione

Interfaccia IDedPublishingConfigurationT
Namespace DedNet.Core


Metodo IDedPublishingConfiguration<T>.SetValue

Metodo IDedPublishingConfigurationTSetValue
Metodo di settaggio del valore dell'opzione

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
void SetValue(
    DedPublicationPlatform platform,
    DedPublicationFormat fmt,
    T newValue
)
Sub SetValue (
    platform As DedPublicationPlatform,
    fmt As DedPublicationFormat,
    newValue As T
)
void SetValue(
    DedPublicationPlatform platform,
    DedPublicationFormat fmt,
    T newValue
)
abstract SetValue :
        platform : DedPublicationPlatform *
        fmt : DedPublicationFormat *
        newValue : 'T -> unit

Parametri

platform DedPublicationPlatform
fmt DedPublicationFormat
newValue T
Vedi anche

Documentazione

Interfaccia IDedPublishingConfigurationT
Namespace DedNet.Core


Interfaccia IDedTypeEditable
Intefaccia con le informazioni sulla famiglia di archiviazione e la validità dell'oggetto

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public interface IDedTypeEditable : IDedEditable
Public Interface IDedTypeEditable
    Inherits IDedEditable
public interface class IDedTypeEditable : IDedEditable
type IDedTypeEditable =
    interface
        interface IDedEditable
    end

Il tipo IDedTypeEditable espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | DedTypeBase | Restituisce la famiglia nella quale è stata archiviata questo oggetto. Può restituire null se non appartiene ad alcuna famiglia.
Proprietà pubblica | IsValid | Restituisce se i valori presenti validano gli attributi della famiglia di appartenenza.
Proprietà pubblica | Root | REstiruisce la Root di appartenneza di questo oggetto
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | GetValue(DedDataStandardDataFields) | Restituisce il contenuto di uno dei campi standard oppure null se non è presente.
Metodo pubblico | GetValue(String) | Restituisce il contenuto di un campo personalizzato oppure null se non esiste. (Ereditato da IDedEditable)
Metodo pubblico | SetValue(DedDataStandardDataFields, Object) | Imposta un campo standard con un nuovo valore.
Metodo pubblico | SetValue(String, Object) | Imposta un campo personalizzato con un nuovo valore. (Ereditato da IDedEditable)
Metodo pubblico | Validate | Valida i dati anagrafici
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di IDedTypeEditable

Il tipo IDedTypeEditable espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | DedTypeBase | Restituisce la famiglia nella quale è stata archiviata questo oggetto. Può restituire null se non appartiene ad alcuna famiglia.
Proprietà pubblica | IsValid | Restituisce se i valori presenti validano gli attributi della famiglia di appartenenza.
Proprietà pubblica | Root | REstiruisce la Root di appartenneza di questo oggetto
Torna su
Vedi anche

Documentazione

Interfaccia IDedTypeEditable
Namespace DedNet.Core


Proprietà IDedTypeEditable.DedTypeBase

Proprietà IDedTypeEditableDedTypeBase
Restituisce la famiglia nella quale è stata archiviata questo oggetto. Può restituire null se non appartiene ad alcuna famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
DedTypeBase DedTypeBase { get; }
ReadOnly Property DedTypeBase As DedTypeBase
    Get
property DedTypeBase^ DedTypeBase {
    DedTypeBase^ get ();
}
abstract DedTypeBase : DedTypeBase with get

Valore della proprietà

DedTypeBase
Vedi anche

Documentazione

Interfaccia IDedTypeEditable
Namespace DedNet.Core


Proprietà IDedTypeEditable.IsValid

Proprietà IDedTypeEditableIsValid
Restituisce se i valori presenti validano gli attributi della famiglia di appartenenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
bool IsValid { get; }
ReadOnly Property IsValid As Boolean
    Get
property bool IsValid {
    bool get ();
}
abstract IsValid : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Interfaccia IDedTypeEditable
Namespace DedNet.Core


Proprietà IDedTypeEditable.Root

Proprietà IDedTypeEditableRoot
REstiruisce la Root di appartenneza di questo oggetto

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
DedTypeBase Root { get; }
ReadOnly Property Root As DedTypeBase
    Get
property DedTypeBase^ Root {
    DedTypeBase^ get ();
}
abstract Root : DedTypeBase with get

Valore della proprietà

DedTypeBase
Vedi anche

Documentazione

Interfaccia IDedTypeEditable
Namespace DedNet.Core


Metodi di IDedTypeEditable

Il tipo IDedTypeEditable espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | GetValue(DedDataStandardDataFields) | Restituisce il contenuto di uno dei campi standard oppure null se non è presente.
Metodo pubblico | GetValue(String) | Restituisce il contenuto di un campo personalizzato oppure null se non esiste. (Ereditato da IDedEditable)
Metodo pubblico | SetValue(DedDataStandardDataFields, Object) | Imposta un campo standard con un nuovo valore.
Metodo pubblico | SetValue(String, Object) | Imposta un campo personalizzato con un nuovo valore. (Ereditato da IDedEditable)
Metodo pubblico | Validate | Valida i dati anagrafici
Torna su
Vedi anche

Documentazione

Interfaccia IDedTypeEditable
Namespace DedNet.Core


Metodo IDedTypeEditable.GetValue

Metodo IDedTypeEditableGetValue
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | GetValue(DedDataStandardDataFields) | Restituisce il contenuto di uno dei campi standard oppure null se non è presente.
Metodo pubblico | GetValue(String) | Restituisce il contenuto di un campo personalizzato oppure null se non esiste.
Torna su
Vedi anche

Documentazione

Interfaccia IDedTypeEditable
Namespace DedNet.Core


Metodo IDedTypeEditable.GetValue(DedData.StandardDataFields)

Metodo IDedTypeEditableGetValue(DedDataStandardDataFields)
Restituisce il contenuto di uno dei campi standard oppure null se non è presente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
Object GetValue(
    DedDataStandardDataFields stdfield
)
Function GetValue (
    stdfield As DedDataStandardDataFields
) As Object
Object^ GetValue(
    DedDataStandardDataFields stdfield
)
abstract GetValue :
        stdfield : DedDataStandardDataFields -> Object

Parametri

stdfield DedDataStandardDataFields
Campo standard del quale restituire il contenuto.

Valore di ritorno

Object
Restituisce il valore se presente oppure null.
Vedi anche

Documentazione

Interfaccia IDedTypeEditable
Overload di GetValue
Namespace DedNet.Core


Metodo IDedTypeEditable.SetValue

Metodo IDedTypeEditableSetValue
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | SetValue(DedDataStandardDataFields, Object) | Imposta un campo standard con un nuovo valore.
Metodo pubblico | SetValue(String, Object) | Imposta un campo personalizzato con un nuovo valore.
Torna su
Vedi anche

Documentazione

Interfaccia IDedTypeEditable
Namespace DedNet.Core


Metodo IDedTypeEditable.SetValue(DedData.StandardDataFields, Object)

Metodo IDedTypeEditableSetValue(DedDataStandardDataFields, Object)
Imposta un campo standard con un nuovo valore.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
void SetValue(
    DedDataStandardDataFields stdfield,
    Object Value
)
Sub SetValue (
    stdfield As DedDataStandardDataFields,
    Value As Object
)
void SetValue(
    DedDataStandardDataFields stdfield,
    Object^ Value
)
abstract SetValue :
        stdfield : DedDataStandardDataFields *
        Value : Object -> unit

Parametri

stdfield DedDataStandardDataFields
Campo standard da impostare.
Value Object
Valore da impostare.
Vedi anche

Documentazione

Interfaccia IDedTypeEditable
Overload di SetValue
Namespace DedNet.Core


Metodo IDedTypeEditable.Validate

Metodo IDedTypeEditableValidate
Valida i dati anagrafici

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
bool Validate(
    bool creating,
    bool revisioning,
    out string error
)
Function Validate (
    creating As Boolean,
    revisioning As Boolean,
    <OutAttribute> ByRef error As String
) As Boolean
bool Validate(
    bool creating,
    bool revisioning,
    [OutAttribute] String^% error
)
abstract Validate :
        creating : bool *
        revisioning : bool *
        error : string byref -> bool

Parametri

creating Boolean
Indica se siamo in fase di creazione anagrafica
revisioning Boolean
Indica se siamo in fase di creazione revisione
error String
Restitusice eventuale errore

Valore di ritorno

Boolean
Restituisce True se è valida altrimenti false con errore
Vedi anche

Documentazione

Interfaccia IDedTypeEditable
Namespace DedNet.Core


Enumerazione ListElaborationTypeEnum
Enumerazione con le tipologiie di oggetti gestiti dalle liste

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum ListElaborationTypeEnum
Public Enumeration ListElaborationTypeEnum
public enum class ListElaborationTypeEnum
type ListElaborationTypeEnum
Membri
Nome | Valore | Descrizione
Anagrafica | 0 |
BomMono | 1 |
BomMulti | 2 |
Bom | 3 |
Vedi anche

Documentazione

Namespace DedNet.Core


Enumerazione ListItemTypeEnum
Enumerazione con le tipologiie di oggetti gestiti dalle liste

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum ListItemTypeEnum
Public Enumeration ListItemTypeEnum
public enum class ListItemTypeEnum
type ListItemTypeEnum
Membri
Nome | Valore | Descrizione
DedData | 0 |
Vedi anche

Documentazione

Namespace DedNet.Core


Classe LocalizedDescriptionAttribute
Gestione localizzazione descrizione
Gerarchia di ereditarietà
SystemObject
SystemAttribute
System.ComponentModelDescriptionAttribute
DedNet.CoreLocalizedDescriptionAttribute

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class LocalizedDescriptionAttribute : DescriptionAttribute
Public Class LocalizedDescriptionAttribute
    Inherits DescriptionAttribute
public ref class LocalizedDescriptionAttribute : public DescriptionAttribute
type LocalizedDescriptionAttribute =
    class
        inherit DescriptionAttribute
    end

Il tipo LocalizedDescriptionAttribute espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | LocalizedDescriptionAttribute |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Description | (Sovrascrive DescriptionAttributeDescription)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore LocalizedDescriptionAttribute

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public LocalizedDescriptionAttribute(
    string resourceKey,
    Type resourceType
)
Public Sub New (
    resourceKey As String,
    resourceType As Type
)
public:
LocalizedDescriptionAttribute(
    String^ resourceKey,
    Type^ resourceType
)
new :
        resourceKey : string *
        resourceType : Type -> LocalizedDescriptionAttribute

Parametri

resourceKey String
resourceType Type
Vedi anche

Documentazione

Classe LocalizedDescriptionAttribute
Namespace DedNet.Core


Proprietà di LocalizedDescriptionAttribute

Il tipo LocalizedDescriptionAttribute espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Description | (Sovrascrive DescriptionAttributeDescription)
Torna su
Vedi anche

Documentazione

Classe LocalizedDescriptionAttribute
Namespace DedNet.Core


Proprietà LocalizedDescriptionAttribute.Description

Proprietà LocalizedDescriptionAttributeDescription

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get () override;
}
abstract Description : string with get
override Description : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe LocalizedDescriptionAttribute
Namespace DedNet.Core


Classe ModelStateRelocationInfo
Informazioni di ripuntamento del model state sulla factory già revisionata
Gerarchia di ereditarietà
SystemObject
DedNet.CoreModelStateRelocationInfo

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ModelStateRelocationInfo
Public Class ModelStateRelocationInfo
public ref class ModelStateRelocationInfo
type ModelStateRelocationInfo = class end

Il tipo ModelStateRelocationInfo espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ModelStateRelocationInfo |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | CfgDescr |
Proprietà pubblica | Data |
Proprietà pubblica | FactoryFullName |
Proprietà pubblica | MasterData |
Proprietà pubblica | RevisionedFactoryFullName |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore ModelStateRelocationInfo

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ModelStateRelocationInfo(
    DedData data,
    ConfigDescriptor cfgDesr,
    string factoryFullName,
    string revisionedFactoryFullName,
    DedData masterData
)
Public Sub New (
    data As DedData,
    cfgDesr As ConfigDescriptor,
    factoryFullName As String,
    revisionedFactoryFullName As String,
    masterData As DedData
)
public:
ModelStateRelocationInfo(
    DedData^ data,
    ConfigDescriptor^ cfgDesr,
    String^ factoryFullName,
    String^ revisionedFactoryFullName,
    DedData^ masterData
)
new :
        data : DedData *
        cfgDesr : ConfigDescriptor *
        factoryFullName : string *
        revisionedFactoryFullName : string *
        masterData : DedData -> ModelStateRelocationInfo

Parametri

data DedData
cfgDesr ConfigDescriptor
factoryFullName String
revisionedFactoryFullName String
masterData DedData
Vedi anche

Documentazione

Classe ModelStateRelocationInfo
Namespace DedNet.Core


Proprietà di ModelStateRelocationInfo

Il tipo ModelStateRelocationInfo espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CfgDescr |
Proprietà pubblica | Data |
Proprietà pubblica | FactoryFullName |
Proprietà pubblica | MasterData |
Proprietà pubblica | RevisionedFactoryFullName |
Torna su
Vedi anche

Documentazione

Classe ModelStateRelocationInfo
Namespace DedNet.Core


Proprietà ModelStateRelocationInfo.CfgDescr

Proprietà ModelStateRelocationInfoCfgDescr

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ConfigDescriptor CfgDescr { get; set; }
Public Property CfgDescr As ConfigDescriptor
    Get
    Set
public:
property ConfigDescriptor^ CfgDescr {
    ConfigDescriptor^ get ();
    void set (ConfigDescriptor^ value);
}
member CfgDescr : ConfigDescriptor with get, set

Valore della proprietà

ConfigDescriptor
Vedi anche

Documentazione

Classe ModelStateRelocationInfo
Namespace DedNet.Core


Proprietà ModelStateRelocationInfo.Data

Proprietà ModelStateRelocationInfoData

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; set; }
Public Property Data As DedData
    Get
    Set
public:
property DedData^ Data {
    DedData^ get ();
    void set (DedData^ value);
}
member Data : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe ModelStateRelocationInfo
Namespace DedNet.Core


Proprietà ModelStateRelocationInfo.FactoryFullName

Proprietà ModelStateRelocationInfoFactoryFullName

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string FactoryFullName { get; set; }
Public Property FactoryFullName As String
    Get
    Set
public:
property String^ FactoryFullName {
    String^ get ();
    void set (String^ value);
}
member FactoryFullName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe ModelStateRelocationInfo
Namespace DedNet.Core


Proprietà ModelStateRelocationInfo.MasterData

Proprietà ModelStateRelocationInfoMasterData

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData MasterData { get; set; }
Public Property MasterData As DedData
    Get
    Set
public:
property DedData^ MasterData {
    DedData^ get ();
    void set (DedData^ value);
}
member MasterData : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe ModelStateRelocationInfo
Namespace DedNet.Core


Proprietà ModelStateRelocationInfo.RevisionedFactoryFullName

Proprietà ModelStateRelocationInfoRevisionedFactoryFullName

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string RevisionedFactoryFullName { get; set; }
Public Property RevisionedFactoryFullName As String
    Get
    Set
public:
property String^ RevisionedFactoryFullName {
    String^ get ();
    void set (String^ value);
}
member RevisionedFactoryFullName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe ModelStateRelocationInfo
Namespace DedNet.Core


Classe ModelStateRelocationInfos
Lista dei descrittori di ripuntamento
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList ModelStateRelocationInfo
DedNet.CoreModelStateRelocationInfos

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ModelStateRelocationInfos : List<ModelStateRelocationInfo>
Public Class ModelStateRelocationInfos
    Inherits List(Of ModelStateRelocationInfo)
public ref class ModelStateRelocationInfos : public List<ModelStateRelocationInfo^>
type ModelStateRelocationInfos =
    class
        inherit List<ModelStateRelocationInfo>
    end

Il tipo ModelStateRelocationInfos espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ModelStateRelocationInfos |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Add |
Metodo pubblico | FindByFactoryFullName |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore ModelStateRelocationInfos

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ModelStateRelocationInfos()
Public Sub New
public:
ModelStateRelocationInfos()
new : unit -> ModelStateRelocationInfos
Vedi anche

Documentazione

Classe ModelStateRelocationInfos
Namespace DedNet.Core


Metodi di ModelStateRelocationInfos

Il tipo ModelStateRelocationInfos espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Add |
Metodo pubblico | FindByFactoryFullName |
Torna su
Vedi anche

Documentazione

Classe ModelStateRelocationInfos
Namespace DedNet.Core


Metodo ModelStateRelocationInfos.Add

Metodo ModelStateRelocationInfosAdd

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Add(
    DedData data,
    ConfigDescriptor cfgDesr,
    string factoryFullName,
    string revisionedFactoryFullName,
    DedData masterData
)
Public Sub Add (
    data As DedData,
    cfgDesr As ConfigDescriptor,
    factoryFullName As String,
    revisionedFactoryFullName As String,
    masterData As DedData
)
public:
void Add(
    DedData^ data,
    ConfigDescriptor^ cfgDesr,
    String^ factoryFullName,
    String^ revisionedFactoryFullName,
    DedData^ masterData
)
member Add :
        data : DedData *
        cfgDesr : ConfigDescriptor *
        factoryFullName : string *
        revisionedFactoryFullName : string *
        masterData : DedData -> unit

Parametri

data DedData
cfgDesr ConfigDescriptor
factoryFullName String
revisionedFactoryFullName String
masterData DedData
Vedi anche

Documentazione

Classe ModelStateRelocationInfos
Namespace DedNet.Core


Metodo ModelStateRelocationInfos.FindByFactoryFullName

Metodo ModelStateRelocationInfosFindByFactoryFullName

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ModelStateRelocationInfo FindByFactoryFullName(
    string factoryFullName
)
Public Function FindByFactoryFullName (
    factoryFullName As String
) As ModelStateRelocationInfo
public:
ModelStateRelocationInfo^ FindByFactoryFullName(
    String^ factoryFullName
)
member FindByFactoryFullName :
        factoryFullName : string -> ModelStateRelocationInfo

Parametri

factoryFullName String

Valore di ritorno

ModelStateRelocationInfo
Vedi anche

Documentazione

Classe ModelStateRelocationInfos
Namespace DedNet.Core


Classe OutlookDataObject
Provides a format-independant machanism for transfering data with support for outlook messages and attachments.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreOutlookDataObject

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class OutlookDataObject : IDataObject
Public Class OutlookDataObject
    Implements IDataObject
public ref class OutlookDataObject : IDataObject
type OutlookDataObject =
    class
        interface IDataObject
    end

Il tipo OutlookDataObject espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | OutlookDataObject | Initializes a new instance of the OutlookDataObject class.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | GetData(String) | Retrieves the data associated with the specified data format.
Metodo pubblico | GetData(Type) | Retrieves the data associated with the specified class type format.
Metodo pubblico | GetData(String, Boolean) | Retrieves the data associated with the specified data format, using a Boolean to determine whether to convert the data to the format.
Metodo pubblico | GetData(String, Int32) | Retrieves the data associated with the specified data format at the specified index.
Metodo pubblico | GetDataPresent(String) | Determines whether data stored in this instance is associated with, or can be converted to, the specified format.
Metodo pubblico | GetDataPresent(Type) | Determines whether data stored in this instance is associated with, or can be converted to, the specified format.
Metodo pubblico | GetDataPresent(String, Boolean) | Determines whether data stored in this instance is associated with the specified format, using a Boolean value to determine whether to convert the data to the format.
Metodo pubblico | GetFormats | Returns a list of all formats that data stored in this instance is associated with or can be converted to.
Metodo pubblico | GetFormats(Boolean) | Gets a list of all formats that data stored in this instance is associated with or can be converted to, using a Boolean value to determine whether to retrieve all formats that the data can be converted to or only native data formats.
Metodo pubblico | SetData(Object) | Stores the specified data in this instance, using the class of the data for the format.
Metodo pubblico | SetData(String, Object) | Stores the specified data and its associated format in this instance.
Metodo pubblico | SetData(Type, Object) | Stores the specified data and its associated class type in this instance.
Metodo pubblico | SetData(String, Boolean, Object) | Stores the specified data and its associated format in this instance, using a Boolean value to specify whether the data can be converted to another format.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore OutlookDataObject
Initializes a new instance of the OutlookDataObject class.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public OutlookDataObject(
    IDataObject underlyingDataObject
)
Public Sub New (
    underlyingDataObject As IDataObject
)
public:
OutlookDataObject(
    IDataObject^ underlyingDataObject
)
new :
        underlyingDataObject : IDataObject -> OutlookDataObject

Parametri

underlyingDataObject IDataObject
The underlying data object to wrap.
Vedi anche

Documentazione

Classe OutlookDataObject
Namespace DedNet.Core


Metodi di OutlookDataObject

Il tipo OutlookDataObject espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | GetData(String) | Retrieves the data associated with the specified data format.
Metodo pubblico | GetData(Type) | Retrieves the data associated with the specified class type format.
Metodo pubblico | GetData(String, Boolean) | Retrieves the data associated with the specified data format, using a Boolean to determine whether to convert the data to the format.
Metodo pubblico | GetData(String, Int32) | Retrieves the data associated with the specified data format at the specified index.
Metodo pubblico | GetDataPresent(String) | Determines whether data stored in this instance is associated with, or can be converted to, the specified format.
Metodo pubblico | GetDataPresent(Type) | Determines whether data stored in this instance is associated with, or can be converted to, the specified format.
Metodo pubblico | GetDataPresent(String, Boolean) | Determines whether data stored in this instance is associated with the specified format, using a Boolean value to determine whether to convert the data to the format.
Metodo pubblico | GetFormats | Returns a list of all formats that data stored in this instance is associated with or can be converted to.
Metodo pubblico | GetFormats(Boolean) | Gets a list of all formats that data stored in this instance is associated with or can be converted to, using a Boolean value to determine whether to retrieve all formats that the data can be converted to or only native data formats.
Metodo pubblico | SetData(Object) | Stores the specified data in this instance, using the class of the data for the format.
Metodo pubblico | SetData(String, Object) | Stores the specified data and its associated format in this instance.
Metodo pubblico | SetData(Type, Object) | Stores the specified data and its associated class type in this instance.
Metodo pubblico | SetData(String, Boolean, Object) | Stores the specified data and its associated format in this instance, using a Boolean value to specify whether the data can be converted to another format.
Torna su
Vedi anche

Documentazione

Classe OutlookDataObject
Namespace DedNet.Core


Metodo OutlookDataObject.GetData

Metodo OutlookDataObjectGetData
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | GetData(String) | Retrieves the data associated with the specified data format.
Metodo pubblico | GetData(Type) | Retrieves the data associated with the specified class type format.
Metodo pubblico | GetData(String, Boolean) | Retrieves the data associated with the specified data format, using a Boolean to determine whether to convert the data to the format.
Metodo pubblico | GetData(String, Int32) | Retrieves the data associated with the specified data format at the specified index.
Torna su
Vedi anche

Documentazione

Classe OutlookDataObject
Namespace DedNet.Core


Metodo OutlookDataObject.GetData(String)

Metodo OutlookDataObjectGetData(String)
Retrieves the data associated with the specified data format.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object GetData(
    string format
)
Public Function GetData (
    format As String
) As Object
public:
virtual Object^ GetData(
    String^ format
) sealed
abstract GetData :
        format : string -> Object
override GetData :
        format : string -> Object

Parametri

format String
The format of the data to retrieve. See DataFormats for predefined formats.

Valore di ritorno

Object
The data associated with the specified format, or null.

Implementa

IDataObjectGetData(String)
Vedi anche

Documentazione

Classe OutlookDataObject
Overload di GetData
Namespace DedNet.Core


Metodo OutlookDataObject.GetData(Type)

Metodo OutlookDataObjectGetData(Type)
Retrieves the data associated with the specified class type format.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object GetData(
    Type format
)
Public Function GetData (
    format As Type
) As Object
public:
virtual Object^ GetData(
    Type^ format
) sealed
abstract GetData :
        format : Type -> Object
override GetData :
        format : Type -> Object

Parametri

format Type
A Type representing the format of the data to retrieve. See DataFormats for predefined formats.

Valore di ritorno

Object
The data associated with the specified format, or null.

Implementa

IDataObjectGetData(Type)
Vedi anche

Documentazione

Classe OutlookDataObject
Overload di GetData
Namespace DedNet.Core


Metodo OutlookDataObject.GetData(String, Boolean)

Metodo OutlookDataObjectGetData(String, Boolean)
Retrieves the data associated with the specified data format, using a Boolean to determine whether to convert the data to the format.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object GetData(
    string format,
    bool autoConvert
)
Public Function GetData (
    format As String,
    autoConvert As Boolean
) As Object
public:
virtual Object^ GetData(
    String^ format,
    bool autoConvert
) sealed
abstract GetData :
        format : string *
        autoConvert : bool -> Object
override GetData :
        format : string *
        autoConvert : bool -> Object

Parametri

format String
The format of the data to retrieve. See DataFormats for predefined formats.
autoConvert Boolean
true to convert the data to the specified format; otherwise, false.

Valore di ritorno

Object
The data associated with the specified format, or null.

Implementa

IDataObjectGetData(String, Boolean)
Vedi anche

Documentazione

Classe OutlookDataObject
Overload di GetData
Namespace DedNet.Core


Metodo OutlookDataObject.GetData(String, Int32)

Metodo OutlookDataObjectGetData(String, Int32)
Retrieves the data associated with the specified data format at the specified index.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public MemoryStream GetData(
    string format,
    int index
)
Public Function GetData (
    format As String,
    index As Integer
) As MemoryStream
public:
MemoryStream^ GetData(
    String^ format,
    int index
)
member GetData :
        format : string *
        index : int -> MemoryStream

Parametri

format String
The format of the data to retrieve. See DataFormats for predefined formats.
index Int32
The index of the data to retrieve.

Valore di ritorno

MemoryStream
A MemoryStream containing the raw data for the specified data format at the specified index.
Vedi anche

Documentazione

Classe OutlookDataObject
Overload di GetData
Namespace DedNet.Core


Metodo OutlookDataObject.GetDataPresent

Metodo OutlookDataObjectGetDataPresent
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | GetDataPresent(String) | Determines whether data stored in this instance is associated with, or can be converted to, the specified format.
Metodo pubblico | GetDataPresent(Type) | Determines whether data stored in this instance is associated with, or can be converted to, the specified format.
Metodo pubblico | GetDataPresent(String, Boolean) | Determines whether data stored in this instance is associated with the specified format, using a Boolean value to determine whether to convert the data to the format.
Torna su
Vedi anche

Documentazione

Classe OutlookDataObject
Namespace DedNet.Core


Metodo OutlookDataObject.GetDataPresent(String)

Metodo OutlookDataObjectGetDataPresent(String)
Determines whether data stored in this instance is associated with, or can be converted to, the specified format.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool GetDataPresent(
    string format
)
Public Function GetDataPresent (
    format As String
) As Boolean
public:
virtual bool GetDataPresent(
    String^ format
) sealed
abstract GetDataPresent :
        format : string -> bool
override GetDataPresent :
        format : string -> bool

Parametri

format String
The format for which to check. See DataFormats for predefined formats.

Valore di ritorno

Boolean
true if data stored in this instance is associated with, or can be converted to, the specified format; otherwise false.

Implementa

IDataObjectGetDataPresent(String)
Vedi anche

Documentazione

Classe OutlookDataObject
Overload di GetDataPresent
Namespace DedNet.Core


Metodo OutlookDataObject.GetDataPresent(Type)

Metodo OutlookDataObjectGetDataPresent(Type)
Determines whether data stored in this instance is associated with, or can be converted to, the specified format.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool GetDataPresent(
    Type format
)
Public Function GetDataPresent (
    format As Type
) As Boolean
public:
virtual bool GetDataPresent(
    Type^ format
) sealed
abstract GetDataPresent :
        format : Type -> bool
override GetDataPresent :
        format : Type -> bool

Parametri

format Type
A Type representing the format for which to check. See DataFormats for predefined formats.

Valore di ritorno

Boolean
true if data stored in this instance is associated with, or can be converted to, the specified format; otherwise, false.

Implementa

IDataObjectGetDataPresent(Type)
Vedi anche

Documentazione

Classe OutlookDataObject
Overload di GetDataPresent
Namespace DedNet.Core


Metodo OutlookDataObject.GetDataPresent(String, Boolean)

Metodo OutlookDataObjectGetDataPresent(String, Boolean)
Determines whether data stored in this instance is associated with the specified format, using a Boolean value to determine whether to convert the data to the format.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool GetDataPresent(
    string format,
    bool autoConvert
)
Public Function GetDataPresent (
    format As String,
    autoConvert As Boolean
) As Boolean
public:
virtual bool GetDataPresent(
    String^ format,
    bool autoConvert
) sealed
abstract GetDataPresent :
        format : string *
        autoConvert : bool -> bool
override GetDataPresent :
        format : string *
        autoConvert : bool -> bool

Parametri

format String
The format for which to check. See DataFormats for predefined formats.
autoConvert Boolean
true to determine whether data stored in this instance can be converted to the specified format; false to check whether the data is in the specified format.

Valore di ritorno

Boolean
true if the data is in, or can be converted to, the specified format; otherwise, false.

Implementa

IDataObjectGetDataPresent(String, Boolean)
Vedi anche

Documentazione

Classe OutlookDataObject
Overload di GetDataPresent
Namespace DedNet.Core


Metodo OutlookDataObject.GetFormats

Metodo OutlookDataObjectGetFormats
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | GetFormats | Returns a list of all formats that data stored in this instance is associated with or can be converted to.
Metodo pubblico | GetFormats(Boolean) | Gets a list of all formats that data stored in this instance is associated with or can be converted to, using a Boolean value to determine whether to retrieve all formats that the data can be converted to or only native data formats.
Torna su
Vedi anche

Documentazione

Classe OutlookDataObject
Namespace DedNet.Core


Metodo OutlookDataObject.GetFormats

Metodo OutlookDataObjectGetFormats
Returns a list of all formats that data stored in this instance is associated with or can be converted to.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string[] GetFormats()
Public Function GetFormats As String()
public:
virtual array<String^>^ GetFormats() sealed
abstract GetFormats : unit -> string[]
override GetFormats : unit -> string[]

Valore di ritorno

String
An array of the names that represents a list of all formats that are supported by the data stored in this object.

Implementa

IDataObjectGetFormats
Vedi anche

Documentazione

Classe OutlookDataObject
Overload di GetFormats
Namespace DedNet.Core


Metodo OutlookDataObject.GetFormats(Boolean)

Metodo OutlookDataObjectGetFormats(Boolean)
Gets a list of all formats that data stored in this instance is associated with or can be converted to, using a Boolean value to determine whether to retrieve all formats that the data can be converted to or only native data formats.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string[] GetFormats(
    bool autoConvert
)
Public Function GetFormats (
    autoConvert As Boolean
) As String()
public:
virtual array<String^>^ GetFormats(
    bool autoConvert
) sealed
abstract GetFormats :
        autoConvert : bool -> string[]
override GetFormats :
        autoConvert : bool -> string[]

Parametri

autoConvert Boolean
true to retrieve all formats that data stored in this instance is associated with or can be converted to; false to retrieve only native data formats.

Valore di ritorno

String
An array of the names that represents a list of all formats that are supported by the data stored in this object.

Implementa

IDataObjectGetFormats(Boolean)
Vedi anche

Documentazione

Classe OutlookDataObject
Overload di GetFormats
Namespace DedNet.Core


Metodo OutlookDataObject.SetData

Metodo OutlookDataObjectSetData
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | SetData(Object) | Stores the specified data in this instance, using the class of the data for the format.
Metodo pubblico | SetData(String, Object) | Stores the specified data and its associated format in this instance.
Metodo pubblico | SetData(Type, Object) | Stores the specified data and its associated class type in this instance.
Metodo pubblico | SetData(String, Boolean, Object) | Stores the specified data and its associated format in this instance, using a Boolean value to specify whether the data can be converted to another format.
Torna su
Vedi anche

Documentazione

Classe OutlookDataObject
Namespace DedNet.Core


Metodo OutlookDataObject.SetData(Object)

Metodo OutlookDataObjectSetData(Object)
Stores the specified data in this instance, using the class of the data for the format.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetData(
    Object data
)
Public Sub SetData (
    data As Object
)
public:
virtual void SetData(
    Object^ data
) sealed
abstract SetData :
        data : Object -> unit
override SetData :
        data : Object -> unit

Parametri

data Object
The data to store.

Implementa

IDataObjectSetData(Object)
Vedi anche

Documentazione

Classe OutlookDataObject
Overload di SetData
Namespace DedNet.Core


Metodo OutlookDataObject.SetData(String, Object)

Metodo OutlookDataObjectSetData(String, Object)
Stores the specified data and its associated format in this instance.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetData(
    string format,
    Object data
)
Public Sub SetData (
    format As String,
    data As Object
)
public:
virtual void SetData(
    String^ format,
    Object^ data
) sealed
abstract SetData :
        format : string *
        data : Object -> unit
override SetData :
        format : string *
        data : Object -> unit

Parametri

format String
The format associated with the data. See DataFormats for predefined formats.
data Object
The data to store.

Implementa

IDataObjectSetData(String, Object)
Vedi anche

Documentazione

Classe OutlookDataObject
Overload di SetData
Namespace DedNet.Core


Metodo OutlookDataObject.SetData(Type, Object)

Metodo OutlookDataObjectSetData(Type, Object)
Stores the specified data and its associated class type in this instance.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetData(
    Type format,
    Object data
)
Public Sub SetData (
    format As Type,
    data As Object
)
public:
virtual void SetData(
    Type^ format,
    Object^ data
) sealed
abstract SetData :
        format : Type *
        data : Object -> unit
override SetData :
        format : Type *
        data : Object -> unit

Parametri

format Type
A Type representing the format associated with the data. See DataFormats for predefined formats.
data Object
The data to store.

Implementa

IDataObjectSetData(Type, Object)
Vedi anche

Documentazione

Classe OutlookDataObject
Overload di SetData
Namespace DedNet.Core


Metodo OutlookDataObject.SetData(String, Boolean, Object)

Metodo OutlookDataObjectSetData(String, Boolean, Object)
Stores the specified data and its associated format in this instance, using a Boolean value to specify whether the data can be converted to another format.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetData(
    string format,
    bool autoConvert,
    Object data
)
Public Sub SetData (
    format As String,
    autoConvert As Boolean,
    data As Object
)
public:
virtual void SetData(
    String^ format,
    bool autoConvert,
    Object^ data
) sealed
abstract SetData :
        format : string *
        autoConvert : bool *
        data : Object -> unit
override SetData :
        format : string *
        autoConvert : bool *
        data : Object -> unit

Parametri

format String
The format associated with the data. See DataFormats for predefined formats.
autoConvert Boolean
true to allow the data to be converted to another format; otherwise, false.
data Object
The data to store.

Implementa

IDataObjectSetData(String, Boolean, Object)
Vedi anche

Documentazione

Classe OutlookDataObject
Overload di SetData
Namespace DedNet.Core


Enumerazione OverwriteBomMode
Enumerazione per indicare il comportamento da utilizzare al salva distinta

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum OverwriteBomMode
Public Enumeration OverwriteBomMode
public enum class OverwriteBomMode
type OverwriteBomMode
Membri
Nome | Valore | Descrizione
OverwriteCad | 0 | Sovrascrivi CAD / Ignora modifiche
KeepEdit | 1 | Mantieni modifiche
Vedi anche

Documentazione

Namespace DedNet.Core


Classe PermSet
Set di permessi standard.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreDedPermOwner
DedNet.CorePermSet

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class PermSet : DedPermOwner
Public Class PermSet
    Inherits DedPermOwner
public ref class PermSet : public DedPermOwner
type PermSet =
    class
        inherit DedPermOwner
    end

Il tipo PermSet espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione di appartenenza. (Ereditato da DedPermOwner)
Proprietà pubblica | IsGroup | Restituisce se si tratti di un gruppo (sempre false tranne nel caso di un gruppo). (Ereditato da DedPermOwner)
Proprietà pubblica | IsUser | Restituisce se si tratti di un utente (sempre false tranne nel caso di un utente). (Ereditato da DedPermOwner)
Proprietà pubblica | Manager | Restituisce il Gestore dei permessi. (Ereditato da DedPermOwner)
Proprietà pubblica | Name | (Ereditato da DedPermOwner)
Proprietà pubblica | PermItems | Restitusice il set di permessi di questo possessore. (Ereditato da DedPermOwner)
Proprietà protetta | TableName | Restituisce il nome della table del Database. (Ereditato da DedPermOwner)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | CreateDeleteCommand | (Ereditato da DedPermOwner)
Metodo protetto | CreateInsertCommand | (Ereditato da DedPermOwner)
Metodo protetto | CreateUpdateCommand | (Ereditato da DedPermOwner)
Metodo protetto | GetDbIndex | (Ereditato da DedPermOwner)
Metodo pubblico | GetPermDescription | Restituisce la descrizione del permesso. (Ereditato da DedPermOwner)
Metodo pubblico | GetPermVal(String, String) | Restituisce il valore del permesso. (Ereditato da DedPermOwner)
Metodo pubblico | GetPermVal(String, String, String) | Restituisce il valore del permesso impostando la stringa descrittiva il tipo di ereditarietà del permesso. (Ereditato da DedPermOwner)
Metodo pubblico | IsPermPresent | Restituisce se il permesso è presente in modo esplicito fra i permessi di questa instanza. (Ereditato da DedPermOwner)
Metodo pubblico | SetPermVal | Imposta il permesso ottenendo la stringa descrittiva del permesso. (Ereditato da DedPermOwner)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di PermSet

Il tipo PermSet espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione di appartenenza. (Ereditato da DedPermOwner)
Proprietà pubblica | IsGroup | Restituisce se si tratti di un gruppo (sempre false tranne nel caso di un gruppo). (Ereditato da DedPermOwner)
Proprietà pubblica | IsUser | Restituisce se si tratti di un utente (sempre false tranne nel caso di un utente). (Ereditato da DedPermOwner)
Proprietà pubblica | Manager | Restituisce il Gestore dei permessi. (Ereditato da DedPermOwner)
Proprietà pubblica | Name | (Ereditato da DedPermOwner)
Proprietà pubblica | PermItems | Restitusice il set di permessi di questo possessore. (Ereditato da DedPermOwner)
Proprietà protetta | TableName | Restituisce il nome della table del Database. (Ereditato da DedPermOwner)
Torna su
Vedi anche

Documentazione

Classe PermSet
Namespace DedNet.Core


Metodi di PermSet

Il tipo PermSet espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | CreateDeleteCommand | (Ereditato da DedPermOwner)
Metodo protetto | CreateInsertCommand | (Ereditato da DedPermOwner)
Metodo protetto | CreateUpdateCommand | (Ereditato da DedPermOwner)
Metodo protetto | GetDbIndex | (Ereditato da DedPermOwner)
Metodo pubblico | GetPermDescription | Restituisce la descrizione del permesso. (Ereditato da DedPermOwner)
Metodo pubblico | GetPermVal(String, String) | Restituisce il valore del permesso. (Ereditato da DedPermOwner)
Metodo pubblico | GetPermVal(String, String, String) | Restituisce il valore del permesso impostando la stringa descrittiva il tipo di ereditarietà del permesso. (Ereditato da DedPermOwner)
Metodo pubblico | IsPermPresent | Restituisce se il permesso è presente in modo esplicito fra i permessi di questa instanza. (Ereditato da DedPermOwner)
Metodo pubblico | SetPermVal | Imposta il permesso ottenendo la stringa descrittiva del permesso. (Ereditato da DedPermOwner)
Torna su
Vedi anche

Documentazione

Classe PermSet
Namespace DedNet.Core


Struttura RelationshipItemStruct
Struttura con informazioni legame tra elemento di Sx con elemento Dx.
Gerarchia di ereditarietà
SystemObject
SystemValueType
DedNet.CoreRelationshipItemStruct

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public struct RelationshipItemStruct
Public Structure RelationshipItemStruct
public value class RelationshipItemStruct
[<SealedAttribute>]
type RelationshipItemStruct =
    struct
        inherit ValueType
    end

Il tipo RelationshipItemStruct espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | BiDx | Elemento di destra
Campo pubblico | BiSx | Elemento di sinistra
Campo pubblico | ListInfoComparBom | Lista valori differenti
Campo pubblico | StateCmp | Stato della comparazione
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Campi di RelationshipItemStruct

Il tipo RelationshipItemStruct espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | BiDx | Elemento di destra
Campo pubblico | BiSx | Elemento di sinistra
Campo pubblico | ListInfoComparBom | Lista valori differenti
Campo pubblico | StateCmp | Stato della comparazione
Torna su
Vedi anche

Documentazione

Struttura RelationshipItemStruct
Namespace DedNet.Core


Campo RelationshipItemStruct.BiDx

Campo RelationshipItemStructBiDx
Elemento di destra

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItem BiDx
Public BiDx As BomItem
public:
BomItem^ BiDx
val mutable BiDx: BomItem

Valore del campo

BomItem
Vedi anche

Documentazione

Struttura RelationshipItemStruct
Namespace DedNet.Core


Campo RelationshipItemStruct.BiSx

Campo RelationshipItemStructBiSx
Elemento di sinistra

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItem BiSx
Public BiSx As BomItem
public:
BomItem^ BiSx
val mutable BiSx: BomItem

Valore del campo

BomItem
Vedi anche

Documentazione

Struttura RelationshipItemStruct
Namespace DedNet.Core


Campo RelationshipItemStruct.ListInfoComparBom

Campo RelationshipItemStructListInfoComparBom
Lista valori differenti

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<BomItemComparerClassComparBom> ListInfoComparBom
Public ListInfoComparBom As List(Of BomItemComparerClassComparBom)
public:
List<BomItemComparerClassComparBom^>^ ListInfoComparBom
val mutable ListInfoComparBom: List<BomItemComparerClassComparBom>

Valore del campo

List BomItemComparerClassComparBom
Vedi anche

Documentazione

Struttura RelationshipItemStruct
Namespace DedNet.Core


Campo RelationshipItemStruct.StateCmp

Campo RelationshipItemStructStateCmp
Stato della comparazione

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDistControlDedCompareDistEnum StateCmp
Public StateCmp As DedDistControlDedCompareDistEnum
public:
DedDistControlDedCompareDistEnum StateCmp
val mutable StateCmp: DedDistControlDedCompareDistEnum

Valore del campo

DedDistControlDedCompareDistEnum
Vedi anche

Documentazione

Struttura RelationshipItemStruct
Namespace DedNet.Core


Classe ResultList
Lista di ResultObj
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList ResultObj
DedNet.CoreResultList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ResultList : List<ResultObj>
Public Class ResultList
    Inherits List(Of ResultObj)
public ref class ResultList : public List<ResultObj^>
type ResultList =
    class
        inherit List<ResultObj>
    end

Il tipo ResultList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ResultList |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore ResultList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ResultList()
Public Sub New
public:
ResultList()
new : unit -> ResultList
Vedi anche

Documentazione

Classe ResultList
Namespace DedNet.Core


Classe ResultObj
Oggetto che rappresenta una riga del risultato.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreResultObj

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ResultObj
Public Class ResultObj
public ref class ResultObj
type ResultObj = class end

Il tipo ResultObj espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ResultObj | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Item | Elemento base (Es : DedData)
Proprietà pubblica | Qta | Quantità
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetDiscrimValue | REstituisce il valore del campo discriminante
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | GetValue | Restituisce il valore del campo passato dell'oggetto base
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore ResultObj
Costruttore

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ResultObj(
    DedListItem listItem,
    DedBaseDbItem item,
    Dictionary<string, Object> discrimDistAttrs
)
Public Sub New (
    listItem As DedListItem,
    item As DedBaseDbItem,
    discrimDistAttrs As Dictionary(Of String, Object)
)
public:
ResultObj(
    DedListItem^ listItem,
    DedBaseDbItem^ item,
    Dictionary<String^, Object^>^ discrimDistAttrs
)
new :
        listItem : DedListItem *
        item : DedBaseDbItem *
        discrimDistAttrs : Dictionary<string, Object> -> ResultObj

Parametri

listItem DedListItem
Oggetto della lista da cui deriva l'elemento "item"
item DedBaseDbItem
Oggetto base
discrimDistAttrs Dictionary String, Object
Attributi usati come discriminanti
Vedi anche

Documentazione

Classe ResultObj
Namespace DedNet.Core


Proprietà di ResultObj

Il tipo ResultObj espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Item | Elemento base (Es : DedData)
Proprietà pubblica | Qta | Quantità
Torna su
Vedi anche

Documentazione

Classe ResultObj
Namespace DedNet.Core


Proprietà ResultObj.Item

Proprietà ResultObjItem
Elemento base (Es : DedData)

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedBaseDbItem Item { get; set; }
Public Property Item As DedBaseDbItem
    Get
    Set
public:
property DedBaseDbItem^ Item {
    DedBaseDbItem^ get ();
    void set (DedBaseDbItem^ value);
}
member Item : DedBaseDbItem with get, set

Valore della proprietà

DedBaseDbItem
Vedi anche

Documentazione

Classe ResultObj
Namespace DedNet.Core


Proprietà ResultObj.Qta

Proprietà ResultObjQta
Quantità

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public double Qta { get; set; }
Public Property Qta As Double
    Get
    Set
public:
property double Qta {
    double get ();
    void set (double value);
}
member Qta : float with get, set

Valore della proprietà

Double
Vedi anche

Documentazione

Classe ResultObj
Namespace DedNet.Core


Metodi di ResultObj

Il tipo ResultObj espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetDiscrimValue | REstituisce il valore del campo discriminante
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | GetValue | Restituisce il valore del campo passato dell'oggetto base
Torna su
Vedi anche

Documentazione

Classe ResultObj
Namespace DedNet.Core


Metodo ResultObj.Equals

Metodo ResultObjEquals

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj Object

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe ResultObj
Namespace DedNet.Core


Metodo ResultObj.GetDiscrimValue

Metodo ResultObjGetDiscrimValue
REstituisce il valore del campo discriminante

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object GetDiscrimValue(
    string name
)
Public Function GetDiscrimValue (
    name As String
) As Object
public:
Object^ GetDiscrimValue(
    String^ name
)
member GetDiscrimValue :
        name : string -> Object

Parametri

name String
Nome del campo discriminante da leggere

Valore di ritorno

Object
Vedi anche

Documentazione

Classe ResultObj
Namespace DedNet.Core


Metodo ResultObj.GetHashCode

Metodo ResultObjGetHashCode

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe ResultObj
Namespace DedNet.Core


Metodo ResultObj.GetValue

Metodo ResultObjGetValue
Restituisce il valore del campo passato dell'oggetto base

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object GetValue(
    string name
)
Public Function GetValue (
    name As String
) As Object
public:
Object^ GetValue(
    String^ name
)
member GetValue :
        name : string -> Object

Parametri

name String
Nome dell'attributo da leggere

Valore di ritorno

Object
Vedi anche

Documentazione

Classe ResultObj
Namespace DedNet.Core


Classe ResultOperationOnStructObject
Classe usata per gestire i risultati nei comandi di CheckIn Struttura, CheckOut Struttura, CheckIn Struttura con Associati e CheckOut Struttura con Associati
Gerarchia di ereditarietà
SystemObject
DedNet.CoreResultOperationOnStructObject

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ResultOperationOnStructObject
Public Class ResultOperationOnStructObject
public ref class ResultOperationOnStructObject
type ResultOperationOnStructObject = class end

Il tipo ResultOperationOnStructObject espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ResultOperationOnStructObject | Costruttore
Metodo pubblico | ResultOperationOnStructObject(Boolean, String) | Costruttore con parametri
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Error | Eccezione da visualizzare
Proprietà pubblica | IsOk | Risultato del comando. Di default viene impostato a True.
Proprietà pubblica | Message | Messaggio da visualizzare
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore ResultOperationOnStructObject
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | ResultOperationOnStructObject | Costruttore
Metodo pubblico | ResultOperationOnStructObject(Boolean, String) | Costruttore con parametri
Torna su
Vedi anche

Documentazione

Classe ResultOperationOnStructObject
Namespace DedNet.Core


Costruttore ResultOperationOnStructObject
Costruttore

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ResultOperationOnStructObject()
Public Sub New
public:
ResultOperationOnStructObject()
new : unit -> ResultOperationOnStructObject
Vedi anche

Documentazione

Classe ResultOperationOnStructObject
Overload di ResultOperationOnStructObject
Namespace DedNet.Core


Costruttore ResultOperationOnStructObject(Boolean, String)
Costruttore con parametri

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ResultOperationOnStructObject(
    bool isOk,
    string message
)
Public Sub New (
    isOk As Boolean,
    message As String
)
public:
ResultOperationOnStructObject(
    bool isOk,
    String^ message
)
new :
        isOk : bool *
        message : string -> ResultOperationOnStructObject

Parametri

isOk Boolean
Identifica il risultato dell'operazione
message String
Messaggio da visualizzare
Vedi anche

Documentazione

Classe ResultOperationOnStructObject
Overload di ResultOperationOnStructObject
Namespace DedNet.Core


Proprietà di ResultOperationOnStructObject

Il tipo ResultOperationOnStructObject espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Error | Eccezione da visualizzare
Proprietà pubblica | IsOk | Risultato del comando. Di default viene impostato a True.
Proprietà pubblica | Message | Messaggio da visualizzare
Torna su
Vedi anche

Documentazione

Classe ResultOperationOnStructObject
Namespace DedNet.Core


Proprietà ResultOperationOnStructObject.Error

Proprietà ResultOperationOnStructObjectError
Eccezione da visualizzare

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Exception Error { get; set; }
Public Property Error As Exception
    Get
    Set
public:
property Exception^ Error {
    Exception^ get ();
    void set (Exception^ value);
}
member Error : Exception with get, set

Valore della proprietà

Exception
Vedi anche

Documentazione

Classe ResultOperationOnStructObject
Namespace DedNet.Core


Proprietà ResultOperationOnStructObject.IsOk

Proprietà ResultOperationOnStructObjectIsOk
Risultato del comando. Di default viene impostato a True.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsOk { get; set; }
Public Property IsOk As Boolean
    Get
    Set
public:
property bool IsOk {
    bool get ();
    void set (bool value);
}
member IsOk : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ResultOperationOnStructObject
Namespace DedNet.Core


Proprietà ResultOperationOnStructObject.Message

Proprietà ResultOperationOnStructObjectMessage
Messaggio da visualizzare

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Message { get; set; }
Public Property Message As String
    Get
    Set
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}
member Message : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe ResultOperationOnStructObject
Namespace DedNet.Core


Enumerazione RuleStateEnum
Enumerazione con lo stato di attivazione della regola

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum RuleStateEnum
Public Enumeration RuleStateEnum
public enum class RuleStateEnum
type RuleStateEnum
Membri
Nome | Valore | Descrizione
Disabled | 0 | Regola disabilitata
Enabled | 1 | Regola abilitata
Vedi anche

Documentazione

Namespace DedNet.Core


Classe SparePartsUtilities
Classe utilizza che espone utilità generali per configurare gli attributi di ricambio. Non è stata esposta nella classe DedNet.Core.Utility per non sporcarla.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreSparePartsUtilities

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static class SparePartsUtilities
Public NotInheritable Class SparePartsUtilities
public ref class SparePartsUtilities abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SparePartsUtilities = class end

Il tipo SparePartsUtilities espone i seguenti membri.

Metodi
Nome | Descrizione
AddSparePartBom | Aggiunge al file TopBom.ini la 'Distinta DB ricambi'.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Metodi di SparePartsUtilities

Il tipo SparePartsUtilities espone i seguenti membri.

Metodi
Nome | Descrizione
AddSparePartBom | Aggiunge al file TopBom.ini la 'Distinta DB ricambi'.
Torna su
Vedi anche

Documentazione

Classe SparePartsUtilities
Namespace DedNet.Core


Metodo SparePartsUtilities.AddSparePartBom

Metodo SparePartsUtilitiesAddSparePartBom
Aggiunge al file TopBom.ini la 'Distinta DB ricambi'.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool AddSparePartBom(
    string envPath,
    bool cad2D
)
Public Shared Function AddSparePartBom (
    envPath As String,
    cad2D As Boolean
) As Boolean
public:
static bool AddSparePartBom(
    String^ envPath,
    bool cad2D
)
static member AddSparePartBom :
        envPath : string *
        cad2D : bool -> bool

Parametri

envPath String
Percorso dell'ambiente corrente.
cad2D Boolean
Indica se il CAD che sta richiamando la funzione è un CAD 2D o meno.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe SparePartsUtilities
Namespace DedNet.Core


Classe StatoRecord
Classe contenente le informazioni necessarie all'identificazione dello stato di un record.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreStatoRecord

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class StatoRecord
Public Class StatoRecord
public ref class StatoRecord
type StatoRecord = class end

Il tipo StatoRecord espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | DbIndex | Restituisce l'indice originario del record.
Proprietà pubblica | Stato | Restituisce lo stato del record.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | SetErased | Imposta come modificato l'oggetto.
Metodo pubblico | SetModified | Imposta come modificato l'oggetto.
Metodo pubblico | SetNewElement | Imposta come modificato l'oggetto.
Metodo pubblico | SetUnModified | Imposta come non modificato l'oggetto.
Torna su
Campi
 | Nome | Descrizione
Campo protetto | _dbIndex | Indice da utilizzare per aggiornare il record.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di StatoRecord

Il tipo StatoRecord espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | DbIndex | Restituisce l'indice originario del record.
Proprietà pubblica | Stato | Restituisce lo stato del record.
Torna su
Vedi anche

Documentazione

Classe StatoRecord
Namespace DedNet.Core


Proprietà StatoRecord.DbIndex

Proprietà StatoRecordDbIndex
Restituisce l'indice originario del record.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object DbIndex { get; }
Public ReadOnly Property DbIndex As Object
    Get
public:
property Object^ DbIndex {
    Object^ get ();
}
member DbIndex : Object with get

Valore della proprietà

Object
Vedi anche

Documentazione

Classe StatoRecord
Namespace DedNet.Core


Proprietà StatoRecord.Stato

Proprietà StatoRecordStato
Restituisce lo stato del record.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public StatoRecordEnum Stato { get; }
Public ReadOnly Property Stato As StatoRecordEnum
    Get
public:
property StatoRecordEnum Stato {
    StatoRecordEnum get ();
}
member Stato : StatoRecordEnum with get

Valore della proprietà

StatoRecordEnum
Vedi anche

Documentazione

Classe StatoRecord
Namespace DedNet.Core


Metodi di StatoRecord

Il tipo StatoRecord espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | SetErased | Imposta come modificato l'oggetto.
Metodo pubblico | SetModified | Imposta come modificato l'oggetto.
Metodo pubblico | SetNewElement | Imposta come modificato l'oggetto.
Metodo pubblico | SetUnModified | Imposta come non modificato l'oggetto.
Torna su
Vedi anche

Documentazione

Classe StatoRecord
Namespace DedNet.Core


Metodo StatoRecord.SetErased

Metodo StatoRecordSetErased
Imposta come modificato l'oggetto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetErased()
Public Sub SetErased
public:
void SetErased()
member SetErased : unit -> unit
Vedi anche

Documentazione

Classe StatoRecord
Namespace DedNet.Core


Metodo StatoRecord.SetModified

Metodo StatoRecordSetModified
Imposta come modificato l'oggetto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetModified()
Public Sub SetModified
public:
void SetModified()
member SetModified : unit -> unit
Vedi anche

Documentazione

Classe StatoRecord
Namespace DedNet.Core


Metodo StatoRecord.SetNewElement

Metodo StatoRecordSetNewElement
Imposta come modificato l'oggetto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetNewElement()
Public Sub SetNewElement
public:
void SetNewElement()
member SetNewElement : unit -> unit
Vedi anche

Documentazione

Classe StatoRecord
Namespace DedNet.Core


Metodo StatoRecord.SetUnModified

Metodo StatoRecordSetUnModified
Imposta come non modificato l'oggetto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetUnModified()
Public Sub SetUnModified
public:
void SetUnModified()
member SetUnModified : unit -> unit
Vedi anche

Documentazione

Classe StatoRecord
Namespace DedNet.Core


Campi di StatoRecord

Il tipo StatoRecord espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | _dbIndex | Indice da utilizzare per aggiornare il record.
Torna su
Vedi anche

Documentazione

Classe StatoRecord
Namespace DedNet.Core


Campo StatoRecord._dbIndex

Campo StatoRecord_dbIndex
Indice da utilizzare per aggiornare il record.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected Object _dbIndex
Protected _dbIndex As Object
protected:
Object^ _dbIndex
val mutable _dbIndex: Object

Valore del campo

Object
Vedi anche

Documentazione

Classe StatoRecord
Namespace DedNet.Core


Enumerazione StatoRecordEnum
Definisce lo stato corrente di un record.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum StatoRecordEnum
Public Enumeration StatoRecordEnum
public enum class StatoRecordEnum
type StatoRecordEnum
Membri
Nome | Valore | Descrizione
UnModified | 0 | Stato del record appena letto dal Database o comunque allineato con il Database.
NewElement | 1 | Stato del record quando è da aggiungere al Database.
Modified | 2 | Stato del record quando è da aggiornare nel Database.
Erased | 3 | Stato del record quando è da eliminare dal Database.
NewAndErased | 4 | Stato del record quando è stato creato nuovo e poi eliminato, quindi è da ignorare come NonModificato ma non è più da visualizzare all'utente.
Vedi anche

Documentazione

Namespace DedNet.Core


Classe TokenInfo
Racchiude le informazioni di un singolo elemento componente una stringa di codifica o comunque una stringa composta da tasselli di sostituzione.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreTokenInfo

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class TokenInfo
Public Class TokenInfo
public ref class TokenInfo
type TokenInfo = class end

Il tipo TokenInfo espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | TokenInfo | Costruttore che permette, dato un token di inizializzare tutti i campi dell'oggetto.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AbsLength | Restituisce il numero di caratteri coinvolti dalla sostituzione del tassello in valore assoluto (sempre positivo). Di default è 0.
Proprietà pubblica | AbsoluteIdx | Restituisce l'indice del carattere iniziale del token all'interno della stringa finale. E' calcolato sommando le lunghezze (in valore assoluto) dei token che lo precedono nella lista.
Proprietà pubblica | Index | Restituisce l'indice (zero-based index) di questo elemento nella stringa di codifica.
Proprietà pubblica | IsValid | Restituisce true se questo oggetto è stato inizializzato con un token valido altrimenti false. Desume che il token sia valido se è stato assegnato il TokenType.
Proprietà pubblica | Length | Restituisce il numero di caratteri coinvolti dalla sostituzione del tassello. Se questo valore è negativo si intende che si debbano prendere a partire dalla fine della stringa di sostituzione. Di default è 0.
Proprietà pubblica | Level | Restituisce il livello della famiglia di riferimento. Se non specificato ha valore -1;
Proprietà pubblica | Name | In alcuni casi restituisce il nome del tassello. Es: "F", "P", "R", ecc; Altrimenti, nel caso degli attributi, restituisce il nome dell'attributo. Es: "CODICE", "DESCRIZIONE", ecc.
Proprietà pubblica | StartFrom | Restituisce il carattere di partenza della sostituzione. Di default è 0.
Proprietà pubblica | Token | Restituisce il token originale completo.
Proprietà pubblica | TokenType | Restituisce il tipo di token.
Proprietà pubblica | Value | Restituisce o imposta il valore di sostituzione del token.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore TokenInfo
Costruttore che permette, dato un token di inizializzare tutti i campi dell'oggetto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public TokenInfo(
    DedTypeBase fam,
    string token,
    int index,
    int absoluteIdx
)
Public Sub New (
    fam As DedTypeBase,
    token As String,
    index As Integer,
    absoluteIdx As Integer
)
public:
TokenInfo(
    DedTypeBase^ fam,
    String^ token,
    int index,
    int absoluteIdx
)
new :
        fam : DedTypeBase *
        token : string *
        index : int *
        absoluteIdx : int -> TokenInfo

Parametri

fam DedTypeBase
Famiglia di appartenenza della codifica
token String
Token del quale si desidera ottenere tutte le informazioni.
index Int32
Indice ordinale (base 0) dell'elemento rispetto la stringa di sostituzione.
absoluteIdx Int32
Indice del carattere iniziale del token all'interno della stringa finale.
Vedi anche

Documentazione

Classe TokenInfo
Namespace DedNet.Core


Proprietà di TokenInfo

Il tipo TokenInfo espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AbsLength | Restituisce il numero di caratteri coinvolti dalla sostituzione del tassello in valore assoluto (sempre positivo). Di default è 0.
Proprietà pubblica | AbsoluteIdx | Restituisce l'indice del carattere iniziale del token all'interno della stringa finale. E' calcolato sommando le lunghezze (in valore assoluto) dei token che lo precedono nella lista.
Proprietà pubblica | Index | Restituisce l'indice (zero-based index) di questo elemento nella stringa di codifica.
Proprietà pubblica | IsValid | Restituisce true se questo oggetto è stato inizializzato con un token valido altrimenti false. Desume che il token sia valido se è stato assegnato il TokenType.
Proprietà pubblica | Length | Restituisce il numero di caratteri coinvolti dalla sostituzione del tassello. Se questo valore è negativo si intende che si debbano prendere a partire dalla fine della stringa di sostituzione. Di default è 0.
Proprietà pubblica | Level | Restituisce il livello della famiglia di riferimento. Se non specificato ha valore -1;
Proprietà pubblica | Name | In alcuni casi restituisce il nome del tassello. Es: "F", "P", "R", ecc; Altrimenti, nel caso degli attributi, restituisce il nome dell'attributo. Es: "CODICE", "DESCRIZIONE", ecc.
Proprietà pubblica | StartFrom | Restituisce il carattere di partenza della sostituzione. Di default è 0.
Proprietà pubblica | Token | Restituisce il token originale completo.
Proprietà pubblica | TokenType | Restituisce il tipo di token.
Proprietà pubblica | Value | Restituisce o imposta il valore di sostituzione del token.
Torna su
Vedi anche

Documentazione

Classe TokenInfo
Namespace DedNet.Core


Proprietà TokenInfo.AbsLength

Proprietà TokenInfoAbsLength
Restituisce il numero di caratteri coinvolti dalla sostituzione del tassello in valore assoluto (sempre positivo). Di default è 0.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int AbsLength { get; }
Public ReadOnly Property AbsLength As Integer
    Get
public:
property int AbsLength {
    int get ();
}
member AbsLength : int with get

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe TokenInfo
Namespace DedNet.Core


Proprietà TokenInfo.AbsoluteIdx

Proprietà TokenInfoAbsoluteIdx
Restituisce l'indice del carattere iniziale del token all'interno della stringa finale. E' calcolato sommando le lunghezze (in valore assoluto) dei token che lo precedono nella lista.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int AbsoluteIdx { get; }
Public ReadOnly Property AbsoluteIdx As Integer
    Get
public:
property int AbsoluteIdx {
    int get ();
}
member AbsoluteIdx : int with get

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe TokenInfo
Namespace DedNet.Core


Proprietà TokenInfo.Index

Proprietà TokenInfoIndex
Restituisce l'indice (zero-based index) di questo elemento nella stringa di codifica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int Index { get; }
Public ReadOnly Property Index As Integer
    Get
public:
property int Index {
    int get ();
}
member Index : int with get

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe TokenInfo
Namespace DedNet.Core


Proprietà TokenInfo.IsValid

Proprietà TokenInfoIsValid
Restituisce true se questo oggetto è stato inizializzato con un token valido altrimenti false. Desume che il token sia valido se è stato assegnato il TokenType.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsValid { get; }
Public ReadOnly Property IsValid As Boolean
    Get
public:
property bool IsValid {
    bool get ();
}
member IsValid : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe TokenInfo
Namespace DedNet.Core


Proprietà TokenInfo.Length

Proprietà TokenInfoLength
Restituisce il numero di caratteri coinvolti dalla sostituzione del tassello. Se questo valore è negativo si intende che si debbano prendere a partire dalla fine della stringa di sostituzione. Di default è 0.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int Length { get; }
Public ReadOnly Property Length As Integer
    Get
public:
property int Length {
    int get ();
}
member Length : int with get

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe TokenInfo
Namespace DedNet.Core


Proprietà TokenInfo.Level

Proprietà TokenInfoLevel
Restituisce il livello della famiglia di riferimento. Se non specificato ha valore -1;

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int Level { get; }
Public ReadOnly Property Level As Integer
    Get
public:
property int Level {
    int get ();
}
member Level : int with get

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe TokenInfo
Namespace DedNet.Core


Proprietà TokenInfo.Name

Proprietà TokenInfoName
In alcuni casi restituisce il nome del tassello. Es: "F", "P", "R", ecc; Altrimenti, nel caso degli attributi, restituisce il nome dell'attributo. Es: "CODICE", "DESCRIZIONE", ecc.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe TokenInfo
Namespace DedNet.Core


Proprietà TokenInfo.StartFrom

Proprietà TokenInfoStartFrom
Restituisce il carattere di partenza della sostituzione. Di default è 0.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int StartFrom { get; }
Public ReadOnly Property StartFrom As Integer
    Get
public:
property int StartFrom {
    int get ();
}
member StartFrom : int with get

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe TokenInfo
Namespace DedNet.Core


Proprietà TokenInfo.Token

Proprietà TokenInfoToken
Restituisce il token originale completo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Token { get; }
Public ReadOnly Property Token As String
    Get
public:
property String^ Token {
    String^ get ();
}
member Token : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe TokenInfo
Namespace DedNet.Core


Proprietà TokenInfo.TokenType

Proprietà TokenInfoTokenType
Restituisce il tipo di token.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public TokenTypeEnum TokenType { get; }
Public ReadOnly Property TokenType As TokenTypeEnum
    Get
public:
property TokenTypeEnum TokenType {
    TokenTypeEnum get ();
}
member TokenType : TokenTypeEnum with get

Valore della proprietà

TokenTypeEnum
Vedi anche

Documentazione

Classe TokenInfo
Namespace DedNet.Core


Proprietà TokenInfo.Value

Proprietà TokenInfoValue
Restituisce o imposta il valore di sostituzione del token.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}
member Value : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe TokenInfo
Namespace DedNet.Core


Metodi di TokenInfo

Il tipo TokenInfo espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Torna su
Vedi anche

Documentazione

Classe TokenInfo
Namespace DedNet.Core


Metodo TokenInfo.Equals

Metodo TokenInfoEquals

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj Object

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe TokenInfo
Namespace DedNet.Core


Metodo TokenInfo.GetHashCode

Metodo TokenInfoGetHashCode

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe TokenInfo
Namespace DedNet.Core


Metodo TokenInfo.ToString

Metodo TokenInfoToString

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe TokenInfo
Namespace DedNet.Core


Classe TokenInfoList
Questa lista non è semplicemente una lista di oggetti TokenInfo. Tramite il costruttore si auto-costruisce sulla stringa di codifica in modo da essere composta da tutti i token validi trovati al suo interno.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreTokenInfoList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class TokenInfoList : IEnumerable<TokenInfo>,
    IEnumerable
Public Class TokenInfoList
    Implements IEnumerable(Of TokenInfo), IEnumerable
public ref class TokenInfoList : IEnumerable<TokenInfo^>,
    IEnumerable
type TokenInfoList =
    class
        interface IEnumerable<TokenInfo>
        interface IEnumerable
    end

Il tipo TokenInfoList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | TokenInfoList | Inizializza la lista con l'insieme dei token letti dalla stringa di codifica.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | CodeString | Restituisce la stringa di codifica con la quale è stata creata questa lista di token.
Proprietà pubblica | Count | Restituisce il numero di elementi presenti.
Proprietà pubblica | Item | Restituisce l'elemento iesimo della lista.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Contains | Verifica l'esistenza di un elemento nella lista.
Metodo pubblico | GetEnumerator | Restituisce l'enumeratore.
Metodo pubblico | GetFirstTokenOf | Restituisce il primo token trovato appartenente ad una particolare tipologia. Se non lo trova restituisce null.
Metodo pubblico | GetTokenCount | Restituisce il numero di tasselli presenti nella lista, relativamente ad un particolare tipo.
Metodo pubblico | GetTokens | Restituisce la lista dei token appartenenti ad un particolare tipo. Restituisce sempre una lista inizializzata ma vuota se non sono stati trovati token del tipo specificato.
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | IEnumerableGetEnumerator | Restituisce l'enumeratore.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore TokenInfoList
Inizializza la lista con l'insieme dei token letti dalla stringa di codifica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public TokenInfoList(
    DedTypeBase fam,
    string codeString
)
Public Sub New (
    fam As DedTypeBase,
    codeString As String
)
public:
TokenInfoList(
    DedTypeBase^ fam,
    String^ codeString
)
new :
        fam : DedTypeBase *
        codeString : string -> TokenInfoList

Parametri

fam DedTypeBase
Famiglia di appartenenza della codifica
codeString String
Stringa di codifica con la quale inizializzare la lista.
Vedi anche

Documentazione

Classe TokenInfoList
Namespace DedNet.Core


Proprietà di TokenInfoList

Il tipo TokenInfoList espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CodeString | Restituisce la stringa di codifica con la quale è stata creata questa lista di token.
Proprietà pubblica | Count | Restituisce il numero di elementi presenti.
Proprietà pubblica | Item | Restituisce l'elemento iesimo della lista.
Torna su
Vedi anche

Documentazione

Classe TokenInfoList
Namespace DedNet.Core


Proprietà TokenInfoList.CodeString

Proprietà TokenInfoListCodeString
Restituisce la stringa di codifica con la quale è stata creata questa lista di token.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string CodeString { get; }
Public ReadOnly Property CodeString As String
    Get
public:
property String^ CodeString {
    String^ get ();
}
member CodeString : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe TokenInfoList
Namespace DedNet.Core


Proprietà TokenInfoList.Count

Proprietà TokenInfoListCount
Restituisce il numero di elementi presenti.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
public:
property int Count {
    int get ();
}
member Count : int with get

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe TokenInfoList
Namespace DedNet.Core


Proprietà TokenInfoList.Item

Proprietà TokenInfoListItem
Restituisce l'elemento iesimo della lista.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public TokenInfo this[
    int idx
] { get; }
Public ReadOnly Default Property Item (
    idx As Integer
) As TokenInfo
    Get
public:
property TokenInfo^ default[int idx] {
    TokenInfo^ get (int idx);
}
member Item : TokenInfo with get

Parametri

idx Int32
Indice dell'elemento da restituire.

Valore di ritorno

TokenInfo
Restituisce l'elemento trovato oppure solleva una eccezione se l'indice è fuori dal range.
Vedi anche

Documentazione

Classe TokenInfoList
Namespace DedNet.Core


Metodi di TokenInfoList

Il tipo TokenInfoList espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Contains | Verifica l'esistenza di un elemento nella lista.
Metodo pubblico | GetEnumerator | Restituisce l'enumeratore.
Metodo pubblico | GetFirstTokenOf | Restituisce il primo token trovato appartenente ad una particolare tipologia. Se non lo trova restituisce null.
Metodo pubblico | GetTokenCount | Restituisce il numero di tasselli presenti nella lista, relativamente ad un particolare tipo.
Metodo pubblico | GetTokens | Restituisce la lista dei token appartenenti ad un particolare tipo. Restituisce sempre una lista inizializzata ma vuota se non sono stati trovati token del tipo specificato.
Metodo pubblico | ToString | (Sovrascrive ObjectToString)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | IEnumerableGetEnumerator | Restituisce l'enumeratore.
Torna su
Vedi anche

Documentazione

Classe TokenInfoList
Namespace DedNet.Core


Metodo TokenInfoList.Contains

Metodo TokenInfoListContains
Verifica l'esistenza di un elemento nella lista.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Contains(
    TokenInfo item
)
Public Function Contains (
    item As TokenInfo
) As Boolean
public:
bool Contains(
    TokenInfo^ item
)
member Contains :
        item : TokenInfo -> bool

Parametri

item TokenInfo
Elemento da verificare.

Valore di ritorno

Boolean
Restituisce true se trova l'elemento altrimenti false.
Vedi anche

Documentazione

Classe TokenInfoList
Namespace DedNet.Core


Metodo TokenInfoList.GetEnumerator

Metodo TokenInfoListGetEnumerator
Restituisce l'enumeratore.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public IEnumerator<TokenInfo> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of TokenInfo)
public:
virtual IEnumerator<TokenInfo^>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<TokenInfo>
override GetEnumerator : unit -> IEnumerator<TokenInfo>

Valore di ritorno

IEnumerator TokenInfo
Restituisce l'enumeratore.

Implementa

IEnumerableTGetEnumerator
Vedi anche

Documentazione

Classe TokenInfoList
Namespace DedNet.Core


Metodo TokenInfoList.GetFirstTokenOf

Metodo TokenInfoListGetFirstTokenOf
Restituisce il primo token trovato appartenente ad una particolare tipologia. Se non lo trova restituisce null.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public TokenInfo GetFirstTokenOf(
    TokenTypeEnum type
)
Public Function GetFirstTokenOf (
    type As TokenTypeEnum
) As TokenInfo
public:
TokenInfo^ GetFirstTokenOf(
    TokenTypeEnum type
)
member GetFirstTokenOf :
        type : TokenTypeEnum -> TokenInfo

Parametri

type TokenTypeEnum
Tipo di token di interesse.

Valore di ritorno

TokenInfo
Restituisce il primo elemento trovato oppure null se non ne trova.
Vedi anche

Documentazione

Classe TokenInfoList
Namespace DedNet.Core


Metodo TokenInfoList.GetTokenCount

Metodo TokenInfoListGetTokenCount
Restituisce il numero di tasselli presenti nella lista, relativamente ad un particolare tipo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int GetTokenCount(
    TokenTypeEnum type
)
Public Function GetTokenCount (
    type As TokenTypeEnum
) As Integer
public:
int GetTokenCount(
    TokenTypeEnum type
)
member GetTokenCount :
        type : TokenTypeEnum -> int

Parametri

type TokenTypeEnum
Tipo di token di interesse.

Valore di ritorno

Int32
Restituisce il numero di token trovati di un particolare tipo oppure 0 se non ne ha trovati.
Vedi anche

Documentazione

Classe TokenInfoList
Namespace DedNet.Core


Metodo TokenInfoList.GetTokens

Metodo TokenInfoListGetTokens
Restituisce la lista dei token appartenenti ad un particolare tipo. Restituisce sempre una lista inizializzata ma vuota se non sono stati trovati token del tipo specificato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<TokenInfo> GetTokens(
    TokenTypeEnum type
)
Public Function GetTokens (
    type As TokenTypeEnum
) As List(Of TokenInfo)
public:
List<TokenInfo^>^ GetTokens(
    TokenTypeEnum type
)
member GetTokens :
        type : TokenTypeEnum -> List<TokenInfo>

Parametri

type TokenTypeEnum
Tipo di token da restituire.

Valore di ritorno

List TokenInfo
Restituisce la lista dei token trovati oppure una lista vuota se non ce ne sono.
Vedi anche

Documentazione

Classe TokenInfoList
Namespace DedNet.Core


Metodo TokenInfoList.IEnumerable.GetEnumerator

Metodo TokenInfoListIEnumerableGetEnumerator
Restituisce l'enumeratore.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
IEnumerator IEnumerable.GetEnumerator()
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
private abstract GetEnumerator : unit -> IEnumerator
private override GetEnumerator : unit -> IEnumerator

Valore di ritorno

IEnumerator
Restituisce l'enumeratore.

Implementa

IEnumerableGetEnumerator
Vedi anche

Documentazione

Classe TokenInfoList
Namespace DedNet.Core


Metodo TokenInfoList.ToString

Metodo TokenInfoListToString

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe TokenInfoList
Namespace DedNet.Core


Enumerazione TokenTypeEnum
Enumerazione delle tipologia di tassello di codifica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum TokenTypeEnum
Public Enumeration TokenTypeEnum
public enum class TokenTypeEnum
type TokenTypeEnum
Membri
Nome | Valore | Descrizione
None | 0 | Non definito.
NomeFamiglia | 1 | Nome della famiglia.
DescizioneFamiglia | 2 | Descrizione della famiglia.
Attributo | 3 | Attributo.
Progressivo | 4 | Progressivo.
Revisione | 5 | Revisione.
Utente | 6 | Tassello utente.
Variante | 7 | Tassello variante.
Formato | 8 | Formato del cartiglio.
LuaFunc | 9 | Funzione LUA personalizzata.
Vedi anche

Documentazione

Namespace DedNet.Core


Enumerazione TranslationDiscrimEnum
Enum utilizzato per identificare il tipo di traduzione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum TranslationDiscrimEnum
Public Enumeration TranslationDiscrimEnum
public enum class TranslationDiscrimEnum
type TranslationDiscrimEnum
Membri
Nome | Valore | Descrizione
Anagrafica | 0 | Traduzione associata ad una anagrafica.
Attributo | 1 | Traduzione associata ad un attributo.
Custom | 2 | Traduzione associata ad un testo.
Vedi anche

Documentazione

Namespace DedNet.Core


Classe UserPermManager
Classe per la gestione dei permessi e degli utenti/gruppi.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreUserPermManager

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class UserPermManager
Public Class UserPermManager
public ref class UserPermManager
type UserPermManager = class end

Il tipo UserPermManager espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione di appartenenza.
Proprietà pubblica | Dirty | Restitusice se si sia stata modificata la struttura degli utenti e permessi.
Proprietà pubblica | Groups | Restitusice la lista dei gruppi disponibili.
Proprietà pubblica | PermSet | Restituisce il set di permessi presenti.
Proprietà pubblica | Users | Restitusice la lista degli utenti disponibili.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | FindOwnerByEmail | Restituisce l'utente avente l'email specificata oppure null se non riesce a trovarlo.
Metodo pubblico | FindOwnerByName | Restituisce l'utente o il gruppo avente il nome interno specificato oppure null se non riesce a trovarlo.
Metodo pubblico | FindOwnerByNameVis | Restituisce l'utente o il gruppo avente il nome visualizzato specificato oppure null se non riesce a trovarlo.
Metodo pubblico | GetAttrOwnerPermSet | Restitusice il set di permessi abbinati ad una famiglia per uno specifico utente/gruppo. Restitusice un set di permessi inizializzato ma vuoto se l'utente/gruppo non era già abbinato alla famiglia.
Metodo pubblico | GetAttrOwners | Restituisce la lista degli owners per i quali sono presenti dei permessi specifici per un attributo. Restituisce sempre una lista inaizializzata.
 | GetAttrPtipo | Restituisce il valore della colonna PTIPO dei permessi sugli attributi per il tipo passato.
Metodo pubblico | GetCommOwnerPermSet | Restitusice il set di permessi abbinati ad una famiglia per uno specifico utente/gruppo. Restitusice un set di permessi inizializzato ma vuoto se l'utente/gruppo non era già abbinato alla famiglia.
Metodo pubblico | GetCommOwners | Restituisce la lista degli owners per i quali sono presenti dei permessi specifici per una particolare famiglia. Restituisce sempre una lista inaizializzata.
Metodo pubblico | GetFamOwnerPermSet | Restitusice il set di permessi abbinati ad una famiglia per uno specifico utente/gruppo. Restitusice un set di permessi inizializzato ma vuoto se l'utente/gruppo non era già abbinato alla famiglia.
Metodo pubblico | GetFamOwners | Restituisce la lista degli owners per i quali sono presenti dei permessi specifici per una particolare famiglia. Restituisce sempre una lista inaizializzata.
Metodo pubblico | GetFolderOwnerPermSet | Restitusice il set di permessi abbinati ad una famiglia per uno specifico utente/gruppo. Restitusice un set di permessi inizializzato ma vuoto se l'utente/gruppo non era già abbinato alla famiglia.
Metodo pubblico | GetFolderOwners | Restituisce la lista degli owners per i quali sono presenti dei permessi specifici per una particolare famiglia. Restituisce sempre una lista inaizializzata.
 | GetPtipo | Restituisce il valore della colonna PTIPO dei permessi sulle famiglie per il tipo passato.
Metodo pubblico | RemoveAttrOwner | Rimuove i permessi specifici di una famiglia, abbinati ad un utente/gruppo.
Metodo pubblico | RemoveAttrsOwner | Rimuove i permessi specifici di un attributo, abbinati ad un utente/gruppo.
Metodo pubblico | RemoveCommOwner | Rimuove i permessi specifici di una famiglia, abbinati ad un utente/gruppo.
Metodo pubblico | RemoveFamOwner | Rimuove i permessi specifici di una famiglia, abbinati ad un utente/gruppo.
Metodo pubblico | RemoveFolderOwner | Rimuove i permessi specifici di una famiglia, abbinati ad un utente/gruppo.
Metodo pubblico | ResetUserPerm | Funzione per azzerare i permessi ( in modo che li ricalcoli quando vengono richiesti )
Metodo pubblico | Save | Salva tutte le modifiche agli utenti e permessi.
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | OnProgressSaving | Evento chiamato durante la progressione del salvataggio.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di UserPermManager

Il tipo UserPermManager espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione di appartenenza.
Proprietà pubblica | Dirty | Restitusice se si sia stata modificata la struttura degli utenti e permessi.
Proprietà pubblica | Groups | Restitusice la lista dei gruppi disponibili.
Proprietà pubblica | PermSet | Restituisce il set di permessi presenti.
Proprietà pubblica | Users | Restitusice la lista degli utenti disponibili.
Torna su
Vedi anche

Documentazione

Classe UserPermManager
Namespace DedNet.Core


Proprietà UserPermManager.Application

Proprietà UserPermManagerApplication
Restituisce l'applicazione di appartenenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedNetApplication Application { get; }
Public ReadOnly Property Application As DedNetApplication
    Get
public:
property DedNetApplication^ Application {
    DedNetApplication^ get ();
}
member Application : DedNetApplication with get

Valore della proprietà

DedNetApplication
Vedi anche

Documentazione

Classe UserPermManager
Namespace DedNet.Core


Proprietà UserPermManager.Dirty

Proprietà UserPermManagerDirty
Restitusice se si sia stata modificata la struttura degli utenti e permessi.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Dirty { get; }
Public ReadOnly Property Dirty As Boolean
    Get
public:
property bool Dirty {
    bool get ();
}
member Dirty : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe UserPermManager
Namespace DedNet.Core


Proprietà UserPermManager.Groups

Proprietà UserPermManagerGroups
Restitusice la lista dei gruppi disponibili.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedGroupCollection Groups { get; }
Public ReadOnly Property Groups As DedGroupCollection
    Get
public:
property DedGroupCollection^ Groups {
    DedGroupCollection^ get ();
}
member Groups : DedGroupCollection with get

Valore della proprietà

DedGroupCollection
Vedi anche

Documentazione

Classe UserPermManager
Namespace DedNet.Core


Proprietà UserPermManager.PermSet

Proprietà UserPermManagerPermSet
Restituisce il set di permessi presenti.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public PermSet PermSet { get; }
Public ReadOnly Property PermSet As PermSet
    Get
public:
property PermSet^ PermSet {
    PermSet^ get ();
}
member PermSet : PermSet with get

Valore della proprietà

PermSet
Vedi anche

Documentazione

Classe UserPermManager
Namespace DedNet.Core


Proprietà UserPermManager.Users

Proprietà UserPermManagerUsers
Restitusice la lista degli utenti disponibili.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedUserCollection Users { get; }
Public ReadOnly Property Users As DedUserCollection
    Get
public:
property DedUserCollection^ Users {
    DedUserCollection^ get ();
}
member Users : DedUserCollection with get

Valore della proprietà

DedUserCollection
Vedi anche

Documentazione

Classe UserPermManager
Namespace DedNet.Core


Metodi di UserPermManager

Il tipo UserPermManager espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | FindOwnerByEmail | Restituisce l'utente avente l'email specificata oppure null se non riesce a trovarlo.
Metodo pubblico | FindOwnerByName | Restituisce l'utente o il gruppo avente il nome interno specificato oppure null se non riesce a trovarlo.
Metodo pubblico | FindOwnerByNameVis | Restituisce l'utente o il gruppo avente il nome visualizzato specificato oppure null se non riesce a trovarlo.
Metodo pubblico | GetAttrOwnerPermSet | Restitusice il set di permessi abbinati ad una famiglia per uno specifico utente/gruppo. Restitusice un set di permessi inizializzato ma vuoto se l'utente/gruppo non era già abbinato alla famiglia.
Metodo pubblico | GetAttrOwners | Restituisce la lista degli owners per i quali sono presenti dei permessi specifici per un attributo. Restituisce sempre una lista inaizializzata.
 | GetAttrPtipo | Restituisce il valore della colonna PTIPO dei permessi sugli attributi per il tipo passato.
Metodo pubblico | GetCommOwnerPermSet | Restitusice il set di permessi abbinati ad una famiglia per uno specifico utente/gruppo. Restitusice un set di permessi inizializzato ma vuoto se l'utente/gruppo non era già abbinato alla famiglia.
Metodo pubblico | GetCommOwners | Restituisce la lista degli owners per i quali sono presenti dei permessi specifici per una particolare famiglia. Restituisce sempre una lista inaizializzata.
Metodo pubblico | GetFamOwnerPermSet | Restitusice il set di permessi abbinati ad una famiglia per uno specifico utente/gruppo. Restitusice un set di permessi inizializzato ma vuoto se l'utente/gruppo non era già abbinato alla famiglia.
Metodo pubblico | GetFamOwners | Restituisce la lista degli owners per i quali sono presenti dei permessi specifici per una particolare famiglia. Restituisce sempre una lista inaizializzata.
Metodo pubblico | GetFolderOwnerPermSet | Restitusice il set di permessi abbinati ad una famiglia per uno specifico utente/gruppo. Restitusice un set di permessi inizializzato ma vuoto se l'utente/gruppo non era già abbinato alla famiglia.
Metodo pubblico | GetFolderOwners | Restituisce la lista degli owners per i quali sono presenti dei permessi specifici per una particolare famiglia. Restituisce sempre una lista inaizializzata.
 | GetPtipo | Restituisce il valore della colonna PTIPO dei permessi sulle famiglie per il tipo passato.
Metodo pubblico | RemoveAttrOwner | Rimuove i permessi specifici di una famiglia, abbinati ad un utente/gruppo.
Metodo pubblico | RemoveAttrsOwner | Rimuove i permessi specifici di un attributo, abbinati ad un utente/gruppo.
Metodo pubblico | RemoveCommOwner | Rimuove i permessi specifici di una famiglia, abbinati ad un utente/gruppo.
Metodo pubblico | RemoveFamOwner | Rimuove i permessi specifici di una famiglia, abbinati ad un utente/gruppo.
Metodo pubblico | RemoveFolderOwner | Rimuove i permessi specifici di una famiglia, abbinati ad un utente/gruppo.
Metodo pubblico | ResetUserPerm | Funzione per azzerare i permessi ( in modo che li ricalcoli quando vengono richiesti )
Metodo pubblico | Save | Salva tutte le modifiche agli utenti e permessi.
Torna su
Vedi anche

Documentazione

Classe UserPermManager
Namespace DedNet.Core


Metodo UserPermManager.FindOwnerByEmail

Metodo UserPermManagerFindOwnerByEmail
Restituisce l'utente avente l'email specificata oppure null se non riesce a trovarlo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedPermOwner FindOwnerByEmail(
    string email
)
Public Function FindOwnerByEmail (
    email As String
) As DedPermOwner
public:
DedPermOwner^ FindOwnerByEmail(
    String^ email
)
member FindOwnerByEmail :
        email : string -> DedPermOwner

Parametri

email String
Email utente da cercare.

Valore di ritorno

DedPermOwner
Vedi anche

Documentazione

Classe UserPermManager
Namespace DedNet.Core


Metodo UserPermManager.FindOwnerByName

Metodo UserPermManagerFindOwnerByName
Restituisce l'utente o il gruppo avente il nome interno specificato oppure null se non riesce a trovarlo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedPermOwner FindOwnerByName(
    string ownerName
)
Public Function FindOwnerByName (
    ownerName As String
) As DedPermOwner
public:
DedPermOwner^ FindOwnerByName(
    String^ ownerName
)
member FindOwnerByName :
        ownerName : string -> DedPermOwner

Parametri

ownerName String
Nome interno del gruppo o utente da cercare.

Valore di ritorno

DedPermOwner
Vedi anche

Documentazione

Classe UserPermManager
Namespace DedNet.Core


Metodo UserPermManager.FindOwnerByNameVis

Metodo UserPermManagerFindOwnerByNameVis
Restituisce l'utente o il gruppo avente il nome visualizzato specificato oppure null se non riesce a trovarlo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedPermOwner FindOwnerByNameVis(
    string nameVis
)
Public Function FindOwnerByNameVis (
    nameVis As String
) As DedPermOwner
public:
DedPermOwner^ FindOwnerByNameVis(
    String^ nameVis
)
member FindOwnerByNameVis :
        nameVis : string -> DedPermOwner

Parametri

nameVis String
Nome visualizzato del gruppo o utente da cercare.

Valore di ritorno

DedPermOwner
Vedi anche

Documentazione

Classe UserPermManager
Namespace DedNet.Core


Metodo UserPermManager.GetAttrOwnerPermSet

Metodo UserPermManagerGetAttrOwnerPermSet
Restitusice il set di permessi abbinati ad una famiglia per uno specifico utente/gruppo. Restitusice un set di permessi inizializzato ma vuoto se l'utente/gruppo non era già abbinato alla famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrPerm GetAttrOwnerPermSet(
    string attrName,
    DedTypeBase tp,
    string ownerName
)
Public Function GetAttrOwnerPermSet (
    attrName As String,
    tp As DedTypeBase,
    ownerName As String
) As DedAttrPerm
public:
DedAttrPerm^ GetAttrOwnerPermSet(
    String^ attrName,
    DedTypeBase^ tp,
    String^ ownerName
)
member GetAttrOwnerPermSet :
        attrName : string *
        tp : DedTypeBase *
        ownerName : string -> DedAttrPerm

Parametri

attrName String
Nome dell'attributo di cui si desidera il set di permessi.
tp DedTypeBase
ownerName String
Nome dell'utente o gruppo del quale avere il set di permessi.

Valore di ritorno

DedAttrPerm
Restitusice null se non sono presenti.
Vedi anche

Documentazione

Classe UserPermManager
Namespace DedNet.Core


Metodo UserPermManager.GetAttrOwners

Metodo UserPermManagerGetAttrOwners
Restituisce la lista degli owners per i quali sono presenti dei permessi specifici per un attributo. Restituisce sempre una lista inaizializzata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<DedPermOwner> GetAttrOwners(
    string attrName,
    DedTypeBase tp
)
Public Function GetAttrOwners (
    attrName As String,
    tp As DedTypeBase
) As List(Of DedPermOwner)
public:
List<DedPermOwner^>^ GetAttrOwners(
    String^ attrName,
    DedTypeBase^ tp
)
member GetAttrOwners :
        attrName : string *
        tp : DedTypeBase -> List<DedPermOwner>

Parametri

attrName String
Nome dell'attributo.
tp DedTypeBase

Valore di ritorno

List DedPermOwner
Restituisce sempre una lista inaizializzata.
Note
Inizializza la struttura del dizionario interno leggendo dal Database se non è ancora stato interrogato relativamente all'attributo richiesto.
Vedi anche

Documentazione

Classe UserPermManager
Namespace DedNet.Core


Metodo UserPermManager.GetAttrPtipo

Metodo UserPermManagerGetAttrPtipo
Restituisce il valore della colonna PTIPO dei permessi sugli attributi per il tipo passato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string GetAttrPtipo(
    DedTypeBase fam
)
Public Shared Function GetAttrPtipo (
    fam As DedTypeBase
) As String
public:
static String^ GetAttrPtipo(
    DedTypeBase^ fam
)
static member GetAttrPtipo :
        fam : DedTypeBase -> string

Parametri

fam DedTypeBase
Tipologia da valutare

Valore di ritorno

String
Vedi anche

Documentazione

Classe UserPermManager
Namespace DedNet.Core


Metodo UserPermManager.GetCommOwnerPermSet

Metodo UserPermManagerGetCommOwnerPermSet
Restitusice il set di permessi abbinati ad una famiglia per uno specifico utente/gruppo. Restitusice un set di permessi inizializzato ma vuoto se l'utente/gruppo non era già abbinato alla famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommPerm GetCommOwnerPermSet(
    Guid commId,
    string ownerName
)
Public Function GetCommOwnerPermSet (
    commId As Guid,
    ownerName As String
) As DedCommPerm
public:
DedCommPerm^ GetCommOwnerPermSet(
    Guid commId,
    String^ ownerName
)
member GetCommOwnerPermSet :
        commId : Guid *
        ownerName : string -> DedCommPerm

Parametri

commId Guid
ownerName String
Nome dell'utente o gruppo del quale avere il set di permessi.

Valore di ritorno

DedCommPerm
Restitusice null se non sono presenti.
Vedi anche

Documentazione

Classe UserPermManager
Namespace DedNet.Core


Metodo UserPermManager.GetCommOwners

Metodo UserPermManagerGetCommOwners
Restituisce la lista degli owners per i quali sono presenti dei permessi specifici per una particolare famiglia. Restituisce sempre una lista inaizializzata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<DedPermOwner> GetCommOwners(
    Guid commid
)
Public Function GetCommOwners (
    commid As Guid
) As List(Of DedPermOwner)
public:
List<DedPermOwner^>^ GetCommOwners(
    Guid commid
)
member GetCommOwners :
        commid : Guid -> List<DedPermOwner>

Parametri

commid Guid

Valore di ritorno

List DedPermOwner
Restituisce sempre una lista inaizializzata.
Note
Inizializza la struttura del dizionario interno leggendo dal Database se non è ancora stato interrogato relativamente alla famiglia richiesta.
Vedi anche

Documentazione

Classe UserPermManager
Namespace DedNet.Core


Metodo UserPermManager.GetFamOwnerPermSet

Metodo UserPermManagerGetFamOwnerPermSet
Restitusice il set di permessi abbinati ad una famiglia per uno specifico utente/gruppo. Restitusice un set di permessi inizializzato ma vuoto se l'utente/gruppo non era già abbinato alla famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFamPerm GetFamOwnerPermSet(
    DedTypeBase tp,
    string ownerName
)
Public Function GetFamOwnerPermSet (
    tp As DedTypeBase,
    ownerName As String
) As DedFamPerm
public:
DedFamPerm^ GetFamOwnerPermSet(
    DedTypeBase^ tp,
    String^ ownerName
)
member GetFamOwnerPermSet :
        tp : DedTypeBase *
        ownerName : string -> DedFamPerm

Parametri

tp DedTypeBase
ownerName String
Nome dell'utente o gruppo del quale avere il set di permessi.

Valore di ritorno

DedFamPerm
Restitusice null se non sono presenti.
Vedi anche

Documentazione

Classe UserPermManager
Namespace DedNet.Core


Metodo UserPermManager.GetFamOwners

Metodo UserPermManagerGetFamOwners
Restituisce la lista degli owners per i quali sono presenti dei permessi specifici per una particolare famiglia. Restituisce sempre una lista inaizializzata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<DedPermOwner> GetFamOwners(
    DedTypeBase tp
)
Public Function GetFamOwners (
    tp As DedTypeBase
) As List(Of DedPermOwner)
public:
List<DedPermOwner^>^ GetFamOwners(
    DedTypeBase^ tp
)
member GetFamOwners :
        tp : DedTypeBase -> List<DedPermOwner>

Parametri

tp DedTypeBase

Valore di ritorno

List DedPermOwner
Restituisce sempre una lista inaizializzata.
Note
Inizializza la struttura del dizionario interno leggendo dal Database se non è ancora stato interrogato relativamente alla famiglia richiesta.
Vedi anche

Documentazione

Classe UserPermManager
Namespace DedNet.Core


Metodo UserPermManager.GetFolderOwnerPermSet

Metodo UserPermManagerGetFolderOwnerPermSet
Restitusice il set di permessi abbinati ad una famiglia per uno specifico utente/gruppo. Restitusice un set di permessi inizializzato ma vuoto se l'utente/gruppo non era già abbinato alla famiglia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFolderPerm GetFolderOwnerPermSet(
    string folder,
    string ownerName
)
Public Function GetFolderOwnerPermSet (
    folder As String,
    ownerName As String
) As DedFolderPerm
public:
DedFolderPerm^ GetFolderOwnerPermSet(
    String^ folder,
    String^ ownerName
)
member GetFolderOwnerPermSet :
        folder : string *
        ownerName : string -> DedFolderPerm

Parametri

folder String
DbPath della famiglia della quale si desidera il set di permessi.
ownerName String
Nome dell'utente o gruppo del quale avere il set di permessi.

Valore di ritorno

DedFolderPerm
Restitusice null se non sono presenti.
Vedi anche

Documentazione

Classe UserPermManager
Namespace DedNet.Core


Metodo UserPermManager.GetFolderOwners

Metodo UserPermManagerGetFolderOwners
Restituisce la lista degli owners per i quali sono presenti dei permessi specifici per una particolare famiglia. Restituisce sempre una lista inaizializzata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<DedPermOwner> GetFolderOwners(
    string folder
)
Public Function GetFolderOwners (
    folder As String
) As List(Of DedPermOwner)
public:
List<DedPermOwner^>^ GetFolderOwners(
    String^ folder
)
member GetFolderOwners :
        folder : string -> List<DedPermOwner>

Parametri

folder String

Valore di ritorno

List DedPermOwner
Restituisce sempre una lista inaizializzata.
Note
Inizializza la struttura del dizionario interno leggendo dal Database se non è ancora stato interrogato relativamente alla famiglia richiesta.
Vedi anche

Documentazione

Classe UserPermManager
Namespace DedNet.Core


Metodo UserPermManager.GetPtipo

Metodo UserPermManagerGetPtipo
Restituisce il valore della colonna PTIPO dei permessi sulle famiglie per il tipo passato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string GetPtipo(
    DedTypeBase fam
)
Public Shared Function GetPtipo (
    fam As DedTypeBase
) As String
public:
static String^ GetPtipo(
    DedTypeBase^ fam
)
static member GetPtipo :
        fam : DedTypeBase -> string

Parametri

fam DedTypeBase
Tipologia da valutare

Valore di ritorno

String
Vedi anche

Documentazione

Classe UserPermManager
Namespace DedNet.Core


Metodo UserPermManager.RemoveAttrOwner

Metodo UserPermManagerRemoveAttrOwner
Rimuove i permessi specifici di una famiglia, abbinati ad un utente/gruppo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void RemoveAttrOwner(
    string attrName,
    DedTypeBase tp,
    string ownerName
)
Public Sub RemoveAttrOwner (
    attrName As String,
    tp As DedTypeBase,
    ownerName As String
)
public:
void RemoveAttrOwner(
    String^ attrName,
    DedTypeBase^ tp,
    String^ ownerName
)
member RemoveAttrOwner :
        attrName : string *
        tp : DedTypeBase *
        ownerName : string -> unit

Parametri

attrName String
Nome dell'attributo da cui si vuole eliminare l'owner.
tp DedTypeBase
ownerName String
Nome dell'owner da eliminare.
Vedi anche

Documentazione

Classe UserPermManager
Namespace DedNet.Core


Metodo UserPermManager.RemoveAttrsOwner

Metodo UserPermManagerRemoveAttrsOwner
Rimuove i permessi specifici di un attributo, abbinati ad un utente/gruppo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void RemoveAttrsOwner(
    string attr,
    string ownerName,
    DedTypeBase tpRoot
)
Public Sub RemoveAttrsOwner (
    attr As String,
    ownerName As String,
    tpRoot As DedTypeBase
)
public:
void RemoveAttrsOwner(
    String^ attr,
    String^ ownerName,
    DedTypeBase^ tpRoot
)
member RemoveAttrsOwner :
        attr : string *
        ownerName : string *
        tpRoot : DedTypeBase -> unit

Parametri

attr String
Attributo dal quale eliminare l'owner.
ownerName String
Nome dell'owner da eliminare.
tpRoot DedTypeBase
Vedi anche

Documentazione

Classe UserPermManager
Namespace DedNet.Core


Metodo UserPermManager.RemoveCommOwner

Metodo UserPermManagerRemoveCommOwner
Rimuove i permessi specifici di una famiglia, abbinati ad un utente/gruppo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void RemoveCommOwner(
    Guid commid,
    string ownerName
)
Public Sub RemoveCommOwner (
    commid As Guid,
    ownerName As String
)
public:
void RemoveCommOwner(
    Guid commid,
    String^ ownerName
)
member RemoveCommOwner :
        commid : Guid *
        ownerName : string -> unit

Parametri

commid Guid
ownerName String
Nome dell'owner da eliminare.
Vedi anche

Documentazione

Classe UserPermManager
Namespace DedNet.Core


Metodo UserPermManager.RemoveFamOwner

Metodo UserPermManagerRemoveFamOwner
Rimuove i permessi specifici di una famiglia, abbinati ad un utente/gruppo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void RemoveFamOwner(
    DedTypeBase tp,
    string ownerName
)
Public Sub RemoveFamOwner (
    tp As DedTypeBase,
    ownerName As String
)
public:
void RemoveFamOwner(
    DedTypeBase^ tp,
    String^ ownerName
)
member RemoveFamOwner :
        tp : DedTypeBase *
        ownerName : string -> unit

Parametri

tp DedTypeBase
ownerName String
Nome dell'owner da eliminare.
Vedi anche

Documentazione

Classe UserPermManager
Namespace DedNet.Core


Metodo UserPermManager.RemoveFolderOwner

Metodo UserPermManagerRemoveFolderOwner
Rimuove i permessi specifici di una famiglia, abbinati ad un utente/gruppo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void RemoveFolderOwner(
    string folder,
    string ownerName
)
Public Sub RemoveFolderOwner (
    folder As String,
    ownerName As String
)
public:
void RemoveFolderOwner(
    String^ folder,
    String^ ownerName
)
member RemoveFolderOwner :
        folder : string *
        ownerName : string -> unit

Parametri

folder String
Famiglia dalla quale eliminare l'owner.
ownerName String
Nome dell'owner da eliminare.
Vedi anche

Documentazione

Classe UserPermManager
Namespace DedNet.Core


Metodo UserPermManager.ResetUserPerm

Metodo UserPermManagerResetUserPerm
Funzione per azzerare i permessi ( in modo che li ricalcoli quando vengono richiesti )

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ResetUserPerm()
Public Sub ResetUserPerm
public:
void ResetUserPerm()
member ResetUserPerm : unit -> unit
Vedi anche

Documentazione

Classe UserPermManager
Namespace DedNet.Core


Metodo UserPermManager.Save

Metodo UserPermManagerSave
Salva tutte le modifiche agli utenti e permessi.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Save()
Public Sub Save
public:
void Save()
member Save : unit -> unit
Vedi anche

Documentazione

Classe UserPermManager
Namespace DedNet.Core


Eventi di UserPermManager

Il tipo UserPermManager espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | OnProgressSaving | Evento chiamato durante la progressione del salvataggio.
Torna su
Vedi anche

Documentazione

Classe UserPermManager
Namespace DedNet.Core


Evento UserPermManager.OnProgressSaving

Evento UserPermManagerOnProgressSaving
Evento chiamato durante la progressione del salvataggio.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<UserPermManagerOnProgressSavingEventArgs> OnProgressSaving
Public Event OnProgressSaving As EventHandler(Of UserPermManagerOnProgressSavingEventArgs)
public:
 event EventHandler<UserPermManagerOnProgressSavingEventArgs^>^ OnProgressSaving {
    void add (EventHandler<UserPermManagerOnProgressSavingEventArgs^>^ value);
    void remove (EventHandler<UserPermManagerOnProgressSavingEventArgs^>^ value);
}
member OnProgressSaving : IEvent<EventHandler<UserPermManagerOnProgressSavingEventArgs>,
    UserPermManagerOnProgressSavingEventArgs>

Valore

EventHandler UserPermManagerOnProgressSavingEventArgs
Vedi anche

Documentazione

Classe UserPermManager
Namespace DedNet.Core


Classe UserPermManager.OnProgressSavingEventArgs

Classe UserPermManagerOnProgressSavingEventArgs
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNet.CoreUserPermManagerOnProgressSavingEventArgs

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class OnProgressSavingEventArgs : EventArgs
Public Class OnProgressSavingEventArgs
    Inherits EventArgs
public ref class OnProgressSavingEventArgs : public EventArgs
type OnProgressSavingEventArgs =
    class
        inherit EventArgs
    end

Il tipo UserPermManagerOnProgressSavingEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | UserPermManagerOnProgressSavingEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Percentuale |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore UserPermManager.OnProgressSavingEventArgs

Costruttore UserPermManagerOnProgressSavingEventArgs

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public OnProgressSavingEventArgs()
Public Sub New
public:
OnProgressSavingEventArgs()
new : unit -> OnProgressSavingEventArgs
Vedi anche

Documentazione

Classe UserPermManagerOnProgressSavingEventArgs
Namespace DedNet.Core


Proprietà di OnProgressSavingEventArgs

Il tipo UserPermManagerOnProgressSavingEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Percentuale |
Torna su
Vedi anche

Documentazione

Classe UserPermManagerOnProgressSavingEventArgs
Namespace DedNet.Core


Proprietà UserPermManager.OnProgressSavingEventArgs.Percentuale

Proprietà UserPermManagerOnProgressSavingEventArgsPercentuale

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int Percentuale { get; set; }
Public Property Percentuale As Integer
    Get
    Set
public:
property int Percentuale {
    int get ();
    void set (int value);
}
member Percentuale : int with get, set

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe UserPermManagerOnProgressSavingEventArgs
Namespace DedNet.Core


Classe UsrPerm
Classe di definizione del singolo permesso.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreUsrPerm

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class UsrPerm
Public Class UsrPerm
public ref class UsrPerm
type UsrPerm = class end

Il tipo UsrPerm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Discrim | Restituisce il discriminante del permesso. Se si tratta dei permessi sui file verrà restituita l'estensione che l'utente può o non può vedere, altrimenti il carattere standard indicante che il discriminante corrente non deve essere preso in considerazione.
Proprietà pubblica | Val | Restituisce il valore del permesso.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ToString | Effettuo override del metodo ToString in modo tale da rendere più chiara la visualizzazione dei valori quando debuggo. (Sovrascrive ObjectToString)
Torna su
Campi
 | Nome | Descrizione
Campo pubblico | Nome |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di UsrPerm

Il tipo UsrPerm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Discrim | Restituisce il discriminante del permesso. Se si tratta dei permessi sui file verrà restituita l'estensione che l'utente può o non può vedere, altrimenti il carattere standard indicante che il discriminante corrente non deve essere preso in considerazione.
Proprietà pubblica | Val | Restituisce il valore del permesso.
Torna su
Vedi anche

Documentazione

Classe UsrPerm
Namespace DedNet.Core


Proprietà UsrPerm.Discrim

Proprietà UsrPermDiscrim
Restituisce il discriminante del permesso. Se si tratta dei permessi sui file verrà restituita l'estensione che l'utente può o non può vedere, altrimenti il carattere standard indicante che il discriminante corrente non deve essere preso in considerazione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Discrim { get; }
Public ReadOnly Property Discrim As String
    Get
public:
property String^ Discrim {
    String^ get ();
}
member Discrim : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe UsrPerm
Namespace DedNet.Core


Proprietà UsrPerm.Val

Proprietà UsrPermVal
Restituisce il valore del permesso.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Val { get; }
Public ReadOnly Property Val As Boolean
    Get
public:
property bool Val {
    bool get ();
}
member Val : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe UsrPerm
Namespace DedNet.Core


Metodi di UsrPerm

Il tipo UsrPerm espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ToString | Effettuo override del metodo ToString in modo tale da rendere più chiara la visualizzazione dei valori quando debuggo. (Sovrascrive ObjectToString)
Torna su
Vedi anche

Documentazione

Classe UsrPerm
Namespace DedNet.Core


Metodo UsrPerm.ToString

Metodo UsrPermToString
Effettuo override del metodo ToString in modo tale da rendere più chiara la visualizzazione dei valori quando debuggo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe UsrPerm
Namespace DedNet.Core


Campi di UsrPerm

Il tipo UsrPerm espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | Nome |
Torna su
Vedi anche

Documentazione

Classe UsrPerm
Namespace DedNet.Core


Campo UsrPerm.Nome

Campo UsrPermNome

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public readonly string Nome
Public ReadOnly Nome As String
public:
initonly String^ Nome
val Nome: string

Valore del campo

String
Vedi anche

Documentazione

Classe UsrPerm
Namespace DedNet.Core


Classe UsrPermDiz
Dizionario di permessi generali, indicizzato tramite nome permesso. Serve per individuare più rapidamente il permesso in base al suo nome.
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericDictionary String, Dictionary String, UsrPerm
DedNet.CoreUsrPermDiz

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class UsrPermDiz : Dictionary<string, Dictionary<string, UsrPerm>>
Public Class UsrPermDiz
    Inherits Dictionary(Of String, Dictionary(Of String, UsrPerm))
public ref class UsrPermDiz : public Dictionary<String^, Dictionary<String^, UsrPerm^>^>
type UsrPermDiz =
    class
        inherit Dictionary<string, Dictionary<string, UsrPerm>>
    end

Il tipo UsrPermDiz espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | UsrPermDiz |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore UsrPermDiz

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public UsrPermDiz()
Public Sub New
public:
UsrPermDiz()
new : unit -> UsrPermDiz
Vedi anche

Documentazione

Classe UsrPermDiz
Namespace DedNet.Core


Classe UsrPermList
Lista di oggetti UsrPerm.
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList UsrPerm
DedNet.CoreUsrPermList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class UsrPermList : List<UsrPerm>
Public Class UsrPermList
    Inherits List(Of UsrPerm)
public ref class UsrPermList : public List<UsrPerm^>
type UsrPermList =
    class
        inherit List<UsrPerm>
    end

Il tipo UsrPermList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | UsrPermList |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | GetByNameAndDiscrim | Cerca e restituisce il permesso tramite il suo nome.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore UsrPermList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public UsrPermList()
Public Sub New
public:
UsrPermList()
new : unit -> UsrPermList
Vedi anche

Documentazione

Classe UsrPermList
Namespace DedNet.Core


Metodi di UsrPermList

Il tipo UsrPermList espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | GetByNameAndDiscrim | Cerca e restituisce il permesso tramite il suo nome.
Torna su
Vedi anche

Documentazione

Classe UsrPermList
Namespace DedNet.Core


Metodo UsrPermList.GetByNameAndDiscrim

Metodo UsrPermListGetByNameAndDiscrim
Cerca e restituisce il permesso tramite il suo nome.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public UsrPerm GetByNameAndDiscrim(
    string name,
    string discrim
)
Public Function GetByNameAndDiscrim (
    name As String,
    discrim As String
) As UsrPerm
public:
UsrPerm^ GetByNameAndDiscrim(
    String^ name,
    String^ discrim
)
member GetByNameAndDiscrim :
        name : string *
        discrim : string -> UsrPerm

Parametri

name String
Nome del permesso da cercare.
discrim String
Discriminante del permesso da cercare.

Valore di ritorno

UsrPerm
Restitusice il permesso oppure null se non è presente nella lista.
Vedi anche

Documentazione

Classe UsrPermList
Namespace DedNet.Core


Classe UsrUser
Classe che incapsula le funzionalità di gestione dei permessi.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreUsrUser

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class UsrUser
Public Class UsrUser
public ref class UsrUser
type UsrUser = class end

Il tipo UsrUser espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione di appartenenza.
Proprietà pubblica | Corporate | Nome dell'azienda.
Proprietà pubblica | HiddenCommDbPaths | Restituisce la lista dei DbPath delle famiglie che non sono leggibili dall'utente (permesso READ = false). Restituisce sempre una lista inizializzata ma vuota se non ce ne sono.
Proprietà pubblica | HiddenDbPaths | Restituisce la lista dei DbPath delle famiglie che non sono leggibili dall'utente (permesso READ = false). Restituisce sempre una lista inizializzata ma vuota se non ce ne sono.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Can(DedStandardPerm, DedTypeBase) | Verifica se l'utente ha il permesso specifico richiesto.
Metodo pubblico | Can(String, DedTypeBase) | Verifica se l'utente ha il permesso specifico richiesto.
Metodo pubblico | Can(DedStandardPerm, Boolean, String) | Verifica se l'utente ha il permesso generale standard richiesto.
Metodo pubblico | Can(String, Boolean, String) | Verifica se l'utente ha il permesso generale richiesto.
Metodo pubblico | CanOnAttr(DedStandardPerm, String, DedTypeBase) | Verifica se l'utente ha il permesso specifico richiesto.
Metodo pubblico | CanOnAttr(DedStandardPerm, String, String) | Verifica se l'utente ha il permesso specifico richiesto.
Metodo pubblico | CanOnAttr(String, String, DedTypeBase) | Verifica se l'utente ha il permesso specifico richiesto.
Metodo pubblico | CanOnAttr(String, String, String) |
Metodo pubblico | CanOnAttrComm(DedStandardPerm, String, String) | Verifica se l'utente ha il permesso specifico richiesto.
Metodo pubblico | CanOnAttrComm(String, String, String) |
Metodo pubblico | CanOnComm(DedStandardPerm, DedComm) | Verifica se l'utente ha il permesso specifico richiesto.
Metodo pubblico | CanOnComm(String, DedComm) | Verifica se l'utente ha il permesso specifico richiesto.
Metodo pubblico | CanOnFile | Verifica se l'utente ha il permesso specifico richiesto.
Metodo pubblico | CanOnFolder(DedStandardPerm, String) | Verifica se l'utente ha il permesso specifico richiesto.
Metodo pubblico | CanOnFolder(String, String) | Verifica se l'utente ha il permesso specifico richiesto.
 | CheckPassword | Verifica la correttezza dell'abbinamento utente e password e restituisce true se combacia.
 | CheckPasswordEncrypted | Verifica la correttezza dell'abbinamento utente e password e restituisce true se combacia.
 | CheckRawPassword | Verifica la correttezza dell'abbinamento utente e password grezza (valore salvato nel db) e restituisce true se combacia.
Torna su
Campi
 | Nome | Descrizione
Campo pubblico | Descr | Descrizione dell'utente.
Campo pubblico | Email | Indirizzo email dell'utente.
Campo pubblico | Name | Nome dell'utente loggato al DED oppure nome dell'utente di Windows se la gestione degli utenti non è attivata.
Campo pubblico | NameVis | Restituisce il nome da visualizzare dell'utente.
Campo pubblico | Pws | Restituisce l'area locale.
Campo pubblico | UserPermActive | Restituisce se sia attiva la gestione degli utenti.
Campo pubblico | UseWinAuth | Restituisce se l'utente utilizza l'autenticazione di Windows.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di UsrUser

Il tipo UsrUser espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione di appartenenza.
Proprietà pubblica | Corporate | Nome dell'azienda.
Proprietà pubblica | HiddenCommDbPaths | Restituisce la lista dei DbPath delle famiglie che non sono leggibili dall'utente (permesso READ = false). Restituisce sempre una lista inizializzata ma vuota se non ce ne sono.
Proprietà pubblica | HiddenDbPaths | Restituisce la lista dei DbPath delle famiglie che non sono leggibili dall'utente (permesso READ = false). Restituisce sempre una lista inizializzata ma vuota se non ce ne sono.
Torna su
Vedi anche

Documentazione

Classe UsrUser
Namespace DedNet.Core


Proprietà UsrUser.Application

Proprietà UsrUserApplication
Restituisce l'applicazione di appartenenza.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedNetApplication Application { get; }
Public ReadOnly Property Application As DedNetApplication
    Get
public:
property DedNetApplication^ Application {
    DedNetApplication^ get ();
}
member Application : DedNetApplication with get

Valore della proprietà

DedNetApplication
Vedi anche

Documentazione

Classe UsrUser
Namespace DedNet.Core


Proprietà UsrUser.Corporate

Proprietà UsrUserCorporate
Nome dell'azienda.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCorporate Corporate { get; set; }
Public Property Corporate As DedCorporate
    Get
    Set
public:
property DedCorporate^ Corporate {
    DedCorporate^ get ();
    void set (DedCorporate^ value);
}
member Corporate : DedCorporate with get, set

Valore della proprietà

DedCorporate
Vedi anche

Documentazione

Classe UsrUser
Namespace DedNet.Core


Proprietà UsrUser.HiddenCommDbPaths

Proprietà UsrUserHiddenCommDbPaths
Restituisce la lista dei DbPath delle famiglie che non sono leggibili dall'utente (permesso READ = false). Restituisce sempre una lista inizializzata ma vuota se non ce ne sono.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> HiddenCommDbPaths { get; }
Public ReadOnly Property HiddenCommDbPaths As List(Of String)
    Get
public:
property List<String^>^ HiddenCommDbPaths {
    List<String^>^ get ();
}
member HiddenCommDbPaths : List<string> with get

Valore della proprietà

List String
Vedi anche

Documentazione

Classe UsrUser
Namespace DedNet.Core


Proprietà UsrUser.HiddenDbPaths

Proprietà UsrUserHiddenDbPaths
Restituisce la lista dei DbPath delle famiglie che non sono leggibili dall'utente (permesso READ = false). Restituisce sempre una lista inizializzata ma vuota se non ce ne sono.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> HiddenDbPaths { get; }
Public ReadOnly Property HiddenDbPaths As List(Of String)
    Get
public:
property List<String^>^ HiddenDbPaths {
    List<String^>^ get ();
}
member HiddenDbPaths : List<string> with get

Valore della proprietà

List String
Vedi anche

Documentazione

Classe UsrUser
Namespace DedNet.Core


Metodi di UsrUser

Il tipo UsrUser espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Can(DedStandardPerm, DedTypeBase) | Verifica se l'utente ha il permesso specifico richiesto.
Metodo pubblico | Can(String, DedTypeBase) | Verifica se l'utente ha il permesso specifico richiesto.
Metodo pubblico | Can(DedStandardPerm, Boolean, String) | Verifica se l'utente ha il permesso generale standard richiesto.
Metodo pubblico | Can(String, Boolean, String) | Verifica se l'utente ha il permesso generale richiesto.
Metodo pubblico | CanOnAttr(DedStandardPerm, String, DedTypeBase) | Verifica se l'utente ha il permesso specifico richiesto.
Metodo pubblico | CanOnAttr(DedStandardPerm, String, String) | Verifica se l'utente ha il permesso specifico richiesto.
Metodo pubblico | CanOnAttr(String, String, DedTypeBase) | Verifica se l'utente ha il permesso specifico richiesto.
Metodo pubblico | CanOnAttr(String, String, String) |
Metodo pubblico | CanOnAttrComm(DedStandardPerm, String, String) | Verifica se l'utente ha il permesso specifico richiesto.
Metodo pubblico | CanOnAttrComm(String, String, String) |
Metodo pubblico | CanOnComm(DedStandardPerm, DedComm) | Verifica se l'utente ha il permesso specifico richiesto.
Metodo pubblico | CanOnComm(String, DedComm) | Verifica se l'utente ha il permesso specifico richiesto.
Metodo pubblico | CanOnFile | Verifica se l'utente ha il permesso specifico richiesto.
Metodo pubblico | CanOnFolder(DedStandardPerm, String) | Verifica se l'utente ha il permesso specifico richiesto.
Metodo pubblico | CanOnFolder(String, String) | Verifica se l'utente ha il permesso specifico richiesto.
 | CheckPassword | Verifica la correttezza dell'abbinamento utente e password e restituisce true se combacia.
 | CheckPasswordEncrypted | Verifica la correttezza dell'abbinamento utente e password e restituisce true se combacia.
 | CheckRawPassword | Verifica la correttezza dell'abbinamento utente e password grezza (valore salvato nel db) e restituisce true se combacia.
Torna su
Vedi anche

Documentazione

Classe UsrUser
Namespace DedNet.Core


Metodo UsrUser.Can

Metodo UsrUserCan
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Can(DedStandardPerm, DedTypeBase) | Verifica se l'utente ha il permesso specifico richiesto.
Metodo pubblico | Can(String, DedTypeBase) | Verifica se l'utente ha il permesso specifico richiesto.
Metodo pubblico | Can(DedStandardPerm, Boolean, String) | Verifica se l'utente ha il permesso generale standard richiesto.
Metodo pubblico | Can(String, Boolean, String) | Verifica se l'utente ha il permesso generale richiesto.
Torna su
Vedi anche

Documentazione

Classe UsrUser
Namespace DedNet.Core


Metodo UsrUser.Can(DedStandardPerm, DedTypeBase)

Metodo UsrUserCan(DedStandardPerm, DedTypeBase)
Verifica se l'utente ha il permesso specifico richiesto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Can(
    DedStandardPerm perm,
    DedTypeBase fam
)
Public Function Can (
    perm As DedStandardPerm,
    fam As DedTypeBase
) As Boolean
public:
bool Can(
    DedStandardPerm perm,
    DedTypeBase^ fam
)
member Can :
        perm : DedStandardPerm *
        fam : DedTypeBase -> bool

Parametri

perm DedStandardPerm
Permesso da verificare.
fam DedTypeBase
Famiglia da verificare.

Valore di ritorno

Boolean
Restituisce true se l'utente ha il permesso specifico richiesto altrimenti false.
Vedi anche

Documentazione

Classe UsrUser
Overload di Can
Namespace DedNet.Core


Metodo UsrUser.Can(String, DedTypeBase)

Metodo UsrUserCan(String, DedTypeBase)
Verifica se l'utente ha il permesso specifico richiesto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Can(
    string permname,
    DedTypeBase fam
)
Public Function Can (
    permname As String,
    fam As DedTypeBase
) As Boolean
public:
bool Can(
    String^ permname,
    DedTypeBase^ fam
)
member Can :
        permname : string *
        fam : DedTypeBase -> bool

Parametri

permname String
Nome del permesso da verificare.
fam DedTypeBase
Famiglia da verificare.

Valore di ritorno

Boolean
Restituisce true se l'utente ha il permesso specifico richiesto altrimenti false.
Vedi anche

Documentazione

Classe UsrUser
Overload di Can
Namespace DedNet.Core


Metodo UsrUser.Can(DedStandardPerm, Boolean, String)

Metodo UsrUserCan(DedStandardPerm, Boolean, String)
Verifica se l'utente ha il permesso generale standard richiesto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Can(
    DedStandardPerm perm,
    bool checkOnlyGeneralPerm = false,
    string discrim = "*"
)
Public Function Can (
    perm As DedStandardPerm,
    Optional checkOnlyGeneralPerm As Boolean = false,
    Optional discrim As String = "*"
) As Boolean
public:
bool Can(
    DedStandardPerm perm,
    bool checkOnlyGeneralPerm = false,
    String^ discrim = L"*"
)
member Can :
        perm : DedStandardPerm *
        ?checkOnlyGeneralPerm : bool *
        ?discrim : string
(* Defaults:
        let _checkOnlyGeneralPerm = defaultArg checkOnlyGeneralPerm false
        let _discrim = defaultArg discrim "*"
*)
-> bool

Parametri

perm DedStandardPerm
Permesso da verificare.
checkOnlyGeneralPerm Boolean (Optional)
discrim String (Optional)

Valore di ritorno

Boolean
Restituisce true se l'utente ha il permesso generale standard richiesto altrimenti false.
Vedi anche

Documentazione

Classe UsrUser
Overload di Can
Namespace DedNet.Core


Metodo UsrUser.Can(String, Boolean, String)

Metodo UsrUserCan(String, Boolean, String)
Verifica se l'utente ha il permesso generale richiesto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Can(
    string permname,
    bool checkOnlyGeneralPerm = false,
    string discrim = "*"
)
Public Function Can (
    permname As String,
    Optional checkOnlyGeneralPerm As Boolean = false,
    Optional discrim As String = "*"
) As Boolean
public:
bool Can(
    String^ permname,
    bool checkOnlyGeneralPerm = false,
    String^ discrim = L"*"
)
member Can :
        permname : string *
        ?checkOnlyGeneralPerm : bool *
        ?discrim : string
(* Defaults:
        let _checkOnlyGeneralPerm = defaultArg checkOnlyGeneralPerm false
        let _discrim = defaultArg discrim "*"
*)
-> bool

Parametri

permname String
Nome del permesso da verificare.
checkOnlyGeneralPerm Boolean (Optional)
discrim String (Optional)

Valore di ritorno

Boolean
Restituisce true se l'utente ha il permesso generale richiesto altrimenti false.
Vedi anche

Documentazione

Classe UsrUser
Overload di Can
Namespace DedNet.Core


Metodo UsrUser.CanOnAttr

Metodo UsrUserCanOnAttr
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | CanOnAttr(DedStandardPerm, String, DedTypeBase) | Verifica se l'utente ha il permesso specifico richiesto.
Metodo pubblico | CanOnAttr(DedStandardPerm, String, String) | Verifica se l'utente ha il permesso specifico richiesto.
Metodo pubblico | CanOnAttr(String, String, DedTypeBase) | Verifica se l'utente ha il permesso specifico richiesto.
Metodo pubblico | CanOnAttr(String, String, String) |
Torna su
Vedi anche

Documentazione

Classe UsrUser
Namespace DedNet.Core


Metodo UsrUser.CanOnAttr(DedStandardPerm, String, DedTypeBase)

Metodo UsrUserCanOnAttr(DedStandardPerm, String, DedTypeBase)
Verifica se l'utente ha il permesso specifico richiesto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CanOnAttr(
    DedStandardPerm perm,
    string attrName,
    DedTypeBase tp
)
Public Function CanOnAttr (
    perm As DedStandardPerm,
    attrName As String,
    tp As DedTypeBase
) As Boolean
public:
bool CanOnAttr(
    DedStandardPerm perm,
    String^ attrName,
    DedTypeBase^ tp
)
member CanOnAttr :
        perm : DedStandardPerm *
        attrName : string *
        tp : DedTypeBase -> bool

Parametri

perm DedStandardPerm
Permesso da verificare.
attrName String
Guid della commessa da verificare.
tp DedTypeBase

Valore di ritorno

Boolean
Restituisce true se l'utente ha il permesso specifico richiesto altrimenti false.
Vedi anche

Documentazione

Classe UsrUser
Overload di CanOnAttr
Namespace DedNet.Core


Metodo UsrUser.CanOnAttr(DedStandardPerm, String, String)

Metodo UsrUserCanOnAttr(DedStandardPerm, String, String)
Verifica se l'utente ha il permesso specifico richiesto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CanOnAttr(
    DedStandardPerm perm,
    string attrName,
    string dbpath
)
Public Function CanOnAttr (
    perm As DedStandardPerm,
    attrName As String,
    dbpath As String
) As Boolean
public:
bool CanOnAttr(
    DedStandardPerm perm,
    String^ attrName,
    String^ dbpath
)
member CanOnAttr :
        perm : DedStandardPerm *
        attrName : string *
        dbpath : string -> bool

Parametri

perm DedStandardPerm
Permesso da verificare.
attrName String
Guid della commessa da verificare.
dbpath String

Valore di ritorno

Boolean
Restituisce true se l'utente ha il permesso specifico richiesto altrimenti false.
Vedi anche

Documentazione

Classe UsrUser
Overload di CanOnAttr
Namespace DedNet.Core


Metodo UsrUser.CanOnAttr(String, String, DedTypeBase)

Metodo UsrUserCanOnAttr(String, String, DedTypeBase)
Verifica se l'utente ha il permesso specifico richiesto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CanOnAttr(
    string permname,
    string attrName,
    DedTypeBase tp
)
Public Function CanOnAttr (
    permname As String,
    attrName As String,
    tp As DedTypeBase
) As Boolean
public:
bool CanOnAttr(
    String^ permname,
    String^ attrName,
    DedTypeBase^ tp
)
member CanOnAttr :
        permname : string *
        attrName : string *
        tp : DedTypeBase -> bool

Parametri

permname String
Permesso da verificare.
attrName String
Guid della commessa da verificare.
tp DedTypeBase

Valore di ritorno

Boolean
Restituisce True se l'utente ha il permesso specifico richiesto, altrimenti False.
Vedi anche

Documentazione

Classe UsrUser
Overload di CanOnAttr
Namespace DedNet.Core


Metodo UsrUser.CanOnAttr(String, String, String)

Metodo UsrUserCanOnAttr(String, String, String)

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CanOnAttr(
    string permname,
    string attrName,
    string dbpath
)
Public Function CanOnAttr (
    permname As String,
    attrName As String,
    dbpath As String
) As Boolean
public:
bool CanOnAttr(
    String^ permname,
    String^ attrName,
    String^ dbpath
)
member CanOnAttr :
        permname : string *
        attrName : string *
        dbpath : string -> bool

Parametri

permname String
attrName String
dbpath String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe UsrUser
Overload di CanOnAttr
Namespace DedNet.Core


Metodo UsrUser.CanOnAttrComm

Metodo UsrUserCanOnAttrComm
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | CanOnAttrComm(DedStandardPerm, String, String) | Verifica se l'utente ha il permesso specifico richiesto.
Metodo pubblico | CanOnAttrComm(String, String, String) |
Torna su
Vedi anche

Documentazione

Classe UsrUser
Namespace DedNet.Core


Metodo UsrUser.CanOnAttrComm(DedStandardPerm, String, String)

Metodo UsrUserCanOnAttrComm(DedStandardPerm, String, String)
Verifica se l'utente ha il permesso specifico richiesto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CanOnAttrComm(
    DedStandardPerm perm,
    string attrName,
    string dbpath
)
Public Function CanOnAttrComm (
    perm As DedStandardPerm,
    attrName As String,
    dbpath As String
) As Boolean
public:
bool CanOnAttrComm(
    DedStandardPerm perm,
    String^ attrName,
    String^ dbpath
)
member CanOnAttrComm :
        perm : DedStandardPerm *
        attrName : string *
        dbpath : string -> bool

Parametri

perm DedStandardPerm
Permesso da verificare.
attrName String
Guid della commessa da verificare.
dbpath String

Valore di ritorno

Boolean
Restituisce true se l'utente ha il permesso specifico richiesto altrimenti false.
Vedi anche

Documentazione

Classe UsrUser
Overload di CanOnAttrComm
Namespace DedNet.Core


Metodo UsrUser.CanOnAttrComm(String, String, String)

Metodo UsrUserCanOnAttrComm(String, String, String)

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CanOnAttrComm(
    string permname,
    string attrName,
    string dbpath
)
Public Function CanOnAttrComm (
    permname As String,
    attrName As String,
    dbpath As String
) As Boolean
public:
bool CanOnAttrComm(
    String^ permname,
    String^ attrName,
    String^ dbpath
)
member CanOnAttrComm :
        permname : string *
        attrName : string *
        dbpath : string -> bool

Parametri

permname String
attrName String
dbpath String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe UsrUser
Overload di CanOnAttrComm
Namespace DedNet.Core


Metodo UsrUser.CanOnComm

Metodo UsrUserCanOnComm
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | CanOnComm(DedStandardPerm, DedComm) | Verifica se l'utente ha il permesso specifico richiesto.
Metodo pubblico | CanOnComm(String, DedComm) | Verifica se l'utente ha il permesso specifico richiesto.
Torna su
Vedi anche

Documentazione

Classe UsrUser
Namespace DedNet.Core


Metodo UsrUser.CanOnComm(DedStandardPerm, DedComm)

Metodo UsrUserCanOnComm(DedStandardPerm, DedComm)
Verifica se l'utente ha il permesso specifico richiesto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CanOnComm(
    DedStandardPerm perm,
    DedComm comm
)
Public Function CanOnComm (
    perm As DedStandardPerm,
    comm As DedComm
) As Boolean
public:
bool CanOnComm(
    DedStandardPerm perm,
    DedComm^ comm
)
member CanOnComm :
        perm : DedStandardPerm *
        comm : DedComm -> bool

Parametri

perm DedStandardPerm
Permesso da verificare.
comm DedComm

Valore di ritorno

Boolean
Restituisce true se l'utente ha il permesso specifico richiesto altrimenti false.
Vedi anche

Documentazione

Classe UsrUser
Overload di CanOnComm
Namespace DedNet.Core


Metodo UsrUser.CanOnComm(String, DedComm)

Metodo UsrUserCanOnComm(String, DedComm)
Verifica se l'utente ha il permesso specifico richiesto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CanOnComm(
    string permname,
    DedComm comm
)
Public Function CanOnComm (
    permname As String,
    comm As DedComm
) As Boolean
public:
bool CanOnComm(
    String^ permname,
    DedComm^ comm
)
member CanOnComm :
        permname : string *
        comm : DedComm -> bool

Parametri

permname String
Nome del permesso da verificare.
comm DedComm
Commessa da verificare.

Valore di ritorno

Boolean
Restituisce true se l'utente ha il permesso specifico richiesto altrimenti false.
Vedi anche

Documentazione

Classe UsrUser
Overload di CanOnComm
Namespace DedNet.Core


Metodo UsrUser.CanOnFile

Metodo UsrUserCanOnFile
Verifica se l'utente ha il permesso specifico richiesto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CanOnFile(
    string ext
)
Public Function CanOnFile (
    ext As String
) As Boolean
public:
bool CanOnFile(
    String^ ext
)
member CanOnFile :
        ext : string -> bool

Parametri

ext String
Estensione da verificare.

Valore di ritorno

Boolean
Restituisce True se l'utente ha il permesso specifico richiesto, altrimenti False.
Vedi anche

Documentazione

Classe UsrUser
Namespace DedNet.Core


Metodo UsrUser.CanOnFolder

Metodo UsrUserCanOnFolder
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | CanOnFolder(DedStandardPerm, String) | Verifica se l'utente ha il permesso specifico richiesto.
Metodo pubblico | CanOnFolder(String, String) | Verifica se l'utente ha il permesso specifico richiesto.
Torna su
Vedi anche

Documentazione

Classe UsrUser
Namespace DedNet.Core


Metodo UsrUser.CanOnFolder(DedStandardPerm, String)

Metodo UsrUserCanOnFolder(DedStandardPerm, String)
Verifica se l'utente ha il permesso specifico richiesto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CanOnFolder(
    DedStandardPerm perm,
    string path
)
Public Function CanOnFolder (
    perm As DedStandardPerm,
    path As String
) As Boolean
public:
bool CanOnFolder(
    DedStandardPerm perm,
    String^ path
)
member CanOnFolder :
        perm : DedStandardPerm *
        path : string -> bool

Parametri

perm DedStandardPerm
Permesso da verificare.
path String

Valore di ritorno

Boolean
Restituisce true se l'utente ha il permesso specifico richiesto altrimenti false.
Vedi anche

Documentazione

Classe UsrUser
Overload di CanOnFolder
Namespace DedNet.Core


Metodo UsrUser.CanOnFolder(String, String)

Metodo UsrUserCanOnFolder(String, String)
Verifica se l'utente ha il permesso specifico richiesto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CanOnFolder(
    string permname,
    string path
)
Public Function CanOnFolder (
    permname As String,
    path As String
) As Boolean
public:
bool CanOnFolder(
    String^ permname,
    String^ path
)
member CanOnFolder :
        permname : string *
        path : string -> bool

Parametri

permname String
Nome del permesso da verificare.
path String

Valore di ritorno

Boolean
Restituisce true se l'utente ha il permesso specifico richiesto altrimenti false.
Vedi anche

Documentazione

Classe UsrUser
Overload di CanOnFolder
Namespace DedNet.Core


Metodo UsrUser.CheckPassword

Metodo UsrUserCheckPassword
Verifica la correttezza dell'abbinamento utente e password e restituisce true se combacia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool CheckPassword(
    DedNetApplication app,
    string username,
    string pwd
)
Public Shared Function CheckPassword (
    app As DedNetApplication,
    username As String,
    pwd As String
) As Boolean
public:
static bool CheckPassword(
    DedNetApplication^ app,
    String^ username,
    String^ pwd
)
static member CheckPassword :
        app : DedNetApplication *
        username : string *
        pwd : string -> bool

Parametri

app DedNetApplication
Applicazione.
username String
Nome utente.
pwd String
Password.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe UsrUser
Namespace DedNet.Core


Metodo UsrUser.CheckPasswordEncrypted

Metodo UsrUserCheckPasswordEncrypted
Verifica la correttezza dell'abbinamento utente e password e restituisce true se combacia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool CheckPasswordEncrypted(
    DedNetApplication app,
    string username,
    string pwdEncrypted
)
Public Shared Function CheckPasswordEncrypted (
    app As DedNetApplication,
    username As String,
    pwdEncrypted As String
) As Boolean
public:
static bool CheckPasswordEncrypted(
    DedNetApplication^ app,
    String^ username,
    String^ pwdEncrypted
)
static member CheckPasswordEncrypted :
        app : DedNetApplication *
        username : string *
        pwdEncrypted : string -> bool

Parametri

app DedNetApplication
Applicazione.
username String
Nome utente.
pwdEncrypted String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe UsrUser
Namespace DedNet.Core


Metodo UsrUser.CheckRawPassword

Metodo UsrUserCheckRawPassword
Verifica la correttezza dell'abbinamento utente e password grezza (valore salvato nel db) e restituisce true se combacia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool CheckRawPassword(
    DedNetApplication app,
    string username,
    string rawpwd
)
Public Shared Function CheckRawPassword (
    app As DedNetApplication,
    username As String,
    rawpwd As String
) As Boolean
public:
static bool CheckRawPassword(
    DedNetApplication^ app,
    String^ username,
    String^ rawpwd
)
static member CheckRawPassword :
        app : DedNetApplication *
        username : string *
        rawpwd : string -> bool

Parametri

app DedNetApplication
Applicazione.
username String
Nome utente.
rawpwd String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe UsrUser
Namespace DedNet.Core


Campi di UsrUser

Il tipo UsrUser espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | Descr | Descrizione dell'utente.
Campo pubblico | Email | Indirizzo email dell'utente.
Campo pubblico | Name | Nome dell'utente loggato al DED oppure nome dell'utente di Windows se la gestione degli utenti non è attivata.
Campo pubblico | NameVis | Restituisce il nome da visualizzare dell'utente.
Campo pubblico | Pws | Restituisce l'area locale.
Campo pubblico | UserPermActive | Restituisce se sia attiva la gestione degli utenti.
Campo pubblico | UseWinAuth | Restituisce se l'utente utilizza l'autenticazione di Windows.
Torna su
Vedi anche

Documentazione

Classe UsrUser
Namespace DedNet.Core


Campo UsrUser.Descr

Campo UsrUserDescr
Descrizione dell'utente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public readonly string Descr
Public ReadOnly Descr As String
public:
initonly String^ Descr
val Descr: string

Valore del campo

String
Vedi anche

Documentazione

Classe UsrUser
Namespace DedNet.Core


Campo UsrUser.Email

Campo UsrUserEmail
Indirizzo email dell'utente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public readonly string Email
Public ReadOnly Email As String
public:
initonly String^ Email
val Email: string

Valore del campo

String
Vedi anche

Documentazione

Classe UsrUser
Namespace DedNet.Core


Campo UsrUser.Name

Campo UsrUserName
Nome dell'utente loggato al DED oppure nome dell'utente di Windows se la gestione degli utenti non è attivata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public readonly string Name
Public ReadOnly Name As String
public:
initonly String^ Name
val Name: string

Valore del campo

String
Vedi anche

Documentazione

Classe UsrUser
Namespace DedNet.Core


Campo UsrUser.NameVis

Campo UsrUserNameVis
Restituisce il nome da visualizzare dell'utente.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public readonly string NameVis
Public ReadOnly NameVis As String
public:
initonly String^ NameVis
val NameVis: string

Valore del campo

String
Vedi anche

Documentazione

Classe UsrUser
Namespace DedNet.Core


Campo UsrUser.Pws

Campo UsrUserPws
Restituisce l'area locale.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public readonly string Pws
Public ReadOnly Pws As String
public:
initonly String^ Pws
val Pws: string

Valore del campo

String
Vedi anche

Documentazione

Classe UsrUser
Namespace DedNet.Core


Campo UsrUser.UserPermActive

Campo UsrUserUserPermActive
Restituisce se sia attiva la gestione degli utenti.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public readonly bool UserPermActive
Public ReadOnly UserPermActive As Boolean
public:
initonly bool UserPermActive
val UserPermActive: bool

Valore del campo

Boolean
Vedi anche

Documentazione

Classe UsrUser
Namespace DedNet.Core


Campo UsrUser.UseWinAuth

Campo UsrUserUseWinAuth
Restituisce se l'utente utilizza l'autenticazione di Windows.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public readonly bool UseWinAuth
Public ReadOnly UseWinAuth As Boolean
public:
initonly bool UseWinAuth
val UseWinAuth: bool

Valore del campo

Boolean
Vedi anche

Documentazione

Classe UsrUser
Namespace DedNet.Core


Classe Utility
Classe di utilità interna.
Gerarchia di ereditarietà
SystemObject
DedNet.CoreUtility

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static class Utility
Public NotInheritable Class Utility
public ref class Utility abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Utility = class end

Il tipo Utility espone i seguenti membri.

Proprietà
Nome | Descrizione
Application | Applicazione DedNet.
ElaboratingImage | Immagine usata per confrontarla con quella nella cella.
Torna su
Metodi
Nome | Descrizione
AddCellTrasparency | Imposta una trasparenza per far sembrare celle disabilitate
AddControlToLayoutControl | Rimuove il controllo dal dialogo.
AddDocAnagr | Aggiunge i documenti di anagrafica
AddDocAnagrComm | Aggiunge le anagrafiche collegate alla commessa. Se deve aggiunge in modo ricorsivo le anagrafiche collegate alle commesse figlie. Per le anagrafiche delle commesse figlie controllo se devono essere aggiunte anche le commesse figlie
AddDocComm | Aggiunge i documenti di commessa. Se deve aggiunge in modo ricorsivo i documenti delle commesse figlie
AddEcoColumn(GridView) | Metodo usato per aggiungere la colonna degli Eco al GridView passato in ingresso.
AddEcoColumn(TreeList) | Metodo usato per aggiungere la colonna degli Eco al TreeList passato in ingresso.
AddPreviewColumn(GridView, Boolean, Boolean) | Aggiunge alla GridView passata una colonna contenente l'Anteprima e si attacca agli eventi in modo da gestire automaticamente la visualizzazione.
AddPreviewColumn(TreeList, Boolean, Boolean) | Aggiunge una colonna di Anteprima al TreeList passato. ATTENZIONE: A differenza della gridview, con il TreeList occorre gestire manualmente l'evento CustomColumnDisplayText e chiamare il GetFilePreview.
AddStateColumn | Metodo usato per aggiungere la colonna degli Eco al GridView passato in ingresso.
AllineaPrj | Allinea il progetto di Inventor nel caso sia più vecchio del progetto presente sul server.
ApplicationIsAlreadyRunning | Controlla se il processo è già in esecuzione ( fatto in questo modo per gestire anche i casi di Terminal Server )
AskForRepresentationSuffix | Chiede all'utente di inserire il suffisso per la rappresentazione e lo restituisce. Restituisce null se l'utente annulla.
AskUserIfWantsToChangeDataState | Verifica se l'anagrafica passata in ingresso può essere impostata in uno stato di "Working" e, nel caso in cui sia possibile, chiede all'utente se vuole procedere col farlo. Il metodo esegue internamente un RunSubCommand e nel caso in cui siano avvenute eccezzioni queste vengono rilanciate al chiamante.
AttributesDataCanBeEdited | Genera una eccezione se gli attributi di anagrafica non possono essere editati a causa dei documenti in CheckIn.
CalcDistanceBetweenString |
ChangeMouseIconOnECOColumn(GridView, MouseEventArgs, DictionaryString, DictionaryDedEcoEcoTypeEnum, Int32) | Cambia l'icona del mouse se questo è sopra la colonna degli ECO.
ChangeMouseIconOnECOColumn(GridView, MouseEventArgs, Int32) | Cambia l'icona del mouse se questo è sopra la colonna degli ECO.
ChangeMouseIconOnECOColumn(TreeList, MouseEventArgs, DictionaryTreeListNode, TupleInt32, DedEcoEcoTypeEnum, Int32) | Cambia l'icona del mouse se questo è sopra la colonna degli ECO.
CheckDedTypeName |
CheckDocExt | Controlla l'estensione del documento
CheckIsDataExportable | Restituisce true se i documenti dell'anagrafica sono esportabili all'esterno.
CheckIsDocExportable | Restituisce true se i documenti sono esportabili all'esterno.
CheckMinimumLicenseDuringExecuteCommand |
CheckMinimumLicenseDuringInitialize |
CheckMinimumLicenseDuringInitialize(Boolean) |
CheckPrjIsDed | Controlla che il progetto attivo sia congruente con una root di progetto definita nel Database.
CheckProgReserved | Controlla se nelle info passate il progressivo è tra quelli permessi o meno. In caso non lo sia lancia un'eccezione.
CheckValueIsConsistentForDB | Controlla se il valore dell'attributo è consistente con le sue proprietà. REstituisce il messaggio di errore nel parametro stringa passato di ritorno.
CheckViewer(DedCommand, ClientApplicationEnum) | Nel caso sia caricato dentro al VIEW vengono visualizzati solo i comandi di tipo READ.
CheckViewer(DedCommand, DedNetApplication) | Nel caso sia caricato dentro al VIEW vengono visualizzati solo i comandi di tipo READ.
ChiediSovrascritturaFile | Chiede all'utente se sovrascrivere il file di destinazione. Restituisce true se l'utente accetta altrimenti false.
ClickOnRow | Restituisce true se il click con il muose è stato fatto sulla riga del sender. Il sender può essere TreeList, GridControl o GridView
ClientConnectedIsNotCad | Restiruisce true se il client connesso non è un cad 2d/3d (Inventor,Solidworks,Autocad,Bricscad)
CloneFolder | Funzione di clonazione contenuto tra cartelle. Non controlla se la cartella di destinazione sia vuota.
CloseOwnerFormOnLoad | Chiude il form del comando chiamante se necessario contollando la variabile CloseWindowOnOpening.
CloseOwnerFormOnOpening | Chiude il form del comando chiamante se necessario contollando la variabile CloseWindowOnOpening.
CompareStringWithAlphabet | Effettua la comparazione delle due stringhe utilizzando l'alfabeto passato. Restituisce -1 se la prima è minore della seconda, 1 se la prima è maggiore della seconda, 0 se sono uguali.
CompareValues | Confronta due valori. Ritorna true se i due valori sono uguali
ContainsDuplicate | Controlla se la stringa contiene dei caratteri duplicati. Case sensitive.
ContainsInvariant | Controlla l'esistenza di un elemento stringa in una lista effettuando il confronto non case sensitive.
ConvertAttrsNameToPrompt | Converte il dizionario nome-valore a prompt-valore
ConvertPixelWithCurrentDPI_X | Adatta il valore in pixel utilizzando le impostazioni DPI correnti. Il calcolo viene eseguito prendendo in considerazione la dimensione orizzontale.
ConvertPixelWithCurrentDPI_Y | Adatta il valore in pixel utilizzando le impostazioni DPI correnti. Il calcolo viene eseguito prendendo in considerazione la dimensione verticale.
CreateEmptyFile | Crea un file vuoto nella posizione specificata
CreateEmptyTempFile | Crea un nuovo file temporaneo data l'estensione passata e ritorna il path.
CreateShortcut | Crea una shortcut.
CustomizeCell | Personalizza la cella della griglia in base alle informazioni specificate in ingresso.
DecrementString |
DecryptString | Funzione per Decriptare una stringa attraverso una determinata chiave.
DeepObtainAnagr | Controllo se esiste una angrafica associata all'interfaccia data. Utilizza in cascata tutti i possibili campi chiave
DeleteEmptyFolder | Rimuove ricorsivamente tutte le cartelle vuote dato il path indicato
DeleteFolder | Elimina una cartella con tutto il suo contenuto
DestroyIcon(Icon) | Metodo utilizzato per distruggere gli oggetti Icon GDI+ e liberare risorse.
DestroyIcon(IntPtr) | Metodo utilizzato per distruggere gli oggetti Icon GDI+ e liberare risorse.
DisableFloatingObject(Bar) | Obsoleto. Impedisce alla barra passata in ingresso di essere floattante.
DisableFloatingObject(DockManager) | Impedisce a tutti i pannelli del dockmanager passato in ingresso e alle barre di essere floattanti.
DocumentsOperation | Effettua la copia o lo spostamento dei documenti dalla posizione attuale alla nuova destinazione.
EncryptString | Funzione per Criptare una stringa attraverso una determinata chiave.
EvaluateMoveOrDel(MoveDocumentInfo) | In base alle informazioni in ingresso restituisce il risultato con le informazioni di MoveDel sull'elemento
EvaluateMoveOrDel(MoveDocumentInfo, Boolean) | In base alle informazioni in ingresso restituisce il risultato con le informazioni di MoveDel sull'elemento
ExtensionExcludedFromCache | Ritorna vero se l'estensione non è compatibile con la gestione della cache
FileAreSameExtension | Restituisce se i due file sono dello stesso tipo, ovvero se hanno la stessa estensione
FileAreSameFileName | Controlla se i due file name passati coincidoono
FileAreSameModDate | Restituisce se i due file passati abbiano la stessa data di ultima modifica.
FileAreSamePath | Restituisce se i due file passati sono nello stesso path
FileIsLocked | Restituisce true se il file non è accessibile in scrittura.
FileRename | Chiede all'utente il nome e percorso con il quale rinominare il file passato.
FileSave | Chiede all'utente la selezione di uno o più file attraverso la finestra di dialogo standard Apri. Se l'utente annulla viene restituito null altrimenti la lista contenente i documenti selezionati.
FileSelect(IWin32Window, String, Boolean, String, String) | Chiede all'utente la selezione di uno o più file attraverso la finestra di dialogo standard Apri. Se l'utente annulla viene restituito null altrimenti la lista contenente i documenti selezionati.
FileSelect(IWin32Window, String, Boolean, String, String, Boolean) | Chiede all'utente la selezione di uno o più file attraverso la finestra di dialogo standard Apri. Se l'utente annulla viene restituito null altrimenti la lista contenente i documenti selezionati.
FileSelect(IWin32Window, String, Boolean, String, String, String) | Chiede all'utente la selezione di uno o più file attraverso la finestra di dialogo standard Apri. Se l'utente annulla viene restituito null altrimenti la lista contenente i documenti selezionati.
FileSelect(IWin32Window, String, Boolean, String, String, String, Boolean) | Chiede all'utente la selezione di uno o più file attraverso la finestra di dialogo standard Apri. Se l'utente annulla viene restituito null altrimenti la lista contenente i documenti selezionati.
FillContextMenuStrip |
FillDictionaryDirFiles | Crea un dizionario con i file e le rispettive cartelle ( per la gestione delle cartelle ).
FillOnlyDB | Metodo che inizializza gli attributi solo db. In fase di salvataggio / creazione revisione / creazione variante faccio in modo di prelevare dall'anagrafica di partenza tutti gli attributi solo db. Fatto ciò aggiorno l'anagrafica impostata con i valori degli attributi solo db.In questo modo sono sicuro di averli sempre impostati quando a schermo devo visualizzare gli attributi.Se non facessi così e da CAD eseguissi uno dei 3 comandi di salvataggio, gli attributi solo db non verrebbero compilati.
FindExecutable |
FindKeyCaptionInMenu | Restituisce true se l'elemento è già presente nella lista.
FindKeyNameInMenu | Restituisce true se l'elemento è già presente nella lista.
FindProcess | Restituisce i processi abbinati al documento passato.
FolderSelect | Chiede all'utente la selezione di una cartella.
ForceDocRowVerInDb | Aggiorna il ROWVER del DB leggendolo dal documento.
FormatDateTimeStringPattern | Formatta il pattern della date eliminando le parentesi graffe. Attenzione! Per gestire eventuali problematiche il pattern {0} non è cosiderato valido per le date e di conseguenza la funzione ritornerà una stringa vuota.
FormatPermAttrKey | Metodo che ritorna la chiave da utilizzare per identificare l'accoppiata 'attributo' e 'famiglia'. È stato centralizzato in un metodo affinchè se un in un futuro si dovesse cambiare formattazione, basta modificare questo metodo senza dover girare tutto il progetto. Attenzione! Non viene eseguito nessun controllo sulla validità dei parametri.
FormatPermAttrKeyToDelete(DedAttr) | Metodo che ritorna la chiave da utilizzare per identificare i record da eliminare in DED_OBJ_PERM quando viene eliminato un attributo. È stato centralizzato in un metodo affinchè se un in un futuro si dovesse cambiare formattazione, basta modificare questo metodo senza dover girare tutto il progetto. Attenzione! Non viene eseguito nessun controllo sulla validità dei parametri.
FormatPermAttrKeyToDelete(DedTypeBase) | Metodo che ritorna la chiave da utilizzare per identificare i record da eliminare in DED_OBJ_PERM quando viene eliminata una famiglia. È stato centralizzato in un metodo affinchè se un in un futuro si dovesse cambiare formattazione, basta modificare questo metodo senza dover girare tutto il progetto. Attenzione! Non viene eseguito nessun controllo sulla validità dei parametri.
FormatZeroLeft | Restituisce una stringa avente il numero di caratteri specificato riempiendo a sinistra con il carattere di riempimento. Nel caso di caratteri eccedenti elimina da sinistra la parte in eccesso.
GestisciAllegati | Gestisce gli allegati in base all'opzione.
GetAll | Cerca tra tutti i controlli figli del controllo passato quelli di un determintao tipo e li restituisce.
GetAllRootsUsedInFam | Restituisce una lista con tutte le root usate all'interno delle famiglie.
GetAttrFromDBProperties | Restituisce la lista degli attributi relativi alle proprietà
GetBackupFiles | Restituisce una lista sempre inizializzata con i file presenti nelle cartelle di backup di tutte le aree locali.
GetBackupFilesFromPwsPath | Restituisce una lista sempre inizializzata con i file presenti in una specifica area locale.
GetBackupFullFileNameFromDoc | Restituisce il percorso e il nome file del documento da backuppare.
GetCachedIcon | Restituisce l'icona del file/cartella
GetConfigName | Dato un fulldocumentname ritorna il fullfilename privato della configurazione
GetDataFromRegistryByDocId | Metodo che ritorna l'anagrafica in base ai campi ID e REV compilati all'interno della chiave di registro.
GetDateTime | Restituisce una data inizializzata con la data passata ma fino ai secondi, evitando i millisecondi.
GetDocPropertiesColumnName | Restituisce la colonna contenete il dato dal tipo dati passato.
GetDocumentStates | Ritorna un dizionario chiave valore contenente l'accoppiata tra "immagine stato documentale" e "enum identificativo".
GetEcoImage | Restituisce l'iimagine relativa all'eco/ecr con il valore passato
GetEncodeLength | Restituisce la lunghezza della stringa di codifica passata
GetExt | Restituisce l'estensione del nome file passato senza il punto iniziale.
GetExtraLargeFileIcon | Ricava l'icona piccola abbinata all'estensione di un nome file completo.
GetFamInfo | Restituisce il Dbpath della famiglia concatenato alla sua descrizione.
GetFileIcon | Ricava l'icona piccola abbinata all'estensione di un nome file completo.
GetFileNamesFromData | Ricava i nomi file da utilizzare dal'oggetto data passato.
GetFilePerms | Dalla lista dei permessi specificata in ingresso, filtra i permessi dei file e li ritorna sottoforma di nuova lista.
GetFilePreview(TreeList, TreeListNode, DedData) | Ritorna l'anteprima chiamando un thread.
GetFilePreview(TreeList, TreeListNode, String) | Ritorna l'anteprima chiamando un thread.
GetFirstDocFileNameFromData | REstituisce il nome del primo file collegato all'anagrafica in base alla PriorityExtList
GetFirstDocFromData | Restituisce il primo file collegato all'anagrafica in base alla PriorityExtList
GetFtpClient | Restituisce l'oggetto FTPClient con i dati passati
GetFullDocumentName | Dato un filename e una configurazione ritorna il fulldocumentname
GetFullFileName | Dato un fulldocumentname ritorna il fullfilename privato della configurazione
GetImageRectangle(Icon, Rectangle) | Restituisce il rettangolo in cui disegnare l'immagine
GetImageRectangle(Image, Rectangle) | Restituisce il rettangolo in cui disegnare l'immagine
GetImageRectangle(Int32, Int32, Rectangle) | Restituisce il rettangolo in cui disegnare l'immagine
GetImageSizeFromIconSizeType | Resitisce le dimensione delle immagini dalla tipologia di Size passata.
GetInternalException | Restituisce l'eccezione più interna.
GetItemByStringId | Metodo usato per sapere quale menu sta per essere processato.
GetItemSize |
GetItemSizeType |
GetLargeFileIcon | Ricava l'icona piccola abbinata all'estensione di un nome file completo.
GetMaxTokenNum | Restituisce il massimo numero di caratteri usati per il TokenTypeEnum passato. Verifica nella maschera di codifica Cod_Id, Cod_Fil e Cod_Dis in modo da prendere il numero massimo di caratteri utilizzati.
GetMd5FromString | Calcola una Guid data una stringa.
GetMd5HashFile | Restituisce il guid calcolato con Md5 del file passato.
GetMediumFileIcon | Ricava l'icona piccola abbinata all'estensione di un nome file completo.
GetNameVisFromUsername | Trova e restituisce il nome visualizzato dell'utente con username passato.
GetPreview | Estrae l'anteprima dal primo documento dall'anagrafica.
GetQsTempPath | Restituuisce il path per i temp Qs
GetRenamedFileNameNgrMode(DedDoc) | Nel caso di documento associato ad anagrafica NGR e ultima revisione restituisce il nuovo nome file con estensione.
GetRenamedFileNameNgrMode(DedData, DedDoc) | Nel caso di anagrafica NGR e ultima revisione restituisce il nuovo nome file.
GetRootsByFam | Ottiene i path usati per la codifica.
GetRootsByType | Ottiene i percorsi rooted associati al tipo di dato specificato in ingresso. Viene utilizzato in fase di costruzione dei permessi perchè l'oggetto DedNet.PathRoots non è ancora stato inizializzato.
GetSmallFileIcon | Ricava l'icona piccola abbinata all'estensione di un nome file completo.
GetTextQuery | Ritorna la query, in formato testuale del comando passato. I valori dei parametri non sono wrappati tra '' ma visualizzano il valore del parametro
GetTimeSuffix | Restituisce una stringa da utilizzare come suffisso nei nomi delle tabelle di backup, indicante l'anno, il mese, il giorno, l'ora, i minuti ed i secondi attuali.
GetUnboundTypeGrid | Restituisce il tipo UnboundColumnType in base al tipo di Attributo.
GetUnboundTypeTree | Restituisce il tipo UnboundColumnType in base al tipo di Attributo.
GetUniqueAttachFileName | Restituisce un nome univoco da aggiungere ai file allegati. Presuppone che il chiamante abbia già controllato che il destfilename sia già presente a destinazione
GetValidFamName | Restituisce un nome valido per il prompt dell'attributo.
IconIsCached | Controlla se l'icona è già presente nella cache
ImageToString | Convert image to base64 string
IncrementString |
InitFilterState | Inizializza la barra di filtraggio in base agli stati
IsAbsolutePath | Restiruisce true se si tratta di un percorso assoluto.
IsAutoCadFile | Ritorna True se il path passato in ingresso è di un dwg creato da AutoCAD, False altrimenti.
IsDesignerHosted | The DesignMode property does not correctly tell you if you are in design mode. IsDesignerHosted is a corrected version of that property. (see https://connect.microsoft.com/VisualStudio/feedback/details/553305 and http://stackoverflow.com/a/2693338/238419 )
IsDistAttr | restituisce true se è un attributo di distinta altrimenti false
IsDrive | Controlla se il path passato rappresenta una unità logica del sistema
IsDrivePath | Controllo se il path passato può rappresentare una unità logica senza che necessariamente sia connessa
IsFamilyNameValid | Controlla che il nome della famiglia non sia già presente tra i figli della famiglia selezionata.
IsFile | Restituisce True se è un file, False se è una Directory
IsFileNewer | Restituisce true se firstFile è più recente di secondFile.
IsFileReadOnly | Verifica se il file sia readonly. Restituisce false anche se il file non esiste.
IsNaN | Controlla se il valore passato è un NaN.
IsNumber | Ritorna vero se l'oggetto è di tipo numerico
IsSystemPath | Dato un percorso indica se è una cartella modificabile o no.
IsWow64Process | Restituisce se il processo corrente sia a 64 bit.
IsWow64Process(Process) | Restituisce se il processo passato sia a 64 bit.
ListNetworkComputers | Ritorna l'elenco dei computer di rete
MakeDocContext | Calcola e restituisce il contesto da utilizzare per collegare un documento ad un'anagrafica. Restituisce None se non è possibile associare il documento con il contesto richiesto.
MakeGrayscale | Ritorna una nuova immagine partendo dall'originale convertita in scala di grigi
MakeRelative | Relativizza un path dato un path di riferimento
ManageReadOnlyState | Imposta lo stato di sola lettura o meno dei file primary associati all'anagrafica passata e allo stato passato.
ManageScaleFactorByDpi | Metodo che gestisce il ridimensionamento delle icone quando si ha un elevato DPI.
MenuContainsKeyCaption | Restituisce true se l'elemento è già presente nella lista.
MenuContainsKeyName | Restituisce true se l'elemento è già presente nella lista.
NormalizeFamLevel | Sistema il livello della famiglia all'interno della codifica in modo da averlo sempre presente e in positivo
NormalizePath | Funzione di normalizzazione del path per uniformare i percorsi ai fini dei confronti
Now | Restituisce la data attuale fino ai secondi, senza i millisecondi. Questo serve per evitare l'errore generato nelle date in access che non hanno i millisecondi.
ParseDateTime | Converte la stringa in oggetto DateTime se riesce altrimenti null.
ProgCheckIsMyMin | Controlla se il progressivo è il primo di un'aassegnatazione
ProgIsInMyCurrentRange | Restituisce se il progressivo è contenuto nel range corrente, ovvero il primo disponibile non esaurito
ProgIsInMyRange | Restituisce se il progressivo appartiene al range di assegnazione passato
ProgIsInMyRanges(DedTypeProgStruct, String) | Restituisce se il progressivo appartiene alla lista dei progressivi assegnati
ProgIsInMyRanges(DedTypeBase, DedTypeProgList, String) | Restituisce se il progressivo appartiene alla lista dei progressivi assegnati per una determinata famiglia
ProgIsInMyUsedRanges |
RelocateOnExistingAttach | Effettua il relocate
RemoveAttributeLength | Rimuove la lunghezza dai token attributi
RemoveControlFromLayoutControl | Rimuove il controllo dal dialogo.
RemoveGenericDepFromList | Rimuove eventuali dipendenze di tipo generic che si trovano nella lista passata
RemoveInvalidFilePathCharacters | Ritorna un nomefile corretto sostituendo i caratteri non validi con il carattere passato.
RenameFileNgrMode(DedDoc) | Nel caso di documento associato ad anagrafica NGR e ultima revisione restituisce il nuovo nome file salvato nei temp aggiungendogli il tassello della revisione.
RenameFileNgrMode(DedData, DedDoc) | Nel caso di anagrafica NGR e ultima revisione restituisce il nuovo nome file salvato nei temp aggiungendogli il tassello della revisione.
ReplaceEx | Effettua il replace sulla stringa original della stringa pattern con replacement (case insensitive)
ReplaceFirstOccurrance | Sostisuisce solamente la prima occorrenza trovata e restiruisce la stringa modificata.
ReplaceTokens | Sostituisce i tasselli passatti con la stringa passata.
ResetCachePreview | Azzera la cache delle anteprime relative al controllo passato
ResizeBitmap | Ridimensiona l'immagine passata.
ResizeImageHighQuality |
RestorePageSettingsInfo | Rispristina le impostazioni di pagina di esportazione devexpress.
ReturnMaxWidth | Restituisce il maggiore tra la lunghezza della stringa e il massimo passato.
ReverseList | Data un array lo restituisce con nell'ordine invertiro.
RunCommandMenuItem | Esegue il comando abbinato alla voce di menu cliccata e poi lo restituisce.
SaveIdRevInTheRegistry | Metodo che salva nel registro l'Id e la Rev dell'anagrafica associata al documento. In questo modo il documento viene aperto con i dati dell'anagrafica corretta. La chiave di registro viene scritta nel caso in cui: 1) Il documento in apertura si un documento CAD. 2) L'anagrafica impostata sia quella effettivamente associata al documento.
SavePageSettingsInfo | Salva le impostazioni di pagina del PrintableComponentLink in un file xml.
SendCustomMailWithSmtpSettings | Permette di inviare un'email con le credenziali presenti nelle impostazioni SMTP del Gestore notifiche.
SendMail(DedNetApplication, DedNotifyNotifyEvent, DedEco) | Controlla che sia inizializzato il notificatore e nel caso invia la notifica. Se il parametro opzionale 'context' non è impostato, la mail verrà inviata in modo asincrono.
SendMail(DedNetApplication, DedNotifyNotifyEvent, DedDataList, DedCommList) | Controlla che sia inizializzato il notificatore e nel caso invia la notifica.
SendMail(DedNetApplication, DedNotifyNotifyEvent, DedEco, ListDedUser) | Controlla che sia inizializzato il notificatore e nel caso invia la notifica. Se il parametro opzionale 'context' non è impostato, la mail verrà inviata in modo asincrono.
SendMail(DedNetApplication, DedNotifyNotifyEvent, DedDataList, DedCommList, ListDedUser) | Controlla che sia inizializzato il notificatore e nel caso invia la notifica.
SendMailCustomizedEvent(DedNetApplication, String, DedDataList, DedCommList) | Controlla se è presente una notifica personalizzata con il nome passato e nel caso la invia.
SendMailCustomizedEvent(DedNetApplication, String, DedDataList, DedCommList, ListDedUser) | Controlla se è presente una notifica personalizzata con il nome passato e nel caso la invia.
SetColumnDisplayFormatFromAttr | Imposta la formattazione della colonna in base all'attributo specificato.
SetCulture | Metodo che imposta la culture in base alla lingua impostata nel file DedNet.ini
SetDpiAware | Metodo che imposta l'applicazione DPIAware e logga eventuali anomalie
SetEcoColumnProperties | Metodo usato per impostare le proprietà della colonna degli Eco.
SetEnabledMenuItem | Abilita o meno le voci di menu in base al contesto selezionato.
SetFileReadOnly | Imposta la proprietà readOnly del file passato. Se non ci riesce perché il file è bloccato restituisce false. Se il file non esiste restituisce false.
ShellOpenFile | Apre il file passato con la shell di windows, in modo asincrono (che è il default).
ShowECO(TreeListHitInfo, DedData, DictionaryTreeListNode, TupleInt32, DedEcoEcoTypeEnum, Int32) | Visualizza gli ECO associati all'anagrafica cliccata.
ShowECO(GridView, Point, String, Int32) | Visualizza gli ECO associati alla commessa cliccata.
ShowECO(GridView, Point, String, String, DictionaryString, DictionaryDedEcoEcoTypeEnum, Int32) | Visualizza gli ECO associati all'anagrafica cliccata.
ShowECO(GridView, Point, String, String, Int32) | Visualizza gli ECO associati all'anagrafica cliccata.
ShowMarkerInfo | Funzione che mostra lo stato del DOCROWVER del documento passato.
ShowPopUpMenu(PopupMenu, Point, PopupMenuShowingEventArgs) | Mostra il menu contestuale nella posizione passata.
ShowPopUpMenu(PopupMenu, Point, PopupMenuShowingEventArgs) | Mostra il menu contestuale nella posizione passata.
ShowUniqueDependencies | Restituisce se mostrare le dipendenze univoche. Restituisce True se si tratta di assieme o parte.
StringHeight | Metodo che ritorna la lunghezza, in pixel, della stringa passata in ingresso.
StringIsDimension | Contolla se l'attributo è del tipo d12, d432, etc.. e nel caso lo esclude.
StringIsGuid | Restituisce se la stringa rappresenta un Guid.
StringToImage | Convert string to image
StringWidth | Metodo che ritorna la lunghezza, in pixel, della stringa passata in ingresso.
ThrowSpecificException | Cerca di generare un'eccezione più specifica nel caso il progressivo sia riservato a altri utenti.
TranslateColumnsCaption | Data una collection di colonne, ne traduce il testo mostrato a schermo per ogni elemento.
UnFormatZeroLeft | Rimuove i caratteri paddingChar che sono all'inizio della stringa strVal.
UnZip | Unzippa il file passato nella cartella desiderata.
UpdateDedDataPartWithOnlyDbAttrs | Dato un DedDataPart calcolato su un documento, lo aggiorna con gli attributi "Solo Db" dell'anagrafica a cui è collegato. Non sporca il DedDataPart perchè è tra BeginIgnoreDirty ed EndIgnoreDirty.
UpdateString | Incrementa o decrementa la stringa passata iniziando dal carattere più a destra e proseguendo. Se necessario aggiunge un carattere a sinistra (es. 99 -> 100) o lo azzera nel caso di decremento (es. 100 -> 099). Se non riesce a trovare nell'alfabeto il carattere da incrementare verifica il caso più semplice del numero (0-9) o dell'alfabeto (A-Za-z). Se non riesce restituisce la stessa stringa che ha ricevuto come argomento.
ValuesAreDifferent | Restituisce true se i due valori sono diversi.
VisMsg(String) | Visualizza un messaggio semplice con solo il pulsante OK e l'icona Information.
VisMsg(IWin32Window, Exception) | Visualizza la finestra di dialogo per le eccezioni.
VisMsg(IWin32Window, String) | Visualizza un messaggio semplice con solo il pulsante OK e l'icona Information.
VisMsg(IWin32Window, DedNetApplication, ListException) | Visualizza la finestra di dialogo per le liste di eccezioni.
VisMsg(IWin32Window, DedNetApplication, Exception) | Visualizza la finestra di dialogo per le eccezioni.
VisMsg(IWin32Window, Exception, Boolean) | Visualizza la finestra di dialogo per le eccezioni.
VisMsg(IWin32Window, String, MessageBoxIcon) | Visualizza un messaggio semplice con solo il pulsante OK e l'icona specificata.
VisMsg(IWin32Window, String, String, MessageBoxIcon) | Visualizza un messaggio semplice con solo il pulsante OK e l'icona specificata.
VisMsg(IWin32Window, String, MessageBoxButtons, MessageBoxIcon) | Visualizza un messaggio semplice con solo il pulsante OK e l'icona specificata.
VisMsg(IWin32Window, String, String, MessageBoxButtons, MessageBoxIcon) | Visualizza un messaggio semplice con solo il pulsante OK e l'icona specificata.
Zip(String, String, Boolean, ActionInt32) | Permette di zippare una cartella. Crea un archivio del contenuto della cartella.
Zip(String, String, Boolean, Boolean, ActionInt32) | Permette di zippare un insieme di file.
ZipFileCount | Ritorna il numero di elementi contenuti nello zip
Torna su
Campi
Nome | Descrizione
ASSPERMCOMMFOLDER | Dizionari utilizzati per le associazioni tra alcuni permessi generici e specifici e viceversa (COMM,FOLDER)
ASSPERMECOFOLDER | Dizionari utilizzati per le associazioni tra alcuni permessi generici e specifici e viceversa (ECO,FOLDER)
ASSPERMFAMFOLDER | Dizionari utilizzati per le associazioni tra alcuni permessi generici e specifici e viceversa (FAM,FOLDER)
ASSPERMFOLDERCOMM | Dizionari utilizzati per le associazioni tra alcuni permessi generici e specifici e viceversa (FOLDER, COMM)
ASSPERMFOLDERECO | Dizionari utilizzati per le associazioni tra alcuni permessi generici e specifici e viceversa (FOLDER, ECO)
ASSPERMFOLDERFAM | Dizionari utilizzati per le associazioni tra alcuni permessi generici e specifici e viceversa (FOLDER, FAM)
DEDCOMM_IDX_NAME | Nome dell'indice sulla colonna COMMNAME nella tabella DED_COMM.
DEFAULT_PERM_DISCRIM | Stringa da utilizzare per indicare che il discriminante del permesso non deve essere preso in considerazione.
ECO_COL | Nome della colonna rappresentante il numero di Eco associati all'anagrafica/commessa. Attenzione! Se si deve cambiare il valore, si deve cambiare anche il nome della property "DedNet.Controls.DedCommAnagExplorer.CommAnagWrapper.NumEcoOnWorking".
FILTER_ECO | Stringa usata nel filtro solo ECO
FILTER_ECO_AND_ECR | Stringa usata nel filtro ECO ed ECR
FILTER_ECR | Stringa usata nel filtro solo ECR
FormToCloseOnOpen | Lista dei nomi dei form che devono essere chiusi dopo l'apertura.
ICON_COL_COLLAPSED_SIZE | Valore larghezza della colonna contenente un'icona quando essa è ristretta.
ICON_COL_EXPANDED_SIZE | Valore larghezza della colonna contenente un'icona quando essa è espansa.
IMPORTED_ATT_NAME | Nome da usare per le liste att che vanno importate da fonti dati esterne tramite evento lua.
ListAttrExcFromProperties | Lista di attributi da escludere durante la lettura delle PROPERTIES
PREVIEW_COL | Nome della colonna preview.
STATEID_COL | Nome della colonna rappresentante il numero di Eco associati all'anagrafica/commessa. Attenzione! Se si deve cambiare il valore, si deve cambiare anche il nome della property "DedNet.Controls.DedCommAnagExplorer.CommAnagWrapper.NumEcoOnWorking".
TableWithIdRevAttr | Lista tabella che contengono gli attributi ID e REV
TableWithIdRevAttrNoDataBom | Lista tabella che contengono gli attributi ID e REV escluse (DED_DATA, DED_DATA_ERASED, DED_BOM)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Proprietà di Utility

Il tipo Utility espone i seguenti membri.

Proprietà
Nome | Descrizione
Application | Applicazione DedNet.
ElaboratingImage | Immagine usata per confrontarla con quella nella cella.
Torna su
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Proprietà Utility.Application

Proprietà UtilityApplication
Applicazione DedNet.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static DedNetApplication Application { get; set; }
Public Shared Property Application As DedNetApplication
    Get
    Set
public:
static property DedNetApplication^ Application {
    DedNetApplication^ get ();
    void set (DedNetApplication^ value);
}
static member Application : DedNetApplication with get, set

Valore della proprietà

DedNetApplication
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Proprietà Utility.ElaboratingImage

Proprietà UtilityElaboratingImage
Immagine usata per confrontarla con quella nella cella.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static Bitmap ElaboratingImage { get; }
Public Shared ReadOnly Property ElaboratingImage As Bitmap
    Get
public:
static property Bitmap^ ElaboratingImage {
    Bitmap^ get ();
}
static member ElaboratingImage : Bitmap with get

Valore della proprietà

Bitmap
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodi di Utility

Il tipo Utility espone i seguenti membri.

Metodi
Nome | Descrizione
AddCellTrasparency | Imposta una trasparenza per far sembrare celle disabilitate
AddControlToLayoutControl | Rimuove il controllo dal dialogo.
AddDocAnagr | Aggiunge i documenti di anagrafica
AddDocAnagrComm | Aggiunge le anagrafiche collegate alla commessa. Se deve aggiunge in modo ricorsivo le anagrafiche collegate alle commesse figlie. Per le anagrafiche delle commesse figlie controllo se devono essere aggiunte anche le commesse figlie
AddDocComm | Aggiunge i documenti di commessa. Se deve aggiunge in modo ricorsivo i documenti delle commesse figlie
AddEcoColumn(GridView) | Metodo usato per aggiungere la colonna degli Eco al GridView passato in ingresso.
AddEcoColumn(TreeList) | Metodo usato per aggiungere la colonna degli Eco al TreeList passato in ingresso.
AddPreviewColumn(GridView, Boolean, Boolean) | Aggiunge alla GridView passata una colonna contenente l'Anteprima e si attacca agli eventi in modo da gestire automaticamente la visualizzazione.
AddPreviewColumn(TreeList, Boolean, Boolean) | Aggiunge una colonna di Anteprima al TreeList passato. ATTENZIONE: A differenza della gridview, con il TreeList occorre gestire manualmente l'evento CustomColumnDisplayText e chiamare il GetFilePreview.
AddStateColumn | Metodo usato per aggiungere la colonna degli Eco al GridView passato in ingresso.
AllineaPrj | Allinea il progetto di Inventor nel caso sia più vecchio del progetto presente sul server.
ApplicationIsAlreadyRunning | Controlla se il processo è già in esecuzione ( fatto in questo modo per gestire anche i casi di Terminal Server )
AskForRepresentationSuffix | Chiede all'utente di inserire il suffisso per la rappresentazione e lo restituisce. Restituisce null se l'utente annulla.
AskUserIfWantsToChangeDataState | Verifica se l'anagrafica passata in ingresso può essere impostata in uno stato di "Working" e, nel caso in cui sia possibile, chiede all'utente se vuole procedere col farlo. Il metodo esegue internamente un RunSubCommand e nel caso in cui siano avvenute eccezzioni queste vengono rilanciate al chiamante.
AttributesDataCanBeEdited | Genera una eccezione se gli attributi di anagrafica non possono essere editati a causa dei documenti in CheckIn.
CalcDistanceBetweenString |
ChangeMouseIconOnECOColumn(GridView, MouseEventArgs, DictionaryString, DictionaryDedEcoEcoTypeEnum, Int32) | Cambia l'icona del mouse se questo è sopra la colonna degli ECO.
ChangeMouseIconOnECOColumn(GridView, MouseEventArgs, Int32) | Cambia l'icona del mouse se questo è sopra la colonna degli ECO.
ChangeMouseIconOnECOColumn(TreeList, MouseEventArgs, DictionaryTreeListNode, TupleInt32, DedEcoEcoTypeEnum, Int32) | Cambia l'icona del mouse se questo è sopra la colonna degli ECO.
CheckDedTypeName |
CheckDocExt | Controlla l'estensione del documento
CheckIsDataExportable | Restituisce true se i documenti dell'anagrafica sono esportabili all'esterno.
CheckIsDocExportable | Restituisce true se i documenti sono esportabili all'esterno.
CheckMinimumLicenseDuringExecuteCommand |
CheckMinimumLicenseDuringInitialize |
CheckMinimumLicenseDuringInitialize(Boolean) |
CheckPrjIsDed | Controlla che il progetto attivo sia congruente con una root di progetto definita nel Database.
CheckProgReserved | Controlla se nelle info passate il progressivo è tra quelli permessi o meno. In caso non lo sia lancia un'eccezione.
CheckValueIsConsistentForDB | Controlla se il valore dell'attributo è consistente con le sue proprietà. REstituisce il messaggio di errore nel parametro stringa passato di ritorno.
CheckViewer(DedCommand, ClientApplicationEnum) | Nel caso sia caricato dentro al VIEW vengono visualizzati solo i comandi di tipo READ.
CheckViewer(DedCommand, DedNetApplication) | Nel caso sia caricato dentro al VIEW vengono visualizzati solo i comandi di tipo READ.
ChiediSovrascritturaFile | Chiede all'utente se sovrascrivere il file di destinazione. Restituisce true se l'utente accetta altrimenti false.
ClickOnRow | Restituisce true se il click con il muose è stato fatto sulla riga del sender. Il sender può essere TreeList, GridControl o GridView
ClientConnectedIsNotCad | Restiruisce true se il client connesso non è un cad 2d/3d (Inventor,Solidworks,Autocad,Bricscad)
CloneFolder | Funzione di clonazione contenuto tra cartelle. Non controlla se la cartella di destinazione sia vuota.
CloseOwnerFormOnLoad | Chiude il form del comando chiamante se necessario contollando la variabile CloseWindowOnOpening.
CloseOwnerFormOnOpening | Chiude il form del comando chiamante se necessario contollando la variabile CloseWindowOnOpening.
CompareStringWithAlphabet | Effettua la comparazione delle due stringhe utilizzando l'alfabeto passato. Restituisce -1 se la prima è minore della seconda, 1 se la prima è maggiore della seconda, 0 se sono uguali.
CompareValues | Confronta due valori. Ritorna true se i due valori sono uguali
ContainsDuplicate | Controlla se la stringa contiene dei caratteri duplicati. Case sensitive.
ContainsInvariant | Controlla l'esistenza di un elemento stringa in una lista effettuando il confronto non case sensitive.
ConvertAttrsNameToPrompt | Converte il dizionario nome-valore a prompt-valore
ConvertPixelWithCurrentDPI_X | Adatta il valore in pixel utilizzando le impostazioni DPI correnti. Il calcolo viene eseguito prendendo in considerazione la dimensione orizzontale.
ConvertPixelWithCurrentDPI_Y | Adatta il valore in pixel utilizzando le impostazioni DPI correnti. Il calcolo viene eseguito prendendo in considerazione la dimensione verticale.
CreateEmptyFile | Crea un file vuoto nella posizione specificata
CreateEmptyTempFile | Crea un nuovo file temporaneo data l'estensione passata e ritorna il path.
CreateShortcut | Crea una shortcut.
CustomizeCell | Personalizza la cella della griglia in base alle informazioni specificate in ingresso.
DecrementString |
DecryptString | Funzione per Decriptare una stringa attraverso una determinata chiave.
DeepObtainAnagr | Controllo se esiste una angrafica associata all'interfaccia data. Utilizza in cascata tutti i possibili campi chiave
DeleteEmptyFolder | Rimuove ricorsivamente tutte le cartelle vuote dato il path indicato
DeleteFolder | Elimina una cartella con tutto il suo contenuto
DestroyIcon(Icon) | Metodo utilizzato per distruggere gli oggetti Icon GDI+ e liberare risorse.
DestroyIcon(IntPtr) | Metodo utilizzato per distruggere gli oggetti Icon GDI+ e liberare risorse.
DisableFloatingObject(Bar) | Obsoleto. Impedisce alla barra passata in ingresso di essere floattante.
DisableFloatingObject(DockManager) | Impedisce a tutti i pannelli del dockmanager passato in ingresso e alle barre di essere floattanti.
DocumentsOperation | Effettua la copia o lo spostamento dei documenti dalla posizione attuale alla nuova destinazione.
EncryptString | Funzione per Criptare una stringa attraverso una determinata chiave.
EvaluateMoveOrDel(MoveDocumentInfo) | In base alle informazioni in ingresso restituisce il risultato con le informazioni di MoveDel sull'elemento
EvaluateMoveOrDel(MoveDocumentInfo, Boolean) | In base alle informazioni in ingresso restituisce il risultato con le informazioni di MoveDel sull'elemento
ExtensionExcludedFromCache | Ritorna vero se l'estensione non è compatibile con la gestione della cache
FileAreSameExtension | Restituisce se i due file sono dello stesso tipo, ovvero se hanno la stessa estensione
FileAreSameFileName | Controlla se i due file name passati coincidoono
FileAreSameModDate | Restituisce se i due file passati abbiano la stessa data di ultima modifica.
FileAreSamePath | Restituisce se i due file passati sono nello stesso path
FileIsLocked | Restituisce true se il file non è accessibile in scrittura.
FileRename | Chiede all'utente il nome e percorso con il quale rinominare il file passato.
FileSave | Chiede all'utente la selezione di uno o più file attraverso la finestra di dialogo standard Apri. Se l'utente annulla viene restituito null altrimenti la lista contenente i documenti selezionati.
FileSelect(IWin32Window, String, Boolean, String, String) | Chiede all'utente la selezione di uno o più file attraverso la finestra di dialogo standard Apri. Se l'utente annulla viene restituito null altrimenti la lista contenente i documenti selezionati.
FileSelect(IWin32Window, String, Boolean, String, String, Boolean) | Chiede all'utente la selezione di uno o più file attraverso la finestra di dialogo standard Apri. Se l'utente annulla viene restituito null altrimenti la lista contenente i documenti selezionati.
FileSelect(IWin32Window, String, Boolean, String, String, String) | Chiede all'utente la selezione di uno o più file attraverso la finestra di dialogo standard Apri. Se l'utente annulla viene restituito null altrimenti la lista contenente i documenti selezionati.
FileSelect(IWin32Window, String, Boolean, String, String, String, Boolean) | Chiede all'utente la selezione di uno o più file attraverso la finestra di dialogo standard Apri. Se l'utente annulla viene restituito null altrimenti la lista contenente i documenti selezionati.
FillContextMenuStrip |
FillDictionaryDirFiles | Crea un dizionario con i file e le rispettive cartelle ( per la gestione delle cartelle ).
FillOnlyDB | Metodo che inizializza gli attributi solo db. In fase di salvataggio / creazione revisione / creazione variante faccio in modo di prelevare dall'anagrafica di partenza tutti gli attributi solo db. Fatto ciò aggiorno l'anagrafica impostata con i valori degli attributi solo db.In questo modo sono sicuro di averli sempre impostati quando a schermo devo visualizzare gli attributi.Se non facessi così e da CAD eseguissi uno dei 3 comandi di salvataggio, gli attributi solo db non verrebbero compilati.
FindExecutable |
FindKeyCaptionInMenu | Restituisce true se l'elemento è già presente nella lista.
FindKeyNameInMenu | Restituisce true se l'elemento è già presente nella lista.
FindProcess | Restituisce i processi abbinati al documento passato.
FolderSelect | Chiede all'utente la selezione di una cartella.
ForceDocRowVerInDb | Aggiorna il ROWVER del DB leggendolo dal documento.
FormatDateTimeStringPattern | Formatta il pattern della date eliminando le parentesi graffe. Attenzione! Per gestire eventuali problematiche il pattern {0} non è cosiderato valido per le date e di conseguenza la funzione ritornerà una stringa vuota.
FormatPermAttrKey | Metodo che ritorna la chiave da utilizzare per identificare l'accoppiata 'attributo' e 'famiglia'. È stato centralizzato in un metodo affinchè se un in un futuro si dovesse cambiare formattazione, basta modificare questo metodo senza dover girare tutto il progetto. Attenzione! Non viene eseguito nessun controllo sulla validità dei parametri.
FormatPermAttrKeyToDelete(DedAttr) | Metodo che ritorna la chiave da utilizzare per identificare i record da eliminare in DED_OBJ_PERM quando viene eliminato un attributo. È stato centralizzato in un metodo affinchè se un in un futuro si dovesse cambiare formattazione, basta modificare questo metodo senza dover girare tutto il progetto. Attenzione! Non viene eseguito nessun controllo sulla validità dei parametri.
FormatPermAttrKeyToDelete(DedTypeBase) | Metodo che ritorna la chiave da utilizzare per identificare i record da eliminare in DED_OBJ_PERM quando viene eliminata una famiglia. È stato centralizzato in un metodo affinchè se un in un futuro si dovesse cambiare formattazione, basta modificare questo metodo senza dover girare tutto il progetto. Attenzione! Non viene eseguito nessun controllo sulla validità dei parametri.
FormatZeroLeft | Restituisce una stringa avente il numero di caratteri specificato riempiendo a sinistra con il carattere di riempimento. Nel caso di caratteri eccedenti elimina da sinistra la parte in eccesso.
GestisciAllegati | Gestisce gli allegati in base all'opzione.
GetAll | Cerca tra tutti i controlli figli del controllo passato quelli di un determintao tipo e li restituisce.
GetAllRootsUsedInFam | Restituisce una lista con tutte le root usate all'interno delle famiglie.
GetAttrFromDBProperties | Restituisce la lista degli attributi relativi alle proprietà
GetBackupFiles | Restituisce una lista sempre inizializzata con i file presenti nelle cartelle di backup di tutte le aree locali.
GetBackupFilesFromPwsPath | Restituisce una lista sempre inizializzata con i file presenti in una specifica area locale.
GetBackupFullFileNameFromDoc | Restituisce il percorso e il nome file del documento da backuppare.
GetCachedIcon | Restituisce l'icona del file/cartella
GetConfigName | Dato un fulldocumentname ritorna il fullfilename privato della configurazione
GetDataFromRegistryByDocId | Metodo che ritorna l'anagrafica in base ai campi ID e REV compilati all'interno della chiave di registro.
GetDateTime | Restituisce una data inizializzata con la data passata ma fino ai secondi, evitando i millisecondi.
GetDocPropertiesColumnName | Restituisce la colonna contenete il dato dal tipo dati passato.
GetDocumentStates | Ritorna un dizionario chiave valore contenente l'accoppiata tra "immagine stato documentale" e "enum identificativo".
GetEcoImage | Restituisce l'iimagine relativa all'eco/ecr con il valore passato
GetEncodeLength | Restituisce la lunghezza della stringa di codifica passata
GetExt | Restituisce l'estensione del nome file passato senza il punto iniziale.
GetExtraLargeFileIcon | Ricava l'icona piccola abbinata all'estensione di un nome file completo.
GetFamInfo | Restituisce il Dbpath della famiglia concatenato alla sua descrizione.
GetFileIcon | Ricava l'icona piccola abbinata all'estensione di un nome file completo.
GetFileNamesFromData | Ricava i nomi file da utilizzare dal'oggetto data passato.
GetFilePerms | Dalla lista dei permessi specificata in ingresso, filtra i permessi dei file e li ritorna sottoforma di nuova lista.
GetFilePreview(TreeList, TreeListNode, DedData) | Ritorna l'anteprima chiamando un thread.
GetFilePreview(TreeList, TreeListNode, String) | Ritorna l'anteprima chiamando un thread.
GetFirstDocFileNameFromData | REstituisce il nome del primo file collegato all'anagrafica in base alla PriorityExtList
GetFirstDocFromData | Restituisce il primo file collegato all'anagrafica in base alla PriorityExtList
GetFtpClient | Restituisce l'oggetto FTPClient con i dati passati
GetFullDocumentName | Dato un filename e una configurazione ritorna il fulldocumentname
GetFullFileName | Dato un fulldocumentname ritorna il fullfilename privato della configurazione
GetImageRectangle(Icon, Rectangle) | Restituisce il rettangolo in cui disegnare l'immagine
GetImageRectangle(Image, Rectangle) | Restituisce il rettangolo in cui disegnare l'immagine
GetImageRectangle(Int32, Int32, Rectangle) | Restituisce il rettangolo in cui disegnare l'immagine
GetImageSizeFromIconSizeType | Resitisce le dimensione delle immagini dalla tipologia di Size passata.
GetInternalException | Restituisce l'eccezione più interna.
GetItemByStringId | Metodo usato per sapere quale menu sta per essere processato.
GetItemSize |
GetItemSizeType |
GetLargeFileIcon | Ricava l'icona piccola abbinata all'estensione di un nome file completo.
GetMaxTokenNum | Restituisce il massimo numero di caratteri usati per il TokenTypeEnum passato. Verifica nella maschera di codifica Cod_Id, Cod_Fil e Cod_Dis in modo da prendere il numero massimo di caratteri utilizzati.
GetMd5FromString | Calcola una Guid data una stringa.
GetMd5HashFile | Restituisce il guid calcolato con Md5 del file passato.
GetMediumFileIcon | Ricava l'icona piccola abbinata all'estensione di un nome file completo.
GetNameVisFromUsername | Trova e restituisce il nome visualizzato dell'utente con username passato.
GetPreview | Estrae l'anteprima dal primo documento dall'anagrafica.
GetQsTempPath | Restituuisce il path per i temp Qs
GetRenamedFileNameNgrMode(DedDoc) | Nel caso di documento associato ad anagrafica NGR e ultima revisione restituisce il nuovo nome file con estensione.
GetRenamedFileNameNgrMode(DedData, DedDoc) | Nel caso di anagrafica NGR e ultima revisione restituisce il nuovo nome file.
GetRootsByFam | Ottiene i path usati per la codifica.
GetRootsByType | Ottiene i percorsi rooted associati al tipo di dato specificato in ingresso. Viene utilizzato in fase di costruzione dei permessi perchè l'oggetto DedNet.PathRoots non è ancora stato inizializzato.
GetSmallFileIcon | Ricava l'icona piccola abbinata all'estensione di un nome file completo.
GetTextQuery | Ritorna la query, in formato testuale del comando passato. I valori dei parametri non sono wrappati tra '' ma visualizzano il valore del parametro
GetTimeSuffix | Restituisce una stringa da utilizzare come suffisso nei nomi delle tabelle di backup, indicante l'anno, il mese, il giorno, l'ora, i minuti ed i secondi attuali.
GetUnboundTypeGrid | Restituisce il tipo UnboundColumnType in base al tipo di Attributo.
GetUnboundTypeTree | Restituisce il tipo UnboundColumnType in base al tipo di Attributo.
GetUniqueAttachFileName | Restituisce un nome univoco da aggiungere ai file allegati. Presuppone che il chiamante abbia già controllato che il destfilename sia già presente a destinazione
GetValidFamName | Restituisce un nome valido per il prompt dell'attributo.
IconIsCached | Controlla se l'icona è già presente nella cache
ImageToString | Convert image to base64 string
IncrementString |
InitFilterState | Inizializza la barra di filtraggio in base agli stati
IsAbsolutePath | Restiruisce true se si tratta di un percorso assoluto.
IsAutoCadFile | Ritorna True se il path passato in ingresso è di un dwg creato da AutoCAD, False altrimenti.
IsDesignerHosted | The DesignMode property does not correctly tell you if you are in design mode. IsDesignerHosted is a corrected version of that property. (see https://connect.microsoft.com/VisualStudio/feedback/details/553305 and http://stackoverflow.com/a/2693338/238419 )
IsDistAttr | restituisce true se è un attributo di distinta altrimenti false
IsDrive | Controlla se il path passato rappresenta una unità logica del sistema
IsDrivePath | Controllo se il path passato può rappresentare una unità logica senza che necessariamente sia connessa
IsFamilyNameValid | Controlla che il nome della famiglia non sia già presente tra i figli della famiglia selezionata.
IsFile | Restituisce True se è un file, False se è una Directory
IsFileNewer | Restituisce true se firstFile è più recente di secondFile.
IsFileReadOnly | Verifica se il file sia readonly. Restituisce false anche se il file non esiste.
IsNaN | Controlla se il valore passato è un NaN.
IsNumber | Ritorna vero se l'oggetto è di tipo numerico
IsSystemPath | Dato un percorso indica se è una cartella modificabile o no.
IsWow64Process | Restituisce se il processo corrente sia a 64 bit.
IsWow64Process(Process) | Restituisce se il processo passato sia a 64 bit.
ListNetworkComputers | Ritorna l'elenco dei computer di rete
MakeDocContext | Calcola e restituisce il contesto da utilizzare per collegare un documento ad un'anagrafica. Restituisce None se non è possibile associare il documento con il contesto richiesto.
MakeGrayscale | Ritorna una nuova immagine partendo dall'originale convertita in scala di grigi
MakeRelative | Relativizza un path dato un path di riferimento
ManageReadOnlyState | Imposta lo stato di sola lettura o meno dei file primary associati all'anagrafica passata e allo stato passato.
ManageScaleFactorByDpi | Metodo che gestisce il ridimensionamento delle icone quando si ha un elevato DPI.
MenuContainsKeyCaption | Restituisce true se l'elemento è già presente nella lista.
MenuContainsKeyName | Restituisce true se l'elemento è già presente nella lista.
NormalizeFamLevel | Sistema il livello della famiglia all'interno della codifica in modo da averlo sempre presente e in positivo
NormalizePath | Funzione di normalizzazione del path per uniformare i percorsi ai fini dei confronti
Now | Restituisce la data attuale fino ai secondi, senza i millisecondi. Questo serve per evitare l'errore generato nelle date in access che non hanno i millisecondi.
ParseDateTime | Converte la stringa in oggetto DateTime se riesce altrimenti null.
ProgCheckIsMyMin | Controlla se il progressivo è il primo di un'aassegnatazione
ProgIsInMyCurrentRange | Restituisce se il progressivo è contenuto nel range corrente, ovvero il primo disponibile non esaurito
ProgIsInMyRange | Restituisce se il progressivo appartiene al range di assegnazione passato
ProgIsInMyRanges(DedTypeProgStruct, String) | Restituisce se il progressivo appartiene alla lista dei progressivi assegnati
ProgIsInMyRanges(DedTypeBase, DedTypeProgList, String) | Restituisce se il progressivo appartiene alla lista dei progressivi assegnati per una determinata famiglia
ProgIsInMyUsedRanges |
RelocateOnExistingAttach | Effettua il relocate
RemoveAttributeLength | Rimuove la lunghezza dai token attributi
RemoveControlFromLayoutControl | Rimuove il controllo dal dialogo.
RemoveGenericDepFromList | Rimuove eventuali dipendenze di tipo generic che si trovano nella lista passata
RemoveInvalidFilePathCharacters | Ritorna un nomefile corretto sostituendo i caratteri non validi con il carattere passato.
RenameFileNgrMode(DedDoc) | Nel caso di documento associato ad anagrafica NGR e ultima revisione restituisce il nuovo nome file salvato nei temp aggiungendogli il tassello della revisione.
RenameFileNgrMode(DedData, DedDoc) | Nel caso di anagrafica NGR e ultima revisione restituisce il nuovo nome file salvato nei temp aggiungendogli il tassello della revisione.
ReplaceEx | Effettua il replace sulla stringa original della stringa pattern con replacement (case insensitive)
ReplaceFirstOccurrance | Sostisuisce solamente la prima occorrenza trovata e restiruisce la stringa modificata.
ReplaceTokens | Sostituisce i tasselli passatti con la stringa passata.
ResetCachePreview | Azzera la cache delle anteprime relative al controllo passato
ResizeBitmap | Ridimensiona l'immagine passata.
ResizeImageHighQuality |
RestorePageSettingsInfo | Rispristina le impostazioni di pagina di esportazione devexpress.
ReturnMaxWidth | Restituisce il maggiore tra la lunghezza della stringa e il massimo passato.
ReverseList | Data un array lo restituisce con nell'ordine invertiro.
RunCommandMenuItem | Esegue il comando abbinato alla voce di menu cliccata e poi lo restituisce.
SaveIdRevInTheRegistry | Metodo che salva nel registro l'Id e la Rev dell'anagrafica associata al documento. In questo modo il documento viene aperto con i dati dell'anagrafica corretta. La chiave di registro viene scritta nel caso in cui: 1) Il documento in apertura si un documento CAD. 2) L'anagrafica impostata sia quella effettivamente associata al documento.
SavePageSettingsInfo | Salva le impostazioni di pagina del PrintableComponentLink in un file xml.
SendCustomMailWithSmtpSettings | Permette di inviare un'email con le credenziali presenti nelle impostazioni SMTP del Gestore notifiche.
SendMail(DedNetApplication, DedNotifyNotifyEvent, DedEco) | Controlla che sia inizializzato il notificatore e nel caso invia la notifica. Se il parametro opzionale 'context' non è impostato, la mail verrà inviata in modo asincrono.
SendMail(DedNetApplication, DedNotifyNotifyEvent, DedDataList, DedCommList) | Controlla che sia inizializzato il notificatore e nel caso invia la notifica.
SendMail(DedNetApplication, DedNotifyNotifyEvent, DedEco, ListDedUser) | Controlla che sia inizializzato il notificatore e nel caso invia la notifica. Se il parametro opzionale 'context' non è impostato, la mail verrà inviata in modo asincrono.
SendMail(DedNetApplication, DedNotifyNotifyEvent, DedDataList, DedCommList, ListDedUser) | Controlla che sia inizializzato il notificatore e nel caso invia la notifica.
SendMailCustomizedEvent(DedNetApplication, String, DedDataList, DedCommList) | Controlla se è presente una notifica personalizzata con il nome passato e nel caso la invia.
SendMailCustomizedEvent(DedNetApplication, String, DedDataList, DedCommList, ListDedUser) | Controlla se è presente una notifica personalizzata con il nome passato e nel caso la invia.
SetColumnDisplayFormatFromAttr | Imposta la formattazione della colonna in base all'attributo specificato.
SetCulture | Metodo che imposta la culture in base alla lingua impostata nel file DedNet.ini
SetDpiAware | Metodo che imposta l'applicazione DPIAware e logga eventuali anomalie
SetEcoColumnProperties | Metodo usato per impostare le proprietà della colonna degli Eco.
SetEnabledMenuItem | Abilita o meno le voci di menu in base al contesto selezionato.
SetFileReadOnly | Imposta la proprietà readOnly del file passato. Se non ci riesce perché il file è bloccato restituisce false. Se il file non esiste restituisce false.
ShellOpenFile | Apre il file passato con la shell di windows, in modo asincrono (che è il default).
ShowECO(TreeListHitInfo, DedData, DictionaryTreeListNode, TupleInt32, DedEcoEcoTypeEnum, Int32) | Visualizza gli ECO associati all'anagrafica cliccata.
ShowECO(GridView, Point, String, Int32) | Visualizza gli ECO associati alla commessa cliccata.
ShowECO(GridView, Point, String, String, DictionaryString, DictionaryDedEcoEcoTypeEnum, Int32) | Visualizza gli ECO associati all'anagrafica cliccata.
ShowECO(GridView, Point, String, String, Int32) | Visualizza gli ECO associati all'anagrafica cliccata.
ShowMarkerInfo | Funzione che mostra lo stato del DOCROWVER del documento passato.
ShowPopUpMenu(PopupMenu, Point, PopupMenuShowingEventArgs) | Mostra il menu contestuale nella posizione passata.
ShowPopUpMenu(PopupMenu, Point, PopupMenuShowingEventArgs) | Mostra il menu contestuale nella posizione passata.
ShowUniqueDependencies | Restituisce se mostrare le dipendenze univoche. Restituisce True se si tratta di assieme o parte.
StringHeight | Metodo che ritorna la lunghezza, in pixel, della stringa passata in ingresso.
StringIsDimension | Contolla se l'attributo è del tipo d12, d432, etc.. e nel caso lo esclude.
StringIsGuid | Restituisce se la stringa rappresenta un Guid.
StringToImage | Convert string to image
StringWidth | Metodo che ritorna la lunghezza, in pixel, della stringa passata in ingresso.
ThrowSpecificException | Cerca di generare un'eccezione più specifica nel caso il progressivo sia riservato a altri utenti.
TranslateColumnsCaption | Data una collection di colonne, ne traduce il testo mostrato a schermo per ogni elemento.
UnFormatZeroLeft | Rimuove i caratteri paddingChar che sono all'inizio della stringa strVal.
UnZip | Unzippa il file passato nella cartella desiderata.
UpdateDedDataPartWithOnlyDbAttrs | Dato un DedDataPart calcolato su un documento, lo aggiorna con gli attributi "Solo Db" dell'anagrafica a cui è collegato. Non sporca il DedDataPart perchè è tra BeginIgnoreDirty ed EndIgnoreDirty.
UpdateString | Incrementa o decrementa la stringa passata iniziando dal carattere più a destra e proseguendo. Se necessario aggiunge un carattere a sinistra (es. 99 -> 100) o lo azzera nel caso di decremento (es. 100 -> 099). Se non riesce a trovare nell'alfabeto il carattere da incrementare verifica il caso più semplice del numero (0-9) o dell'alfabeto (A-Za-z). Se non riesce restituisce la stessa stringa che ha ricevuto come argomento.
ValuesAreDifferent | Restituisce true se i due valori sono diversi.
VisMsg(String) | Visualizza un messaggio semplice con solo il pulsante OK e l'icona Information.
VisMsg(IWin32Window, Exception) | Visualizza la finestra di dialogo per le eccezioni.
VisMsg(IWin32Window, String) | Visualizza un messaggio semplice con solo il pulsante OK e l'icona Information.
VisMsg(IWin32Window, DedNetApplication, ListException) | Visualizza la finestra di dialogo per le liste di eccezioni.
VisMsg(IWin32Window, DedNetApplication, Exception) | Visualizza la finestra di dialogo per le eccezioni.
VisMsg(IWin32Window, Exception, Boolean) | Visualizza la finestra di dialogo per le eccezioni.
VisMsg(IWin32Window, String, MessageBoxIcon) | Visualizza un messaggio semplice con solo il pulsante OK e l'icona specificata.
VisMsg(IWin32Window, String, String, MessageBoxIcon) | Visualizza un messaggio semplice con solo il pulsante OK e l'icona specificata.
VisMsg(IWin32Window, String, MessageBoxButtons, MessageBoxIcon) | Visualizza un messaggio semplice con solo il pulsante OK e l'icona specificata.
VisMsg(IWin32Window, String, String, MessageBoxButtons, MessageBoxIcon) | Visualizza un messaggio semplice con solo il pulsante OK e l'icona specificata.
Zip(String, String, Boolean, ActionInt32) | Permette di zippare una cartella. Crea un archivio del contenuto della cartella.
Zip(String, String, Boolean, Boolean, ActionInt32) | Permette di zippare un insieme di file.
ZipFileCount | Ritorna il numero di elementi contenuti nello zip
Torna su
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.AddCellTrasparency

Metodo UtilityAddCellTrasparency
Imposta una trasparenza per far sembrare celle disabilitate

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void AddCellTrasparency(
    CustomDrawNodeCellEventArgs e
)
Public Shared Sub AddCellTrasparency (
    e As CustomDrawNodeCellEventArgs
)
public:
static void AddCellTrasparency(
    CustomDrawNodeCellEventArgs^ e
)
static member AddCellTrasparency :
        e : CustomDrawNodeCellEventArgs -> unit

Parametri

e CustomDrawNodeCellEventArgs
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.AddControlToLayoutControl

Metodo UtilityAddControlToLayoutControl
Rimuove il controllo dal dialogo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void AddControlToLayoutControl(
    LayoutControl lyt,
    LayoutControlGroup grp,
    LayoutControlItem itemToAdd
)
Public Shared Sub AddControlToLayoutControl (
    lyt As LayoutControl,
    grp As LayoutControlGroup,
    itemToAdd As LayoutControlItem
)
public:
static void AddControlToLayoutControl(
    LayoutControl^ lyt,
    LayoutControlGroup^ grp,
    LayoutControlItem^ itemToAdd
)
static member AddControlToLayoutControl :
        lyt : LayoutControl *
        grp : LayoutControlGroup *
        itemToAdd : LayoutControlItem -> unit

Parametri

lyt LayoutControl
LayoutControl.
grp LayoutControlGroup
LayoutControlGroup.
itemToAdd LayoutControlItem
LayoutControlItem da aggiungere.
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.AddDocAnagr

Metodo UtilityAddDocAnagr
Aggiunge i documenti di anagrafica

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static DedCommandDocAnagrInfoList AddDocAnagr(
    DedDataList dataList,
    DedFormChoseFile frm
)
Public Shared Function AddDocAnagr (
    dataList As DedDataList,
    frm As DedFormChoseFile
) As DedCommandDocAnagrInfoList
public:
static DedCommandDocAnagrInfoList^ AddDocAnagr(
    DedDataList^ dataList,
    DedFormChoseFile^ frm
)
static member AddDocAnagr :
        dataList : DedDataList *
        frm : DedFormChoseFile -> DedCommandDocAnagrInfoList

Parametri

dataList DedDataList
Lista delle anagrafiche
frm DedFormChoseFile
Form contenente tutte le informazioni per cosa importare delle anagrafiche

Valore di ritorno

DedCommandDocAnagrInfoList
Ritorna un oggetto DedCommandDocAnagrInfoList
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.AddDocAnagrComm

Metodo UtilityAddDocAnagrComm
Aggiunge le anagrafiche collegate alla commessa. Se deve aggiunge in modo ricorsivo le anagrafiche collegate alle commesse figlie. Per le anagrafiche delle commesse figlie controllo se devono essere aggiunte anche le commesse figlie

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static DedCommandDocAnagrInfoList AddDocAnagrComm(
    DedComm comm,
    DedFormChoseFile frm,
    ref Dictionary<DedData, bool> dizCacheDedData
)
Public Shared Function AddDocAnagrComm (
    comm As DedComm,
    frm As DedFormChoseFile,
    ByRef dizCacheDedData As Dictionary(Of DedData, Boolean)
) As DedCommandDocAnagrInfoList
public:
static DedCommandDocAnagrInfoList^ AddDocAnagrComm(
    DedComm^ comm,
    DedFormChoseFile^ frm,
    Dictionary<DedData^, bool>^% dizCacheDedData
)
static member AddDocAnagrComm :
        comm : DedComm *
        frm : DedFormChoseFile *
        dizCacheDedData : Dictionary<DedData, bool> byref -> DedCommandDocAnagrInfoList

Parametri

comm DedComm
Commessa
frm DedFormChoseFile
Form contenente tutte le informazioni per cosa importare delle anagrafiche
dizCacheDedData Dictionary DedData, Boolean
Usato per evitare di inserire due volte la stessa anagrafica

Valore di ritorno

DedCommandDocAnagrInfoList
Ritorna un oggetto DedCommandDocAnagrInfoList
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.AddDocComm

Metodo UtilityAddDocComm
Aggiunge i documenti di commessa. Se deve aggiunge in modo ricorsivo i documenti delle commesse figlie

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static DedCommandDocAnagrInfoList AddDocComm(
    DedComm comm,
    DedFormChoseFile frm
)
Public Shared Function AddDocComm (
    comm As DedComm,
    frm As DedFormChoseFile
) As DedCommandDocAnagrInfoList
public:
static DedCommandDocAnagrInfoList^ AddDocComm(
    DedComm^ comm,
    DedFormChoseFile^ frm
)
static member AddDocComm :
        comm : DedComm *
        frm : DedFormChoseFile -> DedCommandDocAnagrInfoList

Parametri

comm DedComm
Commessa
frm DedFormChoseFile
Form contenente tutte le informazioni per cosa importare delle anagrafiche

Valore di ritorno

DedCommandDocAnagrInfoList
Ritorna un oggetto DedCommandDocAnagrInfoList
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.AddEcoColumn

Metodo UtilityAddEcoColumn
Lista degli overload
Nome | Descrizione
AddEcoColumn(GridView) | Metodo usato per aggiungere la colonna degli Eco al GridView passato in ingresso.
AddEcoColumn(TreeList) | Metodo usato per aggiungere la colonna degli Eco al TreeList passato in ingresso.
Torna su
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.AddEcoColumn(GridView)

Metodo UtilityAddEcoColumn(GridView)
Metodo usato per aggiungere la colonna degli Eco al GridView passato in ingresso.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void AddEcoColumn(
    GridView ctr
)
Public Shared Sub AddEcoColumn (
    ctr As GridView
)
public:
static void AddEcoColumn(
    GridView^ ctr
)
static member AddEcoColumn :
        ctr : GridView -> unit

Parametri

ctr GridView
Oggetto GridView al quale aggiungere la colonna degli Eco.
Vedi anche

Documentazione

Classe Utility
Overload di AddEcoColumn
Namespace DedNet.Core


Metodo Utility.AddEcoColumn(TreeList)

Metodo UtilityAddEcoColumn(TreeList)
Metodo usato per aggiungere la colonna degli Eco al TreeList passato in ingresso.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static TreeListColumn AddEcoColumn(
    TreeList ctr
)
Public Shared Function AddEcoColumn (
    ctr As TreeList
) As TreeListColumn
public:
static TreeListColumn^ AddEcoColumn(
    TreeList^ ctr
)
static member AddEcoColumn :
        ctr : TreeList -> TreeListColumn

Parametri

ctr TreeList
Oggetto TreeList al quale aggiungere la colonna degli Eco.

Valore di ritorno

TreeListColumn
Vedi anche

Documentazione

Classe Utility
Overload di AddEcoColumn
Namespace DedNet.Core


Metodo Utility.AddPreviewColumn

Metodo UtilityAddPreviewColumn
Lista degli overload
Nome | Descrizione
AddPreviewColumn(GridView, Boolean, Boolean) | Aggiunge alla GridView passata una colonna contenente l'Anteprima e si attacca agli eventi in modo da gestire automaticamente la visualizzazione.
AddPreviewColumn(TreeList, Boolean, Boolean) | Aggiunge una colonna di Anteprima al TreeList passato. ATTENZIONE: A differenza della gridview, con il TreeList occorre gestire manualmente l'evento CustomColumnDisplayText e chiamare il GetFilePreview.
Torna su
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.AddPreviewColumn(GridView, Boolean, Boolean)

Metodo UtilityAddPreviewColumn(GridView, Boolean, Boolean)
Aggiunge alla GridView passata una colonna contenente l'Anteprima e si attacca agli eventi in modo da gestire automaticamente la visualizzazione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void AddPreviewColumn(
    GridView view,
    bool visible,
    bool handleRowHeight
)
Public Shared Sub AddPreviewColumn (
    view As GridView,
    visible As Boolean,
    handleRowHeight As Boolean
)
public:
static void AddPreviewColumn(
    GridView^ view,
    bool visible,
    bool handleRowHeight
)
static member AddPreviewColumn :
        view : GridView *
        visible : bool *
        handleRowHeight : bool -> unit

Parametri

view GridView
visible Boolean
handleRowHeight Boolean
Vedi anche

Documentazione

Classe Utility
Overload di AddPreviewColumn
Namespace DedNet.Core


Metodo Utility.AddPreviewColumn(TreeList, Boolean, Boolean)

Metodo UtilityAddPreviewColumn(TreeList, Boolean, Boolean)
Aggiunge una colonna di Anteprima al TreeList passato. ATTENZIONE: A differenza della gridview, con il TreeList occorre gestire manualmente l'evento CustomColumnDisplayText e chiamare il GetFilePreview.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static TreeListColumn AddPreviewColumn(
    TreeList tree,
    bool visible,
    bool handleRowHeight
)
Public Shared Function AddPreviewColumn (
    tree As TreeList,
    visible As Boolean,
    handleRowHeight As Boolean
) As TreeListColumn
public:
static TreeListColumn^ AddPreviewColumn(
    TreeList^ tree,
    bool visible,
    bool handleRowHeight
)
static member AddPreviewColumn :
        tree : TreeList *
        visible : bool *
        handleRowHeight : bool -> TreeListColumn

Parametri

tree TreeList
Albero a cui aggiungere la colonna preview.
visible Boolean
Indica se la colonna è attualmente visibile.
handleRowHeight Boolean
Indica se gestire l'evento per uniformare l'altezza del nodo alla larghezza della colonna preview.

Valore di ritorno

TreeListColumn
Vedi anche

Documentazione

Classe Utility
Overload di AddPreviewColumn
Namespace DedNet.Core


Metodo Utility.AddStateColumn

Metodo UtilityAddStateColumn
Metodo usato per aggiungere la colonna degli Eco al GridView passato in ingresso.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void AddStateColumn(
    GridView ctr
)
Public Shared Sub AddStateColumn (
    ctr As GridView
)
public:
static void AddStateColumn(
    GridView^ ctr
)
static member AddStateColumn :
        ctr : GridView -> unit

Parametri

ctr GridView
Oggetto GridView al quale aggiungere la colonna degli Eco.
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.AllineaPrj

Metodo UtilityAllineaPrj
Allinea il progetto di Inventor nel caso sia più vecchio del progetto presente sul server.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void AllineaPrj(
    DedNetApplication app
)
Public Shared Sub AllineaPrj (
    app As DedNetApplication
)
public:
static void AllineaPrj(
    DedNetApplication^ app
)
static member AllineaPrj :
        app : DedNetApplication -> unit

Parametri

app DedNetApplication
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.ApplicationIsAlreadyRunning

Metodo UtilityApplicationIsAlreadyRunning
Controlla se il processo è già in esecuzione ( fatto in questo modo per gestire anche i casi di Terminal Server )

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool ApplicationIsAlreadyRunning(
    string procName
)
Public Shared Function ApplicationIsAlreadyRunning (
    procName As String
) As Boolean
public:
static bool ApplicationIsAlreadyRunning(
    String^ procName
)
static member ApplicationIsAlreadyRunning :
        procName : string -> bool

Parametri

procName String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.AskForRepresentationSuffix

Metodo UtilityAskForRepresentationSuffix
Chiede all'utente di inserire il suffisso per la rappresentazione e lo restituisce. Restituisce null se l'utente annulla.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string AskForRepresentationSuffix(
    string rapIdxDef
)
Public Shared Function AskForRepresentationSuffix (
    rapIdxDef As String
) As String
public:
static String^ AskForRepresentationSuffix(
    String^ rapIdxDef
)
static member AskForRepresentationSuffix :
        rapIdxDef : string -> string

Parametri

rapIdxDef String

Valore di ritorno

String
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.AskUserIfWantsToChangeDataState

Metodo UtilityAskUserIfWantsToChangeDataState
Verifica se l'anagrafica passata in ingresso può essere impostata in uno stato di "Working" e, nel caso in cui sia possibile, chiede all'utente se vuole procedere col farlo. Il metodo esegue internamente un RunSubCommand e nel caso in cui siano avvenute eccezzioni queste vengono rilanciate al chiamante.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool AskUserIfWantsToChangeDataState(
    DedData data,
    IWin32Window parentForm
)
Public Shared Function AskUserIfWantsToChangeDataState (
    data As DedData,
    parentForm As IWin32Window
) As Boolean
public:
static bool AskUserIfWantsToChangeDataState(
    DedData^ data,
    IWin32Window^ parentForm
)
static member AskUserIfWantsToChangeDataState :
        data : DedData *
        parentForm : IWin32Window -> bool

Parametri

data DedData
Anagrafica da esaminare.
parentForm IWin32Window
Dialogo padre da usare come riferimento per il metodo "VisMsg".

Valore di ritorno

Boolean
Ritorna False nel caso in cui l'utente abbia scelto di non cambiare lo stato, True in tutti gli altri casi.
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.AttributesDataCanBeEdited

Metodo UtilityAttributesDataCanBeEdited
Genera una eccezione se gli attributi di anagrafica non possono essere editati a causa dei documenti in CheckIn.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void AttributesDataCanBeEdited(
    DedData data,
    List<Exception> exList
)
Public Shared Sub AttributesDataCanBeEdited (
    data As DedData,
    exList As List(Of Exception)
)
public:
static void AttributesDataCanBeEdited(
    DedData^ data,
    List<Exception^>^ exList
)
static member AttributesDataCanBeEdited :
        data : DedData *
        exList : List<Exception> -> unit

Parametri

data DedData
Anagrafica da controllare.
exList List Exception
Lista delle eccezioni a cui aggiungere il messaggio da visualizzare a schermo.
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.CalcDistanceBetweenString

Metodo UtilityCalcDistanceBetweenString

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static int CalcDistanceBetweenString(
    string firstStr,
    string secondStr,
    string alphabet
)
Public Shared Function CalcDistanceBetweenString (
    firstStr As String,
    secondStr As String,
    alphabet As String
) As Integer
public:
static int CalcDistanceBetweenString(
    String^ firstStr,
    String^ secondStr,
    String^ alphabet
)
static member CalcDistanceBetweenString :
        firstStr : string *
        secondStr : string *
        alphabet : string -> int

Parametri

firstStr String
secondStr String
alphabet String

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.ChangeMouseIconOnECOColumn

Metodo UtilityChangeMouseIconOnECOColumn
Lista degli overload
Nome | Descrizione
ChangeMouseIconOnECOColumn(GridView, MouseEventArgs, DictionaryString, DictionaryDedEcoEcoTypeEnum, Int32) | Cambia l'icona del mouse se questo è sopra la colonna degli ECO.
ChangeMouseIconOnECOColumn(GridView, MouseEventArgs, Int32) | Cambia l'icona del mouse se questo è sopra la colonna degli ECO.
ChangeMouseIconOnECOColumn(TreeList, MouseEventArgs, DictionaryTreeListNode, TupleInt32, DedEcoEcoTypeEnum, Int32) | Cambia l'icona del mouse se questo è sopra la colonna degli ECO.
Torna su
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.ChangeMouseIconOnECOColumn(GridView, MouseEventArgs, Dictionary<String, Dictionary<DedEco.EcoTypeEnum, Int32>>)

Metodo UtilityChangeMouseIconOnECOColumn(GridView, MouseEventArgs, DictionaryString, DictionaryDedEcoEcoTypeEnum, Int32)
Cambia l'icona del mouse se questo è sopra la colonna degli ECO.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void ChangeMouseIconOnECOColumn(
    GridView view,
    MouseEventArgs args,
    Dictionary<string, Dictionary<DedEcoEcoTypeEnum, int>> ecoDiz
)
Public Shared Sub ChangeMouseIconOnECOColumn (
    view As GridView,
    args As MouseEventArgs,
    ecoDiz As Dictionary(Of String, Dictionary(Of DedEcoEcoTypeEnum, Integer))
)
public:
static void ChangeMouseIconOnECOColumn(
    GridView^ view,
    MouseEventArgs^ args,
    Dictionary<String^, Dictionary<DedEcoEcoTypeEnum, int>^>^ ecoDiz
)
static member ChangeMouseIconOnECOColumn :
        view : GridView *
        args : MouseEventArgs *
        ecoDiz : Dictionary<string, Dictionary<DedEcoEcoTypeEnum, int>> -> unit

Parametri

view GridView
args MouseEventArgs
ecoDiz Dictionary String, Dictionary DedEcoEcoTypeEnum, Int32
Vedi anche

Documentazione

Classe Utility
Overload di ChangeMouseIconOnECOColumn
Namespace DedNet.Core


Metodo Utility.ChangeMouseIconOnECOColumn(GridView, MouseEventArgs, Int32)

Metodo UtilityChangeMouseIconOnECOColumn(GridView, MouseEventArgs, Int32)
Cambia l'icona del mouse se questo è sopra la colonna degli ECO.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void ChangeMouseIconOnECOColumn(
    GridView view,
    MouseEventArgs args,
    int numEco
)
Public Shared Sub ChangeMouseIconOnECOColumn (
    view As GridView,
    args As MouseEventArgs,
    numEco As Integer
)
public:
static void ChangeMouseIconOnECOColumn(
    GridView^ view,
    MouseEventArgs^ args,
    int numEco
)
static member ChangeMouseIconOnECOColumn :
        view : GridView *
        args : MouseEventArgs *
        numEco : int -> unit

Parametri

view GridView
args MouseEventArgs
numEco Int32
Vedi anche

Documentazione

Classe Utility
Overload di ChangeMouseIconOnECOColumn
Namespace DedNet.Core


Metodo Utility.ChangeMouseIconOnECOColumn(TreeList, MouseEventArgs, Dictionary<TreeListNode, Tuple<Int32, DedEco.EcoTypeEnum, Int32>>)

Metodo UtilityChangeMouseIconOnECOColumn(TreeList, MouseEventArgs, DictionaryTreeListNode, TupleInt32, DedEcoEcoTypeEnum, Int32)
Cambia l'icona del mouse se questo è sopra la colonna degli ECO.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void ChangeMouseIconOnECOColumn(
    TreeList tree,
    MouseEventArgs args,
    Dictionary<TreeListNode, Tuple<int, DedEcoEcoTypeEnum, int>> ecoDictionary
)
Public Shared Sub ChangeMouseIconOnECOColumn (
    tree As TreeList,
    args As MouseEventArgs,
    ecoDictionary As Dictionary(Of TreeListNode, Tuple(Of Integer, DedEcoEcoTypeEnum, Integer))
)
public:
static void ChangeMouseIconOnECOColumn(
    TreeList^ tree,
    MouseEventArgs^ args,
    Dictionary<TreeListNode^, Tuple<int, DedEcoEcoTypeEnum, int>^>^ ecoDictionary
)
static member ChangeMouseIconOnECOColumn :
        tree : TreeList *
        args : MouseEventArgs *
        ecoDictionary : Dictionary<TreeListNode, Tuple<int, DedEcoEcoTypeEnum, int>> -> unit

Parametri

tree TreeList
args MouseEventArgs
ecoDictionary Dictionary TreeListNode, Tuple Int32, DedEcoEcoTypeEnum, Int32
Vedi anche

Documentazione

Classe Utility
Overload di ChangeMouseIconOnECOColumn
Namespace DedNet.Core


Metodo Utility.CheckDedTypeName

Metodo UtilityCheckDedTypeName

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool CheckDedTypeName(
    string name
)
Public Shared Function CheckDedTypeName (
    name As String
) As Boolean
public:
static bool CheckDedTypeName(
    String^ name
)
static member CheckDedTypeName :
        name : string -> bool

Parametri

name String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.CheckDocExt

Metodo UtilityCheckDocExt
Controlla l'estensione del documento

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool CheckDocExt(
    DedDoc doc,
    List<string> filterExt
)
Public Shared Function CheckDocExt (
    doc As DedDoc,
    filterExt As List(Of String)
) As Boolean
public:
static bool CheckDocExt(
    DedDoc^ doc,
    List<String^>^ filterExt
)
static member CheckDocExt :
        doc : DedDoc *
        filterExt : List<string> -> bool

Parametri

doc DedDoc
Documento da controllare
filterExt List String
Lista delle estensioni da filtrare

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.CheckIsDataExportable

Metodo UtilityCheckIsDataExportable
Restituisce true se i documenti dell'anagrafica sono esportabili all'esterno.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool CheckIsDataExportable(
    DedData data
)
Public Shared Function CheckIsDataExportable (
    data As DedData
) As Boolean
public:
static bool CheckIsDataExportable(
    DedData^ data
)
static member CheckIsDataExportable :
        data : DedData -> bool

Parametri

data DedData

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.CheckIsDocExportable

Metodo UtilityCheckIsDocExportable
Restituisce true se i documenti sono esportabili all'esterno.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool CheckIsDocExportable(
    DedDoc doc
)
Public Shared Function CheckIsDocExportable (
    doc As DedDoc
) As Boolean
public:
static bool CheckIsDocExportable(
    DedDoc^ doc
)
static member CheckIsDocExportable :
        doc : DedDoc -> bool

Parametri

doc DedDoc

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.CheckMinimumLicenseDuringExecuteCommand

Metodo UtilityCheckMinimumLicenseDuringExecuteCommand

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void CheckMinimumLicenseDuringExecuteCommand(
    DedCommandEventArgs e
)
Public Shared Sub CheckMinimumLicenseDuringExecuteCommand (
    e As DedCommandEventArgs
)
public:
static void CheckMinimumLicenseDuringExecuteCommand(
    DedCommandEventArgs^ e
)
static member CheckMinimumLicenseDuringExecuteCommand :
        e : DedCommandEventArgs -> unit

Parametri

e DedCommandEventArgs
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.CheckMinimumLicenseDuringInitialize

Metodo UtilityCheckMinimumLicenseDuringInitialize
Lista degli overload
Nome | Descrizione
CheckMinimumLicenseDuringInitialize |
CheckMinimumLicenseDuringInitialize(Boolean) |
Torna su
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.CheckMinimumLicenseDuringInitialize

Metodo UtilityCheckMinimumLicenseDuringInitialize

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool CheckMinimumLicenseDuringInitialize()
Public Shared Function CheckMinimumLicenseDuringInitialize As Boolean
public:
static bool CheckMinimumLicenseDuringInitialize()
static member CheckMinimumLicenseDuringInitialize : unit -> bool

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Utility
Overload di CheckMinimumLicenseDuringInitialize
Namespace DedNet.Core


Metodo Utility.CheckMinimumLicenseDuringInitialize(Boolean)

Metodo UtilityCheckMinimumLicenseDuringInitialize(Boolean)

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool CheckMinimumLicenseDuringInitialize(
    bool riseException
)
Public Shared Function CheckMinimumLicenseDuringInitialize (
    riseException As Boolean
) As Boolean
public:
static bool CheckMinimumLicenseDuringInitialize(
    bool riseException
)
static member CheckMinimumLicenseDuringInitialize :
        riseException : bool -> bool

Parametri

riseException Boolean

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Utility
Overload di CheckMinimumLicenseDuringInitialize
Namespace DedNet.Core


Metodo Utility.CheckPrjIsDed

Metodo UtilityCheckPrjIsDed
Controlla che il progetto attivo sia congruente con una root di progetto definita nel Database.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool CheckPrjIsDed(
    DedNetApplication app,
    string activePrj
)
Public Shared Function CheckPrjIsDed (
    app As DedNetApplication,
    activePrj As String
) As Boolean
public:
static bool CheckPrjIsDed(
    DedNetApplication^ app,
    String^ activePrj
)
static member CheckPrjIsDed :
        app : DedNetApplication *
        activePrj : string -> bool

Parametri

app DedNetApplication
activePrj String
Progetto da controllare

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.CheckProgReserved

Metodo UtilityCheckProgReserved
Controlla se nelle info passate il progressivo è tra quelli permessi o meno. In caso non lo sia lancia un'eccezione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void CheckProgReserved(
    DedEncodeInfo _info,
    DedData data = null
)
Public Shared Sub CheckProgReserved (
    _info As DedEncodeInfo,
    Optional data As DedData = Nothing
)
public:
static void CheckProgReserved(
    DedEncodeInfo^ _info,
    DedData^ data = nullptr
)
static member CheckProgReserved :
        _info : DedEncodeInfo *
        ?data : DedData
(* Defaults:
        let _data = defaultArg data null
*)
-> unit

Parametri

_info DedEncodeInfo
Info dell'oggetto da analizzare
data DedData (Optional)
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.CheckValueIsConsistentForDB

Metodo UtilityCheckValueIsConsistentForDB
Controlla se il valore dell'attributo è consistente con le sue proprietà. REstituisce il messaggio di errore nel parametro stringa passato di ritorno.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool CheckValueIsConsistentForDB(
    DedAttr dedAttr,
    Object value,
    out string msg
)
Public Shared Function CheckValueIsConsistentForDB (
    dedAttr As DedAttr,
    value As Object,
    <OutAttribute> ByRef msg As String
) As Boolean
public:
static bool CheckValueIsConsistentForDB(
    DedAttr^ dedAttr,
    Object^ value,
    [OutAttribute] String^% msg
)
static member CheckValueIsConsistentForDB :
        dedAttr : DedAttr *
        value : Object *
        msg : string byref -> bool

Parametri

dedAttr DedAttr
Attributo in oggetto.
value Object
Valore da impostare nell'attributo
msg String
Messaggio di errore.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.CheckViewer

Metodo UtilityCheckViewer
Lista degli overload
Nome | Descrizione
CheckViewer(DedCommand, ClientApplicationEnum) | Nel caso sia caricato dentro al VIEW vengono visualizzati solo i comandi di tipo READ.
CheckViewer(DedCommand, DedNetApplication) | Nel caso sia caricato dentro al VIEW vengono visualizzati solo i comandi di tipo READ.
Torna su
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.CheckViewer(DedCommand, ClientApplicationEnum)

Metodo UtilityCheckViewer(DedCommand, ClientApplicationEnum)
Nel caso sia caricato dentro al VIEW vengono visualizzati solo i comandi di tipo READ.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool CheckViewer(
    DedCommand cmd,
    ClientApplicationEnum client
)
Public Shared Function CheckViewer (
    cmd As DedCommand,
    client As ClientApplicationEnum
) As Boolean
public:
static bool CheckViewer(
    DedCommand^ cmd,
    ClientApplicationEnum client
)
static member CheckViewer :
        cmd : DedCommand *
        client : ClientApplicationEnum -> bool

Parametri

cmd DedCommand
Comando da valutare.
client ClientApplicationEnum
Client da comparare.

Valore di ritorno

Boolean
Restituisce se visualizzare o meno il comando a seconda dell'applicativo in esecuzione.
Vedi anche

Documentazione

Classe Utility
Overload di CheckViewer
Namespace DedNet.Core


Metodo Utility.CheckViewer(DedCommand, DedNetApplication)

Metodo UtilityCheckViewer(DedCommand, DedNetApplication)
Nel caso sia caricato dentro al VIEW vengono visualizzati solo i comandi di tipo READ.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool CheckViewer(
    DedCommand cmd,
    DedNetApplication app
)
Public Shared Function CheckViewer (
    cmd As DedCommand,
    app As DedNetApplication
) As Boolean
public:
static bool CheckViewer(
    DedCommand^ cmd,
    DedNetApplication^ app
)
static member CheckViewer :
        cmd : DedCommand *
        app : DedNetApplication -> bool

Parametri

cmd DedCommand
Comando da valutare.
app DedNetApplication
Applicazione in execuzione.

Valore di ritorno

Boolean
Restituisce se visualizzare o meno il comando a seconda dell'applicativo in esecuzione.
Vedi anche

Documentazione

Classe Utility
Overload di CheckViewer
Namespace DedNet.Core


Metodo Utility.ChiediSovrascritturaFile

Metodo UtilityChiediSovrascritturaFile
Chiede all'utente se sovrascrivere il file di destinazione. Restituisce true se l'utente accetta altrimenti false.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool ChiediSovrascritturaFile(
    DedNetApplication app,
    string destFileName
)
Public Shared Function ChiediSovrascritturaFile (
    app As DedNetApplication,
    destFileName As String
) As Boolean
public:
static bool ChiediSovrascritturaFile(
    DedNetApplication^ app,
    String^ destFileName
)
static member ChiediSovrascritturaFile :
        app : DedNetApplication *
        destFileName : string -> bool

Parametri

app DedNetApplication
destFileName String
File da sovrascrivere.

Valore di ritorno

Boolean
Restituisce true se l'utente accetta altrimenti false.
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.ClickOnRow

Metodo UtilityClickOnRow
Restituisce true se il click con il muose è stato fatto sulla riga del sender. Il sender può essere TreeList, GridControl o GridView

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool ClickOnRow(
    Object sender,
    MouseEventArgs e
)
Public Shared Function ClickOnRow (
    sender As Object,
    e As MouseEventArgs
) As Boolean
public:
static bool ClickOnRow(
    Object^ sender,
    MouseEventArgs^ e
)
static member ClickOnRow :
        sender : Object *
        e : MouseEventArgs -> bool

Parametri

sender Object
e MouseEventArgs

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.ClientConnectedIsNotCad

Metodo UtilityClientConnectedIsNotCad
Restiruisce true se il client connesso non è un cad 2d/3d (Inventor,Solidworks,Autocad,Bricscad)

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool ClientConnectedIsNotCad()
Public Shared Function ClientConnectedIsNotCad As Boolean
public:
static bool ClientConnectedIsNotCad()
static member ClientConnectedIsNotCad : unit -> bool

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.CloneFolder

Metodo UtilityCloneFolder
Funzione di clonazione contenuto tra cartelle. Non controlla se la cartella di destinazione sia vuota.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool CloneFolder(
    string sourcePath,
    string destPath
)
Public Shared Function CloneFolder (
    sourcePath As String,
    destPath As String
) As Boolean
public:
static bool CloneFolder(
    String^ sourcePath,
    String^ destPath
)
static member CloneFolder :
        sourcePath : string *
        destPath : string -> bool

Parametri

sourcePath String
Cartella sorgente da cui leggere i contenuti
destPath String
Cartella di destinazione

Valore di ritorno

Boolean
Vero se non si verificano errori
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.CloseOwnerFormOnLoad

Metodo UtilityCloseOwnerFormOnLoad
Chiude il form del comando chiamante se necessario contollando la variabile CloseWindowOnOpening.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void CloseOwnerFormOnLoad(
    DedCommand cmd
)
Public Shared Sub CloseOwnerFormOnLoad (
    cmd As DedCommand
)
public:
static void CloseOwnerFormOnLoad(
    DedCommand^ cmd
)
static member CloseOwnerFormOnLoad :
        cmd : DedCommand -> unit

Parametri

cmd DedCommand
Comando appena eseguito.
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.CloseOwnerFormOnOpening

Metodo UtilityCloseOwnerFormOnOpening
Chiude il form del comando chiamante se necessario contollando la variabile CloseWindowOnOpening.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void CloseOwnerFormOnOpening(
    DedCommand cmd
)
Public Shared Sub CloseOwnerFormOnOpening (
    cmd As DedCommand
)
public:
static void CloseOwnerFormOnOpening(
    DedCommand^ cmd
)
static member CloseOwnerFormOnOpening :
        cmd : DedCommand -> unit

Parametri

cmd DedCommand
Comando appena eseguito.
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.CompareStringWithAlphabet

Metodo UtilityCompareStringWithAlphabet
Effettua la comparazione delle due stringhe utilizzando l'alfabeto passato. Restituisce -1 se la prima è minore della seconda, 1 se la prima è maggiore della seconda, 0 se sono uguali.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static int CompareStringWithAlphabet(
    string firstStr,
    string secondStr,
    string alphabet
)
Public Shared Function CompareStringWithAlphabet (
    firstStr As String,
    secondStr As String,
    alphabet As String
) As Integer
public:
static int CompareStringWithAlphabet(
    String^ firstStr,
    String^ secondStr,
    String^ alphabet
)
static member CompareStringWithAlphabet :
        firstStr : string *
        secondStr : string *
        alphabet : string -> int

Parametri

firstStr String
prima stringa
secondStr String
Seconda stringa
alphabet String
Alfabeto da usare

Valore di ritorno

Int32
Restituisce -1 se la prima è minore della seconda, 1 se la prima è maggiore della seconda, 0 se sono uguali.
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.CompareValues

Metodo UtilityCompareValues
Confronta due valori. Ritorna true se i due valori sono uguali

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool CompareValues(
    Object oldValue,
    Object newValue
)
Public Shared Function CompareValues (
    oldValue As Object,
    newValue As Object
) As Boolean
public:
static bool CompareValues(
    Object^ oldValue,
    Object^ newValue
)
static member CompareValues :
        oldValue : Object *
        newValue : Object -> bool

Parametri

oldValue Object
newValue Object

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.ContainsDuplicate

Metodo UtilityContainsDuplicate
Controlla se la stringa contiene dei caratteri duplicati. Case sensitive.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool ContainsDuplicate(
    string str
)
Public Shared Function ContainsDuplicate (
    str As String
) As Boolean
public:
static bool ContainsDuplicate(
    String^ str
)
static member ContainsDuplicate :
        str : string -> bool

Parametri

str String
Straing ada analizzare.

Valore di ritorno

Boolean
True se contiene duplicati altrimenti False.
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.ContainsInvariant

Metodo UtilityContainsInvariant
Controlla l'esistenza di un elemento stringa in una lista effettuando il confronto non case sensitive.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool ContainsInvariant(
    IList<string> list,
    string item
)
Public Shared Function ContainsInvariant (
    list As IList(Of String),
    item As String
) As Boolean
public:
static bool ContainsInvariant(
    IList<String^>^ list,
    String^ item
)
static member ContainsInvariant :
        list : IList<string> *
        item : string -> bool

Parametri

list IList String
Lista di stringhe da verificare.
item String
Elemento di cui verificare l'esistenza.

Valore di ritorno

Boolean
Restituisce true se trova l'elemento altrimenti false.
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.ConvertAttrsNameToPrompt

Metodo UtilityConvertAttrsNameToPrompt
Converte il dizionario nome-valore a prompt-valore

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static Dictionary<string, Object> ConvertAttrsNameToPrompt(
    DedTypeBase dedType,
    Dictionary<string, Object> attributes
)
Public Shared Function ConvertAttrsNameToPrompt (
    dedType As DedTypeBase,
    attributes As Dictionary(Of String, Object)
) As Dictionary(Of String, Object)
public:
static Dictionary<String^, Object^>^ ConvertAttrsNameToPrompt(
    DedTypeBase^ dedType,
    Dictionary<String^, Object^>^ attributes
)
static member ConvertAttrsNameToPrompt :
        dedType : DedTypeBase *
        attributes : Dictionary<string, Object> -> Dictionary<string, Object>

Parametri

dedType DedTypeBase
Famiglia di riferimento
attributes Dictionary String, Object
Dizionario nome-valore

Valore di ritorno

Dictionary String, Object
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.ConvertPixelWithCurrentDPI_X

Metodo UtilityConvertPixelWithCurrentDPI_X
Adatta il valore in pixel utilizzando le impostazioni DPI correnti. Il calcolo viene eseguito prendendo in considerazione la dimensione orizzontale.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static int ConvertPixelWithCurrentDPI_X(
    int x
)
Public Shared Function ConvertPixelWithCurrentDPI_X (
    x As Integer
) As Integer
public:
static int ConvertPixelWithCurrentDPI_X(
    int x
)
static member ConvertPixelWithCurrentDPI_X :
        x : int -> int

Parametri

x Int32

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.ConvertPixelWithCurrentDPI_Y

Metodo UtilityConvertPixelWithCurrentDPI_Y
Adatta il valore in pixel utilizzando le impostazioni DPI correnti. Il calcolo viene eseguito prendendo in considerazione la dimensione verticale.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static int ConvertPixelWithCurrentDPI_Y(
    int y
)
Public Shared Function ConvertPixelWithCurrentDPI_Y (
    y As Integer
) As Integer
public:
static int ConvertPixelWithCurrentDPI_Y(
    int y
)
static member ConvertPixelWithCurrentDPI_Y :
        y : int -> int

Parametri

y Int32

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.CreateEmptyFile

Metodo UtilityCreateEmptyFile
Crea un file vuoto nella posizione specificata

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void CreateEmptyFile(
    string file
)
Public Shared Sub CreateEmptyFile (
    file As String
)
public:
static void CreateEmptyFile(
    String^ file
)
static member CreateEmptyFile :
        file : string -> unit

Parametri

file String
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.CreateEmptyTempFile

Metodo UtilityCreateEmptyTempFile
Crea un nuovo file temporaneo data l'estensione passata e ritorna il path.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string CreateEmptyTempFile(
    string extension
)
Public Shared Function CreateEmptyTempFile (
    extension As String
) As String
public:
static String^ CreateEmptyTempFile(
    String^ extension
)
static member CreateEmptyTempFile :
        extension : string -> string

Parametri

extension String

Valore di ritorno

String
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.CreateShortcut

Metodo UtilityCreateShortcut
Crea una shortcut.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void CreateShortcut(
    string shortcutName,
    string shortcutPath,
    string targetFileLocation
)
Public Shared Sub CreateShortcut (
    shortcutName As String,
    shortcutPath As String,
    targetFileLocation As String
)
public:
static void CreateShortcut(
    String^ shortcutName,
    String^ shortcutPath,
    String^ targetFileLocation
)
static member CreateShortcut :
        shortcutName : string *
        shortcutPath : string *
        targetFileLocation : string -> unit

Parametri

shortcutName String
shortcutPath String
targetFileLocation String
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.CustomizeCell

Metodo UtilityCustomizeCell
Personalizza la cella della griglia in base alle informazioni specificate in ingresso.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void CustomizeCell(
    RowCellCustomDrawEventArgs e,
    Image img,
    Color rectangle
)
Public Shared Sub CustomizeCell (
    e As RowCellCustomDrawEventArgs,
    img As Image,
    rectangle As Color
)
public:
static void CustomizeCell(
    RowCellCustomDrawEventArgs^ e,
    Image^ img,
    Color rectangle
)
static member CustomizeCell :
        e : RowCellCustomDrawEventArgs *
        img : Image *
        rectangle : Color -> unit

Parametri

e RowCellCustomDrawEventArgs
Evento correntemente processato.
img Image
Immagine che si vuole aggiungere alla cella.
rectangle Color
Colore del bordo della cella.
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.DecrementString

Metodo UtilityDecrementString

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string DecrementString(
    string str,
    int decrementValue,
    string alpabhet
)
Public Shared Function DecrementString (
    str As String,
    decrementValue As Integer,
    alpabhet As String
) As String
public:
static String^ DecrementString(
    String^ str,
    int decrementValue,
    String^ alpabhet
)
static member DecrementString :
        str : string *
        decrementValue : int *
        alpabhet : string -> string

Parametri

str String
decrementValue Int32
alpabhet String

Valore di ritorno

String
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.DecryptString

Metodo UtilityDecryptString
Funzione per Decriptare una stringa attraverso una determinata chiave.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string DecryptString(
    string data,
    string sKey
)
Public Shared Function DecryptString (
    data As String,
    sKey As String
) As String
public:
static String^ DecryptString(
    String^ data,
    String^ sKey
)
static member DecryptString :
        data : string *
        sKey : string -> string

Parametri

data String
Stringa da decodificare
sKey String
-Chiave di decodifica (8 caratteri)

Valore di ritorno

String
Restituisce la stringa decodificata.
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.DeepObtainAnagr

Metodo UtilityDeepObtainAnagr
Controllo se esiste una angrafica associata all'interfaccia data. Utilizza in cascata tutti i possibili campi chiave

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static DedData DeepObtainAnagr(
    DedNetApplication app,
    IDedData iDedData
)
Public Shared Function DeepObtainAnagr (
    app As DedNetApplication,
    iDedData As IDedData
) As DedData
public:
static DedData^ DeepObtainAnagr(
    DedNetApplication^ app,
    IDedData^ iDedData
)
static member DeepObtainAnagr :
        app : DedNetApplication *
        iDedData : IDedData -> DedData

Parametri

app DedNetApplication
iDedData IDedData
Interfaccia da analizzare

Valore di ritorno

DedData
Anagrafica ottenuta
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.DeleteEmptyFolder

Metodo UtilityDeleteEmptyFolder
Rimuove ricorsivamente tutte le cartelle vuote dato il path indicato

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void DeleteEmptyFolder(
    string startLocation,
    bool includeStartLocation = false
)
Public Shared Sub DeleteEmptyFolder (
    startLocation As String,
    Optional includeStartLocation As Boolean = false
)
public:
static void DeleteEmptyFolder(
    String^ startLocation,
    bool includeStartLocation = false
)
static member DeleteEmptyFolder :
        startLocation : string *
        ?includeStartLocation : bool
(* Defaults:
        let _includeStartLocation = defaultArg includeStartLocation false
*)
-> unit

Parametri

startLocation String
Posizione iniziale della ricorsione
includeStartLocation Boolean (Optional)
Indica se includere la radice passata (di default è false)
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.DeleteFolder

Metodo UtilityDeleteFolder
Elimina una cartella con tutto il suo contenuto

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void DeleteFolder(
    string path
)
Public Shared Sub DeleteFolder (
    path As String
)
public:
static void DeleteFolder(
    String^ path
)
static member DeleteFolder :
        path : string -> unit

Parametri

path String
Percorso che identifica il direttorio
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.DestroyIcon

Metodo UtilityDestroyIcon
Lista degli overload
Nome | Descrizione
DestroyIcon(Icon) | Metodo utilizzato per distruggere gli oggetti Icon GDI+ e liberare risorse.
DestroyIcon(IntPtr) | Metodo utilizzato per distruggere gli oggetti Icon GDI+ e liberare risorse.
Torna su
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.DestroyIcon(Icon)

Metodo UtilityDestroyIcon(Icon)
Metodo utilizzato per distruggere gli oggetti Icon GDI+ e liberare risorse.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool DestroyIcon(
    Icon icon
)
Public Shared Function DestroyIcon (
    icon As Icon
) As Boolean
public:
static bool DestroyIcon(
    Icon^ icon
)
static member DestroyIcon :
        icon : Icon -> bool

Parametri

icon Icon
Icona da distruggere.

Valore di ritorno

Boolean
True se successo, False altrimenti.
Vedi anche

Documentazione

Classe Utility
Overload di DestroyIcon
Namespace DedNet.Core


Metodo Utility.DestroyIcon(IntPtr)

Metodo UtilityDestroyIcon(IntPtr)
Metodo utilizzato per distruggere gli oggetti Icon GDI+ e liberare risorse.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool DestroyIcon(
    IntPtr hndl
)
Public Shared Function DestroyIcon (
    hndl As IntPtr
) As Boolean
public:
static bool DestroyIcon(
    IntPtr hndl
)
static member DestroyIcon :
        hndl : IntPtr -> bool

Parametri

hndl IntPtr
Handle dell'icona da distruggere.

Valore di ritorno

Boolean
True se successo, False altrimenti.
Vedi anche

Documentazione

Classe Utility
Overload di DestroyIcon
Namespace DedNet.Core


Metodo Utility.DisableFloatingObject

Metodo UtilityDisableFloatingObject
Lista degli overload
Nome | Descrizione
DisableFloatingObject(Bar) | Obsoleto. Impedisce alla barra passata in ingresso di essere floattante.
DisableFloatingObject(DockManager) | Impedisce a tutti i pannelli del dockmanager passato in ingresso e alle barre di essere floattanti.
Torna su
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.DisableFloatingObject(Bar)

Metodo UtilityDisableFloatingObject(Bar)

Nota: questa API è obsoleta.

Impedisce alla barra passata in ingresso di essere floattante.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Questo metodo è obsoleto in quanto la nuova logica viene gestita nella classe 'DedNet.Forms.BaseForm'.",
    false)]
public static void DisableFloatingObject(
    Bar bar
)
<ObsoleteAttribute("Questo metodo è obsoleto in quanto la nuova logica viene gestita nella classe 'DedNet.Forms.BaseForm'.",
    false)>
Public Shared Sub DisableFloatingObject (
    bar As Bar
)
public:
[ObsoleteAttribute(L"Questo metodo è obsoleto in quanto la nuova logica viene gestita nella classe 'DedNet.Forms.BaseForm'.",
    false)]
static void DisableFloatingObject(
    Bar^ bar
)
[<ObsoleteAttribute("Questo metodo è obsoleto in quanto la nuova logica viene gestita nella classe 'DedNet.Forms.BaseForm'.",
    false)>]
static member DisableFloatingObject :
        bar : Bar -> unit

Parametri

bar Bar
Vedi anche

Documentazione

Classe Utility
Overload di DisableFloatingObject
Namespace DedNet.Core


Metodo Utility.DisableFloatingObject(DockManager)

Metodo UtilityDisableFloatingObject(DockManager)
Impedisce a tutti i pannelli del dockmanager passato in ingresso e alle barre di essere floattanti.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void DisableFloatingObject(
    DockManager dckm
)
Public Shared Sub DisableFloatingObject (
    dckm As DockManager
)
public:
static void DisableFloatingObject(
    DockManager^ dckm
)
static member DisableFloatingObject :
        dckm : DockManager -> unit

Parametri

dckm DockManager
Vedi anche

Documentazione

Classe Utility
Overload di DisableFloatingObject
Namespace DedNet.Core


Metodo Utility.DocumentsOperation

Metodo UtilityDocumentsOperation
Effettua la copia o lo spostamento dei documenti dalla posizione attuale alla nuova destinazione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void DocumentsOperation(
    string file,
    DragDropEffects effect,
    string destPath,
    string fromPath,
    bool isMoveDir
)
Public Shared Sub DocumentsOperation (
    file As String,
    effect As DragDropEffects,
    destPath As String,
    fromPath As String,
    isMoveDir As Boolean
)
public:
static void DocumentsOperation(
    String^ file,
    DragDropEffects effect,
    String^ destPath,
    String^ fromPath,
    bool isMoveDir
)
static member DocumentsOperation :
        file : string *
        effect : DragDropEffects *
        destPath : string *
        fromPath : string *
        isMoveDir : bool -> unit

Parametri

file String
effect DragDropEffects
Indica se effettuare una copia o uno sposta.
destPath String
Percorso di destinazione.
fromPath String
isMoveDir Boolean
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.EncryptString

Metodo UtilityEncryptString
Funzione per Criptare una stringa attraverso una determinata chiave.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string EncryptString(
    string data,
    string sKey
)
Public Shared Function EncryptString (
    data As String,
    sKey As String
) As String
public:
static String^ EncryptString(
    String^ data,
    String^ sKey
)
static member EncryptString :
        data : string *
        sKey : string -> string

Parametri

data String
Stringa da codificare
sKey String
-Chiave di codifica (8 caratteri)

Valore di ritorno

String
Restituisce la stringa codificata.
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.EvaluateMoveOrDel

Metodo UtilityEvaluateMoveOrDel
Lista degli overload
Nome | Descrizione
EvaluateMoveOrDel(MoveDocumentInfo) | In base alle informazioni in ingresso restituisce il risultato con le informazioni di MoveDel sull'elemento
EvaluateMoveOrDel(MoveDocumentInfo, Boolean) | In base alle informazioni in ingresso restituisce il risultato con le informazioni di MoveDel sull'elemento
Torna su
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.EvaluateMoveOrDel(MoveDocumentInfo)

Metodo UtilityEvaluateMoveOrDel(MoveDocumentInfo)
In base alle informazioni in ingresso restituisce il risultato con le informazioni di MoveDel sull'elemento

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static MoveDocumentResult EvaluateMoveOrDel(
    MoveDocumentInfo moveDocInfo
)
Public Shared Function EvaluateMoveOrDel (
    moveDocInfo As MoveDocumentInfo
) As MoveDocumentResult
public:
static MoveDocumentResult^ EvaluateMoveOrDel(
    MoveDocumentInfo^ moveDocInfo
)
static member EvaluateMoveOrDel :
        moveDocInfo : MoveDocumentInfo -> MoveDocumentResult

Parametri

moveDocInfo MoveDocumentInfo
Informazioni sull'oggetto da elaborare

Valore di ritorno

MoveDocumentResult
Vedi anche

Documentazione

Classe Utility
Overload di EvaluateMoveOrDel
Namespace DedNet.Core


Metodo Utility.EvaluateMoveOrDel(MoveDocumentInfo, Boolean)

Metodo UtilityEvaluateMoveOrDel(MoveDocumentInfo, Boolean)
In base alle informazioni in ingresso restituisce il risultato con le informazioni di MoveDel sull'elemento

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static MoveDocumentResult EvaluateMoveOrDel(
    MoveDocumentInfo moveDocInfo,
    bool fireEvent
)
Public Shared Function EvaluateMoveOrDel (
    moveDocInfo As MoveDocumentInfo,
    fireEvent As Boolean
) As MoveDocumentResult
public:
static MoveDocumentResult^ EvaluateMoveOrDel(
    MoveDocumentInfo^ moveDocInfo,
    bool fireEvent
)
static member EvaluateMoveOrDel :
        moveDocInfo : MoveDocumentInfo *
        fireEvent : bool -> MoveDocumentResult

Parametri

moveDocInfo MoveDocumentInfo
Informazioni sull'oggetto da elaborare
fireEvent Boolean
Indica se eseguire l'evento OnManagePlaceHolderLogicComputed per le personalizzazioni

Valore di ritorno

MoveDocumentResult
Vedi anche

Documentazione

Classe Utility
Overload di EvaluateMoveOrDel
Namespace DedNet.Core


Metodo Utility.ExtensionExcludedFromCache

Metodo UtilityExtensionExcludedFromCache
Ritorna vero se l'estensione non è compatibile con la gestione della cache

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool ExtensionExcludedFromCache(
    string ext
)
Public Shared Function ExtensionExcludedFromCache (
    ext As String
) As Boolean
public:
static bool ExtensionExcludedFromCache(
    String^ ext
)
static member ExtensionExcludedFromCache :
        ext : string -> bool

Parametri

ext String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.FileAreSameExtension

Metodo UtilityFileAreSameExtension
Restituisce se i due file sono dello stesso tipo, ovvero se hanno la stessa estensione

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool FileAreSameExtension(
    string firstFile,
    string secondFile
)
Public Shared Function FileAreSameExtension (
    firstFile As String,
    secondFile As String
) As Boolean
public:
static bool FileAreSameExtension(
    String^ firstFile,
    String^ secondFile
)
static member FileAreSameExtension :
        firstFile : string *
        secondFile : string -> bool

Parametri

firstFile String
Primo file da confrontare.
secondFile String
Secondo file da confrontare.

Valore di ritorno

Boolean
Restitusice true se i file hanno la stessa data di ultima modifica altrimenti false.
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.FileAreSameFileName

Metodo UtilityFileAreSameFileName
Controlla se i due file name passati coincidoono

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool FileAreSameFileName(
    string firstFile,
    string secondFile
)
Public Shared Function FileAreSameFileName (
    firstFile As String,
    secondFile As String
) As Boolean
public:
static bool FileAreSameFileName(
    String^ firstFile,
    String^ secondFile
)
static member FileAreSameFileName :
        firstFile : string *
        secondFile : string -> bool

Parametri

firstFile String
secondFile String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.FileAreSameModDate

Metodo UtilityFileAreSameModDate
Restituisce se i due file passati abbiano la stessa data di ultima modifica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool FileAreSameModDate(
    string firstFile,
    string secondFile
)
Public Shared Function FileAreSameModDate (
    firstFile As String,
    secondFile As String
) As Boolean
public:
static bool FileAreSameModDate(
    String^ firstFile,
    String^ secondFile
)
static member FileAreSameModDate :
        firstFile : string *
        secondFile : string -> bool

Parametri

firstFile String
Primo file da confrontare.
secondFile String
Secondo file da confrontare.

Valore di ritorno

Boolean
Restitusice true se i file hanno la stessa data di ultima modifica altrimenti false.
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.FileAreSamePath

Metodo UtilityFileAreSamePath
Restituisce se i due file passati sono nello stesso path

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool FileAreSamePath(
    string firstFile,
    string secondFile
)
Public Shared Function FileAreSamePath (
    firstFile As String,
    secondFile As String
) As Boolean
public:
static bool FileAreSamePath(
    String^ firstFile,
    String^ secondFile
)
static member FileAreSamePath :
        firstFile : string *
        secondFile : string -> bool

Parametri

firstFile String
Primo file da confrontare.
secondFile String
Secondo file da confrontare.

Valore di ritorno

Boolean
Restitusice true se i file risiedono nella stessa cartella.
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.FileIsLocked

Metodo UtilityFileIsLocked
Restituisce true se il file non è accessibile in scrittura.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool FileIsLocked(
    string fileFullPathName
)
Public Shared Function FileIsLocked (
    fileFullPathName As String
) As Boolean
public:
static bool FileIsLocked(
    String^ fileFullPathName
)
static member FileIsLocked :
        fileFullPathName : string -> bool

Parametri

fileFullPathName String
File da verificare.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.FileRename

Metodo UtilityFileRename
Chiede all'utente il nome e percorso con il quale rinominare il file passato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string FileRename(
    IWin32Window ownerForm,
    string startFileName
)
Public Shared Function FileRename (
    ownerForm As IWin32Window,
    startFileName As String
) As String
public:
static String^ FileRename(
    IWin32Window^ ownerForm,
    String^ startFileName
)
static member FileRename :
        ownerForm : IWin32Window *
        startFileName : string -> string

Parametri

ownerForm IWin32Window
Form parent.
startFileName String
File da rinominare.

Valore di ritorno

String
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.FileSave

Metodo UtilityFileSave
Chiede all'utente la selezione di uno o più file attraverso la finestra di dialogo standard Apri. Se l'utente annulla viene restituito null altrimenti la lista contenente i documenti selezionati.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string FileSave(
    IWin32Window ownerForm,
    string[] paths,
    string extFilter,
    string saveExtension,
    string title,
    string initialDirectory,
    string defaultFileName
)
Public Shared Function FileSave (
    ownerForm As IWin32Window,
    paths As String(),
    extFilter As String,
    saveExtension As String,
    title As String,
    initialDirectory As String,
    defaultFileName As String
) As String
public:
static String^ FileSave(
    IWin32Window^ ownerForm,
    array<String^>^ paths,
    String^ extFilter,
    String^ saveExtension,
    String^ title,
    String^ initialDirectory,
    String^ defaultFileName
)
static member FileSave :
        ownerForm : IWin32Window *
        paths : string[] *
        extFilter : string *
        saveExtension : string *
        title : string *
        initialDirectory : string *
        defaultFileName : string -> string

Parametri

ownerForm IWin32Window
Parent Form.
paths String
Percorsi ad aggiungere ai custom places di windows vista o 7. Può essere null.
extFilter String
Stringa di filtro estensioni oppure null per impostare Tutti i file.
saveExtension String
title String
Titolo della finestra oppure nell per lasciare il titolo originale 'Apri'.
initialDirectory String
Directory di selezione iniziale.
defaultFileName String

Valore di ritorno

String
Restituisce la lista dei documenti selezionati dall'utente oppure null se annulla la selezione.
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.FileSelect

Metodo UtilityFileSelect
Lista degli overload
Nome | Descrizione
FileSelect(IWin32Window, String, Boolean, String, String) | Chiede all'utente la selezione di uno o più file attraverso la finestra di dialogo standard Apri. Se l'utente annulla viene restituito null altrimenti la lista contenente i documenti selezionati.
FileSelect(IWin32Window, String, Boolean, String, String, Boolean) | Chiede all'utente la selezione di uno o più file attraverso la finestra di dialogo standard Apri. Se l'utente annulla viene restituito null altrimenti la lista contenente i documenti selezionati.
FileSelect(IWin32Window, String, Boolean, String, String, String) | Chiede all'utente la selezione di uno o più file attraverso la finestra di dialogo standard Apri. Se l'utente annulla viene restituito null altrimenti la lista contenente i documenti selezionati.
FileSelect(IWin32Window, String, Boolean, String, String, String, Boolean) | Chiede all'utente la selezione di uno o più file attraverso la finestra di dialogo standard Apri. Se l'utente annulla viene restituito null altrimenti la lista contenente i documenti selezionati.
Torna su
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.FileSelect(IWin32Window, String[], Boolean, String, String)

Metodo UtilityFileSelect(IWin32Window, String, Boolean, String, String)
Chiede all'utente la selezione di uno o più file attraverso la finestra di dialogo standard Apri. Se l'utente annulla viene restituito null altrimenti la lista contenente i documenti selezionati.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string[] FileSelect(
    IWin32Window ownerForm,
    string[] paths,
    bool multiSelect,
    string extFilter,
    string title
)
Public Shared Function FileSelect (
    ownerForm As IWin32Window,
    paths As String(),
    multiSelect As Boolean,
    extFilter As String,
    title As String
) As String()
public:
static array<String^>^ FileSelect(
    IWin32Window^ ownerForm,
    array<String^>^ paths,
    bool multiSelect,
    String^ extFilter,
    String^ title
)
static member FileSelect :
        ownerForm : IWin32Window *
        paths : string[] *
        multiSelect : bool *
        extFilter : string *
        title : string -> string[]

Parametri

ownerForm IWin32Window
Parent Form.
paths String
Percorsi ad aggiungere ai custom places di windows vista o 7. Può essere null.
multiSelect Boolean
Indica se sia consentita la selezione multipla.
extFilter String
Stringa di filtro estensioni oppure null per impostare Tutti i file.
title String
Titolo della finestra oppure nell per lasciare il titolo originale 'Apri'.

Valore di ritorno

String
Restituisce la lista dei documenti selezionati dall'utente oppure null se annulla la selezione.
Vedi anche

Documentazione

Classe Utility
Overload di FileSelect
Namespace DedNet.Core


Metodo Utility.FileSelect(IWin32Window, String[], Boolean, String, String, Boolean)

Metodo UtilityFileSelect(IWin32Window, String, Boolean, String, String, Boolean)
Chiede all'utente la selezione di uno o più file attraverso la finestra di dialogo standard Apri. Se l'utente annulla viene restituito null altrimenti la lista contenente i documenti selezionati.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string[] FileSelect(
    IWin32Window ownerForm,
    string[] paths,
    bool multiSelect,
    string extFilter,
    string title,
    bool rememberLastFolder
)
Public Shared Function FileSelect (
    ownerForm As IWin32Window,
    paths As String(),
    multiSelect As Boolean,
    extFilter As String,
    title As String,
    rememberLastFolder As Boolean
) As String()
public:
static array<String^>^ FileSelect(
    IWin32Window^ ownerForm,
    array<String^>^ paths,
    bool multiSelect,
    String^ extFilter,
    String^ title,
    bool rememberLastFolder
)
static member FileSelect :
        ownerForm : IWin32Window *
        paths : string[] *
        multiSelect : bool *
        extFilter : string *
        title : string *
        rememberLastFolder : bool -> string[]

Parametri

ownerForm IWin32Window
Parent Form.
paths String
Percorsi ad aggiungere ai custom places di windows vista o 7. Può essere null.
multiSelect Boolean
Indica se sia consentita la selezione multipla.
extFilter String
Stringa di filtro estensioni oppure null per impostare Tutti i file.
title String
Titolo della finestra oppure nell per lasciare il titolo originale 'Apri'.
rememberLastFolder Boolean
Indica se il dialogo deve utilizzare come cartella iniziale quella della sessione precedente (in caso contrario verrà utilizzato C:\\).

Valore di ritorno

String
Restituisce la lista dei documenti selezionati dall'utente oppure null se annulla la selezione.
Vedi anche

Documentazione

Classe Utility
Overload di FileSelect
Namespace DedNet.Core


Metodo Utility.FileSelect(IWin32Window, String[], Boolean, String, String, String)

Metodo UtilityFileSelect(IWin32Window, String, Boolean, String, String, String)
Chiede all'utente la selezione di uno o più file attraverso la finestra di dialogo standard Apri. Se l'utente annulla viene restituito null altrimenti la lista contenente i documenti selezionati.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string[] FileSelect(
    IWin32Window ownerForm,
    string[] paths,
    bool multiSelect,
    string extFilter,
    string title,
    string initialDirectory
)
Public Shared Function FileSelect (
    ownerForm As IWin32Window,
    paths As String(),
    multiSelect As Boolean,
    extFilter As String,
    title As String,
    initialDirectory As String
) As String()
public:
static array<String^>^ FileSelect(
    IWin32Window^ ownerForm,
    array<String^>^ paths,
    bool multiSelect,
    String^ extFilter,
    String^ title,
    String^ initialDirectory
)
static member FileSelect :
        ownerForm : IWin32Window *
        paths : string[] *
        multiSelect : bool *
        extFilter : string *
        title : string *
        initialDirectory : string -> string[]

Parametri

ownerForm IWin32Window
Parent Form.
paths String
Percorsi ad aggiungere ai custom places di windows vista o 7. Può essere null.
multiSelect Boolean
Indica se sia consentita la selezione multipla.
extFilter String
Stringa di filtro estensioni oppure null per impostare Tutti i file.
title String
Titolo della finestra oppure nell per lasciare il titolo originale 'Apri'.
initialDirectory String
Directory di selezione iniziale.

Valore di ritorno

String
Restituisce la lista dei documenti selezionati dall'utente oppure null se annulla la selezione.
Vedi anche

Documentazione

Classe Utility
Overload di FileSelect
Namespace DedNet.Core


Metodo Utility.FileSelect(IWin32Window, String[], Boolean, String, String, String, Boolean)

Metodo UtilityFileSelect(IWin32Window, String, Boolean, String, String, String, Boolean)
Chiede all'utente la selezione di uno o più file attraverso la finestra di dialogo standard Apri. Se l'utente annulla viene restituito null altrimenti la lista contenente i documenti selezionati.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string[] FileSelect(
    IWin32Window ownerForm,
    string[] paths,
    bool multiSelect,
    string extFilter,
    string title,
    string initialDirectory,
    bool rememberLastFolder
)
Public Shared Function FileSelect (
    ownerForm As IWin32Window,
    paths As String(),
    multiSelect As Boolean,
    extFilter As String,
    title As String,
    initialDirectory As String,
    rememberLastFolder As Boolean
) As String()
public:
static array<String^>^ FileSelect(
    IWin32Window^ ownerForm,
    array<String^>^ paths,
    bool multiSelect,
    String^ extFilter,
    String^ title,
    String^ initialDirectory,
    bool rememberLastFolder
)
static member FileSelect :
        ownerForm : IWin32Window *
        paths : string[] *
        multiSelect : bool *
        extFilter : string *
        title : string *
        initialDirectory : string *
        rememberLastFolder : bool -> string[]

Parametri

ownerForm IWin32Window
Parent Form.
paths String
Percorsi ad aggiungere ai custom places di windows vista o 7. Può essere null.
multiSelect Boolean
Indica se sia consentita la selezione multipla.
extFilter String
Stringa di filtro estensioni oppure null per impostare Tutti i file.
title String
Titolo della finestra oppure nell per lasciare il titolo originale 'Apri'.
initialDirectory String
Directory di selezione iniziale.
rememberLastFolder Boolean
Indica se il dialogo deve utilizzare come cartella iniziale quella della sessione precedente (in caso contrario verrà utilizzato C:\\).

Valore di ritorno

String
Restituisce la lista dei documenti selezionati dall'utente oppure null se annulla la selezione.
Vedi anche

Documentazione

Classe Utility
Overload di FileSelect
Namespace DedNet.Core


Metodo Utility.FillContextMenuStrip

Metodo UtilityFillContextMenuStrip

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void FillContextMenuStrip(
    Object ctr,
    DedNetApplication app,
    PopupMenu ctrCtx,
    DedCommandList commandList,
    CommandContextEnum commandContext,
    ItemClickEventHandler handler
)
Public Shared Sub FillContextMenuStrip (
    ctr As Object,
    app As DedNetApplication,
    ctrCtx As PopupMenu,
    commandList As DedCommandList,
    commandContext As CommandContextEnum,
    handler As ItemClickEventHandler
)
public:
static void FillContextMenuStrip(
    Object^ ctr,
    DedNetApplication^ app,
    PopupMenu^ ctrCtx,
    DedCommandList^ commandList,
    CommandContextEnum commandContext,
    ItemClickEventHandler^ handler
)
static member FillContextMenuStrip :
        ctr : Object *
        app : DedNetApplication *
        ctrCtx : PopupMenu *
        commandList : DedCommandList *
        commandContext : CommandContextEnum *
        handler : ItemClickEventHandler -> unit

Parametri

ctr Object
app DedNetApplication
ctrCtx PopupMenu
commandList DedCommandList
commandContext CommandContextEnum
handler ItemClickEventHandler
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.FillDictionaryDirFiles

Metodo UtilityFillDictionaryDirFiles
Crea un dizionario con i file e le rispettive cartelle ( per la gestione delle cartelle ).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void FillDictionaryDirFiles(
    string dirParent,
    string[] paths,
    Dictionary<string, string> resDiztoMove,
    List<string> filepaths
)
Public Shared Sub FillDictionaryDirFiles (
    dirParent As String,
    paths As String(),
    resDiztoMove As Dictionary(Of String, String),
    filepaths As List(Of String)
)
public:
static void FillDictionaryDirFiles(
    String^ dirParent,
    array<String^>^ paths,
    Dictionary<String^, String^>^ resDiztoMove,
    List<String^>^ filepaths
)
static member FillDictionaryDirFiles :
        dirParent : string *
        paths : string[] *
        resDiztoMove : Dictionary<string, string> *
        filepaths : List<string> -> unit

Parametri

dirParent String
paths String
resDiztoMove Dictionary String, String
filepaths List String
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.FillOnlyDB

Metodo UtilityFillOnlyDB
Metodo che inizializza gli attributi solo db. In fase di salvataggio / creazione revisione / creazione variante faccio in modo di prelevare dall'anagrafica di partenza tutti gli attributi solo db. Fatto ciò aggiorno l'anagrafica impostata con i valori degli attributi solo db.In questo modo sono sicuro di averli sempre impostati quando a schermo devo visualizzare gli attributi.Se non facessi così e da CAD eseguissi uno dei 3 comandi di salvataggio, gli attributi solo db non verrebbero compilati.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void FillOnlyDB(
    DedData startingData,
    DedEncodeInfo info
)
Public Shared Sub FillOnlyDB (
    startingData As DedData,
    info As DedEncodeInfo
)
public:
static void FillOnlyDB(
    DedData^ startingData,
    DedEncodeInfo^ info
)
static member FillOnlyDB :
        startingData : DedData *
        info : DedEncodeInfo -> unit

Parametri

startingData DedData
info DedEncodeInfo
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.FindExecutable

Metodo UtilityFindExecutable

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static long FindExecutable(
    string lpFile,
    string lpDirectory,
    StringBuilder lpResult
)
Public Shared Function FindExecutable (
    lpFile As String,
    lpDirectory As String,
    lpResult As StringBuilder
) As Long
public:
static long long FindExecutable(
    String^ lpFile,
    String^ lpDirectory,
    StringBuilder^ lpResult
)
static member FindExecutable :
        lpFile : string *
        lpDirectory : string *
        lpResult : StringBuilder -> int64

Parametri

lpFile String
lpDirectory String
lpResult StringBuilder

Valore di ritorno

Int64
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.FindKeyCaptionInMenu

Metodo UtilityFindKeyCaptionInMenu
Restituisce true se l'elemento è già presente nella lista.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static BarItem FindKeyCaptionInMenu(
    BarItemLinkCollection menu,
    string key
)
Public Shared Function FindKeyCaptionInMenu (
    menu As BarItemLinkCollection,
    key As String
) As BarItem
public:
static BarItem^ FindKeyCaptionInMenu(
    BarItemLinkCollection^ menu,
    String^ key
)
static member FindKeyCaptionInMenu :
        menu : BarItemLinkCollection *
        key : string -> BarItem

Parametri

menu BarItemLinkCollection
key String

Valore di ritorno

BarItem
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.FindKeyNameInMenu

Metodo UtilityFindKeyNameInMenu
Restituisce true se l'elemento è già presente nella lista.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static BarItem FindKeyNameInMenu(
    BarItemLinkCollection menu,
    string key
)
Public Shared Function FindKeyNameInMenu (
    menu As BarItemLinkCollection,
    key As String
) As BarItem
public:
static BarItem^ FindKeyNameInMenu(
    BarItemLinkCollection^ menu,
    String^ key
)
static member FindKeyNameInMenu :
        menu : BarItemLinkCollection *
        key : string -> BarItem

Parametri

menu BarItemLinkCollection
key String

Valore di ritorno

BarItem
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.FindProcess

Metodo UtilityFindProcess
Restituisce i processi abbinati al documento passato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static Process[] FindProcess(
    string fileName
)
Public Shared Function FindProcess (
    fileName As String
) As Process()
public:
static array<Process^>^ FindProcess(
    String^ fileName
)
static member FindProcess :
        fileName : string -> Process[]

Parametri

fileName String

Valore di ritorno

Process
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.FolderSelect

Metodo UtilityFolderSelect
Chiede all'utente la selezione di una cartella.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string FolderSelect(
    IWin32Window ownerForm,
    bool showNewFolderButton
)
Public Shared Function FolderSelect (
    ownerForm As IWin32Window,
    showNewFolderButton As Boolean
) As String
public:
static String^ FolderSelect(
    IWin32Window^ ownerForm,
    bool showNewFolderButton
)
static member FolderSelect :
        ownerForm : IWin32Window *
        showNewFolderButton : bool -> string

Parametri

ownerForm IWin32Window
Parent Form.
showNewFolderButton Boolean
Inidica se dare la possibilità di creare una nuova cartella..

Valore di ritorno

String
Restituisce il percorso della cartella selezionata.
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.ForceDocRowVerInDb

Metodo UtilityForceDocRowVerInDb
Aggiorna il ROWVER del DB leggendolo dal documento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void ForceDocRowVerInDb(
    DedDoc doc
)
Public Shared Sub ForceDocRowVerInDb (
    doc As DedDoc
)
public:
static void ForceDocRowVerInDb(
    DedDoc^ doc
)
static member ForceDocRowVerInDb :
        doc : DedDoc -> unit

Parametri

doc DedDoc
Documento dal quale aggiornare il DB
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.FormatDateTimeStringPattern

Metodo UtilityFormatDateTimeStringPattern
Formatta il pattern della date eliminando le parentesi graffe. Attenzione! Per gestire eventuali problematiche il pattern {0} non è cosiderato valido per le date e di conseguenza la funzione ritornerà una stringa vuota.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string FormatDateTimeStringPattern(
    string format
)
Public Shared Function FormatDateTimeStringPattern (
    format As String
) As String
public:
static String^ FormatDateTimeStringPattern(
    String^ format
)
static member FormatDateTimeStringPattern :
        format : string -> string

Parametri

format String

Valore di ritorno

String
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.FormatPermAttrKey

Metodo UtilityFormatPermAttrKey
Metodo che ritorna la chiave da utilizzare per identificare l'accoppiata 'attributo' e 'famiglia'. È stato centralizzato in un metodo affinchè se un in un futuro si dovesse cambiare formattazione, basta modificare questo metodo senza dover girare tutto il progetto. Attenzione! Non viene eseguito nessun controllo sulla validità dei parametri.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string FormatPermAttrKey(
    string attrName,
    DedTypeBase tp
)
Public Shared Function FormatPermAttrKey (
    attrName As String,
    tp As DedTypeBase
) As String
public:
static String^ FormatPermAttrKey(
    String^ attrName,
    DedTypeBase^ tp
)
static member FormatPermAttrKey :
        attrName : string *
        tp : DedTypeBase -> string

Parametri

attrName String
Nome dell'attributo.
tp DedTypeBase

Valore di ritorno

String
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.FormatPermAttrKeyToDelete

Metodo UtilityFormatPermAttrKeyToDelete
Lista degli overload
Nome | Descrizione
FormatPermAttrKeyToDelete(DedAttr) | Metodo che ritorna la chiave da utilizzare per identificare i record da eliminare in DED_OBJ_PERM quando viene eliminato un attributo. È stato centralizzato in un metodo affinchè se un in un futuro si dovesse cambiare formattazione, basta modificare questo metodo senza dover girare tutto il progetto. Attenzione! Non viene eseguito nessun controllo sulla validità dei parametri.
FormatPermAttrKeyToDelete(DedTypeBase) | Metodo che ritorna la chiave da utilizzare per identificare i record da eliminare in DED_OBJ_PERM quando viene eliminata una famiglia. È stato centralizzato in un metodo affinchè se un in un futuro si dovesse cambiare formattazione, basta modificare questo metodo senza dover girare tutto il progetto. Attenzione! Non viene eseguito nessun controllo sulla validità dei parametri.
Torna su
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.FormatPermAttrKeyToDelete(DedAttr)

Metodo UtilityFormatPermAttrKeyToDelete(DedAttr)
Metodo che ritorna la chiave da utilizzare per identificare i record da eliminare in DED_OBJ_PERM quando viene eliminato un attributo. È stato centralizzato in un metodo affinchè se un in un futuro si dovesse cambiare formattazione, basta modificare questo metodo senza dover girare tutto il progetto. Attenzione! Non viene eseguito nessun controllo sulla validità dei parametri.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string FormatPermAttrKeyToDelete(
    DedAttr attr
)
Public Shared Function FormatPermAttrKeyToDelete (
    attr As DedAttr
) As String
public:
static String^ FormatPermAttrKeyToDelete(
    DedAttr^ attr
)
static member FormatPermAttrKeyToDelete :
        attr : DedAttr -> string

Parametri

attr DedAttr
Attributo da utilizzare.

Valore di ritorno

String
Vedi anche

Documentazione

Classe Utility
Overload di FormatPermAttrKeyToDelete
Namespace DedNet.Core


Metodo Utility.FormatPermAttrKeyToDelete(DedTypeBase)

Metodo UtilityFormatPermAttrKeyToDelete(DedTypeBase)
Metodo che ritorna la chiave da utilizzare per identificare i record da eliminare in DED_OBJ_PERM quando viene eliminata una famiglia. È stato centralizzato in un metodo affinchè se un in un futuro si dovesse cambiare formattazione, basta modificare questo metodo senza dover girare tutto il progetto. Attenzione! Non viene eseguito nessun controllo sulla validità dei parametri.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string FormatPermAttrKeyToDelete(
    DedTypeBase fam
)
Public Shared Function FormatPermAttrKeyToDelete (
    fam As DedTypeBase
) As String
public:
static String^ FormatPermAttrKeyToDelete(
    DedTypeBase^ fam
)
static member FormatPermAttrKeyToDelete :
        fam : DedTypeBase -> string

Parametri

fam DedTypeBase
Famiglia da utilizzare.

Valore di ritorno

String
Vedi anche

Documentazione

Classe Utility
Overload di FormatPermAttrKeyToDelete
Namespace DedNet.Core


Metodo Utility.FormatZeroLeft

Metodo UtilityFormatZeroLeft
Restituisce una stringa avente il numero di caratteri specificato riempiendo a sinistra con il carattere di riempimento. Nel caso di caratteri eccedenti elimina da sinistra la parte in eccesso.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string FormatZeroLeft(
    string strVal,
    int numChar,
    char paddingChar
)
Public Shared Function FormatZeroLeft (
    strVal As String,
    numChar As Integer,
    paddingChar As Char
) As String
public:
static String^ FormatZeroLeft(
    String^ strVal,
    int numChar,
    wchar_t paddingChar
)
static member FormatZeroLeft :
        strVal : string *
        numChar : int *
        paddingChar : char -> string

Parametri

strVal String
Valore da formattare.
numChar Int32
Numero di caratteri.
paddingChar Char
Carattere da utilizzare per riempire le posizioni mancanti.

Valore di ritorno

String
Restituisce la stringa formattata.
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.GestisciAllegati

Metodo UtilityGestisciAllegati
Gestisce gli allegati in base all'opzione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void GestisciAllegati(
    GridInfoDataList infoFile,
    bool ignoreUserPerm,
    DedData destData
)
Public Shared Sub GestisciAllegati (
    infoFile As GridInfoDataList,
    ignoreUserPerm As Boolean,
    destData As DedData
)
public:
static void GestisciAllegati(
    GridInfoDataList^ infoFile,
    bool ignoreUserPerm,
    DedData^ destData
)
static member GestisciAllegati :
        infoFile : GridInfoDataList *
        ignoreUserPerm : bool *
        destData : DedData -> unit

Parametri

infoFile GridInfoDataList
Oggetto descrittivo le opzioni.
ignoreUserPerm Boolean
destData DedData
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.GetAll

Metodo UtilityGetAll
Cerca tra tutti i controlli figli del controllo passato quelli di un determintao tipo e li restituisce.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static IEnumerable<Control> GetAll(
    Control control,
    Type type
)
Public Shared Function GetAll (
    control As Control,
    type As Type
) As IEnumerable(Of Control)
public:
static IEnumerable<Control^>^ GetAll(
    Control^ control,
    Type^ type
)
static member GetAll :
        control : Control *
        type : Type -> IEnumerable<Control>

Parametri

control Control
Controllo nel quale cercare
type Type
Type del controllo da ricercare

Valore di ritorno

IEnumerable Control
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.GetAllRootsUsedInFam

Metodo UtilityGetAllRootsUsedInFam
Restituisce una lista con tutte le root usate all'interno delle famiglie.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static List<DedRoot> GetAllRootsUsedInFam(
    DedNetApplication app
)
Public Shared Function GetAllRootsUsedInFam (
    app As DedNetApplication
) As List(Of DedRoot)
public:
static List<DedRoot^>^ GetAllRootsUsedInFam(
    DedNetApplication^ app
)
static member GetAllRootsUsedInFam :
        app : DedNetApplication -> List<DedRoot>

Parametri

app DedNetApplication
DedNetApplication

Valore di ritorno

List DedRoot
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.GetAttrFromDBProperties

Metodo UtilityGetAttrFromDBProperties
Restituisce la lista degli attributi relativi alle proprietà

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static DedAttrList GetAttrFromDBProperties(
    bool nameTraslated = false
)
Public Shared Function GetAttrFromDBProperties (
    Optional nameTraslated As Boolean = false
) As DedAttrList
public:
static DedAttrList^ GetAttrFromDBProperties(
    bool nameTraslated = false
)
static member GetAttrFromDBProperties :
        ?nameTraslated : bool
(* Defaults:
        let _nameTraslated = defaultArg nameTraslated false
*)
-> DedAttrList

Parametri

nameTraslated Boolean (Optional)

Valore di ritorno

DedAttrList
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.GetBackupFiles

Metodo UtilityGetBackupFiles
Restituisce una lista sempre inizializzata con i file presenti nelle cartelle di backup di tutte le aree locali.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static List<string> GetBackupFiles(
    DedNetApplication app
)
Public Shared Function GetBackupFiles (
    app As DedNetApplication
) As List(Of String)
public:
static List<String^>^ GetBackupFiles(
    DedNetApplication^ app
)
static member GetBackupFiles :
        app : DedNetApplication -> List<string>

Parametri

app DedNetApplication
Oggetto applicazione.

Valore di ritorno

List String
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.GetBackupFilesFromPwsPath

Metodo UtilityGetBackupFilesFromPwsPath
Restituisce una lista sempre inizializzata con i file presenti in una specifica area locale.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static List<string> GetBackupFilesFromPwsPath(
    DedNetApplication app,
    string pwsPath
)
Public Shared Function GetBackupFilesFromPwsPath (
    app As DedNetApplication,
    pwsPath As String
) As List(Of String)
public:
static List<String^>^ GetBackupFilesFromPwsPath(
    DedNetApplication^ app,
    String^ pwsPath
)
static member GetBackupFilesFromPwsPath :
        app : DedNetApplication *
        pwsPath : string -> List<string>

Parametri

app DedNetApplication
Oggetto applicazione.
pwsPath String
Percorso locale.

Valore di ritorno

List String
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.GetBackupFullFileNameFromDoc

Metodo UtilityGetBackupFullFileNameFromDoc
Restituisce il percorso e il nome file del documento da backuppare.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string GetBackupFullFileNameFromDoc(
    DedNetApplication app,
    DedDoc doc
)
Public Shared Function GetBackupFullFileNameFromDoc (
    app As DedNetApplication,
    doc As DedDoc
) As String
public:
static String^ GetBackupFullFileNameFromDoc(
    DedNetApplication^ app,
    DedDoc^ doc
)
static member GetBackupFullFileNameFromDoc :
        app : DedNetApplication *
        doc : DedDoc -> string

Parametri

app DedNetApplication
Oggetto applicazione.
doc DedDoc
Documento del quale avere il nome di backup

Valore di ritorno

String
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.GetCachedIcon

Metodo UtilityGetCachedIcon
Restituisce l'icona del file/cartella

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static Image GetCachedIcon(
    string fname,
    IconSizeType sizeType,
    Size itemSize
)
Public Shared Function GetCachedIcon (
    fname As String,
    sizeType As IconSizeType,
    itemSize As Size
) As Image
public:
static Image^ GetCachedIcon(
    String^ fname,
    IconSizeType^ sizeType,
    Size itemSize
)
static member GetCachedIcon :
        fname : string *
        sizeType : IconSizeType *
        itemSize : Size -> Image

Parametri

fname String
Filename del quale avere l'icona (accetta anche cartelle)
sizeType IconSizeType
Dimensione dell'icona
itemSize Size
Size icona (forse parametro inutile)

Valore di ritorno

Image
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.GetConfigName

Metodo UtilityGetConfigName
Dato un fulldocumentname ritorna il fullfilename privato della configurazione

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string GetConfigName(
    string fullDocumentName
)
Public Shared Function GetConfigName (
    fullDocumentName As String
) As String
public:
static String^ GetConfigName(
    String^ fullDocumentName
)
static member GetConfigName :
        fullDocumentName : string -> string

Parametri

fullDocumentName String

Valore di ritorno

String
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.GetDataFromRegistryByDocId

Metodo UtilityGetDataFromRegistryByDocId
Metodo che ritorna l'anagrafica in base ai campi ID e REV compilati all'interno della chiave di registro.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static DedData GetDataFromRegistryByDocId(
    Guid docID
)
Public Shared Function GetDataFromRegistryByDocId (
    docID As Guid
) As DedData
public:
static DedData^ GetDataFromRegistryByDocId(
    Guid docID
)
static member GetDataFromRegistryByDocId :
        docID : Guid -> DedData

Parametri

docID Guid
DocID del documento usato come nome della chiave di registro.

Valore di ritorno

DedData
Ritorna un oggetto DedData in base ai campi ID e REV.
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.GetDateTime

Metodo UtilityGetDateTime
Restituisce una data inizializzata con la data passata ma fino ai secondi, evitando i millisecondi.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static DateTime GetDateTime(
    DateTime date
)
Public Shared Function GetDateTime (
    date As DateTime
) As DateTime
public:
static DateTime GetDateTime(
    DateTime date
)
static member GetDateTime :
        date : DateTime -> DateTime

Parametri

date DateTime
Data da utilizzare per l'inizializzazione.

Valore di ritorno

DateTime
Restituisce una data senza i millisecondi.
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.GetDocPropertiesColumnName

Metodo UtilityGetDocPropertiesColumnName
Restituisce la colonna contenete il dato dal tipo dati passato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string GetDocPropertiesColumnName(
    Type dataType
)
Public Shared Function GetDocPropertiesColumnName (
    dataType As Type
) As String
public:
static String^ GetDocPropertiesColumnName(
    Type^ dataType
)
static member GetDocPropertiesColumnName :
        dataType : Type -> string

Parametri

dataType Type
Tipo dati

Valore di ritorno

String
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.GetDocumentStates

Metodo UtilityGetDocumentStates
Ritorna un dizionario chiave valore contenente l'accoppiata tra "immagine stato documentale" e "enum identificativo".

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static Dictionary<DocumentStateEnum, Image> GetDocumentStates()
Public Shared Function GetDocumentStates As Dictionary(Of DocumentStateEnum, Image)
public:
static Dictionary<DocumentStateEnum, Image^>^ GetDocumentStates()
static member GetDocumentStates : unit -> Dictionary<DocumentStateEnum, Image>

Valore di ritorno

Dictionary DocumentStateEnum, Image
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.GetEcoImage

Metodo UtilityGetEcoImage
Restituisce l'iimagine relativa all'eco/ecr con il valore passato

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static Image GetEcoImage(
    bool UseECRWalpaper,
    int value,
    FontFamily fontFamily
)
Public Shared Function GetEcoImage (
    UseECRWalpaper As Boolean,
    value As Integer,
    fontFamily As FontFamily
) As Image
public:
static Image^ GetEcoImage(
    bool UseECRWalpaper,
    int value,
    FontFamily^ fontFamily
)
static member GetEcoImage :
        UseECRWalpaper : bool *
        value : int *
        fontFamily : FontFamily -> Image

Parametri

UseECRWalpaper Boolean
Indica se devo utilizzare lo sfondo per gli ECR o per gli ECO
value Int32
Numero di eco da scrivere nell'immagine
fontFamily FontFamily
Font di scrittura

Valore di ritorno

Image
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.GetEncodeLength

Metodo UtilityGetEncodeLength
Restituisce la lunghezza della stringa di codifica passata

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static int GetEncodeLength(
    string encodestr
)
Public Shared Function GetEncodeLength (
    encodestr As String
) As Integer
public:
static int GetEncodeLength(
    String^ encodestr
)
static member GetEncodeLength :
        encodestr : string -> int

Parametri

encodestr String
Stringa di codifica {F1:2}{P:5}....

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.GetExt

Metodo UtilityGetExt
Restituisce l'estensione del nome file passato senza il punto iniziale.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string GetExt(
    string filename
)
Public Shared Function GetExt (
    filename As String
) As String
public:
static String^ GetExt(
    String^ filename
)
static member GetExt :
        filename : string -> string

Parametri

filename String
Nome del file dal quale estrarre l'estensione.

Valore di ritorno

String
Restituisce l'estensione senza il punto iniziale.
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.GetExtraLargeFileIcon

Metodo UtilityGetExtraLargeFileIcon
Ricava l'icona piccola abbinata all'estensione di un nome file completo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static Image GetExtraLargeFileIcon(
    string fileName
)
Public Shared Function GetExtraLargeFileIcon (
    fileName As String
) As Image
public:
static Image^ GetExtraLargeFileIcon(
    String^ fileName
)
static member GetExtraLargeFileIcon :
        fileName : string -> Image

Parametri

fileName String
Nome completo del documento.

Valore di ritorno

Image
Restituisce l'icona oppure null se non la trova.
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.GetFamInfo

Metodo UtilityGetFamInfo
Restituisce il Dbpath della famiglia concatenato alla sua descrizione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string GetFamInfo(
    DedTypeBase fam
)
Public Shared Function GetFamInfo (
    fam As DedTypeBase
) As String
public:
static String^ GetFamInfo(
    DedTypeBase^ fam
)
static member GetFamInfo :
        fam : DedTypeBase -> string

Parametri

fam DedTypeBase
Famiglia di interesse

Valore di ritorno

String
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.GetFileIcon

Metodo UtilityGetFileIcon
Ricava l'icona piccola abbinata all'estensione di un nome file completo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static Image GetFileIcon(
    string fileName,
    IconSizeType sizeType,
    Size size
)
Public Shared Function GetFileIcon (
    fileName As String,
    sizeType As IconSizeType,
    size As Size
) As Image
public:
static Image^ GetFileIcon(
    String^ fileName,
    IconSizeType^ sizeType,
    Size size
)
static member GetFileIcon :
        fileName : string *
        sizeType : IconSizeType *
        size : Size -> Image

Parametri

fileName String
Nome completo del documento.
sizeType IconSizeType
size Size

Valore di ritorno

Image
Restituisce l'icona oppure null se non la trova.
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.GetFileNamesFromData

Metodo UtilityGetFileNamesFromData
Ricava i nomi file da utilizzare dal'oggetto data passato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string[] GetFileNamesFromData(
    IDataObject data
)
Public Shared Function GetFileNamesFromData (
    data As IDataObject
) As String()
public:
static array<String^>^ GetFileNamesFromData(
    IDataObject^ data
)
static member GetFileNamesFromData :
        data : IDataObject -> string[]

Parametri

data IDataObject

Valore di ritorno

String
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.GetFilePerms

Metodo UtilityGetFilePerms
Dalla lista dei permessi specificata in ingresso, filtra i permessi dei file e li ritorna sottoforma di nuova lista.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static IEnumerable<DedPerm> GetFilePerms(
    IEnumerable<DedPerm> source
)
Public Shared Function GetFilePerms (
    source As IEnumerable(Of DedPerm)
) As IEnumerable(Of DedPerm)
public:
static IEnumerable<DedPerm^>^ GetFilePerms(
    IEnumerable<DedPerm^>^ source
)
static member GetFilePerms :
        source : IEnumerable<DedPerm> -> IEnumerable<DedPerm>

Parametri

source IEnumerable DedPerm
Lista contenente tutti i permessi.

Valore di ritorno

IEnumerable DedPerm
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.GetFilePreview

Metodo UtilityGetFilePreview
Lista degli overload
Nome | Descrizione
GetFilePreview(TreeList, TreeListNode, DedData) | Ritorna l'anteprima chiamando un thread.
GetFilePreview(TreeList, TreeListNode, String) | Ritorna l'anteprima chiamando un thread.
Torna su
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.GetFilePreview(TreeList, TreeListNode, DedData)

Metodo UtilityGetFilePreview(TreeList, TreeListNode, DedData)
Ritorna l'anteprima chiamando un thread.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static Image GetFilePreview(
    TreeList tree,
    TreeListNode node,
    DedData data
)
Public Shared Function GetFilePreview (
    tree As TreeList,
    node As TreeListNode,
    data As DedData
) As Image
public:
static Image^ GetFilePreview(
    TreeList^ tree,
    TreeListNode^ node,
    DedData^ data
)
static member GetFilePreview :
        tree : TreeList *
        node : TreeListNode *
        data : DedData -> Image

Parametri

tree TreeList
node TreeListNode
data DedData

Valore di ritorno

Image
Vedi anche

Documentazione

Classe Utility
Overload di GetFilePreview
Namespace DedNet.Core


Metodo Utility.GetFilePreview(TreeList, TreeListNode, String)

Metodo UtilityGetFilePreview(TreeList, TreeListNode, String)
Ritorna l'anteprima chiamando un thread.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static Image GetFilePreview(
    TreeList tree,
    TreeListNode node,
    string fullFileName
)
Public Shared Function GetFilePreview (
    tree As TreeList,
    node As TreeListNode,
    fullFileName As String
) As Image
public:
static Image^ GetFilePreview(
    TreeList^ tree,
    TreeListNode^ node,
    String^ fullFileName
)
static member GetFilePreview :
        tree : TreeList *
        node : TreeListNode *
        fullFileName : string -> Image

Parametri

tree TreeList
node TreeListNode
fullFileName String

Valore di ritorno

Image
Vedi anche

Documentazione

Classe Utility
Overload di GetFilePreview
Namespace DedNet.Core


Metodo Utility.GetFirstDocFileNameFromData

Metodo UtilityGetFirstDocFileNameFromData
REstituisce il nome del primo file collegato all'anagrafica in base alla PriorityExtList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string GetFirstDocFileNameFromData(
    DedData data
)
Public Shared Function GetFirstDocFileNameFromData (
    data As DedData
) As String
public:
static String^ GetFirstDocFileNameFromData(
    DedData^ data
)
static member GetFirstDocFileNameFromData :
        data : DedData -> string

Parametri

data DedData
Anagrafica della quale reperire il file

Valore di ritorno

String
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.GetFirstDocFromData

Metodo UtilityGetFirstDocFromData
Restituisce il primo file collegato all'anagrafica in base alla PriorityExtList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static DedDoc GetFirstDocFromData(
    DedData data
)
Public Shared Function GetFirstDocFromData (
    data As DedData
) As DedDoc
public:
static DedDoc^ GetFirstDocFromData(
    DedData^ data
)
static member GetFirstDocFromData :
        data : DedData -> DedDoc

Parametri

data DedData
Anagrafica della quale reperire il file

Valore di ritorno

DedDoc
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.GetFtpClient

Metodo UtilityGetFtpClient
Restituisce l'oggetto FTPClient con i dati passati

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static FtpClient GetFtpClient(
    string host,
    string user,
    string pwd,
    string port
)
Public Shared Function GetFtpClient (
    host As String,
    user As String,
    pwd As String,
    port As String
) As FtpClient
public:
static FtpClient^ GetFtpClient(
    String^ host,
    String^ user,
    String^ pwd,
    String^ port
)
static member GetFtpClient :
        host : string *
        user : string *
        pwd : string *
        port : string -> FtpClient

Parametri

host String
user String
pwd String
port String

Valore di ritorno

FtpClient
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.GetFullDocumentName

Metodo UtilityGetFullDocumentName
Dato un filename e una configurazione ritorna il fulldocumentname

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string GetFullDocumentName(
    string fileName,
    string config
)
Public Shared Function GetFullDocumentName (
    fileName As String,
    config As String
) As String
public:
static String^ GetFullDocumentName(
    String^ fileName,
    String^ config
)
static member GetFullDocumentName :
        fileName : string *
        config : string -> string

Parametri

fileName String
config String

Valore di ritorno

String
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.GetFullFileName

Metodo UtilityGetFullFileName
Dato un fulldocumentname ritorna il fullfilename privato della configurazione

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string GetFullFileName(
    string fullDocumentName
)
Public Shared Function GetFullFileName (
    fullDocumentName As String
) As String
public:
static String^ GetFullFileName(
    String^ fullDocumentName
)
static member GetFullFileName :
        fullDocumentName : string -> string

Parametri

fullDocumentName String

Valore di ritorno

String
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.GetImageRectangle

Metodo UtilityGetImageRectangle
Lista degli overload
Nome | Descrizione
GetImageRectangle(Icon, Rectangle) | Restituisce il rettangolo in cui disegnare l'immagine
GetImageRectangle(Image, Rectangle) | Restituisce il rettangolo in cui disegnare l'immagine
GetImageRectangle(Int32, Int32, Rectangle) | Restituisce il rettangolo in cui disegnare l'immagine
Torna su
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.GetImageRectangle(Icon, Rectangle)

Metodo UtilityGetImageRectangle(Icon, Rectangle)
Restituisce il rettangolo in cui disegnare l'immagine

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static Rectangle GetImageRectangle(
    Icon icon,
    Rectangle bounds
)
Public Shared Function GetImageRectangle (
    icon As Icon,
    bounds As Rectangle
) As Rectangle
public:
static Rectangle GetImageRectangle(
    Icon^ icon,
    Rectangle bounds
)
static member GetImageRectangle :
        icon : Icon *
        bounds : Rectangle -> Rectangle

Parametri

icon Icon
Icona usata per calcolare le dimensioni del rettangolo
bounds Rectangle
Area interessata

Valore di ritorno

Rectangle
Vedi anche

Documentazione

Classe Utility
Overload di GetImageRectangle
Namespace DedNet.Core


Metodo Utility.GetImageRectangle(Image, Rectangle)

Metodo UtilityGetImageRectangle(Image, Rectangle)
Restituisce il rettangolo in cui disegnare l'immagine

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static Rectangle GetImageRectangle(
    Image img,
    Rectangle bounds
)
Public Shared Function GetImageRectangle (
    img As Image,
    bounds As Rectangle
) As Rectangle
public:
static Rectangle GetImageRectangle(
    Image^ img,
    Rectangle bounds
)
static member GetImageRectangle :
        img : Image *
        bounds : Rectangle -> Rectangle

Parametri

img Image
Immagine usata per calcolare le dimensioni del rettangolo
bounds Rectangle
Area interessata

Valore di ritorno

Rectangle
Vedi anche

Documentazione

Classe Utility
Overload di GetImageRectangle
Namespace DedNet.Core


Metodo Utility.GetImageRectangle(Int32, Int32, Rectangle)

Metodo UtilityGetImageRectangle(Int32, Int32, Rectangle)
Restituisce il rettangolo in cui disegnare l'immagine

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static Rectangle GetImageRectangle(
    int w,
    int h,
    Rectangle bounds
)
Public Shared Function GetImageRectangle (
    w As Integer,
    h As Integer,
    bounds As Rectangle
) As Rectangle
public:
static Rectangle GetImageRectangle(
    int w,
    int h,
    Rectangle bounds
)
static member GetImageRectangle :
        w : int *
        h : int *
        bounds : Rectangle -> Rectangle

Parametri

w Int32
Larghezza dell'immagine
h Int32
Altezza dell'immagine
bounds Rectangle
Area interessata

Valore di ritorno

Rectangle
Vedi anche

Documentazione

Classe Utility
Overload di GetImageRectangle
Namespace DedNet.Core


Metodo Utility.GetImageSizeFromIconSizeType

Metodo UtilityGetImageSizeFromIconSizeType
Resitisce le dimensione delle immagini dalla tipologia di Size passata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static Size GetImageSizeFromIconSizeType(
    IconSizeType iconSize
)
Public Shared Function GetImageSizeFromIconSizeType (
    iconSize As IconSizeType
) As Size
public:
static Size GetImageSizeFromIconSizeType(
    IconSizeType^ iconSize
)
static member GetImageSizeFromIconSizeType :
        iconSize : IconSizeType -> Size

Parametri

iconSize IconSizeType
Tipologia di icona

Valore di ritorno

Size
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.GetInternalException

Metodo UtilityGetInternalException
Restituisce l'eccezione più interna.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static Exception GetInternalException(
    Exception ex
)
Public Shared Function GetInternalException (
    ex As Exception
) As Exception
public:
static Exception^ GetInternalException(
    Exception^ ex
)
static member GetInternalException :
        ex : Exception -> Exception

Parametri

ex Exception

Valore di ritorno

Exception
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.GetItemByStringId

Metodo UtilityGetItemByStringId
Metodo usato per sapere quale menu sta per essere processato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static DXMenuItem GetItemByStringId(
    DXPopupMenu menu,
    GridStringId id
)
Public Shared Function GetItemByStringId (
    menu As DXPopupMenu,
    id As GridStringId
) As DXMenuItem
public:
static DXMenuItem^ GetItemByStringId(
    DXPopupMenu^ menu,
    GridStringId^ id
)
static member GetItemByStringId :
        menu : DXPopupMenu *
        id : GridStringId -> DXMenuItem

Parametri

menu DXPopupMenu
id GridStringId

Valore di ritorno

DXMenuItem
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.GetItemSize

Metodo UtilityGetItemSize

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static Size GetItemSize(
    WinExplorerViewStyle viewStyle
)
Public Shared Function GetItemSize (
    viewStyle As WinExplorerViewStyle
) As Size
public:
static Size GetItemSize(
    WinExplorerViewStyle^ viewStyle
)
static member GetItemSize :
        viewStyle : WinExplorerViewStyle -> Size

Parametri

viewStyle WinExplorerViewStyle

Valore di ritorno

Size
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.GetItemSizeType

Metodo UtilityGetItemSizeType

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static IconSizeType GetItemSizeType(
    WinExplorerViewStyle viewStyle
)
Public Shared Function GetItemSizeType (
    viewStyle As WinExplorerViewStyle
) As IconSizeType
public:
static IconSizeType^ GetItemSizeType(
    WinExplorerViewStyle^ viewStyle
)
static member GetItemSizeType :
        viewStyle : WinExplorerViewStyle -> IconSizeType

Parametri

viewStyle WinExplorerViewStyle

Valore di ritorno

IconSizeType
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.GetLargeFileIcon

Metodo UtilityGetLargeFileIcon
Ricava l'icona piccola abbinata all'estensione di un nome file completo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static Image GetLargeFileIcon(
    string fileName
)
Public Shared Function GetLargeFileIcon (
    fileName As String
) As Image
public:
static Image^ GetLargeFileIcon(
    String^ fileName
)
static member GetLargeFileIcon :
        fileName : string -> Image

Parametri

fileName String
Nome completo del documento.

Valore di ritorno

Image
Restituisce l'icona oppure null se non la trova.
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.GetMaxTokenNum

Metodo UtilityGetMaxTokenNum
Restituisce il massimo numero di caratteri usati per il TokenTypeEnum passato. Verifica nella maschera di codifica Cod_Id, Cod_Fil e Cod_Dis in modo da prendere il numero massimo di caratteri utilizzati.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static int GetMaxTokenNum(
    DedType fam,
    TokenTypeEnum type,
    string[] sLista
)
Public Shared Function GetMaxTokenNum (
    fam As DedType,
    type As TokenTypeEnum,
    sLista As String()
) As Integer
public:
static int GetMaxTokenNum(
    DedType^ fam,
    TokenTypeEnum type,
    array<String^>^ sLista
)
static member GetMaxTokenNum :
        fam : DedType *
        type : TokenTypeEnum *
        sLista : string[] -> int

Parametri

fam DedType
type TokenTypeEnum
Token di interesse.
sLista String

Valore di ritorno

Int32
Restiruisce il numero di caratteri.
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.GetMd5FromString

Metodo UtilityGetMd5FromString
Calcola una Guid data una stringa.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static Guid GetMd5FromString(
    string input
)
Public Shared Function GetMd5FromString (
    input As String
) As Guid
public:
static Guid GetMd5FromString(
    String^ input
)
static member GetMd5FromString :
        input : string -> Guid

Parametri

input String
stringa

Valore di ritorno

Guid
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.GetMd5HashFile

Metodo UtilityGetMd5HashFile
Restituisce il guid calcolato con Md5 del file passato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static Guid GetMd5HashFile(
    string file
)
Public Shared Function GetMd5HashFile (
    file As String
) As Guid
public:
static Guid GetMd5HashFile(
    String^ file
)
static member GetMd5HashFile :
        file : string -> Guid

Parametri

file String
Percorso del file

Valore di ritorno

Guid
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.GetMediumFileIcon

Metodo UtilityGetMediumFileIcon
Ricava l'icona piccola abbinata all'estensione di un nome file completo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static Image GetMediumFileIcon(
    string fileName
)
Public Shared Function GetMediumFileIcon (
    fileName As String
) As Image
public:
static Image^ GetMediumFileIcon(
    String^ fileName
)
static member GetMediumFileIcon :
        fileName : string -> Image

Parametri

fileName String
Nome completo del documento.

Valore di ritorno

Image
Restituisce l'icona oppure null se non la trova.
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.GetNameVisFromUsername

Metodo UtilityGetNameVisFromUsername
Trova e restituisce il nome visualizzato dell'utente con username passato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string GetNameVisFromUsername(
    DedNetApplication app,
    string username
)
Public Shared Function GetNameVisFromUsername (
    app As DedNetApplication,
    username As String
) As String
public:
static String^ GetNameVisFromUsername(
    DedNetApplication^ app,
    String^ username
)
static member GetNameVisFromUsername :
        app : DedNetApplication *
        username : string -> string

Parametri

app DedNetApplication
L'applicazione DedNet.
username String
Lo username dell'utente.

Valore di ritorno

String
Il nome visualizzato se esiste, altrimenti lo username.
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.GetPreview

Metodo UtilityGetPreview
Estrae l'anteprima dal primo documento dall'anagrafica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static Image GetPreview(
    string filename,
    Image defaultImage = null
)
Public Shared Function GetPreview (
    filename As String,
    Optional defaultImage As Image = Nothing
) As Image
public:
static Image^ GetPreview(
    String^ filename,
    Image^ defaultImage = nullptr
)
static member GetPreview :
        filename : string *
        ?defaultImage : Image
(* Defaults:
        let _defaultImage = defaultArg defaultImage null
*)
-> Image

Parametri

filename String
defaultImage Image (Optional)

Valore di ritorno

Image
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.GetQsTempPath

Metodo UtilityGetQsTempPath
Restituuisce il path per i temp Qs

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string GetQsTempPath()
Public Shared Function GetQsTempPath As String
public:
static String^ GetQsTempPath()
static member GetQsTempPath : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.GetRenamedFileNameNgrMode

Metodo UtilityGetRenamedFileNameNgrMode
Lista degli overload
Nome | Descrizione
GetRenamedFileNameNgrMode(DedDoc) | Nel caso di documento associato ad anagrafica NGR e ultima revisione restituisce il nuovo nome file con estensione.
GetRenamedFileNameNgrMode(DedData, DedDoc) | Nel caso di anagrafica NGR e ultima revisione restituisce il nuovo nome file.
Torna su
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.GetRenamedFileNameNgrMode(DedDoc)

Metodo UtilityGetRenamedFileNameNgrMode(DedDoc)
Nel caso di documento associato ad anagrafica NGR e ultima revisione restituisce il nuovo nome file con estensione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string GetRenamedFileNameNgrMode(
    DedDoc doc
)
Public Shared Function GetRenamedFileNameNgrMode (
    doc As DedDoc
) As String
public:
static String^ GetRenamedFileNameNgrMode(
    DedDoc^ doc
)
static member GetRenamedFileNameNgrMode :
        doc : DedDoc -> string

Parametri

doc DedDoc
Documento

Valore di ritorno

String
Vedi anche

Documentazione

Classe Utility
Overload di GetRenamedFileNameNgrMode
Namespace DedNet.Core


Metodo Utility.GetRenamedFileNameNgrMode(DedData, DedDoc)

Metodo UtilityGetRenamedFileNameNgrMode(DedData, DedDoc)
Nel caso di anagrafica NGR e ultima revisione restituisce il nuovo nome file.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string GetRenamedFileNameNgrMode(
    DedData data,
    DedDoc doc
)
Public Shared Function GetRenamedFileNameNgrMode (
    data As DedData,
    doc As DedDoc
) As String
public:
static String^ GetRenamedFileNameNgrMode(
    DedData^ data,
    DedDoc^ doc
)
static member GetRenamedFileNameNgrMode :
        data : DedData *
        doc : DedDoc -> string

Parametri

data DedData
Anagrafica
doc DedDoc
Documento

Valore di ritorno

String
Vedi anche

Documentazione

Classe Utility
Overload di GetRenamedFileNameNgrMode
Namespace DedNet.Core


Metodo Utility.GetRootsByFam

Metodo UtilityGetRootsByFam
Ottiene i path usati per la codifica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static List<string> GetRootsByFam()
Public Shared Function GetRootsByFam As List(Of String)
public:
static List<String^>^ GetRootsByFam()
static member GetRootsByFam : unit -> List<string>

Valore di ritorno

List String
Lista con tutti i path più corti univoci usati per la codifica nelle famiglie.
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.GetRootsByType

Metodo UtilityGetRootsByType
Ottiene i percorsi rooted associati al tipo di dato specificato in ingresso. Viene utilizzato in fase di costruzione dei permessi perchè l'oggetto DedNet.PathRoots non è ancora stato inizializzato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static List<string> GetRootsByType(
    DedRootRootTypeEnum rootType
)
Public Shared Function GetRootsByType (
    rootType As DedRootRootTypeEnum
) As List(Of String)
public:
static List<String^>^ GetRootsByType(
    DedRootRootTypeEnum rootType
)
static member GetRootsByType :
        rootType : DedRootRootTypeEnum -> List<string>

Parametri

rootType DedRootRootTypeEnum

Valore di ritorno

List String
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.GetSmallFileIcon

Metodo UtilityGetSmallFileIcon
Ricava l'icona piccola abbinata all'estensione di un nome file completo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static Image GetSmallFileIcon(
    string fileName
)
Public Shared Function GetSmallFileIcon (
    fileName As String
) As Image
public:
static Image^ GetSmallFileIcon(
    String^ fileName
)
static member GetSmallFileIcon :
        fileName : string -> Image

Parametri

fileName String
Nome completo del documento.

Valore di ritorno

Image
Restituisce l'icona oppure null se non la trova.
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.GetTextQuery

Metodo UtilityGetTextQuery
Ritorna la query, in formato testuale del comando passato. I valori dei parametri non sono wrappati tra '' ma visualizzano il valore del parametro

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string GetTextQuery(
    QSCommandBase dbCommand
)
Public Shared Function GetTextQuery (
    dbCommand As QSCommandBase
) As String
public:
static String^ GetTextQuery(
    QSCommandBase^ dbCommand
)
static member GetTextQuery :
        dbCommand : QSCommandBase -> string

Parametri

dbCommand QSCommandBase

Valore di ritorno

String
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.GetTimeSuffix

Metodo UtilityGetTimeSuffix
Restituisce una stringa da utilizzare come suffisso nei nomi delle tabelle di backup, indicante l'anno, il mese, il giorno, l'ora, i minuti ed i secondi attuali.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string GetTimeSuffix()
Public Shared Function GetTimeSuffix As String
public:
static String^ GetTimeSuffix()
static member GetTimeSuffix : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.GetUnboundTypeGrid

Metodo UtilityGetUnboundTypeGrid
Restituisce il tipo UnboundColumnType in base al tipo di Attributo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static UnboundColumnType GetUnboundTypeGrid(
    DedAttr attr
)
Public Shared Function GetUnboundTypeGrid (
    attr As DedAttr
) As UnboundColumnType
public:
static UnboundColumnType^ GetUnboundTypeGrid(
    DedAttr^ attr
)
static member GetUnboundTypeGrid :
        attr : DedAttr -> UnboundColumnType

Parametri

attr DedAttr
Attribto da valutare

Valore di ritorno

UnboundColumnType
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.GetUnboundTypeTree

Metodo UtilityGetUnboundTypeTree
Restituisce il tipo UnboundColumnType in base al tipo di Attributo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static UnboundColumnType GetUnboundTypeTree(
    DedAttr attr
)
Public Shared Function GetUnboundTypeTree (
    attr As DedAttr
) As UnboundColumnType
public:
static UnboundColumnType^ GetUnboundTypeTree(
    DedAttr^ attr
)
static member GetUnboundTypeTree :
        attr : DedAttr -> UnboundColumnType

Parametri

attr DedAttr
Attribto da valutare

Valore di ritorno

UnboundColumnType
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.GetUniqueAttachFileName

Metodo UtilityGetUniqueAttachFileName
Restituisce un nome univoco da aggiungere ai file allegati. Presuppone che il chiamante abbia già controllato che il destfilename sia già presente a destinazione

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string GetUniqueAttachFileName(
    DedData data,
    string startFileName,
    string destFileName
)
Public Shared Function GetUniqueAttachFileName (
    data As DedData,
    startFileName As String,
    destFileName As String
) As String
public:
static String^ GetUniqueAttachFileName(
    DedData^ data,
    String^ startFileName,
    String^ destFileName
)
static member GetUniqueAttachFileName :
        data : DedData *
        startFileName : string *
        destFileName : string -> string

Parametri

data DedData
Anagrafica nella quale inserire l'allegato
startFileName String
Filename di partenza
destFileName String
Filename della destinazione

Valore di ritorno

String
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.GetValidFamName

Metodo UtilityGetValidFamName
Restituisce un nome valido per il prompt dell'attributo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string GetValidFamName(
    DedTypeBase fam
)
Public Shared Function GetValidFamName (
    fam As DedTypeBase
) As String
public:
static String^ GetValidFamName(
    DedTypeBase^ fam
)
static member GetValidFamName :
        fam : DedTypeBase -> string

Parametri

fam DedTypeBase

Valore di ritorno

String
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.IconIsCached

Metodo UtilityIconIsCached
Controlla se l'icona è già presente nella cache

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool IconIsCached(
    string fname
)
Public Shared Function IconIsCached (
    fname As String
) As Boolean
public:
static bool IconIsCached(
    String^ fname
)
static member IconIsCached :
        fname : string -> bool

Parametri

fname String
Filename del quale avere l'icona (accetta anche cartelle)

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.ImageToString

Metodo UtilityImageToString
Convert image to base64 string

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string ImageToString(
    Image img
)
Public Shared Function ImageToString (
    img As Image
) As String
public:
static String^ ImageToString(
    Image^ img
)
static member ImageToString :
        img : Image -> string

Parametri

img Image

Valore di ritorno

String
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.IncrementString

Metodo UtilityIncrementString

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string IncrementString(
    string str,
    int incrementValue,
    string alpabhet
)
Public Shared Function IncrementString (
    str As String,
    incrementValue As Integer,
    alpabhet As String
) As String
public:
static String^ IncrementString(
    String^ str,
    int incrementValue,
    String^ alpabhet
)
static member IncrementString :
        str : string *
        incrementValue : int *
        alpabhet : string -> string

Parametri

str String
incrementValue Int32
alpabhet String

Valore di ritorno

String
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.InitFilterState

Metodo UtilityInitFilterState
Inizializza la barra di filtraggio in base agli stati

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void InitFilterState(
    BarSubItem baritem,
    ItemClickEventHandler evStateCheck,
    ItemClickEventHandler evClearClick
)
Public Shared Sub InitFilterState (
    baritem As BarSubItem,
    evStateCheck As ItemClickEventHandler,
    evClearClick As ItemClickEventHandler
)
public:
static void InitFilterState(
    BarSubItem^ baritem,
    ItemClickEventHandler^ evStateCheck,
    ItemClickEventHandler^ evClearClick
)
static member InitFilterState :
        baritem : BarSubItem *
        evStateCheck : ItemClickEventHandler *
        evClearClick : ItemClickEventHandler -> unit

Parametri

baritem BarSubItem
evStateCheck ItemClickEventHandler
evClearClick ItemClickEventHandler
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.IsAbsolutePath

Metodo UtilityIsAbsolutePath
Restiruisce true se si tratta di un percorso assoluto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool IsAbsolutePath(
    string p
)
Public Shared Function IsAbsolutePath (
    p As String
) As Boolean
public:
static bool IsAbsolutePath(
    String^ p
)
static member IsAbsolutePath :
        p : string -> bool

Parametri

p String
Percorso da analizzare

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.IsAutoCadFile

Metodo UtilityIsAutoCadFile
Ritorna True se il path passato in ingresso è di un dwg creato da AutoCAD, False altrimenti.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool IsAutoCadFile(
    string path
)
Public Shared Function IsAutoCadFile (
    path As String
) As Boolean
public:
static bool IsAutoCadFile(
    String^ path
)
static member IsAutoCadFile :
        path : string -> bool

Parametri

path String
Percorso del dwg da esaminare.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.IsDesignerHosted

Metodo UtilityIsDesignerHosted
The DesignMode property does not correctly tell you if you are in design mode. IsDesignerHosted is a corrected version of that property. (see https://connect.microsoft.com/VisualStudio/feedback/details/553305 and http://stackoverflow.com/a/2693338/238419 )

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool IsDesignerHosted(
    Control ctr
)
Public Shared Function IsDesignerHosted (
    ctr As Control
) As Boolean
public:
static bool IsDesignerHosted(
    Control^ ctr
)
static member IsDesignerHosted :
        ctr : Control -> bool

Parametri

ctr Control

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.IsDistAttr

Metodo UtilityIsDistAttr
restituisce true se è un attributo di distinta altrimenti false

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool IsDistAttr(
    DedAttr attr
)
Public Shared Function IsDistAttr (
    attr As DedAttr
) As Boolean
public:
static bool IsDistAttr(
    DedAttr^ attr
)
static member IsDistAttr :
        attr : DedAttr -> bool

Parametri

attr DedAttr
Attributo da valutare

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.IsDrive

Metodo UtilityIsDrive
Controlla se il path passato rappresenta una unità logica del sistema

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool IsDrive(
    string path
)
Public Shared Function IsDrive (
    path As String
) As Boolean
public:
static bool IsDrive(
    String^ path
)
static member IsDrive :
        path : string -> bool

Parametri

path String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.IsDrivePath

Metodo UtilityIsDrivePath
Controllo se il path passato può rappresentare una unità logica senza che necessariamente sia connessa

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool IsDrivePath(
    string path
)
Public Shared Function IsDrivePath (
    path As String
) As Boolean
public:
static bool IsDrivePath(
    String^ path
)
static member IsDrivePath :
        path : string -> bool

Parametri

path String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.IsFamilyNameValid

Metodo UtilityIsFamilyNameValid
Controlla che il nome della famiglia non sia già presente tra i figli della famiglia selezionata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool IsFamilyNameValid(
    DedTypeBase fam,
    string name
)
Public Shared Function IsFamilyNameValid (
    fam As DedTypeBase,
    name As String
) As Boolean
public:
static bool IsFamilyNameValid(
    DedTypeBase^ fam,
    String^ name
)
static member IsFamilyNameValid :
        fam : DedTypeBase *
        name : string -> bool

Parametri

fam DedTypeBase
name String
Nome del quale controllare l'esistenza.

Valore di ritorno

Boolean
True se il nome è valido.
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.IsFile

Metodo UtilityIsFile
Restituisce True se è un file, False se è una Directory

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool IsFile(
    string path
)
Public Shared Function IsFile (
    path As String
) As Boolean
public:
static bool IsFile(
    String^ path
)
static member IsFile :
        path : string -> bool

Parametri

path String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.IsFileNewer

Metodo UtilityIsFileNewer
Restituisce true se firstFile è più recente di secondFile.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool IsFileNewer(
    string firstFile,
    string secondFile
)
Public Shared Function IsFileNewer (
    firstFile As String,
    secondFile As String
) As Boolean
public:
static bool IsFileNewer(
    String^ firstFile,
    String^ secondFile
)
static member IsFileNewer :
        firstFile : string *
        secondFile : string -> bool

Parametri

firstFile String
secondFile String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.IsFileReadOnly

Metodo UtilityIsFileReadOnly
Verifica se il file sia readonly. Restituisce false anche se il file non esiste.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool IsFileReadOnly(
    string fullFileName
)
Public Shared Function IsFileReadOnly (
    fullFileName As String
) As Boolean
public:
static bool IsFileReadOnly(
    String^ fullFileName
)
static member IsFileReadOnly :
        fullFileName : string -> bool

Parametri

fullFileName String
File da verificare.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.IsNaN

Metodo UtilityIsNaN
Controlla se il valore passato è un NaN.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool IsNaN(
    Object value
)
Public Shared Function IsNaN (
    value As Object
) As Boolean
public:
static bool IsNaN(
    Object^ value
)
static member IsNaN :
        value : Object -> bool

Parametri

value Object
Valore da controllare

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.IsNumber

Metodo UtilityIsNumber
Ritorna vero se l'oggetto è di tipo numerico

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool IsNumber(
    Object value
)
Public Shared Function IsNumber (
    value As Object
) As Boolean
public:
static bool IsNumber(
    Object^ value
)
static member IsNumber :
        value : Object -> bool

Parametri

value Object

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.IsSystemPath

Metodo UtilityIsSystemPath
Dato un percorso indica se è una cartella modificabile o no.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool IsSystemPath(
    DedNetApplication app,
    string path
)
Public Shared Function IsSystemPath (
    app As DedNetApplication,
    path As String
) As Boolean
public:
static bool IsSystemPath(
    DedNetApplication^ app,
    String^ path
)
static member IsSystemPath :
        app : DedNetApplication *
        path : string -> bool

Parametri

app DedNetApplication
path String
Percorso da analizzare

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.IsWow64Process

Metodo UtilityIsWow64Process
Lista degli overload
Nome | Descrizione
IsWow64Process | Restituisce se il processo corrente sia a 64 bit.
IsWow64Process(Process) | Restituisce se il processo passato sia a 64 bit.
Torna su
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.IsWow64Process

Metodo UtilityIsWow64Process
Restituisce se il processo corrente sia a 64 bit.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool IsWow64Process()
Public Shared Function IsWow64Process As Boolean
public:
static bool IsWow64Process()
static member IsWow64Process : unit -> bool

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Utility
Overload di IsWow64Process
Namespace DedNet.Core


Metodo Utility.IsWow64Process(Process)

Metodo UtilityIsWow64Process(Process)
Restituisce se il processo passato sia a 64 bit.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool IsWow64Process(
    Process process
)
Public Shared Function IsWow64Process (
    process As Process
) As Boolean
public:
static bool IsWow64Process(
    Process^ process
)
static member IsWow64Process :
        process : Process -> bool

Parametri

process Process
Processo da verificare.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Utility
Overload di IsWow64Process
Namespace DedNet.Core


Metodo Utility.ListNetworkComputers

Metodo UtilityListNetworkComputers
Ritorna l'elenco dei computer di rete

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static List<string> ListNetworkComputers()
Public Shared Function ListNetworkComputers As List(Of String)
public:
static List<String^>^ ListNetworkComputers()
static member ListNetworkComputers : unit -> List<string>

Valore di ritorno

List String
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.MakeDocContext

Metodo UtilityMakeDocContext
Calcola e restituisce il contesto da utilizzare per collegare un documento ad un'anagrafica. Restituisce None se non è possibile associare il documento con il contesto richiesto.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static DedDocContextEnum MakeDocContext(
    DedNetApplication app,
    DedData data,
    string fileName,
    bool pimaryContext
)
Public Shared Function MakeDocContext (
    app As DedNetApplication,
    data As DedData,
    fileName As String,
    pimaryContext As Boolean
) As DedDocContextEnum
public:
static DedDocContextEnum MakeDocContext(
    DedNetApplication^ app,
    DedData^ data,
    String^ fileName,
    bool pimaryContext
)
static member MakeDocContext :
        app : DedNetApplication *
        data : DedData *
        fileName : string *
        pimaryContext : bool -> DedDocContextEnum

Parametri

app DedNetApplication
Applicazione di riferimento.
data DedData
Anagrafica alla quale associare il documento.
fileName String
Nome del file del documento da associare.
pimaryContext Boolean
Se il contesto sia o meno primario.

Valore di ritorno

DedDocContextEnum
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.MakeGrayscale

Metodo UtilityMakeGrayscale
Ritorna una nuova immagine partendo dall'originale convertita in scala di grigi

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static Bitmap MakeGrayscale(
    Bitmap original
)
Public Shared Function MakeGrayscale (
    original As Bitmap
) As Bitmap
public:
static Bitmap^ MakeGrayscale(
    Bitmap^ original
)
static member MakeGrayscale :
        original : Bitmap -> Bitmap

Parametri

original Bitmap
Immagine originale

Valore di ritorno

Bitmap
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.MakeRelative

Metodo UtilityMakeRelative
Relativizza un path dato un path di riferimento

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string MakeRelative(
    string filePath,
    string referencePath
)
Public Shared Function MakeRelative (
    filePath As String,
    referencePath As String
) As String
public:
static String^ MakeRelative(
    String^ filePath,
    String^ referencePath
)
static member MakeRelative :
        filePath : string *
        referencePath : string -> string

Parametri

filePath String
Percorso da rendere relativo
referencePath String
Percorso di riferimento

Valore di ritorno

String
Percorso relativo risultante. Se i due percorsi sono slegati viene ritornato il percorso originale.
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.ManageReadOnlyState

Metodo UtilityManageReadOnlyState
Imposta lo stato di sola lettura o meno dei file primary associati all'anagrafica passata e allo stato passato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void ManageReadOnlyState(
    DedData dedData,
    DedState state
)
Public Shared Sub ManageReadOnlyState (
    dedData As DedData,
    state As DedState
)
public:
static void ManageReadOnlyState(
    DedData^ dedData,
    DedState^ state
)
static member ManageReadOnlyState :
        dedData : DedData *
        state : DedState -> unit

Parametri

dedData DedData
Anagrafica in gioco
state DedState
Stato da valutare
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.ManageScaleFactorByDpi

Metodo UtilityManageScaleFactorByDpi
Metodo che gestisce il ridimensionamento delle icone quando si ha un elevato DPI.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void ManageScaleFactorByDpi(
    ImageCollection imgColl
)
Public Shared Sub ManageScaleFactorByDpi (
    imgColl As ImageCollection
)
public:
static void ManageScaleFactorByDpi(
    ImageCollection^ imgColl
)
static member ManageScaleFactorByDpi :
        imgColl : ImageCollection -> unit

Parametri

imgColl ImageCollection
ImageCollection contenente le icone da gestire.
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.MenuContainsKeyCaption

Metodo UtilityMenuContainsKeyCaption
Restituisce true se l'elemento è già presente nella lista.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool MenuContainsKeyCaption(
    BarItemLinkCollection menu,
    string key
)
Public Shared Function MenuContainsKeyCaption (
    menu As BarItemLinkCollection,
    key As String
) As Boolean
public:
static bool MenuContainsKeyCaption(
    BarItemLinkCollection^ menu,
    String^ key
)
static member MenuContainsKeyCaption :
        menu : BarItemLinkCollection *
        key : string -> bool

Parametri

menu BarItemLinkCollection
key String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.MenuContainsKeyName

Metodo UtilityMenuContainsKeyName
Restituisce true se l'elemento è già presente nella lista.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool MenuContainsKeyName(
    BarItemLinkCollection menu,
    string key
)
Public Shared Function MenuContainsKeyName (
    menu As BarItemLinkCollection,
    key As String
) As Boolean
public:
static bool MenuContainsKeyName(
    BarItemLinkCollection^ menu,
    String^ key
)
static member MenuContainsKeyName :
        menu : BarItemLinkCollection *
        key : string -> bool

Parametri

menu BarItemLinkCollection
key String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.NormalizeFamLevel

Metodo UtilityNormalizeFamLevel
Sistema il livello della famiglia all'interno della codifica in modo da averlo sempre presente e in positivo

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string NormalizeFamLevel(
    DedTypeBase fam,
    string encode
)
Public Shared Function NormalizeFamLevel (
    fam As DedTypeBase,
    encode As String
) As String
public:
static String^ NormalizeFamLevel(
    DedTypeBase^ fam,
    String^ encode
)
static member NormalizeFamLevel :
        fam : DedTypeBase *
        encode : string -> string

Parametri

fam DedTypeBase
encode String

Valore di ritorno

String
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.NormalizePath

Metodo UtilityNormalizePath
Funzione di normalizzazione del path per uniformare i percorsi ai fini dei confronti

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string NormalizePath(
    string path
)
Public Shared Function NormalizePath (
    path As String
) As String
public:
static String^ NormalizePath(
    String^ path
)
static member NormalizePath :
        path : string -> string

Parametri

path String
Path da normalizzare

Valore di ritorno

String
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.Now

Metodo UtilityNow
Restituisce la data attuale fino ai secondi, senza i millisecondi. Questo serve per evitare l'errore generato nelle date in access che non hanno i millisecondi.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static DateTime Now()
Public Shared Function Now As DateTime
public:
static DateTime Now()
static member Now : unit -> DateTime

Valore di ritorno

DateTime
Restituisce la data di oggi senza i millisecondi.
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.ParseDateTime

Metodo UtilityParseDateTime
Converte la stringa in oggetto DateTime se riesce altrimenti null.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static DateTime ParseDateTime(
    string date
)
Public Shared Function ParseDateTime (
    date As String
) As DateTime
public:
static DateTime ParseDateTime(
    String^ date
)
static member ParseDateTime :
        date : string -> DateTime

Parametri

date String
Data in formato stringa.

Valore di ritorno

DateTime
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.ProgCheckIsMyMin

Metodo UtilityProgCheckIsMyMin
Controlla se il progressivo è il primo di un'aassegnatazione

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool ProgCheckIsMyMin(
    DedTypeProgStruct myProg,
    string prog
)
Public Shared Function ProgCheckIsMyMin (
    myProg As DedTypeProgStruct,
    prog As String
) As Boolean
public:
static bool ProgCheckIsMyMin(
    DedTypeProgStruct myProg,
    String^ prog
)
static member ProgCheckIsMyMin :
        myProg : DedTypeProgStruct *
        prog : string -> bool

Parametri

myProg DedTypeProgStruct
Struttura dei progressivi
prog String
Progressivo da controllare

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.ProgIsInMyCurrentRange

Metodo UtilityProgIsInMyCurrentRange
Restituisce se il progressivo è contenuto nel range corrente, ovvero il primo disponibile non esaurito

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool ProgIsInMyCurrentRange(
    DedTypeBase type,
    DedTypeProgList progList,
    string prog
)
Public Shared Function ProgIsInMyCurrentRange (
    type As DedTypeBase,
    progList As DedTypeProgList,
    prog As String
) As Boolean
public:
static bool ProgIsInMyCurrentRange(
    DedTypeBase^ type,
    DedTypeProgList^ progList,
    String^ prog
)
static member ProgIsInMyCurrentRange :
        type : DedTypeBase *
        progList : DedTypeProgList *
        prog : string -> bool

Parametri

type DedTypeBase
Famiglia di interesse
progList DedTypeProgList
Progressivi assegnati per la famiglia
prog String
Progressivo da controllare

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.ProgIsInMyRange

Metodo UtilityProgIsInMyRange
Restituisce se il progressivo appartiene al range di assegnazione passato

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool ProgIsInMyRange(
    DedTypeBase type,
    DedTypeProg rangeProg,
    string prog
)
Public Shared Function ProgIsInMyRange (
    type As DedTypeBase,
    rangeProg As DedTypeProg,
    prog As String
) As Boolean
public:
static bool ProgIsInMyRange(
    DedTypeBase^ type,
    DedTypeProg^ rangeProg,
    String^ prog
)
static member ProgIsInMyRange :
        type : DedTypeBase *
        rangeProg : DedTypeProg *
        prog : string -> bool

Parametri

type DedTypeBase
rangeProg DedTypeProg
prog String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.ProgIsInMyRanges

Metodo UtilityProgIsInMyRanges
Lista degli overload
Nome | Descrizione
ProgIsInMyRanges(DedTypeProgStruct, String) | Restituisce se il progressivo appartiene alla lista dei progressivi assegnati
ProgIsInMyRanges(DedTypeBase, DedTypeProgList, String) | Restituisce se il progressivo appartiene alla lista dei progressivi assegnati per una determinata famiglia
Torna su
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.ProgIsInMyRanges(DedType.ProgStruct, String)

Metodo UtilityProgIsInMyRanges(DedTypeProgStruct, String)
Restituisce se il progressivo appartiene alla lista dei progressivi assegnati

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool ProgIsInMyRanges(
    DedTypeProgStruct myProg,
    string prog
)
Public Shared Function ProgIsInMyRanges (
    myProg As DedTypeProgStruct,
    prog As String
) As Boolean
public:
static bool ProgIsInMyRanges(
    DedTypeProgStruct myProg,
    String^ prog
)
static member ProgIsInMyRanges :
        myProg : DedTypeProgStruct *
        prog : string -> bool

Parametri

myProg DedTypeProgStruct
Struttura dei progressivi
prog String
Progressivo da controllare

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Utility
Overload di ProgIsInMyRanges
Namespace DedNet.Core


Metodo Utility.ProgIsInMyRanges(DedTypeBase, DedTypeProgList, String)

Metodo UtilityProgIsInMyRanges(DedTypeBase, DedTypeProgList, String)
Restituisce se il progressivo appartiene alla lista dei progressivi assegnati per una determinata famiglia

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool ProgIsInMyRanges(
    DedTypeBase type,
    DedTypeProgList progList,
    string prog
)
Public Shared Function ProgIsInMyRanges (
    type As DedTypeBase,
    progList As DedTypeProgList,
    prog As String
) As Boolean
public:
static bool ProgIsInMyRanges(
    DedTypeBase^ type,
    DedTypeProgList^ progList,
    String^ prog
)
static member ProgIsInMyRanges :
        type : DedTypeBase *
        progList : DedTypeProgList *
        prog : string -> bool

Parametri

type DedTypeBase
Famiglia di interesse
progList DedTypeProgList
Progressivi assegnati per la famiglia
prog String
Progressivo da controllare

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Utility
Overload di ProgIsInMyRanges
Namespace DedNet.Core


Metodo Utility.ProgIsInMyUsedRanges

Metodo UtilityProgIsInMyUsedRanges

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool ProgIsInMyUsedRanges(
    DedTypeProgStruct myProg,
    string prog
)
Public Shared Function ProgIsInMyUsedRanges (
    myProg As DedTypeProgStruct,
    prog As String
) As Boolean
public:
static bool ProgIsInMyUsedRanges(
    DedTypeProgStruct myProg,
    String^ prog
)
static member ProgIsInMyUsedRanges :
        myProg : DedTypeProgStruct *
        prog : string -> bool

Parametri

myProg DedTypeProgStruct
prog String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.RelocateOnExistingAttach

Metodo UtilityRelocateOnExistingAttach
Effettua il relocate

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void RelocateOnExistingAttach(
    DedData data,
    string destFileName,
    DocStructInfo dsInfo
)
Public Shared Sub RelocateOnExistingAttach (
    data As DedData,
    destFileName As String,
    dsInfo As DocStructInfo
)
public:
static void RelocateOnExistingAttach(
    DedData^ data,
    String^ destFileName,
    DocStructInfo^ dsInfo
)
static member RelocateOnExistingAttach :
        data : DedData *
        destFileName : string *
        dsInfo : DocStructInfo -> unit

Parametri

data DedData
Anagrafica nella quale inserire l'allegato
destFileName String
Filename della destinazione
dsInfo DocStructInfo
DocsrtucInfo di riferimento
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.RemoveAttributeLength

Metodo UtilityRemoveAttributeLength
Rimuove la lunghezza dai token attributi

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string RemoveAttributeLength(
    string encodeIdFamProgReplaced
)
Public Shared Function RemoveAttributeLength (
    encodeIdFamProgReplaced As String
) As String
public:
static String^ RemoveAttributeLength(
    String^ encodeIdFamProgReplaced
)
static member RemoveAttributeLength :
        encodeIdFamProgReplaced : string -> string

Parametri

encodeIdFamProgReplaced String

Valore di ritorno

String
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.RemoveControlFromLayoutControl

Metodo UtilityRemoveControlFromLayoutControl
Rimuove il controllo dal dialogo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void RemoveControlFromLayoutControl(
    LayoutControl lyt,
    LayoutControlGroup grp,
    LayoutControlItem itemToRemove
)
Public Shared Sub RemoveControlFromLayoutControl (
    lyt As LayoutControl,
    grp As LayoutControlGroup,
    itemToRemove As LayoutControlItem
)
public:
static void RemoveControlFromLayoutControl(
    LayoutControl^ lyt,
    LayoutControlGroup^ grp,
    LayoutControlItem^ itemToRemove
)
static member RemoveControlFromLayoutControl :
        lyt : LayoutControl *
        grp : LayoutControlGroup *
        itemToRemove : LayoutControlItem -> unit

Parametri

lyt LayoutControl
LayoutControl.
grp LayoutControlGroup
LayoutControlGroup.
itemToRemove LayoutControlItem
LayoutControlItem da rimuovere.
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.RemoveGenericDepFromList

Metodo UtilityRemoveGenericDepFromList
Rimuove eventuali dipendenze di tipo generic che si trovano nella lista passata

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void RemoveGenericDepFromList(
    ref DocStructInfoList list
)
Public Shared Sub RemoveGenericDepFromList (
    ByRef list As DocStructInfoList
)
public:
static void RemoveGenericDepFromList(
    DocStructInfoList^% list
)
static member RemoveGenericDepFromList :
        list : DocStructInfoList byref -> unit

Parametri

list DocStructInfoList
Lista da controllare
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.RemoveInvalidFilePathCharacters

Metodo UtilityRemoveInvalidFilePathCharacters
Ritorna un nomefile corretto sostituendo i caratteri non validi con il carattere passato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string RemoveInvalidFilePathCharacters(
    string filename,
    string replaceChar
)
Public Shared Function RemoveInvalidFilePathCharacters (
    filename As String,
    replaceChar As String
) As String
public:
static String^ RemoveInvalidFilePathCharacters(
    String^ filename,
    String^ replaceChar
)
static member RemoveInvalidFilePathCharacters :
        filename : string *
        replaceChar : string -> string

Parametri

filename String
replaceChar String

Valore di ritorno

String
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.RenameFileNgrMode

Metodo UtilityRenameFileNgrMode
Lista degli overload
Nome | Descrizione
RenameFileNgrMode(DedDoc) | Nel caso di documento associato ad anagrafica NGR e ultima revisione restituisce il nuovo nome file salvato nei temp aggiungendogli il tassello della revisione.
RenameFileNgrMode(DedData, DedDoc) | Nel caso di anagrafica NGR e ultima revisione restituisce il nuovo nome file salvato nei temp aggiungendogli il tassello della revisione.
Torna su
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.RenameFileNgrMode(DedDoc)

Metodo UtilityRenameFileNgrMode(DedDoc)
Nel caso di documento associato ad anagrafica NGR e ultima revisione restituisce il nuovo nome file salvato nei temp aggiungendogli il tassello della revisione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string RenameFileNgrMode(
    DedDoc doc
)
Public Shared Function RenameFileNgrMode (
    doc As DedDoc
) As String
public:
static String^ RenameFileNgrMode(
    DedDoc^ doc
)
static member RenameFileNgrMode :
        doc : DedDoc -> string

Parametri

doc DedDoc
Documento che deve essere già scaricato in area locale

Valore di ritorno

String
Vedi anche

Documentazione

Classe Utility
Overload di RenameFileNgrMode
Namespace DedNet.Core


Metodo Utility.RenameFileNgrMode(DedData, DedDoc)

Metodo UtilityRenameFileNgrMode(DedData, DedDoc)
Nel caso di anagrafica NGR e ultima revisione restituisce il nuovo nome file salvato nei temp aggiungendogli il tassello della revisione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string RenameFileNgrMode(
    DedData data,
    DedDoc doc
)
Public Shared Function RenameFileNgrMode (
    data As DedData,
    doc As DedDoc
) As String
public:
static String^ RenameFileNgrMode(
    DedData^ data,
    DedDoc^ doc
)
static member RenameFileNgrMode :
        data : DedData *
        doc : DedDoc -> string

Parametri

data DedData
Anagrafica
doc DedDoc
Documento che deve essere già scaricato in area locale

Valore di ritorno

String
Vedi anche

Documentazione

Classe Utility
Overload di RenameFileNgrMode
Namespace DedNet.Core


Metodo Utility.ReplaceEx

Metodo UtilityReplaceEx
Effettua il replace sulla stringa original della stringa pattern con replacement (case insensitive)

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string ReplaceEx(
    string original,
    string pattern,
    string replacement
)
Public Shared Function ReplaceEx (
    original As String,
    pattern As String,
    replacement As String
) As String
public:
static String^ ReplaceEx(
    String^ original,
    String^ pattern,
    String^ replacement
)
static member ReplaceEx :
        original : string *
        pattern : string *
        replacement : string -> string

Parametri

original String
Stringa originale
pattern String
Stringa da sostituire
replacement String
Stringa sostitutiva

Valore di ritorno

String
Restituisce la stringa modificata
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.ReplaceFirstOccurrance

Metodo UtilityReplaceFirstOccurrance
Sostisuisce solamente la prima occorrenza trovata e restiruisce la stringa modificata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string ReplaceFirstOccurrance(
    string original,
    string oldValue,
    string newValue
)
Public Shared Function ReplaceFirstOccurrance (
    original As String,
    oldValue As String,
    newValue As String
) As String
public:
static String^ ReplaceFirstOccurrance(
    String^ original,
    String^ oldValue,
    String^ newValue
)
static member ReplaceFirstOccurrance :
        original : string *
        oldValue : string *
        newValue : string -> string

Parametri

original String
stringa originale
oldValue String
valore da ricercare
newValue String
valore da sostituire

Valore di ritorno

String
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.ReplaceTokens

Metodo UtilityReplaceTokens
Sostituisce i tasselli passatti con la stringa passata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string ReplaceTokens(
    string encodeIdFam,
    Dictionary<TokenTypeEnum, string> tokens
)
Public Shared Function ReplaceTokens (
    encodeIdFam As String,
    tokens As Dictionary(Of TokenTypeEnum, String)
) As String
public:
static String^ ReplaceTokens(
    String^ encodeIdFam,
    Dictionary<TokenTypeEnum, String^>^ tokens
)
static member ReplaceTokens :
        encodeIdFam : string *
        tokens : Dictionary<TokenTypeEnum, string> -> string

Parametri

encodeIdFam String
Stringa di codifica
tokens Dictionary TokenTypeEnum, String
Accoppiata tassello - stringa sostituzione

Valore di ritorno

String
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.ResetCachePreview

Metodo UtilityResetCachePreview
Azzera la cache delle anteprime relative al controllo passato

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void ResetCachePreview(
    Object control
)
Public Shared Sub ResetCachePreview (
    control As Object
)
public:
static void ResetCachePreview(
    Object^ control
)
static member ResetCachePreview :
        control : Object -> unit

Parametri

control Object
Controllo del quale svuotare la cache
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.ResizeBitmap

Metodo UtilityResizeBitmap
Ridimensiona l'immagine passata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static Bitmap ResizeBitmap(
    Bitmap b,
    int nWidth,
    int nHeight
)
Public Shared Function ResizeBitmap (
    b As Bitmap,
    nWidth As Integer,
    nHeight As Integer
) As Bitmap
public:
static Bitmap^ ResizeBitmap(
    Bitmap^ b,
    int nWidth,
    int nHeight
)
static member ResizeBitmap :
        b : Bitmap *
        nWidth : int *
        nHeight : int -> Bitmap

Parametri

b Bitmap
Immagine da ridimensionare
nWidth Int32
Nuova larghezza
nHeight Int32
Nuova altezza

Valore di ritorno

Bitmap
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.ResizeImageHighQuality

Metodo UtilityResizeImageHighQuality

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static Image ResizeImageHighQuality(
    Image OriginalImage,
    Size ThumbSize
)
Public Shared Function ResizeImageHighQuality (
    OriginalImage As Image,
    ThumbSize As Size
) As Image
public:
static Image^ ResizeImageHighQuality(
    Image^ OriginalImage,
    Size ThumbSize
)
static member ResizeImageHighQuality :
        OriginalImage : Image *
        ThumbSize : Size -> Image

Parametri

OriginalImage Image
ThumbSize Size

Valore di ritorno

Image
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.RestorePageSettingsInfo

Metodo UtilityRestorePageSettingsInfo
Rispristina le impostazioni di pagina di esportazione devexpress.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void RestorePageSettingsInfo(
    string xmlpath,
    PrintableComponentLink p
)
Public Shared Sub RestorePageSettingsInfo (
    xmlpath As String,
    p As PrintableComponentLink
)
public:
static void RestorePageSettingsInfo(
    String^ xmlpath,
    PrintableComponentLink^ p
)
static member RestorePageSettingsInfo :
        xmlpath : string *
        p : PrintableComponentLink -> unit

Parametri

xmlpath String
File contenente le impostazioni di pagine
p PrintableComponentLink
PrintableComponentLink da ripristinare
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.ReturnMaxWidth

Metodo UtilityReturnMaxWidth
Restituisce il maggiore tra la lunghezza della stringa e il massimo passato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static int ReturnMaxWidth(
    string text,
    int maxWidth,
    BaseForm ctr
)
Public Shared Function ReturnMaxWidth (
    text As String,
    maxWidth As Integer,
    ctr As BaseForm
) As Integer
public:
static int ReturnMaxWidth(
    String^ text,
    int maxWidth,
    BaseForm^ ctr
)
static member ReturnMaxWidth :
        text : string *
        maxWidth : int *
        ctr : BaseForm -> int

Parametri

text String
Stringa della quale calcolare la lunghezza.
maxWidth Int32
Lunghezza massima attuale.
ctr BaseForm

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.ReverseList

Metodo UtilityReverseList
Data un array lo restituisce con nell'ordine invertiro.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static Object[] ReverseList(
    Object[] obj
)
Public Shared Function ReverseList (
    obj As Object()
) As Object()
public:
static array<Object^>^ ReverseList(
    array<Object^>^ obj
)
static member ReverseList :
        obj : Object[] -> Object[]

Parametri

obj Object
Array da invertire

Valore di ritorno

Object
Array invertiro
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.RunCommandMenuItem

Metodo UtilityRunCommandMenuItem
Esegue il comando abbinato alla voce di menu cliccata e poi lo restituisce.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static DedCommand RunCommandMenuItem(
    IWin32Window ownerForm,
    DedCommandContext context,
    BarButtonItem item
)
Public Shared Function RunCommandMenuItem (
    ownerForm As IWin32Window,
    context As DedCommandContext,
    item As BarButtonItem
) As DedCommand
public:
static DedCommand^ RunCommandMenuItem(
    IWin32Window^ ownerForm,
    DedCommandContext^ context,
    BarButtonItem^ item
)
static member RunCommandMenuItem :
        ownerForm : IWin32Window *
        context : DedCommandContext *
        item : BarButtonItem -> DedCommand

Parametri

ownerForm IWin32Window
Parent Form.
context DedCommandContext
Contesto di esecuzione.
item BarButtonItem
Elemento selezionato dal menu.

Valore di ritorno

DedCommand
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.SaveIdRevInTheRegistry

Metodo UtilitySaveIdRevInTheRegistry
Metodo che salva nel registro l'Id e la Rev dell'anagrafica associata al documento. In questo modo il documento viene aperto con i dati dell'anagrafica corretta. La chiave di registro viene scritta nel caso in cui: 1) Il documento in apertura si un documento CAD. 2) L'anagrafica impostata sia quella effettivamente associata al documento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void SaveIdRevInTheRegistry(
    DedNetApplication app,
    DedData anagr,
    DedDoc doc
)
Public Shared Sub SaveIdRevInTheRegistry (
    app As DedNetApplication,
    anagr As DedData,
    doc As DedDoc
)
public:
static void SaveIdRevInTheRegistry(
    DedNetApplication^ app,
    DedData^ anagr,
    DedDoc^ doc
)
static member SaveIdRevInTheRegistry :
        app : DedNetApplication *
        anagr : DedData *
        doc : DedDoc -> unit

Parametri

app DedNetApplication
Applicazione DedNet dalla quale ricavare il path della chiave di registro.
anagr DedData
Anagrafica con la quale aprire il documento.
doc DedDoc
Documento che si intende aprire.
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.SavePageSettingsInfo

Metodo UtilitySavePageSettingsInfo
Salva le impostazioni di pagina del PrintableComponentLink in un file xml.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void SavePageSettingsInfo(
    string xmlpath,
    PrintableComponentLink p
)
Public Shared Sub SavePageSettingsInfo (
    xmlpath As String,
    p As PrintableComponentLink
)
public:
static void SavePageSettingsInfo(
    String^ xmlpath,
    PrintableComponentLink^ p
)
static member SavePageSettingsInfo :
        xmlpath : string *
        p : PrintableComponentLink -> unit

Parametri

xmlpath String
File nel quale salvare le impostazioni di pagine
p PrintableComponentLink
PrintableComponentLink da salvare
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.SendCustomMailWithSmtpSettings

Metodo UtilitySendCustomMailWithSmtpSettings
Permette di inviare un'email con le credenziali presenti nelle impostazioni SMTP del Gestore notifiche.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void SendCustomMailWithSmtpSettings(
    DedNetApplication app,
    string to,
    string cc,
    string ccn,
    string obj,
    string body,
    List<string> files,
    bool async = false
)
Public Shared Sub SendCustomMailWithSmtpSettings (
    app As DedNetApplication,
    to As String,
    cc As String,
    ccn As String,
    obj As String,
    body As String,
    files As List(Of String),
    Optional async As Boolean = false
)
public:
static void SendCustomMailWithSmtpSettings(
    DedNetApplication^ app,
    String^ to,
    String^ cc,
    String^ ccn,
    String^ obj,
    String^ body,
    List<String^>^ files,
    bool async = false
)
static member SendCustomMailWithSmtpSettings :
        app : DedNetApplication *
        to : string *
        cc : string *
        ccn : string *
        obj : string *
        body : string *
        files : List<string> *
        ?async : bool
(* Defaults:
        let _async = defaultArg async false
*)
-> unit

Parametri

app DedNetApplication
DedNetApplication
to String
Destinatari separati da ,
cc String
Destinatari separati da ,
ccn String
Destinatari separati da ,
obj String
Oggetto del messaggio
body String
Corpo del messagggio
files List String
Lista dei file da inviare
async Boolean (Optional)
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.SendMail

Metodo UtilitySendMail
Lista degli overload
Nome | Descrizione
SendMail(DedNetApplication, DedNotifyNotifyEvent, DedEco) | Controlla che sia inizializzato il notificatore e nel caso invia la notifica. Se il parametro opzionale 'context' non è impostato, la mail verrà inviata in modo asincrono.
SendMail(DedNetApplication, DedNotifyNotifyEvent, DedDataList, DedCommList) | Controlla che sia inizializzato il notificatore e nel caso invia la notifica.
SendMail(DedNetApplication, DedNotifyNotifyEvent, DedEco, ListDedUser) | Controlla che sia inizializzato il notificatore e nel caso invia la notifica. Se il parametro opzionale 'context' non è impostato, la mail verrà inviata in modo asincrono.
SendMail(DedNetApplication, DedNotifyNotifyEvent, DedDataList, DedCommList, ListDedUser) | Controlla che sia inizializzato il notificatore e nel caso invia la notifica.
Torna su
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.SendMail(DedNetApplication, DedNotify.NotifyEvent, DedEco)

Metodo UtilitySendMail(DedNetApplication, DedNotifyNotifyEvent, DedEco)
Controlla che sia inizializzato il notificatore e nel caso invia la notifica. Se il parametro opzionale 'context' non è impostato, la mail verrà inviata in modo asincrono.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void SendMail(
    DedNetApplication app,
    DedNotifyNotifyEvent eventToSend,
    DedEco eco
)
Public Shared Sub SendMail (
    app As DedNetApplication,
    eventToSend As DedNotifyNotifyEvent,
    eco As DedEco
)
public:
static void SendMail(
    DedNetApplication^ app,
    DedNotifyNotifyEvent eventToSend,
    DedEco^ eco
)
static member SendMail :
        app : DedNetApplication *
        eventToSend : DedNotifyNotifyEvent *
        eco : DedEco -> unit

Parametri

app DedNetApplication
DedNetApplication
eventToSend DedNotifyNotifyEvent
Evento da controllare.
eco DedEco
Eco in gioco ( da usare per sostituire i valori )
Vedi anche

Documentazione

Classe Utility
Overload di SendMail
Namespace DedNet.Core


Metodo Utility.SendMail(DedNetApplication, DedNotify.NotifyEvent, DedDataList, DedCommList)

Metodo UtilitySendMail(DedNetApplication, DedNotifyNotifyEvent, DedDataList, DedCommList)
Controlla che sia inizializzato il notificatore e nel caso invia la notifica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void SendMail(
    DedNetApplication app,
    DedNotifyNotifyEvent eventToSend,
    DedDataList datas,
    DedCommList comms
)
Public Shared Sub SendMail (
    app As DedNetApplication,
    eventToSend As DedNotifyNotifyEvent,
    datas As DedDataList,
    comms As DedCommList
)
public:
static void SendMail(
    DedNetApplication^ app,
    DedNotifyNotifyEvent eventToSend,
    DedDataList^ datas,
    DedCommList^ comms
)
static member SendMail :
        app : DedNetApplication *
        eventToSend : DedNotifyNotifyEvent *
        datas : DedDataList *
        comms : DedCommList -> unit

Parametri

app DedNetApplication
DedNetApplication
eventToSend DedNotifyNotifyEvent
Evento da controllare.
datas DedDataList
Anagrafiche in gioco ( da usare per sostituire i valori )
comms DedCommList
Commesse in gioco ( da usare per sostituire i valori )
Vedi anche

Documentazione

Classe Utility
Overload di SendMail
Namespace DedNet.Core


Metodo Utility.SendMail(DedNetApplication, DedNotify.NotifyEvent, DedEco, List<DedUser>)

Metodo UtilitySendMail(DedNetApplication, DedNotifyNotifyEvent, DedEco, ListDedUser)
Controlla che sia inizializzato il notificatore e nel caso invia la notifica. Se il parametro opzionale 'context' non è impostato, la mail verrà inviata in modo asincrono.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void SendMail(
    DedNetApplication app,
    DedNotifyNotifyEvent eventToSend,
    DedEco eco,
    List<DedUser> users
)
Public Shared Sub SendMail (
    app As DedNetApplication,
    eventToSend As DedNotifyNotifyEvent,
    eco As DedEco,
    users As List(Of DedUser)
)
public:
static void SendMail(
    DedNetApplication^ app,
    DedNotifyNotifyEvent eventToSend,
    DedEco^ eco,
    List<DedUser^>^ users
)
static member SendMail :
        app : DedNetApplication *
        eventToSend : DedNotifyNotifyEvent *
        eco : DedEco *
        users : List<DedUser> -> unit

Parametri

app DedNetApplication
DedNetApplication
eventToSend DedNotifyNotifyEvent
Evento da controllare.
eco DedEco
Eco in gioco ( da usare per sostituire i valori )
users List DedUser
Lista degli utenti da aggiungere all'elenco dei notificati.
Vedi anche

Documentazione

Classe Utility
Overload di SendMail
Namespace DedNet.Core


Metodo Utility.SendMail(DedNetApplication, DedNotify.NotifyEvent, DedDataList, DedCommList, List<DedUser>)

Metodo UtilitySendMail(DedNetApplication, DedNotifyNotifyEvent, DedDataList, DedCommList, ListDedUser)
Controlla che sia inizializzato il notificatore e nel caso invia la notifica.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void SendMail(
    DedNetApplication app,
    DedNotifyNotifyEvent eventToSend,
    DedDataList datas,
    DedCommList comms,
    List<DedUser> users
)
Public Shared Sub SendMail (
    app As DedNetApplication,
    eventToSend As DedNotifyNotifyEvent,
    datas As DedDataList,
    comms As DedCommList,
    users As List(Of DedUser)
)
public:
static void SendMail(
    DedNetApplication^ app,
    DedNotifyNotifyEvent eventToSend,
    DedDataList^ datas,
    DedCommList^ comms,
    List<DedUser^>^ users
)
static member SendMail :
        app : DedNetApplication *
        eventToSend : DedNotifyNotifyEvent *
        datas : DedDataList *
        comms : DedCommList *
        users : List<DedUser> -> unit

Parametri

app DedNetApplication
DedNetApplication
eventToSend DedNotifyNotifyEvent
Evento da controllare.
datas DedDataList
Anagrafiche in gioco ( da usare per sostituire i valori )
comms DedCommList
Commesse in gioco ( da usare per sostituire i valori )
users List DedUser
Lista degli utenti da aggiungere all'elenco dei notificati.
Vedi anche

Documentazione

Classe Utility
Overload di SendMail
Namespace DedNet.Core


Metodo Utility.SendMailCustomizedEvent

Metodo UtilitySendMailCustomizedEvent
Lista degli overload
Nome | Descrizione
SendMailCustomizedEvent(DedNetApplication, String, DedDataList, DedCommList) | Controlla se è presente una notifica personalizzata con il nome passato e nel caso la invia.
SendMailCustomizedEvent(DedNetApplication, String, DedDataList, DedCommList, ListDedUser) | Controlla se è presente una notifica personalizzata con il nome passato e nel caso la invia.
Torna su
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.SendMailCustomizedEvent(DedNetApplication, String, DedDataList, DedCommList)

Metodo UtilitySendMailCustomizedEvent(DedNetApplication, String, DedDataList, DedCommList)
Controlla se è presente una notifica personalizzata con il nome passato e nel caso la invia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void SendMailCustomizedEvent(
    DedNetApplication app,
    string notifyName,
    DedDataList datas,
    DedCommList comms
)
Public Shared Sub SendMailCustomizedEvent (
    app As DedNetApplication,
    notifyName As String,
    datas As DedDataList,
    comms As DedCommList
)
public:
static void SendMailCustomizedEvent(
    DedNetApplication^ app,
    String^ notifyName,
    DedDataList^ datas,
    DedCommList^ comms
)
static member SendMailCustomizedEvent :
        app : DedNetApplication *
        notifyName : string *
        datas : DedDataList *
        comms : DedCommList -> unit

Parametri

app DedNetApplication
DedNetApplication
notifyName String
Nome della notifica da controllare.
datas DedDataList
Anagrafiche in gioco ( da usare per sostituire i valori )
comms DedCommList
Commesse in gioco ( da usare per sostituire i valori )
Vedi anche

Documentazione

Classe Utility
Overload di SendMailCustomizedEvent
Namespace DedNet.Core


Metodo Utility.SendMailCustomizedEvent(DedNetApplication, String, DedDataList, DedCommList, List<DedUser>)

Metodo UtilitySendMailCustomizedEvent(DedNetApplication, String, DedDataList, DedCommList, ListDedUser)
Controlla se è presente una notifica personalizzata con il nome passato e nel caso la invia.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void SendMailCustomizedEvent(
    DedNetApplication app,
    string notifyName,
    DedDataList datas,
    DedCommList comms,
    List<DedUser> users
)
Public Shared Sub SendMailCustomizedEvent (
    app As DedNetApplication,
    notifyName As String,
    datas As DedDataList,
    comms As DedCommList,
    users As List(Of DedUser)
)
public:
static void SendMailCustomizedEvent(
    DedNetApplication^ app,
    String^ notifyName,
    DedDataList^ datas,
    DedCommList^ comms,
    List<DedUser^>^ users
)
static member SendMailCustomizedEvent :
        app : DedNetApplication *
        notifyName : string *
        datas : DedDataList *
        comms : DedCommList *
        users : List<DedUser> -> unit

Parametri

app DedNetApplication
DedNetApplication
notifyName String
Nome della notifica da controllare.
datas DedDataList
Anagrafiche in gioco ( da usare per sostituire i valori )
comms DedCommList
Commesse in gioco ( da usare per sostituire i valori )
users List DedUser
Lista degli utenti da aggiungere all'elenco dei notificati.
Vedi anche

Documentazione

Classe Utility
Overload di SendMailCustomizedEvent
Namespace DedNet.Core


Metodo Utility.SetColumnDisplayFormatFromAttr

Metodo UtilitySetColumnDisplayFormatFromAttr
Imposta la formattazione della colonna in base all'attributo specificato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void SetColumnDisplayFormatFromAttr(
    DedAttr attr,
    GridColumn col,
    RepositoryItemCheckEdit repoCheck
)
Public Shared Sub SetColumnDisplayFormatFromAttr (
    attr As DedAttr,
    col As GridColumn,
    repoCheck As RepositoryItemCheckEdit
)
public:
static void SetColumnDisplayFormatFromAttr(
    DedAttr^ attr,
    GridColumn^ col,
    RepositoryItemCheckEdit^ repoCheck
)
static member SetColumnDisplayFormatFromAttr :
        attr : DedAttr *
        col : GridColumn *
        repoCheck : RepositoryItemCheckEdit -> unit

Parametri

attr DedAttr
Attributo da cui leggere la formattazione.
col GridColumn
Colonna di cui si vuole impostare il 'DisplayFormat'.
repoCheck RepositoryItemCheckEdit
RepositoryItemCheckEdit usato nel caso in cui l'attributo contenga valori booleani.
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.SetCulture

Metodo UtilitySetCulture
Metodo che imposta la culture in base alla lingua impostata nel file DedNet.ini

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void SetCulture()
Public Shared Sub SetCulture
public:
static void SetCulture()
static member SetCulture : unit -> unit
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.SetDpiAware

Metodo UtilitySetDpiAware
Metodo che imposta l'applicazione DPIAware e logga eventuali anomalie

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void SetDpiAware()
Public Shared Sub SetDpiAware
public:
static void SetDpiAware()
static member SetDpiAware : unit -> unit
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.SetEcoColumnProperties

Metodo UtilitySetEcoColumnProperties
Metodo usato per impostare le proprietà della colonna degli Eco.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void SetEcoColumnProperties(
    GridColumn col
)
Public Shared Sub SetEcoColumnProperties (
    col As GridColumn
)
public:
static void SetEcoColumnProperties(
    GridColumn^ col
)
static member SetEcoColumnProperties :
        col : GridColumn -> unit

Parametri

col GridColumn
Oggetto GridColumn rappresentante la colonna degli Eco.
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.SetEnabledMenuItem

Metodo UtilitySetEnabledMenuItem
Abilita o meno le voci di menu in base al contesto selezionato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void SetEnabledMenuItem(
    BarItemLinkCollection items,
    DedCommandContext context
)
Public Shared Sub SetEnabledMenuItem (
    items As BarItemLinkCollection,
    context As DedCommandContext
)
public:
static void SetEnabledMenuItem(
    BarItemLinkCollection^ items,
    DedCommandContext^ context
)
static member SetEnabledMenuItem :
        items : BarItemLinkCollection *
        context : DedCommandContext -> unit

Parametri

items BarItemLinkCollection
Collezione di partenza dele voci di menu.
context DedCommandContext
Contesto di esecuzione.
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.SetFileReadOnly

Metodo UtilitySetFileReadOnly
Imposta la proprietà readOnly del file passato. Se non ci riesce perché il file è bloccato restituisce false. Se il file non esiste restituisce false.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool SetFileReadOnly(
    string fileName,
    bool readOnly
)
Public Shared Function SetFileReadOnly (
    fileName As String,
    readOnly As Boolean
) As Boolean
public:
static bool SetFileReadOnly(
    String^ fileName,
    bool readOnly
)
static member SetFileReadOnly :
        fileName : string *
        readOnly : bool -> bool

Parametri

fileName String
File di cui impostare la proprietà readonly.
readOnly Boolean
Indica se deve essere impostato readonly o no

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.ShellOpenFile

Metodo UtilityShellOpenFile
Apre il file passato con la shell di windows, in modo asincrono (che è il default).

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void ShellOpenFile(
    string fileName
)
Public Shared Sub ShellOpenFile (
    fileName As String
)
public:
static void ShellOpenFile(
    String^ fileName
)
static member ShellOpenFile :
        fileName : string -> unit

Parametri

fileName String
File da aprire.
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.ShowECO

Metodo UtilityShowECO
Lista degli overload
Nome | Descrizione
ShowECO(TreeListHitInfo, DedData, DictionaryTreeListNode, TupleInt32, DedEcoEcoTypeEnum, Int32) | Visualizza gli ECO associati all'anagrafica cliccata.
ShowECO(GridView, Point, String, Int32) | Visualizza gli ECO associati alla commessa cliccata.
ShowECO(GridView, Point, String, String, DictionaryString, DictionaryDedEcoEcoTypeEnum, Int32) | Visualizza gli ECO associati all'anagrafica cliccata.
ShowECO(GridView, Point, String, String, Int32) | Visualizza gli ECO associati all'anagrafica cliccata.
Torna su
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.ShowECO(TreeListHitInfo, DedData, Dictionary<TreeListNode, Tuple<Int32, DedEco.EcoTypeEnum, Int32>>)

Metodo UtilityShowECO(TreeListHitInfo, DedData, DictionaryTreeListNode, TupleInt32, DedEcoEcoTypeEnum, Int32)
Visualizza gli ECO associati all'anagrafica cliccata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool ShowECO(
    TreeListHitInfo hitInfo,
    DedData data,
    Dictionary<TreeListNode, Tuple<int, DedEcoEcoTypeEnum, int>> ecoDictionary
)
Public Shared Function ShowECO (
    hitInfo As TreeListHitInfo,
    data As DedData,
    ecoDictionary As Dictionary(Of TreeListNode, Tuple(Of Integer, DedEcoEcoTypeEnum, Integer))
) As Boolean
public:
static bool ShowECO(
    TreeListHitInfo^ hitInfo,
    DedData^ data,
    Dictionary<TreeListNode^, Tuple<int, DedEcoEcoTypeEnum, int>^>^ ecoDictionary
)
static member ShowECO :
        hitInfo : TreeListHitInfo *
        data : DedData *
        ecoDictionary : Dictionary<TreeListNode, Tuple<int, DedEcoEcoTypeEnum, int>> -> bool

Parametri

hitInfo TreeListHitInfo
Informazioni sul punto cliccato.
data DedData
Anagrafica da usare come riferimento.
ecoDictionary Dictionary TreeListNode, Tuple Int32, DedEcoEcoTypeEnum, Int32
Dizionario contentente il numero di ECO.

Valore di ritorno

Boolean
Ritorna True se è stata cliccata la colonna ECO, False altrimenti.
Vedi anche

Documentazione

Classe Utility
Overload di ShowECO
Namespace DedNet.Core


Metodo Utility.ShowECO(GridView, Point, String, Int32)

Metodo UtilityShowECO(GridView, Point, String, Int32)
Visualizza gli ECO associati alla commessa cliccata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void ShowECO(
    GridView view,
    Point pnt,
    string colCommName,
    int numEco
)
Public Shared Sub ShowECO (
    view As GridView,
    pnt As Point,
    colCommName As String,
    numEco As Integer
)
public:
static void ShowECO(
    GridView^ view,
    Point pnt,
    String^ colCommName,
    int numEco
)
static member ShowECO :
        view : GridView *
        pnt : Point *
        colCommName : string *
        numEco : int -> unit

Parametri

view GridView
Vista della griglia.
pnt Point
Punto in cui il mouse è stato cliccato.
colCommName String
Nome della colonna da cui prelevare il nome della commessa.
numEco Int32
Vedi anche

Documentazione

Classe Utility
Overload di ShowECO
Namespace DedNet.Core


Metodo Utility.ShowECO(GridView, Point, String, String, Dictionary<String, Dictionary<DedEco.EcoTypeEnum, Int32>>)

Metodo UtilityShowECO(GridView, Point, String, String, DictionaryString, DictionaryDedEcoEcoTypeEnum, Int32)
Visualizza gli ECO associati all'anagrafica cliccata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void ShowECO(
    GridView view,
    Point pnt,
    string colId,
    string colRev,
    Dictionary<string, Dictionary<DedEcoEcoTypeEnum, int>> dizEco
)
Public Shared Sub ShowECO (
    view As GridView,
    pnt As Point,
    colId As String,
    colRev As String,
    dizEco As Dictionary(Of String, Dictionary(Of DedEcoEcoTypeEnum, Integer))
)
public:
static void ShowECO(
    GridView^ view,
    Point pnt,
    String^ colId,
    String^ colRev,
    Dictionary<String^, Dictionary<DedEcoEcoTypeEnum, int>^>^ dizEco
)
static member ShowECO :
        view : GridView *
        pnt : Point *
        colId : string *
        colRev : string *
        dizEco : Dictionary<string, Dictionary<DedEcoEcoTypeEnum, int>> -> unit

Parametri

view GridView
Vista della griglia.
pnt Point
Punto in cui il mouse è stato cliccato.
colId String
Nome della colonna da cui prelevare l'ID dell'anagrafica.
colRev String
Nome della colonna da cui prelevare la Revisione dell'anagrafica.
dizEco Dictionary String, Dictionary DedEcoEcoTypeEnum, Int32
Vedi anche

Documentazione

Classe Utility
Overload di ShowECO
Namespace DedNet.Core


Metodo Utility.ShowECO(GridView, Point, String, String, Int32)

Metodo UtilityShowECO(GridView, Point, String, String, Int32)
Visualizza gli ECO associati all'anagrafica cliccata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void ShowECO(
    GridView view,
    Point pnt,
    string colId,
    string colRev,
    int numEco
)
Public Shared Sub ShowECO (
    view As GridView,
    pnt As Point,
    colId As String,
    colRev As String,
    numEco As Integer
)
public:
static void ShowECO(
    GridView^ view,
    Point pnt,
    String^ colId,
    String^ colRev,
    int numEco
)
static member ShowECO :
        view : GridView *
        pnt : Point *
        colId : string *
        colRev : string *
        numEco : int -> unit

Parametri

view GridView
Vista della griglia.
pnt Point
Punto in cui il mouse è stato cliccato.
colId String
Nome della colonna da cui prelevare l'ID dell'anagrafica.
colRev String
Nome della colonna da cui prelevare la Revisione dell'anagrafica.
numEco Int32
Vedi anche

Documentazione

Classe Utility
Overload di ShowECO
Namespace DedNet.Core


Metodo Utility.ShowMarkerInfo

Metodo UtilityShowMarkerInfo
Funzione che mostra lo stato del DOCROWVER del documento passato.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void ShowMarkerInfo(
    DedDoc doc
)
Public Shared Sub ShowMarkerInfo (
    doc As DedDoc
)
public:
static void ShowMarkerInfo(
    DedDoc^ doc
)
static member ShowMarkerInfo :
        doc : DedDoc -> unit

Parametri

doc DedDoc
Documanto da analizzare.
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.ShowPopUpMenu

Metodo UtilityShowPopUpMenu
Lista degli overload
Nome | Descrizione
ShowPopUpMenu(PopupMenu, Point, PopupMenuShowingEventArgs) | Mostra il menu contestuale nella posizione passata.
ShowPopUpMenu(PopupMenu, Point, PopupMenuShowingEventArgs) | Mostra il menu contestuale nella posizione passata.
Torna su
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.ShowPopUpMenu(PopupMenu, Point, PopupMenuShowingEventArgs)

Metodo UtilityShowPopUpMenu(PopupMenu, Point, PopupMenuShowingEventArgs)
Mostra il menu contestuale nella posizione passata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void ShowPopUpMenu(
    PopupMenu ctrCtx,
    Point mousePosition,
    PopupMenuShowingEventArgs e
)
Public Shared Sub ShowPopUpMenu (
    ctrCtx As PopupMenu,
    mousePosition As Point,
    e As PopupMenuShowingEventArgs
)
public:
static void ShowPopUpMenu(
    PopupMenu^ ctrCtx,
    Point mousePosition,
    PopupMenuShowingEventArgs^ e
)
static member ShowPopUpMenu :
        ctrCtx : PopupMenu *
        mousePosition : Point *
        e : PopupMenuShowingEventArgs -> unit

Parametri

ctrCtx PopupMenu
menucontestuale
mousePosition Point
punto
e PopupMenuShowingEventArgs
eventargs del chiamante
Vedi anche

Documentazione

Classe Utility
Overload di ShowPopUpMenu
Namespace DedNet.Core


Metodo Utility.ShowUniqueDependencies

Metodo UtilityShowUniqueDependencies
Restituisce se mostrare le dipendenze univoche. Restituisce True se si tratta di assieme o parte.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool ShowUniqueDependencies(
    DedDoc doc
)
Public Shared Function ShowUniqueDependencies (
    doc As DedDoc
) As Boolean
public:
static bool ShowUniqueDependencies(
    DedDoc^ doc
)
static member ShowUniqueDependencies :
        doc : DedDoc -> bool

Parametri

doc DedDoc
Documneto da analizzare

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.StringHeight

Metodo UtilityStringHeight
Metodo che ritorna la lunghezza, in pixel, della stringa passata in ingresso.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static int StringHeight(
    string text,
    Font font,
    Control ctrl
)
Public Shared Function StringHeight (
    text As String,
    font As Font,
    ctrl As Control
) As Integer
public:
static int StringHeight(
    String^ text,
    Font^ font,
    Control^ ctrl
)
static member StringHeight :
        text : string *
        font : Font *
        ctrl : Control -> int

Parametri

text String
Stringa da esaminare.
font Font
Font della stringa da esaminare.
ctrl Control
Controllo contenente la stringa.

Valore di ritorno

Int32
Lunghezza della stringa.
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.StringIsDimension

Metodo UtilityStringIsDimension
Contolla se l'attributo è del tipo d12, d432, etc.. e nel caso lo esclude.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool StringIsDimension(
    string keyUpper,
    char firstChar
)
Public Shared Function StringIsDimension (
    keyUpper As String,
    firstChar As Char
) As Boolean
public:
static bool StringIsDimension(
    String^ keyUpper,
    wchar_t firstChar
)
static member StringIsDimension :
        keyUpper : string *
        firstChar : char -> bool

Parametri

keyUpper String
firstChar Char

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.StringIsGuid

Metodo UtilityStringIsGuid
Restituisce se la stringa rappresenta un Guid.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool StringIsGuid(
    string expression
)
Public Shared Function StringIsGuid (
    expression As String
) As Boolean
public:
static bool StringIsGuid(
    String^ expression
)
static member StringIsGuid :
        expression : string -> bool

Parametri

expression String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.StringToImage

Metodo UtilityStringToImage
Convert string to image

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static Image StringToImage(
    string imageString
)
Public Shared Function StringToImage (
    imageString As String
) As Image
public:
static Image^ StringToImage(
    String^ imageString
)
static member StringToImage :
        imageString : string -> Image

Parametri

imageString String

Valore di ritorno

Image
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.StringWidth

Metodo UtilityStringWidth
Metodo che ritorna la lunghezza, in pixel, della stringa passata in ingresso.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static int StringWidth(
    string text,
    Font font,
    Control ctrl
)
Public Shared Function StringWidth (
    text As String,
    font As Font,
    ctrl As Control
) As Integer
public:
static int StringWidth(
    String^ text,
    Font^ font,
    Control^ ctrl
)
static member StringWidth :
        text : string *
        font : Font *
        ctrl : Control -> int

Parametri

text String
Stringa da esaminare.
font Font
Font della stringa da esaminare.
ctrl Control
Controllo contenente la stringa.

Valore di ritorno

Int32
Lunghezza della stringa.
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.ThrowSpecificException

Metodo UtilityThrowSpecificException
Cerca di generare un'eccezione più specifica nel caso il progressivo sia riservato a altri utenti.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void ThrowSpecificException(
    DedNetApplication app,
    string dbpath,
    string newValue,
    bool progrReserved
)
Public Shared Sub ThrowSpecificException (
    app As DedNetApplication,
    dbpath As String,
    newValue As String,
    progrReserved As Boolean
)
public:
static void ThrowSpecificException(
    DedNetApplication^ app,
    String^ dbpath,
    String^ newValue,
    bool progrReserved
)
static member ThrowSpecificException :
        app : DedNetApplication *
        dbpath : string *
        newValue : string *
        progrReserved : bool -> unit

Parametri

app DedNetApplication
Applicazione DedNet
dbpath String
DbPath della famiglia della quale controllare il progressivo
newValue String
Valore del progressivo da controllare
progrReserved Boolean
Indica se ci sono dei progressivi assegnati
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.TranslateColumnsCaption

Metodo UtilityTranslateColumnsCaption
Data una collection di colonne, ne traduce il testo mostrato a schermo per ogni elemento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void TranslateColumnsCaption(
    GridColumnCollection columns,
    Type tp
)
Public Shared Sub TranslateColumnsCaption (
    columns As GridColumnCollection,
    tp As Type
)
public:
static void TranslateColumnsCaption(
    GridColumnCollection^ columns,
    Type^ tp
)
static member TranslateColumnsCaption :
        columns : GridColumnCollection *
        tp : Type -> unit

Parametri

columns GridColumnCollection
Lista delle colonne da tradurre.
tp Type
Tipo da cui prelevare le proprietà.
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.UnFormatZeroLeft

Metodo UtilityUnFormatZeroLeft
Rimuove i caratteri paddingChar che sono all'inizio della stringa strVal.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string UnFormatZeroLeft(
    string strVal,
    char paddingChar
)
Public Shared Function UnFormatZeroLeft (
    strVal As String,
    paddingChar As Char
) As String
public:
static String^ UnFormatZeroLeft(
    String^ strVal,
    wchar_t paddingChar
)
static member UnFormatZeroLeft :
        strVal : string *
        paddingChar : char -> string

Parametri

strVal String
Stringa da modificare
paddingChar Char
Carattere da rimuovere.

Valore di ritorno

String
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.UnZip

Metodo UtilityUnZip
Unzippa il file passato nella cartella desiderata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void UnZip(
    string zippedFile,
    string targetDir,
    bool showProgressBar = true,
    Action<int> stepperMethod = null
)
Public Shared Sub UnZip (
    zippedFile As String,
    targetDir As String,
    Optional showProgressBar As Boolean = true,
    Optional stepperMethod As Action(Of Integer) = Nothing
)
public:
static void UnZip(
    String^ zippedFile,
    String^ targetDir,
    bool showProgressBar = true,
    Action<int>^ stepperMethod = nullptr
)
static member UnZip :
        zippedFile : string *
        targetDir : string *
        ?showProgressBar : bool *
        ?stepperMethod : Action<int>
(* Defaults:
        let _showProgressBar = defaultArg showProgressBar true
        let _stepperMethod = defaultArg stepperMethod null
*)
-> unit

Parametri

zippedFile String
File da Unzippare.
targetDir String
Cartella di destinazione.
showProgressBar Boolean (Optional)
Imposta la visualizzazione della barra
stepperMethod Action Int32 (Optional)
Delegate che permette la gestione di una progressione esterna
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.UpdateDedDataPartWithOnlyDbAttrs

Metodo UtilityUpdateDedDataPartWithOnlyDbAttrs
Dato un DedDataPart calcolato su un documento, lo aggiorna con gli attributi "Solo Db" dell'anagrafica a cui è collegato. Non sporca il DedDataPart perchè è tra BeginIgnoreDirty ed EndIgnoreDirty.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void UpdateDedDataPartWithOnlyDbAttrs(
    DedDataPart prt,
    DedData dt
)
Public Shared Sub UpdateDedDataPartWithOnlyDbAttrs (
    prt As DedDataPart,
    dt As DedData
)
public:
static void UpdateDedDataPartWithOnlyDbAttrs(
    DedDataPart^ prt,
    DedData^ dt
)
static member UpdateDedDataPartWithOnlyDbAttrs :
        prt : DedDataPart *
        dt : DedData -> unit

Parametri

prt DedDataPart
DedDataPart da modificare.
dt DedData
Anagrafica a cui è associato. Se impostata verrà utilizzata questa e non verrà eseguita una query per calcolarla.
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.UpdateString

Metodo UtilityUpdateString
Incrementa o decrementa la stringa passata iniziando dal carattere più a destra e proseguendo. Se necessario aggiunge un carattere a sinistra (es. 99 -> 100) o lo azzera nel caso di decremento (es. 100 -> 099). Se non riesce a trovare nell'alfabeto il carattere da incrementare verifica il caso più semplice del numero (0-9) o dell'alfabeto (A-Za-z). Se non riesce restituisce la stessa stringa che ha ricevuto come argomento.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string UpdateString(
    string stringToIncrease,
    bool increase,
    string alphabet
)
Public Shared Function UpdateString (
    stringToIncrease As String,
    increase As Boolean,
    alphabet As String
) As String
public:
static String^ UpdateString(
    String^ stringToIncrease,
    bool increase,
    String^ alphabet
)
static member UpdateString :
        stringToIncrease : string *
        increase : bool *
        alphabet : string -> string

Parametri

stringToIncrease String
Stringa numerica o alfanumerica da incrementare.
increase Boolean
Indica se incrementare o decrementare la stringa.
alphabet String
Alfabeto da utilizzare per l'incremento della stringa. Se si passa null utilizza quello numerico o alfabetico.

Valore di ritorno

String
Restituisce la stringa incrementata oppure la stessa stringa passata come argomento.
Note
Se viene trovato un carattere non incrementabile passa al successivo e cerca di incrementare quello. Se viene azzerato un carattere perché arrivato all'indice massimo dell'alfabeto, passa al successivo per incrementarlo se non riesce aggiunge un carattere all'inizio della stringa. Es. ("99" - > "100", "-99" -> "1-00"). Lo stesso vale per il decremento.
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.ValuesAreDifferent

Metodo UtilityValuesAreDifferent
Restituisce true se i due valori sono diversi.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool ValuesAreDifferent(
    Object val1,
    Object val2
)
Public Shared Function ValuesAreDifferent (
    val1 As Object,
    val2 As Object
) As Boolean
public:
static bool ValuesAreDifferent(
    Object^ val1,
    Object^ val2
)
static member ValuesAreDifferent :
        val1 : Object *
        val2 : Object -> bool

Parametri

val1 Object
Valore da confrontare.
val2 Object
Valore da confrontare.

Valore di ritorno

Boolean
Restituisce true se i valori sono differenti altrimenti false.
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.VisMsg

Metodo UtilityVisMsg
Lista degli overload
Nome | Descrizione
VisMsg(String) | Visualizza un messaggio semplice con solo il pulsante OK e l'icona Information.
VisMsg(IWin32Window, Exception) | Visualizza la finestra di dialogo per le eccezioni.
VisMsg(IWin32Window, String) | Visualizza un messaggio semplice con solo il pulsante OK e l'icona Information.
VisMsg(IWin32Window, DedNetApplication, ListException) | Visualizza la finestra di dialogo per le liste di eccezioni.
VisMsg(IWin32Window, DedNetApplication, Exception) | Visualizza la finestra di dialogo per le eccezioni.
VisMsg(IWin32Window, Exception, Boolean) | Visualizza la finestra di dialogo per le eccezioni.
VisMsg(IWin32Window, String, MessageBoxIcon) | Visualizza un messaggio semplice con solo il pulsante OK e l'icona specificata.
VisMsg(IWin32Window, String, String, MessageBoxIcon) | Visualizza un messaggio semplice con solo il pulsante OK e l'icona specificata.
VisMsg(IWin32Window, String, MessageBoxButtons, MessageBoxIcon) | Visualizza un messaggio semplice con solo il pulsante OK e l'icona specificata.
VisMsg(IWin32Window, String, String, MessageBoxButtons, MessageBoxIcon) | Visualizza un messaggio semplice con solo il pulsante OK e l'icona specificata.
Torna su
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.VisMsg(String)

Metodo UtilityVisMsg(String)
Visualizza un messaggio semplice con solo il pulsante OK e l'icona Information.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void VisMsg(
    string msg
)
Public Shared Sub VisMsg (
    msg As String
)
public:
static void VisMsg(
    String^ msg
)
static member VisMsg :
        msg : string -> unit

Parametri

msg String
Stringa da visualizzare.
Vedi anche

Documentazione

Classe Utility
Overload di VisMsg
Namespace DedNet.Core


Metodo Utility.VisMsg(IWin32Window, Exception)

Metodo UtilityVisMsg(IWin32Window, Exception)
Visualizza la finestra di dialogo per le eccezioni.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void VisMsg(
    IWin32Window ownerForm,
    Exception ex
)
Public Shared Sub VisMsg (
    ownerForm As IWin32Window,
    ex As Exception
)
public:
static void VisMsg(
    IWin32Window^ ownerForm,
    Exception^ ex
)
static member VisMsg :
        ownerForm : IWin32Window *
        ex : Exception -> unit

Parametri

ownerForm IWin32Window
Parent Form.
ex Exception
Eccezione da visualizzare.
Vedi anche

Documentazione

Classe Utility
Overload di VisMsg
Namespace DedNet.Core


Metodo Utility.VisMsg(IWin32Window, String)

Metodo UtilityVisMsg(IWin32Window, String)
Visualizza un messaggio semplice con solo il pulsante OK e l'icona Information.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void VisMsg(
    IWin32Window ownerForm,
    string msg
)
Public Shared Sub VisMsg (
    ownerForm As IWin32Window,
    msg As String
)
public:
static void VisMsg(
    IWin32Window^ ownerForm,
    String^ msg
)
static member VisMsg :
        ownerForm : IWin32Window *
        msg : string -> unit

Parametri

ownerForm IWin32Window
Parent Form.
msg String
Stringa da visualizzare.
Vedi anche

Documentazione

Classe Utility
Overload di VisMsg
Namespace DedNet.Core


Metodo Utility.VisMsg(IWin32Window, DedNetApplication, List<Exception>)

Metodo UtilityVisMsg(IWin32Window, DedNetApplication, ListException)
Visualizza la finestra di dialogo per le liste di eccezioni.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void VisMsg(
    IWin32Window ownerForm,
    DedNetApplication app,
    List<Exception> exList
)
Public Shared Sub VisMsg (
    ownerForm As IWin32Window,
    app As DedNetApplication,
    exList As List(Of Exception)
)
public:
static void VisMsg(
    IWin32Window^ ownerForm,
    DedNetApplication^ app,
    List<Exception^>^ exList
)
static member VisMsg :
        ownerForm : IWin32Window *
        app : DedNetApplication *
        exList : List<Exception> -> unit

Parametri

ownerForm IWin32Window
Parent Form.
app DedNetApplication
Applicazione di appartenenza.
exList List Exception
Vedi anche

Documentazione

Classe Utility
Overload di VisMsg
Namespace DedNet.Core


Metodo Utility.VisMsg(IWin32Window, DedNetApplication, Exception)

Metodo UtilityVisMsg(IWin32Window, DedNetApplication, Exception)
Visualizza la finestra di dialogo per le eccezioni.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void VisMsg(
    IWin32Window ownerForm,
    DedNetApplication app,
    Exception ex
)
Public Shared Sub VisMsg (
    ownerForm As IWin32Window,
    app As DedNetApplication,
    ex As Exception
)
public:
static void VisMsg(
    IWin32Window^ ownerForm,
    DedNetApplication^ app,
    Exception^ ex
)
static member VisMsg :
        ownerForm : IWin32Window *
        app : DedNetApplication *
        ex : Exception -> unit

Parametri

ownerForm IWin32Window
Parent Form.
app DedNetApplication
Applicazione di appartenenza.
ex Exception
Eccezione da visualizzare.
Vedi anche

Documentazione

Classe Utility
Overload di VisMsg
Namespace DedNet.Core


Metodo Utility.VisMsg(IWin32Window, Exception, Boolean)

Metodo UtilityVisMsg(IWin32Window, Exception, Boolean)
Visualizza la finestra di dialogo per le eccezioni.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void VisMsg(
    IWin32Window ownerForm,
    Exception ex,
    out bool showAgain
)
Public Shared Sub VisMsg (
    ownerForm As IWin32Window,
    ex As Exception,
    <OutAttribute> ByRef showAgain As Boolean
)
public:
static void VisMsg(
    IWin32Window^ ownerForm,
    Exception^ ex,
    [OutAttribute] bool% showAgain
)
static member VisMsg :
        ownerForm : IWin32Window *
        ex : Exception *
        showAgain : bool byref -> unit

Parametri

ownerForm IWin32Window
Parent Form.
ex Exception
Eccezione da visualizzare.
showAgain Boolean
Booleano che indica se l'utente ha spuntato la voce "non visualizzare più".
Vedi anche

Documentazione

Classe Utility
Overload di VisMsg
Namespace DedNet.Core


Metodo Utility.VisMsg(IWin32Window, String, MessageBoxIcon)

Metodo UtilityVisMsg(IWin32Window, String, MessageBoxIcon)
Visualizza un messaggio semplice con solo il pulsante OK e l'icona specificata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void VisMsg(
    IWin32Window ownerForm,
    string msg,
    MessageBoxIcon iconType
)
Public Shared Sub VisMsg (
    ownerForm As IWin32Window,
    msg As String,
    iconType As MessageBoxIcon
)
public:
static void VisMsg(
    IWin32Window^ ownerForm,
    String^ msg,
    MessageBoxIcon iconType
)
static member VisMsg :
        ownerForm : IWin32Window *
        msg : string *
        iconType : MessageBoxIcon -> unit

Parametri

ownerForm IWin32Window
Parent Form.
msg String
Stringa da visualizzare.
iconType MessageBoxIcon
Tipo di icona da utilizzare per il messaggio.
Vedi anche

Documentazione

Classe Utility
Overload di VisMsg
Namespace DedNet.Core


Metodo Utility.VisMsg(IWin32Window, String, String, MessageBoxIcon)

Metodo UtilityVisMsg(IWin32Window, String, String, MessageBoxIcon)
Visualizza un messaggio semplice con solo il pulsante OK e l'icona specificata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void VisMsg(
    IWin32Window ownerForm,
    string title,
    string msg,
    MessageBoxIcon iconType
)
Public Shared Sub VisMsg (
    ownerForm As IWin32Window,
    title As String,
    msg As String,
    iconType As MessageBoxIcon
)
public:
static void VisMsg(
    IWin32Window^ ownerForm,
    String^ title,
    String^ msg,
    MessageBoxIcon iconType
)
static member VisMsg :
        ownerForm : IWin32Window *
        title : string *
        msg : string *
        iconType : MessageBoxIcon -> unit

Parametri

ownerForm IWin32Window
Parent Form.
title String
Titolo della finestra.
msg String
Stringa da visualizzare.
iconType MessageBoxIcon
Tipo di icona da utilizzare per il messaggio.
Vedi anche

Documentazione

Classe Utility
Overload di VisMsg
Namespace DedNet.Core


Metodo Utility.VisMsg(IWin32Window, String, MessageBoxButtons, MessageBoxIcon)

Metodo UtilityVisMsg(IWin32Window, String, MessageBoxButtons, MessageBoxIcon)
Visualizza un messaggio semplice con solo il pulsante OK e l'icona specificata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static DialogResult VisMsg(
    IWin32Window ownerForm,
    string msg,
    MessageBoxButtons buttons,
    MessageBoxIcon iconType
)
Public Shared Function VisMsg (
    ownerForm As IWin32Window,
    msg As String,
    buttons As MessageBoxButtons,
    iconType As MessageBoxIcon
) As DialogResult
public:
static DialogResult VisMsg(
    IWin32Window^ ownerForm,
    String^ msg,
    MessageBoxButtons buttons,
    MessageBoxIcon iconType
)
static member VisMsg :
        ownerForm : IWin32Window *
        msg : string *
        buttons : MessageBoxButtons *
        iconType : MessageBoxIcon -> DialogResult

Parametri

ownerForm IWin32Window
Parent Form.
msg String
Stringa da visualizzare.
buttons MessageBoxButtons
Bottoni da visualizzare nel messaggio.
iconType MessageBoxIcon
Tipo di icona da utilizzare per il messaggio.

Valore di ritorno

DialogResult
Vedi anche

Documentazione

Classe Utility
Overload di VisMsg
Namespace DedNet.Core


Metodo Utility.VisMsg(IWin32Window, String, String, MessageBoxButtons, MessageBoxIcon)

Metodo UtilityVisMsg(IWin32Window, String, String, MessageBoxButtons, MessageBoxIcon)
Visualizza un messaggio semplice con solo il pulsante OK e l'icona specificata.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static DialogResult VisMsg(
    IWin32Window ownerForm,
    string title,
    string msg,
    MessageBoxButtons buttons,
    MessageBoxIcon iconType
)
Public Shared Function VisMsg (
    ownerForm As IWin32Window,
    title As String,
    msg As String,
    buttons As MessageBoxButtons,
    iconType As MessageBoxIcon
) As DialogResult
public:
static DialogResult VisMsg(
    IWin32Window^ ownerForm,
    String^ title,
    String^ msg,
    MessageBoxButtons buttons,
    MessageBoxIcon iconType
)
static member VisMsg :
        ownerForm : IWin32Window *
        title : string *
        msg : string *
        buttons : MessageBoxButtons *
        iconType : MessageBoxIcon -> DialogResult

Parametri

ownerForm IWin32Window
Parent Form.
title String
Titolo della finestra.
msg String
Stringa da visualizzare.
buttons MessageBoxButtons
Bottoni da visualizzare nel messaggio.
iconType MessageBoxIcon
Tipo di icona da utilizzare per il messaggio.

Valore di ritorno

DialogResult
Vedi anche

Documentazione

Classe Utility
Overload di VisMsg
Namespace DedNet.Core


Metodo Utility.Zip

Metodo UtilityZip
Lista degli overload
Nome | Descrizione
Zip(String, String, Boolean, ActionInt32) | Permette di zippare una cartella. Crea un archivio del contenuto della cartella.
Zip(String, String, Boolean, Boolean, ActionInt32) | Permette di zippare un insieme di file.
Torna su
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Metodo Utility.Zip(String, String, Boolean, Action<Int32>)

Metodo UtilityZip(String, String, Boolean, ActionInt32)
Permette di zippare una cartella. Crea un archivio del contenuto della cartella.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void Zip(
    string destFile,
    string sourcePath,
    bool showProgressBar = true,
    Action<int> stepperMethod = null
)
Public Shared Sub Zip (
    destFile As String,
    sourcePath As String,
    Optional showProgressBar As Boolean = true,
    Optional stepperMethod As Action(Of Integer) = Nothing
)
public:
static void Zip(
    String^ destFile,
    String^ sourcePath,
    bool showProgressBar = true,
    Action<int>^ stepperMethod = nullptr
)
static member Zip :
        destFile : string *
        sourcePath : string *
        ?showProgressBar : bool *
        ?stepperMethod : Action<int>
(* Defaults:
        let _showProgressBar = defaultArg showProgressBar true
        let _stepperMethod = defaultArg stepperMethod null
*)
-> unit

Parametri

destFile String
File .zip di destinazione
sourcePath String
Cartella sorgente
showProgressBar Boolean (Optional)
Controlla la visibilità della progressione
stepperMethod Action Int32 (Optional)
Delegate chiamato in fase di iterazione per gestione progressione esterna
Vedi anche

Documentazione

Classe Utility
Overload di Zip
Namespace DedNet.Core


Metodo Utility.Zip(String, String[], Boolean, Boolean, Action<Int32>)

Metodo UtilityZip(String, String, Boolean, Boolean, ActionInt32)
Permette di zippare un insieme di file.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void Zip(
    string destFile,
    string[] files,
    bool showProgressBar = true,
    bool structureFolder = true,
    Action<int> stepperMethod = null
)
Public Shared Sub Zip (
    destFile As String,
    files As String(),
    Optional showProgressBar As Boolean = true,
    Optional structureFolder As Boolean = true,
    Optional stepperMethod As Action(Of Integer) = Nothing
)
public:
static void Zip(
    String^ destFile,
    array<String^>^ files,
    bool showProgressBar = true,
    bool structureFolder = true,
    Action<int>^ stepperMethod = nullptr
)
static member Zip :
        destFile : string *
        files : string[] *
        ?showProgressBar : bool *
        ?structureFolder : bool *
        ?stepperMethod : Action<int>
(* Defaults:
        let _showProgressBar = defaultArg showProgressBar true
        let _structureFolder = defaultArg structureFolder true
        let _stepperMethod = defaultArg stepperMethod null
*)
-> unit

Parametri

destFile String
File .zip di destinazione
files String
Lista di file da archiviare
showProgressBar Boolean (Optional)
Mostra o meno la progressbar
structureFolder Boolean (Optional)
Riporta o meno la struttura delle cartelle
stepperMethod Action Int32 (Optional)
Delegate per la gestione dell'avanzamento
Vedi anche

Documentazione

Classe Utility
Overload di Zip
Namespace DedNet.Core


Metodo Utility.ZipFileCount

Metodo UtilityZipFileCount
Ritorna il numero di elementi contenuti nello zip

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static long ZipFileCount(
    string zippedFile
)
Public Shared Function ZipFileCount (
    zippedFile As String
) As Long
public:
static long long ZipFileCount(
    String^ zippedFile
)
static member ZipFileCount :
        zippedFile : string -> int64

Parametri

zippedFile String
File da esaminare

Valore di ritorno

Int64
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Campi di Utility

Il tipo Utility espone i seguenti membri.

Campi
Nome | Descrizione
ASSPERMCOMMFOLDER | Dizionari utilizzati per le associazioni tra alcuni permessi generici e specifici e viceversa (COMM,FOLDER)
ASSPERMECOFOLDER | Dizionari utilizzati per le associazioni tra alcuni permessi generici e specifici e viceversa (ECO,FOLDER)
ASSPERMFAMFOLDER | Dizionari utilizzati per le associazioni tra alcuni permessi generici e specifici e viceversa (FAM,FOLDER)
ASSPERMFOLDERCOMM | Dizionari utilizzati per le associazioni tra alcuni permessi generici e specifici e viceversa (FOLDER, COMM)
ASSPERMFOLDERECO | Dizionari utilizzati per le associazioni tra alcuni permessi generici e specifici e viceversa (FOLDER, ECO)
ASSPERMFOLDERFAM | Dizionari utilizzati per le associazioni tra alcuni permessi generici e specifici e viceversa (FOLDER, FAM)
DEDCOMM_IDX_NAME | Nome dell'indice sulla colonna COMMNAME nella tabella DED_COMM.
DEFAULT_PERM_DISCRIM | Stringa da utilizzare per indicare che il discriminante del permesso non deve essere preso in considerazione.
ECO_COL | Nome della colonna rappresentante il numero di Eco associati all'anagrafica/commessa. Attenzione! Se si deve cambiare il valore, si deve cambiare anche il nome della property "DedNet.Controls.DedCommAnagExplorer.CommAnagWrapper.NumEcoOnWorking".
FILTER_ECO | Stringa usata nel filtro solo ECO
FILTER_ECO_AND_ECR | Stringa usata nel filtro ECO ed ECR
FILTER_ECR | Stringa usata nel filtro solo ECR
FormToCloseOnOpen | Lista dei nomi dei form che devono essere chiusi dopo l'apertura.
ICON_COL_COLLAPSED_SIZE | Valore larghezza della colonna contenente un'icona quando essa è ristretta.
ICON_COL_EXPANDED_SIZE | Valore larghezza della colonna contenente un'icona quando essa è espansa.
IMPORTED_ATT_NAME | Nome da usare per le liste att che vanno importate da fonti dati esterne tramite evento lua.
ListAttrExcFromProperties | Lista di attributi da escludere durante la lettura delle PROPERTIES
PREVIEW_COL | Nome della colonna preview.
STATEID_COL | Nome della colonna rappresentante il numero di Eco associati all'anagrafica/commessa. Attenzione! Se si deve cambiare il valore, si deve cambiare anche il nome della property "DedNet.Controls.DedCommAnagExplorer.CommAnagWrapper.NumEcoOnWorking".
TableWithIdRevAttr | Lista tabella che contengono gli attributi ID e REV
TableWithIdRevAttrNoDataBom | Lista tabella che contengono gli attributi ID e REV escluse (DED_DATA, DED_DATA_ERASED, DED_BOM)
Torna su
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Campo Utility.ASSPERMCOMMFOLDER

Campo UtilityASSPERMCOMMFOLDER
Dizionari utilizzati per le associazioni tra alcuni permessi generici e specifici e viceversa (COMM,FOLDER)

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static Dictionary<string, string> ASSPERMCOMMFOLDER
Public Shared ASSPERMCOMMFOLDER As Dictionary(Of String, String)
public:
static Dictionary<String^, String^>^ ASSPERMCOMMFOLDER
static val mutable ASSPERMCOMMFOLDER: Dictionary<string, string>

Valore del campo

Dictionary String, String
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Campo Utility.ASSPERMECOFOLDER

Campo UtilityASSPERMECOFOLDER
Dizionari utilizzati per le associazioni tra alcuni permessi generici e specifici e viceversa (ECO,FOLDER)

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static Dictionary<string, string> ASSPERMECOFOLDER
Public Shared ASSPERMECOFOLDER As Dictionary(Of String, String)
public:
static Dictionary<String^, String^>^ ASSPERMECOFOLDER
static val mutable ASSPERMECOFOLDER: Dictionary<string, string>

Valore del campo

Dictionary String, String
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Campo Utility.ASSPERMFAMFOLDER

Campo UtilityASSPERMFAMFOLDER
Dizionari utilizzati per le associazioni tra alcuni permessi generici e specifici e viceversa (FAM,FOLDER)

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static Dictionary<string, string> ASSPERMFAMFOLDER
Public Shared ASSPERMFAMFOLDER As Dictionary(Of String, String)
public:
static Dictionary<String^, String^>^ ASSPERMFAMFOLDER
static val mutable ASSPERMFAMFOLDER: Dictionary<string, string>

Valore del campo

Dictionary String, String
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Campo Utility.ASSPERMFOLDERCOMM

Campo UtilityASSPERMFOLDERCOMM
Dizionari utilizzati per le associazioni tra alcuni permessi generici e specifici e viceversa (FOLDER, COMM)

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static Dictionary<string, string> ASSPERMFOLDERCOMM
Public Shared ASSPERMFOLDERCOMM As Dictionary(Of String, String)
public:
static Dictionary<String^, String^>^ ASSPERMFOLDERCOMM
static val mutable ASSPERMFOLDERCOMM: Dictionary<string, string>

Valore del campo

Dictionary String, String
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Campo Utility.ASSPERMFOLDERECO

Campo UtilityASSPERMFOLDERECO
Dizionari utilizzati per le associazioni tra alcuni permessi generici e specifici e viceversa (FOLDER, ECO)

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static Dictionary<string, string> ASSPERMFOLDERECO
Public Shared ASSPERMFOLDERECO As Dictionary(Of String, String)
public:
static Dictionary<String^, String^>^ ASSPERMFOLDERECO
static val mutable ASSPERMFOLDERECO: Dictionary<string, string>

Valore del campo

Dictionary String, String
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Campo Utility.ASSPERMFOLDERFAM

Campo UtilityASSPERMFOLDERFAM
Dizionari utilizzati per le associazioni tra alcuni permessi generici e specifici e viceversa (FOLDER, FAM)

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static Dictionary<string, string> ASSPERMFOLDERFAM
Public Shared ASSPERMFOLDERFAM As Dictionary(Of String, String)
public:
static Dictionary<String^, String^>^ ASSPERMFOLDERFAM
static val mutable ASSPERMFOLDERFAM: Dictionary<string, string>

Valore del campo

Dictionary String, String
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Campo Utility.DEDCOMM_IDX_NAME

Campo UtilityDEDCOMM_IDX_NAME
Nome dell'indice sulla colonna COMMNAME nella tabella DED_COMM.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string DEDCOMM_IDX_NAME = "DED_COMM_NAME_IDX"
Public Const DEDCOMM_IDX_NAME As String = "DED_COMM_NAME_IDX"
public:
literal String^ DEDCOMM_IDX_NAME = "DED_COMM_NAME_IDX"
static val mutable DEDCOMM_IDX_NAME: string

Valore del campo

String
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Campo Utility.DEFAULT_PERM_DISCRIM

Campo UtilityDEFAULT_PERM_DISCRIM
Stringa da utilizzare per indicare che il discriminante del permesso non deve essere preso in considerazione.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string DEFAULT_PERM_DISCRIM = "*"
Public Const DEFAULT_PERM_DISCRIM As String = "*"
public:
literal String^ DEFAULT_PERM_DISCRIM = "*"
static val mutable DEFAULT_PERM_DISCRIM: string

Valore del campo

String
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Campo Utility.ECO_COL

Campo UtilityECO_COL
Nome della colonna rappresentante il numero di Eco associati all'anagrafica/commessa. Attenzione! Se si deve cambiare il valore, si deve cambiare anche il nome della property "DedNet.Controls.DedCommAnagExplorer.CommAnagWrapper.NumEcoOnWorking".

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string ECO_COL = "NumEcoOnWorking"
Public Const ECO_COL As String = "NumEcoOnWorking"
public:
literal String^ ECO_COL = "NumEcoOnWorking"
static val mutable ECO_COL: string

Valore del campo

String
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Campo Utility.FILTER_ECO

Campo UtilityFILTER_ECO
Stringa usata nel filtro solo ECO

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string FILTER_ECO = "[NumEcoOnWorking] Is Not Null Or [NumEcoOnWorking] = 'ECO'"
Public Const FILTER_ECO As String = "[NumEcoOnWorking] Is Not Null Or [NumEcoOnWorking] = 'ECO'"
public:
literal String^ FILTER_ECO = "[NumEcoOnWorking] Is Not Null Or [NumEcoOnWorking] = 'ECO'"
static val mutable FILTER_ECO: string

Valore del campo

String
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Campo Utility.FILTER_ECO_AND_ECR

Campo UtilityFILTER_ECO_AND_ECR
Stringa usata nel filtro ECO ed ECR

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string FILTER_ECO_AND_ECR = "[NumEcoOnWorking] Is Not Null"
Public Const FILTER_ECO_AND_ECR As String = "[NumEcoOnWorking] Is Not Null"
public:
literal String^ FILTER_ECO_AND_ECR = "[NumEcoOnWorking] Is Not Null"
static val mutable FILTER_ECO_AND_ECR: string

Valore del campo

String
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Campo Utility.FILTER_ECR

Campo UtilityFILTER_ECR
Stringa usata nel filtro solo ECR

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string FILTER_ECR = "[NumEcoOnWorking] Is Not Null Or [NumEcoOnWorking] = 'ECR'"
Public Const FILTER_ECR As String = "[NumEcoOnWorking] Is Not Null Or [NumEcoOnWorking] = 'ECR'"
public:
literal String^ FILTER_ECR = "[NumEcoOnWorking] Is Not Null Or [NumEcoOnWorking] = 'ECR'"
static val mutable FILTER_ECR: string

Valore del campo

String
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Campo Utility.FormToCloseOnOpen

Campo UtilityFormToCloseOnOpen
Lista dei nomi dei form che devono essere chiusi dopo l'apertura.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static List<string> FormToCloseOnOpen
Public Shared FormToCloseOnOpen As List(Of String)
public:
static List<String^>^ FormToCloseOnOpen
static val mutable FormToCloseOnOpen: List<string>

Valore del campo

List String
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Campo Utility.ICON_COL_COLLAPSED_SIZE

Campo UtilityICON_COL_COLLAPSED_SIZE
Valore larghezza della colonna contenente un'icona quando essa è ristretta.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const int ICON_COL_COLLAPSED_SIZE = 24
Public Const ICON_COL_COLLAPSED_SIZE As Integer = 24
public:
literal int ICON_COL_COLLAPSED_SIZE = 24
static val mutable ICON_COL_COLLAPSED_SIZE: int

Valore del campo

Int32
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Campo Utility.ICON_COL_EXPANDED_SIZE

Campo UtilityICON_COL_EXPANDED_SIZE
Valore larghezza della colonna contenente un'icona quando essa è espansa.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const int ICON_COL_EXPANDED_SIZE = 57
Public Const ICON_COL_EXPANDED_SIZE As Integer = 57
public:
literal int ICON_COL_EXPANDED_SIZE = 57
static val mutable ICON_COL_EXPANDED_SIZE: int

Valore del campo

Int32
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Campo Utility.IMPORTED_ATT_NAME

Campo UtilityIMPORTED_ATT_NAME
Nome da usare per le liste att che vanno importate da fonti dati esterne tramite evento lua.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string IMPORTED_ATT_NAME = "%CALCOLATA%"
Public Const IMPORTED_ATT_NAME As String = "%CALCOLATA%"
public:
literal String^ IMPORTED_ATT_NAME = "%CALCOLATA%"
static val mutable IMPORTED_ATT_NAME: string

Valore del campo

String
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Campo Utility.ListAttrExcFromProperties

Campo UtilityListAttrExcFromProperties
Lista di attributi da escludere durante la lettura delle PROPERTIES

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static List<string> ListAttrExcFromProperties
Public Shared ListAttrExcFromProperties As List(Of String)
public:
static List<String^>^ ListAttrExcFromProperties
static val mutable ListAttrExcFromProperties: List<string>

Valore del campo

List String
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Campo Utility.PREVIEW_COL

Campo UtilityPREVIEW_COL
Nome della colonna preview.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string PREVIEW_COL = "DOC_PREVIEW"
Public Const PREVIEW_COL As String = "DOC_PREVIEW"
public:
literal String^ PREVIEW_COL = "DOC_PREVIEW"
static val mutable PREVIEW_COL: string

Valore del campo

String
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Campo Utility.STATEID_COL

Campo UtilitySTATEID_COL
Nome della colonna rappresentante il numero di Eco associati all'anagrafica/commessa. Attenzione! Se si deve cambiare il valore, si deve cambiare anche il nome della property "DedNet.Controls.DedCommAnagExplorer.CommAnagWrapper.NumEcoOnWorking".

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string STATEID_COL = "DedDataStateId"
Public Const STATEID_COL As String = "DedDataStateId"
public:
literal String^ STATEID_COL = "DedDataStateId"
static val mutable STATEID_COL: string

Valore del campo

String
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Campo Utility.TableWithIdRevAttr

Campo UtilityTableWithIdRevAttr
Lista tabella che contengono gli attributi ID e REV

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static List<string> TableWithIdRevAttr
Public Shared TableWithIdRevAttr As List(Of String)
public:
static List<String^>^ TableWithIdRevAttr
static val mutable TableWithIdRevAttr: List<string>

Valore del campo

List String
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Campo Utility.TableWithIdRevAttrNoDataBom

Campo UtilityTableWithIdRevAttrNoDataBom
Lista tabella che contengono gli attributi ID e REV escluse (DED_DATA, DED_DATA_ERASED, DED_BOM)

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static List<string> TableWithIdRevAttrNoDataBom
Public Shared TableWithIdRevAttrNoDataBom As List(Of String)
public:
static List<String^>^ TableWithIdRevAttrNoDataBom
static val mutable TableWithIdRevAttrNoDataBom: List<string>

Valore del campo

List String
Vedi anche

Documentazione

Classe Utility
Namespace DedNet.Core


Classe Utility.TreeListViewState

Classe UtilityTreeListViewState
Classe gestione stati dell'albero
Gerarchia di ereditarietà
SystemObject
DedNet.CoreUtilityTreeListViewState

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class TreeListViewState
Public Class TreeListViewState
public ref class TreeListViewState
type TreeListViewState = class end

Il tipo UtilityTreeListViewState espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | UtilityTreeListViewState | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | TreeList |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Clear | Metodo di reset della classe
 | ClearSelectionOnSxClick | Ripulisce la selezione dei nodi all'interno del TreeList passato in ingresso sulla pressione del tasto sx del mouse.
Metodo pubblico | LoadState | Metodo pubblico per ricaricare lo stato salvato
Metodo pubblico | SaveState | Metodo di salvataggio dello stato
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core


Costruttore Utility.TreeListViewState

Costruttore UtilityTreeListViewState
Costruttore

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public TreeListViewState(
    TreeList treeList,
    List<string> ReferenceFieldName
)
Public Sub New (
    treeList As TreeList,
    ReferenceFieldName As List(Of String)
)
public:
TreeListViewState(
    TreeList^ treeList,
    List<String^>^ ReferenceFieldName
)
new :
        treeList : TreeList *
        ReferenceFieldName : List<string> -> TreeListViewState

Parametri

treeList TreeList
Oggestto treelist
ReferenceFieldName List String
Campo di riferimenti per i confronti fra i nodi
Vedi anche

Documentazione

Classe UtilityTreeListViewState
Namespace DedNet.Core


Proprietà di TreeListViewState

Il tipo UtilityTreeListViewState espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | TreeList |
Torna su
Vedi anche

Documentazione

Classe UtilityTreeListViewState
Namespace DedNet.Core


Proprietà Utility.TreeListViewState.TreeList

Proprietà UtilityTreeListViewStateTreeList

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public TreeList TreeList { get; set; }
Public Property TreeList As TreeList
    Get
    Set
public:
property TreeList^ TreeList {
    TreeList^ get ();
    void set (TreeList^ value);
}
member TreeList : TreeList with get, set

Valore della proprietà

TreeList
Vedi anche

Documentazione

Classe UtilityTreeListViewState
Namespace DedNet.Core


Metodi di TreeListViewState

Il tipo UtilityTreeListViewState espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Clear | Metodo di reset della classe
 | ClearSelectionOnSxClick | Ripulisce la selezione dei nodi all'interno del TreeList passato in ingresso sulla pressione del tasto sx del mouse.
Metodo pubblico | LoadState | Metodo pubblico per ricaricare lo stato salvato
Metodo pubblico | SaveState | Metodo di salvataggio dello stato
Torna su
Vedi anche

Documentazione

Classe UtilityTreeListViewState
Namespace DedNet.Core


Metodo Utility.TreeListViewState.Clear

Metodo UtilityTreeListViewStateClear
Metodo di reset della classe

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
Vedi anche

Documentazione

Classe UtilityTreeListViewState
Namespace DedNet.Core


Metodo Utility.TreeListViewState.ClearSelectionOnSxClick

Metodo UtilityTreeListViewStateClearSelectionOnSxClick
Ripulisce la selezione dei nodi all'interno del TreeList passato in ingresso sulla pressione del tasto sx del mouse.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void ClearSelectionOnSxClick(
    TreeList ctrTree,
    MouseEventArgs e
)
Public Shared Sub ClearSelectionOnSxClick (
    ctrTree As TreeList,
    e As MouseEventArgs
)
public:
static void ClearSelectionOnSxClick(
    TreeList^ ctrTree,
    MouseEventArgs^ e
)
static member ClearSelectionOnSxClick :
        ctrTree : TreeList *
        e : MouseEventArgs -> unit

Parametri

ctrTree TreeList
Oggetto TreeList su cui eseguire l'operazione.
e MouseEventArgs
Evento MouseEventArgs che è stato generato.
Vedi anche

Documentazione

Classe UtilityTreeListViewState
Namespace DedNet.Core


Metodo Utility.TreeListViewState.LoadState

Metodo UtilityTreeListViewStateLoadState
Metodo pubblico per ricaricare lo stato salvato

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void LoadState(
    bool changeSelected = false
)
Public Sub LoadState (
    Optional changeSelected As Boolean = false
)
public:
void LoadState(
    bool changeSelected = false
)
member LoadState :
        ?changeSelected : bool
(* Defaults:
        let _changeSelected = defaultArg changeSelected false
*)
-> unit

Parametri

changeSelected Boolean (Optional)
Indica che si vuole risalvare la selezione dei nodi. Di Default è a False
Vedi anche

Documentazione

Classe UtilityTreeListViewState
Namespace DedNet.Core


Metodo Utility.TreeListViewState.SaveState

Metodo UtilityTreeListViewStateSaveState
Metodo di salvataggio dello stato

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SaveState()
Public Sub SaveState
public:
void SaveState()
member SaveState : unit -> unit
Vedi anche

Documentazione

Classe UtilityTreeListViewState
Namespace DedNet.Core


Enumerazione ValidatorOperator
Lista delle tipologie dei range di controllo.

Namespace: DedNet.Core
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum ValidatorOperator
Public Enumeration ValidatorOperator
public enum class ValidatorOperator
type ValidatorOperator
Membri
Nome | Valore | Descrizione
Nessuno | 0 |
MaggioreDi | 1 |
MinoreDi | 2 |
MaggioreUgualeA | 3 |
MinoreUgualeA | 4 |
CompresoTra | 5 |
EsclusoDa | 6 |
DiversoDa | 7 |
Vedi anche

Documentazione

Namespace DedNet.Core


DedNet.Core.Help Namespace
Strutture
 | Struttura | Descrizione
Struttura pubblica | Topic | Riporta l'elenco dei Topic contenuti all'interno del manuale.


Struttura Topic
Riporta l'elenco dei Topic contenuti all'interno del manuale.
Gerarchia di ereditarietà
SystemObject
SystemValueType
DedNet.Core.HelpTopic

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public struct Topic
Public Structure Topic
public value class Topic
[<SealedAttribute>]
type Topic =
    struct
        inherit ValueType
    end

Il tipo Topic espone i seguenti membri.

Campi
Nome | Descrizione
AGGIORNA_STATO_ALBERO_DED | Capitolo: Aggiorna Stato Albero DED.
ANNULLA_CHECKOUT | Capitolo: Annulla CheckOut.
APRI_IN_LETTURA | Capitolo: Apri In Lettura.
APRI_IN_MODIFICA | Capitolo: Apri In Modifica.
APRI_NUOVA_RICERCA | Capitolo: Apri nuova ricerca.
ARCHIVIA_DOCUMENTO | Capitolo: ARchivia Documento.
ARCHIVIA_PARTE | Capitolo: Archivia Parte.
AREA_LOCALE | Capitolo: Area Locale.
ASSEGNAZIONE_PROGRESSIVI | Capitolo: Assegnazione Progressivi.
ASSOCIA_DOCUMENTO | Capitolo: Associa Documento.
ASSOCIA_PARTE | Capitolo: Associa Parte.
ATTRIBUTI | Capitolo: Attributi (Famiglie e Attributi/Schede).
ATTRIBUTI_2D | Capitolo: Attributi 2D.
CAD2D | Capitolo: Comandi CAD 2D.
CAMBIA_PASSWORD | Capitolo: Cambia Password.
CAMBIA_STATO | Capitolo: Cambia Stato.
CAMBIA_STATO_MULTIPLO | Capitolo: Cambia Stato Multiplo.
CERCA_REVISIONI_SUPERATE | Capitolo: Cerca Revisioni Superate.
CHECKIN | Capitolo: CheckIn.
CHECKOUT | Capitolo: CheckOut.
CODICI_ALTERNATIVI | Capitolo: Codici Alternativi
CONFIGURATORE_DISTINTE | Capitolo: Configuratore Distinte.
DISTINTA_COMPONENTI | Capitolo: Distinta Componenti.
DISTINTA_ESPLOSA | Capitolo: Distinta Esplosa.
DISTINTA_IMPLOSA | Capitolo: Distinta Implosa.
EDITA_DISTINTA | Capitolo: Edita Distinta.
EDITOR_MOVED | Capitolo: Editor moved.
ESPORTA_QS_PACKGO | Capitolo: Esporta PackGo.
GESTIONE_CASCATE | Capitolo: Gestione attributi a cascata
GESTIONE_CATEGORIE | Capitolo: Gestione categorie
GESTIONE_STATI | Capitolo: Gestione Stati.
GESTORE_COMMESSE | Capitolo: Gestore Commesse.
GESTORE_ECO | Capitolo: Gestore ECO.
GESTORE_FILE_DI_PUBBLICAZIONE | Capitolo: Gestore File Di Pubblicazione.
GESTORE_NOTIFICHE | Capitolo: Gestore Notifiche.
GESTORE_TRADUZIONI | Capitolo: Gestore Traduzioni.
HELP | Capitolo: Help.
HOMEPAGE | Capitolo: Home page.
IMPORTA_DATI | Capitolo: Importa Dati
IMPORTA_QS_PACKGO | Capitolo: Importa PackGo.
INFORMAZIONI | Capitolo: Informazioni.
INIZIA_PARTE_VELOCE | Capitolo: Inizia Parte Veloce.
INTRODUCTION | Capitolo: Introduzione.
INTRODUZIONE | Capitolo: Introduzione.
LAVORAZIONE | Capitolo: Lavorazione.
LAVORAZIONE_MULTIPLO | Capitolo: Lavorazione Multiplo.
MODIFICA_SUPERATO | Capitolo: Modifica Superato.
MOSTRA_ALBERO_DED | Capitolo: Mostra Albero DED.
PUBBLICA | Capitolo: Pubblica.
QSMANAGER | Capitolo: QsManager (Famiglie e Attributi).
REGISTRA_DOCUMENTI | Capitolo: Registra Documenti.
REGISTRA_DOCUMENTO | Capitolo: Registra Documento.
RICERCA | Capitolo: Dialogo della ricerca.
RICERCA_DOCUMENTI | Capitolo: Ricerca documi.
RILASCIO | Capitolo: Rilascio.
RILASCIO_MULTIPLO | Capitolo: Rilascio Multiplo.
SALVA_DED | Capitolo: Salva DeD.
SALVA_DISTINTA | Capitolo: Salva Distinta.
SALVA_MULTIPLO | Capitolo: Salva Multiplo.
SALVA_PARTE | Capitolo: Salva Parte.
SALVA_PARTE_VARIANTE | Capitolo: Cambia Parte Variante.
SALVA_REVISIONE | Capitolo: Salva Revisione.
SALVA_SUPERATO | Capitolo: Modifica Superato.
SALVA_VARIANTE | Capitolo: Cambia Variante.
SBLOCCA | Capitolo: Sblocca.
STATO_DOCUMENTO | Capitolo: Stato Documento.
TEMPORIZZAZIONI | Capitolo: Temporizzazioni
UTENTE_PERMESSI | Capitolo: Utenti e Permessi.
VARIABILI | Capitolo: Variabili del DED+.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Core.Help


Campi di Topic

Il tipo Topic espone i seguenti membri.

Campi
Nome | Descrizione
AGGIORNA_STATO_ALBERO_DED | Capitolo: Aggiorna Stato Albero DED.
ANNULLA_CHECKOUT | Capitolo: Annulla CheckOut.
APRI_IN_LETTURA | Capitolo: Apri In Lettura.
APRI_IN_MODIFICA | Capitolo: Apri In Modifica.
APRI_NUOVA_RICERCA | Capitolo: Apri nuova ricerca.
ARCHIVIA_DOCUMENTO | Capitolo: ARchivia Documento.
ARCHIVIA_PARTE | Capitolo: Archivia Parte.
AREA_LOCALE | Capitolo: Area Locale.
ASSEGNAZIONE_PROGRESSIVI | Capitolo: Assegnazione Progressivi.
ASSOCIA_DOCUMENTO | Capitolo: Associa Documento.
ASSOCIA_PARTE | Capitolo: Associa Parte.
ATTRIBUTI | Capitolo: Attributi (Famiglie e Attributi/Schede).
ATTRIBUTI_2D | Capitolo: Attributi 2D.
CAD2D | Capitolo: Comandi CAD 2D.
CAMBIA_PASSWORD | Capitolo: Cambia Password.
CAMBIA_STATO | Capitolo: Cambia Stato.
CAMBIA_STATO_MULTIPLO | Capitolo: Cambia Stato Multiplo.
CERCA_REVISIONI_SUPERATE | Capitolo: Cerca Revisioni Superate.
CHECKIN | Capitolo: CheckIn.
CHECKOUT | Capitolo: CheckOut.
CODICI_ALTERNATIVI | Capitolo: Codici Alternativi
CONFIGURATORE_DISTINTE | Capitolo: Configuratore Distinte.
DISTINTA_COMPONENTI | Capitolo: Distinta Componenti.
DISTINTA_ESPLOSA | Capitolo: Distinta Esplosa.
DISTINTA_IMPLOSA | Capitolo: Distinta Implosa.
EDITA_DISTINTA | Capitolo: Edita Distinta.
EDITOR_MOVED | Capitolo: Editor moved.
ESPORTA_QS_PACKGO | Capitolo: Esporta PackGo.
GESTIONE_CASCATE | Capitolo: Gestione attributi a cascata
GESTIONE_CATEGORIE | Capitolo: Gestione categorie
GESTIONE_STATI | Capitolo: Gestione Stati.
GESTORE_COMMESSE | Capitolo: Gestore Commesse.
GESTORE_ECO | Capitolo: Gestore ECO.
GESTORE_FILE_DI_PUBBLICAZIONE | Capitolo: Gestore File Di Pubblicazione.
GESTORE_NOTIFICHE | Capitolo: Gestore Notifiche.
GESTORE_TRADUZIONI | Capitolo: Gestore Traduzioni.
HELP | Capitolo: Help.
HOMEPAGE | Capitolo: Home page.
IMPORTA_DATI | Capitolo: Importa Dati
IMPORTA_QS_PACKGO | Capitolo: Importa PackGo.
INFORMAZIONI | Capitolo: Informazioni.
INIZIA_PARTE_VELOCE | Capitolo: Inizia Parte Veloce.
INTRODUCTION | Capitolo: Introduzione.
INTRODUZIONE | Capitolo: Introduzione.
LAVORAZIONE | Capitolo: Lavorazione.
LAVORAZIONE_MULTIPLO | Capitolo: Lavorazione Multiplo.
MODIFICA_SUPERATO | Capitolo: Modifica Superato.
MOSTRA_ALBERO_DED | Capitolo: Mostra Albero DED.
PUBBLICA | Capitolo: Pubblica.
QSMANAGER | Capitolo: QsManager (Famiglie e Attributi).
REGISTRA_DOCUMENTI | Capitolo: Registra Documenti.
REGISTRA_DOCUMENTO | Capitolo: Registra Documento.
RICERCA | Capitolo: Dialogo della ricerca.
RICERCA_DOCUMENTI | Capitolo: Ricerca documi.
RILASCIO | Capitolo: Rilascio.
RILASCIO_MULTIPLO | Capitolo: Rilascio Multiplo.
SALVA_DED | Capitolo: Salva DeD.
SALVA_DISTINTA | Capitolo: Salva Distinta.
SALVA_MULTIPLO | Capitolo: Salva Multiplo.
SALVA_PARTE | Capitolo: Salva Parte.
SALVA_PARTE_VARIANTE | Capitolo: Cambia Parte Variante.
SALVA_REVISIONE | Capitolo: Salva Revisione.
SALVA_SUPERATO | Capitolo: Modifica Superato.
SALVA_VARIANTE | Capitolo: Cambia Variante.
SBLOCCA | Capitolo: Sblocca.
STATO_DOCUMENTO | Capitolo: Stato Documento.
TEMPORIZZAZIONI | Capitolo: Temporizzazioni
UTENTE_PERMESSI | Capitolo: Utenti e Permessi.
VARIABILI | Capitolo: Variabili del DED+.
Torna su
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.AGGIORNA_STATO_ALBERO_DED

Campo TopicAGGIORNA_STATO_ALBERO_DED
Capitolo: Aggiorna Stato Albero DED.

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string AGGIORNA_STATO_ALBERO_DED = "AggiornaStatoAlberoDeD"
Public Const AGGIORNA_STATO_ALBERO_DED As String = "AggiornaStatoAlberoDeD"
public:
literal String^ AGGIORNA_STATO_ALBERO_DED = "AggiornaStatoAlberoDeD"
static val mutable AGGIORNA_STATO_ALBERO_DED: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.ANNULLA_CHECKOUT

Campo TopicANNULLA_CHECKOUT
Capitolo: Annulla CheckOut.

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string ANNULLA_CHECKOUT = "AnnullaCheckOut"
Public Const ANNULLA_CHECKOUT As String = "AnnullaCheckOut"
public:
literal String^ ANNULLA_CHECKOUT = "AnnullaCheckOut"
static val mutable ANNULLA_CHECKOUT: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.APRI_IN_LETTURA

Campo TopicAPRI_IN_LETTURA
Capitolo: Apri In Lettura.

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string APRI_IN_LETTURA = "ApriInLettura"
Public Const APRI_IN_LETTURA As String = "ApriInLettura"
public:
literal String^ APRI_IN_LETTURA = "ApriInLettura"
static val mutable APRI_IN_LETTURA: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.APRI_IN_MODIFICA

Campo TopicAPRI_IN_MODIFICA
Capitolo: Apri In Modifica.

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string APRI_IN_MODIFICA = "ApriInModifica"
Public Const APRI_IN_MODIFICA As String = "ApriInModifica"
public:
literal String^ APRI_IN_MODIFICA = "ApriInModifica"
static val mutable APRI_IN_MODIFICA: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.APRI_NUOVA_RICERCA

Campo TopicAPRI_NUOVA_RICERCA
Capitolo: Apri nuova ricerca.

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string APRI_NUOVA_RICERCA = "ApriNuovaRicerca"
Public Const APRI_NUOVA_RICERCA As String = "ApriNuovaRicerca"
public:
literal String^ APRI_NUOVA_RICERCA = "ApriNuovaRicerca"
static val mutable APRI_NUOVA_RICERCA: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.ARCHIVIA_DOCUMENTO

Campo TopicARCHIVIA_DOCUMENTO
Capitolo: ARchivia Documento.

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string ARCHIVIA_DOCUMENTO = "ArchiviaDocumento"
Public Const ARCHIVIA_DOCUMENTO As String = "ArchiviaDocumento"
public:
literal String^ ARCHIVIA_DOCUMENTO = "ArchiviaDocumento"
static val mutable ARCHIVIA_DOCUMENTO: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.ARCHIVIA_PARTE

Campo TopicARCHIVIA_PARTE
Capitolo: Archivia Parte.

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string ARCHIVIA_PARTE = "ArchiviaParte"
Public Const ARCHIVIA_PARTE As String = "ArchiviaParte"
public:
literal String^ ARCHIVIA_PARTE = "ArchiviaParte"
static val mutable ARCHIVIA_PARTE: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.AREA_LOCALE

Campo TopicAREA_LOCALE
Capitolo: Area Locale.

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string AREA_LOCALE = "AreaLocale"
Public Const AREA_LOCALE As String = "AreaLocale"
public:
literal String^ AREA_LOCALE = "AreaLocale"
static val mutable AREA_LOCALE: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.ASSEGNAZIONE_PROGRESSIVI

Campo TopicASSEGNAZIONE_PROGRESSIVI
Capitolo: Assegnazione Progressivi.

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string ASSEGNAZIONE_PROGRESSIVI = "AssegnazioneProgressivi"
Public Const ASSEGNAZIONE_PROGRESSIVI As String = "AssegnazioneProgressivi"
public:
literal String^ ASSEGNAZIONE_PROGRESSIVI = "AssegnazioneProgressivi"
static val mutable ASSEGNAZIONE_PROGRESSIVI: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.ASSOCIA_DOCUMENTO

Campo TopicASSOCIA_DOCUMENTO
Capitolo: Associa Documento.

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string ASSOCIA_DOCUMENTO = "AssociaDocumento"
Public Const ASSOCIA_DOCUMENTO As String = "AssociaDocumento"
public:
literal String^ ASSOCIA_DOCUMENTO = "AssociaDocumento"
static val mutable ASSOCIA_DOCUMENTO: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.ASSOCIA_PARTE

Campo TopicASSOCIA_PARTE
Capitolo: Associa Parte.

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string ASSOCIA_PARTE = "AssociaParte"
Public Const ASSOCIA_PARTE As String = "AssociaParte"
public:
literal String^ ASSOCIA_PARTE = "AssociaParte"
static val mutable ASSOCIA_PARTE: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.ATTRIBUTI

Campo TopicATTRIBUTI
Capitolo: Attributi (Famiglie e Attributi/Schede).

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string ATTRIBUTI = "Attributi"
Public Const ATTRIBUTI As String = "Attributi"
public:
literal String^ ATTRIBUTI = "Attributi"
static val mutable ATTRIBUTI: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.ATTRIBUTI_2D

Campo TopicATTRIBUTI_2D
Capitolo: Attributi 2D.

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string ATTRIBUTI_2D = "Attributi2D"
Public Const ATTRIBUTI_2D As String = "Attributi2D"
public:
literal String^ ATTRIBUTI_2D = "Attributi2D"
static val mutable ATTRIBUTI_2D: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.CAD2D

Campo TopicCAD2D
Capitolo: Comandi CAD 2D.

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string CAD2D = "Cad2DCommand"
Public Const CAD2D As String = "Cad2DCommand"
public:
literal String^ CAD2D = "Cad2DCommand"
static val mutable CAD2D: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.CAMBIA_PASSWORD

Campo TopicCAMBIA_PASSWORD
Capitolo: Cambia Password.

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string CAMBIA_PASSWORD = "CambiaPassword"
Public Const CAMBIA_PASSWORD As String = "CambiaPassword"
public:
literal String^ CAMBIA_PASSWORD = "CambiaPassword"
static val mutable CAMBIA_PASSWORD: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.CAMBIA_STATO

Campo TopicCAMBIA_STATO
Capitolo: Cambia Stato.

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string CAMBIA_STATO = "CambiaStato"
Public Const CAMBIA_STATO As String = "CambiaStato"
public:
literal String^ CAMBIA_STATO = "CambiaStato"
static val mutable CAMBIA_STATO: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.CAMBIA_STATO_MULTIPLO

Campo TopicCAMBIA_STATO_MULTIPLO
Capitolo: Cambia Stato Multiplo.

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string CAMBIA_STATO_MULTIPLO = "CambiaStatoMultiplo"
Public Const CAMBIA_STATO_MULTIPLO As String = "CambiaStatoMultiplo"
public:
literal String^ CAMBIA_STATO_MULTIPLO = "CambiaStatoMultiplo"
static val mutable CAMBIA_STATO_MULTIPLO: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.CERCA_REVISIONI_SUPERATE

Campo TopicCERCA_REVISIONI_SUPERATE
Capitolo: Cerca Revisioni Superate.

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string CERCA_REVISIONI_SUPERATE = "CercaRevisioniSuperate"
Public Const CERCA_REVISIONI_SUPERATE As String = "CercaRevisioniSuperate"
public:
literal String^ CERCA_REVISIONI_SUPERATE = "CercaRevisioniSuperate"
static val mutable CERCA_REVISIONI_SUPERATE: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.CHECKIN

Campo TopicCHECKIN
Capitolo: CheckIn.

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string CHECKIN = "CheckInCommand"
Public Const CHECKIN As String = "CheckInCommand"
public:
literal String^ CHECKIN = "CheckInCommand"
static val mutable CHECKIN: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.CHECKOUT

Campo TopicCHECKOUT
Capitolo: CheckOut.

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string CHECKOUT = "CheckOutCommand"
Public Const CHECKOUT As String = "CheckOutCommand"
public:
literal String^ CHECKOUT = "CheckOutCommand"
static val mutable CHECKOUT: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.CODICI_ALTERNATIVI

Campo TopicCODICI_ALTERNATIVI
Capitolo: Codici Alternativi

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string CODICI_ALTERNATIVI = "CodiciAlternativi"
Public Const CODICI_ALTERNATIVI As String = "CodiciAlternativi"
public:
literal String^ CODICI_ALTERNATIVI = "CodiciAlternativi"
static val mutable CODICI_ALTERNATIVI: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.CONFIGURATORE_DISTINTE

Campo TopicCONFIGURATORE_DISTINTE
Capitolo: Configuratore Distinte.

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string CONFIGURATORE_DISTINTE = "ConfiguratoreDistinte"
Public Const CONFIGURATORE_DISTINTE As String = "ConfiguratoreDistinte"
public:
literal String^ CONFIGURATORE_DISTINTE = "ConfiguratoreDistinte"
static val mutable CONFIGURATORE_DISTINTE: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.DISTINTA_COMPONENTI

Campo TopicDISTINTA_COMPONENTI
Capitolo: Distinta Componenti.

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string DISTINTA_COMPONENTI = "DistintaComponenti"
Public Const DISTINTA_COMPONENTI As String = "DistintaComponenti"
public:
literal String^ DISTINTA_COMPONENTI = "DistintaComponenti"
static val mutable DISTINTA_COMPONENTI: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.DISTINTA_ESPLOSA

Campo TopicDISTINTA_ESPLOSA
Capitolo: Distinta Esplosa.

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string DISTINTA_ESPLOSA = "DistintaEsplosa"
Public Const DISTINTA_ESPLOSA As String = "DistintaEsplosa"
public:
literal String^ DISTINTA_ESPLOSA = "DistintaEsplosa"
static val mutable DISTINTA_ESPLOSA: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.DISTINTA_IMPLOSA

Campo TopicDISTINTA_IMPLOSA
Capitolo: Distinta Implosa.

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string DISTINTA_IMPLOSA = "DistintaImplosa"
Public Const DISTINTA_IMPLOSA As String = "DistintaImplosa"
public:
literal String^ DISTINTA_IMPLOSA = "DistintaImplosa"
static val mutable DISTINTA_IMPLOSA: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.EDITA_DISTINTA

Campo TopicEDITA_DISTINTA
Capitolo: Edita Distinta.

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string EDITA_DISTINTA = "EditaDistinta"
Public Const EDITA_DISTINTA As String = "EditaDistinta"
public:
literal String^ EDITA_DISTINTA = "EditaDistinta"
static val mutable EDITA_DISTINTA: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.EDITOR_MOVED

Campo TopicEDITOR_MOVED
Capitolo: Editor moved.

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string EDITOR_MOVED = "EditorMoved"
Public Const EDITOR_MOVED As String = "EditorMoved"
public:
literal String^ EDITOR_MOVED = "EditorMoved"
static val mutable EDITOR_MOVED: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.ESPORTA_QS_PACKGO

Campo TopicESPORTA_QS_PACKGO
Capitolo: Esporta PackGo.

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string ESPORTA_QS_PACKGO = "EsportaQsPackGo"
Public Const ESPORTA_QS_PACKGO As String = "EsportaQsPackGo"
public:
literal String^ ESPORTA_QS_PACKGO = "EsportaQsPackGo"
static val mutable ESPORTA_QS_PACKGO: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.GESTIONE_CASCATE

Campo TopicGESTIONE_CASCATE
Capitolo: Gestione attributi a cascata

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string GESTIONE_CASCATE = "Gestioneattributiacascata"
Public Const GESTIONE_CASCATE As String = "Gestioneattributiacascata"
public:
literal String^ GESTIONE_CASCATE = "Gestioneattributiacascata"
static val mutable GESTIONE_CASCATE: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.GESTIONE_CATEGORIE

Campo TopicGESTIONE_CATEGORIE
Capitolo: Gestione categorie

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string GESTIONE_CATEGORIE = "Gestionecategorie"
Public Const GESTIONE_CATEGORIE As String = "Gestionecategorie"
public:
literal String^ GESTIONE_CATEGORIE = "Gestionecategorie"
static val mutable GESTIONE_CATEGORIE: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.GESTIONE_STATI

Campo TopicGESTIONE_STATI
Capitolo: Gestione Stati.

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string GESTIONE_STATI = "GestioneStati"
Public Const GESTIONE_STATI As String = "GestioneStati"
public:
literal String^ GESTIONE_STATI = "GestioneStati"
static val mutable GESTIONE_STATI: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.GESTORE_COMMESSE

Campo TopicGESTORE_COMMESSE
Capitolo: Gestore Commesse.

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string GESTORE_COMMESSE = "GestoreCommesse"
Public Const GESTORE_COMMESSE As String = "GestoreCommesse"
public:
literal String^ GESTORE_COMMESSE = "GestoreCommesse"
static val mutable GESTORE_COMMESSE: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.GESTORE_ECO

Campo TopicGESTORE_ECO
Capitolo: Gestore ECO.

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string GESTORE_ECO = "ECO"
Public Const GESTORE_ECO As String = "ECO"
public:
literal String^ GESTORE_ECO = "ECO"
static val mutable GESTORE_ECO: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.GESTORE_FILE_DI_PUBBLICAZIONE

Campo TopicGESTORE_FILE_DI_PUBBLICAZIONE
Capitolo: Gestore File Di Pubblicazione.

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string GESTORE_FILE_DI_PUBBLICAZIONE = "GestoreFileDiPubblicazione"
Public Const GESTORE_FILE_DI_PUBBLICAZIONE As String = "GestoreFileDiPubblicazione"
public:
literal String^ GESTORE_FILE_DI_PUBBLICAZIONE = "GestoreFileDiPubblicazione"
static val mutable GESTORE_FILE_DI_PUBBLICAZIONE: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.GESTORE_NOTIFICHE

Campo TopicGESTORE_NOTIFICHE
Capitolo: Gestore Notifiche.

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string GESTORE_NOTIFICHE = "GestoreNotifiche"
Public Const GESTORE_NOTIFICHE As String = "GestoreNotifiche"
public:
literal String^ GESTORE_NOTIFICHE = "GestoreNotifiche"
static val mutable GESTORE_NOTIFICHE: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.GESTORE_TRADUZIONI

Campo TopicGESTORE_TRADUZIONI
Capitolo: Gestore Traduzioni.

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string GESTORE_TRADUZIONI = "GestoreTraduzioni"
Public Const GESTORE_TRADUZIONI As String = "GestoreTraduzioni"
public:
literal String^ GESTORE_TRADUZIONI = "GestoreTraduzioni"
static val mutable GESTORE_TRADUZIONI: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.HELP

Campo TopicHELP
Capitolo: Help.

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string HELP = "Help"
Public Const HELP As String = "Help"
public:
literal String^ HELP = "Help"
static val mutable HELP: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.HOMEPAGE

Campo TopicHOMEPAGE
Capitolo: Home page.

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string HOMEPAGE = "QSInformaticaManualeDataDrawings"
Public Const HOMEPAGE As String = "QSInformaticaManualeDataDrawings"
public:
literal String^ HOMEPAGE = "QSInformaticaManualeDataDrawings"
static val mutable HOMEPAGE: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.IMPORTA_DATI

Campo TopicIMPORTA_DATI
Capitolo: Importa Dati

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string IMPORTA_DATI = "ImportaDati"
Public Const IMPORTA_DATI As String = "ImportaDati"
public:
literal String^ IMPORTA_DATI = "ImportaDati"
static val mutable IMPORTA_DATI: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.IMPORTA_QS_PACKGO

Campo TopicIMPORTA_QS_PACKGO
Capitolo: Importa PackGo.

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string IMPORTA_QS_PACKGO = "ImportaQsPackGo"
Public Const IMPORTA_QS_PACKGO As String = "ImportaQsPackGo"
public:
literal String^ IMPORTA_QS_PACKGO = "ImportaQsPackGo"
static val mutable IMPORTA_QS_PACKGO: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.INFORMAZIONI

Campo TopicINFORMAZIONI
Capitolo: Informazioni.

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string INFORMAZIONI = "Informazioni"
Public Const INFORMAZIONI As String = "Informazioni"
public:
literal String^ INFORMAZIONI = "Informazioni"
static val mutable INFORMAZIONI: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.INIZIA_PARTE_VELOCE

Campo TopicINIZIA_PARTE_VELOCE
Capitolo: Inizia Parte Veloce.

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string INIZIA_PARTE_VELOCE = "IniziaParteVeloce"
Public Const INIZIA_PARTE_VELOCE As String = "IniziaParteVeloce"
public:
literal String^ INIZIA_PARTE_VELOCE = "IniziaParteVeloce"
static val mutable INIZIA_PARTE_VELOCE: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.INTRODUCTION

Campo TopicINTRODUCTION
Capitolo: Introduzione.

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string INTRODUCTION = "Introduzione"
Public Const INTRODUCTION As String = "Introduzione"
public:
literal String^ INTRODUCTION = "Introduzione"
static val mutable INTRODUCTION: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.INTRODUZIONE

Campo TopicINTRODUZIONE
Capitolo: Introduzione.

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string INTRODUZIONE = "IntroduzioneDataAndDrawings"
Public Const INTRODUZIONE As String = "IntroduzioneDataAndDrawings"
public:
literal String^ INTRODUZIONE = "IntroduzioneDataAndDrawings"
static val mutable INTRODUZIONE: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.LAVORAZIONE

Campo TopicLAVORAZIONE
Capitolo: Lavorazione.

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string LAVORAZIONE = "Lavorazione"
Public Const LAVORAZIONE As String = "Lavorazione"
public:
literal String^ LAVORAZIONE = "Lavorazione"
static val mutable LAVORAZIONE: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.LAVORAZIONE_MULTIPLO

Campo TopicLAVORAZIONE_MULTIPLO
Capitolo: Lavorazione Multiplo.

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string LAVORAZIONE_MULTIPLO = "LavorazioneMultiplo"
Public Const LAVORAZIONE_MULTIPLO As String = "LavorazioneMultiplo"
public:
literal String^ LAVORAZIONE_MULTIPLO = "LavorazioneMultiplo"
static val mutable LAVORAZIONE_MULTIPLO: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.MODIFICA_SUPERATO

Campo TopicMODIFICA_SUPERATO
Capitolo: Modifica Superato.

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string MODIFICA_SUPERATO = "ModificaSuperato"
Public Const MODIFICA_SUPERATO As String = "ModificaSuperato"
public:
literal String^ MODIFICA_SUPERATO = "ModificaSuperato"
static val mutable MODIFICA_SUPERATO: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.MOSTRA_ALBERO_DED

Campo TopicMOSTRA_ALBERO_DED
Capitolo: Mostra Albero DED.

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string MOSTRA_ALBERO_DED = "MostraAlberoDeD"
Public Const MOSTRA_ALBERO_DED As String = "MostraAlberoDeD"
public:
literal String^ MOSTRA_ALBERO_DED = "MostraAlberoDeD"
static val mutable MOSTRA_ALBERO_DED: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.PUBBLICA

Campo TopicPUBBLICA
Capitolo: Pubblica.

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string PUBBLICA = "Pubblica"
Public Const PUBBLICA As String = "Pubblica"
public:
literal String^ PUBBLICA = "Pubblica"
static val mutable PUBBLICA: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.QSMANAGER

Campo TopicQSMANAGER
Capitolo: QsManager (Famiglie e Attributi).

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string QSMANAGER = "QsManager"
Public Const QSMANAGER As String = "QsManager"
public:
literal String^ QSMANAGER = "QsManager"
static val mutable QSMANAGER: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.REGISTRA_DOCUMENTI

Campo TopicREGISTRA_DOCUMENTI
Capitolo: Registra Documenti.

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string REGISTRA_DOCUMENTI = "RegistraDocumenti"
Public Const REGISTRA_DOCUMENTI As String = "RegistraDocumenti"
public:
literal String^ REGISTRA_DOCUMENTI = "RegistraDocumenti"
static val mutable REGISTRA_DOCUMENTI: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.REGISTRA_DOCUMENTO

Campo TopicREGISTRA_DOCUMENTO
Capitolo: Registra Documento.

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string REGISTRA_DOCUMENTO = "RegistraDocumento"
Public Const REGISTRA_DOCUMENTO As String = "RegistraDocumento"
public:
literal String^ REGISTRA_DOCUMENTO = "RegistraDocumento"
static val mutable REGISTRA_DOCUMENTO: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.RICERCA

Campo TopicRICERCA
Capitolo: Dialogo della ricerca.

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string RICERCA = "Ricerca"
Public Const RICERCA As String = "Ricerca"
public:
literal String^ RICERCA = "Ricerca"
static val mutable RICERCA: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.RICERCA_DOCUMENTI

Campo TopicRICERCA_DOCUMENTI
Capitolo: Ricerca documi.

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string RICERCA_DOCUMENTI = "RicercaDocumenti"
Public Const RICERCA_DOCUMENTI As String = "RicercaDocumenti"
public:
literal String^ RICERCA_DOCUMENTI = "RicercaDocumenti"
static val mutable RICERCA_DOCUMENTI: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.RILASCIO

Campo TopicRILASCIO
Capitolo: Rilascio.

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string RILASCIO = "Rilascio"
Public Const RILASCIO As String = "Rilascio"
public:
literal String^ RILASCIO = "Rilascio"
static val mutable RILASCIO: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.RILASCIO_MULTIPLO

Campo TopicRILASCIO_MULTIPLO
Capitolo: Rilascio Multiplo.

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string RILASCIO_MULTIPLO = "RilascioMultiplo"
Public Const RILASCIO_MULTIPLO As String = "RilascioMultiplo"
public:
literal String^ RILASCIO_MULTIPLO = "RilascioMultiplo"
static val mutable RILASCIO_MULTIPLO: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.SALVA_DED

Campo TopicSALVA_DED
Capitolo: Salva DeD.

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string SALVA_DED = "SalvaDeD"
Public Const SALVA_DED As String = "SalvaDeD"
public:
literal String^ SALVA_DED = "SalvaDeD"
static val mutable SALVA_DED: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.SALVA_DISTINTA

Campo TopicSALVA_DISTINTA
Capitolo: Salva Distinta.

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string SALVA_DISTINTA = "SalvaDistinta"
Public Const SALVA_DISTINTA As String = "SalvaDistinta"
public:
literal String^ SALVA_DISTINTA = "SalvaDistinta"
static val mutable SALVA_DISTINTA: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.SALVA_MULTIPLO

Campo TopicSALVA_MULTIPLO
Capitolo: Salva Multiplo.

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string SALVA_MULTIPLO = "SalvaMultiplo"
Public Const SALVA_MULTIPLO As String = "SalvaMultiplo"
public:
literal String^ SALVA_MULTIPLO = "SalvaMultiplo"
static val mutable SALVA_MULTIPLO: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.SALVA_PARTE

Campo TopicSALVA_PARTE
Capitolo: Salva Parte.

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string SALVA_PARTE = "SalvaParte"
Public Const SALVA_PARTE As String = "SalvaParte"
public:
literal String^ SALVA_PARTE = "SalvaParte"
static val mutable SALVA_PARTE: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.SALVA_PARTE_VARIANTE

Campo TopicSALVA_PARTE_VARIANTE
Capitolo: Cambia Parte Variante.

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string SALVA_PARTE_VARIANTE = "SalvaParteVariante"
Public Const SALVA_PARTE_VARIANTE As String = "SalvaParteVariante"
public:
literal String^ SALVA_PARTE_VARIANTE = "SalvaParteVariante"
static val mutable SALVA_PARTE_VARIANTE: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.SALVA_REVISIONE

Campo TopicSALVA_REVISIONE
Capitolo: Salva Revisione.

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string SALVA_REVISIONE = "SalvaRevisione"
Public Const SALVA_REVISIONE As String = "SalvaRevisione"
public:
literal String^ SALVA_REVISIONE = "SalvaRevisione"
static val mutable SALVA_REVISIONE: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.SALVA_SUPERATO

Campo TopicSALVA_SUPERATO
Capitolo: Modifica Superato.

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string SALVA_SUPERATO = "SalvaSuperato"
Public Const SALVA_SUPERATO As String = "SalvaSuperato"
public:
literal String^ SALVA_SUPERATO = "SalvaSuperato"
static val mutable SALVA_SUPERATO: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.SALVA_VARIANTE

Campo TopicSALVA_VARIANTE
Capitolo: Cambia Variante.

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string SALVA_VARIANTE = "SalvaVariante"
Public Const SALVA_VARIANTE As String = "SalvaVariante"
public:
literal String^ SALVA_VARIANTE = "SalvaVariante"
static val mutable SALVA_VARIANTE: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.SBLOCCA

Campo TopicSBLOCCA
Capitolo: Sblocca.

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string SBLOCCA = "SbloccaeChiudi"
Public Const SBLOCCA As String = "SbloccaeChiudi"
public:
literal String^ SBLOCCA = "SbloccaeChiudi"
static val mutable SBLOCCA: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.STATO_DOCUMENTO

Campo TopicSTATO_DOCUMENTO
Capitolo: Stato Documento.

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string STATO_DOCUMENTO = "StatoDocumento"
Public Const STATO_DOCUMENTO As String = "StatoDocumento"
public:
literal String^ STATO_DOCUMENTO = "StatoDocumento"
static val mutable STATO_DOCUMENTO: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.TEMPORIZZAZIONI

Campo TopicTEMPORIZZAZIONI
Capitolo: Temporizzazioni

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string TEMPORIZZAZIONI = "Temporizzazioni"
Public Const TEMPORIZZAZIONI As String = "Temporizzazioni"
public:
literal String^ TEMPORIZZAZIONI = "Temporizzazioni"
static val mutable TEMPORIZZAZIONI: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.UTENTE_PERMESSI

Campo TopicUTENTE_PERMESSI
Capitolo: Utenti e Permessi.

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string UTENTE_PERMESSI = "UtentiPermessi"
Public Const UTENTE_PERMESSI As String = "UtentiPermessi"
public:
literal String^ UTENTE_PERMESSI = "UtentiPermessi"
static val mutable UTENTE_PERMESSI: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


Campo Topic.VARIABILI

Campo TopicVARIABILI
Capitolo: Variabili del DED+.

Namespace: DedNet.Core.Help
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const string VARIABILI = "Variabili"
Public Const VARIABILI As String = "Variabili"
public:
literal String^ VARIABILI = "Variabili"
static val mutable VARIABILI: string

Valore del campo

String
Vedi anche

Documentazione

Struttura Topic
Namespace DedNet.Core.Help


DedNet.Forms Namespace
Spazio dei nomi contenente tutte le classi relative ai form.
Classi
 | Classe | Descrizione
Classe pubblica | BaseForm |
Classe pubblica | BaseRibbonForm | Classe base da cui devono discendere tutti i vari RibbonForm.
Classe pubblica | BomItemWrapper | Classe wrapper da bindare alla griglia
Classe pubblica | CascadeBinder | Classe da bindare alla griglia.
Classe pubblica | CascadeRow | Riga del CascadeBinder.
Classe pubblica | ChoiceItem | Classe usata per gestire la scelta dell'attributo su cui creare una nuova cascata.
Classe pubblica | ChoiceItemList | Lista di ChoiceItem.
Classe pubblica | CommAnagrItemWrapper | Classe wrapper da bindare alla griglia
Classe pubblica | ControlloPermessi |
Classe pubblica | ControlloPermessiItemPermObj |
Classe pubblica | ControlloPermessiUserPermSpec | Classe utilizzata per visualizzare i permessi specifici dell'utente.
Classe pubblica | CreaGruppoForm |
Classe pubblica | CreaPermessoForm |
Classe pubblica | CreaUtenteForm |
Classe pubblica | CustomListUserGroups | Classe usata per popolare il controllo TreeList con la lista degli utenti/gruppi. Espone la proprietà 'Nome' che è associata alla colonna del TreeList.
Classe pubblica | CustomListUsersToAssign |
Classe pubblica | DedFormAlternativeData | Dialogo utilizzato per visualizzare e editare i codici alternativi di una anagrafica.
Classe pubblica | DedFormAnagrafica | Finestra di dialogo contenente il controllo per visualizzare/editare gli attributi.
Classe pubblica | DedFormAnagrHistory | Classe per visualizzare la storia di un'anagrafica.
Classe pubblica | DedFormAnagrMultiSel |
Classe pubblica | DedFormAssociateDoc |
Classe pubblica | DedFormBomAddItem | From per la gestione dell'inserimento in distinta nel caso di anagrafiche duplicate
Classe pubblica | DedFormBomCompareCfg |
Classe pubblica | DedFormBomCompareExp |
Classe pubblica | DedFormBomEdit |
Classe pubblica | DedFormBomHistory |
Classe pubblica | DedFormCascade | Finestra di dialogo per la creazione ed editazione delle cascate.
Classe pubblica | DedFormCategory | Form per la gestione (creazione, spostamento, modifica ed eliminazione) delle categorie.
Classe pubblica | DedFormChangePwd |
Classe pubblica | DedFormChangeState | Form per il cambio di stato.
Classe pubblica | DedFormChooseComm |
Classe pubblica | DedFormChoseFile | Form che permette di selezionare il tipo di documenti da usare.
Classe pubblica | DedFormComm |
Classe pubblica | DedFormCommMaster |
Classe pubblica | DedFormCorporate |
Classe pubblica | DedFormDbDocCompare | Form per effettuare il confronto tra i dati presenti negli oggetti DataDb e DataDoc. Il risultato del confronto viene salvato nell'oggetto DataResult (se è dirty significa che i sui valori sono diversi da quelli presenti nel DB). Se non si vuole visualizzare l'interfaccia grafica impostare a false UseUI e chimare Run() al posto di ShowDialog.
Classe pubblica | DedFormDbDocCompareListRowObjetc |
Classe pubblica | DedFormDbDocCompareRowObject |
Classe pubblica | DedFormDedBaseDbItem | Dialogo utilizzato per visualizzare gli oggetti con le temporizzazioni.
Classe pubblica | DedFormDedBaseDbItemUpdatingDataSourceEventArgs |
Classe pubblica | DedFormDefFileName |
Classe pubblica | DedFormDependencies | Dialogo utilizzato per visualizzare una struttura gerarchica di dipendenze generiche.
Classe pubblica | DedFormDist | Form per visualizzare la distinta implosa/espolsa di un determinato BomItemCollection
Classe pubblica | DedFormDistProdSave | Form per la gestione del salvataggio della distinta di produzione
Classe pubblica | DedFormDocHistory | Finestra per visualizzare la storia del documento (chekin / checkout ).
Classe pubblica | DedFormDocSearch | Classe per la gestione form della ricerca documentale
Classe pubblica | DedFormDocsManage | Form per la comparazione dei documenti da utilizzare nel comando di nuova revisione.
Classe pubblica | DedFormDocTransferHistory |
Classe pubblica | DedFormEco | Classe usata per istanziare il form degli Eco.
Classe pubblica | DedFormEcoHistory | Classe per visualizzare la storia di un'eco.
Classe pubblica | DedFormEditComm | Form utilizzato per la creazione o la modifica di una commessa.
Classe pubblica | DedFormEditEco |
Classe pubblica | DedFormEditObjects | Dialogo utilizzato per permettere l'editazione della collection di oggetti specificata.
Classe pubblica | DedFormFileRecognizer | Dialogo utilizzato dal comando per il riconoscimento massiccio dei documenti
Classe pubblica | DedFormFindCode | Form per la ricerca veloce in base ad un campo. Si imposta la lista dei campi disponibili all'utente, fra i quali può scegliere il campo di ricerca. Si imposta la lista delle colonne che devono essere sempre visibili nel combo dei valori di ricerca. Il form memorizza il nome del campo di ricerca e gestisce lui la sua inizializzazione.
Classe pubblica | DedFormFindCodeOptions |
Classe pubblica | DedFormFontDialog | Dialogo utilizzato come popup per il DedFontEdit.
Classe pubblica | DedFormImportBom |
Classe pubblica | DedFormImporter |
Classe pubblica | DedFormListEdit | Form per aggiunta elementi alle liste utente
Classe pubblica | DedFormLogView | Dialogo che permette di visualizzare e filtrare all'interno di una griglia devexpress il contenuto della tabella DED_LOG. Sono inoltre presenti due strumenti di utilità: - Esportazione della vista attuale in formato Excel, CSV, PDF, HTML. - Cancellazione dal DB delle loggate presenti nella vista attuale (richiede permessi speciali).
Classe pubblica | DedFormMain |
Classe pubblica | DedFormManageList | From per la gestione delle tipologie di lista
Classe pubblica | DedFormManageRoot |
Classe pubblica | DedFormMappingRoot |
Classe pubblica | DedFormMappingRootMappingRootObject | Classe di servzio.
Classe pubblica | DedFormMovedEditor |
Classe pubblica | DedFormMovedEditorMovedWrapper | Oggetto DedEco che viene visualizzato a schermo.
Classe pubblica | DedFormPrintExportSetting |
Classe pubblica | DedFormPrintExportSettingPrintExportSetting | Classe per gestire la scelta dell'utente.
Classe pubblica | DedFormPropertiesManager | Dialogo di gestione delle variabili riguardanti le proprietà dei documenti.
Classe pubblica | DedFormPropertiesReader | Dialogo che calcola le proprietà di documento dei documenti passati in ingresso. Le proprietà vengono mostrate all'interno della griglia e, selezionandole tramite checkbox, è possibile inserirle automaticamente all'interno della variabile DOC_PROPERTIES_TO_INCLUDE.
Classe pubblica | DedFormPublicationFileManager | Dialogo utilizzato per gestire la creazione dei file di pubblicazione.
Classe pubblica | DedFormPwsBackup |
Classe pubblica | DedFormPwsCache | Form che mostra una finestra con i documenti presenti nella pws locale dell'utente che sta usando l'applicazione.
Classe pubblica | DedFormPwsCachePwsItem | Descrive le caratteristiche di un singolo elemento presente nella cache locale.
Classe pubblica | DedFormPwsCachePwsItemList | Lista di elementi presenti nella pws.
Classe pubblica | DedFormQsManager |
Classe pubblica | DedFormRenameCopyDocument |
Classe pubblica | DedFormReplaceAnagrDist |
Classe pubblica | DedFormReserveProg | Classe per assegnare i progressivi ai vari utenti/gruppi.
Classe pubblica | DedFormSave | Finestra di dialogo per la creazione di una nuova anagrafica.
Classe pubblica | DedFormSaveAs |
Classe pubblica | DedFormSettings | Controllo per la visualizzazione delle configurazioni di visualizzazione delle colonne nei comandi delle distinte (Edita, Visualizzazione...)
Classe pubblica | DedFormStateManager | Dialogo che mostra le relazioni tra i vari stati di una anagrafica.
Classe pubblica | DedFormStateManagerUpdatedStateIcon |
Classe pubblica | DedFormTime | Dialogo utilizzato per visualizzare/editare le temporizzazioni di anagrafiche, commesse, ECO, ecc...
Classe pubblica | DedFormTimeCompareDedTime | Classe utilizzata per ordinare le temporizzazioni in base alla loro data di avvio.
Classe pubblica | DedFormTransferManager | Gestore richieste trasferimento
Classe pubblica | DedFormTransferManagerOptions |
Classe pubblica | DedFormTranslationsManager |
Classe pubblica | DedFormUpdateOldRev |
Classe pubblica | DedFormUserPerm |
Classe pubblica | DedFormUserPermBoolWrapper |
Classe pubblica | DedFormVars | Form per la visualizzazione e la modifica delle variabili del DED.
Classe pubblica | DedFormVisualDep |
Classe pubblica | DedFormWhereUsed | Form per visualizzare tutti i padri di un determinato documento (ovvero dove viene usato in altri documenti). Viene anche usato nel comando Apri file associato, utilizzando il secondo costruttore.
Classe pubblica | DedOptionsForm |
Classe pubblica | DocPropertyDescriptor | Classe che descrive una singola proprietà di documento all'interno della griglia.
Classe pubblica | DocPropertyDescriptorList | Lista di oggetti che descrivono una singola proprietà di documento all'interno della griglia.
Classe pubblica | FolderBrowserDialogEx |
Classe pubblica | ListObjToUpdate |
Classe pubblica | ModificaGruppoForm |
Classe pubblica | ModificaUtenteForm |
Classe pubblica | MyBindingListTranslationWrapperItem | Ridefinisce la BindingList per avere un evento di BeforeRemove in modo da poter apportare le modifiche anche alla reale datasource
Classe pubblica | ObjToUpdate | Oggetto utilizzato per bindare la lista.
Classe pubblica | ObjUpdContext | Oggetto descrittore di contesto
Classe pubblica | ObjUpdContexts | Lista smart di contesti
Classe pubblica | OwnerSelector |
Classe pubblica | OwnerSelectorOwnerSelectorList |
Classe pubblica | OwnerSelectorOwnerSelectorObj |
Classe pubblica | SparePartsAnagrWithoutDrawings | Visualizza le anagrafiche che compongono la distinta ricambi, ma che non hanno una tavola ricambi valida.
Classe pubblica | SparePartsManualForm |
Classe pubblica | SparePartsPrintSettings | Dialogo utilizzato per gestire le impostazioni di pubblicazione manuale.
Classe pubblica | SparePartsTableLayout | Classe utilizzata per impostare il layout della tabella ricambi nel manuale di pubblicazione.
Strutture
 | Struttura | Descrizione
Struttura pubblica | DedFormImportBomBomImportInfo | Struttura con le informazioni sulla distinta da importare
Struttura pubblica | DedFormImportBomDataImportInfo | Struttura con le informazioni sull'anagrafica da importare.
Struttura pubblica | DedFormImportBomFormatJson | Struttura usata per formattare il file Json usato per il salvataggio/caricamento della configurazione
Struttura pubblica | DedFormMainSelectInfo | Struttura contenente le informazioni sulla selezione corrente e precedente.
Delegate
 | Delegate | Descrizione
Delegate pubblico | DedFormUpdateOldRevAction |
Delegate pubblico | DedFormUpdateOldRevViewResult |
Delegate pubblico | MyBindingListTranslationWrapperItemMyTranslationWrapperItemDelegate |
Enumerazioni
 | Enumerazione | Descrizione
Enumerazione pubblica | DedFormCascadeRootTypeEnum | Indentifica la tipologia.
Enumerazione pubblica | DedFormEditCommDedFormEditMode |
Enumerazione pubblica | DedFormImportBomImportTypeEnum | Enumeratore che indica la tipologia di importazione.
Enumerazione pubblica | DedFormQsManagerAttributeOperation | Enumeratore contenente tutte le operazioni applicabili agli attributi.
Enumerazione pubblica | DedFormQsManagerRootTypeEnum | Indentifica la tipologia
Enumerazione pubblica | DedFormSaveModeEnum | Enumerazioni delle possibili configurazioni della finestra di salvataggio nel Database.
Enumerazione pubblica | DedFormTransferManagerTransferBehaviorEnum | Enum dei comportamenti iniziali del form
Enumerazione pubblica | OwnerSelectorEnumOwnerState |


Classe BaseForm
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
Altro

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class BaseForm : XtraForm
Public Class BaseForm
    Inherits XtraForm
public ref class BaseForm : public XtraForm
type BaseForm =
    class
        inherit XtraForm
    end

Il tipo BaseForm espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo protetto | BaseForm | Costruttore per il Designer.
Metodo pubblico | BaseForm(DedNetApplication) | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene.
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout.
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante).
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante).
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive XtraForm.Dispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form.
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato.
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Sovrascrive FormOnVisibleChanged(EventArgs))
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form.
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 |
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsBaseRibbonForm
DedNet.FormsCreaGruppoForm
DedNet.FormsCreaPermessoForm
DedNet.FormsCreaUtenteForm
DedNet.FormsDedFormAlternativeData
DedNet.FormsDedFormAnagrafica
DedNet.FormsDedFormAnagrHistory
DedNet.FormsDedFormAnagrMultiSel
DedNet.FormsDedFormAssociateDoc
DedNet.FormsDedFormBomAddItem
DedNet.FormsDedFormBomCompareCfg
DedNet.FormsDedFormBomCompareExp
DedNet.FormsDedFormBomEdit
DedNet.FormsDedFormBomHistory
DedNet.FormsDedFormCascade
DedNet.FormsDedFormCategory
DedNet.FormsDedFormChangePwd
DedNet.FormsDedFormChangeState
DedNet.FormsDedFormChooseComm
DedNet.FormsDedFormChoseFile
DedNet.FormsDedFormComm
DedNet.FormsDedFormCommMaster
DedNet.FormsDedFormCorporate
DedNet.FormsDedFormDbDocCompare
DedNet.FormsDedFormDedBaseDbItem
DedNet.FormsDedFormDefFileName
DedNet.FormsDedFormDependencies
DedNet.FormsDedFormDist
DedNet.FormsDedFormDistProdSave
DedNet.FormsDedFormDocHistory
DedNet.FormsDedFormDocSearch
DedNet.FormsDedFormDocsManage
DedNet.FormsDedFormDocTransferHistory
DedNet.FormsDedFormEco
DedNet.FormsDedFormEcoHistory
DedNet.FormsDedFormEditComm
DedNet.FormsDedFormEditEco
DedNet.FormsDedFormEditObjects
DedNet.FormsDedFormFileRecognizer
DedNet.FormsDedFormFindCode
DedNet.FormsDedFormFindCodeOptions
DedNet.FormsDedFormFontDialog
DedNet.FormsDedFormImportBom
DedNet.FormsDedFormImporter
DedNet.FormsDedFormListEdit
DedNet.FormsDedFormLogView
DedNet.FormsDedFormMain
DedNet.FormsDedFormManageList
DedNet.FormsDedFormManageRoot
DedNet.FormsDedFormMappingRoot
DedNet.FormsDedFormMovedEditor
DedNet.FormsDedFormPrintExportSetting
DedNet.FormsDedFormPropertiesManager
DedNet.FormsDedFormPropertiesReader
DedNet.FormsDedFormPublicationFileManager
DedNet.FormsDedFormPwsBackup
DedNet.FormsDedFormPwsCache
DedNet.FormsDedFormQsManager
DedNet.FormsDedFormRenameCopyDocument
DedNet.FormsDedFormReplaceAnagrDist
DedNet.FormsDedFormReserveProg
DedNet.FormsDedFormSave
DedNet.FormsDedFormSaveAs
DedNet.FormsDedFormSettings
DedNet.FormsDedFormStateManager
DedNet.FormsDedFormTime
DedNet.FormsDedFormTransferManager
DedNet.FormsDedFormTransferManagerOptions
DedNet.FormsDedFormTranslationsManager
DedNet.FormsDedFormUpdateOldRev
DedNet.FormsDedFormUserPerm
DedNet.FormsDedFormVars
DedNet.FormsDedFormVisualDep
DedNet.FormsDedFormWhereUsed
DedNet.FormsDedOptionsForm
DedNet.FormsModificaGruppoForm
DedNet.FormsModificaUtenteForm
DedNet.FormsOwnerSelector
DedNet.FormsSparePartsAnagrWithoutDrawings
DedNet.FormsSparePartsPrintSettings
DedNet.FormsSparePartsTableLayout
DedNet.NotifyFormDedFormNotity
DedNet.NotifyFormDedNotifyComposer
DedNet.QsManagerFormDedFormAtt
DedNet.QsManagerFormDedFormComposeRule
DedNet.QsManagerFormDedFormOptions
DedNet.QsManagerFormDedRuleForm


Costruttore BaseForm
Lista degli overload
 | Nome | Descrizione
Metodo protetto | BaseForm | Costruttore per il Designer.
Metodo pubblico | BaseForm(DedNetApplication) | Costruttore unico.
Torna su
Vedi anche

Documentazione

Classe BaseForm
Namespace DedNet.Forms


Costruttore BaseForm
Costruttore per il Designer.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected BaseForm()
Protected Sub New
protected:
BaseForm()
new : unit -> BaseForm
Vedi anche

Documentazione

Classe BaseForm
Overload di BaseForm
Namespace DedNet.Forms


Costruttore BaseForm(DedNetApplication)
Costruttore unico.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BaseForm(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
BaseForm(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> BaseForm

Parametri

app DedNetApplication
Oggetto applicazione al quale il Form appartiene.
Vedi anche

Documentazione

Classe BaseForm
Overload di BaseForm
Namespace DedNet.Forms


Proprietà di BaseForm

Il tipo BaseForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene.
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout.
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe BaseForm
Namespace DedNet.Forms


Proprietà BaseForm.Application

Proprietà BaseFormApplication
Restituisce l'applicazione alla quale questo Form appartiene.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedNetApplication Application { get; }
Public ReadOnly Property Application As DedNetApplication
    Get
public:
property DedNetApplication^ Application {
    DedNetApplication^ get ();
}
member Application : DedNetApplication with get

Valore della proprietà

DedNetApplication
Vedi anche

Documentazione

Classe BaseForm
Namespace DedNet.Forms


Proprietà BaseForm.MainRegistryKey

Proprietà BaseFormMainRegistryKey
Chiave di registro in cui scrivere le impostazioni di layout.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string MainRegistryKey { get; }
Public ReadOnly Property MainRegistryKey As String
    Get
public:
property String^ MainRegistryKey {
    String^ get ();
}
member MainRegistryKey : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe BaseForm
Namespace DedNet.Forms


Metodi di BaseForm

Il tipo BaseForm espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante).
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante).
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive XtraForm.Dispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form.
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato.
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Sovrascrive FormOnVisibleChanged(EventArgs))
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form.
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe BaseForm
Namespace DedNet.Forms


Metodo BaseForm.AddGeneralUtilities

Metodo BaseFormAddGeneralUtilities
Lista degli overload
 | Nome | Descrizione
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante).
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante).
Torna su
Vedi anche

Documentazione

Classe BaseForm
Namespace DedNet.Forms


Metodo BaseForm.AddGeneralUtilities(Bar, String)

Metodo BaseFormAddGeneralUtilities(Bar, String)
Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante).

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected void AddGeneralUtilities(
    Bar mainMenu,
    string topicName
)
Protected Sub AddGeneralUtilities (
    mainMenu As Bar,
    topicName As String
)
protected:
void AddGeneralUtilities(
    Bar^ mainMenu,
    String^ topicName
)
member AddGeneralUtilities :
        mainMenu : Bar *
        topicName : string -> unit

Parametri

mainMenu Bar
topicName String
Vedi anche

Documentazione

Classe BaseForm
Overload di AddGeneralUtilities
Namespace DedNet.Forms


Metodo BaseForm.AddGeneralUtilities(Bar, DockManager, String)

Metodo BaseFormAddGeneralUtilities(Bar, DockManager, String)
Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante).

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected void AddGeneralUtilities(
    Bar mainMenu,
    DockManager dockManager,
    string topicName
)
Protected Sub AddGeneralUtilities (
    mainMenu As Bar,
    dockManager As DockManager,
    topicName As String
)
protected:
void AddGeneralUtilities(
    Bar^ mainMenu,
    DockManager^ dockManager,
    String^ topicName
)
member AddGeneralUtilities :
        mainMenu : Bar *
        dockManager : DockManager *
        topicName : string -> unit

Parametri

mainMenu Bar
dockManager DockManager
topicName String
Vedi anche

Documentazione

Classe BaseForm
Overload di AddGeneralUtilities
Namespace DedNet.Forms


Metodo BaseForm.Dispose

Metodo BaseFormDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe BaseForm
Namespace DedNet.Forms


Metodo BaseForm.GetPixelSizeForCurrentDpiSettings

Metodo BaseFormGetPixelSizeForCurrentDpiSettings
Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected int GetPixelSizeForCurrentDpiSettings(
    int pixel
)
Protected Function GetPixelSizeForCurrentDpiSettings (
    pixel As Integer
) As Integer
protected:
int GetPixelSizeForCurrentDpiSettings(
    int pixel
)
member GetPixelSizeForCurrentDpiSettings :
        pixel : int -> int

Parametri

pixel Int32

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe BaseForm
Namespace DedNet.Forms


Metodo BaseForm.LoadSizeAndPosition

Metodo BaseFormLoadSizeAndPosition
Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected void LoadSizeAndPosition()
Protected Sub LoadSizeAndPosition
protected:
void LoadSizeAndPosition()
member LoadSizeAndPosition : unit -> unit
Vedi anche

Documentazione

Classe BaseForm
Namespace DedNet.Forms


Metodo BaseForm.MakeRegistryKey

Metodo BaseFormMakeRegistryKey
Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected bool MakeRegistryKey()
Protected Function MakeRegistryKey As Boolean
protected:
bool MakeRegistryKey()
member MakeRegistryKey : unit -> bool

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe BaseForm
Namespace DedNet.Forms


Metodo BaseForm.OnVisibleChanged

Metodo BaseFormOnVisibleChanged
Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void OnVisibleChanged(
    EventArgs e
)
Protected Overrides Sub OnVisibleChanged (
    e As EventArgs
)
protected:
virtual void OnVisibleChanged(
    EventArgs^ e
) override
abstract OnVisibleChanged :
        e : EventArgs -> unit
override OnVisibleChanged :
        e : EventArgs -> unit

Parametri

e EventArgs
Vedi anche

Documentazione

Classe BaseForm
Namespace DedNet.Forms


Metodo BaseForm.SaveSizeAndPosition

Metodo BaseFormSaveSizeAndPosition
Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected void SaveSizeAndPosition()
Protected Sub SaveSizeAndPosition
protected:
void SaveSizeAndPosition()
member SaveSizeAndPosition : unit -> unit
Vedi anche

Documentazione

Classe BaseForm
Namespace DedNet.Forms


Eventi di BaseForm

Il tipo BaseForm espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe BaseForm
Namespace DedNet.Forms


Campi di BaseForm

Il tipo BaseForm espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 |
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe BaseForm
Namespace DedNet.Forms


Campo BaseForm.defaultLookAndFeel1

Campo BaseFormdefaultLookAndFeel1

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DefaultLookAndFeel defaultLookAndFeel1
Public defaultLookAndFeel1 As DefaultLookAndFeel
public:
DefaultLookAndFeel^ defaultLookAndFeel1
val mutable defaultLookAndFeel1: DefaultLookAndFeel

Valore del campo

DefaultLookAndFeel
Vedi anche

Documentazione

Classe BaseForm
Namespace DedNet.Forms


Campo BaseForm.DpiBasedMinimumSize

Campo BaseFormDpiBasedMinimumSize
Dimensioni minime calcolate sull'impostazione dei dpi correnti

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected Size DpiBasedMinimumSize
Protected DpiBasedMinimumSize As Size
protected:
Size DpiBasedMinimumSize
val mutable DpiBasedMinimumSize: Size

Valore del campo

Size
Vedi anche

Documentazione

Classe BaseForm
Namespace DedNet.Forms


Classe BaseRibbonForm
Classe base da cui devono discendere tutti i vari RibbonForm.
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsBaseRibbonForm
DedNet.FormsSparePartsManualForm

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class BaseRibbonForm : BaseForm
Public Class BaseRibbonForm
    Inherits BaseForm
public ref class BaseRibbonForm : public BaseForm
type BaseRibbonForm =
    class
        inherit BaseForm
    end

Il tipo BaseRibbonForm espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo protetto | BaseRibbonForm | Classe base da cui devono discendere tutti i vari RibbonForm. Costruttore per il Designer affinchè sia possibile editare i dialoghi in VisualStudio.
Metodo protetto | BaseRibbonForm(DedNetApplication) | Classe base da cui devono discendere tutti i vari RibbonForm.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore BaseRibbonForm
Lista degli overload
 | Nome | Descrizione
Metodo protetto | BaseRibbonForm | Classe base da cui devono discendere tutti i vari RibbonForm. Costruttore per il Designer affinchè sia possibile editare i dialoghi in VisualStudio.
Metodo protetto | BaseRibbonForm(DedNetApplication) | Classe base da cui devono discendere tutti i vari RibbonForm.
Torna su
Vedi anche

Documentazione

Classe BaseRibbonForm
Namespace DedNet.Forms


Costruttore BaseRibbonForm
Classe base da cui devono discendere tutti i vari RibbonForm. Costruttore per il Designer affinchè sia possibile editare i dialoghi in VisualStudio.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected BaseRibbonForm()
Protected Sub New
protected:
BaseRibbonForm()
new : unit -> BaseRibbonForm
Vedi anche

Documentazione

Classe BaseRibbonForm
Overload di BaseRibbonForm
Namespace DedNet.Forms


Costruttore BaseRibbonForm(DedNetApplication)
Classe base da cui devono discendere tutti i vari RibbonForm.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected BaseRibbonForm(
    DedNetApplication app
)
Protected Sub New (
    app As DedNetApplication
)
protected:
BaseRibbonForm(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> BaseRibbonForm

Parametri

app DedNetApplication
Applicazione DedNet.
Vedi anche

Documentazione

Classe BaseRibbonForm
Overload di BaseRibbonForm
Namespace DedNet.Forms


Proprietà di BaseRibbonForm

Il tipo BaseRibbonForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe BaseRibbonForm
Namespace DedNet.Forms


Metodi di BaseRibbonForm

Il tipo BaseRibbonForm espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe BaseRibbonForm
Namespace DedNet.Forms


Metodo BaseRibbonForm.Dispose

Metodo BaseRibbonFormDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe BaseRibbonForm
Namespace DedNet.Forms


Eventi di BaseRibbonForm

Il tipo BaseRibbonForm espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe BaseRibbonForm
Namespace DedNet.Forms


Campi di BaseRibbonForm

Il tipo BaseRibbonForm espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe BaseRibbonForm
Namespace DedNet.Forms


Classe BomItemWrapper
Classe wrapper da bindare alla griglia
Gerarchia di ereditarietà
SystemObject
DedNet.FormsBomItemWrapper

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class BomItemWrapper
Public Class BomItemWrapper
public ref class BomItemWrapper
type BomItemWrapper = class end

Il tipo BomItemWrapper espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | BomItemWrapper | Costruttore per le nuove righe
Metodo pubblico | BomItemWrapper(BomItem) | Costrutto per gli elementi che erano già presenti in distinta
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AttributesDistinta | Lista degli attributi di distinta
Proprietà pubblica | DistAttrs | Accoppiata nome-valore degli attributi di distinta
Proprietà pubblica | DistValues | Ritorna i valori degli attributi di distinta in una lista di oggetti ordinata
Proprietà pubblica | IsRowAdded | Indica se è una riga nuova
Proprietà pubblica | Man | Tipo Man
Proprietà pubblica | Qta | Quantità
Proprietà pubblica | RealBomItem | Oggetto BomItem associato (nel caso l'elemento fosse già associato alla distinta [non nuovo])
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetHashCode | Vengono riconosciuti uguali gli elementi che hanno tutti i campi uguali tranne QTA che non concorre come discriminante. (Sovrascrive ObjectGetHashCode)
Metodo pubblico | GetValue | Permette di settare i valori degli attributi di distinta.
Metodo pubblico | IsModified | Restituisce true se l'elemento era gia presente in distinta ed è stato modificato rispetto al BomItem iniziale.
Metodo pubblico | SetValue | Legge i valori degli attributi di distinta
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore BomItemWrapper
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | BomItemWrapper | Costruttore per le nuove righe
Metodo pubblico | BomItemWrapper(BomItem) | Costrutto per gli elementi che erano già presenti in distinta
Torna su
Vedi anche

Documentazione

Classe BomItemWrapper
Namespace DedNet.Forms


Costruttore BomItemWrapper
Costruttore per le nuove righe

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItemWrapper()
Public Sub New
public:
BomItemWrapper()
new : unit -> BomItemWrapper
Vedi anche

Documentazione

Classe BomItemWrapper
Overload di BomItemWrapper
Namespace DedNet.Forms


Costruttore BomItemWrapper(BomItem)
Costrutto per gli elementi che erano già presenti in distinta

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItemWrapper(
    BomItem item
)
Public Sub New (
    item As BomItem
)
public:
BomItemWrapper(
    BomItem^ item
)
new :
        item : BomItem -> BomItemWrapper

Parametri

item BomItem
BomItem di riferimento
Vedi anche

Documentazione

Classe BomItemWrapper
Overload di BomItemWrapper
Namespace DedNet.Forms


Proprietà di BomItemWrapper

Il tipo BomItemWrapper espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AttributesDistinta | Lista degli attributi di distinta
Proprietà pubblica | DistAttrs | Accoppiata nome-valore degli attributi di distinta
Proprietà pubblica | DistValues | Ritorna i valori degli attributi di distinta in una lista di oggetti ordinata
Proprietà pubblica | IsRowAdded | Indica se è una riga nuova
Proprietà pubblica | Man | Tipo Man
Proprietà pubblica | Qta | Quantità
Proprietà pubblica | RealBomItem | Oggetto BomItem associato (nel caso l'elemento fosse già associato alla distinta [non nuovo])
Torna su
Vedi anche

Documentazione

Classe BomItemWrapper
Namespace DedNet.Forms


Proprietà BomItemWrapper.AttributesDistinta

Proprietà BomItemWrapperAttributesDistinta
Lista degli attributi di distinta

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList AttributesDistinta { get; }
Public ReadOnly Property AttributesDistinta As DedAttrList
    Get
public:
property DedAttrList^ AttributesDistinta {
    DedAttrList^ get ();
}
member AttributesDistinta : DedAttrList with get

Valore della proprietà

DedAttrList
Vedi anche

Documentazione

Classe BomItemWrapper
Namespace DedNet.Forms


Proprietà BomItemWrapper.DistAttrs

Proprietà BomItemWrapperDistAttrs
Accoppiata nome-valore degli attributi di distinta

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<string, Object> DistAttrs { get; set; }
Public Property DistAttrs As Dictionary(Of String, Object)
    Get
    Set
public:
property Dictionary<String^, Object^>^ DistAttrs {
    Dictionary<String^, Object^>^ get ();
    void set (Dictionary<String^, Object^>^ value);
}
member DistAttrs : Dictionary<string, Object> with get, set

Valore della proprietà

Dictionary String, Object
Vedi anche

Documentazione

Classe BomItemWrapper
Namespace DedNet.Forms


Proprietà BomItemWrapper.DistValues

Proprietà BomItemWrapperDistValues
Ritorna i valori degli attributi di distinta in una lista di oggetti ordinata

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object[] DistValues { get; }
Public ReadOnly Property DistValues As Object()
    Get
public:
property array<Object^>^ DistValues {
    array<Object^>^ get ();
}
member DistValues : Object[] with get

Valore della proprietà

Object
Vedi anche

Documentazione

Classe BomItemWrapper
Namespace DedNet.Forms


Proprietà BomItemWrapper.IsRowAdded

Proprietà BomItemWrapperIsRowAdded
Indica se è una riga nuova

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsRowAdded { get; set; }
Public Property IsRowAdded As Boolean
    Get
    Set
public:
property bool IsRowAdded {
    bool get ();
    void set (bool value);
}
member IsRowAdded : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe BomItemWrapper
Namespace DedNet.Forms


Proprietà BomItemWrapper.Man

Proprietà BomItemWrapperMan
Tipo Man

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItemManEnum Man { get; set; }
Public Property Man As BomItemManEnum
    Get
    Set
public:
property BomItemManEnum Man {
    BomItemManEnum get ();
    void set (BomItemManEnum value);
}
member Man : BomItemManEnum with get, set

Valore della proprietà

BomItemManEnum
Vedi anche

Documentazione

Classe BomItemWrapper
Namespace DedNet.Forms


Proprietà BomItemWrapper.Qta

Proprietà BomItemWrapperQta
Quantità

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public double Qta { get; set; }
Public Property Qta As Double
    Get
    Set
public:
property double Qta {
    double get ();
    void set (double value);
}
member Qta : float with get, set

Valore della proprietà

Double
Vedi anche

Documentazione

Classe BomItemWrapper
Namespace DedNet.Forms


Proprietà BomItemWrapper.RealBomItem

Proprietà BomItemWrapperRealBomItem
Oggetto BomItem associato (nel caso l'elemento fosse già associato alla distinta [non nuovo])

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItem RealBomItem { get; set; }
Public Property RealBomItem As BomItem
    Get
    Set
public:
property BomItem^ RealBomItem {
    BomItem^ get ();
    void set (BomItem^ value);
}
member RealBomItem : BomItem with get, set

Valore della proprietà

BomItem
Vedi anche

Documentazione

Classe BomItemWrapper
Namespace DedNet.Forms


Metodi di BomItemWrapper

Il tipo BomItemWrapper espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetHashCode | Vengono riconosciuti uguali gli elementi che hanno tutti i campi uguali tranne QTA che non concorre come discriminante. (Sovrascrive ObjectGetHashCode)
Metodo pubblico | GetValue | Permette di settare i valori degli attributi di distinta.
Metodo pubblico | IsModified | Restituisce true se l'elemento era gia presente in distinta ed è stato modificato rispetto al BomItem iniziale.
Metodo pubblico | SetValue | Legge i valori degli attributi di distinta
Torna su
Vedi anche

Documentazione

Classe BomItemWrapper
Namespace DedNet.Forms


Metodo BomItemWrapper.Equals

Metodo BomItemWrapperEquals

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj Object

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe BomItemWrapper
Namespace DedNet.Forms


Metodo BomItemWrapper.GetHashCode

Metodo BomItemWrapperGetHashCode
Vengono riconosciuti uguali gli elementi che hanno tutti i campi uguali tranne QTA che non concorre come discriminante.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Int32
L'hashcode di questo oggetto.
Vedi anche

Documentazione

Classe BomItemWrapper
Namespace DedNet.Forms


Metodo BomItemWrapper.GetValue

Metodo BomItemWrapperGetValue
Permette di settare i valori degli attributi di distinta.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object GetValue(
    string key
)
Public Function GetValue (
    key As String
) As Object
public:
Object^ GetValue(
    String^ key
)
member GetValue :
        key : string -> Object

Parametri

key String
Nome attributo

Valore di ritorno

Object
Vedi anche

Documentazione

Classe BomItemWrapper
Namespace DedNet.Forms


Metodo BomItemWrapper.IsModified

Metodo BomItemWrapperIsModified
Restituisce true se l'elemento era gia presente in distinta ed è stato modificato rispetto al BomItem iniziale.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsModified()
Public Function IsModified As Boolean
public:
bool IsModified()
member IsModified : unit -> bool

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe BomItemWrapper
Namespace DedNet.Forms


Metodo BomItemWrapper.SetValue

Metodo BomItemWrapperSetValue
Legge i valori degli attributi di distinta

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetValue(
    string key,
    Object value
)
Public Sub SetValue (
    key As String,
    value As Object
)
public:
void SetValue(
    String^ key,
    Object^ value
)
member SetValue :
        key : string *
        value : Object -> unit

Parametri

key String
Nome attributo
value Object
Valore
Vedi anche

Documentazione

Classe BomItemWrapper
Namespace DedNet.Forms


Classe CascadeBinder
Classe da bindare alla griglia.
Gerarchia di ereditarietà
SystemObject
System.ComponentModelMarshalByValueComponent
System.DataDataTable
DedNet.FormsCascadeBinder

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class CascadeBinder : DataTable
Public Class CascadeBinder
    Inherits DataTable
public ref class CascadeBinder : public DataTable
type CascadeBinder =
    class
        inherit DataTable
    end

Il tipo CascadeBinder espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | CascadeBinder | Costruttore unico.
Metodo pubblico | CascadeBinder(DedCascade, DedAttrList) | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AttrList | Lista degli attributi.
Proprietà pubblica | Cascade | Restituisce la cascata.
Proprietà pubblica | Item | Indexer della classe.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Add | Metodo di aggiunta di una riga.
Metodo pubblico | GetExistingRowByDependency | Restituisce la riga di cui fa parte la dipendenza passata.
Metodo pubblico | GetNewRow | Metodo che crea e ritorna una nuova riga.
Metodo protetto | GetRowType | Ritorna il tipo della riga. (Sovrascrive DataTableGetRowType)
Metodo protetto | NewRowFromBuilder | Crea e ritorna una nuova riga. (Sovrascrive DataTableNewRowFromBuilder(DataRowBuilder))
Metodo pubblico | Remove | Metodo di eliminazione di una riga.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore CascadeBinder
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | CascadeBinder | Costruttore unico.
Metodo pubblico | CascadeBinder(DedCascade, DedAttrList) | Costruttore unico.
Torna su
Vedi anche

Documentazione

Classe CascadeBinder
Namespace DedNet.Forms


Costruttore CascadeBinder
Costruttore unico.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public CascadeBinder()
Public Sub New
public:
CascadeBinder()
new : unit -> CascadeBinder
Vedi anche

Documentazione

Classe CascadeBinder
Overload di CascadeBinder
Namespace DedNet.Forms


Costruttore CascadeBinder(DedCascade, DedAttrList)
Costruttore unico.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public CascadeBinder(
    DedCascade cascade,
    DedAttrList attrList
)
Public Sub New (
    cascade As DedCascade,
    attrList As DedAttrList
)
public:
CascadeBinder(
    DedCascade^ cascade,
    DedAttrList^ attrList
)
new :
        cascade : DedCascade *
        attrList : DedAttrList -> CascadeBinder

Parametri

cascade DedCascade
Cascata da caricare.
attrList DedAttrList
Lista degli attributi.
Vedi anche

Documentazione

Classe CascadeBinder
Overload di CascadeBinder
Namespace DedNet.Forms


Proprietà di CascadeBinder

Il tipo CascadeBinder espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AttrList | Lista degli attributi.
Proprietà pubblica | Cascade | Restituisce la cascata.
Proprietà pubblica | Item | Indexer della classe.
Torna su
Vedi anche

Documentazione

Classe CascadeBinder
Namespace DedNet.Forms


Proprietà CascadeBinder.AttrList

Proprietà CascadeBinderAttrList
Lista degli attributi.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList AttrList { get; }
Public ReadOnly Property AttrList As DedAttrList
    Get
public:
property DedAttrList^ AttrList {
    DedAttrList^ get ();
}
member AttrList : DedAttrList with get

Valore della proprietà

DedAttrList
Vedi anche

Documentazione

Classe CascadeBinder
Namespace DedNet.Forms


Proprietà CascadeBinder.Cascade

Proprietà CascadeBinderCascade
Restituisce la cascata.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCascade Cascade { get; }
Public ReadOnly Property Cascade As DedCascade
    Get
public:
property DedCascade^ Cascade {
    DedCascade^ get ();
}
member Cascade : DedCascade with get

Valore della proprietà

DedCascade
Vedi anche

Documentazione

Classe CascadeBinder
Namespace DedNet.Forms


Proprietà CascadeBinder.Item

Proprietà CascadeBinderItem
Indexer della classe.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public CascadeRow this[
    int idx
] { get; }
Public ReadOnly Default Property Item (
    idx As Integer
) As CascadeRow
    Get
public:
property CascadeRow^ default[int idx] {
    CascadeRow^ get (int idx);
}
member Item : CascadeRow with get

Parametri

idx Int32
Indice.

Valore della proprietà

CascadeRow
Vedi anche

Documentazione

Classe CascadeBinder
Namespace DedNet.Forms


Metodi di CascadeBinder

Il tipo CascadeBinder espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Add | Metodo di aggiunta di una riga.
Metodo pubblico | GetExistingRowByDependency | Restituisce la riga di cui fa parte la dipendenza passata.
Metodo pubblico | GetNewRow | Metodo che crea e ritorna una nuova riga.
Metodo protetto | GetRowType | Ritorna il tipo della riga. (Sovrascrive DataTableGetRowType)
Metodo protetto | NewRowFromBuilder | Crea e ritorna una nuova riga. (Sovrascrive DataTableNewRowFromBuilder(DataRowBuilder))
Metodo pubblico | Remove | Metodo di eliminazione di una riga.
Torna su
Vedi anche

Documentazione

Classe CascadeBinder
Namespace DedNet.Forms


Metodo CascadeBinder.Add

Metodo CascadeBinderAdd
Metodo di aggiunta di una riga.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Add(
    CascadeRow row
)
Public Sub Add (
    row As CascadeRow
)
public:
void Add(
    CascadeRow^ row
)
member Add :
        row : CascadeRow -> unit

Parametri

row CascadeRow
Vedi anche

Documentazione

Classe CascadeBinder
Namespace DedNet.Forms


Metodo CascadeBinder.GetExistingRowByDependency

Metodo CascadeBinderGetExistingRowByDependency
Restituisce la riga di cui fa parte la dipendenza passata.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public CascadeRow GetExistingRowByDependency(
    DedCascadeDependency item
)
Public Function GetExistingRowByDependency (
    item As DedCascadeDependency
) As CascadeRow
public:
CascadeRow^ GetExistingRowByDependency(
    DedCascadeDependency^ item
)
member GetExistingRowByDependency :
        item : DedCascadeDependency -> CascadeRow

Parametri

item DedCascadeDependency

Valore di ritorno

CascadeRow
Vedi anche

Documentazione

Classe CascadeBinder
Namespace DedNet.Forms


Metodo CascadeBinder.GetNewRow

Metodo CascadeBinderGetNewRow
Metodo che crea e ritorna una nuova riga.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public CascadeRow GetNewRow()
Public Function GetNewRow As CascadeRow
public:
CascadeRow^ GetNewRow()
member GetNewRow : unit -> CascadeRow

Valore di ritorno

CascadeRow
Vedi anche

Documentazione

Classe CascadeBinder
Namespace DedNet.Forms


Metodo CascadeBinder.GetRowType

Metodo CascadeBinderGetRowType
Ritorna il tipo della riga.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override Type GetRowType()
Protected Overrides Function GetRowType As Type
protected:
virtual Type^ GetRowType() override
abstract GetRowType : unit -> Type
override GetRowType : unit -> Type

Valore di ritorno

Type
Vedi anche

Documentazione

Classe CascadeBinder
Namespace DedNet.Forms


Metodo CascadeBinder.NewRowFromBuilder

Metodo CascadeBinderNewRowFromBuilder
Crea e ritorna una nuova riga.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override DataRow NewRowFromBuilder(
    DataRowBuilder builder
)
Protected Overrides Function NewRowFromBuilder (
    builder As DataRowBuilder
) As DataRow
protected:
virtual DataRow^ NewRowFromBuilder(
    DataRowBuilder^ builder
) override
abstract NewRowFromBuilder :
        builder : DataRowBuilder -> DataRow
override NewRowFromBuilder :
        builder : DataRowBuilder -> DataRow

Parametri

builder DataRowBuilder

Valore di ritorno

DataRow
Vedi anche

Documentazione

Classe CascadeBinder
Namespace DedNet.Forms


Metodo CascadeBinder.Remove

Metodo CascadeBinderRemove
Metodo di eliminazione di una riga.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Remove(
    CascadeRow row
)
Public Sub Remove (
    row As CascadeRow
)
public:
void Remove(
    CascadeRow^ row
)
member Remove :
        row : CascadeRow -> unit

Parametri

row CascadeRow
Vedi anche

Documentazione

Classe CascadeBinder
Namespace DedNet.Forms


Classe CascadeRow
Riga del CascadeBinder.
Gerarchia di ereditarietà
SystemObject
System.DataDataRow
DedNet.FormsCascadeRow

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class CascadeRow : DataRow
Public Class CascadeRow
    Inherits DataRow
public ref class CascadeRow : public DataRow
type CascadeRow =
    class
        inherit DataRow
    end

Il tipo CascadeRow espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Dep | Dipendenze contenute nella riga.
Proprietà pubblica | Editable | Indica se le celle della riga sono editabili.
Proprietà pubblica | ValPadre | Valore padre comune a tutte le dipendenze della riga.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Proprietà di CascadeRow

Il tipo CascadeRow espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Dep | Dipendenze contenute nella riga.
Proprietà pubblica | Editable | Indica se le celle della riga sono editabili.
Proprietà pubblica | ValPadre | Valore padre comune a tutte le dipendenze della riga.
Torna su
Vedi anche

Documentazione

Classe CascadeRow
Namespace DedNet.Forms


Proprietà CascadeRow.Dep

Proprietà CascadeRowDep
Dipendenze contenute nella riga.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<DedCascadeDependency> Dep { get; }
Public ReadOnly Property Dep As List(Of DedCascadeDependency)
    Get
public:
property List<DedCascadeDependency^>^ Dep {
    List<DedCascadeDependency^>^ get ();
}
member Dep : List<DedCascadeDependency> with get

Valore della proprietà

List DedCascadeDependency
Vedi anche

Documentazione

Classe CascadeRow
Namespace DedNet.Forms


Proprietà CascadeRow.Editable

Proprietà CascadeRowEditable
Indica se le celle della riga sono editabili.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Editable { get; }
Public ReadOnly Property Editable As Boolean
    Get
public:
property bool Editable {
    bool get ();
}
member Editable : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CascadeRow
Namespace DedNet.Forms


Proprietà CascadeRow.ValPadre

Proprietà CascadeRowValPadre
Valore padre comune a tutte le dipendenze della riga.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object ValPadre { get; }
Public ReadOnly Property ValPadre As Object
    Get
public:
property Object^ ValPadre {
    Object^ get ();
}
member ValPadre : Object with get

Valore della proprietà

Object
Vedi anche

Documentazione

Classe CascadeRow
Namespace DedNet.Forms


Classe ChoiceItem
Classe usata per gestire la scelta dell'attributo su cui creare una nuova cascata.
Gerarchia di ereditarietà
SystemObject
DedNet.FormsChoiceItem

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ChoiceItem
Public Class ChoiceItem
public ref class ChoiceItem
type ChoiceItem = class end

Il tipo ChoiceItem espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ChoiceItem |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Attr | Attributo.
Proprietà pubblica | Prompt | Prompt.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore ChoiceItem

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ChoiceItem()
Public Sub New
public:
ChoiceItem()
new : unit -> ChoiceItem
Vedi anche

Documentazione

Classe ChoiceItem
Namespace DedNet.Forms


Proprietà di ChoiceItem

Il tipo ChoiceItem espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Attr | Attributo.
Proprietà pubblica | Prompt | Prompt.
Torna su
Vedi anche

Documentazione

Classe ChoiceItem
Namespace DedNet.Forms


Proprietà ChoiceItem.Attr

Proprietà ChoiceItemAttr
Attributo.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttr Attr { get; set; }
Public Property Attr As DedAttr
    Get
    Set
public:
property DedAttr^ Attr {
    DedAttr^ get ();
    void set (DedAttr^ value);
}
member Attr : DedAttr with get, set

Valore della proprietà

DedAttr
Vedi anche

Documentazione

Classe ChoiceItem
Namespace DedNet.Forms


Proprietà ChoiceItem.Prompt

Proprietà ChoiceItemPrompt
Prompt.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Prompt { get; set; }
Public Property Prompt As String
    Get
    Set
public:
property String^ Prompt {
    String^ get ();
    void set (String^ value);
}
member Prompt : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe ChoiceItem
Namespace DedNet.Forms


Classe ChoiceItemList
Lista di ChoiceItem.
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList ChoiceItem
DedNet.FormsChoiceItemList

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ChoiceItemList : List<ChoiceItem>
Public Class ChoiceItemList
    Inherits List(Of ChoiceItem)
public ref class ChoiceItemList : public List<ChoiceItem^>
type ChoiceItemList =
    class
        inherit List<ChoiceItem>
    end

Il tipo ChoiceItemList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ChoiceItemList |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Contains | Ritorna true se la lista contiene un Item con l'attributo passato.
Metodo pubblico | Remove | Rimuove dalla lista l'Item corrispondente all'attributo passato.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore ChoiceItemList

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ChoiceItemList()
Public Sub New
public:
ChoiceItemList()
new : unit -> ChoiceItemList
Vedi anche

Documentazione

Classe ChoiceItemList
Namespace DedNet.Forms


Metodi di ChoiceItemList

Il tipo ChoiceItemList espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Contains | Ritorna true se la lista contiene un Item con l'attributo passato.
Metodo pubblico | Remove | Rimuove dalla lista l'Item corrispondente all'attributo passato.
Torna su
Vedi anche

Documentazione

Classe ChoiceItemList
Namespace DedNet.Forms


Metodo ChoiceItemList.Contains

Metodo ChoiceItemListContains
Ritorna true se la lista contiene un Item con l'attributo passato.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Contains(
    DedAttr attr
)
Public Function Contains (
    attr As DedAttr
) As Boolean
public:
bool Contains(
    DedAttr^ attr
)
member Contains :
        attr : DedAttr -> bool

Parametri

attr DedAttr
Attributo da cercare.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe ChoiceItemList
Namespace DedNet.Forms


Metodo ChoiceItemList.Remove

Metodo ChoiceItemListRemove
Rimuove dalla lista l'Item corrispondente all'attributo passato.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Remove(
    DedAttr attr
)
Public Function Remove (
    attr As DedAttr
) As Boolean
public:
bool Remove(
    DedAttr^ attr
)
member Remove :
        attr : DedAttr -> bool

Parametri

attr DedAttr
Attributo da rimuovere.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe ChoiceItemList
Namespace DedNet.Forms


Classe CommAnagrItemWrapper
Classe wrapper da bindare alla griglia
Gerarchia di ereditarietà
SystemObject
DedNet.FormsCommAnagrItemWrapper

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class CommAnagrItemWrapper
Public Class CommAnagrItemWrapper
public ref class CommAnagrItemWrapper
type CommAnagrItemWrapper = class end

Il tipo CommAnagrItemWrapper espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | CommAnagrItemWrapper | Costruttore per le nuove righe
Metodo pubblico | CommAnagrItemWrapper(DedCommAnagrItem) | Costrutto per gli elementi che erano già presenti in commessa
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AttributesAnagrComm | Lista degli attributi di anagrafica di commessa
Proprietà pubblica | Attrs | Accoppiata nome-valore degli attributi di anagrafica di commessa
Proprietà pubblica | IsRowAdded | Indica se è una riga nuova
Proprietà pubblica | Qta | Quantità
Proprietà pubblica | RealCommAnagItem | Oggetto DedCommAnagrItem associato
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetHashCode | Vengono riconosciuti uguali gli elementi che hanno tutti i campi uguali tranne QTA che non concorre come discriminante. (Sovrascrive ObjectGetHashCode)
Metodo pubblico | GetValue | Permette di settare i valori degli attributi di anagrafica di commessa.
Metodo pubblico | IsModified | Restituisce true se l'elemento era gia presente in commessa ed è stato modificato rispetto al DedCommAnagrItem iniziale.
Metodo pubblico | SetValue | Legge i valori degli attributi di anagrafica di commessa
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore CommAnagrItemWrapper
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | CommAnagrItemWrapper | Costruttore per le nuove righe
Metodo pubblico | CommAnagrItemWrapper(DedCommAnagrItem) | Costrutto per gli elementi che erano già presenti in commessa
Torna su
Vedi anche

Documentazione

Classe CommAnagrItemWrapper
Namespace DedNet.Forms


Costruttore CommAnagrItemWrapper
Costruttore per le nuove righe

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public CommAnagrItemWrapper()
Public Sub New
public:
CommAnagrItemWrapper()
new : unit -> CommAnagrItemWrapper
Vedi anche

Documentazione

Classe CommAnagrItemWrapper
Overload di CommAnagrItemWrapper
Namespace DedNet.Forms


Costruttore CommAnagrItemWrapper(DedCommAnagrItem)
Costrutto per gli elementi che erano già presenti in commessa

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public CommAnagrItemWrapper(
    DedCommAnagrItem item
)
Public Sub New (
    item As DedCommAnagrItem
)
public:
CommAnagrItemWrapper(
    DedCommAnagrItem^ item
)
new :
        item : DedCommAnagrItem -> CommAnagrItemWrapper

Parametri

item DedCommAnagrItem
DedCommAnagrItem di riferimento
Vedi anche

Documentazione

Classe CommAnagrItemWrapper
Overload di CommAnagrItemWrapper
Namespace DedNet.Forms


Proprietà di CommAnagrItemWrapper

Il tipo CommAnagrItemWrapper espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AttributesAnagrComm | Lista degli attributi di anagrafica di commessa
Proprietà pubblica | Attrs | Accoppiata nome-valore degli attributi di anagrafica di commessa
Proprietà pubblica | IsRowAdded | Indica se è una riga nuova
Proprietà pubblica | Qta | Quantità
Proprietà pubblica | RealCommAnagItem | Oggetto DedCommAnagrItem associato
Torna su
Vedi anche

Documentazione

Classe CommAnagrItemWrapper
Namespace DedNet.Forms


Proprietà CommAnagrItemWrapper.AttributesAnagrComm

Proprietà CommAnagrItemWrapperAttributesAnagrComm
Lista degli attributi di anagrafica di commessa

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList AttributesAnagrComm { get; }
Public ReadOnly Property AttributesAnagrComm As DedAttrList
    Get
public:
property DedAttrList^ AttributesAnagrComm {
    DedAttrList^ get ();
}
member AttributesAnagrComm : DedAttrList with get

Valore della proprietà

DedAttrList
Vedi anche

Documentazione

Classe CommAnagrItemWrapper
Namespace DedNet.Forms


Proprietà CommAnagrItemWrapper.Attrs

Proprietà CommAnagrItemWrapperAttrs
Accoppiata nome-valore degli attributi di anagrafica di commessa

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<string, Object> Attrs { get; set; }
Public Property Attrs As Dictionary(Of String, Object)
    Get
    Set
public:
property Dictionary<String^, Object^>^ Attrs {
    Dictionary<String^, Object^>^ get ();
    void set (Dictionary<String^, Object^>^ value);
}
member Attrs : Dictionary<string, Object> with get, set

Valore della proprietà

Dictionary String, Object
Vedi anche

Documentazione

Classe CommAnagrItemWrapper
Namespace DedNet.Forms


Proprietà CommAnagrItemWrapper.IsRowAdded

Proprietà CommAnagrItemWrapperIsRowAdded
Indica se è una riga nuova

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsRowAdded { get; set; }
Public Property IsRowAdded As Boolean
    Get
    Set
public:
property bool IsRowAdded {
    bool get ();
    void set (bool value);
}
member IsRowAdded : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe CommAnagrItemWrapper
Namespace DedNet.Forms


Proprietà CommAnagrItemWrapper.Qta

Proprietà CommAnagrItemWrapperQta
Quantità

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public double Qta { get; set; }
Public Property Qta As Double
    Get
    Set
public:
property double Qta {
    double get ();
    void set (double value);
}
member Qta : float with get, set

Valore della proprietà

Double
Vedi anche

Documentazione

Classe CommAnagrItemWrapper
Namespace DedNet.Forms


Proprietà CommAnagrItemWrapper.RealCommAnagItem

Proprietà CommAnagrItemWrapperRealCommAnagItem
Oggetto DedCommAnagrItem associato

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommAnagrItem RealCommAnagItem { get; set; }
Public Property RealCommAnagItem As DedCommAnagrItem
    Get
    Set
public:
property DedCommAnagrItem^ RealCommAnagItem {
    DedCommAnagrItem^ get ();
    void set (DedCommAnagrItem^ value);
}
member RealCommAnagItem : DedCommAnagrItem with get, set

Valore della proprietà

DedCommAnagrItem
Vedi anche

Documentazione

Classe CommAnagrItemWrapper
Namespace DedNet.Forms


Metodi di CommAnagrItemWrapper

Il tipo CommAnagrItemWrapper espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetHashCode | Vengono riconosciuti uguali gli elementi che hanno tutti i campi uguali tranne QTA che non concorre come discriminante. (Sovrascrive ObjectGetHashCode)
Metodo pubblico | GetValue | Permette di settare i valori degli attributi di anagrafica di commessa.
Metodo pubblico | IsModified | Restituisce true se l'elemento era gia presente in commessa ed è stato modificato rispetto al DedCommAnagrItem iniziale.
Metodo pubblico | SetValue | Legge i valori degli attributi di anagrafica di commessa
Torna su
Vedi anche

Documentazione

Classe CommAnagrItemWrapper
Namespace DedNet.Forms


Metodo CommAnagrItemWrapper.Equals

Metodo CommAnagrItemWrapperEquals

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj Object

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe CommAnagrItemWrapper
Namespace DedNet.Forms


Metodo CommAnagrItemWrapper.GetHashCode

Metodo CommAnagrItemWrapperGetHashCode
Vengono riconosciuti uguali gli elementi che hanno tutti i campi uguali tranne QTA che non concorre come discriminante.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Int32
L'hashcode di questo oggetto.
Vedi anche

Documentazione

Classe CommAnagrItemWrapper
Namespace DedNet.Forms


Metodo CommAnagrItemWrapper.GetValue

Metodo CommAnagrItemWrapperGetValue
Permette di settare i valori degli attributi di anagrafica di commessa.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object GetValue(
    string key
)
Public Function GetValue (
    key As String
) As Object
public:
Object^ GetValue(
    String^ key
)
member GetValue :
        key : string -> Object

Parametri

key String
Nome attributo

Valore di ritorno

Object
Vedi anche

Documentazione

Classe CommAnagrItemWrapper
Namespace DedNet.Forms


Metodo CommAnagrItemWrapper.IsModified

Metodo CommAnagrItemWrapperIsModified
Restituisce true se l'elemento era gia presente in commessa ed è stato modificato rispetto al DedCommAnagrItem iniziale.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsModified()
Public Function IsModified As Boolean
public:
bool IsModified()
member IsModified : unit -> bool

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe CommAnagrItemWrapper
Namespace DedNet.Forms


Metodo CommAnagrItemWrapper.SetValue

Metodo CommAnagrItemWrapperSetValue
Legge i valori degli attributi di anagrafica di commessa

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetValue(
    string key,
    Object value
)
Public Sub SetValue (
    key As String,
    value As Object
)
public:
void SetValue(
    String^ key,
    Object^ value
)
member SetValue :
        key : string *
        value : Object -> unit

Parametri

key String
Nome attributo
value Object
Valore
Vedi anche

Documentazione

Classe CommAnagrItemWrapper
Namespace DedNet.Forms


Classe ControlloPermessi
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
XtraUserControl
DedNet.ControlsUserControlBase
DedNet.FormsControlloPermessi

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ControlloPermessi : UserControlBase
Public Class ControlloPermessi
    Inherits UserControlBase
public ref class ControlloPermessi : public UserControlBase
type ControlloPermessi =
    class
        inherit UserControlBase
    end

Il tipo ControlloPermessi espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ControlloPermessi | Costruttore.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Appearance | (Ereditato da XtraUserControl)
Proprietà pubblica | Application | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Proprietà pubblica | BackColor | (Ereditato da XtraUserControl)
Proprietà protetta | CheckDoubleScaling | (Ereditato da XtraUserControl)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraUserControl)
Proprietà protetta | DirectXContainer | (Ereditato da XtraUserControl)
Proprietà pubblica | EnableIXtraResizeableControlInterfaceProxy | (Ereditato da XtraUserControl)
Proprietà pubblica | Font | (Ereditato da XtraUserControl)
Proprietà pubblica | ForeColor | (Ereditato da XtraUserControl)
Proprietà protetta | Helper | (Ereditato da XtraUserControl)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraUserControl)
Proprietà protetta | Painter | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleChildren | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleDPI | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraUserControl)
Proprietà pubblica | SetReadOnly |
Proprietà protetta | ShouldCheckDpiScaleFactorOnParentChanged | (Ereditato da XtraUserControl)
Proprietà pubblica | ShowAdminPerm | Imposta la visualizzazione del permesso di amministrazione.
Proprietà pubblica | ShowAttributesPerm | Imposta la visualizzazione del permesso degli attributi.
Proprietà pubblica | ShowButtons | Imposta la visibilità dei pulsanti Dai Tutti e Togli Tutti.
Proprietà pubblica | ShowCommPerm | Imposta la visualizzazione del permesso di amministrazione.
Proprietà pubblica | ShowECOPerm | Imposta la visualizzazione del permesso per gli ECO.
Proprietà pubblica | ShowFamPerm | Imposta la visualizzazione del permesso di amministrazione.
Proprietà pubblica | ShowFolderPerm | Imposta la visualizzazione del permesso di amministrazione.
Proprietà pubblica | Site | (Ereditato da XtraUserControl)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AbilitaControlli | Metodo per abilitare i controlli dei permessi.
Metodo pubblico | ActivateAdminPage | Attiva la pagina dei permessi di amministazione.
Metodo pubblico | ActivateAttributesPage | Attiva la pagina dei permessi sugli attributi.
Metodo pubblico | ActivateCommPage | Attiva la pagina dei permessi sulle commesse.
Metodo pubblico | ActivateECOPage | Attiva la pagina dei permessi di amministazione.
Metodo pubblico | ActivateFamPage | Attiva la pagina dei permessi sulle famiglie.
Metodo pubblico | ActivateFolderPage | Attiva la pagina dei permessi sulle cartelle.
Metodo protetto | BaseWndProc | (Ereditato da XtraUserControl)
Metodo pubblico | CambiaTutti | Imposta tutti i permessi.
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraUserControl)
Metodo protetto | CreatePainter | (Ereditato da XtraUserControl)
Metodo pubblico | DisabilitaControlli | Metodo per disabilitare i controlli dei permessi.
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive UserControlBaseDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraUserControl)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraUserControl)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraUserControl)
Metodo protetto | GetBackColor | (Ereditato da XtraUserControl)
Metodo protetto | GetBackgroundSkinElement | (Ereditato da XtraUserControl)
Metodo protetto | GetInnerIXtraResizableControl | (Ereditato da XtraUserControl)
Metodo protetto | IsChildControlsRequiredScalingEnabled | (Ereditato da XtraUserControl)
Metodo protetto | IsParentHandleCreatedRecursive | (Ereditato da XtraUserControl)
Metodo pubblico | LoadRegistrySettings | Carica dal registro le dimensioni e la visibilità delle colonne.
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraUserControl)
Metodo protetto | OnBackColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnContextMenuOpening | Evento di apertura del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnControlAdded | (Ereditato da XtraUserControl)
Metodo protetto | OnControlRemoved | (Ereditato da XtraUserControl)
Metodo protetto | OnDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnFirstLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnForeColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleCreated | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraUserControl)
Metodo pubblico | OnItemCheck |
Metodo protetto | OnLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnMenuItemClicked | Evento di pressione di un comando del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnPaintCore | (Ereditato da XtraUserControl)
Metodo protetto | OnParentChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | OnSizeChanged | (Ereditato da XtraUserControl)
Metodo protetto | RaisePaintExEvent | (Ereditato da XtraUserControl)
Metodo pubblico | ResetBackColor | (Ereditato da XtraUserControl)
Metodo pubblico | ResetForeColor | (Ereditato da XtraUserControl)
Metodo protetto | RestoreAutoScaleModeChangedByPM2 | (Ereditato da XtraUserControl)
Metodo pubblico | SaveRegistrySettings | Salva nel registro le dimensioni e la visibilità delle colonne.
Metodo protetto | ScaleControl | (Ereditato da XtraUserControl)
Metodo pubblico | SetCommandList | Rigenera il menu contestuale di questo controllo con la lista dei comandi passati. (Ereditato da UserControlBase)
Metodo protetto | SetVisibleCore | (Ereditato da XtraUserControl)
Metodo protetto | ShouldPaintTransparentBackground | (Ereditato da XtraUserControl)
Metodo protetto | ShouldUseDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | WndProc | (Ereditato da XtraUserControl)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | ContextMenuOpening | Evento su apertura del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | MenuItemClicked | Evento su click su un elemento del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | PaintEx | (Ereditato da XtraUserControl)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | _app | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Campo protetto | _RegistryBaseKey | Chiave nel registro di sistema di salvataggio impostazioni. (Ereditato da UserControlBase)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore ControlloPermessi
Costruttore.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ControlloPermessi()
Public Sub New
public:
ControlloPermessi()
new : unit -> ControlloPermessi
Vedi anche

Documentazione

Classe ControlloPermessi
Namespace DedNet.Forms


Proprietà di ControlloPermessi

Il tipo ControlloPermessi espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Appearance | (Ereditato da XtraUserControl)
Proprietà pubblica | Application | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Proprietà pubblica | BackColor | (Ereditato da XtraUserControl)
Proprietà protetta | CheckDoubleScaling | (Ereditato da XtraUserControl)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraUserControl)
Proprietà protetta | DirectXContainer | (Ereditato da XtraUserControl)
Proprietà pubblica | EnableIXtraResizeableControlInterfaceProxy | (Ereditato da XtraUserControl)
Proprietà pubblica | Font | (Ereditato da XtraUserControl)
Proprietà pubblica | ForeColor | (Ereditato da XtraUserControl)
Proprietà protetta | Helper | (Ereditato da XtraUserControl)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraUserControl)
Proprietà protetta | Painter | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleChildren | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleDPI | (Ereditato da XtraUserControl)
Proprietà protetta | ScaleHelper | (Ereditato da XtraUserControl)
Proprietà pubblica | SetReadOnly |
Proprietà protetta | ShouldCheckDpiScaleFactorOnParentChanged | (Ereditato da XtraUserControl)
Proprietà pubblica | ShowAdminPerm | Imposta la visualizzazione del permesso di amministrazione.
Proprietà pubblica | ShowAttributesPerm | Imposta la visualizzazione del permesso degli attributi.
Proprietà pubblica | ShowButtons | Imposta la visibilità dei pulsanti Dai Tutti e Togli Tutti.
Proprietà pubblica | ShowCommPerm | Imposta la visualizzazione del permesso di amministrazione.
Proprietà pubblica | ShowECOPerm | Imposta la visualizzazione del permesso per gli ECO.
Proprietà pubblica | ShowFamPerm | Imposta la visualizzazione del permesso di amministrazione.
Proprietà pubblica | ShowFolderPerm | Imposta la visualizzazione del permesso di amministrazione.
Proprietà pubblica | Site | (Ereditato da XtraUserControl)
Torna su
Vedi anche

Documentazione

Classe ControlloPermessi
Namespace DedNet.Forms


Proprietà ControlloPermessi.SetReadOnly

Proprietà ControlloPermessiSetReadOnly

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool SetReadOnly { set; }
Public WriteOnly Property SetReadOnly As Boolean
    Set
public:
property bool SetReadOnly {
    void set (bool value);
}
member SetReadOnly : bool with set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ControlloPermessi
Namespace DedNet.Forms


Proprietà ControlloPermessi.ShowAdminPerm

Proprietà ControlloPermessiShowAdminPerm
Imposta la visualizzazione del permesso di amministrazione.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ShowAdminPerm { get; set; }
Public Property ShowAdminPerm As Boolean
    Get
    Set
public:
property bool ShowAdminPerm {
    bool get ();
    void set (bool value);
}
member ShowAdminPerm : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ControlloPermessi
Namespace DedNet.Forms


Proprietà ControlloPermessi.ShowAttributesPerm

Proprietà ControlloPermessiShowAttributesPerm
Imposta la visualizzazione del permesso degli attributi.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ShowAttributesPerm { get; set; }
Public Property ShowAttributesPerm As Boolean
    Get
    Set
public:
property bool ShowAttributesPerm {
    bool get ();
    void set (bool value);
}
member ShowAttributesPerm : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ControlloPermessi
Namespace DedNet.Forms


Proprietà ControlloPermessi.ShowButtons

Proprietà ControlloPermessiShowButtons
Imposta la visibilità dei pulsanti Dai Tutti e Togli Tutti.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ShowButtons { get; set; }
Public Property ShowButtons As Boolean
    Get
    Set
public:
property bool ShowButtons {
    bool get ();
    void set (bool value);
}
member ShowButtons : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ControlloPermessi
Namespace DedNet.Forms


Proprietà ControlloPermessi.ShowCommPerm

Proprietà ControlloPermessiShowCommPerm
Imposta la visualizzazione del permesso di amministrazione.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ShowCommPerm { get; set; }
Public Property ShowCommPerm As Boolean
    Get
    Set
public:
property bool ShowCommPerm {
    bool get ();
    void set (bool value);
}
member ShowCommPerm : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ControlloPermessi
Namespace DedNet.Forms


Proprietà ControlloPermessi.ShowECOPerm

Proprietà ControlloPermessiShowECOPerm
Imposta la visualizzazione del permesso per gli ECO.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ShowECOPerm { get; set; }
Public Property ShowECOPerm As Boolean
    Get
    Set
public:
property bool ShowECOPerm {
    bool get ();
    void set (bool value);
}
member ShowECOPerm : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ControlloPermessi
Namespace DedNet.Forms


Proprietà ControlloPermessi.ShowFamPerm

Proprietà ControlloPermessiShowFamPerm
Imposta la visualizzazione del permesso di amministrazione.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ShowFamPerm { get; set; }
Public Property ShowFamPerm As Boolean
    Get
    Set
public:
property bool ShowFamPerm {
    bool get ();
    void set (bool value);
}
member ShowFamPerm : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ControlloPermessi
Namespace DedNet.Forms


Proprietà ControlloPermessi.ShowFolderPerm

Proprietà ControlloPermessiShowFolderPerm
Imposta la visualizzazione del permesso di amministrazione.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ShowFolderPerm { get; set; }
Public Property ShowFolderPerm As Boolean
    Get
    Set
public:
property bool ShowFolderPerm {
    bool get ();
    void set (bool value);
}
member ShowFolderPerm : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ControlloPermessi
Namespace DedNet.Forms


Metodi di ControlloPermessi

Il tipo ControlloPermessi espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AbilitaControlli | Metodo per abilitare i controlli dei permessi.
Metodo pubblico | ActivateAdminPage | Attiva la pagina dei permessi di amministazione.
Metodo pubblico | ActivateAttributesPage | Attiva la pagina dei permessi sugli attributi.
Metodo pubblico | ActivateCommPage | Attiva la pagina dei permessi sulle commesse.
Metodo pubblico | ActivateECOPage | Attiva la pagina dei permessi di amministazione.
Metodo pubblico | ActivateFamPage | Attiva la pagina dei permessi sulle famiglie.
Metodo pubblico | ActivateFolderPage | Attiva la pagina dei permessi sulle cartelle.
Metodo protetto | BaseWndProc | (Ereditato da XtraUserControl)
Metodo pubblico | CambiaTutti | Imposta tutti i permessi.
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraUserControl)
Metodo protetto | CreatePainter | (Ereditato da XtraUserControl)
Metodo pubblico | DisabilitaControlli | Metodo per disabilitare i controlli dei permessi.
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive UserControlBaseDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraUserControl)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraUserControl)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraUserControl)
Metodo protetto | GetBackColor | (Ereditato da XtraUserControl)
Metodo protetto | GetBackgroundSkinElement | (Ereditato da XtraUserControl)
Metodo protetto | GetInnerIXtraResizableControl | (Ereditato da XtraUserControl)
Metodo protetto | IsChildControlsRequiredScalingEnabled | (Ereditato da XtraUserControl)
Metodo protetto | IsParentHandleCreatedRecursive | (Ereditato da XtraUserControl)
Metodo pubblico | LoadRegistrySettings | Carica dal registro le dimensioni e la visibilità delle colonne.
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraUserControl)
Metodo protetto | OnBackColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnContextMenuOpening | Evento di apertura del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnControlAdded | (Ereditato da XtraUserControl)
Metodo protetto | OnControlRemoved | (Ereditato da XtraUserControl)
Metodo protetto | OnDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnFirstLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnForeColorChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleCreated | (Ereditato da XtraUserControl)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraUserControl)
Metodo pubblico | OnItemCheck |
Metodo protetto | OnLoad | (Ereditato da XtraUserControl)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnMenuItemClicked | Evento di pressione di un comando del menù contestuale. (Ereditato da UserControlBase)
Metodo protetto | OnPaint | (Ereditato da XtraUserControl)
Metodo protetto | OnPaintCore | (Ereditato da XtraUserControl)
Metodo protetto | OnParentChanged | (Ereditato da XtraUserControl)
Metodo protetto | OnScaleControl | (Ereditato da XtraUserControl)
Metodo protetto | OnSizeChanged | (Ereditato da XtraUserControl)
Metodo protetto | RaisePaintExEvent | (Ereditato da XtraUserControl)
Metodo pubblico | ResetBackColor | (Ereditato da XtraUserControl)
Metodo pubblico | ResetForeColor | (Ereditato da XtraUserControl)
Metodo protetto | RestoreAutoScaleModeChangedByPM2 | (Ereditato da XtraUserControl)
Metodo pubblico | SaveRegistrySettings | Salva nel registro le dimensioni e la visibilità delle colonne.
Metodo protetto | ScaleControl | (Ereditato da XtraUserControl)
Metodo pubblico | SetCommandList | Rigenera il menu contestuale di questo controllo con la lista dei comandi passati. (Ereditato da UserControlBase)
Metodo protetto | SetVisibleCore | (Ereditato da XtraUserControl)
Metodo protetto | ShouldPaintTransparentBackground | (Ereditato da XtraUserControl)
Metodo protetto | ShouldUseDirectXPaint | (Ereditato da XtraUserControl)
Metodo protetto | WndProc | (Ereditato da XtraUserControl)
Torna su
Vedi anche

Documentazione

Classe ControlloPermessi
Namespace DedNet.Forms


Metodo ControlloPermessi.AbilitaControlli

Metodo ControlloPermessiAbilitaControlli
Metodo per abilitare i controlli dei permessi.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AbilitaControlli()
Public Sub AbilitaControlli
public:
void AbilitaControlli()
member AbilitaControlli : unit -> unit
Vedi anche

Documentazione

Classe ControlloPermessi
Namespace DedNet.Forms


Metodo ControlloPermessi.ActivateAdminPage

Metodo ControlloPermessiActivateAdminPage
Attiva la pagina dei permessi di amministazione.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ActivateAdminPage()
Public Sub ActivateAdminPage
public:
void ActivateAdminPage()
member ActivateAdminPage : unit -> unit
Vedi anche

Documentazione

Classe ControlloPermessi
Namespace DedNet.Forms


Metodo ControlloPermessi.ActivateAttributesPage

Metodo ControlloPermessiActivateAttributesPage
Attiva la pagina dei permessi sugli attributi.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ActivateAttributesPage()
Public Sub ActivateAttributesPage
public:
void ActivateAttributesPage()
member ActivateAttributesPage : unit -> unit
Vedi anche

Documentazione

Classe ControlloPermessi
Namespace DedNet.Forms


Metodo ControlloPermessi.ActivateCommPage

Metodo ControlloPermessiActivateCommPage
Attiva la pagina dei permessi sulle commesse.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ActivateCommPage()
Public Sub ActivateCommPage
public:
void ActivateCommPage()
member ActivateCommPage : unit -> unit
Vedi anche

Documentazione

Classe ControlloPermessi
Namespace DedNet.Forms


Metodo ControlloPermessi.ActivateECOPage

Metodo ControlloPermessiActivateECOPage
Attiva la pagina dei permessi di amministazione.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ActivateECOPage()
Public Sub ActivateECOPage
public:
void ActivateECOPage()
member ActivateECOPage : unit -> unit
Vedi anche

Documentazione

Classe ControlloPermessi
Namespace DedNet.Forms


Metodo ControlloPermessi.ActivateFamPage

Metodo ControlloPermessiActivateFamPage
Attiva la pagina dei permessi sulle famiglie.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ActivateFamPage()
Public Sub ActivateFamPage
public:
void ActivateFamPage()
member ActivateFamPage : unit -> unit
Vedi anche

Documentazione

Classe ControlloPermessi
Namespace DedNet.Forms


Metodo ControlloPermessi.ActivateFolderPage

Metodo ControlloPermessiActivateFolderPage
Attiva la pagina dei permessi sulle cartelle.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ActivateFolderPage()
Public Sub ActivateFolderPage
public:
void ActivateFolderPage()
member ActivateFolderPage : unit -> unit
Vedi anche

Documentazione

Classe ControlloPermessi
Namespace DedNet.Forms


Metodo ControlloPermessi.CambiaTutti

Metodo ControlloPermessiCambiaTutti
Imposta tutti i permessi.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void CambiaTutti(
    bool daiTutti
)
Public Sub CambiaTutti (
    daiTutti As Boolean
)
public:
void CambiaTutti(
    bool daiTutti
)
member CambiaTutti :
        daiTutti : bool -> unit

Parametri

daiTutti Boolean
Vedi anche

Documentazione

Classe ControlloPermessi
Namespace DedNet.Forms


Metodo ControlloPermessi.DisabilitaControlli

Metodo ControlloPermessiDisabilitaControlli
Metodo per disabilitare i controlli dei permessi.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void DisabilitaControlli()
Public Sub DisabilitaControlli
public:
void DisabilitaControlli()
member DisabilitaControlli : unit -> unit
Vedi anche

Documentazione

Classe ControlloPermessi
Namespace DedNet.Forms


Metodo ControlloPermessi.Dispose

Metodo ControlloPermessiDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe ControlloPermessi
Namespace DedNet.Forms


Metodo ControlloPermessi.LoadRegistrySettings

Metodo ControlloPermessiLoadRegistrySettings
Carica dal registro le dimensioni e la visibilità delle colonne.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void LoadRegistrySettings(
    string key
)
Public Sub LoadRegistrySettings (
    key As String
)
public:
void LoadRegistrySettings(
    String^ key
)
member LoadRegistrySettings :
        key : string -> unit

Parametri

key String
Chiave di registro dalla quale leggere le impostazioni.
Vedi anche

Documentazione

Classe ControlloPermessi
Namespace DedNet.Forms


Metodo ControlloPermessi.OnItemCheck

Metodo ControlloPermessiOnItemCheck

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void OnItemCheck(
    Object sender,
    ItemCheckEventArgs e
)
Public Sub OnItemCheck (
    sender As Object,
    e As ItemCheckEventArgs
)
public:
void OnItemCheck(
    Object^ sender,
    ItemCheckEventArgs^ e
)
member OnItemCheck :
        sender : Object *
        e : ItemCheckEventArgs -> unit

Parametri

sender Object
e ItemCheckEventArgs
Vedi anche

Documentazione

Classe ControlloPermessi
Namespace DedNet.Forms


Metodo ControlloPermessi.SaveRegistrySettings

Metodo ControlloPermessiSaveRegistrySettings
Salva nel registro le dimensioni e la visibilità delle colonne.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SaveRegistrySettings(
    string key
)
Public Sub SaveRegistrySettings (
    key As String
)
public:
void SaveRegistrySettings(
    String^ key
)
member SaveRegistrySettings :
        key : string -> unit

Parametri

key String
Chiave di registro nella quale scrivere le impostazioni.
Vedi anche

Documentazione

Classe ControlloPermessi
Namespace DedNet.Forms


Eventi di ControlloPermessi

Il tipo ControlloPermessi espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | ContextMenuOpening | Evento su apertura del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | MenuItemClicked | Evento su click su un elemento del menu contestuale. (Ereditato da UserControlBase)
Evento pubblico | PaintEx | (Ereditato da XtraUserControl)
Torna su
Vedi anche

Documentazione

Classe ControlloPermessi
Namespace DedNet.Forms


Campi di ControlloPermessi

Il tipo ControlloPermessi espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | _app | Applicazione alla quale il controllo appartiene. (Ereditato da UserControlBase)
Campo protetto | _RegistryBaseKey | Chiave nel registro di sistema di salvataggio impostazioni. (Ereditato da UserControlBase)
Torna su
Vedi anche

Documentazione

Classe ControlloPermessi
Namespace DedNet.Forms


Classe ControlloPermessi.ItemPermObj

Classe ControlloPermessiItemPermObj
Gerarchia di ereditarietà
SystemObject
DedNet.FormsControlloPermessiItemPermObj

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ItemPermObj
Public Class ItemPermObj
public ref class ItemPermObj
type ItemPermObj = class end

Il tipo ControlloPermessiItemPermObj espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ControlloPermessiItemPermObj |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Check |
Proprietà pubblica | Descrizione |
Proprietà pubblica | Nome |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore ControlloPermessi.ItemPermObj

Costruttore ControlloPermessiItemPermObj

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ItemPermObj(
    string nome,
    string descrizione,
    bool check
)
Public Sub New (
    nome As String,
    descrizione As String,
    check As Boolean
)
public:
ItemPermObj(
    String^ nome,
    String^ descrizione,
    bool check
)
new :
        nome : string *
        descrizione : string *
        check : bool -> ItemPermObj

Parametri

nome String
descrizione String
check Boolean
Vedi anche

Documentazione

Classe ControlloPermessiItemPermObj
Namespace DedNet.Forms


Proprietà di ItemPermObj

Il tipo ControlloPermessiItemPermObj espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Check |
Proprietà pubblica | Descrizione |
Proprietà pubblica | Nome |
Torna su
Vedi anche

Documentazione

Classe ControlloPermessiItemPermObj
Namespace DedNet.Forms


Proprietà ControlloPermessi.ItemPermObj.Check

Proprietà ControlloPermessiItemPermObjCheck

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Check { get; set; }
Public Property Check As Boolean
    Get
    Set
public:
property bool Check {
    bool get ();
    void set (bool value);
}
member Check : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ControlloPermessiItemPermObj
Namespace DedNet.Forms


Proprietà ControlloPermessi.ItemPermObj.Descrizione

Proprietà ControlloPermessiItemPermObjDescrizione

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Descrizione { get; set; }
Public Property Descrizione As String
    Get
    Set
public:
property String^ Descrizione {
    String^ get ();
    void set (String^ value);
}
member Descrizione : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe ControlloPermessiItemPermObj
Namespace DedNet.Forms


Proprietà ControlloPermessi.ItemPermObj.Nome

Proprietà ControlloPermessiItemPermObjNome

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Nome { get; set; }
Public Property Nome As String
    Get
    Set
public:
property String^ Nome {
    String^ get ();
    void set (String^ value);
}
member Nome : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe ControlloPermessiItemPermObj
Namespace DedNet.Forms


Classe ControlloPermessi.UserPermSpec

Classe ControlloPermessiUserPermSpec
Classe utilizzata per visualizzare i permessi specifici dell'utente.
Gerarchia di ereditarietà
SystemObject
DedNet.FormsControlloPermessiUserPermSpec

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class UserPermSpec
Public Class UserPermSpec
public ref class UserPermSpec
type UserPermSpec = class end

Il tipo ControlloPermessiUserPermSpec espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ControlloPermessiUserPermSpec |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Perm |
Proprietà pubblica | Source |
Proprietà pubblica | Type |
Proprietà pubblica | Value |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore ControlloPermessi.UserPermSpec

Costruttore ControlloPermessiUserPermSpec

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public UserPermSpec(
    string type,
    string source,
    string perm,
    bool valore
)
Public Sub New (
    type As String,
    source As String,
    perm As String,
    valore As Boolean
)
public:
UserPermSpec(
    String^ type,
    String^ source,
    String^ perm,
    bool valore
)
new :
        type : string *
        source : string *
        perm : string *
        valore : bool -> UserPermSpec

Parametri

type String
source String
perm String
valore Boolean
Vedi anche

Documentazione

Classe ControlloPermessiUserPermSpec
Namespace DedNet.Forms


Proprietà di UserPermSpec

Il tipo ControlloPermessiUserPermSpec espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Perm |
Proprietà pubblica | Source |
Proprietà pubblica | Type |
Proprietà pubblica | Value |
Torna su
Vedi anche

Documentazione

Classe ControlloPermessiUserPermSpec
Namespace DedNet.Forms


Proprietà ControlloPermessi.UserPermSpec.Perm

Proprietà ControlloPermessiUserPermSpecPerm

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Perm { get; }
Public ReadOnly Property Perm As String
    Get
public:
property String^ Perm {
    String^ get ();
}
member Perm : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe ControlloPermessiUserPermSpec
Namespace DedNet.Forms


Proprietà ControlloPermessi.UserPermSpec.Source

Proprietà ControlloPermessiUserPermSpecSource

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Source { get; }
Public ReadOnly Property Source As String
    Get
public:
property String^ Source {
    String^ get ();
}
member Source : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe ControlloPermessiUserPermSpec
Namespace DedNet.Forms


Proprietà ControlloPermessi.UserPermSpec.Type

Proprietà ControlloPermessiUserPermSpecType

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Type { get; }
Public ReadOnly Property Type As String
    Get
public:
property String^ Type {
    String^ get ();
}
member Type : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe ControlloPermessiUserPermSpec
Namespace DedNet.Forms


Proprietà ControlloPermessi.UserPermSpec.Value

Proprietà ControlloPermessiUserPermSpecValue

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Value { get; }
Public ReadOnly Property Value As Boolean
    Get
public:
property bool Value {
    bool get ();
}
member Value : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ControlloPermessiUserPermSpec
Namespace DedNet.Forms


Classe CreaGruppoForm
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsCreaGruppoForm

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class CreaGruppoForm : BaseForm
Public Class CreaGruppoForm
    Inherits BaseForm
public ref class CreaGruppoForm : public BaseForm
type CreaGruppoForm =
    class
        inherit BaseForm
    end

Il tipo CreaGruppoForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Proprietà di CreaGruppoForm

Il tipo CreaGruppoForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe CreaGruppoForm
Namespace DedNet.Forms


Metodi di CreaGruppoForm

Il tipo CreaGruppoForm espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe CreaGruppoForm
Namespace DedNet.Forms


Metodo CreaGruppoForm.Dispose

Metodo CreaGruppoFormDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe CreaGruppoForm
Namespace DedNet.Forms


Eventi di CreaGruppoForm

Il tipo CreaGruppoForm espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe CreaGruppoForm
Namespace DedNet.Forms


Campi di CreaGruppoForm

Il tipo CreaGruppoForm espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe CreaGruppoForm
Namespace DedNet.Forms


Classe CreaPermessoForm
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsCreaPermessoForm

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class CreaPermessoForm : BaseForm
Public Class CreaPermessoForm
    Inherits BaseForm
public ref class CreaPermessoForm : public BaseForm
type CreaPermessoForm =
    class
        inherit BaseForm
    end

Il tipo CreaPermessoForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Proprietà di CreaPermessoForm

Il tipo CreaPermessoForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe CreaPermessoForm
Namespace DedNet.Forms


Metodi di CreaPermessoForm

Il tipo CreaPermessoForm espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe CreaPermessoForm
Namespace DedNet.Forms


Metodo CreaPermessoForm.Dispose

Metodo CreaPermessoFormDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe CreaPermessoForm
Namespace DedNet.Forms


Eventi di CreaPermessoForm

Il tipo CreaPermessoForm espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe CreaPermessoForm
Namespace DedNet.Forms


Campi di CreaPermessoForm

Il tipo CreaPermessoForm espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe CreaPermessoForm
Namespace DedNet.Forms


Classe CreaUtenteForm
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsCreaUtenteForm

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class CreaUtenteForm : BaseForm
Public Class CreaUtenteForm
    Inherits BaseForm
public ref class CreaUtenteForm : public BaseForm
type CreaUtenteForm =
    class
        inherit BaseForm
    end

Il tipo CreaUtenteForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Proprietà di CreaUtenteForm

Il tipo CreaUtenteForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe CreaUtenteForm
Namespace DedNet.Forms


Metodi di CreaUtenteForm

Il tipo CreaUtenteForm espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe CreaUtenteForm
Namespace DedNet.Forms


Metodo CreaUtenteForm.Dispose

Metodo CreaUtenteFormDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe CreaUtenteForm
Namespace DedNet.Forms


Eventi di CreaUtenteForm

Il tipo CreaUtenteForm espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe CreaUtenteForm
Namespace DedNet.Forms


Campi di CreaUtenteForm

Il tipo CreaUtenteForm espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe CreaUtenteForm
Namespace DedNet.Forms


Classe CustomListUserGroups
Classe usata per popolare il controllo TreeList con la lista degli utenti/gruppi. Espone la proprietà 'Nome' che è associata alla colonna del TreeList.
Gerarchia di ereditarietà
SystemObject
DedNet.FormsCustomListUserGroups

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class CustomListUserGroups
Public Class CustomListUserGroups
public ref class CustomListUserGroups
type CustomListUserGroups = class end

Il tipo CustomListUserGroups espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | CustomListUserGroups | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Description | Proprietà associata alla colonna del TreeList rappresentante la descrizione dell'utente/gruppo.
Proprietà pubblica | InternalName | Proprietà associata alla colonna del TreeList rappresentante il nome dell'utente/gruppo.
Proprietà pubblica | PromptName | Proprietà associata alla colonna del TreeList rappresentante il nome visualizzato a schermo dell'utente/gruppo.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore CustomListUserGroups
Costruttore unico.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public CustomListUserGroups(
    string internalName,
    string promptName,
    string description
)
Public Sub New (
    internalName As String,
    promptName As String,
    description As String
)
public:
CustomListUserGroups(
    String^ internalName,
    String^ promptName,
    String^ description
)
new :
        internalName : string *
        promptName : string *
        description : string -> CustomListUserGroups

Parametri

internalName String
Nome dell'utente/gruppo.
promptName String
Nome visualizzato dell'utente/gruppo.
description String
Descrizione dell'utente/gruppo.
Vedi anche

Documentazione

Classe CustomListUserGroups
Namespace DedNet.Forms


Proprietà di CustomListUserGroups

Il tipo CustomListUserGroups espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Description | Proprietà associata alla colonna del TreeList rappresentante la descrizione dell'utente/gruppo.
Proprietà pubblica | InternalName | Proprietà associata alla colonna del TreeList rappresentante il nome dell'utente/gruppo.
Proprietà pubblica | PromptName | Proprietà associata alla colonna del TreeList rappresentante il nome visualizzato a schermo dell'utente/gruppo.
Torna su
Vedi anche

Documentazione

Classe CustomListUserGroups
Namespace DedNet.Forms


Proprietà CustomListUserGroups.Description

Proprietà CustomListUserGroupsDescription
Proprietà associata alla colonna del TreeList rappresentante la descrizione dell'utente/gruppo.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
member Description : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe CustomListUserGroups
Namespace DedNet.Forms


Proprietà CustomListUserGroups.InternalName

Proprietà CustomListUserGroupsInternalName
Proprietà associata alla colonna del TreeList rappresentante il nome dell'utente/gruppo.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string InternalName { get; set; }
Public Property InternalName As String
    Get
    Set
public:
property String^ InternalName {
    String^ get ();
    void set (String^ value);
}
member InternalName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe CustomListUserGroups
Namespace DedNet.Forms


Proprietà CustomListUserGroups.PromptName

Proprietà CustomListUserGroupsPromptName
Proprietà associata alla colonna del TreeList rappresentante il nome visualizzato a schermo dell'utente/gruppo.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string PromptName { get; set; }
Public Property PromptName As String
    Get
    Set
public:
property String^ PromptName {
    String^ get ();
    void set (String^ value);
}
member PromptName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe CustomListUserGroups
Namespace DedNet.Forms


Classe CustomListUsersToAssign
Gerarchia di ereditarietà
SystemObject
DedNet.FormsCustomListUsersToAssign

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class CustomListUsersToAssign
Public Class CustomListUsersToAssign
public ref class CustomListUsersToAssign
type CustomListUsersToAssign = class end

Il tipo CustomListUsersToAssign espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | CustomListUsersToAssign | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Descrizione | Rappresenta la descrizione dell'utente.
Proprietà pubblica | Nome | Rappresena il nome visualizzato a schermo dell'utente.
Proprietà pubblica | User | Rappresenta il nome interno dell'oggetto utente.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore CustomListUsersToAssign
Costruttore unico.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public CustomListUsersToAssign(
    DedUser user,
    string promptName,
    string description
)
Public Sub New (
    user As DedUser,
    promptName As String,
    description As String
)
public:
CustomListUsersToAssign(
    DedUser^ user,
    String^ promptName,
    String^ description
)
new :
        user : DedUser *
        promptName : string *
        description : string -> CustomListUsersToAssign

Parametri

user DedUser
Oggetto utente.
promptName String
Nome visualizzato dell'utente/gruppo.
description String
Descrizione dell'utente/gruppo.
Vedi anche

Documentazione

Classe CustomListUsersToAssign
Namespace DedNet.Forms


Proprietà di CustomListUsersToAssign

Il tipo CustomListUsersToAssign espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Descrizione | Rappresenta la descrizione dell'utente.
Proprietà pubblica | Nome | Rappresena il nome visualizzato a schermo dell'utente.
Proprietà pubblica | User | Rappresenta il nome interno dell'oggetto utente.
Torna su
Vedi anche

Documentazione

Classe CustomListUsersToAssign
Namespace DedNet.Forms


Proprietà CustomListUsersToAssign.Descrizione

Proprietà CustomListUsersToAssignDescrizione
Rappresenta la descrizione dell'utente.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Descrizione { get; set; }
Public Property Descrizione As String
    Get
    Set
public:
property String^ Descrizione {
    String^ get ();
    void set (String^ value);
}
member Descrizione : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe CustomListUsersToAssign
Namespace DedNet.Forms


Proprietà CustomListUsersToAssign.Nome

Proprietà CustomListUsersToAssignNome
Rappresena il nome visualizzato a schermo dell'utente.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Nome { get; set; }
Public Property Nome As String
    Get
    Set
public:
property String^ Nome {
    String^ get ();
    void set (String^ value);
}
member Nome : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe CustomListUsersToAssign
Namespace DedNet.Forms


Proprietà CustomListUsersToAssign.User

Proprietà CustomListUsersToAssignUser
Rappresenta il nome interno dell'oggetto utente.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedUser User { get; set; }
Public Property User As DedUser
    Get
    Set
public:
property DedUser^ User {
    DedUser^ get ();
    void set (DedUser^ value);
}
member User : DedUser with get, set

Valore della proprietà

DedUser
Vedi anche

Documentazione

Classe CustomListUsersToAssign
Namespace DedNet.Forms


Classe DedFormAlternativeData
Dialogo utilizzato per visualizzare e editare i codici alternativi di una anagrafica.
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormAlternativeData

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormAlternativeData : BaseForm
Public Class DedFormAlternativeData
    Inherits BaseForm
public ref class DedFormAlternativeData : public BaseForm
type DedFormAlternativeData =
    class
        inherit BaseForm
    end

Il tipo DedFormAlternativeData espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormAlternativeData | Crea una nuova istanza del dialogo utilizzato per visualizzare e editare i codici alternativi di una anagrafica.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà pubblica | Data | Anagrafica di cui si vogliono vedere i codici alternativi.
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà pubblica | IsFilterByStateActive | Restituisce se è attivo un filtro per stato anagrafico
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo pubblico | alreadyRequested | Indica se richiedere il salvataggio delle modifiche
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormAlternativeData
Crea una nuova istanza del dialogo utilizzato per visualizzare e editare i codici alternativi di una anagrafica.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormAlternativeData(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedFormAlternativeData(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedFormAlternativeData

Parametri

app DedNetApplication
Vedi anche

Documentazione

Classe DedFormAlternativeData
Namespace DedNet.Forms


Proprietà di DedFormAlternativeData

Il tipo DedFormAlternativeData espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà pubblica | Data | Anagrafica di cui si vogliono vedere i codici alternativi.
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà pubblica | IsFilterByStateActive | Restituisce se è attivo un filtro per stato anagrafico
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormAlternativeData
Namespace DedNet.Forms


Proprietà DedFormAlternativeData.Data

Proprietà DedFormAlternativeDataData
Anagrafica di cui si vogliono vedere i codici alternativi.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; set; }
Public Property Data As DedData
    Get
    Set
public:
property DedData^ Data {
    DedData^ get ();
    void set (DedData^ value);
}
member Data : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe DedFormAlternativeData
Namespace DedNet.Forms


Proprietà DedFormAlternativeData.IsFilterByStateActive

Proprietà DedFormAlternativeDataIsFilterByStateActive
Restituisce se è attivo un filtro per stato anagrafico

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsFilterByStateActive { get; }
Public ReadOnly Property IsFilterByStateActive As Boolean
    Get
public:
property bool IsFilterByStateActive {
    bool get ();
}
member IsFilterByStateActive : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormAlternativeData
Namespace DedNet.Forms


Metodi di DedFormAlternativeData

Il tipo DedFormAlternativeData espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormAlternativeData
Namespace DedNet.Forms


Metodo DedFormAlternativeData.Dispose

Metodo DedFormAlternativeDataDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormAlternativeData
Namespace DedNet.Forms


Eventi di DedFormAlternativeData

Il tipo DedFormAlternativeData espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormAlternativeData
Namespace DedNet.Forms


Campi di DedFormAlternativeData

Il tipo DedFormAlternativeData espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | alreadyRequested | Indica se richiedere il salvataggio delle modifiche
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormAlternativeData
Namespace DedNet.Forms


Campo DedFormAlternativeData.alreadyRequested

Campo DedFormAlternativeDataalreadyRequested
Indica se richiedere il salvataggio delle modifiche

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool alreadyRequested
Public alreadyRequested As Boolean
public:
bool alreadyRequested
val mutable alreadyRequested: bool

Valore del campo

Boolean
Vedi anche

Documentazione

Classe DedFormAlternativeData
Namespace DedNet.Forms


Classe DedFormAnagrafica
Finestra di dialogo contenente il controllo per visualizzare/editare gli attributi.
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormAnagrafica

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormAnagrafica : BaseForm
Public Class DedFormAnagrafica
    Inherits BaseForm
public ref class DedFormAnagrafica : public BaseForm
type DedFormAnagrafica =
    class
        inherit BaseForm
    end

Il tipo DedFormAnagrafica espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormAnagrafica | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | AsInDb | Imposta l'anagrafica come in fase di revisione.
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà pubblica | CreatingAnagr | Imposta l'anagrafica come in fase di creazione.
Proprietà pubblica | CtrAnagrafica | Espone il controllo degli attributi
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà pubblica | DisableEditingForOnlyDbAttrs | Indica se abilitare o meno l'editazione per gli attributi marchiati come "Solo Db".
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | Editable | Imposta gli attributi come modificabili o meno.
Proprietà pubblica | EditButtonVisible | Imposta o restituisce la visibilità dell pulsante Edita.
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà pubblica | GroupAttribute | Imposta o restituisce il raggruppamento degli attributi.
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | PanelVisible | Restituisce o imposta la visibilità del pannello contenente i pulsanti.
Proprietà pubblica | RevisionAnagr | Imposta l'anagrafica come in fase di revisione.
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Proprietà pubblica | ValidateAttr | Imposta se validare gli attributi compilati.
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo pubblico | initData | Inizializza la finestra di dialogo con le anagrafiche da visualizzare.
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormAnagrafica
Costruttore unico.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormAnagrafica(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedFormAnagrafica(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedFormAnagrafica

Parametri

app DedNetApplication
Applicazione alla quale appartiene il form
Vedi anche

Documentazione

Classe DedFormAnagrafica
Namespace DedNet.Forms


Proprietà di DedFormAnagrafica

Il tipo DedFormAnagrafica espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | AsInDb | Imposta l'anagrafica come in fase di revisione.
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà pubblica | CreatingAnagr | Imposta l'anagrafica come in fase di creazione.
Proprietà pubblica | CtrAnagrafica | Espone il controllo degli attributi
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà pubblica | DisableEditingForOnlyDbAttrs | Indica se abilitare o meno l'editazione per gli attributi marchiati come "Solo Db".
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | Editable | Imposta gli attributi come modificabili o meno.
Proprietà pubblica | EditButtonVisible | Imposta o restituisce la visibilità dell pulsante Edita.
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà pubblica | GroupAttribute | Imposta o restituisce il raggruppamento degli attributi.
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | PanelVisible | Restituisce o imposta la visibilità del pannello contenente i pulsanti.
Proprietà pubblica | RevisionAnagr | Imposta l'anagrafica come in fase di revisione.
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Proprietà pubblica | ValidateAttr | Imposta se validare gli attributi compilati.
Torna su
Vedi anche

Documentazione

Classe DedFormAnagrafica
Namespace DedNet.Forms


Proprietà DedFormAnagrafica.AsInDb

Proprietà DedFormAnagraficaAsInDb
Imposta l'anagrafica come in fase di revisione.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AsInDb { set; }
Public WriteOnly Property AsInDb As Boolean
    Set
public:
property bool AsInDb {
    void set (bool value);
}
member AsInDb : bool with set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormAnagrafica
Namespace DedNet.Forms


Proprietà DedFormAnagrafica.CreatingAnagr

Proprietà DedFormAnagraficaCreatingAnagr
Imposta l'anagrafica come in fase di creazione.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CreatingAnagr { set; }
Public WriteOnly Property CreatingAnagr As Boolean
    Set
public:
property bool CreatingAnagr {
    void set (bool value);
}
member CreatingAnagr : bool with set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormAnagrafica
Namespace DedNet.Forms


Proprietà DedFormAnagrafica.CtrAnagrafica

Proprietà DedFormAnagraficaCtrAnagrafica
Espone il controllo degli attributi

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEditAnagrControl CtrAnagrafica { get; }
Public ReadOnly Property CtrAnagrafica As DedEditAnagrControl
    Get
public:
property DedEditAnagrControl^ CtrAnagrafica {
    DedEditAnagrControl^ get ();
}
member CtrAnagrafica : DedEditAnagrControl with get

Valore della proprietà

DedEditAnagrControl
Vedi anche

Documentazione

Classe DedFormAnagrafica
Namespace DedNet.Forms


Proprietà DedFormAnagrafica.DisableEditingForOnlyDbAttrs

Proprietà DedFormAnagraficaDisableEditingForOnlyDbAttrs
Indica se abilitare o meno l'editazione per gli attributi marchiati come "Solo Db".

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool DisableEditingForOnlyDbAttrs { get; set; }
Public Property DisableEditingForOnlyDbAttrs As Boolean
    Get
    Set
public:
property bool DisableEditingForOnlyDbAttrs {
    bool get ();
    void set (bool value);
}
member DisableEditingForOnlyDbAttrs : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormAnagrafica
Namespace DedNet.Forms


Proprietà DedFormAnagrafica.Editable

Proprietà DedFormAnagraficaEditable
Imposta gli attributi come modificabili o meno.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Editable { get; set; }
Public Property Editable As Boolean
    Get
    Set
public:
property bool Editable {
    bool get ();
    void set (bool value);
}
member Editable : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormAnagrafica
Namespace DedNet.Forms


Proprietà DedFormAnagrafica.EditButtonVisible

Proprietà DedFormAnagraficaEditButtonVisible
Imposta o restituisce la visibilità dell pulsante Edita.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool EditButtonVisible { get; set; }
Public Property EditButtonVisible As Boolean
    Get
    Set
public:
property bool EditButtonVisible {
    bool get ();
    void set (bool value);
}
member EditButtonVisible : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormAnagrafica
Namespace DedNet.Forms


Proprietà DedFormAnagrafica.GroupAttribute

Proprietà DedFormAnagraficaGroupAttribute
Imposta o restituisce il raggruppamento degli attributi.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool GroupAttribute { get; set; }
Public Property GroupAttribute As Boolean
    Get
    Set
public:
property bool GroupAttribute {
    bool get ();
    void set (bool value);
}
member GroupAttribute : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormAnagrafica
Namespace DedNet.Forms


Proprietà DedFormAnagrafica.PanelVisible

Proprietà DedFormAnagraficaPanelVisible
Restituisce o imposta la visibilità del pannello contenente i pulsanti.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool PanelVisible { get; set; }
Public Property PanelVisible As Boolean
    Get
    Set
public:
property bool PanelVisible {
    bool get ();
    void set (bool value);
}
member PanelVisible : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormAnagrafica
Namespace DedNet.Forms


Proprietà DedFormAnagrafica.RevisionAnagr

Proprietà DedFormAnagraficaRevisionAnagr
Imposta l'anagrafica come in fase di revisione.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool RevisionAnagr { set; }
Public WriteOnly Property RevisionAnagr As Boolean
    Set
public:
property bool RevisionAnagr {
    void set (bool value);
}
member RevisionAnagr : bool with set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormAnagrafica
Namespace DedNet.Forms


Proprietà DedFormAnagrafica.ValidateAttr

Proprietà DedFormAnagraficaValidateAttr
Imposta se validare gli attributi compilati.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ValidateAttr { set; }
Public WriteOnly Property ValidateAttr As Boolean
    Set
public:
property bool ValidateAttr {
    void set (bool value);
}
member ValidateAttr : bool with set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormAnagrafica
Namespace DedNet.Forms


Metodi di DedFormAnagrafica

Il tipo DedFormAnagrafica espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo pubblico | initData | Inizializza la finestra di dialogo con le anagrafiche da visualizzare.
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormAnagrafica
Namespace DedNet.Forms


Metodo DedFormAnagrafica.Dispose

Metodo DedFormAnagraficaDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormAnagrafica
Namespace DedNet.Forms


Metodo DedFormAnagrafica.initData

Metodo DedFormAnagraficainitData
Inizializza la finestra di dialogo con le anagrafiche da visualizzare.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void initData(
    IDedData data,
    DedAttrList attrList,
    DedType fam
)
Public Sub initData (
    data As IDedData,
    attrList As DedAttrList,
    fam As DedType
)
public:
void initData(
    IDedData^ data,
    DedAttrList^ attrList,
    DedType^ fam
)
member initData :
        data : IDedData *
        attrList : DedAttrList *
        fam : DedType -> unit

Parametri

data IDedData
Anagrafica da utilizzare per l'inizializzazione.
attrList DedAttrList
Lista degli attributi comuni alle anagrafiche.
fam DedType
Famiglia a cui appartiene l'anagrafica passata in ingresso (la famiglia è stata passata come parametro perchè non è sempre possibile ricavarla dalle informazioni dell'anagrafica).
Vedi anche

Documentazione

Classe DedFormAnagrafica
Namespace DedNet.Forms


Eventi di DedFormAnagrafica

Il tipo DedFormAnagrafica espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormAnagrafica
Namespace DedNet.Forms


Campi di DedFormAnagrafica

Il tipo DedFormAnagrafica espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormAnagrafica
Namespace DedNet.Forms


Classe DedFormAnagrHistory
Classe per visualizzare la storia di un'anagrafica.
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormAnagrHistory

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormAnagrHistory : BaseForm
Public Class DedFormAnagrHistory
    Inherits BaseForm
public ref class DedFormAnagrHistory : public BaseForm
type DedFormAnagrHistory =
    class
        inherit BaseForm
    end

Il tipo DedFormAnagrHistory espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormAnagrHistory | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormAnagrHistory
Costruttore unico.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormAnagrHistory(
    DedNetApplication app,
    DedData data
)
Public Sub New (
    app As DedNetApplication,
    data As DedData
)
public:
DedFormAnagrHistory(
    DedNetApplication^ app,
    DedData^ data
)
new :
        app : DedNetApplication *
        data : DedData -> DedFormAnagrHistory

Parametri

app DedNetApplication
Applicazione.
data DedData
Anagrafica da visualizzare.
Vedi anche

Documentazione

Classe DedFormAnagrHistory
Namespace DedNet.Forms


Proprietà di DedFormAnagrHistory

Il tipo DedFormAnagrHistory espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormAnagrHistory
Namespace DedNet.Forms


Metodi di DedFormAnagrHistory

Il tipo DedFormAnagrHistory espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormAnagrHistory
Namespace DedNet.Forms


Metodo DedFormAnagrHistory.Dispose

Metodo DedFormAnagrHistoryDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormAnagrHistory
Namespace DedNet.Forms


Eventi di DedFormAnagrHistory

Il tipo DedFormAnagrHistory espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormAnagrHistory
Namespace DedNet.Forms


Campi di DedFormAnagrHistory

Il tipo DedFormAnagrHistory espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormAnagrHistory
Namespace DedNet.Forms


Classe DedFormAnagrMultiSel
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormAnagrMultiSel

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormAnagrMultiSel : BaseForm
Public Class DedFormAnagrMultiSel
    Inherits BaseForm
public ref class DedFormAnagrMultiSel : public BaseForm
type DedFormAnagrMultiSel =
    class
        inherit BaseForm
    end

Il tipo DedFormAnagrMultiSel espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormAnagrMultiSel | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà pubblica | Comment | Aggiunge un commento nella riga finale del form
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà pubblica | DataList | Elenco anagrafica selezionate nel form
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo pubblico | GetOptions | Restiruisce l'oggetto rappresntante le optioni.
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo pubblico | SetOptionsType | Metodo per impostare la tipologia di oggetto rappresentante le opzioni. Nel caso tali opzioni siano già stata salvate nel registro viene ripristinato l'oggetto altrimenti viene creata un'oggetto nuovo
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormAnagrMultiSel
Costruttore

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormAnagrMultiSel(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedFormAnagrMultiSel(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedFormAnagrMultiSel

Parametri

app DedNetApplication
Applicazione DedNet
Vedi anche

Documentazione

Classe DedFormAnagrMultiSel
Namespace DedNet.Forms


Proprietà di DedFormAnagrMultiSel

Il tipo DedFormAnagrMultiSel espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà pubblica | Comment | Aggiunge un commento nella riga finale del form
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà pubblica | DataList | Elenco anagrafica selezionate nel form
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormAnagrMultiSel
Namespace DedNet.Forms


Proprietà DedFormAnagrMultiSel.Comment

Proprietà DedFormAnagrMultiSelComment
Aggiunge un commento nella riga finale del form

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Comment { get; set; }
Public Property Comment As String
    Get
    Set
public:
property String^ Comment {
    String^ get ();
    void set (String^ value);
}
member Comment : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedFormAnagrMultiSel
Namespace DedNet.Forms


Proprietà DedFormAnagrMultiSel.DataList

Proprietà DedFormAnagrMultiSelDataList
Elenco anagrafica selezionate nel form

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataList DataList { get; }
Public ReadOnly Property DataList As DedDataList
    Get
public:
property DedDataList^ DataList {
    DedDataList^ get ();
}
member DataList : DedDataList with get

Valore della proprietà

DedDataList
Vedi anche

Documentazione

Classe DedFormAnagrMultiSel
Namespace DedNet.Forms


Metodi di DedFormAnagrMultiSel

Il tipo DedFormAnagrMultiSel espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo pubblico | GetOptions | Restiruisce l'oggetto rappresntante le optioni.
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo pubblico | SetOptionsType | Metodo per impostare la tipologia di oggetto rappresentante le opzioni. Nel caso tali opzioni siano già stata salvate nel registro viene ripristinato l'oggetto altrimenti viene creata un'oggetto nuovo
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormAnagrMultiSel
Namespace DedNet.Forms


Metodo DedFormAnagrMultiSel.Dispose

Metodo DedFormAnagrMultiSelDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormAnagrMultiSel
Namespace DedNet.Forms


Metodo DedFormAnagrMultiSel.GetOptions

Metodo DedFormAnagrMultiSelGetOptions
Restiruisce l'oggetto rappresntante le optioni.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedOptionsSerializableBase GetOptions()
Public Function GetOptions As DedOptionsSerializableBase
public:
DedOptionsSerializableBase^ GetOptions()
member GetOptions : unit -> DedOptionsSerializableBase

Valore di ritorno

DedOptionsSerializableBase
Vedi anche

Documentazione

Classe DedFormAnagrMultiSel
Namespace DedNet.Forms


Metodo DedFormAnagrMultiSel.SetOptionsType

Metodo DedFormAnagrMultiSelSetOptionsType
Metodo per impostare la tipologia di oggetto rappresentante le opzioni. Nel caso tali opzioni siano già stata salvate nel registro viene ripristinato l'oggetto altrimenti viene creata un'oggetto nuovo

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetOptionsType(
    Type objtype
)
Public Sub SetOptionsType (
    objtype As Type
)
public:
void SetOptionsType(
    Type^ objtype
)
member SetOptionsType :
        objtype : Type -> unit

Parametri

objtype Type
Type dell'oggetto rappresentante le opzioni
Vedi anche

Documentazione

Classe DedFormAnagrMultiSel
Namespace DedNet.Forms


Eventi di DedFormAnagrMultiSel

Il tipo DedFormAnagrMultiSel espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormAnagrMultiSel
Namespace DedNet.Forms


Campi di DedFormAnagrMultiSel

Il tipo DedFormAnagrMultiSel espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormAnagrMultiSel
Namespace DedNet.Forms


Classe DedFormAssociateDoc
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormAssociateDoc

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormAssociateDoc : BaseForm
Public Class DedFormAssociateDoc
    Inherits BaseForm
public ref class DedFormAssociateDoc : public BaseForm
type DedFormAssociateDoc =
    class
        inherit BaseForm
    end

Il tipo DedFormAssociateDoc espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnablAttachContext | Restituisce o imposta se abilitare il contesto allegato.
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | EnableLinkNotCopy | Restituisce o imposta se risulta abilitato all'utente, il controllo per collegare i documenti.
Proprietà pubblica | EnablePrimaryContext | Restituisce o imposta se abilitare il contesto primario.
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LinkNotCopy | Restituisce o imposta se il documento debba essere collegato e non importato (false di default).
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | PrimaryContext | Restituisce o imposta il contesto con il quale associare i documenti. Di default è true ed i documenti vengono associati come primari.
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Proprietà di DedFormAssociateDoc

Il tipo DedFormAssociateDoc espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnablAttachContext | Restituisce o imposta se abilitare il contesto allegato.
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | EnableLinkNotCopy | Restituisce o imposta se risulta abilitato all'utente, il controllo per collegare i documenti.
Proprietà pubblica | EnablePrimaryContext | Restituisce o imposta se abilitare il contesto primario.
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LinkNotCopy | Restituisce o imposta se il documento debba essere collegato e non importato (false di default).
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | PrimaryContext | Restituisce o imposta il contesto con il quale associare i documenti. Di default è true ed i documenti vengono associati come primari.
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormAssociateDoc
Namespace DedNet.Forms


Proprietà DedFormAssociateDoc.EnablAttachContext

Proprietà DedFormAssociateDocEnablAttachContext
Restituisce o imposta se abilitare il contesto allegato.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool EnablAttachContext { get; set; }
Public Property EnablAttachContext As Boolean
    Get
    Set
public:
property bool EnablAttachContext {
    bool get ();
    void set (bool value);
}
member EnablAttachContext : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormAssociateDoc
Namespace DedNet.Forms


Proprietà DedFormAssociateDoc.EnableLinkNotCopy

Proprietà DedFormAssociateDocEnableLinkNotCopy
Restituisce o imposta se risulta abilitato all'utente, il controllo per collegare i documenti.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool EnableLinkNotCopy { get; set; }
Public Property EnableLinkNotCopy As Boolean
    Get
    Set
public:
property bool EnableLinkNotCopy {
    bool get ();
    void set (bool value);
}
member EnableLinkNotCopy : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormAssociateDoc
Namespace DedNet.Forms


Proprietà DedFormAssociateDoc.EnablePrimaryContext

Proprietà DedFormAssociateDocEnablePrimaryContext
Restituisce o imposta se abilitare il contesto primario.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool EnablePrimaryContext { get; set; }
Public Property EnablePrimaryContext As Boolean
    Get
    Set
public:
property bool EnablePrimaryContext {
    bool get ();
    void set (bool value);
}
member EnablePrimaryContext : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormAssociateDoc
Namespace DedNet.Forms


Proprietà DedFormAssociateDoc.LinkNotCopy

Proprietà DedFormAssociateDocLinkNotCopy
Restituisce o imposta se il documento debba essere collegato e non importato (false di default).

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool LinkNotCopy { get; set; }
Public Property LinkNotCopy As Boolean
    Get
    Set
public:
property bool LinkNotCopy {
    bool get ();
    void set (bool value);
}
member LinkNotCopy : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormAssociateDoc
Namespace DedNet.Forms


Proprietà DedFormAssociateDoc.PrimaryContext

Proprietà DedFormAssociateDocPrimaryContext
Restituisce o imposta il contesto con il quale associare i documenti. Di default è true ed i documenti vengono associati come primari.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool PrimaryContext { get; set; }
Public Property PrimaryContext As Boolean
    Get
    Set
public:
property bool PrimaryContext {
    bool get ();
    void set (bool value);
}
member PrimaryContext : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormAssociateDoc
Namespace DedNet.Forms


Metodi di DedFormAssociateDoc

Il tipo DedFormAssociateDoc espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormAssociateDoc
Namespace DedNet.Forms


Metodo DedFormAssociateDoc.Dispose

Metodo DedFormAssociateDocDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormAssociateDoc
Namespace DedNet.Forms


Eventi di DedFormAssociateDoc

Il tipo DedFormAssociateDoc espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormAssociateDoc
Namespace DedNet.Forms


Campi di DedFormAssociateDoc

Il tipo DedFormAssociateDoc espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormAssociateDoc
Namespace DedNet.Forms


Classe DedFormBomAddItem
From per la gestione dell'inserimento in distinta nel caso di anagrafiche duplicate
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormBomAddItem

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormBomAddItem : BaseForm
Public Class DedFormBomAddItem
    Inherits BaseForm
public ref class DedFormBomAddItem : public BaseForm
type DedFormBomAddItem =
    class
        inherit BaseForm
    end

Il tipo DedFormBomAddItem espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormBomAddItem(DedNetApplication, BomItemCollection, String, String, Double, Object, ListString) | Costruttore
Metodo pubblico | DedFormBomAddItem(DedNetApplication, DedComm, String, String, Double, DictionaryString, Object, ListString) | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | ResultList | Lista bindata alla griglia
Proprietà pubblica | ResultListComm | Lista bindata alla griglia
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo pubblico | InitData(ListBomItem) | Inizializza i dati da bindare alla griglia
Metodo pubblico | InitData(ListDedCommAnagrItem) | Inizializza i dati da bindare alla griglia
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormBomAddItem
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | DedFormBomAddItem(DedNetApplication, BomItemCollection, String, String, Double, Object, ListString) | Costruttore
Metodo pubblico | DedFormBomAddItem(DedNetApplication, DedComm, String, String, Double, DictionaryString, Object, ListString) | Costruttore
Torna su
Vedi anche

Documentazione

Classe DedFormBomAddItem
Namespace DedNet.Forms


Costruttore DedFormBomAddItem(DedNetApplication, BomItemCollection, String, String, Double, Object[], List<String>)

Costruttore DedFormBomAddItem(DedNetApplication, BomItemCollection, String, String, Double, Object, ListString)
Costruttore

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormBomAddItem(
    DedNetApplication app,
    BomItemCollection bom,
    string id,
    string rev,
    double qta,
    Object[] distValues,
    List<string> attrOrder
)
Public Sub New (
    app As DedNetApplication,
    bom As BomItemCollection,
    id As String,
    rev As String,
    qta As Double,
    distValues As Object(),
    attrOrder As List(Of String)
)
public:
DedFormBomAddItem(
    DedNetApplication^ app,
    BomItemCollection^ bom,
    String^ id,
    String^ rev,
    double qta,
    array<Object^>^ distValues,
    List<String^>^ attrOrder
)
new :
        app : DedNetApplication *
        bom : BomItemCollection *
        id : string *
        rev : string *
        qta : float *
        distValues : Object[] *
        attrOrder : List<string> -> DedFormBomAddItem

Parametri

app DedNetApplication
DedNetApplication
bom BomItemCollection
Distinta
id String
ID dell'elemento da inserire
rev String
REV dell'elemento da inserire
qta Double
Qta da inserire
distValues Object
Valori attributi di distinta
attrOrder List String
Ordinamento attributi di distinta
Vedi anche

Documentazione

Classe DedFormBomAddItem
Overload di DedFormBomAddItem
Namespace DedNet.Forms


Costruttore DedFormBomAddItem(DedNetApplication, DedComm, String, String, Double, Dictionary<String, Object>, List<String>)

Costruttore DedFormBomAddItem(DedNetApplication, DedComm, String, String, Double, DictionaryString, Object, ListString)
Costruttore

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormBomAddItem(
    DedNetApplication app,
    DedComm comm,
    string id,
    string rev,
    double qta,
    Dictionary<string, Object> attrValues,
    List<string> attrOrder
)
Public Sub New (
    app As DedNetApplication,
    comm As DedComm,
    id As String,
    rev As String,
    qta As Double,
    attrValues As Dictionary(Of String, Object),
    attrOrder As List(Of String)
)
public:
DedFormBomAddItem(
    DedNetApplication^ app,
    DedComm^ comm,
    String^ id,
    String^ rev,
    double qta,
    Dictionary<String^, Object^>^ attrValues,
    List<String^>^ attrOrder
)
new :
        app : DedNetApplication *
        comm : DedComm *
        id : string *
        rev : string *
        qta : float *
        attrValues : Dictionary<string, Object> *
        attrOrder : List<string> -> DedFormBomAddItem

Parametri

app DedNetApplication
DedNetApplication
comm DedComm
Commessa
id String
ID dell'elemento da inserire
rev String
REV dell'elemento da inserire
qta Double
Qta da inserire
attrValues Dictionary String, Object
Valori attributi di anagrafica di commessa
attrOrder List String
Ordinamento attributi di anagrafica di commessa
Vedi anche

Documentazione

Classe DedFormBomAddItem
Overload di DedFormBomAddItem
Namespace DedNet.Forms


Proprietà di DedFormBomAddItem

Il tipo DedFormBomAddItem espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | ResultList | Lista bindata alla griglia
Proprietà pubblica | ResultListComm | Lista bindata alla griglia
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormBomAddItem
Namespace DedNet.Forms


Proprietà DedFormBomAddItem.ResultList

Proprietà DedFormBomAddItemResultList
Lista bindata alla griglia

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BindingList<BomItemWrapper> ResultList { get; set; }
Public Property ResultList As BindingList(Of BomItemWrapper)
    Get
    Set
public:
property BindingList<BomItemWrapper^>^ ResultList {
    BindingList<BomItemWrapper^>^ get ();
    void set (BindingList<BomItemWrapper^>^ value);
}
member ResultList : BindingList<BomItemWrapper> with get, set

Valore della proprietà

BindingList BomItemWrapper
Vedi anche

Documentazione

Classe DedFormBomAddItem
Namespace DedNet.Forms


Proprietà DedFormBomAddItem.ResultListComm

Proprietà DedFormBomAddItemResultListComm
Lista bindata alla griglia

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BindingList<CommAnagrItemWrapper> ResultListComm { get; set; }
Public Property ResultListComm As BindingList(Of CommAnagrItemWrapper)
    Get
    Set
public:
property BindingList<CommAnagrItemWrapper^>^ ResultListComm {
    BindingList<CommAnagrItemWrapper^>^ get ();
    void set (BindingList<CommAnagrItemWrapper^>^ value);
}
member ResultListComm : BindingList<CommAnagrItemWrapper> with get, set

Valore della proprietà

BindingList CommAnagrItemWrapper
Vedi anche

Documentazione

Classe DedFormBomAddItem
Namespace DedNet.Forms


Metodi di DedFormBomAddItem

Il tipo DedFormBomAddItem espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo pubblico | InitData(ListBomItem) | Inizializza i dati da bindare alla griglia
Metodo pubblico | InitData(ListDedCommAnagrItem) | Inizializza i dati da bindare alla griglia
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormBomAddItem
Namespace DedNet.Forms


Metodo DedFormBomAddItem.Dispose

Metodo DedFormBomAddItemDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormBomAddItem
Namespace DedNet.Forms


Metodo DedFormBomAddItem.InitData

Metodo DedFormBomAddItemInitData
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | InitData(ListBomItem) | Inizializza i dati da bindare alla griglia
Metodo pubblico | InitData(ListDedCommAnagrItem) | Inizializza i dati da bindare alla griglia
Torna su
Vedi anche

Documentazione

Classe DedFormBomAddItem
Namespace DedNet.Forms


Metodo DedFormBomAddItem.InitData(List<BomItem>)

Metodo DedFormBomAddItemInitData(ListBomItem)
Inizializza i dati da bindare alla griglia

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void InitData(
    List<BomItem> listSameData
)
Public Sub InitData (
    listSameData As List(Of BomItem)
)
public:
void InitData(
    List<BomItem^>^ listSameData
)
member InitData :
        listSameData : List<BomItem> -> unit

Parametri

listSameData List BomItem
Lista di oggetti BomItem pre-esistenti in distinta
Vedi anche

Documentazione

Classe DedFormBomAddItem
Overload di InitData
Namespace DedNet.Forms


Metodo DedFormBomAddItem.InitData(List<DedCommAnagrItem>)

Metodo DedFormBomAddItemInitData(ListDedCommAnagrItem)
Inizializza i dati da bindare alla griglia

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void InitData(
    List<DedCommAnagrItem> listSameData
)
Public Sub InitData (
    listSameData As List(Of DedCommAnagrItem)
)
public:
void InitData(
    List<DedCommAnagrItem^>^ listSameData
)
member InitData :
        listSameData : List<DedCommAnagrItem> -> unit

Parametri

listSameData List DedCommAnagrItem
Lista di oggetti DedCommAnagrItem pre-esistenti in commessa
Vedi anche

Documentazione

Classe DedFormBomAddItem
Overload di InitData
Namespace DedNet.Forms


Eventi di DedFormBomAddItem

Il tipo DedFormBomAddItem espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormBomAddItem
Namespace DedNet.Forms


Campi di DedFormBomAddItem

Il tipo DedFormBomAddItem espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormBomAddItem
Namespace DedNet.Forms


Classe DedFormBomCompareCfg
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormBomCompareCfg

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormBomCompareCfg : BaseForm
Public Class DedFormBomCompareCfg
    Inherits BaseForm
public ref class DedFormBomCompareCfg : public BaseForm
type DedFormBomCompareCfg =
    class
        inherit BaseForm
    end

Il tipo DedFormBomCompareCfg espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormBomCompareCfg | Costruttore unico
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormBomCompareCfg
Costruttore unico

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormBomCompareCfg(
    DedNetApplication app,
    BomItemComparer bic
)
Public Sub New (
    app As DedNetApplication,
    bic As BomItemComparer
)
public:
DedFormBomCompareCfg(
    DedNetApplication^ app,
    BomItemComparer^ bic
)
new :
        app : DedNetApplication *
        bic : BomItemComparer -> DedFormBomCompareCfg

Parametri

app DedNetApplication
bic BomItemComparer
Vedi anche

Documentazione

Classe DedFormBomCompareCfg
Namespace DedNet.Forms


Proprietà di DedFormBomCompareCfg

Il tipo DedFormBomCompareCfg espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormBomCompareCfg
Namespace DedNet.Forms


Metodi di DedFormBomCompareCfg

Il tipo DedFormBomCompareCfg espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormBomCompareCfg
Namespace DedNet.Forms


Metodo DedFormBomCompareCfg.Dispose

Metodo DedFormBomCompareCfgDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormBomCompareCfg
Namespace DedNet.Forms


Eventi di DedFormBomCompareCfg

Il tipo DedFormBomCompareCfg espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormBomCompareCfg
Namespace DedNet.Forms


Campi di DedFormBomCompareCfg

Il tipo DedFormBomCompareCfg espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormBomCompareCfg
Namespace DedNet.Forms


Classe DedFormBomCompareExp
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormBomCompareExp

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormBomCompareExp : BaseForm
Public Class DedFormBomCompareExp
    Inherits BaseForm
public ref class DedFormBomCompareExp : public BaseForm
type DedFormBomCompareExp =
    class
        inherit BaseForm
    end

Il tipo DedFormBomCompareExp espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormBomCompareExp | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà pubblica | Bom | BomItemCollection della distinta fittizia da visualizzare
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà pubblica | DedDistControl | Ritorna il controllo interno di visualizzazione distinta
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà pubblica | HeaderDx | Header della distinta a destra nell'edita
Proprietà pubblica | HeaderSx | Header della distinta a sinistra nell'edita
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà pubblica | MultiLevel | Indica se la visualizzazione è multi o mono livello
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormBomCompareExp
Costruttore

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormBomCompareExp(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedFormBomCompareExp(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedFormBomCompareExp

Parametri

app DedNetApplication
Vedi anche

Documentazione

Classe DedFormBomCompareExp
Namespace DedNet.Forms


Proprietà di DedFormBomCompareExp

Il tipo DedFormBomCompareExp espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà pubblica | Bom | BomItemCollection della distinta fittizia da visualizzare
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà pubblica | DedDistControl | Ritorna il controllo interno di visualizzazione distinta
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà pubblica | HeaderDx | Header della distinta a destra nell'edita
Proprietà pubblica | HeaderSx | Header della distinta a sinistra nell'edita
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà pubblica | MultiLevel | Indica se la visualizzazione è multi o mono livello
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormBomCompareExp
Namespace DedNet.Forms


Proprietà DedFormBomCompareExp.Bom

Proprietà DedFormBomCompareExpBom
BomItemCollection della distinta fittizia da visualizzare

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItemCollection Bom { get; set; }
Public Property Bom As BomItemCollection
    Get
    Set
public:
property BomItemCollection^ Bom {
    BomItemCollection^ get ();
    void set (BomItemCollection^ value);
}
member Bom : BomItemCollection with get, set

Valore della proprietà

BomItemCollection
Vedi anche

Documentazione

Classe DedFormBomCompareExp
Namespace DedNet.Forms


Proprietà DedFormBomCompareExp.DedDistControl

Proprietà DedFormBomCompareExpDedDistControl
Ritorna il controllo interno di visualizzazione distinta

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDistControl DedDistControl { get; }
Public ReadOnly Property DedDistControl As DedDistControl
    Get
public:
property DedDistControl^ DedDistControl {
    DedDistControl^ get ();
}
member DedDistControl : DedDistControl with get

Valore della proprietà

DedDistControl
Vedi anche

Documentazione

Classe DedFormBomCompareExp
Namespace DedNet.Forms


Proprietà DedFormBomCompareExp.HeaderDx

Proprietà DedFormBomCompareExpHeaderDx
Header della distinta a destra nell'edita

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DistHeader HeaderDx { get; set; }
Public Property HeaderDx As DistHeader
    Get
    Set
public:
property DistHeader^ HeaderDx {
    DistHeader^ get ();
    void set (DistHeader^ value);
}
member HeaderDx : DistHeader with get, set

Valore della proprietà

DistHeader
Vedi anche

Documentazione

Classe DedFormBomCompareExp
Namespace DedNet.Forms


Proprietà DedFormBomCompareExp.HeaderSx

Proprietà DedFormBomCompareExpHeaderSx
Header della distinta a sinistra nell'edita

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DistHeader HeaderSx { get; set; }
Public Property HeaderSx As DistHeader
    Get
    Set
public:
property DistHeader^ HeaderSx {
    DistHeader^ get ();
    void set (DistHeader^ value);
}
member HeaderSx : DistHeader with get, set

Valore della proprietà

DistHeader
Vedi anche

Documentazione

Classe DedFormBomCompareExp
Namespace DedNet.Forms


Proprietà DedFormBomCompareExp.MultiLevel

Proprietà DedFormBomCompareExpMultiLevel
Indica se la visualizzazione è multi o mono livello

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool MultiLevel { get; set; }
Public Property MultiLevel As Boolean
    Get
    Set
public:
property bool MultiLevel {
    bool get ();
    void set (bool value);
}
member MultiLevel : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormBomCompareExp
Namespace DedNet.Forms


Metodi di DedFormBomCompareExp

Il tipo DedFormBomCompareExp espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormBomCompareExp
Namespace DedNet.Forms


Metodo DedFormBomCompareExp.Dispose

Metodo DedFormBomCompareExpDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormBomCompareExp
Namespace DedNet.Forms


Eventi di DedFormBomCompareExp

Il tipo DedFormBomCompareExp espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormBomCompareExp
Namespace DedNet.Forms


Campi di DedFormBomCompareExp

Il tipo DedFormBomCompareExp espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormBomCompareExp
Namespace DedNet.Forms


Classe DedFormBomEdit
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormBomEdit

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormBomEdit : BaseForm
Public Class DedFormBomEdit
    Inherits BaseForm
public ref class DedFormBomEdit : public BaseForm
type DedFormBomEdit =
    class
        inherit BaseForm
    end

Il tipo DedFormBomEdit espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormBomEdit | Costruttore della classe.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà pubblica | CommandBar | Ritorna la barra dei comandi
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà pubblica | CustomButtons | Ritorna il dizionario contenente i custombuttons definiti esternamente. La chiave corrisponde al 'Nome' dell'oggetto creato, il valore è il BurButtonItem.
Proprietà pubblica | CustomVars | Dizionario di variabili utente settabile dall'esterno tramite script
Proprietà pubblica | DedBomExplorerControlDx | Ccontrollo explorer di destra
Proprietà pubblica | DedBomExplorerControlSx | Ccontrollo explorer di sinistra
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà pubblica | DockManager | Ritorna il controllo dockmanager associato al form
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà pubblica | InitBehaviour | Gestione proprietà comportamento in fase di inizializzazione
Proprietà pubblica | InitDedData | Gestione proprietà dati anagrafica in fase di inizializzazione
Proprietà pubblica | InitDiscrimDist | Gestione proprietà dati anagrafica in fase di inizializzazione
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo pubblico | Compare | Esegue la comparazione delle due distinte attive.
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormBomEdit
Costruttore della classe.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormBomEdit(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedFormBomEdit(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedFormBomEdit

Parametri

app DedNetApplication
Oggetto applicazione di appartenenza.
Vedi anche

Documentazione

Classe DedFormBomEdit
Namespace DedNet.Forms


Proprietà di DedFormBomEdit

Il tipo DedFormBomEdit espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà pubblica | CommandBar | Ritorna la barra dei comandi
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà pubblica | CustomButtons | Ritorna il dizionario contenente i custombuttons definiti esternamente. La chiave corrisponde al 'Nome' dell'oggetto creato, il valore è il BurButtonItem.
Proprietà pubblica | CustomVars | Dizionario di variabili utente settabile dall'esterno tramite script
Proprietà pubblica | DedBomExplorerControlDx | Ccontrollo explorer di destra
Proprietà pubblica | DedBomExplorerControlSx | Ccontrollo explorer di sinistra
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà pubblica | DockManager | Ritorna il controllo dockmanager associato al form
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà pubblica | InitBehaviour | Gestione proprietà comportamento in fase di inizializzazione
Proprietà pubblica | InitDedData | Gestione proprietà dati anagrafica in fase di inizializzazione
Proprietà pubblica | InitDiscrimDist | Gestione proprietà dati anagrafica in fase di inizializzazione
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormBomEdit
Namespace DedNet.Forms


Proprietà DedFormBomEdit.CommandBar

Proprietà DedFormBomEditCommandBar
Ritorna la barra dei comandi

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Bar CommandBar { get; }
Public ReadOnly Property CommandBar As Bar
    Get
public:
property Bar^ CommandBar {
    Bar^ get ();
}
member CommandBar : Bar with get

Valore della proprietà

Bar
Vedi anche

Documentazione

Classe DedFormBomEdit
Namespace DedNet.Forms


Proprietà DedFormBomEdit.CustomButtons

Proprietà DedFormBomEditCustomButtons
Ritorna il dizionario contenente i custombuttons definiti esternamente. La chiave corrisponde al 'Nome' dell'oggetto creato, il valore è il BurButtonItem.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<string, BarItem> CustomButtons { get; }
Public ReadOnly Property CustomButtons As Dictionary(Of String, BarItem)
    Get
public:
property Dictionary<String^, BarItem^>^ CustomButtons {
    Dictionary<String^, BarItem^>^ get ();
}
member CustomButtons : Dictionary<string, BarItem> with get

Valore della proprietà

Dictionary String, BarItem
Vedi anche

Documentazione

Classe DedFormBomEdit
Namespace DedNet.Forms


Proprietà DedFormBomEdit.CustomVars

Proprietà DedFormBomEditCustomVars
Dizionario di variabili utente settabile dall'esterno tramite script

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<string, Object> CustomVars { get; set; }
Public Property CustomVars As Dictionary(Of String, Object)
    Get
    Set
public:
property Dictionary<String^, Object^>^ CustomVars {
    Dictionary<String^, Object^>^ get ();
    void set (Dictionary<String^, Object^>^ value);
}
member CustomVars : Dictionary<string, Object> with get, set

Valore della proprietà

Dictionary String, Object
Vedi anche

Documentazione

Classe DedFormBomEdit
Namespace DedNet.Forms


Proprietà DedFormBomEdit.DedBomExplorerControlDx

Proprietà DedFormBomEditDedBomExplorerControlDx
Ccontrollo explorer di destra

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedBomExplorerControl DedBomExplorerControlDx { get; }
Public ReadOnly Property DedBomExplorerControlDx As DedBomExplorerControl
    Get
public:
property DedBomExplorerControl^ DedBomExplorerControlDx {
    DedBomExplorerControl^ get ();
}
member DedBomExplorerControlDx : DedBomExplorerControl with get

Valore della proprietà

DedBomExplorerControl
Vedi anche

Documentazione

Classe DedFormBomEdit
Namespace DedNet.Forms


Proprietà DedFormBomEdit.DedBomExplorerControlSx

Proprietà DedFormBomEditDedBomExplorerControlSx
Ccontrollo explorer di sinistra

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedBomExplorerControl DedBomExplorerControlSx { get; }
Public ReadOnly Property DedBomExplorerControlSx As DedBomExplorerControl
    Get
public:
property DedBomExplorerControl^ DedBomExplorerControlSx {
    DedBomExplorerControl^ get ();
}
member DedBomExplorerControlSx : DedBomExplorerControl with get

Valore della proprietà

DedBomExplorerControl
Vedi anche

Documentazione

Classe DedFormBomEdit
Namespace DedNet.Forms


Proprietà DedFormBomEdit.DockManager

Proprietà DedFormBomEditDockManager
Ritorna il controllo dockmanager associato al form

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DockManager DockManager { get; }
Public ReadOnly Property DockManager As DockManager
    Get
public:
property DockManager^ DockManager {
    DockManager^ get ();
}
member DockManager : DockManager with get

Valore della proprietà

DockManager
Vedi anche

Documentazione

Classe DedFormBomEdit
Namespace DedNet.Forms


Proprietà DedFormBomEdit.InitBehaviour

Proprietà DedFormBomEditInitBehaviour
Gestione proprietà comportamento in fase di inizializzazione

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomEditCommandDedBomEditCommandBehaviourEnum InitBehaviour { get; set; }
Public Property InitBehaviour As BomEditCommandDedBomEditCommandBehaviourEnum
    Get
    Set
public:
property BomEditCommandDedBomEditCommandBehaviourEnum InitBehaviour {
    BomEditCommandDedBomEditCommandBehaviourEnum get ();
    void set (BomEditCommandDedBomEditCommandBehaviourEnum value);
}
member InitBehaviour : BomEditCommandDedBomEditCommandBehaviourEnum with get, set

Valore della proprietà

BomEditCommandDedBomEditCommandBehaviourEnum
Vedi anche

Documentazione

Classe DedFormBomEdit
Namespace DedNet.Forms


Proprietà DedFormBomEdit.InitDedData

Proprietà DedFormBomEditInitDedData
Gestione proprietà dati anagrafica in fase di inizializzazione

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData InitDedData { get; set; }
Public Property InitDedData As DedData
    Get
    Set
public:
property DedData^ InitDedData {
    DedData^ get ();
    void set (DedData^ value);
}
member InitDedData : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe DedFormBomEdit
Namespace DedNet.Forms


Proprietà DedFormBomEdit.InitDiscrimDist

Proprietà DedFormBomEditInitDiscrimDist
Gestione proprietà dati anagrafica in fase di inizializzazione

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string InitDiscrimDist { get; set; }
Public Property InitDiscrimDist As String
    Get
    Set
public:
property String^ InitDiscrimDist {
    String^ get ();
    void set (String^ value);
}
member InitDiscrimDist : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedFormBomEdit
Namespace DedNet.Forms


Metodi di DedFormBomEdit

Il tipo DedFormBomEdit espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo pubblico | Compare | Esegue la comparazione delle due distinte attive.
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormBomEdit
Namespace DedNet.Forms


Metodo DedFormBomEdit.Compare

Metodo DedFormBomEditCompare
Esegue la comparazione delle due distinte attive.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Compare()
Public Sub Compare
public:
void Compare()
member Compare : unit -> unit
Vedi anche

Documentazione

Classe DedFormBomEdit
Namespace DedNet.Forms


Metodo DedFormBomEdit.Dispose

Metodo DedFormBomEditDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormBomEdit
Namespace DedNet.Forms


Eventi di DedFormBomEdit

Il tipo DedFormBomEdit espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormBomEdit
Namespace DedNet.Forms


Campi di DedFormBomEdit

Il tipo DedFormBomEdit espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormBomEdit
Namespace DedNet.Forms


Classe DedFormBomHistory
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormBomHistory

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormBomHistory : BaseForm
Public Class DedFormBomHistory
    Inherits BaseForm
public ref class DedFormBomHistory : public BaseForm
type DedFormBomHistory =
    class
        inherit BaseForm
    end

Il tipo DedFormBomHistory espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormBomHistory | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà pubblica | CurrentDiscr | Discriminante di distina correntemente selezionato.
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormBomHistory
Costruttore unico.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormBomHistory(
    DedNetApplication app,
    DedData data,
    string currentDiscr
)
Public Sub New (
    app As DedNetApplication,
    data As DedData,
    currentDiscr As String
)
public:
DedFormBomHistory(
    DedNetApplication^ app,
    DedData^ data,
    String^ currentDiscr
)
new :
        app : DedNetApplication *
        data : DedData *
        currentDiscr : string -> DedFormBomHistory

Parametri

app DedNetApplication
data DedData
currentDiscr String
Vedi anche

Documentazione

Classe DedFormBomHistory
Namespace DedNet.Forms


Proprietà di DedFormBomHistory

Il tipo DedFormBomHistory espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà pubblica | CurrentDiscr | Discriminante di distina correntemente selezionato.
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormBomHistory
Namespace DedNet.Forms


Proprietà DedFormBomHistory.CurrentDiscr

Proprietà DedFormBomHistoryCurrentDiscr
Discriminante di distina correntemente selezionato.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string CurrentDiscr { get; set; }
Public Property CurrentDiscr As String
    Get
    Set
public:
property String^ CurrentDiscr {
    String^ get ();
    void set (String^ value);
}
member CurrentDiscr : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedFormBomHistory
Namespace DedNet.Forms


Metodi di DedFormBomHistory

Il tipo DedFormBomHistory espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormBomHistory
Namespace DedNet.Forms


Metodo DedFormBomHistory.Dispose

Metodo DedFormBomHistoryDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormBomHistory
Namespace DedNet.Forms


Eventi di DedFormBomHistory

Il tipo DedFormBomHistory espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormBomHistory
Namespace DedNet.Forms


Campi di DedFormBomHistory

Il tipo DedFormBomHistory espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormBomHistory
Namespace DedNet.Forms


Classe DedFormCascade
Finestra di dialogo per la creazione ed editazione delle cascate.
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormCascade

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormCascade : BaseForm
Public Class DedFormCascade
    Inherits BaseForm
public ref class DedFormCascade : public BaseForm
type DedFormCascade =
    class
        inherit BaseForm
    end

Il tipo DedFormCascade espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormCascade | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Applicazione DedNet.
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo pubblico | GetAttValues | Ritorna una lista di ComboItem rappresentante gli elementi dell'AttList dell'attributo.
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo pubblico | SetRootType | Imposta la famiglia/commessa.
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormCascade
Costruttore unico.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormCascade(
    DedNetApplication app,
    DedFormCascadeRootTypeEnum rootType = DedFormCascadeRootTypeEnum.Fam
)
Public Sub New (
    app As DedNetApplication,
    Optional rootType As DedFormCascadeRootTypeEnum = DedFormCascadeRootTypeEnum.Fam
)
public:
DedFormCascade(
    DedNetApplication^ app,
    DedFormCascadeRootTypeEnum rootType = DedFormCascadeRootTypeEnum::Fam
)
new :
        app : DedNetApplication *
        ?rootType : DedFormCascadeRootTypeEnum
(* Defaults:
        let _rootType = defaultArg rootType DedFormCascadeRootTypeEnum.Fam
*)
-> DedFormCascade

Parametri

app DedNetApplication
Applicazione DedNet.
rootType DedFormCascadeRootTypeEnum (Optional)
Tipologia.
Vedi anche

Documentazione

Classe DedFormCascade
Namespace DedNet.Forms


Proprietà di DedFormCascade

Il tipo DedFormCascade espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Applicazione DedNet.
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormCascade
Namespace DedNet.Forms


Proprietà DedFormCascade.Application

Proprietà DedFormCascadeApplication
Applicazione DedNet.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedNetApplication Application { get; set; }
Public Property Application As DedNetApplication
    Get
    Set
public:
property DedNetApplication^ Application {
    DedNetApplication^ get ();
    void set (DedNetApplication^ value);
}
member Application : DedNetApplication with get, set

Valore della proprietà

DedNetApplication
Vedi anche

Documentazione

Classe DedFormCascade
Namespace DedNet.Forms


Metodi di DedFormCascade

Il tipo DedFormCascade espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo pubblico | GetAttValues | Ritorna una lista di ComboItem rappresentante gli elementi dell'AttList dell'attributo.
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo pubblico | SetRootType | Imposta la famiglia/commessa.
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormCascade
Namespace DedNet.Forms


Metodo DedFormCascade.Dispose

Metodo DedFormCascadeDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormCascade
Namespace DedNet.Forms


Metodo DedFormCascade.GetAttValues

Metodo DedFormCascadeGetAttValues
Ritorna una lista di ComboItem rappresentante gli elementi dell'AttList dell'attributo.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<ComboItem> GetAttValues(
    DedAttr attr
)
Public Function GetAttValues (
    attr As DedAttr
) As List(Of ComboItem)
public:
List<ComboItem^>^ GetAttValues(
    DedAttr^ attr
)
member GetAttValues :
        attr : DedAttr -> List<ComboItem>

Parametri

attr DedAttr

Valore di ritorno

List ComboItem
Vedi anche

Documentazione

Classe DedFormCascade
Namespace DedNet.Forms


Metodo DedFormCascade.SetRootType

Metodo DedFormCascadeSetRootType
Imposta la famiglia/commessa.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetRootType(
    DedFormCascadeRootTypeEnum rootType
)
Public Sub SetRootType (
    rootType As DedFormCascadeRootTypeEnum
)
public:
void SetRootType(
    DedFormCascadeRootTypeEnum rootType
)
member SetRootType :
        rootType : DedFormCascadeRootTypeEnum -> unit

Parametri

rootType DedFormCascadeRootTypeEnum
Tipologia della root.
Vedi anche

Documentazione

Classe DedFormCascade
Namespace DedNet.Forms


Eventi di DedFormCascade

Il tipo DedFormCascade espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormCascade
Namespace DedNet.Forms


Campi di DedFormCascade

Il tipo DedFormCascade espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormCascade
Namespace DedNet.Forms


Enumerazione DedFormCascade.RootTypeEnum

Enumerazione DedFormCascadeRootTypeEnum
Indentifica la tipologia.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum RootTypeEnum
Public Enumeration RootTypeEnum
public enum class RootTypeEnum
type RootTypeEnum
Membri
Nome | Valore | Descrizione
Fam | 0 | Famiglie.
Comm | 1 | Commesse.
Vedi anche

Documentazione

Namespace DedNet.Forms


Classe DedFormCategory
Form per la gestione (creazione, spostamento, modifica ed eliminazione) delle categorie.
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormCategory

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormCategory : BaseForm
Public Class DedFormCategory
    Inherits BaseForm
public ref class DedFormCategory : public BaseForm
type DedFormCategory =
    class
        inherit BaseForm
    end

Il tipo DedFormCategory espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormCategory | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormCategory
Costruttore unico.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormCategory(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedFormCategory(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedFormCategory

Parametri

app DedNetApplication
Applicazione DedNet.
Vedi anche

Documentazione

Classe DedFormCategory
Namespace DedNet.Forms


Proprietà di DedFormCategory

Il tipo DedFormCategory espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormCategory
Namespace DedNet.Forms


Metodi di DedFormCategory

Il tipo DedFormCategory espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormCategory
Namespace DedNet.Forms


Metodo DedFormCategory.Dispose

Metodo DedFormCategoryDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormCategory
Namespace DedNet.Forms


Eventi di DedFormCategory

Il tipo DedFormCategory espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormCategory
Namespace DedNet.Forms


Campi di DedFormCategory

Il tipo DedFormCategory espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormCategory
Namespace DedNet.Forms


Classe DedFormChangePwd
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormChangePwd

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormChangePwd : BaseForm
Public Class DedFormChangePwd
    Inherits BaseForm
public ref class DedFormChangePwd : public BaseForm
type DedFormChangePwd =
    class
        inherit BaseForm
    end

Il tipo DedFormChangePwd espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormChangePwd |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Proprietà pubblica | User |
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormChangePwd

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormChangePwd(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedFormChangePwd(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedFormChangePwd

Parametri

app DedNetApplication
Vedi anche

Documentazione

Classe DedFormChangePwd
Namespace DedNet.Forms


Proprietà di DedFormChangePwd

Il tipo DedFormChangePwd espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Proprietà pubblica | User |
Torna su
Vedi anche

Documentazione

Classe DedFormChangePwd
Namespace DedNet.Forms


Proprietà DedFormChangePwd.User

Proprietà DedFormChangePwdUser

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string User { get; set; }
Public Property User As String
    Get
    Set
public:
property String^ User {
    String^ get ();
    void set (String^ value);
}
member User : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedFormChangePwd
Namespace DedNet.Forms


Metodi di DedFormChangePwd

Il tipo DedFormChangePwd espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormChangePwd
Namespace DedNet.Forms


Metodo DedFormChangePwd.Dispose

Metodo DedFormChangePwdDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormChangePwd
Namespace DedNet.Forms


Eventi di DedFormChangePwd

Il tipo DedFormChangePwd espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormChangePwd
Namespace DedNet.Forms


Campi di DedFormChangePwd

Il tipo DedFormChangePwd espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormChangePwd
Namespace DedNet.Forms


Classe DedFormChangeState
Form per il cambio di stato.
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormChangeState

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormChangeState : BaseForm
Public Class DedFormChangeState
    Inherits BaseForm
public ref class DedFormChangeState : public BaseForm
type DedFormChangeState =
    class
        inherit BaseForm
    end

Il tipo DedFormChangeState espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormChangeState | costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà pubblica | CurrentState | Imposta / Restituisce lo stato di partenza.
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | Note | Restiuisce le note inserite sul cambio stato.
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà pubblica | TargetState | Restiuisce lo stato di destinazione.
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormChangeState
costruttore unico.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormChangeState(
    DedNetApplication app,
    DedState currentState,
    bool includeCurrentState
)
Public Sub New (
    app As DedNetApplication,
    currentState As DedState,
    includeCurrentState As Boolean
)
public:
DedFormChangeState(
    DedNetApplication^ app,
    DedState^ currentState,
    bool includeCurrentState
)
new :
        app : DedNetApplication *
        currentState : DedState *
        includeCurrentState : bool -> DedFormChangeState

Parametri

app DedNetApplication
DedNetApplication
currentState DedState
Stato attuale dell'anagrafica.
includeCurrentState Boolean
Indica se aggiungere anche lo stato corrente in lista
Vedi anche

Documentazione

Classe DedFormChangeState
Namespace DedNet.Forms


Proprietà di DedFormChangeState

Il tipo DedFormChangeState espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà pubblica | CurrentState | Imposta / Restituisce lo stato di partenza.
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | Note | Restiuisce le note inserite sul cambio stato.
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà pubblica | TargetState | Restiuisce lo stato di destinazione.
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormChangeState
Namespace DedNet.Forms


Proprietà DedFormChangeState.CurrentState

Proprietà DedFormChangeStateCurrentState
Imposta / Restituisce lo stato di partenza.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedState CurrentState { get; set; }
Public Property CurrentState As DedState
    Get
    Set
public:
property DedState^ CurrentState {
    DedState^ get ();
    void set (DedState^ value);
}
member CurrentState : DedState with get, set

Valore della proprietà

DedState
Vedi anche

Documentazione

Classe DedFormChangeState
Namespace DedNet.Forms


Proprietà DedFormChangeState.Note

Proprietà DedFormChangeStateNote
Restiuisce le note inserite sul cambio stato.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Note { get; }
Public ReadOnly Property Note As String
    Get
public:
property String^ Note {
    String^ get ();
}
member Note : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedFormChangeState
Namespace DedNet.Forms


Proprietà DedFormChangeState.TargetState

Proprietà DedFormChangeStateTargetState
Restiuisce lo stato di destinazione.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedState TargetState { get; }
Public ReadOnly Property TargetState As DedState
    Get
public:
property DedState^ TargetState {
    DedState^ get ();
}
member TargetState : DedState with get

Valore della proprietà

DedState
Vedi anche

Documentazione

Classe DedFormChangeState
Namespace DedNet.Forms


Metodi di DedFormChangeState

Il tipo DedFormChangeState espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormChangeState
Namespace DedNet.Forms


Metodo DedFormChangeState.Dispose

Metodo DedFormChangeStateDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormChangeState
Namespace DedNet.Forms


Eventi di DedFormChangeState

Il tipo DedFormChangeState espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormChangeState
Namespace DedNet.Forms


Campi di DedFormChangeState

Il tipo DedFormChangeState espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormChangeState
Namespace DedNet.Forms


Classe DedFormChooseComm
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormChooseComm

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormChooseComm : BaseForm
Public Class DedFormChooseComm
    Inherits BaseForm
public ref class DedFormChooseComm : public BaseForm
type DedFormChooseComm =
    class
        inherit BaseForm
    end

Il tipo DedFormChooseComm espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormChooseComm | Costruttore unico
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà pubblica | ChooseElementComm | Imposta/Restituisce il tipo di selezione da effettuare all'interno del form.
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà pubblica | CommName | Restituisce il nome della commessa.
Proprietà pubblica | CommSelected | Restituisce la commessa selezionata
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà pubblica | DocsSelected | Restituisce la lista dei documenti selezionati
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HideQta | Se True rimuove il controllo di scelta quantità
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | PathSelected | Restituisce il percorso selezionato
Proprietà pubblica | Qta | Restituisce la quantità di elementi da inserire in commessa.
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormChooseComm
Costruttore unico

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormChooseComm(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedFormChooseComm(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedFormChooseComm

Parametri

app DedNetApplication
DedNetApplication
Vedi anche

Documentazione

Classe DedFormChooseComm
Namespace DedNet.Forms


Proprietà di DedFormChooseComm

Il tipo DedFormChooseComm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà pubblica | ChooseElementComm | Imposta/Restituisce il tipo di selezione da effettuare all'interno del form.
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà pubblica | CommName | Restituisce il nome della commessa.
Proprietà pubblica | CommSelected | Restituisce la commessa selezionata
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà pubblica | DocsSelected | Restituisce la lista dei documenti selezionati
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HideQta | Se True rimuove il controllo di scelta quantità
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | PathSelected | Restituisce il percorso selezionato
Proprietà pubblica | Qta | Restituisce la quantità di elementi da inserire in commessa.
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormChooseComm
Namespace DedNet.Forms


Proprietà DedFormChooseComm.ChooseElementComm

Proprietà DedFormChooseCommChooseElementComm
Imposta/Restituisce il tipo di selezione da effettuare all'interno del form.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedChooseElementComm ChooseElementComm { get; set; }
Public Property ChooseElementComm As DedChooseElementComm
    Get
    Set
public:
property DedChooseElementComm ChooseElementComm {
    DedChooseElementComm get ();
    void set (DedChooseElementComm value);
}
member ChooseElementComm : DedChooseElementComm with get, set

Valore della proprietà

DedChooseElementComm
Vedi anche

Documentazione

Classe DedFormChooseComm
Namespace DedNet.Forms


Proprietà DedFormChooseComm.CommName

Proprietà DedFormChooseCommCommName
Restituisce il nome della commessa.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string CommName { get; }
Public ReadOnly Property CommName As String
    Get
public:
property String^ CommName {
    String^ get ();
}
member CommName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedFormChooseComm
Namespace DedNet.Forms


Proprietà DedFormChooseComm.CommSelected

Proprietà DedFormChooseCommCommSelected
Restituisce la commessa selezionata

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedComm CommSelected { get; }
Public ReadOnly Property CommSelected As DedComm
    Get
public:
property DedComm^ CommSelected {
    DedComm^ get ();
}
member CommSelected : DedComm with get

Valore della proprietà

DedComm
Vedi anche

Documentazione

Classe DedFormChooseComm
Namespace DedNet.Forms


Proprietà DedFormChooseComm.DocsSelected

Proprietà DedFormChooseCommDocsSelected
Restituisce la lista dei documenti selezionati

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocList DocsSelected { get; }
Public ReadOnly Property DocsSelected As DedDocList
    Get
public:
property DedDocList^ DocsSelected {
    DedDocList^ get ();
}
member DocsSelected : DedDocList with get

Valore della proprietà

DedDocList
Vedi anche

Documentazione

Classe DedFormChooseComm
Namespace DedNet.Forms


Proprietà DedFormChooseComm.HideQta

Proprietà DedFormChooseCommHideQta
Se True rimuove il controllo di scelta quantità

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HideQta { set; }
Public WriteOnly Property HideQta As Boolean
    Set
public:
property bool HideQta {
    void set (bool value);
}
member HideQta : bool with set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormChooseComm
Namespace DedNet.Forms


Proprietà DedFormChooseComm.PathSelected

Proprietà DedFormChooseCommPathSelected
Restituisce il percorso selezionato

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string PathSelected { get; }
Public ReadOnly Property PathSelected As String
    Get
public:
property String^ PathSelected {
    String^ get ();
}
member PathSelected : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedFormChooseComm
Namespace DedNet.Forms


Proprietà DedFormChooseComm.Qta

Proprietà DedFormChooseCommQta
Restituisce la quantità di elementi da inserire in commessa.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int Qta { get; set; }
Public Property Qta As Integer
    Get
    Set
public:
property int Qta {
    int get ();
    void set (int value);
}
member Qta : int with get, set

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe DedFormChooseComm
Namespace DedNet.Forms


Metodi di DedFormChooseComm

Il tipo DedFormChooseComm espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormChooseComm
Namespace DedNet.Forms


Metodo DedFormChooseComm.Dispose

Metodo DedFormChooseCommDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormChooseComm
Namespace DedNet.Forms


Eventi di DedFormChooseComm

Il tipo DedFormChooseComm espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormChooseComm
Namespace DedNet.Forms


Campi di DedFormChooseComm

Il tipo DedFormChooseComm espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormChooseComm
Namespace DedNet.Forms


Classe DedFormChoseFile
Form che permette di selezionare il tipo di documenti da usare.
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormChoseFile

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormChoseFile : BaseForm
Public Class DedFormChoseFile
    Inherits BaseForm
public ref class DedFormChoseFile : public BaseForm
type DedFormChoseFile =
    class
        inherit BaseForm
    end

Il tipo DedFormChoseFile espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormChoseFile | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà pubblica | Context | Indica il contesto dei documenti scelto: Allegato - Solo documenti allegati. Modello - Solo documenti primari. None - Documenti primari + allegati.
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | FilterExt | Indica la lista delle estensioni da filtrare
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | OnlyPub | Indica se usare solo i file di pubblicazione.
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà pubblica | StructureFolder | Indica se creare la struttura cartelle o meno
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Proprietà pubblica | WithAnagr | Indica se zippare anche le anagrafiche collegate alle commesse
Proprietà pubblica | WithCommChildren | Indica se zippare anche le commesse figlie
Proprietà pubblica | Zip | Indica se creare la struttura cartelle o meno
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo pubblico | DisableAnagCtrls | Metodo che disabilita tutti i controlli eccetto "Crea struttura cartelle"
Metodo pubblico | DisableZip | Disabilita la spunta dello zip.
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo pubblico | LoadRegistrySetting | Carica dal registro le informazioni necessarie
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo pubblico | SaveRegistrySettings | Salva nel registro di sistema le informazioni necessarie
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormChoseFile
Costruttore unico.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormChoseFile(
    DedNetApplication _app,
    bool comm
)
Public Sub New (
    _app As DedNetApplication,
    comm As Boolean
)
public:
DedFormChoseFile(
    DedNetApplication^ _app,
    bool comm
)
new :
        _app : DedNetApplication *
        comm : bool -> DedFormChoseFile

Parametri

_app DedNetApplication
Oggetto applicazione.
comm Boolean
Indica se devo rendere visibile il tab Commesse
Vedi anche

Documentazione

Classe DedFormChoseFile
Namespace DedNet.Forms


Proprietà di DedFormChoseFile

Il tipo DedFormChoseFile espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà pubblica | Context | Indica il contesto dei documenti scelto: Allegato - Solo documenti allegati. Modello - Solo documenti primari. None - Documenti primari + allegati.
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | FilterExt | Indica la lista delle estensioni da filtrare
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | OnlyPub | Indica se usare solo i file di pubblicazione.
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà pubblica | StructureFolder | Indica se creare la struttura cartelle o meno
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Proprietà pubblica | WithAnagr | Indica se zippare anche le anagrafiche collegate alle commesse
Proprietà pubblica | WithCommChildren | Indica se zippare anche le commesse figlie
Proprietà pubblica | Zip | Indica se creare la struttura cartelle o meno
Torna su
Vedi anche

Documentazione

Classe DedFormChoseFile
Namespace DedNet.Forms


Proprietà DedFormChoseFile.Context

Proprietà DedFormChoseFileContext
Indica il contesto dei documenti scelto: Allegato - Solo documenti allegati. Modello - Solo documenti primari. None - Documenti primari + allegati.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocContextEnum Context { get; }
Public ReadOnly Property Context As DedDocContextEnum
    Get
public:
property DedDocContextEnum Context {
    DedDocContextEnum get ();
}
member Context : DedDocContextEnum with get

Valore della proprietà

DedDocContextEnum
Vedi anche

Documentazione

Classe DedFormChoseFile
Namespace DedNet.Forms


Proprietà DedFormChoseFile.FilterExt

Proprietà DedFormChoseFileFilterExt
Indica la lista delle estensioni da filtrare

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> FilterExt { get; }
Public ReadOnly Property FilterExt As List(Of String)
    Get
public:
property List<String^>^ FilterExt {
    List<String^>^ get ();
}
member FilterExt : List<string> with get

Valore della proprietà

List String
Vedi anche

Documentazione

Classe DedFormChoseFile
Namespace DedNet.Forms


Proprietà DedFormChoseFile.OnlyPub

Proprietà DedFormChoseFileOnlyPub
Indica se usare solo i file di pubblicazione.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool OnlyPub { get; }
Public ReadOnly Property OnlyPub As Boolean
    Get
public:
property bool OnlyPub {
    bool get ();
}
member OnlyPub : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormChoseFile
Namespace DedNet.Forms


Proprietà DedFormChoseFile.StructureFolder

Proprietà DedFormChoseFileStructureFolder
Indica se creare la struttura cartelle o meno

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool StructureFolder { get; }
Public ReadOnly Property StructureFolder As Boolean
    Get
public:
property bool StructureFolder {
    bool get ();
}
member StructureFolder : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormChoseFile
Namespace DedNet.Forms


Proprietà DedFormChoseFile.WithAnagr

Proprietà DedFormChoseFileWithAnagr
Indica se zippare anche le anagrafiche collegate alle commesse

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool WithAnagr { get; }
Public ReadOnly Property WithAnagr As Boolean
    Get
public:
property bool WithAnagr {
    bool get ();
}
member WithAnagr : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormChoseFile
Namespace DedNet.Forms


Proprietà DedFormChoseFile.WithCommChildren

Proprietà DedFormChoseFileWithCommChildren
Indica se zippare anche le commesse figlie

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool WithCommChildren { get; }
Public ReadOnly Property WithCommChildren As Boolean
    Get
public:
property bool WithCommChildren {
    bool get ();
}
member WithCommChildren : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormChoseFile
Namespace DedNet.Forms


Proprietà DedFormChoseFile.Zip

Proprietà DedFormChoseFileZip
Indica se creare la struttura cartelle o meno

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Zip { get; }
Public ReadOnly Property Zip As Boolean
    Get
public:
property bool Zip {
    bool get ();
}
member Zip : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormChoseFile
Namespace DedNet.Forms


Metodi di DedFormChoseFile

Il tipo DedFormChoseFile espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo pubblico | DisableAnagCtrls | Metodo che disabilita tutti i controlli eccetto "Crea struttura cartelle"
Metodo pubblico | DisableZip | Disabilita la spunta dello zip.
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo pubblico | LoadRegistrySetting | Carica dal registro le informazioni necessarie
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo pubblico | SaveRegistrySettings | Salva nel registro di sistema le informazioni necessarie
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormChoseFile
Namespace DedNet.Forms


Metodo DedFormChoseFile.DisableAnagCtrls

Metodo DedFormChoseFileDisableAnagCtrls
Metodo che disabilita tutti i controlli eccetto "Crea struttura cartelle"

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void DisableAnagCtrls()
Public Sub DisableAnagCtrls
public:
void DisableAnagCtrls()
member DisableAnagCtrls : unit -> unit
Vedi anche

Documentazione

Classe DedFormChoseFile
Namespace DedNet.Forms


Metodo DedFormChoseFile.DisableZip

Metodo DedFormChoseFileDisableZip
Disabilita la spunta dello zip.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void DisableZip()
Public Sub DisableZip
public:
void DisableZip()
member DisableZip : unit -> unit
Vedi anche

Documentazione

Classe DedFormChoseFile
Namespace DedNet.Forms


Metodo DedFormChoseFile.Dispose

Metodo DedFormChoseFileDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormChoseFile
Namespace DedNet.Forms


Metodo DedFormChoseFile.LoadRegistrySetting

Metodo DedFormChoseFileLoadRegistrySetting
Carica dal registro le informazioni necessarie

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void LoadRegistrySetting()
Public Sub LoadRegistrySetting
public:
void LoadRegistrySetting()
member LoadRegistrySetting : unit -> unit
Vedi anche

Documentazione

Classe DedFormChoseFile
Namespace DedNet.Forms


Metodo DedFormChoseFile.SaveRegistrySettings

Metodo DedFormChoseFileSaveRegistrySettings
Salva nel registro di sistema le informazioni necessarie

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SaveRegistrySettings()
Public Sub SaveRegistrySettings
public:
void SaveRegistrySettings()
member SaveRegistrySettings : unit -> unit
Vedi anche

Documentazione

Classe DedFormChoseFile
Namespace DedNet.Forms


Eventi di DedFormChoseFile

Il tipo DedFormChoseFile espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormChoseFile
Namespace DedNet.Forms


Campi di DedFormChoseFile

Il tipo DedFormChoseFile espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormChoseFile
Namespace DedNet.Forms


Classe DedFormComm
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormComm

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormComm : BaseForm
Public Class DedFormComm
    Inherits BaseForm
public ref class DedFormComm : public BaseForm
type DedFormComm =
    class
        inherit BaseForm
    end

Il tipo DedFormComm espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormComm | Costruttore della classe
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà pubblica | AllLev | Indica se visualizzare anche le commesse collegate tramite la distinta implosa del codice.
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormComm
Costruttore della classe

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormComm(
    DedNetApplication app,
    DedData anagr = null
)
Public Sub New (
    app As DedNetApplication,
    Optional anagr As DedData = Nothing
)
public:
DedFormComm(
    DedNetApplication^ app,
    DedData^ anagr = nullptr
)
new :
        app : DedNetApplication *
        ?anagr : DedData
(* Defaults:
        let _anagr = defaultArg anagr null
*)
-> DedFormComm

Parametri

app DedNetApplication
Oggetto applicazione
anagr DedData (Optional)
Vedi anche

Documentazione

Classe DedFormComm
Namespace DedNet.Forms


Proprietà di DedFormComm

Il tipo DedFormComm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà pubblica | AllLev | Indica se visualizzare anche le commesse collegate tramite la distinta implosa del codice.
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormComm
Namespace DedNet.Forms


Proprietà DedFormComm.AllLev

Proprietà DedFormCommAllLev
Indica se visualizzare anche le commesse collegate tramite la distinta implosa del codice.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AllLev { get; set; }
Public Property AllLev As Boolean
    Get
    Set
public:
property bool AllLev {
    bool get ();
    void set (bool value);
}
member AllLev : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormComm
Namespace DedNet.Forms


Metodi di DedFormComm

Il tipo DedFormComm espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormComm
Namespace DedNet.Forms


Metodo DedFormComm.Dispose

Metodo DedFormCommDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormComm
Namespace DedNet.Forms


Eventi di DedFormComm

Il tipo DedFormComm espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormComm
Namespace DedNet.Forms


Campi di DedFormComm

Il tipo DedFormComm espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormComm
Namespace DedNet.Forms


Classe DedFormCommMaster
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormCommMaster

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormCommMaster : BaseForm
Public Class DedFormCommMaster
    Inherits BaseForm
public ref class DedFormCommMaster : public BaseForm
type DedFormCommMaster =
    class
        inherit BaseForm
    end

Il tipo DedFormCommMaster espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormCommMaster | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | Reload | Indica se la grigli deve essere ricaricata
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo pubblico | NavigateDetails | Scorre tutte le viste finche non trova la commessa desiderata.
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo pubblico | SetFocusOnComm | Imposta il focus su una determinata commessa.
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormCommMaster
Costruttore

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormCommMaster(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedFormCommMaster(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedFormCommMaster

Parametri

app DedNetApplication
Vedi anche

Documentazione

Classe DedFormCommMaster
Namespace DedNet.Forms


Proprietà di DedFormCommMaster

Il tipo DedFormCommMaster espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | Reload | Indica se la grigli deve essere ricaricata
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormCommMaster
Namespace DedNet.Forms


Proprietà DedFormCommMaster.Reload

Proprietà DedFormCommMasterReload
Indica se la grigli deve essere ricaricata

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Reload { get; }
Public ReadOnly Property Reload As Boolean
    Get
public:
property bool Reload {
    bool get ();
}
member Reload : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormCommMaster
Namespace DedNet.Forms


Metodi di DedFormCommMaster

Il tipo DedFormCommMaster espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo pubblico | NavigateDetails | Scorre tutte le viste finche non trova la commessa desiderata.
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo pubblico | SetFocusOnComm | Imposta il focus su una determinata commessa.
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormCommMaster
Namespace DedNet.Forms


Metodo DedFormCommMaster.Dispose

Metodo DedFormCommMasterDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormCommMaster
Namespace DedNet.Forms


Metodo DedFormCommMaster.NavigateDetails

Metodo DedFormCommMasterNavigateDetails
Scorre tutte le viste finche non trova la commessa desiderata.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool NavigateDetails(
    ColumnView inspectedView,
    string commname
)
Public Function NavigateDetails (
    inspectedView As ColumnView,
    commname As String
) As Boolean
public:
bool NavigateDetails(
    ColumnView^ inspectedView,
    String^ commname
)
member NavigateDetails :
        inspectedView : ColumnView *
        commname : string -> bool

Parametri

inspectedView ColumnView
Vista da analizzare.
commname String
Nome della commessa da ricercare.

Valore di ritorno

Boolean
Restituisce true se la trova.
Vedi anche

Documentazione

Classe DedFormCommMaster
Namespace DedNet.Forms


Metodo DedFormCommMaster.SetFocusOnComm

Metodo DedFormCommMasterSetFocusOnComm
Imposta il focus su una determinata commessa.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetFocusOnComm(
    string commname
)
Public Sub SetFocusOnComm (
    commname As String
)
public:
void SetFocusOnComm(
    String^ commname
)
member SetFocusOnComm :
        commname : string -> unit

Parametri

commname String
Nome della commessa da selezionare.
Vedi anche

Documentazione

Classe DedFormCommMaster
Namespace DedNet.Forms


Eventi di DedFormCommMaster

Il tipo DedFormCommMaster espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormCommMaster
Namespace DedNet.Forms


Campi di DedFormCommMaster

Il tipo DedFormCommMaster espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormCommMaster
Namespace DedNet.Forms


Classe DedFormCorporate
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormCorporate

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormCorporate : BaseForm
Public Class DedFormCorporate
    Inherits BaseForm
public ref class DedFormCorporate : public BaseForm
type DedFormCorporate =
    class
        inherit BaseForm
    end

Il tipo DedFormCorporate espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormCorporate |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormCorporate

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormCorporate(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedFormCorporate(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedFormCorporate

Parametri

app DedNetApplication
Vedi anche

Documentazione

Classe DedFormCorporate
Namespace DedNet.Forms


Proprietà di DedFormCorporate

Il tipo DedFormCorporate espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormCorporate
Namespace DedNet.Forms


Metodi di DedFormCorporate

Il tipo DedFormCorporate espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormCorporate
Namespace DedNet.Forms


Metodo DedFormCorporate.Dispose

Metodo DedFormCorporateDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormCorporate
Namespace DedNet.Forms


Eventi di DedFormCorporate

Il tipo DedFormCorporate espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormCorporate
Namespace DedNet.Forms


Campi di DedFormCorporate

Il tipo DedFormCorporate espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormCorporate
Namespace DedNet.Forms


Classe DedFormDbDocCompare
Form per effettuare il confronto tra i dati presenti negli oggetti DataDb e DataDoc. Il risultato del confronto viene salvato nell'oggetto DataResult (se è dirty significa che i sui valori sono diversi da quelli presenti nel DB). Se non si vuole visualizzare l'interfaccia grafica impostare a false UseUI e chimare Run() al posto di ShowDialog.
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormDbDocCompare

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormDbDocCompare : BaseForm
Public Class DedFormDbDocCompare
    Inherits BaseForm
public ref class DedFormDbDocCompare : public BaseForm
type DedFormDbDocCompare =
    class
        inherit BaseForm
    end

Il tipo DedFormDbDocCompare espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà pubblica | DataResult | Restituisce/Imposta l'anagrafica risultatnte dal confronto.
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà pubblica | DiffList | Restituisce/Imposta la lista delle differenze.
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | RequiredAttr | Restituisce/Imposta la lista di attributi richiesti.
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawCheckBox |
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo pubblico | IsRowChecked |
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnButtonEditClick |
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | EditAttrClick | Evento sul click del bottone Edita.
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Proprietà di DedFormDbDocCompare

Il tipo DedFormDbDocCompare espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà pubblica | DataResult | Restituisce/Imposta l'anagrafica risultatnte dal confronto.
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà pubblica | DiffList | Restituisce/Imposta la lista delle differenze.
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | RequiredAttr | Restituisce/Imposta la lista di attributi richiesti.
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormDbDocCompare
Namespace DedNet.Forms


Proprietà DedFormDbDocCompare.DataResult

Proprietà DedFormDbDocCompareDataResult
Restituisce/Imposta l'anagrafica risultatnte dal confronto.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public IDedData DataResult { get; set; }
Public Property DataResult As IDedData
    Get
    Set
public:
property IDedData^ DataResult {
    IDedData^ get ();
    void set (IDedData^ value);
}
member DataResult : IDedData with get, set

Valore della proprietà

IDedData
Vedi anche

Documentazione

Classe DedFormDbDocCompare
Namespace DedNet.Forms


Proprietà DedFormDbDocCompare.DiffList

Proprietà DedFormDbDocCompareDiffList
Restituisce/Imposta la lista delle differenze.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormDbDocCompareListRowObjetc DiffList { get; set; }
Public Property DiffList As DedFormDbDocCompareListRowObjetc
    Get
    Set
public:
property DedFormDbDocCompareListRowObjetc^ DiffList {
    DedFormDbDocCompareListRowObjetc^ get ();
    void set (DedFormDbDocCompareListRowObjetc^ value);
}
member DiffList : DedFormDbDocCompareListRowObjetc with get, set

Valore della proprietà

DedFormDbDocCompareListRowObjetc
Vedi anche

Documentazione

Classe DedFormDbDocCompare
Namespace DedNet.Forms


Proprietà DedFormDbDocCompare.RequiredAttr

Proprietà DedFormDbDocCompareRequiredAttr
Restituisce/Imposta la lista di attributi richiesti.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> RequiredAttr { get; set; }
Public Property RequiredAttr As List(Of String)
    Get
    Set
public:
property List<String^>^ RequiredAttr {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
member RequiredAttr : List<string> with get, set

Valore della proprietà

List String
Vedi anche

Documentazione

Classe DedFormDbDocCompare
Namespace DedNet.Forms


Metodi di DedFormDbDocCompare

Il tipo DedFormDbDocCompare espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawCheckBox |
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo pubblico | IsRowChecked |
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnButtonEditClick |
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormDbDocCompare
Namespace DedNet.Forms


Metodo DedFormDbDocCompare.Dispose

Metodo DedFormDbDocCompareDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormDbDocCompare
Namespace DedNet.Forms


Metodo DedFormDbDocCompare.DrawCheckBox

Metodo DedFormDbDocCompareDrawCheckBox

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected void DrawCheckBox(
    Graphics g,
    Rectangle r,
    bool Checked
)
Protected Sub DrawCheckBox (
    g As Graphics,
    r As Rectangle,
    Checked As Boolean
)
protected:
void DrawCheckBox(
    Graphics^ g,
    Rectangle r,
    bool Checked
)
member DrawCheckBox :
        g : Graphics *
        r : Rectangle *
        Checked : bool -> unit

Parametri

g Graphics
r Rectangle
Checked Boolean
Vedi anche

Documentazione

Classe DedFormDbDocCompare
Namespace DedNet.Forms


Metodo DedFormDbDocCompare.IsRowChecked

Metodo DedFormDbDocCompareIsRowChecked

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsRowChecked(
    int rowHandle
)
Public Function IsRowChecked (
    rowHandle As Integer
) As Boolean
public:
bool IsRowChecked(
    int rowHandle
)
member IsRowChecked :
        rowHandle : int -> bool

Parametri

rowHandle Int32

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedFormDbDocCompare
Namespace DedNet.Forms


Metodo DedFormDbDocCompare.OnButtonEditClick

Metodo DedFormDbDocCompareOnButtonEditClick

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected void OnButtonEditClick()
Protected Sub OnButtonEditClick
protected:
void OnButtonEditClick()
member OnButtonEditClick : unit -> unit
Vedi anche

Documentazione

Classe DedFormDbDocCompare
Namespace DedNet.Forms


Eventi di DedFormDbDocCompare

Il tipo DedFormDbDocCompare espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | EditAttrClick | Evento sul click del bottone Edita.
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormDbDocCompare
Namespace DedNet.Forms


Evento DedFormDbDocCompare.EditAttrClick

Evento DedFormDbDocCompareEditAttrClick
Evento sul click del bottone Edita.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler EditAttrClick
Public Event EditAttrClick As EventHandler
public:
 event EventHandler^ EditAttrClick {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member EditAttrClick : IEvent<EventHandler,
    EventArgs>

Valore

EventHandler
Vedi anche

Documentazione

Classe DedFormDbDocCompare
Namespace DedNet.Forms


Campi di DedFormDbDocCompare

Il tipo DedFormDbDocCompare espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormDbDocCompare
Namespace DedNet.Forms


Classe DedFormDbDocCompare.ListRowObjetc

Classe DedFormDbDocCompareListRowObjetc
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList DedFormDbDocCompareRowObject
DedNet.FormsDedFormDbDocCompareListRowObjetc

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ListRowObjetc : List<DedFormDbDocCompareRowObject>
Public Class ListRowObjetc
    Inherits List(Of DedFormDbDocCompareRowObject)
public ref class ListRowObjetc : public List<DedFormDbDocCompareRowObject^>
type ListRowObjetc =
    class
        inherit List<DedFormDbDocCompareRowObject>
    end

Il tipo DedFormDbDocCompareListRowObjetc espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormDbDocCompareListRowObjetc |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormDbDocCompare.ListRowObjetc

Costruttore DedFormDbDocCompareListRowObjetc

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ListRowObjetc()
Public Sub New
public:
ListRowObjetc()
new : unit -> ListRowObjetc
Vedi anche

Documentazione

Classe DedFormDbDocCompareListRowObjetc
Namespace DedNet.Forms


Classe DedFormDbDocCompare.RowObject

Classe DedFormDbDocCompareRowObject
Gerarchia di ereditarietà
SystemObject
DedNet.FormsDedFormDbDocCompareRowObject

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class RowObject
Public Class RowObject
public ref class RowObject
type RowObject = class end

Il tipo DedFormDbDocCompareRowObject espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormDbDocCompareRowObject |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Attr |
Proprietà pubblica | AttrPrompt |
Proprietà pubblica | Check |
Proprietà pubblica | DbVal |
Proprietà pubblica | DocVal |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormDbDocCompare.RowObject

Costruttore DedFormDbDocCompareRowObject

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public RowObject(
    bool ckval,
    string attrname,
    string attrprompt,
    Object dbval,
    Object docval
)
Public Sub New (
    ckval As Boolean,
    attrname As String,
    attrprompt As String,
    dbval As Object,
    docval As Object
)
public:
RowObject(
    bool ckval,
    String^ attrname,
    String^ attrprompt,
    Object^ dbval,
    Object^ docval
)
new :
        ckval : bool *
        attrname : string *
        attrprompt : string *
        dbval : Object *
        docval : Object -> RowObject

Parametri

ckval Boolean
attrname String
attrprompt String
dbval Object
docval Object
Vedi anche

Documentazione

Classe DedFormDbDocCompareRowObject
Namespace DedNet.Forms


Proprietà di RowObject

Il tipo DedFormDbDocCompareRowObject espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Attr |
Proprietà pubblica | AttrPrompt |
Proprietà pubblica | Check |
Proprietà pubblica | DbVal |
Proprietà pubblica | DocVal |
Torna su
Vedi anche

Documentazione

Classe DedFormDbDocCompareRowObject
Namespace DedNet.Forms


Proprietà DedFormDbDocCompare.RowObject.Attr

Proprietà DedFormDbDocCompareRowObjectAttr

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttr Attr { get; set; }
Public Property Attr As DedAttr
    Get
    Set
public:
property DedAttr^ Attr {
    DedAttr^ get ();
    void set (DedAttr^ value);
}
member Attr : DedAttr with get, set

Valore della proprietà

DedAttr
Vedi anche

Documentazione

Classe DedFormDbDocCompareRowObject
Namespace DedNet.Forms


Proprietà DedFormDbDocCompare.RowObject.AttrPrompt

Proprietà DedFormDbDocCompareRowObjectAttrPrompt

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string AttrPrompt { get; set; }
Public Property AttrPrompt As String
    Get
    Set
public:
property String^ AttrPrompt {
    String^ get ();
    void set (String^ value);
}
member AttrPrompt : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedFormDbDocCompareRowObject
Namespace DedNet.Forms


Proprietà DedFormDbDocCompare.RowObject.Check

Proprietà DedFormDbDocCompareRowObjectCheck

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Check { get; set; }
Public Property Check As Boolean
    Get
    Set
public:
property bool Check {
    bool get ();
    void set (bool value);
}
member Check : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormDbDocCompareRowObject
Namespace DedNet.Forms


Proprietà DedFormDbDocCompare.RowObject.DbVal

Proprietà DedFormDbDocCompareRowObjectDbVal

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object DbVal { get; set; }
Public Property DbVal As Object
    Get
    Set
public:
property Object^ DbVal {
    Object^ get ();
    void set (Object^ value);
}
member DbVal : Object with get, set

Valore della proprietà

Object
Vedi anche

Documentazione

Classe DedFormDbDocCompareRowObject
Namespace DedNet.Forms


Proprietà DedFormDbDocCompare.RowObject.DocVal

Proprietà DedFormDbDocCompareRowObjectDocVal

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object DocVal { get; set; }
Public Property DocVal As Object
    Get
    Set
public:
property Object^ DocVal {
    Object^ get ();
    void set (Object^ value);
}
member DocVal : Object with get, set

Valore della proprietà

Object
Vedi anche

Documentazione

Classe DedFormDbDocCompareRowObject
Namespace DedNet.Forms


Classe DedFormDedBaseDbItem
Dialogo utilizzato per visualizzare gli oggetti con le temporizzazioni.
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormDedBaseDbItem

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormDedBaseDbItem : BaseForm
Public Class DedFormDedBaseDbItem
    Inherits BaseForm
public ref class DedFormDedBaseDbItem : public BaseForm
type DedFormDedBaseDbItem =
    class
        inherit BaseForm
    end

Il tipo DedFormDedBaseDbItem espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormDedBaseDbItem | Dialogo utilizzato per visualizzare gli oggetti con le temporizzazioni.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Evento pubblico | UpdatingDataSource | Evento su apertura del menu contestuale.
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormDedBaseDbItem
Dialogo utilizzato per visualizzare gli oggetti con le temporizzazioni.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormDedBaseDbItem(
    DedNetApplication app,
    string text
)
Public Sub New (
    app As DedNetApplication,
    text As String
)
public:
DedFormDedBaseDbItem(
    DedNetApplication^ app,
    String^ text
)
new :
        app : DedNetApplication *
        text : string -> DedFormDedBaseDbItem

Parametri

app DedNetApplication
text String
Vedi anche

Documentazione

Classe DedFormDedBaseDbItem
Namespace DedNet.Forms


Proprietà di DedFormDedBaseDbItem

Il tipo DedFormDedBaseDbItem espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormDedBaseDbItem
Namespace DedNet.Forms


Metodi di DedFormDedBaseDbItem

Il tipo DedFormDedBaseDbItem espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormDedBaseDbItem
Namespace DedNet.Forms


Metodo DedFormDedBaseDbItem.Dispose

Metodo DedFormDedBaseDbItemDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormDedBaseDbItem
Namespace DedNet.Forms


Eventi di DedFormDedBaseDbItem

Il tipo DedFormDedBaseDbItem espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Evento pubblico | UpdatingDataSource | Evento su apertura del menu contestuale.
Torna su
Vedi anche

Documentazione

Classe DedFormDedBaseDbItem
Namespace DedNet.Forms


Evento DedFormDedBaseDbItem.UpdatingDataSource

Evento DedFormDedBaseDbItemUpdatingDataSource
Evento su apertura del menu contestuale.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DedFormDedBaseDbItemUpdatingDataSourceEventArgs> UpdatingDataSource
Public Event UpdatingDataSource As EventHandler(Of DedFormDedBaseDbItemUpdatingDataSourceEventArgs)
public:
 event EventHandler<DedFormDedBaseDbItemUpdatingDataSourceEventArgs^>^ UpdatingDataSource {
    void add (EventHandler<DedFormDedBaseDbItemUpdatingDataSourceEventArgs^>^ value);
    void remove (EventHandler<DedFormDedBaseDbItemUpdatingDataSourceEventArgs^>^ value);
}
member UpdatingDataSource : IEvent<EventHandler<DedFormDedBaseDbItemUpdatingDataSourceEventArgs>,
    DedFormDedBaseDbItemUpdatingDataSourceEventArgs>

Valore

EventHandler DedFormDedBaseDbItemUpdatingDataSourceEventArgs
Vedi anche

Documentazione

Classe DedFormDedBaseDbItem
Namespace DedNet.Forms


Campi di DedFormDedBaseDbItem

Il tipo DedFormDedBaseDbItem espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormDedBaseDbItem
Namespace DedNet.Forms


Classe DedFormDedBaseDbItem.UpdatingDataSourceEventArgs

Classe DedFormDedBaseDbItemUpdatingDataSourceEventArgs
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNet.FormsDedFormDedBaseDbItemUpdatingDataSourceEventArgs

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class UpdatingDataSourceEventArgs : EventArgs
Public Class UpdatingDataSourceEventArgs
    Inherits EventArgs
public ref class UpdatingDataSourceEventArgs : public EventArgs
type UpdatingDataSourceEventArgs =
    class
        inherit EventArgs
    end

Il tipo DedFormDedBaseDbItemUpdatingDataSourceEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormDedBaseDbItemUpdatingDataSourceEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | DataSource |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormDedBaseDbItem.UpdatingDataSourceEventArgs

Costruttore DedFormDedBaseDbItemUpdatingDataSourceEventArgs

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public UpdatingDataSourceEventArgs(
    IEnumerable<DedBaseDbItem> dataSource
)
Public Sub New (
    dataSource As IEnumerable(Of DedBaseDbItem)
)
public:
UpdatingDataSourceEventArgs(
    IEnumerable<DedBaseDbItem^>^ dataSource
)
new :
        dataSource : IEnumerable<DedBaseDbItem> -> UpdatingDataSourceEventArgs

Parametri

dataSource IEnumerable DedBaseDbItem
Vedi anche

Documentazione

Classe DedFormDedBaseDbItemUpdatingDataSourceEventArgs
Namespace DedNet.Forms


Proprietà di UpdatingDataSourceEventArgs

Il tipo DedFormDedBaseDbItemUpdatingDataSourceEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | DataSource |
Torna su
Vedi anche

Documentazione

Classe DedFormDedBaseDbItemUpdatingDataSourceEventArgs
Namespace DedNet.Forms


Proprietà DedFormDedBaseDbItem.UpdatingDataSourceEventArgs.DataSource

Proprietà DedFormDedBaseDbItemUpdatingDataSourceEventArgsDataSource

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public IEnumerable<DedBaseDbItem> DataSource { get; set; }
Public Property DataSource As IEnumerable(Of DedBaseDbItem)
    Get
    Set
public:
property IEnumerable<DedBaseDbItem^>^ DataSource {
    IEnumerable<DedBaseDbItem^>^ get ();
    void set (IEnumerable<DedBaseDbItem^>^ value);
}
member DataSource : IEnumerable<DedBaseDbItem> with get, set

Valore della proprietà

IEnumerable DedBaseDbItem
Vedi anche

Documentazione

Classe DedFormDedBaseDbItemUpdatingDataSourceEventArgs
Namespace DedNet.Forms


Classe DedFormDefFileName
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormDefFileName

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormDefFileName : BaseForm
Public Class DedFormDefFileName
    Inherits BaseForm
public ref class DedFormDefFileName : public BaseForm
type DedFormDefFileName =
    class
        inherit BaseForm
    end

Il tipo DedFormDefFileName espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Proprietà di DedFormDefFileName

Il tipo DedFormDefFileName espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormDefFileName
Namespace DedNet.Forms


Metodi di DedFormDefFileName

Il tipo DedFormDefFileName espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormDefFileName
Namespace DedNet.Forms


Metodo DedFormDefFileName.Dispose

Metodo DedFormDefFileNameDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormDefFileName
Namespace DedNet.Forms


Eventi di DedFormDefFileName

Il tipo DedFormDefFileName espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormDefFileName
Namespace DedNet.Forms


Campi di DedFormDefFileName

Il tipo DedFormDefFileName espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormDefFileName
Namespace DedNet.Forms


Classe DedFormDependencies
Dialogo utilizzato per visualizzare una struttura gerarchica di dipendenze generiche.
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormDependencies

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormDependencies : BaseForm
Public Class DedFormDependencies
    Inherits BaseForm
public ref class DedFormDependencies : public BaseForm
type DedFormDependencies =
    class
        inherit BaseForm
    end

Il tipo DedFormDependencies espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormDependencies | Dialogo utilizzato per visualizzare una struttura gerarchica di dipendenze generiche.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà pubblica | DataSource | Fonte dati da riportare nel controllo ad albero.
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | Message | Messaggio personalizzato da visualizzare.
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowOnlyTree | Se viene effettuata l'impostazione di visualizzare solo l'albero nascondo gli altri controlli
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà pubblica | Tree | Albero contenente le dipendenze.
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo pubblico | LoadBom | Carico la struttura della distinta all'interno del dialogo
Metodo pubblico | LoadDocStructInfo | Carico la struttura del DocStructInfo all'interno del dialogo.
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | CustomRowFilter | Evento associato al filtraggio del singolo nodo del treelist.
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormDependencies
Dialogo utilizzato per visualizzare una struttura gerarchica di dipendenze generiche.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormDependencies(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedFormDependencies(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedFormDependencies

Parametri

app DedNetApplication
Applicazione DedNet.
Vedi anche

Documentazione

Classe DedFormDependencies
Namespace DedNet.Forms


Proprietà di DedFormDependencies

Il tipo DedFormDependencies espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà pubblica | DataSource | Fonte dati da riportare nel controllo ad albero.
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | Message | Messaggio personalizzato da visualizzare.
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowOnlyTree | Se viene effettuata l'impostazione di visualizzare solo l'albero nascondo gli altri controlli
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà pubblica | Tree | Albero contenente le dipendenze.
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormDependencies
Namespace DedNet.Forms


Proprietà DedFormDependencies.DataSource

Proprietà DedFormDependenciesDataSource
Fonte dati da riportare nel controllo ad albero.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public IEnumerable<DedCustomDependency> DataSource { set; }
Public WriteOnly Property DataSource As IEnumerable(Of DedCustomDependency)
    Set
public:
property IEnumerable<DedCustomDependency^>^ DataSource {
    void set (IEnumerable<DedCustomDependency^>^ value);
}
member DataSource : IEnumerable<DedCustomDependency> with set

Valore della proprietà

IEnumerable DedCustomDependency
Vedi anche

Documentazione

Classe DedFormDependencies
Namespace DedNet.Forms


Proprietà DedFormDependencies.Message

Proprietà DedFormDependenciesMessage
Messaggio personalizzato da visualizzare.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Message { set; }
Public WriteOnly Property Message As String
    Set
public:
property String^ Message {
    void set (String^ value);
}
member Message : string with set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedFormDependencies
Namespace DedNet.Forms


Proprietà DedFormDependencies.ShowOnlyTree

Proprietà DedFormDependenciesShowOnlyTree
Se viene effettuata l'impostazione di visualizzare solo l'albero nascondo gli altri controlli

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ShowOnlyTree { set; }
Public WriteOnly Property ShowOnlyTree As Boolean
    Set
public:
property bool ShowOnlyTree {
    void set (bool value);
}
member ShowOnlyTree : bool with set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormDependencies
Namespace DedNet.Forms


Proprietà DedFormDependencies.Tree

Proprietà DedFormDependenciesTree
Albero contenente le dipendenze.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public TreeList Tree { get; }
Public ReadOnly Property Tree As TreeList
    Get
public:
property TreeList^ Tree {
    TreeList^ get ();
}
member Tree : TreeList with get

Valore della proprietà

TreeList
Vedi anche

Documentazione

Classe DedFormDependencies
Namespace DedNet.Forms


Metodi di DedFormDependencies

Il tipo DedFormDependencies espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo pubblico | LoadBom | Carico la struttura della distinta all'interno del dialogo
Metodo pubblico | LoadDocStructInfo | Carico la struttura del DocStructInfo all'interno del dialogo.
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormDependencies
Namespace DedNet.Forms


Metodo DedFormDependencies.Dispose

Metodo DedFormDependenciesDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormDependencies
Namespace DedNet.Forms


Metodo DedFormDependencies.LoadBom

Metodo DedFormDependenciesLoadBom
Carico la struttura della distinta all'interno del dialogo

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void LoadBom(
    DedData data,
    bool showParentsStructure
)
Public Sub LoadBom (
    data As DedData,
    showParentsStructure As Boolean
)
public:
void LoadBom(
    DedData^ data,
    bool showParentsStructure
)
member LoadBom :
        data : DedData *
        showParentsStructure : bool -> unit

Parametri

data DedData
showParentsStructure Boolean
Vedi anche

Documentazione

Classe DedFormDependencies
Namespace DedNet.Forms


Metodo DedFormDependencies.LoadDocStructInfo

Metodo DedFormDependenciesLoadDocStructInfo
Carico la struttura del DocStructInfo all'interno del dialogo.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void LoadDocStructInfo(
    DocStructInfo dsinfo,
    bool showParentsStructure
)
Public Sub LoadDocStructInfo (
    dsinfo As DocStructInfo,
    showParentsStructure As Boolean
)
public:
void LoadDocStructInfo(
    DocStructInfo^ dsinfo,
    bool showParentsStructure
)
member LoadDocStructInfo :
        dsinfo : DocStructInfo *
        showParentsStructure : bool -> unit

Parametri

dsinfo DocStructInfo
showParentsStructure Boolean
Vedi anche

Documentazione

Classe DedFormDependencies
Namespace DedNet.Forms


Eventi di DedFormDependencies

Il tipo DedFormDependencies espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | CustomRowFilter | Evento associato al filtraggio del singolo nodo del treelist.
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormDependencies
Namespace DedNet.Forms


Evento DedFormDependencies.CustomRowFilter

Evento DedFormDependenciesCustomRowFilter
Evento associato al filtraggio del singolo nodo del treelist.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event CustomRowFilterEventHandler CustomRowFilter
Public Event CustomRowFilter As CustomRowFilterEventHandler
public:
 event CustomRowFilterEventHandler^ CustomRowFilter {
    void add (CustomRowFilterEventHandler^ value);
    void remove (CustomRowFilterEventHandler^ value);
}
member CustomRowFilter : IEvent<CustomRowFilterEventHandler,
    EventArgs>

Valore

CustomRowFilterEventHandler
Vedi anche

Documentazione

Classe DedFormDependencies
Namespace DedNet.Forms


Campi di DedFormDependencies

Il tipo DedFormDependencies espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormDependencies
Namespace DedNet.Forms


Classe DedFormDist
Form per visualizzare la distinta implosa/espolsa di un determinato BomItemCollection
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormDist

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormDist : BaseForm
Public Class DedFormDist
    Inherits BaseForm
public ref class DedFormDist : public BaseForm
type DedFormDist =
    class
        inherit BaseForm
    end

Il tipo DedFormDist espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo pubblico | RefreshFiles | Metodo che permette di aggiornare i documenti associati all'anagrafica
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo pubblico | SetDist(DedComm, Boolean) | Metodo per impostare la distinta da visualizzare.
Metodo pubblico | SetDist(DedData, String, Boolean) | Metodo per impostare la distinta da visualizzare.
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Proprietà di DedFormDist

Il tipo DedFormDist espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormDist
Namespace DedNet.Forms


Metodi di DedFormDist

Il tipo DedFormDist espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo pubblico | RefreshFiles | Metodo che permette di aggiornare i documenti associati all'anagrafica
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo pubblico | SetDist(DedComm, Boolean) | Metodo per impostare la distinta da visualizzare.
Metodo pubblico | SetDist(DedData, String, Boolean) | Metodo per impostare la distinta da visualizzare.
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormDist
Namespace DedNet.Forms


Metodo DedFormDist.Dispose

Metodo DedFormDistDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormDist
Namespace DedNet.Forms


Metodo DedFormDist.RefreshFiles

Metodo DedFormDistRefreshFiles
Metodo che permette di aggiornare i documenti associati all'anagrafica

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void RefreshFiles(
    bool restore = false
)
Public Sub RefreshFiles (
    Optional restore As Boolean = false
)
public:
void RefreshFiles(
    bool restore = false
)
member RefreshFiles :
        ?restore : bool
(* Defaults:
        let _restore = defaultArg restore false
*)
-> unit

Parametri

restore Boolean (Optional)
Indica se effettuare il restore del controllo.
Vedi anche

Documentazione

Classe DedFormDist
Namespace DedNet.Forms


Metodo DedFormDist.SetDist

Metodo DedFormDistSetDist
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | SetDist(DedComm, Boolean) | Metodo per impostare la distinta da visualizzare.
Metodo pubblico | SetDist(DedData, String, Boolean) | Metodo per impostare la distinta da visualizzare.
Torna su
Vedi anche

Documentazione

Classe DedFormDist
Namespace DedNet.Forms


Metodo DedFormDist.SetDist(DedComm, Boolean)

Metodo DedFormDistSetDist(DedComm, Boolean)
Metodo per impostare la distinta da visualizzare.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetDist(
    DedComm comm,
    bool isImpl
)
Public Sub SetDist (
    comm As DedComm,
    isImpl As Boolean
)
public:
void SetDist(
    DedComm^ comm,
    bool isImpl
)
member SetDist :
        comm : DedComm *
        isImpl : bool -> unit

Parametri

comm DedComm
isImpl Boolean
Indica se visualizzare la distinta impolsa (True) o esplosa (False).
Vedi anche

Documentazione

Classe DedFormDist
Overload di SetDist
Namespace DedNet.Forms


Metodo DedFormDist.SetDist(DedData, String, Boolean)

Metodo DedFormDistSetDist(DedData, String, Boolean)
Metodo per impostare la distinta da visualizzare.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetDist(
    DedData data,
    string discrim,
    bool isImpl
)
Public Sub SetDist (
    data As DedData,
    discrim As String,
    isImpl As Boolean
)
public:
void SetDist(
    DedData^ data,
    String^ discrim,
    bool isImpl
)
member SetDist :
        data : DedData *
        discrim : string *
        isImpl : bool -> unit

Parametri

data DedData
discrim String
isImpl Boolean
Indica se visualizzare la distinta impolsa (True) o esplosa (False).
Vedi anche

Documentazione

Classe DedFormDist
Overload di SetDist
Namespace DedNet.Forms


Eventi di DedFormDist

Il tipo DedFormDist espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormDist
Namespace DedNet.Forms


Campi di DedFormDist

Il tipo DedFormDist espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormDist
Namespace DedNet.Forms


Classe DedFormDistProdSave
Form per la gestione del salvataggio della distinta di produzione
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormDistProdSave

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormDistProdSave : BaseForm
Public Class DedFormDistProdSave
    Inherits BaseForm
public ref class DedFormDistProdSave : public BaseForm
type DedFormDistProdSave =
    class
        inherit BaseForm
    end

Il tipo DedFormDistProdSave espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormDistProdSave | Costruttore del form
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | OverwriteSubHeaders | Indica se è necessario sovrascrivere gli header figli se sono già stati definiti col discriminante di destinazione.
Proprietà pubblica | SavingDiscrimDist | Discriminante di distinta col quale verrà creata la nuova produzione
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà pubblica | StartingData | Restitusice o imposta l'anagrafica la cui distinta deve essere clonata come produzione
Proprietà pubblica | StartingDiscrimDist | Discriminante di distinta di partenza
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormDistProdSave
Costruttore del form

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormDistProdSave(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedFormDistProdSave(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedFormDistProdSave

Parametri

app DedNetApplication
Vedi anche

Documentazione

Classe DedFormDistProdSave
Namespace DedNet.Forms


Proprietà di DedFormDistProdSave

Il tipo DedFormDistProdSave espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | OverwriteSubHeaders | Indica se è necessario sovrascrivere gli header figli se sono già stati definiti col discriminante di destinazione.
Proprietà pubblica | SavingDiscrimDist | Discriminante di distinta col quale verrà creata la nuova produzione
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà pubblica | StartingData | Restitusice o imposta l'anagrafica la cui distinta deve essere clonata come produzione
Proprietà pubblica | StartingDiscrimDist | Discriminante di distinta di partenza
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormDistProdSave
Namespace DedNet.Forms


Proprietà DedFormDistProdSave.OverwriteSubHeaders

Proprietà DedFormDistProdSaveOverwriteSubHeaders
Indica se è necessario sovrascrivere gli header figli se sono già stati definiti col discriminante di destinazione.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool OverwriteSubHeaders { get; set; }
Public Property OverwriteSubHeaders As Boolean
    Get
    Set
public:
property bool OverwriteSubHeaders {
    bool get ();
    void set (bool value);
}
member OverwriteSubHeaders : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormDistProdSave
Namespace DedNet.Forms


Proprietà DedFormDistProdSave.SavingDiscrimDist

Proprietà DedFormDistProdSaveSavingDiscrimDist
Discriminante di distinta col quale verrà creata la nuova produzione

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string SavingDiscrimDist { get; set; }
Public Property SavingDiscrimDist As String
    Get
    Set
public:
property String^ SavingDiscrimDist {
    String^ get ();
    void set (String^ value);
}
member SavingDiscrimDist : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedFormDistProdSave
Namespace DedNet.Forms


Proprietà DedFormDistProdSave.StartingData

Proprietà DedFormDistProdSaveStartingData
Restitusice o imposta l'anagrafica la cui distinta deve essere clonata come produzione

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData StartingData { get; set; }
Public Property StartingData As DedData
    Get
    Set
public:
property DedData^ StartingData {
    DedData^ get ();
    void set (DedData^ value);
}
member StartingData : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe DedFormDistProdSave
Namespace DedNet.Forms


Proprietà DedFormDistProdSave.StartingDiscrimDist

Proprietà DedFormDistProdSaveStartingDiscrimDist
Discriminante di distinta di partenza

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string StartingDiscrimDist { get; set; }
Public Property StartingDiscrimDist As String
    Get
    Set
public:
property String^ StartingDiscrimDist {
    String^ get ();
    void set (String^ value);
}
member StartingDiscrimDist : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedFormDistProdSave
Namespace DedNet.Forms


Metodi di DedFormDistProdSave

Il tipo DedFormDistProdSave espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormDistProdSave
Namespace DedNet.Forms


Metodo DedFormDistProdSave.Dispose

Metodo DedFormDistProdSaveDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormDistProdSave
Namespace DedNet.Forms


Eventi di DedFormDistProdSave

Il tipo DedFormDistProdSave espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormDistProdSave
Namespace DedNet.Forms


Campi di DedFormDistProdSave

Il tipo DedFormDistProdSave espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormDistProdSave
Namespace DedNet.Forms


Classe DedFormDocHistory
Finestra per visualizzare la storia del documento (chekin / checkout ).
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormDocHistory

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormDocHistory : BaseForm
Public Class DedFormDocHistory
    Inherits BaseForm
public ref class DedFormDocHistory : public BaseForm
type DedFormDocHistory =
    class
        inherit BaseForm
    end

Il tipo DedFormDocHistory espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormDocHistory | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormDocHistory
Costruttore unico.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormDocHistory(
    DedNetApplication app,
    DedDoc doc
)
Public Sub New (
    app As DedNetApplication,
    doc As DedDoc
)
public:
DedFormDocHistory(
    DedNetApplication^ app,
    DedDoc^ doc
)
new :
        app : DedNetApplication *
        doc : DedDoc -> DedFormDocHistory

Parametri

app DedNetApplication
Applicazione DedNet.
doc DedDoc
Vedi anche

Documentazione

Classe DedFormDocHistory
Namespace DedNet.Forms


Proprietà di DedFormDocHistory

Il tipo DedFormDocHistory espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormDocHistory
Namespace DedNet.Forms


Metodi di DedFormDocHistory

Il tipo DedFormDocHistory espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormDocHistory
Namespace DedNet.Forms


Metodo DedFormDocHistory.Dispose

Metodo DedFormDocHistoryDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormDocHistory
Namespace DedNet.Forms


Eventi di DedFormDocHistory

Il tipo DedFormDocHistory espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormDocHistory
Namespace DedNet.Forms


Campi di DedFormDocHistory

Il tipo DedFormDocHistory espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormDocHistory
Namespace DedNet.Forms


Classe DedFormDocSearch
Classe per la gestione form della ricerca documentale
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormDocSearch

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormDocSearch : BaseForm
Public Class DedFormDocSearch
    Inherits BaseForm
public ref class DedFormDocSearch : public BaseForm
type DedFormDocSearch =
    class
        inherit BaseForm
    end

Il tipo DedFormDocSearch espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà pubblica | CloseDialogOnQuit | Restituisce o imposta se la finestra, su chiusura, tramite x o tramite menu, si debba chiudere invece di nascondersi. Di default è false.
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà pubblica | Datas | Restituisce / Imposta le anagrafiche per il filtraggio dei documenti
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | FilterOnLoad | Lista di estensioni su cui filtrare in apertura.
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumPerm | Permesso minimo.
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà pubblica | Modale | Restituisce in quale modalità visualizzare la finestra (impostata automaticamente quando viene chiamato il metodo VisualizzaForm()).
Proprietà pubblica | MoreThanOne | Restituisce il numero di elementi da selezionare (in modalità modale).
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | OnlyRap | Restituisce/Imposta se visualizzare solo i file di modello e rappresentazine.
Proprietà pubblica | Root | Restiutisce l'informazione della root selezionata.
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà pubblica | SelDocs | Restituisce le informazioni sulla selezione.
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Proprietà pubblica | UserMessage | Imposta il messaggio di richiesta all'utente ( in modalità modale )
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo pubblico | GetCurrentGridView | Restituisce il grid view attuale
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo pubblico | IsUserChanged | Ritorna True se l'utente corrente con il quale si vuol mostrare il dialogo è cambiato, False altrimenti.
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | (Sovrascrive BaseFormOnVisibleChanged(EventArgs))
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo pubblico | Ripristina | Se la finestra è visibile, la ripristina al FormWindowState precedente.
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo pubblico | ShowFormModal | Funzione per visualizzare il form in modo modale e chiedere all'utente una selezione di documenti o anagrafiche.
Metodo pubblico | ShowFormModeless | Funzione per visualizzare il form in modo non modale.
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Proprietà di DedFormDocSearch

Il tipo DedFormDocSearch espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà pubblica | CloseDialogOnQuit | Restituisce o imposta se la finestra, su chiusura, tramite x o tramite menu, si debba chiudere invece di nascondersi. Di default è false.
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà pubblica | Datas | Restituisce / Imposta le anagrafiche per il filtraggio dei documenti
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | FilterOnLoad | Lista di estensioni su cui filtrare in apertura.
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumPerm | Permesso minimo.
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà pubblica | Modale | Restituisce in quale modalità visualizzare la finestra (impostata automaticamente quando viene chiamato il metodo VisualizzaForm()).
Proprietà pubblica | MoreThanOne | Restituisce il numero di elementi da selezionare (in modalità modale).
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | OnlyRap | Restituisce/Imposta se visualizzare solo i file di modello e rappresentazine.
Proprietà pubblica | Root | Restiutisce l'informazione della root selezionata.
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà pubblica | SelDocs | Restituisce le informazioni sulla selezione.
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Proprietà pubblica | UserMessage | Imposta il messaggio di richiesta all'utente ( in modalità modale )
Torna su
Vedi anche

Documentazione

Classe DedFormDocSearch
Namespace DedNet.Forms


Proprietà DedFormDocSearch.CloseDialogOnQuit

Proprietà DedFormDocSearchCloseDialogOnQuit
Restituisce o imposta se la finestra, su chiusura, tramite x o tramite menu, si debba chiudere invece di nascondersi. Di default è false.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CloseDialogOnQuit { get; set; }
Public Property CloseDialogOnQuit As Boolean
    Get
    Set
public:
property bool CloseDialogOnQuit {
    bool get ();
    void set (bool value);
}
member CloseDialogOnQuit : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormDocSearch
Namespace DedNet.Forms


Proprietà DedFormDocSearch.Datas

Proprietà DedFormDocSearchDatas
Restituisce / Imposta le anagrafiche per il filtraggio dei documenti

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataList Datas { get; set; }
Public Property Datas As DedDataList
    Get
    Set
public:
property DedDataList^ Datas {
    DedDataList^ get ();
    void set (DedDataList^ value);
}
member Datas : DedDataList with get, set

Valore della proprietà

DedDataList
Vedi anche

Documentazione

Classe DedFormDocSearch
Namespace DedNet.Forms


Proprietà DedFormDocSearch.FilterOnLoad

Proprietà DedFormDocSearchFilterOnLoad
Lista di estensioni su cui filtrare in apertura.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> FilterOnLoad { get; set; }
Public Property FilterOnLoad As List(Of String)
    Get
    Set
public:
property List<String^>^ FilterOnLoad {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
member FilterOnLoad : List<string> with get, set

Valore della proprietà

List String
Vedi anche

Documentazione

Classe DedFormDocSearch
Namespace DedNet.Forms


Proprietà DedFormDocSearch.MinimumPerm

Proprietà DedFormDocSearchMinimumPerm
Permesso minimo.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedStandardPerm MinimumPerm { get; set; }
Public Property MinimumPerm As DedStandardPerm
    Get
    Set
public:
property DedStandardPerm MinimumPerm {
    DedStandardPerm get ();
    void set (DedStandardPerm value);
}
member MinimumPerm : DedStandardPerm with get, set

Valore della proprietà

DedStandardPerm
Vedi anche

Documentazione

Classe DedFormDocSearch
Namespace DedNet.Forms


Proprietà DedFormDocSearch.Modale

Proprietà DedFormDocSearchModale
Restituisce in quale modalità visualizzare la finestra (impostata automaticamente quando viene chiamato il metodo VisualizzaForm()).

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Modale { get; set; }
Public Property Modale As Boolean
    Get
    Set
public:
property bool Modale {
    bool get ();
    void set (bool value);
}
member Modale : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormDocSearch
Namespace DedNet.Forms


Proprietà DedFormDocSearch.MoreThanOne

Proprietà DedFormDocSearchMoreThanOne
Restituisce il numero di elementi da selezionare (in modalità modale).

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool MoreThanOne { get; }
Public ReadOnly Property MoreThanOne As Boolean
    Get
public:
property bool MoreThanOne {
    bool get ();
}
member MoreThanOne : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormDocSearch
Namespace DedNet.Forms


Proprietà DedFormDocSearch.OnlyRap

Proprietà DedFormDocSearchOnlyRap
Restituisce/Imposta se visualizzare solo i file di modello e rappresentazine.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool OnlyRap { get; set; }
Public Property OnlyRap As Boolean
    Get
    Set
public:
property bool OnlyRap {
    bool get ();
    void set (bool value);
}
member OnlyRap : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormDocSearch
Namespace DedNet.Forms


Proprietà DedFormDocSearch.Root

Proprietà DedFormDocSearchRoot
Restiutisce l'informazione della root selezionata.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Root { get; }
Public ReadOnly Property Root As String
    Get
public:
property String^ Root {
    String^ get ();
}
member Root : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedFormDocSearch
Namespace DedNet.Forms


Proprietà DedFormDocSearch.SelDocs

Proprietà DedFormDocSearchSelDocs
Restituisce le informazioni sulla selezione.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocList SelDocs { get; }
Public ReadOnly Property SelDocs As DedDocList
    Get
public:
property DedDocList^ SelDocs {
    DedDocList^ get ();
}
member SelDocs : DedDocList with get

Valore della proprietà

DedDocList
Vedi anche

Documentazione

Classe DedFormDocSearch
Namespace DedNet.Forms


Proprietà DedFormDocSearch.UserMessage

Proprietà DedFormDocSearchUserMessage
Imposta il messaggio di richiesta all'utente ( in modalità modale )

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string UserMessage { get; protected set; }
Public Property UserMessage As String
    Get
    Protected Set
public:
property String^ UserMessage {
    String^ get ();
    protected: void set (String^ value);
}
member UserMessage : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedFormDocSearch
Namespace DedNet.Forms


Metodi di DedFormDocSearch

Il tipo DedFormDocSearch espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo pubblico | GetCurrentGridView | Restituisce il grid view attuale
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo pubblico | IsUserChanged | Ritorna True se l'utente corrente con il quale si vuol mostrare il dialogo è cambiato, False altrimenti.
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | (Sovrascrive BaseFormOnVisibleChanged(EventArgs))
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo pubblico | Ripristina | Se la finestra è visibile, la ripristina al FormWindowState precedente.
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo pubblico | ShowFormModal | Funzione per visualizzare il form in modo modale e chiedere all'utente una selezione di documenti o anagrafiche.
Metodo pubblico | ShowFormModeless | Funzione per visualizzare il form in modo non modale.
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormDocSearch
Namespace DedNet.Forms


Metodo DedFormDocSearch.Dispose

Metodo DedFormDocSearchDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormDocSearch
Namespace DedNet.Forms


Metodo DedFormDocSearch.GetCurrentGridView

Metodo DedFormDocSearchGetCurrentGridView
Restituisce il grid view attuale

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public GridView GetCurrentGridView()
Public Function GetCurrentGridView As GridView
public:
GridView^ GetCurrentGridView()
member GetCurrentGridView : unit -> GridView

Valore di ritorno

GridView
Vedi anche

Documentazione

Classe DedFormDocSearch
Namespace DedNet.Forms


Metodo DedFormDocSearch.IsUserChanged

Metodo DedFormDocSearchIsUserChanged
Ritorna True se l'utente corrente con il quale si vuol mostrare il dialogo è cambiato, False altrimenti.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsUserChanged()
Public Function IsUserChanged As Boolean
public:
bool IsUserChanged()
member IsUserChanged : unit -> bool

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedFormDocSearch
Namespace DedNet.Forms


Metodo DedFormDocSearch.OnVisibleChanged

Metodo DedFormDocSearchOnVisibleChanged

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void OnVisibleChanged(
    EventArgs e
)
Protected Overrides Sub OnVisibleChanged (
    e As EventArgs
)
protected:
virtual void OnVisibleChanged(
    EventArgs^ e
) override
abstract OnVisibleChanged :
        e : EventArgs -> unit
override OnVisibleChanged :
        e : EventArgs -> unit

Parametri

e EventArgs
Vedi anche

Documentazione

Classe DedFormDocSearch
Namespace DedNet.Forms


Metodo DedFormDocSearch.Ripristina

Metodo DedFormDocSearchRipristina
Se la finestra è visibile, la ripristina al FormWindowState precedente.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Ripristina()
Public Sub Ripristina
public:
void Ripristina()
member Ripristina : unit -> unit
Vedi anche

Documentazione

Classe DedFormDocSearch
Namespace DedNet.Forms


Metodo DedFormDocSearch.ShowFormModal

Metodo DedFormDocSearchShowFormModal
Funzione per visualizzare il form in modo modale e chiedere all'utente una selezione di documenti o anagrafiche.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DialogResult ShowFormModal(
    IWin32Window parent,
    string userMessage,
    bool moreThanOne,
    bool selectRoot
)
Public Function ShowFormModal (
    parent As IWin32Window,
    userMessage As String,
    moreThanOne As Boolean,
    selectRoot As Boolean
) As DialogResult
public:
DialogResult ShowFormModal(
    IWin32Window^ parent,
    String^ userMessage,
    bool moreThanOne,
    bool selectRoot
)
member ShowFormModal :
        parent : IWin32Window *
        userMessage : string *
        moreThanOne : bool *
        selectRoot : bool -> DialogResult

Parametri

parent IWin32Window
Specifica l'handle della finestra padre oppure IntPtr.Zero.
userMessage String
Messaggio da mostrare
moreThanOne Boolean
Se selizionare più di un elemento
selectRoot Boolean

Valore di ritorno

DialogResult
Il risultato del form modale.
Vedi anche

Documentazione

Classe DedFormDocSearch
Namespace DedNet.Forms


Metodo DedFormDocSearch.ShowFormModeless

Metodo DedFormDocSearchShowFormModeless
Funzione per visualizzare il form in modo non modale.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ShowFormModeless(
    IWin32Window parent
)
Public Sub ShowFormModeless (
    parent As IWin32Window
)
public:
void ShowFormModeless(
    IWin32Window^ parent
)
member ShowFormModeless :
        parent : IWin32Window -> unit

Parametri

parent IWin32Window
Specifica la finestra padre oppure null.
Vedi anche

Documentazione

Classe DedFormDocSearch
Namespace DedNet.Forms


Eventi di DedFormDocSearch

Il tipo DedFormDocSearch espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormDocSearch
Namespace DedNet.Forms


Campi di DedFormDocSearch

Il tipo DedFormDocSearch espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormDocSearch
Namespace DedNet.Forms


Classe DedFormDocsManage
Form per la comparazione dei documenti da utilizzare nel comando di nuova revisione.
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormDocsManage

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormDocsManage : BaseForm
Public Class DedFormDocsManage
    Inherits BaseForm
public ref class DedFormDocsManage : public BaseForm
type DedFormDocsManage =
    class
        inherit BaseForm
    end

Il tipo DedFormDocsManage espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà pubblica | DisableImport | Abilita/Disabilita tutti i radio button del Tipo di Associazione.
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnablAttachContext | Restituisce o imposta se abilitare il contesto allegato.
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | EnableLinkNotCopy | Restituisce o imposta se risulta abilitato all'utente, il controllo per collegare i documenti.
Proprietà pubblica | EnablePrimaryContext | Restituisce o imposta se abilitare il contesto primario.
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LinkNotCopy | Restituisce o imposta se il documento debba essere collegato e non importato (false di default).
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | PrimaryContext | Restituisce o imposta il contesto con il quale associare i documenti. Di default è true ed i documenti vengono associati come primari.
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Proprietà di DedFormDocsManage

Il tipo DedFormDocsManage espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà pubblica | DisableImport | Abilita/Disabilita tutti i radio button del Tipo di Associazione.
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnablAttachContext | Restituisce o imposta se abilitare il contesto allegato.
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | EnableLinkNotCopy | Restituisce o imposta se risulta abilitato all'utente, il controllo per collegare i documenti.
Proprietà pubblica | EnablePrimaryContext | Restituisce o imposta se abilitare il contesto primario.
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LinkNotCopy | Restituisce o imposta se il documento debba essere collegato e non importato (false di default).
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | PrimaryContext | Restituisce o imposta il contesto con il quale associare i documenti. Di default è true ed i documenti vengono associati come primari.
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormDocsManage
Namespace DedNet.Forms


Proprietà DedFormDocsManage.DisableImport

Proprietà DedFormDocsManageDisableImport
Abilita/Disabilita tutti i radio button del Tipo di Associazione.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool DisableImport { get; set; }
Public Property DisableImport As Boolean
    Get
    Set
public:
property bool DisableImport {
    bool get ();
    void set (bool value);
}
member DisableImport : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormDocsManage
Namespace DedNet.Forms


Proprietà DedFormDocsManage.EnablAttachContext

Proprietà DedFormDocsManageEnablAttachContext
Restituisce o imposta se abilitare il contesto allegato.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool EnablAttachContext { get; set; }
Public Property EnablAttachContext As Boolean
    Get
    Set
public:
property bool EnablAttachContext {
    bool get ();
    void set (bool value);
}
member EnablAttachContext : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormDocsManage
Namespace DedNet.Forms


Proprietà DedFormDocsManage.EnableLinkNotCopy

Proprietà DedFormDocsManageEnableLinkNotCopy
Restituisce o imposta se risulta abilitato all'utente, il controllo per collegare i documenti.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool EnableLinkNotCopy { get; set; }
Public Property EnableLinkNotCopy As Boolean
    Get
    Set
public:
property bool EnableLinkNotCopy {
    bool get ();
    void set (bool value);
}
member EnableLinkNotCopy : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormDocsManage
Namespace DedNet.Forms


Proprietà DedFormDocsManage.EnablePrimaryContext

Proprietà DedFormDocsManageEnablePrimaryContext
Restituisce o imposta se abilitare il contesto primario.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool EnablePrimaryContext { get; set; }
Public Property EnablePrimaryContext As Boolean
    Get
    Set
public:
property bool EnablePrimaryContext {
    bool get ();
    void set (bool value);
}
member EnablePrimaryContext : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormDocsManage
Namespace DedNet.Forms


Proprietà DedFormDocsManage.LinkNotCopy

Proprietà DedFormDocsManageLinkNotCopy
Restituisce o imposta se il documento debba essere collegato e non importato (false di default).

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool LinkNotCopy { get; set; }
Public Property LinkNotCopy As Boolean
    Get
    Set
public:
property bool LinkNotCopy {
    bool get ();
    void set (bool value);
}
member LinkNotCopy : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormDocsManage
Namespace DedNet.Forms


Proprietà DedFormDocsManage.PrimaryContext

Proprietà DedFormDocsManagePrimaryContext
Restituisce o imposta il contesto con il quale associare i documenti. Di default è true ed i documenti vengono associati come primari.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool PrimaryContext { get; set; }
Public Property PrimaryContext As Boolean
    Get
    Set
public:
property bool PrimaryContext {
    bool get ();
    void set (bool value);
}
member PrimaryContext : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormDocsManage
Namespace DedNet.Forms


Metodi di DedFormDocsManage

Il tipo DedFormDocsManage espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormDocsManage
Namespace DedNet.Forms


Metodo DedFormDocsManage.Dispose

Metodo DedFormDocsManageDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormDocsManage
Namespace DedNet.Forms


Eventi di DedFormDocsManage

Il tipo DedFormDocsManage espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormDocsManage
Namespace DedNet.Forms


Campi di DedFormDocsManage

Il tipo DedFormDocsManage espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormDocsManage
Namespace DedNet.Forms


Classe DedFormDocTransferHistory
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormDocTransferHistory

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormDocTransferHistory : BaseForm
Public Class DedFormDocTransferHistory
    Inherits BaseForm
public ref class DedFormDocTransferHistory : public BaseForm
type DedFormDocTransferHistory =
    class
        inherit BaseForm
    end

Il tipo DedFormDocTransferHistory espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormDocTransferHistory(DedNetApplication, DedDoc) | Costruttore
Metodo pubblico | DedFormDocTransferHistory(DedNetApplication, Boolean) | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo pubblico | SetCommandList | Rigenera il menu contestuale di questo controllo con la lista dei comandi passati.
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormDocTransferHistory
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | DedFormDocTransferHistory(DedNetApplication, DedDoc) | Costruttore
Metodo pubblico | DedFormDocTransferHistory(DedNetApplication, Boolean) | Costruttore
Torna su
Vedi anche

Documentazione

Classe DedFormDocTransferHistory
Namespace DedNet.Forms


Costruttore DedFormDocTransferHistory(DedNetApplication, DedDoc)
Costruttore

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormDocTransferHistory(
    DedNetApplication app,
    DedDoc doc
)
Public Sub New (
    app As DedNetApplication,
    doc As DedDoc
)
public:
DedFormDocTransferHistory(
    DedNetApplication^ app,
    DedDoc^ doc
)
new :
        app : DedNetApplication *
        doc : DedDoc -> DedFormDocTransferHistory

Parametri

app DedNetApplication
Riferimento all'oggetto DedNetApplication.
doc DedDoc
Documento del quale si vuole ottenere dove è usato.
Vedi anche

Documentazione

Classe DedFormDocTransferHistory
Overload di DedFormDocTransferHistory
Namespace DedNet.Forms


Costruttore DedFormDocTransferHistory(DedNetApplication, Boolean)
Costruttore

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormDocTransferHistory(
    DedNetApplication app,
    bool allTransfer
)
Public Sub New (
    app As DedNetApplication,
    allTransfer As Boolean
)
public:
DedFormDocTransferHistory(
    DedNetApplication^ app,
    bool allTransfer
)
new :
        app : DedNetApplication *
        allTransfer : bool -> DedFormDocTransferHistory

Parametri

app DedNetApplication
Riferimento all'oggetto DedNetApplication.
allTransfer Boolean
Indica se visualizzare la storia di tutti i transfer packet
Vedi anche

Documentazione

Classe DedFormDocTransferHistory
Overload di DedFormDocTransferHistory
Namespace DedNet.Forms


Proprietà di DedFormDocTransferHistory

Il tipo DedFormDocTransferHistory espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormDocTransferHistory
Namespace DedNet.Forms


Metodi di DedFormDocTransferHistory

Il tipo DedFormDocTransferHistory espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo pubblico | SetCommandList | Rigenera il menu contestuale di questo controllo con la lista dei comandi passati.
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormDocTransferHistory
Namespace DedNet.Forms


Metodo DedFormDocTransferHistory.Dispose

Metodo DedFormDocTransferHistoryDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormDocTransferHistory
Namespace DedNet.Forms


Metodo DedFormDocTransferHistory.SetCommandList

Metodo DedFormDocTransferHistorySetCommandList
Rigenera il menu contestuale di questo controllo con la lista dei comandi passati.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetCommandList(
    DedCommandList commandList,
    CommandContextEnum commandContext
)
Public Sub SetCommandList (
    commandList As DedCommandList,
    commandContext As CommandContextEnum
)
public:
void SetCommandList(
    DedCommandList^ commandList,
    CommandContextEnum commandContext
)
member SetCommandList :
        commandList : DedCommandList *
        commandContext : CommandContextEnum -> unit

Parametri

commandList DedCommandList
Lista completa dei comandi.
commandContext CommandContextEnum
Contesto da utilizzare per filtrare i comandi da inserire.
Note
Filtra i comandi in modo da aggiungere soltanto quelli coerenti con il contesto passato.
Vedi anche

Documentazione

Classe DedFormDocTransferHistory
Namespace DedNet.Forms


Eventi di DedFormDocTransferHistory

Il tipo DedFormDocTransferHistory espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormDocTransferHistory
Namespace DedNet.Forms


Campi di DedFormDocTransferHistory

Il tipo DedFormDocTransferHistory espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormDocTransferHistory
Namespace DedNet.Forms


Classe DedFormEco
Classe usata per istanziare il form degli Eco.
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormEco

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormEco : BaseForm
Public Class DedFormEco
    Inherits BaseForm
public ref class DedFormEco : public BaseForm
type DedFormEco =
    class
        inherit BaseForm
    end

Il tipo DedFormEco espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormEco(DedNetApplication) | Costruttore privato utilizzato internamente per settare le varie proprietà.
Metodo pubblico | DedFormEco(DedNetApplication, DedComm) | Costruttore unico.
Metodo pubblico | DedFormEco(DedNetApplication, DedData) | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà pubblica | UpdateDialogAnag | Delegate usato per aggiornare i dati presenti a schermo nel dialogo padre.
Proprietà pubblica | UpdateDialogComm | Delegate usato per aggiornare i dati presenti a schermo nel dialogo padre.
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormEco
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | DedFormEco(DedNetApplication) | Costruttore privato utilizzato internamente per settare le varie proprietà.
Metodo pubblico | DedFormEco(DedNetApplication, DedComm) | Costruttore unico.
Metodo pubblico | DedFormEco(DedNetApplication, DedData) | Costruttore unico.
Torna su
Vedi anche

Documentazione

Classe DedFormEco
Namespace DedNet.Forms


Costruttore DedFormEco(DedNetApplication)
Costruttore privato utilizzato internamente per settare le varie proprietà.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormEco(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedFormEco(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedFormEco

Parametri

app DedNetApplication
Applicazione DedNet.
Vedi anche

Documentazione

Classe DedFormEco
Overload di DedFormEco
Namespace DedNet.Forms


Costruttore DedFormEco(DedNetApplication, DedComm)
Costruttore unico.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormEco(
    DedNetApplication app,
    DedComm comm
)
Public Sub New (
    app As DedNetApplication,
    comm As DedComm
)
public:
DedFormEco(
    DedNetApplication^ app,
    DedComm^ comm
)
new :
        app : DedNetApplication *
        comm : DedComm -> DedFormEco

Parametri

app DedNetApplication
Applicazione DedNetApplication.
comm DedComm
Commessa dedicata all'ECO.
Vedi anche

Documentazione

Classe DedFormEco
Overload di DedFormEco
Namespace DedNet.Forms


Costruttore DedFormEco(DedNetApplication, DedData)
Costruttore unico.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormEco(
    DedNetApplication app,
    DedData data
)
Public Sub New (
    app As DedNetApplication,
    data As DedData
)
public:
DedFormEco(
    DedNetApplication^ app,
    DedData^ data
)
new :
        app : DedNetApplication *
        data : DedData -> DedFormEco

Parametri

app DedNetApplication
Applicazione DedNetApplication.
data DedData
Anagrafica associata all'ECO.
Vedi anche

Documentazione

Classe DedFormEco
Overload di DedFormEco
Namespace DedNet.Forms


Proprietà di DedFormEco

Il tipo DedFormEco espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà pubblica | UpdateDialogAnag | Delegate usato per aggiornare i dati presenti a schermo nel dialogo padre.
Proprietà pubblica | UpdateDialogComm | Delegate usato per aggiornare i dati presenti a schermo nel dialogo padre.
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormEco
Namespace DedNet.Forms


Proprietà DedFormEco.UpdateDialogAnag

Proprietà DedFormEcoUpdateDialogAnag
Delegate usato per aggiornare i dati presenti a schermo nel dialogo padre.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommandContextUpdateDialogAnag UpdateDialogAnag { set; }
Public WriteOnly Property UpdateDialogAnag As DedCommandContextUpdateDialogAnag
    Set
public:
property DedCommandContextUpdateDialogAnag^ UpdateDialogAnag {
    void set (DedCommandContextUpdateDialogAnag^ value);
}
member UpdateDialogAnag : DedCommandContextUpdateDialogAnag with set

Valore della proprietà

DedCommandContextUpdateDialogAnag
Vedi anche

Documentazione

Classe DedFormEco
Namespace DedNet.Forms


Proprietà DedFormEco.UpdateDialogComm

Proprietà DedFormEcoUpdateDialogComm
Delegate usato per aggiornare i dati presenti a schermo nel dialogo padre.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommandContextUpdateDialogComm UpdateDialogComm { set; }
Public WriteOnly Property UpdateDialogComm As DedCommandContextUpdateDialogComm
    Set
public:
property DedCommandContextUpdateDialogComm^ UpdateDialogComm {
    void set (DedCommandContextUpdateDialogComm^ value);
}
member UpdateDialogComm : DedCommandContextUpdateDialogComm with set

Valore della proprietà

DedCommandContextUpdateDialogComm
Vedi anche

Documentazione

Classe DedFormEco
Namespace DedNet.Forms


Metodi di DedFormEco

Il tipo DedFormEco espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormEco
Namespace DedNet.Forms


Metodo DedFormEco.Dispose

Metodo DedFormEcoDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormEco
Namespace DedNet.Forms


Eventi di DedFormEco

Il tipo DedFormEco espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormEco
Namespace DedNet.Forms


Campi di DedFormEco

Il tipo DedFormEco espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormEco
Namespace DedNet.Forms


Classe DedFormEcoHistory
Classe per visualizzare la storia di un'eco.
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormEcoHistory

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormEcoHistory : BaseForm
Public Class DedFormEcoHistory
    Inherits BaseForm
public ref class DedFormEcoHistory : public BaseForm
type DedFormEcoHistory =
    class
        inherit BaseForm
    end

Il tipo DedFormEcoHistory espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormEcoHistory | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormEcoHistory
Costruttore unico.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormEcoHistory(
    DedNetApplication app,
    DedEco eco
)
Public Sub New (
    app As DedNetApplication,
    eco As DedEco
)
public:
DedFormEcoHistory(
    DedNetApplication^ app,
    DedEco^ eco
)
new :
        app : DedNetApplication *
        eco : DedEco -> DedFormEcoHistory

Parametri

app DedNetApplication
eco DedEco
Vedi anche

Documentazione

Classe DedFormEcoHistory
Namespace DedNet.Forms


Proprietà di DedFormEcoHistory

Il tipo DedFormEcoHistory espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormEcoHistory
Namespace DedNet.Forms


Metodi di DedFormEcoHistory

Il tipo DedFormEcoHistory espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormEcoHistory
Namespace DedNet.Forms


Metodo DedFormEcoHistory.Dispose

Metodo DedFormEcoHistoryDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormEcoHistory
Namespace DedNet.Forms


Eventi di DedFormEcoHistory

Il tipo DedFormEcoHistory espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormEcoHistory
Namespace DedNet.Forms


Campi di DedFormEcoHistory

Il tipo DedFormEcoHistory espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormEcoHistory
Namespace DedNet.Forms


Classe DedFormEditComm
Form utilizzato per la creazione o la modifica di una commessa.
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormEditComm

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormEditComm : BaseForm
Public Class DedFormEditComm
    Inherits BaseForm
public ref class DedFormEditComm : public BaseForm
type DedFormEditComm =
    class
        inherit BaseForm
    end

Il tipo DedFormEditComm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà pubblica | CommData | Restituisce il dizionario contenente i dati da utilizzare per la creazione della nuova commessa.
Proprietà pubblica | CommNameChanged | Indica se è stato modificato il nome della commessa.
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà pubblica | Info | Restituisce o imposta le informazioni da utilizzare per il salvataggio.
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | Master | Imposta/Restituisce il master dal quale clonare la struttura cartelle
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnButtonOkPressed | Chiama l'evento ButtonOkPressed.
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnDataChanged | Chiama l'evento DataChanged.
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | ButtonOkPressedEvent | Evento chiamato sulla pressione del pulsante OK della finestra.
Evento pubblico | DataChangedEvent | Evento chiamato alla modifica di una qualsiasi caratteristica della finestra di dialogo.
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Proprietà di DedFormEditComm

Il tipo DedFormEditComm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà pubblica | CommData | Restituisce il dizionario contenente i dati da utilizzare per la creazione della nuova commessa.
Proprietà pubblica | CommNameChanged | Indica se è stato modificato il nome della commessa.
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà pubblica | Info | Restituisce o imposta le informazioni da utilizzare per il salvataggio.
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | Master | Imposta/Restituisce il master dal quale clonare la struttura cartelle
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormEditComm
Namespace DedNet.Forms


Proprietà DedFormEditComm.CommData

Proprietà DedFormEditCommCommData
Restituisce il dizionario contenente i dati da utilizzare per la creazione della nuova commessa.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDictionary CommData { get; }
Public ReadOnly Property CommData As DedDictionary
    Get
public:
property DedDictionary^ CommData {
    DedDictionary^ get ();
}
member CommData : DedDictionary with get

Valore della proprietà

DedDictionary
Vedi anche

Documentazione

Classe DedFormEditComm
Namespace DedNet.Forms


Proprietà DedFormEditComm.CommNameChanged

Proprietà DedFormEditCommCommNameChanged
Indica se è stato modificato il nome della commessa.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CommNameChanged { get; }
Public ReadOnly Property CommNameChanged As Boolean
    Get
public:
property bool CommNameChanged {
    bool get ();
}
member CommNameChanged : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormEditComm
Namespace DedNet.Forms


Proprietà DedFormEditComm.Info

Proprietà DedFormEditCommInfo
Restituisce o imposta le informazioni da utilizzare per il salvataggio.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEncodeInfo Info { get; set; }
Public Property Info As DedEncodeInfo
    Get
    Set
public:
property DedEncodeInfo^ Info {
    DedEncodeInfo^ get ();
    void set (DedEncodeInfo^ value);
}
member Info : DedEncodeInfo with get, set

Valore della proprietà

DedEncodeInfo
Vedi anche

Documentazione

Classe DedFormEditComm
Namespace DedNet.Forms


Proprietà DedFormEditComm.Master

Proprietà DedFormEditCommMaster
Imposta/Restituisce il master dal quale clonare la struttura cartelle

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedComm Master { get; set; }
Public Property Master As DedComm
    Get
    Set
public:
property DedComm^ Master {
    DedComm^ get ();
    void set (DedComm^ value);
}
member Master : DedComm with get, set

Valore della proprietà

DedComm
Vedi anche

Documentazione

Classe DedFormEditComm
Namespace DedNet.Forms


Metodi di DedFormEditComm

Il tipo DedFormEditComm espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnButtonOkPressed | Chiama l'evento ButtonOkPressed.
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnDataChanged | Chiama l'evento DataChanged.
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormEditComm
Namespace DedNet.Forms


Metodo DedFormEditComm.Dispose

Metodo DedFormEditCommDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormEditComm
Namespace DedNet.Forms


Metodo DedFormEditComm.OnButtonOkPressed

Metodo DedFormEditCommOnButtonOkPressed
Chiama l'evento ButtonOkPressed.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected void OnButtonOkPressed(
    CancelEventArgs e
)
Protected Sub OnButtonOkPressed (
    e As CancelEventArgs
)
protected:
void OnButtonOkPressed(
    CancelEventArgs^ e
)
member OnButtonOkPressed :
        e : CancelEventArgs -> unit

Parametri

e CancelEventArgs
Vedi anche

Documentazione

Classe DedFormEditComm
Namespace DedNet.Forms


Metodo DedFormEditComm.OnDataChanged

Metodo DedFormEditCommOnDataChanged
Chiama l'evento DataChanged.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected void OnDataChanged()
Protected Sub OnDataChanged
protected:
void OnDataChanged()
member OnDataChanged : unit -> unit
Vedi anche

Documentazione

Classe DedFormEditComm
Namespace DedNet.Forms


Eventi di DedFormEditComm

Il tipo DedFormEditComm espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | ButtonOkPressedEvent | Evento chiamato sulla pressione del pulsante OK della finestra.
Evento pubblico | DataChangedEvent | Evento chiamato alla modifica di una qualsiasi caratteristica della finestra di dialogo.
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormEditComm
Namespace DedNet.Forms


Evento DedFormEditComm.ButtonOkPressedEvent

Evento DedFormEditCommButtonOkPressedEvent
Evento chiamato sulla pressione del pulsante OK della finestra.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<CancelEventArgs> ButtonOkPressedEvent
Public Event ButtonOkPressedEvent As EventHandler(Of CancelEventArgs)
public:
 event EventHandler<CancelEventArgs^>^ ButtonOkPressedEvent {
    void add (EventHandler<CancelEventArgs^>^ value);
    void remove (EventHandler<CancelEventArgs^>^ value);
}
member ButtonOkPressedEvent : IEvent<EventHandler<CancelEventArgs>,
    CancelEventArgs>

Valore

EventHandler CancelEventArgs
Vedi anche

Documentazione

Classe DedFormEditComm
Namespace DedNet.Forms


Evento DedFormEditComm.DataChangedEvent

Evento DedFormEditCommDataChangedEvent
Evento chiamato alla modifica di una qualsiasi caratteristica della finestra di dialogo.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler DataChangedEvent
Public Event DataChangedEvent As EventHandler
public:
 event EventHandler^ DataChangedEvent {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member DataChangedEvent : IEvent<EventHandler,
    EventArgs>

Valore

EventHandler
Vedi anche

Documentazione

Classe DedFormEditComm
Namespace DedNet.Forms


Campi di DedFormEditComm

Il tipo DedFormEditComm espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormEditComm
Namespace DedNet.Forms


Enumerazione DedFormEditComm.DedFormEditMode

Enumerazione DedFormEditCommDedFormEditMode

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum DedFormEditMode
Public Enumeration DedFormEditMode
public enum class DedFormEditMode
type DedFormEditMode
Membri
Nome | Valore | Descrizione
Creation | 0 |
Edit | 1 |
View | 2 |
Vedi anche

Documentazione

Namespace DedNet.Forms


Classe DedFormEditEco
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormEditEco

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormEditEco : BaseForm
Public Class DedFormEditEco
    Inherits BaseForm
public ref class DedFormEditEco : public BaseForm
type DedFormEditEco =
    class
        inherit BaseForm
    end

Il tipo DedFormEditEco espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormEditEco(DedNetApplication, DedEco) | Costruttore utilizzato per la modalità: EDITAZIONE ECO.
Metodo pubblico | DedFormEditEco(DedNetApplication, DedEco, DedNotifyNotifyEvent) | Costruttore utilizzato per la modalità: CAMBIO STATO ECO.
Metodo pubblico | DedFormEditEco(DedNetApplication, DedData, DedComm, DedDictionary) | Costruttore utilizzato per la modalità: CREAZIONE ECO.
Metodo pubblico | DedFormEditEco(DedNetApplication, DedData, DedComm, DedNotifyNotifyEvent) | Costruttore utilizzato per impostare la modalità con cui il dialogo verrà utilizzato (creazione, editazione o cambio stato).
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | ECO | Ritorna l'oggetto DedEco che deve essere creato.
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | Notes | Imposta o restituisce le note dell'ECO.
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Proprietà pubblica | UsersForced | Lista degli utenti che verranno comunque notificati della creazione/editazione dell'ECO.
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo pubblico | GetListUsersToNotify | Ritorna la lista degli utenti che devono essere notificati. Contiene l'internalname dell'oggetto DedUser.
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormEditEco
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | DedFormEditEco(DedNetApplication, DedEco) | Costruttore utilizzato per la modalità: EDITAZIONE ECO.
Metodo pubblico | DedFormEditEco(DedNetApplication, DedEco, DedNotifyNotifyEvent) | Costruttore utilizzato per la modalità: CAMBIO STATO ECO.
Metodo pubblico | DedFormEditEco(DedNetApplication, DedData, DedComm, DedDictionary) | Costruttore utilizzato per la modalità: CREAZIONE ECO.
Metodo pubblico | DedFormEditEco(DedNetApplication, DedData, DedComm, DedNotifyNotifyEvent) | Costruttore utilizzato per impostare la modalità con cui il dialogo verrà utilizzato (creazione, editazione o cambio stato).
Torna su
Vedi anche

Documentazione

Classe DedFormEditEco
Namespace DedNet.Forms


Costruttore DedFormEditEco(DedNetApplication, DedEco)
Costruttore utilizzato per la modalità: EDITAZIONE ECO.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormEditEco(
    DedNetApplication app,
    DedEco eco
)
Public Sub New (
    app As DedNetApplication,
    eco As DedEco
)
public:
DedFormEditEco(
    DedNetApplication^ app,
    DedEco^ eco
)
new :
        app : DedNetApplication *
        eco : DedEco -> DedFormEditEco

Parametri

app DedNetApplication
Applicazione DedNet.
eco DedEco
ECO che si vuole editare.
Vedi anche

Documentazione

Classe DedFormEditEco
Overload di DedFormEditEco
Namespace DedNet.Forms


Costruttore DedFormEditEco(DedNetApplication, DedEco, DedNotify.NotifyEvent)

Costruttore DedFormEditEco(DedNetApplication, DedEco, DedNotifyNotifyEvent)
Costruttore utilizzato per la modalità: CAMBIO STATO ECO.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormEditEco(
    DedNetApplication app,
    DedEco eco,
    DedNotifyNotifyEvent notify
)
Public Sub New (
    app As DedNetApplication,
    eco As DedEco,
    notify As DedNotifyNotifyEvent
)
public:
DedFormEditEco(
    DedNetApplication^ app,
    DedEco^ eco,
    DedNotifyNotifyEvent notify
)
new :
        app : DedNetApplication *
        eco : DedEco *
        notify : DedNotifyNotifyEvent -> DedFormEditEco

Parametri

app DedNetApplication
Applicazione DedNet.
eco DedEco
ECO che si vuole editare.
notify DedNotifyNotifyEvent
Indica il tipo di notifica ECO.
Vedi anche

Documentazione

Classe DedFormEditEco
Overload di DedFormEditEco
Namespace DedNet.Forms


Costruttore DedFormEditEco(DedNetApplication, DedData, DedComm, DedDictionary)
Costruttore utilizzato per la modalità: CREAZIONE ECO.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormEditEco(
    DedNetApplication app,
    DedData data,
    DedComm comm,
    DedDictionary ecoData
)
Public Sub New (
    app As DedNetApplication,
    data As DedData,
    comm As DedComm,
    ecoData As DedDictionary
)
public:
DedFormEditEco(
    DedNetApplication^ app,
    DedData^ data,
    DedComm^ comm,
    DedDictionary^ ecoData
)
new :
        app : DedNetApplication *
        data : DedData *
        comm : DedComm *
        ecoData : DedDictionary -> DedFormEditEco

Parametri

app DedNetApplication
Applicazione DedNet.
data DedData
Anagrafica associata all'ECO.
comm DedComm
Commessa associata all'ECO.
ecoData DedDictionary
Dizionario contenente i valori di default da utilizzare per l'ECO.
Vedi anche

Documentazione

Classe DedFormEditEco
Overload di DedFormEditEco
Namespace DedNet.Forms


Costruttore DedFormEditEco(DedNetApplication, DedData, DedComm, DedNotify.NotifyEvent)

Costruttore DedFormEditEco(DedNetApplication, DedData, DedComm, DedNotifyNotifyEvent)
Costruttore utilizzato per impostare la modalità con cui il dialogo verrà utilizzato (creazione, editazione o cambio stato).

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormEditEco(
    DedNetApplication app,
    DedData data,
    DedComm comm,
    DedNotifyNotifyEvent notify
)
Public Sub New (
    app As DedNetApplication,
    data As DedData,
    comm As DedComm,
    notify As DedNotifyNotifyEvent
)
public:
DedFormEditEco(
    DedNetApplication^ app,
    DedData^ data,
    DedComm^ comm,
    DedNotifyNotifyEvent notify
)
new :
        app : DedNetApplication *
        data : DedData *
        comm : DedComm *
        notify : DedNotifyNotifyEvent -> DedFormEditEco

Parametri

app DedNetApplication
Applicazione DedNet.
data DedData
Anagrafica associata all'ECO.
comm DedComm
Commessa associata all'ECO.
notify DedNotifyNotifyEvent
Indica il tipo di notifica ECO.
Vedi anche

Documentazione

Classe DedFormEditEco
Overload di DedFormEditEco
Namespace DedNet.Forms


Proprietà di DedFormEditEco

Il tipo DedFormEditEco espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | ECO | Ritorna l'oggetto DedEco che deve essere creato.
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | Notes | Imposta o restituisce le note dell'ECO.
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Proprietà pubblica | UsersForced | Lista degli utenti che verranno comunque notificati della creazione/editazione dell'ECO.
Torna su
Vedi anche

Documentazione

Classe DedFormEditEco
Namespace DedNet.Forms


Proprietà DedFormEditEco.ECO

Proprietà DedFormEditEcoECO
Ritorna l'oggetto DedEco che deve essere creato.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEco ECO { get; }
Public ReadOnly Property ECO As DedEco
    Get
public:
property DedEco^ ECO {
    DedEco^ get ();
}
member ECO : DedEco with get

Valore della proprietà

DedEco
Vedi anche

Documentazione

Classe DedFormEditEco
Namespace DedNet.Forms


Proprietà DedFormEditEco.Notes

Proprietà DedFormEditEcoNotes
Imposta o restituisce le note dell'ECO.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Notes { get; set; }
Public Property Notes As String
    Get
    Set
public:
property String^ Notes {
    String^ get ();
    void set (String^ value);
}
member Notes : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedFormEditEco
Namespace DedNet.Forms


Proprietà DedFormEditEco.UsersForced

Proprietà DedFormEditEcoUsersForced
Lista degli utenti che verranno comunque notificati della creazione/editazione dell'ECO.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<DedUser> UsersForced { get; }
Public ReadOnly Property UsersForced As List(Of DedUser)
    Get
public:
property List<DedUser^>^ UsersForced {
    List<DedUser^>^ get ();
}
member UsersForced : List<DedUser> with get

Valore della proprietà

List DedUser
Vedi anche

Documentazione

Classe DedFormEditEco
Namespace DedNet.Forms


Metodi di DedFormEditEco

Il tipo DedFormEditEco espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo pubblico | GetListUsersToNotify | Ritorna la lista degli utenti che devono essere notificati. Contiene l'internalname dell'oggetto DedUser.
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormEditEco
Namespace DedNet.Forms


Metodo DedFormEditEco.Dispose

Metodo DedFormEditEcoDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormEditEco
Namespace DedNet.Forms


Metodo DedFormEditEco.GetListUsersToNotify

Metodo DedFormEditEcoGetListUsersToNotify
Ritorna la lista degli utenti che devono essere notificati. Contiene l'internalname dell'oggetto DedUser.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<DedUser> GetListUsersToNotify()
Public Function GetListUsersToNotify As List(Of DedUser)
public:
List<DedUser^>^ GetListUsersToNotify()
member GetListUsersToNotify : unit -> List<DedUser>

Valore di ritorno

List DedUser
Vedi anche

Documentazione

Classe DedFormEditEco
Namespace DedNet.Forms


Eventi di DedFormEditEco

Il tipo DedFormEditEco espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormEditEco
Namespace DedNet.Forms


Campi di DedFormEditEco

Il tipo DedFormEditEco espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormEditEco
Namespace DedNet.Forms


Classe DedFormEditObjects
Dialogo utilizzato per permettere l'editazione della collection di oggetti specificata.
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormEditObjects

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormEditObjects : BaseForm
Public Class DedFormEditObjects
    Inherits BaseForm
public ref class DedFormEditObjects : public BaseForm
type DedFormEditObjects =
    class
        inherit BaseForm
    end

Il tipo DedFormEditObjects espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormEditObjects | Crea una nuova istanza della classe 'DedFormEditDataAttributes' utilizzata per editare le anagrafiche specificate in ingresso.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà pubblica | CustomMessage | Messaggio personalizzato da visualizzare a schermo sopra la griglia.
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | OnlyDbAttrManagement | Indica se il dialogo deve gestire solo gli attributi OnlyDb.
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà pubblica | SparePartsManagement | Indica se il dialogo deve gestire gli attributi di ricambio o meno.
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo pubblico | InitData | Inizializza la griglia con i dati specificati in ingresso.
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo pubblico | SelectData | Chiede all'utente di selezionare una sola anagrafica tra quelle specificate in ingresso.
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormEditObjects
Crea una nuova istanza della classe 'DedFormEditDataAttributes' utilizzata per editare le anagrafiche specificate in ingresso.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormEditObjects(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedFormEditObjects(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedFormEditObjects

Parametri

app DedNetApplication
Applicazione DeDNet.
Vedi anche

Documentazione

Classe DedFormEditObjects
Namespace DedNet.Forms


Proprietà di DedFormEditObjects

Il tipo DedFormEditObjects espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà pubblica | CustomMessage | Messaggio personalizzato da visualizzare a schermo sopra la griglia.
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | OnlyDbAttrManagement | Indica se il dialogo deve gestire solo gli attributi OnlyDb.
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà pubblica | SparePartsManagement | Indica se il dialogo deve gestire gli attributi di ricambio o meno.
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormEditObjects
Namespace DedNet.Forms


Proprietà DedFormEditObjects.CustomMessage

Proprietà DedFormEditObjectsCustomMessage
Messaggio personalizzato da visualizzare a schermo sopra la griglia.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string CustomMessage { get; set; }
Public Property CustomMessage As String
    Get
    Set
public:
property String^ CustomMessage {
    String^ get ();
    void set (String^ value);
}
member CustomMessage : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedFormEditObjects
Namespace DedNet.Forms


Proprietà DedFormEditObjects.OnlyDbAttrManagement

Proprietà DedFormEditObjectsOnlyDbAttrManagement
Indica se il dialogo deve gestire solo gli attributi OnlyDb.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool OnlyDbAttrManagement { get; set; }
Public Property OnlyDbAttrManagement As Boolean
    Get
    Set
public:
property bool OnlyDbAttrManagement {
    bool get ();
    void set (bool value);
}
member OnlyDbAttrManagement : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormEditObjects
Namespace DedNet.Forms


Proprietà DedFormEditObjects.SparePartsManagement

Proprietà DedFormEditObjectsSparePartsManagement
Indica se il dialogo deve gestire gli attributi di ricambio o meno.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool SparePartsManagement { get; set; }
Public Property SparePartsManagement As Boolean
    Get
    Set
public:
property bool SparePartsManagement {
    bool get ();
    void set (bool value);
}
member SparePartsManagement : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormEditObjects
Namespace DedNet.Forms


Metodi di DedFormEditObjects

Il tipo DedFormEditObjects espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo pubblico | InitData | Inizializza la griglia con i dati specificati in ingresso.
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo pubblico | SelectData | Chiede all'utente di selezionare una sola anagrafica tra quelle specificate in ingresso.
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormEditObjects
Namespace DedNet.Forms


Metodo DedFormEditObjects.Dispose

Metodo DedFormEditObjectsDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormEditObjects
Namespace DedNet.Forms


Metodo DedFormEditObjects.InitData

Metodo DedFormEditObjectsInitData
Inizializza la griglia con i dati specificati in ingresso.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void InitData(
    IEnumerable<IDedData> dataSource,
    IEnumerable<DedAttr> attributes
)
Public Sub InitData (
    dataSource As IEnumerable(Of IDedData),
    attributes As IEnumerable(Of DedAttr)
)
public:
void InitData(
    IEnumerable<IDedData^>^ dataSource,
    IEnumerable<DedAttr^>^ attributes
)
member InitData :
        dataSource : IEnumerable<IDedData> *
        attributes : IEnumerable<DedAttr> -> unit

Parametri

dataSource IEnumerable IDedData
Elenco di anagrafiche che devono essere bindate alla griglia.
attributes IEnumerable DedAttr
Elenco di attributi da visualizzare a schermo.
Vedi anche

Documentazione

Classe DedFormEditObjects
Namespace DedNet.Forms


Metodo DedFormEditObjects.SelectData

Metodo DedFormEditObjectsSelectData
Chiede all'utente di selezionare una sola anagrafica tra quelle specificate in ingresso.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object SelectData(
    IEnumerable<IDedData> dataSource,
    IEnumerable<DedAttr> attrs,
    SelectionModeEnum selectionMode
)
Public Function SelectData (
    dataSource As IEnumerable(Of IDedData),
    attrs As IEnumerable(Of DedAttr),
    selectionMode As SelectionModeEnum
) As Object
public:
Object^ SelectData(
    IEnumerable<IDedData^>^ dataSource,
    IEnumerable<DedAttr^>^ attrs,
    SelectionModeEnum selectionMode
)
member SelectData :
        dataSource : IEnumerable<IDedData> *
        attrs : IEnumerable<DedAttr> *
        selectionMode : SelectionModeEnum -> Object

Parametri

dataSource IEnumerable IDedData
Fonte dati contenente l'elenco delle anagrafiche da visualizzare.
attrs IEnumerable DedAttr
Attributi per cui creare le colonne.
selectionMode SelectionModeEnum
Indica la modalità di selezione (singola, multipla, ecc..)

Valore di ritorno

Object
Vedi anche

Documentazione

Classe DedFormEditObjects
Namespace DedNet.Forms


Eventi di DedFormEditObjects

Il tipo DedFormEditObjects espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormEditObjects
Namespace DedNet.Forms


Campi di DedFormEditObjects

Il tipo DedFormEditObjects espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormEditObjects
Namespace DedNet.Forms


Classe DedFormFileRecognizer
Dialogo utilizzato dal comando per il riconoscimento massiccio dei documenti
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormFileRecognizer

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormFileRecognizer : BaseForm
Public Class DedFormFileRecognizer
    Inherits BaseForm
public ref class DedFormFileRecognizer : public BaseForm
type DedFormFileRecognizer =
    class
        inherit BaseForm
    end

Il tipo DedFormFileRecognizer espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormFileRecognizer(DedNetApplication) | Costruttore del form
Metodo pubblico | DedFormFileRecognizer(DedNetApplication, Boolean) | Costruttore del form
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | ExtraExtensions | Estensioni extra da utilizzare per ulteriore filtraggio ed estrazione degli elementi da registrare
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà pubblica | ItemsToRecognize | Elementi (file e cartelle) da utilizzare per le operazione di registrazione documenti
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormFileRecognizer
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | DedFormFileRecognizer(DedNetApplication) | Costruttore del form
Metodo pubblico | DedFormFileRecognizer(DedNetApplication, Boolean) | Costruttore del form
Torna su
Vedi anche

Documentazione

Classe DedFormFileRecognizer
Namespace DedNet.Forms


Costruttore DedFormFileRecognizer(DedNetApplication)
Costruttore del form

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormFileRecognizer(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedFormFileRecognizer(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedFormFileRecognizer

Parametri

app DedNetApplication
Vedi anche

Documentazione

Classe DedFormFileRecognizer
Overload di DedFormFileRecognizer
Namespace DedNet.Forms


Costruttore DedFormFileRecognizer(DedNetApplication, Boolean)
Costruttore del form

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormFileRecognizer(
    DedNetApplication app,
    bool test
)
Public Sub New (
    app As DedNetApplication,
    test As Boolean
)
public:
DedFormFileRecognizer(
    DedNetApplication^ app,
    bool test
)
new :
        app : DedNetApplication *
        test : bool -> DedFormFileRecognizer

Parametri

app DedNetApplication
test Boolean
Indica se è un'importazione di test ( senza nessuna scrittura di dati nel Database )
Vedi anche

Documentazione

Classe DedFormFileRecognizer
Overload di DedFormFileRecognizer
Namespace DedNet.Forms


Proprietà di DedFormFileRecognizer

Il tipo DedFormFileRecognizer espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | ExtraExtensions | Estensioni extra da utilizzare per ulteriore filtraggio ed estrazione degli elementi da registrare
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà pubblica | ItemsToRecognize | Elementi (file e cartelle) da utilizzare per le operazione di registrazione documenti
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormFileRecognizer
Namespace DedNet.Forms


Proprietà DedFormFileRecognizer.ExtraExtensions

Proprietà DedFormFileRecognizerExtraExtensions
Estensioni extra da utilizzare per ulteriore filtraggio ed estrazione degli elementi da registrare

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> ExtraExtensions { get; }
Public ReadOnly Property ExtraExtensions As List(Of String)
    Get
public:
property List<String^>^ ExtraExtensions {
    List<String^>^ get ();
}
member ExtraExtensions : List<string> with get

Valore della proprietà

List String
Vedi anche

Documentazione

Classe DedFormFileRecognizer
Namespace DedNet.Forms


Proprietà DedFormFileRecognizer.ItemsToRecognize

Proprietà DedFormFileRecognizerItemsToRecognize
Elementi (file e cartelle) da utilizzare per le operazione di registrazione documenti

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> ItemsToRecognize { get; }
Public ReadOnly Property ItemsToRecognize As List(Of String)
    Get
public:
property List<String^>^ ItemsToRecognize {
    List<String^>^ get ();
}
member ItemsToRecognize : List<string> with get

Valore della proprietà

List String
Vedi anche

Documentazione

Classe DedFormFileRecognizer
Namespace DedNet.Forms


Metodi di DedFormFileRecognizer

Il tipo DedFormFileRecognizer espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormFileRecognizer
Namespace DedNet.Forms


Metodo DedFormFileRecognizer.Dispose

Metodo DedFormFileRecognizerDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormFileRecognizer
Namespace DedNet.Forms


Eventi di DedFormFileRecognizer

Il tipo DedFormFileRecognizer espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormFileRecognizer
Namespace DedNet.Forms


Campi di DedFormFileRecognizer

Il tipo DedFormFileRecognizer espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormFileRecognizer
Namespace DedNet.Forms


Classe DedFormFindCode
Form per la ricerca veloce in base ad un campo. Si imposta la lista dei campi disponibili all'utente, fra i quali può scegliere il campo di ricerca. Si imposta la lista delle colonne che devono essere sempre visibili nel combo dei valori di ricerca. Il form memorizza il nome del campo di ricerca e gestisce lui la sua inizializzazione.
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormFindCode

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormFindCode : BaseForm
Public Class DedFormFindCode
    Inherits BaseForm
public ref class DedFormFindCode : public BaseForm
type DedFormFindCode =
    class
        inherit BaseForm
    end

Il tipo DedFormFindCode espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | AllQueryFields | Restituisce la lista totale dei campi di anagrafica da interrogare in DED_DATA, somma dei campi presenti nel combo di sx più quelli che devono sempre esserci nel risultato del combo di dx.
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà pubblica | DefaultCode | Resituisce o imposta il codice da pre-impostare all'apertura del form.
Proprietà pubblica | DefaultCommandInternalName | Resituisce o imposta il nome interno del comando da impostare come default nel pulsante.
Proprietà pubblica | DefaultId | Resituisce o imposta la revisione da pre-impostare all'apertura del form.
Proprietà pubblica | DefaultRev | Resituisce o imposta la revisione da pre-impostare all'apertura del form.
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | LookupFields | Restituisce la lista dei campi che devono essere sempre presenti nella tendina del risultato ricerca di destra.
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | QueryFields | Restituisce la lista dei campi di scelta ricerca utente contenuti nel ComboBox di sx.
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà pubblica | SelectedField | Restituisce il campo selezionato dall'utente sul quale cercare.
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | AddLookUpField | Aggiunge un campo alla lista delle colonne presenti nel lookupedit.
Metodo pubblico | AddLookUpFields | Aggiunge una lista di campi alle colonne presenti nel lookupedit.
Metodo pubblico | AddQueryField | Aggiunge un campo nel combobox "Cerca per".
Metodo pubblico | AddQueryFields | Aggiunge una lista di campi nel combobox "Cerca per".
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo pubblico | InitializeStatusBar | Inizializza i controlli presenti nella statusbar.
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo pubblico | SetCommandList | Rigenera la lista dei comandi del pulsante con la lista dei comandi passati.
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Proprietà di DedFormFindCode

Il tipo DedFormFindCode espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | AllQueryFields | Restituisce la lista totale dei campi di anagrafica da interrogare in DED_DATA, somma dei campi presenti nel combo di sx più quelli che devono sempre esserci nel risultato del combo di dx.
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà pubblica | DefaultCode | Resituisce o imposta il codice da pre-impostare all'apertura del form.
Proprietà pubblica | DefaultCommandInternalName | Resituisce o imposta il nome interno del comando da impostare come default nel pulsante.
Proprietà pubblica | DefaultId | Resituisce o imposta la revisione da pre-impostare all'apertura del form.
Proprietà pubblica | DefaultRev | Resituisce o imposta la revisione da pre-impostare all'apertura del form.
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | LookupFields | Restituisce la lista dei campi che devono essere sempre presenti nella tendina del risultato ricerca di destra.
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | QueryFields | Restituisce la lista dei campi di scelta ricerca utente contenuti nel ComboBox di sx.
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà pubblica | SelectedField | Restituisce il campo selezionato dall'utente sul quale cercare.
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormFindCode
Namespace DedNet.Forms


Proprietà DedFormFindCode.AllQueryFields

Proprietà DedFormFindCodeAllQueryFields
Restituisce la lista totale dei campi di anagrafica da interrogare in DED_DATA, somma dei campi presenti nel combo di sx più quelli che devono sempre esserci nel risultato del combo di dx.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> AllQueryFields { get; }
Public ReadOnly Property AllQueryFields As List(Of String)
    Get
public:
property List<String^>^ AllQueryFields {
    List<String^>^ get ();
}
member AllQueryFields : List<string> with get

Valore della proprietà

List String
Vedi anche

Documentazione

Classe DedFormFindCode
Namespace DedNet.Forms


Proprietà DedFormFindCode.DefaultCode

Proprietà DedFormFindCodeDefaultCode
Resituisce o imposta il codice da pre-impostare all'apertura del form.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string DefaultCode { get; set; }
Public Property DefaultCode As String
    Get
    Set
public:
property String^ DefaultCode {
    String^ get ();
    void set (String^ value);
}
member DefaultCode : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedFormFindCode
Namespace DedNet.Forms


Proprietà DedFormFindCode.DefaultCommandInternalName

Proprietà DedFormFindCodeDefaultCommandInternalName
Resituisce o imposta il nome interno del comando da impostare come default nel pulsante.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string DefaultCommandInternalName { get; set; }
Public Property DefaultCommandInternalName As String
    Get
    Set
public:
property String^ DefaultCommandInternalName {
    String^ get ();
    void set (String^ value);
}
member DefaultCommandInternalName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedFormFindCode
Namespace DedNet.Forms


Proprietà DedFormFindCode.DefaultId

Proprietà DedFormFindCodeDefaultId
Resituisce o imposta la revisione da pre-impostare all'apertura del form.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string DefaultId { get; set; }
Public Property DefaultId As String
    Get
    Set
public:
property String^ DefaultId {
    String^ get ();
    void set (String^ value);
}
member DefaultId : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedFormFindCode
Namespace DedNet.Forms


Proprietà DedFormFindCode.DefaultRev

Proprietà DedFormFindCodeDefaultRev
Resituisce o imposta la revisione da pre-impostare all'apertura del form.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string DefaultRev { get; set; }
Public Property DefaultRev As String
    Get
    Set
public:
property String^ DefaultRev {
    String^ get ();
    void set (String^ value);
}
member DefaultRev : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedFormFindCode
Namespace DedNet.Forms


Proprietà DedFormFindCode.LookupFields

Proprietà DedFormFindCodeLookupFields
Restituisce la lista dei campi che devono essere sempre presenti nella tendina del risultato ricerca di destra.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string[] LookupFields { get; }
Public ReadOnly Property LookupFields As String()
    Get
public:
property array<String^>^ LookupFields {
    array<String^>^ get ();
}
member LookupFields : string[] with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedFormFindCode
Namespace DedNet.Forms


Proprietà DedFormFindCode.QueryFields

Proprietà DedFormFindCodeQueryFields
Restituisce la lista dei campi di scelta ricerca utente contenuti nel ComboBox di sx.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string[] QueryFields { get; }
Public ReadOnly Property QueryFields As String()
    Get
public:
property array<String^>^ QueryFields {
    array<String^>^ get ();
}
member QueryFields : string[] with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedFormFindCode
Namespace DedNet.Forms


Proprietà DedFormFindCode.SelectedField

Proprietà DedFormFindCodeSelectedField
Restituisce il campo selezionato dall'utente sul quale cercare.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string SelectedField { get; }
Public ReadOnly Property SelectedField As String
    Get
public:
property String^ SelectedField {
    String^ get ();
}
member SelectedField : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedFormFindCode
Namespace DedNet.Forms


Metodi di DedFormFindCode

Il tipo DedFormFindCode espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | AddLookUpField | Aggiunge un campo alla lista delle colonne presenti nel lookupedit.
Metodo pubblico | AddLookUpFields | Aggiunge una lista di campi alle colonne presenti nel lookupedit.
Metodo pubblico | AddQueryField | Aggiunge un campo nel combobox "Cerca per".
Metodo pubblico | AddQueryFields | Aggiunge una lista di campi nel combobox "Cerca per".
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo pubblico | InitializeStatusBar | Inizializza i controlli presenti nella statusbar.
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo pubblico | SetCommandList | Rigenera la lista dei comandi del pulsante con la lista dei comandi passati.
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormFindCode
Namespace DedNet.Forms


Metodo DedFormFindCode.AddLookUpField

Metodo DedFormFindCodeAddLookUpField
Aggiunge un campo alla lista delle colonne presenti nel lookupedit.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddLookUpField(
    string field
)
Public Sub AddLookUpField (
    field As String
)
public:
void AddLookUpField(
    String^ field
)
member AddLookUpField :
        field : string -> unit

Parametri

field String
InternalName dell'attributo che si vuole aggiungere.
Vedi anche

Documentazione

Classe DedFormFindCode
Namespace DedNet.Forms


Metodo DedFormFindCode.AddLookUpFields

Metodo DedFormFindCodeAddLookUpFields
Aggiunge una lista di campi alle colonne presenti nel lookupedit.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddLookUpFields(
    List<string> fields
)
Public Sub AddLookUpFields (
    fields As List(Of String)
)
public:
void AddLookUpFields(
    List<String^>^ fields
)
member AddLookUpFields :
        fields : List<string> -> unit

Parametri

fields List String
Lista dei campi da aggiungere. La lista è formata dai vari InternalName degli attributi.
Vedi anche

Documentazione

Classe DedFormFindCode
Namespace DedNet.Forms


Metodo DedFormFindCode.AddQueryField

Metodo DedFormFindCodeAddQueryField
Aggiunge un campo nel combobox "Cerca per".

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddQueryField(
    string field
)
Public Sub AddQueryField (
    field As String
)
public:
void AddQueryField(
    String^ field
)
member AddQueryField :
        field : string -> unit

Parametri

field String
InternalName dell'attributo che si vuole aggiungere.
Vedi anche

Documentazione

Classe DedFormFindCode
Namespace DedNet.Forms


Metodo DedFormFindCode.AddQueryFields

Metodo DedFormFindCodeAddQueryFields
Aggiunge una lista di campi nel combobox "Cerca per".

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AddQueryFields(
    List<string> field
)
Public Sub AddQueryFields (
    field As List(Of String)
)
public:
void AddQueryFields(
    List<String^>^ field
)
member AddQueryFields :
        field : List<string> -> unit

Parametri

field List String
Lista dei campi da aggiungere. La lista è formata dai vari InternalName degli attributi.
Vedi anche

Documentazione

Classe DedFormFindCode
Namespace DedNet.Forms


Metodo DedFormFindCode.Dispose

Metodo DedFormFindCodeDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormFindCode
Namespace DedNet.Forms


Metodo DedFormFindCode.InitializeStatusBar

Metodo DedFormFindCodeInitializeStatusBar
Inizializza i controlli presenti nella statusbar.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void InitializeStatusBar(
    DedData data,
    bool checkRev,
    bool skipIfClose
)
Public Sub InitializeStatusBar (
    data As DedData,
    checkRev As Boolean,
    skipIfClose As Boolean
)
public:
void InitializeStatusBar(
    DedData^ data,
    bool checkRev,
    bool skipIfClose
)
member InitializeStatusBar :
        data : DedData *
        checkRev : bool *
        skipIfClose : bool -> unit

Parametri

data DedData
Anagrafica di riferimeto da utilizzare.
checkRev Boolean
Indica se tenere conto delle revisioni e ricercare gli ECO solo per ID.
skipIfClose Boolean
Indica se tenere conto degli ECO impostati come chiusi.
Vedi anche

Documentazione

Classe DedFormFindCode
Namespace DedNet.Forms


Metodo DedFormFindCode.SetCommandList

Metodo DedFormFindCodeSetCommandList
Rigenera la lista dei comandi del pulsante con la lista dei comandi passati.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetCommandList(
    DedCommandList commandList
)
Public Sub SetCommandList (
    commandList As DedCommandList
)
public:
void SetCommandList(
    DedCommandList^ commandList
)
member SetCommandList :
        commandList : DedCommandList -> unit

Parametri

commandList DedCommandList
Lista completa dei comandi.
Note
Filtra i comandi in modo da aggiungere soltanto quelli coerenti con il contesto passato.
Vedi anche

Documentazione

Classe DedFormFindCode
Namespace DedNet.Forms


Eventi di DedFormFindCode

Il tipo DedFormFindCode espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormFindCode
Namespace DedNet.Forms


Campi di DedFormFindCode

Il tipo DedFormFindCode espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormFindCode
Namespace DedNet.Forms


Classe DedFormFindCodeOptions
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormFindCodeOptions

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormFindCodeOptions : BaseForm
Public Class DedFormFindCodeOptions
    Inherits BaseForm
public ref class DedFormFindCodeOptions : public BaseForm
type DedFormFindCodeOptions =
    class
        inherit BaseForm
    end

Il tipo DedFormFindCodeOptions espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormFindCodeOptions | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormFindCodeOptions
Costruttore unico.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormFindCodeOptions(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedFormFindCodeOptions(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedFormFindCodeOptions

Parametri

app DedNetApplication
Applicazione DedNet.
Vedi anche

Documentazione

Classe DedFormFindCodeOptions
Namespace DedNet.Forms


Proprietà di DedFormFindCodeOptions

Il tipo DedFormFindCodeOptions espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormFindCodeOptions
Namespace DedNet.Forms


Metodi di DedFormFindCodeOptions

Il tipo DedFormFindCodeOptions espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormFindCodeOptions
Namespace DedNet.Forms


Metodo DedFormFindCodeOptions.Dispose

Metodo DedFormFindCodeOptionsDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormFindCodeOptions
Namespace DedNet.Forms


Eventi di DedFormFindCodeOptions

Il tipo DedFormFindCodeOptions espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormFindCodeOptions
Namespace DedNet.Forms


Campi di DedFormFindCodeOptions

Il tipo DedFormFindCodeOptions espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormFindCodeOptions
Namespace DedNet.Forms


Classe DedFormFontDialog
Dialogo utilizzato come popup per il DedFontEdit.
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormFontDialog

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormFontDialog : BaseForm
Public Class DedFormFontDialog
    Inherits BaseForm
public ref class DedFormFontDialog : public BaseForm
type DedFormFontDialog =
    class
        inherit BaseForm
    end

Il tipo DedFormFontDialog espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormFontDialog | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFontNames | Inizializza il listbox dei font.
Metodo protetto | CreateFontSizes | Inizializza il listbox delle dimensioni.
Metodo protetto | CreateFontStyles | Inizializza il listbox degli stili.
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateNewFontInstance | Utilizza le impostazioni attualmente selezionate per creare e ritornare un oggetto Font.
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | InitializeControlsValue | Metodo che inizializza i controlli con valori di default.
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormClosing | (Sovrascrive FormOnFormClosing(FormClosingEventArgs))
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormFontDialog
Costruttore unico.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormFontDialog(
    RepositoryItemDedFontEdit owner
)
Public Sub New (
    owner As RepositoryItemDedFontEdit
)
public:
DedFormFontDialog(
    RepositoryItemDedFontEdit^ owner
)
new :
        owner : RepositoryItemDedFontEdit -> DedFormFontDialog

Parametri

owner RepositoryItemDedFontEdit
Repository padre.
Vedi anche

Documentazione

Classe DedFormFontDialog
Namespace DedNet.Forms


Proprietà di DedFormFontDialog

Il tipo DedFormFontDialog espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormFontDialog
Namespace DedNet.Forms


Metodi di DedFormFontDialog

Il tipo DedFormFontDialog espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFontNames | Inizializza il listbox dei font.
Metodo protetto | CreateFontSizes | Inizializza il listbox delle dimensioni.
Metodo protetto | CreateFontStyles | Inizializza il listbox degli stili.
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateNewFontInstance | Utilizza le impostazioni attualmente selezionate per creare e ritornare un oggetto Font.
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | InitializeControlsValue | Metodo che inizializza i controlli con valori di default.
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormClosing | (Sovrascrive FormOnFormClosing(FormClosingEventArgs))
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormFontDialog
Namespace DedNet.Forms


Metodo DedFormFontDialog.CreateFontNames

Metodo DedFormFontDialogCreateFontNames
Inizializza il listbox dei font.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected void CreateFontNames()
Protected Sub CreateFontNames
protected:
void CreateFontNames()
member CreateFontNames : unit -> unit
Vedi anche

Documentazione

Classe DedFormFontDialog
Namespace DedNet.Forms


Metodo DedFormFontDialog.CreateFontSizes

Metodo DedFormFontDialogCreateFontSizes
Inizializza il listbox delle dimensioni.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected void CreateFontSizes()
Protected Sub CreateFontSizes
protected:
void CreateFontSizes()
member CreateFontSizes : unit -> unit
Vedi anche

Documentazione

Classe DedFormFontDialog
Namespace DedNet.Forms


Metodo DedFormFontDialog.CreateFontStyles

Metodo DedFormFontDialogCreateFontStyles
Inizializza il listbox degli stili.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected void CreateFontStyles()
Protected Sub CreateFontStyles
protected:
void CreateFontStyles()
member CreateFontStyles : unit -> unit
Vedi anche

Documentazione

Classe DedFormFontDialog
Namespace DedNet.Forms


Metodo DedFormFontDialog.CreateNewFontInstance

Metodo DedFormFontDialogCreateNewFontInstance
Utilizza le impostazioni attualmente selezionate per creare e ritornare un oggetto Font.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected Font CreateNewFontInstance()
Protected Function CreateNewFontInstance As Font
protected:
Font^ CreateNewFontInstance()
member CreateNewFontInstance : unit -> Font

Valore di ritorno

Font
Vedi anche

Documentazione

Classe DedFormFontDialog
Namespace DedNet.Forms


Metodo DedFormFontDialog.Dispose

Metodo DedFormFontDialogDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormFontDialog
Namespace DedNet.Forms


Metodo DedFormFontDialog.InitializeControlsValue

Metodo DedFormFontDialogInitializeControlsValue
Metodo che inizializza i controlli con valori di default.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected void InitializeControlsValue()
Protected Sub InitializeControlsValue
protected:
void InitializeControlsValue()
member InitializeControlsValue : unit -> unit
Vedi anche

Documentazione

Classe DedFormFontDialog
Namespace DedNet.Forms


Metodo DedFormFontDialog.OnFormClosing

Metodo DedFormFontDialogOnFormClosing

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void OnFormClosing(
    FormClosingEventArgs e
)
Protected Overrides Sub OnFormClosing (
    e As FormClosingEventArgs
)
protected:
virtual void OnFormClosing(
    FormClosingEventArgs^ e
) override
abstract OnFormClosing :
        e : FormClosingEventArgs -> unit
override OnFormClosing :
        e : FormClosingEventArgs -> unit

Parametri

e FormClosingEventArgs
Vedi anche

Documentazione

Classe DedFormFontDialog
Namespace DedNet.Forms


Eventi di DedFormFontDialog

Il tipo DedFormFontDialog espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormFontDialog
Namespace DedNet.Forms


Campi di DedFormFontDialog

Il tipo DedFormFontDialog espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormFontDialog
Namespace DedNet.Forms


Classe DedFormImportBom
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormImportBom

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormImportBom : BaseForm
Public Class DedFormImportBom
    Inherits BaseForm
public ref class DedFormImportBom : public BaseForm
type DedFormImportBom =
    class
        inherit BaseForm
    end

Il tipo DedFormImportBom espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormImportBom | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà pubblica | BomInfo | Informazioni sulla distinta da importare
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | ImportDataList | Lista di anagrafiche da importare.
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo pubblico | GetMapping | Inizializza un array contenente la mappatura delle colonne
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo pubblico | SetMapping | Imposta nelle colonne la mappatura letta da un'array di stringhe
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormImportBom
Costruttore

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormImportBom(
    DedNetApplication app,
    string file,
    DedFormImportBomImportTypeEnum importType
)
Public Sub New (
    app As DedNetApplication,
    file As String,
    importType As DedFormImportBomImportTypeEnum
)
public:
DedFormImportBom(
    DedNetApplication^ app,
    String^ file,
    DedFormImportBomImportTypeEnum importType
)
new :
        app : DedNetApplication *
        file : string *
        importType : DedFormImportBomImportTypeEnum -> DedFormImportBom

Parametri

app DedNetApplication
file String
importType DedFormImportBomImportTypeEnum
Vedi anche

Documentazione

Classe DedFormImportBom
Namespace DedNet.Forms


Proprietà di DedFormImportBom

Il tipo DedFormImportBom espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà pubblica | BomInfo | Informazioni sulla distinta da importare
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | ImportDataList | Lista di anagrafiche da importare.
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormImportBom
Namespace DedNet.Forms


Proprietà DedFormImportBom.BomInfo

Proprietà DedFormImportBomBomInfo
Informazioni sulla distinta da importare

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormImportBomBomImportInfo BomInfo { get; }
Public ReadOnly Property BomInfo As DedFormImportBomBomImportInfo
    Get
public:
property DedFormImportBomBomImportInfo BomInfo {
    DedFormImportBomBomImportInfo get ();
}
member BomInfo : DedFormImportBomBomImportInfo with get

Valore della proprietà

DedFormImportBomBomImportInfo
Vedi anche

Documentazione

Classe DedFormImportBom
Namespace DedNet.Forms


Proprietà DedFormImportBom.ImportDataList

Proprietà DedFormImportBomImportDataList
Lista di anagrafiche da importare.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<DedFormImportBomDataImportInfo> ImportDataList { get; }
Public ReadOnly Property ImportDataList As List(Of DedFormImportBomDataImportInfo)
    Get
public:
property List<DedFormImportBomDataImportInfo>^ ImportDataList {
    List<DedFormImportBomDataImportInfo>^ get ();
}
member ImportDataList : List<DedFormImportBomDataImportInfo> with get

Valore della proprietà

List DedFormImportBomDataImportInfo
Vedi anche

Documentazione

Classe DedFormImportBom
Namespace DedNet.Forms


Metodi di DedFormImportBom

Il tipo DedFormImportBom espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo pubblico | GetMapping | Inizializza un array contenente la mappatura delle colonne
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo pubblico | SetMapping | Imposta nelle colonne la mappatura letta da un'array di stringhe
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormImportBom
Namespace DedNet.Forms


Metodo DedFormImportBom.Dispose

Metodo DedFormImportBomDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormImportBom
Namespace DedNet.Forms


Metodo DedFormImportBom.GetMapping

Metodo DedFormImportBomGetMapping
Inizializza un array contenente la mappatura delle colonne

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string[] GetMapping()
Public Function GetMapping As String()
public:
array<String^>^ GetMapping()
member GetMapping : unit -> string[]

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedFormImportBom
Namespace DedNet.Forms


Metodo DedFormImportBom.SetMapping

Metodo DedFormImportBomSetMapping
Imposta nelle colonne la mappatura letta da un'array di stringhe

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetMapping(
    string[] strArr
)
Public Sub SetMapping (
    strArr As String()
)
public:
void SetMapping(
    array<String^>^ strArr
)
member SetMapping :
        strArr : string[] -> unit

Parametri

strArr String
Array di stringhe da usare per la mappatura delle colonne
Vedi anche

Documentazione

Classe DedFormImportBom
Namespace DedNet.Forms


Eventi di DedFormImportBom

Il tipo DedFormImportBom espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormImportBom
Namespace DedNet.Forms


Campi di DedFormImportBom

Il tipo DedFormImportBom espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormImportBom
Namespace DedNet.Forms


Struttura DedFormImportBom.BomImportInfo

Struttura DedFormImportBomBomImportInfo
Struttura con le informazioni sulla distinta da importare
Gerarchia di ereditarietà
SystemObject
SystemValueType
DedNet.FormsDedFormImportBomBomImportInfo

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public struct BomImportInfo
Public Structure BomImportInfo
public value class BomImportInfo
[<SealedAttribute>]
type BomImportInfo =
    struct
        inherit ValueType
    end

Il tipo DedFormImportBomBomImportInfo espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | Bom | Distinta da importare
Campo pubblico | DbPathNeeded | Indica se il DBPath è già stato impostato o meno
Campo pubblico | DdpRootNode | Informazioni anagrafiche del nodo root
Campo pubblico | DiscrimAnagAttrs | Attributi discriminanti di anagrafica
Campo pubblico | DiscrimDistAttrs | Attributi discriminanti di distinta
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Campi di BomImportInfo

Il tipo DedFormImportBomBomImportInfo espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | Bom | Distinta da importare
Campo pubblico | DbPathNeeded | Indica se il DBPath è già stato impostato o meno
Campo pubblico | DdpRootNode | Informazioni anagrafiche del nodo root
Campo pubblico | DiscrimAnagAttrs | Attributi discriminanti di anagrafica
Campo pubblico | DiscrimDistAttrs | Attributi discriminanti di distinta
Torna su
Vedi anche

Documentazione

Struttura DedFormImportBomBomImportInfo
Namespace DedNet.Forms


Campo DedFormImportBom.BomImportInfo.Bom

Campo DedFormImportBomBomImportInfoBom
Distinta da importare

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomItemCollection Bom
Public Bom As BomItemCollection
public:
BomItemCollection^ Bom
val mutable Bom: BomItemCollection

Valore del campo

BomItemCollection
Vedi anche

Documentazione

Struttura DedFormImportBomBomImportInfo
Namespace DedNet.Forms


Campo DedFormImportBom.BomImportInfo.DbPathNeeded

Campo DedFormImportBomBomImportInfoDbPathNeeded
Indica se il DBPath è già stato impostato o meno

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool DbPathNeeded
Public DbPathNeeded As Boolean
public:
bool DbPathNeeded
val mutable DbPathNeeded: bool

Valore del campo

Boolean
Vedi anche

Documentazione

Struttura DedFormImportBomBomImportInfo
Namespace DedNet.Forms


Campo DedFormImportBom.BomImportInfo.DdpRootNode

Campo DedFormImportBomBomImportInfoDdpRootNode
Informazioni anagrafiche del nodo root

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataPart DdpRootNode
Public DdpRootNode As DedDataPart
public:
DedDataPart^ DdpRootNode
val mutable DdpRootNode: DedDataPart

Valore del campo

DedDataPart
Vedi anche

Documentazione

Struttura DedFormImportBomBomImportInfo
Namespace DedNet.Forms


Campo DedFormImportBom.BomImportInfo.DiscrimAnagAttrs

Campo DedFormImportBomBomImportInfoDiscrimAnagAttrs
Attributi discriminanti di anagrafica

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList DiscrimAnagAttrs
Public DiscrimAnagAttrs As DedAttrList
public:
DedAttrList^ DiscrimAnagAttrs
val mutable DiscrimAnagAttrs: DedAttrList

Valore del campo

DedAttrList
Vedi anche

Documentazione

Struttura DedFormImportBomBomImportInfo
Namespace DedNet.Forms


Campo DedFormImportBom.BomImportInfo.DiscrimDistAttrs

Campo DedFormImportBomBomImportInfoDiscrimDistAttrs
Attributi discriminanti di distinta

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList DiscrimDistAttrs
Public DiscrimDistAttrs As DedAttrList
public:
DedAttrList^ DiscrimDistAttrs
val mutable DiscrimDistAttrs: DedAttrList

Valore del campo

DedAttrList
Vedi anche

Documentazione

Struttura DedFormImportBomBomImportInfo
Namespace DedNet.Forms


Struttura DedFormImportBom.DataImportInfo

Struttura DedFormImportBomDataImportInfo
Struttura con le informazioni sull'anagrafica da importare.
Gerarchia di ereditarietà
SystemObject
SystemValueType
DedNet.FormsDedFormImportBomDataImportInfo

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public struct DataImportInfo
Public Structure DataImportInfo
public value class DataImportInfo
[<SealedAttribute>]
type DataImportInfo =
    struct
        inherit ValueType
    end

Il tipo DedFormImportBomDataImportInfo espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | Data | Anagrafica da importare.
Campo pubblico | Elaboration | Tipo di elaborazione.
Campo pubblico | Qta | Quantità.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Campi di DataImportInfo

Il tipo DedFormImportBomDataImportInfo espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | Data | Anagrafica da importare.
Campo pubblico | Elaboration | Tipo di elaborazione.
Campo pubblico | Qta | Quantità.
Torna su
Vedi anche

Documentazione

Struttura DedFormImportBomDataImportInfo
Namespace DedNet.Forms


Campo DedFormImportBom.DataImportInfo.Data

Campo DedFormImportBomDataImportInfoData
Anagrafica da importare.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Data
Public Data As DedData
public:
DedData^ Data
val mutable Data: DedData

Valore del campo

DedData
Vedi anche

Documentazione

Struttura DedFormImportBomDataImportInfo
Namespace DedNet.Forms


Campo DedFormImportBom.DataImportInfo.Elaboration

Campo DedFormImportBomDataImportInfoElaboration
Tipo di elaborazione.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ListElaborationTypeEnum Elaboration
Public Elaboration As ListElaborationTypeEnum
public:
ListElaborationTypeEnum Elaboration
val mutable Elaboration: ListElaborationTypeEnum

Valore del campo

ListElaborationTypeEnum
Vedi anche

Documentazione

Struttura DedFormImportBomDataImportInfo
Namespace DedNet.Forms


Campo DedFormImportBom.DataImportInfo.Qta

Campo DedFormImportBomDataImportInfoQta
Quantità.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public double Qta
Public Qta As Double
public:
double Qta
val mutable Qta: float

Valore del campo

Double
Vedi anche

Documentazione

Struttura DedFormImportBomDataImportInfo
Namespace DedNet.Forms


Struttura DedFormImportBom.FormatJson

Struttura DedFormImportBomFormatJson
Struttura usata per formattare il file Json usato per il salvataggio/caricamento della configurazione
Gerarchia di ereditarietà
SystemObject
SystemValueType
DedNet.FormsDedFormImportBomFormatJson

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public struct FormatJson
Public Structure FormatJson
public value class FormatJson
[<SealedAttribute>]
type FormatJson =
    struct
        inherit ValueType
    end

Il tipo DedFormImportBomFormatJson espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | DataSourceMapping | Mappatura colonne
Campo pubblico | SearchFor | Discriminante
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Campi di FormatJson

Il tipo DedFormImportBomFormatJson espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | DataSourceMapping | Mappatura colonne
Campo pubblico | SearchFor | Discriminante
Torna su
Vedi anche

Documentazione

Struttura DedFormImportBomFormatJson
Namespace DedNet.Forms


Campo DedFormImportBom.FormatJson.DataSourceMapping

Campo DedFormImportBomFormatJsonDataSourceMapping
Mappatura colonne

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string[] DataSourceMapping
Public DataSourceMapping As String()
public:
array<String^>^ DataSourceMapping
val mutable DataSourceMapping: string[]

Valore del campo

String
Vedi anche

Documentazione

Struttura DedFormImportBomFormatJson
Namespace DedNet.Forms


Campo DedFormImportBom.FormatJson.SearchFor

Campo DedFormImportBomFormatJsonSearchFor
Discriminante

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string SearchFor
Public SearchFor As String
public:
String^ SearchFor
val mutable SearchFor: string

Valore del campo

String
Vedi anche

Documentazione

Struttura DedFormImportBomFormatJson
Namespace DedNet.Forms


Enumerazione DedFormImportBom.ImportTypeEnum

Enumerazione DedFormImportBomImportTypeEnum
Enumeratore che indica la tipologia di importazione.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum ImportTypeEnum
Public Enumeration ImportTypeEnum
public enum class ImportTypeEnum
type ImportTypeEnum
Membri
Nome | Valore | Descrizione
Data | 0 | Anagrafiche.
Bom | 1 | Distinta.
Vedi anche

Documentazione

Namespace DedNet.Forms


Classe DedFormImporter
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormImporter

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormImporter : BaseForm
Public Class DedFormImporter
    Inherits BaseForm
public ref class DedFormImporter : public BaseForm
type DedFormImporter =
    class
        inherit BaseForm
    end

Il tipo DedFormImporter espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormImporter |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | ImporterMode | Indica il tipo di importazione che si vuole eseguire (se di anagrafiche, traduzioni, ecc..)
Proprietà pubblica | ImporterTranslationType | Indica il tipo di importazione di traduzione che si vuole eseguire (attributi di ricambio, dizionario aziendale, ecc..)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormImporter

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormImporter(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedFormImporter(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedFormImporter

Parametri

app DedNetApplication
Vedi anche

Documentazione

Classe DedFormImporter
Namespace DedNet.Forms


Proprietà di DedFormImporter

Il tipo DedFormImporter espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | ImporterMode | Indica il tipo di importazione che si vuole eseguire (se di anagrafiche, traduzioni, ecc..)
Proprietà pubblica | ImporterTranslationType | Indica il tipo di importazione di traduzione che si vuole eseguire (attributi di ricambio, dizionario aziendale, ecc..)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormImporter
Namespace DedNet.Forms


Proprietà DedFormImporter.ImporterMode

Proprietà DedFormImporterImporterMode
Indica il tipo di importazione che si vuole eseguire (se di anagrafiche, traduzioni, ecc..)

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ImporterModeEnum ImporterMode { set; }
Public WriteOnly Property ImporterMode As ImporterModeEnum
    Set
public:
property ImporterModeEnum ImporterMode {
    void set (ImporterModeEnum value);
}
member ImporterMode : ImporterModeEnum with set

Valore della proprietà

ImporterModeEnum
Vedi anche

Documentazione

Classe DedFormImporter
Namespace DedNet.Forms


Proprietà DedFormImporter.ImporterTranslationType

Proprietà DedFormImporterImporterTranslationType
Indica il tipo di importazione di traduzione che si vuole eseguire (attributi di ricambio, dizionario aziendale, ecc..)

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ImporterTranslationTypeEnum ImporterTranslationType { set; }
Public WriteOnly Property ImporterTranslationType As ImporterTranslationTypeEnum
    Set
public:
property ImporterTranslationTypeEnum ImporterTranslationType {
    void set (ImporterTranslationTypeEnum value);
}
member ImporterTranslationType : ImporterTranslationTypeEnum with set

Valore della proprietà

ImporterTranslationTypeEnum
Vedi anche

Documentazione

Classe DedFormImporter
Namespace DedNet.Forms


Metodi di DedFormImporter

Il tipo DedFormImporter espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormImporter
Namespace DedNet.Forms


Metodo DedFormImporter.Dispose

Metodo DedFormImporterDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormImporter
Namespace DedNet.Forms


Eventi di DedFormImporter

Il tipo DedFormImporter espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormImporter
Namespace DedNet.Forms


Campi di DedFormImporter

Il tipo DedFormImporter espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormImporter
Namespace DedNet.Forms


Classe DedFormListEdit
Form per aggiunta elementi alle liste utente
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormListEdit

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormListEdit : BaseForm
Public Class DedFormListEdit
    Inherits BaseForm
public ref class DedFormListEdit : public BaseForm
type DedFormListEdit =
    class
        inherit BaseForm
    end

Il tipo DedFormListEdit espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormListEdit | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà pubblica | SelectedList | Tipologia di lista selezionata
Proprietà pubblica | SelectedUserList | Lista utente selezionate
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo pubblico | CreateCommRow | Crea la riga dell'elemento di Commessa da aggiungere al DataTable
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo pubblico | CreateDataRow | Crea la riga dell'elemento di Anagrafica da aggiungere al DataTable
Metodo pubblico | CreateDataTable | Crea il datatable delle anagrafiche lo binda e gestisce visibilità delle colonne
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo pubblico | FillDataTable | Riempie il datatable delle anagrafiche
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormListEdit
Costruttore

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormListEdit(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedFormListEdit(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedFormListEdit

Parametri

app DedNetApplication
Applicazione
Vedi anche

Documentazione

Classe DedFormListEdit
Namespace DedNet.Forms


Proprietà di DedFormListEdit

Il tipo DedFormListEdit espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà pubblica | SelectedList | Tipologia di lista selezionata
Proprietà pubblica | SelectedUserList | Lista utente selezionate
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormListEdit
Namespace DedNet.Forms


Proprietà DedFormListEdit.SelectedList

Proprietà DedFormListEditSelectedList
Tipologia di lista selezionata

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedList SelectedList { get; set; }
Public Property SelectedList As DedList
    Get
    Set
public:
property DedList^ SelectedList {
    DedList^ get ();
    void set (DedList^ value);
}
member SelectedList : DedList with get, set

Valore della proprietà

DedList
Vedi anche

Documentazione

Classe DedFormListEdit
Namespace DedNet.Forms


Proprietà DedFormListEdit.SelectedUserList

Proprietà DedFormListEditSelectedUserList
Lista utente selezionate

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedUserList SelectedUserList { get; set; }
Public Property SelectedUserList As DedUserList
    Get
    Set
public:
property DedUserList^ SelectedUserList {
    DedUserList^ get ();
    void set (DedUserList^ value);
}
member SelectedUserList : DedUserList with get, set

Valore della proprietà

DedUserList
Vedi anche

Documentazione

Classe DedFormListEdit
Namespace DedNet.Forms


Metodi di DedFormListEdit

Il tipo DedFormListEdit espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo pubblico | CreateCommRow | Crea la riga dell'elemento di Commessa da aggiungere al DataTable
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo pubblico | CreateDataRow | Crea la riga dell'elemento di Anagrafica da aggiungere al DataTable
Metodo pubblico | CreateDataTable | Crea il datatable delle anagrafiche lo binda e gestisce visibilità delle colonne
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo pubblico | FillDataTable | Riempie il datatable delle anagrafiche
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormListEdit
Namespace DedNet.Forms


Metodo DedFormListEdit.CreateCommRow

Metodo DedFormListEditCreateCommRow
Crea la riga dell'elemento di Commessa da aggiungere al DataTable

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void CreateCommRow(
    DataTable table,
    DedListItem item
)
Public Sub CreateCommRow (
    table As DataTable,
    item As DedListItem
)
public:
void CreateCommRow(
    DataTable^ table,
    DedListItem^ item
)
member CreateCommRow :
        table : DataTable *
        item : DedListItem -> unit

Parametri

table DataTable
Tabella nel quale aggiungere l'elemento
item DedListItem
Elemento da aggiungere
Vedi anche

Documentazione

Classe DedFormListEdit
Namespace DedNet.Forms


Metodo DedFormListEdit.CreateDataRow

Metodo DedFormListEditCreateDataRow
Crea la riga dell'elemento di Anagrafica da aggiungere al DataTable

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void CreateDataRow(
    DataTable table,
    DedListItem item,
    IEnumerable<DedAttr> attrs
)
Public Sub CreateDataRow (
    table As DataTable,
    item As DedListItem,
    attrs As IEnumerable(Of DedAttr)
)
public:
void CreateDataRow(
    DataTable^ table,
    DedListItem^ item,
    IEnumerable<DedAttr^>^ attrs
)
member CreateDataRow :
        table : DataTable *
        item : DedListItem *
        attrs : IEnumerable<DedAttr> -> unit

Parametri

table DataTable
Tabella nel quale aggiungere l'elemento
item DedListItem
Elemento da aggiungere
attrs IEnumerable DedAttr
Attributi da considerare
Vedi anche

Documentazione

Classe DedFormListEdit
Namespace DedNet.Forms


Metodo DedFormListEdit.CreateDataTable

Metodo DedFormListEditCreateDataTable
Crea il datatable delle anagrafiche lo binda e gestisce visibilità delle colonne

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void CreateDataTable()
Public Sub CreateDataTable
public:
void CreateDataTable()
member CreateDataTable : unit -> unit
Vedi anche

Documentazione

Classe DedFormListEdit
Namespace DedNet.Forms


Metodo DedFormListEdit.Dispose

Metodo DedFormListEditDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormListEdit
Namespace DedNet.Forms


Metodo DedFormListEdit.FillDataTable

Metodo DedFormListEditFillDataTable
Riempie il datatable delle anagrafiche

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void FillDataTable()
Public Sub FillDataTable
public:
void FillDataTable()
member FillDataTable : unit -> unit
Vedi anche

Documentazione

Classe DedFormListEdit
Namespace DedNet.Forms


Eventi di DedFormListEdit

Il tipo DedFormListEdit espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormListEdit
Namespace DedNet.Forms


Campi di DedFormListEdit

Il tipo DedFormListEdit espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormListEdit
Namespace DedNet.Forms


Classe DedFormLogView
Dialogo che permette di visualizzare e filtrare all'interno di una griglia devexpress il contenuto della tabella DED_LOG. Sono inoltre presenti due strumenti di utilità: - Esportazione della vista attuale in formato Excel, CSV, PDF, HTML. - Cancellazione dal DB delle loggate presenti nella vista attuale (richiede permessi speciali).
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormLogView

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormLogView : BaseForm
Public Class DedFormLogView
    Inherits BaseForm
public ref class DedFormLogView : public BaseForm
type DedFormLogView =
    class
        inherit BaseForm
    end

Il tipo DedFormLogView espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormLogView | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà pubblica | SelectedModule | Ritorna il Modulo attualmente selezionato.
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormLogView
Costruttore unico.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormLogView(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedFormLogView(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedFormLogView

Parametri

app DedNetApplication
Applicazione DedNet.
Vedi anche

Documentazione

Classe DedFormLogView
Namespace DedNet.Forms


Proprietà di DedFormLogView

Il tipo DedFormLogView espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà pubblica | SelectedModule | Ritorna il Modulo attualmente selezionato.
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormLogView
Namespace DedNet.Forms


Proprietà DedFormLogView.SelectedModule

Proprietà DedFormLogViewSelectedModule
Ritorna il Modulo attualmente selezionato.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string SelectedModule { get; }
Public ReadOnly Property SelectedModule As String
    Get
public:
property String^ SelectedModule {
    String^ get ();
}
member SelectedModule : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedFormLogView
Namespace DedNet.Forms


Metodi di DedFormLogView

Il tipo DedFormLogView espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormLogView
Namespace DedNet.Forms


Metodo DedFormLogView.Dispose

Metodo DedFormLogViewDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormLogView
Namespace DedNet.Forms


Eventi di DedFormLogView

Il tipo DedFormLogView espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormLogView
Namespace DedNet.Forms


Campi di DedFormLogView

Il tipo DedFormLogView espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormLogView
Namespace DedNet.Forms


Classe DedFormMain
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormMain

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormMain : BaseForm
Public Class DedFormMain
    Inherits BaseForm
public ref class DedFormMain : public BaseForm
type DedFormMain =
    class
        inherit BaseForm
    end

Il tipo DedFormMain espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà pubblica | CloseDialogOnQuit | Restituisce o imposta se la finestra, su chiusura, tramite x o tramite menu, si debba chiudere invece di nascondersi. Di default è false.
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà pubblica | DisableFind | Disabilita la possibilità di selezionare le famigle.
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | ElementToSelect | Restituisce il tipo di elementi che devono essere selezionati dall'utente (in modalità modale).
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | FilterOnLoad | Lista di estensioni su cui filtrare in apertura.
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà pubblica | ForcedSelectedFam | Indica la famiglia da selezionare forzata dopo la lettura del registro
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumPerm | Permesso minimo.
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà pubblica | Modale | Restituisce in quale modalità visualizzare la finestra (impostata automaticamente quando viene chiamato il metodo VisualizzaForm()).
Proprietà pubblica | MoreThanOne | Restituisce il numero di elementi da selezionare (in modalità modale).
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | OnlyLavAnagr | Indica se permettere la selezione di solo anagrafiche in lavorazione.
Proprietà pubblica | OnlySubTypes | Indica se devono essere selezionate solo anagrafiche in lavorazione (caso modale)
Proprietà pubblica | RequestData | Restituisce le informazioni sulla selezione.
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowAttachFile | Visualizzare o no i file allegati
Proprietà pubblica | ShowEditAnagrPage | Visualizzare o no il controllo per visulizzare/editare le anagrafiche
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowManageAnagrPage | Visualizzare o no il controllo con le anagrafiche preferite
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowPreview | Visualizzare o no il preview dei file
Proprietà pubblica | ShowPrimaryFile | Visualizzare o no i file primari
Proprietà pubblica | ShowRecentPage | Visualizzare o no il controllo con le anagrafiche usate di recente
Proprietà pubblica | ShowStatusBar | Visualizzare o no il la barra di stato.
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Proprietà pubblica | UserMessage | Imposta il messaggio di richiesta all'utente ( in modalità modale )
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo pubblico | IndividuaAnagrafica | Mostra l'anagrafica nel tab dei recenti. Da chiamare nel non modale.
Metodo pubblico | IndividuaAnagraficaModal |
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo pubblico | IsUserChanged | Ritorna True se l'utente corrente con il quale si vuol mostrare il dialogo è cambiato, False altrimenti.
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | (Sovrascrive BaseFormOnVisibleChanged(EventArgs))
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo pubblico | Ripristina | Se la finestra è visibile, la ripristina al FormWindowState precedente.
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo pubblico | ShowFormModal(IWin32Window, String, DedChooseElement, Boolean, Boolean) | Funzione per visualizzare il form in modo modale e chiedere all'utente una selezione di documenti o anagrafiche.
Metodo pubblico | ShowFormModal(IWin32Window, String, DedChooseElement, Boolean, Boolean, Boolean) | Funzione per visualizzare il form in modo modale e chiedere all'utente una selezione di documenti o anagrafiche.
Metodo pubblico | ShowFormModal(IWin32Window, String, DedDataList, DedChooseElement, Boolean, Boolean, Boolean) | Funzione per visualizzare il form in modo modale con una lista di anagrafiche già definita e chiedere all'utente una selezione di documenti o anagrafiche.
Metodo pubblico | ShowFormModeless | Funzione per visualizzare il form in modo non modale.
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Proprietà di DedFormMain

Il tipo DedFormMain espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà pubblica | CloseDialogOnQuit | Restituisce o imposta se la finestra, su chiusura, tramite x o tramite menu, si debba chiudere invece di nascondersi. Di default è false.
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà pubblica | DisableFind | Disabilita la possibilità di selezionare le famigle.
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | ElementToSelect | Restituisce il tipo di elementi che devono essere selezionati dall'utente (in modalità modale).
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | FilterOnLoad | Lista di estensioni su cui filtrare in apertura.
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà pubblica | ForcedSelectedFam | Indica la famiglia da selezionare forzata dopo la lettura del registro
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumPerm | Permesso minimo.
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà pubblica | Modale | Restituisce in quale modalità visualizzare la finestra (impostata automaticamente quando viene chiamato il metodo VisualizzaForm()).
Proprietà pubblica | MoreThanOne | Restituisce il numero di elementi da selezionare (in modalità modale).
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | OnlyLavAnagr | Indica se permettere la selezione di solo anagrafiche in lavorazione.
Proprietà pubblica | OnlySubTypes | Indica se devono essere selezionate solo anagrafiche in lavorazione (caso modale)
Proprietà pubblica | RequestData | Restituisce le informazioni sulla selezione.
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowAttachFile | Visualizzare o no i file allegati
Proprietà pubblica | ShowEditAnagrPage | Visualizzare o no il controllo per visulizzare/editare le anagrafiche
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowManageAnagrPage | Visualizzare o no il controllo con le anagrafiche preferite
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowPreview | Visualizzare o no il preview dei file
Proprietà pubblica | ShowPrimaryFile | Visualizzare o no i file primari
Proprietà pubblica | ShowRecentPage | Visualizzare o no il controllo con le anagrafiche usate di recente
Proprietà pubblica | ShowStatusBar | Visualizzare o no il la barra di stato.
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Proprietà pubblica | UserMessage | Imposta il messaggio di richiesta all'utente ( in modalità modale )
Torna su
Vedi anche

Documentazione

Classe DedFormMain
Namespace DedNet.Forms


Proprietà DedFormMain.CloseDialogOnQuit

Proprietà DedFormMainCloseDialogOnQuit
Restituisce o imposta se la finestra, su chiusura, tramite x o tramite menu, si debba chiudere invece di nascondersi. Di default è false.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CloseDialogOnQuit { get; set; }
Public Property CloseDialogOnQuit As Boolean
    Get
    Set
public:
property bool CloseDialogOnQuit {
    bool get ();
    void set (bool value);
}
member CloseDialogOnQuit : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormMain
Namespace DedNet.Forms


Proprietà DedFormMain.DisableFind

Proprietà DedFormMainDisableFind
Disabilita la possibilità di selezionare le famigle.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool DisableFind { set; }
Public WriteOnly Property DisableFind As Boolean
    Set
public:
property bool DisableFind {
    void set (bool value);
}
member DisableFind : bool with set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormMain
Namespace DedNet.Forms


Proprietà DedFormMain.ElementToSelect

Proprietà DedFormMainElementToSelect
Restituisce il tipo di elementi che devono essere selezionati dall'utente (in modalità modale).

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedChooseElement ElementToSelect { get; }
Public ReadOnly Property ElementToSelect As DedChooseElement
    Get
public:
property DedChooseElement ElementToSelect {
    DedChooseElement get ();
}
member ElementToSelect : DedChooseElement with get

Valore della proprietà

DedChooseElement
Vedi anche

Documentazione

Classe DedFormMain
Namespace DedNet.Forms


Proprietà DedFormMain.FilterOnLoad

Proprietà DedFormMainFilterOnLoad
Lista di estensioni su cui filtrare in apertura.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> FilterOnLoad { get; set; }
Public Property FilterOnLoad As List(Of String)
    Get
    Set
public:
property List<String^>^ FilterOnLoad {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
member FilterOnLoad : List<string> with get, set

Valore della proprietà

List String
Vedi anche

Documentazione

Classe DedFormMain
Namespace DedNet.Forms


Proprietà DedFormMain.ForcedSelectedFam

Proprietà DedFormMainForcedSelectedFam
Indica la famiglia da selezionare forzata dopo la lettura del registro

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedType ForcedSelectedFam { get; set; }
Public Property ForcedSelectedFam As DedType
    Get
    Set
public:
property DedType^ ForcedSelectedFam {
    DedType^ get ();
    void set (DedType^ value);
}
member ForcedSelectedFam : DedType with get, set

Valore della proprietà

DedType
Vedi anche

Documentazione

Classe DedFormMain
Namespace DedNet.Forms


Proprietà DedFormMain.MinimumPerm

Proprietà DedFormMainMinimumPerm
Permesso minimo.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedStandardPerm MinimumPerm { get; set; }
Public Property MinimumPerm As DedStandardPerm
    Get
    Set
public:
property DedStandardPerm MinimumPerm {
    DedStandardPerm get ();
    void set (DedStandardPerm value);
}
member MinimumPerm : DedStandardPerm with get, set

Valore della proprietà

DedStandardPerm
Vedi anche

Documentazione

Classe DedFormMain
Namespace DedNet.Forms


Proprietà DedFormMain.Modale

Proprietà DedFormMainModale
Restituisce in quale modalità visualizzare la finestra (impostata automaticamente quando viene chiamato il metodo VisualizzaForm()).

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Modale { get; set; }
Public Property Modale As Boolean
    Get
    Set
public:
property bool Modale {
    bool get ();
    void set (bool value);
}
member Modale : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormMain
Namespace DedNet.Forms


Proprietà DedFormMain.MoreThanOne

Proprietà DedFormMainMoreThanOne
Restituisce il numero di elementi da selezionare (in modalità modale).

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool MoreThanOne { get; }
Public ReadOnly Property MoreThanOne As Boolean
    Get
public:
property bool MoreThanOne {
    bool get ();
}
member MoreThanOne : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormMain
Namespace DedNet.Forms


Proprietà DedFormMain.OnlyLavAnagr

Proprietà DedFormMainOnlyLavAnagr
Indica se permettere la selezione di solo anagrafiche in lavorazione.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool OnlyLavAnagr { get; set; }
Public Property OnlyLavAnagr As Boolean
    Get
    Set
public:
property bool OnlyLavAnagr {
    bool get ();
    void set (bool value);
}
member OnlyLavAnagr : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormMain
Namespace DedNet.Forms


Proprietà DedFormMain.OnlySubTypes

Proprietà DedFormMainOnlySubTypes
Indica se devono essere selezionate solo anagrafiche in lavorazione (caso modale)

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool OnlySubTypes { get; set; }
Public Property OnlySubTypes As Boolean
    Get
    Set
public:
property bool OnlySubTypes {
    bool get ();
    void set (bool value);
}
member OnlySubTypes : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormMain
Namespace DedNet.Forms


Proprietà DedFormMain.RequestData

Proprietà DedFormMainRequestData
Restituisce le informazioni sulla selezione.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormMainSelectInfo RequestData { get; }
Public ReadOnly Property RequestData As DedFormMainSelectInfo
    Get
public:
property DedFormMainSelectInfo RequestData {
    DedFormMainSelectInfo get ();
}
member RequestData : DedFormMainSelectInfo with get

Valore della proprietà

DedFormMainSelectInfo
Vedi anche

Documentazione

Classe DedFormMain
Namespace DedNet.Forms


Proprietà DedFormMain.ShowAttachFile

Proprietà DedFormMainShowAttachFile
Visualizzare o no i file allegati

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ShowAttachFile { set; }
Public WriteOnly Property ShowAttachFile As Boolean
    Set
public:
property bool ShowAttachFile {
    void set (bool value);
}
member ShowAttachFile : bool with set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormMain
Namespace DedNet.Forms


Proprietà DedFormMain.ShowEditAnagrPage

Proprietà DedFormMainShowEditAnagrPage
Visualizzare o no il controllo per visulizzare/editare le anagrafiche

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ShowEditAnagrPage { set; }
Public WriteOnly Property ShowEditAnagrPage As Boolean
    Set
public:
property bool ShowEditAnagrPage {
    void set (bool value);
}
member ShowEditAnagrPage : bool with set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormMain
Namespace DedNet.Forms


Proprietà DedFormMain.ShowManageAnagrPage

Proprietà DedFormMainShowManageAnagrPage
Visualizzare o no il controllo con le anagrafiche preferite

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ShowManageAnagrPage { set; }
Public WriteOnly Property ShowManageAnagrPage As Boolean
    Set
public:
property bool ShowManageAnagrPage {
    void set (bool value);
}
member ShowManageAnagrPage : bool with set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormMain
Namespace DedNet.Forms


Proprietà DedFormMain.ShowPreview

Proprietà DedFormMainShowPreview
Visualizzare o no il preview dei file

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ShowPreview { set; }
Public WriteOnly Property ShowPreview As Boolean
    Set
public:
property bool ShowPreview {
    void set (bool value);
}
member ShowPreview : bool with set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormMain
Namespace DedNet.Forms


Proprietà DedFormMain.ShowPrimaryFile

Proprietà DedFormMainShowPrimaryFile
Visualizzare o no i file primari

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ShowPrimaryFile { set; }
Public WriteOnly Property ShowPrimaryFile As Boolean
    Set
public:
property bool ShowPrimaryFile {
    void set (bool value);
}
member ShowPrimaryFile : bool with set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormMain
Namespace DedNet.Forms


Proprietà DedFormMain.ShowRecentPage

Proprietà DedFormMainShowRecentPage
Visualizzare o no il controllo con le anagrafiche usate di recente

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ShowRecentPage { set; }
Public WriteOnly Property ShowRecentPage As Boolean
    Set
public:
property bool ShowRecentPage {
    void set (bool value);
}
member ShowRecentPage : bool with set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormMain
Namespace DedNet.Forms


Proprietà DedFormMain.ShowStatusBar

Proprietà DedFormMainShowStatusBar
Visualizzare o no il la barra di stato.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ShowStatusBar { set; }
Public WriteOnly Property ShowStatusBar As Boolean
    Set
public:
property bool ShowStatusBar {
    void set (bool value);
}
member ShowStatusBar : bool with set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormMain
Namespace DedNet.Forms


Proprietà DedFormMain.UserMessage

Proprietà DedFormMainUserMessage
Imposta il messaggio di richiesta all'utente ( in modalità modale )

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string UserMessage { get; protected set; }
Public Property UserMessage As String
    Get
    Protected Set
public:
property String^ UserMessage {
    String^ get ();
    protected: void set (String^ value);
}
member UserMessage : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedFormMain
Namespace DedNet.Forms


Metodi di DedFormMain

Il tipo DedFormMain espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo pubblico | IndividuaAnagrafica | Mostra l'anagrafica nel tab dei recenti. Da chiamare nel non modale.
Metodo pubblico | IndividuaAnagraficaModal |
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo pubblico | IsUserChanged | Ritorna True se l'utente corrente con il quale si vuol mostrare il dialogo è cambiato, False altrimenti.
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | (Sovrascrive BaseFormOnVisibleChanged(EventArgs))
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo pubblico | Ripristina | Se la finestra è visibile, la ripristina al FormWindowState precedente.
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo pubblico | ShowFormModal(IWin32Window, String, DedChooseElement, Boolean, Boolean) | Funzione per visualizzare il form in modo modale e chiedere all'utente una selezione di documenti o anagrafiche.
Metodo pubblico | ShowFormModal(IWin32Window, String, DedChooseElement, Boolean, Boolean, Boolean) | Funzione per visualizzare il form in modo modale e chiedere all'utente una selezione di documenti o anagrafiche.
Metodo pubblico | ShowFormModal(IWin32Window, String, DedDataList, DedChooseElement, Boolean, Boolean, Boolean) | Funzione per visualizzare il form in modo modale con una lista di anagrafiche già definita e chiedere all'utente una selezione di documenti o anagrafiche.
Metodo pubblico | ShowFormModeless | Funzione per visualizzare il form in modo non modale.
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormMain
Namespace DedNet.Forms


Metodo DedFormMain.Dispose

Metodo DedFormMainDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormMain
Namespace DedNet.Forms


Metodo DedFormMain.IndividuaAnagrafica

Metodo DedFormMainIndividuaAnagrafica
Mostra l'anagrafica nel tab dei recenti. Da chiamare nel non modale.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void IndividuaAnagrafica(
    DedData anagr
)
Public Sub IndividuaAnagrafica (
    anagr As DedData
)
public:
void IndividuaAnagrafica(
    DedData^ anagr
)
member IndividuaAnagrafica :
        anagr : DedData -> unit

Parametri

anagr DedData
Vedi anche

Documentazione

Classe DedFormMain
Namespace DedNet.Forms


Metodo DedFormMain.IndividuaAnagraficaModal

Metodo DedFormMainIndividuaAnagraficaModal

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void IndividuaAnagraficaModal(
    DedData anagr
)
Public Sub IndividuaAnagraficaModal (
    anagr As DedData
)
public:
void IndividuaAnagraficaModal(
    DedData^ anagr
)
member IndividuaAnagraficaModal :
        anagr : DedData -> unit

Parametri

anagr DedData
Vedi anche

Documentazione

Classe DedFormMain
Namespace DedNet.Forms


Metodo DedFormMain.IsUserChanged

Metodo DedFormMainIsUserChanged
Ritorna True se l'utente corrente con il quale si vuol mostrare il dialogo è cambiato, False altrimenti.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsUserChanged()
Public Function IsUserChanged As Boolean
public:
bool IsUserChanged()
member IsUserChanged : unit -> bool

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DedFormMain
Namespace DedNet.Forms


Metodo DedFormMain.OnVisibleChanged

Metodo DedFormMainOnVisibleChanged

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void OnVisibleChanged(
    EventArgs e
)
Protected Overrides Sub OnVisibleChanged (
    e As EventArgs
)
protected:
virtual void OnVisibleChanged(
    EventArgs^ e
) override
abstract OnVisibleChanged :
        e : EventArgs -> unit
override OnVisibleChanged :
        e : EventArgs -> unit

Parametri

e EventArgs
Vedi anche

Documentazione

Classe DedFormMain
Namespace DedNet.Forms


Metodo DedFormMain.Ripristina

Metodo DedFormMainRipristina
Se la finestra è visibile, la ripristina al FormWindowState precedente.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Ripristina()
Public Sub Ripristina
public:
void Ripristina()
member Ripristina : unit -> unit
Vedi anche

Documentazione

Classe DedFormMain
Namespace DedNet.Forms


Metodo DedFormMain.ShowFormModal

Metodo DedFormMainShowFormModal
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | ShowFormModal(IWin32Window, String, DedChooseElement, Boolean, Boolean) | Funzione per visualizzare il form in modo modale e chiedere all'utente una selezione di documenti o anagrafiche.
Metodo pubblico | ShowFormModal(IWin32Window, String, DedChooseElement, Boolean, Boolean, Boolean) | Funzione per visualizzare il form in modo modale e chiedere all'utente una selezione di documenti o anagrafiche.
Metodo pubblico | ShowFormModal(IWin32Window, String, DedDataList, DedChooseElement, Boolean, Boolean, Boolean) | Funzione per visualizzare il form in modo modale con una lista di anagrafiche già definita e chiedere all'utente una selezione di documenti o anagrafiche.
Torna su
Vedi anche

Documentazione

Classe DedFormMain
Namespace DedNet.Forms


Metodo DedFormMain.ShowFormModal(IWin32Window, String, DedChooseElement, Boolean, Boolean)

Metodo DedFormMainShowFormModal(IWin32Window, String, DedChooseElement, Boolean, Boolean)
Funzione per visualizzare il form in modo modale e chiedere all'utente una selezione di documenti o anagrafiche.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DialogResult ShowFormModal(
    IWin32Window Parent,
    string userMessage,
    DedChooseElement elementToSelect,
    bool moreThanOne,
    bool onlyLavAnagr
)
Public Function ShowFormModal (
    Parent As IWin32Window,
    userMessage As String,
    elementToSelect As DedChooseElement,
    moreThanOne As Boolean,
    onlyLavAnagr As Boolean
) As DialogResult
public:
DialogResult ShowFormModal(
    IWin32Window^ Parent,
    String^ userMessage,
    DedChooseElement elementToSelect,
    bool moreThanOne,
    bool onlyLavAnagr
)
member ShowFormModal :
        Parent : IWin32Window *
        userMessage : string *
        elementToSelect : DedChooseElement *
        moreThanOne : bool *
        onlyLavAnagr : bool -> DialogResult

Parametri

Parent IWin32Window
userMessage String
Messaggio da mostrare
elementToSelect DedChooseElement
Tipo di elementi da selezionare
moreThanOne Boolean
onlyLavAnagr Boolean

Valore di ritorno

DialogResult
Il risultato del form modale.
Vedi anche

Documentazione

Classe DedFormMain
Overload di ShowFormModal
Namespace DedNet.Forms


Metodo DedFormMain.ShowFormModal(IWin32Window, String, DedChooseElement, Boolean, Boolean, Boolean)

Metodo DedFormMainShowFormModal(IWin32Window, String, DedChooseElement, Boolean, Boolean, Boolean)
Funzione per visualizzare il form in modo modale e chiedere all'utente una selezione di documenti o anagrafiche.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DialogResult ShowFormModal(
    IWin32Window Parent,
    string userMessage,
    DedChooseElement elementToSelect,
    bool moreThanOne,
    bool onlyLavAnagr,
    bool onlySubTypes
)
Public Function ShowFormModal (
    Parent As IWin32Window,
    userMessage As String,
    elementToSelect As DedChooseElement,
    moreThanOne As Boolean,
    onlyLavAnagr As Boolean,
    onlySubTypes As Boolean
) As DialogResult
public:
DialogResult ShowFormModal(
    IWin32Window^ Parent,
    String^ userMessage,
    DedChooseElement elementToSelect,
    bool moreThanOne,
    bool onlyLavAnagr,
    bool onlySubTypes
)
member ShowFormModal :
        Parent : IWin32Window *
        userMessage : string *
        elementToSelect : DedChooseElement *
        moreThanOne : bool *
        onlyLavAnagr : bool *
        onlySubTypes : bool -> DialogResult

Parametri

Parent IWin32Window
userMessage String
Messaggio da mostrare
elementToSelect DedChooseElement
Tipo di elementi da selezionare
moreThanOne Boolean
onlyLavAnagr Boolean
onlySubTypes Boolean

Valore di ritorno

DialogResult
Il risultato del form modale.
Vedi anche

Documentazione

Classe DedFormMain
Overload di ShowFormModal
Namespace DedNet.Forms


Metodo DedFormMain.ShowFormModal(IWin32Window, String, DedDataList, DedChooseElement, Boolean, Boolean, Boolean)

Metodo DedFormMainShowFormModal(IWin32Window, String, DedDataList, DedChooseElement, Boolean, Boolean, Boolean)
Funzione per visualizzare il form in modo modale con una lista di anagrafiche già definita e chiedere all'utente una selezione di documenti o anagrafiche.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DialogResult ShowFormModal(
    IWin32Window Parent,
    string userMessage,
    DedDataList dataList,
    DedChooseElement elementToSelect,
    bool moreThanOne,
    bool onlyLavAnagr,
    bool onlySubTypes
)
Public Function ShowFormModal (
    Parent As IWin32Window,
    userMessage As String,
    dataList As DedDataList,
    elementToSelect As DedChooseElement,
    moreThanOne As Boolean,
    onlyLavAnagr As Boolean,
    onlySubTypes As Boolean
) As DialogResult
public:
DialogResult ShowFormModal(
    IWin32Window^ Parent,
    String^ userMessage,
    DedDataList^ dataList,
    DedChooseElement elementToSelect,
    bool moreThanOne,
    bool onlyLavAnagr,
    bool onlySubTypes
)
member ShowFormModal :
        Parent : IWin32Window *
        userMessage : string *
        dataList : DedDataList *
        elementToSelect : DedChooseElement *
        moreThanOne : bool *
        onlyLavAnagr : bool *
        onlySubTypes : bool -> DialogResult

Parametri

Parent IWin32Window
userMessage String
Messaggio da mostrare
dataList DedDataList
Lista di anagrafiche
elementToSelect DedChooseElement
Tipo di elementi da selezionare
moreThanOne Boolean
Indica se deve essere selezionato più di un elemento
onlyLavAnagr Boolean
Indica se devono essere selezionate solo anagrafiche in lavorazione
onlySubTypes Boolean
Indica se devono essere selezionate solo famiglie foglie

Valore di ritorno

DialogResult
Il risultato del form modale.
Vedi anche

Documentazione

Classe DedFormMain
Overload di ShowFormModal
Namespace DedNet.Forms


Metodo DedFormMain.ShowFormModeless

Metodo DedFormMainShowFormModeless
Funzione per visualizzare il form in modo non modale.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ShowFormModeless(
    IWin32Window Parent
)
Public Sub ShowFormModeless (
    Parent As IWin32Window
)
public:
void ShowFormModeless(
    IWin32Window^ Parent
)
member ShowFormModeless :
        Parent : IWin32Window -> unit

Parametri

Parent IWin32Window
Specifica la finestra padre oppure null.
Vedi anche

Documentazione

Classe DedFormMain
Namespace DedNet.Forms


Eventi di DedFormMain

Il tipo DedFormMain espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormMain
Namespace DedNet.Forms


Campi di DedFormMain

Il tipo DedFormMain espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormMain
Namespace DedNet.Forms


Struttura DedFormMain.SelectInfo

Struttura DedFormMainSelectInfo
Struttura contenente le informazioni sulla selezione corrente e precedente.
Gerarchia di ereditarietà
SystemObject
SystemValueType
DedNet.FormsDedFormMainSelectInfo

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public struct SelectInfo
Public Structure SelectInfo
public value class SelectInfo
[<SealedAttribute>]
type SelectInfo =
    struct
        inherit ValueType
    end

Il tipo DedFormMainSelectInfo espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | AllDataCommonAttachDocuments | Tutti i documenti allegati delle anagrafiche correntemente selezionate.
Campo pubblico | AllDataCommonPrimaryDocuments | Tutti i documenti primary delle anagrafiche correntemente selezionate.
Campo pubblico | CurSelAttachDocs | Documenti correntemente selezionati nei file allegati.
Campo pubblico | CurSelAttachDocsConfig | Configurazioni dei documenti correntemente selezionati nei file allegati.
Campo pubblico | CurSelData | Anagrafiche correntemente selezionate.
Campo pubblico | CurSelPrimaryDocsConfig | Configurazioni dei documenti correntemente selezionati nei file primari.
Campo pubblico | CurSelPrimayDocs | Documenti correntemente selezionati nei file primari.
Campo pubblico | CurSelTypes | Famiglie attualmente selezionate.
Campo pubblico | PrecSelData | Anagrafiche selezionate precedentemente.
Campo pubblico | PrecSelNodes | Lista di nodi della penultima selezione (usata per aggiornare le anagrafiche in caso di cambio di selezione di anagrafica dopo che è stata modificata senza averla salvata).
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Campi di SelectInfo

Il tipo DedFormMainSelectInfo espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | AllDataCommonAttachDocuments | Tutti i documenti allegati delle anagrafiche correntemente selezionate.
Campo pubblico | AllDataCommonPrimaryDocuments | Tutti i documenti primary delle anagrafiche correntemente selezionate.
Campo pubblico | CurSelAttachDocs | Documenti correntemente selezionati nei file allegati.
Campo pubblico | CurSelAttachDocsConfig | Configurazioni dei documenti correntemente selezionati nei file allegati.
Campo pubblico | CurSelData | Anagrafiche correntemente selezionate.
Campo pubblico | CurSelPrimaryDocsConfig | Configurazioni dei documenti correntemente selezionati nei file primari.
Campo pubblico | CurSelPrimayDocs | Documenti correntemente selezionati nei file primari.
Campo pubblico | CurSelTypes | Famiglie attualmente selezionate.
Campo pubblico | PrecSelData | Anagrafiche selezionate precedentemente.
Campo pubblico | PrecSelNodes | Lista di nodi della penultima selezione (usata per aggiornare le anagrafiche in caso di cambio di selezione di anagrafica dopo che è stata modificata senza averla salvata).
Torna su
Vedi anche

Documentazione

Struttura DedFormMainSelectInfo
Namespace DedNet.Forms


Campo DedFormMain.SelectInfo.AllDataCommonAttachDocuments

Campo DedFormMainSelectInfoAllDataCommonAttachDocuments
Tutti i documenti allegati delle anagrafiche correntemente selezionate.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocList AllDataCommonAttachDocuments
Public AllDataCommonAttachDocuments As DedDocList
public:
DedDocList^ AllDataCommonAttachDocuments
val mutable AllDataCommonAttachDocuments: DedDocList

Valore del campo

DedDocList
Vedi anche

Documentazione

Struttura DedFormMainSelectInfo
Namespace DedNet.Forms


Campo DedFormMain.SelectInfo.AllDataCommonPrimaryDocuments

Campo DedFormMainSelectInfoAllDataCommonPrimaryDocuments
Tutti i documenti primary delle anagrafiche correntemente selezionate.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocList AllDataCommonPrimaryDocuments
Public AllDataCommonPrimaryDocuments As DedDocList
public:
DedDocList^ AllDataCommonPrimaryDocuments
val mutable AllDataCommonPrimaryDocuments: DedDocList

Valore del campo

DedDocList
Vedi anche

Documentazione

Struttura DedFormMainSelectInfo
Namespace DedNet.Forms


Campo DedFormMain.SelectInfo.CurSelAttachDocs

Campo DedFormMainSelectInfoCurSelAttachDocs
Documenti correntemente selezionati nei file allegati.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocList CurSelAttachDocs
Public CurSelAttachDocs As DedDocList
public:
DedDocList^ CurSelAttachDocs
val mutable CurSelAttachDocs: DedDocList

Valore del campo

DedDocList
Vedi anche

Documentazione

Struttura DedFormMainSelectInfo
Namespace DedNet.Forms


Campo DedFormMain.SelectInfo.CurSelAttachDocsConfig

Campo DedFormMainSelectInfoCurSelAttachDocsConfig
Configurazioni dei documenti correntemente selezionati nei file allegati.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<DedDoc, List<string>> CurSelAttachDocsConfig
Public CurSelAttachDocsConfig As Dictionary(Of DedDoc, List(Of String))
public:
Dictionary<DedDoc^, List<String^>^>^ CurSelAttachDocsConfig
val mutable CurSelAttachDocsConfig: Dictionary<DedDoc, List<string>>

Valore del campo

Dictionary DedDoc, List String
Vedi anche

Documentazione

Struttura DedFormMainSelectInfo
Namespace DedNet.Forms


Campo DedFormMain.SelectInfo.CurSelData

Campo DedFormMainSelectInfoCurSelData
Anagrafiche correntemente selezionate.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataList CurSelData
Public CurSelData As DedDataList
public:
DedDataList^ CurSelData
val mutable CurSelData: DedDataList

Valore del campo

DedDataList
Vedi anche

Documentazione

Struttura DedFormMainSelectInfo
Namespace DedNet.Forms


Campo DedFormMain.SelectInfo.CurSelPrimaryDocsConfig

Campo DedFormMainSelectInfoCurSelPrimaryDocsConfig
Configurazioni dei documenti correntemente selezionati nei file primari.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<DedDoc, List<string>> CurSelPrimaryDocsConfig
Public CurSelPrimaryDocsConfig As Dictionary(Of DedDoc, List(Of String))
public:
Dictionary<DedDoc^, List<String^>^>^ CurSelPrimaryDocsConfig
val mutable CurSelPrimaryDocsConfig: Dictionary<DedDoc, List<string>>

Valore del campo

Dictionary DedDoc, List String
Vedi anche

Documentazione

Struttura DedFormMainSelectInfo
Namespace DedNet.Forms


Campo DedFormMain.SelectInfo.CurSelPrimayDocs

Campo DedFormMainSelectInfoCurSelPrimayDocs
Documenti correntemente selezionati nei file primari.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocList CurSelPrimayDocs
Public CurSelPrimayDocs As DedDocList
public:
DedDocList^ CurSelPrimayDocs
val mutable CurSelPrimayDocs: DedDocList

Valore del campo

DedDocList
Vedi anche

Documentazione

Struttura DedFormMainSelectInfo
Namespace DedNet.Forms


Campo DedFormMain.SelectInfo.CurSelTypes

Campo DedFormMainSelectInfoCurSelTypes
Famiglie attualmente selezionate.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeList CurSelTypes
Public CurSelTypes As DedTypeList
public:
DedTypeList^ CurSelTypes
val mutable CurSelTypes: DedTypeList

Valore del campo

DedTypeList
Vedi anche

Documentazione

Struttura DedFormMainSelectInfo
Namespace DedNet.Forms


Campo DedFormMain.SelectInfo.PrecSelData

Campo DedFormMainSelectInfoPrecSelData
Anagrafiche selezionate precedentemente.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataList PrecSelData
Public PrecSelData As DedDataList
public:
DedDataList^ PrecSelData
val mutable PrecSelData: DedDataList

Valore del campo

DedDataList
Vedi anche

Documentazione

Struttura DedFormMainSelectInfo
Namespace DedNet.Forms


Campo DedFormMain.SelectInfo.PrecSelNodes

Campo DedFormMainSelectInfoPrecSelNodes
Lista di nodi della penultima selezione (usata per aggiornare le anagrafiche in caso di cambio di selezione di anagrafica dopo che è stata modificata senza averla salvata).

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<int> PrecSelNodes
Public PrecSelNodes As List(Of Integer)
public:
List<int>^ PrecSelNodes
val mutable PrecSelNodes: List<int>

Valore del campo

List Int32
Vedi anche

Documentazione

Struttura DedFormMainSelectInfo
Namespace DedNet.Forms


Classe DedFormManageList
From per la gestione delle tipologie di lista
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormManageList

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormManageList : BaseForm
Public Class DedFormManageList
    Inherits BaseForm
public ref class DedFormManageList : public BaseForm
type DedFormManageList =
    class
        inherit BaseForm
    end

Il tipo DedFormManageList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormManageList | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormManageList
Costruttore

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormManageList(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedFormManageList(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedFormManageList

Parametri

app DedNetApplication
Applicazione
Vedi anche

Documentazione

Classe DedFormManageList
Namespace DedNet.Forms


Proprietà di DedFormManageList

Il tipo DedFormManageList espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormManageList
Namespace DedNet.Forms


Metodi di DedFormManageList

Il tipo DedFormManageList espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormManageList
Namespace DedNet.Forms


Metodo DedFormManageList.Dispose

Metodo DedFormManageListDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormManageList
Namespace DedNet.Forms


Eventi di DedFormManageList

Il tipo DedFormManageList espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormManageList
Namespace DedNet.Forms


Campi di DedFormManageList

Il tipo DedFormManageList espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormManageList
Namespace DedNet.Forms


Classe DedFormManageRoot
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormManageRoot

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormManageRoot : BaseForm
Public Class DedFormManageRoot
    Inherits BaseForm
public ref class DedFormManageRoot : public BaseForm
type DedFormManageRoot =
    class
        inherit BaseForm
    end

Il tipo DedFormManageRoot espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormManageRoot | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormManageRoot
Costruttore unico.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormManageRoot(
    DedNetApplication _app
)
Public Sub New (
    _app As DedNetApplication
)
public:
DedFormManageRoot(
    DedNetApplication^ _app
)
new :
        _app : DedNetApplication -> DedFormManageRoot

Parametri

_app DedNetApplication
Oggetto Application
Vedi anche

Documentazione

Classe DedFormManageRoot
Namespace DedNet.Forms


Proprietà di DedFormManageRoot

Il tipo DedFormManageRoot espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormManageRoot
Namespace DedNet.Forms


Metodi di DedFormManageRoot

Il tipo DedFormManageRoot espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormManageRoot
Namespace DedNet.Forms


Metodo DedFormManageRoot.Dispose

Metodo DedFormManageRootDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormManageRoot
Namespace DedNet.Forms


Eventi di DedFormManageRoot

Il tipo DedFormManageRoot espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormManageRoot
Namespace DedNet.Forms


Campi di DedFormManageRoot

Il tipo DedFormManageRoot espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormManageRoot
Namespace DedNet.Forms


Classe DedFormMappingRoot
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormMappingRoot

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormMappingRoot : BaseForm
Public Class DedFormMappingRoot
    Inherits BaseForm
public ref class DedFormMappingRoot : public BaseForm
type DedFormMappingRoot =
    class
        inherit BaseForm
    end

Il tipo DedFormMappingRoot espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormMappingRoot | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormMappingRoot
Costruttore unico.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormMappingRoot(
    DedNetApplication app,
    List<DedFormMappingRootMappingRootObject> list
)
Public Sub New (
    app As DedNetApplication,
    list As List(Of DedFormMappingRootMappingRootObject)
)
public:
DedFormMappingRoot(
    DedNetApplication^ app,
    List<DedFormMappingRootMappingRootObject^>^ list
)
new :
        app : DedNetApplication *
        list : List<DedFormMappingRootMappingRootObject> -> DedFormMappingRoot

Parametri

app DedNetApplication
Apllicazione DedNet.
list List DedFormMappingRootMappingRootObject
Lista di oggetti per la mappatura delle root.
Vedi anche

Documentazione

Classe DedFormMappingRoot
Namespace DedNet.Forms


Proprietà di DedFormMappingRoot

Il tipo DedFormMappingRoot espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormMappingRoot
Namespace DedNet.Forms


Metodi di DedFormMappingRoot

Il tipo DedFormMappingRoot espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormMappingRoot
Namespace DedNet.Forms


Metodo DedFormMappingRoot.Dispose

Metodo DedFormMappingRootDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormMappingRoot
Namespace DedNet.Forms


Eventi di DedFormMappingRoot

Il tipo DedFormMappingRoot espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormMappingRoot
Namespace DedNet.Forms


Campi di DedFormMappingRoot

Il tipo DedFormMappingRoot espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormMappingRoot
Namespace DedNet.Forms


Classe DedFormMappingRoot.MappingRootObject

Classe DedFormMappingRootMappingRootObject
Classe di servzio.
Gerarchia di ereditarietà
SystemObject
DedNet.FormsDedFormMappingRootMappingRootObject

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class MappingRootObject
Public Class MappingRootObject
public ref class MappingRootObject
type MappingRootObject = class end

Il tipo DedFormMappingRootMappingRootObject espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormMappingRootMappingRootObject(String, String) |
Metodo pubblico | DedFormMappingRootMappingRootObject(String, String, String) |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | FolderName |
Proprietà pubblica | OriginalPath |
Proprietà pubblica | RootName |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormMappingRoot.MappingRootObject

Costruttore DedFormMappingRootMappingRootObject
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | DedFormMappingRootMappingRootObject(String, String) |
Metodo pubblico | DedFormMappingRootMappingRootObject(String, String, String) |
Torna su
Vedi anche

Documentazione

Classe DedFormMappingRootMappingRootObject
Namespace DedNet.Forms


Costruttore DedFormMappingRoot.MappingRootObject(String, String)

Costruttore DedFormMappingRootMappingRootObject(String, String)

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public MappingRootObject(
    string originalPath,
    string folderName
)
Public Sub New (
    originalPath As String,
    folderName As String
)
public:
MappingRootObject(
    String^ originalPath,
    String^ folderName
)
new :
        originalPath : string *
        folderName : string -> MappingRootObject

Parametri

originalPath String
folderName String
Vedi anche

Documentazione

Classe DedFormMappingRootMappingRootObject
Overload di DedFormMappingRootMappingRootObject
Namespace DedNet.Forms


Costruttore DedFormMappingRoot.MappingRootObject(String, String, String)

Costruttore DedFormMappingRootMappingRootObject(String, String, String)

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public MappingRootObject(
    string originalPath,
    string folderName,
    string rootName
)
Public Sub New (
    originalPath As String,
    folderName As String,
    rootName As String
)
public:
MappingRootObject(
    String^ originalPath,
    String^ folderName,
    String^ rootName
)
new :
        originalPath : string *
        folderName : string *
        rootName : string -> MappingRootObject

Parametri

originalPath String
folderName String
rootName String
Vedi anche

Documentazione

Classe DedFormMappingRootMappingRootObject
Overload di DedFormMappingRootMappingRootObject
Namespace DedNet.Forms


Proprietà di MappingRootObject

Il tipo DedFormMappingRootMappingRootObject espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | FolderName |
Proprietà pubblica | OriginalPath |
Proprietà pubblica | RootName |
Torna su
Vedi anche

Documentazione

Classe DedFormMappingRootMappingRootObject
Namespace DedNet.Forms


Proprietà DedFormMappingRoot.MappingRootObject.FolderName

Proprietà DedFormMappingRootMappingRootObjectFolderName

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string FolderName { get; }
Public ReadOnly Property FolderName As String
    Get
public:
property String^ FolderName {
    String^ get ();
}
member FolderName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedFormMappingRootMappingRootObject
Namespace DedNet.Forms


Proprietà DedFormMappingRoot.MappingRootObject.OriginalPath

Proprietà DedFormMappingRootMappingRootObjectOriginalPath

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string OriginalPath { get; set; }
Public Property OriginalPath As String
    Get
    Set
public:
property String^ OriginalPath {
    String^ get ();
    void set (String^ value);
}
member OriginalPath : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedFormMappingRootMappingRootObject
Namespace DedNet.Forms


Proprietà DedFormMappingRoot.MappingRootObject.RootName

Proprietà DedFormMappingRootMappingRootObjectRootName

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string RootName { get; set; }
Public Property RootName As String
    Get
    Set
public:
property String^ RootName {
    String^ get ();
    void set (String^ value);
}
member RootName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedFormMappingRootMappingRootObject
Namespace DedNet.Forms


Classe DedFormMovedEditor
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormMovedEditor

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormMovedEditor : BaseForm
Public Class DedFormMovedEditor
    Inherits BaseForm
public ref class DedFormMovedEditor : public BaseForm
type DedFormMovedEditor =
    class
        inherit BaseForm
    end

Il tipo DedFormMovedEditor espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormMovedEditor | Costruttore che visualizza i file .moved del documento specificato.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà pubblica | CanUserDelete | Indica se l'utente può impostare i record da eliminare.
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo pubblico | GetMovedToBeDelete | Ritorna la lista dei moved che devono essere cancellati dal database.
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormMovedEditor
Costruttore che visualizza i file .moved del documento specificato.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormMovedEditor(
    DedNetApplication app,
    DedDoc doc
)
Public Sub New (
    app As DedNetApplication,
    doc As DedDoc
)
public:
DedFormMovedEditor(
    DedNetApplication^ app,
    DedDoc^ doc
)
new :
        app : DedNetApplication *
        doc : DedDoc -> DedFormMovedEditor

Parametri

app DedNetApplication
Applicazione DedNet.
doc DedDoc
Documento da elaborare.
Vedi anche

Documentazione

Classe DedFormMovedEditor
Namespace DedNet.Forms


Proprietà di DedFormMovedEditor

Il tipo DedFormMovedEditor espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà pubblica | CanUserDelete | Indica se l'utente può impostare i record da eliminare.
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormMovedEditor
Namespace DedNet.Forms


Proprietà DedFormMovedEditor.CanUserDelete

Proprietà DedFormMovedEditorCanUserDelete
Indica se l'utente può impostare i record da eliminare.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CanUserDelete { get; }
Public ReadOnly Property CanUserDelete As Boolean
    Get
public:
property bool CanUserDelete {
    bool get ();
}
member CanUserDelete : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormMovedEditor
Namespace DedNet.Forms


Metodi di DedFormMovedEditor

Il tipo DedFormMovedEditor espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo pubblico | GetMovedToBeDelete | Ritorna la lista dei moved che devono essere cancellati dal database.
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormMovedEditor
Namespace DedNet.Forms


Metodo DedFormMovedEditor.Dispose

Metodo DedFormMovedEditorDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormMovedEditor
Namespace DedNet.Forms


Metodo DedFormMovedEditor.GetMovedToBeDelete

Metodo DedFormMovedEditorGetMovedToBeDelete
Ritorna la lista dei moved che devono essere cancellati dal database.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<DedFormMovedEditorMovedWrapper> GetMovedToBeDelete()
Public Function GetMovedToBeDelete As List(Of DedFormMovedEditorMovedWrapper)
public:
List<DedFormMovedEditorMovedWrapper^>^ GetMovedToBeDelete()
member GetMovedToBeDelete : unit -> List<DedFormMovedEditorMovedWrapper>

Valore di ritorno

List DedFormMovedEditorMovedWrapper
Vedi anche

Documentazione

Classe DedFormMovedEditor
Namespace DedNet.Forms


Eventi di DedFormMovedEditor

Il tipo DedFormMovedEditor espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormMovedEditor
Namespace DedNet.Forms


Campi di DedFormMovedEditor

Il tipo DedFormMovedEditor espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormMovedEditor
Namespace DedNet.Forms


Classe DedFormMovedEditor.MovedWrapper

Classe DedFormMovedEditorMovedWrapper
Oggetto DedEco che viene visualizzato a schermo.
Gerarchia di ereditarietà
SystemObject
DedNet.FormsDedFormMovedEditorMovedWrapper

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class MovedWrapper
Public Class MovedWrapper
public ref class MovedWrapper
type MovedWrapper = class end

Il tipo DedFormMovedEditorMovedWrapper espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | MovDate | Data in cui è avvenuta l'operazione di spostamento.
Proprietà pubblica | MovFrom | Nome originale del file.
Proprietà pubblica | MovTo | Nome attuale del file.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | GetMovDate | Data in cui è avvenuto lo spostamento.
Torna su
Campi
 | Nome | Descrizione
Campo pubblico | MovFromExt | Estensione originale del file.
Campo pubblico | MovFromPath | Cartella originale del file.
Campo pubblico | MovToExt | Estensione attuale del file.
Campo pubblico | MovToPath | Cartella attuale del file.
Campo pubblico | MovUser | Utente che ha causato lo spostamento.
Campo pubblico | ToBeDelete | Indica se il record deve essere cancellato nel database o meno.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Proprietà di MovedWrapper

Il tipo DedFormMovedEditorMovedWrapper espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | MovDate | Data in cui è avvenuta l'operazione di spostamento.
Proprietà pubblica | MovFrom | Nome originale del file.
Proprietà pubblica | MovTo | Nome attuale del file.
Torna su
Vedi anche

Documentazione

Classe DedFormMovedEditorMovedWrapper
Namespace DedNet.Forms


Proprietà DedFormMovedEditor.MovedWrapper.MovDate

Proprietà DedFormMovedEditorMovedWrapperMovDate
Data in cui è avvenuta l'operazione di spostamento.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string MovDate { get; }
Public ReadOnly Property MovDate As String
    Get
public:
property String^ MovDate {
    String^ get ();
}
member MovDate : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedFormMovedEditorMovedWrapper
Namespace DedNet.Forms


Proprietà DedFormMovedEditor.MovedWrapper.MovFrom

Proprietà DedFormMovedEditorMovedWrapperMovFrom
Nome originale del file.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string MovFrom { get; }
Public ReadOnly Property MovFrom As String
    Get
public:
property String^ MovFrom {
    String^ get ();
}
member MovFrom : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedFormMovedEditorMovedWrapper
Namespace DedNet.Forms


Proprietà DedFormMovedEditor.MovedWrapper.MovTo

Proprietà DedFormMovedEditorMovedWrapperMovTo
Nome attuale del file.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string MovTo { get; }
Public ReadOnly Property MovTo As String
    Get
public:
property String^ MovTo {
    String^ get ();
}
member MovTo : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedFormMovedEditorMovedWrapper
Namespace DedNet.Forms


Metodi di MovedWrapper

Il tipo DedFormMovedEditorMovedWrapper espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | GetMovDate | Data in cui è avvenuto lo spostamento.
Torna su
Vedi anche

Documentazione

Classe DedFormMovedEditorMovedWrapper
Namespace DedNet.Forms


Metodo DedFormMovedEditor.MovedWrapper.GetMovDate

Metodo DedFormMovedEditorMovedWrapperGetMovDate
Data in cui è avvenuto lo spostamento.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DateTime GetMovDate()
Public Function GetMovDate As DateTime
public:
DateTime GetMovDate()
member GetMovDate : unit -> DateTime

Valore di ritorno

DateTime
Vedi anche

Documentazione

Classe DedFormMovedEditorMovedWrapper
Namespace DedNet.Forms


Campi di MovedWrapper

Il tipo DedFormMovedEditorMovedWrapper espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | MovFromExt | Estensione originale del file.
Campo pubblico | MovFromPath | Cartella originale del file.
Campo pubblico | MovToExt | Estensione attuale del file.
Campo pubblico | MovToPath | Cartella attuale del file.
Campo pubblico | MovUser | Utente che ha causato lo spostamento.
Campo pubblico | ToBeDelete | Indica se il record deve essere cancellato nel database o meno.
Torna su
Vedi anche

Documentazione

Classe DedFormMovedEditorMovedWrapper
Namespace DedNet.Forms


Campo DedFormMovedEditor.MovedWrapper.MovFromExt

Campo DedFormMovedEditorMovedWrapperMovFromExt
Estensione originale del file.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public readonly string MovFromExt
Public ReadOnly MovFromExt As String
public:
initonly String^ MovFromExt
val MovFromExt: string

Valore del campo

String
Vedi anche

Documentazione

Classe DedFormMovedEditorMovedWrapper
Namespace DedNet.Forms


Campo DedFormMovedEditor.MovedWrapper.MovFromPath

Campo DedFormMovedEditorMovedWrapperMovFromPath
Cartella originale del file.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public readonly string MovFromPath
Public ReadOnly MovFromPath As String
public:
initonly String^ MovFromPath
val MovFromPath: string

Valore del campo

String
Vedi anche

Documentazione

Classe DedFormMovedEditorMovedWrapper
Namespace DedNet.Forms


Campo DedFormMovedEditor.MovedWrapper.MovToExt

Campo DedFormMovedEditorMovedWrapperMovToExt
Estensione attuale del file.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public readonly string MovToExt
Public ReadOnly MovToExt As String
public:
initonly String^ MovToExt
val MovToExt: string

Valore del campo

String
Vedi anche

Documentazione

Classe DedFormMovedEditorMovedWrapper
Namespace DedNet.Forms


Campo DedFormMovedEditor.MovedWrapper.MovToPath

Campo DedFormMovedEditorMovedWrapperMovToPath
Cartella attuale del file.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public readonly string MovToPath
Public ReadOnly MovToPath As String
public:
initonly String^ MovToPath
val MovToPath: string

Valore del campo

String
Vedi anche

Documentazione

Classe DedFormMovedEditorMovedWrapper
Namespace DedNet.Forms


Campo DedFormMovedEditor.MovedWrapper.MovUser

Campo DedFormMovedEditorMovedWrapperMovUser
Utente che ha causato lo spostamento.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public readonly string MovUser
Public ReadOnly MovUser As String
public:
initonly String^ MovUser
val MovUser: string

Valore del campo

String
Vedi anche

Documentazione

Classe DedFormMovedEditorMovedWrapper
Namespace DedNet.Forms


Campo DedFormMovedEditor.MovedWrapper.ToBeDelete

Campo DedFormMovedEditorMovedWrapperToBeDelete
Indica se il record deve essere cancellato nel database o meno.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ToBeDelete
Public ToBeDelete As Boolean
public:
bool ToBeDelete
val mutable ToBeDelete: bool

Valore del campo

Boolean
Vedi anche

Documentazione

Classe DedFormMovedEditorMovedWrapper
Namespace DedNet.Forms


Classe DedFormPrintExportSetting
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormPrintExportSetting

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormPrintExportSetting : BaseForm
Public Class DedFormPrintExportSetting
    Inherits BaseForm
public ref class DedFormPrintExportSetting : public BaseForm
type DedFormPrintExportSetting =
    class
        inherit BaseForm
    end

Il tipo DedFormPrintExportSetting espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormPrintExportSetting | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà pubblica | CkConfigDefault |
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HideCkConfigDefault |
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | PersFunc |
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Proprietà pubblica | UserSelection |
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormPrintExportSetting
Costruttore

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormPrintExportSetting(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedFormPrintExportSetting(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedFormPrintExportSetting

Parametri

app DedNetApplication
Vedi anche

Documentazione

Classe DedFormPrintExportSetting
Namespace DedNet.Forms


Proprietà di DedFormPrintExportSetting

Il tipo DedFormPrintExportSetting espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà pubblica | CkConfigDefault |
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HideCkConfigDefault |
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | PersFunc |
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Proprietà pubblica | UserSelection |
Torna su
Vedi anche

Documentazione

Classe DedFormPrintExportSetting
Namespace DedNet.Forms


Proprietà DedFormPrintExportSetting.CkConfigDefault

Proprietà DedFormPrintExportSettingCkConfigDefault

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CkConfigDefault { get; set; }
Public Property CkConfigDefault As Boolean
    Get
    Set
public:
property bool CkConfigDefault {
    bool get ();
    void set (bool value);
}
member CkConfigDefault : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormPrintExportSetting
Namespace DedNet.Forms


Proprietà DedFormPrintExportSetting.HideCkConfigDefault

Proprietà DedFormPrintExportSettingHideCkConfigDefault

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HideCkConfigDefault { get; set; }
Public Property HideCkConfigDefault As Boolean
    Get
    Set
public:
property bool HideCkConfigDefault {
    bool get ();
    void set (bool value);
}
member HideCkConfigDefault : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormPrintExportSetting
Namespace DedNet.Forms


Proprietà DedFormPrintExportSetting.PersFunc

Proprietà DedFormPrintExportSettingPersFunc

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> PersFunc { get; }
Public ReadOnly Property PersFunc As List(Of String)
    Get
public:
property List<String^>^ PersFunc {
    List<String^>^ get ();
}
member PersFunc : List<string> with get

Valore della proprietà

List String
Vedi anche

Documentazione

Classe DedFormPrintExportSetting
Namespace DedNet.Forms


Proprietà DedFormPrintExportSetting.UserSelection

Proprietà DedFormPrintExportSettingUserSelection

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormPrintExportSettingPrintExportSetting UserSelection { get; }
Public ReadOnly Property UserSelection As DedFormPrintExportSettingPrintExportSetting
    Get
public:
property DedFormPrintExportSettingPrintExportSetting^ UserSelection {
    DedFormPrintExportSettingPrintExportSetting^ get ();
}
member UserSelection : DedFormPrintExportSettingPrintExportSetting with get

Valore della proprietà

DedFormPrintExportSettingPrintExportSetting
Vedi anche

Documentazione

Classe DedFormPrintExportSetting
Namespace DedNet.Forms


Metodi di DedFormPrintExportSetting

Il tipo DedFormPrintExportSetting espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormPrintExportSetting
Namespace DedNet.Forms


Metodo DedFormPrintExportSetting.Dispose

Metodo DedFormPrintExportSettingDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormPrintExportSetting
Namespace DedNet.Forms


Eventi di DedFormPrintExportSetting

Il tipo DedFormPrintExportSetting espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormPrintExportSetting
Namespace DedNet.Forms


Campi di DedFormPrintExportSetting

Il tipo DedFormPrintExportSetting espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormPrintExportSetting
Namespace DedNet.Forms


Classe DedFormPrintExportSetting.PrintExportSetting

Classe DedFormPrintExportSettingPrintExportSetting
Classe per gestire la scelta dell'utente.
Gerarchia di ereditarietà
SystemObject
DedNet.FormsDedFormPrintExportSettingPrintExportSetting

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class PrintExportSetting
Public Class PrintExportSetting
public ref class PrintExportSetting
type PrintExportSetting = class end

Il tipo DedFormPrintExportSettingPrintExportSetting espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormPrintExportSettingPrintExportSetting | Costruttore unico
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | IsDefaultExport |
Proprietà pubblica | IsTemplateUsing |
Proprietà pubblica | PersFunction |
Proprietà pubblica | Res |
Proprietà pubblica | TemplatePath |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormPrintExportSetting.PrintExportSetting

Costruttore DedFormPrintExportSettingPrintExportSetting
Costruttore unico

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public PrintExportSetting()
Public Sub New
public:
PrintExportSetting()
new : unit -> PrintExportSetting
Vedi anche

Documentazione

Classe DedFormPrintExportSettingPrintExportSetting
Namespace DedNet.Forms


Proprietà di PrintExportSetting

Il tipo DedFormPrintExportSettingPrintExportSetting espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | IsDefaultExport |
Proprietà pubblica | IsTemplateUsing |
Proprietà pubblica | PersFunction |
Proprietà pubblica | Res |
Proprietà pubblica | TemplatePath |
Torna su
Vedi anche

Documentazione

Classe DedFormPrintExportSettingPrintExportSetting
Namespace DedNet.Forms


Proprietà DedFormPrintExportSetting.PrintExportSetting.IsDefaultExport

Proprietà DedFormPrintExportSettingPrintExportSettingIsDefaultExport

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsDefaultExport { get; }
Public ReadOnly Property IsDefaultExport As Boolean
    Get
public:
property bool IsDefaultExport {
    bool get ();
}
member IsDefaultExport : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormPrintExportSettingPrintExportSetting
Namespace DedNet.Forms


Proprietà DedFormPrintExportSetting.PrintExportSetting.IsTemplateUsing

Proprietà DedFormPrintExportSettingPrintExportSettingIsTemplateUsing

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsTemplateUsing { get; }
Public ReadOnly Property IsTemplateUsing As Boolean
    Get
public:
property bool IsTemplateUsing {
    bool get ();
}
member IsTemplateUsing : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormPrintExportSettingPrintExportSetting
Namespace DedNet.Forms


Proprietà DedFormPrintExportSetting.PrintExportSetting.PersFunction

Proprietà DedFormPrintExportSettingPrintExportSettingPersFunction

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string PersFunction { get; }
Public ReadOnly Property PersFunction As String
    Get
public:
property String^ PersFunction {
    String^ get ();
}
member PersFunction : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedFormPrintExportSettingPrintExportSetting
Namespace DedNet.Forms


Proprietà DedFormPrintExportSetting.PrintExportSetting.Res

Proprietà DedFormPrintExportSettingPrintExportSettingRes

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DialogResult Res { get; }
Public ReadOnly Property Res As DialogResult
    Get
public:
property DialogResult Res {
    DialogResult get ();
}
member Res : DialogResult with get

Valore della proprietà

DialogResult
Vedi anche

Documentazione

Classe DedFormPrintExportSettingPrintExportSetting
Namespace DedNet.Forms


Proprietà DedFormPrintExportSetting.PrintExportSetting.TemplatePath

Proprietà DedFormPrintExportSettingPrintExportSettingTemplatePath

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string TemplatePath { get; }
Public ReadOnly Property TemplatePath As String
    Get
public:
property String^ TemplatePath {
    String^ get ();
}
member TemplatePath : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedFormPrintExportSettingPrintExportSetting
Namespace DedNet.Forms


Classe DedFormPropertiesManager
Dialogo di gestione delle variabili riguardanti le proprietà dei documenti.
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormPropertiesManager

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormPropertiesManager : BaseForm
Public Class DedFormPropertiesManager
    Inherits BaseForm
public ref class DedFormPropertiesManager : public BaseForm
type DedFormPropertiesManager =
    class
        inherit BaseForm
    end

Il tipo DedFormPropertiesManager espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormPropertiesManager | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormPropertiesManager
Costruttore unico.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormPropertiesManager(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedFormPropertiesManager(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedFormPropertiesManager

Parametri

app DedNetApplication
Vedi anche

Documentazione

Classe DedFormPropertiesManager
Namespace DedNet.Forms


Proprietà di DedFormPropertiesManager

Il tipo DedFormPropertiesManager espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormPropertiesManager
Namespace DedNet.Forms


Metodi di DedFormPropertiesManager

Il tipo DedFormPropertiesManager espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormPropertiesManager
Namespace DedNet.Forms


Metodo DedFormPropertiesManager.Dispose

Metodo DedFormPropertiesManagerDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormPropertiesManager
Namespace DedNet.Forms


Eventi di DedFormPropertiesManager

Il tipo DedFormPropertiesManager espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormPropertiesManager
Namespace DedNet.Forms


Campi di DedFormPropertiesManager

Il tipo DedFormPropertiesManager espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormPropertiesManager
Namespace DedNet.Forms


Classe DedFormPropertiesReader
Dialogo che calcola le proprietà di documento dei documenti passati in ingresso. Le proprietà vengono mostrate all'interno della griglia e, selezionandole tramite checkbox, è possibile inserirle automaticamente all'interno della variabile DOC_PROPERTIES_TO_INCLUDE.
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormPropertiesReader

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormPropertiesReader : BaseForm
Public Class DedFormPropertiesReader
    Inherits BaseForm
public ref class DedFormPropertiesReader : public BaseForm
type DedFormPropertiesReader =
    class
        inherit BaseForm
    end

Il tipo DedFormPropertiesReader espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormPropertiesReader | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | PropertiesToAdd | Ritorna la lista di proprietà da aggiungere alla variabile DOC_PROPERTIES_TO_INCLUDE.
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormPropertiesReader
Costruttore unico.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormPropertiesReader()
Public Sub New
public:
DedFormPropertiesReader()
new : unit -> DedFormPropertiesReader
Vedi anche

Documentazione

Classe DedFormPropertiesReader
Namespace DedNet.Forms


Proprietà di DedFormPropertiesReader

Il tipo DedFormPropertiesReader espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | PropertiesToAdd | Ritorna la lista di proprietà da aggiungere alla variabile DOC_PROPERTIES_TO_INCLUDE.
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormPropertiesReader
Namespace DedNet.Forms


Proprietà DedFormPropertiesReader.PropertiesToAdd

Proprietà DedFormPropertiesReaderPropertiesToAdd
Ritorna la lista di proprietà da aggiungere alla variabile DOC_PROPERTIES_TO_INCLUDE.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string[] PropertiesToAdd { get; }
Public ReadOnly Property PropertiesToAdd As String()
    Get
public:
property array<String^>^ PropertiesToAdd {
    array<String^>^ get ();
}
member PropertiesToAdd : string[] with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedFormPropertiesReader
Namespace DedNet.Forms


Metodi di DedFormPropertiesReader

Il tipo DedFormPropertiesReader espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormPropertiesReader
Namespace DedNet.Forms


Metodo DedFormPropertiesReader.Dispose

Metodo DedFormPropertiesReaderDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormPropertiesReader
Namespace DedNet.Forms


Eventi di DedFormPropertiesReader

Il tipo DedFormPropertiesReader espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormPropertiesReader
Namespace DedNet.Forms


Campi di DedFormPropertiesReader

Il tipo DedFormPropertiesReader espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormPropertiesReader
Namespace DedNet.Forms


Classe DedFormPublicationFileManager
Dialogo utilizzato per gestire la creazione dei file di pubblicazione.
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormPublicationFileManager

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormPublicationFileManager : BaseForm
Public Class DedFormPublicationFileManager
    Inherits BaseForm
public ref class DedFormPublicationFileManager : public BaseForm
type DedFormPublicationFileManager =
    class
        inherit BaseForm
    end

Il tipo DedFormPublicationFileManager espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormPublicationFileManager | Dialogo utilizzato per gestire la creazione dei file di pubblicazione.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà pubblica | ConfigurationManager | Oggetto contenenente le impostazioni di pubblicazione.
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormPublicationFileManager
Dialogo utilizzato per gestire la creazione dei file di pubblicazione.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormPublicationFileManager(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedFormPublicationFileManager(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedFormPublicationFileManager

Parametri

app DedNetApplication
Applicazione DedNet.
Vedi anche

Documentazione

Classe DedFormPublicationFileManager
Namespace DedNet.Forms


Proprietà di DedFormPublicationFileManager

Il tipo DedFormPublicationFileManager espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà pubblica | ConfigurationManager | Oggetto contenenente le impostazioni di pubblicazione.
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormPublicationFileManager
Namespace DedNet.Forms


Proprietà DedFormPublicationFileManager.ConfigurationManager

Proprietà DedFormPublicationFileManagerConfigurationManager
Oggetto contenenente le impostazioni di pubblicazione.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedPublicationManager ConfigurationManager { get; }
Public ReadOnly Property ConfigurationManager As DedPublicationManager
    Get
public:
property DedPublicationManager^ ConfigurationManager {
    DedPublicationManager^ get ();
}
member ConfigurationManager : DedPublicationManager with get

Valore della proprietà

DedPublicationManager
Vedi anche

Documentazione

Classe DedFormPublicationFileManager
Namespace DedNet.Forms


Metodi di DedFormPublicationFileManager

Il tipo DedFormPublicationFileManager espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormPublicationFileManager
Namespace DedNet.Forms


Metodo DedFormPublicationFileManager.Dispose

Metodo DedFormPublicationFileManagerDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormPublicationFileManager
Namespace DedNet.Forms


Eventi di DedFormPublicationFileManager

Il tipo DedFormPublicationFileManager espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormPublicationFileManager
Namespace DedNet.Forms


Campi di DedFormPublicationFileManager

Il tipo DedFormPublicationFileManager espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormPublicationFileManager
Namespace DedNet.Forms


Classe DedFormPwsBackup
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormPwsBackup

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormPwsBackup : BaseForm
Public Class DedFormPwsBackup
    Inherits BaseForm
public ref class DedFormPwsBackup : public BaseForm
type DedFormPwsBackup =
    class
        inherit BaseForm
    end

Il tipo DedFormPwsBackup espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormPwsBackup | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà pubblica | FullFileName | Restituisce il nome file completo ripristinato.
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormPwsBackup
Costruttore unico.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormPwsBackup(
    DedNetApplication app,
    FileTransaction fTrans,
    bool bErase
)
Public Sub New (
    app As DedNetApplication,
    fTrans As FileTransaction,
    bErase As Boolean
)
public:
DedFormPwsBackup(
    DedNetApplication^ app,
    FileTransaction^ fTrans,
    bool bErase
)
new :
        app : DedNetApplication *
        fTrans : FileTransaction *
        bErase : bool -> DedFormPwsBackup

Parametri

app DedNetApplication
Oggetto applicazione.
fTrans FileTransaction
bErase Boolean
Indica se eliminare o meno i backup una volta ripristinati.
Vedi anche

Documentazione

Classe DedFormPwsBackup
Namespace DedNet.Forms


Proprietà di DedFormPwsBackup

Il tipo DedFormPwsBackup espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà pubblica | FullFileName | Restituisce il nome file completo ripristinato.
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormPwsBackup
Namespace DedNet.Forms


Proprietà DedFormPwsBackup.FullFileName

Proprietà DedFormPwsBackupFullFileName
Restituisce il nome file completo ripristinato.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string FullFileName { get; }
Public ReadOnly Property FullFileName As String
    Get
public:
property String^ FullFileName {
    String^ get ();
}
member FullFileName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedFormPwsBackup
Namespace DedNet.Forms


Metodi di DedFormPwsBackup

Il tipo DedFormPwsBackup espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormPwsBackup
Namespace DedNet.Forms


Metodo DedFormPwsBackup.Dispose

Metodo DedFormPwsBackupDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormPwsBackup
Namespace DedNet.Forms


Eventi di DedFormPwsBackup

Il tipo DedFormPwsBackup espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormPwsBackup
Namespace DedNet.Forms


Campi di DedFormPwsBackup

Il tipo DedFormPwsBackup espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormPwsBackup
Namespace DedNet.Forms


Classe DedFormPwsCache
Form che mostra una finestra con i documenti presenti nella pws locale dell'utente che sta usando l'applicazione.
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormPwsCache

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormPwsCache : BaseForm
Public Class DedFormPwsCache
    Inherits BaseForm
public ref class DedFormPwsCache : public BaseForm
type DedFormPwsCache =
    class
        inherit BaseForm
    end

Il tipo DedFormPwsCache espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormPwsCache | Costruttore interno.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | ExtToHide | Lista delle estensioni da non visualizzare (con il .)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormPwsCache
Costruttore interno.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormPwsCache(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedFormPwsCache(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedFormPwsCache

Parametri

app DedNetApplication
Applicazione.
Vedi anche

Documentazione

Classe DedFormPwsCache
Namespace DedNet.Forms


Proprietà di DedFormPwsCache

Il tipo DedFormPwsCache espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | ExtToHide | Lista delle estensioni da non visualizzare (con il .)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormPwsCache
Namespace DedNet.Forms


Proprietà DedFormPwsCache.ExtToHide

Proprietà DedFormPwsCacheExtToHide
Lista delle estensioni da non visualizzare (con il .)

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> ExtToHide { get; }
Public ReadOnly Property ExtToHide As List(Of String)
    Get
public:
property List<String^>^ ExtToHide {
    List<String^>^ get ();
}
member ExtToHide : List<string> with get

Valore della proprietà

List String
Vedi anche

Documentazione

Classe DedFormPwsCache
Namespace DedNet.Forms


Metodi di DedFormPwsCache

Il tipo DedFormPwsCache espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormPwsCache
Namespace DedNet.Forms


Metodo DedFormPwsCache.Dispose

Metodo DedFormPwsCacheDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormPwsCache
Namespace DedNet.Forms


Eventi di DedFormPwsCache

Il tipo DedFormPwsCache espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormPwsCache
Namespace DedNet.Forms


Campi di DedFormPwsCache

Il tipo DedFormPwsCache espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormPwsCache
Namespace DedNet.Forms


Classe DedFormPwsCache.PwsItem

Classe DedFormPwsCachePwsItem
Descrive le caratteristiche di un singolo elemento presente nella cache locale.
Gerarchia di ereditarietà
SystemObject
DedNet.FormsDedFormPwsCachePwsItem

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class PwsItem
Public Class PwsItem
public ref class PwsItem
type PwsItem = class end

Il tipo DedFormPwsCachePwsItem espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormPwsCachePwsItem |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AssociateDoc |
Proprietà pubblica | CheckoutHost |
Proprietà pubblica | CheckoutUser |
Proprietà pubblica | FullFileName |
Proprietà pubblica | FullName |
Proprietà pubblica | HasMovedDoc | Ritorna se il documento ha un corrispondente moved
Proprietà pubblica | Image |
Proprietà pubblica | IsDocErased | Ritorna se il documento ha un corrispondente moved
Proprietà pubblica | Preview |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | CreateErasedItem | Crea l'elemento rappresentante un documento eliminato
Metodo pubblico | CreateItem | Crea l'elemento con i dati presenti nel documento.
Metodo pubblico | CreateMovedItem | Crea l'elemento che ha generato un moved
Metodo pubblico | GetState | Calcola l'immagine da associare all'elemento.
Metodo pubblico | Refresh |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormPwsCache.PwsItem

Costruttore DedFormPwsCachePwsItem

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public PwsItem()
Public Sub New
public:
PwsItem()
new : unit -> PwsItem
Vedi anche

Documentazione

Classe DedFormPwsCachePwsItem
Namespace DedNet.Forms


Proprietà di PwsItem

Il tipo DedFormPwsCachePwsItem espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AssociateDoc |
Proprietà pubblica | CheckoutHost |
Proprietà pubblica | CheckoutUser |
Proprietà pubblica | FullFileName |
Proprietà pubblica | FullName |
Proprietà pubblica | HasMovedDoc | Ritorna se il documento ha un corrispondente moved
Proprietà pubblica | Image |
Proprietà pubblica | IsDocErased | Ritorna se il documento ha un corrispondente moved
Proprietà pubblica | Preview |
Torna su
Vedi anche

Documentazione

Classe DedFormPwsCachePwsItem
Namespace DedNet.Forms


Proprietà DedFormPwsCache.PwsItem.AssociateDoc

Proprietà DedFormPwsCachePwsItemAssociateDoc

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDoc AssociateDoc { get; set; }
Public Property AssociateDoc As DedDoc
    Get
    Set
public:
property DedDoc^ AssociateDoc {
    DedDoc^ get ();
    void set (DedDoc^ value);
}
member AssociateDoc : DedDoc with get, set

Valore della proprietà

DedDoc
Vedi anche

Documentazione

Classe DedFormPwsCachePwsItem
Namespace DedNet.Forms


Proprietà DedFormPwsCache.PwsItem.CheckoutHost

Proprietà DedFormPwsCachePwsItemCheckoutHost

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string CheckoutHost { get; set; }
Public Property CheckoutHost As String
    Get
    Set
public:
property String^ CheckoutHost {
    String^ get ();
    void set (String^ value);
}
member CheckoutHost : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedFormPwsCachePwsItem
Namespace DedNet.Forms


Proprietà DedFormPwsCache.PwsItem.CheckoutUser

Proprietà DedFormPwsCachePwsItemCheckoutUser

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string CheckoutUser { get; set; }
Public Property CheckoutUser As String
    Get
    Set
public:
property String^ CheckoutUser {
    String^ get ();
    void set (String^ value);
}
member CheckoutUser : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedFormPwsCachePwsItem
Namespace DedNet.Forms


Proprietà DedFormPwsCache.PwsItem.FullFileName

Proprietà DedFormPwsCachePwsItemFullFileName

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string FullFileName { get; set; }
Public Property FullFileName As String
    Get
    Set
public:
property String^ FullFileName {
    String^ get ();
    void set (String^ value);
}
member FullFileName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedFormPwsCachePwsItem
Namespace DedNet.Forms


Proprietà DedFormPwsCache.PwsItem.FullName

Proprietà DedFormPwsCachePwsItemFullName

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string FullName { get; set; }
Public Property FullName As String
    Get
    Set
public:
property String^ FullName {
    String^ get ();
    void set (String^ value);
}
member FullName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedFormPwsCachePwsItem
Namespace DedNet.Forms


Proprietà DedFormPwsCache.PwsItem.HasMovedDoc

Proprietà DedFormPwsCachePwsItemHasMovedDoc
Ritorna se il documento ha un corrispondente moved

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasMovedDoc { get; set; }
Public Property HasMovedDoc As Boolean
    Get
    Set
public:
property bool HasMovedDoc {
    bool get ();
    void set (bool value);
}
member HasMovedDoc : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormPwsCachePwsItem
Namespace DedNet.Forms


Proprietà DedFormPwsCache.PwsItem.Image

Proprietà DedFormPwsCachePwsItemImage

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Image { get; set; }
Public Property Image As String
    Get
    Set
public:
property String^ Image {
    String^ get ();
    void set (String^ value);
}
member Image : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedFormPwsCachePwsItem
Namespace DedNet.Forms


Proprietà DedFormPwsCache.PwsItem.IsDocErased

Proprietà DedFormPwsCachePwsItemIsDocErased
Ritorna se il documento ha un corrispondente moved

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsDocErased { get; set; }
Public Property IsDocErased As Boolean
    Get
    Set
public:
property bool IsDocErased {
    bool get ();
    void set (bool value);
}
member IsDocErased : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormPwsCachePwsItem
Namespace DedNet.Forms


Proprietà DedFormPwsCache.PwsItem.Preview

Proprietà DedFormPwsCachePwsItemPreview

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Preview { get; }
Public ReadOnly Property Preview As String
    Get
public:
property String^ Preview {
    String^ get ();
}
member Preview : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedFormPwsCachePwsItem
Namespace DedNet.Forms


Metodi di PwsItem

Il tipo DedFormPwsCachePwsItem espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | CreateErasedItem | Crea l'elemento rappresentante un documento eliminato
Metodo pubblico | CreateItem | Crea l'elemento con i dati presenti nel documento.
Metodo pubblico | CreateMovedItem | Crea l'elemento che ha generato un moved
Metodo pubblico | GetState | Calcola l'immagine da associare all'elemento.
Metodo pubblico | Refresh |
Torna su
Vedi anche

Documentazione

Classe DedFormPwsCachePwsItem
Namespace DedNet.Forms


Metodo DedFormPwsCache.PwsItem.CreateErasedItem

Metodo DedFormPwsCachePwsItemCreateErasedItem
Crea l'elemento rappresentante un documento eliminato

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void CreateErasedItem(
    string filename,
    DedNetApplication app
)
Public Sub CreateErasedItem (
    filename As String,
    app As DedNetApplication
)
public:
void CreateErasedItem(
    String^ filename,
    DedNetApplication^ app
)
member CreateErasedItem :
        filename : string *
        app : DedNetApplication -> unit

Parametri

filename String
app DedNetApplication
Vedi anche

Documentazione

Classe DedFormPwsCachePwsItem
Namespace DedNet.Forms


Metodo DedFormPwsCache.PwsItem.CreateItem

Metodo DedFormPwsCachePwsItemCreateItem
Crea l'elemento con i dati presenti nel documento.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void CreateItem(
    DedDoc doc,
    DedNetApplication app
)
Public Sub CreateItem (
    doc As DedDoc,
    app As DedNetApplication
)
public:
void CreateItem(
    DedDoc^ doc,
    DedNetApplication^ app
)
member CreateItem :
        doc : DedDoc *
        app : DedNetApplication -> unit

Parametri

doc DedDoc
Documento collegato all'oggetto.
app DedNetApplication
Vedi anche

Documentazione

Classe DedFormPwsCachePwsItem
Namespace DedNet.Forms


Metodo DedFormPwsCache.PwsItem.CreateMovedItem

Metodo DedFormPwsCachePwsItemCreateMovedItem
Crea l'elemento che ha generato un moved

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void CreateMovedItem(
    string filename,
    DedNetApplication app
)
Public Sub CreateMovedItem (
    filename As String,
    app As DedNetApplication
)
public:
void CreateMovedItem(
    String^ filename,
    DedNetApplication^ app
)
member CreateMovedItem :
        filename : string *
        app : DedNetApplication -> unit

Parametri

filename String
app DedNetApplication
Vedi anche

Documentazione

Classe DedFormPwsCachePwsItem
Namespace DedNet.Forms


Metodo DedFormPwsCache.PwsItem.GetState

Metodo DedFormPwsCachePwsItemGetState
Calcola l'immagine da associare all'elemento.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void GetState()
Public Sub GetState
public:
void GetState()
member GetState : unit -> unit
Vedi anche

Documentazione

Classe DedFormPwsCachePwsItem
Namespace DedNet.Forms


Metodo DedFormPwsCache.PwsItem.Refresh

Metodo DedFormPwsCachePwsItemRefresh

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Refresh(
    DedNetApplication app
)
Public Sub Refresh (
    app As DedNetApplication
)
public:
void Refresh(
    DedNetApplication^ app
)
member Refresh :
        app : DedNetApplication -> unit

Parametri

app DedNetApplication
Vedi anche

Documentazione

Classe DedFormPwsCachePwsItem
Namespace DedNet.Forms


Classe DedFormPwsCache.PwsItemList

Classe DedFormPwsCachePwsItemList
Lista di elementi presenti nella pws.
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList DedFormPwsCachePwsItem
DedNet.FormsDedFormPwsCachePwsItemList

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class PwsItemList : List<DedFormPwsCachePwsItem>
Public Class PwsItemList
    Inherits List(Of DedFormPwsCachePwsItem)
public ref class PwsItemList : public List<DedFormPwsCachePwsItem^>
type PwsItemList =
    class
        inherit List<DedFormPwsCachePwsItem>
    end

Il tipo DedFormPwsCachePwsItemList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormPwsCachePwsItemList |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormPwsCache.PwsItemList

Costruttore DedFormPwsCachePwsItemList

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public PwsItemList()
Public Sub New
public:
PwsItemList()
new : unit -> PwsItemList
Vedi anche

Documentazione

Classe DedFormPwsCachePwsItemList
Namespace DedNet.Forms


Classe DedFormQsManager
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormQsManager

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormQsManager : BaseForm
Public Class DedFormQsManager
    Inherits BaseForm
public ref class DedFormQsManager : public BaseForm
type DedFormQsManager =
    class
        inherit BaseForm
    end

Il tipo DedFormQsManager espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormQsManager | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo pubblico | GetDefaultCurText | REstituisce il controllo attivo del campo Default
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
 | SaveToFile | Scrive su file ASCII tutto il contenuto di una lista di attributi. Il formato risultante del file è quello tipico dell'attrb.txt dell'applicativo Top senza DeD, ovvero una lista di liste assegnate ad una variabile globale di nome TopAttribList.
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo pubblico | SetRootType | Root del controllo dei Tipi
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
 | max_desc_lenght | Lunghezza massima in caratteri del campo descrizione.
 | max_name_lenght | Lunghezza massima in caratteri del campo Name.
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormQsManager
Costruttore unico.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormQsManager(
    DedNetApplication app,
    DedFormQsManagerRootTypeEnum rootType = DedFormQsManagerRootTypeEnum.Fam
)
Public Sub New (
    app As DedNetApplication,
    Optional rootType As DedFormQsManagerRootTypeEnum = DedFormQsManagerRootTypeEnum.Fam
)
public:
DedFormQsManager(
    DedNetApplication^ app,
    DedFormQsManagerRootTypeEnum rootType = DedFormQsManagerRootTypeEnum::Fam
)
new :
        app : DedNetApplication *
        ?rootType : DedFormQsManagerRootTypeEnum
(* Defaults:
        let _rootType = defaultArg rootType DedFormQsManagerRootTypeEnum.Fam
*)
-> DedFormQsManager

Parametri

app DedNetApplication
Oggetto applicazione.
rootType DedFormQsManagerRootTypeEnum (Optional)
Vedi anche

Documentazione

Classe DedFormQsManager
Namespace DedNet.Forms


Proprietà di DedFormQsManager

Il tipo DedFormQsManager espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormQsManager
Namespace DedNet.Forms


Metodi di DedFormQsManager

Il tipo DedFormQsManager espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo pubblico | GetDefaultCurText | REstituisce il controllo attivo del campo Default
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
 | SaveToFile | Scrive su file ASCII tutto il contenuto di una lista di attributi. Il formato risultante del file è quello tipico dell'attrb.txt dell'applicativo Top senza DeD, ovvero una lista di liste assegnate ad una variabile globale di nome TopAttribList.
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo pubblico | SetRootType | Root del controllo dei Tipi
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormQsManager
Namespace DedNet.Forms


Metodo DedFormQsManager.Dispose

Metodo DedFormQsManagerDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormQsManager
Namespace DedNet.Forms


Metodo DedFormQsManager.GetDefaultCurText

Metodo DedFormQsManagerGetDefaultCurText
REstituisce il controllo attivo del campo Default

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BaseEdit GetDefaultCurText()
Public Function GetDefaultCurText As BaseEdit
public:
BaseEdit^ GetDefaultCurText()
member GetDefaultCurText : unit -> BaseEdit

Valore di ritorno

BaseEdit
Vedi anche

Documentazione

Classe DedFormQsManager
Namespace DedNet.Forms


Metodo DedFormQsManager.SaveToFile

Metodo DedFormQsManagerSaveToFile
Scrive su file ASCII tutto il contenuto di una lista di attributi. Il formato risultante del file è quello tipico dell'attrb.txt dell'applicativo Top senza DeD, ovvero una lista di liste assegnate ad una variabile globale di nome TopAttribList.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool SaveToFile(
    string fileName,
    DedAttrList attrList
)
Public Shared Function SaveToFile (
    fileName As String,
    attrList As DedAttrList
) As Boolean
public:
static bool SaveToFile(
    String^ fileName,
    DedAttrList^ attrList
)
static member SaveToFile :
        fileName : string *
        attrList : DedAttrList -> bool

Parametri

fileName String
Nome file nel quale scrivere gli attributi.
attrList DedAttrList
Oggetto FamilyAttributeList da scrivere nel file.

Valore di ritorno

Boolean
Se l'operazione è andata a buon fine.
Vedi anche

Documentazione

Classe DedFormQsManager
Namespace DedNet.Forms


Metodo DedFormQsManager.SetRootType

Metodo DedFormQsManagerSetRootType
Root del controllo dei Tipi

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetRootType(
    DedFormQsManagerRootTypeEnum rootType
)
Public Sub SetRootType (
    rootType As DedFormQsManagerRootTypeEnum
)
public:
void SetRootType(
    DedFormQsManagerRootTypeEnum rootType
)
member SetRootType :
        rootType : DedFormQsManagerRootTypeEnum -> unit

Parametri

rootType DedFormQsManagerRootTypeEnum
Vedi anche

Documentazione

Classe DedFormQsManager
Namespace DedNet.Forms


Eventi di DedFormQsManager

Il tipo DedFormQsManager espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormQsManager
Namespace DedNet.Forms


Campi di DedFormQsManager

Il tipo DedFormQsManager espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
 | max_desc_lenght | Lunghezza massima in caratteri del campo descrizione.
 | max_name_lenght | Lunghezza massima in caratteri del campo Name.
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormQsManager
Namespace DedNet.Forms


Campo DedFormQsManager.max_desc_lenght

Campo DedFormQsManagermax_desc_lenght
Lunghezza massima in caratteri del campo descrizione.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const int max_desc_lenght = 200
Public Const max_desc_lenght As Integer = 200
public:
literal int max_desc_lenght = 200
static val mutable max_desc_lenght: int

Valore del campo

Int32
Vedi anche

Documentazione

Classe DedFormQsManager
Namespace DedNet.Forms


Campo DedFormQsManager.max_name_lenght

Campo DedFormQsManagermax_name_lenght
Lunghezza massima in caratteri del campo Name.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public const int max_name_lenght = 50
Public Const max_name_lenght As Integer = 50
public:
literal int max_name_lenght = 50
static val mutable max_name_lenght: int

Valore del campo

Int32
Vedi anche

Documentazione

Classe DedFormQsManager
Namespace DedNet.Forms


Enumerazione DedFormQsManager.AttributeOperation

Enumerazione DedFormQsManagerAttributeOperation
Enumeratore contenente tutte le operazioni applicabili agli attributi.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum AttributeOperation
Public Enumeration AttributeOperation
public enum class AttributeOperation
type AttributeOperation
Membri
Nome | Valore | Descrizione
Null | 0 |
Copia | 1 |
Taglia | 2 |
Incolla | 3 |
Ridefinisci | 4 |
DragAndDrop | 5 |
Vedi anche

Documentazione

Namespace DedNet.Forms


Enumerazione DedFormQsManager.RootTypeEnum

Enumerazione DedFormQsManagerRootTypeEnum
Indentifica la tipologia

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum RootTypeEnum
Public Enumeration RootTypeEnum
public enum class RootTypeEnum
type RootTypeEnum
Membri
Nome | Valore | Descrizione
Fam | 0 | Famiglie
Comm | 1 | Commesse
Vedi anche

Documentazione

Namespace DedNet.Forms


Classe DedFormRenameCopyDocument
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormRenameCopyDocument

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormRenameCopyDocument : BaseForm
Public Class DedFormRenameCopyDocument
    Inherits BaseForm
public ref class DedFormRenameCopyDocument : public BaseForm
type DedFormRenameCopyDocument =
    class
        inherit BaseForm
    end

Il tipo DedFormRenameCopyDocument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà pubblica | TargetColumnText | Restituisce o imposta il testo della colonna di destinazione.
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Proprietà di DedFormRenameCopyDocument

Il tipo DedFormRenameCopyDocument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà pubblica | TargetColumnText | Restituisce o imposta il testo della colonna di destinazione.
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormRenameCopyDocument
Namespace DedNet.Forms


Proprietà DedFormRenameCopyDocument.TargetColumnText

Proprietà DedFormRenameCopyDocumentTargetColumnText
Restituisce o imposta il testo della colonna di destinazione.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string TargetColumnText { get; set; }
Public Property TargetColumnText As String
    Get
    Set
public:
property String^ TargetColumnText {
    String^ get ();
    void set (String^ value);
}
member TargetColumnText : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedFormRenameCopyDocument
Namespace DedNet.Forms


Metodi di DedFormRenameCopyDocument

Il tipo DedFormRenameCopyDocument espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormRenameCopyDocument
Namespace DedNet.Forms


Metodo DedFormRenameCopyDocument.Dispose

Metodo DedFormRenameCopyDocumentDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormRenameCopyDocument
Namespace DedNet.Forms


Eventi di DedFormRenameCopyDocument

Il tipo DedFormRenameCopyDocument espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormRenameCopyDocument
Namespace DedNet.Forms


Campi di DedFormRenameCopyDocument

Il tipo DedFormRenameCopyDocument espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormRenameCopyDocument
Namespace DedNet.Forms


Classe DedFormReplaceAnagrDist
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormReplaceAnagrDist

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormReplaceAnagrDist : BaseForm
Public Class DedFormReplaceAnagrDist
    Inherits BaseForm
public ref class DedFormReplaceAnagrDist : public BaseForm
type DedFormReplaceAnagrDist =
    class
        inherit BaseForm
    end

Il tipo DedFormReplaceAnagrDist espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormReplaceAnagrDist | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà pubblica | DataDx | Anagrafica sostituta
Proprietà pubblica | DataSx | Anagrafica da sostituire
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormReplaceAnagrDist
Costruttore

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormReplaceAnagrDist()
Public Sub New
public:
DedFormReplaceAnagrDist()
new : unit -> DedFormReplaceAnagrDist
Vedi anche

Documentazione

Classe DedFormReplaceAnagrDist
Namespace DedNet.Forms


Proprietà di DedFormReplaceAnagrDist

Il tipo DedFormReplaceAnagrDist espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà pubblica | DataDx | Anagrafica sostituta
Proprietà pubblica | DataSx | Anagrafica da sostituire
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormReplaceAnagrDist
Namespace DedNet.Forms


Proprietà DedFormReplaceAnagrDist.DataDx

Proprietà DedFormReplaceAnagrDistDataDx
Anagrafica sostituta

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData DataDx { get; set; }
Public Property DataDx As DedData
    Get
    Set
public:
property DedData^ DataDx {
    DedData^ get ();
    void set (DedData^ value);
}
member DataDx : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe DedFormReplaceAnagrDist
Namespace DedNet.Forms


Proprietà DedFormReplaceAnagrDist.DataSx

Proprietà DedFormReplaceAnagrDistDataSx
Anagrafica da sostituire

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData DataSx { get; set; }
Public Property DataSx As DedData
    Get
    Set
public:
property DedData^ DataSx {
    DedData^ get ();
    void set (DedData^ value);
}
member DataSx : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe DedFormReplaceAnagrDist
Namespace DedNet.Forms


Metodi di DedFormReplaceAnagrDist

Il tipo DedFormReplaceAnagrDist espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormReplaceAnagrDist
Namespace DedNet.Forms


Metodo DedFormReplaceAnagrDist.Dispose

Metodo DedFormReplaceAnagrDistDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormReplaceAnagrDist
Namespace DedNet.Forms


Eventi di DedFormReplaceAnagrDist

Il tipo DedFormReplaceAnagrDist espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormReplaceAnagrDist
Namespace DedNet.Forms


Campi di DedFormReplaceAnagrDist

Il tipo DedFormReplaceAnagrDist espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormReplaceAnagrDist
Namespace DedNet.Forms


Classe DedFormReserveProg
Classe per assegnare i progressivi ai vari utenti/gruppi.
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormReserveProg

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormReserveProg : BaseForm
Public Class DedFormReserveProg
    Inherits BaseForm
public ref class DedFormReserveProg : public BaseForm
type DedFormReserveProg =
    class
        inherit BaseForm
    end

Il tipo DedFormReserveProg espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormReserveProg | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo pubblico | LoadRegistrySettings | Carica dal registro le dimensioni e la visibilità delle colonne.
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo pubblico | SaveRegistrySettings | Salva nel registro le dimensioni e la visibilità delle colonne.
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo pubblico | SetRootType | Imposta la root dell'albero ed inizializza le famiglie sottostanti a primo livello. Utilizzato per una root singola.
Metodo pubblico | SetRootTypes | Imposta le root dell'albero ed inizializza le famiglie sottostanti a primo livello. Utilizzato per root multiple.
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormReserveProg
Costruttore

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormReserveProg(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedFormReserveProg(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedFormReserveProg

Parametri

app DedNetApplication
DedNetApp
Vedi anche

Documentazione

Classe DedFormReserveProg
Namespace DedNet.Forms


Proprietà di DedFormReserveProg

Il tipo DedFormReserveProg espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormReserveProg
Namespace DedNet.Forms


Metodi di DedFormReserveProg

Il tipo DedFormReserveProg espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo pubblico | LoadRegistrySettings | Carica dal registro le dimensioni e la visibilità delle colonne.
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo pubblico | SaveRegistrySettings | Salva nel registro le dimensioni e la visibilità delle colonne.
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo pubblico | SetRootType | Imposta la root dell'albero ed inizializza le famiglie sottostanti a primo livello. Utilizzato per una root singola.
Metodo pubblico | SetRootTypes | Imposta le root dell'albero ed inizializza le famiglie sottostanti a primo livello. Utilizzato per root multiple.
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormReserveProg
Namespace DedNet.Forms


Metodo DedFormReserveProg.Dispose

Metodo DedFormReserveProgDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormReserveProg
Namespace DedNet.Forms


Metodo DedFormReserveProg.LoadRegistrySettings

Metodo DedFormReserveProgLoadRegistrySettings
Carica dal registro le dimensioni e la visibilità delle colonne.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void LoadRegistrySettings(
    string key
)
Public Sub LoadRegistrySettings (
    key As String
)
public:
void LoadRegistrySettings(
    String^ key
)
member LoadRegistrySettings :
        key : string -> unit

Parametri

key String
Chiave di registro dalla quale leggere le impostazioni.
Vedi anche

Documentazione

Classe DedFormReserveProg
Namespace DedNet.Forms


Metodo DedFormReserveProg.SaveRegistrySettings

Metodo DedFormReserveProgSaveRegistrySettings
Salva nel registro le dimensioni e la visibilità delle colonne.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SaveRegistrySettings(
    string key
)
Public Sub SaveRegistrySettings (
    key As String
)
public:
void SaveRegistrySettings(
    String^ key
)
member SaveRegistrySettings :
        key : string -> unit

Parametri

key String
Chiave di registro nella quale scrivere le impostazioni.
Vedi anche

Documentazione

Classe DedFormReserveProg
Namespace DedNet.Forms


Metodo DedFormReserveProg.SetRootType

Metodo DedFormReserveProgSetRootType
Imposta la root dell'albero ed inizializza le famiglie sottostanti a primo livello. Utilizzato per una root singola.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetRootType(
    DedType root
)
Public Sub SetRootType (
    root As DedType
)
public:
void SetRootType(
    DedType^ root
)
member SetRootType :
        root : DedType -> unit

Parametri

root DedType
Vedi anche

Documentazione

Classe DedFormReserveProg
Namespace DedNet.Forms


Metodo DedFormReserveProg.SetRootTypes

Metodo DedFormReserveProgSetRootTypes
Imposta le root dell'albero ed inizializza le famiglie sottostanti a primo livello. Utilizzato per root multiple.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetRootTypes(
    DedType[] roots
)
Public Sub SetRootTypes (
    roots As DedType()
)
public:
void SetRootTypes(
    array<DedType^>^ roots
)
member SetRootTypes :
        roots : DedType[] -> unit

Parametri

roots DedType
Famiglie radice di livello 0 dell'albero.
Vedi anche

Documentazione

Classe DedFormReserveProg
Namespace DedNet.Forms


Eventi di DedFormReserveProg

Il tipo DedFormReserveProg espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormReserveProg
Namespace DedNet.Forms


Campi di DedFormReserveProg

Il tipo DedFormReserveProg espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormReserveProg
Namespace DedNet.Forms


Classe DedFormSave
Finestra di dialogo per la creazione di una nuova anagrafica.
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormSave

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormSave : BaseForm
Public Class DedFormSave
    Inherits BaseForm
public ref class DedFormSave : public BaseForm
type DedFormSave =
    class
        inherit BaseForm
    end

Il tipo DedFormSave espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà pubblica | BomCloneMode | Tipo di clonazione dei dati di distinta
Proprietà pubblica | ButtonOkEnabled | Restituisce o imposta l'abilitazione del pulsante ok.
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | ClientDocs | Lista di documenti gestiti dal client.
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà pubblica | Cmd | Comando che ha eseguito il form;
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà pubblica | Comm | Restituisce la commessa selezionata.
Proprietà pubblica | CommandButtons | Restituisce la bottoniera dei comandi
Proprietà pubblica | CommQty | Restituisce la commessa selezionata.
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà pubblica | DistPresent | Indica se l'anagrafica di partenza ha una distinta
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà pubblica | ForceRecognize | Indica se forzare un Riconosci (tipicamente da Inventor in caso di presenza di Member).
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà pubblica | HandleRecognize | Indica al chiamante se gestire un Riconosci.
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà pubblica | Info | Restituisce o imposta le informazioni da utilizzare per il salvataggio.
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | Mdi | Informazioni per il calcolo del move
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | Mdres | Informazioni sul risultato del move
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà pubblica | Mode | Restituisce o imposta la modalità di utilizzo della finestra di dialogo.
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà pubblica | Tree | Espone l'albero per i tecnici
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnButtonOkPressed | Chiama l'evento ButtonOkPressed.
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnDataChanged | Chiama l'evento DataChanged.
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo pubblico | RefreshAttrib | Forza il refresh degli attributi.
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
 | ReplaceLastOccurrence | Sostituisce l'ultima occorrenza da cercare "Find" con il vaslore di "Replace" nella stringa "Source"
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | ButtonOkPressedEvent | Evento chiamato sulla pressione del pulsante OK della finestra.
Evento pubblico | DataChangedEvent | Evento chiamato alla modifica di una qualsiasi caratteristica della finestra di dialogo: La famiglia, il progressivo, la revisione oppure un attributo dell'anagrafica.
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Proprietà di DedFormSave

Il tipo DedFormSave espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà pubblica | BomCloneMode | Tipo di clonazione dei dati di distinta
Proprietà pubblica | ButtonOkEnabled | Restituisce o imposta l'abilitazione del pulsante ok.
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | ClientDocs | Lista di documenti gestiti dal client.
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà pubblica | Cmd | Comando che ha eseguito il form;
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà pubblica | Comm | Restituisce la commessa selezionata.
Proprietà pubblica | CommandButtons | Restituisce la bottoniera dei comandi
Proprietà pubblica | CommQty | Restituisce la commessa selezionata.
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà pubblica | DistPresent | Indica se l'anagrafica di partenza ha una distinta
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà pubblica | ForceRecognize | Indica se forzare un Riconosci (tipicamente da Inventor in caso di presenza di Member).
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà pubblica | HandleRecognize | Indica al chiamante se gestire un Riconosci.
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà pubblica | Info | Restituisce o imposta le informazioni da utilizzare per il salvataggio.
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | Mdi | Informazioni per il calcolo del move
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | Mdres | Informazioni sul risultato del move
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà pubblica | Mode | Restituisce o imposta la modalità di utilizzo della finestra di dialogo.
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà pubblica | Tree | Espone l'albero per i tecnici
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormSave
Namespace DedNet.Forms


Proprietà DedFormSave.BomCloneMode

Proprietà DedFormSaveBomCloneMode
Tipo di clonazione dei dati di distinta

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BomCloneMode BomCloneMode { get; set; }
Public Property BomCloneMode As BomCloneMode
    Get
    Set
public:
property BomCloneMode BomCloneMode {
    BomCloneMode get ();
    void set (BomCloneMode value);
}
member BomCloneMode : BomCloneMode with get, set

Valore della proprietà

BomCloneMode
Vedi anche

Documentazione

Classe DedFormSave
Namespace DedNet.Forms


Proprietà DedFormSave.ButtonOkEnabled

Proprietà DedFormSaveButtonOkEnabled
Restituisce o imposta l'abilitazione del pulsante ok.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ButtonOkEnabled { get; set; }
Public Property ButtonOkEnabled As Boolean
    Get
    Set
public:
property bool ButtonOkEnabled {
    bool get ();
    void set (bool value);
}
member ButtonOkEnabled : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormSave
Namespace DedNet.Forms


Proprietà DedFormSave.ClientDocs

Proprietà DedFormSaveClientDocs
Lista di documenti gestiti dal client.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfoList ClientDocs { get; set; }
Public Property ClientDocs As DocStructInfoList
    Get
    Set
public:
property DocStructInfoList^ ClientDocs {
    DocStructInfoList^ get ();
    void set (DocStructInfoList^ value);
}
member ClientDocs : DocStructInfoList with get, set

Valore della proprietà

DocStructInfoList
Vedi anche

Documentazione

Classe DedFormSave
Namespace DedNet.Forms


Proprietà DedFormSave.Cmd

Proprietà DedFormSaveCmd
Comando che ha eseguito il form;

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommand Cmd { get; set; }
Public Property Cmd As DedCommand
    Get
    Set
public:
property DedCommand^ Cmd {
    DedCommand^ get ();
    void set (DedCommand^ value);
}
member Cmd : DedCommand with get, set

Valore della proprietà

DedCommand
Vedi anche

Documentazione

Classe DedFormSave
Namespace DedNet.Forms


Proprietà DedFormSave.Comm

Proprietà DedFormSaveComm
Restituisce la commessa selezionata.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Comm { get; }
Public ReadOnly Property Comm As String
    Get
public:
property String^ Comm {
    String^ get ();
}
member Comm : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedFormSave
Namespace DedNet.Forms


Proprietà DedFormSave.CommandButtons

Proprietà DedFormSaveCommandButtons
Restituisce la bottoniera dei comandi

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDropDownButtonControl CommandButtons { get; }
Public ReadOnly Property CommandButtons As DedDropDownButtonControl
    Get
public:
property DedDropDownButtonControl^ CommandButtons {
    DedDropDownButtonControl^ get ();
}
member CommandButtons : DedDropDownButtonControl with get

Valore della proprietà

DedDropDownButtonControl
Vedi anche

Documentazione

Classe DedFormSave
Namespace DedNet.Forms


Proprietà DedFormSave.CommQty

Proprietà DedFormSaveCommQty
Restituisce la commessa selezionata.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public double CommQty { get; }
Public ReadOnly Property CommQty As Double
    Get
public:
property double CommQty {
    double get ();
}
member CommQty : float with get

Valore della proprietà

Double
Vedi anche

Documentazione

Classe DedFormSave
Namespace DedNet.Forms


Proprietà DedFormSave.DistPresent

Proprietà DedFormSaveDistPresent
Indica se l'anagrafica di partenza ha una distinta

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool DistPresent { get; set; }
Public Property DistPresent As Boolean
    Get
    Set
public:
property bool DistPresent {
    bool get ();
    void set (bool value);
}
member DistPresent : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormSave
Namespace DedNet.Forms


Proprietà DedFormSave.ForceRecognize

Proprietà DedFormSaveForceRecognize
Indica se forzare un Riconosci (tipicamente da Inventor in caso di presenza di Member).

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ForceRecognize { get; set; }
Public Property ForceRecognize As Boolean
    Get
    Set
public:
property bool ForceRecognize {
    bool get ();
    void set (bool value);
}
member ForceRecognize : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormSave
Namespace DedNet.Forms


Proprietà DedFormSave.HandleRecognize

Proprietà DedFormSaveHandleRecognize
Indica al chiamante se gestire un Riconosci.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HandleRecognize { get; }
Public ReadOnly Property HandleRecognize As Boolean
    Get
public:
property bool HandleRecognize {
    bool get ();
}
member HandleRecognize : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormSave
Namespace DedNet.Forms


Proprietà DedFormSave.Info

Proprietà DedFormSaveInfo
Restituisce o imposta le informazioni da utilizzare per il salvataggio.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedEncodeInfo Info { get; set; }
Public Property Info As DedEncodeInfo
    Get
    Set
public:
property DedEncodeInfo^ Info {
    DedEncodeInfo^ get ();
    void set (DedEncodeInfo^ value);
}
member Info : DedEncodeInfo with get, set

Valore della proprietà

DedEncodeInfo
Vedi anche

Documentazione

Classe DedFormSave
Namespace DedNet.Forms


Proprietà DedFormSave.Mdi

Proprietà DedFormSaveMdi
Informazioni per il calcolo del move

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public MoveDocumentInfo Mdi { get; set; }
Public Property Mdi As MoveDocumentInfo
    Get
    Set
public:
property MoveDocumentInfo^ Mdi {
    MoveDocumentInfo^ get ();
    void set (MoveDocumentInfo^ value);
}
member Mdi : MoveDocumentInfo with get, set

Valore della proprietà

MoveDocumentInfo
Vedi anche

Documentazione

Classe DedFormSave
Namespace DedNet.Forms


Proprietà DedFormSave.Mdres

Proprietà DedFormSaveMdres
Informazioni sul risultato del move

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public MoveDocumentResult Mdres { get; set; }
Public Property Mdres As MoveDocumentResult
    Get
    Set
public:
property MoveDocumentResult^ Mdres {
    MoveDocumentResult^ get ();
    void set (MoveDocumentResult^ value);
}
member Mdres : MoveDocumentResult with get, set

Valore della proprietà

MoveDocumentResult
Vedi anche

Documentazione

Classe DedFormSave
Namespace DedNet.Forms


Proprietà DedFormSave.Mode

Proprietà DedFormSaveMode
Restituisce o imposta la modalità di utilizzo della finestra di dialogo.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormSaveModeEnum Mode { get; set; }
Public Property Mode As DedFormSaveModeEnum
    Get
    Set
public:
property DedFormSaveModeEnum Mode {
    DedFormSaveModeEnum get ();
    void set (DedFormSaveModeEnum value);
}
member Mode : DedFormSaveModeEnum with get, set

Valore della proprietà

DedFormSaveModeEnum
Vedi anche

Documentazione

Classe DedFormSave
Namespace DedNet.Forms


Proprietà DedFormSave.Tree

Proprietà DedFormSaveTree
Espone l'albero per i tecnici

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeTreeControl Tree { get; }
Public ReadOnly Property Tree As DedTypeTreeControl
    Get
public:
property DedTypeTreeControl^ Tree {
    DedTypeTreeControl^ get ();
}
member Tree : DedTypeTreeControl with get

Valore della proprietà

DedTypeTreeControl
Vedi anche

Documentazione

Classe DedFormSave
Namespace DedNet.Forms


Metodi di DedFormSave

Il tipo DedFormSave espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnButtonOkPressed | Chiama l'evento ButtonOkPressed.
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnDataChanged | Chiama l'evento DataChanged.
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo pubblico | RefreshAttrib | Forza il refresh degli attributi.
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
 | ReplaceLastOccurrence | Sostituisce l'ultima occorrenza da cercare "Find" con il vaslore di "Replace" nella stringa "Source"
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormSave
Namespace DedNet.Forms


Metodo DedFormSave.Dispose

Metodo DedFormSaveDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormSave
Namespace DedNet.Forms


Metodo DedFormSave.OnButtonOkPressed

Metodo DedFormSaveOnButtonOkPressed
Chiama l'evento ButtonOkPressed.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected void OnButtonOkPressed(
    CancelEventArgs e
)
Protected Sub OnButtonOkPressed (
    e As CancelEventArgs
)
protected:
void OnButtonOkPressed(
    CancelEventArgs^ e
)
member OnButtonOkPressed :
        e : CancelEventArgs -> unit

Parametri

e CancelEventArgs
Vedi anche

Documentazione

Classe DedFormSave
Namespace DedNet.Forms


Metodo DedFormSave.OnDataChanged

Metodo DedFormSaveOnDataChanged
Chiama l'evento DataChanged.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected void OnDataChanged()
Protected Sub OnDataChanged
protected:
void OnDataChanged()
member OnDataChanged : unit -> unit
Vedi anche

Documentazione

Classe DedFormSave
Namespace DedNet.Forms


Metodo DedFormSave.RefreshAttrib

Metodo DedFormSaveRefreshAttrib
Forza il refresh degli attributi.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void RefreshAttrib()
Public Sub RefreshAttrib
public:
void RefreshAttrib()
member RefreshAttrib : unit -> unit
Vedi anche

Documentazione

Classe DedFormSave
Namespace DedNet.Forms


Metodo DedFormSave.ReplaceLastOccurrence

Metodo DedFormSaveReplaceLastOccurrence
Sostituisce l'ultima occorrenza da cercare "Find" con il vaslore di "Replace" nella stringa "Source"

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string ReplaceLastOccurrence(
    string Source,
    string Find,
    string Replace
)
Public Shared Function ReplaceLastOccurrence (
    Source As String,
    Find As String,
    Replace As String
) As String
public:
static String^ ReplaceLastOccurrence(
    String^ Source,
    String^ Find,
    String^ Replace
)
static member ReplaceLastOccurrence :
        Source : string *
        Find : string *
        Replace : string -> string

Parametri

Source String
Stringa da modificare
Find String
Stringa da cercare
Replace String
Stringa da sostituire

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedFormSave
Namespace DedNet.Forms


Eventi di DedFormSave

Il tipo DedFormSave espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | ButtonOkPressedEvent | Evento chiamato sulla pressione del pulsante OK della finestra.
Evento pubblico | DataChangedEvent | Evento chiamato alla modifica di una qualsiasi caratteristica della finestra di dialogo: La famiglia, il progressivo, la revisione oppure un attributo dell'anagrafica.
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormSave
Namespace DedNet.Forms


Evento DedFormSave.ButtonOkPressedEvent

Evento DedFormSaveButtonOkPressedEvent
Evento chiamato sulla pressione del pulsante OK della finestra.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<CancelEventArgs> ButtonOkPressedEvent
Public Event ButtonOkPressedEvent As EventHandler(Of CancelEventArgs)
public:
 event EventHandler<CancelEventArgs^>^ ButtonOkPressedEvent {
    void add (EventHandler<CancelEventArgs^>^ value);
    void remove (EventHandler<CancelEventArgs^>^ value);
}
member ButtonOkPressedEvent : IEvent<EventHandler<CancelEventArgs>,
    CancelEventArgs>

Valore

EventHandler CancelEventArgs
Vedi anche

Documentazione

Classe DedFormSave
Namespace DedNet.Forms


Evento DedFormSave.DataChangedEvent

Evento DedFormSaveDataChangedEvent
Evento chiamato alla modifica di una qualsiasi caratteristica della finestra di dialogo: La famiglia, il progressivo, la revisione oppure un attributo dell'anagrafica.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler DataChangedEvent
Public Event DataChangedEvent As EventHandler
public:
 event EventHandler^ DataChangedEvent {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member DataChangedEvent : IEvent<EventHandler,
    EventArgs>

Valore

EventHandler
Vedi anche

Documentazione

Classe DedFormSave
Namespace DedNet.Forms


Campi di DedFormSave

Il tipo DedFormSave espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormSave
Namespace DedNet.Forms


Classe DedFormSaveAs
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormSaveAs

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormSaveAs : BaseForm
Public Class DedFormSaveAs
    Inherits BaseForm
public ref class DedFormSaveAs : public BaseForm
type DedFormSaveAs =
    class
        inherit BaseForm
    end

Il tipo DedFormSaveAs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormSaveAs | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Estensione | Estensione del file in salvataggio
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà pubblica | FullFileName | Percorso completo del file in salvataggio
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | Mdi | Imposta/restituisce le informazioni per il calcolo del move sull'oggetto
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | Mdres | Restituisce le informazioni sul risultato del move
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà pubblica | Name | Nome del file in salvataggio
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | Path | Percorso di salvataggio
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormSaveAs
Costruttore

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormSaveAs(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedFormSaveAs(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedFormSaveAs

Parametri

app DedNetApplication
Applicazione Ded
Vedi anche

Documentazione

Classe DedFormSaveAs
Namespace DedNet.Forms


Proprietà di DedFormSaveAs

Il tipo DedFormSaveAs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Estensione | Estensione del file in salvataggio
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà pubblica | FullFileName | Percorso completo del file in salvataggio
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | Mdi | Imposta/restituisce le informazioni per il calcolo del move sull'oggetto
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | Mdres | Restituisce le informazioni sul risultato del move
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà pubblica | Name | Nome del file in salvataggio
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | Path | Percorso di salvataggio
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormSaveAs
Namespace DedNet.Forms


Proprietà DedFormSaveAs.Estensione

Proprietà DedFormSaveAsEstensione
Estensione del file in salvataggio

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Estensione { get; set; }
Public Property Estensione As String
    Get
    Set
public:
property String^ Estensione {
    String^ get ();
    void set (String^ value);
}
member Estensione : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedFormSaveAs
Namespace DedNet.Forms


Proprietà DedFormSaveAs.FullFileName

Proprietà DedFormSaveAsFullFileName
Percorso completo del file in salvataggio

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string FullFileName { get; }
Public ReadOnly Property FullFileName As String
    Get
public:
property String^ FullFileName {
    String^ get ();
}
member FullFileName : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedFormSaveAs
Namespace DedNet.Forms


Proprietà DedFormSaveAs.Mdi

Proprietà DedFormSaveAsMdi
Imposta/restituisce le informazioni per il calcolo del move sull'oggetto

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public MoveDocumentInfo Mdi { get; set; }
Public Property Mdi As MoveDocumentInfo
    Get
    Set
public:
property MoveDocumentInfo^ Mdi {
    MoveDocumentInfo^ get ();
    void set (MoveDocumentInfo^ value);
}
member Mdi : MoveDocumentInfo with get, set

Valore della proprietà

MoveDocumentInfo
Vedi anche

Documentazione

Classe DedFormSaveAs
Namespace DedNet.Forms


Proprietà DedFormSaveAs.Mdres

Proprietà DedFormSaveAsMdres
Restituisce le informazioni sul risultato del move

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public MoveDocumentResult Mdres { get; }
Public ReadOnly Property Mdres As MoveDocumentResult
    Get
public:
property MoveDocumentResult^ Mdres {
    MoveDocumentResult^ get ();
}
member Mdres : MoveDocumentResult with get

Valore della proprietà

MoveDocumentResult
Vedi anche

Documentazione

Classe DedFormSaveAs
Namespace DedNet.Forms


Proprietà DedFormSaveAs.Name

Proprietà DedFormSaveAsName
Nome del file in salvataggio

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedFormSaveAs
Namespace DedNet.Forms


Proprietà DedFormSaveAs.Path

Proprietà DedFormSaveAsPath
Percorso di salvataggio

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Path { get; set; }
Public Property Path As String
    Get
    Set
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}
member Path : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedFormSaveAs
Namespace DedNet.Forms


Metodi di DedFormSaveAs

Il tipo DedFormSaveAs espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormSaveAs
Namespace DedNet.Forms


Metodo DedFormSaveAs.Dispose

Metodo DedFormSaveAsDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormSaveAs
Namespace DedNet.Forms


Eventi di DedFormSaveAs

Il tipo DedFormSaveAs espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormSaveAs
Namespace DedNet.Forms


Campi di DedFormSaveAs

Il tipo DedFormSaveAs espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormSaveAs
Namespace DedNet.Forms


Enumerazione DedFormSaveModeEnum
Enumerazioni delle possibili configurazioni della finestra di salvataggio nel Database.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum DedFormSaveModeEnum
Public Enumeration DedFormSaveModeEnum
public enum class DedFormSaveModeEnum
type DedFormSaveModeEnum
Membri
Nome | Valore | Descrizione
None | 0 | Non specificato.
CreaAnagrafica | 1 | Crea anagrafica.
CreaRevisione | 2 | Crea revisione.
CreaVariante | 3 | Creazione di una variante.
Vedi anche

Documentazione

Namespace DedNet.Forms


Classe DedFormSettings
Controllo per la visualizzazione delle configurazioni di visualizzazione delle colonne nei comandi delle distinte (Edita, Visualizzazione...)
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormSettings

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormSettings : BaseForm
Public Class DedFormSettings
    Inherits BaseForm
public ref class DedFormSettings : public BaseForm
type DedFormSettings =
    class
        inherit BaseForm
    end

Il tipo DedFormSettings espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormSettings | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | ReloadOptions | Indica se bisogna effettuare la rilettura delle opzioni dei FindCodeControl.
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormSettings
Costruttore

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormSettings(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedFormSettings(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedFormSettings

Parametri

app DedNetApplication
Vedi anche

Documentazione

Classe DedFormSettings
Namespace DedNet.Forms


Proprietà di DedFormSettings

Il tipo DedFormSettings espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | ReloadOptions | Indica se bisogna effettuare la rilettura delle opzioni dei FindCodeControl.
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormSettings
Namespace DedNet.Forms


Proprietà DedFormSettings.ReloadOptions

Proprietà DedFormSettingsReloadOptions
Indica se bisogna effettuare la rilettura delle opzioni dei FindCodeControl.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ReloadOptions { get; set; }
Public Property ReloadOptions As Boolean
    Get
    Set
public:
property bool ReloadOptions {
    bool get ();
    void set (bool value);
}
member ReloadOptions : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormSettings
Namespace DedNet.Forms


Metodi di DedFormSettings

Il tipo DedFormSettings espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormSettings
Namespace DedNet.Forms


Metodo DedFormSettings.Dispose

Metodo DedFormSettingsDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormSettings
Namespace DedNet.Forms


Eventi di DedFormSettings

Il tipo DedFormSettings espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormSettings
Namespace DedNet.Forms


Campi di DedFormSettings

Il tipo DedFormSettings espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormSettings
Namespace DedNet.Forms


Classe DedFormStateManager
Dialogo che mostra le relazioni tra i vari stati di una anagrafica.
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormStateManager

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormStateManager : BaseForm
Public Class DedFormStateManager
    Inherits BaseForm
public ref class DedFormStateManager : public BaseForm
type DedFormStateManager =
    class
        inherit BaseForm
    end

Il tipo DedFormStateManager espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormStateManager | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà pubblica | StateToUpdate | Dizionario contenente le nuove icone degli stati da aggiornare/ripristinare.
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | navigationPane |
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Campo protetto | statePanel |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormStateManager
Costruttore unico.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormStateManager(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedFormStateManager(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedFormStateManager

Parametri

app DedNetApplication
DedNetApplication
Vedi anche

Documentazione

Classe DedFormStateManager
Namespace DedNet.Forms


Proprietà di DedFormStateManager

Il tipo DedFormStateManager espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà pubblica | StateToUpdate | Dizionario contenente le nuove icone degli stati da aggiornare/ripristinare.
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormStateManager
Namespace DedNet.Forms


Proprietà DedFormStateManager.StateToUpdate

Proprietà DedFormStateManagerStateToUpdate
Dizionario contenente le nuove icone degli stati da aggiornare/ripristinare.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<DedState, DedFormStateManagerUpdatedStateIcon> StateToUpdate { get; }
Public ReadOnly Property StateToUpdate As Dictionary(Of DedState, DedFormStateManagerUpdatedStateIcon)
    Get
public:
property Dictionary<DedState^, DedFormStateManagerUpdatedStateIcon^>^ StateToUpdate {
    Dictionary<DedState^, DedFormStateManagerUpdatedStateIcon^>^ get ();
}
member StateToUpdate : Dictionary<DedState, DedFormStateManagerUpdatedStateIcon> with get

Valore della proprietà

Dictionary DedState, DedFormStateManagerUpdatedStateIcon
Vedi anche

Documentazione

Classe DedFormStateManager
Namespace DedNet.Forms


Metodi di DedFormStateManager

Il tipo DedFormStateManager espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormStateManager
Namespace DedNet.Forms


Metodo DedFormStateManager.Dispose

Metodo DedFormStateManagerDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormStateManager
Namespace DedNet.Forms


Eventi di DedFormStateManager

Il tipo DedFormStateManager espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormStateManager
Namespace DedNet.Forms


Campi di DedFormStateManager

Il tipo DedFormStateManager espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | navigationPane |
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Campo protetto | statePanel |
Torna su
Vedi anche

Documentazione

Classe DedFormStateManager
Namespace DedNet.Forms


Campo DedFormStateManager.navigationPane

Campo DedFormStateManagernavigationPane

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected NavigationPane navigationPane
Protected navigationPane As NavigationPane
protected:
NavigationPane^ navigationPane
val mutable navigationPane: NavigationPane

Valore del campo

NavigationPane
Vedi anche

Documentazione

Classe DedFormStateManager
Namespace DedNet.Forms


Campo DedFormStateManager.statePanel

Campo DedFormStateManagerstatePanel

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected NavigationPage statePanel
Protected statePanel As NavigationPage
protected:
NavigationPage^ statePanel
val mutable statePanel: NavigationPage

Valore del campo

NavigationPage
Vedi anche

Documentazione

Classe DedFormStateManager
Namespace DedNet.Forms


Classe DedFormStateManager.UpdatedStateIcon

Classe DedFormStateManagerUpdatedStateIcon
Gerarchia di ereditarietà
SystemObject
DedNet.FormsDedFormStateManagerUpdatedStateIcon

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class UpdatedStateIcon
Public Class UpdatedStateIcon
public ref class UpdatedStateIcon
type UpdatedStateIcon = class end

Il tipo DedFormStateManagerUpdatedStateIcon espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormStateManagerUpdatedStateIcon |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormStateManager.UpdatedStateIcon

Costruttore DedFormStateManagerUpdatedStateIcon

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public UpdatedStateIcon()
Public Sub New
public:
UpdatedStateIcon()
new : unit -> UpdatedStateIcon
Vedi anche

Documentazione

Classe DedFormStateManagerUpdatedStateIcon
Namespace DedNet.Forms


Classe DedFormTime
Dialogo utilizzato per visualizzare/editare le temporizzazioni di anagrafiche, commesse, ECO, ecc...
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormTime

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormTime : BaseForm
Public Class DedFormTime
    Inherits BaseForm
public ref class DedFormTime : public BaseForm
type DedFormTime =
    class
        inherit BaseForm
    end

Il tipo DedFormTime espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormTime | Crea una nuova istanza della classe 'DedFormTiming' utilizzata per visualizzare/editare le temporizzazioni di anagrafiche, commesse, ECO, ecc...
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà pubblica | Source | Oggetto di cui si vogliono visualizzare/editare le temporizzazioni.
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo pubblico | ConvertToString | Ritorna una stringa, comprensibile all'utente, che identifica l'elemento corrente.
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormTime
Crea una nuova istanza della classe 'DedFormTiming' utilizzata per visualizzare/editare le temporizzazioni di anagrafiche, commesse, ECO, ecc...

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormTime(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedFormTime(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedFormTime

Parametri

app DedNetApplication
Vedi anche

Documentazione

Classe DedFormTime
Namespace DedNet.Forms


Proprietà di DedFormTime

Il tipo DedFormTime espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà pubblica | Source | Oggetto di cui si vogliono visualizzare/editare le temporizzazioni.
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormTime
Namespace DedNet.Forms


Proprietà DedFormTime.Source

Proprietà DedFormTimeSource
Oggetto di cui si vogliono visualizzare/editare le temporizzazioni.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTimedDbItem Source { set; }
Public WriteOnly Property Source As DedTimedDbItem
    Set
public:
property DedTimedDbItem^ Source {
    void set (DedTimedDbItem^ value);
}
member Source : DedTimedDbItem with set

Valore della proprietà

DedTimedDbItem
Vedi anche

Documentazione

Classe DedFormTime
Namespace DedNet.Forms


Metodi di DedFormTime

Il tipo DedFormTime espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo pubblico | ConvertToString | Ritorna una stringa, comprensibile all'utente, che identifica l'elemento corrente.
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormTime
Namespace DedNet.Forms


Metodo DedFormTime.ConvertToString

Metodo DedFormTimeConvertToString
Ritorna una stringa, comprensibile all'utente, che identifica l'elemento corrente.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string ConvertToString()
Public Function ConvertToString As String
public:
String^ ConvertToString()
member ConvertToString : unit -> string

Valore di ritorno

String
Vedi anche

Documentazione

Classe DedFormTime
Namespace DedNet.Forms


Metodo DedFormTime.Dispose

Metodo DedFormTimeDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormTime
Namespace DedNet.Forms


Eventi di DedFormTime

Il tipo DedFormTime espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormTime
Namespace DedNet.Forms


Campi di DedFormTime

Il tipo DedFormTime espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormTime
Namespace DedNet.Forms


Classe DedFormTime.CompareDedTime

Classe DedFormTimeCompareDedTime
Classe utilizzata per ordinare le temporizzazioni in base alla loro data di avvio.
Gerarchia di ereditarietà
SystemObject
DedNet.FormsDedFormTimeCompareDedTime

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class CompareDedTime : IComparer<DedTime>
Public Class CompareDedTime
    Implements IComparer(Of DedTime)
public ref class CompareDedTime : IComparer<DedTime^>
type CompareDedTime =
    class
        interface IComparer<DedTime>
    end

Il tipo DedFormTimeCompareDedTime espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormTimeCompareDedTime |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Compare | Metodo per comparare due oggetti.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormTime.CompareDedTime

Costruttore DedFormTimeCompareDedTime

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public CompareDedTime()
Public Sub New
public:
CompareDedTime()
new : unit -> CompareDedTime
Vedi anche

Documentazione

Classe DedFormTimeCompareDedTime
Namespace DedNet.Forms


Metodi di CompareDedTime

Il tipo DedFormTimeCompareDedTime espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Compare | Metodo per comparare due oggetti.
Torna su
Vedi anche

Documentazione

Classe DedFormTimeCompareDedTime
Namespace DedNet.Forms


Metodo DedFormTime.CompareDedTime.Compare

Metodo DedFormTimeCompareDedTimeCompare
Metodo per comparare due oggetti.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int Compare(
    DedTime x,
    DedTime y
)
Public Function Compare (
    x As DedTime,
    y As DedTime
) As Integer
public:
virtual int Compare(
    DedTime^ x,
    DedTime^ y
) sealed
abstract Compare :
        x : DedTime *
        y : DedTime -> int
override Compare :
        x : DedTime *
        y : DedTime -> int

Parametri

x DedTime
Oggetto x.
y DedTime
Oggetto y.

Valore di ritorno

Int32

Implementa

IComparerTCompare(T, T)
Vedi anche

Documentazione

Classe DedFormTimeCompareDedTime
Namespace DedNet.Forms


Classe DedFormTransferManager
Gestore richieste trasferimento
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormTransferManager

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormTransferManager : BaseForm
Public Class DedFormTransferManager
    Inherits BaseForm
public ref class DedFormTransferManager : public BaseForm
type DedFormTransferManager =
    class
        inherit BaseForm
    end

Il tipo DedFormTransferManager espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormTransferManager | Costruttore unico
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà pubblica | SendingCommandContext | Contesto effettivo del comando sul quale costruire la data source di invio
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà pubblica | TransferInitBehavior | Indica il comportamento iniziale per cui è stato lanciato il form
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | DrawGroupRowButton | Si occupa del rappresentazione grafica del pulsante sulle group row
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormTransferManager
Costruttore unico

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormTransferManager(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedFormTransferManager(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedFormTransferManager

Parametri

app DedNetApplication
Vedi anche

Documentazione

Classe DedFormTransferManager
Namespace DedNet.Forms


Proprietà di DedFormTransferManager

Il tipo DedFormTransferManager espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà pubblica | SendingCommandContext | Contesto effettivo del comando sul quale costruire la data source di invio
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà pubblica | TransferInitBehavior | Indica il comportamento iniziale per cui è stato lanciato il form
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormTransferManager
Namespace DedNet.Forms


Proprietà DedFormTransferManager.SendingCommandContext

Proprietà DedFormTransferManagerSendingCommandContext
Contesto effettivo del comando sul quale costruire la data source di invio

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedCommandContext SendingCommandContext { get; set; }
Public Property SendingCommandContext As DedCommandContext
    Get
    Set
public:
property DedCommandContext^ SendingCommandContext {
    DedCommandContext^ get ();
    void set (DedCommandContext^ value);
}
member SendingCommandContext : DedCommandContext with get, set

Valore della proprietà

DedCommandContext
Vedi anche

Documentazione

Classe DedFormTransferManager
Namespace DedNet.Forms


Proprietà DedFormTransferManager.TransferInitBehavior

Proprietà DedFormTransferManagerTransferInitBehavior
Indica il comportamento iniziale per cui è stato lanciato il form

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormTransferManagerTransferBehaviorEnum TransferInitBehavior { get; set; }
Public Property TransferInitBehavior As DedFormTransferManagerTransferBehaviorEnum
    Get
    Set
public:
property DedFormTransferManagerTransferBehaviorEnum TransferInitBehavior {
    DedFormTransferManagerTransferBehaviorEnum get ();
    void set (DedFormTransferManagerTransferBehaviorEnum value);
}
member TransferInitBehavior : DedFormTransferManagerTransferBehaviorEnum with get, set

Valore della proprietà

DedFormTransferManagerTransferBehaviorEnum
Vedi anche

Documentazione

Classe DedFormTransferManager
Namespace DedNet.Forms


Metodi di DedFormTransferManager

Il tipo DedFormTransferManager espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | DrawGroupRowButton | Si occupa del rappresentazione grafica del pulsante sulle group row
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormTransferManager
Namespace DedNet.Forms


Metodo DedFormTransferManager.Dispose

Metodo DedFormTransferManagerDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormTransferManager
Namespace DedNet.Forms


Metodo DedFormTransferManager.DrawGroupRowButton

Metodo DedFormTransferManagerDrawGroupRowButton
Si occupa del rappresentazione grafica del pulsante sulle group row

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected void DrawGroupRowButton(
    Graphics g,
    Rectangle r
)
Protected Sub DrawGroupRowButton (
    g As Graphics,
    r As Rectangle
)
protected:
void DrawGroupRowButton(
    Graphics^ g,
    Rectangle r
)
member DrawGroupRowButton :
        g : Graphics *
        r : Rectangle -> unit

Parametri

g Graphics
r Rectangle
Vedi anche

Documentazione

Classe DedFormTransferManager
Namespace DedNet.Forms


Eventi di DedFormTransferManager

Il tipo DedFormTransferManager espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormTransferManager
Namespace DedNet.Forms


Campi di DedFormTransferManager

Il tipo DedFormTransferManager espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormTransferManager
Namespace DedNet.Forms


Enumerazione DedFormTransferManager.TransferBehaviorEnum

Enumerazione DedFormTransferManagerTransferBehaviorEnum
Enum dei comportamenti iniziali del form

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum TransferBehaviorEnum
Public Enumeration TransferBehaviorEnum
public enum class TransferBehaviorEnum
type TransferBehaviorEnum
Membri
Nome | Valore | Descrizione
Send | 0 |
Import | 1 |
Vedi anche

Documentazione

Namespace DedNet.Forms


Classe DedFormTransferManagerOptions
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormTransferManagerOptions

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormTransferManagerOptions : BaseForm
Public Class DedFormTransferManagerOptions
    Inherits BaseForm
public ref class DedFormTransferManagerOptions : public BaseForm
type DedFormTransferManagerOptions =
    class
        inherit BaseForm
    end

Il tipo DedFormTransferManagerOptions espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormTransferManagerOptions | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormTransferManagerOptions
Costruttore

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormTransferManagerOptions(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedFormTransferManagerOptions(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedFormTransferManagerOptions

Parametri

app DedNetApplication
Vedi anche

Documentazione

Classe DedFormTransferManagerOptions
Namespace DedNet.Forms


Proprietà di DedFormTransferManagerOptions

Il tipo DedFormTransferManagerOptions espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormTransferManagerOptions
Namespace DedNet.Forms


Metodi di DedFormTransferManagerOptions

Il tipo DedFormTransferManagerOptions espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormTransferManagerOptions
Namespace DedNet.Forms


Metodo DedFormTransferManagerOptions.Dispose

Metodo DedFormTransferManagerOptionsDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormTransferManagerOptions
Namespace DedNet.Forms


Eventi di DedFormTransferManagerOptions

Il tipo DedFormTransferManagerOptions espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormTransferManagerOptions
Namespace DedNet.Forms


Campi di DedFormTransferManagerOptions

Il tipo DedFormTransferManagerOptions espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormTransferManagerOptions
Namespace DedNet.Forms


Classe DedFormTranslationsManager
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormTranslationsManager

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormTranslationsManager : BaseForm
Public Class DedFormTranslationsManager
    Inherits BaseForm
public ref class DedFormTranslationsManager : public BaseForm
type DedFormTranslationsManager =
    class
        inherit BaseForm
    end

Il tipo DedFormTranslationsManager espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormTranslationsManager | Crea e restituisce una nuova istanza del dialogo DedFormTranslationsManager utilizzato per gestire le traduzioni in lingua dei vari testi.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | AttributesList | Imposta la lista di attributi di cui si vuole editare le traduzioni.
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà pubblica | CustomTranslations | Indica di eseguirlo in modalità dizionario aziendale.
Proprietà pubblica | DataList | Imposta la lista delle anagrafiche di cui si vuole editare le traduzioni.
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormTranslationsManager
Crea e restituisce una nuova istanza del dialogo DedFormTranslationsManager utilizzato per gestire le traduzioni in lingua dei vari testi.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormTranslationsManager(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedFormTranslationsManager(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedFormTranslationsManager

Parametri

app DedNetApplication
Vedi anche

Documentazione

Classe DedFormTranslationsManager
Namespace DedNet.Forms


Proprietà di DedFormTranslationsManager

Il tipo DedFormTranslationsManager espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | AttributesList | Imposta la lista di attributi di cui si vuole editare le traduzioni.
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà pubblica | CustomTranslations | Indica di eseguirlo in modalità dizionario aziendale.
Proprietà pubblica | DataList | Imposta la lista delle anagrafiche di cui si vuole editare le traduzioni.
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormTranslationsManager
Namespace DedNet.Forms


Proprietà DedFormTranslationsManager.AttributesList

Proprietà DedFormTranslationsManagerAttributesList
Imposta la lista di attributi di cui si vuole editare le traduzioni.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<DedAttr> AttributesList { get; set; }
Public Property AttributesList As List(Of DedAttr)
    Get
    Set
public:
property List<DedAttr^>^ AttributesList {
    List<DedAttr^>^ get ();
    void set (List<DedAttr^>^ value);
}
member AttributesList : List<DedAttr> with get, set

Valore della proprietà

List DedAttr
Vedi anche

Documentazione

Classe DedFormTranslationsManager
Namespace DedNet.Forms


Proprietà DedFormTranslationsManager.CustomTranslations

Proprietà DedFormTranslationsManagerCustomTranslations
Indica di eseguirlo in modalità dizionario aziendale.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool CustomTranslations { get; set; }
Public Property CustomTranslations As Boolean
    Get
    Set
public:
property bool CustomTranslations {
    bool get ();
    void set (bool value);
}
member CustomTranslations : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormTranslationsManager
Namespace DedNet.Forms


Proprietà DedFormTranslationsManager.DataList

Proprietà DedFormTranslationsManagerDataList
Imposta la lista delle anagrafiche di cui si vuole editare le traduzioni.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDataList DataList { get; set; }
Public Property DataList As DedDataList
    Get
    Set
public:
property DedDataList^ DataList {
    DedDataList^ get ();
    void set (DedDataList^ value);
}
member DataList : DedDataList with get, set

Valore della proprietà

DedDataList
Vedi anche

Documentazione

Classe DedFormTranslationsManager
Namespace DedNet.Forms


Metodi di DedFormTranslationsManager

Il tipo DedFormTranslationsManager espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormTranslationsManager
Namespace DedNet.Forms


Metodo DedFormTranslationsManager.Dispose

Metodo DedFormTranslationsManagerDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormTranslationsManager
Namespace DedNet.Forms


Eventi di DedFormTranslationsManager

Il tipo DedFormTranslationsManager espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormTranslationsManager
Namespace DedNet.Forms


Campi di DedFormTranslationsManager

Il tipo DedFormTranslationsManager espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormTranslationsManager
Namespace DedNet.Forms


Classe DedFormUpdateOldRev
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormUpdateOldRev

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormUpdateOldRev : BaseForm
Public Class DedFormUpdateOldRev
    Inherits BaseForm
public ref class DedFormUpdateOldRev : public BaseForm
type DedFormUpdateOldRev =
    class
        inherit BaseForm
    end

Il tipo DedFormUpdateOldRev espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | ResultList | Restituisce la lista di elementi da aggiornare.
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowOnly | Indica se mostrare il form in visualizzazione.
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà pubblica | UpdateList | Imposta la lista degli elementi da visualizzare.
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | AggiornaRevEvent |
Evento pubblico | Apri |
Evento pubblico | ApriPadre |
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Evento pubblico | Individua |
Evento pubblico | TrovaDipendenze |
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Proprietà di DedFormUpdateOldRev

Il tipo DedFormUpdateOldRev espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | ResultList | Restituisce la lista di elementi da aggiornare.
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowOnly | Indica se mostrare il form in visualizzazione.
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà pubblica | UpdateList | Imposta la lista degli elementi da visualizzare.
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormUpdateOldRev
Namespace DedNet.Forms


Proprietà DedFormUpdateOldRev.ResultList

Proprietà DedFormUpdateOldRevResultList
Restituisce la lista di elementi da aggiornare.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ListObjToUpdate ResultList { get; }
Public ReadOnly Property ResultList As ListObjToUpdate
    Get
public:
property ListObjToUpdate^ ResultList {
    ListObjToUpdate^ get ();
}
member ResultList : ListObjToUpdate with get

Valore della proprietà

ListObjToUpdate
Vedi anche

Documentazione

Classe DedFormUpdateOldRev
Namespace DedNet.Forms


Proprietà DedFormUpdateOldRev.ShowOnly

Proprietà DedFormUpdateOldRevShowOnly
Indica se mostrare il form in visualizzazione.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ShowOnly { set; }
Public WriteOnly Property ShowOnly As Boolean
    Set
public:
property bool ShowOnly {
    void set (bool value);
}
member ShowOnly : bool with set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormUpdateOldRev
Namespace DedNet.Forms


Proprietà DedFormUpdateOldRev.UpdateList

Proprietà DedFormUpdateOldRevUpdateList
Imposta la lista degli elementi da visualizzare.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ListObjToUpdate UpdateList { set; }
Public WriteOnly Property UpdateList As ListObjToUpdate
    Set
public:
property ListObjToUpdate^ UpdateList {
    void set (ListObjToUpdate^ value);
}
member UpdateList : ListObjToUpdate with set

Valore della proprietà

ListObjToUpdate
Vedi anche

Documentazione

Classe DedFormUpdateOldRev
Namespace DedNet.Forms


Metodi di DedFormUpdateOldRev

Il tipo DedFormUpdateOldRev espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormUpdateOldRev
Namespace DedNet.Forms


Metodo DedFormUpdateOldRev.Dispose

Metodo DedFormUpdateOldRevDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormUpdateOldRev
Namespace DedNet.Forms


Eventi di DedFormUpdateOldRev

Il tipo DedFormUpdateOldRev espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | AggiornaRevEvent |
Evento pubblico | Apri |
Evento pubblico | ApriPadre |
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Evento pubblico | Individua |
Evento pubblico | TrovaDipendenze |
Torna su
Vedi anche

Documentazione

Classe DedFormUpdateOldRev
Namespace DedNet.Forms


Evento DedFormUpdateOldRev.AggiornaRevEvent

Evento DedFormUpdateOldRevAggiornaRevEvent

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event DedFormUpdateOldRevViewResult AggiornaRevEvent
Public Event AggiornaRevEvent As DedFormUpdateOldRevViewResult
public:
 event DedFormUpdateOldRevViewResult^ AggiornaRevEvent {
    void add (DedFormUpdateOldRevViewResult^ value);
    void remove (DedFormUpdateOldRevViewResult^ value);
}
member AggiornaRevEvent : IEvent<DedFormUpdateOldRevViewResult,
    EventArgs>

Valore

DedFormUpdateOldRevViewResult
Vedi anche

Documentazione

Classe DedFormUpdateOldRev
Namespace DedNet.Forms


Evento DedFormUpdateOldRev.Apri

Evento DedFormUpdateOldRevApri

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event DedFormUpdateOldRevAction Apri
Public Event Apri As DedFormUpdateOldRevAction
public:
 event DedFormUpdateOldRevAction^ Apri {
    void add (DedFormUpdateOldRevAction^ value);
    void remove (DedFormUpdateOldRevAction^ value);
}
member Apri : IEvent<DedFormUpdateOldRevAction,
    EventArgs>

Valore

DedFormUpdateOldRevAction
Vedi anche

Documentazione

Classe DedFormUpdateOldRev
Namespace DedNet.Forms


Evento DedFormUpdateOldRev.ApriPadre

Evento DedFormUpdateOldRevApriPadre

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event DedFormUpdateOldRevAction ApriPadre
Public Event ApriPadre As DedFormUpdateOldRevAction
public:
 event DedFormUpdateOldRevAction^ ApriPadre {
    void add (DedFormUpdateOldRevAction^ value);
    void remove (DedFormUpdateOldRevAction^ value);
}
member ApriPadre : IEvent<DedFormUpdateOldRevAction,
    EventArgs>

Valore

DedFormUpdateOldRevAction
Vedi anche

Documentazione

Classe DedFormUpdateOldRev
Namespace DedNet.Forms


Evento DedFormUpdateOldRev.Individua

Evento DedFormUpdateOldRevIndividua

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event DedFormUpdateOldRevAction Individua
Public Event Individua As DedFormUpdateOldRevAction
public:
 event DedFormUpdateOldRevAction^ Individua {
    void add (DedFormUpdateOldRevAction^ value);
    void remove (DedFormUpdateOldRevAction^ value);
}
member Individua : IEvent<DedFormUpdateOldRevAction,
    EventArgs>

Valore

DedFormUpdateOldRevAction
Vedi anche

Documentazione

Classe DedFormUpdateOldRev
Namespace DedNet.Forms


Evento DedFormUpdateOldRev.TrovaDipendenze

Evento DedFormUpdateOldRevTrovaDipendenze

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event DedFormUpdateOldRevAction TrovaDipendenze
Public Event TrovaDipendenze As DedFormUpdateOldRevAction
public:
 event DedFormUpdateOldRevAction^ TrovaDipendenze {
    void add (DedFormUpdateOldRevAction^ value);
    void remove (DedFormUpdateOldRevAction^ value);
}
member TrovaDipendenze : IEvent<DedFormUpdateOldRevAction,
    EventArgs>

Valore

DedFormUpdateOldRevAction
Vedi anche

Documentazione

Classe DedFormUpdateOldRev
Namespace DedNet.Forms


Campi di DedFormUpdateOldRev

Il tipo DedFormUpdateOldRev espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormUpdateOldRev
Namespace DedNet.Forms


Delegate DedFormUpdateOldRev.Action

Delegate DedFormUpdateOldRevAction

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public delegate void Action(
    ObjToUpdate obj
)
Public Delegate Sub Action (
    obj As ObjToUpdate
)
public delegate void Action(
    ObjToUpdate^ obj
)
type Action =
    delegate of
        obj : ObjToUpdate -> unit

Parametri

obj ObjToUpdate
Vedi anche

Documentazione

Namespace DedNet.Forms


Delegate DedFormUpdateOldRev.ViewResult

Delegate DedFormUpdateOldRevViewResult

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public delegate void ViewResult(
    ListObjToUpdate resultList
)
Public Delegate Sub ViewResult (
    resultList As ListObjToUpdate
)
public delegate void ViewResult(
    ListObjToUpdate^ resultList
)
type ViewResult =
    delegate of
        resultList : ListObjToUpdate -> unit

Parametri

resultList ListObjToUpdate
Vedi anche

Documentazione

Namespace DedNet.Forms


Classe DedFormUserPerm
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormUserPerm

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormUserPerm : BaseForm
Public Class DedFormUserPerm
    Inherits BaseForm
public ref class DedFormUserPerm : public BaseForm
type DedFormUserPerm =
    class
        inherit BaseForm
    end

Il tipo DedFormUserPerm espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormUserPerm | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormUserPerm
Costruttore unico.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormUserPerm(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedFormUserPerm(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedFormUserPerm

Parametri

app DedNetApplication
Vedi anche

Documentazione

Classe DedFormUserPerm
Namespace DedNet.Forms


Proprietà di DedFormUserPerm

Il tipo DedFormUserPerm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormUserPerm
Namespace DedNet.Forms


Metodi di DedFormUserPerm

Il tipo DedFormUserPerm espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormUserPerm
Namespace DedNet.Forms


Metodo DedFormUserPerm.Dispose

Metodo DedFormUserPermDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormUserPerm
Namespace DedNet.Forms


Eventi di DedFormUserPerm

Il tipo DedFormUserPerm espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormUserPerm
Namespace DedNet.Forms


Campi di DedFormUserPerm

Il tipo DedFormUserPerm espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormUserPerm
Namespace DedNet.Forms


Classe DedFormUserPerm.BoolWrapper

Classe DedFormUserPermBoolWrapper
Gerarchia di ereditarietà
SystemObject
DedNet.FormsDedFormUserPermBoolWrapper

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class BoolWrapper
Public Class BoolWrapper
public ref class BoolWrapper
type BoolWrapper = class end

Il tipo DedFormUserPermBoolWrapper espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormUserPermBoolWrapper |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Value |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormUserPerm.BoolWrapper

Costruttore DedFormUserPermBoolWrapper

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public BoolWrapper(
    bool value
)
Public Sub New (
    value As Boolean
)
public:
BoolWrapper(
    bool value
)
new :
        value : bool -> BoolWrapper

Parametri

value Boolean
Vedi anche

Documentazione

Classe DedFormUserPermBoolWrapper
Namespace DedNet.Forms


Proprietà di BoolWrapper

Il tipo DedFormUserPermBoolWrapper espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Value |
Torna su
Vedi anche

Documentazione

Classe DedFormUserPermBoolWrapper
Namespace DedNet.Forms


Proprietà DedFormUserPerm.BoolWrapper.Value

Proprietà DedFormUserPermBoolWrapperValue

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Value { get; set; }
Public Property Value As Boolean
    Get
    Set
public:
property bool Value {
    bool get ();
    void set (bool value);
}
member Value : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormUserPermBoolWrapper
Namespace DedNet.Forms


Classe DedFormVars
Form per la visualizzazione e la modifica delle variabili del DED.
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormVars

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormVars : BaseForm
Public Class DedFormVars
    Inherits BaseForm
public ref class DedFormVars : public BaseForm
type DedFormVars =
    class
        inherit BaseForm
    end

Il tipo DedFormVars espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormVars | Costruttore.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormVars
Costruttore.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormVars(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedFormVars(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedFormVars

Parametri

app DedNetApplication
Vedi anche

Documentazione

Classe DedFormVars
Namespace DedNet.Forms


Proprietà di DedFormVars

Il tipo DedFormVars espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormVars
Namespace DedNet.Forms


Metodi di DedFormVars

Il tipo DedFormVars espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormVars
Namespace DedNet.Forms


Metodo DedFormVars.Dispose

Metodo DedFormVarsDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormVars
Namespace DedNet.Forms


Eventi di DedFormVars

Il tipo DedFormVars espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormVars
Namespace DedNet.Forms


Campi di DedFormVars

Il tipo DedFormVars espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormVars
Namespace DedNet.Forms


Classe DedFormVisualDep
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormVisualDep

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormVisualDep : BaseForm
Public Class DedFormVisualDep
    Inherits BaseForm
public ref class DedFormVisualDep : public BaseForm
type DedFormVisualDep =
    class
        inherit BaseForm
    end

Il tipo DedFormVisualDep espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormVisualDep | Costruttore della classe.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà pubblica | Doc | Proprietà del documento da visualizzare nel diagramma
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà pubblica | IsFilterByAnagStateActive | Indica se il filtro sugli stati anagrafici è attivo
Proprietà pubblica | IsFilterByDocStateActive | Indica se il filtro sugli stati documentali è attivo
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo pubblico | SetCommandList | Rigenera il menu contestuale di questo controllo con la lista dei comandi passati.
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormVisualDep
Costruttore della classe.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormVisualDep(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedFormVisualDep(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedFormVisualDep

Parametri

app DedNetApplication
Oggetto applicazione di appartenenza.
Vedi anche

Documentazione

Classe DedFormVisualDep
Namespace DedNet.Forms


Proprietà di DedFormVisualDep

Il tipo DedFormVisualDep espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà pubblica | Doc | Proprietà del documento da visualizzare nel diagramma
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà pubblica | IsFilterByAnagStateActive | Indica se il filtro sugli stati anagrafici è attivo
Proprietà pubblica | IsFilterByDocStateActive | Indica se il filtro sugli stati documentali è attivo
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormVisualDep
Namespace DedNet.Forms


Proprietà DedFormVisualDep.Doc

Proprietà DedFormVisualDepDoc
Proprietà del documento da visualizzare nel diagramma

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDoc Doc { get; set; }
Public Property Doc As DedDoc
    Get
    Set
public:
property DedDoc^ Doc {
    DedDoc^ get ();
    void set (DedDoc^ value);
}
member Doc : DedDoc with get, set

Valore della proprietà

DedDoc
Vedi anche

Documentazione

Classe DedFormVisualDep
Namespace DedNet.Forms


Proprietà DedFormVisualDep.IsFilterByAnagStateActive

Proprietà DedFormVisualDepIsFilterByAnagStateActive
Indica se il filtro sugli stati anagrafici è attivo

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsFilterByAnagStateActive { get; }
Public ReadOnly Property IsFilterByAnagStateActive As Boolean
    Get
public:
property bool IsFilterByAnagStateActive {
    bool get ();
}
member IsFilterByAnagStateActive : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormVisualDep
Namespace DedNet.Forms


Proprietà DedFormVisualDep.IsFilterByDocStateActive

Proprietà DedFormVisualDepIsFilterByDocStateActive
Indica se il filtro sugli stati documentali è attivo

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsFilterByDocStateActive { get; }
Public ReadOnly Property IsFilterByDocStateActive As Boolean
    Get
public:
property bool IsFilterByDocStateActive {
    bool get ();
}
member IsFilterByDocStateActive : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormVisualDep
Namespace DedNet.Forms


Metodi di DedFormVisualDep

Il tipo DedFormVisualDep espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo pubblico | SetCommandList | Rigenera il menu contestuale di questo controllo con la lista dei comandi passati.
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormVisualDep
Namespace DedNet.Forms


Metodo DedFormVisualDep.Dispose

Metodo DedFormVisualDepDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormVisualDep
Namespace DedNet.Forms


Metodo DedFormVisualDep.SetCommandList

Metodo DedFormVisualDepSetCommandList
Rigenera il menu contestuale di questo controllo con la lista dei comandi passati.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SetCommandList(
    DedCommandList commandList,
    CommandContextEnum commandContext
)
Public Sub SetCommandList (
    commandList As DedCommandList,
    commandContext As CommandContextEnum
)
public:
void SetCommandList(
    DedCommandList^ commandList,
    CommandContextEnum commandContext
)
member SetCommandList :
        commandList : DedCommandList *
        commandContext : CommandContextEnum -> unit

Parametri

commandList DedCommandList
Lista completa dei comandi.
commandContext CommandContextEnum
Contesto da utilizzare per filtrare i comandi da inserire.
Note
Filtra i comandi in modo da aggiungere soltanto quelli coerenti con il contesto passato.
Vedi anche

Documentazione

Classe DedFormVisualDep
Namespace DedNet.Forms


Eventi di DedFormVisualDep

Il tipo DedFormVisualDep espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormVisualDep
Namespace DedNet.Forms


Campi di DedFormVisualDep

Il tipo DedFormVisualDep espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormVisualDep
Namespace DedNet.Forms


Classe DedFormWhereUsed
Form per visualizzare tutti i padri di un determinato documento (ovvero dove viene usato in altri documenti). Viene anche usato nel comando Apri file associato, utilizzando il secondo costruttore.
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedFormWhereUsed

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormWhereUsed : BaseForm
Public Class DedFormWhereUsed
    Inherits BaseForm
public ref class DedFormWhereUsed : public BaseForm
type DedFormWhereUsed =
    class
        inherit BaseForm
    end

Il tipo DedFormWhereUsed espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormWhereUsed(DedNetApplication, DedDoc) | Costruttore utilizzato allo scopo di visualizzare i documenti padri del documento passato ovvero proprio dal comando WhereUsedCommand.
Metodo pubblico | DedFormWhereUsed(DedNetApplication, DedDoc, Boolean) | Costruttore utilizzato allo scopo di visualizzare i documenti padri del documento passato ovvero proprio dal comando WhereUsedCommand.
Metodo pubblico | DedFormWhereUsed(DedNetApplication, DedDocList, Boolean) | Costruttore utilizzato allo scopo di selezionare i file associati di un particolare documento. ovvero per il comando OpenAssocFiles.
Metodo pubblico | DedFormWhereUsed(DedNetApplication, DedDoc, String, Boolean) | Costruttore utilizzato allo scopo di visualizzare i documenti padri del documento passato ovvero proprio dal comando WhereUsedCommand.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà pubblica | IsFileAssocMode | Restitusice se il form sia stato inizializzato per essere usato come selezione dei file associati.
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo pubblico | GetSelectedDocs | Restituisce la lista dei file selezionati. Restituisce sempre una lista inizializzata.
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedFormWhereUsed
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | DedFormWhereUsed(DedNetApplication, DedDoc) | Costruttore utilizzato allo scopo di visualizzare i documenti padri del documento passato ovvero proprio dal comando WhereUsedCommand.
Metodo pubblico | DedFormWhereUsed(DedNetApplication, DedDoc, Boolean) | Costruttore utilizzato allo scopo di visualizzare i documenti padri del documento passato ovvero proprio dal comando WhereUsedCommand.
Metodo pubblico | DedFormWhereUsed(DedNetApplication, DedDocList, Boolean) | Costruttore utilizzato allo scopo di selezionare i file associati di un particolare documento. ovvero per il comando OpenAssocFiles.
Metodo pubblico | DedFormWhereUsed(DedNetApplication, DedDoc, String, Boolean) | Costruttore utilizzato allo scopo di visualizzare i documenti padri del documento passato ovvero proprio dal comando WhereUsedCommand.
Torna su
Vedi anche

Documentazione

Classe DedFormWhereUsed
Namespace DedNet.Forms


Costruttore DedFormWhereUsed(DedNetApplication, DedDoc)
Costruttore utilizzato allo scopo di visualizzare i documenti padri del documento passato ovvero proprio dal comando WhereUsedCommand.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormWhereUsed(
    DedNetApplication app,
    DedDoc doc
)
Public Sub New (
    app As DedNetApplication,
    doc As DedDoc
)
public:
DedFormWhereUsed(
    DedNetApplication^ app,
    DedDoc^ doc
)
new :
        app : DedNetApplication *
        doc : DedDoc -> DedFormWhereUsed

Parametri

app DedNetApplication
Applicazione di riferimento.
doc DedDoc
Documento da elaborare.
Vedi anche

Documentazione

Classe DedFormWhereUsed
Overload di DedFormWhereUsed
Namespace DedNet.Forms


Costruttore DedFormWhereUsed(DedNetApplication, DedDoc, Boolean)
Costruttore utilizzato allo scopo di visualizzare i documenti padri del documento passato ovvero proprio dal comando WhereUsedCommand.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormWhereUsed(
    DedNetApplication app,
    DedDoc doc,
    bool showExtraData
)
Public Sub New (
    app As DedNetApplication,
    doc As DedDoc,
    showExtraData As Boolean
)
public:
DedFormWhereUsed(
    DedNetApplication^ app,
    DedDoc^ doc,
    bool showExtraData
)
new :
        app : DedNetApplication *
        doc : DedDoc *
        showExtraData : bool -> DedFormWhereUsed

Parametri

app DedNetApplication
Applicazione di riferimento.
doc DedDoc
Documento da elaborare.
showExtraData Boolean
Indica se visualizzare o meno i dati delle anagrafiche associate ai documenti.
Vedi anche

Documentazione

Classe DedFormWhereUsed
Overload di DedFormWhereUsed
Namespace DedNet.Forms


Costruttore DedFormWhereUsed(DedNetApplication, DedDocList, Boolean)
Costruttore utilizzato allo scopo di selezionare i file associati di un particolare documento. ovvero per il comando OpenAssocFiles.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormWhereUsed(
    DedNetApplication app,
    DedDocList docs,
    bool attach = false
)
Public Sub New (
    app As DedNetApplication,
    docs As DedDocList,
    Optional attach As Boolean = false
)
public:
DedFormWhereUsed(
    DedNetApplication^ app,
    DedDocList^ docs,
    bool attach = false
)
new :
        app : DedNetApplication *
        docs : DedDocList *
        ?attach : bool
(* Defaults:
        let _attach = defaultArg attach false
*)
-> DedFormWhereUsed

Parametri

app DedNetApplication
Applicazione di riferimento.
docs DedDocList
attach Boolean (Optional)
Vedi anche

Documentazione

Classe DedFormWhereUsed
Overload di DedFormWhereUsed
Namespace DedNet.Forms


Costruttore DedFormWhereUsed(DedNetApplication, DedDoc, String, Boolean)
Costruttore utilizzato allo scopo di visualizzare i documenti padri del documento passato ovvero proprio dal comando WhereUsedCommand.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormWhereUsed(
    DedNetApplication app,
    DedDoc doc,
    string config,
    bool showExtraData
)
Public Sub New (
    app As DedNetApplication,
    doc As DedDoc,
    config As String,
    showExtraData As Boolean
)
public:
DedFormWhereUsed(
    DedNetApplication^ app,
    DedDoc^ doc,
    String^ config,
    bool showExtraData
)
new :
        app : DedNetApplication *
        doc : DedDoc *
        config : string *
        showExtraData : bool -> DedFormWhereUsed

Parametri

app DedNetApplication
Applicazione di riferimento.
doc DedDoc
Documento da elaborare.
config String
Nome del model state attivo
showExtraData Boolean
Indica se visualizzare o meno i dati delle anagrafiche associate ai documenti.
Vedi anche

Documentazione

Classe DedFormWhereUsed
Overload di DedFormWhereUsed
Namespace DedNet.Forms


Proprietà di DedFormWhereUsed

Il tipo DedFormWhereUsed espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà pubblica | IsFileAssocMode | Restitusice se il form sia stato inizializzato per essere usato come selezione dei file associati.
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormWhereUsed
Namespace DedNet.Forms


Proprietà DedFormWhereUsed.IsFileAssocMode

Proprietà DedFormWhereUsedIsFileAssocMode
Restitusice se il form sia stato inizializzato per essere usato come selezione dei file associati.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsFileAssocMode { get; }
Public ReadOnly Property IsFileAssocMode As Boolean
    Get
public:
property bool IsFileAssocMode {
    bool get ();
}
member IsFileAssocMode : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormWhereUsed
Namespace DedNet.Forms


Metodi di DedFormWhereUsed

Il tipo DedFormWhereUsed espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo pubblico | GetSelectedDocs | Restituisce la lista dei file selezionati. Restituisce sempre una lista inizializzata.
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormWhereUsed
Namespace DedNet.Forms


Metodo DedFormWhereUsed.Dispose

Metodo DedFormWhereUsedDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormWhereUsed
Namespace DedNet.Forms


Metodo DedFormWhereUsed.GetSelectedDocs

Metodo DedFormWhereUsedGetSelectedDocs
Restituisce la lista dei file selezionati. Restituisce sempre una lista inizializzata.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedDocList GetSelectedDocs()
Public Function GetSelectedDocs As DedDocList
public:
DedDocList^ GetSelectedDocs()
member GetSelectedDocs : unit -> DedDocList

Valore di ritorno

DedDocList
Vedi anche

Documentazione

Classe DedFormWhereUsed
Namespace DedNet.Forms


Eventi di DedFormWhereUsed

Il tipo DedFormWhereUsed espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormWhereUsed
Namespace DedNet.Forms


Campi di DedFormWhereUsed

Il tipo DedFormWhereUsed espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormWhereUsed
Namespace DedNet.Forms


Classe DedOptionsForm
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsDedOptionsForm

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedOptionsForm : BaseForm
Public Class DedOptionsForm
    Inherits BaseForm
public ref class DedOptionsForm : public BaseForm
type DedOptionsForm =
    class
        inherit BaseForm
    end

Il tipo DedOptionsForm espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedOptionsForm | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà pubblica | NameValue | Nome del valore nella chiave di registro
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DedOptionsForm
Costruttore

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedOptionsForm(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedOptionsForm(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedOptionsForm

Parametri

app DedNetApplication
Vedi anche

Documentazione

Classe DedOptionsForm
Namespace DedNet.Forms


Proprietà di DedOptionsForm

Il tipo DedOptionsForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà pubblica | NameValue | Nome del valore nella chiave di registro
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedOptionsForm
Namespace DedNet.Forms


Proprietà DedOptionsForm.NameValue

Proprietà DedOptionsFormNameValue
Nome del valore nella chiave di registro

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string NameValue { get; set; }
Public Property NameValue As String
    Get
    Set
public:
property String^ NameValue {
    String^ get ();
    void set (String^ value);
}
member NameValue : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedOptionsForm
Namespace DedNet.Forms


Metodi di DedOptionsForm

Il tipo DedOptionsForm espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedOptionsForm
Namespace DedNet.Forms


Metodo DedOptionsForm.Dispose

Metodo DedOptionsFormDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedOptionsForm
Namespace DedNet.Forms


Eventi di DedOptionsForm

Il tipo DedOptionsForm espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedOptionsForm
Namespace DedNet.Forms


Campi di DedOptionsForm

Il tipo DedOptionsForm espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedOptionsForm
Namespace DedNet.Forms


Classe DocPropertyDescriptor
Classe che descrive una singola proprietà di documento all'interno della griglia.
Gerarchia di ereditarietà
SystemObject
DedNet.FormsDocPropertyDescriptor

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DocPropertyDescriptor
Public Class DocPropertyDescriptor
public ref class DocPropertyDescriptor
type DocPropertyDescriptor = class end

Il tipo DocPropertyDescriptor espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DocPropertyDescriptor | Costruttore.
Metodo pubblico | DocPropertyDescriptor(String) | Costruttore.
Metodo pubblico | DocPropertyDescriptor(String, ListString) | Costruttore.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | ExtensionList | Lista di estensioni che la contengono.
Proprietà pubblica | Name | Nome della proprietà.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DocPropertyDescriptor
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | DocPropertyDescriptor | Costruttore.
Metodo pubblico | DocPropertyDescriptor(String) | Costruttore.
Metodo pubblico | DocPropertyDescriptor(String, ListString) | Costruttore.
Torna su
Vedi anche

Documentazione

Classe DocPropertyDescriptor
Namespace DedNet.Forms


Costruttore DocPropertyDescriptor
Costruttore.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocPropertyDescriptor()
Public Sub New
public:
DocPropertyDescriptor()
new : unit -> DocPropertyDescriptor
Vedi anche

Documentazione

Classe DocPropertyDescriptor
Overload di DocPropertyDescriptor
Namespace DedNet.Forms


Costruttore DocPropertyDescriptor(String)
Costruttore.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocPropertyDescriptor(
    string name
)
Public Sub New (
    name As String
)
public:
DocPropertyDescriptor(
    String^ name
)
new :
        name : string -> DocPropertyDescriptor

Parametri

name String
Vedi anche

Documentazione

Classe DocPropertyDescriptor
Overload di DocPropertyDescriptor
Namespace DedNet.Forms


Costruttore DocPropertyDescriptor(String, List<String>)

Costruttore DocPropertyDescriptor(String, ListString)
Costruttore.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocPropertyDescriptor(
    string name,
    List<string> extensions
)
Public Sub New (
    name As String,
    extensions As List(Of String)
)
public:
DocPropertyDescriptor(
    String^ name,
    List<String^>^ extensions
)
new :
        name : string *
        extensions : List<string> -> DocPropertyDescriptor

Parametri

name String
extensions List String
Vedi anche

Documentazione

Classe DocPropertyDescriptor
Overload di DocPropertyDescriptor
Namespace DedNet.Forms


Proprietà di DocPropertyDescriptor

Il tipo DocPropertyDescriptor espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | ExtensionList | Lista di estensioni che la contengono.
Proprietà pubblica | Name | Nome della proprietà.
Torna su
Vedi anche

Documentazione

Classe DocPropertyDescriptor
Namespace DedNet.Forms


Proprietà DocPropertyDescriptor.ExtensionList

Proprietà DocPropertyDescriptorExtensionList
Lista di estensioni che la contengono.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<string> ExtensionList { get; set; }
Public Property ExtensionList As List(Of String)
    Get
    Set
public:
property List<String^>^ ExtensionList {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
member ExtensionList : List<string> with get, set

Valore della proprietà

List String
Vedi anche

Documentazione

Classe DocPropertyDescriptor
Namespace DedNet.Forms


Proprietà DocPropertyDescriptor.Name

Proprietà DocPropertyDescriptorName
Nome della proprietà.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DocPropertyDescriptor
Namespace DedNet.Forms


Classe DocPropertyDescriptorList
Lista di oggetti che descrivono una singola proprietà di documento all'interno della griglia.
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList DocPropertyDescriptor
DedNet.FormsDocPropertyDescriptorList

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DocPropertyDescriptorList : List<DocPropertyDescriptor>
Public Class DocPropertyDescriptorList
    Inherits List(Of DocPropertyDescriptor)
public ref class DocPropertyDescriptorList : public List<DocPropertyDescriptor^>
type DocPropertyDescriptorList =
    class
        inherit List<DocPropertyDescriptor>
    end

Il tipo DocPropertyDescriptorList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DocPropertyDescriptorList |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Contains | Ritorna True se all'interno della lista è presente una proprietà con il nome passato.
Metodo pubblico | FindByExtension | Ritorna la lista di proprietà contenuto all'interno dell'estensione passata. Se non ne esistono ritorna null
Metodo pubblico | FindByName | Ritorna la proprietà di documento corrispondente al nome passato. Se non esiste ritorna null.
Metodo pubblico | GetAllExtensions | Ritorna la lista di tutte le estensioni analizzate.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore DocPropertyDescriptorList

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocPropertyDescriptorList()
Public Sub New
public:
DocPropertyDescriptorList()
new : unit -> DocPropertyDescriptorList
Vedi anche

Documentazione

Classe DocPropertyDescriptorList
Namespace DedNet.Forms


Metodi di DocPropertyDescriptorList

Il tipo DocPropertyDescriptorList espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Contains | Ritorna True se all'interno della lista è presente una proprietà con il nome passato.
Metodo pubblico | FindByExtension | Ritorna la lista di proprietà contenuto all'interno dell'estensione passata. Se non ne esistono ritorna null
Metodo pubblico | FindByName | Ritorna la proprietà di documento corrispondente al nome passato. Se non esiste ritorna null.
Metodo pubblico | GetAllExtensions | Ritorna la lista di tutte le estensioni analizzate.
Torna su
Vedi anche

Documentazione

Classe DocPropertyDescriptorList
Namespace DedNet.Forms


Metodo DocPropertyDescriptorList.Contains

Metodo DocPropertyDescriptorListContains
Ritorna True se all'interno della lista è presente una proprietà con il nome passato.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Contains(
    string name
)
Public Function Contains (
    name As String
) As Boolean
public:
bool Contains(
    String^ name
)
member Contains :
        name : string -> bool

Parametri

name String
Nome della proprietà.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DocPropertyDescriptorList
Namespace DedNet.Forms


Metodo DocPropertyDescriptorList.FindByExtension

Metodo DocPropertyDescriptorListFindByExtension
Ritorna la lista di proprietà contenuto all'interno dell'estensione passata. Se non ne esistono ritorna null

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocPropertyDescriptorList FindByExtension(
    string ext
)
Public Function FindByExtension (
    ext As String
) As DocPropertyDescriptorList
public:
DocPropertyDescriptorList^ FindByExtension(
    String^ ext
)
member FindByExtension :
        ext : string -> DocPropertyDescriptorList

Parametri

ext String
Estensione (senza punto davanti).

Valore di ritorno

DocPropertyDescriptorList
Vedi anche

Documentazione

Classe DocPropertyDescriptorList
Namespace DedNet.Forms


Metodo DocPropertyDescriptorList.FindByName

Metodo DocPropertyDescriptorListFindByName
Ritorna la proprietà di documento corrispondente al nome passato. Se non esiste ritorna null.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DocPropertyDescriptor FindByName(
    string name
)
Public Function FindByName (
    name As String
) As DocPropertyDescriptor
public:
DocPropertyDescriptor^ FindByName(
    String^ name
)
member FindByName :
        name : string -> DocPropertyDescriptor

Parametri

name String
Nome della proprietà.

Valore di ritorno

DocPropertyDescriptor
Vedi anche

Documentazione

Classe DocPropertyDescriptorList
Namespace DedNet.Forms


Metodo DocPropertyDescriptorList.GetAllExtensions

Metodo DocPropertyDescriptorListGetAllExtensions
Ritorna la lista di tutte le estensioni analizzate.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string[] GetAllExtensions()
Public Function GetAllExtensions As String()
public:
array<String^>^ GetAllExtensions()
member GetAllExtensions : unit -> string[]

Valore di ritorno

String
Vedi anche

Documentazione

Classe DocPropertyDescriptorList
Namespace DedNet.Forms


Classe FolderBrowserDialogEx
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsCommonDialog
DedNet.FormsFolderBrowserDialogEx

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class FolderBrowserDialogEx : CommonDialog
Public Class FolderBrowserDialogEx
    Inherits CommonDialog
public ref class FolderBrowserDialogEx : public CommonDialog
type FolderBrowserDialogEx =
    class
        inherit CommonDialog
    end

Il tipo FolderBrowserDialogEx espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | FolderBrowserDialogEx |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Description | This description appears near the top of the dialog box, providing direction to the user.
Proprietà pubblica | DontIncludeNetworkFoldersBelowDomainLevel |
Proprietà pubblica | NewStyle | Set whether to use the New Folder Browser dialog style.
Proprietà pubblica | RootFolder |
Proprietà pubblica | SelectedPath | Set or get the selected path.
Proprietà pubblica | ShowBothFilesAndFolders |
Proprietà pubblica | ShowEditBox | Show an "edit box" in the folder browser.
Proprietà pubblica | ShowFullPathInEditBox | Show the full path in the edit box as the user selects it.
Proprietà pubblica | ShowNewFolderButton | Enable or disable the "New Folder" button in the browser dialog.
Torna su
Metodi
 | Nome | Descrizione
 | ComputerBrowser |
 | PrinterBrowser |
Metodo pubblico | Reset | (Sovrascrive CommonDialogReset)
Metodo protetto | RunDialog | (Sovrascrive CommonDialogRunDialog(IntPtr))
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | HelpRequest |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore FolderBrowserDialogEx

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public FolderBrowserDialogEx()
Public Sub New
public:
FolderBrowserDialogEx()
new : unit -> FolderBrowserDialogEx
Vedi anche

Documentazione

Classe FolderBrowserDialogEx
Namespace DedNet.Forms


Proprietà di FolderBrowserDialogEx

Il tipo FolderBrowserDialogEx espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Description | This description appears near the top of the dialog box, providing direction to the user.
Proprietà pubblica | DontIncludeNetworkFoldersBelowDomainLevel |
Proprietà pubblica | NewStyle | Set whether to use the New Folder Browser dialog style.
Proprietà pubblica | RootFolder |
Proprietà pubblica | SelectedPath | Set or get the selected path.
Proprietà pubblica | ShowBothFilesAndFolders |
Proprietà pubblica | ShowEditBox | Show an "edit box" in the folder browser.
Proprietà pubblica | ShowFullPathInEditBox | Show the full path in the edit box as the user selects it.
Proprietà pubblica | ShowNewFolderButton | Enable or disable the "New Folder" button in the browser dialog.
Torna su
Vedi anche

Documentazione

Classe FolderBrowserDialogEx
Namespace DedNet.Forms


Proprietà FolderBrowserDialogEx.Description

Proprietà FolderBrowserDialogExDescription
This description appears near the top of the dialog box, providing direction to the user.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
member Description : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe FolderBrowserDialogEx
Namespace DedNet.Forms


Proprietà FolderBrowserDialogEx.DontIncludeNetworkFoldersBelowDomainLevel

Proprietà FolderBrowserDialogExDontIncludeNetworkFoldersBelowDomainLevel

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool DontIncludeNetworkFoldersBelowDomainLevel { get; set; }
Public Property DontIncludeNetworkFoldersBelowDomainLevel As Boolean
    Get
    Set
public:
property bool DontIncludeNetworkFoldersBelowDomainLevel {
    bool get ();
    void set (bool value);
}
member DontIncludeNetworkFoldersBelowDomainLevel : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe FolderBrowserDialogEx
Namespace DedNet.Forms


Proprietà FolderBrowserDialogEx.NewStyle

Proprietà FolderBrowserDialogExNewStyle
Set whether to use the New Folder Browser dialog style.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool NewStyle { get; set; }
Public Property NewStyle As Boolean
    Get
    Set
public:
property bool NewStyle {
    bool get ();
    void set (bool value);
}
member NewStyle : bool with get, set

Valore della proprietà

Boolean
Note
The new style is resizable and includes a "New Folder" button.
Vedi anche

Documentazione

Classe FolderBrowserDialogEx
Namespace DedNet.Forms


Proprietà FolderBrowserDialogEx.RootFolder

Proprietà FolderBrowserDialogExRootFolder

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public EnvironmentSpecialFolder RootFolder { get; set; }
Public Property RootFolder As EnvironmentSpecialFolder
    Get
    Set
public:
property EnvironmentSpecialFolder RootFolder {
    EnvironmentSpecialFolder get ();
    void set (EnvironmentSpecialFolder value);
}
member RootFolder : EnvironmentSpecialFolder with get, set

Valore della proprietà

EnvironmentSpecialFolder
Vedi anche

Documentazione

Classe FolderBrowserDialogEx
Namespace DedNet.Forms


Proprietà FolderBrowserDialogEx.SelectedPath

Proprietà FolderBrowserDialogExSelectedPath
Set or get the selected path.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string SelectedPath { get; set; }
Public Property SelectedPath As String
    Get
    Set
public:
property String^ SelectedPath {
    String^ get ();
    void set (String^ value);
}
member SelectedPath : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe FolderBrowserDialogEx
Namespace DedNet.Forms


Proprietà FolderBrowserDialogEx.ShowBothFilesAndFolders

Proprietà FolderBrowserDialogExShowBothFilesAndFolders

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ShowBothFilesAndFolders { get; set; }
Public Property ShowBothFilesAndFolders As Boolean
    Get
    Set
public:
property bool ShowBothFilesAndFolders {
    bool get ();
    void set (bool value);
}
member ShowBothFilesAndFolders : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe FolderBrowserDialogEx
Namespace DedNet.Forms


Proprietà FolderBrowserDialogEx.ShowEditBox

Proprietà FolderBrowserDialogExShowEditBox
Show an "edit box" in the folder browser.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ShowEditBox { get; set; }
Public Property ShowEditBox As Boolean
    Get
    Set
public:
property bool ShowEditBox {
    bool get ();
    void set (bool value);
}
member ShowEditBox : bool with get, set

Valore della proprietà

Boolean
Note
The "edit box" normally shows the name of the selected folder. The user may also type a pathname directly into the edit box.
Vedi anche

Documentazione

Classe FolderBrowserDialogEx
Namespace DedNet.Forms
ShowFullPathInEditBox


Proprietà FolderBrowserDialogEx.ShowFullPathInEditBox

Proprietà FolderBrowserDialogExShowFullPathInEditBox
Show the full path in the edit box as the user selects it.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ShowFullPathInEditBox { get; set; }
Public Property ShowFullPathInEditBox As Boolean
    Get
    Set
public:
property bool ShowFullPathInEditBox {
    bool get ();
    void set (bool value);
}
member ShowFullPathInEditBox : bool with get, set

Valore della proprietà

Boolean
Note
This works only if ShowEditBox is also set to true.
Vedi anche

Documentazione

Classe FolderBrowserDialogEx
Namespace DedNet.Forms


Proprietà FolderBrowserDialogEx.ShowNewFolderButton

Proprietà FolderBrowserDialogExShowNewFolderButton
Enable or disable the "New Folder" button in the browser dialog.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ShowNewFolderButton { get; set; }
Public Property ShowNewFolderButton As Boolean
    Get
    Set
public:
property bool ShowNewFolderButton {
    bool get ();
    void set (bool value);
}
member ShowNewFolderButton : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe FolderBrowserDialogEx
Namespace DedNet.Forms


Metodi di FolderBrowserDialogEx

Il tipo FolderBrowserDialogEx espone i seguenti membri.

Metodi
 | Nome | Descrizione
 | ComputerBrowser |
 | PrinterBrowser |
Metodo pubblico | Reset | (Sovrascrive CommonDialogReset)
Metodo protetto | RunDialog | (Sovrascrive CommonDialogRunDialog(IntPtr))
Torna su
Vedi anche

Documentazione

Classe FolderBrowserDialogEx
Namespace DedNet.Forms


Metodo FolderBrowserDialogEx.ComputerBrowser

Metodo FolderBrowserDialogExComputerBrowser

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static FolderBrowserDialogEx ComputerBrowser()
Public Shared Function ComputerBrowser As FolderBrowserDialogEx
public:
static FolderBrowserDialogEx^ ComputerBrowser()
static member ComputerBrowser : unit -> FolderBrowserDialogEx

Valore di ritorno

FolderBrowserDialogEx
Vedi anche

Documentazione

Classe FolderBrowserDialogEx
Namespace DedNet.Forms


Metodo FolderBrowserDialogEx.PrinterBrowser

Metodo FolderBrowserDialogExPrinterBrowser

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static FolderBrowserDialogEx PrinterBrowser()
Public Shared Function PrinterBrowser As FolderBrowserDialogEx
public:
static FolderBrowserDialogEx^ PrinterBrowser()
static member PrinterBrowser : unit -> FolderBrowserDialogEx

Valore di ritorno

FolderBrowserDialogEx
Vedi anche

Documentazione

Classe FolderBrowserDialogEx
Namespace DedNet.Forms


Metodo FolderBrowserDialogEx.Reset

Metodo FolderBrowserDialogExReset

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override void Reset()
Public Overrides Sub Reset
public:
virtual void Reset() override
abstract Reset : unit -> unit
override Reset : unit -> unit
Vedi anche

Documentazione

Classe FolderBrowserDialogEx
Namespace DedNet.Forms


Metodo FolderBrowserDialogEx.RunDialog

Metodo FolderBrowserDialogExRunDialog

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override bool RunDialog(
    IntPtr hWndOwner
)
Protected Overrides Function RunDialog (
    hWndOwner As IntPtr
) As Boolean
protected:
virtual bool RunDialog(
    IntPtr hWndOwner
) override
abstract RunDialog :
        hWndOwner : IntPtr -> bool
override RunDialog :
        hWndOwner : IntPtr -> bool

Parametri

hWndOwner IntPtr

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe FolderBrowserDialogEx
Namespace DedNet.Forms


Eventi di FolderBrowserDialogEx

Il tipo FolderBrowserDialogEx espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | HelpRequest |
Torna su
Vedi anche

Documentazione

Classe FolderBrowserDialogEx
Namespace DedNet.Forms


Evento FolderBrowserDialogEx.HelpRequest

Evento FolderBrowserDialogExHelpRequest

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler HelpRequest
Public Event HelpRequest As EventHandler
public:
 event EventHandler^ HelpRequest {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member HelpRequest : IEvent<EventHandler,
    EventArgs>

Valore

EventHandler
Vedi anche

Documentazione

Classe FolderBrowserDialogEx
Namespace DedNet.Forms


Classe ListObjToUpdate
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList ObjToUpdate
DedNet.FormsListObjToUpdate

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ListObjToUpdate : List<ObjToUpdate>
Public Class ListObjToUpdate
    Inherits List(Of ObjToUpdate)
public ref class ListObjToUpdate : public List<ObjToUpdate^>
type ListObjToUpdate =
    class
        inherit List<ObjToUpdate>
    end

Il tipo ListObjToUpdate espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ListObjToUpdate |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | GetAllContexts | Ritorna l'elenco dei contesti definiti nella lista
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore ListObjToUpdate

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ListObjToUpdate()
Public Sub New
public:
ListObjToUpdate()
new : unit -> ListObjToUpdate
Vedi anche

Documentazione

Classe ListObjToUpdate
Namespace DedNet.Forms


Metodi di ListObjToUpdate

Il tipo ListObjToUpdate espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | GetAllContexts | Ritorna l'elenco dei contesti definiti nella lista
Torna su
Vedi anche

Documentazione

Classe ListObjToUpdate
Namespace DedNet.Forms


Metodo ListObjToUpdate.GetAllContexts

Metodo ListObjToUpdateGetAllContexts
Ritorna l'elenco dei contesti definiti nella lista

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ObjUpdContexts GetAllContexts()
Public Function GetAllContexts As ObjUpdContexts
public:
ObjUpdContexts^ GetAllContexts()
member GetAllContexts : unit -> ObjUpdContexts

Valore di ritorno

ObjUpdContexts
Vedi anche

Documentazione

Classe ListObjToUpdate
Namespace DedNet.Forms


Classe ModificaGruppoForm
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsModificaGruppoForm

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ModificaGruppoForm : BaseForm
Public Class ModificaGruppoForm
    Inherits BaseForm
public ref class ModificaGruppoForm : public BaseForm
type ModificaGruppoForm =
    class
        inherit BaseForm
    end

Il tipo ModificaGruppoForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo pubblico | VisMsg | Visualizza un messaggio all'utente con il solo pulsante OK.
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Proprietà di ModificaGruppoForm

Il tipo ModificaGruppoForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe ModificaGruppoForm
Namespace DedNet.Forms


Metodi di ModificaGruppoForm

Il tipo ModificaGruppoForm espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo pubblico | VisMsg | Visualizza un messaggio all'utente con il solo pulsante OK.
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe ModificaGruppoForm
Namespace DedNet.Forms


Metodo ModificaGruppoForm.Dispose

Metodo ModificaGruppoFormDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe ModificaGruppoForm
Namespace DedNet.Forms


Metodo ModificaGruppoForm.VisMsg

Metodo ModificaGruppoFormVisMsg
Visualizza un messaggio all'utente con il solo pulsante OK.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void VisMsg(
    string msg,
    MessageBoxIcon ico
)
Public Sub VisMsg (
    msg As String,
    ico As MessageBoxIcon
)
public:
void VisMsg(
    String^ msg,
    MessageBoxIcon ico
)
member VisMsg :
        msg : string *
        ico : MessageBoxIcon -> unit

Parametri

msg String
Messaggio da visualizzare.
ico MessageBoxIcon
Icona da abbinare al messaggio.
Vedi anche

Documentazione

Classe ModificaGruppoForm
Namespace DedNet.Forms


Eventi di ModificaGruppoForm

Il tipo ModificaGruppoForm espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe ModificaGruppoForm
Namespace DedNet.Forms


Campi di ModificaGruppoForm

Il tipo ModificaGruppoForm espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe ModificaGruppoForm
Namespace DedNet.Forms


Classe ModificaUtenteForm
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsModificaUtenteForm

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ModificaUtenteForm : BaseForm
Public Class ModificaUtenteForm
    Inherits BaseForm
public ref class ModificaUtenteForm : public BaseForm
type ModificaUtenteForm =
    class
        inherit BaseForm
    end

Il tipo ModificaUtenteForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo pubblico | VisMsg | Visualizza un messaggio all'utente con il solo pulsante OK.
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Proprietà di ModificaUtenteForm

Il tipo ModificaUtenteForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe ModificaUtenteForm
Namespace DedNet.Forms


Metodi di ModificaUtenteForm

Il tipo ModificaUtenteForm espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo pubblico | VisMsg | Visualizza un messaggio all'utente con il solo pulsante OK.
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe ModificaUtenteForm
Namespace DedNet.Forms


Metodo ModificaUtenteForm.Dispose

Metodo ModificaUtenteFormDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe ModificaUtenteForm
Namespace DedNet.Forms


Metodo ModificaUtenteForm.VisMsg

Metodo ModificaUtenteFormVisMsg
Visualizza un messaggio all'utente con il solo pulsante OK.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void VisMsg(
    string msg,
    MessageBoxIcon ico
)
Public Sub VisMsg (
    msg As String,
    ico As MessageBoxIcon
)
public:
void VisMsg(
    String^ msg,
    MessageBoxIcon ico
)
member VisMsg :
        msg : string *
        ico : MessageBoxIcon -> unit

Parametri

msg String
Messaggio da visualizzare.
ico MessageBoxIcon
Icona da abbinare al messaggio.
Vedi anche

Documentazione

Classe ModificaUtenteForm
Namespace DedNet.Forms


Eventi di ModificaUtenteForm

Il tipo ModificaUtenteForm espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe ModificaUtenteForm
Namespace DedNet.Forms


Campi di ModificaUtenteForm

Il tipo ModificaUtenteForm espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe ModificaUtenteForm
Namespace DedNet.Forms


Classe MyBindingList<TranslationWrapperItem>

Classe MyBindingListTranslationWrapperItem
Ridefinisce la BindingList per avere un evento di BeforeRemove in modo da poter apportare le modifiche anche alla reale datasource
Gerarchia di ereditarietà
SystemObject
System.Collections.ObjectModelCollection TranslationWrapperItem
System.ComponentModelBindingList TranslationWrapperItem
DedNet.FormsMyBindingListTranslationWrapperItem

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class MyBindingList<TranslationWrapperItem> : BindingList<TranslationWrapperItem>

Public Class MyBindingList(Of TranslationWrapperItem)
    Inherits BindingList(Of TranslationWrapperItem)
generic<typename TranslationWrapperItem>
public ref class MyBindingList : public BindingList<TranslationWrapperItem>
type MyBindingList<'TranslationWrapperItem> =
    class
        inherit BindingList<'TranslationWrapperItem>
    end

Parametri di tipo

TranslationWrapperItem

Il tipo MyBindingListTranslationWrapperItem espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | MyBindingListTranslationWrapperItem |
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | RemoveItem | (Sovrascrive BindingListTRemoveItem(Int32))
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | BeforeRemove |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore MyBindingList<TranslationWrapperItem>

Costruttore MyBindingListTranslationWrapperItem

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public MyBindingList()
Public Sub New
public:
MyBindingList()
new : unit -> MyBindingList
Vedi anche

Documentazione

Classe MyBindingListTranslationWrapperItem
Namespace DedNet.Forms


Metodi di MyBindingList<TranslationWrapperItem>

Metodi di MyBindingListTranslationWrapperItem

Il tipo MyBindingListTranslationWrapperItem espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | RemoveItem | (Sovrascrive BindingListTRemoveItem(Int32))
Torna su
Vedi anche

Documentazione

Classe MyBindingListTranslationWrapperItem
Namespace DedNet.Forms


Metodo MyBindingList<TranslationWrapperItem>.RemoveItem

Metodo MyBindingListTranslationWrapperItemRemoveItem

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void RemoveItem(
    int itemIndex
)
Protected Overrides Sub RemoveItem (
    itemIndex As Integer
)
protected:
virtual void RemoveItem(
    int itemIndex
) override
abstract RemoveItem :
        itemIndex : int -> unit
override RemoveItem :
        itemIndex : int -> unit

Parametri

itemIndex Int32
Vedi anche

Documentazione

Classe MyBindingListTranslationWrapperItem
Namespace DedNet.Forms


Eventi di MyBindingList<TranslationWrapperItem>

Eventi di MyBindingListTranslationWrapperItem

Il tipo MyBindingListTranslationWrapperItem espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | BeforeRemove |
Torna su
Vedi anche

Documentazione

Classe MyBindingListTranslationWrapperItem
Namespace DedNet.Forms


Evento MyBindingList<TranslationWrapperItem>.BeforeRemove

Evento MyBindingListTranslationWrapperItemBeforeRemove

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event MyBindingListTranslationWrapperItemMyTranslationWrapperItemDelegate BeforeRemove
Public Event BeforeRemove As MyBindingListTranslationWrapperItemMyTranslationWrapperItemDelegate
public:
 event MyBindingListTranslationWrapperItemMyTranslationWrapperItemDelegate^ BeforeRemove {
    void add (MyBindingListTranslationWrapperItemMyTranslationWrapperItemDelegate^ value);
    void remove (MyBindingListTranslationWrapperItemMyTranslationWrapperItemDelegate^ value);
}
member BeforeRemove : IEvent<MyBindingListTranslationWrapperItemMyTranslationWrapperItemDelegate,
    EventArgs>

Valore

MyBindingListTranslationWrapperItemMyTranslationWrapperItemDelegate
Vedi anche

Documentazione

Classe MyBindingListTranslationWrapperItem
Namespace DedNet.Forms


Delegate MyBindingList<TranslationWrapperItem>.MyTranslationWrapperItemDelegate

Delegate MyBindingListTranslationWrapperItemMyTranslationWrapperItemDelegate

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public delegate void MyTranslationWrapperItemDelegate(
    TranslationWrapperItem deletedItem
)
Public Delegate Sub MyTranslationWrapperItemDelegate (
    deletedItem As TranslationWrapperItem
)
public delegate void MyTranslationWrapperItemDelegate(
    TranslationWrapperItem deletedItem
)
type MyTranslationWrapperItemDelegate =
    delegate of
        deletedItem : 'TranslationWrapperItem -> unit

Parametri

deletedItem TranslationWrapperItem
Vedi anche

Documentazione

Namespace DedNet.Forms


Classe ObjToUpdate
Oggetto utilizzato per bindare la lista.
Gerarchia di ereditarietà
SystemObject
DedNet.FormsObjToUpdate

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ObjToUpdate
Public Class ObjToUpdate
public ref class ObjToUpdate
type ObjToUpdate = class end

Il tipo ObjToUpdate espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ObjToUpdate | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Check | Indica se l'elemento è selezionato o no.
Proprietà pubblica | Checkable |
Proprietà pubblica | Config |
Proprietà pubblica | Contesto | Restituisce il contesto di aggiornamento
Proprietà pubblica | Data | Restituisce l'ultima revisione.
Proprietà pubblica | Descrizione | Restituisce la descrizione.
Proprietà pubblica | ElaborationIsGood | Indica se il ObjTuUpdate è stato elaborato con esito positivo
Proprietà pubblica | Ext | Imposta/restituisce l'estensione dell'elemento senza il punto.
Proprietà pubblica | FileExist | Imposta/restiruisce se il file da sostituire è presente.
Proprietà pubblica | NewDedData | Restituisce l'ultima revisione.
Proprietà pubblica | Note | Restituuisce le note relative al record.
Proprietà pubblica | Obj | Oggetto che rappresenta il record.
Proprietà pubblica | Pdr | Restituisce l'anagrafica del genitore.
Proprietà pubblica | Result | Esito dell'aggiornamento che viene visualizzato nella griglia
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore ObjToUpdate
Costruttore unico.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ObjToUpdate(
    Object obj,
    DedData data,
    string descrizione,
    string ext
)
Public Sub New (
    obj As Object,
    data As DedData,
    descrizione As String,
    ext As String
)
public:
ObjToUpdate(
    Object^ obj,
    DedData^ data,
    String^ descrizione,
    String^ ext
)
new :
        obj : Object *
        data : DedData *
        descrizione : string *
        ext : string -> ObjToUpdate

Parametri

obj Object
Oggetto che rappresenta l'elemento.
data DedData
descrizione String
Descrizione dell'elemento (se non impostata viene presa dal record.)
ext String
Vedi anche

Documentazione

Classe ObjToUpdate
Namespace DedNet.Forms


Proprietà di ObjToUpdate

Il tipo ObjToUpdate espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Check | Indica se l'elemento è selezionato o no.
Proprietà pubblica | Checkable |
Proprietà pubblica | Config |
Proprietà pubblica | Contesto | Restituisce il contesto di aggiornamento
Proprietà pubblica | Data | Restituisce l'ultima revisione.
Proprietà pubblica | Descrizione | Restituisce la descrizione.
Proprietà pubblica | ElaborationIsGood | Indica se il ObjTuUpdate è stato elaborato con esito positivo
Proprietà pubblica | Ext | Imposta/restituisce l'estensione dell'elemento senza il punto.
Proprietà pubblica | FileExist | Imposta/restiruisce se il file da sostituire è presente.
Proprietà pubblica | NewDedData | Restituisce l'ultima revisione.
Proprietà pubblica | Note | Restituuisce le note relative al record.
Proprietà pubblica | Obj | Oggetto che rappresenta il record.
Proprietà pubblica | Pdr | Restituisce l'anagrafica del genitore.
Proprietà pubblica | Result | Esito dell'aggiornamento che viene visualizzato nella griglia
Torna su
Vedi anche

Documentazione

Classe ObjToUpdate
Namespace DedNet.Forms


Proprietà ObjToUpdate.Check

Proprietà ObjToUpdateCheck
Indica se l'elemento è selezionato o no.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Check { get; set; }
Public Property Check As Boolean
    Get
    Set
public:
property bool Check {
    bool get ();
    void set (bool value);
}
member Check : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ObjToUpdate
Namespace DedNet.Forms


Proprietà ObjToUpdate.Checkable

Proprietà ObjToUpdateCheckable

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Checkable { get; set; }
Public Property Checkable As Boolean
    Get
    Set
public:
property bool Checkable {
    bool get ();
    void set (bool value);
}
member Checkable : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ObjToUpdate
Namespace DedNet.Forms


Proprietà ObjToUpdate.Config

Proprietà ObjToUpdateConfig

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Config { get; set; }
Public Property Config As String
    Get
    Set
public:
property String^ Config {
    String^ get ();
    void set (String^ value);
}
member Config : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe ObjToUpdate
Namespace DedNet.Forms


Proprietà ObjToUpdate.Contesto

Proprietà ObjToUpdateContesto
Restituisce il contesto di aggiornamento

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ObjUpdContext Contesto { get; set; }
Public Property Contesto As ObjUpdContext
    Get
    Set
public:
property ObjUpdContext^ Contesto {
    ObjUpdContext^ get ();
    void set (ObjUpdContext^ value);
}
member Contesto : ObjUpdContext with get, set

Valore della proprietà

ObjUpdContext
Vedi anche

Documentazione

Classe ObjToUpdate
Namespace DedNet.Forms


Proprietà ObjToUpdate.Data

Proprietà ObjToUpdateData
Restituisce l'ultima revisione.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; }
Public ReadOnly Property Data As DedData
    Get
public:
property DedData^ Data {
    DedData^ get ();
}
member Data : DedData with get

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe ObjToUpdate
Namespace DedNet.Forms


Proprietà ObjToUpdate.Descrizione

Proprietà ObjToUpdateDescrizione
Restituisce la descrizione.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Descrizione { get; set; }
Public Property Descrizione As String
    Get
    Set
public:
property String^ Descrizione {
    String^ get ();
    void set (String^ value);
}
member Descrizione : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe ObjToUpdate
Namespace DedNet.Forms


Proprietà ObjToUpdate.ElaborationIsGood

Proprietà ObjToUpdateElaborationIsGood
Indica se il ObjTuUpdate è stato elaborato con esito positivo

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ElaborationIsGood { get; set; }
Public Property ElaborationIsGood As Boolean
    Get
    Set
public:
property bool ElaborationIsGood {
    bool get ();
    void set (bool value);
}
member ElaborationIsGood : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ObjToUpdate
Namespace DedNet.Forms


Proprietà ObjToUpdate.Ext

Proprietà ObjToUpdateExt
Imposta/restituisce l'estensione dell'elemento senza il punto.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Ext { get; set; }
Public Property Ext As String
    Get
    Set
public:
property String^ Ext {
    String^ get ();
    void set (String^ value);
}
member Ext : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe ObjToUpdate
Namespace DedNet.Forms


Proprietà ObjToUpdate.FileExist

Proprietà ObjToUpdateFileExist
Imposta/restiruisce se il file da sostituire è presente.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool FileExist { get; set; }
Public Property FileExist As Boolean
    Get
    Set
public:
property bool FileExist {
    bool get ();
    void set (bool value);
}
member FileExist : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ObjToUpdate
Namespace DedNet.Forms


Proprietà ObjToUpdate.NewDedData

Proprietà ObjToUpdateNewDedData
Restituisce l'ultima revisione.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData NewDedData { get; }
Public ReadOnly Property NewDedData As DedData
    Get
public:
property DedData^ NewDedData {
    DedData^ get ();
}
member NewDedData : DedData with get

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe ObjToUpdate
Namespace DedNet.Forms


Proprietà ObjToUpdate.Note

Proprietà ObjToUpdateNote
Restituuisce le note relative al record.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Note { get; }
Public ReadOnly Property Note As String
    Get
public:
property String^ Note {
    String^ get ();
}
member Note : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe ObjToUpdate
Namespace DedNet.Forms


Proprietà ObjToUpdate.Obj

Proprietà ObjToUpdateObj
Oggetto che rappresenta il record.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object Obj { get; set; }
Public Property Obj As Object
    Get
    Set
public:
property Object^ Obj {
    Object^ get ();
    void set (Object^ value);
}
member Obj : Object with get, set

Valore della proprietà

Object
Vedi anche

Documentazione

Classe ObjToUpdate
Namespace DedNet.Forms


Proprietà ObjToUpdate.Pdr

Proprietà ObjToUpdatePdr
Restituisce l'anagrafica del genitore.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedData Pdr { get; set; }
Public Property Pdr As DedData
    Get
    Set
public:
property DedData^ Pdr {
    DedData^ get ();
    void set (DedData^ value);
}
member Pdr : DedData with get, set

Valore della proprietà

DedData
Vedi anche

Documentazione

Classe ObjToUpdate
Namespace DedNet.Forms


Proprietà ObjToUpdate.Result

Proprietà ObjToUpdateResult
Esito dell'aggiornamento che viene visualizzato nella griglia

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Result { get; set; }
Public Property Result As String
    Get
    Set
public:
property String^ Result {
    String^ get ();
    void set (String^ value);
}
member Result : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe ObjToUpdate
Namespace DedNet.Forms


Metodi di ObjToUpdate

Il tipo ObjToUpdate espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode)
Torna su
Vedi anche

Documentazione

Classe ObjToUpdate
Namespace DedNet.Forms


Metodo ObjToUpdate.Equals

Metodo ObjToUpdateEquals

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj Object

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe ObjToUpdate
Namespace DedNet.Forms


Metodo ObjToUpdate.GetHashCode

Metodo ObjToUpdateGetHashCode

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe ObjToUpdate
Namespace DedNet.Forms


Classe ObjUpdContext
Oggetto descrittore di contesto
Gerarchia di ereditarietà
SystemObject
DedNet.FormsObjUpdContext

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ObjUpdContext : IComparable
Public Class ObjUpdContext
    Implements IComparable
public ref class ObjUpdContext : IComparable
type ObjUpdContext =
    class
        interface IComparable
    end

Il tipo ObjUpdContext espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ObjUpdContext | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | FullFileName | File name completo associato al contesto
Proprietà pubblica | Name | Nome del contesto
Proprietà pubblica | Primary | Indica se il contesto è primario o meno
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | CompareTo | Implemento il CompareTo per il raggruppamento sul form
Metodo pubblico | Equals | Ridefinizione di uguaglianza. (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetHashCode | Restituisce l'HashCode di questo oggetto. (Sovrascrive ObjectGetHashCode)
Metodo pubblico | ToString | Restituisce una rappresentazione stringa di questo oggetto. (Sovrascrive ObjectToString)
Torna su
Operatori
Nome | Descrizione
Equality(ObjUpdContext, ObjUpdContext) | Ridefinizione dell'operatore ==.
Inequality(ObjUpdContext, ObjUpdContext) | Ridefinizione dell'operatore !=.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore ObjUpdContext
Costruttore

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ObjUpdContext(
    string fullname,
    bool primario
)
Public Sub New (
    fullname As String,
    primario As Boolean
)
public:
ObjUpdContext(
    String^ fullname,
    bool primario
)
new :
        fullname : string *
        primario : bool -> ObjUpdContext

Parametri

fullname String
primario Boolean
Vedi anche

Documentazione

Classe ObjUpdContext
Namespace DedNet.Forms


Proprietà di ObjUpdContext

Il tipo ObjUpdContext espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | FullFileName | File name completo associato al contesto
Proprietà pubblica | Name | Nome del contesto
Proprietà pubblica | Primary | Indica se il contesto è primario o meno
Torna su
Vedi anche

Documentazione

Classe ObjUpdContext
Namespace DedNet.Forms


Proprietà ObjUpdContext.FullFileName

Proprietà ObjUpdContextFullFileName
File name completo associato al contesto

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string FullFileName { get; set; }
Public Property FullFileName As String
    Get
    Set
public:
property String^ FullFileName {
    String^ get ();
    void set (String^ value);
}
member FullFileName : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe ObjUpdContext
Namespace DedNet.Forms


Proprietà ObjUpdContext.Name

Proprietà ObjUpdContextName
Nome del contesto

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe ObjUpdContext
Namespace DedNet.Forms


Proprietà ObjUpdContext.Primary

Proprietà ObjUpdContextPrimary
Indica se il contesto è primario o meno

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Primary { get; set; }
Public Property Primary As Boolean
    Get
    Set
public:
property bool Primary {
    bool get ();
    void set (bool value);
}
member Primary : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ObjUpdContext
Namespace DedNet.Forms


Metodi di ObjUpdContext

Il tipo ObjUpdContext espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | CompareTo | Implemento il CompareTo per il raggruppamento sul form
Metodo pubblico | Equals | Ridefinizione di uguaglianza. (Sovrascrive ObjectEquals(Object))
Metodo pubblico | GetHashCode | Restituisce l'HashCode di questo oggetto. (Sovrascrive ObjectGetHashCode)
Metodo pubblico | ToString | Restituisce una rappresentazione stringa di questo oggetto. (Sovrascrive ObjectToString)
Torna su
Vedi anche

Documentazione

Classe ObjUpdContext
Namespace DedNet.Forms


Metodo ObjUpdContext.CompareTo

Metodo ObjUpdContextCompareTo
Implemento il CompareTo per il raggruppamento sul form

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int CompareTo(
    Object obj
)
Public Function CompareTo (
    obj As Object
) As Integer
public:
virtual int CompareTo(
    Object^ obj
) sealed
abstract CompareTo :
        obj : Object -> int
override CompareTo :
        obj : Object -> int

Parametri

obj Object

Valore di ritorno

Int32

Implementa

IComparableCompareTo(Object)
Vedi anche

Documentazione

Classe ObjUpdContext
Namespace DedNet.Forms


Metodo ObjUpdContext.Equals

Metodo ObjUpdContextEquals
Ridefinizione di uguaglianza.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj Object
Oggetto da confrontare.

Valore di ritorno

Boolean
Restituisce true se l'oggetto è uguale a questo.
Vedi anche

Documentazione

Classe ObjUpdContext
Namespace DedNet.Forms


Metodo ObjUpdContext.GetHashCode

Metodo ObjUpdContextGetHashCode
Restituisce l'HashCode di questo oggetto.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe ObjUpdContext
Namespace DedNet.Forms


Metodo ObjUpdContext.ToString

Metodo ObjUpdContextToString
Restituisce una rappresentazione stringa di questo oggetto.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

String
Restituisce una stringa rappresentante questo oggetto.
Vedi anche

Documentazione

Classe ObjUpdContext
Namespace DedNet.Forms


ObjUpdContext Operators

Il tipo ObjUpdContext espone i seguenti membri.

Operatori
Nome | Descrizione
Equality(ObjUpdContext, ObjUpdContext) | Ridefinizione dell'operatore ==.
Inequality(ObjUpdContext, ObjUpdContext) | Ridefinizione dell'operatore !=.
Torna su
Vedi anche

Documentazione

Classe ObjUpdContext
Namespace DedNet.Forms


ObjUpdContext.Equality Operatore

ObjUpdContextEquality Operatore
Ridefinizione dell'operatore ==.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool operator ==(
    ObjUpdContext a,
    ObjUpdContext b
)
Public Shared Operator = (
    a As ObjUpdContext,
    b As ObjUpdContext
) As Boolean
public:
static bool operator ==(
    ObjUpdContext^ a,
    ObjUpdContext^ b
)
static let inline (=)
        a : ObjUpdContext *
        b : ObjUpdContext  : bool

Parametri

a ObjUpdContext
b ObjUpdContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe ObjUpdContext
Namespace DedNet.Forms


ObjUpdContext.Inequality Operatore

ObjUpdContextInequality Operatore
Ridefinizione dell'operatore !=.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool operator !=(
    ObjUpdContext a,
    ObjUpdContext b
)
Public Shared Operator <> (
    a As ObjUpdContext,
    b As ObjUpdContext
) As Boolean
public:
static bool operator !=(
    ObjUpdContext^ a,
    ObjUpdContext^ b
)
static let inline (<>)
        a : ObjUpdContext *
        b : ObjUpdContext  : bool

Parametri

a ObjUpdContext
b ObjUpdContext

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe ObjUpdContext
Namespace DedNet.Forms


Classe ObjUpdContexts
Lista smart di contesti
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList ObjUpdContext
DedNet.FormsObjUpdContexts

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ObjUpdContexts : List<ObjUpdContext>
Public Class ObjUpdContexts
    Inherits List(Of ObjUpdContext)
public ref class ObjUpdContexts : public List<ObjUpdContext^>
type ObjUpdContexts =
    class
        inherit List<ObjUpdContext>
    end

Il tipo ObjUpdContexts espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ObjUpdContexts |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | HasAtLeastOneNotPrimary | Indica se esiste almeno un contesto non primario
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore ObjUpdContexts

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ObjUpdContexts()
Public Sub New
public:
ObjUpdContexts()
new : unit -> ObjUpdContexts
Vedi anche

Documentazione

Classe ObjUpdContexts
Namespace DedNet.Forms


Proprietà di ObjUpdContexts

Il tipo ObjUpdContexts espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | HasAtLeastOneNotPrimary | Indica se esiste almeno un contesto non primario
Torna su
Vedi anche

Documentazione

Classe ObjUpdContexts
Namespace DedNet.Forms


Proprietà ObjUpdContexts.HasAtLeastOneNotPrimary

Proprietà ObjUpdContextsHasAtLeastOneNotPrimary
Indica se esiste almeno un contesto non primario

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool HasAtLeastOneNotPrimary { get; }
Public ReadOnly Property HasAtLeastOneNotPrimary As Boolean
    Get
public:
property bool HasAtLeastOneNotPrimary {
    bool get ();
}
member HasAtLeastOneNotPrimary : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe ObjUpdContexts
Namespace DedNet.Forms


Classe OwnerSelector
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsOwnerSelector

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class OwnerSelector : BaseForm
Public Class OwnerSelector
    Inherits BaseForm
public ref class OwnerSelector : public BaseForm
type OwnerSelector =
    class
        inherit BaseForm
    end

Il tipo OwnerSelector espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | OwnerSelector | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà pubblica | Names | Restituisce l'indice selezionato dall'utente.
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo pubblico | DisableMultiselect | Metodo che disabilita la multiselezione degli elementi.
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore OwnerSelector
Costruttore unico.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public OwnerSelector(
    DedNetApplication app,
    string titolo,
    List<string> listanomi,
    List<string> listaOwnerState,
    OwnerSelectorEnumOwnerState ownerState
)
Public Sub New (
    app As DedNetApplication,
    titolo As String,
    listanomi As List(Of String),
    listaOwnerState As List(Of String),
    ownerState As OwnerSelectorEnumOwnerState
)
public:
OwnerSelector(
    DedNetApplication^ app,
    String^ titolo,
    List<String^>^ listanomi,
    List<String^>^ listaOwnerState,
    OwnerSelectorEnumOwnerState ownerState
)
new :
        app : DedNetApplication *
        titolo : string *
        listanomi : List<string> *
        listaOwnerState : List<string> *
        ownerState : OwnerSelectorEnumOwnerState -> OwnerSelector

Parametri

app DedNetApplication
titolo String
listanomi List String
listaOwnerState List String
ownerState OwnerSelectorEnumOwnerState
Vedi anche

Documentazione

Classe OwnerSelector
Namespace DedNet.Forms


Proprietà di OwnerSelector

Il tipo OwnerSelector espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà pubblica | Names | Restituisce l'indice selezionato dall'utente.
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe OwnerSelector
Namespace DedNet.Forms


Proprietà OwnerSelector.Names

Proprietà OwnerSelectorNames
Restituisce l'indice selezionato dall'utente.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string[] Names { get; }
Public ReadOnly Property Names As String()
    Get
public:
property array<String^>^ Names {
    array<String^>^ get ();
}
member Names : string[] with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe OwnerSelector
Namespace DedNet.Forms


Metodi di OwnerSelector

Il tipo OwnerSelector espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo pubblico | DisableMultiselect | Metodo che disabilita la multiselezione degli elementi.
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe OwnerSelector
Namespace DedNet.Forms


Metodo OwnerSelector.DisableMultiselect

Metodo OwnerSelectorDisableMultiselect
Metodo che disabilita la multiselezione degli elementi.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void DisableMultiselect()
Public Sub DisableMultiselect
public:
void DisableMultiselect()
member DisableMultiselect : unit -> unit
Vedi anche

Documentazione

Classe OwnerSelector
Namespace DedNet.Forms


Metodo OwnerSelector.Dispose

Metodo OwnerSelectorDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe OwnerSelector
Namespace DedNet.Forms


Eventi di OwnerSelector

Il tipo OwnerSelector espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe OwnerSelector
Namespace DedNet.Forms


Campi di OwnerSelector

Il tipo OwnerSelector espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe OwnerSelector
Namespace DedNet.Forms


Enumerazione OwnerSelector.EnumOwnerState

Enumerazione OwnerSelectorEnumOwnerState

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum EnumOwnerState
Public Enumeration EnumOwnerState
public enum class EnumOwnerState
type EnumOwnerState
Membri
Nome | Valore | Descrizione
Hide | 0 |
Selected | 1 |
Vedi anche

Documentazione

Namespace DedNet.Forms


Classe OwnerSelector.OwnerSelectorList

Classe OwnerSelectorOwnerSelectorList
Gerarchia di ereditarietà
SystemObject
DedNet.FormsOwnerSelectorOwnerSelectorList

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class OwnerSelectorList
Public Class OwnerSelectorList
public ref class OwnerSelectorList
type OwnerSelectorList = class end

Il tipo OwnerSelectorOwnerSelectorList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | OwnerSelectorOwnerSelectorList |
Metodo pubblico | OwnerSelectorOwnerSelectorList(ListString) |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | List |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore OwnerSelector.OwnerSelectorList

Costruttore OwnerSelectorOwnerSelectorList
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | OwnerSelectorOwnerSelectorList |
Metodo pubblico | OwnerSelectorOwnerSelectorList(ListString) |
Torna su
Vedi anche

Documentazione

Classe OwnerSelectorOwnerSelectorList
Namespace DedNet.Forms


Costruttore OwnerSelector.OwnerSelectorList

Costruttore OwnerSelectorOwnerSelectorList

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public OwnerSelectorList()
Public Sub New
public:
OwnerSelectorList()
new : unit -> OwnerSelectorList
Vedi anche

Documentazione

Classe OwnerSelectorOwnerSelectorList
Overload di OwnerSelectorOwnerSelectorList
Namespace DedNet.Forms


Costruttore OwnerSelector.OwnerSelectorList(List<String>)

Costruttore OwnerSelectorOwnerSelectorList(ListString)

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public OwnerSelectorList(
    List<string> lista
)
Public Sub New (
    lista As List(Of String)
)
public:
OwnerSelectorList(
    List<String^>^ lista
)
new :
        lista : List<string> -> OwnerSelectorList

Parametri

lista List String
Vedi anche

Documentazione

Classe OwnerSelectorOwnerSelectorList
Overload di OwnerSelectorOwnerSelectorList
Namespace DedNet.Forms


Proprietà di OwnerSelectorList

Il tipo OwnerSelectorOwnerSelectorList espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | List |
Torna su
Vedi anche

Documentazione

Classe OwnerSelectorOwnerSelectorList
Namespace DedNet.Forms


Proprietà OwnerSelector.OwnerSelectorList.List

Proprietà OwnerSelectorOwnerSelectorListList

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<OwnerSelectorOwnerSelectorObj> List { get; }
Public ReadOnly Property List As List(Of OwnerSelectorOwnerSelectorObj)
    Get
public:
property List<OwnerSelectorOwnerSelectorObj^>^ List {
    List<OwnerSelectorOwnerSelectorObj^>^ get ();
}
member List : List<OwnerSelectorOwnerSelectorObj> with get

Valore della proprietà

List OwnerSelectorOwnerSelectorObj
Vedi anche

Documentazione

Classe OwnerSelectorOwnerSelectorList
Namespace DedNet.Forms


Classe OwnerSelector.OwnerSelectorObj

Classe OwnerSelectorOwnerSelectorObj
Gerarchia di ereditarietà
SystemObject
DedNet.FormsOwnerSelectorOwnerSelectorObj

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class OwnerSelectorObj
Public Class OwnerSelectorObj
public ref class OwnerSelectorObj
type OwnerSelectorObj = class end

Il tipo OwnerSelectorOwnerSelectorObj espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | OwnerSelectorOwnerSelectorObj |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Name |
Proprietà pubblica | Selected |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore OwnerSelector.OwnerSelectorObj

Costruttore OwnerSelectorOwnerSelectorObj

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public OwnerSelectorObj(
    string name
)
Public Sub New (
    name As String
)
public:
OwnerSelectorObj(
    String^ name
)
new :
        name : string -> OwnerSelectorObj

Parametri

name String
Vedi anche

Documentazione

Classe OwnerSelectorOwnerSelectorObj
Namespace DedNet.Forms


Proprietà di OwnerSelectorObj

Il tipo OwnerSelectorOwnerSelectorObj espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Name |
Proprietà pubblica | Selected |
Torna su
Vedi anche

Documentazione

Classe OwnerSelectorOwnerSelectorObj
Namespace DedNet.Forms


Proprietà OwnerSelector.OwnerSelectorObj.Name

Proprietà OwnerSelectorOwnerSelectorObjName

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe OwnerSelectorOwnerSelectorObj
Namespace DedNet.Forms


Proprietà OwnerSelector.OwnerSelectorObj.Selected

Proprietà OwnerSelectorOwnerSelectorObjSelected

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Selected { get; set; }
Public Property Selected As Boolean
    Get
    Set
public:
property bool Selected {
    bool get ();
    void set (bool value);
}
member Selected : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe OwnerSelectorOwnerSelectorObj
Namespace DedNet.Forms


Classe SparePartsAnagrWithoutDrawings
Visualizza le anagrafiche che compongono la distinta ricambi, ma che non hanno una tavola ricambi valida.
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsSparePartsAnagrWithoutDrawings

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class SparePartsAnagrWithoutDrawings : BaseForm
Public Class SparePartsAnagrWithoutDrawings
    Inherits BaseForm
public ref class SparePartsAnagrWithoutDrawings : public BaseForm
type SparePartsAnagrWithoutDrawings =
    class
        inherit BaseForm
    end

Il tipo SparePartsAnagrWithoutDrawings espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | SparePartsAnagrWithoutDrawings | Crea una nuova istanza della classe 'SparePartsAnagrWithoutDrawings'. Visualizza le anagrafiche che compongono la distinta ricambi, ma che non hanno una tavola ricambi valida.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà pubblica | MissingAttrTranslations | Elenco degli attributi che non hanno una traduzione impostata per il loro prompt.
Proprietà pubblica | MissingDataTranslations | Elenco delle anagrafiche che non hanno una traduzione impostata.
Proprietà pubblica | MissingDrawings | Elenco delle anagrafiche che non hanno una tavola ricambi.
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore SparePartsAnagrWithoutDrawings
Crea una nuova istanza della classe 'SparePartsAnagrWithoutDrawings'. Visualizza le anagrafiche che compongono la distinta ricambi, ma che non hanno una tavola ricambi valida.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public SparePartsAnagrWithoutDrawings(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
SparePartsAnagrWithoutDrawings(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> SparePartsAnagrWithoutDrawings

Parametri

app DedNetApplication
Applicazione DedNet.
Vedi anche

Documentazione

Classe SparePartsAnagrWithoutDrawings
Namespace DedNet.Forms


Proprietà di SparePartsAnagrWithoutDrawings

Il tipo SparePartsAnagrWithoutDrawings espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà pubblica | MissingAttrTranslations | Elenco degli attributi che non hanno una traduzione impostata per il loro prompt.
Proprietà pubblica | MissingDataTranslations | Elenco delle anagrafiche che non hanno una traduzione impostata.
Proprietà pubblica | MissingDrawings | Elenco delle anagrafiche che non hanno una tavola ricambi.
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe SparePartsAnagrWithoutDrawings
Namespace DedNet.Forms


Proprietà SparePartsAnagrWithoutDrawings.MissingAttrTranslations

Proprietà SparePartsAnagrWithoutDrawingsMissingAttrTranslations
Elenco degli attributi che non hanno una traduzione impostata per il loro prompt.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public HashSet<DedAttr> MissingAttrTranslations { get; set; }
Public Property MissingAttrTranslations As HashSet(Of DedAttr)
    Get
    Set
public:
property HashSet<DedAttr^>^ MissingAttrTranslations {
    HashSet<DedAttr^>^ get ();
    void set (HashSet<DedAttr^>^ value);
}
member MissingAttrTranslations : HashSet<DedAttr> with get, set

Valore della proprietà

HashSet DedAttr
Vedi anche

Documentazione

Classe SparePartsAnagrWithoutDrawings
Namespace DedNet.Forms


Proprietà SparePartsAnagrWithoutDrawings.MissingDataTranslations

Proprietà SparePartsAnagrWithoutDrawingsMissingDataTranslations
Elenco delle anagrafiche che non hanno una traduzione impostata.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<DedData, HashSet<DedAttr>> MissingDataTranslations { get; set; }
Public Property MissingDataTranslations As Dictionary(Of DedData, HashSet(Of DedAttr))
    Get
    Set
public:
property Dictionary<DedData^, HashSet<DedAttr^>^>^ MissingDataTranslations {
    Dictionary<DedData^, HashSet<DedAttr^>^>^ get ();
    void set (Dictionary<DedData^, HashSet<DedAttr^>^>^ value);
}
member MissingDataTranslations : Dictionary<DedData, HashSet<DedAttr>> with get, set

Valore della proprietà

Dictionary DedData, HashSet DedAttr
Vedi anche

Documentazione

Classe SparePartsAnagrWithoutDrawings
Namespace DedNet.Forms


Proprietà SparePartsAnagrWithoutDrawings.MissingDrawings

Proprietà SparePartsAnagrWithoutDrawingsMissingDrawings
Elenco delle anagrafiche che non hanno una tavola ricambi.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public HashSet<DedData> MissingDrawings { get; set; }
Public Property MissingDrawings As HashSet(Of DedData)
    Get
    Set
public:
property HashSet<DedData^>^ MissingDrawings {
    HashSet<DedData^>^ get ();
    void set (HashSet<DedData^>^ value);
}
member MissingDrawings : HashSet<DedData> with get, set

Valore della proprietà

HashSet DedData
Vedi anche

Documentazione

Classe SparePartsAnagrWithoutDrawings
Namespace DedNet.Forms


Metodi di SparePartsAnagrWithoutDrawings

Il tipo SparePartsAnagrWithoutDrawings espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe SparePartsAnagrWithoutDrawings
Namespace DedNet.Forms


Metodo SparePartsAnagrWithoutDrawings.Dispose

Metodo SparePartsAnagrWithoutDrawingsDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe SparePartsAnagrWithoutDrawings
Namespace DedNet.Forms


Eventi di SparePartsAnagrWithoutDrawings

Il tipo SparePartsAnagrWithoutDrawings espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe SparePartsAnagrWithoutDrawings
Namespace DedNet.Forms


Campi di SparePartsAnagrWithoutDrawings

Il tipo SparePartsAnagrWithoutDrawings espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe SparePartsAnagrWithoutDrawings
Namespace DedNet.Forms


Classe SparePartsManualForm
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsBaseRibbonForm
DedNet.FormsSparePartsManualForm

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class SparePartsManualForm : BaseRibbonForm
Public Class SparePartsManualForm
    Inherits BaseRibbonForm
public ref class SparePartsManualForm : public BaseRibbonForm
type SparePartsManualForm =
    class
        inherit BaseRibbonForm
    end

Il tipo SparePartsManualForm espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | SparePartsManualForm | Crea una nuova istanza della classe SparePartsManualForm.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo pubblico | ContainsSpareParts | Metodo che controlla se i figli hanno il check sull'attributo GESTIONE_RICAMBIO attivo Restituisce un bool a true se almeno un figlio ha il check attivo
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseRibbonFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo pubblico | LoadDocument | Partendo dal template impostato, crea il manuale ricambi e lo carica nell'editor di testo.
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDataWithoutSparePartsDrawings | Visualizza l'elenco delle anagrafiche che non hanno nessuna tavola ricambi da inserire nel manuale.
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore SparePartsManualForm
Crea una nuova istanza della classe SparePartsManualForm.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public SparePartsManualForm(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
SparePartsManualForm(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> SparePartsManualForm

Parametri

app DedNetApplication
Vedi anche

Documentazione

Classe SparePartsManualForm
Namespace DedNet.Forms


Proprietà di SparePartsManualForm

Il tipo SparePartsManualForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe SparePartsManualForm
Namespace DedNet.Forms


Metodi di SparePartsManualForm

Il tipo SparePartsManualForm espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo pubblico | ContainsSpareParts | Metodo che controlla se i figli hanno il check sull'attributo GESTIONE_RICAMBIO attivo Restituisce un bool a true se almeno un figlio ha il check attivo
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseRibbonFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo pubblico | LoadDocument | Partendo dal template impostato, crea il manuale ricambi e lo carica nell'editor di testo.
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDataWithoutSparePartsDrawings | Visualizza l'elenco delle anagrafiche che non hanno nessuna tavola ricambi da inserire nel manuale.
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe SparePartsManualForm
Namespace DedNet.Forms


Metodo SparePartsManualForm.ContainsSpareParts

Metodo SparePartsManualFormContainsSpareParts
Metodo che controlla se i figli hanno il check sull'attributo GESTIONE_RICAMBIO attivo Restituisce un bool a true se almeno un figlio ha il check attivo

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool ContainsSpareParts(
    BomItem item
)
Public Function ContainsSpareParts (
    item As BomItem
) As Boolean
public:
bool ContainsSpareParts(
    BomItem^ item
)
member ContainsSpareParts :
        item : BomItem -> bool

Parametri

item BomItem

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe SparePartsManualForm
Namespace DedNet.Forms


Metodo SparePartsManualForm.Dispose

Metodo SparePartsManualFormDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe SparePartsManualForm
Namespace DedNet.Forms


Metodo SparePartsManualForm.LoadDocument

Metodo SparePartsManualFormLoadDocument
Partendo dal template impostato, crea il manuale ricambi e lo carica nell'editor di testo.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void LoadDocument(
    DistHeader header,
    string template,
    string multiSheetTemplate,
    string lang
)
Public Sub LoadDocument (
    header As DistHeader,
    template As String,
    multiSheetTemplate As String,
    lang As String
)
public:
void LoadDocument(
    DistHeader^ header,
    String^ template,
    String^ multiSheetTemplate,
    String^ lang
)
member LoadDocument :
        header : DistHeader *
        template : string *
        multiSheetTemplate : string *
        lang : string -> unit

Parametri

header DistHeader
template String
multiSheetTemplate String
lang String
Vedi anche

Documentazione

Classe SparePartsManualForm
Namespace DedNet.Forms


Metodo SparePartsManualForm.ShowDataWithoutSparePartsDrawings

Metodo SparePartsManualFormShowDataWithoutSparePartsDrawings
Visualizza l'elenco delle anagrafiche che non hanno nessuna tavola ricambi da inserire nel manuale.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ShowDataWithoutSparePartsDrawings()
Public Sub ShowDataWithoutSparePartsDrawings
public:
void ShowDataWithoutSparePartsDrawings()
member ShowDataWithoutSparePartsDrawings : unit -> unit
Vedi anche

Documentazione

Classe SparePartsManualForm
Namespace DedNet.Forms


Eventi di SparePartsManualForm

Il tipo SparePartsManualForm espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe SparePartsManualForm
Namespace DedNet.Forms


Campi di SparePartsManualForm

Il tipo SparePartsManualForm espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe SparePartsManualForm
Namespace DedNet.Forms


Classe SparePartsPrintSettings
Dialogo utilizzato per gestire le impostazioni di pubblicazione manuale.
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsSparePartsPrintSettings

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class SparePartsPrintSettings : BaseForm
Public Class SparePartsPrintSettings
    Inherits BaseForm
public ref class SparePartsPrintSettings : public BaseForm
type SparePartsPrintSettings =
    class
        inherit BaseForm
    end

Il tipo SparePartsPrintSettings espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | SparePartsPrintSettings | Crea una nuova istanza della classe 'SparePartsPrintSettings'.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà pubblica | DiscrimDist | Discriminante di distinta di cui si vuole creare il manuale ricambi.
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà pubblica | Language | Discriminante di distinta di cui si vuole creare il manuale ricambi.
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà pubblica | MultiSheetTemplate | Nome del template multifoglio da utilizzare per la generazione del manuale.
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | RevisionDist | Revisione di distinta di cui si vuole creare il manuale ricambi. Ritorna -1 se non impostata.
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Template | Nome del template da utilizzare per la generazione del manuale.
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore SparePartsPrintSettings
Crea una nuova istanza della classe 'SparePartsPrintSettings'.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public SparePartsPrintSettings(
    DedNetApplication app,
    DedData data,
    DistManager manager
)
Public Sub New (
    app As DedNetApplication,
    data As DedData,
    manager As DistManager
)
public:
SparePartsPrintSettings(
    DedNetApplication^ app,
    DedData^ data,
    DistManager^ manager
)
new :
        app : DedNetApplication *
        data : DedData *
        manager : DistManager -> SparePartsPrintSettings

Parametri

app DedNetApplication
Applicazione DedNet.
data DedData
Anagrafica di cui si vuole creare il manuale.
manager DistManager
Manager delle distinte.
Vedi anche

Documentazione

Classe SparePartsPrintSettings
Namespace DedNet.Forms


Proprietà di SparePartsPrintSettings

Il tipo SparePartsPrintSettings espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà pubblica | DiscrimDist | Discriminante di distinta di cui si vuole creare il manuale ricambi.
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà pubblica | Language | Discriminante di distinta di cui si vuole creare il manuale ricambi.
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà pubblica | MultiSheetTemplate | Nome del template multifoglio da utilizzare per la generazione del manuale.
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | RevisionDist | Revisione di distinta di cui si vuole creare il manuale ricambi. Ritorna -1 se non impostata.
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Template | Nome del template da utilizzare per la generazione del manuale.
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe SparePartsPrintSettings
Namespace DedNet.Forms


Proprietà SparePartsPrintSettings.DiscrimDist

Proprietà SparePartsPrintSettingsDiscrimDist
Discriminante di distinta di cui si vuole creare il manuale ricambi.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string DiscrimDist { get; set; }
Public Property DiscrimDist As String
    Get
    Set
public:
property String^ DiscrimDist {
    String^ get ();
    void set (String^ value);
}
member DiscrimDist : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe SparePartsPrintSettings
Namespace DedNet.Forms


Proprietà SparePartsPrintSettings.Language

Proprietà SparePartsPrintSettingsLanguage
Discriminante di distinta di cui si vuole creare il manuale ricambi.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Language { get; set; }
Public Property Language As String
    Get
    Set
public:
property String^ Language {
    String^ get ();
    void set (String^ value);
}
member Language : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe SparePartsPrintSettings
Namespace DedNet.Forms


Proprietà SparePartsPrintSettings.MultiSheetTemplate

Proprietà SparePartsPrintSettingsMultiSheetTemplate
Nome del template multifoglio da utilizzare per la generazione del manuale.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string MultiSheetTemplate { get; set; }
Public Property MultiSheetTemplate As String
    Get
    Set
public:
property String^ MultiSheetTemplate {
    String^ get ();
    void set (String^ value);
}
member MultiSheetTemplate : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe SparePartsPrintSettings
Namespace DedNet.Forms


Proprietà SparePartsPrintSettings.RevisionDist

Proprietà SparePartsPrintSettingsRevisionDist
Revisione di distinta di cui si vuole creare il manuale ricambi. Ritorna -1 se non impostata.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int RevisionDist { get; set; }
Public Property RevisionDist As Integer
    Get
    Set
public:
property int RevisionDist {
    int get ();
    void set (int value);
}
member RevisionDist : int with get, set

Valore della proprietà

Int32
Vedi anche

Documentazione

Classe SparePartsPrintSettings
Namespace DedNet.Forms


Proprietà SparePartsPrintSettings.Template

Proprietà SparePartsPrintSettingsTemplate
Nome del template da utilizzare per la generazione del manuale.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Template { get; set; }
Public Property Template As String
    Get
    Set
public:
property String^ Template {
    String^ get ();
    void set (String^ value);
}
member Template : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe SparePartsPrintSettings
Namespace DedNet.Forms


Metodi di SparePartsPrintSettings

Il tipo SparePartsPrintSettings espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe SparePartsPrintSettings
Namespace DedNet.Forms


Metodo SparePartsPrintSettings.Dispose

Metodo SparePartsPrintSettingsDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe SparePartsPrintSettings
Namespace DedNet.Forms


Eventi di SparePartsPrintSettings

Il tipo SparePartsPrintSettings espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe SparePartsPrintSettings
Namespace DedNet.Forms


Campi di SparePartsPrintSettings

Il tipo SparePartsPrintSettings espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe SparePartsPrintSettings
Namespace DedNet.Forms


Classe SparePartsTableLayout
Classe utilizzata per impostare il layout della tabella ricambi nel manuale di pubblicazione.
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.FormsSparePartsTableLayout

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class SparePartsTableLayout : BaseForm
Public Class SparePartsTableLayout
    Inherits BaseForm
public ref class SparePartsTableLayout : public BaseForm
type SparePartsTableLayout =
    class
        inherit BaseForm
    end

Il tipo SparePartsTableLayout espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | SparePartsTableLayout | Crea una nuova istanza della classe 'SparePartsTableLayout' utilizzata per impostare il layout della tabella ricambi nel manuale di pubblicazione.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.Forms


Costruttore SparePartsTableLayout
Crea una nuova istanza della classe 'SparePartsTableLayout' utilizzata per impostare il layout della tabella ricambi nel manuale di pubblicazione.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public SparePartsTableLayout(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
SparePartsTableLayout(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> SparePartsTableLayout

Parametri

app DedNetApplication
Applicazione DedNet.
Vedi anche

Documentazione

Classe SparePartsTableLayout
Namespace DedNet.Forms


Proprietà di SparePartsTableLayout

Il tipo SparePartsTableLayout espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe SparePartsTableLayout
Namespace DedNet.Forms


Metodi di SparePartsTableLayout

Il tipo SparePartsTableLayout espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe SparePartsTableLayout
Namespace DedNet.Forms


Metodo SparePartsTableLayout.Dispose

Metodo SparePartsTableLayoutDispose
Clean up any resources being used.

Namespace: DedNet.Forms
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe SparePartsTableLayout
Namespace DedNet.Forms


Eventi di SparePartsTableLayout

Il tipo SparePartsTableLayout espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe SparePartsTableLayout
Namespace DedNet.Forms


Campi di SparePartsTableLayout

Il tipo SparePartsTableLayout espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe SparePartsTableLayout
Namespace DedNet.Forms


DedNet.Lib Namespace
Spazio dei nomi contenente le utilità eterogenee utilizzate anche dall'applicazione.
Classi
 | Classe | Descrizione
Classe pubblica | AttributeBinder | Lista di RowAttribute da bindare al repository.
Classe pubblica | AttributesUtility | Classe dedicata alla gestione dell'editazione degli attributi.
Classe pubblica | DevExpressUtility | Classe che espone funzionalità di utilità generale per operare con i controlli DevExpress
Classe pubblica | DragCellsValuesHelper |
Classe pubblica | DragCellsValuesHelperGridView |
Classe pubblica | EnumDescriptionHelper | Espone dei metodi per avere delle descrizioni leggibili all'utente data una enumerazione avente i membri "marchiati" con attributo System.ComponentModel.Description().
Classe pubblica | FileServerManager | Classe contenente le informazioni sulla gestione e le impostazione della gestione client/server dei file.
Classe pubblica | FileTransaction | Classe per la gestione delle transazione sulla copia, spostamento o modifica delle proprietà dei file.
Classe pubblica | GridControlState |
Classe pubblica | GridControlStateViewState |
Classe pubblica | RowAttribute | Classe rappresentante la riga della griglia dedicata all'editazione degli attributi.
Classe pubblica | SelectedCellsBorderHelper |
Classe pubblica | SelectedCellsBorderHelperGridView |
Strutture
 | Struttura | Descrizione
Struttura pubblica | GridControlStateRowInfo |
Struttura pubblica | GridControlStateViewDescriptor |
Enumerazioni
 | Enumerazione | Descrizione
Enumerazione pubblica | DataSourceTypeEnum | Enum indicante il tipo di fonte dati (Excel, Ascii, ecc...).
Enumerazione pubblica | DedDbItemType | Enum che identifica il tipo di elemento che può essere archiviato nel db.
Enumerazione pubblica | DocumentStateEnum | Enum indicante i possibili stati documentali.
Enumerazione pubblica | DuplicatesOptionEnum | Enum indicante il tipo l'operazione da eseguire (durante l'importazione di anagrafiche/traduzioni) nel caso di elementi duplicati.
Enumerazione pubblica | ImportationOptionEnum | Enum indicante il tipo di fonte dati (Excel, Ascii, ecc...).
Enumerazione pubblica | ImporterModeEnum | Enum indicante il tipo di importazione (importazione di traduzioni, importazione di anagrafiche, ecc...).
Enumerazione pubblica | ImporterTranslationTypeEnum | Enum indicante il tipo di importazione (importazione di traduzioni, importazione di anagrafiche, ecc...).
Enumerazione pubblica | ReferenceUpdateEnum | Enum che indica i tre stati possibili della variabile HANDLE_REFERENCE_UPDATE.
Enumerazione pubblica | SelectionModeEnum | Enum indicante la modalità di selezione di determinati oggetti.
Enumerazione pubblica | TimeEnum | Possibili formati in cui esprimere il tempo (secondi, minuti, ore, ecc..)


Classe AttributeBinder
Lista di RowAttribute da bindare al repository.
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList RowAttribute
DedNet.LibAttributeBinder

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class AttributeBinder : List<RowAttribute>
Public Class AttributeBinder
    Inherits List(Of RowAttribute)
public ref class AttributeBinder : public List<RowAttribute^>
type AttributeBinder =
    class
        inherit List<RowAttribute>
    end

Il tipo AttributeBinder espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | AttributeBinder |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | UpdateOnlyDbAttrsAndTranslations | Rilegge dal database gli attributi solo db e le traduzioni.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Lib


Costruttore AttributeBinder

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public AttributeBinder()
Public Sub New
public:
AttributeBinder()
new : unit -> AttributeBinder
Vedi anche

Documentazione

Classe AttributeBinder
Namespace DedNet.Lib


Metodi di AttributeBinder

Il tipo AttributeBinder espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | UpdateOnlyDbAttrsAndTranslations | Rilegge dal database gli attributi solo db e le traduzioni.
Torna su
Vedi anche

Documentazione

Classe AttributeBinder
Namespace DedNet.Lib


Metodo AttributeBinder.UpdateOnlyDbAttrsAndTranslations

Metodo AttributeBinderUpdateOnlyDbAttrsAndTranslations
Rilegge dal database gli attributi solo db e le traduzioni.

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void UpdateOnlyDbAttrsAndTranslations(
    IDedEditable obj
)
Public Sub UpdateOnlyDbAttrsAndTranslations (
    obj As IDedEditable
)
public:
void UpdateOnlyDbAttrsAndTranslations(
    IDedEditable^ obj
)
member UpdateOnlyDbAttrsAndTranslations :
        obj : IDedEditable -> unit

Parametri

obj IDedEditable
Oggetto da cui prelevare le informazioni.
Vedi anche

Documentazione

Classe AttributeBinder
Namespace DedNet.Lib


Classe AttributesUtility
Classe dedicata alla gestione dell'editazione degli attributi.
Gerarchia di ereditarietà
SystemObject
DedNet.LibAttributesUtility

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class AttributesUtility
Public Class AttributesUtility
public ref class AttributesUtility
type AttributesUtility = class end

Il tipo AttributesUtility espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | AttributesUtility | Crea una nuova istanza della classe 'AttributesUtility' che permette di gestire l'editazione degli attributi.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | RepositoryItemPopupContainer |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AttrIsEditable | Ritorna True se l'attributo è editabile, False altrimenti.
Metodo pubblico | AttrIsValid | Ritorna True se l'attributo è compilato correttamene e non contiene errori, False altrimenti.
Metodo pubblico | BindAttListToRepo | Collega la lista Att al relativo repository.
Metodo pubblico | ClearRepoCache | Ripulisce la cache dei repository in modo tale che vengano ricreati.
Metodo pubblico | GetComboItemList | Ritorna una lista di ComboItem rappresentante gli elementi dell'AttList dell'attributo.
 | GetGroup | Restituisce il gruppo di appartenenza dell'attributo.
Metodo pubblico | RemoveSeparator | Toglie lo spazio tra il separatore e il valore successivo (viene messo in automatico dal repository).
Metodo pubblico | UpdateCellValue | Aggiorna il contenuto della cella con il valore del menu a tendina selezionato.
Metodo pubblico | ValidateAttr | Valida le modifiche e segnala eventuali errori.
Metodo pubblico | ValidateSelection | Avvia la validazione dell'elemento selezionato nel menu a tendina.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Lib


Costruttore AttributesUtility
Crea una nuova istanza della classe 'AttributesUtility' che permette di gestire l'editazione degli attributi.

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public AttributesUtility(
    GridView view,
    RepositoryItemCheckedComboBoxEdit repositoryItemCheckedComboBox,
    RepositoryItemComboBox repositoryItemComboBox,
    RepositoryItemPopupContainerEdit repositoryItemPopupContainerEdit,
    RepositoryItemMemoEdit repositoryItemMemoEdit,
    RepositoryItemTextEdit repositoryItemTextEdit,
    RepositoryItemSpinEdit repositoryItemSpinEdit,
    RepositoryItemDateEdit repositoryItemDateEdit,
    RepositoryItemCheckEdit repositoryItemCheckEdit,
    RepositoryItemMemoExEdit repositoryItemMemoExEdit,
    RepositoryItemHyperLinkEdit repositoryItemHyperLinkEdit
)
Public Sub New (
    view As GridView,
    repositoryItemCheckedComboBox As RepositoryItemCheckedComboBoxEdit,
    repositoryItemComboBox As RepositoryItemComboBox,
    repositoryItemPopupContainerEdit As RepositoryItemPopupContainerEdit,
    repositoryItemMemoEdit As RepositoryItemMemoEdit,
    repositoryItemTextEdit As RepositoryItemTextEdit,
    repositoryItemSpinEdit As RepositoryItemSpinEdit,
    repositoryItemDateEdit As RepositoryItemDateEdit,
    repositoryItemCheckEdit As RepositoryItemCheckEdit,
    repositoryItemMemoExEdit As RepositoryItemMemoExEdit,
    repositoryItemHyperLinkEdit As RepositoryItemHyperLinkEdit
)
public:
AttributesUtility(
    GridView^ view,
    RepositoryItemCheckedComboBoxEdit^ repositoryItemCheckedComboBox,
    RepositoryItemComboBox^ repositoryItemComboBox,
    RepositoryItemPopupContainerEdit^ repositoryItemPopupContainerEdit,
    RepositoryItemMemoEdit^ repositoryItemMemoEdit,
    RepositoryItemTextEdit^ repositoryItemTextEdit,
    RepositoryItemSpinEdit^ repositoryItemSpinEdit,
    RepositoryItemDateEdit^ repositoryItemDateEdit,
    RepositoryItemCheckEdit^ repositoryItemCheckEdit,
    RepositoryItemMemoExEdit^ repositoryItemMemoExEdit,
    RepositoryItemHyperLinkEdit^ repositoryItemHyperLinkEdit
)
new :
        view : GridView *
        repositoryItemCheckedComboBox : RepositoryItemCheckedComboBoxEdit *
        repositoryItemComboBox : RepositoryItemComboBox *
        repositoryItemPopupContainerEdit : RepositoryItemPopupContainerEdit *
        repositoryItemMemoEdit : RepositoryItemMemoEdit *
        repositoryItemTextEdit : RepositoryItemTextEdit *
        repositoryItemSpinEdit : RepositoryItemSpinEdit *
        repositoryItemDateEdit : RepositoryItemDateEdit *
        repositoryItemCheckEdit : RepositoryItemCheckEdit *
        repositoryItemMemoExEdit : RepositoryItemMemoExEdit *
        repositoryItemHyperLinkEdit : RepositoryItemHyperLinkEdit -> AttributesUtility

Parametri

view GridView
repositoryItemCheckedComboBox RepositoryItemCheckedComboBoxEdit
repositoryItemComboBox RepositoryItemComboBox
repositoryItemPopupContainerEdit RepositoryItemPopupContainerEdit
repositoryItemMemoEdit RepositoryItemMemoEdit
repositoryItemTextEdit RepositoryItemTextEdit
repositoryItemSpinEdit RepositoryItemSpinEdit
repositoryItemDateEdit RepositoryItemDateEdit
repositoryItemCheckEdit RepositoryItemCheckEdit
repositoryItemMemoExEdit RepositoryItemMemoExEdit
repositoryItemHyperLinkEdit RepositoryItemHyperLinkEdit
Vedi anche

Documentazione

Classe AttributesUtility
Namespace DedNet.Lib


Proprietà di AttributesUtility

Il tipo AttributesUtility espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | RepositoryItemPopupContainer |
Torna su
Vedi anche

Documentazione

Classe AttributesUtility
Namespace DedNet.Lib


Proprietà AttributesUtility.RepositoryItemPopupContainer

Proprietà AttributesUtilityRepositoryItemPopupContainer

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public RepositoryItemPopupContainerEdit RepositoryItemPopupContainer { get; set; }
Public Property RepositoryItemPopupContainer As RepositoryItemPopupContainerEdit
    Get
    Set
public:
property RepositoryItemPopupContainerEdit^ RepositoryItemPopupContainer {
    RepositoryItemPopupContainerEdit^ get ();
    void set (RepositoryItemPopupContainerEdit^ value);
}
member RepositoryItemPopupContainer : RepositoryItemPopupContainerEdit with get, set

Valore della proprietà

RepositoryItemPopupContainerEdit
Vedi anche

Documentazione

Classe AttributesUtility
Namespace DedNet.Lib


Metodi di AttributesUtility

Il tipo AttributesUtility espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AttrIsEditable | Ritorna True se l'attributo è editabile, False altrimenti.
Metodo pubblico | AttrIsValid | Ritorna True se l'attributo è compilato correttamene e non contiene errori, False altrimenti.
Metodo pubblico | BindAttListToRepo | Collega la lista Att al relativo repository.
Metodo pubblico | ClearRepoCache | Ripulisce la cache dei repository in modo tale che vengano ricreati.
Metodo pubblico | GetComboItemList | Ritorna una lista di ComboItem rappresentante gli elementi dell'AttList dell'attributo.
 | GetGroup | Restituisce il gruppo di appartenenza dell'attributo.
Metodo pubblico | RemoveSeparator | Toglie lo spazio tra il separatore e il valore successivo (viene messo in automatico dal repository).
Metodo pubblico | UpdateCellValue | Aggiorna il contenuto della cella con il valore del menu a tendina selezionato.
Metodo pubblico | ValidateAttr | Valida le modifiche e segnala eventuali errori.
Metodo pubblico | ValidateSelection | Avvia la validazione dell'elemento selezionato nel menu a tendina.
Torna su
Vedi anche

Documentazione

Classe AttributesUtility
Namespace DedNet.Lib


Metodo AttributesUtility.AttrIsEditable

Metodo AttributesUtilityAttrIsEditable
Ritorna True se l'attributo è editabile, False altrimenti.

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AttrIsEditable(
    RowAttribute rowAttr,
    bool ctrlEditable,
    bool creatingAnagr,
    GridColumn col,
    bool attrReadOnlyOverride
)
Public Function AttrIsEditable (
    rowAttr As RowAttribute,
    ctrlEditable As Boolean,
    creatingAnagr As Boolean,
    col As GridColumn,
    attrReadOnlyOverride As Boolean
) As Boolean
public:
bool AttrIsEditable(
    RowAttribute^ rowAttr,
    bool ctrlEditable,
    bool creatingAnagr,
    GridColumn^ col,
    bool attrReadOnlyOverride
)
member AttrIsEditable :
        rowAttr : RowAttribute *
        ctrlEditable : bool *
        creatingAnagr : bool *
        col : GridColumn *
        attrReadOnlyOverride : bool -> bool

Parametri

rowAttr RowAttribute
Wrapper dell'attributo.
ctrlEditable Boolean
Indica se di default il controllo padre è in editazione.
creatingAnagr Boolean
Indica se sono in fase di creazione anagrafica.
col GridColumn
Colonna correntemente processata.
attrReadOnlyOverride Boolean
Indica se l'attributo è in sola lettura per logiche non intrinseche ma dovute al contesto.

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe AttributesUtility
Namespace DedNet.Lib


Metodo AttributesUtility.AttrIsValid

Metodo AttributesUtilityAttrIsValid
Ritorna True se l'attributo è compilato correttamene e non contiene errori, False altrimenti.

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool AttrIsValid(
    DedAttr attr,
    IDedEditable dedData,
    bool validateAttr,
    bool creatingAnagr,
    bool revisionAnagr,
    bool checkRowHandle,
    RowCellCustomDrawEventArgs e
)
Public Function AttrIsValid (
    attr As DedAttr,
    dedData As IDedEditable,
    validateAttr As Boolean,
    creatingAnagr As Boolean,
    revisionAnagr As Boolean,
    checkRowHandle As Boolean,
    e As RowCellCustomDrawEventArgs
) As Boolean
public:
bool AttrIsValid(
    DedAttr^ attr,
    IDedEditable^ dedData,
    bool validateAttr,
    bool creatingAnagr,
    bool revisionAnagr,
    bool checkRowHandle,
    RowCellCustomDrawEventArgs^ e
)
member AttrIsValid :
        attr : DedAttr *
        dedData : IDedEditable *
        validateAttr : bool *
        creatingAnagr : bool *
        revisionAnagr : bool *
        checkRowHandle : bool *
        e : RowCellCustomDrawEventArgs -> bool

Parametri

attr DedAttr
dedData IDedEditable
validateAttr Boolean
creatingAnagr Boolean
revisionAnagr Boolean
checkRowHandle Boolean
e RowCellCustomDrawEventArgs

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe AttributesUtility
Namespace DedNet.Lib


Metodo AttributesUtility.BindAttListToRepo

Metodo AttributesUtilityBindAttListToRepo
Collega la lista Att al relativo repository.

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void BindAttListToRepo(
    bool creatingAnagr,
    RowAttribute rowAttr,
    CustomRowCellEditEventArgs e
)
Public Sub BindAttListToRepo (
    creatingAnagr As Boolean,
    rowAttr As RowAttribute,
    e As CustomRowCellEditEventArgs
)
public:
void BindAttListToRepo(
    bool creatingAnagr,
    RowAttribute^ rowAttr,
    CustomRowCellEditEventArgs^ e
)
member BindAttListToRepo :
        creatingAnagr : bool *
        rowAttr : RowAttribute *
        e : CustomRowCellEditEventArgs -> unit

Parametri

creatingAnagr Boolean
Indica se sono in fase di creazione anagrafica.
rowAttr RowAttribute
Oggetto RowAttribute correntemente processato.
e CustomRowCellEditEventArgs
EventArgs correntemente processato.
Vedi anche

Documentazione

Classe AttributesUtility
Namespace DedNet.Lib


Metodo AttributesUtility.ClearRepoCache

Metodo AttributesUtilityClearRepoCache
Ripulisce la cache dei repository in modo tale che vengano ricreati.

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ClearRepoCache()
Public Sub ClearRepoCache
public:
void ClearRepoCache()
member ClearRepoCache : unit -> unit
Vedi anche

Documentazione

Classe AttributesUtility
Namespace DedNet.Lib


Metodo AttributesUtility.GetComboItemList

Metodo AttributesUtilityGetComboItemList
Ritorna una lista di ComboItem rappresentante gli elementi dell'AttList dell'attributo.

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public List<ComboItem> GetComboItemList(
    DedAttr attr
)
Public Function GetComboItemList (
    attr As DedAttr
) As List(Of ComboItem)
public:
List<ComboItem^>^ GetComboItemList(
    DedAttr^ attr
)
member GetComboItemList :
        attr : DedAttr -> List<ComboItem>

Parametri

attr DedAttr

Valore di ritorno

List ComboItem
Vedi anche

Documentazione

Classe AttributesUtility
Namespace DedNet.Lib


Metodo AttributesUtility.GetGroup

Metodo AttributesUtilityGetGroup
Restituisce il gruppo di appartenenza dell'attributo.

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string GetGroup(
    DedAttr attr
)
Public Shared Function GetGroup (
    attr As DedAttr
) As String
public:
static String^ GetGroup(
    DedAttr^ attr
)
static member GetGroup :
        attr : DedAttr -> string

Parametri

attr DedAttr

Valore di ritorno

String
Vedi anche

Documentazione

Classe AttributesUtility
Namespace DedNet.Lib


Metodo AttributesUtility.RemoveSeparator

Metodo AttributesUtilityRemoveSeparator
Toglie lo spazio tra il separatore e il valore successivo (viene messo in automatico dal repository).

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void RemoveSeparator(
    CloseUpEventArgs e
)
Public Sub RemoveSeparator (
    e As CloseUpEventArgs
)
public:
void RemoveSeparator(
    CloseUpEventArgs^ e
)
member RemoveSeparator :
        e : CloseUpEventArgs -> unit

Parametri

e CloseUpEventArgs
Vedi anche

Documentazione

Classe AttributesUtility
Namespace DedNet.Lib


Metodo AttributesUtility.UpdateCellValue

Metodo AttributesUtilityUpdateCellValue
Aggiorna il contenuto della cella con il valore del menu a tendina selezionato.

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void UpdateCellValue(
    GridView view,
    Object sender,
    QueryResultValueEventArgs e
)
Public Sub UpdateCellValue (
    view As GridView,
    sender As Object,
    e As QueryResultValueEventArgs
)
public:
void UpdateCellValue(
    GridView^ view,
    Object^ sender,
    QueryResultValueEventArgs^ e
)
member UpdateCellValue :
        view : GridView *
        sender : Object *
        e : QueryResultValueEventArgs -> unit

Parametri

view GridView
sender Object
e QueryResultValueEventArgs
Vedi anche

Documentazione

Classe AttributesUtility
Namespace DedNet.Lib


Metodo AttributesUtility.ValidateAttr

Metodo AttributesUtilityValidateAttr
Valida le modifiche e segnala eventuali errori.

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ValidateAttr(
    DedAttr attr,
    IDedEditable dedData,
    bool validateAttr,
    bool creatingAnagr,
    bool revisionAnagr,
    BaseContainerValidateEditorEventArgs e,
    ref bool isValid
)
Public Sub ValidateAttr (
    attr As DedAttr,
    dedData As IDedEditable,
    validateAttr As Boolean,
    creatingAnagr As Boolean,
    revisionAnagr As Boolean,
    e As BaseContainerValidateEditorEventArgs,
    ByRef isValid As Boolean
)
public:
void ValidateAttr(
    DedAttr^ attr,
    IDedEditable^ dedData,
    bool validateAttr,
    bool creatingAnagr,
    bool revisionAnagr,
    BaseContainerValidateEditorEventArgs^ e,
    bool% isValid
)
member ValidateAttr :
        attr : DedAttr *
        dedData : IDedEditable *
        validateAttr : bool *
        creatingAnagr : bool *
        revisionAnagr : bool *
        e : BaseContainerValidateEditorEventArgs *
        isValid : bool byref -> unit

Parametri

attr DedAttr
dedData IDedEditable
validateAttr Boolean
creatingAnagr Boolean
revisionAnagr Boolean
e BaseContainerValidateEditorEventArgs
isValid Boolean
Vedi anche

Documentazione

Classe AttributesUtility
Namespace DedNet.Lib


Metodo AttributesUtility.ValidateSelection

Metodo AttributesUtilityValidateSelection
Avvia la validazione dell'elemento selezionato nel menu a tendina.

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void ValidateSelection(
    GridView view,
    Object sender,
    MouseEventArgs e
)
Public Sub ValidateSelection (
    view As GridView,
    sender As Object,
    e As MouseEventArgs
)
public:
void ValidateSelection(
    GridView^ view,
    Object^ sender,
    MouseEventArgs^ e
)
member ValidateSelection :
        view : GridView *
        sender : Object *
        e : MouseEventArgs -> unit

Parametri

view GridView
sender Object
e MouseEventArgs
Vedi anche

Documentazione

Classe AttributesUtility
Namespace DedNet.Lib


Enumerazione DataSourceTypeEnum
Enum indicante il tipo di fonte dati (Excel, Ascii, ecc...).

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum DataSourceTypeEnum
Public Enumeration DataSourceTypeEnum
public enum class DataSourceTypeEnum
type DataSourceTypeEnum
Membri
Nome | Valore | Descrizione
None | 0 | Nessuna modalità selezionata.
Excel | 1 | Verranno importati i dati leggendoli da un file Excel.
Ascii | 2 | Verranno importati i dati leggendoli da un file Ascii (cvs, txt, ecc..).
Vedi anche

Documentazione

Namespace DedNet.Lib


Enumerazione DedDbItemType
Enum che identifica il tipo di elemento che può essere archiviato nel db.

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum DedDbItemType
Public Enumeration DedDbItemType
public enum class DedDbItemType
type DedDbItemType
Membri
Nome | Valore | Descrizione
None | 0 | Tipo di oggetto non riconosciuto.
Data | 1 | L'oggetto corrisponde ad una anagrafica.
Comm | 2 | L'oggetto corrisponde ad una commessa.
ECO | 3 | L'oggetto corrisponde ad un ECO.
Timing | 4 | L'oggetto corrisponde ad una temporizzazione.
Vedi anche

Documentazione

Namespace DedNet.Lib


Classe DevExpressUtility
Classe che espone funzionalità di utilità generale per operare con i controlli DevExpress
Gerarchia di ereditarietà
SystemObject
DedNet.LibDevExpressUtility

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static class DevExpressUtility
Public NotInheritable Class DevExpressUtility
public ref class DevExpressUtility abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DevExpressUtility = class end

Il tipo DevExpressUtility espone i seguenti membri.

Metodi
Nome | Descrizione
AssociateEditorControl | Metodo che, in base alla tipologia dell'attributo, associa alla colonna specificata in ingresso il relativo repositoy.
ColumnIsEditable | Ritorna True se la colonna è editabile, False altrimenti (controlla tutte le proprietà della colonna).
CustomizeCell(GridView, RowCellCustomDrawEventArgs, Image, Color) | Personalizza la cella della griglia in base alle informazioni specificate in ingresso.
CustomizeCell(GridView, RowCellCustomDrawEventArgs, Image, Color, Boolean) | Personalizza la cella della griglia in base alle informazioni specificate in ingresso.
FixTreeListView | Risolve i problemi di visualizzazione dovuti all'utilizzo di monitor 4k.
GetControlTextColor | Ritorna il colore di default del testo in base allo skin attualmente impostato.
GetReadOnlyBackColor | Ritorna il colore 'ReadOnly' a seconda dello skin attualmente impostato.
GetWindowTextColor | Ritorna il colore di default del testo in base allo skin attualmente impostato.
IsPointOnTheGrip |
MakeRepository | REstituisce il repository in base alle impostazioni dell'attributo passato.
SeriesDataMemberMustBeSet | Ritorna True nel caso in cui il campo 'SeriesDataMember' necessiti di essere compilato, False altrimenti. Attenzione! Il campo 'SeriesDataMember' deve essere compilato solamente nel caso in cui il tipo di diagramma necessiti di avere a schermo più serie (per esempio in un grafico a linee o barre). In caso contrario (per esempio in un diagramma a torta) non lo compilo in modo tale che tutti i dati vengano riportati in una serie sola.
SetRepositoryCase | Setta il case sensitive del repository
SetRepositoryFormat | Setta il formato di visualizzazione del repository
SetRepositoryInfo | Setta tutte le impostazioni del repository
SetRepositoryLength | Setta la lunghezza del repository
Torna su
Vedi anche

Documentazione

Namespace DedNet.Lib


Metodi di DevExpressUtility

Il tipo DevExpressUtility espone i seguenti membri.

Metodi
Nome | Descrizione
AssociateEditorControl | Metodo che, in base alla tipologia dell'attributo, associa alla colonna specificata in ingresso il relativo repositoy.
ColumnIsEditable | Ritorna True se la colonna è editabile, False altrimenti (controlla tutte le proprietà della colonna).
CustomizeCell(GridView, RowCellCustomDrawEventArgs, Image, Color) | Personalizza la cella della griglia in base alle informazioni specificate in ingresso.
CustomizeCell(GridView, RowCellCustomDrawEventArgs, Image, Color, Boolean) | Personalizza la cella della griglia in base alle informazioni specificate in ingresso.
FixTreeListView | Risolve i problemi di visualizzazione dovuti all'utilizzo di monitor 4k.
GetControlTextColor | Ritorna il colore di default del testo in base allo skin attualmente impostato.
GetReadOnlyBackColor | Ritorna il colore 'ReadOnly' a seconda dello skin attualmente impostato.
GetWindowTextColor | Ritorna il colore di default del testo in base allo skin attualmente impostato.
IsPointOnTheGrip |
MakeRepository | REstituisce il repository in base alle impostazioni dell'attributo passato.
SeriesDataMemberMustBeSet | Ritorna True nel caso in cui il campo 'SeriesDataMember' necessiti di essere compilato, False altrimenti. Attenzione! Il campo 'SeriesDataMember' deve essere compilato solamente nel caso in cui il tipo di diagramma necessiti di avere a schermo più serie (per esempio in un grafico a linee o barre). In caso contrario (per esempio in un diagramma a torta) non lo compilo in modo tale che tutti i dati vengano riportati in una serie sola.
SetRepositoryCase | Setta il case sensitive del repository
SetRepositoryFormat | Setta il formato di visualizzazione del repository
SetRepositoryInfo | Setta tutte le impostazioni del repository
SetRepositoryLength | Setta la lunghezza del repository
Torna su
Vedi anche

Documentazione

Classe DevExpressUtility
Namespace DedNet.Lib


Metodo DevExpressUtility.AssociateEditorControl

Metodo DevExpressUtilityAssociateEditorControl
Metodo che, in base alla tipologia dell'attributo, associa alla colonna specificata in ingresso il relativo repositoy.

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void AssociateEditorControl(
    DedAttr attr,
    Object col,
    Dictionary<Object, RepositoryItem> dizColRep,
    RepositoryItemCheckedComboBoxEdit repositoryItemCheckedComboBoxEdit,
    RepositoryItemComboBox repositoryItemComboBox,
    RepositoryItemPopupContainerEdit repositoryItemPopupContainerEdit,
    RepositoryItemTextEdit repositoryItemTextEdit,
    RepositoryItemMemoEdit repositoryItemMemoEdit,
    RepositoryItemSpinEdit repositoryItemSpinEdit,
    RepositoryItemDateEdit repositoryItemDateEdit,
    RepositoryItemCheckEdit repositoryItemCheckEdit,
    RepositoryItemMemoExEdit repositoryItemMemoExEdit,
    RepositoryItemHyperLinkEdit repositoryItemHyperLinkEdit
)
Public Shared Sub AssociateEditorControl (
    attr As DedAttr,
    col As Object,
    dizColRep As Dictionary(Of Object, RepositoryItem),
    repositoryItemCheckedComboBoxEdit As RepositoryItemCheckedComboBoxEdit,
    repositoryItemComboBox As RepositoryItemComboBox,
    repositoryItemPopupContainerEdit As RepositoryItemPopupContainerEdit,
    repositoryItemTextEdit As RepositoryItemTextEdit,
    repositoryItemMemoEdit As RepositoryItemMemoEdit,
    repositoryItemSpinEdit As RepositoryItemSpinEdit,
    repositoryItemDateEdit As RepositoryItemDateEdit,
    repositoryItemCheckEdit As RepositoryItemCheckEdit,
    repositoryItemMemoExEdit As RepositoryItemMemoExEdit,
    repositoryItemHyperLinkEdit As RepositoryItemHyperLinkEdit
)
public:
static void AssociateEditorControl(
    DedAttr^ attr,
    Object^ col,
    Dictionary<Object^, RepositoryItem^>^ dizColRep,
    RepositoryItemCheckedComboBoxEdit^ repositoryItemCheckedComboBoxEdit,
    RepositoryItemComboBox^ repositoryItemComboBox,
    RepositoryItemPopupContainerEdit^ repositoryItemPopupContainerEdit,
    RepositoryItemTextEdit^ repositoryItemTextEdit,
    RepositoryItemMemoEdit^ repositoryItemMemoEdit,
    RepositoryItemSpinEdit^ repositoryItemSpinEdit,
    RepositoryItemDateEdit^ repositoryItemDateEdit,
    RepositoryItemCheckEdit^ repositoryItemCheckEdit,
    RepositoryItemMemoExEdit^ repositoryItemMemoExEdit,
    RepositoryItemHyperLinkEdit^ repositoryItemHyperLinkEdit
)
static member AssociateEditorControl :
        attr : DedAttr *
        col : Object *
        dizColRep : Dictionary<Object, RepositoryItem> *
        repositoryItemCheckedComboBoxEdit : RepositoryItemCheckedComboBoxEdit *
        repositoryItemComboBox : RepositoryItemComboBox *
        repositoryItemPopupContainerEdit : RepositoryItemPopupContainerEdit *
        repositoryItemTextEdit : RepositoryItemTextEdit *
        repositoryItemMemoEdit : RepositoryItemMemoEdit *
        repositoryItemSpinEdit : RepositoryItemSpinEdit *
        repositoryItemDateEdit : RepositoryItemDateEdit *
        repositoryItemCheckEdit : RepositoryItemCheckEdit *
        repositoryItemMemoExEdit : RepositoryItemMemoExEdit *
        repositoryItemHyperLinkEdit : RepositoryItemHyperLinkEdit -> unit

Parametri

attr DedAttr
col Object
dizColRep Dictionary Object, RepositoryItem
repositoryItemCheckedComboBoxEdit RepositoryItemCheckedComboBoxEdit
repositoryItemComboBox RepositoryItemComboBox
repositoryItemPopupContainerEdit RepositoryItemPopupContainerEdit
repositoryItemTextEdit RepositoryItemTextEdit
repositoryItemMemoEdit RepositoryItemMemoEdit
repositoryItemSpinEdit RepositoryItemSpinEdit
repositoryItemDateEdit RepositoryItemDateEdit
repositoryItemCheckEdit RepositoryItemCheckEdit
repositoryItemMemoExEdit RepositoryItemMemoExEdit
repositoryItemHyperLinkEdit RepositoryItemHyperLinkEdit
Vedi anche

Documentazione

Classe DevExpressUtility
Namespace DedNet.Lib


Metodo DevExpressUtility.ColumnIsEditable

Metodo DevExpressUtilityColumnIsEditable
Ritorna True se la colonna è editabile, False altrimenti (controlla tutte le proprietà della colonna).

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool ColumnIsEditable(
    GridColumn col
)
Public Shared Function ColumnIsEditable (
    col As GridColumn
) As Boolean
public:
static bool ColumnIsEditable(
    GridColumn^ col
)
static member ColumnIsEditable :
        col : GridColumn -> bool

Parametri

col GridColumn

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DevExpressUtility
Namespace DedNet.Lib


Metodo DevExpressUtility.CustomizeCell

Metodo DevExpressUtilityCustomizeCell
Lista degli overload
Nome | Descrizione
CustomizeCell(GridView, RowCellCustomDrawEventArgs, Image, Color) | Personalizza la cella della griglia in base alle informazioni specificate in ingresso.
CustomizeCell(GridView, RowCellCustomDrawEventArgs, Image, Color, Boolean) | Personalizza la cella della griglia in base alle informazioni specificate in ingresso.
Torna su
Vedi anche

Documentazione

Classe DevExpressUtility
Namespace DedNet.Lib


Metodo DevExpressUtility.CustomizeCell(GridView, RowCellCustomDrawEventArgs, Image, Color)

Metodo DevExpressUtilityCustomizeCell(GridView, RowCellCustomDrawEventArgs, Image, Color)
Personalizza la cella della griglia in base alle informazioni specificate in ingresso.

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void CustomizeCell(
    GridView view,
    RowCellCustomDrawEventArgs e,
    Image img,
    Color rectangle
)
Public Shared Sub CustomizeCell (
    view As GridView,
    e As RowCellCustomDrawEventArgs,
    img As Image,
    rectangle As Color
)
public:
static void CustomizeCell(
    GridView^ view,
    RowCellCustomDrawEventArgs^ e,
    Image^ img,
    Color rectangle
)
static member CustomizeCell :
        view : GridView *
        e : RowCellCustomDrawEventArgs *
        img : Image *
        rectangle : Color -> unit

Parametri

view GridView
Vista della griglia.
e RowCellCustomDrawEventArgs
Evento correntemente processato.
img Image
Immagine che si vuole aggiungere alla cella.
rectangle Color
Colore del bordo della cella.
Vedi anche

Documentazione

Classe DevExpressUtility
Overload di CustomizeCell
Namespace DedNet.Lib


Metodo DevExpressUtility.CustomizeCell(GridView, RowCellCustomDrawEventArgs, Image, Color, Boolean)

Metodo DevExpressUtilityCustomizeCell(GridView, RowCellCustomDrawEventArgs, Image, Color, Boolean)
Personalizza la cella della griglia in base alle informazioni specificate in ingresso.

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void CustomizeCell(
    GridView view,
    RowCellCustomDrawEventArgs e,
    Image img,
    Color rectangle,
    bool drawGrip
)
Public Shared Sub CustomizeCell (
    view As GridView,
    e As RowCellCustomDrawEventArgs,
    img As Image,
    rectangle As Color,
    drawGrip As Boolean
)
public:
static void CustomizeCell(
    GridView^ view,
    RowCellCustomDrawEventArgs^ e,
    Image^ img,
    Color rectangle,
    bool drawGrip
)
static member CustomizeCell :
        view : GridView *
        e : RowCellCustomDrawEventArgs *
        img : Image *
        rectangle : Color *
        drawGrip : bool -> unit

Parametri

view GridView
Vista della griglia.
e RowCellCustomDrawEventArgs
Evento correntemente processato.
img Image
Immagine che si vuole aggiungere alla cella.
rectangle Color
Colore del bordo della cella.
drawGrip Boolean
Coordinate del mouse. Se diverse da 0,0 indica se disegnare il gripin basso a dx per indicare all'utente la possibilità di copiare il valore della cella trascinandola (come excel).
Vedi anche

Documentazione

Classe DevExpressUtility
Overload di CustomizeCell
Namespace DedNet.Lib


Metodo DevExpressUtility.FixTreeListView

Metodo DevExpressUtilityFixTreeListView
Risolve i problemi di visualizzazione dovuti all'utilizzo di monitor 4k.

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void FixTreeListView(
    TreeList tree
)
Public Shared Sub FixTreeListView (
    tree As TreeList
)
public:
static void FixTreeListView(
    TreeList^ tree
)
static member FixTreeListView :
        tree : TreeList -> unit

Parametri

tree TreeList
Vedi anche

Documentazione

Classe DevExpressUtility
Namespace DedNet.Lib


Metodo DevExpressUtility.GetControlTextColor

Metodo DevExpressUtilityGetControlTextColor
Ritorna il colore di default del testo in base allo skin attualmente impostato.

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static Color GetControlTextColor(
    ISupportLookAndFeel ctrl
)
Public Shared Function GetControlTextColor (
    ctrl As ISupportLookAndFeel
) As Color
public:
static Color GetControlTextColor(
    ISupportLookAndFeel^ ctrl
)
static member GetControlTextColor :
        ctrl : ISupportLookAndFeel -> Color

Parametri

ctrl ISupportLookAndFeel

Valore di ritorno

Color
Vedi anche

Documentazione

Classe DevExpressUtility
Namespace DedNet.Lib


Metodo DevExpressUtility.GetReadOnlyBackColor

Metodo DevExpressUtilityGetReadOnlyBackColor
Ritorna il colore 'ReadOnly' a seconda dello skin attualmente impostato.

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static Color GetReadOnlyBackColor(
    ISupportLookAndFeel ctrl
)
Public Shared Function GetReadOnlyBackColor (
    ctrl As ISupportLookAndFeel
) As Color
public:
static Color GetReadOnlyBackColor(
    ISupportLookAndFeel^ ctrl
)
static member GetReadOnlyBackColor :
        ctrl : ISupportLookAndFeel -> Color

Parametri

ctrl ISupportLookAndFeel

Valore di ritorno

Color
Vedi anche

Documentazione

Classe DevExpressUtility
Namespace DedNet.Lib


Metodo DevExpressUtility.GetWindowTextColor

Metodo DevExpressUtilityGetWindowTextColor
Ritorna il colore di default del testo in base allo skin attualmente impostato.

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static Color GetWindowTextColor(
    ISupportLookAndFeel ctrl
)
Public Shared Function GetWindowTextColor (
    ctrl As ISupportLookAndFeel
) As Color
public:
static Color GetWindowTextColor(
    ISupportLookAndFeel^ ctrl
)
static member GetWindowTextColor :
        ctrl : ISupportLookAndFeel -> Color

Parametri

ctrl ISupportLookAndFeel

Valore di ritorno

Color
Vedi anche

Documentazione

Classe DevExpressUtility
Namespace DedNet.Lib


Metodo DevExpressUtility.IsPointOnTheGrip

Metodo DevExpressUtilityIsPointOnTheGrip

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool IsPointOnTheGrip(
    GridView view,
    Point pt
)
Public Shared Function IsPointOnTheGrip (
    view As GridView,
    pt As Point
) As Boolean
public:
static bool IsPointOnTheGrip(
    GridView^ view,
    Point pt
)
static member IsPointOnTheGrip :
        view : GridView *
        pt : Point -> bool

Parametri

view GridView
pt Point

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DevExpressUtility
Namespace DedNet.Lib


Metodo DevExpressUtility.MakeRepository

Metodo DevExpressUtilityMakeRepository
REstituisce il repository in base alle impostazioni dell'attributo passato.

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static RepositoryItem MakeRepository(
    DedAttr attr,
    RepositoryItemCheckedComboBoxEdit repositoryItemCheckedComboBoxEdit,
    RepositoryItemComboBox repositoryItemComboBox,
    RepositoryItemPopupContainerEdit repositoryItemPopupContainerEdit,
    RepositoryItemTextEdit repositoryItemTextEdit,
    RepositoryItemMemoEdit repositoryItemMemoEdit,
    RepositoryItemSpinEdit repositoryItemSpinEdit,
    RepositoryItemDateEdit repositoryItemDateEdit,
    RepositoryItemCheckEdit repositoryItemCheckEdit,
    RepositoryItemMemoExEdit repositoryItemMemoExEdit,
    RepositoryItemHyperLinkEdit repositoryItemHyperLinkEdit
)
Public Shared Function MakeRepository (
    attr As DedAttr,
    repositoryItemCheckedComboBoxEdit As RepositoryItemCheckedComboBoxEdit,
    repositoryItemComboBox As RepositoryItemComboBox,
    repositoryItemPopupContainerEdit As RepositoryItemPopupContainerEdit,
    repositoryItemTextEdit As RepositoryItemTextEdit,
    repositoryItemMemoEdit As RepositoryItemMemoEdit,
    repositoryItemSpinEdit As RepositoryItemSpinEdit,
    repositoryItemDateEdit As RepositoryItemDateEdit,
    repositoryItemCheckEdit As RepositoryItemCheckEdit,
    repositoryItemMemoExEdit As RepositoryItemMemoExEdit,
    repositoryItemHyperLinkEdit As RepositoryItemHyperLinkEdit
) As RepositoryItem
public:
static RepositoryItem^ MakeRepository(
    DedAttr^ attr,
    RepositoryItemCheckedComboBoxEdit^ repositoryItemCheckedComboBoxEdit,
    RepositoryItemComboBox^ repositoryItemComboBox,
    RepositoryItemPopupContainerEdit^ repositoryItemPopupContainerEdit,
    RepositoryItemTextEdit^ repositoryItemTextEdit,
    RepositoryItemMemoEdit^ repositoryItemMemoEdit,
    RepositoryItemSpinEdit^ repositoryItemSpinEdit,
    RepositoryItemDateEdit^ repositoryItemDateEdit,
    RepositoryItemCheckEdit^ repositoryItemCheckEdit,
    RepositoryItemMemoExEdit^ repositoryItemMemoExEdit,
    RepositoryItemHyperLinkEdit^ repositoryItemHyperLinkEdit
)
static member MakeRepository :
        attr : DedAttr *
        repositoryItemCheckedComboBoxEdit : RepositoryItemCheckedComboBoxEdit *
        repositoryItemComboBox : RepositoryItemComboBox *
        repositoryItemPopupContainerEdit : RepositoryItemPopupContainerEdit *
        repositoryItemTextEdit : RepositoryItemTextEdit *
        repositoryItemMemoEdit : RepositoryItemMemoEdit *
        repositoryItemSpinEdit : RepositoryItemSpinEdit *
        repositoryItemDateEdit : RepositoryItemDateEdit *
        repositoryItemCheckEdit : RepositoryItemCheckEdit *
        repositoryItemMemoExEdit : RepositoryItemMemoExEdit *
        repositoryItemHyperLinkEdit : RepositoryItemHyperLinkEdit -> RepositoryItem

Parametri

attr DedAttr
Attributo del quale generare il repository
repositoryItemCheckedComboBoxEdit RepositoryItemCheckedComboBoxEdit
repositoryItemComboBox RepositoryItemComboBox
repositoryItemPopupContainerEdit RepositoryItemPopupContainerEdit
repositoryItemTextEdit RepositoryItemTextEdit
repositoryItemMemoEdit RepositoryItemMemoEdit
repositoryItemSpinEdit RepositoryItemSpinEdit
repositoryItemDateEdit RepositoryItemDateEdit
repositoryItemCheckEdit RepositoryItemCheckEdit
repositoryItemMemoExEdit RepositoryItemMemoExEdit
repositoryItemHyperLinkEdit RepositoryItemHyperLinkEdit

Valore di ritorno

RepositoryItem
Vedi anche

Documentazione

Classe DevExpressUtility
Namespace DedNet.Lib


Metodo DevExpressUtility.SeriesDataMemberMustBeSet

Metodo DevExpressUtilitySeriesDataMemberMustBeSet
Ritorna True nel caso in cui il campo 'SeriesDataMember' necessiti di essere compilato, False altrimenti. Attenzione! Il campo 'SeriesDataMember' deve essere compilato solamente nel caso in cui il tipo di diagramma necessiti di avere a schermo più serie (per esempio in un grafico a linee o barre). In caso contrario (per esempio in un diagramma a torta) non lo compilo in modo tale che tutti i dati vengano riportati in una serie sola.

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool SeriesDataMemberMustBeSet(
    SeriesViewBase view
)
Public Shared Function SeriesDataMemberMustBeSet (
    view As SeriesViewBase
) As Boolean
public:
static bool SeriesDataMemberMustBeSet(
    SeriesViewBase^ view
)
static member SeriesDataMemberMustBeSet :
        view : SeriesViewBase -> bool

Parametri

view SeriesViewBase

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DevExpressUtility
Namespace DedNet.Lib


Metodo DevExpressUtility.SetRepositoryCase

Metodo DevExpressUtilitySetRepositoryCase
Setta il case sensitive del repository

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void SetRepositoryCase(
    RepositoryItem rep,
    DedAttr attr
)
Public Shared Sub SetRepositoryCase (
    rep As RepositoryItem,
    attr As DedAttr
)
public:
static void SetRepositoryCase(
    RepositoryItem^ rep,
    DedAttr^ attr
)
static member SetRepositoryCase :
        rep : RepositoryItem *
        attr : DedAttr -> unit

Parametri

rep RepositoryItem
repository da modificare
attr DedAttr
Attributo del repository
Vedi anche

Documentazione

Classe DevExpressUtility
Namespace DedNet.Lib


Metodo DevExpressUtility.SetRepositoryFormat

Metodo DevExpressUtilitySetRepositoryFormat
Setta il formato di visualizzazione del repository

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void SetRepositoryFormat(
    RepositoryItem rep,
    DedAttr attr
)
Public Shared Sub SetRepositoryFormat (
    rep As RepositoryItem,
    attr As DedAttr
)
public:
static void SetRepositoryFormat(
    RepositoryItem^ rep,
    DedAttr^ attr
)
static member SetRepositoryFormat :
        rep : RepositoryItem *
        attr : DedAttr -> unit

Parametri

rep RepositoryItem
repository da modificare
attr DedAttr
Attributo del repository
Vedi anche

Documentazione

Classe DevExpressUtility
Namespace DedNet.Lib


Metodo DevExpressUtility.SetRepositoryInfo

Metodo DevExpressUtilitySetRepositoryInfo
Setta tutte le impostazioni del repository

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void SetRepositoryInfo(
    RepositoryItem rep,
    DedAttr attr
)
Public Shared Sub SetRepositoryInfo (
    rep As RepositoryItem,
    attr As DedAttr
)
public:
static void SetRepositoryInfo(
    RepositoryItem^ rep,
    DedAttr^ attr
)
static member SetRepositoryInfo :
        rep : RepositoryItem *
        attr : DedAttr -> unit

Parametri

rep RepositoryItem
repository da modificare
attr DedAttr
Attributo del repository
Vedi anche

Documentazione

Classe DevExpressUtility
Namespace DedNet.Lib


Metodo DevExpressUtility.SetRepositoryLength

Metodo DevExpressUtilitySetRepositoryLength
Setta la lunghezza del repository

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void SetRepositoryLength(
    RepositoryItem rep,
    DedAttr attr
)
Public Shared Sub SetRepositoryLength (
    rep As RepositoryItem,
    attr As DedAttr
)
public:
static void SetRepositoryLength(
    RepositoryItem^ rep,
    DedAttr^ attr
)
static member SetRepositoryLength :
        rep : RepositoryItem *
        attr : DedAttr -> unit

Parametri

rep RepositoryItem
repository da modificare
attr DedAttr
Attributo del repository
Vedi anche

Documentazione

Classe DevExpressUtility
Namespace DedNet.Lib


Enumerazione DocumentStateEnum
Enum indicante i possibili stati documentali.

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum DocumentStateEnum
Public Enumeration DocumentStateEnum
public enum class DocumentStateEnum
type DocumentStateEnum
Membri
Nome | Valore | Descrizione
CheckIn | 0 |
CheckOutByMe | 1 |
CheckOutByMeOnOtherHost | 2 |
CheckOutByOther | 3 |
Undefined | 4 |
Vedi anche

Documentazione

Namespace DedNet.Lib


Classe DragCellsValuesHelper
Gerarchia di ereditarietà
SystemObject
DedNet.LibDragCellsValuesHelper

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DragCellsValuesHelper
Public Class DragCellsValuesHelper
public ref class DragCellsValuesHelper
type DragCellsValuesHelper = class end

Il tipo DragCellsValuesHelper espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DragCellsValuesHelper |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | SourceTreeCell |
Proprietà pubblica | Tree |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Lib


Costruttore DragCellsValuesHelper

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DragCellsValuesHelper(
    SelectedCellsBorderHelper selectedCellsHelper
)
Public Sub New (
    selectedCellsHelper As SelectedCellsBorderHelper
)
public:
DragCellsValuesHelper(
    SelectedCellsBorderHelper^ selectedCellsHelper
)
new :
        selectedCellsHelper : SelectedCellsBorderHelper -> DragCellsValuesHelper

Parametri

selectedCellsHelper SelectedCellsBorderHelper
Vedi anche

Documentazione

Classe DragCellsValuesHelper
Namespace DedNet.Lib


Proprietà di DragCellsValuesHelper

Il tipo DragCellsValuesHelper espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | SourceTreeCell |
Proprietà pubblica | Tree |
Torna su
Vedi anche

Documentazione

Classe DragCellsValuesHelper
Namespace DedNet.Lib


Proprietà DragCellsValuesHelper.SourceTreeCell

Proprietà DragCellsValuesHelperSourceTreeCell

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public TreeListCell SourceTreeCell { get; set; }
Public Property SourceTreeCell As TreeListCell
    Get
    Set
public:
property TreeListCell^ SourceTreeCell {
    TreeListCell^ get ();
    void set (TreeListCell^ value);
}
member SourceTreeCell : TreeListCell with get, set

Valore della proprietà

TreeListCell
Vedi anche

Documentazione

Classe DragCellsValuesHelper
Namespace DedNet.Lib


Proprietà DragCellsValuesHelper.Tree

Proprietà DragCellsValuesHelperTree

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public TreeList Tree { get; }
Public ReadOnly Property Tree As TreeList
    Get
public:
property TreeList^ Tree {
    TreeList^ get ();
}
member Tree : TreeList with get

Valore della proprietà

TreeList
Vedi anche

Documentazione

Classe DragCellsValuesHelper
Namespace DedNet.Lib


Classe DragCellsValuesHelperGridView
Gerarchia di ereditarietà
SystemObject
DedNet.LibDragCellsValuesHelperGridView

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DragCellsValuesHelperGridView
Public Class DragCellsValuesHelperGridView
public ref class DragCellsValuesHelperGridView
type DragCellsValuesHelperGridView = class end

Il tipo DragCellsValuesHelperGridView espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DragCellsValuesHelperGridView |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | SourceGridCell |
Proprietà pubblica | View |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Lib


Costruttore DragCellsValuesHelperGridView

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DragCellsValuesHelperGridView(
    SelectedCellsBorderHelperGridView selectedCellsHelper
)
Public Sub New (
    selectedCellsHelper As SelectedCellsBorderHelperGridView
)
public:
DragCellsValuesHelperGridView(
    SelectedCellsBorderHelperGridView^ selectedCellsHelper
)
new :
        selectedCellsHelper : SelectedCellsBorderHelperGridView -> DragCellsValuesHelperGridView

Parametri

selectedCellsHelper SelectedCellsBorderHelperGridView
Vedi anche

Documentazione

Classe DragCellsValuesHelperGridView
Namespace DedNet.Lib


Proprietà di DragCellsValuesHelperGridView

Il tipo DragCellsValuesHelperGridView espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | SourceGridCell |
Proprietà pubblica | View |
Torna su
Vedi anche

Documentazione

Classe DragCellsValuesHelperGridView
Namespace DedNet.Lib


Proprietà DragCellsValuesHelperGridView.SourceGridCell

Proprietà DragCellsValuesHelperGridViewSourceGridCell

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public GridCell SourceGridCell { get; set; }
Public Property SourceGridCell As GridCell
    Get
    Set
public:
property GridCell^ SourceGridCell {
    GridCell^ get ();
    void set (GridCell^ value);
}
member SourceGridCell : GridCell with get, set

Valore della proprietà

GridCell
Vedi anche

Documentazione

Classe DragCellsValuesHelperGridView
Namespace DedNet.Lib


Proprietà DragCellsValuesHelperGridView.View

Proprietà DragCellsValuesHelperGridViewView

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public GridView View { get; }
Public ReadOnly Property View As GridView
    Get
public:
property GridView^ View {
    GridView^ get ();
}
member View : GridView with get

Valore della proprietà

GridView
Vedi anche

Documentazione

Classe DragCellsValuesHelperGridView
Namespace DedNet.Lib


Enumerazione DuplicatesOptionEnum
Enum indicante il tipo l'operazione da eseguire (durante l'importazione di anagrafiche/traduzioni) nel caso di elementi duplicati.

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum DuplicatesOptionEnum
Public Enumeration DuplicatesOptionEnum
public enum class DuplicatesOptionEnum
type DuplicatesOptionEnum
Membri
Nome | Valore | Descrizione
None | 0 | Nessuna modalità selezionata.
Skip | 1 | I duplicati non verranno importati (sarà valido il primo valore).
Update | 2 | I duplicati verranno aggiornati (sarà valido l'ultimo valore).
Vedi anche

Documentazione

Namespace DedNet.Lib


Classe EnumDescriptionHelper
Espone dei metodi per avere delle descrizioni leggibili all'utente data una enumerazione avente i membri "marchiati" con attributo System.ComponentModel.Description().
Gerarchia di ereditarietà
SystemObject
DedNet.LibEnumDescriptionHelper

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static class EnumDescriptionHelper
Public NotInheritable Class EnumDescriptionHelper
public ref class EnumDescriptionHelper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type EnumDescriptionHelper = class end

Il tipo EnumDescriptionHelper espone i seguenti membri.

Metodi
Nome | Descrizione
GetDescription | Restituisce il valore dell'attributo Description() abbinato al valore di una particolare enum se non lo trova restituisce il valore.
GetOnlyDescription | Restituisce il valore dell'attributo Description() abbinato al valore di una particolare enum se presente altrimenti stringa vuota.
ToList | Converte una enumerazione in una lista leggibile di stringhe.
ToListOnlyWithDescr | Converte una enumerazione in una lista leggibile di stringhe.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Lib


Metodi di EnumDescriptionHelper

Il tipo EnumDescriptionHelper espone i seguenti membri.

Metodi
Nome | Descrizione
GetDescription | Restituisce il valore dell'attributo Description() abbinato al valore di una particolare enum se non lo trova restituisce il valore.
GetOnlyDescription | Restituisce il valore dell'attributo Description() abbinato al valore di una particolare enum se presente altrimenti stringa vuota.
ToList | Converte una enumerazione in una lista leggibile di stringhe.
ToListOnlyWithDescr | Converte una enumerazione in una lista leggibile di stringhe.
Torna su
Vedi anche

Documentazione

Classe EnumDescriptionHelper
Namespace DedNet.Lib


Metodo EnumDescriptionHelper.GetDescription

Metodo EnumDescriptionHelperGetDescription
Restituisce il valore dell'attributo Description() abbinato al valore di una particolare enum se non lo trova restituisce il valore.

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string GetDescription(
    Enum value
)
Public Shared Function GetDescription (
    value As Enum
) As String
public:
static String^ GetDescription(
    Enum^ value
)
static member GetDescription :
        value : Enum -> string

Parametri

value Enum
Valore dell'enumerazione.

Valore di ritorno

String
Vedi anche

Documentazione

Classe EnumDescriptionHelper
Namespace DedNet.Lib


Metodo EnumDescriptionHelper.GetOnlyDescription

Metodo EnumDescriptionHelperGetOnlyDescription
Restituisce il valore dell'attributo Description() abbinato al valore di una particolare enum se presente altrimenti stringa vuota.

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string GetOnlyDescription(
    Enum value
)
Public Shared Function GetOnlyDescription (
    value As Enum
) As String
public:
static String^ GetOnlyDescription(
    Enum^ value
)
static member GetOnlyDescription :
        value : Enum -> string

Parametri

value Enum
Valore dell'enumerazione.

Valore di ritorno

String
Vedi anche

Documentazione

Classe EnumDescriptionHelper
Namespace DedNet.Lib


Metodo EnumDescriptionHelper.ToList

Metodo EnumDescriptionHelperToList
Converte una enumerazione in una lista leggibile di stringhe.

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static Dictionary<string, Enum> ToList(
    Type type
)
Public Shared Function ToList (
    type As Type
) As Dictionary(Of String, Enum)
public:
static Dictionary<String^, Enum^>^ ToList(
    Type^ type
)
static member ToList :
        type : Type -> Dictionary<string, Enum>

Parametri

type Type
Tipo dell'enumerazione.

Valore di ritorno

Dictionary String, Enum
Vedi anche

Documentazione

Classe EnumDescriptionHelper
Namespace DedNet.Lib


Metodo EnumDescriptionHelper.ToListOnlyWithDescr

Metodo EnumDescriptionHelperToListOnlyWithDescr
Converte una enumerazione in una lista leggibile di stringhe.

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static Dictionary<string, Enum> ToListOnlyWithDescr(
    Type type
)
Public Shared Function ToListOnlyWithDescr (
    type As Type
) As Dictionary(Of String, Enum)
public:
static Dictionary<String^, Enum^>^ ToListOnlyWithDescr(
    Type^ type
)
static member ToListOnlyWithDescr :
        type : Type -> Dictionary<string, Enum>

Parametri

type Type
Tipo dell'enumerazione.

Valore di ritorno

Dictionary String, Enum
Vedi anche

Documentazione

Classe EnumDescriptionHelper
Namespace DedNet.Lib


Classe FileServerManager
Classe contenente le informazioni sulla gestione e le impostazione della gestione client/server dei file.
Gerarchia di ereditarietà
SystemObject
DedNet.LibFileServerManager

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class FileServerManager
Public Class FileServerManager
public ref class FileServerManager
type FileServerManager = class end

Il tipo FileServerManager espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | FileServerManager | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Active | Imposta e restituisce se è attiva la gestione client/server dei file
Proprietà pubblica | ClientSecret |
Proprietà pubblica | Token | Restituisce il to
Proprietà pubblica | Url | Imposta e restituisce l'indirizzo del Server
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AssertIsAlive | Controlla se il server a attivo. In caso non lo sia genera un'eccezione
Metodo pubblico | AuthorizeClient | Chiede al server il token di autenticazione
Metodo pubblico | SendRootInfo | Controlla se il server a attivo. In caso non lo sia genera un'eccezione
Torna su
Vedi anche

Documentazione

Namespace DedNet.Lib


Costruttore FileServerManager
Costruttore unico.

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public FileServerManager()
Public Sub New
public:
FileServerManager()
new : unit -> FileServerManager
Vedi anche

Documentazione

Classe FileServerManager
Namespace DedNet.Lib


Proprietà di FileServerManager

Il tipo FileServerManager espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Active | Imposta e restituisce se è attiva la gestione client/server dei file
Proprietà pubblica | ClientSecret |
Proprietà pubblica | Token | Restituisce il to
Proprietà pubblica | Url | Imposta e restituisce l'indirizzo del Server
Torna su
Vedi anche

Documentazione

Classe FileServerManager
Namespace DedNet.Lib


Proprietà FileServerManager.Active

Proprietà FileServerManagerActive
Imposta e restituisce se è attiva la gestione client/server dei file

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Active { get; set; }
Public Property Active As Boolean
    Get
    Set
public:
property bool Active {
    bool get ();
    void set (bool value);
}
member Active : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe FileServerManager
Namespace DedNet.Lib


Proprietà FileServerManager.ClientSecret

Proprietà FileServerManagerClientSecret

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string ClientSecret { get; set; }
Public Property ClientSecret As String
    Get
    Set
public:
property String^ ClientSecret {
    String^ get ();
    void set (String^ value);
}
member ClientSecret : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe FileServerManager
Namespace DedNet.Lib


Proprietà FileServerManager.Token

Proprietà FileServerManagerToken
Restituisce il to

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Token { get; }
Public ReadOnly Property Token As String
    Get
public:
property String^ Token {
    String^ get ();
}
member Token : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe FileServerManager
Namespace DedNet.Lib


Proprietà FileServerManager.Url

Proprietà FileServerManagerUrl
Imposta e restituisce l'indirizzo del Server

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Url { get; set; }
Public Property Url As String
    Get
    Set
public:
property String^ Url {
    String^ get ();
    void set (String^ value);
}
member Url : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe FileServerManager
Namespace DedNet.Lib


Metodi di FileServerManager

Il tipo FileServerManager espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AssertIsAlive | Controlla se il server a attivo. In caso non lo sia genera un'eccezione
Metodo pubblico | AuthorizeClient | Chiede al server il token di autenticazione
Metodo pubblico | SendRootInfo | Controlla se il server a attivo. In caso non lo sia genera un'eccezione
Torna su
Vedi anche

Documentazione

Classe FileServerManager
Namespace DedNet.Lib


Metodo FileServerManager.AssertIsAlive

Metodo FileServerManagerAssertIsAlive
Controlla se il server a attivo. In caso non lo sia genera un'eccezione

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AssertIsAlive()
Public Sub AssertIsAlive
public:
void AssertIsAlive()
member AssertIsAlive : unit -> unit
Vedi anche

Documentazione

Classe FileServerManager
Namespace DedNet.Lib


Metodo FileServerManager.AuthorizeClient

Metodo FileServerManagerAuthorizeClient
Chiede al server il token di autenticazione

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void AuthorizeClient()
Public Sub AuthorizeClient
public:
void AuthorizeClient()
member AuthorizeClient : unit -> unit
Vedi anche

Documentazione

Classe FileServerManager
Namespace DedNet.Lib


Metodo FileServerManager.SendRootInfo

Metodo FileServerManagerSendRootInfo
Controlla se il server a attivo. In caso non lo sia genera un'eccezione

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SendRootInfo(
    bool forcerolad
)
Public Sub SendRootInfo (
    forcerolad As Boolean
)
public:
void SendRootInfo(
    bool forcerolad
)
member SendRootInfo :
        forcerolad : bool -> unit

Parametri

forcerolad Boolean
Vedi anche

Documentazione

Classe FileServerManager
Namespace DedNet.Lib


Classe FileTransaction
Classe per la gestione delle transazione sulla copia, spostamento o modifica delle proprietà dei file.
Gerarchia di ereditarietà
SystemObject
DedNet.LibFileTransaction

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class FileTransaction
Public Class FileTransaction
public ref class FileTransaction
type FileTransaction = class end

Il tipo FileTransaction espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | FileTransaction | Costruttore dell'oggetto.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | RollBackOnError | Restituisce o imposta se effettuare il Rollback in caso di errore durante l'esecuzione. Di default è true.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Commit | Questo metodo conferma le operazioni effettuate. L'utilizzatore di questo oggetto deve chiamare questo metodo per fare 'pulizia' dei file temporanei.
 | EraseRenameFile | Elimina il file rinominandolo con il nome creato con MakeRenameFileName.
Metodo pubblico | Execute | Esegue tutte le operazioni registrate nell'ordine specificato. Se una sola delle operazioni ha esito negativo viene effettuato il rollback automatico di quelle effettuate fino a quel momento.
Metodo pubblico | FileCopy | Accoda un'operazione di copia file.
Metodo pubblico | FileErase | Accoda un'operazione di eliminazione file. Il file viene rinominato con la seguente regola: c:\pippo.txt -> c:\pippo.txt.20101216122300.erased
Metodo pubblico | FileMove | Accoda un'operazione di spostamento file. Restituisce una eccezione se il file di destinazione è già presente a meno che il .moved non vada creato
Metodo pubblico | FileReadOnly | Accoda un'operazione di impostazione file readonly oppure non readonly.
Metodo pubblico | FileRename | Accoda un'operazione di rinomina file. Restituisce una eccezione se il file di destinazione è già presente.
 | MakeRenameFileName | Accoda alla stringa passata la data attuale e l'estensione ".erased".
Metodo pubblico | Rollback | Effettua il Rollback delle operazioni eseguite. Questo metodo viene chiamato in automatico da Execute se una delle azioni ha esito negativo ma può essere anche chiamato esplicitamente per ripristinare la situazione a prima di una esecuzione.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Lib


Costruttore FileTransaction
Costruttore dell'oggetto.

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public FileTransaction()
Public Sub New
public:
FileTransaction()
new : unit -> FileTransaction
Vedi anche

Documentazione

Classe FileTransaction
Namespace DedNet.Lib


Proprietà di FileTransaction

Il tipo FileTransaction espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | RollBackOnError | Restituisce o imposta se effettuare il Rollback in caso di errore durante l'esecuzione. Di default è true.
Torna su
Vedi anche

Documentazione

Classe FileTransaction
Namespace DedNet.Lib


Proprietà FileTransaction.RollBackOnError

Proprietà FileTransactionRollBackOnError
Restituisce o imposta se effettuare il Rollback in caso di errore durante l'esecuzione. Di default è true.

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool RollBackOnError { get; set; }
Public Property RollBackOnError As Boolean
    Get
    Set
public:
property bool RollBackOnError {
    bool get ();
    void set (bool value);
}
member RollBackOnError : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe FileTransaction
Namespace DedNet.Lib


Metodi di FileTransaction

Il tipo FileTransaction espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Commit | Questo metodo conferma le operazioni effettuate. L'utilizzatore di questo oggetto deve chiamare questo metodo per fare 'pulizia' dei file temporanei.
 | EraseRenameFile | Elimina il file rinominandolo con il nome creato con MakeRenameFileName.
Metodo pubblico | Execute | Esegue tutte le operazioni registrate nell'ordine specificato. Se una sola delle operazioni ha esito negativo viene effettuato il rollback automatico di quelle effettuate fino a quel momento.
Metodo pubblico | FileCopy | Accoda un'operazione di copia file.
Metodo pubblico | FileErase | Accoda un'operazione di eliminazione file. Il file viene rinominato con la seguente regola: c:\pippo.txt -> c:\pippo.txt.20101216122300.erased
Metodo pubblico | FileMove | Accoda un'operazione di spostamento file. Restituisce una eccezione se il file di destinazione è già presente a meno che il .moved non vada creato
Metodo pubblico | FileReadOnly | Accoda un'operazione di impostazione file readonly oppure non readonly.
Metodo pubblico | FileRename | Accoda un'operazione di rinomina file. Restituisce una eccezione se il file di destinazione è già presente.
 | MakeRenameFileName | Accoda alla stringa passata la data attuale e l'estensione ".erased".
Metodo pubblico | Rollback | Effettua il Rollback delle operazioni eseguite. Questo metodo viene chiamato in automatico da Execute se una delle azioni ha esito negativo ma può essere anche chiamato esplicitamente per ripristinare la situazione a prima di una esecuzione.
Torna su
Vedi anche

Documentazione

Classe FileTransaction
Namespace DedNet.Lib


Metodo FileTransaction.Commit

Metodo FileTransactionCommit
Questo metodo conferma le operazioni effettuate. L'utilizzatore di questo oggetto deve chiamare questo metodo per fare 'pulizia' dei file temporanei.

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Commit()
Public Sub Commit
public:
void Commit()
member Commit : unit -> unit
Vedi anche

Documentazione

Classe FileTransaction
Namespace DedNet.Lib


Metodo FileTransaction.EraseRenameFile

Metodo FileTransactionEraseRenameFile
Elimina il file rinominandolo con il nome creato con MakeRenameFileName.

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string EraseRenameFile(
    string fileName
)
Public Shared Function EraseRenameFile (
    fileName As String
) As String
public:
static String^ EraseRenameFile(
    String^ fileName
)
static member EraseRenameFile :
        fileName : string -> string

Parametri

fileName String
Nome completo del file da eliminare rinominandolo.

Valore di ritorno

String
Restituisce il nome attuale del file rinominato.
Vedi anche

Documentazione

Classe FileTransaction
Namespace DedNet.Lib


Metodo FileTransaction.Execute

Metodo FileTransactionExecute
Esegue tutte le operazioni registrate nell'ordine specificato. Se una sola delle operazioni ha esito negativo viene effettuato il rollback automatico di quelle effettuate fino a quel momento.

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Execute()
Public Sub Execute
public:
void Execute()
member Execute : unit -> unit
Vedi anche

Documentazione

Classe FileTransaction
Namespace DedNet.Lib


Metodo FileTransaction.FileCopy

Metodo FileTransactionFileCopy
Accoda un'operazione di copia file.

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void FileCopy(
    string fileFrom,
    string fileTo,
    bool overvriteFileTo
)
Public Sub FileCopy (
    fileFrom As String,
    fileTo As String,
    overvriteFileTo As Boolean
)
public:
void FileCopy(
    String^ fileFrom,
    String^ fileTo,
    bool overvriteFileTo
)
member FileCopy :
        fileFrom : string *
        fileTo : string *
        overvriteFileTo : bool -> unit

Parametri

fileFrom String
Nome del file da copiare.
fileTo String
Nome di destinazione.
overvriteFileTo Boolean
Indica se sollevare una eccezione se il file di destinazione è presente.
Vedi anche

Documentazione

Classe FileTransaction
Namespace DedNet.Lib


Metodo FileTransaction.FileErase

Metodo FileTransactionFileErase
Accoda un'operazione di eliminazione file. Il file viene rinominato con la seguente regola: c:\pippo.txt -> c:\pippo.txt.20101216122300.erased

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void FileErase(
    string fileName
)
Public Sub FileErase (
    fileName As String
)
public:
void FileErase(
    String^ fileName
)
member FileErase :
        fileName : string -> unit

Parametri

fileName String
Nome del file da eliminare.
Vedi anche

Documentazione

Classe FileTransaction
Namespace DedNet.Lib


Metodo FileTransaction.FileMove

Metodo FileTransactionFileMove
Accoda un'operazione di spostamento file. Restituisce una eccezione se il file di destinazione è già presente a meno che il .moved non vada creato

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void FileMove(
    string fileFrom,
    string fileTo,
    bool addMovedMarker = true
)
Public Sub FileMove (
    fileFrom As String,
    fileTo As String,
    Optional addMovedMarker As Boolean = true
)
public:
void FileMove(
    String^ fileFrom,
    String^ fileTo,
    bool addMovedMarker = true
)
member FileMove :
        fileFrom : string *
        fileTo : string *
        ?addMovedMarker : bool
(* Defaults:
        let _addMovedMarker = defaultArg addMovedMarker true
*)
-> unit

Parametri

fileFrom String
Nome del file di partenza.
fileTo String
Nuovo nome che dovrà avere il file.
addMovedMarker Boolean (Optional)
Se vero e le circostanze lo consentono aggiunge il clone del file .moved
Vedi anche

Documentazione

Classe FileTransaction
Namespace DedNet.Lib


Metodo FileTransaction.FileReadOnly

Metodo FileTransactionFileReadOnly
Accoda un'operazione di impostazione file readonly oppure non readonly.

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void FileReadOnly(
    string fileName,
    bool readOnly
)
Public Sub FileReadOnly (
    fileName As String,
    readOnly As Boolean
)
public:
void FileReadOnly(
    String^ fileName,
    bool readOnly
)
member FileReadOnly :
        fileName : string *
        readOnly : bool -> unit

Parametri

fileName String
Nome del file da modificare.
readOnly Boolean
Indica se il file debba essere impostato in sola lettura (true) oppure essere scrivibile (false).
Vedi anche

Documentazione

Classe FileTransaction
Namespace DedNet.Lib


Metodo FileTransaction.FileRename

Metodo FileTransactionFileRename
Accoda un'operazione di rinomina file. Restituisce una eccezione se il file di destinazione è già presente.

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void FileRename(
    string fileFrom,
    string fileTo
)
Public Sub FileRename (
    fileFrom As String,
    fileTo As String
)
public:
void FileRename(
    String^ fileFrom,
    String^ fileTo
)
member FileRename :
        fileFrom : string *
        fileTo : string -> unit

Parametri

fileFrom String
Nome del file di partenza.
fileTo String
Nuovo nome che dovrà avere il file.
Vedi anche

Documentazione

Classe FileTransaction
Namespace DedNet.Lib


Metodo FileTransaction.MakeRenameFileName

Metodo FileTransactionMakeRenameFileName
Accoda alla stringa passata la data attuale e l'estensione ".erased".

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string MakeRenameFileName(
    string fileName
)
Public Shared Function MakeRenameFileName (
    fileName As String
) As String
public:
static String^ MakeRenameFileName(
    String^ fileName
)
static member MakeRenameFileName :
        fileName : string -> string

Parametri

fileName String
Nome del file, completo di estensione, al quale accodare la stringa di eliminazione.

Valore di ritorno

String
Restituisce la stringa con il nome del file da eliminare.
Vedi anche

Documentazione

Classe FileTransaction
Namespace DedNet.Lib


Metodo FileTransaction.Rollback

Metodo FileTransactionRollback
Effettua il Rollback delle operazioni eseguite. Questo metodo viene chiamato in automatico da Execute se una delle azioni ha esito negativo ma può essere anche chiamato esplicitamente per ripristinare la situazione a prima di una esecuzione.

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void Rollback()
Public Sub Rollback
public:
void Rollback()
member Rollback : unit -> unit
Vedi anche

Documentazione

Classe FileTransaction
Namespace DedNet.Lib


Classe GridControlState
Gerarchia di ereditarietà
SystemObject
DedNet.LibGridControlState

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class GridControlState
Public Class GridControlState
public ref class GridControlState
type GridControlState = class end

Il tipo GridControlState espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | GridControlState |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | LoadViewInfo |
Metodo pubblico | SaveViewInfo |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Lib


Costruttore GridControlState

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public GridControlState(
    GridControlStateViewDescriptor[] views
)
Public Sub New (
    views As GridControlStateViewDescriptor()
)
public:
GridControlState(
    array<GridControlStateViewDescriptor>^ views
)
new :
        views : GridControlStateViewDescriptor[] -> GridControlState

Parametri

views GridControlStateViewDescriptor
Vedi anche

Documentazione

Classe GridControlState
Namespace DedNet.Lib


Metodi di GridControlState

Il tipo GridControlState espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | LoadViewInfo |
Metodo pubblico | SaveViewInfo |
Torna su
Vedi anche

Documentazione

Classe GridControlState
Namespace DedNet.Lib


Metodo GridControlState.LoadViewInfo

Metodo GridControlStateLoadViewInfo

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void LoadViewInfo(
    GridView view
)
Public Sub LoadViewInfo (
    view As GridView
)
public:
void LoadViewInfo(
    GridView^ view
)
member LoadViewInfo :
        view : GridView -> unit

Parametri

view GridView
Vedi anche

Documentazione

Classe GridControlState
Namespace DedNet.Lib


Metodo GridControlState.SaveViewInfo

Metodo GridControlStateSaveViewInfo

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SaveViewInfo(
    GridView view
)
Public Sub SaveViewInfo (
    view As GridView
)
public:
void SaveViewInfo(
    GridView^ view
)
member SaveViewInfo :
        view : GridView -> unit

Parametri

view GridView
Vedi anche

Documentazione

Classe GridControlState
Namespace DedNet.Lib


Struttura GridControlState.RowInfo

Struttura GridControlStateRowInfo
Gerarchia di ereditarietà
SystemObject
SystemValueType
DedNet.LibGridControlStateRowInfo

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public struct RowInfo
Public Structure RowInfo
public value class RowInfo
[<SealedAttribute>]
type RowInfo =
    struct
        inherit ValueType
    end

Il tipo GridControlStateRowInfo espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | Id |
Campo pubblico | level |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Lib


Campi di RowInfo

Il tipo GridControlStateRowInfo espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | Id |
Campo pubblico | level |
Torna su
Vedi anche

Documentazione

Struttura GridControlStateRowInfo
Namespace DedNet.Lib


Campo GridControlState.RowInfo.Id

Campo GridControlStateRowInfoId

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object Id
Public Id As Object
public:
Object^ Id
val mutable Id: Object

Valore del campo

Object
Vedi anche

Documentazione

Struttura GridControlStateRowInfo
Namespace DedNet.Lib


Campo GridControlState.RowInfo.level

Campo GridControlStateRowInfolevel

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public int level
Public level As Integer
public:
int level
val mutable level: int

Valore del campo

Int32
Vedi anche

Documentazione

Struttura GridControlStateRowInfo
Namespace DedNet.Lib


Struttura GridControlState.ViewDescriptor

Struttura GridControlStateViewDescriptor
Gerarchia di ereditarietà
SystemObject
SystemValueType
DedNet.LibGridControlStateViewDescriptor

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public struct ViewDescriptor
Public Structure ViewDescriptor
public value class ViewDescriptor
[<SealedAttribute>]
type ViewDescriptor =
    struct
        inherit ValueType
    end

Il tipo GridControlStateViewDescriptor espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | GridControlStateViewDescriptor |
Torna su
Campi
 | Nome | Descrizione
Campo pubblico | keyFieldName |
Campo pubblico | relationName |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Lib


Costruttore GridControlState.ViewDescriptor

Costruttore GridControlStateViewDescriptor

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ViewDescriptor(
    string relationName,
    string keyFieldName
)
Public Sub New (
    relationName As String,
    keyFieldName As String
)
public:
ViewDescriptor(
    String^ relationName,
    String^ keyFieldName
)
new :
        relationName : string *
        keyFieldName : string -> ViewDescriptor

Parametri

relationName String
keyFieldName String
Vedi anche

Documentazione

Struttura GridControlStateViewDescriptor
Namespace DedNet.Lib


Campi di ViewDescriptor

Il tipo GridControlStateViewDescriptor espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | keyFieldName |
Campo pubblico | relationName |
Torna su
Vedi anche

Documentazione

Struttura GridControlStateViewDescriptor
Namespace DedNet.Lib


Campo GridControlState.ViewDescriptor.keyFieldName

Campo GridControlStateViewDescriptorkeyFieldName

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string keyFieldName
Public keyFieldName As String
public:
String^ keyFieldName
val mutable keyFieldName: string

Valore del campo

String
Vedi anche

Documentazione

Struttura GridControlStateViewDescriptor
Namespace DedNet.Lib


Campo GridControlState.ViewDescriptor.relationName

Campo GridControlStateViewDescriptorrelationName

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string relationName
Public relationName As String
public:
String^ relationName
val mutable relationName: string

Valore del campo

String
Vedi anche

Documentazione

Struttura GridControlStateViewDescriptor
Namespace DedNet.Lib


Classe GridControlState.ViewState

Classe GridControlStateViewState
Gerarchia di ereditarietà
SystemObject
DedNet.LibGridControlStateViewState

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class ViewState
Public Class ViewState
public ref class ViewState
type ViewState = class end

Il tipo GridControlStateViewState espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo protetto | GridControlStateViewState(GridControlState, GridControlStateViewDescriptor) |
Metodo protetto | GridControlStateViewState(GridControlStateViewState, GridControlStateViewDescriptor) |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | CellSelection |
Proprietà pubblica | DetailViews |
Proprietà pubblica | SaveExpList |
Proprietà pubblica | SaveMasterRowsList |
Proprietà pubblica | SaveSelList |
Torna su
Metodi
 | Nome | Descrizione
 | Create |
Metodo protetto | ExpandRowByRowInfo |
Metodo protetto | FindParentRowHandle |
Metodo protetto | GetRowHandleToSelect |
Metodo pubblico | IsLevel |
Metodo pubblico | LoadExpandedMasterRows |
Metodo pubblico | LoadExpansionViewInfo |
Metodo pubblico | LoadSelectionViewInfo |
Metodo pubblico | LoadState |
Metodo pubblico | LoadVisibleIndex |
Metodo pubblico | SaveExpandedMasterRows |
Metodo pubblico | SaveExpansionViewInfo |
Metodo pubblico | SaveSelectionViewInfo |
Metodo pubblico | SaveState |
Metodo pubblico | SaveVisibleIndex |
Metodo protetto | SelectRowByRowInfo |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Lib


Costruttore GridControlState.ViewState

Costruttore GridControlStateViewState
Lista degli overload
 | Nome | Descrizione
Metodo protetto | GridControlStateViewState(GridControlState, GridControlStateViewDescriptor) |
Metodo protetto | GridControlStateViewState(GridControlStateViewState, GridControlStateViewDescriptor) |
Torna su
Vedi anche

Documentazione

Classe GridControlStateViewState
Namespace DedNet.Lib


Costruttore GridControlState.ViewState(GridControlState, GridControlState.ViewDescriptor)

Costruttore GridControlStateViewState(GridControlState, GridControlStateViewDescriptor)

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected ViewState(
    GridControlState gridState,
    GridControlStateViewDescriptor descriptor
)
Protected Sub New (
    gridState As GridControlState,
    descriptor As GridControlStateViewDescriptor
)
protected:
ViewState(
    GridControlState^ gridState,
    GridControlStateViewDescriptor descriptor
)
new :
        gridState : GridControlState *
        descriptor : GridControlStateViewDescriptor -> ViewState

Parametri

gridState GridControlState
descriptor GridControlStateViewDescriptor
Vedi anche

Documentazione

Classe GridControlStateViewState
Overload di GridControlStateViewState
Namespace DedNet.Lib


Costruttore GridControlState.ViewState(GridControlState.ViewState, GridControlState.ViewDescriptor)

Costruttore GridControlStateViewState(GridControlStateViewState, GridControlStateViewDescriptor)

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected ViewState(
    GridControlStateViewState parent,
    GridControlStateViewDescriptor descriptor
)
Protected Sub New (
    parent As GridControlStateViewState,
    descriptor As GridControlStateViewDescriptor
)
protected:
ViewState(
    GridControlStateViewState^ parent,
    GridControlStateViewDescriptor descriptor
)
new :
        parent : GridControlStateViewState *
        descriptor : GridControlStateViewDescriptor -> ViewState

Parametri

parent GridControlStateViewState
descriptor GridControlStateViewDescriptor
Vedi anche

Documentazione

Classe GridControlStateViewState
Overload di GridControlStateViewState
Namespace DedNet.Lib


Proprietà di ViewState

Il tipo GridControlStateViewState espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CellSelection |
Proprietà pubblica | DetailViews |
Proprietà pubblica | SaveExpList |
Proprietà pubblica | SaveMasterRowsList |
Proprietà pubblica | SaveSelList |
Torna su
Vedi anche

Documentazione

Classe GridControlStateViewState
Namespace DedNet.Lib


Proprietà GridControlState.ViewState.CellSelection

Proprietà GridControlStateViewStateCellSelection

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Hashtable CellSelection { get; }
Public ReadOnly Property CellSelection As Hashtable
    Get
public:
property Hashtable^ CellSelection {
    Hashtable^ get ();
}
member CellSelection : Hashtable with get

Valore della proprietà

Hashtable
Vedi anche

Documentazione

Classe GridControlStateViewState
Namespace DedNet.Lib


Proprietà GridControlState.ViewState.DetailViews

Proprietà GridControlStateViewStateDetailViews

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Hashtable DetailViews { get; }
Public ReadOnly Property DetailViews As Hashtable
    Get
public:
property Hashtable^ DetailViews {
    Hashtable^ get ();
}
member DetailViews : Hashtable with get

Valore della proprietà

Hashtable
Vedi anche

Documentazione

Classe GridControlStateViewState
Namespace DedNet.Lib


Proprietà GridControlState.ViewState.SaveExpList

Proprietà GridControlStateViewStateSaveExpList

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ArrayList SaveExpList { get; }
Public ReadOnly Property SaveExpList As ArrayList
    Get
public:
property ArrayList^ SaveExpList {
    ArrayList^ get ();
}
member SaveExpList : ArrayList with get

Valore della proprietà

ArrayList
Vedi anche

Documentazione

Classe GridControlStateViewState
Namespace DedNet.Lib


Proprietà GridControlState.ViewState.SaveMasterRowsList

Proprietà GridControlStateViewStateSaveMasterRowsList

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ArrayList SaveMasterRowsList { get; }
Public ReadOnly Property SaveMasterRowsList As ArrayList
    Get
public:
property ArrayList^ SaveMasterRowsList {
    ArrayList^ get ();
}
member SaveMasterRowsList : ArrayList with get

Valore della proprietà

ArrayList
Vedi anche

Documentazione

Classe GridControlStateViewState
Namespace DedNet.Lib


Proprietà GridControlState.ViewState.SaveSelList

Proprietà GridControlStateViewStateSaveSelList

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public ArrayList SaveSelList { get; }
Public ReadOnly Property SaveSelList As ArrayList
    Get
public:
property ArrayList^ SaveSelList {
    ArrayList^ get ();
}
member SaveSelList : ArrayList with get

Valore della proprietà

ArrayList
Vedi anche

Documentazione

Classe GridControlStateViewState
Namespace DedNet.Lib


Metodi di ViewState

Il tipo GridControlStateViewState espone i seguenti membri.

Metodi
 | Nome | Descrizione
 | Create |
Metodo protetto | ExpandRowByRowInfo |
Metodo protetto | FindParentRowHandle |
Metodo protetto | GetRowHandleToSelect |
Metodo pubblico | IsLevel |
Metodo pubblico | LoadExpandedMasterRows |
Metodo pubblico | LoadExpansionViewInfo |
Metodo pubblico | LoadSelectionViewInfo |
Metodo pubblico | LoadState |
Metodo pubblico | LoadVisibleIndex |
Metodo pubblico | SaveExpandedMasterRows |
Metodo pubblico | SaveExpansionViewInfo |
Metodo pubblico | SaveSelectionViewInfo |
Metodo pubblico | SaveState |
Metodo pubblico | SaveVisibleIndex |
Metodo protetto | SelectRowByRowInfo |
Torna su
Vedi anche

Documentazione

Classe GridControlStateViewState
Namespace DedNet.Lib


Metodo GridControlState.ViewState.Create

Metodo GridControlStateViewStateCreate

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static GridControlStateViewState Create(
    GridControlState gridState,
    GridView view
)
Public Shared Function Create (
    gridState As GridControlState,
    view As GridView
) As GridControlStateViewState
public:
static GridControlStateViewState^ Create(
    GridControlState^ gridState,
    GridView^ view
)
static member Create :
        gridState : GridControlState *
        view : GridView -> GridControlStateViewState

Parametri

gridState GridControlState
view GridView

Valore di ritorno

GridControlStateViewState
Vedi anche

Documentazione

Classe GridControlStateViewState
Namespace DedNet.Lib


Metodo GridControlState.ViewState.ExpandRowByRowInfo

Metodo GridControlStateViewStateExpandRowByRowInfo

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected void ExpandRowByRowInfo(
    GridView view,
    GridControlStateRowInfo rowInfo
)
Protected Sub ExpandRowByRowInfo (
    view As GridView,
    rowInfo As GridControlStateRowInfo
)
protected:
void ExpandRowByRowInfo(
    GridView^ view,
    GridControlStateRowInfo rowInfo
)
member ExpandRowByRowInfo :
        view : GridView *
        rowInfo : GridControlStateRowInfo -> unit

Parametri

view GridView
rowInfo GridControlStateRowInfo
Vedi anche

Documentazione

Classe GridControlStateViewState
Namespace DedNet.Lib


Metodo GridControlState.ViewState.FindParentRowHandle

Metodo GridControlStateViewStateFindParentRowHandle

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected int FindParentRowHandle(
    GridView view,
    GridControlStateRowInfo rowInfo,
    int rowHandle
)
Protected Function FindParentRowHandle (
    view As GridView,
    rowInfo As GridControlStateRowInfo,
    rowHandle As Integer
) As Integer
protected:
int FindParentRowHandle(
    GridView^ view,
    GridControlStateRowInfo rowInfo,
    int rowHandle
)
member FindParentRowHandle :
        view : GridView *
        rowInfo : GridControlStateRowInfo *
        rowHandle : int -> int

Parametri

view GridView
rowInfo GridControlStateRowInfo
rowHandle Int32

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe GridControlStateViewState
Namespace DedNet.Lib


Metodo GridControlState.ViewState.GetRowHandleToSelect

Metodo GridControlStateViewStateGetRowHandleToSelect

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected int GetRowHandleToSelect(
    GridView view,
    GridControlStateRowInfo rowInfo
)
Protected Function GetRowHandleToSelect (
    view As GridView,
    rowInfo As GridControlStateRowInfo
) As Integer
protected:
int GetRowHandleToSelect(
    GridView^ view,
    GridControlStateRowInfo rowInfo
)
member GetRowHandleToSelect :
        view : GridView *
        rowInfo : GridControlStateRowInfo -> int

Parametri

view GridView
rowInfo GridControlStateRowInfo

Valore di ritorno

Int32
Vedi anche

Documentazione

Classe GridControlStateViewState
Namespace DedNet.Lib


Metodo GridControlState.ViewState.IsLevel

Metodo GridControlStateViewStateIsLevel

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsLevel(
    string level
)
Public Function IsLevel (
    level As String
) As Boolean
public:
bool IsLevel(
    String^ level
)
member IsLevel :
        level : string -> bool

Parametri

level String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe GridControlStateViewState
Namespace DedNet.Lib


Metodo GridControlState.ViewState.LoadExpandedMasterRows

Metodo GridControlStateViewStateLoadExpandedMasterRows

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void LoadExpandedMasterRows(
    GridView view
)
Public Sub LoadExpandedMasterRows (
    view As GridView
)
public:
void LoadExpandedMasterRows(
    GridView^ view
)
member LoadExpandedMasterRows :
        view : GridView -> unit

Parametri

view GridView
Vedi anche

Documentazione

Classe GridControlStateViewState
Namespace DedNet.Lib


Metodo GridControlState.ViewState.LoadExpansionViewInfo

Metodo GridControlStateViewStateLoadExpansionViewInfo

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void LoadExpansionViewInfo(
    GridView view
)
Public Sub LoadExpansionViewInfo (
    view As GridView
)
public:
void LoadExpansionViewInfo(
    GridView^ view
)
member LoadExpansionViewInfo :
        view : GridView -> unit

Parametri

view GridView
Vedi anche

Documentazione

Classe GridControlStateViewState
Namespace DedNet.Lib


Metodo GridControlState.ViewState.LoadSelectionViewInfo

Metodo GridControlStateViewStateLoadSelectionViewInfo

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void LoadSelectionViewInfo(
    GridView view
)
Public Sub LoadSelectionViewInfo (
    view As GridView
)
public:
void LoadSelectionViewInfo(
    GridView^ view
)
member LoadSelectionViewInfo :
        view : GridView -> unit

Parametri

view GridView
Vedi anche

Documentazione

Classe GridControlStateViewState
Namespace DedNet.Lib


Metodo GridControlState.ViewState.LoadState

Metodo GridControlStateViewStateLoadState

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void LoadState(
    GridView view
)
Public Sub LoadState (
    view As GridView
)
public:
void LoadState(
    GridView^ view
)
member LoadState :
        view : GridView -> unit

Parametri

view GridView
Vedi anche

Documentazione

Classe GridControlStateViewState
Namespace DedNet.Lib


Metodo GridControlState.ViewState.LoadVisibleIndex

Metodo GridControlStateViewStateLoadVisibleIndex

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void LoadVisibleIndex(
    GridView view
)
Public Sub LoadVisibleIndex (
    view As GridView
)
public:
void LoadVisibleIndex(
    GridView^ view
)
member LoadVisibleIndex :
        view : GridView -> unit

Parametri

view GridView
Vedi anche

Documentazione

Classe GridControlStateViewState
Namespace DedNet.Lib


Metodo GridControlState.ViewState.SaveExpandedMasterRows

Metodo GridControlStateViewStateSaveExpandedMasterRows

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SaveExpandedMasterRows(
    GridView view
)
Public Sub SaveExpandedMasterRows (
    view As GridView
)
public:
void SaveExpandedMasterRows(
    GridView^ view
)
member SaveExpandedMasterRows :
        view : GridView -> unit

Parametri

view GridView
Vedi anche

Documentazione

Classe GridControlStateViewState
Namespace DedNet.Lib


Metodo GridControlState.ViewState.SaveExpansionViewInfo

Metodo GridControlStateViewStateSaveExpansionViewInfo

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SaveExpansionViewInfo(
    GridView view
)
Public Sub SaveExpansionViewInfo (
    view As GridView
)
public:
void SaveExpansionViewInfo(
    GridView^ view
)
member SaveExpansionViewInfo :
        view : GridView -> unit

Parametri

view GridView
Vedi anche

Documentazione

Classe GridControlStateViewState
Namespace DedNet.Lib


Metodo GridControlState.ViewState.SaveSelectionViewInfo

Metodo GridControlStateViewStateSaveSelectionViewInfo

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SaveSelectionViewInfo(
    GridView view
)
Public Sub SaveSelectionViewInfo (
    view As GridView
)
public:
void SaveSelectionViewInfo(
    GridView^ view
)
member SaveSelectionViewInfo :
        view : GridView -> unit

Parametri

view GridView
Vedi anche

Documentazione

Classe GridControlStateViewState
Namespace DedNet.Lib


Metodo GridControlState.ViewState.SaveState

Metodo GridControlStateViewStateSaveState

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SaveState(
    GridView view
)
Public Sub SaveState (
    view As GridView
)
public:
void SaveState(
    GridView^ view
)
member SaveState :
        view : GridView -> unit

Parametri

view GridView
Vedi anche

Documentazione

Classe GridControlStateViewState
Namespace DedNet.Lib


Metodo GridControlState.ViewState.SaveVisibleIndex

Metodo GridControlStateViewStateSaveVisibleIndex

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public void SaveVisibleIndex(
    GridView view
)
Public Sub SaveVisibleIndex (
    view As GridView
)
public:
void SaveVisibleIndex(
    GridView^ view
)
member SaveVisibleIndex :
        view : GridView -> unit

Parametri

view GridView
Vedi anche

Documentazione

Classe GridControlStateViewState
Namespace DedNet.Lib


Metodo GridControlState.ViewState.SelectRowByRowInfo

Metodo GridControlStateViewStateSelectRowByRowInfo

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected void SelectRowByRowInfo(
    GridView view,
    GridControlStateRowInfo rowInfo,
    bool isFocused
)
Protected Sub SelectRowByRowInfo (
    view As GridView,
    rowInfo As GridControlStateRowInfo,
    isFocused As Boolean
)
protected:
void SelectRowByRowInfo(
    GridView^ view,
    GridControlStateRowInfo rowInfo,
    bool isFocused
)
member SelectRowByRowInfo :
        view : GridView *
        rowInfo : GridControlStateRowInfo *
        isFocused : bool -> unit

Parametri

view GridView
rowInfo GridControlStateRowInfo
isFocused Boolean
Vedi anche

Documentazione

Classe GridControlStateViewState
Namespace DedNet.Lib


Enumerazione ImportationOptionEnum
Enum indicante il tipo di fonte dati (Excel, Ascii, ecc...).

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum ImportationOptionEnum
Public Enumeration ImportationOptionEnum
public enum class ImportationOptionEnum
type ImportationOptionEnum
Membri
Nome | Valore | Descrizione
None | 0 | Nessuna modalità selezionata.
CreateOnlyIfNotExists | 1 | Verranno importati i dati solamente se già non esistono.
UpdateOnlyIfExists | 2 | Verranno importati i dati solamente se già esistono in modo tale da eseguire solamente un aggiornamento e non una creazione.
CreateOrUpdate | 3 | Crea l'anagrafica nel caso non esista o altrimenti l'aggiorna.
Vedi anche

Documentazione

Namespace DedNet.Lib


Enumerazione ImporterModeEnum
Enum indicante il tipo di importazione (importazione di traduzioni, importazione di anagrafiche, ecc...).

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum ImporterModeEnum
Public Enumeration ImporterModeEnum
public enum class ImporterModeEnum
type ImporterModeEnum
Membri
Nome | Valore | Descrizione
None | 0 | Nessuna modalità di importazione impostata.
Translations | 1 | Importazione di traduzioni.
Data | 2 | Importazione di anagrafiche.
Vedi anche

Documentazione

Namespace DedNet.Lib


Enumerazione ImporterTranslationTypeEnum
Enum indicante il tipo di importazione (importazione di traduzioni, importazione di anagrafiche, ecc...).

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum ImporterTranslationTypeEnum
Public Enumeration ImporterTranslationTypeEnum
public enum class ImporterTranslationTypeEnum
type ImporterTranslationTypeEnum
Membri
Nome | Valore | Descrizione
None | 0 | Nessuna modalità di importazione impostata.
SparePartAttributes | 1 | Importazione di traduzioni.
CustomDictionary | 2 | Importazione di anagrafiche.
Vedi anche

Documentazione

Namespace DedNet.Lib


Enumerazione ReferenceUpdateEnum
Enum che indica i tre stati possibili della variabile HANDLE_REFERENCE_UPDATE.

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum ReferenceUpdateEnum
Public Enumeration ReferenceUpdateEnum
public enum class ReferenceUpdateEnum
type ReferenceUpdateEnum
Membri
Nome | Valore | Descrizione
Never | 0 | Non effettuare mai l'aggiornamento dei riferimenti.
Always | 1 | Effettua sempre l'aggiornamento dei riferimenti.
Choice | 2 | Permetti all'utente di scegliere se effettuare l'aggiornamento.
Vedi anche

Documentazione

Namespace DedNet.Lib


Classe RowAttribute
Classe rappresentante la riga della griglia dedicata all'editazione degli attributi.
Gerarchia di ereditarietà
SystemObject
DedNet.LibRowAttribute

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class RowAttribute
Public Class RowAttribute
public ref class RowAttribute
type RowAttribute = class end

Il tipo RowAttribute espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | RowAttribute(String, String, Object, DedAttr, DedTypeBase) | Crea una nuova istanza della classe 'RowAttribute'.
Metodo pubblico | RowAttribute(String, String, Object, DedAttr, DedTypeBase, String, Boolean) | Crea una nuova istanza della classe 'RowAttribute'.
Metodo pubblico | RowAttribute(String, String, Object, DedAttr, String, DedTypeBase, String, Boolean) | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BackColor | Ritorna il colore di sfondo dell'attributo impostato dall'utente. Viene utilizzato per le traduzioni in quanto non hanno l'oggetto DedAttr impostato.
Proprietà pubblica | DedType | DbPath della famiglia alla quale l'attributo è associato.
Proprietà pubblica | ForeColor | Ritorna il colore del testo dell'attributo impostato dall'utente. Viene utilizzato per le traduzioni in quanto non hanno l'oggetto DedAttr impostato.
Proprietà pubblica | Group | Gruppo di appartenenza (EnvDest).
Proprietà pubblica | IsTranslation | Indica se si tratta di una traduzione o meno.
Proprietà pubblica | Name | Nome interno dell'attributo.
Proprietà pubblica | Prompt | Prompt dell'attributo.
Proprietà pubblica | Tag | Attributo usato come tag.
Proprietà pubblica | TranslationCode | Ritorna il codice ISO della lingua a cui corrisponde la traduzione.
Proprietà pubblica | Valore | Valore dell'attributo.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | IsEditable | Ritorna True se l'oggetto RowAttribute può essere editato, False altrimenti.
Torna su
Vedi anche

Documentazione

Namespace DedNet.Lib


Costruttore RowAttribute
Lista degli overload
 | Nome | Descrizione
Metodo pubblico | RowAttribute(String, String, Object, DedAttr, DedTypeBase) | Crea una nuova istanza della classe 'RowAttribute'.
Metodo pubblico | RowAttribute(String, String, Object, DedAttr, DedTypeBase, String, Boolean) | Crea una nuova istanza della classe 'RowAttribute'.
Metodo pubblico | RowAttribute(String, String, Object, DedAttr, String, DedTypeBase, String, Boolean) | Costruttore unico.
Torna su
Vedi anche

Documentazione

Classe RowAttribute
Namespace DedNet.Lib


Costruttore RowAttribute(String, String, Object, DedAttr, DedTypeBase)
Crea una nuova istanza della classe 'RowAttribute'.

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public RowAttribute(
    string name,
    string prompt,
    Object valore,
    DedAttr tag,
    DedTypeBase tp
)
Public Sub New (
    name As String,
    prompt As String,
    valore As Object,
    tag As DedAttr,
    tp As DedTypeBase
)
public:
RowAttribute(
    String^ name,
    String^ prompt,
    Object^ valore,
    DedAttr^ tag,
    DedTypeBase^ tp
)
new :
        name : string *
        prompt : string *
        valore : Object *
        tag : DedAttr *
        tp : DedTypeBase -> RowAttribute

Parametri

name String
Nome interno dell'attributo.
prompt String
Prompt dell'attributo.
valore Object
Valore dell'attributo.
tag DedAttr
Attributo usato come tag.
tp DedTypeBase
Vedi anche

Documentazione

Classe RowAttribute
Overload di RowAttribute
Namespace DedNet.Lib


Costruttore RowAttribute(String, String, Object, DedAttr, DedTypeBase, String, Boolean)
Crea una nuova istanza della classe 'RowAttribute'.

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public RowAttribute(
    string name,
    string prompt,
    Object valore,
    DedAttr tag,
    DedTypeBase tp,
    string translationCode,
    bool disableEditingForOnlyDbAttrs
)
Public Sub New (
    name As String,
    prompt As String,
    valore As Object,
    tag As DedAttr,
    tp As DedTypeBase,
    translationCode As String,
    disableEditingForOnlyDbAttrs As Boolean
)
public:
RowAttribute(
    String^ name,
    String^ prompt,
    Object^ valore,
    DedAttr^ tag,
    DedTypeBase^ tp,
    String^ translationCode,
    bool disableEditingForOnlyDbAttrs
)
new :
        name : string *
        prompt : string *
        valore : Object *
        tag : DedAttr *
        tp : DedTypeBase *
        translationCode : string *
        disableEditingForOnlyDbAttrs : bool -> RowAttribute

Parametri

name String
Nome interno dell'attributo.
prompt String
Prompt dell'attributo.
valore Object
Valore dell'attributo.
tag DedAttr
Attributo usato come tag.
tp DedTypeBase
translationCode String
Codice ISO della lingua a cui corrisponde la traduzione.
disableEditingForOnlyDbAttrs Boolean
Indica se abilitare o meno l'editazione per gli attributi marchiati come "Solo Db".
Vedi anche

Documentazione

Classe RowAttribute
Overload di RowAttribute
Namespace DedNet.Lib


Costruttore RowAttribute(String, String, Object, DedAttr, String, DedTypeBase, String, Boolean)
Costruttore unico.

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public RowAttribute(
    string name,
    string prompt,
    Object valore,
    DedAttr tag,
    string group,
    DedTypeBase tp,
    string translationCode,
    bool disableEditingForOnlyDbAttrs
)
Public Sub New (
    name As String,
    prompt As String,
    valore As Object,
    tag As DedAttr,
    group As String,
    tp As DedTypeBase,
    translationCode As String,
    disableEditingForOnlyDbAttrs As Boolean
)
public:
RowAttribute(
    String^ name,
    String^ prompt,
    Object^ valore,
    DedAttr^ tag,
    String^ group,
    DedTypeBase^ tp,
    String^ translationCode,
    bool disableEditingForOnlyDbAttrs
)
new :
        name : string *
        prompt : string *
        valore : Object *
        tag : DedAttr *
        group : string *
        tp : DedTypeBase *
        translationCode : string *
        disableEditingForOnlyDbAttrs : bool -> RowAttribute

Parametri

name String
Nome interno dell'attributo.
prompt String
Prompt dell'attributo.
valore Object
Valore dell'attributo.
tag DedAttr
Attributo usato come tag.
group String
Gruppo a cui appartiene l'attributo.
tp DedTypeBase
translationCode String
Codice ISO della lingua a cui corrisponde la traduzione.
disableEditingForOnlyDbAttrs Boolean
Indica se abilitare o meno l'editazione per gli attributi marchiati come "Solo Db".
Vedi anche

Documentazione

Classe RowAttribute
Overload di RowAttribute
Namespace DedNet.Lib


Proprietà di RowAttribute

Il tipo RowAttribute espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BackColor | Ritorna il colore di sfondo dell'attributo impostato dall'utente. Viene utilizzato per le traduzioni in quanto non hanno l'oggetto DedAttr impostato.
Proprietà pubblica | DedType | DbPath della famiglia alla quale l'attributo è associato.
Proprietà pubblica | ForeColor | Ritorna il colore del testo dell'attributo impostato dall'utente. Viene utilizzato per le traduzioni in quanto non hanno l'oggetto DedAttr impostato.
Proprietà pubblica | Group | Gruppo di appartenenza (EnvDest).
Proprietà pubblica | IsTranslation | Indica se si tratta di una traduzione o meno.
Proprietà pubblica | Name | Nome interno dell'attributo.
Proprietà pubblica | Prompt | Prompt dell'attributo.
Proprietà pubblica | Tag | Attributo usato come tag.
Proprietà pubblica | TranslationCode | Ritorna il codice ISO della lingua a cui corrisponde la traduzione.
Proprietà pubblica | Valore | Valore dell'attributo.
Torna su
Vedi anche

Documentazione

Classe RowAttribute
Namespace DedNet.Lib


Proprietà RowAttribute.BackColor

Proprietà RowAttributeBackColor
Ritorna il colore di sfondo dell'attributo impostato dall'utente. Viene utilizzato per le traduzioni in quanto non hanno l'oggetto DedAttr impostato.

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Color BackColor { get; set; }
Public Property BackColor As Color
    Get
    Set
public:
property Color BackColor {
    Color get ();
    void set (Color value);
}
member BackColor : Color with get, set

Valore della proprietà

Color
Vedi anche

Documentazione

Classe RowAttribute
Namespace DedNet.Lib


Proprietà RowAttribute.DedType

Proprietà RowAttributeDedType
DbPath della famiglia alla quale l'attributo è associato.

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeBase DedType { get; }
Public ReadOnly Property DedType As DedTypeBase
    Get
public:
property DedTypeBase^ DedType {
    DedTypeBase^ get ();
}
member DedType : DedTypeBase with get

Valore della proprietà

DedTypeBase
Vedi anche

Documentazione

Classe RowAttribute
Namespace DedNet.Lib


Proprietà RowAttribute.ForeColor

Proprietà RowAttributeForeColor
Ritorna il colore del testo dell'attributo impostato dall'utente. Viene utilizzato per le traduzioni in quanto non hanno l'oggetto DedAttr impostato.

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Color ForeColor { get; set; }
Public Property ForeColor As Color
    Get
    Set
public:
property Color ForeColor {
    Color get ();
    void set (Color value);
}
member ForeColor : Color with get, set

Valore della proprietà

Color
Vedi anche

Documentazione

Classe RowAttribute
Namespace DedNet.Lib


Proprietà RowAttribute.Group

Proprietà RowAttributeGroup
Gruppo di appartenenza (EnvDest).

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Group { get; }
Public ReadOnly Property Group As String
    Get
public:
property String^ Group {
    String^ get ();
}
member Group : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe RowAttribute
Namespace DedNet.Lib


Proprietà RowAttribute.IsTranslation

Proprietà RowAttributeIsTranslation
Indica se si tratta di una traduzione o meno.

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsTranslation { get; }
Public ReadOnly Property IsTranslation As Boolean
    Get
public:
property bool IsTranslation {
    bool get ();
}
member IsTranslation : bool with get

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe RowAttribute
Namespace DedNet.Lib


Proprietà RowAttribute.Name

Proprietà RowAttributeName
Nome interno dell'attributo.

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe RowAttribute
Namespace DedNet.Lib


Proprietà RowAttribute.Prompt

Proprietà RowAttributePrompt
Prompt dell'attributo.

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string Prompt { get; }
Public ReadOnly Property Prompt As String
    Get
public:
property String^ Prompt {
    String^ get ();
}
member Prompt : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe RowAttribute
Namespace DedNet.Lib


Proprietà RowAttribute.Tag

Proprietà RowAttributeTag
Attributo usato come tag.

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttr Tag { get; }
Public ReadOnly Property Tag As DedAttr
    Get
public:
property DedAttr^ Tag {
    DedAttr^ get ();
}
member Tag : DedAttr with get

Valore della proprietà

DedAttr
Vedi anche

Documentazione

Classe RowAttribute
Namespace DedNet.Lib


Proprietà RowAttribute.TranslationCode

Proprietà RowAttributeTranslationCode
Ritorna il codice ISO della lingua a cui corrisponde la traduzione.

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string TranslationCode { get; }
Public ReadOnly Property TranslationCode As String
    Get
public:
property String^ TranslationCode {
    String^ get ();
}
member TranslationCode : string with get

Valore della proprietà

String
Vedi anche

Documentazione

Classe RowAttribute
Namespace DedNet.Lib


Proprietà RowAttribute.Valore

Proprietà RowAttributeValore
Valore dell'attributo.

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Object Valore { get; set; }
Public Property Valore As Object
    Get
    Set
public:
property Object^ Valore {
    Object^ get ();
    void set (Object^ value);
}
member Valore : Object with get, set

Valore della proprietà

Object
Vedi anche

Documentazione

Classe RowAttribute
Namespace DedNet.Lib


Metodi di RowAttribute

Il tipo RowAttribute espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | IsEditable | Ritorna True se l'oggetto RowAttribute può essere editato, False altrimenti.
Torna su
Vedi anche

Documentazione

Classe RowAttribute
Namespace DedNet.Lib


Metodo RowAttribute.IsEditable

Metodo RowAttributeIsEditable
Ritorna True se l'oggetto RowAttribute può essere editato, False altrimenti.

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsEditable()
Public Function IsEditable As Boolean
public:
bool IsEditable()
member IsEditable : unit -> bool

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe RowAttribute
Namespace DedNet.Lib


Classe SelectedCellsBorderHelper
Gerarchia di ereditarietà
SystemObject
DedNet.LibSelectedCellsBorderHelper

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class SelectedCellsBorderHelper
Public Class SelectedCellsBorderHelper
public ref class SelectedCellsBorderHelper
type SelectedCellsBorderHelper = class end

Il tipo SelectedCellsBorderHelper espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | SelectedCellsBorderHelper |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | IsCopyMode |
Proprietà pubblica | Tree |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | GetDragRect |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Lib


Costruttore SelectedCellsBorderHelper

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public SelectedCellsBorderHelper(
    TreeList tree
)
Public Sub New (
    tree As TreeList
)
public:
SelectedCellsBorderHelper(
    TreeList^ tree
)
new :
        tree : TreeList -> SelectedCellsBorderHelper

Parametri

tree TreeList
Vedi anche

Documentazione

Classe SelectedCellsBorderHelper
Namespace DedNet.Lib


Proprietà di SelectedCellsBorderHelper

Il tipo SelectedCellsBorderHelper espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | IsCopyMode |
Proprietà pubblica | Tree |
Torna su
Vedi anche

Documentazione

Classe SelectedCellsBorderHelper
Namespace DedNet.Lib


Proprietà SelectedCellsBorderHelper.IsCopyMode

Proprietà SelectedCellsBorderHelperIsCopyMode

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsCopyMode { get; set; }
Public Property IsCopyMode As Boolean
    Get
    Set
public:
property bool IsCopyMode {
    bool get ();
    void set (bool value);
}
member IsCopyMode : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SelectedCellsBorderHelper
Namespace DedNet.Lib


Proprietà SelectedCellsBorderHelper.Tree

Proprietà SelectedCellsBorderHelperTree

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public TreeList Tree { get; set; }
Public Property Tree As TreeList
    Get
    Set
public:
property TreeList^ Tree {
    TreeList^ get ();
    void set (TreeList^ value);
}
member Tree : TreeList with get, set

Valore della proprietà

TreeList
Vedi anche

Documentazione

Classe SelectedCellsBorderHelper
Namespace DedNet.Lib


Metodi di SelectedCellsBorderHelper

Il tipo SelectedCellsBorderHelper espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | GetDragRect |
Torna su
Vedi anche

Documentazione

Classe SelectedCellsBorderHelper
Namespace DedNet.Lib


Metodo SelectedCellsBorderHelper.GetDragRect

Metodo SelectedCellsBorderHelperGetDragRect

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Rectangle GetDragRect()
Public Function GetDragRect As Rectangle
public:
Rectangle GetDragRect()
member GetDragRect : unit -> Rectangle

Valore di ritorno

Rectangle
Vedi anche

Documentazione

Classe SelectedCellsBorderHelper
Namespace DedNet.Lib


Classe SelectedCellsBorderHelperGridView
Gerarchia di ereditarietà
SystemObject
DedNet.LibSelectedCellsBorderHelperGridView

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class SelectedCellsBorderHelperGridView
Public Class SelectedCellsBorderHelperGridView
public ref class SelectedCellsBorderHelperGridView
type SelectedCellsBorderHelperGridView = class end

Il tipo SelectedCellsBorderHelperGridView espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | SelectedCellsBorderHelperGridView |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | GridControl |
Proprietà pubblica | GridView |
Proprietà pubblica | IsCopyMode |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | GetDragRect |
Torna su
Vedi anche

Documentazione

Namespace DedNet.Lib


Costruttore SelectedCellsBorderHelperGridView

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public SelectedCellsBorderHelperGridView(
    GridView gridView
)
Public Sub New (
    gridView As GridView
)
public:
SelectedCellsBorderHelperGridView(
    GridView^ gridView
)
new :
        gridView : GridView -> SelectedCellsBorderHelperGridView

Parametri

gridView GridView
Vedi anche

Documentazione

Classe SelectedCellsBorderHelperGridView
Namespace DedNet.Lib


Proprietà di SelectedCellsBorderHelperGridView

Il tipo SelectedCellsBorderHelperGridView espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | GridControl |
Proprietà pubblica | GridView |
Proprietà pubblica | IsCopyMode |
Torna su
Vedi anche

Documentazione

Classe SelectedCellsBorderHelperGridView
Namespace DedNet.Lib


Proprietà SelectedCellsBorderHelperGridView.GridControl

Proprietà SelectedCellsBorderHelperGridViewGridControl

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public GridControl GridControl { get; }
Public ReadOnly Property GridControl As GridControl
    Get
public:
property GridControl^ GridControl {
    GridControl^ get ();
}
member GridControl : GridControl with get

Valore della proprietà

GridControl
Vedi anche

Documentazione

Classe SelectedCellsBorderHelperGridView
Namespace DedNet.Lib


Proprietà SelectedCellsBorderHelperGridView.GridView

Proprietà SelectedCellsBorderHelperGridViewGridView

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public GridView GridView { get; set; }
Public Property GridView As GridView
    Get
    Set
public:
property GridView^ GridView {
    GridView^ get ();
    void set (GridView^ value);
}
member GridView : GridView with get, set

Valore della proprietà

GridView
Vedi anche

Documentazione

Classe SelectedCellsBorderHelperGridView
Namespace DedNet.Lib


Proprietà SelectedCellsBorderHelperGridView.IsCopyMode

Proprietà SelectedCellsBorderHelperGridViewIsCopyMode

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool IsCopyMode { get; set; }
Public Property IsCopyMode As Boolean
    Get
    Set
public:
property bool IsCopyMode {
    bool get ();
    void set (bool value);
}
member IsCopyMode : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe SelectedCellsBorderHelperGridView
Namespace DedNet.Lib


Metodi di SelectedCellsBorderHelperGridView

Il tipo SelectedCellsBorderHelperGridView espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | GetDragRect |
Torna su
Vedi anche

Documentazione

Classe SelectedCellsBorderHelperGridView
Namespace DedNet.Lib


Metodo SelectedCellsBorderHelperGridView.GetDragRect

Metodo SelectedCellsBorderHelperGridViewGetDragRect

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Rectangle GetDragRect()
Public Function GetDragRect As Rectangle
public:
Rectangle GetDragRect()
member GetDragRect : unit -> Rectangle

Valore di ritorno

Rectangle
Vedi anche

Documentazione

Classe SelectedCellsBorderHelperGridView
Namespace DedNet.Lib


Enumerazione SelectionModeEnum
Enum indicante la modalità di selezione di determinati oggetti.

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum SelectionModeEnum
Public Enumeration SelectionModeEnum
public enum class SelectionModeEnum
type SelectionModeEnum
Membri
Nome | Valore | Descrizione
None | 0 |
SingleItem | 1 |
MultiItem | 2 |
Vedi anche

Documentazione

Namespace DedNet.Lib


Enumerazione TimeEnum
Possibili formati in cui esprimere il tempo (secondi, minuti, ore, ecc..)

Namespace: DedNet.Lib
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public enum TimeEnum
Public Enumeration TimeEnum
public enum class TimeEnum
type TimeEnum
Membri
Nome | Valore | Descrizione
Seconds | 0 | L'unità di misura del tempo è espressa in secondi.
Minuts | 1 | L'unità di misura del tempo è espressa in minuti.
Hours | 2 | L'unità di misura del tempo è espressa in ore.
Days | 3 | L'unità di misura del tempo è espressa in giorni.
Months | 4 | L'unità di misura del tempo è espressa in mesi.
Years | 5 | L'unità di misura del tempo è espressa in anni.
Vedi anche

Documentazione

Namespace DedNet.Lib


DedNet.Lib.DedIO Namespace
Classi
 | Classe | Descrizione
Classe pubblica | Directory | DIRECTORY Classe switcher chiamate su Directory con firme identiche alla classe di IO nativa. Smista le chiamata su IO se client server non è attivo o per le chiamate locali, diversamente chiama DirectoryServer.
Classe pubblica | DirectoryServer | DIRECTORYSERVER Classe di interfacciamento chiamate client server per le chiamate su directory
Classe pubblica | File | FILE Classe switcher chiamate su File con firme identiche alla classe di IO nativa. Smista le chiamata su IO se client server non è attivo o per le chiamate locali, diversamente chiama FileServer.
Classe pubblica | FileServer | FILESERVER Classe di interfacciamento chiamate client server per le chiamate su file
Classe pubblica | Path | PATH Classe per controlli specifici sui percorsi. Estende idealmente le funzionalità della classe nativa di IO
Classe pubblica | Utils | UTILS Utilità specifiche per le operazioni di DedIO e server


Classe Directory
DIRECTORY Classe switcher chiamate su Directory con firme identiche alla classe di IO nativa. Smista le chiamata su IO se client server non è attivo o per le chiamate locali, diversamente chiama DirectoryServer.
Gerarchia di ereditarietà
SystemObject
DedNet.Lib.DedIODirectory

Namespace: DedNet.Lib.DedIO
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class Directory
Public Class Directory
public ref class Directory
type Directory = class end

Il tipo Directory espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | Directory |
Torna su
Metodi
Nome | Descrizione
CreateDirectory | CreateDirectory
Delete | Delete
DeleteAll | DeleteAll
Exists | Exists
GetDirectories(String) | GetDirectories
GetDirectories(String, String, SearchOption) | GetDirectories
GetFiles(String) | GetFiles
GetFiles(String, String, SearchOption) | GetFiles
Move | Move
Torna su
Vedi anche

Documentazione

Namespace DedNet.Lib.DedIO


Costruttore Directory

Namespace: DedNet.Lib.DedIO
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Directory()
Public Sub New
public:
Directory()
new : unit -> Directory
Vedi anche

Documentazione

Classe Directory
Namespace DedNet.Lib.DedIO


Metodi di Directory

Il tipo Directory espone i seguenti membri.

Metodi
Nome | Descrizione
CreateDirectory | CreateDirectory
Delete | Delete
DeleteAll | DeleteAll
Exists | Exists
GetDirectories(String) | GetDirectories
GetDirectories(String, String, SearchOption) | GetDirectories
GetFiles(String) | GetFiles
GetFiles(String, String, SearchOption) | GetFiles
Move | Move
Torna su
Vedi anche

Documentazione

Classe Directory
Namespace DedNet.Lib.DedIO


Metodo Directory.CreateDirectory

Metodo DirectoryCreateDirectory
CreateDirectory

Namespace: DedNet.Lib.DedIO
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void CreateDirectory(
    string path
)
Public Shared Sub CreateDirectory (
    path As String
)
public:
static void CreateDirectory(
    String^ path
)
static member CreateDirectory :
        path : string -> unit

Parametri

path String
Vedi anche

Documentazione

Classe Directory
Namespace DedNet.Lib.DedIO


Metodo Directory.Delete

Metodo DirectoryDelete
Delete

Namespace: DedNet.Lib.DedIO
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void Delete(
    string path,
    bool recursive = false
)
Public Shared Sub Delete (
    path As String,
    Optional recursive As Boolean = false
)
public:
static void Delete(
    String^ path,
    bool recursive = false
)
static member Delete :
        path : string *
        ?recursive : bool
(* Defaults:
        let _recursive = defaultArg recursive false
*)
-> unit

Parametri

path String
recursive Boolean (Optional)
Vedi anche

Documentazione

Classe Directory
Namespace DedNet.Lib.DedIO


Metodo Directory.DeleteAll

Metodo DirectoryDeleteAll
DeleteAll

Namespace: DedNet.Lib.DedIO
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void DeleteAll(
    string path
)
Public Shared Sub DeleteAll (
    path As String
)
public:
static void DeleteAll(
    String^ path
)
static member DeleteAll :
        path : string -> unit

Parametri

path String
Vedi anche

Documentazione

Classe Directory
Namespace DedNet.Lib.DedIO


Metodo Directory.Exists

Metodo DirectoryExists
Exists

Namespace: DedNet.Lib.DedIO
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool Exists(
    string path
)
Public Shared Function Exists (
    path As String
) As Boolean
public:
static bool Exists(
    String^ path
)
static member Exists :
        path : string -> bool

Parametri

path String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Directory
Namespace DedNet.Lib.DedIO


Metodo Directory.GetDirectories

Metodo DirectoryGetDirectories
Lista degli overload
Nome | Descrizione
GetDirectories(String) | GetDirectories
GetDirectories(String, String, SearchOption) | GetDirectories
Torna su
Vedi anche

Documentazione

Classe Directory
Namespace DedNet.Lib.DedIO


Metodo Directory.GetDirectories(String)

Metodo DirectoryGetDirectories(String)
GetDirectories

Namespace: DedNet.Lib.DedIO
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string[] GetDirectories(
    string path
)
Public Shared Function GetDirectories (
    path As String
) As String()
public:
static array<String^>^ GetDirectories(
    String^ path
)
static member GetDirectories :
        path : string -> string[]

Parametri

path String

Valore di ritorno

String
Vedi anche

Documentazione

Classe Directory
Overload di GetDirectories
Namespace DedNet.Lib.DedIO


Metodo Directory.GetDirectories(String, String, SearchOption)

Metodo DirectoryGetDirectories(String, String, SearchOption)
GetDirectories

Namespace: DedNet.Lib.DedIO
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string[] GetDirectories(
    string path,
    string searchPattern,
    SearchOption searchOpt
)
Public Shared Function GetDirectories (
    path As String,
    searchPattern As String,
    searchOpt As SearchOption
) As String()
public:
static array<String^>^ GetDirectories(
    String^ path,
    String^ searchPattern,
    SearchOption searchOpt
)
static member GetDirectories :
        path : string *
        searchPattern : string *
        searchOpt : SearchOption -> string[]

Parametri

path String
searchPattern String
searchOpt SearchOption

Valore di ritorno

String
Vedi anche

Documentazione

Classe Directory
Overload di GetDirectories
Namespace DedNet.Lib.DedIO


Metodo Directory.GetFiles

Metodo DirectoryGetFiles
Lista degli overload
Nome | Descrizione
GetFiles(String) | GetFiles
GetFiles(String, String, SearchOption) | GetFiles
Torna su
Vedi anche

Documentazione

Classe Directory
Namespace DedNet.Lib.DedIO


Metodo Directory.GetFiles(String)

Metodo DirectoryGetFiles(String)
GetFiles

Namespace: DedNet.Lib.DedIO
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string[] GetFiles(
    string path
)
Public Shared Function GetFiles (
    path As String
) As String()
public:
static array<String^>^ GetFiles(
    String^ path
)
static member GetFiles :
        path : string -> string[]

Parametri

path String

Valore di ritorno

String
Vedi anche

Documentazione

Classe Directory
Overload di GetFiles
Namespace DedNet.Lib.DedIO


Metodo Directory.GetFiles(String, String, SearchOption)

Metodo DirectoryGetFiles(String, String, SearchOption)
GetFiles

Namespace: DedNet.Lib.DedIO
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string[] GetFiles(
    string path,
    string searchPattern,
    SearchOption searchOpt
)
Public Shared Function GetFiles (
    path As String,
    searchPattern As String,
    searchOpt As SearchOption
) As String()
public:
static array<String^>^ GetFiles(
    String^ path,
    String^ searchPattern,
    SearchOption searchOpt
)
static member GetFiles :
        path : string *
        searchPattern : string *
        searchOpt : SearchOption -> string[]

Parametri

path String
searchPattern String
searchOpt SearchOption

Valore di ritorno

String
Vedi anche

Documentazione

Classe Directory
Overload di GetFiles
Namespace DedNet.Lib.DedIO


Metodo Directory.Move

Metodo DirectoryMove
Move

Namespace: DedNet.Lib.DedIO
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void Move(
    string sourceDirName,
    string destDirName
)
Public Shared Sub Move (
    sourceDirName As String,
    destDirName As String
)
public:
static void Move(
    String^ sourceDirName,
    String^ destDirName
)
static member Move :
        sourceDirName : string *
        destDirName : string -> unit

Parametri

sourceDirName String
destDirName String
Vedi anche

Documentazione

Classe Directory
Namespace DedNet.Lib.DedIO


Classe DirectoryServer
DIRECTORYSERVER Classe di interfacciamento chiamate client server per le chiamate su directory
Gerarchia di ereditarietà
SystemObject
DedNet.Lib.DedIODirectoryServer

Namespace: DedNet.Lib.DedIO
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DirectoryServer
Public Class DirectoryServer
public ref class DirectoryServer
type DirectoryServer = class end

Il tipo DirectoryServer espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DirectoryServer |
Torna su
Metodi
Nome | Descrizione
CreateDirectory | Crea la nuova cartella su server
Delete | Elimina la cartella su server. Supporta l'eliminazione dell'intero ramo
DeleteAll | Elimina la cartella su server con relative sotto cartelle
Exists | Controlla l'esistenza della cartella su server
GetDirectories(String) | Ritorna una lista di cartelle figlie del percorso indicato
GetDirectories(String, String, SearchOption) | Ritorna una lista di cartelle figlie del percorso indicato
GetFiles(String) | Ritorna una lista di file contenuti nel percorso indicato
GetFiles(String, String, SearchOption) | Ritorna una lista di file contenuti nel percorso indicato
Move | Sposta o rinomina la cartella su server
Torna su
Vedi anche

Documentazione

Namespace DedNet.Lib.DedIO


Costruttore DirectoryServer

Namespace: DedNet.Lib.DedIO
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DirectoryServer()
Public Sub New
public:
DirectoryServer()
new : unit -> DirectoryServer
Vedi anche

Documentazione

Classe DirectoryServer
Namespace DedNet.Lib.DedIO


Metodi di DirectoryServer

Il tipo DirectoryServer espone i seguenti membri.

Metodi
Nome | Descrizione
CreateDirectory | Crea la nuova cartella su server
Delete | Elimina la cartella su server. Supporta l'eliminazione dell'intero ramo
DeleteAll | Elimina la cartella su server con relative sotto cartelle
Exists | Controlla l'esistenza della cartella su server
GetDirectories(String) | Ritorna una lista di cartelle figlie del percorso indicato
GetDirectories(String, String, SearchOption) | Ritorna una lista di cartelle figlie del percorso indicato
GetFiles(String) | Ritorna una lista di file contenuti nel percorso indicato
GetFiles(String, String, SearchOption) | Ritorna una lista di file contenuti nel percorso indicato
Move | Sposta o rinomina la cartella su server
Torna su
Vedi anche

Documentazione

Classe DirectoryServer
Namespace DedNet.Lib.DedIO


Metodo DirectoryServer.CreateDirectory

Metodo DirectoryServerCreateDirectory
Crea la nuova cartella su server

Namespace: DedNet.Lib.DedIO
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void CreateDirectory(
    string path
)
Public Shared Sub CreateDirectory (
    path As String
)
public:
static void CreateDirectory(
    String^ path
)
static member CreateDirectory :
        path : string -> unit

Parametri

path String
Vedi anche

Documentazione

Classe DirectoryServer
Namespace DedNet.Lib.DedIO


Metodo DirectoryServer.Delete

Metodo DirectoryServerDelete
Elimina la cartella su server. Supporta l'eliminazione dell'intero ramo

Namespace: DedNet.Lib.DedIO
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void Delete(
    string path,
    bool recursive = false
)
Public Shared Sub Delete (
    path As String,
    Optional recursive As Boolean = false
)
public:
static void Delete(
    String^ path,
    bool recursive = false
)
static member Delete :
        path : string *
        ?recursive : bool
(* Defaults:
        let _recursive = defaultArg recursive false
*)
-> unit

Parametri

path String
recursive Boolean (Optional)
Vedi anche

Documentazione

Classe DirectoryServer
Namespace DedNet.Lib.DedIO


Metodo DirectoryServer.DeleteAll

Metodo DirectoryServerDeleteAll
Elimina la cartella su server con relative sotto cartelle

Namespace: DedNet.Lib.DedIO
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void DeleteAll(
    string path
)
Public Shared Sub DeleteAll (
    path As String
)
public:
static void DeleteAll(
    String^ path
)
static member DeleteAll :
        path : string -> unit

Parametri

path String
Vedi anche

Documentazione

Classe DirectoryServer
Namespace DedNet.Lib.DedIO


Metodo DirectoryServer.Exists

Metodo DirectoryServerExists
Controlla l'esistenza della cartella su server

Namespace: DedNet.Lib.DedIO
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool Exists(
    string path
)
Public Shared Function Exists (
    path As String
) As Boolean
public:
static bool Exists(
    String^ path
)
static member Exists :
        path : string -> bool

Parametri

path String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe DirectoryServer
Namespace DedNet.Lib.DedIO


Metodo DirectoryServer.GetDirectories

Metodo DirectoryServerGetDirectories
Lista degli overload
Nome | Descrizione
GetDirectories(String) | Ritorna una lista di cartelle figlie del percorso indicato
GetDirectories(String, String, SearchOption) | Ritorna una lista di cartelle figlie del percorso indicato
Torna su
Vedi anche

Documentazione

Classe DirectoryServer
Namespace DedNet.Lib.DedIO


Metodo DirectoryServer.GetDirectories(String)

Metodo DirectoryServerGetDirectories(String)
Ritorna una lista di cartelle figlie del percorso indicato

Namespace: DedNet.Lib.DedIO
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string[] GetDirectories(
    string path
)
Public Shared Function GetDirectories (
    path As String
) As String()
public:
static array<String^>^ GetDirectories(
    String^ path
)
static member GetDirectories :
        path : string -> string[]

Parametri

path String

Valore di ritorno

String
Vedi anche

Documentazione

Classe DirectoryServer
Overload di GetDirectories
Namespace DedNet.Lib.DedIO


Metodo DirectoryServer.GetDirectories(String, String, SearchOption)

Metodo DirectoryServerGetDirectories(String, String, SearchOption)
Ritorna una lista di cartelle figlie del percorso indicato

Namespace: DedNet.Lib.DedIO
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string[] GetDirectories(
    string path,
    string searchPattern,
    SearchOption searchOpt
)
Public Shared Function GetDirectories (
    path As String,
    searchPattern As String,
    searchOpt As SearchOption
) As String()
public:
static array<String^>^ GetDirectories(
    String^ path,
    String^ searchPattern,
    SearchOption searchOpt
)
static member GetDirectories :
        path : string *
        searchPattern : string *
        searchOpt : SearchOption -> string[]

Parametri

path String
searchPattern String
searchOpt SearchOption

Valore di ritorno

String
Vedi anche

Documentazione

Classe DirectoryServer
Overload di GetDirectories
Namespace DedNet.Lib.DedIO


Metodo DirectoryServer.GetFiles

Metodo DirectoryServerGetFiles
Lista degli overload
Nome | Descrizione
GetFiles(String) | Ritorna una lista di file contenuti nel percorso indicato
GetFiles(String, String, SearchOption) | Ritorna una lista di file contenuti nel percorso indicato
Torna su
Vedi anche

Documentazione

Classe DirectoryServer
Namespace DedNet.Lib.DedIO


Metodo DirectoryServer.GetFiles(String)

Metodo DirectoryServerGetFiles(String)
Ritorna una lista di file contenuti nel percorso indicato

Namespace: DedNet.Lib.DedIO
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string[] GetFiles(
    string path
)
Public Shared Function GetFiles (
    path As String
) As String()
public:
static array<String^>^ GetFiles(
    String^ path
)
static member GetFiles :
        path : string -> string[]

Parametri

path String

Valore di ritorno

String
Vedi anche

Documentazione

Classe DirectoryServer
Overload di GetFiles
Namespace DedNet.Lib.DedIO


Metodo DirectoryServer.GetFiles(String, String, SearchOption)

Metodo DirectoryServerGetFiles(String, String, SearchOption)
Ritorna una lista di file contenuti nel percorso indicato

Namespace: DedNet.Lib.DedIO
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string[] GetFiles(
    string path,
    string searchPattern,
    SearchOption searchOpt
)
Public Shared Function GetFiles (
    path As String,
    searchPattern As String,
    searchOpt As SearchOption
) As String()
public:
static array<String^>^ GetFiles(
    String^ path,
    String^ searchPattern,
    SearchOption searchOpt
)
static member GetFiles :
        path : string *
        searchPattern : string *
        searchOpt : SearchOption -> string[]

Parametri

path String
searchPattern String
searchOpt SearchOption

Valore di ritorno

String
Vedi anche

Documentazione

Classe DirectoryServer
Overload di GetFiles
Namespace DedNet.Lib.DedIO


Metodo DirectoryServer.Move

Metodo DirectoryServerMove
Sposta o rinomina la cartella su server

Namespace: DedNet.Lib.DedIO
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void Move(
    string sourceDirName,
    string destDirName
)
Public Shared Sub Move (
    sourceDirName As String,
    destDirName As String
)
public:
static void Move(
    String^ sourceDirName,
    String^ destDirName
)
static member Move :
        sourceDirName : string *
        destDirName : string -> unit

Parametri

sourceDirName String
destDirName String
Vedi anche

Documentazione

Classe DirectoryServer
Namespace DedNet.Lib.DedIO


Classe File
FILE Classe switcher chiamate su File con firme identiche alla classe di IO nativa. Smista le chiamata su IO se client server non è attivo o per le chiamate locali, diversamente chiama FileServer.
Gerarchia di ereditarietà
SystemObject
DedNet.Lib.DedIOFile

Namespace: DedNet.Lib.DedIO
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class File
Public Class File
public ref class File
type File = class end

Il tipo File espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | File |
Torna su
Metodi
Nome | Descrizione
Copy | Copy
Delete | Delete
Exists | Exists
FileInfo | FileInfo
GetAttributes | GetAttributes
GetIcon | GetIcon
GetMd5Hash | GetMd5Hash
IsFileReadOnly | IsFileReadOnly
IsLocked | IsLocked
Move | Move
SetAttributes | SetAttributes
SetFileReadOnly | SetFileReadOnly
Torna su
Vedi anche

Documentazione

Namespace DedNet.Lib.DedIO


Costruttore File

Namespace: DedNet.Lib.DedIO
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public File()
Public Sub New
public:
File()
new : unit -> File
Vedi anche

Documentazione

Classe File
Namespace DedNet.Lib.DedIO


Metodi di File

Il tipo File espone i seguenti membri.

Metodi
Nome | Descrizione
Copy | Copy
Delete | Delete
Exists | Exists
FileInfo | FileInfo
GetAttributes | GetAttributes
GetIcon | GetIcon
GetMd5Hash | GetMd5Hash
IsFileReadOnly | IsFileReadOnly
IsLocked | IsLocked
Move | Move
SetAttributes | SetAttributes
SetFileReadOnly | SetFileReadOnly
Torna su
Vedi anche

Documentazione

Classe File
Namespace DedNet.Lib.DedIO


Metodo File.Copy

Metodo FileCopy
Copy

Namespace: DedNet.Lib.DedIO
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void Copy(
    string sourceFileName,
    string destFileName,
    bool overwrite = false
)
Public Shared Sub Copy (
    sourceFileName As String,
    destFileName As String,
    Optional overwrite As Boolean = false
)
public:
static void Copy(
    String^ sourceFileName,
    String^ destFileName,
    bool overwrite = false
)
static member Copy :
        sourceFileName : string *
        destFileName : string *
        ?overwrite : bool
(* Defaults:
        let _overwrite = defaultArg overwrite false
*)
-> unit

Parametri

sourceFileName String
destFileName String
overwrite Boolean (Optional)
Vedi anche

Documentazione

Classe File
Namespace DedNet.Lib.DedIO


Metodo File.Delete

Metodo FileDelete
Delete

Namespace: DedNet.Lib.DedIO
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void Delete(
    string path
)
Public Shared Sub Delete (
    path As String
)
public:
static void Delete(
    String^ path
)
static member Delete :
        path : string -> unit

Parametri

path String
Vedi anche

Documentazione

Classe File
Namespace DedNet.Lib.DedIO


Metodo File.Exists

Metodo FileExists
Exists

Namespace: DedNet.Lib.DedIO
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool Exists(
    string path
)
Public Shared Function Exists (
    path As String
) As Boolean
public:
static bool Exists(
    String^ path
)
static member Exists :
        path : string -> bool

Parametri

path String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe File
Namespace DedNet.Lib.DedIO


Metodo File.FileInfo

Metodo FileFileInfo
FileInfo

Namespace: DedNet.Lib.DedIO
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static FileInfoSerializable FileInfo(
    string path
)
Public Shared Function FileInfo (
    path As String
) As FileInfoSerializable
public:
static FileInfoSerializable^ FileInfo(
    String^ path
)
static member FileInfo :
        path : string -> FileInfoSerializable

Parametri

path String

Valore di ritorno

FileInfoSerializable
Vedi anche

Documentazione

Classe File
Namespace DedNet.Lib.DedIO


Metodo File.GetAttributes

Metodo FileGetAttributes
GetAttributes

Namespace: DedNet.Lib.DedIO
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static FileAttributes GetAttributes(
    string path
)
Public Shared Function GetAttributes (
    path As String
) As FileAttributes
public:
static FileAttributes GetAttributes(
    String^ path
)
static member GetAttributes :
        path : string -> FileAttributes

Parametri

path String

Valore di ritorno

FileAttributes
Vedi anche

Documentazione

Classe File
Namespace DedNet.Lib.DedIO


Metodo File.GetIcon

Metodo FileGetIcon
GetIcon

Namespace: DedNet.Lib.DedIO
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static Image GetIcon(
    string path,
    IconSizeType sizeType,
    Size itemSize
)
Public Shared Function GetIcon (
    path As String,
    sizeType As IconSizeType,
    itemSize As Size
) As Image
public:
static Image^ GetIcon(
    String^ path,
    IconSizeType^ sizeType,
    Size itemSize
)
static member GetIcon :
        path : string *
        sizeType : IconSizeType *
        itemSize : Size -> Image

Parametri

path String
sizeType IconSizeType
itemSize Size

Valore di ritorno

Image
Vedi anche

Documentazione

Classe File
Namespace DedNet.Lib.DedIO


Metodo File.GetMd5Hash

Metodo FileGetMd5Hash
GetMd5Hash

Namespace: DedNet.Lib.DedIO
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static Guid GetMd5Hash(
    string path
)
Public Shared Function GetMd5Hash (
    path As String
) As Guid
public:
static Guid GetMd5Hash(
    String^ path
)
static member GetMd5Hash :
        path : string -> Guid

Parametri

path String

Valore di ritorno

Guid
Vedi anche

Documentazione

Classe File
Namespace DedNet.Lib.DedIO


Metodo File.IsFileReadOnly

Metodo FileIsFileReadOnly
IsFileReadOnly

Namespace: DedNet.Lib.DedIO
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool IsFileReadOnly(
    string path
)
Public Shared Function IsFileReadOnly (
    path As String
) As Boolean
public:
static bool IsFileReadOnly(
    String^ path
)
static member IsFileReadOnly :
        path : string -> bool

Parametri

path String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe File
Namespace DedNet.Lib.DedIO


Metodo File.IsLocked

Metodo FileIsLocked
IsLocked

Namespace: DedNet.Lib.DedIO
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool IsLocked(
    string path
)
Public Shared Function IsLocked (
    path As String
) As Boolean
public:
static bool IsLocked(
    String^ path
)
static member IsLocked :
        path : string -> bool

Parametri

path String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe File
Namespace DedNet.Lib.DedIO


Metodo File.Move

Metodo FileMove
Move

Namespace: DedNet.Lib.DedIO
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void Move(
    string sourceFileName,
    string destFileName,
    bool ignoreNotFoundExcetion
)
Public Shared Sub Move (
    sourceFileName As String,
    destFileName As String,
    ignoreNotFoundExcetion As Boolean
)
public:
static void Move(
    String^ sourceFileName,
    String^ destFileName,
    bool ignoreNotFoundExcetion
)
static member Move :
        sourceFileName : string *
        destFileName : string *
        ignoreNotFoundExcetion : bool -> unit

Parametri

sourceFileName String
destFileName String
ignoreNotFoundExcetion Boolean
Vedi anche

Documentazione

Classe File
Namespace DedNet.Lib.DedIO


Metodo File.SetAttributes

Metodo FileSetAttributes
SetAttributes

Namespace: DedNet.Lib.DedIO
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void SetAttributes(
    string path,
    FileAttributes attributes
)
Public Shared Sub SetAttributes (
    path As String,
    attributes As FileAttributes
)
public:
static void SetAttributes(
    String^ path,
    FileAttributes attributes
)
static member SetAttributes :
        path : string *
        attributes : FileAttributes -> unit

Parametri

path String
attributes FileAttributes
Vedi anche

Documentazione

Classe File
Namespace DedNet.Lib.DedIO


Metodo File.SetFileReadOnly

Metodo FileSetFileReadOnly
SetFileReadOnly

Namespace: DedNet.Lib.DedIO
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool SetFileReadOnly(
    string path,
    bool readOnly
)
Public Shared Function SetFileReadOnly (
    path As String,
    readOnly As Boolean
) As Boolean
public:
static bool SetFileReadOnly(
    String^ path,
    bool readOnly
)
static member SetFileReadOnly :
        path : string *
        readOnly : bool -> bool

Parametri

path String
readOnly Boolean

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe File
Namespace DedNet.Lib.DedIO


Classe FileServer
FILESERVER Classe di interfacciamento chiamate client server per le chiamate su file
Gerarchia di ereditarietà
SystemObject
DedNet.Lib.DedIOFileServer

Namespace: DedNet.Lib.DedIO
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class FileServer
Public Class FileServer
public ref class FileServer
type FileServer = class end

Il tipo FileServer espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | FileServer |
Torna su
Metodi
Nome | Descrizione
Copy | Esegue una copia di file da server a server
Delete | Elimina un documento su server
Download | Esegue un downalod del file indicato sul server nella posizione locale
Exists | Controlla l'esistenza del file su server
FileInfo | Ritorna le informazioni del file indicato. Ritorna un oggetto serializzabile che contiene tutte le proprietà che ci interessano
GetMd5Hash | Ritorna del md5 del file indicato
IsLocked | Ritorna true se il file su server è bloccato e non apribile
IsReadOnly | Ritorna vero se il file su server è in sola lettura
Move | Sposta/rinomina un file da una posizione all'altra su server
SetFileAttributes | Settaggio attributi del file su server
SetReadOnly | Controlla lo stato di sola lettura del file su server
Upload | Esegue l'upload del file sorgente sul server. Utilizza lo stream per aumentare le prestazioni
Torna su
Vedi anche

Documentazione

Namespace DedNet.Lib.DedIO


Costruttore FileServer

Namespace: DedNet.Lib.DedIO
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public FileServer()
Public Sub New
public:
FileServer()
new : unit -> FileServer
Vedi anche

Documentazione

Classe FileServer
Namespace DedNet.Lib.DedIO


Metodi di FileServer

Il tipo FileServer espone i seguenti membri.

Metodi
Nome | Descrizione
Copy | Esegue una copia di file da server a server
Delete | Elimina un documento su server
Download | Esegue un downalod del file indicato sul server nella posizione locale
Exists | Controlla l'esistenza del file su server
FileInfo | Ritorna le informazioni del file indicato. Ritorna un oggetto serializzabile che contiene tutte le proprietà che ci interessano
GetMd5Hash | Ritorna del md5 del file indicato
IsLocked | Ritorna true se il file su server è bloccato e non apribile
IsReadOnly | Ritorna vero se il file su server è in sola lettura
Move | Sposta/rinomina un file da una posizione all'altra su server
SetFileAttributes | Settaggio attributi del file su server
SetReadOnly | Controlla lo stato di sola lettura del file su server
Upload | Esegue l'upload del file sorgente sul server. Utilizza lo stream per aumentare le prestazioni
Torna su
Vedi anche

Documentazione

Classe FileServer
Namespace DedNet.Lib.DedIO


Metodo FileServer.Copy

Metodo FileServerCopy
Esegue una copia di file da server a server

Namespace: DedNet.Lib.DedIO
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void Copy(
    string sourceFileName,
    string destFileName
)
Public Shared Sub Copy (
    sourceFileName As String,
    destFileName As String
)
public:
static void Copy(
    String^ sourceFileName,
    String^ destFileName
)
static member Copy :
        sourceFileName : string *
        destFileName : string -> unit

Parametri

sourceFileName String
destFileName String
Vedi anche

Documentazione

Classe FileServer
Namespace DedNet.Lib.DedIO


Metodo FileServer.Delete

Metodo FileServerDelete
Elimina un documento su server

Namespace: DedNet.Lib.DedIO
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void Delete(
    string path
)
Public Shared Sub Delete (
    path As String
)
public:
static void Delete(
    String^ path
)
static member Delete :
        path : string -> unit

Parametri

path String
Vedi anche

Documentazione

Classe FileServer
Namespace DedNet.Lib.DedIO


Metodo FileServer.Download

Metodo FileServerDownload
Esegue un downalod del file indicato sul server nella posizione locale

Namespace: DedNet.Lib.DedIO
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void Download(
    string sourceFileName,
    string destFileName
)
Public Shared Sub Download (
    sourceFileName As String,
    destFileName As String
)
public:
static void Download(
    String^ sourceFileName,
    String^ destFileName
)
static member Download :
        sourceFileName : string *
        destFileName : string -> unit

Parametri

sourceFileName String
destFileName String
Vedi anche

Documentazione

Classe FileServer
Namespace DedNet.Lib.DedIO


Metodo FileServer.Exists

Metodo FileServerExists
Controlla l'esistenza del file su server

Namespace: DedNet.Lib.DedIO
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool Exists(
    string path
)
Public Shared Function Exists (
    path As String
) As Boolean
public:
static bool Exists(
    String^ path
)
static member Exists :
        path : string -> bool

Parametri

path String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe FileServer
Namespace DedNet.Lib.DedIO


Metodo FileServer.FileInfo

Metodo FileServerFileInfo
Ritorna le informazioni del file indicato. Ritorna un oggetto serializzabile che contiene tutte le proprietà che ci interessano

Namespace: DedNet.Lib.DedIO
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static FileInfoSerializable FileInfo(
    string path
)
Public Shared Function FileInfo (
    path As String
) As FileInfoSerializable
public:
static FileInfoSerializable^ FileInfo(
    String^ path
)
static member FileInfo :
        path : string -> FileInfoSerializable

Parametri

path String

Valore di ritorno

FileInfoSerializable
Vedi anche

Documentazione

Classe FileServer
Namespace DedNet.Lib.DedIO


Metodo FileServer.GetMd5Hash

Metodo FileServerGetMd5Hash
Ritorna del md5 del file indicato

Namespace: DedNet.Lib.DedIO
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static Guid GetMd5Hash(
    string path
)
Public Shared Function GetMd5Hash (
    path As String
) As Guid
public:
static Guid GetMd5Hash(
    String^ path
)
static member GetMd5Hash :
        path : string -> Guid

Parametri

path String

Valore di ritorno

Guid
Vedi anche

Documentazione

Classe FileServer
Namespace DedNet.Lib.DedIO


Metodo FileServer.IsLocked

Metodo FileServerIsLocked
Ritorna true se il file su server è bloccato e non apribile

Namespace: DedNet.Lib.DedIO
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool IsLocked(
    string path
)
Public Shared Function IsLocked (
    path As String
) As Boolean
public:
static bool IsLocked(
    String^ path
)
static member IsLocked :
        path : string -> bool

Parametri

path String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe FileServer
Namespace DedNet.Lib.DedIO


Metodo FileServer.IsReadOnly

Metodo FileServerIsReadOnly
Ritorna vero se il file su server è in sola lettura

Namespace: DedNet.Lib.DedIO
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool IsReadOnly(
    string path
)
Public Shared Function IsReadOnly (
    path As String
) As Boolean
public:
static bool IsReadOnly(
    String^ path
)
static member IsReadOnly :
        path : string -> bool

Parametri

path String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe FileServer
Namespace DedNet.Lib.DedIO


Metodo FileServer.Move

Metodo FileServerMove
Sposta/rinomina un file da una posizione all'altra su server

Namespace: DedNet.Lib.DedIO
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void Move(
    string sourceFileName,
    string destFileName,
    bool ignoreNotFoundExcetion
)
Public Shared Sub Move (
    sourceFileName As String,
    destFileName As String,
    ignoreNotFoundExcetion As Boolean
)
public:
static void Move(
    String^ sourceFileName,
    String^ destFileName,
    bool ignoreNotFoundExcetion
)
static member Move :
        sourceFileName : string *
        destFileName : string *
        ignoreNotFoundExcetion : bool -> unit

Parametri

sourceFileName String
destFileName String
ignoreNotFoundExcetion Boolean
Vedi anche

Documentazione

Classe FileServer
Namespace DedNet.Lib.DedIO


Metodo FileServer.SetFileAttributes

Metodo FileServerSetFileAttributes
Settaggio attributi del file su server

Namespace: DedNet.Lib.DedIO
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool SetFileAttributes(
    string path,
    FileAttributes attributes
)
Public Shared Function SetFileAttributes (
    path As String,
    attributes As FileAttributes
) As Boolean
public:
static bool SetFileAttributes(
    String^ path,
    FileAttributes attributes
)
static member SetFileAttributes :
        path : string *
        attributes : FileAttributes -> bool

Parametri

path String
attributes FileAttributes

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe FileServer
Namespace DedNet.Lib.DedIO


Metodo FileServer.SetReadOnly

Metodo FileServerSetReadOnly
Controlla lo stato di sola lettura del file su server

Namespace: DedNet.Lib.DedIO
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool SetReadOnly(
    string path,
    bool readOnly
)
Public Shared Function SetReadOnly (
    path As String,
    readOnly As Boolean
) As Boolean
public:
static bool SetReadOnly(
    String^ path,
    bool readOnly
)
static member SetReadOnly :
        path : string *
        readOnly : bool -> bool

Parametri

path String
readOnly Boolean

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe FileServer
Namespace DedNet.Lib.DedIO


Metodo FileServer.Upload

Metodo FileServerUpload
Esegue l'upload del file sorgente sul server. Utilizza lo stream per aumentare le prestazioni

Namespace: DedNet.Lib.DedIO
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static void Upload(
    string sourceFileName,
    string destFileName
)
Public Shared Sub Upload (
    sourceFileName As String,
    destFileName As String
)
public:
static void Upload(
    String^ sourceFileName,
    String^ destFileName
)
static member Upload :
        sourceFileName : string *
        destFileName : string -> unit

Parametri

sourceFileName String
destFileName String
Vedi anche

Documentazione

Classe FileServer
Namespace DedNet.Lib.DedIO


Classe Path
PATH Classe per controlli specifici sui percorsi. Estende idealmente le funzionalità della classe nativa di IO
Gerarchia di ereditarietà
SystemObject
DedNet.Lib.DedIOPath

Namespace: DedNet.Lib.DedIO
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class Path
Public Class Path
public ref class Path
type Path = class end

Il tipo Path espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | Path |
Torna su
Metodi
Nome | Descrizione
Combine | Combine Se i due path sono entrambi di vault ritorna il path che include l'altro, altrimenti esegue un combine secco
IsVault | IsVault Se il percorso è rooted determina ch è di vault
Torna su
Vedi anche

Documentazione

Namespace DedNet.Lib.DedIO


Costruttore Path

Namespace: DedNet.Lib.DedIO
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Path()
Public Sub New
public:
Path()
new : unit -> Path
Vedi anche

Documentazione

Classe Path
Namespace DedNet.Lib.DedIO


Metodi di Path

Il tipo Path espone i seguenti membri.

Metodi
Nome | Descrizione
Combine | Combine Se i due path sono entrambi di vault ritorna il path che include l'altro, altrimenti esegue un combine secco
IsVault | IsVault Se il percorso è rooted determina ch è di vault
Torna su
Vedi anche

Documentazione

Classe Path
Namespace DedNet.Lib.DedIO


Metodo Path.Combine

Metodo PathCombine
Combine Se i due path sono entrambi di vault ritorna il path che include l'altro, altrimenti esegue un combine secco

Namespace: DedNet.Lib.DedIO
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string Combine(
    string path1,
    string path2
)
Public Shared Function Combine (
    path1 As String,
    path2 As String
) As String
public:
static String^ Combine(
    String^ path1,
    String^ path2
)
static member Combine :
        path1 : string *
        path2 : string -> string

Parametri

path1 String
path2 String

Valore di ritorno

String
Vedi anche

Documentazione

Classe Path
Namespace DedNet.Lib.DedIO


Metodo Path.IsVault

Metodo PathIsVault
IsVault Se il percorso è rooted determina ch è di vault

Namespace: DedNet.Lib.DedIO
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static bool IsVault(
    string path
)
Public Shared Function IsVault (
    path As String
) As Boolean
public:
static bool IsVault(
    String^ path
)
static member IsVault :
        path : string -> bool

Parametri

path String

Valore di ritorno

Boolean
Vedi anche

Documentazione

Classe Path
Namespace DedNet.Lib.DedIO


Classe Utils
UTILS Utilità specifiche per le operazioni di DedIO e server
Gerarchia di ereditarietà
SystemObject
DedNet.Lib.DedIOUtils

Namespace: DedNet.Lib.DedIO
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class Utils
Public Class Utils
public ref class Utils
type Utils = class end

Il tipo Utils espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | Utils |
Torna su
Metodi
Nome | Descrizione
GetBearerAuthHeader | Ritorna la stringa da utilizzare per la creazione del valore di autorizzazione Bearer da passare all'header
GetWrappedWebException | Ritorna l'eccezione wrappando l'eventuale eccezione interna lato server
Torna su
Vedi anche

Documentazione

Namespace DedNet.Lib.DedIO


Costruttore Utils

Namespace: DedNet.Lib.DedIO
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public Utils()
Public Sub New
public:
Utils()
new : unit -> Utils
Vedi anche

Documentazione

Classe Utils
Namespace DedNet.Lib.DedIO


Metodi di Utils

Il tipo Utils espone i seguenti membri.

Metodi
Nome | Descrizione
GetBearerAuthHeader | Ritorna la stringa da utilizzare per la creazione del valore di autorizzazione Bearer da passare all'header
GetWrappedWebException | Ritorna l'eccezione wrappando l'eventuale eccezione interna lato server
Torna su
Vedi anche

Documentazione

Classe Utils
Namespace DedNet.Lib.DedIO


Metodo Utils.GetBearerAuthHeader

Metodo UtilsGetBearerAuthHeader
Ritorna la stringa da utilizzare per la creazione del valore di autorizzazione Bearer da passare all'header

Namespace: DedNet.Lib.DedIO
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static string GetBearerAuthHeader(
    string token
)
Public Shared Function GetBearerAuthHeader (
    token As String
) As String
public:
static String^ GetBearerAuthHeader(
    String^ token
)
static member GetBearerAuthHeader :
        token : string -> string

Parametri

token String

Valore di ritorno

String
Vedi anche

Documentazione

Classe Utils
Namespace DedNet.Lib.DedIO


Metodo Utils.GetWrappedWebException

Metodo UtilsGetWrappedWebException
Ritorna l'eccezione wrappando l'eventuale eccezione interna lato server

Namespace: DedNet.Lib.DedIO
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public static Exception GetWrappedWebException(
    string methodName,
    Exception ex
)
Public Shared Function GetWrappedWebException (
    methodName As String,
    ex As Exception
) As Exception
public:
static Exception^ GetWrappedWebException(
    String^ methodName,
    Exception^ ex
)
static member GetWrappedWebException :
        methodName : string *
        ex : Exception -> Exception

Parametri

methodName String
ex Exception

Valore di ritorno

Exception
Vedi anche

Documentazione

Classe Utils
Namespace DedNet.Lib.DedIO


DedNet.NotifyForm Namespace
Classi
 | Classe | Descrizione
Classe pubblica | DedFormNotity | Classe per gestire le notifiche inviate via email.
Classe pubblica | DedNotifyComposer |


Classe DedFormNotity
Classe per gestire le notifiche inviate via email.
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.NotifyFormDedFormNotity

Namespace: DedNet.NotifyForm
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormNotity : BaseForm
Public Class DedFormNotity
    Inherits BaseForm
public ref class DedFormNotity : public BaseForm
type DedFormNotity =
    class
        inherit BaseForm
    end

Il tipo DedFormNotity espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormNotity | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.NotifyForm


Costruttore DedFormNotity
Costruttore unico.

Namespace: DedNet.NotifyForm
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormNotity(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedFormNotity(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedFormNotity

Parametri

app DedNetApplication
Applicazione DedNetApp.
Vedi anche

Documentazione

Classe DedFormNotity
Namespace DedNet.NotifyForm


Proprietà di DedFormNotity

Il tipo DedFormNotity espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormNotity
Namespace DedNet.NotifyForm


Metodi di DedFormNotity

Il tipo DedFormNotity espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormNotity
Namespace DedNet.NotifyForm


Metodo DedFormNotity.Dispose

Metodo DedFormNotityDispose
Clean up any resources being used.

Namespace: DedNet.NotifyForm
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormNotity
Namespace DedNet.NotifyForm


Eventi di DedFormNotity

Il tipo DedFormNotity espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormNotity
Namespace DedNet.NotifyForm


Campi di DedFormNotity

Il tipo DedFormNotity espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormNotity
Namespace DedNet.NotifyForm


Classe DedNotifyComposer
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.NotifyFormDedNotifyComposer

Namespace: DedNet.NotifyForm
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedNotifyComposer : BaseForm
Public Class DedNotifyComposer
    Inherits BaseForm
public ref class DedNotifyComposer : public BaseForm
type DedNotifyComposer =
    class
        inherit BaseForm
    end

Il tipo DedNotifyComposer espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNotifyComposer | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.NotifyForm


Costruttore DedNotifyComposer
Costruttore unico.

Namespace: DedNet.NotifyForm
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedNotifyComposer(
    DedNetApplication app,
    MemoEdit edit
)
Public Sub New (
    app As DedNetApplication,
    edit As MemoEdit
)
public:
DedNotifyComposer(
    DedNetApplication^ app,
    MemoEdit^ edit
)
new :
        app : DedNetApplication *
        edit : MemoEdit -> DedNotifyComposer

Parametri

app DedNetApplication
Applicazione DedNet.
edit MemoEdit
MemoEdit da cui prelevare/impostare il testo.
Vedi anche

Documentazione

Classe DedNotifyComposer
Namespace DedNet.NotifyForm


Proprietà di DedNotifyComposer

Il tipo DedNotifyComposer espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedNotifyComposer
Namespace DedNet.NotifyForm


Metodi di DedNotifyComposer

Il tipo DedNotifyComposer espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedNotifyComposer
Namespace DedNet.NotifyForm


Metodo DedNotifyComposer.Dispose

Metodo DedNotifyComposerDispose
Clean up any resources being used.

Namespace: DedNet.NotifyForm
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedNotifyComposer
Namespace DedNet.NotifyForm


Eventi di DedNotifyComposer

Il tipo DedNotifyComposer espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedNotifyComposer
Namespace DedNet.NotifyForm


Campi di DedNotifyComposer

Il tipo DedNotifyComposer espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedNotifyComposer
Namespace DedNet.NotifyForm


DedNet.QsManagerForm Namespace
Classi
 | Classe | Descrizione
Classe pubblica | DedFormAtt | Form per la creazione delle liste degli att.
Classe pubblica | DedFormComposeRule | Form per creare la singola regola. Per ricevere la regola appena composta bisogna registrarsi all'evento RuleComposed.
Classe pubblica | DedFormComposeRuleRuleComposeAdded | Contiene l'indicazione di momento esecuzione comando.
Classe pubblica | DedFormOptions |
Classe pubblica | DedRuleForm | Form per creare le ragole di autocomposizione.


Classe DedFormAtt
Form per la creazione delle liste degli att.
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.QsManagerFormDedFormAtt

Namespace: DedNet.QsManagerForm
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormAtt : BaseForm
Public Class DedFormAtt
    Inherits BaseForm
public ref class DedFormAtt : public BaseForm
type DedFormAtt =
    class
        inherit BaseForm
    end

Il tipo DedFormAtt espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormAtt | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà pubblica | SelectAttList | Restituisce o imposta la lista da preselezionare in apertura.
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.QsManagerForm


Costruttore DedFormAtt
Costruttore unico.

Namespace: DedNet.QsManagerForm
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormAtt(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedFormAtt(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedFormAtt

Parametri

app DedNetApplication
Applicazione di appartenenza.
Vedi anche

Documentazione

Classe DedFormAtt
Namespace DedNet.QsManagerForm


Proprietà di DedFormAtt

Il tipo DedFormAtt espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà pubblica | SelectAttList | Restituisce o imposta la lista da preselezionare in apertura.
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormAtt
Namespace DedNet.QsManagerForm


Proprietà DedFormAtt.SelectAttList

Proprietà DedFormAttSelectAttList
Restituisce o imposta la lista da preselezionare in apertura.

Namespace: DedNet.QsManagerForm
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string SelectAttList { get; set; }
Public Property SelectAttList As String
    Get
    Set
public:
property String^ SelectAttList {
    String^ get ();
    void set (String^ value);
}
member SelectAttList : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedFormAtt
Namespace DedNet.QsManagerForm


Metodi di DedFormAtt

Il tipo DedFormAtt espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormAtt
Namespace DedNet.QsManagerForm


Metodo DedFormAtt.Dispose

Metodo DedFormAttDispose
Clean up any resources being used.

Namespace: DedNet.QsManagerForm
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormAtt
Namespace DedNet.QsManagerForm


Eventi di DedFormAtt

Il tipo DedFormAtt espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormAtt
Namespace DedNet.QsManagerForm


Campi di DedFormAtt

Il tipo DedFormAtt espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormAtt
Namespace DedNet.QsManagerForm


Classe DedFormComposeRule
Form per creare la singola regola. Per ricevere la regola appena composta bisogna registrarsi all'evento RuleComposed.
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.QsManagerFormDedFormComposeRule

Namespace: DedNet.QsManagerForm
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormComposeRule : BaseForm
Public Class DedFormComposeRule
    Inherits BaseForm
public ref class DedFormComposeRule : public BaseForm
type DedFormComposeRule =
    class
        inherit BaseForm
    end

Il tipo DedFormComposeRule espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormComposeRule | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | AttrList | Attributi da visualizzare.
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà pubblica | Codifica | Indica se si tratta di una codifica di famiglia ( disabilita tutti i caratteri ).
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà pubblica | DisableProgr | Indica se disabilitare il progressivo nell'autocomposizione.
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Fam | Famiglia attualmente selezionata
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnRuleCompose | Lancia l'evento ShowMessageVaultPwsDocumentAlreadyOpen.
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Evento pubblico | RuleComposed |
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.QsManagerForm


Costruttore DedFormComposeRule
Costruttore unico.

Namespace: DedNet.QsManagerForm
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormComposeRule(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedFormComposeRule(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedFormComposeRule

Parametri

app DedNetApplication
Applicazione di appartenenza.
Vedi anche

Documentazione

Classe DedFormComposeRule
Namespace DedNet.QsManagerForm


Proprietà di DedFormComposeRule

Il tipo DedFormComposeRule espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | AttrList | Attributi da visualizzare.
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà pubblica | Codifica | Indica se si tratta di una codifica di famiglia ( disabilita tutti i caratteri ).
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà pubblica | DisableProgr | Indica se disabilitare il progressivo nell'autocomposizione.
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Fam | Famiglia attualmente selezionata
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormComposeRule
Namespace DedNet.QsManagerForm


Proprietà DedFormComposeRule.AttrList

Proprietà DedFormComposeRuleAttrList
Attributi da visualizzare.

Namespace: DedNet.QsManagerForm
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList AttrList { get; set; }
Public Property AttrList As DedAttrList
    Get
    Set
public:
property DedAttrList^ AttrList {
    DedAttrList^ get ();
    void set (DedAttrList^ value);
}
member AttrList : DedAttrList with get, set

Valore della proprietà

DedAttrList
Vedi anche

Documentazione

Classe DedFormComposeRule
Namespace DedNet.QsManagerForm


Proprietà DedFormComposeRule.Codifica

Proprietà DedFormComposeRuleCodifica
Indica se si tratta di una codifica di famiglia ( disabilita tutti i caratteri ).

Namespace: DedNet.QsManagerForm
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool Codifica { get; set; }
Public Property Codifica As Boolean
    Get
    Set
public:
property bool Codifica {
    bool get ();
    void set (bool value);
}
member Codifica : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormComposeRule
Namespace DedNet.QsManagerForm


Proprietà DedFormComposeRule.DisableProgr

Proprietà DedFormComposeRuleDisableProgr
Indica se disabilitare il progressivo nell'autocomposizione.

Namespace: DedNet.QsManagerForm
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool DisableProgr { get; set; }
Public Property DisableProgr As Boolean
    Get
    Set
public:
property bool DisableProgr {
    bool get ();
    void set (bool value);
}
member DisableProgr : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormComposeRule
Namespace DedNet.QsManagerForm


Proprietà DedFormComposeRule.Fam

Proprietà DedFormComposeRuleFam
Famiglia attualmente selezionata

Namespace: DedNet.QsManagerForm
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeBase Fam { get; set; }
Public Property Fam As DedTypeBase
    Get
    Set
public:
property DedTypeBase^ Fam {
    DedTypeBase^ get ();
    void set (DedTypeBase^ value);
}
member Fam : DedTypeBase with get, set

Valore della proprietà

DedTypeBase
Vedi anche

Documentazione

Classe DedFormComposeRule
Namespace DedNet.QsManagerForm


Metodi di DedFormComposeRule

Il tipo DedFormComposeRule espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnRuleCompose | Lancia l'evento ShowMessageVaultPwsDocumentAlreadyOpen.
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormComposeRule
Namespace DedNet.QsManagerForm


Metodo DedFormComposeRule.Dispose

Metodo DedFormComposeRuleDispose
Clean up any resources being used.

Namespace: DedNet.QsManagerForm
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormComposeRule
Namespace DedNet.QsManagerForm


Metodo DedFormComposeRule.OnRuleCompose

Metodo DedFormComposeRuleOnRuleCompose
Lancia l'evento ShowMessageVaultPwsDocumentAlreadyOpen.

Namespace: DedNet.QsManagerForm
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnRuleCompose(
    DedFormComposeRuleRuleComposeAdded e
)
Protected Friend Sub OnRuleCompose (
    e As DedFormComposeRuleRuleComposeAdded
)
protected public:
void OnRuleCompose(
    DedFormComposeRuleRuleComposeAdded^ e
)
member OnRuleCompose :
        e : DedFormComposeRuleRuleComposeAdded -> unit

Parametri

e DedFormComposeRuleRuleComposeAdded
Argomento DocumentVaultPwsEventArgs.
Vedi anche

Documentazione

Classe DedFormComposeRule
Namespace DedNet.QsManagerForm


Eventi di DedFormComposeRule

Il tipo DedFormComposeRule espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Evento pubblico | RuleComposed |
Torna su
Vedi anche

Documentazione

Classe DedFormComposeRule
Namespace DedNet.QsManagerForm


Evento DedFormComposeRule.RuleComposed

Evento DedFormComposeRuleRuleComposed

Namespace: DedNet.QsManagerForm
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DedFormComposeRuleRuleComposeAdded> RuleComposed
Public Event RuleComposed As EventHandler(Of DedFormComposeRuleRuleComposeAdded)
public:
 event EventHandler<DedFormComposeRuleRuleComposeAdded^>^ RuleComposed {
    void add (EventHandler<DedFormComposeRuleRuleComposeAdded^>^ value);
    void remove (EventHandler<DedFormComposeRuleRuleComposeAdded^>^ value);
}
member RuleComposed : IEvent<EventHandler<DedFormComposeRuleRuleComposeAdded>,
    DedFormComposeRuleRuleComposeAdded>

Valore

EventHandler DedFormComposeRuleRuleComposeAdded
Vedi anche

Documentazione

Classe DedFormComposeRule
Namespace DedNet.QsManagerForm


Campi di DedFormComposeRule

Il tipo DedFormComposeRule espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormComposeRule
Namespace DedNet.QsManagerForm


Classe DedFormComposeRule.RuleComposeAdded

Classe DedFormComposeRuleRuleComposeAdded
Contiene l'indicazione di momento esecuzione comando.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNet.QsManagerFormDedFormComposeRuleRuleComposeAdded

Namespace: DedNet.QsManagerForm
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class RuleComposeAdded : EventArgs
Public Class RuleComposeAdded
    Inherits EventArgs
public ref class RuleComposeAdded : public EventArgs
type RuleComposeAdded =
    class
        inherit EventArgs
    end

Il tipo DedFormComposeRuleRuleComposeAdded espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormComposeRuleRuleComposeAdded |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | RuleAdded |
Torna su
Vedi anche

Documentazione

Namespace DedNet.QsManagerForm


Costruttore DedFormComposeRule.RuleComposeAdded

Costruttore DedFormComposeRuleRuleComposeAdded

Namespace: DedNet.QsManagerForm
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public RuleComposeAdded()
Public Sub New
public:
RuleComposeAdded()
new : unit -> RuleComposeAdded
Vedi anche

Documentazione

Classe DedFormComposeRuleRuleComposeAdded
Namespace DedNet.QsManagerForm


Proprietà di RuleComposeAdded

Il tipo DedFormComposeRuleRuleComposeAdded espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | RuleAdded |
Torna su
Vedi anche

Documentazione

Classe DedFormComposeRuleRuleComposeAdded
Namespace DedNet.QsManagerForm


Proprietà DedFormComposeRule.RuleComposeAdded.RuleAdded

Proprietà DedFormComposeRuleRuleComposeAddedRuleAdded

Namespace: DedNet.QsManagerForm
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public string RuleAdded { get; set; }
Public Property RuleAdded As String
    Get
    Set
public:
property String^ RuleAdded {
    String^ get ();
    void set (String^ value);
}
member RuleAdded : string with get, set

Valore della proprietà

String
Vedi anche

Documentazione

Classe DedFormComposeRuleRuleComposeAdded
Namespace DedNet.QsManagerForm


Classe DedFormOptions
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.QsManagerFormDedFormOptions

Namespace: DedNet.QsManagerForm
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedFormOptions : BaseForm
Public Class DedFormOptions
    Inherits BaseForm
public ref class DedFormOptions : public BaseForm
type DedFormOptions =
    class
        inherit BaseForm
    end

Il tipo DedFormOptions espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedFormOptions | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | EnableDragNoButton | Imposta/restituisce se abilitare il drag senza ctrl/shift
Proprietà pubblica | EqualIntenalName | Imposta/restituisce se di default mettere nome interno uguale al prompt.
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.QsManagerForm


Costruttore DedFormOptions
Costruttore unico.

Namespace: DedNet.QsManagerForm
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedFormOptions(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedFormOptions(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedFormOptions

Parametri

app DedNetApplication
Applicazione di appatenenza.
Vedi anche

Documentazione

Classe DedFormOptions
Namespace DedNet.QsManagerForm


Proprietà di DedFormOptions

Il tipo DedFormOptions espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | EnableDragNoButton | Imposta/restituisce se abilitare il drag senza ctrl/shift
Proprietà pubblica | EqualIntenalName | Imposta/restituisce se di default mettere nome interno uguale al prompt.
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormOptions
Namespace DedNet.QsManagerForm


Proprietà DedFormOptions.EnableDragNoButton

Proprietà DedFormOptionsEnableDragNoButton
Imposta/restituisce se abilitare il drag senza ctrl/shift

Namespace: DedNet.QsManagerForm
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool EnableDragNoButton { get; set; }
Public Property EnableDragNoButton As Boolean
    Get
    Set
public:
property bool EnableDragNoButton {
    bool get ();
    void set (bool value);
}
member EnableDragNoButton : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormOptions
Namespace DedNet.QsManagerForm


Proprietà DedFormOptions.EqualIntenalName

Proprietà DedFormOptionsEqualIntenalName
Imposta/restituisce se di default mettere nome interno uguale al prompt.

Namespace: DedNet.QsManagerForm
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public bool EqualIntenalName { get; set; }
Public Property EqualIntenalName As Boolean
    Get
    Set
public:
property bool EqualIntenalName {
    bool get ();
    void set (bool value);
}
member EqualIntenalName : bool with get, set

Valore della proprietà

Boolean
Vedi anche

Documentazione

Classe DedFormOptions
Namespace DedNet.QsManagerForm


Metodi di DedFormOptions

Il tipo DedFormOptions espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormOptions
Namespace DedNet.QsManagerForm


Metodo DedFormOptions.Dispose

Metodo DedFormOptionsDispose
Clean up any resources being used.

Namespace: DedNet.QsManagerForm
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedFormOptions
Namespace DedNet.QsManagerForm


Eventi di DedFormOptions

Il tipo DedFormOptions espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormOptions
Namespace DedNet.QsManagerForm


Campi di DedFormOptions

Il tipo DedFormOptions espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedFormOptions
Namespace DedNet.QsManagerForm


Classe DedRuleForm
Form per creare le ragole di autocomposizione.
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
DedNet.FormsBaseForm
DedNet.QsManagerFormDedRuleForm

Namespace: DedNet.QsManagerForm
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public class DedRuleForm : BaseForm
Public Class DedRuleForm
    Inherits BaseForm
public ref class DedRuleForm : public BaseForm
type DedRuleForm =
    class
        inherit BaseForm
    end

Il tipo DedRuleForm espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedRuleForm |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà pubblica | ContextList | Contiene la lista degli attributi disponibili nella combo box del campo nome Attributo.
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Fam |
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MenuList | Contiene la lista degli attributi disponibili nel menu a tendina per creare la regola
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | RuleObject | Restituisce o imposta l'oggetto FamilyRule che è stato creato o che è da editare.
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Namespace DedNet.QsManagerForm


Costruttore DedRuleForm

Namespace: DedNet.QsManagerForm
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedRuleForm(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedRuleForm(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedRuleForm

Parametri

app DedNetApplication
Vedi anche

Documentazione

Classe DedRuleForm
Namespace DedNet.QsManagerForm


Proprietà di DedRuleForm

Il tipo DedRuleForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm)
Proprietà pubblica | Appearance | (Ereditato da XtraForm)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm)
Proprietà pubblica | BackColor | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm)
Proprietà pubblica | ContextList | Contiene la lista degli attributi disponibili nella combo box del campo nome Attributo.
Proprietà protetta | CreateParams | (Ereditato da XtraForm)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm)
Proprietà protetta | DXAccessible | (Ereditato da XtraForm)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm)
Proprietà pubblica | Fam |
Proprietà pubblica | Font | (Ereditato da XtraForm)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm)
Proprietà protetta | FormPainter | (Ereditato da XtraForm)
Proprietà protetta | FormShadow | (Ereditato da XtraForm)
Proprietà protetta | HasHtmlTemplate | (Ereditato da XtraForm)
Proprietà protetta | Helper | (Ereditato da XtraForm)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm)
Proprietà pubblica | Icon | (Ereditato da XtraForm)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm)
Proprietà protetta | IsActive | (Ereditato da XtraForm)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm)
Proprietà pubblica | MenuList | Contiene la lista degli attributi disponibili nel menu a tendina per creare la regola
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm)
Proprietà pubblica | RuleObject | Restituisce o imposta l'oggetto FamilyRule che è stato creato o che è da editare.
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Proprietà protetta | ShowMode | (Ereditato da XtraForm)
Proprietà pubblica | Site | (Ereditato da XtraForm)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm)
Proprietà pubblica | SurfaceMaterial | (Ereditato da XtraForm)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm)
Proprietà pubblica | Text | (Ereditato da XtraForm)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm)
Proprietà protetta | UseFormShadow | (Ereditato da XtraForm)
Proprietà protetta | UseFormShowHelper | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedRuleForm
Namespace DedNet.QsManagerForm


Proprietà DedRuleForm.ContextList

Proprietà DedRuleFormContextList
Contiene la lista degli attributi disponibili nella combo box del campo nome Attributo.

Namespace: DedNet.QsManagerForm
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList ContextList { get; set; }
Public Property ContextList As DedAttrList
    Get
    Set
public:
property DedAttrList^ ContextList {
    DedAttrList^ get ();
    void set (DedAttrList^ value);
}
member ContextList : DedAttrList with get, set

Valore della proprietà

DedAttrList
Vedi anche

Documentazione

Classe DedRuleForm
Namespace DedNet.QsManagerForm


Proprietà DedRuleForm.Fam

Proprietà DedRuleFormFam

Namespace: DedNet.QsManagerForm
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedTypeBase Fam { get; set; }
Public Property Fam As DedTypeBase
    Get
    Set
public:
property DedTypeBase^ Fam {
    DedTypeBase^ get ();
    void set (DedTypeBase^ value);
}
member Fam : DedTypeBase with get, set

Valore della proprietà

DedTypeBase
Vedi anche

Documentazione

Classe DedRuleForm
Namespace DedNet.QsManagerForm


Proprietà DedRuleForm.MenuList

Proprietà DedRuleFormMenuList
Contiene la lista degli attributi disponibili nel menu a tendina per creare la regola

Namespace: DedNet.QsManagerForm
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedAttrList MenuList { get; set; }
Public Property MenuList As DedAttrList
    Get
    Set
public:
property DedAttrList^ MenuList {
    DedAttrList^ get ();
    void set (DedAttrList^ value);
}
member MenuList : DedAttrList with get, set

Valore della proprietà

DedAttrList
Vedi anche

Documentazione

Classe DedRuleForm
Namespace DedNet.QsManagerForm


Proprietà DedRuleForm.RuleObject

Proprietà DedRuleFormRuleObject
Restituisce o imposta l'oggetto FamilyRule che è stato creato o che è da editare.

Namespace: DedNet.QsManagerForm
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
public DedRule RuleObject { get; set; }
Public Property RuleObject As DedRule
    Get
    Set
public:
property DedRule^ RuleObject {
    DedRule^ get ();
    void set (DedRule^ value);
}
member RuleObject : DedRule with get, set

Valore della proprietà

DedRule
Vedi anche

Documentazione

Classe DedRuleForm
Namespace DedNet.QsManagerForm


Metodi di DedRuleForm

Il tipo DedRuleForm espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm)
Metodo protetto | CheckRestoredWindowSize | (Ereditato da XtraForm)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibilityInstance | (Ereditato da XtraForm)
Metodo protetto | CreateAccessibleInstance | (Ereditato da XtraForm)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm)
Metodo protetto | CreateHandle | (Ereditato da XtraForm)
Metodo protetto | CreateHelper | (Ereditato da XtraForm)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseFormDispose(Boolean))
Metodo protetto | DoDpiChange | (Ereditato da XtraForm)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm)
Metodo protetto | GetAllowRoundedWindowCorners | (Ereditato da DForm)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm)
Metodo protetto | GetCaptionSkinElement | (Ereditato da XtraForm)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm)
Metodo protetto | GetStandardAccessibleObject | (Ereditato da DForm)
Metodo protetto | GetSurfaceMaterial | (Ereditato da XtraForm)
Metodo protetto | GetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | InitCore | (Ereditato da XtraForm)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported | (Ereditato da XtraForm)
Metodo protetto | IsSurfaceMaterialSupported(SurfaceMaterial) | (Ereditato da XtraForm)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm)
Metodo protetto | OnLayout | (Ereditato da XtraForm)
Metodo protetto | OnLoad | (Ereditato da XtraForm)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm)
Metodo protetto | OnPaint | (Ereditato da XtraForm)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm)
Metodo protetto | OnShown | (Ereditato da XtraForm)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm)
Metodo protetto | OnSurfaceMaterialChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm)
Metodo protetto | ScaleControl | (Ereditato da XtraForm)
Metodo protetto | ScaleCore | (Ereditato da XtraForm)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm)
Metodo protetto | SetWindowCornerMode | (Ereditato da DForm)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm)
Metodo protetto | WndProc | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedRuleForm
Namespace DedNet.QsManagerForm


Metodo DedRuleForm.Dispose

Metodo DedRuleFormDispose
Clean up any resources being used.

Namespace: DedNet.QsManagerForm
Assembly: DedNet (in DedNet.dll) Versione: 27.1.0
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing Boolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedRuleForm
Namespace DedNet.QsManagerForm


Eventi di DedRuleForm

Il tipo DedRuleForm espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedRuleForm
Namespace DedNet.QsManagerForm


Campi di DedRuleForm

Il tipo DedRuleForm espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm)
Campo protetto | formBounds | (Ereditato da XtraForm)
Campo protetto | isFormPainted | (Ereditato da XtraForm)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm)
Campo protetto | prevFormBounds | (Ereditato da XtraForm)
Torna su
Vedi anche

Documentazione

Classe DedRuleForm
Namespace DedNet.QsManagerForm